BoldSqlNodeMaker Namespace

Enterprise Core Objects
BoldSqlNodeMaker Namespace
Classes
Collapse All

This is namespace BoldSqlNodeMaker.

Classes
Name | Description
TBoldSqlNodeMaker | TBoldSqlNodeMaker
Top
What do you think about this topic? Send feedback!
Copyright (c) 2007-2009. All rights reserved.


TBoldSqlNodeMaker Class

TBoldSqlNodeMaker Class
Inheritance Hierarchy See Also
Collapse All
C#
public class TBoldSqlNodeMaker : TBoldOLWNodeVisitor;
Remarks

TBoldSqlNodeMaker

Inheritance Hierarchy
BoldSqlNodeMaker.TBoldSqlNodeMaker
File

BoldSqlNodeMaker.cs

See Also
Inheritance Hierarchy


TBoldSqlNodeMaker.TBoldSqlNodeMaker Constructor

TBoldSqlNodeMaker.TBoldSqlNodeMaker Constructor
TBoldSqlNodeMaker Class BoldSqlNodeMaker Namespace See Also
Collapse All
C#
public TBoldSqlNodeMaker(
    TBoldOclCondition Condition
);
Remarks

This is TBoldSqlNodeMaker, a member of class TBoldSqlNodeMaker.

See Also
TBoldSqlNodeMaker Class
BoldSqlNodeMaker Namespace


TBoldSqlNodeMaker Methods

TBoldSqlNodeMaker Methods
Public Methods
Collapse All

The methods of the TBoldSqlNodeMaker class are listed here.

Public Methods
Name | Description
Execute | This is Execute, a member of class TBoldSqlNodeMaker.
SQLBindingForVarBinding | This is SQLBindingForVarBinding, a member of class TBoldSqlNodeMaker.
VisitTBoldOLWDateLiteral | This is VisitTBoldOLWDateLiteral, a member of class TBoldSqlNodeMaker.
VisitTBoldOLWEnumLiteral | This is VisitTBoldOLWEnumLiteral, a member of class TBoldSqlNodeMaker.
VisitTBoldOLWFloatLiteral | This is VisitTBoldOLWFloatLiteral, a member of class TBoldSqlNodeMaker.
VisitTBoldOLWIntLiteral | This is VisitTBoldOLWIntLiteral, a member of class TBoldSqlNodeMaker.
VisitTBoldOLWIteration | This is VisitTBoldOLWIteration, a member of class TBoldSqlNodeMaker.
VisitTBoldOLWListCoercion | This is VisitTBoldOLWListCoercion, a member of class TBoldSqlNodeMaker.
VisitTBoldOLWLiteral | This is VisitTBoldOLWLiteral, a member of class TBoldSqlNodeMaker.
VisitTBoldOLWMember | This is VisitTBoldOLWMember, a member of class TBoldSqlNodeMaker.
VisitTBoldOLWNode | This is VisitTBoldOLWNode, a member of class TBoldSqlNodeMaker.
VisitTBoldOLWOperation | This is VisitTBoldOLWOperation, a member of class TBoldSqlNodeMaker.
VisitTBoldOLWStrLiteral | This is VisitTBoldOLWStrLiteral, a member of class TBoldSqlNodeMaker.
VisitTBoldOLWTimeLiteral | This is VisitTBoldOLWTimeLiteral, a member of class TBoldSqlNodeMaker.
VisitTBoldOLWTypeNode | This is VisitTBoldOLWTypeNode, a member of class TBoldSqlNodeMaker.
VisitTBoldOLWVariableBinding | This is VisitTBoldOLWVariableBinding, a member of class TBoldSqlNodeMaker.
VisitTBoldOLWVariableReference | This is VisitTBoldOLWVariableReference, a member of class TBoldSqlNodeMaker.


TBoldSqlNodeMaker.Execute Method

TBoldSqlNodeMaker.Execute Method
TBoldSqlNodeMaker Class BoldSqlNodeMaker Namespace See Also
Collapse All
C#
public void Execute();
Remarks

This is Execute, a member of class TBoldSqlNodeMaker.

See Also
TBoldSqlNodeMaker Class
BoldSqlNodeMaker Namespace


TBoldSqlNodeMaker.SQLBindingForVarBinding Method

TBoldSqlNodeMaker.SQLBindingForVarBinding Method
TBoldSqlNodeMaker Class BoldSqlNodeMaker Namespace See Also
Collapse All
C#
public TBoldSqlVariableBinding SQLBindingForVarBinding(
    TBoldOLWVariableBinding VarBinding
);
Remarks

This is SQLBindingForVarBinding, a member of class TBoldSqlNodeMaker.

See Also
TBoldSqlNodeMaker Class
BoldSqlNodeMaker Namespace


TBoldSqlNodeMaker.VisitTBoldOLWDateLiteral Method

TBoldSqlNodeMaker.VisitTBoldOLWDateLiteral Method
TBoldSqlNodeMaker Class BoldSqlNodeMaker Namespace See Also
Collapse All
C#
public override void VisitTBoldOLWDateLiteral(
    TBoldOLWDateLiteral N
);
Remarks

This is VisitTBoldOLWDateLiteral, a member of class TBoldSqlNodeMaker.

See Also
TBoldSqlNodeMaker Class
BoldSqlNodeMaker Namespace


TBoldSqlNodeMaker.VisitTBoldOLWEnumLiteral Method

TBoldSqlNodeMaker.VisitTBoldOLWEnumLiteral Method
TBoldSqlNodeMaker Class BoldSqlNodeMaker Namespace See Also
Collapse All
C#
public override void VisitTBoldOLWEnumLiteral(
    TBoldOLWEnumLiteral N
);
Remarks

This is VisitTBoldOLWEnumLiteral, a member of class TBoldSqlNodeMaker.

See Also
TBoldSqlNodeMaker Class
BoldSqlNodeMaker Namespace


TBoldSqlNodeMaker.VisitTBoldOLWFloatLiteral Method

TBoldSqlNodeMaker.VisitTBoldOLWFloatLiteral Method
TBoldSqlNodeMaker Class BoldSqlNodeMaker Namespace See Also
Collapse All
C#
public override void VisitTBoldOLWFloatLiteral(
    TBoldOLWFloatLiteral N
);
Remarks

This is VisitTBoldOLWFloatLiteral, a member of class TBoldSqlNodeMaker.

See Also
TBoldSqlNodeMaker Class
BoldSqlNodeMaker Namespace


TBoldSqlNodeMaker.VisitTBoldOLWIntLiteral Method

TBoldSqlNodeMaker.VisitTBoldOLWIntLiteral Method
TBoldSqlNodeMaker Class BoldSqlNodeMaker Namespace See Also
Collapse All
C#
public override void VisitTBoldOLWIntLiteral(
    TBoldOLWIntLiteral N
);
Remarks

This is VisitTBoldOLWIntLiteral, a member of class TBoldSqlNodeMaker.

See Also
TBoldSqlNodeMaker Class
BoldSqlNodeMaker Namespace


TBoldSqlNodeMaker.VisitTBoldOLWIteration Method

TBoldSqlNodeMaker.VisitTBoldOLWIteration Method
TBoldSqlNodeMaker Class BoldSqlNodeMaker Namespace See Also
Collapse All
C#
public override void VisitTBoldOLWIteration(
    TBoldOLWIteration N
);
Remarks

This is VisitTBoldOLWIteration, a member of class TBoldSqlNodeMaker.

See Also
TBoldSqlNodeMaker Class
BoldSqlNodeMaker Namespace


TBoldSqlNodeMaker.VisitTBoldOLWListCoercion Method

TBoldSqlNodeMaker.VisitTBoldOLWListCoercion Method
TBoldSqlNodeMaker Class BoldSqlNodeMaker Namespace See Also
Collapse All
C#
public override void VisitTBoldOLWListCoercion(
    TBoldOLWListCoercion N
);
Remarks

This is VisitTBoldOLWListCoercion, a member of class TBoldSqlNodeMaker.

See Also
TBoldSqlNodeMaker Class
BoldSqlNodeMaker Namespace


TBoldSqlNodeMaker.VisitTBoldOLWLiteral Method

TBoldSqlNodeMaker.VisitTBoldOLWLiteral Method
TBoldSqlNodeMaker Class BoldSqlNodeMaker Namespace See Also
Collapse All
C#
public override void VisitTBoldOLWLiteral(
    TBoldOLWLiteral N
);
Remarks

This is VisitTBoldOLWLiteral, a member of class TBoldSqlNodeMaker.

See Also
TBoldSqlNodeMaker Class
BoldSqlNodeMaker Namespace


TBoldSqlNodeMaker.VisitTBoldOLWMember Method

TBoldSqlNodeMaker.VisitTBoldOLWMember Method
TBoldSqlNodeMaker Class BoldSqlNodeMaker Namespace See Also
Collapse All
C#
public override void VisitTBoldOLWMember(
    TBoldOLWMember N
);
Remarks

This is VisitTBoldOLWMember, a member of class TBoldSqlNodeMaker.

See Also
TBoldSqlNodeMaker Class
BoldSqlNodeMaker Namespace


TBoldSqlNodeMaker.VisitTBoldOLWNode Method

TBoldSqlNodeMaker.VisitTBoldOLWNode Method
TBoldSqlNodeMaker Class BoldSqlNodeMaker Namespace See Also
Collapse All
C#
public override void VisitTBoldOLWNode(
    TBoldOLWNode N
);
Remarks

This is VisitTBoldOLWNode, a member of class TBoldSqlNodeMaker.

See Also
TBoldSqlNodeMaker Class
BoldSqlNodeMaker Namespace


TBoldSqlNodeMaker.VisitTBoldOLWOperation Method

TBoldSqlNodeMaker.VisitTBoldOLWOperation Method
TBoldSqlNodeMaker Class BoldSqlNodeMaker Namespace See Also
Collapse All
C#
public override void VisitTBoldOLWOperation(
    TBoldOLWOperation N
);
Remarks

This is VisitTBoldOLWOperation, a member of class TBoldSqlNodeMaker.

See Also
TBoldSqlNodeMaker Class
BoldSqlNodeMaker Namespace


TBoldSqlNodeMaker.VisitTBoldOLWStrLiteral Method

TBoldSqlNodeMaker.VisitTBoldOLWStrLiteral Method
TBoldSqlNodeMaker Class BoldSqlNodeMaker Namespace See Also
Collapse All
C#
public override void VisitTBoldOLWStrLiteral(
    TBoldOLWStrLiteral N
);
Remarks

This is VisitTBoldOLWStrLiteral, a member of class TBoldSqlNodeMaker.

See Also
TBoldSqlNodeMaker Class
BoldSqlNodeMaker Namespace


TBoldSqlNodeMaker.VisitTBoldOLWTimeLiteral Method

TBoldSqlNodeMaker.VisitTBoldOLWTimeLiteral Method
TBoldSqlNodeMaker Class BoldSqlNodeMaker Namespace See Also
Collapse All
C#
public override void VisitTBoldOLWTimeLiteral(
    TBoldOLWTimeLiteral N
);
Remarks

This is VisitTBoldOLWTimeLiteral, a member of class TBoldSqlNodeMaker.

See Also
TBoldSqlNodeMaker Class
BoldSqlNodeMaker Namespace


TBoldSqlNodeMaker.VisitTBoldOLWTypeNode Method

TBoldSqlNodeMaker.VisitTBoldOLWTypeNode Method
TBoldSqlNodeMaker Class BoldSqlNodeMaker Namespace See Also
Collapse All
C#
public override void VisitTBoldOLWTypeNode(
    TBoldOLWTypeNode N
);
Remarks

This is VisitTBoldOLWTypeNode, a member of class TBoldSqlNodeMaker.

See Also
TBoldSqlNodeMaker Class
BoldSqlNodeMaker Namespace


TBoldSqlNodeMaker.VisitTBoldOLWVariableBinding Method

TBoldSqlNodeMaker.VisitTBoldOLWVariableBinding Method
TBoldSqlNodeMaker Class BoldSqlNodeMaker Namespace See Also
Collapse All
C#
public override void VisitTBoldOLWVariableBinding(
    TBoldOLWVariableBinding N
);
Remarks

This is VisitTBoldOLWVariableBinding, a member of class TBoldSqlNodeMaker.

See Also
TBoldSqlNodeMaker Class
BoldSqlNodeMaker Namespace


TBoldSqlNodeMaker.VisitTBoldOLWVariableReference Method

TBoldSqlNodeMaker.VisitTBoldOLWVariableReference Method
TBoldSqlNodeMaker Class BoldSqlNodeMaker Namespace See Also
Collapse All
C#
public override void VisitTBoldOLWVariableReference(
    TBoldOLWVariableReference N
);
Remarks

This is VisitTBoldOLWVariableReference, a member of class TBoldSqlNodeMaker.

See Also
TBoldSqlNodeMaker Class
BoldSqlNodeMaker Namespace


TBoldSqlNodeMaker Properties

TBoldSqlNodeMaker Properties
Public Properties
Collapse All

The properties of the TBoldSqlNodeMaker class are listed here.

Public Properties
Name | Description
OLWVarBindings | This is OLWVarBindings, a member of class TBoldSqlNodeMaker.
RootNode | This is RootNode, a member of class TBoldSqlNodeMaker.
SQLVarBindings | This is SQLVarBindings, a member of class TBoldSqlNodeMaker.


TBoldSqlNodeMaker.OLWVarBindings Property

TBoldSqlNodeMaker.OLWVarBindings Property
TBoldSqlNodeMaker Class BoldSqlNodeMaker Namespace See Also
Collapse All
C#
public TBoldOLWNodeList OLWVarBindings;
Remarks

This is OLWVarBindings, a member of class TBoldSqlNodeMaker.

See Also
TBoldSqlNodeMaker Class
BoldSqlNodeMaker Namespace


TBoldSqlNodeMaker.RootNode Property

TBoldSqlNodeMaker.RootNode Property
TBoldSqlNodeMaker Class BoldSqlNodeMaker Namespace See Also
Collapse All
C#
public TBoldSqlNode RootNode;
Remarks

This is RootNode, a member of class TBoldSqlNodeMaker.

See Also
TBoldSqlNodeMaker Class
BoldSqlNodeMaker Namespace


TBoldSqlNodeMaker.SQLVarBindings Property

TBoldSqlNodeMaker.SQLVarBindings Property
TBoldSqlNodeMaker Class BoldSqlNodeMaker Namespace See Also
Collapse All
C#
public TBoldSqlNodeList SQLVarBindings;
Remarks

This is SQLVarBindings, a member of class TBoldSqlNodeMaker.

See Also
TBoldSqlNodeMaker Class
BoldSqlNodeMaker Namespace


BoldSqlNodes Namespace

BoldSqlNodes Namespace
Classes
Collapse All

This is namespace BoldSqlNodes.

Classes
Name | Description
TBoldSqlDateLiteral | end TBoldSqlStrLiteral
TBoldSqlEnumLiteral | end TBoldSqlIntLiteral
TBoldSqlFloatLiteral | end TBoldSqlTimeLiteral
TBoldSqlIntLiteral | end TBoldSqlFloatLiteral
TBoldSqlIteration | end TBoldSqlOperation
TBoldSqlListCoercion | end TBoldSqlTypeNode
TBoldSqlLiteral | end TBoldSqlVariableReference
TBoldSqlMember | end TBoldSqlIteration
TBoldSqlNode | TBoldSqlNode
TBoldSqlNodeList | TBoldSqlNodeList
TBoldSqlNodeVisitor | TBoldSqlNodeVisitor
TBoldSqlOperation | end TBoldSqlListCoercion
TBoldSqlStrLiteral | end TBoldSqlLiteral
TBoldSqlSymbol | end TBoldSqlNodeList
TBoldSqlTimeLiteral | end TBoldSqlDateLiteral
TBoldSqlTypeNode | end TBoldSqlNode
TBoldSqlVariableBinding | end TBoldSqlMember
TBoldSqlVariableReference | end TBoldSqlVariableBinding
TBoldSQLWCFVariable | end TBoldSqlNodeVisitor


TBoldSqlDateLiteral Class

TBoldSqlDateLiteral Class
Inheritance Hierarchy See Also
Collapse All
C#
public class TBoldSqlDateLiteral : TBoldSqlLiteral;
Remarks

end TBoldSqlStrLiteral

Inheritance Hierarchy
BoldSqlNodes.TBoldSqlNode
    BoldSqlNodes.TBoldSqlLiteral
        BoldSqlNodes.TBoldSqlDateLiteral
File

BoldSqlNodes.cs

See Also
Inheritance Hierarchy


TBoldSqlDateLiteral.TBoldSqlDateLiteral Constructor

TBoldSqlDateLiteral.TBoldSqlDateLiteral Constructor
TBoldSqlDateLiteral Class BoldSqlNodes Namespace See Also
Collapse All
C#
public TBoldSqlDateLiteral(
    int Position,
    DateTime DateValue
);
Remarks

Constructor Create( Position, DateValue)

See Also
TBoldSqlDateLiteral Class
BoldSqlNodes Namespace


TBoldSqlDateLiteral Methods

TBoldSqlDateLiteral Methods
Public Methods
Collapse All

The methods of the TBoldSqlDateLiteral class are listed here.

Public Methods
Name | Description
AcceptVisitor | <- END (HK) TBoldSqlDateLiteral


TBoldSqlDateLiteral.AcceptVisitor Method

TBoldSqlDateLiteral.AcceptVisitor Method
TBoldSqlDateLiteral Class BoldSqlNodes Namespace See Also
Collapse All
C#
public override void AcceptVisitor(
    TBoldSqlNodeVisitor V
);
Remarks

<- END (HK) TBoldSqlDateLiteral

See Also
TBoldSqlDateLiteral Class
BoldSqlNodes Namespace


TBoldSqlDateLiteral Properties

TBoldSqlDateLiteral Properties
Public Properties
Collapse All

The properties of the TBoldSqlDateLiteral class are listed here.

Public Properties
Name | Description
DateValue | This is DateValue, a member of class TBoldSqlDateLiteral.


TBoldSqlDateLiteral.DateValue Property

TBoldSqlDateLiteral.DateValue Property
TBoldSqlDateLiteral Class BoldSqlNodes Namespace See Also
Collapse All
C#
public DateTime DateValue;
Remarks

This is DateValue, a member of class TBoldSqlDateLiteral.

See Also
TBoldSqlDateLiteral Class
BoldSqlNodes Namespace


TBoldSqlEnumLiteral Class

TBoldSqlEnumLiteral Class
Inheritance Hierarchy See Also
Collapse All
C#
public class TBoldSqlEnumLiteral : TBoldSqlLiteral;
Remarks

end TBoldSqlIntLiteral

Inheritance Hierarchy
BoldSqlNodes.TBoldSqlNode
    BoldSqlNodes.TBoldSqlLiteral
        BoldSqlNodes.TBoldSqlEnumLiteral
File

BoldSqlNodes.cs

See Also
Inheritance Hierarchy


TBoldSqlEnumLiteral.TBoldSqlEnumLiteral Constructor

TBoldSqlEnumLiteral.TBoldSqlEnumLiteral Constructor
TBoldSqlEnumLiteral Class BoldSqlNodes Namespace See Also
Collapse All
C#
public TBoldSqlEnumLiteral(
    int Position,
    int IntValue
);
Remarks

Constructor Create( Position, IntValue)

See Also
TBoldSqlEnumLiteral Class
BoldSqlNodes Namespace


TBoldSqlEnumLiteral Methods

TBoldSqlEnumLiteral Methods
Public Methods
Collapse All

The methods of the TBoldSqlEnumLiteral class are listed here.

Public Methods
Name | Description
AcceptVisitor | TBoldSqlEnumLiteral


TBoldSqlEnumLiteral.AcceptVisitor Method

TBoldSqlEnumLiteral.AcceptVisitor Method
TBoldSqlEnumLiteral Class BoldSqlNodes Namespace See Also
Collapse All
C#
public override void AcceptVisitor(
    TBoldSqlNodeVisitor V
);
Remarks

TBoldSqlEnumLiteral

See Also
TBoldSqlEnumLiteral Class
BoldSqlNodes Namespace


TBoldSqlEnumLiteral Properties

TBoldSqlEnumLiteral Properties
Public Properties
Collapse All

The properties of the TBoldSqlEnumLiteral class are listed here.

Public Properties
Name | Description
Intvalue | This is Intvalue, a member of class TBoldSqlEnumLiteral.


TBoldSqlEnumLiteral.Intvalue Property

TBoldSqlEnumLiteral.Intvalue Property
TBoldSqlEnumLiteral Class BoldSqlNodes Namespace See Also
Collapse All
C#
public int Intvalue;
Remarks

This is Intvalue, a member of class TBoldSqlEnumLiteral.

See Also
TBoldSqlEnumLiteral Class
BoldSqlNodes Namespace


TBoldSqlFloatLiteral Class

TBoldSqlFloatLiteral Class
Inheritance Hierarchy See Also
Collapse All
C#
public class TBoldSqlFloatLiteral : TBoldSqlLiteral;
Remarks

end TBoldSqlTimeLiteral

Inheritance Hierarchy
BoldSqlNodes.TBoldSqlNode
    BoldSqlNodes.TBoldSqlLiteral
        BoldSqlNodes.TBoldSqlFloatLiteral
File

BoldSqlNodes.cs

See Also
Inheritance Hierarchy


TBoldSqlFloatLiteral.TBoldSqlFloatLiteral Constructor

TBoldSqlFloatLiteral.TBoldSqlFloatLiteral Constructor
TBoldSqlFloatLiteral Class BoldSqlNodes Namespace See Also
Collapse All
C#
public TBoldSqlFloatLiteral(
    int Position,
    double FloatValue
);
Remarks

Constructor Create( Position, FloatValue)

See Also
TBoldSqlFloatLiteral Class
BoldSqlNodes Namespace


TBoldSqlFloatLiteral Methods

TBoldSqlFloatLiteral Methods
Public Methods
Collapse All

The methods of the TBoldSqlFloatLiteral class are listed here.

Public Methods
Name | Description
AcceptVisitor | TBoldSqlFloatLiteral


TBoldSqlFloatLiteral.AcceptVisitor Method

TBoldSqlFloatLiteral.AcceptVisitor Method
TBoldSqlFloatLiteral Class BoldSqlNodes Namespace See Also
Collapse All
C#
public override void AcceptVisitor(
    TBoldSqlNodeVisitor V
);
Remarks

TBoldSqlFloatLiteral

See Also
TBoldSqlFloatLiteral Class
BoldSqlNodes Namespace


TBoldSqlFloatLiteral Properties

TBoldSqlFloatLiteral Properties
Public Properties
Collapse All

The properties of the TBoldSqlFloatLiteral class are listed here.

Public Properties
Name | Description
FloatValue | This is FloatValue, a member of class TBoldSqlFloatLiteral.


TBoldSqlFloatLiteral.FloatValue Property

TBoldSqlFloatLiteral.FloatValue Property
TBoldSqlFloatLiteral Class BoldSqlNodes Namespace See Also
Collapse All
C#
public double FloatValue;
Remarks

This is FloatValue, a member of class TBoldSqlFloatLiteral.

See Also
TBoldSqlFloatLiteral Class
BoldSqlNodes Namespace


TBoldSqlIntLiteral Class

TBoldSqlIntLiteral Class
Inheritance Hierarchy See Also
Collapse All
C#
public class TBoldSqlIntLiteral : TBoldSqlLiteral;
Remarks

end TBoldSqlFloatLiteral

Inheritance Hierarchy
BoldSqlNodes.TBoldSqlNode
    BoldSqlNodes.TBoldSqlLiteral
        BoldSqlNodes.TBoldSqlIntLiteral
File

BoldSqlNodes.cs

See Also
Inheritance Hierarchy


TBoldSqlIntLiteral.TBoldSqlIntLiteral Constructor

TBoldSqlIntLiteral.TBoldSqlIntLiteral Constructor
TBoldSqlIntLiteral Class BoldSqlNodes Namespace See Also
Collapse All
C#
public TBoldSqlIntLiteral(
    int Position,
    int IntValue
);
Remarks

Constructor Create( Position, IntValue)

See Also
TBoldSqlIntLiteral Class
BoldSqlNodes Namespace


TBoldSqlIntLiteral Methods

TBoldSqlIntLiteral Methods
Public Methods
Collapse All

The methods of the TBoldSqlIntLiteral class are listed here.

Public Methods
Name | Description
AcceptVisitor | TBoldSqlIntLiteral


TBoldSqlIntLiteral.AcceptVisitor Method

TBoldSqlIntLiteral.AcceptVisitor Method
TBoldSqlIntLiteral Class BoldSqlNodes Namespace See Also
Collapse All
C#
public override void AcceptVisitor(
    TBoldSqlNodeVisitor V
);
Remarks

TBoldSqlIntLiteral

See Also
TBoldSqlIntLiteral Class
BoldSqlNodes Namespace


TBoldSqlIntLiteral Properties

TBoldSqlIntLiteral Properties
Public Properties
Collapse All

The properties of the TBoldSqlIntLiteral class are listed here.

Public Properties
Name | Description
IntValue | This is IntValue, a member of class TBoldSqlIntLiteral.


TBoldSqlIntLiteral.IntValue Property

TBoldSqlIntLiteral.IntValue Property
TBoldSqlIntLiteral Class BoldSqlNodes Namespace See Also
Collapse All
C#
public int IntValue;
Remarks

This is IntValue, a member of class TBoldSqlIntLiteral.

See Also
TBoldSqlIntLiteral Class
BoldSqlNodes Namespace


TBoldSqlIteration Class

TBoldSqlIteration Class
Inheritance Hierarchy See Also
Collapse All
C#
public class TBoldSqlIteration : TBoldSqlOperation;
Remarks

end TBoldSqlOperation

Inheritance Hierarchy
BoldSqlNodes.TBoldSqlNode
    BoldSqlNodes.TBoldSqlOperation
        BoldSqlNodes.TBoldSqlIteration
File

BoldSqlNodes.cs

See Also
Inheritance Hierarchy


TBoldSqlIteration.TBoldSqlIteration Constructor

TBoldSqlIteration.TBoldSqlIteration Constructor
TBoldSqlIteration Class BoldSqlNodes Namespace See Also
Collapse All
C#
public TBoldSqlIteration(
    int Position,
    string OperationName,
    TBoldSqlVariableBinding LoopVar
);
Remarks

Constructor Create( Position, OperationName, LoopVar)

See Also
TBoldSqlIteration Class
BoldSqlNodes Namespace


TBoldSqlIteration Methods

TBoldSqlIteration Methods
Public Methods
Collapse All

The methods of the TBoldSqlIteration class are listed here.

Public Methods
Name | Description
AcceptVisitor | TBoldSqlIteration
AliasReferenceForAlias | This is AliasReferenceForAlias, a member of class TBoldSqlIteration.


TBoldSqlIteration.AcceptVisitor Method

TBoldSqlIteration.AcceptVisitor Method
TBoldSqlIteration Class BoldSqlNodes Namespace See Also
Collapse All
C#
public override void AcceptVisitor(
    TBoldSqlNodeVisitor V
);
Remarks

TBoldSqlIteration

See Also
TBoldSqlIteration Class
BoldSqlNodes Namespace


TBoldSqlIteration.AliasReferenceForAlias Method

TBoldSqlIteration.AliasReferenceForAlias Method
TBoldSqlIteration Class BoldSqlNodes Namespace See Also
Collapse All
C#
public override TBoldSQLAliasReference AliasReferenceForAlias(
    AliasDefinition Alias,
    TBoldSQLQuery Query,
    bool ForceOwntable
);
Remarks

This is AliasReferenceForAlias, a member of class TBoldSqlIteration.

See Also
TBoldSqlIteration Class
BoldSqlNodes Namespace


TBoldSqlIteration Properties

TBoldSqlIteration Properties
Public Properties
Collapse All

The properties of the TBoldSqlIteration class are listed here.

Public Properties
Name | Description
LoopVar | This is LoopVar, a member of class TBoldSqlIteration.


TBoldSqlIteration.LoopVar Property

TBoldSqlIteration.LoopVar Property
TBoldSqlIteration Class BoldSqlNodes Namespace See Also
Collapse All
C#
public TBoldSqlVariableBinding LoopVar;
Remarks

This is LoopVar, a member of class TBoldSqlIteration.

See Also
TBoldSqlIteration Class
BoldSqlNodes Namespace


TBoldSqlListCoercion Class

TBoldSqlListCoercion Class
Inheritance Hierarchy See Also
Collapse All
C#
public class TBoldSqlListCoercion : TBoldSqlNode;
Remarks

end TBoldSqlTypeNode

Inheritance Hierarchy
BoldSqlNodes.TBoldSqlNode
    BoldSqlNodes.TBoldSqlListCoercion
File

BoldSqlNodes.cs

See Also
Inheritance Hierarchy


TBoldSqlListCoercion.TBoldSqlListCoercion Constructor

TBoldSqlListCoercion.TBoldSqlListCoercion Constructor
TBoldSqlListCoercion Class BoldSqlNodes Namespace See Also
Collapse All
C#
public TBoldSqlListCoercion(
    int Position,
    TBoldSqlNode Child
);
Remarks

Constructor Create( Position, Child)

See Also
TBoldSqlListCoercion Class
BoldSqlNodes Namespace


TBoldSqlListCoercion Methods

TBoldSqlListCoercion Methods
Public Methods
Collapse All

The methods of the TBoldSqlListCoercion class are listed here.

Public Methods
Name | Description
AcceptVisitor | <- End (HK) TBoldOCLListCoercion


TBoldSqlListCoercion.AcceptVisitor Method

TBoldSqlListCoercion.AcceptVisitor Method
TBoldSqlListCoercion Class BoldSqlNodes Namespace See Also
Collapse All
C#
public override void AcceptVisitor(
    TBoldSqlNodeVisitor V
);
Remarks

<- End (HK) TBoldOCLListCoercion

See Also
TBoldSqlListCoercion Class
BoldSqlNodes Namespace


TBoldSqlListCoercion Properties

TBoldSqlListCoercion Properties
Public Properties
Collapse All

The properties of the TBoldSqlListCoercion class are listed here.

Public Properties
Name | Description
Child | This is Child, a member of class TBoldSqlListCoercion.


TBoldSqlListCoercion.Child Property

TBoldSqlListCoercion.Child Property
TBoldSqlListCoercion Class BoldSqlNodes Namespace See Also
Collapse All
C#
public TBoldSqlNode Child;
Remarks

This is Child, a member of class TBoldSqlListCoercion.

See Also
TBoldSqlListCoercion Class
BoldSqlNodes Namespace


TBoldSqlLiteral Class

TBoldSqlLiteral Class
Inheritance Hierarchy See Also
Collapse All
C#
public class TBoldSqlLiteral : TBoldSqlNode;
Remarks

end TBoldSqlVariableReference

Inheritance Hierarchy
BoldSqlNodes.TBoldSqlNode
    BoldSqlNodes.TBoldSqlLiteral
        BoldSqlNodes.TBoldSqlDateLiteral
        BoldSqlNodes.TBoldSqlEnumLiteral
        BoldSqlNodes.TBoldSqlFloatLiteral
        BoldSqlNodes.TBoldSqlIntLiteral
        BoldSqlNodes.TBoldSqlStrLiteral
        BoldSqlNodes.TBoldSqlTimeLiteral
File

BoldSqlNodes.cs

See Also
Inheritance Hierarchy


TBoldSqlLiteral.TBoldSqlLiteral Constructor

TBoldSqlLiteral.TBoldSqlLiteral Constructor
TBoldSqlLiteral Class BoldSqlNodes Namespace See Also
Collapse All
C#
public TBoldSqlLiteral(
    int Position
);
Remarks

Constructors

See Also
TBoldSqlLiteral Class
BoldSqlNodes Namespace


TBoldSqlLiteral Methods

TBoldSqlLiteral Methods
Public Methods
Collapse All

The methods of the TBoldSqlLiteral class are listed here.

Public Methods
Name | Description
AcceptVisitor | TBoldSqlLiteral


TBoldSqlLiteral.AcceptVisitor Method

TBoldSqlLiteral.AcceptVisitor Method
TBoldSqlLiteral Class BoldSqlNodes Namespace See Also
Collapse All
C#
public override void AcceptVisitor(
    TBoldSqlNodeVisitor V
);
Remarks

TBoldSqlLiteral

See Also
TBoldSqlLiteral Class
BoldSqlNodes Namespace


TBoldSqlMember Class

TBoldSqlMember Class
Inheritance Hierarchy See Also
Collapse All
C#
public class TBoldSqlMember : TBoldSqlNode;
Remarks

end TBoldSqlIteration

Inheritance Hierarchy
BoldSqlNodes.TBoldSqlNode
    BoldSqlNodes.TBoldSqlMember
File

BoldSqlNodes.cs

See Also
Inheritance Hierarchy


TBoldSqlMember.TBoldSqlMember Constructor

TBoldSqlMember.TBoldSqlMember Constructor
TBoldSqlMember Class BoldSqlNodes Namespace See Also
Collapse All
C#
public TBoldSqlMember(
    int Position,
    string memberName,
    int MemberIndex,
    TBoldSqlNode MemberOf,
    bool IsBoolean
);
Remarks

Constructor Create( Position, memberName, MemberIndex, MemberOf, IsBoolean)

See Also
TBoldSqlMember Class
BoldSqlNodes Namespace


TBoldSqlMember Methods

TBoldSqlMember Methods
Public Methods
Collapse All

The methods of the TBoldSqlMember class are listed here.

Public Methods
Name | Description
AcceptVisitor | TBoldSqlMember
AliasReferenceForAlias | This is AliasReferenceForAlias, a member of class TBoldSqlMember.
QueryOfMemberOfIsEnclosing | This is QueryOfMemberOfIsEnclosing, a member of class TBoldSqlMember.


TBoldSqlMember.AcceptVisitor Method

TBoldSqlMember.AcceptVisitor Method
TBoldSqlMember Class BoldSqlNodes Namespace See Also
Collapse All
C#
public override void AcceptVisitor(
    TBoldSqlNodeVisitor V
);
Remarks

TBoldSqlMember

See Also
TBoldSqlMember Class
BoldSqlNodes Namespace


TBoldSqlMember.AliasReferenceForAlias Method

TBoldSqlMember.AliasReferenceForAlias Method
TBoldSqlMember Class BoldSqlNodes Namespace See Also
Collapse All
C#
public override TBoldSQLAliasReference AliasReferenceForAlias(
    AliasDefinition Alias,
    TBoldSQLQuery Query,
    bool ForceOwntable
);
Remarks

This is AliasReferenceForAlias, a member of class TBoldSqlMember.

See Also
TBoldSqlMember Class
BoldSqlNodes Namespace


TBoldSqlMember.QueryOfMemberOfIsEnclosing Method

TBoldSqlMember.QueryOfMemberOfIsEnclosing Method
TBoldSqlMember Class BoldSqlNodes Namespace See Also
Collapse All
C#
public bool QueryOfMemberOfIsEnclosing();
Remarks

This is QueryOfMemberOfIsEnclosing, a member of class TBoldSqlMember.

See Also
TBoldSqlMember Class
BoldSqlNodes Namespace


TBoldSqlMember Properties

TBoldSqlMember Properties
Public Properties
Collapse All

The properties of the TBoldSqlMember class are listed here.

Public Properties
Name | Description
IsBoolean | This is IsBoolean, a member of class TBoldSqlMember.
MemberIndex | This is MemberIndex, a member of class TBoldSqlMember.
MemberMapper | This is MemberMapper, a member of class TBoldSqlMember.
MemberName | This is MemberName, a member of class TBoldSqlMember.
MemberOf | This is MemberOf, a member of class TBoldSqlMember.
Qualifier | This is Qualifier, a member of class TBoldSqlMember.


TBoldSqlMember.IsBoolean Property

TBoldSqlMember.IsBoolean Property
TBoldSqlMember Class BoldSqlNodes Namespace See Also
Collapse All
C#
public bool IsBoolean;
Remarks

This is IsBoolean, a member of class TBoldSqlMember.

See Also
TBoldSqlMember Class
BoldSqlNodes Namespace


TBoldSqlMember.MemberIndex Property

TBoldSqlMember.MemberIndex Property
TBoldSqlMember Class BoldSqlNodes Namespace See Also
Collapse All
C#
public int MemberIndex;
Remarks

This is MemberIndex, a member of class TBoldSqlMember.

See Also
TBoldSqlMember Class
BoldSqlNodes Namespace


TBoldSqlMember.MemberMapper Property

TBoldSqlMember.MemberMapper Property
TBoldSqlMember Class BoldSqlNodes Namespace See Also
Collapse All
C#
public TBoldMemberPersistenceMapper MemberMapper;
Remarks

This is MemberMapper, a member of class TBoldSqlMember.

See Also
TBoldSqlMember Class
BoldSqlNodes Namespace


TBoldSqlMember.MemberName Property

TBoldSqlMember.MemberName Property
TBoldSqlMember Class BoldSqlNodes Namespace See Also
Collapse All
C#
public string MemberName;
Remarks

This is MemberName, a member of class TBoldSqlMember.

See Also
TBoldSqlMember Class
BoldSqlNodes Namespace


TBoldSqlMember.MemberOf Property

TBoldSqlMember.MemberOf Property
TBoldSqlMember Class BoldSqlNodes Namespace See Also
Collapse All
C#
public TBoldSqlNode MemberOf;
Remarks

This is MemberOf, a member of class TBoldSqlMember.

See Also
TBoldSqlMember Class
BoldSqlNodes Namespace


TBoldSqlMember.Qualifier Property

TBoldSqlMember.Qualifier Property
TBoldSqlMember Class BoldSqlNodes Namespace See Also
Collapse All
C#
public TBoldSqlNodeList Qualifier;
Remarks

This is Qualifier, a member of class TBoldSqlMember.

See Also
TBoldSqlMember Class
BoldSqlNodes Namespace


TBoldSqlNode Class

TBoldSqlNode Class
Inheritance Hierarchy See Also
Collapse All
C#
public class TBoldSqlNode;
Remarks

TBoldSqlNode

Inheritance Hierarchy
BoldSqlNodes.TBoldSqlNode
    BoldSqlNodes.TBoldSqlListCoercion
    BoldSqlNodes.TBoldSqlLiteral
    BoldSqlNodes.TBoldSqlMember
    BoldSqlNodes.TBoldSqlOperation
    BoldSqlNodes.TBoldSqlTypeNode
    BoldSqlNodes.TBoldSqlVariableBinding
    BoldSqlNodes.TBoldSqlVariableReference
File

BoldSqlNodes.cs

See Also
Inheritance Hierarchy


TBoldSqlNode.TBoldSqlNode Constructor

TBoldSqlNode.TBoldSqlNode Constructor
TBoldSqlNode Class BoldSqlNodes Namespace See Also
Collapse All
C#
public TBoldSqlNode(
    int Position
);
Remarks

Constructor Create( Position)

See Also
TBoldSqlNode Class
BoldSqlNodes Namespace


TBoldSqlNode Methods

TBoldSqlNode Methods
Public Methods
Collapse All

The methods of the TBoldSqlNode class are listed here.

Public Methods
Name | Description
AcceptVisitor | TBoldSqlNode
AliasReferenceForAlias | This is AliasReferenceForAlias, a member of class TBoldSqlNode.
AliasReferenceForAlias_ObjectMapperContainsAlias | TypeColRefWCF: TBoldSqlWCF; TypeIDWCF: TBoldSqlWCF; TypeColRef: TBoldSQLColumnReference; TypeWCF: TBoldSqlWCF;
CopyAliasReferences | This is CopyAliasReferences, a member of class TBoldSqlNode.
EnsureRetrievalOfMainColumns | This is EnsureRetrievalOfMainColumns, a member of class TBoldSqlNode.
MainAliasRef | This is MainAliasRef, a member of class TBoldSqlNode.
NewQuery | This is NewQuery, a member of class TBoldSqlNode.
RelinquishQuery | This is RelinquishQuery, a member of class TBoldSqlNode.
RelinquishWCF | This is RelinquishWCF, a member of class TBoldSqlNode.


TBoldSqlNode.AcceptVisitor Method

TBoldSqlNode.AcceptVisitor Method
TBoldSqlNode Class BoldSqlNodes Namespace See Also
Collapse All
C#
public virtual void AcceptVisitor(
    TBoldSqlNodeVisitor V
);
Remarks

TBoldSqlNode

See Also
TBoldSqlNode Class
BoldSqlNodes Namespace


TBoldSqlNode.AliasReferenceForAlias Method

TBoldSqlNode.AliasReferenceForAlias Method
TBoldSqlNode Class BoldSqlNodes Namespace See Also
Collapse All
C#
public virtual TBoldSQLAliasReference AliasReferenceForAlias(
    AliasDefinition Alias,
    TBoldSQLQuery Query,
    bool ForceOwntable
);
Remarks

This is AliasReferenceForAlias, a member of class TBoldSqlNode.

See Also
TBoldSqlNode Class
BoldSqlNodes Namespace


TBoldSqlNode.AliasReferenceForAlias_ObjectMapperContainsAlias Method

TBoldSqlNode.AliasReferenceForAlias_ObjectMapperContainsAlias Method
TBoldSqlNode Class BoldSqlNodes Namespace See Also
Collapse All
C#
public bool AliasReferenceForAlias_ObjectMapperContainsAlias(
    ClassPersistenceMapper mapper,
    AliasDefinition Alias
);
Remarks

TypeColRefWCF: TBoldSqlWCF; TypeIDWCF: TBoldSqlWCF; TypeColRef: TBoldSQLColumnReference; TypeWCF: TBoldSqlWCF;

See Also
TBoldSqlNode Class
BoldSqlNodes Namespace


TBoldSqlNode.CopyAliasReferences Method

TBoldSqlNode.CopyAliasReferences Method
TBoldSqlNode Class BoldSqlNodes Namespace See Also
Collapse All
C#
public void CopyAliasReferences(
    TBoldSqlNode node
);
Remarks

This is CopyAliasReferences, a member of class TBoldSqlNode.

See Also
TBoldSqlNode Class
BoldSqlNodes Namespace


TBoldSqlNode.EnsureRetrievalOfMainColumns Method

TBoldSqlNode.EnsureRetrievalOfMainColumns Method
TBoldSqlNode Class BoldSqlNodes Namespace See Also
Collapse All
C#
public void EnsureRetrievalOfMainColumns();
Remarks

This is EnsureRetrievalOfMainColumns, a member of class TBoldSqlNode.

See Also
TBoldSqlNode Class
BoldSqlNodes Namespace


TBoldSqlNode.MainAliasRef Method

TBoldSqlNode.MainAliasRef Method
TBoldSqlNode Class BoldSqlNodes Namespace See Also
Collapse All
C#
public TBoldSQLAliasReference MainAliasRef(
    TBoldSQLQuery Query
);
Remarks

This is MainAliasRef, a member of class TBoldSqlNode.

See Also
TBoldSqlNode Class
BoldSqlNodes Namespace


TBoldSqlNode.NewQuery Method

TBoldSqlNode.NewQuery Method
TBoldSqlNode Class BoldSqlNodes Namespace See Also
Collapse All
C#
public void NewQuery(
    TBoldSQLNameSpace __NameSpace
);
Remarks

This is NewQuery, a member of class TBoldSqlNode.

See Also
TBoldSqlNode Class
BoldSqlNodes Namespace


TBoldSqlNode.RelinquishQuery Method

TBoldSqlNode.RelinquishQuery Method
TBoldSqlNode Class BoldSqlNodes Namespace See Also
Collapse All
C#
public virtual TBoldSQLQuery RelinquishQuery();
Remarks

This is RelinquishQuery, a member of class TBoldSqlNode.

See Also
TBoldSqlNode Class
BoldSqlNodes Namespace


TBoldSqlNode.RelinquishWCF Method

TBoldSqlNode.RelinquishWCF Method
TBoldSqlNode Class BoldSqlNodes Namespace See Also
Collapse All
C#
public virtual TBoldSqlWCF RelinquishWCF();
Remarks

This is RelinquishWCF, a member of class TBoldSqlNode.

See Also
TBoldSqlNode Class
BoldSqlNodes Namespace


TBoldSqlNode Properties

TBoldSqlNode Properties
Public Properties
Collapse All

The properties of the TBoldSqlNode class are listed here.

Public Properties
Name | Description
HasObjectMapper | This is HasObjectMapper, a member of class TBoldSqlNode.
HasQuery | This is HasQuery, a member of class TBoldSqlNode.
ObjectMapper | This is ObjectMapper, a member of class TBoldSqlNode.
Position | This is Position, a member of class TBoldSqlNode.
Query | This is Query, a member of class TBoldSqlNode.
WCF | This is WCF, a member of class TBoldSqlNode.


TBoldSqlNode.HasObjectMapper Property

TBoldSqlNode.HasObjectMapper Property
TBoldSqlNode Class BoldSqlNodes Namespace See Also
Collapse All
C#
public bool HasObjectMapper;
Remarks

This is HasObjectMapper, a member of class TBoldSqlNode.

See Also
TBoldSqlNode Class
BoldSqlNodes Namespace


TBoldSqlNode.HasQuery Property

TBoldSqlNode.HasQuery Property
TBoldSqlNode Class BoldSqlNodes Namespace See Also
Collapse All
C#
public bool HasQuery;
Remarks

This is HasQuery, a member of class TBoldSqlNode.

See Also
TBoldSqlNode Class
BoldSqlNodes Namespace


TBoldSqlNode.ObjectMapper Property

TBoldSqlNode.ObjectMapper Property
TBoldSqlNode Class BoldSqlNodes Namespace See Also
Collapse All
C#
public virtual ClassPersistenceMapper ObjectMapper;
Remarks

This is ObjectMapper, a member of class TBoldSqlNode.

See Also
TBoldSqlNode Class
BoldSqlNodes Namespace


TBoldSqlNode.Position Property

TBoldSqlNode.Position Property
TBoldSqlNode Class BoldSqlNodes Namespace See Also
Collapse All
C#
public int Position;
Remarks

This is Position, a member of class TBoldSqlNode.

See Also
TBoldSqlNode Class
BoldSqlNodes Namespace


TBoldSqlNode.Query Property

TBoldSqlNode.Query Property
TBoldSqlNode Class BoldSqlNodes Namespace See Also
Collapse All
C#
public virtual TBoldSQLQuery Query;
Remarks

This is Query, a member of class TBoldSqlNode.

See Also
TBoldSqlNode Class
BoldSqlNodes Namespace


TBoldSqlNode.WCF Property

TBoldSqlNode.WCF Property
TBoldSqlNode Class BoldSqlNodes Namespace See Also
Collapse All
C#
public TBoldSqlWCF WCF;
Remarks

This is WCF, a member of class TBoldSqlNode.

See Also
TBoldSqlNode Class
BoldSqlNodes Namespace


TBoldSqlNodeList Class

TBoldSqlNodeList Class
Inheritance Hierarchy See Also
Collapse All
C#
public class TBoldSqlNodeList : ArrayList;
Remarks

TBoldSqlNodeList

Inheritance Hierarchy
BoldSqlNodes.TBoldSqlNodeList
File

BoldSqlNodes.cs

See Also
Inheritance Hierarchy


TBoldSqlNodeList Methods

TBoldSqlNodeList Methods
Public Methods
Collapse All

The methods of the TBoldSqlNodeList class are listed here.

Public Methods
Name | Description
Add | TBoldSqlNodeList
this | This is this, a member of class TBoldSqlNodeList.
TraverseList | This is TraverseList, a member of class TBoldSqlNodeList.


TBoldSqlNodeList.Add Method

TBoldSqlNodeList.Add Method
TBoldSqlNodeList Class BoldSqlNodes Namespace See Also
Collapse All
C#
public int Add(
    TBoldSqlNode Item
);
Remarks

TBoldSqlNodeList

See Also
TBoldSqlNodeList Class
BoldSqlNodes Namespace


TBoldSqlNodeList.this Indexer

TBoldSqlNodeList.this Indexer
TBoldSqlNodeList Class BoldSqlNodes Namespace See Also
Collapse All
C#
public new TBoldSqlNode this[
    int index
];
Remarks

This is this, a member of class TBoldSqlNodeList.

See Also
TBoldSqlNodeList Class
BoldSqlNodes Namespace


TBoldSqlNodeList.TraverseList Method

TBoldSqlNodeList.TraverseList Method
TBoldSqlNodeList Class BoldSqlNodes Namespace See Also
Collapse All
C#
public virtual void TraverseList(
    TBoldSqlNodeVisitor V
);
Remarks

This is TraverseList, a member of class TBoldSqlNodeList.

See Also
TBoldSqlNodeList Class
BoldSqlNodes Namespace


TBoldSqlNodeVisitor Class

TBoldSqlNodeVisitor Class
Inheritance Hierarchy See Also
Collapse All
C#
public class TBoldSqlNodeVisitor;
Remarks

TBoldSqlNodeVisitor

Inheritance Hierarchy
BoldSqlNodes.TBoldSqlNodeVisitor
    BoldSqlNodesResolver.TBoldSqlNodeResolver
    BoldSqlQueryGenerator.TBoldSqlQueryGenerator
File

BoldSqlNodes.cs

See Also
Inheritance Hierarchy


TBoldSqlNodeVisitor Methods

TBoldSqlNodeVisitor Methods
Public Methods
Collapse All

The methods of the TBoldSqlNodeVisitor class are listed here.

Public Methods
Name | Description
VisitTBoldSqlDateLiteral | This is VisitTBoldSqlDateLiteral, a member of class TBoldSqlNodeVisitor.
VisitTBoldSqlEnumLiteral | TBoldSqlNodeVisitor
VisitTBoldSqlFloatLiteral | This is VisitTBoldSqlFloatLiteral, a member of class TBoldSqlNodeVisitor.
VisitTBoldSqlIntLiteral | This is VisitTBoldSqlIntLiteral, a member of class TBoldSqlNodeVisitor.
VisitTBoldSqlIteration | This is VisitTBoldSqlIteration, a member of class TBoldSqlNodeVisitor.
VisitTBoldSqlListCoercion | This is VisitTBoldSqlListCoercion, a member of class TBoldSqlNodeVisitor.
VisitTBoldSqlLiteral | This is VisitTBoldSqlLiteral, a member of class TBoldSqlNodeVisitor.
VisitTBoldSqlMember | This is VisitTBoldSqlMember, a member of class TBoldSqlNodeVisitor.
VisitTBoldSqlNode | internal
VisitTBoldSqlOperation | This is VisitTBoldSqlOperation, a member of class TBoldSqlNodeVisitor.
VisitTBoldSqlStrLiteral | This is VisitTBoldSqlStrLiteral, a member of class TBoldSqlNodeVisitor.
VisitTBoldSqlTimeLiteral | This is VisitTBoldSqlTimeLiteral, a member of class TBoldSqlNodeVisitor.
VisitTBoldSqlTypeNode | This is VisitTBoldSqlTypeNode, a member of class TBoldSqlNodeVisitor.
VisitTBoldSqlVariableBinding | This is VisitTBoldSqlVariableBinding, a member of class TBoldSqlNodeVisitor.
VisitTBoldSqlVariableReference | This is VisitTBoldSqlVariableReference, a member of class TBoldSqlNodeVisitor.


TBoldSqlNodeVisitor.VisitTBoldSqlDateLiteral Method

TBoldSqlNodeVisitor.VisitTBoldSqlDateLiteral Method
TBoldSqlNodeVisitor Class BoldSqlNodes Namespace See Also
Collapse All
C#
public virtual void VisitTBoldSqlDateLiteral(
    TBoldSqlDateLiteral N
);
Remarks

This is VisitTBoldSqlDateLiteral, a member of class TBoldSqlNodeVisitor.

See Also
TBoldSqlNodeVisitor Class
BoldSqlNodes Namespace


TBoldSqlNodeVisitor.VisitTBoldSqlEnumLiteral Method

TBoldSqlNodeVisitor.VisitTBoldSqlEnumLiteral Method
TBoldSqlNodeVisitor Class BoldSqlNodes Namespace See Also
Collapse All
C#
public virtual void VisitTBoldSqlEnumLiteral(
    TBoldSqlEnumLiteral N
);
Remarks

TBoldSqlNodeVisitor

See Also
TBoldSqlNodeVisitor Class
BoldSqlNodes Namespace


TBoldSqlNodeVisitor.VisitTBoldSqlFloatLiteral Method

TBoldSqlNodeVisitor.VisitTBoldSqlFloatLiteral Method
TBoldSqlNodeVisitor Class BoldSqlNodes Namespace See Also
Collapse All
C#
public virtual void VisitTBoldSqlFloatLiteral(
    TBoldSqlFloatLiteral N
);
Remarks

This is VisitTBoldSqlFloatLiteral, a member of class TBoldSqlNodeVisitor.

See Also
TBoldSqlNodeVisitor Class
BoldSqlNodes Namespace


TBoldSqlNodeVisitor.VisitTBoldSqlIntLiteral Method

TBoldSqlNodeVisitor.VisitTBoldSqlIntLiteral Method
TBoldSqlNodeVisitor Class BoldSqlNodes Namespace See Also
Collapse All
C#
public virtual void VisitTBoldSqlIntLiteral(
    TBoldSqlIntLiteral N
);
Remarks

This is VisitTBoldSqlIntLiteral, a member of class TBoldSqlNodeVisitor.

See Also
TBoldSqlNodeVisitor Class
BoldSqlNodes Namespace


TBoldSqlNodeVisitor.VisitTBoldSqlIteration Method

TBoldSqlNodeVisitor.VisitTBoldSqlIteration Method
TBoldSqlNodeVisitor Class BoldSqlNodes Namespace See Also
Collapse All
C#
public virtual void VisitTBoldSqlIteration(
    TBoldSqlIteration N
);
Remarks

This is VisitTBoldSqlIteration, a member of class TBoldSqlNodeVisitor.

See Also
TBoldSqlNodeVisitor Class
BoldSqlNodes Namespace


TBoldSqlNodeVisitor.VisitTBoldSqlListCoercion Method

TBoldSqlNodeVisitor.VisitTBoldSqlListCoercion Method
TBoldSqlNodeVisitor Class BoldSqlNodes Namespace See Also
Collapse All
C#
public virtual void VisitTBoldSqlListCoercion(
    TBoldSqlListCoercion N
);
Remarks

This is VisitTBoldSqlListCoercion, a member of class TBoldSqlNodeVisitor.

See Also
TBoldSqlNodeVisitor Class
BoldSqlNodes Namespace


TBoldSqlNodeVisitor.VisitTBoldSqlLiteral Method

TBoldSqlNodeVisitor.VisitTBoldSqlLiteral Method
TBoldSqlNodeVisitor Class BoldSqlNodes Namespace See Also
Collapse All
C#
public virtual void VisitTBoldSqlLiteral(
    TBoldSqlLiteral N
);
Remarks

This is VisitTBoldSqlLiteral, a member of class TBoldSqlNodeVisitor.

See Also
TBoldSqlNodeVisitor Class
BoldSqlNodes Namespace


TBoldSqlNodeVisitor.VisitTBoldSqlMember Method

TBoldSqlNodeVisitor.VisitTBoldSqlMember Method
TBoldSqlNodeVisitor Class BoldSqlNodes Namespace See Also
Collapse All
C#
public virtual void VisitTBoldSqlMember(
    TBoldSqlMember N
);
Remarks

This is VisitTBoldSqlMember, a member of class TBoldSqlNodeVisitor.

See Also
TBoldSqlNodeVisitor Class
BoldSqlNodes Namespace


TBoldSqlNodeVisitor.VisitTBoldSqlNode Method

TBoldSqlNodeVisitor.VisitTBoldSqlNode Method
TBoldSqlNodeVisitor Class BoldSqlNodes Namespace See Also
Collapse All
C#
public virtual void VisitTBoldSqlNode(
    TBoldSqlNode N
);
Remarks

internal

See Also
TBoldSqlNodeVisitor Class
BoldSqlNodes Namespace


TBoldSqlNodeVisitor.VisitTBoldSqlOperation Method

TBoldSqlNodeVisitor.VisitTBoldSqlOperation Method
TBoldSqlNodeVisitor Class BoldSqlNodes Namespace See Also
Collapse All
C#
public virtual void VisitTBoldSqlOperation(
    TBoldSqlOperation N
);
Remarks

This is VisitTBoldSqlOperation, a member of class TBoldSqlNodeVisitor.

See Also
TBoldSqlNodeVisitor Class
BoldSqlNodes Namespace


TBoldSqlNodeVisitor.VisitTBoldSqlStrLiteral Method

TBoldSqlNodeVisitor.VisitTBoldSqlStrLiteral Method
TBoldSqlNodeVisitor Class BoldSqlNodes Namespace See Also
Collapse All
C#
public virtual void VisitTBoldSqlStrLiteral(
    TBoldSqlStrLiteral N
);
Remarks

This is VisitTBoldSqlStrLiteral, a member of class TBoldSqlNodeVisitor.

See Also
TBoldSqlNodeVisitor Class
BoldSqlNodes Namespace


TBoldSqlNodeVisitor.VisitTBoldSqlTimeLiteral Method

TBoldSqlNodeVisitor.VisitTBoldSqlTimeLiteral Method
TBoldSqlNodeVisitor Class BoldSqlNodes Namespace See Also
Collapse All
C#
public virtual void VisitTBoldSqlTimeLiteral(
    TBoldSqlTimeLiteral N
);
Remarks

This is VisitTBoldSqlTimeLiteral, a member of class TBoldSqlNodeVisitor.

See Also
TBoldSqlNodeVisitor Class
BoldSqlNodes Namespace


TBoldSqlNodeVisitor.VisitTBoldSqlTypeNode Method

TBoldSqlNodeVisitor.VisitTBoldSqlTypeNode Method
TBoldSqlNodeVisitor Class BoldSqlNodes Namespace See Also
Collapse All
C#
public virtual void VisitTBoldSqlTypeNode(
    TBoldSqlTypeNode N
);
Remarks

This is VisitTBoldSqlTypeNode, a member of class TBoldSqlNodeVisitor.

See Also
TBoldSqlNodeVisitor Class
BoldSqlNodes Namespace


TBoldSqlNodeVisitor.VisitTBoldSqlVariableBinding Method

TBoldSqlNodeVisitor.VisitTBoldSqlVariableBinding Method
TBoldSqlNodeVisitor Class BoldSqlNodes Namespace See Also
Collapse All
C#
public virtual void VisitTBoldSqlVariableBinding(
    TBoldSqlVariableBinding N
);
Remarks

This is VisitTBoldSqlVariableBinding, a member of class TBoldSqlNodeVisitor.

See Also
TBoldSqlNodeVisitor Class
BoldSqlNodes Namespace


TBoldSqlNodeVisitor.VisitTBoldSqlVariableReference Method

TBoldSqlNodeVisitor.VisitTBoldSqlVariableReference Method
TBoldSqlNodeVisitor Class BoldSqlNodes Namespace See Also
Collapse All
C#
public virtual void VisitTBoldSqlVariableReference(
    TBoldSqlVariableReference N
);
Remarks

This is VisitTBoldSqlVariableReference, a member of class TBoldSqlNodeVisitor.

See Also
TBoldSqlNodeVisitor Class
BoldSqlNodes Namespace


TBoldSqlOperation Class

TBoldSqlOperation Class
Inheritance Hierarchy See Also
Collapse All
C#
public class TBoldSqlOperation : TBoldSqlNode;
Remarks

end TBoldSqlListCoercion

Inheritance Hierarchy
BoldSqlNodes.TBoldSqlNode
    BoldSqlNodes.TBoldSqlOperation
        BoldSqlNodes.TBoldSqlIteration
File

BoldSqlNodes.cs

See Also
Inheritance Hierarchy


TBoldSqlOperation.TBoldSqlOperation Constructor

TBoldSqlOperation.TBoldSqlOperation Constructor
TBoldSqlOperation Class BoldSqlNodes Namespace See Also
Collapse All
C#
public TBoldSqlOperation(
    int Position,
    string OperationName
);
Remarks

Constructor create( Position, OperationName)

See Also
TBoldSqlOperation Class
BoldSqlNodes Namespace


TBoldSqlOperation Methods

TBoldSqlOperation Methods
Public Methods
Collapse All

The methods of the TBoldSqlOperation class are listed here.

Public Methods
Name | Description
AcceptVisitor | TBoldOclOperation


TBoldSqlOperation.AcceptVisitor Method

TBoldSqlOperation.AcceptVisitor Method
TBoldSqlOperation Class BoldSqlNodes Namespace See Also
Collapse All
C#
public override void AcceptVisitor(
    TBoldSqlNodeVisitor V
);
Remarks

TBoldOclOperation

See Also
TBoldSqlOperation Class
BoldSqlNodes Namespace


TBoldSqlOperation Properties

TBoldSqlOperation Properties
Public Properties
Collapse All

The properties of the TBoldSqlOperation class are listed here.

Public Properties
Name | Description
Args | This is Args, a member of class TBoldSqlOperation.
IsAssociative | This is IsAssociative, a member of class TBoldSqlOperation.
OperationName | This is OperationName, a member of class TBoldSqlOperation.
ParentIsSameOperation | This is ParentIsSameOperation, a member of class TBoldSqlOperation.
Symbol | This is Symbol, a member of class TBoldSqlOperation.


TBoldSqlOperation.Args Property

TBoldSqlOperation.Args Property
TBoldSqlOperation Class BoldSqlNodes Namespace See Also
Collapse All
C#
public TBoldSqlNodeList Args;
Remarks

This is Args, a member of class TBoldSqlOperation.

See Also
TBoldSqlOperation Class
BoldSqlNodes Namespace


TBoldSqlOperation.IsAssociative Property

TBoldSqlOperation.IsAssociative Property
TBoldSqlOperation Class BoldSqlNodes Namespace See Also
Collapse All
C#
public bool IsAssociative;
Remarks

This is IsAssociative, a member of class TBoldSqlOperation.

See Also
TBoldSqlOperation Class
BoldSqlNodes Namespace


TBoldSqlOperation.OperationName Property

TBoldSqlOperation.OperationName Property
TBoldSqlOperation Class BoldSqlNodes Namespace See Also
Collapse All
C#
public string OperationName;
Remarks

This is OperationName, a member of class TBoldSqlOperation.

See Also
TBoldSqlOperation Class
BoldSqlNodes Namespace


TBoldSqlOperation.ParentIsSameOperation Property

TBoldSqlOperation.ParentIsSameOperation Property
TBoldSqlOperation Class BoldSqlNodes Namespace See Also
Collapse All
C#
public bool ParentIsSameOperation;
Remarks

This is ParentIsSameOperation, a member of class TBoldSqlOperation.

See Also
TBoldSqlOperation Class
BoldSqlNodes Namespace


TBoldSqlOperation.Symbol Property

TBoldSqlOperation.Symbol Property
TBoldSqlOperation Class BoldSqlNodes Namespace See Also
Collapse All
C#
public TBoldSqlSymbol Symbol;
Remarks

This is Symbol, a member of class TBoldSqlOperation.

See Also
TBoldSqlOperation Class
BoldSqlNodes Namespace


TBoldSqlStrLiteral Class

TBoldSqlStrLiteral Class
Inheritance Hierarchy See Also
Collapse All
C#
public class TBoldSqlStrLiteral : TBoldSqlLiteral;
Remarks

end TBoldSqlLiteral

Inheritance Hierarchy
BoldSqlNodes.TBoldSqlNode
    BoldSqlNodes.TBoldSqlLiteral
        BoldSqlNodes.TBoldSqlStrLiteral
File

BoldSqlNodes.cs

See Also
Inheritance Hierarchy


TBoldSqlStrLiteral.TBoldSqlStrLiteral Constructor

TBoldSqlStrLiteral.TBoldSqlStrLiteral Constructor
TBoldSqlStrLiteral Class BoldSqlNodes Namespace See Also
Collapse All
C#
public TBoldSqlStrLiteral(
    int Position,
    string StrValue
);
Remarks

Constructor Create( Position, StrValue)

See Also
TBoldSqlStrLiteral Class
BoldSqlNodes Namespace


TBoldSqlStrLiteral Methods

TBoldSqlStrLiteral Methods
Public Methods
Collapse All

The methods of the TBoldSqlStrLiteral class are listed here.

Public Methods
Name | Description
AcceptVisitor | TBoldSqlStrLiteral


TBoldSqlStrLiteral.AcceptVisitor Method

TBoldSqlStrLiteral.AcceptVisitor Method
TBoldSqlStrLiteral Class BoldSqlNodes Namespace See Also
Collapse All
C#
public override void AcceptVisitor(
    TBoldSqlNodeVisitor V
);
Remarks

TBoldSqlStrLiteral

See Also
TBoldSqlStrLiteral Class
BoldSqlNodes Namespace


TBoldSqlStrLiteral Properties

TBoldSqlStrLiteral Properties
Public Properties
Collapse All

The properties of the TBoldSqlStrLiteral class are listed here.

Public Properties
Name | Description
StrValue | This is StrValue, a member of class TBoldSqlStrLiteral.


TBoldSqlStrLiteral.StrValue Property

TBoldSqlStrLiteral.StrValue Property
TBoldSqlStrLiteral Class BoldSqlNodes Namespace See Also
Collapse All
C#
public string StrValue;
Remarks

This is StrValue, a member of class TBoldSqlStrLiteral.

See Also
TBoldSqlStrLiteral Class
BoldSqlNodes Namespace


TBoldSqlSymbol Class

TBoldSqlSymbol Class
Inheritance Hierarchy See Also
Collapse All
C#
public abstract class TBoldSqlSymbol;
Remarks

end TBoldSqlNodeList

Inheritance Hierarchy
BoldSqlNodes.TBoldSqlSymbol
    BoldSqlSymbols.TBSS_Symbol
File

BoldSqlNodes.cs

See Also
Inheritance Hierarchy


TBoldSqlSymbol Methods

TBoldSqlSymbol Methods
Public Methods
Collapse All

The methods of the TBoldSqlSymbol class are listed here.

Public Methods
Name | Description
BuildWCFOrQuery | TBoldSqlSymbol
ResolveObjectMapper | This is ResolveObjectMapper, a member of class TBoldSqlSymbol.


TBoldSqlSymbol.BuildWCFOrQuery Method

TBoldSqlSymbol.BuildWCFOrQuery Method
TBoldSqlSymbol Class BoldSqlNodes Namespace See Also
Collapse All
C#
public virtual void BuildWCFOrQuery(
    TBoldSqlOperation OperationNode,
    TBoldSQLNameSpace __NameSpace
);
Remarks

TBoldSqlSymbol

See Also
TBoldSqlSymbol Class
BoldSqlNodes Namespace


TBoldSqlSymbol.ResolveObjectMapper Method

TBoldSqlSymbol.ResolveObjectMapper Method
TBoldSqlSymbol Class BoldSqlNodes Namespace See Also
Collapse All
C#
public virtual ClassPersistenceMapper ResolveObjectMapper(
    TBoldSqlOperation OperationNode
);
Remarks

This is ResolveObjectMapper, a member of class TBoldSqlSymbol.

See Also
TBoldSqlSymbol Class
BoldSqlNodes Namespace


TBoldSqlSymbol Properties

TBoldSqlSymbol Properties
Public Properties
Collapse All

The properties of the TBoldSqlSymbol class are listed here.

Public Properties
Name | Description
Name | This is Name, a member of class TBoldSqlSymbol.
SqlName | This is SqlName, a member of class TBoldSqlSymbol.


TBoldSqlSymbol.Name Property

TBoldSqlSymbol.Name Property
TBoldSqlSymbol Class BoldSqlNodes Namespace See Also
Collapse All
C#
public virtual string Name;
Remarks

This is Name, a member of class TBoldSqlSymbol.

See Also
TBoldSqlSymbol Class
BoldSqlNodes Namespace


TBoldSqlSymbol.SqlName Property

TBoldSqlSymbol.SqlName Property
TBoldSqlSymbol Class BoldSqlNodes Namespace See Also
Collapse All
C#
public virtual string SqlName;
Remarks

This is SqlName, a member of class TBoldSqlSymbol.

See Also
TBoldSqlSymbol Class
BoldSqlNodes Namespace


TBoldSqlTimeLiteral Class

TBoldSqlTimeLiteral Class
Inheritance Hierarchy See Also
Collapse All
C#
public class TBoldSqlTimeLiteral : TBoldSqlLiteral;
Remarks

end TBoldSqlDateLiteral

Inheritance Hierarchy
BoldSqlNodes.TBoldSqlNode
    BoldSqlNodes.TBoldSqlLiteral
        BoldSqlNodes.TBoldSqlTimeLiteral
File

BoldSqlNodes.cs

See Also
Inheritance Hierarchy


TBoldSqlTimeLiteral.TBoldSqlTimeLiteral Constructor

TBoldSqlTimeLiteral.TBoldSqlTimeLiteral Constructor
TBoldSqlTimeLiteral Class BoldSqlNodes Namespace See Also
Collapse All
C#
public TBoldSqlTimeLiteral(
    int Position,
    TimeSpan TimeValue
);
Remarks

Constructor Create( Position, TimeValue)

See Also
TBoldSqlTimeLiteral Class
BoldSqlNodes Namespace


TBoldSqlTimeLiteral Methods

TBoldSqlTimeLiteral Methods
Public Methods
Collapse All

The methods of the TBoldSqlTimeLiteral class are listed here.

Public Methods
Name | Description
AcceptVisitor | TBoldSqlTimeLiteral


TBoldSqlTimeLiteral.AcceptVisitor Method

TBoldSqlTimeLiteral.AcceptVisitor Method
TBoldSqlTimeLiteral Class BoldSqlNodes Namespace See Also
Collapse All
C#
public override void AcceptVisitor(
    TBoldSqlNodeVisitor V
);
Remarks

TBoldSqlTimeLiteral

See Also
TBoldSqlTimeLiteral Class
BoldSqlNodes Namespace


TBoldSqlTimeLiteral Properties

TBoldSqlTimeLiteral Properties
Public Properties
Collapse All

The properties of the TBoldSqlTimeLiteral class are listed here.

Public Properties
Name | Description
TimeValue | This is TimeValue, a member of class TBoldSqlTimeLiteral.


TBoldSqlTimeLiteral.TimeValue Property

TBoldSqlTimeLiteral.TimeValue Property
TBoldSqlTimeLiteral Class BoldSqlNodes Namespace See Also
Collapse All
C#
public TimeSpan TimeValue;
Remarks

This is TimeValue, a member of class TBoldSqlTimeLiteral.

See Also
TBoldSqlTimeLiteral Class
BoldSqlNodes Namespace


TBoldSqlTypeNode Class

TBoldSqlTypeNode Class
Inheritance Hierarchy See Also
Collapse All
C#
public class TBoldSqlTypeNode : TBoldSqlNode;
Remarks

end TBoldSqlNode

Inheritance Hierarchy
BoldSqlNodes.TBoldSqlNode
    BoldSqlNodes.TBoldSqlTypeNode
File

BoldSqlNodes.cs

See Also
Inheritance Hierarchy


TBoldSqlTypeNode.TBoldSqlTypeNode Constructor

TBoldSqlTypeNode.TBoldSqlTypeNode Constructor
TBoldSqlTypeNode Class BoldSqlNodes Namespace See Also
Collapse All
C#
public TBoldSqlTypeNode(
    int Position,
    string TypeName,
    int TopSortedIndex
);
Remarks

Constructor Create( Position, TypeName, TopSortedIndex)

See Also
TBoldSqlTypeNode Class
BoldSqlNodes Namespace


TBoldSqlTypeNode Methods

TBoldSqlTypeNode Methods
Public Methods
Collapse All

The methods of the TBoldSqlTypeNode class are listed here.

Public Methods
Name | Description
AcceptVisitor | TBoldSqlTypeNode


TBoldSqlTypeNode.AcceptVisitor Method

TBoldSqlTypeNode.AcceptVisitor Method
TBoldSqlTypeNode Class BoldSqlNodes Namespace See Also
Collapse All
C#
public override void AcceptVisitor(
    TBoldSqlNodeVisitor V
);
Remarks

TBoldSqlTypeNode

See Also
TBoldSqlTypeNode Class
BoldSqlNodes Namespace


TBoldSqlTypeNode Properties

TBoldSqlTypeNode Properties
Public Properties
Collapse All

The properties of the TBoldSqlTypeNode class are listed here.

Public Properties
Name | Description
TopSortedIndex | This is TopSortedIndex, a member of class TBoldSqlTypeNode.
TypeName | This is TypeName, a member of class TBoldSqlTypeNode.


TBoldSqlTypeNode.TopSortedIndex Property

TBoldSqlTypeNode.TopSortedIndex Property
TBoldSqlTypeNode Class BoldSqlNodes Namespace See Also
Collapse All
C#
public int TopSortedIndex;
Remarks

This is TopSortedIndex, a member of class TBoldSqlTypeNode.

See Also
TBoldSqlTypeNode Class
BoldSqlNodes Namespace


TBoldSqlTypeNode.TypeName Property

TBoldSqlTypeNode.TypeName Property
TBoldSqlTypeNode Class BoldSqlNodes Namespace See Also
Collapse All
C#
public string TypeName;
Remarks

This is TypeName, a member of class TBoldSqlTypeNode.

See Also
TBoldSqlTypeNode Class
BoldSqlNodes Namespace


TBoldSqlVariableBinding Class

TBoldSqlVariableBinding Class
Inheritance Hierarchy See Also
Collapse All
C#
public class TBoldSqlVariableBinding : TBoldSqlNode;
Remarks

end TBoldSqlMember

Inheritance Hierarchy
BoldSqlNodes.TBoldSqlNode
    BoldSqlNodes.TBoldSqlVariableBinding
File

BoldSqlNodes.cs

See Also
Inheritance Hierarchy


TBoldSqlVariableBinding.TBoldSqlVariableBinding Constructor

TBoldSqlVariableBinding.TBoldSqlVariableBinding Constructor
TBoldSqlVariableBinding Class BoldSqlNodes Namespace See Also
Collapse All
C#
public TBoldSqlVariableBinding(
    int Position,
    string VariableName,
    int TopSortedIndex
);
Remarks

Constructor Create( Position, VariableName, TopSortedIndex)

See Also
TBoldSqlVariableBinding Class
BoldSqlNodes Namespace


TBoldSqlVariableBinding Methods

TBoldSqlVariableBinding Methods
Public Methods
Collapse All

The methods of the TBoldSqlVariableBinding class are listed here.

Public Methods
Name | Description
AcceptVisitor | TBoldSqlVariableBinding
AddRef | This is AddRef, a member of class TBoldSqlVariableBinding.


TBoldSqlVariableBinding.AcceptVisitor Method

TBoldSqlVariableBinding.AcceptVisitor Method
TBoldSqlVariableBinding Class BoldSqlNodes Namespace See Also
Collapse All
C#
public override void AcceptVisitor(
    TBoldSqlNodeVisitor V
);
Remarks

TBoldSqlVariableBinding

See Also
TBoldSqlVariableBinding Class
BoldSqlNodes Namespace


TBoldSqlVariableBinding.AddRef Method

TBoldSqlVariableBinding.AddRef Method
TBoldSqlVariableBinding Class BoldSqlNodes Namespace See Also
Collapse All
C#
public void AddRef();
Remarks

This is AddRef, a member of class TBoldSqlVariableBinding.

See Also
TBoldSqlVariableBinding Class
BoldSqlNodes Namespace


TBoldSqlVariableBinding Properties

TBoldSqlVariableBinding Properties
Public Properties
Collapse All

The properties of the TBoldSqlVariableBinding class are listed here.

Public Properties
Name | Description
ExternalVarvalue | This is ExternalVarvalue, a member of class TBoldSqlVariableBinding.
IsExternal | This is IsExternal, a member of class TBoldSqlVariableBinding.
IsLoopVar | This is IsLoopVar, a member of class TBoldSqlVariableBinding.
RefCount | This is RefCount, a member of class TBoldSqlVariableBinding.
TopSortedIndex | This is TopSortedIndex, a member of class TBoldSqlVariableBinding.
VariableName | This is VariableName, a member of class TBoldSqlVariableBinding.


TBoldSqlVariableBinding.ExternalVarvalue Property

TBoldSqlVariableBinding.ExternalVarvalue Property
TBoldSqlVariableBinding Class BoldSqlNodes Namespace See Also
Collapse All
C#
public object ExternalVarvalue;
Remarks

This is ExternalVarvalue, a member of class TBoldSqlVariableBinding.

See Also
TBoldSqlVariableBinding Class
BoldSqlNodes Namespace


TBoldSqlVariableBinding.IsExternal Property

TBoldSqlVariableBinding.IsExternal Property
TBoldSqlVariableBinding Class BoldSqlNodes Namespace See Also
Collapse All
C#
public bool IsExternal;
Remarks

This is IsExternal, a member of class TBoldSqlVariableBinding.

See Also
TBoldSqlVariableBinding Class
BoldSqlNodes Namespace


TBoldSqlVariableBinding.IsLoopVar Property

TBoldSqlVariableBinding.IsLoopVar Property
TBoldSqlVariableBinding Class BoldSqlNodes Namespace See Also
Collapse All
C#
public bool IsLoopVar;
Remarks

This is IsLoopVar, a member of class TBoldSqlVariableBinding.

See Also
TBoldSqlVariableBinding Class
BoldSqlNodes Namespace


TBoldSqlVariableBinding.RefCount Property

TBoldSqlVariableBinding.RefCount Property
TBoldSqlVariableBinding Class BoldSqlNodes Namespace See Also
Collapse All
C#
public int RefCount;
Remarks

This is RefCount, a member of class TBoldSqlVariableBinding.

See Also
TBoldSqlVariableBinding Class
BoldSqlNodes Namespace


TBoldSqlVariableBinding.TopSortedIndex Property

TBoldSqlVariableBinding.TopSortedIndex Property
TBoldSqlVariableBinding Class BoldSqlNodes Namespace See Also
Collapse All
C#
public int TopSortedIndex;
Remarks

This is TopSortedIndex, a member of class TBoldSqlVariableBinding.

See Also
TBoldSqlVariableBinding Class
BoldSqlNodes Namespace


TBoldSqlVariableBinding.VariableName Property

TBoldSqlVariableBinding.VariableName Property
TBoldSqlVariableBinding Class BoldSqlNodes Namespace See Also
Collapse All
C#
public string VariableName;
Remarks

This is VariableName, a member of class TBoldSqlVariableBinding.

See Also
TBoldSqlVariableBinding Class
BoldSqlNodes Namespace


TBoldSqlVariableReference Class

TBoldSqlVariableReference Class
Inheritance Hierarchy See Also
Collapse All
C#
public class TBoldSqlVariableReference : TBoldSqlNode;
Remarks

end TBoldSqlVariableBinding

Inheritance Hierarchy
BoldSqlNodes.TBoldSqlNode
    BoldSqlNodes.TBoldSqlVariableReference
File

BoldSqlNodes.cs

See Also
Inheritance Hierarchy


TBoldSqlVariableReference.TBoldSqlVariableReference Constructor

TBoldSqlVariableReference.TBoldSqlVariableReference Constructor
TBoldSqlVariableReference Class BoldSqlNodes Namespace See Also
Collapse All
C#
public TBoldSqlVariableReference(
    int Position,
    TBoldSqlVariableBinding VariableBinding
);
Remarks

Constructor Create( Position, VariableBinding)

See Also
TBoldSqlVariableReference Class
BoldSqlNodes Namespace


TBoldSqlVariableReference Methods

TBoldSqlVariableReference Methods
Public Methods
Collapse All

The methods of the TBoldSqlVariableReference class are listed here.

Public Methods
Name | Description
AcceptVisitor | TBoldSqlVariableReference
AliasReferenceForAlias | This is AliasReferenceForAlias, a member of class TBoldSqlVariableReference.
IsExternalVariable | This is IsExternalVariable, a member of class TBoldSqlVariableReference.
RelinquishQuery | This is RelinquishQuery, a member of class TBoldSqlVariableReference.
RelinquishWCF | This is RelinquishWCF, a member of class TBoldSqlVariableReference.


TBoldSqlVariableReference.AcceptVisitor Method

TBoldSqlVariableReference.AcceptVisitor Method
TBoldSqlVariableReference Class BoldSqlNodes Namespace See Also
Collapse All
C#
public override void AcceptVisitor(
    TBoldSqlNodeVisitor V
);
Remarks

TBoldSqlVariableReference

See Also
TBoldSqlVariableReference Class
BoldSqlNodes Namespace


TBoldSqlVariableReference.AliasReferenceForAlias Method

TBoldSqlVariableReference.AliasReferenceForAlias Method
TBoldSqlVariableReference Class BoldSqlNodes Namespace See Also
Collapse All
C#
public override TBoldSQLAliasReference AliasReferenceForAlias(
    AliasDefinition Alias,
    TBoldSQLQuery Query,
    bool ForceOwntable
);
Remarks

This is AliasReferenceForAlias, a member of class TBoldSqlVariableReference.

See Also
TBoldSqlVariableReference Class
BoldSqlNodes Namespace


TBoldSqlVariableReference.IsExternalVariable Method

TBoldSqlVariableReference.IsExternalVariable Method
TBoldSqlVariableReference Class BoldSqlNodes Namespace See Also
Collapse All
C#
public bool IsExternalVariable();
Remarks

This is IsExternalVariable, a member of class TBoldSqlVariableReference.

See Also
TBoldSqlVariableReference Class
BoldSqlNodes Namespace


TBoldSqlVariableReference.RelinquishQuery Method

TBoldSqlVariableReference.RelinquishQuery Method
TBoldSqlVariableReference Class BoldSqlNodes Namespace See Also
Collapse All
C#
public override TBoldSQLQuery RelinquishQuery();
Remarks

This is RelinquishQuery, a member of class TBoldSqlVariableReference.

See Also
TBoldSqlVariableReference Class
BoldSqlNodes Namespace


TBoldSqlVariableReference.RelinquishWCF Method

TBoldSqlVariableReference.RelinquishWCF Method
TBoldSqlVariableReference Class BoldSqlNodes Namespace See Also
Collapse All
C#
public override TBoldSqlWCF RelinquishWCF();
Remarks

This is RelinquishWCF, a member of class TBoldSqlVariableReference.

See Also
TBoldSqlVariableReference Class
BoldSqlNodes Namespace


TBoldSqlVariableReference Properties

TBoldSqlVariableReference Properties
Public Properties
Collapse All

The properties of the TBoldSqlVariableReference class are listed here.

Public Properties
Name | Description
ObjectMapper | This is ObjectMapper, a member of class TBoldSqlVariableReference.
Query | This is Query, a member of class TBoldSqlVariableReference.
RefCount | This is RefCount, a member of class TBoldSqlVariableReference.
VariableBinding | This is VariableBinding, a member of class TBoldSqlVariableReference.


TBoldSqlVariableReference.ObjectMapper Property

TBoldSqlVariableReference.ObjectMapper Property
TBoldSqlVariableReference Class BoldSqlNodes Namespace See Also
Collapse All
C#
public override ClassPersistenceMapper ObjectMapper;
Remarks

This is ObjectMapper, a member of class TBoldSqlVariableReference.

See Also
TBoldSqlVariableReference Class
BoldSqlNodes Namespace


TBoldSqlVariableReference.Query Property

TBoldSqlVariableReference.Query Property
TBoldSqlVariableReference Class BoldSqlNodes Namespace See Also
Collapse All
C#
public override TBoldSQLQuery Query;
Remarks

This is Query, a member of class TBoldSqlVariableReference.

See Also
TBoldSqlVariableReference Class
BoldSqlNodes Namespace


TBoldSqlVariableReference.RefCount Property

TBoldSqlVariableReference.RefCount Property
TBoldSqlVariableReference Class BoldSqlNodes Namespace See Also
Collapse All
C#
public int RefCount;
Remarks

This is RefCount, a member of class TBoldSqlVariableReference.

See Also
TBoldSqlVariableReference Class
BoldSqlNodes Namespace


TBoldSqlVariableReference.VariableBinding Property

TBoldSqlVariableReference.VariableBinding Property
TBoldSqlVariableReference Class BoldSqlNodes Namespace See Also
Collapse All
C#
public TBoldSqlVariableBinding VariableBinding;
Remarks

This is VariableBinding, a member of class TBoldSqlVariableReference.

See Also
TBoldSqlVariableReference Class
BoldSqlNodes Namespace


TBoldSQLWCFVariable Class

TBoldSQLWCFVariable Class
Inheritance Hierarchy See Also
Collapse All
C#
public class TBoldSQLWCFVariable : TBoldSqlWCF;
Remarks

end TBoldSqlNodeVisitor

Inheritance Hierarchy
BoldSQLQuery.TBoldSqlWCF
    BoldSqlNodes.TBoldSQLWCFVariable
File

BoldSqlNodes.cs

See Also
Inheritance Hierarchy


TBoldSQLWCFVariable.TBoldSQLWCFVariable Constructor

TBoldSQLWCFVariable.TBoldSQLWCFVariable Constructor
TBoldSQLWCFVariable Class BoldSqlNodes Namespace See Also
Collapse All
C#
public TBoldSQLWCFVariable(
    TBoldSqlVariableBinding VariableBinding,
    TBoldSqlVariableReference VariableReference
);
Remarks

TBoldSQLWCFVariable <- Implement new WCFclass for variables (HK) Constructor Create( VariableBinding, VariableReference)

See Also
TBoldSQLWCFVariable Class
BoldSqlNodes Namespace


TBoldSQLWCFVariable Methods

TBoldSQLWCFVariable Methods
Public Methods
Collapse All

The methods of the TBoldSQLWCFVariable class are listed here.

Public Methods
Name | Description
GetAsString | This is GetAsString, a member of class TBoldSQLWCFVariable.


TBoldSQLWCFVariable.GetAsString Method

TBoldSQLWCFVariable.GetAsString Method
TBoldSQLWCFVariable Class BoldSqlNodes Namespace See Also
Collapse All
C#
public override string GetAsString(
    TBoldSQLQuery Query
);
Remarks

This is GetAsString, a member of class TBoldSQLWCFVariable.

See Also
TBoldSQLWCFVariable Class
BoldSqlNodes Namespace


BoldSqlNodesResolver Namespace

BoldSqlNodesResolver Namespace
Classes
Collapse All

This is namespace BoldSqlNodesResolver.

Classes
Name | Description
TBoldSqlNodeResolver | TBoldSqlNodeResolver


TBoldSqlNodeResolver Class

TBoldSqlNodeResolver Class
Inheritance Hierarchy See Also
Collapse All
C#
public class TBoldSqlNodeResolver : TBoldSqlNodeVisitor;
Remarks

TBoldSqlNodeResolver

Inheritance Hierarchy
BoldSqlNodes.TBoldSqlNodeVisitor
    BoldSqlNodesResolver.TBoldSqlNodeResolver
File

BoldSqlNodesResolver.cs

See Also
Inheritance Hierarchy


TBoldSqlNodeResolver.TBoldSqlNodeResolver Constructor

TBoldSqlNodeResolver.TBoldSqlNodeResolver Constructor
TBoldSqlNodeResolver Class BoldSqlNodesResolver Namespace See Also
Collapse All
C#
public TBoldSqlNodeResolver(
    SystemPersistenceMapper SystemMapper,
    TBoldSqlNode RootNode,
    TBoldSqlNodeList ExternalVariables
);
Remarks

TBoldSqlNodeResolver Constructor Create( SystemMapper, RootNode, ExternalVariables)

See Also
TBoldSqlNodeResolver Class
BoldSqlNodesResolver Namespace


TBoldSqlNodeResolver Methods

TBoldSqlNodeResolver Methods
Public Methods
Collapse All

The methods of the TBoldSqlNodeResolver class are listed here.

Public Methods
Name | Description
Execute | This is Execute, a member of class TBoldSqlNodeResolver.
VisitTBoldSqlDateLiteral | This is VisitTBoldSqlDateLiteral, a member of class TBoldSqlNodeResolver.
VisitTBoldSqlEnumLiteral | This is VisitTBoldSqlEnumLiteral, a member of class TBoldSqlNodeResolver.
VisitTBoldSqlFloatLiteral | This is VisitTBoldSqlFloatLiteral, a member of class TBoldSqlNodeResolver.
VisitTBoldSqlIntLiteral | This is VisitTBoldSqlIntLiteral, a member of class TBoldSqlNodeResolver.
VisitTBoldSqlIteration | This is VisitTBoldSqlIteration, a member of class TBoldSqlNodeResolver.
VisitTBoldSqlListCoercion | This is VisitTBoldSqlListCoercion, a member of class TBoldSqlNodeResolver.
VisitTBoldSqlLiteral | This is VisitTBoldSqlLiteral, a member of class TBoldSqlNodeResolver.
VisitTBoldSqlMember | This is VisitTBoldSqlMember, a member of class TBoldSqlNodeResolver.
VisitTBoldSqlNode | internal
VisitTBoldSqlOperation | This is VisitTBoldSqlOperation, a member of class TBoldSqlNodeResolver.
VisitTBoldSqlStrLiteral | This is VisitTBoldSqlStrLiteral, a member of class TBoldSqlNodeResolver.
VisitTBoldSqlTimeLiteral | This is VisitTBoldSqlTimeLiteral, a member of class TBoldSqlNodeResolver.
VisitTBoldSqlTypeNode | This is VisitTBoldSqlTypeNode, a member of class TBoldSqlNodeResolver.
VisitTBoldSqlVariableBinding | This is VisitTBoldSqlVariableBinding, a member of class TBoldSqlNodeResolver.
VisitTBoldSqlVariableReference | This is VisitTBoldSqlVariableReference, a member of class TBoldSqlNodeResolver.


TBoldSqlNodeResolver.Execute Method

TBoldSqlNodeResolver.Execute Method
TBoldSqlNodeResolver Class BoldSqlNodesResolver Namespace See Also
Collapse All
C#
public void Execute();
Remarks

This is Execute, a member of class TBoldSqlNodeResolver.

See Also
TBoldSqlNodeResolver Class
BoldSqlNodesResolver Namespace


TBoldSqlNodeResolver.VisitTBoldSqlDateLiteral Method

TBoldSqlNodeResolver.VisitTBoldSqlDateLiteral Method
TBoldSqlNodeResolver Class BoldSqlNodesResolver Namespace See Also
Collapse All
C#
public override void VisitTBoldSqlDateLiteral(
    TBoldSqlDateLiteral N
);
Remarks

This is VisitTBoldSqlDateLiteral, a member of class TBoldSqlNodeResolver.

See Also
TBoldSqlNodeResolver Class
BoldSqlNodesResolver Namespace


TBoldSqlNodeResolver.VisitTBoldSqlEnumLiteral Method

TBoldSqlNodeResolver.VisitTBoldSqlEnumLiteral Method
TBoldSqlNodeResolver Class BoldSqlNodesResolver Namespace See Also
Collapse All
C#
public override void VisitTBoldSqlEnumLiteral(
    TBoldSqlEnumLiteral N
);
Remarks

This is VisitTBoldSqlEnumLiteral, a member of class TBoldSqlNodeResolver.

See Also
TBoldSqlNodeResolver Class
BoldSqlNodesResolver Namespace


TBoldSqlNodeResolver.VisitTBoldSqlFloatLiteral Method

TBoldSqlNodeResolver.VisitTBoldSqlFloatLiteral Method
TBoldSqlNodeResolver Class BoldSqlNodesResolver Namespace See Also
Collapse All
C#
public override void VisitTBoldSqlFloatLiteral(
    TBoldSqlFloatLiteral N
);
Remarks

This is VisitTBoldSqlFloatLiteral, a member of class TBoldSqlNodeResolver.

See Also
TBoldSqlNodeResolver Class
BoldSqlNodesResolver Namespace


TBoldSqlNodeResolver.VisitTBoldSqlIntLiteral Method

TBoldSqlNodeResolver.VisitTBoldSqlIntLiteral Method
TBoldSqlNodeResolver Class BoldSqlNodesResolver Namespace See Also
Collapse All
C#
public override void VisitTBoldSqlIntLiteral(
    TBoldSqlIntLiteral N
);
Remarks

This is VisitTBoldSqlIntLiteral, a member of class TBoldSqlNodeResolver.

See Also
TBoldSqlNodeResolver Class
BoldSqlNodesResolver Namespace


TBoldSqlNodeResolver.VisitTBoldSqlIteration Method

TBoldSqlNodeResolver.VisitTBoldSqlIteration Method
TBoldSqlNodeResolver Class BoldSqlNodesResolver Namespace See Also
Collapse All
C#
public override void VisitTBoldSqlIteration(
    TBoldSqlIteration N
);
Remarks

This is VisitTBoldSqlIteration, a member of class TBoldSqlNodeResolver.

See Also
TBoldSqlNodeResolver Class
BoldSqlNodesResolver Namespace


TBoldSqlNodeResolver.VisitTBoldSqlListCoercion Method

TBoldSqlNodeResolver.VisitTBoldSqlListCoercion Method
TBoldSqlNodeResolver Class BoldSqlNodesResolver Namespace See Also
Collapse All
C#
public override void VisitTBoldSqlListCoercion(
    TBoldSqlListCoercion N
);
Remarks

This is VisitTBoldSqlListCoercion, a member of class TBoldSqlNodeResolver.

See Also
TBoldSqlNodeResolver Class
BoldSqlNodesResolver Namespace


TBoldSqlNodeResolver.VisitTBoldSqlLiteral Method

TBoldSqlNodeResolver.VisitTBoldSqlLiteral Method
TBoldSqlNodeResolver Class BoldSqlNodesResolver Namespace See Also
Collapse All
C#
public override void VisitTBoldSqlLiteral(
    TBoldSqlLiteral N
);
Remarks

This is VisitTBoldSqlLiteral, a member of class TBoldSqlNodeResolver.

See Also
TBoldSqlNodeResolver Class
BoldSqlNodesResolver Namespace


TBoldSqlNodeResolver.VisitTBoldSqlMember Method

TBoldSqlNodeResolver.VisitTBoldSqlMember Method
TBoldSqlNodeResolver Class BoldSqlNodesResolver Namespace See Also
Collapse All
C#
public override void VisitTBoldSqlMember(
    TBoldSqlMember N
);
Remarks

This is VisitTBoldSqlMember, a member of class TBoldSqlNodeResolver.

See Also
TBoldSqlNodeResolver Class
BoldSqlNodesResolver Namespace


TBoldSqlNodeResolver.VisitTBoldSqlNode Method

TBoldSqlNodeResolver.VisitTBoldSqlNode Method
TBoldSqlNodeResolver Class BoldSqlNodesResolver Namespace See Also
Collapse All
C#
public override void VisitTBoldSqlNode(
    TBoldSqlNode N
);
Remarks

internal

See Also
TBoldSqlNodeResolver Class
BoldSqlNodesResolver Namespace


TBoldSqlNodeResolver.VisitTBoldSqlOperation Method

TBoldSqlNodeResolver.VisitTBoldSqlOperation Method
TBoldSqlNodeResolver Class BoldSqlNodesResolver Namespace See Also
Collapse All
C#
public override void VisitTBoldSqlOperation(
    TBoldSqlOperation N
);
Remarks

This is VisitTBoldSqlOperation, a member of class TBoldSqlNodeResolver.

See Also
TBoldSqlNodeResolver Class
BoldSqlNodesResolver Namespace


TBoldSqlNodeResolver.VisitTBoldSqlStrLiteral Method

TBoldSqlNodeResolver.VisitTBoldSqlStrLiteral Method
TBoldSqlNodeResolver Class BoldSqlNodesResolver Namespace See Also
Collapse All
C#
public override void VisitTBoldSqlStrLiteral(
    TBoldSqlStrLiteral N
);
Remarks

This is VisitTBoldSqlStrLiteral, a member of class TBoldSqlNodeResolver.

See Also
TBoldSqlNodeResolver Class
BoldSqlNodesResolver Namespace


TBoldSqlNodeResolver.VisitTBoldSqlTimeLiteral Method

TBoldSqlNodeResolver.VisitTBoldSqlTimeLiteral Method
TBoldSqlNodeResolver Class BoldSqlNodesResolver Namespace See Also
Collapse All
C#
public override void VisitTBoldSqlTimeLiteral(
    TBoldSqlTimeLiteral N
);
Remarks

This is VisitTBoldSqlTimeLiteral, a member of class TBoldSqlNodeResolver.

See Also
TBoldSqlNodeResolver Class
BoldSqlNodesResolver Namespace


TBoldSqlNodeResolver.VisitTBoldSqlTypeNode Method

TBoldSqlNodeResolver.VisitTBoldSqlTypeNode Method
TBoldSqlNodeResolver Class BoldSqlNodesResolver Namespace See Also
Collapse All
C#
public override void VisitTBoldSqlTypeNode(
    TBoldSqlTypeNode N
);
Remarks

This is VisitTBoldSqlTypeNode, a member of class TBoldSqlNodeResolver.

See Also
TBoldSqlNodeResolver Class
BoldSqlNodesResolver Namespace


TBoldSqlNodeResolver.VisitTBoldSqlVariableBinding Method

TBoldSqlNodeResolver.VisitTBoldSqlVariableBinding Method
TBoldSqlNodeResolver Class BoldSqlNodesResolver Namespace See Also
Collapse All
C#
public override void VisitTBoldSqlVariableBinding(
    TBoldSqlVariableBinding N
);
Remarks

This is VisitTBoldSqlVariableBinding, a member of class TBoldSqlNodeResolver.

See Also
TBoldSqlNodeResolver Class
BoldSqlNodesResolver Namespace


TBoldSqlNodeResolver.VisitTBoldSqlVariableReference Method

TBoldSqlNodeResolver.VisitTBoldSqlVariableReference Method
TBoldSqlNodeResolver Class BoldSqlNodesResolver Namespace See Also
Collapse All
C#
public override void VisitTBoldSqlVariableReference(
    TBoldSqlVariableReference N
);
Remarks

This is VisitTBoldSqlVariableReference, a member of class TBoldSqlNodeResolver.

See Also
TBoldSqlNodeResolver Class
BoldSqlNodesResolver Namespace


BoldSQLQuery Namespace

BoldSQLQuery Namespace
Classes Enumerations
Collapse All

This is namespace BoldSQLQuery.

Classes
Name | Description
TBoldSQLAliasReference | TBoldSQLAliasReference
TBoldSqlAliasReferenceList | TBoldSqlAliasReferenceList
TBoldSQLColumnReference | TBoldSQLColumnReference
TBoldSQLJoin | TBoldSQLJoin
TBoldSQLNameSpace | TBoldSQLNameSpace
TBoldSqlOrderByColumn | end TBoldSQLWCFLiteralString
TBoldSQLQuery | TBoldSQLQuery
TBoldSqlQueryParameter | end TBoldSqlAliasReferenceList
TBoldSqlQueryParameterList | end TBoldSqlQueryParameter
TBoldSqlWCF | TBoldSqlWCF
TBoldSQLWCFBinary | TBoldSQLWCFBinary
TBoldSQLWCFBinaryInfix | TBoldSQLWCFBinaryInfix
TBoldSQLWCFBinaryPrefix | TBoldSQLWCFBinaryPrefix
TBoldSQLWCFColumnRef | TBoldSQLWCFColumnRef
TBoldSQLWCFDate | TBoldSQLWCFDate
TBoldSQLWCFExists | TBoldSQLWCFExists
TBoldSQLWCFFloat | TBoldSQLWCFFloat
TBoldSQLWCFGenericExpression | TBoldSQLWCFGenericExpression
TBoldSQLWCFGroupFunction | TBoldSQLWCFGroupFunction
TBoldSQLWCFGroupFunctionWithColumn | TBoldSQLWCFGroupFunctionWithColumn
TBoldSQLWCFInQuery | TBoldSQLWCFInQuery
TBoldSQLWCFInteger | TBoldSQLWCFInteger
TBoldSQLWCFJoin | TBoldSQLWCFJoin
TBoldSQLWCFLiteralString | TBoldSQLWCFLiteralString
TBoldSQLWCFSize | TBoldSQLWCFSize
TBoldSQLWCFString | TBoldSQLWCFString
TBoldSQLWCFTime | TBoldSQLWCFTime
TBoldSQLWCFUnary | TBoldSQLWCFUnary
TBoldSQLWCFUnaryPostfix | TBoldSQLWCFUnaryPostfix
TBoldSQLWCFUnaryPrefix | TBoldSQLWCFUnaryPrefix
TBoldSQLWCFWithQuery | TBoldSQLWCFWithQuery
Top
Enumerations
Name | Description
TBoldSQLQueryMode | end TBoldSqlOrderByColumn


TBoldSQLAliasReference Class

TBoldSQLAliasReference Class
Inheritance Hierarchy See Also
Collapse All
C#
public class TBoldSQLAliasReference;
Remarks

TBoldSQLAliasReference

Inheritance Hierarchy
BoldSQLQuery.TBoldSQLAliasReference
File

BoldSQLQuery.cs

See Also
Inheritance Hierarchy


TBoldSQLAliasReference.TBoldSQLAliasReference Constructor

TBoldSQLAliasReference.TBoldSQLAliasReference Constructor
TBoldSQLAliasReference Class BoldSQLQuery Namespace See Also
Collapse All
C#
public TBoldSQLAliasReference(
    TBoldSQLQuery Query
);
Remarks

Constructor Create( Query)

See Also
TBoldSQLAliasReference Class
BoldSQLQuery Namespace


TBoldSQLAliasReference Methods

TBoldSQLAliasReference Methods
Public Methods
Collapse All

The methods of the TBoldSQLAliasReference class are listed here.

Public Methods
Name | Description
GetColumnReference | TBoldSQLAliasReference


TBoldSQLAliasReference.GetColumnReference Method

TBoldSQLAliasReference.GetColumnReference Method
TBoldSQLAliasReference Class BoldSQLQuery Namespace See Also
Collapse All
C#
public TBoldSQLColumnReference GetColumnReference(
    string ColumnName
);
Remarks

TBoldSQLAliasReference

See Also
TBoldSQLAliasReference Class
BoldSQLQuery Namespace


TBoldSQLAliasReference Properties

TBoldSQLAliasReference Properties
Public Properties
Collapse All

The properties of the TBoldSQLAliasReference class are listed here.

Public Properties
Name | Description
AliasDefinition | This is AliasDefinition, a member of class TBoldSQLAliasReference.
AliasName | This is AliasName, a member of class TBoldSQLAliasReference.
Query | This is Query, a member of class TBoldSQLAliasReference.
TableAliasDeclaration | This is TableAliasDeclaration, a member of class TBoldSQLAliasReference.


TBoldSQLAliasReference.AliasDefinition Property

TBoldSQLAliasReference.AliasDefinition Property
TBoldSQLAliasReference Class BoldSQLQuery Namespace See Also
Collapse All
C#
public AliasDefinition AliasDefinition;
Remarks

This is AliasDefinition, a member of class TBoldSQLAliasReference.

See Also
TBoldSQLAliasReference Class
BoldSQLQuery Namespace


TBoldSQLAliasReference.AliasName Property

TBoldSQLAliasReference.AliasName Property
TBoldSQLAliasReference Class BoldSQLQuery Namespace See Also
Collapse All
C#
public string AliasName;
Remarks

This is AliasName, a member of class TBoldSQLAliasReference.

See Also
TBoldSQLAliasReference Class
BoldSQLQuery Namespace


TBoldSQLAliasReference.Query Property

TBoldSQLAliasReference.Query Property
TBoldSQLAliasReference Class BoldSQLQuery Namespace See Also
Collapse All
C#
public TBoldSQLQuery Query;
Remarks

This is Query, a member of class TBoldSQLAliasReference.

See Also
TBoldSQLAliasReference Class
BoldSQLQuery Namespace


TBoldSQLAliasReference.TableAliasDeclaration Property

TBoldSQLAliasReference.TableAliasDeclaration Property
TBoldSQLAliasReference Class BoldSQLQuery Namespace See Also
Collapse All
C#
public string TableAliasDeclaration;
Remarks

This is TableAliasDeclaration, a member of class TBoldSQLAliasReference.

See Also
TBoldSQLAliasReference Class
BoldSQLQuery Namespace


TBoldSqlAliasReferenceList Class

TBoldSqlAliasReferenceList Class
Inheritance Hierarchy See Also
Collapse All
C#
public class TBoldSqlAliasReferenceList : ArrayList;
Remarks

TBoldSqlAliasReferenceList

Inheritance Hierarchy
BoldSQLQuery.TBoldSqlAliasReferenceList
File

BoldSQLQuery.cs

See Also
Inheritance Hierarchy


TBoldSqlAliasReferenceList Methods

TBoldSqlAliasReferenceList Methods
Public Methods
Collapse All

The methods of the TBoldSqlAliasReferenceList class are listed here.

Public Methods
Name | Description
Add | TBoldSQLAliasReferenceList
Insert | This is Insert, a member of class TBoldSqlAliasReferenceList.
this | This is this, a member of class TBoldSqlAliasReferenceList.


TBoldSqlAliasReferenceList.Add Method

TBoldSqlAliasReferenceList.Add Method
TBoldSqlAliasReferenceList Class BoldSQLQuery Namespace See Also
Collapse All
C#
public int Add(
    TBoldSQLAliasReference Item
);
Remarks

TBoldSQLAliasReferenceList

See Also
TBoldSqlAliasReferenceList Class
BoldSQLQuery Namespace


TBoldSqlAliasReferenceList.Insert Method

TBoldSqlAliasReferenceList.Insert Method
TBoldSqlAliasReferenceList Class BoldSQLQuery Namespace See Also
Collapse All
C#
public void Insert(
    int Index,
    TBoldSQLAliasReference Item
);
Remarks

This is Insert, a member of class TBoldSqlAliasReferenceList.

See Also
TBoldSqlAliasReferenceList Class
BoldSQLQuery Namespace


TBoldSqlAliasReferenceList.this Indexer

TBoldSqlAliasReferenceList.this Indexer
TBoldSqlAliasReferenceList Class BoldSQLQuery Namespace See Also
Collapse All
C#
public new TBoldSQLAliasReference this[
    int Index
];
Remarks

This is this, a member of class TBoldSqlAliasReferenceList.

See Also
TBoldSqlAliasReferenceList Class
BoldSQLQuery Namespace


TBoldSQLColumnReference Class

TBoldSQLColumnReference Class
Inheritance Hierarchy See Also
Collapse All
C#
public class TBoldSQLColumnReference;
Remarks

TBoldSQLColumnReference

Inheritance Hierarchy
BoldSQLQuery.TBoldSQLColumnReference
File

BoldSQLQuery.cs

See Also
Inheritance Hierarchy


TBoldSQLColumnReference.TBoldSQLColumnReference Constructor

TBoldSQLColumnReference.TBoldSQLColumnReference Constructor
TBoldSQLColumnReference Class BoldSQLQuery Namespace See Also
Collapse All
C#
public TBoldSQLColumnReference(
    TBoldSQLAliasReference AliasReference,
    ColumnDefinition ColumnDescription
);
Remarks

TBoldSQLColumnReference Constructor create( AliasReference, ColumnDescription)

See Also
TBoldSQLColumnReference Class
BoldSQLQuery Namespace


TBoldSQLColumnReference Properties

TBoldSQLColumnReference Properties
Public Properties
Collapse All

The properties of the TBoldSQLColumnReference class are listed here.

Public Properties
Name | Description
AliasReference | This is AliasReference, a member of class TBoldSQLColumnReference.
ColumnDescription | This is ColumnDescription, a member of class TBoldSQLColumnReference.
PrefixedColumnName | This is PrefixedColumnName, a member of class TBoldSQLColumnReference.


TBoldSQLColumnReference.AliasReference Property

TBoldSQLColumnReference.AliasReference Property
TBoldSQLColumnReference Class BoldSQLQuery Namespace See Also
Collapse All
C#
public TBoldSQLAliasReference AliasReference;
Remarks

This is AliasReference, a member of class TBoldSQLColumnReference.

See Also
TBoldSQLColumnReference Class
BoldSQLQuery Namespace


TBoldSQLColumnReference.ColumnDescription Property

TBoldSQLColumnReference.ColumnDescription Property
TBoldSQLColumnReference Class BoldSQLQuery Namespace See Also
Collapse All
C#
public ColumnDefinition ColumnDescription;
Remarks

This is ColumnDescription, a member of class TBoldSQLColumnReference.

See Also
TBoldSQLColumnReference Class
BoldSQLQuery Namespace


TBoldSQLColumnReference.PrefixedColumnName Property

TBoldSQLColumnReference.PrefixedColumnName Property
TBoldSQLColumnReference Class BoldSQLQuery Namespace See Also
Collapse All
C#
public string PrefixedColumnName;
Remarks

This is PrefixedColumnName, a member of class TBoldSQLColumnReference.

See Also
TBoldSQLColumnReference Class
BoldSQLQuery Namespace


TBoldSQLJoin Class

TBoldSQLJoin Class
Inheritance Hierarchy See Also
Collapse All
C#
public class TBoldSQLJoin;
Remarks

TBoldSQLJoin

Inheritance Hierarchy
BoldSQLQuery.TBoldSQLJoin
File

BoldSQLQuery.cs

See Also
Inheritance Hierarchy


TBoldSQLJoin.TBoldSQLJoin Constructor

TBoldSQLJoin.TBoldSQLJoin Constructor
TBoldSQLJoin Class BoldSQLQuery Namespace See Also
Collapse All
C#
public TBoldSQLJoin(
    TBoldSQLColumnReference ColumnRef1,
    TBoldSQLColumnReference ColumnRef2
);
Remarks

TBoldSQLJoin Constructor Create( ColumnRef1, ColumnRef2)

See Also
TBoldSQLJoin Class
BoldSQLQuery Namespace


TBoldSQLJoin Methods

TBoldSQLJoin Methods
Public Methods
Collapse All

The methods of the TBoldSQLJoin class are listed here.

Public Methods
Name | Description
Matches | This is Matches, a member of class TBoldSQLJoin.


TBoldSQLJoin.Matches Method

TBoldSQLJoin.Matches Method
TBoldSQLJoin Class BoldSQLQuery Namespace See Also
Collapse All
C#
public bool Matches(
    TBoldSQLColumnReference ColumnRef1,
    TBoldSQLColumnReference ColumnRef2
);
Remarks

This is Matches, a member of class TBoldSQLJoin.

See Also
TBoldSQLJoin Class
BoldSQLQuery Namespace


TBoldSQLJoin Properties

TBoldSQLJoin Properties
Public Properties
Collapse All

The properties of the TBoldSQLJoin class are listed here.

Public Properties
Name | Description
JoinStatement | This is JoinStatement, a member of class TBoldSQLJoin.


TBoldSQLJoin.JoinStatement Property

TBoldSQLJoin.JoinStatement Property
TBoldSQLJoin Class BoldSQLQuery Namespace See Also
Collapse All
C#
public string JoinStatement;
Remarks

This is JoinStatement, a member of class TBoldSQLJoin.

See Also
TBoldSQLJoin Class
BoldSQLQuery Namespace


TBoldSQLNameSpace Class

TBoldSQLNameSpace Class
Inheritance Hierarchy See Also
Collapse All
C#
public class TBoldSQLNameSpace;
Remarks

TBoldSQLNameSpace

Inheritance Hierarchy
BoldSQLQuery.TBoldSQLNameSpace
File

BoldSQLQuery.cs

See Also
Inheritance Hierarchy


TBoldSQLNameSpace.TBoldSQLNameSpace Constructor

TBoldSQLNameSpace.TBoldSQLNameSpace Constructor
TBoldSQLNameSpace Class BoldSQLQuery Namespace See Also
Collapse All
C#
public TBoldSQLNameSpace(
    IDatabase Database
);
Remarks

TBoldSQLNameSpace Constructor Create( Database)

See Also
TBoldSQLNameSpace Class
BoldSQLQuery Namespace


TBoldSQLNameSpace Methods

TBoldSQLNameSpace Methods
Public Methods
Collapse All

The methods of the TBoldSQLNameSpace class are listed here.

Public Methods
Name | Description
GetUniqueAlias | This is GetUniqueAlias, a member of class TBoldSQLNameSpace.
GetUnusedParamNumber | This is GetUnusedParamNumber, a member of class TBoldSQLNameSpace.


TBoldSQLNameSpace.GetUniqueAlias Method

TBoldSQLNameSpace.GetUniqueAlias Method
TBoldSQLNameSpace Class BoldSQLQuery Namespace See Also
Collapse All
C#
public string GetUniqueAlias(
    string TableName
);
Remarks

This is GetUniqueAlias, a member of class TBoldSQLNameSpace.

See Also
TBoldSQLNameSpace Class
BoldSQLQuery Namespace


TBoldSQLNameSpace.GetUnusedParamNumber Method

TBoldSQLNameSpace.GetUnusedParamNumber Method
TBoldSQLNameSpace Class BoldSQLQuery Namespace See Also
Collapse All
C#
public int GetUnusedParamNumber();
Remarks

This is GetUnusedParamNumber, a member of class TBoldSQLNameSpace.

See Also
TBoldSQLNameSpace Class
BoldSQLQuery Namespace


TBoldSQLNameSpace Properties

TBoldSQLNameSpace Properties
Public Properties
Collapse All

The properties of the TBoldSQLNameSpace class are listed here.

Public Properties
Name | Description
Database | This is Database, a member of class TBoldSQLNameSpace.


TBoldSQLNameSpace.Database Property

TBoldSQLNameSpace.Database Property
TBoldSQLNameSpace Class BoldSQLQuery Namespace See Also
Collapse All
C#
public IDatabase Database;
Remarks

This is Database, a member of class TBoldSQLNameSpace.

See Also
TBoldSQLNameSpace Class
BoldSQLQuery Namespace


TBoldSqlOrderByColumn Class

TBoldSqlOrderByColumn Class
Inheritance Hierarchy See Also
Collapse All
C#
public class TBoldSqlOrderByColumn;
Remarks

end TBoldSQLWCFLiteralString

Inheritance Hierarchy
BoldSQLQuery.TBoldSqlOrderByColumn
File

BoldSQLQuery.cs

See Also
Inheritance Hierarchy


TBoldSqlOrderByColumn.TBoldSqlOrderByColumn Constructor

TBoldSqlOrderByColumn.TBoldSqlOrderByColumn Constructor
TBoldSqlOrderByColumn Class BoldSQLQuery Namespace See Also
Collapse All
C#
public TBoldSqlOrderByColumn(
    OclSortDirection Direction,
    TBoldSQLColumnReference ColumnRef
);
Remarks

TBoldSqlOrderByColumn Constructor create( Direction, ColumnRef)

See Also
TBoldSqlOrderByColumn Class
BoldSQLQuery Namespace


TBoldSqlOrderByColumn Properties

TBoldSqlOrderByColumn Properties
Public Properties
Collapse All

The properties of the TBoldSqlOrderByColumn class are listed here.

Public Properties
Name | Description
ColumnRef | This is ColumnRef, a member of class TBoldSqlOrderByColumn.
Direction | This is Direction, a member of class TBoldSqlOrderByColumn.


TBoldSqlOrderByColumn.ColumnRef Property

TBoldSqlOrderByColumn.ColumnRef Property
TBoldSqlOrderByColumn Class BoldSQLQuery Namespace See Also
Collapse All
C#
public TBoldSQLColumnReference ColumnRef;
Remarks

This is ColumnRef, a member of class TBoldSqlOrderByColumn.

See Also
TBoldSqlOrderByColumn Class
BoldSQLQuery Namespace


TBoldSqlOrderByColumn.Direction Property

TBoldSqlOrderByColumn.Direction Property
TBoldSqlOrderByColumn Class BoldSQLQuery Namespace See Also
Collapse All
C#
public OclSortDirection Direction;
Remarks

This is Direction, a member of class TBoldSqlOrderByColumn.

See Also
TBoldSqlOrderByColumn Class
BoldSQLQuery Namespace


TBoldSQLQuery Class

TBoldSQLQuery Class
Inheritance Hierarchy See Also
Collapse All
C#
public class TBoldSQLQuery;
Remarks

TBoldSQLQuery

Inheritance Hierarchy
BoldSQLQuery.TBoldSQLQuery
File

BoldSQLQuery.cs

See Also
Inheritance Hierarchy


TBoldSQLQuery.TBoldSQLQuery Constructor

TBoldSQLQuery.TBoldSQLQuery Constructor
TBoldSQLQuery Class BoldSQLQuery Namespace See Also
Collapse All
C#
public TBoldSQLQuery(
    TBoldSQLQueryMode Mode,
    SqlDatabaseConfig SQLDatabaseConfig,
    TBoldSQLNameSpace __NameSpace
);
Remarks

procedure TBoldSQLQuery.AddVersionJoins(alias, alias2: TBoldSqlAliasReference; ObjectMapper: TBoldObjectPersistenceMapper); var RootAlias: AliasDefinition; RootAliasRef: TBoldSQLAliasReference; NowTimeWCF: TBoldSQLWCFInteger; EndTimeColWCF: TBoldSQLWCFColumnRef; MyIdCol, RootIdCol, MyStartCol, RootStartCol: TBoldSQLColumnReference; begin if alias.TableDescription.Versioned and IgnoreHistoricObjects then begin if alias.Table = ObjectMapper.StopTimeAlias.Table then begin NowTimeWCF := TBoldSQLWCFInteger.Create(BOLDMAXTIMESTAMP); EndTimeColWCF := TBoldSQLWCFColumnRef.Create(Result.GetColumnReference(TIMESTAMPSTOPCOLUMNNAME)); AddWCF(TBoldSQLWCFBinaryInfix.Create(NowTimeWCF, EndTimeColWCF, '=')); end else begin RootAliasRef := AddAliasReference(RootAlias.SqlName);

MyStartCol := Result.GetColumnReference(TIMESTAMPSTARTCOLUMNNAME); RootStartCol := RootAliasRef.GetColumnReference(TIMESTAMPSTARTCOLUMNNAME); AddJoin(MyStartCol, RootStartCol); MyIdCol := Result.GetColumnReference(IDCOLUMN_NAME); RootIdCol := RootAliasRef.GetColumnReference(IDCOLUMN_NAME); AddJoin(MyIdCol, RootIdCol); end; end; end; Constructor Create( Mode, SQLDatabaseConfig, __NameSpace)

See Also
TBoldSQLQuery Class
BoldSQLQuery Namespace


TBoldSQLQuery Methods

TBoldSQLQuery Methods
Protected Methods Public Methods
Collapse All

The methods of the TBoldSQLQuery class are listed here.

Protected Methods
Name | Description
GetJoin | This is GetJoin, a member of class TBoldSQLQuery.
GetWCF | This is GetWCF, a member of class TBoldSQLQuery.
Top
Public Methods
Name | Description
AddAliasReference | TBoldSQLQuery
AddColumnToOrderBy | This is AddColumnToOrderBy, a member of class TBoldSQLQuery.
AddColumnToRetrieve | This is AddColumnToRetrieve, a member of class TBoldSQLQuery.
AddJoin | SystemDescription: TBoldSQLSystemDescription;
AddParam | This is AddParam, a member of class TBoldSQLQuery.
AddWCF | This is AddWCF, a member of class TBoldSQLQuery.
ClearColumnsToRetrieve | This is ClearColumnsToRetrieve, a member of class TBoldSQLQuery.
GenerateSQL | This is GenerateSQL, a member of class TBoldSQLQuery.
GetColumnToRetrieve | This is GetColumnToRetrieve, a member of class TBoldSQLQuery.
HasAliasReferenceInList | This is HasAliasReferenceInList, a member of class TBoldSQLQuery.
RetrieveCountStar | This is RetrieveCountStar, a member of class TBoldSQLQuery.


TBoldSQLQuery.AddAliasReference Method

TBoldSQLQuery.AddAliasReference Method
TBoldSQLQuery Class BoldSQLQuery Namespace See Also
Collapse All
C#
public TBoldSQLAliasReference AddAliasReference(
    AliasDefinition AliasDefinition
);
Remarks

TBoldSQLQuery

See Also
TBoldSQLQuery Class
BoldSQLQuery Namespace


TBoldSQLQuery.AddColumnToOrderBy Method

TBoldSQLQuery.AddColumnToOrderBy Method
TBoldSQLQuery Class BoldSQLQuery Namespace See Also
Collapse All
C#
public void AddColumnToOrderBy(
    TBoldSQLColumnReference Columnreference,
    OclSortDirection Direction
);
Remarks

This is AddColumnToOrderBy, a member of class TBoldSQLQuery.

See Also
TBoldSQLQuery Class
BoldSQLQuery Namespace


TBoldSQLQuery.AddColumnToRetrieve Method

TBoldSQLQuery.AddColumnToRetrieve Method
TBoldSQLQuery Class BoldSQLQuery Namespace See Also
Collapse All
C#
public void AddColumnToRetrieve(
    TBoldSQLColumnReference ColumnReference
);
Remarks

This is AddColumnToRetrieve, a member of class TBoldSQLQuery.

See Also
TBoldSQLQuery Class
BoldSQLQuery Namespace


TBoldSQLQuery.AddJoin Method

TBoldSQLQuery.AddJoin Method
TBoldSQLQuery Class BoldSQLQuery Namespace See Also
Collapse All
C#
public TBoldSQLJoin AddJoin(
    TBoldSQLColumnReference ColumnRef1,
    TBoldSQLColumnReference ColumnRef2
);
Remarks

SystemDescription: TBoldSQLSystemDescription;

See Also
TBoldSQLQuery Class
BoldSQLQuery Namespace


TBoldSQLQuery.AddParam Method

TBoldSQLQuery.AddParam Method
TBoldSQLQuery Class BoldSQLQuery Namespace See Also
Collapse All
C#
public TBoldSqlQueryParameter AddParam(
    string name,
    System.Data.DbType FieldType
);
Remarks

This is AddParam, a member of class TBoldSQLQuery.

See Also
TBoldSQLQuery Class
BoldSQLQuery Namespace


TBoldSQLQuery.AddWCF Method

TBoldSQLQuery.AddWCF Method
TBoldSQLQuery Class BoldSQLQuery Namespace See Also
Collapse All
C#
public void AddWCF(
    TBoldSqlWCF WCF
);
Remarks

This is AddWCF, a member of class TBoldSQLQuery.

See Also
TBoldSQLQuery Class
BoldSQLQuery Namespace


TBoldSQLQuery.ClearColumnsToRetrieve Method

TBoldSQLQuery.ClearColumnsToRetrieve Method
TBoldSQLQuery Class BoldSQLQuery Namespace See Also
Collapse All
C#
public void ClearColumnsToRetrieve();
Remarks

This is ClearColumnsToRetrieve, a member of class TBoldSQLQuery.

See Also
TBoldSQLQuery Class
BoldSQLQuery Namespace


TBoldSQLQuery.GenerateSQL Method

TBoldSQLQuery.GenerateSQL Method
TBoldSQLQuery Class BoldSQLQuery Namespace See Also
Collapse All
C#
public void GenerateSQL(
    IList<string> Strings
);
Remarks

This is GenerateSQL, a member of class TBoldSQLQuery.

See Also
TBoldSQLQuery Class
BoldSQLQuery Namespace


TBoldSQLQuery.GetColumnToRetrieve Method

TBoldSQLQuery.GetColumnToRetrieve Method
TBoldSQLQuery Class BoldSQLQuery Namespace See Also
Collapse All
C#
public TBoldSQLColumnReference GetColumnToRetrieve(
    int Index
);
Remarks

This is GetColumnToRetrieve, a member of class TBoldSQLQuery.

See Also
TBoldSQLQuery Class
BoldSQLQuery Namespace


TBoldSQLQuery.GetJoin Method

TBoldSQLQuery.GetJoin Method
TBoldSQLQuery Class BoldSQLQuery Namespace See Also
Collapse All
C#
protected TBoldSQLJoin GetJoin(
    int index
);
Remarks

This is GetJoin, a member of class TBoldSQLQuery.

See Also
TBoldSQLQuery Class
BoldSQLQuery Namespace


TBoldSQLQuery.GetWCF Method

TBoldSQLQuery.GetWCF Method
TBoldSQLQuery Class BoldSQLQuery Namespace See Also
Collapse All
C#
protected TBoldSqlWCF GetWCF(
    int index
);
Remarks

This is GetWCF, a member of class TBoldSQLQuery.

See Also
TBoldSQLQuery Class
BoldSQLQuery Namespace


TBoldSQLQuery.HasAliasReferenceInList Method

TBoldSQLQuery.HasAliasReferenceInList Method
TBoldSQLQuery Class BoldSQLQuery Namespace See Also
Collapse All
C#
public bool HasAliasReferenceInList(
    TBoldSQLAliasReference AliasReference
);
Remarks

This is HasAliasReferenceInList, a member of class TBoldSQLQuery.

See Also
TBoldSQLQuery Class
BoldSQLQuery Namespace


TBoldSQLQuery.RetrieveCountStar Method

TBoldSQLQuery.RetrieveCountStar Method
TBoldSQLQuery Class BoldSQLQuery Namespace See Also
Collapse All
C#
public void RetrieveCountStar();
Remarks

This is RetrieveCountStar, a member of class TBoldSQLQuery.

See Also
TBoldSQLQuery Class
BoldSQLQuery Namespace


TBoldSQLQuery Properties

TBoldSQLQuery Properties
Public Properties Protected Properties
Collapse All

The properties of the TBoldSQLQuery class are listed here.

Public Properties
Name | Description
IgnoreHistoricObjects | <- Expose params so we may Copy them to real Query (HK)
MainAlias | This is MainAlias, a member of class TBoldSQLQuery.
Mode | This is Mode, a member of class TBoldSQLQuery.
Params | This is Params, a member of class TBoldSQLQuery.
SQLDatabaseConfig | This is SQLDatabaseConfig, a member of class TBoldSQLQuery.
Top
Protected Properties
Name | Description
AliasReferences | This is AliasReferences, a member of class TBoldSQLQuery.


TBoldSQLQuery.AliasReferences Property

TBoldSQLQuery.AliasReferences Property
TBoldSQLQuery Class BoldSQLQuery Namespace See Also
Collapse All
C#
protected TBoldSqlAliasReferenceList AliasReferences;
Remarks

This is AliasReferences, a member of class TBoldSQLQuery.

See Also
TBoldSQLQuery Class
BoldSQLQuery Namespace


TBoldSQLQuery.IgnoreHistoricObjects Property

TBoldSQLQuery.IgnoreHistoricObjects Property
TBoldSQLQuery Class BoldSQLQuery Namespace See Also
Collapse All
C#
public bool IgnoreHistoricObjects;
Remarks

<- Expose params so we may Copy them to real Query (HK)

See Also
TBoldSQLQuery Class
BoldSQLQuery Namespace


TBoldSQLQuery.MainAlias Property

TBoldSQLQuery.MainAlias Property
TBoldSQLQuery Class BoldSQLQuery Namespace See Also
Collapse All
C#
public TBoldSQLAliasReference MainAlias;
Remarks

This is MainAlias, a member of class TBoldSQLQuery.

See Also
TBoldSQLQuery Class
BoldSQLQuery Namespace


TBoldSQLQuery.Mode Property

TBoldSQLQuery.Mode Property
TBoldSQLQuery Class BoldSQLQuery Namespace See Also
Collapse All
C#
public TBoldSQLQueryMode Mode;
Remarks

This is Mode, a member of class TBoldSQLQuery.

See Also
TBoldSQLQuery Class
BoldSQLQuery Namespace


TBoldSQLQuery.Params Property

TBoldSQLQuery.Params Property
TBoldSQLQuery Class BoldSQLQuery Namespace See Also
Collapse All
C#
public TBoldSqlQueryParameterList Params;
Remarks

This is Params, a member of class TBoldSQLQuery.

See Also
TBoldSQLQuery Class
BoldSQLQuery Namespace


TBoldSQLQuery.SQLDatabaseConfig Property

TBoldSQLQuery.SQLDatabaseConfig Property
TBoldSQLQuery Class BoldSQLQuery Namespace See Also
Collapse All
C#
public SqlDatabaseConfig SQLDatabaseConfig;
Remarks

This is SQLDatabaseConfig, a member of class TBoldSQLQuery.

See Also
TBoldSQLQuery Class
BoldSQLQuery Namespace


TBoldSqlQueryParameter Class

TBoldSqlQueryParameter Class
Inheritance Hierarchy See Also
Collapse All
C#
public class TBoldSqlQueryParameter;
Remarks

end TBoldSqlAliasReferenceList

Inheritance Hierarchy
BoldSQLQuery.TBoldSqlQueryParameter
File

BoldSQLQuery.cs

See Also
Inheritance Hierarchy


TBoldSqlQueryParameter.TBoldSqlQueryParameter Constructor

TBoldSqlQueryParameter.TBoldSqlQueryParameter Constructor
TBoldSqlQueryParameter Class BoldSQLQuery Namespace See Also
Collapse All
C#
public TBoldSqlQueryParameter(
    string Name,
    System.Data.DbType FieldType
);
Remarks

TBoldSqlQueryParameter Constructor Create( Name, FieldType)

See Also
TBoldSqlQueryParameter Class
BoldSQLQuery Namespace


TBoldSqlQueryParameter Properties

TBoldSqlQueryParameter Properties
Public Properties
Collapse All

The properties of the TBoldSqlQueryParameter class are listed here.

Public Properties
Name | Description
FieldType | This is FieldType, a member of class TBoldSqlQueryParameter.
Name | This is Name, a member of class TBoldSqlQueryParameter.
Value | This is Value, a member of class TBoldSqlQueryParameter.


TBoldSqlQueryParameter.FieldType Property

TBoldSqlQueryParameter.FieldType Property
TBoldSqlQueryParameter Class BoldSQLQuery Namespace See Also
Collapse All
C#
public System.Data.DbType FieldType;
Remarks

This is FieldType, a member of class TBoldSqlQueryParameter.

See Also
TBoldSqlQueryParameter Class
BoldSQLQuery Namespace


TBoldSqlQueryParameter.Name Property

TBoldSqlQueryParameter.Name Property
TBoldSqlQueryParameter Class BoldSQLQuery Namespace See Also
Collapse All
C#
public string Name;
Remarks

This is Name, a member of class TBoldSqlQueryParameter.

See Also
TBoldSqlQueryParameter Class
BoldSQLQuery Namespace


TBoldSqlQueryParameter.Value Property

TBoldSqlQueryParameter.Value Property
TBoldSqlQueryParameter Class BoldSQLQuery Namespace See Also
Collapse All
C#
public object Value;
Remarks

This is Value, a member of class TBoldSqlQueryParameter.

See Also
TBoldSqlQueryParameter Class
BoldSQLQuery Namespace


TBoldSqlQueryParameterList Class

TBoldSqlQueryParameterList Class
Inheritance Hierarchy See Also
Collapse All
C#
public class TBoldSqlQueryParameterList;
Remarks

end TBoldSqlQueryParameter

Inheritance Hierarchy
BoldSQLQuery.TBoldSqlQueryParameterList
File

BoldSQLQuery.cs

See Also
Inheritance Hierarchy


TBoldSqlQueryParameterList.TBoldSqlQueryParameterList Constructor

TBoldSqlQueryParameterList.TBoldSqlQueryParameterList Constructor
TBoldSqlQueryParameterList Class BoldSQLQuery Namespace See Also
Collapse All
C#
public TBoldSqlQueryParameterList(
    TBoldSQLQuery Query
);
Remarks

Constructor create( Query)

See Also
TBoldSqlQueryParameterList Class
BoldSQLQuery Namespace


TBoldSqlQueryParameterList Methods

TBoldSqlQueryParameterList Methods
Public Methods
Collapse All

The methods of the TBoldSqlQueryParameterList class are listed here.

Public Methods
Name | Description
AddParam | TBoldSqlQueryParameterList
FindParam | This is FindParam, a member of class TBoldSqlQueryParameterList.
this | This is this, a member of class TBoldSqlQueryParameterList.
TransferParams | This is TransferParams, a member of class TBoldSqlQueryParameterList.


TBoldSqlQueryParameterList.AddParam Method

TBoldSqlQueryParameterList.AddParam Method
TBoldSqlQueryParameterList Class BoldSQLQuery Namespace See Also
Collapse All
C#
public TBoldSqlQueryParameter AddParam(
    string Name,
    System.Data.DbType FieldType
);
Remarks

TBoldSqlQueryParameterList

See Also
TBoldSqlQueryParameterList Class
BoldSQLQuery Namespace


TBoldSqlQueryParameterList.FindParam Method

TBoldSqlQueryParameterList.FindParam Method
TBoldSqlQueryParameterList Class BoldSQLQuery Namespace See Also
Collapse All
C#
public TBoldSqlQueryParameter FindParam(
    string Name
);
Remarks

This is FindParam, a member of class TBoldSqlQueryParameterList.

See Also
TBoldSqlQueryParameterList Class
BoldSQLQuery Namespace


TBoldSqlQueryParameterList.this Indexer

TBoldSqlQueryParameterList.this Indexer
TBoldSqlQueryParameterList Class BoldSQLQuery Namespace See Also
Collapse All
C#
public TBoldSqlQueryParameter this[
    int i
];
Remarks

This is this, a member of class TBoldSqlQueryParameterList.

See Also
TBoldSqlQueryParameterList Class
BoldSQLQuery Namespace


TBoldSqlQueryParameterList.TransferParams Method

TBoldSqlQueryParameterList.TransferParams Method
TBoldSqlQueryParameterList Class BoldSQLQuery Namespace See Also
Collapse All
C#
public void TransferParams(
    IParameterized Parameterized
);
Remarks

This is TransferParams, a member of class TBoldSqlQueryParameterList.

See Also
TBoldSqlQueryParameterList Class
BoldSQLQuery Namespace


TBoldSqlQueryParameterList Properties

TBoldSqlQueryParameterList Properties
Public Properties
Collapse All

The properties of the TBoldSqlQueryParameterList class are listed here.

Public Properties
Name | Description
Count | This is Count, a member of class TBoldSqlQueryParameterList.


TBoldSqlQueryParameterList.Count Property

TBoldSqlQueryParameterList.Count Property
TBoldSqlQueryParameterList Class BoldSQLQuery Namespace See Also
Collapse All
C#
public int Count;
Remarks

This is Count, a member of class TBoldSqlQueryParameterList.

See Also
TBoldSqlQueryParameterList Class
BoldSQLQuery Namespace


TBoldSqlWCF Class

TBoldSqlWCF Class
Inheritance Hierarchy See Also
Collapse All
C#
public abstract class TBoldSqlWCF;
Remarks

TBoldSqlWCF

Inheritance Hierarchy
BoldSQLQuery.TBoldSqlWCF
    BoldSqlNodes.TBoldSQLWCFVariable
    BoldSQLQuery.TBoldSQLWCFBinary
    BoldSQLQuery.TBoldSQLWCFColumnRef
    BoldSQLQuery.TBoldSQLWCFDate
    BoldSQLQuery.TBoldSQLWCFFloat
    BoldSQLQuery.TBoldSQLWCFGenericExpression
    BoldSQLQuery.TBoldSQLWCFInteger
    BoldSQLQuery.TBoldSQLWCFJoin
    BoldSQLQuery.TBoldSQLWCFLiteralString
    BoldSQLQuery.TBoldSQLWCFString
    BoldSQLQuery.TBoldSQLWCFTime
    BoldSQLQuery.TBoldSQLWCFUnary
    BoldSQLQuery.TBoldSQLWCFWithQuery
File

BoldSQLQuery.cs

See Also
Inheritance Hierarchy


TBoldSqlWCF Methods

TBoldSqlWCF Methods
Public Methods
Collapse All

The methods of the TBoldSqlWCF class are listed here.

Public Methods
Name | Description
GetAsString | This is GetAsString, a member of class TBoldSqlWCF.


TBoldSqlWCF.GetAsString Method

TBoldSqlWCF.GetAsString Method
TBoldSqlWCF Class BoldSQLQuery Namespace See Also
Collapse All
C#
public abstract string GetAsString(
    TBoldSQLQuery Query
);
Remarks

This is GetAsString, a member of class TBoldSqlWCF.

See Also
TBoldSqlWCF Class
BoldSQLQuery Namespace


TBoldSQLWCFBinary Class

TBoldSQLWCFBinary Class
Inheritance Hierarchy See Also
Collapse All
C#
public abstract class TBoldSQLWCFBinary : TBoldSqlWCF;
Remarks

TBoldSQLWCFBinary

Inheritance Hierarchy
BoldSQLQuery.TBoldSqlWCF
    BoldSQLQuery.TBoldSQLWCFBinary
        BoldSQLQuery.TBoldSQLWCFBinaryInfix
        BoldSQLQuery.TBoldSQLWCFBinaryPrefix
File

BoldSQLQuery.cs

See Also
Inheritance Hierarchy


TBoldSQLWCFBinary.TBoldSQLWCFBinary Constructor

TBoldSQLWCFBinary.TBoldSQLWCFBinary Constructor
TBoldSQLWCFBinary Class BoldSQLQuery Namespace See Also
Collapse All
C#
public TBoldSQLWCFBinary(
    TBoldSqlWCF arg1,
    TBoldSqlWCF arg2,
    string Symbol
);
Remarks

TBoldSQLWCFBinary Constructor Create( arg1, arg2, Symbol)

See Also
TBoldSQLWCFBinary Class
BoldSQLQuery Namespace


TBoldSQLWCFBinary Fields

TBoldSQLWCFBinary Fields
Protected Fields
Collapse All

The fields of the TBoldSQLWCFBinary class are listed here.

Protected Fields
Name | Description
fArg1 | This is fArg1, a member of class TBoldSQLWCFBinary.
fArg2 | This is fArg2, a member of class TBoldSQLWCFBinary.
fSymbol | This is fSymbol, a member of class TBoldSQLWCFBinary.


TBoldSQLWCFBinary.fArg1 Field

TBoldSQLWCFBinary.fArg1 Field
TBoldSQLWCFBinary Class BoldSQLQuery Namespace See Also
Collapse All
C#
protected TBoldSqlWCF fArg1 = null;
Remarks

This is fArg1, a member of class TBoldSQLWCFBinary.

See Also
TBoldSQLWCFBinary Class
BoldSQLQuery Namespace


TBoldSQLWCFBinary.fArg2 Field

TBoldSQLWCFBinary.fArg2 Field
TBoldSQLWCFBinary Class BoldSQLQuery Namespace See Also
Collapse All
C#
protected TBoldSqlWCF fArg2 = null;
Remarks

This is fArg2, a member of class TBoldSQLWCFBinary.

See Also
TBoldSQLWCFBinary Class
BoldSQLQuery Namespace


TBoldSQLWCFBinary.fSymbol Field

TBoldSQLWCFBinary.fSymbol Field
TBoldSQLWCFBinary Class BoldSQLQuery Namespace See Also
Collapse All
C#
protected string fSymbol = String.Empty;
Remarks

This is fSymbol, a member of class TBoldSQLWCFBinary.

See Also
TBoldSQLWCFBinary Class
BoldSQLQuery Namespace


TBoldSQLWCFBinaryInfix Class

TBoldSQLWCFBinaryInfix Class
Inheritance Hierarchy See Also
Collapse All
C#
public class TBoldSQLWCFBinaryInfix : TBoldSQLWCFBinary;
Remarks

TBoldSQLWCFBinaryInfix

Inheritance Hierarchy
BoldSQLQuery.TBoldSqlWCF
    BoldSQLQuery.TBoldSQLWCFBinary
        BoldSQLQuery.TBoldSQLWCFBinaryInfix
File

BoldSQLQuery.cs

See Also
Inheritance Hierarchy


TBoldSQLWCFBinaryInfix Constructor

TBoldSQLWCFBinaryInfix Constructor
Collapse All

This is the overview for the TBoldSQLWCFBinaryInfix constructor overload.

Overload List
Name | Description
TBoldSQLWCFBinaryInfix.TBoldSQLWCFBinaryInfix (TBoldSqlWCF, TBoldSqlWCF, string) | TBoldSQLWCFBinaryInfix Constructor Create( arg1, arg2, Symbol)
TBoldSQLWCFBinaryInfix.TBoldSQLWCFBinaryInfix (TBoldSqlWCF, TBoldSqlWCF, string, bool) | Constructor Create( arg1, arg2, Symbol, NeedsParenthesis)


TBoldSQLWCFBinaryInfix.TBoldSQLWCFBinaryInfix Constructor (TBoldSqlWCF, TBoldSqlWCF, string)

TBoldSQLWCFBinaryInfix.TBoldSQLWCFBinaryInfix Constructor (TBoldSqlWCF, TBoldSqlWCF, string)
TBoldSQLWCFBinaryInfix Class BoldSQLQuery Namespace See Also
Collapse All
C#
public TBoldSQLWCFBinaryInfix(
    TBoldSqlWCF arg1,
    TBoldSqlWCF arg2,
    string Symbol
);
Remarks

TBoldSQLWCFBinaryInfix Constructor Create( arg1, arg2, Symbol)

See Also
TBoldSQLWCFBinaryInfix Class
BoldSQLQuery Namespace


TBoldSQLWCFBinaryInfix.TBoldSQLWCFBinaryInfix Constructor (TBoldSqlWCF, TBoldSqlWCF, string, bool)

TBoldSQLWCFBinaryInfix.TBoldSQLWCFBinaryInfix Constructor (TBoldSqlWCF, TBoldSqlWCF, string, bool)
TBoldSQLWCFBinaryInfix Class BoldSQLQuery Namespace See Also
Collapse All
C#
public TBoldSQLWCFBinaryInfix(
    TBoldSqlWCF arg1,
    TBoldSqlWCF arg2,
    string Symbol,
    bool NeedsParenthesis
);
Remarks

Constructor Create( arg1, arg2, Symbol, NeedsParenthesis)

See Also
TBoldSQLWCFBinaryInfix Class
BoldSQLQuery Namespace


TBoldSQLWCFBinaryInfix Methods

TBoldSQLWCFBinaryInfix Methods
Public Methods
Collapse All

The methods of the TBoldSQLWCFBinaryInfix class are listed here.

Public Methods
Name | Description
CommaSeparatedIdList | This is CommaSeparatedIdList, a member of class TBoldSQLWCFBinaryInfix.
CreateWCFForIdCollection | This is CreateWCFForIdCollection, a member of class TBoldSQLWCFBinaryInfix.
CreateWCFForIdList | This is CreateWCFForIdList, a member of class TBoldSQLWCFBinaryInfix.
GetAsString | This is GetAsString, a member of class TBoldSQLWCFBinaryInfix.
GetStringRep | This is GetStringRep, a member of class TBoldSQLWCFBinaryInfix.


TBoldSQLWCFBinaryInfix.CommaSeparatedIdList Method

TBoldSQLWCFBinaryInfix.CommaSeparatedIdList Method
TBoldSQLWCFBinaryInfix Class BoldSQLQuery Namespace See Also
Collapse All
C#
public static string CommaSeparatedIdList(
    ObjectIdCollection IdList,
    SqlDatabaseConfig Config
);
Remarks

This is CommaSeparatedIdList, a member of class TBoldSQLWCFBinaryInfix.

See Also
TBoldSQLWCFBinaryInfix Class
BoldSQLQuery Namespace


TBoldSQLWCFBinaryInfix.CreateWCFForIdCollection Method

TBoldSQLWCFBinaryInfix.CreateWCFForIdCollection Method
TBoldSQLWCFBinaryInfix Class BoldSQLQuery Namespace See Also
Collapse All
C#
public static TBoldSQLWCFBinaryInfix CreateWCFForIdCollection(
    TBoldSQLColumnReference ColumnRef,
    ObjectIdCollection IdList
);
Remarks

This is CreateWCFForIdCollection, a member of class TBoldSQLWCFBinaryInfix.

See Also
TBoldSQLWCFBinaryInfix Class
BoldSQLQuery Namespace


TBoldSQLWCFBinaryInfix.CreateWCFForIdList Method

TBoldSQLWCFBinaryInfix.CreateWCFForIdList Method
TBoldSQLWCFBinaryInfix Class BoldSQLQuery Namespace See Also
Collapse All
C#
public static TBoldSQLWCFBinaryInfix CreateWCFForIdList(
    TBoldSQLColumnReference ColumnRef,
    ObjectIdList IdList
);
Remarks

This is CreateWCFForIdList, a member of class TBoldSQLWCFBinaryInfix.

See Also
TBoldSQLWCFBinaryInfix Class
BoldSQLQuery Namespace


TBoldSQLWCFBinaryInfix.GetAsString Method

TBoldSQLWCFBinaryInfix.GetAsString Method
TBoldSQLWCFBinaryInfix Class BoldSQLQuery Namespace See Also
Collapse All
C#
public override string GetAsString(
    TBoldSQLQuery Query
);
Remarks

This is GetAsString, a member of class TBoldSQLWCFBinaryInfix.

See Also
TBoldSQLWCFBinaryInfix Class
BoldSQLQuery Namespace


TBoldSQLWCFBinaryInfix.GetStringRep Method

TBoldSQLWCFBinaryInfix.GetStringRep Method
TBoldSQLWCFBinaryInfix Class BoldSQLQuery Namespace See Also
Collapse All
C#
public static string GetStringRep(
    Object value,
    SqlDatabaseConfig Config
);
Remarks

This is GetStringRep, a member of class TBoldSQLWCFBinaryInfix.

See Also
TBoldSQLWCFBinaryInfix Class
BoldSQLQuery Namespace


TBoldSQLWCFBinaryPrefix Class

TBoldSQLWCFBinaryPrefix Class
Inheritance Hierarchy See Also
Collapse All
C#
public class TBoldSQLWCFBinaryPrefix : TBoldSQLWCFBinary;
Remarks

TBoldSQLWCFBinaryPrefix

Inheritance Hierarchy
BoldSQLQuery.TBoldSqlWCF
    BoldSQLQuery.TBoldSQLWCFBinary
        BoldSQLQuery.TBoldSQLWCFBinaryPrefix
File

BoldSQLQuery.cs

See Also
Inheritance Hierarchy


TBoldSQLWCFBinaryPrefix.TBoldSQLWCFBinaryPrefix Constructor

TBoldSQLWCFBinaryPrefix.TBoldSQLWCFBinaryPrefix Constructor
TBoldSQLWCFBinaryPrefix Class BoldSQLQuery Namespace See Also
Collapse All
C#
public TBoldSQLWCFBinaryPrefix(
    TBoldSqlWCF arg1,
    TBoldSqlWCF arg2,
    string Symbol
);
Remarks

Constructors

See Also
TBoldSQLWCFBinaryPrefix Class
BoldSQLQuery Namespace


TBoldSQLWCFBinaryPrefix Methods

TBoldSQLWCFBinaryPrefix Methods
Public Methods
Collapse All

The methods of the TBoldSQLWCFBinaryPrefix class are listed here.

Public Methods
Name | Description
GetAsString | TBoldSQLWCFBinaryPrefix


TBoldSQLWCFBinaryPrefix.GetAsString Method

TBoldSQLWCFBinaryPrefix.GetAsString Method
TBoldSQLWCFBinaryPrefix Class BoldSQLQuery Namespace See Also
Collapse All
C#
public override string GetAsString(
    TBoldSQLQuery Query
);
Remarks

TBoldSQLWCFBinaryPrefix

See Also
TBoldSQLWCFBinaryPrefix Class
BoldSQLQuery Namespace


TBoldSQLWCFColumnRef Class

TBoldSQLWCFColumnRef Class
Inheritance Hierarchy See Also
Collapse All
C#
public class TBoldSQLWCFColumnRef : TBoldSqlWCF;
Remarks

TBoldSQLWCFColumnRef

Inheritance Hierarchy
BoldSQLQuery.TBoldSqlWCF
    BoldSQLQuery.TBoldSQLWCFColumnRef
File

BoldSQLQuery.cs

See Also
Inheritance Hierarchy


TBoldSQLWCFColumnRef.TBoldSQLWCFColumnRef Constructor

TBoldSQLWCFColumnRef.TBoldSQLWCFColumnRef Constructor
TBoldSQLWCFColumnRef Class BoldSQLQuery Namespace See Also
Collapse All
C#
public TBoldSQLWCFColumnRef(
    TBoldSQLColumnReference ColumnRef
);
Remarks

TBoldSQLWCFColumnRef Constructor Create( ColumnRef)

See Also
TBoldSQLWCFColumnRef Class
BoldSQLQuery Namespace


TBoldSQLWCFColumnRef Methods

TBoldSQLWCFColumnRef Methods
Public Methods
Collapse All

The methods of the TBoldSQLWCFColumnRef class are listed here.

Public Methods
Name | Description
GetAsString | This is GetAsString, a member of class TBoldSQLWCFColumnRef.


TBoldSQLWCFColumnRef.GetAsString Method

TBoldSQLWCFColumnRef.GetAsString Method
TBoldSQLWCFColumnRef Class BoldSQLQuery Namespace See Also
Collapse All
C#
public override string GetAsString(
    TBoldSQLQuery Query
);
Remarks

This is GetAsString, a member of class TBoldSQLWCFColumnRef.

See Also
TBoldSQLWCFColumnRef Class
BoldSQLQuery Namespace


TBoldSQLWCFColumnRef Properties

TBoldSQLWCFColumnRef Properties
Public Properties
Collapse All

The properties of the TBoldSQLWCFColumnRef class are listed here.

Public Properties
Name | Description
ColumnRef | This is ColumnRef, a member of class TBoldSQLWCFColumnRef.


TBoldSQLWCFColumnRef.ColumnRef Property

TBoldSQLWCFColumnRef.ColumnRef Property
TBoldSQLWCFColumnRef Class BoldSQLQuery Namespace See Also
Collapse All
C#
public TBoldSQLColumnReference ColumnRef;
Remarks

This is ColumnRef, a member of class TBoldSQLWCFColumnRef.

See Also
TBoldSQLWCFColumnRef Class
BoldSQLQuery Namespace


TBoldSQLWCFDate Class

TBoldSQLWCFDate Class
Inheritance Hierarchy See Also
Collapse All
C#
public class TBoldSQLWCFDate : TBoldSqlWCF;
Remarks

TBoldSQLWCFDate

Inheritance Hierarchy
BoldSQLQuery.TBoldSqlWCF
    BoldSQLQuery.TBoldSQLWCFDate
File

BoldSQLQuery.cs

See Also
Inheritance Hierarchy


TBoldSQLWCFDate.TBoldSQLWCFDate Constructor

TBoldSQLWCFDate.TBoldSQLWCFDate Constructor
TBoldSQLWCFDate Class BoldSQLQuery Namespace See Also
Collapse All
C#
public TBoldSQLWCFDate(
    DateTime Value
);
Remarks

TBoldSQLWCFDate Constructor Create( Value)

See Also
TBoldSQLWCFDate Class
BoldSQLQuery Namespace


TBoldSQLWCFDate Methods

TBoldSQLWCFDate Methods
Public Methods
Collapse All

The methods of the TBoldSQLWCFDate class are listed here.

Public Methods
Name | Description
GetAsString | This is GetAsString, a member of class TBoldSQLWCFDate.


TBoldSQLWCFDate.GetAsString Method

TBoldSQLWCFDate.GetAsString Method
TBoldSQLWCFDate Class BoldSQLQuery Namespace See Also
Collapse All
C#
public override string GetAsString(
    TBoldSQLQuery Query
);
Remarks

This is GetAsString, a member of class TBoldSQLWCFDate.

See Also
TBoldSQLWCFDate Class
BoldSQLQuery Namespace


TBoldSQLWCFExists Class

TBoldSQLWCFExists Class
Inheritance Hierarchy See Also
Collapse All
C#
public class TBoldSQLWCFExists : TBoldSQLWCFWithQuery;
Remarks

TBoldSQLWCFExists

Inheritance Hierarchy
BoldSQLQuery.TBoldSqlWCF
    BoldSQLQuery.TBoldSQLWCFWithQuery
        BoldSQLQuery.TBoldSQLWCFExists
File

BoldSQLQuery.cs

See Also
Inheritance Hierarchy


TBoldSQLWCFExists.TBoldSQLWCFExists Constructor

TBoldSQLWCFExists.TBoldSQLWCFExists Constructor
TBoldSQLWCFExists Class BoldSQLQuery Namespace See Also
Collapse All
C#
public TBoldSQLWCFExists(
    TBoldSQLQuery query,
    TBoldSQLAliasReference MainAlias
);
Remarks

TBoldSQLWCFExists Constructor create( query, MainAlias)

See Also
TBoldSQLWCFExists Class
BoldSQLQuery Namespace


TBoldSQLWCFExists Methods

TBoldSQLWCFExists Methods
Public Methods
Collapse All

The methods of the TBoldSQLWCFExists class are listed here.

Public Methods
Name | Description
GetAsString | This is GetAsString, a member of class TBoldSQLWCFExists.


TBoldSQLWCFExists.GetAsString Method

TBoldSQLWCFExists.GetAsString Method
TBoldSQLWCFExists Class BoldSQLQuery Namespace See Also
Collapse All
C#
public override string GetAsString(
    TBoldSQLQuery Query
);
Remarks

This is GetAsString, a member of class TBoldSQLWCFExists.

See Also
TBoldSQLWCFExists Class
BoldSQLQuery Namespace


TBoldSQLWCFFloat Class

TBoldSQLWCFFloat Class
Inheritance Hierarchy See Also
Collapse All
C#
public class TBoldSQLWCFFloat : TBoldSqlWCF;
Remarks

TBoldSQLWCFFloat

Inheritance Hierarchy
BoldSQLQuery.TBoldSqlWCF
    BoldSQLQuery.TBoldSQLWCFFloat
File

BoldSQLQuery.cs

See Also
Inheritance Hierarchy


TBoldSQLWCFFloat.TBoldSQLWCFFloat Constructor

TBoldSQLWCFFloat.TBoldSQLWCFFloat Constructor
TBoldSQLWCFFloat Class BoldSQLQuery Namespace See Also
Collapse All
C#
public TBoldSQLWCFFloat(
    double Value
);
Remarks

TBoldSQLWCFFloat Constructor Create( Value)

See Also
TBoldSQLWCFFloat Class
BoldSQLQuery Namespace


TBoldSQLWCFFloat Methods

TBoldSQLWCFFloat Methods
Public Methods
Collapse All

The methods of the TBoldSQLWCFFloat class are listed here.

Public Methods
Name | Description
GetAsString | This is GetAsString, a member of class TBoldSQLWCFFloat.


TBoldSQLWCFFloat.GetAsString Method

TBoldSQLWCFFloat.GetAsString Method
TBoldSQLWCFFloat Class BoldSQLQuery Namespace See Also
Collapse All
C#
public override string GetAsString(
    TBoldSQLQuery Query
);
Remarks

This is GetAsString, a member of class TBoldSQLWCFFloat.

See Also
TBoldSQLWCFFloat Class
BoldSQLQuery Namespace


TBoldSQLWCFGenericExpression Class

TBoldSQLWCFGenericExpression Class
Inheritance Hierarchy See Also
Collapse All
C#
public class TBoldSQLWCFGenericExpression : TBoldSqlWCF;
Remarks

TBoldSQLWCFGenericExpression

Inheritance Hierarchy
BoldSQLQuery.TBoldSqlWCF
    BoldSQLQuery.TBoldSQLWCFGenericExpression
File

BoldSQLQuery.cs

See Also
Inheritance Hierarchy


TBoldSQLWCFGenericExpression.TBoldSQLWCFGenericExpression Constructor

TBoldSQLWCFGenericExpression.TBoldSQLWCFGenericExpression Constructor
TBoldSQLWCFGenericExpression Class BoldSQLQuery Namespace See Also
Collapse All
C#
public TBoldSQLWCFGenericExpression(
    string Expr
);
Remarks

TBoldSQLWCFGenericExpression Constructor Create( Expr)

See Also
TBoldSQLWCFGenericExpression Class
BoldSQLQuery Namespace


TBoldSQLWCFGenericExpression Methods

TBoldSQLWCFGenericExpression Methods
Public Methods
Collapse All

The methods of the TBoldSQLWCFGenericExpression class are listed here.

Public Methods
Name | Description
GetAsString | This is GetAsString, a member of class TBoldSQLWCFGenericExpression.


TBoldSQLWCFGenericExpression.GetAsString Method

TBoldSQLWCFGenericExpression.GetAsString Method
TBoldSQLWCFGenericExpression Class BoldSQLQuery Namespace See Also
Collapse All
C#
public override string GetAsString(
    TBoldSQLQuery Query
);
Remarks

This is GetAsString, a member of class TBoldSQLWCFGenericExpression.

See Also
TBoldSQLWCFGenericExpression Class
BoldSQLQuery Namespace


TBoldSQLWCFGroupFunction Class

TBoldSQLWCFGroupFunction Class
Inheritance Hierarchy See Also
Collapse All
C#
public class TBoldSQLWCFGroupFunction : TBoldSQLWCFWithQuery;
Remarks

TBoldSQLWCFGroupFunction

Inheritance Hierarchy
BoldSQLQuery.TBoldSqlWCF
    BoldSQLQuery.TBoldSQLWCFWithQuery
        BoldSQLQuery.TBoldSQLWCFGroupFunction
            BoldSQLQuery.TBoldSQLWCFGroupFunctionWithColumn
            BoldSQLQuery.TBoldSQLWCFSize
File

BoldSQLQuery.cs

See Also
Inheritance Hierarchy


TBoldSQLWCFGroupFunction.TBoldSQLWCFGroupFunction Constructor

TBoldSQLWCFGroupFunction.TBoldSQLWCFGroupFunction Constructor
TBoldSQLWCFGroupFunction Class BoldSQLQuery Namespace See Also
Collapse All
C#
public TBoldSQLWCFGroupFunction(
    TBoldSQLQuery query
);
Remarks

TBoldSQLWCFGroupFunction Constructor create( query)

See Also
TBoldSQLWCFGroupFunction Class
BoldSQLQuery Namespace


TBoldSQLWCFGroupFunction Methods

TBoldSQLWCFGroupFunction Methods
Protected Methods Public Methods
Collapse All

The methods of the TBoldSQLWCFGroupFunction class are listed here.

Protected Methods
Name | Description
PreGetAsString | This is PreGetAsString, a member of class TBoldSQLWCFGroupFunction.
Top
Public Methods
Name | Description
GetAsString | This is GetAsString, a member of class TBoldSQLWCFGroupFunction.


TBoldSQLWCFGroupFunction.GetAsString Method

TBoldSQLWCFGroupFunction.GetAsString Method
TBoldSQLWCFGroupFunction Class BoldSQLQuery Namespace See Also
Collapse All
C#
public override string GetAsString(
    TBoldSQLQuery Query
);
Remarks

This is GetAsString, a member of class TBoldSQLWCFGroupFunction.

See Also
TBoldSQLWCFGroupFunction Class
BoldSQLQuery Namespace


TBoldSQLWCFGroupFunction.PreGetAsString Method

TBoldSQLWCFGroupFunction.PreGetAsString Method
TBoldSQLWCFGroupFunction Class BoldSQLQuery Namespace See Also
Collapse All
C#
protected virtual void PreGetAsString();
Remarks

This is PreGetAsString, a member of class TBoldSQLWCFGroupFunction.

See Also
TBoldSQLWCFGroupFunction Class
BoldSQLQuery Namespace


TBoldSQLWCFGroupFunctionWithColumn Class

TBoldSQLWCFGroupFunctionWithColumn Class
Inheritance Hierarchy See Also
Collapse All
C#
public class TBoldSQLWCFGroupFunctionWithColumn : TBoldSQLWCFGroupFunction;
Remarks

TBoldSQLWCFGroupFunctionWithColumn

Inheritance Hierarchy
BoldSQLQuery.TBoldSqlWCF
    BoldSQLQuery.TBoldSQLWCFWithQuery
        BoldSQLQuery.TBoldSQLWCFGroupFunction
            BoldSQLQuery.TBoldSQLWCFGroupFunctionWithColumn
File

BoldSQLQuery.cs

See Also
Inheritance Hierarchy


TBoldSQLWCFGroupFunctionWithColumn.TBoldSQLWCFGroupFunctionWithColumn Constructor

TBoldSQLWCFGroupFunctionWithColumn.TBoldSQLWCFGroupFunctionWithColumn Constructor
TBoldSQLWCFGroupFunctionWithColumn Class BoldSQLQuery Namespace See Also
Collapse All
C#
public TBoldSQLWCFGroupFunctionWithColumn(
    TBoldSQLQuery query,
    TBoldSQLColumnReference ColumnRef,
    string Operation
);
Remarks

TBoldSQLWCFGroupFunctionWithColumn Constructor create( query, ColumnRef, Operation)

See Also
TBoldSQLWCFGroupFunctionWithColumn Class
BoldSQLQuery Namespace


TBoldSQLWCFInQuery Class

TBoldSQLWCFInQuery Class
Inheritance Hierarchy See Also
Collapse All
C#
public class TBoldSQLWCFInQuery : TBoldSQLWCFWithQuery;
Remarks

TBoldSQLWCFInQuery

Inheritance Hierarchy
BoldSQLQuery.TBoldSqlWCF
    BoldSQLQuery.TBoldSQLWCFWithQuery
        BoldSQLQuery.TBoldSQLWCFInQuery
File

BoldSQLQuery.cs

See Also
Inheritance Hierarchy


TBoldSQLWCFInQuery.TBoldSQLWCFInQuery Constructor

TBoldSQLWCFInQuery.TBoldSQLWCFInQuery Constructor
TBoldSQLWCFInQuery Class BoldSQLQuery Namespace See Also
Collapse All
C#
public TBoldSQLWCFInQuery(
    TBoldSqlWCF Arg1,
    TBoldSQLQuery Query,
    TBoldSQLAliasReference MainAlias
);
Remarks

TBoldSQLWCFInQuery Constructor create( Arg1, Query, MainAlias)

See Also
TBoldSQLWCFInQuery Class
BoldSQLQuery Namespace


TBoldSQLWCFInQuery Methods

TBoldSQLWCFInQuery Methods
Public Methods
Collapse All

The methods of the TBoldSQLWCFInQuery class are listed here.

Public Methods
Name | Description
GetAsString | This is GetAsString, a member of class TBoldSQLWCFInQuery.


TBoldSQLWCFInQuery.GetAsString Method

TBoldSQLWCFInQuery.GetAsString Method
TBoldSQLWCFInQuery Class BoldSQLQuery Namespace See Also
Collapse All
C#
public override string GetAsString(
    TBoldSQLQuery Query
);
Remarks

This is GetAsString, a member of class TBoldSQLWCFInQuery.

See Also
TBoldSQLWCFInQuery Class
BoldSQLQuery Namespace


TBoldSQLWCFInQuery Properties

TBoldSQLWCFInQuery Properties
Public Properties
Collapse All

The properties of the TBoldSQLWCFInQuery class are listed here.

Public Properties
Name | Description
Arg1 | This is Arg1, a member of class TBoldSQLWCFInQuery.


TBoldSQLWCFInQuery.Arg1 Property

TBoldSQLWCFInQuery.Arg1 Property
TBoldSQLWCFInQuery Class BoldSQLQuery Namespace See Also
Collapse All
C#
public TBoldSqlWCF Arg1;
Remarks

This is Arg1, a member of class TBoldSQLWCFInQuery.

See Also
TBoldSQLWCFInQuery Class
BoldSQLQuery Namespace


TBoldSQLWCFInteger Class

TBoldSQLWCFInteger Class
Inheritance Hierarchy See Also
Collapse All
C#
public class TBoldSQLWCFInteger : TBoldSqlWCF;
Remarks

TBoldSQLWCFInteger

Inheritance Hierarchy
BoldSQLQuery.TBoldSqlWCF
    BoldSQLQuery.TBoldSQLWCFInteger
File

BoldSQLQuery.cs

See Also
Inheritance Hierarchy


TBoldSQLWCFInteger.TBoldSQLWCFInteger Constructor

TBoldSQLWCFInteger.TBoldSQLWCFInteger Constructor
TBoldSQLWCFInteger Class BoldSQLQuery Namespace See Also
Collapse All
C#
public TBoldSQLWCFInteger(
    int Value
);
Remarks

TBoldSQLWCFInteger Constructor Create( Value)

See Also
TBoldSQLWCFInteger Class
BoldSQLQuery Namespace


TBoldSQLWCFInteger Methods

TBoldSQLWCFInteger Methods
Public Methods
Collapse All

The methods of the TBoldSQLWCFInteger class are listed here.

Public Methods
Name | Description
GetAsString | This is GetAsString, a member of class TBoldSQLWCFInteger.


TBoldSQLWCFInteger.GetAsString Method

TBoldSQLWCFInteger.GetAsString Method
TBoldSQLWCFInteger Class BoldSQLQuery Namespace See Also
Collapse All
C#
public override string GetAsString(
    TBoldSQLQuery Query
);
Remarks

This is GetAsString, a member of class TBoldSQLWCFInteger.

See Also
TBoldSQLWCFInteger Class
BoldSQLQuery Namespace


TBoldSQLWCFJoin Class

TBoldSQLWCFJoin Class
Inheritance Hierarchy See Also
Collapse All
C#
public class TBoldSQLWCFJoin : TBoldSqlWCF;
Remarks

TBoldSQLWCFJoin

Inheritance Hierarchy
BoldSQLQuery.TBoldSqlWCF
    BoldSQLQuery.TBoldSQLWCFJoin
File

BoldSQLQuery.cs

See Also
Inheritance Hierarchy


TBoldSQLWCFJoin.TBoldSQLWCFJoin Constructor

TBoldSQLWCFJoin.TBoldSQLWCFJoin Constructor
TBoldSQLWCFJoin Class BoldSQLQuery Namespace See Also
Collapse All
C#
public TBoldSQLWCFJoin(
    TBoldSQLColumnReference ColumnRef1,
    TBoldSQLColumnReference ColumnRef2
);
Remarks

TBoldSQLWCFJoin Constructor Create( ColumnRef1, ColumnRef2)

See Also
TBoldSQLWCFJoin Class
BoldSQLQuery Namespace


TBoldSQLWCFJoin Methods

TBoldSQLWCFJoin Methods
Public Methods
Collapse All

The methods of the TBoldSQLWCFJoin class are listed here.

Public Methods
Name | Description
GetAsString | This is GetAsString, a member of class TBoldSQLWCFJoin.


TBoldSQLWCFJoin.GetAsString Method

TBoldSQLWCFJoin.GetAsString Method
TBoldSQLWCFJoin Class BoldSQLQuery Namespace See Also
Collapse All
C#
public override string GetAsString(
    TBoldSQLQuery Query
);
Remarks

This is GetAsString, a member of class TBoldSQLWCFJoin.

See Also
TBoldSQLWCFJoin Class
BoldSQLQuery Namespace


TBoldSQLWCFLiteralString Class

TBoldSQLWCFLiteralString Class
Inheritance Hierarchy See Also
Collapse All
C#
public class TBoldSQLWCFLiteralString : TBoldSqlWCF;
Remarks

TBoldSQLWCFLiteralString

Inheritance Hierarchy
BoldSQLQuery.TBoldSqlWCF
    BoldSQLQuery.TBoldSQLWCFLiteralString
File

BoldSQLQuery.cs

See Also
Inheritance Hierarchy


TBoldSQLWCFLiteralString.TBoldSQLWCFLiteralString Constructor

TBoldSQLWCFLiteralString.TBoldSQLWCFLiteralString Constructor
TBoldSQLWCFLiteralString Class BoldSQLQuery Namespace See Also
Collapse All
C#
public TBoldSQLWCFLiteralString(
    string Value
);
Remarks

TBoldSQLWCFLiteralString Constructor Create( Value)

See Also
TBoldSQLWCFLiteralString Class
BoldSQLQuery Namespace


TBoldSQLWCFLiteralString Methods

TBoldSQLWCFLiteralString Methods
Public Methods
Collapse All

The methods of the TBoldSQLWCFLiteralString class are listed here.

Public Methods
Name | Description
GetAsString | This is GetAsString, a member of class TBoldSQLWCFLiteralString.


TBoldSQLWCFLiteralString.GetAsString Method

TBoldSQLWCFLiteralString.GetAsString Method
TBoldSQLWCFLiteralString Class BoldSQLQuery Namespace See Also
Collapse All
C#
public override string GetAsString(
    TBoldSQLQuery Query
);
Remarks

This is GetAsString, a member of class TBoldSQLWCFLiteralString.

See Also
TBoldSQLWCFLiteralString Class
BoldSQLQuery Namespace


TBoldSQLWCFSize Class

TBoldSQLWCFSize Class
Inheritance Hierarchy See Also
Collapse All
C#
public class TBoldSQLWCFSize : TBoldSQLWCFGroupFunction;
Remarks

TBoldSQLWCFSize

Inheritance Hierarchy
BoldSQLQuery.TBoldSqlWCF
    BoldSQLQuery.TBoldSQLWCFWithQuery
        BoldSQLQuery.TBoldSQLWCFGroupFunction
            BoldSQLQuery.TBoldSQLWCFSize
File

BoldSQLQuery.cs

See Also
Inheritance Hierarchy


TBoldSQLWCFSize.TBoldSQLWCFSize Constructor

TBoldSQLWCFSize.TBoldSQLWCFSize Constructor
TBoldSQLWCFSize Class BoldSQLQuery Namespace See Also
Collapse All
C#
public TBoldSQLWCFSize(
    TBoldSQLQuery query
);
Remarks

Constructors

See Also
TBoldSQLWCFSize Class
BoldSQLQuery Namespace


TBoldSQLWCFSize Methods

TBoldSQLWCFSize Methods
Protected Methods
Collapse All

The methods of the TBoldSQLWCFSize class are listed here.

Protected Methods
Name | Description
PreGetAsString | TBoldSQLWCFSize


TBoldSQLWCFSize.PreGetAsString Method

TBoldSQLWCFSize.PreGetAsString Method
TBoldSQLWCFSize Class BoldSQLQuery Namespace See Also
Collapse All
C#
protected override void PreGetAsString();
Remarks

TBoldSQLWCFSize

See Also
TBoldSQLWCFSize Class
BoldSQLQuery Namespace


TBoldSQLWCFString Class

TBoldSQLWCFString Class
Inheritance Hierarchy See Also
Collapse All
C#
public class TBoldSQLWCFString : TBoldSqlWCF;
Remarks

TBoldSQLWCFString

Inheritance Hierarchy
BoldSQLQuery.TBoldSqlWCF
    BoldSQLQuery.TBoldSQLWCFString
File

BoldSQLQuery.cs

See Also
Inheritance Hierarchy


TBoldSQLWCFString.TBoldSQLWCFString Constructor

TBoldSQLWCFString.TBoldSQLWCFString Constructor
TBoldSQLWCFString Class BoldSQLQuery Namespace See Also
Collapse All
C#
public TBoldSQLWCFString(
    string Value
);
Remarks

TBoldSQLWCFString Constructor Create( Value)

See Also
TBoldSQLWCFString Class
BoldSQLQuery Namespace


TBoldSQLWCFString Methods

TBoldSQLWCFString Methods
Public Methods
Collapse All

The methods of the TBoldSQLWCFString class are listed here.

Public Methods
Name | Description
GetAsString | This is GetAsString, a member of class TBoldSQLWCFString.


TBoldSQLWCFString.GetAsString Method

TBoldSQLWCFString.GetAsString Method
TBoldSQLWCFString Class BoldSQLQuery Namespace See Also
Collapse All
C#
public override string GetAsString(
    TBoldSQLQuery Query
);
Remarks

This is GetAsString, a member of class TBoldSQLWCFString.

See Also
TBoldSQLWCFString Class
BoldSQLQuery Namespace


TBoldSQLWCFString Properties

TBoldSQLWCFString Properties
Public Properties
Collapse All

The properties of the TBoldSQLWCFString class are listed here.

Public Properties
Name | Description
Str | This is Str, a member of class TBoldSQLWCFString.


TBoldSQLWCFString.Str Property

TBoldSQLWCFString.Str Property
TBoldSQLWCFString Class BoldSQLQuery Namespace See Also
Collapse All
C#
public string Str;
Remarks

This is Str, a member of class TBoldSQLWCFString.

See Also
TBoldSQLWCFString Class
BoldSQLQuery Namespace


TBoldSQLWCFTime Class

TBoldSQLWCFTime Class
Inheritance Hierarchy See Also
Collapse All
C#
public class TBoldSQLWCFTime : TBoldSqlWCF;
Remarks

TBoldSQLWCFTime

Inheritance Hierarchy
BoldSQLQuery.TBoldSqlWCF
    BoldSQLQuery.TBoldSQLWCFTime
File

BoldSQLQuery.cs

See Also
Inheritance Hierarchy


TBoldSQLWCFTime.TBoldSQLWCFTime Constructor

TBoldSQLWCFTime.TBoldSQLWCFTime Constructor
TBoldSQLWCFTime Class BoldSQLQuery Namespace See Also
Collapse All
C#
public TBoldSQLWCFTime(
    TimeSpan Value
);
Remarks

TBoldSQLWCFTime Constructor Create( Value)

See Also
TBoldSQLWCFTime Class
BoldSQLQuery Namespace


TBoldSQLWCFTime Methods

TBoldSQLWCFTime Methods
Public Methods
Collapse All

The methods of the TBoldSQLWCFTime class are listed here.

Public Methods
Name | Description
GetAsString | This is GetAsString, a member of class TBoldSQLWCFTime.


TBoldSQLWCFTime.GetAsString Method

TBoldSQLWCFTime.GetAsString Method
TBoldSQLWCFTime Class BoldSQLQuery Namespace See Also
Collapse All
C#
public override string GetAsString(
    TBoldSQLQuery Query
);
Remarks

This is GetAsString, a member of class TBoldSQLWCFTime.

See Also
TBoldSQLWCFTime Class
BoldSQLQuery Namespace


TBoldSQLWCFUnary Class

TBoldSQLWCFUnary Class
Inheritance Hierarchy See Also
Collapse All
C#
public abstract class TBoldSQLWCFUnary : TBoldSqlWCF;
Remarks

TBoldSQLWCFUnary

Inheritance Hierarchy
BoldSQLQuery.TBoldSqlWCF
    BoldSQLQuery.TBoldSQLWCFUnary
        BoldSQLQuery.TBoldSQLWCFUnaryPostfix
        BoldSQLQuery.TBoldSQLWCFUnaryPrefix
File

BoldSQLQuery.cs

See Also
Inheritance Hierarchy


TBoldSQLWCFUnary.TBoldSQLWCFUnary Constructor

TBoldSQLWCFUnary.TBoldSQLWCFUnary Constructor
TBoldSQLWCFUnary Class BoldSQLQuery Namespace See Also
Collapse All
C#
public TBoldSQLWCFUnary(
    TBoldSqlWCF arg1,
    string Symbol
);
Remarks

TBoldSQLWCFUnary Constructor Create( arg1, Symbol)

See Also
TBoldSQLWCFUnary Class
BoldSQLQuery Namespace


TBoldSQLWCFUnaryPostfix Class

TBoldSQLWCFUnaryPostfix Class
Inheritance Hierarchy See Also
Collapse All
C#
public class TBoldSQLWCFUnaryPostfix : TBoldSQLWCFUnary;
Remarks

TBoldSQLWCFUnaryPostfix

Inheritance Hierarchy
BoldSQLQuery.TBoldSqlWCF
    BoldSQLQuery.TBoldSQLWCFUnary
        BoldSQLQuery.TBoldSQLWCFUnaryPostfix
File

BoldSQLQuery.cs

See Also
Inheritance Hierarchy


TBoldSQLWCFUnaryPostfix.TBoldSQLWCFUnaryPostfix Constructor

TBoldSQLWCFUnaryPostfix.TBoldSQLWCFUnaryPostfix Constructor
TBoldSQLWCFUnaryPostfix Class BoldSQLQuery Namespace See Also
Collapse All
C#
public TBoldSQLWCFUnaryPostfix(
    TBoldSqlWCF arg1,
    string Symbol
);
Remarks

Constructors

See Also
TBoldSQLWCFUnaryPostfix Class
BoldSQLQuery Namespace


TBoldSQLWCFUnaryPostfix Methods

TBoldSQLWCFUnaryPostfix Methods
Public Methods
Collapse All

The methods of the TBoldSQLWCFUnaryPostfix class are listed here.

Public Methods
Name | Description
GetAsString | TBoldSQLWCFUnaryPostfix


TBoldSQLWCFUnaryPostfix.GetAsString Method

TBoldSQLWCFUnaryPostfix.GetAsString Method
TBoldSQLWCFUnaryPostfix Class BoldSQLQuery Namespace See Also
Collapse All
C#
public override string GetAsString(
    TBoldSQLQuery Query
);
Remarks

TBoldSQLWCFUnaryPostfix

See Also
TBoldSQLWCFUnaryPostfix Class
BoldSQLQuery Namespace


TBoldSQLWCFUnaryPrefix Class

TBoldSQLWCFUnaryPrefix Class
Inheritance Hierarchy See Also
Collapse All
C#
public class TBoldSQLWCFUnaryPrefix : TBoldSQLWCFUnary;
Remarks

TBoldSQLWCFUnaryPrefix

Inheritance Hierarchy
BoldSQLQuery.TBoldSqlWCF
    BoldSQLQuery.TBoldSQLWCFUnary
        BoldSQLQuery.TBoldSQLWCFUnaryPrefix
File

BoldSQLQuery.cs

See Also
Inheritance Hierarchy


TBoldSQLWCFUnaryPrefix.TBoldSQLWCFUnaryPrefix Constructor

TBoldSQLWCFUnaryPrefix.TBoldSQLWCFUnaryPrefix Constructor
TBoldSQLWCFUnaryPrefix Class BoldSQLQuery Namespace See Also
Collapse All
C#
public TBoldSQLWCFUnaryPrefix(
    TBoldSqlWCF arg1,
    string Symbol
);
Remarks

Constructors

See Also
TBoldSQLWCFUnaryPrefix Class
BoldSQLQuery Namespace


TBoldSQLWCFUnaryPrefix Methods

TBoldSQLWCFUnaryPrefix Methods
Public Methods
Collapse All

The methods of the TBoldSQLWCFUnaryPrefix class are listed here.

Public Methods
Name | Description
GetAsString | This is GetAsString, a member of class TBoldSQLWCFUnaryPrefix.


TBoldSQLWCFUnaryPrefix.GetAsString Method

TBoldSQLWCFUnaryPrefix.GetAsString Method
TBoldSQLWCFUnaryPrefix Class BoldSQLQuery Namespace See Also
Collapse All
C#
public override string GetAsString(
    TBoldSQLQuery Query
);
Remarks

This is GetAsString, a member of class TBoldSQLWCFUnaryPrefix.

See Also
TBoldSQLWCFUnaryPrefix Class
BoldSQLQuery Namespace


TBoldSQLWCFWithQuery Class

TBoldSQLWCFWithQuery Class
Inheritance Hierarchy See Also
Collapse All
C#
public class TBoldSQLWCFWithQuery : TBoldSqlWCF;
Remarks

TBoldSQLWCFWithQuery

Inheritance Hierarchy
BoldSQLQuery.TBoldSqlWCF
    BoldSQLQuery.TBoldSQLWCFWithQuery
        BoldSQLQuery.TBoldSQLWCFExists
        BoldSQLQuery.TBoldSQLWCFGroupFunction
        BoldSQLQuery.TBoldSQLWCFInQuery
File

BoldSQLQuery.cs

See Also
Inheritance Hierarchy


TBoldSQLWCFWithQuery.TBoldSQLWCFWithQuery Constructor

TBoldSQLWCFWithQuery.TBoldSQLWCFWithQuery Constructor
TBoldSQLWCFWithQuery Class BoldSQLQuery Namespace See Also
Collapse All
C#
public TBoldSQLWCFWithQuery(
    TBoldSQLQuery query
);
Remarks

Constructor create( query)

See Also
TBoldSQLWCFWithQuery Class
BoldSQLQuery Namespace


TBoldSQLWCFWithQuery Methods

TBoldSQLWCFWithQuery Methods
Protected Methods Public Methods
Collapse All

The methods of the TBoldSQLWCFWithQuery class are listed here.

Protected Methods
Name | Description
AddIdKeyColumns | <- Provide a way to copy parameters (HK) TBoldSQLWCFWithQuery
CopyParams | This is CopyParams, a member of class TBoldSQLWCFWithQuery.
QueryAsString | This is QueryAsString, a member of class TBoldSQLWCFWithQuery.
Top
Public Methods
Name | Description
GetAsString | This is GetAsString, a member of class TBoldSQLWCFWithQuery.


TBoldSQLWCFWithQuery.AddIdKeyColumns Method

TBoldSQLWCFWithQuery.AddIdKeyColumns Method
TBoldSQLWCFWithQuery Class BoldSQLQuery Namespace See Also
Collapse All
C#
protected void AddIdKeyColumns(
    TBoldSQLAliasReference Alias,
    TBoldSQLQuery Query
);
Remarks

<- Provide a way to copy parameters (HK) TBoldSQLWCFWithQuery

See Also
TBoldSQLWCFWithQuery Class
BoldSQLQuery Namespace


TBoldSQLWCFWithQuery.CopyParams Method

TBoldSQLWCFWithQuery.CopyParams Method
TBoldSQLWCFWithQuery Class BoldSQLQuery Namespace See Also
Collapse All
C#
protected void CopyParams(
    TBoldSQLQuery Query
);
Remarks

This is CopyParams, a member of class TBoldSQLWCFWithQuery.

See Also
TBoldSQLWCFWithQuery Class
BoldSQLQuery Namespace


TBoldSQLWCFWithQuery.GetAsString Method

TBoldSQLWCFWithQuery.GetAsString Method
TBoldSQLWCFWithQuery Class BoldSQLQuery Namespace See Also
Collapse All
C#
public override string GetAsString(
    TBoldSQLQuery Query
);
Remarks

This is GetAsString, a member of class TBoldSQLWCFWithQuery.

See Also
TBoldSQLWCFWithQuery Class
BoldSQLQuery Namespace


TBoldSQLWCFWithQuery.QueryAsString Method

TBoldSQLWCFWithQuery.QueryAsString Method
TBoldSQLWCFWithQuery Class BoldSQLQuery Namespace See Also
Collapse All
C#
protected string QueryAsString();
Remarks

This is QueryAsString, a member of class TBoldSQLWCFWithQuery.

See Also
TBoldSQLWCFWithQuery Class
BoldSQLQuery Namespace


TBoldSQLWCFWithQuery Properties

TBoldSQLWCFWithQuery Properties
Public Properties
Collapse All

The properties of the TBoldSQLWCFWithQuery class are listed here.

Public Properties
Name | Description
Query | This is Query, a member of class TBoldSQLWCFWithQuery.


TBoldSQLWCFWithQuery.Query Property

TBoldSQLWCFWithQuery.Query Property
TBoldSQLWCFWithQuery Class BoldSQLQuery Namespace See Also
Collapse All
C#
public TBoldSQLQuery Query;
Remarks

This is Query, a member of class TBoldSQLWCFWithQuery.

See Also
TBoldSQLWCFWithQuery Class
BoldSQLQuery Namespace


BoldSQLQuery.TBoldSQLQueryMode Enumeration

BoldSQLQuery.TBoldSQLQueryMode Enumeration
C#
public enum TBoldSQLQueryMode {
  qmSelect,
  qmInsert,
  qmUpdate,
  qmDelete
}
Remarks

end TBoldSqlOrderByColumn

File

BoldSQLQuery.cs


BoldSqlQueryGenerator Namespace

BoldSqlQueryGenerator Namespace
Classes
Collapse All

This is namespace BoldSqlQueryGenerator.

Classes
Name | Description
TBoldSqlQueryGenerator | TBoldSqlQueryGenerator


TBoldSqlQueryGenerator Class

TBoldSqlQueryGenerator Class
Inheritance Hierarchy See Also
Collapse All
C#
public class TBoldSqlQueryGenerator : TBoldSqlNodeVisitor;
Remarks

TBoldSqlQueryGenerator

Inheritance Hierarchy
BoldSqlNodes.TBoldSqlNodeVisitor
    BoldSqlQueryGenerator.TBoldSqlQueryGenerator
File

BoldSqlQueryGenerator.cs

See Also
Inheritance Hierarchy


TBoldSqlQueryGenerator.TBoldSqlQueryGenerator Constructor

TBoldSqlQueryGenerator.TBoldSqlQueryGenerator Constructor
TBoldSqlQueryGenerator Class BoldSqlQueryGenerator Namespace See Also
Collapse All
C#
public TBoldSqlQueryGenerator(
    TBoldSQLNameSpace __NameSpace,
    SqlDatabaseConfig Config
);
Remarks

TBoldSqlQueryGenerator Constructor Create( __NameSpace, Config)

See Also
TBoldSqlQueryGenerator Class
BoldSqlQueryGenerator Namespace


TBoldSqlQueryGenerator Methods

TBoldSqlQueryGenerator Methods
Public Methods
Collapse All

The methods of the TBoldSqlQueryGenerator class are listed here.

Public Methods
Name | Description
VisitTBoldSqlDateLiteral | This is VisitTBoldSqlDateLiteral, a member of class TBoldSqlQueryGenerator.
VisitTBoldSqlEnumLiteral | This is VisitTBoldSqlEnumLiteral, a member of class TBoldSqlQueryGenerator.
VisitTBoldSqlFloatLiteral | This is VisitTBoldSqlFloatLiteral, a member of class TBoldSqlQueryGenerator.
VisitTBoldSqlIntLiteral | This is VisitTBoldSqlIntLiteral, a member of class TBoldSqlQueryGenerator.
VisitTBoldSqlIteration | This is VisitTBoldSqlIteration, a member of class TBoldSqlQueryGenerator.
VisitTBoldSqlListCoercion | This is VisitTBoldSqlListCoercion, a member of class TBoldSqlQueryGenerator.
VisitTBoldSqlLiteral | This is VisitTBoldSqlLiteral, a member of class TBoldSqlQueryGenerator.
VisitTBoldSqlMember | This is VisitTBoldSqlMember, a member of class TBoldSqlQueryGenerator.
VisitTBoldSqlNode | internal
VisitTBoldSqlOperation | This is VisitTBoldSqlOperation, a member of class TBoldSqlQueryGenerator.
VisitTBoldSqlStrLiteral | This is VisitTBoldSqlStrLiteral, a member of class TBoldSqlQueryGenerator.
VisitTBoldSqlTimeLiteral | This is VisitTBoldSqlTimeLiteral, a member of class TBoldSqlQueryGenerator.
VisitTBoldSqlTypeNode | This is VisitTBoldSqlTypeNode, a member of class TBoldSqlQueryGenerator.
VisitTBoldSqlVariableBinding | This is VisitTBoldSqlVariableBinding, a member of class TBoldSqlQueryGenerator.
VisitTBoldSqlVariableReference | This is VisitTBoldSqlVariableReference, a member of class TBoldSqlQueryGenerator.


TBoldSqlQueryGenerator.VisitTBoldSqlDateLiteral Method

TBoldSqlQueryGenerator.VisitTBoldSqlDateLiteral Method
TBoldSqlQueryGenerator Class BoldSqlQueryGenerator Namespace See Also
Collapse All
C#
public override void VisitTBoldSqlDateLiteral(
    TBoldSqlDateLiteral N
);
Remarks

This is VisitTBoldSqlDateLiteral, a member of class TBoldSqlQueryGenerator.

See Also
TBoldSqlQueryGenerator Class
BoldSqlQueryGenerator Namespace


TBoldSqlQueryGenerator.VisitTBoldSqlEnumLiteral Method

TBoldSqlQueryGenerator.VisitTBoldSqlEnumLiteral Method
TBoldSqlQueryGenerator Class BoldSqlQueryGenerator Namespace See Also
Collapse All
C#
public override void VisitTBoldSqlEnumLiteral(
    TBoldSqlEnumLiteral N
);
Remarks

This is VisitTBoldSqlEnumLiteral, a member of class TBoldSqlQueryGenerator.

See Also
TBoldSqlQueryGenerator Class
BoldSqlQueryGenerator Namespace


TBoldSqlQueryGenerator.VisitTBoldSqlFloatLiteral Method

TBoldSqlQueryGenerator.VisitTBoldSqlFloatLiteral Method
TBoldSqlQueryGenerator Class BoldSqlQueryGenerator Namespace See Also
Collapse All
C#
public override void VisitTBoldSqlFloatLiteral(
    TBoldSqlFloatLiteral N
);
Remarks

This is VisitTBoldSqlFloatLiteral, a member of class TBoldSqlQueryGenerator.

See Also
TBoldSqlQueryGenerator Class
BoldSqlQueryGenerator Namespace


TBoldSqlQueryGenerator.VisitTBoldSqlIntLiteral Method

TBoldSqlQueryGenerator.VisitTBoldSqlIntLiteral Method
TBoldSqlQueryGenerator Class BoldSqlQueryGenerator Namespace See Also
Collapse All
C#
public override void VisitTBoldSqlIntLiteral(
    TBoldSqlIntLiteral N
);
Remarks

This is VisitTBoldSqlIntLiteral, a member of class TBoldSqlQueryGenerator.

See Also
TBoldSqlQueryGenerator Class
BoldSqlQueryGenerator Namespace


TBoldSqlQueryGenerator.VisitTBoldSqlIteration Method

TBoldSqlQueryGenerator.VisitTBoldSqlIteration Method
TBoldSqlQueryGenerator Class BoldSqlQueryGenerator Namespace See Also
Collapse All
C#
public override void VisitTBoldSqlIteration(
    TBoldSqlIteration N
);
Remarks

This is VisitTBoldSqlIteration, a member of class TBoldSqlQueryGenerator.

See Also
TBoldSqlQueryGenerator Class
BoldSqlQueryGenerator Namespace


TBoldSqlQueryGenerator.VisitTBoldSqlListCoercion Method

TBoldSqlQueryGenerator.VisitTBoldSqlListCoercion Method
TBoldSqlQueryGenerator Class BoldSqlQueryGenerator Namespace See Also
Collapse All
C#
public override void VisitTBoldSqlListCoercion(
    TBoldSqlListCoercion N
);
Remarks

This is VisitTBoldSqlListCoercion, a member of class TBoldSqlQueryGenerator.

See Also
TBoldSqlQueryGenerator Class
BoldSqlQueryGenerator Namespace


TBoldSqlQueryGenerator.VisitTBoldSqlLiteral Method

TBoldSqlQueryGenerator.VisitTBoldSqlLiteral Method
TBoldSqlQueryGenerator Class BoldSqlQueryGenerator Namespace See Also
Collapse All
C#
public override void VisitTBoldSqlLiteral(
    TBoldSqlLiteral N
);
Remarks

This is VisitTBoldSqlLiteral, a member of class TBoldSqlQueryGenerator.

See Also
TBoldSqlQueryGenerator Class
BoldSqlQueryGenerator Namespace


TBoldSqlQueryGenerator.VisitTBoldSqlMember Method

TBoldSqlQueryGenerator.VisitTBoldSqlMember Method
TBoldSqlQueryGenerator Class BoldSqlQueryGenerator Namespace See Also
Collapse All
C#
public override void VisitTBoldSqlMember(
    TBoldSqlMember N
);
Remarks

This is VisitTBoldSqlMember, a member of class TBoldSqlQueryGenerator.

See Also
TBoldSqlQueryGenerator Class
BoldSqlQueryGenerator Namespace


TBoldSqlQueryGenerator.VisitTBoldSqlNode Method

TBoldSqlQueryGenerator.VisitTBoldSqlNode Method
TBoldSqlQueryGenerator Class BoldSqlQueryGenerator Namespace See Also
Collapse All
C#
public override void VisitTBoldSqlNode(
    TBoldSqlNode N
);
Remarks

internal

See Also
TBoldSqlQueryGenerator Class
BoldSqlQueryGenerator Namespace


TBoldSqlQueryGenerator.VisitTBoldSqlOperation Method

TBoldSqlQueryGenerator.VisitTBoldSqlOperation Method
TBoldSqlQueryGenerator Class BoldSqlQueryGenerator Namespace See Also
Collapse All
C#
public override void VisitTBoldSqlOperation(
    TBoldSqlOperation N
);
Remarks

This is VisitTBoldSqlOperation, a member of class TBoldSqlQueryGenerator.

See Also
TBoldSqlQueryGenerator Class
BoldSqlQueryGenerator Namespace


TBoldSqlQueryGenerator.VisitTBoldSqlStrLiteral Method

TBoldSqlQueryGenerator.VisitTBoldSqlStrLiteral Method
TBoldSqlQueryGenerator Class BoldSqlQueryGenerator Namespace See Also
Collapse All
C#
public override void VisitTBoldSqlStrLiteral(
    TBoldSqlStrLiteral N
);
Remarks

This is VisitTBoldSqlStrLiteral, a member of class TBoldSqlQueryGenerator.

See Also
TBoldSqlQueryGenerator Class
BoldSqlQueryGenerator Namespace


TBoldSqlQueryGenerator.VisitTBoldSqlTimeLiteral Method

TBoldSqlQueryGenerator.VisitTBoldSqlTimeLiteral Method
TBoldSqlQueryGenerator Class BoldSqlQueryGenerator Namespace See Also
Collapse All
C#
public override void VisitTBoldSqlTimeLiteral(
    TBoldSqlTimeLiteral N
);
Remarks

This is VisitTBoldSqlTimeLiteral, a member of class TBoldSqlQueryGenerator.

See Also
TBoldSqlQueryGenerator Class
BoldSqlQueryGenerator Namespace


TBoldSqlQueryGenerator.VisitTBoldSqlTypeNode Method

TBoldSqlQueryGenerator.VisitTBoldSqlTypeNode Method
TBoldSqlQueryGenerator Class BoldSqlQueryGenerator Namespace See Also
Collapse All
C#
public override void VisitTBoldSqlTypeNode(
    TBoldSqlTypeNode N
);
Remarks

This is VisitTBoldSqlTypeNode, a member of class TBoldSqlQueryGenerator.

See Also
TBoldSqlQueryGenerator Class
BoldSqlQueryGenerator Namespace


TBoldSqlQueryGenerator.VisitTBoldSqlVariableBinding Method

TBoldSqlQueryGenerator.VisitTBoldSqlVariableBinding Method
TBoldSqlQueryGenerator Class BoldSqlQueryGenerator Namespace See Also
Collapse All
C#
public override void VisitTBoldSqlVariableBinding(
    TBoldSqlVariableBinding N
);
Remarks

This is VisitTBoldSqlVariableBinding, a member of class TBoldSqlQueryGenerator.

See Also
TBoldSqlQueryGenerator Class
BoldSqlQueryGenerator Namespace


TBoldSqlQueryGenerator.VisitTBoldSqlVariableReference Method

TBoldSqlQueryGenerator.VisitTBoldSqlVariableReference Method
TBoldSqlQueryGenerator Class BoldSqlQueryGenerator Namespace See Also
Collapse All
C#
public override void VisitTBoldSqlVariableReference(
    TBoldSqlVariableReference N
);
Remarks

This is VisitTBoldSqlVariableReference, a member of class TBoldSqlQueryGenerator.

See Also
TBoldSqlQueryGenerator Class
BoldSqlQueryGenerator Namespace


BoldSqlSymbols Namespace

BoldSqlSymbols Namespace
Classes
Collapse All

This is namespace BoldSqlSymbols.

Classes
Name
Description
TBoldSqlSymbols
TBoldSqlSymbols
TBSS_Abs
This is class BoldSqlSymbols.TBSS_Abs.
TBSS_AbstractOrder
This is class BoldSqlSymbols.TBSS_AbstractOrder.
TBSS_Add
end TBSS_SQLLikeCaseInsensitive
TBSS_AllInstances
This is class BoldSqlSymbols.TBSS_AllInstances.
TBSS_and
This is class BoldSqlSymbols.TBSS_and.
TBSS_Average
This is class BoldSqlSymbols.TBSS_Average.
TBSS_BinaryBooleanSymbol
This is class BoldSqlSymbols.TBSS_BinaryBooleanSymbol.
TBSS_BinarySymbol
end TBoldSqlSymbols
TBSS_Contains
This is class BoldSqlSymbols.TBSS_Contains.
TBSS_Difference
This is class BoldSqlSymbols.TBSS_Difference.
TBSS_Div
This is class BoldSqlSymbols.TBSS_Div.
TBSS_Divide
This is class BoldSqlSymbols.TBSS_Divide.
TBSS_Equal
This is class BoldSqlSymbols.TBSS_Equal.
TBSS_Exists
This is class BoldSqlSymbols.TBSS_Exists.
TBSS_Floor
This is class BoldSqlSymbols.TBSS_Floor.
TBSS_ForAll
This is class BoldSqlSymbols.TBSS_ForAll.
TBSS_Greater
This is class BoldSqlSymbols.TBSS_Greater.
TBSS_GreaterEQ
This is class BoldSqlSymbols.TBSS_GreaterEQ.
TBSS_GroupFunctions
This is class BoldSqlSymbols.TBSS_GroupFunctions.
TBSS_implies
This is class BoldSqlSymbols.TBSS_implies.
TBSS_includes
This is class BoldSqlSymbols.TBSS_includes.
TBSS_Intersection
This is class BoldSqlSymbols.TBSS_Intersection.
TBSS_isEmpty
This is class BoldSqlSymbols.TBSS_isEmpty.
TBSS_isNull
This is class BoldSqlSymbols.TBSS_isNull.
TBSS_Iteration
This is class BoldSqlSymbols.TBSS_Iteration.
TBSS_Length
This is class BoldSqlSymbols.TBSS_Length.
TBSS_Less
This is class BoldSqlSymbols.TBSS_Less.
TBSS_LessEQ
This is class BoldSqlSymbols.TBSS_LessEQ.
TBSS_ListOperations
This is class BoldSqlSymbols.TBSS_ListOperations.
TBSS_Maxvalue
This is class BoldSqlSymbols.TBSS_Maxvalue.
TBSS_MinValue
This is class BoldSqlSymbols.TBSS_MinValue.
TBSS_Mod
This is class BoldSqlSymbols.TBSS_Mod.
TBSS_ModifiedSinceTimeStamp
end TBSS_BinarySymbol
TBSS_Multiply
This is class BoldSqlSymbols.TBSS_Multiply.
TBSS_not
This is class BoldSqlSymbols.TBSS_not.
TBSS_NotEmpty
This is class BoldSqlSymbols.TBSS_NotEmpty.
TBSS_NotEqual
This is class BoldSqlSymbols.TBSS_NotEqual.
TBSS_OclAsType
(* TBSS_OclIsTypeOf = class(TBSS_BinarySymbol) public procedure BuildWCFOrQuery(OperationNode: TBoldSQLOperation; NameSpace: TBoldSqlNameSpace); override; end;
TBSS_OclIsKindOf = class(TBSS_BinarySymbol) public procedure BuildWCFOrQuery(OperationNode: TBoldSQLOperation; NameSpace: TBoldSqlNameSpace); override; end;
TBSS_FilterOnType = class(TBSS_Symbol) public function ResolveObjectMapper(OperationNode: TBoldSqlOperation): TBoldObjectPersistenceMapper; override; procedure BuildWCFOrQuery(OperationNode: TBoldSQLOperation; NameSpace: TBoldSqlNameSpace); override; end; *)
TBSS_or
This is class BoldSqlSymbols.TBSS_or.
TBSS_orderby
This is class BoldSqlSymbols.TBSS_orderby.
TBSS_orderDescending
This is class BoldSqlSymbols.TBSS_orderDescending.
TBSS_orderGeneric
This is class BoldSqlSymbols.TBSS_orderGeneric.
TBSS_PrefixBinarySymbol
This is class BoldSqlSymbols.TBSS_PrefixBinarySymbol.
TBSS_reject
This is class BoldSqlSymbols.TBSS_reject.
TBSS_Round
This is class BoldSqlSymbols.TBSS_Round.
TBSS_Select
This is class BoldSqlSymbols.TBSS_Select.
TBSS_Size
This is class BoldSqlSymbols.TBSS_Size.
TBSS_SQLLike
This is class BoldSqlSymbols.TBSS_SQLLike.
TBSS_SQLLikeCaseInsensitive
This is class BoldSqlSymbols.TBSS_SQLLikeCaseInsensitive.
TBSS_SqlLikeUsersBase
This is class BoldSqlSymbols.TBSS_SqlLikeUsersBase.
TBSS_StartsWith
This is class BoldSqlSymbols.TBSS_StartsWith.
TBSS_Subtract
This is class BoldSqlSymbols.TBSS_Subtract.
TBSS_Sum
This is class BoldSqlSymbols.TBSS_Sum.
TBSS_Symbol
TBSS_Symbol
TBSS_SymmetricDifference
This is class BoldSqlSymbols.TBSS_SymmetricDifference.
TBSS_toLower
This is class BoldSqlSymbols.TBSS_toLower.
TBSS_ToUpper
This is class BoldSqlSymbols.TBSS_ToUpper.
TBSS_UnaryMinus
This is class BoldSqlSymbols.TBSS_UnaryMinus.
TBSS_UnarySymbol
This is class BoldSqlSymbols.TBSS_UnarySymbol.
TBSS_union
This is class BoldSqlSymbols.TBSS_union.
TBSS_xor
This is class BoldSqlSymbols.TBSS_xor.


TBoldSqlSymbols Class

TBoldSqlSymbols Class
Inheritance Hierarchy See Also
Collapse All
C#
public class TBoldSqlSymbols;
Remarks

TBoldSqlSymbols

Inheritance Hierarchy
BoldSqlSymbols.TBoldSqlSymbols
File

BoldSqlSymbols.cs

See Also
Inheritance Hierarchy


TBoldSqlSymbols Methods

TBoldSqlSymbols Methods
Public Methods
Collapse All

The methods of the TBoldSqlSymbols class are listed here.

Public Methods
Name | Description
FindSymbolByName | This is FindSymbolByName, a member of class TBoldSqlSymbols.


TBoldSqlSymbols.FindSymbolByName Method

TBoldSqlSymbols.FindSymbolByName Method
TBoldSqlSymbols Class BoldSqlSymbols Namespace See Also
Collapse All
C#
public static TBSS_Symbol FindSymbolByName(
    string Name
);
Remarks

This is FindSymbolByName, a member of class TBoldSqlSymbols.

See Also
TBoldSqlSymbols Class
BoldSqlSymbols Namespace


TBSS_Abs Class

TBSS_Abs Class
Inheritance Hierarchy See Also
Collapse All
C#
public class TBSS_Abs : TBSS_UnarySymbol;
Remarks

This is class BoldSqlSymbols.TBSS_Abs.

Inheritance Hierarchy
BoldSqlNodes.TBoldSqlSymbol
    BoldSqlSymbols.TBSS_Symbol
        BoldSqlSymbols.TBSS_UnarySymbol
            BoldSqlSymbols.TBSS_Abs
File

BoldSqlSymbols.cs

See Also
Inheritance Hierarchy


TBSS_AbstractOrder Class

TBSS_AbstractOrder Class
Inheritance Hierarchy See Also
Collapse All
C#
public abstract class TBSS_AbstractOrder : TBSS_Iteration;
Remarks

This is class BoldSqlSymbols.TBSS_AbstractOrder.

Inheritance Hierarchy
BoldSqlNodes.TBoldSqlSymbol
    BoldSqlSymbols.TBSS_Symbol
        BoldSqlSymbols.TBSS_Iteration
            BoldSqlSymbols.TBSS_AbstractOrder
                BoldSqlSymbols.TBSS_orderby
                BoldSqlSymbols.TBSS_orderDescending
                BoldSqlSymbols.TBSS_orderGeneric
File

BoldSqlSymbols.cs

See Also
Inheritance Hierarchy


TBSS_AbstractOrder Methods

TBSS_AbstractOrder Methods
Public Methods
Collapse All

The methods of the TBSS_AbstractOrder class are listed here.

Public Methods
Name | Description
BuildWCFOrQuery | TBSS_AbstractOrder
GetArgCount | This is GetArgCount, a member of class TBSS_AbstractOrder.
GetDirection | This is GetDirection, a member of class TBSS_AbstractOrder.
GetNode | This is GetNode, a member of class TBSS_AbstractOrder.


TBSS_AbstractOrder.BuildWCFOrQuery Method

TBSS_AbstractOrder.BuildWCFOrQuery Method
TBSS_AbstractOrder Class BoldSqlSymbols Namespace See Also
Collapse All
C#
public override void BuildWCFOrQuery(
    TBoldSqlOperation OperationNode,
    TBoldSQLNameSpace __NameSpace
);
Remarks

TBSS_AbstractOrder

See Also
TBSS_AbstractOrder Class
BoldSqlSymbols Namespace


TBSS_AbstractOrder.GetArgCount Method

TBSS_AbstractOrder.GetArgCount Method
TBSS_AbstractOrder Class BoldSqlSymbols Namespace See Also
Collapse All
C#
public abstract int GetArgCount(
    TBoldSqlNodeList Args
);
Remarks

This is GetArgCount, a member of class TBSS_AbstractOrder.

See Also
TBSS_AbstractOrder Class
BoldSqlSymbols Namespace


TBSS_AbstractOrder.GetDirection Method

TBSS_AbstractOrder.GetDirection Method
TBSS_AbstractOrder Class BoldSqlSymbols Namespace See Also
Collapse All
C#
public abstract OclSortDirection GetDirection(
    TBoldSqlNodeList Args,
    int index
);
Remarks

This is GetDirection, a member of class TBSS_AbstractOrder.

See Also
TBSS_AbstractOrder Class
BoldSqlSymbols Namespace


TBSS_AbstractOrder.GetNode Method

TBSS_AbstractOrder.GetNode Method
TBSS_AbstractOrder Class BoldSqlSymbols Namespace See Also
Collapse All
C#
public abstract TBoldSqlNode GetNode(
    TBoldSqlNodeList Args,
    int index
);
Remarks

This is GetNode, a member of class TBSS_AbstractOrder.

See Also
TBSS_AbstractOrder Class
BoldSqlSymbols Namespace


TBSS_Add Class

TBSS_Add Class
Inheritance Hierarchy See Also
Collapse All
C#
public class TBSS_Add : TBSS_BinarySymbol;
Remarks

end TBSS_SQLLikeCaseInsensitive

Inheritance Hierarchy
BoldSqlNodes.TBoldSqlSymbol
    BoldSqlSymbols.TBSS_Symbol
        BoldSqlSymbols.TBSS_BinarySymbol
            BoldSqlSymbols.TBSS_Add
File

BoldSqlSymbols.cs

See Also
Inheritance Hierarchy


TBSS_Add Properties

TBSS_Add Properties
Public Properties
Collapse All

The properties of the TBSS_Add class are listed here.

Public Properties
Name | Description
Name | This is Name, a member of class TBSS_Add.


TBSS_Add.Name Property

TBSS_Add.Name Property
TBSS_Add Class BoldSqlSymbols Namespace See Also
Collapse All
C#
public override string Name;
Remarks

This is Name, a member of class TBSS_Add.

See Also
TBSS_Add Class
BoldSqlSymbols Namespace


TBSS_AllInstances Class

TBSS_AllInstances Class
Inheritance Hierarchy See Also
Collapse All
C#
public class TBSS_AllInstances : TBSS_Symbol;
Remarks

This is class BoldSqlSymbols.TBSS_AllInstances.

Inheritance Hierarchy
BoldSqlNodes.TBoldSqlSymbol
    BoldSqlSymbols.TBSS_Symbol
        BoldSqlSymbols.TBSS_AllInstances
File

BoldSqlSymbols.cs

See Also
Inheritance Hierarchy


TBSS_AllInstances Methods

TBSS_AllInstances Methods
Public Methods
Collapse All

The methods of the TBSS_AllInstances class are listed here.

Public Methods
Name | Description
BuildWCFOrQuery | This is BuildWCFOrQuery, a member of class TBSS_AllInstances.
ResolveObjectMapper | This is ResolveObjectMapper, a member of class TBSS_AllInstances.


TBSS_AllInstances.BuildWCFOrQuery Method

TBSS_AllInstances.BuildWCFOrQuery Method
TBSS_AllInstances Class BoldSqlSymbols Namespace See Also
Collapse All
C#
public override void BuildWCFOrQuery(
    TBoldSqlOperation OperationNode,
    TBoldSQLNameSpace __NameSpace
);
Remarks

This is BuildWCFOrQuery, a member of class TBSS_AllInstances.

See Also
TBSS_AllInstances Class
BoldSqlSymbols Namespace


TBSS_AllInstances.ResolveObjectMapper Method

TBSS_AllInstances.ResolveObjectMapper Method
TBSS_AllInstances Class BoldSqlSymbols Namespace See Also
Collapse All
C#
public override ClassPersistenceMapper ResolveObjectMapper(
    TBoldSqlOperation OperationNode
);
Remarks

This is ResolveObjectMapper, a member of class TBSS_AllInstances.

See Also
TBSS_AllInstances Class
BoldSqlSymbols Namespace


TBSS_and Class

TBSS_and Class
Inheritance Hierarchy See Also
Collapse All
C#
public class TBSS_and : TBSS_BinarySymbol;
Remarks

This is class BoldSqlSymbols.TBSS_and.

Inheritance Hierarchy
BoldSqlNodes.TBoldSqlSymbol
    BoldSqlSymbols.TBSS_Symbol
        BoldSqlSymbols.TBSS_BinarySymbol
            BoldSqlSymbols.TBSS_and
File

BoldSqlSymbols.cs

See Also
Inheritance Hierarchy


TBSS_Average Class

TBSS_Average Class
Inheritance Hierarchy See Also
Collapse All
C#
public class TBSS_Average : TBSS_GroupFunctions;
Remarks

This is class BoldSqlSymbols.TBSS_Average.

Inheritance Hierarchy
BoldSqlNodes.TBoldSqlSymbol
    BoldSqlSymbols.TBSS_Symbol
        BoldSqlSymbols.TBSS_GroupFunctions
            BoldSqlSymbols.TBSS_Average
File

BoldSqlSymbols.cs

See Also
Inheritance Hierarchy


TBSS_Average Properties

TBSS_Average Properties
Public Properties
Collapse All

The properties of the TBSS_Average class are listed here.

Public Properties
Name | Description
SqlName | This is SqlName, a member of class TBSS_Average.


TBSS_Average.SqlName Property

TBSS_Average.SqlName Property
TBSS_Average Class BoldSqlSymbols Namespace See Also
Collapse All
C#
public override string SqlName;
Remarks

This is SqlName, a member of class TBSS_Average.

See Also
TBSS_Average Class
BoldSqlSymbols Namespace


TBSS_BinaryBooleanSymbol Class

TBSS_BinaryBooleanSymbol Class
Inheritance Hierarchy See Also
Collapse All
C#
public class TBSS_BinaryBooleanSymbol : TBSS_BinarySymbol;
Remarks

This is class BoldSqlSymbols.TBSS_BinaryBooleanSymbol.

Inheritance Hierarchy
BoldSqlNodes.TBoldSqlSymbol
    BoldSqlSymbols.TBSS_Symbol
        BoldSqlSymbols.TBSS_BinarySymbol
            BoldSqlSymbols.TBSS_BinaryBooleanSymbol
                BoldSqlSymbols.TBSS_Equal
                BoldSqlSymbols.TBSS_Greater
                BoldSqlSymbols.TBSS_GreaterEQ
                BoldSqlSymbols.TBSS_Less
                BoldSqlSymbols.TBSS_LessEQ
                BoldSqlSymbols.TBSS_NotEqual
File

BoldSqlSymbols.cs

See Also
Inheritance Hierarchy


TBSS_BinarySymbol Class

TBSS_BinarySymbol Class
Inheritance Hierarchy See Also
Collapse All
C#
public class TBSS_BinarySymbol : TBSS_Symbol;
Remarks

end TBoldSqlSymbols

Inheritance Hierarchy
BoldSqlNodes.TBoldSqlSymbol
    BoldSqlSymbols.TBSS_Symbol
        BoldSqlSymbols.TBSS_BinarySymbol
            BoldSqlSymbols.TBSS_Add
            BoldSqlSymbols.TBSS_and
            BoldSqlSymbols.TBSS_BinaryBooleanSymbol
            BoldSqlSymbols.TBSS_Divide
            BoldSqlSymbols.TBSS_implies
            BoldSqlSymbols.TBSS_ModifiedSinceTimeStamp
            BoldSqlSymbols.TBSS_Multiply
            BoldSqlSymbols.TBSS_or
            BoldSqlSymbols.TBSS_SQLLike
            BoldSqlSymbols.TBSS_SqlLikeUsersBase
            BoldSqlSymbols.TBSS_Subtract
            BoldSqlSymbols.TBSS_xor
File

BoldSqlSymbols.cs

See Also
Inheritance Hierarchy


TBSS_BinarySymbol Methods

TBSS_BinarySymbol Methods
Protected Methods Public Methods
Collapse All

The methods of the TBSS_BinarySymbol class are listed here.

Protected Methods
Name | Description
CollectArgWCFs | This is CollectArgWCFs, a member of class TBSS_BinarySymbol.
ConvertQueryToWCF | This is ConvertQueryToWCF, a member of class TBSS_BinarySymbol.
Top
Public Methods
Name | Description
BuildWCFOrQuery | TBSS_BinarySymbol


TBSS_BinarySymbol.BuildWCFOrQuery Method

TBSS_BinarySymbol.BuildWCFOrQuery Method
TBSS_BinarySymbol Class BoldSqlSymbols Namespace See Also
Collapse All
C#
public override void BuildWCFOrQuery(
    TBoldSqlOperation OperationNode,
    TBoldSQLNameSpace __NameSpace
);
Remarks

TBSS_BinarySymbol

See Also
TBSS_BinarySymbol Class
BoldSqlSymbols Namespace


TBSS_BinarySymbol.CollectArgWCFs Method

TBSS_BinarySymbol.CollectArgWCFs Method
TBSS_BinarySymbol Class BoldSqlSymbols Namespace See Also
Collapse All
C#
protected void CollectArgWCFs(
    TBoldSqlOperation OpNode
);
Remarks

This is CollectArgWCFs, a member of class TBSS_BinarySymbol.

See Also
TBSS_BinarySymbol Class
BoldSqlSymbols Namespace


TBSS_BinarySymbol.ConvertQueryToWCF Method

TBSS_BinarySymbol.ConvertQueryToWCF Method
TBSS_BinarySymbol Class BoldSqlSymbols Namespace See Also
Collapse All
C#
protected void ConvertQueryToWCF(
    TBoldSqlNode SourceNode,
    TBoldSqlNode DestNode
);
Remarks

This is ConvertQueryToWCF, a member of class TBSS_BinarySymbol.

See Also
TBSS_BinarySymbol Class
BoldSqlSymbols Namespace


TBSS_Contains Class

TBSS_Contains Class
Inheritance Hierarchy See Also
Collapse All
C#
public class TBSS_Contains : TBSS_SqlLikeUsersBase;
Remarks

This is class BoldSqlSymbols.TBSS_Contains.

Inheritance Hierarchy
BoldSqlNodes.TBoldSqlSymbol
    BoldSqlSymbols.TBSS_Symbol
        BoldSqlSymbols.TBSS_BinarySymbol
            BoldSqlSymbols.TBSS_SqlLikeUsersBase
                BoldSqlSymbols.TBSS_Contains
File

BoldSqlSymbols.cs

See Also
Inheritance Hierarchy


TBSS_Contains Methods

TBSS_Contains Methods
Protected Methods
Collapse All

The methods of the TBSS_Contains class are listed here.

Protected Methods
Name | Description
AdjustLikeArgument | This is AdjustLikeArgument, a member of class TBSS_Contains.


TBSS_Contains.AdjustLikeArgument Method

TBSS_Contains.AdjustLikeArgument Method
TBSS_Contains Class BoldSqlSymbols Namespace See Also
Collapse All
C#
protected override TBoldSqlWCF AdjustLikeArgument(
    TBoldSqlWCF arg
);
Remarks

This is AdjustLikeArgument, a member of class TBSS_Contains.

See Also
TBSS_Contains Class
BoldSqlSymbols Namespace


TBSS_Difference Class

TBSS_Difference Class
Inheritance Hierarchy See Also
Collapse All
C#
public class TBSS_Difference : TBSS_ListOperations;
Remarks

This is class BoldSqlSymbols.TBSS_Difference.

Inheritance Hierarchy
BoldSqlNodes.TBoldSqlSymbol
    BoldSqlSymbols.TBSS_Symbol
        BoldSqlSymbols.TBSS_ListOperations
            BoldSqlSymbols.TBSS_Difference
File

BoldSqlSymbols.cs

See Also
Inheritance Hierarchy


TBSS_Difference Methods

TBSS_Difference Methods
Public Methods
Collapse All

The methods of the TBSS_Difference class are listed here.

Public Methods
Name | Description
BuildWCFOrQuery | This is BuildWCFOrQuery, a member of class TBSS_Difference.


TBSS_Difference.BuildWCFOrQuery Method

TBSS_Difference.BuildWCFOrQuery Method
TBSS_Difference Class BoldSqlSymbols Namespace See Also
Collapse All
C#
public override void BuildWCFOrQuery(
    TBoldSqlOperation OperationNode,
    TBoldSQLNameSpace __NameSpace
);
Remarks

This is BuildWCFOrQuery, a member of class TBSS_Difference.

See Also
TBSS_Difference Class
BoldSqlSymbols Namespace


TBSS_Div Class

TBSS_Div Class
Inheritance Hierarchy See Also
Collapse All
C#
public class TBSS_Div : TBSS_PrefixBinarySymbol;
Remarks

This is class BoldSqlSymbols.TBSS_Div.

Inheritance Hierarchy
BoldSqlNodes.TBoldSqlSymbol
    BoldSqlSymbols.TBSS_Symbol
        BoldSqlSymbols.TBSS_PrefixBinarySymbol
            BoldSqlSymbols.TBSS_Div
File

BoldSqlSymbols.cs

See Also
Inheritance Hierarchy


TBSS_Divide Class

TBSS_Divide Class
Inheritance Hierarchy See Also
Collapse All
C#
public class TBSS_Divide : TBSS_BinarySymbol;
Remarks

This is class BoldSqlSymbols.TBSS_Divide.

Inheritance Hierarchy
BoldSqlNodes.TBoldSqlSymbol
    BoldSqlSymbols.TBSS_Symbol
        BoldSqlSymbols.TBSS_BinarySymbol
            BoldSqlSymbols.TBSS_Divide
File

BoldSqlSymbols.cs

See Also
Inheritance Hierarchy


TBSS_Divide Properties

TBSS_Divide Properties
Public Properties
Collapse All

The properties of the TBSS_Divide class are listed here.

Public Properties
Name | Description
Name | This is Name, a member of class TBSS_Divide.


TBSS_Divide.Name Property

TBSS_Divide.Name Property
TBSS_Divide Class BoldSqlSymbols Namespace See Also
Collapse All
C#
public override string Name;
Remarks

This is Name, a member of class TBSS_Divide.

See Also
TBSS_Divide Class
BoldSqlSymbols Namespace


TBSS_Equal Class

TBSS_Equal Class
Inheritance Hierarchy See Also
Collapse All
C#
public class TBSS_Equal : TBSS_BinaryBooleanSymbol;
Remarks

This is class BoldSqlSymbols.TBSS_Equal.

Inheritance Hierarchy
BoldSqlNodes.TBoldSqlSymbol
    BoldSqlSymbols.TBSS_Symbol
        BoldSqlSymbols.TBSS_BinarySymbol
            BoldSqlSymbols.TBSS_BinaryBooleanSymbol
                BoldSqlSymbols.TBSS_Equal
File

BoldSqlSymbols.cs

See Also
Inheritance Hierarchy


TBSS_Equal Properties

TBSS_Equal Properties
Public Properties
Collapse All

The properties of the TBSS_Equal class are listed here.

Public Properties
Name | Description
Name | This is Name, a member of class TBSS_Equal.


TBSS_Equal.Name Property

TBSS_Equal.Name Property
TBSS_Equal Class BoldSqlSymbols Namespace See Also
Collapse All
C#
public override string Name;
Remarks

This is Name, a member of class TBSS_Equal.

See Also
TBSS_Equal Class
BoldSqlSymbols Namespace


TBSS_Exists Class

TBSS_Exists Class
Inheritance Hierarchy See Also
Collapse All
C#
public class TBSS_Exists : TBSS_Iteration;
Remarks

This is class BoldSqlSymbols.TBSS_Exists.

Inheritance Hierarchy
BoldSqlNodes.TBoldSqlSymbol
    BoldSqlSymbols.TBSS_Symbol
        BoldSqlSymbols.TBSS_Iteration
            BoldSqlSymbols.TBSS_Exists
File

BoldSqlSymbols.cs

See Also
Inheritance Hierarchy


TBSS_Exists Methods

TBSS_Exists Methods
Public Methods
Collapse All

The methods of the TBSS_Exists class are listed here.

Public Methods
Name | Description
BuildWCFOrQuery | This is BuildWCFOrQuery, a member of class TBSS_Exists.


TBSS_Exists.BuildWCFOrQuery Method

TBSS_Exists.BuildWCFOrQuery Method
TBSS_Exists Class BoldSqlSymbols Namespace See Also
Collapse All
C#
public override void BuildWCFOrQuery(
    TBoldSqlOperation OperationNode,
    TBoldSQLNameSpace __NameSpace
);
Remarks

This is BuildWCFOrQuery, a member of class TBSS_Exists.

See Also
TBSS_Exists Class
BoldSqlSymbols Namespace


TBSS_Floor Class

TBSS_Floor Class
Inheritance Hierarchy See Also
Collapse All
C#
public class TBSS_Floor : TBSS_UnarySymbol;
Remarks

This is class BoldSqlSymbols.TBSS_Floor.

Inheritance Hierarchy
BoldSqlNodes.TBoldSqlSymbol
    BoldSqlSymbols.TBSS_Symbol
        BoldSqlSymbols.TBSS_UnarySymbol
            BoldSqlSymbols.TBSS_Floor
File

BoldSqlSymbols.cs

See Also
Inheritance Hierarchy


TBSS_ForAll Class

TBSS_ForAll Class
Inheritance Hierarchy See Also
Collapse All
C#
public class TBSS_ForAll : TBSS_Iteration;
Remarks

This is class BoldSqlSymbols.TBSS_ForAll.

Inheritance Hierarchy
BoldSqlNodes.TBoldSqlSymbol
    BoldSqlSymbols.TBSS_Symbol
        BoldSqlSymbols.TBSS_Iteration
            BoldSqlSymbols.TBSS_ForAll
File

BoldSqlSymbols.cs

See Also
Inheritance Hierarchy


TBSS_ForAll Methods

TBSS_ForAll Methods
Public Methods
Collapse All

The methods of the TBSS_ForAll class are listed here.

Public Methods
Name | Description
BuildWCFOrQuery | This is BuildWCFOrQuery, a member of class TBSS_ForAll.


TBSS_ForAll.BuildWCFOrQuery Method

TBSS_ForAll.BuildWCFOrQuery Method
TBSS_ForAll Class BoldSqlSymbols Namespace See Also
Collapse All
C#
public override void BuildWCFOrQuery(
    TBoldSqlOperation OperationNode,
    TBoldSQLNameSpace __NameSpace
);
Remarks

This is BuildWCFOrQuery, a member of class TBSS_ForAll.

See Also
TBSS_ForAll Class
BoldSqlSymbols Namespace


TBSS_Greater Class

TBSS_Greater Class
Inheritance Hierarchy See Also
Collapse All
C#
public class TBSS_Greater : TBSS_BinaryBooleanSymbol;
Remarks

This is class BoldSqlSymbols.TBSS_Greater.

Inheritance Hierarchy
BoldSqlNodes.TBoldSqlSymbol
    BoldSqlSymbols.TBSS_Symbol
        BoldSqlSymbols.TBSS_BinarySymbol
            BoldSqlSymbols.TBSS_BinaryBooleanSymbol
                BoldSqlSymbols.TBSS_Greater
File

BoldSqlSymbols.cs

See Also
Inheritance Hierarchy


TBSS_Greater Properties

TBSS_Greater Properties
Public Properties
Collapse All

The properties of the TBSS_Greater class are listed here.

Public Properties
Name | Description
Name | This is Name, a member of class TBSS_Greater.


TBSS_Greater.Name Property

TBSS_Greater.Name Property
TBSS_Greater Class BoldSqlSymbols Namespace See Also
Collapse All
C#
public override string Name;
Remarks

This is Name, a member of class TBSS_Greater.

See Also
TBSS_Greater Class
BoldSqlSymbols Namespace


TBSS_GreaterEQ Class

TBSS_GreaterEQ Class
Inheritance Hierarchy See Also
Collapse All
C#
public class TBSS_GreaterEQ : TBSS_BinaryBooleanSymbol;
Remarks

This is class BoldSqlSymbols.TBSS_GreaterEQ.

Inheritance Hierarchy
BoldSqlNodes.TBoldSqlSymbol
    BoldSqlSymbols.TBSS_Symbol
        BoldSqlSymbols.TBSS_BinarySymbol
            BoldSqlSymbols.TBSS_BinaryBooleanSymbol
                BoldSqlSymbols.TBSS_GreaterEQ
File

BoldSqlSymbols.cs

See Also
Inheritance Hierarchy


TBSS_GreaterEQ Properties

TBSS_GreaterEQ Properties
Public Properties
Collapse All

The properties of the TBSS_GreaterEQ class are listed here.

Public Properties
Name | Description
Name | This is Name, a member of class TBSS_GreaterEQ.


TBSS_GreaterEQ.Name Property

TBSS_GreaterEQ.Name Property
TBSS_GreaterEQ Class BoldSqlSymbols Namespace See Also
Collapse All
C#
public override string Name;
Remarks

This is Name, a member of class TBSS_GreaterEQ.

See Also
TBSS_GreaterEQ Class
BoldSqlSymbols Namespace


TBSS_GroupFunctions Class

TBSS_GroupFunctions Class
Inheritance Hierarchy See Also
Collapse All
C#
public class TBSS_GroupFunctions : TBSS_Symbol;
Remarks

This is class BoldSqlSymbols.TBSS_GroupFunctions.

Inheritance Hierarchy
BoldSqlNodes.TBoldSqlSymbol
    BoldSqlSymbols.TBSS_Symbol
        BoldSqlSymbols.TBSS_GroupFunctions
            BoldSqlSymbols.TBSS_Average
            BoldSqlSymbols.TBSS_Maxvalue
            BoldSqlSymbols.TBSS_MinValue
            BoldSqlSymbols.TBSS_Sum
File

BoldSqlSymbols.cs

See Also
Inheritance Hierarchy


TBSS_GroupFunctions Methods

TBSS_GroupFunctions Methods
Public Methods
Collapse All

The methods of the TBSS_GroupFunctions class are listed here.

Public Methods
Name | Description
BuildWCFOrQuery | This is BuildWCFOrQuery, a member of class TBSS_GroupFunctions.


TBSS_GroupFunctions.BuildWCFOrQuery Method

TBSS_GroupFunctions.BuildWCFOrQuery Method
TBSS_GroupFunctions Class BoldSqlSymbols Namespace See Also
Collapse All
C#
public override void BuildWCFOrQuery(
    TBoldSqlOperation OperationNode,
    TBoldSQLNameSpace __NameSpace
);
Remarks

This is BuildWCFOrQuery, a member of class TBSS_GroupFunctions.

See Also
TBSS_GroupFunctions Class
BoldSqlSymbols Namespace


TBSS_implies Class

TBSS_implies Class
Inheritance Hierarchy See Also
Collapse All
C#
public class TBSS_implies : TBSS_BinarySymbol;
Remarks

This is class BoldSqlSymbols.TBSS_implies.

Inheritance Hierarchy
BoldSqlNodes.TBoldSqlSymbol
    BoldSqlSymbols.TBSS_Symbol
        BoldSqlSymbols.TBSS_BinarySymbol
            BoldSqlSymbols.TBSS_implies
File

BoldSqlSymbols.cs

See Also
Inheritance Hierarchy


TBSS_implies Methods

TBSS_implies Methods
Public Methods
Collapse All

The methods of the TBSS_implies class are listed here.

Public Methods
Name | Description
BuildWCFOrQuery | TBSS_BinarySymbol


TBSS_implies.BuildWCFOrQuery Method

TBSS_implies.BuildWCFOrQuery Method
TBSS_implies Class BoldSqlSymbols Namespace See Also
Collapse All
C#
public override void BuildWCFOrQuery(
    TBoldSqlOperation OperationNode,
    TBoldSQLNameSpace __NameSpace
);
Remarks

TBSS_BinarySymbol

See Also
TBSS_implies Class
BoldSqlSymbols Namespace


TBSS_includes Class

TBSS_includes Class
Inheritance Hierarchy See Also
Collapse All
C#
public class TBSS_includes : TBSS_Symbol;
Remarks

This is class BoldSqlSymbols.TBSS_includes.

Inheritance Hierarchy
BoldSqlNodes.TBoldSqlSymbol
    BoldSqlSymbols.TBSS_Symbol
        BoldSqlSymbols.TBSS_includes
File

BoldSqlSymbols.cs

See Also
Inheritance Hierarchy


TBSS_includes Methods

TBSS_includes Methods
Public Methods
Collapse All

The methods of the TBSS_includes class are listed here.

Public Methods
Name | Description
BuildWCFOrQuery | This is BuildWCFOrQuery, a member of class TBSS_includes.


TBSS_includes.BuildWCFOrQuery Method

TBSS_includes.BuildWCFOrQuery Method
TBSS_includes Class BoldSqlSymbols Namespace See Also
Collapse All
C#
public override void BuildWCFOrQuery(
    TBoldSqlOperation OperationNode,
    TBoldSQLNameSpace __NameSpace
);
Remarks

This is BuildWCFOrQuery, a member of class TBSS_includes.

See Also
TBSS_includes Class
BoldSqlSymbols Namespace


TBSS_Intersection Class

TBSS_Intersection Class
Inheritance Hierarchy See Also
Collapse All
C#
public class TBSS_Intersection : TBSS_ListOperations;
Remarks

This is class BoldSqlSymbols.TBSS_Intersection.

Inheritance Hierarchy
BoldSqlNodes.TBoldSqlSymbol
    BoldSqlSymbols.TBSS_Symbol
        BoldSqlSymbols.TBSS_ListOperations
            BoldSqlSymbols.TBSS_Intersection
File

BoldSqlSymbols.cs

See Also
Inheritance Hierarchy


TBSS_Intersection Methods

TBSS_Intersection Methods
Public Methods
Collapse All

The methods of the TBSS_Intersection class are listed here.

Public Methods
Name | Description
BuildWCFOrQuery | This is BuildWCFOrQuery, a member of class TBSS_Intersection.


TBSS_Intersection.BuildWCFOrQuery Method

TBSS_Intersection.BuildWCFOrQuery Method
TBSS_Intersection Class BoldSqlSymbols Namespace See Also
Collapse All
C#
public override void BuildWCFOrQuery(
    TBoldSqlOperation OperationNode,
    TBoldSQLNameSpace __NameSpace
);
Remarks

This is BuildWCFOrQuery, a member of class TBSS_Intersection.

See Also
TBSS_Intersection Class
BoldSqlSymbols Namespace


TBSS_isEmpty Class

TBSS_isEmpty Class
Inheritance Hierarchy See Also
Collapse All
C#
public class TBSS_isEmpty : TBSS_Symbol;
Remarks

This is class BoldSqlSymbols.TBSS_isEmpty.

Inheritance Hierarchy
BoldSqlNodes.TBoldSqlSymbol
    BoldSqlSymbols.TBSS_Symbol
        BoldSqlSymbols.TBSS_isEmpty
File

BoldSqlSymbols.cs

See Also
Inheritance Hierarchy


TBSS_isEmpty Methods

TBSS_isEmpty Methods
Public Methods
Collapse All

The methods of the TBSS_isEmpty class are listed here.

Public Methods
Name | Description
BuildWCFOrQuery | This is BuildWCFOrQuery, a member of class TBSS_isEmpty.


TBSS_isEmpty.BuildWCFOrQuery Method

TBSS_isEmpty.BuildWCFOrQuery Method
TBSS_isEmpty Class BoldSqlSymbols Namespace See Also
Collapse All
C#
public override void BuildWCFOrQuery(
    TBoldSqlOperation OperationNode,
    TBoldSQLNameSpace __NameSpace
);
Remarks

This is BuildWCFOrQuery, a member of class TBSS_isEmpty.

See Also
TBSS_isEmpty Class
BoldSqlSymbols Namespace


TBSS_isNull Class

TBSS_isNull Class
Inheritance Hierarchy See Also
Collapse All
C#
public class TBSS_isNull : TBSS_Symbol;
Remarks

This is class BoldSqlSymbols.TBSS_isNull.

Inheritance Hierarchy
BoldSqlNodes.TBoldSqlSymbol
    BoldSqlSymbols.TBSS_Symbol
        BoldSqlSymbols.TBSS_isNull
File

BoldSqlSymbols.cs

See Also
Inheritance Hierarchy


TBSS_isNull Methods

TBSS_isNull Methods
Public Methods
Collapse All

The methods of the TBSS_isNull class are listed here.

Public Methods
Name | Description
BuildWCFOrQuery | This is BuildWCFOrQuery, a member of class TBSS_isNull.


TBSS_isNull.BuildWCFOrQuery Method

TBSS_isNull.BuildWCFOrQuery Method
TBSS_isNull Class BoldSqlSymbols Namespace See Also
Collapse All
C#
public override void BuildWCFOrQuery(
    TBoldSqlOperation OperationNode,
    TBoldSQLNameSpace __NameSpace
);
Remarks

This is BuildWCFOrQuery, a member of class TBSS_isNull.

See Also
TBSS_isNull Class
BoldSqlSymbols Namespace


TBSS_Iteration Class

TBSS_Iteration Class
Inheritance Hierarchy See Also
Collapse All
C#
public class TBSS_Iteration : TBSS_Symbol;
Remarks

This is class BoldSqlSymbols.TBSS_Iteration.

Inheritance Hierarchy
BoldSqlNodes.TBoldSqlSymbol
    BoldSqlSymbols.TBSS_Symbol
        BoldSqlSymbols.TBSS_Iteration
            BoldSqlSymbols.TBSS_AbstractOrder
            BoldSqlSymbols.TBSS_Exists
            BoldSqlSymbols.TBSS_ForAll
            BoldSqlSymbols.TBSS_reject
            BoldSqlSymbols.TBSS_Select
File

BoldSqlSymbols.cs

See Also
Inheritance Hierarchy


TBSS_Iteration Methods

TBSS_Iteration Methods
Public Methods
Collapse All

The methods of the TBSS_Iteration class are listed here.

Public Methods
Name | Description
ResolveObjectMapper | This is ResolveObjectMapper, a member of class TBSS_Iteration.


TBSS_Iteration.ResolveObjectMapper Method

TBSS_Iteration.ResolveObjectMapper Method
TBSS_Iteration Class BoldSqlSymbols Namespace See Also
Collapse All
C#
public override ClassPersistenceMapper ResolveObjectMapper(
    TBoldSqlOperation OperationNode
);
Remarks

This is ResolveObjectMapper, a member of class TBSS_Iteration.

See Also
TBSS_Iteration Class
BoldSqlSymbols Namespace


TBSS_Length Class

TBSS_Length Class
Inheritance Hierarchy See Also
Collapse All
C#
public class TBSS_Length : TBSS_UnarySymbol;
Remarks

This is class BoldSqlSymbols.TBSS_Length.

Inheritance Hierarchy
BoldSqlNodes.TBoldSqlSymbol
    BoldSqlSymbols.TBSS_Symbol
        BoldSqlSymbols.TBSS_UnarySymbol
            BoldSqlSymbols.TBSS_Length
File

BoldSqlSymbols.cs

See Also
Inheritance Hierarchy


TBSS_Length Methods

TBSS_Length Methods
Public Methods
Collapse All

The methods of the TBSS_Length class are listed here.

Public Methods
Name | Description
BuildWCFOrQuery | This is BuildWCFOrQuery, a member of class TBSS_Length.


TBSS_Length.BuildWCFOrQuery Method

TBSS_Length.BuildWCFOrQuery Method
TBSS_Length Class BoldSqlSymbols Namespace See Also
Collapse All
C#
public override void BuildWCFOrQuery(
    TBoldSqlOperation OperationNode,
    TBoldSQLNameSpace __NameSpace
);
Remarks

This is BuildWCFOrQuery, a member of class TBSS_Length.

See Also
TBSS_Length Class
BoldSqlSymbols Namespace


TBSS_Less Class

TBSS_Less Class
Inheritance Hierarchy See Also
Collapse All
C#
public class TBSS_Less : TBSS_BinaryBooleanSymbol;
Remarks

This is class BoldSqlSymbols.TBSS_Less.

Inheritance Hierarchy
BoldSqlNodes.TBoldSqlSymbol
    BoldSqlSymbols.TBSS_Symbol
        BoldSqlSymbols.TBSS_BinarySymbol
            BoldSqlSymbols.TBSS_BinaryBooleanSymbol
                BoldSqlSymbols.TBSS_Less
File

BoldSqlSymbols.cs

See Also
Inheritance Hierarchy


TBSS_Less Properties

TBSS_Less Properties
Public Properties
Collapse All

The properties of the TBSS_Less class are listed here.

Public Properties
Name | Description
Name | This is Name, a member of class TBSS_Less.


TBSS_Less.Name Property

TBSS_Less.Name Property
TBSS_Less Class BoldSqlSymbols Namespace See Also
Collapse All
C#
public override string Name;
Remarks

This is Name, a member of class TBSS_Less.

See Also
TBSS_Less Class
BoldSqlSymbols Namespace


TBSS_LessEQ Class

TBSS_LessEQ Class
Inheritance Hierarchy See Also
Collapse All
C#
public class TBSS_LessEQ : TBSS_BinaryBooleanSymbol;
Remarks

This is class BoldSqlSymbols.TBSS_LessEQ.

Inheritance Hierarchy
BoldSqlNodes.TBoldSqlSymbol
    BoldSqlSymbols.TBSS_Symbol
        BoldSqlSymbols.TBSS_BinarySymbol
            BoldSqlSymbols.TBSS_BinaryBooleanSymbol
                BoldSqlSymbols.TBSS_LessEQ
File

BoldSqlSymbols.cs

See Also
Inheritance Hierarchy


TBSS_LessEQ Properties

TBSS_LessEQ Properties
Public Properties
Collapse All

The properties of the TBSS_LessEQ class are listed here.

Public Properties
Name | Description
Name | This is Name, a member of class TBSS_LessEQ.


TBSS_LessEQ.Name Property

TBSS_LessEQ.Name Property
TBSS_LessEQ Class BoldSqlSymbols Namespace See Also
Collapse All
C#
public override string Name;
Remarks

This is Name, a member of class TBSS_LessEQ.

See Also
TBSS_LessEQ Class
BoldSqlSymbols Namespace


TBSS_ListOperations Class

TBSS_ListOperations Class
Inheritance Hierarchy See Also
Collapse All
C#
public class TBSS_ListOperations : TBSS_Symbol;
Remarks

This is class BoldSqlSymbols.TBSS_ListOperations.

Inheritance Hierarchy
BoldSqlNodes.TBoldSqlSymbol
    BoldSqlSymbols.TBSS_Symbol
        BoldSqlSymbols.TBSS_ListOperations
            BoldSqlSymbols.TBSS_Difference
            BoldSqlSymbols.TBSS_Intersection
            BoldSqlSymbols.TBSS_SymmetricDifference
            BoldSqlSymbols.TBSS_union
File

BoldSqlSymbols.cs

See Also
Inheritance Hierarchy


TBSS_ListOperations Methods

TBSS_ListOperations Methods
Protected Methods Public Methods
Collapse All

The methods of the TBSS_ListOperations class are listed here.

Protected Methods
Name | Description
CreateBoldIdMatchWCF | This is CreateBoldIdMatchWCF, a member of class TBSS_ListOperations.
Top
Public Methods
Name | Description
ResolveObjectMapper | This is ResolveObjectMapper, a member of class TBSS_ListOperations.


TBSS_ListOperations.CreateBoldIdMatchWCF Method

TBSS_ListOperations.CreateBoldIdMatchWCF Method
TBSS_ListOperations Class BoldSqlSymbols Namespace See Also
Collapse All
C#
protected TBoldSqlWCF CreateBoldIdMatchWCF(
    TBoldSqlOperation MainNode,
    TBoldSqlNode ArgNode
);
Remarks

This is CreateBoldIdMatchWCF, a member of class TBSS_ListOperations.

See Also
TBSS_ListOperations Class
BoldSqlSymbols Namespace


TBSS_ListOperations.ResolveObjectMapper Method

TBSS_ListOperations.ResolveObjectMapper Method
TBSS_ListOperations Class BoldSqlSymbols Namespace See Also
Collapse All
C#
public override ClassPersistenceMapper ResolveObjectMapper(
    TBoldSqlOperation OperationNode
);
Remarks

This is ResolveObjectMapper, a member of class TBSS_ListOperations.

See Also
TBSS_ListOperations Class
BoldSqlSymbols Namespace


TBSS_Maxvalue Class

TBSS_Maxvalue Class
Inheritance Hierarchy See Also
Collapse All
C#
public class TBSS_Maxvalue : TBSS_GroupFunctions;
Remarks

This is class BoldSqlSymbols.TBSS_Maxvalue.

Inheritance Hierarchy
BoldSqlNodes.TBoldSqlSymbol
    BoldSqlSymbols.TBSS_Symbol
        BoldSqlSymbols.TBSS_GroupFunctions
            BoldSqlSymbols.TBSS_Maxvalue
File

BoldSqlSymbols.cs

See Also
Inheritance Hierarchy


TBSS_Maxvalue Properties

TBSS_Maxvalue Properties
Public Properties
Collapse All

The properties of the TBSS_Maxvalue class are listed here.

Public Properties
Name | Description
SqlName | This is SqlName, a member of class TBSS_Maxvalue.


TBSS_Maxvalue.SqlName Property

TBSS_Maxvalue.SqlName Property
TBSS_Maxvalue Class BoldSqlSymbols Namespace See Also
Collapse All
C#
public override string SqlName;
Remarks

This is SqlName, a member of class TBSS_Maxvalue.

See Also
TBSS_Maxvalue Class
BoldSqlSymbols Namespace


TBSS_MinValue Class

TBSS_MinValue Class
Inheritance Hierarchy See Also
Collapse All
C#
public class TBSS_MinValue : TBSS_GroupFunctions;
Remarks

This is class BoldSqlSymbols.TBSS_MinValue.

Inheritance Hierarchy
BoldSqlNodes.TBoldSqlSymbol
    BoldSqlSymbols.TBSS_Symbol
        BoldSqlSymbols.TBSS_GroupFunctions
            BoldSqlSymbols.TBSS_MinValue
File

BoldSqlSymbols.cs

See Also
Inheritance Hierarchy


TBSS_MinValue Properties

TBSS_MinValue Properties
Public Properties
Collapse All

The properties of the TBSS_MinValue class are listed here.

Public Properties
Name | Description
SqlName | This is SqlName, a member of class TBSS_MinValue.


TBSS_MinValue.SqlName Property

TBSS_MinValue.SqlName Property
TBSS_MinValue Class BoldSqlSymbols Namespace See Also
Collapse All
C#
public override string SqlName;
Remarks

This is SqlName, a member of class TBSS_MinValue.

See Also
TBSS_MinValue Class
BoldSqlSymbols Namespace


TBSS_Mod Class

TBSS_Mod Class
Inheritance Hierarchy See Also
Collapse All
C#
public class TBSS_Mod : TBSS_PrefixBinarySymbol;
Remarks

This is class BoldSqlSymbols.TBSS_Mod.

Inheritance Hierarchy
BoldSqlNodes.TBoldSqlSymbol
    BoldSqlSymbols.TBSS_Symbol
        BoldSqlSymbols.TBSS_PrefixBinarySymbol
            BoldSqlSymbols.TBSS_Mod
File

BoldSqlSymbols.cs

See Also
Inheritance Hierarchy


TBSS_ModifiedSinceTimeStamp Class

TBSS_ModifiedSinceTimeStamp Class
Inheritance Hierarchy See Also
Collapse All
C#
public class TBSS_ModifiedSinceTimeStamp : TBSS_BinarySymbol;
Remarks

end TBSS_BinarySymbol

Inheritance Hierarchy
BoldSqlNodes.TBoldSqlSymbol
    BoldSqlSymbols.TBSS_Symbol
        BoldSqlSymbols.TBSS_BinarySymbol
            BoldSqlSymbols.TBSS_ModifiedSinceTimeStamp
File

BoldSqlSymbols.cs

See Also
Inheritance Hierarchy


TBSS_ModifiedSinceTimeStamp Methods

TBSS_ModifiedSinceTimeStamp Methods
Public Methods
Collapse All

The methods of the TBSS_ModifiedSinceTimeStamp class are listed here.

Public Methods
Name | Description
BuildWCFOrQuery | TBSS_BinarySymbol


TBSS_ModifiedSinceTimeStamp.BuildWCFOrQuery Method

TBSS_ModifiedSinceTimeStamp.BuildWCFOrQuery Method
TBSS_ModifiedSinceTimeStamp Class BoldSqlSymbols Namespace See Also
Collapse All
C#
public override void BuildWCFOrQuery(
    TBoldSqlOperation OperationNode,
    TBoldSQLNameSpace __NameSpace
);
Remarks

TBSS_BinarySymbol

See Also
TBSS_ModifiedSinceTimeStamp Class
BoldSqlSymbols Namespace


TBSS_Multiply Class

TBSS_Multiply Class
Inheritance Hierarchy See Also
Collapse All
C#
public class TBSS_Multiply : TBSS_BinarySymbol;
Remarks

This is class BoldSqlSymbols.TBSS_Multiply.

Inheritance Hierarchy
BoldSqlNodes.TBoldSqlSymbol
    BoldSqlSymbols.TBSS_Symbol
        BoldSqlSymbols.TBSS_BinarySymbol
            BoldSqlSymbols.TBSS_Multiply
File

BoldSqlSymbols.cs

See Also
Inheritance Hierarchy


TBSS_Multiply Properties

TBSS_Multiply Properties
Public Properties
Collapse All

The properties of the TBSS_Multiply class are listed here.

Public Properties
Name | Description
Name | This is Name, a member of class TBSS_Multiply.


TBSS_Multiply.Name Property

TBSS_Multiply.Name Property
TBSS_Multiply Class BoldSqlSymbols Namespace See Also
Collapse All
C#
public override string Name;
Remarks

This is Name, a member of class TBSS_Multiply.

See Also
TBSS_Multiply Class
BoldSqlSymbols Namespace


TBSS_not Class

TBSS_not Class
Inheritance Hierarchy See Also
Collapse All
C#
public class TBSS_not : TBSS_UnarySymbol;
Remarks

This is class BoldSqlSymbols.TBSS_not.

Inheritance Hierarchy
BoldSqlNodes.TBoldSqlSymbol
    BoldSqlSymbols.TBSS_Symbol
        BoldSqlSymbols.TBSS_UnarySymbol
            BoldSqlSymbols.TBSS_not
File

BoldSqlSymbols.cs

See Also
Inheritance Hierarchy


TBSS_NotEmpty Class

TBSS_NotEmpty Class
Inheritance Hierarchy See Also
Collapse All
C#
public class TBSS_NotEmpty : TBSS_Symbol;
Remarks

This is class BoldSqlSymbols.TBSS_NotEmpty.

Inheritance Hierarchy
BoldSqlNodes.TBoldSqlSymbol
    BoldSqlSymbols.TBSS_Symbol
        BoldSqlSymbols.TBSS_NotEmpty
File

BoldSqlSymbols.cs

See Also
Inheritance Hierarchy


TBSS_NotEmpty Methods

TBSS_NotEmpty Methods
Public Methods
Collapse All

The methods of the TBSS_NotEmpty class are listed here.

Public Methods
Name | Description
BuildWCFOrQuery | This is BuildWCFOrQuery, a member of class TBSS_NotEmpty.


TBSS_NotEmpty.BuildWCFOrQuery Method

TBSS_NotEmpty.BuildWCFOrQuery Method
TBSS_NotEmpty Class BoldSqlSymbols Namespace See Also
Collapse All
C#
public override void BuildWCFOrQuery(
    TBoldSqlOperation OperationNode,
    TBoldSQLNameSpace __NameSpace
);
Remarks

This is BuildWCFOrQuery, a member of class TBSS_NotEmpty.

See Also
TBSS_NotEmpty Class
BoldSqlSymbols Namespace


TBSS_NotEqual Class

TBSS_NotEqual Class
Inheritance Hierarchy See Also
Collapse All
C#
public class TBSS_NotEqual : TBSS_BinaryBooleanSymbol;
Remarks

This is class BoldSqlSymbols.TBSS_NotEqual.

Inheritance Hierarchy
BoldSqlNodes.TBoldSqlSymbol
    BoldSqlSymbols.TBSS_Symbol
        BoldSqlSymbols.TBSS_BinarySymbol
            BoldSqlSymbols.TBSS_BinaryBooleanSymbol
                BoldSqlSymbols.TBSS_NotEqual
File

BoldSqlSymbols.cs

See Also
Inheritance Hierarchy


TBSS_NotEqual Properties

TBSS_NotEqual Properties
Public Properties
Collapse All

The properties of the TBSS_NotEqual class are listed here.

Public Properties
Name | Description
Name | This is Name, a member of class TBSS_NotEqual.


TBSS_NotEqual.Name Property

TBSS_NotEqual.Name Property
TBSS_NotEqual Class BoldSqlSymbols Namespace See Also
Collapse All
C#
public override string Name;
Remarks

This is Name, a member of class TBSS_NotEqual.

See Also
TBSS_NotEqual Class
BoldSqlSymbols Namespace


TBSS_OclAsType Class

TBSS_OclAsType Class
Inheritance Hierarchy See Also
Collapse All
C#
public class TBSS_OclAsType : TBSS_Symbol;
Remarks

(* TBSS_OclIsTypeOf = class(TBSS_BinarySymbol) public procedure BuildWCFOrQuery(OperationNode: TBoldSQLOperation; NameSpace: TBoldSqlNameSpace); override; end;

TBSS_OclIsKindOf = class(TBSS_BinarySymbol) public procedure BuildWCFOrQuery(OperationNode: TBoldSQLOperation; NameSpace: TBoldSqlNameSpace); override; end;

TBSS_FilterOnType = class(TBSS_Symbol) public function ResolveObjectMapper(OperationNode: TBoldSqlOperation): TBoldObjectPersistenceMapper; override; procedure BuildWCFOrQuery(OperationNode: TBoldSQLOperation; NameSpace: TBoldSqlNameSpace); override; end; *)

Inheritance Hierarchy
BoldSqlNodes.TBoldSqlSymbol
    BoldSqlSymbols.TBSS_Symbol
        BoldSqlSymbols.TBSS_OclAsType
File

BoldSqlSymbols.cs

See Also
Inheritance Hierarchy


TBSS_OclAsType Methods

TBSS_OclAsType Methods
Public Methods
Collapse All

The methods of the TBSS_OclAsType class are listed here.

Public Methods
Name
Description
BuildWCFOrQuery
(* { TBSS_OclIsTypeOf }
procedure TBSS_OclIsTypeOf.BuildWCFOrQuery( OperationNode: TBoldSQLOperation; NameSpace: TBoldSqlNameSpace); var TypeColRef: TBoldSQLWCFColumnRef; TypeValue: TBoldSQLWCFInteger; begin TypeColRef := TBoldSQLWCFColumnRef.Create(OperationNode.Args[0].MainAliasRef(nil).GetColumnReference(TYPECOLUMN_NAME)); {$MESSAGE WARN 'OclIsTypeOf is disabled in Ocl2Ps, need to find complete and sufficient discriminator'} // TypeValue := TBoldSQLWCFInteger.Create(OperationNode.Args[1].ObjectMapper.BoldDbType); OperationNode.WCF := TBoldSQLWCFBinaryInfix.Create(TypeColRef, TypeValue, '='); CollectArgWCFs(OperationNode); { This code has been commented for some time if OPerationNode.Args[0].HasQuery then OperationNode.Query := OperationNode.Args[0].RelinquishQuery(); if assigned(OperationNode.Args[0].WCF) then OperationNode.WCF := TBoldSQLWCFBinaryInfix.Create(OperationNode.WCF, OperationNode.Args[0].WCF, 'AND'); } end;
{ TBSS_OclIsKindOf }
procedure TBSS_OclIsKindOf.BuildWCFOrQuery( OperationNode: TBoldSQLOperation; NameSpace: TBoldSqlNameSpace); var TypeColRef: TBoldSQLWCFColumnRef; TypeValue: TBoldSQLWCFGenericExpression; ObjectMapper: TBoldObjectPersistenceMapper; begin ObjectMapper := OperationNode.Args[1].ObjectMapper; TypeColRef := TBoldSQLWCFColumnRef.Create(OperationNode.Args[0].MainAliasRef(nil).GetColumnReference(TYPECOLUMN_NAME)); {$MESSAGE WARN 'OclIsKindOf is disabled... more
ResolveObjectMapper
This is ResolveObjectMapper, a member of class TBSS_OclAsType.


TBSS_OclAsType.BuildWCFOrQuery Method

TBSS_OclAsType.BuildWCFOrQuery Method
TBSS_OclAsType Class BoldSqlSymbols Namespace See Also
Collapse All
C#
public override void BuildWCFOrQuery(
    TBoldSqlOperation OperationNode,
    TBoldSQLNameSpace __NameSpace
);
Returns

= OperationNode.Args[1].ObjectMapper; end; *) TBSS_OclAsType

Remarks

(* { TBSS_OclIsTypeOf }

procedure TBSS_OclIsTypeOf.BuildWCFOrQuery( OperationNode: TBoldSQLOperation; NameSpace: TBoldSqlNameSpace); var TypeColRef: TBoldSQLWCFColumnRef; TypeValue: TBoldSQLWCFInteger; begin TypeColRef := TBoldSQLWCFColumnRef.Create(OperationNode.Args[0].MainAliasRef(nil).GetColumnReference(TYPECOLUMN_NAME)); {$MESSAGE WARN 'OclIsTypeOf is disabled in Ocl2Ps, need to find complete and sufficient discriminator'} // TypeValue := TBoldSQLWCFInteger.Create(OperationNode.Args[1].ObjectMapper.BoldDbType); OperationNode.WCF := TBoldSQLWCFBinaryInfix.Create(TypeColRef, TypeValue, '='); CollectArgWCFs(OperationNode); { This code has been commented for some time if OPerationNode.Args[0].HasQuery then OperationNode.Query := OperationNode.Args[0].RelinquishQuery(); if assigned(OperationNode.Args[0].WCF) then OperationNode.WCF := TBoldSQLWCFBinaryInfix.Create(OperationNode.WCF, OperationNode.Args[0].WCF, 'AND'); } end;

{ TBSS_OclIsKindOf }

procedure TBSS_OclIsKindOf.BuildWCFOrQuery( OperationNode: TBoldSQLOperation; NameSpace: TBoldSqlNameSpace); var TypeColRef: TBoldSQLWCFColumnRef; TypeValue: TBoldSQLWCFGenericExpression; ObjectMapper: TBoldObjectPersistenceMapper; begin ObjectMapper := OperationNode.Args[1].ObjectMapper; TypeColRef := TBoldSQLWCFColumnRef.Create(OperationNode.Args[0].MainAliasRef(nil).GetColumnReference(TYPECOLUMN_NAME)); {$MESSAGE WARN 'OclIsKindOf is disabled in Ocl2Ps, need to find complete and sufficient discriminator'} // TypeValue := TBoldSQLWCFGenericExpression.Create('(' + ObjectMapper.SubClassesID + ')'); OperationNode.WCF := TBoldSQLWCFBinaryInfix.Create(TypeColRef, TypeValue, 'in'); CollectArgWCFs(OperationNode); end;

{ TBSS_FilterOnType }

procedure TBSS_FilterOnType.BuildWCFOrQuery( OperationNode: TBoldSQLOperation; NameSpace: TBoldSqlNameSpace); var TypeColRef: TBoldSQLWCFColumnRef; TypeValue: TBoldSQLWCFGenericExpression; ObjectMapper: TBoldObjectPersistenceMapper; WCF: TBoldSQLWCF; begin ObjectMapper := OperationNode.Args[1].ObjectMapper; TypeColRef := TBoldSQLWCFColumnRef.Create(OperationNode.Args[0].MainAliasRef(nil).GetColumnReference(TYPECOLUMN_NAME)); {$MESSAGE WARN 'FilterOnType is disabled in Ocl2Ps, need to find complete and sufficient discriminator'} // TypeValue := TBoldSQLWCFGenericExpression.Create('(' + ObjectMapper.SubClassesID + ')'); WCF := TBoldSQLWCFBinaryInfix.Create(TypeColRef, TypeValue, 'IN'); { do not localize }

if OperationNode.Args[0].HasQuery then OperationNode.Query := OperationNode.Args[0].RelinquishQuery();

if OperationNode.HasQuery then OPerationNode.Query.AddWCF(WCF) else begin if assigned(OperationNode.Args[0].WCF) then WCF := TBoldSQLWCFBinaryInfix.Create(WCF, OperationNode.Args[0].RelinquishWCF(), 'AND'); { do not localize } OperationNode.WCF := WCF; end;

OperationNode.CopyAliasReferences(OPerationNode.Args[0]); end;

function TBSS_FilterOnType.ResolveObjectMapper( OperationNode: TBoldSqlOperation): TBoldObjectPersistenceMapper; begin

See Also
TBSS_OclAsType Class
BoldSqlSymbols Namespace


TBSS_OclAsType.ResolveObjectMapper Method

TBSS_OclAsType.ResolveObjectMapper Method
TBSS_OclAsType Class BoldSqlSymbols Namespace See Also
Collapse All
C#
public override ClassPersistenceMapper ResolveObjectMapper(
    TBoldSqlOperation OperationNode
);
Remarks

This is ResolveObjectMapper, a member of class TBSS_OclAsType.

See Also
TBSS_OclAsType Class
BoldSqlSymbols Namespace


TBSS_or Class

TBSS_or Class
Inheritance Hierarchy See Also
Collapse All
C#
public class TBSS_or : TBSS_BinarySymbol;
Remarks

This is class BoldSqlSymbols.TBSS_or.

Inheritance Hierarchy
BoldSqlNodes.TBoldSqlSymbol
    BoldSqlSymbols.TBSS_Symbol
        BoldSqlSymbols.TBSS_BinarySymbol
            BoldSqlSymbols.TBSS_or
File

BoldSqlSymbols.cs

See Also
Inheritance Hierarchy


TBSS_orderby Class

TBSS_orderby Class
Inheritance Hierarchy See Also
Collapse All
C#
public class TBSS_orderby : TBSS_AbstractOrder;
Remarks

This is class BoldSqlSymbols.TBSS_orderby.

Inheritance Hierarchy
BoldSqlNodes.TBoldSqlSymbol
    BoldSqlSymbols.TBSS_Symbol
        BoldSqlSymbols.TBSS_Iteration
            BoldSqlSymbols.TBSS_AbstractOrder
                BoldSqlSymbols.TBSS_orderby
File

BoldSqlSymbols.cs

See Also
Inheritance Hierarchy


TBSS_orderby Methods

TBSS_orderby Methods
Public Methods
Collapse All

The methods of the TBSS_orderby class are listed here.

Public Methods
Name | Description
GetArgCount | This is GetArgCount, a member of class TBSS_orderby.
GetDirection | This is GetDirection, a member of class TBSS_orderby.
GetNode | This is GetNode, a member of class TBSS_orderby.


TBSS_orderby.GetArgCount Method

TBSS_orderby.GetArgCount Method
TBSS_orderby Class BoldSqlSymbols Namespace See Also
Collapse All
C#
public override int GetArgCount(
    TBoldSqlNodeList Args
);
Remarks

This is GetArgCount, a member of class TBSS_orderby.

See Also
TBSS_orderby Class
BoldSqlSymbols Namespace


TBSS_orderby.GetDirection Method

TBSS_orderby.GetDirection Method
TBSS_orderby Class BoldSqlSymbols Namespace See Also
Collapse All
C#
public override OclSortDirection GetDirection(
    TBoldSqlNodeList Args,
    int index
);
Remarks

This is GetDirection, a member of class TBSS_orderby.

See Also
TBSS_orderby Class
BoldSqlSymbols Namespace


TBSS_orderby.GetNode Method

TBSS_orderby.GetNode Method
TBSS_orderby Class BoldSqlSymbols Namespace See Also
Collapse All
C#
public override TBoldSqlNode GetNode(
    TBoldSqlNodeList Args,
    int index
);
Remarks

This is GetNode, a member of class TBSS_orderby.

See Also
TBSS_orderby Class
BoldSqlSymbols Namespace


TBSS_orderDescending Class

TBSS_orderDescending Class
Inheritance Hierarchy See Also
Collapse All
C#
public class TBSS_orderDescending : TBSS_AbstractOrder;
Remarks

This is class BoldSqlSymbols.TBSS_orderDescending.

Inheritance Hierarchy
BoldSqlNodes.TBoldSqlSymbol
    BoldSqlSymbols.TBSS_Symbol
        BoldSqlSymbols.TBSS_Iteration
            BoldSqlSymbols.TBSS_AbstractOrder
                BoldSqlSymbols.TBSS_orderDescending
File

BoldSqlSymbols.cs

See Also
Inheritance Hierarchy


TBSS_orderDescending Methods

TBSS_orderDescending Methods
Public Methods
Collapse All

The methods of the TBSS_orderDescending class are listed here.

Public Methods
Name | Description
GetArgCount | This is GetArgCount, a member of class TBSS_orderDescending.
GetDirection | This is GetDirection, a member of class TBSS_orderDescending.
GetNode | This is GetNode, a member of class TBSS_orderDescending.


TBSS_orderDescending.GetArgCount Method

TBSS_orderDescending.GetArgCount Method
TBSS_orderDescending Class BoldSqlSymbols Namespace See Also
Collapse All
C#
public override int GetArgCount(
    TBoldSqlNodeList Args
);
Remarks

This is GetArgCount, a member of class TBSS_orderDescending.

See Also
TBSS_orderDescending Class
BoldSqlSymbols Namespace


TBSS_orderDescending.GetDirection Method

TBSS_orderDescending.GetDirection Method
TBSS_orderDescending Class BoldSqlSymbols Namespace See Also
Collapse All
C#
public override OclSortDirection GetDirection(
    TBoldSqlNodeList Args,
    int index
);
Remarks

This is GetDirection, a member of class TBSS_orderDescending.

See Also
TBSS_orderDescending Class
BoldSqlSymbols Namespace


TBSS_orderDescending.GetNode Method

TBSS_orderDescending.GetNode Method
TBSS_orderDescending Class BoldSqlSymbols Namespace See Also
Collapse All
C#
public override TBoldSqlNode GetNode(
    TBoldSqlNodeList Args,
    int index
);
Remarks

This is GetNode, a member of class TBSS_orderDescending.

See Also
TBSS_orderDescending Class
BoldSqlSymbols Namespace


TBSS_orderGeneric Class

TBSS_orderGeneric Class
Inheritance Hierarchy See Also
Collapse All
C#
public class TBSS_orderGeneric : TBSS_AbstractOrder;
Remarks

This is class BoldSqlSymbols.TBSS_orderGeneric.

Inheritance Hierarchy
BoldSqlNodes.TBoldSqlSymbol
    BoldSqlSymbols.TBSS_Symbol
        BoldSqlSymbols.TBSS_Iteration
            BoldSqlSymbols.TBSS_AbstractOrder
                BoldSqlSymbols.TBSS_orderGeneric
File

BoldSqlSymbols.cs

See Also
Inheritance Hierarchy


TBSS_orderGeneric Methods

TBSS_orderGeneric Methods
Public Methods
Collapse All

The methods of the TBSS_orderGeneric class are listed here.

Public Methods
Name | Description
GetArgCount | This is GetArgCount, a member of class TBSS_orderGeneric.
GetDirection | This is GetDirection, a member of class TBSS_orderGeneric.
GetNode | This is GetNode, a member of class TBSS_orderGeneric.


TBSS_orderGeneric.GetArgCount Method

TBSS_orderGeneric.GetArgCount Method
TBSS_orderGeneric Class BoldSqlSymbols Namespace See Also
Collapse All
C#
public override int GetArgCount(
    TBoldSqlNodeList Args
);
Remarks

This is GetArgCount, a member of class TBSS_orderGeneric.

See Also
TBSS_orderGeneric Class
BoldSqlSymbols Namespace


TBSS_orderGeneric.GetDirection Method

TBSS_orderGeneric.GetDirection Method
TBSS_orderGeneric Class BoldSqlSymbols Namespace See Also
Collapse All
C#
public override OclSortDirection GetDirection(
    TBoldSqlNodeList Args,
    int index
);
Remarks

This is GetDirection, a member of class TBSS_orderGeneric.

See Also
TBSS_orderGeneric Class
BoldSqlSymbols Namespace


TBSS_orderGeneric.GetNode Method

TBSS_orderGeneric.GetNode Method
TBSS_orderGeneric Class BoldSqlSymbols Namespace See Also
Collapse All
C#
public override TBoldSqlNode GetNode(
    TBoldSqlNodeList Args,
    int index
);
Remarks

This is GetNode, a member of class TBSS_orderGeneric.

See Also
TBSS_orderGeneric Class
BoldSqlSymbols Namespace


TBSS_PrefixBinarySymbol Class

TBSS_PrefixBinarySymbol Class
Inheritance Hierarchy See Also
Collapse All
C#
public class TBSS_PrefixBinarySymbol : TBSS_Symbol;
Remarks

This is class BoldSqlSymbols.TBSS_PrefixBinarySymbol.

Inheritance Hierarchy
BoldSqlNodes.TBoldSqlSymbol
    BoldSqlSymbols.TBSS_Symbol
        BoldSqlSymbols.TBSS_PrefixBinarySymbol
            BoldSqlSymbols.TBSS_Div
            BoldSqlSymbols.TBSS_Mod
File

BoldSqlSymbols.cs

See Also
Inheritance Hierarchy


TBSS_PrefixBinarySymbol Methods

TBSS_PrefixBinarySymbol Methods
Public Methods
Collapse All

The methods of the TBSS_PrefixBinarySymbol class are listed here.

Public Methods
Name | Description
BuildWCFOrQuery | This is BuildWCFOrQuery, a member of class TBSS_PrefixBinarySymbol.


TBSS_PrefixBinarySymbol.BuildWCFOrQuery Method

TBSS_PrefixBinarySymbol.BuildWCFOrQuery Method
TBSS_PrefixBinarySymbol Class BoldSqlSymbols Namespace See Also
Collapse All
C#
public override void BuildWCFOrQuery(
    TBoldSqlOperation OperationNode,
    TBoldSQLNameSpace __NameSpace
);
Remarks

This is BuildWCFOrQuery, a member of class TBSS_PrefixBinarySymbol.

See Also
TBSS_PrefixBinarySymbol Class
BoldSqlSymbols Namespace


TBSS_reject Class

TBSS_reject Class
Inheritance Hierarchy See Also
Collapse All
C#
public class TBSS_reject : TBSS_Iteration;
Remarks

This is class BoldSqlSymbols.TBSS_reject.

Inheritance Hierarchy
BoldSqlNodes.TBoldSqlSymbol
    BoldSqlSymbols.TBSS_Symbol
        BoldSqlSymbols.TBSS_Iteration
            BoldSqlSymbols.TBSS_reject
File

BoldSqlSymbols.cs

See Also
Inheritance Hierarchy


TBSS_reject Methods

TBSS_reject Methods
Public Methods
Collapse All

The methods of the TBSS_reject class are listed here.

Public Methods
Name | Description
BuildWCFOrQuery | This is BuildWCFOrQuery, a member of class TBSS_reject.


TBSS_reject.BuildWCFOrQuery Method

TBSS_reject.BuildWCFOrQuery Method
TBSS_reject Class BoldSqlSymbols Namespace See Also
Collapse All
C#
public override void BuildWCFOrQuery(
    TBoldSqlOperation OperationNode,
    TBoldSQLNameSpace __NameSpace
);
Remarks

This is BuildWCFOrQuery, a member of class TBSS_reject.

See Also
TBSS_reject Class
BoldSqlSymbols Namespace


TBSS_Round Class

TBSS_Round Class
Inheritance Hierarchy See Also
Collapse All
C#
public class TBSS_Round : TBSS_UnarySymbol;
Remarks

This is class BoldSqlSymbols.TBSS_Round.

Inheritance Hierarchy
BoldSqlNodes.TBoldSqlSymbol
    BoldSqlSymbols.TBSS_Symbol
        BoldSqlSymbols.TBSS_UnarySymbol
            BoldSqlSymbols.TBSS_Round
File

BoldSqlSymbols.cs

See Also
Inheritance Hierarchy


TBSS_Select Class

TBSS_Select Class
Inheritance Hierarchy See Also
Collapse All
C#
public class TBSS_Select : TBSS_Iteration;
Remarks

This is class BoldSqlSymbols.TBSS_Select.

Inheritance Hierarchy
BoldSqlNodes.TBoldSqlSymbol
    BoldSqlSymbols.TBSS_Symbol
        BoldSqlSymbols.TBSS_Iteration
            BoldSqlSymbols.TBSS_Select
File

BoldSqlSymbols.cs

See Also
Inheritance Hierarchy


TBSS_Select Methods

TBSS_Select Methods
Public Methods
Collapse All

The methods of the TBSS_Select class are listed here.

Public Methods
Name | Description
BuildWCFOrQuery | This is BuildWCFOrQuery, a member of class TBSS_Select.


TBSS_Select.BuildWCFOrQuery Method

TBSS_Select.BuildWCFOrQuery Method
TBSS_Select Class BoldSqlSymbols Namespace See Also
Collapse All
C#
public override void BuildWCFOrQuery(
    TBoldSqlOperation OperationNode,
    TBoldSQLNameSpace __NameSpace
);
Remarks

This is BuildWCFOrQuery, a member of class TBSS_Select.

See Also
TBSS_Select Class
BoldSqlSymbols Namespace


TBSS_Size Class

TBSS_Size Class
Inheritance Hierarchy See Also
Collapse All
C#
public class TBSS_Size : TBSS_Symbol;
Remarks

This is class BoldSqlSymbols.TBSS_Size.

Inheritance Hierarchy
BoldSqlNodes.TBoldSqlSymbol
    BoldSqlSymbols.TBSS_Symbol
        BoldSqlSymbols.TBSS_Size
File

BoldSqlSymbols.cs

See Also
Inheritance Hierarchy


TBSS_Size Methods

TBSS_Size Methods
Public Methods
Collapse All

The methods of the TBSS_Size class are listed here.

Public Methods
Name | Description
BuildWCFOrQuery | This is BuildWCFOrQuery, a member of class TBSS_Size.


TBSS_Size.BuildWCFOrQuery Method

TBSS_Size.BuildWCFOrQuery Method
TBSS_Size Class BoldSqlSymbols Namespace See Also
Collapse All
C#
public override void BuildWCFOrQuery(
    TBoldSqlOperation OperationNode,
    TBoldSQLNameSpace __NameSpace
);
Remarks

This is BuildWCFOrQuery, a member of class TBSS_Size.

See Also
TBSS_Size Class
BoldSqlSymbols Namespace


TBSS_SQLLike Class

TBSS_SQLLike Class
Inheritance Hierarchy See Also
Collapse All
C#
public class TBSS_SQLLike : TBSS_BinarySymbol;
Remarks

This is class BoldSqlSymbols.TBSS_SQLLike.

Inheritance Hierarchy
BoldSqlNodes.TBoldSqlSymbol
    BoldSqlSymbols.TBSS_Symbol
        BoldSqlSymbols.TBSS_BinarySymbol
            BoldSqlSymbols.TBSS_SQLLike
                BoldSqlSymbols.TBSS_SQLLikeCaseInsensitive
File

BoldSqlSymbols.cs

See Also
Inheritance Hierarchy


TBSS_SQLLike Properties

TBSS_SQLLike Properties
Public Properties
Collapse All

The properties of the TBSS_SQLLike class are listed here.

Public Properties
Name | Description
SqlName | This is SqlName, a member of class TBSS_SQLLike.


TBSS_SQLLike.SqlName Property

TBSS_SQLLike.SqlName Property
TBSS_SQLLike Class BoldSqlSymbols Namespace See Also
Collapse All
C#
public override string SqlName;
Remarks

This is SqlName, a member of class TBSS_SQLLike.

See Also
TBSS_SQLLike Class
BoldSqlSymbols Namespace


TBSS_SQLLikeCaseInsensitive Class

TBSS_SQLLikeCaseInsensitive Class
Inheritance Hierarchy See Also
Collapse All
C#
public class TBSS_SQLLikeCaseInsensitive : TBSS_SQLLike;
Remarks

This is class BoldSqlSymbols.TBSS_SQLLikeCaseInsensitive.

Inheritance Hierarchy
BoldSqlNodes.TBoldSqlSymbol
    BoldSqlSymbols.TBSS_Symbol
        BoldSqlSymbols.TBSS_BinarySymbol
            BoldSqlSymbols.TBSS_SQLLike
                BoldSqlSymbols.TBSS_SQLLikeCaseInsensitive
File

BoldSqlSymbols.cs

See Also
Inheritance Hierarchy


TBSS_SQLLikeCaseInsensitive Methods

TBSS_SQLLikeCaseInsensitive Methods
Public Methods
Collapse All

The methods of the TBSS_SQLLikeCaseInsensitive class are listed here.

Public Methods
Name | Description
BuildWCFOrQuery | TBSS_SQLLikeCaseInsensitive
BuildWCFOrQuery_MakeUpper | This is BuildWCFOrQuery_MakeUpper, a member of class TBSS_SQLLikeCaseInsensitive.


TBSS_SQLLikeCaseInsensitive.BuildWCFOrQuery Method

TBSS_SQLLikeCaseInsensitive.BuildWCFOrQuery Method
TBSS_SQLLikeCaseInsensitive Class BoldSqlSymbols Namespace See Also
Collapse All
C#
public override void BuildWCFOrQuery(
    TBoldSqlOperation OperationNode,
    TBoldSQLNameSpace __NameSpace
);
Remarks

TBSS_SQLLikeCaseInsensitive

See Also
TBSS_SQLLikeCaseInsensitive Class
BoldSqlSymbols Namespace


TBSS_SQLLikeCaseInsensitive.BuildWCFOrQuery_MakeUpper Method

TBSS_SQLLikeCaseInsensitive.BuildWCFOrQuery_MakeUpper Method
TBSS_SQLLikeCaseInsensitive Class BoldSqlSymbols Namespace See Also
Collapse All
C#
public TBoldSqlWCF BuildWCFOrQuery_MakeUpper(
    TBoldSqlNode Node,
    TBoldSQLNameSpace __NameSpace
);
Remarks

This is BuildWCFOrQuery_MakeUpper, a member of class TBSS_SQLLikeCaseInsensitive.

See Also
TBSS_SQLLikeCaseInsensitive Class
BoldSqlSymbols Namespace


TBSS_SqlLikeUsersBase Class

TBSS_SqlLikeUsersBase Class
Inheritance Hierarchy See Also
Collapse All
C#
public abstract class TBSS_SqlLikeUsersBase : TBSS_BinarySymbol;
Remarks

This is class BoldSqlSymbols.TBSS_SqlLikeUsersBase.

Inheritance Hierarchy
BoldSqlNodes.TBoldSqlSymbol
    BoldSqlSymbols.TBSS_Symbol
        BoldSqlSymbols.TBSS_BinarySymbol
            BoldSqlSymbols.TBSS_SqlLikeUsersBase
                BoldSqlSymbols.TBSS_Contains
                BoldSqlSymbols.TBSS_StartsWith
File

BoldSqlSymbols.cs

See Also
Inheritance Hierarchy


TBSS_SqlLikeUsersBase Methods

TBSS_SqlLikeUsersBase Methods
Protected Methods Public Methods
Collapse All

The methods of the TBSS_SqlLikeUsersBase class are listed here.

Protected Methods
Name | Description
AdjustLikeArgument | This is AdjustLikeArgument, a member of class TBSS_SqlLikeUsersBase.
ArmourString | This is ArmourString, a member of class TBSS_SqlLikeUsersBase.
Top
Public Methods
Name | Description
BuildWCFOrQuery | TBSS_BinarySymbol


TBSS_SqlLikeUsersBase.AdjustLikeArgument Method

TBSS_SqlLikeUsersBase.AdjustLikeArgument Method
TBSS_SqlLikeUsersBase Class BoldSqlSymbols Namespace See Also
Collapse All
C#
protected abstract TBoldSqlWCF AdjustLikeArgument(
    TBoldSqlWCF arg
);
Remarks

This is AdjustLikeArgument, a member of class TBSS_SqlLikeUsersBase.

See Also
TBSS_SqlLikeUsersBase Class
BoldSqlSymbols Namespace


TBSS_SqlLikeUsersBase.ArmourString Method

TBSS_SqlLikeUsersBase.ArmourString Method
TBSS_SqlLikeUsersBase Class BoldSqlSymbols Namespace See Also
Collapse All
C#
protected string ArmourString(
    string s
);
Remarks

This is ArmourString, a member of class TBSS_SqlLikeUsersBase.

See Also
TBSS_SqlLikeUsersBase Class
BoldSqlSymbols Namespace


TBSS_SqlLikeUsersBase.BuildWCFOrQuery Method

TBSS_SqlLikeUsersBase.BuildWCFOrQuery Method
TBSS_SqlLikeUsersBase Class BoldSqlSymbols Namespace See Also
Collapse All
C#
public override void BuildWCFOrQuery(
    TBoldSqlOperation OperationNode,
    TBoldSQLNameSpace __NameSpace
);
Remarks

TBSS_BinarySymbol

See Also
TBSS_SqlLikeUsersBase Class
BoldSqlSymbols Namespace


TBSS_SqlLikeUsersBase Properties

TBSS_SqlLikeUsersBase Properties
Public Properties
Collapse All

The properties of the TBSS_SqlLikeUsersBase class are listed here.

Public Properties
Name | Description
SqlName | This is SqlName, a member of class TBSS_SqlLikeUsersBase.


TBSS_SqlLikeUsersBase.SqlName Property

TBSS_SqlLikeUsersBase.SqlName Property
TBSS_SqlLikeUsersBase Class BoldSqlSymbols Namespace See Also
Collapse All
C#
public override string SqlName;
Remarks

This is SqlName, a member of class TBSS_SqlLikeUsersBase.

See Also
TBSS_SqlLikeUsersBase Class
BoldSqlSymbols Namespace


TBSS_StartsWith Class

TBSS_StartsWith Class
Inheritance Hierarchy See Also
Collapse All
C#
public class TBSS_StartsWith : TBSS_SqlLikeUsersBase;
Remarks

This is class BoldSqlSymbols.TBSS_StartsWith.

Inheritance Hierarchy
BoldSqlNodes.TBoldSqlSymbol
    BoldSqlSymbols.TBSS_Symbol
        BoldSqlSymbols.TBSS_BinarySymbol
            BoldSqlSymbols.TBSS_SqlLikeUsersBase
                BoldSqlSymbols.TBSS_StartsWith
File

BoldSqlSymbols.cs

See Also
Inheritance Hierarchy


TBSS_StartsWith Methods

TBSS_StartsWith Methods
Protected Methods
Collapse All

The methods of the TBSS_StartsWith class are listed here.

Protected Methods
Name | Description
AdjustLikeArgument | This is AdjustLikeArgument, a member of class TBSS_StartsWith.


TBSS_StartsWith.AdjustLikeArgument Method

TBSS_StartsWith.AdjustLikeArgument Method
TBSS_StartsWith Class BoldSqlSymbols Namespace See Also
Collapse All
C#
protected override TBoldSqlWCF AdjustLikeArgument(
    TBoldSqlWCF arg
);
Remarks

This is AdjustLikeArgument, a member of class TBSS_StartsWith.

See Also
TBSS_StartsWith Class
BoldSqlSymbols Namespace


TBSS_Subtract Class

TBSS_Subtract Class
Inheritance Hierarchy See Also
Collapse All
C#
public class TBSS_Subtract : TBSS_BinarySymbol;
Remarks

This is class BoldSqlSymbols.TBSS_Subtract.

Inheritance Hierarchy
BoldSqlNodes.TBoldSqlSymbol
    BoldSqlSymbols.TBSS_Symbol
        BoldSqlSymbols.TBSS_BinarySymbol
            BoldSqlSymbols.TBSS_Subtract
File

BoldSqlSymbols.cs

See Also
Inheritance Hierarchy


TBSS_Subtract Properties

TBSS_Subtract Properties
Public Properties
Collapse All

The properties of the TBSS_Subtract class are listed here.

Public Properties
Name | Description
Name | This is Name, a member of class TBSS_Subtract.


TBSS_Subtract.Name Property

TBSS_Subtract.Name Property
TBSS_Subtract Class BoldSqlSymbols Namespace See Also
Collapse All
C#
public override string Name;
Remarks

This is Name, a member of class TBSS_Subtract.

See Also
TBSS_Subtract Class
BoldSqlSymbols Namespace


TBSS_Sum Class

TBSS_Sum Class
Inheritance Hierarchy See Also
Collapse All
C#
public class TBSS_Sum : TBSS_GroupFunctions;
Remarks

This is class BoldSqlSymbols.TBSS_Sum.

Inheritance Hierarchy
BoldSqlNodes.TBoldSqlSymbol
    BoldSqlSymbols.TBSS_Symbol
        BoldSqlSymbols.TBSS_GroupFunctions
            BoldSqlSymbols.TBSS_Sum
File

BoldSqlSymbols.cs

See Also
Inheritance Hierarchy


TBSS_Symbol Class

TBSS_Symbol Class
Inheritance Hierarchy See Also
Collapse All
C#
public class TBSS_Symbol : TBoldSqlSymbol;
Remarks

TBSS_Symbol

Inheritance Hierarchy
BoldSqlNodes.TBoldSqlSymbol
    BoldSqlSymbols.TBSS_Symbol
        BoldSqlSymbols.TBSS_AllInstances
        BoldSqlSymbols.TBSS_BinarySymbol
        BoldSqlSymbols.TBSS_GroupFunctions
        BoldSqlSymbols.TBSS_includes
        BoldSqlSymbols.TBSS_isEmpty
        BoldSqlSymbols.TBSS_isNull
        BoldSqlSymbols.TBSS_Iteration
        BoldSqlSymbols.TBSS_ListOperations
        BoldSqlSymbols.TBSS_NotEmpty
        BoldSqlSymbols.TBSS_OclAsType
        BoldSqlSymbols.TBSS_PrefixBinarySymbol
        BoldSqlSymbols.TBSS_Size
        BoldSqlSymbols.TBSS_toLower
        BoldSqlSymbols.TBSS_ToUpper
        BoldSqlSymbols.TBSS_UnarySymbol
File

BoldSqlSymbols.cs

See Also
Inheritance Hierarchy


TBSS_Symbol Properties

TBSS_Symbol Properties
Public Properties
Collapse All

The properties of the TBSS_Symbol class are listed here.

Public Properties
Name | Description
Name | This is Name, a member of class TBSS_Symbol.


TBSS_Symbol.Name Property

TBSS_Symbol.Name Property
TBSS_Symbol Class BoldSqlSymbols Namespace See Also
Collapse All
C#
public override string Name;
Remarks

This is Name, a member of class TBSS_Symbol.

See Also
TBSS_Symbol Class
BoldSqlSymbols Namespace


TBSS_SymmetricDifference Class

TBSS_SymmetricDifference Class
Inheritance Hierarchy See Also
Collapse All
C#
public class TBSS_SymmetricDifference : TBSS_ListOperations;
Remarks

This is class BoldSqlSymbols.TBSS_SymmetricDifference.

Inheritance Hierarchy
BoldSqlNodes.TBoldSqlSymbol
    BoldSqlSymbols.TBSS_Symbol
        BoldSqlSymbols.TBSS_ListOperations
            BoldSqlSymbols.TBSS_SymmetricDifference
File

BoldSqlSymbols.cs

See Also
Inheritance Hierarchy


TBSS_SymmetricDifference Methods

TBSS_SymmetricDifference Methods
Public Methods
Collapse All

The methods of the TBSS_SymmetricDifference class are listed here.

Public Methods
Name | Description
BuildWCFOrQuery | This is BuildWCFOrQuery, a member of class TBSS_SymmetricDifference.


TBSS_SymmetricDifference.BuildWCFOrQuery Method

TBSS_SymmetricDifference.BuildWCFOrQuery Method
TBSS_SymmetricDifference Class BoldSqlSymbols Namespace See Also
Collapse All
C#
public override void BuildWCFOrQuery(
    TBoldSqlOperation OperationNode,
    TBoldSQLNameSpace __NameSpace
);
Remarks

This is BuildWCFOrQuery, a member of class TBSS_SymmetricDifference.

See Also
TBSS_SymmetricDifference Class
BoldSqlSymbols Namespace


TBSS_toLower Class

TBSS_toLower Class
Inheritance Hierarchy See Also
Collapse All
C#
public class TBSS_toLower : TBSS_Symbol;
Remarks

This is class BoldSqlSymbols.TBSS_toLower.

Inheritance Hierarchy
BoldSqlNodes.TBoldSqlSymbol
    BoldSqlSymbols.TBSS_Symbol
        BoldSqlSymbols.TBSS_toLower
File

BoldSqlSymbols.cs

See Also
Inheritance Hierarchy


TBSS_toLower Methods

TBSS_toLower Methods
Public Methods
Collapse All

The methods of the TBSS_toLower class are listed here.

Public Methods
Name | Description
BuildWCFOrQuery | This is BuildWCFOrQuery, a member of class TBSS_toLower.


TBSS_toLower.BuildWCFOrQuery Method

TBSS_toLower.BuildWCFOrQuery Method
TBSS_toLower Class BoldSqlSymbols Namespace See Also
Collapse All
C#
public override void BuildWCFOrQuery(
    TBoldSqlOperation OperationNode,
    TBoldSQLNameSpace __NameSpace
);
Remarks

This is BuildWCFOrQuery, a member of class TBSS_toLower.

See Also
TBSS_toLower Class
BoldSqlSymbols Namespace


TBSS_toLower Properties

TBSS_toLower Properties
Public Properties
Collapse All

The properties of the TBSS_toLower class are listed here.

Public Properties
Name | Description
SqlName | This is SqlName, a member of class TBSS_toLower.


TBSS_toLower.SqlName Property

TBSS_toLower.SqlName Property
TBSS_toLower Class BoldSqlSymbols Namespace See Also
Collapse All
C#
public override string SqlName;
Remarks

This is SqlName, a member of class TBSS_toLower.

See Also
TBSS_toLower Class
BoldSqlSymbols Namespace


TBSS_ToUpper Class

TBSS_ToUpper Class
Inheritance Hierarchy See Also
Collapse All
C#
public class TBSS_ToUpper : TBSS_Symbol;
Remarks

This is class BoldSqlSymbols.TBSS_ToUpper.

Inheritance Hierarchy
BoldSqlNodes.TBoldSqlSymbol
    BoldSqlSymbols.TBSS_Symbol
        BoldSqlSymbols.TBSS_ToUpper
File

BoldSqlSymbols.cs

See Also
Inheritance Hierarchy


TBSS_ToUpper Methods

TBSS_ToUpper Methods
Public Methods
Collapse All

The methods of the TBSS_ToUpper class are listed here.

Public Methods
Name | Description
BuildWCFOrQuery | This is BuildWCFOrQuery, a member of class TBSS_ToUpper.


TBSS_ToUpper.BuildWCFOrQuery Method

TBSS_ToUpper.BuildWCFOrQuery Method
TBSS_ToUpper Class BoldSqlSymbols Namespace See Also
Collapse All
C#
public override void BuildWCFOrQuery(
    TBoldSqlOperation OperationNode,
    TBoldSQLNameSpace __NameSpace
);
Remarks

This is BuildWCFOrQuery, a member of class TBSS_ToUpper.

See Also
TBSS_ToUpper Class
BoldSqlSymbols Namespace


TBSS_UnaryMinus Class

TBSS_UnaryMinus Class
Inheritance Hierarchy See Also
Collapse All
C#
public class TBSS_UnaryMinus : TBSS_UnarySymbol;
Remarks

This is class BoldSqlSymbols.TBSS_UnaryMinus.

Inheritance Hierarchy
BoldSqlNodes.TBoldSqlSymbol
    BoldSqlSymbols.TBSS_Symbol
        BoldSqlSymbols.TBSS_UnarySymbol
            BoldSqlSymbols.TBSS_UnaryMinus
File

BoldSqlSymbols.cs

See Also
Inheritance Hierarchy


TBSS_UnaryMinus Properties

TBSS_UnaryMinus Properties
Public Properties
Collapse All

The properties of the TBSS_UnaryMinus class are listed here.

Public Properties
Name | Description
Name | This is Name, a member of class TBSS_UnaryMinus.
SqlName | This is SqlName, a member of class TBSS_UnaryMinus.


TBSS_UnaryMinus.Name Property

TBSS_UnaryMinus.Name Property
TBSS_UnaryMinus Class BoldSqlSymbols Namespace See Also
Collapse All
C#
public override string Name;
Remarks

This is Name, a member of class TBSS_UnaryMinus.

See Also
TBSS_UnaryMinus Class
BoldSqlSymbols Namespace


TBSS_UnaryMinus.SqlName Property

TBSS_UnaryMinus.SqlName Property
TBSS_UnaryMinus Class BoldSqlSymbols Namespace See Also
Collapse All
C#
public override string SqlName;
Remarks

This is SqlName, a member of class TBSS_UnaryMinus.

See Also
TBSS_UnaryMinus Class
BoldSqlSymbols Namespace


TBSS_UnarySymbol Class

TBSS_UnarySymbol Class
Inheritance Hierarchy See Also
Collapse All
C#
public class TBSS_UnarySymbol : TBSS_Symbol;
Remarks

This is class BoldSqlSymbols.TBSS_UnarySymbol.

Inheritance Hierarchy
BoldSqlNodes.TBoldSqlSymbol
    BoldSqlSymbols.TBSS_Symbol
        BoldSqlSymbols.TBSS_UnarySymbol
            BoldSqlSymbols.TBSS_Abs
            BoldSqlSymbols.TBSS_Floor
            BoldSqlSymbols.TBSS_Length
            BoldSqlSymbols.TBSS_not
            BoldSqlSymbols.TBSS_Round
            BoldSqlSymbols.TBSS_UnaryMinus
File

BoldSqlSymbols.cs

See Also
Inheritance Hierarchy


TBSS_UnarySymbol Methods

TBSS_UnarySymbol Methods
Public Methods
Collapse All

The methods of the TBSS_UnarySymbol class are listed here.

Public Methods
Name | Description
BuildWCFOrQuery | This is BuildWCFOrQuery, a member of class TBSS_UnarySymbol.


TBSS_UnarySymbol.BuildWCFOrQuery Method

TBSS_UnarySymbol.BuildWCFOrQuery Method
TBSS_UnarySymbol Class BoldSqlSymbols Namespace See Also
Collapse All
C#
public override void BuildWCFOrQuery(
    TBoldSqlOperation OperationNode,
    TBoldSQLNameSpace __NameSpace
);
Remarks

This is BuildWCFOrQuery, a member of class TBSS_UnarySymbol.

See Also
TBSS_UnarySymbol Class
BoldSqlSymbols Namespace


TBSS_union Class

TBSS_union Class
Inheritance Hierarchy See Also
Collapse All
C#
public class TBSS_union : TBSS_ListOperations;
Remarks

This is class BoldSqlSymbols.TBSS_union.

Inheritance Hierarchy
BoldSqlNodes.TBoldSqlSymbol
    BoldSqlSymbols.TBSS_Symbol
        BoldSqlSymbols.TBSS_ListOperations
            BoldSqlSymbols.TBSS_union
File

BoldSqlSymbols.cs

See Also
Inheritance Hierarchy


TBSS_union Methods

TBSS_union Methods
Public Methods
Collapse All

The methods of the TBSS_union class are listed here.

Public Methods
Name | Description
BuildWCFOrQuery | This is BuildWCFOrQuery, a member of class TBSS_union.


TBSS_union.BuildWCFOrQuery Method

TBSS_union.BuildWCFOrQuery Method
TBSS_union Class BoldSqlSymbols Namespace See Also
Collapse All
C#
public override void BuildWCFOrQuery(
    TBoldSqlOperation OperationNode,
    TBoldSQLNameSpace __NameSpace
);
Remarks

This is BuildWCFOrQuery, a member of class TBSS_union.

See Also
TBSS_union Class
BoldSqlSymbols Namespace


TBSS_xor Class

TBSS_xor Class
Inheritance Hierarchy See Also
Collapse All
C#
public class TBSS_xor : TBSS_BinarySymbol;
Remarks

This is class BoldSqlSymbols.TBSS_xor.

Inheritance Hierarchy
BoldSqlNodes.TBoldSqlSymbol
    BoldSqlSymbols.TBSS_Symbol
        BoldSqlSymbols.TBSS_BinarySymbol
            BoldSqlSymbols.TBSS_xor
File

BoldSqlSymbols.cs

See Also
Inheritance Hierarchy


Eco.AutoContainers Namespace

Eco.AutoContainers Namespace
Classes Enumerations Interfaces
Collapse All

This is namespace Eco.AutoContainers.

Classes
Name | Description
AutoContainerArgs | Parameter class sent into the autocontainer and AutoContainerFactory. This way the signature can change without requiring changing all consumers.
AutoContainerFactory | "Last resort" IAutoContainerFactory implementation. Very generic. Handles all classes.
AutoContainerProvider | This class is replaced by Eco.AutoContainers.AutoContainerService. Consider this class obsolete.
AutoContainerService | Implementation of IAutoContainerService. The actual service returned in property Instance.
DefaultAutoForm | This class makes up the form that is used by the ECO autocontainer mechanisms to display classes. The various parts (builders) can be reused individually, or this class can be subclassed and plugged into the autocontainer mechanisms.
DefaultListContainerFactory | Default autocontainerdactory to handle lists
LayoutInfo | Class used to keep info about control sizes, margins etc used when contructing the UI of the DefaultAutoForm.
Top
Enumerations
Name | Description
AutoContainerMemberVisibility | Enumeration determining which visibility scopes shall be shown in the autoform.
ContainerReusage | Enumeration determining which visibility scopes shall be shown in the autoform.
Top
Interfaces
Name | Description
IAutoContainer | Interface to implement to be an autocontainer. An autocontainerFactory should create instances of the implementor.
IAutoContainerFactory | The interface to implement to participate in handing out AutoContainers. An instance of the implementing class must be regsistered on AutoContainerFactory.AddFactory().
IAutoContainerService | The service interface for AutoContainerService.


AutoContainerArgs Class

AutoContainerArgs Class
Inheritance Hierarchy See Also
Collapse All

Parameter class sent into the autocontainer and AutoContainerFactory. This way the signature can change without requiring changing all consumers.

C#
public class AutoContainerArgs;
Inheritance Hierarchy
Eco.AutoContainers.AutoContainerArgs
File

AutoContainers.cs

See Also
Inheritance Hierarchy


AutoContainerArgs Constructor

AutoContainerArgs Constructor

This is the overview for the AutoContainerArgs constructor overload.

Overload List
Name | Description
AutoContainerArgs.AutoContainerArgs (EcoSpace) | Simpler constructor.
AutoContainerArgs.AutoContainerArgs (EcoSpace, bool, AutoContainerMemberVisibility, ContainerReusage) | Constructor. ShowModal defaults to false.
AutoContainerArgs.AutoContainerArgs (EcoSpace, bool, AutoContainerMemberVisibility, ContainerReusage, bool) | Constructor


AutoContainerArgs.AutoContainerArgs Constructor (EcoSpace)

AutoContainerArgs.AutoContainerArgs Constructor (EcoSpace)
AutoContainerArgs Class Eco.AutoContainers Namespace See Also
Collapse All

Simpler constructor.

C#
public AutoContainerArgs(
    EcoSpace ecoSpace
);
Parameters
Parameters | Description
ecoSpace | The EcoSpace the form lives in
Remarks

ForceReadOnly will be set to false, MemberVisibility will be set to AutoContainerMemberVisibility.AllMembers, ContainerReusage will be set to ContainerReusage.NeverReuse. ShowModal will be set to false.

See Also
AutoContainerArgs Class
Eco.AutoContainers Namespace


AutoContainerArgs.AutoContainerArgs Constructor (EcoSpace, bool, AutoContainerMemberVisibility, ContainerReusage)

AutoContainerArgs.AutoContainerArgs Constructor (EcoSpace, bool, AutoContainerMemberVisibility, ContainerReusage)
AutoContainerArgs Class Eco.AutoContainers Namespace See Also
Collapse All

Constructor. ShowModal defaults to false.

C#
public AutoContainerArgs(
    EcoSpace ecoSpace,
    bool forceReadOnly,
    AutoContainerMemberVisibility memberVisibility,
    ContainerReusage containerReusage
);
Parameters
Parameters | Description
ecoSpace | The EcoSpace the form lives in
forceReadOnly | indicates if the new form should be readOnly.
memberVisibility | indicates what level visibility of members should appear on the form.
containerReusage | indicates how forms shall be reused.
See Also
AutoContainerArgs Class
Eco.AutoContainers Namespace


AutoContainerArgs.AutoContainerArgs Constructor (EcoSpace, bool, AutoContainerMemberVisibility, ContainerReusage, bool)

AutoContainerArgs.AutoContainerArgs Constructor (EcoSpace, bool, AutoContainerMemberVisibility, ContainerReusage, bool)
AutoContainerArgs Class Eco.AutoContainers Namespace See Also
Collapse All

Constructor

C#
public AutoContainerArgs(
    EcoSpace ecoSpace,
    bool forceReadOnly,
    AutoContainerMemberVisibility memberVisibility,
    ContainerReusage containerReusage,
    bool showModal
);
Parameters
Parameters | Description
ecoSpace | The EcoSpace the form lives in
forceReadOnly | indicates if the new form should be readOnly.
memberVisibility | indicates what level visibility of members should appear on the form.
containerReusage | indicates how forms shall be reused.
showModal | indicates if the form is intended to show modally.
See Also
AutoContainerArgs Class
Eco.AutoContainers Namespace


AutoContainerArgs Properties

AutoContainerArgs Properties
Public Properties
Collapse All

The properties of the AutoContainerArgs class are listed here.

Public Properties
Name | Description
ContainerReusage | Indicates how forms shall be reused.
EcoSpace | The EcoSpace the form lives in.
ForceReadOnly | Indicates if the new form should be readOnly.
MemberVisibility | Indicates what level visibility of members should appear on the form.
ShowModal | Indicates if the form is intended to show modally.


AutoContainerArgs.ContainerReusage Property

AutoContainerArgs.ContainerReusage Property
AutoContainerArgs Class Eco.AutoContainers Namespace See Also
Collapse All

Indicates how forms shall be reused.

C#
public ContainerReusage ContainerReusage;
See Also
AutoContainerArgs Class
Eco.AutoContainers Namespace


AutoContainerArgs.EcoSpace Property

AutoContainerArgs.EcoSpace Property
AutoContainerArgs Class Eco.AutoContainers Namespace See Also
Collapse All

The EcoSpace the form lives in.

C#
public EcoSpace EcoSpace;
See Also
AutoContainerArgs Class
Eco.AutoContainers Namespace


AutoContainerArgs.ForceReadOnly Property

AutoContainerArgs.ForceReadOnly Property
AutoContainerArgs Class Eco.AutoContainers Namespace See Also
Collapse All

Indicates if the new form should be readOnly.

C#
public bool ForceReadOnly;
See Also
AutoContainerArgs Class
Eco.AutoContainers Namespace


AutoContainerArgs.MemberVisibility Property

AutoContainerArgs.MemberVisibility Property
AutoContainerArgs Class Eco.AutoContainers Namespace See Also
Collapse All

Indicates what level visibility of members should appear on the form.

C#
public AutoContainerMemberVisibility MemberVisibility;
See Also
AutoContainerArgs Class
Eco.AutoContainers Namespace


AutoContainerArgs.ShowModal Property

AutoContainerArgs.ShowModal Property
AutoContainerArgs Class Eco.AutoContainers Namespace See Also
Collapse All

Indicates if the form is intended to show modally.

C#
public bool ShowModal;
See Also
AutoContainerArgs Class
Eco.AutoContainers Namespace


AutoContainerFactory Class

AutoContainerFactory Class
Inheritance Hierarchy See Also
Collapse All

"Last resort" IAutoContainerFactory implementation. Very generic. Handles all classes.

C#
public class AutoContainerFactory : IAutoContainerFactory;
Inheritance Hierarchy
Eco.AutoContainers.IAutoContainerFactory
    Eco.AutoContainers.AutoContainerFactory
File

Eco.AutoContainers.DefaultAutoForm.cs

See Also
Inheritance Hierarchy


AutoContainerFactory Methods

AutoContainerFactory Methods
Public Methods
Collapse All

The methods of the AutoContainerFactory class are listed here.

Public Methods
Name | Description
Matches | Returns true if modelElement is a IClassifier.


AutoContainerFactory.Matches Method

AutoContainerFactory.Matches Method
AutoContainerFactory Class Eco.AutoContainers Namespace See Also
Collapse All

Returns true if modelElement is a IClassifier.

C#
public bool Matches(
    IModelElement modelElement
);
Remarks

IAutoContainerFactory

See Also
AutoContainerFactory Class
Eco.AutoContainers Namespace


AutoContainerFactory Properties

AutoContainerFactory Properties
Public Properties
Collapse All

The properties of the AutoContainerFactory class are listed here.

Public Properties
Name | Description
AutoContainer | Returns a DefaultAutoForm
Instance | This is Instance, a member of class AutoContainerFactory.


AutoContainerFactory.AutoContainer Property

AutoContainerFactory.AutoContainer Property
AutoContainerFactory Class Eco.AutoContainers Namespace See Also
Collapse All

Returns a DefaultAutoForm

C#
public IAutoContainer AutoContainer;
Remarks

IAutoContainerFactory

See Also
AutoContainerFactory Class
Eco.AutoContainers Namespace


AutoContainerFactory.Instance Property

AutoContainerFactory.Instance Property
AutoContainerFactory Class Eco.AutoContainers Namespace See Also
Collapse All
C#
public static AutoContainerFactory Instance;
Remarks

This is Instance, a member of class AutoContainerFactory.

See Also
AutoContainerFactory Class
Eco.AutoContainers Namespace


AutoContainerProvider Class

AutoContainerProvider Class
Inheritance Hierarchy See Also
Collapse All

This class is replaced by Eco.AutoContainers.AutoContainerService. Consider this class obsolete.

C#
public class AutoContainerProvider;
Inheritance Hierarchy
Eco.AutoContainers.AutoContainerProvider
File

AutoContainerProvider.cs

See Also
Inheritance Hierarchy


AutoContainerProvider.AutoContainerProvider Constructor

AutoContainerProvider.AutoContainerProvider Constructor
AutoContainerProvider Class Eco.AutoContainers Namespace See Also
Collapse All
C#
public AutoContainerProvider(
    Control host,
    EcoSpace ecoSpace
);
Exceptions
Exceptions | Description
ArgumentNullException | Thrown if host is null.
See Also
AutoContainerProvider Class
Eco.AutoContainers Namespace


AutoContainerProvider Methods

AutoContainerProvider Methods
Protected Methods
Collapse All

The methods of the AutoContainerProvider class are listed here.

Protected Methods
Name | Description
IsHookable |


AutoContainerProvider.IsHookable Method

AutoContainerProvider.IsHookable Method
AutoContainerProvider Class Eco.AutoContainers Namespace See Also
Collapse All
C#
protected virtual bool IsHookable(
    Control control
);
Exceptions
Exceptions | Description
ArgumentNullException | Thrown if control is null.
See Also
AutoContainerProvider Class
Eco.AutoContainers Namespace


AutoContainerProvider Properties

AutoContainerProvider Properties
Public Properties
Collapse All

The properties of the AutoContainerProvider class are listed here.

Public Properties
Name | Description
EcoSpace | This is EcoSpace, a member of class AutoContainerProvider.
Host | This is Host, a member of class AutoContainerProvider.


AutoContainerProvider.EcoSpace Property

AutoContainerProvider.EcoSpace Property
AutoContainerProvider Class Eco.AutoContainers Namespace See Also
Collapse All
C#
public EcoSpace EcoSpace;
Remarks

This is EcoSpace, a member of class AutoContainerProvider.

See Also
AutoContainerProvider Class
Eco.AutoContainers Namespace


AutoContainerProvider.Host Property

AutoContainerProvider.Host Property
AutoContainerProvider Class Eco.AutoContainers Namespace See Also
Collapse All
C#
public Control Host;
Remarks

This is Host, a member of class AutoContainerProvider.

See Also
AutoContainerProvider Class
Eco.AutoContainers Namespace


AutoContainerService Class

AutoContainerService Class
Inheritance Hierarchy See Also
Collapse All

Implementation of IAutoContainerService. The actual service returned in property Instance.

C#
public class AutoContainerService : IAutoContainerService;
Remarks

This should probably be hidden away as a singleton retrieved by some getService.

Inheritance Hierarchy
Eco.AutoContainers.IAutoContainerService
    Eco.AutoContainers.AutoContainerService
File

AutoContainers.cs

See Also
Inheritance Hierarchy


AutoContainerService.AutoContainerService Constructor

AutoContainerService.AutoContainerService Constructor
AutoContainerService Class Eco.AutoContainers Namespace See Also
Collapse All
C#
public AutoContainerService();
Remarks

This is AutoContainerService, a member of class AutoContainerService.

See Also
AutoContainerService Class
Eco.AutoContainers Namespace


AutoContainerService Methods

AutoContainerService Methods
Public Methods
Collapse All

The methods of the AutoContainerService class are listed here.

Public Methods
Name | Description
AddFactory | Registers an instance of IAutoContainerFactory to participate in providing autocontainers.
CreateContainer | This is the overview for the CreateContainer method overload.
RegisterContainerForElement | Registers an existing container for an element so that subsequent calls to RetrieveContainer will get this container, and not create a new.
RegisteredFactories | Hands back the list of the registered IAutoContainerFactory.
RemoveAllContainers | Closes all currently showing autoforms, regardless of who brought them info existence.
RemoveFactory | Unregisters an instance of IAutoContainerFactory so it no longer participates in providing autocontainers.
RetrieveContainer | Checks if there is a an IAutoContainer that can be reused and returns it. If not calls CreateContainer(IElement, AutoContainerArgs) to return a new container.
UnregisterContainer | Removes a container from the registry.


AutoContainerService.AddFactory Method

AutoContainerService.AddFactory Method
AutoContainerService Class Eco.AutoContainers Namespace See Also
Collapse All

Registers an instance of IAutoContainerFactory to participate in providing autocontainers.

C#
public void AddFactory(
    IAutoContainerFactory autoContainerFactory
);
Parameters
Parameters | Description
autoContainerFactory | The instance to register.
Remarks

IAutoContainerService

Exceptions
Exceptions | Description
ArgumentNullException | Thrown if autoContainerFactory is null.
See Also
AutoContainerService Class
Eco.AutoContainers Namespace


CreateContainer Method

CreateContainer Method

This is the overview for the CreateContainer method overload.

Overload List
Name | Description
AutoContainerService.CreateContainer (EcoSpace, IElement) | Backwards compatibility
AutoContainerService.CreateContainer (IElement, AutoContainerArgs) | IAutoFormService


AutoContainerService.CreateContainer Method (EcoSpace, IElement)

AutoContainerService.CreateContainer Method (EcoSpace, IElement)
AutoContainerService Class Eco.AutoContainers Namespace See Also
Collapse All
C#
public IAutoContainer CreateContainer(
    EcoSpace ecoSpace,
    IElement element
);
Remarks

Backwards compatibility

See Also
AutoContainerService Class
Eco.AutoContainers Namespace


AutoContainerService.CreateContainer Method (IElement, AutoContainerArgs)

AutoContainerService.CreateContainer Method (IElement, AutoContainerArgs)
AutoContainerService Class Eco.AutoContainers Namespace See Also
Collapse All
C#
public IAutoContainer CreateContainer(
    IElement element,
    AutoContainerArgs autoContainerArgs
);
Remarks

IAutoFormService

Exceptions
Exceptions | Description
ArgumentNullException | Thrown if element is null. Thrown if autoContainerArgs is null.
See Also
AutoContainerService Class
Eco.AutoContainers Namespace


AutoContainerService.RegisterContainerForElement Method

AutoContainerService.RegisterContainerForElement Method
AutoContainerService Class Eco.AutoContainers Namespace See Also
Collapse All

Registers an existing container for an element so that subsequent calls to RetrieveContainer will get this container, and not create a new.

C#
public void RegisterContainerForElement(
    IAutoContainer container,
    IElement element
);
Parameters
Parameters | Description
container | Instance of IAutoContainer to match with element.
element | Instance of IElement to match with container.
See Also
AutoContainerService Class
Eco.AutoContainers Namespace


AutoContainerService.RegisteredFactories Method

AutoContainerService.RegisteredFactories Method
AutoContainerService Class Eco.AutoContainers Namespace See Also
Collapse All

Hands back the list of the registered IAutoContainerFactory.

C#
public ArrayList RegisteredFactories();
Returns

Returns a clone of the list of the registered instances of IAutoContainerFactory.

Remarks

IAutoContainerService

See Also
AutoContainerService Class
Eco.AutoContainers Namespace


AutoContainerService.RemoveAllContainers Method

AutoContainerService.RemoveAllContainers Method
AutoContainerService Class Eco.AutoContainers Namespace See Also
Collapse All

Closes all currently showing autoforms, regardless of who brought them info existence.

C#
public void RemoveAllContainers();
See Also
AutoContainerService Class
Eco.AutoContainers Namespace


AutoContainerService.RemoveFactory Method

AutoContainerService.RemoveFactory Method
AutoContainerService Class Eco.AutoContainers Namespace See Also
Collapse All

Unregisters an instance of IAutoContainerFactory so it no longer participates in providing autocontainers.

C#
public bool RemoveFactory(
    IAutoContainerFactory autoContainerFactory
);
Parameters
Parameters | Description
autoContainerFactory | The instance to unregister.
Returns

Returns true if a factory of the correct type was registered (and thus unregistered).

Remarks

IAutoContainerService

The first registered factory of the same type as autoContainerFactory will be unregistered.

Exceptions
Exceptions | Description
ArgumentNullException | Thrown if autoContainerFactory is null.
See Also
AutoContainerService Class
Eco.AutoContainers Namespace


AutoContainerService.RetrieveContainer Method

AutoContainerService.RetrieveContainer Method
AutoContainerService Class Eco.AutoContainers Namespace See Also
Collapse All

Checks if there is a an IAutoContainer that can be reused and returns it. If not calls CreateContainer(IElement, AutoContainerArgs) to return a new container.

C#
public IAutoContainer RetrieveContainer(
    IElement element,
    AutoContainerArgs autoContainerArgs
);
Parameters
Parameters | Description
element | Instance of IElement to return a IAutoContainer for.
autoContainerArgs | Used to determine if a new container should be created. If so the object is passed to CreateContainer(IElement, AutoContainerArgs).
Returns

Returns an instance of IAutoContainer for the element.

Exceptions
Exceptions | Description
ArgumentNullException | Thrown if autoContainerArgs is null. Thrown if element is null.
See Also
AutoContainerService Class
Eco.AutoContainers Namespace


AutoContainerService.UnregisterContainer Method

AutoContainerService.UnregisterContainer Method
AutoContainerService Class Eco.AutoContainers Namespace See Also
Collapse All

Removes a container from the registry.

C#
public void UnregisterContainer(
    IAutoContainer container
);
Remarks

Call this method if you intend to dispose a container that has been registered with RegisterContainerForElement.

See Also
AutoContainerService Class
Eco.AutoContainers Namespace


AutoContainerService Properties

AutoContainerService Properties
Public Properties
Collapse All

The properties of the AutoContainerService class are listed here.

Public Properties
Name | Description
Instance | Returns a singleton instance of AutoContainerService


AutoContainerService.Instance Property

AutoContainerService.Instance Property
AutoContainerService Class Eco.AutoContainers Namespace See Also
Collapse All

Returns a singleton instance of AutoContainerService

C#
public static IAutoContainerService Instance;
See Also
AutoContainerService Class
Eco.AutoContainers Namespace


DefaultAutoForm Class

DefaultAutoForm Class
Inheritance Hierarchy See Also
Collapse All

This class makes up the form that is used by the ECO autocontainer mechanisms to display classes. The various parts (builders) can be reused individually, or this class can be subclassed and plugged into the autocontainer mechanisms.

C#
public class DefaultAutoForm : System.Windows.Forms.Form, IAutoContainer;
Inheritance Hierarchy
Eco.AutoContainers.IAutoContainer
System.Windows.Forms.Form
    Eco.AutoContainers.DefaultAutoForm
File

Eco.AutoContainers.DefaultAutoForm.cs

See Also
Inheritance Hierarchy


DefaultAutoForm.DefaultAutoForm Constructor

DefaultAutoForm.DefaultAutoForm Constructor
DefaultAutoForm Class Eco.AutoContainers Namespace See Also
Collapse All
C#
public DefaultAutoForm();
Remarks

This is DefaultAutoForm, a member of class DefaultAutoForm.

See Also
DefaultAutoForm Class
Eco.AutoContainers Namespace


DefaultAutoForm Methods

DefaultAutoForm Methods
Protected Methods Public Methods
Collapse All

The methods of the DefaultAutoForm class are listed here.

Protected Methods
Name | Description
BuildConstraintsPage | Override this method to make adjustments to the constraints page.
BuildMembersPage | Override this method to make adjustments to the "main" page.
BuildMethodsPage | Override this method to make adjustments to the methods page.
BuildMultiLinksPages | Override this method to make adjustments to the multilinks pages.
BuildStatePage | Override this method to make adjustments to the state page.
Dispose | Clean up any resources being used.
Top
Public Methods
Name | Description
BuildControls |
HookUpGUI | HookUpGUI is called after BuildControls. It hooks in the object to the handle in the container.
Show |


DefaultAutoForm.BuildConstraintsPage Method

DefaultAutoForm.BuildConstraintsPage Method
DefaultAutoForm Class Eco.AutoContainers Namespace See Also
Collapse All

Override this method to make adjustments to the constraints page.

C#
protected virtual void BuildConstraintsPage(
    IElement element,
    AutoContainerArgs autoContainerArgs
);
Exceptions
Exceptions | Description
ArgumentNullException | Thrown if element is null.
See Also
DefaultAutoForm Class
Eco.AutoContainers Namespace


DefaultAutoForm.BuildControls Method

DefaultAutoForm.BuildControls Method
DefaultAutoForm Class Eco.AutoContainers Namespace See Also
Collapse All
C#
public void BuildControls(
    IElement element,
    AutoContainerArgs autoContainerArgs
);
Exceptions
Exceptions | Description
ArgumentNullException | Thrown if element is null. Thrown if autoContainerArgs is null.
See Also
DefaultAutoForm Class
Eco.AutoContainers Namespace


DefaultAutoForm.BuildMembersPage Method

DefaultAutoForm.BuildMembersPage Method
DefaultAutoForm Class Eco.AutoContainers Namespace See Also
Collapse All

Override this method to make adjustments to the "main" page.

C#
protected virtual Size BuildMembersPage(
    IClass umlClass,
    AutoContainerArgs autoContainerArgs
);
See Also
DefaultAutoForm Class
Eco.AutoContainers Namespace


DefaultAutoForm.BuildMethodsPage Method

DefaultAutoForm.BuildMethodsPage Method
DefaultAutoForm Class Eco.AutoContainers Namespace See Also
Collapse All

Override this method to make adjustments to the methods page.

C#
protected virtual void BuildMethodsPage(
    IClass umlClass,
    AutoContainerArgs autoContainerArgs
);
Exceptions
Exceptions | Description
ArgumentNullException | Thrown if umlClass is null.
See Also
DefaultAutoForm Class
Eco.AutoContainers Namespace


DefaultAutoForm.BuildMultiLinksPages Method

DefaultAutoForm.BuildMultiLinksPages Method
DefaultAutoForm Class Eco.AutoContainers Namespace See Also
Collapse All

Override this method to make adjustments to the multilinks pages.

C#
protected virtual void BuildMultiLinksPages(
    IClass umlClass,
    AutoContainerArgs autoContainerArgs
);
Exceptions
Exceptions | Description
ArgumentNullException | Thrown if umlClass is null. Thrown if autoContainerArgs is null.
See Also
DefaultAutoForm Class
Eco.AutoContainers Namespace


DefaultAutoForm.BuildStatePage Method

DefaultAutoForm.BuildStatePage Method
DefaultAutoForm Class Eco.AutoContainers Namespace See Also
Collapse All

Override this method to make adjustments to the state page.

C#
protected virtual TriggerControlsRefresher BuildStatePage(
    IClass umlClass,
    AutoContainerArgs autoContainerArgs
);
Exceptions
Exceptions | Description
ArgumentNullException | Thrown if umlClass is null.
See Also
DefaultAutoForm Class
Eco.AutoContainers Namespace


DefaultAutoForm.Dispose Method

DefaultAutoForm.Dispose Method
DefaultAutoForm Class Eco.AutoContainers Namespace See Also
Collapse All

Clean up any resources being used.

C#
protected override void Dispose(
    bool disposing
);
See Also
DefaultAutoForm Class
Eco.AutoContainers Namespace


DefaultAutoForm.HookUpGUI Method

DefaultAutoForm.HookUpGUI Method
DefaultAutoForm Class Eco.AutoContainers Namespace See Also
Collapse All

HookUpGUI is called after BuildControls. It hooks in the object to the handle in the container.

C#
public void HookUpGUI(
    EcoSpace ecoSpace,
    IElement element
);
Remarks

This method must be callable several times on the same container instance, as the instance may be reused.

See Also
DefaultAutoForm Class
Eco.AutoContainers Namespace


DefaultAutoForm.Show Method

DefaultAutoForm.Show Method
DefaultAutoForm Class Eco.AutoContainers Namespace See Also
Collapse All
C#
public void Show(
    AutoContainerArgs autoContainerArgs
);
Exceptions
Exceptions | Description
ArgumentNullException | Thrown if autoContainerArgs is null.
See Also
DefaultAutoForm Class
Eco.AutoContainers Namespace


DefaultAutoForm Properties

DefaultAutoForm Properties
Public Properties
Collapse All

The properties of the DefaultAutoForm class are listed here.

Public Properties
Name | Description
BuildConstraints | If false, Constraints tab are not shown. The actual checking of the class property is in the virtual method BuildConstraintsPage.
BuildMethods | If false, Methods tabs are not shown. The actual checking of the class property is in the virtual method BuildMethodsPage.
BuildMultiLinks | If false, Multilinks tabs are not shown. The actual checking of the class property is in the virtual method BuildMultiLinksPages.
BuildStates | If false, States tabs are not shown. The actual checking of the class property is in the virtual method BuildStatePage.
EcoSpace | In order to hook up the form to a type system, the form's referenceHandle must get its EcoSpace property set. This property is a passthrough to the referencehandle's EcoSpace.


DefaultAutoForm.BuildConstraints Property

DefaultAutoForm.BuildConstraints Property
DefaultAutoForm Class Eco.AutoContainers Namespace See Also
Collapse All

If false, Constraints tab are not shown. The actual checking of the class property is in the virtual method BuildConstraintsPage.

C#
public static bool BuildConstraints;
See Also
DefaultAutoForm Class
Eco.AutoContainers Namespace


DefaultAutoForm.BuildMethods Property

DefaultAutoForm.BuildMethods Property
DefaultAutoForm Class Eco.AutoContainers Namespace See Also
Collapse All

If false, Methods tabs are not shown. The actual checking of the class property is in the virtual method BuildMethodsPage.

C#
public static bool BuildMethods;
See Also
DefaultAutoForm Class
Eco.AutoContainers Namespace


DefaultAutoForm.BuildMultiLinks Property

DefaultAutoForm.BuildMultiLinks Property
DefaultAutoForm Class Eco.AutoContainers Namespace See Also
Collapse All

If false, Multilinks tabs are not shown. The actual checking of the class property is in the virtual method BuildMultiLinksPages.

C#
public static bool BuildMultiLinks;
See Also
DefaultAutoForm Class
Eco.AutoContainers Namespace


DefaultAutoForm.BuildStates Property

DefaultAutoForm.BuildStates Property
DefaultAutoForm Class Eco.AutoContainers Namespace See Also
Collapse All

If false, States tabs are not shown. The actual checking of the class property is in the virtual method BuildStatePage.

C#
public static bool BuildStates;
See Also
DefaultAutoForm Class
Eco.AutoContainers Namespace


DefaultAutoForm.EcoSpace Property

DefaultAutoForm.EcoSpace Property
DefaultAutoForm Class Eco.AutoContainers Namespace See Also
Collapse All

In order to hook up the form to a type system, the form's referenceHandle must get its EcoSpace property set. This property is a passthrough to the referencehandle's EcoSpace.

C#
public EcoSpace EcoSpace;
See Also
DefaultAutoForm Class
Eco.AutoContainers Namespace


DefaultListContainerFactory Class

DefaultListContainerFactory Class
Inheritance Hierarchy See Also
Collapse All

Default autocontainerdactory to handle lists

C#
public class DefaultListContainerFactory : IAutoContainerFactory;
Inheritance Hierarchy
Eco.AutoContainers.IAutoContainerFactory
    Eco.AutoContainers.DefaultListContainerFactory
File

Eco.AutoContainers.DefaultAutoListForm.cs

See Also
Inheritance Hierarchy


DefaultListContainerFactory Methods

DefaultListContainerFactory Methods
Public Methods
Collapse All

The methods of the DefaultListContainerFactory class are listed here.

Public Methods
Name | Description
Matches | IAutoContainerFactory


DefaultListContainerFactory.Matches Method

DefaultListContainerFactory.Matches Method
DefaultListContainerFactory Class Eco.AutoContainers Namespace See Also
Collapse All
C#
public bool Matches(
    IModelElement modelElement
);
Remarks

IAutoContainerFactory

See Also
DefaultListContainerFactory Class
Eco.AutoContainers Namespace


DefaultListContainerFactory Properties

DefaultListContainerFactory Properties
Public Properties
Collapse All

The properties of the DefaultListContainerFactory class are listed here.

Public Properties
Name | Description
AutoContainer | IAutoContainerFactory
Instance | This is Instance, a member of class DefaultListContainerFactory.


DefaultListContainerFactory.AutoContainer Property

DefaultListContainerFactory.AutoContainer Property
DefaultListContainerFactory Class Eco.AutoContainers Namespace See Also
Collapse All
C#
public IAutoContainer AutoContainer;
Remarks

IAutoContainerFactory

See Also
DefaultListContainerFactory Class
Eco.AutoContainers Namespace


DefaultListContainerFactory.Instance Property

DefaultListContainerFactory.Instance Property
DefaultListContainerFactory Class Eco.AutoContainers Namespace See Also
Collapse All
C#
public static DefaultListContainerFactory Instance;
Remarks

This is Instance, a member of class DefaultListContainerFactory.

See Also
DefaultListContainerFactory Class
Eco.AutoContainers Namespace


LayoutInfo Class

LayoutInfo Class
Inheritance Hierarchy See Also
Collapse All

Class used to keep info about control sizes, margins etc used when contructing the UI of the DefaultAutoForm.

C#
public static class LayoutInfo;
Inheritance Hierarchy
Eco.AutoContainers.LayoutInfo
File

Eco.AutoContainers.DefaultAutoForm.cs

See Also
Inheritance Hierarchy


LayoutInfo Fields

LayoutInfo Fields
Public Fields
Collapse All

The fields of the LayoutInfo class are listed here.

Public Fields
Name | Description
BottomMargin | Constant used for vertical spacing, bottom.
HorizontalSpace | Constant used for vertical spacing.
LeftMargin | Constant used for horizontal spacing, left side.
Nudge | Constant used for small spacing.
PanelNestingSpace | Constant used for spacing.
RightMargin | Constant used for horizontal spacing, right side.
TopMargin | Constant used for vertical spacing, top.
VerticalSpace | Constant used for vertical spacing.


LayoutInfo.BottomMargin Field

LayoutInfo.BottomMargin Field
LayoutInfo Class Eco.AutoContainers Namespace See Also
Collapse All

Constant used for vertical spacing, bottom.

C#
public const int BottomMargin = TopMargin;
Remarks

Equal to TopMargin.

See Also
LayoutInfo Class
Eco.AutoContainers Namespace


LayoutInfo.HorizontalSpace Field

LayoutInfo.HorizontalSpace Field
LayoutInfo Class Eco.AutoContainers Namespace See Also
Collapse All

Constant used for vertical spacing.

C#
public const int HorizontalSpace = 4;
See Also
LayoutInfo Class
Eco.AutoContainers Namespace


LayoutInfo.LeftMargin Field

LayoutInfo.LeftMargin Field
LayoutInfo Class Eco.AutoContainers Namespace See Also
Collapse All

Constant used for horizontal spacing, left side.

C#
public const int LeftMargin = RightMargin;
Remarks

Equal to RightMargin.

See Also
LayoutInfo Class
Eco.AutoContainers Namespace


LayoutInfo.Nudge Field

LayoutInfo.Nudge Field
LayoutInfo Class Eco.AutoContainers Namespace See Also
Collapse All

Constant used for small spacing.

C#
public const int Nudge = VerticalSpace / 2;
Remarks

Equal to VerticalSpace/2.

See Also
LayoutInfo Class
Eco.AutoContainers Namespace


LayoutInfo.PanelNestingSpace Field

LayoutInfo.PanelNestingSpace Field
LayoutInfo Class Eco.AutoContainers Namespace See Also
Collapse All

Constant used for spacing.

C#
public const int PanelNestingSpace = 2 * VerticalSpace;
Remarks

Equal to VerticalSpace*2.

See Also
LayoutInfo Class
Eco.AutoContainers Namespace


LayoutInfo.RightMargin Field

LayoutInfo.RightMargin Field
LayoutInfo Class Eco.AutoContainers Namespace See Also
Collapse All

Constant used for horizontal spacing, right side.

C#
public const int RightMargin = 4;
Remarks

public const int HeightOffset = 4; public const int WidthOffset = 4;

See Also
LayoutInfo Class
Eco.AutoContainers Namespace


LayoutInfo.TopMargin Field

LayoutInfo.TopMargin Field
LayoutInfo Class Eco.AutoContainers Namespace See Also
Collapse All

Constant used for vertical spacing, top.

C#
public const int TopMargin = 4;
See Also
LayoutInfo Class
Eco.AutoContainers Namespace


LayoutInfo.VerticalSpace Field

LayoutInfo.VerticalSpace Field
LayoutInfo Class Eco.AutoContainers Namespace See Also
Collapse All

Constant used for vertical spacing.

C#
public const int VerticalSpace = 4;
See Also
LayoutInfo Class
Eco.AutoContainers Namespace


IAutoContainer Interface

IAutoContainer Interface
Inheritance Hierarchy See Also
Collapse All

Interface to implement to be an autocontainer. An autocontainerFactory should create instances of the implementor.

C#
public interface IAutoContainer;
Remarks

.

Inheritance Hierarchy
Eco.AutoContainers.IAutoContainer
    Eco.AutoContainers.DefaultAutoForm
File

AutoContainers.cs

See Also
Inheritance Hierarchy


IAutoContainer Methods

IAutoContainer Methods
Public Methods
Collapse All

The methods of the IAutoContainer class are listed here.

Public Methods
Name | Description
BuildControls | BuildControls (optionally) creates any widgets etc to sit in the container. It's like a constructor.
HookUpGUI | HookUpGUI is called after BuildControls. It hooks in the object to the handle in the container.
Show | Allows the autocontainer to show itself, using the information in the args - maybe to show modally, change colors or what not.


IAutoContainer.BuildControls Method

IAutoContainer.BuildControls Method
IAutoContainer Interface Eco.AutoContainers Namespace See Also
Collapse All

BuildControls (optionally) creates any widgets etc to sit in the container. It's like a constructor.

C#
void BuildControls(
    IElement element,
    AutoContainerArgs autoContainerArgs
);
See Also
IAutoContainer Interface
Eco.AutoContainers Namespace


IAutoContainer.HookUpGUI Method

IAutoContainer.HookUpGUI Method
IAutoContainer Interface Eco.AutoContainers Namespace See Also
Collapse All

HookUpGUI is called after BuildControls. It hooks in the object to the handle in the container.

C#
void HookUpGUI(
    EcoSpace ecoSpace,
    IElement element
);
Remarks

This method must be callable several times on the same container instance, as the instance may be reused.

See Also
IAutoContainer Interface
Eco.AutoContainers Namespace


IAutoContainer.Show Method

IAutoContainer.Show Method
IAutoContainer Interface Eco.AutoContainers Namespace See Also
Collapse All

Allows the autocontainer to show itself, using the information in the args - maybe to show modally, change colors or what not.

C#
void Show(
    AutoContainerArgs autoContainerArgs
);
See Also
IAutoContainer Interface
Eco.AutoContainers Namespace


IAutoContainer Properties

IAutoContainer Properties
Public Properties
Collapse All

The properties of the IAutoContainer class are listed here.

Public Properties
Name | Description
EcoSpace | Used to set up the EcoSpace of the AutoContainer.
IsDisposed | Return true if this this container should not be reused any more.


IAutoContainer.EcoSpace Property

IAutoContainer.EcoSpace Property
IAutoContainer Interface Eco.AutoContainers Namespace See Also
Collapse All

Used to set up the EcoSpace of the AutoContainer.

C#
EcoSpace EcoSpace;
See Also
IAutoContainer Interface
Eco.AutoContainers Namespace


IAutoContainer.IsDisposed Property

IAutoContainer.IsDisposed Property
IAutoContainer Interface Eco.AutoContainers Namespace See Also
Collapse All

Return true if this this container should not be reused any more.

C#
bool IsDisposed;
See Also
IAutoContainer Interface
Eco.AutoContainers Namespace


IAutoContainerFactory Interface

IAutoContainerFactory Interface
Inheritance Hierarchy See Also
Collapse All

The interface to implement to participate in handing out AutoContainers. An instance of the implementing class must be regsistered on AutoContainerFactory.AddFactory().

C#
public interface IAutoContainerFactory;
Inheritance Hierarchy
Eco.AutoContainers.IAutoContainerFactory
    Eco.AutoContainers.AutoContainerFactory
    Eco.AutoContainers.DefaultListContainerFactory
File

AutoContainers.cs

See Also
Inheritance Hierarchy


IAutoContainerFactory Methods

IAutoContainerFactory Methods
Public Methods
Collapse All

The methods of the IAutoContainerFactory class are listed here.

Public Methods
Name | Description
Matches | Each factory determines if it handles the modelElement


IAutoContainerFactory.Matches Method

IAutoContainerFactory.Matches Method
IAutoContainerFactory Interface Eco.AutoContainers Namespace See Also
Collapse All

Each factory determines if it handles the modelElement

C#
bool Matches(
    IModelElement modelElement
);
See Also
IAutoContainerFactory Interface
Eco.AutoContainers Namespace


IAutoContainerFactory Properties

IAutoContainerFactory Properties
Public Properties
Collapse All

The properties of the IAutoContainerFactory class are listed here.

Public Properties
Name | Description
AutoContainer | It would be possible for the factory to return an existing container


IAutoContainerFactory.AutoContainer Property

IAutoContainerFactory.AutoContainer Property
IAutoContainerFactory Interface Eco.AutoContainers Namespace See Also
Collapse All

It would be possible for the factory to return an existing container

C#
IAutoContainer AutoContainer;
See Also
IAutoContainerFactory Interface
Eco.AutoContainers Namespace


IAutoContainerService Interface

IAutoContainerService Interface
Inheritance Hierarchy See Also
Collapse All

The service interface for AutoContainerService.

C#
public interface IAutoContainerService;
Remarks

Should probably be defined in interfaces somewhere.

Inheritance Hierarchy
Eco.AutoContainers.IAutoContainerService
    Eco.AutoContainers.AutoContainerService
File

AutoContainers.cs

See Also
Inheritance Hierarchy


IAutoContainerService Methods

IAutoContainerService Methods
Public Methods
Collapse All

The methods of the IAutoContainerService class are listed here.

Public Methods
Name | Description
AddFactory | Plugs in yet another factory that can handle a set of elements.
CreateContainer | Finds a suitable factory for element and returns the container it creates.
RegisterContainerForElement | Registers an existing container for an element so that subsequent calls to RetrieveContainer will get this container, and not create a new.
RegisteredFactories | Returns a clone of the list of registered factories.
RemoveAllContainers | Closes all currently showing autoforms, regardless of who brought them info existence.
RemoveFactory | Removes a factory of the same type as the instance passed as parameter.
RetrieveContainer | Checks if there is a an AutoContainer that can be reused and returns it. If not calls CreateContainer to return a new container.
UnregisterContainer | Removes a container from the registry.


IAutoContainerService.AddFactory Method

IAutoContainerService.AddFactory Method
IAutoContainerService Interface Eco.AutoContainers Namespace See Also
Collapse All

Plugs in yet another factory that can handle a set of elements.

C#
void AddFactory(
    IAutoContainerFactory autoContainerFactory
);
Parameters
Parameters | Description
autoContainerFactory | Instance of factory that will be added
See Also
IAutoContainerService Interface
Eco.AutoContainers Namespace


IAutoContainerService.CreateContainer Method

IAutoContainerService.CreateContainer Method
IAutoContainerService Interface Eco.AutoContainers Namespace See Also
Collapse All

Finds a suitable factory for element and returns the container it creates.

C#
IAutoContainer CreateContainer(
    IElement element,
    AutoContainerArgs autoContainerArgs
);
See Also
IAutoContainerService Interface
Eco.AutoContainers Namespace


IAutoContainerService.RegisterContainerForElement Method

IAutoContainerService.RegisterContainerForElement Method
IAutoContainerService Interface Eco.AutoContainers Namespace See Also
Collapse All

Registers an existing container for an element so that subsequent calls to RetrieveContainer will get this container, and not create a new.

C#
void RegisterContainerForElement(
    IAutoContainer container,
    IElement element
);
See Also
IAutoContainerService Interface
Eco.AutoContainers Namespace


IAutoContainerService.RegisteredFactories Method

IAutoContainerService.RegisteredFactories Method
IAutoContainerService Interface Eco.AutoContainers Namespace See Also
Collapse All

Returns a clone of the list of registered factories.

C#
ArrayList RegisteredFactories();
Returns

a clone of the list of registered factories.

See Also
IAutoContainerService Interface
Eco.AutoContainers Namespace


IAutoContainerService.RemoveAllContainers Method

IAutoContainerService.RemoveAllContainers Method
IAutoContainerService Interface Eco.AutoContainers Namespace See Also
Collapse All

Closes all currently showing autoforms, regardless of who brought them info existence.

C#
void RemoveAllContainers();
See Also
IAutoContainerService Interface
Eco.AutoContainers Namespace


IAutoContainerService.RemoveFactory Method

IAutoContainerService.RemoveFactory Method
IAutoContainerService Interface Eco.AutoContainers Namespace See Also
Collapse All

Removes a factory of the same type as the instance passed as parameter.

C#
bool RemoveFactory(
    IAutoContainerFactory autoContainerFactory
);
Parameters
Parameters | Description
autoContainerFactory | Instance of factory that will be removed
Returns

The method will return false if the removal couldn't be done (if there was no factory of the same type).

See Also
IAutoContainerService Interface
Eco.AutoContainers Namespace


IAutoContainerService.RetrieveContainer Method

IAutoContainerService.RetrieveContainer Method
IAutoContainerService Interface Eco.AutoContainers Namespace See Also
Collapse All

Checks if there is a an AutoContainer that can be reused and returns it. If not calls CreateContainer to return a new container.

C#
IAutoContainer RetrieveContainer(
    IElement element,
    AutoContainerArgs autoContainerArgs
);
See Also
IAutoContainerService Interface
Eco.AutoContainers Namespace


IAutoContainerService.UnregisterContainer Method

IAutoContainerService.UnregisterContainer Method
IAutoContainerService Interface Eco.AutoContainers Namespace See Also
Collapse All

Removes a container from the registry.

C#
void UnregisterContainer(
    IAutoContainer container
);
Remarks

Call this method if you intend to dispose a container that has been registered with RegisterContainerForElement.

See Also
IAutoContainerService Interface
Eco.AutoContainers Namespace


Eco.AutoContainers.AutoContainerMemberVisibility Enumeration

Eco.AutoContainers.AutoContainerMemberVisibility Enumeration

Enumeration determining which visibility scopes shall be shown in the autoform.

C#
public enum AutoContainerMemberVisibility {
  AllMembers,
  ProtectedOrHigher,
  PublicOnly
}
Members
Members | Description
AllMembers | All members are shown.
ProtectedOrHigher | Public + protected members are shown.
PublicOnly | Only public members are shown.
File

AutoContainers.cs


Eco.AutoContainers.ContainerReusage Enumeration

Eco.AutoContainers.ContainerReusage Enumeration

Enumeration determining which visibility scopes shall be shown in the autoform.

C#
public enum ContainerReusage {
  NeverReuse,
  ReuseForClass,
  ReuseForElement
}
Members
Members | Description
NeverReuse | Always create new form.
ReuseForClass | Reuse form on a per-class basis.
ReuseForElement | Reuse form on a per-instance basis.
File

AutoContainers.cs


Eco.Cache Namespace

Eco.Cache Namespace
Classes Enumerations Interfaces Types
Collapse All

This is namespace Eco.Cache.

Classes
Name | Description
CanReleaseResult | This is class Eco.Cache.CanReleaseResult.
ChainedCacheBase | This class implements the ICache interface by simply passing all calls on to another ICache implementation It is intended for subclassing by ICache implementations that need to implement only a subset of the features of the interface. Override any methods you need to intercept and at the end of the overridden methods, either call the base method, or call the same method on NextCache manually. If the behaviour of the original cache is not wanted at all, then just skip calling it.
GenericCollection | This is class Eco.Cache.GenericCollection.
Locator | A locator is an identifier that's used to identify an object.
LocatorEventArgs | This is class Eco.Cache.LocatorEventArgs.
LocatorPair | This is class Eco.Cache.LocatorPair.
Top
Enumerations
Name | Description
ExistenceState | Whether or not the object exists.
PersistenceState | How the current value in memory is related to the database.
Top
Interfaces
Name | Description
ICache | The function of an ICache is to store data about objects in memory, in relation to the Db.
Top
Types
Name | Description
CanReleaseDelegate | This is type Eco.Cache.CanReleaseDelegate.
ChangeDelegate | This is type Eco.Cache.ChangeDelegate.
ExtentChangedEventHandler | This is type Eco.Cache.ExtentChangedEventHandler.
LocatorEventHandler | This is type Eco.Cache.LocatorEventHandler.
ValueChangedDelegate | This is type Eco.Cache.ValueChangedDelegate.


CanReleaseResult Class

CanReleaseResult Class
Inheritance Hierarchy See Also
Collapse All
C#
public class CanReleaseResult;
Remarks

This is class Eco.Cache.CanReleaseResult.

Inheritance Hierarchy
Eco.Cache.CanReleaseResult
File

CacheInterfaces.cs

See Also
Inheritance Hierarchy


CanReleaseResult Properties

CanReleaseResult Properties
Public Properties
Collapse All

The properties of the CanReleaseResult class are listed here.

Public Properties
Name | Description
Result | This is Result, a member of class CanReleaseResult.


CanReleaseResult.Result Property

CanReleaseResult.Result Property
CanReleaseResult Class Eco.Cache Namespace See Also
Collapse All
C#
public bool Result;
Remarks

This is Result, a member of class CanReleaseResult.

See Also
CanReleaseResult Class
Eco.Cache Namespace


ChainedCacheBase Class

ChainedCacheBase Class
Inheritance Hierarchy See Also
Collapse All

This class implements the ICache interface by simply passing all calls on to another ICache implementation It is intended for subclassing by ICache implementations that need to implement only a subset of the features of the interface.

Override any methods you need to intercept and at the end of the overridden methods, either call the base method, or call the same method on NextCache manually. If the behaviour of the original cache is not wanted at all, then just skip calling it.

C#
public class ChainedCacheBase : EcoSpacePart, ICache;
Inheritance Hierarchy
Eco.Cache.ICache
    Eco.Cache.ChainedCacheBase
File

AbstractCache.cs

See Also
Inheritance Hierarchy


ChainedCacheBase Methods

ChainedCacheBase Methods
Protected Methods Public Methods
Collapse All

The methods of the ChainedCacheBase class are listed here.

Protected Methods
Name | Description
DoActivate | This is DoActivate, a member of class ChainedCacheBase.
Top
Public Methods
Name | Description
ApplyTranslationList | Default implementation that will only call the same method on the "NextCache"
Contains | Default implementation that will only call the same method on the "NextCache"
CreateNewObject | This is the overview for the CreateNewObject method overload.
DestroyObject | Default implementation that will only call the same method on the "NextCache"
GetAllLocators | Default implementation that will only call the same method on the "NextCache"
GetCurrentOrderNo | Default implementation that will only call the same method on the "NextCache"
GetCurrentValue | Default implementation that will only call the same method on the "NextCache"
GetEnsuredLocatorById | Default implementation that will only call the same method on the "NextCache"
GetExistenceState | Default implementation that will only call the same method on the "NextCache"
GetExtentIsCurrent | Default implementation that will only call the same method on the "NextCache"
GetFetchedOrderNo | Default implementation that will only call the same method on the "NextCache"
GetFetchedValue | Default implementation that will only call the same method on the "NextCache"
GetIdByLocator | Default implementation that will only call the same method on the "NextCache"
GetLocatorById | Default implementation that will only call the same method on the "NextCache"
GetMemberHasFetchedValue | Default implementation that will only call the same method on the "NextCache"
GetMemberPersistenceState | Default implementation that will only call the same method on the "NextCache"
GetPersistenceState | Default implementation that will only call the same method on the "NextCache"
GetTimestamp | Default implementation that will only call the same method on the "NextCache"
GetUmlClass | Default implementation that will only call the same method on the "NextCache"
InvalidateExtent | Default implementation that will only call the same method on the "NextCache"
IsDefaultFetched | Default implementation that will only call the same method on the "NextCache"
IsDirty | Default implementation that will only call the same method on the "NextCache"
IsPersistent | Default implementation that will only call the same method on the "NextCache"
SetCurrentAndFetchedOrderNo | Default implementation that will only call the same method on the "NextCache"
SetCurrentAndFetchedValue | Default implementation that will only call the same method on the "NextCache"
SetCurrentOrderNo | Default implementation that will only call the same method on the "NextCache"
SetCurrentValue | Default implementation that will only call the same method on the "NextCache"
SetExistenceState | Default implementation that will only call the same method on the "NextCache"
SetExtentCurrent | Default implementation that will only call the same method on the "NextCache"
SetFetchedValue | Default implementation that will only call the same method on the "NextCache"
SetMemberPersistenceState | Default implementation that will only call the same method on the "NextCache"
SetObjectId | Default implementation that will only call the same method on the "NextCache"
SetPersistenceState | Default implementation that will only call the same method on the "NextCache"
SetTimestamp | Default implementation that will only call the same method on the "NextCache"


ChainedCacheBase.ApplyTranslationList Method

ChainedCacheBase.ApplyTranslationList Method
ChainedCacheBase Class Eco.Cache Namespace See Also
Collapse All

Default implementation that will only call the same method on the "NextCache"

C#
public virtual void ApplyTranslationList(
    IdTranslationList idTranslationList
);
See Also
ChainedCacheBase Class
Eco.Cache Namespace


ChainedCacheBase.Contains Method

ChainedCacheBase.Contains Method
ChainedCacheBase Class Eco.Cache Namespace See Also
Collapse All

Default implementation that will only call the same method on the "NextCache"

C#
public virtual bool Contains(
    Locator locator
);
See Also
ChainedCacheBase Class
Eco.Cache Namespace


CreateNewObject Method

CreateNewObject Method

This is the overview for the CreateNewObject method overload.

Overload List
Name | Description
ChainedCacheBase.CreateNewObject (IClass) | Default implementation that will only call the same method on the "NextCache"
ChainedCacheBase.CreateNewObject (IClass, ILoopBack) | Default implementation that will only call the same method on the "NextCache"


ChainedCacheBase.CreateNewObject Method (IClass)

ChainedCacheBase.CreateNewObject Method (IClass)
ChainedCacheBase Class Eco.Cache Namespace See Also
Collapse All

Default implementation that will only call the same method on the "NextCache"

C#
public virtual Locator CreateNewObject(
    IClass class_
);
See Also
ChainedCacheBase Class
Eco.Cache Namespace


ChainedCacheBase.CreateNewObject Method (IClass, ILoopBack)

ChainedCacheBase.CreateNewObject Method (IClass, ILoopBack)
ChainedCacheBase Class Eco.Cache Namespace See Also
Collapse All

Default implementation that will only call the same method on the "NextCache"

C#
public virtual Locator CreateNewObject(
    IClass class_,
    ILoopBack loopback
);
See Also
ChainedCacheBase Class
Eco.Cache Namespace


ChainedCacheBase.DestroyObject Method

ChainedCacheBase.DestroyObject Method
ChainedCacheBase Class Eco.Cache Namespace See Also
Collapse All

Default implementation that will only call the same method on the "NextCache"

C#
public virtual void DestroyObject(
    Locator locator
);
See Also
ChainedCacheBase Class
Eco.Cache Namespace


ChainedCacheBase.DoActivate Method

ChainedCacheBase.DoActivate Method
ChainedCacheBase Class Eco.Cache Namespace See Also
Collapse All
C#
protected override void DoActivate();
Remarks

This is DoActivate, a member of class ChainedCacheBase.

See Also
ChainedCacheBase Class
Eco.Cache Namespace


ChainedCacheBase.GetAllLocators Method

ChainedCacheBase.GetAllLocators Method
ChainedCacheBase Class Eco.Cache Namespace See Also
Collapse All

Default implementation that will only call the same method on the "NextCache"

C#
public virtual Locator[] GetAllLocators();
See Also
ChainedCacheBase Class
Eco.Cache Namespace


ChainedCacheBase.GetCurrentOrderNo Method

ChainedCacheBase.GetCurrentOrderNo Method
ChainedCacheBase Class Eco.Cache Namespace See Also
Collapse All

Default implementation that will only call the same method on the "NextCache"

C#
public virtual int GetCurrentOrderNo(
    Locator locator,
    IStructuralFeature structuralFeature
);
See Also
ChainedCacheBase Class
Eco.Cache Namespace


ChainedCacheBase.GetCurrentValue Method

ChainedCacheBase.GetCurrentValue Method
ChainedCacheBase Class Eco.Cache Namespace See Also
Collapse All

Default implementation that will only call the same method on the "NextCache"

C#
public virtual object GetCurrentValue(
    Locator locator,
    IStructuralFeature structuralFeature
);
See Also
ChainedCacheBase Class
Eco.Cache Namespace


ChainedCacheBase.GetEnsuredLocatorById Method

ChainedCacheBase.GetEnsuredLocatorById Method
ChainedCacheBase Class Eco.Cache Namespace See Also
Collapse All

Default implementation that will only call the same method on the "NextCache"

C#
public virtual Locator GetEnsuredLocatorById(
    ObjectId objectId
);
See Also
ChainedCacheBase Class
Eco.Cache Namespace


ChainedCacheBase.GetExistenceState Method

ChainedCacheBase.GetExistenceState Method
ChainedCacheBase Class Eco.Cache Namespace See Also
Collapse All

Default implementation that will only call the same method on the "NextCache"

C#
public virtual ExistenceState GetExistenceState(
    Locator locator
);
See Also
ChainedCacheBase Class
Eco.Cache Namespace


ChainedCacheBase.GetExtentIsCurrent Method

ChainedCacheBase.GetExtentIsCurrent Method
ChainedCacheBase Class Eco.Cache Namespace See Also
Collapse All

Default implementation that will only call the same method on the "NextCache"

C#
public virtual bool GetExtentIsCurrent(
    IClass c
);
See Also
ChainedCacheBase Class
Eco.Cache Namespace


ChainedCacheBase.GetFetchedOrderNo Method

ChainedCacheBase.GetFetchedOrderNo Method
ChainedCacheBase Class Eco.Cache Namespace See Also
Collapse All

Default implementation that will only call the same method on the "NextCache"

C#
public virtual int GetFetchedOrderNo(
    Locator locator,
    IStructuralFeature structuralFeature
);
See Also
ChainedCacheBase Class
Eco.Cache Namespace


ChainedCacheBase.GetFetchedValue Method

ChainedCacheBase.GetFetchedValue Method
ChainedCacheBase Class Eco.Cache Namespace See Also
Collapse All

Default implementation that will only call the same method on the "NextCache"

C#
public virtual object GetFetchedValue(
    Locator locator,
    IStructuralFeature structuralFeature
);
See Also
ChainedCacheBase Class
Eco.Cache Namespace


ChainedCacheBase.GetIdByLocator Method

ChainedCacheBase.GetIdByLocator Method
ChainedCacheBase Class Eco.Cache Namespace See Also
Collapse All

Default implementation that will only call the same method on the "NextCache"

C#
public virtual ObjectId GetIdByLocator(
    Locator locator
);
See Also
ChainedCacheBase Class
Eco.Cache Namespace


ChainedCacheBase.GetLocatorById Method

ChainedCacheBase.GetLocatorById Method
ChainedCacheBase Class Eco.Cache Namespace See Also
Collapse All

Default implementation that will only call the same method on the "NextCache"

C#
public virtual Locator GetLocatorById(
    ObjectId objectId
);
See Also
ChainedCacheBase Class
Eco.Cache Namespace


ChainedCacheBase.GetMemberHasFetchedValue Method

ChainedCacheBase.GetMemberHasFetchedValue Method
ChainedCacheBase Class Eco.Cache Namespace See Also
Collapse All

Default implementation that will only call the same method on the "NextCache"

C#
public virtual bool GetMemberHasFetchedValue(
    Locator locator,
    IStructuralFeature structuralFeature
);
See Also
ChainedCacheBase Class
Eco.Cache Namespace


ChainedCacheBase.GetMemberPersistenceState Method

ChainedCacheBase.GetMemberPersistenceState Method
ChainedCacheBase Class Eco.Cache Namespace See Also
Collapse All

Default implementation that will only call the same method on the "NextCache"

C#
public virtual PersistenceState GetMemberPersistenceState(
    Locator locator,
    IStructuralFeature structuralFeature
);
See Also
ChainedCacheBase Class
Eco.Cache Namespace


ChainedCacheBase.GetPersistenceState Method

ChainedCacheBase.GetPersistenceState Method
ChainedCacheBase Class Eco.Cache Namespace See Also
Collapse All

Default implementation that will only call the same method on the "NextCache"

C#
public virtual PersistenceState GetPersistenceState(
    Locator locator
);
See Also
ChainedCacheBase Class
Eco.Cache Namespace


ChainedCacheBase.GetTimestamp Method

ChainedCacheBase.GetTimestamp Method
ChainedCacheBase Class Eco.Cache Namespace See Also
Collapse All

Default implementation that will only call the same method on the "NextCache"

C#
public virtual int GetTimestamp(
    Locator locator
);
See Also
ChainedCacheBase Class
Eco.Cache Namespace


ChainedCacheBase.GetUmlClass Method

ChainedCacheBase.GetUmlClass Method
ChainedCacheBase Class Eco.Cache Namespace See Also
Collapse All

Default implementation that will only call the same method on the "NextCache"

C#
public virtual IClass GetUmlClass(
    Locator locator
);
See Also
ChainedCacheBase Class
Eco.Cache Namespace


ChainedCacheBase.InvalidateExtent Method

ChainedCacheBase.InvalidateExtent Method
ChainedCacheBase Class Eco.Cache Namespace See Also
Collapse All

Default implementation that will only call the same method on the "NextCache"

C#
public virtual void InvalidateExtent(
    IClass c
);
See Also
ChainedCacheBase Class
Eco.Cache Namespace


ChainedCacheBase.IsDefaultFetched Method

ChainedCacheBase.IsDefaultFetched Method
ChainedCacheBase Class Eco.Cache Namespace See Also
Collapse All

Default implementation that will only call the same method on the "NextCache"

C#
public virtual bool IsDefaultFetched(
    Locator locator
);
See Also
ChainedCacheBase Class
Eco.Cache Namespace


ChainedCacheBase.IsDirty Method

ChainedCacheBase.IsDirty Method
ChainedCacheBase Class Eco.Cache Namespace See Also
Collapse All

Default implementation that will only call the same method on the "NextCache"

C#
public virtual bool IsDirty(
    Locator locator
);
See Also
ChainedCacheBase Class
Eco.Cache Namespace


ChainedCacheBase.IsPersistent Method

ChainedCacheBase.IsPersistent Method
ChainedCacheBase Class Eco.Cache Namespace See Also
Collapse All

Default implementation that will only call the same method on the "NextCache"

C#
public virtual bool IsPersistent(
    Locator locator
);
See Also
ChainedCacheBase Class
Eco.Cache Namespace


ChainedCacheBase.SetCurrentAndFetchedOrderNo Method

ChainedCacheBase.SetCurrentAndFetchedOrderNo Method
ChainedCacheBase Class Eco.Cache Namespace See Also
Collapse All

Default implementation that will only call the same method on the "NextCache"

C#
public virtual void SetCurrentAndFetchedOrderNo(
    Locator locator,
    IStructuralFeature structuralFeature,
    int orderNo
);
See Also
ChainedCacheBase Class
Eco.Cache Namespace


ChainedCacheBase.SetCurrentAndFetchedValue Method

ChainedCacheBase.SetCurrentAndFetchedValue Method
ChainedCacheBase Class Eco.Cache Namespace See Also
Collapse All

Default implementation that will only call the same method on the "NextCache"

C#
public virtual void SetCurrentAndFetchedValue(
    Locator locator,
    IStructuralFeature structuralFeature,
    object value
);
See Also
ChainedCacheBase Class
Eco.Cache Namespace


ChainedCacheBase.SetCurrentOrderNo Method

ChainedCacheBase.SetCurrentOrderNo Method
ChainedCacheBase Class Eco.Cache Namespace See Also
Collapse All

Default implementation that will only call the same method on the "NextCache"

C#
public virtual void SetCurrentOrderNo(
    Locator locator,
    IStructuralFeature structuralFeature,
    int orderNo
);
See Also
ChainedCacheBase Class
Eco.Cache Namespace


ChainedCacheBase.SetCurrentValue Method

ChainedCacheBase.SetCurrentValue Method
ChainedCacheBase Class Eco.Cache Namespace See Also
Collapse All

Default implementation that will only call the same method on the "NextCache"

C#
public virtual void SetCurrentValue(
    Locator locator,
    IStructuralFeature structuralFeature,
    object value
);
See Also
ChainedCacheBase Class
Eco.Cache Namespace


ChainedCacheBase.SetExistenceState Method

ChainedCacheBase.SetExistenceState Method
ChainedCacheBase Class Eco.Cache Namespace See Also
Collapse All

Default implementation that will only call the same method on the "NextCache"

C#
public virtual void SetExistenceState(
    Locator locator,
    Eco.Cache.ExistenceState value
);
See Also
ChainedCacheBase Class
Eco.Cache Namespace


ChainedCacheBase.SetExtentCurrent Method

ChainedCacheBase.SetExtentCurrent Method
ChainedCacheBase Class Eco.Cache Namespace See Also
Collapse All

Default implementation that will only call the same method on the "NextCache"

C#
public virtual void SetExtentCurrent(
    IClass c
);
See Also
ChainedCacheBase Class
Eco.Cache Namespace


ChainedCacheBase.SetFetchedValue Method

ChainedCacheBase.SetFetchedValue Method
ChainedCacheBase Class Eco.Cache Namespace See Also
Collapse All

Default implementation that will only call the same method on the "NextCache"

C#
public virtual void SetFetchedValue(
    Locator locator,
    IStructuralFeature structuralFeature,
    object value
);
See Also
ChainedCacheBase Class
Eco.Cache Namespace


ChainedCacheBase.SetMemberPersistenceState Method

ChainedCacheBase.SetMemberPersistenceState Method
ChainedCacheBase Class Eco.Cache Namespace See Also
Collapse All

Default implementation that will only call the same method on the "NextCache"

C#
public virtual void SetMemberPersistenceState(
    Locator locator,
    IStructuralFeature structuralFeature,
    PersistenceState value
);
See Also
ChainedCacheBase Class
Eco.Cache Namespace


ChainedCacheBase.SetObjectId Method

ChainedCacheBase.SetObjectId Method
ChainedCacheBase Class Eco.Cache Namespace See Also
Collapse All

Default implementation that will only call the same method on the "NextCache"

C#
public void SetObjectId(
    Locator locator,
    ObjectId newId
);
See Also
ChainedCacheBase Class
Eco.Cache Namespace


ChainedCacheBase.SetPersistenceState Method

ChainedCacheBase.SetPersistenceState Method
ChainedCacheBase Class Eco.Cache Namespace See Also
Collapse All

Default implementation that will only call the same method on the "NextCache"

C#
public virtual void SetPersistenceState(
    Locator locator,
    PersistenceState value
);
See Also
ChainedCacheBase Class
Eco.Cache Namespace


ChainedCacheBase.SetTimestamp Method

ChainedCacheBase.SetTimestamp Method
ChainedCacheBase Class Eco.Cache Namespace See Also
Collapse All

Default implementation that will only call the same method on the "NextCache"

C#
public virtual void SetTimestamp(
    Locator locator,
    int value
);
See Also
ChainedCacheBase Class
Eco.Cache Namespace


ChainedCacheBase Properties

ChainedCacheBase Properties
Public Properties
Collapse All

The properties of the ChainedCacheBase class are listed here.

Public Properties
Name | Description
DeleteStack | Default implementation that will only call the same method on the "NextCache"
IsActive | Default implementation that will only call the same property on the "NextCache"
NextCache | Set the "NextCache" to allow the default implementations of all interface methods to pass through the calls to another cache Setting this property is mandatory!


ChainedCacheBase.DeleteStack Property

ChainedCacheBase.DeleteStack Property
ChainedCacheBase Class Eco.Cache Namespace See Also
Collapse All

Default implementation that will only call the same method on the "NextCache"

C#
public ICollection<Locator> DeleteStack;
See Also
ChainedCacheBase Class
Eco.Cache Namespace


ChainedCacheBase.IsActive Property

ChainedCacheBase.IsActive Property
ChainedCacheBase Class Eco.Cache Namespace See Also
Collapse All

Default implementation that will only call the same property on the "NextCache"

C#
public virtual bool IsActive;
See Also
ChainedCacheBase Class
Eco.Cache Namespace


ChainedCacheBase.NextCache Property

ChainedCacheBase.NextCache Property
ChainedCacheBase Class Eco.Cache Namespace See Also
Collapse All

Set the "NextCache" to allow the default implementations of all interface methods to pass through the calls to another cache Setting this property is mandatory!

C#
public ICache NextCache;
See Also
ChainedCacheBase Class
Eco.Cache Namespace


ChainedCacheBase Events

ChainedCacheBase Events
Public Events
Collapse All

The events of the ChainedCacheBase class are listed here.

Public Events
Name | Description
CanRelease | Default implementation that will only call the same method on the "NextCache"
DirtyChanged | Default implementation that will only call the same method on the "NextCache"
ExistenceChanged | Default implementation that will only call the same method on the "NextCache"
ExtentInvalidated | Default implementation that will only call the same method on the "NextCache"
LocatorAdded | Default implementation that will only call the same method on the "NextCache"
ValueChanged | Default implementation that will only call the same method on the "NextCache"


ChainedCacheBase.CanRelease Event

ChainedCacheBase.CanRelease Event
ChainedCacheBase Class Eco.Cache Namespace See Also
Collapse All

Default implementation that will only call the same method on the "NextCache"

C#
public virtual event CanReleaseDelegate CanRelease;
See Also
ChainedCacheBase Class
Eco.Cache Namespace


ChainedCacheBase.DirtyChanged Event

ChainedCacheBase.DirtyChanged Event
ChainedCacheBase Class Eco.Cache Namespace See Also
Collapse All

Default implementation that will only call the same method on the "NextCache"

C#
public virtual event LocatorEventHandler DirtyChanged;
See Also
ChainedCacheBase Class
Eco.Cache Namespace


ChainedCacheBase.ExistenceChanged Event

ChainedCacheBase.ExistenceChanged Event
ChainedCacheBase Class Eco.Cache Namespace See Also
Collapse All

Default implementation that will only call the same method on the "NextCache"

C#
public virtual event LocatorEventHandler ExistenceChanged;
See Also
ChainedCacheBase Class
Eco.Cache Namespace


ChainedCacheBase.ExtentInvalidated Event

ChainedCacheBase.ExtentInvalidated Event
ChainedCacheBase Class Eco.Cache Namespace See Also
Collapse All

Default implementation that will only call the same method on the "NextCache"

C#
public virtual event ExtentChangedEventHandler ExtentInvalidated;
See Also
ChainedCacheBase Class
Eco.Cache Namespace


ChainedCacheBase.LocatorAdded Event

ChainedCacheBase.LocatorAdded Event
ChainedCacheBase Class Eco.Cache Namespace See Also
Collapse All

Default implementation that will only call the same method on the "NextCache"

C#
public virtual event LocatorEventHandler LocatorAdded;
See Also
ChainedCacheBase Class
Eco.Cache Namespace


ChainedCacheBase.ValueChanged Event

ChainedCacheBase.ValueChanged Event
ChainedCacheBase Class Eco.Cache Namespace See Also
Collapse All

Default implementation that will only call the same method on the "NextCache"

C#
public virtual event ValueChangedDelegate ValueChanged;
See Also
ChainedCacheBase Class
Eco.Cache Namespace


GenericCollection Class

GenericCollection Class
Inheritance Hierarchy See Also
Collapse All
C#
public class GenericCollection<T> : ICollection<T>, IEnumerable<T>;
Remarks

This is class Eco.Cache.GenericCollection.

Inheritance Hierarchy
Eco.Cache.GenericCollection
File

CacheInterfaces.cs

See Also
Inheritance Hierarchy


GenericCollection Methods

GenericCollection Methods
Public Methods
Collapse All

The methods of the GenericCollection class are listed here.

Public Methods
Name | Description
Add | This is Add, a member of class GenericCollection.
Clear | This is Clear, a member of class GenericCollection.
Contains | This is Contains, a member of class GenericCollection.
CopyTo | This is CopyTo, a member of class GenericCollection.
Remove | This is Remove, a member of class GenericCollection.


GenericCollection.Add Method

GenericCollection.Add Method
GenericCollection Class Eco.Cache Namespace See Also
Collapse All
C#
public void Add(
    T item
);
Remarks

This is Add, a member of class GenericCollection.

See Also
GenericCollection Class
Eco.Cache Namespace


GenericCollection.Clear Method

GenericCollection.Clear Method
GenericCollection Class Eco.Cache Namespace See Also
Collapse All
C#
public void Clear();
Remarks

This is Clear, a member of class GenericCollection.

See Also
GenericCollection Class
Eco.Cache Namespace


GenericCollection.Contains Method

GenericCollection.Contains Method
GenericCollection Class Eco.Cache Namespace See Also
Collapse All
C#
public bool Contains(
    T item
);
Remarks

This is Contains, a member of class GenericCollection.

See Also
GenericCollection Class
Eco.Cache Namespace


GenericCollection.CopyTo Method

GenericCollection.CopyTo Method
GenericCollection Class Eco.Cache Namespace See Also
Collapse All
C#
public void CopyTo(
    T[] array,
    int arrayIndex
);
Remarks

This is CopyTo, a member of class GenericCollection.

See Also
GenericCollection Class
Eco.Cache Namespace


GenericCollection.Remove Method

GenericCollection.Remove Method
GenericCollection Class Eco.Cache Namespace See Also
Collapse All
C#
public bool Remove(
    T item
);
Remarks

This is Remove, a member of class GenericCollection.

See Also
GenericCollection Class
Eco.Cache Namespace


GenericCollection Properties

GenericCollection Properties
Public Properties
Collapse All

The properties of the GenericCollection class are listed here.

Public Properties
Name | Description
Count | This is Count, a member of class GenericCollection.
IsReadOnly | This is IsReadOnly, a member of class GenericCollection.


GenericCollection.Count Property

GenericCollection.Count Property
GenericCollection Class Eco.Cache Namespace See Also
Collapse All
C#
public int Count;
Remarks

This is Count, a member of class GenericCollection.

See Also
GenericCollection Class
Eco.Cache Namespace


GenericCollection.IsReadOnly Property

GenericCollection.IsReadOnly Property
GenericCollection Class Eco.Cache Namespace See Also
Collapse All
C#
public bool IsReadOnly;
Remarks

This is IsReadOnly, a member of class GenericCollection.

See Also
GenericCollection Class
Eco.Cache Namespace


Locator Class

Locator Class
Inheritance Hierarchy See Also
Collapse All

A locator is an identifier that's used to identify an object.

C#
public abstract class Locator;
Remarks

It has reference semantics. It has no features of its own, but is accessed through the ICache interface.

Inheritance Hierarchy
Eco.Cache.Locator
File

CacheInterfaces.cs

See Also
Inheritance Hierarchy


Locator Properties

Locator Properties
Public Properties
Collapse All

The properties of the Locator class are listed here.

Public Properties
Name | Description
Id | This is Id, a member of class Locator.


Locator.Id Property

Locator.Id Property
Locator Class Eco.Cache Namespace See Also
Collapse All
C#
public abstract ObjectId Id;
Remarks

This is Id, a member of class Locator.

See Also
Locator Class
Eco.Cache Namespace


LocatorEventArgs Class

LocatorEventArgs Class
Inheritance Hierarchy See Also
Collapse All
C#
public sealed class LocatorEventArgs : EventArgs;
Remarks

This is class Eco.Cache.LocatorEventArgs.

Inheritance Hierarchy
Eco.Cache.LocatorEventArgs
File

CacheInterfaces.cs

See Also
Inheritance Hierarchy


LocatorEventArgs.LocatorEventArgs Constructor

LocatorEventArgs.LocatorEventArgs Constructor
LocatorEventArgs Class Eco.Cache Namespace See Also
Collapse All
C#
public LocatorEventArgs(
    Locator locator
);
Remarks

This is LocatorEventArgs, a member of class LocatorEventArgs.

See Also
LocatorEventArgs Class
Eco.Cache Namespace


LocatorEventArgs Properties

LocatorEventArgs Properties
Public Properties
Collapse All

The properties of the LocatorEventArgs class are listed here.

Public Properties
Name | Description
Locator | This is Locator, a member of class LocatorEventArgs.


LocatorEventArgs.Locator Property

LocatorEventArgs.Locator Property
LocatorEventArgs Class Eco.Cache Namespace See Also
Collapse All
C#
public Locator Locator;
Remarks

This is Locator, a member of class LocatorEventArgs.

See Also
LocatorEventArgs Class
Eco.Cache Namespace


LocatorPair Class

LocatorPair Class
Inheritance Hierarchy See Also
Collapse All
C#
public class LocatorPair;
Remarks

This is class Eco.Cache.LocatorPair.

Inheritance Hierarchy
Eco.Cache.LocatorPair
File

CacheInterfaces.cs

See Also
Inheritance Hierarchy


LocatorPair.LocatorPair Constructor

LocatorPair.LocatorPair Constructor
LocatorPair Class Eco.Cache Namespace See Also
Collapse All
C#
public LocatorPair(
    Locator loc1,
    Locator loc2
);
Remarks

This is LocatorPair, a member of class LocatorPair.

See Also
LocatorPair Class
Eco.Cache Namespace


LocatorPair Properties

LocatorPair Properties
Public Properties
Collapse All

The properties of the LocatorPair class are listed here.

Public Properties
Name | Description
Loc1 | This is Loc1, a member of class LocatorPair.
Loc2 | This is Loc2, a member of class LocatorPair.


LocatorPair.Loc1 Property

LocatorPair.Loc1 Property
LocatorPair Class Eco.Cache Namespace See Also
Collapse All
C#
public Locator Loc1;
Remarks

This is Loc1, a member of class LocatorPair.

See Also
LocatorPair Class
Eco.Cache Namespace


LocatorPair.Loc2 Property

LocatorPair.Loc2 Property
LocatorPair Class Eco.Cache Namespace See Also
Collapse All
C#
public Locator Loc2;
Remarks

This is Loc2, a member of class LocatorPair.

See Also
LocatorPair Class
Eco.Cache Namespace


ICache Interface

ICache Interface
Inheritance Hierarchy See Also
Collapse All

The function of an ICache is to store data about objects in memory, in relation to the Db.

C#
public interface ICache;
Inheritance Hierarchy
Eco.Cache.ICache
    Eco.Cache.ChainedCacheBase
File

CacheInterfaces.cs

See Also
Inheritance Hierarchy


ICache Methods

ICache Methods
Public Methods
Collapse All

The methods of the ICache class are listed here.

Public Methods
Name | Description
ApplyTranslationList | Changes the ObjectIds of objects in the cache according to to translations in the list
Contains | Returns true if the locator belongs to the cache
CreateNewObject | This is the overview for the CreateNewObject method overload.
DestroyObject | Remove locator from the cache.
GetAllLocators | The locators of all the objects in the cache
GetCurrentOrderNo | Returns the order number of an item in an ordered association.
GetCurrentValue | Returns the current value of a member
GetEnsuredLocatorById | Returns the locator associated with a particular ObjectId. If it doesn't exist in the cache, it is created
GetExistenceState | Returns the existence state of the object
GetExtentIsCurrent | This is GetExtentIsCurrent, a member of class ICache.
GetFetchedOrderNo | Returns the fetched order number of an item in an ordered association
GetFetchedValue | Returns the fetched value of a member
GetIdByLocator | Returns the ObjectId associated with a locator
GetLocatorById | Returns the locator associated with a particular ObjectId. If it doesn't exist in the cache, null is returned
GetMemberHasFetchedValue | Returns true if the fetched value differs from the current value
GetMemberPersistenceState | Returns the persistence state of a member
GetPersistenceState | Returns the persistence state of the object. It indicates the persistence state only, not the members of the object
GetTimestamp | If this object uses timestamp-based optimistic locking, this is the timestamp of the object. Otherwise it is -1
GetUmlClass | Returns the IClass of the object
InvalidateExtent | This is InvalidateExtent, a member of class ICache.
IsDefaultFetched | Returns true if the object referred by the locator has been default fetched, i.e. all persistence non-delayfetch members have been fetched
IsDirty | Returns true if the object referred by the locator is dirty, i.e. if it is persistent, and either is new, or deleted, or had at least one member that is Modified
IsPersistent | Returns true if the object referred by the locator is persistent, false if it's transient
SetCurrentAndFetchedOrderNo | Same as SetCurrentOrderNo, except it sets both the current value and the fetched value
SetCurrentAndFetchedValue | Sets the current and fetched values of a member. Equvalent to calling SetCurrentValue and SetFetchedValue with the same value.
SetCurrentOrderNo | Sets the order number of an item in an ordered association. The structuralFeature feature must refer to an embedded single end of an ordered association. The correponding multi end will be sorted automatically.
SetCurrentValue | Sets the current value of a member
SetExistenceState | Sets the existence state of the object
SetExtentCurrent | This is SetExtentCurrent, a member of class ICache.
SetFetchedValue | Sets the fetched value of a member
SetMemberPersistenceState | Sets the persistence state of a member
SetObjectId | Changes the ObjectId of an object to newId
SetPersistenceState | Sets the persistence state of the object. It indicates the exisitence state only, not the members of the object
SetTimestamp | Sets the timestamp. If this object uses timestamp-based optimistic locking, this is the timestamp of the object. Otherwise it is -1


ICache.ApplyTranslationList Method

ICache.ApplyTranslationList Method
ICache Interface Eco.Cache Namespace See Also
Collapse All

Changes the ObjectIds of objects in the cache according to to translations in the list

C#
void ApplyTranslationList(
    IdTranslationList idTranslationList
);
See Also
ICache Interface
Eco.Cache Namespace


ICache.Contains Method

ICache.Contains Method
ICache Interface Eco.Cache Namespace See Also
Collapse All

Returns true if the locator belongs to the cache

C#
bool Contains(
    Locator locator
);
See Also
ICache Interface
Eco.Cache Namespace


CreateNewObject Method

CreateNewObject Method

This is the overview for the CreateNewObject method overload.

Overload List
Name | Description
ICache.CreateNewObject (IClass) | Creates, and returns, a new locator with the UmlClass class_. A non-persistent id will be generated and assigned automatically.
ICache.CreateNewObject (IClass, ILoopBack) | Creates, and returns, a new locator with the UmlClass class_. A non-persistent id will be generated and assigned automatically. The locator will be hooked up with the loopback object.


ICache.CreateNewObject Method (IClass)

ICache.CreateNewObject Method (IClass)
ICache Interface Eco.Cache Namespace See Also
Collapse All

Creates, and returns, a new locator with the UmlClass class_. A non-persistent id will be generated and assigned automatically.

C#
Locator CreateNewObject(
    IClass class_
);
See Also
ICache Interface
Eco.Cache Namespace


ICache.CreateNewObject Method (IClass, ILoopBack)

ICache.CreateNewObject Method (IClass, ILoopBack)
ICache Interface Eco.Cache Namespace See Also
Collapse All

Creates, and returns, a new locator with the UmlClass class_. A non-persistent id will be generated and assigned automatically. The locator will be hooked up with the loopback object.

C#
Locator CreateNewObject(
    IClass class_,
    ILoopBack loopback
);
See Also
ICache Interface
Eco.Cache Namespace


ICache.DestroyObject Method

ICache.DestroyObject Method
ICache Interface Eco.Cache Namespace See Also
Collapse All

Remove locator from the cache.

C#
void DestroyObject(
    Locator locator
);
See Also
ICache Interface
Eco.Cache Namespace


ICache.GetAllLocators Method

ICache.GetAllLocators Method
ICache Interface Eco.Cache Namespace See Also
Collapse All

The locators of all the objects in the cache

C#
Locator[] GetAllLocators();
See Also
ICache Interface
Eco.Cache Namespace


ICache.GetCurrentOrderNo Method

ICache.GetCurrentOrderNo Method
ICache Interface Eco.Cache Namespace See Also
Collapse All

Returns the order number of an item in an ordered association.

C#
int GetCurrentOrderNo(
    Locator locator,
    IStructuralFeature structuralFeature
);
See Also
ICache Interface
Eco.Cache Namespace


ICache.GetCurrentValue Method

ICache.GetCurrentValue Method
ICache Interface Eco.Cache Namespace See Also
Collapse All

Returns the current value of a member

C#
object GetCurrentValue(
    Locator locator,
    IStructuralFeature structuralFeature
);
See Also
ICache Interface
Eco.Cache Namespace


ICache.GetEnsuredLocatorById Method

ICache.GetEnsuredLocatorById Method
ICache Interface Eco.Cache Namespace See Also
Collapse All

Returns the locator associated with a particular ObjectId. If it doesn't exist in the cache, it is created

C#
Locator GetEnsuredLocatorById(
    ObjectId objectId
);
See Also
ICache Interface
Eco.Cache Namespace


ICache.GetExistenceState Method

ICache.GetExistenceState Method
ICache Interface Eco.Cache Namespace See Also
Collapse All

Returns the existence state of the object

C#
ExistenceState GetExistenceState(
    Locator locator
);
See Also
ICache Interface
Eco.Cache Namespace


ICache.GetExtentIsCurrent Method

ICache.GetExtentIsCurrent Method
ICache Interface Eco.Cache Namespace See Also
Collapse All
C#
bool GetExtentIsCurrent(
    IClass c
);
Remarks

This is GetExtentIsCurrent, a member of class ICache.

See Also
ICache Interface
Eco.Cache Namespace


ICache.GetFetchedOrderNo Method

ICache.GetFetchedOrderNo Method
ICache Interface Eco.Cache Namespace See Also
Collapse All

Returns the fetched order number of an item in an ordered association

C#
int GetFetchedOrderNo(
    Locator locator,
    IStructuralFeature structuralFeature
);
See Also
ICache Interface
Eco.Cache Namespace


ICache.GetFetchedValue Method

ICache.GetFetchedValue Method
ICache Interface Eco.Cache Namespace See Also
Collapse All

Returns the fetched value of a member

C#
object GetFetchedValue(
    Locator locator,
    IStructuralFeature structuralFeature
);
See Also
ICache Interface
Eco.Cache Namespace


ICache.GetIdByLocator Method

ICache.GetIdByLocator Method
ICache Interface Eco.Cache Namespace See Also
Collapse All

Returns the ObjectId associated with a locator

C#
ObjectId GetIdByLocator(
    Locator locator
);
See Also
ICache Interface
Eco.Cache Namespace


ICache.GetLocatorById Method

ICache.GetLocatorById Method
ICache Interface Eco.Cache Namespace See Also
Collapse All

Returns the locator associated with a particular ObjectId. If it doesn't exist in the cache, null is returned

C#
Locator GetLocatorById(
    ObjectId objectId
);
See Also
ICache Interface
Eco.Cache Namespace


ICache.GetMemberHasFetchedValue Method

ICache.GetMemberHasFetchedValue Method
ICache Interface Eco.Cache Namespace See Also
Collapse All

Returns true if the fetched value differs from the current value

C#
bool GetMemberHasFetchedValue(
    Locator locator,
    IStructuralFeature structuralFeature
);
See Also
ICache Interface
Eco.Cache Namespace


ICache.GetMemberPersistenceState Method

ICache.GetMemberPersistenceState Method
ICache Interface Eco.Cache Namespace See Also
Collapse All

Returns the persistence state of a member

C#
PersistenceState GetMemberPersistenceState(
    Locator locator,
    IStructuralFeature structuralFeature
);
See Also
ICache Interface
Eco.Cache Namespace


ICache.GetPersistenceState Method

ICache.GetPersistenceState Method
ICache Interface Eco.Cache Namespace See Also
Collapse All

Returns the persistence state of the object. It indicates the persistence state only, not the members of the object

C#
PersistenceState GetPersistenceState(
    Locator locator
);
See Also
ICache Interface
Eco.Cache Namespace


ICache.GetTimestamp Method

ICache.GetTimestamp Method
ICache Interface Eco.Cache Namespace See Also
Collapse All

If this object uses timestamp-based optimistic locking, this is the timestamp of the object. Otherwise it is -1

C#
int GetTimestamp(
    Locator locator
);
See Also
ICache Interface
Eco.Cache Namespace


ICache.GetUmlClass Method

ICache.GetUmlClass Method
ICache Interface Eco.Cache Namespace See Also
Collapse All

Returns the IClass of the object

C#
IClass GetUmlClass(
    Locator locator
);
See Also
ICache Interface
Eco.Cache Namespace


ICache.InvalidateExtent Method

ICache.InvalidateExtent Method
ICache Interface Eco.Cache Namespace See Also
Collapse All
C#
void InvalidateExtent(
    IClass c
);
Remarks

This is InvalidateExtent, a member of class ICache.

See Also
ICache Interface
Eco.Cache Namespace


ICache.IsDefaultFetched Method

ICache.IsDefaultFetched Method
ICache Interface Eco.Cache Namespace See Also
Collapse All

Returns true if the object referred by the locator has been default fetched, i.e. all persistence non-delayfetch members have been fetched

C#
bool IsDefaultFetched(
    Locator locator
);
See Also
ICache Interface
Eco.Cache Namespace


ICache.IsDirty Method

ICache.IsDirty Method
ICache Interface Eco.Cache Namespace See Also
Collapse All

Returns true if the object referred by the locator is dirty, i.e. if it is persistent, and either is new, or deleted, or had at least one member that is Modified

C#
bool IsDirty(
    Locator locator
);
See Also
ICache Interface
Eco.Cache Namespace


ICache.IsPersistent Method

ICache.IsPersistent Method
ICache Interface Eco.Cache Namespace See Also
Collapse All

Returns true if the object referred by the locator is persistent, false if it's transient

C#
bool IsPersistent(
    Locator locator
);
See Also
ICache Interface
Eco.Cache Namespace


ICache.SetCurrentAndFetchedOrderNo Method

ICache.SetCurrentAndFetchedOrderNo Method
ICache Interface Eco.Cache Namespace See Also
Collapse All

Same as SetCurrentOrderNo, except it sets both the current value and the fetched value

C#
void SetCurrentAndFetchedOrderNo(
    Locator locator,
    IStructuralFeature structuralFeature,
    int orderNo
);
See Also
ICache Interface
Eco.Cache Namespace


ICache.SetCurrentAndFetchedValue Method

ICache.SetCurrentAndFetchedValue Method
ICache Interface Eco.Cache Namespace See Also
Collapse All

Sets the current and fetched values of a member. Equvalent to calling SetCurrentValue and SetFetchedValue with the same value.

C#
void SetCurrentAndFetchedValue(
    Locator locator,
    IStructuralFeature structuralFeature,
    object value
);
See Also
ICache Interface
Eco.Cache Namespace


ICache.SetCurrentOrderNo Method

ICache.SetCurrentOrderNo Method
ICache Interface Eco.Cache Namespace See Also
Collapse All

Sets the order number of an item in an ordered association. The structuralFeature feature must refer to an embedded single end of an ordered association. The correponding multi end will be sorted automatically.

C#
void SetCurrentOrderNo(
    Locator locator,
    IStructuralFeature structuralFeature,
    int orderNo
);
See Also
ICache Interface
Eco.Cache Namespace


ICache.SetCurrentValue Method

ICache.SetCurrentValue Method
ICache Interface Eco.Cache Namespace See Also
Collapse All

Sets the current value of a member

C#
void SetCurrentValue(
    Locator locator,
    IStructuralFeature structuralFeature,
    object value
);
See Also
ICache Interface
Eco.Cache Namespace


ICache.SetExistenceState Method

ICache.SetExistenceState Method
ICache Interface Eco.Cache Namespace See Also
Collapse All

Sets the existence state of the object

C#
void SetExistenceState(
    Locator locator,
    ExistenceState value
);
See Also
ICache Interface
Eco.Cache Namespace


ICache.SetExtentCurrent Method

ICache.SetExtentCurrent Method
ICache Interface Eco.Cache Namespace See Also
Collapse All
C#
void SetExtentCurrent(
    IClass c
);
Remarks

This is SetExtentCurrent, a member of class ICache.

See Also
ICache Interface
Eco.Cache Namespace


ICache.SetFetchedValue Method

ICache.SetFetchedValue Method
ICache Interface Eco.Cache Namespace See Also
Collapse All

Sets the fetched value of a member

C#
void SetFetchedValue(
    Locator locator,
    IStructuralFeature structuralFeature,
    object value
);
See Also
ICache Interface
Eco.Cache Namespace


ICache.SetMemberPersistenceState Method

ICache.SetMemberPersistenceState Method
ICache Interface Eco.Cache Namespace See Also
Collapse All

Sets the persistence state of a member

C#
void SetMemberPersistenceState(
    Locator locator,
    IStructuralFeature structuralFeature,
    PersistenceState value
);
See Also
ICache Interface
Eco.Cache Namespace


ICache.SetObjectId Method

ICache.SetObjectId Method
ICache Interface Eco.Cache Namespace See Also
Collapse All

Changes the ObjectId of an object to newId

C#
void SetObjectId(
    Locator locator,
    ObjectId newId
);
See Also
ICache Interface
Eco.Cache Namespace


ICache.SetPersistenceState Method

ICache.SetPersistenceState Method
ICache Interface Eco.Cache Namespace See Also
Collapse All

Sets the persistence state of the object. It indicates the exisitence state only, not the members of the object

C#
void SetPersistenceState(
    Locator locator,
    PersistenceState value
);
See Also
ICache Interface
Eco.Cache Namespace


ICache.SetTimestamp Method

ICache.SetTimestamp Method
ICache Interface Eco.Cache Namespace See Also
Collapse All

Sets the timestamp. If this object uses timestamp-based optimistic locking, this is the timestamp of the object. Otherwise it is -1

C#
void SetTimestamp(
    Locator locator,
    int value
);
See Also
ICache Interface
Eco.Cache Namespace


ICache Properties

ICache Properties
Public Properties
Collapse All

The properties of the ICache class are listed here.

Public Properties
Name | Description
DeleteStack | The deletestack is used internally to store references to objects that are being deleted during complex delete-operations to avoid circular dependencies
IsActive | This is IsActive, a member of class ICache.


ICache.DeleteStack Property

ICache.DeleteStack Property
ICache Interface Eco.Cache Namespace See Also
Collapse All

The deletestack is used internally to store references to objects that are being deleted during complex delete-operations to avoid circular dependencies

C#
ICollection<Locator> DeleteStack;
See Also
ICache Interface
Eco.Cache Namespace


ICache.IsActive Property

ICache.IsActive Property
ICache Interface Eco.Cache Namespace See Also
Collapse All
C#
bool IsActive;
Remarks

This is IsActive, a member of class ICache.

See Also
ICache Interface
Eco.Cache Namespace


ICache Events

ICache Events
Public Events
Collapse All

The events of the ICache class are listed here.

Public Events
Name | Description
CanRelease | Called before an object is permanently removed from the cache
DirtyChanged | Called when the dirtyness of an object may have changed
ExistenceChanged | Called when the existence state of an object changes
ExtentInvalidated | Called when an extent is invalidated
LocatorAdded | Called when a new locator gets created
ValueChanged | Called whenever the current value of an attribute or association end changes If the persistencestate is invalid, no event is sent. If it changes from current or modified to invalid, an event is sent.


ICache.CanRelease Event

ICache.CanRelease Event
ICache Interface Eco.Cache Namespace See Also
Collapse All

Called before an object is permanently removed from the cache

C#
event CanReleaseDelegate CanRelease;
Remarks

If for some reason, an object must remain in the cache, the receiver of the event can return False

See Also
ICache Interface
Eco.Cache Namespace


ICache.DirtyChanged Event

ICache.DirtyChanged Event
ICache Interface Eco.Cache Namespace See Also
Collapse All

Called when the dirtyness of an object may have changed

C#
event LocatorEventHandler DirtyChanged;
See Also
ICache Interface
Eco.Cache Namespace


ICache.ExistenceChanged Event

ICache.ExistenceChanged Event
ICache Interface Eco.Cache Namespace See Also
Collapse All

Called when the existence state of an object changes

C#
event LocatorEventHandler ExistenceChanged;
See Also
ICache Interface
Eco.Cache Namespace


ICache.ExtentInvalidated Event

ICache.ExtentInvalidated Event
ICache Interface Eco.Cache Namespace See Also
Collapse All

Called when an extent is invalidated

C#
event ExtentChangedEventHandler ExtentInvalidated;
See Also
ICache Interface
Eco.Cache Namespace


ICache.LocatorAdded Event

ICache.LocatorAdded Event
ICache Interface Eco.Cache Namespace See Also
Collapse All

Called when a new locator gets created

C#
event LocatorEventHandler LocatorAdded;
See Also
ICache Interface
Eco.Cache Namespace


ICache.ValueChanged Event

ICache.ValueChanged Event
ICache Interface Eco.Cache Namespace See Also
Collapse All

Called whenever the current value of an attribute or association end changes If the persistencestate is invalid, no event is sent. If it changes from current or modified to invalid, an event is sent.

C#
event ValueChangedDelegate ValueChanged;
See Also
ICache Interface
Eco.Cache Namespace


Eco.Cache.ExistenceState Enumeration

Eco.Cache.ExistenceState Enumeration

Whether or not the object exists.

C#
public enum ExistenceState {
  NotCreated,
  Existing,
  Deleted
}
File

CacheInterfaces.cs


Eco.Cache.PersistenceState Enumeration

Eco.Cache.PersistenceState Enumeration

How the current value in memory is related to the database.

C#
public enum PersistenceState {
  Current,
  Modified,
  Invalid,
  Transient
}
Members
Members | Description
Current | They are believed to be the same.
Modified | The value has been changed in memory, but not yet saved.
Invalid | The value needs to be fetched from Db.
Transient | The value in memory has no equivalence in Db.
File

CacheInterfaces.cs


Eco.Cache.CanReleaseDelegate Type

Eco.Cache.CanReleaseDelegate Type
C#
public delegate void CanReleaseDelegate(Locator locator, CanReleaseResult result);
Remarks

This is type Eco.Cache.CanReleaseDelegate.

File

CacheInterfaces.cs


Eco.Cache.ChangeDelegate Type

Eco.Cache.ChangeDelegate Type
C#
public delegate void ChangeDelegate(string message);
Remarks

This is type Eco.Cache.ChangeDelegate.

File

AbstractCache.cs


Eco.Cache.ExtentChangedEventHandler Type

Eco.Cache.ExtentChangedEventHandler Type
C#
public delegate void ExtentChangedEventHandler(IClass c);
Remarks

This is type Eco.Cache.ExtentChangedEventHandler.

File

CacheInterfaces.cs


Eco.Cache.LocatorEventHandler Type

Eco.Cache.LocatorEventHandler Type
C#
public delegate void LocatorEventHandler(object sender, LocatorEventArgs args);
Remarks

This is type Eco.Cache.LocatorEventHandler.

File

CacheInterfaces.cs


Eco.Cache.ValueChangedDelegate Type

Eco.Cache.ValueChangedDelegate Type
C#
public delegate void ValueChangedDelegate(Locator locator, IStructuralFeature feature);
Remarks

This is type Eco.Cache.ValueChangedDelegate.

File

CacheInterfaces.cs


Eco.Collections Namespace

Eco.Collections Namespace
Classes Interfaces
Collapse All

This is namespace Eco.Collections.

Classes
Name | Description
CollectionBase | This class is intended for the internal use of the Eco framework
HashBase | This class is intended for the internal use of the Eco framework
Top
Interfaces
Name | Description
IHashBaseElement | This interface is intended for the internal use of the Eco framework


CollectionBase Class

CollectionBase Class
Inheritance Hierarchy See Also
Collapse All

This class is intended for the internal use of the Eco framework

C#
public abstract class CollectionBase : IEnumerable, IList;
Inheritance Hierarchy
Eco.Collections.CollectionBase
File

CollectionBaseClasses.cs

See Also
Inheritance Hierarchy


CollectionBase Methods

CollectionBase Methods
Public Methods
Collapse All

The methods of the CollectionBase class are listed here.

Public Methods
Name | Description
Clear | This is Clear, a member of class CollectionBase.
Contains | This is Contains, a member of class CollectionBase.
CopyTo | This is CopyTo, a member of class CollectionBase.
GetEnumerator | This is GetEnumerator, a member of class CollectionBase.
IndexOf | This is IndexOf, a member of class CollectionBase.
Remove | This is Remove, a member of class CollectionBase.
RemoveAt | This is RemoveAt, a member of class CollectionBase.


CollectionBase.Clear Method

CollectionBase.Clear Method
CollectionBase Class Eco.Collections Namespace See Also
Collapse All
C#
public void Clear();
Remarks

This is Clear, a member of class CollectionBase.

See Also
CollectionBase Class
Eco.Collections Namespace


CollectionBase.Contains Method

CollectionBase.Contains Method
CollectionBase Class Eco.Collections Namespace See Also
Collapse All
C#
public bool Contains(
    object value
);
Remarks

This is Contains, a member of class CollectionBase.

See Also
CollectionBase Class
Eco.Collections Namespace


CollectionBase.CopyTo Method

CollectionBase.CopyTo Method
CollectionBase Class Eco.Collections Namespace See Also
Collapse All
C#
public void CopyTo(
    System.Array array,
    int index
);
Remarks

This is CopyTo, a member of class CollectionBase.

See Also
CollectionBase Class
Eco.Collections Namespace


CollectionBase.GetEnumerator Method

CollectionBase.GetEnumerator Method
CollectionBase Class Eco.Collections Namespace See Also
Collapse All
C#
public IEnumerator GetEnumerator();
Remarks

This is GetEnumerator, a member of class CollectionBase.

See Also
CollectionBase Class
Eco.Collections Namespace


CollectionBase.IndexOf Method

CollectionBase.IndexOf Method
CollectionBase Class Eco.Collections Namespace See Also
Collapse All
C#
public int IndexOf(
    object value
);
Remarks

This is IndexOf, a member of class CollectionBase.

See Also
CollectionBase Class
Eco.Collections Namespace


CollectionBase.Remove Method

CollectionBase.Remove Method
CollectionBase Class Eco.Collections Namespace See Also
Collapse All
C#
public void Remove(
    object value
);
Remarks

This is Remove, a member of class CollectionBase.

See Also
CollectionBase Class
Eco.Collections Namespace


CollectionBase.RemoveAt Method

CollectionBase.RemoveAt Method
CollectionBase Class Eco.Collections Namespace See Also
Collapse All
C#
public void RemoveAt(
    int index
);
Remarks

This is RemoveAt, a member of class CollectionBase.

See Also
CollectionBase Class
Eco.Collections Namespace


CollectionBase Properties

CollectionBase Properties
Public Properties Protected Properties
Collapse All

The properties of the CollectionBase class are listed here.

Public Properties
Name | Description
Count | This is Count, a member of class CollectionBase.
IsFixedSize | This is IsFixedSize, a member of class CollectionBase.
IsReadOnly | This is IsReadOnly, a member of class CollectionBase.
IsSynchronized | This is IsSynchronized, a member of class CollectionBase.
SyncRoot | This is SyncRoot, a member of class CollectionBase.
Top
Protected Properties
Name | Description
InternalList | This is InternalList, a member of class CollectionBase.


CollectionBase.Count Property

CollectionBase.Count Property
CollectionBase Class Eco.Collections Namespace See Also
Collapse All
C#
public int Count;
Remarks

This is Count, a member of class CollectionBase.

See Also
CollectionBase Class
Eco.Collections Namespace


CollectionBase.InternalList Property

CollectionBase.InternalList Property
CollectionBase Class Eco.Collections Namespace See Also
Collapse All
C#
protected ArrayList InternalList;
Remarks

This is InternalList, a member of class CollectionBase.

See Also
CollectionBase Class
Eco.Collections Namespace


CollectionBase.IsFixedSize Property

CollectionBase.IsFixedSize Property
CollectionBase Class Eco.Collections Namespace See Also
Collapse All
C#
public bool IsFixedSize;
Remarks

This is IsFixedSize, a member of class CollectionBase.

See Also
CollectionBase Class
Eco.Collections Namespace


CollectionBase.IsReadOnly Property

CollectionBase.IsReadOnly Property
CollectionBase Class Eco.Collections Namespace See Also
Collapse All
C#
public bool IsReadOnly;
Remarks

This is IsReadOnly, a member of class CollectionBase.

See Also
CollectionBase Class
Eco.Collections Namespace


CollectionBase.IsSynchronized Property

CollectionBase.IsSynchronized Property
CollectionBase Class Eco.Collections Namespace See Also
Collapse All
C#
public bool IsSynchronized;
Remarks

This is IsSynchronized, a member of class CollectionBase.

See Also
CollectionBase Class
Eco.Collections Namespace


CollectionBase.SyncRoot Property

CollectionBase.SyncRoot Property
CollectionBase Class Eco.Collections Namespace See Also
Collapse All
C#
public object SyncRoot;
Remarks

This is SyncRoot, a member of class CollectionBase.

See Also
CollectionBase Class
Eco.Collections Namespace


HashBase Class

HashBase Class
Inheritance Hierarchy See Also
Collapse All

This class is intended for the internal use of the Eco framework

C#
public abstract class HashBase : ICollection, IEnumerable;
Inheritance Hierarchy
Eco.Collections.HashBase
File

CollectionBaseClasses.cs

See Also
Inheritance Hierarchy


HashBase Methods

HashBase Methods
Protected Methods Public Methods
Collapse All

The methods of the HashBase class are listed here.

Protected Methods
Name | Description
GetByName | This is GetByName, a member of class HashBase.
InternalAdd |
Top
Public Methods
Name | Description
Clear | This is Clear, a member of class HashBase.
Contains |
CopyTo | This is CopyTo, a member of class HashBase.
GetEnumerator | This is GetEnumerator, a member of class HashBase.
Remove | This is Remove, a member of class HashBase.


HashBase.Clear Method

HashBase.Clear Method
HashBase Class Eco.Collections Namespace See Also
Collapse All
C#
public void Clear();
Remarks

This is Clear, a member of class HashBase.

See Also
HashBase Class
Eco.Collections Namespace


HashBase.Contains Method

HashBase.Contains Method
HashBase Class Eco.Collections Namespace See Also
Collapse All
C#
public bool Contains(
    IHashBaseElement value
);
Exceptions
Exceptions | Description
ArgumentNullException | Thrown if value is null
See Also
HashBase Class
Eco.Collections Namespace


HashBase.CopyTo Method

HashBase.CopyTo Method
HashBase Class Eco.Collections Namespace See Also
Collapse All
C#
public void CopyTo(
    System.Array array,
    int index
);
Remarks

This is CopyTo, a member of class HashBase.

See Also
HashBase Class
Eco.Collections Namespace


HashBase.GetByName Method

HashBase.GetByName Method
HashBase Class Eco.Collections Namespace See Also
Collapse All
C#
protected object GetByName(
    string Name
);
Remarks

This is GetByName, a member of class HashBase.

See Also
HashBase Class
Eco.Collections Namespace


HashBase.GetEnumerator Method

HashBase.GetEnumerator Method
HashBase Class Eco.Collections Namespace See Also
Collapse All
C#
public IEnumerator GetEnumerator();
Remarks

This is GetEnumerator, a member of class HashBase.

See Also
HashBase Class
Eco.Collections Namespace


HashBase.InternalAdd Method

HashBase.InternalAdd Method
HashBase Class Eco.Collections Namespace See Also
Collapse All
C#
protected void InternalAdd(
    IHashBaseElement value
);
Exceptions
Exceptions | Description
ArgumentNullException | Thrown if value is null
See Also
HashBase Class
Eco.Collections Namespace


HashBase.Remove Method

HashBase.Remove Method
HashBase Class Eco.Collections Namespace See Also
Collapse All
C#
public void Remove(
    object value
);
Remarks

This is Remove, a member of class HashBase.

See Also
HashBase Class
Eco.Collections Namespace


HashBase Properties

HashBase Properties
Public Properties Protected Properties
Collapse All

The properties of the HashBase class are listed here.

Public Properties
Name | Description
Count | This is Count, a member of class HashBase.
IsFixedSize | This is IsFixedSize, a member of class HashBase.
IsReadOnly | This is IsReadOnly, a member of class HashBase.
IsSynchronized | This is IsSynchronized, a member of class HashBase.
SyncRoot | This is SyncRoot, a member of class HashBase.
Top
Protected Properties
Name | Description
InternalList | This is InternalList, a member of class HashBase.


HashBase.Count Property

HashBase.Count Property
HashBase Class Eco.Collections Namespace See Also
Collapse All
C#
public int Count;
Remarks

This is Count, a member of class HashBase.

See Also
HashBase Class
Eco.Collections Namespace


HashBase.InternalList Property

HashBase.InternalList Property
HashBase Class Eco.Collections Namespace See Also
Collapse All
C#
protected Hashtable InternalList;
Remarks

This is InternalList, a member of class HashBase.

See Also
HashBase Class
Eco.Collections Namespace


HashBase.IsFixedSize Property

HashBase.IsFixedSize Property
HashBase Class Eco.Collections Namespace See Also
Collapse All
C#
public bool IsFixedSize;
Remarks

This is IsFixedSize, a member of class HashBase.

See Also
HashBase Class
Eco.Collections Namespace


HashBase.IsReadOnly Property

HashBase.IsReadOnly Property
HashBase Class Eco.Collections Namespace See Also
Collapse All
C#
public bool IsReadOnly;
Remarks

This is IsReadOnly, a member of class HashBase.

See Also
HashBase Class
Eco.Collections Namespace


HashBase.IsSynchronized Property

HashBase.IsSynchronized Property
HashBase Class Eco.Collections Namespace See Also
Collapse All
C#
public bool IsSynchronized;
Remarks

This is IsSynchronized, a member of class HashBase.

See Also
HashBase Class
Eco.Collections Namespace


HashBase.SyncRoot Property

HashBase.SyncRoot Property
HashBase Class Eco.Collections Namespace See Also
Collapse All
C#
public object SyncRoot;
Remarks

This is SyncRoot, a member of class HashBase.

See Also
HashBase Class
Eco.Collections Namespace


IHashBaseElement Interface

IHashBaseElement Interface
Inheritance Hierarchy See Also
Collapse All

This interface is intended for the internal use of the Eco framework

C#
public interface IHashBaseElement;
Inheritance Hierarchy
Eco.Collections.IHashBaseElement
File

CollectionBaseClasses.cs

See Also
Inheritance Hierarchy


IHashBaseElement Methods

IHashBaseElement Methods
Public Methods
Collapse All

The methods of the IHashBaseElement class are listed here.

Public Methods
Name | Description
GetHashKey | This is GetHashKey, a member of class IHashBaseElement.


IHashBaseElement.GetHashKey Method

IHashBaseElement.GetHashKey Method
IHashBaseElement Interface Eco.Collections Namespace See Also
Collapse All
C#
object GetHashKey();
Remarks

This is GetHashKey, a member of class IHashBaseElement.

See Also
IHashBaseElement Interface
Eco.Collections Namespace


Eco.DataRepresentation Namespace

Eco.DataRepresentation Namespace
Classes Enumerations
Collapse All

This is namespace Eco.DataRepresentation.

Classes
Name | Description
AssociationEnd | This is class Eco.DataRepresentation.AssociationEnd.
Datablock | Holds the values of a set of objects for the purposes of transporting them.
DefaultId | This is class Eco.DataRepresentation.DefaultId.
IdTranslationList | This is class Eco.DataRepresentation.IdTranslationList.
IndirectMultiAssociationEnd | Holds the value of an association end with multiplicty * if the association has an association class. Hold both the ids of the link objects and of the objects at the opposite end.
IndirectSingleAssociationEnd | Holds the value of an association end with multiplicty 1 or 0..1 if the association has an association class. Hold both the id of the link object and of the object at the opposite end.
InternalObjectId | This is class Eco.DataRepresentation.InternalObjectId.
MemberNotAssignedException | This is class Eco.DataRepresentation.MemberNotAssignedException.
MultiAssociationEnd | Holds the value of an association end with multiplicty *.
ObjectContents | Holds the values of an object.
ObjectId | The id of an object for the purposes of communicating with the persistence mechanism.
ObjectIdCollection | This is class Eco.DataRepresentation.ObjectIdCollection.
ObjectIdList | A list of object ids
SingleAssociationEnd | Holds the value of an association end with multiplicty 1 or 0..1. May also hold an order number if the opposite end is ordered.
TimestampedDefaultId | This is class Eco.DataRepresentation.TimestampedDefaultId.
Top
Enumerations
Name | Description
ExistenceState | This is record Eco.DataRepresentation.ExistenceState.


AssociationEnd Class

AssociationEnd Class
Inheritance Hierarchy See Also
Collapse All
C#
public abstract class AssociationEnd;
Remarks

This is class Eco.DataRepresentation.AssociationEnd.

Inheritance Hierarchy
Eco.DataRepresentation.AssociationEnd
    Eco.DataRepresentation.IndirectMultiAssociationEnd
    Eco.DataRepresentation.IndirectSingleAssociationEnd
    Eco.DataRepresentation.MultiAssociationEnd
    Eco.DataRepresentation.SingleAssociationEnd
File

Datablock.cs

See Also
Inheritance Hierarchy


AssociationEnd Methods

AssociationEnd Methods
Public Methods
Collapse All

The methods of the AssociationEnd class are listed here.

Public Methods
Name | Description
AddAllIds | This is AddAllIds, a member of class AssociationEnd.
ApplyTranslationList | This is ApplyTranslationList, a member of class AssociationEnd.


AssociationEnd.AddAllIds Method

AssociationEnd.AddAllIds Method
AssociationEnd Class Eco.DataRepresentation Namespace See Also
Collapse All
C#
public abstract void AddAllIds(
    ObjectIdList idList
);
Remarks

This is AddAllIds, a member of class AssociationEnd.

See Also
AssociationEnd Class
Eco.DataRepresentation Namespace


AssociationEnd.ApplyTranslationList Method

AssociationEnd.ApplyTranslationList Method
AssociationEnd Class Eco.DataRepresentation Namespace See Also
Collapse All
C#
public abstract void ApplyTranslationList(
    IdTranslationList translationList
);
Remarks

This is ApplyTranslationList, a member of class AssociationEnd.

See Also
AssociationEnd Class
Eco.DataRepresentation Namespace


Datablock Class

Datablock Class
Inheritance Hierarchy See Also
Collapse All

Holds the values of a set of objects for the purposes of transporting them.

C#
public sealed class Datablock : IEnumerable;
Inheritance Hierarchy
Eco.DataRepresentation.Datablock
File

Datablock.cs

See Also
Inheritance Hierarchy


Datablock Methods

Datablock Methods
Public Methods
Collapse All

The methods of the Datablock class are listed here.

Public Methods
Name | Description
ApplyTranslationList | public void AllObjectIdsInLinks(ObjectIdList resultList) { foreach (ObjectId id in EnsuredHashTable.Keys) { ObjectContents oc = GetObjectContents(id); for (int i = oc.MemberCount; i-- >0; ) { if (oc.IsMemberAssigned(i)) { AssociationEnd associationEnd = oc.GetMember(i) as AssociationEnd; if (associationEnd != null) associationEnd.AddAllIds(resultList); } } } }
GetEnsuredObjectContents | This is GetEnsuredObjectContents, a member of class Datablock.
GetObjectContents | This is GetObjectContents, a member of class Datablock.
RemoveDeletedObjects | This is RemoveDeletedObjects, a member of class Datablock.
Strip | This is Strip, a member of class Datablock.


Datablock.ApplyTranslationList Method

Datablock.ApplyTranslationList Method
Datablock Class Eco.DataRepresentation Namespace See Also
Collapse All
C#
public void ApplyTranslationList(
    IdTranslationList translationList
);
Remarks

public void AllObjectIdsInLinks(ObjectIdList resultList) { foreach (ObjectId id in EnsuredHashTable.Keys) { ObjectContents oc = GetObjectContents(id); for (int i = oc.MemberCount; i-- >0; ) { if (oc.IsMemberAssigned(i)) { AssociationEnd associationEnd = oc.GetMember(i) as AssociationEnd; if (associationEnd != null) associationEnd.AddAllIds(resultList); } }

} }

Exceptions
Exceptions | Description
ArgumentNullException | Thrown if translationList is null.
See Also
Datablock Class
Eco.DataRepresentation Namespace


Datablock.GetEnsuredObjectContents Method

Datablock.GetEnsuredObjectContents Method
Datablock Class Eco.DataRepresentation Namespace See Also
Collapse All
C#
public ObjectContents GetEnsuredObjectContents(
    ObjectId objectId
);
Remarks

This is GetEnsuredObjectContents, a member of class Datablock.

See Also
Datablock Class
Eco.DataRepresentation Namespace


Datablock.GetObjectContents Method

Datablock.GetObjectContents Method
Datablock Class Eco.DataRepresentation Namespace See Also
Collapse All
C#
public ObjectContents GetObjectContents(
    ObjectId objectId
);
Remarks

This is GetObjectContents, a member of class Datablock.

See Also
Datablock Class
Eco.DataRepresentation Namespace


Datablock.RemoveDeletedObjects Method

Datablock.RemoveDeletedObjects Method
Datablock Class Eco.DataRepresentation Namespace See Also
Collapse All
C#
public void RemoveDeletedObjects();
Remarks

This is RemoveDeletedObjects, a member of class Datablock.

See Also
Datablock Class
Eco.DataRepresentation Namespace


Datablock.Strip Method

Datablock.Strip Method
Datablock Class Eco.DataRepresentation Namespace See Also
Collapse All
C#
public void Strip();
Remarks

This is Strip, a member of class Datablock.

See Also
Datablock Class
Eco.DataRepresentation Namespace


Datablock Properties

Datablock Properties
Public Properties
Collapse All

The properties of the Datablock class are listed here.

Public Properties
Name | Description
Count | This is Count, a member of class Datablock.


Datablock.Count Property

Datablock.Count Property
Datablock Class Eco.DataRepresentation Namespace See Also
Collapse All
C#
public int Count;
Remarks

This is Count, a member of class Datablock.

See Also
Datablock Class
Eco.DataRepresentation Namespace


DefaultId Class

DefaultId Class
Inheritance Hierarchy See Also
Collapse All
C#
public class DefaultId : ObjectId;
Remarks

This is class Eco.DataRepresentation.DefaultId.

Inheritance Hierarchy
Eco.DataRepresentation.ObjectId
    Eco.DataRepresentation.DefaultId
        Eco.DataRepresentation.TimestampedDefaultId
File

ObjectIds.cs

See Also
Inheritance Hierarchy


DefaultId.DefaultId Constructor

DefaultId.DefaultId Constructor
DefaultId Class Eco.DataRepresentation Namespace See Also
Collapse All
C#
public DefaultId(
    object key,
    int classId
);
Remarks

This is DefaultId, a member of class DefaultId.

See Also
DefaultId Class
Eco.DataRepresentation Namespace


DefaultId Methods

DefaultId Methods
Public Methods
Collapse All

The methods of the DefaultId class are listed here.

Public Methods
Name | Description
CloneWithClassId | This is CloneWithClassId, a member of class DefaultId.
CloneWithTimestamp | This is CloneWithTimestamp, a member of class DefaultId.
Equals | This is Equals, a member of class DefaultId.
GetHashCode | This is GetHashCode, a member of class DefaultId.


DefaultId.CloneWithClassId Method

DefaultId.CloneWithClassId Method
DefaultId Class Eco.DataRepresentation Namespace See Also
Collapse All
C#
public override ObjectId CloneWithClassId(
    int topSortedIndex
);
Remarks

This is CloneWithClassId, a member of class DefaultId.

See Also
DefaultId Class
Eco.DataRepresentation Namespace


DefaultId.CloneWithTimestamp Method

DefaultId.CloneWithTimestamp Method
DefaultId Class Eco.DataRepresentation Namespace See Also
Collapse All
C#
public DefaultId CloneWithTimestamp(
    int timestamp
);
Remarks

This is CloneWithTimestamp, a member of class DefaultId.

See Also
DefaultId Class
Eco.DataRepresentation Namespace


DefaultId.Equals Method

DefaultId.Equals Method
DefaultId Class Eco.DataRepresentation Namespace See Also
Collapse All
C#
public override bool Equals(
    object obj
);
Remarks

This is Equals, a member of class DefaultId.

See Also
DefaultId Class
Eco.DataRepresentation Namespace


DefaultId.GetHashCode Method

DefaultId.GetHashCode Method
DefaultId Class Eco.DataRepresentation Namespace See Also
Collapse All
C#
public override int GetHashCode();
Remarks

This is GetHashCode, a member of class DefaultId.

See Also
DefaultId Class
Eco.DataRepresentation Namespace


DefaultId Properties

DefaultId Properties
Public Properties
Collapse All

The properties of the DefaultId class are listed here.

Public Properties
Name | Description
IsStorable | This is IsStorable, a member of class DefaultId.


DefaultId.IsStorable Property

DefaultId.IsStorable Property
DefaultId Class Eco.DataRepresentation Namespace See Also
Collapse All
C#
public override bool IsStorable;
Remarks

This is IsStorable, a member of class DefaultId.

See Also
DefaultId Class
Eco.DataRepresentation Namespace


IdTranslationList Class

IdTranslationList Class
Inheritance Hierarchy See Also
Collapse All
C#
public sealed class IdTranslationList;
Remarks

This is class Eco.DataRepresentation.IdTranslationList.

Inheritance Hierarchy
Eco.DataRepresentation.IdTranslationList
File

ObjectIds.cs

See Also
Inheritance Hierarchy


IdTranslationList Methods

IdTranslationList Methods
Public Methods
Collapse All

The methods of the IdTranslationList class are listed here.

Public Methods
Name | Description
AddTimestampTranslation | This is AddTimestampTranslation, a member of class IdTranslationList.
AddTranslation | This is AddTranslation, a member of class IdTranslationList.
TranslateTimestamp | This is TranslateTimestamp, a member of class IdTranslationList.
TranslateToNewId | This is TranslateToNewId, a member of class IdTranslationList.


IdTranslationList.AddTimestampTranslation Method

IdTranslationList.AddTimestampTranslation Method
IdTranslationList Class Eco.DataRepresentation Namespace See Also
Collapse All
C#
public void AddTimestampTranslation(
    ObjectId id,
    int newTimeStamp
);
Remarks

This is AddTimestampTranslation, a member of class IdTranslationList.

See Also
IdTranslationList Class
Eco.DataRepresentation Namespace


IdTranslationList.AddTranslation Method

IdTranslationList.AddTranslation Method
IdTranslationList Class Eco.DataRepresentation Namespace See Also
Collapse All
C#
public void AddTranslation(
    ObjectId oldId,
    ObjectId newId
);
Remarks

This is AddTranslation, a member of class IdTranslationList.

See Also
IdTranslationList Class
Eco.DataRepresentation Namespace


IdTranslationList.TranslateTimestamp Method

IdTranslationList.TranslateTimestamp Method
IdTranslationList Class Eco.DataRepresentation Namespace See Also
Collapse All
C#
public int TranslateTimestamp(
    ObjectId id
);
Remarks

This is TranslateTimestamp, a member of class IdTranslationList.

See Also
IdTranslationList Class
Eco.DataRepresentation Namespace


IdTranslationList.TranslateToNewId Method

IdTranslationList.TranslateToNewId Method
IdTranslationList Class Eco.DataRepresentation Namespace See Also
Collapse All
C#
public ObjectId TranslateToNewId(
    ObjectId oldId
);
Remarks

This is TranslateToNewId, a member of class IdTranslationList.

See Also
IdTranslationList Class
Eco.DataRepresentation Namespace


IdTranslationList Properties

IdTranslationList Properties
Public Properties
Collapse All

The properties of the IdTranslationList class are listed here.

Public Properties
Name | Description
Count | This is Count, a member of class IdTranslationList.
NewIds | This is NewIds, a member of class IdTranslationList.
OldIds | This is OldIds, a member of class IdTranslationList.


IdTranslationList.Count Property

IdTranslationList.Count Property
IdTranslationList Class Eco.DataRepresentation Namespace See Also
Collapse All
C#
public int Count;
Remarks

This is Count, a member of class IdTranslationList.

See Also
IdTranslationList Class
Eco.DataRepresentation Namespace


IdTranslationList.NewIds Property

IdTranslationList.NewIds Property
IdTranslationList Class Eco.DataRepresentation Namespace See Also
Collapse All
C#
public IEnumerable NewIds;
Remarks

This is NewIds, a member of class IdTranslationList.

See Also
IdTranslationList Class
Eco.DataRepresentation Namespace


IdTranslationList.OldIds Property

IdTranslationList.OldIds Property
IdTranslationList Class Eco.DataRepresentation Namespace See Also
Collapse All
C#
public IEnumerable OldIds;
Remarks

This is OldIds, a member of class IdTranslationList.

See Also
IdTranslationList Class
Eco.DataRepresentation Namespace


IndirectMultiAssociationEnd Class

IndirectMultiAssociationEnd Class
Inheritance Hierarchy See Also
Collapse All

Holds the value of an association end with multiplicty * if the association has an association class. Hold both the ids of the link objects and of the objects at the opposite end.

C#
public sealed class IndirectMultiAssociationEnd : AssociationEnd;
Inheritance Hierarchy
Eco.DataRepresentation.AssociationEnd
    Eco.DataRepresentation.IndirectMultiAssociationEnd
File

Datablock.cs

See Also
Inheritance Hierarchy


IndirectMultiAssociationEnd.IndirectMultiAssociationEnd Constructor

IndirectMultiAssociationEnd.IndirectMultiAssociationEnd Constructor
IndirectMultiAssociationEnd Class Eco.DataRepresentation Namespace See Also
Collapse All
C#
public IndirectMultiAssociationEnd(
    ObjectIdList list1,
    ObjectIdList list2
);
Exceptions
Exceptions | Description
ArgumentNullException | Thrown if list1 is null. Thrown if list2 is null.
See Also
IndirectMultiAssociationEnd Class
Eco.DataRepresentation Namespace


IndirectMultiAssociationEnd Methods

IndirectMultiAssociationEnd Methods
Public Methods
Collapse All

The methods of the IndirectMultiAssociationEnd class are listed here.

Public Methods
Name | Description
AddAllIds |
ApplyTranslationList | This is ApplyTranslationList, a member of class IndirectMultiAssociationEnd.


IndirectMultiAssociationEnd.AddAllIds Method

IndirectMultiAssociationEnd.AddAllIds Method
IndirectMultiAssociationEnd Class Eco.DataRepresentation Namespace See Also
Collapse All
C#
public override void AddAllIds(
    ObjectIdList idList
);
Exceptions
Exceptions | Description
ArgumentNullException | Thrown if idList is null.
See Also
IndirectMultiAssociationEnd Class
Eco.DataRepresentation Namespace


IndirectMultiAssociationEnd.ApplyTranslationList Method

IndirectMultiAssociationEnd.ApplyTranslationList Method
IndirectMultiAssociationEnd Class Eco.DataRepresentation Namespace See Also
Collapse All
C#
public override void ApplyTranslationList(
    IdTranslationList translationList
);
Remarks

This is ApplyTranslationList, a member of class IndirectMultiAssociationEnd.

See Also
IndirectMultiAssociationEnd Class
Eco.DataRepresentation Namespace


IndirectMultiAssociationEnd Properties

IndirectMultiAssociationEnd Properties
Public Properties
Collapse All

The properties of the IndirectMultiAssociationEnd class are listed here.

Public Properties
Name | Description
List1 | This is List1, a member of class IndirectMultiAssociationEnd.
List2 | This is List2, a member of class IndirectMultiAssociationEnd.


IndirectMultiAssociationEnd.List1 Property

IndirectMultiAssociationEnd.List1 Property
IndirectMultiAssociationEnd Class Eco.DataRepresentation Namespace See Also
Collapse All
C#
public ObjectIdList List1;
Remarks

This is List1, a member of class IndirectMultiAssociationEnd.

See Also
IndirectMultiAssociationEnd Class
Eco.DataRepresentation Namespace


IndirectMultiAssociationEnd.List2 Property

IndirectMultiAssociationEnd.List2 Property
IndirectMultiAssociationEnd Class Eco.DataRepresentation Namespace See Also
Collapse All
C#
public ObjectIdList List2;
Remarks

This is List2, a member of class IndirectMultiAssociationEnd.

See Also
IndirectMultiAssociationEnd Class
Eco.DataRepresentation Namespace


IndirectSingleAssociationEnd Class

IndirectSingleAssociationEnd Class
Inheritance Hierarchy See Also
Collapse All

Holds the value of an association end with multiplicty 1 or 0..1 if the association has an association class. Hold both the id of the link object and of the object at the opposite end.

C#
public sealed class IndirectSingleAssociationEnd : AssociationEnd;
Inheritance Hierarchy
Eco.DataRepresentation.AssociationEnd
    Eco.DataRepresentation.IndirectSingleAssociationEnd
File

Datablock.cs

See Also
Inheritance Hierarchy


IndirectSingleAssociationEnd.IndirectSingleAssociationEnd Constructor

IndirectSingleAssociationEnd.IndirectSingleAssociationEnd Constructor
IndirectSingleAssociationEnd Class Eco.DataRepresentation Namespace See Also
Collapse All
C#
public IndirectSingleAssociationEnd(
    ObjectId id1,
    ObjectId id2
);
Remarks

This is IndirectSingleAssociationEnd, a member of class IndirectSingleAssociationEnd.

See Also
IndirectSingleAssociationEnd Class
Eco.DataRepresentation Namespace


IndirectSingleAssociationEnd Methods

IndirectSingleAssociationEnd Methods
Public Methods
Collapse All

The methods of the IndirectSingleAssociationEnd class are listed here.

Public Methods
Name | Description
AddAllIds |
ApplyTranslationList |


IndirectSingleAssociationEnd.AddAllIds Method

IndirectSingleAssociationEnd.AddAllIds Method
IndirectSingleAssociationEnd Class Eco.DataRepresentation Namespace See Also
Collapse All
C#
public override void AddAllIds(
    ObjectIdList idList
);
Exceptions
Exceptions | Description
ArgumentNullException | Thrown if idList is null.
See Also
IndirectSingleAssociationEnd Class
Eco.DataRepresentation Namespace


IndirectSingleAssociationEnd.ApplyTranslationList Method

IndirectSingleAssociationEnd.ApplyTranslationList Method
IndirectSingleAssociationEnd Class Eco.DataRepresentation Namespace See Also
Collapse All
C#
public override void ApplyTranslationList(
    IdTranslationList translationList
);
Exceptions
Exceptions | Description
ArgumentNullException | Thrown if translationList is null.
See Also
IndirectSingleAssociationEnd Class
Eco.DataRepresentation Namespace


IndirectSingleAssociationEnd Properties

IndirectSingleAssociationEnd Properties
Public Properties
Collapse All

The properties of the IndirectSingleAssociationEnd class are listed here.

Public Properties
Name | Description
Id1 | This is Id1, a member of class IndirectSingleAssociationEnd.
Id2 | This is Id2, a member of class IndirectSingleAssociationEnd.


IndirectSingleAssociationEnd.Id1 Property

IndirectSingleAssociationEnd.Id1 Property
IndirectSingleAssociationEnd Class Eco.DataRepresentation Namespace See Also
Collapse All
C#
public ObjectId Id1;
Remarks

This is Id1, a member of class IndirectSingleAssociationEnd.

See Also
IndirectSingleAssociationEnd Class
Eco.DataRepresentation Namespace


IndirectSingleAssociationEnd.Id2 Property

IndirectSingleAssociationEnd.Id2 Property
IndirectSingleAssociationEnd Class Eco.DataRepresentation Namespace See Also
Collapse All
C#
public ObjectId Id2;
Remarks

This is Id2, a member of class IndirectSingleAssociationEnd.

See Also
IndirectSingleAssociationEnd Class
Eco.DataRepresentation Namespace


InternalObjectId Class

InternalObjectId Class
Inheritance Hierarchy See Also
Collapse All
C#
public sealed class InternalObjectId : ObjectId;
Remarks

This is class Eco.DataRepresentation.InternalObjectId.

Inheritance Hierarchy
Eco.DataRepresentation.ObjectId
    Eco.DataRepresentation.InternalObjectId
File

ObjectIds.cs

See Also
Inheritance Hierarchy


InternalObjectId.InternalObjectId Constructor

InternalObjectId.InternalObjectId Constructor
InternalObjectId Class Eco.DataRepresentation Namespace See Also
Collapse All
C#
public InternalObjectId(
    object key,
    int classId
);
Remarks

This is InternalObjectId, a member of class InternalObjectId.

See Also
InternalObjectId Class
Eco.DataRepresentation Namespace


InternalObjectId Methods

InternalObjectId Methods
Public Methods
Collapse All

The methods of the InternalObjectId class are listed here.

Public Methods
Name | Description
CloneWithClassId | This is CloneWithClassId, a member of class InternalObjectId.


InternalObjectId.CloneWithClassId Method

InternalObjectId.CloneWithClassId Method
InternalObjectId Class Eco.DataRepresentation Namespace See Also
Collapse All
C#
public override ObjectId CloneWithClassId(
    int topSortedIndex
);
Remarks

This is CloneWithClassId, a member of class InternalObjectId.

See Also
InternalObjectId Class
Eco.DataRepresentation Namespace


InternalObjectId Properties

InternalObjectId Properties
Public Properties
Collapse All

The properties of the InternalObjectId class are listed here.

Public Properties
Name | Description
IsStorable | This is IsStorable, a member of class InternalObjectId.


InternalObjectId.IsStorable Property

InternalObjectId.IsStorable Property
InternalObjectId Class Eco.DataRepresentation Namespace See Also
Collapse All
C#
public override bool IsStorable;
Remarks

This is IsStorable, a member of class InternalObjectId.

See Also
InternalObjectId Class
Eco.DataRepresentation Namespace


MemberNotAssignedException Class

MemberNotAssignedException Class
Inheritance Hierarchy See Also
Collapse All
C#
public class MemberNotAssignedException : ArgumentException;
Remarks

This is class Eco.DataRepresentation.MemberNotAssignedException.

Inheritance Hierarchy
Eco.DataRepresentation.MemberNotAssignedException
File

Datablock.cs

See Also
Inheritance Hierarchy


MemberNotAssignedException Constructor

MemberNotAssignedException Constructor

This is the overview for the MemberNotAssignedException constructor overload.

Overload List
Name | Description
MemberNotAssignedException.MemberNotAssignedException () | This is MemberNotAssignedException, a member of class MemberNotAssignedException.
MemberNotAssignedException.MemberNotAssignedException (SerializationInfo, StreamingContext) | This is MemberNotAssignedException, a member of class MemberNotAssignedException.
MemberNotAssignedException.MemberNotAssignedException (string) | This is MemberNotAssignedException, a member of class MemberNotAssignedException.
MemberNotAssignedException.MemberNotAssignedException (string, Exception) | This is MemberNotAssignedException, a member of class MemberNotAssignedException.


MemberNotAssignedException.MemberNotAssignedException Constructor ()

MemberNotAssignedException.MemberNotAssignedException Constructor ()
MemberNotAssignedException Class Eco.DataRepresentation Namespace See Also
Collapse All
C#
public MemberNotAssignedException();
Remarks

This is MemberNotAssignedException, a member of class MemberNotAssignedException.

See Also
MemberNotAssignedException Class
Eco.DataRepresentation Namespace


MemberNotAssignedException.MemberNotAssignedException Constructor (SerializationInfo, StreamingContext)

MemberNotAssignedException.MemberNotAssignedException Constructor (SerializationInfo, StreamingContext)
MemberNotAssignedException Class Eco.DataRepresentation Namespace See Also
Collapse All
C#
protected MemberNotAssignedException(
    SerializationInfo info,
    StreamingContext context
);
Remarks

This is MemberNotAssignedException, a member of class MemberNotAssignedException.

See Also
MemberNotAssignedException Class
Eco.DataRepresentation Namespace


MemberNotAssignedException.MemberNotAssignedException Constructor (string)

MemberNotAssignedException.MemberNotAssignedException Constructor (string)
MemberNotAssignedException Class Eco.DataRepresentation Namespace See Also
Collapse All
C#
public MemberNotAssignedException(
    string message
);
Remarks

This is MemberNotAssignedException, a member of class MemberNotAssignedException.

See Also
MemberNotAssignedException Class
Eco.DataRepresentation Namespace


MemberNotAssignedException.MemberNotAssignedException Constructor (string, Exception)

MemberNotAssignedException.MemberNotAssignedException Constructor (string, Exception)
MemberNotAssignedException Class Eco.DataRepresentation Namespace See Also
Collapse All
C#
public MemberNotAssignedException(
    string message,
    Exception inner
);
Remarks

This is MemberNotAssignedException, a member of class MemberNotAssignedException.

See Also
MemberNotAssignedException Class
Eco.DataRepresentation Namespace


MultiAssociationEnd Class

MultiAssociationEnd Class
Inheritance Hierarchy See Also
Collapse All

Holds the value of an association end with multiplicty *.

C#
public sealed class MultiAssociationEnd : AssociationEnd;
Inheritance Hierarchy
Eco.DataRepresentation.AssociationEnd
    Eco.DataRepresentation.MultiAssociationEnd
File

Datablock.cs

See Also
Inheritance Hierarchy


MultiAssociationEnd.MultiAssociationEnd Constructor

MultiAssociationEnd.MultiAssociationEnd Constructor
MultiAssociationEnd Class Eco.DataRepresentation Namespace See Also
Collapse All
C#
public MultiAssociationEnd(
    ObjectIdList list
);
Exceptions
Exceptions | Description
ArgumentNullException | Thrown if list is null.
See Also
MultiAssociationEnd Class
Eco.DataRepresentation Namespace


MultiAssociationEnd Methods

MultiAssociationEnd Methods
Public Methods
Collapse All

The methods of the MultiAssociationEnd class are listed here.

Public Methods
Name | Description
AddAllIds | This is AddAllIds, a member of class MultiAssociationEnd.
ApplyTranslationList | This is ApplyTranslationList, a member of class MultiAssociationEnd.


MultiAssociationEnd.AddAllIds Method

MultiAssociationEnd.AddAllIds Method
MultiAssociationEnd Class Eco.DataRepresentation Namespace See Also
Collapse All
C#
public override void AddAllIds(
    ObjectIdList idList
);
Remarks

This is AddAllIds, a member of class MultiAssociationEnd.

See Also
MultiAssociationEnd Class
Eco.DataRepresentation Namespace


MultiAssociationEnd.ApplyTranslationList Method

MultiAssociationEnd.ApplyTranslationList Method
MultiAssociationEnd Class Eco.DataRepresentation Namespace See Also
Collapse All
C#
public override void ApplyTranslationList(
    IdTranslationList translationList
);
Remarks

This is ApplyTranslationList, a member of class MultiAssociationEnd.

See Also
MultiAssociationEnd Class
Eco.DataRepresentation Namespace


MultiAssociationEnd Properties

MultiAssociationEnd Properties
Public Properties
Collapse All

The properties of the MultiAssociationEnd class are listed here.

Public Properties
Name | Description
List | This is List, a member of class MultiAssociationEnd.


MultiAssociationEnd.List Property

MultiAssociationEnd.List Property
MultiAssociationEnd Class Eco.DataRepresentation Namespace See Also
Collapse All
C#
public ObjectIdList List;
Remarks

This is List, a member of class MultiAssociationEnd.

See Also
MultiAssociationEnd Class
Eco.DataRepresentation Namespace


ObjectContents Class

ObjectContents Class
Inheritance Hierarchy See Also
Collapse All

Holds the values of an object.

C#
public sealed class ObjectContents;
Inheritance Hierarchy
Eco.DataRepresentation.ObjectContents
File

Datablock.cs

See Also
Inheritance Hierarchy


ObjectContents.ObjectContents Constructor

ObjectContents.ObjectContents Constructor
ObjectContents Class Eco.DataRepresentation Namespace See Also
Collapse All
C#
public ObjectContents(
    ObjectId objectId
);
Remarks

This is ObjectContents, a member of class ObjectContents.

See Also
ObjectContents Class
Eco.DataRepresentation Namespace


ObjectContents Methods

ObjectContents Methods
Public Methods
Collapse All

The methods of the ObjectContents class are listed here.

Public Methods
Name | Description
ApplyTranslationList | This is ApplyTranslationList, a member of class ObjectContents.
GetMember |
IsMemberAssigned | This is IsMemberAssigned, a member of class ObjectContents.
RemoveMember | This is RemoveMember, a member of class ObjectContents.
SetMember | This is SetMember, a member of class ObjectContents.


ObjectContents.ApplyTranslationList Method

ObjectContents.ApplyTranslationList Method
ObjectContents Class Eco.DataRepresentation Namespace See Also
Collapse All
C#
public void ApplyTranslationList(
    IdTranslationList translationList
);
Remarks

This is ApplyTranslationList, a member of class ObjectContents.

See Also
ObjectContents Class
Eco.DataRepresentation Namespace


ObjectContents.GetMember Method

ObjectContents.GetMember Method
ObjectContents Class Eco.DataRepresentation Namespace See Also
Collapse All
C#
public object GetMember(
    int index
);
Exceptions
Exceptions | Description
MemberNotAssignedException | Thrown if index does not refer to a position with a valid member.
See Also
ObjectContents Class
Eco.DataRepresentation Namespace


ObjectContents.IsMemberAssigned Method

ObjectContents.IsMemberAssigned Method
ObjectContents Class Eco.DataRepresentation Namespace See Also
Collapse All
C#
public bool IsMemberAssigned(
    int index
);
Remarks

This is IsMemberAssigned, a member of class ObjectContents.

See Also
ObjectContents Class
Eco.DataRepresentation Namespace


ObjectContents.RemoveMember Method

ObjectContents.RemoveMember Method
ObjectContents Class Eco.DataRepresentation Namespace See Also
Collapse All
C#
public void RemoveMember(
    int index
);
Remarks

This is RemoveMember, a member of class ObjectContents.

See Also
ObjectContents Class
Eco.DataRepresentation Namespace


ObjectContents.SetMember Method

ObjectContents.SetMember Method
ObjectContents Class Eco.DataRepresentation Namespace See Also
Collapse All
C#
public void SetMember(
    int index,
    object value
);
Remarks

This is SetMember, a member of class ObjectContents.

See Also
ObjectContents Class
Eco.DataRepresentation Namespace


ObjectContents Properties

ObjectContents Properties
Public Properties
Collapse All

The properties of the ObjectContents class are listed here.

Public Properties
Name | Description
ExistenceState | This is ExistenceState, a member of class ObjectContents.
IsReadOnly | This is IsReadOnly, a member of class ObjectContents.
MemberCount | This is MemberCount, a member of class ObjectContents.
ObjectId | This is ObjectId, a member of class ObjectContents.
Timestamp | This is Timestamp, a member of class ObjectContents.


ObjectContents.ExistenceState Property

ObjectContents.ExistenceState Property
ObjectContents Class Eco.DataRepresentation Namespace See Also
Collapse All
C#
public ExistenceState ExistenceState;
Remarks

This is ExistenceState, a member of class ObjectContents.

See Also
ObjectContents Class
Eco.DataRepresentation Namespace


ObjectContents.IsReadOnly Property

ObjectContents.IsReadOnly Property
ObjectContents Class Eco.DataRepresentation Namespace See Also
Collapse All
C#
public bool IsReadOnly;
Remarks

This is IsReadOnly, a member of class ObjectContents.

See Also
ObjectContents Class
Eco.DataRepresentation Namespace


ObjectContents.MemberCount Property

ObjectContents.MemberCount Property
ObjectContents Class Eco.DataRepresentation Namespace See Also
Collapse All
C#
public int MemberCount;
Remarks

This is MemberCount, a member of class ObjectContents.

See Also
ObjectContents Class
Eco.DataRepresentation Namespace


ObjectContents.ObjectId Property

ObjectContents.ObjectId Property
ObjectContents Class Eco.DataRepresentation Namespace See Also
Collapse All
C#
public ObjectId ObjectId;
Remarks

This is ObjectId, a member of class ObjectContents.

See Also
ObjectContents Class
Eco.DataRepresentation Namespace


ObjectContents.Timestamp Property

ObjectContents.Timestamp Property
ObjectContents Class Eco.DataRepresentation Namespace See Also
Collapse All
C#
public int Timestamp;
Remarks

This is Timestamp, a member of class ObjectContents.

See Also
ObjectContents Class
Eco.DataRepresentation Namespace


ObjectId Class

ObjectId Class
Inheritance Hierarchy See Also
Collapse All

The id of an object for the purposes of communicating with the persistence mechanism.

C#
public abstract class ObjectId;
Inheritance Hierarchy
Eco.DataRepresentation.ObjectId
    Eco.DataRepresentation.DefaultId
    Eco.DataRepresentation.InternalObjectId
File

ObjectIds.cs

See Also
Inheritance Hierarchy


ObjectId.ObjectId Constructor

ObjectId.ObjectId Constructor
ObjectId Class Eco.DataRepresentation Namespace See Also
Collapse All
C#
protected ObjectId(
    object key,
    int classId
);
Remarks

This is ObjectId, a member of class ObjectId.

See Also
ObjectId Class
Eco.DataRepresentation Namespace


ObjectId Methods

ObjectId Methods
Public Methods
Collapse All

The methods of the ObjectId class are listed here.

Public Methods
Name | Description
CloneWithClassId | This is CloneWithClassId, a member of class ObjectId.
Compare | This is Compare, a member of class ObjectId.
DeserializeId | This is DeserializeId, a member of class ObjectId.
Equals | This is Equals, a member of class ObjectId.
GetHashCode | This is GetHashCode, a member of class ObjectId.
SerializeId | This is SerializeId, a member of class ObjectId.


ObjectId.CloneWithClassId Method

ObjectId.CloneWithClassId Method
ObjectId Class Eco.DataRepresentation Namespace See Also
Collapse All
C#
public abstract ObjectId CloneWithClassId(
    int topSortedIndex
);
Remarks

This is CloneWithClassId, a member of class ObjectId.

See Also
ObjectId Class
Eco.DataRepresentation Namespace


ObjectId.Compare Method

ObjectId.Compare Method
ObjectId Class Eco.DataRepresentation Namespace See Also
Collapse All
C#
public int Compare(
    ObjectId id
);
Remarks

This is Compare, a member of class ObjectId.

See Also
ObjectId Class
Eco.DataRepresentation Namespace


ObjectId.DeserializeId Method

ObjectId.DeserializeId Method
ObjectId Class Eco.DataRepresentation Namespace See Also
Collapse All
C#
public static ObjectId DeserializeId(
    Stream source
);
Remarks

This is DeserializeId, a member of class ObjectId.

See Also
ObjectId Class
Eco.DataRepresentation Namespace


ObjectId.Equals Method

ObjectId.Equals Method
ObjectId Class Eco.DataRepresentation Namespace See Also
Collapse All
C#
public override bool Equals(
    object obj
);
Remarks

This is Equals, a member of class ObjectId.

See Also
ObjectId Class
Eco.DataRepresentation Namespace


ObjectId.GetHashCode Method

ObjectId.GetHashCode Method
ObjectId Class Eco.DataRepresentation Namespace See Also
Collapse All
C#
public override int GetHashCode();
Remarks

This is GetHashCode, a member of class ObjectId.

See Also
ObjectId Class
Eco.DataRepresentation Namespace


ObjectId.SerializeId Method

ObjectId.SerializeId Method
ObjectId Class Eco.DataRepresentation Namespace See Also
Collapse All
C#
public static void SerializeId(
    Stream target,
    ObjectId id
);
Remarks

This is SerializeId, a member of class ObjectId.

See Also
ObjectId Class
Eco.DataRepresentation Namespace


ObjectId Properties

ObjectId Properties
Public Properties
Collapse All

The properties of the ObjectId class are listed here.

Public Properties
Name | Description
ClassId | This is ClassId, a member of class ObjectId.
IsStorable | This is IsStorable, a member of class ObjectId.
Key | This is Key, a member of class ObjectId.
Timestamp | This is Timestamp, a member of class ObjectId.


ObjectId.ClassId Property

ObjectId.ClassId Property
ObjectId Class Eco.DataRepresentation Namespace See Also
Collapse All
C#
public int ClassId;
Remarks

This is ClassId, a member of class ObjectId.

See Also
ObjectId Class
Eco.DataRepresentation Namespace


ObjectId.IsStorable Property

ObjectId.IsStorable Property
ObjectId Class Eco.DataRepresentation Namespace See Also
Collapse All
C#
public abstract bool IsStorable;
Remarks

This is IsStorable, a member of class ObjectId.

See Also
ObjectId Class
Eco.DataRepresentation Namespace


ObjectId.Key Property

ObjectId.Key Property
ObjectId Class Eco.DataRepresentation Namespace See Also
Collapse All
C#
public object Key;
Remarks

This is Key, a member of class ObjectId.

See Also
ObjectId Class
Eco.DataRepresentation Namespace


ObjectId.Timestamp Property

ObjectId.Timestamp Property
ObjectId Class Eco.DataRepresentation Namespace See Also
Collapse All
C#
public virtual int Timestamp;
Remarks

This is Timestamp, a member of class ObjectId.

See Also
ObjectId Class
Eco.DataRepresentation Namespace


ObjectIdCollection Class

ObjectIdCollection Class
Inheritance Hierarchy See Also
Collapse All
C#
public sealed class ObjectIdCollection : IEnumerable;
Remarks

This is class Eco.DataRepresentation.ObjectIdCollection.

Inheritance Hierarchy
Eco.DataRepresentation.ObjectIdCollection
File

ObjectIds.cs

See Also
Inheritance Hierarchy


ObjectIdCollection Constructor

ObjectIdCollection Constructor

This is the overview for the ObjectIdCollection constructor overload.

Overload List
Name | Description
ObjectIdCollection.ObjectIdCollection () | This is ObjectIdCollection, a member of class ObjectIdCollection.
ObjectIdCollection.ObjectIdCollection (ObjectIdCollection) | This is ObjectIdCollection, a member of class ObjectIdCollection.
ObjectIdCollection.ObjectIdCollection (ObjectIdList) | This is ObjectIdCollection, a member of class ObjectIdCollection.


ObjectIdCollection.ObjectIdCollection Constructor ()

ObjectIdCollection.ObjectIdCollection Constructor ()
ObjectIdCollection Class Eco.DataRepresentation Namespace See Also
Collapse All
C#
public ObjectIdCollection();
Remarks

This is ObjectIdCollection, a member of class ObjectIdCollection.

See Also
ObjectIdCollection Class
Eco.DataRepresentation Namespace


ObjectIdCollection.ObjectIdCollection Constructor (ObjectIdCollection)

ObjectIdCollection.ObjectIdCollection Constructor (ObjectIdCollection)
ObjectIdCollection Class Eco.DataRepresentation Namespace See Also
Collapse All
C#
public ObjectIdCollection(
    ObjectIdCollection list
);
Remarks

This is ObjectIdCollection, a member of class ObjectIdCollection.

See Also
ObjectIdCollection Class
Eco.DataRepresentation Namespace


ObjectIdCollection.ObjectIdCollection Constructor (ObjectIdList)

ObjectIdCollection.ObjectIdCollection Constructor (ObjectIdList)
ObjectIdCollection Class Eco.DataRepresentation Namespace See Also
Collapse All
C#
public ObjectIdCollection(
    ObjectIdList list
);
Remarks

This is ObjectIdCollection, a member of class ObjectIdCollection.

See Also
ObjectIdCollection Class
Eco.DataRepresentation Namespace


ObjectIdCollection Methods

ObjectIdCollection Methods
Public Methods
Collapse All

The methods of the ObjectIdCollection class are listed here.

Public Methods
Name | Description
Add | This is the overview for the Add method overload.
Clone | This is Clone, a member of class ObjectIdCollection.
CommaSeparatedIdList | This is CommaSeparatedIdList, a member of class ObjectIdCollection.
Contains | This is Contains, a member of class ObjectIdCollection.
ExtractIds | This is ExtractIds, a member of class ObjectIdCollection.
GetEnumerator | This is GetEnumerator, a member of class ObjectIdCollection.
IdById | This is IdById, a member of class ObjectIdCollection.
Remove | This is Remove, a member of class ObjectIdCollection.


Add Method

Add Method

This is the overview for the Add method overload.

Overload List
Name | Description
ObjectIdCollection.Add (ObjectId) | This is Add, a member of class ObjectIdCollection.
ObjectIdCollection.Add (ObjectIdCollection) | This is Add, a member of class ObjectIdCollection.


ObjectIdCollection.Add Method (ObjectId)

ObjectIdCollection.Add Method (ObjectId)
ObjectIdCollection Class Eco.DataRepresentation Namespace See Also
Collapse All
C#
public void Add(
    ObjectId value
);
Remarks

This is Add, a member of class ObjectIdCollection.

See Also
ObjectIdCollection Class
Eco.DataRepresentation Namespace


ObjectIdCollection.Add Method (ObjectIdCollection)

ObjectIdCollection.Add Method (ObjectIdCollection)
ObjectIdCollection Class Eco.DataRepresentation Namespace See Also
Collapse All
C#
public void Add(
    ObjectIdCollection list
);
Remarks

This is Add, a member of class ObjectIdCollection.

See Also
ObjectIdCollection Class
Eco.DataRepresentation Namespace


ObjectIdCollection.Clone Method

ObjectIdCollection.Clone Method
ObjectIdCollection Class Eco.DataRepresentation Namespace See Also
Collapse All
C#
public ObjectIdCollection Clone();
Remarks

This is Clone, a member of class ObjectIdCollection.

See Also
ObjectIdCollection Class
Eco.DataRepresentation Namespace


ObjectIdCollection.CommaSeparatedIdList Method

ObjectIdCollection.CommaSeparatedIdList Method
ObjectIdCollection Class Eco.DataRepresentation Namespace See Also
Collapse All
C#
public string CommaSeparatedIdList();
Remarks

This is CommaSeparatedIdList, a member of class ObjectIdCollection.

See Also
ObjectIdCollection Class
Eco.DataRepresentation Namespace


ObjectIdCollection.Contains Method

ObjectIdCollection.Contains Method
ObjectIdCollection Class Eco.DataRepresentation Namespace See Also
Collapse All
C#
public bool Contains(
    ObjectId id
);
Remarks

This is Contains, a member of class ObjectIdCollection.

See Also
ObjectIdCollection Class
Eco.DataRepresentation Namespace


ObjectIdCollection.ExtractIds Method

ObjectIdCollection.ExtractIds Method
ObjectIdCollection Class Eco.DataRepresentation Namespace See Also
Collapse All
C#
public ObjectIdCollection ExtractIds(
    int numberOfIds
);
Remarks

This is ExtractIds, a member of class ObjectIdCollection.

See Also
ObjectIdCollection Class
Eco.DataRepresentation Namespace


ObjectIdCollection.GetEnumerator Method

ObjectIdCollection.GetEnumerator Method
ObjectIdCollection Class Eco.DataRepresentation Namespace See Also
Collapse All
C#
public IEnumerator GetEnumerator();
Remarks

This is GetEnumerator, a member of class ObjectIdCollection.

See Also
ObjectIdCollection Class
Eco.DataRepresentation Namespace


ObjectIdCollection.IdById Method

ObjectIdCollection.IdById Method
ObjectIdCollection Class Eco.DataRepresentation Namespace See Also
Collapse All
C#
public ObjectId IdById(
    ObjectId id
);
Remarks

This is IdById, a member of class ObjectIdCollection.

See Also
ObjectIdCollection Class
Eco.DataRepresentation Namespace


ObjectIdCollection.Remove Method

ObjectIdCollection.Remove Method
ObjectIdCollection Class Eco.DataRepresentation Namespace See Also
Collapse All
C#
public void Remove(
    ObjectId value
);
Remarks

This is Remove, a member of class ObjectIdCollection.

See Also
ObjectIdCollection Class
Eco.DataRepresentation Namespace


ObjectIdCollection Properties

ObjectIdCollection Properties
Public Properties
Collapse All

The properties of the ObjectIdCollection class are listed here.

Public Properties
Name | Description
Any | This is Any, a member of class ObjectIdCollection.
Count | This is Count, a member of class ObjectIdCollection.
IsEmpty | This is IsEmpty, a member of class ObjectIdCollection.


ObjectIdCollection.Any Property

ObjectIdCollection.Any Property
ObjectIdCollection Class Eco.DataRepresentation Namespace See Also
Collapse All
C#
public ObjectId Any;
Remarks

This is Any, a member of class ObjectIdCollection.

See Also
ObjectIdCollection Class
Eco.DataRepresentation Namespace


ObjectIdCollection.Count Property

ObjectIdCollection.Count Property
ObjectIdCollection Class Eco.DataRepresentation Namespace See Also
Collapse All
C#
public int Count;
Remarks

This is Count, a member of class ObjectIdCollection.

See Also
ObjectIdCollection Class
Eco.DataRepresentation Namespace


ObjectIdCollection.IsEmpty Property

ObjectIdCollection.IsEmpty Property
ObjectIdCollection Class Eco.DataRepresentation Namespace See Also
Collapse All
C#
public bool IsEmpty;
Remarks

This is IsEmpty, a member of class ObjectIdCollection.

See Also
ObjectIdCollection Class
Eco.DataRepresentation Namespace


ObjectIdList Class

ObjectIdList Class
Inheritance Hierarchy See Also
Collapse All

A list of object ids

C#
public sealed class ObjectIdList : List<ObjectId>;
Inheritance Hierarchy
Eco.DataRepresentation.ObjectIdList
File

ObjectIds.cs

See Also
Inheritance Hierarchy


ObjectIdList Constructor

ObjectIdList Constructor

This is the overview for the ObjectIdList constructor overload.

Overload List
Name | Description
ObjectIdList.ObjectIdList () | This is ObjectIdList, a member of class ObjectIdList.
ObjectIdList.ObjectIdList (IEnumerable) | This is ObjectIdList, a member of class ObjectIdList.
ObjectIdList.ObjectIdList (ObjectId) | This is ObjectIdList, a member of class ObjectIdList.


ObjectIdList.ObjectIdList Constructor ()

ObjectIdList.ObjectIdList Constructor ()
ObjectIdList Class Eco.DataRepresentation Namespace See Also
Collapse All
C#
public ObjectIdList();
Remarks

This is ObjectIdList, a member of class ObjectIdList.

See Also
ObjectIdList Class
Eco.DataRepresentation Namespace


ObjectIdList.ObjectIdList Constructor (IEnumerable)

ObjectIdList.ObjectIdList Constructor (IEnumerable)
ObjectIdList Class Eco.DataRepresentation Namespace See Also
Collapse All
C#
public ObjectIdList(
    IEnumerable e
);
Remarks

This is ObjectIdList, a member of class ObjectIdList.

See Also
ObjectIdList Class
Eco.DataRepresentation Namespace


ObjectIdList.ObjectIdList Constructor (ObjectId)

ObjectIdList.ObjectIdList Constructor (ObjectId)
ObjectIdList Class Eco.DataRepresentation Namespace See Also
Collapse All
C#
public ObjectIdList(
    ObjectId id
);
Remarks

This is ObjectIdList, a member of class ObjectIdList.

See Also
ObjectIdList Class
Eco.DataRepresentation Namespace


ObjectIdList Methods

ObjectIdList Methods
Public Methods
Collapse All

The methods of the ObjectIdList class are listed here.

Public Methods
Name | Description
AddList | This is AddList, a member of class ObjectIdList.
ApplyTranslationList |
Clone | This is Clone, a member of class ObjectIdList.
CommaSeparatedIdList | This is CommaSeparatedIdList, a member of class ObjectIdList.
GetAsArray | This is GetAsArray, a member of class ObjectIdList.
IdById | This is IdById, a member of class ObjectIdList.
Sort | Sorts the list of IDs on their key


ObjectIdList.AddList Method

ObjectIdList.AddList Method
ObjectIdList Class Eco.DataRepresentation Namespace See Also
Collapse All
C#
public void AddList(
    ObjectIdList list
);
Remarks

This is AddList, a member of class ObjectIdList.

See Also
ObjectIdList Class
Eco.DataRepresentation Namespace


ObjectIdList.ApplyTranslationList Method

ObjectIdList.ApplyTranslationList Method
ObjectIdList Class Eco.DataRepresentation Namespace See Also
Collapse All
C#
public void ApplyTranslationList(
    IdTranslationList translationList
);
Exceptions
Exceptions | Description
ArgumentNullException | Thrown if translationList is null.
See Also
ObjectIdList Class
Eco.DataRepresentation Namespace


ObjectIdList.Clone Method

ObjectIdList.Clone Method
ObjectIdList Class Eco.DataRepresentation Namespace See Also
Collapse All
C#
public ObjectIdList Clone();
Remarks

This is Clone, a member of class ObjectIdList.

See Also
ObjectIdList Class
Eco.DataRepresentation Namespace


ObjectIdList.CommaSeparatedIdList Method

ObjectIdList.CommaSeparatedIdList Method
ObjectIdList Class Eco.DataRepresentation Namespace See Also
Collapse All
C#
public string CommaSeparatedIdList();
Remarks

This is CommaSeparatedIdList, a member of class ObjectIdList.

See Also
ObjectIdList Class
Eco.DataRepresentation Namespace


ObjectIdList.GetAsArray Method

ObjectIdList.GetAsArray Method
ObjectIdList Class Eco.DataRepresentation Namespace See Also
Collapse All
C#
public ObjectId[] GetAsArray();
Remarks

This is GetAsArray, a member of class ObjectIdList.

See Also
ObjectIdList Class
Eco.DataRepresentation Namespace


ObjectIdList.IdById Method

ObjectIdList.IdById Method
ObjectIdList Class Eco.DataRepresentation Namespace See Also
Collapse All
C#
public ObjectId IdById(
    ObjectId id
);
Remarks

This is IdById, a member of class ObjectIdList.

See Also
ObjectIdList Class
Eco.DataRepresentation Namespace


ObjectIdList.Sort Method

ObjectIdList.Sort Method
ObjectIdList Class Eco.DataRepresentation Namespace See Also
Collapse All

Sorts the list of IDs on their key

C#
public new void Sort();
See Also
ObjectIdList Class
Eco.DataRepresentation Namespace


SingleAssociationEnd Class

SingleAssociationEnd Class
Inheritance Hierarchy See Also
Collapse All

Holds the value of an association end with multiplicty 1 or 0..1. May also hold an order number if the opposite end is ordered.

C#
public sealed class SingleAssociationEnd : AssociationEnd;
Inheritance Hierarchy
Eco.DataRepresentation.AssociationEnd
    Eco.DataRepresentation.SingleAssociationEnd
File

Datablock.cs

See Also
Inheritance Hierarchy


SingleAssociationEnd.SingleAssociationEnd Constructor

SingleAssociationEnd.SingleAssociationEnd Constructor
SingleAssociationEnd Class Eco.DataRepresentation Namespace See Also
Collapse All
C#
public SingleAssociationEnd(
    ObjectId id,
    int orderNo
);
Remarks

This is SingleAssociationEnd, a member of class SingleAssociationEnd.

See Also
SingleAssociationEnd Class
Eco.DataRepresentation Namespace


SingleAssociationEnd Methods

SingleAssociationEnd Methods
Public Methods
Collapse All

The methods of the SingleAssociationEnd class are listed here.

Public Methods
Name | Description
AddAllIds |
ApplyTranslationList |


SingleAssociationEnd.AddAllIds Method

SingleAssociationEnd.AddAllIds Method
SingleAssociationEnd Class Eco.DataRepresentation Namespace See Also
Collapse All
C#
public override void AddAllIds(
    ObjectIdList idList
);
Exceptions
Exceptions | Description
ArgumentNullException | Thrown if idList is null.
See Also
SingleAssociationEnd Class
Eco.DataRepresentation Namespace


SingleAssociationEnd.ApplyTranslationList Method

SingleAssociationEnd.ApplyTranslationList Method
SingleAssociationEnd Class Eco.DataRepresentation Namespace See Also
Collapse All
C#
public override void ApplyTranslationList(
    IdTranslationList translationList
);
Exceptions
Exceptions | Description
ArgumentNullException | Thrown if translationList is null.
See Also
SingleAssociationEnd Class
Eco.DataRepresentation Namespace


SingleAssociationEnd Properties

SingleAssociationEnd Properties
Public Properties
Collapse All

The properties of the SingleAssociationEnd class are listed here.

Public Properties
Name | Description
Id | This is Id, a member of class SingleAssociationEnd.
OrderNo | This is OrderNo, a member of class SingleAssociationEnd.


SingleAssociationEnd.Id Property

SingleAssociationEnd.Id Property
SingleAssociationEnd Class Eco.DataRepresentation Namespace See Also
Collapse All
C#
public ObjectId Id;
Remarks

This is Id, a member of class SingleAssociationEnd.

See Also
SingleAssociationEnd Class
Eco.DataRepresentation Namespace


SingleAssociationEnd.OrderNo Property

SingleAssociationEnd.OrderNo Property
SingleAssociationEnd Class Eco.DataRepresentation Namespace See Also
Collapse All
C#
public int OrderNo;
Remarks

This is OrderNo, a member of class SingleAssociationEnd.

See Also
SingleAssociationEnd Class
Eco.DataRepresentation Namespace


TimestampedDefaultId Class

TimestampedDefaultId Class
Inheritance Hierarchy See Also
Collapse All
C#
public sealed class TimestampedDefaultId : DefaultId;
Remarks

This is class Eco.DataRepresentation.TimestampedDefaultId.

Inheritance Hierarchy
Eco.DataRepresentation.ObjectId
    Eco.DataRepresentation.DefaultId
        Eco.DataRepresentation.TimestampedDefaultId
File

ObjectIds.cs

See Also
Inheritance Hierarchy


TimestampedDefaultId.TimestampedDefaultId Constructor

TimestampedDefaultId.TimestampedDefaultId Constructor
TimestampedDefaultId Class Eco.DataRepresentation Namespace See Also
Collapse All
C#
public TimestampedDefaultId(
    object key,
    int classId,
    int timestamp
);
Remarks

This is TimestampedDefaultId, a member of class TimestampedDefaultId.

See Also
TimestampedDefaultId Class
Eco.DataRepresentation Namespace


TimestampedDefaultId Methods

TimestampedDefaultId Methods
Public Methods
Collapse All

The methods of the TimestampedDefaultId class are listed here.

Public Methods
Name | Description
CloneWithClassId | This is CloneWithClassId, a member of class TimestampedDefaultId.


TimestampedDefaultId.CloneWithClassId Method

TimestampedDefaultId.CloneWithClassId Method
TimestampedDefaultId Class Eco.DataRepresentation Namespace See Also
Collapse All
C#
public override ObjectId CloneWithClassId(
    int topSortedIndex
);
Remarks

This is CloneWithClassId, a member of class TimestampedDefaultId.

See Also
TimestampedDefaultId Class
Eco.DataRepresentation Namespace


TimestampedDefaultId Properties

TimestampedDefaultId Properties
Public Properties
Collapse All

The properties of the TimestampedDefaultId class are listed here.

Public Properties
Name | Description
Timestamp | This is Timestamp, a member of class TimestampedDefaultId.


TimestampedDefaultId.Timestamp Property

TimestampedDefaultId.Timestamp Property
TimestampedDefaultId Class Eco.DataRepresentation Namespace See Also
Collapse All
C#
public override int Timestamp;
Remarks

This is Timestamp, a member of class TimestampedDefaultId.

See Also
TimestampedDefaultId Class
Eco.DataRepresentation Namespace


Eco.DataRepresentation.ExistenceState Enumeration

Eco.DataRepresentation.ExistenceState Enumeration
C#
public enum ExistenceState {
  New,
  Existing,
  Deleted
}
Remarks

This is record Eco.DataRepresentation.ExistenceState.

File

Datablock.cs


Eco.Diagnostics Namespace

Eco.Diagnostics Namespace
Classes
Collapse All

This is namespace Eco.Diagnostics.

Classes
Name | Description
TemplateDebuggerPanel | Summary description for EcoWinForm.


TemplateDebuggerPanel Class

TemplateDebuggerPanel Class
Inheritance Hierarchy See Also
Collapse All

Summary description for EcoWinForm.

C#
public class TemplateDebuggerPanel : System.Windows.Forms.Form, IEcoSpaceDebuggerPanel;
Inheritance Hierarchy
System.Windows.Forms.Form
    Eco.Diagnostics.TemplateDebuggerPanel
File

DebuggerTemplate.cs

See Also
Inheritance Hierarchy


TemplateDebuggerPanel.TemplateDebuggerPanel Constructor

TemplateDebuggerPanel.TemplateDebuggerPanel Constructor
TemplateDebuggerPanel Class Eco.Diagnostics Namespace See Also
Collapse All
C#
public TemplateDebuggerPanel();
Remarks

This is TemplateDebuggerPanel, a member of class TemplateDebuggerPanel.

See Also
TemplateDebuggerPanel Class
Eco.Diagnostics Namespace


TemplateDebuggerPanel Methods

TemplateDebuggerPanel Methods
Protected Methods
Collapse All

The methods of the TemplateDebuggerPanel class are listed here.

Protected Methods
Name | Description
Dispose | Clean up any resources being used.


TemplateDebuggerPanel.Dispose Method

TemplateDebuggerPanel.Dispose Method
TemplateDebuggerPanel Class Eco.Diagnostics Namespace See Also
Collapse All

Clean up any resources being used.

C#
protected override void Dispose(
    bool disposing
);
See Also
TemplateDebuggerPanel Class
Eco.Diagnostics Namespace


TemplateDebuggerPanel Properties

TemplateDebuggerPanel Properties
Public Properties
Collapse All

The properties of the TemplateDebuggerPanel class are listed here.

Public Properties
Name | Description
DirtyListService | This is DirtyListService, a member of class TemplateDebuggerPanel.
EcoSpace | This is EcoSpace, a member of class TemplateDebuggerPanel.
ExtentService | This is ExtentService, a member of class TemplateDebuggerPanel.
ObjectFactoryService | This is ObjectFactoryService, a member of class TemplateDebuggerPanel.
OclService | This is OclService, a member of class TemplateDebuggerPanel.
PersistenceService | This is PersistenceService, a member of class TemplateDebuggerPanel.
TypeSystemService | This is TypeSystemService, a member of class TemplateDebuggerPanel.
UndoService | This is UndoService, a member of class TemplateDebuggerPanel.
VariableFactoryService | This is VariableFactoryService, a member of class TemplateDebuggerPanel.


TemplateDebuggerPanel.DirtyListService Property

TemplateDebuggerPanel.DirtyListService Property
TemplateDebuggerPanel Class Eco.Diagnostics Namespace See Also
Collapse All
C#
public IDirtyListService DirtyListService;
Remarks

This is DirtyListService, a member of class TemplateDebuggerPanel.

See Also
TemplateDebuggerPanel Class
Eco.Diagnostics Namespace


TemplateDebuggerPanel.EcoSpace Property

TemplateDebuggerPanel.EcoSpace Property
TemplateDebuggerPanel Class Eco.Diagnostics Namespace See Also
Collapse All
C#
public Eco.Handles.EcoSpace EcoSpace;
Remarks

This is EcoSpace, a member of class TemplateDebuggerPanel.

See Also
TemplateDebuggerPanel Class
Eco.Diagnostics Namespace


TemplateDebuggerPanel.ExtentService Property

TemplateDebuggerPanel.ExtentService Property
TemplateDebuggerPanel Class Eco.Diagnostics Namespace See Also
Collapse All
C#
public IExtentService ExtentService;
Remarks

This is ExtentService, a member of class TemplateDebuggerPanel.

See Also
TemplateDebuggerPanel Class
Eco.Diagnostics Namespace


TemplateDebuggerPanel.ObjectFactoryService Property

TemplateDebuggerPanel.ObjectFactoryService Property
TemplateDebuggerPanel Class Eco.Diagnostics Namespace See Also
Collapse All
C#
public IObjectFactoryService ObjectFactoryService;
Remarks

This is ObjectFactoryService, a member of class TemplateDebuggerPanel.

See Also
TemplateDebuggerPanel Class
Eco.Diagnostics Namespace


TemplateDebuggerPanel.OclService Property

TemplateDebuggerPanel.OclService Property
TemplateDebuggerPanel Class Eco.Diagnostics Namespace See Also
Collapse All
C#
public IOclService OclService;
Remarks

This is OclService, a member of class TemplateDebuggerPanel.

See Also
TemplateDebuggerPanel Class
Eco.Diagnostics Namespace


TemplateDebuggerPanel.PersistenceService Property

TemplateDebuggerPanel.PersistenceService Property
TemplateDebuggerPanel Class Eco.Diagnostics Namespace See Also
Collapse All
C#
public IPersistenceService PersistenceService;
Remarks

This is PersistenceService, a member of class TemplateDebuggerPanel.

See Also
TemplateDebuggerPanel Class
Eco.Diagnostics Namespace


TemplateDebuggerPanel.TypeSystemService Property

TemplateDebuggerPanel.TypeSystemService Property
TemplateDebuggerPanel Class Eco.Diagnostics Namespace See Also
Collapse All
C#
public ITypeSystemService TypeSystemService;
Remarks

This is TypeSystemService, a member of class TemplateDebuggerPanel.

See Also
TemplateDebuggerPanel Class
Eco.Diagnostics Namespace


TemplateDebuggerPanel.UndoService Property

TemplateDebuggerPanel.UndoService Property
TemplateDebuggerPanel Class Eco.Diagnostics Namespace See Also
Collapse All
C#
public IUndoService UndoService;
Remarks

This is UndoService, a member of class TemplateDebuggerPanel.

See Also
TemplateDebuggerPanel Class
Eco.Diagnostics Namespace


TemplateDebuggerPanel.VariableFactoryService Property

TemplateDebuggerPanel.VariableFactoryService Property
TemplateDebuggerPanel Class Eco.Diagnostics Namespace See Also
Collapse All
C#
public IVariableFactoryService VariableFactoryService;
Remarks

This is VariableFactoryService, a member of class TemplateDebuggerPanel.

See Also
TemplateDebuggerPanel Class
Eco.Diagnostics Namespace


Eco.Exceptions Namespace

Eco.Exceptions Namespace
Classes
Collapse All

This is namespace Eco.Exceptions.

Classes
Name | Description
BadLockExpressionException | This is class Eco.Exceptions.BadLockExpressionException.
EcoException | This is class Eco.Exceptions.EcoException.
EcoInternalErrorException | This is class Eco.Exceptions.EcoInternalErrorException.
EcoOclErrorException | This is class Eco.Exceptions.EcoOclErrorException.
InvalidMappingException | This is class Eco.Exceptions.InvalidMappingException.
UserAbortException | This is class Eco.Exceptions.UserAbortException.


BadLockExpressionException Class

BadLockExpressionException Class
Inheritance Hierarchy See Also
Collapse All
C#
public class BadLockExpressionException : EcoException;
Remarks

This is class Eco.Exceptions.BadLockExpressionException.

Inheritance Hierarchy
Eco.Exceptions.EcoException
    Eco.Exceptions.BadLockExpressionException
File

Exceptions.cs

See Also
Inheritance Hierarchy


BadLockExpressionException Constructor

BadLockExpressionException Constructor

This is the overview for the BadLockExpressionException constructor overload.

Overload List
Name | Description
BadLockExpressionException.BadLockExpressionException () | This is BadLockExpressionException, a member of class BadLockExpressionException.
BadLockExpressionException.BadLockExpressionException (SerializationInfo, StreamingContext) | This is BadLockExpressionException, a member of class BadLockExpressionException.
BadLockExpressionException.BadLockExpressionException (string) | This is BadLockExpressionException, a member of class BadLockExpressionException.
BadLockExpressionException.BadLockExpressionException (string, Exception) | This is BadLockExpressionException, a member of class BadLockExpressionException.


BadLockExpressionException.BadLockExpressionException Constructor ()

BadLockExpressionException.BadLockExpressionException Constructor ()
BadLockExpressionException Class Eco.Exceptions Namespace See Also
Collapse All
C#
public BadLockExpressionException();
Remarks

This is BadLockExpressionException, a member of class BadLockExpressionException.

See Also
BadLockExpressionException Class
Eco.Exceptions Namespace


BadLockExpressionException.BadLockExpressionException Constructor (SerializationInfo, StreamingContext)

BadLockExpressionException.BadLockExpressionException Constructor (SerializationInfo, StreamingContext)
BadLockExpressionException Class Eco.Exceptions Namespace See Also
Collapse All
C#
protected BadLockExpressionException(
    SerializationInfo info,
    StreamingContext context
);
Remarks

This is BadLockExpressionException, a member of class BadLockExpressionException.

See Also
BadLockExpressionException Class
Eco.Exceptions Namespace


BadLockExpressionException.BadLockExpressionException Constructor (string)

BadLockExpressionException.BadLockExpressionException Constructor (string)
BadLockExpressionException Class Eco.Exceptions Namespace See Also
Collapse All
C#
public BadLockExpressionException(
    string message
);
Remarks

This is BadLockExpressionException, a member of class BadLockExpressionException.

See Also
BadLockExpressionException Class
Eco.Exceptions Namespace


BadLockExpressionException.BadLockExpressionException Constructor (string, Exception)

BadLockExpressionException.BadLockExpressionException Constructor (string, Exception)
BadLockExpressionException Class Eco.Exceptions Namespace See Also
Collapse All
C#
public BadLockExpressionException(
    string message,
    Exception inner
);
Remarks

This is BadLockExpressionException, a member of class BadLockExpressionException.

See Also
BadLockExpressionException Class
Eco.Exceptions Namespace


EcoException Class

EcoException Class
Inheritance Hierarchy See Also
Collapse All
C#
public class EcoException : Exception;
Remarks

This is class Eco.Exceptions.EcoException.

Inheritance Hierarchy
Eco.Exceptions.EcoException
    Eco.Exceptions.BadLockExpressionException
    Eco.Exceptions.EcoInternalErrorException
    Eco.Exceptions.EcoOclErrorException
    Eco.Exceptions.InvalidMappingException
    Eco.Exceptions.UserAbortException
File

Exceptions.cs

See Also
Inheritance Hierarchy


EcoException Constructor

EcoException Constructor

This is the overview for the EcoException constructor overload.

Overload List
Name | Description
EcoException.EcoException () | This is EcoException, a member of class EcoException.
EcoException.EcoException (SerializationInfo, StreamingContext) | This is EcoException, a member of class EcoException.
EcoException.EcoException (string) | This is EcoException, a member of class EcoException.
EcoException.EcoException (string, Exception) | This is EcoException, a member of class EcoException.


EcoException.EcoException Constructor ()

EcoException.EcoException Constructor ()
EcoException Class Eco.Exceptions Namespace See Also
Collapse All
C#
public EcoException();
Remarks

This is EcoException, a member of class EcoException.

See Also
EcoException Class
Eco.Exceptions Namespace


EcoException.EcoException Constructor (SerializationInfo, StreamingContext)

EcoException.EcoException Constructor (SerializationInfo, StreamingContext)
EcoException Class Eco.Exceptions Namespace See Also
Collapse All
C#
protected EcoException(
    SerializationInfo info,
    StreamingContext context
);
Remarks

This is EcoException, a member of class EcoException.

See Also
EcoException Class
Eco.Exceptions Namespace


EcoException.EcoException Constructor (string)

EcoException.EcoException Constructor (string)
EcoException Class Eco.Exceptions Namespace See Also
Collapse All
C#
public EcoException(
    string message
);
Remarks

This is EcoException, a member of class EcoException.

See Also
EcoException Class
Eco.Exceptions Namespace


EcoException.EcoException Constructor (string, Exception)

EcoException.EcoException Constructor (string, Exception)
EcoException Class Eco.Exceptions Namespace See Also
Collapse All
C#
public EcoException(
    string message,
    Exception inner
);
Remarks

This is EcoException, a member of class EcoException.

See Also
EcoException Class
Eco.Exceptions Namespace


EcoInternalErrorException Class

EcoInternalErrorException Class
Inheritance Hierarchy See Also
Collapse All
C#
public class EcoInternalErrorException : EcoException;
Remarks

This is class Eco.Exceptions.EcoInternalErrorException.

Inheritance Hierarchy
Eco.Exceptions.EcoException
    Eco.Exceptions.EcoInternalErrorException
File

Exceptions.cs

See Also
Inheritance Hierarchy


EcoInternalErrorException Constructor

EcoInternalErrorException Constructor

This is the overview for the EcoInternalErrorException constructor overload.

Overload List
Name | Description
EcoInternalErrorException.EcoInternalErrorException () | This is EcoInternalErrorException, a member of class EcoInternalErrorException.
EcoInternalErrorException.EcoInternalErrorException (SerializationInfo, StreamingContext) | This is EcoInternalErrorException, a member of class EcoInternalErrorException.
EcoInternalErrorException.EcoInternalErrorException (string) | This is EcoInternalErrorException, a member of class EcoInternalErrorException.
EcoInternalErrorException.EcoInternalErrorException (string, Exception) | This is EcoInternalErrorException, a member of class EcoInternalErrorException.


EcoInternalErrorException.EcoInternalErrorException Constructor ()

EcoInternalErrorException.EcoInternalErrorException Constructor ()
EcoInternalErrorException Class Eco.Exceptions Namespace See Also
Collapse All
C#
public EcoInternalErrorException();
Remarks

This is EcoInternalErrorException, a member of class EcoInternalErrorException.

See Also
EcoInternalErrorException Class
Eco.Exceptions Namespace


EcoInternalErrorException.EcoInternalErrorException Constructor (SerializationInfo, StreamingContext)

EcoInternalErrorException.EcoInternalErrorException Constructor (SerializationInfo, StreamingContext)
EcoInternalErrorException Class Eco.Exceptions Namespace See Also
Collapse All
C#
protected EcoInternalErrorException(
    SerializationInfo info,
    StreamingContext context
);
Remarks

This is EcoInternalErrorException, a member of class EcoInternalErrorException.

See Also
EcoInternalErrorException Class
Eco.Exceptions Namespace


EcoInternalErrorException.EcoInternalErrorException Constructor (string)

EcoInternalErrorException.EcoInternalErrorException Constructor (string)
EcoInternalErrorException Class Eco.Exceptions Namespace See Also
Collapse All
C#
public EcoInternalErrorException(
    string message
);
Remarks

This is EcoInternalErrorException, a member of class EcoInternalErrorException.

See Also
EcoInternalErrorException Class
Eco.Exceptions Namespace


EcoInternalErrorException.EcoInternalErrorException Constructor (string, Exception)

EcoInternalErrorException.EcoInternalErrorException Constructor (string, Exception)
EcoInternalErrorException Class Eco.Exceptions Namespace See Also
Collapse All
C#
public EcoInternalErrorException(
    string message,
    Exception inner
);
Remarks

This is EcoInternalErrorException, a member of class EcoInternalErrorException.

See Also
EcoInternalErrorException Class
Eco.Exceptions Namespace


EcoOclErrorException Class

EcoOclErrorException Class
Inheritance Hierarchy See Also
Collapse All
C#
public abstract class EcoOclErrorException : EcoException;
Remarks

This is class Eco.Exceptions.EcoOclErrorException.

Inheritance Hierarchy
Eco.Exceptions.EcoException
    Eco.Exceptions.EcoOclErrorException
File

OclError.cs

See Also
Inheritance Hierarchy


EcoOclErrorException Constructor

EcoOclErrorException Constructor

This is the overview for the EcoOclErrorException constructor overload.

Overload List
Name | Description
EcoOclErrorException.EcoOclErrorException () | This is EcoOclErrorException, a member of class EcoOclErrorException.
EcoOclErrorException.EcoOclErrorException (SerializationInfo, StreamingContext) | This is EcoOclErrorException, a member of class EcoOclErrorException.
EcoOclErrorException.EcoOclErrorException (string) | This is EcoOclErrorException, a member of class EcoOclErrorException.
EcoOclErrorException.EcoOclErrorException (string, Exception) | This is EcoOclErrorException, a member of class EcoOclErrorException.


EcoOclErrorException.EcoOclErrorException Constructor ()

EcoOclErrorException.EcoOclErrorException Constructor ()
EcoOclErrorException Class Eco.Exceptions Namespace See Also
Collapse All
C#
protected EcoOclErrorException();
Remarks

This is EcoOclErrorException, a member of class EcoOclErrorException.

See Also
EcoOclErrorException Class
Eco.Exceptions Namespace


EcoOclErrorException.EcoOclErrorException Constructor (SerializationInfo, StreamingContext)

EcoOclErrorException.EcoOclErrorException Constructor (SerializationInfo, StreamingContext)
EcoOclErrorException Class Eco.Exceptions Namespace See Also
Collapse All
C#
protected EcoOclErrorException(
    SerializationInfo info,
    StreamingContext context
);
Remarks

This is EcoOclErrorException, a member of class EcoOclErrorException.

See Also
EcoOclErrorException Class
Eco.Exceptions Namespace


EcoOclErrorException.EcoOclErrorException Constructor (string)

EcoOclErrorException.EcoOclErrorException Constructor (string)
EcoOclErrorException Class Eco.Exceptions Namespace See Also
Collapse All
C#
protected EcoOclErrorException(
    string message
);
Remarks

This is EcoOclErrorException, a member of class EcoOclErrorException.

See Also
EcoOclErrorException Class
Eco.Exceptions Namespace


EcoOclErrorException.EcoOclErrorException Constructor (string, Exception)

EcoOclErrorException.EcoOclErrorException Constructor (string, Exception)
EcoOclErrorException Class Eco.Exceptions Namespace See Also
Collapse All
C#
protected EcoOclErrorException(
    string message,
    Exception inner
);
Remarks

This is EcoOclErrorException, a member of class EcoOclErrorException.

See Also
EcoOclErrorException Class
Eco.Exceptions Namespace


EcoOclErrorException Properties

EcoOclErrorException Properties
Public Properties
Collapse All

The properties of the EcoOclErrorException class are listed here.

Public Properties
Name | Description
Expression | This is Expression, a member of class EcoOclErrorException.
InternalError | This is InternalError, a member of class EcoOclErrorException.
Position | protected EcoOclErrorException(string message): base(message)


EcoOclErrorException.Expression Property

EcoOclErrorException.Expression Property
EcoOclErrorException Class Eco.Exceptions Namespace See Also
Collapse All
C#
public abstract string Expression;
Remarks

This is Expression, a member of class EcoOclErrorException.

See Also
EcoOclErrorException Class
Eco.Exceptions Namespace


EcoOclErrorException.InternalError Property

EcoOclErrorException.InternalError Property
EcoOclErrorException Class Eco.Exceptions Namespace See Also
Collapse All
C#
public abstract bool InternalError;
Remarks

This is InternalError, a member of class EcoOclErrorException.

See Also
EcoOclErrorException Class
Eco.Exceptions Namespace


EcoOclErrorException.Position Property

EcoOclErrorException.Position Property
EcoOclErrorException Class Eco.Exceptions Namespace See Also
Collapse All
C#
public abstract int Position;
Remarks

protected EcoOclErrorException(string message): base(message)

See Also
EcoOclErrorException Class
Eco.Exceptions Namespace


InvalidMappingException Class

InvalidMappingException Class
Inheritance Hierarchy See Also
Collapse All
C#
public class InvalidMappingException : EcoException;
Remarks

This is class Eco.Exceptions.InvalidMappingException.

Inheritance Hierarchy
Eco.Exceptions.EcoException
    Eco.Exceptions.InvalidMappingException
File

Exceptions.cs

See Also
Inheritance Hierarchy


InvalidMappingException Constructor

InvalidMappingException Constructor

This is the overview for the InvalidMappingException constructor overload.

Overload List
Name | Description
InvalidMappingException.InvalidMappingException () | This is InvalidMappingException, a member of class InvalidMappingException.
InvalidMappingException.InvalidMappingException (SerializationInfo, StreamingContext) | This is InvalidMappingException, a member of class InvalidMappingException.
InvalidMappingException.InvalidMappingException (string) | This is InvalidMappingException, a member of class InvalidMappingException.
InvalidMappingException.InvalidMappingException (string, Exception) | This is InvalidMappingException, a member of class InvalidMappingException.


InvalidMappingException.InvalidMappingException Constructor ()

InvalidMappingException.InvalidMappingException Constructor ()
InvalidMappingException Class Eco.Exceptions Namespace See Also
Collapse All
C#
public InvalidMappingException();
Remarks

This is InvalidMappingException, a member of class InvalidMappingException.

See Also
InvalidMappingException Class
Eco.Exceptions Namespace


InvalidMappingException.InvalidMappingException Constructor (SerializationInfo, StreamingContext)

InvalidMappingException.InvalidMappingException Constructor (SerializationInfo, StreamingContext)
InvalidMappingException Class Eco.Exceptions Namespace See Also
Collapse All
C#
protected InvalidMappingException(
    SerializationInfo info,
    StreamingContext context
);
Remarks

This is InvalidMappingException, a member of class InvalidMappingException.

See Also
InvalidMappingException Class
Eco.Exceptions Namespace


InvalidMappingException.InvalidMappingException Constructor (string)

InvalidMappingException.InvalidMappingException Constructor (string)
InvalidMappingException Class Eco.Exceptions Namespace See Also
Collapse All
C#
public InvalidMappingException(
    string message
);
Remarks

This is InvalidMappingException, a member of class InvalidMappingException.

See Also
InvalidMappingException Class
Eco.Exceptions Namespace


InvalidMappingException.InvalidMappingException Constructor (string, Exception)

InvalidMappingException.InvalidMappingException Constructor (string, Exception)
InvalidMappingException Class Eco.Exceptions Namespace See Also
Collapse All
C#
public InvalidMappingException(
    string message,
    Exception inner
);
Remarks

This is InvalidMappingException, a member of class InvalidMappingException.

See Also
InvalidMappingException Class
Eco.Exceptions Namespace


UserAbortException Class

UserAbortException Class
Inheritance Hierarchy See Also
Collapse All
C#
public class UserAbortException : EcoException;
Remarks

This is class Eco.Exceptions.UserAbortException.

Inheritance Hierarchy
Eco.Exceptions.EcoException
    Eco.Exceptions.UserAbortException
File

Exceptions.cs

See Also
Inheritance Hierarchy


UserAbortException Constructor

UserAbortException Constructor

This is the overview for the UserAbortException constructor overload.

Overload List
Name | Description
UserAbortException.UserAbortException () | This is UserAbortException, a member of class UserAbortException.
UserAbortException.UserAbortException (SerializationInfo, StreamingContext) | This is UserAbortException, a member of class UserAbortException.
UserAbortException.UserAbortException (string) | This is UserAbortException, a member of class UserAbortException.
UserAbortException.UserAbortException (string, Exception) | This is UserAbortException, a member of class UserAbortException.


UserAbortException.UserAbortException Constructor ()

UserAbortException.UserAbortException Constructor ()
UserAbortException Class Eco.Exceptions Namespace See Also
Collapse All
C#
public UserAbortException();
Remarks

This is UserAbortException, a member of class UserAbortException.

See Also
UserAbortException Class
Eco.Exceptions Namespace


UserAbortException.UserAbortException Constructor (SerializationInfo, StreamingContext)

UserAbortException.UserAbortException Constructor (SerializationInfo, StreamingContext)
UserAbortException Class Eco.Exceptions Namespace See Also
Collapse All
C#
protected UserAbortException(
    SerializationInfo info,
    StreamingContext context
);
Remarks

This is UserAbortException, a member of class UserAbortException.

See Also
UserAbortException Class
Eco.Exceptions Namespace


UserAbortException.UserAbortException Constructor (string)

UserAbortException.UserAbortException Constructor (string)
UserAbortException Class Eco.Exceptions Namespace See Also
Collapse All
C#
public UserAbortException(
    string message
);
Remarks

This is UserAbortException, a member of class UserAbortException.

See Also
UserAbortException Class
Eco.Exceptions Namespace


UserAbortException.UserAbortException Constructor (string, Exception)

UserAbortException.UserAbortException Constructor (string, Exception)
UserAbortException Class Eco.Exceptions Namespace See Also
Collapse All
C#
public UserAbortException(
    string message,
    Exception inner
);
Remarks

This is UserAbortException, a member of class UserAbortException.

See Also
UserAbortException Class
Eco.Exceptions Namespace


Eco.Framework Namespace

Eco.Framework Namespace
Classes Enumerations Interfaces Types
Collapse All

This is namespace Eco.Framework.

Classes
Name | Description
DerivedMemberManager | This class is used in the internal implementation of an EcoSpace, and is not currently documented.
EcoServiceProvider | This is class Eco.Framework.EcoServiceProvider.
EcoSpacePart | The base class for various ECO service implementations.
EcoSpacePartList | Holds a collection of EcoSpacePart instances.
EcoSpacePartWithTypeSystem | Base class for various standard ECO services of the EcoSpace.
EcoSpaceSerializationConfig | Used to specify the way in which an EcoSpace is serialized.
LocatorCollectionEventArgs | This is class Eco.Framework.LocatorCollectionEventArgs.
MemberDeriveException | This is class Eco.Framework.MemberDeriveException.
Top
Enumerations
Name | Description
EcoSpacePartState | Indicates the state of an EcoSpacePart.
FetchStrategy | This is record Eco.Framework.FetchStrategy.
Top
Interfaces
Name | Description
IChangeHandler | This is class Eco.Framework.IChangeHandler.
IDerivedMemberManager | This interface is used in the internal implementation of an EcoSpace, and is not currently documented.
IFetchHandler | This is class Eco.Framework.IFetchHandler.
IObjectRepresentationProvider | This is class Eco.Framework.IObjectRepresentationProvider.
IPersistenceHandler | This is class Eco.Framework.IPersistenceHandler.
Top
Types
Name | Description
LocatorArrayEventHandler | This is type Eco.Framework.LocatorArrayEventHandler.
ValueChangedDelegate | This delegate is used in the internal implementation of an EcoSpace, and is not currently documented.


DerivedMemberManager Class

DerivedMemberManager Class
Inheritance Hierarchy See Also
Collapse All

This class is used in the internal implementation of an EcoSpace, and is not currently documented.

C#
public sealed class DerivedMemberManager : IDerivedMemberManager;
Inheritance Hierarchy
Eco.Framework.IDerivedMemberManager
    Eco.Framework.DerivedMemberManager
File

DerivedMembers.cs

See Also
Inheritance Hierarchy


DerivedMemberManager.DerivedMemberManager Constructor

DerivedMemberManager.DerivedMemberManager Constructor
DerivedMemberManager Class Eco.Framework Namespace See Also
Collapse All
C#
public DerivedMemberManager(
    IAutoSubscriptionService autoSubscriptionService
);
Remarks

This is DerivedMemberManager, a member of class DerivedMemberManager.

See Also
DerivedMemberManager Class
Eco.Framework Namespace


DerivedMemberManager Methods

DerivedMemberManager Methods
Public Methods
Collapse All

The methods of the DerivedMemberManager class are listed here.

Public Methods
Name | Description
GetIsDerived |
GetMemberValue |


DerivedMemberManager.GetIsDerived Method

DerivedMemberManager.GetIsDerived Method
DerivedMemberManager Class Eco.Framework Namespace See Also
Collapse All
C#
public bool GetIsDerived(
    IProperty prop
);
Exceptions
Exceptions | Description
ArgumentNullException | Thrown if prop is null.
See Also
DerivedMemberManager Class
Eco.Framework Namespace


DerivedMemberManager.GetMemberValue Method

DerivedMemberManager.GetMemberValue Method
DerivedMemberManager Class Eco.Framework Namespace See Also
Collapse All
C#
public object GetMemberValue(
    IProperty prop
);
Exceptions
Exceptions | Description
ArgumentNullException | Thrown if prop is null.
See Also
DerivedMemberManager Class
Eco.Framework Namespace


DerivedMemberManager Properties

DerivedMemberManager Properties
Public Properties
Collapse All

The properties of the DerivedMemberManager class are listed here.

Public Properties
Name | Description
AutoSubscriptionService | This is AutoSubscriptionService, a member of class DerivedMemberManager.


DerivedMemberManager.AutoSubscriptionService Property

DerivedMemberManager.AutoSubscriptionService Property
DerivedMemberManager Class Eco.Framework Namespace See Also
Collapse All
C#
public IAutoSubscriptionService AutoSubscriptionService;
Remarks

This is AutoSubscriptionService, a member of class DerivedMemberManager.

See Also
DerivedMemberManager Class
Eco.Framework Namespace


DerivedMemberManager Events

DerivedMemberManager Events
Public Events
Collapse All

The events of the DerivedMemberManager class are listed here.

Public Events
Name | Description
ValueChanged | This is ValueChanged, a member of class DerivedMemberManager.


DerivedMemberManager.ValueChanged Event

DerivedMemberManager.ValueChanged Event
DerivedMemberManager Class Eco.Framework Namespace See Also
Collapse All
C#
public event ValueChangedDelegate ValueChanged;
Remarks

This is ValueChanged, a member of class DerivedMemberManager.

See Also
DerivedMemberManager Class
Eco.Framework Namespace


EcoServiceProvider Class

EcoServiceProvider Class
Inheritance Hierarchy See Also
Collapse All
C#
public class EcoServiceProvider : IEcoServiceProvider;
Remarks

This is class Eco.Framework.EcoServiceProvider.

Inheritance Hierarchy
Eco.Framework.EcoServiceProvider
File

DefaultEcoServiceProvider.cs

See Also
Inheritance Hierarchy


EcoServiceProvider.EcoServiceProvider Constructor

EcoServiceProvider.EcoServiceProvider Constructor
EcoServiceProvider Class Eco.Framework Namespace See Also
Collapse All
C#
public EcoServiceProvider();
Remarks

This is EcoServiceProvider, a member of class EcoServiceProvider.

See Also
EcoServiceProvider Class
Eco.Framework Namespace


EcoServiceProvider Methods

EcoServiceProvider Methods
Public Methods
Collapse All

The methods of the EcoServiceProvider class are listed here.

Public Methods
Name | Description
ActivateEcoSpaceParts | This is ActivateEcoSpaceParts, a member of class EcoServiceProvider.
DeactivateEcoSpaceParts | This is DeactivateEcoSpaceParts, a member of class EcoServiceProvider.
GetEcoService | This is the overview for the GetEcoService method overload.
RegisterEcoService | This is the overview for the RegisterEcoService method overload.


EcoServiceProvider.ActivateEcoSpaceParts Method

EcoServiceProvider.ActivateEcoSpaceParts Method
EcoServiceProvider Class Eco.Framework Namespace See Also
Collapse All
C#
public void ActivateEcoSpaceParts();
Remarks

This is ActivateEcoSpaceParts, a member of class EcoServiceProvider.

See Also
EcoServiceProvider Class
Eco.Framework Namespace


EcoServiceProvider.DeactivateEcoSpaceParts Method

EcoServiceProvider.DeactivateEcoSpaceParts Method
EcoServiceProvider Class Eco.Framework Namespace See Also
Collapse All
C#
public void DeactivateEcoSpaceParts();
Remarks

This is DeactivateEcoSpaceParts, a member of class EcoServiceProvider.

See Also
EcoServiceProvider Class
Eco.Framework Namespace


GetEcoService Method

GetEcoService Method

This is the overview for the GetEcoService method overload.

Overload List
Name | Description
EcoServiceProvider.GetEcoService () | This is GetEcoService, a member of class EcoServiceProvider.
EcoServiceProvider.GetEcoService (object) | This is GetEcoService, a member of class EcoServiceProvider.
EcoServiceProvider.GetEcoService (Type) | This is GetEcoService, a member of class EcoServiceProvider.


EcoServiceProvider.GetEcoService Method ()

EcoServiceProvider.GetEcoService Method ()
EcoServiceProvider Class Eco.Framework Namespace See Also
Collapse All
C#
public virtual T GetEcoService<T>() where T: class;
Remarks

This is GetEcoService, a member of class EcoServiceProvider.

See Also
EcoServiceProvider Class
Eco.Framework Namespace


EcoServiceProvider.GetEcoService Method (Type)

EcoServiceProvider.GetEcoService Method (Type)
EcoServiceProvider Class Eco.Framework Namespace See Also
Collapse All
C#
public virtual object GetEcoService(
    Type serviceType
);
Remarks

This is GetEcoService, a member of class EcoServiceProvider.

See Also
EcoServiceProvider Class
Eco.Framework Namespace


EcoServiceProvider.GetEcoService Method (object)

EcoServiceProvider.GetEcoService Method (object)
EcoServiceProvider Class Eco.Framework Namespace See Also
Collapse All
C#
public virtual T GetEcoService<T>(
    object key
) where T: class;
Remarks

This is GetEcoService, a member of class EcoServiceProvider.

See Also
EcoServiceProvider Class
Eco.Framework Namespace


RegisterEcoService Method

RegisterEcoService Method

This is the overview for the RegisterEcoService method overload.

Overload List
Name | Description
EcoServiceProvider.RegisterEcoService (object, T) | This is RegisterEcoService, a member of class EcoServiceProvider.
EcoServiceProvider.RegisterEcoService (T) | This is RegisterEcoService, a member of class EcoServiceProvider.
EcoServiceProvider.RegisterEcoService (Type, object) | This is RegisterEcoService, a member of class EcoServiceProvider.


EcoServiceProvider.RegisterEcoService Method (T)

EcoServiceProvider.RegisterEcoService Method (T)
EcoServiceProvider Class Eco.Framework Namespace See Also
Collapse All
C#
public void RegisterEcoService<T>(
    T service
) where T: class;
Remarks

This is RegisterEcoService, a member of class EcoServiceProvider.

See Also
EcoServiceProvider Class
Eco.Framework Namespace


EcoServiceProvider.RegisterEcoService Method (Type, object)

EcoServiceProvider.RegisterEcoService Method (Type, object)
EcoServiceProvider Class Eco.Framework Namespace See Also
Collapse All
C#
public virtual void RegisterEcoService(
    Type serviceType,
    object service
);
Remarks

This is RegisterEcoService, a member of class EcoServiceProvider.

See Also
EcoServiceProvider Class
Eco.Framework Namespace


EcoServiceProvider.RegisterEcoService Method (object, T)

EcoServiceProvider.RegisterEcoService Method (object, T)
EcoServiceProvider Class Eco.Framework Namespace See Also
Collapse All
C#
public void RegisterEcoService<T>(
    object key,
    T service
) where T: class;
Remarks

This is RegisterEcoService, a member of class EcoServiceProvider.

See Also
EcoServiceProvider Class
Eco.Framework Namespace


EcoSpacePart Class

EcoSpacePart Class
Inheritance Hierarchy See Also
Collapse All

The base class for various ECO service implementations.

C#
public class EcoSpacePart;
Inheritance Hierarchy
Eco.Framework.EcoSpacePart
    Eco.Framework.EcoSpacePartWithTypeSystem
    Eco.Framework.Impl.Frontside.DefaultFrontsidePolicy
File

EcoSpacepart.cs

See Also
Inheritance Hierarchy


EcoSpacePart Methods

EcoSpacePart Methods
Protected Methods Public Methods
Collapse All

The methods of the EcoSpacePart class are listed here.

Protected Methods
Name | Description
DoActivate | Executed by Activate after State has been set to EcoSpacePartState.Activating and before it is set to EcoSpacePartState.Active.
DoDeactivate | Executed by Deactivate after State has been set to EcoSpacePartState.Deactivating and before it is set to EcoSpacePartState.Inactive.
DoDeserialize | Executed by Deserialize so that the object may restore it's inner state from the specified stream.
DoSerialize | Executed by Serialize so that the object may store it's inner state from to specified stream.
EnsureActive | Ensures the instance is active.
EnsurePropertySet | Ensures the specified property is not null.
FriendlyName | Used to provide a human readable name for this class.
Top
Public Methods
Name | Description
Activate | Executed by the EcoSpace to inform this object it is being activated.
Deactivate | Executed by the EcoSpace to inform this object it is being deactivated.
Deserialize | Executed by the EcoSpace when it is required to deserialize its inner state from a stream.
Serialize | Executed by the EcoSpace when it is required to serialize its inner state to a stream.


EcoSpacePart.Activate Method

EcoSpacePart.Activate Method
EcoSpacePart Class Eco.Framework Namespace See Also
Collapse All

Executed by the EcoSpace to inform this object it is being activated.

C#
public void Activate();
See Also
EcoSpacePart Class
Eco.Framework Namespace


EcoSpacePart.Deactivate Method

EcoSpacePart.Deactivate Method
EcoSpacePart Class Eco.Framework Namespace See Also
Collapse All

Executed by the EcoSpace to inform this object it is being deactivated.

C#
public void Deactivate();
See Also
EcoSpacePart Class
Eco.Framework Namespace


EcoSpacePart.Deserialize Method

EcoSpacePart.Deserialize Method
EcoSpacePart Class Eco.Framework Namespace Related Topics See Also
Collapse All

Executed by the EcoSpace when it is required to deserialize its inner state from a stream.

C#
public void Deserialize(
    Stream source
);
Parameters
Parameters | Description
source | The stream to restore from.
Related Topics

EcoSpacePart.Serialize

See Also
EcoSpacePart Class
Eco.Framework Namespace
Related Topics


EcoSpacePart.DoActivate Method

EcoSpacePart.DoActivate Method
EcoSpacePart Class Eco.Framework Namespace See Also
Collapse All

Executed by Activate after State has been set to EcoSpacePartState.Activating and before it is set to EcoSpacePartState.Active.

C#
protected virtual void DoActivate();
See Also
EcoSpacePart Class
Eco.Framework Namespace


EcoSpacePart.DoDeactivate Method

EcoSpacePart.DoDeactivate Method
EcoSpacePart Class Eco.Framework Namespace See Also
Collapse All

Executed by Deactivate after State has been set to EcoSpacePartState.Deactivating and before it is set to EcoSpacePartState.Inactive.

C#
protected virtual void DoDeactivate();
See Also
EcoSpacePart Class
Eco.Framework Namespace


EcoSpacePart.DoDeserialize Method

EcoSpacePart.DoDeserialize Method
EcoSpacePart Class Eco.Framework Namespace See Also
Collapse All

Executed by Deserialize so that the object may restore it's inner state from the specified stream.

C#
protected virtual void DoDeserialize(
    Stream source
);
Parameters
Parameters | Description
source | The stream containing previously serialized data.
See Also
EcoSpacePart Class
Eco.Framework Namespace


EcoSpacePart.DoSerialize Method

EcoSpacePart.DoSerialize Method
EcoSpacePart Class Eco.Framework Namespace See Also
Collapse All

Executed by Serialize so that the object may store it's inner state from to specified stream.

C#
protected virtual void DoSerialize(
    Stream target,
    EcoSpaceSerializationConfig config
);
Parameters
Parameters | Description
target | The stream containing previously serialized data.
config | Additional information passed to the EcoSpace outlining application preferences to be taken into account when serializing.
See Also
EcoSpacePart Class
Eco.Framework Namespace


EcoSpacePart.EnsureActive Method

EcoSpacePart.EnsureActive Method
EcoSpacePart Class Eco.Framework Namespace See Also
Collapse All

Ensures the instance is active.

C#
protected void EnsureActive();
Exceptions
Exceptions | Description
InvalidOperationException | Thrown if State is not EcoSpacePartState.Active.
See Also
EcoSpacePart Class
Eco.Framework Namespace


EcoSpacePart.EnsurePropertySet Method

EcoSpacePart.EnsurePropertySet Method
EcoSpacePart Class Eco.Framework Namespace See Also
Collapse All

Ensures the specified property is not null.

C#
protected void EnsurePropertySet(
    object property,
    string propertyName
);
Parameters
Parameters | Description
property | The value to compare wih null.
propertyName | A human readable named to display in the exception text.
Exceptions
Exceptions | Description
InvalidOperationException | Thrown if the value of property is null.
See Also
EcoSpacePart Class
Eco.Framework Namespace


EcoSpacePart.FriendlyName Method

EcoSpacePart.FriendlyName Method
EcoSpacePart Class Eco.Framework Namespace See Also
Collapse All

Used to provide a human readable name for this class.

C#
protected virtual string FriendlyName();
Remarks

The result of this method is used when constructing the text for exceptions.

See Also
EcoSpacePart Class
Eco.Framework Namespace


EcoSpacePart.Serialize Method

EcoSpacePart.Serialize Method
EcoSpacePart Class Eco.Framework Namespace See Also
Collapse All

Executed by the EcoSpace when it is required to serialize its inner state to a stream.

C#
public void Serialize(
    Stream target,
    EcoSpaceSerializationConfig config
);
Parameters
Parameters | Description
target | The stream to serialize to.
config | Additional information passed to the EcoSpace outlining application preferences to be taken into account when serializing.
See Also
EcoSpacePart Class
Eco.Framework Namespace


EcoSpacePart Properties

EcoSpacePart Properties
Public Properties
Collapse All

The properties of the EcoSpacePart class are listed here.

Public Properties
Name | Description
State | Returns the state of the EcoSpacePart.


EcoSpacePart.State Property

EcoSpacePart.State Property
EcoSpacePart Class Eco.Framework Namespace See Also
Collapse All

Returns the state of the EcoSpacePart.

C#
public EcoSpacePartState State;
See Also
EcoSpacePart Class
Eco.Framework Namespace


EcoSpacePartList Class

EcoSpacePartList Class
Inheritance Hierarchy See Also
Collapse All

Holds a collection of EcoSpacePart instances.

C#
public class EcoSpacePartList;
Inheritance Hierarchy
Eco.Framework.EcoSpacePartList
File

EcoSpacepart.cs

See Also
Inheritance Hierarchy


EcoSpacePartList Methods

EcoSpacePartList Methods
Public Methods
Collapse All

The methods of the EcoSpacePartList class are listed here.

Public Methods
Name | Description
Activate | Activates each EcoSpacePart within the collection.
Add | Adds an EcoSpacePart to the collection.
Contains | Indicates whether or not the specified EcoSpacePart is contained within the collection.
Deactivate | Deactivates each EcoSpacePart within the collection.
Remove | Removes an EcoSpacePart from the collection.


EcoSpacePartList.Activate Method

EcoSpacePartList.Activate Method
EcoSpacePartList Class Eco.Framework Namespace Related Topics See Also
Collapse All

Activates each EcoSpacePart within the collection.

C#
public void Activate();
Related Topics

EcoSpacePart.Activate

See Also
EcoSpacePartList Class
Eco.Framework Namespace
Related Topics


EcoSpacePartList.Add Method

EcoSpacePartList.Add Method
EcoSpacePartList Class Eco.Framework Namespace See Also
Collapse All

Adds an EcoSpacePart to the collection.

C#
public void Add(
    EcoSpacePart part
);
Parameters
Parameters | Description
part | The instance to add to the collection.
See Also
EcoSpacePartList Class
Eco.Framework Namespace


EcoSpacePartList.Contains Method

EcoSpacePartList.Contains Method
EcoSpacePartList Class Eco.Framework Namespace See Also
Collapse All

Indicates whether or not the specified EcoSpacePart is contained within the collection.

C#
public bool Contains(
    EcoSpacePart part
);
Parameters
Parameters | Description
part | The instance to inspect the collection for.
See Also
EcoSpacePartList Class
Eco.Framework Namespace


EcoSpacePartList.Deactivate Method

EcoSpacePartList.Deactivate Method
EcoSpacePartList Class Eco.Framework Namespace Related Topics See Also
Collapse All

Deactivates each EcoSpacePart within the collection.

C#
public void Deactivate();
Related Topics

EcoSpacePart.Deactivate

See Also
EcoSpacePartList Class
Eco.Framework Namespace
Related Topics


EcoSpacePartList.Remove Method

EcoSpacePartList.Remove Method
EcoSpacePartList Class Eco.Framework Namespace See Also
Collapse All

Removes an EcoSpacePart from the collection.

C#
public void Remove(
    EcoSpacePart part
);
Parameters
Parameters | Description
part |
See Also
EcoSpacePartList Class
Eco.Framework Namespace


EcoSpacePartWithTypeSystem Class

EcoSpacePartWithTypeSystem Class
Inheritance Hierarchy See Also
Collapse All

Base class for various standard ECO services of the EcoSpace.

C#
public class EcoSpacePartWithTypeSystem : EcoSpacePart;
Inheritance Hierarchy
Eco.Framework.EcoSpacePart
    Eco.Framework.EcoSpacePartWithTypeSystem
        Eco.Framework.Impl.CacheImpl
File

EcoSpacepart.cs

See Also
Inheritance Hierarchy


EcoSpacePartWithTypeSystem.EcoSpacePartWithTypeSystem Constructor

EcoSpacePartWithTypeSystem.EcoSpacePartWithTypeSystem Constructor
EcoSpacePartWithTypeSystem Class Eco.Framework Namespace See Also
Collapse All

Creates a new instance of this class.

C#
public EcoSpacePartWithTypeSystem(
    IEcoTypeSystem typeSystem
);
Parameters
Parameters | Description
typeSystem | The type system of the owning EcoSpace.
Exceptions
Exceptions | Description
ArgumentNullException | Thrown if typeSystem is null.
See Also
EcoSpacePartWithTypeSystem Class
Eco.Framework Namespace


EcoSpacePartWithTypeSystem Properties

EcoSpacePartWithTypeSystem Properties
Public Properties
Collapse All

The properties of the EcoSpacePartWithTypeSystem class are listed here.

Public Properties
Name | Description
TypeSystem | Returns a reference to the EcoSpace’s type system, which provides information about the model.


EcoSpacePartWithTypeSystem.TypeSystem Property

EcoSpacePartWithTypeSystem.TypeSystem Property
EcoSpacePartWithTypeSystem Class Eco.Framework Namespace See Also
Collapse All

Returns a reference to the EcoSpace’s type system, which provides information about the model.

C#
public IEcoTypeSystem TypeSystem;
See Also
EcoSpacePartWithTypeSystem Class
Eco.Framework Namespace


EcoSpaceSerializationConfig Class

EcoSpaceSerializationConfig Class
Inheritance Hierarchy See Also
Collapse All

Used to specify the way in which an EcoSpace is serialized.

C#
public class EcoSpaceSerializationConfig;
Inheritance Hierarchy
Eco.Framework.EcoSpaceSerializationConfig
File

EcoSpacepart.cs

See Also
Inheritance Hierarchy


EcoSpaceSerializationConfig Enumerations

EcoSpaceSerializationConfig Enumerations
Enumerations
Collapse All

The enumerations of the EcoSpaceSerializationConfig class are listed here.

Enumerations
Name | Description
CacheSerializationMode | Used to define how much information should be written when serializing an EcoSpace.


Eco.Framework.EcoSpaceSerializationConfig.CacheSerializationMode Enumeration

Eco.Framework.EcoSpaceSerializationConfig.CacheSerializationMode Enumeration
Collapse All

Used to define how much information should be written when serializing an EcoSpace.

C#
public enum CacheSerializationMode {
  Minimal,
  SkipDelayedFetch,
  All
}
Members
Members | Description
Minimal | Only modified members will be written.
SkipDelayedFetch | All members will be written, except for members that are marked DelayedFetch that have not been modified.
All | All members will be written.
File

EcoSpacepart.cs


EcoSpaceSerializationConfig Properties

EcoSpaceSerializationConfig Properties
Public Properties
Collapse All

The properties of the EcoSpaceSerializationConfig class are listed here.

Public Properties
Name | Description
CacheMode | Specifies how much information should be written when serializing the EcoSpace.
ObjectsToSerialize | Specifies a custom list of objects to serialize.
OptimisticLockingPrecondition | Used to serialize locking information.
SerializeUndo | Specifies whether or not the state of the UndoService will be serialized.


EcoSpaceSerializationConfig.CacheMode Property

EcoSpaceSerializationConfig.CacheMode Property
EcoSpaceSerializationConfig Class Eco.Framework Namespace See Also
Collapse All

Specifies how much information should be written when serializing the EcoSpace.

C#
public CacheSerializationMode CacheMode;
See Also
EcoSpaceSerializationConfig Class
Eco.Framework Namespace


EcoSpaceSerializationConfig.ObjectsToSerialize Property

EcoSpaceSerializationConfig.ObjectsToSerialize Property
EcoSpaceSerializationConfig Class Eco.Framework Namespace See Also
Collapse All

Specifies a custom list of objects to serialize.

C#
public IEnumerable<Locator> ObjectsToSerialize;
Remarks

If this property is null then all objects will be serialized. If the application requires only a custom list of objects to be serialized then this property should be set to an ICollection containing a list of the objects to serialize.

See Also
EcoSpaceSerializationConfig Class
Eco.Framework Namespace


EcoSpaceSerializationConfig.OptimisticLockingPrecondition Property

EcoSpaceSerializationConfig.OptimisticLockingPrecondition Property
EcoSpaceSerializationConfig Class Eco.Framework Namespace See Also
Collapse All

Used to serialize locking information.

C#
public OptimisticLockingPrecondition OptimisticLockingPrecondition;
Remarks

If EcoSpaceSerializationConfig.ObjectsToSerialize is not null then this property will be set automatically when the EcoSpace is serialized.

See Also
EcoSpaceSerializationConfig Class
Eco.Framework Namespace


EcoSpaceSerializationConfig.SerializeUndo Property

EcoSpaceSerializationConfig.SerializeUndo Property
EcoSpaceSerializationConfig Class Eco.Framework Namespace See Also
Collapse All

Specifies whether or not the state of the UndoService will be serialized.

C#
public bool SerializeUndo;
See Also
EcoSpaceSerializationConfig Class
Eco.Framework Namespace


LocatorCollectionEventArgs Class

LocatorCollectionEventArgs Class
Inheritance Hierarchy See Also
Collapse All
C#
public sealed class LocatorCollectionEventArgs : EventArgs;
Remarks

This is class Eco.Framework.LocatorCollectionEventArgs.

Inheritance Hierarchy
Eco.Framework.LocatorCollectionEventArgs
File

PersistenceHandler.cs

See Also
Inheritance Hierarchy


LocatorCollectionEventArgs.LocatorCollectionEventArgs Constructor

LocatorCollectionEventArgs.LocatorCollectionEventArgs Constructor
LocatorCollectionEventArgs Class Eco.Framework Namespace See Also
Collapse All
C#
public LocatorCollectionEventArgs(
    ICollection<Locator> locators
);
Remarks

This is LocatorCollectionEventArgs, a member of class LocatorCollectionEventArgs.

See Also
LocatorCollectionEventArgs Class
Eco.Framework Namespace


LocatorCollectionEventArgs Properties

LocatorCollectionEventArgs Properties
Public Properties
Collapse All

The properties of the LocatorCollectionEventArgs class are listed here.

Public Properties
Name | Description
Locators | This is Locators, a member of class LocatorCollectionEventArgs.


LocatorCollectionEventArgs.Locators Property

LocatorCollectionEventArgs.Locators Property
LocatorCollectionEventArgs Class Eco.Framework Namespace See Also
Collapse All
C#
public ICollection<Locator> Locators;
Remarks

This is Locators, a member of class LocatorCollectionEventArgs.

See Also
LocatorCollectionEventArgs Class
Eco.Framework Namespace


MemberDeriveException Class

MemberDeriveException Class
Inheritance Hierarchy See Also
Collapse All
C#
public class MemberDeriveException : InvalidOperationException;
Remarks

This is class Eco.Framework.MemberDeriveException.

Inheritance Hierarchy
Eco.Framework.MemberDeriveException
File

DerivedMembers.cs

See Also
Inheritance Hierarchy


MemberDeriveException Constructor

MemberDeriveException Constructor

This is the overview for the MemberDeriveException constructor overload.

Overload List
Name | Description
MemberDeriveException.MemberDeriveException (string) | This is MemberDeriveException, a member of class MemberDeriveException.
MemberDeriveException.MemberDeriveException (string, Exception) | This is MemberDeriveException, a member of class MemberDeriveException.


MemberDeriveException.MemberDeriveException Constructor (string)

MemberDeriveException.MemberDeriveException Constructor (string)
MemberDeriveException Class Eco.Framework Namespace See Also
Collapse All
C#
public MemberDeriveException(
    string message
);
Remarks

This is MemberDeriveException, a member of class MemberDeriveException.

See Also
MemberDeriveException Class
Eco.Framework Namespace


MemberDeriveException.MemberDeriveException Constructor (string, Exception)

MemberDeriveException.MemberDeriveException Constructor (string, Exception)
MemberDeriveException Class Eco.Framework Namespace See Also
Collapse All
C#
public MemberDeriveException(
    string message,
    Exception innerException
);
Remarks

This is MemberDeriveException, a member of class MemberDeriveException.

See Also
MemberDeriveException Class
Eco.Framework Namespace


IChangeHandler Interface

IChangeHandler Interface
Inheritance Hierarchy See Also
Collapse All
C#
public interface IChangeHandler;
Remarks

This is class Eco.Framework.IChangeHandler.

Inheritance Hierarchy
Eco.Framework.IChangeHandler
File

ChangeHandler.cs

See Also
Inheritance Hierarchy


IChangeHandler Methods

IChangeHandler Methods
Public Methods
Collapse All

The methods of the IChangeHandler class are listed here.

Public Methods
Name | Description
AddAllChanged | This is AddAllChanged, a member of class IChangeHandler.
AddLinkConflict | This is AddLinkConflict, a member of class IChangeHandler.
AddMemberChanged | This is AddMemberChanged, a member of class IChangeHandler.
AddObjectCreated | This is AddObjectCreated, a member of class IChangeHandler.
AddObjectDeleted | This is AddObjectDeleted, a member of class IChangeHandler.
ApplyAll | This is ApplyAll, a member of class IChangeHandler.
GetChanges | This is GetChanges, a member of class IChangeHandler.
IgnoreVersion | Version that can be ignored when retrieving changes. Normally becase it is a version updated by this EcoSpace


IChangeHandler.AddAllChanged Method

IChangeHandler.AddAllChanged Method
IChangeHandler Interface Eco.Framework Namespace See Also
Collapse All
C#
void AddAllChanged();
Remarks

This is AddAllChanged, a member of class IChangeHandler.

See Also
IChangeHandler Interface
Eco.Framework Namespace


IChangeHandler.AddLinkConflict Method

IChangeHandler.AddLinkConflict Method
IChangeHandler Interface Eco.Framework Namespace See Also
Collapse All
C#
void AddLinkConflict(
    Locator locator,
    IAssociationEnd end,
    Locator newValue
);
Remarks

This is AddLinkConflict, a member of class IChangeHandler.

See Also
IChangeHandler Interface
Eco.Framework Namespace


IChangeHandler.AddMemberChanged Method

IChangeHandler.AddMemberChanged Method
IChangeHandler Interface Eco.Framework Namespace See Also
Collapse All
C#
void AddMemberChanged(
    Locator locator,
    IStructuralFeature feature
);
Remarks

This is AddMemberChanged, a member of class IChangeHandler.

See Also
IChangeHandler Interface
Eco.Framework Namespace


IChangeHandler.AddObjectCreated Method

IChangeHandler.AddObjectCreated Method
IChangeHandler Interface Eco.Framework Namespace See Also
Collapse All
C#
void AddObjectCreated(
    ObjectId obj
);
Remarks

This is AddObjectCreated, a member of class IChangeHandler.

See Also
IChangeHandler Interface
Eco.Framework Namespace


IChangeHandler.AddObjectDeleted Method

IChangeHandler.AddObjectDeleted Method
IChangeHandler Interface Eco.Framework Namespace See Also
Collapse All
C#
void AddObjectDeleted(
    Locator locator
);
Remarks

This is AddObjectDeleted, a member of class IChangeHandler.

See Also
IChangeHandler Interface
Eco.Framework Namespace


IChangeHandler.ApplyAll Method

IChangeHandler.ApplyAll Method
IChangeHandler Interface Eco.Framework Namespace See Also
Collapse All
C#
void ApplyAll();
Remarks

This is ApplyAll, a member of class IChangeHandler.

See Also
IChangeHandler Interface
Eco.Framework Namespace


IChangeHandler.GetChanges Method

IChangeHandler.GetChanges Method
IChangeHandler Interface Eco.Framework Namespace See Also
Collapse All
C#
IChange[] GetChanges();
Remarks

This is GetChanges, a member of class IChangeHandler.

See Also
IChangeHandler Interface
Eco.Framework Namespace


IChangeHandler.IgnoreVersion Method

IChangeHandler.IgnoreVersion Method
IChangeHandler Interface Eco.Framework Namespace See Also
Collapse All

Version that can be ignored when retrieving changes. Normally becase it is a version updated by this EcoSpace

C#
void IgnoreVersion(
    SyncVersion version
);
See Also
IChangeHandler Interface
Eco.Framework Namespace


IChangeHandler Properties

IChangeHandler Properties
Public Properties
Collapse All

The properties of the IChangeHandler class are listed here.

Public Properties
Name | Description
ChangesCurrentTo | The version that all changes have been retrieved to. Setting it will also clear the IgnoreVersions
IgnoreVersions | This is IgnoreVersions, a member of class IChangeHandler.


IChangeHandler.ChangesCurrentTo Property

IChangeHandler.ChangesCurrentTo Property
IChangeHandler Interface Eco.Framework Namespace See Also
Collapse All

The version that all changes have been retrieved to. Setting it will also clear the IgnoreVersions

C#
SyncVersion ChangesCurrentTo;
See Also
IChangeHandler Interface
Eco.Framework Namespace


IChangeHandler.IgnoreVersions Property

IChangeHandler.IgnoreVersions Property
IChangeHandler Interface Eco.Framework Namespace See Also
Collapse All
C#
SyncVersion IgnoreVersions;
Remarks

This is IgnoreVersions, a member of class IChangeHandler.

See Also
IChangeHandler Interface
Eco.Framework Namespace


IDerivedMemberManager Interface

IDerivedMemberManager Interface
Inheritance Hierarchy See Also
Collapse All

This interface is used in the internal implementation of an EcoSpace, and is not currently documented.

C#
public interface IDerivedMemberManager;
Inheritance Hierarchy
Eco.Framework.IDerivedMemberManager
    Eco.Framework.DerivedMemberManager
File

DerivedMembers.cs

See Also
Inheritance Hierarchy


IDerivedMemberManager Methods

IDerivedMemberManager Methods
Public Methods
Collapse All

The methods of the IDerivedMemberManager class are listed here.

Public Methods
Name | Description
GetIsDerived | This is GetIsDerived, a member of class IDerivedMemberManager.
GetMemberValue | This is GetMemberValue, a member of class IDerivedMemberManager.


IDerivedMemberManager.GetIsDerived Method

IDerivedMemberManager.GetIsDerived Method
IDerivedMemberManager Interface Eco.Framework Namespace See Also
Collapse All
C#
bool GetIsDerived(
    IProperty prop
);
Remarks

This is GetIsDerived, a member of class IDerivedMemberManager.

See Also
IDerivedMemberManager Interface
Eco.Framework Namespace


IDerivedMemberManager.GetMemberValue Method

IDerivedMemberManager.GetMemberValue Method
IDerivedMemberManager Interface Eco.Framework Namespace See Also
Collapse All
C#
object GetMemberValue(
    IProperty prop
);
Remarks

This is GetMemberValue, a member of class IDerivedMemberManager.

See Also
IDerivedMemberManager Interface
Eco.Framework Namespace


IDerivedMemberManager Events

IDerivedMemberManager Events
Public Events
Collapse All

The events of the IDerivedMemberManager class are listed here.

Public Events
Name | Description
ValueChanged | This is ValueChanged, a member of class IDerivedMemberManager.


IDerivedMemberManager.ValueChanged Event

IDerivedMemberManager.ValueChanged Event
IDerivedMemberManager Interface Eco.Framework Namespace See Also
Collapse All
C#
event ValueChangedDelegate ValueChanged;
Remarks

This is ValueChanged, a member of class IDerivedMemberManager.

See Also
IDerivedMemberManager Interface
Eco.Framework Namespace


IFetchHandler Interface

IFetchHandler Interface
Inheritance Hierarchy See Also
Collapse All
C#
public interface IFetchHandler;
Remarks

This is class Eco.Framework.IFetchHandler.

Inheritance Hierarchy
Eco.Framework.IFetchHandler
File

PersistenceHandler.cs

See Also
Inheritance Hierarchy


IFetchHandler Methods

IFetchHandler Methods
Public Methods
Collapse All

The methods of the IFetchHandler class are listed here.

Public Methods
Name | Description
ApplyAttributeValue | This is ApplyAttributeValue, a member of class IFetchHandler.
ApplyDataBlock | This is ApplyDataBlock, a member of class IFetchHandler.
ApplyIndirectMultilink | This is ApplyIndirectMultilink, a member of class IFetchHandler.
ApplyIndirectSinglelink | This is ApplyIndirectSinglelink, a member of class IFetchHandler.
ApplyMultilink | This is ApplyMultilink, a member of class IFetchHandler.
ApplySinglelink | This is ApplySinglelink, a member of class IFetchHandler.


IFetchHandler.ApplyAttributeValue Method

IFetchHandler.ApplyAttributeValue Method
IFetchHandler Interface Eco.Framework Namespace See Also
Collapse All
C#
void ApplyAttributeValue(
    Locator locator,
    IAttribute attribute,
    object sourceValue
);
Remarks

This is ApplyAttributeValue, a member of class IFetchHandler.

See Also
IFetchHandler Interface
Eco.Framework Namespace


IFetchHandler.ApplyDataBlock Method

IFetchHandler.ApplyDataBlock Method
IFetchHandler Interface Eco.Framework Namespace See Also
Collapse All
C#
void ApplyDataBlock(
    Datablock datablock
);
Remarks

This is ApplyDataBlock, a member of class IFetchHandler.

See Also
IFetchHandler Interface
Eco.Framework Namespace


IFetchHandler.ApplyIndirectMultilink Method

IFetchHandler.ApplyIndirectMultilink Method
IFetchHandler Interface Eco.Framework Namespace See Also
Collapse All
C#
void ApplyIndirectMultilink(
    Locator locator,
    IAssociationEnd assocEnd,
    IEnumerable<LocatorPair> sourceValue
);
Remarks

This is ApplyIndirectMultilink, a member of class IFetchHandler.

See Also
IFetchHandler Interface
Eco.Framework Namespace


IFetchHandler.ApplyIndirectSinglelink Method

IFetchHandler.ApplyIndirectSinglelink Method
IFetchHandler Interface Eco.Framework Namespace See Also
Collapse All
C#
void ApplyIndirectSinglelink(
    Locator locator,
    IAssociationEnd assocEnd,
    LocatorPair sourceValue
);
Remarks

This is ApplyIndirectSinglelink, a member of class IFetchHandler.

See Also
IFetchHandler Interface
Eco.Framework Namespace


IFetchHandler.ApplyMultilink Method

IFetchHandler.ApplyMultilink Method
IFetchHandler Interface Eco.Framework Namespace See Also
Collapse All
C#
void ApplyMultilink(
    Locator locator,
    IAssociationEnd assocEnd,
    IEnumerable<Locator> sourceValue
);
Remarks

This is ApplyMultilink, a member of class IFetchHandler.

See Also
IFetchHandler Interface
Eco.Framework Namespace


IFetchHandler.ApplySinglelink Method

IFetchHandler.ApplySinglelink Method
IFetchHandler Interface Eco.Framework Namespace See Also
Collapse All
C#
void ApplySinglelink(
    Locator locator,
    IAssociationEnd assocEnd,
    Locator sourceValue,
    int orderNo
);
Remarks

This is ApplySinglelink, a member of class IFetchHandler.

See Also
IFetchHandler Interface
Eco.Framework Namespace


IObjectRepresentationProvider Interface

IObjectRepresentationProvider Interface
Inheritance Hierarchy See Also
Collapse All
C#
public interface IObjectRepresentationProvider;
Remarks

This is class Eco.Framework.IObjectRepresentationProvider.

Inheritance Hierarchy
Eco.Framework.IObjectRepresentationProvider
    Eco.Framework.Impl.Frontside.DefaultFrontsidePolicy
File

FrontsideFramework.cs

See Also
Inheritance Hierarchy


IObjectRepresentationProvider Methods

IObjectRepresentationProvider Methods
Public Methods
Collapse All

The methods of the IObjectRepresentationProvider class are listed here.

Public Methods
Name | Description
IObjectForLocator | This is IObjectForLocator, a member of class IObjectRepresentationProvider.
IObjectListToLocatorList | This is IObjectListToLocatorList, a member of class IObjectRepresentationProvider.
LocatorCollectionToIObjectList | This is LocatorCollectionToIObjectList, a member of class IObjectRepresentationProvider.
LocatorForIObject | This is LocatorForIObject, a member of class IObjectRepresentationProvider.


IObjectRepresentationProvider.IObjectForLocator Method

IObjectRepresentationProvider.IObjectForLocator Method
IObjectRepresentationProvider Interface Eco.Framework Namespace See Also
Collapse All
C#
IObjectInstance IObjectForLocator(
    Locator locator
);
Remarks

This is IObjectForLocator, a member of class IObjectRepresentationProvider.

See Also
IObjectRepresentationProvider Interface
Eco.Framework Namespace


IObjectRepresentationProvider.IObjectListToLocatorList Method

IObjectRepresentationProvider.IObjectListToLocatorList Method
IObjectRepresentationProvider Interface Eco.Framework Namespace See Also
Collapse All
C#
IList<Locator> IObjectListToLocatorList<T>(
    IEnumerable<T> objectList
) where T : IEcoObject;
Remarks

This is IObjectListToLocatorList, a member of class IObjectRepresentationProvider.

See Also
IObjectRepresentationProvider Interface
Eco.Framework Namespace


IObjectRepresentationProvider.LocatorCollectionToIObjectList Method

IObjectRepresentationProvider.LocatorCollectionToIObjectList Method
IObjectRepresentationProvider Interface Eco.Framework Namespace See Also
Collapse All
C#
IObjectList LocatorCollectionToIObjectList(
    IEnumerable<Locator> locators,
    IClass umlClass
);
Remarks

This is LocatorCollectionToIObjectList, a member of class IObjectRepresentationProvider.

See Also
IObjectRepresentationProvider Interface
Eco.Framework Namespace


IObjectRepresentationProvider.LocatorForIObject Method

IObjectRepresentationProvider.LocatorForIObject Method
IObjectRepresentationProvider Interface Eco.Framework Namespace See Also
Collapse All
C#
Locator LocatorForIObject(
    IObjectInstance obj
);
Remarks

This is LocatorForIObject, a member of class IObjectRepresentationProvider.

See Also
IObjectRepresentationProvider Interface
Eco.Framework Namespace


IPersistenceHandler Interface

IPersistenceHandler Interface
Inheritance Hierarchy See Also
Collapse All
C#
public interface IPersistenceHandler;
Remarks

This is class Eco.Framework.IPersistenceHandler.

Inheritance Hierarchy
Eco.Framework.IPersistenceHandler
File

PersistenceHandler.cs

See Also
Inheritance Hierarchy


IPersistenceHandler Methods

IPersistenceHandler Methods
Public Methods
Collapse All

The methods of the IPersistenceHandler class are listed here.

Public Methods
Name | Description
Fetch | This is Fetch, a member of class IPersistenceHandler.
FetchLinksWithObjects | This is FetchLinksWithObjects, a member of class IPersistenceHandler.
GetAllWithCondition | This is GetAllWithCondition, a member of class IPersistenceHandler.
RetrieveChanges | This is RetrieveChanges, a member of class IPersistenceHandler.
TimeForVersion | This is TimeForVersion, a member of class IPersistenceHandler.
UpdateDatabaseWithList | This is UpdateDatabaseWithList, a member of class IPersistenceHandler.
VersionAtTime | This is VersionAtTime, a member of class IPersistenceHandler.


IPersistenceHandler.Fetch Method

IPersistenceHandler.Fetch Method
IPersistenceHandler Interface Eco.Framework Namespace See Also
Collapse All
C#
void Fetch(
    ICollection<Locator> locators,
    int[] members,
    FetchStrategy fetchStrategy
);
Remarks

This is Fetch, a member of class IPersistenceHandler.

See Also
IPersistenceHandler Interface
Eco.Framework Namespace


IPersistenceHandler.FetchLinksWithObjects Method

IPersistenceHandler.FetchLinksWithObjects Method
IPersistenceHandler Interface Eco.Framework Namespace See Also
Collapse All
C#
ICollection<Locator> FetchLinksWithObjects(
    ICollection<Locator> locators,
    IAssociationEnd assocEnd
);
Remarks

This is FetchLinksWithObjects, a member of class IPersistenceHandler.

See Also
IPersistenceHandler Interface
Eco.Framework Namespace


IPersistenceHandler.GetAllWithCondition Method

IPersistenceHandler.GetAllWithCondition Method
IPersistenceHandler Interface Eco.Framework Namespace See Also
Collapse All
C#
ICollection<Locator> GetAllWithCondition(
    AbstractCondition condition,
    int maxAnswers,
    int offset
);
Remarks

This is GetAllWithCondition, a member of class IPersistenceHandler.

See Also
IPersistenceHandler Interface
Eco.Framework Namespace


IPersistenceHandler.RetrieveChanges Method

IPersistenceHandler.RetrieveChanges Method
IPersistenceHandler Interface Eco.Framework Namespace See Also
Collapse All
C#
void RetrieveChanges(
    out DBChangeCollection ignoredChanges
);
Remarks

This is RetrieveChanges, a member of class IPersistenceHandler.

See Also
IPersistenceHandler Interface
Eco.Framework Namespace


IPersistenceHandler.TimeForVersion Method

IPersistenceHandler.TimeForVersion Method
IPersistenceHandler Interface Eco.Framework Namespace See Also
Collapse All
C#
DateTime TimeForVersion(
    int version
);
Remarks

This is TimeForVersion, a member of class IPersistenceHandler.

See Also
IPersistenceHandler Interface
Eco.Framework Namespace


IPersistenceHandler.UpdateDatabaseWithList Method

IPersistenceHandler.UpdateDatabaseWithList Method
IPersistenceHandler Interface Eco.Framework Namespace See Also
Collapse All
C#
void UpdateDatabaseWithList(
    ICollection<Locator> locators
);
Remarks

This is UpdateDatabaseWithList, a member of class IPersistenceHandler.

See Also
IPersistenceHandler Interface
Eco.Framework Namespace


IPersistenceHandler.VersionAtTime Method

IPersistenceHandler.VersionAtTime Method
IPersistenceHandler Interface Eco.Framework Namespace See Also
Collapse All
C#
int VersionAtTime(
    DateTime time
);
Remarks

This is VersionAtTime, a member of class IPersistenceHandler.

See Also
IPersistenceHandler Interface
Eco.Framework Namespace


IPersistenceHandler Properties

IPersistenceHandler Properties
Public Properties
Collapse All

The properties of the IPersistenceHandler class are listed here.

Public Properties
Name | Description
IsPersistent | This is IsPersistent, a member of class IPersistenceHandler.
MaxSavedVersion | This is MaxSavedVersion, a member of class IPersistenceHandler.
SupportsSync | This is SupportsSync, a member of class IPersistenceHandler.


IPersistenceHandler.IsPersistent Property

IPersistenceHandler.IsPersistent Property
IPersistenceHandler Interface Eco.Framework Namespace See Also
Collapse All
C#
bool IsPersistent;
Remarks

This is IsPersistent, a member of class IPersistenceHandler.

See Also
IPersistenceHandler Interface
Eco.Framework Namespace


IPersistenceHandler.MaxSavedVersion Property

IPersistenceHandler.MaxSavedVersion Property
IPersistenceHandler Interface Eco.Framework Namespace See Also
Collapse All
C#
int MaxSavedVersion;
Remarks

This is MaxSavedVersion, a member of class IPersistenceHandler.

See Also
IPersistenceHandler Interface
Eco.Framework Namespace


IPersistenceHandler.SupportsSync Property

IPersistenceHandler.SupportsSync Property
IPersistenceHandler Interface Eco.Framework Namespace See Also
Collapse All
C#
bool SupportsSync;
Remarks

This is SupportsSync, a member of class IPersistenceHandler.

See Also
IPersistenceHandler Interface
Eco.Framework Namespace


IPersistenceHandler Events

IPersistenceHandler Events
Public Events
Collapse All

The events of the IPersistenceHandler class are listed here.

Public Events
Name | Description
ObjectsUpdated | This is ObjectsUpdated, a member of class IPersistenceHandler.


IPersistenceHandler.ObjectsUpdated Event

IPersistenceHandler.ObjectsUpdated Event
IPersistenceHandler Interface Eco.Framework Namespace See Also
Collapse All
C#
event LocatorArrayEventHandler ObjectsUpdated;
Remarks

This is ObjectsUpdated, a member of class IPersistenceHandler.

See Also
IPersistenceHandler Interface
Eco.Framework Namespace


Eco.Framework.EcoSpacePartState Enumeration

Eco.Framework.EcoSpacePartState Enumeration

Indicates the state of an EcoSpacePart.

C#
public enum EcoSpacePartState {
  Inactive,
  Activating,
  Active,
  Deactivating,
  Deserializing
}
Members
Members | Description
Inactive | The part is inactive.
Activating | The part is being activated.
Active | The part is active and ready for use.
Deactivating | The part is undergoing deactivation.
Deserializing | The part’s internal state is being restored from a previously serialized stream.
File

EcoSpacepart.cs


Eco.Framework.FetchStrategy Enumeration

Eco.Framework.FetchStrategy Enumeration
C#
public enum FetchStrategy {
  FetchObjects,
  IdsOnly
}
Remarks

This is record Eco.Framework.FetchStrategy.

File

PersistenceHandler.cs


Eco.Framework.LocatorArrayEventHandler Type

Eco.Framework.LocatorArrayEventHandler Type
C#
public delegate void LocatorArrayEventHandler(object sender, LocatorCollectionEventArgs args);
Remarks

This is type Eco.Framework.LocatorArrayEventHandler.

File

PersistenceHandler.cs


Eco.Framework.ValueChangedDelegate Type

Eco.Framework.ValueChangedDelegate Type

This delegate is used in the internal implementation of an EcoSpace, and is not currently documented.

C#
public delegate void ValueChangedDelegate(IProperty prop, EventArgs args);
File

DerivedMembers.cs


Eco.Framework.Impl Namespace

Eco.Framework.Impl Namespace
Classes Interfaces
Collapse All

This is namespace Eco.Framework.Impl.

Classes
Name | Description
ArrayAttributeCachePolicy | This is class Eco.Framework.Impl.ArrayAttributeCachePolicy.
AssociationEndCachePolicy | This is class Eco.Framework.Impl.AssociationEndCachePolicy.
AttributeCachePolicy | This is class Eco.Framework.Impl.AttributeCachePolicy.
CacheImpl | This is class Eco.Framework.Impl.CacheImpl.
CacheLocator | This is class Eco.Framework.Impl.CacheLocator.
CacheMultilinkAdapter | This is class Eco.Framework.Impl.CacheMultilinkAdapter.
CacheMultilinkCurrentValueAdapter | This is class Eco.Framework.Impl.CacheMultilinkCurrentValueAdapter.
CacheMultilinkEnumerator | This is class Eco.Framework.Impl.CacheMultilinkEnumerator.
CacheMultilinkFetchedValueAdapter | This is class Eco.Framework.Impl.CacheMultilinkFetchedValueAdapter.
ClassCachePolicy | This is class Eco.Framework.Impl.ClassCachePolicy.
DirectMultiAssociationEndCachePolicy | This is class Eco.Framework.Impl.DirectMultiAssociationEndCachePolicy.
DirectSingleAssociationEndCachePolicy | This is class Eco.Framework.Impl.DirectSingleAssociationEndCachePolicy.
IndirectMultiAssociationEndCachePolicy | This is class Eco.Framework.Impl.IndirectMultiAssociationEndCachePolicy.
IndirectSingleAssociationEndCachePolicy | This is class Eco.Framework.Impl.IndirectSingleAssociationEndCachePolicy.
InnerAssociationEndCachePolicy | This is class Eco.Framework.Impl.InnerAssociationEndCachePolicy.
LinkObjectMultiAssociationEndCachePolicy | This is class Eco.Framework.Impl.LinkObjectMultiAssociationEndCachePolicy.
LinkObjectSingleAssociationEndCachePolicy | This is class Eco.Framework.Impl.LinkObjectSingleAssociationEndCachePolicy.
LocatorDictionary | This is class Eco.Framework.Impl.LocatorDictionary.
MainMultiAssociationEndCachePolicy | This is class Eco.Framework.Impl.MainMultiAssociationEndCachePolicy.
MemberCachePolicy | This is class Eco.Framework.Impl.MemberCachePolicy.
MultiAssociationEndCachePolicy | This is class Eco.Framework.Impl.MultiAssociationEndCachePolicy.
SingleAssociationEndCachePolicy | This is class Eco.Framework.Impl.SingleAssociationEndCachePolicy.
Top
Interfaces
Name | Description
IIndirectController | This is class Eco.Framework.Impl.IIndirectController.
IOtherEndController | This is class Eco.Framework.Impl.IOtherEndController.


ArrayAttributeCachePolicy Class

ArrayAttributeCachePolicy Class
Inheritance Hierarchy See Also
Collapse All
C#
public class ArrayAttributeCachePolicy : AttributeCachePolicy;
Remarks

This is class Eco.Framework.Impl.ArrayAttributeCachePolicy.

Inheritance Hierarchy
Eco.Framework.Impl.MemberCachePolicy
    Eco.Framework.Impl.AttributeCachePolicy
        Eco.Framework.Impl.ArrayAttributeCachePolicy
File

AttributeClassPolicy.cs

See Also
Inheritance Hierarchy


ArrayAttributeCachePolicy.ArrayAttributeCachePolicy Constructor

ArrayAttributeCachePolicy.ArrayAttributeCachePolicy Constructor
ArrayAttributeCachePolicy Class Eco.Framework.Impl Namespace See Also
Collapse All
C#
public ArrayAttributeCachePolicy(
    ClassCachePolicy owner,
    IAttribute attribute,
    int memberContentIndex,
    int flagIndex
);
Remarks

This is ArrayAttributeCachePolicy, a member of class ArrayAttributeCachePolicy.

See Also
ArrayAttributeCachePolicy Class
Eco.Framework.Impl Namespace


ArrayAttributeCachePolicy Methods

ArrayAttributeCachePolicy Methods
Public Methods
Collapse All

The methods of the ArrayAttributeCachePolicy class are listed here.

Public Methods
Name | Description
GetCurrentValue | This is GetCurrentValue, a member of class ArrayAttributeCachePolicy.
SetCurrentValue | This is SetCurrentValue, a member of class ArrayAttributeCachePolicy.
SetFetchedValue | This is SetFetchedValue, a member of class ArrayAttributeCachePolicy.


ArrayAttributeCachePolicy.GetCurrentValue Method

ArrayAttributeCachePolicy.GetCurrentValue Method
ArrayAttributeCachePolicy Class Eco.Framework.Impl Namespace See Also
Collapse All
C#
public override object GetCurrentValue(
    CacheLocator owningLocator
);
Remarks

This is GetCurrentValue, a member of class ArrayAttributeCachePolicy.

See Also
ArrayAttributeCachePolicy Class
Eco.Framework.Impl Namespace


ArrayAttributeCachePolicy.SetCurrentValue Method

ArrayAttributeCachePolicy.SetCurrentValue Method
ArrayAttributeCachePolicy Class Eco.Framework.Impl Namespace See Also
Collapse All
C#
public override void SetCurrentValue(
    CacheLocator owningLocator,
    object value
);
Remarks

This is SetCurrentValue, a member of class ArrayAttributeCachePolicy.

See Also
ArrayAttributeCachePolicy Class
Eco.Framework.Impl Namespace


ArrayAttributeCachePolicy.SetFetchedValue Method

ArrayAttributeCachePolicy.SetFetchedValue Method
ArrayAttributeCachePolicy Class Eco.Framework.Impl Namespace See Also
Collapse All
C#
public override void SetFetchedValue(
    CacheLocator owningObject,
    object value
);
Remarks

This is SetFetchedValue, a member of class ArrayAttributeCachePolicy.

See Also
ArrayAttributeCachePolicy Class
Eco.Framework.Impl Namespace


AssociationEndCachePolicy Class

AssociationEndCachePolicy Class
Inheritance Hierarchy See Also
Collapse All
C#
public abstract class AssociationEndCachePolicy : MemberCachePolicy;
Remarks

This is class Eco.Framework.Impl.AssociationEndCachePolicy.

Inheritance Hierarchy
Eco.Framework.Impl.MemberCachePolicy
    Eco.Framework.Impl.AssociationEndCachePolicy
        Eco.Framework.Impl.MultiAssociationEndCachePolicy
        Eco.Framework.Impl.SingleAssociationEndCachePolicy
File

AssociationEndCachePolicy.cs

See Also
Inheritance Hierarchy


AssociationEndCachePolicy.AssociationEndCachePolicy Constructor

AssociationEndCachePolicy.AssociationEndCachePolicy Constructor
AssociationEndCachePolicy Class Eco.Framework.Impl Namespace See Also
Collapse All
C#
public AssociationEndCachePolicy(
    ClassCachePolicy owner,
    IAssociationEnd associationEnd,
    int memberContentIndex,
    int flagIndex
);
Remarks

This is AssociationEndCachePolicy, a member of class AssociationEndCachePolicy.

See Also
AssociationEndCachePolicy Class
Eco.Framework.Impl Namespace


AssociationEndCachePolicy Methods

AssociationEndCachePolicy Methods
Protected Methods Public Methods
Collapse All

The methods of the AssociationEndCachePolicy class are listed here.

Protected Methods
Name | Description
SerializeNonEmbeddedLink | This is SerializeNonEmbeddedLink, a member of class AssociationEndCachePolicy.
Top
Public Methods
Name | Description
Initialize | This is Initialize, a member of class AssociationEndCachePolicy.
Pass2 | This is Pass2, a member of class AssociationEndCachePolicy.
SetCurrentAndFetchedValue | This is SetCurrentAndFetchedValue, a member of class AssociationEndCachePolicy.


AssociationEndCachePolicy.Initialize Method

AssociationEndCachePolicy.Initialize Method
AssociationEndCachePolicy Class Eco.Framework.Impl Namespace See Also
Collapse All
C#
public override void Initialize(
    object[] objectContents
);
Remarks

This is Initialize, a member of class AssociationEndCachePolicy.

See Also
AssociationEndCachePolicy Class
Eco.Framework.Impl Namespace


AssociationEndCachePolicy.Pass2 Method

AssociationEndCachePolicy.Pass2 Method
AssociationEndCachePolicy Class Eco.Framework.Impl Namespace See Also
Collapse All
C#
public override void Pass2();
Remarks

This is Pass2, a member of class AssociationEndCachePolicy.

See Also
AssociationEndCachePolicy Class
Eco.Framework.Impl Namespace


AssociationEndCachePolicy.SerializeNonEmbeddedLink Method

AssociationEndCachePolicy.SerializeNonEmbeddedLink Method
AssociationEndCachePolicy Class Eco.Framework.Impl Namespace See Also
Collapse All
C#
protected void SerializeNonEmbeddedLink(
    CacheLocator locator,
    Stream target,
    EcoSpaceSerializationConfig config
);
Remarks

This is SerializeNonEmbeddedLink, a member of class AssociationEndCachePolicy.

See Also
AssociationEndCachePolicy Class
Eco.Framework.Impl Namespace


AssociationEndCachePolicy.SetCurrentAndFetchedValue Method

AssociationEndCachePolicy.SetCurrentAndFetchedValue Method
AssociationEndCachePolicy Class Eco.Framework.Impl Namespace See Also
Collapse All
C#
public override void SetCurrentAndFetchedValue(
    object value,
    CacheLocator owningLocator
);
Remarks

This is SetCurrentAndFetchedValue, a member of class AssociationEndCachePolicy.

See Also
AssociationEndCachePolicy Class
Eco.Framework.Impl Namespace


AssociationEndCachePolicy Properties

AssociationEndCachePolicy Properties
Public Properties
Collapse All

The properties of the AssociationEndCachePolicy class are listed here.

Public Properties
Name | Description
AssociationEnd | This is AssociationEnd, a member of class AssociationEndCachePolicy.
MainOppositeEnd | This is MainOppositeEnd, a member of class AssociationEndCachePolicy.
MainOppositeEndController | This is MainOppositeEndController, a member of class AssociationEndCachePolicy.
StructuralFeature | This is StructuralFeature, a member of class AssociationEndCachePolicy.


AssociationEndCachePolicy.AssociationEnd Property

AssociationEndCachePolicy.AssociationEnd Property
AssociationEndCachePolicy Class Eco.Framework.Impl Namespace See Also
Collapse All
C#
public IAssociationEnd AssociationEnd;
Remarks

This is AssociationEnd, a member of class AssociationEndCachePolicy.

See Also
AssociationEndCachePolicy Class
Eco.Framework.Impl Namespace


AssociationEndCachePolicy.MainOppositeEnd Property

AssociationEndCachePolicy.MainOppositeEnd Property
AssociationEndCachePolicy Class Eco.Framework.Impl Namespace See Also
Collapse All
C#
public IAssociationEnd MainOppositeEnd;
Remarks

This is MainOppositeEnd, a member of class AssociationEndCachePolicy.

See Also
AssociationEndCachePolicy Class
Eco.Framework.Impl Namespace


AssociationEndCachePolicy.MainOppositeEndController Property

AssociationEndCachePolicy.MainOppositeEndController Property
AssociationEndCachePolicy Class Eco.Framework.Impl Namespace See Also
Collapse All
C#
public IOtherEndController MainOppositeEndController;
Remarks

This is MainOppositeEndController, a member of class AssociationEndCachePolicy.

See Also
AssociationEndCachePolicy Class
Eco.Framework.Impl Namespace


AssociationEndCachePolicy.StructuralFeature Property

AssociationEndCachePolicy.StructuralFeature Property
AssociationEndCachePolicy Class Eco.Framework.Impl Namespace See Also
Collapse All
C#
public override IStructuralFeature StructuralFeature;
Remarks

This is StructuralFeature, a member of class AssociationEndCachePolicy.

See Also
AssociationEndCachePolicy Class
Eco.Framework.Impl Namespace


AttributeCachePolicy Class

AttributeCachePolicy Class
Inheritance Hierarchy See Also
Collapse All
C#
public class AttributeCachePolicy : MemberCachePolicy;
Remarks

This is class Eco.Framework.Impl.AttributeCachePolicy.

Inheritance Hierarchy
Eco.Framework.Impl.MemberCachePolicy
    Eco.Framework.Impl.AttributeCachePolicy
        Eco.Framework.Impl.ArrayAttributeCachePolicy
File

AttributeClassPolicy.cs

See Also
Inheritance Hierarchy


AttributeCachePolicy.AttributeCachePolicy Constructor

AttributeCachePolicy.AttributeCachePolicy Constructor
AttributeCachePolicy Class Eco.Framework.Impl Namespace See Also
Collapse All
C#
public AttributeCachePolicy(
    ClassCachePolicy owner,
    IAttribute attribute,
    int memberContentIndex,
    int flagIndex
);
Remarks

This is AttributeCachePolicy, a member of class AttributeCachePolicy.

See Also
AttributeCachePolicy Class
Eco.Framework.Impl Namespace


AttributeCachePolicy Methods

AttributeCachePolicy Methods
Protected Methods Public Methods
Collapse All

The methods of the AttributeCachePolicy class are listed here.

Protected Methods
Name | Description
ValidateDatatype | This is ValidateDatatype, a member of class AttributeCachePolicy.
Top
Public Methods
Name | Description
ClearOldValue | This is ClearOldValue, a member of class AttributeCachePolicy.
DoDeserialize | This is DoDeserialize, a member of class AttributeCachePolicy.
DoSerialize | This is DoSerialize, a member of class AttributeCachePolicy.
FreeMemberContent | This is FreeMemberContent, a member of class AttributeCachePolicy.
GetCurrentValue | This is GetCurrentValue, a member of class AttributeCachePolicy.
GetFetchedValue | This is GetFetchedValue, a member of class AttributeCachePolicy.
Initialize | This is Initialize, a member of class AttributeCachePolicy.
SaveOldValue | This is SaveOldValue, a member of class AttributeCachePolicy.
SetCurrentAndFetchedValue | This is SetCurrentAndFetchedValue, a member of class AttributeCachePolicy.
SetCurrentValue | This is SetCurrentValue, a member of class AttributeCachePolicy.
SetFetchedValue | This is SetFetchedValue, a member of class AttributeCachePolicy.


AttributeCachePolicy.ClearOldValue Method

AttributeCachePolicy.ClearOldValue Method
AttributeCachePolicy Class Eco.Framework.Impl Namespace See Also
Collapse All
C#
public override void ClearOldValue(
    object[] objectContents
);
Remarks

This is ClearOldValue, a member of class AttributeCachePolicy.

See Also
AttributeCachePolicy Class
Eco.Framework.Impl Namespace


AttributeCachePolicy.DoDeserialize Method

AttributeCachePolicy.DoDeserialize Method
AttributeCachePolicy Class Eco.Framework.Impl Namespace See Also
Collapse All
C#
public override void DoDeserialize(
    CacheLocator locator,
    Stream source
);
Remarks

This is DoDeserialize, a member of class AttributeCachePolicy.

See Also
AttributeCachePolicy Class
Eco.Framework.Impl Namespace


AttributeCachePolicy.DoSerialize Method

AttributeCachePolicy.DoSerialize Method
AttributeCachePolicy Class Eco.Framework.Impl Namespace See Also
Collapse All
C#
public override void DoSerialize(
    CacheLocator locator,
    Stream target,
    EcoSpaceSerializationConfig config
);
Remarks

This is DoSerialize, a member of class AttributeCachePolicy.

See Also
AttributeCachePolicy Class
Eco.Framework.Impl Namespace


AttributeCachePolicy.FreeMemberContent Method

AttributeCachePolicy.FreeMemberContent Method
AttributeCachePolicy Class Eco.Framework.Impl Namespace See Also
Collapse All
C#
public override void FreeMemberContent(
    object[] objectContents
);
Remarks

This is FreeMemberContent, a member of class AttributeCachePolicy.

See Also
AttributeCachePolicy Class
Eco.Framework.Impl Namespace


AttributeCachePolicy.GetCurrentValue Method

AttributeCachePolicy.GetCurrentValue Method
AttributeCachePolicy Class Eco.Framework.Impl Namespace See Also
Collapse All
C#
public override object GetCurrentValue(
    CacheLocator owningLocator
);
Remarks

This is GetCurrentValue, a member of class AttributeCachePolicy.

See Also
AttributeCachePolicy Class
Eco.Framework.Impl Namespace


AttributeCachePolicy.GetFetchedValue Method

AttributeCachePolicy.GetFetchedValue Method
AttributeCachePolicy Class Eco.Framework.Impl Namespace See Also
Collapse All
C#
public override object GetFetchedValue(
    CacheLocator owningObject
);
Remarks

This is GetFetchedValue, a member of class AttributeCachePolicy.

See Also
AttributeCachePolicy Class
Eco.Framework.Impl Namespace


AttributeCachePolicy.Initialize Method

AttributeCachePolicy.Initialize Method
AttributeCachePolicy Class Eco.Framework.Impl Namespace See Also
Collapse All
C#
public override void Initialize(
    object[] objectContents
);
Remarks

This is Initialize, a member of class AttributeCachePolicy.

See Also
AttributeCachePolicy Class
Eco.Framework.Impl Namespace


AttributeCachePolicy.SaveOldValue Method

AttributeCachePolicy.SaveOldValue Method
AttributeCachePolicy Class Eco.Framework.Impl Namespace See Also
Collapse All
C#
public override void SaveOldValue(
    object[] objectContents
);
Remarks

This is SaveOldValue, a member of class AttributeCachePolicy.

See Also
AttributeCachePolicy Class
Eco.Framework.Impl Namespace


AttributeCachePolicy.SetCurrentAndFetchedValue Method

AttributeCachePolicy.SetCurrentAndFetchedValue Method
AttributeCachePolicy Class Eco.Framework.Impl Namespace See Also
Collapse All
C#
public override void SetCurrentAndFetchedValue(
    object value,
    CacheLocator owningLocator
);
Remarks

This is SetCurrentAndFetchedValue, a member of class AttributeCachePolicy.

See Also
AttributeCachePolicy Class
Eco.Framework.Impl Namespace


AttributeCachePolicy.SetCurrentValue Method

AttributeCachePolicy.SetCurrentValue Method
AttributeCachePolicy Class Eco.Framework.Impl Namespace See Also
Collapse All
C#
public override void SetCurrentValue(
    CacheLocator owningLocator,
    object value
);
Remarks

This is SetCurrentValue, a member of class AttributeCachePolicy.

See Also
AttributeCachePolicy Class
Eco.Framework.Impl Namespace


AttributeCachePolicy.SetFetchedValue Method

AttributeCachePolicy.SetFetchedValue Method
AttributeCachePolicy Class Eco.Framework.Impl Namespace See Also
Collapse All
C#
public override void SetFetchedValue(
    CacheLocator owningObject,
    object value
);
Remarks

This is SetFetchedValue, a member of class AttributeCachePolicy.

See Also
AttributeCachePolicy Class
Eco.Framework.Impl Namespace


AttributeCachePolicy.ValidateDatatype Method

AttributeCachePolicy.ValidateDatatype Method
AttributeCachePolicy Class Eco.Framework.Impl Namespace See Also
Collapse All
C#
protected void ValidateDatatype(
    object value
);
Remarks

This is ValidateDatatype, a member of class AttributeCachePolicy.

See Also
AttributeCachePolicy Class
Eco.Framework.Impl Namespace


AttributeCachePolicy Properties

AttributeCachePolicy Properties
Public Properties
Collapse All

The properties of the AttributeCachePolicy class are listed here.

Public Properties
Name | Description
StructuralFeature | This is StructuralFeature, a member of class AttributeCachePolicy.


AttributeCachePolicy.StructuralFeature Property

AttributeCachePolicy.StructuralFeature Property
AttributeCachePolicy Class Eco.Framework.Impl Namespace See Also
Collapse All
C#
public override IStructuralFeature StructuralFeature;
Remarks

This is StructuralFeature, a member of class AttributeCachePolicy.

See Also
AttributeCachePolicy Class
Eco.Framework.Impl Namespace


CacheImpl Class

CacheImpl Class
Inheritance Hierarchy See Also
Collapse All
C#
public class CacheImpl : EcoSpacePartWithTypeSystem, ICache;
Remarks

This is class Eco.Framework.Impl.CacheImpl.

Inheritance Hierarchy
Eco.Framework.EcoSpacePart
    Eco.Framework.EcoSpacePartWithTypeSystem
        Eco.Framework.Impl.CacheImpl
File

CacheImpl.cs

See Also
Inheritance Hierarchy


CacheImpl.CacheImpl Constructor

CacheImpl.CacheImpl Constructor
CacheImpl Class Eco.Framework.Impl Namespace See Also
Collapse All
C#
public CacheImpl(
    IEcoTypeSystem typeSystem
);
Remarks

This is CacheImpl, a member of class CacheImpl.

See Also
CacheImpl Class
Eco.Framework.Impl Namespace


CacheImpl Methods

CacheImpl Methods
Protected Methods Public Methods
Collapse All

The methods of the CacheImpl class are listed here.

Protected Methods
Name | Description
DoActivate | Executed by Activate after State has been set to EcoSpacePartState.Activating and before it is set to EcoSpacePartState.Active.
DoDeactivate | Executed by Deactivate after State has been set to EcoSpacePartState.Deactivating and before it is set to EcoSpacePartState.Inactive.
DoDeserialize | Executed by Deserialize so that the object may restore it's inner state from the specified stream.
DoSerialize | Executed by Serialize so that the object may store it's inner state from to specified stream.
Top
Public Methods
Name | Description
ApplyTranslationList | This is ApplyTranslationList, a member of class CacheImpl.
Contains | This is Contains, a member of class CacheImpl.
CreateNewObject | This is the overview for the CreateNewObject method overload.
DestroyObject | This is DestroyObject, a member of class CacheImpl.
GetAllLocators | This is GetAllLocators, a member of class CacheImpl.
GetClassPolicy | This is the overview for the GetClassPolicy method overload.
GetCurrentOrderNo | This is GetCurrentOrderNo, a member of class CacheImpl.
GetCurrentValue | This is the overview for the GetCurrentValue method overload.
GetEnsuredLocatorById | This is GetEnsuredLocatorById, a member of class CacheImpl.
GetExistenceState | This is GetExistenceState, a member of class CacheImpl.
GetExtentIsCurrent | This is GetExtentIsCurrent, a member of class CacheImpl.
GetFetchedOrderNo | This is GetFetchedOrderNo, a member of class CacheImpl.
GetFetchedValue | This is the overview for the GetFetchedValue method overload.
GetIdByLocator | This is the overview for the GetIdByLocator method overload.
GetLocatorById | This is GetLocatorById, a member of class CacheImpl.
GetMemberHasFetchedValue | This is the overview for the GetMemberHasFetchedValue method overload.
GetMemberPersistenceState | This is the overview for the GetMemberPersistenceState method overload.
GetMemberPolicy | This is GetMemberPolicy, a member of class CacheImpl.
GetObjectContents | This is GetObjectContents, a member of class CacheImpl.
GetPersistenceState | This is GetPersistenceState, a member of class CacheImpl.
GetTimestamp | This is GetTimestamp, a member of class CacheImpl.
GetUmlClass | This is GetUmlClass, a member of class CacheImpl.
InvalidateExtent | This is InvalidateExtent, a member of class CacheImpl.
IsDefaultFetched | This is IsDefaultFetched, a member of class CacheImpl.
IsDirty | This is IsDirty, a member of class CacheImpl.
IsPersistent | This is IsPersistent, a member of class CacheImpl.
MarkObjectDirty | This is MarkObjectDirty, a member of class CacheImpl.
MarkObjectPossiblyCleaner | This is MarkObjectPossiblyCleaner, a member of class CacheImpl.
MemberChanged | This is MemberChanged, a member of class CacheImpl.
OnExistenceChanged | This is OnExistenceChanged, a member of class CacheImpl.
SetCurrentAndFetchedOrderNo | This is SetCurrentAndFetchedOrderNo, a member of class CacheImpl.
SetCurrentAndFetchedValue | This is SetCurrentAndFetchedValue, a member of class CacheImpl.
SetCurrentOrderNo | This is SetCurrentOrderNo, a member of class CacheImpl.
SetCurrentValue | This is SetCurrentValue, a member of class CacheImpl.
SetExistenceState | This is SetExistenceState, a member of class CacheImpl.
SetExtentCurrent | This is SetExtentCurrent, a member of class CacheImpl.
SetFetchedValue | This is SetFetchedValue, a member of class CacheImpl.
SetMemberPersistenceState | This is SetMemberPersistenceState, a member of class CacheImpl.
SetObjectId | This is SetObjectId, a member of class CacheImpl.
SetPersistenceState | This is SetPersistenceState, a member of class CacheImpl.
SetTimestamp | This is SetTimestamp, a member of class CacheImpl.


CacheImpl.ApplyTranslationList Method

CacheImpl.ApplyTranslationList Method
CacheImpl Class Eco.Framework.Impl Namespace See Also
Collapse All
C#
public void ApplyTranslationList(
    IdTranslationList IdTranslationList
);
Remarks

This is ApplyTranslationList, a member of class CacheImpl.

See Also
CacheImpl Class
Eco.Framework.Impl Namespace


CacheImpl.Contains Method

CacheImpl.Contains Method
CacheImpl Class Eco.Framework.Impl Namespace See Also
Collapse All
C#
public bool Contains(
    Eco.Cache.Locator locator
);
Remarks

This is Contains, a member of class CacheImpl.

See Also
CacheImpl Class
Eco.Framework.Impl Namespace


CreateNewObject Method

CreateNewObject Method

This is the overview for the CreateNewObject method overload.

Overload List
Name | Description
CacheImpl.CreateNewObject (IClass) | This is CreateNewObject, a member of class CacheImpl.
CacheImpl.CreateNewObject (IClass, ILoopBack) | This is CreateNewObject, a member of class CacheImpl.


CacheImpl.CreateNewObject Method (IClass)

CacheImpl.CreateNewObject Method (IClass)
CacheImpl Class Eco.Framework.Impl Namespace See Also
Collapse All
C#
public Locator CreateNewObject(
    IClass umlClass
);
Remarks

This is CreateNewObject, a member of class CacheImpl.

See Also
CacheImpl Class
Eco.Framework.Impl Namespace


CacheImpl.CreateNewObject Method (IClass, ILoopBack)

CacheImpl.CreateNewObject Method (IClass, ILoopBack)
CacheImpl Class Eco.Framework.Impl Namespace See Also
Collapse All
C#
public Locator CreateNewObject(
    IClass umlClass,
    ILoopBack loopback
);
Remarks

This is CreateNewObject, a member of class CacheImpl.

See Also
CacheImpl Class
Eco.Framework.Impl Namespace


CacheImpl.DestroyObject Method

CacheImpl.DestroyObject Method
CacheImpl Class Eco.Framework.Impl Namespace See Also
Collapse All
C#
public void DestroyObject(
    Locator locator
);
Remarks

This is DestroyObject, a member of class CacheImpl.

See Also
CacheImpl Class
Eco.Framework.Impl Namespace


CacheImpl.DoActivate Method

CacheImpl.DoActivate Method
CacheImpl Class Eco.Framework.Impl Namespace See Also
Collapse All

Executed by Activate after State has been set to EcoSpacePartState.Activating and before it is set to EcoSpacePartState.Active.

C#
protected override void DoActivate();
See Also
CacheImpl Class
Eco.Framework.Impl Namespace


CacheImpl.DoDeactivate Method

CacheImpl.DoDeactivate Method
CacheImpl Class Eco.Framework.Impl Namespace See Also
Collapse All

Executed by Deactivate after State has been set to EcoSpacePartState.Deactivating and before it is set to EcoSpacePartState.Inactive.

C#
protected override void DoDeactivate();
See Also
CacheImpl Class
Eco.Framework.Impl Namespace


CacheImpl.DoDeserialize Method

CacheImpl.DoDeserialize Method
CacheImpl Class Eco.Framework.Impl Namespace See Also
Collapse All

Executed by Deserialize so that the object may restore it's inner state from the specified stream.

C#
protected override void DoDeserialize(
    Stream source
);
Parameters
Parameters | Description
source | The stream containing previously serialized data.
See Also
CacheImpl Class
Eco.Framework.Impl Namespace


CacheImpl.DoSerialize Method

CacheImpl.DoSerialize Method
CacheImpl Class Eco.Framework.Impl Namespace See Also
Collapse All

Executed by Serialize so that the object may store it's inner state from to specified stream.

C#
protected override void DoSerialize(
    Stream target,
    EcoSpaceSerializationConfig config
);
Parameters
Parameters | Description
target | The stream containing previously serialized data.
config | Additional information passed to the EcoSpace outlining application preferences to be taken into account when serializing.
See Also
CacheImpl Class
Eco.Framework.Impl Namespace


CacheImpl.GetAllLocators Method

CacheImpl.GetAllLocators Method
CacheImpl Class Eco.Framework.Impl Namespace See Also
Collapse All
C#
public Eco.Cache.Locator[] GetAllLocators();
Remarks

This is GetAllLocators, a member of class CacheImpl.

See Also
CacheImpl Class
Eco.Framework.Impl Namespace


GetClassPolicy Method

GetClassPolicy Method

This is the overview for the GetClassPolicy method overload.

Overload List
Name | Description
CacheImpl.GetClassPolicy (CacheLocator) | This is GetClassPolicy, a member of class CacheImpl.
CacheImpl.GetClassPolicy (IClass) | This is GetClassPolicy, a member of class CacheImpl.


CacheImpl.GetClassPolicy Method (CacheLocator)

CacheImpl.GetClassPolicy Method (CacheLocator)
CacheImpl Class Eco.Framework.Impl Namespace See Also
Collapse All
C#
public ClassCachePolicy GetClassPolicy(
    CacheLocator locator
);
Remarks

This is GetClassPolicy, a member of class CacheImpl.

See Also
CacheImpl Class
Eco.Framework.Impl Namespace


CacheImpl.GetClassPolicy Method (IClass)

CacheImpl.GetClassPolicy Method (IClass)
CacheImpl Class Eco.Framework.Impl Namespace See Also
Collapse All
C#
public ClassCachePolicy GetClassPolicy(
    IClass Class_
);
Remarks

This is GetClassPolicy, a member of class CacheImpl.

See Also
CacheImpl Class
Eco.Framework.Impl Namespace


CacheImpl.GetCurrentOrderNo Method

CacheImpl.GetCurrentOrderNo Method
CacheImpl Class Eco.Framework.Impl Namespace See Also
Collapse All
C#
public int GetCurrentOrderNo(
    Locator locator,
    IStructuralFeature StructuralFeature
);
Remarks

This is GetCurrentOrderNo, a member of class CacheImpl.

See Also
CacheImpl Class
Eco.Framework.Impl Namespace


GetCurrentValue Method

GetCurrentValue Method

This is the overview for the GetCurrentValue method overload.

Overload List
Name | Description
CacheImpl.GetCurrentValue (CacheLocator, IStructuralFeature) | This is GetCurrentValue, a member of class CacheImpl.
CacheImpl.GetCurrentValue (Locator, IStructuralFeature) | This is GetCurrentValue, a member of class CacheImpl.


CacheImpl.GetCurrentValue Method (CacheLocator, IStructuralFeature)

CacheImpl.GetCurrentValue Method (CacheLocator, IStructuralFeature)
CacheImpl Class Eco.Framework.Impl Namespace See Also
Collapse All
C#
public object GetCurrentValue(
    CacheLocator locator,
    IStructuralFeature structuralFeature
);
Remarks

This is GetCurrentValue, a member of class CacheImpl.

See Also
CacheImpl Class
Eco.Framework.Impl Namespace


CacheImpl.GetCurrentValue Method (Locator, IStructuralFeature)

CacheImpl.GetCurrentValue Method (Locator, IStructuralFeature)
CacheImpl Class Eco.Framework.Impl Namespace See Also
Collapse All
C#
public object GetCurrentValue(
    Locator locator,
    IStructuralFeature structuralFeature
);
Remarks

This is GetCurrentValue, a member of class CacheImpl.

See Also
CacheImpl Class
Eco.Framework.Impl Namespace


CacheImpl.GetEnsuredLocatorById Method

CacheImpl.GetEnsuredLocatorById Method
CacheImpl Class Eco.Framework.Impl Namespace See Also
Collapse All
C#
public Eco.Cache.Locator GetEnsuredLocatorById(
    ObjectId objectID
);
Remarks

This is GetEnsuredLocatorById, a member of class CacheImpl.

See Also
CacheImpl Class
Eco.Framework.Impl Namespace


CacheImpl.GetExistenceState Method

CacheImpl.GetExistenceState Method
CacheImpl Class Eco.Framework.Impl Namespace See Also
Collapse All
C#
public ExistenceState GetExistenceState(
    Locator locator
);
Remarks

This is GetExistenceState, a member of class CacheImpl.

See Also
CacheImpl Class
Eco.Framework.Impl Namespace


CacheImpl.GetExtentIsCurrent Method

CacheImpl.GetExtentIsCurrent Method
CacheImpl Class Eco.Framework.Impl Namespace See Also
Collapse All
C#
public bool GetExtentIsCurrent(
    IClass c
);
Remarks

This is GetExtentIsCurrent, a member of class CacheImpl.

See Also
CacheImpl Class
Eco.Framework.Impl Namespace


CacheImpl.GetFetchedOrderNo Method

CacheImpl.GetFetchedOrderNo Method
CacheImpl Class Eco.Framework.Impl Namespace See Also
Collapse All
C#
public int GetFetchedOrderNo(
    Locator locator,
    IStructuralFeature structuralFeature
);
Remarks

This is GetFetchedOrderNo, a member of class CacheImpl.

See Also
CacheImpl Class
Eco.Framework.Impl Namespace


GetFetchedValue Method

GetFetchedValue Method

This is the overview for the GetFetchedValue method overload.

Overload List
Name | Description
CacheImpl.GetFetchedValue (CacheLocator, IStructuralFeature) | This is GetFetchedValue, a member of class CacheImpl.
CacheImpl.GetFetchedValue (Eco.Cache.Locator, IStructuralFeature) | This is GetFetchedValue, a member of class CacheImpl.


CacheImpl.GetFetchedValue Method (CacheLocator, IStructuralFeature)

CacheImpl.GetFetchedValue Method (CacheLocator, IStructuralFeature)
CacheImpl Class Eco.Framework.Impl Namespace See Also
Collapse All
C#
public object GetFetchedValue(
    CacheLocator locator,
    IStructuralFeature structuralFeature
);
Remarks

This is GetFetchedValue, a member of class CacheImpl.

See Also
CacheImpl Class
Eco.Framework.Impl Namespace


CacheImpl.GetFetchedValue Method (Eco.Cache.Locator, IStructuralFeature)

CacheImpl.GetFetchedValue Method (Eco.Cache.Locator, IStructuralFeature)
CacheImpl Class Eco.Framework.Impl Namespace See Also
Collapse All
C#
public object GetFetchedValue(
    Eco.Cache.Locator locator,
    IStructuralFeature structuralFeature
);
Remarks

This is GetFetchedValue, a member of class CacheImpl.

See Also
CacheImpl Class
Eco.Framework.Impl Namespace


GetIdByLocator Method

GetIdByLocator Method

This is the overview for the GetIdByLocator method overload.

Overload List
Name | Description
CacheImpl.GetIdByLocator (CacheLocator) | This is GetIdByLocator, a member of class CacheImpl.
CacheImpl.GetIdByLocator (Eco.Cache.Locator) | This is GetIdByLocator, a member of class CacheImpl.


CacheImpl.GetIdByLocator Method (CacheLocator)

CacheImpl.GetIdByLocator Method (CacheLocator)
CacheImpl Class Eco.Framework.Impl Namespace See Also
Collapse All
C#
public ObjectId GetIdByLocator(
    CacheLocator locator
);
Remarks

This is GetIdByLocator, a member of class CacheImpl.

See Also
CacheImpl Class
Eco.Framework.Impl Namespace


CacheImpl.GetIdByLocator Method (Eco.Cache.Locator)

CacheImpl.GetIdByLocator Method (Eco.Cache.Locator)
CacheImpl Class Eco.Framework.Impl Namespace See Also
Collapse All
C#
public ObjectId GetIdByLocator(
    Eco.Cache.Locator locator
);
Remarks

This is GetIdByLocator, a member of class CacheImpl.

See Also
CacheImpl Class
Eco.Framework.Impl Namespace


CacheImpl.GetLocatorById Method

CacheImpl.GetLocatorById Method
CacheImpl Class Eco.Framework.Impl Namespace See Also
Collapse All
C#
public Eco.Cache.Locator GetLocatorById(
    ObjectId objectId
);
Remarks

This is GetLocatorById, a member of class CacheImpl.

See Also
CacheImpl Class
Eco.Framework.Impl Namespace


GetMemberHasFetchedValue Method

GetMemberHasFetchedValue Method

This is the overview for the GetMemberHasFetchedValue method overload.

Overload List
Name | Description
CacheImpl.GetMemberHasFetchedValue (CacheLocator, IStructuralFeature) | This is GetMemberHasFetchedValue, a member of class CacheImpl.
CacheImpl.GetMemberHasFetchedValue (Eco.Cache.Locator, IStructuralFeature) | This is GetMemberHasFetchedValue, a member of class CacheImpl.


CacheImpl.GetMemberHasFetchedValue Method (CacheLocator, IStructuralFeature)

CacheImpl.GetMemberHasFetchedValue Method (CacheLocator, IStructuralFeature)
CacheImpl Class Eco.Framework.Impl Namespace See Also
Collapse All
C#
public bool GetMemberHasFetchedValue(
    CacheLocator locator,
    IStructuralFeature structuralFeature
);
Remarks

This is GetMemberHasFetchedValue, a member of class CacheImpl.

See Also
CacheImpl Class
Eco.Framework.Impl Namespace


CacheImpl.GetMemberHasFetchedValue Method (Eco.Cache.Locator, IStructuralFeature)

CacheImpl.GetMemberHasFetchedValue Method (Eco.Cache.Locator, IStructuralFeature)
CacheImpl Class Eco.Framework.Impl Namespace See Also
Collapse All
C#
public bool GetMemberHasFetchedValue(
    Eco.Cache.Locator locator,
    IStructuralFeature structuralFeature
);
Remarks

This is GetMemberHasFetchedValue, a member of class CacheImpl.

See Also
CacheImpl Class
Eco.Framework.Impl Namespace


GetMemberPersistenceState Method

GetMemberPersistenceState Method

This is the overview for the GetMemberPersistenceState method overload.

Overload List
Name | Description
CacheImpl.GetMemberPersistenceState (CacheLocator, IStructuralFeature) | This is GetMemberPersistenceState, a member of class CacheImpl.
CacheImpl.GetMemberPersistenceState (Locator, IStructuralFeature) | This is GetMemberPersistenceState, a member of class CacheImpl.


CacheImpl.GetMemberPersistenceState Method (CacheLocator, IStructuralFeature)

CacheImpl.GetMemberPersistenceState Method (CacheLocator, IStructuralFeature)
CacheImpl Class Eco.Framework.Impl Namespace See Also
Collapse All
C#
public PersistenceState GetMemberPersistenceState(
    CacheLocator locator,
    IStructuralFeature structuralFeature
);
Remarks

This is GetMemberPersistenceState, a member of class CacheImpl.

See Also
CacheImpl Class
Eco.Framework.Impl Namespace


CacheImpl.GetMemberPersistenceState Method (Locator, IStructuralFeature)

CacheImpl.GetMemberPersistenceState Method (Locator, IStructuralFeature)
CacheImpl Class Eco.Framework.Impl Namespace See Also
Collapse All
C#
public PersistenceState GetMemberPersistenceState(
    Locator locator,
    IStructuralFeature structuralFeature
);
Remarks

This is GetMemberPersistenceState, a member of class CacheImpl.

See Also
CacheImpl Class
Eco.Framework.Impl Namespace


CacheImpl.GetMemberPolicy Method

CacheImpl.GetMemberPolicy Method
CacheImpl Class Eco.Framework.Impl Namespace See Also
Collapse All
C#
public MemberCachePolicy GetMemberPolicy(
    IStructuralFeature member
);
Remarks

This is GetMemberPolicy, a member of class CacheImpl.

See Also
CacheImpl Class
Eco.Framework.Impl Namespace


CacheImpl.GetObjectContents Method

CacheImpl.GetObjectContents Method
CacheImpl Class Eco.Framework.Impl Namespace See Also
Collapse All
C#
public object[] GetObjectContents(
    CacheLocator locator
);
Remarks

This is GetObjectContents, a member of class CacheImpl.

See Also
CacheImpl Class
Eco.Framework.Impl Namespace


CacheImpl.GetPersistenceState Method

CacheImpl.GetPersistenceState Method
CacheImpl Class Eco.Framework.Impl Namespace See Also
Collapse All
C#
public PersistenceState GetPersistenceState(
    Locator locator
);
Remarks

This is GetPersistenceState, a member of class CacheImpl.

See Also
CacheImpl Class
Eco.Framework.Impl Namespace


CacheImpl.GetTimestamp Method

CacheImpl.GetTimestamp Method
CacheImpl Class Eco.Framework.Impl Namespace See Also
Collapse All
C#
public int GetTimestamp(
    Eco.Cache.Locator locator
);
Remarks

This is GetTimestamp, a member of class CacheImpl.

See Also
CacheImpl Class
Eco.Framework.Impl Namespace


CacheImpl.GetUmlClass Method

CacheImpl.GetUmlClass Method
CacheImpl Class Eco.Framework.Impl Namespace See Also
Collapse All
C#
public IClass GetUmlClass(
    Locator locator
);
Remarks

This is GetUmlClass, a member of class CacheImpl.

See Also
CacheImpl Class
Eco.Framework.Impl Namespace


CacheImpl.InvalidateExtent Method

CacheImpl.InvalidateExtent Method
CacheImpl Class Eco.Framework.Impl Namespace See Also
Collapse All
C#
public void InvalidateExtent(
    IClass umlClass
);
Remarks

This is InvalidateExtent, a member of class CacheImpl.

See Also
CacheImpl Class
Eco.Framework.Impl Namespace


CacheImpl.IsDefaultFetched Method

CacheImpl.IsDefaultFetched Method
CacheImpl Class Eco.Framework.Impl Namespace See Also
Collapse All
C#
public bool IsDefaultFetched(
    Eco.Cache.Locator locator
);
Remarks

This is IsDefaultFetched, a member of class CacheImpl.

See Also
CacheImpl Class
Eco.Framework.Impl Namespace


CacheImpl.IsDirty Method

CacheImpl.IsDirty Method
CacheImpl Class Eco.Framework.Impl Namespace See Also
Collapse All
C#
public bool IsDirty(
    Eco.Cache.Locator locator
);
Remarks

This is IsDirty, a member of class CacheImpl.

See Also
CacheImpl Class
Eco.Framework.Impl Namespace


CacheImpl.IsPersistent Method

CacheImpl.IsPersistent Method
CacheImpl Class Eco.Framework.Impl Namespace See Also
Collapse All
C#
public bool IsPersistent(
    Eco.Cache.Locator locator
);
Remarks

This is IsPersistent, a member of class CacheImpl.

See Also
CacheImpl Class
Eco.Framework.Impl Namespace


CacheImpl.MarkObjectDirty Method

CacheImpl.MarkObjectDirty Method
CacheImpl Class Eco.Framework.Impl Namespace See Also
Collapse All
C#
public void MarkObjectDirty(
    CacheLocator locator
);
Remarks

This is MarkObjectDirty, a member of class CacheImpl.

See Also
CacheImpl Class
Eco.Framework.Impl Namespace


CacheImpl.MarkObjectPossiblyCleaner Method

CacheImpl.MarkObjectPossiblyCleaner Method
CacheImpl Class Eco.Framework.Impl Namespace See Also
Collapse All
C#
public void MarkObjectPossiblyCleaner(
    CacheLocator locator
);
Remarks

This is MarkObjectPossiblyCleaner, a member of class CacheImpl.

See Also
CacheImpl Class
Eco.Framework.Impl Namespace


CacheImpl.MemberChanged Method

CacheImpl.MemberChanged Method
CacheImpl Class Eco.Framework.Impl Namespace See Also
Collapse All
C#
public void MemberChanged(
    CacheLocator locator,
    IStructuralFeature structuralFeature
);
Remarks

This is MemberChanged, a member of class CacheImpl.

See Also
CacheImpl Class
Eco.Framework.Impl Namespace


CacheImpl.OnExistenceChanged Method

CacheImpl.OnExistenceChanged Method
CacheImpl Class Eco.Framework.Impl Namespace See Also
Collapse All
C#
public void OnExistenceChanged(
    CacheLocator locator
);
Remarks

This is OnExistenceChanged, a member of class CacheImpl.

See Also
CacheImpl Class
Eco.Framework.Impl Namespace


CacheImpl.SetCurrentAndFetchedOrderNo Method

CacheImpl.SetCurrentAndFetchedOrderNo Method
CacheImpl Class Eco.Framework.Impl Namespace See Also
Collapse All
C#
public void SetCurrentAndFetchedOrderNo(
    Locator locator,
    IStructuralFeature StructuralFeature,
    int orderNo
);
Remarks

This is SetCurrentAndFetchedOrderNo, a member of class CacheImpl.

See Also
CacheImpl Class
Eco.Framework.Impl Namespace


CacheImpl.SetCurrentAndFetchedValue Method

CacheImpl.SetCurrentAndFetchedValue Method
CacheImpl Class Eco.Framework.Impl Namespace See Also
Collapse All
C#
public void SetCurrentAndFetchedValue(
    Eco.Cache.Locator locator,
    IStructuralFeature structuralFeature,
    object value
);
Remarks

This is SetCurrentAndFetchedValue, a member of class CacheImpl.

See Also
CacheImpl Class
Eco.Framework.Impl Namespace


CacheImpl.SetCurrentOrderNo Method

CacheImpl.SetCurrentOrderNo Method
CacheImpl Class Eco.Framework.Impl Namespace See Also
Collapse All
C#
public void SetCurrentOrderNo(
    Locator locator,
    IStructuralFeature structuralFeature,
    int orderNo
);
Remarks

This is SetCurrentOrderNo, a member of class CacheImpl.

See Also
CacheImpl Class
Eco.Framework.Impl Namespace


CacheImpl.SetCurrentValue Method

CacheImpl.SetCurrentValue Method
CacheImpl Class Eco.Framework.Impl Namespace See Also
Collapse All
C#
public void SetCurrentValue(
    Locator locator,
    IStructuralFeature StructuralFeature,
    object value
);
Remarks

This is SetCurrentValue, a member of class CacheImpl.

See Also
CacheImpl Class
Eco.Framework.Impl Namespace


CacheImpl.SetExistenceState Method

CacheImpl.SetExistenceState Method
CacheImpl Class Eco.Framework.Impl Namespace See Also
Collapse All
C#
public void SetExistenceState(
    Locator locator,
    ExistenceState value
);
Remarks

This is SetExistenceState, a member of class CacheImpl.

See Also
CacheImpl Class
Eco.Framework.Impl Namespace


CacheImpl.SetExtentCurrent Method

CacheImpl.SetExtentCurrent Method
CacheImpl Class Eco.Framework.Impl Namespace See Also
Collapse All
C#
public void SetExtentCurrent(
    IClass umlClass
);
Remarks

This is SetExtentCurrent, a member of class CacheImpl.

See Also
CacheImpl Class
Eco.Framework.Impl Namespace


CacheImpl.SetFetchedValue Method

CacheImpl.SetFetchedValue Method
CacheImpl Class Eco.Framework.Impl Namespace See Also
Collapse All
C#
public void SetFetchedValue(
    Eco.Cache.Locator locator,
    IStructuralFeature structuralFeature,
    object value
);
Remarks

This is SetFetchedValue, a member of class CacheImpl.

See Also
CacheImpl Class
Eco.Framework.Impl Namespace


CacheImpl.SetMemberPersistenceState Method

CacheImpl.SetMemberPersistenceState Method
CacheImpl Class Eco.Framework.Impl Namespace See Also
Collapse All
C#
public void SetMemberPersistenceState(
    Locator locator,
    IStructuralFeature structuralFeature,
    PersistenceState value
);
Remarks

This is SetMemberPersistenceState, a member of class CacheImpl.

See Also
CacheImpl Class
Eco.Framework.Impl Namespace


CacheImpl.SetObjectId Method

CacheImpl.SetObjectId Method
CacheImpl Class Eco.Framework.Impl Namespace See Also
Collapse All
C#
public void SetObjectId(
    Locator locator,
    ObjectId newId
);
Remarks

This is SetObjectId, a member of class CacheImpl.

See Also
CacheImpl Class
Eco.Framework.Impl Namespace


CacheImpl.SetPersistenceState Method

CacheImpl.SetPersistenceState Method
CacheImpl Class Eco.Framework.Impl Namespace See Also
Collapse All
C#
public void SetPersistenceState(
    Locator locator,
    PersistenceState value
);
Remarks

This is SetPersistenceState, a member of class CacheImpl.

See Also
CacheImpl Class
Eco.Framework.Impl Namespace


CacheImpl.SetTimestamp Method

CacheImpl.SetTimestamp Method
CacheImpl Class Eco.Framework.Impl Namespace See Also
Collapse All
C#
public void SetTimestamp(
    Eco.Cache.Locator locator,
    int value
);
Remarks

This is SetTimestamp, a member of class CacheImpl.

See Also
CacheImpl Class
Eco.Framework.Impl Namespace


CacheImpl Properties

CacheImpl Properties
Public Properties
Collapse All

The properties of the CacheImpl class are listed here.

Public Properties
Name | Description
DeleteStack | This is DeleteStack, a member of class CacheImpl.
IsActive | This is IsActive, a member of class CacheImpl.
LocatorFactory | This is LocatorFactory, a member of class CacheImpl.
Persistent | This is Persistent, a member of class CacheImpl.


CacheImpl.DeleteStack Property

CacheImpl.DeleteStack Property
CacheImpl Class Eco.Framework.Impl Namespace See Also
Collapse All
C#
public ICollection<Locator> DeleteStack;
Remarks

This is DeleteStack, a member of class CacheImpl.

See Also
CacheImpl Class
Eco.Framework.Impl Namespace


CacheImpl.IsActive Property

CacheImpl.IsActive Property
CacheImpl Class Eco.Framework.Impl Namespace See Also
Collapse All
C#
public bool IsActive;
Remarks

This is IsActive, a member of class CacheImpl.

See Also
CacheImpl Class
Eco.Framework.Impl Namespace


CacheImpl.LocatorFactory Property

CacheImpl.LocatorFactory Property
CacheImpl Class Eco.Framework.Impl Namespace See Also
Collapse All
C#
public LocatorFactory LocatorFactory;
Remarks

This is LocatorFactory, a member of class CacheImpl.

See Also
CacheImpl Class
Eco.Framework.Impl Namespace


CacheImpl.Persistent Property

CacheImpl.Persistent Property
CacheImpl Class Eco.Framework.Impl Namespace See Also
Collapse All
C#
public bool Persistent;
Remarks

This is Persistent, a member of class CacheImpl.

See Also
CacheImpl Class
Eco.Framework.Impl Namespace


CacheImpl Events

CacheImpl Events
Public Events
Collapse All

The events of the CacheImpl class are listed here.

Public Events
Name | Description
CanRelease | This is CanRelease, a member of class CacheImpl.
DirtyChanged | This is DirtyChanged, a member of class CacheImpl.
ExistenceChanged | This is ExistenceChanged, a member of class CacheImpl.
ExtentInvalidated | This is ExtentInvalidated, a member of class CacheImpl.
LocatorAdded | This is LocatorAdded, a member of class CacheImpl.
ValueChanged | This is ValueChanged, a member of class CacheImpl.


CacheImpl.CanRelease Event

CacheImpl.CanRelease Event
CacheImpl Class Eco.Framework.Impl Namespace See Also
Collapse All
C#
public event CanReleaseDelegate CanRelease;
Remarks

This is CanRelease, a member of class CacheImpl.

See Also
CacheImpl Class
Eco.Framework.Impl Namespace


CacheImpl.DirtyChanged Event

CacheImpl.DirtyChanged Event
CacheImpl Class Eco.Framework.Impl Namespace See Also
Collapse All
C#
public event LocatorEventHandler DirtyChanged;
Remarks

This is DirtyChanged, a member of class CacheImpl.

See Also
CacheImpl Class
Eco.Framework.Impl Namespace


CacheImpl.ExistenceChanged Event

CacheImpl.ExistenceChanged Event
CacheImpl Class Eco.Framework.Impl Namespace See Also
Collapse All
C#
public event LocatorEventHandler ExistenceChanged;
Remarks

This is ExistenceChanged, a member of class CacheImpl.

See Also
CacheImpl Class
Eco.Framework.Impl Namespace


CacheImpl.ExtentInvalidated Event

CacheImpl.ExtentInvalidated Event
CacheImpl Class Eco.Framework.Impl Namespace See Also
Collapse All
C#
public event ExtentChangedEventHandler ExtentInvalidated;
Remarks

This is ExtentInvalidated, a member of class CacheImpl.

See Also
CacheImpl Class
Eco.Framework.Impl Namespace


CacheImpl.LocatorAdded Event

CacheImpl.LocatorAdded Event
CacheImpl Class Eco.Framework.Impl Namespace See Also
Collapse All
C#
public event LocatorEventHandler LocatorAdded;
Remarks

This is LocatorAdded, a member of class CacheImpl.

See Also
CacheImpl Class
Eco.Framework.Impl Namespace


CacheImpl.ValueChanged Event

CacheImpl.ValueChanged Event
CacheImpl Class Eco.Framework.Impl Namespace See Also
Collapse All
C#
public event Eco.Cache.ValueChangedDelegate ValueChanged;
Remarks

This is ValueChanged, a member of class CacheImpl.

See Also
CacheImpl Class
Eco.Framework.Impl Namespace


CacheLocator Class

CacheLocator Class
Inheritance Hierarchy See Also
Collapse All
C#
public abstract class CacheLocator : Locator;
Remarks

This is class Eco.Framework.Impl.CacheLocator.

Inheritance Hierarchy
Eco.Framework.Impl.CacheLocator
    Eco.Framework.Impl.Frontside.DefaultFrontsideLocator
File

CacheLocator.cs

See Also
Inheritance Hierarchy


CacheLocator.CacheLocator Constructor

CacheLocator.CacheLocator Constructor
CacheLocator Class Eco.Framework.Impl Namespace See Also
Collapse All
C#
public CacheLocator();
Remarks

This is CacheLocator, a member of class CacheLocator.

See Also
CacheLocator Class
Eco.Framework.Impl Namespace


CacheLocator Properties

CacheLocator Properties
Public Properties
Collapse All

The properties of the CacheLocator class are listed here.

Public Properties
Name | Description
Contents | This is Contents, a member of class CacheLocator.
Id | This is Id, a member of class CacheLocator.
ObjectId | This is ObjectId, a member of class CacheLocator.
UmlClass | This is UmlClass, a member of class CacheLocator.


CacheLocator.Contents Property

CacheLocator.Contents Property
CacheLocator Class Eco.Framework.Impl Namespace See Also
Collapse All
C#
public object Contents;
Remarks

This is Contents, a member of class CacheLocator.

See Also
CacheLocator Class
Eco.Framework.Impl Namespace


CacheLocator.Id Property

CacheLocator.Id Property
CacheLocator Class Eco.Framework.Impl Namespace See Also
Collapse All
C#
public override ObjectId Id;
Remarks

This is Id, a member of class CacheLocator.

See Also
CacheLocator Class
Eco.Framework.Impl Namespace


CacheLocator.ObjectId Property

CacheLocator.ObjectId Property
CacheLocator Class Eco.Framework.Impl Namespace See Also
Collapse All
C#
public ObjectId ObjectId;
Remarks

This is ObjectId, a member of class CacheLocator.

See Also
CacheLocator Class
Eco.Framework.Impl Namespace


CacheLocator.UmlClass Property

CacheLocator.UmlClass Property
CacheLocator Class Eco.Framework.Impl Namespace See Also
Collapse All
C#
public abstract IClass UmlClass;
Remarks

This is UmlClass, a member of class CacheLocator.

See Also
CacheLocator Class
Eco.Framework.Impl Namespace


CacheMultilinkAdapter Class

CacheMultilinkAdapter Class
Inheritance Hierarchy See Also
Collapse All
C#
public abstract class CacheMultilinkAdapter : IList;
Remarks

This is class Eco.Framework.Impl.CacheMultilinkAdapter.

Inheritance Hierarchy
Eco.Framework.Impl.CacheMultilinkAdapter
    Eco.Framework.Impl.CacheMultilinkCurrentValueAdapter
    Eco.Framework.Impl.CacheMultilinkFetchedValueAdapter
File

CacheMultilinkAdapter.cs

See Also
Inheritance Hierarchy


CacheMultilinkAdapter.CacheMultilinkAdapter Constructor

CacheMultilinkAdapter.CacheMultilinkAdapter Constructor
CacheMultilinkAdapter Class Eco.Framework.Impl Namespace See Also
Collapse All
C#
public CacheMultilinkAdapter(
    CacheLocator locator,
    MultiAssociationEndCachePolicy listController
);
Remarks

This is CacheMultilinkAdapter, a member of class CacheMultilinkAdapter.

See Also
CacheMultilinkAdapter Class
Eco.Framework.Impl Namespace


CacheMultilinkAdapter Methods

CacheMultilinkAdapter Methods
Public Methods
Collapse All

The methods of the CacheMultilinkAdapter class are listed here.

Public Methods
Name | Description
Add | This is Add, a member of class CacheMultilinkAdapter.
Clear | This is Clear, a member of class CacheMultilinkAdapter.
Contains | This is Contains, a member of class CacheMultilinkAdapter.
CopyTo | This is CopyTo, a member of class CacheMultilinkAdapter.
GetEnumerator | This is GetEnumerator, a member of class CacheMultilinkAdapter.
IndexOf | This is IndexOf, a member of class CacheMultilinkAdapter.
Insert | This is Insert, a member of class CacheMultilinkAdapter.
Remove | This is Remove, a member of class CacheMultilinkAdapter.
RemoveAt | This is RemoveAt, a member of class CacheMultilinkAdapter.
this | This is this, a member of class CacheMultilinkAdapter.


CacheMultilinkAdapter.Add Method

CacheMultilinkAdapter.Add Method
CacheMultilinkAdapter Class Eco.Framework.Impl Namespace See Also
Collapse All
C#
public int Add(
    object value
);
Remarks

This is Add, a member of class CacheMultilinkAdapter.

See Also
CacheMultilinkAdapter Class
Eco.Framework.Impl Namespace


CacheMultilinkAdapter.Clear Method

CacheMultilinkAdapter.Clear Method
CacheMultilinkAdapter Class Eco.Framework.Impl Namespace See Also
Collapse All
C#
public void Clear();
Remarks

This is Clear, a member of class CacheMultilinkAdapter.

See Also
CacheMultilinkAdapter Class
Eco.Framework.Impl Namespace


CacheMultilinkAdapter.Contains Method

CacheMultilinkAdapter.Contains Method
CacheMultilinkAdapter Class Eco.Framework.Impl Namespace See Also
Collapse All
C#
public abstract bool Contains(
    object value
);
Remarks

This is Contains, a member of class CacheMultilinkAdapter.

See Also
CacheMultilinkAdapter Class
Eco.Framework.Impl Namespace


CacheMultilinkAdapter.CopyTo Method

CacheMultilinkAdapter.CopyTo Method
CacheMultilinkAdapter Class Eco.Framework.Impl Namespace See Also
Collapse All
C#
public void CopyTo(
    System.Array arr,
    int index
);
Remarks

This is CopyTo, a member of class CacheMultilinkAdapter.

See Also
CacheMultilinkAdapter Class
Eco.Framework.Impl Namespace


CacheMultilinkAdapter.GetEnumerator Method

CacheMultilinkAdapter.GetEnumerator Method
CacheMultilinkAdapter Class Eco.Framework.Impl Namespace See Also
Collapse All
C#
public IEnumerator GetEnumerator();
Remarks

This is GetEnumerator, a member of class CacheMultilinkAdapter.

See Also
CacheMultilinkAdapter Class
Eco.Framework.Impl Namespace


CacheMultilinkAdapter.IndexOf Method

CacheMultilinkAdapter.IndexOf Method
CacheMultilinkAdapter Class Eco.Framework.Impl Namespace See Also
Collapse All
C#
public abstract int IndexOf(
    object value
);
Remarks

This is IndexOf, a member of class CacheMultilinkAdapter.

See Also
CacheMultilinkAdapter Class
Eco.Framework.Impl Namespace


CacheMultilinkAdapter.Insert Method

CacheMultilinkAdapter.Insert Method
CacheMultilinkAdapter Class Eco.Framework.Impl Namespace See Also
Collapse All
C#
public void Insert(
    int index,
    object value
);
Remarks

This is Insert, a member of class CacheMultilinkAdapter.

See Also
CacheMultilinkAdapter Class
Eco.Framework.Impl Namespace


CacheMultilinkAdapter.Remove Method

CacheMultilinkAdapter.Remove Method
CacheMultilinkAdapter Class Eco.Framework.Impl Namespace See Also
Collapse All
C#
public void Remove(
    object value
);
Remarks

This is Remove, a member of class CacheMultilinkAdapter.

See Also
CacheMultilinkAdapter Class
Eco.Framework.Impl Namespace


CacheMultilinkAdapter.RemoveAt Method

CacheMultilinkAdapter.RemoveAt Method
CacheMultilinkAdapter Class Eco.Framework.Impl Namespace See Also
Collapse All
C#
public void RemoveAt(
    int index
);
Remarks

This is RemoveAt, a member of class CacheMultilinkAdapter.

See Also
CacheMultilinkAdapter Class
Eco.Framework.Impl Namespace


CacheMultilinkAdapter.this Indexer

CacheMultilinkAdapter.this Indexer
CacheMultilinkAdapter Class Eco.Framework.Impl Namespace See Also
Collapse All
C#
public virtual object this[
    int index
];
Remarks

This is this, a member of class CacheMultilinkAdapter.

See Also
CacheMultilinkAdapter Class
Eco.Framework.Impl Namespace


CacheMultilinkAdapter Properties

CacheMultilinkAdapter Properties
Public Properties Protected Properties
Collapse All

The properties of the CacheMultilinkAdapter class are listed here.

Public Properties
Name | Description
Count | This is Count, a member of class CacheMultilinkAdapter.
IsFixedSize | This is IsFixedSize, a member of class CacheMultilinkAdapter.
IsReadOnly | This is IsReadOnly, a member of class CacheMultilinkAdapter.
IsSynchronized | This is IsSynchronized, a member of class CacheMultilinkAdapter.
SyncRoot | This is SyncRoot, a member of class CacheMultilinkAdapter.
Top
Protected Properties
Name | Description
ListController | This is ListController, a member of class CacheMultilinkAdapter.
Locator | This is Locator, a member of class CacheMultilinkAdapter.


CacheMultilinkAdapter.Count Property

CacheMultilinkAdapter.Count Property
CacheMultilinkAdapter Class Eco.Framework.Impl Namespace See Also
Collapse All
C#
public abstract int Count;
Remarks

This is Count, a member of class CacheMultilinkAdapter.

See Also
CacheMultilinkAdapter Class
Eco.Framework.Impl Namespace


CacheMultilinkAdapter.IsFixedSize Property

CacheMultilinkAdapter.IsFixedSize Property
CacheMultilinkAdapter Class Eco.Framework.Impl Namespace See Also
Collapse All
C#
public bool IsFixedSize;
Remarks

This is IsFixedSize, a member of class CacheMultilinkAdapter.

See Also
CacheMultilinkAdapter Class
Eco.Framework.Impl Namespace


CacheMultilinkAdapter.IsReadOnly Property

CacheMultilinkAdapter.IsReadOnly Property
CacheMultilinkAdapter Class Eco.Framework.Impl Namespace See Also
Collapse All
C#
public bool IsReadOnly;
Remarks

This is IsReadOnly, a member of class CacheMultilinkAdapter.

See Also
CacheMultilinkAdapter Class
Eco.Framework.Impl Namespace


CacheMultilinkAdapter.IsSynchronized Property

CacheMultilinkAdapter.IsSynchronized Property
CacheMultilinkAdapter Class Eco.Framework.Impl Namespace See Also
Collapse All
C#
public bool IsSynchronized;
Remarks

This is IsSynchronized, a member of class CacheMultilinkAdapter.

See Also
CacheMultilinkAdapter Class
Eco.Framework.Impl Namespace


CacheMultilinkAdapter.ListController Property

CacheMultilinkAdapter.ListController Property
CacheMultilinkAdapter Class Eco.Framework.Impl Namespace See Also
Collapse All
C#
protected MultiAssociationEndCachePolicy ListController;
Remarks

This is ListController, a member of class CacheMultilinkAdapter.

See Also
CacheMultilinkAdapter Class
Eco.Framework.Impl Namespace


CacheMultilinkAdapter.Locator Property

CacheMultilinkAdapter.Locator Property
CacheMultilinkAdapter Class Eco.Framework.Impl Namespace See Also
Collapse All
C#
protected CacheLocator Locator;
Remarks

This is Locator, a member of class CacheMultilinkAdapter.

See Also
CacheMultilinkAdapter Class
Eco.Framework.Impl Namespace


CacheMultilinkAdapter.SyncRoot Property

CacheMultilinkAdapter.SyncRoot Property
CacheMultilinkAdapter Class Eco.Framework.Impl Namespace See Also
Collapse All
C#
public object SyncRoot;
Remarks

This is SyncRoot, a member of class CacheMultilinkAdapter.

See Also
CacheMultilinkAdapter Class
Eco.Framework.Impl Namespace


CacheMultilinkCurrentValueAdapter Class

CacheMultilinkCurrentValueAdapter Class
Inheritance Hierarchy See Also
Collapse All
C#
public class CacheMultilinkCurrentValueAdapter : CacheMultilinkAdapter;
Remarks

This is class Eco.Framework.Impl.CacheMultilinkCurrentValueAdapter.

Inheritance Hierarchy
Eco.Framework.Impl.CacheMultilinkAdapter
    Eco.Framework.Impl.CacheMultilinkCurrentValueAdapter
File

CacheMultilinkAdapter.cs

See Also
Inheritance Hierarchy


CacheMultilinkCurrentValueAdapter.CacheMultilinkCurrentValueAdapter Constructor

CacheMultilinkCurrentValueAdapter.CacheMultilinkCurrentValueAdapter Constructor
CacheMultilinkCurrentValueAdapter Class Eco.Framework.Impl Namespace See Also
Collapse All
C#
public CacheMultilinkCurrentValueAdapter(
    CacheLocator OwningObject,
    MultiAssociationEndCachePolicy ListController
);
Remarks

This is CacheMultilinkCurrentValueAdapter, a member of class CacheMultilinkCurrentValueAdapter.

See Also
CacheMultilinkCurrentValueAdapter Class
Eco.Framework.Impl Namespace


CacheMultilinkCurrentValueAdapter Methods

CacheMultilinkCurrentValueAdapter Methods
Public Methods
Collapse All

The methods of the CacheMultilinkCurrentValueAdapter class are listed here.

Public Methods
Name | Description
Contains | This is Contains, a member of class CacheMultilinkCurrentValueAdapter.
IndexOf | This is IndexOf, a member of class CacheMultilinkCurrentValueAdapter.
this | This is this, a member of class CacheMultilinkCurrentValueAdapter.


CacheMultilinkCurrentValueAdapter.Contains Method

CacheMultilinkCurrentValueAdapter.Contains Method
CacheMultilinkCurrentValueAdapter Class Eco.Framework.Impl Namespace See Also
Collapse All
C#
public override bool Contains(
    object value
);
Remarks

This is Contains, a member of class CacheMultilinkCurrentValueAdapter.

See Also
CacheMultilinkCurrentValueAdapter Class
Eco.Framework.Impl Namespace


CacheMultilinkCurrentValueAdapter.IndexOf Method

CacheMultilinkCurrentValueAdapter.IndexOf Method
CacheMultilinkCurrentValueAdapter Class Eco.Framework.Impl Namespace See Also
Collapse All
C#
public override int IndexOf(
    object value
);
Remarks

This is IndexOf, a member of class CacheMultilinkCurrentValueAdapter.

See Also
CacheMultilinkCurrentValueAdapter Class
Eco.Framework.Impl Namespace


CacheMultilinkCurrentValueAdapter.this Indexer

CacheMultilinkCurrentValueAdapter.this Indexer
CacheMultilinkCurrentValueAdapter Class Eco.Framework.Impl Namespace See Also
Collapse All
C#
public override object this[
    int index
];
Remarks

This is this, a member of class CacheMultilinkCurrentValueAdapter.

See Also
CacheMultilinkCurrentValueAdapter Class
Eco.Framework.Impl Namespace


CacheMultilinkCurrentValueAdapter Properties

CacheMultilinkCurrentValueAdapter Properties
Public Properties
Collapse All

The properties of the CacheMultilinkCurrentValueAdapter class are listed here.

Public Properties
Name | Description
Count | This is Count, a member of class CacheMultilinkCurrentValueAdapter.


CacheMultilinkCurrentValueAdapter.Count Property

CacheMultilinkCurrentValueAdapter.Count Property
CacheMultilinkCurrentValueAdapter Class Eco.Framework.Impl Namespace See Also
Collapse All
C#
public override int Count;
Remarks

This is Count, a member of class CacheMultilinkCurrentValueAdapter.

See Also
CacheMultilinkCurrentValueAdapter Class
Eco.Framework.Impl Namespace


CacheMultilinkEnumerator Class

CacheMultilinkEnumerator Class
Inheritance Hierarchy See Also
Collapse All
C#
public class CacheMultilinkEnumerator : IEnumerator;
Remarks

This is class Eco.Framework.Impl.CacheMultilinkEnumerator.

Inheritance Hierarchy
Eco.Framework.Impl.CacheMultilinkEnumerator
File

CacheMultilinkAdapter.cs

See Also
Inheritance Hierarchy


CacheMultilinkEnumerator.CacheMultilinkEnumerator Constructor

CacheMultilinkEnumerator.CacheMultilinkEnumerator Constructor
CacheMultilinkEnumerator Class Eco.Framework.Impl Namespace See Also
Collapse All
C#
public CacheMultilinkEnumerator(
    CacheMultilinkAdapter adapter
);
Remarks

This is CacheMultilinkEnumerator, a member of class CacheMultilinkEnumerator.

See Also
CacheMultilinkEnumerator Class
Eco.Framework.Impl Namespace


CacheMultilinkEnumerator Methods

CacheMultilinkEnumerator Methods
Public Methods
Collapse All

The methods of the CacheMultilinkEnumerator class are listed here.

Public Methods
Name | Description
MoveNext | This is MoveNext, a member of class CacheMultilinkEnumerator.
Reset | This is Reset, a member of class CacheMultilinkEnumerator.


CacheMultilinkEnumerator.MoveNext Method

CacheMultilinkEnumerator.MoveNext Method
CacheMultilinkEnumerator Class Eco.Framework.Impl Namespace See Also
Collapse All
C#
public bool MoveNext();
Remarks

This is MoveNext, a member of class CacheMultilinkEnumerator.

See Also
CacheMultilinkEnumerator Class
Eco.Framework.Impl Namespace


CacheMultilinkEnumerator.Reset Method

CacheMultilinkEnumerator.Reset Method
CacheMultilinkEnumerator Class Eco.Framework.Impl Namespace See Also
Collapse All
C#
public void Reset();
Remarks

This is Reset, a member of class CacheMultilinkEnumerator.

See Also
CacheMultilinkEnumerator Class
Eco.Framework.Impl Namespace


CacheMultilinkEnumerator Properties

CacheMultilinkEnumerator Properties
Public Properties
Collapse All

The properties of the CacheMultilinkEnumerator class are listed here.

Public Properties
Name | Description
Current | This is Current, a member of class CacheMultilinkEnumerator.


CacheMultilinkEnumerator.Current Property

CacheMultilinkEnumerator.Current Property
CacheMultilinkEnumerator Class Eco.Framework.Impl Namespace See Also
Collapse All
C#
public object Current;
Remarks

This is Current, a member of class CacheMultilinkEnumerator.

See Also
CacheMultilinkEnumerator Class
Eco.Framework.Impl Namespace


CacheMultilinkFetchedValueAdapter Class

CacheMultilinkFetchedValueAdapter Class
Inheritance Hierarchy See Also
Collapse All
C#
public class CacheMultilinkFetchedValueAdapter : CacheMultilinkAdapter;
Remarks

This is class Eco.Framework.Impl.CacheMultilinkFetchedValueAdapter.

Inheritance Hierarchy
Eco.Framework.Impl.CacheMultilinkAdapter
    Eco.Framework.Impl.CacheMultilinkFetchedValueAdapter
File

CacheMultilinkAdapter.cs

See Also
Inheritance Hierarchy


CacheMultilinkFetchedValueAdapter.CacheMultilinkFetchedValueAdapter Constructor

CacheMultilinkFetchedValueAdapter.CacheMultilinkFetchedValueAdapter Constructor
CacheMultilinkFetchedValueAdapter Class Eco.Framework.Impl Namespace See Also
Collapse All
C#
public CacheMultilinkFetchedValueAdapter(
    CacheLocator OwningObject,
    MultiAssociationEndCachePolicy ListController
);
Remarks

This is CacheMultilinkFetchedValueAdapter, a member of class CacheMultilinkFetchedValueAdapter.

See Also
CacheMultilinkFetchedValueAdapter Class
Eco.Framework.Impl Namespace


CacheMultilinkFetchedValueAdapter Methods

CacheMultilinkFetchedValueAdapter Methods
Public Methods
Collapse All

The methods of the CacheMultilinkFetchedValueAdapter class are listed here.

Public Methods
Name | Description
Contains | This is Contains, a member of class CacheMultilinkFetchedValueAdapter.
IndexOf | This is IndexOf, a member of class CacheMultilinkFetchedValueAdapter.
this | This is this, a member of class CacheMultilinkFetchedValueAdapter.


CacheMultilinkFetchedValueAdapter.Contains Method

CacheMultilinkFetchedValueAdapter.Contains Method
CacheMultilinkFetchedValueAdapter Class Eco.Framework.Impl Namespace See Also
Collapse All
C#
public override bool Contains(
    object value
);
Remarks

This is Contains, a member of class CacheMultilinkFetchedValueAdapter.

See Also
CacheMultilinkFetchedValueAdapter Class
Eco.Framework.Impl Namespace


CacheMultilinkFetchedValueAdapter.IndexOf Method

CacheMultilinkFetchedValueAdapter.IndexOf Method
CacheMultilinkFetchedValueAdapter Class Eco.Framework.Impl Namespace See Also
Collapse All
C#
public override int IndexOf(
    object value
);
Remarks

This is IndexOf, a member of class CacheMultilinkFetchedValueAdapter.

See Also
CacheMultilinkFetchedValueAdapter Class
Eco.Framework.Impl Namespace


CacheMultilinkFetchedValueAdapter.this Indexer

CacheMultilinkFetchedValueAdapter.this Indexer
CacheMultilinkFetchedValueAdapter Class Eco.Framework.Impl Namespace See Also
Collapse All
C#
public override object this[
    int index
];
Remarks

This is this, a member of class CacheMultilinkFetchedValueAdapter.

See Also
CacheMultilinkFetchedValueAdapter Class
Eco.Framework.Impl Namespace


CacheMultilinkFetchedValueAdapter Properties

CacheMultilinkFetchedValueAdapter Properties
Public Properties
Collapse All

The properties of the CacheMultilinkFetchedValueAdapter class are listed here.

Public Properties
Name | Description
Count | This is Count, a member of class CacheMultilinkFetchedValueAdapter.


CacheMultilinkFetchedValueAdapter.Count Property

CacheMultilinkFetchedValueAdapter.Count Property
CacheMultilinkFetchedValueAdapter Class Eco.Framework.Impl Namespace See Also
Collapse All
C#
public override int Count;
Remarks

This is Count, a member of class CacheMultilinkFetchedValueAdapter.

See Also
CacheMultilinkFetchedValueAdapter Class
Eco.Framework.Impl Namespace


ClassCachePolicy Class

ClassCachePolicy Class
Inheritance Hierarchy See Also
Collapse All
C#
public class ClassCachePolicy;
Remarks

This is class Eco.Framework.Impl.ClassCachePolicy.

Inheritance Hierarchy
Eco.Framework.Impl.ClassCachePolicy
File

ClassCachePolicy.cs

See Also
Inheritance Hierarchy


ClassCachePolicy.ClassCachePolicy Constructor

ClassCachePolicy.ClassCachePolicy Constructor
ClassCachePolicy Class Eco.Framework.Impl Namespace See Also
Collapse All
C#
public ClassCachePolicy(
    IClass class_,
    CacheImpl owner
);
Remarks

This is ClassCachePolicy, a member of class ClassCachePolicy.

See Also
ClassCachePolicy Class
Eco.Framework.Impl Namespace


ClassCachePolicy Fields

ClassCachePolicy Fields
Public Fields
Collapse All

The fields of the ClassCachePolicy class are listed here.

Public Fields
Name | Description
FlagsIndex | This is FlagsIndex, a member of class ClassCachePolicy.
FlagsOffset | This is FlagsOffset, a member of class ClassCachePolicy.
MembersOffset | This is MembersOffset, a member of class ClassCachePolicy.
ObjectExistenceStateIndex | This is ObjectExistenceStateIndex, a member of class ClassCachePolicy.
ObjectFlagsIndex | This is ObjectFlagsIndex, a member of class ClassCachePolicy.
ObjectPersistenceStateIndex | This is ObjectPersistenceStateIndex, a member of class ClassCachePolicy.


ClassCachePolicy.FlagsIndex Field

ClassCachePolicy.FlagsIndex Field
ClassCachePolicy Class Eco.Framework.Impl Namespace See Also
Collapse All
C#
public const int FlagsIndex = 0;
Remarks

This is FlagsIndex, a member of class ClassCachePolicy.

See Also
ClassCachePolicy Class
Eco.Framework.Impl Namespace


ClassCachePolicy.FlagsOffset Field

ClassCachePolicy.FlagsOffset Field
ClassCachePolicy Class Eco.Framework.Impl Namespace See Also
Collapse All
C#
public const int FlagsOffset = 3;
Remarks

This is FlagsOffset, a member of class ClassCachePolicy.

See Also
ClassCachePolicy Class
Eco.Framework.Impl Namespace


ClassCachePolicy.MembersOffset Field

ClassCachePolicy.MembersOffset Field
ClassCachePolicy Class Eco.Framework.Impl Namespace See Also
Collapse All
C#
public const int MembersOffset = 1;
Remarks

This is MembersOffset, a member of class ClassCachePolicy.

See Also
ClassCachePolicy Class
Eco.Framework.Impl Namespace


ClassCachePolicy.ObjectExistenceStateIndex Field

ClassCachePolicy.ObjectExistenceStateIndex Field
ClassCachePolicy Class Eco.Framework.Impl Namespace See Also
Collapse All
C#
public const int ObjectExistenceStateIndex = 1;
Remarks

This is ObjectExistenceStateIndex, a member of class ClassCachePolicy.

See Also
ClassCachePolicy Class
Eco.Framework.Impl Namespace


ClassCachePolicy.ObjectFlagsIndex Field

ClassCachePolicy.ObjectFlagsIndex Field
ClassCachePolicy Class Eco.Framework.Impl Namespace See Also
Collapse All
C#
public const int ObjectFlagsIndex = 2;
Remarks

This is ObjectFlagsIndex, a member of class ClassCachePolicy.

See Also
ClassCachePolicy Class
Eco.Framework.Impl Namespace


ClassCachePolicy.ObjectPersistenceStateIndex Field

ClassCachePolicy.ObjectPersistenceStateIndex Field
ClassCachePolicy Class Eco.Framework.Impl Namespace See Also
Collapse All
C#
public const int ObjectPersistenceStateIndex = 0;
Remarks

This is ObjectPersistenceStateIndex, a member of class ClassCachePolicy.

See Also
ClassCachePolicy Class
Eco.Framework.Impl Namespace


ClassCachePolicy Methods

ClassCachePolicy Methods
Public Methods
Collapse All

The methods of the ClassCachePolicy class are listed here.

Public Methods
Name | Description
ClearTouched | This is ClearTouched, a member of class ClassCachePolicy.
CreateContent | This is the overview for the CreateContent method overload.
DoDeserialize | This is DoDeserialize, a member of class ClassCachePolicy.
DoSerialize | This is DoSerialize, a member of class ClassCachePolicy.
GetDefaultFetched | This is GetDefaultFetched, a member of class ClassCachePolicy.
GetDirty | This is GetDirty, a member of class ClassCachePolicy.
GetExistenceState | This is GetExistenceState, a member of class ClassCachePolicy.
GetHasModifedMember | This is GetHasModifedMember, a member of class ClassCachePolicy.
GetIsDefaultFetched | This is GetIsDefaultFetched, a member of class ClassCachePolicy.
GetIsDefaultFetchedKnown | This is GetIsDefaultFetchedKnown, a member of class ClassCachePolicy.
GetMemberPolicy | This is GetMemberPolicy, a member of class ClassCachePolicy.
GetPersistenceState | This is GetPersistenceState, a member of class ClassCachePolicy.
GetPersistent | This is GetPersistent, a member of class ClassCachePolicy.
GetTouched | This is GetTouched, a member of class ClassCachePolicy.
GetVersion | This is GetVersion, a member of class ClassCachePolicy.
Pass2 | This is Pass2, a member of class ClassCachePolicy.
SetExistenceState | This is SetExistenceState, a member of class ClassCachePolicy.
SetHasModifedMember | This is SetHasModifedMember, a member of class ClassCachePolicy.
SetHasModifedMemberKnown | This is SetHasModifedMemberKnown, a member of class ClassCachePolicy.
SetIsDefaultFetched | This is SetIsDefaultFetched, a member of class ClassCachePolicy.
SetIsDefaultFetchedKnown | This is SetIsDefaultFetchedKnown, a member of class ClassCachePolicy.
SetPersistenceState | This is SetPersistenceState, a member of class ClassCachePolicy.
SetTouched | This is SetTouched, a member of class ClassCachePolicy.
SetVersion | This is SetVersion, a member of class ClassCachePolicy.


ClassCachePolicy.ClearTouched Method

ClassCachePolicy.ClearTouched Method
ClassCachePolicy Class Eco.Framework.Impl Namespace See Also
Collapse All
C#
public void ClearTouched(
    object[] objectContents
);
Remarks

This is ClearTouched, a member of class ClassCachePolicy.

See Also
ClassCachePolicy Class
Eco.Framework.Impl Namespace


CreateContent Method

CreateContent Method

This is the overview for the CreateContent method overload.

Overload List
Name | Description
ClassCachePolicy.CreateContent (CacheLocator, bool, bool) | This is CreateContent, a member of class ClassCachePolicy.
ClassCachePolicy.CreateContent (CacheLocator, bool, bool, ILoopBack) | This is CreateContent, a member of class ClassCachePolicy.


ClassCachePolicy.CreateContent Method (CacheLocator, bool, bool)

ClassCachePolicy.CreateContent Method (CacheLocator, bool, bool)
ClassCachePolicy Class Eco.Framework.Impl Namespace See Also
Collapse All
C#
public object[] CreateContent(
    CacheLocator locator,
    bool isNew,
    bool persistentInstance
);
Remarks

This is CreateContent, a member of class ClassCachePolicy.

See Also
ClassCachePolicy Class
Eco.Framework.Impl Namespace


ClassCachePolicy.CreateContent Method (CacheLocator, bool, bool, ILoopBack)

ClassCachePolicy.CreateContent Method (CacheLocator, bool, bool, ILoopBack)
ClassCachePolicy Class Eco.Framework.Impl Namespace See Also
Collapse All
C#
public object[] CreateContent(
    CacheLocator locator,
    bool isNew,
    bool persistentInstance,
    ILoopBack loopback
);
Remarks

This is CreateContent, a member of class ClassCachePolicy.

See Also
ClassCachePolicy Class
Eco.Framework.Impl Namespace


ClassCachePolicy.DoDeserialize Method

ClassCachePolicy.DoDeserialize Method
ClassCachePolicy Class Eco.Framework.Impl Namespace See Also
Collapse All
C#
public void DoDeserialize(
    CacheLocator locator,
    Stream source
);
Remarks

This is DoDeserialize, a member of class ClassCachePolicy.

See Also
ClassCachePolicy Class
Eco.Framework.Impl Namespace


ClassCachePolicy.DoSerialize Method

ClassCachePolicy.DoSerialize Method
ClassCachePolicy Class Eco.Framework.Impl Namespace See Also
Collapse All
C#
public void DoSerialize(
    CacheLocator locator,
    Stream target,
    EcoSpaceSerializationConfig config
);
Remarks

This is DoSerialize, a member of class ClassCachePolicy.

See Also
ClassCachePolicy Class
Eco.Framework.Impl Namespace


ClassCachePolicy.GetDefaultFetched Method

ClassCachePolicy.GetDefaultFetched Method
ClassCachePolicy Class Eco.Framework.Impl Namespace See Also
Collapse All
C#
public bool GetDefaultFetched(
    object[] objectContents
);
Remarks

This is GetDefaultFetched, a member of class ClassCachePolicy.

See Also
ClassCachePolicy Class
Eco.Framework.Impl Namespace


ClassCachePolicy.GetDirty Method

ClassCachePolicy.GetDirty Method
ClassCachePolicy Class Eco.Framework.Impl Namespace See Also
Collapse All
C#
public bool GetDirty(
    object[] objectContents
);
Remarks

This is GetDirty, a member of class ClassCachePolicy.

See Also
ClassCachePolicy Class
Eco.Framework.Impl Namespace


ClassCachePolicy.GetExistenceState Method

ClassCachePolicy.GetExistenceState Method
ClassCachePolicy Class Eco.Framework.Impl Namespace See Also
Collapse All
C#
public ExistenceState GetExistenceState(
    object[] objectContents
);
Remarks

This is GetExistenceState, a member of class ClassCachePolicy.

See Also
ClassCachePolicy Class
Eco.Framework.Impl Namespace


ClassCachePolicy.GetHasModifedMember Method

ClassCachePolicy.GetHasModifedMember Method
ClassCachePolicy Class Eco.Framework.Impl Namespace See Also
Collapse All
C#
public bool GetHasModifedMember(
    object[] objectContents
);
Remarks

This is GetHasModifedMember, a member of class ClassCachePolicy.

See Also
ClassCachePolicy Class
Eco.Framework.Impl Namespace


ClassCachePolicy.GetIsDefaultFetched Method

ClassCachePolicy.GetIsDefaultFetched Method
ClassCachePolicy Class Eco.Framework.Impl Namespace See Also
Collapse All
C#
public bool GetIsDefaultFetched(
    object[] objectContents
);
Remarks

This is GetIsDefaultFetched, a member of class ClassCachePolicy.

See Also
ClassCachePolicy Class
Eco.Framework.Impl Namespace


ClassCachePolicy.GetIsDefaultFetchedKnown Method

ClassCachePolicy.GetIsDefaultFetchedKnown Method
ClassCachePolicy Class Eco.Framework.Impl Namespace See Also
Collapse All
C#
public bool GetIsDefaultFetchedKnown(
    object[] objectContents
);
Remarks

This is GetIsDefaultFetchedKnown, a member of class ClassCachePolicy.

See Also
ClassCachePolicy Class
Eco.Framework.Impl Namespace


ClassCachePolicy.GetMemberPolicy Method

ClassCachePolicy.GetMemberPolicy Method
ClassCachePolicy Class Eco.Framework.Impl Namespace See Also
Collapse All
C#
public MemberCachePolicy GetMemberPolicy(
    IStructuralFeature member
);
Remarks

This is GetMemberPolicy, a member of class ClassCachePolicy.

See Also
ClassCachePolicy Class
Eco.Framework.Impl Namespace


ClassCachePolicy.GetPersistenceState Method

ClassCachePolicy.GetPersistenceState Method
ClassCachePolicy Class Eco.Framework.Impl Namespace See Also
Collapse All
C#
public PersistenceState GetPersistenceState(
    object[] objectContents
);
Remarks

This is GetPersistenceState, a member of class ClassCachePolicy.

See Also
ClassCachePolicy Class
Eco.Framework.Impl Namespace


ClassCachePolicy.GetPersistent Method

ClassCachePolicy.GetPersistent Method
ClassCachePolicy Class Eco.Framework.Impl Namespace See Also
Collapse All
C#
public bool GetPersistent(
    object[] objectContents
);
Remarks

This is GetPersistent, a member of class ClassCachePolicy.

See Also
ClassCachePolicy Class
Eco.Framework.Impl Namespace


ClassCachePolicy.GetTouched Method

ClassCachePolicy.GetTouched Method
ClassCachePolicy Class Eco.Framework.Impl Namespace See Also
Collapse All
C#
public bool GetTouched(
    object[] objectContents
);
Remarks

This is GetTouched, a member of class ClassCachePolicy.

See Also
ClassCachePolicy Class
Eco.Framework.Impl Namespace


ClassCachePolicy.GetVersion Method

ClassCachePolicy.GetVersion Method
ClassCachePolicy Class Eco.Framework.Impl Namespace See Also
Collapse All
C#
public int GetVersion(
    object[] objectContents
);
Remarks

This is GetVersion, a member of class ClassCachePolicy.

See Also
ClassCachePolicy Class
Eco.Framework.Impl Namespace


ClassCachePolicy.Pass2 Method

ClassCachePolicy.Pass2 Method
ClassCachePolicy Class Eco.Framework.Impl Namespace See Also
Collapse All
C#
public void Pass2();
Remarks

This is Pass2, a member of class ClassCachePolicy.

See Also
ClassCachePolicy Class
Eco.Framework.Impl Namespace


ClassCachePolicy.SetExistenceState Method

ClassCachePolicy.SetExistenceState Method
ClassCachePolicy Class Eco.Framework.Impl Namespace See Also
Collapse All
C#
public void SetExistenceState(
    object[] objectContents,
    CacheLocator locator,
    ExistenceState value
);
Remarks

This is SetExistenceState, a member of class ClassCachePolicy.

See Also
ClassCachePolicy Class
Eco.Framework.Impl Namespace


ClassCachePolicy.SetHasModifedMember Method

ClassCachePolicy.SetHasModifedMember Method
ClassCachePolicy Class Eco.Framework.Impl Namespace See Also
Collapse All
C#
public void SetHasModifedMember(
    object[] objectContents,
    bool value
);
Remarks

This is SetHasModifedMember, a member of class ClassCachePolicy.

See Also
ClassCachePolicy Class
Eco.Framework.Impl Namespace


ClassCachePolicy.SetHasModifedMemberKnown Method

ClassCachePolicy.SetHasModifedMemberKnown Method
ClassCachePolicy Class Eco.Framework.Impl Namespace See Also
Collapse All
C#
public void SetHasModifedMemberKnown(
    object[] objectContents,
    bool value
);
Remarks

This is SetHasModifedMemberKnown, a member of class ClassCachePolicy.

See Also
ClassCachePolicy Class
Eco.Framework.Impl Namespace


ClassCachePolicy.SetIsDefaultFetched Method

ClassCachePolicy.SetIsDefaultFetched Method
ClassCachePolicy Class Eco.Framework.Impl Namespace See Also
Collapse All
C#
public void SetIsDefaultFetched(
    object[] objectContents,
    bool value
);
Remarks

This is SetIsDefaultFetched, a member of class ClassCachePolicy.

See Also
ClassCachePolicy Class
Eco.Framework.Impl Namespace


ClassCachePolicy.SetIsDefaultFetchedKnown Method

ClassCachePolicy.SetIsDefaultFetchedKnown Method
ClassCachePolicy Class Eco.Framework.Impl Namespace See Also
Collapse All
C#
public void SetIsDefaultFetchedKnown(
    object[] objectContents,
    bool value
);
Remarks

This is SetIsDefaultFetchedKnown, a member of class ClassCachePolicy.

See Also
ClassCachePolicy Class
Eco.Framework.Impl Namespace


ClassCachePolicy.SetPersistenceState Method

ClassCachePolicy.SetPersistenceState Method
ClassCachePolicy Class Eco.Framework.Impl Namespace See Also
Collapse All
C#
public void SetPersistenceState(
    object[] objectContents,
    CacheLocator locator,
    PersistenceState value
);
Remarks

This is SetPersistenceState, a member of class ClassCachePolicy.

See Also
ClassCachePolicy Class
Eco.Framework.Impl Namespace


ClassCachePolicy.SetTouched Method

ClassCachePolicy.SetTouched Method
ClassCachePolicy Class Eco.Framework.Impl Namespace See Also
Collapse All
C#
public void SetTouched(
    object[] objectContents,
    bool value
);
Remarks

This is SetTouched, a member of class ClassCachePolicy.

See Also
ClassCachePolicy Class
Eco.Framework.Impl Namespace


ClassCachePolicy.SetVersion Method

ClassCachePolicy.SetVersion Method
ClassCachePolicy Class Eco.Framework.Impl Namespace See Also
Collapse All
C#
public void SetVersion(
    object[] objectContents,
    int value
);
Remarks

This is SetVersion, a member of class ClassCachePolicy.

See Also
ClassCachePolicy Class
Eco.Framework.Impl Namespace


ClassCachePolicy Properties

ClassCachePolicy Properties
Public Properties
Collapse All

The properties of the ClassCachePolicy class are listed here.

Public Properties
Name | Description
BoxedMinusOne | This is BoxedMinusOne, a member of class ClassCachePolicy.
ContentSize | This is ContentSize, a member of class ClassCachePolicy.
FlagsSize | This is FlagsSize, a member of class ClassCachePolicy.
OldValueIndex | This is OldValueIndex, a member of class ClassCachePolicy.
Owner | This is Owner, a member of class ClassCachePolicy.
UmlClass | This is UmlClass, a member of class ClassCachePolicy.
VersionIndex | This is VersionIndex, a member of class ClassCachePolicy.


ClassCachePolicy.BoxedMinusOne Property

ClassCachePolicy.BoxedMinusOne Property
ClassCachePolicy Class Eco.Framework.Impl Namespace See Also
Collapse All
C#
public static object BoxedMinusOne;
Remarks

This is BoxedMinusOne, a member of class ClassCachePolicy.

See Also
ClassCachePolicy Class
Eco.Framework.Impl Namespace


ClassCachePolicy.ContentSize Property

ClassCachePolicy.ContentSize Property
ClassCachePolicy Class Eco.Framework.Impl Namespace See Also
Collapse All
C#
public int ContentSize;
Remarks

This is ContentSize, a member of class ClassCachePolicy.

See Also
ClassCachePolicy Class
Eco.Framework.Impl Namespace


ClassCachePolicy.FlagsSize Property

ClassCachePolicy.FlagsSize Property
ClassCachePolicy Class Eco.Framework.Impl Namespace See Also
Collapse All
C#
public int FlagsSize;
Remarks

This is FlagsSize, a member of class ClassCachePolicy.

See Also
ClassCachePolicy Class
Eco.Framework.Impl Namespace


ClassCachePolicy.OldValueIndex Property

ClassCachePolicy.OldValueIndex Property
ClassCachePolicy Class Eco.Framework.Impl Namespace See Also
Collapse All
C#
public int OldValueIndex;
Remarks

This is OldValueIndex, a member of class ClassCachePolicy.

See Also
ClassCachePolicy Class
Eco.Framework.Impl Namespace


ClassCachePolicy.Owner Property

ClassCachePolicy.Owner Property
ClassCachePolicy Class Eco.Framework.Impl Namespace See Also
Collapse All
C#
public CacheImpl Owner;
Remarks

This is Owner, a member of class ClassCachePolicy.

See Also
ClassCachePolicy Class
Eco.Framework.Impl Namespace


ClassCachePolicy.UmlClass Property

ClassCachePolicy.UmlClass Property
ClassCachePolicy Class Eco.Framework.Impl Namespace See Also
Collapse All
C#
public IClass UmlClass;
Remarks

This is UmlClass, a member of class ClassCachePolicy.

See Also
ClassCachePolicy Class
Eco.Framework.Impl Namespace


ClassCachePolicy.VersionIndex Property

ClassCachePolicy.VersionIndex Property
ClassCachePolicy Class Eco.Framework.Impl Namespace See Also
Collapse All
C#
public int VersionIndex;
Remarks

This is VersionIndex, a member of class ClassCachePolicy.

See Also
ClassCachePolicy Class
Eco.Framework.Impl Namespace


DirectMultiAssociationEndCachePolicy Class

DirectMultiAssociationEndCachePolicy Class
Inheritance Hierarchy See Also
Collapse All
C#
public class DirectMultiAssociationEndCachePolicy : MainMultiAssociationEndCachePolicy, IOtherEndController;
Remarks

This is class Eco.Framework.Impl.DirectMultiAssociationEndCachePolicy.

Inheritance Hierarchy
Eco.Framework.Impl.MemberCachePolicy
    Eco.Framework.Impl.AssociationEndCachePolicy
        Eco.Framework.Impl.MultiAssociationEndCachePolicy
            Eco.Framework.Impl.MainMultiAssociationEndCachePolicy
            Eco.Framework.Impl.IOtherEndController
                Eco.Framework.Impl.DirectMultiAssociationEndCachePolicy
File

MultiAssociationEndPolicies.cs

See Also
Inheritance Hierarchy


DirectMultiAssociationEndCachePolicy.DirectMultiAssociationEndCachePolicy Constructor

DirectMultiAssociationEndCachePolicy.DirectMultiAssociationEndCachePolicy Constructor
DirectMultiAssociationEndCachePolicy Class Eco.Framework.Impl Namespace See Also
Collapse All
C#
public DirectMultiAssociationEndCachePolicy(
    ClassCachePolicy Owner,
    IAssociationEnd AssociationEnd,
    int MemberContentIndex,
    int FlagIndex
);
Remarks

This is DirectMultiAssociationEndCachePolicy, a member of class DirectMultiAssociationEndCachePolicy.

See Also
DirectMultiAssociationEndCachePolicy Class
Eco.Framework.Impl Namespace


DirectMultiAssociationEndCachePolicy Fields

DirectMultiAssociationEndCachePolicy Fields
Protected Fields
Collapse All

The fields of the DirectMultiAssociationEndCachePolicy class are listed here.

Protected Fields
Name | Description
m_OppositeEndPolicy | This is m_OppositeEndPolicy, a member of class DirectMultiAssociationEndCachePolicy.


DirectMultiAssociationEndCachePolicy.m_OppositeEndPolicy Field

DirectMultiAssociationEndCachePolicy.m_OppositeEndPolicy Field
DirectMultiAssociationEndCachePolicy Class Eco.Framework.Impl Namespace See Also
Collapse All
C#
protected DirectSingleAssociationEndCachePolicy m_OppositeEndPolicy = null;
Remarks

This is m_OppositeEndPolicy, a member of class DirectMultiAssociationEndCachePolicy.

See Also
DirectMultiAssociationEndCachePolicy Class
Eco.Framework.Impl Namespace


DirectMultiAssociationEndCachePolicy Methods

DirectMultiAssociationEndCachePolicy Methods
Protected Methods Public Methods
Collapse All

The methods of the DirectMultiAssociationEndCachePolicy class are listed here.

Protected Methods
Name | Description
GetOtherEndOrderNo | This is GetOtherEndOrderNo, a member of class DirectMultiAssociationEndCachePolicy.
IsInOrder | This is IsInOrder, a member of class DirectMultiAssociationEndCachePolicy.
Resort | This is Resort, a member of class DirectMultiAssociationEndCachePolicy.
SetOtherEndOrderNo | This is SetOtherEndOrderNo, a member of class DirectMultiAssociationEndCachePolicy.
Top
Public Methods
Name | Description
ClearOldValue | This is ClearOldValue, a member of class DirectMultiAssociationEndCachePolicy.
FreeContent | This is FreeContent, a member of class DirectMultiAssociationEndCachePolicy.
GetCount | This is GetCount, a member of class DirectMultiAssociationEndCachePolicy.
LinkTo_Current | This is LinkTo_Current, a member of class DirectMultiAssociationEndCachePolicy.
LinkTo_CurrentAndFetched | This is LinkTo_CurrentAndFetched, a member of class DirectMultiAssociationEndCachePolicy.
LinkTo_fetched | This is LinkTo_fetched, a member of class DirectMultiAssociationEndCachePolicy.
Pass2 | This is Pass2, a member of class DirectMultiAssociationEndCachePolicy.
SaveOldValue | This is SaveOldValue, a member of class DirectMultiAssociationEndCachePolicy.
Unlink_Current | This is Unlink_Current, a member of class DirectMultiAssociationEndCachePolicy.
Unlink_CurrentAndFetched | This is Unlink_CurrentAndFetched, a member of class DirectMultiAssociationEndCachePolicy.
Unlink_fetched | This is Unlink_fetched, a member of class DirectMultiAssociationEndCachePolicy.


DirectMultiAssociationEndCachePolicy.ClearOldValue Method

DirectMultiAssociationEndCachePolicy.ClearOldValue Method
DirectMultiAssociationEndCachePolicy Class Eco.Framework.Impl Namespace See Also
Collapse All
C#
public override void ClearOldValue(
    object[] objectContents
);
Remarks

This is ClearOldValue, a member of class DirectMultiAssociationEndCachePolicy.

See Also
DirectMultiAssociationEndCachePolicy Class
Eco.Framework.Impl Namespace


DirectMultiAssociationEndCachePolicy.FreeContent Method

DirectMultiAssociationEndCachePolicy.FreeContent Method
DirectMultiAssociationEndCachePolicy Class Eco.Framework.Impl Namespace See Also
Collapse All
C#
public override void FreeContent();
Remarks

This is FreeContent, a member of class DirectMultiAssociationEndCachePolicy.

See Also
DirectMultiAssociationEndCachePolicy Class
Eco.Framework.Impl Namespace


DirectMultiAssociationEndCachePolicy.GetCount Method

DirectMultiAssociationEndCachePolicy.GetCount Method
DirectMultiAssociationEndCachePolicy Class Eco.Framework.Impl Namespace See Also
Collapse All
C#
public override int GetCount(
    CacheLocator owningObject
);
Remarks

This is GetCount, a member of class DirectMultiAssociationEndCachePolicy.

See Also
DirectMultiAssociationEndCachePolicy Class
Eco.Framework.Impl Namespace


DirectMultiAssociationEndCachePolicy.GetOtherEndOrderNo Method

DirectMultiAssociationEndCachePolicy.GetOtherEndOrderNo Method
DirectMultiAssociationEndCachePolicy Class Eco.Framework.Impl Namespace See Also
Collapse All
C#
protected int GetOtherEndOrderNo(
    int index,
    CacheLocator owningObject
);
Remarks

This is GetOtherEndOrderNo, a member of class DirectMultiAssociationEndCachePolicy.

See Also
DirectMultiAssociationEndCachePolicy Class
Eco.Framework.Impl Namespace


DirectMultiAssociationEndCachePolicy.IsInOrder Method

DirectMultiAssociationEndCachePolicy.IsInOrder Method
DirectMultiAssociationEndCachePolicy Class Eco.Framework.Impl Namespace See Also
Collapse All
C#
protected override bool IsInOrder(
    CacheLocator owningObject
);
Remarks

This is IsInOrder, a member of class DirectMultiAssociationEndCachePolicy.

See Also
DirectMultiAssociationEndCachePolicy Class
Eco.Framework.Impl Namespace


DirectMultiAssociationEndCachePolicy.LinkTo_Current Method

DirectMultiAssociationEndCachePolicy.LinkTo_Current Method
DirectMultiAssociationEndCachePolicy Class Eco.Framework.Impl Namespace See Also
Collapse All
C#
public void LinkTo_Current(
    CacheLocator newLocator,
    CacheLocator owningObject
);
Remarks

This is LinkTo_Current, a member of class DirectMultiAssociationEndCachePolicy.

See Also
DirectMultiAssociationEndCachePolicy Class
Eco.Framework.Impl Namespace


DirectMultiAssociationEndCachePolicy.LinkTo_CurrentAndFetched Method

DirectMultiAssociationEndCachePolicy.LinkTo_CurrentAndFetched Method
DirectMultiAssociationEndCachePolicy Class Eco.Framework.Impl Namespace See Also
Collapse All
C#
public void LinkTo_CurrentAndFetched(
    CacheLocator newLocator,
    CacheLocator owningObject
);
Remarks

This is LinkTo_CurrentAndFetched, a member of class DirectMultiAssociationEndCachePolicy.

See Also
DirectMultiAssociationEndCachePolicy Class
Eco.Framework.Impl Namespace


DirectMultiAssociationEndCachePolicy.LinkTo_fetched Method

DirectMultiAssociationEndCachePolicy.LinkTo_fetched Method
DirectMultiAssociationEndCachePolicy Class Eco.Framework.Impl Namespace See Also
Collapse All
C#
public void LinkTo_fetched(
    CacheLocator newLocator,
    CacheLocator owningObject
);
Remarks

This is LinkTo_fetched, a member of class DirectMultiAssociationEndCachePolicy.

See Also
DirectMultiAssociationEndCachePolicy Class
Eco.Framework.Impl Namespace


DirectMultiAssociationEndCachePolicy.Pass2 Method

DirectMultiAssociationEndCachePolicy.Pass2 Method
DirectMultiAssociationEndCachePolicy Class Eco.Framework.Impl Namespace See Also
Collapse All
C#
public override void Pass2();
Remarks

This is Pass2, a member of class DirectMultiAssociationEndCachePolicy.

See Also
DirectMultiAssociationEndCachePolicy Class
Eco.Framework.Impl Namespace


DirectMultiAssociationEndCachePolicy.Resort Method

DirectMultiAssociationEndCachePolicy.Resort Method
DirectMultiAssociationEndCachePolicy Class Eco.Framework.Impl Namespace See Also
Collapse All
C#
protected override void Resort(
    CacheLocator owningObject
);
Remarks

This is Resort, a member of class DirectMultiAssociationEndCachePolicy.

See Also
DirectMultiAssociationEndCachePolicy Class
Eco.Framework.Impl Namespace


DirectMultiAssociationEndCachePolicy.SaveOldValue Method

DirectMultiAssociationEndCachePolicy.SaveOldValue Method
DirectMultiAssociationEndCachePolicy Class Eco.Framework.Impl Namespace See Also
Collapse All
C#
public override void SaveOldValue(
    object[] objectContents
);
Remarks

This is SaveOldValue, a member of class DirectMultiAssociationEndCachePolicy.

See Also
DirectMultiAssociationEndCachePolicy Class
Eco.Framework.Impl Namespace


DirectMultiAssociationEndCachePolicy.SetOtherEndOrderNo Method

DirectMultiAssociationEndCachePolicy.SetOtherEndOrderNo Method
DirectMultiAssociationEndCachePolicy Class Eco.Framework.Impl Namespace See Also
Collapse All
C#
protected void SetOtherEndOrderNo(
    int index,
    CacheLocator owningObject,
    int value
);
Remarks

This is SetOtherEndOrderNo, a member of class DirectMultiAssociationEndCachePolicy.

See Also
DirectMultiAssociationEndCachePolicy Class
Eco.Framework.Impl Namespace


DirectMultiAssociationEndCachePolicy.Unlink_Current Method

DirectMultiAssociationEndCachePolicy.Unlink_Current Method
DirectMultiAssociationEndCachePolicy Class Eco.Framework.Impl Namespace See Also
Collapse All
C#
public void Unlink_Current(
    CacheLocator oldLocator,
    CacheLocator owningObject
);
Remarks

This is Unlink_Current, a member of class DirectMultiAssociationEndCachePolicy.

See Also
DirectMultiAssociationEndCachePolicy Class
Eco.Framework.Impl Namespace


DirectMultiAssociationEndCachePolicy.Unlink_CurrentAndFetched Method

DirectMultiAssociationEndCachePolicy.Unlink_CurrentAndFetched Method
DirectMultiAssociationEndCachePolicy Class Eco.Framework.Impl Namespace See Also
Collapse All
C#
public void Unlink_CurrentAndFetched(
    CacheLocator oldLocator,
    CacheLocator owningObject
);
Remarks

This is Unlink_CurrentAndFetched, a member of class DirectMultiAssociationEndCachePolicy.

See Also
DirectMultiAssociationEndCachePolicy Class
Eco.Framework.Impl Namespace


DirectMultiAssociationEndCachePolicy.Unlink_fetched Method

DirectMultiAssociationEndCachePolicy.Unlink_fetched Method
DirectMultiAssociationEndCachePolicy Class Eco.Framework.Impl Namespace See Also
Collapse All
C#
public void Unlink_fetched(
    CacheLocator oldLocator,
    CacheLocator owningObject
);
Remarks

This is Unlink_fetched, a member of class DirectMultiAssociationEndCachePolicy.

See Also
DirectMultiAssociationEndCachePolicy Class
Eco.Framework.Impl Namespace


DirectSingleAssociationEndCachePolicy Class

DirectSingleAssociationEndCachePolicy Class
Inheritance Hierarchy See Also
Collapse All
C#
public class DirectSingleAssociationEndCachePolicy : SingleAssociationEndCachePolicy, IOtherEndController;
Remarks

This is class Eco.Framework.Impl.DirectSingleAssociationEndCachePolicy.

Inheritance Hierarchy
Eco.Framework.Impl.MemberCachePolicy
    Eco.Framework.Impl.AssociationEndCachePolicy
        Eco.Framework.Impl.SingleAssociationEndCachePolicy
        Eco.Framework.Impl.IOtherEndController
            Eco.Framework.Impl.DirectSingleAssociationEndCachePolicy
                Eco.Framework.Impl.InnerAssociationEndCachePolicy
File

SingleAssociationEndPolicies.cs

See Also
Inheritance Hierarchy


DirectSingleAssociationEndCachePolicy.DirectSingleAssociationEndCachePolicy Constructor

DirectSingleAssociationEndCachePolicy.DirectSingleAssociationEndCachePolicy Constructor
DirectSingleAssociationEndCachePolicy Class Eco.Framework.Impl Namespace See Also
Collapse All
C#
public DirectSingleAssociationEndCachePolicy(
    ClassCachePolicy owner,
    IAssociationEnd associationEnd,
    int memberContentIndex,
    int flagIndex
);
Remarks

This is DirectSingleAssociationEndCachePolicy, a member of class DirectSingleAssociationEndCachePolicy.

See Also
DirectSingleAssociationEndCachePolicy Class
Eco.Framework.Impl Namespace


DirectSingleAssociationEndCachePolicy Methods

DirectSingleAssociationEndCachePolicy Methods
Public Methods
Collapse All

The methods of the DirectSingleAssociationEndCachePolicy class are listed here.

Public Methods
Name | Description
ClearOldValue | This is ClearOldValue, a member of class DirectSingleAssociationEndCachePolicy.
DoDeserialize | This is DoDeserialize, a member of class DirectSingleAssociationEndCachePolicy.
DoDeserialize_FromId | This is DoDeserialize_FromId, a member of class DirectSingleAssociationEndCachePolicy.
DoSerialize | This is DoSerialize, a member of class DirectSingleAssociationEndCachePolicy.
DoSerialize_ToId | This is DoSerialize_ToId, a member of class DirectSingleAssociationEndCachePolicy.
LinkTo_Current | This is LinkTo_Current, a member of class DirectSingleAssociationEndCachePolicy.
LinkTo_CurrentAndFetched | This is LinkTo_CurrentAndFetched, a member of class DirectSingleAssociationEndCachePolicy.
LinkTo_fetched | This is LinkTo_fetched, a member of class DirectSingleAssociationEndCachePolicy.
SaveOldValue | This is SaveOldValue, a member of class DirectSingleAssociationEndCachePolicy.
SetCurrentAndFetchedValue | This is SetCurrentAndFetchedValue, a member of class DirectSingleAssociationEndCachePolicy.
SetLocator_Current | This is SetLocator_Current, a member of class DirectSingleAssociationEndCachePolicy.
SetLocator_CurrentAndFetched | This is SetLocator_CurrentAndFetched, a member of class DirectSingleAssociationEndCachePolicy.
SetOrderNo_cache | This is SetOrderNo_cache, a member of class DirectSingleAssociationEndCachePolicy.
Unlink_Current | This is Unlink_Current, a member of class DirectSingleAssociationEndCachePolicy.
Unlink_CurrentAndFetched | This is Unlink_CurrentAndFetched, a member of class DirectSingleAssociationEndCachePolicy.
Unlink_fetched | This is Unlink_fetched, a member of class DirectSingleAssociationEndCachePolicy.


DirectSingleAssociationEndCachePolicy.ClearOldValue Method

DirectSingleAssociationEndCachePolicy.ClearOldValue Method
DirectSingleAssociationEndCachePolicy Class Eco.Framework.Impl Namespace See Also
Collapse All
C#
public override void ClearOldValue(
    object[] objectContents
);
Remarks

This is ClearOldValue, a member of class DirectSingleAssociationEndCachePolicy.

See Also
DirectSingleAssociationEndCachePolicy Class
Eco.Framework.Impl Namespace


DirectSingleAssociationEndCachePolicy.DoDeserialize Method

DirectSingleAssociationEndCachePolicy.DoDeserialize Method
DirectSingleAssociationEndCachePolicy Class Eco.Framework.Impl Namespace See Also
Collapse All
C#
public override void DoDeserialize(
    CacheLocator locator,
    Stream source
);
Remarks

This is DoDeserialize, a member of class DirectSingleAssociationEndCachePolicy.

See Also
DirectSingleAssociationEndCachePolicy Class
Eco.Framework.Impl Namespace


DirectSingleAssociationEndCachePolicy.DoDeserialize_FromId Method

DirectSingleAssociationEndCachePolicy.DoDeserialize_FromId Method
DirectSingleAssociationEndCachePolicy Class Eco.Framework.Impl Namespace See Also
Collapse All
C#
public Locator DoDeserialize_FromId(
    ObjectId id
);
Remarks

This is DoDeserialize_FromId, a member of class DirectSingleAssociationEndCachePolicy.

See Also
DirectSingleAssociationEndCachePolicy Class
Eco.Framework.Impl Namespace


DirectSingleAssociationEndCachePolicy.DoSerialize Method

DirectSingleAssociationEndCachePolicy.DoSerialize Method
DirectSingleAssociationEndCachePolicy Class Eco.Framework.Impl Namespace See Also
Collapse All
C#
public override void DoSerialize(
    CacheLocator locator,
    Stream target,
    EcoSpaceSerializationConfig config
);
Remarks

This is DoSerialize, a member of class DirectSingleAssociationEndCachePolicy.

See Also
DirectSingleAssociationEndCachePolicy Class
Eco.Framework.Impl Namespace


DirectSingleAssociationEndCachePolicy.DoSerialize_ToId Method

DirectSingleAssociationEndCachePolicy.DoSerialize_ToId Method
DirectSingleAssociationEndCachePolicy Class Eco.Framework.Impl Namespace See Also
Collapse All
C#
public ObjectId DoSerialize_ToId(
    object obj
);
Remarks

This is DoSerialize_ToId, a member of class DirectSingleAssociationEndCachePolicy.

See Also
DirectSingleAssociationEndCachePolicy Class
Eco.Framework.Impl Namespace


DirectSingleAssociationEndCachePolicy.LinkTo_Current Method

DirectSingleAssociationEndCachePolicy.LinkTo_Current Method
DirectSingleAssociationEndCachePolicy Class Eco.Framework.Impl Namespace See Also
Collapse All
C#
public void LinkTo_Current(
    CacheLocator newLocator,
    CacheLocator owningObject
);
Remarks

This is LinkTo_Current, a member of class DirectSingleAssociationEndCachePolicy.

See Also
DirectSingleAssociationEndCachePolicy Class
Eco.Framework.Impl Namespace


DirectSingleAssociationEndCachePolicy.LinkTo_CurrentAndFetched Method

DirectSingleAssociationEndCachePolicy.LinkTo_CurrentAndFetched Method
DirectSingleAssociationEndCachePolicy Class Eco.Framework.Impl Namespace See Also
Collapse All
C#
public void LinkTo_CurrentAndFetched(
    CacheLocator newLocator,
    CacheLocator owningObject
);
Remarks

This is LinkTo_CurrentAndFetched, a member of class DirectSingleAssociationEndCachePolicy.

See Also
DirectSingleAssociationEndCachePolicy Class
Eco.Framework.Impl Namespace


DirectSingleAssociationEndCachePolicy.LinkTo_fetched Method

DirectSingleAssociationEndCachePolicy.LinkTo_fetched Method
DirectSingleAssociationEndCachePolicy Class Eco.Framework.Impl Namespace See Also
Collapse All
C#
public void LinkTo_fetched(
    CacheLocator newLocator,
    CacheLocator owningObject
);
Remarks

This is LinkTo_fetched, a member of class DirectSingleAssociationEndCachePolicy.

See Also
DirectSingleAssociationEndCachePolicy Class
Eco.Framework.Impl Namespace


DirectSingleAssociationEndCachePolicy.SaveOldValue Method

DirectSingleAssociationEndCachePolicy.SaveOldValue Method
DirectSingleAssociationEndCachePolicy Class Eco.Framework.Impl Namespace See Also
Collapse All
C#
public override void SaveOldValue(
    object[] objectContents
);
Remarks

This is SaveOldValue, a member of class DirectSingleAssociationEndCachePolicy.

See Also
DirectSingleAssociationEndCachePolicy Class
Eco.Framework.Impl Namespace


DirectSingleAssociationEndCachePolicy.SetCurrentAndFetchedValue Method

DirectSingleAssociationEndCachePolicy.SetCurrentAndFetchedValue Method
DirectSingleAssociationEndCachePolicy Class Eco.Framework.Impl Namespace See Also
Collapse All
C#
public override void SetCurrentAndFetchedValue(
    object value,
    CacheLocator owningObject
);
Remarks

This is SetCurrentAndFetchedValue, a member of class DirectSingleAssociationEndCachePolicy.

See Also
DirectSingleAssociationEndCachePolicy Class
Eco.Framework.Impl Namespace


DirectSingleAssociationEndCachePolicy.SetLocator_Current Method

DirectSingleAssociationEndCachePolicy.SetLocator_Current Method
DirectSingleAssociationEndCachePolicy Class Eco.Framework.Impl Namespace See Also
Collapse All
C#
public override void SetLocator_Current(
    CacheLocator newLocator,
    CacheLocator owningObject
);
Remarks

This is SetLocator_Current, a member of class DirectSingleAssociationEndCachePolicy.

See Also
DirectSingleAssociationEndCachePolicy Class
Eco.Framework.Impl Namespace


DirectSingleAssociationEndCachePolicy.SetLocator_CurrentAndFetched Method

DirectSingleAssociationEndCachePolicy.SetLocator_CurrentAndFetched Method
DirectSingleAssociationEndCachePolicy Class Eco.Framework.Impl Namespace See Also
Collapse All
C#
public void SetLocator_CurrentAndFetched(
    CacheLocator newLocator,
    CacheLocator owningObject
);
Remarks

This is SetLocator_CurrentAndFetched, a member of class DirectSingleAssociationEndCachePolicy.

See Also
DirectSingleAssociationEndCachePolicy Class
Eco.Framework.Impl Namespace


DirectSingleAssociationEndCachePolicy.SetOrderNo_cache Method

DirectSingleAssociationEndCachePolicy.SetOrderNo_cache Method
DirectSingleAssociationEndCachePolicy Class Eco.Framework.Impl Namespace See Also
Collapse All
C#
public override void SetOrderNo_cache(
    int orderNo,
    CacheLocator owningObject
);
Remarks

This is SetOrderNo_cache, a member of class DirectSingleAssociationEndCachePolicy.

See Also
DirectSingleAssociationEndCachePolicy Class
Eco.Framework.Impl Namespace


DirectSingleAssociationEndCachePolicy.Unlink_Current Method

DirectSingleAssociationEndCachePolicy.Unlink_Current Method
DirectSingleAssociationEndCachePolicy Class Eco.Framework.Impl Namespace See Also
Collapse All
C#
public void Unlink_Current(
    CacheLocator oldLocator,
    CacheLocator owningObject
);
Remarks

This is Unlink_Current, a member of class DirectSingleAssociationEndCachePolicy.

See Also
DirectSingleAssociationEndCachePolicy Class
Eco.Framework.Impl Namespace


DirectSingleAssociationEndCachePolicy.Unlink_CurrentAndFetched Method

DirectSingleAssociationEndCachePolicy.Unlink_CurrentAndFetched Method
DirectSingleAssociationEndCachePolicy Class Eco.Framework.Impl Namespace See Also
Collapse All
C#
public void Unlink_CurrentAndFetched(
    CacheLocator oldLocator,
    CacheLocator owningObject
);
Remarks

This is Unlink_CurrentAndFetched, a member of class DirectSingleAssociationEndCachePolicy.

See Also
DirectSingleAssociationEndCachePolicy Class
Eco.Framework.Impl Namespace


DirectSingleAssociationEndCachePolicy.Unlink_fetched Method

DirectSingleAssociationEndCachePolicy.Unlink_fetched Method
DirectSingleAssociationEndCachePolicy Class Eco.Framework.Impl Namespace See Also
Collapse All
C#
public void Unlink_fetched(
    CacheLocator oldLocator,
    CacheLocator owningObject
);
Remarks

This is Unlink_fetched, a member of class DirectSingleAssociationEndCachePolicy.

See Also
DirectSingleAssociationEndCachePolicy Class
Eco.Framework.Impl Namespace


IndirectMultiAssociationEndCachePolicy Class

IndirectMultiAssociationEndCachePolicy Class
Inheritance Hierarchy See Also
Collapse All
C#
public class IndirectMultiAssociationEndCachePolicy : MainMultiAssociationEndCachePolicy, IIndirectController, IOtherEndController;
Remarks

This is class Eco.Framework.Impl.IndirectMultiAssociationEndCachePolicy.

Inheritance Hierarchy
Eco.Framework.Impl.MemberCachePolicy
    Eco.Framework.Impl.AssociationEndCachePolicy
        Eco.Framework.Impl.MultiAssociationEndCachePolicy
            Eco.Framework.Impl.MainMultiAssociationEndCachePolicy
            Eco.Framework.Impl.IIndirectController
            Eco.Framework.Impl.IOtherEndController
                Eco.Framework.Impl.IndirectMultiAssociationEndCachePolicy
File

MultiAssociationEndPolicies.cs

See Also
Inheritance Hierarchy


IndirectMultiAssociationEndCachePolicy.IndirectMultiAssociationEndCachePolicy Constructor

IndirectMultiAssociationEndCachePolicy.IndirectMultiAssociationEndCachePolicy Constructor
IndirectMultiAssociationEndCachePolicy Class Eco.Framework.Impl Namespace See Also
Collapse All
C#
public IndirectMultiAssociationEndCachePolicy(
    ClassCachePolicy Owner,
    IAssociationEnd AssociationEnd,
    int MemberContentIndex,
    int FlagIndex
);
Remarks

This is IndirectMultiAssociationEndCachePolicy, a member of class IndirectMultiAssociationEndCachePolicy.

See Also
IndirectMultiAssociationEndCachePolicy Class
Eco.Framework.Impl Namespace


IndirectMultiAssociationEndCachePolicy Methods

IndirectMultiAssociationEndCachePolicy Methods
Protected Methods Public Methods
Collapse All

The methods of the IndirectMultiAssociationEndCachePolicy class are listed here.

Protected Methods
Name | Description
Changed | This is Changed, a member of class IndirectMultiAssociationEndCachePolicy.
IsInOrder | This is IsInOrder, a member of class IndirectMultiAssociationEndCachePolicy.
Resort | This is Resort, a member of class IndirectMultiAssociationEndCachePolicy.
Top
Public Methods
Name | Description
AdjustIndirectAdd | This is AdjustIndirectAdd, a member of class IndirectMultiAssociationEndCachePolicy.
AdjustIndirectRemove | This is AdjustIndirectRemove, a member of class IndirectMultiAssociationEndCachePolicy.
ClearOldValue | This is ClearOldValue, a member of class IndirectMultiAssociationEndCachePolicy.
FreeContent | This is FreeContent, a member of class IndirectMultiAssociationEndCachePolicy.
GetCount | This is GetCount, a member of class IndirectMultiAssociationEndCachePolicy.
GetEnsuredLinkLocatorList | This is GetEnsuredLinkLocatorList, a member of class IndirectMultiAssociationEndCachePolicy.
LinkTo_Current | This is LinkTo_Current, a member of class IndirectMultiAssociationEndCachePolicy.
LinkTo_CurrentAndFetched | This is LinkTo_CurrentAndFetched, a member of class IndirectMultiAssociationEndCachePolicy.
LinkTo_fetched | This is LinkTo_fetched, a member of class IndirectMultiAssociationEndCachePolicy.
Pass2 | This is Pass2, a member of class IndirectMultiAssociationEndCachePolicy.
SaveOldValue | This is SaveOldValue, a member of class IndirectMultiAssociationEndCachePolicy.
Unlink_Current | This is Unlink_Current, a member of class IndirectMultiAssociationEndCachePolicy.
Unlink_CurrentAndFetched | This is Unlink_CurrentAndFetched, a member of class IndirectMultiAssociationEndCachePolicy.
Unlink_fetched | This is Unlink_fetched, a member of class IndirectMultiAssociationEndCachePolicy.


IndirectMultiAssociationEndCachePolicy.AdjustIndirectAdd Method

IndirectMultiAssociationEndCachePolicy.AdjustIndirectAdd Method
IndirectMultiAssociationEndCachePolicy Class Eco.Framework.Impl Namespace See Also
Collapse All
C#
public void AdjustIndirectAdd(
    CacheLocator referredLocator,
    CacheLocator owningObject
);
Remarks

This is AdjustIndirectAdd, a member of class IndirectMultiAssociationEndCachePolicy.

See Also
IndirectMultiAssociationEndCachePolicy Class
Eco.Framework.Impl Namespace


IndirectMultiAssociationEndCachePolicy.AdjustIndirectRemove Method

IndirectMultiAssociationEndCachePolicy.AdjustIndirectRemove Method
IndirectMultiAssociationEndCachePolicy Class Eco.Framework.Impl Namespace See Also
Collapse All
C#
public void AdjustIndirectRemove(
    CacheLocator referredLocator,
    CacheLocator owningObject
);
Remarks

This is AdjustIndirectRemove, a member of class IndirectMultiAssociationEndCachePolicy.

See Also
IndirectMultiAssociationEndCachePolicy Class
Eco.Framework.Impl Namespace


IndirectMultiAssociationEndCachePolicy.Changed Method

IndirectMultiAssociationEndCachePolicy.Changed Method
IndirectMultiAssociationEndCachePolicy Class Eco.Framework.Impl Namespace See Also
Collapse All
C#
protected override void Changed(
    CacheLocator locator
);
Remarks

This is Changed, a member of class IndirectMultiAssociationEndCachePolicy.

See Also
IndirectMultiAssociationEndCachePolicy Class
Eco.Framework.Impl Namespace


IndirectMultiAssociationEndCachePolicy.ClearOldValue Method

IndirectMultiAssociationEndCachePolicy.ClearOldValue Method
IndirectMultiAssociationEndCachePolicy Class Eco.Framework.Impl Namespace See Also
Collapse All
C#
public override void ClearOldValue(
    object[] objectContents
);
Remarks

This is ClearOldValue, a member of class IndirectMultiAssociationEndCachePolicy.

See Also
IndirectMultiAssociationEndCachePolicy Class
Eco.Framework.Impl Namespace


IndirectMultiAssociationEndCachePolicy.FreeContent Method

IndirectMultiAssociationEndCachePolicy.FreeContent Method
IndirectMultiAssociationEndCachePolicy Class Eco.Framework.Impl Namespace See Also
Collapse All
C#
public override void FreeContent();
Remarks

This is FreeContent, a member of class IndirectMultiAssociationEndCachePolicy.

See Also
IndirectMultiAssociationEndCachePolicy Class
Eco.Framework.Impl Namespace


IndirectMultiAssociationEndCachePolicy.GetCount Method

IndirectMultiAssociationEndCachePolicy.GetCount Method
IndirectMultiAssociationEndCachePolicy Class Eco.Framework.Impl Namespace See Also
Collapse All
C#
public override int GetCount(
    CacheLocator owningObject
);
Remarks

This is GetCount, a member of class IndirectMultiAssociationEndCachePolicy.

See Also
IndirectMultiAssociationEndCachePolicy Class
Eco.Framework.Impl Namespace


IndirectMultiAssociationEndCachePolicy.GetEnsuredLinkLocatorList Method

IndirectMultiAssociationEndCachePolicy.GetEnsuredLinkLocatorList Method
IndirectMultiAssociationEndCachePolicy Class Eco.Framework.Impl Namespace See Also
Collapse All
C#
public List<CacheLocator> GetEnsuredLinkLocatorList(
    CacheLocator owningObject
);
Remarks

This is GetEnsuredLinkLocatorList, a member of class IndirectMultiAssociationEndCachePolicy.

See Also
IndirectMultiAssociationEndCachePolicy Class
Eco.Framework.Impl Namespace


IndirectMultiAssociationEndCachePolicy.IsInOrder Method

IndirectMultiAssociationEndCachePolicy.IsInOrder Method
IndirectMultiAssociationEndCachePolicy Class Eco.Framework.Impl Namespace See Also
Collapse All
C#
protected override bool IsInOrder(
    CacheLocator owningObject
);
Remarks

This is IsInOrder, a member of class IndirectMultiAssociationEndCachePolicy.

See Also
IndirectMultiAssociationEndCachePolicy Class
Eco.Framework.Impl Namespace


IndirectMultiAssociationEndCachePolicy.LinkTo_Current Method

IndirectMultiAssociationEndCachePolicy.LinkTo_Current Method
IndirectMultiAssociationEndCachePolicy Class Eco.Framework.Impl Namespace See Also
Collapse All
C#
public void LinkTo_Current(
    CacheLocator newLocator,
    CacheLocator owningObject
);
Remarks

This is LinkTo_Current, a member of class IndirectMultiAssociationEndCachePolicy.

See Also
IndirectMultiAssociationEndCachePolicy Class
Eco.Framework.Impl Namespace


IndirectMultiAssociationEndCachePolicy.LinkTo_CurrentAndFetched Method

IndirectMultiAssociationEndCachePolicy.LinkTo_CurrentAndFetched Method
IndirectMultiAssociationEndCachePolicy Class Eco.Framework.Impl Namespace See Also
Collapse All
C#
public void LinkTo_CurrentAndFetched(
    CacheLocator newLocator,
    CacheLocator owningObject
);
Remarks

This is LinkTo_CurrentAndFetched, a member of class IndirectMultiAssociationEndCachePolicy.

See Also
IndirectMultiAssociationEndCachePolicy Class
Eco.Framework.Impl Namespace


IndirectMultiAssociationEndCachePolicy.LinkTo_fetched Method

IndirectMultiAssociationEndCachePolicy.LinkTo_fetched Method
IndirectMultiAssociationEndCachePolicy Class Eco.Framework.Impl Namespace See Also
Collapse All
C#
public void LinkTo_fetched(
    CacheLocator newLocator,
    CacheLocator owningObject
);
Remarks

This is LinkTo_fetched, a member of class IndirectMultiAssociationEndCachePolicy.

See Also
IndirectMultiAssociationEndCachePolicy Class
Eco.Framework.Impl Namespace


IndirectMultiAssociationEndCachePolicy.Pass2 Method

IndirectMultiAssociationEndCachePolicy.Pass2 Method
IndirectMultiAssociationEndCachePolicy Class Eco.Framework.Impl Namespace See Also
Collapse All
C#
public override void Pass2();
Remarks

This is Pass2, a member of class IndirectMultiAssociationEndCachePolicy.

See Also
IndirectMultiAssociationEndCachePolicy Class
Eco.Framework.Impl Namespace


IndirectMultiAssociationEndCachePolicy.Resort Method

IndirectMultiAssociationEndCachePolicy.Resort Method
IndirectMultiAssociationEndCachePolicy Class Eco.Framework.Impl Namespace See Also
Collapse All
C#
protected override void Resort(
    CacheLocator owningObject
);
Remarks

This is Resort, a member of class IndirectMultiAssociationEndCachePolicy.

See Also
IndirectMultiAssociationEndCachePolicy Class
Eco.Framework.Impl Namespace


IndirectMultiAssociationEndCachePolicy.SaveOldValue Method

IndirectMultiAssociationEndCachePolicy.SaveOldValue Method
IndirectMultiAssociationEndCachePolicy Class Eco.Framework.Impl Namespace See Also
Collapse All
C#
public override void SaveOldValue(
    object[] objectContents
);
Remarks

This is SaveOldValue, a member of class IndirectMultiAssociationEndCachePolicy.

See Also
IndirectMultiAssociationEndCachePolicy Class
Eco.Framework.Impl Namespace


IndirectMultiAssociationEndCachePolicy.Unlink_Current Method

IndirectMultiAssociationEndCachePolicy.Unlink_Current Method
IndirectMultiAssociationEndCachePolicy Class Eco.Framework.Impl Namespace See Also
Collapse All
C#
public void Unlink_Current(
    CacheLocator oldLocator,
    CacheLocator owningObject
);
Remarks

This is Unlink_Current, a member of class IndirectMultiAssociationEndCachePolicy.

See Also
IndirectMultiAssociationEndCachePolicy Class
Eco.Framework.Impl Namespace


IndirectMultiAssociationEndCachePolicy.Unlink_CurrentAndFetched Method

IndirectMultiAssociationEndCachePolicy.Unlink_CurrentAndFetched Method
IndirectMultiAssociationEndCachePolicy Class Eco.Framework.Impl Namespace See Also
Collapse All
C#
public void Unlink_CurrentAndFetched(
    CacheLocator oldLocator,
    CacheLocator owningObject
);
Remarks

This is Unlink_CurrentAndFetched, a member of class IndirectMultiAssociationEndCachePolicy.

See Also
IndirectMultiAssociationEndCachePolicy Class
Eco.Framework.Impl Namespace


IndirectMultiAssociationEndCachePolicy.Unlink_fetched Method

IndirectMultiAssociationEndCachePolicy.Unlink_fetched Method
IndirectMultiAssociationEndCachePolicy Class Eco.Framework.Impl Namespace See Also
Collapse All
C#
public void Unlink_fetched(
    CacheLocator oldLocator,
    CacheLocator owningObject
);
Remarks

This is Unlink_fetched, a member of class IndirectMultiAssociationEndCachePolicy.

See Also
IndirectMultiAssociationEndCachePolicy Class
Eco.Framework.Impl Namespace


IndirectSingleAssociationEndCachePolicy Class

IndirectSingleAssociationEndCachePolicy Class
Inheritance Hierarchy See Also
Collapse All
C#
public class IndirectSingleAssociationEndCachePolicy : SingleAssociationEndCachePolicy, IOtherEndController, IIndirectController;
Remarks

This is class Eco.Framework.Impl.IndirectSingleAssociationEndCachePolicy.

Inheritance Hierarchy
Eco.Framework.Impl.MemberCachePolicy
    Eco.Framework.Impl.AssociationEndCachePolicy
        Eco.Framework.Impl.SingleAssociationEndCachePolicy
        Eco.Framework.Impl.IIndirectController
        Eco.Framework.Impl.IOtherEndController
            Eco.Framework.Impl.IndirectSingleAssociationEndCachePolicy
File

SingleAssociationEndPolicies.cs

See Also
Inheritance Hierarchy


IndirectSingleAssociationEndCachePolicy.IndirectSingleAssociationEndCachePolicy Constructor

IndirectSingleAssociationEndCachePolicy.IndirectSingleAssociationEndCachePolicy Constructor
IndirectSingleAssociationEndCachePolicy Class Eco.Framework.Impl Namespace See Also
Collapse All
C#
public IndirectSingleAssociationEndCachePolicy(
    ClassCachePolicy owner,
    IAssociationEnd associationEnd,
    int memberContentIndex,
    int flagIndex
);
Remarks

This is IndirectSingleAssociationEndCachePolicy, a member of class IndirectSingleAssociationEndCachePolicy.

See Also
IndirectSingleAssociationEndCachePolicy Class
Eco.Framework.Impl Namespace


IndirectSingleAssociationEndCachePolicy Methods

IndirectSingleAssociationEndCachePolicy Methods
Protected Methods Public Methods
Collapse All

The methods of the IndirectSingleAssociationEndCachePolicy class are listed here.

Protected Methods
Name | Description
Changed | This is Changed, a member of class IndirectSingleAssociationEndCachePolicy.
Top
Public Methods
Name | Description
AdjustIndirectAdd | This is AdjustIndirectAdd, a member of class IndirectSingleAssociationEndCachePolicy.
AdjustIndirectRemove | This is AdjustIndirectRemove, a member of class IndirectSingleAssociationEndCachePolicy.
ClearOldValue | This is ClearOldValue, a member of class IndirectSingleAssociationEndCachePolicy.
DoDeserialize | This is DoDeserialize, a member of class IndirectSingleAssociationEndCachePolicy.
DoSerialize | This is DoSerialize, a member of class IndirectSingleAssociationEndCachePolicy.
GetLinkObjectLocator | This is GetLinkObjectLocator, a member of class IndirectSingleAssociationEndCachePolicy.
LinkTo_Current | This is LinkTo_Current, a member of class IndirectSingleAssociationEndCachePolicy.
LinkTo_CurrentAndFetched | This is LinkTo_CurrentAndFetched, a member of class IndirectSingleAssociationEndCachePolicy.
LinkTo_fetched | This is LinkTo_fetched, a member of class IndirectSingleAssociationEndCachePolicy.
Pass2 | This is Pass2, a member of class IndirectSingleAssociationEndCachePolicy.
SaveOldValue | This is SaveOldValue, a member of class IndirectSingleAssociationEndCachePolicy.
SetLocator_Current | This is SetLocator_Current, a member of class IndirectSingleAssociationEndCachePolicy.
Unlink_Current | This is Unlink_Current, a member of class IndirectSingleAssociationEndCachePolicy.
Unlink_CurrentAndFetched | This is Unlink_CurrentAndFetched, a member of class IndirectSingleAssociationEndCachePolicy.
Unlink_fetched | This is Unlink_fetched, a member of class IndirectSingleAssociationEndCachePolicy.


IndirectSingleAssociationEndCachePolicy.AdjustIndirectAdd Method

IndirectSingleAssociationEndCachePolicy.AdjustIndirectAdd Method
IndirectSingleAssociationEndCachePolicy Class Eco.Framework.Impl Namespace See Also
Collapse All
C#
public void AdjustIndirectAdd(
    CacheLocator ReferredLocator,
    CacheLocator owningObject
);
Remarks

This is AdjustIndirectAdd, a member of class IndirectSingleAssociationEndCachePolicy.

See Also
IndirectSingleAssociationEndCachePolicy Class
Eco.Framework.Impl Namespace


IndirectSingleAssociationEndCachePolicy.AdjustIndirectRemove Method

IndirectSingleAssociationEndCachePolicy.AdjustIndirectRemove Method
IndirectSingleAssociationEndCachePolicy Class Eco.Framework.Impl Namespace See Also
Collapse All
C#
public void AdjustIndirectRemove(
    CacheLocator referredLocator,
    CacheLocator owningObject
);
Remarks

This is AdjustIndirectRemove, a member of class IndirectSingleAssociationEndCachePolicy.

See Also
IndirectSingleAssociationEndCachePolicy Class
Eco.Framework.Impl Namespace


IndirectSingleAssociationEndCachePolicy.Changed Method

IndirectSingleAssociationEndCachePolicy.Changed Method
IndirectSingleAssociationEndCachePolicy Class Eco.Framework.Impl Namespace See Also
Collapse All
C#
protected override void Changed(
    CacheLocator locator
);
Remarks

This is Changed, a member of class IndirectSingleAssociationEndCachePolicy.

See Also
IndirectSingleAssociationEndCachePolicy Class
Eco.Framework.Impl Namespace


IndirectSingleAssociationEndCachePolicy.ClearOldValue Method

IndirectSingleAssociationEndCachePolicy.ClearOldValue Method
IndirectSingleAssociationEndCachePolicy Class Eco.Framework.Impl Namespace See Also
Collapse All
C#
public override void ClearOldValue(
    object[] objectContents
);
Remarks

This is ClearOldValue, a member of class IndirectSingleAssociationEndCachePolicy.

See Also
IndirectSingleAssociationEndCachePolicy Class
Eco.Framework.Impl Namespace


IndirectSingleAssociationEndCachePolicy.DoDeserialize Method

IndirectSingleAssociationEndCachePolicy.DoDeserialize Method
IndirectSingleAssociationEndCachePolicy Class Eco.Framework.Impl Namespace See Also
Collapse All
C#
public override void DoDeserialize(
    CacheLocator locator,
    Stream source
);
Remarks

This is DoDeserialize, a member of class IndirectSingleAssociationEndCachePolicy.

See Also
IndirectSingleAssociationEndCachePolicy Class
Eco.Framework.Impl Namespace


IndirectSingleAssociationEndCachePolicy.DoSerialize Method

IndirectSingleAssociationEndCachePolicy.DoSerialize Method
IndirectSingleAssociationEndCachePolicy Class Eco.Framework.Impl Namespace See Also
Collapse All
C#
public override void DoSerialize(
    CacheLocator locator,
    Stream target,
    EcoSpaceSerializationConfig config
);
Remarks

This is DoSerialize, a member of class IndirectSingleAssociationEndCachePolicy.

See Also
IndirectSingleAssociationEndCachePolicy Class
Eco.Framework.Impl Namespace


IndirectSingleAssociationEndCachePolicy.GetLinkObjectLocator Method

IndirectSingleAssociationEndCachePolicy.GetLinkObjectLocator Method
IndirectSingleAssociationEndCachePolicy Class Eco.Framework.Impl Namespace See Also
Collapse All
C#
public CacheLocator GetLinkObjectLocator(
    CacheLocator owningObject
);
Remarks

This is GetLinkObjectLocator, a member of class IndirectSingleAssociationEndCachePolicy.

See Also
IndirectSingleAssociationEndCachePolicy Class
Eco.Framework.Impl Namespace


IndirectSingleAssociationEndCachePolicy.LinkTo_Current Method

IndirectSingleAssociationEndCachePolicy.LinkTo_Current Method
IndirectSingleAssociationEndCachePolicy Class Eco.Framework.Impl Namespace See Also
Collapse All
C#
public void LinkTo_Current(
    CacheLocator newLocator,
    CacheLocator owningObject
);
Remarks

This is LinkTo_Current, a member of class IndirectSingleAssociationEndCachePolicy.

See Also
IndirectSingleAssociationEndCachePolicy Class
Eco.Framework.Impl Namespace


IndirectSingleAssociationEndCachePolicy.LinkTo_CurrentAndFetched Method

IndirectSingleAssociationEndCachePolicy.LinkTo_CurrentAndFetched Method
IndirectSingleAssociationEndCachePolicy Class Eco.Framework.Impl Namespace See Also
Collapse All
C#
public void LinkTo_CurrentAndFetched(
    CacheLocator newLocator,
    CacheLocator owningObject
);
Remarks

This is LinkTo_CurrentAndFetched, a member of class IndirectSingleAssociationEndCachePolicy.

See Also
IndirectSingleAssociationEndCachePolicy Class
Eco.Framework.Impl Namespace


IndirectSingleAssociationEndCachePolicy.LinkTo_fetched Method

IndirectSingleAssociationEndCachePolicy.LinkTo_fetched Method
IndirectSingleAssociationEndCachePolicy Class Eco.Framework.Impl Namespace See Also
Collapse All
C#
public void LinkTo_fetched(
    CacheLocator newLocator,
    CacheLocator owningObject
);
Remarks

This is LinkTo_fetched, a member of class IndirectSingleAssociationEndCachePolicy.

See Also
IndirectSingleAssociationEndCachePolicy Class
Eco.Framework.Impl Namespace


IndirectSingleAssociationEndCachePolicy.Pass2 Method

IndirectSingleAssociationEndCachePolicy.Pass2 Method
IndirectSingleAssociationEndCachePolicy Class Eco.Framework.Impl Namespace See Also
Collapse All
C#
public override void Pass2();
Remarks

This is Pass2, a member of class IndirectSingleAssociationEndCachePolicy.

See Also
IndirectSingleAssociationEndCachePolicy Class
Eco.Framework.Impl Namespace


IndirectSingleAssociationEndCachePolicy.SaveOldValue Method

IndirectSingleAssociationEndCachePolicy.SaveOldValue Method
IndirectSingleAssociationEndCachePolicy Class Eco.Framework.Impl Namespace See Also
Collapse All
C#
public override void SaveOldValue(
    object[] objectContents
);
Remarks

This is SaveOldValue, a member of class IndirectSingleAssociationEndCachePolicy.

See Also
IndirectSingleAssociationEndCachePolicy Class
Eco.Framework.Impl Namespace


IndirectSingleAssociationEndCachePolicy.SetLocator_Current Method

IndirectSingleAssociationEndCachePolicy.SetLocator_Current Method
IndirectSingleAssociationEndCachePolicy Class Eco.Framework.Impl Namespace See Also
Collapse All
C#
public override void SetLocator_Current(
    CacheLocator newLocator,
    CacheLocator owningObject
);
Remarks

This is SetLocator_Current, a member of class IndirectSingleAssociationEndCachePolicy.

See Also
IndirectSingleAssociationEndCachePolicy Class
Eco.Framework.Impl Namespace


IndirectSingleAssociationEndCachePolicy.Unlink_Current Method

IndirectSingleAssociationEndCachePolicy.Unlink_Current Method
IndirectSingleAssociationEndCachePolicy Class Eco.Framework.Impl Namespace See Also
Collapse All
C#
public void Unlink_Current(
    CacheLocator oldLocator,
    CacheLocator owningObject
);
Remarks

This is Unlink_Current, a member of class IndirectSingleAssociationEndCachePolicy.

See Also
IndirectSingleAssociationEndCachePolicy Class
Eco.Framework.Impl Namespace


IndirectSingleAssociationEndCachePolicy.Unlink_CurrentAndFetched Method

IndirectSingleAssociationEndCachePolicy.Unlink_CurrentAndFetched Method
IndirectSingleAssociationEndCachePolicy Class Eco.Framework.Impl Namespace See Also
Collapse All
C#
public void Unlink_CurrentAndFetched(
    CacheLocator oldLocator,
    CacheLocator owningObject
);
Remarks

This is Unlink_CurrentAndFetched, a member of class IndirectSingleAssociationEndCachePolicy.

See Also
IndirectSingleAssociationEndCachePolicy Class
Eco.Framework.Impl Namespace


IndirectSingleAssociationEndCachePolicy.Unlink_fetched Method

IndirectSingleAssociationEndCachePolicy.Unlink_fetched Method
IndirectSingleAssociationEndCachePolicy Class Eco.Framework.Impl Namespace See Also
Collapse All
C#
public void Unlink_fetched(
    CacheLocator oldLocator,
    CacheLocator owningObject
);
Remarks

This is Unlink_fetched, a member of class IndirectSingleAssociationEndCachePolicy.

See Also
IndirectSingleAssociationEndCachePolicy Class
Eco.Framework.Impl Namespace


InnerAssociationEndCachePolicy Class

InnerAssociationEndCachePolicy Class
Inheritance Hierarchy See Also
Collapse All
C#
public class InnerAssociationEndCachePolicy : DirectSingleAssociationEndCachePolicy;
Remarks

This is class Eco.Framework.Impl.InnerAssociationEndCachePolicy.

Inheritance Hierarchy
Eco.Framework.Impl.MemberCachePolicy
    Eco.Framework.Impl.AssociationEndCachePolicy
        Eco.Framework.Impl.SingleAssociationEndCachePolicy
        Eco.Framework.Impl.IOtherEndController
            Eco.Framework.Impl.DirectSingleAssociationEndCachePolicy
                Eco.Framework.Impl.InnerAssociationEndCachePolicy
File

SingleAssociationEndPolicies.cs

See Also
Inheritance Hierarchy


InnerAssociationEndCachePolicy.InnerAssociationEndCachePolicy Constructor

InnerAssociationEndCachePolicy.InnerAssociationEndCachePolicy Constructor
InnerAssociationEndCachePolicy Class Eco.Framework.Impl Namespace See Also
Collapse All
C#
public InnerAssociationEndCachePolicy(
    ClassCachePolicy owner,
    IAssociationEnd associationEnd,
    int memberContentIndex,
    int flagIndex
);
Remarks

This is InnerAssociationEndCachePolicy, a member of class InnerAssociationEndCachePolicy.

See Also
InnerAssociationEndCachePolicy Class
Eco.Framework.Impl Namespace


InnerAssociationEndCachePolicy Fields

InnerAssociationEndCachePolicy Fields
Public Fields
Collapse All

The fields of the InnerAssociationEndCachePolicy class are listed here.

Public Fields
Name | Description
m_OhterInnerPolicy | This is m_OhterInnerPolicy, a member of class InnerAssociationEndCachePolicy.


InnerAssociationEndCachePolicy.m_OhterInnerPolicy Field

InnerAssociationEndCachePolicy.m_OhterInnerPolicy Field
InnerAssociationEndCachePolicy Class Eco.Framework.Impl Namespace See Also
Collapse All
C#
public InnerAssociationEndCachePolicy m_OhterInnerPolicy = null;
Remarks

This is m_OhterInnerPolicy, a member of class InnerAssociationEndCachePolicy.

See Also
InnerAssociationEndCachePolicy Class
Eco.Framework.Impl Namespace


InnerAssociationEndCachePolicy Methods

InnerAssociationEndCachePolicy Methods
Public Methods
Collapse All

The methods of the InnerAssociationEndCachePolicy class are listed here.

Public Methods
Name | Description
Pass2 | This is Pass2, a member of class InnerAssociationEndCachePolicy.
SetCurrentAndFetchedValue | This is SetCurrentAndFetchedValue, a member of class InnerAssociationEndCachePolicy.
SetLocator_Current | This is SetLocator_Current, a member of class InnerAssociationEndCachePolicy.


InnerAssociationEndCachePolicy.Pass2 Method

InnerAssociationEndCachePolicy.Pass2 Method
InnerAssociationEndCachePolicy Class Eco.Framework.Impl Namespace See Also
Collapse All
C#
public override void Pass2();
Remarks

This is Pass2, a member of class InnerAssociationEndCachePolicy.

See Also
InnerAssociationEndCachePolicy Class
Eco.Framework.Impl Namespace


InnerAssociationEndCachePolicy.SetCurrentAndFetchedValue Method

InnerAssociationEndCachePolicy.SetCurrentAndFetchedValue Method
InnerAssociationEndCachePolicy Class Eco.Framework.Impl Namespace See Also
Collapse All
C#
public override void SetCurrentAndFetchedValue(
    object value,
    CacheLocator owningObject
);
Remarks

This is SetCurrentAndFetchedValue, a member of class InnerAssociationEndCachePolicy.

See Also
InnerAssociationEndCachePolicy Class
Eco.Framework.Impl Namespace


InnerAssociationEndCachePolicy.SetLocator_Current Method

InnerAssociationEndCachePolicy.SetLocator_Current Method
InnerAssociationEndCachePolicy Class Eco.Framework.Impl Namespace See Also
Collapse All
C#
public override void SetLocator_Current(
    CacheLocator newLocator,
    CacheLocator owningObject
);
Remarks

This is SetLocator_Current, a member of class InnerAssociationEndCachePolicy.

See Also
InnerAssociationEndCachePolicy Class
Eco.Framework.Impl Namespace


LinkObjectMultiAssociationEndCachePolicy Class

LinkObjectMultiAssociationEndCachePolicy Class
Inheritance Hierarchy See Also
Collapse All
C#
public class LinkObjectMultiAssociationEndCachePolicy : MultiAssociationEndCachePolicy;
Remarks

This is class Eco.Framework.Impl.LinkObjectMultiAssociationEndCachePolicy.

Inheritance Hierarchy
Eco.Framework.Impl.MemberCachePolicy
    Eco.Framework.Impl.AssociationEndCachePolicy
        Eco.Framework.Impl.MultiAssociationEndCachePolicy
            Eco.Framework.Impl.LinkObjectMultiAssociationEndCachePolicy
File

MultiAssociationEndPolicies.cs

See Also
Inheritance Hierarchy


LinkObjectMultiAssociationEndCachePolicy.LinkObjectMultiAssociationEndCachePolicy Constructor

LinkObjectMultiAssociationEndCachePolicy.LinkObjectMultiAssociationEndCachePolicy Constructor
LinkObjectMultiAssociationEndCachePolicy Class Eco.Framework.Impl Namespace See Also
Collapse All
C#
public LinkObjectMultiAssociationEndCachePolicy(
    ClassCachePolicy owner,
    IAssociationEnd associationEnd,
    int memberContentIndex,
    int flagIndex
);
Remarks

This is LinkObjectMultiAssociationEndCachePolicy, a member of class LinkObjectMultiAssociationEndCachePolicy.

See Also
LinkObjectMultiAssociationEndCachePolicy Class
Eco.Framework.Impl Namespace


LinkObjectMultiAssociationEndCachePolicy Methods

LinkObjectMultiAssociationEndCachePolicy Methods
Public Methods
Collapse All

The methods of the LinkObjectMultiAssociationEndCachePolicy class are listed here.

Public Methods
Name | Description
ClearOldValue | This is ClearOldValue, a member of class LinkObjectMultiAssociationEndCachePolicy.
EnsureOrder | This is EnsureOrder, a member of class LinkObjectMultiAssociationEndCachePolicy.
GetCount | This is GetCount, a member of class LinkObjectMultiAssociationEndCachePolicy.
GetPersistenceState | overridden for association ends pointing at link objects, where main end is used.
Pass2 | This is Pass2, a member of class LinkObjectMultiAssociationEndCachePolicy.
SaveOldValue | This is SaveOldValue, a member of class LinkObjectMultiAssociationEndCachePolicy.
SetPersistenceState | overridden for association ends pointing at link objects, where main end is used.


LinkObjectMultiAssociationEndCachePolicy.ClearOldValue Method

LinkObjectMultiAssociationEndCachePolicy.ClearOldValue Method
LinkObjectMultiAssociationEndCachePolicy Class Eco.Framework.Impl Namespace See Also
Collapse All
C#
public override void ClearOldValue(
    object[] objectContents
);
Remarks

This is ClearOldValue, a member of class LinkObjectMultiAssociationEndCachePolicy.

See Also
LinkObjectMultiAssociationEndCachePolicy Class
Eco.Framework.Impl Namespace


LinkObjectMultiAssociationEndCachePolicy.EnsureOrder Method

LinkObjectMultiAssociationEndCachePolicy.EnsureOrder Method
LinkObjectMultiAssociationEndCachePolicy Class Eco.Framework.Impl Namespace See Also
Collapse All
C#
public override void EnsureOrder(
    CacheLocator owningObject
);
Remarks

This is EnsureOrder, a member of class LinkObjectMultiAssociationEndCachePolicy.

See Also
LinkObjectMultiAssociationEndCachePolicy Class
Eco.Framework.Impl Namespace


LinkObjectMultiAssociationEndCachePolicy.GetCount Method

LinkObjectMultiAssociationEndCachePolicy.GetCount Method
LinkObjectMultiAssociationEndCachePolicy Class Eco.Framework.Impl Namespace See Also
Collapse All
C#
public override int GetCount(
    CacheLocator owningObject
);
Remarks

This is GetCount, a member of class LinkObjectMultiAssociationEndCachePolicy.

See Also
LinkObjectMultiAssociationEndCachePolicy Class
Eco.Framework.Impl Namespace


LinkObjectMultiAssociationEndCachePolicy.GetPersistenceState Method

LinkObjectMultiAssociationEndCachePolicy.GetPersistenceState Method
LinkObjectMultiAssociationEndCachePolicy Class Eco.Framework.Impl Namespace See Also
Collapse All
C#
public override PersistenceState GetPersistenceState(
    object[] objectContents
);
Remarks

overridden for association ends pointing at link objects, where main end is used.

See Also
LinkObjectMultiAssociationEndCachePolicy Class
Eco.Framework.Impl Namespace


LinkObjectMultiAssociationEndCachePolicy.Pass2 Method

LinkObjectMultiAssociationEndCachePolicy.Pass2 Method
LinkObjectMultiAssociationEndCachePolicy Class Eco.Framework.Impl Namespace See Also
Collapse All
C#
public override void Pass2();
Remarks

This is Pass2, a member of class LinkObjectMultiAssociationEndCachePolicy.

See Also
LinkObjectMultiAssociationEndCachePolicy Class
Eco.Framework.Impl Namespace


LinkObjectMultiAssociationEndCachePolicy.SaveOldValue Method

LinkObjectMultiAssociationEndCachePolicy.SaveOldValue Method
LinkObjectMultiAssociationEndCachePolicy Class Eco.Framework.Impl Namespace See Also
Collapse All
C#
public override void SaveOldValue(
    object[] objectContents
);
Remarks

This is SaveOldValue, a member of class LinkObjectMultiAssociationEndCachePolicy.

See Also
LinkObjectMultiAssociationEndCachePolicy Class
Eco.Framework.Impl Namespace


LinkObjectMultiAssociationEndCachePolicy.SetPersistenceState Method

LinkObjectMultiAssociationEndCachePolicy.SetPersistenceState Method
LinkObjectMultiAssociationEndCachePolicy Class Eco.Framework.Impl Namespace See Also
Collapse All
C#
public override void SetPersistenceState(
    object[] objectContents,
    CacheLocator locator,
    PersistenceState value
);
Remarks

overridden for association ends pointing at link objects, where main end is used.

See Also
LinkObjectMultiAssociationEndCachePolicy Class
Eco.Framework.Impl Namespace


LinkObjectSingleAssociationEndCachePolicy Class

LinkObjectSingleAssociationEndCachePolicy Class
Inheritance Hierarchy See Also
Collapse All
C#
public class LinkObjectSingleAssociationEndCachePolicy : SingleAssociationEndCachePolicy;
Remarks

This is class Eco.Framework.Impl.LinkObjectSingleAssociationEndCachePolicy.

Inheritance Hierarchy
Eco.Framework.Impl.MemberCachePolicy
    Eco.Framework.Impl.AssociationEndCachePolicy
        Eco.Framework.Impl.SingleAssociationEndCachePolicy
            Eco.Framework.Impl.LinkObjectSingleAssociationEndCachePolicy
File

SingleAssociationEndPolicies.cs

See Also
Inheritance Hierarchy


LinkObjectSingleAssociationEndCachePolicy.LinkObjectSingleAssociationEndCachePolicy Constructor

LinkObjectSingleAssociationEndCachePolicy.LinkObjectSingleAssociationEndCachePolicy Constructor
LinkObjectSingleAssociationEndCachePolicy Class Eco.Framework.Impl Namespace See Also
Collapse All
C#
public LinkObjectSingleAssociationEndCachePolicy(
    ClassCachePolicy owner,
    IAssociationEnd associationEnd,
    int memberContentIndex,
    int flagIndex
);
Remarks

This is LinkObjectSingleAssociationEndCachePolicy, a member of class LinkObjectSingleAssociationEndCachePolicy.

See Also
LinkObjectSingleAssociationEndCachePolicy Class
Eco.Framework.Impl Namespace


LinkObjectSingleAssociationEndCachePolicy Methods

LinkObjectSingleAssociationEndCachePolicy Methods
Public Methods
Collapse All

The methods of the LinkObjectSingleAssociationEndCachePolicy class are listed here.

Public Methods
Name | Description
ClearOldValue | This is ClearOldValue, a member of class LinkObjectSingleAssociationEndCachePolicy.
GetPersistenceState | overridden for association ends pointing at link objects, where main end is used.
Pass2 | This is Pass2, a member of class LinkObjectSingleAssociationEndCachePolicy.
SaveOldValue | This is SaveOldValue, a member of class LinkObjectSingleAssociationEndCachePolicy.
SetLocator_Current | This is SetLocator_Current, a member of class LinkObjectSingleAssociationEndCachePolicy.
SetPersistenceState | overridden for association ends pointing at link objects, where main end is used.


LinkObjectSingleAssociationEndCachePolicy.ClearOldValue Method

LinkObjectSingleAssociationEndCachePolicy.ClearOldValue Method
LinkObjectSingleAssociationEndCachePolicy Class Eco.Framework.Impl Namespace See Also
Collapse All
C#
public override void ClearOldValue(
    object[] objectContents
);
Remarks

This is ClearOldValue, a member of class LinkObjectSingleAssociationEndCachePolicy.

See Also
LinkObjectSingleAssociationEndCachePolicy Class
Eco.Framework.Impl Namespace


LinkObjectSingleAssociationEndCachePolicy.GetPersistenceState Method

LinkObjectSingleAssociationEndCachePolicy.GetPersistenceState Method
LinkObjectSingleAssociationEndCachePolicy Class Eco.Framework.Impl Namespace See Also
Collapse All
C#
public override PersistenceState GetPersistenceState(
    object[] objectContents
);
Remarks

overridden for association ends pointing at link objects, where main end is used.

See Also
LinkObjectSingleAssociationEndCachePolicy Class
Eco.Framework.Impl Namespace


LinkObjectSingleAssociationEndCachePolicy.Pass2 Method

LinkObjectSingleAssociationEndCachePolicy.Pass2 Method
LinkObjectSingleAssociationEndCachePolicy Class Eco.Framework.Impl Namespace See Also
Collapse All
C#
public override void Pass2();
Remarks

This is Pass2, a member of class LinkObjectSingleAssociationEndCachePolicy.

See Also
LinkObjectSingleAssociationEndCachePolicy Class
Eco.Framework.Impl Namespace


LinkObjectSingleAssociationEndCachePolicy.SaveOldValue Method

LinkObjectSingleAssociationEndCachePolicy.SaveOldValue Method
LinkObjectSingleAssociationEndCachePolicy Class Eco.Framework.Impl Namespace See Also
Collapse All
C#
public override void SaveOldValue(
    object[] objectContents
);
Remarks

This is SaveOldValue, a member of class LinkObjectSingleAssociationEndCachePolicy.

See Also
LinkObjectSingleAssociationEndCachePolicy Class
Eco.Framework.Impl Namespace


LinkObjectSingleAssociationEndCachePolicy.SetLocator_Current Method

LinkObjectSingleAssociationEndCachePolicy.SetLocator_Current Method
LinkObjectSingleAssociationEndCachePolicy Class Eco.Framework.Impl Namespace See Also
Collapse All
C#
public override void SetLocator_Current(
    CacheLocator newLocator,
    CacheLocator owningObject
);
Remarks

This is SetLocator_Current, a member of class LinkObjectSingleAssociationEndCachePolicy.

See Also
LinkObjectSingleAssociationEndCachePolicy Class
Eco.Framework.Impl Namespace


LinkObjectSingleAssociationEndCachePolicy.SetPersistenceState Method

LinkObjectSingleAssociationEndCachePolicy.SetPersistenceState Method
LinkObjectSingleAssociationEndCachePolicy Class Eco.Framework.Impl Namespace See Also
Collapse All
C#
public override void SetPersistenceState(
    object[] objectContents,
    CacheLocator locator,
    PersistenceState value
);
Remarks

overridden for association ends pointing at link objects, where main end is used.

See Also
LinkObjectSingleAssociationEndCachePolicy Class
Eco.Framework.Impl Namespace


LocatorDictionary Class

LocatorDictionary Class
Inheritance Hierarchy See Also
Collapse All
C#
public class LocatorDictionary;
Remarks

This is class Eco.Framework.Impl.LocatorDictionary.

Inheritance Hierarchy
Eco.Framework.Impl.LocatorDictionary
File

LocatorDictionary.cs

See Also
Inheritance Hierarchy


LocatorDictionary.LocatorDictionary Constructor

LocatorDictionary.LocatorDictionary Constructor
LocatorDictionary Class Eco.Framework.Impl Namespace See Also
Collapse All
C#
public LocatorDictionary();
Remarks

This is LocatorDictionary, a member of class LocatorDictionary.

See Also
LocatorDictionary Class
Eco.Framework.Impl Namespace


LocatorDictionary Methods

LocatorDictionary Methods
Public Methods
Collapse All

The methods of the LocatorDictionary class are listed here.

Public Methods
Name | Description
Add | This is Add, a member of class LocatorDictionary.
ContainsInstance | This is ContainsInstance, a member of class LocatorDictionary.
GetLocators | This is GetLocators, a member of class LocatorDictionary.
Remove | This is Remove, a member of class LocatorDictionary.
this | This is this, a member of class LocatorDictionary.
UpdateID | This is UpdateID, a member of class LocatorDictionary.


LocatorDictionary.Add Method

LocatorDictionary.Add Method
LocatorDictionary Class Eco.Framework.Impl Namespace See Also
Collapse All
C#
public void Add(
    CacheLocator Locator
);
Remarks

This is Add, a member of class LocatorDictionary.

See Also
LocatorDictionary Class
Eco.Framework.Impl Namespace


LocatorDictionary.ContainsInstance Method

LocatorDictionary.ContainsInstance Method
LocatorDictionary Class Eco.Framework.Impl Namespace See Also
Collapse All
C#
public bool ContainsInstance(
    CacheLocator Locator
);
Remarks

This is ContainsInstance, a member of class LocatorDictionary.

See Also
LocatorDictionary Class
Eco.Framework.Impl Namespace


LocatorDictionary.GetLocators Method

LocatorDictionary.GetLocators Method
LocatorDictionary Class Eco.Framework.Impl Namespace See Also
Collapse All
C#
public ICollection GetLocators();
Remarks

This is GetLocators, a member of class LocatorDictionary.

See Also
LocatorDictionary Class
Eco.Framework.Impl Namespace


LocatorDictionary.Remove Method

LocatorDictionary.Remove Method
LocatorDictionary Class Eco.Framework.Impl Namespace See Also
Collapse All
C#
public void Remove(
    CacheLocator Locator
);
Remarks

This is Remove, a member of class LocatorDictionary.

See Also
LocatorDictionary Class
Eco.Framework.Impl Namespace


LocatorDictionary.this Indexer

LocatorDictionary.this Indexer
LocatorDictionary Class Eco.Framework.Impl Namespace See Also
Collapse All
C#
public CacheLocator this[
    ObjectId objectID
];
Remarks

This is this, a member of class LocatorDictionary.

See Also
LocatorDictionary Class
Eco.Framework.Impl Namespace


LocatorDictionary.UpdateID Method

LocatorDictionary.UpdateID Method
LocatorDictionary Class Eco.Framework.Impl Namespace See Also
Collapse All
C#
public void UpdateID(
    CacheLocator Locator,
    ObjectId NewObjectID,
    bool AllowInternal
);
Remarks

This is UpdateID, a member of class LocatorDictionary.

See Also
LocatorDictionary Class
Eco.Framework.Impl Namespace


MainMultiAssociationEndCachePolicy Class

MainMultiAssociationEndCachePolicy Class
Inheritance Hierarchy See Also
Collapse All
C#
public abstract class MainMultiAssociationEndCachePolicy : MultiAssociationEndCachePolicy;
Remarks

This is class Eco.Framework.Impl.MainMultiAssociationEndCachePolicy.

Inheritance Hierarchy
Eco.Framework.Impl.MemberCachePolicy
    Eco.Framework.Impl.AssociationEndCachePolicy
        Eco.Framework.Impl.MultiAssociationEndCachePolicy
            Eco.Framework.Impl.MainMultiAssociationEndCachePolicy
                Eco.Framework.Impl.DirectMultiAssociationEndCachePolicy
                Eco.Framework.Impl.IndirectMultiAssociationEndCachePolicy
File

MultiAssociationEndPolicies.cs

See Also
Inheritance Hierarchy


MainMultiAssociationEndCachePolicy.MainMultiAssociationEndCachePolicy Constructor

MainMultiAssociationEndCachePolicy.MainMultiAssociationEndCachePolicy Constructor
MainMultiAssociationEndCachePolicy Class Eco.Framework.Impl Namespace See Also
Collapse All
C#
public MainMultiAssociationEndCachePolicy(
    ClassCachePolicy owner,
    IAssociationEnd associationEnd,
    int memberContentIndex,
    int flagIndex
);
Remarks

This is MainMultiAssociationEndCachePolicy, a member of class MainMultiAssociationEndCachePolicy.

See Also
MainMultiAssociationEndCachePolicy Class
Eco.Framework.Impl Namespace


MainMultiAssociationEndCachePolicy Methods

MainMultiAssociationEndCachePolicy Methods
Protected Methods Public Methods
Collapse All

The methods of the MainMultiAssociationEndCachePolicy class are listed here.

Protected Methods
Name | Description
IsInOrder | This is IsInOrder, a member of class MainMultiAssociationEndCachePolicy.
Resort | This is Resort, a member of class MainMultiAssociationEndCachePolicy.
Top
Public Methods
Name | Description
EnsureOrder | This is EnsureOrder, a member of class MainMultiAssociationEndCachePolicy.
MarkPossiblyOutOfOrder | This is MarkPossiblyOutOfOrder, a member of class MainMultiAssociationEndCachePolicy.


MainMultiAssociationEndCachePolicy.EnsureOrder Method

MainMultiAssociationEndCachePolicy.EnsureOrder Method
MainMultiAssociationEndCachePolicy Class Eco.Framework.Impl Namespace See Also
Collapse All
C#
public override void EnsureOrder(
    CacheLocator owningObject
);
Remarks

This is EnsureOrder, a member of class MainMultiAssociationEndCachePolicy.

See Also
MainMultiAssociationEndCachePolicy Class
Eco.Framework.Impl Namespace


MainMultiAssociationEndCachePolicy.IsInOrder Method

MainMultiAssociationEndCachePolicy.IsInOrder Method
MainMultiAssociationEndCachePolicy Class Eco.Framework.Impl Namespace See Also
Collapse All
C#
protected abstract bool IsInOrder(
    CacheLocator owningObject
);
Remarks

This is IsInOrder, a member of class MainMultiAssociationEndCachePolicy.

See Also
MainMultiAssociationEndCachePolicy Class
Eco.Framework.Impl Namespace


MainMultiAssociationEndCachePolicy.MarkPossiblyOutOfOrder Method

MainMultiAssociationEndCachePolicy.MarkPossiblyOutOfOrder Method
MainMultiAssociationEndCachePolicy Class Eco.Framework.Impl Namespace See Also
Collapse All
C#
public void MarkPossiblyOutOfOrder(
    CacheLocator owningObject
);
Remarks

This is MarkPossiblyOutOfOrder, a member of class MainMultiAssociationEndCachePolicy.

See Also
MainMultiAssociationEndCachePolicy Class
Eco.Framework.Impl Namespace


MainMultiAssociationEndCachePolicy.Resort Method

MainMultiAssociationEndCachePolicy.Resort Method
MainMultiAssociationEndCachePolicy Class Eco.Framework.Impl Namespace See Also
Collapse All
C#
protected abstract void Resort(
    CacheLocator owningObject
);
Remarks

This is Resort, a member of class MainMultiAssociationEndCachePolicy.

See Also
MainMultiAssociationEndCachePolicy Class
Eco.Framework.Impl Namespace


MemberCachePolicy Class

MemberCachePolicy Class
Inheritance Hierarchy See Also
Collapse All
C#
public abstract class MemberCachePolicy;
Remarks

This is class Eco.Framework.Impl.MemberCachePolicy.

Inheritance Hierarchy
Eco.Framework.Impl.MemberCachePolicy
    Eco.Framework.Impl.AssociationEndCachePolicy
    Eco.Framework.Impl.AttributeCachePolicy
File

MemberClassPolicy.cs

See Also
Inheritance Hierarchy


MemberCachePolicy.MemberCachePolicy Constructor

MemberCachePolicy.MemberCachePolicy Constructor
MemberCachePolicy Class Eco.Framework.Impl Namespace See Also
Collapse All
C#
public MemberCachePolicy(
    ClassCachePolicy Owner,
    IStructuralFeature structuralFeature,
    int MemberContentIndex,
    int FlagIndex
);
Remarks

This is MemberCachePolicy, a member of class MemberCachePolicy.

See Also
MemberCachePolicy Class
Eco.Framework.Impl Namespace


MemberCachePolicy Classes

MemberCachePolicy Classes
Classes
Collapse All

The classes of the MemberCachePolicy class are listed here.

Classes
Name | Description
MemberFlags | This is class Eco.Framework.Impl.MemberCachePolicy.MemberFlags.


MemberCachePolicy.MemberFlags Class

MemberCachePolicy.MemberFlags Class
Inheritance Hierarchy See Also
Collapse All
C#
protected static class MemberFlags;
Remarks

This is class Eco.Framework.Impl.MemberCachePolicy.MemberFlags.

Inheritance Hierarchy
Eco.Framework.Impl.MemberCachePolicy.MemberFlags
File

MemberClassPolicy.cs

See Also
Inheritance Hierarchy


MemberFlags Fields

MemberFlags Fields
Public Fields
Collapse All

The fields of the MemberFlags class are listed here.

Public Fields
Name | Description
HasOldValue | 0001 0000
MayBeOutOfOrder | 0000 1000
PersistenceStateMask | 0000 0011
Touched | 0000 0100


MemberCachePolicy.MemberFlags.HasOldValue Field

MemberCachePolicy.MemberFlags.HasOldValue Field
MemberCachePolicy.MemberFlags Class Eco.Framework.Impl Namespace See Also
Collapse All
C#
public const int HasOldValue = 16;
Remarks

0001 0000

See Also
MemberCachePolicy.MemberFlags Class
Eco.Framework.Impl Namespace


MemberCachePolicy.MemberFlags.MayBeOutOfOrder Field

MemberCachePolicy.MemberFlags.MayBeOutOfOrder Field
MemberCachePolicy.MemberFlags Class Eco.Framework.Impl Namespace See Also
Collapse All
C#
public const int MayBeOutOfOrder = 8;
Remarks

0000 1000

See Also
MemberCachePolicy.MemberFlags Class
Eco.Framework.Impl Namespace


MemberCachePolicy.MemberFlags.PersistenceStateMask Field

MemberCachePolicy.MemberFlags.PersistenceStateMask Field
MemberCachePolicy.MemberFlags Class Eco.Framework.Impl Namespace See Also
Collapse All
C#
public const int PersistenceStateMask = 3;
Remarks

0000 0011

See Also
MemberCachePolicy.MemberFlags Class
Eco.Framework.Impl Namespace


MemberCachePolicy.MemberFlags.Touched Field

MemberCachePolicy.MemberFlags.Touched Field
MemberCachePolicy.MemberFlags Class Eco.Framework.Impl Namespace See Also
Collapse All
C#
public const int Touched = 4;
Remarks

0000 0100

See Also
MemberCachePolicy.MemberFlags Class
Eco.Framework.Impl Namespace


MemberCachePolicy Methods

MemberCachePolicy Methods
Protected Methods Public Methods
Collapse All

The methods of the MemberCachePolicy class are listed here.

Protected Methods
Name | Description
Changed | This is Changed, a member of class MemberCachePolicy.
GetEnsuredOldValues | This is GetEnsuredOldValues, a member of class MemberCachePolicy.
GetMemberFlags | This is GetMemberFlags, a member of class MemberCachePolicy.
MemberExistsInDatablock | This is MemberExistsInDatablock, a member of class MemberCachePolicy.
RemoveOldMemberContent | This is RemoveOldMemberContent, a member of class MemberCachePolicy.
SetFlag | This is SetFlag, a member of class MemberCachePolicy.
SetMemberFlags | This is SetMemberFlags, a member of class MemberCachePolicy.
ValueChanged | This is ValueChanged, a member of class MemberCachePolicy.
Top
Public Methods
Name | Description
ClearOldValue | This is ClearOldValue, a member of class MemberCachePolicy.
CopyOldMemberContent | This is CopyOldMemberContent, a member of class MemberCachePolicy.
DoDeserialize | This is DoDeserialize, a member of class MemberCachePolicy.
DoSerialize | This is DoSerialize, a member of class MemberCachePolicy.
FreeMemberContent | This is FreeMemberContent, a member of class MemberCachePolicy.
GetContents | This is the overview for the GetContents method overload.
GetCurrentValue | This is GetCurrentValue, a member of class MemberCachePolicy.
GetEnsuredOldMemberContent | This is GetEnsuredOldMemberContent, a member of class MemberCachePolicy.
GetFetchedValue | This is GetFetchedValue, a member of class MemberCachePolicy.
GetHasOldValue | This is GetHasOldValue, a member of class MemberCachePolicy.
GetIsPersistent | This is GetIsPersistent, a member of class MemberCachePolicy.
GetMayBeOutOfOrder | This is GetMayBeOutOfOrder, a member of class MemberCachePolicy.
GetMemberSlots | This is GetMemberSlots, a member of class MemberCachePolicy.
GetObjectContents | This is GetObjectContents, a member of class MemberCachePolicy.
GetOldMemberContent | This is GetOldMemberContent, a member of class MemberCachePolicy.
GetPersistenceState | overridden for association ends pointing at link objects, where main end is used.
GetTouched | This is GetTouched, a member of class MemberCachePolicy.
Initialize | This is Initialize, a member of class MemberCachePolicy.
InitState | This is InitState, a member of class MemberCachePolicy.
InternalSetPersistenceState | This is InternalSetPersistenceState, a member of class MemberCachePolicy.
Pass2 | This is Pass2, a member of class MemberCachePolicy.
PreChange | This is PreChange, a member of class MemberCachePolicy.
SaveOldValue | This is SaveOldValue, a member of class MemberCachePolicy.
SetContents | This is the overview for the SetContents method overload.
SetCurrentAndFetchedValue | This is SetCurrentAndFetchedValue, a member of class MemberCachePolicy.
SetCurrentValue | This is SetCurrentValue, a member of class MemberCachePolicy.
SetFetchedValue | This is SetFetchedValue, a member of class MemberCachePolicy.
SetHasOldValue | This is SetHasOldValue, a member of class MemberCachePolicy.
SetMayBeOutOfOrder | This is SetMayBeOutOfOrder, a member of class MemberCachePolicy.
SetOldMemberContent | This is SetOldMemberContent, a member of class MemberCachePolicy.
SetPersistenceState | overridden for association ends pointing at link objects, where main end is used.
SetTouched | This is SetTouched, a member of class MemberCachePolicy.
UpdatePersistenceStateFlags | This is UpdatePersistenceStateFlags, a member of class MemberCachePolicy.


MemberCachePolicy.Changed Method

MemberCachePolicy.Changed Method
MemberCachePolicy Class Eco.Framework.Impl Namespace See Also
Collapse All
C#
protected virtual void Changed(
    CacheLocator locator
);
Remarks

This is Changed, a member of class MemberCachePolicy.

See Also
MemberCachePolicy Class
Eco.Framework.Impl Namespace


MemberCachePolicy.ClearOldValue Method

MemberCachePolicy.ClearOldValue Method
MemberCachePolicy Class Eco.Framework.Impl Namespace See Also
Collapse All
C#
public abstract void ClearOldValue(
    object[] objectContents
);
Remarks

This is ClearOldValue, a member of class MemberCachePolicy.

See Also
MemberCachePolicy Class
Eco.Framework.Impl Namespace


MemberCachePolicy.CopyOldMemberContent Method

MemberCachePolicy.CopyOldMemberContent Method
MemberCachePolicy Class Eco.Framework.Impl Namespace See Also
Collapse All
C#
public void CopyOldMemberContent(
    object[] objectContents
);
Remarks

This is CopyOldMemberContent, a member of class MemberCachePolicy.

See Also
MemberCachePolicy Class
Eco.Framework.Impl Namespace


MemberCachePolicy.DoDeserialize Method

MemberCachePolicy.DoDeserialize Method
MemberCachePolicy Class Eco.Framework.Impl Namespace See Also
Collapse All
C#
public virtual void DoDeserialize(
    CacheLocator locator,
    Stream source
);
Remarks

This is DoDeserialize, a member of class MemberCachePolicy.

See Also
MemberCachePolicy Class
Eco.Framework.Impl Namespace


MemberCachePolicy.DoSerialize Method

MemberCachePolicy.DoSerialize Method
MemberCachePolicy Class Eco.Framework.Impl Namespace See Also
Collapse All
C#
public virtual void DoSerialize(
    CacheLocator locator,
    Stream target,
    EcoSpaceSerializationConfig config
);
Remarks

This is DoSerialize, a member of class MemberCachePolicy.

See Also
MemberCachePolicy Class
Eco.Framework.Impl Namespace


MemberCachePolicy.FreeMemberContent Method

MemberCachePolicy.FreeMemberContent Method
MemberCachePolicy Class Eco.Framework.Impl Namespace See Also
Collapse All
C#
public virtual void FreeMemberContent(
    object[] objectContents
);
Remarks

This is FreeMemberContent, a member of class MemberCachePolicy.

See Also
MemberCachePolicy Class
Eco.Framework.Impl Namespace


GetContents Method

GetContents Method

This is the overview for the GetContents method overload.

Overload List
Name | Description
MemberCachePolicy.GetContents (CacheLocator) | This is GetContents, a member of class MemberCachePolicy.
MemberCachePolicy.GetContents (object[]) | This is GetContents, a member of class MemberCachePolicy.


MemberCachePolicy.GetContents Method (CacheLocator)

MemberCachePolicy.GetContents Method (CacheLocator)
MemberCachePolicy Class Eco.Framework.Impl Namespace See Also
Collapse All
C#
public object GetContents(
    CacheLocator locator
);
Remarks

This is GetContents, a member of class MemberCachePolicy.

See Also
MemberCachePolicy Class
Eco.Framework.Impl Namespace


MemberCachePolicy.GetContents Method (object[])

MemberCachePolicy.GetContents Method (object[])
MemberCachePolicy Class Eco.Framework.Impl Namespace See Also
Collapse All
C#
public object GetContents(
    object[] objectContents
);
Remarks

This is GetContents, a member of class MemberCachePolicy.

See Also
MemberCachePolicy Class
Eco.Framework.Impl Namespace


MemberCachePolicy.GetCurrentValue Method

MemberCachePolicy.GetCurrentValue Method
MemberCachePolicy Class Eco.Framework.Impl Namespace See Also
Collapse All
C#
public abstract object GetCurrentValue(
    CacheLocator locator
);
Remarks

This is GetCurrentValue, a member of class MemberCachePolicy.

See Also
MemberCachePolicy Class
Eco.Framework.Impl Namespace


MemberCachePolicy.GetEnsuredOldMemberContent Method

MemberCachePolicy.GetEnsuredOldMemberContent Method
MemberCachePolicy Class Eco.Framework.Impl Namespace See Also
Collapse All
C#
public object GetEnsuredOldMemberContent(
    object[] objectContents
);
Remarks

This is GetEnsuredOldMemberContent, a member of class MemberCachePolicy.

See Also
MemberCachePolicy Class
Eco.Framework.Impl Namespace


MemberCachePolicy.GetEnsuredOldValues Method

MemberCachePolicy.GetEnsuredOldValues Method
MemberCachePolicy Class Eco.Framework.Impl Namespace See Also
Collapse All
C#
protected object[] GetEnsuredOldValues(
    object[] objectContents
);
Remarks

This is GetEnsuredOldValues, a member of class MemberCachePolicy.

See Also
MemberCachePolicy Class
Eco.Framework.Impl Namespace


MemberCachePolicy.GetFetchedValue Method

MemberCachePolicy.GetFetchedValue Method
MemberCachePolicy Class Eco.Framework.Impl Namespace See Also
Collapse All
C#
public abstract object GetFetchedValue(
    CacheLocator locator
);
Remarks

This is GetFetchedValue, a member of class MemberCachePolicy.

See Also
MemberCachePolicy Class
Eco.Framework.Impl Namespace


MemberCachePolicy.GetHasOldValue Method

MemberCachePolicy.GetHasOldValue Method
MemberCachePolicy Class Eco.Framework.Impl Namespace See Also
Collapse All
C#
public bool GetHasOldValue(
    object[] objectContents
);
Remarks

This is GetHasOldValue, a member of class MemberCachePolicy.

See Also
MemberCachePolicy Class
Eco.Framework.Impl Namespace


MemberCachePolicy.GetIsPersistent Method

MemberCachePolicy.GetIsPersistent Method
MemberCachePolicy Class Eco.Framework.Impl Namespace See Also
Collapse All
C#
public bool GetIsPersistent(
    object[] objectContents
);
Remarks

This is GetIsPersistent, a member of class MemberCachePolicy.

See Also
MemberCachePolicy Class
Eco.Framework.Impl Namespace


MemberCachePolicy.GetMayBeOutOfOrder Method

MemberCachePolicy.GetMayBeOutOfOrder Method
MemberCachePolicy Class Eco.Framework.Impl Namespace See Also
Collapse All
C#
public bool GetMayBeOutOfOrder(
    object[] objectContents
);
Remarks

This is GetMayBeOutOfOrder, a member of class MemberCachePolicy.

See Also
MemberCachePolicy Class
Eco.Framework.Impl Namespace


MemberCachePolicy.GetMemberFlags Method

MemberCachePolicy.GetMemberFlags Method
MemberCachePolicy Class Eco.Framework.Impl Namespace See Also
Collapse All
C#
protected byte GetMemberFlags(
    object[] objectContents
);
Remarks

This is GetMemberFlags, a member of class MemberCachePolicy.

See Also
MemberCachePolicy Class
Eco.Framework.Impl Namespace


MemberCachePolicy.GetMemberSlots Method

MemberCachePolicy.GetMemberSlots Method
MemberCachePolicy Class Eco.Framework.Impl Namespace See Also
Collapse All
C#
public virtual int GetMemberSlots();
Remarks

This is GetMemberSlots, a member of class MemberCachePolicy.

See Also
MemberCachePolicy Class
Eco.Framework.Impl Namespace


MemberCachePolicy.GetObjectContents Method

MemberCachePolicy.GetObjectContents Method
MemberCachePolicy Class Eco.Framework.Impl Namespace See Also
Collapse All
C#
public object[] GetObjectContents(
    CacheLocator locator
);
Remarks

This is GetObjectContents, a member of class MemberCachePolicy.

See Also
MemberCachePolicy Class
Eco.Framework.Impl Namespace


MemberCachePolicy.GetOldMemberContent Method

MemberCachePolicy.GetOldMemberContent Method
MemberCachePolicy Class Eco.Framework.Impl Namespace See Also
Collapse All
C#
public object GetOldMemberContent(
    object[] objectContents
);
Remarks

This is GetOldMemberContent, a member of class MemberCachePolicy.

See Also
MemberCachePolicy Class
Eco.Framework.Impl Namespace


MemberCachePolicy.GetPersistenceState Method

MemberCachePolicy.GetPersistenceState Method
MemberCachePolicy Class Eco.Framework.Impl Namespace See Also
Collapse All
C#
public virtual PersistenceState GetPersistenceState(
    object[] objectContents
);
Remarks

overridden for association ends pointing at link objects, where main end is used.

See Also
MemberCachePolicy Class
Eco.Framework.Impl Namespace


MemberCachePolicy.GetTouched Method

MemberCachePolicy.GetTouched Method
MemberCachePolicy Class Eco.Framework.Impl Namespace See Also
Collapse All
C#
public bool GetTouched(
    object[] objectContents
);
Remarks

This is GetTouched, a member of class MemberCachePolicy.

See Also
MemberCachePolicy Class
Eco.Framework.Impl Namespace


MemberCachePolicy.Initialize Method

MemberCachePolicy.Initialize Method
MemberCachePolicy Class Eco.Framework.Impl Namespace See Also
Collapse All
C#
public abstract void Initialize(
    object[] objectContents
);
Remarks

This is Initialize, a member of class MemberCachePolicy.

See Also
MemberCachePolicy Class
Eco.Framework.Impl Namespace


MemberCachePolicy.InitState Method

MemberCachePolicy.InitState Method
MemberCachePolicy Class Eco.Framework.Impl Namespace See Also
Collapse All
C#
public void InitState(
    object[] objectContents,
    bool persistentObject,
    bool isNew
);
Remarks

This is InitState, a member of class MemberCachePolicy.

See Also
MemberCachePolicy Class
Eco.Framework.Impl Namespace


MemberCachePolicy.InternalSetPersistenceState Method

MemberCachePolicy.InternalSetPersistenceState Method
MemberCachePolicy Class Eco.Framework.Impl Namespace See Also
Collapse All
C#
public void InternalSetPersistenceState(
    object[] objectContents,
    PersistenceState value
);
Remarks

This is InternalSetPersistenceState, a member of class MemberCachePolicy.

See Also
MemberCachePolicy Class
Eco.Framework.Impl Namespace


MemberCachePolicy.MemberExistsInDatablock Method

MemberCachePolicy.MemberExistsInDatablock Method
MemberCachePolicy Class Eco.Framework.Impl Namespace See Also
Collapse All
C#
protected bool MemberExistsInDatablock(
    CacheLocator locator,
    Datablock block
);
Remarks

This is MemberExistsInDatablock, a member of class MemberCachePolicy.

See Also
MemberCachePolicy Class
Eco.Framework.Impl Namespace


MemberCachePolicy.Pass2 Method

MemberCachePolicy.Pass2 Method
MemberCachePolicy Class Eco.Framework.Impl Namespace See Also
Collapse All
C#
public virtual void Pass2();
Remarks

This is Pass2, a member of class MemberCachePolicy.

See Also
MemberCachePolicy Class
Eco.Framework.Impl Namespace


MemberCachePolicy.PreChange Method

MemberCachePolicy.PreChange Method
MemberCachePolicy Class Eco.Framework.Impl Namespace See Also
Collapse All
C#
public void PreChange(
    CacheLocator locator
);
Remarks

This is PreChange, a member of class MemberCachePolicy.

See Also
MemberCachePolicy Class
Eco.Framework.Impl Namespace


MemberCachePolicy.RemoveOldMemberContent Method

MemberCachePolicy.RemoveOldMemberContent Method
MemberCachePolicy Class Eco.Framework.Impl Namespace See Also
Collapse All
C#
protected void RemoveOldMemberContent(
    object[] objectContents
);
Remarks

This is RemoveOldMemberContent, a member of class MemberCachePolicy.

See Also
MemberCachePolicy Class
Eco.Framework.Impl Namespace


MemberCachePolicy.SaveOldValue Method

MemberCachePolicy.SaveOldValue Method
MemberCachePolicy Class Eco.Framework.Impl Namespace See Also
Collapse All
C#
public abstract void SaveOldValue(
    object[] objectContents
);
Remarks

This is SaveOldValue, a member of class MemberCachePolicy.

See Also
MemberCachePolicy Class
Eco.Framework.Impl Namespace


SetContents Method

SetContents Method

This is the overview for the SetContents method overload.

Overload List
Name | Description
MemberCachePolicy.SetContents (CacheLocator, object) | This is SetContents, a member of class MemberCachePolicy.
MemberCachePolicy.SetContents (object[], object) | This is SetContents, a member of class MemberCachePolicy.


MemberCachePolicy.SetContents Method (CacheLocator, object)

MemberCachePolicy.SetContents Method (CacheLocator, object)
MemberCachePolicy Class Eco.Framework.Impl Namespace See Also
Collapse All
C#
public void SetContents(
    CacheLocator locator,
    object value
);
Remarks

This is SetContents, a member of class MemberCachePolicy.

See Also
MemberCachePolicy Class
Eco.Framework.Impl Namespace


MemberCachePolicy.SetContents Method (object[], object)

MemberCachePolicy.SetContents Method (object[], object)
MemberCachePolicy Class Eco.Framework.Impl Namespace See Also
Collapse All
C#
public void SetContents(
    object[] objectContents,
    object value
);
Remarks

This is SetContents, a member of class MemberCachePolicy.

See Also
MemberCachePolicy Class
Eco.Framework.Impl Namespace


MemberCachePolicy.SetCurrentAndFetchedValue Method

MemberCachePolicy.SetCurrentAndFetchedValue Method
MemberCachePolicy Class Eco.Framework.Impl Namespace See Also
Collapse All
C#
public abstract void SetCurrentAndFetchedValue(
    object value,
    CacheLocator locator
);
Remarks

This is SetCurrentAndFetchedValue, a member of class MemberCachePolicy.

See Also
MemberCachePolicy Class
Eco.Framework.Impl Namespace


MemberCachePolicy.SetCurrentValue Method

MemberCachePolicy.SetCurrentValue Method
MemberCachePolicy Class Eco.Framework.Impl Namespace See Also
Collapse All
C#
public abstract void SetCurrentValue(
    CacheLocator locator,
    object value
);
Remarks

This is SetCurrentValue, a member of class MemberCachePolicy.

See Also
MemberCachePolicy Class
Eco.Framework.Impl Namespace


MemberCachePolicy.SetFetchedValue Method

MemberCachePolicy.SetFetchedValue Method
MemberCachePolicy Class Eco.Framework.Impl Namespace See Also
Collapse All
C#
public abstract void SetFetchedValue(
    CacheLocator locator,
    object value
);
Remarks

This is SetFetchedValue, a member of class MemberCachePolicy.

See Also
MemberCachePolicy Class
Eco.Framework.Impl Namespace


MemberCachePolicy.SetFlag Method

MemberCachePolicy.SetFlag Method
MemberCachePolicy Class Eco.Framework.Impl Namespace See Also
Collapse All
C#
protected void SetFlag(
    object[] objectContents,
    int flag,
    bool value
);
Remarks

This is SetFlag, a member of class MemberCachePolicy.

See Also
MemberCachePolicy Class
Eco.Framework.Impl Namespace


MemberCachePolicy.SetHasOldValue Method

MemberCachePolicy.SetHasOldValue Method
MemberCachePolicy Class Eco.Framework.Impl Namespace See Also
Collapse All
C#
public void SetHasOldValue(
    object[] objectContents,
    bool value
);
Remarks

This is SetHasOldValue, a member of class MemberCachePolicy.

See Also
MemberCachePolicy Class
Eco.Framework.Impl Namespace


MemberCachePolicy.SetMayBeOutOfOrder Method

MemberCachePolicy.SetMayBeOutOfOrder Method
MemberCachePolicy Class Eco.Framework.Impl Namespace See Also
Collapse All
C#
public void SetMayBeOutOfOrder(
    object[] objectContents,
    bool value
);
Remarks

This is SetMayBeOutOfOrder, a member of class MemberCachePolicy.

See Also
MemberCachePolicy Class
Eco.Framework.Impl Namespace


MemberCachePolicy.SetMemberFlags Method

MemberCachePolicy.SetMemberFlags Method
MemberCachePolicy Class Eco.Framework.Impl Namespace See Also
Collapse All
C#
protected void SetMemberFlags(
    object[] objectContents,
    byte value
);
Remarks

This is SetMemberFlags, a member of class MemberCachePolicy.

See Also
MemberCachePolicy Class
Eco.Framework.Impl Namespace


MemberCachePolicy.SetOldMemberContent Method

MemberCachePolicy.SetOldMemberContent Method
MemberCachePolicy Class Eco.Framework.Impl Namespace See Also
Collapse All
C#
public void SetOldMemberContent(
    object[] objectContents,
    object oldValue
);
Remarks

This is SetOldMemberContent, a member of class MemberCachePolicy.

See Also
MemberCachePolicy Class
Eco.Framework.Impl Namespace


MemberCachePolicy.SetPersistenceState Method

MemberCachePolicy.SetPersistenceState Method
MemberCachePolicy Class Eco.Framework.Impl Namespace See Also
Collapse All
C#
public virtual void SetPersistenceState(
    object[] objectContents,
    CacheLocator locator,
    PersistenceState value
);
Remarks

overridden for association ends pointing at link objects, where main end is used.

See Also
MemberCachePolicy Class
Eco.Framework.Impl Namespace


MemberCachePolicy.SetTouched Method

MemberCachePolicy.SetTouched Method
MemberCachePolicy Class Eco.Framework.Impl Namespace See Also
Collapse All
C#
public void SetTouched(
    object[] objectContents,
    bool value
);
Remarks

This is SetTouched, a member of class MemberCachePolicy.

See Also
MemberCachePolicy Class
Eco.Framework.Impl Namespace


MemberCachePolicy.UpdatePersistenceStateFlags Method

MemberCachePolicy.UpdatePersistenceStateFlags Method
MemberCachePolicy Class Eco.Framework.Impl Namespace See Also
Collapse All
C#
public byte UpdatePersistenceStateFlags(
    byte flags,
    PersistenceState value
);
Remarks

This is UpdatePersistenceStateFlags, a member of class MemberCachePolicy.

See Also
MemberCachePolicy Class
Eco.Framework.Impl Namespace


MemberCachePolicy.ValueChanged Method

MemberCachePolicy.ValueChanged Method
MemberCachePolicy Class Eco.Framework.Impl Namespace See Also
Collapse All
C#
protected void ValueChanged(
    CacheLocator locator
);
Remarks

This is ValueChanged, a member of class MemberCachePolicy.

See Also
MemberCachePolicy Class
Eco.Framework.Impl Namespace


MemberCachePolicy Properties

MemberCachePolicy Properties
Public Properties Protected Properties
Collapse All

The properties of the MemberCachePolicy class are listed here.

Public Properties
Name | Description
IsDefaultFetch | This is IsDefaultFetch, a member of class MemberCachePolicy.
MemberContentIndex | This is MemberContentIndex, a member of class MemberCachePolicy.
MemberFlagIndex | This is MemberFlagIndex, a member of class MemberCachePolicy.
Owner | This is Owner, a member of class MemberCachePolicy.
OwningCache | This is OwningCache, a member of class MemberCachePolicy.
StructuralFeature | This is StructuralFeature, a member of class MemberCachePolicy.
Top
Protected Properties
Name | Description
ClassCachePolicy | This is ClassCachePolicy, a member of class MemberCachePolicy.


MemberCachePolicy.ClassCachePolicy Property

MemberCachePolicy.ClassCachePolicy Property
MemberCachePolicy Class Eco.Framework.Impl Namespace See Also
Collapse All
C#
protected ClassCachePolicy ClassCachePolicy;
Remarks

This is ClassCachePolicy, a member of class MemberCachePolicy.

See Also
MemberCachePolicy Class
Eco.Framework.Impl Namespace


MemberCachePolicy.IsDefaultFetch Property

MemberCachePolicy.IsDefaultFetch Property
MemberCachePolicy Class Eco.Framework.Impl Namespace See Also
Collapse All
C#
public bool IsDefaultFetch;
Remarks

This is IsDefaultFetch, a member of class MemberCachePolicy.

See Also
MemberCachePolicy Class
Eco.Framework.Impl Namespace


MemberCachePolicy.MemberContentIndex Property

MemberCachePolicy.MemberContentIndex Property
MemberCachePolicy Class Eco.Framework.Impl Namespace See Also
Collapse All
C#
public int MemberContentIndex;
Remarks

This is MemberContentIndex, a member of class MemberCachePolicy.

See Also
MemberCachePolicy Class
Eco.Framework.Impl Namespace


MemberCachePolicy.MemberFlagIndex Property

MemberCachePolicy.MemberFlagIndex Property
MemberCachePolicy Class Eco.Framework.Impl Namespace See Also
Collapse All
C#
public int MemberFlagIndex;
Remarks

This is MemberFlagIndex, a member of class MemberCachePolicy.

See Also
MemberCachePolicy Class
Eco.Framework.Impl Namespace


MemberCachePolicy.Owner Property

MemberCachePolicy.Owner Property
MemberCachePolicy Class Eco.Framework.Impl Namespace See Also
Collapse All
C#
public ClassCachePolicy Owner;
Remarks

This is Owner, a member of class MemberCachePolicy.

See Also
MemberCachePolicy Class
Eco.Framework.Impl Namespace


MemberCachePolicy.OwningCache Property

MemberCachePolicy.OwningCache Property
MemberCachePolicy Class Eco.Framework.Impl Namespace See Also
Collapse All
C#
public CacheImpl OwningCache;
Remarks

This is OwningCache, a member of class MemberCachePolicy.

See Also
MemberCachePolicy Class
Eco.Framework.Impl Namespace


MemberCachePolicy.StructuralFeature Property

MemberCachePolicy.StructuralFeature Property
MemberCachePolicy Class Eco.Framework.Impl Namespace See Also
Collapse All
C#
public abstract IStructuralFeature StructuralFeature;
Remarks

This is StructuralFeature, a member of class MemberCachePolicy.

See Also
MemberCachePolicy Class
Eco.Framework.Impl Namespace


MultiAssociationEndCachePolicy Class

MultiAssociationEndCachePolicy Class
Inheritance Hierarchy See Also
Collapse All
C#
public abstract class MultiAssociationEndCachePolicy : AssociationEndCachePolicy;
Remarks

This is class Eco.Framework.Impl.MultiAssociationEndCachePolicy.

Inheritance Hierarchy
Eco.Framework.Impl.MemberCachePolicy
    Eco.Framework.Impl.AssociationEndCachePolicy
        Eco.Framework.Impl.MultiAssociationEndCachePolicy
            Eco.Framework.Impl.LinkObjectMultiAssociationEndCachePolicy
            Eco.Framework.Impl.MainMultiAssociationEndCachePolicy
File

MultiAssociationEndPolicies.cs

See Also
Inheritance Hierarchy


MultiAssociationEndCachePolicy.MultiAssociationEndCachePolicy Constructor

MultiAssociationEndCachePolicy.MultiAssociationEndCachePolicy Constructor
MultiAssociationEndCachePolicy Class Eco.Framework.Impl Namespace See Also
Collapse All
C#
public MultiAssociationEndCachePolicy(
    ClassCachePolicy owner,
    IAssociationEnd associationEnd,
    int memberContentIndex,
    int flagIndex
);
Remarks

This is MultiAssociationEndCachePolicy, a member of class MultiAssociationEndCachePolicy.

See Also
MultiAssociationEndCachePolicy Class
Eco.Framework.Impl Namespace


MultiAssociationEndCachePolicy Methods

MultiAssociationEndCachePolicy Methods
Protected Methods Public Methods
Collapse All

The methods of the MultiAssociationEndCachePolicy class are listed here.

Protected Methods
Name | Description
CopyOldLocatorList | This is CopyOldLocatorList, a member of class MultiAssociationEndCachePolicy.
Top
Public Methods
Name | Description
DoDeserialize | This is DoDeserialize, a member of class MultiAssociationEndCachePolicy.
DoSerialize | This is DoSerialize, a member of class MultiAssociationEndCachePolicy.
EnsureOrder | This is EnsureOrder, a member of class MultiAssociationEndCachePolicy.
FreeContent | This is FreeContent, a member of class MultiAssociationEndCachePolicy.
GetContentAsLocatorList | This is GetContentAsLocatorList, a member of class MultiAssociationEndCachePolicy.
GetCount | This is GetCount, a member of class MultiAssociationEndCachePolicy.
GetCurrentValue | This is GetCurrentValue, a member of class MultiAssociationEndCachePolicy.
GetEnsuredContentAsLocatorList | This is GetEnsuredContentAsLocatorList, a member of class MultiAssociationEndCachePolicy.
GetFetchedValue | This is GetFetchedValue, a member of class MultiAssociationEndCachePolicy.
GetLocator | This is GetLocator, a member of class MultiAssociationEndCachePolicy.
IncludesLocator | This is IncludesLocator, a member of class MultiAssociationEndCachePolicy.
IndexOfLocator | This is IndexOfLocator, a member of class MultiAssociationEndCachePolicy.
InternalAddLocator | This is InternalAddLocator, a member of class MultiAssociationEndCachePolicy.
ResortContents | This is ResortContents, a member of class MultiAssociationEndCachePolicy.
SetCurrentValue | This is SetCurrentValue, a member of class MultiAssociationEndCachePolicy.
SetFetchedValue | This is SetFetchedValue, a member of class MultiAssociationEndCachePolicy.


MultiAssociationEndCachePolicy.CopyOldLocatorList Method

MultiAssociationEndCachePolicy.CopyOldLocatorList Method
MultiAssociationEndCachePolicy Class Eco.Framework.Impl Namespace See Also
Collapse All
C#
protected void CopyOldLocatorList(
    object[] objectContents
);
Remarks

This is CopyOldLocatorList, a member of class MultiAssociationEndCachePolicy.

See Also
MultiAssociationEndCachePolicy Class
Eco.Framework.Impl Namespace


MultiAssociationEndCachePolicy.DoDeserialize Method

MultiAssociationEndCachePolicy.DoDeserialize Method
MultiAssociationEndCachePolicy Class Eco.Framework.Impl Namespace See Also
Collapse All
C#
public override void DoDeserialize(
    CacheLocator locator,
    Stream source
);
Remarks

This is DoDeserialize, a member of class MultiAssociationEndCachePolicy.

See Also
MultiAssociationEndCachePolicy Class
Eco.Framework.Impl Namespace


MultiAssociationEndCachePolicy.DoSerialize Method

MultiAssociationEndCachePolicy.DoSerialize Method
MultiAssociationEndCachePolicy Class Eco.Framework.Impl Namespace See Also
Collapse All
C#
public override void DoSerialize(
    CacheLocator locator,
    Stream target,
    EcoSpaceSerializationConfig config
);
Remarks

This is DoSerialize, a member of class MultiAssociationEndCachePolicy.

See Also
MultiAssociationEndCachePolicy Class
Eco.Framework.Impl Namespace


MultiAssociationEndCachePolicy.EnsureOrder Method

MultiAssociationEndCachePolicy.EnsureOrder Method
MultiAssociationEndCachePolicy Class Eco.Framework.Impl Namespace See Also
Collapse All
C#
public abstract void EnsureOrder(
    CacheLocator owningObject
);
Remarks

This is EnsureOrder, a member of class MultiAssociationEndCachePolicy.

See Also
MultiAssociationEndCachePolicy Class
Eco.Framework.Impl Namespace


MultiAssociationEndCachePolicy.FreeContent Method

MultiAssociationEndCachePolicy.FreeContent Method
MultiAssociationEndCachePolicy Class Eco.Framework.Impl Namespace See Also
Collapse All
C#
public virtual void FreeContent();
Remarks

This is FreeContent, a member of class MultiAssociationEndCachePolicy.

See Also
MultiAssociationEndCachePolicy Class
Eco.Framework.Impl Namespace


MultiAssociationEndCachePolicy.GetContentAsLocatorList Method

MultiAssociationEndCachePolicy.GetContentAsLocatorList Method
MultiAssociationEndCachePolicy Class Eco.Framework.Impl Namespace See Also
Collapse All
C#
public List<CacheLocator> GetContentAsLocatorList(
    CacheLocator owningObject
);
Remarks

This is GetContentAsLocatorList, a member of class MultiAssociationEndCachePolicy.

See Also
MultiAssociationEndCachePolicy Class
Eco.Framework.Impl Namespace


MultiAssociationEndCachePolicy.GetCount Method

MultiAssociationEndCachePolicy.GetCount Method
MultiAssociationEndCachePolicy Class Eco.Framework.Impl Namespace See Also
Collapse All
C#
public abstract int GetCount(
    CacheLocator owningObject
);
Remarks

This is GetCount, a member of class MultiAssociationEndCachePolicy.

See Also
MultiAssociationEndCachePolicy Class
Eco.Framework.Impl Namespace


MultiAssociationEndCachePolicy.GetCurrentValue Method

MultiAssociationEndCachePolicy.GetCurrentValue Method
MultiAssociationEndCachePolicy Class Eco.Framework.Impl Namespace See Also
Collapse All
C#
public override object GetCurrentValue(
    CacheLocator owningObject
);
Remarks

This is GetCurrentValue, a member of class MultiAssociationEndCachePolicy.

See Also
MultiAssociationEndCachePolicy Class
Eco.Framework.Impl Namespace


MultiAssociationEndCachePolicy.GetEnsuredContentAsLocatorList Method

MultiAssociationEndCachePolicy.GetEnsuredContentAsLocatorList Method
MultiAssociationEndCachePolicy Class Eco.Framework.Impl Namespace See Also
Collapse All
C#
public List<CacheLocator> GetEnsuredContentAsLocatorList(
    CacheLocator owningObject
);
Remarks

This is GetEnsuredContentAsLocatorList, a member of class MultiAssociationEndCachePolicy.

See Also
MultiAssociationEndCachePolicy Class
Eco.Framework.Impl Namespace


MultiAssociationEndCachePolicy.GetFetchedValue Method

MultiAssociationEndCachePolicy.GetFetchedValue Method
MultiAssociationEndCachePolicy Class Eco.Framework.Impl Namespace See Also
Collapse All
C#
public override object GetFetchedValue(
    CacheLocator owningObject
);
Remarks

This is GetFetchedValue, a member of class MultiAssociationEndCachePolicy.

See Also
MultiAssociationEndCachePolicy Class
Eco.Framework.Impl Namespace


MultiAssociationEndCachePolicy.GetLocator Method

MultiAssociationEndCachePolicy.GetLocator Method
MultiAssociationEndCachePolicy Class Eco.Framework.Impl Namespace See Also
Collapse All
C#
public CacheLocator GetLocator(
    int index,
    CacheLocator owningObject
);
Remarks

This is GetLocator, a member of class MultiAssociationEndCachePolicy.

See Also
MultiAssociationEndCachePolicy Class
Eco.Framework.Impl Namespace


MultiAssociationEndCachePolicy.IncludesLocator Method

MultiAssociationEndCachePolicy.IncludesLocator Method
MultiAssociationEndCachePolicy Class Eco.Framework.Impl Namespace See Also
Collapse All
C#
public bool IncludesLocator(
    CacheLocator item,
    CacheLocator owningObject
);
Remarks

This is IncludesLocator, a member of class MultiAssociationEndCachePolicy.

See Also
MultiAssociationEndCachePolicy Class
Eco.Framework.Impl Namespace


MultiAssociationEndCachePolicy.IndexOfLocator Method

MultiAssociationEndCachePolicy.IndexOfLocator Method
MultiAssociationEndCachePolicy Class Eco.Framework.Impl Namespace See Also
Collapse All
C#
public int IndexOfLocator(
    CacheLocator item,
    CacheLocator owningObject
);
Remarks

This is IndexOfLocator, a member of class MultiAssociationEndCachePolicy.

See Also
MultiAssociationEndCachePolicy Class
Eco.Framework.Impl Namespace


MultiAssociationEndCachePolicy.InternalAddLocator Method

MultiAssociationEndCachePolicy.InternalAddLocator Method
MultiAssociationEndCachePolicy Class Eco.Framework.Impl Namespace See Also
Collapse All
C#
public void InternalAddLocator(
    CacheLocator owningObject,
    CacheLocator locator
);
Remarks

This is InternalAddLocator, a member of class MultiAssociationEndCachePolicy.

See Also
MultiAssociationEndCachePolicy Class
Eco.Framework.Impl Namespace


MultiAssociationEndCachePolicy.ResortContents Method

MultiAssociationEndCachePolicy.ResortContents Method
MultiAssociationEndCachePolicy Class Eco.Framework.Impl Namespace See Also
Collapse All
C#
public void ResortContents(
    CacheLocator owningObject,
    int[] keys
);
Remarks

This is ResortContents, a member of class MultiAssociationEndCachePolicy.

See Also
MultiAssociationEndCachePolicy Class
Eco.Framework.Impl Namespace


MultiAssociationEndCachePolicy.SetCurrentValue Method

MultiAssociationEndCachePolicy.SetCurrentValue Method
MultiAssociationEndCachePolicy Class Eco.Framework.Impl Namespace See Also
Collapse All
C#
public override void SetCurrentValue(
    CacheLocator owningObject,
    object value
);
Remarks

This is SetCurrentValue, a member of class MultiAssociationEndCachePolicy.

See Also
MultiAssociationEndCachePolicy Class
Eco.Framework.Impl Namespace


MultiAssociationEndCachePolicy.SetFetchedValue Method

MultiAssociationEndCachePolicy.SetFetchedValue Method
MultiAssociationEndCachePolicy Class Eco.Framework.Impl Namespace See Also
Collapse All
C#
public override void SetFetchedValue(
    CacheLocator owningObject,
    object value
);
Remarks

This is SetFetchedValue, a member of class MultiAssociationEndCachePolicy.

See Also
MultiAssociationEndCachePolicy Class
Eco.Framework.Impl Namespace


SingleAssociationEndCachePolicy Class

SingleAssociationEndCachePolicy Class
Inheritance Hierarchy See Also
Collapse All
C#
public abstract class SingleAssociationEndCachePolicy : AssociationEndCachePolicy;
Remarks

This is class Eco.Framework.Impl.SingleAssociationEndCachePolicy.

Inheritance Hierarchy
Eco.Framework.Impl.MemberCachePolicy
    Eco.Framework.Impl.AssociationEndCachePolicy
        Eco.Framework.Impl.SingleAssociationEndCachePolicy
            Eco.Framework.Impl.DirectSingleAssociationEndCachePolicy
            Eco.Framework.Impl.IndirectSingleAssociationEndCachePolicy
            Eco.Framework.Impl.LinkObjectSingleAssociationEndCachePolicy
File

SingleAssociationEndPolicies.cs

See Also
Inheritance Hierarchy


SingleAssociationEndCachePolicy.SingleAssociationEndCachePolicy Constructor

SingleAssociationEndCachePolicy.SingleAssociationEndCachePolicy Constructor
SingleAssociationEndCachePolicy Class Eco.Framework.Impl Namespace See Also
Collapse All
C#
public SingleAssociationEndCachePolicy(
    ClassCachePolicy owner,
    IAssociationEnd associationEnd,
    int memberContentIndex,
    int flagIndex
);
Remarks

This is SingleAssociationEndCachePolicy, a member of class SingleAssociationEndCachePolicy.

See Also
SingleAssociationEndCachePolicy Class
Eco.Framework.Impl Namespace


SingleAssociationEndCachePolicy Methods

SingleAssociationEndCachePolicy Methods
Public Methods
Collapse All

The methods of the SingleAssociationEndCachePolicy class are listed here.

Public Methods
Name | Description
GetContentsAsLocator | This is GetContentsAsLocator, a member of class SingleAssociationEndCachePolicy.
GetCurrentValue | This is GetCurrentValue, a member of class SingleAssociationEndCachePolicy.
GetFetchedOrderNo | This is GetFetchedOrderNo, a member of class SingleAssociationEndCachePolicy.
GetFetchedValue | This is GetFetchedValue, a member of class SingleAssociationEndCachePolicy.
GetMemberSlots | This is GetMemberSlots, a member of class SingleAssociationEndCachePolicy.
GetOrderNo | This is the overview for the GetOrderNo method overload.
Initialize | This is Initialize, a member of class SingleAssociationEndCachePolicy.
SetCurrentValue | This is SetCurrentValue, a member of class SingleAssociationEndCachePolicy.
SetFetchedValue | This is SetFetchedValue, a member of class SingleAssociationEndCachePolicy.
SetLocator_Current | This is SetLocator_Current, a member of class SingleAssociationEndCachePolicy.
SetOrderNo | This is the overview for the SetOrderNo method overload.
SetOrderNo_cache | This is SetOrderNo_cache, a member of class SingleAssociationEndCachePolicy.


SingleAssociationEndCachePolicy.GetContentsAsLocator Method

SingleAssociationEndCachePolicy.GetContentsAsLocator Method
SingleAssociationEndCachePolicy Class Eco.Framework.Impl Namespace See Also
Collapse All
C#
public CacheLocator GetContentsAsLocator(
    CacheLocator owningObject
);
Remarks

This is GetContentsAsLocator, a member of class SingleAssociationEndCachePolicy.

See Also
SingleAssociationEndCachePolicy Class
Eco.Framework.Impl Namespace


SingleAssociationEndCachePolicy.GetCurrentValue Method

SingleAssociationEndCachePolicy.GetCurrentValue Method
SingleAssociationEndCachePolicy Class Eco.Framework.Impl Namespace See Also
Collapse All
C#
public override object GetCurrentValue(
    CacheLocator owningObject
);
Remarks

This is GetCurrentValue, a member of class SingleAssociationEndCachePolicy.

See Also
SingleAssociationEndCachePolicy Class
Eco.Framework.Impl Namespace


SingleAssociationEndCachePolicy.GetFetchedOrderNo Method

SingleAssociationEndCachePolicy.GetFetchedOrderNo Method
SingleAssociationEndCachePolicy Class Eco.Framework.Impl Namespace See Also
Collapse All
C#
public int GetFetchedOrderNo(
    CacheLocator locator
);
Remarks

This is GetFetchedOrderNo, a member of class SingleAssociationEndCachePolicy.

See Also
SingleAssociationEndCachePolicy Class
Eco.Framework.Impl Namespace


SingleAssociationEndCachePolicy.GetFetchedValue Method

SingleAssociationEndCachePolicy.GetFetchedValue Method
SingleAssociationEndCachePolicy Class Eco.Framework.Impl Namespace See Also
Collapse All
C#
public override object GetFetchedValue(
    CacheLocator owningObject
);
Remarks

This is GetFetchedValue, a member of class SingleAssociationEndCachePolicy.

See Also
SingleAssociationEndCachePolicy Class
Eco.Framework.Impl Namespace


SingleAssociationEndCachePolicy.GetMemberSlots Method

SingleAssociationEndCachePolicy.GetMemberSlots Method
SingleAssociationEndCachePolicy Class Eco.Framework.Impl Namespace See Also
Collapse All
C#
public override int GetMemberSlots();
Remarks

This is GetMemberSlots, a member of class SingleAssociationEndCachePolicy.

See Also
SingleAssociationEndCachePolicy Class
Eco.Framework.Impl Namespace


GetOrderNo Method

GetOrderNo Method

This is the overview for the GetOrderNo method overload.

Overload List
Name | Description
SingleAssociationEndCachePolicy.GetOrderNo (CacheLocator) | This is GetOrderNo, a member of class SingleAssociationEndCachePolicy.
SingleAssociationEndCachePolicy.GetOrderNo (object[]) | This is GetOrderNo, a member of class SingleAssociationEndCachePolicy.


SingleAssociationEndCachePolicy.GetOrderNo Method (CacheLocator)

SingleAssociationEndCachePolicy.GetOrderNo Method (CacheLocator)
SingleAssociationEndCachePolicy Class Eco.Framework.Impl Namespace See Also
Collapse All
C#
public int GetOrderNo(
    CacheLocator locator
);
Remarks

This is GetOrderNo, a member of class SingleAssociationEndCachePolicy.

See Also
SingleAssociationEndCachePolicy Class
Eco.Framework.Impl Namespace


SingleAssociationEndCachePolicy.GetOrderNo Method (object[])

SingleAssociationEndCachePolicy.GetOrderNo Method (object[])
SingleAssociationEndCachePolicy Class Eco.Framework.Impl Namespace See Also
Collapse All
C#
public int GetOrderNo(
    object[] objectContents
);
Remarks

This is GetOrderNo, a member of class SingleAssociationEndCachePolicy.

See Also
SingleAssociationEndCachePolicy Class
Eco.Framework.Impl Namespace


SingleAssociationEndCachePolicy.Initialize Method

SingleAssociationEndCachePolicy.Initialize Method
SingleAssociationEndCachePolicy Class Eco.Framework.Impl Namespace See Also
Collapse All
C#
public override void Initialize(
    object[] objectContents
);
Remarks

This is Initialize, a member of class SingleAssociationEndCachePolicy.

See Also
SingleAssociationEndCachePolicy Class
Eco.Framework.Impl Namespace


SingleAssociationEndCachePolicy.SetCurrentValue Method

SingleAssociationEndCachePolicy.SetCurrentValue Method
SingleAssociationEndCachePolicy Class Eco.Framework.Impl Namespace See Also
Collapse All
C#
public override void SetCurrentValue(
    CacheLocator owningObject,
    object value
);
Remarks

This is SetCurrentValue, a member of class SingleAssociationEndCachePolicy.

See Also
SingleAssociationEndCachePolicy Class
Eco.Framework.Impl Namespace


SingleAssociationEndCachePolicy.SetFetchedValue Method

SingleAssociationEndCachePolicy.SetFetchedValue Method
SingleAssociationEndCachePolicy Class Eco.Framework.Impl Namespace See Also
Collapse All
C#
public override void SetFetchedValue(
    CacheLocator owningObject,
    object value
);
Remarks

This is SetFetchedValue, a member of class SingleAssociationEndCachePolicy.

See Also
SingleAssociationEndCachePolicy Class
Eco.Framework.Impl Namespace


SingleAssociationEndCachePolicy.SetLocator_Current Method

SingleAssociationEndCachePolicy.SetLocator_Current Method
SingleAssociationEndCachePolicy Class Eco.Framework.Impl Namespace See Also
Collapse All
C#
public abstract void SetLocator_Current(
    CacheLocator newLocator,
    CacheLocator owningObject
);
Remarks

This is SetLocator_Current, a member of class SingleAssociationEndCachePolicy.

See Also
SingleAssociationEndCachePolicy Class
Eco.Framework.Impl Namespace


SetOrderNo Method

SetOrderNo Method

This is the overview for the SetOrderNo method overload.

Overload List
Name | Description
SingleAssociationEndCachePolicy.SetOrderNo (CacheLocator, int) | This is SetOrderNo, a member of class SingleAssociationEndCachePolicy.
SingleAssociationEndCachePolicy.SetOrderNo (object[], int) | This is SetOrderNo, a member of class SingleAssociationEndCachePolicy.


SingleAssociationEndCachePolicy.SetOrderNo Method (CacheLocator, int)

SingleAssociationEndCachePolicy.SetOrderNo Method (CacheLocator, int)
SingleAssociationEndCachePolicy Class Eco.Framework.Impl Namespace See Also
Collapse All
C#
public void SetOrderNo(
    CacheLocator locator,
    int value
);
Remarks

This is SetOrderNo, a member of class SingleAssociationEndCachePolicy.

See Also
SingleAssociationEndCachePolicy Class
Eco.Framework.Impl Namespace


SingleAssociationEndCachePolicy.SetOrderNo Method (object[], int)

SingleAssociationEndCachePolicy.SetOrderNo Method (object[], int)
SingleAssociationEndCachePolicy Class Eco.Framework.Impl Namespace See Also
Collapse All
C#
public void SetOrderNo(
    object[] objectContents,
    int value
);
Remarks

This is SetOrderNo, a member of class SingleAssociationEndCachePolicy.

See Also
SingleAssociationEndCachePolicy Class
Eco.Framework.Impl Namespace


SingleAssociationEndCachePolicy.SetOrderNo_cache Method

SingleAssociationEndCachePolicy.SetOrderNo_cache Method
SingleAssociationEndCachePolicy Class Eco.Framework.Impl Namespace See Also
Collapse All
C#
public virtual void SetOrderNo_cache(
    int orderNo,
    CacheLocator owningObject
);
Remarks

This is SetOrderNo_cache, a member of class SingleAssociationEndCachePolicy.

See Also
SingleAssociationEndCachePolicy Class
Eco.Framework.Impl Namespace


SingleAssociationEndCachePolicy Properties

SingleAssociationEndCachePolicy Properties
Protected Properties
Collapse All

The properties of the SingleAssociationEndCachePolicy class are listed here.

Protected Properties
Name | Description
OrderNoIndex | This is OrderNoIndex, a member of class SingleAssociationEndCachePolicy.


SingleAssociationEndCachePolicy.OrderNoIndex Property

SingleAssociationEndCachePolicy.OrderNoIndex Property
SingleAssociationEndCachePolicy Class Eco.Framework.Impl Namespace See Also
Collapse All
C#
protected int OrderNoIndex;
Remarks

This is OrderNoIndex, a member of class SingleAssociationEndCachePolicy.

See Also
SingleAssociationEndCachePolicy Class
Eco.Framework.Impl Namespace


IIndirectController Interface

IIndirectController Interface
Inheritance Hierarchy See Also
Collapse All
C#
public interface IIndirectController;
Remarks

This is class Eco.Framework.Impl.IIndirectController.

Inheritance Hierarchy
Eco.Framework.Impl.IIndirectController
    Eco.Framework.Impl.IndirectMultiAssociationEndCachePolicy
    Eco.Framework.Impl.IndirectSingleAssociationEndCachePolicy
File

AssociationEndCachePolicy.cs

See Also
Inheritance Hierarchy


IIndirectController Methods

IIndirectController Methods
Public Methods
Collapse All

The methods of the IIndirectController class are listed here.

Public Methods
Name | Description
AdjustIndirectAdd | This is AdjustIndirectAdd, a member of class IIndirectController.
AdjustIndirectRemove | This is AdjustIndirectRemove, a member of class IIndirectController.
PreChange | AI: Shouldn't there be versions of these for fetched values too?


IIndirectController.AdjustIndirectAdd Method

IIndirectController.AdjustIndirectAdd Method
IIndirectController Interface Eco.Framework.Impl Namespace See Also
Collapse All
C#
void AdjustIndirectAdd(
    CacheLocator ReferredLocator,
    CacheLocator OwningObject
);
Remarks

This is AdjustIndirectAdd, a member of class IIndirectController.

See Also
IIndirectController Interface
Eco.Framework.Impl Namespace


IIndirectController.AdjustIndirectRemove Method

IIndirectController.AdjustIndirectRemove Method
IIndirectController Interface Eco.Framework.Impl Namespace See Also
Collapse All
C#
void AdjustIndirectRemove(
    CacheLocator ReferredLocator,
    CacheLocator OwningObject
);
Remarks

This is AdjustIndirectRemove, a member of class IIndirectController.

See Also
IIndirectController Interface
Eco.Framework.Impl Namespace


IIndirectController.PreChange Method

IIndirectController.PreChange Method
IIndirectController Interface Eco.Framework.Impl Namespace See Also
Collapse All
C#
void PreChange(
    CacheLocator OwningObject
);
Remarks

AI: Shouldn't there be versions of these for fetched values too?

See Also
IIndirectController Interface
Eco.Framework.Impl Namespace


IOtherEndController Interface

IOtherEndController Interface
Inheritance Hierarchy See Also
Collapse All
C#
public interface IOtherEndController;
Remarks

This is class Eco.Framework.Impl.IOtherEndController.

Inheritance Hierarchy
Eco.Framework.Impl.IOtherEndController
    Eco.Framework.Impl.DirectMultiAssociationEndCachePolicy
    Eco.Framework.Impl.DirectSingleAssociationEndCachePolicy
    Eco.Framework.Impl.IndirectMultiAssociationEndCachePolicy
    Eco.Framework.Impl.IndirectSingleAssociationEndCachePolicy
File

AssociationEndCachePolicy.cs

See Also
Inheritance Hierarchy


IOtherEndController Methods

IOtherEndController Methods
Public Methods
Collapse All

The methods of the IOtherEndController class are listed here.

Public Methods
Name | Description
LinkTo_Current | This is LinkTo_Current, a member of class IOtherEndController.
LinkTo_CurrentAndFetched | This is LinkTo_CurrentAndFetched, a member of class IOtherEndController.
LinkTo_fetched | This is LinkTo_fetched, a member of class IOtherEndController.
Unlink_Current | This is Unlink_Current, a member of class IOtherEndController.
Unlink_CurrentAndFetched | This is Unlink_CurrentAndFetched, a member of class IOtherEndController.
Unlink_fetched | This is Unlink_fetched, a member of class IOtherEndController.


IOtherEndController.LinkTo_Current Method

IOtherEndController.LinkTo_Current Method
IOtherEndController Interface Eco.Framework.Impl Namespace See Also
Collapse All
C#
void LinkTo_Current(
    CacheLocator NewLocator,
    CacheLocator OwningObject
);
Remarks

This is LinkTo_Current, a member of class IOtherEndController.

See Also
IOtherEndController Interface
Eco.Framework.Impl Namespace


IOtherEndController.LinkTo_CurrentAndFetched Method

IOtherEndController.LinkTo_CurrentAndFetched Method
IOtherEndController Interface Eco.Framework.Impl Namespace See Also
Collapse All
C#
void LinkTo_CurrentAndFetched(
    CacheLocator NewLocator,
    CacheLocator OwningObject
);
Remarks

This is LinkTo_CurrentAndFetched, a member of class IOtherEndController.

See Also
IOtherEndController Interface
Eco.Framework.Impl Namespace


IOtherEndController.LinkTo_fetched Method

IOtherEndController.LinkTo_fetched Method
IOtherEndController Interface Eco.Framework.Impl Namespace See Also
Collapse All
C#
void LinkTo_fetched(
    CacheLocator NewLocator,
    CacheLocator OwningObject
);
Remarks

This is LinkTo_fetched, a member of class IOtherEndController.

See Also
IOtherEndController Interface
Eco.Framework.Impl Namespace


IOtherEndController.Unlink_Current Method

IOtherEndController.Unlink_Current Method
IOtherEndController Interface Eco.Framework.Impl Namespace See Also
Collapse All
C#
void Unlink_Current(
    CacheLocator OldLocator,
    CacheLocator OwningObject
);
Remarks

This is Unlink_Current, a member of class IOtherEndController.

See Also
IOtherEndController Interface
Eco.Framework.Impl Namespace


IOtherEndController.Unlink_CurrentAndFetched Method

IOtherEndController.Unlink_CurrentAndFetched Method
IOtherEndController Interface Eco.Framework.Impl Namespace See Also
Collapse All
C#
void Unlink_CurrentAndFetched(
    CacheLocator OldLocator,
    CacheLocator OwningObject
);
Remarks

This is Unlink_CurrentAndFetched, a member of class IOtherEndController.

See Also
IOtherEndController Interface
Eco.Framework.Impl Namespace


IOtherEndController.Unlink_fetched Method

IOtherEndController.Unlink_fetched Method
IOtherEndController Interface Eco.Framework.Impl Namespace See Also
Collapse All
C#
void Unlink_fetched(
    CacheLocator OldLocator,
    CacheLocator OwningObject
);
Remarks

This is Unlink_fetched, a member of class IOtherEndController.

See Also
IOtherEndController Interface
Eco.Framework.Impl Namespace


Eco.Framework.Impl.Frontside Namespace

Eco.Framework.Impl.Frontside Namespace
Classes Interfaces Types
Collapse All

This is namespace Eco.Framework.Impl.Frontside.

Classes
Name | Description
AssociationEndFrontsidePolicy | This is class Eco.Framework.Impl.Frontside.AssociationEndFrontsidePolicy.
AttributeFrontsidePolicy | This is class Eco.Framework.Impl.Frontside.AttributeFrontsidePolicy.
AttributePropertyAdapter | This is class Eco.Framework.Impl.Frontside.AttributePropertyAdapter.
ClassFrontsidePolicy | This is class Eco.Framework.Impl.Frontside.ClassFrontsidePolicy.
DefaultFrontsideLocator | This is class Eco.Framework.Impl.Frontside.DefaultFrontsideLocator.
DefaultFrontsidePolicy | This is class Eco.Framework.Impl.Frontside.DefaultFrontsidePolicy.
DefaultLoopback | This is class Eco.Framework.Impl.Frontside.DefaultLoopback.
DerivedAttributeFrontsidePolicy | This is class Eco.Framework.Impl.Frontside.DerivedAttributeFrontsidePolicy.
DerivedMemberFrontsidePolicy | This is class Eco.Framework.Impl.Frontside.DerivedMemberFrontsidePolicy.
DerivedMultilinkFrontsidePolicy | This is class Eco.Framework.Impl.Frontside.DerivedMultilinkFrontsidePolicy.
DerivedSingleLinkFrontsidePolicy | This is class Eco.Framework.Impl.Frontside.DerivedSingleLinkFrontsidePolicy.
DirectMultiFrontsidePolicy | This is class Eco.Framework.Impl.Frontside.DirectMultiFrontsidePolicy.
DirectSingleMultiFrontsidePolicy | DirectSingleMultiFrontsidePolicy
DirectSingleSingleEmbeddedFrontsidePolicy | This is class Eco.Framework.Impl.Frontside.DirectSingleSingleEmbeddedFrontsidePolicy.
DirectSingleSingleNonembeddedFrontsidePolicy | This is class Eco.Framework.Impl.Frontside.DirectSingleSingleNonembeddedFrontsidePolicy.
FrontSideAdapterFactory | This is class Eco.Framework.Impl.Frontside.FrontSideAdapterFactory.
FrontSideDerivedAdapterFactory | This is class Eco.Framework.Impl.Frontside.FrontSideDerivedAdapterFactory.
FrontsideDerivedMultilinkAdapter | This is class Eco.Framework.Impl.Frontside.FrontsideDerivedMultilinkAdapter.
FrontsideMultilinkAdapter | This is class Eco.Framework.Impl.Frontside.FrontsideMultilinkAdapter.
FrontsideUtils | This is class Eco.Framework.Impl.Frontside.FrontsideUtils.
IndirectMultiFrontsidePolicy | This is class Eco.Framework.Impl.Frontside.IndirectMultiFrontsidePolicy.
IndirectMultiSingleFrontsidePolicy | This is class Eco.Framework.Impl.Frontside.IndirectMultiSingleFrontsidePolicy.
IndirectSingleFrontsidePolicy | This is class Eco.Framework.Impl.Frontside.IndirectSingleFrontsidePolicy.
InnerLinkFrontsidePolicy | This is class Eco.Framework.Impl.Frontside.InnerLinkFrontsidePolicy.
LocatorFactory | This is class Eco.Framework.Impl.Frontside.LocatorFactory.
MemberFrontsidePolicy | This is class Eco.Framework.Impl.Frontside.MemberFrontsidePolicy.
MemberPropertyAdapter | This is class Eco.Framework.Impl.Frontside.MemberPropertyAdapter.
MultAssociationEndFrontsidePolicy | This is class Eco.Framework.Impl.Frontside.MultAssociationEndFrontsidePolicy.
MultiLinkAdapterEnumerator | This is class Eco.Framework.Impl.Frontside.MultiLinkAdapterEnumerator.
MultiMultiFrontsidePolicy | This is class Eco.Framework.Impl.Frontside.MultiMultiFrontsidePolicy.
NonDeletableReason | This is class Eco.Framework.Impl.Frontside.NonDeletableReason.
ObjectListPropertyAdapter | This is class Eco.Framework.Impl.Frontside.ObjectListPropertyAdapter.
ObjectReferencePropertyAdapter | This is class Eco.Framework.Impl.Frontside.ObjectReferencePropertyAdapter.
SingleAssociationEndFrontsidePolicy | This is class Eco.Framework.Impl.Frontside.SingleAssociationEndFrontsidePolicy.
ToInnerMultiFrontsidePolicy | This is class Eco.Framework.Impl.Frontside.ToInnerMultiFrontsidePolicy.
ToInnerSingleFrontsidePolicy | This is class Eco.Framework.Impl.Frontside.ToInnerSingleFrontsidePolicy.
Top
Interfaces
Name | Description
IFrontsideAdapterFactory | This is class Eco.Framework.Impl.Frontside.IFrontsideAdapterFactory.
IFrontsideDerivedAdapterFactory | This is class Eco.Framework.Impl.Frontside.IFrontsideDerivedAdapterFactory.
Top
Types
Name | Description
CreateFrontEndObjectDelegate | This is type Eco.Framework.Impl.Frontside.CreateFrontEndObjectDelegate.
RecreateFrontEndObjectDelegate | This is type Eco.Framework.Impl.Frontside.RecreateFrontEndObjectDelegate.


AssociationEndFrontsidePolicy Class

AssociationEndFrontsidePolicy Class
Inheritance Hierarchy See Also
Collapse All
C#
public abstract class AssociationEndFrontsidePolicy : MemberFrontsidePolicy;
Remarks

This is class Eco.Framework.Impl.Frontside.AssociationEndFrontsidePolicy.

Inheritance Hierarchy
Eco.Framework.Impl.Frontside.MemberFrontsidePolicy
    Eco.Framework.Impl.Frontside.AssociationEndFrontsidePolicy
        Eco.Framework.Impl.Frontside.MultAssociationEndFrontsidePolicy
        Eco.Framework.Impl.Frontside.SingleAssociationEndFrontsidePolicy
File

AssociationEndFrontsidePolicy.cs

See Also
Inheritance Hierarchy


AssociationEndFrontsidePolicy.AssociationEndFrontsidePolicy Constructor

AssociationEndFrontsidePolicy.AssociationEndFrontsidePolicy Constructor
AssociationEndFrontsidePolicy Class Eco.Framework.Impl.Frontside Namespace See Also
Collapse All
C#
public AssociationEndFrontsidePolicy(
    IAssociationEnd assocEnd,
    ClassFrontsidePolicy owner
);
Remarks

This is AssociationEndFrontsidePolicy, a member of class AssociationEndFrontsidePolicy.

See Also
AssociationEndFrontsidePolicy Class
Eco.Framework.Impl.Frontside Namespace


AssociationEndFrontsidePolicy Methods

AssociationEndFrontsidePolicy Methods
Protected Methods
Collapse All

The methods of the AssociationEndFrontsidePolicy class are listed here.

Protected Methods
Name | Description
GetOppositeEndPolicy | This is GetOppositeEndPolicy, a member of class AssociationEndFrontsidePolicy.


AssociationEndFrontsidePolicy.GetOppositeEndPolicy Method

AssociationEndFrontsidePolicy.GetOppositeEndPolicy Method
AssociationEndFrontsidePolicy Class Eco.Framework.Impl.Frontside Namespace See Also
Collapse All
C#
protected MemberFrontsidePolicy GetOppositeEndPolicy();
Remarks

This is GetOppositeEndPolicy, a member of class AssociationEndFrontsidePolicy.

See Also
AssociationEndFrontsidePolicy Class
Eco.Framework.Impl.Frontside Namespace


AssociationEndFrontsidePolicy Properties

AssociationEndFrontsidePolicy Properties
Public Properties Protected Properties
Collapse All

The properties of the AssociationEndFrontsidePolicy class are listed here.

Public Properties
Name | Description
AssociationEnd | This is AssociationEnd, a member of class AssociationEndFrontsidePolicy.
Feature | This is Feature, a member of class AssociationEndFrontsidePolicy.
Top
Protected Properties
Name | Description
EffectiveFetchStrategy | This is EffectiveFetchStrategy, a member of class AssociationEndFrontsidePolicy.
OppositeEnd | This is OppositeEnd, a member of class AssociationEndFrontsidePolicy.


AssociationEndFrontsidePolicy.AssociationEnd Property

AssociationEndFrontsidePolicy.AssociationEnd Property
AssociationEndFrontsidePolicy Class Eco.Framework.Impl.Frontside Namespace See Also
Collapse All
C#
public IAssociationEnd AssociationEnd;
Remarks

This is AssociationEnd, a member of class AssociationEndFrontsidePolicy.

See Also
AssociationEndFrontsidePolicy Class
Eco.Framework.Impl.Frontside Namespace


AssociationEndFrontsidePolicy.EffectiveFetchStrategy Property

AssociationEndFrontsidePolicy.EffectiveFetchStrategy Property
AssociationEndFrontsidePolicy Class Eco.Framework.Impl.Frontside Namespace See Also
Collapse All
C#
protected override FetchStrategy EffectiveFetchStrategy;
Remarks

This is EffectiveFetchStrategy, a member of class AssociationEndFrontsidePolicy.

See Also
AssociationEndFrontsidePolicy Class
Eco.Framework.Impl.Frontside Namespace


AssociationEndFrontsidePolicy.Feature Property

AssociationEndFrontsidePolicy.Feature Property
AssociationEndFrontsidePolicy Class Eco.Framework.Impl.Frontside Namespace See Also
Collapse All
C#
public override IStructuralFeature Feature;
Remarks

This is Feature, a member of class AssociationEndFrontsidePolicy.

See Also
AssociationEndFrontsidePolicy Class
Eco.Framework.Impl.Frontside Namespace


AssociationEndFrontsidePolicy.OppositeEnd Property

AssociationEndFrontsidePolicy.OppositeEnd Property
AssociationEndFrontsidePolicy Class Eco.Framework.Impl.Frontside Namespace See Also
Collapse All
C#
protected IAssociationEnd OppositeEnd;
Remarks

This is OppositeEnd, a member of class AssociationEndFrontsidePolicy.

See Also
AssociationEndFrontsidePolicy Class
Eco.Framework.Impl.Frontside Namespace


AttributeFrontsidePolicy Class

AttributeFrontsidePolicy Class
Inheritance Hierarchy See Also
Collapse All
C#
public sealed class AttributeFrontsidePolicy : MemberFrontsidePolicy;
Remarks

This is class Eco.Framework.Impl.Frontside.AttributeFrontsidePolicy.

Inheritance Hierarchy
Eco.Framework.Impl.Frontside.MemberFrontsidePolicy
    Eco.Framework.Impl.Frontside.AttributeFrontsidePolicy
File

AttributeFrontsidePolicy.cs

See Also
Inheritance Hierarchy


AttributeFrontsidePolicy.AttributeFrontsidePolicy Constructor

AttributeFrontsidePolicy.AttributeFrontsidePolicy Constructor
AttributeFrontsidePolicy Class Eco.Framework.Impl.Frontside Namespace See Also
Collapse All
C#
public AttributeFrontsidePolicy(
    IAttribute feature,
    ClassFrontsidePolicy owner
);
Remarks

This is AttributeFrontsidePolicy, a member of class AttributeFrontsidePolicy.

See Also
AttributeFrontsidePolicy Class
Eco.Framework.Impl.Frontside Namespace


AttributeFrontsidePolicy Methods

AttributeFrontsidePolicy Methods
Public Methods
Collapse All

The methods of the AttributeFrontsidePolicy class are listed here.

Public Methods
Name | Description
ApplyMemberValue | This is ApplyMemberValue, a member of class AttributeFrontsidePolicy.
GetPropertyAdapter | This is GetPropertyAdapter, a member of class AttributeFrontsidePolicy.
RetrieveMemberValue | This is RetrieveMemberValue, a member of class AttributeFrontsidePolicy.


AttributeFrontsidePolicy.ApplyMemberValue Method

AttributeFrontsidePolicy.ApplyMemberValue Method
AttributeFrontsidePolicy Class Eco.Framework.Impl.Frontside Namespace See Also
Collapse All
C#
public override void ApplyMemberValue(
    Locator locator,
    object value,
    bool callerStateMachine
);
Remarks

This is ApplyMemberValue, a member of class AttributeFrontsidePolicy.

See Also
AttributeFrontsidePolicy Class
Eco.Framework.Impl.Frontside Namespace


AttributeFrontsidePolicy.GetPropertyAdapter Method

AttributeFrontsidePolicy.GetPropertyAdapter Method
AttributeFrontsidePolicy Class Eco.Framework.Impl.Frontside Namespace See Also
Collapse All
C#
public override IProperty GetPropertyAdapter(
    DefaultFrontsideLocator locator
);
Remarks

This is GetPropertyAdapter, a member of class AttributeFrontsidePolicy.

See Also
AttributeFrontsidePolicy Class
Eco.Framework.Impl.Frontside Namespace


AttributeFrontsidePolicy.RetrieveMemberValue Method

AttributeFrontsidePolicy.RetrieveMemberValue Method
AttributeFrontsidePolicy Class Eco.Framework.Impl.Frontside Namespace See Also
Collapse All
C#
public override object RetrieveMemberValue(
    DefaultFrontsideLocator locator
);
Remarks

This is RetrieveMemberValue, a member of class AttributeFrontsidePolicy.

See Also
AttributeFrontsidePolicy Class
Eco.Framework.Impl.Frontside Namespace


AttributeFrontsidePolicy Properties

AttributeFrontsidePolicy Properties
Public Properties
Collapse All

The properties of the AttributeFrontsidePolicy class are listed here.

Public Properties
Name | Description
Feature | This is Feature, a member of class AttributeFrontsidePolicy.


AttributeFrontsidePolicy.Feature Property

AttributeFrontsidePolicy.Feature Property
AttributeFrontsidePolicy Class Eco.Framework.Impl.Frontside Namespace See Also
Collapse All
C#
public override IStructuralFeature Feature;
Remarks

This is Feature, a member of class AttributeFrontsidePolicy.

See Also
AttributeFrontsidePolicy Class
Eco.Framework.Impl.Frontside Namespace


AttributePropertyAdapter Class

AttributePropertyAdapter Class
Inheritance Hierarchy See Also
Collapse All
C#
public class AttributePropertyAdapter : MemberPropertyAdapter, IPrimitive;
Remarks

This is class Eco.Framework.Impl.Frontside.AttributePropertyAdapter.

Inheritance Hierarchy
Eco.Framework.Impl.Frontside.MemberPropertyAdapter
    Eco.Framework.Impl.Frontside.AttributePropertyAdapter
File

AttributePropertyAdapter.cs

See Also
Inheritance Hierarchy


AttributePropertyAdapter.AttributePropertyAdapter Constructor

AttributePropertyAdapter.AttributePropertyAdapter Constructor
AttributePropertyAdapter Class Eco.Framework.Impl.Frontside Namespace See Also
Collapse All
C#
public AttributePropertyAdapter(
    Eco.Cache.Locator locator,
    MemberFrontsidePolicy memberPolicy
);
Remarks

This is AttributePropertyAdapter, a member of class AttributePropertyAdapter.

See Also
AttributePropertyAdapter Class
Eco.Framework.Impl.Frontside Namespace


AttributePropertyAdapter Methods

AttributePropertyAdapter Methods
Public Methods
Collapse All

The methods of the AttributePropertyAdapter class are listed here.

Public Methods
Name | Description
AsObjectConvertError | This is AsObjectConvertError, a member of class AttributePropertyAdapter.
Assign | This is Assign, a member of class AttributePropertyAdapter.
CloneValue | This is CloneValue, a member of class AttributePropertyAdapter.
GetAsCollection | This is GetAsCollection, a member of class AttributePropertyAdapter.
GetAsIList | This is GetAsIList, a member of class AttributePropertyAdapter.
GetIsEqualHashCode | This is GetIsEqualHashCode, a member of class AttributePropertyAdapter.
IsEqual | This is IsEqual, a member of class AttributePropertyAdapter.


AttributePropertyAdapter.AsObjectConvertError Method

AttributePropertyAdapter.AsObjectConvertError Method
AttributePropertyAdapter Class Eco.Framework.Impl.Frontside Namespace See Also
Collapse All
C#
public void AsObjectConvertError(
    object value
);
Remarks

This is AsObjectConvertError, a member of class AttributePropertyAdapter.

See Also
AttributePropertyAdapter Class
Eco.Framework.Impl.Frontside Namespace


AttributePropertyAdapter.Assign Method

AttributePropertyAdapter.Assign Method
AttributePropertyAdapter Class Eco.Framework.Impl.Frontside Namespace See Also
Collapse All
C#
public override void Assign(
    IElement element
);
Remarks

This is Assign, a member of class AttributePropertyAdapter.

See Also
AttributePropertyAdapter Class
Eco.Framework.Impl.Frontside Namespace


AttributePropertyAdapter.CloneValue Method

AttributePropertyAdapter.CloneValue Method
AttributePropertyAdapter Class Eco.Framework.Impl.Frontside Namespace See Also
Collapse All
C#
public override IElement CloneValue(
    bool readOnly
);
Remarks

This is CloneValue, a member of class AttributePropertyAdapter.

See Also
AttributePropertyAdapter Class
Eco.Framework.Impl.Frontside Namespace


AttributePropertyAdapter.GetAsCollection Method

AttributePropertyAdapter.GetAsCollection Method
AttributePropertyAdapter Class Eco.Framework.Impl.Frontside Namespace See Also
Collapse All
C#
public override IElementCollection GetAsCollection();
Remarks

This is GetAsCollection, a member of class AttributePropertyAdapter.

See Also
AttributePropertyAdapter Class
Eco.Framework.Impl.Frontside Namespace


AttributePropertyAdapter.GetAsIList Method

AttributePropertyAdapter.GetAsIList Method
AttributePropertyAdapter Class Eco.Framework.Impl.Frontside Namespace See Also
Collapse All
C#
public override IList<T> GetAsIList<T>();
Remarks

This is GetAsIList, a member of class AttributePropertyAdapter.

See Also
AttributePropertyAdapter Class
Eco.Framework.Impl.Frontside Namespace


AttributePropertyAdapter.GetIsEqualHashCode Method

AttributePropertyAdapter.GetIsEqualHashCode Method
AttributePropertyAdapter Class Eco.Framework.Impl.Frontside Namespace See Also
Collapse All
C#
public override int GetIsEqualHashCode();
Remarks

This is GetIsEqualHashCode, a member of class AttributePropertyAdapter.

See Also
AttributePropertyAdapter Class
Eco.Framework.Impl.Frontside Namespace


AttributePropertyAdapter.IsEqual Method

AttributePropertyAdapter.IsEqual Method
AttributePropertyAdapter Class Eco.Framework.Impl.Frontside Namespace See Also
Collapse All
C#
public override bool IsEqual(
    IElement element
);
Remarks

This is IsEqual, a member of class AttributePropertyAdapter.

See Also
AttributePropertyAdapter Class
Eco.Framework.Impl.Frontside Namespace


AttributePropertyAdapter Properties

AttributePropertyAdapter Properties
Public Properties
Collapse All

The properties of the AttributePropertyAdapter class are listed here.

Public Properties
Name | Description
AsObject | This is AsObject, a member of class AttributePropertyAdapter.
ContentType | This is ContentType, a member of class AttributePropertyAdapter.
UmlDataType | This is UmlDataType, a member of class AttributePropertyAdapter.


AttributePropertyAdapter.AsObject Property

AttributePropertyAdapter.AsObject Property
AttributePropertyAdapter Class Eco.Framework.Impl.Frontside Namespace See Also
Collapse All
C#
public override object AsObject;
Remarks

This is AsObject, a member of class AttributePropertyAdapter.

See Also
AttributePropertyAdapter Class
Eco.Framework.Impl.Frontside Namespace


AttributePropertyAdapter.ContentType Property

AttributePropertyAdapter.ContentType Property
AttributePropertyAdapter Class Eco.Framework.Impl.Frontside Namespace See Also
Collapse All
C#
public override ContentType ContentType;
Remarks

This is ContentType, a member of class AttributePropertyAdapter.

See Also
AttributePropertyAdapter Class
Eco.Framework.Impl.Frontside Namespace


AttributePropertyAdapter.UmlDataType Property

AttributePropertyAdapter.UmlDataType Property
AttributePropertyAdapter Class Eco.Framework.Impl.Frontside Namespace See Also
Collapse All
C#
public IDataType UmlDataType;
Remarks

This is UmlDataType, a member of class AttributePropertyAdapter.

See Also
AttributePropertyAdapter Class
Eco.Framework.Impl.Frontside Namespace


ClassFrontsidePolicy Class

ClassFrontsidePolicy Class
Inheritance Hierarchy See Also
Collapse All
C#
public class ClassFrontsidePolicy;
Remarks

This is class Eco.Framework.Impl.Frontside.ClassFrontsidePolicy.

Inheritance Hierarchy
Eco.Framework.Impl.Frontside.ClassFrontsidePolicy
File

ClassFrontsidePolicy.cs

See Also
Inheritance Hierarchy


ClassFrontsidePolicy.ClassFrontsidePolicy Constructor

ClassFrontsidePolicy.ClassFrontsidePolicy Constructor
ClassFrontsidePolicy Class Eco.Framework.Impl.Frontside Namespace See Also
Collapse All
C#
public ClassFrontsidePolicy(
    IClass umlClass,
    DefaultFrontsidePolicy owner
);
Remarks

This is ClassFrontsidePolicy, a member of class ClassFrontsidePolicy.

See Also
ClassFrontsidePolicy Class
Eco.Framework.Impl.Frontside Namespace


ClassFrontsidePolicy Methods

ClassFrontsidePolicy Methods
Public Methods
Collapse All

The methods of the ClassFrontsidePolicy class are listed here.

Public Methods
Name | Description
CreateFrontendObject | This is CreateFrontendObject, a member of class ClassFrontsidePolicy.
CreateNewLinkObject | This is CreateNewLinkObject, a member of class ClassFrontsidePolicy.
CreateNewObject | This is CreateNewObject, a member of class ClassFrontsidePolicy.
GetCache | This is GetCache, a member of class ClassFrontsidePolicy.
GetMemberPolicy | This is GetMemberPolicy, a member of class ClassFrontsidePolicy.
GetMemberPolicyByLoopbackIndex | This is GetMemberPolicyByLoopbackIndex, a member of class ClassFrontsidePolicy.
GetPreDeleteMethod | This is GetPreDeleteMethod, a member of class ClassFrontsidePolicy.


ClassFrontsidePolicy.CreateFrontendObject Method

ClassFrontsidePolicy.CreateFrontendObject Method
ClassFrontsidePolicy Class Eco.Framework.Impl.Frontside Namespace See Also
Collapse All
C#
public object CreateFrontendObject(
    IContent contents
);
Remarks

This is CreateFrontendObject, a member of class ClassFrontsidePolicy.

See Also
ClassFrontsidePolicy Class
Eco.Framework.Impl.Frontside Namespace


ClassFrontsidePolicy.CreateNewLinkObject Method

ClassFrontsidePolicy.CreateNewLinkObject Method
ClassFrontsidePolicy Class Eco.Framework.Impl.Frontside Namespace See Also
Collapse All
C#
public Locator CreateNewLinkObject(
    Locator locator1,
    IAssociationEnd end1,
    Locator locator2,
    IAssociationEnd end2
);
Remarks

This is CreateNewLinkObject, a member of class ClassFrontsidePolicy.

See Also
ClassFrontsidePolicy Class
Eco.Framework.Impl.Frontside Namespace


ClassFrontsidePolicy.CreateNewObject Method

ClassFrontsidePolicy.CreateNewObject Method
ClassFrontsidePolicy Class Eco.Framework.Impl.Frontside Namespace See Also
Collapse All
C#
public IObjectInstance CreateNewObject();
Remarks

This is CreateNewObject, a member of class ClassFrontsidePolicy.

See Also
ClassFrontsidePolicy Class
Eco.Framework.Impl.Frontside Namespace


ClassFrontsidePolicy.GetCache Method

ClassFrontsidePolicy.GetCache Method
ClassFrontsidePolicy Class Eco.Framework.Impl.Frontside Namespace See Also
Collapse All
C#
public ICache GetCache();
Remarks

This is GetCache, a member of class ClassFrontsidePolicy.

See Also
ClassFrontsidePolicy Class
Eco.Framework.Impl.Frontside Namespace


ClassFrontsidePolicy.GetMemberPolicy Method

ClassFrontsidePolicy.GetMemberPolicy Method
ClassFrontsidePolicy Class Eco.Framework.Impl.Frontside Namespace See Also
Collapse All
C#
public MemberFrontsidePolicy GetMemberPolicy(
    int memberIndex
);
Remarks

This is GetMemberPolicy, a member of class ClassFrontsidePolicy.

See Also
ClassFrontsidePolicy Class
Eco.Framework.Impl.Frontside Namespace


ClassFrontsidePolicy.GetMemberPolicyByLoopbackIndex Method

ClassFrontsidePolicy.GetMemberPolicyByLoopbackIndex Method
ClassFrontsidePolicy Class Eco.Framework.Impl.Frontside Namespace See Also
Collapse All
C#
public MemberFrontsidePolicy GetMemberPolicyByLoopbackIndex(
    int loopbackIndex
);
Remarks

This is GetMemberPolicyByLoopbackIndex, a member of class ClassFrontsidePolicy.

See Also
ClassFrontsidePolicy Class
Eco.Framework.Impl.Frontside Namespace


ClassFrontsidePolicy.GetPreDeleteMethod Method

ClassFrontsidePolicy.GetPreDeleteMethod Method
ClassFrontsidePolicy Class Eco.Framework.Impl.Frontside Namespace See Also
Collapse All
C#
public MethodInfo GetPreDeleteMethod();
Remarks

This is GetPreDeleteMethod, a member of class ClassFrontsidePolicy.

See Also
ClassFrontsidePolicy Class
Eco.Framework.Impl.Frontside Namespace


ClassFrontsidePolicy Properties

ClassFrontsidePolicy Properties
Public Properties
Collapse All

The properties of the ClassFrontsidePolicy class are listed here.

Public Properties
Name | Description
Owner | This is Owner, a member of class ClassFrontsidePolicy.
UmlClass | This is UmlClass, a member of class ClassFrontsidePolicy.


ClassFrontsidePolicy.Owner Property

ClassFrontsidePolicy.Owner Property
ClassFrontsidePolicy Class Eco.Framework.Impl.Frontside Namespace See Also
Collapse All
C#
public DefaultFrontsidePolicy Owner;
Remarks

This is Owner, a member of class ClassFrontsidePolicy.

See Also
ClassFrontsidePolicy Class
Eco.Framework.Impl.Frontside Namespace


ClassFrontsidePolicy.UmlClass Property

ClassFrontsidePolicy.UmlClass Property
ClassFrontsidePolicy Class Eco.Framework.Impl.Frontside Namespace See Also
Collapse All
C#
public IClass UmlClass;
Remarks

This is UmlClass, a member of class ClassFrontsidePolicy.

See Also
ClassFrontsidePolicy Class
Eco.Framework.Impl.Frontside Namespace


DefaultFrontsideLocator Class

DefaultFrontsideLocator Class
Inheritance Hierarchy See Also
Collapse All
C#
public class DefaultFrontsideLocator : CacheLocator, IElement, IObjectInstance, IEcoObject, IFeatured, IContent, IPropertyCollection, IStateMachineAccess, INotifyPropertyChanged;
Remarks

This is class Eco.Framework.Impl.Frontside.DefaultFrontsideLocator.

Inheritance Hierarchy
Eco.Framework.Impl.CacheLocator
    Eco.Framework.Impl.Frontside.DefaultFrontsideLocator
File

DefaultCacheAndFrontsideLocator.cs

See Also
Inheritance Hierarchy


DefaultFrontsideLocator.DefaultFrontsideLocator Constructor

DefaultFrontsideLocator.DefaultFrontsideLocator Constructor
DefaultFrontsideLocator Class Eco.Framework.Impl.Frontside Namespace See Also
Collapse All
C#
public DefaultFrontsideLocator(
    object owner,
    IClass umlClass
);
Remarks

This is DefaultFrontsideLocator, a member of class DefaultFrontsideLocator.

See Also
DefaultFrontsideLocator Class
Eco.Framework.Impl.Frontside Namespace


DefaultFrontsideLocator Methods

DefaultFrontsideLocator Methods
Public Methods
Collapse All

The methods of the DefaultFrontsideLocator class are listed here.

Public Methods
Name | Description
AddValueChanged | This is AddValueChanged, a member of class DefaultFrontsideLocator.
AsIObject | This is AsIObject, a member of class DefaultFrontsideLocator.
AssertLoopbackUnassigned | This is AssertLoopbackUnassigned, a member of class DefaultFrontsideLocator.
Assign | This is Assign, a member of class DefaultFrontsideLocator.
Clear | This is Clear, a member of class DefaultFrontsideLocator.
CloneValue | This is CloneValue, a member of class DefaultFrontsideLocator.
Delete | This is Delete, a member of class DefaultFrontsideLocator.
Delete_CascadeDelete | This is Delete_CascadeDelete, a member of class DefaultFrontsideLocator.
EnsureFetched | This is EnsureFetched, a member of class DefaultFrontsideLocator.
ExistenceChanged | This is ExistenceChanged, a member of class DefaultFrontsideLocator.
get_MemberByIndex | IContent
GetAsCollection | This is GetAsCollection, a member of class DefaultFrontsideLocator.
GetAsIList | This is GetAsIList, a member of class DefaultFrontsideLocator.
GetAsList | This is GetAsList, a member of class DefaultFrontsideLocator.
GetByLoopbackIndex | This is GetByLoopbackIndex, a member of class DefaultFrontsideLocator.
GetIsEqualHashCode | This is GetIsEqualHashCode, a member of class DefaultFrontsideLocator.
GetOwner | This is GetOwner, a member of class DefaultFrontsideLocator.
GetValue | This is GetValue, a member of class DefaultFrontsideLocator.
InternalCanDelete_CascadeCanDelete | This is InternalCanDelete_CascadeCanDelete, a member of class DefaultFrontsideLocator.
InternalCanDelete_CheckEmpty | This is InternalCanDelete_CheckEmpty, a member of class DefaultFrontsideLocator.
Invoke | This is the overview for the Invoke method overload.
InvokeQuery | This is InvokeQuery, a member of class DefaultFrontsideLocator.
IsEqual | This is IsEqual, a member of class DefaultFrontsideLocator.
LoopbackValid | This is LoopbackValid, a member of class DefaultFrontsideLocator.
MemberChanged | This is MemberChanged, a member of class DefaultFrontsideLocator.
RemoveValueChanged | This is RemoveValueChanged, a member of class DefaultFrontsideLocator.
set_LoopBack | This is set_LoopBack, a member of class DefaultFrontsideLocator.
set_MemberByIndex | This is set_MemberByIndex, a member of class DefaultFrontsideLocator.
SetValue | This is SetValue, a member of class DefaultFrontsideLocator.
SubscribeToMember | This is SubscribeToMember, a member of class DefaultFrontsideLocator.
SubscribeToPropertyChanged | This is SubscribeToPropertyChanged, a member of class DefaultFrontsideLocator.
SubscribeToValue | This is SubscribeToValue, a member of class DefaultFrontsideLocator.
this | This is the overview for the this indexer overload.


DefaultFrontsideLocator.AddValueChanged Method

DefaultFrontsideLocator.AddValueChanged Method
DefaultFrontsideLocator Class Eco.Framework.Impl.Frontside Namespace See Also
Collapse All
C#
public void AddValueChanged(
    IStructuralFeature member,
    EventHandler handler
);
Remarks

This is AddValueChanged, a member of class DefaultFrontsideLocator.

See Also
DefaultFrontsideLocator Class
Eco.Framework.Impl.Frontside Namespace


DefaultFrontsideLocator.AsIObject Method

DefaultFrontsideLocator.AsIObject Method
DefaultFrontsideLocator Class Eco.Framework.Impl.Frontside Namespace See Also
Collapse All
C#
public IObjectInstance AsIObject();
Remarks

This is AsIObject, a member of class DefaultFrontsideLocator.

See Also
DefaultFrontsideLocator Class
Eco.Framework.Impl.Frontside Namespace


DefaultFrontsideLocator.AssertLoopbackUnassigned Method

DefaultFrontsideLocator.AssertLoopbackUnassigned Method
DefaultFrontsideLocator Class Eco.Framework.Impl.Frontside Namespace See Also
Collapse All
C#
public void AssertLoopbackUnassigned();
Remarks

This is AssertLoopbackUnassigned, a member of class DefaultFrontsideLocator.

See Also
DefaultFrontsideLocator Class
Eco.Framework.Impl.Frontside Namespace


DefaultFrontsideLocator.Assign Method

DefaultFrontsideLocator.Assign Method
DefaultFrontsideLocator Class Eco.Framework.Impl.Frontside Namespace See Also
Collapse All
C#
public void Assign(
    IElement element
);
Remarks

This is Assign, a member of class DefaultFrontsideLocator.

See Also
DefaultFrontsideLocator Class
Eco.Framework.Impl.Frontside Namespace


DefaultFrontsideLocator.Clear Method

DefaultFrontsideLocator.Clear Method
DefaultFrontsideLocator Class Eco.Framework.Impl.Frontside Namespace See Also
Collapse All
C#
public void Clear();
Remarks

This is Clear, a member of class DefaultFrontsideLocator.

See Also
DefaultFrontsideLocator Class
Eco.Framework.Impl.Frontside Namespace


DefaultFrontsideLocator.CloneValue Method

DefaultFrontsideLocator.CloneValue Method
DefaultFrontsideLocator Class Eco.Framework.Impl.Frontside Namespace See Also
Collapse All
C#
public IElement CloneValue(
    bool readOnly
);
Remarks

This is CloneValue, a member of class DefaultFrontsideLocator.

See Also
DefaultFrontsideLocator Class
Eco.Framework.Impl.Frontside Namespace


DefaultFrontsideLocator.Delete Method

DefaultFrontsideLocator.Delete Method
DefaultFrontsideLocator Class Eco.Framework.Impl.Frontside Namespace See Also
Collapse All
C#
public void Delete();
Remarks

This is Delete, a member of class DefaultFrontsideLocator.

See Also
DefaultFrontsideLocator Class
Eco.Framework.Impl.Frontside Namespace


DefaultFrontsideLocator.Delete_CascadeDelete Method

DefaultFrontsideLocator.Delete_CascadeDelete Method
DefaultFrontsideLocator Class Eco.Framework.Impl.Frontside Namespace See Also
Collapse All
C#
public void Delete_CascadeDelete(
    IProperty member
);
Remarks

This is Delete_CascadeDelete, a member of class DefaultFrontsideLocator.

See Also
DefaultFrontsideLocator Class
Eco.Framework.Impl.Frontside Namespace


DefaultFrontsideLocator.EnsureFetched Method

DefaultFrontsideLocator.EnsureFetched Method
DefaultFrontsideLocator Class Eco.Framework.Impl.Frontside Namespace See Also
Collapse All
C#
public void EnsureFetched();
Remarks

This is EnsureFetched, a member of class DefaultFrontsideLocator.

See Also
DefaultFrontsideLocator Class
Eco.Framework.Impl.Frontside Namespace


DefaultFrontsideLocator.ExistenceChanged Method

DefaultFrontsideLocator.ExistenceChanged Method
DefaultFrontsideLocator Class Eco.Framework.Impl.Frontside Namespace See Also
Collapse All
C#
public void ExistenceChanged();
Remarks

This is ExistenceChanged, a member of class DefaultFrontsideLocator.

See Also
DefaultFrontsideLocator Class
Eco.Framework.Impl.Frontside Namespace


DefaultFrontsideLocator.get_MemberByIndex Method

DefaultFrontsideLocator.get_MemberByIndex Method
DefaultFrontsideLocator Class Eco.Framework.Impl.Frontside Namespace See Also
Collapse All
C#
public object get_MemberByIndex(
    int index
);
Remarks

IContent

See Also
DefaultFrontsideLocator Class
Eco.Framework.Impl.Frontside Namespace


DefaultFrontsideLocator.GetAsCollection Method

DefaultFrontsideLocator.GetAsCollection Method
DefaultFrontsideLocator Class Eco.Framework.Impl.Frontside Namespace See Also
Collapse All
C#
public IElementCollection GetAsCollection();
Remarks

This is GetAsCollection, a member of class DefaultFrontsideLocator.

See Also
DefaultFrontsideLocator Class
Eco.Framework.Impl.Frontside Namespace


DefaultFrontsideLocator.GetAsIList Method

DefaultFrontsideLocator.GetAsIList Method
DefaultFrontsideLocator Class Eco.Framework.Impl.Frontside Namespace See Also
Collapse All
C#
public IList<T> GetAsIList<T>();
Remarks

This is GetAsIList, a member of class DefaultFrontsideLocator.

See Also
DefaultFrontsideLocator Class
Eco.Framework.Impl.Frontside Namespace


DefaultFrontsideLocator.GetAsList Method

DefaultFrontsideLocator.GetAsList Method
DefaultFrontsideLocator Class Eco.Framework.Impl.Frontside Namespace See Also
Collapse All
C#
public IObjectList GetAsList();
Remarks

This is GetAsList, a member of class DefaultFrontsideLocator.

See Also
DefaultFrontsideLocator Class
Eco.Framework.Impl.Frontside Namespace


DefaultFrontsideLocator.GetByLoopbackIndex Method

DefaultFrontsideLocator.GetByLoopbackIndex Method
DefaultFrontsideLocator Class Eco.Framework.Impl.Frontside Namespace See Also
Collapse All
C#
public IProperty GetByLoopbackIndex(
    int loopbackIndex
);
Remarks

This is GetByLoopbackIndex, a member of class DefaultFrontsideLocator.

See Also
DefaultFrontsideLocator Class
Eco.Framework.Impl.Frontside Namespace


DefaultFrontsideLocator.GetIsEqualHashCode Method

DefaultFrontsideLocator.GetIsEqualHashCode Method
DefaultFrontsideLocator Class Eco.Framework.Impl.Frontside Namespace See Also
Collapse All
C#
public int GetIsEqualHashCode();
Remarks

This is GetIsEqualHashCode, a member of class DefaultFrontsideLocator.

See Also
DefaultFrontsideLocator Class
Eco.Framework.Impl.Frontside Namespace


DefaultFrontsideLocator.GetOwner Method

DefaultFrontsideLocator.GetOwner Method
DefaultFrontsideLocator Class Eco.Framework.Impl.Frontside Namespace See Also
Collapse All
C#
public IObjectInstance GetOwner();
Remarks

This is GetOwner, a member of class DefaultFrontsideLocator.

See Also
DefaultFrontsideLocator Class
Eco.Framework.Impl.Frontside Namespace


DefaultFrontsideLocator.GetValue Method

DefaultFrontsideLocator.GetValue Method
DefaultFrontsideLocator Class Eco.Framework.Impl.Frontside Namespace See Also
Collapse All
C#
public T GetValue<T>();
Remarks

This is GetValue, a member of class DefaultFrontsideLocator.

See Also
DefaultFrontsideLocator Class
Eco.Framework.Impl.Frontside Namespace


DefaultFrontsideLocator.InternalCanDelete_CascadeCanDelete Method

DefaultFrontsideLocator.InternalCanDelete_CascadeCanDelete Method
DefaultFrontsideLocator Class Eco.Framework.Impl.Frontside Namespace See Also
Collapse All
C#
public NonDeletableReason InternalCanDelete_CascadeCanDelete(
    Dictionary<DefaultFrontsideLocator, DefaultFrontsideLocator> checkedObjects,
    bool cascade,
    IProperty member
);
Remarks

This is InternalCanDelete_CascadeCanDelete, a member of class DefaultFrontsideLocator.

See Also
DefaultFrontsideLocator Class
Eco.Framework.Impl.Frontside Namespace


DefaultFrontsideLocator.InternalCanDelete_CheckEmpty Method

DefaultFrontsideLocator.InternalCanDelete_CheckEmpty Method
DefaultFrontsideLocator Class Eco.Framework.Impl.Frontside Namespace See Also
Collapse All
C#
public bool InternalCanDelete_CheckEmpty(
    IProperty member
);
Remarks

This is InternalCanDelete_CheckEmpty, a member of class DefaultFrontsideLocator.

See Also
DefaultFrontsideLocator Class
Eco.Framework.Impl.Frontside Namespace


Invoke Method

Invoke Method

This is the overview for the Invoke method overload.

Overload List
Name | Description
DefaultFrontsideLocator.Invoke (IMethod, IElement[]) | This is Invoke, a member of class DefaultFrontsideLocator.
DefaultFrontsideLocator.Invoke (IMethod, object[]) | This is Invoke, a member of class DefaultFrontsideLocator.
DefaultFrontsideLocator.Invoke (string, object[]) | This is Invoke, a member of class DefaultFrontsideLocator.


DefaultFrontsideLocator.Invoke Method (IMethod, IElement[])

DefaultFrontsideLocator.Invoke Method (IMethod, IElement[])
DefaultFrontsideLocator Class Eco.Framework.Impl.Frontside Namespace See Also
Collapse All
C#
public object Invoke(
    IMethod method,
    IElement[] parameters
);
Remarks

This is Invoke, a member of class DefaultFrontsideLocator.

See Also
DefaultFrontsideLocator Class
Eco.Framework.Impl.Frontside Namespace


DefaultFrontsideLocator.Invoke Method (IMethod, object[])

DefaultFrontsideLocator.Invoke Method (IMethod, object[])
DefaultFrontsideLocator Class Eco.Framework.Impl.Frontside Namespace See Also
Collapse All
C#
public object Invoke(
    IMethod method,
    object[] parameters
);
Remarks

This is Invoke, a member of class DefaultFrontsideLocator.

See Also
DefaultFrontsideLocator Class
Eco.Framework.Impl.Frontside Namespace


DefaultFrontsideLocator.Invoke Method (string, object[])

DefaultFrontsideLocator.Invoke Method (string, object[])
DefaultFrontsideLocator Class Eco.Framework.Impl.Frontside Namespace See Also
Collapse All
C#
public object Invoke(
    string methodName,
    object[] parameters
);
Remarks

This is Invoke, a member of class DefaultFrontsideLocator.

See Also
DefaultFrontsideLocator Class
Eco.Framework.Impl.Frontside Namespace


DefaultFrontsideLocator.InvokeQuery Method

DefaultFrontsideLocator.InvokeQuery Method
DefaultFrontsideLocator Class Eco.Framework.Impl.Frontside Namespace See Also
Collapse All
C#
public object InvokeQuery(
    IMethod method,
    IElement[] parameters,
    ISubscriber reevaluateSubscriber,
    ISubscriber resubscribeSubscriber
);
Remarks

This is InvokeQuery, a member of class DefaultFrontsideLocator.

See Also
DefaultFrontsideLocator Class
Eco.Framework.Impl.Frontside Namespace


DefaultFrontsideLocator.IsEqual Method

DefaultFrontsideLocator.IsEqual Method
DefaultFrontsideLocator Class Eco.Framework.Impl.Frontside Namespace See Also
Collapse All
C#
public bool IsEqual(
    IElement element
);
Remarks

This is IsEqual, a member of class DefaultFrontsideLocator.

See Also
DefaultFrontsideLocator Class
Eco.Framework.Impl.Frontside Namespace


DefaultFrontsideLocator.LoopbackValid Method

DefaultFrontsideLocator.LoopbackValid Method
DefaultFrontsideLocator Class Eco.Framework.Impl.Frontside Namespace See Also
Collapse All
C#
public void LoopbackValid();
Remarks

This is LoopbackValid, a member of class DefaultFrontsideLocator.

See Also
DefaultFrontsideLocator Class
Eco.Framework.Impl.Frontside Namespace


DefaultFrontsideLocator.MemberChanged Method

DefaultFrontsideLocator.MemberChanged Method
DefaultFrontsideLocator Class Eco.Framework.Impl.Frontside Namespace See Also
Collapse All
C#
public void MemberChanged(
    IStructuralFeature feature
);
Remarks

This is MemberChanged, a member of class DefaultFrontsideLocator.

See Also
DefaultFrontsideLocator Class
Eco.Framework.Impl.Frontside Namespace


DefaultFrontsideLocator.RemoveValueChanged Method

DefaultFrontsideLocator.RemoveValueChanged Method
DefaultFrontsideLocator Class Eco.Framework.Impl.Frontside Namespace See Also
Collapse All
C#
public void RemoveValueChanged(
    IStructuralFeature member,
    EventHandler handler
);
Remarks

This is RemoveValueChanged, a member of class DefaultFrontsideLocator.

See Also
DefaultFrontsideLocator Class
Eco.Framework.Impl.Frontside Namespace


DefaultFrontsideLocator.set_LoopBack Method

DefaultFrontsideLocator.set_LoopBack Method
DefaultFrontsideLocator Class Eco.Framework.Impl.Frontside Namespace See Also
Collapse All
C#
public void set_LoopBack(
    ILoopBack value
);
Remarks

This is set_LoopBack, a member of class DefaultFrontsideLocator.

See Also
DefaultFrontsideLocator Class
Eco.Framework.Impl.Frontside Namespace


DefaultFrontsideLocator.set_MemberByIndex Method

DefaultFrontsideLocator.set_MemberByIndex Method
DefaultFrontsideLocator Class Eco.Framework.Impl.Frontside Namespace See Also
Collapse All
C#
public void set_MemberByIndex(
    int index,
    object value
);
Remarks

This is set_MemberByIndex, a member of class DefaultFrontsideLocator.

See Also
DefaultFrontsideLocator Class
Eco.Framework.Impl.Frontside Namespace


DefaultFrontsideLocator.SetValue Method

DefaultFrontsideLocator.SetValue Method
DefaultFrontsideLocator Class Eco.Framework.Impl.Frontside Namespace See Also
Collapse All
C#
public void SetValue<T>(
    T value
);
Remarks

This is SetValue, a member of class DefaultFrontsideLocator.

See Also
DefaultFrontsideLocator Class
Eco.Framework.Impl.Frontside Namespace


DefaultFrontsideLocator.SubscribeToMember Method

DefaultFrontsideLocator.SubscribeToMember Method
DefaultFrontsideLocator Class Eco.Framework.Impl.Frontside Namespace See Also
Collapse All
C#
public void SubscribeToMember(
    IStructuralFeature member,
    ISubscriber subscriber
);
Remarks

This is SubscribeToMember, a member of class DefaultFrontsideLocator.

See Also
DefaultFrontsideLocator Class
Eco.Framework.Impl.Frontside Namespace


DefaultFrontsideLocator.SubscribeToPropertyChanged Method

DefaultFrontsideLocator.SubscribeToPropertyChanged Method
DefaultFrontsideLocator Class Eco.Framework.Impl.Frontside Namespace See Also
Collapse All
C#
public void SubscribeToPropertyChanged(
    ISubscriber subscriber
);
Remarks

This is SubscribeToPropertyChanged, a member of class DefaultFrontsideLocator.

See Also
DefaultFrontsideLocator Class
Eco.Framework.Impl.Frontside Namespace


DefaultFrontsideLocator.SubscribeToValue Method

DefaultFrontsideLocator.SubscribeToValue Method
DefaultFrontsideLocator Class Eco.Framework.Impl.Frontside Namespace See Also
Collapse All
C#
public void SubscribeToValue(
    ISubscriber subscriber
);
Remarks

This is SubscribeToValue, a member of class DefaultFrontsideLocator.

See Also
DefaultFrontsideLocator Class
Eco.Framework.Impl.Frontside Namespace


this Indexer

this Indexer

This is the overview for the this indexer overload.

Overload List
Name | Description
DefaultFrontsideLocator.this (int) | This is this, a member of class DefaultFrontsideLocator.
DefaultFrontsideLocator.this (IStructuralFeature) | This is this, a member of class DefaultFrontsideLocator.
DefaultFrontsideLocator.this (string) | This is this, a member of class DefaultFrontsideLocator.


DefaultFrontsideLocator.this Indexer (IStructuralFeature)

DefaultFrontsideLocator.this Indexer (IStructuralFeature)
DefaultFrontsideLocator Class Eco.Framework.Impl.Frontside Namespace See Also
Collapse All
C#
public IProperty this[
    IStructuralFeature feature
];
Remarks

This is this, a member of class DefaultFrontsideLocator.

See Also
DefaultFrontsideLocator Class
Eco.Framework.Impl.Frontside Namespace


DefaultFrontsideLocator.this Indexer (int)

DefaultFrontsideLocator.this Indexer (int)
DefaultFrontsideLocator Class Eco.Framework.Impl.Frontside Namespace See Also
Collapse All
C#
public IProperty this[
    int index
];
Remarks

This is this, a member of class DefaultFrontsideLocator.

See Also
DefaultFrontsideLocator Class
Eco.Framework.Impl.Frontside Namespace


DefaultFrontsideLocator.this Indexer (string)

DefaultFrontsideLocator.this Indexer (string)
DefaultFrontsideLocator Class Eco.Framework.Impl.Frontside Namespace See Also
Collapse All
C#
public IProperty this[
    string name
];
Remarks

This is this, a member of class DefaultFrontsideLocator.

See Also
DefaultFrontsideLocator Class
Eco.Framework.Impl.Frontside Namespace


DefaultFrontsideLocator Properties

DefaultFrontsideLocator Properties
Public Properties
Collapse All

The properties of the DefaultFrontsideLocator class are listed here.

Public Properties
Name | Description
AsObject | This is AsObject, a member of class DefaultFrontsideLocator.
ClassPolicy | This is ClassPolicy, a member of class DefaultFrontsideLocator.
ContentType | This is ContentType, a member of class DefaultFrontsideLocator.
DefaultStringRepresentation | This is DefaultStringRepresentation, a member of class DefaultFrontsideLocator.
Deleted | This is Deleted, a member of class DefaultFrontsideLocator.
EnsuredLoopBack | This is EnsuredLoopBack, a member of class DefaultFrontsideLocator.
FrontsidePolicy | This is FrontsidePolicy, a member of class DefaultFrontsideLocator.
IsDeletable | This is IsDeletable, a member of class DefaultFrontsideLocator.
IsNullInstance | This is IsNullInstance, a member of class DefaultFrontsideLocator.
IsProperty | This is IsProperty, a member of class DefaultFrontsideLocator.
Mutable | This is Mutable, a member of class DefaultFrontsideLocator.
NonDeletableReason | This is NonDeletableReason, a member of class DefaultFrontsideLocator.
ObjectInstance | This is ObjectInstance, a member of class DefaultFrontsideLocator.
Properties | This is Properties, a member of class DefaultFrontsideLocator.
ReadOnly | This is ReadOnly, a member of class DefaultFrontsideLocator.
ServiceProvider | IObject
StateMachine | This is StateMachine, a member of class DefaultFrontsideLocator.
UmlClass | IObjectContainer
UmlType | This is UmlType, a member of class DefaultFrontsideLocator.
UndoService | This is UndoService, a member of class DefaultFrontsideLocator.


DefaultFrontsideLocator.AsObject Property

DefaultFrontsideLocator.AsObject Property
DefaultFrontsideLocator Class Eco.Framework.Impl.Frontside Namespace See Also
Collapse All
C#
public object AsObject;
Remarks

This is AsObject, a member of class DefaultFrontsideLocator.

See Also
DefaultFrontsideLocator Class
Eco.Framework.Impl.Frontside Namespace


DefaultFrontsideLocator.ClassPolicy Property

DefaultFrontsideLocator.ClassPolicy Property
DefaultFrontsideLocator Class Eco.Framework.Impl.Frontside Namespace See Also
Collapse All
C#
public ClassFrontsidePolicy ClassPolicy;
Remarks

This is ClassPolicy, a member of class DefaultFrontsideLocator.

See Also
DefaultFrontsideLocator Class
Eco.Framework.Impl.Frontside Namespace


DefaultFrontsideLocator.ContentType Property

DefaultFrontsideLocator.ContentType Property
DefaultFrontsideLocator Class Eco.Framework.Impl.Frontside Namespace See Also
Collapse All
C#
public ContentType ContentType;
Remarks

This is ContentType, a member of class DefaultFrontsideLocator.

See Also
DefaultFrontsideLocator Class
Eco.Framework.Impl.Frontside Namespace


DefaultFrontsideLocator.DefaultStringRepresentation Property

DefaultFrontsideLocator.DefaultStringRepresentation Property
DefaultFrontsideLocator Class Eco.Framework.Impl.Frontside Namespace See Also
Collapse All
C#
public string DefaultStringRepresentation;
Remarks

This is DefaultStringRepresentation, a member of class DefaultFrontsideLocator.

See Also
DefaultFrontsideLocator Class
Eco.Framework.Impl.Frontside Namespace


DefaultFrontsideLocator.Deleted Property

DefaultFrontsideLocator.Deleted Property
DefaultFrontsideLocator Class Eco.Framework.Impl.Frontside Namespace See Also
Collapse All
C#
public bool Deleted;
Remarks

This is Deleted, a member of class DefaultFrontsideLocator.

See Also
DefaultFrontsideLocator Class
Eco.Framework.Impl.Frontside Namespace


DefaultFrontsideLocator.EnsuredLoopBack Property

DefaultFrontsideLocator.EnsuredLoopBack Property
DefaultFrontsideLocator Class Eco.Framework.Impl.Frontside Namespace See Also
Collapse All
C#
public ILoopBack EnsuredLoopBack;
Remarks

This is EnsuredLoopBack, a member of class DefaultFrontsideLocator.

See Also
DefaultFrontsideLocator Class
Eco.Framework.Impl.Frontside Namespace


DefaultFrontsideLocator.FrontsidePolicy Property

DefaultFrontsideLocator.FrontsidePolicy Property
DefaultFrontsideLocator Class Eco.Framework.Impl.Frontside Namespace See Also
Collapse All
C#
public DefaultFrontsidePolicy FrontsidePolicy;
Remarks

This is FrontsidePolicy, a member of class DefaultFrontsideLocator.

See Also
DefaultFrontsideLocator Class
Eco.Framework.Impl.Frontside Namespace


DefaultFrontsideLocator.IsDeletable Property

DefaultFrontsideLocator.IsDeletable Property
DefaultFrontsideLocator Class Eco.Framework.Impl.Frontside Namespace See Also
Collapse All
C#
public bool IsDeletable;
Remarks

This is IsDeletable, a member of class DefaultFrontsideLocator.

See Also
DefaultFrontsideLocator Class
Eco.Framework.Impl.Frontside Namespace


DefaultFrontsideLocator.IsNullInstance Property

DefaultFrontsideLocator.IsNullInstance Property
DefaultFrontsideLocator Class Eco.Framework.Impl.Frontside Namespace See Also
Collapse All
C#
public bool IsNullInstance;
Remarks

This is IsNullInstance, a member of class DefaultFrontsideLocator.

See Also
DefaultFrontsideLocator Class
Eco.Framework.Impl.Frontside Namespace


DefaultFrontsideLocator.IsProperty Property

DefaultFrontsideLocator.IsProperty Property
DefaultFrontsideLocator Class Eco.Framework.Impl.Frontside Namespace See Also
Collapse All
C#
public bool IsProperty;
Remarks

This is IsProperty, a member of class DefaultFrontsideLocator.

See Also
DefaultFrontsideLocator Class
Eco.Framework.Impl.Frontside Namespace


DefaultFrontsideLocator.Mutable Property

DefaultFrontsideLocator.Mutable Property
DefaultFrontsideLocator Class Eco.Framework.Impl.Frontside Namespace See Also
Collapse All
C#
public bool Mutable;
Remarks

This is Mutable, a member of class DefaultFrontsideLocator.

See Also
DefaultFrontsideLocator Class
Eco.Framework.Impl.Frontside Namespace


DefaultFrontsideLocator.NonDeletableReason Property

DefaultFrontsideLocator.NonDeletableReason Property
DefaultFrontsideLocator Class Eco.Framework.Impl.Frontside Namespace See Also
Collapse All
C#
public INonDeletableReason NonDeletableReason;
Remarks

This is NonDeletableReason, a member of class DefaultFrontsideLocator.

See Also
DefaultFrontsideLocator Class
Eco.Framework.Impl.Frontside Namespace


DefaultFrontsideLocator.ObjectInstance Property

DefaultFrontsideLocator.ObjectInstance Property
DefaultFrontsideLocator Class Eco.Framework.Impl.Frontside Namespace See Also
Collapse All
C#
public IObjectInstance ObjectInstance;
Remarks

This is ObjectInstance, a member of class DefaultFrontsideLocator.

See Also
DefaultFrontsideLocator Class
Eco.Framework.Impl.Frontside Namespace


DefaultFrontsideLocator.Properties Property

DefaultFrontsideLocator.Properties Property
DefaultFrontsideLocator Class Eco.Framework.Impl.Frontside Namespace See Also
Collapse All
C#
public IPropertyCollection Properties;
Remarks

This is Properties, a member of class DefaultFrontsideLocator.

See Also
DefaultFrontsideLocator Class
Eco.Framework.Impl.Frontside Namespace


DefaultFrontsideLocator.ReadOnly Property

DefaultFrontsideLocator.ReadOnly Property
DefaultFrontsideLocator Class Eco.Framework.Impl.Frontside Namespace See Also
Collapse All
C#
public bool ReadOnly;
Remarks

This is ReadOnly, a member of class DefaultFrontsideLocator.

See Also
DefaultFrontsideLocator Class
Eco.Framework.Impl.Frontside Namespace


DefaultFrontsideLocator.ServiceProvider Property

DefaultFrontsideLocator.ServiceProvider Property
DefaultFrontsideLocator Class Eco.Framework.Impl.Frontside Namespace See Also
Collapse All
C#
public IEcoServiceProvider ServiceProvider;
Remarks

IObject

See Also
DefaultFrontsideLocator Class
Eco.Framework.Impl.Frontside Namespace


DefaultFrontsideLocator.StateMachine Property

DefaultFrontsideLocator.StateMachine Property
DefaultFrontsideLocator Class Eco.Framework.Impl.Frontside Namespace See Also
Collapse All
C#
public IObjectStateMachine StateMachine;
Remarks

This is StateMachine, a member of class DefaultFrontsideLocator.

See Also
DefaultFrontsideLocator Class
Eco.Framework.Impl.Frontside Namespace


DefaultFrontsideLocator.UmlClass Property

DefaultFrontsideLocator.UmlClass Property
DefaultFrontsideLocator Class Eco.Framework.Impl.Frontside Namespace See Also
Collapse All
C#
public override IClass UmlClass;
Remarks

IObjectContainer

See Also
DefaultFrontsideLocator Class
Eco.Framework.Impl.Frontside Namespace


DefaultFrontsideLocator.UmlType Property

DefaultFrontsideLocator.UmlType Property
DefaultFrontsideLocator Class Eco.Framework.Impl.Frontside Namespace See Also
Collapse All
C#
public IClassifier UmlType;
Remarks

This is UmlType, a member of class DefaultFrontsideLocator.

See Also
DefaultFrontsideLocator Class
Eco.Framework.Impl.Frontside Namespace


DefaultFrontsideLocator.UndoService Property

DefaultFrontsideLocator.UndoService Property
DefaultFrontsideLocator Class Eco.Framework.Impl.Frontside Namespace See Also
Collapse All
C#
public IUndoService UndoService;
Remarks

This is UndoService, a member of class DefaultFrontsideLocator.

See Also
DefaultFrontsideLocator Class
Eco.Framework.Impl.Frontside Namespace


DefaultFrontsideLocator Events

DefaultFrontsideLocator Events
Public Events
Collapse All

The events of the DefaultFrontsideLocator class are listed here.

Public Events
Name | Description
PropertyChanged | This is PropertyChanged, a member of class DefaultFrontsideLocator.


DefaultFrontsideLocator.PropertyChanged Event

DefaultFrontsideLocator.PropertyChanged Event
DefaultFrontsideLocator Class Eco.Framework.Impl.Frontside Namespace See Also
Collapse All
C#
public event PropertyChangedEventHandler PropertyChanged;
Remarks

This is PropertyChanged, a member of class DefaultFrontsideLocator.

See Also
DefaultFrontsideLocator Class
Eco.Framework.Impl.Frontside Namespace


DefaultFrontsidePolicy Class

DefaultFrontsidePolicy Class
Inheritance Hierarchy See Also
Collapse All
C#
public class DefaultFrontsidePolicy : EcoSpacePart, IInternalObjectContentFactory, IObjectRepresentationProvider, IObjectFactoryService;
Remarks

This is class Eco.Framework.Impl.Frontside.DefaultFrontsidePolicy.

Inheritance Hierarchy
Eco.Framework.EcoSpacePart
Eco.Framework.IObjectRepresentationProvider
    Eco.Framework.Impl.Frontside.DefaultFrontsidePolicy
File

FrontsidePolicy.cs

See Also
Inheritance Hierarchy


DefaultFrontsidePolicy.DefaultFrontsidePolicy Constructor

DefaultFrontsidePolicy.DefaultFrontsidePolicy Constructor
DefaultFrontsidePolicy Class Eco.Framework.Impl.Frontside Namespace See Also
Collapse All
C#
public DefaultFrontsidePolicy();
Remarks

This is DefaultFrontsidePolicy, a member of class DefaultFrontsidePolicy.

See Also
DefaultFrontsidePolicy Class
Eco.Framework.Impl.Frontside Namespace


DefaultFrontsidePolicy Fields

DefaultFrontsidePolicy Fields
Public Fields
Collapse All

The fields of the DefaultFrontsidePolicy class are listed here.

Public Fields
Name | Description
C_ExistenceQualifier | actually internal
C_PropertyValueChangeQualifier | This is C_PropertyValueChangeQualifier, a member of class DefaultFrontsidePolicy.


DefaultFrontsidePolicy.C_ExistenceQualifier Field

DefaultFrontsidePolicy.C_ExistenceQualifier Field
DefaultFrontsidePolicy Class Eco.Framework.Impl.Frontside Namespace See Also
Collapse All
C#
public const int C_ExistenceQualifier = -1;
Remarks

actually internal

See Also
DefaultFrontsidePolicy Class
Eco.Framework.Impl.Frontside Namespace


DefaultFrontsidePolicy.C_PropertyValueChangeQualifier Field

DefaultFrontsidePolicy.C_PropertyValueChangeQualifier Field
DefaultFrontsidePolicy Class Eco.Framework.Impl.Frontside Namespace See Also
Collapse All
C#
public const int C_PropertyValueChangeQualifier = -2;
Remarks

This is C_PropertyValueChangeQualifier, a member of class DefaultFrontsidePolicy.

See Also
DefaultFrontsidePolicy Class
Eco.Framework.Impl.Frontside Namespace


DefaultFrontsidePolicy Methods

DefaultFrontsidePolicy Methods
Protected Methods Public Methods
Collapse All

The methods of the DefaultFrontsidePolicy class are listed here.

Protected Methods
Name | Description
DoActivate | Executed by Activate after State has been set to EcoSpacePartState.Activating and before it is set to EcoSpacePartState.Active.
DoDeactivate | Executed by Deactivate after State has been set to EcoSpacePartState.Deactivating and before it is set to EcoSpacePartState.Inactive.
Top
Public Methods
Name | Description
CreateContent | This is CreateContent, a member of class DefaultFrontsidePolicy.
CreateContentFailed | This is CreateContentFailed, a member of class DefaultFrontsidePolicy.
CreateNewLinkObject | This is the overview for the CreateNewLinkObject method overload.
CreateNewObject | This is the overview for the CreateNewObject method overload.
DeleteObjects | This is DeleteObjects, a member of class DefaultFrontsidePolicy.
GetClassPolicy | This is GetClassPolicy, a member of class DefaultFrontsidePolicy.
IObjectForLocator | This is IObjectForLocator, a member of class DefaultFrontsidePolicy.
IObjectListToLocatorList | This is IObjectListToLocatorList, a member of class DefaultFrontsidePolicy.
LocatorCollectionToIObjectList | This is LocatorCollectionToIObjectList, a member of class DefaultFrontsidePolicy.
LocatorForIObject | This is LocatorForIObject, a member of class DefaultFrontsidePolicy.


DefaultFrontsidePolicy.CreateContent Method

DefaultFrontsidePolicy.CreateContent Method
DefaultFrontsidePolicy Class Eco.Framework.Impl.Frontside Namespace See Also
Collapse All
C#
public IContent CreateContent(
    ILoopBack dotNetObject
);
Remarks

This is CreateContent, a member of class DefaultFrontsidePolicy.

See Also
DefaultFrontsidePolicy Class
Eco.Framework.Impl.Frontside Namespace


DefaultFrontsidePolicy.CreateContentFailed Method

DefaultFrontsidePolicy.CreateContentFailed Method
DefaultFrontsidePolicy Class Eco.Framework.Impl.Frontside Namespace See Also
Collapse All
C#
public void CreateContentFailed(
    IContent obj,
    object dotNetObject
);
Remarks

This is CreateContentFailed, a member of class DefaultFrontsidePolicy.

See Also
DefaultFrontsidePolicy Class
Eco.Framework.Impl.Frontside Namespace


CreateNewLinkObject Method

CreateNewLinkObject Method

This is the overview for the CreateNewLinkObject method overload.

Overload List
Name | Description
DefaultFrontsidePolicy.CreateNewLinkObject (IEcoObject, IEcoObject) | This is CreateNewLinkObject, a member of class DefaultFrontsidePolicy.
DefaultFrontsidePolicy.CreateNewLinkObject (IEcoObject, IEcoObject, IAssociation) | This is CreateNewLinkObject, a member of class DefaultFrontsidePolicy.
DefaultFrontsidePolicy.CreateNewLinkObject (IEcoObject, IEcoObject, System.Type) | This is CreateNewLinkObject, a member of class DefaultFrontsidePolicy.


DefaultFrontsidePolicy.CreateNewLinkObject Method (IEcoObject, IEcoObject)

DefaultFrontsidePolicy.CreateNewLinkObject Method (IEcoObject, IEcoObject)
DefaultFrontsidePolicy Class Eco.Framework.Impl.Frontside Namespace See Also
Collapse All
C#
public IObjectInstance CreateNewLinkObject(
    IEcoObject end1,
    IEcoObject end2
);
Remarks

This is CreateNewLinkObject, a member of class DefaultFrontsidePolicy.

See Also
DefaultFrontsidePolicy Class
Eco.Framework.Impl.Frontside Namespace


DefaultFrontsidePolicy.CreateNewLinkObject Method (IEcoObject, IEcoObject, IAssociation)

DefaultFrontsidePolicy.CreateNewLinkObject Method (IEcoObject, IEcoObject, IAssociation)
DefaultFrontsidePolicy Class Eco.Framework.Impl.Frontside Namespace See Also
Collapse All
C#
public IObjectInstance CreateNewLinkObject(
    IEcoObject end1,
    IEcoObject end2,
    IAssociation assoc
);
Remarks

This is CreateNewLinkObject, a member of class DefaultFrontsidePolicy.

See Also
DefaultFrontsidePolicy Class
Eco.Framework.Impl.Frontside Namespace


DefaultFrontsidePolicy.CreateNewLinkObject Method (IEcoObject, IEcoObject, System.Type)

DefaultFrontsidePolicy.CreateNewLinkObject Method (IEcoObject, IEcoObject, System.Type)
DefaultFrontsidePolicy Class Eco.Framework.Impl.Frontside Namespace See Also
Collapse All
C#
public object CreateNewLinkObject(
    IEcoObject end1,
    IEcoObject end2,
    System.Type assocClass
);
Remarks

This is CreateNewLinkObject, a member of class DefaultFrontsidePolicy.

See Also
DefaultFrontsidePolicy Class
Eco.Framework.Impl.Frontside Namespace


CreateNewObject Method

CreateNewObject Method

This is the overview for the CreateNewObject method overload.

Overload List
Name | Description
DefaultFrontsidePolicy.CreateNewObject (IClass) | This is CreateNewObject, a member of class DefaultFrontsidePolicy.
DefaultFrontsidePolicy.CreateNewObject (string) | This is CreateNewObject, a member of class DefaultFrontsidePolicy.
DefaultFrontsidePolicy.CreateNewObject (System.Type) | This is CreateNewObject, a member of class DefaultFrontsidePolicy.


DefaultFrontsidePolicy.CreateNewObject Method (IClass)

DefaultFrontsidePolicy.CreateNewObject Method (IClass)
DefaultFrontsidePolicy Class Eco.Framework.Impl.Frontside Namespace See Also
Collapse All
C#
public IObjectInstance CreateNewObject(
    IClass c
);
Remarks

This is CreateNewObject, a member of class DefaultFrontsidePolicy.

See Also
DefaultFrontsidePolicy Class
Eco.Framework.Impl.Frontside Namespace


DefaultFrontsidePolicy.CreateNewObject Method (System.Type)

DefaultFrontsidePolicy.CreateNewObject Method (System.Type)
DefaultFrontsidePolicy Class Eco.Framework.Impl.Frontside Namespace See Also
Collapse All
C#
public IObjectInstance CreateNewObject(
    System.Type t
);
Remarks

This is CreateNewObject, a member of class DefaultFrontsidePolicy.

See Also
DefaultFrontsidePolicy Class
Eco.Framework.Impl.Frontside Namespace


DefaultFrontsidePolicy.CreateNewObject Method (string)

DefaultFrontsidePolicy.CreateNewObject Method (string)
DefaultFrontsidePolicy Class Eco.Framework.Impl.Frontside Namespace See Also
Collapse All
C#
public IObjectInstance CreateNewObject(
    string className
);
Remarks

This is CreateNewObject, a member of class DefaultFrontsidePolicy.

See Also
DefaultFrontsidePolicy Class
Eco.Framework.Impl.Frontside Namespace


DefaultFrontsidePolicy.DeleteObjects Method

DefaultFrontsidePolicy.DeleteObjects Method
DefaultFrontsidePolicy Class Eco.Framework.Impl.Frontside Namespace See Also
Collapse All
C#
public void DeleteObjects(
    IEnumerable<IEcoObject> list
);
Remarks

This is DeleteObjects, a member of class DefaultFrontsidePolicy.

See Also
DefaultFrontsidePolicy Class
Eco.Framework.Impl.Frontside Namespace


DefaultFrontsidePolicy.DoActivate Method

DefaultFrontsidePolicy.DoActivate Method
DefaultFrontsidePolicy Class Eco.Framework.Impl.Frontside Namespace See Also
Collapse All

Executed by Activate after State has been set to EcoSpacePartState.Activating and before it is set to EcoSpacePartState.Active.

C#
protected override void DoActivate();
See Also
DefaultFrontsidePolicy Class
Eco.Framework.Impl.Frontside Namespace


DefaultFrontsidePolicy.DoDeactivate Method

DefaultFrontsidePolicy.DoDeactivate Method
DefaultFrontsidePolicy Class Eco.Framework.Impl.Frontside Namespace See Also
Collapse All

Executed by Deactivate after State has been set to EcoSpacePartState.Deactivating and before it is set to EcoSpacePartState.Inactive.

C#
protected override void DoDeactivate();
See Also
DefaultFrontsidePolicy Class
Eco.Framework.Impl.Frontside Namespace


DefaultFrontsidePolicy.GetClassPolicy Method

DefaultFrontsidePolicy.GetClassPolicy Method
DefaultFrontsidePolicy Class Eco.Framework.Impl.Frontside Namespace See Also
Collapse All
C#
public ClassFrontsidePolicy GetClassPolicy(
    IClass class_
);
Remarks

This is GetClassPolicy, a member of class DefaultFrontsidePolicy.

See Also
DefaultFrontsidePolicy Class
Eco.Framework.Impl.Frontside Namespace


DefaultFrontsidePolicy.IObjectForLocator Method

DefaultFrontsidePolicy.IObjectForLocator Method
DefaultFrontsidePolicy Class Eco.Framework.Impl.Frontside Namespace See Also
Collapse All
C#
public IObjectInstance IObjectForLocator(
    Locator locator
);
Remarks

This is IObjectForLocator, a member of class DefaultFrontsidePolicy.

See Also
DefaultFrontsidePolicy Class
Eco.Framework.Impl.Frontside Namespace


DefaultFrontsidePolicy.IObjectListToLocatorList Method

DefaultFrontsidePolicy.IObjectListToLocatorList Method
DefaultFrontsidePolicy Class Eco.Framework.Impl.Frontside Namespace See Also
Collapse All
C#
public IList<Locator> IObjectListToLocatorList<T>(
    IEnumerable<T> objectList
) where T : IEcoObject;
Remarks

This is IObjectListToLocatorList, a member of class DefaultFrontsidePolicy.

See Also
DefaultFrontsidePolicy Class
Eco.Framework.Impl.Frontside Namespace


DefaultFrontsidePolicy.LocatorCollectionToIObjectList Method

DefaultFrontsidePolicy.LocatorCollectionToIObjectList Method
DefaultFrontsidePolicy Class Eco.Framework.Impl.Frontside Namespace See Also
Collapse All
C#
public IObjectList LocatorCollectionToIObjectList(
    IEnumerable<Locator> locators,
    IClass umlClass
);
Remarks

This is LocatorCollectionToIObjectList, a member of class DefaultFrontsidePolicy.

See Also
DefaultFrontsidePolicy Class
Eco.Framework.Impl.Frontside Namespace


DefaultFrontsidePolicy.LocatorForIObject Method

DefaultFrontsidePolicy.LocatorForIObject Method
DefaultFrontsidePolicy Class Eco.Framework.Impl.Frontside Namespace See Also
Collapse All
C#
public Locator LocatorForIObject(
    IObjectInstance obj
);
Remarks

This is LocatorForIObject, a member of class DefaultFrontsidePolicy.

See Also
DefaultFrontsidePolicy Class
Eco.Framework.Impl.Frontside Namespace


DefaultFrontsidePolicy Properties

DefaultFrontsidePolicy Properties
Public Properties
Collapse All

The properties of the DefaultFrontsidePolicy class are listed here.

Public Properties
Name | Description
ActionLanguageService | This is ActionLanguageService, a member of class DefaultFrontsidePolicy.
AutoSubscriptionService | This is AutoSubscriptionService, a member of class DefaultFrontsidePolicy.
Cache | This is Cache, a member of class DefaultFrontsidePolicy.
DerivedMemberManager | This is DerivedMemberManager, a member of class DefaultFrontsidePolicy.
EnforceStringLength | This is EnforceStringLength, a member of class DefaultFrontsidePolicy.
FetchStrategy | This is FetchStrategy, a member of class DefaultFrontsidePolicy.
LocatorOwner | This is LocatorOwner, a member of class DefaultFrontsidePolicy.
ObjectFactoryService | This is ObjectFactoryService, a member of class DefaultFrontsidePolicy.
ObjectRepresentationProvider | This is ObjectRepresentationProvider, a member of class DefaultFrontsidePolicy.
OclService | This is OclService, a member of class DefaultFrontsidePolicy.
PersistenceHandler | This is PersistenceHandler, a member of class DefaultFrontsidePolicy.
ServiceProvider | This is ServiceProvider, a member of class DefaultFrontsidePolicy.
TypeSystem | This is TypeSystem, a member of class DefaultFrontsidePolicy.
UndoService | This is UndoService, a member of class DefaultFrontsidePolicy.
VariableFactory | This is VariableFactory, a member of class DefaultFrontsidePolicy.


DefaultFrontsidePolicy.ActionLanguageService Property

DefaultFrontsidePolicy.ActionLanguageService Property
DefaultFrontsidePolicy Class Eco.Framework.Impl.Frontside Namespace See Also
Collapse All
C#
public IActionLanguageService ActionLanguageService;
Remarks

This is ActionLanguageService, a member of class DefaultFrontsidePolicy.

See Also
DefaultFrontsidePolicy Class
Eco.Framework.Impl.Frontside Namespace


DefaultFrontsidePolicy.AutoSubscriptionService Property

DefaultFrontsidePolicy.AutoSubscriptionService Property
DefaultFrontsidePolicy Class Eco.Framework.Impl.Frontside Namespace See Also
Collapse All
C#
public IAutoSubscriptionService AutoSubscriptionService;
Remarks

This is AutoSubscriptionService, a member of class DefaultFrontsidePolicy.

See Also
DefaultFrontsidePolicy Class
Eco.Framework.Impl.Frontside Namespace


DefaultFrontsidePolicy.Cache Property

DefaultFrontsidePolicy.Cache Property
DefaultFrontsidePolicy Class Eco.Framework.Impl.Frontside Namespace See Also
Collapse All
C#
public ICache Cache;
Remarks

This is Cache, a member of class DefaultFrontsidePolicy.

See Also
DefaultFrontsidePolicy Class
Eco.Framework.Impl.Frontside Namespace


DefaultFrontsidePolicy.DerivedMemberManager Property

DefaultFrontsidePolicy.DerivedMemberManager Property
DefaultFrontsidePolicy Class Eco.Framework.Impl.Frontside Namespace See Also
Collapse All
C#
public IDerivedMemberManager DerivedMemberManager;
Remarks

This is DerivedMemberManager, a member of class DefaultFrontsidePolicy.

See Also
DefaultFrontsidePolicy Class
Eco.Framework.Impl.Frontside Namespace


DefaultFrontsidePolicy.EnforceStringLength Property

DefaultFrontsidePolicy.EnforceStringLength Property
DefaultFrontsidePolicy Class Eco.Framework.Impl.Frontside Namespace See Also
Collapse All
C#
public bool EnforceStringLength;
Remarks

This is EnforceStringLength, a member of class DefaultFrontsidePolicy.

See Also
DefaultFrontsidePolicy Class
Eco.Framework.Impl.Frontside Namespace


DefaultFrontsidePolicy.FetchStrategy Property

DefaultFrontsidePolicy.FetchStrategy Property
DefaultFrontsidePolicy Class Eco.Framework.Impl.Frontside Namespace See Also
Collapse All
C#
public FetchStrategy FetchStrategy;
Remarks

This is FetchStrategy, a member of class DefaultFrontsidePolicy.

See Also
DefaultFrontsidePolicy Class
Eco.Framework.Impl.Frontside Namespace


DefaultFrontsidePolicy.LocatorOwner Property

DefaultFrontsidePolicy.LocatorOwner Property
DefaultFrontsidePolicy Class Eco.Framework.Impl.Frontside Namespace See Also
Collapse All
C#
public object LocatorOwner;
Remarks

This is LocatorOwner, a member of class DefaultFrontsidePolicy.

See Also
DefaultFrontsidePolicy Class
Eco.Framework.Impl.Frontside Namespace


DefaultFrontsidePolicy.ObjectFactoryService Property

DefaultFrontsidePolicy.ObjectFactoryService Property
DefaultFrontsidePolicy Class Eco.Framework.Impl.Frontside Namespace See Also
Collapse All
C#
public IObjectFactoryService ObjectFactoryService;
Remarks

This is ObjectFactoryService, a member of class DefaultFrontsidePolicy.

See Also
DefaultFrontsidePolicy Class
Eco.Framework.Impl.Frontside Namespace


DefaultFrontsidePolicy.ObjectRepresentationProvider Property

DefaultFrontsidePolicy.ObjectRepresentationProvider Property
DefaultFrontsidePolicy Class Eco.Framework.Impl.Frontside Namespace See Also
Collapse All
C#
public IObjectRepresentationProvider ObjectRepresentationProvider;
Remarks

This is ObjectRepresentationProvider, a member of class DefaultFrontsidePolicy.

See Also
DefaultFrontsidePolicy Class
Eco.Framework.Impl.Frontside Namespace


DefaultFrontsidePolicy.OclService Property

DefaultFrontsidePolicy.OclService Property
DefaultFrontsidePolicy Class Eco.Framework.Impl.Frontside Namespace See Also
Collapse All
C#
public IOclService OclService;
Remarks

This is OclService, a member of class DefaultFrontsidePolicy.

See Also
DefaultFrontsidePolicy Class
Eco.Framework.Impl.Frontside Namespace


DefaultFrontsidePolicy.PersistenceHandler Property

DefaultFrontsidePolicy.PersistenceHandler Property
DefaultFrontsidePolicy Class Eco.Framework.Impl.Frontside Namespace See Also
Collapse All
C#
public IPersistenceHandler PersistenceHandler;
Remarks

This is PersistenceHandler, a member of class DefaultFrontsidePolicy.

See Also
DefaultFrontsidePolicy Class
Eco.Framework.Impl.Frontside Namespace


DefaultFrontsidePolicy.ServiceProvider Property

DefaultFrontsidePolicy.ServiceProvider Property
DefaultFrontsidePolicy Class Eco.Framework.Impl.Frontside Namespace See Also
Collapse All
C#
public IEcoServiceProvider ServiceProvider;
Remarks

This is ServiceProvider, a member of class DefaultFrontsidePolicy.

See Also
DefaultFrontsidePolicy Class
Eco.Framework.Impl.Frontside Namespace


DefaultFrontsidePolicy.TypeSystem Property

DefaultFrontsidePolicy.TypeSystem Property
DefaultFrontsidePolicy Class Eco.Framework.Impl.Frontside Namespace See Also
Collapse All
C#
public IEcoTypeSystem TypeSystem;
Remarks

This is TypeSystem, a member of class DefaultFrontsidePolicy.

See Also
DefaultFrontsidePolicy Class
Eco.Framework.Impl.Frontside Namespace


DefaultFrontsidePolicy.UndoService Property

DefaultFrontsidePolicy.UndoService Property
DefaultFrontsidePolicy Class Eco.Framework.Impl.Frontside Namespace See Also
Collapse All
C#
public IUndoService UndoService;
Remarks

This is UndoService, a member of class DefaultFrontsidePolicy.

See Also
DefaultFrontsidePolicy Class
Eco.Framework.Impl.Frontside Namespace


DefaultFrontsidePolicy.VariableFactory Property

DefaultFrontsidePolicy.VariableFactory Property
DefaultFrontsidePolicy Class Eco.Framework.Impl.Frontside Namespace See Also
Collapse All
C#
public IVariableFactoryService VariableFactory;
Remarks

This is VariableFactory, a member of class DefaultFrontsidePolicy.

See Also
DefaultFrontsidePolicy Class
Eco.Framework.Impl.Frontside Namespace


DefaultFrontsidePolicy Events

DefaultFrontsidePolicy Events
Public Events
Collapse All

The events of the DefaultFrontsidePolicy class are listed here.

Public Events
Name | Description
CreateFrontEndObject | Implement this event if you want to take control over how the actual object instances are created when a domain object is created via the object factory service
RecreateFrontEndObject | Implement this event if you want to take control over how the actual object instances are created when they are loaded from persistence


DefaultFrontsidePolicy.CreateFrontEndObject Event

DefaultFrontsidePolicy.CreateFrontEndObject Event
DefaultFrontsidePolicy Class Eco.Framework.Impl.Frontside Namespace See Also
Collapse All

Implement this event if you want to take control over how the actual object instances are created when a domain object is created via the object factory service

C#
public event CreateFrontEndObjectDelegate CreateFrontEndObject;
See Also
DefaultFrontsidePolicy Class
Eco.Framework.Impl.Frontside Namespace


DefaultFrontsidePolicy.RecreateFrontEndObject Event

DefaultFrontsidePolicy.RecreateFrontEndObject Event
DefaultFrontsidePolicy Class Eco.Framework.Impl.Frontside Namespace See Also
Collapse All

Implement this event if you want to take control over how the actual object instances are created when they are loaded from persistence

C#
public event RecreateFrontEndObjectDelegate RecreateFrontEndObject;
See Also
DefaultFrontsidePolicy Class
Eco.Framework.Impl.Frontside Namespace


DefaultLoopback Class

DefaultLoopback Class
Inheritance Hierarchy See Also
Collapse All
C#
public class DefaultLoopback : ILoopBack, INotifyPropertyChanged, IEcoObject, ICustomTypeDescriptor;
Remarks

This is class Eco.Framework.Impl.Frontside.DefaultLoopback.

Inheritance Hierarchy
Eco.Framework.Impl.Frontside.DefaultLoopback
File

FrontsidePolicy.cs

See Also
Inheritance Hierarchy


DefaultLoopback.DefaultLoopback Constructor

DefaultLoopback.DefaultLoopback Constructor
DefaultLoopback Class Eco.Framework.Impl.Frontside Namespace See Also
Collapse All
C#
public DefaultLoopback(
    IContent content
);
Remarks

This is DefaultLoopback, a member of class DefaultLoopback.

See Also
DefaultLoopback Class
Eco.Framework.Impl.Frontside Namespace


DefaultLoopback Methods

DefaultLoopback Methods
Public Methods
Collapse All

The methods of the DefaultLoopback class are listed here.

Public Methods
Name | Description
AsIObject | This is AsIObject, a member of class DefaultLoopback.
get_MemberByIndex | This is get_MemberByIndex, a member of class DefaultLoopback.
set_MemberByIndex | This is set_MemberByIndex, a member of class DefaultLoopback.


DefaultLoopback.AsIObject Method

DefaultLoopback.AsIObject Method
DefaultLoopback Class Eco.Framework.Impl.Frontside Namespace See Also
Collapse All
C#
public IObject AsIObject();
Remarks

This is AsIObject, a member of class DefaultLoopback.

See Also
DefaultLoopback Class
Eco.Framework.Impl.Frontside Namespace


DefaultLoopback.get_MemberByIndex Method

DefaultLoopback.get_MemberByIndex Method
DefaultLoopback Class Eco.Framework.Impl.Frontside Namespace See Also
Collapse All
C#
public object get_MemberByIndex(
    int index
);
Remarks

This is get_MemberByIndex, a member of class DefaultLoopback.

See Also
DefaultLoopback Class
Eco.Framework.Impl.Frontside Namespace


DefaultLoopback.set_MemberByIndex Method

DefaultLoopback.set_MemberByIndex Method
DefaultLoopback Class Eco.Framework.Impl.Frontside Namespace See Also
Collapse All
C#
public void set_MemberByIndex(
    int index,
    object value
);
Remarks

This is set_MemberByIndex, a member of class DefaultLoopback.

See Also
DefaultLoopback Class
Eco.Framework.Impl.Frontside Namespace


DerivedAttributeFrontsidePolicy Class

DerivedAttributeFrontsidePolicy Class
Inheritance Hierarchy See Also
Collapse All
C#
public class DerivedAttributeFrontsidePolicy : DerivedMemberFrontsidePolicy;
Remarks

This is class Eco.Framework.Impl.Frontside.DerivedAttributeFrontsidePolicy.

Inheritance Hierarchy
Eco.Framework.Impl.Frontside.MemberFrontsidePolicy
    Eco.Framework.Impl.Frontside.DerivedMemberFrontsidePolicy
        Eco.Framework.Impl.Frontside.DerivedAttributeFrontsidePolicy
File

DerivedMemberFrontsidePolicies.cs

See Also
Inheritance Hierarchy


DerivedAttributeFrontsidePolicy.DerivedAttributeFrontsidePolicy Constructor

DerivedAttributeFrontsidePolicy.DerivedAttributeFrontsidePolicy Constructor
DerivedAttributeFrontsidePolicy Class Eco.Framework.Impl.Frontside Namespace See Also
Collapse All
C#
public DerivedAttributeFrontsidePolicy(
    IAttribute feature,
    ClassFrontsidePolicy owner
);
Remarks

This is DerivedAttributeFrontsidePolicy, a member of class DerivedAttributeFrontsidePolicy.

See Also
DerivedAttributeFrontsidePolicy Class
Eco.Framework.Impl.Frontside Namespace


DerivedAttributeFrontsidePolicy Methods

DerivedAttributeFrontsidePolicy Methods
Public Methods
Collapse All

The methods of the DerivedAttributeFrontsidePolicy class are listed here.

Public Methods
Name | Description
GetPropertyAdapter | This is GetPropertyAdapter, a member of class DerivedAttributeFrontsidePolicy.


DerivedAttributeFrontsidePolicy.GetPropertyAdapter Method

DerivedAttributeFrontsidePolicy.GetPropertyAdapter Method
DerivedAttributeFrontsidePolicy Class Eco.Framework.Impl.Frontside Namespace See Also
Collapse All
C#
public override IProperty GetPropertyAdapter(
    DefaultFrontsideLocator locator
);
Remarks

This is GetPropertyAdapter, a member of class DerivedAttributeFrontsidePolicy.

See Also
DerivedAttributeFrontsidePolicy Class
Eco.Framework.Impl.Frontside Namespace


DerivedMemberFrontsidePolicy Class

DerivedMemberFrontsidePolicy Class
Inheritance Hierarchy See Also
Collapse All
C#
public abstract class DerivedMemberFrontsidePolicy : MemberFrontsidePolicy;
Remarks

This is class Eco.Framework.Impl.Frontside.DerivedMemberFrontsidePolicy.

Inheritance Hierarchy
Eco.Framework.Impl.Frontside.MemberFrontsidePolicy
    Eco.Framework.Impl.Frontside.DerivedMemberFrontsidePolicy
        Eco.Framework.Impl.Frontside.DerivedAttributeFrontsidePolicy
        Eco.Framework.Impl.Frontside.DerivedMultilinkFrontsidePolicy
        Eco.Framework.Impl.Frontside.DerivedSingleLinkFrontsidePolicy
File

DerivedMemberFrontsidePolicies.cs

See Also
Inheritance Hierarchy


DerivedMemberFrontsidePolicy.DerivedMemberFrontsidePolicy Constructor

DerivedMemberFrontsidePolicy.DerivedMemberFrontsidePolicy Constructor
DerivedMemberFrontsidePolicy Class Eco.Framework.Impl.Frontside Namespace See Also
Collapse All
C#
public DerivedMemberFrontsidePolicy(
    IStructuralFeature feature,
    ClassFrontsidePolicy owner
);
Remarks

This is DerivedMemberFrontsidePolicy, a member of class DerivedMemberFrontsidePolicy.

See Also
DerivedMemberFrontsidePolicy Class
Eco.Framework.Impl.Frontside Namespace


DerivedMemberFrontsidePolicy Methods

DerivedMemberFrontsidePolicy Methods
Public Methods
Collapse All

The methods of the DerivedMemberFrontsidePolicy class are listed here.

Public Methods
Name | Description
ApplyMemberValue | This is ApplyMemberValue, a member of class DerivedMemberFrontsidePolicy.
GetDerivedValue | This is GetDerivedValue, a member of class DerivedMemberFrontsidePolicy.
RetrieveMemberValue | This is RetrieveMemberValue, a member of class DerivedMemberFrontsidePolicy.


DerivedMemberFrontsidePolicy.ApplyMemberValue Method

DerivedMemberFrontsidePolicy.ApplyMemberValue Method
DerivedMemberFrontsidePolicy Class Eco.Framework.Impl.Frontside Namespace See Also
Collapse All
C#
public override void ApplyMemberValue(
    Locator locator,
    object value,
    bool CallerStateMachine
);
Remarks

This is ApplyMemberValue, a member of class DerivedMemberFrontsidePolicy.

See Also
DerivedMemberFrontsidePolicy Class
Eco.Framework.Impl.Frontside Namespace


DerivedMemberFrontsidePolicy.GetDerivedValue Method

DerivedMemberFrontsidePolicy.GetDerivedValue Method
DerivedMemberFrontsidePolicy Class Eco.Framework.Impl.Frontside Namespace See Also
Collapse All
C#
public object GetDerivedValue(
    Locator locator
);
Remarks

This is GetDerivedValue, a member of class DerivedMemberFrontsidePolicy.

See Also
DerivedMemberFrontsidePolicy Class
Eco.Framework.Impl.Frontside Namespace


DerivedMemberFrontsidePolicy.RetrieveMemberValue Method

DerivedMemberFrontsidePolicy.RetrieveMemberValue Method
DerivedMemberFrontsidePolicy Class Eco.Framework.Impl.Frontside Namespace See Also
Collapse All
C#
public override object RetrieveMemberValue(
    DefaultFrontsideLocator locator
);
Remarks

This is RetrieveMemberValue, a member of class DerivedMemberFrontsidePolicy.

See Also
DerivedMemberFrontsidePolicy Class
Eco.Framework.Impl.Frontside Namespace


DerivedMemberFrontsidePolicy Properties

DerivedMemberFrontsidePolicy Properties
Public Properties
Collapse All

The properties of the DerivedMemberFrontsidePolicy class are listed here.

Public Properties
Name | Description
Feature | This is Feature, a member of class DerivedMemberFrontsidePolicy.


DerivedMemberFrontsidePolicy.Feature Property

DerivedMemberFrontsidePolicy.Feature Property
DerivedMemberFrontsidePolicy Class Eco.Framework.Impl.Frontside Namespace See Also
Collapse All
C#
public override IStructuralFeature Feature;
Remarks

This is Feature, a member of class DerivedMemberFrontsidePolicy.

See Also
DerivedMemberFrontsidePolicy Class
Eco.Framework.Impl.Frontside Namespace


DerivedMultilinkFrontsidePolicy Class

DerivedMultilinkFrontsidePolicy Class
Inheritance Hierarchy See Also
Collapse All
C#
public class DerivedMultilinkFrontsidePolicy : DerivedMemberFrontsidePolicy;
Remarks

This is class Eco.Framework.Impl.Frontside.DerivedMultilinkFrontsidePolicy.

Inheritance Hierarchy
Eco.Framework.Impl.Frontside.MemberFrontsidePolicy
    Eco.Framework.Impl.Frontside.DerivedMemberFrontsidePolicy
        Eco.Framework.Impl.Frontside.DerivedMultilinkFrontsidePolicy
File

DerivedMemberFrontsidePolicies.cs

See Also
Inheritance Hierarchy


DerivedMultilinkFrontsidePolicy.DerivedMultilinkFrontsidePolicy Constructor

DerivedMultilinkFrontsidePolicy.DerivedMultilinkFrontsidePolicy Constructor
DerivedMultilinkFrontsidePolicy Class Eco.Framework.Impl.Frontside Namespace See Also
Collapse All
C#
public DerivedMultilinkFrontsidePolicy(
    IAssociationEnd assocEnd,
    ClassFrontsidePolicy owner
);
Remarks

This is DerivedMultilinkFrontsidePolicy, a member of class DerivedMultilinkFrontsidePolicy.

See Also
DerivedMultilinkFrontsidePolicy Class
Eco.Framework.Impl.Frontside Namespace


DerivedMultilinkFrontsidePolicy Methods

DerivedMultilinkFrontsidePolicy Methods
Public Methods
Collapse All

The methods of the DerivedMultilinkFrontsidePolicy class are listed here.

Public Methods
Name | Description
GetFactory | This is GetFactory, a member of class DerivedMultilinkFrontsidePolicy.
GetPropertyAdapter | This is GetPropertyAdapter, a member of class DerivedMultilinkFrontsidePolicy.
RetrieveMemberValue | This is RetrieveMemberValue, a member of class DerivedMultilinkFrontsidePolicy.


DerivedMultilinkFrontsidePolicy.GetFactory Method

DerivedMultilinkFrontsidePolicy.GetFactory Method
DerivedMultilinkFrontsidePolicy Class Eco.Framework.Impl.Frontside Namespace See Also
Collapse All
C#
public IFrontsideDerivedAdapterFactory GetFactory();
Remarks

This is GetFactory, a member of class DerivedMultilinkFrontsidePolicy.

See Also
DerivedMultilinkFrontsidePolicy Class
Eco.Framework.Impl.Frontside Namespace


DerivedMultilinkFrontsidePolicy.GetPropertyAdapter Method

DerivedMultilinkFrontsidePolicy.GetPropertyAdapter Method
DerivedMultilinkFrontsidePolicy Class Eco.Framework.Impl.Frontside Namespace See Also
Collapse All
C#
public override IProperty GetPropertyAdapter(
    DefaultFrontsideLocator locator
);
Remarks

This is GetPropertyAdapter, a member of class DerivedMultilinkFrontsidePolicy.

See Also
DerivedMultilinkFrontsidePolicy Class
Eco.Framework.Impl.Frontside Namespace


DerivedMultilinkFrontsidePolicy.RetrieveMemberValue Method

DerivedMultilinkFrontsidePolicy.RetrieveMemberValue Method
DerivedMultilinkFrontsidePolicy Class Eco.Framework.Impl.Frontside Namespace See Also
Collapse All
C#
public override object RetrieveMemberValue(
    DefaultFrontsideLocator locator
);
Remarks

This is RetrieveMemberValue, a member of class DerivedMultilinkFrontsidePolicy.

See Also
DerivedMultilinkFrontsidePolicy Class
Eco.Framework.Impl.Frontside Namespace


DerivedMultilinkFrontsidePolicy Properties

DerivedMultilinkFrontsidePolicy Properties
Public Properties
Collapse All

The properties of the DerivedMultilinkFrontsidePolicy class are listed here.

Public Properties
Name | Description
AssociationEnd | This is AssociationEnd, a member of class DerivedMultilinkFrontsidePolicy.


DerivedMultilinkFrontsidePolicy.AssociationEnd Property

DerivedMultilinkFrontsidePolicy.AssociationEnd Property
DerivedMultilinkFrontsidePolicy Class Eco.Framework.Impl.Frontside Namespace See Also
Collapse All
C#
public IAssociationEnd AssociationEnd;
Remarks

This is AssociationEnd, a member of class DerivedMultilinkFrontsidePolicy.

See Also
DerivedMultilinkFrontsidePolicy Class
Eco.Framework.Impl.Frontside Namespace


DerivedSingleLinkFrontsidePolicy Class

DerivedSingleLinkFrontsidePolicy Class
Inheritance Hierarchy See Also
Collapse All
C#
public class DerivedSingleLinkFrontsidePolicy : DerivedMemberFrontsidePolicy;
Remarks

This is class Eco.Framework.Impl.Frontside.DerivedSingleLinkFrontsidePolicy.

Inheritance Hierarchy
Eco.Framework.Impl.Frontside.MemberFrontsidePolicy
    Eco.Framework.Impl.Frontside.DerivedMemberFrontsidePolicy
        Eco.Framework.Impl.Frontside.DerivedSingleLinkFrontsidePolicy
File

DerivedMemberFrontsidePolicies.cs

See Also
Inheritance Hierarchy


DerivedSingleLinkFrontsidePolicy.DerivedSingleLinkFrontsidePolicy Constructor

DerivedSingleLinkFrontsidePolicy.DerivedSingleLinkFrontsidePolicy Constructor
DerivedSingleLinkFrontsidePolicy Class Eco.Framework.Impl.Frontside Namespace See Also
Collapse All
C#
public DerivedSingleLinkFrontsidePolicy(
    IAssociationEnd feature,
    ClassFrontsidePolicy owner
);
Remarks

This is DerivedSingleLinkFrontsidePolicy, a member of class DerivedSingleLinkFrontsidePolicy.

See Also
DerivedSingleLinkFrontsidePolicy Class
Eco.Framework.Impl.Frontside Namespace


DerivedSingleLinkFrontsidePolicy Methods

DerivedSingleLinkFrontsidePolicy Methods
Public Methods
Collapse All

The methods of the DerivedSingleLinkFrontsidePolicy class are listed here.

Public Methods
Name | Description
GetPropertyAdapter | This is GetPropertyAdapter, a member of class DerivedSingleLinkFrontsidePolicy.


DerivedSingleLinkFrontsidePolicy.GetPropertyAdapter Method

DerivedSingleLinkFrontsidePolicy.GetPropertyAdapter Method
DerivedSingleLinkFrontsidePolicy Class Eco.Framework.Impl.Frontside Namespace See Also
Collapse All
C#
public override IProperty GetPropertyAdapter(
    DefaultFrontsideLocator locator
);
Remarks

This is GetPropertyAdapter, a member of class DerivedSingleLinkFrontsidePolicy.

See Also
DerivedSingleLinkFrontsidePolicy Class
Eco.Framework.Impl.Frontside Namespace


DirectMultiFrontsidePolicy Class

DirectMultiFrontsidePolicy Class
Inheritance Hierarchy See Also
Collapse All
C#
public class DirectMultiFrontsidePolicy : MultAssociationEndFrontsidePolicy;
Remarks

This is class Eco.Framework.Impl.Frontside.DirectMultiFrontsidePolicy.

Inheritance Hierarchy
Eco.Framework.Impl.Frontside.MemberFrontsidePolicy
    Eco.Framework.Impl.Frontside.AssociationEndFrontsidePolicy
        Eco.Framework.Impl.Frontside.MultAssociationEndFrontsidePolicy
            Eco.Framework.Impl.Frontside.DirectMultiFrontsidePolicy
File

MultiAssociationEndFrontsidePolicies.cs

See Also
Inheritance Hierarchy


DirectMultiFrontsidePolicy.DirectMultiFrontsidePolicy Constructor

DirectMultiFrontsidePolicy.DirectMultiFrontsidePolicy Constructor
DirectMultiFrontsidePolicy Class Eco.Framework.Impl.Frontside Namespace See Also
Collapse All
C#
public DirectMultiFrontsidePolicy(
    IAssociationEnd assocEnd,
    ClassFrontsidePolicy owner
);
Remarks

This is DirectMultiFrontsidePolicy, a member of class DirectMultiFrontsidePolicy.

See Also
DirectMultiFrontsidePolicy Class
Eco.Framework.Impl.Frontside Namespace


DirectMultiFrontsidePolicy Methods

DirectMultiFrontsidePolicy Methods
Public Methods
Collapse All

The methods of the DirectMultiFrontsidePolicy class are listed here.

Public Methods
Name | Description
Add | This is Add, a member of class DirectMultiFrontsidePolicy.
Clear | This is Clear, a member of class DirectMultiFrontsidePolicy.
Insert | This is Insert, a member of class DirectMultiFrontsidePolicy.
Remove | This is Remove, a member of class DirectMultiFrontsidePolicy.
RemoveAt | This is RemoveAt, a member of class DirectMultiFrontsidePolicy.
SetItem | This is SetItem, a member of class DirectMultiFrontsidePolicy.


DirectMultiFrontsidePolicy.Add Method

DirectMultiFrontsidePolicy.Add Method
DirectMultiFrontsidePolicy Class Eco.Framework.Impl.Frontside Namespace See Also
Collapse All
C#
public override int Add(
    Locator locator,
    object value
);
Remarks

This is Add, a member of class DirectMultiFrontsidePolicy.

See Also
DirectMultiFrontsidePolicy Class
Eco.Framework.Impl.Frontside Namespace


DirectMultiFrontsidePolicy.Clear Method

DirectMultiFrontsidePolicy.Clear Method
DirectMultiFrontsidePolicy Class Eco.Framework.Impl.Frontside Namespace See Also
Collapse All
C#
public override void Clear(
    Locator locator
);
Remarks

This is Clear, a member of class DirectMultiFrontsidePolicy.

See Also
DirectMultiFrontsidePolicy Class
Eco.Framework.Impl.Frontside Namespace


DirectMultiFrontsidePolicy.Insert Method

DirectMultiFrontsidePolicy.Insert Method
DirectMultiFrontsidePolicy Class Eco.Framework.Impl.Frontside Namespace See Also
Collapse All
C#
public override void Insert(
    Locator locator,
    int index,
    object value
);
Remarks

This is Insert, a member of class DirectMultiFrontsidePolicy.

See Also
DirectMultiFrontsidePolicy Class
Eco.Framework.Impl.Frontside Namespace


DirectMultiFrontsidePolicy.Remove Method

DirectMultiFrontsidePolicy.Remove Method
DirectMultiFrontsidePolicy Class Eco.Framework.Impl.Frontside Namespace See Also
Collapse All
C#
public override void Remove(
    Locator locator,
    object value
);
Remarks

This is Remove, a member of class DirectMultiFrontsidePolicy.

See Also
DirectMultiFrontsidePolicy Class
Eco.Framework.Impl.Frontside Namespace


DirectMultiFrontsidePolicy.RemoveAt Method

DirectMultiFrontsidePolicy.RemoveAt Method
DirectMultiFrontsidePolicy Class Eco.Framework.Impl.Frontside Namespace See Also
Collapse All
C#
public override void RemoveAt(
    Locator locator,
    int index
);
Remarks

This is RemoveAt, a member of class DirectMultiFrontsidePolicy.

See Also
DirectMultiFrontsidePolicy Class
Eco.Framework.Impl.Frontside Namespace


DirectMultiFrontsidePolicy.SetItem Method

DirectMultiFrontsidePolicy.SetItem Method
DirectMultiFrontsidePolicy Class Eco.Framework.Impl.Frontside Namespace See Also
Collapse All
C#
public override void SetItem(
    Locator locator,
    int index,
    object value
);
Remarks

This is SetItem, a member of class DirectMultiFrontsidePolicy.

See Also
DirectMultiFrontsidePolicy Class
Eco.Framework.Impl.Frontside Namespace


DirectSingleMultiFrontsidePolicy Class

DirectSingleMultiFrontsidePolicy Class
Inheritance Hierarchy See Also
Collapse All
C#
public class DirectSingleMultiFrontsidePolicy : SingleAssociationEndFrontsidePolicy;
Remarks

DirectSingleMultiFrontsidePolicy

Inheritance Hierarchy
Eco.Framework.Impl.Frontside.MemberFrontsidePolicy
    Eco.Framework.Impl.Frontside.AssociationEndFrontsidePolicy
        Eco.Framework.Impl.Frontside.SingleAssociationEndFrontsidePolicy
            Eco.Framework.Impl.Frontside.DirectSingleMultiFrontsidePolicy
File

SingleAssociationEndFrontsidePolicies.cs

See Also
Inheritance Hierarchy


DirectSingleMultiFrontsidePolicy.DirectSingleMultiFrontsidePolicy Constructor

DirectSingleMultiFrontsidePolicy.DirectSingleMultiFrontsidePolicy Constructor
DirectSingleMultiFrontsidePolicy Class Eco.Framework.Impl.Frontside Namespace See Also
Collapse All
C#
public DirectSingleMultiFrontsidePolicy(
    IAssociationEnd assocEnd,
    ClassFrontsidePolicy owner
);
Remarks

This is DirectSingleMultiFrontsidePolicy, a member of class DirectSingleMultiFrontsidePolicy.

See Also
DirectSingleMultiFrontsidePolicy Class
Eco.Framework.Impl.Frontside Namespace


DirectSingleMultiFrontsidePolicy Methods

DirectSingleMultiFrontsidePolicy Methods
Public Methods
Collapse All

The methods of the DirectSingleMultiFrontsidePolicy class are listed here.

Public Methods
Name | Description
ApplyMemberValue | This is ApplyMemberValue, a member of class DirectSingleMultiFrontsidePolicy.


DirectSingleMultiFrontsidePolicy.ApplyMemberValue Method

DirectSingleMultiFrontsidePolicy.ApplyMemberValue Method
DirectSingleMultiFrontsidePolicy Class Eco.Framework.Impl.Frontside Namespace See Also
Collapse All
C#
public override void ApplyMemberValue(
    Locator locator,
    object value,
    bool CallerStateMachine
);
Remarks

This is ApplyMemberValue, a member of class DirectSingleMultiFrontsidePolicy.

See Also
DirectSingleMultiFrontsidePolicy Class
Eco.Framework.Impl.Frontside Namespace


DirectSingleSingleEmbeddedFrontsidePolicy Class

DirectSingleSingleEmbeddedFrontsidePolicy Class
Inheritance Hierarchy See Also
Collapse All
C#
public class DirectSingleSingleEmbeddedFrontsidePolicy : SingleAssociationEndFrontsidePolicy;
Remarks

This is class Eco.Framework.Impl.Frontside.DirectSingleSingleEmbeddedFrontsidePolicy.

Inheritance Hierarchy
Eco.Framework.Impl.Frontside.MemberFrontsidePolicy
    Eco.Framework.Impl.Frontside.AssociationEndFrontsidePolicy
        Eco.Framework.Impl.Frontside.SingleAssociationEndFrontsidePolicy
            Eco.Framework.Impl.Frontside.DirectSingleSingleEmbeddedFrontsidePolicy
File

SingleAssociationEndFrontsidePolicies.cs

See Also
Inheritance Hierarchy


DirectSingleSingleEmbeddedFrontsidePolicy.DirectSingleSingleEmbeddedFrontsidePolicy Constructor

DirectSingleSingleEmbeddedFrontsidePolicy.DirectSingleSingleEmbeddedFrontsidePolicy Constructor
DirectSingleSingleEmbeddedFrontsidePolicy Class Eco.Framework.Impl.Frontside Namespace See Also
Collapse All
C#
public DirectSingleSingleEmbeddedFrontsidePolicy(
    IAssociationEnd assocEnd,
    ClassFrontsidePolicy owner
);
Remarks

This is DirectSingleSingleEmbeddedFrontsidePolicy, a member of class DirectSingleSingleEmbeddedFrontsidePolicy.

See Also
DirectSingleSingleEmbeddedFrontsidePolicy Class
Eco.Framework.Impl.Frontside Namespace


DirectSingleSingleEmbeddedFrontsidePolicy Methods

DirectSingleSingleEmbeddedFrontsidePolicy Methods
Public Methods
Collapse All

The methods of the DirectSingleSingleEmbeddedFrontsidePolicy class are listed here.

Public Methods
Name | Description
ApplyMemberValue | This is ApplyMemberValue, a member of class DirectSingleSingleEmbeddedFrontsidePolicy.


DirectSingleSingleEmbeddedFrontsidePolicy.ApplyMemberValue Method

DirectSingleSingleEmbeddedFrontsidePolicy.ApplyMemberValue Method
DirectSingleSingleEmbeddedFrontsidePolicy Class Eco.Framework.Impl.Frontside Namespace See Also
Collapse All
C#
public override void ApplyMemberValue(
    Locator locator,
    object value,
    bool CallerStateMachine
);
Remarks

This is ApplyMemberValue, a member of class DirectSingleSingleEmbeddedFrontsidePolicy.

See Also
DirectSingleSingleEmbeddedFrontsidePolicy Class
Eco.Framework.Impl.Frontside Namespace


DirectSingleSingleNonembeddedFrontsidePolicy Class

DirectSingleSingleNonembeddedFrontsidePolicy Class
Inheritance Hierarchy See Also
Collapse All
C#
public class DirectSingleSingleNonembeddedFrontsidePolicy : SingleAssociationEndFrontsidePolicy;
Remarks

This is class Eco.Framework.Impl.Frontside.DirectSingleSingleNonembeddedFrontsidePolicy.

Inheritance Hierarchy
Eco.Framework.Impl.Frontside.MemberFrontsidePolicy
    Eco.Framework.Impl.Frontside.AssociationEndFrontsidePolicy
        Eco.Framework.Impl.Frontside.SingleAssociationEndFrontsidePolicy
            Eco.Framework.Impl.Frontside.DirectSingleSingleNonembeddedFrontsidePolicy
File

SingleAssociationEndFrontsidePolicies.cs

See Also
Inheritance Hierarchy


DirectSingleSingleNonembeddedFrontsidePolicy.DirectSingleSingleNonembeddedFrontsidePolicy Constructor

DirectSingleSingleNonembeddedFrontsidePolicy.DirectSingleSingleNonembeddedFrontsidePolicy Constructor
DirectSingleSingleNonembeddedFrontsidePolicy Class Eco.Framework.Impl.Frontside Namespace See Also
Collapse All
C#
public DirectSingleSingleNonembeddedFrontsidePolicy(
    IAssociationEnd assocEnd,
    ClassFrontsidePolicy owner
);
Remarks

This is DirectSingleSingleNonembeddedFrontsidePolicy, a member of class DirectSingleSingleNonembeddedFrontsidePolicy.

See Also
DirectSingleSingleNonembeddedFrontsidePolicy Class
Eco.Framework.Impl.Frontside Namespace


DirectSingleSingleNonembeddedFrontsidePolicy Methods

DirectSingleSingleNonembeddedFrontsidePolicy Methods
Public Methods
Collapse All

The methods of the DirectSingleSingleNonembeddedFrontsidePolicy class are listed here.

Public Methods
Name | Description
ApplyMemberValue | This is ApplyMemberValue, a member of class DirectSingleSingleNonembeddedFrontsidePolicy.


DirectSingleSingleNonembeddedFrontsidePolicy.ApplyMemberValue Method

DirectSingleSingleNonembeddedFrontsidePolicy.ApplyMemberValue Method
DirectSingleSingleNonembeddedFrontsidePolicy Class Eco.Framework.Impl.Frontside Namespace See Also
Collapse All
C#
public override void ApplyMemberValue(
    Locator locator,
    object value,
    bool CallerStateMachine
);
Remarks

This is ApplyMemberValue, a member of class DirectSingleSingleNonembeddedFrontsidePolicy.

See Also
DirectSingleSingleNonembeddedFrontsidePolicy Class
Eco.Framework.Impl.Frontside Namespace


FrontSideAdapterFactory Class

FrontSideAdapterFactory Class
Inheritance Hierarchy See Also
Collapse All
C#
public class FrontSideAdapterFactory<T> : IFrontsideAdapterFactory where T : class, IEcoObject;
Remarks

This is class Eco.Framework.Impl.Frontside.FrontSideAdapterFactory.

Inheritance Hierarchy
Eco.Framework.Impl.Frontside.IFrontsideAdapterFactory
    Eco.Framework.Impl.Frontside.FrontSideAdapterFactory
File

FrontsideMultilinkAdapters.cs

See Also
Inheritance Hierarchy


FrontSideAdapterFactory Methods

FrontSideAdapterFactory Methods
Public Methods
Collapse All

The methods of the FrontSideAdapterFactory class are listed here.

Public Methods
Name | Description
Make | This is Make, a member of class FrontSideAdapterFactory.


FrontSideAdapterFactory.Make Method

FrontSideAdapterFactory.Make Method
FrontSideAdapterFactory Class Eco.Framework.Impl.Frontside Namespace See Also
Collapse All
C#
public object Make(
    DefaultFrontsideLocator locator,
    MultAssociationEndFrontsidePolicy policy
);
Remarks

This is Make, a member of class FrontSideAdapterFactory.

See Also
FrontSideAdapterFactory Class
Eco.Framework.Impl.Frontside Namespace


FrontSideDerivedAdapterFactory Class

FrontSideDerivedAdapterFactory Class
Inheritance Hierarchy See Also
Collapse All
C#
public class FrontSideDerivedAdapterFactory<T> : IFrontsideDerivedAdapterFactory where T : class, IEcoObject;
Remarks

This is class Eco.Framework.Impl.Frontside.FrontSideDerivedAdapterFactory.

Inheritance Hierarchy
Eco.Framework.Impl.Frontside.IFrontsideDerivedAdapterFactory
    Eco.Framework.Impl.Frontside.FrontSideDerivedAdapterFactory
File

FrontsideMultilinkAdapters.cs

See Also
Inheritance Hierarchy


FrontSideDerivedAdapterFactory Methods

FrontSideDerivedAdapterFactory Methods
Public Methods
Collapse All

The methods of the FrontSideDerivedAdapterFactory class are listed here.

Public Methods
Name | Description
Make | This is Make, a member of class FrontSideDerivedAdapterFactory.


FrontSideDerivedAdapterFactory.Make Method

FrontSideDerivedAdapterFactory.Make Method
FrontSideDerivedAdapterFactory Class Eco.Framework.Impl.Frontside Namespace See Also
Collapse All
C#
public object Make(
    DefaultFrontsideLocator locator,
    DerivedMemberFrontsidePolicy policy
);
Remarks

This is Make, a member of class FrontSideDerivedAdapterFactory.

See Also
FrontSideDerivedAdapterFactory Class
Eco.Framework.Impl.Frontside Namespace


FrontsideDerivedMultilinkAdapter Class

FrontsideDerivedMultilinkAdapter Class
Inheritance Hierarchy See Also
Collapse All
C#
public class FrontsideDerivedMultilinkAdapter<T> : IList<T>, ICollection<T>, IEcoList<T>, IObjectListProvider, IBindingList where T : class, IEcoObject;
Remarks

This is class Eco.Framework.Impl.Frontside.FrontsideDerivedMultilinkAdapter.

Inheritance Hierarchy
Eco.Framework.Impl.Frontside.FrontsideDerivedMultilinkAdapter
File

FrontsideMultilinkAdapters.cs

See Also
Inheritance Hierarchy


FrontsideDerivedMultilinkAdapter.FrontsideDerivedMultilinkAdapter Constructor

FrontsideDerivedMultilinkAdapter.FrontsideDerivedMultilinkAdapter Constructor
FrontsideDerivedMultilinkAdapter Class Eco.Framework.Impl.Frontside Namespace See Also
Collapse All
C#
public FrontsideDerivedMultilinkAdapter(
    DefaultFrontsideLocator locator,
    DerivedMemberFrontsidePolicy policy
);
Remarks

This is FrontsideDerivedMultilinkAdapter, a member of class FrontsideDerivedMultilinkAdapter.

See Also
FrontsideDerivedMultilinkAdapter Class
Eco.Framework.Impl.Frontside Namespace


FrontsideDerivedMultilinkAdapter Methods

FrontsideDerivedMultilinkAdapter Methods
Public Methods
Collapse All

The methods of the FrontsideDerivedMultilinkAdapter class are listed here.

Public Methods
Name | Description
Add | This is the overview for the Add method overload.
Clear | This is Clear, a member of class FrontsideDerivedMultilinkAdapter.
Contains | This is the overview for the Contains method overload.
CopyTo | This is the overview for the CopyTo method overload.
GetEnumerator | This is GetEnumerator, a member of class FrontsideDerivedMultilinkAdapter.
IndexOf | This is the overview for the IndexOf method overload.
Insert | This is the overview for the Insert method overload.
Remove | This is the overview for the Remove method overload.
RemoveAt | This is RemoveAt, a member of class FrontsideDerivedMultilinkAdapter.
this | This is this, a member of class FrontsideDerivedMultilinkAdapter.


Add Method

Add Method

This is the overview for the Add method overload.

Overload List
Name | Description
FrontsideDerivedMultilinkAdapter.Add (object) | This is Add, a member of class FrontsideDerivedMultilinkAdapter.
FrontsideDerivedMultilinkAdapter.Add (T) | This is Add, a member of class FrontsideDerivedMultilinkAdapter.


FrontsideDerivedMultilinkAdapter.Add Method (T)

FrontsideDerivedMultilinkAdapter.Add Method (T)
FrontsideDerivedMultilinkAdapter Class Eco.Framework.Impl.Frontside Namespace See Also
Collapse All
C#
public void Add(
    T value
);
Remarks

This is Add, a member of class FrontsideDerivedMultilinkAdapter.

See Also
FrontsideDerivedMultilinkAdapter Class
Eco.Framework.Impl.Frontside Namespace


FrontsideDerivedMultilinkAdapter.Add Method (object)

FrontsideDerivedMultilinkAdapter.Add Method (object)
FrontsideDerivedMultilinkAdapter Class Eco.Framework.Impl.Frontside Namespace See Also
Collapse All
C#
public int Add(
    object value
);
Remarks

This is Add, a member of class FrontsideDerivedMultilinkAdapter.

See Also
FrontsideDerivedMultilinkAdapter Class
Eco.Framework.Impl.Frontside Namespace


FrontsideDerivedMultilinkAdapter.Clear Method

FrontsideDerivedMultilinkAdapter.Clear Method
FrontsideDerivedMultilinkAdapter Class Eco.Framework.Impl.Frontside Namespace See Also
Collapse All
C#
public void Clear();
Remarks

This is Clear, a member of class FrontsideDerivedMultilinkAdapter.

See Also
FrontsideDerivedMultilinkAdapter Class
Eco.Framework.Impl.Frontside Namespace


Contains Method

Contains Method

This is the overview for the Contains method overload.

Overload List
Name | Description
FrontsideDerivedMultilinkAdapter.Contains (object) | This is Contains, a member of class FrontsideDerivedMultilinkAdapter.
FrontsideDerivedMultilinkAdapter.Contains (T) | This is Contains, a member of class FrontsideDerivedMultilinkAdapter.


FrontsideDerivedMultilinkAdapter.Contains Method (T)

FrontsideDerivedMultilinkAdapter.Contains Method (T)
FrontsideDerivedMultilinkAdapter Class Eco.Framework.Impl.Frontside Namespace See Also
Collapse All
C#
public bool Contains(
    T value
);
Remarks

This is Contains, a member of class FrontsideDerivedMultilinkAdapter.

See Also
FrontsideDerivedMultilinkAdapter Class
Eco.Framework.Impl.Frontside Namespace


FrontsideDerivedMultilinkAdapter.Contains Method (object)

FrontsideDerivedMultilinkAdapter.Contains Method (object)
FrontsideDerivedMultilinkAdapter Class Eco.Framework.Impl.Frontside Namespace See Also
Collapse All
C#
public bool Contains(
    object value
);
Remarks

This is Contains, a member of class FrontsideDerivedMultilinkAdapter.

See Also
FrontsideDerivedMultilinkAdapter Class
Eco.Framework.Impl.Frontside Namespace


CopyTo Method

CopyTo Method

This is the overview for the CopyTo method overload.

Overload List
Name | Description
FrontsideDerivedMultilinkAdapter.CopyTo (System.Array, int) | This is CopyTo, a member of class FrontsideDerivedMultilinkAdapter.
FrontsideDerivedMultilinkAdapter.CopyTo (T[], int) | This is CopyTo, a member of class FrontsideDerivedMultilinkAdapter.


FrontsideDerivedMultilinkAdapter.CopyTo Method (System.Array, int)

FrontsideDerivedMultilinkAdapter.CopyTo Method (System.Array, int)
FrontsideDerivedMultilinkAdapter Class Eco.Framework.Impl.Frontside Namespace See Also
Collapse All
C#
public void CopyTo(
    System.Array arr,
    int index
);
Remarks

This is CopyTo, a member of class FrontsideDerivedMultilinkAdapter.

See Also
FrontsideDerivedMultilinkAdapter Class
Eco.Framework.Impl.Frontside Namespace


FrontsideDerivedMultilinkAdapter.CopyTo Method (T[], int)

FrontsideDerivedMultilinkAdapter.CopyTo Method (T[], int)
FrontsideDerivedMultilinkAdapter Class Eco.Framework.Impl.Frontside Namespace See Also
Collapse All
C#
public void CopyTo(
    T[] arr,
    int index
);
Remarks

This is CopyTo, a member of class FrontsideDerivedMultilinkAdapter.

See Also
FrontsideDerivedMultilinkAdapter Class
Eco.Framework.Impl.Frontside Namespace


FrontsideDerivedMultilinkAdapter.GetEnumerator Method

FrontsideDerivedMultilinkAdapter.GetEnumerator Method
FrontsideDerivedMultilinkAdapter Class Eco.Framework.Impl.Frontside Namespace See Also
Collapse All
C#
public IEnumerator<T> GetEnumerator();
Remarks

This is GetEnumerator, a member of class FrontsideDerivedMultilinkAdapter.

See Also
FrontsideDerivedMultilinkAdapter Class
Eco.Framework.Impl.Frontside Namespace


IndexOf Method

IndexOf Method

This is the overview for the IndexOf method overload.

Overload List
Name | Description
FrontsideDerivedMultilinkAdapter.IndexOf (object) | This is IndexOf, a member of class FrontsideDerivedMultilinkAdapter.
FrontsideDerivedMultilinkAdapter.IndexOf (T) | This is IndexOf, a member of class FrontsideDerivedMultilinkAdapter.


FrontsideDerivedMultilinkAdapter.IndexOf Method (T)

FrontsideDerivedMultilinkAdapter.IndexOf Method (T)
FrontsideDerivedMultilinkAdapter Class Eco.Framework.Impl.Frontside Namespace See Also
Collapse All
C#
public int IndexOf(
    T value
);
Remarks

This is IndexOf, a member of class FrontsideDerivedMultilinkAdapter.

See Also
FrontsideDerivedMultilinkAdapter Class
Eco.Framework.Impl.Frontside Namespace


FrontsideDerivedMultilinkAdapter.IndexOf Method (object)

FrontsideDerivedMultilinkAdapter.IndexOf Method (object)
FrontsideDerivedMultilinkAdapter Class Eco.Framework.Impl.Frontside Namespace See Also
Collapse All
C#
public int IndexOf(
    object value
);
Remarks

This is IndexOf, a member of class FrontsideDerivedMultilinkAdapter.

See Also
FrontsideDerivedMultilinkAdapter Class
Eco.Framework.Impl.Frontside Namespace


Insert Method

Insert Method

This is the overview for the Insert method overload.

Overload List
Name | Description
FrontsideDerivedMultilinkAdapter.Insert (int, object) | This is Insert, a member of class FrontsideDerivedMultilinkAdapter.
FrontsideDerivedMultilinkAdapter.Insert (int, T) | This is Insert, a member of class FrontsideDerivedMultilinkAdapter.


FrontsideDerivedMultilinkAdapter.Insert Method (int, T)

FrontsideDerivedMultilinkAdapter.Insert Method (int, T)
FrontsideDerivedMultilinkAdapter Class Eco.Framework.Impl.Frontside Namespace See Also
Collapse All
C#
public void Insert(
    int index,
    T value
);
Remarks

This is Insert, a member of class FrontsideDerivedMultilinkAdapter.

See Also
FrontsideDerivedMultilinkAdapter Class
Eco.Framework.Impl.Frontside Namespace


FrontsideDerivedMultilinkAdapter.Insert Method (int, object)

FrontsideDerivedMultilinkAdapter.Insert Method (int, object)
FrontsideDerivedMultilinkAdapter Class Eco.Framework.Impl.Frontside Namespace See Also
Collapse All
C#
public void Insert(
    int index,
    object value
);
Remarks

This is Insert, a member of class FrontsideDerivedMultilinkAdapter.

See Also
FrontsideDerivedMultilinkAdapter Class
Eco.Framework.Impl.Frontside Namespace


Remove Method

Remove Method

This is the overview for the Remove method overload.

Overload List
Name | Description
FrontsideDerivedMultilinkAdapter.Remove (object) | This is Remove, a member of class FrontsideDerivedMultilinkAdapter.
FrontsideDerivedMultilinkAdapter.Remove (T) | This is Remove, a member of class FrontsideDerivedMultilinkAdapter.


FrontsideDerivedMultilinkAdapter.Remove Method (T)

FrontsideDerivedMultilinkAdapter.Remove Method (T)
FrontsideDerivedMultilinkAdapter Class Eco.Framework.Impl.Frontside Namespace See Also
Collapse All
C#
public bool Remove(
    T value
);
Remarks

This is Remove, a member of class FrontsideDerivedMultilinkAdapter.

See Also
FrontsideDerivedMultilinkAdapter Class
Eco.Framework.Impl.Frontside Namespace


FrontsideDerivedMultilinkAdapter.Remove Method (object)

FrontsideDerivedMultilinkAdapter.Remove Method (object)
FrontsideDerivedMultilinkAdapter Class Eco.Framework.Impl.Frontside Namespace See Also
Collapse All
C#
public void Remove(
    object value
);
Remarks

This is Remove, a member of class FrontsideDerivedMultilinkAdapter.

See Also
FrontsideDerivedMultilinkAdapter Class
Eco.Framework.Impl.Frontside Namespace


FrontsideDerivedMultilinkAdapter.RemoveAt Method

FrontsideDerivedMultilinkAdapter.RemoveAt Method
FrontsideDerivedMultilinkAdapter Class Eco.Framework.Impl.Frontside Namespace See Also
Collapse All
C#
public void RemoveAt(
    int index
);
Remarks

This is RemoveAt, a member of class FrontsideDerivedMultilinkAdapter.

See Also
FrontsideDerivedMultilinkAdapter Class
Eco.Framework.Impl.Frontside Namespace


FrontsideDerivedMultilinkAdapter.this Indexer

FrontsideDerivedMultilinkAdapter.this Indexer
FrontsideDerivedMultilinkAdapter Class Eco.Framework.Impl.Frontside Namespace See Also
Collapse All
C#
public T this[
    int index
];
Remarks

This is this, a member of class FrontsideDerivedMultilinkAdapter.

See Also
FrontsideDerivedMultilinkAdapter Class
Eco.Framework.Impl.Frontside Namespace


FrontsideDerivedMultilinkAdapter Properties

FrontsideDerivedMultilinkAdapter Properties
Public Properties
Collapse All

The properties of the FrontsideDerivedMultilinkAdapter class are listed here.

Public Properties
Name | Description
AllowNew | This is AllowNew, a member of class FrontsideDerivedMultilinkAdapter.
AsIObjectList | This is AsIObjectList, a member of class FrontsideDerivedMultilinkAdapter.
Count | This is Count, a member of class FrontsideDerivedMultilinkAdapter.
IsFixedSize | This is IsFixedSize, a member of class FrontsideDerivedMultilinkAdapter.
IsReadOnly | This is IsReadOnly, a member of class FrontsideDerivedMultilinkAdapter.
IsSynchronized | This is IsSynchronized, a member of class FrontsideDerivedMultilinkAdapter.
ServiceProvider | This is ServiceProvider, a member of class FrontsideDerivedMultilinkAdapter.
SyncRoot | This is SyncRoot, a member of class FrontsideDerivedMultilinkAdapter.


FrontsideDerivedMultilinkAdapter.AllowNew Property

FrontsideDerivedMultilinkAdapter.AllowNew Property
FrontsideDerivedMultilinkAdapter Class Eco.Framework.Impl.Frontside Namespace See Also
Collapse All
C#
public bool AllowNew;
Remarks

This is AllowNew, a member of class FrontsideDerivedMultilinkAdapter.

See Also
FrontsideDerivedMultilinkAdapter Class
Eco.Framework.Impl.Frontside Namespace


FrontsideDerivedMultilinkAdapter.AsIObjectList Property

FrontsideDerivedMultilinkAdapter.AsIObjectList Property
FrontsideDerivedMultilinkAdapter Class Eco.Framework.Impl.Frontside Namespace See Also
Collapse All
C#
public IObjectList AsIObjectList;
Remarks

This is AsIObjectList, a member of class FrontsideDerivedMultilinkAdapter.

See Also
FrontsideDerivedMultilinkAdapter Class
Eco.Framework.Impl.Frontside Namespace


FrontsideDerivedMultilinkAdapter.Count Property

FrontsideDerivedMultilinkAdapter.Count Property
FrontsideDerivedMultilinkAdapter Class Eco.Framework.Impl.Frontside Namespace See Also
Collapse All
C#
public int Count;
Remarks

This is Count, a member of class FrontsideDerivedMultilinkAdapter.

See Also
FrontsideDerivedMultilinkAdapter Class
Eco.Framework.Impl.Frontside Namespace


FrontsideDerivedMultilinkAdapter.IsFixedSize Property

FrontsideDerivedMultilinkAdapter.IsFixedSize Property
FrontsideDerivedMultilinkAdapter Class Eco.Framework.Impl.Frontside Namespace See Also
Collapse All
C#
public bool IsFixedSize;
Remarks

This is IsFixedSize, a member of class FrontsideDerivedMultilinkAdapter.

See Also
FrontsideDerivedMultilinkAdapter Class
Eco.Framework.Impl.Frontside Namespace


FrontsideDerivedMultilinkAdapter.IsReadOnly Property

FrontsideDerivedMultilinkAdapter.IsReadOnly Property
FrontsideDerivedMultilinkAdapter Class Eco.Framework.Impl.Frontside Namespace See Also
Collapse All
C#
public bool IsReadOnly;
Remarks

This is IsReadOnly, a member of class FrontsideDerivedMultilinkAdapter.

See Also
FrontsideDerivedMultilinkAdapter Class
Eco.Framework.Impl.Frontside Namespace


FrontsideDerivedMultilinkAdapter.IsSynchronized Property

FrontsideDerivedMultilinkAdapter.IsSynchronized Property
FrontsideDerivedMultilinkAdapter Class Eco.Framework.Impl.Frontside Namespace See Also
Collapse All
C#
public bool IsSynchronized;
Remarks

This is IsSynchronized, a member of class FrontsideDerivedMultilinkAdapter.

See Also
FrontsideDerivedMultilinkAdapter Class
Eco.Framework.Impl.Frontside Namespace


FrontsideDerivedMultilinkAdapter.ServiceProvider Property

FrontsideDerivedMultilinkAdapter.ServiceProvider Property
FrontsideDerivedMultilinkAdapter Class Eco.Framework.Impl.Frontside Namespace See Also
Collapse All
C#
public IEcoServiceProvider ServiceProvider;
Remarks

This is ServiceProvider, a member of class FrontsideDerivedMultilinkAdapter.

See Also
FrontsideDerivedMultilinkAdapter Class
Eco.Framework.Impl.Frontside Namespace


FrontsideDerivedMultilinkAdapter.SyncRoot Property

FrontsideDerivedMultilinkAdapter.SyncRoot Property
FrontsideDerivedMultilinkAdapter Class Eco.Framework.Impl.Frontside Namespace See Also
Collapse All
C#
public object SyncRoot;
Remarks

This is SyncRoot, a member of class FrontsideDerivedMultilinkAdapter.

See Also
FrontsideDerivedMultilinkAdapter Class
Eco.Framework.Impl.Frontside Namespace


FrontsideMultilinkAdapter Class

FrontsideMultilinkAdapter Class
Inheritance Hierarchy See Also
Collapse All
C#
public class FrontsideMultilinkAdapter<T> : IList<T>, ICollection<T>, IEcoList<T>, IObjectListProvider, IBindingList where T : class, IEcoObject;
Remarks

This is class Eco.Framework.Impl.Frontside.FrontsideMultilinkAdapter.

Inheritance Hierarchy
Eco.Framework.Impl.Frontside.FrontsideMultilinkAdapter
File

FrontsideMultilinkAdapters.cs

See Also
Inheritance Hierarchy


FrontsideMultilinkAdapter.FrontsideMultilinkAdapter Constructor

FrontsideMultilinkAdapter.FrontsideMultilinkAdapter Constructor
FrontsideMultilinkAdapter Class Eco.Framework.Impl.Frontside Namespace See Also
Collapse All
C#
public FrontsideMultilinkAdapter(
    DefaultFrontsideLocator locator,
    MultAssociationEndFrontsidePolicy policy
);
Remarks

This is FrontsideMultilinkAdapter, a member of class FrontsideMultilinkAdapter.

See Also
FrontsideMultilinkAdapter Class
Eco.Framework.Impl.Frontside Namespace


FrontsideMultilinkAdapter Methods

FrontsideMultilinkAdapter Methods
Public Methods
Collapse All

The methods of the FrontsideMultilinkAdapter class are listed here.

Public Methods
Name | Description
Add | This is the overview for the Add method overload.
Clear | This is Clear, a member of class FrontsideMultilinkAdapter.
Contains | This is the overview for the Contains method overload.
CopyTo | This is the overview for the CopyTo method overload.
GetEnumerator | This is GetEnumerator, a member of class FrontsideMultilinkAdapter.
IndexOf | This is the overview for the IndexOf method overload.
Insert | This is the overview for the Insert method overload.
Remove | This is the overview for the Remove method overload.
RemoveAt | This is RemoveAt, a member of class FrontsideMultilinkAdapter.
this | This is this, a member of class FrontsideMultilinkAdapter.


Add Method

Add Method

This is the overview for the Add method overload.

Overload List
Name | Description
FrontsideMultilinkAdapter.Add (object) | This is Add, a member of class FrontsideMultilinkAdapter.
FrontsideMultilinkAdapter.Add (T) | This is Add, a member of class FrontsideMultilinkAdapter.


FrontsideMultilinkAdapter.Add Method (T)

FrontsideMultilinkAdapter.Add Method (T)
FrontsideMultilinkAdapter Class Eco.Framework.Impl.Frontside Namespace See Also
Collapse All
C#
public void Add(
    T value
);
Remarks

This is Add, a member of class FrontsideMultilinkAdapter.

See Also
FrontsideMultilinkAdapter Class
Eco.Framework.Impl.Frontside Namespace


FrontsideMultilinkAdapter.Add Method (object)

FrontsideMultilinkAdapter.Add Method (object)
FrontsideMultilinkAdapter Class Eco.Framework.Impl.Frontside Namespace See Also
Collapse All
C#
public int Add(
    object value
);
Remarks

This is Add, a member of class FrontsideMultilinkAdapter.

See Also
FrontsideMultilinkAdapter Class
Eco.Framework.Impl.Frontside Namespace


FrontsideMultilinkAdapter.Clear Method

FrontsideMultilinkAdapter.Clear Method
FrontsideMultilinkAdapter Class Eco.Framework.Impl.Frontside Namespace See Also
Collapse All
C#
public void Clear();
Remarks

This is Clear, a member of class FrontsideMultilinkAdapter.

See Also
FrontsideMultilinkAdapter Class
Eco.Framework.Impl.Frontside Namespace


Contains Method

Contains Method

This is the overview for the Contains method overload.

Overload List
Name | Description
FrontsideMultilinkAdapter.Contains (object) | This is Contains, a member of class FrontsideMultilinkAdapter.
FrontsideMultilinkAdapter.Contains (T) | This is Contains, a member of class FrontsideMultilinkAdapter.


FrontsideMultilinkAdapter.Contains Method (T)

FrontsideMultilinkAdapter.Contains Method (T)
FrontsideMultilinkAdapter Class Eco.Framework.Impl.Frontside Namespace See Also
Collapse All
C#
public bool Contains(
    T value
);
Remarks

This is Contains, a member of class FrontsideMultilinkAdapter.

See Also
FrontsideMultilinkAdapter Class
Eco.Framework.Impl.Frontside Namespace


FrontsideMultilinkAdapter.Contains Method (object)

FrontsideMultilinkAdapter.Contains Method (object)
FrontsideMultilinkAdapter Class Eco.Framework.Impl.Frontside Namespace See Also
Collapse All
C#
public bool Contains(
    object value
);
Remarks

This is Contains, a member of class FrontsideMultilinkAdapter.

See Also
FrontsideMultilinkAdapter Class
Eco.Framework.Impl.Frontside Namespace


CopyTo Method

CopyTo Method

This is the overview for the CopyTo method overload.

Overload List
Name | Description
FrontsideMultilinkAdapter.CopyTo (System.Array, int) | This is CopyTo, a member of class FrontsideMultilinkAdapter.
FrontsideMultilinkAdapter.CopyTo (T[], int) | This is CopyTo, a member of class FrontsideMultilinkAdapter.


FrontsideMultilinkAdapter.CopyTo Method (System.Array, int)

FrontsideMultilinkAdapter.CopyTo Method (System.Array, int)
FrontsideMultilinkAdapter Class Eco.Framework.Impl.Frontside Namespace See Also
Collapse All
C#
public void CopyTo(
    System.Array arr,
    int index
);
Remarks

This is CopyTo, a member of class FrontsideMultilinkAdapter.

See Also
FrontsideMultilinkAdapter Class
Eco.Framework.Impl.Frontside Namespace


FrontsideMultilinkAdapter.CopyTo Method (T[], int)

FrontsideMultilinkAdapter.CopyTo Method (T[], int)
FrontsideMultilinkAdapter Class Eco.Framework.Impl.Frontside Namespace See Also
Collapse All
C#
public void CopyTo(
    T[] arr,
    int index
);
Remarks

This is CopyTo, a member of class FrontsideMultilinkAdapter.

See Also
FrontsideMultilinkAdapter Class
Eco.Framework.Impl.Frontside Namespace


FrontsideMultilinkAdapter.GetEnumerator Method

FrontsideMultilinkAdapter.GetEnumerator Method
FrontsideMultilinkAdapter Class Eco.Framework.Impl.Frontside Namespace See Also
Collapse All
C#
public IEnumerator<T> GetEnumerator();
Remarks

This is GetEnumerator, a member of class FrontsideMultilinkAdapter.

See Also
FrontsideMultilinkAdapter Class
Eco.Framework.Impl.Frontside Namespace


IndexOf Method

IndexOf Method

This is the overview for the IndexOf method overload.

Overload List
Name | Description
FrontsideMultilinkAdapter.IndexOf (object) | This is IndexOf, a member of class FrontsideMultilinkAdapter.
FrontsideMultilinkAdapter.IndexOf (T) | This is IndexOf, a member of class FrontsideMultilinkAdapter.


FrontsideMultilinkAdapter.IndexOf Method (T)

FrontsideMultilinkAdapter.IndexOf Method (T)
FrontsideMultilinkAdapter Class Eco.Framework.Impl.Frontside Namespace See Also
Collapse All
C#
public int IndexOf(
    T value
);
Remarks

This is IndexOf, a member of class FrontsideMultilinkAdapter.

See Also
FrontsideMultilinkAdapter Class
Eco.Framework.Impl.Frontside Namespace


FrontsideMultilinkAdapter.IndexOf Method (object)

FrontsideMultilinkAdapter.IndexOf Method (object)
FrontsideMultilinkAdapter Class Eco.Framework.Impl.Frontside Namespace See Also
Collapse All
C#
public int IndexOf(
    object value
);
Remarks

This is IndexOf, a member of class FrontsideMultilinkAdapter.

See Also
FrontsideMultilinkAdapter Class
Eco.Framework.Impl.Frontside Namespace


Insert Method

Insert Method

This is the overview for the Insert method overload.

Overload List
Name | Description
FrontsideMultilinkAdapter.Insert (int, object) | This is Insert, a member of class FrontsideMultilinkAdapter.
FrontsideMultilinkAdapter.Insert (int, T) | This is Insert, a member of class FrontsideMultilinkAdapter.


FrontsideMultilinkAdapter.Insert Method (int, T)

FrontsideMultilinkAdapter.Insert Method (int, T)
FrontsideMultilinkAdapter Class Eco.Framework.Impl.Frontside Namespace See Also
Collapse All
C#
public void Insert(
    int index,
    T value
);
Remarks

This is Insert, a member of class FrontsideMultilinkAdapter.

See Also
FrontsideMultilinkAdapter Class
Eco.Framework.Impl.Frontside Namespace


FrontsideMultilinkAdapter.Insert Method (int, object)

FrontsideMultilinkAdapter.Insert Method (int, object)
FrontsideMultilinkAdapter Class Eco.Framework.Impl.Frontside Namespace See Also
Collapse All
C#
public void Insert(
    int index,
    object value
);
Remarks

This is Insert, a member of class FrontsideMultilinkAdapter.

See Also
FrontsideMultilinkAdapter Class
Eco.Framework.Impl.Frontside Namespace


Remove Method

Remove Method

This is the overview for the Remove method overload.

Overload List
Name | Description
FrontsideMultilinkAdapter.Remove (object) | This is Remove, a member of class FrontsideMultilinkAdapter.
FrontsideMultilinkAdapter.Remove (T) | This is Remove, a member of class FrontsideMultilinkAdapter.


FrontsideMultilinkAdapter.Remove Method (T)

FrontsideMultilinkAdapter.Remove Method (T)
FrontsideMultilinkAdapter Class Eco.Framework.Impl.Frontside Namespace See Also
Collapse All
C#
public bool Remove(
    T value
);
Remarks

This is Remove, a member of class FrontsideMultilinkAdapter.

See Also
FrontsideMultilinkAdapter Class
Eco.Framework.Impl.Frontside Namespace


FrontsideMultilinkAdapter.Remove Method (object)

FrontsideMultilinkAdapter.Remove Method (object)
FrontsideMultilinkAdapter Class Eco.Framework.Impl.Frontside Namespace See Also
Collapse All
C#
public void Remove(
    object value
);
Remarks

This is Remove, a member of class FrontsideMultilinkAdapter.

See Also
FrontsideMultilinkAdapter Class
Eco.Framework.Impl.Frontside Namespace


FrontsideMultilinkAdapter.RemoveAt Method

FrontsideMultilinkAdapter.RemoveAt Method
FrontsideMultilinkAdapter Class Eco.Framework.Impl.Frontside Namespace See Also
Collapse All
C#
public void RemoveAt(
    int index
);
Remarks

This is RemoveAt, a member of class FrontsideMultilinkAdapter.

See Also
FrontsideMultilinkAdapter Class
Eco.Framework.Impl.Frontside Namespace


FrontsideMultilinkAdapter.this Indexer

FrontsideMultilinkAdapter.this Indexer
FrontsideMultilinkAdapter Class Eco.Framework.Impl.Frontside Namespace See Also
Collapse All
C#
public T this[
    int index
];
Remarks

This is this, a member of class FrontsideMultilinkAdapter.

See Also
FrontsideMultilinkAdapter Class
Eco.Framework.Impl.Frontside Namespace


FrontsideMultilinkAdapter Properties

FrontsideMultilinkAdapter Properties
Public Properties
Collapse All

The properties of the FrontsideMultilinkAdapter class are listed here.

Public Properties
Name | Description
AllowNew | This is AllowNew, a member of class FrontsideMultilinkAdapter.
AsIObjectList | This is AsIObjectList, a member of class FrontsideMultilinkAdapter.
Count | This is Count, a member of class FrontsideMultilinkAdapter.
IsFixedSize | This is IsFixedSize, a member of class FrontsideMultilinkAdapter.
IsReadOnly | This is IsReadOnly, a member of class FrontsideMultilinkAdapter.
IsSynchronized | This is IsSynchronized, a member of class FrontsideMultilinkAdapter.
ServiceProvider | This is ServiceProvider, a member of class FrontsideMultilinkAdapter.
SyncRoot | This is SyncRoot, a member of class FrontsideMultilinkAdapter.


FrontsideMultilinkAdapter.AllowNew Property

FrontsideMultilinkAdapter.AllowNew Property
FrontsideMultilinkAdapter Class Eco.Framework.Impl.Frontside Namespace See Also
Collapse All
C#
public bool AllowNew;
Remarks

This is AllowNew, a member of class FrontsideMultilinkAdapter.

See Also
FrontsideMultilinkAdapter Class
Eco.Framework.Impl.Frontside Namespace


FrontsideMultilinkAdapter.AsIObjectList Property

FrontsideMultilinkAdapter.AsIObjectList Property
FrontsideMultilinkAdapter Class Eco.Framework.Impl.Frontside Namespace See Also
Collapse All
C#
public IObjectList AsIObjectList;
Remarks

This is AsIObjectList, a member of class FrontsideMultilinkAdapter.

See Also
FrontsideMultilinkAdapter Class
Eco.Framework.Impl.Frontside Namespace


FrontsideMultilinkAdapter.Count Property

FrontsideMultilinkAdapter.Count Property
FrontsideMultilinkAdapter Class Eco.Framework.Impl.Frontside Namespace See Also
Collapse All
C#
public int Count;
Remarks

This is Count, a member of class FrontsideMultilinkAdapter.

See Also
FrontsideMultilinkAdapter Class
Eco.Framework.Impl.Frontside Namespace


FrontsideMultilinkAdapter.IsFixedSize Property

FrontsideMultilinkAdapter.IsFixedSize Property
FrontsideMultilinkAdapter Class Eco.Framework.Impl.Frontside Namespace See Also
Collapse All
C#
public bool IsFixedSize;
Remarks

This is IsFixedSize, a member of class FrontsideMultilinkAdapter.

See Also
FrontsideMultilinkAdapter Class
Eco.Framework.Impl.Frontside Namespace


FrontsideMultilinkAdapter.IsReadOnly Property

FrontsideMultilinkAdapter.IsReadOnly Property
FrontsideMultilinkAdapter Class Eco.Framework.Impl.Frontside Namespace See Also
Collapse All
C#
public bool IsReadOnly;
Remarks

This is IsReadOnly, a member of class FrontsideMultilinkAdapter.

See Also
FrontsideMultilinkAdapter Class
Eco.Framework.Impl.Frontside Namespace


FrontsideMultilinkAdapter.IsSynchronized Property

FrontsideMultilinkAdapter.IsSynchronized Property
FrontsideMultilinkAdapter Class Eco.Framework.Impl.Frontside Namespace See Also
Collapse All
C#
public bool IsSynchronized;
Remarks

This is IsSynchronized, a member of class FrontsideMultilinkAdapter.

See Also
FrontsideMultilinkAdapter Class
Eco.Framework.Impl.Frontside Namespace


FrontsideMultilinkAdapter.ServiceProvider Property

FrontsideMultilinkAdapter.ServiceProvider Property
FrontsideMultilinkAdapter Class Eco.Framework.Impl.Frontside Namespace See Also
Collapse All
C#
public IEcoServiceProvider ServiceProvider;
Remarks

This is ServiceProvider, a member of class FrontsideMultilinkAdapter.

See Also
FrontsideMultilinkAdapter Class
Eco.Framework.Impl.Frontside Namespace


FrontsideMultilinkAdapter.SyncRoot Property

FrontsideMultilinkAdapter.SyncRoot Property
FrontsideMultilinkAdapter Class Eco.Framework.Impl.Frontside Namespace See Also
Collapse All
C#
public object SyncRoot;
Remarks

This is SyncRoot, a member of class FrontsideMultilinkAdapter.

See Also
FrontsideMultilinkAdapter Class
Eco.Framework.Impl.Frontside Namespace


FrontsideUtils Class

FrontsideUtils Class
Inheritance Hierarchy See Also
Collapse All
C#
public class FrontsideUtils;
Remarks

This is class Eco.Framework.Impl.Frontside.FrontsideUtils.

Inheritance Hierarchy
Eco.Framework.Impl.Frontside.FrontsideUtils
File

FrontsidePolicy.cs

See Also
Inheritance Hierarchy


FrontsideUtils Methods

FrontsideUtils Methods
Public Methods
Collapse All

The methods of the FrontsideUtils class are listed here.

Public Methods
Name | Description
EnsureLocatorsCanBeLinked | This is EnsureLocatorsCanBeLinked, a member of class FrontsideUtils.
GetLocatorFromFrontendObject | This is GetLocatorFromFrontendObject, a member of class FrontsideUtils.


FrontsideUtils.EnsureLocatorsCanBeLinked Method

FrontsideUtils.EnsureLocatorsCanBeLinked Method
FrontsideUtils Class Eco.Framework.Impl.Frontside Namespace See Also
Collapse All
C#
public static void EnsureLocatorsCanBeLinked(
    Locator locator1,
    Locator locator2,
    ICache cache
);
Remarks

This is EnsureLocatorsCanBeLinked, a member of class FrontsideUtils.

See Also
FrontsideUtils Class
Eco.Framework.Impl.Frontside Namespace


FrontsideUtils.GetLocatorFromFrontendObject Method

FrontsideUtils.GetLocatorFromFrontendObject Method
FrontsideUtils Class Eco.Framework.Impl.Frontside Namespace See Also
Collapse All
C#
public static DefaultFrontsideLocator GetLocatorFromFrontendObject(
    object obj
);
Remarks

This is GetLocatorFromFrontendObject, a member of class FrontsideUtils.

See Also
FrontsideUtils Class
Eco.Framework.Impl.Frontside Namespace


IndirectMultiFrontsidePolicy Class

IndirectMultiFrontsidePolicy Class
Inheritance Hierarchy See Also
Collapse All
C#
public abstract class IndirectMultiFrontsidePolicy : MultAssociationEndFrontsidePolicy;
Remarks

This is class Eco.Framework.Impl.Frontside.IndirectMultiFrontsidePolicy.

Inheritance Hierarchy
Eco.Framework.Impl.Frontside.MemberFrontsidePolicy
    Eco.Framework.Impl.Frontside.AssociationEndFrontsidePolicy
        Eco.Framework.Impl.Frontside.MultAssociationEndFrontsidePolicy
            Eco.Framework.Impl.Frontside.IndirectMultiFrontsidePolicy
                Eco.Framework.Impl.Frontside.IndirectMultiSingleFrontsidePolicy
                Eco.Framework.Impl.Frontside.MultiMultiFrontsidePolicy
File

MultiAssociationEndFrontsidePolicies.cs

See Also
Inheritance Hierarchy


IndirectMultiFrontsidePolicy.IndirectMultiFrontsidePolicy Constructor

IndirectMultiFrontsidePolicy.IndirectMultiFrontsidePolicy Constructor
IndirectMultiFrontsidePolicy Class Eco.Framework.Impl.Frontside Namespace See Also
Collapse All
C#
public IndirectMultiFrontsidePolicy(
    IAssociationEnd assocEnd,
    ClassFrontsidePolicy owner
);
Remarks

This is IndirectMultiFrontsidePolicy, a member of class IndirectMultiFrontsidePolicy.

See Also
IndirectMultiFrontsidePolicy Class
Eco.Framework.Impl.Frontside Namespace


IndirectMultiFrontsidePolicy Methods

IndirectMultiFrontsidePolicy Methods
Protected Methods Public Methods
Collapse All

The methods of the IndirectMultiFrontsidePolicy class are listed here.

Protected Methods
Name | Description
GetAssociationClassPolicy | This is GetAssociationClassPolicy, a member of class IndirectMultiFrontsidePolicy.
GetEndPointingHerePolicy | This is GetEndPointingHerePolicy, a member of class IndirectMultiFrontsidePolicy.
Top
Public Methods
Name | Description
Add | This is Add, a member of class IndirectMultiFrontsidePolicy.
Clear | This is Clear, a member of class IndirectMultiFrontsidePolicy.
Insert | This is Insert, a member of class IndirectMultiFrontsidePolicy.
Remove | This is Remove, a member of class IndirectMultiFrontsidePolicy.
RemoveAt | This is RemoveAt, a member of class IndirectMultiFrontsidePolicy.
SetItem | This is SetItem, a member of class IndirectMultiFrontsidePolicy.


IndirectMultiFrontsidePolicy.Add Method

IndirectMultiFrontsidePolicy.Add Method
IndirectMultiFrontsidePolicy Class Eco.Framework.Impl.Frontside Namespace See Also
Collapse All
C#
public override int Add(
    Locator locator,
    object value
);
Remarks

This is Add, a member of class IndirectMultiFrontsidePolicy.

See Also
IndirectMultiFrontsidePolicy Class
Eco.Framework.Impl.Frontside Namespace


IndirectMultiFrontsidePolicy.Clear Method

IndirectMultiFrontsidePolicy.Clear Method
IndirectMultiFrontsidePolicy Class Eco.Framework.Impl.Frontside Namespace See Also
Collapse All
C#
public override void Clear(
    Locator locator
);
Remarks

This is Clear, a member of class IndirectMultiFrontsidePolicy.

See Also
IndirectMultiFrontsidePolicy Class
Eco.Framework.Impl.Frontside Namespace


IndirectMultiFrontsidePolicy.GetAssociationClassPolicy Method

IndirectMultiFrontsidePolicy.GetAssociationClassPolicy Method
IndirectMultiFrontsidePolicy Class Eco.Framework.Impl.Frontside Namespace See Also
Collapse All
C#
protected ClassFrontsidePolicy GetAssociationClassPolicy();
Remarks

This is GetAssociationClassPolicy, a member of class IndirectMultiFrontsidePolicy.

See Also
IndirectMultiFrontsidePolicy Class
Eco.Framework.Impl.Frontside Namespace


IndirectMultiFrontsidePolicy.GetEndPointingHerePolicy Method

IndirectMultiFrontsidePolicy.GetEndPointingHerePolicy Method
IndirectMultiFrontsidePolicy Class Eco.Framework.Impl.Frontside Namespace See Also
Collapse All
C#
protected MemberFrontsidePolicy GetEndPointingHerePolicy();
Remarks

This is GetEndPointingHerePolicy, a member of class IndirectMultiFrontsidePolicy.

See Also
IndirectMultiFrontsidePolicy Class
Eco.Framework.Impl.Frontside Namespace


IndirectMultiFrontsidePolicy.Insert Method

IndirectMultiFrontsidePolicy.Insert Method
IndirectMultiFrontsidePolicy Class Eco.Framework.Impl.Frontside Namespace See Also
Collapse All
C#
public override void Insert(
    Locator locator,
    int index,
    object value
);
Remarks

This is Insert, a member of class IndirectMultiFrontsidePolicy.

See Also
IndirectMultiFrontsidePolicy Class
Eco.Framework.Impl.Frontside Namespace


IndirectMultiFrontsidePolicy.Remove Method

IndirectMultiFrontsidePolicy.Remove Method
IndirectMultiFrontsidePolicy Class Eco.Framework.Impl.Frontside Namespace See Also
Collapse All
C#
public override void Remove(
    Locator locator,
    object value
);
Remarks

This is Remove, a member of class IndirectMultiFrontsidePolicy.

See Also
IndirectMultiFrontsidePolicy Class
Eco.Framework.Impl.Frontside Namespace


IndirectMultiFrontsidePolicy.RemoveAt Method

IndirectMultiFrontsidePolicy.RemoveAt Method
IndirectMultiFrontsidePolicy Class Eco.Framework.Impl.Frontside Namespace See Also
Collapse All
C#
public override void RemoveAt(
    Locator locator,
    int index
);
Remarks

This is RemoveAt, a member of class IndirectMultiFrontsidePolicy.

See Also
IndirectMultiFrontsidePolicy Class
Eco.Framework.Impl.Frontside Namespace


IndirectMultiFrontsidePolicy.SetItem Method

IndirectMultiFrontsidePolicy.SetItem Method
IndirectMultiFrontsidePolicy Class Eco.Framework.Impl.Frontside Namespace See Also
Collapse All
C#
public override void SetItem(
    Locator locator,
    int index,
    object value
);
Remarks

This is SetItem, a member of class IndirectMultiFrontsidePolicy.

See Also
IndirectMultiFrontsidePolicy Class
Eco.Framework.Impl.Frontside Namespace


IndirectMultiFrontsidePolicy Properties

IndirectMultiFrontsidePolicy Properties
Protected Properties
Collapse All

The properties of the IndirectMultiFrontsidePolicy class are listed here.

Protected Properties
Name | Description
AssociationClass | This is AssociationClass, a member of class IndirectMultiFrontsidePolicy.
AssociationClassEndPointingAway | This is AssociationClassEndPointingAway, a member of class IndirectMultiFrontsidePolicy.
AssociationClassEndPointingHere | This is AssociationClassEndPointingHere, a member of class IndirectMultiFrontsidePolicy.
EndPointingHere | This is EndPointingHere, a member of class IndirectMultiFrontsidePolicy.
EndPointingToAssociationClass | This is EndPointingToAssociationClass, a member of class IndirectMultiFrontsidePolicy.


IndirectMultiFrontsidePolicy.AssociationClass Property

IndirectMultiFrontsidePolicy.AssociationClass Property
IndirectMultiFrontsidePolicy Class Eco.Framework.Impl.Frontside Namespace See Also
Collapse All
C#
protected IClass AssociationClass;
Remarks

This is AssociationClass, a member of class IndirectMultiFrontsidePolicy.

See Also
IndirectMultiFrontsidePolicy Class
Eco.Framework.Impl.Frontside Namespace


IndirectMultiFrontsidePolicy.AssociationClassEndPointingAway Property

IndirectMultiFrontsidePolicy.AssociationClassEndPointingAway Property
IndirectMultiFrontsidePolicy Class Eco.Framework.Impl.Frontside Namespace See Also
Collapse All
C#
protected IAssociationEnd AssociationClassEndPointingAway;
Remarks

This is AssociationClassEndPointingAway, a member of class IndirectMultiFrontsidePolicy.

See Also
IndirectMultiFrontsidePolicy Class
Eco.Framework.Impl.Frontside Namespace


IndirectMultiFrontsidePolicy.AssociationClassEndPointingHere Property

IndirectMultiFrontsidePolicy.AssociationClassEndPointingHere Property
IndirectMultiFrontsidePolicy Class Eco.Framework.Impl.Frontside Namespace See Also
Collapse All
C#
protected IAssociationEnd AssociationClassEndPointingHere;
Remarks

This is AssociationClassEndPointingHere, a member of class IndirectMultiFrontsidePolicy.

See Also
IndirectMultiFrontsidePolicy Class
Eco.Framework.Impl.Frontside Namespace


IndirectMultiFrontsidePolicy.EndPointingHere Property

IndirectMultiFrontsidePolicy.EndPointingHere Property
IndirectMultiFrontsidePolicy Class Eco.Framework.Impl.Frontside Namespace See Also
Collapse All
C#
protected IAssociationEnd EndPointingHere;
Remarks

This is EndPointingHere, a member of class IndirectMultiFrontsidePolicy.

See Also
IndirectMultiFrontsidePolicy Class
Eco.Framework.Impl.Frontside Namespace


IndirectMultiFrontsidePolicy.EndPointingToAssociationClass Property

IndirectMultiFrontsidePolicy.EndPointingToAssociationClass Property
IndirectMultiFrontsidePolicy Class Eco.Framework.Impl.Frontside Namespace See Also
Collapse All
C#
protected IAssociationEnd EndPointingToAssociationClass;
Remarks

This is EndPointingToAssociationClass, a member of class IndirectMultiFrontsidePolicy.

See Also
IndirectMultiFrontsidePolicy Class
Eco.Framework.Impl.Frontside Namespace


IndirectMultiSingleFrontsidePolicy Class

IndirectMultiSingleFrontsidePolicy Class
Inheritance Hierarchy See Also
Collapse All
C#
public sealed class IndirectMultiSingleFrontsidePolicy : IndirectMultiFrontsidePolicy;
Remarks

This is class Eco.Framework.Impl.Frontside.IndirectMultiSingleFrontsidePolicy.

Inheritance Hierarchy
Eco.Framework.Impl.Frontside.MemberFrontsidePolicy
    Eco.Framework.Impl.Frontside.AssociationEndFrontsidePolicy
        Eco.Framework.Impl.Frontside.MultAssociationEndFrontsidePolicy
            Eco.Framework.Impl.Frontside.IndirectMultiFrontsidePolicy
                Eco.Framework.Impl.Frontside.IndirectMultiSingleFrontsidePolicy
File

MultiAssociationEndFrontsidePolicies.cs

See Also
Inheritance Hierarchy


IndirectMultiSingleFrontsidePolicy.IndirectMultiSingleFrontsidePolicy Constructor

IndirectMultiSingleFrontsidePolicy.IndirectMultiSingleFrontsidePolicy Constructor
IndirectMultiSingleFrontsidePolicy Class Eco.Framework.Impl.Frontside Namespace See Also
Collapse All
C#
public IndirectMultiSingleFrontsidePolicy(
    IAssociationEnd assocEnd,
    ClassFrontsidePolicy owner
);
Remarks

This is IndirectMultiSingleFrontsidePolicy, a member of class IndirectMultiSingleFrontsidePolicy.

See Also
IndirectMultiSingleFrontsidePolicy Class
Eco.Framework.Impl.Frontside Namespace


IndirectSingleFrontsidePolicy Class

IndirectSingleFrontsidePolicy Class
Inheritance Hierarchy See Also
Collapse All
C#
public sealed class IndirectSingleFrontsidePolicy : SingleAssociationEndFrontsidePolicy;
Remarks

This is class Eco.Framework.Impl.Frontside.IndirectSingleFrontsidePolicy.

Inheritance Hierarchy
Eco.Framework.Impl.Frontside.MemberFrontsidePolicy
    Eco.Framework.Impl.Frontside.AssociationEndFrontsidePolicy
        Eco.Framework.Impl.Frontside.SingleAssociationEndFrontsidePolicy
            Eco.Framework.Impl.Frontside.IndirectSingleFrontsidePolicy
File

SingleAssociationEndFrontsidePolicies.cs

See Also
Inheritance Hierarchy


IndirectSingleFrontsidePolicy.IndirectSingleFrontsidePolicy Constructor

IndirectSingleFrontsidePolicy.IndirectSingleFrontsidePolicy Constructor
IndirectSingleFrontsidePolicy Class Eco.Framework.Impl.Frontside Namespace See Also
Collapse All
C#
public IndirectSingleFrontsidePolicy(
    IAssociationEnd assocEnd,
    ClassFrontsidePolicy owner
);
Remarks

This is IndirectSingleFrontsidePolicy, a member of class IndirectSingleFrontsidePolicy.

See Also
IndirectSingleFrontsidePolicy Class
Eco.Framework.Impl.Frontside Namespace


IndirectSingleFrontsidePolicy Methods

IndirectSingleFrontsidePolicy Methods
Public Methods
Collapse All

The methods of the IndirectSingleFrontsidePolicy class are listed here.

Public Methods
Name | Description
ApplyMemberValue | IndirectSingleFrontsidePolicy


IndirectSingleFrontsidePolicy.ApplyMemberValue Method

IndirectSingleFrontsidePolicy.ApplyMemberValue Method
IndirectSingleFrontsidePolicy Class Eco.Framework.Impl.Frontside Namespace See Also
Collapse All
C#
public override void ApplyMemberValue(
    Locator locator,
    object value,
    bool CallerStateMachine
);
Remarks

IndirectSingleFrontsidePolicy

See Also
IndirectSingleFrontsidePolicy Class
Eco.Framework.Impl.Frontside Namespace


InnerLinkFrontsidePolicy Class

InnerLinkFrontsidePolicy Class
Inheritance Hierarchy See Also
Collapse All
C#
public class InnerLinkFrontsidePolicy : SingleAssociationEndFrontsidePolicy;
Remarks

This is class Eco.Framework.Impl.Frontside.InnerLinkFrontsidePolicy.

Inheritance Hierarchy
Eco.Framework.Impl.Frontside.MemberFrontsidePolicy
    Eco.Framework.Impl.Frontside.AssociationEndFrontsidePolicy
        Eco.Framework.Impl.Frontside.SingleAssociationEndFrontsidePolicy
            Eco.Framework.Impl.Frontside.InnerLinkFrontsidePolicy
File

SingleAssociationEndFrontsidePolicies.cs

See Also
Inheritance Hierarchy


InnerLinkFrontsidePolicy.InnerLinkFrontsidePolicy Constructor

InnerLinkFrontsidePolicy.InnerLinkFrontsidePolicy Constructor
InnerLinkFrontsidePolicy Class Eco.Framework.Impl.Frontside Namespace See Also
Collapse All
C#
public InnerLinkFrontsidePolicy(
    IAssociationEnd assocEnd,
    ClassFrontsidePolicy owner
);
Remarks

This is InnerLinkFrontsidePolicy, a member of class InnerLinkFrontsidePolicy.

See Also
InnerLinkFrontsidePolicy Class
Eco.Framework.Impl.Frontside Namespace


InnerLinkFrontsidePolicy Methods

InnerLinkFrontsidePolicy Methods
Public Methods
Collapse All

The methods of the InnerLinkFrontsidePolicy class are listed here.

Public Methods
Name | Description
ApplyMemberValue | This is ApplyMemberValue, a member of class InnerLinkFrontsidePolicy.
GetIsReadOnly | This is GetIsReadOnly, a member of class InnerLinkFrontsidePolicy.


InnerLinkFrontsidePolicy.ApplyMemberValue Method

InnerLinkFrontsidePolicy.ApplyMemberValue Method
InnerLinkFrontsidePolicy Class Eco.Framework.Impl.Frontside Namespace See Also
Collapse All
C#
public override void ApplyMemberValue(
    Locator locator,
    object value,
    bool callerStateMachine
);
Remarks

This is ApplyMemberValue, a member of class InnerLinkFrontsidePolicy.

See Also
InnerLinkFrontsidePolicy Class
Eco.Framework.Impl.Frontside Namespace


InnerLinkFrontsidePolicy.GetIsReadOnly Method

InnerLinkFrontsidePolicy.GetIsReadOnly Method
InnerLinkFrontsidePolicy Class Eco.Framework.Impl.Frontside Namespace See Also
Collapse All
C#
public override bool GetIsReadOnly(
    Locator locator
);
Remarks

This is GetIsReadOnly, a member of class InnerLinkFrontsidePolicy.

See Also
InnerLinkFrontsidePolicy Class
Eco.Framework.Impl.Frontside Namespace


LocatorFactory Class

LocatorFactory Class
Inheritance Hierarchy See Also
Collapse All
C#
public class LocatorFactory;
Remarks

This is class Eco.Framework.Impl.Frontside.LocatorFactory.

Inheritance Hierarchy
Eco.Framework.Impl.Frontside.LocatorFactory
File

DefaultCacheAndFrontsideLocator.cs

See Also
Inheritance Hierarchy


LocatorFactory Methods

LocatorFactory Methods
Public Methods
Collapse All

The methods of the LocatorFactory class are listed here.

Public Methods
Name | Description
CreateLocator | This is the overview for the CreateLocator method overload.


CreateLocator Method

CreateLocator Method

This is the overview for the CreateLocator method overload.

Overload List
Name | Description
LocatorFactory.CreateLocator (IClass) | This is CreateLocator, a member of class LocatorFactory.
LocatorFactory.CreateLocator (IClass, ILoopBack) | This is CreateLocator, a member of class LocatorFactory.


LocatorFactory.CreateLocator Method (IClass)

LocatorFactory.CreateLocator Method (IClass)
LocatorFactory Class Eco.Framework.Impl.Frontside Namespace See Also
Collapse All
C#
public CacheLocator CreateLocator(
    IClass umlClass
);
Remarks

This is CreateLocator, a member of class LocatorFactory.

See Also
LocatorFactory Class
Eco.Framework.Impl.Frontside Namespace


LocatorFactory.CreateLocator Method (IClass, ILoopBack)

LocatorFactory.CreateLocator Method (IClass, ILoopBack)
LocatorFactory Class Eco.Framework.Impl.Frontside Namespace See Also
Collapse All
C#
public CacheLocator CreateLocator(
    IClass umlClass,
    ILoopBack loopback
);
Remarks

This is CreateLocator, a member of class LocatorFactory.

See Also
LocatorFactory Class
Eco.Framework.Impl.Frontside Namespace


LocatorFactory Properties

LocatorFactory Properties
Public Properties
Collapse All

The properties of the LocatorFactory class are listed here.

Public Properties
Name | Description
LocatorOwner | This is LocatorOwner, a member of class LocatorFactory.


LocatorFactory.LocatorOwner Property

LocatorFactory.LocatorOwner Property
LocatorFactory Class Eco.Framework.Impl.Frontside Namespace See Also
Collapse All
C#
public object LocatorOwner;
Remarks

This is LocatorOwner, a member of class LocatorFactory.

See Also
LocatorFactory Class
Eco.Framework.Impl.Frontside Namespace


MemberFrontsidePolicy Class

MemberFrontsidePolicy Class
Inheritance Hierarchy See Also
Collapse All
C#
public abstract class MemberFrontsidePolicy;
Remarks

This is class Eco.Framework.Impl.Frontside.MemberFrontsidePolicy.

Inheritance Hierarchy
Eco.Framework.Impl.Frontside.MemberFrontsidePolicy
    Eco.Framework.Impl.Frontside.AssociationEndFrontsidePolicy
    Eco.Framework.Impl.Frontside.AttributeFrontsidePolicy
    Eco.Framework.Impl.Frontside.DerivedMemberFrontsidePolicy
File

MemberFrontsidePolicy.cs

See Also
Inheritance Hierarchy


MemberFrontsidePolicy.MemberFrontsidePolicy Constructor

MemberFrontsidePolicy.MemberFrontsidePolicy Constructor
MemberFrontsidePolicy Class Eco.Framework.Impl.Frontside Namespace See Also
Collapse All
C#
public MemberFrontsidePolicy(
    IStructuralFeature feature,
    ClassFrontsidePolicy owner
);
Remarks

This is MemberFrontsidePolicy, a member of class MemberFrontsidePolicy.

See Also
MemberFrontsidePolicy Class
Eco.Framework.Impl.Frontside Namespace


MemberFrontsidePolicy Methods

MemberFrontsidePolicy Methods
Protected Methods Public Methods
Collapse All

The methods of the MemberFrontsidePolicy class are listed here.

Protected Methods
Name | Description
ThrowException | This is ThrowException, a member of class MemberFrontsidePolicy.
Top
Public Methods
Name | Description
AddValueChanged | This is AddValueChanged, a member of class MemberFrontsidePolicy.
ApplyMemberValue | This is ApplyMemberValue, a member of class MemberFrontsidePolicy.
ApplyMemberValueViaSetter | This is ApplyMemberValueViaSetter, a member of class MemberFrontsidePolicy.
EndModify | This is EndModify, a member of class MemberFrontsidePolicy.
EnsureContentsCurrent | This is the overview for the EnsureContentsCurrent method overload.
GetCache | This is GetCache, a member of class MemberFrontsidePolicy.
GetIsReadOnly | This is GetIsReadOnly, a member of class MemberFrontsidePolicy.
GetPropertyAdapter | This is GetPropertyAdapter, a member of class MemberFrontsidePolicy.
MakeDbCurrent | This is MakeDbCurrent, a member of class MemberFrontsidePolicy.
RemoveValueChanged | This is RemoveValueChanged, a member of class MemberFrontsidePolicy.
RetrieveMemberValue | This is RetrieveMemberValue, a member of class MemberFrontsidePolicy.
RetrieveMemberValueViaGetter | This is RetrieveMemberValueViaGetter, a member of class MemberFrontsidePolicy.
SubscribeToValue | This is SubscribeToValue, a member of class MemberFrontsidePolicy.


MemberFrontsidePolicy.AddValueChanged Method

MemberFrontsidePolicy.AddValueChanged Method
MemberFrontsidePolicy Class Eco.Framework.Impl.Frontside Namespace See Also
Collapse All
C#
public void AddValueChanged(
    DefaultFrontsideLocator locator,
    EventHandler handler
);
Remarks

This is AddValueChanged, a member of class MemberFrontsidePolicy.

See Also
MemberFrontsidePolicy Class
Eco.Framework.Impl.Frontside Namespace


MemberFrontsidePolicy.ApplyMemberValue Method

MemberFrontsidePolicy.ApplyMemberValue Method
MemberFrontsidePolicy Class Eco.Framework.Impl.Frontside Namespace See Also
Collapse All
C#
public abstract void ApplyMemberValue(
    Locator locator,
    object value,
    bool CallerStateMachine
);
Remarks

This is ApplyMemberValue, a member of class MemberFrontsidePolicy.

See Also
MemberFrontsidePolicy Class
Eco.Framework.Impl.Frontside Namespace


MemberFrontsidePolicy.ApplyMemberValueViaSetter Method

MemberFrontsidePolicy.ApplyMemberValueViaSetter Method
MemberFrontsidePolicy Class Eco.Framework.Impl.Frontside Namespace See Also
Collapse All
C#
public void ApplyMemberValueViaSetter(
    DefaultFrontsideLocator locator,
    object value
);
Remarks

This is ApplyMemberValueViaSetter, a member of class MemberFrontsidePolicy.

See Also
MemberFrontsidePolicy Class
Eco.Framework.Impl.Frontside Namespace


MemberFrontsidePolicy.EndModify Method

MemberFrontsidePolicy.EndModify Method
MemberFrontsidePolicy Class Eco.Framework.Impl.Frontside Namespace See Also
Collapse All
C#
public void EndModify(
    Locator locator
);
Remarks

This is EndModify, a member of class MemberFrontsidePolicy.

See Also
MemberFrontsidePolicy Class
Eco.Framework.Impl.Frontside Namespace


EnsureContentsCurrent Method

EnsureContentsCurrent Method

This is the overview for the EnsureContentsCurrent method overload.

Overload List
Name | Description
MemberFrontsidePolicy.EnsureContentsCurrent (Locator) | This is EnsureContentsCurrent, a member of class MemberFrontsidePolicy.
MemberFrontsidePolicy.EnsureContentsCurrent (Locator, FetchStrategy) | duplicate code to avoid evaluating EffectiveFetchStrategy to often


MemberFrontsidePolicy.EnsureContentsCurrent Method (Locator)

MemberFrontsidePolicy.EnsureContentsCurrent Method (Locator)
MemberFrontsidePolicy Class Eco.Framework.Impl.Frontside Namespace See Also
Collapse All
C#
public void EnsureContentsCurrent(
    Locator locator
);
Remarks

This is EnsureContentsCurrent, a member of class MemberFrontsidePolicy.

See Also
MemberFrontsidePolicy Class
Eco.Framework.Impl.Frontside Namespace


MemberFrontsidePolicy.EnsureContentsCurrent Method (Locator, FetchStrategy)

MemberFrontsidePolicy.EnsureContentsCurrent Method (Locator, FetchStrategy)
MemberFrontsidePolicy Class Eco.Framework.Impl.Frontside Namespace See Also
Collapse All
C#
public void EnsureContentsCurrent(
    Locator locator,
    FetchStrategy FetchStrategy
);
Remarks

duplicate code to avoid evaluating EffectiveFetchStrategy to often

See Also
MemberFrontsidePolicy Class
Eco.Framework.Impl.Frontside Namespace


MemberFrontsidePolicy.GetCache Method

MemberFrontsidePolicy.GetCache Method
MemberFrontsidePolicy Class Eco.Framework.Impl.Frontside Namespace See Also
Collapse All
C#
public ICache GetCache();
Remarks

This is GetCache, a member of class MemberFrontsidePolicy.

See Also
MemberFrontsidePolicy Class
Eco.Framework.Impl.Frontside Namespace


MemberFrontsidePolicy.GetIsReadOnly Method

MemberFrontsidePolicy.GetIsReadOnly Method
MemberFrontsidePolicy Class Eco.Framework.Impl.Frontside Namespace See Also
Collapse All
C#
public virtual bool GetIsReadOnly(
    Locator locator
);
Remarks

This is GetIsReadOnly, a member of class MemberFrontsidePolicy.

See Also
MemberFrontsidePolicy Class
Eco.Framework.Impl.Frontside Namespace


MemberFrontsidePolicy.GetPropertyAdapter Method

MemberFrontsidePolicy.GetPropertyAdapter Method
MemberFrontsidePolicy Class Eco.Framework.Impl.Frontside Namespace See Also
Collapse All
C#
public abstract IProperty GetPropertyAdapter(
    DefaultFrontsideLocator locator
);
Remarks

This is GetPropertyAdapter, a member of class MemberFrontsidePolicy.

See Also
MemberFrontsidePolicy Class
Eco.Framework.Impl.Frontside Namespace


MemberFrontsidePolicy.MakeDbCurrent Method

MemberFrontsidePolicy.MakeDbCurrent Method
MemberFrontsidePolicy Class Eco.Framework.Impl.Frontside Namespace See Also
Collapse All
C#
public void MakeDbCurrent(
    Locator loc,
    FetchStrategy FetchStrategy
);
Remarks

This is MakeDbCurrent, a member of class MemberFrontsidePolicy.

See Also
MemberFrontsidePolicy Class
Eco.Framework.Impl.Frontside Namespace


MemberFrontsidePolicy.RemoveValueChanged Method

MemberFrontsidePolicy.RemoveValueChanged Method
MemberFrontsidePolicy Class Eco.Framework.Impl.Frontside Namespace See Also
Collapse All
C#
public void RemoveValueChanged(
    DefaultFrontsideLocator locator,
    EventHandler handler
);
Remarks

This is RemoveValueChanged, a member of class MemberFrontsidePolicy.

See Also
MemberFrontsidePolicy Class
Eco.Framework.Impl.Frontside Namespace


MemberFrontsidePolicy.RetrieveMemberValue Method

MemberFrontsidePolicy.RetrieveMemberValue Method
MemberFrontsidePolicy Class Eco.Framework.Impl.Frontside Namespace See Also
Collapse All
C#
public abstract object RetrieveMemberValue(
    DefaultFrontsideLocator locator
);
Remarks

This is RetrieveMemberValue, a member of class MemberFrontsidePolicy.

See Also
MemberFrontsidePolicy Class
Eco.Framework.Impl.Frontside Namespace


MemberFrontsidePolicy.RetrieveMemberValueViaGetter Method

MemberFrontsidePolicy.RetrieveMemberValueViaGetter Method
MemberFrontsidePolicy Class Eco.Framework.Impl.Frontside Namespace See Also
Collapse All
C#
public object RetrieveMemberValueViaGetter(
    DefaultFrontsideLocator locator
);
Remarks

This is RetrieveMemberValueViaGetter, a member of class MemberFrontsidePolicy.

See Also
MemberFrontsidePolicy Class
Eco.Framework.Impl.Frontside Namespace


MemberFrontsidePolicy.SubscribeToValue Method

MemberFrontsidePolicy.SubscribeToValue Method
MemberFrontsidePolicy Class Eco.Framework.Impl.Frontside Namespace See Also
Collapse All
C#
public void SubscribeToValue(
    DefaultFrontsideLocator locator,
    ISubscriber Subscriber
);
Remarks

This is SubscribeToValue, a member of class MemberFrontsidePolicy.

See Also
MemberFrontsidePolicy Class
Eco.Framework.Impl.Frontside Namespace


MemberFrontsidePolicy.ThrowException Method

MemberFrontsidePolicy.ThrowException Method
MemberFrontsidePolicy Class Eco.Framework.Impl.Frontside Namespace See Also
Collapse All
C#
protected void ThrowException(
    string method
);
Remarks

This is ThrowException, a member of class MemberFrontsidePolicy.

See Also
MemberFrontsidePolicy Class
Eco.Framework.Impl.Frontside Namespace


MemberFrontsidePolicy Properties

MemberFrontsidePolicy Properties
Public Properties Protected Properties
Collapse All

The properties of the MemberFrontsidePolicy class are listed here.

Public Properties
Name | Description
Feature | This is Feature, a member of class MemberFrontsidePolicy.
Owner | This is Owner, a member of class MemberFrontsidePolicy.
TypeHandlesNull | This is TypeHandlesNull, a member of class MemberFrontsidePolicy.
UseGetter | This is UseGetter, a member of class MemberFrontsidePolicy.
UseSetter | This is UseSetter, a member of class MemberFrontsidePolicy.
Top
Protected Properties
Name | Description
EffectiveFetchStrategy | This is EffectiveFetchStrategy, a member of class MemberFrontsidePolicy.


MemberFrontsidePolicy.EffectiveFetchStrategy Property

MemberFrontsidePolicy.EffectiveFetchStrategy Property
MemberFrontsidePolicy Class Eco.Framework.Impl.Frontside Namespace See Also
Collapse All
C#
protected virtual FetchStrategy EffectiveFetchStrategy;
Remarks

This is EffectiveFetchStrategy, a member of class MemberFrontsidePolicy.

See Also
MemberFrontsidePolicy Class
Eco.Framework.Impl.Frontside Namespace


MemberFrontsidePolicy.Feature Property

MemberFrontsidePolicy.Feature Property
MemberFrontsidePolicy Class Eco.Framework.Impl.Frontside Namespace See Also
Collapse All
C#
public abstract IStructuralFeature Feature;
Remarks

This is Feature, a member of class MemberFrontsidePolicy.

See Also
MemberFrontsidePolicy Class
Eco.Framework.Impl.Frontside Namespace


MemberFrontsidePolicy.Owner Property

MemberFrontsidePolicy.Owner Property
MemberFrontsidePolicy Class Eco.Framework.Impl.Frontside Namespace See Also
Collapse All
C#
public ClassFrontsidePolicy Owner;
Remarks

This is Owner, a member of class MemberFrontsidePolicy.

See Also
MemberFrontsidePolicy Class
Eco.Framework.Impl.Frontside Namespace


MemberFrontsidePolicy.TypeHandlesNull Property

MemberFrontsidePolicy.TypeHandlesNull Property
MemberFrontsidePolicy Class Eco.Framework.Impl.Frontside Namespace See Also
Collapse All
C#
public bool TypeHandlesNull;
Remarks

This is TypeHandlesNull, a member of class MemberFrontsidePolicy.

See Also
MemberFrontsidePolicy Class
Eco.Framework.Impl.Frontside Namespace


MemberFrontsidePolicy.UseGetter Property

MemberFrontsidePolicy.UseGetter Property
MemberFrontsidePolicy Class Eco.Framework.Impl.Frontside Namespace See Also
Collapse All
C#
public bool UseGetter;
Remarks

This is UseGetter, a member of class MemberFrontsidePolicy.

See Also
MemberFrontsidePolicy Class
Eco.Framework.Impl.Frontside Namespace


MemberFrontsidePolicy.UseSetter Property

MemberFrontsidePolicy.UseSetter Property
MemberFrontsidePolicy Class Eco.Framework.Impl.Frontside Namespace See Also
Collapse All
C#
public bool UseSetter;
Remarks

This is UseSetter, a member of class MemberFrontsidePolicy.

See Also
MemberFrontsidePolicy Class
Eco.Framework.Impl.Frontside Namespace


MemberPropertyAdapter Class

MemberPropertyAdapter Class
Inheritance Hierarchy See Also
Collapse All
C#
public abstract class MemberPropertyAdapter : IProperty, IElement;
Remarks

This is class Eco.Framework.Impl.Frontside.MemberPropertyAdapter.

Inheritance Hierarchy
Eco.Framework.Impl.Frontside.MemberPropertyAdapter
    Eco.Framework.Impl.Frontside.AttributePropertyAdapter
    Eco.Framework.Impl.Frontside.ObjectListPropertyAdapter
    Eco.Framework.Impl.Frontside.ObjectReferencePropertyAdapter
File

MemberPropertyAdapter.cs

See Also
Inheritance Hierarchy


MemberPropertyAdapter.MemberPropertyAdapter Constructor

MemberPropertyAdapter.MemberPropertyAdapter Constructor
MemberPropertyAdapter Class Eco.Framework.Impl.Frontside Namespace See Also
Collapse All
C#
public MemberPropertyAdapter(
    Eco.Cache.Locator locator,
    MemberFrontsidePolicy memberPolicy
);
Remarks

This is MemberPropertyAdapter, a member of class MemberPropertyAdapter.

See Also
MemberPropertyAdapter Class
Eco.Framework.Impl.Frontside Namespace


MemberPropertyAdapter Methods

MemberPropertyAdapter Methods
Protected Methods Public Methods
Collapse All

The methods of the MemberPropertyAdapter class are listed here.

Protected Methods
Name | Description
AutoSubscribe | This is AutoSubscribe, a member of class MemberPropertyAdapter.
GetAsObject | This is GetAsObject, a member of class MemberPropertyAdapter.
Top
Public Methods
Name | Description
Assign | This is Assign, a member of class MemberPropertyAdapter.
CloneValue | This is CloneValue, a member of class MemberPropertyAdapter.
GetAsCollection | This is GetAsCollection, a member of class MemberPropertyAdapter.
GetAsIList | This is GetAsIList, a member of class MemberPropertyAdapter.
GetIsEqualHashCode | This is GetIsEqualHashCode, a member of class MemberPropertyAdapter.
GetValue | This is GetValue, a member of class MemberPropertyAdapter.
IsEqual | This is IsEqual, a member of class MemberPropertyAdapter.
SetValue | This is SetValue, a member of class MemberPropertyAdapter.
SubscribeToValue | This is SubscribeToValue, a member of class MemberPropertyAdapter.


MemberPropertyAdapter.Assign Method

MemberPropertyAdapter.Assign Method
MemberPropertyAdapter Class Eco.Framework.Impl.Frontside Namespace See Also
Collapse All
C#
public abstract void Assign(
    IElement element
);
Remarks

This is Assign, a member of class MemberPropertyAdapter.

See Also
MemberPropertyAdapter Class
Eco.Framework.Impl.Frontside Namespace


MemberPropertyAdapter.AutoSubscribe Method

MemberPropertyAdapter.AutoSubscribe Method
MemberPropertyAdapter Class Eco.Framework.Impl.Frontside Namespace See Also
Collapse All
C#
protected void AutoSubscribe();
Remarks

This is AutoSubscribe, a member of class MemberPropertyAdapter.

See Also
MemberPropertyAdapter Class
Eco.Framework.Impl.Frontside Namespace


MemberPropertyAdapter.CloneValue Method

MemberPropertyAdapter.CloneValue Method
MemberPropertyAdapter Class Eco.Framework.Impl.Frontside Namespace See Also
Collapse All
C#
public abstract IElement CloneValue(
    bool __readonly
);
Remarks

This is CloneValue, a member of class MemberPropertyAdapter.

See Also
MemberPropertyAdapter Class
Eco.Framework.Impl.Frontside Namespace


MemberPropertyAdapter.GetAsCollection Method

MemberPropertyAdapter.GetAsCollection Method
MemberPropertyAdapter Class Eco.Framework.Impl.Frontside Namespace See Also
Collapse All
C#
public abstract IElementCollection GetAsCollection();
Remarks

This is GetAsCollection, a member of class MemberPropertyAdapter.

See Also
MemberPropertyAdapter Class
Eco.Framework.Impl.Frontside Namespace


MemberPropertyAdapter.GetAsIList Method

MemberPropertyAdapter.GetAsIList Method
MemberPropertyAdapter Class Eco.Framework.Impl.Frontside Namespace See Also
Collapse All
C#
public abstract IList<T> GetAsIList<T>();
Remarks

This is GetAsIList, a member of class MemberPropertyAdapter.

See Also
MemberPropertyAdapter Class
Eco.Framework.Impl.Frontside Namespace


MemberPropertyAdapter.GetAsObject Method

MemberPropertyAdapter.GetAsObject Method
MemberPropertyAdapter Class Eco.Framework.Impl.Frontside Namespace See Also
Collapse All
C#
protected object GetAsObject();
Remarks

This is GetAsObject, a member of class MemberPropertyAdapter.

See Also
MemberPropertyAdapter Class
Eco.Framework.Impl.Frontside Namespace


MemberPropertyAdapter.GetIsEqualHashCode Method

MemberPropertyAdapter.GetIsEqualHashCode Method
MemberPropertyAdapter Class Eco.Framework.Impl.Frontside Namespace See Also
Collapse All
C#
public abstract int GetIsEqualHashCode();
Remarks

This is GetIsEqualHashCode, a member of class MemberPropertyAdapter.

See Also
MemberPropertyAdapter Class
Eco.Framework.Impl.Frontside Namespace


MemberPropertyAdapter.GetValue Method

MemberPropertyAdapter.GetValue Method
MemberPropertyAdapter Class Eco.Framework.Impl.Frontside Namespace See Also
Collapse All
C#
public virtual T GetValue<T>();
Remarks

This is GetValue, a member of class MemberPropertyAdapter.

See Also
MemberPropertyAdapter Class
Eco.Framework.Impl.Frontside Namespace


MemberPropertyAdapter.IsEqual Method

MemberPropertyAdapter.IsEqual Method
MemberPropertyAdapter Class Eco.Framework.Impl.Frontside Namespace See Also
Collapse All
C#
public abstract bool IsEqual(
    IElement Element
);
Remarks

This is IsEqual, a member of class MemberPropertyAdapter.

See Also
MemberPropertyAdapter Class
Eco.Framework.Impl.Frontside Namespace


MemberPropertyAdapter.SetValue Method

MemberPropertyAdapter.SetValue Method
MemberPropertyAdapter Class Eco.Framework.Impl.Frontside Namespace See Also
Collapse All
C#
public void SetValue<T>(
    T value
);
Remarks

This is SetValue, a member of class MemberPropertyAdapter.

See Also
MemberPropertyAdapter Class
Eco.Framework.Impl.Frontside Namespace


MemberPropertyAdapter.SubscribeToValue Method

MemberPropertyAdapter.SubscribeToValue Method
MemberPropertyAdapter Class Eco.Framework.Impl.Frontside Namespace See Also
Collapse All
C#
public void SubscribeToValue(
    ISubscriber subscriber
);
Remarks

This is SubscribeToValue, a member of class MemberPropertyAdapter.

See Also
MemberPropertyAdapter Class
Eco.Framework.Impl.Frontside Namespace


MemberPropertyAdapter Properties

MemberPropertyAdapter Properties
Public Properties Protected Properties
Collapse All

The properties of the MemberPropertyAdapter class are listed here.

Public Properties
Name | Description
AsObject | This is AsObject, a member of class MemberPropertyAdapter.
ContentType | This is ContentType, a member of class MemberPropertyAdapter.
IsProperty | This is IsProperty, a member of class MemberPropertyAdapter.
Mutable | This is Mutable, a member of class MemberPropertyAdapter.
Owner | This is Owner, a member of class MemberPropertyAdapter.
ReadOnly | This is ReadOnly, a member of class MemberPropertyAdapter.
ServiceProvider | This is ServiceProvider, a member of class MemberPropertyAdapter.
StructuralFeature | This is StructuralFeature, a member of class MemberPropertyAdapter.
UmlType | This is UmlType, a member of class MemberPropertyAdapter.
Top
Protected Properties
Name | Description
FrontsidePolicy | This is FrontsidePolicy, a member of class MemberPropertyAdapter.
Locator | This is Locator, a member of class MemberPropertyAdapter.
MemberPolicy | This is MemberPolicy, a member of class MemberPropertyAdapter.


MemberPropertyAdapter.AsObject Property

MemberPropertyAdapter.AsObject Property
MemberPropertyAdapter Class Eco.Framework.Impl.Frontside Namespace See Also
Collapse All
C#
public virtual object AsObject;
Remarks

This is AsObject, a member of class MemberPropertyAdapter.

See Also
MemberPropertyAdapter Class
Eco.Framework.Impl.Frontside Namespace


MemberPropertyAdapter.ContentType Property

MemberPropertyAdapter.ContentType Property
MemberPropertyAdapter Class Eco.Framework.Impl.Frontside Namespace See Also
Collapse All
C#
public abstract ContentType ContentType;
Remarks

This is ContentType, a member of class MemberPropertyAdapter.

See Also
MemberPropertyAdapter Class
Eco.Framework.Impl.Frontside Namespace


MemberPropertyAdapter.FrontsidePolicy Property

MemberPropertyAdapter.FrontsidePolicy Property
MemberPropertyAdapter Class Eco.Framework.Impl.Frontside Namespace See Also
Collapse All
C#
protected DefaultFrontsidePolicy FrontsidePolicy;
Remarks

This is FrontsidePolicy, a member of class MemberPropertyAdapter.

See Also
MemberPropertyAdapter Class
Eco.Framework.Impl.Frontside Namespace


MemberPropertyAdapter.IsProperty Property

MemberPropertyAdapter.IsProperty Property
MemberPropertyAdapter Class Eco.Framework.Impl.Frontside Namespace See Also
Collapse All
C#
public bool IsProperty;
Remarks

This is IsProperty, a member of class MemberPropertyAdapter.

See Also
MemberPropertyAdapter Class
Eco.Framework.Impl.Frontside Namespace


MemberPropertyAdapter.Locator Property

MemberPropertyAdapter.Locator Property
MemberPropertyAdapter Class Eco.Framework.Impl.Frontside Namespace See Also
Collapse All
C#
protected DefaultFrontsideLocator Locator;
Remarks

This is Locator, a member of class MemberPropertyAdapter.

See Also
MemberPropertyAdapter Class
Eco.Framework.Impl.Frontside Namespace


MemberPropertyAdapter.MemberPolicy Property

MemberPropertyAdapter.MemberPolicy Property
MemberPropertyAdapter Class Eco.Framework.Impl.Frontside Namespace See Also
Collapse All
C#
protected MemberFrontsidePolicy MemberPolicy;
Remarks

This is MemberPolicy, a member of class MemberPropertyAdapter.

See Also
MemberPropertyAdapter Class
Eco.Framework.Impl.Frontside Namespace


MemberPropertyAdapter.Mutable Property

MemberPropertyAdapter.Mutable Property
MemberPropertyAdapter Class Eco.Framework.Impl.Frontside Namespace See Also
Collapse All
C#
public bool Mutable;
Remarks

This is Mutable, a member of class MemberPropertyAdapter.

See Also
MemberPropertyAdapter Class
Eco.Framework.Impl.Frontside Namespace


MemberPropertyAdapter.Owner Property

MemberPropertyAdapter.Owner Property
MemberPropertyAdapter Class Eco.Framework.Impl.Frontside Namespace See Also
Collapse All
C#
public IFeatured Owner;
Remarks

This is Owner, a member of class MemberPropertyAdapter.

See Also
MemberPropertyAdapter Class
Eco.Framework.Impl.Frontside Namespace


MemberPropertyAdapter.ReadOnly Property

MemberPropertyAdapter.ReadOnly Property
MemberPropertyAdapter Class Eco.Framework.Impl.Frontside Namespace See Also
Collapse All
C#
public bool ReadOnly;
Remarks

This is ReadOnly, a member of class MemberPropertyAdapter.

See Also
MemberPropertyAdapter Class
Eco.Framework.Impl.Frontside Namespace


MemberPropertyAdapter.ServiceProvider Property

MemberPropertyAdapter.ServiceProvider Property
MemberPropertyAdapter Class Eco.Framework.Impl.Frontside Namespace See Also
Collapse All
C#
public IEcoServiceProvider ServiceProvider;
Remarks

This is ServiceProvider, a member of class MemberPropertyAdapter.

See Also
MemberPropertyAdapter Class
Eco.Framework.Impl.Frontside Namespace


MemberPropertyAdapter.StructuralFeature Property

MemberPropertyAdapter.StructuralFeature Property
MemberPropertyAdapter Class Eco.Framework.Impl.Frontside Namespace See Also
Collapse All
C#
public IStructuralFeature StructuralFeature;
Remarks

This is StructuralFeature, a member of class MemberPropertyAdapter.

See Also
MemberPropertyAdapter Class
Eco.Framework.Impl.Frontside Namespace


MemberPropertyAdapter.UmlType Property

MemberPropertyAdapter.UmlType Property
MemberPropertyAdapter Class Eco.Framework.Impl.Frontside Namespace See Also
Collapse All
C#
public virtual IClassifier UmlType;
Remarks

This is UmlType, a member of class MemberPropertyAdapter.

See Also
MemberPropertyAdapter Class
Eco.Framework.Impl.Frontside Namespace


MultAssociationEndFrontsidePolicy Class

MultAssociationEndFrontsidePolicy Class
Inheritance Hierarchy See Also
Collapse All
C#
public abstract class MultAssociationEndFrontsidePolicy : AssociationEndFrontsidePolicy;
Remarks

This is class Eco.Framework.Impl.Frontside.MultAssociationEndFrontsidePolicy.

Inheritance Hierarchy
Eco.Framework.Impl.Frontside.MemberFrontsidePolicy
    Eco.Framework.Impl.Frontside.AssociationEndFrontsidePolicy
        Eco.Framework.Impl.Frontside.MultAssociationEndFrontsidePolicy
            Eco.Framework.Impl.Frontside.DirectMultiFrontsidePolicy
            Eco.Framework.Impl.Frontside.IndirectMultiFrontsidePolicy
            Eco.Framework.Impl.Frontside.ToInnerMultiFrontsidePolicy
File

MultiAssociationEndFrontsidePolicies.cs

See Also
Inheritance Hierarchy


MultAssociationEndFrontsidePolicy.MultAssociationEndFrontsidePolicy Constructor

MultAssociationEndFrontsidePolicy.MultAssociationEndFrontsidePolicy Constructor
MultAssociationEndFrontsidePolicy Class Eco.Framework.Impl.Frontside Namespace See Also
Collapse All
C#
public MultAssociationEndFrontsidePolicy(
    IAssociationEnd assocEnd,
    ClassFrontsidePolicy owner
);
Remarks

This is MultAssociationEndFrontsidePolicy, a member of class MultAssociationEndFrontsidePolicy.

See Also
MultAssociationEndFrontsidePolicy Class
Eco.Framework.Impl.Frontside Namespace


MultAssociationEndFrontsidePolicy Methods

MultAssociationEndFrontsidePolicy Methods
Protected Methods Public Methods
Collapse All

The methods of the MultAssociationEndFrontsidePolicy class are listed here.

Protected Methods
Name | Description
GetEnsuredCurrentList | This is GetEnsuredCurrentList, a member of class MultAssociationEndFrontsidePolicy.
Reorder | This is Reorder, a member of class MultAssociationEndFrontsidePolicy.
Top
Public Methods
Name | Description
Add | This is Add, a member of class MultAssociationEndFrontsidePolicy.
ApplyMemberValue | This is ApplyMemberValue, a member of class MultAssociationEndFrontsidePolicy.
Clear | This is Clear, a member of class MultAssociationEndFrontsidePolicy.
Contains | This is Contains, a member of class MultAssociationEndFrontsidePolicy.
GetCount | This is GetCount, a member of class MultAssociationEndFrontsidePolicy.
GetItem | This is GetItem, a member of class MultAssociationEndFrontsidePolicy.
GetPropertyAdapter | This is GetPropertyAdapter, a member of class MultAssociationEndFrontsidePolicy.
IndexOf | This is IndexOf, a member of class MultAssociationEndFrontsidePolicy.
Insert | This is Insert, a member of class MultAssociationEndFrontsidePolicy.
Remove | This is Remove, a member of class MultAssociationEndFrontsidePolicy.
RemoveAt | This is RemoveAt, a member of class MultAssociationEndFrontsidePolicy.
RetrieveMemberValue | This is RetrieveMemberValue, a member of class MultAssociationEndFrontsidePolicy.
SetItem | This is SetItem, a member of class MultAssociationEndFrontsidePolicy.


MultAssociationEndFrontsidePolicy.Add Method

MultAssociationEndFrontsidePolicy.Add Method
MultAssociationEndFrontsidePolicy Class Eco.Framework.Impl.Frontside Namespace See Also
Collapse All
C#
public abstract int Add(
    Locator locator,
    object value
);
Remarks

This is Add, a member of class MultAssociationEndFrontsidePolicy.

See Also
MultAssociationEndFrontsidePolicy Class
Eco.Framework.Impl.Frontside Namespace


MultAssociationEndFrontsidePolicy.ApplyMemberValue Method

MultAssociationEndFrontsidePolicy.ApplyMemberValue Method
MultAssociationEndFrontsidePolicy Class Eco.Framework.Impl.Frontside Namespace See Also
Collapse All
C#
public override void ApplyMemberValue(
    Locator locator,
    object value,
    bool CallerStateMachine
);
Remarks

This is ApplyMemberValue, a member of class MultAssociationEndFrontsidePolicy.

See Also
MultAssociationEndFrontsidePolicy Class
Eco.Framework.Impl.Frontside Namespace


MultAssociationEndFrontsidePolicy.Clear Method

MultAssociationEndFrontsidePolicy.Clear Method
MultAssociationEndFrontsidePolicy Class Eco.Framework.Impl.Frontside Namespace See Also
Collapse All
C#
public abstract void Clear(
    Locator locator
);
Remarks

This is Clear, a member of class MultAssociationEndFrontsidePolicy.

See Also
MultAssociationEndFrontsidePolicy Class
Eco.Framework.Impl.Frontside Namespace


MultAssociationEndFrontsidePolicy.Contains Method

MultAssociationEndFrontsidePolicy.Contains Method
MultAssociationEndFrontsidePolicy Class Eco.Framework.Impl.Frontside Namespace See Also
Collapse All
C#
public bool Contains(
    Locator locator,
    object value
);
Remarks

This is Contains, a member of class MultAssociationEndFrontsidePolicy.

See Also
MultAssociationEndFrontsidePolicy Class
Eco.Framework.Impl.Frontside Namespace


MultAssociationEndFrontsidePolicy.GetCount Method

MultAssociationEndFrontsidePolicy.GetCount Method
MultAssociationEndFrontsidePolicy Class Eco.Framework.Impl.Frontside Namespace See Also
Collapse All
C#
public int GetCount(
    Locator locator
);
Remarks

This is GetCount, a member of class MultAssociationEndFrontsidePolicy.

See Also
MultAssociationEndFrontsidePolicy Class
Eco.Framework.Impl.Frontside Namespace


MultAssociationEndFrontsidePolicy.GetEnsuredCurrentList Method

MultAssociationEndFrontsidePolicy.GetEnsuredCurrentList Method
MultAssociationEndFrontsidePolicy Class Eco.Framework.Impl.Frontside Namespace See Also
Collapse All
C#
protected IList GetEnsuredCurrentList(
    Locator locator
);
Remarks

This is GetEnsuredCurrentList, a member of class MultAssociationEndFrontsidePolicy.

See Also
MultAssociationEndFrontsidePolicy Class
Eco.Framework.Impl.Frontside Namespace


MultAssociationEndFrontsidePolicy.GetItem Method

MultAssociationEndFrontsidePolicy.GetItem Method
MultAssociationEndFrontsidePolicy Class Eco.Framework.Impl.Frontside Namespace See Also
Collapse All
C#
public object GetItem(
    Locator locator,
    int index
);
Remarks

This is GetItem, a member of class MultAssociationEndFrontsidePolicy.

See Also
MultAssociationEndFrontsidePolicy Class
Eco.Framework.Impl.Frontside Namespace


MultAssociationEndFrontsidePolicy.GetPropertyAdapter Method

MultAssociationEndFrontsidePolicy.GetPropertyAdapter Method
MultAssociationEndFrontsidePolicy Class Eco.Framework.Impl.Frontside Namespace See Also
Collapse All
C#
public override IProperty GetPropertyAdapter(
    DefaultFrontsideLocator locator
);
Remarks

This is GetPropertyAdapter, a member of class MultAssociationEndFrontsidePolicy.

See Also
MultAssociationEndFrontsidePolicy Class
Eco.Framework.Impl.Frontside Namespace


MultAssociationEndFrontsidePolicy.IndexOf Method

MultAssociationEndFrontsidePolicy.IndexOf Method
MultAssociationEndFrontsidePolicy Class Eco.Framework.Impl.Frontside Namespace See Also
Collapse All
C#
public int IndexOf(
    Locator locator,
    object value
);
Remarks

This is IndexOf, a member of class MultAssociationEndFrontsidePolicy.

See Also
MultAssociationEndFrontsidePolicy Class
Eco.Framework.Impl.Frontside Namespace


MultAssociationEndFrontsidePolicy.Insert Method

MultAssociationEndFrontsidePolicy.Insert Method
MultAssociationEndFrontsidePolicy Class Eco.Framework.Impl.Frontside Namespace See Also
Collapse All
C#
public abstract void Insert(
    Locator locator,
    int index,
    object value
);
Remarks

This is Insert, a member of class MultAssociationEndFrontsidePolicy.

See Also
MultAssociationEndFrontsidePolicy Class
Eco.Framework.Impl.Frontside Namespace


MultAssociationEndFrontsidePolicy.Remove Method

MultAssociationEndFrontsidePolicy.Remove Method
MultAssociationEndFrontsidePolicy Class Eco.Framework.Impl.Frontside Namespace See Also
Collapse All
C#
public abstract void Remove(
    Locator locator,
    object value
);
Remarks

This is Remove, a member of class MultAssociationEndFrontsidePolicy.

See Also
MultAssociationEndFrontsidePolicy Class
Eco.Framework.Impl.Frontside Namespace


MultAssociationEndFrontsidePolicy.RemoveAt Method

MultAssociationEndFrontsidePolicy.RemoveAt Method
MultAssociationEndFrontsidePolicy Class Eco.Framework.Impl.Frontside Namespace See Also
Collapse All
C#
public abstract void RemoveAt(
    Locator locator,
    int index
);
Remarks

This is RemoveAt, a member of class MultAssociationEndFrontsidePolicy.

See Also
MultAssociationEndFrontsidePolicy Class
Eco.Framework.Impl.Frontside Namespace


MultAssociationEndFrontsidePolicy.Reorder Method

MultAssociationEndFrontsidePolicy.Reorder Method
MultAssociationEndFrontsidePolicy Class Eco.Framework.Impl.Frontside Namespace See Also
Collapse All
C#
protected void Reorder(
    IList<Locator> Locators,
    MemberFrontsidePolicy singleEndPolicy
);
Remarks

This is Reorder, a member of class MultAssociationEndFrontsidePolicy.

See Also
MultAssociationEndFrontsidePolicy Class
Eco.Framework.Impl.Frontside Namespace


MultAssociationEndFrontsidePolicy.RetrieveMemberValue Method

MultAssociationEndFrontsidePolicy.RetrieveMemberValue Method
MultAssociationEndFrontsidePolicy Class Eco.Framework.Impl.Frontside Namespace See Also
Collapse All
C#
public override object RetrieveMemberValue(
    DefaultFrontsideLocator locator
);
Remarks

This is RetrieveMemberValue, a member of class MultAssociationEndFrontsidePolicy.

See Also
MultAssociationEndFrontsidePolicy Class
Eco.Framework.Impl.Frontside Namespace


MultAssociationEndFrontsidePolicy.SetItem Method

MultAssociationEndFrontsidePolicy.SetItem Method
MultAssociationEndFrontsidePolicy Class Eco.Framework.Impl.Frontside Namespace See Also
Collapse All
C#
public abstract void SetItem(
    Locator locator,
    int index,
    object value
);
Remarks

This is SetItem, a member of class MultAssociationEndFrontsidePolicy.

See Also
MultAssociationEndFrontsidePolicy Class
Eco.Framework.Impl.Frontside Namespace


MultiLinkAdapterEnumerator Class

MultiLinkAdapterEnumerator Class
Inheritance Hierarchy See Also
Collapse All
C#
public class MultiLinkAdapterEnumerator<T> : object, IEnumerator<T>;
Remarks

This is class Eco.Framework.Impl.Frontside.MultiLinkAdapterEnumerator.

Inheritance Hierarchy
Eco.Framework.Impl.Frontside.MultiLinkAdapterEnumerator
File

FrontsideMultilinkAdapters.cs

See Also
Inheritance Hierarchy


MultiLinkAdapterEnumerator.MultiLinkAdapterEnumerator Constructor

MultiLinkAdapterEnumerator.MultiLinkAdapterEnumerator Constructor
MultiLinkAdapterEnumerator Class Eco.Framework.Impl.Frontside Namespace See Also
Collapse All
C#
public MultiLinkAdapterEnumerator(
    IList<T> Adapter
);
Remarks

This is MultiLinkAdapterEnumerator, a member of class MultiLinkAdapterEnumerator.

See Also
MultiLinkAdapterEnumerator Class
Eco.Framework.Impl.Frontside Namespace


MultiLinkAdapterEnumerator Methods

MultiLinkAdapterEnumerator Methods
Public Methods
Collapse All

The methods of the MultiLinkAdapterEnumerator class are listed here.

Public Methods
Name | Description
Dispose | This is Dispose, a member of class MultiLinkAdapterEnumerator.
MoveNext | This is MoveNext, a member of class MultiLinkAdapterEnumerator.
Reset | This is Reset, a member of class MultiLinkAdapterEnumerator.


MultiLinkAdapterEnumerator.Dispose Method

MultiLinkAdapterEnumerator.Dispose Method
MultiLinkAdapterEnumerator Class Eco.Framework.Impl.Frontside Namespace See Also
Collapse All
C#
public void Dispose();
Remarks

This is Dispose, a member of class MultiLinkAdapterEnumerator.

See Also
MultiLinkAdapterEnumerator Class
Eco.Framework.Impl.Frontside Namespace


MultiLinkAdapterEnumerator.MoveNext Method

MultiLinkAdapterEnumerator.MoveNext Method
MultiLinkAdapterEnumerator Class Eco.Framework.Impl.Frontside Namespace See Also
Collapse All
C#
public bool MoveNext();
Remarks

This is MoveNext, a member of class MultiLinkAdapterEnumerator.

See Also
MultiLinkAdapterEnumerator Class
Eco.Framework.Impl.Frontside Namespace


MultiLinkAdapterEnumerator.Reset Method

MultiLinkAdapterEnumerator.Reset Method
MultiLinkAdapterEnumerator Class Eco.Framework.Impl.Frontside Namespace See Also
Collapse All
C#
public void Reset();
Remarks

This is Reset, a member of class MultiLinkAdapterEnumerator.

See Also
MultiLinkAdapterEnumerator Class
Eco.Framework.Impl.Frontside Namespace


MultiLinkAdapterEnumerator Properties

MultiLinkAdapterEnumerator Properties
Public Properties
Collapse All

The properties of the MultiLinkAdapterEnumerator class are listed here.

Public Properties
Name | Description
Current | This is Current, a member of class MultiLinkAdapterEnumerator.


MultiLinkAdapterEnumerator.Current Property

MultiLinkAdapterEnumerator.Current Property
MultiLinkAdapterEnumerator Class Eco.Framework.Impl.Frontside Namespace See Also
Collapse All
C#
public T Current;
Remarks

This is Current, a member of class MultiLinkAdapterEnumerator.

See Also
MultiLinkAdapterEnumerator Class
Eco.Framework.Impl.Frontside Namespace


MultiMultiFrontsidePolicy Class

MultiMultiFrontsidePolicy Class
Inheritance Hierarchy See Also
Collapse All
C#
public sealed class MultiMultiFrontsidePolicy : IndirectMultiFrontsidePolicy;
Remarks

This is class Eco.Framework.Impl.Frontside.MultiMultiFrontsidePolicy.

Inheritance Hierarchy
Eco.Framework.Impl.Frontside.MemberFrontsidePolicy
    Eco.Framework.Impl.Frontside.AssociationEndFrontsidePolicy
        Eco.Framework.Impl.Frontside.MultAssociationEndFrontsidePolicy
            Eco.Framework.Impl.Frontside.IndirectMultiFrontsidePolicy
                Eco.Framework.Impl.Frontside.MultiMultiFrontsidePolicy
File

MultiAssociationEndFrontsidePolicies.cs

See Also
Inheritance Hierarchy


MultiMultiFrontsidePolicy.MultiMultiFrontsidePolicy Constructor

MultiMultiFrontsidePolicy.MultiMultiFrontsidePolicy Constructor
MultiMultiFrontsidePolicy Class Eco.Framework.Impl.Frontside Namespace See Also
Collapse All
C#
public MultiMultiFrontsidePolicy(
    IAssociationEnd assocEnd,
    ClassFrontsidePolicy owner
);
Remarks

This is MultiMultiFrontsidePolicy, a member of class MultiMultiFrontsidePolicy.

See Also
MultiMultiFrontsidePolicy Class
Eco.Framework.Impl.Frontside Namespace


NonDeletableReason Class

NonDeletableReason Class
Inheritance Hierarchy See Also
Collapse All
C#
public class NonDeletableReason : INonDeletableReason;
Remarks

This is class Eco.Framework.Impl.Frontside.NonDeletableReason.

Inheritance Hierarchy
Eco.Framework.Impl.Frontside.NonDeletableReason
File

DefaultCacheAndFrontsideLocator.cs

See Also
Inheritance Hierarchy


NonDeletableReason.NonDeletableReason Constructor

NonDeletableReason.NonDeletableReason Constructor
NonDeletableReason Class Eco.Framework.Impl.Frontside Namespace See Also
Collapse All
C#
public NonDeletableReason(
    IObjectInstance obj,
    IAssociationEnd associationEnd
);
Remarks

This is NonDeletableReason, a member of class NonDeletableReason.

See Also
NonDeletableReason Class
Eco.Framework.Impl.Frontside Namespace


NonDeletableReason Properties

NonDeletableReason Properties
Public Properties
Collapse All

The properties of the NonDeletableReason class are listed here.

Public Properties
Name | Description
AssociationEnd | This is AssociationEnd, a member of class NonDeletableReason.
Obj | This is Obj, a member of class NonDeletableReason.


NonDeletableReason.AssociationEnd Property

NonDeletableReason.AssociationEnd Property
NonDeletableReason Class Eco.Framework.Impl.Frontside Namespace See Also
Collapse All
C#
public IAssociationEnd AssociationEnd;
Remarks

This is AssociationEnd, a member of class NonDeletableReason.

See Also
NonDeletableReason Class
Eco.Framework.Impl.Frontside Namespace


NonDeletableReason.Obj Property

NonDeletableReason.Obj Property
NonDeletableReason Class Eco.Framework.Impl.Frontside Namespace See Also
Collapse All
C#
public IObjectInstance Obj;
Remarks

This is Obj, a member of class NonDeletableReason.

See Also
NonDeletableReason Class
Eco.Framework.Impl.Frontside Namespace


ObjectListPropertyAdapter Class

ObjectListPropertyAdapter Class
Inheritance Hierarchy See Also
Collapse All
C#
public class ObjectListPropertyAdapter : MemberPropertyAdapter, IObjectList, IElementCollection;
Remarks

This is class Eco.Framework.Impl.Frontside.ObjectListPropertyAdapter.

Inheritance Hierarchy
Eco.Framework.Impl.Frontside.MemberPropertyAdapter
    Eco.Framework.Impl.Frontside.ObjectListPropertyAdapter
File

ObjectListPropertyAdapter.cs

See Also
Inheritance Hierarchy


ObjectListPropertyAdapter.ObjectListPropertyAdapter Constructor

ObjectListPropertyAdapter.ObjectListPropertyAdapter Constructor
ObjectListPropertyAdapter Class Eco.Framework.Impl.Frontside Namespace See Also
Collapse All
C#
public ObjectListPropertyAdapter(
    Eco.Cache.Locator Locator,
    MemberFrontsidePolicy memberPolicy
);
Remarks

This is ObjectListPropertyAdapter, a member of class ObjectListPropertyAdapter.

See Also
ObjectListPropertyAdapter Class
Eco.Framework.Impl.Frontside Namespace


ObjectListPropertyAdapter Methods

ObjectListPropertyAdapter Methods
Public Methods
Collapse All

The methods of the ObjectListPropertyAdapter class are listed here.

Public Methods
Name | Description
Add | This is Add, a member of class ObjectListPropertyAdapter.
AddNew | This is AddNew, a member of class ObjectListPropertyAdapter.
AssertedIObject | This is AssertedIObject, a member of class ObjectListPropertyAdapter.
Assign | This is Assign, a member of class ObjectListPropertyAdapter.
Clear | This is Clear, a member of class ObjectListPropertyAdapter.
CloneValue | IElement
Contains | This is Contains, a member of class ObjectListPropertyAdapter.
CopyTo | This is CopyTo, a member of class ObjectListPropertyAdapter.
EnsureIdsOnly | This is EnsureIdsOnly, a member of class ObjectListPropertyAdapter.
EnsureObjects | This is EnsureObjects, a member of class ObjectListPropertyAdapter.
EnsureRange | This is EnsureRange, a member of class ObjectListPropertyAdapter.
EnsureRelatedObjects | This is EnsureRelatedObjects, a member of class ObjectListPropertyAdapter.
GetAsCollection | This is GetAsCollection, a member of class ObjectListPropertyAdapter.
GetAsEcoList | This is GetAsEcoList, a member of class ObjectListPropertyAdapter.
GetAsIList | This is GetAsIList, a member of class ObjectListPropertyAdapter.
GetAsList | This is GetAsList, a member of class ObjectListPropertyAdapter.
GetEnumerator | This is GetEnumerator, a member of class ObjectListPropertyAdapter.
GetIsEqualHashCode | This is GetIsEqualHashCode, a member of class ObjectListPropertyAdapter.
GetValue | This is GetValue, a member of class ObjectListPropertyAdapter.
IndexOf | This is IndexOf, a member of class ObjectListPropertyAdapter.
Insert | This is Insert, a member of class ObjectListPropertyAdapter.
InternalGet | This is InternalGet, a member of class ObjectListPropertyAdapter.
IsEqual | This is IsEqual, a member of class ObjectListPropertyAdapter.
Move | This is Move, a member of class ObjectListPropertyAdapter.
Remove | This is Remove, a member of class ObjectListPropertyAdapter.
RemoveAt | This is RemoveAt, a member of class ObjectListPropertyAdapter.
this | IObjectList


ObjectListPropertyAdapter.Add Method

ObjectListPropertyAdapter.Add Method
ObjectListPropertyAdapter Class Eco.Framework.Impl.Frontside Namespace See Also
Collapse All
C#
public void Add(
    IEcoObject value
);
Remarks

This is Add, a member of class ObjectListPropertyAdapter.

See Also
ObjectListPropertyAdapter Class
Eco.Framework.Impl.Frontside Namespace


ObjectListPropertyAdapter.AddNew Method

ObjectListPropertyAdapter.AddNew Method
ObjectListPropertyAdapter Class Eco.Framework.Impl.Frontside Namespace See Also
Collapse All
C#
public IElement AddNew();
Remarks

This is AddNew, a member of class ObjectListPropertyAdapter.

See Also
ObjectListPropertyAdapter Class
Eco.Framework.Impl.Frontside Namespace


ObjectListPropertyAdapter.AssertedIObject Method

ObjectListPropertyAdapter.AssertedIObject Method
ObjectListPropertyAdapter Class Eco.Framework.Impl.Frontside Namespace See Also
Collapse All
C#
public static IObject AssertedIObject(
    IElement value
);
Remarks

This is AssertedIObject, a member of class ObjectListPropertyAdapter.

See Also
ObjectListPropertyAdapter Class
Eco.Framework.Impl.Frontside Namespace


ObjectListPropertyAdapter.Assign Method

ObjectListPropertyAdapter.Assign Method
ObjectListPropertyAdapter Class Eco.Framework.Impl.Frontside Namespace See Also
Collapse All
C#
public override void Assign(
    IElement Element
);
Remarks

This is Assign, a member of class ObjectListPropertyAdapter.

See Also
ObjectListPropertyAdapter Class
Eco.Framework.Impl.Frontside Namespace


ObjectListPropertyAdapter.Clear Method

ObjectListPropertyAdapter.Clear Method
ObjectListPropertyAdapter Class Eco.Framework.Impl.Frontside Namespace See Also
Collapse All
C#
public void Clear();
Remarks

This is Clear, a member of class ObjectListPropertyAdapter.

See Also
ObjectListPropertyAdapter Class
Eco.Framework.Impl.Frontside Namespace


ObjectListPropertyAdapter.CloneValue Method

ObjectListPropertyAdapter.CloneValue Method
ObjectListPropertyAdapter Class Eco.Framework.Impl.Frontside Namespace See Also
Collapse All
C#
public override IElement CloneValue(
    bool readOnly
);
Remarks

IElement

See Also
ObjectListPropertyAdapter Class
Eco.Framework.Impl.Frontside Namespace


ObjectListPropertyAdapter.Contains Method

ObjectListPropertyAdapter.Contains Method
ObjectListPropertyAdapter Class Eco.Framework.Impl.Frontside Namespace See Also
Collapse All
C#
public bool Contains(
    IEcoObject value
);
Remarks

This is Contains, a member of class ObjectListPropertyAdapter.

See Also
ObjectListPropertyAdapter Class
Eco.Framework.Impl.Frontside Namespace


ObjectListPropertyAdapter.CopyTo Method

ObjectListPropertyAdapter.CopyTo Method
ObjectListPropertyAdapter Class Eco.Framework.Impl.Frontside Namespace See Also
Collapse All
C#
public void CopyTo(
    System.Array array_,
    int index
);
Remarks

This is CopyTo, a member of class ObjectListPropertyAdapter.

See Also
ObjectListPropertyAdapter Class
Eco.Framework.Impl.Frontside Namespace


ObjectListPropertyAdapter.EnsureIdsOnly Method

ObjectListPropertyAdapter.EnsureIdsOnly Method
ObjectListPropertyAdapter Class Eco.Framework.Impl.Frontside Namespace See Also
Collapse All
C#
public void EnsureIdsOnly();
Remarks

This is EnsureIdsOnly, a member of class ObjectListPropertyAdapter.

See Also
ObjectListPropertyAdapter Class
Eco.Framework.Impl.Frontside Namespace


ObjectListPropertyAdapter.EnsureObjects Method

ObjectListPropertyAdapter.EnsureObjects Method
ObjectListPropertyAdapter Class Eco.Framework.Impl.Frontside Namespace See Also
Collapse All
C#
public void EnsureObjects();
Remarks

This is EnsureObjects, a member of class ObjectListPropertyAdapter.

See Also
ObjectListPropertyAdapter Class
Eco.Framework.Impl.Frontside Namespace


ObjectListPropertyAdapter.EnsureRange Method

ObjectListPropertyAdapter.EnsureRange Method
ObjectListPropertyAdapter Class Eco.Framework.Impl.Frontside Namespace See Also
Collapse All
C#
public void EnsureRange(
    int FromIndex,
    int ToIndex
);
Remarks

This is EnsureRange, a member of class ObjectListPropertyAdapter.

See Also
ObjectListPropertyAdapter Class
Eco.Framework.Impl.Frontside Namespace


ObjectListPropertyAdapter.EnsureRelatedObjects Method

ObjectListPropertyAdapter.EnsureRelatedObjects Method
ObjectListPropertyAdapter Class Eco.Framework.Impl.Frontside Namespace See Also
Collapse All
C#
public IObjectList EnsureRelatedObjects(
    string MemberName
);
Remarks

This is EnsureRelatedObjects, a member of class ObjectListPropertyAdapter.

See Also
ObjectListPropertyAdapter Class
Eco.Framework.Impl.Frontside Namespace


ObjectListPropertyAdapter.GetAsCollection Method

ObjectListPropertyAdapter.GetAsCollection Method
ObjectListPropertyAdapter Class Eco.Framework.Impl.Frontside Namespace See Also
Collapse All
C#
public override IElementCollection GetAsCollection();
Remarks

This is GetAsCollection, a member of class ObjectListPropertyAdapter.

See Also
ObjectListPropertyAdapter Class
Eco.Framework.Impl.Frontside Namespace


ObjectListPropertyAdapter.GetAsEcoList Method

ObjectListPropertyAdapter.GetAsEcoList Method
ObjectListPropertyAdapter Class Eco.Framework.Impl.Frontside Namespace See Also
Collapse All
C#
public IEcoList<T> GetAsEcoList<T>() where T: class, IEcoObject;
Remarks

This is GetAsEcoList, a member of class ObjectListPropertyAdapter.

See Also
ObjectListPropertyAdapter Class
Eco.Framework.Impl.Frontside Namespace


ObjectListPropertyAdapter.GetAsIList Method

ObjectListPropertyAdapter.GetAsIList Method
ObjectListPropertyAdapter Class Eco.Framework.Impl.Frontside Namespace See Also
Collapse All
C#
public override IList<T> GetAsIList<T>();
Remarks

This is GetAsIList, a member of class ObjectListPropertyAdapter.

See Also
ObjectListPropertyAdapter Class
Eco.Framework.Impl.Frontside Namespace


ObjectListPropertyAdapter.GetAsList Method

ObjectListPropertyAdapter.GetAsList Method
ObjectListPropertyAdapter Class Eco.Framework.Impl.Frontside Namespace See Also
Collapse All
C#
public IObjectList GetAsList();
Remarks

This is GetAsList, a member of class ObjectListPropertyAdapter.

See Also
ObjectListPropertyAdapter Class
Eco.Framework.Impl.Frontside Namespace


ObjectListPropertyAdapter.GetEnumerator Method

ObjectListPropertyAdapter.GetEnumerator Method
ObjectListPropertyAdapter Class Eco.Framework.Impl.Frontside Namespace See Also
Collapse All
C#
public IEnumerator GetEnumerator();
Remarks

This is GetEnumerator, a member of class ObjectListPropertyAdapter.

See Also
ObjectListPropertyAdapter Class
Eco.Framework.Impl.Frontside Namespace


ObjectListPropertyAdapter.GetIsEqualHashCode Method

ObjectListPropertyAdapter.GetIsEqualHashCode Method
ObjectListPropertyAdapter Class Eco.Framework.Impl.Frontside Namespace See Also
Collapse All
C#
public override int GetIsEqualHashCode();
Remarks

This is GetIsEqualHashCode, a member of class ObjectListPropertyAdapter.

See Also
ObjectListPropertyAdapter Class
Eco.Framework.Impl.Frontside Namespace


ObjectListPropertyAdapter.GetValue Method

ObjectListPropertyAdapter.GetValue Method
ObjectListPropertyAdapter Class Eco.Framework.Impl.Frontside Namespace See Also
Collapse All
C#
public override T GetValue<T>();
Remarks

This is GetValue, a member of class ObjectListPropertyAdapter.

See Also
ObjectListPropertyAdapter Class
Eco.Framework.Impl.Frontside Namespace


ObjectListPropertyAdapter.IndexOf Method

ObjectListPropertyAdapter.IndexOf Method
ObjectListPropertyAdapter Class Eco.Framework.Impl.Frontside Namespace See Also
Collapse All
C#
public int IndexOf(
    IEcoObject value
);
Remarks

This is IndexOf, a member of class ObjectListPropertyAdapter.

See Also
ObjectListPropertyAdapter Class
Eco.Framework.Impl.Frontside Namespace


ObjectListPropertyAdapter.Insert Method

ObjectListPropertyAdapter.Insert Method
ObjectListPropertyAdapter Class Eco.Framework.Impl.Frontside Namespace See Also
Collapse All
C#
public void Insert(
    int index,
    IEcoObject value
);
Remarks

This is Insert, a member of class ObjectListPropertyAdapter.

See Also
ObjectListPropertyAdapter Class
Eco.Framework.Impl.Frontside Namespace


ObjectListPropertyAdapter.InternalGet Method

ObjectListPropertyAdapter.InternalGet Method
ObjectListPropertyAdapter Class Eco.Framework.Impl.Frontside Namespace See Also
Collapse All
C#
public IObjectInstance InternalGet(
    int index
);
Remarks

This is InternalGet, a member of class ObjectListPropertyAdapter.

See Also
ObjectListPropertyAdapter Class
Eco.Framework.Impl.Frontside Namespace


ObjectListPropertyAdapter.IsEqual Method

ObjectListPropertyAdapter.IsEqual Method
ObjectListPropertyAdapter Class Eco.Framework.Impl.Frontside Namespace See Also
Collapse All
C#
public override bool IsEqual(
    IElement Element
);
Remarks

This is IsEqual, a member of class ObjectListPropertyAdapter.

See Also
ObjectListPropertyAdapter Class
Eco.Framework.Impl.Frontside Namespace


ObjectListPropertyAdapter.Move Method

ObjectListPropertyAdapter.Move Method
ObjectListPropertyAdapter Class Eco.Framework.Impl.Frontside Namespace See Also
Collapse All
C#
public void Move(
    int fromPos,
    int toPos
);
Remarks

This is Move, a member of class ObjectListPropertyAdapter.

See Also
ObjectListPropertyAdapter Class
Eco.Framework.Impl.Frontside Namespace


ObjectListPropertyAdapter.Remove Method

ObjectListPropertyAdapter.Remove Method
ObjectListPropertyAdapter Class Eco.Framework.Impl.Frontside Namespace See Also
Collapse All
C#
public void Remove(
    IEcoObject value
);
Remarks

This is Remove, a member of class ObjectListPropertyAdapter.

See Also
ObjectListPropertyAdapter Class
Eco.Framework.Impl.Frontside Namespace


ObjectListPropertyAdapter.RemoveAt Method

ObjectListPropertyAdapter.RemoveAt Method
ObjectListPropertyAdapter Class Eco.Framework.Impl.Frontside Namespace See Also
Collapse All
C#
public void RemoveAt(
    int index
);
Remarks

This is RemoveAt, a member of class ObjectListPropertyAdapter.

See Also
ObjectListPropertyAdapter Class
Eco.Framework.Impl.Frontside Namespace


ObjectListPropertyAdapter.this Indexer

ObjectListPropertyAdapter.this Indexer
ObjectListPropertyAdapter Class Eco.Framework.Impl.Frontside Namespace See Also
Collapse All
C#
public IObjectInstance this[
    int index
];
Remarks

IObjectList

See Also
ObjectListPropertyAdapter Class
Eco.Framework.Impl.Frontside Namespace


ObjectListPropertyAdapter Properties

ObjectListPropertyAdapter Properties
Public Properties
Collapse All

The properties of the ObjectListPropertyAdapter class are listed here.

Public Properties
Name | Description
ContentType | This is ContentType, a member of class ObjectListPropertyAdapter.
Count | ICollection
IsSynchronized | This is IsSynchronized, a member of class ObjectListPropertyAdapter.
RemoveDeletedObjects | This is RemoveDeletedObjects, a member of class ObjectListPropertyAdapter.
SupportsAddNew | This is SupportsAddNew, a member of class ObjectListPropertyAdapter.
SupportsMove | This is SupportsMove, a member of class ObjectListPropertyAdapter.
SupportsRemoveAt | This is SupportsRemoveAt, a member of class ObjectListPropertyAdapter.
SyncRoot | This is SyncRoot, a member of class ObjectListPropertyAdapter.
UmlClass | This is UmlClass, a member of class ObjectListPropertyAdapter.
UmlCollectionType | This is UmlCollectionType, a member of class ObjectListPropertyAdapter.
UmlType | This is UmlType, a member of class ObjectListPropertyAdapter.


ObjectListPropertyAdapter.ContentType Property

ObjectListPropertyAdapter.ContentType Property
ObjectListPropertyAdapter Class Eco.Framework.Impl.Frontside Namespace See Also
Collapse All
C#
public override ContentType ContentType;
Remarks

This is ContentType, a member of class ObjectListPropertyAdapter.

See Also
ObjectListPropertyAdapter Class
Eco.Framework.Impl.Frontside Namespace


ObjectListPropertyAdapter.Count Property

ObjectListPropertyAdapter.Count Property
ObjectListPropertyAdapter Class Eco.Framework.Impl.Frontside Namespace See Also
Collapse All
C#
public int Count;
Remarks

ICollection

See Also
ObjectListPropertyAdapter Class
Eco.Framework.Impl.Frontside Namespace


ObjectListPropertyAdapter.IsSynchronized Property

ObjectListPropertyAdapter.IsSynchronized Property
ObjectListPropertyAdapter Class Eco.Framework.Impl.Frontside Namespace See Also
Collapse All
C#
public bool IsSynchronized;
Remarks

This is IsSynchronized, a member of class ObjectListPropertyAdapter.

See Also
ObjectListPropertyAdapter Class
Eco.Framework.Impl.Frontside Namespace


ObjectListPropertyAdapter.RemoveDeletedObjects Property

ObjectListPropertyAdapter.RemoveDeletedObjects Property
ObjectListPropertyAdapter Class Eco.Framework.Impl.Frontside Namespace See Also
Collapse All
C#
public bool RemoveDeletedObjects;
Remarks

This is RemoveDeletedObjects, a member of class ObjectListPropertyAdapter.

See Also
ObjectListPropertyAdapter Class
Eco.Framework.Impl.Frontside Namespace


ObjectListPropertyAdapter.SupportsAddNew Property

ObjectListPropertyAdapter.SupportsAddNew Property
ObjectListPropertyAdapter Class Eco.Framework.Impl.Frontside Namespace See Also
Collapse All
C#
public bool SupportsAddNew;
Remarks

This is SupportsAddNew, a member of class ObjectListPropertyAdapter.

See Also
ObjectListPropertyAdapter Class
Eco.Framework.Impl.Frontside Namespace


ObjectListPropertyAdapter.SupportsMove Property

ObjectListPropertyAdapter.SupportsMove Property
ObjectListPropertyAdapter Class Eco.Framework.Impl.Frontside Namespace See Also
Collapse All
C#
public bool SupportsMove;
Remarks

This is SupportsMove, a member of class ObjectListPropertyAdapter.

See Also
ObjectListPropertyAdapter Class
Eco.Framework.Impl.Frontside Namespace


ObjectListPropertyAdapter.SupportsRemoveAt Property

ObjectListPropertyAdapter.SupportsRemoveAt Property
ObjectListPropertyAdapter Class Eco.Framework.Impl.Frontside Namespace See Also
Collapse All
C#
public bool SupportsRemoveAt;
Remarks

This is SupportsRemoveAt, a member of class ObjectListPropertyAdapter.

See Also
ObjectListPropertyAdapter Class
Eco.Framework.Impl.Frontside Namespace


ObjectListPropertyAdapter.SyncRoot Property

ObjectListPropertyAdapter.SyncRoot Property
ObjectListPropertyAdapter Class Eco.Framework.Impl.Frontside Namespace See Also
Collapse All
C#
public object SyncRoot;
Remarks

This is SyncRoot, a member of class ObjectListPropertyAdapter.

See Also
ObjectListPropertyAdapter Class
Eco.Framework.Impl.Frontside Namespace


ObjectListPropertyAdapter.UmlClass Property

ObjectListPropertyAdapter.UmlClass Property
ObjectListPropertyAdapter Class Eco.Framework.Impl.Frontside Namespace See Also
Collapse All
C#
public IClass UmlClass;
Remarks

This is UmlClass, a member of class ObjectListPropertyAdapter.

See Also
ObjectListPropertyAdapter Class
Eco.Framework.Impl.Frontside Namespace


ObjectListPropertyAdapter.UmlCollectionType Property

ObjectListPropertyAdapter.UmlCollectionType Property
ObjectListPropertyAdapter Class Eco.Framework.Impl.Frontside Namespace See Also
Collapse All
C#
public ICollectionType UmlCollectionType;
Remarks

This is UmlCollectionType, a member of class ObjectListPropertyAdapter.

See Also
ObjectListPropertyAdapter Class
Eco.Framework.Impl.Frontside Namespace


ObjectListPropertyAdapter.UmlType Property

ObjectListPropertyAdapter.UmlType Property
ObjectListPropertyAdapter Class Eco.Framework.Impl.Frontside Namespace See Also
Collapse All
C#
public override IClassifier UmlType;
Remarks

This is UmlType, a member of class ObjectListPropertyAdapter.

See Also
ObjectListPropertyAdapter Class
Eco.Framework.Impl.Frontside Namespace


ObjectReferencePropertyAdapter Class

ObjectReferencePropertyAdapter Class
Inheritance Hierarchy See Also
Collapse All
C#
public class ObjectReferencePropertyAdapter : MemberPropertyAdapter, IObjectReference, IFeatured, IEcoObject;
Remarks

This is class Eco.Framework.Impl.Frontside.ObjectReferencePropertyAdapter.

Inheritance Hierarchy
Eco.Framework.Impl.Frontside.MemberPropertyAdapter
    Eco.Framework.Impl.Frontside.ObjectReferencePropertyAdapter
File

ObjectReferencePropertyAdapter.cs

See Also
Inheritance Hierarchy


ObjectReferencePropertyAdapter.ObjectReferencePropertyAdapter Constructor

ObjectReferencePropertyAdapter.ObjectReferencePropertyAdapter Constructor
ObjectReferencePropertyAdapter Class Eco.Framework.Impl.Frontside Namespace See Also
Collapse All
C#
public ObjectReferencePropertyAdapter(
    Eco.Cache.Locator Locator,
    MemberFrontsidePolicy MemberPolicy
);
Remarks

This is ObjectReferencePropertyAdapter, a member of class ObjectReferencePropertyAdapter.

See Also
ObjectReferencePropertyAdapter Class
Eco.Framework.Impl.Frontside Namespace


ObjectReferencePropertyAdapter Methods

ObjectReferencePropertyAdapter Methods
Public Methods
Collapse All

The methods of the ObjectReferencePropertyAdapter class are listed here.

Public Methods
Name | Description
Assign | This is Assign, a member of class ObjectReferencePropertyAdapter.
Clear | This is Clear, a member of class ObjectReferencePropertyAdapter.
CloneValue | This is CloneValue, a member of class ObjectReferencePropertyAdapter.
Delete | This is Delete, a member of class ObjectReferencePropertyAdapter.
EnsureFetched | This is EnsureFetched, a member of class ObjectReferencePropertyAdapter.
GetAsCollection | This is GetAsCollection, a member of class ObjectReferencePropertyAdapter.
GetAsIList | This is GetAsIList, a member of class ObjectReferencePropertyAdapter.
GetAsList | This is GetAsList, a member of class ObjectReferencePropertyAdapter.
GetIsEqualHashCode | This is GetIsEqualHashCode, a member of class ObjectReferencePropertyAdapter.
IsEqual | This is IsEqual, a member of class ObjectReferencePropertyAdapter.


ObjectReferencePropertyAdapter.Assign Method

ObjectReferencePropertyAdapter.Assign Method
ObjectReferencePropertyAdapter Class Eco.Framework.Impl.Frontside Namespace See Also
Collapse All
C#
public override void Assign(
    IElement element
);
Remarks

This is Assign, a member of class ObjectReferencePropertyAdapter.

See Also
ObjectReferencePropertyAdapter Class
Eco.Framework.Impl.Frontside Namespace


ObjectReferencePropertyAdapter.Clear Method

ObjectReferencePropertyAdapter.Clear Method
ObjectReferencePropertyAdapter Class Eco.Framework.Impl.Frontside Namespace See Also
Collapse All
C#
public void Clear();
Remarks

This is Clear, a member of class ObjectReferencePropertyAdapter.

See Also
ObjectReferencePropertyAdapter Class
Eco.Framework.Impl.Frontside Namespace


ObjectReferencePropertyAdapter.CloneValue Method

ObjectReferencePropertyAdapter.CloneValue Method
ObjectReferencePropertyAdapter Class Eco.Framework.Impl.Frontside Namespace See Also
Collapse All
C#
public override IElement CloneValue(
    bool readOnly
);
Remarks

This is CloneValue, a member of class ObjectReferencePropertyAdapter.

See Also
ObjectReferencePropertyAdapter Class
Eco.Framework.Impl.Frontside Namespace


ObjectReferencePropertyAdapter.Delete Method

ObjectReferencePropertyAdapter.Delete Method
ObjectReferencePropertyAdapter Class Eco.Framework.Impl.Frontside Namespace See Also
Collapse All
C#
public void Delete();
Remarks

This is Delete, a member of class ObjectReferencePropertyAdapter.

See Also
ObjectReferencePropertyAdapter Class
Eco.Framework.Impl.Frontside Namespace


ObjectReferencePropertyAdapter.EnsureFetched Method

ObjectReferencePropertyAdapter.EnsureFetched Method
ObjectReferencePropertyAdapter Class Eco.Framework.Impl.Frontside Namespace See Also
Collapse All
C#
public void EnsureFetched();
Remarks

This is EnsureFetched, a member of class ObjectReferencePropertyAdapter.

See Also
ObjectReferencePropertyAdapter Class
Eco.Framework.Impl.Frontside Namespace


ObjectReferencePropertyAdapter.GetAsCollection Method

ObjectReferencePropertyAdapter.GetAsCollection Method
ObjectReferencePropertyAdapter Class Eco.Framework.Impl.Frontside Namespace See Also
Collapse All
C#
public override IElementCollection GetAsCollection();
Remarks

This is GetAsCollection, a member of class ObjectReferencePropertyAdapter.

See Also
ObjectReferencePropertyAdapter Class
Eco.Framework.Impl.Frontside Namespace


ObjectReferencePropertyAdapter.GetAsIList Method

ObjectReferencePropertyAdapter.GetAsIList Method
ObjectReferencePropertyAdapter Class Eco.Framework.Impl.Frontside Namespace See Also
Collapse All
C#
public override IList<T> GetAsIList<T>();
Remarks

This is GetAsIList, a member of class ObjectReferencePropertyAdapter.

See Also
ObjectReferencePropertyAdapter Class
Eco.Framework.Impl.Frontside Namespace


ObjectReferencePropertyAdapter.GetAsList Method

ObjectReferencePropertyAdapter.GetAsList Method
ObjectReferencePropertyAdapter Class Eco.Framework.Impl.Frontside Namespace See Also
Collapse All
C#
public IObjectList GetAsList();
Remarks

This is GetAsList, a member of class ObjectReferencePropertyAdapter.

See Also
ObjectReferencePropertyAdapter Class
Eco.Framework.Impl.Frontside Namespace


ObjectReferencePropertyAdapter.GetIsEqualHashCode Method

ObjectReferencePropertyAdapter.GetIsEqualHashCode Method
ObjectReferencePropertyAdapter Class Eco.Framework.Impl.Frontside Namespace See Also
Collapse All
C#
public override int GetIsEqualHashCode();
Remarks

This is GetIsEqualHashCode, a member of class ObjectReferencePropertyAdapter.

See Also
ObjectReferencePropertyAdapter Class
Eco.Framework.Impl.Frontside Namespace


ObjectReferencePropertyAdapter.IsEqual Method

ObjectReferencePropertyAdapter.IsEqual Method
ObjectReferencePropertyAdapter Class Eco.Framework.Impl.Frontside Namespace See Also
Collapse All
C#
public override bool IsEqual(
    IElement Element
);
Remarks

This is IsEqual, a member of class ObjectReferencePropertyAdapter.

See Also
ObjectReferencePropertyAdapter Class
Eco.Framework.Impl.Frontside Namespace


ObjectReferencePropertyAdapter Properties

ObjectReferencePropertyAdapter Properties
Public Properties
Collapse All

The properties of the ObjectReferencePropertyAdapter class are listed here.

Public Properties
Name | Description
ContentType | This is ContentType, a member of class ObjectReferencePropertyAdapter.
Count | This is Count, a member of class ObjectReferencePropertyAdapter.
DefaultStringRepresentation | This is DefaultStringRepresentation, a member of class ObjectReferencePropertyAdapter.
Deleted | This is Deleted, a member of class ObjectReferencePropertyAdapter.
IsDeletable | This is IsDeletable, a member of class ObjectReferencePropertyAdapter.
NonDeletableReason | This is NonDeletableReason, a member of class ObjectReferencePropertyAdapter.
ObjectInstance | This is ObjectInstance, a member of class ObjectReferencePropertyAdapter.
Properties | This is Properties, a member of class ObjectReferencePropertyAdapter.
UmlClass | IObject
UmlType | This is UmlType, a member of class ObjectReferencePropertyAdapter.


ObjectReferencePropertyAdapter.ContentType Property

ObjectReferencePropertyAdapter.ContentType Property
ObjectReferencePropertyAdapter Class Eco.Framework.Impl.Frontside Namespace See Also
Collapse All
C#
public override ContentType ContentType;
Remarks

This is ContentType, a member of class ObjectReferencePropertyAdapter.

See Also
ObjectReferencePropertyAdapter Class
Eco.Framework.Impl.Frontside Namespace


ObjectReferencePropertyAdapter.Count Property

ObjectReferencePropertyAdapter.Count Property
ObjectReferencePropertyAdapter Class Eco.Framework.Impl.Frontside Namespace See Also
Collapse All
C#
public int Count;
Remarks

This is Count, a member of class ObjectReferencePropertyAdapter.

See Also
ObjectReferencePropertyAdapter Class
Eco.Framework.Impl.Frontside Namespace


ObjectReferencePropertyAdapter.DefaultStringRepresentation Property

ObjectReferencePropertyAdapter.DefaultStringRepresentation Property
ObjectReferencePropertyAdapter Class Eco.Framework.Impl.Frontside Namespace See Also
Collapse All
C#
public string DefaultStringRepresentation;
Remarks

This is DefaultStringRepresentation, a member of class ObjectReferencePropertyAdapter.

See Also
ObjectReferencePropertyAdapter Class
Eco.Framework.Impl.Frontside Namespace


ObjectReferencePropertyAdapter.Deleted Property

ObjectReferencePropertyAdapter.Deleted Property
ObjectReferencePropertyAdapter Class Eco.Framework.Impl.Frontside Namespace See Also
Collapse All
C#
public bool Deleted;
Remarks

This is Deleted, a member of class ObjectReferencePropertyAdapter.

See Also
ObjectReferencePropertyAdapter Class
Eco.Framework.Impl.Frontside Namespace


ObjectReferencePropertyAdapter.IsDeletable Property

ObjectReferencePropertyAdapter.IsDeletable Property
ObjectReferencePropertyAdapter Class Eco.Framework.Impl.Frontside Namespace See Also
Collapse All
C#
public bool IsDeletable;
Remarks

This is IsDeletable, a member of class ObjectReferencePropertyAdapter.

See Also
ObjectReferencePropertyAdapter Class
Eco.Framework.Impl.Frontside Namespace


ObjectReferencePropertyAdapter.NonDeletableReason Property

ObjectReferencePropertyAdapter.NonDeletableReason Property
ObjectReferencePropertyAdapter Class Eco.Framework.Impl.Frontside Namespace See Also
Collapse All
C#
public INonDeletableReason NonDeletableReason;
Remarks

This is NonDeletableReason, a member of class ObjectReferencePropertyAdapter.

See Also
ObjectReferencePropertyAdapter Class
Eco.Framework.Impl.Frontside Namespace


ObjectReferencePropertyAdapter.ObjectInstance Property

ObjectReferencePropertyAdapter.ObjectInstance Property
ObjectReferencePropertyAdapter Class Eco.Framework.Impl.Frontside Namespace See Also
Collapse All
C#
public IObjectInstance ObjectInstance;
Remarks

This is ObjectInstance, a member of class ObjectReferencePropertyAdapter.

See Also
ObjectReferencePropertyAdapter Class
Eco.Framework.Impl.Frontside Namespace


ObjectReferencePropertyAdapter.Properties Property

ObjectReferencePropertyAdapter.Properties Property
ObjectReferencePropertyAdapter Class Eco.Framework.Impl.Frontside Namespace See Also
Collapse All
C#
public IPropertyCollection Properties;
Remarks

This is Properties, a member of class ObjectReferencePropertyAdapter.

See Also
ObjectReferencePropertyAdapter Class
Eco.Framework.Impl.Frontside Namespace


ObjectReferencePropertyAdapter.UmlClass Property

ObjectReferencePropertyAdapter.UmlClass Property
ObjectReferencePropertyAdapter Class Eco.Framework.Impl.Frontside Namespace See Also
Collapse All
C#
public IClass UmlClass;
Remarks

IObject

See Also
ObjectReferencePropertyAdapter Class
Eco.Framework.Impl.Frontside Namespace


ObjectReferencePropertyAdapter.UmlType Property

ObjectReferencePropertyAdapter.UmlType Property
ObjectReferencePropertyAdapter Class Eco.Framework.Impl.Frontside Namespace See Also
Collapse All
C#
public override IClassifier UmlType;
Remarks

This is UmlType, a member of class ObjectReferencePropertyAdapter.

See Also
ObjectReferencePropertyAdapter Class
Eco.Framework.Impl.Frontside Namespace


SingleAssociationEndFrontsidePolicy Class

SingleAssociationEndFrontsidePolicy Class
Inheritance Hierarchy See Also
Collapse All
C#
public abstract class SingleAssociationEndFrontsidePolicy : AssociationEndFrontsidePolicy;
Remarks

This is class Eco.Framework.Impl.Frontside.SingleAssociationEndFrontsidePolicy.

Inheritance Hierarchy
Eco.Framework.Impl.Frontside.MemberFrontsidePolicy
    Eco.Framework.Impl.Frontside.AssociationEndFrontsidePolicy
        Eco.Framework.Impl.Frontside.SingleAssociationEndFrontsidePolicy
            Eco.Framework.Impl.Frontside.DirectSingleMultiFrontsidePolicy
            Eco.Framework.Impl.Frontside.DirectSingleSingleEmbeddedFrontsidePolicy
            Eco.Framework.Impl.Frontside.DirectSingleSingleNonembeddedFrontsidePolicy
            Eco.Framework.Impl.Frontside.IndirectSingleFrontsidePolicy
            Eco.Framework.Impl.Frontside.InnerLinkFrontsidePolicy
            Eco.Framework.Impl.Frontside.ToInnerSingleFrontsidePolicy
File

SingleAssociationEndFrontsidePolicies.cs

See Also
Inheritance Hierarchy


SingleAssociationEndFrontsidePolicy.SingleAssociationEndFrontsidePolicy Constructor

SingleAssociationEndFrontsidePolicy.SingleAssociationEndFrontsidePolicy Constructor
SingleAssociationEndFrontsidePolicy Class Eco.Framework.Impl.Frontside Namespace See Also
Collapse All
C#
public SingleAssociationEndFrontsidePolicy(
    IAssociationEnd assocEnd,
    ClassFrontsidePolicy owner
);
Remarks

This is SingleAssociationEndFrontsidePolicy, a member of class SingleAssociationEndFrontsidePolicy.

See Also
SingleAssociationEndFrontsidePolicy Class
Eco.Framework.Impl.Frontside Namespace


SingleAssociationEndFrontsidePolicy Methods

SingleAssociationEndFrontsidePolicy Methods
Public Methods
Collapse All

The methods of the SingleAssociationEndFrontsidePolicy class are listed here.

Public Methods
Name | Description
GetPropertyAdapter | This is GetPropertyAdapter, a member of class SingleAssociationEndFrontsidePolicy.
RetrieveMemberValue | This is RetrieveMemberValue, a member of class SingleAssociationEndFrontsidePolicy.


SingleAssociationEndFrontsidePolicy.GetPropertyAdapter Method

SingleAssociationEndFrontsidePolicy.GetPropertyAdapter Method
SingleAssociationEndFrontsidePolicy Class Eco.Framework.Impl.Frontside Namespace See Also
Collapse All
C#
public override IProperty GetPropertyAdapter(
    DefaultFrontsideLocator locator
);
Remarks

This is GetPropertyAdapter, a member of class SingleAssociationEndFrontsidePolicy.

See Also
SingleAssociationEndFrontsidePolicy Class
Eco.Framework.Impl.Frontside Namespace


SingleAssociationEndFrontsidePolicy.RetrieveMemberValue Method

SingleAssociationEndFrontsidePolicy.RetrieveMemberValue Method
SingleAssociationEndFrontsidePolicy Class Eco.Framework.Impl.Frontside Namespace See Also
Collapse All
C#
public override object RetrieveMemberValue(
    DefaultFrontsideLocator locator
);
Remarks

This is RetrieveMemberValue, a member of class SingleAssociationEndFrontsidePolicy.

See Also
SingleAssociationEndFrontsidePolicy Class
Eco.Framework.Impl.Frontside Namespace


ToInnerMultiFrontsidePolicy Class

ToInnerMultiFrontsidePolicy Class
Inheritance Hierarchy See Also
Collapse All
C#
public sealed class ToInnerMultiFrontsidePolicy : MultAssociationEndFrontsidePolicy;
Remarks

This is class Eco.Framework.Impl.Frontside.ToInnerMultiFrontsidePolicy.

Inheritance Hierarchy
Eco.Framework.Impl.Frontside.MemberFrontsidePolicy
    Eco.Framework.Impl.Frontside.AssociationEndFrontsidePolicy
        Eco.Framework.Impl.Frontside.MultAssociationEndFrontsidePolicy
            Eco.Framework.Impl.Frontside.ToInnerMultiFrontsidePolicy
File

MultiAssociationEndFrontsidePolicies.cs

See Also
Inheritance Hierarchy


ToInnerMultiFrontsidePolicy.ToInnerMultiFrontsidePolicy Constructor

ToInnerMultiFrontsidePolicy.ToInnerMultiFrontsidePolicy Constructor
ToInnerMultiFrontsidePolicy Class Eco.Framework.Impl.Frontside Namespace See Also
Collapse All
C#
public ToInnerMultiFrontsidePolicy(
    IAssociationEnd assocEnd,
    ClassFrontsidePolicy owner
);
Remarks

This is ToInnerMultiFrontsidePolicy, a member of class ToInnerMultiFrontsidePolicy.

See Also
ToInnerMultiFrontsidePolicy Class
Eco.Framework.Impl.Frontside Namespace


ToInnerMultiFrontsidePolicy Methods

ToInnerMultiFrontsidePolicy Methods
Public Methods
Collapse All

The methods of the ToInnerMultiFrontsidePolicy class are listed here.

Public Methods
Name | Description
Add | This is Add, a member of class ToInnerMultiFrontsidePolicy.
Clear | This is Clear, a member of class ToInnerMultiFrontsidePolicy.
Insert | This is Insert, a member of class ToInnerMultiFrontsidePolicy.
Remove | This is Remove, a member of class ToInnerMultiFrontsidePolicy.
RemoveAt | This is RemoveAt, a member of class ToInnerMultiFrontsidePolicy.
SetItem | This is SetItem, a member of class ToInnerMultiFrontsidePolicy.


ToInnerMultiFrontsidePolicy.Add Method

ToInnerMultiFrontsidePolicy.Add Method
ToInnerMultiFrontsidePolicy Class Eco.Framework.Impl.Frontside Namespace See Also
Collapse All
C#
public override int Add(
    Locator locator,
    object value
);
Remarks

This is Add, a member of class ToInnerMultiFrontsidePolicy.

See Also
ToInnerMultiFrontsidePolicy Class
Eco.Framework.Impl.Frontside Namespace


ToInnerMultiFrontsidePolicy.Clear Method

ToInnerMultiFrontsidePolicy.Clear Method
ToInnerMultiFrontsidePolicy Class Eco.Framework.Impl.Frontside Namespace See Also
Collapse All
C#
public override void Clear(
    Locator locator
);
Remarks

This is Clear, a member of class ToInnerMultiFrontsidePolicy.

See Also
ToInnerMultiFrontsidePolicy Class
Eco.Framework.Impl.Frontside Namespace


ToInnerMultiFrontsidePolicy.Insert Method

ToInnerMultiFrontsidePolicy.Insert Method
ToInnerMultiFrontsidePolicy Class Eco.Framework.Impl.Frontside Namespace See Also
Collapse All
C#
public override void Insert(
    Locator locator,
    int index,
    object value
);
Remarks

This is Insert, a member of class ToInnerMultiFrontsidePolicy.

See Also
ToInnerMultiFrontsidePolicy Class
Eco.Framework.Impl.Frontside Namespace


ToInnerMultiFrontsidePolicy.Remove Method

ToInnerMultiFrontsidePolicy.Remove Method
ToInnerMultiFrontsidePolicy Class Eco.Framework.Impl.Frontside Namespace See Also
Collapse All
C#
public override void Remove(
    Locator locator,
    object value
);
Remarks

This is Remove, a member of class ToInnerMultiFrontsidePolicy.

See Also
ToInnerMultiFrontsidePolicy Class
Eco.Framework.Impl.Frontside Namespace


ToInnerMultiFrontsidePolicy.RemoveAt Method

ToInnerMultiFrontsidePolicy.RemoveAt Method
ToInnerMultiFrontsidePolicy Class Eco.Framework.Impl.Frontside Namespace See Also
Collapse All
C#
public override void RemoveAt(
    Locator locator,
    int index
);
Remarks

This is RemoveAt, a member of class ToInnerMultiFrontsidePolicy.

See Also
ToInnerMultiFrontsidePolicy Class
Eco.Framework.Impl.Frontside Namespace


ToInnerMultiFrontsidePolicy.SetItem Method

ToInnerMultiFrontsidePolicy.SetItem Method
ToInnerMultiFrontsidePolicy Class Eco.Framework.Impl.Frontside Namespace See Also
Collapse All
C#
public override void SetItem(
    Locator locator,
    int index,
    object value
);
Remarks

This is SetItem, a member of class ToInnerMultiFrontsidePolicy.

See Also
ToInnerMultiFrontsidePolicy Class
Eco.Framework.Impl.Frontside Namespace


ToInnerSingleFrontsidePolicy Class

ToInnerSingleFrontsidePolicy Class
Inheritance Hierarchy See Also
Collapse All
C#
public class ToInnerSingleFrontsidePolicy : SingleAssociationEndFrontsidePolicy;
Remarks

This is class Eco.Framework.Impl.Frontside.ToInnerSingleFrontsidePolicy.

Inheritance Hierarchy
Eco.Framework.Impl.Frontside.MemberFrontsidePolicy
    Eco.Framework.Impl.Frontside.AssociationEndFrontsidePolicy
        Eco.Framework.Impl.Frontside.SingleAssociationEndFrontsidePolicy
            Eco.Framework.Impl.Frontside.ToInnerSingleFrontsidePolicy
File

SingleAssociationEndFrontsidePolicies.cs

See Also
Inheritance Hierarchy


ToInnerSingleFrontsidePolicy.ToInnerSingleFrontsidePolicy Constructor

ToInnerSingleFrontsidePolicy.ToInnerSingleFrontsidePolicy Constructor
ToInnerSingleFrontsidePolicy Class Eco.Framework.Impl.Frontside Namespace See Also
Collapse All
C#
public ToInnerSingleFrontsidePolicy(
    IAssociationEnd assocEnd,
    ClassFrontsidePolicy owner
);
Remarks

This is ToInnerSingleFrontsidePolicy, a member of class ToInnerSingleFrontsidePolicy.

See Also
ToInnerSingleFrontsidePolicy Class
Eco.Framework.Impl.Frontside Namespace


ToInnerSingleFrontsidePolicy Methods

ToInnerSingleFrontsidePolicy Methods
Public Methods
Collapse All

The methods of the ToInnerSingleFrontsidePolicy class are listed here.

Public Methods
Name | Description
ApplyMemberValue | ToInnerSingleFrontsidePolicy


ToInnerSingleFrontsidePolicy.ApplyMemberValue Method

ToInnerSingleFrontsidePolicy.ApplyMemberValue Method
ToInnerSingleFrontsidePolicy Class Eco.Framework.Impl.Frontside Namespace See Also
Collapse All
C#
public override void ApplyMemberValue(
    Locator locator,
    object value,
    bool CallerStateMachine
);
Remarks

ToInnerSingleFrontsidePolicy

See Also
ToInnerSingleFrontsidePolicy Class
Eco.Framework.Impl.Frontside Namespace


IFrontsideAdapterFactory Interface

IFrontsideAdapterFactory Interface
Inheritance Hierarchy See Also
Collapse All
C#
public interface IFrontsideAdapterFactory;
Remarks

This is class Eco.Framework.Impl.Frontside.IFrontsideAdapterFactory.

Inheritance Hierarchy
Eco.Framework.Impl.Frontside.IFrontsideAdapterFactory
    Eco.Framework.Impl.Frontside.FrontSideAdapterFactory
File

FrontsideMultilinkAdapters.cs

See Also
Inheritance Hierarchy


IFrontsideAdapterFactory Methods

IFrontsideAdapterFactory Methods
Public Methods
Collapse All

The methods of the IFrontsideAdapterFactory class are listed here.

Public Methods
Name | Description
Make | This is Make, a member of class IFrontsideAdapterFactory.


IFrontsideAdapterFactory.Make Method

IFrontsideAdapterFactory.Make Method
IFrontsideAdapterFactory Interface Eco.Framework.Impl.Frontside Namespace See Also
Collapse All
C#
object Make(
    DefaultFrontsideLocator locator,
    MultAssociationEndFrontsidePolicy policy
);
Remarks

This is Make, a member of class IFrontsideAdapterFactory.

See Also
IFrontsideAdapterFactory Interface
Eco.Framework.Impl.Frontside Namespace


IFrontsideDerivedAdapterFactory Interface

IFrontsideDerivedAdapterFactory Interface
Inheritance Hierarchy See Also
Collapse All
C#
public interface IFrontsideDerivedAdapterFactory;
Remarks

This is class Eco.Framework.Impl.Frontside.IFrontsideDerivedAdapterFactory.

Inheritance Hierarchy
Eco.Framework.Impl.Frontside.IFrontsideDerivedAdapterFactory
    Eco.Framework.Impl.Frontside.FrontSideDerivedAdapterFactory
File

FrontsideMultilinkAdapters.cs

See Also
Inheritance Hierarchy


IFrontsideDerivedAdapterFactory Methods

IFrontsideDerivedAdapterFactory Methods
Public Methods
Collapse All

The methods of the IFrontsideDerivedAdapterFactory class are listed here.

Public Methods
Name | Description
Make | This is Make, a member of class IFrontsideDerivedAdapterFactory.


IFrontsideDerivedAdapterFactory.Make Method

IFrontsideDerivedAdapterFactory.Make Method
IFrontsideDerivedAdapterFactory Interface Eco.Framework.Impl.Frontside Namespace See Also
Collapse All
C#
object Make(
    DefaultFrontsideLocator locator,
    DerivedMemberFrontsidePolicy policy
);
Remarks

This is Make, a member of class IFrontsideDerivedAdapterFactory.

See Also
IFrontsideDerivedAdapterFactory Interface
Eco.Framework.Impl.Frontside Namespace


Eco.Framework.Impl.Frontside.CreateFrontEndObjectDelegate Type

Eco.Framework.Impl.Frontside.CreateFrontEndObjectDelegate Type
Collapse All
C#
public delegate object CreateFrontEndObjectDelegate(IClass umlClass, ConstructorInfo constructorInfo, IEcoServiceProvider sp);
Remarks

This is type Eco.Framework.Impl.Frontside.CreateFrontEndObjectDelegate.

File

FrontsidePolicy.cs


Eco.Framework.Impl.Frontside.RecreateFrontEndObjectDelegate Type

Eco.Framework.Impl.Frontside.RecreateFrontEndObjectDelegate Type
Collapse All
C#
public delegate object RecreateFrontEndObjectDelegate(IClass umlClass, ConstructorInfo constructorInfo, IContent content);
Remarks

This is type Eco.Framework.Impl.Frontside.RecreateFrontEndObjectDelegate.

File

FrontsidePolicy.cs


Eco.FrameworkImpl.Frontside Namespace

Eco.FrameworkImpl.Frontside Namespace
Classes Interfaces
Collapse All

This is namespace Eco.FrameworkImpl.Frontside.

Classes
Name | Description
ObjectStateMachine | This is class Eco.FrameworkImpl.Frontside.ObjectStateMachine.
Top
Interfaces
Name | Description
IStateMachineAccess | This is class Eco.FrameworkImpl.Frontside.IStateMachineAccess.


ObjectStateMachine Class

ObjectStateMachine Class
Inheritance Hierarchy See Also
Collapse All
C#
public class ObjectStateMachine : Object, IObjectStateMachine;
Remarks

This is class Eco.FrameworkImpl.Frontside.ObjectStateMachine.

Inheritance Hierarchy
Eco.FrameworkImpl.Frontside.ObjectStateMachine
File

StateMachine.cs

See Also
Inheritance Hierarchy


ObjectStateMachine.ObjectStateMachine Constructor

ObjectStateMachine.ObjectStateMachine Constructor
ObjectStateMachine Class Eco.FrameworkImpl.Frontside Namespace See Also
Collapse All
C#
public ObjectStateMachine(
    IStateMachineAccess stateMachineAccess
);
Remarks

This is ObjectStateMachine, a member of class ObjectStateMachine.

See Also
ObjectStateMachine Class
Eco.FrameworkImpl.Frontside Namespace


ObjectStateMachine Methods

ObjectStateMachine Methods
Public Methods
Collapse All

The methods of the ObjectStateMachine class are listed here.

Public Methods
Name | Description
CanTrigger | This is the overview for the CanTrigger method overload.
FilterState | This is FilterState, a member of class ObjectStateMachine.
GetState | This is GetState, a member of class ObjectStateMachine.
GetStates | This is the overview for the GetStates method overload.
GetTransitions | This is the overview for the GetTransitions method overload.
GetTriggers | This is the overview for the GetTriggers method overload.
InitializeObject | This is InitializeObject, a member of class ObjectStateMachine.
IsInRegion | This is the overview for the IsInRegion method overload.
IsInState | This is the overview for the IsInState method overload.
RegionByName | This is RegionByName, a member of class ObjectStateMachine.
StateByName | This is StateByName, a member of class ObjectStateMachine.
SubscribeToState | This is SubscribeToState, a member of class ObjectStateMachine.
Trigger | This is the overview for the Trigger method overload.
TriggerByName | This is TriggerByName, a member of class ObjectStateMachine.


CanTrigger Method

CanTrigger Method

This is the overview for the CanTrigger method overload.

Overload List
Name | Description
ObjectStateMachine.CanTrigger (ITrigger, IElement[]) | This is CanTrigger, a member of class ObjectStateMachine.
ObjectStateMachine.CanTrigger (ITrigger, IElement[], ISubscriber, ISubscriber) | This is CanTrigger, a member of class ObjectStateMachine.
ObjectStateMachine.CanTrigger (ITrigger, Object[]) | ObjectStateMachine
ObjectStateMachine.CanTrigger (string, IElement[]) | This is CanTrigger, a member of class ObjectStateMachine.
ObjectStateMachine.CanTrigger (string, Object[]) | This is CanTrigger, a member of class ObjectStateMachine.


ObjectStateMachine.CanTrigger Method (ITrigger, IElement[])

ObjectStateMachine.CanTrigger Method (ITrigger, IElement[])
ObjectStateMachine Class Eco.FrameworkImpl.Frontside Namespace See Also
Collapse All
C#
public bool CanTrigger(
    ITrigger trigger,
    IElement[] parameters
);
Remarks

This is CanTrigger, a member of class ObjectStateMachine.

See Also
ObjectStateMachine Class
Eco.FrameworkImpl.Frontside Namespace


ObjectStateMachine.CanTrigger Method (ITrigger, IElement[], ISubscriber, ISubscriber)

ObjectStateMachine.CanTrigger Method (ITrigger, IElement[], ISubscriber, ISubscriber)
ObjectStateMachine Class Eco.FrameworkImpl.Frontside Namespace See Also
Collapse All
C#
public bool CanTrigger(
    ITrigger trigger,
    IElement[] parameters,
    ISubscriber reevaluateSubscriber,
    ISubscriber resubscribeSubscriber
);
Remarks

This is CanTrigger, a member of class ObjectStateMachine.

See Also
ObjectStateMachine Class
Eco.FrameworkImpl.Frontside Namespace


ObjectStateMachine.CanTrigger Method (ITrigger, Object[])

ObjectStateMachine.CanTrigger Method (ITrigger, Object[])
ObjectStateMachine Class Eco.FrameworkImpl.Frontside Namespace See Also
Collapse All
C#
public bool CanTrigger(
    ITrigger trigger,
    Object[] parameters
);
Remarks

ObjectStateMachine

See Also
ObjectStateMachine Class
Eco.FrameworkImpl.Frontside Namespace


ObjectStateMachine.CanTrigger Method (string, IElement[])

ObjectStateMachine.CanTrigger Method (string, IElement[])
ObjectStateMachine Class Eco.FrameworkImpl.Frontside Namespace See Also
Collapse All
C#
public bool CanTrigger(
    string triggerName,
    IElement[] parameters
);
Remarks

This is CanTrigger, a member of class ObjectStateMachine.

See Also
ObjectStateMachine Class
Eco.FrameworkImpl.Frontside Namespace


ObjectStateMachine.CanTrigger Method (string, Object[])

ObjectStateMachine.CanTrigger Method (string, Object[])
ObjectStateMachine Class Eco.FrameworkImpl.Frontside Namespace See Also
Collapse All
C#
public bool CanTrigger(
    string triggerName,
    Object[] parameters
);
Remarks

This is CanTrigger, a member of class ObjectStateMachine.

See Also
ObjectStateMachine Class
Eco.FrameworkImpl.Frontside Namespace


ObjectStateMachine.FilterState Method

ObjectStateMachine.FilterState Method
ObjectStateMachine Class Eco.FrameworkImpl.Frontside Namespace See Also
Collapse All
C#
public static bool FilterState(
    IState state,
    StateFilter filter
);
Remarks

This is FilterState, a member of class ObjectStateMachine.

See Also
ObjectStateMachine Class
Eco.FrameworkImpl.Frontside Namespace


ObjectStateMachine.GetState Method

ObjectStateMachine.GetState Method
ObjectStateMachine Class Eco.FrameworkImpl.Frontside Namespace See Also
Collapse All
C#
public IState GetState(
    IRegion region
);
Remarks

This is GetState, a member of class ObjectStateMachine.

See Also
ObjectStateMachine Class
Eco.FrameworkImpl.Frontside Namespace


GetStates Method

GetStates Method

This is the overview for the GetStates method overload.

Overload List
Name | Description
ObjectStateMachine.GetStates (IRegion, StateFilter) | This is GetStates, a member of class ObjectStateMachine.
ObjectStateMachine.GetStates (StateFilter) | This is GetStates, a member of class ObjectStateMachine.
ObjectStateMachine.GetStates (string, StateFilter) | Get top level state


ObjectStateMachine.GetStates Method (IRegion, StateFilter)

ObjectStateMachine.GetStates Method (IRegion, StateFilter)
ObjectStateMachine Class Eco.FrameworkImpl.Frontside Namespace See Also
Collapse All
C#
public IStateCollection GetStates(
    IRegion region,
    StateFilter filter
);
Remarks

This is GetStates, a member of class ObjectStateMachine.

See Also
ObjectStateMachine Class
Eco.FrameworkImpl.Frontside Namespace


ObjectStateMachine.GetStates Method (StateFilter)

ObjectStateMachine.GetStates Method (StateFilter)
ObjectStateMachine Class Eco.FrameworkImpl.Frontside Namespace See Also
Collapse All
C#
public IStateCollection GetStates(
    StateFilter filter
);
Remarks

This is GetStates, a member of class ObjectStateMachine.

See Also
ObjectStateMachine Class
Eco.FrameworkImpl.Frontside Namespace


ObjectStateMachine.GetStates Method (string, StateFilter)

ObjectStateMachine.GetStates Method (string, StateFilter)
ObjectStateMachine Class Eco.FrameworkImpl.Frontside Namespace See Also
Collapse All
C#
public IStateCollection GetStates(
    string regionName,
    StateFilter Filter
);
Remarks

Get top level state

See Also
ObjectStateMachine Class
Eco.FrameworkImpl.Frontside Namespace


GetTransitions Method

GetTransitions Method

This is the overview for the GetTransitions method overload.

Overload List
Name | Description
ObjectStateMachine.GetTransitions () | This is GetTransitions, a member of class ObjectStateMachine.
ObjectStateMachine.GetTransitions (IRegion) | This is GetTransitions, a member of class ObjectStateMachine.
ObjectStateMachine.GetTransitions (string) | This is GetTransitions, a member of class ObjectStateMachine.


ObjectStateMachine.GetTransitions Method ()

ObjectStateMachine.GetTransitions Method ()
ObjectStateMachine Class Eco.FrameworkImpl.Frontside Namespace See Also
Collapse All
C#
public ITransitionCollection GetTransitions();
Remarks

This is GetTransitions, a member of class ObjectStateMachine.

See Also
ObjectStateMachine Class
Eco.FrameworkImpl.Frontside Namespace


ObjectStateMachine.GetTransitions Method (IRegion)

ObjectStateMachine.GetTransitions Method (IRegion)
ObjectStateMachine Class Eco.FrameworkImpl.Frontside Namespace See Also
Collapse All
C#
public ITransitionCollection GetTransitions(
    IRegion region
);
Remarks

This is GetTransitions, a member of class ObjectStateMachine.

See Also
ObjectStateMachine Class
Eco.FrameworkImpl.Frontside Namespace


ObjectStateMachine.GetTransitions Method (string)

ObjectStateMachine.GetTransitions Method (string)
ObjectStateMachine Class Eco.FrameworkImpl.Frontside Namespace See Also
Collapse All
C#
public ITransitionCollection GetTransitions(
    string regionName
);
Remarks

This is GetTransitions, a member of class ObjectStateMachine.

See Also
ObjectStateMachine Class
Eco.FrameworkImpl.Frontside Namespace


GetTriggers Method

GetTriggers Method

This is the overview for the GetTriggers method overload.

Overload List
Name | Description
ObjectStateMachine.GetTriggers () | This is GetTriggers, a member of class ObjectStateMachine.
ObjectStateMachine.GetTriggers (IRegion) | This is GetTriggers, a member of class ObjectStateMachine.
ObjectStateMachine.GetTriggers (string) | This is GetTriggers, a member of class ObjectStateMachine.


ObjectStateMachine.GetTriggers Method ()

ObjectStateMachine.GetTriggers Method ()
ObjectStateMachine Class Eco.FrameworkImpl.Frontside Namespace See Also
Collapse All
C#
public ITriggerCollection GetTriggers();
Remarks

This is GetTriggers, a member of class ObjectStateMachine.

See Also
ObjectStateMachine Class
Eco.FrameworkImpl.Frontside Namespace


ObjectStateMachine.GetTriggers Method (IRegion)

ObjectStateMachine.GetTriggers Method (IRegion)
ObjectStateMachine Class Eco.FrameworkImpl.Frontside Namespace See Also
Collapse All
C#
public ITriggerCollection GetTriggers(
    IRegion region
);
Remarks

This is GetTriggers, a member of class ObjectStateMachine.

See Also
ObjectStateMachine Class
Eco.FrameworkImpl.Frontside Namespace


ObjectStateMachine.GetTriggers Method (string)

ObjectStateMachine.GetTriggers Method (string)
ObjectStateMachine Class Eco.FrameworkImpl.Frontside Namespace See Also
Collapse All
C#
public ITriggerCollection GetTriggers(
    string regionName
);
Remarks

This is GetTriggers, a member of class ObjectStateMachine.

See Also
ObjectStateMachine Class
Eco.FrameworkImpl.Frontside Namespace


ObjectStateMachine.InitializeObject Method

ObjectStateMachine.InitializeObject Method
ObjectStateMachine Class Eco.FrameworkImpl.Frontside Namespace See Also
Collapse All
C#
public void InitializeObject();
Remarks

This is InitializeObject, a member of class ObjectStateMachine.

See Also
ObjectStateMachine Class
Eco.FrameworkImpl.Frontside Namespace


IsInRegion Method

IsInRegion Method

This is the overview for the IsInRegion method overload.

Overload List
Name | Description
ObjectStateMachine.IsInRegion (IRegion) | This is IsInRegion, a member of class ObjectStateMachine.
ObjectStateMachine.IsInRegion (string) | This is IsInRegion, a member of class ObjectStateMachine.


ObjectStateMachine.IsInRegion Method (IRegion)

ObjectStateMachine.IsInRegion Method (IRegion)
ObjectStateMachine Class Eco.FrameworkImpl.Frontside Namespace See Also
Collapse All
C#
public bool IsInRegion(
    IRegion region
);
Remarks

This is IsInRegion, a member of class ObjectStateMachine.

See Also
ObjectStateMachine Class
Eco.FrameworkImpl.Frontside Namespace


ObjectStateMachine.IsInRegion Method (string)

ObjectStateMachine.IsInRegion Method (string)
ObjectStateMachine Class Eco.FrameworkImpl.Frontside Namespace See Also
Collapse All
C#
public bool IsInRegion(
    string regionName
);
Remarks

This is IsInRegion, a member of class ObjectStateMachine.

See Also
ObjectStateMachine Class
Eco.FrameworkImpl.Frontside Namespace


IsInState Method

IsInState Method

This is the overview for the IsInState method overload.

Overload List
Name | Description
ObjectStateMachine.IsInState (IState) | This is IsInState, a member of class ObjectStateMachine.
ObjectStateMachine.IsInState (IStateName) | This is IsInState, a member of class ObjectStateMachine.
ObjectStateMachine.IsInState (string) | This is IsInState, a member of class ObjectStateMachine.


ObjectStateMachine.IsInState Method (IState)

ObjectStateMachine.IsInState Method (IState)
ObjectStateMachine Class Eco.FrameworkImpl.Frontside Namespace See Also
Collapse All
C#
public bool IsInState(
    IState state
);
Remarks

This is IsInState, a member of class ObjectStateMachine.

See Also
ObjectStateMachine Class
Eco.FrameworkImpl.Frontside Namespace


ObjectStateMachine.IsInState Method (IStateName)

ObjectStateMachine.IsInState Method (IStateName)
ObjectStateMachine Class Eco.FrameworkImpl.Frontside Namespace See Also
Collapse All
C#
public bool IsInState(
    IStateName stateName
);
Remarks

This is IsInState, a member of class ObjectStateMachine.

See Also
ObjectStateMachine Class
Eco.FrameworkImpl.Frontside Namespace


ObjectStateMachine.IsInState Method (string)

ObjectStateMachine.IsInState Method (string)
ObjectStateMachine Class Eco.FrameworkImpl.Frontside Namespace See Also
Collapse All
C#
public bool IsInState(
    string stateName
);
Remarks

This is IsInState, a member of class ObjectStateMachine.

See Also
ObjectStateMachine Class
Eco.FrameworkImpl.Frontside Namespace


ObjectStateMachine.RegionByName Method

ObjectStateMachine.RegionByName Method
ObjectStateMachine Class Eco.FrameworkImpl.Frontside Namespace See Also
Collapse All
C#
public IRegion RegionByName(
    string name
);
Remarks

This is RegionByName, a member of class ObjectStateMachine.

See Also
ObjectStateMachine Class
Eco.FrameworkImpl.Frontside Namespace


ObjectStateMachine.StateByName Method

ObjectStateMachine.StateByName Method
ObjectStateMachine Class Eco.FrameworkImpl.Frontside Namespace See Also
Collapse All
C#
public IState StateByName(
    string name
);
Remarks

This is StateByName, a member of class ObjectStateMachine.

See Also
ObjectStateMachine Class
Eco.FrameworkImpl.Frontside Namespace


ObjectStateMachine.SubscribeToState Method

ObjectStateMachine.SubscribeToState Method
ObjectStateMachine Class Eco.FrameworkImpl.Frontside Namespace See Also
Collapse All
C#
public void SubscribeToState(
    ISubscriber subscriber
);
Remarks

This is SubscribeToState, a member of class ObjectStateMachine.

See Also
ObjectStateMachine Class
Eco.FrameworkImpl.Frontside Namespace


Trigger Method

Trigger Method

This is the overview for the Trigger method overload.

Overload List
Name | Description
ObjectStateMachine.Trigger (ITrigger, IElement[]) | This is Trigger, a member of class ObjectStateMachine.
ObjectStateMachine.Trigger (ITrigger, Object[]) | This is Trigger, a member of class ObjectStateMachine.
ObjectStateMachine.Trigger (string, IElement[]) | This is Trigger, a member of class ObjectStateMachine.
ObjectStateMachine.Trigger (string, Object[]) | This is Trigger, a member of class ObjectStateMachine.


ObjectStateMachine.Trigger Method (ITrigger, IElement[])

ObjectStateMachine.Trigger Method (ITrigger, IElement[])
ObjectStateMachine Class Eco.FrameworkImpl.Frontside Namespace See Also
Collapse All
C#
public IElement Trigger(
    ITrigger trigger,
    IElement[] parameters
);
Remarks

This is Trigger, a member of class ObjectStateMachine.

See Also
ObjectStateMachine Class
Eco.FrameworkImpl.Frontside Namespace


ObjectStateMachine.Trigger Method (ITrigger, Object[])

ObjectStateMachine.Trigger Method (ITrigger, Object[])
ObjectStateMachine Class Eco.FrameworkImpl.Frontside Namespace See Also
Collapse All
C#
public object Trigger(
    ITrigger trigger,
    Object[] parameters
);
Remarks

This is Trigger, a member of class ObjectStateMachine.

See Also
ObjectStateMachine Class
Eco.FrameworkImpl.Frontside Namespace


ObjectStateMachine.Trigger Method (string, IElement[])

ObjectStateMachine.Trigger Method (string, IElement[])
ObjectStateMachine Class Eco.FrameworkImpl.Frontside Namespace See Also
Collapse All
C#
public IElement Trigger(
    string triggerName,
    IElement[] parameters
);
Remarks

This is Trigger, a member of class ObjectStateMachine.

See Also
ObjectStateMachine Class
Eco.FrameworkImpl.Frontside Namespace


ObjectStateMachine.Trigger Method (string, Object[])

ObjectStateMachine.Trigger Method (string, Object[])
ObjectStateMachine Class Eco.FrameworkImpl.Frontside Namespace See Also
Collapse All
C#
public object Trigger(
    string triggerName,
    Object[] parameters
);
Remarks

This is Trigger, a member of class ObjectStateMachine.

See Also
ObjectStateMachine Class
Eco.FrameworkImpl.Frontside Namespace


ObjectStateMachine.TriggerByName Method

ObjectStateMachine.TriggerByName Method
ObjectStateMachine Class Eco.FrameworkImpl.Frontside Namespace See Also
Collapse All
C#
public ITrigger TriggerByName(
    string name
);
Remarks

This is TriggerByName, a member of class ObjectStateMachine.

See Also
ObjectStateMachine Class
Eco.FrameworkImpl.Frontside Namespace


ObjectStateMachine Properties

ObjectStateMachine Properties
Public Properties
Collapse All

The properties of the ObjectStateMachine class are listed here.

Public Properties
Name | Description
Owner | This is Owner, a member of class ObjectStateMachine.
StateMachine | This is StateMachine, a member of class ObjectStateMachine.


ObjectStateMachine.Owner Property

ObjectStateMachine.Owner Property
ObjectStateMachine Class Eco.FrameworkImpl.Frontside Namespace See Also
Collapse All
C#
public IObjectInstance Owner;
Remarks

This is Owner, a member of class ObjectStateMachine.

See Also
ObjectStateMachine Class
Eco.FrameworkImpl.Frontside Namespace


ObjectStateMachine.StateMachine Property

ObjectStateMachine.StateMachine Property
ObjectStateMachine Class Eco.FrameworkImpl.Frontside Namespace See Also
Collapse All
C#
public IStateMachine StateMachine;
Remarks

This is StateMachine, a member of class ObjectStateMachine.

See Also
ObjectStateMachine Class
Eco.FrameworkImpl.Frontside Namespace


IStateMachineAccess Interface

IStateMachineAccess Interface
Inheritance Hierarchy See Also
Collapse All
C#
public interface IStateMachineAccess : IObject;
Remarks

This is class Eco.FrameworkImpl.Frontside.IStateMachineAccess.

Inheritance Hierarchy
Eco.FrameworkImpl.Frontside.IStateMachineAccess
File

StateMachine.cs

See Also
Inheritance Hierarchy


IStateMachineAccess Methods

IStateMachineAccess Methods
Public Methods
Collapse All

The methods of the IStateMachineAccess class are listed here.

Public Methods
Name | Description
GetOwner | This is GetOwner, a member of class IStateMachineAccess.
SetState | This is SetState, a member of class IStateMachineAccess.


IStateMachineAccess.GetOwner Method

IStateMachineAccess.GetOwner Method
IStateMachineAccess Interface Eco.FrameworkImpl.Frontside Namespace See Also
Collapse All
C#
IObjectInstance GetOwner();
Remarks

This is GetOwner, a member of class IStateMachineAccess.

See Also
IStateMachineAccess Interface
Eco.FrameworkImpl.Frontside Namespace


IStateMachineAccess.SetState Method

IStateMachineAccess.SetState Method
IStateMachineAccess Interface Eco.FrameworkImpl.Frontside Namespace See Also
Collapse All
C#
void SetState(
    IState state
);
Remarks

This is SetState, a member of class IStateMachineAccess.

See Also
IStateMachineAccess Interface
Eco.FrameworkImpl.Frontside Namespace


IStateMachineAccess Properties

IStateMachineAccess Properties
Public Properties
Collapse All

The properties of the IStateMachineAccess class are listed here.

Public Properties
Name | Description
UndoService | This is UndoService, a member of class IStateMachineAccess.


IStateMachineAccess.UndoService Property

IStateMachineAccess.UndoService Property
IStateMachineAccess Interface Eco.FrameworkImpl.Frontside Namespace See Also
Collapse All
C#
IUndoService UndoService;
Remarks

This is UndoService, a member of class IStateMachineAccess.

See Also
IStateMachineAccess Interface
Eco.FrameworkImpl.Frontside Namespace


Eco.FrameworkImpl.LockRegions Namespace

Eco.FrameworkImpl.LockRegions Namespace
Classes Interfaces Structures
Collapse All

This is namespace Eco.FrameworkImpl.LockRegions.

Classes
Name | Description
ConcreteRegionDefinitionList | end TBoldRegionElementInclusion
IdChangedEventargs | This is class Eco.FrameworkImpl.LockRegions.IdChangedEventargs.
LockRegionImpl | This is class Eco.FrameworkImpl.LockRegions.LockRegionImpl.
RegionExpressionSyntaxErrorException | Format RegionName[ClassName] : memberName (, memberName)* (| RegionName[memberName] (, RegionName[memberName]*))
RegionParser | This is class Eco.FrameworkImpl.LockRegions.RegionParser.
TBoldConcreteRegionDefinition | TBoldConcreteRegionDefinition
TBoldIdChangedAdapter | This is class Eco.FrameworkImpl.LockRegions.TBoldIdChangedAdapter.
TBoldOrderedRegionLookup | TBoldOrderedRegionLookup
TBoldRegionChangedAdapter | TBoldRegionChangedAdapter
TBoldRegionCoreDefinition | end TBoldRegionDefinitions
TBoldRegionDefinitions | TBoldRegionDefinitions
TBoldRegionElementInclusion | TBoldRegionElementInclusion
TBoldRegionExpander | TBoldRegionState = (rrSource, rrDepParent, rrIndepParent, rrDepSub, rrIndepSub); TBoldRegionExpanderRegionLists = array[TBoldRegionState] of TBoldregionLookup; TBoldRegionExpander
TBoldRegionFactory | TBoldRegionFactory
TBoldRegionLookup | This is class Eco.FrameworkImpl.LockRegions.TBoldRegionLookup.
TBoldSubregionReference | TBoldSubregionReference
Top
Interfaces
Name | Description
ILockRegion | These should be make public when an actual RegionService is added.
IRegionFactory | This is class Eco.FrameworkImpl.LockRegions.IRegionFactory.
Top
Structures
Name | Description
TRegionElement | This is class Eco.FrameworkImpl.LockRegions.TRegionElement.


ConcreteRegionDefinitionList Class

ConcreteRegionDefinitionList Class
Inheritance Hierarchy See Also
Collapse All
C#
public class ConcreteRegionDefinitionList : List<TBoldConcreteRegionDefinition>;
Remarks

end TBoldRegionElementInclusion

Inheritance Hierarchy
Eco.FrameworkImpl.LockRegions.ConcreteRegionDefinitionList
File

RegionDefinitions.cs

See Also
Inheritance Hierarchy


ConcreteRegionDefinitionList Methods

ConcreteRegionDefinitionList Methods
Public Methods
Collapse All

The methods of the ConcreteRegionDefinitionList class are listed here.

Public Methods
Name | Description
FindByRootClass | This is FindByRootClass, a member of class ConcreteRegionDefinitionList.


ConcreteRegionDefinitionList.FindByRootClass Method

ConcreteRegionDefinitionList.FindByRootClass Method
ConcreteRegionDefinitionList Class Eco.FrameworkImpl.LockRegions Namespace See Also
Collapse All
C#
public TBoldConcreteRegionDefinition FindByRootClass(
    IClass RootClass
);
Remarks

This is FindByRootClass, a member of class ConcreteRegionDefinitionList.

See Also
ConcreteRegionDefinitionList Class
Eco.FrameworkImpl.LockRegions Namespace


IdChangedEventargs Class

IdChangedEventargs Class
Inheritance Hierarchy See Also
Collapse All
C#
public class IdChangedEventargs : ElementChangedEventArgs;
Remarks

This is class Eco.FrameworkImpl.LockRegions.IdChangedEventargs.

Inheritance Hierarchy
Eco.FrameworkImpl.LockRegions.IdChangedEventargs
File

LockRegions.cs

See Also
Inheritance Hierarchy


IdChangedEventargs.IdChangedEventargs Constructor

IdChangedEventargs.IdChangedEventargs Constructor
IdChangedEventargs Class Eco.FrameworkImpl.LockRegions Namespace See Also
Collapse All
C#
public IdChangedEventargs(
    IElement Element,
    bool PreChange
);
Remarks

Constructor Create( Element, PreChange)

See Also
IdChangedEventargs Class
Eco.FrameworkImpl.LockRegions Namespace


IdChangedEventargs Properties

IdChangedEventargs Properties
Public Properties
Collapse All

The properties of the IdChangedEventargs class are listed here.

Public Properties
Name | Description
PreChange | This is PreChange, a member of class IdChangedEventargs.


IdChangedEventargs.PreChange Property

IdChangedEventargs.PreChange Property
IdChangedEventargs Class Eco.FrameworkImpl.LockRegions Namespace See Also
Collapse All
C#
public bool PreChange;
Remarks

This is PreChange, a member of class IdChangedEventargs.

See Also
IdChangedEventargs Class
Eco.FrameworkImpl.LockRegions Namespace


LockRegionImpl Class

LockRegionImpl Class
Inheritance Hierarchy See Also
Collapse All
C#
public class LockRegionImpl : ILockRegion;
Remarks

This is class Eco.FrameworkImpl.LockRegions.LockRegionImpl.

Inheritance Hierarchy
Eco.FrameworkImpl.LockRegions.ILockRegion
    Eco.FrameworkImpl.LockRegions.LockRegionImpl
File

LockRegions.cs

See Also
Inheritance Hierarchy


LockRegionImpl.LockRegionImpl Constructor

LockRegionImpl.LockRegionImpl Constructor
LockRegionImpl Class Eco.FrameworkImpl.LockRegions Namespace See Also
Collapse All
C#
public LockRegionImpl(
    TBoldConcreteRegionDefinition Definition,
    Locator RootLocator,
    TBoldRegionFactory Factory
);
Remarks

This is LockRegionImpl, a member of class LockRegionImpl.

See Also
LockRegionImpl Class
Eco.FrameworkImpl.LockRegions Namespace


LockRegionImpl Methods

LockRegionImpl Methods
Public Methods
Collapse All

The methods of the LockRegionImpl class are listed here.

Public Methods
Name | Description
FillDependentSubregions | This is FillDependentSubregions, a member of class LockRegionImpl.
FillIndependentSubregions | This is FillIndependentSubregions, a member of class LockRegionImpl.
GetRegionElements | This is GetRegionElements, a member of class LockRegionImpl.
NavigateAndSubscribe | This is NavigateAndSubscribe, a member of class LockRegionImpl.
ToString | This is ToString, a member of class LockRegionImpl.


LockRegionImpl.FillDependentSubregions Method

LockRegionImpl.FillDependentSubregions Method
LockRegionImpl Class Eco.FrameworkImpl.LockRegions Namespace See Also
Collapse All
C#
public void FillDependentSubregions(
    List<ILockRegion> RegionList
);
Remarks

This is FillDependentSubregions, a member of class LockRegionImpl.

See Also
LockRegionImpl Class
Eco.FrameworkImpl.LockRegions Namespace


LockRegionImpl.FillIndependentSubregions Method

LockRegionImpl.FillIndependentSubregions Method
LockRegionImpl Class Eco.FrameworkImpl.LockRegions Namespace See Also
Collapse All
C#
public void FillIndependentSubregions(
    List<ILockRegion> RegionList
);
Remarks

This is FillIndependentSubregions, a member of class LockRegionImpl.

See Also
LockRegionImpl Class
Eco.FrameworkImpl.LockRegions Namespace


LockRegionImpl.GetRegionElements Method

LockRegionImpl.GetRegionElements Method
LockRegionImpl Class Eco.FrameworkImpl.LockRegions Namespace See Also
Collapse All
C#
public ICollection<TRegionElement> GetRegionElements();
Remarks

This is GetRegionElements, a member of class LockRegionImpl.

See Also
LockRegionImpl Class
Eco.FrameworkImpl.LockRegions Namespace


LockRegionImpl.NavigateAndSubscribe Method

LockRegionImpl.NavigateAndSubscribe Method
LockRegionImpl Class Eco.FrameworkImpl.LockRegions Namespace See Also
Collapse All
C#
public IEnumerable<Locator> NavigateAndSubscribe(
    IAssociationEnd RoleRT,
    ISubscriber Subscriber,
    bool Ensure
);
Remarks

This is NavigateAndSubscribe, a member of class LockRegionImpl.

See Also
LockRegionImpl Class
Eco.FrameworkImpl.LockRegions Namespace


LockRegionImpl.ToString Method

LockRegionImpl.ToString Method
LockRegionImpl Class Eco.FrameworkImpl.LockRegions Namespace See Also
Collapse All
C#
public override string ToString();
Remarks

This is ToString, a member of class LockRegionImpl.

See Also
LockRegionImpl Class
Eco.FrameworkImpl.LockRegions Namespace


LockRegionImpl Properties

LockRegionImpl Properties
Public Properties
Collapse All

The properties of the LockRegionImpl class are listed here.

Public Properties
Name | Description
Definition | This is Definition, a member of class LockRegionImpl.
Factory | This is Factory, a member of class LockRegionImpl.
RegionChangedAdapter | This is RegionChangedAdapter, a member of class LockRegionImpl.
RegionId | This is RegionId, a member of class LockRegionImpl.
RootClass | This is RootClass, a member of class LockRegionImpl.
RootLocator | This is RootLocator, a member of class LockRegionImpl.


LockRegionImpl.Definition Property

LockRegionImpl.Definition Property
LockRegionImpl Class Eco.FrameworkImpl.LockRegions Namespace See Also
Collapse All
C#
public TBoldConcreteRegionDefinition Definition;
Remarks

This is Definition, a member of class LockRegionImpl.

See Also
LockRegionImpl Class
Eco.FrameworkImpl.LockRegions Namespace


LockRegionImpl.Factory Property

LockRegionImpl.Factory Property
LockRegionImpl Class Eco.FrameworkImpl.LockRegions Namespace See Also
Collapse All
C#
public TBoldRegionFactory Factory;
Remarks

This is Factory, a member of class LockRegionImpl.

See Also
LockRegionImpl Class
Eco.FrameworkImpl.LockRegions Namespace


LockRegionImpl.RegionChangedAdapter Property

LockRegionImpl.RegionChangedAdapter Property
LockRegionImpl Class Eco.FrameworkImpl.LockRegions Namespace See Also
Collapse All
C#
public TBoldRegionChangedAdapter RegionChangedAdapter;
Remarks

This is RegionChangedAdapter, a member of class LockRegionImpl.

See Also
LockRegionImpl Class
Eco.FrameworkImpl.LockRegions Namespace


LockRegionImpl.RegionId Property

LockRegionImpl.RegionId Property
LockRegionImpl Class Eco.FrameworkImpl.LockRegions Namespace See Also
Collapse All
C#
public string RegionId;
Remarks

This is RegionId, a member of class LockRegionImpl.

See Also
LockRegionImpl Class
Eco.FrameworkImpl.LockRegions Namespace


LockRegionImpl.RootClass Property

LockRegionImpl.RootClass Property
LockRegionImpl Class Eco.FrameworkImpl.LockRegions Namespace See Also
Collapse All
C#
public IClass RootClass;
Remarks

This is RootClass, a member of class LockRegionImpl.

See Also
LockRegionImpl Class
Eco.FrameworkImpl.LockRegions Namespace


LockRegionImpl.RootLocator Property

LockRegionImpl.RootLocator Property
LockRegionImpl Class Eco.FrameworkImpl.LockRegions Namespace See Also
Collapse All
C#
public Locator RootLocator;
Remarks

This is RootLocator, a member of class LockRegionImpl.

See Also
LockRegionImpl Class
Eco.FrameworkImpl.LockRegions Namespace


RegionExpressionSyntaxErrorException Class

RegionExpressionSyntaxErrorException Class
Example Inheritance Hierarchy See Also
Collapse All
C#
public class RegionExpressionSyntaxErrorException : Exception;
Remarks

Format RegionName[ClassName] : memberName (, memberName)* (| RegionName[memberName] (, RegionName[memberName]*))

Example

Region1[Person]: firstName, lastName | Region2[home] Region1[Building]: zipCode Region1[Residential_Building]: totalRent

Inheritance Hierarchy
Eco.FrameworkImpl.LockRegions.RegionExpressionSyntaxErrorException
File

RegionDefinitionParser.cs

See Also
Example
Inheritance Hierarchy


RegionExpressionSyntaxErrorException.RegionExpressionSyntaxErrorException Constructor

RegionExpressionSyntaxErrorException.RegionExpressionSyntaxErrorException Constructor
RegionExpressionSyntaxErrorException Class Eco.FrameworkImpl.LockRegions Namespace See Also
Collapse All
C#
public RegionExpressionSyntaxErrorException(
    string s
);
Remarks

This is RegionExpressionSyntaxErrorException, a member of class RegionExpressionSyntaxErrorException.

See Also
RegionExpressionSyntaxErrorException Class
Eco.FrameworkImpl.LockRegions Namespace


RegionParser Class

RegionParser Class
Inheritance Hierarchy See Also
Collapse All
C#
public class RegionParser;
Remarks

This is class Eco.FrameworkImpl.LockRegions.RegionParser.

Inheritance Hierarchy
Eco.FrameworkImpl.LockRegions.RegionParser
File

RegionDefinitionParser.cs

See Also
Inheritance Hierarchy


RegionParser.RegionParser Constructor

RegionParser.RegionParser Constructor
RegionParser Class Eco.FrameworkImpl.LockRegions Namespace See Also
Collapse All
C#
public RegionParser(
    IEcoTypeSystem systemTypeInfo
);
Remarks

This is RegionParser, a member of class RegionParser.

See Also
RegionParser Class
Eco.FrameworkImpl.LockRegions Namespace


RegionParser Methods

RegionParser Methods
Protected Methods Public Methods
Collapse All

The methods of the RegionParser class are listed here.

Protected Methods
Name | Description
Skip | This is Skip, a member of class RegionParser.
TryToEat | This is TryToEat, a member of class RegionParser.
Top
Public Methods
Name | Description
Parse | This is Parse, a member of class RegionParser.


RegionParser.Parse Method

RegionParser.Parse Method
RegionParser Class Eco.FrameworkImpl.LockRegions Namespace See Also
Collapse All
C#
public bool Parse(
    string RegionDefinitionListAsString
);
Remarks

This is Parse, a member of class RegionParser.

See Also
RegionParser Class
Eco.FrameworkImpl.LockRegions Namespace


RegionParser.Skip Method

RegionParser.Skip Method
RegionParser Class Eco.FrameworkImpl.LockRegions Namespace See Also
Collapse All
C#
protected void Skip();
Remarks

This is Skip, a member of class RegionParser.

See Also
RegionParser Class
Eco.FrameworkImpl.LockRegions Namespace


RegionParser.TryToEat Method

RegionParser.TryToEat Method
RegionParser Class Eco.FrameworkImpl.LockRegions Namespace See Also
Collapse All
C#
protected bool TryToEat(
    string s
);
Remarks

This is TryToEat, a member of class RegionParser.

See Also
RegionParser Class
Eco.FrameworkImpl.LockRegions Namespace


RegionParser Properties

RegionParser Properties
Public Properties
Collapse All

The properties of the RegionParser class are listed here.

Public Properties
Name | Description
Errors | This is Errors, a member of class RegionParser.
RegionDefinitions | This is RegionDefinitions, a member of class RegionParser.


RegionParser.Errors Property

RegionParser.Errors Property
RegionParser Class Eco.FrameworkImpl.LockRegions Namespace See Also
Collapse All
C#
public IList<string> Errors;
Remarks

This is Errors, a member of class RegionParser.

See Also
RegionParser Class
Eco.FrameworkImpl.LockRegions Namespace


RegionParser.RegionDefinitions Property

RegionParser.RegionDefinitions Property
RegionParser Class Eco.FrameworkImpl.LockRegions Namespace See Also
Collapse All
C#
public TBoldRegionDefinitions RegionDefinitions;
Remarks

This is RegionDefinitions, a member of class RegionParser.

See Also
RegionParser Class
Eco.FrameworkImpl.LockRegions Namespace


TBoldConcreteRegionDefinition Class

TBoldConcreteRegionDefinition Class
Inheritance Hierarchy See Also
Collapse All
C#
public class TBoldConcreteRegionDefinition;
Remarks

TBoldConcreteRegionDefinition

Inheritance Hierarchy
Eco.FrameworkImpl.LockRegions.TBoldConcreteRegionDefinition
File

RegionDefinitions.cs

See Also
Inheritance Hierarchy


TBoldConcreteRegionDefinition.TBoldConcreteRegionDefinition Constructor

TBoldConcreteRegionDefinition.TBoldConcreteRegionDefinition Constructor
TBoldConcreteRegionDefinition Class Eco.FrameworkImpl.LockRegions Namespace See Also
Collapse All
C#
public TBoldConcreteRegionDefinition(
    TBoldRegionCoreDefinition CoreDefinition,
    IClass Root
);
Remarks

Constructor Create( CoreDefinition, Root)

See Also
TBoldConcreteRegionDefinition Class
Eco.FrameworkImpl.LockRegions Namespace


TBoldConcreteRegionDefinition Methods

TBoldConcreteRegionDefinition Methods
Public Methods
Collapse All

The methods of the TBoldConcreteRegionDefinition class are listed here.

Public Methods
Name | Description
ToString | This is ToString, a member of class TBoldConcreteRegionDefinition.


TBoldConcreteRegionDefinition.ToString Method

TBoldConcreteRegionDefinition.ToString Method
TBoldConcreteRegionDefinition Class Eco.FrameworkImpl.LockRegions Namespace See Also
Collapse All
C#
public override string ToString();
Remarks

This is ToString, a member of class TBoldConcreteRegionDefinition.

See Also
TBoldConcreteRegionDefinition Class
Eco.FrameworkImpl.LockRegions Namespace


TBoldConcreteRegionDefinition Properties

TBoldConcreteRegionDefinition Properties
Public Properties
Collapse All

The properties of the TBoldConcreteRegionDefinition class are listed here.

Public Properties
Name | Description
CoreDefinition | This is CoreDefinition, a member of class TBoldConcreteRegionDefinition.
Elements | This is Elements, a member of class TBoldConcreteRegionDefinition.
ParentRegions | This is ParentRegions, a member of class TBoldConcreteRegionDefinition.
RootClass | This is RootClass, a member of class TBoldConcreteRegionDefinition.
Subregions | This is Subregions, a member of class TBoldConcreteRegionDefinition.


TBoldConcreteRegionDefinition.CoreDefinition Property

TBoldConcreteRegionDefinition.CoreDefinition Property
TBoldConcreteRegionDefinition Class Eco.FrameworkImpl.LockRegions Namespace See Also
Collapse All
C#
public TBoldRegionCoreDefinition CoreDefinition;
Remarks

This is CoreDefinition, a member of class TBoldConcreteRegionDefinition.

See Also
TBoldConcreteRegionDefinition Class
Eco.FrameworkImpl.LockRegions Namespace


TBoldConcreteRegionDefinition.Elements Property

TBoldConcreteRegionDefinition.Elements Property
TBoldConcreteRegionDefinition Class Eco.FrameworkImpl.LockRegions Namespace See Also
Collapse All
C#
public List<TBoldRegionElementInclusion> Elements;
Remarks

This is Elements, a member of class TBoldConcreteRegionDefinition.

See Also
TBoldConcreteRegionDefinition Class
Eco.FrameworkImpl.LockRegions Namespace


TBoldConcreteRegionDefinition.ParentRegions Property

TBoldConcreteRegionDefinition.ParentRegions Property
TBoldConcreteRegionDefinition Class Eco.FrameworkImpl.LockRegions Namespace See Also
Collapse All
C#
public List<TBoldSubregionReference> ParentRegions;
Remarks

This is ParentRegions, a member of class TBoldConcreteRegionDefinition.

See Also
TBoldConcreteRegionDefinition Class
Eco.FrameworkImpl.LockRegions Namespace


TBoldConcreteRegionDefinition.RootClass Property

TBoldConcreteRegionDefinition.RootClass Property
TBoldConcreteRegionDefinition Class Eco.FrameworkImpl.LockRegions Namespace See Also
Collapse All
C#
public IClass RootClass;
Remarks

This is RootClass, a member of class TBoldConcreteRegionDefinition.

See Also
TBoldConcreteRegionDefinition Class
Eco.FrameworkImpl.LockRegions Namespace


TBoldConcreteRegionDefinition.Subregions Property

TBoldConcreteRegionDefinition.Subregions Property
TBoldConcreteRegionDefinition Class Eco.FrameworkImpl.LockRegions Namespace See Also
Collapse All
C#
public ICollection<TBoldSubregionReference> Subregions;
Remarks

This is Subregions, a member of class TBoldConcreteRegionDefinition.

See Also
TBoldConcreteRegionDefinition Class
Eco.FrameworkImpl.LockRegions Namespace


TBoldIdChangedAdapter Class

TBoldIdChangedAdapter Class
Inheritance Hierarchy See Also
Collapse All
C#
public class TBoldIdChangedAdapter : SubscriberAdapterBase;
Remarks

This is class Eco.FrameworkImpl.LockRegions.TBoldIdChangedAdapter.

Inheritance Hierarchy
Eco.FrameworkImpl.LockRegions.TBoldIdChangedAdapter
File

LockRegions.cs

See Also
Inheritance Hierarchy


TBoldIdChangedAdapter.TBoldIdChangedAdapter Constructor

TBoldIdChangedAdapter.TBoldIdChangedAdapter Constructor
TBoldIdChangedAdapter Class Eco.FrameworkImpl.LockRegions Namespace See Also
Collapse All
C#
public TBoldIdChangedAdapter(
    object subscriber
);
Remarks

This is TBoldIdChangedAdapter, a member of class TBoldIdChangedAdapter.

See Also
TBoldIdChangedAdapter Class
Eco.FrameworkImpl.LockRegions Namespace


TBoldIdChangedAdapter Methods

TBoldIdChangedAdapter Methods
Protected Methods
Collapse All

The methods of the TBoldIdChangedAdapter class are listed here.

Protected Methods
Name | Description
DoReceive | This is DoReceive, a member of class TBoldIdChangedAdapter.


TBoldIdChangedAdapter.DoReceive Method

TBoldIdChangedAdapter.DoReceive Method
TBoldIdChangedAdapter Class Eco.FrameworkImpl.LockRegions Namespace See Also
Collapse All
C#
protected override void DoReceive(
    object sender,
    EventArgs e,
    object actualSubscriber
);
Remarks

This is DoReceive, a member of class TBoldIdChangedAdapter.

See Also
TBoldIdChangedAdapter Class
Eco.FrameworkImpl.LockRegions Namespace


TBoldOrderedRegionLookup Class

TBoldOrderedRegionLookup Class
Inheritance Hierarchy See Also
Collapse All
C#
public class TBoldOrderedRegionLookup : TBoldRegionLookup;
Remarks

TBoldOrderedRegionLookup

Inheritance Hierarchy
Eco.FrameworkImpl.LockRegions.TBoldRegionLookup
    Eco.FrameworkImpl.LockRegions.TBoldOrderedRegionLookup
File

LockRegions.cs

See Also
Inheritance Hierarchy


TBoldOrderedRegionLookup Methods

TBoldOrderedRegionLookup Methods
Public Methods
Collapse All

The methods of the TBoldOrderedRegionLookup class are listed here.

Public Methods
Name | Description
Add | TBoldOrderedRegionLookup
Clear | This is Clear, a member of class TBoldOrderedRegionLookup.
Remove | This is Remove, a member of class TBoldOrderedRegionLookup.


TBoldOrderedRegionLookup.Add Method

TBoldOrderedRegionLookup.Add Method
TBoldOrderedRegionLookup Class Eco.FrameworkImpl.LockRegions Namespace See Also
Collapse All
C#
public override void Add(
    ILockRegion Region
);
Remarks

TBoldOrderedRegionLookup

See Also
TBoldOrderedRegionLookup Class
Eco.FrameworkImpl.LockRegions Namespace


TBoldOrderedRegionLookup.Clear Method

TBoldOrderedRegionLookup.Clear Method
TBoldOrderedRegionLookup Class Eco.FrameworkImpl.LockRegions Namespace See Also
Collapse All
C#
public override void Clear();
Remarks

This is Clear, a member of class TBoldOrderedRegionLookup.

See Also
TBoldOrderedRegionLookup Class
Eco.FrameworkImpl.LockRegions Namespace


TBoldOrderedRegionLookup.Remove Method

TBoldOrderedRegionLookup.Remove Method
TBoldOrderedRegionLookup Class Eco.FrameworkImpl.LockRegions Namespace See Also
Collapse All
C#
public override void Remove(
    ILockRegion Region
);
Remarks

This is Remove, a member of class TBoldOrderedRegionLookup.

See Also
TBoldOrderedRegionLookup Class
Eco.FrameworkImpl.LockRegions Namespace


TBoldOrderedRegionLookup Properties

TBoldOrderedRegionLookup Properties
Public Properties
Collapse All

The properties of the TBoldOrderedRegionLookup class are listed here.

Public Properties
Name | Description
FirstRegion | This is FirstRegion, a member of class TBoldOrderedRegionLookup.


TBoldOrderedRegionLookup.FirstRegion Property

TBoldOrderedRegionLookup.FirstRegion Property
TBoldOrderedRegionLookup Class Eco.FrameworkImpl.LockRegions Namespace See Also
Collapse All
C#
public ILockRegion FirstRegion;
Remarks

This is FirstRegion, a member of class TBoldOrderedRegionLookup.

See Also
TBoldOrderedRegionLookup Class
Eco.FrameworkImpl.LockRegions Namespace


TBoldRegionChangedAdapter Class

TBoldRegionChangedAdapter Class
Inheritance Hierarchy See Also
Collapse All
C#
public class TBoldRegionChangedAdapter : SubscriberAdapterBase;
Remarks

TBoldRegionChangedAdapter

Inheritance Hierarchy
Eco.FrameworkImpl.LockRegions.TBoldRegionChangedAdapter
File

LockRegions.cs

See Also
Inheritance Hierarchy


TBoldRegionChangedAdapter.TBoldRegionChangedAdapter Constructor

TBoldRegionChangedAdapter.TBoldRegionChangedAdapter Constructor
TBoldRegionChangedAdapter Class Eco.FrameworkImpl.LockRegions Namespace See Also
Collapse All
C#
public TBoldRegionChangedAdapter(
    object subscriber
);
Remarks

TBoldRegionChangedAdapter Constructor Create( subscriber)

See Also
TBoldRegionChangedAdapter Class
Eco.FrameworkImpl.LockRegions Namespace


TBoldRegionChangedAdapter Methods

TBoldRegionChangedAdapter Methods
Protected Methods
Collapse All

The methods of the TBoldRegionChangedAdapter class are listed here.

Protected Methods
Name | Description
DoReceive | This is DoReceive, a member of class TBoldRegionChangedAdapter.


TBoldRegionChangedAdapter.DoReceive Method

TBoldRegionChangedAdapter.DoReceive Method
TBoldRegionChangedAdapter Class Eco.FrameworkImpl.LockRegions Namespace See Also
Collapse All
C#
protected override void DoReceive(
    object sender,
    EventArgs e,
    object actualSubscriber
);
Remarks

This is DoReceive, a member of class TBoldRegionChangedAdapter.

See Also
TBoldRegionChangedAdapter Class
Eco.FrameworkImpl.LockRegions Namespace


TBoldRegionCoreDefinition Class

TBoldRegionCoreDefinition Class
Inheritance Hierarchy See Also
Collapse All
C#
public class TBoldRegionCoreDefinition;
Remarks

end TBoldRegionDefinitions

Inheritance Hierarchy
Eco.FrameworkImpl.LockRegions.TBoldRegionCoreDefinition
File

RegionDefinitions.cs

See Also
Inheritance Hierarchy


TBoldRegionCoreDefinition.TBoldRegionCoreDefinition Constructor

TBoldRegionCoreDefinition.TBoldRegionCoreDefinition Constructor
TBoldRegionCoreDefinition Class Eco.FrameworkImpl.LockRegions Namespace See Also
Collapse All
C#
public TBoldRegionCoreDefinition(
    TBoldRegionDefinitions Owner,
    string Name
);
Remarks

TBoldRegionCoreDefinition Constructor Create( Owner, Name)

See Also
TBoldRegionCoreDefinition Class
Eco.FrameworkImpl.LockRegions Namespace


TBoldRegionCoreDefinition Methods

TBoldRegionCoreDefinition Methods
Public Methods
Collapse All

The methods of the TBoldRegionCoreDefinition class are listed here.

Public Methods
Name | Description
EnsuredConcreteDefinition | This is EnsuredConcreteDefinition, a member of class TBoldRegionCoreDefinition.


TBoldRegionCoreDefinition.EnsuredConcreteDefinition Method

TBoldRegionCoreDefinition.EnsuredConcreteDefinition Method
TBoldRegionCoreDefinition Class Eco.FrameworkImpl.LockRegions Namespace See Also
Collapse All
C#
public TBoldConcreteRegionDefinition EnsuredConcreteDefinition(
    IClass Root,
    out bool Existed
);
Remarks

This is EnsuredConcreteDefinition, a member of class TBoldRegionCoreDefinition.

See Also
TBoldRegionCoreDefinition Class
Eco.FrameworkImpl.LockRegions Namespace


TBoldRegionCoreDefinition Properties

TBoldRegionCoreDefinition Properties
Public Properties
Collapse All

The properties of the TBoldRegionCoreDefinition class are listed here.

Public Properties
Name | Description
ConcreteDefinitions | This is ConcreteDefinitions, a member of class TBoldRegionCoreDefinition.
Name | This is Name, a member of class TBoldRegionCoreDefinition.
Owner | This is Owner, a member of class TBoldRegionCoreDefinition.
UsedBy | This is UsedBy, a member of class TBoldRegionCoreDefinition.


TBoldRegionCoreDefinition.ConcreteDefinitions Property

TBoldRegionCoreDefinition.ConcreteDefinitions Property
TBoldRegionCoreDefinition Class Eco.FrameworkImpl.LockRegions Namespace See Also
Collapse All
C#
public ConcreteRegionDefinitionList ConcreteDefinitions;
Remarks

This is ConcreteDefinitions, a member of class TBoldRegionCoreDefinition.

See Also
TBoldRegionCoreDefinition Class
Eco.FrameworkImpl.LockRegions Namespace


TBoldRegionCoreDefinition.Name Property

TBoldRegionCoreDefinition.Name Property
TBoldRegionCoreDefinition Class Eco.FrameworkImpl.LockRegions Namespace See Also
Collapse All
C#
public string Name;
Remarks

This is Name, a member of class TBoldRegionCoreDefinition.

See Also
TBoldRegionCoreDefinition Class
Eco.FrameworkImpl.LockRegions Namespace


TBoldRegionCoreDefinition.Owner Property

TBoldRegionCoreDefinition.Owner Property
TBoldRegionCoreDefinition Class Eco.FrameworkImpl.LockRegions Namespace See Also
Collapse All
C#
public TBoldRegionDefinitions Owner;
Remarks

This is Owner, a member of class TBoldRegionCoreDefinition.

See Also
TBoldRegionCoreDefinition Class
Eco.FrameworkImpl.LockRegions Namespace


TBoldRegionCoreDefinition.UsedBy Property

TBoldRegionCoreDefinition.UsedBy Property
TBoldRegionCoreDefinition Class Eco.FrameworkImpl.LockRegions Namespace See Also
Collapse All
C#
public List<TBoldSubregionReference> UsedBy;
Remarks

This is UsedBy, a member of class TBoldRegionCoreDefinition.

See Also
TBoldRegionCoreDefinition Class
Eco.FrameworkImpl.LockRegions Namespace


TBoldRegionDefinitions Class

TBoldRegionDefinitions Class
Inheritance Hierarchy See Also
Collapse All
C#
public class TBoldRegionDefinitions;
Remarks

TBoldRegionDefinitions

Inheritance Hierarchy
Eco.FrameworkImpl.LockRegions.TBoldRegionDefinitions
File

RegionDefinitions.cs

See Also
Inheritance Hierarchy


TBoldRegionDefinitions.TBoldRegionDefinitions Constructor

TBoldRegionDefinitions.TBoldRegionDefinitions Constructor
TBoldRegionDefinitions Class Eco.FrameworkImpl.LockRegions Namespace See Also
Collapse All
C#
public TBoldRegionDefinitions();
Remarks

Constructor Create()

See Also
TBoldRegionDefinitions Class
Eco.FrameworkImpl.LockRegions Namespace


TBoldRegionDefinitions Classes

TBoldRegionDefinitions Classes
Classes
Collapse All

The classes of the TBoldRegionDefinitions class are listed here.

Classes
Name | Description
ClassListType | This is class Eco.FrameworkImpl.LockRegions.TBoldRegionDefinitions.ClassListType.
MemberListItemType | This is class Eco.FrameworkImpl.LockRegions.TBoldRegionDefinitions.MemberListItemType.
MemberListType | This is class Eco.FrameworkImpl.LockRegions.TBoldRegionDefinitions.MemberListType.


TBoldRegionDefinitions.ClassListType Class

TBoldRegionDefinitions.ClassListType Class
Inheritance Hierarchy See Also
Collapse All
C#
public class ClassListType : List<MemberListType>;
Remarks

This is class Eco.FrameworkImpl.LockRegions.TBoldRegionDefinitions.ClassListType.

Inheritance Hierarchy
Eco.FrameworkImpl.LockRegions.TBoldRegionDefinitions.ClassListType
File

RegionDefinitions.cs

See Also
Inheritance Hierarchy


TBoldRegionDefinitions.MemberListItemType Class

TBoldRegionDefinitions.MemberListItemType Class
Inheritance Hierarchy See Also
Collapse All
C#
public class MemberListItemType : List<TBoldRegionElementInclusion>;
Remarks

This is class Eco.FrameworkImpl.LockRegions.TBoldRegionDefinitions.MemberListItemType.

Inheritance Hierarchy
Eco.FrameworkImpl.LockRegions.TBoldRegionDefinitions.MemberListItemType
File

RegionDefinitions.cs

See Also
Inheritance Hierarchy


TBoldRegionDefinitions.MemberListType Class

TBoldRegionDefinitions.MemberListType Class
Inheritance Hierarchy See Also
Collapse All
C#
public class MemberListType : List<MemberListItemType>;
Remarks

This is class Eco.FrameworkImpl.LockRegions.TBoldRegionDefinitions.MemberListType.

Inheritance Hierarchy
Eco.FrameworkImpl.LockRegions.TBoldRegionDefinitions.MemberListType
File

RegionDefinitions.cs

See Also
Inheritance Hierarchy


TBoldRegionDefinitions Methods

TBoldRegionDefinitions Methods
Public Methods
Collapse All

The methods of the TBoldRegionDefinitions class are listed here.

Public Methods
Name | Description
ConcreteRegionDefinitionsByRootClass | This is ConcreteRegionDefinitionsByRootClass, a member of class TBoldRegionDefinitions.
CoreDefinition | This is CoreDefinition, a member of class TBoldRegionDefinitions.
EnsuredCoreDefinition | This is EnsuredCoreDefinition, a member of class TBoldRegionDefinitions.
ExpandDefinitions | This is ExpandDefinitions, a member of class TBoldRegionDefinitions.
RegionInclusionsByMember | This is RegionInclusionsByMember, a member of class TBoldRegionDefinitions.


TBoldRegionDefinitions.ConcreteRegionDefinitionsByRootClass Method

TBoldRegionDefinitions.ConcreteRegionDefinitionsByRootClass Method
TBoldRegionDefinitions Class Eco.FrameworkImpl.LockRegions Namespace See Also
Collapse All
C#
public ConcreteRegionDefinitionList ConcreteRegionDefinitionsByRootClass(
    IClass TheClass
);
Remarks

This is ConcreteRegionDefinitionsByRootClass, a member of class TBoldRegionDefinitions.

See Also
TBoldRegionDefinitions Class
Eco.FrameworkImpl.LockRegions Namespace


TBoldRegionDefinitions.CoreDefinition Method

TBoldRegionDefinitions.CoreDefinition Method
TBoldRegionDefinitions Class Eco.FrameworkImpl.LockRegions Namespace See Also
Collapse All
C#
public TBoldRegionCoreDefinition CoreDefinition(
    string Name
);
Remarks

This is CoreDefinition, a member of class TBoldRegionDefinitions.

See Also
TBoldRegionDefinitions Class
Eco.FrameworkImpl.LockRegions Namespace


TBoldRegionDefinitions.EnsuredCoreDefinition Method

TBoldRegionDefinitions.EnsuredCoreDefinition Method
TBoldRegionDefinitions Class Eco.FrameworkImpl.LockRegions Namespace See Also
Collapse All
C#
public TBoldRegionCoreDefinition EnsuredCoreDefinition(
    string Name
);
Remarks

This is EnsuredCoreDefinition, a member of class TBoldRegionDefinitions.

See Also
TBoldRegionDefinitions Class
Eco.FrameworkImpl.LockRegions Namespace


TBoldRegionDefinitions.ExpandDefinitions Method

TBoldRegionDefinitions.ExpandDefinitions Method
TBoldRegionDefinitions Class Eco.FrameworkImpl.LockRegions Namespace See Also
Collapse All
C#
public void ExpandDefinitions();
Remarks

This is ExpandDefinitions, a member of class TBoldRegionDefinitions.

See Also
TBoldRegionDefinitions Class
Eco.FrameworkImpl.LockRegions Namespace


TBoldRegionDefinitions.RegionInclusionsByMember Method

TBoldRegionDefinitions.RegionInclusionsByMember Method
TBoldRegionDefinitions Class Eco.FrameworkImpl.LockRegions Namespace See Also
Collapse All
C#
public List<TBoldRegionElementInclusion> RegionInclusionsByMember(
    IStructuralFeature Member
);
Remarks

This is RegionInclusionsByMember, a member of class TBoldRegionDefinitions.

See Also
TBoldRegionDefinitions Class
Eco.FrameworkImpl.LockRegions Namespace


TBoldRegionDefinitions Properties

TBoldRegionDefinitions Properties
Public Properties
Collapse All

The properties of the TBoldRegionDefinitions class are listed here.

Public Properties
Name | Description
CoreDefinitions | This is CoreDefinitions, a member of class TBoldRegionDefinitions.


TBoldRegionDefinitions.CoreDefinitions Property

TBoldRegionDefinitions.CoreDefinitions Property
TBoldRegionDefinitions Class Eco.FrameworkImpl.LockRegions Namespace See Also
Collapse All
C#
public List<TBoldRegionCoreDefinition> CoreDefinitions;
Remarks

This is CoreDefinitions, a member of class TBoldRegionDefinitions.

See Also
TBoldRegionDefinitions Class
Eco.FrameworkImpl.LockRegions Namespace


TBoldRegionElementInclusion Class

TBoldRegionElementInclusion Class
Inheritance Hierarchy See Also
Collapse All
C#
public class TBoldRegionElementInclusion;
Remarks

TBoldRegionElementInclusion

Inheritance Hierarchy
Eco.FrameworkImpl.LockRegions.TBoldRegionElementInclusion
File

RegionDefinitions.cs

See Also
Inheritance Hierarchy


TBoldRegionElementInclusion.TBoldRegionElementInclusion Constructor

TBoldRegionElementInclusion.TBoldRegionElementInclusion Constructor
TBoldRegionElementInclusion Class Eco.FrameworkImpl.LockRegions Namespace See Also
Collapse All
C#
public TBoldRegionElementInclusion(
    TBoldConcreteRegionDefinition Region,
    IStructuralFeature Member
);
Remarks

Constructor Create( Region, Member)

See Also
TBoldRegionElementInclusion Class
Eco.FrameworkImpl.LockRegions Namespace


TBoldRegionElementInclusion Properties

TBoldRegionElementInclusion Properties
Public Properties
Collapse All

The properties of the TBoldRegionElementInclusion class are listed here.

Public Properties
Name | Description
Member | This is Member, a member of class TBoldRegionElementInclusion.
Region | This is Region, a member of class TBoldRegionElementInclusion.


TBoldRegionElementInclusion.Member Property

TBoldRegionElementInclusion.Member Property
TBoldRegionElementInclusion Class Eco.FrameworkImpl.LockRegions Namespace See Also
Collapse All
C#
public IStructuralFeature Member;
Remarks

This is Member, a member of class TBoldRegionElementInclusion.

See Also
TBoldRegionElementInclusion Class
Eco.FrameworkImpl.LockRegions Namespace


TBoldRegionElementInclusion.Region Property

TBoldRegionElementInclusion.Region Property
TBoldRegionElementInclusion Class Eco.FrameworkImpl.LockRegions Namespace See Also
Collapse All
C#
public TBoldConcreteRegionDefinition Region;
Remarks

This is Region, a member of class TBoldRegionElementInclusion.

See Also
TBoldRegionElementInclusion Class
Eco.FrameworkImpl.LockRegions Namespace


TBoldRegionExpander Class

TBoldRegionExpander Class
Inheritance Hierarchy See Also
Collapse All
C#
public class TBoldRegionExpander;
Remarks

TBoldRegionState = (rrSource, rrDepParent, rrIndepParent, rrDepSub, rrIndepSub);

TBoldRegionExpanderRegionLists = array[TBoldRegionState] of TBoldregionLookup; TBoldRegionExpander

Inheritance Hierarchy
Eco.FrameworkImpl.LockRegions.TBoldRegionExpander
File

LockRegions.cs

See Also
Inheritance Hierarchy


TBoldRegionExpander.TBoldRegionExpander Constructor

TBoldRegionExpander.TBoldRegionExpander Constructor
TBoldRegionExpander Class Eco.FrameworkImpl.LockRegions Namespace See Also
Collapse All
C#
public TBoldRegionExpander(
    IEcoTypeSystem typeSystem
);
Remarks

This is TBoldRegionExpander, a member of class TBoldRegionExpander.

See Also
TBoldRegionExpander Class
Eco.FrameworkImpl.LockRegions Namespace


TBoldRegionExpander Methods

TBoldRegionExpander Methods
Protected Methods Public Methods
Collapse All

The methods of the TBoldRegionExpander class are listed here.

Protected Methods
Name
Description
Clear
procedure TBoldRegionList.EnsureSubRegionObjects; var ObjectList: TBoldObjectList; i: integer; Region: TBoldRegion; SubRegionReferences: TBoldSubregionReferenceList; TempRegionList: TBoldRegionList; begin TempRegionList := TBoldRegionList.Create; ObjectList := TBoldObjectList.Create; try TempRegionList.AddList(self); while TempRegionList.Count > 0 do begin Region := TempRegionList[0]; for i := TempRegionList.Count - 1 downto 0 do begin if TempRegionList[i].Definition = Region.Definition then begin ObjectList.Add(TempRegionList[i].Root); TempRegionList.Delete(i); end; end; if ObjectList.Count > 1 then for i := 0 to Region.Definition.Subregions.Count - 1 do ObjectList[0].BoldSystem.FetchLinksWithObjects(ObjectList, Region.Definition.Subregions[i].SubregionRootNavigation.ExpressionName); ObjectList.Clear; end; for i := 0 to Count - 1 do begin Items[i].FillDependentSubregions(TempRegionList); Items[i].FillInDependentSubregions(TempRegionList); end; if TempRegionList.Count > 0 then TempRegionList.EnsureSubRegionObjects; finally ObjectList.Free; TempRegionList.Free; end; end; TBoldRegionExpander
ExtractSimilarRegions
procedure TBoldRegionExpander.ExpandSubAndParentRegions(ExplicitRegions: TBoldRegionList); begin Clear; // BoldLog.LogFmt('Start Expanding: %s', [DateTimeToStr(now)]); fToBeSubExpanded.AddRegionList(ExplicitRegions); fToBeParentExpanded.AddRegionList(ExplicitRegions); InternalExpandParents; InternalExpandSubRegions; // BoldLog.LogFmt('Done Expanding: %s', [DateTimeToStr(now)]); end;
Top
Public Methods
Name | Description
ExpandParentRegions | This is ExpandParentRegions, a member of class TBoldRegionExpander.
ExpandRegionEnclosure | This is ExpandRegionEnclosure, a member of class TBoldRegionExpander.
ExpandSubregions | This is ExpandSubregions, a member of class TBoldRegionExpander.


TBoldRegionExpander.Clear Method

TBoldRegionExpander.Clear Method
TBoldRegionExpander Class Eco.FrameworkImpl.LockRegions Namespace See Also
Collapse All
C#
protected void Clear();
Remarks

procedure TBoldRegionList.EnsureSubRegionObjects; var ObjectList: TBoldObjectList; i: integer; Region: TBoldRegion; SubRegionReferences: TBoldSubregionReferenceList; TempRegionList: TBoldRegionList; begin TempRegionList := TBoldRegionList.Create; ObjectList := TBoldObjectList.Create; try TempRegionList.AddList(self); while TempRegionList.Count > 0 do begin Region := TempRegionList[0]; for i := TempRegionList.Count - 1 downto 0 do begin if TempRegionList[i].Definition = Region.Definition then begin ObjectList.Add(TempRegionList[i].Root); TempRegionList.Delete(i); end; end; if ObjectList.Count > 1 then for i := 0 to Region.Definition.Subregions.Count - 1 do ObjectList[0].BoldSystem.FetchLinksWithObjects(ObjectList, Region.Definition.Subregions[i].SubregionRootNavigation.ExpressionName); ObjectList.Clear; end; for i := 0 to Count - 1 do begin Items[i].FillDependentSubregions(TempRegionList); Items[i].FillInDependentSubregions(TempRegionList); end; if TempRegionList.Count > 0 then TempRegionList.EnsureSubRegionObjects; finally ObjectList.Free; TempRegionList.Free; end; end; TBoldRegionExpander

See Also
TBoldRegionExpander Class
Eco.FrameworkImpl.LockRegions Namespace


TBoldRegionExpander.ExpandParentRegions Method

TBoldRegionExpander.ExpandParentRegions Method
TBoldRegionExpander Class Eco.FrameworkImpl.LockRegions Namespace See Also
Collapse All
C#
public void ExpandParentRegions(
    TBoldRegionLookup RegionsToExpand,
    TBoldRegionLookup KnownParentRegions,
    TBoldRegionLookup KnownSubregions,
    IPersistenceHandler PersistenceHandler
);
Remarks

This is ExpandParentRegions, a member of class TBoldRegionExpander.

See Also
TBoldRegionExpander Class
Eco.FrameworkImpl.LockRegions Namespace


TBoldRegionExpander.ExpandRegionEnclosure Method

TBoldRegionExpander.ExpandRegionEnclosure Method
TBoldRegionExpander Class Eco.FrameworkImpl.LockRegions Namespace See Also
Collapse All
C#
public void ExpandRegionEnclosure(
    TBoldRegionLookup Regions,
    IPersistenceHandler PersistenceHandler,
    ICache Cache
);
Remarks

This is ExpandRegionEnclosure, a member of class TBoldRegionExpander.

See Also
TBoldRegionExpander Class
Eco.FrameworkImpl.LockRegions Namespace


TBoldRegionExpander.ExpandSubregions Method

TBoldRegionExpander.ExpandSubregions Method
TBoldRegionExpander Class Eco.FrameworkImpl.LockRegions Namespace See Also
Collapse All
C#
public void ExpandSubregions(
    TBoldRegionLookup RegionsToExpand,
    TBoldRegionLookup KnownSubregions,
    IPersistenceHandler System,
    ICache Cache
);
Remarks

This is ExpandSubregions, a member of class TBoldRegionExpander.

See Also
TBoldRegionExpander Class
Eco.FrameworkImpl.LockRegions Namespace


TBoldRegionExpander.ExtractSimilarRegions Method

TBoldRegionExpander.ExtractSimilarRegions Method
TBoldRegionExpander Class Eco.FrameworkImpl.LockRegions Namespace See Also
Collapse All
C#
protected void ExtractSimilarRegions(
    TBoldRegionLookup Regions,
    ILockRegion Region,
    TBoldRegionLookup Result
);
Remarks

procedure TBoldRegionExpander.ExpandSubAndParentRegions(ExplicitRegions: TBoldRegionList); begin Clear; // BoldLog.LogFmt('Start Expanding: %s', [DateTimeToStr(now)]); fToBeSubExpanded.AddRegionList(ExplicitRegions); fToBeParentExpanded.AddRegionList(ExplicitRegions); InternalExpandParents; InternalExpandSubRegions; // BoldLog.LogFmt('Done Expanding: %s', [DateTimeToStr(now)]); end;

See Also
TBoldRegionExpander Class
Eco.FrameworkImpl.LockRegions Namespace


TBoldRegionExpander Properties

TBoldRegionExpander Properties
Public Properties
Collapse All

The properties of the TBoldRegionExpander class are listed here.

Public Properties
Name | Description
NewParentRegions | This is NewParentRegions, a member of class TBoldRegionExpander.
NewSubRegions | This is NewSubRegions, a member of class TBoldRegionExpander.
OnProgress | This is OnProgress, a member of class TBoldRegionExpander.


TBoldRegionExpander.NewParentRegions Property

TBoldRegionExpander.NewParentRegions Property
TBoldRegionExpander Class Eco.FrameworkImpl.LockRegions Namespace See Also
Collapse All
C#
public TBoldRegionLookup NewParentRegions;
Remarks

This is NewParentRegions, a member of class TBoldRegionExpander.

See Also
TBoldRegionExpander Class
Eco.FrameworkImpl.LockRegions Namespace


TBoldRegionExpander.NewSubRegions Property

TBoldRegionExpander.NewSubRegions Property
TBoldRegionExpander Class Eco.FrameworkImpl.LockRegions Namespace See Also
Collapse All
C#
public TBoldRegionLookup NewSubRegions;
Remarks

This is NewSubRegions, a member of class TBoldRegionExpander.

See Also
TBoldRegionExpander Class
Eco.FrameworkImpl.LockRegions Namespace


TBoldRegionExpander.OnProgress Property

TBoldRegionExpander.OnProgress Property
TBoldRegionExpander Class Eco.FrameworkImpl.LockRegions Namespace See Also
Collapse All
C#
public object OnProgress;
Remarks

This is OnProgress, a member of class TBoldRegionExpander.

See Also
TBoldRegionExpander Class
Eco.FrameworkImpl.LockRegions Namespace


TBoldRegionFactory Class

TBoldRegionFactory Class
Inheritance Hierarchy See Also
Collapse All
C#
public class TBoldRegionFactory : EcoSpacePartWithTypeSystem, IRegionFactory;
Remarks

TBoldRegionFactory

Inheritance Hierarchy
Eco.FrameworkImpl.LockRegions.IRegionFactory
    Eco.FrameworkImpl.LockRegions.TBoldRegionFactory
File

LockRegions.cs

See Also
Inheritance Hierarchy


TBoldRegionFactory.TBoldRegionFactory Constructor

TBoldRegionFactory.TBoldRegionFactory Constructor
TBoldRegionFactory Class Eco.FrameworkImpl.LockRegions Namespace See Also
Collapse All
C#
public TBoldRegionFactory(
    IEcoTypeSystem typeSystem
);
Remarks

Constructor Create( typeSystem)

See Also
TBoldRegionFactory Class
Eco.FrameworkImpl.LockRegions Namespace


TBoldRegionFactory Methods

TBoldRegionFactory Methods
Protected Methods Public Methods
Collapse All

The methods of the TBoldRegionFactory class are listed here.

Protected Methods
Name | Description
DoActivate | This is DoActivate, a member of class TBoldRegionFactory.
DoDeactivate | This is DoDeactivate, a member of class TBoldRegionFactory.
Top
Public Methods
Name | Description
GetRegion | This is GetRegion, a member of class TBoldRegionFactory.
GetRegionByName | This is GetRegionByName, a member of class TBoldRegionFactory.
GetRegionId | This is GetRegionId, a member of class TBoldRegionFactory.
GetRegionsForMember | This is GetRegionsForMember, a member of class TBoldRegionFactory.
GetRegionsForObject | IRegionFactory
RootObjectLocatorFromRegionId_ExtractIdAndClass | This is RootObjectLocatorFromRegionId_ExtractIdAndClass, a member of class TBoldRegionFactory.


TBoldRegionFactory.DoActivate Method

TBoldRegionFactory.DoActivate Method
TBoldRegionFactory Class Eco.FrameworkImpl.LockRegions Namespace See Also
Collapse All
C#
protected override void DoActivate();
Remarks

This is DoActivate, a member of class TBoldRegionFactory.

See Also
TBoldRegionFactory Class
Eco.FrameworkImpl.LockRegions Namespace


TBoldRegionFactory.DoDeactivate Method

TBoldRegionFactory.DoDeactivate Method
TBoldRegionFactory Class Eco.FrameworkImpl.LockRegions Namespace See Also
Collapse All
C#
protected override void DoDeactivate();
Remarks

This is DoDeactivate, a member of class TBoldRegionFactory.

See Also
TBoldRegionFactory Class
Eco.FrameworkImpl.LockRegions Namespace


TBoldRegionFactory.GetRegion Method

TBoldRegionFactory.GetRegion Method
TBoldRegionFactory Class Eco.FrameworkImpl.LockRegions Namespace See Also
Collapse All
C#
public ILockRegion GetRegion(
    TBoldRegionCoreDefinition Definition,
    Locator RootLocator
);
Remarks

This is GetRegion, a member of class TBoldRegionFactory.

See Also
TBoldRegionFactory Class
Eco.FrameworkImpl.LockRegions Namespace


TBoldRegionFactory.GetRegionByName Method

TBoldRegionFactory.GetRegionByName Method
TBoldRegionFactory Class Eco.FrameworkImpl.LockRegions Namespace See Also
Collapse All
C#
public ILockRegion GetRegionByName(
    string RegionName
);
Remarks

This is GetRegionByName, a member of class TBoldRegionFactory.

See Also
TBoldRegionFactory Class
Eco.FrameworkImpl.LockRegions Namespace


TBoldRegionFactory.GetRegionId Method

TBoldRegionFactory.GetRegionId Method
TBoldRegionFactory Class Eco.FrameworkImpl.LockRegions Namespace See Also
Collapse All
C#
public string GetRegionId(
    TBoldRegionCoreDefinition Definition,
    Locator RootLocator
);
Remarks

This is GetRegionId, a member of class TBoldRegionFactory.

See Also
TBoldRegionFactory Class
Eco.FrameworkImpl.LockRegions Namespace


TBoldRegionFactory.GetRegionsForMember Method

TBoldRegionFactory.GetRegionsForMember Method
TBoldRegionFactory Class Eco.FrameworkImpl.LockRegions Namespace See Also
Collapse All
C#
public ICollection<ILockRegion> GetRegionsForMember(
    Locator aLocator,
    IStructuralFeature StructuralFeature
);
Remarks

This is GetRegionsForMember, a member of class TBoldRegionFactory.

See Also
TBoldRegionFactory Class
Eco.FrameworkImpl.LockRegions Namespace


TBoldRegionFactory.GetRegionsForObject Method

TBoldRegionFactory.GetRegionsForObject Method
TBoldRegionFactory Class Eco.FrameworkImpl.LockRegions Namespace See Also
Collapse All
C#
public ICollection<ILockRegion> GetRegionsForObject(
    Locator aLocator
);
Remarks

IRegionFactory

See Also
TBoldRegionFactory Class
Eco.FrameworkImpl.LockRegions Namespace


TBoldRegionFactory.RootObjectLocatorFromRegionId_ExtractIdAndClass Method

TBoldRegionFactory.RootObjectLocatorFromRegionId_ExtractIdAndClass Method
TBoldRegionFactory Class Eco.FrameworkImpl.LockRegions Namespace See Also
Collapse All
C#
public static void RootObjectLocatorFromRegionId_ExtractIdAndClass(
    string s,
    out int Id,
    out int ClassId
);
Remarks

This is RootObjectLocatorFromRegionId_ExtractIdAndClass, a member of class TBoldRegionFactory.

See Also
TBoldRegionFactory Class
Eco.FrameworkImpl.LockRegions Namespace


TBoldRegionFactory Properties

TBoldRegionFactory Properties
Public Properties
Collapse All

The properties of the TBoldRegionFactory class are listed here.

Public Properties
Name | Description
Cache | This is Cache, a member of class TBoldRegionFactory.
ObjectRepresentationProvider | This is ObjectRepresentationProvider, a member of class TBoldRegionFactory.


TBoldRegionFactory.Cache Property

TBoldRegionFactory.Cache Property
TBoldRegionFactory Class Eco.FrameworkImpl.LockRegions Namespace See Also
Collapse All
C#
public ICache Cache;
Remarks

This is Cache, a member of class TBoldRegionFactory.

See Also
TBoldRegionFactory Class
Eco.FrameworkImpl.LockRegions Namespace


TBoldRegionFactory.ObjectRepresentationProvider Property

TBoldRegionFactory.ObjectRepresentationProvider Property
TBoldRegionFactory Class Eco.FrameworkImpl.LockRegions Namespace See Also
Collapse All
C#
public IObjectRepresentationProvider ObjectRepresentationProvider;
Remarks

This is ObjectRepresentationProvider, a member of class TBoldRegionFactory.

See Also
TBoldRegionFactory Class
Eco.FrameworkImpl.LockRegions Namespace


TBoldRegionLookup Class

TBoldRegionLookup Class
Inheritance Hierarchy See Also
Collapse All
C#
public class TBoldRegionLookup;
Remarks

This is class Eco.FrameworkImpl.LockRegions.TBoldRegionLookup.

Inheritance Hierarchy
Eco.FrameworkImpl.LockRegions.TBoldRegionLookup
    Eco.FrameworkImpl.LockRegions.TBoldOrderedRegionLookup
File

LockRegions.cs

See Also
Inheritance Hierarchy


TBoldRegionLookup Methods

TBoldRegionLookup Methods
Public Methods
Collapse All

The methods of the TBoldRegionLookup class are listed here.

Public Methods
Name | Description
Add | This is Add, a member of class TBoldRegionLookup.
AddRegionLookup | This is AddRegionLookup, a member of class TBoldRegionLookup.
AddRegionLookupWithFilter | This is AddRegionLookupWithFilter, a member of class TBoldRegionLookup.
Clear | This is Clear, a member of class TBoldRegionLookup.
ContainsKey | This is ContainsKey, a member of class TBoldRegionLookup.
GetRegions | This is GetRegions, a member of class TBoldRegionLookup.
Remove | This is Remove, a member of class TBoldRegionLookup.
TryGetValue | This is TryGetValue, a member of class TBoldRegionLookup.


TBoldRegionLookup.Add Method

TBoldRegionLookup.Add Method
TBoldRegionLookup Class Eco.FrameworkImpl.LockRegions Namespace See Also
Collapse All
C#
public virtual void Add(
    ILockRegion Region
);
Remarks

This is Add, a member of class TBoldRegionLookup.

See Also
TBoldRegionLookup Class
Eco.FrameworkImpl.LockRegions Namespace


TBoldRegionLookup.AddRegionLookup Method

TBoldRegionLookup.AddRegionLookup Method
TBoldRegionLookup Class Eco.FrameworkImpl.LockRegions Namespace See Also
Collapse All
C#
public void AddRegionLookup(
    TBoldRegionLookup Regions
);
Remarks

This is AddRegionLookup, a member of class TBoldRegionLookup.

See Also
TBoldRegionLookup Class
Eco.FrameworkImpl.LockRegions Namespace


TBoldRegionLookup.AddRegionLookupWithFilter Method

TBoldRegionLookup.AddRegionLookupWithFilter Method
TBoldRegionLookup Class Eco.FrameworkImpl.LockRegions Namespace See Also
Collapse All
C#
public void AddRegionLookupWithFilter(
    TBoldRegionLookup Regions,
    TBoldRegionLookup Filter
);
Remarks

This is AddRegionLookupWithFilter, a member of class TBoldRegionLookup.

See Also
TBoldRegionLookup Class
Eco.FrameworkImpl.LockRegions Namespace


TBoldRegionLookup.Clear Method

TBoldRegionLookup.Clear Method
TBoldRegionLookup Class Eco.FrameworkImpl.LockRegions Namespace See Also
Collapse All
C#
public virtual void Clear();
Remarks

This is Clear, a member of class TBoldRegionLookup.

See Also
TBoldRegionLookup Class
Eco.FrameworkImpl.LockRegions Namespace


TBoldRegionLookup.ContainsKey Method

TBoldRegionLookup.ContainsKey Method
TBoldRegionLookup Class Eco.FrameworkImpl.LockRegions Namespace See Also
Collapse All
C#
public bool ContainsKey(
    string key
);
Remarks

This is ContainsKey, a member of class TBoldRegionLookup.

See Also
TBoldRegionLookup Class
Eco.FrameworkImpl.LockRegions Namespace


TBoldRegionLookup.GetRegions Method

TBoldRegionLookup.GetRegions Method
TBoldRegionLookup Class Eco.FrameworkImpl.LockRegions Namespace See Also
Collapse All
C#
public ICollection<ILockRegion> GetRegions(
    bool clone
);
Remarks

This is GetRegions, a member of class TBoldRegionLookup.

See Also
TBoldRegionLookup Class
Eco.FrameworkImpl.LockRegions Namespace


TBoldRegionLookup.Remove Method

TBoldRegionLookup.Remove Method
TBoldRegionLookup Class Eco.FrameworkImpl.LockRegions Namespace See Also
Collapse All
C#
public virtual void Remove(
    ILockRegion Region
);
Remarks

This is Remove, a member of class TBoldRegionLookup.

See Also
TBoldRegionLookup Class
Eco.FrameworkImpl.LockRegions Namespace


TBoldRegionLookup.TryGetValue Method

TBoldRegionLookup.TryGetValue Method
TBoldRegionLookup Class Eco.FrameworkImpl.LockRegions Namespace See Also
Collapse All
C#
public bool TryGetValue(
    string key,
    out ILockRegion value
);
Remarks

This is TryGetValue, a member of class TBoldRegionLookup.

See Also
TBoldRegionLookup Class
Eco.FrameworkImpl.LockRegions Namespace


TBoldRegionLookup Properties

TBoldRegionLookup Properties
Public Properties
Collapse All

The properties of the TBoldRegionLookup class are listed here.

Public Properties
Name | Description
Count | This is Count, a member of class TBoldRegionLookup.


TBoldRegionLookup.Count Property

TBoldRegionLookup.Count Property
TBoldRegionLookup Class Eco.FrameworkImpl.LockRegions Namespace See Also
Collapse All
C#
public int Count;
Remarks

This is Count, a member of class TBoldRegionLookup.

See Also
TBoldRegionLookup Class
Eco.FrameworkImpl.LockRegions Namespace


TBoldSubregionReference Class

TBoldSubregionReference Class
Inheritance Hierarchy See Also
Collapse All
C#
public class TBoldSubregionReference;
Remarks

TBoldSubregionReference

Inheritance Hierarchy
Eco.FrameworkImpl.LockRegions.TBoldSubregionReference
File

RegionDefinitions.cs

See Also
Inheritance Hierarchy


TBoldSubregionReference.TBoldSubregionReference Constructor

TBoldSubregionReference.TBoldSubregionReference Constructor
TBoldSubregionReference Class Eco.FrameworkImpl.LockRegions Namespace See Also
Collapse All
C#
public TBoldSubregionReference(
    TBoldConcreteRegionDefinition ParentRegion,
    TBoldRegionCoreDefinition SubregionCoreDefinition,
    IAssociationEnd Navigation,
    bool IsDependent
);
Remarks

Constructor Create( ParentRegion, SubregionCoreDefinition, Navigation, IsDependent)

See Also
TBoldSubregionReference Class
Eco.FrameworkImpl.LockRegions Namespace


TBoldSubregionReference Properties

TBoldSubregionReference Properties
Public Properties
Collapse All

The properties of the TBoldSubregionReference class are listed here.

Public Properties
Name | Description
IsDependent | This is IsDependent, a member of class TBoldSubregionReference.
ParentRegion | This is ParentRegion, a member of class TBoldSubregionReference.
SubregionCoreDefinition | This is SubregionCoreDefinition, a member of class TBoldSubregionReference.
SubregionRootNavigation | This is SubregionRootNavigation, a member of class TBoldSubregionReference.


TBoldSubregionReference.IsDependent Property

TBoldSubregionReference.IsDependent Property
TBoldSubregionReference Class Eco.FrameworkImpl.LockRegions Namespace See Also
Collapse All
C#
public bool IsDependent;
Remarks

This is IsDependent, a member of class TBoldSubregionReference.

See Also
TBoldSubregionReference Class
Eco.FrameworkImpl.LockRegions Namespace


TBoldSubregionReference.ParentRegion Property

TBoldSubregionReference.ParentRegion Property
TBoldSubregionReference Class Eco.FrameworkImpl.LockRegions Namespace See Also
Collapse All
C#
public TBoldConcreteRegionDefinition ParentRegion;
Remarks

This is ParentRegion, a member of class TBoldSubregionReference.

See Also
TBoldSubregionReference Class
Eco.FrameworkImpl.LockRegions Namespace


TBoldSubregionReference.SubregionCoreDefinition Property

TBoldSubregionReference.SubregionCoreDefinition Property
TBoldSubregionReference Class Eco.FrameworkImpl.LockRegions Namespace See Also
Collapse All
C#
public TBoldRegionCoreDefinition SubregionCoreDefinition;
Remarks

This is SubregionCoreDefinition, a member of class TBoldSubregionReference.

See Also
TBoldSubregionReference Class
Eco.FrameworkImpl.LockRegions Namespace


TBoldSubregionReference.SubregionRootNavigation Property

TBoldSubregionReference.SubregionRootNavigation Property
TBoldSubregionReference Class Eco.FrameworkImpl.LockRegions Namespace See Also
Collapse All
C#
public IAssociationEnd SubregionRootNavigation;
Remarks

This is SubregionRootNavigation, a member of class TBoldSubregionReference.

See Also
TBoldSubregionReference Class
Eco.FrameworkImpl.LockRegions Namespace


TRegionElement Structure

TRegionElement Structure
C#
public struct TRegionElement {
}
Remarks

This is class Eco.FrameworkImpl.LockRegions.TRegionElement.

File

LockRegions.cs


TRegionElement.TRegionElement Constructor

TRegionElement.TRegionElement Constructor
TRegionElement Structure Eco.FrameworkImpl.LockRegions Namespace See Also
Collapse All
C#
public TRegionElement(
    Locator locator,
    ICollection<IStructuralFeature> members
);
Remarks

This is TRegionElement, a member of class TRegionElement.

See Also
TRegionElement Structure
Eco.FrameworkImpl.LockRegions Namespace


TRegionElement Properties

TRegionElement Properties
Public Properties
Collapse All

The properties of the TRegionElement class are listed here.

Public Properties
Name | Description
Members | This is Members, a member of class TRegionElement.
MyLocator | This is MyLocator, a member of class TRegionElement.


TRegionElement.Members Property

TRegionElement.Members Property
TRegionElement Structure Eco.FrameworkImpl.LockRegions Namespace See Also
Collapse All
C#
public ICollection<IStructuralFeature> Members;
Remarks

This is Members, a member of class TRegionElement.

See Also
TRegionElement Structure
Eco.FrameworkImpl.LockRegions Namespace


TRegionElement.MyLocator Property

TRegionElement.MyLocator Property
TRegionElement Structure Eco.FrameworkImpl.LockRegions Namespace See Also
Collapse All
C#
public Locator MyLocator;
Remarks

This is MyLocator, a member of class TRegionElement.

See Also
TRegionElement Structure
Eco.FrameworkImpl.LockRegions Namespace


ILockRegion Interface

ILockRegion Interface
Inheritance Hierarchy See Also
Collapse All
C#
public interface ILockRegion;
Remarks

These should be make public when an actual RegionService is added.

Inheritance Hierarchy
Eco.FrameworkImpl.LockRegions.ILockRegion
    Eco.FrameworkImpl.LockRegions.LockRegionImpl
File

LockRegions.cs

See Also
Inheritance Hierarchy


ILockRegion Methods

ILockRegion Methods
Public Methods
Collapse All

The methods of the ILockRegion class are listed here.

Public Methods
Name | Description
GetRegionElements | This is GetRegionElements, a member of class ILockRegion.


ILockRegion.GetRegionElements Method

ILockRegion.GetRegionElements Method
ILockRegion Interface Eco.FrameworkImpl.LockRegions Namespace See Also
Collapse All
C#
ICollection<TRegionElement> GetRegionElements();
Remarks

This is GetRegionElements, a member of class ILockRegion.

See Also
ILockRegion Interface
Eco.FrameworkImpl.LockRegions Namespace


ILockRegion Properties

ILockRegion Properties
Public Properties
Collapse All

The properties of the ILockRegion class are listed here.

Public Properties
Name | Description
Definition | This is Definition, a member of class ILockRegion.
RegionId | This is RegionId, a member of class ILockRegion.
RootClass | This is RootClass, a member of class ILockRegion.
RootLocator | This is RootLocator, a member of class ILockRegion.


ILockRegion.Definition Property

ILockRegion.Definition Property
ILockRegion Interface Eco.FrameworkImpl.LockRegions Namespace See Also
Collapse All
C#
TBoldConcreteRegionDefinition Definition;
Remarks

This is Definition, a member of class ILockRegion.

See Also
ILockRegion Interface
Eco.FrameworkImpl.LockRegions Namespace


ILockRegion.RegionId Property

ILockRegion.RegionId Property
ILockRegion Interface Eco.FrameworkImpl.LockRegions Namespace See Also
Collapse All
C#
string RegionId;
Remarks

This is RegionId, a member of class ILockRegion.

See Also
ILockRegion Interface
Eco.FrameworkImpl.LockRegions Namespace


ILockRegion.RootClass Property

ILockRegion.RootClass Property
ILockRegion Interface Eco.FrameworkImpl.LockRegions Namespace See Also
Collapse All
C#
IClass RootClass;
Remarks

This is RootClass, a member of class ILockRegion.

See Also
ILockRegion Interface
Eco.FrameworkImpl.LockRegions Namespace


ILockRegion.RootLocator Property

ILockRegion.RootLocator Property
ILockRegion Interface Eco.FrameworkImpl.LockRegions Namespace See Also
Collapse All
C#
Locator RootLocator;
Remarks

This is RootLocator, a member of class ILockRegion.

See Also
ILockRegion Interface
Eco.FrameworkImpl.LockRegions Namespace


IRegionFactory Interface

IRegionFactory Interface
Inheritance Hierarchy See Also
Collapse All
C#
public interface IRegionFactory;
Remarks

This is class Eco.FrameworkImpl.LockRegions.IRegionFactory.

Inheritance Hierarchy
Eco.FrameworkImpl.LockRegions.IRegionFactory
    Eco.FrameworkImpl.LockRegions.TBoldRegionFactory
File

LockRegions.cs

See Also
Inheritance Hierarchy


IRegionFactory Methods

IRegionFactory Methods
Public Methods
Collapse All

The methods of the IRegionFactory class are listed here.

Public Methods
Name | Description
GetRegionsForMember | This is GetRegionsForMember, a member of class IRegionFactory.
GetRegionsForObject | This is GetRegionsForObject, a member of class IRegionFactory.


IRegionFactory.GetRegionsForMember Method

IRegionFactory.GetRegionsForMember Method
IRegionFactory Interface Eco.FrameworkImpl.LockRegions Namespace See Also
Collapse All
C#
ICollection<ILockRegion> GetRegionsForMember(
    Locator locator,
    IStructuralFeature structuralFeature
);
Remarks

This is GetRegionsForMember, a member of class IRegionFactory.

See Also
IRegionFactory Interface
Eco.FrameworkImpl.LockRegions Namespace


IRegionFactory.GetRegionsForObject Method

IRegionFactory.GetRegionsForObject Method
IRegionFactory Interface Eco.FrameworkImpl.LockRegions Namespace See Also
Collapse All
C#
ICollection<ILockRegion> GetRegionsForObject(
    Locator locator
);
Remarks

This is GetRegionsForObject, a member of class IRegionFactory.

See Also
IRegionFactory Interface
Eco.FrameworkImpl.LockRegions Namespace


Eco.FrameworkImpl.Ocl Namespace

Eco.FrameworkImpl.Ocl Namespace
Classes
Collapse All

This is namespace Eco.FrameworkImpl.Ocl.

Classes
Name | Description
BoldOclError | This is class Eco.FrameworkImpl.Ocl.BoldOclError.
EBoldOCLAbort | This is class Eco.FrameworkImpl.Ocl.EBoldOCLAbort.
EBoldOCLError | EBoldOCLError
EBoldOCLInternalError | This is class Eco.FrameworkImpl.Ocl.EBoldOCLInternalError.
EBoldOclRunTimeError | end EBoldOCLAbort
Ocl__ListCopier | end Ocl_collect
Ocl_AbstractCompare | end TBoldDefaultActionLanguageSymbolFactory
Ocl_AbstractOrder | end Ocl_last
Ocl_AllInstances | end Ocl_AllSubClasses
Ocl_AllInstancesAtTime | end Ocl_ObjectTimeStamp
Ocl_AllLoadedObjects | end Ocl_AllInstances
Ocl_AllSubClasses | end Ocl_AllSuperTypes
Ocl_AllSuperTypes | end Ocl_SuperTypes
Ocl_and | end Ocl_or
Ocl_Append | end Ocl_AsOrderedSet
Ocl_AsBag | end Ocl_AsSequence
Ocl_AsOrderedSet | end Ocl_AsSet
Ocl_AsSequence | end Ocl__ListCopier
Ocl_AsSet | end Ocl_AsBag
Ocl_AssociationEnds | end Ocl_Attributes
Ocl_asString | end Ocl_OrderGeneric
Ocl_at | end Ocl_SubSequence
Ocl_AtTime | end Ocl_RegExpMatch
Ocl_Attributes | end Ocl_TypeName
Ocl_collect | This is class Eco.FrameworkImpl.Ocl.Ocl_collect.
Ocl_concat | end Ocl_MaxLength
Ocl_Constraints | This is class Eco.FrameworkImpl.Ocl.Ocl_Constraints.
Ocl_Count | end Ocl_IndexOf
Ocl_Create | end Ocl_Let
Ocl_Delete | end Ocl_Create
Ocl_difference | end Ocl_Intersection
Ocl_Div | end Ocl_GreaterEQ
Ocl_EmptyList | end Ocl_AllLoadedObjects
Ocl_Equal | end Ocl_AbstractCompare
Ocl_excluding | end Ocl_Including
Ocl_Existing | end Ocl_AllInstancesAtTime
Ocl_Exists | end Ocl_isNull
Ocl_ExternalId | end Ocl_TaggedValue
Ocl_FilterOnType | end Ocl_Existing
Ocl_first | end Ocl_at
Ocl_ForAll | end Ocl_Exists
Ocl_Format | end Ocl_PostPad
Ocl_FormatDateTime | end Ocl_Format
Ocl_Greater | end Ocl_Less
Ocl_GreaterEQ | end Ocl_LessEQ
Ocl_GroupBy | This is class Eco.FrameworkImpl.Ocl.Ocl_GroupBy.
Ocl_if | end Ocl_implies
Ocl_implies | end Ocl_xor
Ocl_includes | end Ocl_Size
Ocl_IncludesAll | end Ocl_Count
Ocl_Including | end Ocl_difference
Ocl_IndexOf | end Ocl_includes
Ocl_Intersection | end Ocl_union
Ocl_isEmpty | end Ocl_IncludesAll
Ocl_isNull | This is class Eco.FrameworkImpl.Ocl.Ocl_isNull.
Ocl_last | end Ocl_first
Ocl_Length | end OclPsOperationBase
Ocl_Less | end Ocl_strToInt
Ocl_LessEQ | end Ocl_Greater
Ocl_Let | end Ocl_TimeToTimeStamp
Ocl_ListAdd | end Ocl_StatementSequence
Ocl_ListClear | end Ocl_ListRemoveAt
Ocl_ListRemove | end Ocl_ListAdd
Ocl_ListRemoveAt | end Ocl_ListRemove
Ocl_MaxLength | end Ocl_Mod
Ocl_Mod | end Ocl_Div
Ocl_not | end Ocl_and
Ocl_NotEmpty | This is class Eco.FrameworkImpl.Ocl.Ocl_NotEmpty.
Ocl_NotEqual | end Ocl_Equal
Ocl_ObjectFromExternalId | end Ocl_ExternalId
Ocl_ObjectTimeStamp | end Ocl_AtTime
Ocl_OclAsType | end Ocl_OclIsTypeOf
Ocl_oclGetStates | end Ocl_oclIsInState
Ocl_oclGetTriggers | end Ocl_oclGetStates
Ocl_oclIsInState | end Ocl_ListClear
Ocl_oclIsKindOf | end Ocl_OclType
Ocl_OclIsTypeOf | end Ocl_oclIsKindOf
Ocl_OclType | end Ocl_EmptyList
Ocl_or | end Ocl_StrToDateTime
Ocl_orderby | end Ocl_AbstractOrder
Ocl_orderDescending | end Ocl_orderby
Ocl_OrderGeneric | end Ocl_orderDescending
Ocl_Pad | end Ocl_SubString
Ocl_PostPad | end Ocl_Pad
Ocl_Prepend | end Ocl_Append
Ocl_RegExpMatch | end Ocl_SQLLikeCaseInsensitive
Ocl_reject | end Ocl_Select
Ocl_safeCast | end Ocl_OclAsType
Ocl_Select | end Ocl_SymmetricDifference
Ocl_Size | end Ocl_if
Ocl_SQLLike | This is class Eco.FrameworkImpl.Ocl.Ocl_SQLLike.
Ocl_SQLLikeCaseInsensitive | end Ocl_SQLLike
Ocl_SqlLikeCommon | end Ocl_safeCast
Ocl_StatementSequence | end Ocl_Delete
Ocl_StrToDate | end Ocl_FormatDateTime
Ocl_StrToDateTime | end Ocl_StrToTime
Ocl_strToInt | end Ocl_NotEqual
Ocl_StrToTime | end Ocl_StrToDate
Ocl_SubSequence | end Ocl_Prepend
Ocl_SubString | end Ocl_toLower
Ocl_SuperTypes | Ocl_Operations = class(OclOperationBase) strict protected procedure Init; override; public procedure Evaluate(Params: IOclOperationParameters); override; end;
Ocl_SymmetricDifference | end Ocl_excluding
Ocl_TaggedValue | end Ocl_asString
Ocl_TimeStampToTime | end Ocl_FilterOnType
Ocl_TimeToTimeStamp | end Ocl_TimeStampToTime
Ocl_toLower | end Ocl_ToUpper
Ocl_ToUpper | end Ocl_Length
Ocl_TupleOperation | end Ocl_reject
Ocl_TypeName | end Ocl_ObjectFromExternalId
Ocl_union | end Ocl_ForAll
Ocl_xor | end Ocl_not
OclPsOperationBase | end Ocl_concat
SymbolImplementationUtils | end Ocl_oclGetTriggers
TBoldDefaultActionLanguageSymbolFactory | end TBoldDefaultOclPsSymbolFactory
TBoldDefaultOclPsSymbolFactory | This is class Eco.FrameworkImpl.Ocl.TBoldDefaultOclPsSymbolFactory.
TBoldDefaultOclSymbolFactory | TBoldOclSymbolFactory


BoldOclError Class

BoldOclError Class
Inheritance Hierarchy See Also
Collapse All
C#
public class BoldOclError;
Remarks

This is class Eco.FrameworkImpl.Ocl.BoldOclError.

Inheritance Hierarchy
Eco.FrameworkImpl.Ocl.BoldOclError
File

OclError.cs

See Also
Inheritance Hierarchy


BoldOclError Fields

BoldOclError Fields
Public Fields
Collapse All

The fields of the BoldOclError class are listed here.

Public Fields
Name | Description
boeAmbiguousOverload | This is boeAmbiguousOverload, a member of class BoldOclError.
boeArgrtIsNotList | This is boeArgrtIsNotList, a member of class BoldOclError.
boeArgrtIsNotType | This is boeArgrtIsNotType, a member of class BoldOclError.
boeConversionError | This is boeConversionError, a member of class BoldOclError.
boeDerivedMemberNotAllowed | This is boeDerivedMemberNotAllowed, a member of class BoldOclError.
boeDuplicateOverload | This is boeDuplicateOverload, a member of class BoldOclError.
boeElementNotConformToCollection | boeSubscribeBeforeEval = '%d:You can not subscribe to an expression that has not been evaluated'; boeCollectionNotValidLiteral = '%d:You can not create a literal of type "Collection", try Set, Sequence or Bag instead'; boeTryingMemberOfNilPtr = '%d:Trying to take a member of a nil-reference';
boeEnvSizeError | This is boeEnvSizeError, a member of class BoldOclError.
boeExplicitTypesNotAllowed | This is boeExplicitTypesNotAllowed, a member of class BoldOclError.
boeExpressionNeedsContext | boeNoRootElement = '%d:OCL expression has no root element' ; boeUnknownRoot = '%d:Unknown type of root: %s';
boeExpressionReturnsAType | This is boeExpressionReturnsAType, a member of class BoldOclError.
boeInvalidCharacter | This is boeInvalidCharacter, a member of class BoldOclError.
boeInvalidEnumName | boeInvalidMethodName = '%d:Method names may not be type path-names, only single names';
boeInvalidLoopVariable | This is boeInvalidLoopVariable, a member of class BoldOclError.
boeInvalidMemberName | This is boeInvalidMemberName, a member of class BoldOclError.
boeInvalidQualifier | boeOperationWithoutContext = '%d:Strange indeed! an operation without a context...';
boeInvalidTimeSpecifier | This is boeInvalidTimeSpecifier, a member of class BoldOclError.
boeInvalidTypeNameName | boeModelIsNoModel = '%d:For some Reason, the model of the expression is no model...(%s)';
boeMemberofAttr | This is boeMemberofAttr, a member of class BoldOclError.
boeMemberofType | boeUnknownTypeButMember = '%d:"%s" is not a type name (but it is a member of the current class context, use lowercase!)';
boeNoCommonSuperClass | This is boeNoCommonSuperClass, a member of class BoldOclError.
boeNoConform | boeOperationNotDefinedOnArgTypes = '%d:%s %s %s is not defined';
boeNonListArgumentToCopyArg1Elem | This is boeNonListArgumentToCopyArg1Elem, a member of class BoldOclError.
boeNoOverloadWithParameterCount | This is boeNoOverloadWithParameterCount, a member of class BoldOclError.
boeNoOverloadWithTheseParameterTypes | This is boeNoOverloadWithTheseParameterTypes, a member of class BoldOclError.
boeNoOverloadWithXParameters | This is boeNoOverloadWithXParameters, a member of class BoldOclError.
boeOperationNotAllowedOnDerivedMembers | This is boeOperationNotAllowedOnDerivedMembers, a member of class BoldOclError.
boeOperationOnlyAllowedOnMembers | This is boeOperationOnlyAllowedOnMembers, a member of class BoldOclError.
boeOperationWithLoopVar | This is boeOperationWithLoopVar, a member of class BoldOclError.
boeOverloadNotSupportedForIterators | This is boeOverloadNotSupportedForIterators, a member of class BoldOclError.
boePackageSpecUnImpl | This is boePackageSpecUnImpl, a member of class BoldOclError.
boeParameterIsNotTOclType | This is boeParameterIsNotTOclType, a member of class BoldOclError.
boeRangeMustBeInt | This is boeRangeMustBeInt, a member of class BoldOclError.
boertAllInstancesAtTimeOnlyOnClasses | This is boertAllInstancesAtTimeOnlyOnClasses, a member of class BoldOclError.
boertBadEnumLiteral | This is boertBadEnumLiteral, a member of class BoldOclError.
boertCantGetAllInstances | This is boertCantGetAllInstances, a member of class BoldOclError.
boertCantGetAllLoadedObjects | This is boertCantGetAllLoadedObjects, a member of class BoldOclError.
boertElementIsNotIFeatured | This is boertElementIsNotIFeatured, a member of class BoldOclError.
boertEnumLiteralComparision | This is boertEnumLiteralComparision, a member of class BoldOclError.
boertFailedToEvaluateDefaultStringRepresentation | This is boertFailedToEvaluateDefaultStringRepresentation, a member of class BoldOclError.
boertInvalidConstraintType | This is boertInvalidConstraintType, a member of class BoldOclError.
boertObjectFromExternalIdInvalidObject | This is boertObjectFromExternalIdInvalidObject, a member of class BoldOclError.
boertRangeNotAssigned | This is boertRangeNotAssigned, a member of class BoldOclError.
boeTimeExpressionsUnImpl | boeUserSpecifiedCollections = '%d:User specified collections are not implemented';
boeTransientClassesNotAllowed | This is boeTransientClassesNotAllowed, a member of class BoldOclError.
boeTransientMemberNotAllowed | This is boeTransientMemberNotAllowed, a member of class BoldOclError.
boeUndefinedOperation | boeSystemAsOperationArgument = '%d:The entire system can not be argument to an operation';
boeUnknownClass | boeInvalidOperationOnAttr = '%d:"%s" is not an operation on the type "%s"'; boeMethodsNotImplemented = '%d:Method calls on classes are not yet implemented';
boeUnknownExprtypeinDeduce |
boeUnknownIterator | This is boeUnknownIterator, a member of class BoldOclError.
boeUnknownMember | This is boeUnknownMember, a member of class BoldOclError.
boeUnknownType | This is boeUnknownType, a member of class BoldOclError.
boeUnknownTypeOfLoopVar | boeUnknownContext = '%d:Unknown type (%s) of Context in SemanticCheck';
boeUnknownVariable | boeUnknownMemberType = '%d:This member is neither an attribute or a role (%s)'; boeNotAnOperation = '%d:"%s" is not an operation on "%s"';
boeUnmatchedParentesis | This is boeUnmatchedParentesis, a member of class BoldOclError.
boeUnterminatedQuote | This is boeUnterminatedQuote, a member of class BoldOclError.
boeUserSpecifiedEnumsUnImpl | This is boeUserSpecifiedEnumsUnImpl, a member of class BoldOclError.
boeVariableNotAssigned | boeExpressionNeedsRoot = '%d:This expression needs a root element';
boeWrongNumberOfArgs | This is boeWrongNumberOfArgs, a member of class BoldOclError.
borteDivisionByZero | boeOperationNotOclable = '%d:Operation %s is not OCLCompatible'; BoldOCLRunTimeErrors borteFirstOnEmptyList = 'Tried to take first element of an empty list'; borteLastOnEmptyList = 'Tried to take last element of an empty list'; borteAtIndexOutOfBounds = '%d:Tried to take element #%d of a list with %d elements';
borteInvalidCast | This is borteInvalidCast, a member of class BoldOclError.
borteNonClassAttribute | This is borteNonClassAttribute, a member of class BoldOclError.
borteOperationNotDefinedOnArgTypes | This is borteOperationNotDefinedOnArgTypes, a member of class BoldOclError.
bortePadStringEmpty | This is bortePadStringEmpty, a member of class BoldOclError.
sClassHasNoStateMachine | This is sClassHasNoStateMachine, a member of class BoldOclError.
sIComparableNotImplemented | EBoldOCLError
sTypesDoNotConform | This is sTypesDoNotConform, a member of class BoldOclError.
sUnknownState | This is sUnknownState, a member of class BoldOclError.


BoldOclError.boeAmbiguousOverload Field

BoldOclError.boeAmbiguousOverload Field
BoldOclError Class Eco.FrameworkImpl.Ocl Namespace See Also
Collapse All
C#
public const string boeAmbiguousOverload = "{0}:Ambigous overload for method \"{1}\". Signatures: {2} Current call: {3}";
Remarks

This is boeAmbiguousOverload, a member of class BoldOclError.

See Also
BoldOclError Class
Eco.FrameworkImpl.Ocl Namespace


BoldOclError.boeArgrtIsNotList Field

BoldOclError.boeArgrtIsNotList Field
BoldOclError Class Eco.FrameworkImpl.Ocl Namespace See Also
Collapse All
C#
public const string boeArgrtIsNotList = "{0}:Argument of \'{1}\' is not a list";
Remarks

This is boeArgrtIsNotList, a member of class BoldOclError.

See Also
BoldOclError Class
Eco.FrameworkImpl.Ocl Namespace


BoldOclError.boeArgrtIsNotType Field

BoldOclError.boeArgrtIsNotType Field
BoldOclError Class Eco.FrameworkImpl.Ocl Namespace See Also
Collapse All
C#
public const string boeArgrtIsNotType = "{0}:Argument of \'{1}\' is not a type";
Remarks

This is boeArgrtIsNotType, a member of class BoldOclError.

See Also
BoldOclError Class
Eco.FrameworkImpl.Ocl Namespace


BoldOclError.boeConversionError Field

BoldOclError.boeConversionError Field
BoldOclError Class Eco.FrameworkImpl.Ocl Namespace See Also
Collapse All
C#
public const string boeConversionError = "{0}:Conversion failed in OCL parser (tried to convert \"{1}\" to {2})";
Remarks

This is boeConversionError, a member of class BoldOclError.

See Also
BoldOclError Class
Eco.FrameworkImpl.Ocl Namespace


BoldOclError.boeDerivedMemberNotAllowed Field

BoldOclError.boeDerivedMemberNotAllowed Field
BoldOclError Class Eco.FrameworkImpl.Ocl Namespace See Also
Collapse All
C#
public const string boeDerivedMemberNotAllowed = "{0}:Derived members can not be used here ({1})";
Remarks

This is boeDerivedMemberNotAllowed, a member of class BoldOclError.

See Also
BoldOclError Class
Eco.FrameworkImpl.Ocl Namespace


BoldOclError.boeDuplicateOverload Field

BoldOclError.boeDuplicateOverload Field
BoldOclError Class Eco.FrameworkImpl.Ocl Namespace See Also
Collapse All
C#
public const string boeDuplicateOverload = "{0}:Duplicate overload for method \"{1}\"";
Remarks

This is boeDuplicateOverload, a member of class BoldOclError.

See Also
BoldOclError Class
Eco.FrameworkImpl.Ocl Namespace


BoldOclError.boeElementNotConformToCollection Field

BoldOclError.boeElementNotConformToCollection Field
BoldOclError Class Eco.FrameworkImpl.Ocl Namespace See Also
Collapse All
C#
public const string boeElementNotConformToCollection = "{0}:All elements in a collection literal must conform to a common type, this one doesn\'t";
Remarks

boeSubscribeBeforeEval = '%d:You can not subscribe to an expression that has not been evaluated'; boeCollectionNotValidLiteral = '%d:You can not create a literal of type "Collection", try Set, Sequence or Bag instead'; boeTryingMemberOfNilPtr = '%d:Trying to take a member of a nil-reference';

See Also
BoldOclError Class
Eco.FrameworkImpl.Ocl Namespace


BoldOclError.boeEnvSizeError Field

BoldOclError.boeEnvSizeError Field
BoldOclError Class Eco.FrameworkImpl.Ocl Namespace See Also
Collapse All
C#
public const string boeEnvSizeError = "{0}:Started with {1} vars, ended up with {2}...";
Remarks

This is boeEnvSizeError, a member of class BoldOclError.

See Also
BoldOclError Class
Eco.FrameworkImpl.Ocl Namespace


BoldOclError.boeExplicitTypesNotAllowed Field

BoldOclError.boeExplicitTypesNotAllowed Field
BoldOclError Class Eco.FrameworkImpl.Ocl Namespace See Also
Collapse All
C#
public const string boeExplicitTypesNotAllowed = "Explicit types not allowed (or necessary!)";
Remarks

This is boeExplicitTypesNotAllowed, a member of class BoldOclError.

See Also
BoldOclError Class
Eco.FrameworkImpl.Ocl Namespace


BoldOclError.boeExpressionNeedsContext Field

BoldOclError.boeExpressionNeedsContext Field
BoldOclError Class Eco.FrameworkImpl.Ocl Namespace See Also
Collapse All
C#
public const string boeExpressionNeedsContext = "{0}:This expression needs a context/model";
Remarks

boeNoRootElement = '%d:OCL expression has no root element' ; boeUnknownRoot = '%d:Unknown type of root: %s';

See Also
BoldOclError Class
Eco.FrameworkImpl.Ocl Namespace


BoldOclError.boeExpressionReturnsAType Field

BoldOclError.boeExpressionReturnsAType Field
BoldOclError Class Eco.FrameworkImpl.Ocl Namespace See Also
Collapse All
C#
public const string boeExpressionReturnsAType = "0: The expression returns a type and not a value, this is not allowed";
Remarks

This is boeExpressionReturnsAType, a member of class BoldOclError.

See Also
BoldOclError Class
Eco.FrameworkImpl.Ocl Namespace


BoldOclError.boeInvalidCharacter Field

BoldOclError.boeInvalidCharacter Field
BoldOclError Class Eco.FrameworkImpl.Ocl Namespace See Also
Collapse All
C#
public const string boeInvalidCharacter = "{0}:Expression contains an invalid character";
Remarks

This is boeInvalidCharacter, a member of class BoldOclError.

See Also
BoldOclError Class
Eco.FrameworkImpl.Ocl Namespace


BoldOclError.boeInvalidEnumName Field

BoldOclError.boeInvalidEnumName Field
BoldOclError Class Eco.FrameworkImpl.Ocl Namespace See Also
Collapse All
C#
public const string boeInvalidEnumName = "{0}:Enumeration {1} does not have a value called {2}";
Remarks

boeInvalidMethodName = '%d:Method names may not be type path-names, only single names';

See Also
BoldOclError Class
Eco.FrameworkImpl.Ocl Namespace


BoldOclError.boeInvalidLoopVariable Field

BoldOclError.boeInvalidLoopVariable Field
BoldOclError Class Eco.FrameworkImpl.Ocl Namespace See Also
Collapse All
C#
public const string boeInvalidLoopVariable = "{0}:This function ({1}) may not define a loop variable";
Remarks

This is boeInvalidLoopVariable, a member of class BoldOclError.

See Also
BoldOclError Class
Eco.FrameworkImpl.Ocl Namespace


BoldOclError.boeInvalidMemberName Field

BoldOclError.boeInvalidMemberName Field
BoldOclError Class Eco.FrameworkImpl.Ocl Namespace See Also
Collapse All
C#
public const string boeInvalidMemberName = "{0}:Member names may not be type path-names, only single names";
Remarks

This is boeInvalidMemberName, a member of class BoldOclError.

See Also
BoldOclError Class
Eco.FrameworkImpl.Ocl Namespace


BoldOclError.boeInvalidQualifier Field

BoldOclError.boeInvalidQualifier Field
BoldOclError Class Eco.FrameworkImpl.Ocl Namespace See Also
Collapse All
C#
public const string boeInvalidQualifier = "{0}:Qualifiers aren\'t legal here";
Remarks

boeOperationWithoutContext = '%d:Strange indeed! an operation without a context...';

See Also
BoldOclError Class
Eco.FrameworkImpl.Ocl Namespace


BoldOclError.boeInvalidTimeSpecifier Field

BoldOclError.boeInvalidTimeSpecifier Field
BoldOclError Class Eco.FrameworkImpl.Ocl Namespace See Also
Collapse All
C#
public const string boeInvalidTimeSpecifier = "{0}:Timespecifiers aren\'t legal here";
Remarks

This is boeInvalidTimeSpecifier, a member of class BoldOclError.

See Also
BoldOclError Class
Eco.FrameworkImpl.Ocl Namespace


BoldOclError.boeInvalidTypeNameName Field

BoldOclError.boeInvalidTypeNameName Field
BoldOclError Class Eco.FrameworkImpl.Ocl Namespace See Also
Collapse All
C#
public const string boeInvalidTypeNameName = "{0}:This Multiple parts in type names are not implemented";
Remarks

boeModelIsNoModel = '%d:For some Reason, the model of the expression is no model...(%s)';

See Also
BoldOclError Class
Eco.FrameworkImpl.Ocl Namespace


BoldOclError.boeMemberofAttr Field

BoldOclError.boeMemberofAttr Field
BoldOclError Class Eco.FrameworkImpl.Ocl Namespace See Also
Collapse All
C#
public const string boeMemberofAttr = "{0}:Attributes can not have members (tried {1}.{2})";
Remarks

This is boeMemberofAttr, a member of class BoldOclError.

See Also
BoldOclError Class
Eco.FrameworkImpl.Ocl Namespace


BoldOclError.boeMemberofType Field

BoldOclError.boeMemberofType Field
BoldOclError Class Eco.FrameworkImpl.Ocl Namespace See Also
Collapse All
C#
public const string boeMemberofType = "{0}:Types can not have members (tried {1}.{2})";
Remarks

boeUnknownTypeButMember = '%d:"%s" is not a type name (but it is a member of the current class context, use lowercase!)';

See Also
BoldOclError Class
Eco.FrameworkImpl.Ocl Namespace


BoldOclError.boeNoCommonSuperClass Field

BoldOclError.boeNoCommonSuperClass Field
BoldOclError Class Eco.FrameworkImpl.Ocl Namespace See Also
Collapse All
C#
public const string boeNoCommonSuperClass = "{0}:The parameters of this operation have no common super class ({1} and {2})";
Remarks

This is boeNoCommonSuperClass, a member of class BoldOclError.

See Also
BoldOclError Class
Eco.FrameworkImpl.Ocl Namespace


BoldOclError.boeNoConform Field

BoldOclError.boeNoConform Field
BoldOclError Class Eco.FrameworkImpl.Ocl Namespace See Also
Collapse All
C#
public const string boeNoConform = "{0}:{1} does not conform to {2}";
Remarks

boeOperationNotDefinedOnArgTypes = '%d:%s %s %s is not defined';

See Also
BoldOclError Class
Eco.FrameworkImpl.Ocl Namespace


BoldOclError.boeNonListArgumentToCopyArg1Elem Field

BoldOclError.boeNonListArgumentToCopyArg1Elem Field
BoldOclError Class Eco.FrameworkImpl.Ocl Namespace See Also
Collapse All
C#
public const string boeNonListArgumentToCopyArg1Elem = "{0}:Can\'t take ListElement-type of a non-list";
Remarks

This is boeNonListArgumentToCopyArg1Elem, a member of class BoldOclError.

See Also
BoldOclError Class
Eco.FrameworkImpl.Ocl Namespace


BoldOclError.boeNoOverloadWithParameterCount Field

BoldOclError.boeNoOverloadWithParameterCount Field
BoldOclError Class Eco.FrameworkImpl.Ocl Namespace See Also
Collapse All
C#
public const string boeNoOverloadWithParameterCount = "{0}:There is no version of {1} that takes {2} parameters";
Remarks

This is boeNoOverloadWithParameterCount, a member of class BoldOclError.

See Also
BoldOclError Class
Eco.FrameworkImpl.Ocl Namespace


BoldOclError.boeNoOverloadWithTheseParameterTypes Field

BoldOclError.boeNoOverloadWithTheseParameterTypes Field
BoldOclError Class Eco.FrameworkImpl.Ocl Namespace See Also
Collapse All
C#
public const string boeNoOverloadWithTheseParameterTypes = "{0}:There is no version of {1} that takes these parameter types ({2})";
Remarks

This is boeNoOverloadWithTheseParameterTypes, a member of class BoldOclError.

See Also
BoldOclError Class
Eco.FrameworkImpl.Ocl Namespace


BoldOclError.boeNoOverloadWithXParameters Field

BoldOclError.boeNoOverloadWithXParameters Field
BoldOclError Class Eco.FrameworkImpl.Ocl Namespace See Also
Collapse All
C#
public const string boeNoOverloadWithXParameters = "{0}:No overloaded operator for {1} with {2} parameters";
Remarks

This is boeNoOverloadWithXParameters, a member of class BoldOclError.

See Also
BoldOclError Class
Eco.FrameworkImpl.Ocl Namespace


BoldOclError.boeOperationNotAllowedOnDerivedMembers Field

BoldOclError.boeOperationNotAllowedOnDerivedMembers Field
BoldOclError Class Eco.FrameworkImpl.Ocl Namespace See Also
Collapse All
C#
public const string boeOperationNotAllowedOnDerivedMembers = "{0}:Operation {1} not allowed on derived members";
Remarks

This is boeOperationNotAllowedOnDerivedMembers, a member of class BoldOclError.

See Also
BoldOclError Class
Eco.FrameworkImpl.Ocl Namespace


BoldOclError.boeOperationOnlyAllowedOnMembers Field

BoldOclError.boeOperationOnlyAllowedOnMembers Field
BoldOclError Class Eco.FrameworkImpl.Ocl Namespace See Also
Collapse All
C#
public const string boeOperationOnlyAllowedOnMembers = "{0}:Operation {1} only allowed on members";
Remarks

This is boeOperationOnlyAllowedOnMembers, a member of class BoldOclError.

See Also
BoldOclError Class
Eco.FrameworkImpl.Ocl Namespace


BoldOclError.boeOperationWithLoopVar Field

BoldOclError.boeOperationWithLoopVar Field
BoldOclError Class Eco.FrameworkImpl.Ocl Namespace See Also
Collapse All
C#
public const string boeOperationWithLoopVar = "{0}:Only iterations may use CopyLoopVar-semantics! (tried with {1})";
Remarks

This is boeOperationWithLoopVar, a member of class BoldOclError.

See Also
BoldOclError Class
Eco.FrameworkImpl.Ocl Namespace


BoldOclError.boeOverloadNotSupportedForIterators Field

BoldOclError.boeOverloadNotSupportedForIterators Field
BoldOclError Class Eco.FrameworkImpl.Ocl Namespace See Also
Collapse All
C#
public const string boeOverloadNotSupportedForIterators = "{0}:Overloaded operations with the same number of parameters not supported for iterators ({1})";
Remarks

This is boeOverloadNotSupportedForIterators, a member of class BoldOclError.

See Also
BoldOclError Class
Eco.FrameworkImpl.Ocl Namespace


BoldOclError.boePackageSpecUnImpl Field

BoldOclError.boePackageSpecUnImpl Field
BoldOclError Class Eco.FrameworkImpl.Ocl Namespace See Also
Collapse All
C#
public const string boePackageSpecUnImpl = "{0}:Package specification in types aren\'t implemented";
Remarks

This is boePackageSpecUnImpl, a member of class BoldOclError.

See Also
BoldOclError Class
Eco.FrameworkImpl.Ocl Namespace


BoldOclError.boeParameterIsNotTOclType Field

BoldOclError.boeParameterIsNotTOclType Field
BoldOclError Class Eco.FrameworkImpl.Ocl Namespace See Also
Collapse All
C#
public const string boeParameterIsNotTOclType = "Argument does not implement IInternalTypeAccess";
Remarks

This is boeParameterIsNotTOclType, a member of class BoldOclError.

See Also
BoldOclError Class
Eco.FrameworkImpl.Ocl Namespace


BoldOclError.boeRangeMustBeInt Field

BoldOclError.boeRangeMustBeInt Field
BoldOclError Class Eco.FrameworkImpl.Ocl Namespace See Also
Collapse All
C#
public const string boeRangeMustBeInt = "{0}:Ranges can only consist of integers";
Remarks

This is boeRangeMustBeInt, a member of class BoldOclError.

See Also
BoldOclError Class
Eco.FrameworkImpl.Ocl Namespace


BoldOclError.boertAllInstancesAtTimeOnlyOnClasses Field

BoldOclError.boertAllInstancesAtTimeOnlyOnClasses Field
BoldOclError Class Eco.FrameworkImpl.Ocl Namespace See Also
Collapse All
C#
public const string boertAllInstancesAtTimeOnlyOnClasses = "{0}: AllInstancesAtTime only allowed on classes";
Remarks

This is boertAllInstancesAtTimeOnlyOnClasses, a member of class BoldOclError.

See Also
BoldOclError Class
Eco.FrameworkImpl.Ocl Namespace


BoldOclError.boertBadEnumLiteral Field

BoldOclError.boertBadEnumLiteral Field
BoldOclError Class Eco.FrameworkImpl.Ocl Namespace See Also
Collapse All
C#
public const string boertBadEnumLiteral = "{0}: {1} is not an allowed value for {2}";
Remarks

This is boertBadEnumLiteral, a member of class BoldOclError.

See Also
BoldOclError Class
Eco.FrameworkImpl.Ocl Namespace


BoldOclError.boertCantGetAllInstances Field

BoldOclError.boertCantGetAllInstances Field
BoldOclError Class Eco.FrameworkImpl.Ocl Namespace See Also
Collapse All
C#
public const string boertCantGetAllInstances = "{0}: Unable to get allInstances. This evaluator has no system";
Remarks

This is boertCantGetAllInstances, a member of class BoldOclError.

See Also
BoldOclError Class
Eco.FrameworkImpl.Ocl Namespace


BoldOclError.boertCantGetAllLoadedObjects Field

BoldOclError.boertCantGetAllLoadedObjects Field
BoldOclError Class Eco.FrameworkImpl.Ocl Namespace See Also
Collapse All
C#
public const string boertCantGetAllLoadedObjects = "{0}: Unable to get allLoadedObjects. This evaluator has no system";
Remarks

This is boertCantGetAllLoadedObjects, a member of class BoldOclError.

See Also
BoldOclError Class
Eco.FrameworkImpl.Ocl Namespace


BoldOclError.boertElementIsNotIFeatured Field

BoldOclError.boertElementIsNotIFeatured Field
BoldOclError Class Eco.FrameworkImpl.Ocl Namespace See Also
Collapse All
C#
public const string boertElementIsNotIFeatured = "{0}: Element in collection was not an IFeatured";
Remarks

This is boertElementIsNotIFeatured, a member of class BoldOclError.

See Also
BoldOclError Class
Eco.FrameworkImpl.Ocl Namespace


BoldOclError.boertEnumLiteralComparision Field

BoldOclError.boertEnumLiteralComparision Field
BoldOclError Class Eco.FrameworkImpl.Ocl Namespace See Also
Collapse All
C#
public const string boertEnumLiteralComparision = "{0}: Enum literals can not be compared to other enum literals ({1} and {2})";
Remarks

This is boertEnumLiteralComparision, a member of class BoldOclError.

See Also
BoldOclError Class
Eco.FrameworkImpl.Ocl Namespace


BoldOclError.boertFailedToEvaluateDefaultStringRepresentation Field

BoldOclError.boertFailedToEvaluateDefaultStringRepresentation Field
BoldOclError Class Eco.FrameworkImpl.Ocl Namespace See Also
Collapse All
C#
public const string boertFailedToEvaluateDefaultStringRepresentation = "{0}: Failed to evaluate DefaultStringRepresentation for class {1}, Expression: \"{2}\", Message: {3}";
Remarks

This is boertFailedToEvaluateDefaultStringRepresentation, a member of class BoldOclError.

See Also
BoldOclError Class
Eco.FrameworkImpl.Ocl Namespace


BoldOclError.boertInvalidConstraintType Field

BoldOclError.boertInvalidConstraintType Field
BoldOclError Class Eco.FrameworkImpl.Ocl Namespace See Also
Collapse All
C#
public const string boertInvalidConstraintType = "{0}: Constraint {1} ({2}) has an invalid return type. Expected boolean but was {3}";
Remarks

This is boertInvalidConstraintType, a member of class BoldOclError.

See Also
BoldOclError Class
Eco.FrameworkImpl.Ocl Namespace


BoldOclError.boertObjectFromExternalIdInvalidObject Field

BoldOclError.boertObjectFromExternalIdInvalidObject Field
BoldOclError Class Eco.FrameworkImpl.Ocl Namespace See Also
Collapse All
C#
public const string boertObjectFromExternalIdInvalidObject = "{0}: Invalid object. Expected an object of type {1} but ExternalId \"{2}\" returns an object of type {3}";
Remarks

This is boertObjectFromExternalIdInvalidObject, a member of class BoldOclError.

See Also
BoldOclError Class
Eco.FrameworkImpl.Ocl Namespace


BoldOclError.boertRangeNotAssigned Field

BoldOclError.boertRangeNotAssigned Field
BoldOclError Class Eco.FrameworkImpl.Ocl Namespace See Also
Collapse All
C#
public const string boertRangeNotAssigned = "{0}:Invalid value of range";
Remarks

This is boertRangeNotAssigned, a member of class BoldOclError.

See Also
BoldOclError Class
Eco.FrameworkImpl.Ocl Namespace


BoldOclError.boeTimeExpressionsUnImpl Field

BoldOclError.boeTimeExpressionsUnImpl Field
BoldOclError Class Eco.FrameworkImpl.Ocl Namespace See Also
Collapse All
C#
public const string boeTimeExpressionsUnImpl = "{0}:Timeexpressions aren\'t implemented";
Remarks

boeUserSpecifiedCollections = '%d:User specified collections are not implemented';

See Also
BoldOclError Class
Eco.FrameworkImpl.Ocl Namespace


BoldOclError.boeTransientClassesNotAllowed Field

BoldOclError.boeTransientClassesNotAllowed Field
BoldOclError Class Eco.FrameworkImpl.Ocl Namespace See Also
Collapse All
C#
public const string boeTransientClassesNotAllowed = "{0}:Transient classes can not be used here ({1})";
Remarks

This is boeTransientClassesNotAllowed, a member of class BoldOclError.

See Also
BoldOclError Class
Eco.FrameworkImpl.Ocl Namespace


BoldOclError.boeTransientMemberNotAllowed Field

BoldOclError.boeTransientMemberNotAllowed Field
BoldOclError Class Eco.FrameworkImpl.Ocl Namespace See Also
Collapse All
C#
public const string boeTransientMemberNotAllowed = "{0}:Transient members can not be used here ({1})";
Remarks

This is boeTransientMemberNotAllowed, a member of class BoldOclError.

See Also
BoldOclError Class
Eco.FrameworkImpl.Ocl Namespace


BoldOclError.boeUndefinedOperation Field

BoldOclError.boeUndefinedOperation Field
BoldOclError Class Eco.FrameworkImpl.Ocl Namespace See Also
Collapse All
C#
public const string boeUndefinedOperation = "{0}:Undefined operation: {1}";
Remarks

boeSystemAsOperationArgument = '%d:The entire system can not be argument to an operation';

See Also
BoldOclError Class
Eco.FrameworkImpl.Ocl Namespace


BoldOclError.boeUnknownClass Field

BoldOclError.boeUnknownClass Field
BoldOclError Class Eco.FrameworkImpl.Ocl Namespace See Also
Collapse All
C#
public const string boeUnknownClass = "{0}:\"{1}\" is not a class name in the model";
Remarks

boeInvalidOperationOnAttr = '%d:"%s" is not an operation on the type "%s"'; boeMethodsNotImplemented = '%d:Method calls on classes are not yet implemented';

See Also
BoldOclError Class
Eco.FrameworkImpl.Ocl Namespace


BoldOclError.boeUnknownExprtypeinDeduce Field

BoldOclError.boeUnknownExprtypeinDeduce Field
BoldOclError Class Eco.FrameworkImpl.Ocl Namespace See Also
Collapse All
C#
public const string boeUnknownExprtypeinDeduce = "{0}:Unable to deduce type of expression\r\n Operation: {1} \r\n{2}\r\n Using deduce method: {3}";
See Also
BoldOclError Class
Eco.FrameworkImpl.Ocl Namespace


BoldOclError.boeUnknownIterator Field

BoldOclError.boeUnknownIterator Field
BoldOclError Class Eco.FrameworkImpl.Ocl Namespace See Also
Collapse All
C#
public const string boeUnknownIterator = "{0}:Semantics for this iterator has not been implemented";
Remarks

This is boeUnknownIterator, a member of class BoldOclError.

See Also
BoldOclError Class
Eco.FrameworkImpl.Ocl Namespace


BoldOclError.boeUnknownMember Field

BoldOclError.boeUnknownMember Field
BoldOclError Class Eco.FrameworkImpl.Ocl Namespace See Also
Collapse All
C#
public const string boeUnknownMember = "{0}:\"{1}\" is not a member of \"{2}\"";
Remarks

This is boeUnknownMember, a member of class BoldOclError.

See Also
BoldOclError Class
Eco.FrameworkImpl.Ocl Namespace


BoldOclError.boeUnknownType Field

BoldOclError.boeUnknownType Field
BoldOclError Class Eco.FrameworkImpl.Ocl Namespace See Also
Collapse All
C#
public const string boeUnknownType = "{0}:\"{1}\" is not a type name";
Remarks

This is boeUnknownType, a member of class BoldOclError.

See Also
BoldOclError Class
Eco.FrameworkImpl.Ocl Namespace


BoldOclError.boeUnknownTypeOfLoopVar Field

BoldOclError.boeUnknownTypeOfLoopVar Field
BoldOclError Class Eco.FrameworkImpl.Ocl Namespace See Also
Collapse All
C#
public const string boeUnknownTypeOfLoopVar = "{0}:Unknown type ({1}) of loop variable";
Remarks

boeUnknownContext = '%d:Unknown type (%s) of Context in SemanticCheck';

See Also
BoldOclError Class
Eco.FrameworkImpl.Ocl Namespace


BoldOclError.boeUnknownVariable Field

BoldOclError.boeUnknownVariable Field
BoldOclError Class Eco.FrameworkImpl.Ocl Namespace See Also
Collapse All
C#
public const string boeUnknownVariable = "{0}:Can\'t find variable \"{1}\" in environment";
Remarks

boeUnknownMemberType = '%d:This member is neither an attribute or a role (%s)'; boeNotAnOperation = '%d:"%s" is not an operation on "%s"';

See Also
BoldOclError Class
Eco.FrameworkImpl.Ocl Namespace


BoldOclError.boeUnmatchedParentesis Field

BoldOclError.boeUnmatchedParentesis Field
BoldOclError Class Eco.FrameworkImpl.Ocl Namespace See Also
Collapse All
C#
public const string boeUnmatchedParentesis = "{0}:Parenthesis are not in balance";
Remarks

This is boeUnmatchedParentesis, a member of class BoldOclError.

See Also
BoldOclError Class
Eco.FrameworkImpl.Ocl Namespace


BoldOclError.boeUnterminatedQuote Field

BoldOclError.boeUnterminatedQuote Field
BoldOclError Class Eco.FrameworkImpl.Ocl Namespace See Also
Collapse All
C#
public const string boeUnterminatedQuote = "{0}:Unterminated string in expression";
Remarks

This is boeUnterminatedQuote, a member of class BoldOclError.

See Also
BoldOclError Class
Eco.FrameworkImpl.Ocl Namespace


BoldOclError.boeUserSpecifiedEnumsUnImpl Field

BoldOclError.boeUserSpecifiedEnumsUnImpl Field
BoldOclError Class Eco.FrameworkImpl.Ocl Namespace See Also
Collapse All
C#
public const string boeUserSpecifiedEnumsUnImpl = "{0}:User specified enumerations aren\'t implemented";
Remarks

This is boeUserSpecifiedEnumsUnImpl, a member of class BoldOclError.

See Also
BoldOclError Class
Eco.FrameworkImpl.Ocl Namespace


BoldOclError.boeVariableNotAssigned Field

BoldOclError.boeVariableNotAssigned Field
BoldOclError Class Eco.FrameworkImpl.Ocl Namespace See Also
Collapse All
C#
public const string boeVariableNotAssigned = "{0}:This variable ({1}) has no value or type";
Remarks

boeExpressionNeedsRoot = '%d:This expression needs a root element';

See Also
BoldOclError Class
Eco.FrameworkImpl.Ocl Namespace


BoldOclError.boeWrongNumberOfArgs Field

BoldOclError.boeWrongNumberOfArgs Field
BoldOclError Class Eco.FrameworkImpl.Ocl Namespace See Also
Collapse All
C#
public const string boeWrongNumberOfArgs = "{0}:{1} parameters expected, {2} found...";
Remarks

This is boeWrongNumberOfArgs, a member of class BoldOclError.

See Also
BoldOclError Class
Eco.FrameworkImpl.Ocl Namespace


BoldOclError.borteDivisionByZero Field

BoldOclError.borteDivisionByZero Field
BoldOclError Class Eco.FrameworkImpl.Ocl Namespace See Also
Collapse All
C#
public const string borteDivisionByZero = "{0}:Division By Zero";
Remarks

boeOperationNotOclable = '%d:Operation %s is not OCLCompatible'; BoldOCLRunTimeErrors borteFirstOnEmptyList = 'Tried to take first element of an empty list'; borteLastOnEmptyList = 'Tried to take last element of an empty list'; borteAtIndexOutOfBounds = '%d:Tried to take element #%d of a list with %d elements';

See Also
BoldOclError Class
Eco.FrameworkImpl.Ocl Namespace


BoldOclError.borteInvalidCast Field

BoldOclError.borteInvalidCast Field
BoldOclError Class Eco.FrameworkImpl.Ocl Namespace See Also
Collapse All
C#
public const string borteInvalidCast = "{0}:Invalid OCL-cast, tried to cast a {1} to a {2}";
Remarks

This is borteInvalidCast, a member of class BoldOclError.

See Also
BoldOclError Class
Eco.FrameworkImpl.Ocl Namespace


BoldOclError.borteNonClassAttribute Field

BoldOclError.borteNonClassAttribute Field
BoldOclError Class Eco.FrameworkImpl.Ocl Namespace See Also
Collapse All
C#
public const string borteNonClassAttribute = "{0}:Can not take attributes of a non-class ({1})";
Remarks

This is borteNonClassAttribute, a member of class BoldOclError.

See Also
BoldOclError Class
Eco.FrameworkImpl.Ocl Namespace


BoldOclError.borteOperationNotDefinedOnArgTypes Field

BoldOclError.borteOperationNotDefinedOnArgTypes Field
BoldOclError Class Eco.FrameworkImpl.Ocl Namespace See Also
Collapse All
C#
public const string borteOperationNotDefinedOnArgTypes = "{0}:{1} {2} {3} is not defined";
Remarks

This is borteOperationNotDefinedOnArgTypes, a member of class BoldOclError.

See Also
BoldOclError Class
Eco.FrameworkImpl.Ocl Namespace


BoldOclError.bortePadStringEmpty Field

BoldOclError.bortePadStringEmpty Field
BoldOclError Class Eco.FrameworkImpl.Ocl Namespace See Also
Collapse All
C#
public const string bortePadStringEmpty = "{0}:Trying to pad with an empty string doesn\'t really get me anywhere...";
Remarks

This is bortePadStringEmpty, a member of class BoldOclError.

See Also
BoldOclError Class
Eco.FrameworkImpl.Ocl Namespace


BoldOclError.sClassHasNoStateMachine Field

BoldOclError.sClassHasNoStateMachine Field
BoldOclError Class Eco.FrameworkImpl.Ocl Namespace See Also
Collapse All
C#
public const string sClassHasNoStateMachine = "{0}:Class {1} has no statemachine";
Remarks

This is sClassHasNoStateMachine, a member of class BoldOclError.

See Also
BoldOclError Class
Eco.FrameworkImpl.Ocl Namespace


BoldOclError.sIComparableNotImplemented Field

BoldOclError.sIComparableNotImplemented Field
BoldOclError Class Eco.FrameworkImpl.Ocl Namespace See Also
Collapse All
C#
public const string sIComparableNotImplemented = "OCL evaluator tried to compare values not implementing IComparable ({0})";
Remarks

EBoldOCLError

See Also
BoldOclError Class
Eco.FrameworkImpl.Ocl Namespace


BoldOclError.sTypesDoNotConform Field

BoldOclError.sTypesDoNotConform Field
BoldOclError Class Eco.FrameworkImpl.Ocl Namespace See Also
Collapse All
C#
public const string sTypesDoNotConform = "Types {0} and {1} do not conform";
Remarks

This is sTypesDoNotConform, a member of class BoldOclError.

See Also
BoldOclError Class
Eco.FrameworkImpl.Ocl Namespace


BoldOclError.sUnknownState Field

BoldOclError.sUnknownState Field
BoldOclError Class Eco.FrameworkImpl.Ocl Namespace See Also
Collapse All
C#
public const string sUnknownState = "{0}:Unknown state: {1}";
Remarks

This is sUnknownState, a member of class BoldOclError.

See Also
BoldOclError Class
Eco.FrameworkImpl.Ocl Namespace


EBoldOCLAbort Class

EBoldOCLAbort Class
Inheritance Hierarchy See Also
Collapse All
C#
public class EBoldOCLAbort : EBoldOCLError;
Remarks

This is class Eco.FrameworkImpl.Ocl.EBoldOCLAbort.

Inheritance Hierarchy
Eco.FrameworkImpl.Ocl.EBoldOCLError
    Eco.FrameworkImpl.Ocl.EBoldOCLAbort
File

OclError.cs

See Also
Inheritance Hierarchy


EBoldOCLAbort Constructor

EBoldOCLAbort Constructor

This is the overview for the EBoldOCLAbort constructor overload.

Overload List
Name | Description
EBoldOCLAbort.EBoldOCLAbort (SerializationInfo, StreamingContext) | This is EBoldOCLAbort, a member of class EBoldOCLAbort.
EBoldOCLAbort.EBoldOCLAbort (string) | This is EBoldOCLAbort, a member of class EBoldOCLAbort.
EBoldOCLAbort.EBoldOCLAbort (string, Exception) | This is EBoldOCLAbort, a member of class EBoldOCLAbort.


EBoldOCLAbort.EBoldOCLAbort Constructor (SerializationInfo, StreamingContext)

EBoldOCLAbort.EBoldOCLAbort Constructor (SerializationInfo, StreamingContext)
EBoldOCLAbort Class Eco.FrameworkImpl.Ocl Namespace See Also
Collapse All
C#
public EBoldOCLAbort(
    SerializationInfo info,
    StreamingContext context
);
Remarks

This is EBoldOCLAbort, a member of class EBoldOCLAbort.

See Also
EBoldOCLAbort Class
Eco.FrameworkImpl.Ocl Namespace


EBoldOCLAbort.EBoldOCLAbort Constructor (string)

EBoldOCLAbort.EBoldOCLAbort Constructor (string)
EBoldOCLAbort Class Eco.FrameworkImpl.Ocl Namespace See Also
Collapse All
C#
public EBoldOCLAbort(
    string msg
);
Remarks

This is EBoldOCLAbort, a member of class EBoldOCLAbort.

See Also
EBoldOCLAbort Class
Eco.FrameworkImpl.Ocl Namespace


EBoldOCLAbort.EBoldOCLAbort Constructor (string, Exception)

EBoldOCLAbort.EBoldOCLAbort Constructor (string, Exception)
EBoldOCLAbort Class Eco.FrameworkImpl.Ocl Namespace See Also
Collapse All
C#
public EBoldOCLAbort(
    string msg,
    Exception InnerException
);
Remarks

This is EBoldOCLAbort, a member of class EBoldOCLAbort.

See Also
EBoldOCLAbort Class
Eco.FrameworkImpl.Ocl Namespace


EBoldOCLAbort Methods

EBoldOCLAbort Methods
Public Methods
Collapse All

The methods of the EBoldOCLAbort class are listed here.

Public Methods
Name | Description
CreateFmt | This is the overview for the CreateFmt method overload.


CreateFmt Method

CreateFmt Method

This is the overview for the CreateFmt method overload.

Overload List
Name | Description
EBoldOCLAbort.CreateFmt (string, object[]) | This is CreateFmt, a member of class EBoldOCLAbort.
EBoldOCLAbort.CreateFmt (string, string) | This is CreateFmt, a member of class EBoldOCLAbort.


EBoldOCLAbort.CreateFmt Method (string, object[])

EBoldOCLAbort.CreateFmt Method (string, object[])
EBoldOCLAbort Class Eco.FrameworkImpl.Ocl Namespace See Also
Collapse All
C#
public static EBoldOCLAbort CreateFmt(
    string msg,
    object[] args
);
Remarks

This is CreateFmt, a member of class EBoldOCLAbort.

See Also
EBoldOCLAbort Class
Eco.FrameworkImpl.Ocl Namespace


EBoldOCLAbort.CreateFmt Method (string, string)

EBoldOCLAbort.CreateFmt Method (string, string)
EBoldOCLAbort Class Eco.FrameworkImpl.Ocl Namespace See Also
Collapse All
C#
public static EBoldOCLAbort CreateFmt(
    string msg,
    string arg1
);
Remarks

This is CreateFmt, a member of class EBoldOCLAbort.

See Also
EBoldOCLAbort Class
Eco.FrameworkImpl.Ocl Namespace


EBoldOCLError Class

EBoldOCLError Class
Inheritance Hierarchy See Also
Collapse All
C#
public class EBoldOCLError : Eco.Exceptions.EcoOclErrorException;
Remarks

EBoldOCLError

Inheritance Hierarchy
Eco.FrameworkImpl.Ocl.EBoldOCLError
    Eco.FrameworkImpl.Ocl.EBoldOCLAbort
    Eco.FrameworkImpl.Ocl.EBoldOCLInternalError
    Eco.FrameworkImpl.Ocl.EBoldOclRunTimeError
File

OclError.cs

See Also
Inheritance Hierarchy


EBoldOCLError Constructor

EBoldOCLError Constructor

This is the overview for the EBoldOCLError constructor overload.

Overload List
Name | Description
EBoldOCLError.EBoldOCLError (SerializationInfo, StreamingContext) | This is EBoldOCLError, a member of class EBoldOCLError.
EBoldOCLError.EBoldOCLError (string) | This is EBoldOCLError, a member of class EBoldOCLError.
EBoldOCLError.EBoldOCLError (string, Exception) | This is EBoldOCLError, a member of class EBoldOCLError.


EBoldOCLError.EBoldOCLError Constructor (SerializationInfo, StreamingContext)

EBoldOCLError.EBoldOCLError Constructor (SerializationInfo, StreamingContext)
EBoldOCLError Class Eco.FrameworkImpl.Ocl Namespace See Also
Collapse All
C#
public EBoldOCLError(
    SerializationInfo info,
    StreamingContext context
);
Remarks

This is EBoldOCLError, a member of class EBoldOCLError.

See Also
EBoldOCLError Class
Eco.FrameworkImpl.Ocl Namespace


EBoldOCLError.EBoldOCLError Constructor (string)

EBoldOCLError.EBoldOCLError Constructor (string)
EBoldOCLError Class Eco.FrameworkImpl.Ocl Namespace See Also
Collapse All
C#
public EBoldOCLError(
    string msg
);
Remarks

This is EBoldOCLError, a member of class EBoldOCLError.

See Also
EBoldOCLError Class
Eco.FrameworkImpl.Ocl Namespace


EBoldOCLError.EBoldOCLError Constructor (string, Exception)

EBoldOCLError.EBoldOCLError Constructor (string, Exception)
EBoldOCLError Class Eco.FrameworkImpl.Ocl Namespace See Also
Collapse All
C#
public EBoldOCLError(
    string msg,
    Exception InnerException
);
Remarks

This is EBoldOCLError, a member of class EBoldOCLError.

See Also
EBoldOCLError Class
Eco.FrameworkImpl.Ocl Namespace


EBoldOCLError Fields

EBoldOCLError Fields
Public Fields
Collapse All

The fields of the EBoldOCLError class are listed here.

Public Fields
Name | Description
ErrorFixed | This is ErrorFixed, a member of class EBoldOCLError.
fPosition | This is fPosition, a member of class EBoldOCLError.
OCL | This is OCL, a member of class EBoldOCLError.


EBoldOCLError.ErrorFixed Field

EBoldOCLError.ErrorFixed Field
EBoldOCLError Class Eco.FrameworkImpl.Ocl Namespace See Also
Collapse All
C#
public bool ErrorFixed = false;
Remarks

This is ErrorFixed, a member of class EBoldOCLError.

See Also
EBoldOCLError Class
Eco.FrameworkImpl.Ocl Namespace


EBoldOCLError.fPosition Field

EBoldOCLError.fPosition Field
EBoldOCLError Class Eco.FrameworkImpl.Ocl Namespace See Also
Collapse All
C#
public int fPosition = 0;
Remarks

This is fPosition, a member of class EBoldOCLError.

See Also
EBoldOCLError Class
Eco.FrameworkImpl.Ocl Namespace


EBoldOCLError.OCL Field

EBoldOCLError.OCL Field
EBoldOCLError Class Eco.FrameworkImpl.Ocl Namespace See Also
Collapse All
C#
public string OCL = String.Empty;
Remarks

This is OCL, a member of class EBoldOCLError.

See Also
EBoldOCLError Class
Eco.FrameworkImpl.Ocl Namespace


EBoldOCLError Methods

EBoldOCLError Methods
Public Methods
Collapse All

The methods of the EBoldOCLError class are listed here.

Public Methods
Name | Description
ErrorPointer | This is ErrorPointer, a member of class EBoldOCLError.
FixError | This is FixError, a member of class EBoldOCLError.


EBoldOCLError.ErrorPointer Method

EBoldOCLError.ErrorPointer Method
EBoldOCLError Class Eco.FrameworkImpl.Ocl Namespace See Also
Collapse All
C#
public string ErrorPointer();
Remarks

This is ErrorPointer, a member of class EBoldOCLError.

See Also
EBoldOCLError Class
Eco.FrameworkImpl.Ocl Namespace


EBoldOCLError.FixError Method

EBoldOCLError.FixError Method
EBoldOCLError Class Eco.FrameworkImpl.Ocl Namespace See Also
Collapse All
C#
public void FixError();
Remarks

This is FixError, a member of class EBoldOCLError.

See Also
EBoldOCLError Class
Eco.FrameworkImpl.Ocl Namespace


EBoldOCLError Properties

EBoldOCLError Properties
Public Properties
Collapse All

The properties of the EBoldOCLError class are listed here.

Public Properties
Name | Description
Expression | This is Expression, a member of class EBoldOCLError.
InternalError | This is InternalError, a member of class EBoldOCLError.
Position | This is Position, a member of class EBoldOCLError.


EBoldOCLError.Expression Property

EBoldOCLError.Expression Property
EBoldOCLError Class Eco.FrameworkImpl.Ocl Namespace See Also
Collapse All
C#
public override string Expression;
Remarks

This is Expression, a member of class EBoldOCLError.

See Also
EBoldOCLError Class
Eco.FrameworkImpl.Ocl Namespace


EBoldOCLError.InternalError Property

EBoldOCLError.InternalError Property
EBoldOCLError Class Eco.FrameworkImpl.Ocl Namespace See Also
Collapse All
C#
public override bool InternalError;
Remarks

This is InternalError, a member of class EBoldOCLError.

See Also
EBoldOCLError Class
Eco.FrameworkImpl.Ocl Namespace


EBoldOCLError.Position Property

EBoldOCLError.Position Property
EBoldOCLError Class Eco.FrameworkImpl.Ocl Namespace See Also
Collapse All
C#
public override int Position;
Remarks

This is Position, a member of class EBoldOCLError.

See Also
EBoldOCLError Class
Eco.FrameworkImpl.Ocl Namespace


EBoldOCLInternalError Class

EBoldOCLInternalError Class
Inheritance Hierarchy See Also
Collapse All
C#
public class EBoldOCLInternalError : EBoldOCLError;
Remarks

This is class Eco.FrameworkImpl.Ocl.EBoldOCLInternalError.

Inheritance Hierarchy
Eco.FrameworkImpl.Ocl.EBoldOCLError
    Eco.FrameworkImpl.Ocl.EBoldOCLInternalError
File

OclError.cs

See Also
Inheritance Hierarchy


EBoldOCLInternalError Constructor

EBoldOCLInternalError Constructor

This is the overview for the EBoldOCLInternalError constructor overload.

Overload List
Name | Description
EBoldOCLInternalError.EBoldOCLInternalError (SerializationInfo, StreamingContext) | This is EBoldOCLInternalError, a member of class EBoldOCLInternalError.
EBoldOCLInternalError.EBoldOCLInternalError (string) | This is EBoldOCLInternalError, a member of class EBoldOCLInternalError.
EBoldOCLInternalError.EBoldOCLInternalError (string, Exception) | This is EBoldOCLInternalError, a member of class EBoldOCLInternalError.


EBoldOCLInternalError.EBoldOCLInternalError Constructor (SerializationInfo, StreamingContext)

EBoldOCLInternalError.EBoldOCLInternalError Constructor (SerializationInfo, StreamingContext)
EBoldOCLInternalError Class Eco.FrameworkImpl.Ocl Namespace See Also
Collapse All
C#
public EBoldOCLInternalError(
    SerializationInfo info,
    StreamingContext context
);
Remarks

This is EBoldOCLInternalError, a member of class EBoldOCLInternalError.

See Also
EBoldOCLInternalError Class
Eco.FrameworkImpl.Ocl Namespace


EBoldOCLInternalError.EBoldOCLInternalError Constructor (string)

EBoldOCLInternalError.EBoldOCLInternalError Constructor (string)
EBoldOCLInternalError Class Eco.FrameworkImpl.Ocl Namespace See Also
Collapse All
C#
public EBoldOCLInternalError(
    string msg
);
Remarks

This is EBoldOCLInternalError, a member of class EBoldOCLInternalError.

See Also
EBoldOCLInternalError Class
Eco.FrameworkImpl.Ocl Namespace


EBoldOCLInternalError.EBoldOCLInternalError Constructor (string, Exception)

EBoldOCLInternalError.EBoldOCLInternalError Constructor (string, Exception)
EBoldOCLInternalError Class Eco.FrameworkImpl.Ocl Namespace See Also
Collapse All
C#
public EBoldOCLInternalError(
    string msg,
    Exception InnerException
);
Remarks

This is EBoldOCLInternalError, a member of class EBoldOCLInternalError.

See Also
EBoldOCLInternalError Class
Eco.FrameworkImpl.Ocl Namespace


EBoldOCLInternalError Methods

EBoldOCLInternalError Methods
Public Methods
Collapse All

The methods of the EBoldOCLInternalError class are listed here.

Public Methods
Name | Description
CreateFmt | This is CreateFmt, a member of class EBoldOCLInternalError.


EBoldOCLInternalError.CreateFmt Method

EBoldOCLInternalError.CreateFmt Method
EBoldOCLInternalError Class Eco.FrameworkImpl.Ocl Namespace See Also
Collapse All
C#
public static EBoldOCLInternalError CreateFmt(
    string msg,
    object[] args
);
Remarks

This is CreateFmt, a member of class EBoldOCLInternalError.

See Also
EBoldOCLInternalError Class
Eco.FrameworkImpl.Ocl Namespace


EBoldOCLInternalError Properties

EBoldOCLInternalError Properties
Public Properties
Collapse All

The properties of the EBoldOCLInternalError class are listed here.

Public Properties
Name | Description
InternalError | This is InternalError, a member of class EBoldOCLInternalError.


EBoldOCLInternalError.InternalError Property

EBoldOCLInternalError.InternalError Property
EBoldOCLInternalError Class Eco.FrameworkImpl.Ocl Namespace See Also
Collapse All
C#
public override bool InternalError;
Remarks

This is InternalError, a member of class EBoldOCLInternalError.

See Also
EBoldOCLInternalError Class
Eco.FrameworkImpl.Ocl Namespace


EBoldOclRunTimeError Class

EBoldOclRunTimeError Class
Inheritance Hierarchy See Also
Collapse All
C#
public class EBoldOclRunTimeError : EBoldOCLError;
Remarks

end EBoldOCLAbort

Inheritance Hierarchy
Eco.FrameworkImpl.Ocl.EBoldOCLError
    Eco.FrameworkImpl.Ocl.EBoldOclRunTimeError
File

OclError.cs

See Also
Inheritance Hierarchy


EBoldOclRunTimeError Constructor

EBoldOclRunTimeError Constructor

This is the overview for the EBoldOclRunTimeError constructor overload.

Overload List
Name | Description
EBoldOclRunTimeError.EBoldOclRunTimeError (SerializationInfo, StreamingContext) | This is EBoldOclRunTimeError, a member of class EBoldOclRunTimeError.
EBoldOclRunTimeError.EBoldOclRunTimeError (string) | This is EBoldOclRunTimeError, a member of class EBoldOclRunTimeError.
EBoldOclRunTimeError.EBoldOclRunTimeError (string, Exception) | This is EBoldOclRunTimeError, a member of class EBoldOclRunTimeError.


EBoldOclRunTimeError.EBoldOclRunTimeError Constructor (SerializationInfo, StreamingContext)

EBoldOclRunTimeError.EBoldOclRunTimeError Constructor (SerializationInfo, StreamingContext)
EBoldOclRunTimeError Class Eco.FrameworkImpl.Ocl Namespace See Also
Collapse All
C#
public EBoldOclRunTimeError(
    SerializationInfo info,
    StreamingContext context
);
Remarks

This is EBoldOclRunTimeError, a member of class EBoldOclRunTimeError.

See Also
EBoldOclRunTimeError Class
Eco.FrameworkImpl.Ocl Namespace


EBoldOclRunTimeError.EBoldOclRunTimeError Constructor (string)

EBoldOclRunTimeError.EBoldOclRunTimeError Constructor (string)
EBoldOclRunTimeError Class Eco.FrameworkImpl.Ocl Namespace See Also
Collapse All
C#
public EBoldOclRunTimeError(
    string msg
);
Remarks

This is EBoldOclRunTimeError, a member of class EBoldOclRunTimeError.

See Also
EBoldOclRunTimeError Class
Eco.FrameworkImpl.Ocl Namespace


EBoldOclRunTimeError.EBoldOclRunTimeError Constructor (string, Exception)

EBoldOclRunTimeError.EBoldOclRunTimeError Constructor (string, Exception)
EBoldOclRunTimeError Class Eco.FrameworkImpl.Ocl Namespace See Also
Collapse All
C#
public EBoldOclRunTimeError(
    string msg,
    Exception InnerException
);
Remarks

This is EBoldOclRunTimeError, a member of class EBoldOclRunTimeError.

See Also
EBoldOclRunTimeError Class
Eco.FrameworkImpl.Ocl Namespace


EBoldOclRunTimeError Methods

EBoldOclRunTimeError Methods
Public Methods
Collapse All

The methods of the EBoldOclRunTimeError class are listed here.

Public Methods
Name | Description
CreateFmt | This is CreateFmt, a member of class EBoldOclRunTimeError.


EBoldOclRunTimeError.CreateFmt Method

EBoldOclRunTimeError.CreateFmt Method
EBoldOclRunTimeError Class Eco.FrameworkImpl.Ocl Namespace See Also
Collapse All
C#
public static EBoldOclRunTimeError CreateFmt(
    string msg,
    object[] args
);
Remarks

This is CreateFmt, a member of class EBoldOclRunTimeError.

See Also
EBoldOclRunTimeError Class
Eco.FrameworkImpl.Ocl Namespace


Ocl__ListCopier Class

Ocl__ListCopier Class
Inheritance Hierarchy See Also
Collapse All
C#
public abstract class Ocl__ListCopier : OclOperationBase;
Remarks

end Ocl_collect

Inheritance Hierarchy
Eco.FrameworkImpl.Ocl.Ocl__ListCopier
    Eco.FrameworkImpl.Ocl.Ocl_AsBag
    Eco.FrameworkImpl.Ocl.Ocl_AsOrderedSet
    Eco.FrameworkImpl.Ocl.Ocl_AsSequence
    Eco.FrameworkImpl.Ocl.Ocl_AsSet
File

OclSymbolImplementations.cs

See Also
Inheritance Hierarchy


Ocl__ListCopier Methods

Ocl__ListCopier Methods
Public Methods
Collapse All

The methods of the Ocl__ListCopier class are listed here.

Public Methods
Name | Description
Evaluate | This is Evaluate, a member of class Ocl__ListCopier.


Ocl__ListCopier.Evaluate Method

Ocl__ListCopier.Evaluate Method
Ocl__ListCopier Class Eco.FrameworkImpl.Ocl Namespace See Also
Collapse All
C#
public override void Evaluate(
    IOclOperationParameters __Params
);
Remarks

This is Evaluate, a member of class Ocl__ListCopier.

See Also
Ocl__ListCopier Class
Eco.FrameworkImpl.Ocl Namespace


Ocl_AbstractCompare Class

Ocl_AbstractCompare Class
Inheritance Hierarchy See Also
Collapse All
C#
public abstract class Ocl_AbstractCompare : OclOperationBase;
Remarks

end TBoldDefaultActionLanguageSymbolFactory

Inheritance Hierarchy
Eco.FrameworkImpl.Ocl.Ocl_AbstractCompare
    Eco.FrameworkImpl.Ocl.Ocl_Equal
    Eco.FrameworkImpl.Ocl.Ocl_NotEqual
File

OclSymbolImplementations.cs

See Also
Inheritance Hierarchy


Ocl_AbstractCompare Methods

Ocl_AbstractCompare Methods
Protected Methods
Collapse All

The methods of the Ocl_AbstractCompare class are listed here.

Protected Methods
Name | Description
CompareElements | This is CompareElements, a member of class Ocl_AbstractCompare.
CompareEnumLiterals | SymbolImplementations
CompareEquals | This is CompareEquals, a member of class Ocl_AbstractCompare.


Ocl_AbstractCompare.CompareElements Method

Ocl_AbstractCompare.CompareElements Method
Ocl_AbstractCompare Class Eco.FrameworkImpl.Ocl Namespace See Also
Collapse All
C#
protected bool CompareElements(
    IElement el1,
    IElement el2
);
Remarks

This is CompareElements, a member of class Ocl_AbstractCompare.

See Also
Ocl_AbstractCompare Class
Eco.FrameworkImpl.Ocl Namespace


Ocl_AbstractCompare.CompareEnumLiterals Method

Ocl_AbstractCompare.CompareEnumLiterals Method
Ocl_AbstractCompare Class Eco.FrameworkImpl.Ocl Namespace See Also
Collapse All
C#
protected bool CompareEnumLiterals(
    IOclOperationParameters __Params
);
Remarks

SymbolImplementations

See Also
Ocl_AbstractCompare Class
Eco.FrameworkImpl.Ocl Namespace


Ocl_AbstractCompare.CompareEquals Method

Ocl_AbstractCompare.CompareEquals Method
Ocl_AbstractCompare Class Eco.FrameworkImpl.Ocl Namespace See Also
Collapse All
C#
protected bool CompareEquals(
    IOclOperationParameters __Params
);
Remarks

This is CompareEquals, a member of class Ocl_AbstractCompare.

See Also
Ocl_AbstractCompare Class
Eco.FrameworkImpl.Ocl Namespace


Ocl_AbstractOrder Class

Ocl_AbstractOrder Class
Inheritance Hierarchy See Also
Collapse All
C#
public abstract class Ocl_AbstractOrder : OclOperationBase;
Remarks

end Ocl_last

Inheritance Hierarchy
Eco.FrameworkImpl.Ocl.Ocl_AbstractOrder
    Eco.FrameworkImpl.Ocl.Ocl_orderby
    Eco.FrameworkImpl.Ocl.Ocl_orderDescending
File

OclSymbolImplementations.cs

See Also
Inheritance Hierarchy


Ocl_AbstractOrder Methods

Ocl_AbstractOrder Methods
Public Methods
Collapse All

The methods of the Ocl_AbstractOrder class are listed here.

Public Methods
Name | Description
Evaluate | This is Evaluate, a member of class Ocl_AbstractOrder.


Ocl_AbstractOrder.Evaluate Method

Ocl_AbstractOrder.Evaluate Method
Ocl_AbstractOrder Class Eco.FrameworkImpl.Ocl Namespace See Also
Collapse All
C#
public override void Evaluate(
    IOclOperationParameters __Params
);
Remarks

This is Evaluate, a member of class Ocl_AbstractOrder.

See Also
Ocl_AbstractOrder Class
Eco.FrameworkImpl.Ocl Namespace


Ocl_AllInstances Class

Ocl_AllInstances Class
Inheritance Hierarchy See Also
Collapse All
C#
public class Ocl_AllInstances : OclOperationBase;
Remarks

end Ocl_AllSubClasses

Inheritance Hierarchy
Eco.FrameworkImpl.Ocl.Ocl_AllInstances
File

OclSymbolImplementations.cs

See Also
Inheritance Hierarchy


Ocl_AllInstances Methods

Ocl_AllInstances Methods
Protected Methods Public Methods
Collapse All

The methods of the Ocl_AllInstances class are listed here.

Protected Methods
Name | Description
Init | This is Init, a member of class Ocl_AllInstances.
Top
Public Methods
Name | Description
Evaluate | This is Evaluate, a member of class Ocl_AllInstances.
ResultIsReadOnly | This is ResultIsReadOnly, a member of class Ocl_AllInstances.


Ocl_AllInstances.Evaluate Method

Ocl_AllInstances.Evaluate Method
Ocl_AllInstances Class Eco.FrameworkImpl.Ocl Namespace See Also
Collapse All
C#
public override void Evaluate(
    IOclOperationParameters __Params
);
Remarks

This is Evaluate, a member of class Ocl_AllInstances.

See Also
Ocl_AllInstances Class
Eco.FrameworkImpl.Ocl Namespace


Ocl_AllInstances.Init Method

Ocl_AllInstances.Init Method
Ocl_AllInstances Class Eco.FrameworkImpl.Ocl Namespace See Also
Collapse All
C#
protected override void Init();
Remarks

This is Init, a member of class Ocl_AllInstances.

See Also
Ocl_AllInstances Class
Eco.FrameworkImpl.Ocl Namespace


Ocl_AllInstances.ResultIsReadOnly Method

Ocl_AllInstances.ResultIsReadOnly Method
Ocl_AllInstances Class Eco.FrameworkImpl.Ocl Namespace See Also
Collapse All
C#
public override bool ResultIsReadOnly(
    bool[] Args
);
Remarks

This is ResultIsReadOnly, a member of class Ocl_AllInstances.

See Also
Ocl_AllInstances Class
Eco.FrameworkImpl.Ocl Namespace


Ocl_AllInstancesAtTime Class

Ocl_AllInstancesAtTime Class
Inheritance Hierarchy See Also
Collapse All
C#
public class Ocl_AllInstancesAtTime : OclOperationBase;
Remarks

end Ocl_ObjectTimeStamp

Inheritance Hierarchy
Eco.FrameworkImpl.Ocl.Ocl_AllInstancesAtTime
File

OclSymbolImplementations.cs

See Also
Inheritance Hierarchy


Ocl_AllInstancesAtTime Methods

Ocl_AllInstancesAtTime Methods
Protected Methods Public Methods
Collapse All

The methods of the Ocl_AllInstancesAtTime class are listed here.

Protected Methods
Name | Description
Init | This is Init, a member of class Ocl_AllInstancesAtTime.
Top
Public Methods
Name | Description
Evaluate | This is Evaluate, a member of class Ocl_AllInstancesAtTime.


Ocl_AllInstancesAtTime.Evaluate Method

Ocl_AllInstancesAtTime.Evaluate Method
Ocl_AllInstancesAtTime Class Eco.FrameworkImpl.Ocl Namespace See Also
Collapse All
C#
public override void Evaluate(
    IOclOperationParameters __Params
);
Remarks

This is Evaluate, a member of class Ocl_AllInstancesAtTime.

See Also
Ocl_AllInstancesAtTime Class
Eco.FrameworkImpl.Ocl Namespace


Ocl_AllInstancesAtTime.Init Method

Ocl_AllInstancesAtTime.Init Method
Ocl_AllInstancesAtTime Class Eco.FrameworkImpl.Ocl Namespace See Also
Collapse All
C#
protected override void Init();
Remarks

This is Init, a member of class Ocl_AllInstancesAtTime.

See Also
Ocl_AllInstancesAtTime Class
Eco.FrameworkImpl.Ocl Namespace


Ocl_AllLoadedObjects Class

Ocl_AllLoadedObjects Class
Inheritance Hierarchy See Also
Collapse All
C#
public class Ocl_AllLoadedObjects : OclOperationBase;
Remarks

end Ocl_AllInstances

Inheritance Hierarchy
Eco.FrameworkImpl.Ocl.Ocl_AllLoadedObjects
File

OclSymbolImplementations.cs

See Also
Inheritance Hierarchy


Ocl_AllLoadedObjects Methods

Ocl_AllLoadedObjects Methods
Protected Methods Public Methods
Collapse All

The methods of the Ocl_AllLoadedObjects class are listed here.

Protected Methods
Name | Description
Init | This is Init, a member of class Ocl_AllLoadedObjects.
Top
Public Methods
Name | Description
Evaluate | This is Evaluate, a member of class Ocl_AllLoadedObjects.


Ocl_AllLoadedObjects.Evaluate Method

Ocl_AllLoadedObjects.Evaluate Method
Ocl_AllLoadedObjects Class Eco.FrameworkImpl.Ocl Namespace See Also
Collapse All
C#
public override void Evaluate(
    IOclOperationParameters __Params
);
Remarks

This is Evaluate, a member of class Ocl_AllLoadedObjects.

See Also
Ocl_AllLoadedObjects Class
Eco.FrameworkImpl.Ocl Namespace


Ocl_AllLoadedObjects.Init Method

Ocl_AllLoadedObjects.Init Method
Ocl_AllLoadedObjects Class Eco.FrameworkImpl.Ocl Namespace See Also
Collapse All
C#
protected override void Init();
Remarks

This is Init, a member of class Ocl_AllLoadedObjects.

See Also
Ocl_AllLoadedObjects Class
Eco.FrameworkImpl.Ocl Namespace


Ocl_AllSubClasses Class

Ocl_AllSubClasses Class
Inheritance Hierarchy See Also
Collapse All
C#
public class Ocl_AllSubClasses : OclOperationBase;
Remarks

end Ocl_AllSuperTypes

Inheritance Hierarchy
Eco.FrameworkImpl.Ocl.Ocl_AllSubClasses
File

OclSymbolImplementations.cs

See Also
Inheritance Hierarchy


Ocl_AllSubClasses Methods

Ocl_AllSubClasses Methods
Protected Methods Public Methods
Collapse All

The methods of the Ocl_AllSubClasses class are listed here.

Protected Methods
Name | Description
Init | This is Init, a member of class Ocl_AllSubClasses.
Top
Public Methods
Name | Description
Evaluate | This is Evaluate, a member of class Ocl_AllSubClasses.
Evaluate_AddAllSubTypes | This is Evaluate_AddAllSubTypes, a member of class Ocl_AllSubClasses.


Ocl_AllSubClasses.Evaluate Method

Ocl_AllSubClasses.Evaluate Method
Ocl_AllSubClasses Class Eco.FrameworkImpl.Ocl Namespace See Also
Collapse All
C#
public override void Evaluate(
    IOclOperationParameters __Params
);
Remarks

This is Evaluate, a member of class Ocl_AllSubClasses.

See Also
Ocl_AllSubClasses Class
Eco.FrameworkImpl.Ocl Namespace


Ocl_AllSubClasses.Evaluate_AddAllSubTypes Method

Ocl_AllSubClasses.Evaluate_AddAllSubTypes Method
Ocl_AllSubClasses Class Eco.FrameworkImpl.Ocl Namespace See Also
Collapse All
C#
public void Evaluate_AddAllSubTypes(
    IElementCollection List,
    IClassifier Classifier
);
Remarks

This is Evaluate_AddAllSubTypes, a member of class Ocl_AllSubClasses.

See Also
Ocl_AllSubClasses Class
Eco.FrameworkImpl.Ocl Namespace


Ocl_AllSubClasses.Init Method

Ocl_AllSubClasses.Init Method
Ocl_AllSubClasses Class Eco.FrameworkImpl.Ocl Namespace See Also
Collapse All
C#
protected override void Init();
Remarks

This is Init, a member of class Ocl_AllSubClasses.

See Also
Ocl_AllSubClasses Class
Eco.FrameworkImpl.Ocl Namespace


Ocl_AllSuperTypes Class

Ocl_AllSuperTypes Class
Inheritance Hierarchy See Also
Collapse All
C#
public class Ocl_AllSuperTypes : OclOperationBase;
Remarks

end Ocl_SuperTypes

Inheritance Hierarchy
Eco.FrameworkImpl.Ocl.Ocl_AllSuperTypes
File

OclSymbolImplementations.cs

See Also
Inheritance Hierarchy


Ocl_AllSuperTypes Methods

Ocl_AllSuperTypes Methods
Protected Methods Public Methods
Collapse All

The methods of the Ocl_AllSuperTypes class are listed here.

Protected Methods
Name | Description
Init | This is Init, a member of class Ocl_AllSuperTypes.
Top
Public Methods
Name | Description
Evaluate | This is Evaluate, a member of class Ocl_AllSuperTypes.
Evaluate_AddAllSuperTypes | This is Evaluate_AddAllSuperTypes, a member of class Ocl_AllSuperTypes.


Ocl_AllSuperTypes.Evaluate Method

Ocl_AllSuperTypes.Evaluate Method
Ocl_AllSuperTypes Class Eco.FrameworkImpl.Ocl Namespace See Also
Collapse All
C#
public override void Evaluate(
    IOclOperationParameters __Params
);
Remarks

This is Evaluate, a member of class Ocl_AllSuperTypes.

See Also
Ocl_AllSuperTypes Class
Eco.FrameworkImpl.Ocl Namespace


Ocl_AllSuperTypes.Evaluate_AddAllSuperTypes Method

Ocl_AllSuperTypes.Evaluate_AddAllSuperTypes Method
Ocl_AllSuperTypes Class Eco.FrameworkImpl.Ocl Namespace See Also
Collapse All
C#
public void Evaluate_AddAllSuperTypes(
    IElementCollection List,
    IClassifier Classifier
);
Remarks

This is Evaluate_AddAllSuperTypes, a member of class Ocl_AllSuperTypes.

See Also
Ocl_AllSuperTypes Class
Eco.FrameworkImpl.Ocl Namespace


Ocl_AllSuperTypes.Init Method

Ocl_AllSuperTypes.Init Method
Ocl_AllSuperTypes Class Eco.FrameworkImpl.Ocl Namespace See Also
Collapse All
C#
protected override void Init();
Remarks

This is Init, a member of class Ocl_AllSuperTypes.

See Also
Ocl_AllSuperTypes Class
Eco.FrameworkImpl.Ocl Namespace


Ocl_and Class

Ocl_and Class
Inheritance Hierarchy See Also
Collapse All
C#
public class Ocl_and : OclOperationBase;
Remarks

end Ocl_or

Inheritance Hierarchy
Eco.FrameworkImpl.Ocl.Ocl_and
File

OclSymbolImplementations.cs

See Also
Inheritance Hierarchy


Ocl_and Methods

Ocl_and Methods
Protected Methods Public Methods
Collapse All

The methods of the Ocl_and class are listed here.

Protected Methods
Name | Description
Init | This is Init, a member of class Ocl_and.
Top
Public Methods
Name | Description
Evaluate | This is Evaluate, a member of class Ocl_and.


Ocl_and.Evaluate Method

Ocl_and.Evaluate Method
Ocl_and Class Eco.FrameworkImpl.Ocl Namespace See Also
Collapse All
C#
public override void Evaluate(
    IOclOperationParameters __Params
);
Remarks

This is Evaluate, a member of class Ocl_and.

See Also
Ocl_and Class
Eco.FrameworkImpl.Ocl Namespace


Ocl_and.Init Method

Ocl_and.Init Method
Ocl_and Class Eco.FrameworkImpl.Ocl Namespace See Also
Collapse All
C#
protected override void Init();
Remarks

This is Init, a member of class Ocl_and.

See Also
Ocl_and Class
Eco.FrameworkImpl.Ocl Namespace


Ocl_Append Class

Ocl_Append Class
Inheritance Hierarchy See Also
Collapse All
C#
public class Ocl_Append : OclOperationBase;
Remarks

end Ocl_AsOrderedSet

Inheritance Hierarchy
Eco.FrameworkImpl.Ocl.Ocl_Append
File

OclSymbolImplementations.cs

See Also
Inheritance Hierarchy


Ocl_Append Methods

Ocl_Append Methods
Protected Methods Public Methods
Collapse All

The methods of the Ocl_Append class are listed here.

Protected Methods
Name | Description
Init | This is Init, a member of class Ocl_Append.
Top
Public Methods
Name | Description
Evaluate | This is Evaluate, a member of class Ocl_Append.


Ocl_Append.Evaluate Method

Ocl_Append.Evaluate Method
Ocl_Append Class Eco.FrameworkImpl.Ocl Namespace See Also
Collapse All
C#
public override void Evaluate(
    IOclOperationParameters __Params
);
Remarks

This is Evaluate, a member of class Ocl_Append.

See Also
Ocl_Append Class
Eco.FrameworkImpl.Ocl Namespace


Ocl_Append.Init Method

Ocl_Append.Init Method
Ocl_Append Class Eco.FrameworkImpl.Ocl Namespace See Also
Collapse All
C#
protected override void Init();
Remarks

This is Init, a member of class Ocl_Append.

See Also
Ocl_Append Class
Eco.FrameworkImpl.Ocl Namespace


Ocl_AsBag Class

Ocl_AsBag Class
Inheritance Hierarchy See Also
Collapse All
C#
public class Ocl_AsBag : Ocl__ListCopier;
Remarks

end Ocl_AsSequence

Inheritance Hierarchy
Eco.FrameworkImpl.Ocl.Ocl__ListCopier
    Eco.FrameworkImpl.Ocl.Ocl_AsBag
File

OclSymbolImplementations.cs

See Also
Inheritance Hierarchy


Ocl_AsBag Methods

Ocl_AsBag Methods
Protected Methods
Collapse All

The methods of the Ocl_AsBag class are listed here.

Protected Methods
Name | Description
Init | This is Init, a member of class Ocl_AsBag.


Ocl_AsBag.Init Method

Ocl_AsBag.Init Method
Ocl_AsBag Class Eco.FrameworkImpl.Ocl Namespace See Also
Collapse All
C#
protected override void Init();
Remarks

This is Init, a member of class Ocl_AsBag.

See Also
Ocl_AsBag Class
Eco.FrameworkImpl.Ocl Namespace


Ocl_AsOrderedSet Class

Ocl_AsOrderedSet Class
Inheritance Hierarchy See Also
Collapse All
C#
public class Ocl_AsOrderedSet : Ocl__ListCopier;
Remarks

end Ocl_AsSet

Inheritance Hierarchy
Eco.FrameworkImpl.Ocl.Ocl__ListCopier
    Eco.FrameworkImpl.Ocl.Ocl_AsOrderedSet
File

OclSymbolImplementations.cs

See Also
Inheritance Hierarchy


Ocl_AsOrderedSet Methods

Ocl_AsOrderedSet Methods
Protected Methods
Collapse All

The methods of the Ocl_AsOrderedSet class are listed here.

Protected Methods
Name | Description
Init | This is Init, a member of class Ocl_AsOrderedSet.


Ocl_AsOrderedSet.Init Method

Ocl_AsOrderedSet.Init Method
Ocl_AsOrderedSet Class Eco.FrameworkImpl.Ocl Namespace See Also
Collapse All
C#
protected override void Init();
Remarks

This is Init, a member of class Ocl_AsOrderedSet.

See Also
Ocl_AsOrderedSet Class
Eco.FrameworkImpl.Ocl Namespace


Ocl_AsSequence Class

Ocl_AsSequence Class
Inheritance Hierarchy See Also
Collapse All
C#
public class Ocl_AsSequence : Ocl__ListCopier;
Remarks

end Ocl__ListCopier

Inheritance Hierarchy
Eco.FrameworkImpl.Ocl.Ocl__ListCopier
    Eco.FrameworkImpl.Ocl.Ocl_AsSequence
File

OclSymbolImplementations.cs

See Also
Inheritance Hierarchy


Ocl_AsSequence Methods

Ocl_AsSequence Methods
Protected Methods
Collapse All

The methods of the Ocl_AsSequence class are listed here.

Protected Methods
Name | Description
Init | This is Init, a member of class Ocl_AsSequence.


Ocl_AsSequence.Init Method

Ocl_AsSequence.Init Method
Ocl_AsSequence Class Eco.FrameworkImpl.Ocl Namespace See Also
Collapse All
C#
protected override void Init();
Remarks

This is Init, a member of class Ocl_AsSequence.

See Also
Ocl_AsSequence Class
Eco.FrameworkImpl.Ocl Namespace


Ocl_AsSet Class

Ocl_AsSet Class
Inheritance Hierarchy See Also
Collapse All
C#
public class Ocl_AsSet : Ocl__ListCopier;
Remarks

end Ocl_AsBag

Inheritance Hierarchy
Eco.FrameworkImpl.Ocl.Ocl__ListCopier
    Eco.FrameworkImpl.Ocl.Ocl_AsSet
File

OclSymbolImplementations.cs

See Also
Inheritance Hierarchy


Ocl_AsSet Methods

Ocl_AsSet Methods
Protected Methods
Collapse All

The methods of the Ocl_AsSet class are listed here.

Protected Methods
Name | Description
Init | This is Init, a member of class Ocl_AsSet.


Ocl_AsSet.Init Method

Ocl_AsSet.Init Method
Ocl_AsSet Class Eco.FrameworkImpl.Ocl Namespace See Also
Collapse All
C#
protected override void Init();
Remarks

This is Init, a member of class Ocl_AsSet.

See Also
Ocl_AsSet Class
Eco.FrameworkImpl.Ocl Namespace


Ocl_AssociationEnds Class

Ocl_AssociationEnds Class
Inheritance Hierarchy See Also
Collapse All
C#
public class Ocl_AssociationEnds : OclOperationBase;
Remarks

end Ocl_Attributes

Inheritance Hierarchy
Eco.FrameworkImpl.Ocl.Ocl_AssociationEnds
File

OclSymbolImplementations.cs

See Also
Inheritance Hierarchy


Ocl_AssociationEnds Methods

Ocl_AssociationEnds Methods
Protected Methods Public Methods
Collapse All

The methods of the Ocl_AssociationEnds class are listed here.

Protected Methods
Name | Description
Init | This is Init, a member of class Ocl_AssociationEnds.
Top
Public Methods
Name | Description
Evaluate | This is Evaluate, a member of class Ocl_AssociationEnds.


Ocl_AssociationEnds.Evaluate Method

Ocl_AssociationEnds.Evaluate Method
Ocl_AssociationEnds Class Eco.FrameworkImpl.Ocl Namespace See Also
Collapse All
C#
public override void Evaluate(
    IOclOperationParameters __Params
);
Remarks

This is Evaluate, a member of class Ocl_AssociationEnds.

See Also
Ocl_AssociationEnds Class
Eco.FrameworkImpl.Ocl Namespace


Ocl_AssociationEnds.Init Method

Ocl_AssociationEnds.Init Method
Ocl_AssociationEnds Class Eco.FrameworkImpl.Ocl Namespace See Also
Collapse All
C#
protected override void Init();
Remarks

This is Init, a member of class Ocl_AssociationEnds.

See Also
Ocl_AssociationEnds Class
Eco.FrameworkImpl.Ocl Namespace


Ocl_asString Class

Ocl_asString Class
Inheritance Hierarchy See Also
Collapse All
C#
public class Ocl_asString : OclOperationBase;
Remarks

end Ocl_OrderGeneric

Inheritance Hierarchy
Eco.FrameworkImpl.Ocl.Ocl_asString
File

OclSymbolImplementations.cs

See Also
Inheritance Hierarchy


Ocl_asString Methods

Ocl_asString Methods
Protected Methods Public Methods
Collapse All

The methods of the Ocl_asString class are listed here.

Protected Methods
Name | Description
Init | This is Init, a member of class Ocl_asString.
Top
Public Methods
Name | Description
Evaluate | This is Evaluate, a member of class Ocl_asString.


Ocl_asString.Evaluate Method

Ocl_asString.Evaluate Method
Ocl_asString Class Eco.FrameworkImpl.Ocl Namespace See Also
Collapse All
C#
public override void Evaluate(
    IOclOperationParameters __Params
);
Remarks

This is Evaluate, a member of class Ocl_asString.

See Also
Ocl_asString Class
Eco.FrameworkImpl.Ocl Namespace


Ocl_asString.Init Method

Ocl_asString.Init Method
Ocl_asString Class Eco.FrameworkImpl.Ocl Namespace See Also
Collapse All
C#
protected override void Init();
Remarks

This is Init, a member of class Ocl_asString.

See Also
Ocl_asString Class
Eco.FrameworkImpl.Ocl Namespace


Ocl_at Class

Ocl_at Class
Inheritance Hierarchy See Also
Collapse All
C#
public class Ocl_at : OclOperationBase;
Remarks

end Ocl_SubSequence

Inheritance Hierarchy
Eco.FrameworkImpl.Ocl.Ocl_at
File

OclSymbolImplementations.cs

See Also
Inheritance Hierarchy


Ocl_at Methods

Ocl_at Methods
Protected Methods Public Methods
Collapse All

The methods of the Ocl_at class are listed here.

Protected Methods
Name | Description
Init | This is Init, a member of class Ocl_at.
Top
Public Methods
Name | Description
Evaluate | This is Evaluate, a member of class Ocl_at.


Ocl_at.Evaluate Method

Ocl_at.Evaluate Method
Ocl_at Class Eco.FrameworkImpl.Ocl Namespace See Also
Collapse All
C#
public override void Evaluate(
    IOclOperationParameters __Params
);
Remarks

This is Evaluate, a member of class Ocl_at.

See Also
Ocl_at Class
Eco.FrameworkImpl.Ocl Namespace


Ocl_at.Init Method

Ocl_at.Init Method
Ocl_at Class Eco.FrameworkImpl.Ocl Namespace See Also
Collapse All
C#
protected override void Init();
Remarks

This is Init, a member of class Ocl_at.

See Also
Ocl_at Class
Eco.FrameworkImpl.Ocl Namespace


Ocl_AtTime Class

Ocl_AtTime Class
Inheritance Hierarchy See Also
Collapse All
C#
public class Ocl_AtTime : OclOperationBase;
Remarks

end Ocl_RegExpMatch

Inheritance Hierarchy
Eco.FrameworkImpl.Ocl.Ocl_AtTime
File

OclSymbolImplementations.cs

See Also
Inheritance Hierarchy


Ocl_AtTime Methods

Ocl_AtTime Methods
Protected Methods Public Methods
Collapse All

The methods of the Ocl_AtTime class are listed here.

Protected Methods
Name | Description
Init | This is Init, a member of class Ocl_AtTime.
Top
Public Methods
Name | Description
Evaluate | This is Evaluate, a member of class Ocl_AtTime.


Ocl_AtTime.Evaluate Method

Ocl_AtTime.Evaluate Method
Ocl_AtTime Class Eco.FrameworkImpl.Ocl Namespace See Also
Collapse All
C#
public override void Evaluate(
    IOclOperationParameters __Params
);
Remarks

This is Evaluate, a member of class Ocl_AtTime.

See Also
Ocl_AtTime Class
Eco.FrameworkImpl.Ocl Namespace


Ocl_AtTime.Init Method

Ocl_AtTime.Init Method
Ocl_AtTime Class Eco.FrameworkImpl.Ocl Namespace See Also
Collapse All
C#
protected override void Init();
Remarks

This is Init, a member of class Ocl_AtTime.

See Also
Ocl_AtTime Class
Eco.FrameworkImpl.Ocl Namespace


Ocl_Attributes Class

Ocl_Attributes Class
Inheritance Hierarchy See Also
Collapse All
C#
public class Ocl_Attributes : OclOperationBase;
Remarks

end Ocl_TypeName

Inheritance Hierarchy
Eco.FrameworkImpl.Ocl.Ocl_Attributes
File

OclSymbolImplementations.cs

See Also
Inheritance Hierarchy


Ocl_Attributes Methods

Ocl_Attributes Methods
Protected Methods Public Methods
Collapse All

The methods of the Ocl_Attributes class are listed here.

Protected Methods
Name | Description
Init | This is Init, a member of class Ocl_Attributes.
Top
Public Methods
Name | Description
Evaluate | This is Evaluate, a member of class Ocl_Attributes.


Ocl_Attributes.Evaluate Method

Ocl_Attributes.Evaluate Method
Ocl_Attributes Class Eco.FrameworkImpl.Ocl Namespace See Also
Collapse All
C#
public override void Evaluate(
    IOclOperationParameters __Params
);
Remarks

This is Evaluate, a member of class Ocl_Attributes.

See Also
Ocl_Attributes Class
Eco.FrameworkImpl.Ocl Namespace


Ocl_Attributes.Init Method

Ocl_Attributes.Init Method
Ocl_Attributes Class Eco.FrameworkImpl.Ocl Namespace See Also
Collapse All
C#
protected override void Init();
Remarks

This is Init, a member of class Ocl_Attributes.

See Also
Ocl_Attributes Class
Eco.FrameworkImpl.Ocl Namespace


Ocl_collect Class

Ocl_collect Class
Inheritance Hierarchy See Also
Collapse All
C#
public class Ocl_collect : Ocl_TupleOperation;
Remarks

This is class Eco.FrameworkImpl.Ocl.Ocl_collect.

Inheritance Hierarchy
Eco.FrameworkImpl.Ocl.Ocl_TupleOperation
    Eco.FrameworkImpl.Ocl.Ocl_collect
File

OclSymbolImplementations.cs

See Also
Inheritance Hierarchy


Ocl_collect Methods

Ocl_collect Methods
Protected Methods Public Methods
Collapse All

The methods of the Ocl_collect class are listed here.

Protected Methods
Name | Description
Init | This is Init, a member of class Ocl_collect.
Top
Public Methods
Name | Description
CalculateReturnType | This is CalculateReturnType, a member of class Ocl_collect.
Evaluate | This is Evaluate, a member of class Ocl_collect.


Ocl_collect.CalculateReturnType Method

Ocl_collect.CalculateReturnType Method
Ocl_collect Class Eco.FrameworkImpl.Ocl Namespace See Also
Collapse All
C#
public override IOclType CalculateReturnType(
    IOclOperationParameters oclParameters
);
Remarks

This is CalculateReturnType, a member of class Ocl_collect.

See Also
Ocl_collect Class
Eco.FrameworkImpl.Ocl Namespace


Ocl_collect.Evaluate Method

Ocl_collect.Evaluate Method
Ocl_collect Class Eco.FrameworkImpl.Ocl Namespace See Also
Collapse All
C#
public override void Evaluate(
    IOclOperationParameters __Params
);
Remarks

This is Evaluate, a member of class Ocl_collect.

See Also
Ocl_collect Class
Eco.FrameworkImpl.Ocl Namespace


Ocl_collect.Init Method

Ocl_collect.Init Method
Ocl_collect Class Eco.FrameworkImpl.Ocl Namespace See Also
Collapse All
C#
protected override void Init();
Remarks

This is Init, a member of class Ocl_collect.

See Also
Ocl_collect Class
Eco.FrameworkImpl.Ocl Namespace


Ocl_concat Class

Ocl_concat Class
Inheritance Hierarchy See Also
Collapse All
C#
public class Ocl_concat : OclOperationBase;
Remarks

end Ocl_MaxLength

Inheritance Hierarchy
Eco.FrameworkImpl.Ocl.Ocl_concat
File

OclSymbolImplementations.cs

See Also
Inheritance Hierarchy


Ocl_concat Methods

Ocl_concat Methods
Protected Methods Public Methods
Collapse All

The methods of the Ocl_concat class are listed here.

Protected Methods
Name | Description
Init | This is Init, a member of class Ocl_concat.
Top
Public Methods
Name | Description
Evaluate | This is Evaluate, a member of class Ocl_concat.


Ocl_concat.Evaluate Method

Ocl_concat.Evaluate Method
Ocl_concat Class Eco.FrameworkImpl.Ocl Namespace See Also
Collapse All
C#
public override void Evaluate(
    IOclOperationParameters __Params
);
Remarks

This is Evaluate, a member of class Ocl_concat.

See Also
Ocl_concat Class
Eco.FrameworkImpl.Ocl Namespace


Ocl_concat.Init Method

Ocl_concat.Init Method
Ocl_concat Class Eco.FrameworkImpl.Ocl Namespace See Also
Collapse All
C#
protected override void Init();
Remarks

This is Init, a member of class Ocl_concat.

See Also
Ocl_concat Class
Eco.FrameworkImpl.Ocl Namespace


Ocl_Constraints Class

Ocl_Constraints Class
Inheritance Hierarchy See Also
Collapse All
C#
public class Ocl_Constraints : OclOperationBase;
Remarks

This is class Eco.FrameworkImpl.Ocl.Ocl_Constraints.

Inheritance Hierarchy
Eco.FrameworkImpl.Ocl.Ocl_Constraints
File

OclConstraintOperations.cs

See Also
Inheritance Hierarchy


Ocl_Constraints Methods

Ocl_Constraints Methods
Protected Methods Public Methods
Collapse All

The methods of the Ocl_Constraints class are listed here.

Protected Methods
Name | Description
Init | Ocl_Constraints
Top
Public Methods
Name | Description
Evaluate | This is Evaluate, a member of class Ocl_Constraints.


Ocl_Constraints.Evaluate Method

Ocl_Constraints.Evaluate Method
Ocl_Constraints Class Eco.FrameworkImpl.Ocl Namespace See Also
Collapse All
C#
public override void Evaluate(
    IOclOperationParameters __Params
);
Remarks

This is Evaluate, a member of class Ocl_Constraints.

See Also
Ocl_Constraints Class
Eco.FrameworkImpl.Ocl Namespace


Ocl_Constraints.Init Method

Ocl_Constraints.Init Method
Ocl_Constraints Class Eco.FrameworkImpl.Ocl Namespace See Also
Collapse All
C#
protected override void Init();
Remarks

Ocl_Constraints

See Also
Ocl_Constraints Class
Eco.FrameworkImpl.Ocl Namespace


Ocl_Count Class

Ocl_Count Class
Inheritance Hierarchy See Also
Collapse All
C#
public class Ocl_Count : OclOperationBase;
Remarks

end Ocl_IndexOf

Inheritance Hierarchy
Eco.FrameworkImpl.Ocl.Ocl_Count
File

OclSymbolImplementations.cs

See Also
Inheritance Hierarchy


Ocl_Count Methods

Ocl_Count Methods
Protected Methods Public Methods
Collapse All

The methods of the Ocl_Count class are listed here.

Protected Methods
Name | Description
Init | This is Init, a member of class Ocl_Count.
Top
Public Methods
Name | Description
Evaluate | This is Evaluate, a member of class Ocl_Count.


Ocl_Count.Evaluate Method

Ocl_Count.Evaluate Method
Ocl_Count Class Eco.FrameworkImpl.Ocl Namespace See Also
Collapse All
C#
public override void Evaluate(
    IOclOperationParameters __Params
);
Remarks

This is Evaluate, a member of class Ocl_Count.

See Also
Ocl_Count Class
Eco.FrameworkImpl.Ocl Namespace


Ocl_Count.Init Method

Ocl_Count.Init Method
Ocl_Count Class Eco.FrameworkImpl.Ocl Namespace See Also
Collapse All
C#
protected override void Init();
Remarks

This is Init, a member of class Ocl_Count.

See Also
Ocl_Count Class
Eco.FrameworkImpl.Ocl Namespace


Ocl_Create Class

Ocl_Create Class
Inheritance Hierarchy See Also
Collapse All
C#
public class Ocl_Create : OclOperationBase;
Remarks

end Ocl_Let

Inheritance Hierarchy
Eco.FrameworkImpl.Ocl.Ocl_Create
File

OclSymbolImplementations.cs

See Also
Inheritance Hierarchy


Ocl_Create Methods

Ocl_Create Methods
Protected Methods Public Methods
Collapse All

The methods of the Ocl_Create class are listed here.

Protected Methods
Name | Description
Init | This is Init, a member of class Ocl_Create.
Top
Public Methods
Name | Description
Evaluate | This is Evaluate, a member of class Ocl_Create.


Ocl_Create.Evaluate Method

Ocl_Create.Evaluate Method
Ocl_Create Class Eco.FrameworkImpl.Ocl Namespace See Also
Collapse All
C#
public override void Evaluate(
    IOclOperationParameters __Params
);
Remarks

This is Evaluate, a member of class Ocl_Create.

See Also
Ocl_Create Class
Eco.FrameworkImpl.Ocl Namespace


Ocl_Create.Init Method

Ocl_Create.Init Method
Ocl_Create Class Eco.FrameworkImpl.Ocl Namespace See Also
Collapse All
C#
protected override void Init();
Remarks

This is Init, a member of class Ocl_Create.

See Also
Ocl_Create Class
Eco.FrameworkImpl.Ocl Namespace


Ocl_Delete Class

Ocl_Delete Class
Inheritance Hierarchy See Also
Collapse All
C#
public class Ocl_Delete : OclOperationBase;
Remarks

end Ocl_Create

Inheritance Hierarchy
Eco.FrameworkImpl.Ocl.Ocl_Delete
File

OclSymbolImplementations.cs

See Also
Inheritance Hierarchy


Ocl_Delete Methods

Ocl_Delete Methods
Protected Methods Public Methods
Collapse All

The methods of the Ocl_Delete class are listed here.

Protected Methods
Name | Description
Init | This is Init, a member of class Ocl_Delete.
Top
Public Methods
Name | Description
Evaluate | This is Evaluate, a member of class Ocl_Delete.


Ocl_Delete.Evaluate Method

Ocl_Delete.Evaluate Method
Ocl_Delete Class Eco.FrameworkImpl.Ocl Namespace See Also
Collapse All
C#
public override void Evaluate(
    IOclOperationParameters __Params
);
Remarks

This is Evaluate, a member of class Ocl_Delete.

See Also
Ocl_Delete Class
Eco.FrameworkImpl.Ocl Namespace


Ocl_Delete.Init Method

Ocl_Delete.Init Method
Ocl_Delete Class Eco.FrameworkImpl.Ocl Namespace See Also
Collapse All
C#
protected override void Init();
Remarks

This is Init, a member of class Ocl_Delete.

See Also
Ocl_Delete Class
Eco.FrameworkImpl.Ocl Namespace


Ocl_difference Class

Ocl_difference Class
Inheritance Hierarchy See Also
Collapse All
C#
public class Ocl_difference : OclOperationBase;
Remarks

end Ocl_Intersection

Inheritance Hierarchy
Eco.FrameworkImpl.Ocl.Ocl_difference
File

OclSymbolImplementations.cs

See Also
Inheritance Hierarchy


Ocl_difference Methods

Ocl_difference Methods
Protected Methods Public Methods
Collapse All

The methods of the Ocl_difference class are listed here.

Protected Methods
Name | Description
Init | This is Init, a member of class Ocl_difference.
Top
Public Methods
Name | Description
Evaluate | This is Evaluate, a member of class Ocl_difference.


Ocl_difference.Evaluate Method

Ocl_difference.Evaluate Method
Ocl_difference Class Eco.FrameworkImpl.Ocl Namespace See Also
Collapse All
C#
public override void Evaluate(
    IOclOperationParameters __Params
);
Remarks

This is Evaluate, a member of class Ocl_difference.

See Also
Ocl_difference Class
Eco.FrameworkImpl.Ocl Namespace


Ocl_difference.Init Method

Ocl_difference.Init Method
Ocl_difference Class Eco.FrameworkImpl.Ocl Namespace See Also
Collapse All
C#
protected override void Init();
Remarks

This is Init, a member of class Ocl_difference.

See Also
Ocl_difference Class
Eco.FrameworkImpl.Ocl Namespace


Ocl_Div Class

Ocl_Div Class
Inheritance Hierarchy See Also
Collapse All
C#
public class Ocl_Div : OclOperationBase;
Remarks

end Ocl_GreaterEQ

Inheritance Hierarchy
Eco.FrameworkImpl.Ocl.Ocl_Div
File

OclSymbolImplementations.cs

See Also
Inheritance Hierarchy


Ocl_Div Methods

Ocl_Div Methods
Protected Methods Public Methods
Collapse All

The methods of the Ocl_Div class are listed here.

Protected Methods
Name | Description
Init | This is Init, a member of class Ocl_Div.
Top
Public Methods
Name | Description
Evaluate | integer operations


Ocl_Div.Evaluate Method

Ocl_Div.Evaluate Method
Ocl_Div Class Eco.FrameworkImpl.Ocl Namespace See Also
Collapse All
C#
public override void Evaluate(
    IOclOperationParameters __Params
);
Remarks

integer operations

See Also
Ocl_Div Class
Eco.FrameworkImpl.Ocl Namespace


Ocl_Div.Init Method

Ocl_Div.Init Method
Ocl_Div Class Eco.FrameworkImpl.Ocl Namespace See Also
Collapse All
C#
protected override void Init();
Remarks

This is Init, a member of class Ocl_Div.

See Also
Ocl_Div Class
Eco.FrameworkImpl.Ocl Namespace


Ocl_EmptyList Class

Ocl_EmptyList Class
Inheritance Hierarchy See Also
Collapse All
C#
public class Ocl_EmptyList : OclOperationBase;
Remarks

end Ocl_AllLoadedObjects

Inheritance Hierarchy
Eco.FrameworkImpl.Ocl.Ocl_EmptyList
File

OclSymbolImplementations.cs

See Also
Inheritance Hierarchy


Ocl_EmptyList Methods

Ocl_EmptyList Methods
Protected Methods Public Methods
Collapse All

The methods of the Ocl_EmptyList class are listed here.

Protected Methods
Name | Description
Init | This is Init, a member of class Ocl_EmptyList.
Top
Public Methods
Name | Description
Evaluate | This is Evaluate, a member of class Ocl_EmptyList.


Ocl_EmptyList.Evaluate Method

Ocl_EmptyList.Evaluate Method
Ocl_EmptyList Class Eco.FrameworkImpl.Ocl Namespace See Also
Collapse All
C#
public override void Evaluate(
    IOclOperationParameters __Params
);
Remarks

This is Evaluate, a member of class Ocl_EmptyList.

See Also
Ocl_EmptyList Class
Eco.FrameworkImpl.Ocl Namespace


Ocl_EmptyList.Init Method

Ocl_EmptyList.Init Method
Ocl_EmptyList Class Eco.FrameworkImpl.Ocl Namespace See Also
Collapse All
C#
protected override void Init();
Remarks

This is Init, a member of class Ocl_EmptyList.

See Also
Ocl_EmptyList Class
Eco.FrameworkImpl.Ocl Namespace


Ocl_Equal Class

Ocl_Equal Class
Inheritance Hierarchy See Also
Collapse All
C#
public class Ocl_Equal : Ocl_AbstractCompare;
Remarks

end Ocl_AbstractCompare

Inheritance Hierarchy
Eco.FrameworkImpl.Ocl.Ocl_AbstractCompare
    Eco.FrameworkImpl.Ocl.Ocl_Equal
File

OclSymbolImplementations.cs

See Also
Inheritance Hierarchy


Ocl_Equal Methods

Ocl_Equal Methods
Protected Methods Public Methods
Collapse All

The methods of the Ocl_Equal class are listed here.

Protected Methods
Name | Description
Init | This is Init, a member of class Ocl_Equal.
Top
Public Methods
Name | Description
Evaluate | This is Evaluate, a member of class Ocl_Equal.


Ocl_Equal.Evaluate Method

Ocl_Equal.Evaluate Method
Ocl_Equal Class Eco.FrameworkImpl.Ocl Namespace See Also
Collapse All
C#
public override void Evaluate(
    IOclOperationParameters __Params
);
Remarks

This is Evaluate, a member of class Ocl_Equal.

See Also
Ocl_Equal Class
Eco.FrameworkImpl.Ocl Namespace


Ocl_Equal.Init Method

Ocl_Equal.Init Method
Ocl_Equal Class Eco.FrameworkImpl.Ocl Namespace See Also
Collapse All
C#
protected override void Init();
Remarks

This is Init, a member of class Ocl_Equal.

See Also
Ocl_Equal Class
Eco.FrameworkImpl.Ocl Namespace


Ocl_excluding Class

Ocl_excluding Class
Inheritance Hierarchy See Also
Collapse All
C#
public class Ocl_excluding : OclOperationBase;
Remarks

end Ocl_Including

Inheritance Hierarchy
Eco.FrameworkImpl.Ocl.Ocl_excluding
File

OclSymbolImplementations.cs

See Also
Inheritance Hierarchy


Ocl_excluding Methods

Ocl_excluding Methods
Protected Methods Public Methods
Collapse All

The methods of the Ocl_excluding class are listed here.

Protected Methods
Name | Description
Init | This is Init, a member of class Ocl_excluding.
Top
Public Methods
Name | Description
Evaluate | This is Evaluate, a member of class Ocl_excluding.


Ocl_excluding.Evaluate Method

Ocl_excluding.Evaluate Method
Ocl_excluding Class Eco.FrameworkImpl.Ocl Namespace See Also
Collapse All
C#
public override void Evaluate(
    IOclOperationParameters __Params
);
Remarks

This is Evaluate, a member of class Ocl_excluding.

See Also
Ocl_excluding Class
Eco.FrameworkImpl.Ocl Namespace


Ocl_excluding.Init Method

Ocl_excluding.Init Method
Ocl_excluding Class Eco.FrameworkImpl.Ocl Namespace See Also
Collapse All
C#
protected override void Init();
Remarks

This is Init, a member of class Ocl_excluding.

See Also
Ocl_excluding Class
Eco.FrameworkImpl.Ocl Namespace


Ocl_Existing Class

Ocl_Existing Class
Inheritance Hierarchy See Also
Collapse All
C#
public class Ocl_Existing : OclOperationBase;
Remarks

end Ocl_AllInstancesAtTime

Inheritance Hierarchy
Eco.FrameworkImpl.Ocl.Ocl_Existing
File

OclSymbolImplementations.cs

See Also
Inheritance Hierarchy


Ocl_Existing Methods

Ocl_Existing Methods
Protected Methods Public Methods
Collapse All

The methods of the Ocl_Existing class are listed here.

Protected Methods
Name | Description
Init | This is Init, a member of class Ocl_Existing.
Top
Public Methods
Name | Description
Evaluate | This is Evaluate, a member of class Ocl_Existing.


Ocl_Existing.Evaluate Method

Ocl_Existing.Evaluate Method
Ocl_Existing Class Eco.FrameworkImpl.Ocl Namespace See Also
Collapse All
C#
public override void Evaluate(
    IOclOperationParameters __Params
);
Remarks

This is Evaluate, a member of class Ocl_Existing.

See Also
Ocl_Existing Class
Eco.FrameworkImpl.Ocl Namespace


Ocl_Existing.Init Method

Ocl_Existing.Init Method
Ocl_Existing Class Eco.FrameworkImpl.Ocl Namespace See Also
Collapse All
C#
protected override void Init();
Remarks

This is Init, a member of class Ocl_Existing.

See Also
Ocl_Existing Class
Eco.FrameworkImpl.Ocl Namespace


Ocl_Exists Class

Ocl_Exists Class
Inheritance Hierarchy See Also
Collapse All
C#
public class Ocl_Exists : OclOperationBase;
Remarks

end Ocl_isNull

Inheritance Hierarchy
Eco.FrameworkImpl.Ocl.Ocl_Exists
File

OclSymbolImplementations.cs

See Also
Inheritance Hierarchy


Ocl_Exists Methods

Ocl_Exists Methods
Protected Methods Public Methods
Collapse All

The methods of the Ocl_Exists class are listed here.

Protected Methods
Name | Description
Init | This is Init, a member of class Ocl_Exists.
Top
Public Methods
Name | Description
Evaluate | This is Evaluate, a member of class Ocl_Exists.


Ocl_Exists.Evaluate Method

Ocl_Exists.Evaluate Method
Ocl_Exists Class Eco.FrameworkImpl.Ocl Namespace See Also
Collapse All
C#
public override void Evaluate(
    IOclOperationParameters __Params
);
Remarks

This is Evaluate, a member of class Ocl_Exists.

See Also
Ocl_Exists Class
Eco.FrameworkImpl.Ocl Namespace


Ocl_Exists.Init Method

Ocl_Exists.Init Method
Ocl_Exists Class Eco.FrameworkImpl.Ocl Namespace See Also
Collapse All
C#
protected override void Init();
Remarks

This is Init, a member of class Ocl_Exists.

See Also
Ocl_Exists Class
Eco.FrameworkImpl.Ocl Namespace


Ocl_ExternalId Class

Ocl_ExternalId Class
Inheritance Hierarchy See Also
Collapse All
C#
public class Ocl_ExternalId : OclOperationBase;
Remarks

end Ocl_TaggedValue

Inheritance Hierarchy
Eco.FrameworkImpl.Ocl.Ocl_ExternalId
File

OclSymbolImplementations.cs

See Also
Inheritance Hierarchy


Ocl_ExternalId Methods

Ocl_ExternalId Methods
Protected Methods Public Methods
Collapse All

The methods of the Ocl_ExternalId class are listed here.

Protected Methods
Name | Description
Init | This is Init, a member of class Ocl_ExternalId.
Top
Public Methods
Name | Description
Evaluate | This is Evaluate, a member of class Ocl_ExternalId.


Ocl_ExternalId.Evaluate Method

Ocl_ExternalId.Evaluate Method
Ocl_ExternalId Class Eco.FrameworkImpl.Ocl Namespace See Also
Collapse All
C#
public override void Evaluate(
    IOclOperationParameters __Params
);
Remarks

This is Evaluate, a member of class Ocl_ExternalId.

See Also
Ocl_ExternalId Class
Eco.FrameworkImpl.Ocl Namespace


Ocl_ExternalId.Init Method

Ocl_ExternalId.Init Method
Ocl_ExternalId Class Eco.FrameworkImpl.Ocl Namespace See Also
Collapse All
C#
protected override void Init();
Remarks

This is Init, a member of class Ocl_ExternalId.

See Also
Ocl_ExternalId Class
Eco.FrameworkImpl.Ocl Namespace


Ocl_FilterOnType Class

Ocl_FilterOnType Class
Inheritance Hierarchy See Also
Collapse All
C#
public class Ocl_FilterOnType : OclOperationBase;
Remarks

end Ocl_Existing

Inheritance Hierarchy
Eco.FrameworkImpl.Ocl.Ocl_FilterOnType
File

OclSymbolImplementations.cs

See Also
Inheritance Hierarchy


Ocl_FilterOnType Methods

Ocl_FilterOnType Methods
Protected Methods Public Methods
Collapse All

The methods of the Ocl_FilterOnType class are listed here.

Protected Methods
Name | Description
Init | This is Init, a member of class Ocl_FilterOnType.
Top
Public Methods
Name | Description
Evaluate | This is Evaluate, a member of class Ocl_FilterOnType.


Ocl_FilterOnType.Evaluate Method

Ocl_FilterOnType.Evaluate Method
Ocl_FilterOnType Class Eco.FrameworkImpl.Ocl Namespace See Also
Collapse All
C#
public override void Evaluate(
    IOclOperationParameters __Params
);
Remarks

This is Evaluate, a member of class Ocl_FilterOnType.

See Also
Ocl_FilterOnType Class
Eco.FrameworkImpl.Ocl Namespace


Ocl_FilterOnType.Init Method

Ocl_FilterOnType.Init Method
Ocl_FilterOnType Class Eco.FrameworkImpl.Ocl Namespace See Also
Collapse All
C#
protected override void Init();
Remarks

This is Init, a member of class Ocl_FilterOnType.

See Also
Ocl_FilterOnType Class
Eco.FrameworkImpl.Ocl Namespace


Ocl_first Class

Ocl_first Class
Inheritance Hierarchy See Also
Collapse All
C#
public class Ocl_first : OclOperationBase;
Remarks

end Ocl_at

Inheritance Hierarchy
Eco.FrameworkImpl.Ocl.Ocl_first
File

OclSymbolImplementations.cs

See Also
Inheritance Hierarchy


Ocl_first Methods

Ocl_first Methods
Protected Methods Public Methods
Collapse All

The methods of the Ocl_first class are listed here.

Protected Methods
Name | Description
Init | This is Init, a member of class Ocl_first.
Top
Public Methods
Name | Description
Evaluate | This is Evaluate, a member of class Ocl_first.


Ocl_first.Evaluate Method

Ocl_first.Evaluate Method
Ocl_first Class Eco.FrameworkImpl.Ocl Namespace See Also
Collapse All
C#
public override void Evaluate(
    IOclOperationParameters __Params
);
Remarks

This is Evaluate, a member of class Ocl_first.

See Also
Ocl_first Class
Eco.FrameworkImpl.Ocl Namespace


Ocl_first.Init Method

Ocl_first.Init Method
Ocl_first Class Eco.FrameworkImpl.Ocl Namespace See Also
Collapse All
C#
protected override void Init();
Remarks

This is Init, a member of class Ocl_first.

See Also
Ocl_first Class
Eco.FrameworkImpl.Ocl Namespace


Ocl_ForAll Class

Ocl_ForAll Class
Inheritance Hierarchy See Also
Collapse All
C#
public class Ocl_ForAll : OclOperationBase;
Remarks

end Ocl_Exists

Inheritance Hierarchy
Eco.FrameworkImpl.Ocl.Ocl_ForAll
File

OclSymbolImplementations.cs

See Also
Inheritance Hierarchy


Ocl_ForAll Methods

Ocl_ForAll Methods
Protected Methods Public Methods
Collapse All

The methods of the Ocl_ForAll class are listed here.

Protected Methods
Name | Description
Init | This is Init, a member of class Ocl_ForAll.
Top
Public Methods
Name | Description
Evaluate | This is Evaluate, a member of class Ocl_ForAll.


Ocl_ForAll.Evaluate Method

Ocl_ForAll.Evaluate Method
Ocl_ForAll Class Eco.FrameworkImpl.Ocl Namespace See Also
Collapse All
C#
public override void Evaluate(
    IOclOperationParameters __Params
);
Remarks

This is Evaluate, a member of class Ocl_ForAll.

See Also
Ocl_ForAll Class
Eco.FrameworkImpl.Ocl Namespace


Ocl_ForAll.Init Method

Ocl_ForAll.Init Method
Ocl_ForAll Class Eco.FrameworkImpl.Ocl Namespace See Also
Collapse All
C#
protected override void Init();
Remarks

This is Init, a member of class Ocl_ForAll.

See Also
Ocl_ForAll Class
Eco.FrameworkImpl.Ocl Namespace


Ocl_Format Class

Ocl_Format Class
Inheritance Hierarchy See Also
Collapse All
C#
public class Ocl_Format : OclOperationBase;
Remarks

end Ocl_PostPad

Inheritance Hierarchy
Eco.FrameworkImpl.Ocl.Ocl_Format
File

OclSymbolImplementations.cs

See Also
Inheritance Hierarchy


Ocl_Format Methods

Ocl_Format Methods
Protected Methods Public Methods
Collapse All

The methods of the Ocl_Format class are listed here.

Protected Methods
Name | Description
Init | This is Init, a member of class Ocl_Format.
Top
Public Methods
Name | Description
Evaluate | This is Evaluate, a member of class Ocl_Format.


Ocl_Format.Evaluate Method

Ocl_Format.Evaluate Method
Ocl_Format Class Eco.FrameworkImpl.Ocl Namespace See Also
Collapse All
C#
public override void Evaluate(
    IOclOperationParameters __Params
);
Remarks

This is Evaluate, a member of class Ocl_Format.

See Also
Ocl_Format Class
Eco.FrameworkImpl.Ocl Namespace


Ocl_Format.Init Method

Ocl_Format.Init Method
Ocl_Format Class Eco.FrameworkImpl.Ocl Namespace See Also
Collapse All
C#
protected override void Init();
Remarks

This is Init, a member of class Ocl_Format.

See Also
Ocl_Format Class
Eco.FrameworkImpl.Ocl Namespace


Ocl_FormatDateTime Class

Ocl_FormatDateTime Class
Inheritance Hierarchy See Also
Collapse All
C#
public class Ocl_FormatDateTime : OclOperationBase;
Remarks

end Ocl_Format

Inheritance Hierarchy
Eco.FrameworkImpl.Ocl.Ocl_FormatDateTime
File

OclSymbolImplementations.cs

See Also
Inheritance Hierarchy


Ocl_FormatDateTime Methods

Ocl_FormatDateTime Methods
Protected Methods Public Methods
Collapse All

The methods of the Ocl_FormatDateTime class are listed here.

Protected Methods
Name | Description
Init | This is Init, a member of class Ocl_FormatDateTime.
Top
Public Methods
Name | Description
Evaluate | This is Evaluate, a member of class Ocl_FormatDateTime.


Ocl_FormatDateTime.Evaluate Method

Ocl_FormatDateTime.Evaluate Method
Ocl_FormatDateTime Class Eco.FrameworkImpl.Ocl Namespace See Also
Collapse All
C#
public override void Evaluate(
    IOclOperationParameters __Params
);
Remarks

This is Evaluate, a member of class Ocl_FormatDateTime.

See Also
Ocl_FormatDateTime Class
Eco.FrameworkImpl.Ocl Namespace


Ocl_FormatDateTime.Init Method

Ocl_FormatDateTime.Init Method
Ocl_FormatDateTime Class Eco.FrameworkImpl.Ocl Namespace See Also
Collapse All
C#
protected override void Init();
Remarks

This is Init, a member of class Ocl_FormatDateTime.

See Also
Ocl_FormatDateTime Class
Eco.FrameworkImpl.Ocl Namespace


Ocl_Greater Class

Ocl_Greater Class
Inheritance Hierarchy See Also
Collapse All
C#
public class Ocl_Greater : OclOperationBase;
Remarks

end Ocl_Less

Inheritance Hierarchy
Eco.FrameworkImpl.Ocl.Ocl_Greater
File

OclSymbolImplementations.cs

See Also
Inheritance Hierarchy


Ocl_Greater Methods

Ocl_Greater Methods
Protected Methods Public Methods
Collapse All

The methods of the Ocl_Greater class are listed here.

Protected Methods
Name | Description
Init | This is Init, a member of class Ocl_Greater.
Top
Public Methods
Name | Description
Evaluate | This is Evaluate, a member of class Ocl_Greater.


Ocl_Greater.Evaluate Method

Ocl_Greater.Evaluate Method
Ocl_Greater Class Eco.FrameworkImpl.Ocl Namespace See Also
Collapse All
C#
public override void Evaluate(
    IOclOperationParameters __Params
);
Remarks

This is Evaluate, a member of class Ocl_Greater.

See Also
Ocl_Greater Class
Eco.FrameworkImpl.Ocl Namespace


Ocl_Greater.Init Method

Ocl_Greater.Init Method
Ocl_Greater Class Eco.FrameworkImpl.Ocl Namespace See Also
Collapse All
C#
protected override void Init();
Remarks

This is Init, a member of class Ocl_Greater.

See Also
Ocl_Greater Class
Eco.FrameworkImpl.Ocl Namespace


Ocl_GreaterEQ Class

Ocl_GreaterEQ Class
Inheritance Hierarchy See Also
Collapse All
C#
public class Ocl_GreaterEQ : OclOperationBase;
Remarks

end Ocl_LessEQ

Inheritance Hierarchy
Eco.FrameworkImpl.Ocl.Ocl_GreaterEQ
File

OclSymbolImplementations.cs

See Also
Inheritance Hierarchy


Ocl_GreaterEQ Methods

Ocl_GreaterEQ Methods
Protected Methods Public Methods
Collapse All

The methods of the Ocl_GreaterEQ class are listed here.

Protected Methods
Name | Description
Init | This is Init, a member of class Ocl_GreaterEQ.
Top
Public Methods
Name | Description
Evaluate | This is Evaluate, a member of class Ocl_GreaterEQ.


Ocl_GreaterEQ.Evaluate Method

Ocl_GreaterEQ.Evaluate Method
Ocl_GreaterEQ Class Eco.FrameworkImpl.Ocl Namespace See Also
Collapse All
C#
public override void Evaluate(
    IOclOperationParameters __Params
);
Remarks

This is Evaluate, a member of class Ocl_GreaterEQ.

See Also
Ocl_GreaterEQ Class
Eco.FrameworkImpl.Ocl Namespace


Ocl_GreaterEQ.Init Method

Ocl_GreaterEQ.Init Method
Ocl_GreaterEQ Class Eco.FrameworkImpl.Ocl Namespace See Also
Collapse All
C#
protected override void Init();
Remarks

This is Init, a member of class Ocl_GreaterEQ.

See Also
Ocl_GreaterEQ Class
Eco.FrameworkImpl.Ocl Namespace


Ocl_GroupBy Class

Ocl_GroupBy Class
Inheritance Hierarchy See Also
Collapse All
C#
public class Ocl_GroupBy : Ocl_TupleOperation;
Remarks

This is class Eco.FrameworkImpl.Ocl.Ocl_GroupBy.

Inheritance Hierarchy
Eco.FrameworkImpl.Ocl.Ocl_TupleOperation
    Eco.FrameworkImpl.Ocl.Ocl_GroupBy
File

OclSymbolImplementations.cs

See Also
Inheritance Hierarchy


Ocl_GroupBy Methods

Ocl_GroupBy Methods
Protected Methods Public Methods
Collapse All

The methods of the Ocl_GroupBy class are listed here.

Protected Methods
Name | Description
Init | This is Init, a member of class Ocl_GroupBy.
Top
Public Methods
Name | Description
CalculateReturnType | This is CalculateReturnType, a member of class Ocl_GroupBy.
Evaluate | This is Evaluate, a member of class Ocl_GroupBy.


Ocl_GroupBy.CalculateReturnType Method

Ocl_GroupBy.CalculateReturnType Method
Ocl_GroupBy Class Eco.FrameworkImpl.Ocl Namespace See Also
Collapse All
C#
public override IOclType CalculateReturnType(
    IOclOperationParameters oclParameters
);
Remarks

This is CalculateReturnType, a member of class Ocl_GroupBy.

See Also
Ocl_GroupBy Class
Eco.FrameworkImpl.Ocl Namespace


Ocl_GroupBy.Evaluate Method

Ocl_GroupBy.Evaluate Method
Ocl_GroupBy Class Eco.FrameworkImpl.Ocl Namespace See Also
Collapse All
C#
public override void Evaluate(
    IOclOperationParameters __Params
);
Remarks

This is Evaluate, a member of class Ocl_GroupBy.

See Also
Ocl_GroupBy Class
Eco.FrameworkImpl.Ocl Namespace


Ocl_GroupBy.Init Method

Ocl_GroupBy.Init Method
Ocl_GroupBy Class Eco.FrameworkImpl.Ocl Namespace See Also
Collapse All
C#
protected override void Init();
Remarks

This is Init, a member of class Ocl_GroupBy.

See Also
Ocl_GroupBy Class
Eco.FrameworkImpl.Ocl Namespace


Ocl_if Class

Ocl_if Class
Inheritance Hierarchy See Also
Collapse All
C#
public class Ocl_if : OclOperationBase;
Remarks

end Ocl_implies

Inheritance Hierarchy
Eco.FrameworkImpl.Ocl.Ocl_if
File

OclSymbolImplementations.cs

See Also
Inheritance Hierarchy


Ocl_if Methods

Ocl_if Methods
Protected Methods Public Methods
Collapse All

The methods of the Ocl_if class are listed here.

Protected Methods
Name | Description
Init | This is Init, a member of class Ocl_if.
Top
Public Methods
Name | Description
Evaluate | This is Evaluate, a member of class Ocl_if.
ResultIsReadOnly | This is ResultIsReadOnly, a member of class Ocl_if.


Ocl_if.Evaluate Method

Ocl_if.Evaluate Method
Ocl_if Class Eco.FrameworkImpl.Ocl Namespace See Also
Collapse All
C#
public override void Evaluate(
    IOclOperationParameters __Params
);
Remarks

This is Evaluate, a member of class Ocl_if.

See Also
Ocl_if Class
Eco.FrameworkImpl.Ocl Namespace


Ocl_if.Init Method

Ocl_if.Init Method
Ocl_if Class Eco.FrameworkImpl.Ocl Namespace See Also
Collapse All
C#
protected override void Init();
Remarks

This is Init, a member of class Ocl_if.

See Also
Ocl_if Class
Eco.FrameworkImpl.Ocl Namespace


Ocl_if.ResultIsReadOnly Method

Ocl_if.ResultIsReadOnly Method
Ocl_if Class Eco.FrameworkImpl.Ocl Namespace See Also
Collapse All
C#
public override bool ResultIsReadOnly(
    bool[] Args
);
Remarks

This is ResultIsReadOnly, a member of class Ocl_if.

See Also
Ocl_if Class
Eco.FrameworkImpl.Ocl Namespace


Ocl_implies Class

Ocl_implies Class
Inheritance Hierarchy See Also
Collapse All
C#
public class Ocl_implies : OclOperationBase;
Remarks

end Ocl_xor

Inheritance Hierarchy
Eco.FrameworkImpl.Ocl.Ocl_implies
File

OclSymbolImplementations.cs

See Also
Inheritance Hierarchy


Ocl_implies Methods

Ocl_implies Methods
Protected Methods Public Methods
Collapse All

The methods of the Ocl_implies class are listed here.

Protected Methods
Name | Description
Init | This is Init, a member of class Ocl_implies.
Top
Public Methods
Name | Description
Evaluate | This is Evaluate, a member of class Ocl_implies.


Ocl_implies.Evaluate Method

Ocl_implies.Evaluate Method
Ocl_implies Class Eco.FrameworkImpl.Ocl Namespace See Also
Collapse All
C#
public override void Evaluate(
    IOclOperationParameters __Params
);
Remarks

This is Evaluate, a member of class Ocl_implies.

See Also
Ocl_implies Class
Eco.FrameworkImpl.Ocl Namespace


Ocl_implies.Init Method

Ocl_implies.Init Method
Ocl_implies Class Eco.FrameworkImpl.Ocl Namespace See Also
Collapse All
C#
protected override void Init();
Remarks

This is Init, a member of class Ocl_implies.

See Also
Ocl_implies Class
Eco.FrameworkImpl.Ocl Namespace


Ocl_includes Class

Ocl_includes Class
Inheritance Hierarchy See Also
Collapse All
C#
public class Ocl_includes : OclOperationBase;
Remarks

end Ocl_Size

Inheritance Hierarchy
Eco.FrameworkImpl.Ocl.Ocl_includes
File

OclSymbolImplementations.cs

See Also
Inheritance Hierarchy


Ocl_includes Methods

Ocl_includes Methods
Protected Methods Public Methods
Collapse All

The methods of the Ocl_includes class are listed here.

Protected Methods
Name | Description
Init | This is Init, a member of class Ocl_includes.
Top
Public Methods
Name | Description
Evaluate | This is Evaluate, a member of class Ocl_includes.


Ocl_includes.Evaluate Method

Ocl_includes.Evaluate Method
Ocl_includes Class Eco.FrameworkImpl.Ocl Namespace See Also
Collapse All
C#
public override void Evaluate(
    IOclOperationParameters __Params
);
Remarks

This is Evaluate, a member of class Ocl_includes.

See Also
Ocl_includes Class
Eco.FrameworkImpl.Ocl Namespace


Ocl_includes.Init Method

Ocl_includes.Init Method
Ocl_includes Class Eco.FrameworkImpl.Ocl Namespace See Also
Collapse All
C#
protected override void Init();
Remarks

This is Init, a member of class Ocl_includes.

See Also
Ocl_includes Class
Eco.FrameworkImpl.Ocl Namespace


Ocl_IncludesAll Class

Ocl_IncludesAll Class
Inheritance Hierarchy See Also
Collapse All
C#
public class Ocl_IncludesAll : OclOperationBase;
Remarks

end Ocl_Count

Inheritance Hierarchy
Eco.FrameworkImpl.Ocl.Ocl_IncludesAll
File

OclSymbolImplementations.cs

See Also
Inheritance Hierarchy


Ocl_IncludesAll Methods

Ocl_IncludesAll Methods
Protected Methods Public Methods
Collapse All

The methods of the Ocl_IncludesAll class are listed here.

Protected Methods
Name | Description
Init | This is Init, a member of class Ocl_IncludesAll.
Top
Public Methods
Name | Description
Evaluate | This is Evaluate, a member of class Ocl_IncludesAll.


Ocl_IncludesAll.Evaluate Method

Ocl_IncludesAll.Evaluate Method
Ocl_IncludesAll Class Eco.FrameworkImpl.Ocl Namespace See Also
Collapse All
C#
public override void Evaluate(
    IOclOperationParameters __Params
);
Remarks

This is Evaluate, a member of class Ocl_IncludesAll.

See Also
Ocl_IncludesAll Class
Eco.FrameworkImpl.Ocl Namespace


Ocl_IncludesAll.Init Method

Ocl_IncludesAll.Init Method
Ocl_IncludesAll Class Eco.FrameworkImpl.Ocl Namespace See Also
Collapse All
C#
protected override void Init();
Remarks

This is Init, a member of class Ocl_IncludesAll.

See Also
Ocl_IncludesAll Class
Eco.FrameworkImpl.Ocl Namespace


Ocl_Including Class

Ocl_Including Class
Inheritance Hierarchy See Also
Collapse All
C#
public class Ocl_Including : OclOperationBase;
Remarks

end Ocl_difference

Inheritance Hierarchy
Eco.FrameworkImpl.Ocl.Ocl_Including
File

OclSymbolImplementations.cs

See Also
Inheritance Hierarchy


Ocl_Including Methods

Ocl_Including Methods
Protected Methods Public Methods
Collapse All

The methods of the Ocl_Including class are listed here.

Protected Methods
Name | Description
Init | This is Init, a member of class Ocl_Including.
Top
Public Methods
Name | Description
Evaluate | This is Evaluate, a member of class Ocl_Including.


Ocl_Including.Evaluate Method

Ocl_Including.Evaluate Method
Ocl_Including Class Eco.FrameworkImpl.Ocl Namespace See Also
Collapse All
C#
public override void Evaluate(
    IOclOperationParameters __Params
);
Remarks

This is Evaluate, a member of class Ocl_Including.

See Also
Ocl_Including Class
Eco.FrameworkImpl.Ocl Namespace


Ocl_Including.Init Method

Ocl_Including.Init Method
Ocl_Including Class Eco.FrameworkImpl.Ocl Namespace See Also
Collapse All
C#
protected override void Init();
Remarks

This is Init, a member of class Ocl_Including.

See Also
Ocl_Including Class
Eco.FrameworkImpl.Ocl Namespace


Ocl_IndexOf Class

Ocl_IndexOf Class
Inheritance Hierarchy See Also
Collapse All
C#
public class Ocl_IndexOf : OclOperationBase;
Remarks

end Ocl_includes

Inheritance Hierarchy
Eco.FrameworkImpl.Ocl.Ocl_IndexOf
File

OclSymbolImplementations.cs

See Also
Inheritance Hierarchy


Ocl_IndexOf Methods

Ocl_IndexOf Methods
Protected Methods Public Methods
Collapse All

The methods of the Ocl_IndexOf class are listed here.

Protected Methods
Name | Description
Init | This is Init, a member of class Ocl_IndexOf.
Top
Public Methods
Name | Description
Evaluate | This is Evaluate, a member of class Ocl_IndexOf.


Ocl_IndexOf.Evaluate Method

Ocl_IndexOf.Evaluate Method
Ocl_IndexOf Class Eco.FrameworkImpl.Ocl Namespace See Also
Collapse All
C#
public override void Evaluate(
    IOclOperationParameters __Params
);
Remarks

This is Evaluate, a member of class Ocl_IndexOf.

See Also
Ocl_IndexOf Class
Eco.FrameworkImpl.Ocl Namespace


Ocl_IndexOf.Init Method

Ocl_IndexOf.Init Method
Ocl_IndexOf Class Eco.FrameworkImpl.Ocl Namespace See Also
Collapse All
C#
protected override void Init();
Remarks

This is Init, a member of class Ocl_IndexOf.

See Also
Ocl_IndexOf Class
Eco.FrameworkImpl.Ocl Namespace


Ocl_Intersection Class

Ocl_Intersection Class
Inheritance Hierarchy See Also
Collapse All
C#
public class Ocl_Intersection : OclOperationBase;
Remarks

end Ocl_union

Inheritance Hierarchy
Eco.FrameworkImpl.Ocl.Ocl_Intersection
File

OclSymbolImplementations.cs

See Also
Inheritance Hierarchy


Ocl_Intersection Methods

Ocl_Intersection Methods
Protected Methods Public Methods
Collapse All

The methods of the Ocl_Intersection class are listed here.

Protected Methods
Name | Description
Init | This is Init, a member of class Ocl_Intersection.
Top
Public Methods
Name | Description
Evaluate | This is Evaluate, a member of class Ocl_Intersection.


Ocl_Intersection.Evaluate Method

Ocl_Intersection.Evaluate Method
Ocl_Intersection Class Eco.FrameworkImpl.Ocl Namespace See Also
Collapse All
C#
public override void Evaluate(
    IOclOperationParameters __Params
);
Remarks

This is Evaluate, a member of class Ocl_Intersection.

See Also
Ocl_Intersection Class
Eco.FrameworkImpl.Ocl Namespace


Ocl_Intersection.Init Method

Ocl_Intersection.Init Method
Ocl_Intersection Class Eco.FrameworkImpl.Ocl Namespace See Also
Collapse All
C#
protected override void Init();
Remarks

This is Init, a member of class Ocl_Intersection.

See Also
Ocl_Intersection Class
Eco.FrameworkImpl.Ocl Namespace


Ocl_isEmpty Class

Ocl_isEmpty Class
Inheritance Hierarchy See Also
Collapse All
C#
public class Ocl_isEmpty : OclOperationBase;
Remarks

end Ocl_IncludesAll

Inheritance Hierarchy
Eco.FrameworkImpl.Ocl.Ocl_isEmpty
File

OclSymbolImplementations.cs

See Also
Inheritance Hierarchy


Ocl_isEmpty Methods

Ocl_isEmpty Methods
Protected Methods Public Methods
Collapse All

The methods of the Ocl_isEmpty class are listed here.

Protected Methods
Name | Description
Init | This is Init, a member of class Ocl_isEmpty.
Top
Public Methods
Name | Description
Evaluate | This is Evaluate, a member of class Ocl_isEmpty.


Ocl_isEmpty.Evaluate Method

Ocl_isEmpty.Evaluate Method
Ocl_isEmpty Class Eco.FrameworkImpl.Ocl Namespace See Also
Collapse All
C#
public override void Evaluate(
    IOclOperationParameters __Params
);
Remarks

This is Evaluate, a member of class Ocl_isEmpty.

See Also
Ocl_isEmpty Class
Eco.FrameworkImpl.Ocl Namespace


Ocl_isEmpty.Init Method

Ocl_isEmpty.Init Method
Ocl_isEmpty Class Eco.FrameworkImpl.Ocl Namespace See Also
Collapse All
C#
protected override void Init();
Remarks

This is Init, a member of class Ocl_isEmpty.

See Also
Ocl_isEmpty Class
Eco.FrameworkImpl.Ocl Namespace


Ocl_isNull Class

Ocl_isNull Class
Inheritance Hierarchy See Also
Collapse All
C#
public class Ocl_isNull : OclOperationBase;
Remarks

This is class Eco.FrameworkImpl.Ocl.Ocl_isNull.

Inheritance Hierarchy
Eco.FrameworkImpl.Ocl.Ocl_isNull
File

OclSymbolImplementations.cs

See Also
Inheritance Hierarchy


Ocl_isNull Methods

Ocl_isNull Methods
Protected Methods Public Methods
Collapse All

The methods of the Ocl_isNull class are listed here.

Protected Methods
Name | Description
Init | This is Init, a member of class Ocl_isNull.
Top
Public Methods
Name | Description
Evaluate | This is Evaluate, a member of class Ocl_isNull.


Ocl_isNull.Evaluate Method

Ocl_isNull.Evaluate Method
Ocl_isNull Class Eco.FrameworkImpl.Ocl Namespace See Also
Collapse All
C#
public override void Evaluate(
    IOclOperationParameters __Params
);
Remarks

This is Evaluate, a member of class Ocl_isNull.

See Also
Ocl_isNull Class
Eco.FrameworkImpl.Ocl Namespace


Ocl_isNull.Init Method

Ocl_isNull.Init Method
Ocl_isNull Class Eco.FrameworkImpl.Ocl Namespace See Also
Collapse All
C#
protected override void Init();
Remarks

This is Init, a member of class Ocl_isNull.

See Also
Ocl_isNull Class
Eco.FrameworkImpl.Ocl Namespace


Ocl_last Class

Ocl_last Class
Inheritance Hierarchy See Also
Collapse All
C#
public class Ocl_last : OclOperationBase;
Remarks

end Ocl_first

Inheritance Hierarchy
Eco.FrameworkImpl.Ocl.Ocl_last
File

OclSymbolImplementations.cs

See Also
Inheritance Hierarchy


Ocl_last Methods

Ocl_last Methods
Protected Methods Public Methods
Collapse All

The methods of the Ocl_last class are listed here.

Protected Methods
Name | Description
Init | This is Init, a member of class Ocl_last.
Top
Public Methods
Name | Description
Evaluate | This is Evaluate, a member of class Ocl_last.


Ocl_last.Evaluate Method

Ocl_last.Evaluate Method
Ocl_last Class Eco.FrameworkImpl.Ocl Namespace See Also
Collapse All
C#
public override void Evaluate(
    IOclOperationParameters __Params
);
Remarks

This is Evaluate, a member of class Ocl_last.

See Also
Ocl_last Class
Eco.FrameworkImpl.Ocl Namespace


Ocl_last.Init Method

Ocl_last.Init Method
Ocl_last Class Eco.FrameworkImpl.Ocl Namespace See Also
Collapse All
C#
protected override void Init();
Remarks

This is Init, a member of class Ocl_last.

See Also
Ocl_last Class
Eco.FrameworkImpl.Ocl Namespace


Ocl_Length Class

Ocl_Length Class
Inheritance Hierarchy See Also
Collapse All
C#
public class Ocl_Length : OclPsOperationBase;
Remarks

end OclPsOperationBase

Inheritance Hierarchy
Eco.FrameworkImpl.Ocl.OclPsOperationBase
    Eco.FrameworkImpl.Ocl.Ocl_Length
File

OclSymbolImplementations.cs

See Also
Inheritance Hierarchy


Ocl_Length Methods

Ocl_Length Methods
Protected Methods
Collapse All

The methods of the Ocl_Length class are listed here.

Protected Methods
Name | Description
Init | This is Init, a member of class Ocl_Length.


Ocl_Length.Init Method

Ocl_Length.Init Method
Ocl_Length Class Eco.FrameworkImpl.Ocl Namespace See Also
Collapse All
C#
protected override void Init();
Remarks

This is Init, a member of class Ocl_Length.

See Also
Ocl_Length Class
Eco.FrameworkImpl.Ocl Namespace


Ocl_Less Class

Ocl_Less Class
Inheritance Hierarchy See Also
Collapse All
C#
public class Ocl_Less : OclOperationBase;
Remarks

end Ocl_strToInt

Inheritance Hierarchy
Eco.FrameworkImpl.Ocl.Ocl_Less
File

OclSymbolImplementations.cs

See Also
Inheritance Hierarchy


Ocl_Less Methods

Ocl_Less Methods
Protected Methods Public Methods
Collapse All

The methods of the Ocl_Less class are listed here.

Protected Methods
Name | Description
Init | This is Init, a member of class Ocl_Less.
Top
Public Methods
Name | Description
Evaluate | This is Evaluate, a member of class Ocl_Less.


Ocl_Less.Evaluate Method

Ocl_Less.Evaluate Method
Ocl_Less Class Eco.FrameworkImpl.Ocl Namespace See Also
Collapse All
C#
public override void Evaluate(
    IOclOperationParameters __Params
);
Remarks

This is Evaluate, a member of class Ocl_Less.

See Also
Ocl_Less Class
Eco.FrameworkImpl.Ocl Namespace


Ocl_Less.Init Method

Ocl_Less.Init Method
Ocl_Less Class Eco.FrameworkImpl.Ocl Namespace See Also
Collapse All
C#
protected override void Init();
Remarks

This is Init, a member of class Ocl_Less.

See Also
Ocl_Less Class
Eco.FrameworkImpl.Ocl Namespace


Ocl_LessEQ Class

Ocl_LessEQ Class
Inheritance Hierarchy See Also
Collapse All
C#
public class Ocl_LessEQ : OclOperationBase;
Remarks

end Ocl_Greater

Inheritance Hierarchy
Eco.FrameworkImpl.Ocl.Ocl_LessEQ
File

OclSymbolImplementations.cs

See Also
Inheritance Hierarchy


Ocl_LessEQ Methods

Ocl_LessEQ Methods
Protected Methods Public Methods
Collapse All

The methods of the Ocl_LessEQ class are listed here.

Protected Methods
Name | Description
Init | This is Init, a member of class Ocl_LessEQ.
Top
Public Methods
Name | Description
Evaluate | This is Evaluate, a member of class Ocl_LessEQ.


Ocl_LessEQ.Evaluate Method

Ocl_LessEQ.Evaluate Method
Ocl_LessEQ Class Eco.FrameworkImpl.Ocl Namespace See Also
Collapse All
C#
public override void Evaluate(
    IOclOperationParameters __Params
);
Remarks

This is Evaluate, a member of class Ocl_LessEQ.

See Also
Ocl_LessEQ Class
Eco.FrameworkImpl.Ocl Namespace


Ocl_LessEQ.Init Method

Ocl_LessEQ.Init Method
Ocl_LessEQ Class Eco.FrameworkImpl.Ocl Namespace See Also
Collapse All
C#
protected override void Init();
Remarks

This is Init, a member of class Ocl_LessEQ.

See Also
Ocl_LessEQ Class
Eco.FrameworkImpl.Ocl Namespace


Ocl_Let Class

Ocl_Let Class
Inheritance Hierarchy See Also
Collapse All
C#
public class Ocl_Let : OclOperationBase;
Remarks

end Ocl_TimeToTimeStamp

Inheritance Hierarchy
Eco.FrameworkImpl.Ocl.Ocl_Let
File

OclSymbolImplementations.cs

See Also
Inheritance Hierarchy


Ocl_Let Methods

Ocl_Let Methods
Protected Methods Public Methods
Collapse All

The methods of the Ocl_Let class are listed here.

Protected Methods
Name | Description
Init | This is Init, a member of class Ocl_Let.
Top
Public Methods
Name | Description
Evaluate | This is Evaluate, a member of class Ocl_Let.


Ocl_Let.Evaluate Method

Ocl_Let.Evaluate Method
Ocl_Let Class Eco.FrameworkImpl.Ocl Namespace See Also
Collapse All
C#
public override void Evaluate(
    IOclOperationParameters __Params
);
Remarks

This is Evaluate, a member of class Ocl_Let.

See Also
Ocl_Let Class
Eco.FrameworkImpl.Ocl Namespace


Ocl_Let.Init Method

Ocl_Let.Init Method
Ocl_Let Class Eco.FrameworkImpl.Ocl Namespace See Also
Collapse All
C#
protected override void Init();
Remarks

This is Init, a member of class Ocl_Let.

See Also
Ocl_Let Class
Eco.FrameworkImpl.Ocl Namespace


Ocl_ListAdd Class

Ocl_ListAdd Class
Inheritance Hierarchy See Also
Collapse All
C#
public class Ocl_ListAdd : OclOperationBase;
Remarks

end Ocl_StatementSequence

Inheritance Hierarchy
Eco.FrameworkImpl.Ocl.Ocl_ListAdd
File

OclSymbolImplementations.cs

See Also
Inheritance Hierarchy


Ocl_ListAdd Methods

Ocl_ListAdd Methods
Protected Methods Public Methods
Collapse All

The methods of the Ocl_ListAdd class are listed here.

Protected Methods
Name | Description
Init | This is Init, a member of class Ocl_ListAdd.
Top
Public Methods
Name | Description
Evaluate | This is Evaluate, a member of class Ocl_ListAdd.


Ocl_ListAdd.Evaluate Method

Ocl_ListAdd.Evaluate Method
Ocl_ListAdd Class Eco.FrameworkImpl.Ocl Namespace See Also
Collapse All
C#
public override void Evaluate(
    IOclOperationParameters __Params
);
Remarks

This is Evaluate, a member of class Ocl_ListAdd.

See Also
Ocl_ListAdd Class
Eco.FrameworkImpl.Ocl Namespace


Ocl_ListAdd.Init Method

Ocl_ListAdd.Init Method
Ocl_ListAdd Class Eco.FrameworkImpl.Ocl Namespace See Also
Collapse All
C#
protected override void Init();
Remarks

This is Init, a member of class Ocl_ListAdd.

See Also
Ocl_ListAdd Class
Eco.FrameworkImpl.Ocl Namespace


Ocl_ListClear Class

Ocl_ListClear Class
Inheritance Hierarchy See Also
Collapse All
C#
public class Ocl_ListClear : OclOperationBase;
Remarks

end Ocl_ListRemoveAt

Inheritance Hierarchy
Eco.FrameworkImpl.Ocl.Ocl_ListClear
File

OclSymbolImplementations.cs

See Also
Inheritance Hierarchy


Ocl_ListClear Methods

Ocl_ListClear Methods
Protected Methods Public Methods
Collapse All

The methods of the Ocl_ListClear class are listed here.

Protected Methods
Name | Description
Init | This is Init, a member of class Ocl_ListClear.
Top
Public Methods
Name | Description
Evaluate | This is Evaluate, a member of class Ocl_ListClear.


Ocl_ListClear.Evaluate Method

Ocl_ListClear.Evaluate Method
Ocl_ListClear Class Eco.FrameworkImpl.Ocl Namespace See Also
Collapse All
C#
public override void Evaluate(
    IOclOperationParameters __Params
);
Remarks

This is Evaluate, a member of class Ocl_ListClear.

See Also
Ocl_ListClear Class
Eco.FrameworkImpl.Ocl Namespace


Ocl_ListClear.Init Method

Ocl_ListClear.Init Method
Ocl_ListClear Class Eco.FrameworkImpl.Ocl Namespace See Also
Collapse All
C#
protected override void Init();
Remarks

This is Init, a member of class Ocl_ListClear.

See Also
Ocl_ListClear Class
Eco.FrameworkImpl.Ocl Namespace


Ocl_ListRemove Class

Ocl_ListRemove Class
Inheritance Hierarchy See Also
Collapse All
C#
public class Ocl_ListRemove : OclOperationBase;
Remarks

end Ocl_ListAdd

Inheritance Hierarchy
Eco.FrameworkImpl.Ocl.Ocl_ListRemove
File

OclSymbolImplementations.cs

See Also
Inheritance Hierarchy


Ocl_ListRemove Methods

Ocl_ListRemove Methods
Protected Methods Public Methods
Collapse All

The methods of the Ocl_ListRemove class are listed here.

Protected Methods
Name | Description
Init | This is Init, a member of class Ocl_ListRemove.
Top
Public Methods
Name | Description
Evaluate | This is Evaluate, a member of class Ocl_ListRemove.


Ocl_ListRemove.Evaluate Method

Ocl_ListRemove.Evaluate Method
Ocl_ListRemove Class Eco.FrameworkImpl.Ocl Namespace See Also
Collapse All
C#
public override void Evaluate(
    IOclOperationParameters __Params
);
Remarks

This is Evaluate, a member of class Ocl_ListRemove.

See Also
Ocl_ListRemove Class
Eco.FrameworkImpl.Ocl Namespace


Ocl_ListRemove.Init Method

Ocl_ListRemove.Init Method
Ocl_ListRemove Class Eco.FrameworkImpl.Ocl Namespace See Also
Collapse All
C#
protected override void Init();
Remarks

This is Init, a member of class Ocl_ListRemove.

See Also
Ocl_ListRemove Class
Eco.FrameworkImpl.Ocl Namespace


Ocl_ListRemoveAt Class

Ocl_ListRemoveAt Class
Inheritance Hierarchy See Also
Collapse All
C#
public class Ocl_ListRemoveAt : OclOperationBase;
Remarks

end Ocl_ListRemove

Inheritance Hierarchy
Eco.FrameworkImpl.Ocl.Ocl_ListRemoveAt
File

OclSymbolImplementations.cs

See Also
Inheritance Hierarchy


Ocl_ListRemoveAt Methods

Ocl_ListRemoveAt Methods
Protected Methods Public Methods
Collapse All

The methods of the Ocl_ListRemoveAt class are listed here.

Protected Methods
Name | Description
Init | This is Init, a member of class Ocl_ListRemoveAt.
Top
Public Methods
Name | Description
Evaluate | This is Evaluate, a member of class Ocl_ListRemoveAt.


Ocl_ListRemoveAt.Evaluate Method

Ocl_ListRemoveAt.Evaluate Method
Ocl_ListRemoveAt Class Eco.FrameworkImpl.Ocl Namespace See Also
Collapse All
C#
public override void Evaluate(
    IOclOperationParameters __Params
);
Remarks

This is Evaluate, a member of class Ocl_ListRemoveAt.

See Also
Ocl_ListRemoveAt Class
Eco.FrameworkImpl.Ocl Namespace


Ocl_ListRemoveAt.Init Method

Ocl_ListRemoveAt.Init Method
Ocl_ListRemoveAt Class Eco.FrameworkImpl.Ocl Namespace See Also
Collapse All
C#
protected override void Init();
Remarks

This is Init, a member of class Ocl_ListRemoveAt.

See Also
Ocl_ListRemoveAt Class
Eco.FrameworkImpl.Ocl Namespace


Ocl_MaxLength Class

Ocl_MaxLength Class
Inheritance Hierarchy See Also
Collapse All
C#
public class Ocl_MaxLength : OclOperationBase;
Remarks

end Ocl_Mod

Inheritance Hierarchy
Eco.FrameworkImpl.Ocl.Ocl_MaxLength
File

OclSymbolImplementations.cs

See Also
Inheritance Hierarchy


Ocl_MaxLength Methods

Ocl_MaxLength Methods
Protected Methods Public Methods
Collapse All

The methods of the Ocl_MaxLength class are listed here.

Protected Methods
Name | Description
Init | This is Init, a member of class Ocl_MaxLength.
Top
Public Methods
Name | Description
Evaluate | String operations


Ocl_MaxLength.Evaluate Method

Ocl_MaxLength.Evaluate Method
Ocl_MaxLength Class Eco.FrameworkImpl.Ocl Namespace See Also
Collapse All
C#
public override void Evaluate(
    IOclOperationParameters __Params
);
Remarks

String operations

See Also
Ocl_MaxLength Class
Eco.FrameworkImpl.Ocl Namespace


Ocl_MaxLength.Init Method

Ocl_MaxLength.Init Method
Ocl_MaxLength Class Eco.FrameworkImpl.Ocl Namespace See Also
Collapse All
C#
protected override void Init();
Remarks

This is Init, a member of class Ocl_MaxLength.

See Also
Ocl_MaxLength Class
Eco.FrameworkImpl.Ocl Namespace


Ocl_Mod Class

Ocl_Mod Class
Inheritance Hierarchy See Also
Collapse All
C#
public class Ocl_Mod : OclOperationBase;
Remarks

end Ocl_Div

Inheritance Hierarchy
Eco.FrameworkImpl.Ocl.Ocl_Mod
File

OclSymbolImplementations.cs

See Also
Inheritance Hierarchy


Ocl_Mod Methods

Ocl_Mod Methods
Protected Methods Public Methods
Collapse All

The methods of the Ocl_Mod class are listed here.

Protected Methods
Name | Description
Init | This is Init, a member of class Ocl_Mod.
Top
Public Methods
Name | Description
Evaluate | This is Evaluate, a member of class Ocl_Mod.


Ocl_Mod.Evaluate Method

Ocl_Mod.Evaluate Method
Ocl_Mod Class Eco.FrameworkImpl.Ocl Namespace See Also
Collapse All
C#
public override void Evaluate(
    IOclOperationParameters __Params
);
Remarks

This is Evaluate, a member of class Ocl_Mod.

See Also
Ocl_Mod Class
Eco.FrameworkImpl.Ocl Namespace


Ocl_Mod.Init Method

Ocl_Mod.Init Method
Ocl_Mod Class Eco.FrameworkImpl.Ocl Namespace See Also
Collapse All
C#
protected override void Init();
Remarks

This is Init, a member of class Ocl_Mod.

See Also
Ocl_Mod Class
Eco.FrameworkImpl.Ocl Namespace


Ocl_not Class

Ocl_not Class
Inheritance Hierarchy See Also
Collapse All
C#
public class Ocl_not : OclOperationBase;
Remarks

end Ocl_and

Inheritance Hierarchy
Eco.FrameworkImpl.Ocl.Ocl_not
File

OclSymbolImplementations.cs

See Also
Inheritance Hierarchy


Ocl_not Methods

Ocl_not Methods
Protected Methods Public Methods
Collapse All

The methods of the Ocl_not class are listed here.

Protected Methods
Name | Description
Init | This is Init, a member of class Ocl_not.
Top
Public Methods
Name | Description
Evaluate | This is Evaluate, a member of class Ocl_not.


Ocl_not.Evaluate Method

Ocl_not.Evaluate Method
Ocl_not Class Eco.FrameworkImpl.Ocl Namespace See Also
Collapse All
C#
public override void Evaluate(
    IOclOperationParameters __Params
);
Remarks

This is Evaluate, a member of class Ocl_not.

See Also
Ocl_not Class
Eco.FrameworkImpl.Ocl Namespace


Ocl_not.Init Method

Ocl_not.Init Method
Ocl_not Class Eco.FrameworkImpl.Ocl Namespace See Also
Collapse All
C#
protected override void Init();
Remarks

This is Init, a member of class Ocl_not.

See Also
Ocl_not Class
Eco.FrameworkImpl.Ocl Namespace


Ocl_NotEmpty Class

Ocl_NotEmpty Class
Inheritance Hierarchy See Also
Collapse All
C#
public class Ocl_NotEmpty : OclOperationBase;
Remarks

This is class Eco.FrameworkImpl.Ocl.Ocl_NotEmpty.

Inheritance Hierarchy
Eco.FrameworkImpl.Ocl.Ocl_NotEmpty
File

OclSymbolImplementations.cs

See Also
Inheritance Hierarchy


Ocl_NotEmpty Methods

Ocl_NotEmpty Methods
Protected Methods Public Methods
Collapse All

The methods of the Ocl_NotEmpty class are listed here.

Protected Methods
Name | Description
Init | This is Init, a member of class Ocl_NotEmpty.
Top
Public Methods
Name | Description
Evaluate | This is Evaluate, a member of class Ocl_NotEmpty.


Ocl_NotEmpty.Evaluate Method

Ocl_NotEmpty.Evaluate Method
Ocl_NotEmpty Class Eco.FrameworkImpl.Ocl Namespace See Also
Collapse All
C#
public override void Evaluate(
    IOclOperationParameters __Params
);
Remarks

This is Evaluate, a member of class Ocl_NotEmpty.

See Also
Ocl_NotEmpty Class
Eco.FrameworkImpl.Ocl Namespace


Ocl_NotEmpty.Init Method

Ocl_NotEmpty.Init Method
Ocl_NotEmpty Class Eco.FrameworkImpl.Ocl Namespace See Also
Collapse All
C#
protected override void Init();
Remarks

This is Init, a member of class Ocl_NotEmpty.

See Also
Ocl_NotEmpty Class
Eco.FrameworkImpl.Ocl Namespace


Ocl_NotEqual Class

Ocl_NotEqual Class
Inheritance Hierarchy See Also
Collapse All
C#
public class Ocl_NotEqual : Ocl_AbstractCompare;
Remarks

end Ocl_Equal

Inheritance Hierarchy
Eco.FrameworkImpl.Ocl.Ocl_AbstractCompare
    Eco.FrameworkImpl.Ocl.Ocl_NotEqual
File

OclSymbolImplementations.cs

See Also
Inheritance Hierarchy


Ocl_NotEqual Methods

Ocl_NotEqual Methods
Protected Methods Public Methods
Collapse All

The methods of the Ocl_NotEqual class are listed here.

Protected Methods
Name | Description
Init | This is Init, a member of class Ocl_NotEqual.
Top
Public Methods
Name | Description
Evaluate | This is Evaluate, a member of class Ocl_NotEqual.


Ocl_NotEqual.Evaluate Method

Ocl_NotEqual.Evaluate Method
Ocl_NotEqual Class Eco.FrameworkImpl.Ocl Namespace See Also
Collapse All
C#
public override void Evaluate(
    IOclOperationParameters __Params
);
Remarks

This is Evaluate, a member of class Ocl_NotEqual.

See Also
Ocl_NotEqual Class
Eco.FrameworkImpl.Ocl Namespace


Ocl_NotEqual.Init Method

Ocl_NotEqual.Init Method
Ocl_NotEqual Class Eco.FrameworkImpl.Ocl Namespace See Also
Collapse All
C#
protected override void Init();
Remarks

This is Init, a member of class Ocl_NotEqual.

See Also
Ocl_NotEqual Class
Eco.FrameworkImpl.Ocl Namespace


Ocl_ObjectFromExternalId Class

Ocl_ObjectFromExternalId Class
Inheritance Hierarchy See Also
Collapse All
C#
public class Ocl_ObjectFromExternalId : OclOperationBase;
Remarks

end Ocl_ExternalId

Inheritance Hierarchy
Eco.FrameworkImpl.Ocl.Ocl_ObjectFromExternalId
File

OclSymbolImplementations.cs

See Also
Inheritance Hierarchy


Ocl_ObjectFromExternalId Methods

Ocl_ObjectFromExternalId Methods
Protected Methods Public Methods
Collapse All

The methods of the Ocl_ObjectFromExternalId class are listed here.

Protected Methods
Name | Description
Init | This is Init, a member of class Ocl_ObjectFromExternalId.
Top
Public Methods
Name | Description
Evaluate | This is Evaluate, a member of class Ocl_ObjectFromExternalId.


Ocl_ObjectFromExternalId.Evaluate Method

Ocl_ObjectFromExternalId.Evaluate Method
Ocl_ObjectFromExternalId Class Eco.FrameworkImpl.Ocl Namespace See Also
Collapse All
C#
public override void Evaluate(
    IOclOperationParameters __Params
);
Remarks

This is Evaluate, a member of class Ocl_ObjectFromExternalId.

See Also
Ocl_ObjectFromExternalId Class
Eco.FrameworkImpl.Ocl Namespace


Ocl_ObjectFromExternalId.Init Method

Ocl_ObjectFromExternalId.Init Method
Ocl_ObjectFromExternalId Class Eco.FrameworkImpl.Ocl Namespace See Also
Collapse All
C#
protected override void Init();
Remarks

This is Init, a member of class Ocl_ObjectFromExternalId.

See Also
Ocl_ObjectFromExternalId Class
Eco.FrameworkImpl.Ocl Namespace


Ocl_ObjectTimeStamp Class

Ocl_ObjectTimeStamp Class
Inheritance Hierarchy See Also
Collapse All
C#
public class Ocl_ObjectTimeStamp : OclOperationBase;
Remarks

end Ocl_AtTime

Inheritance Hierarchy
Eco.FrameworkImpl.Ocl.Ocl_ObjectTimeStamp
File

OclSymbolImplementations.cs

See Also
Inheritance Hierarchy


Ocl_ObjectTimeStamp Methods

Ocl_ObjectTimeStamp Methods
Protected Methods Public Methods
Collapse All

The methods of the Ocl_ObjectTimeStamp class are listed here.

Protected Methods
Name | Description
Init | This is Init, a member of class Ocl_ObjectTimeStamp.
Top
Public Methods
Name | Description
Evaluate | This is Evaluate, a member of class Ocl_ObjectTimeStamp.


Ocl_ObjectTimeStamp.Evaluate Method

Ocl_ObjectTimeStamp.Evaluate Method
Ocl_ObjectTimeStamp Class Eco.FrameworkImpl.Ocl Namespace See Also
Collapse All
C#
public override void Evaluate(
    IOclOperationParameters __Params
);
Remarks

This is Evaluate, a member of class Ocl_ObjectTimeStamp.

See Also
Ocl_ObjectTimeStamp Class
Eco.FrameworkImpl.Ocl Namespace


Ocl_ObjectTimeStamp.Init Method

Ocl_ObjectTimeStamp.Init Method
Ocl_ObjectTimeStamp Class Eco.FrameworkImpl.Ocl Namespace See Also
Collapse All
C#
protected override void Init();
Remarks

This is Init, a member of class Ocl_ObjectTimeStamp.

See Also
Ocl_ObjectTimeStamp Class
Eco.FrameworkImpl.Ocl Namespace


Ocl_OclAsType Class

Ocl_OclAsType Class
Inheritance Hierarchy See Also
Collapse All
C#
public class Ocl_OclAsType : OclOperationBase;
Remarks

end Ocl_OclIsTypeOf

Inheritance Hierarchy
Eco.FrameworkImpl.Ocl.Ocl_OclAsType
File

OclSymbolImplementations.cs

See Also
Inheritance Hierarchy


Ocl_OclAsType Methods

Ocl_OclAsType Methods
Protected Methods Public Methods
Collapse All

The methods of the Ocl_OclAsType class are listed here.

Protected Methods
Name | Description
Init | This is Init, a member of class Ocl_OclAsType.
Top
Public Methods
Name | Description
Evaluate | This is Evaluate, a member of class Ocl_OclAsType.


Ocl_OclAsType.Evaluate Method

Ocl_OclAsType.Evaluate Method
Ocl_OclAsType Class Eco.FrameworkImpl.Ocl Namespace See Also
Collapse All
C#
public override void Evaluate(
    IOclOperationParameters __Params
);
Remarks

This is Evaluate, a member of class Ocl_OclAsType.

See Also
Ocl_OclAsType Class
Eco.FrameworkImpl.Ocl Namespace


Ocl_OclAsType.Init Method

Ocl_OclAsType.Init Method
Ocl_OclAsType Class Eco.FrameworkImpl.Ocl Namespace See Also
Collapse All
C#
protected override void Init();
Remarks

This is Init, a member of class Ocl_OclAsType.

See Also
Ocl_OclAsType Class
Eco.FrameworkImpl.Ocl Namespace


Ocl_oclGetStates Class

Ocl_oclGetStates Class
Inheritance Hierarchy See Also
Collapse All
C#
public class Ocl_oclGetStates : OclOperationBase;
Remarks

end Ocl_oclIsInState

Inheritance Hierarchy
Eco.FrameworkImpl.Ocl.Ocl_oclGetStates
File

OclSymbolImplementations.cs

See Also
Inheritance Hierarchy


Ocl_oclGetStates Methods

Ocl_oclGetStates Methods
Protected Methods Public Methods
Collapse All

The methods of the Ocl_oclGetStates class are listed here.

Protected Methods
Name | Description
Init | Ocl_oclGetStates
Top
Public Methods
Name | Description
Evaluate | This is Evaluate, a member of class Ocl_oclGetStates.


Ocl_oclGetStates.Evaluate Method

Ocl_oclGetStates.Evaluate Method
Ocl_oclGetStates Class Eco.FrameworkImpl.Ocl Namespace See Also
Collapse All
C#
public override void Evaluate(
    IOclOperationParameters __Params
);
Remarks

This is Evaluate, a member of class Ocl_oclGetStates.

See Also
Ocl_oclGetStates Class
Eco.FrameworkImpl.Ocl Namespace


Ocl_oclGetStates.Init Method

Ocl_oclGetStates.Init Method
Ocl_oclGetStates Class Eco.FrameworkImpl.Ocl Namespace See Also
Collapse All
C#
protected override void Init();
Remarks

Ocl_oclGetStates

See Also
Ocl_oclGetStates Class
Eco.FrameworkImpl.Ocl Namespace


Ocl_oclGetTriggers Class

Ocl_oclGetTriggers Class
Inheritance Hierarchy See Also
Collapse All
C#
public class Ocl_oclGetTriggers : OclOperationBase;
Remarks

end Ocl_oclGetStates

Inheritance Hierarchy
Eco.FrameworkImpl.Ocl.Ocl_oclGetTriggers
File

OclSymbolImplementations.cs

See Also
Inheritance Hierarchy


Ocl_oclGetTriggers Methods

Ocl_oclGetTriggers Methods
Protected Methods Public Methods
Collapse All

The methods of the Ocl_oclGetTriggers class are listed here.

Protected Methods
Name | Description
Init | Ocl_oclGetTriggers
Top
Public Methods
Name | Description
Evaluate | This is Evaluate, a member of class Ocl_oclGetTriggers.


Ocl_oclGetTriggers.Evaluate Method

Ocl_oclGetTriggers.Evaluate Method
Ocl_oclGetTriggers Class Eco.FrameworkImpl.Ocl Namespace See Also
Collapse All
C#
public override void Evaluate(
    IOclOperationParameters __Params
);
Remarks

This is Evaluate, a member of class Ocl_oclGetTriggers.

See Also
Ocl_oclGetTriggers Class
Eco.FrameworkImpl.Ocl Namespace


Ocl_oclGetTriggers.Init Method

Ocl_oclGetTriggers.Init Method
Ocl_oclGetTriggers Class Eco.FrameworkImpl.Ocl Namespace See Also
Collapse All
C#
protected override void Init();
Remarks

Ocl_oclGetTriggers

See Also
Ocl_oclGetTriggers Class
Eco.FrameworkImpl.Ocl Namespace


Ocl_oclIsInState Class

Ocl_oclIsInState Class
Inheritance Hierarchy See Also
Collapse All
C#
public class Ocl_oclIsInState : OclOperationBase;
Remarks

end Ocl_ListClear

Inheritance Hierarchy
Eco.FrameworkImpl.Ocl.Ocl_oclIsInState
File

OclSymbolImplementations.cs

See Also
Inheritance Hierarchy


Ocl_oclIsInState Methods

Ocl_oclIsInState Methods
Protected Methods Public Methods
Collapse All

The methods of the Ocl_oclIsInState class are listed here.

Protected Methods
Name | Description
Init | This is Init, a member of class Ocl_oclIsInState.
Top
Public Methods
Name | Description
Evaluate | This is Evaluate, a member of class Ocl_oclIsInState.
SemanticCheck | This is SemanticCheck, a member of class Ocl_oclIsInState.


Ocl_oclIsInState.Evaluate Method

Ocl_oclIsInState.Evaluate Method
Ocl_oclIsInState Class Eco.FrameworkImpl.Ocl Namespace See Also
Collapse All
C#
public override void Evaluate(
    IOclOperationParameters __Params
);
Remarks

This is Evaluate, a member of class Ocl_oclIsInState.

See Also
Ocl_oclIsInState Class
Eco.FrameworkImpl.Ocl Namespace


Ocl_oclIsInState.Init Method

Ocl_oclIsInState.Init Method
Ocl_oclIsInState Class Eco.FrameworkImpl.Ocl Namespace See Also
Collapse All
C#
protected override void Init();
Remarks

This is Init, a member of class Ocl_oclIsInState.

See Also
Ocl_oclIsInState Class
Eco.FrameworkImpl.Ocl Namespace


Ocl_oclIsInState.SemanticCheck Method

Ocl_oclIsInState.SemanticCheck Method
Ocl_oclIsInState Class Eco.FrameworkImpl.Ocl Namespace See Also
Collapse All
C#
public override void SemanticCheck(
    IOclOperationParameters __Params
);
Remarks

This is SemanticCheck, a member of class Ocl_oclIsInState.

See Also
Ocl_oclIsInState Class
Eco.FrameworkImpl.Ocl Namespace


Ocl_oclIsKindOf Class

Ocl_oclIsKindOf Class
Inheritance Hierarchy See Also
Collapse All
C#
public class Ocl_oclIsKindOf : OclOperationBase;
Remarks

end Ocl_OclType

Inheritance Hierarchy
Eco.FrameworkImpl.Ocl.Ocl_oclIsKindOf
File

OclSymbolImplementations.cs

See Also
Inheritance Hierarchy


Ocl_oclIsKindOf Methods

Ocl_oclIsKindOf Methods
Protected Methods Public Methods
Collapse All

The methods of the Ocl_oclIsKindOf class are listed here.

Protected Methods
Name | Description
Init | This is Init, a member of class Ocl_oclIsKindOf.
Top
Public Methods
Name | Description
Evaluate | This is Evaluate, a member of class Ocl_oclIsKindOf.


Ocl_oclIsKindOf.Evaluate Method

Ocl_oclIsKindOf.Evaluate Method
Ocl_oclIsKindOf Class Eco.FrameworkImpl.Ocl Namespace See Also
Collapse All
C#
public override void Evaluate(
    IOclOperationParameters __Params
);
Remarks

This is Evaluate, a member of class Ocl_oclIsKindOf.

See Also
Ocl_oclIsKindOf Class
Eco.FrameworkImpl.Ocl Namespace


Ocl_oclIsKindOf.Init Method

Ocl_oclIsKindOf.Init Method
Ocl_oclIsKindOf Class Eco.FrameworkImpl.Ocl Namespace See Also
Collapse All
C#
protected override void Init();
Remarks

This is Init, a member of class Ocl_oclIsKindOf.

See Also
Ocl_oclIsKindOf Class
Eco.FrameworkImpl.Ocl Namespace


Ocl_OclIsTypeOf Class

Ocl_OclIsTypeOf Class
Inheritance Hierarchy See Also
Collapse All
C#
public class Ocl_OclIsTypeOf : OclOperationBase;
Remarks

end Ocl_oclIsKindOf

Inheritance Hierarchy
Eco.FrameworkImpl.Ocl.Ocl_OclIsTypeOf
File

OclSymbolImplementations.cs

See Also
Inheritance Hierarchy


Ocl_OclIsTypeOf Methods

Ocl_OclIsTypeOf Methods
Protected Methods Public Methods
Collapse All

The methods of the Ocl_OclIsTypeOf class are listed here.

Protected Methods
Name | Description
Init | This is Init, a member of class Ocl_OclIsTypeOf.
Top
Public Methods
Name | Description
Evaluate | This is Evaluate, a member of class Ocl_OclIsTypeOf.


Ocl_OclIsTypeOf.Evaluate Method

Ocl_OclIsTypeOf.Evaluate Method
Ocl_OclIsTypeOf Class Eco.FrameworkImpl.Ocl Namespace See Also
Collapse All
C#
public override void Evaluate(
    IOclOperationParameters __Params
);
Remarks

This is Evaluate, a member of class Ocl_OclIsTypeOf.

See Also
Ocl_OclIsTypeOf Class
Eco.FrameworkImpl.Ocl Namespace


Ocl_OclIsTypeOf.Init Method

Ocl_OclIsTypeOf.Init Method
Ocl_OclIsTypeOf Class Eco.FrameworkImpl.Ocl Namespace See Also
Collapse All
C#
protected override void Init();
Remarks

This is Init, a member of class Ocl_OclIsTypeOf.

See Also
Ocl_OclIsTypeOf Class
Eco.FrameworkImpl.Ocl Namespace


Ocl_OclType Class

Ocl_OclType Class
Inheritance Hierarchy See Also
Collapse All
C#
public class Ocl_OclType : OclOperationBase;
Remarks

end Ocl_EmptyList

Inheritance Hierarchy
Eco.FrameworkImpl.Ocl.Ocl_OclType
File

OclSymbolImplementations.cs

See Also
Inheritance Hierarchy


Ocl_OclType Methods

Ocl_OclType Methods
Protected Methods Public Methods
Collapse All

The methods of the Ocl_OclType class are listed here.

Protected Methods
Name | Description
Init | This is Init, a member of class Ocl_OclType.
Top
Public Methods
Name | Description
Evaluate | This is Evaluate, a member of class Ocl_OclType.


Ocl_OclType.Evaluate Method

Ocl_OclType.Evaluate Method
Ocl_OclType Class Eco.FrameworkImpl.Ocl Namespace See Also
Collapse All
C#
public override void Evaluate(
    IOclOperationParameters __Params
);
Remarks

This is Evaluate, a member of class Ocl_OclType.

See Also
Ocl_OclType Class
Eco.FrameworkImpl.Ocl Namespace


Ocl_OclType.Init Method

Ocl_OclType.Init Method
Ocl_OclType Class Eco.FrameworkImpl.Ocl Namespace See Also
Collapse All
C#
protected override void Init();
Remarks

This is Init, a member of class Ocl_OclType.

See Also
Ocl_OclType Class
Eco.FrameworkImpl.Ocl Namespace


Ocl_or Class

Ocl_or Class
Inheritance Hierarchy See Also
Collapse All
C#
public class Ocl_or : OclOperationBase;
Remarks

end Ocl_StrToDateTime

Inheritance Hierarchy
Eco.FrameworkImpl.Ocl.Ocl_or
File

OclSymbolImplementations.cs

See Also
Inheritance Hierarchy


Ocl_or Methods

Ocl_or Methods
Protected Methods Public Methods
Collapse All

The methods of the Ocl_or class are listed here.

Protected Methods
Name | Description
Init | This is Init, a member of class Ocl_or.
Top
Public Methods
Name | Description
Evaluate | Boolean Operations


Ocl_or.Evaluate Method

Ocl_or.Evaluate Method
Ocl_or Class Eco.FrameworkImpl.Ocl Namespace See Also
Collapse All
C#
public override void Evaluate(
    IOclOperationParameters __Params
);
Remarks

Boolean Operations

See Also
Ocl_or Class
Eco.FrameworkImpl.Ocl Namespace


Ocl_or.Init Method

Ocl_or.Init Method
Ocl_or Class Eco.FrameworkImpl.Ocl Namespace See Also
Collapse All
C#
protected override void Init();
Remarks

This is Init, a member of class Ocl_or.

See Also
Ocl_or Class
Eco.FrameworkImpl.Ocl Namespace


Ocl_orderby Class

Ocl_orderby Class
Inheritance Hierarchy See Also
Collapse All
C#
public class Ocl_orderby : Ocl_AbstractOrder;
Remarks

end Ocl_AbstractOrder

Inheritance Hierarchy
Eco.FrameworkImpl.Ocl.Ocl_AbstractOrder
    Eco.FrameworkImpl.Ocl.Ocl_orderby
File

OclSymbolImplementations.cs

See Also
Inheritance Hierarchy


Ocl_orderby Methods

Ocl_orderby Methods
Protected Methods
Collapse All

The methods of the Ocl_orderby class are listed here.

Protected Methods
Name | Description
Init | This is Init, a member of class Ocl_orderby.


Ocl_orderby.Init Method

Ocl_orderby.Init Method
Ocl_orderby Class Eco.FrameworkImpl.Ocl Namespace See Also
Collapse All
C#
protected override void Init();
Remarks

This is Init, a member of class Ocl_orderby.

See Also
Ocl_orderby Class
Eco.FrameworkImpl.Ocl Namespace


Ocl_orderDescending Class

Ocl_orderDescending Class
Inheritance Hierarchy See Also
Collapse All
C#
public class Ocl_orderDescending : Ocl_AbstractOrder;
Remarks

end Ocl_orderby

Inheritance Hierarchy
Eco.FrameworkImpl.Ocl.Ocl_AbstractOrder
    Eco.FrameworkImpl.Ocl.Ocl_orderDescending
File

OclSymbolImplementations.cs

See Also
Inheritance Hierarchy


Ocl_orderDescending Methods

Ocl_orderDescending Methods
Protected Methods
Collapse All

The methods of the Ocl_orderDescending class are listed here.

Protected Methods
Name | Description
Init | This is Init, a member of class Ocl_orderDescending.


Ocl_orderDescending.Init Method

Ocl_orderDescending.Init Method
Ocl_orderDescending Class Eco.FrameworkImpl.Ocl Namespace See Also
Collapse All
C#
protected override void Init();
Remarks

This is Init, a member of class Ocl_orderDescending.

See Also
Ocl_orderDescending Class
Eco.FrameworkImpl.Ocl Namespace


Ocl_OrderGeneric Class

Ocl_OrderGeneric Class
Inheritance Hierarchy See Also
Collapse All
C#
public class Ocl_OrderGeneric : OclOperationBase;
Remarks

end Ocl_orderDescending

Inheritance Hierarchy
Eco.FrameworkImpl.Ocl.Ocl_OrderGeneric
File

OclSymbolImplementations.cs

See Also
Inheritance Hierarchy


Ocl_OrderGeneric Methods

Ocl_OrderGeneric Methods
Protected Methods Public Methods
Collapse All

The methods of the Ocl_OrderGeneric class are listed here.

Protected Methods
Name | Description
Init | This is Init, a member of class Ocl_OrderGeneric.
Top
Public Methods
Name | Description
Evaluate | This is Evaluate, a member of class Ocl_OrderGeneric.


Ocl_OrderGeneric.Evaluate Method

Ocl_OrderGeneric.Evaluate Method
Ocl_OrderGeneric Class Eco.FrameworkImpl.Ocl Namespace See Also
Collapse All
C#
public override void Evaluate(
    IOclOperationParameters __Params
);
Remarks

This is Evaluate, a member of class Ocl_OrderGeneric.

See Also
Ocl_OrderGeneric Class
Eco.FrameworkImpl.Ocl Namespace


Ocl_OrderGeneric.Init Method

Ocl_OrderGeneric.Init Method
Ocl_OrderGeneric Class Eco.FrameworkImpl.Ocl Namespace See Also
Collapse All
C#
protected override void Init();
Remarks

This is Init, a member of class Ocl_OrderGeneric.

See Also
Ocl_OrderGeneric Class
Eco.FrameworkImpl.Ocl Namespace


Ocl_Pad Class

Ocl_Pad Class
Inheritance Hierarchy See Also
Collapse All
C#
public class Ocl_Pad : OclOperationBase;
Remarks

end Ocl_SubString

Inheritance Hierarchy
Eco.FrameworkImpl.Ocl.Ocl_Pad
File

OclSymbolImplementations.cs

See Also
Inheritance Hierarchy


Ocl_Pad Methods

Ocl_Pad Methods
Protected Methods Public Methods
Collapse All

The methods of the Ocl_Pad class are listed here.

Protected Methods
Name | Description
Init | This is Init, a member of class Ocl_Pad.
Top
Public Methods
Name | Description
Evaluate | This is Evaluate, a member of class Ocl_Pad.


Ocl_Pad.Evaluate Method

Ocl_Pad.Evaluate Method
Ocl_Pad Class Eco.FrameworkImpl.Ocl Namespace See Also
Collapse All
C#
public override void Evaluate(
    IOclOperationParameters __Params
);
Remarks

This is Evaluate, a member of class Ocl_Pad.

See Also
Ocl_Pad Class
Eco.FrameworkImpl.Ocl Namespace


Ocl_Pad.Init Method

Ocl_Pad.Init Method
Ocl_Pad Class Eco.FrameworkImpl.Ocl Namespace See Also
Collapse All
C#
protected override void Init();
Remarks

This is Init, a member of class Ocl_Pad.

See Also
Ocl_Pad Class
Eco.FrameworkImpl.Ocl Namespace


Ocl_PostPad Class

Ocl_PostPad Class
Inheritance Hierarchy See Also
Collapse All
C#
public class Ocl_PostPad : OclOperationBase;
Remarks

end Ocl_Pad

Inheritance Hierarchy
Eco.FrameworkImpl.Ocl.Ocl_PostPad
File

OclSymbolImplementations.cs

See Also
Inheritance Hierarchy


Ocl_PostPad Methods

Ocl_PostPad Methods
Protected Methods Public Methods
Collapse All

The methods of the Ocl_PostPad class are listed here.

Protected Methods
Name | Description
Init | This is Init, a member of class Ocl_PostPad.
Top
Public Methods
Name | Description
Evaluate | This is Evaluate, a member of class Ocl_PostPad.


Ocl_PostPad.Evaluate Method

Ocl_PostPad.Evaluate Method
Ocl_PostPad Class Eco.FrameworkImpl.Ocl Namespace See Also
Collapse All
C#
public override void Evaluate(
    IOclOperationParameters __Params
);
Remarks

This is Evaluate, a member of class Ocl_PostPad.

See Also
Ocl_PostPad Class
Eco.FrameworkImpl.Ocl Namespace


Ocl_PostPad.Init Method

Ocl_PostPad.Init Method
Ocl_PostPad Class Eco.FrameworkImpl.Ocl Namespace See Also
Collapse All
C#
protected override void Init();
Remarks

This is Init, a member of class Ocl_PostPad.

See Also
Ocl_PostPad Class
Eco.FrameworkImpl.Ocl Namespace


Ocl_Prepend Class

Ocl_Prepend Class
Inheritance Hierarchy See Also
Collapse All
C#
public class Ocl_Prepend : OclOperationBase;
Remarks

end Ocl_Append

Inheritance Hierarchy
Eco.FrameworkImpl.Ocl.Ocl_Prepend
File

OclSymbolImplementations.cs

See Also
Inheritance Hierarchy


Ocl_Prepend Methods

Ocl_Prepend Methods
Protected Methods Public Methods
Collapse All

The methods of the Ocl_Prepend class are listed here.

Protected Methods
Name | Description
Init | This is Init, a member of class Ocl_Prepend.
Top
Public Methods
Name | Description
Evaluate | This is Evaluate, a member of class Ocl_Prepend.


Ocl_Prepend.Evaluate Method

Ocl_Prepend.Evaluate Method
Ocl_Prepend Class Eco.FrameworkImpl.Ocl Namespace See Also
Collapse All
C#
public override void Evaluate(
    IOclOperationParameters __Params
);
Remarks

This is Evaluate, a member of class Ocl_Prepend.

See Also
Ocl_Prepend Class
Eco.FrameworkImpl.Ocl Namespace


Ocl_Prepend.Init Method

Ocl_Prepend.Init Method
Ocl_Prepend Class Eco.FrameworkImpl.Ocl Namespace See Also
Collapse All
C#
protected override void Init();
Remarks

This is Init, a member of class Ocl_Prepend.

See Also
Ocl_Prepend Class
Eco.FrameworkImpl.Ocl Namespace


Ocl_RegExpMatch Class

Ocl_RegExpMatch Class
Inheritance Hierarchy See Also
Collapse All
C#
public class Ocl_RegExpMatch : OclOperationBase;
Remarks

end Ocl_SQLLikeCaseInsensitive

Inheritance Hierarchy
Eco.FrameworkImpl.Ocl.Ocl_RegExpMatch
File

OclSymbolImplementations.cs

See Also
Inheritance Hierarchy


Ocl_RegExpMatch Methods

Ocl_RegExpMatch Methods
Protected Methods Public Methods
Collapse All

The methods of the Ocl_RegExpMatch class are listed here.

Protected Methods
Name | Description
Init | This is Init, a member of class Ocl_RegExpMatch.
Top
Public Methods
Name | Description
Evaluate | This is Evaluate, a member of class Ocl_RegExpMatch.


Ocl_RegExpMatch.Evaluate Method

Ocl_RegExpMatch.Evaluate Method
Ocl_RegExpMatch Class Eco.FrameworkImpl.Ocl Namespace See Also
Collapse All
C#
public override void Evaluate(
    IOclOperationParameters __Params
);
Remarks

This is Evaluate, a member of class Ocl_RegExpMatch.

See Also
Ocl_RegExpMatch Class
Eco.FrameworkImpl.Ocl Namespace


Ocl_RegExpMatch.Init Method

Ocl_RegExpMatch.Init Method
Ocl_RegExpMatch Class Eco.FrameworkImpl.Ocl Namespace See Also
Collapse All
C#
protected override void Init();
Remarks

This is Init, a member of class Ocl_RegExpMatch.

See Also
Ocl_RegExpMatch Class
Eco.FrameworkImpl.Ocl Namespace


Ocl_reject Class

Ocl_reject Class
Inheritance Hierarchy See Also
Collapse All
C#
public class Ocl_reject : OclOperationBase;
Remarks

end Ocl_Select

Inheritance Hierarchy
Eco.FrameworkImpl.Ocl.Ocl_reject
File

OclSymbolImplementations.cs

See Also
Inheritance Hierarchy


Ocl_reject Methods

Ocl_reject Methods
Protected Methods Public Methods
Collapse All

The methods of the Ocl_reject class are listed here.

Protected Methods
Name | Description
Init | This is Init, a member of class Ocl_reject.
Top
Public Methods
Name | Description
Evaluate | This is Evaluate, a member of class Ocl_reject.


Ocl_reject.Evaluate Method

Ocl_reject.Evaluate Method
Ocl_reject Class Eco.FrameworkImpl.Ocl Namespace See Also
Collapse All
C#
public override void Evaluate(
    IOclOperationParameters __Params
);
Remarks

This is Evaluate, a member of class Ocl_reject.

See Also
Ocl_reject Class
Eco.FrameworkImpl.Ocl Namespace


Ocl_reject.Init Method

Ocl_reject.Init Method
Ocl_reject Class Eco.FrameworkImpl.Ocl Namespace See Also
Collapse All
C#
protected override void Init();
Remarks

This is Init, a member of class Ocl_reject.

See Also
Ocl_reject Class
Eco.FrameworkImpl.Ocl Namespace


Ocl_safeCast Class

Ocl_safeCast Class
Inheritance Hierarchy See Also
Collapse All
C#
public class Ocl_safeCast : OclOperationBase;
Remarks

end Ocl_OclAsType

Inheritance Hierarchy
Eco.FrameworkImpl.Ocl.Ocl_safeCast
File

OclSymbolImplementations.cs

See Also
Inheritance Hierarchy


Ocl_safeCast Methods

Ocl_safeCast Methods
Protected Methods Public Methods
Collapse All

The methods of the Ocl_safeCast class are listed here.

Protected Methods
Name | Description
Init | This is Init, a member of class Ocl_safeCast.
Top
Public Methods
Name | Description
Evaluate | This is Evaluate, a member of class Ocl_safeCast.


Ocl_safeCast.Evaluate Method

Ocl_safeCast.Evaluate Method
Ocl_safeCast Class Eco.FrameworkImpl.Ocl Namespace See Also
Collapse All
C#
public override void Evaluate(
    IOclOperationParameters __Params
);
Remarks

This is Evaluate, a member of class Ocl_safeCast.

See Also
Ocl_safeCast Class
Eco.FrameworkImpl.Ocl Namespace


Ocl_safeCast.Init Method

Ocl_safeCast.Init Method
Ocl_safeCast Class Eco.FrameworkImpl.Ocl Namespace See Also
Collapse All
C#
protected override void Init();
Remarks

This is Init, a member of class Ocl_safeCast.

See Also
Ocl_safeCast Class
Eco.FrameworkImpl.Ocl Namespace


Ocl_Select Class

Ocl_Select Class
Inheritance Hierarchy See Also
Collapse All
C#
public class Ocl_Select : OclOperationBase;
Remarks

end Ocl_SymmetricDifference

Inheritance Hierarchy
Eco.FrameworkImpl.Ocl.Ocl_Select
File

OclSymbolImplementations.cs

See Also
Inheritance Hierarchy


Ocl_Select Methods

Ocl_Select Methods
Protected Methods Public Methods
Collapse All

The methods of the Ocl_Select class are listed here.

Protected Methods
Name | Description
Init | This is Init, a member of class Ocl_Select.
Top
Public Methods
Name | Description
Evaluate | This is Evaluate, a member of class Ocl_Select.


Ocl_Select.Evaluate Method

Ocl_Select.Evaluate Method
Ocl_Select Class Eco.FrameworkImpl.Ocl Namespace See Also
Collapse All
C#
public override void Evaluate(
    IOclOperationParameters __Params
);
Remarks

This is Evaluate, a member of class Ocl_Select.

See Also
Ocl_Select Class
Eco.FrameworkImpl.Ocl Namespace


Ocl_Select.Init Method

Ocl_Select.Init Method
Ocl_Select Class Eco.FrameworkImpl.Ocl Namespace See Also
Collapse All
C#
protected override void Init();
Remarks

This is Init, a member of class Ocl_Select.

See Also
Ocl_Select Class
Eco.FrameworkImpl.Ocl Namespace


Ocl_Size Class

Ocl_Size Class
Inheritance Hierarchy See Also
Collapse All
C#
public class Ocl_Size : OclOperationBase;
Remarks

end Ocl_if

Inheritance Hierarchy
Eco.FrameworkImpl.Ocl.Ocl_Size
File

OclSymbolImplementations.cs

See Also
Inheritance Hierarchy


Ocl_Size Methods

Ocl_Size Methods
Protected Methods Public Methods
Collapse All

The methods of the Ocl_Size class are listed here.

Protected Methods
Name | Description
Init | This is Init, a member of class Ocl_Size.
Top
Public Methods
Name | Description
Evaluate | This is Evaluate, a member of class Ocl_Size.


Ocl_Size.Evaluate Method

Ocl_Size.Evaluate Method
Ocl_Size Class Eco.FrameworkImpl.Ocl Namespace See Also
Collapse All
C#
public override void Evaluate(
    IOclOperationParameters __Params
);
Remarks

This is Evaluate, a member of class Ocl_Size.

See Also
Ocl_Size Class
Eco.FrameworkImpl.Ocl Namespace


Ocl_Size.Init Method

Ocl_Size.Init Method
Ocl_Size Class Eco.FrameworkImpl.Ocl Namespace See Also
Collapse All
C#
protected override void Init();
Remarks

This is Init, a member of class Ocl_Size.

See Also
Ocl_Size Class
Eco.FrameworkImpl.Ocl Namespace


Ocl_SQLLike Class

Ocl_SQLLike Class
Inheritance Hierarchy See Also
Collapse All
C#
public class Ocl_SQLLike : Ocl_SqlLikeCommon;
Remarks

This is class Eco.FrameworkImpl.Ocl.Ocl_SQLLike.

Inheritance Hierarchy
Eco.FrameworkImpl.Ocl.Ocl_SqlLikeCommon
    Eco.FrameworkImpl.Ocl.Ocl_SQLLike
File

OclSymbolImplementations.cs

See Also
Inheritance Hierarchy


Ocl_SQLLike Methods

Ocl_SQLLike Methods
Protected Methods Public Methods
Collapse All

The methods of the Ocl_SQLLike class are listed here.

Protected Methods
Name | Description
Init | This is Init, a member of class Ocl_SQLLike.
Top
Public Methods
Name | Description
Evaluate | This is Evaluate, a member of class Ocl_SQLLike.


Ocl_SQLLike.Evaluate Method

Ocl_SQLLike.Evaluate Method
Ocl_SQLLike Class Eco.FrameworkImpl.Ocl Namespace See Also
Collapse All
C#
public override void Evaluate(
    IOclOperationParameters __Params
);
Remarks

This is Evaluate, a member of class Ocl_SQLLike.

See Also
Ocl_SQLLike Class
Eco.FrameworkImpl.Ocl Namespace


Ocl_SQLLike.Init Method

Ocl_SQLLike.Init Method
Ocl_SQLLike Class Eco.FrameworkImpl.Ocl Namespace See Also
Collapse All
C#
protected override void Init();
Remarks

This is Init, a member of class Ocl_SQLLike.

See Also
Ocl_SQLLike Class
Eco.FrameworkImpl.Ocl Namespace


Ocl_SQLLikeCaseInsensitive Class

Ocl_SQLLikeCaseInsensitive Class
Inheritance Hierarchy See Also
Collapse All
C#
public class Ocl_SQLLikeCaseInsensitive : Ocl_SqlLikeCommon;
Remarks

end Ocl_SQLLike

Inheritance Hierarchy
Eco.FrameworkImpl.Ocl.Ocl_SqlLikeCommon
    Eco.FrameworkImpl.Ocl.Ocl_SQLLikeCaseInsensitive
File

OclSymbolImplementations.cs

See Also
Inheritance Hierarchy


Ocl_SQLLikeCaseInsensitive Methods

Ocl_SQLLikeCaseInsensitive Methods
Protected Methods Public Methods
Collapse All

The methods of the Ocl_SQLLikeCaseInsensitive class are listed here.

Protected Methods
Name | Description
Init | This is Init, a member of class Ocl_SQLLikeCaseInsensitive.
Top
Public Methods
Name | Description
Evaluate | This is Evaluate, a member of class Ocl_SQLLikeCaseInsensitive.


Ocl_SQLLikeCaseInsensitive.Evaluate Method

Ocl_SQLLikeCaseInsensitive.Evaluate Method
Ocl_SQLLikeCaseInsensitive Class Eco.FrameworkImpl.Ocl Namespace See Also
Collapse All
C#
public override void Evaluate(
    IOclOperationParameters __Params
);
Remarks

This is Evaluate, a member of class Ocl_SQLLikeCaseInsensitive.

See Also
Ocl_SQLLikeCaseInsensitive Class
Eco.FrameworkImpl.Ocl Namespace


Ocl_SQLLikeCaseInsensitive.Init Method

Ocl_SQLLikeCaseInsensitive.Init Method
Ocl_SQLLikeCaseInsensitive Class Eco.FrameworkImpl.Ocl Namespace See Also
Collapse All
C#
protected override void Init();
Remarks

This is Init, a member of class Ocl_SQLLikeCaseInsensitive.

See Also
Ocl_SQLLikeCaseInsensitive Class
Eco.FrameworkImpl.Ocl Namespace


Ocl_SqlLikeCommon Class

Ocl_SqlLikeCommon Class
Inheritance Hierarchy See Also
Collapse All
C#
public abstract class Ocl_SqlLikeCommon : OclOperationBase;
Remarks

end Ocl_safeCast

Inheritance Hierarchy
Eco.FrameworkImpl.Ocl.Ocl_SqlLikeCommon
    Eco.FrameworkImpl.Ocl.Ocl_SQLLike
    Eco.FrameworkImpl.Ocl.Ocl_SQLLikeCaseInsensitive
File

OclSymbolImplementations.cs

See Also
Inheritance Hierarchy


Ocl_SqlLikeCommon Methods

Ocl_SqlLikeCommon Methods
Public Methods
Collapse All

The methods of the Ocl_SqlLikeCommon class are listed here.

Public Methods
Name | Description
Match | This is Match, a member of class Ocl_SqlLikeCommon.


Ocl_SqlLikeCommon.Match Method

Ocl_SqlLikeCommon.Match Method
Ocl_SqlLikeCommon Class Eco.FrameworkImpl.Ocl Namespace See Also
Collapse All
C#
public bool Match(
    IOclOperationParameters __Params,
    RegexOptions options
);
Remarks

This is Match, a member of class Ocl_SqlLikeCommon.

See Also
Ocl_SqlLikeCommon Class
Eco.FrameworkImpl.Ocl Namespace


Ocl_StatementSequence Class

Ocl_StatementSequence Class
Inheritance Hierarchy See Also
Collapse All
C#
public class Ocl_StatementSequence : OclOperationBase;
Remarks

end Ocl_Delete

Inheritance Hierarchy
Eco.FrameworkImpl.Ocl.Ocl_StatementSequence
File

OclSymbolImplementations.cs

See Also
Inheritance Hierarchy


Ocl_StatementSequence Methods

Ocl_StatementSequence Methods
Protected Methods Public Methods
Collapse All

The methods of the Ocl_StatementSequence class are listed here.

Protected Methods
Name | Description
Init | This is Init, a member of class Ocl_StatementSequence.
Top
Public Methods
Name | Description
Evaluate | This is Evaluate, a member of class Ocl_StatementSequence.


Ocl_StatementSequence.Evaluate Method

Ocl_StatementSequence.Evaluate Method
Ocl_StatementSequence Class Eco.FrameworkImpl.Ocl Namespace See Also
Collapse All
C#
public override void Evaluate(
    IOclOperationParameters __Params
);
Remarks

This is Evaluate, a member of class Ocl_StatementSequence.

See Also
Ocl_StatementSequence Class
Eco.FrameworkImpl.Ocl Namespace


Ocl_StatementSequence.Init Method

Ocl_StatementSequence.Init Method
Ocl_StatementSequence Class Eco.FrameworkImpl.Ocl Namespace See Also
Collapse All
C#
protected override void Init();
Remarks

This is Init, a member of class Ocl_StatementSequence.

See Also
Ocl_StatementSequence Class
Eco.FrameworkImpl.Ocl Namespace


Ocl_StrToDate Class

Ocl_StrToDate Class
Inheritance Hierarchy See Also
Collapse All
C#
public class Ocl_StrToDate : OclOperationBase;
Remarks

end Ocl_FormatDateTime

Inheritance Hierarchy
Eco.FrameworkImpl.Ocl.Ocl_StrToDate
File

OclSymbolImplementations.cs

See Also
Inheritance Hierarchy


Ocl_StrToDate Methods

Ocl_StrToDate Methods
Protected Methods Public Methods
Collapse All

The methods of the Ocl_StrToDate class are listed here.

Protected Methods
Name | Description
Init | This is Init, a member of class Ocl_StrToDate.
Top
Public Methods
Name | Description
Evaluate | This is Evaluate, a member of class Ocl_StrToDate.


Ocl_StrToDate.Evaluate Method

Ocl_StrToDate.Evaluate Method
Ocl_StrToDate Class Eco.FrameworkImpl.Ocl Namespace See Also
Collapse All
C#
public override void Evaluate(
    IOclOperationParameters __Params
);
Remarks

This is Evaluate, a member of class Ocl_StrToDate.

See Also
Ocl_StrToDate Class
Eco.FrameworkImpl.Ocl Namespace


Ocl_StrToDate.Init Method

Ocl_StrToDate.Init Method
Ocl_StrToDate Class Eco.FrameworkImpl.Ocl Namespace See Also
Collapse All
C#
protected override void Init();
Remarks

This is Init, a member of class Ocl_StrToDate.

See Also
Ocl_StrToDate Class
Eco.FrameworkImpl.Ocl Namespace


Ocl_StrToDateTime Class

Ocl_StrToDateTime Class
Inheritance Hierarchy See Also
Collapse All
C#
public class Ocl_StrToDateTime : OclOperationBase;
Remarks

end Ocl_StrToTime

Inheritance Hierarchy
Eco.FrameworkImpl.Ocl.Ocl_StrToDateTime
File

OclSymbolImplementations.cs

See Also
Inheritance Hierarchy


Ocl_StrToDateTime Methods

Ocl_StrToDateTime Methods
Protected Methods Public Methods
Collapse All

The methods of the Ocl_StrToDateTime class are listed here.

Protected Methods
Name | Description
Init | This is Init, a member of class Ocl_StrToDateTime.
Top
Public Methods
Name | Description
Evaluate | This is Evaluate, a member of class Ocl_StrToDateTime.


Ocl_StrToDateTime.Evaluate Method

Ocl_StrToDateTime.Evaluate Method
Ocl_StrToDateTime Class Eco.FrameworkImpl.Ocl Namespace See Also
Collapse All
C#
public override void Evaluate(
    IOclOperationParameters __Params
);
Remarks

This is Evaluate, a member of class Ocl_StrToDateTime.

See Also
Ocl_StrToDateTime Class
Eco.FrameworkImpl.Ocl Namespace


Ocl_StrToDateTime.Init Method

Ocl_StrToDateTime.Init Method
Ocl_StrToDateTime Class Eco.FrameworkImpl.Ocl Namespace See Also
Collapse All
C#
protected override void Init();
Remarks

This is Init, a member of class Ocl_StrToDateTime.

See Also
Ocl_StrToDateTime Class
Eco.FrameworkImpl.Ocl Namespace


Ocl_strToInt Class

Ocl_strToInt Class
Inheritance Hierarchy See Also
Collapse All
C#
public class Ocl_strToInt : OclOperationBase;
Remarks

end Ocl_NotEqual

Inheritance Hierarchy
Eco.FrameworkImpl.Ocl.Ocl_strToInt
File

OclSymbolImplementations.cs

See Also
Inheritance Hierarchy


Ocl_strToInt Methods

Ocl_strToInt Methods
Protected Methods Public Methods
Collapse All

The methods of the Ocl_strToInt class are listed here.

Protected Methods
Name | Description
Init | This is Init, a member of class Ocl_strToInt.
Top
Public Methods
Name | Description
Evaluate | Real operations


Ocl_strToInt.Evaluate Method

Ocl_strToInt.Evaluate Method
Ocl_strToInt Class Eco.FrameworkImpl.Ocl Namespace See Also
Collapse All
C#
public override void Evaluate(
    IOclOperationParameters __Params
);
Remarks

Real operations

See Also
Ocl_strToInt Class
Eco.FrameworkImpl.Ocl Namespace


Ocl_strToInt.Init Method

Ocl_strToInt.Init Method
Ocl_strToInt Class Eco.FrameworkImpl.Ocl Namespace See Also
Collapse All
C#
protected override void Init();
Remarks

This is Init, a member of class Ocl_strToInt.

See Also
Ocl_strToInt Class
Eco.FrameworkImpl.Ocl Namespace


Ocl_StrToTime Class

Ocl_StrToTime Class
Inheritance Hierarchy See Also
Collapse All
C#
public class Ocl_StrToTime : OclOperationBase;
Remarks

end Ocl_StrToDate

Inheritance Hierarchy
Eco.FrameworkImpl.Ocl.Ocl_StrToTime
File

OclSymbolImplementations.cs

See Also
Inheritance Hierarchy


Ocl_StrToTime Methods

Ocl_StrToTime Methods
Protected Methods Public Methods
Collapse All

The methods of the Ocl_StrToTime class are listed here.

Protected Methods
Name | Description
Init | This is Init, a member of class Ocl_StrToTime.
Top
Public Methods
Name | Description
Evaluate | This is Evaluate, a member of class Ocl_StrToTime.


Ocl_StrToTime.Evaluate Method

Ocl_StrToTime.Evaluate Method
Ocl_StrToTime Class Eco.FrameworkImpl.Ocl Namespace See Also
Collapse All
C#
public override void Evaluate(
    IOclOperationParameters __Params
);
Remarks

This is Evaluate, a member of class Ocl_StrToTime.

See Also
Ocl_StrToTime Class
Eco.FrameworkImpl.Ocl Namespace


Ocl_StrToTime.Init Method

Ocl_StrToTime.Init Method
Ocl_StrToTime Class Eco.FrameworkImpl.Ocl Namespace See Also
Collapse All
C#
protected override void Init();
Remarks

This is Init, a member of class Ocl_StrToTime.

See Also
Ocl_StrToTime Class
Eco.FrameworkImpl.Ocl Namespace


Ocl_SubSequence Class

Ocl_SubSequence Class
Inheritance Hierarchy See Also
Collapse All
C#
public class Ocl_SubSequence : OclOperationBase;
Remarks

end Ocl_Prepend

Inheritance Hierarchy
Eco.FrameworkImpl.Ocl.Ocl_SubSequence
File

OclSymbolImplementations.cs

See Also
Inheritance Hierarchy


Ocl_SubSequence Methods

Ocl_SubSequence Methods
Protected Methods Public Methods
Collapse All

The methods of the Ocl_SubSequence class are listed here.

Protected Methods
Name | Description
Init | This is Init, a member of class Ocl_SubSequence.
Top
Public Methods
Name | Description
Evaluate | This is Evaluate, a member of class Ocl_SubSequence.


Ocl_SubSequence.Evaluate Method

Ocl_SubSequence.Evaluate Method
Ocl_SubSequence Class Eco.FrameworkImpl.Ocl Namespace See Also
Collapse All
C#
public override void Evaluate(
    IOclOperationParameters __Params
);
Remarks

This is Evaluate, a member of class Ocl_SubSequence.

See Also
Ocl_SubSequence Class
Eco.FrameworkImpl.Ocl Namespace


Ocl_SubSequence.Init Method

Ocl_SubSequence.Init Method
Ocl_SubSequence Class Eco.FrameworkImpl.Ocl Namespace See Also
Collapse All
C#
protected override void Init();
Remarks

This is Init, a member of class Ocl_SubSequence.

See Also
Ocl_SubSequence Class
Eco.FrameworkImpl.Ocl Namespace


Ocl_SubString Class

Ocl_SubString Class
Inheritance Hierarchy See Also
Collapse All
C#
public class Ocl_SubString : OclOperationBase;
Remarks

end Ocl_toLower

Inheritance Hierarchy
Eco.FrameworkImpl.Ocl.Ocl_SubString
File

OclSymbolImplementations.cs

See Also
Inheritance Hierarchy


Ocl_SubString Methods

Ocl_SubString Methods
Protected Methods Public Methods
Collapse All

The methods of the Ocl_SubString class are listed here.

Protected Methods
Name | Description
Init | This is Init, a member of class Ocl_SubString.
Top
Public Methods
Name | Description
Evaluate | This is Evaluate, a member of class Ocl_SubString.


Ocl_SubString.Evaluate Method

Ocl_SubString.Evaluate Method
Ocl_SubString Class Eco.FrameworkImpl.Ocl Namespace See Also
Collapse All
C#
public override void Evaluate(
    IOclOperationParameters __Params
);
Remarks

This is Evaluate, a member of class Ocl_SubString.

See Also
Ocl_SubString Class
Eco.FrameworkImpl.Ocl Namespace


Ocl_SubString.Init Method

Ocl_SubString.Init Method
Ocl_SubString Class Eco.FrameworkImpl.Ocl Namespace See Also
Collapse All
C#
protected override void Init();
Remarks

This is Init, a member of class Ocl_SubString.

See Also
Ocl_SubString Class
Eco.FrameworkImpl.Ocl Namespace


Ocl_SuperTypes Class

Ocl_SuperTypes Class
Inheritance Hierarchy See Also
Collapse All
C#
public class Ocl_SuperTypes : OclOperationBase;
Remarks

Ocl_Operations = class(OclOperationBase) strict protected procedure Init; override; public procedure Evaluate(Params: IOclOperationParameters); override; end;

Inheritance Hierarchy
Eco.FrameworkImpl.Ocl.Ocl_SuperTypes
File

OclSymbolImplementations.cs

See Also
Inheritance Hierarchy


Ocl_SuperTypes Methods

Ocl_SuperTypes Methods
Protected Methods Public Methods
Collapse All

The methods of the Ocl_SuperTypes class are listed here.

Protected Methods
Name | Description
Init | procedure Ocl_Operations.Init; begin InternalInit('operations', [Support.TypeType], Support.StringListType); // do not localize end;
Top
Public Methods
Name | Description
Evaluate | This is Evaluate, a member of class Ocl_SuperTypes.


Ocl_SuperTypes.Evaluate Method

Ocl_SuperTypes.Evaluate Method
Ocl_SuperTypes Class Eco.FrameworkImpl.Ocl Namespace See Also
Collapse All
C#
public override void Evaluate(
    IOclOperationParameters __Params
);
Remarks

This is Evaluate, a member of class Ocl_SuperTypes.

See Also
Ocl_SuperTypes Class
Eco.FrameworkImpl.Ocl Namespace


Ocl_SuperTypes.Init Method

Ocl_SuperTypes.Init Method
Ocl_SuperTypes Class Eco.FrameworkImpl.Ocl Namespace See Also
Collapse All
C#
protected override void Init();
Remarks

procedure Ocl_Operations.Init; begin InternalInit('operations', [Support.TypeType], Support.StringListType); // do not localize end;

See Also
Ocl_SuperTypes Class
Eco.FrameworkImpl.Ocl Namespace


Ocl_SymmetricDifference Class

Ocl_SymmetricDifference Class
Inheritance Hierarchy See Also
Collapse All
C#
public class Ocl_SymmetricDifference : OclOperationBase;
Remarks

end Ocl_excluding

Inheritance Hierarchy
Eco.FrameworkImpl.Ocl.Ocl_SymmetricDifference
File

OclSymbolImplementations.cs

See Also
Inheritance Hierarchy


Ocl_SymmetricDifference Methods

Ocl_SymmetricDifference Methods
Protected Methods Public Methods
Collapse All

The methods of the Ocl_SymmetricDifference class are listed here.

Protected Methods
Name | Description
Init | This is Init, a member of class Ocl_SymmetricDifference.
Top
Public Methods
Name | Description
Evaluate | This is Evaluate, a member of class Ocl_SymmetricDifference.


Ocl_SymmetricDifference.Evaluate Method

Ocl_SymmetricDifference.Evaluate Method
Ocl_SymmetricDifference Class Eco.FrameworkImpl.Ocl Namespace See Also
Collapse All
C#
public override void Evaluate(
    IOclOperationParameters __Params
);
Remarks

This is Evaluate, a member of class Ocl_SymmetricDifference.

See Also
Ocl_SymmetricDifference Class
Eco.FrameworkImpl.Ocl Namespace


Ocl_SymmetricDifference.Init Method

Ocl_SymmetricDifference.Init Method
Ocl_SymmetricDifference Class Eco.FrameworkImpl.Ocl Namespace See Also
Collapse All
C#
protected override void Init();
Remarks

This is Init, a member of class Ocl_SymmetricDifference.

See Also
Ocl_SymmetricDifference Class
Eco.FrameworkImpl.Ocl Namespace


Ocl_TaggedValue Class

Ocl_TaggedValue Class
Inheritance Hierarchy See Also
Collapse All
C#
public class Ocl_TaggedValue : OclOperationBase;
Remarks

end Ocl_asString

Inheritance Hierarchy
Eco.FrameworkImpl.Ocl.Ocl_TaggedValue
File

OclSymbolImplementations.cs

See Also
Inheritance Hierarchy


Ocl_TaggedValue Methods

Ocl_TaggedValue Methods
Protected Methods Public Methods
Collapse All

The methods of the Ocl_TaggedValue class are listed here.

Protected Methods
Name | Description
Init | This is Init, a member of class Ocl_TaggedValue.
Top
Public Methods
Name | Description
Evaluate | This is Evaluate, a member of class Ocl_TaggedValue.


Ocl_TaggedValue.Evaluate Method

Ocl_TaggedValue.Evaluate Method
Ocl_TaggedValue Class Eco.FrameworkImpl.Ocl Namespace See Also
Collapse All
C#
public override void Evaluate(
    IOclOperationParameters __Params
);
Remarks

This is Evaluate, a member of class Ocl_TaggedValue.

See Also
Ocl_TaggedValue Class
Eco.FrameworkImpl.Ocl Namespace


Ocl_TaggedValue.Init Method

Ocl_TaggedValue.Init Method
Ocl_TaggedValue Class Eco.FrameworkImpl.Ocl Namespace See Also
Collapse All
C#
protected override void Init();
Remarks

This is Init, a member of class Ocl_TaggedValue.

See Also
Ocl_TaggedValue Class
Eco.FrameworkImpl.Ocl Namespace


Ocl_TimeStampToTime Class

Ocl_TimeStampToTime Class
Inheritance Hierarchy See Also
Collapse All
C#
public class Ocl_TimeStampToTime : OclOperationBase;
Remarks

end Ocl_FilterOnType

Inheritance Hierarchy
Eco.FrameworkImpl.Ocl.Ocl_TimeStampToTime
File

OclSymbolImplementations.cs

See Also
Inheritance Hierarchy


Ocl_TimeStampToTime Methods

Ocl_TimeStampToTime Methods
Protected Methods Public Methods
Collapse All

The methods of the Ocl_TimeStampToTime class are listed here.

Protected Methods
Name | Description
Init | This is Init, a member of class Ocl_TimeStampToTime.
Top
Public Methods
Name | Description
Evaluate | This is Evaluate, a member of class Ocl_TimeStampToTime.


Ocl_TimeStampToTime.Evaluate Method

Ocl_TimeStampToTime.Evaluate Method
Ocl_TimeStampToTime Class Eco.FrameworkImpl.Ocl Namespace See Also
Collapse All
C#
public override void Evaluate(
    IOclOperationParameters __Params
);
Remarks

This is Evaluate, a member of class Ocl_TimeStampToTime.

See Also
Ocl_TimeStampToTime Class
Eco.FrameworkImpl.Ocl Namespace


Ocl_TimeStampToTime.Init Method

Ocl_TimeStampToTime.Init Method
Ocl_TimeStampToTime Class Eco.FrameworkImpl.Ocl Namespace See Also
Collapse All
C#
protected override void Init();
Remarks

This is Init, a member of class Ocl_TimeStampToTime.

See Also
Ocl_TimeStampToTime Class
Eco.FrameworkImpl.Ocl Namespace


Ocl_TimeToTimeStamp Class

Ocl_TimeToTimeStamp Class
Inheritance Hierarchy See Also
Collapse All
C#
public class Ocl_TimeToTimeStamp : OclOperationBase;
Remarks

end Ocl_TimeStampToTime

Inheritance Hierarchy
Eco.FrameworkImpl.Ocl.Ocl_TimeToTimeStamp
File

OclSymbolImplementations.cs

See Also
Inheritance Hierarchy


Ocl_TimeToTimeStamp Methods

Ocl_TimeToTimeStamp Methods
Protected Methods Public Methods
Collapse All

The methods of the Ocl_TimeToTimeStamp class are listed here.

Protected Methods
Name | Description
Init | This is Init, a member of class Ocl_TimeToTimeStamp.
Top
Public Methods
Name | Description
Evaluate | This is Evaluate, a member of class Ocl_TimeToTimeStamp.


Ocl_TimeToTimeStamp.Evaluate Method

Ocl_TimeToTimeStamp.Evaluate Method
Ocl_TimeToTimeStamp Class Eco.FrameworkImpl.Ocl Namespace See Also
Collapse All
C#
public override void Evaluate(
    IOclOperationParameters __Params
);
Remarks

This is Evaluate, a member of class Ocl_TimeToTimeStamp.

See Also
Ocl_TimeToTimeStamp Class
Eco.FrameworkImpl.Ocl Namespace


Ocl_TimeToTimeStamp.Init Method

Ocl_TimeToTimeStamp.Init Method
Ocl_TimeToTimeStamp Class Eco.FrameworkImpl.Ocl Namespace See Also
Collapse All
C#
protected override void Init();
Remarks

This is Init, a member of class Ocl_TimeToTimeStamp.

See Also
Ocl_TimeToTimeStamp Class
Eco.FrameworkImpl.Ocl Namespace


Ocl_toLower Class

Ocl_toLower Class
Inheritance Hierarchy See Also
Collapse All
C#
public class Ocl_toLower : OclPsOperationBase;
Remarks

end Ocl_ToUpper

Inheritance Hierarchy
Eco.FrameworkImpl.Ocl.OclPsOperationBase
    Eco.FrameworkImpl.Ocl.Ocl_toLower
File

OclSymbolImplementations.cs

See Also
Inheritance Hierarchy


Ocl_toLower Methods

Ocl_toLower Methods
Protected Methods
Collapse All

The methods of the Ocl_toLower class are listed here.

Protected Methods
Name | Description
Init | This is Init, a member of class Ocl_toLower.


Ocl_toLower.Init Method

Ocl_toLower.Init Method
Ocl_toLower Class Eco.FrameworkImpl.Ocl Namespace See Also
Collapse All
C#
protected override void Init();
Remarks

This is Init, a member of class Ocl_toLower.

See Also
Ocl_toLower Class
Eco.FrameworkImpl.Ocl Namespace


Ocl_ToUpper Class

Ocl_ToUpper Class
Inheritance Hierarchy See Also
Collapse All
C#
public class Ocl_ToUpper : OclPsOperationBase;
Remarks

end Ocl_Length

Inheritance Hierarchy
Eco.FrameworkImpl.Ocl.OclPsOperationBase
    Eco.FrameworkImpl.Ocl.Ocl_ToUpper
File

OclSymbolImplementations.cs

See Also
Inheritance Hierarchy


Ocl_ToUpper Methods

Ocl_ToUpper Methods
Protected Methods
Collapse All

The methods of the Ocl_ToUpper class are listed here.

Protected Methods
Name | Description
Init | This is Init, a member of class Ocl_ToUpper.


Ocl_ToUpper.Init Method

Ocl_ToUpper.Init Method
Ocl_ToUpper Class Eco.FrameworkImpl.Ocl Namespace See Also
Collapse All
C#
protected override void Init();
Remarks

This is Init, a member of class Ocl_ToUpper.

See Also
Ocl_ToUpper Class
Eco.FrameworkImpl.Ocl Namespace


Ocl_TupleOperation Class

Ocl_TupleOperation Class
Inheritance Hierarchy See Also
Collapse All
C#
public abstract class Ocl_TupleOperation : OclOperationBase;
Remarks

end Ocl_reject

Inheritance Hierarchy
Eco.FrameworkImpl.Ocl.Ocl_TupleOperation
    Eco.FrameworkImpl.Ocl.Ocl_collect
    Eco.FrameworkImpl.Ocl.Ocl_GroupBy
File

OclSymbolImplementations.cs

See Also
Inheritance Hierarchy


Ocl_TupleOperation Methods

Ocl_TupleOperation Methods
Public Methods
Collapse All

The methods of the Ocl_TupleOperation class are listed here.

Public Methods
Name | Description
GenerateTuplePart | This is GenerateTuplePart, a member of class Ocl_TupleOperation.
GetUniqueName | This is GetUniqueName, a member of class Ocl_TupleOperation.


Ocl_TupleOperation.GenerateTuplePart Method

Ocl_TupleOperation.GenerateTuplePart Method
Ocl_TupleOperation Class Eco.FrameworkImpl.Ocl Namespace See Also
Collapse All
C#
public ClassifierNamePair GenerateTuplePart(
    IOclValue value,
    int index,
    StringDictionary names
);
Remarks

This is GenerateTuplePart, a member of class Ocl_TupleOperation.

See Also
Ocl_TupleOperation Class
Eco.FrameworkImpl.Ocl Namespace


Ocl_TupleOperation.GetUniqueName Method

Ocl_TupleOperation.GetUniqueName Method
Ocl_TupleOperation Class Eco.FrameworkImpl.Ocl Namespace See Also
Collapse All
C#
public string GetUniqueName(
    string baseName,
    StringDictionary names
);
Remarks

This is GetUniqueName, a member of class Ocl_TupleOperation.

See Also
Ocl_TupleOperation Class
Eco.FrameworkImpl.Ocl Namespace


Ocl_TypeName Class

Ocl_TypeName Class
Inheritance Hierarchy See Also
Collapse All
C#
public class Ocl_TypeName : OclOperationBase;
Remarks

end Ocl_ObjectFromExternalId

Inheritance Hierarchy
Eco.FrameworkImpl.Ocl.Ocl_TypeName
File

OclSymbolImplementations.cs

See Also
Inheritance Hierarchy


Ocl_TypeName Methods

Ocl_TypeName Methods
Protected Methods Public Methods
Collapse All

The methods of the Ocl_TypeName class are listed here.

Protected Methods
Name | Description
Init | This is Init, a member of class Ocl_TypeName.
Top
Public Methods
Name | Description
Evaluate | This is Evaluate, a member of class Ocl_TypeName.


Ocl_TypeName.Evaluate Method

Ocl_TypeName.Evaluate Method
Ocl_TypeName Class Eco.FrameworkImpl.Ocl Namespace See Also
Collapse All
C#
public override void Evaluate(
    IOclOperationParameters __Params
);
Remarks

This is Evaluate, a member of class Ocl_TypeName.

See Also
Ocl_TypeName Class
Eco.FrameworkImpl.Ocl Namespace


Ocl_TypeName.Init Method

Ocl_TypeName.Init Method
Ocl_TypeName Class Eco.FrameworkImpl.Ocl Namespace See Also
Collapse All
C#
protected override void Init();
Remarks

This is Init, a member of class Ocl_TypeName.

See Also
Ocl_TypeName Class
Eco.FrameworkImpl.Ocl Namespace


Ocl_union Class

Ocl_union Class
Inheritance Hierarchy See Also
Collapse All
C#
public class Ocl_union : OclOperationBase;
Remarks

end Ocl_ForAll

Inheritance Hierarchy
Eco.FrameworkImpl.Ocl.Ocl_union
File

OclSymbolImplementations.cs

See Also
Inheritance Hierarchy


Ocl_union Methods

Ocl_union Methods
Protected Methods Public Methods
Collapse All

The methods of the Ocl_union class are listed here.

Protected Methods
Name | Description
Init | This is Init, a member of class Ocl_union.
Top
Public Methods
Name | Description
Evaluate | This is Evaluate, a member of class Ocl_union.
Evaluate_AddList | This is Evaluate_AddList, a member of class Ocl_union.


Ocl_union.Evaluate Method

Ocl_union.Evaluate Method
Ocl_union Class Eco.FrameworkImpl.Ocl Namespace See Also
Collapse All
C#
public override void Evaluate(
    IOclOperationParameters __Params
);
Remarks

This is Evaluate, a member of class Ocl_union.

See Also
Ocl_union Class
Eco.FrameworkImpl.Ocl Namespace


Ocl_union.Evaluate_AddList Method

Ocl_union.Evaluate_AddList Method
Ocl_union Class Eco.FrameworkImpl.Ocl Namespace See Also
Collapse All
C#
public void Evaluate_AddList(
    IElementCollection Target,
    IElementCollection Source
);
Remarks

This is Evaluate_AddList, a member of class Ocl_union.

See Also
Ocl_union Class
Eco.FrameworkImpl.Ocl Namespace


Ocl_union.Init Method

Ocl_union.Init Method
Ocl_union Class Eco.FrameworkImpl.Ocl Namespace See Also
Collapse All
C#
protected override void Init();
Remarks

This is Init, a member of class Ocl_union.

See Also
Ocl_union Class
Eco.FrameworkImpl.Ocl Namespace


Ocl_xor Class

Ocl_xor Class
Inheritance Hierarchy See Also
Collapse All
C#
public class Ocl_xor : OclOperationBase;
Remarks

end Ocl_not

Inheritance Hierarchy
Eco.FrameworkImpl.Ocl.Ocl_xor
File

OclSymbolImplementations.cs

See Also
Inheritance Hierarchy


Ocl_xor Methods

Ocl_xor Methods
Protected Methods Public Methods
Collapse All

The methods of the Ocl_xor class are listed here.

Protected Methods
Name | Description
Init | This is Init, a member of class Ocl_xor.
Top
Public Methods
Name | Description
Evaluate | This is Evaluate, a member of class Ocl_xor.


Ocl_xor.Evaluate Method

Ocl_xor.Evaluate Method
Ocl_xor Class Eco.FrameworkImpl.Ocl Namespace See Also
Collapse All
C#
public override void Evaluate(
    IOclOperationParameters __Params
);
Remarks

This is Evaluate, a member of class Ocl_xor.

See Also
Ocl_xor Class
Eco.FrameworkImpl.Ocl Namespace


Ocl_xor.Init Method

Ocl_xor.Init Method
Ocl_xor Class Eco.FrameworkImpl.Ocl Namespace See Also
Collapse All
C#
protected override void Init();
Remarks

This is Init, a member of class Ocl_xor.

See Also
Ocl_xor Class
Eco.FrameworkImpl.Ocl Namespace


OclPsOperationBase Class

OclPsOperationBase Class
Inheritance Hierarchy See Also
Collapse All
C#
public abstract class OclPsOperationBase : OclOperationBase;
Remarks

end Ocl_concat

Inheritance Hierarchy
Eco.FrameworkImpl.Ocl.OclPsOperationBase
    Eco.FrameworkImpl.Ocl.Ocl_Length
    Eco.FrameworkImpl.Ocl.Ocl_toLower
    Eco.FrameworkImpl.Ocl.Ocl_ToUpper
File

OclSymbolImplementations.cs

See Also
Inheritance Hierarchy


OclPsOperationBase Methods

OclPsOperationBase Methods
Public Methods
Collapse All

The methods of the OclPsOperationBase class are listed here.

Public Methods
Name | Description
Evaluate | This is Evaluate, a member of class OclPsOperationBase.


OclPsOperationBase.Evaluate Method

OclPsOperationBase.Evaluate Method
OclPsOperationBase Class Eco.FrameworkImpl.Ocl Namespace See Also
Collapse All
C#
public override void Evaluate(
    IOclOperationParameters __Params
);
Remarks

This is Evaluate, a member of class OclPsOperationBase.

See Also
OclPsOperationBase Class
Eco.FrameworkImpl.Ocl Namespace


SymbolImplementationUtils Class

SymbolImplementationUtils Class
Inheritance Hierarchy See Also
Collapse All
C#
public class SymbolImplementationUtils;
Remarks

end Ocl_oclGetTriggers

Inheritance Hierarchy
Eco.FrameworkImpl.Ocl.SymbolImplementationUtils
File

OclSymbolImplementations.cs

See Also
Inheritance Hierarchy


SymbolImplementationUtils Methods

SymbolImplementationUtils Methods
Public Methods
Collapse All

The methods of the SymbolImplementationUtils class are listed here.

Public Methods
Name | Description
CompareNodes | This is CompareNodes, a member of class SymbolImplementationUtils.
FixSQLRegExp | This is FixSQLRegExp, a member of class SymbolImplementationUtils.


SymbolImplementationUtils.CompareNodes Method

SymbolImplementationUtils.CompareNodes Method
SymbolImplementationUtils Class Eco.FrameworkImpl.Ocl Namespace See Also
Collapse All
C#
public static int CompareNodes(
    IOclOperationParameters __Params,
    IOclOperationSupport Support
);
Remarks

This is CompareNodes, a member of class SymbolImplementationUtils.

See Also
SymbolImplementationUtils Class
Eco.FrameworkImpl.Ocl Namespace


SymbolImplementationUtils.FixSQLRegExp Method

SymbolImplementationUtils.FixSQLRegExp Method
SymbolImplementationUtils Class Eco.FrameworkImpl.Ocl Namespace See Also
Collapse All
C#
public static string FixSQLRegExp(
    string S
);
Remarks

This is FixSQLRegExp, a member of class SymbolImplementationUtils.

See Also
SymbolImplementationUtils Class
Eco.FrameworkImpl.Ocl Namespace


TBoldDefaultActionLanguageSymbolFactory Class

TBoldDefaultActionLanguageSymbolFactory Class
Inheritance Hierarchy See Also
Collapse All
C#
public class TBoldDefaultActionLanguageSymbolFactory : Object;
Remarks

end TBoldDefaultOclPsSymbolFactory

Inheritance Hierarchy
Eco.FrameworkImpl.Ocl.TBoldDefaultActionLanguageSymbolFactory
File

OclSymbolImplementations.cs

See Also
Inheritance Hierarchy


TBoldDefaultActionLanguageSymbolFactory Methods

TBoldDefaultActionLanguageSymbolFactory Methods
Public Methods
Collapse All

The methods of the TBoldDefaultActionLanguageSymbolFactory class are listed here.

Public Methods
Name | Description
InstallSymbols | This is InstallSymbols, a member of class TBoldDefaultActionLanguageSymbolFactory.


TBoldDefaultActionLanguageSymbolFactory.InstallSymbols Method

TBoldDefaultActionLanguageSymbolFactory.InstallSymbols Method
TBoldDefaultActionLanguageSymbolFactory Class Eco.FrameworkImpl.Ocl Namespace See Also
Collapse All
C#
public static void InstallSymbols(
    ITypeService typeService,
    IEcoTypeSystem typeSystem,
    OclTypeMethodInstaller MethodInstaller
);
Remarks

This is InstallSymbols, a member of class TBoldDefaultActionLanguageSymbolFactory.

See Also
TBoldDefaultActionLanguageSymbolFactory Class
Eco.FrameworkImpl.Ocl Namespace


TBoldDefaultOclPsSymbolFactory Class

TBoldDefaultOclPsSymbolFactory Class
Inheritance Hierarchy See Also
Collapse All
C#
public class TBoldDefaultOclPsSymbolFactory : Object;
Remarks

This is class Eco.FrameworkImpl.Ocl.TBoldDefaultOclPsSymbolFactory.

Inheritance Hierarchy
Eco.FrameworkImpl.Ocl.TBoldDefaultOclPsSymbolFactory
File

OclSymbolImplementations.cs

See Also
Inheritance Hierarchy


TBoldDefaultOclPsSymbolFactory Methods

TBoldDefaultOclPsSymbolFactory Methods
Public Methods
Collapse All

The methods of the TBoldDefaultOclPsSymbolFactory class are listed here.

Public Methods
Name | Description
InstallSymbols | This is InstallSymbols, a member of class TBoldDefaultOclPsSymbolFactory.


TBoldDefaultOclPsSymbolFactory.InstallSymbols Method

TBoldDefaultOclPsSymbolFactory.InstallSymbols Method
TBoldDefaultOclPsSymbolFactory Class Eco.FrameworkImpl.Ocl Namespace See Also
Collapse All
C#
public static void InstallSymbols(
    ITypeService typeService,
    IEcoTypeSystem typeSystem,
    OclTypeMethodInstaller MethodInstaller
);
Remarks

This is InstallSymbols, a member of class TBoldDefaultOclPsSymbolFactory.

See Also
TBoldDefaultOclPsSymbolFactory Class
Eco.FrameworkImpl.Ocl Namespace


TBoldDefaultOclSymbolFactory Class

TBoldDefaultOclSymbolFactory Class
Inheritance Hierarchy See Also
Collapse All
C#
public class TBoldDefaultOclSymbolFactory : Object;
Remarks

TBoldOclSymbolFactory

Inheritance Hierarchy
Eco.FrameworkImpl.Ocl.TBoldDefaultOclSymbolFactory
File

OclSymbolImplementations.cs

See Also
Inheritance Hierarchy


TBoldDefaultOclSymbolFactory Methods

TBoldDefaultOclSymbolFactory Methods
Public Methods
Collapse All

The methods of the TBoldDefaultOclSymbolFactory class are listed here.

Public Methods
Name | Description
InstallSymbols | TBoldDefaultOclSymbolFactory


TBoldDefaultOclSymbolFactory.InstallSymbols Method

TBoldDefaultOclSymbolFactory.InstallSymbols Method
TBoldDefaultOclSymbolFactory Class Eco.FrameworkImpl.Ocl Namespace See Also
Collapse All
C#
public static void InstallSymbols(
    ITypeService typeService,
    IEcoTypeSystem typeSystem,
    OclTypeMethodInstaller MethodInstaller
);
Remarks

TBoldDefaultOclSymbolFactory

See Also
TBoldDefaultOclSymbolFactory Class
Eco.FrameworkImpl.Ocl Namespace


Eco.FrameworkImpl.OptimisticLocking Namespace

Eco.FrameworkImpl.OptimisticLocking Namespace
Classes
Collapse All

This is namespace Eco.FrameworkImpl.OptimisticLocking.

Classes
Name | Description
OptimisticLockHandler | FIXME needs cleanup after autoconversion


OptimisticLockHandler Class

OptimisticLockHandler Class
Inheritance Hierarchy See Also
Collapse All
C#
public class OptimisticLockHandler : EcoSpacePartWithTypeSystem, IOptimisticLockHandler;
Remarks

FIXME needs cleanup after autoconversion

Inheritance Hierarchy
Eco.FrameworkImpl.OptimisticLocking.OptimisticLockHandler
File

OptimisticLockHandler.cs

See Also
Inheritance Hierarchy


OptimisticLockHandler.OptimisticLockHandler Constructor

OptimisticLockHandler.OptimisticLockHandler Constructor
OptimisticLockHandler Class Eco.FrameworkImpl.OptimisticLocking Namespace See Also
Collapse All
C#
public OptimisticLockHandler(
    IEcoTypeSystem typeSystem
);
Remarks

This is OptimisticLockHandler, a member of class OptimisticLockHandler.

See Also
OptimisticLockHandler Class
Eco.FrameworkImpl.OptimisticLocking Namespace


OptimisticLockHandler Methods

OptimisticLockHandler Methods
Protected Methods Public Methods
Collapse All

The methods of the OptimisticLockHandler class are listed here.

Protected Methods
Name | Description
DoActivate | This is DoActivate, a member of class OptimisticLockHandler.
Top
Public Methods
Name | Description
CreatePrecondition | This is CreatePrecondition, a member of class OptimisticLockHandler.
EnsureEnclosure | Currently not called anywhere, but don't remove since it should be exposed as part of a future IRegionService


OptimisticLockHandler.CreatePrecondition Method

OptimisticLockHandler.CreatePrecondition Method
OptimisticLockHandler Class Eco.FrameworkImpl.OptimisticLocking Namespace See Also
Collapse All
C#
public OptimisticLockingPrecondition CreatePrecondition(
    IEnumerable<Locator> locators
);
Remarks

This is CreatePrecondition, a member of class OptimisticLockHandler.

See Also
OptimisticLockHandler Class
Eco.FrameworkImpl.OptimisticLocking Namespace


OptimisticLockHandler.DoActivate Method

OptimisticLockHandler.DoActivate Method
OptimisticLockHandler Class Eco.FrameworkImpl.OptimisticLocking Namespace See Also
Collapse All
C#
protected override void DoActivate();
Remarks

This is DoActivate, a member of class OptimisticLockHandler.

See Also
OptimisticLockHandler Class
Eco.FrameworkImpl.OptimisticLocking Namespace


OptimisticLockHandler.EnsureEnclosure Method

OptimisticLockHandler.EnsureEnclosure Method
OptimisticLockHandler Class Eco.FrameworkImpl.OptimisticLocking Namespace See Also
Collapse All
C#
public void EnsureEnclosure(
    Locator aLocator,
    IObjectList Enclosure,
    bool ValidateOnly,
    ref bool ListIsEnclosure
);
Remarks

Currently not called anywhere, but don't remove since it should be exposed as part of a future IRegionService

See Also
OptimisticLockHandler Class
Eco.FrameworkImpl.OptimisticLocking Namespace


OptimisticLockHandler Properties

OptimisticLockHandler Properties
Public Properties
Collapse All

The properties of the OptimisticLockHandler class are listed here.

Public Properties
Name | Description
Cache | This is Cache, a member of class OptimisticLockHandler.
ObjectRepresentationProvider | This is ObjectRepresentationProvider, a member of class OptimisticLockHandler.
PersistenceHandler | This is PersistenceHandler, a member of class OptimisticLockHandler.
RegionFactory | This is RegionFactory, a member of class OptimisticLockHandler.


OptimisticLockHandler.Cache Property

OptimisticLockHandler.Cache Property
OptimisticLockHandler Class Eco.FrameworkImpl.OptimisticLocking Namespace See Also
Collapse All
C#
public ICache Cache;
Remarks

This is Cache, a member of class OptimisticLockHandler.

See Also
OptimisticLockHandler Class
Eco.FrameworkImpl.OptimisticLocking Namespace


OptimisticLockHandler.ObjectRepresentationProvider Property

OptimisticLockHandler.ObjectRepresentationProvider Property
OptimisticLockHandler Class Eco.FrameworkImpl.OptimisticLocking Namespace See Also
Collapse All
C#
public IObjectRepresentationProvider ObjectRepresentationProvider;
Remarks

This is ObjectRepresentationProvider, a member of class OptimisticLockHandler.

See Also
OptimisticLockHandler Class
Eco.FrameworkImpl.OptimisticLocking Namespace


OptimisticLockHandler.PersistenceHandler Property

OptimisticLockHandler.PersistenceHandler Property
OptimisticLockHandler Class Eco.FrameworkImpl.OptimisticLocking Namespace See Also
Collapse All
C#
public IPersistenceHandler PersistenceHandler;
Remarks

This is PersistenceHandler, a member of class OptimisticLockHandler.

See Also
OptimisticLockHandler Class
Eco.FrameworkImpl.OptimisticLocking Namespace


OptimisticLockHandler.RegionFactory Property

OptimisticLockHandler.RegionFactory Property
OptimisticLockHandler Class Eco.FrameworkImpl.OptimisticLocking Namespace See Also
Collapse All
C#
public IRegionFactory RegionFactory;
Remarks

This is RegionFactory, a member of class OptimisticLockHandler.

See Also
OptimisticLockHandler Class
Eco.FrameworkImpl.OptimisticLocking Namespace


Eco.Handles Namespace

Eco.Handles Namespace
Classes Enumerations Interfaces Types
Collapse All

IStaticContext

Classes
Name | Description
AbstractColumn | Abstract superclass for "Columns", i.e. additional properties on the Objects in the bindinglist of an ElementHandle
AbstractColumnConverter | Type converter for AbstractColumn. Mainly for the internal use of the WinForm designer.
AbstractCursorHandle | This abstract ECO handle holds a reference to an ECO element and also an index "position" pointing to a specific item if the element is a collection.
AbstractRenderedTuple | This class is part of the internal implementation of the databindable Ilist implemented by the Eco handles. It should not be used directly.
AbstractRenderedTupleProperty | This is class Eco.Handles.AbstractRenderedTupleProperty.
Column | This class is for backwards comatibility only
ColumnCollection | Represents a collection of columns.
ColumnConstants | This is class Eco.Handles.ColumnConstants.
ColumnConverter | Type converter for Column. Mainly for the internal use of the WinForm designer.
CurrencyManagerHandle | This is class Eco.Handles.CurrencyManagerHandle.
CursorHandle | This abstract ECO handle holds a reference to an ECO element and also an index "position" pointing to a specific item if the element is a collection.
DefaultEcoSpace | This is class Eco.Handles.DefaultEcoSpace.
DeriveEventArgs | This is class Eco.Handles.DeriveEventArgs.
DescriptorFactory | This is class Eco.Handles.DescriptorFactory.
DisplayQueue | This is class Eco.Handles.DisplayQueue.
EcoSpace | This is class Eco.Handles.EcoSpace.
EcoSpaceBase | This is class Eco.Handles.EcoSpaceBase.
EcoSpaceSerializer | The EcoSpaceSerializer is a class that can be used to serialize Ecospaces using standard dotnet serialization.
ElementHandle | This component is the base class for all of the ECO handle components.
EventDerivedColumn | Class describing an additional property to be added to the items in the rendered list, which gets its value through ElementHandle.DeriveValue
EventDerivedColumnConverter | Type converter for EventDerivedColumn. Mainly for the internal use of the WinForm designer.
ExpressionHandle | An ECO handle that specifies its ElementHandle.Element in the form of an OCL expression.
HandleAdapter | This is class Eco.Handles.HandleAdapter.
HandlesStringRes | Autogenerated class to get compiler safe access to resource strings.
HandleUtils | Helper class with useful routines. This class contains only static methods and cannot be instantiated.
ItemStaticContext | This class is part of the internal implementation of the databindable IList implemented by the Eco handles. It should not be used directly.
MaxLengthSupportFunctions | This class provides some useful routines to set the max entry length on UI controls based on the modeled max length of (string) attributes).
MaxLengthSupportLibraryAttribute | This is class Eco.Handles.MaxLengthSupportLibraryAttribute.
MaxLengthSupportProviderAttribute | This is class Eco.Handles.MaxLengthSupportProviderAttribute.
NameValidator | This is class Eco.Handles.NameValidator.
Nesting | This is class Eco.Handles.Nesting.
NestingCollection | NestingCollection
NestingConverter | Type converter to make Nesting Serialize
OclColumn | Class describing an additional property to be added to the items in the rendered list defined via OCL
OclColumnConverter | Type converter for OclColumn. Mainly for the internal use of the WinForm designer.
OclEditorResult | This is class Eco.Handles.OclEditorResult.
OclEditorSupport | OclEditorSuppport is a convenience class to show an ocl-editor.
OclPSHandle | An ECO handle that specifies its ElementHandle.Element in the form of an OCL expression evaluated direcly within the data store.
OclVariable | Item
OclVariableCollection | internal class ExternalVariableListAdapter: IExternalVariableList { OclVariableCollection adaptee; internal ExternalVariableListAdapter(OclVariableCollection adaptee) { this.adaptee = adaptee; } int IExternalVariableList.Count { get { return adaptee.Count; } } IExternalVariable IExternalVariableList.this[int index] { get { return adaptee[index].Variable; } } IExternalVariable IExternalVariableList.this[string name] { get { return adaptee[name]; } } void IExternalVariableList.Subscribe(ISubscriber subscriber) { adaptee.Subscribe(subscriber); } IEnumerator IEnumerable.GetEnumerator() { ArrayList list = new ArrayList(); foreach (OclVariable v in adaptee) list.Add(v.Variable); return list.GetEnumerator();
OclVariables | This is class Eco.Handles.OclVariables.
PropertyComparer | This is class Eco.Handles.PropertyComparer.
PrototypeEcoSpace | This is class Eco.Handles.PrototypeEcoSpace.
ReferenceHandle | This type of RootHandle holds a reference to an EcoSpace and (optionally) an ECO element.
RenderedList | This is class Eco.Handles.RenderedList.
RenderedTestTuple | This is class Eco.Handles.RenderedTestTuple.
RenderedTuple | This is class Eco.Handles.RenderedTuple.
RenderedTupleDescriptor | This class is part of the internal implementation of the databindable Ilist implemented by the Eco handles. It should not be used directly.
RenderedTupleFilter | This is class Eco.Handles.RenderedTupleFilter.
RenderedTupleListProperty | This is class Eco.Handles.RenderedTupleListProperty.
RenderedTupleProperty | This is class Eco.Handles.RenderedTupleProperty.
RenderedTuplePropertyDescriptor | This is class Eco.Handles.RenderedTuplePropertyDescriptor.
RenderedTupleTestProperty | This is class Eco.Handles.RenderedTupleTestProperty.
ReverseDeriveEventArgs | This is class Eco.Handles.ReverseDeriveEventArgs.
RootedHandle | An ECO handle that depends upon an ElementHandle for its context.
RootHandle | An ECO handle component that does not depend upon another ECO handle for its context or EcoSpace reference.
TupleContext | This is class Eco.Handles.TupleContext.
VariableHandle | Handle for a Eco Variable, i.e. for an Element that is not part of an EcoSpace.
Top
Enumerations
Name | Description
ExpressionKind | This is record Eco.Handles.ExpressionKind.
FilterMode | Enumeration to control the format of Filter
MemberVisibility | Enumeration used to filter members on visibility.
NullRowMode | Enumeration to control adding a "null row" to an Eco Handle.
Top
Interfaces
Name | Description
IColumn | This is class Eco.Handles.IColumn.
IEcoSpaceTypeLookupService | For internal use. Adds IDE specific methods of looking up EcoSpace types in design time.
IElementHandle | This is class Eco.Handles.IElementHandle.
IHasEditableExpression | Interface implemented by classes that hold a editable OCL expression. Mainly for internal use.
IHasSecondEditableExpression | Interface implemented by classes that hold a second editable OCL expression. Mainly for internal use.
IHasTypeSystem | Interface implemented by classes that can supply typesystem to designers. Mainly for internal use
IMaxLengthSupportProvider | This is class Eco.Handles.IMaxLengthSupportProvider.
INesting | This is class Eco.Handles.INesting.
INestingProvider | This is class Eco.Handles.INestingProvider.
INotifyOnIdle | This interface is part of the internal implementation of the databindable IList implemented by the Eco handles. It should not be used directly.
IOclVariables | This is class Eco.Handles.IOclVariables.
IRenderingContext | This interface is part of the internal implementation of the databindable IList implemented by the Eco handles. It should not be used directly.
IReorderableList | This is class Eco.Handles.IReorderableList.
IRooted | This is class Eco.Handles.IRooted.
IStaticContextFromObject | Interface implemented by classes that can return an IStaticContext indexed on an object. Mainly for internal use
ITupleListRenderingContext | This interface is part of the internal implementation of the databindable IList implemented by the Eco handles. It should not be used directly.
ITuplePropertyRenderingContext | This interface is part of the internal implementation of the databindable IList implemented by the Eco handles. It should not be used directly.
ITupleRenderingContext | This interface is part of the internal implementation of the databindable IList implemented by the Eco handles. It should not be used directly.
Top
Types
Name | Description
DeriveEventHandler | Delegate declaration.
DisplayQueueNotEmptyEventHandler | This is type Eco.Handles.DisplayQueueNotEmptyEventHandler.
ReverseDeriveEventHandler | This is type Eco.Handles.ReverseDeriveEventHandler.
SignalListChangedHandler | This is type Eco.Handles.SignalListChangedHandler.


AbstractColumn Class

AbstractColumn Class
Inheritance Hierarchy See Also
Collapse All

Abstract superclass for "Columns", i.e. additional properties on the Objects in the bindinglist of an ElementHandle

C#
public abstract class AbstractColumn : IColumn;
Remarks

The strange inheritance hierarchy is in order to keep compatibility with the old definition of 'Column'.

Inheritance Hierarchy
Eco.Handles.IColumn
    Eco.Handles.AbstractColumn
        Eco.Handles.EventDerivedColumn
        Eco.Handles.OclColumn
File

Columns.cs

See Also
Inheritance Hierarchy


AbstractColumn.AbstractColumn Constructor

AbstractColumn.AbstractColumn Constructor
AbstractColumn Class Eco.Handles Namespace See Also
Collapse All
C#
protected AbstractColumn();
Remarks

This is AbstractColumn, a member of class AbstractColumn.

See Also
AbstractColumn Class
Eco.Handles Namespace


AbstractColumn Methods

AbstractColumn Methods
Protected Methods
Collapse All

The methods of the AbstractColumn class are listed here.

Protected Methods
Name | Description
Changed | This is Changed, a member of class AbstractColumn.


AbstractColumn.Changed Method

AbstractColumn.Changed Method
AbstractColumn Class Eco.Handles Namespace See Also
Collapse All
C#
protected void Changed();
Remarks

This is Changed, a member of class AbstractColumn.

See Also
AbstractColumn Class
Eco.Handles Namespace


AbstractColumn Properties

AbstractColumn Properties
Public Properties
Collapse All

The properties of the AbstractColumn class are listed here.

Public Properties
Name | Description
AsExternalId | Set this value to true to indicate that the property shall be represented by its ExternalId. Setting this value to true for a property that represents an ECO object will render the property as a string returned by IExternalIdService. And on setting it will accept a string which is produced by that service. This is mainly for use in ASP.Net databinding, where only value types survive.
EventDerivedValue | This is EventDerivedValue, a member of class AbstractColumn.
Expression | OCL expression used to compute the value of the column unless EventDerivedValue is true.
IsReadOnly | Set this value to true to indicate that the property shall be read only. If this value is false for an OclColumn, the readablility will be decided by the Ocl expression If this value is false for an EventDerviedColumn, setting is handled by ElementHandle.ReverseDeriveValue
Name | This is the name given to the property added to the binding list. This name is used when binding to a data aware control.
Nested | Set this property to true to make the property in the binding list a list rather than a single value.
NestingName | Nesting definition to use
NullElementRepresentation | Representation for null rows.
TypeName | This is TypeName, a member of class AbstractColumn.


AbstractColumn.AsExternalId Property

AbstractColumn.AsExternalId Property
AbstractColumn Class Eco.Handles Namespace See Also
Collapse All

Set this value to true to indicate that the property shall be represented by its ExternalId.

Setting this value to true for a property that represents an ECO object will render the property as a string returned by IExternalIdService. And on setting it will accept a string which is produced by that service. This is mainly for use in ASP.Net databinding, where only value types survive.

C#
public bool AsExternalId;
See Also
AbstractColumn Class
Eco.Handles Namespace


AbstractColumn.EventDerivedValue Property

AbstractColumn.EventDerivedValue Property
AbstractColumn Class Eco.Handles Namespace See Also
Collapse All
C#
public abstract bool EventDerivedValue;
Remarks

This is EventDerivedValue, a member of class AbstractColumn.

See Also
AbstractColumn Class
Eco.Handles Namespace


AbstractColumn.Expression Property

AbstractColumn.Expression Property
AbstractColumn Class Eco.Handles Namespace See Also
Collapse All

OCL expression used to compute the value of the column unless EventDerivedValue is true.

C#
public abstract string Expression;
See Also
AbstractColumn Class
Eco.Handles Namespace


AbstractColumn.IsReadOnly Property

AbstractColumn.IsReadOnly Property
AbstractColumn Class Eco.Handles Namespace See Also
Collapse All

Set this value to true to indicate that the property shall be read only.

If this value is false for an OclColumn, the readablility will be decided by the Ocl expression

If this value is false for an EventDerviedColumn, setting is handled by ElementHandle.ReverseDeriveValue

C#
public bool IsReadOnly;
See Also
AbstractColumn Class
Eco.Handles Namespace


AbstractColumn.Name Property

AbstractColumn.Name Property
AbstractColumn Class Eco.Handles Namespace See Also
Collapse All

This is the name given to the property added to the binding list.

This name is used when binding to a data aware control.

C#
public String Name;
Exceptions
Exceptions | Description
InvalidOperationException | Thrown if the name of the column is not unique in the owner's column collection.
See Also
AbstractColumn Class
Eco.Handles Namespace


AbstractColumn.Nested Property

AbstractColumn.Nested Property
AbstractColumn Class Eco.Handles Namespace See Also
Collapse All

Set this property to true to make the property in the binding list a list rather than a single value.

C#
public bool Nested;
See Also
AbstractColumn Class
Eco.Handles Namespace


AbstractColumn.NestingName Property

AbstractColumn.NestingName Property
AbstractColumn Class Eco.Handles Namespace See Also
Collapse All

Nesting definition to use

C#
public String NestingName;
Remarks

If this name is set, a Nesting with that name must exist in the ElementHandle.Nestings of the owning handle. If the name is empty, default columns will be created for the nesting.

See Also
AbstractColumn Class
Eco.Handles Namespace


AbstractColumn.NullElementRepresentation Property

AbstractColumn.NullElementRepresentation Property
AbstractColumn Class Eco.Handles Namespace See Also
Collapse All

Representation for null rows.

C#
public abstract string NullElementRepresentation;
Remarks

This property controls the column is presented for a "null" row created by setting ElementHandle.NullRowMode to something toher than NullRowMode.None

The property is a string that will be convereted to the type of the column.

Two special values are recognized, <Null> which will represent the column as null and <DbNull> which will represent the column as DbNull.Value". The default is <Null>.

See Also
AbstractColumn Class
Eco.Handles Namespace


AbstractColumn.TypeName Property

AbstractColumn.TypeName Property
AbstractColumn Class Eco.Handles Namespace See Also
Collapse All
C#
public virtual string TypeName;
Remarks

This is TypeName, a member of class AbstractColumn.

See Also
AbstractColumn Class
Eco.Handles Namespace


AbstractColumnConverter Class

AbstractColumnConverter Class
Inheritance Hierarchy See Also
Collapse All

Type converter for AbstractColumn. Mainly for the internal use of the WinForm designer.

C#
public abstract class AbstractColumnConverter : ExpandableObjectConverter;
Inheritance Hierarchy
Eco.Handles.AbstractColumnConverter
    Eco.Handles.ColumnConverter
    Eco.Handles.EventDerivedColumnConverter
    Eco.Handles.OclColumnConverter
File

Columns.cs

See Also
Inheritance Hierarchy


AbstractColumnConverter Methods

AbstractColumnConverter Methods
Protected Methods Public Methods
Collapse All

The methods of the AbstractColumnConverter class are listed here.

Protected Methods
Name | Description
GetTargetType | This is GetTargetType, a member of class AbstractColumnConverter.
Top
Public Methods
Name | Description
CanConvertTo | This is CanConvertTo, a member of class AbstractColumnConverter.
ConvertTo | This is ConvertTo, a member of class AbstractColumnConverter.


AbstractColumnConverter.CanConvertTo Method

AbstractColumnConverter.CanConvertTo Method
AbstractColumnConverter Class Eco.Handles Namespace See Also
Collapse All
C#
public override bool CanConvertTo(
    ITypeDescriptorContext context,
    Type destinationType
);
Remarks

This is CanConvertTo, a member of class AbstractColumnConverter.

See Also
AbstractColumnConverter Class
Eco.Handles Namespace


AbstractColumnConverter.ConvertTo Method

AbstractColumnConverter.ConvertTo Method
AbstractColumnConverter Class Eco.Handles Namespace See Also
Collapse All
C#
public override object ConvertTo(
    ITypeDescriptorContext context,
    CultureInfo culture,
    object value,
    Type destinationType
);
Remarks

This is ConvertTo, a member of class AbstractColumnConverter.

See Also
AbstractColumnConverter Class
Eco.Handles Namespace


AbstractColumnConverter.GetTargetType Method

AbstractColumnConverter.GetTargetType Method
AbstractColumnConverter Class Eco.Handles Namespace See Also
Collapse All
C#
protected abstract Type GetTargetType();
Remarks

This is GetTargetType, a member of class AbstractColumnConverter.

See Also
AbstractColumnConverter Class
Eco.Handles Namespace


AbstractCursorHandle Class

AbstractCursorHandle Class
Inheritance Hierarchy See Also
Collapse All

This abstract ECO handle holds a reference to an ECO element and also an index "position" pointing to a specific item if the element is a collection.

C#
public abstract class AbstractCursorHandle : RootedHandle;
Inheritance Hierarchy
Eco.Handles.IElementHandle
Eco.Handles.INotifyOnIdle
    Eco.Handles.ElementHandle
    Eco.Handles.IRooted
        Eco.Handles.RootedHandle
            Eco.Handles.AbstractCursorHandle
                Eco.Handles.CurrencyManagerHandle
                Eco.Handles.CursorHandle
File

CursorHandle.cs

See Also
Inheritance Hierarchy


AbstractCursorHandle Methods

AbstractCursorHandle Methods
Protected Methods
Collapse All

The methods of the AbstractCursorHandle class are listed here.

Protected Methods
Name | Description
DeriveAndSubscribe | This is DeriveAndSubscribe, a member of class AbstractCursorHandle.
GetStaticUmlType | This is GetStaticUmlType, a member of class AbstractCursorHandle.


AbstractCursorHandle.DeriveAndSubscribe Method

AbstractCursorHandle.DeriveAndSubscribe Method
AbstractCursorHandle Class Eco.Handles Namespace See Also
Collapse All
C#
protected override void DeriveAndSubscribe(
    ISubscriber valueChangeSubscriber,
    ISubscriber resubscribeSubscriber
);
Remarks

This is DeriveAndSubscribe, a member of class AbstractCursorHandle.

See Also
AbstractCursorHandle Class
Eco.Handles Namespace


AbstractCursorHandle.GetStaticUmlType Method

AbstractCursorHandle.GetStaticUmlType Method
AbstractCursorHandle Class Eco.Handles Namespace See Also
Collapse All
C#
protected override IClassifier GetStaticUmlType();
Remarks

This is GetStaticUmlType, a member of class AbstractCursorHandle.

See Also
AbstractCursorHandle Class
Eco.Handles Namespace


AbstractCursorHandle Properties

AbstractCursorHandle Properties
Public Properties
Collapse All

The properties of the AbstractCursorHandle class are listed here.

Public Properties
Name | Description
Position | Sets and gets the position in the list pointed to by the handle.


AbstractCursorHandle.Position Property

AbstractCursorHandle.Position Property
AbstractCursorHandle Class Eco.Handles Namespace See Also
Collapse All

Sets and gets the position in the list pointed to by the handle.

C#
public abstract int Position;
See Also
AbstractCursorHandle Class
Eco.Handles Namespace


AbstractRenderedTuple Class

AbstractRenderedTuple Class
Inheritance Hierarchy See Also
Collapse All

This class is part of the internal implementation of the databindable Ilist implemented by the Eco handles. It should not be used directly.

C#
public abstract class AbstractRenderedTuple : ICustomTypeDescriptor, INotifyPropertyChanged, ITuplePropertyRenderingContext;
Remarks

// This class not used yet public sealed class EditableRenderedTuple: AbstractRenderedTuple, IEditableObject { public EditableRenderedTuple(IElement element, ITupleRenderingContext owner): base(element, owner) { } #region IRenderingContext implementation void IEditableObject.BeginEdit() { } void IEditableObject.EndEdit() { } void IEditableObject.CancelEdit() { IObject o = Element as IObject; if (o != null) o.Delete(); } #endregion }

Inheritance Hierarchy
Eco.Handles.IRenderingContext
    Eco.Handles.ITuplePropertyRenderingContext
        Eco.Handles.AbstractRenderedTuple
            Eco.Handles.RenderedTestTuple
            Eco.Handles.RenderedTuple
File

ControlPack.cs

See Also
Inheritance Hierarchy


AbstractRenderedTuple.AbstractRenderedTuple Constructor

AbstractRenderedTuple.AbstractRenderedTuple Constructor
AbstractRenderedTuple Class Eco.Handles Namespace See Also
Collapse All
C#
protected AbstractRenderedTuple(
    IElement element,
    ITupleRenderingContext owner
);
Remarks

This is AbstractRenderedTuple, a member of class AbstractRenderedTuple.

See Also
AbstractRenderedTuple Class
Eco.Handles Namespace


AbstractRenderedTuple Methods

AbstractRenderedTuple Methods
Public Methods
Collapse All

The methods of the AbstractRenderedTuple class are listed here.

Public Methods
Name | Description
Equals | This is Equals, a member of class AbstractRenderedTuple.
GetHashCode | This is GetHashCode, a member of class AbstractRenderedTuple.
GetProperty |


AbstractRenderedTuple.Equals Method

AbstractRenderedTuple.Equals Method
AbstractRenderedTuple Class Eco.Handles Namespace See Also
Collapse All
C#
public override bool Equals(
    object obj
);
Remarks

This is Equals, a member of class AbstractRenderedTuple.

See Also
AbstractRenderedTuple Class
Eco.Handles Namespace


AbstractRenderedTuple.GetHashCode Method

AbstractRenderedTuple.GetHashCode Method
AbstractRenderedTuple Class Eco.Handles Namespace See Also
Collapse All
C#
public override int GetHashCode();
Remarks

This is GetHashCode, a member of class AbstractRenderedTuple.

See Also
AbstractRenderedTuple Class
Eco.Handles Namespace


AbstractRenderedTuple.GetProperty Method

AbstractRenderedTuple.GetProperty Method
AbstractRenderedTuple Class Eco.Handles Namespace See Also
Collapse All
C#
public AbstractRenderedTupleProperty GetProperty(
    RenderedTuplePropertyDescriptor descriptor
);
Exceptions
Exceptions | Description
ArgumentException | Thrown if descriptor does not exist in the list of the owner's descriptors.
See Also
AbstractRenderedTuple Class
Eco.Handles Namespace


AbstractRenderedTuple Properties

AbstractRenderedTuple Properties
Public Properties
Collapse All

The properties of the AbstractRenderedTuple class are listed here.

Public Properties
Name | Description
Element | This is Element, a member of class AbstractRenderedTuple.
IsTestTuple | This is IsTestTuple, a member of class AbstractRenderedTuple.
Owner | This is Owner, a member of class AbstractRenderedTuple.


AbstractRenderedTuple.Element Property

AbstractRenderedTuple.Element Property
AbstractRenderedTuple Class Eco.Handles Namespace See Also
Collapse All
C#
public IElement Element;
Remarks

This is Element, a member of class AbstractRenderedTuple.

See Also
AbstractRenderedTuple Class
Eco.Handles Namespace


AbstractRenderedTuple.IsTestTuple Property

AbstractRenderedTuple.IsTestTuple Property
AbstractRenderedTuple Class Eco.Handles Namespace See Also
Collapse All
C#
public virtual bool IsTestTuple;
Remarks

This is IsTestTuple, a member of class AbstractRenderedTuple.

See Also
AbstractRenderedTuple Class
Eco.Handles Namespace


AbstractRenderedTuple.Owner Property

AbstractRenderedTuple.Owner Property
AbstractRenderedTuple Class Eco.Handles Namespace See Also
Collapse All
C#
public ITupleRenderingContext Owner;
Remarks

This is Owner, a member of class AbstractRenderedTuple.

See Also
AbstractRenderedTuple Class
Eco.Handles Namespace


AbstractRenderedTuple Events

AbstractRenderedTuple Events
Public Events
Collapse All

The events of the AbstractRenderedTuple class are listed here.

Public Events
Name | Description
PropertyChanged | This is PropertyChanged, a member of class AbstractRenderedTuple.


AbstractRenderedTuple.PropertyChanged Event

AbstractRenderedTuple.PropertyChanged Event
AbstractRenderedTuple Class Eco.Handles Namespace See Also
Collapse All
C#
public event PropertyChangedEventHandler PropertyChanged;
Remarks

This is PropertyChanged, a member of class AbstractRenderedTuple.

See Also
AbstractRenderedTuple Class
Eco.Handles Namespace


AbstractRenderedTupleProperty Class

AbstractRenderedTupleProperty Class
Inheritance Hierarchy See Also
Collapse All
C#
public abstract class AbstractRenderedTupleProperty : AbstractDeriver, ISubscribableElementProvider;
Remarks

This is class Eco.Handles.AbstractRenderedTupleProperty.

Inheritance Hierarchy
Eco.Handles.AbstractRenderedTupleProperty
    Eco.Handles.RenderedTupleListProperty
    Eco.Handles.RenderedTupleProperty
    Eco.Handles.RenderedTupleTestProperty
File

ControlPack.cs

See Also
Inheritance Hierarchy


AbstractRenderedTupleProperty.AbstractRenderedTupleProperty Constructor

AbstractRenderedTupleProperty.AbstractRenderedTupleProperty Constructor
AbstractRenderedTupleProperty Class Eco.Handles Namespace See Also
Collapse All
C#
protected AbstractRenderedTupleProperty(
    RenderedTuplePropertyDescriptor descriptor,
    ITuplePropertyRenderingContext owner
);
Remarks

This is AbstractRenderedTupleProperty, a member of class AbstractRenderedTupleProperty.

See Also
AbstractRenderedTupleProperty Class
Eco.Handles Namespace


AbstractRenderedTupleProperty Fields

AbstractRenderedTupleProperty Fields
Protected Fields
Collapse All

The fields of the AbstractRenderedTupleProperty class are listed here.

Protected Fields
Name | Description
m_Descriptor | This is m_Descriptor, a member of class AbstractRenderedTupleProperty.
m_IsNullElementProperty | This is m_IsNullElementProperty, a member of class AbstractRenderedTupleProperty.
m_Owner | This is m_Owner, a member of class AbstractRenderedTupleProperty.
m_ValueRead | This is m_ValueRead, a member of class AbstractRenderedTupleProperty.


AbstractRenderedTupleProperty.m_Descriptor Field

AbstractRenderedTupleProperty.m_Descriptor Field
AbstractRenderedTupleProperty Class Eco.Handles Namespace See Also
Collapse All
C#
protected readonly RenderedTuplePropertyDescriptor m_Descriptor;
Remarks

This is m_Descriptor, a member of class AbstractRenderedTupleProperty.

See Also
AbstractRenderedTupleProperty Class
Eco.Handles Namespace


AbstractRenderedTupleProperty.m_IsNullElementProperty Field

AbstractRenderedTupleProperty.m_IsNullElementProperty Field
AbstractRenderedTupleProperty Class Eco.Handles Namespace See Also
Collapse All
C#
protected bool m_IsNullElementProperty = false;
Remarks

This is m_IsNullElementProperty, a member of class AbstractRenderedTupleProperty.

See Also
AbstractRenderedTupleProperty Class
Eco.Handles Namespace


AbstractRenderedTupleProperty.m_Owner Field

AbstractRenderedTupleProperty.m_Owner Field
AbstractRenderedTupleProperty Class Eco.Handles Namespace See Also
Collapse All
C#
protected readonly ITuplePropertyRenderingContext m_Owner;
Remarks

This is m_Owner, a member of class AbstractRenderedTupleProperty.

See Also
AbstractRenderedTupleProperty Class
Eco.Handles Namespace


AbstractRenderedTupleProperty.m_ValueRead Field

AbstractRenderedTupleProperty.m_ValueRead Field
AbstractRenderedTupleProperty Class Eco.Handles Namespace See Also
Collapse All
C#
protected bool m_ValueRead = false;
Remarks

This is m_ValueRead, a member of class AbstractRenderedTupleProperty.

See Also
AbstractRenderedTupleProperty Class
Eco.Handles Namespace


AbstractRenderedTupleProperty Methods

AbstractRenderedTupleProperty Methods
Protected Methods Public Methods
Collapse All

The methods of the AbstractRenderedTupleProperty class are listed here.

Protected Methods
Name | Description
DoDeriveAndSubscribe | This is DoDeriveAndSubscribe, a member of class AbstractRenderedTupleProperty.
DoGetValue | This is DoGetValue, a member of class AbstractRenderedTupleProperty.
DoNotifyOutOfDate | This is DoNotifyOutOfDate, a member of class AbstractRenderedTupleProperty.
Top
Public Methods
Name | Description
GetValue | This is GetValue, a member of class AbstractRenderedTupleProperty.
SetValue | This is SetValue, a member of class AbstractRenderedTupleProperty.
ToString | This is ToString, a member of class AbstractRenderedTupleProperty.


AbstractRenderedTupleProperty.DoDeriveAndSubscribe Method

AbstractRenderedTupleProperty.DoDeriveAndSubscribe Method
AbstractRenderedTupleProperty Class Eco.Handles Namespace See Also
Collapse All
C#
protected override void DoDeriveAndSubscribe(
    bool subscribe
);
Remarks

This is DoDeriveAndSubscribe, a member of class AbstractRenderedTupleProperty.

See Also
AbstractRenderedTupleProperty Class
Eco.Handles Namespace


AbstractRenderedTupleProperty.DoGetValue Method

AbstractRenderedTupleProperty.DoGetValue Method
AbstractRenderedTupleProperty Class Eco.Handles Namespace See Also
Collapse All
C#
protected abstract object DoGetValue();
Remarks

This is DoGetValue, a member of class AbstractRenderedTupleProperty.

See Also
AbstractRenderedTupleProperty Class
Eco.Handles Namespace


AbstractRenderedTupleProperty.DoNotifyOutOfDate Method

AbstractRenderedTupleProperty.DoNotifyOutOfDate Method
AbstractRenderedTupleProperty Class Eco.Handles Namespace See Also
Collapse All
C#
protected override void DoNotifyOutOfDate();
Remarks

This is DoNotifyOutOfDate, a member of class AbstractRenderedTupleProperty.

See Also
AbstractRenderedTupleProperty Class
Eco.Handles Namespace


AbstractRenderedTupleProperty.GetValue Method

AbstractRenderedTupleProperty.GetValue Method
AbstractRenderedTupleProperty Class Eco.Handles Namespace See Also
Collapse All
C#
public object GetValue();
Remarks

This is GetValue, a member of class AbstractRenderedTupleProperty.

See Also
AbstractRenderedTupleProperty Class
Eco.Handles Namespace


AbstractRenderedTupleProperty.SetValue Method

AbstractRenderedTupleProperty.SetValue Method
AbstractRenderedTupleProperty Class Eco.Handles Namespace See Also
Collapse All
C#
public abstract void SetValue(
    object value
);
Remarks

This is SetValue, a member of class AbstractRenderedTupleProperty.

See Also
AbstractRenderedTupleProperty Class
Eco.Handles Namespace


AbstractRenderedTupleProperty.ToString Method

AbstractRenderedTupleProperty.ToString Method
AbstractRenderedTupleProperty Class Eco.Handles Namespace See Also
Collapse All
C#
public override string ToString();
Remarks

This is ToString, a member of class AbstractRenderedTupleProperty.

See Also
AbstractRenderedTupleProperty Class
Eco.Handles Namespace


AbstractRenderedTupleProperty Properties

AbstractRenderedTupleProperty Properties
Protected Properties
Collapse All

The properties of the AbstractRenderedTupleProperty class are listed here.

Protected Properties
Name | Description
Element | This is Element, a member of class AbstractRenderedTupleProperty.


AbstractRenderedTupleProperty.Element Property

AbstractRenderedTupleProperty.Element Property
AbstractRenderedTupleProperty Class Eco.Handles Namespace See Also
Collapse All
C#
protected IElement Element;
Remarks

This is Element, a member of class AbstractRenderedTupleProperty.

See Also
AbstractRenderedTupleProperty Class
Eco.Handles Namespace


Column Class

Column Class
Inheritance Hierarchy See Also
Collapse All

This class is for backwards comatibility only

C#
public class Column : OclColumn;
Inheritance Hierarchy
Eco.Handles.IColumn
    Eco.Handles.AbstractColumn
    Eco.Handles.IHasEditableExpression
        Eco.Handles.OclColumn
            Eco.Handles.Column
File

Columns.cs

See Also
Inheritance Hierarchy


Column Properties

Column Properties
Public Properties
Collapse All

The properties of the Column class are listed here.

Public Properties
Name | Description
EventDerivedValue | This property is always false for an OclColumn. For a column deriving its value by an event, use an EventDerivedColumn.


Column.EventDerivedValue Property

Column.EventDerivedValue Property
Column Class Eco.Handles Namespace See Also
Collapse All

This property is always false for an OclColumn. For a column deriving its value by an event, use an EventDerivedColumn.

C#
public override bool EventDerivedValue;
See Also
Column Class
Eco.Handles Namespace


ColumnCollection Class

ColumnCollection Class
Inheritance Hierarchy See Also
Collapse All

Represents a collection of columns.

C#
public sealed class ColumnCollection : System.Collections.CollectionBase;
Inheritance Hierarchy
Eco.Handles.ColumnCollection
File

Columns.cs

See Also
Inheritance Hierarchy


ColumnCollection.ColumnCollection Constructor

ColumnCollection.ColumnCollection Constructor
ColumnCollection Class Eco.Handles Namespace See Also
Collapse All

Creates an instance of the class.

C#
public ColumnCollection(
    IStaticContext staticContext
);
See Also
ColumnCollection Class
Eco.Handles Namespace


ColumnCollection Methods

ColumnCollection Methods
Protected Methods Public Methods
Collapse All

The methods of the ColumnCollection class are listed here.

Protected Methods
Name | Description
OnClearComplete | This is OnClearComplete, a member of class ColumnCollection.
OnInsert |
OnInsertComplete | This is OnInsertComplete, a member of class ColumnCollection.
OnRemoveComplete | This is OnRemoveComplete, a member of class ColumnCollection.
Top
Public Methods
Name | Description
Add | Adds a column to the collection.
AddRange | This is the overview for the AddRange method overload.
IndexOf | Returns the index of value within the collection.
this | This is the overview for the this indexer overload.


ColumnCollection.Add Method

ColumnCollection.Add Method
ColumnCollection Class Eco.Handles Namespace See Also
Collapse All

Adds a column to the collection.

C#
public void Add(
    AbstractColumn column
);
See Also
ColumnCollection Class
Eco.Handles Namespace


AddRange Method

AddRange Method

This is the overview for the AddRange method overload.

Overload List
Name | Description
ColumnCollection.AddRange (AbstractColumn[]) | Adds an array of columns to the collection.
ColumnCollection.AddRange (Column[]) | Adds an array of columns to the collection.


ColumnCollection.AddRange Method (AbstractColumn[])

ColumnCollection.AddRange Method (AbstractColumn[])
ColumnCollection Class Eco.Handles Namespace See Also
Collapse All

Adds an array of columns to the collection.

C#
public void AddRange(
    AbstractColumn[] columns
);
See Also
ColumnCollection Class
Eco.Handles Namespace


ColumnCollection.AddRange Method (Column[])

ColumnCollection.AddRange Method (Column[])
ColumnCollection Class Eco.Handles Namespace See Also
Collapse All

Adds an array of columns to the collection.

C#
public void AddRange(
    Column[] columns
);
Remarks

For backwards compatibility.

See Also
ColumnCollection Class
Eco.Handles Namespace


ColumnCollection.IndexOf Method

ColumnCollection.IndexOf Method
ColumnCollection Class Eco.Handles Namespace See Also
Collapse All

Returns the index of value within the collection.

C#
public int IndexOf(
    object value
);
See Also
ColumnCollection Class
Eco.Handles Namespace


ColumnCollection.OnClearComplete Method

ColumnCollection.OnClearComplete Method
ColumnCollection Class Eco.Handles Namespace See Also
Collapse All
C#
protected override void OnClearComplete();
Remarks

This is OnClearComplete, a member of class ColumnCollection.

See Also
ColumnCollection Class
Eco.Handles Namespace


ColumnCollection.OnInsert Method

ColumnCollection.OnInsert Method
ColumnCollection Class Eco.Handles Namespace See Also
Collapse All
C#
protected override void OnInsert(
    int index,
    object value
);
Exceptions
Exceptions | Description
InvalidOperationException | Thrown if the name of the added column exists in the collection.
See Also
ColumnCollection Class
Eco.Handles Namespace


ColumnCollection.OnInsertComplete Method

ColumnCollection.OnInsertComplete Method
ColumnCollection Class Eco.Handles Namespace See Also
Collapse All
C#
protected override void OnInsertComplete(
    int index,
    object value
);
Remarks

This is OnInsertComplete, a member of class ColumnCollection.

See Also
ColumnCollection Class
Eco.Handles Namespace


ColumnCollection.OnRemoveComplete Method

ColumnCollection.OnRemoveComplete Method
ColumnCollection Class Eco.Handles Namespace See Also
Collapse All
C#
protected override void OnRemoveComplete(
    int index,
    object value
);
Remarks

This is OnRemoveComplete, a member of class ColumnCollection.

See Also
ColumnCollection Class
Eco.Handles Namespace


this Indexer

this Indexer

This is the overview for the this indexer overload.

Overload List
Name | Description
ColumnCollection.this (int) | Returns the column at position index.
ColumnCollection.this (string) | Returns the column named name.


ColumnCollection.this Indexer (int)

ColumnCollection.this Indexer (int)
ColumnCollection Class Eco.Handles Namespace See Also
Collapse All

Returns the column at position index.

C#
public AbstractColumn this[
    int index
];
See Also
ColumnCollection Class
Eco.Handles Namespace


ColumnCollection.this Indexer (string)

ColumnCollection.this Indexer (string)
ColumnCollection Class Eco.Handles Namespace See Also
Collapse All

Returns the column named name.

C#
public AbstractColumn this[
    string name
];
See Also
ColumnCollection Class
Eco.Handles Namespace


ColumnCollection Properties

ColumnCollection Properties
Public Properties
Collapse All

The properties of the ColumnCollection class are listed here.

Public Properties
Name | Description
StaticContext | This is StaticContext, a member of class ColumnCollection.


ColumnCollection.StaticContext Property

ColumnCollection.StaticContext Property
ColumnCollection Class Eco.Handles Namespace See Also
Collapse All
C#
public IStaticContext StaticContext;
Remarks

This is StaticContext, a member of class ColumnCollection.

See Also
ColumnCollection Class
Eco.Handles Namespace


ColumnCollection Events

ColumnCollection Events
Public Events
Collapse All

The events of the ColumnCollection class are listed here.

Public Events
Name | Description
OnChange | This is OnChange, a member of class ColumnCollection.


ColumnCollection.OnChange Event

ColumnCollection.OnChange Event
ColumnCollection Class Eco.Handles Namespace See Also
Collapse All
C#
public event EventHandler OnChange;
Remarks

This is OnChange, a member of class ColumnCollection.

See Also
ColumnCollection Class
Eco.Handles Namespace


ColumnConstants Class

ColumnConstants Class
Inheritance Hierarchy See Also
Collapse All
C#
public static class ColumnConstants;
Remarks

This is class Eco.Handles.ColumnConstants.

Inheritance Hierarchy
Eco.Handles.ColumnConstants
File

HandleInterfaces.cs

See Also
Inheritance Hierarchy


ColumnConstants Fields

ColumnConstants Fields
Public Fields
Collapse All

The fields of the ColumnConstants class are listed here.

Public Fields
Name | Description
DbNullRep | This is DbNullRep, a member of class ColumnConstants.
NullRep | This is NullRep, a member of class ColumnConstants.


ColumnConstants.DbNullRep Field

ColumnConstants.DbNullRep Field
ColumnConstants Class Eco.Handles Namespace See Also
Collapse All
C#
public const string DbNullRep = "<DbNull>";
Remarks

This is DbNullRep, a member of class ColumnConstants.

See Also
ColumnConstants Class
Eco.Handles Namespace


ColumnConstants.NullRep Field

ColumnConstants.NullRep Field
ColumnConstants Class Eco.Handles Namespace See Also
Collapse All
C#
public const string NullRep = "<Null>";
Remarks

This is NullRep, a member of class ColumnConstants.

See Also
ColumnConstants Class
Eco.Handles Namespace


ColumnConverter Class

ColumnConverter Class
Inheritance Hierarchy See Also
Collapse All

Type converter for Column. Mainly for the internal use of the WinForm designer.

C#
public sealed class ColumnConverter : AbstractColumnConverter;
Inheritance Hierarchy
Eco.Handles.AbstractColumnConverter
    Eco.Handles.ColumnConverter
File

Columns.cs

See Also
Inheritance Hierarchy


ColumnConverter Methods

ColumnConverter Methods
Protected Methods
Collapse All

The methods of the ColumnConverter class are listed here.

Protected Methods
Name | Description
GetTargetType | This is GetTargetType, a member of class ColumnConverter.


ColumnConverter.GetTargetType Method

ColumnConverter.GetTargetType Method
ColumnConverter Class Eco.Handles Namespace See Also
Collapse All
C#
protected override Type GetTargetType();
Remarks

This is GetTargetType, a member of class ColumnConverter.

See Also
ColumnConverter Class
Eco.Handles Namespace


CurrencyManagerHandle Class

CurrencyManagerHandle Class
Inheritance Hierarchy See Also
Collapse All
C#
public sealed class CurrencyManagerHandle : AbstractCursorHandle;
Remarks

This is class Eco.Handles.CurrencyManagerHandle.

Inheritance Hierarchy
Eco.Handles.IElementHandle
Eco.Handles.INotifyOnIdle
    Eco.Handles.ElementHandle
    Eco.Handles.IRooted
        Eco.Handles.RootedHandle
            Eco.Handles.AbstractCursorHandle
                Eco.Handles.CurrencyManagerHandle
File

CurrencyManagerHandle.cs

See Also
Inheritance Hierarchy


CurrencyManagerHandle.CurrencyManagerHandle Constructor

CurrencyManagerHandle.CurrencyManagerHandle Constructor
CurrencyManagerHandle Class Eco.Handles Namespace See Also
Collapse All
C#
public CurrencyManagerHandle();
Remarks

This is CurrencyManagerHandle, a member of class CurrencyManagerHandle.

See Also
CurrencyManagerHandle Class
Eco.Handles Namespace


CurrencyManagerHandle Methods

CurrencyManagerHandle Methods
Protected Methods Public Methods
Collapse All

The methods of the CurrencyManagerHandle class are listed here.

Protected Methods
Name | Description
DeriveAndSubscribe | This is DeriveAndSubscribe, a member of class CurrencyManagerHandle.
Dispose | Disables the element handle and disposes it.
Top
Public Methods
Name | Description
CurrentElement | This is the overview for the CurrentElement method overload.


CurrentElement Method

CurrentElement Method

This is the overview for the CurrentElement method overload.

Overload List
Name | Description
CurrencyManagerHandle.CurrentElement (Control) | In a lot of cases users drop a CurrencyManagerHandle to get to the current element of a control. This static method allows for retrieving that without having to instantiate a CurrencyManagerHandle. (ITypedList)EcoWinFormHelper.ConnectedDataSource(control) is used to extract the actual object.
CurrencyManagerHandle.CurrentElement (ITypedList, Control) | Returns the current element of a control.


CurrencyManagerHandle.CurrentElement Method (Control)

CurrencyManagerHandle.CurrentElement Method (Control)
CurrencyManagerHandle Class Eco.Handles Namespace See Also
Collapse All

In a lot of cases users drop a CurrencyManagerHandle to get to the current element of a control.

This static method allows for retrieving that without having to instantiate a CurrencyManagerHandle.

(ITypedList)EcoWinFormHelper.ConnectedDataSource(control) is used to extract the actual object.

C#
public T CurrentElement<T>(
    Control c
);
See Also
CurrencyManagerHandle Class
Eco.Handles Namespace


CurrencyManagerHandle.CurrentElement Method (ITypedList, Control)

CurrencyManagerHandle.CurrentElement Method (ITypedList, Control)
CurrencyManagerHandle Class Eco.Handles Namespace See Also
Collapse All

Returns the current element of a control.

C#
public static IElement CurrentElement(
    ITypedList datasource,
    Control control
);
Remarks

In a lot of cases users drop a CurrencyManagerHandle to get to the current element of a control.

This static method allows for retrieving that without having to instantiate a CurrencyManagerHandle.

Exceptions
Exceptions | Description
ArgumentNullException | Thrown if either datasource or control is null.
ArgumentException | Thrown if no CurrencyManager can be found connecting the control with the handle.
See Also
CurrencyManagerHandle Class
Eco.Handles Namespace


CurrencyManagerHandle.DeriveAndSubscribe Method

CurrencyManagerHandle.DeriveAndSubscribe Method
CurrencyManagerHandle Class Eco.Handles Namespace See Also
Collapse All
C#
protected override void DeriveAndSubscribe(
    ISubscriber valueChangeSubscriber,
    ISubscriber resubscribeSubscriber
);
Remarks

This is DeriveAndSubscribe, a member of class CurrencyManagerHandle.

See Also
CurrencyManagerHandle Class
Eco.Handles Namespace


CurrencyManagerHandle.Dispose Method

CurrencyManagerHandle.Dispose Method
CurrencyManagerHandle Class Eco.Handles Namespace See Also
Collapse All

Disables the element handle and disposes it.

C#
protected override void Dispose(
    bool disposing
);
See Also
CurrencyManagerHandle Class
Eco.Handles Namespace


CurrencyManagerHandle Properties

CurrencyManagerHandle Properties
Public Properties Protected Properties
Collapse All

The properties of the CurrencyManagerHandle class are listed here.

Public Properties
Name | Description
BindingContext | Set this property to the Control whose BindingContext shall be used. If the Default BindingContext is to be used, it can be set to the ContainerControl, which is usually the Form.
BindingSource | In the case where a BindingSource is used between the handle and the visual control, this property must be set in addition to the RootHandle property.
CurrencyManager | The currencyManager used by the Handle.
Position | Setting the position will update the CurrencyManagers position, thus updating databound controls.
Top
Protected Properties
Name | Description
AutoQueue | This is AutoQueue, a member of class CurrencyManagerHandle.


CurrencyManagerHandle.AutoQueue Property

CurrencyManagerHandle.AutoQueue Property
CurrencyManagerHandle Class Eco.Handles Namespace See Also
Collapse All
C#
protected override bool AutoQueue;
Remarks

This is AutoQueue, a member of class CurrencyManagerHandle.

See Also
CurrencyManagerHandle Class
Eco.Handles Namespace


CurrencyManagerHandle.BindingContext Property

CurrencyManagerHandle.BindingContext Property
CurrencyManagerHandle Class Eco.Handles Namespace See Also
Collapse All

Set this property to the Control whose BindingContext shall be used. If the Default BindingContext is to be used, it can be set to the ContainerControl, which is usually the Form.

C#
public Control BindingContext;
See Also
CurrencyManagerHandle Class
Eco.Handles Namespace


CurrencyManagerHandle.BindingSource Property

CurrencyManagerHandle.BindingSource Property
CurrencyManagerHandle Class Eco.Handles Namespace See Also
Collapse All

In the case where a BindingSource is used between the handle and the visual control, this property must be set in addition to the RootHandle property.

C#
public BindingSource BindingSource;
See Also
CurrencyManagerHandle Class
Eco.Handles Namespace


CurrencyManagerHandle.CurrencyManager Property

CurrencyManagerHandle.CurrencyManager Property
CurrencyManagerHandle Class Eco.Handles Namespace See Also
Collapse All

The currencyManager used by the Handle.

C#
public CurrencyManager CurrencyManager;
Remarks

Note of bug in ListBox (or CurrencyManger). When the first element is created in a list, CurrencyManager will send a PositionChanged. The ListBox will raise an exception on this, since it has not yet updated its list to contain a element, and the expection will cut of notification to other controls subscribing to the same event.

See Also
CurrencyManagerHandle Class
Eco.Handles Namespace


CurrencyManagerHandle.Position Property

CurrencyManagerHandle.Position Property
CurrencyManagerHandle Class Eco.Handles Namespace See Also
Collapse All

Setting the position will update the CurrencyManagers position, thus updating databound controls.

C#
public override int Position;
See Also
CurrencyManagerHandle Class
Eco.Handles Namespace


CurrencyManagerHandle Events

CurrencyManagerHandle Events
Public Events
Collapse All

The events of the CurrencyManagerHandle class are listed here.

Public Events
Name | Description
BindingContextChanged | Called if the BindingContext changes.


CurrencyManagerHandle.BindingContextChanged Event

CurrencyManagerHandle.BindingContextChanged Event
CurrencyManagerHandle Class Eco.Handles Namespace See Also
Collapse All

Called if the BindingContext changes.

C#
public event EventHandler BindingContextChanged;
See Also
CurrencyManagerHandle Class
Eco.Handles Namespace


CursorHandle Class

CursorHandle Class
Inheritance Hierarchy See Also
Collapse All

This abstract ECO handle holds a reference to an ECO element and also an index "position" pointing to a specific item if the element is a collection.

C#
public sealed class CursorHandle : AbstractCursorHandle;
Remarks

Any ECO handle that uses this handle as its RootedHandle.RootHandle will not obtain the Element as its context but will instead obtain the element within (Element as IElementCollection) identified by the Position property. This also applies to data binding.

Inheritance Hierarchy
Eco.Handles.IElementHandle
Eco.Handles.INotifyOnIdle
    Eco.Handles.ElementHandle
    Eco.Handles.IRooted
        Eco.Handles.RootedHandle
            Eco.Handles.AbstractCursorHandle
                Eco.Handles.CursorHandle
File

CursorHandle.cs

See Also
Inheritance Hierarchy


CursorHandle.CursorHandle Constructor

CursorHandle.CursorHandle Constructor
CursorHandle Class Eco.Handles Namespace See Also
Collapse All

Creates a new instance of the handle.

C#
public CursorHandle();
See Also
CursorHandle Class
Eco.Handles Namespace


CursorHandle Properties

CursorHandle Properties
Public Properties
Collapse All

The properties of the CursorHandle class are listed here.

Public Properties
Name | Description
Position | If the element is a collection, this property identifies which element within the collection should be used as a context for other handles and for data binding.


CursorHandle.Position Property

CursorHandle.Position Property
CursorHandle Class Eco.Handles Namespace See Also
Collapse All

If the element is a collection, this property identifies which element within the collection should be used as a context for other handles and for data binding.

C#
public override int Position;
See Also
CursorHandle Class
Eco.Handles Namespace


DefaultEcoSpace Class

DefaultEcoSpace Class
Inheritance Hierarchy See Also
Collapse All
C#
public class DefaultEcoSpace : EcoSpace;
Remarks

This is class Eco.Handles.DefaultEcoSpace.

Inheritance Hierarchy
Eco.Handles.EcoSpaceBase
    Eco.Handles.EcoSpace
        Eco.Handles.DefaultEcoSpace
            Eco.Handles.PrototypeEcoSpace
File

DefaultEcoSpace.cs

See Also
Inheritance Hierarchy


DefaultEcoSpace Constructor

DefaultEcoSpace Constructor

This is the overview for the DefaultEcoSpace constructor overload.

Overload List
Name | Description
DefaultEcoSpace.DefaultEcoSpace () | This is DefaultEcoSpace, a member of class DefaultEcoSpace.
DefaultEcoSpace.DefaultEcoSpace (IEcoTypeSystem) | This is DefaultEcoSpace, a member of class DefaultEcoSpace.


DefaultEcoSpace.DefaultEcoSpace Constructor ()

DefaultEcoSpace.DefaultEcoSpace Constructor ()
DefaultEcoSpace Class Eco.Handles Namespace See Also
Collapse All
C#
public DefaultEcoSpace();
Remarks

This is DefaultEcoSpace, a member of class DefaultEcoSpace.

See Also
DefaultEcoSpace Class
Eco.Handles Namespace


DefaultEcoSpace.DefaultEcoSpace Constructor (IEcoTypeSystem)

DefaultEcoSpace.DefaultEcoSpace Constructor (IEcoTypeSystem)
DefaultEcoSpace Class Eco.Handles Namespace See Also
Collapse All
C#
protected DefaultEcoSpace(
    IEcoTypeSystem typeSystem
);
Remarks

This is DefaultEcoSpace, a member of class DefaultEcoSpace.

See Also
DefaultEcoSpace Class
Eco.Handles Namespace


DefaultEcoSpace Methods

DefaultEcoSpace Methods
Protected Methods Public Methods
Collapse All

The methods of the DefaultEcoSpace class are listed here.

Protected Methods
Name | Description
CreateExternalIdService | Creates the instance of IExternalIdService that will be hooked up to the other internal services such as IOclService
GetTypeSystemProvider | This is GetTypeSystemProvider, a member of class DefaultEcoSpace.
Top
Public Methods
Name | Description
Deserialize | Activates the ecospace with data from a stream.
GetEcoService | This is the overview for the GetEcoService method overload.
GetTypeSystemService | This is GetTypeSystemService, a member of class DefaultEcoSpace.
Initialize | This is Initialize, a member of class DefaultEcoSpace.
MakeTypeService | This is the overview for the MakeTypeService method overload.
PreAllocateGuidID | This is the overview for the PreAllocateGuidID method overload.
RegisterEcoService | This is the overview for the RegisterEcoService method overload.
Serialize | Writes the contents of the EcoSpace to a stream
SubscribeToActive | This is SubscribeToActive, a member of class DefaultEcoSpace.


DefaultEcoSpace.CreateExternalIdService Method

DefaultEcoSpace.CreateExternalIdService Method
DefaultEcoSpace Class Eco.Handles Namespace Example See Also
Collapse All

Creates the instance of IExternalIdService that will be hooked up to the other internal services such as IOclService

C#
protected virtual ExternalIdServiceBase CreateExternalIdService(
    IEcoTypeSystem typeSystem
);
Remarks

Overriding this method allows you to instantiate your own IExternalIdService and have it registered with all the other internal services that uses IExternalIdService

Example

This method will install the ExternalIdService implementation that uses the name of the class rather than the internal index of the class

Copy Code
protected override ExternalIdServiceBase CreateExternalIdService(IEcoTypeSystem typeSystem)
{
    return new ExternalIdServiceImpl_Name(typeSystem);
}
See Also
DefaultEcoSpace Class
Eco.Handles Namespace
Example


DefaultEcoSpace.Deserialize Method

DefaultEcoSpace.Deserialize Method
DefaultEcoSpace Class Eco.Handles Namespace See Also
Collapse All

Activates the ecospace with data from a stream.

C#
public override void Deserialize(
    Stream source
);
Remarks

The ecospace will become active, and will contain data from the supplied stream. This stream should have been produced by the Serialize method. It is an error to call this method on an active EcoSpace. The ecospace must have the exact same type as the ecospace that was serialized, or the result of this operation is undefined.

See Also
DefaultEcoSpace Class
Eco.Handles Namespace


GetEcoService Method

GetEcoService Method

This is the overview for the GetEcoService method overload.

Overload List
Name | Description
DefaultEcoSpace.GetEcoService () | This is GetEcoService, a member of class DefaultEcoSpace.
DefaultEcoSpace.GetEcoService (object) | This is GetEcoService, a member of class DefaultEcoSpace.
DefaultEcoSpace.GetEcoService (System.Type) | This is GetEcoService, a member of class DefaultEcoSpace.


DefaultEcoSpace.GetEcoService Method ()

DefaultEcoSpace.GetEcoService Method ()
DefaultEcoSpace Class Eco.Handles Namespace See Also
Collapse All
C#
public override T GetEcoService<T>();
Remarks

This is GetEcoService, a member of class DefaultEcoSpace.

See Also
DefaultEcoSpace Class
Eco.Handles Namespace


DefaultEcoSpace.GetEcoService Method (System.Type)

DefaultEcoSpace.GetEcoService Method (System.Type)
DefaultEcoSpace Class Eco.Handles Namespace See Also
Collapse All
C#
public override object GetEcoService(
    System.Type serviceType
);
Remarks

This is GetEcoService, a member of class DefaultEcoSpace.

See Also
DefaultEcoSpace Class
Eco.Handles Namespace


DefaultEcoSpace.GetEcoService Method (object)

DefaultEcoSpace.GetEcoService Method (object)
DefaultEcoSpace Class Eco.Handles Namespace See Also
Collapse All
C#
public override T GetEcoService<T>(
    object key
);
Remarks

This is GetEcoService, a member of class DefaultEcoSpace.

See Also
DefaultEcoSpace Class
Eco.Handles Namespace


DefaultEcoSpace.GetTypeSystemProvider Method

DefaultEcoSpace.GetTypeSystemProvider Method
DefaultEcoSpace Class Eco.Handles Namespace See Also
Collapse All
C#
protected virtual ITypeSystemService GetTypeSystemProvider();
Remarks

This is GetTypeSystemProvider, a member of class DefaultEcoSpace.

See Also
DefaultEcoSpace Class
Eco.Handles Namespace


DefaultEcoSpace.GetTypeSystemService Method

DefaultEcoSpace.GetTypeSystemService Method
DefaultEcoSpace Class Eco.Handles Namespace See Also
Collapse All
C#
public static ITypeSystemService GetTypeSystemService();
Remarks

This is GetTypeSystemService, a member of class DefaultEcoSpace.

See Also
DefaultEcoSpace Class
Eco.Handles Namespace


DefaultEcoSpace.Initialize Method

DefaultEcoSpace.Initialize Method
DefaultEcoSpace Class Eco.Handles Namespace See Also
Collapse All
C#
public virtual void Initialize(
    IEcoTypeSystem typeSystem
);
Remarks

This is Initialize, a member of class DefaultEcoSpace.

See Also
DefaultEcoSpace Class
Eco.Handles Namespace


MakeTypeService Method

MakeTypeService Method

This is the overview for the MakeTypeService method overload.

Overload List
Name | Description
DefaultEcoSpace.MakeTypeService (object, System.Type) | This is MakeTypeService, a member of class DefaultEcoSpace.
DefaultEcoSpace.MakeTypeService (System.Type) | This is MakeTypeService, a member of class DefaultEcoSpace.


DefaultEcoSpace.MakeTypeService Method (System.Type)

DefaultEcoSpace.MakeTypeService Method (System.Type)
DefaultEcoSpace Class Eco.Handles Namespace See Also
Collapse All
C#
public static ITypeSystemService MakeTypeService(
    System.Type ecoSpaceType
);
Remarks

This is MakeTypeService, a member of class DefaultEcoSpace.

See Also
DefaultEcoSpace Class
Eco.Handles Namespace


DefaultEcoSpace.MakeTypeService Method (object, System.Type)

DefaultEcoSpace.MakeTypeService Method (object, System.Type)
DefaultEcoSpace Class Eco.Handles Namespace See Also
Collapse All
C#
protected static ITypeSystemService MakeTypeService(
    object dummy,
    System.Type ecoSpaceType
);
Remarks

This is MakeTypeService, a member of class DefaultEcoSpace.

See Also
DefaultEcoSpace Class
Eco.Handles Namespace


PreAllocateGuidID Method

PreAllocateGuidID Method

This is the overview for the PreAllocateGuidID method overload.

Overload List
Name | Description
DefaultEcoSpace.PreAllocateGuidID (IEcoObject) | This is PreAllocateGuidID, a member of class DefaultEcoSpace.
DefaultEcoSpace.PreAllocateGuidID (IEnumerable<IEcoObject>) | This method generates a new GUID id for newly created objects. Use only if your persistencemechanism supports autogenerated GUID IDs


DefaultEcoSpace.PreAllocateGuidID Method (IEcoObject)

DefaultEcoSpace.PreAllocateGuidID Method (IEcoObject)
DefaultEcoSpace Class Eco.Handles Namespace See Also
Collapse All
C#
public void PreAllocateGuidID(
    IEcoObject obj
);
Remarks

This is PreAllocateGuidID, a member of class DefaultEcoSpace.

See Also
DefaultEcoSpace Class
Eco.Handles Namespace


DefaultEcoSpace.PreAllocateGuidID Method (IEnumerable<IEcoObject>)

DefaultEcoSpace.PreAllocateGuidID Method (IEnumerable<IEcoObject>)
DefaultEcoSpace Class Eco.Handles Namespace See Also
Collapse All

This method generates a new GUID id for newly created objects. Use only if your persistencemechanism supports autogenerated GUID IDs

C#
public void PreAllocateGuidID(
    IEnumerable<IEcoObject> list
);
Parameters
Parameters | Description
list | List of objects that should get preallocated GUID ids
Remarks

Normally, the ExternalIdService generates an id for new objects that is only valid in the same EcoSpace. When the object is saved the first time, the persistent ID can be generated. Using this method, you can allocate an ID that will become the persistent ID of the object. Only autogenerated GUID ids can be allocated this way. If your persistence mechanism uses some other persistent ID this will result in an exception when you try to save the object. A new id will only be allocated the first time this method is called for any given object.

This method does not work with the default ECO OR mapping since it uses database generated integers as primary keys.

See Also
DefaultEcoSpace Class
Eco.Handles Namespace


RegisterEcoService Method

RegisterEcoService Method

This is the overview for the RegisterEcoService method overload.

Overload List
Name | Description
DefaultEcoSpace.RegisterEcoService (object, T) | This is RegisterEcoService, a member of class DefaultEcoSpace.
DefaultEcoSpace.RegisterEcoService (T) | This is RegisterEcoService, a member of class DefaultEcoSpace.
DefaultEcoSpace.RegisterEcoService (Type, object) | This is RegisterEcoService, a member of class DefaultEcoSpace.


DefaultEcoSpace.RegisterEcoService Method (T)

DefaultEcoSpace.RegisterEcoService Method (T)
DefaultEcoSpace Class Eco.Handles Namespace See Also
Collapse All
C#
public override void RegisterEcoService<T>(
    T service
);
Remarks

This is RegisterEcoService, a member of class DefaultEcoSpace.

See Also
DefaultEcoSpace Class
Eco.Handles Namespace


DefaultEcoSpace.RegisterEcoService Method (Type, object)

DefaultEcoSpace.RegisterEcoService Method (Type, object)
DefaultEcoSpace Class Eco.Handles Namespace See Also
Collapse All
C#
public void RegisterEcoService(
    Type serviceType,
    object service
);
Remarks

This is RegisterEcoService, a member of class DefaultEcoSpace.

See Also
DefaultEcoSpace Class
Eco.Handles Namespace


DefaultEcoSpace.RegisterEcoService Method (object, T)

DefaultEcoSpace.RegisterEcoService Method (object, T)
DefaultEcoSpace Class Eco.Handles Namespace See Also
Collapse All
C#
public override void RegisterEcoService<T>(
    object key,
    T service
);
Remarks

This is RegisterEcoService, a member of class DefaultEcoSpace.

See Also
DefaultEcoSpace Class
Eco.Handles Namespace


DefaultEcoSpace.Serialize Method

DefaultEcoSpace.Serialize Method
DefaultEcoSpace Class Eco.Handles Namespace See Also
Collapse All

Writes the contents of the EcoSpace to a stream

C#
public override void Serialize(
    Stream target,
    EcoSpaceSerializationConfig config
);
Remarks

This will write the complete state of the EcoSpace to the stream. This includes all loaded objects, dirty objects, undo blocks, the change list. The ecospace can then be reconstructed by calling Deserialize with the same stream.

See Also
DefaultEcoSpace Class
Eco.Handles Namespace


DefaultEcoSpace.SubscribeToActive Method

DefaultEcoSpace.SubscribeToActive Method
DefaultEcoSpace Class Eco.Handles Namespace See Also
Collapse All
C#
public override void SubscribeToActive(
    ISubscriber subscriber
);
Remarks

This is SubscribeToActive, a member of class DefaultEcoSpace.

See Also
DefaultEcoSpace Class
Eco.Handles Namespace


DefaultEcoSpace Properties

DefaultEcoSpace Properties
Public Properties Protected Properties
Collapse All

The properties of the DefaultEcoSpace class are listed here.

Public Properties
Name | Description
ActionLanguage | The IActionLanguageService of the EcoSpace
Active |
AllowDeactivateDirty | This is AllowDeactivateDirty, a member of class DefaultEcoSpace.
AutoSubscriptionService | The IDirtyListService of the EcoSpace
CacheContent | The ICacheContentService of the EcoSpace
DefaultLinkFetchStrategy | This is DefaultLinkFetchStrategy, a member of class DefaultEcoSpace.
DirtyList | The IDirtyListService of the EcoSpace
EnforceStringLength | This is EnforceStringLength, a member of class DefaultEcoSpace.
Extents | The IExtentService of the EcoSpace
ExternalIds | The IExternalIdService of the EcoSpace
LinkFetchStrategy | This is LinkFetchStrategy, a member of class DefaultEcoSpace.
ObjectFactory | The IObjectFactoryService of the EcoSpace
Ocl | The IOclService of the EcoSpace
OclPs | The IOclPsService of the EcoSpace
OptimisticLocking | This is OptimisticLocking, a member of class DefaultEcoSpace.
Persistence | The IPersistenceService of the EcoSpace
PersistenceMapper | This is PersistenceMapper, a member of class DefaultEcoSpace.
Persistent | This is Persistent, a member of class DefaultEcoSpace.
States | The IStateService of the EcoSpace
TypeSystem | This is TypeSystem, a member of class DefaultEcoSpace.
TypeSystemService | The ITypeSystemService of the EcoSpace
Undo | The IUndoService of the EcoSpace
UpdateWholeObjects | This is UpdateWholeObjects, a member of class DefaultEcoSpace.
VariableFactory | The IVariableFactoryService of the EcoSpace
Versioning | The IVersionService of the EcoSpace
Top
Protected Properties
Name | Description
ChangeHandler | This is ChangeHandler, a member of class DefaultEcoSpace.
DefaultAutoSubscriptionServiceImpl | This is DefaultAutoSubscriptionServiceImpl, a member of class DefaultEcoSpace.
DefaultCacheContentService | This is DefaultCacheContentService, a member of class DefaultEcoSpace.
DefaultCacheImpl | This is DefaultCacheImpl, a member of class DefaultEcoSpace.
DefaultDirtyListService | This is DefaultDirtyListService, a member of class DefaultEcoSpace.
DefaultExtentService | This is DefaultExtentService, a member of class DefaultEcoSpace.
DefaultExternalIdService | This is DefaultExternalIdService, a member of class DefaultEcoSpace.
DefaultFetchHandlerImpl | This is DefaultFetchHandlerImpl, a member of class DefaultEcoSpace.
DefaultOptimisticLockHandlerImpl | This is DefaultOptimisticLockHandlerImpl, a member of class DefaultEcoSpace.
DefaultPersistenceHandlerImpl | This is DefaultPersistenceHandlerImpl, a member of class DefaultEcoSpace.
DefaultPersistenceService | This is DefaultPersistenceService, a member of class DefaultEcoSpace.
DefaultRegionFactoryImpl | This is DefaultRegionFactoryImpl, a member of class DefaultEcoSpace.
DefaultStateService | This is DefaultStateService, a member of class DefaultEcoSpace.
DefaultUndoImpl | This is DefaultUndoImpl, a member of class DefaultEcoSpace.
DefaultVariableFactoryService | This is DefaultVariableFactoryService, a member of class DefaultEcoSpace.
DefaultVersionService | This is DefaultVersionService, a member of class DefaultEcoSpace.
EcoServiceProvider | This is EcoServiceProvider, a member of class DefaultEcoSpace.
FrontsidePolicy | This is FrontsidePolicy, a member of class DefaultEcoSpace.
LocatorFactory | This is LocatorFactory, a member of class DefaultEcoSpace.
MandatoryParts | This is MandatoryParts, a member of class DefaultEcoSpace.
OclServicesImpl | This is OclServicesImpl, a member of class DefaultEcoSpace.
OptionalParts | This is OptionalParts, a member of class DefaultEcoSpace.


DefaultEcoSpace.ActionLanguage Property

DefaultEcoSpace.ActionLanguage Property
DefaultEcoSpace Class Eco.Handles Namespace See Also
Collapse All

The IActionLanguageService of the EcoSpace

C#
public IActionLanguageService ActionLanguage;
Remarks

The IActionLanguageService is used for executing ActionLanguage against the objects in the EcoSpace. The ActionLanguage is an ECO specific extension of OCL, with additions for method calls, assignment, etc. This propery is equivalent to retieving the IActionLanguageService from an IEcoServiceProvider using GetEcoService(typeof(IActionLanguageService)).

See Also
DefaultEcoSpace Class
Eco.Handles Namespace


DefaultEcoSpace.Active Property

DefaultEcoSpace.Active Property
DefaultEcoSpace Class Eco.Handles Namespace See Also
Collapse All
C#
public override bool Active;
Exceptions
Exceptions | Description
InvalidOperationException | Thrown if trying to set Active to false when there are dirty objects in the cache.
See Also
DefaultEcoSpace Class
Eco.Handles Namespace


DefaultEcoSpace.AllowDeactivateDirty Property

DefaultEcoSpace.AllowDeactivateDirty Property
DefaultEcoSpace Class Eco.Handles Namespace See Also
Collapse All
C#
public bool AllowDeactivateDirty;
Remarks

This is AllowDeactivateDirty, a member of class DefaultEcoSpace.

See Also
DefaultEcoSpace Class
Eco.Handles Namespace


DefaultEcoSpace.AutoSubscriptionService Property

DefaultEcoSpace.AutoSubscriptionService Property
DefaultEcoSpace Class Eco.Handles Namespace See Also
Collapse All

The IDirtyListService of the EcoSpace

C#
public IAutoSubscriptionService AutoSubscriptionService;
Remarks

The IDirtyListService is used for accessing the list of all dirty objects in an EcoSpace. This propery is equivalent to retieving the IDirtyListService from an IEcoServiceProvider using GetEcoService(typeof(IDirtyListService)).

See Also
DefaultEcoSpace Class
Eco.Handles Namespace


DefaultEcoSpace.CacheContent Property

DefaultEcoSpace.CacheContent Property
DefaultEcoSpace Class Eco.Handles Namespace See Also
Collapse All

The ICacheContentService of the EcoSpace

C#
public ICacheContentService CacheContent;
Remarks

The ICacheContentService is used to put data into the cache as if it had been fetched from the database. This propery is equivalent to retieving the ICacheContentService from an IEcoServiceProvider using GetEcoService(typeof(ICacheContentService)).

See Also
DefaultEcoSpace Class
Eco.Handles Namespace


DefaultEcoSpace.ChangeHandler Property

DefaultEcoSpace.ChangeHandler Property
DefaultEcoSpace Class Eco.Handles Namespace See Also
Collapse All
C#
protected ChangeHandlerImpl ChangeHandler;
Remarks

This is ChangeHandler, a member of class DefaultEcoSpace.

See Also
DefaultEcoSpace Class
Eco.Handles Namespace


DefaultEcoSpace.DefaultAutoSubscriptionServiceImpl Property

DefaultEcoSpace.DefaultAutoSubscriptionServiceImpl Property
DefaultEcoSpace Class Eco.Handles Namespace See Also
Collapse All
C#
protected AutoSubscriptionServiceImpl DefaultAutoSubscriptionServiceImpl;
Remarks

This is DefaultAutoSubscriptionServiceImpl, a member of class DefaultEcoSpace.

See Also
DefaultEcoSpace Class
Eco.Handles Namespace


DefaultEcoSpace.DefaultCacheContentService Property

DefaultEcoSpace.DefaultCacheContentService Property
DefaultEcoSpace Class Eco.Handles Namespace See Also
Collapse All
C#
protected CacheContentServiceImpl DefaultCacheContentService;
Remarks

This is DefaultCacheContentService, a member of class DefaultEcoSpace.

See Also
DefaultEcoSpace Class
Eco.Handles Namespace


DefaultEcoSpace.DefaultCacheImpl Property

DefaultEcoSpace.DefaultCacheImpl Property
DefaultEcoSpace Class Eco.Handles Namespace See Also
Collapse All
C#
protected Eco.Framework.Impl.CacheImpl DefaultCacheImpl;
Remarks

This is DefaultCacheImpl, a member of class DefaultEcoSpace.

See Also
DefaultEcoSpace Class
Eco.Handles Namespace


DefaultEcoSpace.DefaultDirtyListService Property

DefaultEcoSpace.DefaultDirtyListService Property
DefaultEcoSpace Class Eco.Handles Namespace See Also
Collapse All
C#
protected DirtyListServiceImpl DefaultDirtyListService;
Remarks

This is DefaultDirtyListService, a member of class DefaultEcoSpace.

See Also
DefaultEcoSpace Class
Eco.Handles Namespace


DefaultEcoSpace.DefaultExtentService Property

DefaultEcoSpace.DefaultExtentService Property
DefaultEcoSpace Class Eco.Handles Namespace See Also
Collapse All
C#
protected ExtentServiceImpl DefaultExtentService;
Remarks

This is DefaultExtentService, a member of class DefaultEcoSpace.

See Also
DefaultEcoSpace Class
Eco.Handles Namespace


DefaultEcoSpace.DefaultExternalIdService Property

DefaultEcoSpace.DefaultExternalIdService Property
DefaultEcoSpace Class Eco.Handles Namespace See Also
Collapse All
C#
protected ExternalIdServiceBase DefaultExternalIdService;
Remarks

This is DefaultExternalIdService, a member of class DefaultEcoSpace.

See Also
DefaultEcoSpace Class
Eco.Handles Namespace


DefaultEcoSpace.DefaultFetchHandlerImpl Property

DefaultEcoSpace.DefaultFetchHandlerImpl Property
DefaultEcoSpace Class Eco.Handles Namespace See Also
Collapse All
C#
protected FetchedBlockHandler DefaultFetchHandlerImpl;
Remarks

This is DefaultFetchHandlerImpl, a member of class DefaultEcoSpace.

See Also
DefaultEcoSpace Class
Eco.Handles Namespace


DefaultEcoSpace.DefaultLinkFetchStrategy Property

DefaultEcoSpace.DefaultLinkFetchStrategy Property
DefaultEcoSpace Class Eco.Handles Namespace See Also
Collapse All
C#
public FetchStrategy DefaultLinkFetchStrategy;
Remarks

This is DefaultLinkFetchStrategy, a member of class DefaultEcoSpace.

See Also
DefaultEcoSpace Class
Eco.Handles Namespace


DefaultEcoSpace.DefaultOptimisticLockHandlerImpl Property

DefaultEcoSpace.DefaultOptimisticLockHandlerImpl Property
DefaultEcoSpace Class Eco.Handles Namespace See Also
Collapse All
C#
protected Eco.FrameworkImpl.OptimisticLocking.OptimisticLockHandler DefaultOptimisticLockHandlerImpl;
Remarks

This is DefaultOptimisticLockHandlerImpl, a member of class DefaultEcoSpace.

See Also
DefaultEcoSpace Class
Eco.Handles Namespace


DefaultEcoSpace.DefaultPersistenceHandlerImpl Property

DefaultEcoSpace.DefaultPersistenceHandlerImpl Property
DefaultEcoSpace Class Eco.Handles Namespace See Also
Collapse All
C#
protected PersistenceHandlerImpl DefaultPersistenceHandlerImpl;
Remarks

This is DefaultPersistenceHandlerImpl, a member of class DefaultEcoSpace.

See Also
DefaultEcoSpace Class
Eco.Handles Namespace


DefaultEcoSpace.DefaultPersistenceService Property

DefaultEcoSpace.DefaultPersistenceService Property
DefaultEcoSpace Class Eco.Handles Namespace See Also
Collapse All
C#
protected PersistenceServiceImpl DefaultPersistenceService;
Remarks

This is DefaultPersistenceService, a member of class DefaultEcoSpace.

See Also
DefaultEcoSpace Class
Eco.Handles Namespace


DefaultEcoSpace.DefaultRegionFactoryImpl Property

DefaultEcoSpace.DefaultRegionFactoryImpl Property
DefaultEcoSpace Class Eco.Handles Namespace See Also
Collapse All
C#
protected Eco.FrameworkImpl.LockRegions.TBoldRegionFactory DefaultRegionFactoryImpl;
Remarks

This is DefaultRegionFactoryImpl, a member of class DefaultEcoSpace.

See Also
DefaultEcoSpace Class
Eco.Handles Namespace


DefaultEcoSpace.DefaultStateService Property

DefaultEcoSpace.DefaultStateService Property
DefaultEcoSpace Class Eco.Handles Namespace See Also
Collapse All
C#
protected StateServiceImpl DefaultStateService;
Remarks

This is DefaultStateService, a member of class DefaultEcoSpace.

See Also
DefaultEcoSpace Class
Eco.Handles Namespace


DefaultEcoSpace.DefaultUndoImpl Property

DefaultEcoSpace.DefaultUndoImpl Property
DefaultEcoSpace Class Eco.Handles Namespace See Also
Collapse All
C#
protected UndoImpl DefaultUndoImpl;
Remarks

This is DefaultUndoImpl, a member of class DefaultEcoSpace.

See Also
DefaultEcoSpace Class
Eco.Handles Namespace


DefaultEcoSpace.DefaultVariableFactoryService Property

DefaultEcoSpace.DefaultVariableFactoryService Property
DefaultEcoSpace Class Eco.Handles Namespace See Also
Collapse All
C#
protected VariableFactoryServiceImpl DefaultVariableFactoryService;
Remarks

This is DefaultVariableFactoryService, a member of class DefaultEcoSpace.

See Also
DefaultEcoSpace Class
Eco.Handles Namespace


DefaultEcoSpace.DefaultVersionService Property

DefaultEcoSpace.DefaultVersionService Property
DefaultEcoSpace Class Eco.Handles Namespace See Also
Collapse All
C#
protected VersionServiceImpl DefaultVersionService;
Remarks

This is DefaultVersionService, a member of class DefaultEcoSpace.

See Also
DefaultEcoSpace Class
Eco.Handles Namespace


DefaultEcoSpace.DirtyList Property

DefaultEcoSpace.DirtyList Property
DefaultEcoSpace Class Eco.Handles Namespace See Also
Collapse All

The IDirtyListService of the EcoSpace

C#
public IDirtyListService DirtyList;
Remarks

The IDirtyListService is used for accessing the list of all dirty objects in an EcoSpace. This propery is equivalent to retieving the IDirtyListService from an IEcoServiceProvider using GetEcoService(typeof(IDirtyListService)).

See Also
DefaultEcoSpace Class
Eco.Handles Namespace


DefaultEcoSpace.EcoServiceProvider Property

DefaultEcoSpace.EcoServiceProvider Property
DefaultEcoSpace Class Eco.Handles Namespace See Also
Collapse All
C#
protected EcoServiceProvider EcoServiceProvider;
Remarks

This is EcoServiceProvider, a member of class DefaultEcoSpace.

See Also
DefaultEcoSpace Class
Eco.Handles Namespace


DefaultEcoSpace.EnforceStringLength Property

DefaultEcoSpace.EnforceStringLength Property
DefaultEcoSpace Class Eco.Handles Namespace See Also
Collapse All
C#
public bool EnforceStringLength;
Remarks

This is EnforceStringLength, a member of class DefaultEcoSpace.

See Also
DefaultEcoSpace Class
Eco.Handles Namespace


DefaultEcoSpace.Extents Property

DefaultEcoSpace.Extents Property
DefaultEcoSpace Class Eco.Handles Namespace See Also
Collapse All

The IExtentService of the EcoSpace

C#
public IExtentService Extents;
Remarks

The IExtentService is used for accessing the list of all instances of a particular ECO class. This propery is equivalent to retieving the IExtentService from an IEcoServiceProvider using GetEcoService(typeof(IExtentService)).

See Also
DefaultEcoSpace Class
Eco.Handles Namespace


DefaultEcoSpace.ExternalIds Property

DefaultEcoSpace.ExternalIds Property
DefaultEcoSpace Class Eco.Handles Namespace See Also
Collapse All

The IExternalIdService of the EcoSpace

C#
public IExternalIdService ExternalIds;
Remarks

The IExternalIdService is used to retrieve external id for ECO objects. These ids are useful in e.g. url:s. This propery is equivalent to retieving the IExternalIdService from an IEcoServiceProvider using GetEcoService(typeof(IExternalIdService)).

See Also
DefaultEcoSpace Class
Eco.Handles Namespace


DefaultEcoSpace.FrontsidePolicy Property

DefaultEcoSpace.FrontsidePolicy Property
DefaultEcoSpace Class Eco.Handles Namespace See Also
Collapse All
C#
protected Eco.Framework.Impl.Frontside.DefaultFrontsidePolicy FrontsidePolicy;
Remarks

This is FrontsidePolicy, a member of class DefaultEcoSpace.

See Also
DefaultEcoSpace Class
Eco.Handles Namespace


DefaultEcoSpace.LinkFetchStrategy Property

DefaultEcoSpace.LinkFetchStrategy Property
DefaultEcoSpace Class Eco.Handles Namespace See Also
Collapse All
C#
public LinkFetchStrategy LinkFetchStrategy;
Remarks

This is LinkFetchStrategy, a member of class DefaultEcoSpace.

See Also
DefaultEcoSpace Class
Eco.Handles Namespace


DefaultEcoSpace.LocatorFactory Property

DefaultEcoSpace.LocatorFactory Property
DefaultEcoSpace Class Eco.Handles Namespace See Also
Collapse All
C#
protected Eco.Framework.Impl.Frontside.LocatorFactory LocatorFactory;
Remarks

This is LocatorFactory, a member of class DefaultEcoSpace.

See Also
DefaultEcoSpace Class
Eco.Handles Namespace


DefaultEcoSpace.MandatoryParts Property

DefaultEcoSpace.MandatoryParts Property
DefaultEcoSpace Class Eco.Handles Namespace See Also
Collapse All
C#
protected EcoSpacePartList MandatoryParts;
Remarks

This is MandatoryParts, a member of class DefaultEcoSpace.

See Also
DefaultEcoSpace Class
Eco.Handles Namespace


DefaultEcoSpace.ObjectFactory Property

DefaultEcoSpace.ObjectFactory Property
DefaultEcoSpace Class Eco.Handles Namespace See Also
Collapse All

The IObjectFactoryService of the EcoSpace

C#
public IObjectFactoryService ObjectFactory;
Remarks

The IObjectFactoryService is used to create new ECO objects. Its primary use is when the class is not statically known so that, e.g., new Person(ecospace) cannot be called. This propery is equivalent to retieving the IObjectFactoryService from an IEcoServiceProvider using GetEcoService(typeof(IObjectFactoryService)).

See Also
DefaultEcoSpace Class
Eco.Handles Namespace


DefaultEcoSpace.Ocl Property

DefaultEcoSpace.Ocl Property
DefaultEcoSpace Class Eco.Handles Namespace See Also
Collapse All

The IOclService of the EcoSpace

C#
public IOclService Ocl;
Remarks

The IOclService is used for evaluating OCL expressions against the objects in the EcoSpace. This propery is equivalent to retieving the IOclService from an IEcoServiceProvider using GetEcoService(typeof(IOclService)).

See Also
DefaultEcoSpace Class
Eco.Handles Namespace


DefaultEcoSpace.OclPs Property

DefaultEcoSpace.OclPs Property
DefaultEcoSpace Class Eco.Handles Namespace See Also
Collapse All

The IOclPsService of the EcoSpace

C#
public IOclPsService OclPs;
Remarks

The IOclPsService is used for evaluating OCL expression against the database, or other persistent storage. This propery is equivalent to retieving the IOclPsService from an IEcoServiceProvider using GetEcoService(typeof(IOclPsService)).

See Also
DefaultEcoSpace Class
Eco.Handles Namespace


DefaultEcoSpace.OclServicesImpl Property

DefaultEcoSpace.OclServicesImpl Property
DefaultEcoSpace Class Eco.Handles Namespace See Also
Collapse All
C#
protected OclServicesImpl OclServicesImpl;
Remarks

This is OclServicesImpl, a member of class DefaultEcoSpace.

See Also
DefaultEcoSpace Class
Eco.Handles Namespace


DefaultEcoSpace.OptimisticLocking Property

DefaultEcoSpace.OptimisticLocking Property
DefaultEcoSpace Class Eco.Handles Namespace See Also
Collapse All
C#
public bool OptimisticLocking;
Remarks

This is OptimisticLocking, a member of class DefaultEcoSpace.

See Also
DefaultEcoSpace Class
Eco.Handles Namespace


DefaultEcoSpace.OptionalParts Property

DefaultEcoSpace.OptionalParts Property
DefaultEcoSpace Class Eco.Handles Namespace See Also
Collapse All
C#
protected EcoSpacePartList OptionalParts;
Remarks

This is OptionalParts, a member of class DefaultEcoSpace.

See Also
DefaultEcoSpace Class
Eco.Handles Namespace


DefaultEcoSpace.Persistence Property

DefaultEcoSpace.Persistence Property
DefaultEcoSpace Class Eco.Handles Namespace See Also
Collapse All

The IPersistenceService of the EcoSpace

C#
public IPersistenceService Persistence;
Remarks

The IPersistenceService contains operations for saving, loading, and unloading ECO objects. This propery is equivalent to retieving the IPersistenceService from an IEcoServiceProvider using GetEcoService(typeof(IPersistenceService)).

See Also
DefaultEcoSpace Class
Eco.Handles Namespace


DefaultEcoSpace.PersistenceMapper Property

DefaultEcoSpace.PersistenceMapper Property
DefaultEcoSpace Class Eco.Handles Namespace See Also
Collapse All
C#
public PersistenceMapper PersistenceMapper;
Remarks

This is PersistenceMapper, a member of class DefaultEcoSpace.

See Also
DefaultEcoSpace Class
Eco.Handles Namespace


DefaultEcoSpace.Persistent Property

DefaultEcoSpace.Persistent Property
DefaultEcoSpace Class Eco.Handles Namespace See Also
Collapse All
C#
public bool Persistent;
Remarks

This is Persistent, a member of class DefaultEcoSpace.

See Also
DefaultEcoSpace Class
Eco.Handles Namespace


DefaultEcoSpace.States Property

DefaultEcoSpace.States Property
DefaultEcoSpace Class Eco.Handles Namespace See Also
Collapse All

The IStateService of the EcoSpace

C#
public IStateService States;
Remarks

The IStateService exposes functionality to query if an ECO object or property contains changes that have not been written to the database or other persistent storage. This propery is equivalent to retieving the IStateService from an IEcoServiceProvider using GetEcoService(typeof(IStateService)).

See Also
DefaultEcoSpace Class
Eco.Handles Namespace


DefaultEcoSpace.TypeSystem Property

DefaultEcoSpace.TypeSystem Property
DefaultEcoSpace Class Eco.Handles Namespace See Also
Collapse All
C#
public override IEcoTypeSystem TypeSystem;
Remarks

This is TypeSystem, a member of class DefaultEcoSpace.

See Also
DefaultEcoSpace Class
Eco.Handles Namespace


DefaultEcoSpace.TypeSystemService Property

DefaultEcoSpace.TypeSystemService Property
DefaultEcoSpace Class Eco.Handles Namespace See Also
Collapse All

The ITypeSystemService of the EcoSpace

C#
public ITypeSystemService TypeSystemService;
Remarks

The ITypeSystemService is used for inspecting the classes, attributes, etc, that make up the model for the objects contained in the EcoSpace. This propery is equivalent to retieving the ITypeSystemService from an IEcoServiceProvider using GetEcoService(typeof(ITypeSystemService)).

See Also
DefaultEcoSpace Class
Eco.Handles Namespace


DefaultEcoSpace.Undo Property

DefaultEcoSpace.Undo Property
DefaultEcoSpace Class Eco.Handles Namespace See Also
Collapse All

The IUndoService of the EcoSpace

C#
public IUndoService Undo;
Remarks

The IUndoService contains methods for undoing - and redoing - changes made to ECO objects. This propery is equivalent to retieving the IUndoService from an IEcoServiceProvider using GetEcoService(typeof(IUndoService)).

See Also
DefaultEcoSpace Class
Eco.Handles Namespace


DefaultEcoSpace.UpdateWholeObjects Property

DefaultEcoSpace.UpdateWholeObjects Property
DefaultEcoSpace Class Eco.Handles Namespace See Also
Collapse All
C#
public bool UpdateWholeObjects;
Remarks

This is UpdateWholeObjects, a member of class DefaultEcoSpace.

See Also
DefaultEcoSpace Class
Eco.Handles Namespace


DefaultEcoSpace.VariableFactory Property

DefaultEcoSpace.VariableFactory Property
DefaultEcoSpace Class Eco.Handles Namespace See Also
Collapse All

The IVariableFactoryService of the EcoSpace

C#
public IVariableFactoryService VariableFactory;
Remarks

The IVariableFactoryService contains methods for creating free standing ECO elements that can be used as variables. The elements returned will implement IElement, and any other applicable interfaces from the Eco.ObjectRepresentation namespace. This propery is equivalent to retieving the IVariableFactoryService from an IEcoServiceProvider using GetEcoService(typeof(IVariableFactoryService)).

See Also
DefaultEcoSpace Class
Eco.Handles Namespace


DefaultEcoSpace.Versioning Property

DefaultEcoSpace.Versioning Property
DefaultEcoSpace Class Eco.Handles Namespace See Also
Collapse All

The IVersionService of the EcoSpace

C#
public IVersionService Versioning;
Remarks

The IVersionService is used for accessing historical values of ECO objects. This propery is equivalent to retieving the IVersionService from an IEcoServiceProvider using GetEcoService(typeof(IVersionService)).

See Also
DefaultEcoSpace Class
Eco.Handles Namespace


DeriveEventArgs Class

DeriveEventArgs Class
Inheritance Hierarchy See Also
Collapse All
C#
public sealed class DeriveEventArgs : EventArgs;
Remarks

This is class Eco.Handles.DeriveEventArgs.

Inheritance Hierarchy
Eco.Handles.DeriveEventArgs
File

ControlPack.cs

See Also
Inheritance Hierarchy


DeriveEventArgs.DeriveEventArgs Constructor

DeriveEventArgs.DeriveEventArgs Constructor
DeriveEventArgs Class Eco.Handles Namespace See Also
Collapse All
C#
public DeriveEventArgs(
    string name,
    IEcoServiceProvider serviceProvider,
    IElement rootElement,
    ISubscriber valueChangeSubscriber,
    ISubscriber resubscribeSubscriber,
    IStaticContext staticContext
);
Remarks

This is DeriveEventArgs, a member of class DeriveEventArgs.

See Also
DeriveEventArgs Class
Eco.Handles Namespace


DeriveEventArgs Properties

DeriveEventArgs Properties
Public Properties
Collapse All

The properties of the DeriveEventArgs class are listed here.

Public Properties
Name | Description
Name | The name given to the property added to the binding list.
OclService | This is OclService, a member of class DeriveEventArgs.
ResubscribeSubscriber | This is ResubscribeSubscriber, a member of class DeriveEventArgs.
ResultElement | This is ResultElement, a member of class DeriveEventArgs.
RootElement | This is RootElement, a member of class DeriveEventArgs.
ServiceProvider | This is ServiceProvider, a member of class DeriveEventArgs.
StaticContext | This is StaticContext, a member of class DeriveEventArgs.
ValueChangeSubscriber | This is ValueChangeSubscriber, a member of class DeriveEventArgs.


DeriveEventArgs.Name Property

DeriveEventArgs.Name Property
DeriveEventArgs Class Eco.Handles Namespace See Also
Collapse All

The name given to the property added to the binding list.

C#
public string Name;
Remarks

This name is used when binding to a data aware control.

See Also
DeriveEventArgs Class
Eco.Handles Namespace


DeriveEventArgs.OclService Property

DeriveEventArgs.OclService Property
DeriveEventArgs Class Eco.Handles Namespace See Also
Collapse All
C#
public IOclService OclService;
Remarks

This is OclService, a member of class DeriveEventArgs.

See Also
DeriveEventArgs Class
Eco.Handles Namespace


DeriveEventArgs.ResubscribeSubscriber Property

DeriveEventArgs.ResubscribeSubscriber Property
DeriveEventArgs Class Eco.Handles Namespace See Also
Collapse All
C#
public ISubscriber ResubscribeSubscriber;
Remarks

This is ResubscribeSubscriber, a member of class DeriveEventArgs.

See Also
DeriveEventArgs Class
Eco.Handles Namespace


DeriveEventArgs.ResultElement Property

DeriveEventArgs.ResultElement Property
DeriveEventArgs Class Eco.Handles Namespace See Also
Collapse All
C#
public IElement ResultElement;
Remarks

This is ResultElement, a member of class DeriveEventArgs.

See Also
DeriveEventArgs Class
Eco.Handles Namespace


DeriveEventArgs.RootElement Property

DeriveEventArgs.RootElement Property
DeriveEventArgs Class Eco.Handles Namespace See Also
Collapse All
C#
public IElement RootElement;
Remarks

This is RootElement, a member of class DeriveEventArgs.

See Also
DeriveEventArgs Class
Eco.Handles Namespace


DeriveEventArgs.ServiceProvider Property

DeriveEventArgs.ServiceProvider Property
DeriveEventArgs Class Eco.Handles Namespace See Also
Collapse All
C#
public IEcoServiceProvider ServiceProvider;
Remarks

This is ServiceProvider, a member of class DeriveEventArgs.

See Also
DeriveEventArgs Class
Eco.Handles Namespace


DeriveEventArgs.StaticContext Property

DeriveEventArgs.StaticContext Property
DeriveEventArgs Class Eco.Handles Namespace See Also
Collapse All
C#
public IStaticContext StaticContext;
Remarks

This is StaticContext, a member of class DeriveEventArgs.

See Also
DeriveEventArgs Class
Eco.Handles Namespace


DeriveEventArgs.ValueChangeSubscriber Property

DeriveEventArgs.ValueChangeSubscriber Property
DeriveEventArgs Class Eco.Handles Namespace See Also
Collapse All
C#
public ISubscriber ValueChangeSubscriber;
Remarks

This is ValueChangeSubscriber, a member of class DeriveEventArgs.

See Also
DeriveEventArgs Class
Eco.Handles Namespace


DescriptorFactory Class

DescriptorFactory Class
Inheritance Hierarchy See Also
Collapse All
C#
public sealed class DescriptorFactory;
Remarks

This is class Eco.Handles.DescriptorFactory.

Inheritance Hierarchy
Eco.Handles.DescriptorFactory
File

ControlPack.cs

See Also
Inheritance Hierarchy


DescriptorFactory.DescriptorFactory Constructor

DescriptorFactory.DescriptorFactory Constructor
DescriptorFactory Class Eco.Handles Namespace See Also
Collapse All
C#
public DescriptorFactory(
    IStaticContext staticContext,
    INestingProvider nestings,
    Boolean addDefaultNestings,
    MemberVisibility memberVisibility,
    bool designMode,
    bool supportSorting,
    FilterMode filterMode
);
Remarks

This is DescriptorFactory, a member of class DescriptorFactory.

See Also
DescriptorFactory Class
Eco.Handles Namespace


DescriptorFactory Methods

DescriptorFactory Methods
Public Methods
Collapse All

The methods of the DescriptorFactory class are listed here.

Public Methods
Name | Description
GetDescriptor | This is GetDescriptor, a member of class DescriptorFactory.


DescriptorFactory.GetDescriptor Method

DescriptorFactory.GetDescriptor Method
DescriptorFactory Class Eco.Handles Namespace See Also
Collapse All
C#
public RenderedTupleDescriptor GetDescriptor(
    IClassifier staticType,
    string nestingName
);
Remarks

This is GetDescriptor, a member of class DescriptorFactory.

See Also
DescriptorFactory Class
Eco.Handles Namespace


DisplayQueue Class

DisplayQueue Class
Inheritance Hierarchy See Also
Collapse All
C#
public abstract class DisplayQueue;
Remarks

This is class Eco.Handles.DisplayQueue.

Inheritance Hierarchy
Eco.Handles.DisplayQueue
File

ControlPack.cs

See Also
Inheritance Hierarchy


DisplayQueue Methods

DisplayQueue Methods
Public Methods
Collapse All

The methods of the DisplayQueue class are listed here.

Public Methods
Name | Description
Add | This is Add, a member of class DisplayQueue.
DisplayAll | This is DisplayAll, a member of class DisplayQueue.
OnIdle | This is OnIdle, a member of class DisplayQueue.
Remove | This is Remove, a member of class DisplayQueue.


DisplayQueue.Add Method

DisplayQueue.Add Method
DisplayQueue Class Eco.Handles Namespace See Also
Collapse All
C#
public static void Add(
    INotifyOnIdle displayable
);
Remarks

This is Add, a member of class DisplayQueue.

See Also
DisplayQueue Class
Eco.Handles Namespace


DisplayQueue.DisplayAll Method

DisplayQueue.DisplayAll Method
DisplayQueue Class Eco.Handles Namespace See Also
Collapse All
C#
public static void DisplayAll();
Remarks

This is DisplayAll, a member of class DisplayQueue.

See Also
DisplayQueue Class
Eco.Handles Namespace


DisplayQueue.OnIdle Method

DisplayQueue.OnIdle Method
DisplayQueue Class Eco.Handles Namespace See Also
Collapse All
C#
public static void OnIdle(
    object sender,
    EventArgs args
);
Remarks

This is OnIdle, a member of class DisplayQueue.

See Also
DisplayQueue Class
Eco.Handles Namespace


DisplayQueue.Remove Method

DisplayQueue.Remove Method
DisplayQueue Class Eco.Handles Namespace See Also
Collapse All
C#
public static void Remove(
    INotifyOnIdle displayable
);
Remarks

This is Remove, a member of class DisplayQueue.

See Also
DisplayQueue Class
Eco.Handles Namespace


DisplayQueue Events

DisplayQueue Events
Public Events
Collapse All

The events of the DisplayQueue class are listed here.

Public Events
Name | Description
OnQueueNotEmpty | This is OnQueueNotEmpty, a member of class DisplayQueue.


DisplayQueue.OnQueueNotEmpty Event

DisplayQueue.OnQueueNotEmpty Event
DisplayQueue Class Eco.Handles Namespace See Also
Collapse All
C#
public static event DisplayQueueNotEmptyEventHandler OnQueueNotEmpty;
Remarks

This is OnQueueNotEmpty, a member of class DisplayQueue.

See Also
DisplayQueue Class
Eco.Handles Namespace


EcoSpace Class

EcoSpace Class
Inheritance Hierarchy See Also
Collapse All
C#
public abstract class EcoSpace : EcoSpaceBase, IEcoServiceProvider, IDisposable;
Remarks

This is class Eco.Handles.EcoSpace.

Inheritance Hierarchy
Eco.Handles.EcoSpaceBase
    Eco.Handles.EcoSpace
        Eco.Handles.DefaultEcoSpace
File

EcoSpace.cs

See Also
Inheritance Hierarchy


EcoSpace.EcoSpace Constructor

EcoSpace.EcoSpace Constructor
EcoSpace Class Eco.Handles Namespace See Also
Collapse All
C#
public EcoSpace();
Remarks

This is EcoSpace, a member of class EcoSpace.

See Also
EcoSpace Class
Eco.Handles Namespace


EcoSpace Methods

EcoSpace Methods
Public Methods
Collapse All

The methods of the EcoSpace class are listed here.

Public Methods
Name | Description
Deserialize | Activates the ecospace with data from a stream.
Dispose | This is the overview for the Dispose method overload.
GetEcoService | This is the overview for the GetEcoService method overload.
GetEcoSpaceType | Returns the EcoSpace type with a specific name, if it is registered.
RegisterEcoService | This is the overview for the RegisterEcoService method overload.
RegisterEcoSpaceType | Registers an EcoSpace type so that it may later be retieve by name using GetEcoSpaceType().
Serialize | This is the overview for the Serialize method overload.
SubscribeToActive | This is SubscribeToActive, a member of class EcoSpace.


EcoSpace.Deserialize Method

EcoSpace.Deserialize Method
EcoSpace Class Eco.Handles Namespace See Also
Collapse All

Activates the ecospace with data from a stream.

C#
public abstract void Deserialize(
    Stream source
);
Remarks

The ecospace will become active, and will contain data from the supplied stream. This stream should have been produced by the Serialize method. It is an error to call this method on an active EcoSpace. The ecospace must have the exact same type as the ecospace that was serialized, or the result of this operation is undefined.

See Also
EcoSpace Class
Eco.Handles Namespace


Dispose Method

Dispose Method

This is the overview for the Dispose method overload.

Overload List
Name | Description
EcoSpace.Dispose () | This is Dispose, a member of class EcoSpace.
EcoSpace.Dispose (Boolean) | This is Dispose, a member of class EcoSpace.


EcoSpace.Dispose Method ()

EcoSpace.Dispose Method ()
EcoSpace Class Eco.Handles Namespace See Also
Collapse All
C#
public void Dispose();
Remarks

This is Dispose, a member of class EcoSpace.

See Also
EcoSpace Class
Eco.Handles Namespace


EcoSpace.Dispose Method (Boolean)

EcoSpace.Dispose Method (Boolean)
EcoSpace Class Eco.Handles Namespace See Also
Collapse All
C#
protected override void Dispose(
    Boolean disposing
);
Remarks

This is Dispose, a member of class EcoSpace.

See Also
EcoSpace Class
Eco.Handles Namespace


GetEcoService Method

GetEcoService Method

This is the overview for the GetEcoService method overload.

Overload List
Name | Description
EcoSpace.GetEcoService () | This is GetEcoService, a member of class EcoSpace.
EcoSpace.GetEcoService (object) | This is GetEcoService, a member of class EcoSpace.
EcoSpace.GetEcoService (System.Type) | This is GetEcoService, a member of class EcoSpace.


EcoSpace.GetEcoService Method ()

EcoSpace.GetEcoService Method ()
EcoSpace Class Eco.Handles Namespace See Also
Collapse All
C#
public abstract T GetEcoService<T>() where T : class;
Remarks

This is GetEcoService, a member of class EcoSpace.

See Also
EcoSpace Class
Eco.Handles Namespace


EcoSpace.GetEcoService Method (System.Type)

EcoSpace.GetEcoService Method (System.Type)
EcoSpace Class Eco.Handles Namespace See Also
Collapse All
C#
public abstract object GetEcoService(
    System.Type serviceType
);
Remarks

This is GetEcoService, a member of class EcoSpace.

See Also
EcoSpace Class
Eco.Handles Namespace


EcoSpace.GetEcoService Method (object)

EcoSpace.GetEcoService Method (object)
EcoSpace Class Eco.Handles Namespace See Also
Collapse All
C#
public abstract T GetEcoService<T>(
    object key
) where T: class;
Remarks

This is GetEcoService, a member of class EcoSpace.

See Also
EcoSpace Class
Eco.Handles Namespace


EcoSpace.GetEcoSpaceType Method

EcoSpace.GetEcoSpaceType Method
EcoSpace Class Eco.Handles Namespace See Also
Collapse All

Returns the EcoSpace type with a specific name, if it is registered.

C#
public static System.Type GetEcoSpaceType(
    string name
);
Remarks

The result will be the type of the EcoSpace class with the given, unqualified, name. In run time, this class must have been previously registered using the RegisterEcoSpaceType method. GetEcoSpaceType is primarily intended to be called from the RootHandles (ReferenceHandle and VariableHandle) to resolve the EcoSpaceType property.

See Also
EcoSpace Class
Eco.Handles Namespace


RegisterEcoService Method

RegisterEcoService Method

This is the overview for the RegisterEcoService method overload.

Overload List
Name | Description
EcoSpace.RegisterEcoService (object, T) | This is RegisterEcoService, a member of class EcoSpace.
EcoSpace.RegisterEcoService (T) | This is RegisterEcoService, a member of class EcoSpace.


EcoSpace.RegisterEcoService Method (T)

EcoSpace.RegisterEcoService Method (T)
EcoSpace Class Eco.Handles Namespace See Also
Collapse All
C#
public abstract void RegisterEcoService<T>(
    T service
) where T : class;
Remarks

This is RegisterEcoService, a member of class EcoSpace.

See Also
EcoSpace Class
Eco.Handles Namespace


EcoSpace.RegisterEcoService Method (object, T)

EcoSpace.RegisterEcoService Method (object, T)
EcoSpace Class Eco.Handles Namespace See Also
Collapse All
C#
public abstract void RegisterEcoService<T>(
    object key,
    T service
) where T : class;
Remarks

This is RegisterEcoService, a member of class EcoSpace.

See Also
EcoSpace Class
Eco.Handles Namespace


EcoSpace.RegisterEcoSpaceType Method

EcoSpace.RegisterEcoSpaceType Method
EcoSpace Class Eco.Handles Namespace See Also
Collapse All

Registers an EcoSpace type so that it may later be retieve by name using GetEcoSpaceType().

C#
public static void RegisterEcoSpaceType(
    System.Type t
);
See Also
EcoSpace Class
Eco.Handles Namespace


Serialize Method

Serialize Method

This is the overview for the Serialize method overload.

Overload List
Name | Description
EcoSpace.Serialize (Stream) | This is Serialize, a member of class EcoSpace.
EcoSpace.Serialize (Stream, EcoSpaceSerializationConfig) | Writes the contents of the EcoSpace to a stream


EcoSpace.Serialize Method (Stream)

EcoSpace.Serialize Method (Stream)
EcoSpace Class Eco.Handles Namespace See Also
Collapse All
C#
public void Serialize(
    Stream target
);
Remarks

This is Serialize, a member of class EcoSpace.

See Also
EcoSpace Class
Eco.Handles Namespace


EcoSpace.Serialize Method (Stream, EcoSpaceSerializationConfig)

EcoSpace.Serialize Method (Stream, EcoSpaceSerializationConfig)
EcoSpace Class Eco.Handles Namespace See Also
Collapse All

Writes the contents of the EcoSpace to a stream

C#
public abstract void Serialize(
    Stream target,
    EcoSpaceSerializationConfig config
);
Remarks

This will write the complete state of the EcoSpace to the stream. This includes all loaded objects, dirty objects, undo blocks, the change list. The ecospace can then be reconstructed by calling Deserialize with the same stream.

See Also
EcoSpace Class
Eco.Handles Namespace


EcoSpace.SubscribeToActive Method

EcoSpace.SubscribeToActive Method
EcoSpace Class Eco.Handles Namespace See Also
Collapse All
C#
public abstract void SubscribeToActive(
    ISubscriber subscriber
);
Remarks

This is SubscribeToActive, a member of class EcoSpace.

See Also
EcoSpace Class
Eco.Handles Namespace


EcoSpace Properties

EcoSpace Properties
Public Properties
Collapse All

The properties of the EcoSpace class are listed here.

Public Properties
Name | Description
Active | This is Active, a member of class EcoSpace.
CreateTime | This is CreateTime, a member of class EcoSpace.
EcoSpaceTypeLookupService | Used to find EcoSpace types. For internal use.
TypeSystem | This is TypeSystem, a member of class EcoSpace.


EcoSpace.Active Property

EcoSpace.Active Property
EcoSpace Class Eco.Handles Namespace See Also
Collapse All
C#
public abstract bool Active;
Remarks

This is Active, a member of class EcoSpace.

See Also
EcoSpace Class
Eco.Handles Namespace


EcoSpace.CreateTime Property

EcoSpace.CreateTime Property
EcoSpace Class Eco.Handles Namespace See Also
Collapse All
C#
public DateTime CreateTime;
Remarks

This is CreateTime, a member of class EcoSpace.

See Also
EcoSpace Class
Eco.Handles Namespace


EcoSpace.EcoSpaceTypeLookupService Property

EcoSpace.EcoSpaceTypeLookupService Property
EcoSpace Class Eco.Handles Namespace See Also
Collapse All

Used to find EcoSpace types. For internal use.

C#
public static IEcoSpaceTypeLookupService EcoSpaceTypeLookupService;
Remarks

This is used in design time to use IDE specific methods of searching for suitable EcoSpace types. It will affect the result of GetEcoSpaceType. For internal use.

See Also
EcoSpace Class
Eco.Handles Namespace


EcoSpace.TypeSystem Property

EcoSpace.TypeSystem Property
EcoSpace Class Eco.Handles Namespace See Also
Collapse All
C#
public abstract IEcoTypeSystem TypeSystem;
Remarks

This is TypeSystem, a member of class EcoSpace.

See Also
EcoSpace Class
Eco.Handles Namespace


EcoSpaceBase Class

EcoSpaceBase Class
Inheritance Hierarchy See Also
Collapse All
C#
public abstract class EcoSpaceBase : Component;
Remarks

This is class Eco.Handles.EcoSpaceBase.

Inheritance Hierarchy
Eco.Handles.EcoSpaceBase
    Eco.Handles.EcoSpace
File

EcoSpaceBase.cs

See Also
Inheritance Hierarchy


EcoSpaceBase Fields

EcoSpaceBase Fields
Public Fields
Collapse All

The fields of the EcoSpaceBase class are listed here.

Public Fields
Name | Description
GetTypeSystemServiceName | This is GetTypeSystemServiceName, a member of class EcoSpaceBase.


EcoSpaceBase.GetTypeSystemServiceName Field

EcoSpaceBase.GetTypeSystemServiceName Field
EcoSpaceBase Class Eco.Handles Namespace See Also
Collapse All
C#
public const string GetTypeSystemServiceName = "GetTypeSystemService";
Remarks

This is GetTypeSystemServiceName, a member of class EcoSpaceBase.

See Also
EcoSpaceBase Class
Eco.Handles Namespace


EcoSpaceBase Methods

EcoSpaceBase Methods
Public Methods
Collapse All

The methods of the EcoSpaceBase class are listed here.

Public Methods
Name | Description
ResolveTypeName | This is ResolveTypeName, a member of class EcoSpaceBase.


EcoSpaceBase.ResolveTypeName Method

EcoSpaceBase.ResolveTypeName Method
EcoSpaceBase Class Eco.Handles Namespace See Also
Collapse All
C#
public static Type ResolveTypeName(
    string ecoSpaceTypeName,
    ISite site
);
Remarks

This is ResolveTypeName, a member of class EcoSpaceBase.

See Also
EcoSpaceBase Class
Eco.Handles Namespace


EcoSpaceSerializer Class

EcoSpaceSerializer Class
Inheritance Hierarchy See Also
Collapse All

The EcoSpaceSerializer is a class that can be used to serialize Ecospaces using standard dotnet serialization.

C#
public class EcoSpaceSerializer : ISerializable;
Remarks

This class is primarily used by the EcoSpaceStrategyHandler to store an ecospace in the HttpSessionState, but it can be used whenever an ecospace needs to be serialized by standard serialization.

Inheritance Hierarchy
Eco.Handles.EcoSpaceSerializer
File

EcoSpaceSerializer.cs

See Also
Inheritance Hierarchy


EcoSpaceSerializer Constructor

EcoSpaceSerializer Constructor

This is the overview for the EcoSpaceSerializer constructor overload.

Overload List
Name | Description
EcoSpaceSerializer.EcoSpaceSerializer () | This is EcoSpaceSerializer, a member of class EcoSpaceSerializer.
EcoSpaceSerializer.EcoSpaceSerializer (SerializationInfo, StreamingContext) | This is EcoSpaceSerializer, a member of class EcoSpaceSerializer.


EcoSpaceSerializer.EcoSpaceSerializer Constructor ()

EcoSpaceSerializer.EcoSpaceSerializer Constructor ()
EcoSpaceSerializer Class Eco.Handles Namespace See Also
Collapse All
C#
public EcoSpaceSerializer();
Remarks

This is EcoSpaceSerializer, a member of class EcoSpaceSerializer.

See Also
EcoSpaceSerializer Class
Eco.Handles Namespace


EcoSpaceSerializer.EcoSpaceSerializer Constructor (SerializationInfo, StreamingContext)

EcoSpaceSerializer.EcoSpaceSerializer Constructor (SerializationInfo, StreamingContext)
EcoSpaceSerializer Class Eco.Handles Namespace See Also
Collapse All
C#
protected EcoSpaceSerializer(
    SerializationInfo si,
    StreamingContext context
);
Remarks

This is EcoSpaceSerializer, a member of class EcoSpaceSerializer.

See Also
EcoSpaceSerializer Class
Eco.Handles Namespace


EcoSpaceSerializer Properties

EcoSpaceSerializer Properties
Public Properties
Collapse All

The properties of the EcoSpaceSerializer class are listed here.

Public Properties
Name | Description
EcoSpace | This is EcoSpace, a member of class EcoSpaceSerializer.


EcoSpaceSerializer.EcoSpace Property

EcoSpaceSerializer.EcoSpace Property
EcoSpaceSerializer Class Eco.Handles Namespace See Also
Collapse All
C#
public EcoSpace EcoSpace;
Remarks

This is EcoSpace, a member of class EcoSpaceSerializer.

See Also
EcoSpaceSerializer Class
Eco.Handles Namespace


ElementHandle Class

ElementHandle Class
Inheritance Hierarchy See Also
Collapse All

This component is the base class for all of the ECO handle components.

C#
public abstract class ElementHandle : System.ComponentModel.Component, IElementHandle, IStaticContext, IEcoServiceProvider, ISubscribableElementProvider, ITypedList, IBindingListView, INotifyOnIdle, ISupportInitialize;
Remarks

An ECO handle provides a way at runtime to reference instances of modeled business classes to enable modification. At design time it provides a way of specifying the type of information that will be referenced by the handle when the application is running, this type information is used when linking up UI controls for databinding and also to provide a context to any child handles that depend upon it for their context (parent / child).

Inheritance Hierarchy
Eco.Handles.IElementHandle
Eco.Handles.INotifyOnIdle
    Eco.Handles.ElementHandle
        Eco.Handles.RootedHandle
        Eco.Handles.RootHandle
File

ElementHandle.cs

See Also
Inheritance Hierarchy


ElementHandle.ElementHandle Constructor

ElementHandle.ElementHandle Constructor
ElementHandle Class Eco.Handles Namespace See Also
Collapse All

Creates a new instance of the component.

C#
public ElementHandle();
See Also
ElementHandle Class
Eco.Handles Namespace


ElementHandle Fields

ElementHandle Fields
Protected Fields
Collapse All

The fields of the ElementHandle class are listed here.

Protected Fields
Name | Description
DesignMode | This is DesignMode, a member of class ElementHandle.


ElementHandle.DesignMode Field

ElementHandle.DesignMode Field
ElementHandle Class Eco.Handles Namespace See Also
Collapse All
C#
protected bool DesignMode = false;
Remarks

This is DesignMode, a member of class ElementHandle.

See Also
ElementHandle Class
Eco.Handles Namespace


ElementHandle Methods

ElementHandle Methods
Protected Methods Public Methods
Collapse All

The methods of the ElementHandle class are listed here.

Protected Methods
Name | Description
CheckType | This is CheckType, a member of class ElementHandle.
Dispose | Disables the element handle and disposes it.
DoEndInit | This is DoEndInit, a member of class ElementHandle.
EffectiveEnabledChanged | This is EffectiveEnabledChanged, a member of class ElementHandle.
EffectiveVariables | This is EffectiveVariables, a member of class ElementHandle.
ElementChanged | This is ElementChanged, a member of class ElementHandle.
EnsureInternalElement | This is EnsureInternalElement, a member of class ElementHandle.
GetActionLanguageTypeService | This is GetActionLanguageTypeService, a member of class ElementHandle.
GetOclPsTypeService | This is GetOclPsTypeService, a member of class ElementHandle.
GetOclTypeService | This is GetOclTypeService, a member of class ElementHandle.
GetStaticUmlType | This is GetStaticUmlType, a member of class ElementHandle.
GetTypeSystem | This is GetTypeSystem, a member of class ElementHandle.
MergeVariables | This is MergeVariables, a member of class ElementHandle.
StaticContextChanged | This is StaticContextChanged, a member of class ElementHandle.
SubscribeToDownstreamActive | This is SubscribeToDownstreamActive, a member of class ElementHandle.
UpdateActiveSubscription | This is UpdateActiveSubscription, a member of class ElementHandle.
Top
Public Methods
Name | Description
CreateDefaultColumns | Checks each structural feature of the specified StaticUmlType and if no column exists with the same name it will create a column for it.
EnsureAllBindingLists | Equivalent of calling EnsureBindingList on all handles.
EnsureBindingList | This method updates the values in the binding list with the true values from the local EcoSpace cache.
GetEcoService | This is the overview for the GetEcoService method overload.
GetElementValue | This is GetElementValue, a member of class ElementHandle.
GetList | Gets a list of columns the element handle owns, this is used for data binding.
GetRenderedValue | Returns the rendered value for a certain column on a certain row.
RegisterEcoService | This is the overview for the RegisterEcoService method overload.
RenderElement | Creates an object for IElement of the same type as the objects in the bindinglist.
SetRenderedElementProperty | Primarily intended for setting values in ASP apps.
SubscribeToActive | Places subscription on EffectiveEnabled.
SubscribeToEffectiveEnabled | Places a subscription on EffectiveEnabled.
SubscribeToElement | Places a subscription on the Element being replaced.
SubscribeToStaticContext | Places a subscription on StaticContext.
UsesVariables | This is UsesVariables, a member of class ElementHandle.


ElementHandle.CheckType Method

ElementHandle.CheckType Method
ElementHandle Class Eco.Handles Namespace See Also
Collapse All
C#
protected void CheckType();
Remarks

This is CheckType, a member of class ElementHandle.

See Also
ElementHandle Class
Eco.Handles Namespace


ElementHandle.CreateDefaultColumns Method

ElementHandle.CreateDefaultColumns Method
ElementHandle Class Eco.Handles Namespace Related Topics See Also
Collapse All

Checks each structural feature of the specified StaticUmlType and if no column exists with the same name it will create a column for it.

C#
public void CreateDefaultColumns();
Remarks

If the StaticUmlType is an IPrimitiveType (int, string, etc) then only a single unnamed column will be created with the expression "self".

MemberVisibility will be honoured when creating columns.

Related Topics

AddExternalId, AddDefaultNestings, Columns, MemberVisibility, Nestings

See Also
ElementHandle Class
Eco.Handles Namespace
Related Topics


ElementHandle.Dispose Method

ElementHandle.Dispose Method
ElementHandle Class Eco.Handles Namespace See Also
Collapse All

Disables the element handle and disposes it.

C#
protected override void Dispose(
    bool disposing
);
See Also
ElementHandle Class
Eco.Handles Namespace


ElementHandle.DoEndInit Method

ElementHandle.DoEndInit Method
ElementHandle Class Eco.Handles Namespace See Also
Collapse All
C#
protected void DoEndInit();
Remarks

This is DoEndInit, a member of class ElementHandle.

See Also
ElementHandle Class
Eco.Handles Namespace


ElementHandle.EffectiveEnabledChanged Method

ElementHandle.EffectiveEnabledChanged Method
ElementHandle Class Eco.Handles Namespace See Also
Collapse All
C#
protected virtual void EffectiveEnabledChanged();
Remarks

This is EffectiveEnabledChanged, a member of class ElementHandle.

See Also
ElementHandle Class
Eco.Handles Namespace


ElementHandle.EffectiveVariables Method

ElementHandle.EffectiveVariables Method
ElementHandle Class Eco.Handles Namespace See Also
Collapse All
C#
protected virtual IExternalVariableList EffectiveVariables();
Remarks

This is EffectiveVariables, a member of class ElementHandle.

See Also
ElementHandle Class
Eco.Handles Namespace


ElementHandle.ElementChanged Method

ElementHandle.ElementChanged Method
ElementHandle Class Eco.Handles Namespace See Also
Collapse All
C#
protected void ElementChanged();
Remarks

This is ElementChanged, a member of class ElementHandle.

See Also
ElementHandle Class
Eco.Handles Namespace


ElementHandle.EnsureAllBindingLists Method

ElementHandle.EnsureAllBindingLists Method
ElementHandle Class Eco.Handles Namespace See Also
Collapse All

Equivalent of calling EnsureBindingList on all handles.

C#
public static void EnsureAllBindingLists();
See Also
ElementHandle Class
Eco.Handles Namespace


ElementHandle.EnsureBindingList Method

ElementHandle.EnsureBindingList Method
ElementHandle Class Eco.Handles Namespace See Also
Collapse All

This method updates the values in the binding list with the true values from the local EcoSpace cache.

C#
public void EnsureBindingList();
Remarks

In WinForms apps this method is called automatically from the Application.Idle event.

In ASP apps it needs to be called manually when required.

See Also
ElementHandle Class
Eco.Handles Namespace


ElementHandle.EnsureInternalElement Method

ElementHandle.EnsureInternalElement Method
ElementHandle Class Eco.Handles Namespace See Also
Collapse All
C#
protected virtual void EnsureInternalElement();
Remarks

This is EnsureInternalElement, a member of class ElementHandle.

See Also
ElementHandle Class
Eco.Handles Namespace


ElementHandle.GetActionLanguageTypeService Method

ElementHandle.GetActionLanguageTypeService Method
ElementHandle Class Eco.Handles Namespace See Also
Collapse All
C#
protected abstract IActionLanguageTypeService GetActionLanguageTypeService();
Remarks

This is GetActionLanguageTypeService, a member of class ElementHandle.

See Also
ElementHandle Class
Eco.Handles Namespace


GetEcoService Method

GetEcoService Method

This is the overview for the GetEcoService method overload.

Overload List
Name | Description
ElementHandle.GetEcoService () | This is GetEcoService, a member of class ElementHandle.
ElementHandle.GetEcoService (object) | This is GetEcoService, a member of class ElementHandle.
ElementHandle.GetEcoService (System.Type) | This is GetEcoService, a member of class ElementHandle.


ElementHandle.GetEcoService Method ()

ElementHandle.GetEcoService Method ()
ElementHandle Class Eco.Handles Namespace See Also
Collapse All
C#
public T GetEcoService<T>() where T : class;
Remarks

This is GetEcoService, a member of class ElementHandle.

See Also
ElementHandle Class
Eco.Handles Namespace


ElementHandle.GetEcoService Method (System.Type)

ElementHandle.GetEcoService Method (System.Type)
ElementHandle Class Eco.Handles Namespace See Also
Collapse All
C#
protected abstract object GetEcoService(
    System.Type serviceType
);
Remarks

This is GetEcoService, a member of class ElementHandle.

See Also
ElementHandle Class
Eco.Handles Namespace


ElementHandle.GetEcoService Method (object)

ElementHandle.GetEcoService Method (object)
ElementHandle Class Eco.Handles Namespace See Also
Collapse All
C#
protected abstract T GetEcoService<T>(
    object key
) where T: class;
Remarks

This is GetEcoService, a member of class ElementHandle.

See Also
ElementHandle Class
Eco.Handles Namespace


ElementHandle.GetElementValue Method

ElementHandle.GetElementValue Method
ElementHandle Class Eco.Handles Namespace See Also
Collapse All
C#
public T GetElementValue<T>();
Remarks

This is GetElementValue, a member of class ElementHandle.

See Also
ElementHandle Class
Eco.Handles Namespace


ElementHandle.GetList Method

ElementHandle.GetList Method
ElementHandle Class Eco.Handles Namespace Related Topics See Also
Collapse All

Gets a list of columns the element handle owns, this is used for data binding.

C#
public IList GetList();
Related Topics

AddDefaultNestings, AddDefaultProperties, Columns

See Also
ElementHandle Class
Eco.Handles Namespace
Related Topics


ElementHandle.GetOclPsTypeService Method

ElementHandle.GetOclPsTypeService Method
ElementHandle Class Eco.Handles Namespace See Also
Collapse All
C#
protected abstract IOclPsTypeService GetOclPsTypeService();
Remarks

This is GetOclPsTypeService, a member of class ElementHandle.

See Also
ElementHandle Class
Eco.Handles Namespace


ElementHandle.GetOclTypeService Method

ElementHandle.GetOclTypeService Method
ElementHandle Class Eco.Handles Namespace See Also
Collapse All
C#
protected abstract IOclTypeService GetOclTypeService();
Remarks

This is GetOclTypeService, a member of class ElementHandle.

See Also
ElementHandle Class
Eco.Handles Namespace


ElementHandle.GetRenderedValue Method

ElementHandle.GetRenderedValue Method
ElementHandle Class Eco.Handles Namespace See Also
Collapse All

Returns the rendered value for a certain column on a certain row.

C#
public object GetRenderedValue(
    int row,
    string columnName
);
Remarks

This method will respect any sorting or filtering that is done in the handle. To know how many rows there is in the handle, check ElementHandle.GetList().Count.

See Also
ElementHandle Class
Eco.Handles Namespace


ElementHandle.GetStaticUmlType Method

ElementHandle.GetStaticUmlType Method
ElementHandle Class Eco.Handles Namespace See Also
Collapse All
C#
protected abstract IClassifier GetStaticUmlType();
Remarks

This is GetStaticUmlType, a member of class ElementHandle.

See Also
ElementHandle Class
Eco.Handles Namespace


ElementHandle.GetTypeSystem Method

ElementHandle.GetTypeSystem Method
ElementHandle Class Eco.Handles Namespace See Also
Collapse All
C#
protected abstract IEcoTypeSystem GetTypeSystem();
Remarks

This is GetTypeSystem, a member of class ElementHandle.

See Also
ElementHandle Class
Eco.Handles Namespace


ElementHandle.MergeVariables Method

ElementHandle.MergeVariables Method
ElementHandle Class Eco.Handles Namespace See Also
Collapse All
C#
protected IExternalVariableList MergeVariables(
    IExternalVariableList list1,
    IExternalVariableList list2
);
Remarks

This is MergeVariables, a member of class ElementHandle.

See Also
ElementHandle Class
Eco.Handles Namespace


RegisterEcoService Method

RegisterEcoService Method

This is the overview for the RegisterEcoService method overload.

Overload List
Name | Description
ElementHandle.RegisterEcoService (object, T) | This is RegisterEcoService, a member of class ElementHandle.
ElementHandle.RegisterEcoService (T) | This is RegisterEcoService, a member of class ElementHandle.


ElementHandle.RegisterEcoService Method (T)

ElementHandle.RegisterEcoService Method (T)
ElementHandle Class Eco.Handles Namespace See Also
Collapse All
C#
public abstract void RegisterEcoService<T>(
    T service
) where T : class;
Remarks

This is RegisterEcoService, a member of class ElementHandle.

See Also
ElementHandle Class
Eco.Handles Namespace


ElementHandle.RegisterEcoService Method (object, T)

ElementHandle.RegisterEcoService Method (object, T)
ElementHandle Class Eco.Handles Namespace See Also
Collapse All
C#
public abstract void RegisterEcoService<T>(
    object key,
    T service
) where T : class;
Remarks

This is RegisterEcoService, a member of class ElementHandle.

See Also
ElementHandle Class
Eco.Handles Namespace


ElementHandle.RenderElement Method

ElementHandle.RenderElement Method
ElementHandle Class Eco.Handles Namespace See Also
Collapse All

Creates an object for IElement of the same type as the objects in the bindinglist.

C#
public object RenderElement(
    IElement element
);
See Also
ElementHandle Class
Eco.Handles Namespace


ElementHandle.SetRenderedElementProperty Method

ElementHandle.SetRenderedElementProperty Method
ElementHandle Class Eco.Handles Namespace See Also
Collapse All

Primarily intended for setting values in ASP apps.

C#
public void SetRenderedElementProperty(
    object item,
    string propertyName,
    object value,
    bool autoConvert
);
Remarks

Given a row in the bindinglist or an object created from an element as returned by RenderElement this method sets the value of a named property (which is defined as column.Name except for auto-properties).

See Also
ElementHandle Class
Eco.Handles Namespace


ElementHandle.StaticContextChanged Method

ElementHandle.StaticContextChanged Method
ElementHandle Class Eco.Handles Namespace See Also
Collapse All
C#
protected virtual void StaticContextChanged();
Remarks

This is StaticContextChanged, a member of class ElementHandle.

See Also
ElementHandle Class
Eco.Handles Namespace


ElementHandle.SubscribeToActive Method

ElementHandle.SubscribeToActive Method
ElementHandle Class Eco.Handles Namespace Related Topics See Also
Collapse All

Places subscription on EffectiveEnabled.

C#
public void SubscribeToActive(
    ISubscriber subscriber
);
Related Topics

SubscribeToEffectiveEnabled

See Also
ElementHandle Class
Eco.Handles Namespace
Related Topics


ElementHandle.SubscribeToDownstreamActive Method

ElementHandle.SubscribeToDownstreamActive Method
ElementHandle Class Eco.Handles Namespace See Also
Collapse All
C#
protected abstract void SubscribeToDownstreamActive(
    ISubscriber subscriber
);
Remarks

This is SubscribeToDownstreamActive, a member of class ElementHandle.

See Also
ElementHandle Class
Eco.Handles Namespace


ElementHandle.SubscribeToEffectiveEnabled Method

ElementHandle.SubscribeToEffectiveEnabled Method
ElementHandle Class Eco.Handles Namespace See Also
Collapse All

Places a subscription on EffectiveEnabled.

C#
public void SubscribeToEffectiveEnabled(
    ISubscriber subscriber
);
Parameters
Parameters | Description
subscriber | The subscriber to notify whenever EffectiveEnabled changes.
Remarks

This is used internally by RootedHandle to update its own EffectiveEnabled property whenever the EffectiveEnabled property of its RootHandle is altered.

See Also
ElementHandle Class
Eco.Handles Namespace


ElementHandle.SubscribeToElement Method

ElementHandle.SubscribeToElement Method
ElementHandle Class Eco.Handles Namespace See Also
Collapse All

Places a subscription on the Element being replaced.

C#
public void SubscribeToElement(
    ISubscriber subscriber
);
Remarks

The subscriber will be notified whenever the Element is replaced, it will not be notified if items are added, removed, or replaced in a collection. To be notified of such events a subscription should be placed on the element itself.

See Also
ElementHandle Class
Eco.Handles Namespace


ElementHandle.SubscribeToStaticContext Method

ElementHandle.SubscribeToStaticContext Method
ElementHandle Class Eco.Handles Namespace See Also
Collapse All

Places a subscription on StaticContext.

C#
public void SubscribeToStaticContext(
    ISubscriber subscriber
);
Remarks

This is for internal use only.

See Also
ElementHandle Class
Eco.Handles Namespace


ElementHandle.UpdateActiveSubscription Method

ElementHandle.UpdateActiveSubscription Method
ElementHandle Class Eco.Handles Namespace See Also
Collapse All
C#
protected void UpdateActiveSubscription();
Remarks

This is UpdateActiveSubscription, a member of class ElementHandle.

See Also
ElementHandle Class
Eco.Handles Namespace


ElementHandle.UsesVariables Method

ElementHandle.UsesVariables Method
ElementHandle Class Eco.Handles Namespace See Also
Collapse All
C#
public abstract bool UsesVariables(
    IOclVariables variables
);
Remarks

This is UsesVariables, a member of class ElementHandle.

See Also
ElementHandle Class
Eco.Handles Namespace


ElementHandle Properties

ElementHandle Properties
Public Properties Protected Properties
Collapse All

The properties of the ElementHandle class are listed here.

Public Properties
Name
Description
Active
This property has been replaced by EffectiveEnabled to be more compatible with the VCL handles.
AddDefaultNestings
Indicates whether or not the handle should add a column for each association end of the StaticUmlType at runtime.
AddDefaultProperties
Indicates whether or not the handle should add a column for each simple structural feature (int, string, etc) of the StaticUmlType at runtime.
AddExternalId
Specifies whether or not a read-only column named "ExternalId" should be added automatically.
AddSelfColumn
Specifies whether or not a self referencing "self" column should be added automatically.
AllowNew
Specifies whether or not the handle should declare itself as supporting IBindingList.AllowNew.
Columns
Holds a collection of columns that the handle exposes for data binding.
EffectiveEnabled
Indicates whether or not the handle is truely active.
Element
Returns the current value of the handle.
Enabled
/// If set to False, the element is set to null and the Active property is /// set to False, effectively disabling the handle.
/// However, the implementation of IStaticContext is still valid.
///
Specifies whether or not the handle should be enabled.
Filter
Specifies a filter to apply to the elements in the list when Element is a collection.
FilterMode
Specifies the type of filtering defined in Filter
List
Exposed to allow for Path notation in WPF
MemberVisibility
Specifies which of the StaticUmlType's features are automatically added as columns at runtime.
Nestings
Contains a list of nestings for .NET data binding.
NullRowMode
Specifies whether or not to add an additional "null" row when the element to which the handle refers is a collection.
StaticUmlType
This property is used at design time to enable designer support.
SupportSorting
Specifies to UI controls whether or not this handle supports sorting by the values of a column.
Variables
Points to the variables used by this handle.
Top
Protected Properties
Name | Description
AutoQueue | This is AutoQueue, a member of class ElementHandle.
InternalElement | This is InternalElement, a member of class ElementHandle.
IsInitializing | This is IsInitializing, a member of class ElementHandle.


ElementHandle.Active Property

ElementHandle.Active Property
ElementHandle Class Eco.Handles Namespace See Also
Collapse All

This property has been replaced by EffectiveEnabled to be more compatible with the VCL handles.

C#
public bool Active;
See Also
ElementHandle Class
Eco.Handles Namespace


ElementHandle.AddDefaultNestings Property

ElementHandle.AddDefaultNestings Property
ElementHandle Class Eco.Handles Namespace Related Topics See Also
Collapse All

Indicates whether or not the handle should add a column for each association end of the StaticUmlType at runtime.

C#
public bool AddDefaultNestings;
Remarks

If this property is True CreateDefaultColumns will create a column for each association end of the type identified by StaticUmlType. If a column already exists with the propertie's name the existing column will remain untouched and a new column will not be added, this allows the developer to override the definition of default columns at design time.

Related Topics

AddExternalId, AddDefaultProperties, Columns, MemberVisibility

See Also
ElementHandle Class
Eco.Handles Namespace
Related Topics


ElementHandle.AddDefaultProperties Property

ElementHandle.AddDefaultProperties Property
ElementHandle Class Eco.Handles Namespace Related Topics See Also
Collapse All

Indicates whether or not the handle should add a column for each simple structural feature (int, string, etc) of the StaticUmlType at runtime.

C#
public bool AddDefaultProperties;
Remarks

If this property is True CreateDefaultColumns will create a column for each of the simple features (int, string, etc) of the type identified by StaticUmlType. If a column already exists with the propertie's name the existing column will remain untouched and a new column will not be added, this allows the developer to override the definition of default columns at design time.

Related Topics

AddExternalId, AddDefaultNestings, Columns, MemberVisibility

See Also
ElementHandle Class
Eco.Handles Namespace
Related Topics


ElementHandle.AddExternalId Property

ElementHandle.AddExternalId Property
ElementHandle Class Eco.Handles Namespace Related Topics See Also
Collapse All

Specifies whether or not a read-only column named "ExternalId" should be added automatically.

C#
public bool AddExternalId;
Remarks

The column added will be of type "string". An external ID is useful for retrieving an object instance using a string based indentifier. This additional column is especially useful in ASP .NET for providing links to other pages passing an object ID in the query string.

Related Topics

Eco.Services.IExternalIdService

See Also
ElementHandle Class
Eco.Handles Namespace
Related Topics


ElementHandle.AddSelfColumn Property

ElementHandle.AddSelfColumn Property
ElementHandle Class Eco.Handles Namespace Related Topics See Also
Collapse All

Specifies whether or not a self referencing "self" column should be added automatically.

C#
public bool AddSelfColumn;
Remarks

Adds a column with the name "self" of type string. This can be used to refer to the object when setting up data bindings for controls such as ComboBoxes.

Related Topics

Columns

See Also
ElementHandle Class
Eco.Handles Namespace
Related Topics


ElementHandle.AllowNew Property

ElementHandle.AllowNew Property
ElementHandle Class Eco.Handles Namespace See Also
Collapse All

Specifies whether or not the handle should declare itself as supporting IBindingList.AllowNew.

C#
public bool AllowNew;
Remarks

Some controls, such as the DataGrid, will query its DataSource for IBindingList.AllowNew. If the DataSource returns true a blank row will be added to the bottom of the DataGrid allowing the user to create a new object simply by typing into one of the blank row's columns.

See Also
ElementHandle Class
Eco.Handles Namespace


ElementHandle.AutoQueue Property

ElementHandle.AutoQueue Property
ElementHandle Class Eco.Handles Namespace See Also
Collapse All
C#
protected virtual bool AutoQueue;
Remarks

This is AutoQueue, a member of class ElementHandle.

See Also
ElementHandle Class
Eco.Handles Namespace


ElementHandle.Columns Property

ElementHandle.Columns Property
ElementHandle Class Eco.Handles Namespace Related Topics See Also
Collapse All

Holds a collection of columns that the handle exposes for data binding.

C#
public ColumnCollection Columns;
Remarks

This property affects the appearance of the list returned by GetList and used when data binding .NET components.

Each column in the collection will add a property to the list in addition to the ones defined by AddDefaultProperties and AddDefaultNestings.

Related Topics

AddDefaultProperties, AddDefaultNestings, AddSelfColumn, MemberVisibility

See Also
ElementHandle Class
Eco.Handles Namespace
Related Topics


ElementHandle.EffectiveEnabled Property

ElementHandle.EffectiveEnabled Property
ElementHandle Class Eco.Handles Namespace See Also
Collapse All

Indicates whether or not the handle is truely active.

C#
public abstract bool EffectiveEnabled;
Remarks

When a handle is EffectiveEnabled it is correctly connected to an active EcoSpace. For a RootHandle this is the case when its Active property is True. For a RootedHandle this is the case when its Active property is True and its RootHandle is also effectively enabled.

See Also
ElementHandle Class
Eco.Handles Namespace


ElementHandle.Element Property

ElementHandle.Element Property
ElementHandle Class Eco.Handles Namespace See Also
Collapse All

Returns the current value of the handle.

C#
public IElement Element;
Remarks

The value of the handle could be a simple type such as a string or integer, an instance of a modeled UML class, a collection of a simple type, or a collection of instances of a modeled UML class + its descendant classes.

See Also
ElementHandle Class
Eco.Handles Namespace


ElementHandle.Enabled Property

ElementHandle.Enabled Property
ElementHandle Class Eco.Handles Namespace See Also
Collapse All

/// If set to False, the element is set to null and the Active property is /// set to False, effectively disabling the handle.

/// However, the implementation of IStaticContext is still valid.

///

Specifies whether or not the handle should be enabled.

C#
public bool Enabled;
Remarks

///

When set to False the Element property is set to null and the EffectiveEnabled property is set to False.

See Also
ElementHandle Class
Eco.Handles Namespace


ElementHandle.Filter Property

ElementHandle.Filter Property
ElementHandle Class Eco.Handles Namespace See Also
Collapse All

Specifies a filter to apply to the elements in the list when Element is a collection.

C#
public string Filter;
Remarks

The action taken on this property depends upon the setting specified in FilterMode

  • FilterMode.Ocl: This is currently the only mode implemented. The Filter is treated as an OCL expression which must result in a boolean value. The expression is evaluated against each value in the collection, if it results in True the element will appear in the rendered list, otherwise it will not.
See Also
ElementHandle Class
Eco.Handles Namespace


ElementHandle.FilterMode Property

ElementHandle.FilterMode Property
ElementHandle Class Eco.Handles Namespace See Also
Collapse All

Specifies the type of filtering defined in Filter

C#
public FilterMode FilterMode;
See Also
ElementHandle Class
Eco.Handles Namespace


ElementHandle.InternalElement Property

ElementHandle.InternalElement Property
ElementHandle Class Eco.Handles Namespace See Also
Collapse All
C#
protected IElement InternalElement;
Remarks

This is InternalElement, a member of class ElementHandle.

See Also
ElementHandle Class
Eco.Handles Namespace


ElementHandle.IsInitializing Property

ElementHandle.IsInitializing Property
ElementHandle Class Eco.Handles Namespace See Also
Collapse All
C#
protected bool IsInitializing;
Remarks

This is IsInitializing, a member of class ElementHandle.

See Also
ElementHandle Class
Eco.Handles Namespace


ElementHandle.List Property

ElementHandle.List Property
ElementHandle Class Eco.Handles Namespace See Also
Collapse All

Exposed to allow for Path notation in WPF

C#
public IList List;
See Also
ElementHandle Class
Eco.Handles Namespace


ElementHandle.MemberVisibility Property

ElementHandle.MemberVisibility Property
ElementHandle Class Eco.Handles Namespace See Also
Collapse All

Specifies which of the StaticUmlType's features are automatically added as columns at runtime.

C#
public MemberVisibility MemberVisibility;
Remarks

This property allows the developer to restrict which class features are added as columns based on the exposure level defined during modeling.

See Also
ElementHandle Class
Eco.Handles Namespace


ElementHandle.Nestings Property

ElementHandle.Nestings Property
ElementHandle Class Eco.Handles Namespace Related Topics See Also
Collapse All

Contains a list of nestings for .NET data binding.

C#
public NestingCollection Nestings;
Remarks

The nestings defined here will appear in the list returned by GetList. This list is then used for data binding. A nesting is the equivalent of a class association in ECO, at runtime it will be used to represent an instance of a modeled UML class.

Related Topics

AddDefaultNestings, GetList

See Also
ElementHandle Class
Eco.Handles Namespace
Related Topics


ElementHandle.NullRowMode Property

ElementHandle.NullRowMode Property
ElementHandle Class Eco.Handles Namespace See Also
Collapse All

Specifies whether or not to add an additional "null" row when the element to which the handle refers is a collection.

C#
public NullRowMode NullRowMode;
Remarks

A null row may be useful in various scenarios, for example:

  • Specifying an association value in a control such as a ComboBox when "<None>" is a valid input.
  • Data binding to a single value control that doesn't implement "null" values well, such as a Textbox.

The display of columns of the null row are controlled by AbstractColumn.NullElementRepresentation

See Also
ElementHandle Class
Eco.Handles Namespace


ElementHandle.StaticUmlType Property

ElementHandle.StaticUmlType Property
ElementHandle Class Eco.Handles Namespace See Also
Collapse All

This property is used at design time to enable designer support.

C#
public IClassifier StaticUmlType;
Remarks

This property may be set at design time in order to identify what data type the handle will refer to at runtime. Using this information is it possible for the ECO designers to determine information it needs to provide designer support for various tasks such as creating columns and nestings, and invoking the OCL editor window for OCL expressions.

A RootedHandle is capable of determining its StaticUmlType automatically from its parent handle (RootHandle) property.

See Also
ElementHandle Class
Eco.Handles Namespace


ElementHandle.SupportSorting Property

ElementHandle.SupportSorting Property
ElementHandle Class Eco.Handles Namespace See Also
Collapse All

Specifies to UI controls whether or not this handle supports sorting by the values of a column.

C#
public bool SupportSorting;
Remarks

When SupportSorting is set to True UI controls that check for this value using IBindingList.SupportsSorting / IBindingListView.SupportsAdvancedSorting will typically enable sorting support. For example, a DataGrid will allow the user to sort its rows whenever the user clicks on a column header.

See Also
ElementHandle Class
Eco.Handles Namespace


ElementHandle.Variables Property

ElementHandle.Variables Property
ElementHandle Class Eco.Handles Namespace See Also
Collapse All

Points to the variables used by this handle.

C#
public OclVariables Variables;
Remarks

Set this property to refer to an OclVariables component defining the variables to be used by the handle. The variables are passed on to any connected handles by way of the VariableList property on IStaticContext.

Variables defined here will be available for expressions when defining columns and nestings as well as in the expression of the handle.

Exceptions
Exceptions | Description
EcoException | Thrown if creating a circular reference when setting the new value.
See Also
ElementHandle Class
Eco.Handles Namespace


ElementHandle Events

ElementHandle Events
Public Events
Collapse All

The events of the ElementHandle class are listed here.

Public Events
Name | Description
DeriveValue | This event is used to calculate the value of all event derived columns.
ReverseDeriveValue | This event should be used when an EventDerivedColumn has IsReadOnly set to False.


ElementHandle.DeriveValue Event

ElementHandle.DeriveValue Event
ElementHandle Class Eco.Handles Namespace Example 1 Example 2 Related Topics See Also
Collapse All

This event is used to calculate the value of all event derived columns.

C#
public event DeriveEventHandler DeriveValue;
Remarks

When adding columns to a handle manually it is possible to add not only OCL derived columns but also event derived columns. When ECO requires the value of an event derived column it will trigger this event, the application is then responsible for returning a value for the requested column and also for subscribing to the elements required to calculate the value, the returned value will be cached until any of its subscribed elements change.

Related Topics

EventDerivedColumn, ReverseDeriveValue

Example 1
Copy Code
procedure TWinForm.ExpressionHandle1_DeriveValue(sender: object; e: Eco.Handles.DeriveEventArgs);
var
CurrentPerson: Person;
Age: Integer;
DateOfBirthProperty: IProperty;
begin
       if e.Name = 'Age' then
       begin
       CurrentPerson := e.RootElement.AsObject as Person;
       Age := (DateTime.Now.Year - 1) - CurrentPerson.DateOfBirth.Year;
       if (DateTime.Now.Month >= CurrentPerson.DateOfBirth.Month) and
         (DateTime.Now.Day >= CurrentPerson.DateOfBirth.Day) then
         Inc(Age);
       e.ResultElement := EcoSpace.VariableFactoryService.CreateConstant(Age);
       if e.ValueChangeSubscriber <> nil then
       begin
         DateOfBirthProperty := CurrentPerson.AsIObject.Properties.GetByLoopbackIndex(Person.Eco_LoopbackIndices.DateOfBirth);
         DateOfBirthProperty.SubscribeToValue(e.ValueChangeSubscriber);
       end;
     end else
       raise InvalidOperationException.Create('No derivation code for ' + e.Name);
   end;
Example 2
Copy Code
private void ExpressionHandle1_DeriveValue(object sender, Eco.Handles.DeriveEventArgs e)
{
       switch (e.Name)
       {
           case "Age":
           {
               Person currentPerson = e.RootElement.AsObject as Person;
               int age = (DateTime.Now.Year - 1) - currentPerson.DateOfBirth.Year;
               if (DateTime.Now.Month >= currentPerson.DateOfBirth.Month && (DateTime.Now.Day >= currentPerson.DateOfBirth.Day)
                   age = age++;
               e.ResultElement = EcoSpace.VariableFactoryService.CreateConstant(age);
               if (e.ValueChangeSubscriber != null)
               {
                   IProperty dateOfBirthProperty = durrentPerson.AsIObject.Properties.GetByLoopbackIndex(Person.Eco_LoopbackIndices.DateOfBirth);
                   dateOfBirthProperty.SubscribeToValue(e.ValueChangeSubscriber);
               }
           }

           default:
               throw new InvalidOperationException("No derivation code for " + e.Name);
       }
}
See Also
ElementHandle Class
Eco.Handles Namespace
Example 1
Example 2
Related Topics


ElementHandle.ReverseDeriveValue Event

ElementHandle.ReverseDeriveValue Event
ElementHandle Class Eco.Handles Namespace Example 1 Example 2 Related Topics See Also
Collapse All

This event should be used when an EventDerivedColumn has IsReadOnly set to False.

C#
public event ReverseDeriveEventHandler ReverseDeriveValue;
Remarks

If an event derived column on a handle has its IsReadOnly property set to False then it will be possible to set the value of the calculated column from within the UI. If the user of the application does set the value this event will be triggered so that the application can update the necessary elements to reflect the change.

Related Topics

DeriveValue, EventDerivedColumn

Example 1
Copy Code
procedure TWinForm.ExpressionHandle1_ReverseDeriveValue(sender: object; e: Eco.Handles.ReverseDeriveEventArgs);
var
  NewAge: Integer;
  NewYearOfBirth: Integer;
  CurrentPerson: Person;
begin
  if e.Name = 'Age' then
  begin
    NewAge := Convert.ToInt16(e.Value);
    CurrentPerson := e.RootElement.AsObject as Person;
    NewYearOfBirth := (DateTime.Now.Year - 1) - NewAge;
    if (DateTime.Now.Month >= CurrentPerson.DateOfBirth.Month) and
      (DateTime.Now.Day >= CurrentPerson.DateOfBirth.Day) then
      Inc(NewYearOfBirth);
    CurrentPerson.DateOfBirth := DateTime.Create(NewYearOfBirth, CurrentPerson.DateOfBirth.Month, CurrentPerson.DateOfBirth.Day);
  end else
    raise InvalidOperationException.Create('No reverse derivation code for ' + e.Name);
end;
Example 2
Copy Code
private void ExpressionHandle1_ReverseDeriveValue(sender: object; e: Eco.Handles.ReverseDeriveEventArgs);
   {
       switch (e.Name)
       {
           case "Age":
           {
               int newAge = Convert.ToInt16(e.Value);
               Person currentPerson = e.RootElement.AsObject as Person;
               int newYearOfBirth = (DateTime.Now.Year - 1) - newAge;
               if (DateTime.Now.Month >= currentPerson.DateOfBirth.Month &&
                   DateTime.Now.Day >= currentPerson.DateOfBirth.Day)
                   Inc(newYearOfBirth);
               currentPerson.DateOfBirth = new DateTime(newYearOfBirth, currentPerson.DateOfBirth.Month, currentPerson.DateOfBirth.Day);
           }

           default:
               throw new InvalidOperationException("No reverse derivation code for " + e.Name);
       }
}
See Also
ElementHandle Class
Eco.Handles Namespace
Example 1
Example 2
Related Topics


EventDerivedColumn Class

EventDerivedColumn Class
Inheritance Hierarchy See Also
Collapse All

Class describing an additional property to be added to the items in the rendered list, which gets its value through ElementHandle.DeriveValue

C#
public class EventDerivedColumn : AbstractColumn, IHasTypeSystem;
Inheritance Hierarchy
Eco.Handles.IColumn
    Eco.Handles.AbstractColumn
    Eco.Handles.IHasTypeSystem
        Eco.Handles.EventDerivedColumn
File

Columns.cs

See Also
Inheritance Hierarchy


EventDerivedColumn Properties

EventDerivedColumn Properties
Public Properties
Collapse All

The properties of the EventDerivedColumn class are listed here.

Public Properties
Name | Description
EventDerivedValue | The property EventDerivedValue is not settable in the class EventDerivedColumn. It is always true.
Expression | The property Expression is not settable in the class EventDerivedColumn. For a column deriving its value using an OCL expression, use an OclColumn.
NullElementRepresentation | The property NullElementRepresentation is not settable in the class EventDerivedColumn.
TypeName | The is the type of the derived value The eventhandler for ElementHandle.DeriveValue must set e.ResultElement to an element of this type


EventDerivedColumn.EventDerivedValue Property

EventDerivedColumn.EventDerivedValue Property
EventDerivedColumn Class Eco.Handles Namespace See Also
Collapse All

The property EventDerivedValue is not settable in the class EventDerivedColumn. It is always true.

C#
public override bool EventDerivedValue;
See Also
EventDerivedColumn Class
Eco.Handles Namespace


EventDerivedColumn.Expression Property

EventDerivedColumn.Expression Property
EventDerivedColumn Class Eco.Handles Namespace See Also
Collapse All

The property Expression is not settable in the class EventDerivedColumn. For a column deriving its value using an OCL expression, use an OclColumn.

C#
public override string Expression;
See Also
EventDerivedColumn Class
Eco.Handles Namespace


EventDerivedColumn.NullElementRepresentation Property

EventDerivedColumn.NullElementRepresentation Property
EventDerivedColumn Class Eco.Handles Namespace See Also
Collapse All

The property NullElementRepresentation is not settable in the class EventDerivedColumn.

C#
public override string NullElementRepresentation;
See Also
EventDerivedColumn Class
Eco.Handles Namespace


EventDerivedColumn.TypeName Property

EventDerivedColumn.TypeName Property
EventDerivedColumn Class Eco.Handles Namespace See Also
Collapse All

The is the type of the derived value

The eventhandler for ElementHandle.DeriveValue must set e.ResultElement to an element of this type

C#
public override string TypeName;
See Also
EventDerivedColumn Class
Eco.Handles Namespace


EventDerivedColumnConverter Class

EventDerivedColumnConverter Class
Inheritance Hierarchy See Also
Collapse All

Type converter for EventDerivedColumn. Mainly for the internal use of the WinForm designer.

C#
public sealed class EventDerivedColumnConverter : AbstractColumnConverter;
Inheritance Hierarchy
Eco.Handles.AbstractColumnConverter
    Eco.Handles.EventDerivedColumnConverter
File

Columns.cs

See Also
Inheritance Hierarchy


EventDerivedColumnConverter Methods

EventDerivedColumnConverter Methods
Protected Methods
Collapse All

The methods of the EventDerivedColumnConverter class are listed here.

Protected Methods
Name | Description
GetTargetType | This is GetTargetType, a member of class EventDerivedColumnConverter.


EventDerivedColumnConverter.GetTargetType Method

EventDerivedColumnConverter.GetTargetType Method
EventDerivedColumnConverter Class Eco.Handles Namespace See Also
Collapse All
C#
protected override Type GetTargetType();
Remarks

This is GetTargetType, a member of class EventDerivedColumnConverter.

See Also
EventDerivedColumnConverter Class
Eco.Handles Namespace


ExpressionHandle Class

ExpressionHandle Class
Inheritance Hierarchy Related Topics See Also
Collapse All

An ECO handle that specifies its ElementHandle.Element in the form of an OCL expression.

C#
public sealed class ExpressionHandle : RootedHandle, IHasEditableExpression;
Remarks

The ExpressionHandle obtains its EcoSpace instance from its RootHandle property. It then uses the OCL expression specified in its Expression property by evaluating it against the context of its RootHandle.

Related Topics

ExpressionHandle.Expression, OclPSHandle

Inheritance Hierarchy
Eco.Handles.IElementHandle
Eco.Handles.INotifyOnIdle
    Eco.Handles.ElementHandle
    Eco.Handles.IRooted
        Eco.Handles.RootedHandle
        Eco.Handles.IHasEditableExpression
            Eco.Handles.ExpressionHandle
File

ExpressionHandle.cs

See Also
Inheritance Hierarchy
Related Topics


ExpressionHandle Methods

ExpressionHandle Methods
Protected Methods
Collapse All

The methods of the ExpressionHandle class are listed here.

Protected Methods
Name | Description
DeriveAndSubscribe | This is DeriveAndSubscribe, a member of class ExpressionHandle.
GetStaticUmlType | This is GetStaticUmlType, a member of class ExpressionHandle.
StaticContextChanged | This is StaticContextChanged, a member of class ExpressionHandle.


ExpressionHandle.DeriveAndSubscribe Method

ExpressionHandle.DeriveAndSubscribe Method
ExpressionHandle Class Eco.Handles Namespace See Also
Collapse All
C#
protected override void DeriveAndSubscribe(
    ISubscriber valueChangeSubscriber,
    ISubscriber resubscribeSubscriber
);
Remarks

This is DeriveAndSubscribe, a member of class ExpressionHandle.

See Also
ExpressionHandle Class
Eco.Handles Namespace


ExpressionHandle.GetStaticUmlType Method

ExpressionHandle.GetStaticUmlType Method
ExpressionHandle Class Eco.Handles Namespace See Also
Collapse All
C#
protected override sealed IClassifier GetStaticUmlType();
Remarks

This is GetStaticUmlType, a member of class ExpressionHandle.

See Also
ExpressionHandle Class
Eco.Handles Namespace


ExpressionHandle.StaticContextChanged Method

ExpressionHandle.StaticContextChanged Method
ExpressionHandle Class Eco.Handles Namespace See Also
Collapse All
C#
protected override void StaticContextChanged();
Remarks

This is StaticContextChanged, a member of class ExpressionHandle.

See Also
ExpressionHandle Class
Eco.Handles Namespace


ExpressionHandle Properties

ExpressionHandle Properties
Public Properties
Collapse All

The properties of the ExpressionHandle class are listed here.

Public Properties
Name | Description
Expression | The OCL expression to be used when deriving the value of the handle.


ExpressionHandle.Expression Property

ExpressionHandle.Expression Property
ExpressionHandle Class Eco.Handles Namespace Example See Also
Collapse All

The OCL expression to be used when deriving the value of the handle.

C#
public string Expression;
Remarks

The Element property is set to the value obtained by evaluating this OCL expression against the Element of its RootHandle.

Example
Copy Code
           Person.allInstances->select(firstName = 'Pete')->first
Copy Code
           self.homeResidence.address
See Also
ExpressionHandle Class
Eco.Handles Namespace
Example


HandleAdapter Class

HandleAdapter Class
Inheritance Hierarchy See Also
Collapse All
C#
public sealed class HandleAdapter : ITupleListRenderingContext, INotifyOnIdle;
Remarks

This is class Eco.Handles.HandleAdapter.

Inheritance Hierarchy
Eco.Handles.IRenderingContext
    Eco.Handles.ITupleRenderingContext
        Eco.Handles.ITupleListRenderingContext
        Eco.Handles.INotifyOnIdle
            Eco.Handles.HandleAdapter
File

ControlPack.cs

See Also
Inheritance Hierarchy


HandleAdapter.HandleAdapter Constructor

HandleAdapter.HandleAdapter Constructor
HandleAdapter Class Eco.Handles Namespace See Also
Collapse All
C#
public HandleAdapter(
    IElementHandle handle
);
Remarks

This is HandleAdapter, a member of class HandleAdapter.

See Also
HandleAdapter Class
Eco.Handles Namespace


HandleAdapter Methods

HandleAdapter Methods
Public Methods
Collapse All

The methods of the HandleAdapter class are listed here.

Public Methods
Name | Description
EnsureCurrent | This is EnsureCurrent, a member of class HandleAdapter.
GetRenderedTupleForElement | This is GetRenderedTupleForElement, a member of class HandleAdapter.
SetupProperties | This is SetupProperties, a member of class HandleAdapter.


HandleAdapter.EnsureCurrent Method

HandleAdapter.EnsureCurrent Method
HandleAdapter Class Eco.Handles Namespace See Also
Collapse All
C#
public void EnsureCurrent();
Remarks

This is EnsureCurrent, a member of class HandleAdapter.

See Also
HandleAdapter Class
Eco.Handles Namespace


HandleAdapter.GetRenderedTupleForElement Method

HandleAdapter.GetRenderedTupleForElement Method
HandleAdapter Class Eco.Handles Namespace See Also
Collapse All
C#
public object GetRenderedTupleForElement(
    IElement element
);
Remarks

This is GetRenderedTupleForElement, a member of class HandleAdapter.

See Also
HandleAdapter Class
Eco.Handles Namespace


HandleAdapter.SetupProperties Method

HandleAdapter.SetupProperties Method
HandleAdapter Class Eco.Handles Namespace See Also
Collapse All
C#
public void SetupProperties(
    IEnumerable columns,
    bool addDefaultProperties,
    bool addDefaultNestings,
    bool addExternalId,
    bool addSelfColumn,
    MemberVisibility memberVisibility,
    INestingProvider nestings,
    bool designMode,
    NullRowMode nullRowMode,
    bool supportSorting,
    bool allowNew,
    FilterMode filterMode
);
Remarks

This is SetupProperties, a member of class HandleAdapter.

See Also
HandleAdapter Class
Eco.Handles Namespace


HandleAdapter Properties

HandleAdapter Properties
Public Properties
Collapse All

The properties of the HandleAdapter class are listed here.

Public Properties
Name | Description
List | This is List, a member of class HandleAdapter.
TupleDescriptor | This is TupleDescriptor, a member of class HandleAdapter.


HandleAdapter.List Property

HandleAdapter.List Property
HandleAdapter Class Eco.Handles Namespace See Also
Collapse All
C#
public IList List;
Remarks

This is List, a member of class HandleAdapter.

See Also
HandleAdapter Class
Eco.Handles Namespace


HandleAdapter.TupleDescriptor Property

HandleAdapter.TupleDescriptor Property
HandleAdapter Class Eco.Handles Namespace See Also
Collapse All
C#
public RenderedTupleDescriptor TupleDescriptor;
Remarks

This is TupleDescriptor, a member of class HandleAdapter.

See Also
HandleAdapter Class
Eco.Handles Namespace


HandlesStringRes Class

HandlesStringRes Class
Inheritance Hierarchy See Also
Collapse All

Autogenerated class to get compiler safe access to resource strings.

C#
public sealed class HandlesStringRes : StringResources;
Inheritance Hierarchy
Eco.Handles.HandlesStringRes
File

Eco.Handles.Strings.cs

See Also
Inheritance Hierarchy


HandlesStringRes Methods

HandlesStringRes Methods
Public Methods
Collapse All

The methods of the HandlesStringRes class are listed here.

Public Methods
Name | Description
ClassLimitReached | Returns: "An application built with Free Enterprise Core Objects will not handle more than {0} classes."
DeserializationError | Returns: "Deserialization error: {0}"
DeserializationIncompatibleModels | Returns: "Deserialization error: Stream contains incompatible model (checksum: {0} expected {1})"
DeserializationIncompatibleVersions | Returns: "Deserialization error: Stream contains incompatible version (was: {0} expected {1})"
FailedCodederivedMember | Returns: "Failed to derive member {0}.{1} using method {2}. Original message: {3}"
FilenameNotSet | Returns: "{0}.{1} does not specify a filename."
HandleHasNoPropertyNamedSo | Returns: "The handle has no property called {0}"
InvalidAssociatedType | Returns: "Invalid type of associated object in {0}.{1}: {2}. Not a subtype of {3}"
ObjectWithNoId | Returns: "Object with no id: {0}"
ParameterRowIsOutOfRange | Returns: "Parameter 'row' is out of range. Value was {0}, list contains {1} row(s)."
RecursivelyDerivedMember | Returns: "Member {0}.{1} is recursively derived"
sCantInstansiateAbstract | Returns: "Can't instantiate abstract class {0}"
sClassHasNoModelId | Returns: "Class "{0}" has no model id"
sClassIsAbstract | Returns: "Class "{0}" is abstract"
sClassNotVersioned | Returns: "Class {0} is not versioned;"
sFailedToLoadXmlFile | Returns: "Failed to load xml file {0}: {1}"
sFreeVersion | Returns: "Free version, max {0} classes"
sGetTypeSystemServiceMissing | Returns: "{0} lacks GetTypeSystemService method."
sIncompatibleAssignment | Returns: "Tried to assign a value to {0}.{1} that is not compatible with the model (was: {2}, expected {3})"
sInvalidClassId | Returns: "Invalid Class id: {0}"
sInvalidName | Returns: "Invalid name: {0}"
sNameNotUnique | Returns: "Not unique name: {0}"
sNoMemberWithName | Returns: "No member named {0};"
sNotATypeSystemProvider | Returns: "{0} is not ITypeSystemProvider."
sStaticTypeNotMatching | Returns: "Attempt to set handle to type {0} when static type is {1}"
sTrialLicense | Returns: "Trial license, expires in {0} days"
sTypeMismatchInHandle | Returns: "Type mismatch in handle, Element type [{0}], static type is [{1}]"
sUnableToResolveEcoSpaceTypeName | Returns: "Unable to resolve EcoSpaceTypeName {0}"
sUnsupportedCondition | Returns: "This persistencemapper does not support conditions of type {0}"
TriedToAddNullToMultilink | Returns: "Tried to add null to multilink {0}.{1}"
TriedToInsertNullIntoMultilink | Returns: "Tried to insert null into multilink {0}.{1}"
UnableToHandleAttribute | Returns: "Unable to correctly serialize/deserialize attribute {0}.{1} of type {2} ("{3}" <> "{4}")"
UnknownAssociatedType | Returns: "Unknown type of associated object in {0}.{1}: {2}"
UnknownAttribute | Returns: "Unknown attribute {0}.{1}"
UnknownClass | Returns: "Unknown class {0}"
UnknownLink | Returns: "Unknown link {0}.{1}"
UnknownTypeName | Returns: "StaticValueTypeName {0} is not a known type"


HandlesStringRes.ClassLimitReached Method

HandlesStringRes.ClassLimitReached Method
HandlesStringRes Class Eco.Handles Namespace See Also
Collapse All

Returns: "An application built with Free Enterprise Core Objects will not handle more than {0} classes."

C#
public static string ClassLimitReached(
    object param0
);
Remarks

For internal use.

See Also
HandlesStringRes Class
Eco.Handles Namespace


HandlesStringRes.DeserializationError Method

HandlesStringRes.DeserializationError Method
HandlesStringRes Class Eco.Handles Namespace See Also
Collapse All

Returns: "Deserialization error: {0}"

C#
public static string DeserializationError(
    object param0
);
Remarks

For internal use.

See Also
HandlesStringRes Class
Eco.Handles Namespace


HandlesStringRes.DeserializationIncompatibleModels Method

HandlesStringRes.DeserializationIncompatibleModels Method
HandlesStringRes Class Eco.Handles Namespace See Also
Collapse All

Returns: "Deserialization error: Stream contains incompatible model (checksum: {0} expected {1})"

C#
public static string DeserializationIncompatibleModels(
    object param0,
    object param1
);
Remarks

For internal use.

See Also
HandlesStringRes Class
Eco.Handles Namespace


HandlesStringRes.DeserializationIncompatibleVersions Method

HandlesStringRes.DeserializationIncompatibleVersions Method
HandlesStringRes Class Eco.Handles Namespace See Also
Collapse All

Returns: "Deserialization error: Stream contains incompatible version (was: {0} expected {1})"

C#
public static string DeserializationIncompatibleVersions(
    object param0,
    object param1
);
Remarks

For internal use.

See Also
HandlesStringRes Class
Eco.Handles Namespace


HandlesStringRes.FailedCodederivedMember Method

HandlesStringRes.FailedCodederivedMember Method
HandlesStringRes Class Eco.Handles Namespace See Also
Collapse All

Returns: "Failed to derive member {0}.{1} using method {2}. Original message: {3}"

C#
public static string FailedCodederivedMember(
    object param0,
    object param1,
    object param2,
    object param3
);
Remarks

For internal use.

See Also
HandlesStringRes Class
Eco.Handles Namespace


HandlesStringRes.FilenameNotSet Method

HandlesStringRes.FilenameNotSet Method
HandlesStringRes Class Eco.Handles Namespace See Also
Collapse All

Returns: "{0}.{1} does not specify a filename."

C#
public static string FilenameNotSet(
    object param0,
    object param1
);
Remarks

For internal use.

See Also
HandlesStringRes Class
Eco.Handles Namespace


HandlesStringRes.HandleHasNoPropertyNamedSo Method

HandlesStringRes.HandleHasNoPropertyNamedSo Method
HandlesStringRes Class Eco.Handles Namespace See Also
Collapse All

Returns: "The handle has no property called {0}"

C#
public static string HandleHasNoPropertyNamedSo(
    object param0
);
Remarks

For internal use.

See Also
HandlesStringRes Class
Eco.Handles Namespace


HandlesStringRes.InvalidAssociatedType Method

HandlesStringRes.InvalidAssociatedType Method
HandlesStringRes Class Eco.Handles Namespace See Also
Collapse All

Returns: "Invalid type of associated object in {0}.{1}: {2}. Not a subtype of {3}"

C#
public static string InvalidAssociatedType(
    object param0,
    object param1,
    object param2,
    object param3
);
Remarks

For internal use.

See Also
HandlesStringRes Class
Eco.Handles Namespace


HandlesStringRes.ObjectWithNoId Method

HandlesStringRes.ObjectWithNoId Method
HandlesStringRes Class Eco.Handles Namespace See Also
Collapse All

Returns: "Object with no id: {0}"

C#
public static string ObjectWithNoId(
    object param0
);
Remarks

For internal use.

See Also
HandlesStringRes Class
Eco.Handles Namespace


HandlesStringRes.ParameterRowIsOutOfRange Method

HandlesStringRes.ParameterRowIsOutOfRange Method
HandlesStringRes Class Eco.Handles Namespace See Also
Collapse All

Returns: "Parameter 'row' is out of range. Value was {0}, list contains {1} row(s)."

C#
public static string ParameterRowIsOutOfRange(
    object param0,
    object param1
);
Remarks

For internal use.

See Also
HandlesStringRes Class
Eco.Handles Namespace


HandlesStringRes.RecursivelyDerivedMember Method

HandlesStringRes.RecursivelyDerivedMember Method
HandlesStringRes Class Eco.Handles Namespace See Also
Collapse All

Returns: "Member {0}.{1} is recursively derived"

C#
public static string RecursivelyDerivedMember(
    object param0,
    object param1
);
Remarks

For internal use.

See Also
HandlesStringRes Class
Eco.Handles Namespace


HandlesStringRes.sCantInstansiateAbstract Method

HandlesStringRes.sCantInstansiateAbstract Method
HandlesStringRes Class Eco.Handles Namespace See Also
Collapse All

Returns: "Can't instantiate abstract class {0}"

C#
public static string sCantInstansiateAbstract(
    object param0
);
Remarks

For internal use.

See Also
HandlesStringRes Class
Eco.Handles Namespace


HandlesStringRes.sClassHasNoModelId Method

HandlesStringRes.sClassHasNoModelId Method
HandlesStringRes Class Eco.Handles Namespace See Also
Collapse All

Returns: "Class "{0}" has no model id"

C#
public static string sClassHasNoModelId(
    object param0
);
Remarks

For internal use.

See Also
HandlesStringRes Class
Eco.Handles Namespace


HandlesStringRes.sClassIsAbstract Method

HandlesStringRes.sClassIsAbstract Method
HandlesStringRes Class Eco.Handles Namespace See Also
Collapse All

Returns: "Class "{0}" is abstract"

C#
public static string sClassIsAbstract(
    object param0
);
Remarks

For internal use.

See Also
HandlesStringRes Class
Eco.Handles Namespace


HandlesStringRes.sClassNotVersioned Method

HandlesStringRes.sClassNotVersioned Method
HandlesStringRes Class Eco.Handles Namespace See Also
Collapse All

Returns: "Class {0} is not versioned;"

C#
public static string sClassNotVersioned(
    object param0
);
Remarks

For internal use.

See Also
HandlesStringRes Class
Eco.Handles Namespace


HandlesStringRes.sFailedToLoadXmlFile Method

HandlesStringRes.sFailedToLoadXmlFile Method
HandlesStringRes Class Eco.Handles Namespace See Also
Collapse All

Returns: "Failed to load xml file {0}: {1}"

C#
public static string sFailedToLoadXmlFile(
    object param0,
    object param1
);
Remarks

For internal use.

See Also
HandlesStringRes Class
Eco.Handles Namespace


HandlesStringRes.sFreeVersion Method

HandlesStringRes.sFreeVersion Method
HandlesStringRes Class Eco.Handles Namespace See Also
Collapse All

Returns: "Free version, max {0} classes"

C#
public static string sFreeVersion(
    object param0
);
Remarks

For internal use.

See Also
HandlesStringRes Class
Eco.Handles Namespace


HandlesStringRes.sGetTypeSystemServiceMissing Method

HandlesStringRes.sGetTypeSystemServiceMissing Method
HandlesStringRes Class Eco.Handles Namespace See Also
Collapse All

Returns: "{0} lacks GetTypeSystemService method."

C#
public static string sGetTypeSystemServiceMissing(
    object param0
);
Remarks

For internal use.

See Also
HandlesStringRes Class
Eco.Handles Namespace


HandlesStringRes.sIncompatibleAssignment Method

HandlesStringRes.sIncompatibleAssignment Method
HandlesStringRes Class Eco.Handles Namespace See Also
Collapse All

Returns: "Tried to assign a value to {0}.{1} that is not compatible with the model (was: {2}, expected {3})"

C#
public static string sIncompatibleAssignment(
    object param0,
    object param1,
    object param2,
    object param3
);
Remarks

For internal use.

See Also
HandlesStringRes Class
Eco.Handles Namespace


HandlesStringRes.sInvalidClassId Method

HandlesStringRes.sInvalidClassId Method
HandlesStringRes Class Eco.Handles Namespace See Also
Collapse All

Returns: "Invalid Class id: {0}"

C#
public static string sInvalidClassId(
    object param0
);
Remarks

For internal use.

See Also
HandlesStringRes Class
Eco.Handles Namespace


HandlesStringRes.sInvalidName Method

HandlesStringRes.sInvalidName Method
HandlesStringRes Class Eco.Handles Namespace See Also
Collapse All

Returns: "Invalid name: {0}"

C#
public static string sInvalidName(
    object param0
);
Remarks

For internal use.

See Also
HandlesStringRes Class
Eco.Handles Namespace


HandlesStringRes.sNameNotUnique Method

HandlesStringRes.sNameNotUnique Method
HandlesStringRes Class Eco.Handles Namespace See Also
Collapse All

Returns: "Not unique name: {0}"

C#
public static string sNameNotUnique(
    object param0
);
Remarks

For internal use.

See Also
HandlesStringRes Class
Eco.Handles Namespace


HandlesStringRes.sNoMemberWithName Method

HandlesStringRes.sNoMemberWithName Method
HandlesStringRes Class Eco.Handles Namespace See Also
Collapse All

Returns: "No member named {0};"

C#
public static string sNoMemberWithName(
    object param0
);
Remarks

For internal use.

See Also
HandlesStringRes Class
Eco.Handles Namespace


HandlesStringRes.sNotATypeSystemProvider Method

HandlesStringRes.sNotATypeSystemProvider Method
HandlesStringRes Class Eco.Handles Namespace See Also
Collapse All

Returns: "{0} is not ITypeSystemProvider."

C#
public static string sNotATypeSystemProvider(
    object param0
);
Remarks

For internal use.

See Also
HandlesStringRes Class
Eco.Handles Namespace


HandlesStringRes.sStaticTypeNotMatching Method

HandlesStringRes.sStaticTypeNotMatching Method
HandlesStringRes Class Eco.Handles Namespace See Also
Collapse All

Returns: "Attempt to set handle to type {0} when static type is {1}"

C#
public static string sStaticTypeNotMatching(
    object param0,
    object param1
);
Remarks

For internal use.

See Also
HandlesStringRes Class
Eco.Handles Namespace


HandlesStringRes.sTrialLicense Method

HandlesStringRes.sTrialLicense Method
HandlesStringRes Class Eco.Handles Namespace See Also
Collapse All

Returns: "Trial license, expires in {0} days"

C#
public static string sTrialLicense(
    object param0
);
Remarks

For internal use.

See Also
HandlesStringRes Class
Eco.Handles Namespace


HandlesStringRes.sTypeMismatchInHandle Method

HandlesStringRes.sTypeMismatchInHandle Method
HandlesStringRes Class Eco.Handles Namespace See Also
Collapse All

Returns: "Type mismatch in handle, Element type [{0}], static type is [{1}]"

C#
public static string sTypeMismatchInHandle(
    object param0,
    object param1
);
Remarks

For internal use.

See Also
HandlesStringRes Class
Eco.Handles Namespace


HandlesStringRes.sUnableToResolveEcoSpaceTypeName Method

HandlesStringRes.sUnableToResolveEcoSpaceTypeName Method
HandlesStringRes Class Eco.Handles Namespace See Also
Collapse All

Returns: "Unable to resolve EcoSpaceTypeName {0}"

C#
public static string sUnableToResolveEcoSpaceTypeName(
    object param0
);
Remarks

For internal use.

See Also
HandlesStringRes Class
Eco.Handles Namespace


HandlesStringRes.sUnsupportedCondition Method

HandlesStringRes.sUnsupportedCondition Method
HandlesStringRes Class Eco.Handles Namespace See Also
Collapse All

Returns: "This persistencemapper does not support conditions of type {0}"

C#
public static string sUnsupportedCondition(
    object param0
);
Remarks

For internal use.

See Also
HandlesStringRes Class
Eco.Handles Namespace


HandlesStringRes.TriedToAddNullToMultilink Method

HandlesStringRes.TriedToAddNullToMultilink Method
HandlesStringRes Class Eco.Handles Namespace See Also
Collapse All

Returns: "Tried to add null to multilink {0}.{1}"

C#
public static string TriedToAddNullToMultilink(
    object param0,
    object param1
);
Remarks

For internal use.

See Also
HandlesStringRes Class
Eco.Handles Namespace


HandlesStringRes.TriedToInsertNullIntoMultilink Method

HandlesStringRes.TriedToInsertNullIntoMultilink Method
HandlesStringRes Class Eco.Handles Namespace See Also
Collapse All

Returns: "Tried to insert null into multilink {0}.{1}"

C#
public static string TriedToInsertNullIntoMultilink(
    object param0,
    object param1
);
Remarks

For internal use.

See Also
HandlesStringRes Class
Eco.Handles Namespace


HandlesStringRes.UnableToHandleAttribute Method

HandlesStringRes.UnableToHandleAttribute Method
HandlesStringRes Class Eco.Handles Namespace See Also
Collapse All

Returns: "Unable to correctly serialize/deserialize attribute {0}.{1} of type {2} ("{3}" <> "{4}")"

C#
public static string UnableToHandleAttribute(
    object param0,
    object param1,
    object param2,
    object param3,
    object param4
);
Remarks

For internal use.

See Also
HandlesStringRes Class
Eco.Handles Namespace


HandlesStringRes.UnknownAssociatedType Method

HandlesStringRes.UnknownAssociatedType Method
HandlesStringRes Class Eco.Handles Namespace See Also
Collapse All

Returns: "Unknown type of associated object in {0}.{1}: {2}"

C#
public static string UnknownAssociatedType(
    object param0,
    object param1,
    object param2
);
Remarks

For internal use.

See Also
HandlesStringRes Class
Eco.Handles Namespace


HandlesStringRes.UnknownAttribute Method

HandlesStringRes.UnknownAttribute Method
HandlesStringRes Class Eco.Handles Namespace See Also
Collapse All

Returns: "Unknown attribute {0}.{1}"

C#
public static string UnknownAttribute(
    object param0,
    object param1
);
Remarks

For internal use.

See Also
HandlesStringRes Class
Eco.Handles Namespace


HandlesStringRes.UnknownClass Method

HandlesStringRes.UnknownClass Method
HandlesStringRes Class Eco.Handles Namespace See Also
Collapse All

Returns: "Unknown class {0}"

C#
public static string UnknownClass(
    object param0
);
Remarks

For internal use.

See Also
HandlesStringRes Class
Eco.Handles Namespace


HandlesStringRes.UnknownLink Method

HandlesStringRes.UnknownLink Method
HandlesStringRes Class Eco.Handles Namespace See Also
Collapse All

Returns: "Unknown link {0}.{1}"

C#
public static string UnknownLink(
    object param0,
    object param1
);
Remarks

For internal use.

See Also
HandlesStringRes Class
Eco.Handles Namespace


HandlesStringRes.UnknownTypeName Method

HandlesStringRes.UnknownTypeName Method
HandlesStringRes Class Eco.Handles Namespace See Also
Collapse All

Returns: "StaticValueTypeName {0} is not a known type"

C#
public static string UnknownTypeName(
    object param0
);
Remarks

For internal use.

See Also
HandlesStringRes Class
Eco.Handles Namespace


HandlesStringRes Properties

HandlesStringRes Properties
Public Properties
Collapse All

The properties of the HandlesStringRes class are listed here.

Public Properties
Name | Description
CantChangePMapperOnActiveSystem | Returns: "Changing PersistenceMapper on an active system is not allowed"
ComponentCategoryDroopyEyes | Returns: "DroopyEyes"
ComponentCategoryHandles | Returns: "ECO|Handles"
ComponentCategoryPersistence | Returns: "ECO|Persistence"
DeserializationEndOfStream | Returns: "Deserialization error: Stream position at end already"
DeserializationNoEcoSpace | Returns: "Deserialization error: Stream does not contain a serialized ecospace"
DeserializationStreamEmpty | Returns: "Deserialization error: Stream empty"
HandleNotEnabled | Returns: "Handle is not enabled"
LicenseStatus | Returns: "License status"
PropertyAllowDeactivateDirty | Returns: "Allow deactivation of ecospace with dirty objects in memory"
PropertyEnforceStringLength | Returns: "If true, string attributes can not exceed the maximum length specified in the model"
s4pack | Returns: "Licensed for 4 developers"
s8pack | Returns: "Licensed for 8 developers"
sCacheContentMismatch | Returns: "Cache contents do not match"
sCannotLinkAssignedSingleLink | Returns: "Cannot link this single link. It is already assigned."
sCannotLinkLinkedSingleLink | Returns: "Cannot link this single link. It is already assigned."
sCannotSetAssociationEndDirectly | Returns: "Cannot set this association end directly"
sCannotSetLinkObjectReference | Returns: "Cannot set a link object reference directly"
sCannotSetOrderNo_NotAReference | Returns: "Cannot set order number. Member is not an object reference"
sCannotSetOrderNumOnUnassignedLink | Returns: "Cannot set the order number when the link is not assigned"
sCannotSetValueOfNonembeddedLinkInCache | Returns: "Cannot set value of non-embedded link in cache"
sCantAccessVersionInfoWithoutAPersistenceMapper | Returns: "Can't access version-info on a transient system"
sCantUpdateTransientObject | Returns: "Can't update transient object"
sCategoryBehaviour | Returns: "ECO|Behaviour"
sCategoryBinding | Returns: "ECO|DataBinding"
sCategoryConnections | Returns: "ECO|Connections"
sCategoryDerivation | Returns: "ECO|Derivation"
sCategoryNesting | Returns: "ECO|Nesting"
sCategoryOCL | Returns: "ECO|OCL"
sCategoryPersistence | Returns: "ECO|Persistence"
sCategoryPresentation | Returns: "ECO|Presentation"
sCategoryTypes | Returns: "ECO|Types"
sCircularReference | Returns: "Circular reference."
sDeactivatingWithDirtyObjects | Returns: "Deactivating system with dirty objects."
sDescriptorIsNotAProperty | Returns: "Descriptor is not a property of object."
sDeserializingActive | Returns: "Deserializing to an active EcoSpace."
sEcoSpaceNotSet | Returns: "EcoSpace not set"
sElementBelongsToAnotherEcoSpace | Returns: "Element belongs to another EcoSpace"
sExpired | Returns: "Expired"
sExpiredShort | Returns: "Trial license expired"
sFileIsInconsistent | Returns: "File is inconsistent"
sFileWrittenSinceLastAccess | Returns: "File has been written to since it was last accessed"
sForeignObjectsInUpdateDatabase | Returns: "UpdateDatabase called with object that does not belong to the same EcoSpace"
sHandleHasNoEcoSpace | Returns: "Handle has no EcoSpace"
sHandleHasNoEcoSpaceTypeName | Returns: "Handle has no EcoSpaceTypeName"
sHandleHasNoStaticValueTypeName | Returns: "Handle has no StaticValueTypeName"
sHelpSetFilename | Returns: "Specify the filename containing the XML-data"
sInconsistentUmlRtModel | Returns: "Inconsistent UmlRT Model"
sInternalIDFromOtherEcoSpace | Returns: "Internal id from other EcoSpace instance"
sLicensedForDifferentIDE | Returns: "Licensed, but for a different IDE"
sLicenseHasExpired | Returns: "Your ECO trial license has expired! ECO will run with limitations."
sListContainsNullLocator | Returns: "List Containes null locator"
sListIsReadOnly | Returns: "List is read only"
sMemberIsDerived | Returns: "Member is derived"
sMultiLinksNotModifiableInICache | Returns: "Multi-end links are not modifiable in ICache"
sNoLicense | Returns: "No license for Enterprise Core Objects found!"
sNoObjectsInParameter | Returns: "No objects in parameter;"
sNoPersistenceControllerAvailable | Returns: "EcoSpace has no PersistenceMapper"
sNoRuntimeLicense | Returns: "No ECO runtime license found. Make sure your project includes a licenses.licx file."
sNotConnected | Returns: "Not Connected"
sNotLicensed | Returns: "Not licensed"
sNullRowMode | Returns: "Conditonally add row for null object."
sObjectIsDirtyOrTransient | Returns: "Object is dirty or transient"
sObjectIsTransient | Returns: "Object is transient"
sObjectNotDestroyable | Returns: "Object is not destroyable. It is either modified or existing"
sObjectNotFoundInFile | Returns: "Object not found in file"
sOclPSHandleNotConnected | Returns: "The handle is not connected to a root handle"
sOclPSHandleUnableToFindService | Returns: "Unable to find an IOclPsService"
sOwnerNotSet | Returns: "Owner not set"
sPersistenceHandleIsActive | Returns: "PersistenceHandle is active"
sPreconditionsNotAllowed | Returns: "Preconditions not allowed for this mapper"
sPropertyAddDefaultNestings | Returns: "Add default nestings."
sPropertyAddDefaultProperties | Returns: "Add the default columns."
sPropertyAddExternalId | Returns: "Add column for external ID."
sPropertyAddRootVariables | Returns: "Add variables from RootHandle to own variables."
sPropertyAddSelfColumn | Returns: "Add a column refering to the element."
sPropertyAllowNew | Returns: "Allow New"
sPropertyAsExternalId | Returns: "Represent ECO object as ExternalId"
sPropertyCacheData | Returns: "If true, the file is cached through the session."
sPropertyColumnName | Returns: "Name of the property to add to the binding list."
sPropertyColumns | Returns: "Columns surfaced by this handle."
sPropertyDefaultLinkFetchStrategy | Returns: "Controls how to load relations by default"
sPropertyDerivationExpression | Returns: "OCL expression for deriving property."
sPropertyDeriveValue | Returns: "For deriving columns with code."
sPropertyEcoSpaceTypeName | Returns: "The type of the EcoSpace that defines the type system to use in design time."
sPropertyElementHandle | Returns: "Handle supplying the value of the variable."
sPropertyEnabled | Returns: "Determines if component is serving values to connected components."
sPropertyExpression | Returns: "OCL Expression used to populate the handle."
sPropertyFileName | Returns: "The file used to persist data."
sPropertyFilter | Returns: "Filter expression"
sPropertyFilterMode | Returns: "Filter Mode"
sPropertyInitialValues | Returns: "Initial value for the element of the handle"
sPropertyIsReadOnly | Returns: "Property is readonly."
sPropertyMaxAnswers | Returns: "The maximum number of objects to be returned by the query"
sPropertyMemberVisibility | Returns: "Filter exposed members based on their visibility."
sPropertyNested | Returns: "Property is Nested."
sPropertyNesting | Returns: "Name of nesting to use if Property is Nested."
sPropertyNestings | Returns: "Nestings."
sPropertyNullElementRepresentation | Returns: "Representation for null row."
sPropertyOclVariableCollection | Returns: "Collection of the variables defined."
sPropertyOffset | Returns: "The offset in the query result set from where to start returning objects"
sPropertyOptimisticLocking | Returns: "Enabled optimistic locking."
sPropertyPersistenceMapper | Returns: "Component managing EcoSpace's persistence."
sPropertyReverseDeriveValue | Returns: "For reverse deriving columns with code."
sPropertyRootHandle | Returns: "Handle supplying uplink value."
sPropertyStaticValueTypeName | Returns: "Static type for handle."
sPropertySupportSorting | Returns: "Support Sorting"
sPropertySyncHandler | Returns: "Specify a SyncHandler component if Sync is to be active"
sPropertyTypeName | Returns: "Type of the derived property."
sPropertyUpdateWholeObjects | Returns: "Enables updating entire objects."
sPropertyVariableName | Returns: "Name of the variable as used in expression."
sPropertyVariables | Returns: "OCL variables to be known by handle."
sRootContextNotSet | Returns: "The owner's context is not set"
sSingleUserLicense | Returns: "Single developer license"
sSiteLicense | Returns: "Site License"
sSpecifyXmlFile | Returns: "Specify file to use for data storage"
sSupportsSyncIsNotEnabled | Returns: "Either your PersistenceMapper does not support synchronization, or it is currently disabled"
sSyncNotActive | Returns: "Sync not active"
sTypeOfValueUnknown | Returns: "value is not of a known type."
sTypeSystemProblems | Returns: "type system problems..."
sVariableRoot | Returns: "Variable"
sWrongIDE | Returns: "Your ECO license is not valid for this IDE! ECO will run with limitations."
sWrongIDEShort | Returns: "Wrong ECO license"
sWrongPMapperReturned | Returns: "Wrong persistence mapper returned"
sXmlFileFilter | Returns: "XML-files (*.xml)|*.xml|All files (*.*)|*.*"
UnknownAutoincKey | Returns: "Unknown autoinc key"
XmlDocumentContainsNoDatablock | Returns: "XmlDocument does not contain a datablock"


HandlesStringRes.CantChangePMapperOnActiveSystem Property

HandlesStringRes.CantChangePMapperOnActiveSystem Property
HandlesStringRes Class Eco.Handles Namespace See Also
Collapse All

Returns: "Changing PersistenceMapper on an active system is not allowed"

C#
public static string CantChangePMapperOnActiveSystem;
Remarks

For internal use.

See Also
HandlesStringRes Class
Eco.Handles Namespace


HandlesStringRes.ComponentCategoryDroopyEyes Property

HandlesStringRes.ComponentCategoryDroopyEyes Property
HandlesStringRes Class Eco.Handles Namespace See Also
Collapse All

Returns: "DroopyEyes"

C#
public static string ComponentCategoryDroopyEyes;
Remarks

For internal use.

See Also
HandlesStringRes Class
Eco.Handles Namespace


HandlesStringRes.ComponentCategoryHandles Property

HandlesStringRes.ComponentCategoryHandles Property
HandlesStringRes Class Eco.Handles Namespace See Also
Collapse All

Returns: "ECO|Handles"

C#
public static string ComponentCategoryHandles;
Remarks

For internal use.

See Also
HandlesStringRes Class
Eco.Handles Namespace


HandlesStringRes.ComponentCategoryPersistence Property

HandlesStringRes.ComponentCategoryPersistence Property
HandlesStringRes Class Eco.Handles Namespace See Also
Collapse All

Returns: "ECO|Persistence"

C#
public static string ComponentCategoryPersistence;
Remarks

For internal use.

See Also
HandlesStringRes Class
Eco.Handles Namespace


HandlesStringRes.DeserializationEndOfStream Property

HandlesStringRes.DeserializationEndOfStream Property
HandlesStringRes Class Eco.Handles Namespace See Also
Collapse All

Returns: "Deserialization error: Stream position at end already"

C#
public static string DeserializationEndOfStream;
Remarks

For internal use.

See Also
HandlesStringRes Class
Eco.Handles Namespace


HandlesStringRes.DeserializationNoEcoSpace Property

HandlesStringRes.DeserializationNoEcoSpace Property
HandlesStringRes Class Eco.Handles Namespace See Also
Collapse All

Returns: "Deserialization error: Stream does not contain a serialized ecospace"

C#
public static string DeserializationNoEcoSpace;
Remarks

For internal use.

See Also
HandlesStringRes Class
Eco.Handles Namespace


HandlesStringRes.DeserializationStreamEmpty Property

HandlesStringRes.DeserializationStreamEmpty Property
HandlesStringRes Class Eco.Handles Namespace See Also
Collapse All

Returns: "Deserialization error: Stream empty"

C#
public static string DeserializationStreamEmpty;
Remarks

For internal use.

See Also
HandlesStringRes Class
Eco.Handles Namespace


HandlesStringRes.HandleNotEnabled Property

HandlesStringRes.HandleNotEnabled Property
HandlesStringRes Class Eco.Handles Namespace See Also
Collapse All

Returns: "Handle is not enabled"

C#
public static string HandleNotEnabled;
Remarks

For internal use.

See Also
HandlesStringRes Class
Eco.Handles Namespace


HandlesStringRes.LicenseStatus Property

HandlesStringRes.LicenseStatus Property
HandlesStringRes Class Eco.Handles Namespace See Also
Collapse All

Returns: "License status"

C#
public static string LicenseStatus;
Remarks

For internal use.

See Also
HandlesStringRes Class
Eco.Handles Namespace


HandlesStringRes.PropertyAllowDeactivateDirty Property

HandlesStringRes.PropertyAllowDeactivateDirty Property
HandlesStringRes Class Eco.Handles Namespace See Also
Collapse All

Returns: "Allow deactivation of ecospace with dirty objects in memory"

C#
public static string PropertyAllowDeactivateDirty;
Remarks

For internal use.

See Also
HandlesStringRes Class
Eco.Handles Namespace


HandlesStringRes.PropertyEnforceStringLength Property

HandlesStringRes.PropertyEnforceStringLength Property
HandlesStringRes Class Eco.Handles Namespace See Also
Collapse All

Returns: "If true, string attributes can not exceed the maximum length specified in the model"

C#
public static string PropertyEnforceStringLength;
Remarks

For internal use.

See Also
HandlesStringRes Class
Eco.Handles Namespace


HandlesStringRes.s4pack Property

HandlesStringRes.s4pack Property
HandlesStringRes Class Eco.Handles Namespace See Also
Collapse All

Returns: "Licensed for 4 developers"

C#
public static string s4pack;
Remarks

For internal use.

See Also
HandlesStringRes Class
Eco.Handles Namespace


HandlesStringRes.s8pack Property

HandlesStringRes.s8pack Property
HandlesStringRes Class Eco.Handles Namespace See Also
Collapse All

Returns: "Licensed for 8 developers"

C#
public static string s8pack;
Remarks

For internal use.

See Also
HandlesStringRes Class
Eco.Handles Namespace


HandlesStringRes.sCacheContentMismatch Property

HandlesStringRes.sCacheContentMismatch Property
HandlesStringRes Class Eco.Handles Namespace See Also
Collapse All

Returns: "Cache contents do not match"

C#
public static string sCacheContentMismatch;
Remarks

For internal use.

See Also
HandlesStringRes Class
Eco.Handles Namespace


HandlesStringRes.sCannotLinkAssignedSingleLink Property

HandlesStringRes.sCannotLinkAssignedSingleLink Property
HandlesStringRes Class Eco.Handles Namespace See Also
Collapse All

Returns: "Cannot link this single link. It is already assigned."

C#
public static string sCannotLinkAssignedSingleLink;
Remarks

For internal use.

See Also
HandlesStringRes Class
Eco.Handles Namespace


HandlesStringRes.sCannotLinkLinkedSingleLink Property

HandlesStringRes.sCannotLinkLinkedSingleLink Property
HandlesStringRes Class Eco.Handles Namespace See Also
Collapse All

Returns: "Cannot link this single link. It is already assigned."

C#
public static string sCannotLinkLinkedSingleLink;
Remarks

For internal use.

See Also
HandlesStringRes Class
Eco.Handles Namespace


HandlesStringRes.sCannotSetAssociationEndDirectly Property

HandlesStringRes.sCannotSetAssociationEndDirectly Property
HandlesStringRes Class Eco.Handles Namespace See Also
Collapse All

Returns: "Cannot set this association end directly"

C#
public static string sCannotSetAssociationEndDirectly;
Remarks

For internal use.

See Also
HandlesStringRes Class
Eco.Handles Namespace


HandlesStringRes.sCannotSetLinkObjectReference Property

HandlesStringRes.sCannotSetLinkObjectReference Property
HandlesStringRes Class Eco.Handles Namespace See Also
Collapse All

Returns: "Cannot set a link object reference directly"

C#
public static string sCannotSetLinkObjectReference;
Remarks

For internal use.

See Also
HandlesStringRes Class
Eco.Handles Namespace


HandlesStringRes.sCannotSetOrderNo_NotAReference Property

HandlesStringRes.sCannotSetOrderNo_NotAReference Property
HandlesStringRes Class Eco.Handles Namespace See Also
Collapse All

Returns: "Cannot set order number. Member is not an object reference"

C#
public static string sCannotSetOrderNo_NotAReference;
Remarks

For internal use.

See Also
HandlesStringRes Class
Eco.Handles Namespace


HandlesStringRes.sCannotSetOrderNumOnUnassignedLink Property

HandlesStringRes.sCannotSetOrderNumOnUnassignedLink Property
HandlesStringRes Class Eco.Handles Namespace See Also
Collapse All

Returns: "Cannot set the order number when the link is not assigned"

C#
public static string sCannotSetOrderNumOnUnassignedLink;
Remarks

For internal use.

See Also
HandlesStringRes Class
Eco.Handles Namespace


HandlesStringRes.sCannotSetValueOfNonembeddedLinkInCache Property

HandlesStringRes.sCannotSetValueOfNonembeddedLinkInCache Property
HandlesStringRes Class Eco.Handles Namespace See Also
Collapse All

Returns: "Cannot set value of non-embedded link in cache"

C#
public static string sCannotSetValueOfNonembeddedLinkInCache;
Remarks

For internal use.

See Also
HandlesStringRes Class
Eco.Handles Namespace


HandlesStringRes.sCantAccessVersionInfoWithoutAPersistenceMapper Property

HandlesStringRes.sCantAccessVersionInfoWithoutAPersistenceMapper Property
HandlesStringRes Class Eco.Handles Namespace See Also
Collapse All

Returns: "Can't access version-info on a transient system"

C#
public static string sCantAccessVersionInfoWithoutAPersistenceMapper;
Remarks

For internal use.

See Also
HandlesStringRes Class
Eco.Handles Namespace


HandlesStringRes.sCantUpdateTransientObject Property

HandlesStringRes.sCantUpdateTransientObject Property
HandlesStringRes Class Eco.Handles Namespace See Also
Collapse All

Returns: "Can't update transient object"

C#
public static string sCantUpdateTransientObject;
Remarks

For internal use.

See Also
HandlesStringRes Class
Eco.Handles Namespace


HandlesStringRes.sCategoryBehaviour Property

HandlesStringRes.sCategoryBehaviour Property
HandlesStringRes Class Eco.Handles Namespace See Also
Collapse All

Returns: "ECO|Behaviour"

C#
public static string sCategoryBehaviour;
Remarks

For internal use.

See Also
HandlesStringRes Class
Eco.Handles Namespace


HandlesStringRes.sCategoryBinding Property

HandlesStringRes.sCategoryBinding Property
HandlesStringRes Class Eco.Handles Namespace See Also
Collapse All

Returns: "ECO|DataBinding"

C#
public static string sCategoryBinding;
Remarks

For internal use.

See Also
HandlesStringRes Class
Eco.Handles Namespace


HandlesStringRes.sCategoryConnections Property

HandlesStringRes.sCategoryConnections Property
HandlesStringRes Class Eco.Handles Namespace See Also
Collapse All

Returns: "ECO|Connections"

C#
public static string sCategoryConnections;
Remarks

For internal use.

See Also
HandlesStringRes Class
Eco.Handles Namespace


HandlesStringRes.sCategoryDerivation Property

HandlesStringRes.sCategoryDerivation Property
HandlesStringRes Class Eco.Handles Namespace See Also
Collapse All

Returns: "ECO|Derivation"

C#
public static string sCategoryDerivation;
Remarks

For internal use.

See Also
HandlesStringRes Class
Eco.Handles Namespace


HandlesStringRes.sCategoryNesting Property

HandlesStringRes.sCategoryNesting Property
HandlesStringRes Class Eco.Handles Namespace See Also
Collapse All

Returns: "ECO|Nesting"

C#
public static string sCategoryNesting;
Remarks

For internal use.

See Also
HandlesStringRes Class
Eco.Handles Namespace


HandlesStringRes.sCategoryOCL Property

HandlesStringRes.sCategoryOCL Property
HandlesStringRes Class Eco.Handles Namespace See Also
Collapse All

Returns: "ECO|OCL"

C#
public static string sCategoryOCL;
Remarks

For internal use.

See Also
HandlesStringRes Class
Eco.Handles Namespace


HandlesStringRes.sCategoryPersistence Property

HandlesStringRes.sCategoryPersistence Property
HandlesStringRes Class Eco.Handles Namespace See Also
Collapse All

Returns: "ECO|Persistence"

C#
public static string sCategoryPersistence;
Remarks

For internal use.

See Also
HandlesStringRes Class
Eco.Handles Namespace


HandlesStringRes.sCategoryPresentation Property

HandlesStringRes.sCategoryPresentation Property
HandlesStringRes Class Eco.Handles Namespace See Also
Collapse All

Returns: "ECO|Presentation"

C#
public static string sCategoryPresentation;
Remarks

For internal use.

See Also
HandlesStringRes Class
Eco.Handles Namespace


HandlesStringRes.sCategoryTypes Property

HandlesStringRes.sCategoryTypes Property
HandlesStringRes Class Eco.Handles Namespace See Also
Collapse All

Returns: "ECO|Types"

C#
public static string sCategoryTypes;
Remarks

For internal use.

See Also
HandlesStringRes Class
Eco.Handles Namespace


HandlesStringRes.sCircularReference Property

HandlesStringRes.sCircularReference Property
HandlesStringRes Class Eco.Handles Namespace See Also
Collapse All

Returns: "Circular reference."

C#
public static string sCircularReference;
Remarks

For internal use.

See Also
HandlesStringRes Class
Eco.Handles Namespace


HandlesStringRes.sDeactivatingWithDirtyObjects Property

HandlesStringRes.sDeactivatingWithDirtyObjects Property
HandlesStringRes Class Eco.Handles Namespace See Also
Collapse All

Returns: "Deactivating system with dirty objects."

C#
public static string sDeactivatingWithDirtyObjects;
Remarks

For internal use.

See Also
HandlesStringRes Class
Eco.Handles Namespace


HandlesStringRes.sDescriptorIsNotAProperty Property

HandlesStringRes.sDescriptorIsNotAProperty Property
HandlesStringRes Class Eco.Handles Namespace See Also
Collapse All

Returns: "Descriptor is not a property of object."

C#
public static string sDescriptorIsNotAProperty;
Remarks

For internal use.

See Also
HandlesStringRes Class
Eco.Handles Namespace


HandlesStringRes.sDeserializingActive Property

HandlesStringRes.sDeserializingActive Property
HandlesStringRes Class Eco.Handles Namespace See Also
Collapse All

Returns: "Deserializing to an active EcoSpace."

C#
public static string sDeserializingActive;
Remarks

For internal use.

See Also
HandlesStringRes Class
Eco.Handles Namespace


HandlesStringRes.sEcoSpaceNotSet Property

HandlesStringRes.sEcoSpaceNotSet Property
HandlesStringRes Class Eco.Handles Namespace See Also
Collapse All

Returns: "EcoSpace not set"

C#
public static string sEcoSpaceNotSet;
Remarks

For internal use.

See Also
HandlesStringRes Class
Eco.Handles Namespace


HandlesStringRes.sElementBelongsToAnotherEcoSpace Property

HandlesStringRes.sElementBelongsToAnotherEcoSpace Property
HandlesStringRes Class Eco.Handles Namespace See Also
Collapse All

Returns: "Element belongs to another EcoSpace"

C#
public static string sElementBelongsToAnotherEcoSpace;
Remarks

For internal use.

See Also
HandlesStringRes Class
Eco.Handles Namespace


HandlesStringRes.sExpired Property

HandlesStringRes.sExpired Property
HandlesStringRes Class Eco.Handles Namespace See Also
Collapse All

Returns: "Expired"

C#
public static string sExpired;
Remarks

For internal use.

See Also
HandlesStringRes Class
Eco.Handles Namespace


HandlesStringRes.sExpiredShort Property

HandlesStringRes.sExpiredShort Property
HandlesStringRes Class Eco.Handles Namespace See Also
Collapse All

Returns: "Trial license expired"

C#
public static string sExpiredShort;
Remarks

For internal use.

See Also
HandlesStringRes Class
Eco.Handles Namespace


HandlesStringRes.sFileIsInconsistent Property

HandlesStringRes.sFileIsInconsistent Property
HandlesStringRes Class Eco.Handles Namespace See Also
Collapse All

Returns: "File is inconsistent"

C#
public static string sFileIsInconsistent;
Remarks

For internal use.

See Also
HandlesStringRes Class
Eco.Handles Namespace


HandlesStringRes.sFileWrittenSinceLastAccess Property

HandlesStringRes.sFileWrittenSinceLastAccess Property
HandlesStringRes Class Eco.Handles Namespace See Also
Collapse All

Returns: "File has been written to since it was last accessed"

C#
public static string sFileWrittenSinceLastAccess;
Remarks

For internal use.

See Also
HandlesStringRes Class
Eco.Handles Namespace


HandlesStringRes.sForeignObjectsInUpdateDatabase Property

HandlesStringRes.sForeignObjectsInUpdateDatabase Property
HandlesStringRes Class Eco.Handles Namespace See Also
Collapse All

Returns: "UpdateDatabase called with object that does not belong to the same EcoSpace"

C#
public static string sForeignObjectsInUpdateDatabase;
Remarks

For internal use.

See Also
HandlesStringRes Class
Eco.Handles Namespace


HandlesStringRes.sHandleHasNoEcoSpace Property

HandlesStringRes.sHandleHasNoEcoSpace Property
HandlesStringRes Class Eco.Handles Namespace See Also
Collapse All

Returns: "Handle has no EcoSpace"

C#
public static string sHandleHasNoEcoSpace;
Remarks

For internal use.

See Also
HandlesStringRes Class
Eco.Handles Namespace


HandlesStringRes.sHandleHasNoEcoSpaceTypeName Property

HandlesStringRes.sHandleHasNoEcoSpaceTypeName Property
HandlesStringRes Class Eco.Handles Namespace See Also
Collapse All

Returns: "Handle has no EcoSpaceTypeName"

C#
public static string sHandleHasNoEcoSpaceTypeName;
Remarks

For internal use.

See Also
HandlesStringRes Class
Eco.Handles Namespace


HandlesStringRes.sHandleHasNoStaticValueTypeName Property

HandlesStringRes.sHandleHasNoStaticValueTypeName Property
HandlesStringRes Class Eco.Handles Namespace See Also
Collapse All

Returns: "Handle has no StaticValueTypeName"

C#
public static string sHandleHasNoStaticValueTypeName;
Remarks

For internal use.

See Also
HandlesStringRes Class
Eco.Handles Namespace


HandlesStringRes.sHelpSetFilename Property

HandlesStringRes.sHelpSetFilename Property
HandlesStringRes Class Eco.Handles Namespace See Also
Collapse All

Returns: "Specify the filename containing the XML-data"

C#
public static string sHelpSetFilename;
Remarks

For internal use.

See Also
HandlesStringRes Class
Eco.Handles Namespace


HandlesStringRes.sInconsistentUmlRtModel Property

HandlesStringRes.sInconsistentUmlRtModel Property
HandlesStringRes Class Eco.Handles Namespace See Also
Collapse All

Returns: "Inconsistent UmlRT Model"

C#
public static string sInconsistentUmlRtModel;
Remarks

For internal use.

See Also
HandlesStringRes Class
Eco.Handles Namespace


HandlesStringRes.sInternalIDFromOtherEcoSpace Property

HandlesStringRes.sInternalIDFromOtherEcoSpace Property
HandlesStringRes Class Eco.Handles Namespace See Also
Collapse All

Returns: "Internal id from other EcoSpace instance"

C#
public static string sInternalIDFromOtherEcoSpace;
Remarks

For internal use.

See Also
HandlesStringRes Class
Eco.Handles Namespace


HandlesStringRes.sLicensedForDifferentIDE Property

HandlesStringRes.sLicensedForDifferentIDE Property
HandlesStringRes Class Eco.Handles Namespace See Also
Collapse All

Returns: "Licensed, but for a different IDE"

C#
public static string sLicensedForDifferentIDE;
Remarks

For internal use.

See Also
HandlesStringRes Class
Eco.Handles Namespace


HandlesStringRes.sLicenseHasExpired Property

HandlesStringRes.sLicenseHasExpired Property
HandlesStringRes Class Eco.Handles Namespace See Also
Collapse All

Returns: "Your ECO trial license has expired! ECO will run with limitations."

C#
public static string sLicenseHasExpired;
Remarks

For internal use.

See Also
HandlesStringRes Class
Eco.Handles Namespace


HandlesStringRes.sListContainsNullLocator Property

HandlesStringRes.sListContainsNullLocator Property
HandlesStringRes Class Eco.Handles Namespace See Also
Collapse All

Returns: "List Containes null locator"

C#
public static string sListContainsNullLocator;
Remarks

For internal use.

See Also
HandlesStringRes Class
Eco.Handles Namespace


HandlesStringRes.sListIsReadOnly Property

HandlesStringRes.sListIsReadOnly Property
HandlesStringRes Class Eco.Handles Namespace See Also
Collapse All

Returns: "List is read only"

C#
public static string sListIsReadOnly;
Remarks

For internal use.

See Also
HandlesStringRes Class
Eco.Handles Namespace


HandlesStringRes.sMemberIsDerived Property

HandlesStringRes.sMemberIsDerived Property
HandlesStringRes Class Eco.Handles Namespace See Also
Collapse All

Returns: "Member is derived"

C#
public static string sMemberIsDerived;
Remarks

For internal use.

See Also
HandlesStringRes Class
Eco.Handles Namespace


HandlesStringRes.sMultiLinksNotModifiableInICache Property

HandlesStringRes.sMultiLinksNotModifiableInICache Property
HandlesStringRes Class Eco.Handles Namespace See Also
Collapse All

Returns: "Multi-end links are not modifiable in ICache"

C#
public static string sMultiLinksNotModifiableInICache;
Remarks

For internal use.

See Also
HandlesStringRes Class
Eco.Handles Namespace


HandlesStringRes.sNoLicense Property

HandlesStringRes.sNoLicense Property
HandlesStringRes Class Eco.Handles Namespace See Also
Collapse All

Returns: "No license for Enterprise Core Objects found!"

C#
public static string sNoLicense;
Remarks

For internal use.

See Also
HandlesStringRes Class
Eco.Handles Namespace


HandlesStringRes.sNoObjectsInParameter Property

HandlesStringRes.sNoObjectsInParameter Property
HandlesStringRes Class Eco.Handles Namespace See Also
Collapse All

Returns: "No objects in parameter;"

C#
public static string sNoObjectsInParameter;
Remarks

For internal use.

See Also
HandlesStringRes Class
Eco.Handles Namespace


HandlesStringRes.sNoPersistenceControllerAvailable Property

HandlesStringRes.sNoPersistenceControllerAvailable Property
HandlesStringRes Class Eco.Handles Namespace See Also
Collapse All

Returns: "EcoSpace has no PersistenceMapper"

C#
public static string sNoPersistenceControllerAvailable;
Remarks

For internal use.

See Also
HandlesStringRes Class
Eco.Handles Namespace


HandlesStringRes.sNoRuntimeLicense Property

HandlesStringRes.sNoRuntimeLicense Property
HandlesStringRes Class Eco.Handles Namespace See Also
Collapse All

Returns: "No ECO runtime license found. Make sure your project includes a licenses.licx file."

C#
public static string sNoRuntimeLicense;
Remarks

For internal use.

See Also
HandlesStringRes Class
Eco.Handles Namespace


HandlesStringRes.sNotConnected Property

HandlesStringRes.sNotConnected Property
HandlesStringRes Class Eco.Handles Namespace See Also
Collapse All

Returns: "Not Connected"

C#
public static string sNotConnected;
Remarks

For internal use.

See Also
HandlesStringRes Class
Eco.Handles Namespace


HandlesStringRes.sNotLicensed Property

HandlesStringRes.sNotLicensed Property
HandlesStringRes Class Eco.Handles Namespace See Also
Collapse All

Returns: "Not licensed"

C#
public static string sNotLicensed;
Remarks

For internal use.

See Also
HandlesStringRes Class
Eco.Handles Namespace


HandlesStringRes.sNullRowMode Property

HandlesStringRes.sNullRowMode Property
HandlesStringRes Class Eco.Handles Namespace See Also
Collapse All

Returns: "Conditonally add row for null object."

C#
public static string sNullRowMode;
Remarks

For internal use.

See Also
HandlesStringRes Class
Eco.Handles Namespace


HandlesStringRes.sObjectIsDirtyOrTransient Property

HandlesStringRes.sObjectIsDirtyOrTransient Property
HandlesStringRes Class Eco.Handles Namespace See Also
Collapse All

Returns: "Object is dirty or transient"

C#
public static string sObjectIsDirtyOrTransient;
Remarks

For internal use.

See Also
HandlesStringRes Class
Eco.Handles Namespace


HandlesStringRes.sObjectIsTransient Property

HandlesStringRes.sObjectIsTransient Property
HandlesStringRes Class Eco.Handles Namespace See Also
Collapse All

Returns: "Object is transient"

C#
public static string sObjectIsTransient;
Remarks

For internal use.

See Also
HandlesStringRes Class
Eco.Handles Namespace


HandlesStringRes.sObjectNotDestroyable Property

HandlesStringRes.sObjectNotDestroyable Property
HandlesStringRes Class Eco.Handles Namespace See Also
Collapse All

Returns: "Object is not destroyable. It is either modified or existing"

C#
public static string sObjectNotDestroyable;
Remarks

For internal use.

See Also
HandlesStringRes Class
Eco.Handles Namespace


HandlesStringRes.sObjectNotFoundInFile Property

HandlesStringRes.sObjectNotFoundInFile Property
HandlesStringRes Class Eco.Handles Namespace See Also
Collapse All

Returns: "Object not found in file"

C#
public static string sObjectNotFoundInFile;
Remarks

For internal use.

See Also
HandlesStringRes Class
Eco.Handles Namespace


HandlesStringRes.sOclPSHandleNotConnected Property

HandlesStringRes.sOclPSHandleNotConnected Property
HandlesStringRes Class Eco.Handles Namespace See Also
Collapse All

Returns: "The handle is not connected to a root handle"

C#
public static string sOclPSHandleNotConnected;
Remarks

For internal use.

See Also
HandlesStringRes Class
Eco.Handles Namespace


HandlesStringRes.sOclPSHandleUnableToFindService Property

HandlesStringRes.sOclPSHandleUnableToFindService Property
HandlesStringRes Class Eco.Handles Namespace See Also
Collapse All

Returns: "Unable to find an IOclPsService"

C#
public static string sOclPSHandleUnableToFindService;
Remarks

For internal use.

See Also
HandlesStringRes Class
Eco.Handles Namespace


HandlesStringRes.sOwnerNotSet Property

HandlesStringRes.sOwnerNotSet Property
HandlesStringRes Class Eco.Handles Namespace See Also
Collapse All

Returns: "Owner not set"

C#
public static string sOwnerNotSet;
Remarks

For internal use.

See Also
HandlesStringRes Class
Eco.Handles Namespace


HandlesStringRes.sPersistenceHandleIsActive Property

HandlesStringRes.sPersistenceHandleIsActive Property
HandlesStringRes Class Eco.Handles Namespace See Also
Collapse All

Returns: "PersistenceHandle is active"

C#
public static string sPersistenceHandleIsActive;
Remarks

For internal use.

See Also
HandlesStringRes Class
Eco.Handles Namespace


HandlesStringRes.sPreconditionsNotAllowed Property

HandlesStringRes.sPreconditionsNotAllowed Property
HandlesStringRes Class Eco.Handles Namespace See Also
Collapse All

Returns: "Preconditions not allowed for this mapper"

C#
public static string sPreconditionsNotAllowed;
Remarks

For internal use.

See Also
HandlesStringRes Class
Eco.Handles Namespace


HandlesStringRes.sPropertyAddDefaultNestings Property

HandlesStringRes.sPropertyAddDefaultNestings Property
HandlesStringRes Class Eco.Handles Namespace See Also
Collapse All

Returns: "Add default nestings."

C#
public static string sPropertyAddDefaultNestings;
Remarks

For internal use.

See Also
HandlesStringRes Class
Eco.Handles Namespace


HandlesStringRes.sPropertyAddDefaultProperties Property

HandlesStringRes.sPropertyAddDefaultProperties Property
HandlesStringRes Class Eco.Handles Namespace See Also
Collapse All

Returns: "Add the default columns."

C#
public static string sPropertyAddDefaultProperties;
Remarks

For internal use.

See Also
HandlesStringRes Class
Eco.Handles Namespace


HandlesStringRes.sPropertyAddExternalId Property

HandlesStringRes.sPropertyAddExternalId Property
HandlesStringRes Class Eco.Handles Namespace See Also
Collapse All

Returns: "Add column for external ID."

C#
public static string sPropertyAddExternalId;
Remarks

For internal use.

See Also
HandlesStringRes Class
Eco.Handles Namespace


HandlesStringRes.sPropertyAddRootVariables Property

HandlesStringRes.sPropertyAddRootVariables Property
HandlesStringRes Class Eco.Handles Namespace See Also
Collapse All

Returns: "Add variables from RootHandle to own variables."

C#
public static string sPropertyAddRootVariables;
Remarks

For internal use.

See Also
HandlesStringRes Class
Eco.Handles Namespace


HandlesStringRes.sPropertyAddSelfColumn Property

HandlesStringRes.sPropertyAddSelfColumn Property
HandlesStringRes Class Eco.Handles Namespace See Also
Collapse All

Returns: "Add a column refering to the element."

C#
public static string sPropertyAddSelfColumn;
Remarks

For internal use.

See Also
HandlesStringRes Class
Eco.Handles Namespace


HandlesStringRes.sPropertyAllowNew Property

HandlesStringRes.sPropertyAllowNew Property
HandlesStringRes Class Eco.Handles Namespace See Also
Collapse All

Returns: "Allow New"

C#
public static string sPropertyAllowNew;
Remarks

For internal use.

See Also
HandlesStringRes Class
Eco.Handles Namespace


HandlesStringRes.sPropertyAsExternalId Property

HandlesStringRes.sPropertyAsExternalId Property
HandlesStringRes Class Eco.Handles Namespace See Also
Collapse All

Returns: "Represent ECO object as ExternalId"

C#
public static string sPropertyAsExternalId;
Remarks

For internal use.

See Also
HandlesStringRes Class
Eco.Handles Namespace


HandlesStringRes.sPropertyCacheData Property

HandlesStringRes.sPropertyCacheData Property
HandlesStringRes Class Eco.Handles Namespace See Also
Collapse All

Returns: "If true, the file is cached through the session."

C#
public static string sPropertyCacheData;
Remarks

For internal use.

See Also
HandlesStringRes Class
Eco.Handles Namespace


HandlesStringRes.sPropertyColumnName Property

HandlesStringRes.sPropertyColumnName Property
HandlesStringRes Class Eco.Handles Namespace See Also
Collapse All

Returns: "Name of the property to add to the binding list."

C#
public static string sPropertyColumnName;
Remarks

For internal use.

See Also
HandlesStringRes Class
Eco.Handles Namespace


HandlesStringRes.sPropertyColumns Property

HandlesStringRes.sPropertyColumns Property
HandlesStringRes Class Eco.Handles Namespace See Also
Collapse All

Returns: "Columns surfaced by this handle."

C#
public static string sPropertyColumns;
Remarks

For internal use.

See Also
HandlesStringRes Class
Eco.Handles Namespace


HandlesStringRes.sPropertyDefaultLinkFetchStrategy Property

HandlesStringRes.sPropertyDefaultLinkFetchStrategy Property
HandlesStringRes Class Eco.Handles Namespace See Also
Collapse All

Returns: "Controls how to load relations by default"

C#
public static string sPropertyDefaultLinkFetchStrategy;
Remarks

For internal use.

See Also
HandlesStringRes Class
Eco.Handles Namespace


HandlesStringRes.sPropertyDerivationExpression Property

HandlesStringRes.sPropertyDerivationExpression Property
HandlesStringRes Class Eco.Handles Namespace See Also
Collapse All

Returns: "OCL expression for deriving property."

C#
public static string sPropertyDerivationExpression;
Remarks

For internal use.

See Also
HandlesStringRes Class
Eco.Handles Namespace


HandlesStringRes.sPropertyDeriveValue Property

HandlesStringRes.sPropertyDeriveValue Property
HandlesStringRes Class Eco.Handles Namespace See Also
Collapse All

Returns: "For deriving columns with code."

C#
public static string sPropertyDeriveValue;
Remarks

For internal use.

See Also
HandlesStringRes Class
Eco.Handles Namespace


HandlesStringRes.sPropertyEcoSpaceTypeName Property

HandlesStringRes.sPropertyEcoSpaceTypeName Property
HandlesStringRes Class Eco.Handles Namespace See Also
Collapse All

Returns: "The type of the EcoSpace that defines the type system to use in design time."

C#
public static string sPropertyEcoSpaceTypeName;
Remarks

For internal use.

See Also
HandlesStringRes Class
Eco.Handles Namespace


HandlesStringRes.sPropertyElementHandle Property

HandlesStringRes.sPropertyElementHandle Property
HandlesStringRes Class Eco.Handles Namespace See Also
Collapse All

Returns: "Handle supplying the value of the variable."

C#
public static string sPropertyElementHandle;
Remarks

For internal use.

See Also
HandlesStringRes Class
Eco.Handles Namespace


HandlesStringRes.sPropertyEnabled Property

HandlesStringRes.sPropertyEnabled Property
HandlesStringRes Class Eco.Handles Namespace See Also
Collapse All

Returns: "Determines if component is serving values to connected components."

C#
public static string sPropertyEnabled;
Remarks

For internal use.

See Also
HandlesStringRes Class
Eco.Handles Namespace


HandlesStringRes.sPropertyExpression Property

HandlesStringRes.sPropertyExpression Property
HandlesStringRes Class Eco.Handles Namespace See Also
Collapse All

Returns: "OCL Expression used to populate the handle."

C#
public static string sPropertyExpression;
Remarks

For internal use.

See Also
HandlesStringRes Class
Eco.Handles Namespace


HandlesStringRes.sPropertyFileName Property

HandlesStringRes.sPropertyFileName Property
HandlesStringRes Class Eco.Handles Namespace See Also
Collapse All

Returns: "The file used to persist data."

C#
public static string sPropertyFileName;
Remarks

For internal use.

See Also
HandlesStringRes Class
Eco.Handles Namespace


HandlesStringRes.sPropertyFilter Property

HandlesStringRes.sPropertyFilter Property
HandlesStringRes Class Eco.Handles Namespace See Also
Collapse All

Returns: "Filter expression"

C#
public static string sPropertyFilter;
Remarks

For internal use.

See Also
HandlesStringRes Class
Eco.Handles Namespace


HandlesStringRes.sPropertyFilterMode Property

HandlesStringRes.sPropertyFilterMode Property
HandlesStringRes Class Eco.Handles Namespace See Also
Collapse All

Returns: "Filter Mode"

C#
public static string sPropertyFilterMode;
Remarks

For internal use.

See Also
HandlesStringRes Class
Eco.Handles Namespace


HandlesStringRes.sPropertyInitialValues Property

HandlesStringRes.sPropertyInitialValues Property
HandlesStringRes Class Eco.Handles Namespace See Also
Collapse All

Returns: "Initial value for the element of the handle"

C#
public static string sPropertyInitialValues;
Remarks

For internal use.

See Also
HandlesStringRes Class
Eco.Handles Namespace


HandlesStringRes.sPropertyIsReadOnly Property

HandlesStringRes.sPropertyIsReadOnly Property
HandlesStringRes Class Eco.Handles Namespace See Also
Collapse All

Returns: "Property is readonly."

C#
public static string sPropertyIsReadOnly;
Remarks

For internal use.

See Also
HandlesStringRes Class
Eco.Handles Namespace


HandlesStringRes.sPropertyMaxAnswers Property

HandlesStringRes.sPropertyMaxAnswers Property
HandlesStringRes Class Eco.Handles Namespace See Also
Collapse All

Returns: "The maximum number of objects to be returned by the query"

C#
public static string sPropertyMaxAnswers;
Remarks

For internal use.

See Also
HandlesStringRes Class
Eco.Handles Namespace


HandlesStringRes.sPropertyMemberVisibility Property

HandlesStringRes.sPropertyMemberVisibility Property
HandlesStringRes Class Eco.Handles Namespace See Also
Collapse All

Returns: "Filter exposed members based on their visibility."

C#
public static string sPropertyMemberVisibility;
Remarks

For internal use.

See Also
HandlesStringRes Class
Eco.Handles Namespace


HandlesStringRes.sPropertyNested Property

HandlesStringRes.sPropertyNested Property
HandlesStringRes Class Eco.Handles Namespace See Also
Collapse All

Returns: "Property is Nested."

C#
public static string sPropertyNested;
Remarks

For internal use.

See Also
HandlesStringRes Class
Eco.Handles Namespace


HandlesStringRes.sPropertyNesting Property

HandlesStringRes.sPropertyNesting Property
HandlesStringRes Class Eco.Handles Namespace See Also
Collapse All

Returns: "Name of nesting to use if Property is Nested."

C#
public static string sPropertyNesting;
Remarks

For internal use.

See Also
HandlesStringRes Class
Eco.Handles Namespace


HandlesStringRes.sPropertyNestings Property

HandlesStringRes.sPropertyNestings Property
HandlesStringRes Class Eco.Handles Namespace See Also
Collapse All

Returns: "Nestings."

C#
public static string sPropertyNestings;
Remarks

For internal use.

See Also
HandlesStringRes Class
Eco.Handles Namespace


HandlesStringRes.sPropertyNullElementRepresentation Property

HandlesStringRes.sPropertyNullElementRepresentation Property
HandlesStringRes Class Eco.Handles Namespace See Also
Collapse All

Returns: "Representation for null row."

C#
public static string sPropertyNullElementRepresentation;
Remarks

For internal use.

See Also
HandlesStringRes Class
Eco.Handles Namespace


HandlesStringRes.sPropertyOclVariableCollection Property

HandlesStringRes.sPropertyOclVariableCollection Property
HandlesStringRes Class Eco.Handles Namespace See Also
Collapse All

Returns: "Collection of the variables defined."

C#
public static string sPropertyOclVariableCollection;
Remarks

For internal use.

See Also
HandlesStringRes Class
Eco.Handles Namespace


HandlesStringRes.sPropertyOffset Property

HandlesStringRes.sPropertyOffset Property
HandlesStringRes Class Eco.Handles Namespace See Also
Collapse All

Returns: "The offset in the query result set from where to start returning objects"

C#
public static string sPropertyOffset;
Remarks

For internal use.

See Also
HandlesStringRes Class
Eco.Handles Namespace


HandlesStringRes.sPropertyOptimisticLocking Property

HandlesStringRes.sPropertyOptimisticLocking Property
HandlesStringRes Class Eco.Handles Namespace See Also
Collapse All

Returns: "Enabled optimistic locking."

C#
public static string sPropertyOptimisticLocking;
Remarks

For internal use.

See Also
HandlesStringRes Class
Eco.Handles Namespace


HandlesStringRes.sPropertyPersistenceMapper Property

HandlesStringRes.sPropertyPersistenceMapper Property
HandlesStringRes Class Eco.Handles Namespace See Also
Collapse All

Returns: "Component managing EcoSpace's persistence."

C#
public static string sPropertyPersistenceMapper;
Remarks

For internal use.

See Also
HandlesStringRes Class
Eco.Handles Namespace


HandlesStringRes.sPropertyReverseDeriveValue Property

HandlesStringRes.sPropertyReverseDeriveValue Property
HandlesStringRes Class Eco.Handles Namespace See Also
Collapse All

Returns: "For reverse deriving columns with code."

C#
public static string sPropertyReverseDeriveValue;
Remarks

For internal use.

See Also
HandlesStringRes Class
Eco.Handles Namespace


HandlesStringRes.sPropertyRootHandle Property

HandlesStringRes.sPropertyRootHandle Property
HandlesStringRes Class Eco.Handles Namespace See Also
Collapse All

Returns: "Handle supplying uplink value."

C#
public static string sPropertyRootHandle;
Remarks

For internal use.

See Also
HandlesStringRes Class
Eco.Handles Namespace


HandlesStringRes.sPropertyStaticValueTypeName Property

HandlesStringRes.sPropertyStaticValueTypeName Property
HandlesStringRes Class Eco.Handles Namespace See Also
Collapse All

Returns: "Static type for handle."

C#
public static string sPropertyStaticValueTypeName;
Remarks

For internal use.

See Also
HandlesStringRes Class
Eco.Handles Namespace


HandlesStringRes.sPropertySupportSorting Property

HandlesStringRes.sPropertySupportSorting Property
HandlesStringRes Class Eco.Handles Namespace See Also
Collapse All

Returns: "Support Sorting"

C#
public static string sPropertySupportSorting;
Remarks

For internal use.

See Also
HandlesStringRes Class
Eco.Handles Namespace


HandlesStringRes.sPropertySyncHandler Property

HandlesStringRes.sPropertySyncHandler Property
HandlesStringRes Class Eco.Handles Namespace See Also
Collapse All

Returns: "Specify a SyncHandler component if Sync is to be active"

C#
public static string sPropertySyncHandler;
Remarks

For internal use.

See Also
HandlesStringRes Class
Eco.Handles Namespace


HandlesStringRes.sPropertyTypeName Property

HandlesStringRes.sPropertyTypeName Property
HandlesStringRes Class Eco.Handles Namespace See Also
Collapse All

Returns: "Type of the derived property."

C#
public static string sPropertyTypeName;
Remarks

For internal use.

See Also
HandlesStringRes Class
Eco.Handles Namespace


HandlesStringRes.sPropertyUpdateWholeObjects Property

HandlesStringRes.sPropertyUpdateWholeObjects Property
HandlesStringRes Class Eco.Handles Namespace See Also
Collapse All

Returns: "Enables updating entire objects."

C#
public static string sPropertyUpdateWholeObjects;
Remarks

For internal use.

See Also
HandlesStringRes Class
Eco.Handles Namespace


HandlesStringRes.sPropertyVariableName Property

HandlesStringRes.sPropertyVariableName Property
HandlesStringRes Class Eco.Handles Namespace See Also
Collapse All

Returns: "Name of the variable as used in expression."

C#
public static string sPropertyVariableName;
Remarks

For internal use.

See Also
HandlesStringRes Class
Eco.Handles Namespace


HandlesStringRes.sPropertyVariables Property

HandlesStringRes.sPropertyVariables Property
HandlesStringRes Class Eco.Handles Namespace See Also
Collapse All

Returns: "OCL variables to be known by handle."

C#
public static string sPropertyVariables;
Remarks

For internal use.

See Also
HandlesStringRes Class
Eco.Handles Namespace


HandlesStringRes.sRootContextNotSet Property

HandlesStringRes.sRootContextNotSet Property
HandlesStringRes Class Eco.Handles Namespace See Also
Collapse All

Returns: "The owner's context is not set"

C#
public static string sRootContextNotSet;
Remarks

For internal use.

See Also
HandlesStringRes Class
Eco.Handles Namespace


HandlesStringRes.sSingleUserLicense Property

HandlesStringRes.sSingleUserLicense Property
HandlesStringRes Class Eco.Handles Namespace See Also
Collapse All

Returns: "Single developer license"

C#
public static string sSingleUserLicense;
Remarks

For internal use.

See Also
HandlesStringRes Class
Eco.Handles Namespace


HandlesStringRes.sSiteLicense Property

HandlesStringRes.sSiteLicense Property
HandlesStringRes Class Eco.Handles Namespace See Also
Collapse All

Returns: "Site License"

C#
public static string sSiteLicense;
Remarks

For internal use.

See Also
HandlesStringRes Class
Eco.Handles Namespace


HandlesStringRes.sSpecifyXmlFile Property

HandlesStringRes.sSpecifyXmlFile Property
HandlesStringRes Class Eco.Handles Namespace See Also
Collapse All

Returns: "Specify file to use for data storage"

C#
public static string sSpecifyXmlFile;
Remarks

For internal use.

See Also
HandlesStringRes Class
Eco.Handles Namespace


HandlesStringRes.sSupportsSyncIsNotEnabled Property

HandlesStringRes.sSupportsSyncIsNotEnabled Property
HandlesStringRes Class Eco.Handles Namespace See Also
Collapse All

Returns: "Either your PersistenceMapper does not support synchronization, or it is currently disabled"

C#
public static string sSupportsSyncIsNotEnabled;
Remarks

For internal use.

See Also
HandlesStringRes Class
Eco.Handles Namespace


HandlesStringRes.sSyncNotActive Property

HandlesStringRes.sSyncNotActive Property
HandlesStringRes Class Eco.Handles Namespace See Also
Collapse All

Returns: "Sync not active"

C#
public static string sSyncNotActive;
Remarks

For internal use.

See Also
HandlesStringRes Class
Eco.Handles Namespace


HandlesStringRes.sTypeOfValueUnknown Property

HandlesStringRes.sTypeOfValueUnknown Property
HandlesStringRes Class Eco.Handles Namespace See Also
Collapse All

Returns: "value is not of a known type."

C#
public static string sTypeOfValueUnknown;
Remarks

For internal use.

See Also
HandlesStringRes Class
Eco.Handles Namespace


HandlesStringRes.sTypeSystemProblems Property

HandlesStringRes.sTypeSystemProblems Property
HandlesStringRes Class Eco.Handles Namespace See Also
Collapse All

Returns: "type system problems..."

C#
public static string sTypeSystemProblems;
Remarks

For internal use.

See Also
HandlesStringRes Class
Eco.Handles Namespace


HandlesStringRes.sVariableRoot Property

HandlesStringRes.sVariableRoot Property
HandlesStringRes Class Eco.Handles Namespace See Also
Collapse All

Returns: "Variable"

C#
public static string sVariableRoot;
Remarks

For internal use.

See Also
HandlesStringRes Class
Eco.Handles Namespace


HandlesStringRes.sWrongIDE Property

HandlesStringRes.sWrongIDE Property
HandlesStringRes Class Eco.Handles Namespace See Also
Collapse All

Returns: "Your ECO license is not valid for this IDE! ECO will run with limitations."

C#
public static string sWrongIDE;
Remarks

For internal use.

See Also
HandlesStringRes Class
Eco.Handles Namespace


HandlesStringRes.sWrongIDEShort Property

HandlesStringRes.sWrongIDEShort Property
HandlesStringRes Class Eco.Handles Namespace See Also
Collapse All

Returns: "Wrong ECO license"

C#
public static string sWrongIDEShort;
Remarks

For internal use.

See Also
HandlesStringRes Class
Eco.Handles Namespace


HandlesStringRes.sWrongPMapperReturned Property

HandlesStringRes.sWrongPMapperReturned Property
HandlesStringRes Class Eco.Handles Namespace See Also
Collapse All

Returns: "Wrong persistence mapper returned"

C#
public static string sWrongPMapperReturned;
Remarks

For internal use.

See Also
HandlesStringRes Class
Eco.Handles Namespace


HandlesStringRes.sXmlFileFilter Property

HandlesStringRes.sXmlFileFilter Property
HandlesStringRes Class Eco.Handles Namespace See Also
Collapse All

Returns: "XML-files (*.xml)|*.xml|All files (*.*)|*.*"

C#
public static string sXmlFileFilter;
Remarks

For internal use.

See Also
HandlesStringRes Class
Eco.Handles Namespace


HandlesStringRes.UnknownAutoincKey Property

HandlesStringRes.UnknownAutoincKey Property
HandlesStringRes Class Eco.Handles Namespace See Also
Collapse All

Returns: "Unknown autoinc key"

C#
public static string UnknownAutoincKey;
Remarks

For internal use.

See Also
HandlesStringRes Class
Eco.Handles Namespace


HandlesStringRes.XmlDocumentContainsNoDatablock Property

HandlesStringRes.XmlDocumentContainsNoDatablock Property
HandlesStringRes Class Eco.Handles Namespace See Also
Collapse All

Returns: "XmlDocument does not contain a datablock"

C#
public static string XmlDocumentContainsNoDatablock;
Remarks

For internal use.

See Also
HandlesStringRes Class
Eco.Handles Namespace


HandleUtils Class

HandleUtils Class
Inheritance Hierarchy See Also
Collapse All

Helper class with useful routines. This class contains only static methods and cannot be instantiated.

C#
public static class HandleUtils;
Inheritance Hierarchy
Eco.Handles.HandleUtils
File

ControlPack.cs

See Also
Inheritance Hierarchy


HandleUtils Methods

HandleUtils Methods
Public Methods
Collapse All

The methods of the HandleUtils class are listed here.

Public Methods
Name | Description
ItemType | Returns the type of the classifier or the type of its elements, if it happens to be a collection type.


HandleUtils.ItemType Method

HandleUtils.ItemType Method
HandleUtils Class Eco.Handles Namespace See Also
Collapse All

Returns the type of the classifier or the type of its elements, if it happens to be a collection type.

C#
public static IClassifier ItemType(
    IClassifier classifier
);
See Also
HandleUtils Class
Eco.Handles Namespace


ItemStaticContext Class

ItemStaticContext Class
Inheritance Hierarchy See Also
Collapse All

This class is part of the internal implementation of the databindable IList implemented by the Eco handles. It should not be used directly.

C#
public sealed class ItemStaticContext : IStaticContext;
Inheritance Hierarchy
Eco.Handles.ItemStaticContext
File

ControlPack.cs

See Also
Inheritance Hierarchy


ItemStaticContext.ItemStaticContext Constructor

ItemStaticContext.ItemStaticContext Constructor
ItemStaticContext Class Eco.Handles Namespace See Also
Collapse All
C#
public ItemStaticContext(
    IStaticContext adaptedContext
);
Remarks

This is ItemStaticContext, a member of class ItemStaticContext.

See Also
ItemStaticContext Class
Eco.Handles Namespace


MaxLengthSupportFunctions Class

MaxLengthSupportFunctions Class
Inheritance Hierarchy See Also
Collapse All

This class provides some useful routines to set the max entry length on UI controls based on the modeled max length of (string) attributes).

C#
public sealed class MaxLengthSupportFunctions;
Inheritance Hierarchy
Eco.Handles.MaxLengthSupportFunctions
File

MaxLengthSupportFunctions.cs

See Also
Inheritance Hierarchy


MaxLengthSupportFunctions Methods

MaxLengthSupportFunctions Methods
Public Methods
Collapse All

The methods of the MaxLengthSupportFunctions class are listed here.

Public Methods
Name | Description
GetMaxLength | This is the overview for the GetMaxLength method overload.
RegisterMaxLengthSupportLibrary | Reflects over all classes within the specified assembly to find MaxLengthSupportProviders
RegisterMaxLengthSupportProvider | Register a maxLengthSupportProvider in the internal registry
UpdateMaxLengths | This is the overview for the UpdateMaxLengths method overload.


GetMaxLength Method

GetMaxLength Method

This is the overview for the GetMaxLength method overload.

Overload List
Name | Description
MaxLengthSupportFunctions.GetMaxLength (RenderedTuplePropertyDescriptor, IElementHandle, int) | Returns the GetMaxLength by using the expression of prop.
MaxLengthSupportFunctions.GetMaxLength (string, IElementHandle, int) | GetMaxLength returns the modeled length of the attribute pointed to by applying expression to the StaticUmlType of the handle. If the resulting element is not an IAttribute, def is returned.


MaxLengthSupportFunctions.GetMaxLength Method (RenderedTuplePropertyDescriptor, IElementHandle, int)

MaxLengthSupportFunctions.GetMaxLength Method (RenderedTuplePropertyDescriptor, IElementHandle, int)
MaxLengthSupportFunctions Class Eco.Handles Namespace See Also
Collapse All

Returns the GetMaxLength by using the expression of prop.

C#
public static int GetMaxLength(
    RenderedTuplePropertyDescriptor prop,
    IElementHandle handle,
    int def
);
Parameters
Parameters | Description
prop | The property descriptor used to obtain an expression.
handle | Acting as an IEcoServiceProvider to get to IOclService, and provides the starting type to which to apply expression.
def | Default value returned if prop is null or prop.IsEventDerived is true.
See Also
MaxLengthSupportFunctions Class
Eco.Handles Namespace


MaxLengthSupportFunctions.GetMaxLength Method (string, IElementHandle, int)

MaxLengthSupportFunctions.GetMaxLength Method (string, IElementHandle, int)
MaxLengthSupportFunctions Class Eco.Handles Namespace See Also
Collapse All

GetMaxLength returns the modeled length of the attribute pointed to by applying expression to the StaticUmlType of the handle. If the resulting element is not an IAttribute, def is returned.

C#
public static int GetMaxLength(
    string expression,
    IElementHandle handle,
    int def
);
Parameters
Parameters | Description
expression | An OCL expression applied to the handle's StaticUmlType.
handle | Acting as an IEcoServiceProvider to get to IOclService, and provides the starting type to which to apply expression.
def | Default value returned if the resulting type afer applying expression to the handle's type is not an IAttribute.
Exceptions
Exceptions | Description
ArgumentNullException | Thrown if handle is null.
See Also
MaxLengthSupportFunctions Class
Eco.Handles Namespace


MaxLengthSupportFunctions.RegisterMaxLengthSupportLibrary Method

MaxLengthSupportFunctions.RegisterMaxLengthSupportLibrary Method
MaxLengthSupportFunctions Class Eco.Handles Namespace See Also
Collapse All

Reflects over all classes within the specified assembly to find MaxLengthSupportProviders

C#
public static void RegisterMaxLengthSupportLibrary(
    Assembly assembly
);
Parameters
Parameters | Description
assembly | The assembly to reflect over
Remarks

Each class within the assembly will be reflected over. Any class decorated with the MaxLengthSupportProviderAttribute will be instatiated and added to the internal list of providers for max-length support.

See Also
MaxLengthSupportFunctions Class
Eco.Handles Namespace


MaxLengthSupportFunctions.RegisterMaxLengthSupportProvider Method

MaxLengthSupportFunctions.RegisterMaxLengthSupportProvider Method
MaxLengthSupportFunctions Class Eco.Handles Namespace Example See Also
Collapse All

Register a maxLengthSupportProvider in the internal registry

C#
public static void RegisterMaxLengthSupportProvider(
    IMaxLengthSupportProvider maxLengthSupportProvider,
    Type supportedType
);
Remarks

When the MaxLengthSupportFunctions class is initialized, it will scan all loaded assemblies for MaxLengthSupportProviders If you want to register a provider later (or replace an existing one with your own), you can do so with this method.

Example

This code registers the class MyMaxLengthSupportProvider to handle Textbox components

Copy Code
MaxLengthSupportFunctions.RegisterMaxLengthSupportProvider(
    new MyMaxLengthSupportProvider(),
    typeof(Textbox));
See Also
MaxLengthSupportFunctions Class
Eco.Handles Namespace
Example


UpdateMaxLengths Method

UpdateMaxLengths Method

This is the overview for the UpdateMaxLengths method overload.

Overload List
Name | Description
MaxLengthSupportFunctions.UpdateMaxLengths (IEnumerable) | Invokes IMaxLengthSupportProvider.SetMaxLength on each object in objects.
MaxLengthSupportFunctions.UpdateMaxLengths (object) | Extracts the property Controls from obj (which quite reasonably is a form) using reflection. If there is no such property, nothing is done, no exception is raised.


MaxLengthSupportFunctions.UpdateMaxLengths Method (IEnumerable)

MaxLengthSupportFunctions.UpdateMaxLengths Method (IEnumerable)
MaxLengthSupportFunctions Class Eco.Handles Namespace See Also
Collapse All

Invokes IMaxLengthSupportProvider.SetMaxLength on each object in objects.

C#
public static void UpdateMaxLengths(
    IEnumerable objects
);
Parameters
Parameters | Description
objects | A container of objects that will get their max length set (like a ControlCollection).
See Also
MaxLengthSupportFunctions Class
Eco.Handles Namespace


MaxLengthSupportFunctions.UpdateMaxLengths Method (object)

MaxLengthSupportFunctions.UpdateMaxLengths Method (object)
MaxLengthSupportFunctions Class Eco.Handles Namespace See Also
Collapse All

Extracts the property Controls from obj (which quite reasonably is a form) using reflection. If there is no such property, nothing is done, no exception is raised.

C#
public static void UpdateMaxLengths(
    object obj
);
Parameters
Parameters | Description
obj | A container of objects that will get their max length set (like a form).
Exceptions
Exceptions | Description
ArgumentNullException | Thrown if control is null.
See Also
MaxLengthSupportFunctions Class
Eco.Handles Namespace


MaxLengthSupportLibraryAttribute Class

MaxLengthSupportLibraryAttribute Class
Inheritance Hierarchy See Also
Collapse All
C#
public sealed class MaxLengthSupportLibraryAttribute : System.Attribute;
Remarks

This is class Eco.Handles.MaxLengthSupportLibraryAttribute.

Inheritance Hierarchy
Eco.Handles.MaxLengthSupportLibraryAttribute
File

MaxLengthSupportFunctions.cs

See Also
Inheritance Hierarchy


MaxLengthSupportLibraryAttribute.MaxLengthSupportLibraryAttribute Constructor

MaxLengthSupportLibraryAttribute.MaxLengthSupportLibraryAttribute Constructor
MaxLengthSupportLibraryAttribute Class Eco.Handles Namespace See Also
Collapse All
C#
public MaxLengthSupportLibraryAttribute();
Remarks

This is MaxLengthSupportLibraryAttribute, a member of class MaxLengthSupportLibraryAttribute.

See Also
MaxLengthSupportLibraryAttribute Class
Eco.Handles Namespace


MaxLengthSupportProviderAttribute Class

MaxLengthSupportProviderAttribute Class
Inheritance Hierarchy See Also
Collapse All
C#
public sealed class MaxLengthSupportProviderAttribute : System.Attribute;
Remarks

This is class Eco.Handles.MaxLengthSupportProviderAttribute.

Inheritance Hierarchy
Eco.Handles.MaxLengthSupportProviderAttribute
File

MaxLengthSupportFunctions.cs

See Also
Inheritance Hierarchy


MaxLengthSupportProviderAttribute.MaxLengthSupportProviderAttribute Constructor

MaxLengthSupportProviderAttribute.MaxLengthSupportProviderAttribute Constructor
MaxLengthSupportProviderAttribute Class Eco.Handles Namespace See Also
Collapse All
C#
public MaxLengthSupportProviderAttribute(
    Type type
);
Remarks

This is MaxLengthSupportProviderAttribute, a member of class MaxLengthSupportProviderAttribute.

See Also
MaxLengthSupportProviderAttribute Class
Eco.Handles Namespace


MaxLengthSupportProviderAttribute Fields

MaxLengthSupportProviderAttribute Fields
Public Fields
Collapse All

The fields of the MaxLengthSupportProviderAttribute class are listed here.

Public Fields
Name | Description
type | This is type, a member of class MaxLengthSupportProviderAttribute.


MaxLengthSupportProviderAttribute.type Field

MaxLengthSupportProviderAttribute.type Field
MaxLengthSupportProviderAttribute Class Eco.Handles Namespace See Also
Collapse All
C#
public readonly Type type;
Remarks

This is type, a member of class MaxLengthSupportProviderAttribute.

See Also
MaxLengthSupportProviderAttribute Class
Eco.Handles Namespace


NameValidator Class

NameValidator Class
Inheritance Hierarchy See Also
Collapse All
C#
public static class NameValidator;
Remarks

This is class Eco.Handles.NameValidator.

Inheritance Hierarchy
Eco.Handles.NameValidator
File

NameValidator.cs

See Also
Inheritance Hierarchy


NameValidator Methods

NameValidator Methods
Public Methods
Collapse All

The methods of the NameValidator class are listed here.

Public Methods
Name | Description
AssertNameIsValid | This is AssertNameIsValid, a member of class NameValidator.
CheckNameIsValid | Based on ms-help://MS.NETFrameworkSDKv1.1/vblsnet/html/vblrfVBSpec2_2.htm Current algorithm allows for Name ::= StartChar[IdentifierChar+] StartChar ::= Letter | _ IdentifierChar ::= Letter | Digit | _


NameValidator.AssertNameIsValid Method

NameValidator.AssertNameIsValid Method
NameValidator Class Eco.Handles Namespace See Also
Collapse All
C#
public static void AssertNameIsValid(
    string name
);
Remarks

This is AssertNameIsValid, a member of class NameValidator.

See Also
NameValidator Class
Eco.Handles Namespace


NameValidator.CheckNameIsValid Method

NameValidator.CheckNameIsValid Method
NameValidator Class Eco.Handles Namespace See Also
Collapse All

Based on ms-help://MS.NETFrameworkSDKv1.1/vblsnet/html/vblrfVBSpec2_2.htm Current algorithm allows for Name ::= StartChar[IdentifierChar+] StartChar ::= Letter | _ IdentifierChar ::= Letter | Digit | _

C#
public static bool CheckNameIsValid(
    string name
);
See Also
NameValidator Class
Eco.Handles Namespace


Nesting Class

Nesting Class
Inheritance Hierarchy See Also
Collapse All
C#
public sealed class Nesting : INesting, IStaticContext, IHasTypeSystem;
Remarks

This is class Eco.Handles.Nesting.

Inheritance Hierarchy
Eco.Handles.IHasTypeSystem
Eco.Handles.INesting
    Eco.Handles.Nesting
File

Nestings.cs

See Also
Inheritance Hierarchy


Nesting.Nesting Constructor

Nesting.Nesting Constructor
Nesting Class Eco.Handles Namespace See Also
Collapse All
C#
public Nesting();
Remarks

This is Nesting, a member of class Nesting.

See Also
Nesting Class
Eco.Handles Namespace


Nesting Properties

Nesting Properties
Public Properties
Collapse All

The properties of the Nesting class are listed here.

Public Properties
Name | Description
ActionLanguageTypeService | This is ActionLanguageTypeService, a member of class Nesting.
AddDefaultNestings | See ElementHandle.AddDefaultNestings.
AddDefaultProperties | See ElementHandle.AddDefaultProperties.
Columns | See ElementHandle.Columns.
Name | This name is refered to by Column.NestingName.
NullRowMode | Specifies what happens if the nesting is empty
OclPsTypeService | This is OclPsTypeService, a member of class Nesting.
OclTypeService | For internal use.
RootContext | For internal use.
TypeName | The type of the objects in the list the nesting applies to.
VariableList | For internal use.


Nesting.ActionLanguageTypeService Property

Nesting.ActionLanguageTypeService Property
Nesting Class Eco.Handles Namespace See Also
Collapse All
C#
public IActionLanguageTypeService ActionLanguageTypeService;
Remarks

This is ActionLanguageTypeService, a member of class Nesting.

See Also
Nesting Class
Eco.Handles Namespace


Nesting.AddDefaultNestings Property

Nesting.AddDefaultNestings Property
Nesting Class Eco.Handles Namespace See Also
Collapse All

See ElementHandle.AddDefaultNestings.

C#
public bool AddDefaultNestings;
Remarks

FIXME [LocalizableDescription(typeof(HandlesStringRes), "sPropertyAddDefaultProperties")]

See Also
Nesting Class
Eco.Handles Namespace


Nesting.AddDefaultProperties Property

Nesting.AddDefaultProperties Property
Nesting Class Eco.Handles Namespace See Also
Collapse All

See ElementHandle.AddDefaultProperties.

C#
public bool AddDefaultProperties;
See Also
Nesting Class
Eco.Handles Namespace


Nesting.Columns Property

Nesting.Columns Property
Nesting Class Eco.Handles Namespace See Also
Collapse All

See ElementHandle.Columns.

C#
public ColumnCollection Columns;
See Also
Nesting Class
Eco.Handles Namespace


Nesting.Name Property

Nesting.Name Property
Nesting Class Eco.Handles Namespace See Also
Collapse All

This name is refered to by Column.NestingName.

C#
public String Name;
Exceptions
Exceptions | Description
InvalidOperationException | Thrown if the new name is not unique in the owning collection.
See Also
Nesting Class
Eco.Handles Namespace


Nesting.NullRowMode Property

Nesting.NullRowMode Property
Nesting Class Eco.Handles Namespace See Also
Collapse All

Specifies what happens if the nesting is empty

C#
public NullRowMode NullRowMode;
See Also
Nesting Class
Eco.Handles Namespace


Nesting.OclPsTypeService Property

Nesting.OclPsTypeService Property
Nesting Class Eco.Handles Namespace See Also
Collapse All
C#
public IOclPsTypeService OclPsTypeService;
Remarks

This is OclPsTypeService, a member of class Nesting.

See Also
Nesting Class
Eco.Handles Namespace


Nesting.OclTypeService Property

Nesting.OclTypeService Property
Nesting Class Eco.Handles Namespace See Also
Collapse All

For internal use.

C#
public IOclTypeService OclTypeService;
See Also
Nesting Class
Eco.Handles Namespace


Nesting.RootContext Property

Nesting.RootContext Property
Nesting Class Eco.Handles Namespace See Also
Collapse All

For internal use.

C#
public IStaticContext RootContext;
Exceptions
Exceptions | Description
InvalidOperationException | Thrown if the new nesting has no owner.
See Also
Nesting Class
Eco.Handles Namespace


Nesting.TypeName Property

Nesting.TypeName Property
Nesting Class Eco.Handles Namespace See Also
Collapse All

The type of the objects in the list the nesting applies to.

C#
public string TypeName;
See Also
Nesting Class
Eco.Handles Namespace


Nesting.VariableList Property

Nesting.VariableList Property
Nesting Class Eco.Handles Namespace See Also
Collapse All

For internal use.

C#
public IExternalVariableList VariableList;
See Also
Nesting Class
Eco.Handles Namespace


NestingCollection Class

NestingCollection Class
Inheritance Hierarchy See Also
Collapse All
C#
public sealed class NestingCollection : System.Collections.CollectionBase, INestingProvider;
Remarks

NestingCollection

Inheritance Hierarchy
Eco.Handles.INestingProvider
    Eco.Handles.NestingCollection
File

Nestings.cs

See Also
Inheritance Hierarchy


NestingCollection.NestingCollection Constructor

NestingCollection.NestingCollection Constructor
NestingCollection Class Eco.Handles Namespace See Also
Collapse All
C#
public NestingCollection(
    IStaticContext staticContext
);
Remarks

This is NestingCollection, a member of class NestingCollection.

See Also
NestingCollection Class
Eco.Handles Namespace


NestingCollection Methods

NestingCollection Methods
Protected Methods Public Methods
Collapse All

The methods of the NestingCollection class are listed here.

Protected Methods
Name | Description
OnClearComplete | This is OnClearComplete, a member of class NestingCollection.
OnInsert |
OnInsertComplete | This is OnInsertComplete, a member of class NestingCollection.
OnRemoveComplete | This is OnRemoveComplete, a member of class NestingCollection.
Top
Public Methods
Name | Description
Add | This is Add, a member of class NestingCollection.
AddRange | This is AddRange, a member of class NestingCollection.
IndexOf | This is IndexOf, a member of class NestingCollection.
this | This is the overview for the this indexer overload.


NestingCollection.Add Method

NestingCollection.Add Method
NestingCollection Class Eco.Handles Namespace See Also
Collapse All
C#
public void Add(
    Nesting nesting
);
Remarks

This is Add, a member of class NestingCollection.

See Also
NestingCollection Class
Eco.Handles Namespace


NestingCollection.AddRange Method

NestingCollection.AddRange Method
NestingCollection Class Eco.Handles Namespace See Also
Collapse All
C#
public void AddRange(
    Nesting[] nestings
);
Remarks

This is AddRange, a member of class NestingCollection.

See Also
NestingCollection Class
Eco.Handles Namespace


NestingCollection.IndexOf Method

NestingCollection.IndexOf Method
NestingCollection Class Eco.Handles Namespace See Also
Collapse All
C#
public int IndexOf(
    object value
);
Remarks

This is IndexOf, a member of class NestingCollection.

See Also
NestingCollection Class
Eco.Handles Namespace


NestingCollection.OnClearComplete Method

NestingCollection.OnClearComplete Method
NestingCollection Class Eco.Handles Namespace See Also
Collapse All
C#
protected override void OnClearComplete();
Remarks

This is OnClearComplete, a member of class NestingCollection.

See Also
NestingCollection Class
Eco.Handles Namespace


NestingCollection.OnInsert Method

NestingCollection.OnInsert Method
NestingCollection Class Eco.Handles Namespace See Also
Collapse All
C#
protected override void OnInsert(
    int index,
    object value
);
Exceptions
Exceptions | Description
InvalidOperationException | Thrown if the inserted nesting's name is not unique.
See Also
NestingCollection Class
Eco.Handles Namespace


NestingCollection.OnInsertComplete Method

NestingCollection.OnInsertComplete Method
NestingCollection Class Eco.Handles Namespace See Also
Collapse All
C#
protected override void OnInsertComplete(
    int index,
    object value
);
Remarks

This is OnInsertComplete, a member of class NestingCollection.

See Also
NestingCollection Class
Eco.Handles Namespace


NestingCollection.OnRemoveComplete Method

NestingCollection.OnRemoveComplete Method
NestingCollection Class Eco.Handles Namespace See Also
Collapse All
C#
protected override void OnRemoveComplete(
    int index,
    object value
);
Remarks

This is OnRemoveComplete, a member of class NestingCollection.

See Also
NestingCollection Class
Eco.Handles Namespace


this Indexer

this Indexer

This is the overview for the this indexer overload.

Overload List
Name | Description
NestingCollection.this (int) | This is this, a member of class NestingCollection.
NestingCollection.this (string) | This is this, a member of class NestingCollection.


NestingCollection.this Indexer (int)

NestingCollection.this Indexer (int)
NestingCollection Class Eco.Handles Namespace See Also
Collapse All
C#
public Nesting this[
    int index
];
Remarks

This is this, a member of class NestingCollection.

See Also
NestingCollection Class
Eco.Handles Namespace


NestingCollection.this Indexer (string)

NestingCollection.this Indexer (string)
NestingCollection Class Eco.Handles Namespace See Also
Collapse All
C#
public INesting this[
    string name
];
Remarks

This is this, a member of class NestingCollection.

See Also
NestingCollection Class
Eco.Handles Namespace


NestingCollection Properties

NestingCollection Properties
Public Properties
Collapse All

The properties of the NestingCollection class are listed here.

Public Properties
Name | Description
StaticContext | This is StaticContext, a member of class NestingCollection.


NestingCollection.StaticContext Property

NestingCollection.StaticContext Property
NestingCollection Class Eco.Handles Namespace See Also
Collapse All
C#
public IStaticContext StaticContext;
Remarks

This is StaticContext, a member of class NestingCollection.

See Also
NestingCollection Class
Eco.Handles Namespace


NestingCollection Events

NestingCollection Events
Public Events
Collapse All

The events of the NestingCollection class are listed here.

Public Events
Name | Description
OnChange | This is OnChange, a member of class NestingCollection.


NestingCollection.OnChange Event

NestingCollection.OnChange Event
NestingCollection Class Eco.Handles Namespace See Also
Collapse All
C#
public event EventHandler OnChange;
Remarks

This is OnChange, a member of class NestingCollection.

See Also
NestingCollection Class
Eco.Handles Namespace


NestingConverter Class

NestingConverter Class
Inheritance Hierarchy See Also
Collapse All
C#
public sealed class NestingConverter : ExpandableObjectConverter;
Remarks

Type converter to make Nesting Serialize

Inheritance Hierarchy
Eco.Handles.NestingConverter
File

Nestings.cs

See Also
Inheritance Hierarchy


NestingConverter Methods

NestingConverter Methods
Public Methods
Collapse All

The methods of the NestingConverter class are listed here.

Public Methods
Name | Description
CanConvertTo | This is CanConvertTo, a member of class NestingConverter.
ConvertTo | This is ConvertTo, a member of class NestingConverter.


NestingConverter.CanConvertTo Method

NestingConverter.CanConvertTo Method
NestingConverter Class Eco.Handles Namespace See Also
Collapse All
C#
public override bool CanConvertTo(
    ITypeDescriptorContext context,
    Type destinationType
);
Remarks

This is CanConvertTo, a member of class NestingConverter.

See Also
NestingConverter Class
Eco.Handles Namespace


NestingConverter.ConvertTo Method

NestingConverter.ConvertTo Method
NestingConverter Class Eco.Handles Namespace See Also
Collapse All
C#
public override object ConvertTo(
    ITypeDescriptorContext context,
    CultureInfo culture,
    object value,
    Type destinationType
);
Remarks

This is ConvertTo, a member of class NestingConverter.

See Also
NestingConverter Class
Eco.Handles Namespace


OclColumn Class

OclColumn Class
Inheritance Hierarchy See Also
Collapse All

Class describing an additional property to be added to the items in the rendered list defined via OCL

C#
public class OclColumn : AbstractColumn, IHasEditableExpression;
Inheritance Hierarchy
Eco.Handles.IColumn
    Eco.Handles.AbstractColumn
    Eco.Handles.IHasEditableExpression
        Eco.Handles.OclColumn
            Eco.Handles.Column
File

Columns.cs

See Also
Inheritance Hierarchy


OclColumn Properties

OclColumn Properties
Public Properties
Collapse All

The properties of the OclColumn class are listed here.

Public Properties
Name | Description
EventDerivedValue | This property is always false for an OclColumn. For a column deriving its value by an event, use an EventDerivedColumn.
Expression | OCL expression used to compute the value of the column unless EventDerivedValue is true.
NullElementRepresentation | Representation for null rows.


OclColumn.EventDerivedValue Property

OclColumn.EventDerivedValue Property
OclColumn Class Eco.Handles Namespace See Also
Collapse All

This property is always false for an OclColumn. For a column deriving its value by an event, use an EventDerivedColumn.

C#
public override bool EventDerivedValue;
See Also
OclColumn Class
Eco.Handles Namespace


OclColumn.Expression Property

OclColumn.Expression Property
OclColumn Class Eco.Handles Namespace See Also
Collapse All

OCL expression used to compute the value of the column unless EventDerivedValue is true.

C#
public override string Expression;
See Also
OclColumn Class
Eco.Handles Namespace


OclColumn.NullElementRepresentation Property

OclColumn.NullElementRepresentation Property
OclColumn Class Eco.Handles Namespace See Also
Collapse All

Representation for null rows.

C#
public override string NullElementRepresentation;
Remarks

This property controls the column is presented for a "null" row created by setting ElementHandle.NullRowMode to something toher than NullRowMode.None

The property is a string that will be convereted to the type of the column.

Two special values are recognized, <Null> which will represent the column as null and <DbNull> which will represent the column as DbNull.Value". The default is <Null>.

See Also
OclColumn Class
Eco.Handles Namespace


OclColumnConverter Class

OclColumnConverter Class
Inheritance Hierarchy See Also
Collapse All

Type converter for OclColumn. Mainly for the internal use of the WinForm designer.

C#
public sealed class OclColumnConverter : AbstractColumnConverter;
Inheritance Hierarchy
Eco.Handles.AbstractColumnConverter
    Eco.Handles.OclColumnConverter
File

Columns.cs

See Also
Inheritance Hierarchy


OclColumnConverter Methods

OclColumnConverter Methods
Protected Methods
Collapse All

The methods of the OclColumnConverter class are listed here.

Protected Methods
Name | Description
GetTargetType | This is GetTargetType, a member of class OclColumnConverter.


OclColumnConverter.GetTargetType Method

OclColumnConverter.GetTargetType Method
OclColumnConverter Class Eco.Handles Namespace See Also
Collapse All
C#
protected override Type GetTargetType();
Remarks

This is GetTargetType, a member of class OclColumnConverter.

See Also
OclColumnConverter Class
Eco.Handles Namespace


OclEditorResult Class

OclEditorResult Class
Inheritance Hierarchy See Also
Collapse All
C#
public class OclEditorResult;
Remarks

This is class Eco.Handles.OclEditorResult.

Inheritance Hierarchy
Eco.Handles.OclEditorResult
File

OclEditorSupport.cs

See Also
Inheritance Hierarchy


OclEditorResult.OclEditorResult Constructor

OclEditorResult.OclEditorResult Constructor
OclEditorResult Class Eco.Handles Namespace See Also
Collapse All
C#
public OclEditorResult(
    DialogResult dialogResult,
    string expression
);
Remarks

This is OclEditorResult, a member of class OclEditorResult.

See Also
OclEditorResult Class
Eco.Handles Namespace


OclEditorResult Properties

OclEditorResult Properties
Public Properties
Collapse All

The properties of the OclEditorResult class are listed here.

Public Properties
Name | Description
DialogResult | This is DialogResult, a member of class OclEditorResult.
Expression | This is Expression, a member of class OclEditorResult.


OclEditorResult.DialogResult Property

OclEditorResult.DialogResult Property
OclEditorResult Class Eco.Handles Namespace See Also
Collapse All
C#
public DialogResult DialogResult;
Remarks

This is DialogResult, a member of class OclEditorResult.

See Also
OclEditorResult Class
Eco.Handles Namespace


OclEditorResult.Expression Property

OclEditorResult.Expression Property
OclEditorResult Class Eco.Handles Namespace See Also
Collapse All
C#
public string Expression;
Remarks

This is Expression, a member of class OclEditorResult.

See Also
OclEditorResult Class
Eco.Handles Namespace


OclEditorSupport Class

OclEditorSupport Class
Inheritance Hierarchy See Also
Collapse All

OclEditorSuppport is a convenience class to show an ocl-editor.

C#
public class OclEditorSupport;
Inheritance Hierarchy
Eco.Handles.OclEditorSupport
File

OclEditorSupport.cs

See Also
Inheritance Hierarchy


OclEditorSupport Methods

OclEditorSupport Methods
Public Methods
Collapse All

The methods of the OclEditorSupport class are listed here.

Public Methods
Name | Description
ShowEditor | This is the overview for the ShowEditor method overload.


ShowEditor Method

ShowEditor Method

This is the overview for the ShowEditor method overload.

Overload List
Name | Description
OclEditorSupport.ShowEditor (IHasEditableExpression) | This is ShowEditor, a member of class OclEditorSupport.
OclEditorSupport.ShowEditor (IHelpService, IHasEditableExpression, bool) | This is ShowEditor, a member of class OclEditorSupport.
OclEditorSupport.ShowEditor (IServiceProvider, IHasEditableExpression, bool) |
OclEditorSupport.ShowEditor (ITypeService, IEcoTypeSystem, IClassifier, string, IExternalVariableList) | This is ShowEditor, a member of class OclEditorSupport.
OclEditorSupport.ShowEditor (ITypeService, IEcoTypeSystem, IClassifier, string, IExternalVariableList, bool, IClassifier, IHelpService) | This is ShowEditor, a member of class OclEditorSupport.


OclEditorSupport.ShowEditor Method (IHasEditableExpression)

OclEditorSupport.ShowEditor Method (IHasEditableExpression)
OclEditorSupport Class Eco.Handles Namespace See Also
Collapse All
C#
public static bool ShowEditor(
    IHasEditableExpression e
);
Remarks

This is ShowEditor, a member of class OclEditorSupport.

See Also
OclEditorSupport Class
Eco.Handles Namespace


OclEditorSupport.ShowEditor Method (IHelpService, IHasEditableExpression, bool)

OclEditorSupport.ShowEditor Method (IHelpService, IHasEditableExpression, bool)
OclEditorSupport Class Eco.Handles Namespace See Also
Collapse All
C#
public static bool ShowEditor(
    IHelpService helpService,
    IHasEditableExpression e,
    bool binariesOutOfDate
);
Remarks

This is ShowEditor, a member of class OclEditorSupport.

See Also
OclEditorSupport Class
Eco.Handles Namespace


OclEditorSupport.ShowEditor Method (IServiceProvider, IHasEditableExpression, bool)

OclEditorSupport.ShowEditor Method (IServiceProvider, IHasEditableExpression, bool)
OclEditorSupport Class Eco.Handles Namespace See Also
Collapse All
C#
public static bool ShowEditor(
    IServiceProvider serviceProvider,
    IHasEditableExpression e,
    bool binariesOutOfDate
);
Exceptions
Exceptions | Description
ArgumentNullException | Thrown if e is null.
See Also
OclEditorSupport Class
Eco.Handles Namespace


OclEditorSupport.ShowEditor Method (ITypeService, IEcoTypeSystem, IClassifier, string, IExternalVariableList)

OclEditorSupport.ShowEditor Method (ITypeService, IEcoTypeSystem, IClassifier, string, IExternalVariableList)
OclEditorSupport Class Eco.Handles Namespace See Also
Collapse All
C#
public static OclEditorResult ShowEditor(
    ITypeService typeService,
    IEcoTypeSystem typeSystem,
    IClassifier context,
    string expression,
    IExternalVariableList variables
);
Remarks

This is ShowEditor, a member of class OclEditorSupport.

See Also
OclEditorSupport Class
Eco.Handles Namespace


OclEditorSupport.ShowEditor Method (ITypeService, IEcoTypeSystem, IClassifier, string, IExternalVariableList, bool, IClassifier, IHelpService)

OclEditorSupport.ShowEditor Method (ITypeService, IEcoTypeSystem, IClassifier, string, IExternalVariableList, bool, IClassifier, IHelpService)
OclEditorSupport Class Eco.Handles Namespace See Also
Collapse All
C#
public static OclEditorResult ShowEditor(
    ITypeService typeService,
    IEcoTypeSystem typeSystem,
    IClassifier context,
    string oldExpression,
    IExternalVariableList variables,
    bool binariesOutOfDate,
    IClassifier expectedType,
    IHelpService helpService
);
Remarks

This is ShowEditor, a member of class OclEditorSupport.

See Also
OclEditorSupport Class
Eco.Handles Namespace


OclPSHandle Class

OclPSHandle Class
Inheritance Hierarchy Related Topics See Also
Collapse All

An ECO handle that specifies its ElementHandle.Element in the form of an OCL expression evaluated direcly within the data store.

C#
public sealed class OclPSHandle : RootedHandle, IHasEditableExpression;
Remarks

The OclPSHandle obtains its EcoSpace instance from its RootHandle property. It then uses the OCL expression specified in its Expression property by evaluating it against the context of its RootHandle.

Unlike the ExpressionHandle which loads objects from the data store into memory in order to perform its evaluation, the OclPSHandle will instead evaluate the expression in the data store itself. In the case of a SQL database the OCL will be translated into one or more SQL statements and executed.

The OclPSHandle will not load any object contents into memory, instead it will only add the ID of the object to the local EcoSpace cache's list of known objects. The contents of the resulting objects will be loaded on demand or if Eco.Services.IPersistenceService.EnsureRange is executed.

As the evaluation is made within the data store and not locally it is possible for an object in the data store to match a given criteria, but for the same object in the cache not to match. For example, if the following expression was evaluated.

Copy Code
       Person.allInstances->select(firstName = 'Fred')

one of the object IDs returned may refer to an object that has been modified locally but not yet saved. Resulting in a list of objects where all have a first name 'Fred' except for the modified object. To avoid this it is possible to evaluate the following expression on an ExpressionHandle linked to the current OclPSHandle.

Copy Code
       Person.allLoadedObjects->select(firstName = 'Fred')

Related Topics

OclPSHandle.Expression, ExpressionHandle

Inheritance Hierarchy
Eco.Handles.IElementHandle
Eco.Handles.INotifyOnIdle
    Eco.Handles.ElementHandle
    Eco.Handles.IRooted
        Eco.Handles.RootedHandle
        Eco.Handles.IHasEditableExpression
            Eco.Handles.OclPSHandle
File

OCLPSHandle.cs

See Also
Inheritance Hierarchy
Related Topics


OclPSHandle Methods

OclPSHandle Methods
Protected Methods Public Methods
Collapse All

The methods of the OclPSHandle class are listed here.

Protected Methods
Name | Description
DeriveAndSubscribe | This is DeriveAndSubscribe, a member of class OclPSHandle.
GetStaticUmlType | This is GetStaticUmlType, a member of class OclPSHandle.
StaticContextChanged | This is StaticContextChanged, a member of class OclPSHandle.
Top
Public Methods
Name | Description
Execute | Evaluates the OCL expression directly in the data store and creates an Element to hold the results.


OclPSHandle.DeriveAndSubscribe Method

OclPSHandle.DeriveAndSubscribe Method
OclPSHandle Class Eco.Handles Namespace See Also
Collapse All
C#
protected override void DeriveAndSubscribe(
    ISubscriber valueChangeSubscriber,
    ISubscriber resubscribeSubscriber
);
Remarks

This is DeriveAndSubscribe, a member of class OclPSHandle.

See Also
OclPSHandle Class
Eco.Handles Namespace


OclPSHandle.Execute Method

OclPSHandle.Execute Method
OclPSHandle Class Eco.Handles Namespace Related Topics See Also
Collapse All

Evaluates the OCL expression directly in the data store and creates an Element to hold the results.

C#
public void Execute();
Remarks

The element returned reflects the state of the objects in the data store and does not reflect any changes that may have been made to the local EcoSpace cache and not yet saved.

Related Topics

Expression

See Also
OclPSHandle Class
Eco.Handles Namespace
Related Topics


OclPSHandle.GetStaticUmlType Method

OclPSHandle.GetStaticUmlType Method
OclPSHandle Class Eco.Handles Namespace See Also
Collapse All
C#
protected sealed override IClassifier GetStaticUmlType();
Remarks

This is GetStaticUmlType, a member of class OclPSHandle.

See Also
OclPSHandle Class
Eco.Handles Namespace


OclPSHandle.StaticContextChanged Method

OclPSHandle.StaticContextChanged Method
OclPSHandle Class Eco.Handles Namespace See Also
Collapse All
C#
protected override void StaticContextChanged();
Remarks

This is StaticContextChanged, a member of class OclPSHandle.

See Also
OclPSHandle Class
Eco.Handles Namespace


OclPSHandle Properties

OclPSHandle Properties
Public Properties
Collapse All

The properties of the OclPSHandle class are listed here.

Public Properties
Name | Description
Expression | The OCL expression to be used when deriving the value of the handle.
MaxAnswers | Specifies the maximum number of results to return.
Offset | Specifies the first object instance to include from the evaluation.


OclPSHandle.Expression Property

OclPSHandle.Expression Property
OclPSHandle Class Eco.Handles Namespace Example Related Topics See Also
Collapse All

The OCL expression to be used when deriving the value of the handle.

C#
public string Expression;
Remarks

The Element property is set to the value obtained by evaluating this OCL expression against the Element of its RootHandle.

The OCL expression may only contain a subset of OCL commands as not all commands are possible via SQL. The expression specified must return either a single instance of a modeled UML class, or a collection of instances.

Related Topics

Execute

Example
Copy Code
           Person.allInstances->select(firstName = 'Pete')->first
Copy Code
           self.homeResidence.tenants
See Also
OclPSHandle Class
Eco.Handles Namespace
Example
Related Topics


OclPSHandle.MaxAnswers Property

OclPSHandle.MaxAnswers Property
OclPSHandle Class Eco.Handles Namespace Related Topics See Also
Collapse All

Specifies the maximum number of results to return.

C#
public int MaxAnswers;
Remarks

If this value is -1 then there will be no limit on the total number of objects returned from the data store. If the value is greater than 0 then the specified number will be the maximum number of object instances returned.

Related Topics

Offset

See Also
OclPSHandle Class
Eco.Handles Namespace
Related Topics


OclPSHandle.Offset Property

OclPSHandle.Offset Property
OclPSHandle Class Eco.Handles Namespace Related Topics See Also
Collapse All

Specifies the first object instance to include from the evaluation.

C#
public int Offset;
Remarks

This property specifies the first item returned from the data store to include in the collection that is assigned to the handle's Element property after evaluation. Combined with the MaxAnswers property this allows the developer to implement result paging, or to limit the number of included results of the data store is likely to contain a lot of data matching the specified criteria.

Related Topics

MaxAnswers

See Also
OclPSHandle Class
Eco.Handles Namespace
Related Topics


OclVariable Class

OclVariable Class
Inheritance Hierarchy See Also
Collapse All
C#
public sealed class OclVariable;
Remarks

Item

Inheritance Hierarchy
Eco.Handles.OclVariable
File

OclVariables.cs

See Also
Inheritance Hierarchy


OclVariable Constructor

OclVariable Constructor

This is the overview for the OclVariable constructor overload.

Overload List
Name | Description
OclVariable.OclVariable () | This is OclVariable, a member of class OclVariable.
OclVariable.OclVariable (OclVariable) | This is OclVariable, a member of class OclVariable.
OclVariable.OclVariable (string, ElementHandle) | This is OclVariable, a member of class OclVariable.


OclVariable.OclVariable Constructor ()

OclVariable.OclVariable Constructor ()
OclVariable Class Eco.Handles Namespace See Also
Collapse All
C#
public OclVariable();
Remarks

This is OclVariable, a member of class OclVariable.

See Also
OclVariable Class
Eco.Handles Namespace


OclVariable.OclVariable Constructor (OclVariable)

OclVariable.OclVariable Constructor (OclVariable)
OclVariable Class Eco.Handles Namespace See Also
Collapse All
C#
public OclVariable(
    OclVariable oclVariable
);
Remarks

This is OclVariable, a member of class OclVariable.

See Also
OclVariable Class
Eco.Handles Namespace


OclVariable.OclVariable Constructor (string, ElementHandle)

OclVariable.OclVariable Constructor (string, ElementHandle)
OclVariable Class Eco.Handles Namespace See Also
Collapse All
C#
public OclVariable(
    string variableName,
    ElementHandle elementHandle
);
Remarks

This is OclVariable, a member of class OclVariable.

See Also
OclVariable Class
Eco.Handles Namespace


OclVariable Methods

OclVariable Methods
Public Methods
Collapse All

The methods of the OclVariable class are listed here.

Public Methods
Name | Description
LinksToHandle | This is LinksToHandle, a member of class OclVariable.
ToString | This is ToString, a member of class OclVariable.


OclVariable.LinksToHandle Method

OclVariable.LinksToHandle Method
OclVariable Class Eco.Handles Namespace See Also
Collapse All
C#
public bool LinksToHandle(
    ElementHandle handle
);
Remarks

This is LinksToHandle, a member of class OclVariable.

See Also
OclVariable Class
Eco.Handles Namespace


OclVariable.ToString Method

OclVariable.ToString Method
OclVariable Class Eco.Handles Namespace See Also
Collapse All
C#
public override string ToString();
Remarks

This is ToString, a member of class OclVariable.

See Also
OclVariable Class
Eco.Handles Namespace


OclVariable Properties

OclVariable Properties
Public Properties
Collapse All

The properties of the OclVariable class are listed here.

Public Properties
Name | Description
ElementHandle | This is ElementHandle, a member of class OclVariable.
VariableName | This is VariableName, a member of class OclVariable.


OclVariable.ElementHandle Property

OclVariable.ElementHandle Property
OclVariable Class Eco.Handles Namespace See Also
Collapse All
C#
public ElementHandle ElementHandle;
Remarks

This is ElementHandle, a member of class OclVariable.

See Also
OclVariable Class
Eco.Handles Namespace


OclVariable.VariableName Property

OclVariable.VariableName Property
OclVariable Class Eco.Handles Namespace See Also
Collapse All
C#
public string VariableName;
Remarks

This is VariableName, a member of class OclVariable.

See Also
OclVariable Class
Eco.Handles Namespace


OclVariableCollection Class

OclVariableCollection Class
Inheritance Hierarchy See Also
Collapse All
C#
public sealed class OclVariableCollection : System.Collections.CollectionBase, IExternalVariableList;
Remarks

internal class ExternalVariableListAdapter: IExternalVariableList { OclVariableCollection adaptee; internal ExternalVariableListAdapter(OclVariableCollection adaptee) { this.adaptee = adaptee; }

int IExternalVariableList.Count { get { return adaptee.Count; } } IExternalVariable IExternalVariableList.this[int index] { get { return adaptee[index].Variable; } } IExternalVariable IExternalVariableList.this[string name] { get { return adaptee[name]; } } void IExternalVariableList.Subscribe(ISubscriber subscriber) { adaptee.Subscribe(subscriber); } IEnumerator IEnumerable.GetEnumerator() { ArrayList list = new ArrayList(); foreach (OclVariable v in adaptee) list.Add(v.Variable); return list.GetEnumerator();

Inheritance Hierarchy
Eco.Handles.OclVariableCollection
File

OclVariables.cs

See Also
Inheritance Hierarchy


OclVariableCollection.OclVariableCollection Constructor

OclVariableCollection.OclVariableCollection Constructor
OclVariableCollection Class Eco.Handles Namespace See Also
Collapse All
C#
public OclVariableCollection(
    OclVariables owner
);
Remarks

This is OclVariableCollection, a member of class OclVariableCollection.

See Also
OclVariableCollection Class
Eco.Handles Namespace


OclVariableCollection Methods

OclVariableCollection Methods
Protected Methods Public Methods
Collapse All

The methods of the OclVariableCollection class are listed here.

Protected Methods
Name | Description
OnInsert |
OnInsertComplete | This is OnInsertComplete, a member of class OclVariableCollection.
Top
Public Methods
Name | Description
Add | This is Add, a member of class OclVariableCollection.
AddRange | This is AddRange, a member of class OclVariableCollection.
Merge |
Remove | This is Remove, a member of class OclVariableCollection.
this | This is this, a member of class OclVariableCollection.


OclVariableCollection.Add Method

OclVariableCollection.Add Method
OclVariableCollection Class Eco.Handles Namespace See Also
Collapse All
C#
public void Add(
    OclVariable oclVariable
);
Remarks

This is Add, a member of class OclVariableCollection.

See Also
OclVariableCollection Class
Eco.Handles Namespace


OclVariableCollection.AddRange Method

OclVariableCollection.AddRange Method
OclVariableCollection Class Eco.Handles Namespace See Also
Collapse All
C#
public void AddRange(
    OclVariable[] oclVariables
);
Remarks

This is AddRange, a member of class OclVariableCollection.

See Also
OclVariableCollection Class
Eco.Handles Namespace


OclVariableCollection.Merge Method

OclVariableCollection.Merge Method
OclVariableCollection Class Eco.Handles Namespace See Also
Collapse All
C#
public static OclVariableCollection Merge(
    OclVariableCollection baseVars,
    OclVariableCollection overrideVars
);
Exceptions
Exceptions | Description
ArgumentNullException | Thrown if baseVars is null. Thrown if overrideVars is null.
See Also
OclVariableCollection Class
Eco.Handles Namespace


OclVariableCollection.OnInsert Method

OclVariableCollection.OnInsert Method
OclVariableCollection Class Eco.Handles Namespace See Also
Collapse All
C#
protected override void OnInsert(
    int index,
    object value
);
Exceptions
Exceptions | Description
InvalidOperationException | Thrown if the inserted OclVariable's name is not unique in the owning collection.
See Also
OclVariableCollection Class
Eco.Handles Namespace


OclVariableCollection.OnInsertComplete Method

OclVariableCollection.OnInsertComplete Method
OclVariableCollection Class Eco.Handles Namespace See Also
Collapse All
C#
protected override void OnInsertComplete(
    int index,
    object value
);
Remarks

This is OnInsertComplete, a member of class OclVariableCollection.

See Also
OclVariableCollection Class
Eco.Handles Namespace


OclVariableCollection.Remove Method

OclVariableCollection.Remove Method
OclVariableCollection Class Eco.Handles Namespace See Also
Collapse All
C#
public void Remove(
    OclVariable oclVariable
);
Remarks

This is Remove, a member of class OclVariableCollection.

See Also
OclVariableCollection Class
Eco.Handles Namespace


OclVariableCollection.this Indexer

OclVariableCollection.this Indexer
OclVariableCollection Class Eco.Handles Namespace See Also
Collapse All
C#
public OclVariable this[
    int index
];
Remarks

This is this, a member of class OclVariableCollection.

See Also
OclVariableCollection Class
Eco.Handles Namespace


OclVariables Class

OclVariables Class
Inheritance Hierarchy See Also
Collapse All
C#
public sealed class OclVariables : System.ComponentModel.Component, IOclVariables;
Remarks

This is class Eco.Handles.OclVariables.

Inheritance Hierarchy
Eco.Handles.IOclVariables
    Eco.Handles.OclVariables
File

OclVariables.cs

See Also
Inheritance Hierarchy


OclVariables.OclVariables Constructor

OclVariables.OclVariables Constructor
OclVariables Class Eco.Handles Namespace See Also
Collapse All
C#
public OclVariables();
Remarks

This is OclVariables, a member of class OclVariables.

See Also
OclVariables Class
Eco.Handles Namespace


OclVariables Properties

OclVariables Properties
Public Properties
Collapse All

The properties of the OclVariables class are listed here.

Public Properties
Name | Description
OclVariableCollection | This is OclVariableCollection, a member of class OclVariables.


OclVariables.OclVariableCollection Property

OclVariables.OclVariableCollection Property
OclVariables Class Eco.Handles Namespace See Also
Collapse All
C#
public OclVariableCollection OclVariableCollection;
Remarks

This is OclVariableCollection, a member of class OclVariables.

See Also
OclVariables Class
Eco.Handles Namespace


PropertyComparer Class

PropertyComparer Class
Inheritance Hierarchy See Also
Collapse All
C#
public sealed class PropertyComparer : IComparer<AbstractRenderedTuple>;
Remarks

This is class Eco.Handles.PropertyComparer.

Inheritance Hierarchy
Eco.Handles.PropertyComparer
File

ControlPack.cs

See Also
Inheritance Hierarchy


PropertyComparer.PropertyComparer Constructor

PropertyComparer.PropertyComparer Constructor
PropertyComparer Class Eco.Handles Namespace See Also
Collapse All
C#
public PropertyComparer(
    ListSortDescriptionCollection sortDescriptions
);
Remarks

This is PropertyComparer, a member of class PropertyComparer.

See Also
PropertyComparer Class
Eco.Handles Namespace


PrototypeEcoSpace Class

PrototypeEcoSpace Class
Inheritance Hierarchy See Also
Collapse All
C#
public class PrototypeEcoSpace : DefaultEcoSpace, ITypeSystemService;
Remarks

This is class Eco.Handles.PrototypeEcoSpace.

Inheritance Hierarchy
Eco.Handles.EcoSpaceBase
    Eco.Handles.EcoSpace
        Eco.Handles.DefaultEcoSpace
            Eco.Handles.PrototypeEcoSpace
File

PrototypeEcospace.cs

See Also
Inheritance Hierarchy


PrototypeEcoSpace.PrototypeEcoSpace Constructor

PrototypeEcoSpace.PrototypeEcoSpace Constructor
PrototypeEcoSpace Class Eco.Handles Namespace See Also
Collapse All
C#
public PrototypeEcoSpace(
    IEcoTypeSystem typeSystem
);
Remarks

This is PrototypeEcoSpace, a member of class PrototypeEcoSpace.

See Also
PrototypeEcoSpace Class
Eco.Handles Namespace


PrototypeEcoSpace Methods

PrototypeEcoSpace Methods
Protected Methods
Collapse All

The methods of the PrototypeEcoSpace class are listed here.

Protected Methods
Name | Description
GetTypeSystemProvider | This is GetTypeSystemProvider, a member of class PrototypeEcoSpace.


PrototypeEcoSpace.GetTypeSystemProvider Method

PrototypeEcoSpace.GetTypeSystemProvider Method
PrototypeEcoSpace Class Eco.Handles Namespace See Also
Collapse All
C#
protected override ITypeSystemService GetTypeSystemProvider();
Remarks

This is GetTypeSystemProvider, a member of class PrototypeEcoSpace.

See Also
PrototypeEcoSpace Class
Eco.Handles Namespace


ReferenceHandle Class

ReferenceHandle Class
Inheritance Hierarchy See Also
Collapse All

This type of RootHandle holds a reference to an EcoSpace and (optionally) an ECO element.

C#
public sealed class ReferenceHandle : RootHandle;
Remarks

A reference handle is used as the primary handle in an application. It is used to hold a reference to an EcoSpace at runtime and optionally an ECO element such as an instance of a UML modeled class, a collection of instances, or even a simple data type.

At design time this handle is used to provide model information using its RootHandle.EcoSpaceTypeName property. This model information is then passed on to any RootedHandle that is directly or indirectly connected to this handle.

Inheritance Hierarchy
Eco.Handles.IElementHandle
Eco.Handles.INotifyOnIdle
    Eco.Handles.ElementHandle
    Eco.Handles.IHasTypeSystem
        Eco.Handles.RootHandle
            Eco.Handles.ReferenceHandle
File

ReferenceHandle.cs

See Also
Inheritance Hierarchy


ReferenceHandle Methods

ReferenceHandle Methods
Public Methods
Collapse All

The methods of the ReferenceHandle class are listed here.

Public Methods
Name | Description
SetElement | Sets the value of the handle.


ReferenceHandle.SetElement Method

ReferenceHandle.SetElement Method
ReferenceHandle Class Eco.Handles Namespace Related Topics See Also
Collapse All

Sets the value of the handle.

C#
public void SetElement(
    object value
);
Parameters
Parameters | Description
value | An object containing the value to hold.
Remarks

If no element is set then any RootedHandles that use this handle as its RootHandle will have the EcoSpace as their context. If an element is set then rooted handles will use the element specified as their context instead.

Exceptions
Exceptions | Description
ArgumentException | Thrown if value does not implement IElement, IEcoObject or IElementProvider.
Related Topics

Eco.ObjectRepresentation.IElement, Eco.ObjectRepresentation.IElementProvider, Eco.ObjectRepresentation.IEcoObject

See Also
ReferenceHandle Class
Eco.Handles Namespace
Related Topics


RenderedList Class

RenderedList Class
Inheritance Hierarchy See Also
Collapse All
C#
public sealed class RenderedList : AbstractDeriver, ITypedList, IBindingListView, IReorderableList;
Remarks

This is class Eco.Handles.RenderedList.

Inheritance Hierarchy
Eco.Handles.IReorderableList
    Eco.Handles.RenderedList
File

ControlPack.cs

See Also
Inheritance Hierarchy


RenderedList.RenderedList Constructor

RenderedList.RenderedList Constructor
RenderedList Class Eco.Handles Namespace See Also
Collapse All
C#
public RenderedList(
    ITupleListRenderingContext context
);
Remarks

This is RenderedList, a member of class RenderedList.

See Also
RenderedList Class
Eco.Handles Namespace


RenderedList Methods

RenderedList Methods
Protected Methods Public Methods
Collapse All

The methods of the RenderedList class are listed here.

Protected Methods
Name | Description
DoDeriveAndSubscribe | This is DoDeriveAndSubscribe, a member of class RenderedList.
DoNotifyOutOfDate | This is DoNotifyOutOfDate, a member of class RenderedList.
Top
Public Methods
Name | Description
CreateTestData | This is CreateTestData, a member of class RenderedList.
GetItem | This is GetItem, a member of class RenderedList.
MakeListsCurrent | This is MakeListsCurrent, a member of class RenderedList.
SignalListChanged | This is SignalListChanged, a member of class RenderedList.
ToString | This is ToString, a member of class RenderedList.
TupleDescriptorChanged | This is TupleDescriptorChanged, a member of class RenderedList.


RenderedList.CreateTestData Method

RenderedList.CreateTestData Method
RenderedList Class Eco.Handles Namespace See Also
Collapse All
C#
public void CreateTestData(
    int minimumRows
);
Remarks

This is CreateTestData, a member of class RenderedList.

See Also
RenderedList Class
Eco.Handles Namespace


RenderedList.DoDeriveAndSubscribe Method

RenderedList.DoDeriveAndSubscribe Method
RenderedList Class Eco.Handles Namespace See Also
Collapse All
C#
protected override void DoDeriveAndSubscribe(
    bool subscribe
);
Remarks

This is DoDeriveAndSubscribe, a member of class RenderedList.

See Also
RenderedList Class
Eco.Handles Namespace


RenderedList.DoNotifyOutOfDate Method

RenderedList.DoNotifyOutOfDate Method
RenderedList Class Eco.Handles Namespace See Also
Collapse All
C#
protected override void DoNotifyOutOfDate();
Remarks

This is DoNotifyOutOfDate, a member of class RenderedList.

See Also
RenderedList Class
Eco.Handles Namespace


RenderedList.GetItem Method

RenderedList.GetItem Method
RenderedList Class Eco.Handles Namespace See Also
Collapse All
C#
public object GetItem(
    int index
);
Remarks

This is GetItem, a member of class RenderedList.

See Also
RenderedList Class
Eco.Handles Namespace


RenderedList.MakeListsCurrent Method

RenderedList.MakeListsCurrent Method
RenderedList Class Eco.Handles Namespace See Also
Collapse All
C#
public void MakeListsCurrent();
Remarks

This is MakeListsCurrent, a member of class RenderedList.

See Also
RenderedList Class
Eco.Handles Namespace


RenderedList.SignalListChanged Method

RenderedList.SignalListChanged Method
RenderedList Class Eco.Handles Namespace See Also
Collapse All
C#
public void SignalListChanged(
    ListChangedEventArgs args
);
Remarks

This is SignalListChanged, a member of class RenderedList.

See Also
RenderedList Class
Eco.Handles Namespace


RenderedList.ToString Method

RenderedList.ToString Method
RenderedList Class Eco.Handles Namespace See Also
Collapse All
C#
public override string ToString();
Remarks

This is ToString, a member of class RenderedList.

See Also
RenderedList Class
Eco.Handles Namespace


RenderedList.TupleDescriptorChanged Method

RenderedList.TupleDescriptorChanged Method
RenderedList Class Eco.Handles Namespace See Also
Collapse All
C#
public void TupleDescriptorChanged();
Remarks

This is TupleDescriptorChanged, a member of class RenderedList.

See Also
RenderedList Class
Eco.Handles Namespace


RenderedList Properties

RenderedList Properties
Public Properties
Collapse All

The properties of the RenderedList class are listed here.

Public Properties
Name | Description
Context | This is Context, a member of class RenderedList.
SupportsAddNew | This is SupportsAddNew, a member of class RenderedList.


RenderedList.Context Property

RenderedList.Context Property
RenderedList Class Eco.Handles Namespace See Also
Collapse All
C#
public ITupleListRenderingContext Context;
Remarks

This is Context, a member of class RenderedList.

See Also
RenderedList Class
Eco.Handles Namespace


RenderedList.SupportsAddNew Property

RenderedList.SupportsAddNew Property
RenderedList Class Eco.Handles Namespace See Also
Collapse All
C#
public bool SupportsAddNew;
Remarks

This is SupportsAddNew, a member of class RenderedList.

See Also
RenderedList Class
Eco.Handles Namespace


RenderedTestTuple Class

RenderedTestTuple Class
Inheritance Hierarchy See Also
Collapse All
C#
public sealed class RenderedTestTuple : AbstractRenderedTuple;
Remarks

This is class Eco.Handles.RenderedTestTuple.

Inheritance Hierarchy
Eco.Handles.IRenderingContext
    Eco.Handles.ITuplePropertyRenderingContext
        Eco.Handles.AbstractRenderedTuple
            Eco.Handles.RenderedTestTuple
File

ControlPack.cs

See Also
Inheritance Hierarchy


RenderedTestTuple.RenderedTestTuple Constructor

RenderedTestTuple.RenderedTestTuple Constructor
RenderedTestTuple Class Eco.Handles Namespace See Also
Collapse All
C#
public RenderedTestTuple(
    ITupleRenderingContext owner,
    int testData
);
Remarks

This is RenderedTestTuple, a member of class RenderedTestTuple.

See Also
RenderedTestTuple Class
Eco.Handles Namespace


RenderedTestTuple Properties

RenderedTestTuple Properties
Public Properties
Collapse All

The properties of the RenderedTestTuple class are listed here.

Public Properties
Name | Description
IsTestTuple | This is IsTestTuple, a member of class RenderedTestTuple.


RenderedTestTuple.IsTestTuple Property

RenderedTestTuple.IsTestTuple Property
RenderedTestTuple Class Eco.Handles Namespace See Also
Collapse All
C#
public override bool IsTestTuple;
Remarks

This is IsTestTuple, a member of class RenderedTestTuple.

See Also
RenderedTestTuple Class
Eco.Handles Namespace


RenderedTuple Class

RenderedTuple Class
Inheritance Hierarchy See Also
Collapse All
C#
public sealed class RenderedTuple : AbstractRenderedTuple;
Remarks

This is class Eco.Handles.RenderedTuple.

Inheritance Hierarchy
Eco.Handles.IRenderingContext
    Eco.Handles.ITuplePropertyRenderingContext
        Eco.Handles.AbstractRenderedTuple
            Eco.Handles.RenderedTuple
File

ControlPack.cs

See Also
Inheritance Hierarchy


RenderedTuple.RenderedTuple Constructor

RenderedTuple.RenderedTuple Constructor
RenderedTuple Class Eco.Handles Namespace See Also
Collapse All
C#
public RenderedTuple(
    IElement element,
    ITupleRenderingContext owner
);
Remarks

This is RenderedTuple, a member of class RenderedTuple.

See Also
RenderedTuple Class
Eco.Handles Namespace


RenderedTupleDescriptor Class

RenderedTupleDescriptor Class
Inheritance Hierarchy See Also
Collapse All

This class is part of the internal implementation of the databindable Ilist implemented by the Eco handles. It should not be used directly.

C#
public sealed class RenderedTupleDescriptor : PropertyDescriptorCollection;
Inheritance Hierarchy
Eco.Handles.RenderedTupleDescriptor
File

ControlPack.cs

See Also
Inheritance Hierarchy


RenderedTupleDescriptor.RenderedTupleDescriptor Constructor

RenderedTupleDescriptor.RenderedTupleDescriptor Constructor
RenderedTupleDescriptor Class Eco.Handles Namespace See Also
Collapse All
C#
public RenderedTupleDescriptor(
    IStaticContext staticContext
);
Remarks

This is RenderedTupleDescriptor, a member of class RenderedTupleDescriptor.

See Also
RenderedTupleDescriptor Class
Eco.Handles Namespace


RenderedTupleDescriptor Methods

RenderedTupleDescriptor Methods
Public Methods
Collapse All

The methods of the RenderedTupleDescriptor class are listed here.

Public Methods
Name | Description
SetupProperties | This is SetupProperties, a member of class RenderedTupleDescriptor.


RenderedTupleDescriptor.SetupProperties Method

RenderedTupleDescriptor.SetupProperties Method
RenderedTupleDescriptor Class Eco.Handles Namespace See Also
Collapse All
C#
public void SetupProperties(
    IEnumerable columns,
    bool addDefaultProperties,
    bool addDefaultNestings,
    bool addExternalId,
    bool addSelfColumn,
    MemberVisibility memberVisibility,
    DescriptorFactory descriptorFacory,
    bool designMode,
    NullRowMode nullRowMode,
    bool supportSorting,
    bool allowNew,
    FilterMode filterMode
);
Remarks

This is SetupProperties, a member of class RenderedTupleDescriptor.

See Also
RenderedTupleDescriptor Class
Eco.Handles Namespace


RenderedTupleDescriptor Properties

RenderedTupleDescriptor Properties
Public Properties
Collapse All

The properties of the RenderedTupleDescriptor class are listed here.

Public Properties
Name | Description
AllowNew | This is AllowNew, a member of class RenderedTupleDescriptor.
DescriptorFactory | This is DescriptorFactory, a member of class RenderedTupleDescriptor.
FilterMode | This is FilterMode, a member of class RenderedTupleDescriptor.
HasEditableProperty | This is HasEditableProperty, a member of class RenderedTupleDescriptor.
IsDeriveValueAssigned | This is IsDeriveValueAssigned, a member of class RenderedTupleDescriptor.
IsReverseDeriveValueAssigned | This is IsReverseDeriveValueAssigned, a member of class RenderedTupleDescriptor.
NullRowMode | This is NullRowMode, a member of class RenderedTupleDescriptor.
StaticContext | This is StaticContext, a member of class RenderedTupleDescriptor.
SupportSorting | This is SupportSorting, a member of class RenderedTupleDescriptor.


RenderedTupleDescriptor.AllowNew Property

RenderedTupleDescriptor.AllowNew Property
RenderedTupleDescriptor Class Eco.Handles Namespace See Also
Collapse All
C#
public bool AllowNew;
Remarks

This is AllowNew, a member of class RenderedTupleDescriptor.

See Also
RenderedTupleDescriptor Class
Eco.Handles Namespace


RenderedTupleDescriptor.DescriptorFactory Property

RenderedTupleDescriptor.DescriptorFactory Property
RenderedTupleDescriptor Class Eco.Handles Namespace See Also
Collapse All
C#
public DescriptorFactory DescriptorFactory;
Remarks

This is DescriptorFactory, a member of class RenderedTupleDescriptor.

See Also
RenderedTupleDescriptor Class
Eco.Handles Namespace


RenderedTupleDescriptor.FilterMode Property

RenderedTupleDescriptor.FilterMode Property
RenderedTupleDescriptor Class Eco.Handles Namespace See Also
Collapse All
C#
public FilterMode FilterMode;
Remarks

This is FilterMode, a member of class RenderedTupleDescriptor.

See Also
RenderedTupleDescriptor Class
Eco.Handles Namespace


RenderedTupleDescriptor.HasEditableProperty Property

RenderedTupleDescriptor.HasEditableProperty Property
RenderedTupleDescriptor Class Eco.Handles Namespace See Also
Collapse All
C#
public bool HasEditableProperty;
Remarks

This is HasEditableProperty, a member of class RenderedTupleDescriptor.

See Also
RenderedTupleDescriptor Class
Eco.Handles Namespace


RenderedTupleDescriptor.IsDeriveValueAssigned Property

RenderedTupleDescriptor.IsDeriveValueAssigned Property
RenderedTupleDescriptor Class Eco.Handles Namespace See Also
Collapse All
C#
public bool IsDeriveValueAssigned;
Remarks

This is IsDeriveValueAssigned, a member of class RenderedTupleDescriptor.

See Also
RenderedTupleDescriptor Class
Eco.Handles Namespace


RenderedTupleDescriptor.IsReverseDeriveValueAssigned Property

RenderedTupleDescriptor.IsReverseDeriveValueAssigned Property
RenderedTupleDescriptor Class Eco.Handles Namespace See Also
Collapse All
C#
public bool IsReverseDeriveValueAssigned;
Remarks

This is IsReverseDeriveValueAssigned, a member of class RenderedTupleDescriptor.

See Also
RenderedTupleDescriptor Class
Eco.Handles Namespace


RenderedTupleDescriptor.NullRowMode Property

RenderedTupleDescriptor.NullRowMode Property
RenderedTupleDescriptor Class Eco.Handles Namespace See Also
Collapse All
C#
public NullRowMode NullRowMode;
Remarks

This is NullRowMode, a member of class RenderedTupleDescriptor.

See Also
RenderedTupleDescriptor Class
Eco.Handles Namespace


RenderedTupleDescriptor.StaticContext Property

RenderedTupleDescriptor.StaticContext Property
RenderedTupleDescriptor Class Eco.Handles Namespace See Also
Collapse All
C#
public IStaticContext StaticContext;
Remarks

This is StaticContext, a member of class RenderedTupleDescriptor.

See Also
RenderedTupleDescriptor Class
Eco.Handles Namespace


RenderedTupleDescriptor.SupportSorting Property

RenderedTupleDescriptor.SupportSorting Property
RenderedTupleDescriptor Class Eco.Handles Namespace See Also
Collapse All
C#
public bool SupportSorting;
Remarks

This is SupportSorting, a member of class RenderedTupleDescriptor.

See Also
RenderedTupleDescriptor Class
Eco.Handles Namespace


RenderedTupleDescriptor Events

RenderedTupleDescriptor Events
Public Events
Collapse All

The events of the RenderedTupleDescriptor class are listed here.

Public Events
Name | Description
DeriveValue | This is DeriveValue, a member of class RenderedTupleDescriptor.
DescriptorsChanged | This is DescriptorsChanged, a member of class RenderedTupleDescriptor.
ReverseDeriveValue | This is ReverseDeriveValue, a member of class RenderedTupleDescriptor.


RenderedTupleDescriptor.DeriveValue Event

RenderedTupleDescriptor.DeriveValue Event
RenderedTupleDescriptor Class Eco.Handles Namespace See Also
Collapse All
C#
public event DeriveEventHandler DeriveValue;
Remarks

This is DeriveValue, a member of class RenderedTupleDescriptor.

See Also
RenderedTupleDescriptor Class
Eco.Handles Namespace


RenderedTupleDescriptor.DescriptorsChanged Event

RenderedTupleDescriptor.DescriptorsChanged Event
RenderedTupleDescriptor Class Eco.Handles Namespace See Also
Collapse All
C#
public event SignalListChangedHandler DescriptorsChanged;
Remarks

This is DescriptorsChanged, a member of class RenderedTupleDescriptor.

See Also
RenderedTupleDescriptor Class
Eco.Handles Namespace


RenderedTupleDescriptor.ReverseDeriveValue Event

RenderedTupleDescriptor.ReverseDeriveValue Event
RenderedTupleDescriptor Class Eco.Handles Namespace See Also
Collapse All
C#
public event ReverseDeriveEventHandler ReverseDeriveValue;
Remarks

This is ReverseDeriveValue, a member of class RenderedTupleDescriptor.

See Also
RenderedTupleDescriptor Class
Eco.Handles Namespace


RenderedTupleFilter Class

RenderedTupleFilter Class
Inheritance Hierarchy See Also
Collapse All
C#
public abstract class RenderedTupleFilter;
Remarks

This is class Eco.Handles.RenderedTupleFilter.

Inheritance Hierarchy
Eco.Handles.RenderedTupleFilter
File

ControlPack.cs

See Also
Inheritance Hierarchy


RenderedTupleFilter Methods

RenderedTupleFilter Methods
Public Methods
Collapse All

The methods of the RenderedTupleFilter class are listed here.

Public Methods
Name | Description
Filter | This is Filter, a member of class RenderedTupleFilter.
Match | This is Match, a member of class RenderedTupleFilter.


RenderedTupleFilter.Filter Method

RenderedTupleFilter.Filter Method
RenderedTupleFilter Class Eco.Handles Namespace See Also
Collapse All
C#
public List<AbstractRenderedTuple> Filter(
    List<AbstractRenderedTuple> list
);
Remarks

This is Filter, a member of class RenderedTupleFilter.

See Also
RenderedTupleFilter Class
Eco.Handles Namespace


RenderedTupleFilter.Match Method

RenderedTupleFilter.Match Method
RenderedTupleFilter Class Eco.Handles Namespace See Also
Collapse All
C#
public abstract bool Match(
    AbstractRenderedTuple rt
);
Remarks

This is Match, a member of class RenderedTupleFilter.

See Also
RenderedTupleFilter Class
Eco.Handles Namespace


RenderedTupleListProperty Class

RenderedTupleListProperty Class
Inheritance Hierarchy See Also
Collapse All
C#
public sealed class RenderedTupleListProperty : AbstractRenderedTupleProperty, ITupleListRenderingContext;
Remarks

This is class Eco.Handles.RenderedTupleListProperty.

Inheritance Hierarchy
Eco.Handles.IRenderingContext
    Eco.Handles.ITupleRenderingContext
        Eco.Handles.ITupleListRenderingContext
        Eco.Handles.AbstractRenderedTupleProperty
            Eco.Handles.RenderedTupleListProperty
File

ControlPack.cs

See Also
Inheritance Hierarchy


RenderedTupleListProperty.RenderedTupleListProperty Constructor

RenderedTupleListProperty.RenderedTupleListProperty Constructor
RenderedTupleListProperty Class Eco.Handles Namespace See Also
Collapse All
C#
public RenderedTupleListProperty(
    RenderedTuplePropertyDescriptor descriptor,
    ITuplePropertyRenderingContext owner
);
Remarks

This is RenderedTupleListProperty, a member of class RenderedTupleListProperty.

See Also
RenderedTupleListProperty Class
Eco.Handles Namespace


RenderedTupleListProperty Methods

RenderedTupleListProperty Methods
Protected Methods Public Methods
Collapse All

The methods of the RenderedTupleListProperty class are listed here.

Protected Methods
Name | Description
DoGetValue | This is DoGetValue, a member of class RenderedTupleListProperty.
Top
Public Methods
Name | Description
SetValue |


RenderedTupleListProperty.DoGetValue Method

RenderedTupleListProperty.DoGetValue Method
RenderedTupleListProperty Class Eco.Handles Namespace See Also
Collapse All
C#
protected override object DoGetValue();
Remarks

This is DoGetValue, a member of class RenderedTupleListProperty.

See Also
RenderedTupleListProperty Class
Eco.Handles Namespace


RenderedTupleListProperty.SetValue Method

RenderedTupleListProperty.SetValue Method
RenderedTupleListProperty Class Eco.Handles Namespace See Also
Collapse All
C#
public override void SetValue(
    object value
);
Exceptions
Exceptions | Description
InvalidOperationException | Thrown always.
See Also
RenderedTupleListProperty Class
Eco.Handles Namespace


RenderedTupleProperty Class

RenderedTupleProperty Class
Inheritance Hierarchy See Also
Collapse All
C#
public sealed class RenderedTupleProperty : AbstractRenderedTupleProperty;
Remarks

This is class Eco.Handles.RenderedTupleProperty.

Inheritance Hierarchy
Eco.Handles.AbstractRenderedTupleProperty
    Eco.Handles.RenderedTupleProperty
File

ControlPack.cs

See Also
Inheritance Hierarchy


RenderedTupleProperty.RenderedTupleProperty Constructor

RenderedTupleProperty.RenderedTupleProperty Constructor
RenderedTupleProperty Class Eco.Handles Namespace See Also
Collapse All
C#
public RenderedTupleProperty(
    RenderedTuplePropertyDescriptor descriptor,
    ITuplePropertyRenderingContext owner
);
Remarks

This is RenderedTupleProperty, a member of class RenderedTupleProperty.

See Also
RenderedTupleProperty Class
Eco.Handles Namespace


RenderedTupleProperty Methods

RenderedTupleProperty Methods
Protected Methods Public Methods
Collapse All

The methods of the RenderedTupleProperty class are listed here.

Protected Methods
Name | Description
DoGetValue | This is DoGetValue, a member of class RenderedTupleProperty.
Top
Public Methods
Name | Description
SetValue | This is SetValue, a member of class RenderedTupleProperty.


RenderedTupleProperty.DoGetValue Method

RenderedTupleProperty.DoGetValue Method
RenderedTupleProperty Class Eco.Handles Namespace See Also
Collapse All
C#
protected override object DoGetValue();
Remarks

This is DoGetValue, a member of class RenderedTupleProperty.

See Also
RenderedTupleProperty Class
Eco.Handles Namespace


RenderedTupleProperty.SetValue Method

RenderedTupleProperty.SetValue Method
RenderedTupleProperty Class Eco.Handles Namespace See Also
Collapse All
C#
public override void SetValue(
    object value
);
Remarks

This is SetValue, a member of class RenderedTupleProperty.

See Also
RenderedTupleProperty Class
Eco.Handles Namespace


RenderedTuplePropertyDescriptor Class

RenderedTuplePropertyDescriptor Class
Inheritance Hierarchy See Also
Collapse All
C#
public sealed class RenderedTuplePropertyDescriptor : PropertyDescriptor;
Remarks

This is class Eco.Handles.RenderedTuplePropertyDescriptor.

Inheritance Hierarchy
Eco.Handles.RenderedTuplePropertyDescriptor
File

ControlPack.cs

See Also
Inheritance Hierarchy


RenderedTuplePropertyDescriptor Methods

RenderedTuplePropertyDescriptor Methods
Public Methods
Collapse All

The methods of the RenderedTuplePropertyDescriptor class are listed here.

Public Methods
Name | Description
CanResetValue | This is CanResetValue, a member of class RenderedTuplePropertyDescriptor.
DeriveAndSubscribe | Rendering
GetItemProperties | This is GetItemProperties, a member of class RenderedTuplePropertyDescriptor.
GetOwnItemProperties | This is GetOwnItemProperties, a member of class RenderedTuplePropertyDescriptor.
GetValue | This is GetValue, a member of class RenderedTuplePropertyDescriptor.
ResetValue | This is ResetValue, a member of class RenderedTuplePropertyDescriptor.
ReverseDerive | This is ReverseDerive, a member of class RenderedTuplePropertyDescriptor.
SetValue | This is SetValue, a member of class RenderedTuplePropertyDescriptor.
ShouldSerializeValue | This is ShouldSerializeValue, a member of class RenderedTuplePropertyDescriptor.


RenderedTuplePropertyDescriptor.CanResetValue Method

RenderedTuplePropertyDescriptor.CanResetValue Method
RenderedTuplePropertyDescriptor Class Eco.Handles Namespace See Also
Collapse All
C#
public override bool CanResetValue(
    object component
);
Remarks

This is CanResetValue, a member of class RenderedTuplePropertyDescriptor.

See Also
RenderedTuplePropertyDescriptor Class
Eco.Handles Namespace


RenderedTuplePropertyDescriptor.DeriveAndSubscribe Method

RenderedTuplePropertyDescriptor.DeriveAndSubscribe Method
RenderedTuplePropertyDescriptor Class Eco.Handles Namespace See Also
Collapse All
C#
public IElement DeriveAndSubscribe(
    IEcoServiceProvider serviceProvider,
    IElement rootElement,
    ISubscriber valueChangeSubscriber,
    ISubscriber resubscribeSubscriber
);
Remarks

Rendering

Exceptions
Exceptions | Description
ArgumentNullException | Thrown if serviceProvider is null.
See Also
RenderedTuplePropertyDescriptor Class
Eco.Handles Namespace


RenderedTuplePropertyDescriptor.GetItemProperties Method

RenderedTuplePropertyDescriptor.GetItemProperties Method
RenderedTuplePropertyDescriptor Class Eco.Handles Namespace See Also
Collapse All
C#
public RenderedTupleDescriptor GetItemProperties(
    PropertyDescriptor[] listAccessors,
    int startIndex
);
Remarks

This is GetItemProperties, a member of class RenderedTuplePropertyDescriptor.

See Also
RenderedTuplePropertyDescriptor Class
Eco.Handles Namespace


RenderedTuplePropertyDescriptor.GetOwnItemProperties Method

RenderedTuplePropertyDescriptor.GetOwnItemProperties Method
RenderedTuplePropertyDescriptor Class Eco.Handles Namespace See Also
Collapse All
C#
public RenderedTupleDescriptor GetOwnItemProperties();
Remarks

This is GetOwnItemProperties, a member of class RenderedTuplePropertyDescriptor.

See Also
RenderedTuplePropertyDescriptor Class
Eco.Handles Namespace


RenderedTuplePropertyDescriptor.GetValue Method

RenderedTuplePropertyDescriptor.GetValue Method
RenderedTuplePropertyDescriptor Class Eco.Handles Namespace See Also
Collapse All
C#
public override object GetValue(
    object component
);
Remarks

This is GetValue, a member of class RenderedTuplePropertyDescriptor.

See Also
RenderedTuplePropertyDescriptor Class
Eco.Handles Namespace


RenderedTuplePropertyDescriptor.ResetValue Method

RenderedTuplePropertyDescriptor.ResetValue Method
RenderedTuplePropertyDescriptor Class Eco.Handles Namespace See Also
Collapse All
C#
public override void ResetValue(
    object component
);
Remarks

This is ResetValue, a member of class RenderedTuplePropertyDescriptor.

See Also
RenderedTuplePropertyDescriptor Class
Eco.Handles Namespace


RenderedTuplePropertyDescriptor.ReverseDerive Method

RenderedTuplePropertyDescriptor.ReverseDerive Method
RenderedTuplePropertyDescriptor Class Eco.Handles Namespace See Also
Collapse All
C#
public void ReverseDerive(
    IEcoServiceProvider serviceProvider,
    IElement rootElement,
    object value
);
Remarks

This is ReverseDerive, a member of class RenderedTuplePropertyDescriptor.

See Also
RenderedTuplePropertyDescriptor Class
Eco.Handles Namespace


RenderedTuplePropertyDescriptor.SetValue Method

RenderedTuplePropertyDescriptor.SetValue Method
RenderedTuplePropertyDescriptor Class Eco.Handles Namespace See Also
Collapse All
C#
public override void SetValue(
    object component,
    object value
);
Remarks

This is SetValue, a member of class RenderedTuplePropertyDescriptor.

See Also
RenderedTuplePropertyDescriptor Class
Eco.Handles Namespace


RenderedTuplePropertyDescriptor.ShouldSerializeValue Method

RenderedTuplePropertyDescriptor.ShouldSerializeValue Method
RenderedTuplePropertyDescriptor Class Eco.Handles Namespace See Also
Collapse All
C#
public override bool ShouldSerializeValue(
    object component
);
Remarks

This is ShouldSerializeValue, a member of class RenderedTuplePropertyDescriptor.

See Also
RenderedTuplePropertyDescriptor Class
Eco.Handles Namespace


RenderedTuplePropertyDescriptor Properties

RenderedTuplePropertyDescriptor Properties
Public Properties
Collapse All

The properties of the RenderedTuplePropertyDescriptor class are listed here.

Public Properties
Name | Description
AsExternalId | This is AsExternalId, a member of class RenderedTuplePropertyDescriptor.
ComponentType | This is ComponentType, a member of class RenderedTuplePropertyDescriptor.
Expression | This is Expression, a member of class RenderedTuplePropertyDescriptor.
IsEventDerived | This is IsEventDerived, a member of class RenderedTuplePropertyDescriptor.
IsNested | Nested descriptor
IsReadOnly | This is IsReadOnly, a member of class RenderedTuplePropertyDescriptor.
NestingName | This is NestingName, a member of class RenderedTuplePropertyDescriptor.
NullElementRepresentation | This is NullElementRepresentation, a member of class RenderedTuplePropertyDescriptor.
PropertyType | This is PropertyType, a member of class RenderedTuplePropertyDescriptor.


RenderedTuplePropertyDescriptor.AsExternalId Property

RenderedTuplePropertyDescriptor.AsExternalId Property
RenderedTuplePropertyDescriptor Class Eco.Handles Namespace See Also
Collapse All
C#
public bool AsExternalId;
Remarks

This is AsExternalId, a member of class RenderedTuplePropertyDescriptor.

See Also
RenderedTuplePropertyDescriptor Class
Eco.Handles Namespace


RenderedTuplePropertyDescriptor.ComponentType Property

RenderedTuplePropertyDescriptor.ComponentType Property
RenderedTuplePropertyDescriptor Class Eco.Handles Namespace See Also
Collapse All
C#
public override System.Type ComponentType;
Remarks

This is ComponentType, a member of class RenderedTuplePropertyDescriptor.

See Also
RenderedTuplePropertyDescriptor Class
Eco.Handles Namespace


RenderedTuplePropertyDescriptor.Expression Property

RenderedTuplePropertyDescriptor.Expression Property
RenderedTuplePropertyDescriptor Class Eco.Handles Namespace See Also
Collapse All
C#
public string Expression;
Remarks

This is Expression, a member of class RenderedTuplePropertyDescriptor.

See Also
RenderedTuplePropertyDescriptor Class
Eco.Handles Namespace


RenderedTuplePropertyDescriptor.IsEventDerived Property

RenderedTuplePropertyDescriptor.IsEventDerived Property
RenderedTuplePropertyDescriptor Class Eco.Handles Namespace See Also
Collapse All
C#
public bool IsEventDerived;
Remarks

This is IsEventDerived, a member of class RenderedTuplePropertyDescriptor.

See Also
RenderedTuplePropertyDescriptor Class
Eco.Handles Namespace


RenderedTuplePropertyDescriptor.IsNested Property

RenderedTuplePropertyDescriptor.IsNested Property
RenderedTuplePropertyDescriptor Class Eco.Handles Namespace See Also
Collapse All
C#
public bool IsNested;
Remarks

Nested descriptor

See Also
RenderedTuplePropertyDescriptor Class
Eco.Handles Namespace


RenderedTuplePropertyDescriptor.IsReadOnly Property

RenderedTuplePropertyDescriptor.IsReadOnly Property
RenderedTuplePropertyDescriptor Class Eco.Handles Namespace See Also
Collapse All
C#
public override bool IsReadOnly;
Remarks

This is IsReadOnly, a member of class RenderedTuplePropertyDescriptor.

See Also
RenderedTuplePropertyDescriptor Class
Eco.Handles Namespace


RenderedTuplePropertyDescriptor.NestingName Property

RenderedTuplePropertyDescriptor.NestingName Property
RenderedTuplePropertyDescriptor Class Eco.Handles Namespace See Also
Collapse All
C#
public string NestingName;
Remarks

This is NestingName, a member of class RenderedTuplePropertyDescriptor.

See Also
RenderedTuplePropertyDescriptor Class
Eco.Handles Namespace


RenderedTuplePropertyDescriptor.NullElementRepresentation Property

RenderedTuplePropertyDescriptor.NullElementRepresentation Property
RenderedTuplePropertyDescriptor Class Eco.Handles Namespace See Also
Collapse All
C#
public string NullElementRepresentation;
Remarks

This is NullElementRepresentation, a member of class RenderedTuplePropertyDescriptor.

See Also
RenderedTuplePropertyDescriptor Class
Eco.Handles Namespace


RenderedTuplePropertyDescriptor.PropertyType Property

RenderedTuplePropertyDescriptor.PropertyType Property
RenderedTuplePropertyDescriptor Class Eco.Handles Namespace See Also
Collapse All
C#
public override System.Type PropertyType;
Remarks

This is PropertyType, a member of class RenderedTuplePropertyDescriptor.

See Also
RenderedTuplePropertyDescriptor Class
Eco.Handles Namespace


RenderedTupleTestProperty Class

RenderedTupleTestProperty Class
Inheritance Hierarchy See Also
Collapse All
C#
public sealed class RenderedTupleTestProperty : AbstractRenderedTupleProperty;
Remarks

This is class Eco.Handles.RenderedTupleTestProperty.

Inheritance Hierarchy
Eco.Handles.AbstractRenderedTupleProperty
    Eco.Handles.RenderedTupleTestProperty
File

ControlPack.cs

See Also
Inheritance Hierarchy


RenderedTupleTestProperty.RenderedTupleTestProperty Constructor

RenderedTupleTestProperty.RenderedTupleTestProperty Constructor
RenderedTupleTestProperty Class Eco.Handles Namespace See Also
Collapse All
C#
public RenderedTupleTestProperty(
    RenderedTuplePropertyDescriptor descriptor,
    ITuplePropertyRenderingContext owner,
    int testData
);
Remarks

This is RenderedTupleTestProperty, a member of class RenderedTupleTestProperty.

See Also
RenderedTupleTestProperty Class
Eco.Handles Namespace


RenderedTupleTestProperty Methods

RenderedTupleTestProperty Methods
Protected Methods Public Methods
Collapse All

The methods of the RenderedTupleTestProperty class are listed here.

Protected Methods
Name | Description
DoGetValue | This is DoGetValue, a member of class RenderedTupleTestProperty.
Top
Public Methods
Name | Description
SetValue | This is SetValue, a member of class RenderedTupleTestProperty.


RenderedTupleTestProperty.DoGetValue Method

RenderedTupleTestProperty.DoGetValue Method
RenderedTupleTestProperty Class Eco.Handles Namespace See Also
Collapse All
C#
protected override object DoGetValue();
Remarks

This is DoGetValue, a member of class RenderedTupleTestProperty.

See Also
RenderedTupleTestProperty Class
Eco.Handles Namespace


RenderedTupleTestProperty.SetValue Method

RenderedTupleTestProperty.SetValue Method
RenderedTupleTestProperty Class Eco.Handles Namespace See Also
Collapse All
C#
public override void SetValue(
    object value
);
Remarks

This is SetValue, a member of class RenderedTupleTestProperty.

See Also
RenderedTupleTestProperty Class
Eco.Handles Namespace


ReverseDeriveEventArgs Class

ReverseDeriveEventArgs Class
Inheritance Hierarchy See Also
Collapse All
C#
public sealed class ReverseDeriveEventArgs : EventArgs;
Remarks

This is class Eco.Handles.ReverseDeriveEventArgs.

Inheritance Hierarchy
Eco.Handles.ReverseDeriveEventArgs
File

ControlPack.cs

See Also
Inheritance Hierarchy


ReverseDeriveEventArgs.ReverseDeriveEventArgs Constructor

ReverseDeriveEventArgs.ReverseDeriveEventArgs Constructor
ReverseDeriveEventArgs Class Eco.Handles Namespace See Also
Collapse All
C#
public ReverseDeriveEventArgs(
    string name,
    IEcoServiceProvider serviceProvider,
    IElement rootElement,
    IStaticContext staticContext,
    object value
);
Remarks

This is ReverseDeriveEventArgs, a member of class ReverseDeriveEventArgs.

See Also
ReverseDeriveEventArgs Class
Eco.Handles Namespace


ReverseDeriveEventArgs Properties

ReverseDeriveEventArgs Properties
Public Properties
Collapse All

The properties of the ReverseDeriveEventArgs class are listed here.

Public Properties
Name | Description
Name | This is Name, a member of class ReverseDeriveEventArgs.
OclService | This is OclService, a member of class ReverseDeriveEventArgs.
RootElement | This is RootElement, a member of class ReverseDeriveEventArgs.
ServiceProvider | This is ServiceProvider, a member of class ReverseDeriveEventArgs.
StaticContext | This is StaticContext, a member of class ReverseDeriveEventArgs.
Value | This is Value, a member of class ReverseDeriveEventArgs.


ReverseDeriveEventArgs.Name Property

ReverseDeriveEventArgs.Name Property
ReverseDeriveEventArgs Class Eco.Handles Namespace See Also
Collapse All
C#
public string Name;
Remarks

This is Name, a member of class ReverseDeriveEventArgs.

See Also
ReverseDeriveEventArgs Class
Eco.Handles Namespace


ReverseDeriveEventArgs.OclService Property

ReverseDeriveEventArgs.OclService Property
ReverseDeriveEventArgs Class Eco.Handles Namespace See Also
Collapse All
C#
public IOclService OclService;
Remarks

This is OclService, a member of class ReverseDeriveEventArgs.

See Also
ReverseDeriveEventArgs Class
Eco.Handles Namespace


ReverseDeriveEventArgs.RootElement Property

ReverseDeriveEventArgs.RootElement Property
ReverseDeriveEventArgs Class Eco.Handles Namespace See Also
Collapse All
C#
public IElement RootElement;
Remarks

This is RootElement, a member of class ReverseDeriveEventArgs.

See Also
ReverseDeriveEventArgs Class
Eco.Handles Namespace


ReverseDeriveEventArgs.ServiceProvider Property

ReverseDeriveEventArgs.ServiceProvider Property
ReverseDeriveEventArgs Class Eco.Handles Namespace See Also
Collapse All
C#
public IEcoServiceProvider ServiceProvider;
Remarks

This is ServiceProvider, a member of class ReverseDeriveEventArgs.

See Also
ReverseDeriveEventArgs Class
Eco.Handles Namespace


ReverseDeriveEventArgs.StaticContext Property

ReverseDeriveEventArgs.StaticContext Property
ReverseDeriveEventArgs Class Eco.Handles Namespace See Also
Collapse All
C#
public IStaticContext StaticContext;
Remarks

This is StaticContext, a member of class ReverseDeriveEventArgs.

See Also
ReverseDeriveEventArgs Class
Eco.Handles Namespace


ReverseDeriveEventArgs.Value Property

ReverseDeriveEventArgs.Value Property
ReverseDeriveEventArgs Class Eco.Handles Namespace See Also
Collapse All
C#
public object Value;
Remarks

This is Value, a member of class ReverseDeriveEventArgs.

See Also
ReverseDeriveEventArgs Class
Eco.Handles Namespace


RootedHandle Class

RootedHandle Class
Inheritance Hierarchy See Also
Collapse All

An ECO handle that depends upon an ElementHandle for its context.

C#
public abstract class RootedHandle : ElementHandle, IRooted;
Remarks

Unlike a Eco.Handles.RootHandle, a rooted handle does not hold a reference to an instance of an EcoSpace. Instead it depends upon its RootHandle to provide an instance of an EcoSpace and also a context on which to operate.

Inheritance Hierarchy
Eco.Handles.IElementHandle
Eco.Handles.INotifyOnIdle
    Eco.Handles.ElementHandle
    Eco.Handles.IRooted
        Eco.Handles.RootedHandle
            Eco.Handles.AbstractCursorHandle
            Eco.Handles.ExpressionHandle
            Eco.Handles.OclPSHandle
File

RootedHandle.cs

See Also
Inheritance Hierarchy


RootedHandle.RootedHandle Constructor

RootedHandle.RootedHandle Constructor
RootedHandle Class Eco.Handles Namespace See Also
Collapse All
C#
protected RootedHandle();
Remarks

This is RootedHandle, a member of class RootedHandle.

See Also
RootedHandle Class
Eco.Handles Namespace


RootedHandle Methods

RootedHandle Methods
Protected Methods Public Methods
Collapse All

The methods of the RootedHandle class are listed here.

Protected Methods
Name | Description
DeriveAndSubscribe | This is DeriveAndSubscribe, a member of class RootedHandle.
EffectiveEnabledChanged | This is EffectiveEnabledChanged, a member of class RootedHandle.
EffectiveRootValue | Returns the element of its RootHandle.
EffectiveVariables | This is EffectiveVariables, a member of class RootedHandle.
EnsureInternalElement | This is EnsureInternalElement, a member of class RootedHandle.
GetActionLanguageTypeService | This is GetActionLanguageTypeService, a member of class RootedHandle.
GetEcoService | This is the overview for the GetEcoService method overload.
GetOclPsTypeService | This is GetOclPsTypeService, a member of class RootedHandle.
GetOclTypeService | This is GetOclTypeService, a member of class RootedHandle.
GetTypeSystem | This is GetTypeSystem, a member of class RootedHandle.
MarkSubscriptionOutOfDate | This is MarkSubscriptionOutOfDate, a member of class RootedHandle.
StaticContextChanged | This is StaticContextChanged, a member of class RootedHandle.
SubscribeToDownstreamActive | This is SubscribeToDownstreamActive, a member of class RootedHandle.
Top
Public Methods
Name | Description
IsRootLinkedTo | Indicates whether or not this handle is directly or indirectly dependent upon the specified handle
RegisterEcoService | This is the overview for the RegisterEcoService method overload.
UsesVariables | This is UsesVariables, a member of class RootedHandle.


RootedHandle.DeriveAndSubscribe Method

RootedHandle.DeriveAndSubscribe Method
RootedHandle Class Eco.Handles Namespace See Also
Collapse All
C#
protected abstract void DeriveAndSubscribe(
    ISubscriber valueChangeSubscriber,
    ISubscriber resubscribeSubscriber
);
Remarks

This is DeriveAndSubscribe, a member of class RootedHandle.

See Also
RootedHandle Class
Eco.Handles Namespace


RootedHandle.EffectiveEnabledChanged Method

RootedHandle.EffectiveEnabledChanged Method
RootedHandle Class Eco.Handles Namespace See Also
Collapse All
C#
protected override void EffectiveEnabledChanged();
Remarks

This is EffectiveEnabledChanged, a member of class RootedHandle.

See Also
RootedHandle Class
Eco.Handles Namespace


RootedHandle.EffectiveRootValue Method

RootedHandle.EffectiveRootValue Method
RootedHandle Class Eco.Handles Namespace See Also
Collapse All

Returns the element of its RootHandle.

C#
protected IElement EffectiveRootValue();
See Also
RootedHandle Class
Eco.Handles Namespace


RootedHandle.EffectiveVariables Method

RootedHandle.EffectiveVariables Method
RootedHandle Class Eco.Handles Namespace See Also
Collapse All
C#
protected override IExternalVariableList EffectiveVariables();
Remarks

This is EffectiveVariables, a member of class RootedHandle.

See Also
RootedHandle Class
Eco.Handles Namespace


RootedHandle.EnsureInternalElement Method

RootedHandle.EnsureInternalElement Method
RootedHandle Class Eco.Handles Namespace See Also
Collapse All
C#
protected override void EnsureInternalElement();
Remarks

This is EnsureInternalElement, a member of class RootedHandle.

See Also
RootedHandle Class
Eco.Handles Namespace


RootedHandle.GetActionLanguageTypeService Method

RootedHandle.GetActionLanguageTypeService Method
RootedHandle Class Eco.Handles Namespace See Also
Collapse All
C#
protected sealed override IActionLanguageTypeService GetActionLanguageTypeService();
Remarks

This is GetActionLanguageTypeService, a member of class RootedHandle.

See Also
RootedHandle Class
Eco.Handles Namespace


GetEcoService Method

GetEcoService Method

This is the overview for the GetEcoService method overload.

Overload List
Name | Description
RootedHandle.GetEcoService (object) | This is GetEcoService, a member of class RootedHandle.
RootedHandle.GetEcoService (System.Type) | This is GetEcoService, a member of class RootedHandle.


RootedHandle.GetEcoService Method (System.Type)

RootedHandle.GetEcoService Method (System.Type)
RootedHandle Class Eco.Handles Namespace See Also
Collapse All
C#
protected sealed override object GetEcoService(
    System.Type serviceType
);
Remarks

This is GetEcoService, a member of class RootedHandle.

See Also
RootedHandle Class
Eco.Handles Namespace


RootedHandle.GetEcoService Method (object)

RootedHandle.GetEcoService Method (object)
RootedHandle Class Eco.Handles Namespace See Also
Collapse All
C#
protected sealed override T GetEcoService<T>(
    object key
);
Remarks

This is GetEcoService, a member of class RootedHandle.

See Also
RootedHandle Class
Eco.Handles Namespace


RootedHandle.GetOclPsTypeService Method

RootedHandle.GetOclPsTypeService Method
RootedHandle Class Eco.Handles Namespace See Also
Collapse All
C#
protected sealed override IOclPsTypeService GetOclPsTypeService();
Remarks

This is GetOclPsTypeService, a member of class RootedHandle.

See Also
RootedHandle Class
Eco.Handles Namespace


RootedHandle.GetOclTypeService Method

RootedHandle.GetOclTypeService Method
RootedHandle Class Eco.Handles Namespace See Also
Collapse All
C#
protected sealed override IOclTypeService GetOclTypeService();
Remarks

This is GetOclTypeService, a member of class RootedHandle.

See Also
RootedHandle Class
Eco.Handles Namespace


RootedHandle.GetTypeSystem Method

RootedHandle.GetTypeSystem Method
RootedHandle Class Eco.Handles Namespace See Also
Collapse All
C#
protected sealed override IEcoTypeSystem GetTypeSystem();
Remarks

This is GetTypeSystem, a member of class RootedHandle.

See Also
RootedHandle Class
Eco.Handles Namespace


RootedHandle.IsRootLinkedTo Method

RootedHandle.IsRootLinkedTo Method
RootedHandle Class Eco.Handles Namespace See Also
Collapse All

Indicates whether or not this handle is directly or indirectly dependent upon the specified handle

C#
public bool IsRootLinkedTo(
    IElementHandle handle
);
Parameters
Parameters | Description
handle | The handle to check for dependency.
Remarks

This is used internally to prevent circular references.

See Also
RootedHandle Class
Eco.Handles Namespace


RootedHandle.MarkSubscriptionOutOfDate Method

RootedHandle.MarkSubscriptionOutOfDate Method
RootedHandle Class Eco.Handles Namespace See Also
Collapse All
C#
protected void MarkSubscriptionOutOfDate();
Remarks

This is MarkSubscriptionOutOfDate, a member of class RootedHandle.

See Also
RootedHandle Class
Eco.Handles Namespace


RegisterEcoService Method

RegisterEcoService Method

This is the overview for the RegisterEcoService method overload.

Overload List
Name | Description
RootedHandle.RegisterEcoService (object, T) | This is RegisterEcoService, a member of class RootedHandle.
RootedHandle.RegisterEcoService (T) | This is RegisterEcoService, a member of class RootedHandle.


RootedHandle.RegisterEcoService Method (T)

RootedHandle.RegisterEcoService Method (T)
RootedHandle Class Eco.Handles Namespace See Also
Collapse All
C#
public override void RegisterEcoService<T>(
    T service
);
Remarks

This is RegisterEcoService, a member of class RootedHandle.

See Also
RootedHandle Class
Eco.Handles Namespace


RootedHandle.RegisterEcoService Method (object, T)

RootedHandle.RegisterEcoService Method (object, T)
RootedHandle Class Eco.Handles Namespace See Also
Collapse All
C#
public override void RegisterEcoService<T>(
    object key,
    T service
);
Remarks

This is RegisterEcoService, a member of class RootedHandle.

See Also
RootedHandle Class
Eco.Handles Namespace


RootedHandle.StaticContextChanged Method

RootedHandle.StaticContextChanged Method
RootedHandle Class Eco.Handles Namespace See Also
Collapse All
C#
protected override void StaticContextChanged();
Remarks

This is StaticContextChanged, a member of class RootedHandle.

See Also
RootedHandle Class
Eco.Handles Namespace


RootedHandle.SubscribeToDownstreamActive Method

RootedHandle.SubscribeToDownstreamActive Method
RootedHandle Class Eco.Handles Namespace See Also
Collapse All
C#
protected override void SubscribeToDownstreamActive(
    ISubscriber subscriber
);
Remarks

This is SubscribeToDownstreamActive, a member of class RootedHandle.

See Also
RootedHandle Class
Eco.Handles Namespace


RootedHandle.UsesVariables Method

RootedHandle.UsesVariables Method
RootedHandle Class Eco.Handles Namespace See Also
Collapse All
C#
public sealed override bool UsesVariables(
    IOclVariables variables
);
Remarks

This is UsesVariables, a member of class RootedHandle.

See Also
RootedHandle Class
Eco.Handles Namespace


RootedHandle Properties

RootedHandle Properties
Public Properties Protected Properties
Collapse All

The properties of the RootedHandle class are listed here.

Public Properties
Name | Description
AddRootVariables | Specifies whether or not this handle should also use the variables defined on its RootHandle
EffectiveEnabled | Indicates whether or not the handle is truely active.
RootHandle | Specifies which ECO handle should be used to determine a context, and also which EcoSpace instance to use.
Top
Protected Properties
Name | Description
EffectiveRootStaticContext | This is EffectiveRootStaticContext, a member of class RootedHandle.


RootedHandle.AddRootVariables Property

RootedHandle.AddRootVariables Property
RootedHandle Class Eco.Handles Namespace See Also
Collapse All

Specifies whether or not this handle should also use the variables defined on its RootHandle

C#
public bool AddRootVariables;
Remarks

If False then this handle will only register its own variables when evaluating OCL expressions. If True it will additionally register all variables known to its root handle. Specifying True will also pass on acquired variables to any rooted handles that also have this property set to True.

See Also
RootedHandle Class
Eco.Handles Namespace


RootedHandle.EffectiveEnabled Property

RootedHandle.EffectiveEnabled Property
RootedHandle Class Eco.Handles Namespace See Also
Collapse All

Indicates whether or not the handle is truely active.

C#
public override bool EffectiveEnabled;
Remarks

When a handle is EffectiveEnabled it is correctly connected to an active EcoSpace. For a RootHandle this is the case when its Active property is True. For a RootedHandle this is the case when its Active property is True and its RootHandle is also effectively enabled.

See Also
RootedHandle Class
Eco.Handles Namespace


RootedHandle.EffectiveRootStaticContext Property

RootedHandle.EffectiveRootStaticContext Property
RootedHandle Class Eco.Handles Namespace See Also
Collapse All
C#
protected IStaticContext EffectiveRootStaticContext;
Remarks

This is EffectiveRootStaticContext, a member of class RootedHandle.

See Also
RootedHandle Class
Eco.Handles Namespace


RootedHandle.RootHandle Property

RootedHandle.RootHandle Property
RootedHandle Class Eco.Handles Namespace See Also
Collapse All

Specifies which ECO handle should be used to determine a context, and also which EcoSpace instance to use.

C#
public ElementHandle RootHandle;
Exceptions
Exceptions | Description
EcoException | Thrown if a circular chain is created when setting the new roothandle.
See Also
RootedHandle Class
Eco.Handles Namespace


RootHandle Class

RootHandle Class
Inheritance Hierarchy See Also
Collapse All

An ECO handle component that does not depend upon another ECO handle for its context or EcoSpace reference.

C#
public abstract class RootHandle : ElementHandle, IHasTypeSystem;
Inheritance Hierarchy
Eco.Handles.IElementHandle
Eco.Handles.INotifyOnIdle
    Eco.Handles.ElementHandle
    Eco.Handles.IHasTypeSystem
        Eco.Handles.RootHandle
            Eco.Handles.ReferenceHandle
            Eco.Handles.VariableHandle
File

RootHandle.cs

See Also
Inheritance Hierarchy


RootHandle.RootHandle Constructor

RootHandle.RootHandle Constructor
RootHandle Class Eco.Handles Namespace See Also
Collapse All
C#
protected RootHandle();
Remarks

This is RootHandle, a member of class RootHandle.

See Also
RootHandle Class
Eco.Handles Namespace


RootHandle Methods

RootHandle Methods
Protected Methods Public Methods
Collapse All

The methods of the RootHandle class are listed here.

Protected Methods
Name | Description
Dispose | Disables the element handle and disposes it.
EffectiveEnabledChanged | This is EffectiveEnabledChanged, a member of class RootHandle.
EnsureConfigured | This is EnsureConfigured, a member of class RootHandle.
GetActionLanguageTypeService | Returns an instance of the Eco.Services.IActionLanguageTypeService for the handle's EcoSpace.
GetEcoService | This is the overview for the GetEcoService method overload.
GetOclPsTypeService | Returns an instance of the Eco.Services.IOclPsTypeService for the handle's EcoSpace.
GetOclTypeService | Returns an instance of the Eco.Services.IOclTypeService for the handle's EcoSpace.
GetStaticUmlType | Returns an ECO type that represents the IElement will hold at runtime.
GetTypeSystem | Returns an instance of the Eco.UmlRt.IEcoTypeSystem for the handle's EcoSpace.
SubscribeToDownstreamActive | Subscribes the the EcoSpace becoming active or inactive.
Top
Public Methods
Name | Description
RefreshTypeInfo | This is RefreshTypeInfo, a member of class RootHandle.
RegisterEcoService | This is the overview for the RegisterEcoService method overload.
UsesVariables | Indicates whether or not the handle uses the specified OCL variables.


RootHandle.Dispose Method

RootHandle.Dispose Method
RootHandle Class Eco.Handles Namespace See Also
Collapse All

Disables the element handle and disposes it.

C#
protected override void Dispose(
    bool disposing
);
See Also
RootHandle Class
Eco.Handles Namespace


RootHandle.EffectiveEnabledChanged Method

RootHandle.EffectiveEnabledChanged Method
RootHandle Class Eco.Handles Namespace See Also
Collapse All
C#
protected override void EffectiveEnabledChanged();
Remarks

This is EffectiveEnabledChanged, a member of class RootHandle.

See Also
RootHandle Class
Eco.Handles Namespace


RootHandle.EnsureConfigured Method

RootHandle.EnsureConfigured Method
RootHandle Class Eco.Handles Namespace See Also
Collapse All
C#
protected void EnsureConfigured();
Remarks

This is EnsureConfigured, a member of class RootHandle.

See Also
RootHandle Class
Eco.Handles Namespace


RootHandle.GetActionLanguageTypeService Method

RootHandle.GetActionLanguageTypeService Method
RootHandle Class Eco.Handles Namespace See Also
Collapse All

Returns an instance of the Eco.Services.IActionLanguageTypeService for the handle's EcoSpace.

C#
protected sealed override IActionLanguageTypeService GetActionLanguageTypeService();
See Also
RootHandle Class
Eco.Handles Namespace


GetEcoService Method

GetEcoService Method

This is the overview for the GetEcoService method overload.

Overload List
Name | Description
RootHandle.GetEcoService (object) | This is GetEcoService, a member of class RootHandle.
RootHandle.GetEcoService (System.Type) | Returns an ECO service of the specified type.


RootHandle.GetEcoService Method (System.Type)

RootHandle.GetEcoService Method (System.Type)
RootHandle Class Eco.Handles Namespace Related Topics See Also
Collapse All

Returns an ECO service of the specified type.

C#
protected sealed override object GetEcoService(
    System.Type serviceType
);
Parameters
Parameters | Description
serviceType | The .NET type of the service to return.
Returns

Returns an instance of a registered service, if the EcoSpace is not active then "null" will be returned.

Related Topics

Eco.Handles.DefaultEcoSpace.RegisterEcoService

See Also
RootHandle Class
Eco.Handles Namespace
Related Topics


RootHandle.GetEcoService Method (object)

RootHandle.GetEcoService Method (object)
RootHandle Class Eco.Handles Namespace See Also
Collapse All
C#
protected sealed override T GetEcoService<T>(
    object key
);
Remarks

This is GetEcoService, a member of class RootHandle.

See Also
RootHandle Class
Eco.Handles Namespace


RootHandle.GetOclPsTypeService Method

RootHandle.GetOclPsTypeService Method
RootHandle Class Eco.Handles Namespace See Also
Collapse All

Returns an instance of the Eco.Services.IOclPsTypeService for the handle's EcoSpace.

C#
protected sealed override IOclPsTypeService GetOclPsTypeService();
See Also
RootHandle Class
Eco.Handles Namespace


RootHandle.GetOclTypeService Method

RootHandle.GetOclTypeService Method
RootHandle Class Eco.Handles Namespace See Also
Collapse All

Returns an instance of the Eco.Services.IOclTypeService for the handle's EcoSpace.

C#
protected sealed override IOclTypeService GetOclTypeService();
See Also
RootHandle Class
Eco.Handles Namespace


RootHandle.GetStaticUmlType Method

RootHandle.GetStaticUmlType Method
RootHandle Class Eco.Handles Namespace See Also
Collapse All

Returns an ECO type that represents the IElement will hold at runtime.

C#
protected sealed override IClassifier GetStaticUmlType();
See Also
RootHandle Class
Eco.Handles Namespace


RootHandle.GetTypeSystem Method

RootHandle.GetTypeSystem Method
RootHandle Class Eco.Handles Namespace See Also
Collapse All

Returns an instance of the Eco.UmlRt.IEcoTypeSystem for the handle's EcoSpace.

C#
protected sealed override IEcoTypeSystem GetTypeSystem();
See Also
RootHandle Class
Eco.Handles Namespace


RootHandle.RefreshTypeInfo Method

RootHandle.RefreshTypeInfo Method
RootHandle Class Eco.Handles Namespace See Also
Collapse All
C#
public void RefreshTypeInfo();
Remarks

This is RefreshTypeInfo, a member of class RootHandle.

See Also
RootHandle Class
Eco.Handles Namespace


RegisterEcoService Method

RegisterEcoService Method

This is the overview for the RegisterEcoService method overload.

Overload List
Name | Description
RootHandle.RegisterEcoService (object, T) | This is RegisterEcoService, a member of class RootHandle.
RootHandle.RegisterEcoService (T) | This is RegisterEcoService, a member of class RootHandle.


RootHandle.RegisterEcoService Method (T)

RootHandle.RegisterEcoService Method (T)
RootHandle Class Eco.Handles Namespace See Also
Collapse All
C#
public override void RegisterEcoService<T>(
    T service
);
Remarks

This is RegisterEcoService, a member of class RootHandle.

See Also
RootHandle Class
Eco.Handles Namespace


RootHandle.RegisterEcoService Method (object, T)

RootHandle.RegisterEcoService Method (object, T)
RootHandle Class Eco.Handles Namespace See Also
Collapse All
C#
public override void RegisterEcoService<T>(
    object key,
    T service
);
Remarks

This is RegisterEcoService, a member of class RootHandle.

See Also
RootHandle Class
Eco.Handles Namespace


RootHandle.SubscribeToDownstreamActive Method

RootHandle.SubscribeToDownstreamActive Method
RootHandle Class Eco.Handles Namespace See Also
Collapse All

Subscribes the the EcoSpace becoming active or inactive.

C#
protected override void SubscribeToDownstreamActive(
    ISubscriber subscriber
);
Parameters
Parameters | Description
subscriber | The subscriber to notify.
See Also
RootHandle Class
Eco.Handles Namespace


RootHandle.UsesVariables Method

RootHandle.UsesVariables Method
RootHandle Class Eco.Handles Namespace See Also
Collapse All

Indicates whether or not the handle uses the specified OCL variables.

C#
public sealed override bool UsesVariables(
    IOclVariables variables
);
Parameters
Parameters | Description
variables | The variable list to check.
See Also
RootHandle Class
Eco.Handles Namespace


RootHandle Properties

RootHandle Properties
Public Properties
Collapse All

The properties of the RootHandle class are listed here.

Public Properties
Name | Description
EcoSpace | The EcoSpace to which the RootHandle is connected.
EcoSpaceType | Specifies the .NET type of the EcoSpace used by this handle.
EcoSpaceTypeName | Specifies the .NET type of the EcoSpace used by this handle.
EffectiveEnabled | Indicates whether or not the EcoSpace is active and correctly configured for use.
StaticValueTypeName | Identifies the data type from the model that the handle will hold in its IElement property.


RootHandle.EcoSpace Property

RootHandle.EcoSpace Property
RootHandle Class Eco.Handles Namespace See Also
Collapse All

The EcoSpace to which the RootHandle is connected.

C#
public EcoSpace EcoSpace;
Remarks

A RootHandle does not depend upon another handle for its context or link to an EcoSpace. This property must be set at runtime in order for the handle to operate correctly.

See Also
RootHandle Class
Eco.Handles Namespace


RootHandle.EcoSpaceType Property

RootHandle.EcoSpaceType Property
RootHandle Class Eco.Handles Namespace Related Topics See Also
Collapse All

Specifies the .NET type of the EcoSpace used by this handle.

C#
public System.Type EcoSpaceType;
Related Topics

EcoSpaceTypeName

See Also
RootHandle Class
Eco.Handles Namespace
Related Topics


RootHandle.EcoSpaceTypeName Property

RootHandle.EcoSpaceTypeName Property
RootHandle Class Eco.Handles Namespace See Also
Collapse All

Specifies the .NET type of the EcoSpace used by this handle.

C#
public string EcoSpaceTypeName;
Remarks

A single application may contain multiple EcoSpace classes, each consuming different UML models. This property is used to identify the type of the EcoSpace to which the handle will connect at runtime. Using this information the ECO designers are able to use .NET reflection on the EcoSpace class to determine which UML packages are in use, what UML classes are defined within the packages, and so on. This information is then used at design time to provide design time support for the model for designers such as the OCL editor.

See Also
RootHandle Class
Eco.Handles Namespace


RootHandle.EffectiveEnabled Property

RootHandle.EffectiveEnabled Property
RootHandle Class Eco.Handles Namespace See Also
Collapse All

Indicates whether or not the EcoSpace is active and correctly configured for use.

C#
public override bool EffectiveEnabled;
Remarks

The handle is considered to be "effectively enabled" if the following criteria is met:

  • ElementHandle.Enabled is True.
  • EcoSpace is not "null".
  • EcoSpace.Active is True.
See Also
RootHandle Class
Eco.Handles Namespace


RootHandle.StaticValueTypeName Property

RootHandle.StaticValueTypeName Property
RootHandle Class Eco.Handles Namespace See Also
Collapse All

Identifies the data type from the model that the handle will hold in its IElement property.

C#
public string StaticValueTypeName;
Remarks

This type is used at design time for support in the OCL editor, and at runtime for determining the available properties for the data binding if the Element is not set.

See Also
RootHandle Class
Eco.Handles Namespace


TupleContext Class

TupleContext Class
Inheritance Hierarchy See Also
Collapse All
C#
public sealed class TupleContext : ITupleRenderingContext;
Remarks

This is class Eco.Handles.TupleContext.

Inheritance Hierarchy
Eco.Handles.IRenderingContext
    Eco.Handles.ITupleRenderingContext
        Eco.Handles.TupleContext
File

ControlPack.cs

See Also
Inheritance Hierarchy


TupleContext.TupleContext Constructor

TupleContext.TupleContext Constructor
TupleContext Class Eco.Handles Namespace See Also
Collapse All
C#
public TupleContext(
    ITupleRenderingContext owner
);
Remarks

This is TupleContext, a member of class TupleContext.

See Also
TupleContext Class
Eco.Handles Namespace


TupleContext Properties

TupleContext Properties
Public Properties
Collapse All

The properties of the TupleContext class are listed here.

Public Properties
Name | Description
TupleDescriptor | This is TupleDescriptor, a member of class TupleContext.


TupleContext.TupleDescriptor Property

TupleContext.TupleDescriptor Property
TupleContext Class Eco.Handles Namespace See Also
Collapse All
C#
public RenderedTupleDescriptor TupleDescriptor;
Remarks

This is TupleDescriptor, a member of class TupleContext.

See Also
TupleContext Class
Eco.Handles Namespace


VariableHandle Class

VariableHandle Class
Inheritance Hierarchy See Also
Collapse All

Handle for a Eco Variable, i.e. for an Element that is not part of an EcoSpace.

C#
public sealed class VariableHandle : RootHandle;
Remarks

A VariableHandle is used to hold a value that is not part of an EcoSpace. The value can be either a primitive, such as a string or an integer, an reference to an object, or a list of objects. The type is set by setting the RootHandle.StaticValueTypeName property.

A common use is to define a Ocl variable using a OclVariables, with a value that can be set via databinding. As for all RootHandles, the EcoSpace property must be set, usually in the constructor for the form. The initial value of the variable must also be set. For example (for a VariableHandle holding a string):

Copy Code
 public WinForm()
{
 //...
 rhRoot.EcoSpace = m_EcoSpace;
 RootHandle1.EcoSpace = m_EcoSpace;
 RootHandle1.Element.AsObject = "";
 //...
}
Inheritance Hierarchy
Eco.Handles.IElementHandle
Eco.Handles.INotifyOnIdle
    Eco.Handles.ElementHandle
    Eco.Handles.IHasTypeSystem
        Eco.Handles.RootHandle
            Eco.Handles.VariableHandle
File

VariableHandle.cs

See Also
Inheritance Hierarchy


VariableHandle Methods

VariableHandle Methods
Protected Methods Public Methods
Collapse All

The methods of the VariableHandle class are listed here.

Protected Methods
Name | Description
EffectiveEnabledChanged | This is EffectiveEnabledChanged, a member of class VariableHandle.
EnsureInternalElement | This is EnsureInternalElement, a member of class VariableHandle.
StaticContextChanged | This is StaticContextChanged, a member of class VariableHandle.
Top
Public Methods
Name | Description
SetElementValue | This is SetElementValue, a member of class VariableHandle.


VariableHandle.EffectiveEnabledChanged Method

VariableHandle.EffectiveEnabledChanged Method
VariableHandle Class Eco.Handles Namespace See Also
Collapse All
C#
protected override void EffectiveEnabledChanged();
Remarks

This is EffectiveEnabledChanged, a member of class VariableHandle.

See Also
VariableHandle Class
Eco.Handles Namespace


VariableHandle.EnsureInternalElement Method

VariableHandle.EnsureInternalElement Method
VariableHandle Class Eco.Handles Namespace See Also
Collapse All
C#
protected override void EnsureInternalElement();
Remarks

This is EnsureInternalElement, a member of class VariableHandle.

See Also
VariableHandle Class
Eco.Handles Namespace


VariableHandle.SetElementValue Method

VariableHandle.SetElementValue Method
VariableHandle Class Eco.Handles Namespace See Also
Collapse All
C#
public void SetElementValue<T>(
    T value
);
Remarks

This is SetElementValue, a member of class VariableHandle.

See Also
VariableHandle Class
Eco.Handles Namespace


VariableHandle.StaticContextChanged Method

VariableHandle.StaticContextChanged Method
VariableHandle Class Eco.Handles Namespace See Also
Collapse All
C#
protected override void StaticContextChanged();
Remarks

This is StaticContextChanged, a member of class VariableHandle.

See Also
VariableHandle Class
Eco.Handles Namespace


VariableHandle Properties

VariableHandle Properties
Public Properties
Collapse All

The properties of the VariableHandle class are listed here.

Public Properties
Name | Description
InitialValues | Initializes the element of the handle


VariableHandle.InitialValues Property

VariableHandle.InitialValues Property
VariableHandle Class Eco.Handles Namespace See Also
Collapse All

Initializes the element of the handle

C#
public string InitialValues;
Remarks

The value will be converted to the relevant type of the handle RootHandle.StaticValueTypeName. If the type is a collection type, the elements must be separated by line breaks.

See Also
VariableHandle Class
Eco.Handles Namespace


IColumn Interface

IColumn Interface
Inheritance Hierarchy See Also
Collapse All
C#
public interface IColumn;
Remarks

This is class Eco.Handles.IColumn.

Inheritance Hierarchy
Eco.Handles.IColumn
    Eco.Handles.AbstractColumn
File

HandleInterfaces.cs

See Also
Inheritance Hierarchy


IColumn Properties

IColumn Properties
Public Properties
Collapse All

The properties of the IColumn class are listed here.

Public Properties
Name | Description
AsExternalId | This is AsExternalId, a member of class IColumn.
Expression | This is Expression, a member of class IColumn.
IsEventDerived | This is IsEventDerived, a member of class IColumn.
IsNested | This is IsNested, a member of class IColumn.
IsReadOnly | This is IsReadOnly, a member of class IColumn.
Name | This is Name, a member of class IColumn.
NestingName | This is NestingName, a member of class IColumn.
NullElementRepresentation | This is NullElementRepresentation, a member of class IColumn.
TypeName | This is TypeName, a member of class IColumn.


IColumn.AsExternalId Property

IColumn.AsExternalId Property
IColumn Interface Eco.Handles Namespace See Also
Collapse All
C#
bool AsExternalId;
Remarks

This is AsExternalId, a member of class IColumn.

See Also
IColumn Interface
Eco.Handles Namespace


IColumn.Expression Property

IColumn.Expression Property
IColumn Interface Eco.Handles Namespace See Also
Collapse All
C#
string Expression;
Remarks

This is Expression, a member of class IColumn.

See Also
IColumn Interface
Eco.Handles Namespace


IColumn.IsEventDerived Property

IColumn.IsEventDerived Property
IColumn Interface Eco.Handles Namespace See Also
Collapse All
C#
bool IsEventDerived;
Remarks

This is IsEventDerived, a member of class IColumn.

See Also
IColumn Interface
Eco.Handles Namespace


IColumn.IsNested Property

IColumn.IsNested Property
IColumn Interface Eco.Handles Namespace See Also
Collapse All
C#
bool IsNested;
Remarks

This is IsNested, a member of class IColumn.

See Also
IColumn Interface
Eco.Handles Namespace


IColumn.IsReadOnly Property

IColumn.IsReadOnly Property
IColumn Interface Eco.Handles Namespace See Also
Collapse All
C#
bool IsReadOnly;
Remarks

This is IsReadOnly, a member of class IColumn.

See Also
IColumn Interface
Eco.Handles Namespace


IColumn.Name Property

IColumn.Name Property
IColumn Interface Eco.Handles Namespace See Also
Collapse All
C#
string Name;
Remarks

This is Name, a member of class IColumn.

See Also
IColumn Interface
Eco.Handles Namespace


IColumn.NestingName Property

IColumn.NestingName Property
IColumn Interface Eco.Handles Namespace See Also
Collapse All
C#
string NestingName;
Remarks

This is NestingName, a member of class IColumn.

See Also
IColumn Interface
Eco.Handles Namespace


IColumn.NullElementRepresentation Property

IColumn.NullElementRepresentation Property
IColumn Interface Eco.Handles Namespace See Also
Collapse All
C#
string NullElementRepresentation;
Remarks

This is NullElementRepresentation, a member of class IColumn.

See Also
IColumn Interface
Eco.Handles Namespace


IColumn.TypeName Property

IColumn.TypeName Property
IColumn Interface Eco.Handles Namespace See Also
Collapse All
C#
string TypeName;
Remarks

This is TypeName, a member of class IColumn.

See Also
IColumn Interface
Eco.Handles Namespace


IEcoSpaceTypeLookupService Interface

IEcoSpaceTypeLookupService Interface
Inheritance Hierarchy See Also
Collapse All

For internal use. Adds IDE specific methods of looking up EcoSpace types in design time.

C#
public interface IEcoSpaceTypeLookupService;
Remarks

See EcoSpace.EcoSpaceTypeLookupService

Inheritance Hierarchy
Eco.Handles.IEcoSpaceTypeLookupService
File

DefaultEcoSpace.cs

See Also
Inheritance Hierarchy


IEcoSpaceTypeLookupService Methods

IEcoSpaceTypeLookupService Methods
Public Methods
Collapse All

The methods of the IEcoSpaceTypeLookupService class are listed here.

Public Methods
Name | Description
GetEcoSpaceType | For internal use. Adds IDE specific methods of looking up EcoSpace types in design time.


IEcoSpaceTypeLookupService.GetEcoSpaceType Method

IEcoSpaceTypeLookupService.GetEcoSpaceType Method
IEcoSpaceTypeLookupService Interface Eco.Handles Namespace See Also
Collapse All

For internal use. Adds IDE specific methods of looking up EcoSpace types in design time.

C#
System.Type GetEcoSpaceType(
    string name
);
Remarks

See EcoSpace.EcoSpaceTypeLookupService

See Also
IEcoSpaceTypeLookupService Interface
Eco.Handles Namespace


IElementHandle Interface

IElementHandle Interface
Inheritance Hierarchy See Also
Collapse All
C#
public interface IElementHandle : ISubscribableElementProvider, IStaticContext, IEcoServiceProvider;
Remarks

This is class Eco.Handles.IElementHandle.

Inheritance Hierarchy
Eco.Handles.IElementHandle
    Eco.Handles.ElementHandle
File

HandleInterfaces.cs

See Also
Inheritance Hierarchy


IElementHandle Methods

IElementHandle Methods
Public Methods
Collapse All

The methods of the IElementHandle class are listed here.

Public Methods
Name | Description
SubscribeToEffectiveEnabled | This is SubscribeToEffectiveEnabled, a member of class IElementHandle.
SubscribeToStaticContext | This is SubscribeToStaticContext, a member of class IElementHandle.
UsesVariables | This is UsesVariables, a member of class IElementHandle.


IElementHandle.SubscribeToEffectiveEnabled Method

IElementHandle.SubscribeToEffectiveEnabled Method
IElementHandle Interface Eco.Handles Namespace See Also
Collapse All
C#
void SubscribeToEffectiveEnabled(
    ISubscriber subscriber
);
Remarks

This is SubscribeToEffectiveEnabled, a member of class IElementHandle.

See Also
IElementHandle Interface
Eco.Handles Namespace


IElementHandle.SubscribeToStaticContext Method

IElementHandle.SubscribeToStaticContext Method
IElementHandle Interface Eco.Handles Namespace See Also
Collapse All
C#
void SubscribeToStaticContext(
    ISubscriber subscriber
);
Remarks

This is SubscribeToStaticContext, a member of class IElementHandle.

See Also
IElementHandle Interface
Eco.Handles Namespace


IElementHandle.UsesVariables Method

IElementHandle.UsesVariables Method
IElementHandle Interface Eco.Handles Namespace See Also
Collapse All
C#
bool UsesVariables(
    IOclVariables variables
);
Remarks

This is UsesVariables, a member of class IElementHandle.

See Also
IElementHandle Interface
Eco.Handles Namespace


IElementHandle Properties

IElementHandle Properties
Public Properties
Collapse All

The properties of the IElementHandle class are listed here.

Public Properties
Name | Description
EffectiveEnabled | This is EffectiveEnabled, a member of class IElementHandle.


IElementHandle.EffectiveEnabled Property

IElementHandle.EffectiveEnabled Property
IElementHandle Interface Eco.Handles Namespace See Also
Collapse All
C#
bool EffectiveEnabled;
Remarks

This is EffectiveEnabled, a member of class IElementHandle.

See Also
IElementHandle Interface
Eco.Handles Namespace


IHasEditableExpression Interface

IHasEditableExpression Interface
Inheritance Hierarchy See Also
Collapse All

Interface implemented by classes that hold a editable OCL expression.

Mainly for internal use.

C#
public interface IHasEditableExpression;
Inheritance Hierarchy
Eco.Handles.IHasEditableExpression
    Eco.Handles.ExpressionHandle
    Eco.Handles.OclColumn
    Eco.Handles.OclPSHandle
File

HasEditableExpression.cs

See Also
Inheritance Hierarchy


IHasEditableExpression Properties

IHasEditableExpression Properties
Public Properties
Collapse All

The properties of the IHasEditableExpression class are listed here.

Public Properties
Name | Description
ExpectedType | The expected returntype of the expression (for validation purposes).
Expression | The expression to be edited.
ExpressionKind | The kind of expression to be edited.
StaticContext | Static context used for the OCL expression editor.


IHasEditableExpression.ExpectedType Property

IHasEditableExpression.ExpectedType Property
IHasEditableExpression Interface Eco.Handles Namespace See Also
Collapse All

The expected returntype of the expression (for validation purposes).

C#
IClassifier ExpectedType;
Remarks

Mainly for internal/design time use.

If no type in particular is required, this property can return null.

See Also
IHasEditableExpression Interface
Eco.Handles Namespace


IHasEditableExpression.Expression Property

IHasEditableExpression.Expression Property
IHasEditableExpression Interface Eco.Handles Namespace See Also
Collapse All

The expression to be edited.

C#
string Expression;
Remarks

Mainly for internal/design time use.

See Also
IHasEditableExpression Interface
Eco.Handles Namespace


IHasEditableExpression.ExpressionKind Property

IHasEditableExpression.ExpressionKind Property
IHasEditableExpression Interface Eco.Handles Namespace See Also
Collapse All

The kind of expression to be edited.

C#
ExpressionKind ExpressionKind;
Remarks

Mainly for internal/design time use.

See Also
IHasEditableExpression Interface
Eco.Handles Namespace


IHasEditableExpression.StaticContext Property

IHasEditableExpression.StaticContext Property
IHasEditableExpression Interface Eco.Handles Namespace See Also
Collapse All

Static context used for the OCL expression editor.

C#
IStaticContext StaticContext;
Remarks

Mainly for internal use.

See Also
IHasEditableExpression Interface
Eco.Handles Namespace


IHasSecondEditableExpression Interface

IHasSecondEditableExpression Interface
Inheritance Hierarchy See Also
Collapse All

Interface implemented by classes that hold a second editable OCL expression.

Mainly for internal use.

C#
public interface IHasSecondEditableExpression;
Inheritance Hierarchy
Eco.Handles.IHasSecondEditableExpression
File

HasEditableExpression.cs

See Also
Inheritance Hierarchy


IHasSecondEditableExpression Properties

IHasSecondEditableExpression Properties
Public Properties
Collapse All

The properties of the IHasSecondEditableExpression class are listed here.

Public Properties
Name | Description
HasEditableExpression | This is HasEditableExpression, a member of class IHasSecondEditableExpression.


IHasSecondEditableExpression.HasEditableExpression Property

IHasSecondEditableExpression.HasEditableExpression Property
IHasSecondEditableExpression Interface Eco.Handles Namespace See Also
Collapse All
C#
IHasEditableExpression HasEditableExpression;
Remarks

This is HasEditableExpression, a member of class IHasSecondEditableExpression.

See Also
IHasSecondEditableExpression Interface
Eco.Handles Namespace


IHasTypeSystem Interface

IHasTypeSystem Interface
Inheritance Hierarchy See Also
Collapse All

Interface implemented by classes that can supply typesystem to designers.

Mainly for internal use

C#
public interface IHasTypeSystem;
Inheritance Hierarchy
Eco.Handles.IHasTypeSystem
    Eco.Handles.EventDerivedColumn
    Eco.Handles.Nesting
    Eco.Handles.RootHandle
File

HasEditableExpression.cs

See Also
Inheritance Hierarchy


IHasTypeSystem Properties

IHasTypeSystem Properties
Public Properties
Collapse All

The properties of the IHasTypeSystem class are listed here.

Public Properties
Name | Description
IsHookedUp | Returns true if the premises for returning a TypeSystem are fulfilled.
TypeSystem | Type system for the editor to show type names from. Mainly for internal/design time use


IHasTypeSystem.IsHookedUp Property

IHasTypeSystem.IsHookedUp Property
IHasTypeSystem Interface Eco.Handles Namespace See Also
Collapse All

Returns true if the premises for returning a TypeSystem are fulfilled.

C#
bool IsHookedUp;
See Also
IHasTypeSystem Interface
Eco.Handles Namespace


IHasTypeSystem.TypeSystem Property

IHasTypeSystem.TypeSystem Property
IHasTypeSystem Interface Eco.Handles Namespace See Also
Collapse All

Type system for the editor to show type names from.

Mainly for internal/design time use

C#
IEcoTypeSystem TypeSystem;
See Also
IHasTypeSystem Interface
Eco.Handles Namespace


IMaxLengthSupportProvider Interface

IMaxLengthSupportProvider Interface
Inheritance Hierarchy See Also
Collapse All
C#
public interface IMaxLengthSupportProvider;
Remarks

This is class Eco.Handles.IMaxLengthSupportProvider.

Inheritance Hierarchy
Eco.Handles.IMaxLengthSupportProvider
File

MaxLengthSupportFunctions.cs

See Also
Inheritance Hierarchy


IMaxLengthSupportProvider Methods

IMaxLengthSupportProvider Methods
Public Methods
Collapse All

The methods of the IMaxLengthSupportProvider class are listed here.

Public Methods
Name | Description
SetMaxLength | This is SetMaxLength, a member of class IMaxLengthSupportProvider.


IMaxLengthSupportProvider.SetMaxLength Method

IMaxLengthSupportProvider.SetMaxLength Method
IMaxLengthSupportProvider Interface Eco.Handles Namespace See Also
Collapse All
C#
void SetMaxLength(
    object obj
);
Remarks

This is SetMaxLength, a member of class IMaxLengthSupportProvider.

See Also
IMaxLengthSupportProvider Interface
Eco.Handles Namespace


INesting Interface

INesting Interface
Inheritance Hierarchy See Also
Collapse All
C#
public interface INesting;
Remarks

This is class Eco.Handles.INesting.

Inheritance Hierarchy
Eco.Handles.INesting
    Eco.Handles.Nesting
File

HandleInterfaces.cs

See Also
Inheritance Hierarchy


INesting Properties

INesting Properties
Public Properties
Collapse All

The properties of the INesting class are listed here.

Public Properties
Name | Description
AddDefaultNestings | This is AddDefaultNestings, a member of class INesting.
AddDefaultProperties | This is AddDefaultProperties, a member of class INesting.
Columns | This is Columns, a member of class INesting.
NullRowMode | This is NullRowMode, a member of class INesting.


INesting.AddDefaultNestings Property

INesting.AddDefaultNestings Property
INesting Interface Eco.Handles Namespace See Also
Collapse All
C#
bool AddDefaultNestings;
Remarks

This is AddDefaultNestings, a member of class INesting.

See Also
INesting Interface
Eco.Handles Namespace


INesting.AddDefaultProperties Property

INesting.AddDefaultProperties Property
INesting Interface Eco.Handles Namespace See Also
Collapse All
C#
bool AddDefaultProperties;
Remarks

This is AddDefaultProperties, a member of class INesting.

See Also
INesting Interface
Eco.Handles Namespace


INesting.Columns Property

INesting.Columns Property
INesting Interface Eco.Handles Namespace See Also
Collapse All
C#
IEnumerable Columns;
Remarks

This is Columns, a member of class INesting.

See Also
INesting Interface
Eco.Handles Namespace


INesting.NullRowMode Property

INesting.NullRowMode Property
INesting Interface Eco.Handles Namespace See Also
Collapse All
C#
NullRowMode NullRowMode;
Remarks

This is NullRowMode, a member of class INesting.

See Also
INesting Interface
Eco.Handles Namespace


INestingProvider Interface

INestingProvider Interface
Inheritance Hierarchy See Also
Collapse All
C#
public interface INestingProvider;
Remarks

This is class Eco.Handles.INestingProvider.

Inheritance Hierarchy
Eco.Handles.INestingProvider
    Eco.Handles.NestingCollection
File

HandleInterfaces.cs

See Also
Inheritance Hierarchy


INestingProvider Methods

INestingProvider Methods
Public Methods
Collapse All

The methods of the INestingProvider class are listed here.

Public Methods
Name | Description
this | This is this, a member of class INestingProvider.


INestingProvider.this Indexer

INestingProvider.this Indexer
INestingProvider Interface Eco.Handles Namespace See Also
Collapse All
C#
INesting this[
    string name
];
Remarks

This is this, a member of class INestingProvider.

See Also
INestingProvider Interface
Eco.Handles Namespace


INotifyOnIdle Interface

INotifyOnIdle Interface
Inheritance Hierarchy See Also
Collapse All

This interface is part of the internal implementation of the databindable IList implemented by the Eco handles. It should not be used directly.

C#
public interface INotifyOnIdle;
Inheritance Hierarchy
Eco.Handles.INotifyOnIdle
    Eco.Handles.ElementHandle
    Eco.Handles.HandleAdapter
File

ControlPack.cs

See Also
Inheritance Hierarchy


INotifyOnIdle Methods

INotifyOnIdle Methods
Public Methods
Collapse All

The methods of the INotifyOnIdle class are listed here.

Public Methods
Name | Description
NotifyOnIdle | This is NotifyOnIdle, a member of class INotifyOnIdle.


INotifyOnIdle.NotifyOnIdle Method

INotifyOnIdle.NotifyOnIdle Method
INotifyOnIdle Interface Eco.Handles Namespace See Also
Collapse All
C#
void NotifyOnIdle();
Remarks

This is NotifyOnIdle, a member of class INotifyOnIdle.

See Also
INotifyOnIdle Interface
Eco.Handles Namespace


IOclVariables Interface

IOclVariables Interface
Inheritance Hierarchy See Also
Collapse All
C#
public interface IOclVariables;
Remarks

This is class Eco.Handles.IOclVariables.

Inheritance Hierarchy
Eco.Handles.IOclVariables
    Eco.Handles.OclVariables
File

HandleInterfaces.cs

See Also
Inheritance Hierarchy


IOclVariables Properties

IOclVariables Properties
Public Properties
Collapse All

The properties of the IOclVariables class are listed here.

Public Properties
Name | Description
VariableList | This is VariableList, a member of class IOclVariables.


IOclVariables.VariableList Property

IOclVariables.VariableList Property
IOclVariables Interface Eco.Handles Namespace See Also
Collapse All
C#
IExternalVariableList VariableList;
Remarks

This is VariableList, a member of class IOclVariables.

See Also
IOclVariables Interface
Eco.Handles Namespace


IRenderingContext Interface

IRenderingContext Interface
Inheritance Hierarchy See Also
Collapse All

This interface is part of the internal implementation of the databindable IList implemented by the Eco handles. It should not be used directly.

C#
public interface IRenderingContext;
Inheritance Hierarchy
Eco.Handles.IRenderingContext
    Eco.Handles.ITuplePropertyRenderingContext
    Eco.Handles.ITupleRenderingContext
File

ControlPack.cs

See Also
Inheritance Hierarchy


IRenderingContext Properties

IRenderingContext Properties
Public Properties
Collapse All

The properties of the IRenderingContext class are listed here.

Public Properties
Name | Description
ServiceProvider | This is ServiceProvider, a member of class IRenderingContext.


IRenderingContext.ServiceProvider Property

IRenderingContext.ServiceProvider Property
IRenderingContext Interface Eco.Handles Namespace See Also
Collapse All
C#
IEcoServiceProvider ServiceProvider;
Remarks

This is ServiceProvider, a member of class IRenderingContext.

See Also
IRenderingContext Interface
Eco.Handles Namespace


IReorderableList Interface

IReorderableList Interface
Inheritance Hierarchy See Also
Collapse All
C#
public interface IReorderableList;
Remarks

This is class Eco.Handles.IReorderableList.

Inheritance Hierarchy
Eco.Handles.IReorderableList
    Eco.Handles.RenderedList
File

ControlPack.cs

See Also
Inheritance Hierarchy


IReorderableList Methods

IReorderableList Methods
Public Methods
Collapse All

The methods of the IReorderableList class are listed here.

Public Methods
Name | Description
Move | This is Move, a member of class IReorderableList.


IReorderableList.Move Method

IReorderableList.Move Method
IReorderableList Interface Eco.Handles Namespace See Also
Collapse All
C#
void Move(
    int from,
    int to
);
Remarks

This is Move, a member of class IReorderableList.

See Also
IReorderableList Interface
Eco.Handles Namespace


IReorderableList Properties

IReorderableList Properties
Public Properties
Collapse All

The properties of the IReorderableList class are listed here.

Public Properties
Name | Description
SupportsMove | This is SupportsMove, a member of class IReorderableList.


IReorderableList.SupportsMove Property

IReorderableList.SupportsMove Property
IReorderableList Interface Eco.Handles Namespace See Also
Collapse All
C#
bool SupportsMove;
Remarks

This is SupportsMove, a member of class IReorderableList.

See Also
IReorderableList Interface
Eco.Handles Namespace


IRooted Interface

IRooted Interface
Inheritance Hierarchy See Also
Collapse All
C#
public interface IRooted;
Remarks

This is class Eco.Handles.IRooted.

Inheritance Hierarchy
Eco.Handles.IRooted
    Eco.Handles.RootedHandle
File

HandleInterfaces.cs

See Also
Inheritance Hierarchy


IRooted Methods

IRooted Methods
Public Methods
Collapse All

The methods of the IRooted class are listed here.

Public Methods
Name | Description
IsRootLinkedTo | This is IsRootLinkedTo, a member of class IRooted.


IRooted.IsRootLinkedTo Method

IRooted.IsRootLinkedTo Method
IRooted Interface Eco.Handles Namespace See Also
Collapse All
C#
bool IsRootLinkedTo(
    IElementHandle handle
);
Remarks

This is IsRootLinkedTo, a member of class IRooted.

See Also
IRooted Interface
Eco.Handles Namespace


IStaticContextFromObject Interface

IStaticContextFromObject Interface
Inheritance Hierarchy See Also
Collapse All

Interface implemented by classes that can return an IStaticContext indexed on an object.

Mainly for internal use

C#
public interface IStaticContextFromObject;
Inheritance Hierarchy
Eco.Handles.IStaticContextFromObject
File

HasEditableExpression.cs

See Also
Inheritance Hierarchy


IStaticContextFromObject Methods

IStaticContextFromObject Methods
Public Methods
Collapse All

The methods of the IStaticContextFromObject class are listed here.

Public Methods
Name | Description
GetExpectedType | This is GetExpectedType, a member of class IStaticContextFromObject.
StaticContextForObject | This is StaticContextForObject, a member of class IStaticContextFromObject.


IStaticContextFromObject.GetExpectedType Method

IStaticContextFromObject.GetExpectedType Method
IStaticContextFromObject Interface Eco.Handles Namespace See Also
Collapse All
C#
IClassifier GetExpectedType(
    ExtenderProvidedPropertyAttribute prop,
    IStaticContext context
);
Remarks

This is GetExpectedType, a member of class IStaticContextFromObject.

See Also
IStaticContextFromObject Interface
Eco.Handles Namespace


IStaticContextFromObject.StaticContextForObject Method

IStaticContextFromObject.StaticContextForObject Method
IStaticContextFromObject Interface Eco.Handles Namespace See Also
Collapse All
C#
IStaticContext StaticContextForObject(
    object o
);
Remarks

This is StaticContextForObject, a member of class IStaticContextFromObject.

See Also
IStaticContextFromObject Interface
Eco.Handles Namespace


ITupleListRenderingContext Interface

ITupleListRenderingContext Interface
Inheritance Hierarchy See Also
Collapse All

This interface is part of the internal implementation of the databindable IList implemented by the Eco handles. It should not be used directly.

C#
public interface ITupleListRenderingContext : ITupleRenderingContext, ISubscribableElementProvider;
Inheritance Hierarchy
Eco.Handles.IRenderingContext
    Eco.Handles.ITupleRenderingContext
        Eco.Handles.ITupleListRenderingContext
            Eco.Handles.HandleAdapter
            Eco.Handles.RenderedTupleListProperty
File

ControlPack.cs

See Also
Inheritance Hierarchy


ITuplePropertyRenderingContext Interface

ITuplePropertyRenderingContext Interface
Inheritance Hierarchy See Also
Collapse All

This interface is part of the internal implementation of the databindable IList implemented by the Eco handles. It should not be used directly.

C#
public interface ITuplePropertyRenderingContext : IRenderingContext, IElementProvider;
Inheritance Hierarchy
Eco.Handles.IRenderingContext
    Eco.Handles.ITuplePropertyRenderingContext
        Eco.Handles.AbstractRenderedTuple
File

ControlPack.cs

See Also
Inheritance Hierarchy


ITuplePropertyRenderingContext Methods

ITuplePropertyRenderingContext Methods
Public Methods
Collapse All

The methods of the ITuplePropertyRenderingContext class are listed here.

Public Methods
Name | Description
PropertyOutOfDate | Callback


ITuplePropertyRenderingContext.PropertyOutOfDate Method

ITuplePropertyRenderingContext.PropertyOutOfDate Method
ITuplePropertyRenderingContext Interface Eco.Handles Namespace See Also
Collapse All
C#
void PropertyOutOfDate(
    string name
);
Remarks

Callback

See Also
ITuplePropertyRenderingContext Interface
Eco.Handles Namespace


ITuplePropertyRenderingContext Properties

ITuplePropertyRenderingContext Properties
Public Properties
Collapse All

The properties of the ITuplePropertyRenderingContext class are listed here.

Public Properties
Name | Description
IsTestTuple | This is IsTestTuple, a member of class ITuplePropertyRenderingContext.


ITuplePropertyRenderingContext.IsTestTuple Property

ITuplePropertyRenderingContext.IsTestTuple Property
ITuplePropertyRenderingContext Interface Eco.Handles Namespace See Also
Collapse All
C#
bool IsTestTuple;
Remarks

This is IsTestTuple, a member of class ITuplePropertyRenderingContext.

See Also
ITuplePropertyRenderingContext Interface
Eco.Handles Namespace


ITupleRenderingContext Interface

ITupleRenderingContext Interface
Inheritance Hierarchy See Also
Collapse All

This interface is part of the internal implementation of the databindable IList implemented by the Eco handles. It should not be used directly.

C#
public interface ITupleRenderingContext : IRenderingContext;
Inheritance Hierarchy
Eco.Handles.IRenderingContext
    Eco.Handles.ITupleRenderingContext
        Eco.Handles.ITupleListRenderingContext
        Eco.Handles.TupleContext
File

ControlPack.cs

See Also
Inheritance Hierarchy


ITupleRenderingContext Methods

ITupleRenderingContext Methods
Public Methods
Collapse All

The methods of the ITupleRenderingContext class are listed here.

Public Methods
Name | Description
PartOutOfDate | Callback


ITupleRenderingContext.PartOutOfDate Method

ITupleRenderingContext.PartOutOfDate Method
ITupleRenderingContext Interface Eco.Handles Namespace See Also
Collapse All
C#
void PartOutOfDate();
Remarks

Callback

See Also
ITupleRenderingContext Interface
Eco.Handles Namespace


ITupleRenderingContext Properties

ITupleRenderingContext Properties
Public Properties
Collapse All

The properties of the ITupleRenderingContext class are listed here.

Public Properties
Name | Description
TupleDescriptor | This is TupleDescriptor, a member of class ITupleRenderingContext.


ITupleRenderingContext.TupleDescriptor Property

ITupleRenderingContext.TupleDescriptor Property
ITupleRenderingContext Interface Eco.Handles Namespace See Also
Collapse All
C#
RenderedTupleDescriptor TupleDescriptor;
Remarks

This is TupleDescriptor, a member of class ITupleRenderingContext.

See Also
ITupleRenderingContext Interface
Eco.Handles Namespace


Eco.Handles.ExpressionKind Enumeration

Eco.Handles.ExpressionKind Enumeration
C#
public enum ExpressionKind {
  Ocl,
  OclPs,
  EcoActionLanguage
}
Remarks

This is record Eco.Handles.ExpressionKind.

File

HasEditableExpression.cs


Eco.Handles.FilterMode Enumeration

Eco.Handles.FilterMode Enumeration

Enumeration to control the format of Filter

C#
public enum FilterMode {
  None,
  Column,
  Ocl
}
Members
Members | Description
None | Filtering not supported.
Column | Filter is expressed in terms of the columns on the handle.
Ocl | Filter is a OCL expression.
File

ControlPack.cs


Eco.Handles.MemberVisibility Enumeration

Eco.Handles.MemberVisibility Enumeration

Enumeration used to filter members on visibility.

C#
public enum MemberVisibility {
  AllMembers,
  ProtectedOrHigher,
  PublicOnly
}
Members
Members | Description
AllMembers | All members are shown.
ProtectedOrHigher | Public + protected members are shown.
PublicOnly | Only public members are shown.
File

ControlPack.cs


Eco.Handles.NullRowMode Enumeration

Eco.Handles.NullRowMode Enumeration

Enumeration to control adding a "null row" to an Eco Handle.

C#
public enum NullRowMode {
  None,
  First,
  Last,
  IfEmpty
}
Members
Members | Description
None | No null row is added.
First | A null row is added first in the list.
Last | A null row is added last in the list.
IfEmpty | A null row is added if the list is empty.
File

ControlPack.cs


Eco.Handles.DeriveEventHandler Type

Eco.Handles.DeriveEventHandler Type
C#
public delegate void DeriveEventHandler(object sender, DeriveEventArgs e);
Remarks

Delegate declaration.

File

ControlPack.cs


Eco.Handles.DisplayQueueNotEmptyEventHandler Type

Eco.Handles.DisplayQueueNotEmptyEventHandler Type
C#
public delegate void DisplayQueueNotEmptyEventHandler();
Remarks

This is type Eco.Handles.DisplayQueueNotEmptyEventHandler.

File

ControlPack.cs


Eco.Handles.ReverseDeriveEventHandler Type

Eco.Handles.ReverseDeriveEventHandler Type
C#
public delegate void ReverseDeriveEventHandler(object sender, ReverseDeriveEventArgs e);
Remarks

This is type Eco.Handles.ReverseDeriveEventHandler.

File

ControlPack.cs


Eco.Handles.SignalListChangedHandler Type

Eco.Handles.SignalListChangedHandler Type
C#
public delegate void SignalListChangedHandler(ListChangedEventArgs args);
Remarks

This is type Eco.Handles.SignalListChangedHandler.

File

ControlPack.cs


Eco.Interfaces Namespace

Eco.Interfaces Namespace
Classes
Collapse All

This is namespace Eco.Interfaces.

Classes
Name | Description
InterfacesStringRes | Autogenerated class to get compiler safe access to resource strings.


InterfacesStringRes Class

InterfacesStringRes Class
Inheritance Hierarchy See Also
Collapse All

Autogenerated class to get compiler safe access to resource strings.

C#
public sealed class InterfacesStringRes : StringResources;
Inheritance Hierarchy
Eco.Interfaces.InterfacesStringRes
File

Eco.Interfaces.Strings.cs

See Also
Inheritance Hierarchy


InterfacesStringRes Methods

InterfacesStringRes Methods
Public Methods
Collapse All

The methods of the InterfacesStringRes class are listed here.

Public Methods
Name | Description
MapperDoesntImplementInterface | Returns: ""{0}" doesn't implement {1}"
MapperDoesntImplementInterfaces | Returns: ""{0}" doesn't implement neither {1} nor {2}"
MissingTypeForColumn | Returns: "Missing type for column: {0}.{1}"
sAliasContainsKeyWithNoName | Returns: "Alias {0}.{1} contains a key implementation with no name"
sAliasDoesNotSpecifyKeys | Returns: "Alias {0}.{1} does not specify any keys"
sAliasDoesNotSpecifyTable | Returns: "Alias {0}.{1} does not specify a table"
sAliasKeyRefersToNonExistingKey | Returns: "Key implementation {0} in alias {1} in class {2} refers to a key that is not defined"
sAmbiguousTransitionsForTrigger | Returns: "State {0} has ambiguous transitions for trigger {1}, guards "{2}", "{3}" both valid"
sArgumentIsNotA | Returns: "Argument is not a {0}"
sAssociationAlreadyBelongsToPackage | Returns: "Association {0} already belongs to Package {1}"
sAssociationEndAlreadySet | Returns: "{0}[{1}] already set"
sAssociationEndNotAssociation | Returns: "AssociationEnd {0}.{1} not part of association. Probably due to incorrect or missing UmlElement attribute"
sAssociationEndRefersToUnknownAssociation | Returns: "AssociationEnd {0}.{1} refers to an association ({2}) that is unknown"
sAssociationEndTypeMismatch | Returns: "Association end {0} is of type {1}, but other end is part of {2}"
sAssociationHasNoEnds | Returns: "Association {0} has no ends"
sAssociationNotInIncludedPackage | Returns: "Association {0} is not in an Eco package included in the EcoSpace {1}"
sAssociationNotMarkedWithAttribute | Returns: "AssociationEnd {0} lacks association attribute"
sAssociationOnlyHasOneNonnavigableEnd | Returns: "Association {0} has only one nonnavigable end (and no navigable ends)"
sAttributeDefinedButNotInModel | Returns: "{0}.{1} is defined as an attribute, but it is not an attribute in the model"
sAttributeNotInModel | Returns: "Attribute {0}.{1} does not exist in model"
sAutoMandatoryConstraintDesc | Returns: "Role {0} must not be empty"
sAutoMultiplicityConstraintDesc | Returns: "Role {0} must have {1} {2} {3}"
sAutoMultiplicityConstraintModelName | Returns: "{0} multiplicity constraint"
sBooleanValueMustBe | Returns: "Boolean tagged value is "{0}" must be "{1}" or "{2}""
sBothEndsEmbedded | Returns: "Both ends of association {0} are single and embedded ({1}.{2} and {3}.{4})"
sCannotSetElementToValue | Returns: "Can''tset element of type {0} to value {1}"
sCantGetEcoSpaceProvider | Returns: "Cant get an EcoServiceProvider from '{0}'"
sCantGetID | Returns: "Can't get ID ({0}: {1})!"
sChildMappedConcreteClass | Returns: "Class {0} has table mapping "Children" but is not defined to be abstract"
sClassAlreadyBelongsToPackage | Returns: "Class {0} already belongs to Package {1}"
sClassCannotDefineID | Returns: "Class {0} can not define an id because an ancestor class ({1}) already defines an id"
sClassContainsAliasWithNoName | Returns: "Class {0} contains an alias definition with no name"
sClassDefinedInMultipleConfigs | Returns: "O/R mapping for class {0} is defined in multiple configurations"
sClassIDRefersToUndefinedKey | Returns: "Class {0} defines an id that refers to a key ({1}) that does not exist"
sClassifierIsNotAClass | Returns: "The classifier {0} is not a class"
sClassIsAbstract | Returns: "Class "{0}" is abstract"
sClassNotInIncludedPackage | Returns: "Referred class {0} is not in an Eco package included in the EcoSpace {1}"
sClassNotInModel | Returns: "There is no class called "{0}" in the model"
sClassRefersToUnknownAssociation | Returns: "Class {0} refers to an association ({1}) that is unknown"
sConflictingLoopbackIndexes | Returns: "Members have conflicting loopback indexes: {0} and {1} on class {2} (index {3})"
sDeriveAndSubscribeReturnedNull | Returns: "DeriveAndSubscribe for {0}.{1} returned an unexpected null value"
sDerivedAssociationWithLinkClass | Returns: "Association {0} is derived and has an association class ({1}))"
sDerivedMemberHasNoDerivation | Returns: "Derived member {0}.{1} has no derivation defined"
sDiscriminatorDefSignatureEmpty | Returns: "Discriminator definition {0}.{1} has an empty signature"
sDoesNotConform | Returns: "{0} does not conform to {1}"
sDuplicateAliasInClass | Returns: "Duplicate alias definitions ({0}) in class {1}"
sDuplicateAssociationName | Returns: "Two Associations with same unqualified name {0}, {1}"
sDuplicateClassDefinitions | Returns: "The class {0} is defined multiple times"
sDuplicateClassName | Returns: "Two classes with same unqualified name {0}, {1}"
sDuplicateColumnDefinitions | Returns: "The Column {0} is defined multiple times in table {1}"
sDuplicateColumnsWithDifferentCase | Returns: "Duplicate columns with different case in table {0}: {1}, {2}"
sDuplicateFeatureDefinitionsInClass | Returns: "The feature {0} in class {1} is defined multiple times"
sDuplicateKeysInAlias | Returns: "Duplicate key implementation definitions ({0}) in alias {1}.{2}"
sDuplicateKeysInClass | Returns: "Duplicate key definitions ({0}) in class {1}"
sDuplicateTableDefinitions | Returns: "The table {0} is defined multiple times"
sDuplicateUmlElementAttribute | Returns: "Duplicate UmlElementAttribute on {0}"
sEnumValueNotInRange | Returns: "{0} must be in {1}, actual value was {2}"
sErrorBuildingStateMachineFromTransportFormat | Returns: "Error building state machine from transport format {0}"
sErrorInitializingStateMachine | Returns: "Error initializing state machine for class {0}"
sFeatureAlsoDefinedInSuperclass | Returns: "The feature {0} in class {1} is already defined in a super class"
sFeatureDoesNotSpecifyAlias | Returns: "Feature definition {0}.{1} does not specify an alias"
sFeatureDoesNotSpecifyColumns | Returns: "Feature definition {0}.{1} does not specify any columns"
sFeatureHasInvalidAlias | Returns: "Feature definition {0}.{1} refers to an invalid alias {2}"
sFeatureHasNoName | Returns: "Feature definition in class {0} does not have a name"
sInheritedStateMachinesMustHaveUniqueNames | Returns: "Inherited statemachines must have unique region names ({0}.{1})"
sInitializationError | Returns: "Unable to activate system. Initialization errors in StaticSystemTypeInfo:{0}{1}"
sInvalidAssociation | Returns: "Invalid association: {0}.{1} does not point to a class"
sInvalidAttributeType | Returns: "Attribute {0}.{1} has an invalid type: {2}. Only arrays, enums, strings and valuetypes are allowed"
sInvalidAttributeTypeDomainClass | Returns: "The type of attribute {0}.{1} is a domain class ({2}). Please use an association instead"
sInvalidInitialValue | Returns: "Attribute {0}.{1} has an invalid initial value: {2}"
sInvalidLoopbackIndex | Returns: "Property {0}.{1} has in invalid loopback index {2}. Class {0} has only {3} known properties."
sInvalidMapping_AliasDefinesNoKeys | Returns: "The alias "{0}" defined in class {1}, does not implement any keys"
sInvalidMapping_DuplicateAutoIncImplForKeyDef | Returns: "KeyDefinition {0} has multiple implementations marked as IsAutoInc"
sInvalidMapping_DuplicateAutoIncKeyImpl | Returns: "The key definition {0} for class {1} has multiple autoinc key implementations (in alias {2} and {3})"
sInvalidMapping_DuplicateDiscriminatorDefs | Returns: "Discriminator "{0}" is defined in class {1} but it is already defined in a superclass"
sInvalidMapping_DuplicateKeyDefs | Returns: "Key "{0}" is defined in class {1} but it is already defined in a superclass"
sInvalidMapping_TypeCondOverridesFinalValue | Returns: "A discriminator value for discriminator {0} is defined in class {1} but it is marked as final in a superclass"
sInvalidOwnedElementAttribute | Returns: "Invalid UmlMetaAttribute "ownedElement" for package {0}"
sInvalidParamType | Returns: "Trigger {0} Parameter {1}[{2}], Expected {3}, found {4}"
sInvalidSuperClassReference | Returns: "Invalid super class reference in class {0} (refers to {1})"
sInvalidSyntaxForKeyInSingleLink | Returns: "Invalid syntax in key reference for single link {0}.{1}. Key references should be <class>.<key>"
sInvalidValueForStateVariable | Returns: "{0}: "{1}" is not a valid value for state variable {2}"
sIOclOperationNotImplemented | Returns: "Type {0} does not implement IOclOperation"
sIsNotA | Returns: "{0} is not a {1}"
sIsStateAttributeNotSet | Returns: "StateAttribute: {1}.{0} does not have the IsStateAttribute tagged value set"
sIsTriggerNotSet | Returns: "Method {0}.{1} is used as trigger, but IsTrigger is not true"
sKeyColumnCountDiffers | Returns: "Key implementation {0}.{1}.{2} and key definition {3} differs in column count"
sKeyHasConstantColumnWithNoName | Returns: "Key implementation {0}.{1}.{2} contains a constant column with no column name"
sKeyHasConstantColumnWithNoValue | Returns: "Key implementation {0}.{1}.{2} contains a constant column with no value"
sKeyHasEmptySignature | Returns: "Key definition {0}.{1} has an empty signature"
sKeyHasNoName | Returns: "Key definition in class {0} does not have a name"
sKeyHasUnknownSignature | Returns: "There is no persistence mapper defined for "{2}" in key definition {0}.{1}, check your SqlDatabaseConfig"
sKeyImplementationHasUndefinedDiscriminatorColumn | Returns: "Key implementation {0}.{1}.{2} references a discriminator column ({3}) that is not defined by a discriminator implementation"
sKeyImplementationMissingImplementsKey | Returns: "Key implementation {0}.{1}.{2} does not specify the "ImplementsKey" attribute"
sKeyRefersToNonExistingKey | Returns: "Key implementation {0}.{1}.{2} refers to a non-existing key definition"
sLinkInherits | Returns: "AssociationClass {0} inherits from one of its ends"
sMapperDefinitionHasNoMapper | Returns: "The persistence mapper definition for {0} has no type defined (check PersistenceMapper.SqlDatabaseConfig.PersistenceMappers)"
sMapperDoesNotSupportMappingInterfaces | Returns: "Mapper ({0}/{1}) does not support mapping interfaces."
sMappingIsNotSingleColumn | Returns: "The mapping defined for "{0}" ({1}) does not implement ISingleColumnAttributemapping"
sMemberNameCollision | Returns: "Member name {0}.{1} collides with a member of a superclass"
sMissingColumnNameForDiscriminatorImpl | Returns: "DiscriminatorImpl {2} in alias {0}.{1} has no column name"
sMissingDiscriminatorForDiscriminatorImpl | Returns: "DiscriminatorImpl in alias {0}.{1} has no Discriminator"
sMissingDiscriminatorValuesForClass | Returns: "There is no discriminator value defined for discriminator "{0}" in class {1}"
sMissingIdForClass | Returns: "Class {0} does not define any id"
sMissingMappingForFeature | Returns: "There is no persistence mapping defined for {0}.{1}"
sMissingNameForDiscriminatorValue | Returns: "Class {0} specifies a DiscriminatorValue that has no name"
sMissingTableInAlias | Returns: "Missing table in alias {0}.{1}"
sMissingValueForDiscriminatorValue | Returns: "DiscriminatorValue {0} for class {1} does not specify a value"
sMultipleAssociationsSameName | Returns: "System contains multiple associations named {0}"
sMultipleClassesSameName | Returns: "System contains multiple classes named {0}"
sMultipleClassFeaturesSameName | Returns: "Class {0} contains multiple features named {1}"
sMultipleDiscriminatorValuesForClass | Returns: "Discriminator value for discriminator "{0}" is defined in both {1} and {2}"
sMultipleIDsForClass | Returns: "Multiple id definitions for class {0}"
sMultiplePacakgesSameName | Returns: "System contains multiple packages named {0}"
sMultiplePackageElementsSameName | Returns: "Package {0} contains multiple elements named {1}"
sMultipleParametersSameName | Returns: "Method {0} contains multiple parameters named {1}"
sMultipleTypeConditionsForClass | Returns: "Multiple type conditions for class {0}"
sMultipleUnguardedTransitionsForTrigger | Returns: "Vertex "{0}" has multiple outgoing transitions with same trigger "{1}", where at least one lacks Guard"
sMultipleVertextesSameName | Returns: "Region{0} has multiple vertexes named {1}"
sNameAmbiguous | Returns: "Name {0} is ambiguous, can be any of {1}"
sNameNotDefined | Returns: "Name {0} is not defined."
sNameNotUnique | Returns: "Name {0} is not unique."
sNoMappingForPersistentClass | Returns: "No mapping defined for persistent class {0}"
sNoMethodInfoFound | Returns: "Unable to find a MethodInfo for {0}.{1}"
sNoStateAttributeForRegionContainingState | Returns: "No StateAttribute defined for region containing state {0}"
sNot2Ends | Returns: "Association {0} doesn''t have 2 ends"
sNotActive | Returns: "{0} not Active. Please activate the EcoSpace."
sNotEcoType | Returns: "{0} is not a type in the ECO typesystem"
sNoTransition | Returns: "Unable to find a transition for trigger {0} from state {1} in class {2}"
sNotValidOclDerivationOverride | Returns: "{0} is not a valid OCL derivation override"
sNoUnguardedExitStateFromRegionToFinal | Returns: "Region "{0}" has Final state but owning state {1} lacks unguarded outgoing transition"
sNoValidInitialTransition | Returns: "No valid initial transition from State {0} in class {1}"
sNoValueForTag | Returns: "No value for tag '{0}'"
sOptimisticLockingFailed | Returns: "Optimistic locking failed for {0} objects"
sOtherEndOfOrderedMultiLinkHasNoOrderColumn | Returns: "The single link end ({0}.{1}) of an ordered association {2} lacks an OrderColumn"
sOwnedElementWithNoUmlElementAttribute | Returns: "Package {0} contains a class ({1}) that doesnt have the [UmlElement] attribute"
sPackageAlreadyBelongsToPackage | Returns: "Package {0} already belongs to Package {1}"
sPropertyNull | Returns: "{0} null"
sRegionHasMultipleInitialStates | Returns: "Region "{0}" has more than one initial state"
sRegionHasNoInitialState | Returns: "Region "{0}" has no initial state"
sRootStateAttributeAllowsNull | Returns: "Root state attribute "{1}.{0}" must not allow NULL"
sSingleLinkDefinedButNotInModel | Returns: "{0}.{1} is defined as a single link, but it is not an association end in the model"
sSingleLinkDoesNotSpecifyKey | Returns: "Single link definition {0}.{1} does not specify a valid key"
sSingleLinkKeyColumnCountDiffers | Returns: "Single link definition {0}.{1} does not have the same number of columns as key {2}.{3}"
sSingleLinkKeyRefersToUndefinedClass | Returns: "Key in single link definition {0}.{1} refers to a class ({2}) that does not exist in model"
sSingleLinkKeyRefersToUndefinedKey | Returns: "Key in single link definition {0}.{1} refers to a key ({2}) in class {3}, but such a key is not defined"
sSingleLinkNotInModel | Returns: "Single link {0}.{1} does not exist in model"
sSourceIsNotAVertex | Returns: "Source: {0}{1} is not the the name of a vertex in the State Machine"
sStateAttributeNotAnAttributeOnClass | Returns: "StateAttribute: {0} is not an attribute on class {1}"
sStatemachineMultipleRegionsSameName | Returns: "Statemachine {0} has multiple Regions named {1}"
sStateMultipleRegionsSameName | Returns: "State {0} has multiple Regions named {1}"
sTargetIsNotAVertex | Returns: "Target: {0}{1} is not the the name of a vertex in the State Machine"
sTransitionCrossesRegionBoundary | Returns: "Transition from: {0} to {1} crosses boundary to sibling region"
sTransitionsWithAndWithoutTriggers | Returns: "Vertex "{0}" has outgoing transitions both with and without triggers (without guards)"
sTriggerIsNotAMethodOnClass | Returns: "Trigger {0} is not a method on class {1}"
sTriggerlessTransitionsFormLoopFromState | Returns: "Invalid loop of triggerless transitions from state {0} back to itself"
sTriggersNotAllowedFromInitialState | Returns: "Triggers not allowed on transition from initial state {0}:{1}"
sTypeConditionRefersToUndefinedDiscriminator | Returns: "Type condition in class {0} refers to a discriminator {1}), that is not defined"
sTypeDiscriminatorImplementationRefersToUnknownDiscriminator | Returns: "Type discriminator in alias {0}.{1} refers to a type discriminator ({2}) that is not defined in any superclass"
sTypeIsNotAValidSimpleType | Returns: "Type {0} is not a valid "SimpleType", only valuetypes, strings, enums and arrays are allowed."
sTypenotAnEcoAssociation | Returns: "Type {0} is not an EcoAssociation"
sTypeNotAnEcoClass | Returns: "Type {0} is not an EcoClass"
sTypeNotFound | Returns: "{0}.{1}, type {2} not found"
sUnableToFindMapperForAttribute | Returns: "Unable to find a mapper for attribute {0}.{1}, PMapper: "{2}", Type: {3}, please update your SqlDatabaseConfig.PersistenceMappers."
sUnableToFindSingleColumnMapping | Returns: "Unable to find a mapping for "{0}", please check your SqlDatabaseConfig."
sUnableToInstantiateMapper | Returns: "Unable to instantiate mapper {0}"
sUnknownClassifier | Returns: "Model has no class called {0}"
sUnknownColumnInAttribute | Returns: "Unknown Column {0} in attribute {1}.{2}"
sUnknownColumnInSingleLink | Returns: "Unknown Column {0} in single link {1}.{2}"
sUnknownColumnNameInDiscriminatorColumn | Returns: "Unknown DiscriminatorColumn name ({0}) in alias {1}.{2}"
sUnknownColumnNameInKeyImpl | Returns: "Unknown column name ({0}) for KeyImpl in alias {1}.{2}"
sUnknownDatabaseInAlias | Returns: "Unknown database {0} in alias {1}.{2}"
sUnknownDatabaseInClass | Returns: "Unknown database "{0}" in class "{1}""
sUnknownElementInAlias | Returns: "Unknown XML element ({0}) in alias definition (alias: {1}.{2})"
sUnknownElementInClass | Returns: "Unknown XML element ({0}) in class definition (class: {1})"
sUnknownElementInKey | Returns: "Unknown XML element ({0}) in key implementation (key: {3} in alias {1}.{2})"
sUnknownElementInTable | Returns: "Unknown XML element ({0}) in table definition (table: {1})"
sUnknownMember | Returns: "Class {0} has no member called {1}"
sUnknownRegionName | Returns: "Statemachine contains no region named {0}"
sUnknownStateName | Returns: "Statemachine contains no state named {0}"
sUnknownTableInAlias | Returns: "Unknown table {0} in alias {1}.{2}"
sUnknownTriggerName | Returns: "Statemachine contains no trigger named {0}"
sWrongParamCount | Returns: "Trigger {0}: found {1} parameters, expected {2}"
TypeIsNotAValidForOclOperationAttribute | Returns: "Type {0} does not implement IOclOperation, and does not define any static operations that can be used as OCL operations"
UnknownIdType | Returns: "Unknown IdType: {0}"
UnknownKeyType | Returns: "Unknown KeyType: {0}"
UnknownTypeOfOtherEnd | Returns: "AssociationEnd {0}.{1} has an unknown type: {2}. Must be a class in the model"


InterfacesStringRes.MapperDoesntImplementInterface Method

InterfacesStringRes.MapperDoesntImplementInterface Method
InterfacesStringRes Class Eco.Interfaces Namespace See Also
Collapse All

Returns: ""{0}" doesn't implement {1}"

C#
public static string MapperDoesntImplementInterface(
    object param0,
    object param1
);
Remarks

For internal use.

See Also
InterfacesStringRes Class
Eco.Interfaces Namespace


InterfacesStringRes.MapperDoesntImplementInterfaces Method

InterfacesStringRes.MapperDoesntImplementInterfaces Method
InterfacesStringRes Class Eco.Interfaces Namespace See Also
Collapse All

Returns: ""{0}" doesn't implement neither {1} nor {2}"

C#
public static string MapperDoesntImplementInterfaces(
    object param0,
    object param1,
    object param2
);
Remarks

For internal use.

See Also
InterfacesStringRes Class
Eco.Interfaces Namespace


InterfacesStringRes.MissingTypeForColumn Method

InterfacesStringRes.MissingTypeForColumn Method
InterfacesStringRes Class Eco.Interfaces Namespace See Also
Collapse All

Returns: "Missing type for column: {0}.{1}"

C#
public static string MissingTypeForColumn(
    object param0,
    object param1
);
Remarks

For internal use.

See Also
InterfacesStringRes Class
Eco.Interfaces Namespace


InterfacesStringRes.sAliasContainsKeyWithNoName Method

InterfacesStringRes.sAliasContainsKeyWithNoName Method
InterfacesStringRes Class Eco.Interfaces Namespace See Also
Collapse All

Returns: "Alias {0}.{1} contains a key implementation with no name"

C#
public static string sAliasContainsKeyWithNoName(
    object param0,
    object param1
);
Remarks

For internal use.

See Also
InterfacesStringRes Class
Eco.Interfaces Namespace


InterfacesStringRes.sAliasDoesNotSpecifyKeys Method

InterfacesStringRes.sAliasDoesNotSpecifyKeys Method
InterfacesStringRes Class Eco.Interfaces Namespace See Also
Collapse All

Returns: "Alias {0}.{1} does not specify any keys"

C#
public static string sAliasDoesNotSpecifyKeys(
    object param0,
    object param1
);
Remarks

For internal use.

See Also
InterfacesStringRes Class
Eco.Interfaces Namespace


InterfacesStringRes.sAliasDoesNotSpecifyTable Method

InterfacesStringRes.sAliasDoesNotSpecifyTable Method
InterfacesStringRes Class Eco.Interfaces Namespace See Also
Collapse All

Returns: "Alias {0}.{1} does not specify a table"

C#
public static string sAliasDoesNotSpecifyTable(
    object param0,
    object param1
);
Remarks

For internal use.

See Also
InterfacesStringRes Class
Eco.Interfaces Namespace


InterfacesStringRes.sAliasKeyRefersToNonExistingKey Method

InterfacesStringRes.sAliasKeyRefersToNonExistingKey Method
InterfacesStringRes Class Eco.Interfaces Namespace See Also
Collapse All

Returns: "Key implementation {0} in alias {1} in class {2} refers to a key that is not defined"

C#
public static string sAliasKeyRefersToNonExistingKey(
    object param0,
    object param1,
    object param2
);
Remarks

For internal use.

See Also
InterfacesStringRes Class
Eco.Interfaces Namespace


InterfacesStringRes.sAmbiguousTransitionsForTrigger Method

InterfacesStringRes.sAmbiguousTransitionsForTrigger Method
InterfacesStringRes Class Eco.Interfaces Namespace See Also
Collapse All

Returns: "State {0} has ambiguous transitions for trigger {1}, guards "{2}", "{3}" both valid"

C#
public static string sAmbiguousTransitionsForTrigger(
    object param0,
    object param1,
    object param2,
    object param3
);
Remarks

For internal use.

See Also
InterfacesStringRes Class
Eco.Interfaces Namespace


InterfacesStringRes.sArgumentIsNotA Method

InterfacesStringRes.sArgumentIsNotA Method
InterfacesStringRes Class Eco.Interfaces Namespace See Also
Collapse All

Returns: "Argument is not a {0}"

C#
public static string sArgumentIsNotA(
    object param0
);
Remarks

For internal use.

See Also
InterfacesStringRes Class
Eco.Interfaces Namespace


InterfacesStringRes.sAssociationAlreadyBelongsToPackage Method

InterfacesStringRes.sAssociationAlreadyBelongsToPackage Method
InterfacesStringRes Class Eco.Interfaces Namespace See Also
Collapse All

Returns: "Association {0} already belongs to Package {1}"

C#
public static string sAssociationAlreadyBelongsToPackage(
    object param0,
    object param1
);
Remarks

For internal use.

See Also
InterfacesStringRes Class
Eco.Interfaces Namespace


InterfacesStringRes.sAssociationEndAlreadySet Method

InterfacesStringRes.sAssociationEndAlreadySet Method
InterfacesStringRes Class Eco.Interfaces Namespace See Also
Collapse All

Returns: "{0}[{1}] already set"

C#
public static string sAssociationEndAlreadySet(
    object param0,
    object param1
);
Remarks

For internal use.

See Also
InterfacesStringRes Class
Eco.Interfaces Namespace


InterfacesStringRes.sAssociationEndNotAssociation Method

InterfacesStringRes.sAssociationEndNotAssociation Method
InterfacesStringRes Class Eco.Interfaces Namespace See Also
Collapse All

Returns: "AssociationEnd {0}.{1} not part of association. Probably due to incorrect or missing UmlElement attribute"

C#
public static string sAssociationEndNotAssociation(
    object param0,
    object param1
);
Remarks

For internal use.

See Also
InterfacesStringRes Class
Eco.Interfaces Namespace


InterfacesStringRes.sAssociationEndRefersToUnknownAssociation Method

InterfacesStringRes.sAssociationEndRefersToUnknownAssociation Method
InterfacesStringRes Class Eco.Interfaces Namespace See Also
Collapse All

Returns: "AssociationEnd {0}.{1} refers to an association ({2}) that is unknown"

C#
public static string sAssociationEndRefersToUnknownAssociation(
    object param0,
    object param1,
    object param2
);
Remarks

For internal use.

See Also
InterfacesStringRes Class
Eco.Interfaces Namespace


InterfacesStringRes.sAssociationEndTypeMismatch Method

InterfacesStringRes.sAssociationEndTypeMismatch Method
InterfacesStringRes Class Eco.Interfaces Namespace See Also
Collapse All

Returns: "Association end {0} is of type {1}, but other end is part of {2}"

C#
public static string sAssociationEndTypeMismatch(
    object param0,
    object param1,
    object param2
);
Remarks

For internal use.

See Also
InterfacesStringRes Class
Eco.Interfaces Namespace


InterfacesStringRes.sAssociationHasNoEnds Method

InterfacesStringRes.sAssociationHasNoEnds Method
InterfacesStringRes Class Eco.Interfaces Namespace See Also
Collapse All

Returns: "Association {0} has no ends"

C#
public static string sAssociationHasNoEnds(
    object param0
);
Remarks

For internal use.

See Also
InterfacesStringRes Class
Eco.Interfaces Namespace


InterfacesStringRes.sAssociationNotInIncludedPackage Method

InterfacesStringRes.sAssociationNotInIncludedPackage Method
InterfacesStringRes Class Eco.Interfaces Namespace See Also
Collapse All

Returns: "Association {0} is not in an Eco package included in the EcoSpace {1}"

C#
public static string sAssociationNotInIncludedPackage(
    object param0,
    object param1
);
Remarks

For internal use.

See Also
InterfacesStringRes Class
Eco.Interfaces Namespace


InterfacesStringRes.sAssociationNotMarkedWithAttribute Method

InterfacesStringRes.sAssociationNotMarkedWithAttribute Method
InterfacesStringRes Class Eco.Interfaces Namespace See Also
Collapse All

Returns: "AssociationEnd {0} lacks association attribute"

C#
public static string sAssociationNotMarkedWithAttribute(
    object param0
);
Remarks

For internal use.

See Also
InterfacesStringRes Class
Eco.Interfaces Namespace


InterfacesStringRes.sAssociationOnlyHasOneNonnavigableEnd Method

InterfacesStringRes.sAssociationOnlyHasOneNonnavigableEnd Method
InterfacesStringRes Class Eco.Interfaces Namespace See Also
Collapse All

Returns: "Association {0} has only one nonnavigable end (and no navigable ends)"

C#
public static string sAssociationOnlyHasOneNonnavigableEnd(
    object param0
);
Remarks

For internal use.

See Also
InterfacesStringRes Class
Eco.Interfaces Namespace


InterfacesStringRes.sAttributeDefinedButNotInModel Method

InterfacesStringRes.sAttributeDefinedButNotInModel Method
InterfacesStringRes Class Eco.Interfaces Namespace See Also
Collapse All

Returns: "{0}.{1} is defined as an attribute, but it is not an attribute in the model"

C#
public static string sAttributeDefinedButNotInModel(
    object param0,
    object param1
);
Remarks

For internal use.

See Also
InterfacesStringRes Class
Eco.Interfaces Namespace


InterfacesStringRes.sAttributeNotInModel Method

InterfacesStringRes.sAttributeNotInModel Method
InterfacesStringRes Class Eco.Interfaces Namespace See Also
Collapse All

Returns: "Attribute {0}.{1} does not exist in model"

C#
public static string sAttributeNotInModel(
    object param0,
    object param1
);
Remarks

For internal use.

See Also
InterfacesStringRes Class
Eco.Interfaces Namespace


InterfacesStringRes.sAutoMandatoryConstraintDesc Method

InterfacesStringRes.sAutoMandatoryConstraintDesc Method
InterfacesStringRes Class Eco.Interfaces Namespace See Also
Collapse All

Returns: "Role {0} must not be empty"

C#
public static string sAutoMandatoryConstraintDesc(
    object param0
);
Remarks

For internal use.

See Also
InterfacesStringRes Class
Eco.Interfaces Namespace


InterfacesStringRes.sAutoMultiplicityConstraintDesc Method

InterfacesStringRes.sAutoMultiplicityConstraintDesc Method
InterfacesStringRes Class Eco.Interfaces Namespace See Also
Collapse All

Returns: "Role {0} must have {1} {2} {3}"

C#
public static string sAutoMultiplicityConstraintDesc(
    object param0,
    object param1,
    object param2,
    object param3
);
Remarks

For internal use.

See Also
InterfacesStringRes Class
Eco.Interfaces Namespace


InterfacesStringRes.sAutoMultiplicityConstraintModelName Method

InterfacesStringRes.sAutoMultiplicityConstraintModelName Method
InterfacesStringRes Class Eco.Interfaces Namespace See Also
Collapse All

Returns: "{0} multiplicity constraint"

C#
public static string sAutoMultiplicityConstraintModelName(
    object param0
);
Remarks

For internal use.

See Also
InterfacesStringRes Class
Eco.Interfaces Namespace


InterfacesStringRes.sBooleanValueMustBe Method

InterfacesStringRes.sBooleanValueMustBe Method
InterfacesStringRes Class Eco.Interfaces Namespace See Also
Collapse All

Returns: "Boolean tagged value is "{0}" must be "{1}" or "{2}""

C#
public static string sBooleanValueMustBe(
    object param0,
    object param1,
    object param2
);
Remarks

For internal use.

See Also
InterfacesStringRes Class
Eco.Interfaces Namespace


InterfacesStringRes.sBothEndsEmbedded Method

InterfacesStringRes.sBothEndsEmbedded Method
InterfacesStringRes Class Eco.Interfaces Namespace See Also
Collapse All

Returns: "Both ends of association {0} are single and embedded ({1}.{2} and {3}.{4})"

C#
public static string sBothEndsEmbedded(
    object param0,
    object param1,
    object param2,
    object param3,
    object param4
);
Remarks

For internal use.

See Also
InterfacesStringRes Class
Eco.Interfaces Namespace


InterfacesStringRes.sCannotSetElementToValue Method

InterfacesStringRes.sCannotSetElementToValue Method
InterfacesStringRes Class Eco.Interfaces Namespace See Also
Collapse All

Returns: "Can''tset element of type {0} to value {1}"

C#
public static string sCannotSetElementToValue(
    object param0,
    object param1
);
Remarks

For internal use.

See Also
InterfacesStringRes Class
Eco.Interfaces Namespace


InterfacesStringRes.sCantGetEcoSpaceProvider Method

InterfacesStringRes.sCantGetEcoSpaceProvider Method
InterfacesStringRes Class Eco.Interfaces Namespace See Also
Collapse All

Returns: "Cant get an EcoServiceProvider from '{0}'"

C#
public static string sCantGetEcoSpaceProvider(
    object param0
);
Remarks

For internal use.

See Also
InterfacesStringRes Class
Eco.Interfaces Namespace


InterfacesStringRes.sCantGetID Method

InterfacesStringRes.sCantGetID Method
InterfacesStringRes Class Eco.Interfaces Namespace See Also
Collapse All

Returns: "Can't get ID ({0}: {1})!"

C#
public static string sCantGetID(
    object param0,
    object param1
);
Remarks

For internal use.

See Also
InterfacesStringRes Class
Eco.Interfaces Namespace


InterfacesStringRes.sChildMappedConcreteClass Method

InterfacesStringRes.sChildMappedConcreteClass Method
InterfacesStringRes Class Eco.Interfaces Namespace See Also
Collapse All

Returns: "Class {0} has table mapping "Children" but is not defined to be abstract"

C#
public static string sChildMappedConcreteClass(
    object param0
);
Remarks

For internal use.

See Also
InterfacesStringRes Class
Eco.Interfaces Namespace


InterfacesStringRes.sClassAlreadyBelongsToPackage Method

InterfacesStringRes.sClassAlreadyBelongsToPackage Method
InterfacesStringRes Class Eco.Interfaces Namespace See Also
Collapse All

Returns: "Class {0} already belongs to Package {1}"

C#
public static string sClassAlreadyBelongsToPackage(
    object param0,
    object param1
);
Remarks

For internal use.

See Also
InterfacesStringRes Class
Eco.Interfaces Namespace


InterfacesStringRes.sClassCannotDefineID Method

InterfacesStringRes.sClassCannotDefineID Method
InterfacesStringRes Class Eco.Interfaces Namespace See Also
Collapse All

Returns: "Class {0} can not define an id because an ancestor class ({1}) already defines an id"

C#
public static string sClassCannotDefineID(
    object param0,
    object param1
);
Remarks

For internal use.

See Also
InterfacesStringRes Class
Eco.Interfaces Namespace


InterfacesStringRes.sClassContainsAliasWithNoName Method

InterfacesStringRes.sClassContainsAliasWithNoName Method
InterfacesStringRes Class Eco.Interfaces Namespace See Also
Collapse All

Returns: "Class {0} contains an alias definition with no name"

C#
public static string sClassContainsAliasWithNoName(
    object param0
);
Remarks

For internal use.

See Also
InterfacesStringRes Class
Eco.Interfaces Namespace


InterfacesStringRes.sClassDefinedInMultipleConfigs Method

InterfacesStringRes.sClassDefinedInMultipleConfigs Method
InterfacesStringRes Class Eco.Interfaces Namespace See Also
Collapse All

Returns: "O/R mapping for class {0} is defined in multiple configurations"

C#
public static string sClassDefinedInMultipleConfigs(
    object param0
);
Remarks

For internal use.

See Also
InterfacesStringRes Class
Eco.Interfaces Namespace


InterfacesStringRes.sClassIDRefersToUndefinedKey Method

InterfacesStringRes.sClassIDRefersToUndefinedKey Method
InterfacesStringRes Class Eco.Interfaces Namespace See Also
Collapse All

Returns: "Class {0} defines an id that refers to a key ({1}) that does not exist"

C#
public static string sClassIDRefersToUndefinedKey(
    object param0,
    object param1
);
Remarks

For internal use.

See Also
InterfacesStringRes Class
Eco.Interfaces Namespace


InterfacesStringRes.sClassifierIsNotAClass Method

InterfacesStringRes.sClassifierIsNotAClass Method
InterfacesStringRes Class Eco.Interfaces Namespace See Also
Collapse All

Returns: "The classifier {0} is not a class"

C#
public static string sClassifierIsNotAClass(
    object param0
);
Remarks

For internal use.

See Also
InterfacesStringRes Class
Eco.Interfaces Namespace


InterfacesStringRes.sClassIsAbstract Method

InterfacesStringRes.sClassIsAbstract Method
InterfacesStringRes Class Eco.Interfaces Namespace See Also
Collapse All

Returns: "Class "{0}" is abstract"

C#
public static string sClassIsAbstract(
    object param0
);
Remarks

For internal use.

See Also
InterfacesStringRes Class
Eco.Interfaces Namespace


InterfacesStringRes.sClassNotInIncludedPackage Method

InterfacesStringRes.sClassNotInIncludedPackage Method
InterfacesStringRes Class Eco.Interfaces Namespace See Also
Collapse All

Returns: "Referred class {0} is not in an Eco package included in the EcoSpace {1}"

C#
public static string sClassNotInIncludedPackage(
    object param0,
    object param1
);
Remarks

For internal use.

See Also
InterfacesStringRes Class
Eco.Interfaces Namespace


InterfacesStringRes.sClassNotInModel Method

InterfacesStringRes.sClassNotInModel Method
InterfacesStringRes Class Eco.Interfaces Namespace See Also
Collapse All

Returns: "There is no class called "{0}" in the model"

C#
public static string sClassNotInModel(
    object param0
);
Remarks

For internal use.

See Also
InterfacesStringRes Class
Eco.Interfaces Namespace


InterfacesStringRes.sClassRefersToUnknownAssociation Method

InterfacesStringRes.sClassRefersToUnknownAssociation Method
InterfacesStringRes Class Eco.Interfaces Namespace See Also
Collapse All

Returns: "Class {0} refers to an association ({1}) that is unknown"

C#
public static string sClassRefersToUnknownAssociation(
    object param0,
    object param1
);
Remarks

For internal use.

See Also
InterfacesStringRes Class
Eco.Interfaces Namespace


InterfacesStringRes.sConflictingLoopbackIndexes Method

InterfacesStringRes.sConflictingLoopbackIndexes Method
InterfacesStringRes Class Eco.Interfaces Namespace See Also
Collapse All

Returns: "Members have conflicting loopback indexes: {0} and {1} on class {2} (index {3})"

C#
public static string sConflictingLoopbackIndexes(
    object param0,
    object param1,
    object param2,
    object param3
);
Remarks

For internal use.

See Also
InterfacesStringRes Class
Eco.Interfaces Namespace


InterfacesStringRes.sDeriveAndSubscribeReturnedNull Method

InterfacesStringRes.sDeriveAndSubscribeReturnedNull Method
InterfacesStringRes Class Eco.Interfaces Namespace See Also
Collapse All

Returns: "DeriveAndSubscribe for {0}.{1} returned an unexpected null value"

C#
public static string sDeriveAndSubscribeReturnedNull(
    object param0,
    object param1
);
Remarks

For internal use.

See Also
InterfacesStringRes Class
Eco.Interfaces Namespace


InterfacesStringRes.sDerivedAssociationWithLinkClass Method

InterfacesStringRes.sDerivedAssociationWithLinkClass Method
InterfacesStringRes Class Eco.Interfaces Namespace See Also
Collapse All

Returns: "Association {0} is derived and has an association class ({1}))"

C#
public static string sDerivedAssociationWithLinkClass(
    object param0,
    object param1
);
Remarks

For internal use.

See Also
InterfacesStringRes Class
Eco.Interfaces Namespace


InterfacesStringRes.sDerivedMemberHasNoDerivation Method

InterfacesStringRes.sDerivedMemberHasNoDerivation Method
InterfacesStringRes Class Eco.Interfaces Namespace See Also
Collapse All

Returns: "Derived member {0}.{1} has no derivation defined"

C#
public static string sDerivedMemberHasNoDerivation(
    object param0,
    object param1
);
Remarks

For internal use.

See Also
InterfacesStringRes Class
Eco.Interfaces Namespace


InterfacesStringRes.sDiscriminatorDefSignatureEmpty Method

InterfacesStringRes.sDiscriminatorDefSignatureEmpty Method
InterfacesStringRes Class Eco.Interfaces Namespace See Also
Collapse All

Returns: "Discriminator definition {0}.{1} has an empty signature"

C#
public static string sDiscriminatorDefSignatureEmpty(
    object param0,
    object param1
);
Remarks

For internal use.

See Also
InterfacesStringRes Class
Eco.Interfaces Namespace


InterfacesStringRes.sDoesNotConform Method

InterfacesStringRes.sDoesNotConform Method
InterfacesStringRes Class Eco.Interfaces Namespace See Also
Collapse All

Returns: "{0} does not conform to {1}"

C#
public static string sDoesNotConform(
    object param0,
    object param1
);
Remarks

For internal use.

See Also
InterfacesStringRes Class
Eco.Interfaces Namespace


InterfacesStringRes.sDuplicateAliasInClass Method

InterfacesStringRes.sDuplicateAliasInClass Method
InterfacesStringRes Class Eco.Interfaces Namespace See Also
Collapse All

Returns: "Duplicate alias definitions ({0}) in class {1}"

C#
public static string sDuplicateAliasInClass(
    object param0,
    object param1
);
Remarks

For internal use.

See Also
InterfacesStringRes Class
Eco.Interfaces Namespace


InterfacesStringRes.sDuplicateAssociationName Method

InterfacesStringRes.sDuplicateAssociationName Method
InterfacesStringRes Class Eco.Interfaces Namespace See Also
Collapse All

Returns: "Two Associations with same unqualified name {0}, {1}"

C#
public static string sDuplicateAssociationName(
    object param0,
    object param1
);
Remarks

For internal use.

See Also
InterfacesStringRes Class
Eco.Interfaces Namespace


InterfacesStringRes.sDuplicateClassDefinitions Method

InterfacesStringRes.sDuplicateClassDefinitions Method
InterfacesStringRes Class Eco.Interfaces Namespace See Also
Collapse All

Returns: "The class {0} is defined multiple times"

C#
public static string sDuplicateClassDefinitions(
    object param0
);
Remarks

For internal use.

See Also
InterfacesStringRes Class
Eco.Interfaces Namespace


InterfacesStringRes.sDuplicateClassName Method

InterfacesStringRes.sDuplicateClassName Method
InterfacesStringRes Class Eco.Interfaces Namespace See Also
Collapse All

Returns: "Two classes with same unqualified name {0}, {1}"

C#
public static string sDuplicateClassName(
    object param0,
    object param1
);
Remarks

For internal use.

See Also
InterfacesStringRes Class
Eco.Interfaces Namespace


InterfacesStringRes.sDuplicateColumnDefinitions Method

InterfacesStringRes.sDuplicateColumnDefinitions Method
InterfacesStringRes Class Eco.Interfaces Namespace See Also
Collapse All

Returns: "The Column {0} is defined multiple times in table {1}"

C#
public static string sDuplicateColumnDefinitions(
    object param0,
    object param1
);
Remarks

For internal use.

See Also
InterfacesStringRes Class
Eco.Interfaces Namespace


InterfacesStringRes.sDuplicateColumnsWithDifferentCase Method

InterfacesStringRes.sDuplicateColumnsWithDifferentCase Method
InterfacesStringRes Class Eco.Interfaces Namespace See Also
Collapse All

Returns: "Duplicate columns with different case in table {0}: {1}, {2}"

C#
public static string sDuplicateColumnsWithDifferentCase(
    object param0,
    object param1,
    object param2
);
Remarks

For internal use.

See Also
InterfacesStringRes Class
Eco.Interfaces Namespace


InterfacesStringRes.sDuplicateFeatureDefinitionsInClass Method

InterfacesStringRes.sDuplicateFeatureDefinitionsInClass Method
InterfacesStringRes Class Eco.Interfaces Namespace See Also
Collapse All

Returns: "The feature {0} in class {1} is defined multiple times"

C#
public static string sDuplicateFeatureDefinitionsInClass(
    object param0,
    object param1
);
Remarks

For internal use.

See Also
InterfacesStringRes Class
Eco.Interfaces Namespace


InterfacesStringRes.sDuplicateKeysInAlias Method

InterfacesStringRes.sDuplicateKeysInAlias Method
InterfacesStringRes Class Eco.Interfaces Namespace See Also
Collapse All

Returns: "Duplicate key implementation definitions ({0}) in alias {1}.{2}"

C#
public static string sDuplicateKeysInAlias(
    object param0,
    object param1,
    object param2
);
Remarks

For internal use.

See Also
InterfacesStringRes Class
Eco.Interfaces Namespace


InterfacesStringRes.sDuplicateKeysInClass Method

InterfacesStringRes.sDuplicateKeysInClass Method
InterfacesStringRes Class Eco.Interfaces Namespace See Also
Collapse All

Returns: "Duplicate key definitions ({0}) in class {1}"

C#
public static string sDuplicateKeysInClass(
    object param0,
    object param1
);
Remarks

For internal use.

See Also
InterfacesStringRes Class
Eco.Interfaces Namespace


InterfacesStringRes.sDuplicateTableDefinitions Method

InterfacesStringRes.sDuplicateTableDefinitions Method
InterfacesStringRes Class Eco.Interfaces Namespace See Also
Collapse All

Returns: "The table {0} is defined multiple times"

C#
public static string sDuplicateTableDefinitions(
    object param0
);
Remarks

For internal use.

See Also
InterfacesStringRes Class
Eco.Interfaces Namespace


InterfacesStringRes.sDuplicateUmlElementAttribute Method

InterfacesStringRes.sDuplicateUmlElementAttribute Method
InterfacesStringRes Class Eco.Interfaces Namespace See Also
Collapse All

Returns: "Duplicate UmlElementAttribute on {0}"

C#
public static string sDuplicateUmlElementAttribute(
    object param0
);
Remarks

For internal use.

See Also
InterfacesStringRes Class
Eco.Interfaces Namespace


InterfacesStringRes.sEnumValueNotInRange Method

InterfacesStringRes.sEnumValueNotInRange Method
InterfacesStringRes Class Eco.Interfaces Namespace See Also
Collapse All

Returns: "{0} must be in {1}, actual value was {2}"

C#
public static string sEnumValueNotInRange(
    object param0,
    object param1,
    object param2
);
Remarks

For internal use.

See Also
InterfacesStringRes Class
Eco.Interfaces Namespace


InterfacesStringRes.sErrorBuildingStateMachineFromTransportFormat Method

InterfacesStringRes.sErrorBuildingStateMachineFromTransportFormat Method
InterfacesStringRes Class Eco.Interfaces Namespace See Also
Collapse All

Returns: "Error building state machine from transport format {0}"

C#
public static string sErrorBuildingStateMachineFromTransportFormat(
    object param0
);
Remarks

For internal use.

See Also
InterfacesStringRes Class
Eco.Interfaces Namespace


InterfacesStringRes.sErrorInitializingStateMachine Method

InterfacesStringRes.sErrorInitializingStateMachine Method
InterfacesStringRes Class Eco.Interfaces Namespace See Also
Collapse All

Returns: "Error initializing state machine for class {0}"

C#
public static string sErrorInitializingStateMachine(
    object param0
);
Remarks

For internal use.

See Also
InterfacesStringRes Class
Eco.Interfaces Namespace


InterfacesStringRes.sFeatureAlsoDefinedInSuperclass Method

InterfacesStringRes.sFeatureAlsoDefinedInSuperclass Method
InterfacesStringRes Class Eco.Interfaces Namespace See Also
Collapse All

Returns: "The feature {0} in class {1} is already defined in a super class"

C#
public static string sFeatureAlsoDefinedInSuperclass(
    object param0,
    object param1
);
Remarks

For internal use.

See Also
InterfacesStringRes Class
Eco.Interfaces Namespace


InterfacesStringRes.sFeatureDoesNotSpecifyAlias Method

InterfacesStringRes.sFeatureDoesNotSpecifyAlias Method
InterfacesStringRes Class Eco.Interfaces Namespace See Also
Collapse All

Returns: "Feature definition {0}.{1} does not specify an alias"

C#
public static string sFeatureDoesNotSpecifyAlias(
    object param0,
    object param1
);
Remarks

For internal use.

See Also
InterfacesStringRes Class
Eco.Interfaces Namespace


InterfacesStringRes.sFeatureDoesNotSpecifyColumns Method

InterfacesStringRes.sFeatureDoesNotSpecifyColumns Method
InterfacesStringRes Class Eco.Interfaces Namespace See Also
Collapse All

Returns: "Feature definition {0}.{1} does not specify any columns"

C#
public static string sFeatureDoesNotSpecifyColumns(
    object param0,
    object param1
);
Remarks

For internal use.

See Also
InterfacesStringRes Class
Eco.Interfaces Namespace


InterfacesStringRes.sFeatureHasInvalidAlias Method

InterfacesStringRes.sFeatureHasInvalidAlias Method
InterfacesStringRes Class Eco.Interfaces Namespace See Also
Collapse All

Returns: "Feature definition {0}.{1} refers to an invalid alias {2}"

C#
public static string sFeatureHasInvalidAlias(
    object param0,
    object param1,
    object param2
);
Remarks

For internal use.

See Also
InterfacesStringRes Class
Eco.Interfaces Namespace


InterfacesStringRes.sFeatureHasNoName Method

InterfacesStringRes.sFeatureHasNoName Method
InterfacesStringRes Class Eco.Interfaces Namespace See Also
Collapse All

Returns: "Feature definition in class {0} does not have a name"

C#
public static string sFeatureHasNoName(
    object param0
);
Remarks

For internal use.

See Also
InterfacesStringRes Class
Eco.Interfaces Namespace


InterfacesStringRes.sInheritedStateMachinesMustHaveUniqueNames Method

InterfacesStringRes.sInheritedStateMachinesMustHaveUniqueNames Method
InterfacesStringRes Class Eco.Interfaces Namespace See Also
Collapse All

Returns: "Inherited statemachines must have unique region names ({0}.{1})"

C#
public static string sInheritedStateMachinesMustHaveUniqueNames(
    object param0,
    object param1
);
Remarks

For internal use.

See Also
InterfacesStringRes Class
Eco.Interfaces Namespace


InterfacesStringRes.sInitializationError Method

InterfacesStringRes.sInitializationError Method
InterfacesStringRes Class Eco.Interfaces Namespace See Also
Collapse All

Returns: "Unable to activate system. Initialization errors in StaticSystemTypeInfo:{0}{1}"

C#
public static string sInitializationError(
    object param0,
    object param1
);
Remarks

For internal use.

See Also
InterfacesStringRes Class
Eco.Interfaces Namespace


InterfacesStringRes.sInvalidAssociation Method

InterfacesStringRes.sInvalidAssociation Method
InterfacesStringRes Class Eco.Interfaces Namespace See Also
Collapse All

Returns: "Invalid association: {0}.{1} does not point to a class"

C#
public static string sInvalidAssociation(
    object param0,
    object param1
);
Remarks

For internal use.

See Also
InterfacesStringRes Class
Eco.Interfaces Namespace


InterfacesStringRes.sInvalidAttributeType Method

InterfacesStringRes.sInvalidAttributeType Method
InterfacesStringRes Class Eco.Interfaces Namespace See Also
Collapse All

Returns: "Attribute {0}.{1} has an invalid type: {2}. Only arrays, enums, strings and valuetypes are allowed"

C#
public static string sInvalidAttributeType(
    object param0,
    object param1,
    object param2
);
Remarks

For internal use.

See Also
InterfacesStringRes Class
Eco.Interfaces Namespace


InterfacesStringRes.sInvalidAttributeTypeDomainClass Method

InterfacesStringRes.sInvalidAttributeTypeDomainClass Method
InterfacesStringRes Class Eco.Interfaces Namespace See Also
Collapse All

Returns: "The type of attribute {0}.{1} is a domain class ({2}). Please use an association instead"

C#
public static string sInvalidAttributeTypeDomainClass(
    object param0,
    object param1,
    object param2
);
Remarks

For internal use.

See Also
InterfacesStringRes Class
Eco.Interfaces Namespace


InterfacesStringRes.sInvalidInitialValue Method

InterfacesStringRes.sInvalidInitialValue Method
InterfacesStringRes Class Eco.Interfaces Namespace See Also
Collapse All

Returns: "Attribute {0}.{1} has an invalid initial value: {2}"

C#
public static string sInvalidInitialValue(
    object param0,
    object param1,
    object param2
);
Remarks

For internal use.

See Also
InterfacesStringRes Class
Eco.Interfaces Namespace


InterfacesStringRes.sInvalidLoopbackIndex Method

InterfacesStringRes.sInvalidLoopbackIndex Method
InterfacesStringRes Class Eco.Interfaces Namespace See Also
Collapse All

Returns: "Property {0}.{1} has in invalid loopback index {2}. Class {0} has only {3} known properties."

C#
public static string sInvalidLoopbackIndex(
    object param0,
    object param1,
    object param2,
    object param3
);
Remarks

For internal use.

See Also
InterfacesStringRes Class
Eco.Interfaces Namespace


InterfacesStringRes.sInvalidMapping_AliasDefinesNoKeys Method

InterfacesStringRes.sInvalidMapping_AliasDefinesNoKeys Method
InterfacesStringRes Class Eco.Interfaces Namespace See Also
Collapse All

Returns: "The alias "{0}" defined in class {1}, does not implement any keys"

C#
public static string sInvalidMapping_AliasDefinesNoKeys(
    object param0,
    object param1
);
Remarks

For internal use.

See Also
InterfacesStringRes Class
Eco.Interfaces Namespace


InterfacesStringRes.sInvalidMapping_DuplicateAutoIncImplForKeyDef Method

InterfacesStringRes.sInvalidMapping_DuplicateAutoIncImplForKeyDef Method
InterfacesStringRes Class Eco.Interfaces Namespace See Also
Collapse All

Returns: "KeyDefinition {0} has multiple implementations marked as IsAutoInc"

C#
public static string sInvalidMapping_DuplicateAutoIncImplForKeyDef(
    object param0
);
Remarks

For internal use.

See Also
InterfacesStringRes Class
Eco.Interfaces Namespace


InterfacesStringRes.sInvalidMapping_DuplicateAutoIncKeyImpl Method

InterfacesStringRes.sInvalidMapping_DuplicateAutoIncKeyImpl Method
InterfacesStringRes Class Eco.Interfaces Namespace See Also
Collapse All

Returns: "The key definition {0} for class {1} has multiple autoinc key implementations (in alias {2} and {3})"

C#
public static string sInvalidMapping_DuplicateAutoIncKeyImpl(
    object param0,
    object param1,
    object param2,
    object param3
);
Remarks

For internal use.

See Also
InterfacesStringRes Class
Eco.Interfaces Namespace


InterfacesStringRes.sInvalidMapping_DuplicateDiscriminatorDefs Method

InterfacesStringRes.sInvalidMapping_DuplicateDiscriminatorDefs Method
InterfacesStringRes Class Eco.Interfaces Namespace See Also
Collapse All

Returns: "Discriminator "{0}" is defined in class {1} but it is already defined in a superclass"

C#
public static string sInvalidMapping_DuplicateDiscriminatorDefs(
    object param0,
    object param1
);
Remarks

For internal use.

See Also
InterfacesStringRes Class
Eco.Interfaces Namespace


InterfacesStringRes.sInvalidMapping_DuplicateKeyDefs Method

InterfacesStringRes.sInvalidMapping_DuplicateKeyDefs Method
InterfacesStringRes Class Eco.Interfaces Namespace See Also
Collapse All

Returns: "Key "{0}" is defined in class {1} but it is already defined in a superclass"

C#
public static string sInvalidMapping_DuplicateKeyDefs(
    object param0,
    object param1
);
Remarks

For internal use.

See Also
InterfacesStringRes Class
Eco.Interfaces Namespace


InterfacesStringRes.sInvalidMapping_TypeCondOverridesFinalValue Method

InterfacesStringRes.sInvalidMapping_TypeCondOverridesFinalValue Method
InterfacesStringRes Class Eco.Interfaces Namespace See Also
Collapse All

Returns: "A discriminator value for discriminator {0} is defined in class {1} but it is marked as final in a superclass"

C#
public static string sInvalidMapping_TypeCondOverridesFinalValue(
    object param0,
    object param1
);
Remarks

For internal use.

See Also
InterfacesStringRes Class
Eco.Interfaces Namespace


InterfacesStringRes.sInvalidOwnedElementAttribute Method

InterfacesStringRes.sInvalidOwnedElementAttribute Method
InterfacesStringRes Class Eco.Interfaces Namespace See Also
Collapse All

Returns: "Invalid UmlMetaAttribute "ownedElement" for package {0}"

C#
public static string sInvalidOwnedElementAttribute(
    object param0
);
Remarks

For internal use.

See Also
InterfacesStringRes Class
Eco.Interfaces Namespace


InterfacesStringRes.sInvalidParamType Method

InterfacesStringRes.sInvalidParamType Method
InterfacesStringRes Class Eco.Interfaces Namespace See Also
Collapse All

Returns: "Trigger {0} Parameter {1}[{2}], Expected {3}, found {4}"

C#
public static string sInvalidParamType(
    object param0,
    object param1,
    object param2,
    object param3,
    object param4
);
Remarks

For internal use.

See Also
InterfacesStringRes Class
Eco.Interfaces Namespace


InterfacesStringRes.sInvalidSuperClassReference Method

InterfacesStringRes.sInvalidSuperClassReference Method
InterfacesStringRes Class Eco.Interfaces Namespace See Also
Collapse All

Returns: "Invalid super class reference in class {0} (refers to {1})"

C#
public static string sInvalidSuperClassReference(
    object param0,
    object param1
);
Remarks

For internal use.

See Also
InterfacesStringRes Class
Eco.Interfaces Namespace


InterfacesStringRes.sInvalidSyntaxForKeyInSingleLink Method

InterfacesStringRes.sInvalidSyntaxForKeyInSingleLink Method
InterfacesStringRes Class Eco.Interfaces Namespace See Also
Collapse All

Returns: "Invalid syntax in key reference for single link {0}.{1}. Key references should be <class>.<key>"

C#
public static string sInvalidSyntaxForKeyInSingleLink(
    object param0,
    object param1
);
Remarks

For internal use.

See Also
InterfacesStringRes Class
Eco.Interfaces Namespace


InterfacesStringRes.sInvalidValueForStateVariable Method

InterfacesStringRes.sInvalidValueForStateVariable Method
InterfacesStringRes Class Eco.Interfaces Namespace See Also
Collapse All

Returns: "{0}: "{1}" is not a valid value for state variable {2}"

C#
public static string sInvalidValueForStateVariable(
    object param0,
    object param1,
    object param2
);
Remarks

For internal use.

See Also
InterfacesStringRes Class
Eco.Interfaces Namespace


InterfacesStringRes.sIOclOperationNotImplemented Method

InterfacesStringRes.sIOclOperationNotImplemented Method
InterfacesStringRes Class Eco.Interfaces Namespace See Also
Collapse All

Returns: "Type {0} does not implement IOclOperation"

C#
public static string sIOclOperationNotImplemented(
    object param0
);
Remarks

For internal use.

See Also
InterfacesStringRes Class
Eco.Interfaces Namespace


InterfacesStringRes.sIsNotA Method

InterfacesStringRes.sIsNotA Method
InterfacesStringRes Class Eco.Interfaces Namespace See Also
Collapse All

Returns: "{0} is not a {1}"

C#
public static string sIsNotA(
    object param0,
    object param1
);
Remarks

For internal use.

See Also
InterfacesStringRes Class
Eco.Interfaces Namespace


InterfacesStringRes.sIsStateAttributeNotSet Method

InterfacesStringRes.sIsStateAttributeNotSet Method
InterfacesStringRes Class Eco.Interfaces Namespace See Also
Collapse All

Returns: "StateAttribute: {1}.{0} does not have the IsStateAttribute tagged value set"

C#
public static string sIsStateAttributeNotSet(
    object param0,
    object param1
);
Remarks

For internal use.

See Also
InterfacesStringRes Class
Eco.Interfaces Namespace


InterfacesStringRes.sIsTriggerNotSet Method

InterfacesStringRes.sIsTriggerNotSet Method
InterfacesStringRes Class Eco.Interfaces Namespace See Also
Collapse All

Returns: "Method {0}.{1} is used as trigger, but IsTrigger is not true"

C#
public static string sIsTriggerNotSet(
    object param0,
    object param1
);
Remarks

For internal use.

See Also
InterfacesStringRes Class
Eco.Interfaces Namespace


InterfacesStringRes.sKeyColumnCountDiffers Method

InterfacesStringRes.sKeyColumnCountDiffers Method
InterfacesStringRes Class Eco.Interfaces Namespace See Also
Collapse All

Returns: "Key implementation {0}.{1}.{2} and key definition {3} differs in column count"

C#
public static string sKeyColumnCountDiffers(
    object param0,
    object param1,
    object param2,
    object param3
);
Remarks

For internal use.

See Also
InterfacesStringRes Class
Eco.Interfaces Namespace


InterfacesStringRes.sKeyHasConstantColumnWithNoName Method

InterfacesStringRes.sKeyHasConstantColumnWithNoName Method
InterfacesStringRes Class Eco.Interfaces Namespace See Also
Collapse All

Returns: "Key implementation {0}.{1}.{2} contains a constant column with no column name"

C#
public static string sKeyHasConstantColumnWithNoName(
    object param0,
    object param1,
    object param2
);
Remarks

For internal use.

See Also
InterfacesStringRes Class
Eco.Interfaces Namespace


InterfacesStringRes.sKeyHasConstantColumnWithNoValue Method

InterfacesStringRes.sKeyHasConstantColumnWithNoValue Method
InterfacesStringRes Class Eco.Interfaces Namespace See Also
Collapse All

Returns: "Key implementation {0}.{1}.{2} contains a constant column with no value"

C#
public static string sKeyHasConstantColumnWithNoValue(
    object param0,
    object param1,
    object param2
);
Remarks

For internal use.

See Also
InterfacesStringRes Class
Eco.Interfaces Namespace


InterfacesStringRes.sKeyHasEmptySignature Method

InterfacesStringRes.sKeyHasEmptySignature Method
InterfacesStringRes Class Eco.Interfaces Namespace See Also
Collapse All

Returns: "Key definition {0}.{1} has an empty signature"

C#
public static string sKeyHasEmptySignature(
    object param0,
    object param1
);
Remarks

For internal use.

See Also
InterfacesStringRes Class
Eco.Interfaces Namespace


InterfacesStringRes.sKeyHasNoName Method

InterfacesStringRes.sKeyHasNoName Method
InterfacesStringRes Class Eco.Interfaces Namespace See Also
Collapse All

Returns: "Key definition in class {0} does not have a name"

C#
public static string sKeyHasNoName(
    object param0
);
Remarks

For internal use.

See Also
InterfacesStringRes Class
Eco.Interfaces Namespace


InterfacesStringRes.sKeyHasUnknownSignature Method

InterfacesStringRes.sKeyHasUnknownSignature Method
InterfacesStringRes Class Eco.Interfaces Namespace See Also
Collapse All

Returns: "There is no persistence mapper defined for "{2}" in key definition {0}.{1}, check your SqlDatabaseConfig"

C#
public static string sKeyHasUnknownSignature(
    object param0,
    object param1,
    object param2
);
Remarks

For internal use.

See Also
InterfacesStringRes Class
Eco.Interfaces Namespace


InterfacesStringRes.sKeyImplementationHasUndefinedDiscriminatorColumn Method

InterfacesStringRes.sKeyImplementationHasUndefinedDiscriminatorColumn Method
InterfacesStringRes Class Eco.Interfaces Namespace See Also
Collapse All

Returns: "Key implementation {0}.{1}.{2} references a discriminator column ({3}) that is not defined by a discriminator implementation"

C#
public static string sKeyImplementationHasUndefinedDiscriminatorColumn(
    object param0,
    object param1,
    object param2,
    object param3
);
Remarks

For internal use.

See Also
InterfacesStringRes Class
Eco.Interfaces Namespace


InterfacesStringRes.sKeyImplementationMissingImplementsKey Method

InterfacesStringRes.sKeyImplementationMissingImplementsKey Method
InterfacesStringRes Class Eco.Interfaces Namespace See Also
Collapse All

Returns: "Key implementation {0}.{1}.{2} does not specify the "ImplementsKey" attribute"

C#
public static string sKeyImplementationMissingImplementsKey(
    object param0,
    object param1,
    object param2
);
Remarks

For internal use.

See Also
InterfacesStringRes Class
Eco.Interfaces Namespace


InterfacesStringRes.sKeyRefersToNonExistingKey Method

InterfacesStringRes.sKeyRefersToNonExistingKey Method
InterfacesStringRes Class Eco.Interfaces Namespace See Also
Collapse All

Returns: "Key implementation {0}.{1}.{2} refers to a non-existing key definition"

C#
public static string sKeyRefersToNonExistingKey(
    object param0,
    object param1,
    object param2
);
Remarks

For internal use.

See Also
InterfacesStringRes Class
Eco.Interfaces Namespace


InterfacesStringRes.sLinkInherits Method

InterfacesStringRes.sLinkInherits Method
InterfacesStringRes Class Eco.Interfaces Namespace See Also
Collapse All

Returns: "AssociationClass {0} inherits from one of its ends"

C#
public static string sLinkInherits(
    object param0
);
Remarks

For internal use.

See Also
InterfacesStringRes Class
Eco.Interfaces Namespace


InterfacesStringRes.sMapperDefinitionHasNoMapper Method

InterfacesStringRes.sMapperDefinitionHasNoMapper Method
InterfacesStringRes Class Eco.Interfaces Namespace See Also
Collapse All

Returns: "The persistence mapper definition for {0} has no type defined (check PersistenceMapper.SqlDatabaseConfig.PersistenceMappers)"

C#
public static string sMapperDefinitionHasNoMapper(
    object param0
);
Remarks

For internal use.

See Also
InterfacesStringRes Class
Eco.Interfaces Namespace


InterfacesStringRes.sMapperDoesNotSupportMappingInterfaces Method

InterfacesStringRes.sMapperDoesNotSupportMappingInterfaces Method
InterfacesStringRes Class Eco.Interfaces Namespace See Also
Collapse All

Returns: "Mapper ({0}/{1}) does not support mapping interfaces."

C#
public static string sMapperDoesNotSupportMappingInterfaces(
    object param0,
    object param1
);
Remarks

For internal use.

See Also
InterfacesStringRes Class
Eco.Interfaces Namespace


InterfacesStringRes.sMappingIsNotSingleColumn Method

InterfacesStringRes.sMappingIsNotSingleColumn Method
InterfacesStringRes Class Eco.Interfaces Namespace See Also
Collapse All

Returns: "The mapping defined for "{0}" ({1}) does not implement ISingleColumnAttributemapping"

C#
public static string sMappingIsNotSingleColumn(
    object param0,
    object param1
);
Remarks

For internal use.

See Also
InterfacesStringRes Class
Eco.Interfaces Namespace


InterfacesStringRes.sMemberNameCollision Method

InterfacesStringRes.sMemberNameCollision Method
InterfacesStringRes Class Eco.Interfaces Namespace See Also
Collapse All

Returns: "Member name {0}.{1} collides with a member of a superclass"

C#
public static string sMemberNameCollision(
    object param0,
    object param1
);
Remarks

For internal use.

See Also
InterfacesStringRes Class
Eco.Interfaces Namespace


InterfacesStringRes.sMissingColumnNameForDiscriminatorImpl Method

InterfacesStringRes.sMissingColumnNameForDiscriminatorImpl Method
InterfacesStringRes Class Eco.Interfaces Namespace See Also
Collapse All

Returns: "DiscriminatorImpl {2} in alias {0}.{1} has no column name"

C#
public static string sMissingColumnNameForDiscriminatorImpl(
    object param0,
    object param1,
    object param2
);
Remarks

For internal use.

See Also
InterfacesStringRes Class
Eco.Interfaces Namespace


InterfacesStringRes.sMissingDiscriminatorForDiscriminatorImpl Method

InterfacesStringRes.sMissingDiscriminatorForDiscriminatorImpl Method
InterfacesStringRes Class Eco.Interfaces Namespace See Also
Collapse All

Returns: "DiscriminatorImpl in alias {0}.{1} has no Discriminator"

C#
public static string sMissingDiscriminatorForDiscriminatorImpl(
    object param0,
    object param1
);
Remarks

For internal use.

See Also
InterfacesStringRes Class
Eco.Interfaces Namespace


InterfacesStringRes.sMissingDiscriminatorValuesForClass Method

InterfacesStringRes.sMissingDiscriminatorValuesForClass Method
InterfacesStringRes Class Eco.Interfaces Namespace See Also
Collapse All

Returns: "There is no discriminator value defined for discriminator "{0}" in class {1}"

C#
public static string sMissingDiscriminatorValuesForClass(
    object param0,
    object param1
);
Remarks

For internal use.

See Also
InterfacesStringRes Class
Eco.Interfaces Namespace


InterfacesStringRes.sMissingIdForClass Method

InterfacesStringRes.sMissingIdForClass Method
InterfacesStringRes Class Eco.Interfaces Namespace See Also
Collapse All

Returns: "Class {0} does not define any id"

C#
public static string sMissingIdForClass(
    object param0
);
Remarks

For internal use.

See Also
InterfacesStringRes Class
Eco.Interfaces Namespace


InterfacesStringRes.sMissingMappingForFeature Method

InterfacesStringRes.sMissingMappingForFeature Method
InterfacesStringRes Class Eco.Interfaces Namespace See Also
Collapse All

Returns: "There is no persistence mapping defined for {0}.{1}"

C#
public static string sMissingMappingForFeature(
    object param0,
    object param1
);
Remarks

For internal use.

See Also
InterfacesStringRes Class
Eco.Interfaces Namespace


InterfacesStringRes.sMissingNameForDiscriminatorValue Method

InterfacesStringRes.sMissingNameForDiscriminatorValue Method
InterfacesStringRes Class Eco.Interfaces Namespace See Also
Collapse All

Returns: "Class {0} specifies a DiscriminatorValue that has no name"

C#
public static string sMissingNameForDiscriminatorValue(
    object param0
);
Remarks

For internal use.

See Also
InterfacesStringRes Class
Eco.Interfaces Namespace


InterfacesStringRes.sMissingTableInAlias Method

InterfacesStringRes.sMissingTableInAlias Method
InterfacesStringRes Class Eco.Interfaces Namespace See Also
Collapse All

Returns: "Missing table in alias {0}.{1}"

C#
public static string sMissingTableInAlias(
    object param0,
    object param1
);
Remarks

For internal use.

See Also
InterfacesStringRes Class
Eco.Interfaces Namespace


InterfacesStringRes.sMissingValueForDiscriminatorValue Method

InterfacesStringRes.sMissingValueForDiscriminatorValue Method
InterfacesStringRes Class Eco.Interfaces Namespace See Also
Collapse All

Returns: "DiscriminatorValue {0} for class {1} does not specify a value"

C#
public static string sMissingValueForDiscriminatorValue(
    object param0,
    object param1
);
Remarks

For internal use.

See Also
InterfacesStringRes Class
Eco.Interfaces Namespace


InterfacesStringRes.sMultipleAssociationsSameName Method

InterfacesStringRes.sMultipleAssociationsSameName Method
InterfacesStringRes Class Eco.Interfaces Namespace See Also
Collapse All

Returns: "System contains multiple associations named {0}"

C#
public static string sMultipleAssociationsSameName(
    object param0
);
Remarks

For internal use.

See Also
InterfacesStringRes Class
Eco.Interfaces Namespace


InterfacesStringRes.sMultipleClassesSameName Method

InterfacesStringRes.sMultipleClassesSameName Method
InterfacesStringRes Class Eco.Interfaces Namespace See Also
Collapse All

Returns: "System contains multiple classes named {0}"

C#
public static string sMultipleClassesSameName(
    object param0
);
Remarks

For internal use.

See Also
InterfacesStringRes Class
Eco.Interfaces Namespace


InterfacesStringRes.sMultipleClassFeaturesSameName Method

InterfacesStringRes.sMultipleClassFeaturesSameName Method
InterfacesStringRes Class Eco.Interfaces Namespace See Also
Collapse All

Returns: "Class {0} contains multiple features named {1}"

C#
public static string sMultipleClassFeaturesSameName(
    object param0,
    object param1
);
Remarks

For internal use.

See Also
InterfacesStringRes Class
Eco.Interfaces Namespace


InterfacesStringRes.sMultipleDiscriminatorValuesForClass Method

InterfacesStringRes.sMultipleDiscriminatorValuesForClass Method
InterfacesStringRes Class Eco.Interfaces Namespace See Also
Collapse All

Returns: "Discriminator value for discriminator "{0}" is defined in both {1} and {2}"

C#
public static string sMultipleDiscriminatorValuesForClass(
    object param0,
    object param1,
    object param2
);
Remarks

For internal use.

See Also
InterfacesStringRes Class
Eco.Interfaces Namespace


InterfacesStringRes.sMultipleIDsForClass Method

InterfacesStringRes.sMultipleIDsForClass Method
InterfacesStringRes Class Eco.Interfaces Namespace See Also
Collapse All

Returns: "Multiple id definitions for class {0}"

C#
public static string sMultipleIDsForClass(
    object param0
);
Remarks

For internal use.

See Also
InterfacesStringRes Class
Eco.Interfaces Namespace


InterfacesStringRes.sMultiplePacakgesSameName Method

InterfacesStringRes.sMultiplePacakgesSameName Method
InterfacesStringRes Class Eco.Interfaces Namespace See Also
Collapse All

Returns: "System contains multiple packages named {0}"

C#
public static string sMultiplePacakgesSameName(
    object param0
);
Remarks

For internal use.

See Also
InterfacesStringRes Class
Eco.Interfaces Namespace


InterfacesStringRes.sMultiplePackageElementsSameName Method

InterfacesStringRes.sMultiplePackageElementsSameName Method
InterfacesStringRes Class Eco.Interfaces Namespace See Also
Collapse All

Returns: "Package {0} contains multiple elements named {1}"

C#
public static string sMultiplePackageElementsSameName(
    object param0,
    object param1
);
Remarks

For internal use.

See Also
InterfacesStringRes Class
Eco.Interfaces Namespace


InterfacesStringRes.sMultipleParametersSameName Method

InterfacesStringRes.sMultipleParametersSameName Method
InterfacesStringRes Class Eco.Interfaces Namespace See Also
Collapse All

Returns: "Method {0} contains multiple parameters named {1}"

C#
public static string sMultipleParametersSameName(
    object param0,
    object param1
);
Remarks

For internal use.

See Also
InterfacesStringRes Class
Eco.Interfaces Namespace


InterfacesStringRes.sMultipleTypeConditionsForClass Method

InterfacesStringRes.sMultipleTypeConditionsForClass Method
InterfacesStringRes Class Eco.Interfaces Namespace See Also
Collapse All

Returns: "Multiple type conditions for class {0}"

C#
public static string sMultipleTypeConditionsForClass(
    object param0
);
Remarks

For internal use.

See Also
InterfacesStringRes Class
Eco.Interfaces Namespace


InterfacesStringRes.sMultipleUnguardedTransitionsForTrigger Method

InterfacesStringRes.sMultipleUnguardedTransitionsForTrigger Method
InterfacesStringRes Class Eco.Interfaces Namespace See Also
Collapse All

Returns: "Vertex "{0}" has multiple outgoing transitions with same trigger "{1}", where at least one lacks Guard"

C#
public static string sMultipleUnguardedTransitionsForTrigger(
    object param0,
    object param1
);
Remarks

For internal use.

See Also
InterfacesStringRes Class
Eco.Interfaces Namespace


InterfacesStringRes.sMultipleVertextesSameName Method

InterfacesStringRes.sMultipleVertextesSameName Method
InterfacesStringRes Class Eco.Interfaces Namespace See Also
Collapse All

Returns: "Region{0} has multiple vertexes named {1}"

C#
public static string sMultipleVertextesSameName(
    object param0,
    object param1
);
Remarks

For internal use.

See Also
InterfacesStringRes Class
Eco.Interfaces Namespace


InterfacesStringRes.sNameAmbiguous Method

InterfacesStringRes.sNameAmbiguous Method
InterfacesStringRes Class Eco.Interfaces Namespace See Also
Collapse All

Returns: "Name {0} is ambiguous, can be any of {1}"

C#
public static string sNameAmbiguous(
    object param0,
    object param1
);
Remarks

For internal use.

See Also
InterfacesStringRes Class
Eco.Interfaces Namespace


InterfacesStringRes.sNameNotDefined Method

InterfacesStringRes.sNameNotDefined Method
InterfacesStringRes Class Eco.Interfaces Namespace See Also
Collapse All

Returns: "Name {0} is not defined."

C#
public static string sNameNotDefined(
    object param0
);
Remarks

For internal use.

See Also
InterfacesStringRes Class
Eco.Interfaces Namespace


InterfacesStringRes.sNameNotUnique Method

InterfacesStringRes.sNameNotUnique Method
InterfacesStringRes Class Eco.Interfaces Namespace See Also
Collapse All

Returns: "Name {0} is not unique."

C#
public static string sNameNotUnique(
    object param0
);
Remarks

For internal use.

See Also
InterfacesStringRes Class
Eco.Interfaces Namespace


InterfacesStringRes.sNoMappingForPersistentClass Method

InterfacesStringRes.sNoMappingForPersistentClass Method
InterfacesStringRes Class Eco.Interfaces Namespace See Also
Collapse All

Returns: "No mapping defined for persistent class {0}"

C#
public static string sNoMappingForPersistentClass(
    object param0
);
Remarks

For internal use.

See Also
InterfacesStringRes Class
Eco.Interfaces Namespace


InterfacesStringRes.sNoMethodInfoFound Method

InterfacesStringRes.sNoMethodInfoFound Method
InterfacesStringRes Class Eco.Interfaces Namespace See Also
Collapse All

Returns: "Unable to find a MethodInfo for {0}.{1}"

C#
public static string sNoMethodInfoFound(
    object param0,
    object param1
);
Remarks

For internal use.

See Also
InterfacesStringRes Class
Eco.Interfaces Namespace


InterfacesStringRes.sNoStateAttributeForRegionContainingState Method

InterfacesStringRes.sNoStateAttributeForRegionContainingState Method
InterfacesStringRes Class Eco.Interfaces Namespace See Also
Collapse All

Returns: "No StateAttribute defined for region containing state {0}"

C#
public static string sNoStateAttributeForRegionContainingState(
    object param0
);
Remarks

For internal use.

See Also
InterfacesStringRes Class
Eco.Interfaces Namespace


InterfacesStringRes.sNot2Ends Method

InterfacesStringRes.sNot2Ends Method
InterfacesStringRes Class Eco.Interfaces Namespace See Also
Collapse All

Returns: "Association {0} doesn''t have 2 ends"

C#
public static string sNot2Ends(
    object param0
);
Remarks

For internal use.

See Also
InterfacesStringRes Class
Eco.Interfaces Namespace


InterfacesStringRes.sNotActive Method

InterfacesStringRes.sNotActive Method
InterfacesStringRes Class Eco.Interfaces Namespace See Also
Collapse All

Returns: "{0} not Active. Please activate the EcoSpace."

C#
public static string sNotActive(
    object param0
);
Remarks

For internal use.

See Also
InterfacesStringRes Class
Eco.Interfaces Namespace


InterfacesStringRes.sNotEcoType Method

InterfacesStringRes.sNotEcoType Method
InterfacesStringRes Class Eco.Interfaces Namespace See Also
Collapse All

Returns: "{0} is not a type in the ECO typesystem"

C#
public static string sNotEcoType(
    object param0
);
Remarks

For internal use.

See Also
InterfacesStringRes Class
Eco.Interfaces Namespace


InterfacesStringRes.sNoTransition Method

InterfacesStringRes.sNoTransition Method
InterfacesStringRes Class Eco.Interfaces Namespace See Also
Collapse All

Returns: "Unable to find a transition for trigger {0} from state {1} in class {2}"

C#
public static string sNoTransition(
    object param0,
    object param1,
    object param2
);
Remarks

For internal use.

See Also
InterfacesStringRes Class
Eco.Interfaces Namespace


InterfacesStringRes.sNotValidOclDerivationOverride Method

InterfacesStringRes.sNotValidOclDerivationOverride Method
InterfacesStringRes Class Eco.Interfaces Namespace See Also
Collapse All

Returns: "{0} is not a valid OCL derivation override"

C#
public static string sNotValidOclDerivationOverride(
    object param0
);
Remarks

For internal use.

See Also
InterfacesStringRes Class
Eco.Interfaces Namespace


InterfacesStringRes.sNoUnguardedExitStateFromRegionToFinal Method

InterfacesStringRes.sNoUnguardedExitStateFromRegionToFinal Method
InterfacesStringRes Class Eco.Interfaces Namespace See Also
Collapse All

Returns: "Region "{0}" has Final state but owning state {1} lacks unguarded outgoing transition"

C#
public static string sNoUnguardedExitStateFromRegionToFinal(
    object param0,
    object param1
);
Remarks

For internal use.

See Also
InterfacesStringRes Class
Eco.Interfaces Namespace


InterfacesStringRes.sNoValidInitialTransition Method

InterfacesStringRes.sNoValidInitialTransition Method
InterfacesStringRes Class Eco.Interfaces Namespace See Also
Collapse All

Returns: "No valid initial transition from State {0} in class {1}"

C#
public static string sNoValidInitialTransition(
    object param0,
    object param1
);
Remarks

For internal use.

See Also
InterfacesStringRes Class
Eco.Interfaces Namespace


InterfacesStringRes.sNoValueForTag Method

InterfacesStringRes.sNoValueForTag Method
InterfacesStringRes Class Eco.Interfaces Namespace See Also
Collapse All

Returns: "No value for tag '{0}'"

C#
public static string sNoValueForTag(
    object param0
);
Remarks

For internal use.

See Also
InterfacesStringRes Class
Eco.Interfaces Namespace


InterfacesStringRes.sOptimisticLockingFailed Method

InterfacesStringRes.sOptimisticLockingFailed Method
InterfacesStringRes Class Eco.Interfaces Namespace See Also
Collapse All

Returns: "Optimistic locking failed for {0} objects"

C#
public static string sOptimisticLockingFailed(
    object param0
);
Remarks

For internal use.

See Also
InterfacesStringRes Class
Eco.Interfaces Namespace


InterfacesStringRes.sOtherEndOfOrderedMultiLinkHasNoOrderColumn Method

InterfacesStringRes.sOtherEndOfOrderedMultiLinkHasNoOrderColumn Method
InterfacesStringRes Class Eco.Interfaces Namespace See Also
Collapse All

Returns: "The single link end ({0}.{1}) of an ordered association {2} lacks an OrderColumn"

C#
public static string sOtherEndOfOrderedMultiLinkHasNoOrderColumn(
    object param0,
    object param1,
    object param2
);
Remarks

For internal use.

See Also
InterfacesStringRes Class
Eco.Interfaces Namespace


InterfacesStringRes.sOwnedElementWithNoUmlElementAttribute Method

InterfacesStringRes.sOwnedElementWithNoUmlElementAttribute Method
InterfacesStringRes Class Eco.Interfaces Namespace See Also
Collapse All

Returns: "Package {0} contains a class ({1}) that doesnt have the [UmlElement] attribute"

C#
public static string sOwnedElementWithNoUmlElementAttribute(
    object param0,
    object param1
);
Remarks

For internal use.

See Also
InterfacesStringRes Class
Eco.Interfaces Namespace


InterfacesStringRes.sPackageAlreadyBelongsToPackage Method

InterfacesStringRes.sPackageAlreadyBelongsToPackage Method
InterfacesStringRes Class Eco.Interfaces Namespace See Also
Collapse All

Returns: "Package {0} already belongs to Package {1}"

C#
public static string sPackageAlreadyBelongsToPackage(
    object param0,
    object param1
);
Remarks

For internal use.

See Also
InterfacesStringRes Class
Eco.Interfaces Namespace


InterfacesStringRes.sPropertyNull Method

InterfacesStringRes.sPropertyNull Method
InterfacesStringRes Class Eco.Interfaces Namespace See Also
Collapse All

Returns: "{0} null"

C#
public static string sPropertyNull(
    object param0
);
Remarks

For internal use.

See Also
InterfacesStringRes Class
Eco.Interfaces Namespace


InterfacesStringRes.sRegionHasMultipleInitialStates Method

InterfacesStringRes.sRegionHasMultipleInitialStates Method
InterfacesStringRes Class Eco.Interfaces Namespace See Also
Collapse All

Returns: "Region "{0}" has more than one initial state"

C#
public static string sRegionHasMultipleInitialStates(
    object param0
);
Remarks

For internal use.

See Also
InterfacesStringRes Class
Eco.Interfaces Namespace


InterfacesStringRes.sRegionHasNoInitialState Method

InterfacesStringRes.sRegionHasNoInitialState Method
InterfacesStringRes Class Eco.Interfaces Namespace See Also
Collapse All

Returns: "Region "{0}" has no initial state"

C#
public static string sRegionHasNoInitialState(
    object param0
);
Remarks

For internal use.

See Also
InterfacesStringRes Class
Eco.Interfaces Namespace


InterfacesStringRes.sRootStateAttributeAllowsNull Method

InterfacesStringRes.sRootStateAttributeAllowsNull Method
InterfacesStringRes Class Eco.Interfaces Namespace See Also
Collapse All

Returns: "Root state attribute "{1}.{0}" must not allow NULL"

C#
public static string sRootStateAttributeAllowsNull(
    object param0,
    object param1
);
Remarks

For internal use.

See Also
InterfacesStringRes Class
Eco.Interfaces Namespace


InterfacesStringRes.sSingleLinkDefinedButNotInModel Method

InterfacesStringRes.sSingleLinkDefinedButNotInModel Method
InterfacesStringRes Class Eco.Interfaces Namespace See Also
Collapse All

Returns: "{0}.{1} is defined as a single link, but it is not an association end in the model"

C#
public static string sSingleLinkDefinedButNotInModel(
    object param0,
    object param1
);
Remarks

For internal use.

See Also
InterfacesStringRes Class
Eco.Interfaces Namespace


InterfacesStringRes.sSingleLinkDoesNotSpecifyKey Method

InterfacesStringRes.sSingleLinkDoesNotSpecifyKey Method
InterfacesStringRes Class Eco.Interfaces Namespace See Also
Collapse All

Returns: "Single link definition {0}.{1} does not specify a valid key"

C#
public static string sSingleLinkDoesNotSpecifyKey(
    object param0,
    object param1
);
Remarks

For internal use.

See Also
InterfacesStringRes Class
Eco.Interfaces Namespace


InterfacesStringRes.sSingleLinkKeyColumnCountDiffers Method

InterfacesStringRes.sSingleLinkKeyColumnCountDiffers Method
InterfacesStringRes Class Eco.Interfaces Namespace See Also
Collapse All

Returns: "Single link definition {0}.{1} does not have the same number of columns as key {2}.{3}"

C#
public static string sSingleLinkKeyColumnCountDiffers(
    object param0,
    object param1,
    object param2,
    object param3
);
Remarks

For internal use.

See Also
InterfacesStringRes Class
Eco.Interfaces Namespace


InterfacesStringRes.sSingleLinkKeyRefersToUndefinedClass Method

InterfacesStringRes.sSingleLinkKeyRefersToUndefinedClass Method
InterfacesStringRes Class Eco.Interfaces Namespace See Also
Collapse All

Returns: "Key in single link definition {0}.{1} refers to a class ({2}) that does not exist in model"

C#
public static string sSingleLinkKeyRefersToUndefinedClass(
    object param0,
    object param1,
    object param2
);
Remarks

For internal use.

See Also
InterfacesStringRes Class
Eco.Interfaces Namespace


InterfacesStringRes.sSingleLinkKeyRefersToUndefinedKey Method

InterfacesStringRes.sSingleLinkKeyRefersToUndefinedKey Method
InterfacesStringRes Class Eco.Interfaces Namespace See Also
Collapse All

Returns: "Key in single link definition {0}.{1} refers to a key ({2}) in class {3}, but such a key is not defined"

C#
public static string sSingleLinkKeyRefersToUndefinedKey(
    object param0,
    object param1,
    object param2,
    object param3
);
Remarks

For internal use.

See Also
InterfacesStringRes Class
Eco.Interfaces Namespace


InterfacesStringRes.sSingleLinkNotInModel Method

InterfacesStringRes.sSingleLinkNotInModel Method
InterfacesStringRes Class Eco.Interfaces Namespace See Also
Collapse All

Returns: "Single link {0}.{1} does not exist in model"

C#
public static string sSingleLinkNotInModel(
    object param0,
    object param1
);
Remarks

For internal use.

See Also
InterfacesStringRes Class
Eco.Interfaces Namespace


InterfacesStringRes.sSourceIsNotAVertex Method

InterfacesStringRes.sSourceIsNotAVertex Method
InterfacesStringRes Class Eco.Interfaces Namespace See Also
Collapse All

Returns: "Source: {0}{1} is not the the name of a vertex in the State Machine"

C#
public static string sSourceIsNotAVertex(
    object param0,
    object param1
);
Remarks

For internal use.

See Also
InterfacesStringRes Class
Eco.Interfaces Namespace


InterfacesStringRes.sStateAttributeNotAnAttributeOnClass Method

InterfacesStringRes.sStateAttributeNotAnAttributeOnClass Method
InterfacesStringRes Class Eco.Interfaces Namespace See Also
Collapse All

Returns: "StateAttribute: {0} is not an attribute on class {1}"

C#
public static string sStateAttributeNotAnAttributeOnClass(
    object param0,
    object param1
);
Remarks

For internal use.

See Also
InterfacesStringRes Class
Eco.Interfaces Namespace


InterfacesStringRes.sStatemachineMultipleRegionsSameName Method

InterfacesStringRes.sStatemachineMultipleRegionsSameName Method
InterfacesStringRes Class Eco.Interfaces Namespace See Also
Collapse All

Returns: "Statemachine {0} has multiple Regions named {1}"

C#
public static string sStatemachineMultipleRegionsSameName(
    object param0,
    object param1
);
Remarks

For internal use.

See Also
InterfacesStringRes Class
Eco.Interfaces Namespace


InterfacesStringRes.sStateMultipleRegionsSameName Method

InterfacesStringRes.sStateMultipleRegionsSameName Method
InterfacesStringRes Class Eco.Interfaces Namespace See Also
Collapse All

Returns: "State {0} has multiple Regions named {1}"

C#
public static string sStateMultipleRegionsSameName(
    object param0,
    object param1
);
Remarks

For internal use.

See Also
InterfacesStringRes Class
Eco.Interfaces Namespace


InterfacesStringRes.sTargetIsNotAVertex Method

InterfacesStringRes.sTargetIsNotAVertex Method
InterfacesStringRes Class Eco.Interfaces Namespace See Also
Collapse All

Returns: "Target: {0}{1} is not the the name of a vertex in the State Machine"

C#
public static string sTargetIsNotAVertex(
    object param0,
    object param1
);
Remarks

For internal use.

See Also
InterfacesStringRes Class
Eco.Interfaces Namespace


InterfacesStringRes.sTransitionCrossesRegionBoundary Method

InterfacesStringRes.sTransitionCrossesRegionBoundary Method
InterfacesStringRes Class Eco.Interfaces Namespace See Also
Collapse All

Returns: "Transition from: {0} to {1} crosses boundary to sibling region"

C#
public static string sTransitionCrossesRegionBoundary(
    object param0,
    object param1
);
Remarks

For internal use.

See Also
InterfacesStringRes Class
Eco.Interfaces Namespace


InterfacesStringRes.sTransitionsWithAndWithoutTriggers Method

InterfacesStringRes.sTransitionsWithAndWithoutTriggers Method
InterfacesStringRes Class Eco.Interfaces Namespace See Also
Collapse All

Returns: "Vertex "{0}" has outgoing transitions both with and without triggers (without guards)"

C#
public static string sTransitionsWithAndWithoutTriggers(
    object param0
);
Remarks

For internal use.

See Also
InterfacesStringRes Class
Eco.Interfaces Namespace


InterfacesStringRes.sTriggerIsNotAMethodOnClass Method

InterfacesStringRes.sTriggerIsNotAMethodOnClass Method
InterfacesStringRes Class Eco.Interfaces Namespace See Also
Collapse All

Returns: "Trigger {0} is not a method on class {1}"

C#
public static string sTriggerIsNotAMethodOnClass(
    object param0,
    object param1
);
Remarks

For internal use.

See Also
InterfacesStringRes Class
Eco.Interfaces Namespace


InterfacesStringRes.sTriggerlessTransitionsFormLoopFromState Method

InterfacesStringRes.sTriggerlessTransitionsFormLoopFromState Method
InterfacesStringRes Class Eco.Interfaces Namespace See Also
Collapse All

Returns: "Invalid loop of triggerless transitions from state {0} back to itself"

C#
public static string sTriggerlessTransitionsFormLoopFromState(
    object param0
);
Remarks

For internal use.

See Also
InterfacesStringRes Class
Eco.Interfaces Namespace


InterfacesStringRes.sTriggersNotAllowedFromInitialState Method

InterfacesStringRes.sTriggersNotAllowedFromInitialState Method
InterfacesStringRes Class Eco.Interfaces Namespace See Also
Collapse All

Returns: "Triggers not allowed on transition from initial state {0}:{1}"

C#
public static string sTriggersNotAllowedFromInitialState(
    object param0,
    object param1
);
Remarks

For internal use.

See Also
InterfacesStringRes Class
Eco.Interfaces Namespace


InterfacesStringRes.sTypeConditionRefersToUndefinedDiscriminator Method

InterfacesStringRes.sTypeConditionRefersToUndefinedDiscriminator Method
InterfacesStringRes Class Eco.Interfaces Namespace See Also
Collapse All

Returns: "Type condition in class {0} refers to a discriminator {1}), that is not defined"

C#
public static string sTypeConditionRefersToUndefinedDiscriminator(
    object param0,
    object param1
);
Remarks

For internal use.

See Also
InterfacesStringRes Class
Eco.Interfaces Namespace


InterfacesStringRes.sTypeDiscriminatorImplementationRefersToUnknownDiscriminator Method

InterfacesStringRes.sTypeDiscriminatorImplementationRefersToUnknownDiscriminator Method
InterfacesStringRes Class Eco.Interfaces Namespace See Also
Collapse All

Returns: "Type discriminator in alias {0}.{1} refers to a type discriminator ({2}) that is not defined in any superclass"

C#
public static string sTypeDiscriminatorImplementationRefersToUnknownDiscriminator(
    object param0,
    object param1,
    object param2
);
Remarks

For internal use.

See Also
InterfacesStringRes Class
Eco.Interfaces Namespace


InterfacesStringRes.sTypeIsNotAValidSimpleType Method

InterfacesStringRes.sTypeIsNotAValidSimpleType Method
InterfacesStringRes Class Eco.Interfaces Namespace See Also
Collapse All

Returns: "Type {0} is not a valid "SimpleType", only valuetypes, strings, enums and arrays are allowed."

C#
public static string sTypeIsNotAValidSimpleType(
    object param0
);
Remarks

For internal use.

See Also
InterfacesStringRes Class
Eco.Interfaces Namespace


InterfacesStringRes.sTypenotAnEcoAssociation Method

InterfacesStringRes.sTypenotAnEcoAssociation Method
InterfacesStringRes Class Eco.Interfaces Namespace See Also
Collapse All

Returns: "Type {0} is not an EcoAssociation"

C#
public static string sTypenotAnEcoAssociation(
    object param0
);
Remarks

For internal use.

See Also
InterfacesStringRes Class
Eco.Interfaces Namespace


InterfacesStringRes.sTypeNotAnEcoClass Method

InterfacesStringRes.sTypeNotAnEcoClass Method
InterfacesStringRes Class Eco.Interfaces Namespace See Also
Collapse All

Returns: "Type {0} is not an EcoClass"

C#
public static string sTypeNotAnEcoClass(
    object param0
);
Remarks

For internal use.

See Also
InterfacesStringRes Class
Eco.Interfaces Namespace


InterfacesStringRes.sTypeNotFound Method

InterfacesStringRes.sTypeNotFound Method
InterfacesStringRes Class Eco.Interfaces Namespace See Also
Collapse All

Returns: "{0}.{1}, type {2} not found"

C#
public static string sTypeNotFound(
    object param0,
    object param1,
    object param2
);
Remarks

For internal use.

See Also
InterfacesStringRes Class
Eco.Interfaces Namespace


InterfacesStringRes.sUnableToFindMapperForAttribute Method

InterfacesStringRes.sUnableToFindMapperForAttribute Method
InterfacesStringRes Class Eco.Interfaces Namespace See Also
Collapse All

Returns: "Unable to find a mapper for attribute {0}.{1}, PMapper: "{2}", Type: {3}, please update your SqlDatabaseConfig.PersistenceMappers."

C#
public static string sUnableToFindMapperForAttribute(
    object param0,
    object param1,
    object param2,
    object param3
);
Remarks

For internal use.

See Also
InterfacesStringRes Class
Eco.Interfaces Namespace


InterfacesStringRes.sUnableToFindSingleColumnMapping Method

InterfacesStringRes.sUnableToFindSingleColumnMapping Method
InterfacesStringRes Class Eco.Interfaces Namespace See Also
Collapse All

Returns: "Unable to find a mapping for "{0}", please check your SqlDatabaseConfig."

C#
public static string sUnableToFindSingleColumnMapping(
    object param0
);
Remarks

For internal use.

See Also
InterfacesStringRes Class
Eco.Interfaces Namespace


InterfacesStringRes.sUnableToInstantiateMapper Method

InterfacesStringRes.sUnableToInstantiateMapper Method
InterfacesStringRes Class Eco.Interfaces Namespace See Also
Collapse All

Returns: "Unable to instantiate mapper {0}"

C#
public static string sUnableToInstantiateMapper(
    object param0
);
Remarks

For internal use.

See Also
InterfacesStringRes Class
Eco.Interfaces Namespace


InterfacesStringRes.sUnknownClassifier Method

InterfacesStringRes.sUnknownClassifier Method
InterfacesStringRes Class Eco.Interfaces Namespace See Also
Collapse All

Returns: "Model has no class called {0}"

C#
public static string sUnknownClassifier(
    object param0
);
Remarks

For internal use.

See Also
InterfacesStringRes Class
Eco.Interfaces Namespace


InterfacesStringRes.sUnknownColumnInAttribute Method

InterfacesStringRes.sUnknownColumnInAttribute Method
InterfacesStringRes Class Eco.Interfaces Namespace See Also
Collapse All

Returns: "Unknown Column {0} in attribute {1}.{2}"

C#
public static string sUnknownColumnInAttribute(
    object param0,
    object param1,
    object param2
);
Remarks

For internal use.

See Also
InterfacesStringRes Class
Eco.Interfaces Namespace


InterfacesStringRes.sUnknownColumnInSingleLink Method

InterfacesStringRes.sUnknownColumnInSingleLink Method
InterfacesStringRes Class Eco.Interfaces Namespace See Also
Collapse All

Returns: "Unknown Column {0} in single link {1}.{2}"

C#
public static string sUnknownColumnInSingleLink(
    object param0,
    object param1,
    object param2
);
Remarks

For internal use.

See Also
InterfacesStringRes Class
Eco.Interfaces Namespace


InterfacesStringRes.sUnknownColumnNameInDiscriminatorColumn Method

InterfacesStringRes.sUnknownColumnNameInDiscriminatorColumn Method
InterfacesStringRes Class Eco.Interfaces Namespace See Also
Collapse All

Returns: "Unknown DiscriminatorColumn name ({0}) in alias {1}.{2}"

C#
public static string sUnknownColumnNameInDiscriminatorColumn(
    object param0,
    object param1,
    object param2
);
Remarks

For internal use.

See Also
InterfacesStringRes Class
Eco.Interfaces Namespace


InterfacesStringRes.sUnknownColumnNameInKeyImpl Method

InterfacesStringRes.sUnknownColumnNameInKeyImpl Method
InterfacesStringRes Class Eco.Interfaces Namespace See Also
Collapse All

Returns: "Unknown column name ({0}) for KeyImpl in alias {1}.{2}"

C#
public static string sUnknownColumnNameInKeyImpl(
    object param0,
    object param1,
    object param2
);
Remarks

For internal use.

See Also
InterfacesStringRes Class
Eco.Interfaces Namespace


InterfacesStringRes.sUnknownDatabaseInAlias Method

InterfacesStringRes.sUnknownDatabaseInAlias Method
InterfacesStringRes Class Eco.Interfaces Namespace See Also
Collapse All

Returns: "Unknown database {0} in alias {1}.{2}"

C#
public static string sUnknownDatabaseInAlias(
    object param0,
    object param1,
    object param2
);
Remarks

For internal use.

See Also
InterfacesStringRes Class
Eco.Interfaces Namespace


InterfacesStringRes.sUnknownDatabaseInClass Method

InterfacesStringRes.sUnknownDatabaseInClass Method
InterfacesStringRes Class Eco.Interfaces Namespace See Also
Collapse All

Returns: "Unknown database "{0}" in class "{1}""

C#
public static string sUnknownDatabaseInClass(
    object param0,
    object param1
);
Remarks

For internal use.

See Also
InterfacesStringRes Class
Eco.Interfaces Namespace


InterfacesStringRes.sUnknownElementInAlias Method

InterfacesStringRes.sUnknownElementInAlias Method
InterfacesStringRes Class Eco.Interfaces Namespace See Also
Collapse All

Returns: "Unknown XML element ({0}) in alias definition (alias: {1}.{2})"

C#
public static string sUnknownElementInAlias(
    object param0,
    object param1,
    object param2
);
Remarks

For internal use.

See Also
InterfacesStringRes Class
Eco.Interfaces Namespace


InterfacesStringRes.sUnknownElementInClass Method

InterfacesStringRes.sUnknownElementInClass Method
InterfacesStringRes Class Eco.Interfaces Namespace See Also
Collapse All

Returns: "Unknown XML element ({0}) in class definition (class: {1})"

C#
public static string sUnknownElementInClass(
    object param0,
    object param1
);
Remarks

For internal use.

See Also
InterfacesStringRes Class
Eco.Interfaces Namespace


InterfacesStringRes.sUnknownElementInKey Method

InterfacesStringRes.sUnknownElementInKey Method
InterfacesStringRes Class Eco.Interfaces Namespace See Also
Collapse All

Returns: "Unknown XML element ({0}) in key implementation (key: {3} in alias {1}.{2})"

C#
public static string sUnknownElementInKey(
    object param0,
    object param1,
    object param2,
    object param3
);
Remarks

For internal use.

See Also
InterfacesStringRes Class
Eco.Interfaces Namespace


InterfacesStringRes.sUnknownElementInTable Method

InterfacesStringRes.sUnknownElementInTable Method
InterfacesStringRes Class Eco.Interfaces Namespace See Also
Collapse All

Returns: "Unknown XML element ({0}) in table definition (table: {1})"

C#
public static string sUnknownElementInTable(
    object param0,
    object param1
);
Remarks

For internal use.

See Also
InterfacesStringRes Class
Eco.Interfaces Namespace


InterfacesStringRes.sUnknownMember Method

InterfacesStringRes.sUnknownMember Method
InterfacesStringRes Class Eco.Interfaces Namespace See Also
Collapse All

Returns: "Class {0} has no member called {1}"

C#
public static string sUnknownMember(
    object param0,
    object param1
);
Remarks

For internal use.

See Also
InterfacesStringRes Class
Eco.Interfaces Namespace


InterfacesStringRes.sUnknownRegionName Method

InterfacesStringRes.sUnknownRegionName Method
InterfacesStringRes Class Eco.Interfaces Namespace See Also
Collapse All

Returns: "Statemachine contains no region named {0}"

C#
public static string sUnknownRegionName(
    object param0
);
Remarks

For internal use.

See Also
InterfacesStringRes Class
Eco.Interfaces Namespace


InterfacesStringRes.sUnknownStateName Method

InterfacesStringRes.sUnknownStateName Method
InterfacesStringRes Class Eco.Interfaces Namespace See Also
Collapse All

Returns: "Statemachine contains no state named {0}"

C#
public static string sUnknownStateName(
    object param0
);
Remarks

For internal use.

See Also
InterfacesStringRes Class
Eco.Interfaces Namespace


InterfacesStringRes.sUnknownTableInAlias Method

InterfacesStringRes.sUnknownTableInAlias Method
InterfacesStringRes Class Eco.Interfaces Namespace See Also
Collapse All

Returns: "Unknown table {0} in alias {1}.{2}"

C#
public static string sUnknownTableInAlias(
    object param0,
    object param1,
    object param2
);
Remarks

For internal use.

See Also
InterfacesStringRes Class
Eco.Interfaces Namespace


InterfacesStringRes.sUnknownTriggerName Method

InterfacesStringRes.sUnknownTriggerName Method
InterfacesStringRes Class Eco.Interfaces Namespace See Also
Collapse All

Returns: "Statemachine contains no trigger named {0}"

C#
public static string sUnknownTriggerName(
    object param0
);
Remarks

For internal use.

See Also
InterfacesStringRes Class
Eco.Interfaces Namespace


InterfacesStringRes.sWrongParamCount Method

InterfacesStringRes.sWrongParamCount Method
InterfacesStringRes Class Eco.Interfaces Namespace See Also
Collapse All

Returns: "Trigger {0}: found {1} parameters, expected {2}"

C#
public static string sWrongParamCount(
    object param0,
    object param1,
    object param2
);
Remarks

For internal use.

See Also
InterfacesStringRes Class
Eco.Interfaces Namespace


InterfacesStringRes.TypeIsNotAValidForOclOperationAttribute Method

InterfacesStringRes.TypeIsNotAValidForOclOperationAttribute Method
InterfacesStringRes Class Eco.Interfaces Namespace See Also
Collapse All

Returns: "Type {0} does not implement IOclOperation, and does not define any static operations that can be used as OCL operations"

C#
public static string TypeIsNotAValidForOclOperationAttribute(
    object param0
);
Remarks

For internal use.

See Also
InterfacesStringRes Class
Eco.Interfaces Namespace


InterfacesStringRes.UnknownIdType Method

InterfacesStringRes.UnknownIdType Method
InterfacesStringRes Class Eco.Interfaces Namespace See Also
Collapse All

Returns: "Unknown IdType: {0}"

C#
public static string UnknownIdType(
    object param0
);
Remarks

For internal use.

See Also
InterfacesStringRes Class
Eco.Interfaces Namespace


InterfacesStringRes.UnknownKeyType Method

InterfacesStringRes.UnknownKeyType Method
InterfacesStringRes Class Eco.Interfaces Namespace See Also
Collapse All

Returns: "Unknown KeyType: {0}"

C#
public static string UnknownKeyType(
    object param0
);
Remarks

For internal use.

See Also
InterfacesStringRes Class
Eco.Interfaces Namespace


InterfacesStringRes.UnknownTypeOfOtherEnd Method

InterfacesStringRes.UnknownTypeOfOtherEnd Method
InterfacesStringRes Class Eco.Interfaces Namespace See Also
Collapse All

Returns: "AssociationEnd {0}.{1} has an unknown type: {2}. Must be a class in the model"

C#
public static string UnknownTypeOfOtherEnd(
    object param0,
    object param1,
    object param2
);
Remarks

For internal use.

See Also
InterfacesStringRes Class
Eco.Interfaces Namespace


InterfacesStringRes Properties

InterfacesStringRes Properties
Public Properties
Collapse All

The properties of the InterfacesStringRes class are listed here.

Public Properties
Name | Description
OclHelpTypeMethod | Returns: "This method is is just a passthrough to the corresponding CLR-operation, please refer to the .net SDK online help"
PropertyMapperTypeName | Returns: "Name of persistence mapper (FQN, e.g. Eco.Persistence.Default.StringAsVarChar)."
PropertyName | Returns: "Name of attribute or type (e.g. Person.FirstName or System.String)."
sArgumentNotICollection | Returns: "Argument is not ICollection"
sAtLeast | Returns: "at least"
sAtMost | Returns: "at most"
sAutoIncNotSupportingVersionedDBs | Returns: "AutoInc Id does not support versioned databases..."
sCannotApplyWithUndecidedAction | Returns: "Cannot apply a change with an undecided action"
sCannotCompareNullValues | Returns: "Cannot compare if either is null."
sCategoryPersistenceTuning | Returns: "ECO|Performance tuning"
sCategorySQLTweaks | Returns: "ECO|SQL Tweaks"
sClassMappingWithNoName | Returns: "Class mapping found with no name"
sConnectionNotOpen | Returns: "Connection not open"
sElementIsReadOnly | Returns: "Element is readonly"
sError | Returns: "ERROR:"
sForceUpperCase | Returns: "Forces identifiers for tables/columns to use upper case"
sGetKeyNotValidForUnsavedObjects | Returns: "GetKey is not a valid operation for unsaved objects"
sIdentifierCharacterMode | Returns: "Indicates how non-ascii characters in table and columns names should be handled"
sInternalIdEncountered | Returns: "Internal error. NewIdFromAttributes found an internal id."
sInternalIDFromOtherEcoSpace | Returns: "Internal id from other EcoSpace instance"
sKeepOnlyValidForDeletedObjects | Returns: "Action 'Keep' is only valid if the object is deleted."
sKeepOnlyValidForModifiedMembers | Returns: "Action 'Keep' is only valid for modified members"
sKeyAttributeHasNoValue | Returns: "An attribute is defined to be the source for the primary key for the object, but it has no value"
sLeftSideMustBeProperty | Returns: "Left hand side must be a property"
sLengthFunctionName | Returns: "In most databases, this should be "Length", in Sql Server, this should be "LEN""
sListIsNull | Returns: "List is null"
sMapperDefinitionHasNoName | Returns: "There is an entry in the PersistenceMapper collection that has no name (check PersistenceMapper.SqlDatabaseConfig.PersistenceMappers)"
sModelNotEcoified | Returns: "Model not Ecoified"
sMustBeACollectionType | Returns: "Must be a Collection(IObject) type"
sNoClassDefinitionsInDocument | Returns: "Could not find any class definitions in XML document"
sNoElementType | Returns: "<no elementType>"
sNoFileNameForXmlMappingFile | Returns: "No file name specified for XML OR-Mapping file"
sNoLocator | Returns: "The LocatorEventArgs did not contain a Locator"
sObjectRefIsNull | Returns: "Object reference is null"
sPropertyAllowMetadataChangesInTransaction | Returns: "Specifies DB backend allows meta data changes within transactions."
sPropertyBooleanTrueLiteral | Returns: "The value representing a true boolean value during SQL comparison"
sPropertyDateTimeFormat | Returns: "Format used by DateTime.ToString(string format) to set default value for DateTime columns (be careful with your quotes, and server settings)."
sPropertyDefaultDateTime | Returns: "The default DateTime value to be used when creating DateTime columns."
sPropertyDefaultStringLength | Returns: "Default length of strings."
sPropertyDropColumnTemplate | Returns: "SQL template for dropping column."
sPropertyDropIndexTemplate | Returns: "SQL template for dropping an index."
sPropertyDropTableTemplate | Returns: "SQL template for dropping a table."
sPropertyFetchBlockSize | Returns: "Maximum number of objects to fetch in one select statement."
sPropertyIdMappers | Returns: "Definitions for the ID mappers to be used."
sPropertyKeyMapperTypeName | Returns: "Name of key mapper (FQN, ie; Eco.Persistence.AttributeKeyMapper)."
sPropertyMaxDbIdentifierLength | Returns: "Maximum length of identifier allowed by DB backend."
sPropertyMaxIndexNameLength | Returns: "Maximum length of index name allowed by DB backend."
sPropertyMaxParamsInIdList | Returns: "Maximum number of IDs before switching to literal IDs instead of parameters."
sPropertyPersistenceMappers | Returns: "Definitions for the persistence mappers to be used."
sPropertyQuoteSqlNames | Returns: "Indicates if SQL names should be quoted."
sPropertySQLForAllowNull | Returns: "SQL template for specifying that an attribute allows NULL"
sPropertySQLForNotNull | Returns: "SQL template for specifying NOT NULL."
sPropertySupportsConstraintsInCreateTable | Returns: "Specifies if constraints can be specified in CREATE TABLE statements."
sPropertySupportsDefaultColumnValues | Returns: "Indicates if the backends supports default values on columns."
sPropertySystemTablePrefix | Returns: "Prefix prepended to ECO system tables."
sPropertyUpdateIsolationLevel | Returns: "Defines transaction level used in updates."
sPropertyUseClockLog | Returns: "Add table that logs the actual time of timestamps."
sPropertyUseGlobalId | Returns: "Add Globally Unique Ids to XFiles table."
sPropertyUseReadOnly | Returns: "Add column to root class table, allowing objects to be marked as Read Only."
sPropertyUseSQL92Joins | Returns: "Specifies if SQL92 style JOINs are used."
sPropertyUseTimestamp | Returns: "Add timestamp column to XFiles table."
sPropertyUseTimestampColumn | Returns: "Use a column to store time stamps."
sPropertyUseTimestampTable | Returns: "Use a table to store time stamps. Required if versioned classes are used."
sPropertyUseXFiles | Returns: "Add extra table where the ids of deleted objects are not removed."
sReadBeforeSet | Returns: "Attempt to read value before setting it"
sReservedWords | Returns: "A list of reserved words that should be avoided when generating table and column names."
sSQLConfigEmpty | Returns: "Unable to perform requested operation. The SqlDatabaseConfig.PersistenceMappers property is empty, please update your persistence mapper (right click component for preconfigured settings)."
sSqlPostQuoteChar | Returns: "Used with SqlPreQuoteChar to quote table and column names like: [My Name]"
sSqlPreQuoteChar | Returns: "Used with SqlPostQuoteChar to quote table and column names like: [My Name]"
sSqlQuoteChar | Returns: "The character to use when quoting table and column names in sql commands"
sSqlQuoteCharInString | Returns: "Replacement string to represent quote characters inside a string literal in a sql command"
sSqlScriptCommentStart | Returns: "Token that starts a comment in a Sql script."
sSqlScriptCommentStop | Returns: "Token that ends a comment in a Sql script."
sSqlScriptCommitTransaction | Returns: "Command that commits a transaction in a Sql script."
sSqlScriptRollBackTransaction | Returns: "Command that rolls back a transaction in a Sql script."
sSqlScriptSeparator | Returns: "Token that separates two commands in a Sql script (will be placed on separate lines between commands)."
sSqlScriptStartTransaction | Returns: "Command that starts a transaction in a Sql script."
sSqlScriptTerminator | Returns: "Token that terminates a command in a Sql script (will be placed at the end of commands)."
sSqlStringQuoteChar | Returns: "This will be used to surround string literals in sql commands"
sStringTooLong | Returns: "String too long to be converted to a char"
sUMVUseTimeStampRequired | Returns: "148 Model has versioned classes, but the SQLDatabaseConfig does not have UseTimeStamp set to true"
sUnableToFindImplementor | Returns: "Unable to find IAutoIncAttributeMapping for "AutoInc", please update your SqlDatabaseConfig.PersistenceMappers"
sUnknownClassifierType | Returns: "unknown classifier type"
sUnknownClassifierTypeForElement | Returns: "unknown classifier type for element"
sUpperCaseFunctionName | Returns: "In most databases, this should be "UPPER", in MSAccess, this should be "UCASE""
sUseGetAsCollection | Returns: "Operation not implemented for collections, use GetAsCollection<T> instead."
sWarning | Returns: "WARNING:"


InterfacesStringRes.OclHelpTypeMethod Property

InterfacesStringRes.OclHelpTypeMethod Property
InterfacesStringRes Class Eco.Interfaces Namespace See Also
Collapse All

Returns: "This method is is just a passthrough to the corresponding CLR-operation, please refer to the .net SDK online help"

C#
public static string OclHelpTypeMethod;
Remarks

For internal use.

See Also
InterfacesStringRes Class
Eco.Interfaces Namespace


InterfacesStringRes.PropertyMapperTypeName Property

InterfacesStringRes.PropertyMapperTypeName Property
InterfacesStringRes Class Eco.Interfaces Namespace See Also
Collapse All

Returns: "Name of persistence mapper (FQN, e.g. Eco.Persistence.Default.StringAsVarChar)."

C#
public static string PropertyMapperTypeName;
Remarks

For internal use.

See Also
InterfacesStringRes Class
Eco.Interfaces Namespace


InterfacesStringRes.PropertyName Property

InterfacesStringRes.PropertyName Property
InterfacesStringRes Class Eco.Interfaces Namespace See Also
Collapse All

Returns: "Name of attribute or type (e.g. Person.FirstName or System.String)."

C#
public static string PropertyName;
Remarks

For internal use.

See Also
InterfacesStringRes Class
Eco.Interfaces Namespace


InterfacesStringRes.sArgumentNotICollection Property

InterfacesStringRes.sArgumentNotICollection Property
InterfacesStringRes Class Eco.Interfaces Namespace See Also
Collapse All

Returns: "Argument is not ICollection"

C#
public static string sArgumentNotICollection;
Remarks

For internal use.

See Also
InterfacesStringRes Class
Eco.Interfaces Namespace


InterfacesStringRes.sAtLeast Property

InterfacesStringRes.sAtLeast Property
InterfacesStringRes Class Eco.Interfaces Namespace See Also
Collapse All

Returns: "at least"

C#
public static string sAtLeast;
Remarks

For internal use.

See Also
InterfacesStringRes Class
Eco.Interfaces Namespace


InterfacesStringRes.sAtMost Property

InterfacesStringRes.sAtMost Property
InterfacesStringRes Class Eco.Interfaces Namespace See Also
Collapse All

Returns: "at most"

C#
public static string sAtMost;
Remarks

For internal use.

See Also
InterfacesStringRes Class
Eco.Interfaces Namespace


InterfacesStringRes.sAutoIncNotSupportingVersionedDBs Property

InterfacesStringRes.sAutoIncNotSupportingVersionedDBs Property
InterfacesStringRes Class Eco.Interfaces Namespace See Also
Collapse All

Returns: "AutoInc Id does not support versioned databases..."

C#
public static string sAutoIncNotSupportingVersionedDBs;
Remarks

For internal use.

See Also
InterfacesStringRes Class
Eco.Interfaces Namespace


InterfacesStringRes.sCannotApplyWithUndecidedAction Property

InterfacesStringRes.sCannotApplyWithUndecidedAction Property
InterfacesStringRes Class Eco.Interfaces Namespace See Also
Collapse All

Returns: "Cannot apply a change with an undecided action"

C#
public static string sCannotApplyWithUndecidedAction;
Remarks

For internal use.

See Also
InterfacesStringRes Class
Eco.Interfaces Namespace


InterfacesStringRes.sCannotCompareNullValues Property

InterfacesStringRes.sCannotCompareNullValues Property
InterfacesStringRes Class Eco.Interfaces Namespace See Also
Collapse All

Returns: "Cannot compare if either is null."

C#
public static string sCannotCompareNullValues;
Remarks

For internal use.

See Also
InterfacesStringRes Class
Eco.Interfaces Namespace


InterfacesStringRes.sCategoryPersistenceTuning Property

InterfacesStringRes.sCategoryPersistenceTuning Property
InterfacesStringRes Class Eco.Interfaces Namespace See Also
Collapse All

Returns: "ECO|Performance tuning"

C#
public static string sCategoryPersistenceTuning;
Remarks

For internal use.

See Also
InterfacesStringRes Class
Eco.Interfaces Namespace


InterfacesStringRes.sCategorySQLTweaks Property

InterfacesStringRes.sCategorySQLTweaks Property
InterfacesStringRes Class Eco.Interfaces Namespace See Also
Collapse All

Returns: "ECO|SQL Tweaks"

C#
public static string sCategorySQLTweaks;
Remarks

For internal use.

See Also
InterfacesStringRes Class
Eco.Interfaces Namespace


InterfacesStringRes.sClassMappingWithNoName Property

InterfacesStringRes.sClassMappingWithNoName Property
InterfacesStringRes Class Eco.Interfaces Namespace See Also
Collapse All

Returns: "Class mapping found with no name"

C#
public static string sClassMappingWithNoName;
Remarks

For internal use.

See Also
InterfacesStringRes Class
Eco.Interfaces Namespace


InterfacesStringRes.sConnectionNotOpen Property

InterfacesStringRes.sConnectionNotOpen Property
InterfacesStringRes Class Eco.Interfaces Namespace See Also
Collapse All

Returns: "Connection not open"

C#
public static string sConnectionNotOpen;
Remarks

For internal use.

See Also
InterfacesStringRes Class
Eco.Interfaces Namespace


InterfacesStringRes.sElementIsReadOnly Property

InterfacesStringRes.sElementIsReadOnly Property
InterfacesStringRes Class Eco.Interfaces Namespace See Also
Collapse All

Returns: "Element is readonly"

C#
public static string sElementIsReadOnly;
Remarks

For internal use.

See Also
InterfacesStringRes Class
Eco.Interfaces Namespace


InterfacesStringRes.sError Property

InterfacesStringRes.sError Property
InterfacesStringRes Class Eco.Interfaces Namespace See Also
Collapse All

Returns: "ERROR:"

C#
public static string sError;
Remarks

For internal use.

See Also
InterfacesStringRes Class
Eco.Interfaces Namespace


InterfacesStringRes.sForceUpperCase Property

InterfacesStringRes.sForceUpperCase Property
InterfacesStringRes Class Eco.Interfaces Namespace See Also
Collapse All

Returns: "Forces identifiers for tables/columns to use upper case"

C#
public static string sForceUpperCase;
Remarks

For internal use.

See Also
InterfacesStringRes Class
Eco.Interfaces Namespace


InterfacesStringRes.sGetKeyNotValidForUnsavedObjects Property

InterfacesStringRes.sGetKeyNotValidForUnsavedObjects Property
InterfacesStringRes Class Eco.Interfaces Namespace See Also
Collapse All

Returns: "GetKey is not a valid operation for unsaved objects"

C#
public static string sGetKeyNotValidForUnsavedObjects;
Remarks

For internal use.

See Also
InterfacesStringRes Class
Eco.Interfaces Namespace


InterfacesStringRes.sIdentifierCharacterMode Property

InterfacesStringRes.sIdentifierCharacterMode Property
InterfacesStringRes Class Eco.Interfaces Namespace See Also
Collapse All

Returns: "Indicates how non-ascii characters in table and columns names should be handled"

C#
public static string sIdentifierCharacterMode;
Remarks

For internal use.

See Also
InterfacesStringRes Class
Eco.Interfaces Namespace


InterfacesStringRes.sInternalIdEncountered Property

InterfacesStringRes.sInternalIdEncountered Property
InterfacesStringRes Class Eco.Interfaces Namespace See Also
Collapse All

Returns: "Internal error. NewIdFromAttributes found an internal id."

C#
public static string sInternalIdEncountered;
Remarks

For internal use.

See Also
InterfacesStringRes Class
Eco.Interfaces Namespace


InterfacesStringRes.sInternalIDFromOtherEcoSpace Property

InterfacesStringRes.sInternalIDFromOtherEcoSpace Property
InterfacesStringRes Class Eco.Interfaces Namespace See Also
Collapse All

Returns: "Internal id from other EcoSpace instance"

C#
public static string sInternalIDFromOtherEcoSpace;
Remarks

For internal use.

See Also
InterfacesStringRes Class
Eco.Interfaces Namespace


InterfacesStringRes.sKeepOnlyValidForDeletedObjects Property

InterfacesStringRes.sKeepOnlyValidForDeletedObjects Property
InterfacesStringRes Class Eco.Interfaces Namespace See Also
Collapse All

Returns: "Action 'Keep' is only valid if the object is deleted."

C#
public static string sKeepOnlyValidForDeletedObjects;
Remarks

For internal use.

See Also
InterfacesStringRes Class
Eco.Interfaces Namespace


InterfacesStringRes.sKeepOnlyValidForModifiedMembers Property

InterfacesStringRes.sKeepOnlyValidForModifiedMembers Property
InterfacesStringRes Class Eco.Interfaces Namespace See Also
Collapse All

Returns: "Action 'Keep' is only valid for modified members"

C#
public static string sKeepOnlyValidForModifiedMembers;
Remarks

For internal use.

See Also
InterfacesStringRes Class
Eco.Interfaces Namespace


InterfacesStringRes.sKeyAttributeHasNoValue Property

InterfacesStringRes.sKeyAttributeHasNoValue Property
InterfacesStringRes Class Eco.Interfaces Namespace See Also
Collapse All

Returns: "An attribute is defined to be the source for the primary key for the object, but it has no value"

C#
public static string sKeyAttributeHasNoValue;
Remarks

For internal use.

See Also
InterfacesStringRes Class
Eco.Interfaces Namespace


InterfacesStringRes.sLeftSideMustBeProperty Property

InterfacesStringRes.sLeftSideMustBeProperty Property
InterfacesStringRes Class Eco.Interfaces Namespace See Also
Collapse All

Returns: "Left hand side must be a property"

C#
public static string sLeftSideMustBeProperty;
Remarks

For internal use.

See Also
InterfacesStringRes Class
Eco.Interfaces Namespace


InterfacesStringRes.sLengthFunctionName Property

InterfacesStringRes.sLengthFunctionName Property
InterfacesStringRes Class Eco.Interfaces Namespace See Also
Collapse All

Returns: "In most databases, this should be "Length", in Sql Server, this should be "LEN""

C#
public static string sLengthFunctionName;
Remarks

For internal use.

See Also
InterfacesStringRes Class
Eco.Interfaces Namespace


InterfacesStringRes.sListIsNull Property

InterfacesStringRes.sListIsNull Property
InterfacesStringRes Class Eco.Interfaces Namespace See Also
Collapse All

Returns: "List is null"

C#
public static string sListIsNull;
Remarks

For internal use.

See Also
InterfacesStringRes Class
Eco.Interfaces Namespace


InterfacesStringRes.sMapperDefinitionHasNoName Property

InterfacesStringRes.sMapperDefinitionHasNoName Property
InterfacesStringRes Class Eco.Interfaces Namespace See Also
Collapse All

Returns: "There is an entry in the PersistenceMapper collection that has no name (check PersistenceMapper.SqlDatabaseConfig.PersistenceMappers)"

C#
public static string sMapperDefinitionHasNoName;
Remarks

For internal use.

See Also
InterfacesStringRes Class
Eco.Interfaces Namespace


InterfacesStringRes.sModelNotEcoified Property

InterfacesStringRes.sModelNotEcoified Property
InterfacesStringRes Class Eco.Interfaces Namespace See Also
Collapse All

Returns: "Model not Ecoified"

C#
public static string sModelNotEcoified;
Remarks

For internal use.

See Also
InterfacesStringRes Class
Eco.Interfaces Namespace


InterfacesStringRes.sMustBeACollectionType Property

InterfacesStringRes.sMustBeACollectionType Property
InterfacesStringRes Class Eco.Interfaces Namespace See Also
Collapse All

Returns: "Must be a Collection(IObject) type"

C#
public static string sMustBeACollectionType;
Remarks

For internal use.

See Also
InterfacesStringRes Class
Eco.Interfaces Namespace


InterfacesStringRes.sNoClassDefinitionsInDocument Property

InterfacesStringRes.sNoClassDefinitionsInDocument Property
InterfacesStringRes Class Eco.Interfaces Namespace See Also
Collapse All

Returns: "Could not find any class definitions in XML document"

C#
public static string sNoClassDefinitionsInDocument;
Remarks

For internal use.

See Also
InterfacesStringRes Class
Eco.Interfaces Namespace


InterfacesStringRes.sNoElementType Property

InterfacesStringRes.sNoElementType Property
InterfacesStringRes Class Eco.Interfaces Namespace See Also
Collapse All

Returns: "<no elementType>"

C#
public static string sNoElementType;
Remarks

For internal use.

See Also
InterfacesStringRes Class
Eco.Interfaces Namespace


InterfacesStringRes.sNoFileNameForXmlMappingFile Property

InterfacesStringRes.sNoFileNameForXmlMappingFile Property
InterfacesStringRes Class Eco.Interfaces Namespace See Also
Collapse All

Returns: "No file name specified for XML OR-Mapping file"

C#
public static string sNoFileNameForXmlMappingFile;
Remarks

For internal use.

See Also
InterfacesStringRes Class
Eco.Interfaces Namespace


InterfacesStringRes.sNoLocator Property

InterfacesStringRes.sNoLocator Property
InterfacesStringRes Class Eco.Interfaces Namespace See Also
Collapse All

Returns: "The LocatorEventArgs did not contain a Locator"

C#
public static string sNoLocator;
Remarks

For internal use.

See Also
InterfacesStringRes Class
Eco.Interfaces Namespace


InterfacesStringRes.sObjectRefIsNull Property

InterfacesStringRes.sObjectRefIsNull Property
InterfacesStringRes Class Eco.Interfaces Namespace See Also
Collapse All

Returns: "Object reference is null"

C#
public static string sObjectRefIsNull;
Remarks

For internal use.

See Also
InterfacesStringRes Class
Eco.Interfaces Namespace


InterfacesStringRes.sPropertyAllowMetadataChangesInTransaction Property

InterfacesStringRes.sPropertyAllowMetadataChangesInTransaction Property
InterfacesStringRes Class Eco.Interfaces Namespace See Also
Collapse All

Returns: "Specifies DB backend allows meta data changes within transactions."

C#
public static string sPropertyAllowMetadataChangesInTransaction;
Remarks

For internal use.

See Also
InterfacesStringRes Class
Eco.Interfaces Namespace


InterfacesStringRes.sPropertyBooleanTrueLiteral Property

InterfacesStringRes.sPropertyBooleanTrueLiteral Property
InterfacesStringRes Class Eco.Interfaces Namespace See Also
Collapse All

Returns: "The value representing a true boolean value during SQL comparison"

C#
public static string sPropertyBooleanTrueLiteral;
Remarks

For internal use.

See Also
InterfacesStringRes Class
Eco.Interfaces Namespace


InterfacesStringRes.sPropertyDateTimeFormat Property

InterfacesStringRes.sPropertyDateTimeFormat Property
InterfacesStringRes Class Eco.Interfaces Namespace See Also
Collapse All

Returns: "Format used by DateTime.ToString(string format) to set default value for DateTime columns (be careful with your quotes, and server settings)."

C#
public static string sPropertyDateTimeFormat;
Remarks

For internal use.

See Also
InterfacesStringRes Class
Eco.Interfaces Namespace


InterfacesStringRes.sPropertyDefaultDateTime Property

InterfacesStringRes.sPropertyDefaultDateTime Property
InterfacesStringRes Class Eco.Interfaces Namespace See Also
Collapse All

Returns: "The default DateTime value to be used when creating DateTime columns."

C#
public static string sPropertyDefaultDateTime;
Remarks

For internal use.

See Also
InterfacesStringRes Class
Eco.Interfaces Namespace


InterfacesStringRes.sPropertyDefaultStringLength Property

InterfacesStringRes.sPropertyDefaultStringLength Property
InterfacesStringRes Class Eco.Interfaces Namespace See Also
Collapse All

Returns: "Default length of strings."

C#
public static string sPropertyDefaultStringLength;
Remarks

For internal use.

See Also
InterfacesStringRes Class
Eco.Interfaces Namespace


InterfacesStringRes.sPropertyDropColumnTemplate Property

InterfacesStringRes.sPropertyDropColumnTemplate Property
InterfacesStringRes Class Eco.Interfaces Namespace See Also
Collapse All

Returns: "SQL template for dropping column."

C#
public static string sPropertyDropColumnTemplate;
Remarks

For internal use.

See Also
InterfacesStringRes Class
Eco.Interfaces Namespace


InterfacesStringRes.sPropertyDropIndexTemplate Property

InterfacesStringRes.sPropertyDropIndexTemplate Property
InterfacesStringRes Class Eco.Interfaces Namespace See Also
Collapse All

Returns: "SQL template for dropping an index."

C#
public static string sPropertyDropIndexTemplate;
Remarks

For internal use.

See Also
InterfacesStringRes Class
Eco.Interfaces Namespace


InterfacesStringRes.sPropertyDropTableTemplate Property

InterfacesStringRes.sPropertyDropTableTemplate Property
InterfacesStringRes Class Eco.Interfaces Namespace See Also
Collapse All

Returns: "SQL template for dropping a table."

C#
public static string sPropertyDropTableTemplate;
Remarks

For internal use.

See Also
InterfacesStringRes Class
Eco.Interfaces Namespace


InterfacesStringRes.sPropertyFetchBlockSize Property

InterfacesStringRes.sPropertyFetchBlockSize Property
InterfacesStringRes Class Eco.Interfaces Namespace See Also
Collapse All

Returns: "Maximum number of objects to fetch in one select statement."

C#
public static string sPropertyFetchBlockSize;
Remarks

For internal use.

See Also
InterfacesStringRes Class
Eco.Interfaces Namespace


InterfacesStringRes.sPropertyIdMappers Property

InterfacesStringRes.sPropertyIdMappers Property
InterfacesStringRes Class Eco.Interfaces Namespace See Also
Collapse All

Returns: "Definitions for the ID mappers to be used."

C#
public static string sPropertyIdMappers;
Remarks

For internal use.

See Also
InterfacesStringRes Class
Eco.Interfaces Namespace


InterfacesStringRes.sPropertyKeyMapperTypeName Property

InterfacesStringRes.sPropertyKeyMapperTypeName Property
InterfacesStringRes Class Eco.Interfaces Namespace See Also
Collapse All

Returns: "Name of key mapper (FQN, ie; Eco.Persistence.AttributeKeyMapper)."

C#
public static string sPropertyKeyMapperTypeName;
Remarks

For internal use.

See Also
InterfacesStringRes Class
Eco.Interfaces Namespace


InterfacesStringRes.sPropertyMaxDbIdentifierLength Property

InterfacesStringRes.sPropertyMaxDbIdentifierLength Property
InterfacesStringRes Class Eco.Interfaces Namespace See Also
Collapse All

Returns: "Maximum length of identifier allowed by DB backend."

C#
public static string sPropertyMaxDbIdentifierLength;
Remarks

For internal use.

See Also
InterfacesStringRes Class
Eco.Interfaces Namespace


InterfacesStringRes.sPropertyMaxIndexNameLength Property

InterfacesStringRes.sPropertyMaxIndexNameLength Property
InterfacesStringRes Class Eco.Interfaces Namespace See Also
Collapse All

Returns: "Maximum length of index name allowed by DB backend."

C#
public static string sPropertyMaxIndexNameLength;
Remarks

For internal use.

See Also
InterfacesStringRes Class
Eco.Interfaces Namespace


InterfacesStringRes.sPropertyMaxParamsInIdList Property

InterfacesStringRes.sPropertyMaxParamsInIdList Property
InterfacesStringRes Class Eco.Interfaces Namespace See Also
Collapse All

Returns: "Maximum number of IDs before switching to literal IDs instead of parameters."

C#
public static string sPropertyMaxParamsInIdList;
Remarks

For internal use.

See Also
InterfacesStringRes Class
Eco.Interfaces Namespace


InterfacesStringRes.sPropertyPersistenceMappers Property

InterfacesStringRes.sPropertyPersistenceMappers Property
InterfacesStringRes Class Eco.Interfaces Namespace See Also
Collapse All

Returns: "Definitions for the persistence mappers to be used."

C#
public static string sPropertyPersistenceMappers;
Remarks

For internal use.

See Also
InterfacesStringRes Class
Eco.Interfaces Namespace


InterfacesStringRes.sPropertyQuoteSqlNames Property

InterfacesStringRes.sPropertyQuoteSqlNames Property
InterfacesStringRes Class Eco.Interfaces Namespace See Also
Collapse All

Returns: "Indicates if SQL names should be quoted."

C#
public static string sPropertyQuoteSqlNames;
Remarks

For internal use.

See Also
InterfacesStringRes Class
Eco.Interfaces Namespace


InterfacesStringRes.sPropertySQLForAllowNull Property

InterfacesStringRes.sPropertySQLForAllowNull Property
InterfacesStringRes Class Eco.Interfaces Namespace See Also
Collapse All

Returns: "SQL template for specifying that an attribute allows NULL"

C#
public static string sPropertySQLForAllowNull;
Remarks

For internal use.

See Also
InterfacesStringRes Class
Eco.Interfaces Namespace


InterfacesStringRes.sPropertySQLForNotNull Property

InterfacesStringRes.sPropertySQLForNotNull Property
InterfacesStringRes Class Eco.Interfaces Namespace See Also
Collapse All

Returns: "SQL template for specifying NOT NULL."

C#
public static string sPropertySQLForNotNull;
Remarks

For internal use.

See Also
InterfacesStringRes Class
Eco.Interfaces Namespace


InterfacesStringRes.sPropertySupportsConstraintsInCreateTable Property

InterfacesStringRes.sPropertySupportsConstraintsInCreateTable Property
InterfacesStringRes Class Eco.Interfaces Namespace See Also
Collapse All

Returns: "Specifies if constraints can be specified in CREATE TABLE statements."

C#
public static string sPropertySupportsConstraintsInCreateTable;
Remarks

For internal use.

See Also
InterfacesStringRes Class
Eco.Interfaces Namespace


InterfacesStringRes.sPropertySupportsDefaultColumnValues Property

InterfacesStringRes.sPropertySupportsDefaultColumnValues Property
InterfacesStringRes Class Eco.Interfaces Namespace See Also
Collapse All

Returns: "Indicates if the backends supports default values on columns."

C#
public static string sPropertySupportsDefaultColumnValues;
Remarks

For internal use.

See Also
InterfacesStringRes Class
Eco.Interfaces Namespace


InterfacesStringRes.sPropertySystemTablePrefix Property

InterfacesStringRes.sPropertySystemTablePrefix Property
InterfacesStringRes Class Eco.Interfaces Namespace See Also
Collapse All

Returns: "Prefix prepended to ECO system tables."

C#
public static string sPropertySystemTablePrefix;
Remarks

For internal use.

See Also
InterfacesStringRes Class
Eco.Interfaces Namespace


InterfacesStringRes.sPropertyUpdateIsolationLevel Property

InterfacesStringRes.sPropertyUpdateIsolationLevel Property
InterfacesStringRes Class Eco.Interfaces Namespace See Also
Collapse All

Returns: "Defines transaction level used in updates."

C#
public static string sPropertyUpdateIsolationLevel;
Remarks

For internal use.

See Also
InterfacesStringRes Class
Eco.Interfaces Namespace


InterfacesStringRes.sPropertyUseClockLog Property

InterfacesStringRes.sPropertyUseClockLog Property
InterfacesStringRes Class Eco.Interfaces Namespace See Also
Collapse All

Returns: "Add table that logs the actual time of timestamps."

C#
public static string sPropertyUseClockLog;
Remarks

For internal use.

See Also
InterfacesStringRes Class
Eco.Interfaces Namespace


InterfacesStringRes.sPropertyUseGlobalId Property

InterfacesStringRes.sPropertyUseGlobalId Property
InterfacesStringRes Class Eco.Interfaces Namespace See Also
Collapse All

Returns: "Add Globally Unique Ids to XFiles table."

C#
public static string sPropertyUseGlobalId;
Remarks

For internal use.

See Also
InterfacesStringRes Class
Eco.Interfaces Namespace


InterfacesStringRes.sPropertyUseReadOnly Property

InterfacesStringRes.sPropertyUseReadOnly Property
InterfacesStringRes Class Eco.Interfaces Namespace See Also
Collapse All

Returns: "Add column to root class table, allowing objects to be marked as Read Only."

C#
public static string sPropertyUseReadOnly;
Remarks

For internal use.

See Also
InterfacesStringRes Class
Eco.Interfaces Namespace


InterfacesStringRes.sPropertyUseSQL92Joins Property

InterfacesStringRes.sPropertyUseSQL92Joins Property
InterfacesStringRes Class Eco.Interfaces Namespace See Also
Collapse All

Returns: "Specifies if SQL92 style JOINs are used."

C#
public static string sPropertyUseSQL92Joins;
Remarks

For internal use.

See Also
InterfacesStringRes Class
Eco.Interfaces Namespace


InterfacesStringRes.sPropertyUseTimestamp Property

InterfacesStringRes.sPropertyUseTimestamp Property
InterfacesStringRes Class Eco.Interfaces Namespace See Also
Collapse All

Returns: "Add timestamp column to XFiles table."

C#
public static string sPropertyUseTimestamp;
Remarks

For internal use.

See Also
InterfacesStringRes Class
Eco.Interfaces Namespace


InterfacesStringRes.sPropertyUseTimestampColumn Property

InterfacesStringRes.sPropertyUseTimestampColumn Property
InterfacesStringRes Class Eco.Interfaces Namespace See Also
Collapse All

Returns: "Use a column to store time stamps."

C#
public static string sPropertyUseTimestampColumn;
Remarks

For internal use.

See Also
InterfacesStringRes Class
Eco.Interfaces Namespace


InterfacesStringRes.sPropertyUseTimestampTable Property

InterfacesStringRes.sPropertyUseTimestampTable Property
InterfacesStringRes Class Eco.Interfaces Namespace See Also
Collapse All

Returns: "Use a table to store time stamps. Required if versioned classes are used."

C#
public static string sPropertyUseTimestampTable;
Remarks

For internal use.

See Also
InterfacesStringRes Class
Eco.Interfaces Namespace


InterfacesStringRes.sPropertyUseXFiles Property

InterfacesStringRes.sPropertyUseXFiles Property
InterfacesStringRes Class Eco.Interfaces Namespace See Also
Collapse All

Returns: "Add extra table where the ids of deleted objects are not removed."

C#
public static string sPropertyUseXFiles;
Remarks

For internal use.

See Also
InterfacesStringRes Class
Eco.Interfaces Namespace


InterfacesStringRes.sReadBeforeSet Property

InterfacesStringRes.sReadBeforeSet Property
InterfacesStringRes Class Eco.Interfaces Namespace See Also
Collapse All

Returns: "Attempt to read value before setting it"

C#
public static string sReadBeforeSet;
Remarks

For internal use.

See Also
InterfacesStringRes Class
Eco.Interfaces Namespace


InterfacesStringRes.sReservedWords Property

InterfacesStringRes.sReservedWords Property
InterfacesStringRes Class Eco.Interfaces Namespace See Also
Collapse All

Returns: "A list of reserved words that should be avoided when generating table and column names."

C#
public static string sReservedWords;
Remarks

For internal use.

See Also
InterfacesStringRes Class
Eco.Interfaces Namespace


InterfacesStringRes.sSQLConfigEmpty Property

InterfacesStringRes.sSQLConfigEmpty Property
InterfacesStringRes Class Eco.Interfaces Namespace See Also
Collapse All

Returns: "Unable to perform requested operation. The SqlDatabaseConfig.PersistenceMappers property is empty, please update your persistence mapper (right click component for preconfigured settings)."

C#
public static string sSQLConfigEmpty;
Remarks

For internal use.

See Also
InterfacesStringRes Class
Eco.Interfaces Namespace


InterfacesStringRes.sSqlPostQuoteChar Property

InterfacesStringRes.sSqlPostQuoteChar Property
InterfacesStringRes Class Eco.Interfaces Namespace See Also
Collapse All

Returns: "Used with SqlPreQuoteChar to quote table and column names like: [My Name]"

C#
public static string sSqlPostQuoteChar;
Remarks

For internal use.

See Also
InterfacesStringRes Class
Eco.Interfaces Namespace


InterfacesStringRes.sSqlPreQuoteChar Property

InterfacesStringRes.sSqlPreQuoteChar Property
InterfacesStringRes Class Eco.Interfaces Namespace See Also
Collapse All

Returns: "Used with SqlPostQuoteChar to quote table and column names like: [My Name]"

C#
public static string sSqlPreQuoteChar;
Remarks

For internal use.

See Also
InterfacesStringRes Class
Eco.Interfaces Namespace


InterfacesStringRes.sSqlQuoteChar Property

InterfacesStringRes.sSqlQuoteChar Property
InterfacesStringRes Class Eco.Interfaces Namespace See Also
Collapse All

Returns: "The character to use when quoting table and column names in sql commands"

C#
public static string sSqlQuoteChar;
Remarks

For internal use.

See Also
InterfacesStringRes Class
Eco.Interfaces Namespace


InterfacesStringRes.sSqlQuoteCharInString Property

InterfacesStringRes.sSqlQuoteCharInString Property
InterfacesStringRes Class Eco.Interfaces Namespace See Also
Collapse All

Returns: "Replacement string to represent quote characters inside a string literal in a sql command"

C#
public static string sSqlQuoteCharInString;
Remarks

For internal use.

See Also
InterfacesStringRes Class
Eco.Interfaces Namespace


InterfacesStringRes.sSqlScriptCommentStart Property

InterfacesStringRes.sSqlScriptCommentStart Property
InterfacesStringRes Class Eco.Interfaces Namespace See Also
Collapse All

Returns: "Token that starts a comment in a Sql script."

C#
public static string sSqlScriptCommentStart;
Remarks

For internal use.

See Also
InterfacesStringRes Class
Eco.Interfaces Namespace


InterfacesStringRes.sSqlScriptCommentStop Property

InterfacesStringRes.sSqlScriptCommentStop Property
InterfacesStringRes Class Eco.Interfaces Namespace See Also
Collapse All

Returns: "Token that ends a comment in a Sql script."

C#
public static string sSqlScriptCommentStop;
Remarks

For internal use.

See Also
InterfacesStringRes Class
Eco.Interfaces Namespace


InterfacesStringRes.sSqlScriptCommitTransaction Property

InterfacesStringRes.sSqlScriptCommitTransaction Property
InterfacesStringRes Class Eco.Interfaces Namespace See Also
Collapse All

Returns: "Command that commits a transaction in a Sql script."

C#
public static string sSqlScriptCommitTransaction;
Remarks

For internal use.

See Also
InterfacesStringRes Class
Eco.Interfaces Namespace


InterfacesStringRes.sSqlScriptRollBackTransaction Property

InterfacesStringRes.sSqlScriptRollBackTransaction Property
InterfacesStringRes Class Eco.Interfaces Namespace See Also
Collapse All

Returns: "Command that rolls back a transaction in a Sql script."

C#
public static string sSqlScriptRollBackTransaction;
Remarks

For internal use.

See Also
InterfacesStringRes Class
Eco.Interfaces Namespace


InterfacesStringRes.sSqlScriptSeparator Property

InterfacesStringRes.sSqlScriptSeparator Property
InterfacesStringRes Class Eco.Interfaces Namespace See Also
Collapse All

Returns: "Token that separates two commands in a Sql script (will be placed on separate lines between commands)."

C#
public static string sSqlScriptSeparator;
Remarks

For internal use.

See Also
InterfacesStringRes Class
Eco.Interfaces Namespace


InterfacesStringRes.sSqlScriptStartTransaction Property

InterfacesStringRes.sSqlScriptStartTransaction Property
InterfacesStringRes Class Eco.Interfaces Namespace See Also
Collapse All

Returns: "Command that starts a transaction in a Sql script."

C#
public static string sSqlScriptStartTransaction;
Remarks

For internal use.

See Also
InterfacesStringRes Class
Eco.Interfaces Namespace


InterfacesStringRes.sSqlScriptTerminator Property

InterfacesStringRes.sSqlScriptTerminator Property
InterfacesStringRes Class Eco.Interfaces Namespace See Also
Collapse All

Returns: "Token that terminates a command in a Sql script (will be placed at the end of commands)."

C#
public static string sSqlScriptTerminator;
Remarks

For internal use.

See Also
InterfacesStringRes Class
Eco.Interfaces Namespace


InterfacesStringRes.sSqlStringQuoteChar Property

InterfacesStringRes.sSqlStringQuoteChar Property
InterfacesStringRes Class Eco.Interfaces Namespace See Also
Collapse All

Returns: "This will be used to surround string literals in sql commands"

C#
public static string sSqlStringQuoteChar;
Remarks

For internal use.

See Also
InterfacesStringRes Class
Eco.Interfaces Namespace


InterfacesStringRes.sStringTooLong Property

InterfacesStringRes.sStringTooLong Property
InterfacesStringRes Class Eco.Interfaces Namespace See Also
Collapse All

Returns: "String too long to be converted to a char"

C#
public static string sStringTooLong;
Remarks

For internal use.

See Also
InterfacesStringRes Class
Eco.Interfaces Namespace


InterfacesStringRes.sUMVUseTimeStampRequired Property

InterfacesStringRes.sUMVUseTimeStampRequired Property
InterfacesStringRes Class Eco.Interfaces Namespace See Also
Collapse All

Returns: "148 Model has versioned classes, but the SQLDatabaseConfig does not have UseTimeStamp set to true"

C#
public static string sUMVUseTimeStampRequired;
Remarks

For internal use.

See Also
InterfacesStringRes Class
Eco.Interfaces Namespace


InterfacesStringRes.sUnableToFindImplementor Property

InterfacesStringRes.sUnableToFindImplementor Property
InterfacesStringRes Class Eco.Interfaces Namespace See Also
Collapse All

Returns: "Unable to find IAutoIncAttributeMapping for "AutoInc", please update your SqlDatabaseConfig.PersistenceMappers"

C#
public static string sUnableToFindImplementor;
Remarks

For internal use.

See Also
InterfacesStringRes Class
Eco.Interfaces Namespace


InterfacesStringRes.sUnknownClassifierType Property

InterfacesStringRes.sUnknownClassifierType Property
InterfacesStringRes Class Eco.Interfaces Namespace See Also
Collapse All

Returns: "unknown classifier type"

C#
public static string sUnknownClassifierType;
Remarks

For internal use.

See Also
InterfacesStringRes Class
Eco.Interfaces Namespace


InterfacesStringRes.sUnknownClassifierTypeForElement Property

InterfacesStringRes.sUnknownClassifierTypeForElement Property
InterfacesStringRes Class Eco.Interfaces Namespace See Also
Collapse All

Returns: "unknown classifier type for element"

C#
public static string sUnknownClassifierTypeForElement;
Remarks

For internal use.

See Also
InterfacesStringRes Class
Eco.Interfaces Namespace


InterfacesStringRes.sUpperCaseFunctionName Property

InterfacesStringRes.sUpperCaseFunctionName Property
InterfacesStringRes Class Eco.Interfaces Namespace See Also
Collapse All

Returns: "In most databases, this should be "UPPER", in MSAccess, this should be "UCASE""

C#
public static string sUpperCaseFunctionName;
Remarks

For internal use.

See Also
InterfacesStringRes Class
Eco.Interfaces Namespace


InterfacesStringRes.sUseGetAsCollection Property

InterfacesStringRes.sUseGetAsCollection Property
InterfacesStringRes Class Eco.Interfaces Namespace See Also
Collapse All

Returns: "Operation not implemented for collections, use GetAsCollection<T> instead."

C#
public static string sUseGetAsCollection;
Remarks

For internal use.

See Also
InterfacesStringRes Class
Eco.Interfaces Namespace


InterfacesStringRes.sWarning Property

InterfacesStringRes.sWarning Property
InterfacesStringRes Class Eco.Interfaces Namespace See Also
Collapse All

Returns: "WARNING:"

C#
public static string sWarning;
Remarks

For internal use.

See Also
InterfacesStringRes Class
Eco.Interfaces Namespace


Eco.Linq Namespace

Eco.Linq Namespace
Classes
Collapse All

This is namespace Eco.Linq.

Classes
Name | Description
EcoLinqExtender | This is class Eco.Linq.EcoLinqExtender.
EcoQuery | This is class Eco.Linq.EcoQuery.
ProviderException | This is class Eco.Linq.ProviderException.


EcoLinqExtender Class

EcoLinqExtender Class
Inheritance Hierarchy See Also
Collapse All
C#
public static class EcoLinqExtender;
Remarks

This is class Eco.Linq.EcoLinqExtender.

Inheritance Hierarchy
Eco.Linq.EcoLinqExtender
File

EcoQuery.cs

See Also
Inheritance Hierarchy


EcoLinqExtender Methods

EcoLinqExtender Methods
Public Methods
Collapse All

The methods of the EcoLinqExtender class are listed here.

Public Methods
Name | Description
MemQuery | This is MemQuery, a member of class EcoLinqExtender.
PSQuery | This is the overview for the PSQuery method overload.
SqlLike | This is SqlLike, a member of class EcoLinqExtender.
SqlLikeCaseInsensitive | This is SqlLikeCaseInsensitive, a member of class EcoLinqExtender.


EcoLinqExtender.MemQuery Method

EcoLinqExtender.MemQuery Method
EcoLinqExtender Class Eco.Linq Namespace See Also
Collapse All
C#
public static EcoQuery<T> MemQuery<T>(
    this IEcoServiceProvider sp
) where T : class, IEcoObject;
Remarks

This is MemQuery, a member of class EcoLinqExtender.

See Also
EcoLinqExtender Class
Eco.Linq Namespace


PSQuery Method

PSQuery Method

This is the overview for the PSQuery method overload.

Overload List
Name | Description
EcoLinqExtender.PSQuery (this IEcoServiceProvider) | This is PSQuery, a member of class EcoLinqExtender.
EcoLinqExtender.PSQuery (this IEcoServiceProvider, IEcoList<T>) | This is PSQuery, a member of class EcoLinqExtender.


EcoLinqExtender.PSQuery Method (this IEcoServiceProvider)

EcoLinqExtender.PSQuery Method (this IEcoServiceProvider)
EcoLinqExtender Class Eco.Linq Namespace See Also
Collapse All
C#
public static EcoQuery<T> PSQuery<T>(
    this IEcoServiceProvider sp
) where T : class, IEcoObject;
Remarks

This is PSQuery, a member of class EcoLinqExtender.

See Also
EcoLinqExtender Class
Eco.Linq Namespace


EcoLinqExtender.PSQuery Method (this IEcoServiceProvider, IEcoList<T>)

EcoLinqExtender.PSQuery Method (this IEcoServiceProvider, IEcoList<T>)
EcoLinqExtender Class Eco.Linq Namespace See Also
Collapse All
C#
public static EcoQuery<T> PSQuery<T>(
    this IEcoServiceProvider sp,
    IEcoList<T> context
) where T : class, IEcoObject;
Remarks

This is PSQuery, a member of class EcoLinqExtender.

See Also
EcoLinqExtender Class
Eco.Linq Namespace


EcoLinqExtender.SqlLike Method

EcoLinqExtender.SqlLike Method
EcoLinqExtender Class Eco.Linq Namespace See Also
Collapse All
C#
public static bool SqlLike(
    this string s,
    string pattern
);
Remarks

This is SqlLike, a member of class EcoLinqExtender.

See Also
EcoLinqExtender Class
Eco.Linq Namespace


EcoLinqExtender.SqlLikeCaseInsensitive Method

EcoLinqExtender.SqlLikeCaseInsensitive Method
EcoLinqExtender Class Eco.Linq Namespace See Also
Collapse All
C#
public static bool SqlLikeCaseInsensitive(
    this string s,
    string pattern
);
Remarks

This is SqlLikeCaseInsensitive, a member of class EcoLinqExtender.

See Also
EcoLinqExtender Class
Eco.Linq Namespace


EcoQuery Class

EcoQuery Class
Inheritance Hierarchy See Also
Collapse All
C#
public class EcoQuery<T> : IOrderedQueryable<T>, IDisposable, IQueryProvider, IEcoQuery;
Remarks

This is class Eco.Linq.EcoQuery.

Inheritance Hierarchy
Eco.Linq.EcoQuery
File

EcoQuery.cs

See Also
Inheritance Hierarchy


EcoQuery Constructor

EcoQuery Constructor

This is the overview for the EcoQuery constructor overload.

Overload List
Name | Description
EcoQuery.EcoQuery (IEcoServiceProvider) | This is EcoQuery, a member of class EcoQuery.
EcoQuery.EcoQuery (IObject) | This is EcoQuery, a member of class EcoQuery.
EcoQuery.EcoQuery (IObjectList) | This is EcoQuery, a member of class EcoQuery.


EcoQuery.EcoQuery Constructor (IEcoServiceProvider)

EcoQuery.EcoQuery Constructor (IEcoServiceProvider)
EcoQuery Class Eco.Linq Namespace See Also
Collapse All
C#
public EcoQuery(
    IEcoServiceProvider sp
);
Remarks

This is EcoQuery, a member of class EcoQuery.

See Also
EcoQuery Class
Eco.Linq Namespace


EcoQuery.EcoQuery Constructor (IObject)

EcoQuery.EcoQuery Constructor (IObject)
EcoQuery Class Eco.Linq Namespace See Also
Collapse All
C#
public EcoQuery(
    IObject source
);
Remarks

This is EcoQuery, a member of class EcoQuery.

See Also
EcoQuery Class
Eco.Linq Namespace


EcoQuery.EcoQuery Constructor (IObjectList)

EcoQuery.EcoQuery Constructor (IObjectList)
EcoQuery Class Eco.Linq Namespace See Also
Collapse All
C#
public EcoQuery(
    IObjectList source
);
Remarks

This is EcoQuery, a member of class EcoQuery.

See Also
EcoQuery Class
Eco.Linq Namespace


EcoQuery Classes

EcoQuery Classes
Classes
Collapse All

The classes of the EcoQuery class are listed here.

Classes
Name | Description
OutEventArgs | This is class Eco.Linq.EcoQuery.OutEventArgs.


EcoQuery.OutEventArgs Class

EcoQuery.OutEventArgs Class
Inheritance Hierarchy See Also
Collapse All
C#
public class OutEventArgs : EventArgs;
Remarks

This is class Eco.Linq.EcoQuery.OutEventArgs.

Inheritance Hierarchy
Eco.Linq.EcoQuery.OutEventArgs
File

EcoQuery.cs

See Also
Inheritance Hierarchy


OutEventArgs Fields

OutEventArgs Fields
Public Fields
Collapse All

The fields of the OutEventArgs class are listed here.

Public Fields
Name | Description
String | This is String, a member of class OutEventArgs.


EcoQuery.OutEventArgs.String Field

EcoQuery.OutEventArgs.String Field
EcoQuery.OutEventArgs Class Eco.Linq Namespace See Also
Collapse All
C#
public string String;
Remarks

This is String, a member of class OutEventArgs.

See Also
EcoQuery.OutEventArgs Class
Eco.Linq Namespace


EcoQuery Methods

EcoQuery Methods
Public Methods
Collapse All

The methods of the EcoQuery class are listed here.

Public Methods
Name | Description
CreateQuery | This is CreateQuery, a member of class EcoQuery.
Execute | This is Execute, a member of class EcoQuery.
GetEnumerator | This is GetEnumerator, a member of class EcoQuery.


EcoQuery.CreateQuery Method

EcoQuery.CreateQuery Method
EcoQuery Class Eco.Linq Namespace See Also
Collapse All
C#
public IQueryable CreateQuery(
    Expression expression
);
Remarks

This is CreateQuery, a member of class EcoQuery.

See Also
EcoQuery Class
Eco.Linq Namespace


EcoQuery.Execute Method

EcoQuery.Execute Method
EcoQuery Class Eco.Linq Namespace See Also
Collapse All
C#
public object Execute(
    Expression expression
);
Remarks

This is Execute, a member of class EcoQuery.

See Also
EcoQuery Class
Eco.Linq Namespace


EcoQuery.GetEnumerator Method

EcoQuery.GetEnumerator Method
EcoQuery Class Eco.Linq Namespace See Also
Collapse All
C#
public IEnumerator<T> GetEnumerator();
Remarks

This is GetEnumerator, a member of class EcoQuery.

See Also
EcoQuery Class
Eco.Linq Namespace


EcoQuery Properties

EcoQuery Properties
Public Properties
Collapse All

The properties of the EcoQuery class are listed here.

Public Properties
Name | Description
ElementType | This is ElementType, a member of class EcoQuery.
Expression | This is Expression, a member of class EcoQuery.
InPS | This is InPS, a member of class EcoQuery.
Provider | This is Provider, a member of class EcoQuery.
TypeSystem | This is TypeSystem, a member of class EcoQuery.
VariableFactory | This is VariableFactory, a member of class EcoQuery.


EcoQuery.ElementType Property

EcoQuery.ElementType Property
EcoQuery Class Eco.Linq Namespace See Also
Collapse All
C#
public Type ElementType;
Remarks

This is ElementType, a member of class EcoQuery.

See Also
EcoQuery Class
Eco.Linq Namespace


EcoQuery.Expression Property

EcoQuery.Expression Property
EcoQuery Class Eco.Linq Namespace See Also
Collapse All
C#
public Expression Expression;
Remarks

This is Expression, a member of class EcoQuery.

See Also
EcoQuery Class
Eco.Linq Namespace


EcoQuery.InPS Property

EcoQuery.InPS Property
EcoQuery Class Eco.Linq Namespace See Also
Collapse All
C#
public bool InPS;
Remarks

This is InPS, a member of class EcoQuery.

See Also
EcoQuery Class
Eco.Linq Namespace


EcoQuery.Provider Property

EcoQuery.Provider Property
EcoQuery Class Eco.Linq Namespace See Also
Collapse All
C#
public IQueryProvider Provider;
Remarks

This is Provider, a member of class EcoQuery.

See Also
EcoQuery Class
Eco.Linq Namespace


EcoQuery.TypeSystem Property

EcoQuery.TypeSystem Property
EcoQuery Class Eco.Linq Namespace See Also
Collapse All
C#
public IEcoTypeSystem TypeSystem;
Remarks

This is TypeSystem, a member of class EcoQuery.

See Also
EcoQuery Class
Eco.Linq Namespace


EcoQuery.VariableFactory Property

EcoQuery.VariableFactory Property
EcoQuery Class Eco.Linq Namespace See Also
Collapse All
C#
public IVariableFactoryService VariableFactory;
Remarks

This is VariableFactory, a member of class EcoQuery.

See Also
EcoQuery Class
Eco.Linq Namespace


EcoQuery Delegates

EcoQuery Delegates
Public Delegates Public Delegates See Also
Collapse All

The delegates of the EcoQuery class are listed here.

Public Delegates
Name | Description
ErrorHandler | This is nested type Eco.Linq.EcoQuery.ErrorHandler.
Top
See Also
Public Delegates


EcoQuery.ErrorHandler Delegate

EcoQuery.ErrorHandler Delegate
EcoQuery Class Eco.Linq Namespace See Also
Collapse All
C#
public delegate void ErrorHandler(ProviderException providerException);
Remarks

This is nested type Eco.Linq.EcoQuery.ErrorHandler.

See Also
EcoQuery Class
Eco.Linq Namespace


EcoQuery Events

EcoQuery Events
Public Events
Collapse All

The events of the EcoQuery class are listed here.

Public Events
Name | Description
OnError | This is OnError, a member of class EcoQuery.
ParseOut | This is ParseOut, a member of class EcoQuery.


EcoQuery.OnError Event

EcoQuery.OnError Event
EcoQuery Class Eco.Linq Namespace See Also
Collapse All
C#
public event ErrorHandler OnError;
Remarks

This is OnError, a member of class EcoQuery.

See Also
EcoQuery Class
Eco.Linq Namespace


EcoQuery.ParseOut Event

EcoQuery.ParseOut Event
EcoQuery Class Eco.Linq Namespace See Also
Collapse All
C#
public event EventHandler<OutEventArgs> ParseOut;
Remarks

This is ParseOut, a member of class EcoQuery.

See Also
EcoQuery Class
Eco.Linq Namespace


ProviderException Class

ProviderException Class
Inheritance Hierarchy See Also
Collapse All
C#
public class ProviderException : Exception;
Remarks

This is class Eco.Linq.ProviderException.

Inheritance Hierarchy
Eco.Linq.ProviderException
File

ProviderException.cs

See Also
Inheritance Hierarchy


ProviderException Constructor

ProviderException Constructor

This is the overview for the ProviderException constructor overload.

Overload List
Name | Description
ProviderException.ProviderException (string) | This is ProviderException, a member of class ProviderException.
ProviderException.ProviderException (string, Exception) | This is ProviderException, a member of class ProviderException.


ProviderException.ProviderException Constructor (string)

ProviderException.ProviderException Constructor (string)
ProviderException Class Eco.Linq Namespace See Also
Collapse All
C#
public ProviderException(
    string message
);
Remarks

This is ProviderException, a member of class ProviderException.

See Also
ProviderException Class
Eco.Linq Namespace


ProviderException.ProviderException Constructor (string, Exception)

ProviderException.ProviderException Constructor (string, Exception)
ProviderException Class Eco.Linq Namespace See Also
Collapse All
C#
public ProviderException(
    string message,
    Exception ex
);
Remarks

This is ProviderException, a member of class ProviderException.

See Also
ProviderException Class
Eco.Linq Namespace


Eco.Logging Namespace

Eco.Logging Namespace
Classes Interfaces Types
Collapse All

This is namespace Eco.Logging.

Classes
Name | Description
EcoListener | EcoListener is a TraceListener with some additional functionality to plug itself into and out of the listener collection. When a Trace.Write* is captured, the category is compared with the Eco categories and if the category is indeed an ECO category, the event OnTraceLog is triggered. This class can - but must not necessarily - be subclassed.
EcoLogSwitches | This class controls what kind of log messages are being issues by ECO.
EcoTraceCategories | This class contains the categories used by the ECO logging mechanism.
OclTraceSwitch | This is class Eco.Logging.OclTraceSwitch.
PMapperTraceSwitch | This is class Eco.Logging.PMapperTraceSwitch.
RegionTraceSwitch | This is class Eco.Logging.RegionTraceSwitch.
SqlMetaTraceSwitch | This is class Eco.Logging.SqlMetaTraceSwitch.
SqlTraceSwitch | This is class Eco.Logging.SqlTraceSwitch.
TraceEventArgs | This is class Eco.Logging.TraceEventArgs.
ValidationTraceSwitch | This is class Eco.Logging.ValidationTraceSwitch.
Top
Interfaces
Name | Description
IMessageDisplay | This is class Eco.Logging.IMessageDisplay.
Top
Types
Name | Description
TraceLogHandler | This is type Eco.Logging.TraceLogHandler.


EcoListener Class

EcoListener Class
Inheritance Hierarchy See Also
Collapse All

EcoListener is a TraceListener with some additional functionality to plug itself into and out of the listener collection. When a Trace.Write* is captured, the category is compared with the Eco categories and if the category is indeed an ECO category, the event OnTraceLog is triggered. This class can - but must not necessarily - be subclassed.

C#
public class EcoListener : TraceListener;
Inheritance Hierarchy
Eco.Logging.EcoListener
File

LogTracers.cs

See Also
Inheritance Hierarchy


EcoListener.EcoListener Constructor

EcoListener.EcoListener Constructor
EcoListener Class Eco.Logging Namespace See Also
Collapse All
C#
protected EcoListener();
Remarks

This is EcoListener, a member of class EcoListener.

See Also
EcoListener Class
Eco.Logging Namespace


EcoListener Fields

EcoListener Fields
Public Fields
Collapse All

The fields of the EcoListener class are listed here.

Public Fields
Name | Description
Singleton | A singleton instance of this class.


EcoListener.Singleton Field

EcoListener.Singleton Field
EcoListener Class Eco.Logging Namespace See Also
Collapse All

A singleton instance of this class.

C#
public static readonly EcoListener Singleton = new EcoListener();
See Also
EcoListener Class
Eco.Logging Namespace


EcoListener Methods

EcoListener Methods
Protected Methods Public Methods
Collapse All

The methods of the EcoListener class are listed here.

Protected Methods
Name | Description
DoTraceMessage | Spawns the OnTraceLog events listeners.
Top
Public Methods
Name | Description
Close | Flags the listener as closed. No events will be triggered when the listener is closed.
Flush | Empty implementation
Open | Flags the listener as open (the default state). Can be called after Close to resume listening.
RemoveDefaultListener | Removes the DefaultTraceListener from Trace.Listeners.
StartListening | Makes sure Singleton is inserted into Trace.Listeners. Increases a reference count.
StopAllListening | Sets the reference count to zero and removes Singleton from Trace.Listeners.
StopListening | Decreases the reference count. If it reaches zero, Singleton is removed from the list of Trace.Listeners.
Write | This is the overview for the Write method overload.
WriteLine | This is the overview for the WriteLine method overload.


EcoListener.Close Method

EcoListener.Close Method
EcoListener Class Eco.Logging Namespace See Also
Collapse All

Flags the listener as closed. No events will be triggered when the listener is closed.

C#
public override void Close();
See Also
EcoListener Class
Eco.Logging Namespace


EcoListener.DoTraceMessage Method

EcoListener.DoTraceMessage Method
EcoListener Class Eco.Logging Namespace See Also
Collapse All

Spawns the OnTraceLog events listeners.

C#
protected void DoTraceMessage(
    string message,
    string category
);
See Also
EcoListener Class
Eco.Logging Namespace


EcoListener.Flush Method

EcoListener.Flush Method
EcoListener Class Eco.Logging Namespace See Also
Collapse All

Empty implementation

C#
public override void Flush();
See Also
EcoListener Class
Eco.Logging Namespace


EcoListener.Open Method

EcoListener.Open Method
EcoListener Class Eco.Logging Namespace See Also
Collapse All

Flags the listener as open (the default state). Can be called after Close to resume listening.

C#
public virtual void Open();
See Also
EcoListener Class
Eco.Logging Namespace


EcoListener.RemoveDefaultListener Method

EcoListener.RemoveDefaultListener Method
EcoListener Class Eco.Logging Namespace See Also
Collapse All

Removes the DefaultTraceListener from Trace.Listeners.

C#
public static void RemoveDefaultListener();
See Also
EcoListener Class
Eco.Logging Namespace


EcoListener.StartListening Method

EcoListener.StartListening Method
EcoListener Class Eco.Logging Namespace See Also
Collapse All

Makes sure Singleton is inserted into Trace.Listeners. Increases a reference count.

C#
public static void StartListening();
See Also
EcoListener Class
Eco.Logging Namespace


EcoListener.StopAllListening Method

EcoListener.StopAllListening Method
EcoListener Class Eco.Logging Namespace See Also
Collapse All

Sets the reference count to zero and removes Singleton from Trace.Listeners.

C#
public static void StopAllListening();
See Also
EcoListener Class
Eco.Logging Namespace


EcoListener.StopListening Method

EcoListener.StopListening Method
EcoListener Class Eco.Logging Namespace See Also
Collapse All

Decreases the reference count. If it reaches zero, Singleton is removed from the list of Trace.Listeners.

C#
public static void StopListening();
See Also
EcoListener Class
Eco.Logging Namespace


Write Method

Write Method

This is the overview for the Write method overload.

Overload List
Name | Description
EcoListener.Write (object) | Empty implementation
EcoListener.Write (object, string) | Calls Write(string, string)(value.ToString(), category)
EcoListener.Write (string) | Empty implementation
EcoListener.Write (string, string) | If the state of the listened is Open and the category is one of the ECO categories, the OnTraceLog event is triggered.


EcoListener.Write Method (object)

EcoListener.Write Method (object)
EcoListener Class Eco.Logging Namespace See Also
Collapse All

Empty implementation

C#
public override void Write(
    object o
);
See Also
EcoListener Class
Eco.Logging Namespace


EcoListener.Write Method (object, string)

EcoListener.Write Method (object, string)
EcoListener Class Eco.Logging Namespace See Also
Collapse All

Calls Write(string, string)(value.ToString(), category)

C#
public override void Write(
    object o,
    string category
);
See Also
EcoListener Class
Eco.Logging Namespace


EcoListener.Write Method (string)

EcoListener.Write Method (string)
EcoListener Class Eco.Logging Namespace See Also
Collapse All

Empty implementation

C#
public override void Write(
    string message
);
See Also
EcoListener Class
Eco.Logging Namespace


EcoListener.Write Method (string, string)

EcoListener.Write Method (string, string)
EcoListener Class Eco.Logging Namespace See Also
Collapse All

If the state of the listened is Open and the category is one of the ECO categories, the OnTraceLog event is triggered.

C#
public override void Write(
    string message,
    string category
);
See Also
EcoListener Class
Eco.Logging Namespace


WriteLine Method

WriteLine Method

This is the overview for the WriteLine method overload.

Overload List
Name | Description
EcoListener.WriteLine (object) | Empty implementation
EcoListener.WriteLine (object, string) | Invokes WriteLine(string, string) with value.ToString().
EcoListener.WriteLine (string) | Empty implementation
EcoListener.WriteLine (string, string) | Invokes Write(string, string) with a CRLF appended to the string.


EcoListener.WriteLine Method (object)

EcoListener.WriteLine Method (object)
EcoListener Class Eco.Logging Namespace See Also
Collapse All

Empty implementation

C#
public override void WriteLine(
    object o
);
See Also
EcoListener Class
Eco.Logging Namespace


EcoListener.WriteLine Method (object, string)

EcoListener.WriteLine Method (object, string)
EcoListener Class Eco.Logging Namespace See Also
Collapse All

Invokes WriteLine(string, string) with value.ToString().

C#
public override void WriteLine(
    object o,
    string category
);
See Also
EcoListener Class
Eco.Logging Namespace


EcoListener.WriteLine Method (string)

EcoListener.WriteLine Method (string)
EcoListener Class Eco.Logging Namespace See Also
Collapse All

Empty implementation

C#
public override void WriteLine(
    string message
);
See Also
EcoListener Class
Eco.Logging Namespace


EcoListener.WriteLine Method (string, string)

EcoListener.WriteLine Method (string, string)
EcoListener Class Eco.Logging Namespace See Also
Collapse All

Invokes Write(string, string) with a CRLF appended to the string.

C#
public override void WriteLine(
    string message,
    string category
);
See Also
EcoListener Class
Eco.Logging Namespace


EcoListener Events

EcoListener Events
Public Events
Collapse All

The events of the EcoListener class are listed here.

Public Events
Name | Description
OnTraceLog | Triggered when a trace-message beloning to an ECO category is intercepted.


EcoListener.OnTraceLog Event

EcoListener.OnTraceLog Event
EcoListener Class Eco.Logging Namespace See Also
Collapse All

Triggered when a trace-message beloning to an ECO category is intercepted.

C#
public event TraceLogHandler OnTraceLog;
See Also
EcoListener Class
Eco.Logging Namespace


EcoLogSwitches Class

EcoLogSwitches Class
Inheritance Hierarchy See Also
Collapse All

This class controls what kind of log messages are being issues by ECO.

C#
public sealed class EcoLogSwitches;
Inheritance Hierarchy
Eco.Logging.EcoLogSwitches
File

LogTracers.cs

See Also
Inheritance Hierarchy


EcoLogSwitches Methods

EcoLogSwitches Methods
Public Methods
Collapse All

The methods of the EcoLogSwitches class are listed here.

Public Methods
Name | Description
RestoreDefaultLogStates | This method restores all eco log switches to the value of DefaultLogState.


EcoLogSwitches.RestoreDefaultLogStates Method

EcoLogSwitches.RestoreDefaultLogStates Method
EcoLogSwitches Class Eco.Logging Namespace See Also
Collapse All

This method restores all eco log switches to the value of DefaultLogState.

C#
public static void RestoreDefaultLogStates();
See Also
EcoLogSwitches Class
Eco.Logging Namespace


EcoLogSwitches Properties

EcoLogSwitches Properties
Public Properties
Collapse All

The properties of the EcoLogSwitches class are listed here.

Public Properties
Name | Description
DefaultLogState | Default state for all classes of tracing.
LogOcl | Detemines if Ocl class messages are traced.
LogPMapper | Detemines if PMapper class messages are traced.
LogRegions | Detemines if Region class messages are traced.
LogSql | Detemines if Sql class messages are traced.
LogSqlMeta | Detemines if SqlMeta class messages are traced.
LogValidation | Detemines if Validation class messages are traced.


EcoLogSwitches.DefaultLogState Property

EcoLogSwitches.DefaultLogState Property
EcoLogSwitches Class Eco.Logging Namespace See Also
Collapse All

Default state for all classes of tracing.

C#
public static bool DefaultLogState;
See Also
EcoLogSwitches Class
Eco.Logging Namespace


EcoLogSwitches.LogOcl Property

EcoLogSwitches.LogOcl Property
EcoLogSwitches Class Eco.Logging Namespace See Also
Collapse All

Detemines if Ocl class messages are traced.

C#
public static bool LogOcl;
See Also
EcoLogSwitches Class
Eco.Logging Namespace


EcoLogSwitches.LogPMapper Property

EcoLogSwitches.LogPMapper Property
EcoLogSwitches Class Eco.Logging Namespace See Also
Collapse All

Detemines if PMapper class messages are traced.

C#
public static bool LogPMapper;
See Also
EcoLogSwitches Class
Eco.Logging Namespace


EcoLogSwitches.LogRegions Property

EcoLogSwitches.LogRegions Property
EcoLogSwitches Class Eco.Logging Namespace See Also
Collapse All

Detemines if Region class messages are traced.

C#
public static bool LogRegions;
See Also
EcoLogSwitches Class
Eco.Logging Namespace


EcoLogSwitches.LogSql Property

EcoLogSwitches.LogSql Property
EcoLogSwitches Class Eco.Logging Namespace See Also
Collapse All

Detemines if Sql class messages are traced.

C#
public static bool LogSql;
See Also
EcoLogSwitches Class
Eco.Logging Namespace


EcoLogSwitches.LogSqlMeta Property

EcoLogSwitches.LogSqlMeta Property
EcoLogSwitches Class Eco.Logging Namespace See Also
Collapse All

Detemines if SqlMeta class messages are traced.

C#
public static bool LogSqlMeta;
See Also
EcoLogSwitches Class
Eco.Logging Namespace


EcoLogSwitches.LogValidation Property

EcoLogSwitches.LogValidation Property
EcoLogSwitches Class Eco.Logging Namespace See Also
Collapse All

Detemines if Validation class messages are traced.

C#
public static bool LogValidation;
See Also
EcoLogSwitches Class
Eco.Logging Namespace


EcoTraceCategories Class

EcoTraceCategories Class
Inheritance Hierarchy See Also
Collapse All

This class contains the categories used by the ECO logging mechanism.

C#
public sealed class EcoTraceCategories;
Inheritance Hierarchy
Eco.Logging.EcoTraceCategories
File

LogTracers.cs

See Also
Inheritance Hierarchy


EcoTraceCategories Fields

EcoTraceCategories Fields
Public Fields
Collapse All

The fields of the EcoTraceCategories class are listed here.

Public Fields
Name | Description
Ocl | Category used for OCL-related events.
PMapper | Category used for Persistence mapper related events.
Regions | Category used for region-related events.
Sql | Category used for SQL-related events.
SqlMeta | Category used for SQL meta data-related events.
SqlParams | Category used for SQL-parameters.
Validation | Category used for validation-related events (model, schema, data).


EcoTraceCategories.Ocl Field

EcoTraceCategories.Ocl Field
EcoTraceCategories Class Eco.Logging Namespace See Also
Collapse All

Category used for OCL-related events.

C#
public const string Ocl = "Eco.Ocl";
See Also
EcoTraceCategories Class
Eco.Logging Namespace


EcoTraceCategories.PMapper Field

EcoTraceCategories.PMapper Field
EcoTraceCategories Class Eco.Logging Namespace See Also
Collapse All

Category used for Persistence mapper related events.

C#
public const string PMapper = "Eco.PMapper";
See Also
EcoTraceCategories Class
Eco.Logging Namespace


EcoTraceCategories.Regions Field

EcoTraceCategories.Regions Field
EcoTraceCategories Class Eco.Logging Namespace See Also
Collapse All

Category used for region-related events.

C#
public const string Regions = "Eco.Regions";
See Also
EcoTraceCategories Class
Eco.Logging Namespace


EcoTraceCategories.Sql Field

EcoTraceCategories.Sql Field
EcoTraceCategories Class Eco.Logging Namespace See Also
Collapse All

Category used for SQL-related events.

C#
public const string Sql = "Eco.Sql";
See Also
EcoTraceCategories Class
Eco.Logging Namespace


EcoTraceCategories.SqlMeta Field

EcoTraceCategories.SqlMeta Field
EcoTraceCategories Class Eco.Logging Namespace See Also
Collapse All

Category used for SQL meta data-related events.

C#
public const string SqlMeta = "Eco.SqlMeta";
See Also
EcoTraceCategories Class
Eco.Logging Namespace


EcoTraceCategories.SqlParams Field

EcoTraceCategories.SqlParams Field
EcoTraceCategories Class Eco.Logging Namespace See Also
Collapse All

Category used for SQL-parameters.

C#
public const string SqlParams = "Eco.SqlParams";
See Also
EcoTraceCategories Class
Eco.Logging Namespace


EcoTraceCategories.Validation Field

EcoTraceCategories.Validation Field
EcoTraceCategories Class Eco.Logging Namespace See Also
Collapse All

Category used for validation-related events (model, schema, data).

C#
public const string Validation = "Eco.Validation";
See Also
EcoTraceCategories Class
Eco.Logging Namespace


EcoTraceCategories Methods

EcoTraceCategories Methods
Public Methods
Collapse All

The methods of the EcoTraceCategories class are listed here.

Public Methods
Name | Description
IsEcoCategory | Function to determine if a string is one of the pre-defined categories.


EcoTraceCategories.IsEcoCategory Method

EcoTraceCategories.IsEcoCategory Method
EcoTraceCategories Class Eco.Logging Namespace See Also
Collapse All

Function to determine if a string is one of the pre-defined categories.

C#
public static bool IsEcoCategory(
    string category
);
See Also
EcoTraceCategories Class
Eco.Logging Namespace


EcoTraceCategories Properties

EcoTraceCategories Properties
Public Properties
Collapse All

The properties of the EcoTraceCategories class are listed here.

Public Properties
Name | Description
Separator | String constant used as separator in trace sequences.


EcoTraceCategories.Separator Property

EcoTraceCategories.Separator Property
EcoTraceCategories Class Eco.Logging Namespace See Also
Collapse All

String constant used as separator in trace sequences.

C#
public static string Separator;
See Also
EcoTraceCategories Class
Eco.Logging Namespace


OclTraceSwitch Class

OclTraceSwitch Class
Inheritance Hierarchy See Also
Collapse All
C#
public class OclTraceSwitch : BooleanSwitch;
Remarks

This is class Eco.Logging.OclTraceSwitch.

Inheritance Hierarchy
Eco.Logging.OclTraceSwitch
File

LogTracers.cs

See Also
Inheritance Hierarchy


PMapperTraceSwitch Class

PMapperTraceSwitch Class
Inheritance Hierarchy See Also
Collapse All
C#
public class PMapperTraceSwitch : BooleanSwitch;
Remarks

This is class Eco.Logging.PMapperTraceSwitch.

Inheritance Hierarchy
Eco.Logging.PMapperTraceSwitch
File

LogTracers.cs

See Also
Inheritance Hierarchy


RegionTraceSwitch Class

RegionTraceSwitch Class
Inheritance Hierarchy See Also
Collapse All
C#
public class RegionTraceSwitch : BooleanSwitch;
Remarks

This is class Eco.Logging.RegionTraceSwitch.

Inheritance Hierarchy
Eco.Logging.RegionTraceSwitch
File

LogTracers.cs

See Also
Inheritance Hierarchy


SqlMetaTraceSwitch Class

SqlMetaTraceSwitch Class
Inheritance Hierarchy See Also
Collapse All
C#
public class SqlMetaTraceSwitch : BooleanSwitch;
Remarks

This is class Eco.Logging.SqlMetaTraceSwitch.

Inheritance Hierarchy
Eco.Logging.SqlMetaTraceSwitch
File

LogTracers.cs

See Also
Inheritance Hierarchy


SqlTraceSwitch Class

SqlTraceSwitch Class
Inheritance Hierarchy See Also
Collapse All
C#
public class SqlTraceSwitch : BooleanSwitch;
Remarks

This is class Eco.Logging.SqlTraceSwitch.

Inheritance Hierarchy
Eco.Logging.SqlTraceSwitch
File

LogTracers.cs

See Also
Inheritance Hierarchy


TraceEventArgs Class

TraceEventArgs Class
Inheritance Hierarchy See Also
Collapse All
C#
public class TraceEventArgs;
Remarks

This is class Eco.Logging.TraceEventArgs.

Inheritance Hierarchy
Eco.Logging.TraceEventArgs
File

LogTracers.cs

See Also
Inheritance Hierarchy


TraceEventArgs.TraceEventArgs Constructor

TraceEventArgs.TraceEventArgs Constructor
TraceEventArgs Class Eco.Logging Namespace See Also
Collapse All
C#
public TraceEventArgs(
    string message,
    string category
);
Remarks

This is TraceEventArgs, a member of class TraceEventArgs.

See Also
TraceEventArgs Class
Eco.Logging Namespace


TraceEventArgs Methods

TraceEventArgs Methods
Public Methods
Collapse All

The methods of the TraceEventArgs class are listed here.

Public Methods
Name | Description
ToString | This is ToString, a member of class TraceEventArgs.


TraceEventArgs.ToString Method

TraceEventArgs.ToString Method
TraceEventArgs Class Eco.Logging Namespace See Also
Collapse All
C#
public override string ToString();
Remarks

This is ToString, a member of class TraceEventArgs.

See Also
TraceEventArgs Class
Eco.Logging Namespace


TraceEventArgs Properties

TraceEventArgs Properties
Public Properties
Collapse All

The properties of the TraceEventArgs class are listed here.

Public Properties
Name | Description
Category | This is Category, a member of class TraceEventArgs.
Message | This is Message, a member of class TraceEventArgs.


TraceEventArgs.Category Property

TraceEventArgs.Category Property
TraceEventArgs Class Eco.Logging Namespace See Also
Collapse All
C#
public string Category;
Remarks

This is Category, a member of class TraceEventArgs.

See Also
TraceEventArgs Class
Eco.Logging Namespace


TraceEventArgs.Message Property

TraceEventArgs.Message Property
TraceEventArgs Class Eco.Logging Namespace See Also
Collapse All
C#
public string Message;
Remarks

This is Message, a member of class TraceEventArgs.

See Also
TraceEventArgs Class
Eco.Logging Namespace


ValidationTraceSwitch Class

ValidationTraceSwitch Class
Inheritance Hierarchy See Also
Collapse All
C#
public class ValidationTraceSwitch : BooleanSwitch;
Remarks

This is class Eco.Logging.ValidationTraceSwitch.

Inheritance Hierarchy
Eco.Logging.ValidationTraceSwitch
File

LogTracers.cs

See Also
Inheritance Hierarchy


IMessageDisplay Interface

IMessageDisplay Interface
Inheritance Hierarchy See Also
Collapse All
C#
public interface IMessageDisplay;
Remarks

This is class Eco.Logging.IMessageDisplay.

Inheritance Hierarchy
Eco.Logging.IMessageDisplay
File

LogInterfaces.cs

See Also
Inheritance Hierarchy


IMessageDisplay Methods

IMessageDisplay Methods
Public Methods
Collapse All

The methods of the IMessageDisplay class are listed here.

Public Methods
Name | Description
AddMessage | This is the overview for the AddMessage method overload.


AddMessage Method

AddMessage Method

This is the overview for the AddMessage method overload.

Overload List
Name | Description
IMessageDisplay.AddMessage (string) | This is AddMessage, a member of class IMessageDisplay.
IMessageDisplay.AddMessage (string, string) | This is AddMessage, a member of class IMessageDisplay.


IMessageDisplay.AddMessage Method (string)

IMessageDisplay.AddMessage Method (string)
IMessageDisplay Interface Eco.Logging Namespace See Also
Collapse All
C#
void AddMessage(
    string message
);
Remarks

This is AddMessage, a member of class IMessageDisplay.

See Also
IMessageDisplay Interface
Eco.Logging Namespace


IMessageDisplay.AddMessage Method (string, string)

IMessageDisplay.AddMessage Method (string, string)
IMessageDisplay Interface Eco.Logging Namespace See Also
Collapse All
C#
void AddMessage(
    string title,
    string message
);
Remarks

This is AddMessage, a member of class IMessageDisplay.

See Also
IMessageDisplay Interface
Eco.Logging Namespace


Eco.Logging.TraceLogHandler Type

Eco.Logging.TraceLogHandler Type
C#
public delegate void TraceLogHandler(object sender, TraceEventArgs e);
Remarks

This is type Eco.Logging.TraceLogHandler.

File

LogTracers.cs


Eco.MySql.FullTextSupport Namespace

Eco.MySql.FullTextSupport Namespace
Classes
Collapse All

This is namespace Eco.MySql.FullTextSupport.

Classes
Name | Description
FullTextIndexer | This is class Eco.MySql.FullTextSupport.FullTextIndexer.


FullTextIndexer Class

FullTextIndexer Class
Inheritance Hierarchy See Also
Collapse All
C#
public class FullTextIndexer;
Remarks

This is class Eco.MySql.FullTextSupport.FullTextIndexer.

Inheritance Hierarchy
Eco.MySql.FullTextSupport.FullTextIndexer
File

FullTextIndexSupport.cs

See Also
Inheritance Hierarchy


FullTextIndexer Methods

FullTextIndexer Methods
Public Methods
Collapse All

The methods of the FullTextIndexer class are listed here.

Public Methods
Name | Description
AddFullTexIndex | This is AddFullTexIndex, a member of class FullTextIndexer.


FullTextIndexer.AddFullTexIndex Method

FullTextIndexer.AddFullTexIndex Method
FullTextIndexer Class Eco.MySql.FullTextSupport Namespace See Also
Collapse All
C#
public void AddFullTexIndex(
    PersistenceMapperDb pmapper,
    IEcoTypeSystem typeSystem
);
Remarks

This is AddFullTexIndex, a member of class FullTextIndexer.

See Also
FullTextIndexer Class
Eco.MySql.FullTextSupport Namespace


Eco.ObjectImplementation Namespace

Eco.ObjectImplementation Namespace
Classes Interfaces
Collapse All

This is namespace Eco.ObjectImplementation.

Classes
Name | Description
EcoListShimBase | This is class Eco.ObjectImplementation.EcoListShimBase.
EcoObjectListAdapter | This is class Eco.ObjectImplementation.EcoObjectListAdapter.
ObjectEnumeratorAdapter | This is class Eco.ObjectImplementation.ObjectEnumeratorAdapter.
ObjectListAdapter | Obsolete("The value returned by get_MemberByIndex can be cast to IEcoListdirectly")
ObjectListAdapterX | This is class Eco.ObjectImplementation.ObjectListAdapterX.
StateName | This is class Eco.ObjectImplementation.StateName.
Top
Interfaces
Name | Description
IContent | This is class Eco.ObjectImplementation.IContent.
IEcoList | Sub interface of IList<T> that allows navigation back to the IElement world
IInternalObjectContentFactory | This is class Eco.ObjectImplementation.IInternalObjectContentFactory.
ILoopBack | This is class Eco.ObjectImplementation.ILoopBack.
ILoopBack2 | This is class Eco.ObjectImplementation.ILoopBack2.


EcoListShimBase Class

EcoListShimBase Class
Inheritance Hierarchy See Also
Collapse All
C#
public class EcoListShimBase<T> : IEcoList<T>, IList where T : class, IEcoObject;
Remarks

This is class Eco.ObjectImplementation.EcoListShimBase.

Inheritance Hierarchy
Eco.ObjectImplementation.IEcoList
    Eco.ObjectImplementation.EcoListShimBase
        Eco.ObjectImplementation.ObjectListAdapter
File

ObjectImplementation.cs

See Also
Inheritance Hierarchy


EcoListShimBase.EcoListShimBase Constructor

EcoListShimBase.EcoListShimBase Constructor
EcoListShimBase Class Eco.ObjectImplementation Namespace See Also
Collapse All
C#
public EcoListShimBase(
    IEcoList<T> adaptee
);
Remarks

This is EcoListShimBase, a member of class EcoListShimBase.

See Also
EcoListShimBase Class
Eco.ObjectImplementation Namespace


EcoListShimBase Methods

EcoListShimBase Methods
Public Methods
Collapse All

The methods of the EcoListShimBase class are listed here.

Public Methods
Name | Description
Add | This is Add, a member of class EcoListShimBase.
Clear | This is Clear, a member of class EcoListShimBase.
Contains | This is Contains, a member of class EcoListShimBase.
CopyTo | This is CopyTo, a member of class EcoListShimBase.
GetEnumerator | This is GetEnumerator, a member of class EcoListShimBase.
IndexOf | This is IndexOf, a member of class EcoListShimBase.
Insert | This is Insert, a member of class EcoListShimBase.
Remove | This is Remove, a member of class EcoListShimBase.
RemoveAt | This is RemoveAt, a member of class EcoListShimBase.
this | This is this, a member of class EcoListShimBase.


EcoListShimBase.Add Method

EcoListShimBase.Add Method
EcoListShimBase Class Eco.ObjectImplementation Namespace See Also
Collapse All
C#
public virtual void Add(
    T item
);
Remarks

This is Add, a member of class EcoListShimBase.

See Also
EcoListShimBase Class
Eco.ObjectImplementation Namespace


EcoListShimBase.Clear Method

EcoListShimBase.Clear Method
EcoListShimBase Class Eco.ObjectImplementation Namespace See Also
Collapse All
C#
public virtual void Clear();
Remarks

This is Clear, a member of class EcoListShimBase.

See Also
EcoListShimBase Class
Eco.ObjectImplementation Namespace


EcoListShimBase.Contains Method

EcoListShimBase.Contains Method
EcoListShimBase Class Eco.ObjectImplementation Namespace See Also
Collapse All
C#
public virtual bool Contains(
    T item
);
Remarks

This is Contains, a member of class EcoListShimBase.

See Also
EcoListShimBase Class
Eco.ObjectImplementation Namespace


EcoListShimBase.CopyTo Method

EcoListShimBase.CopyTo Method
EcoListShimBase Class Eco.ObjectImplementation Namespace See Also
Collapse All
C#
public virtual void CopyTo(
    T[] array,
    int arrayIndex
);
Remarks

This is CopyTo, a member of class EcoListShimBase.

See Also
EcoListShimBase Class
Eco.ObjectImplementation Namespace


EcoListShimBase.GetEnumerator Method

EcoListShimBase.GetEnumerator Method
EcoListShimBase Class Eco.ObjectImplementation Namespace See Also
Collapse All
C#
public virtual IEnumerator<T> GetEnumerator();
Remarks

This is GetEnumerator, a member of class EcoListShimBase.

See Also
EcoListShimBase Class
Eco.ObjectImplementation Namespace


EcoListShimBase.IndexOf Method

EcoListShimBase.IndexOf Method
EcoListShimBase Class Eco.ObjectImplementation Namespace See Also
Collapse All
C#
public virtual int IndexOf(
    T item
);
Remarks

This is IndexOf, a member of class EcoListShimBase.

See Also
EcoListShimBase Class
Eco.ObjectImplementation Namespace


EcoListShimBase.Insert Method

EcoListShimBase.Insert Method
EcoListShimBase Class Eco.ObjectImplementation Namespace See Also
Collapse All
C#
public virtual void Insert(
    int index,
    T item
);
Remarks

This is Insert, a member of class EcoListShimBase.

See Also
EcoListShimBase Class
Eco.ObjectImplementation Namespace


EcoListShimBase.Remove Method

EcoListShimBase.Remove Method
EcoListShimBase Class Eco.ObjectImplementation Namespace See Also
Collapse All
C#
public virtual bool Remove(
    T item
);
Remarks

This is Remove, a member of class EcoListShimBase.

See Also
EcoListShimBase Class
Eco.ObjectImplementation Namespace


EcoListShimBase.RemoveAt Method

EcoListShimBase.RemoveAt Method
EcoListShimBase Class Eco.ObjectImplementation Namespace See Also
Collapse All
C#
public virtual void RemoveAt(
    int index
);
Remarks

This is RemoveAt, a member of class EcoListShimBase.

See Also
EcoListShimBase Class
Eco.ObjectImplementation Namespace


EcoListShimBase.this Indexer

EcoListShimBase.this Indexer
EcoListShimBase Class Eco.ObjectImplementation Namespace See Also
Collapse All
C#
public virtual T this[
    int index
];
Remarks

This is this, a member of class EcoListShimBase.

See Also
EcoListShimBase Class
Eco.ObjectImplementation Namespace


EcoListShimBase Properties

EcoListShimBase Properties
Public Properties
Collapse All

The properties of the EcoListShimBase class are listed here.

Public Properties
Name | Description
Count | This is Count, a member of class EcoListShimBase.
IsFixedSize | This is IsFixedSize, a member of class EcoListShimBase.
IsReadOnly | This is IsReadOnly, a member of class EcoListShimBase.
IsSynchronized | This is IsSynchronized, a member of class EcoListShimBase.
ServiceProvider | This is ServiceProvider, a member of class EcoListShimBase.
SyncRoot | This is SyncRoot, a member of class EcoListShimBase.


EcoListShimBase.Count Property

EcoListShimBase.Count Property
EcoListShimBase Class Eco.ObjectImplementation Namespace See Also
Collapse All
C#
public virtual int Count;
Remarks

This is Count, a member of class EcoListShimBase.

See Also
EcoListShimBase Class
Eco.ObjectImplementation Namespace


EcoListShimBase.IsFixedSize Property

EcoListShimBase.IsFixedSize Property
EcoListShimBase Class Eco.ObjectImplementation Namespace See Also
Collapse All
C#
public bool IsFixedSize;
Remarks

This is IsFixedSize, a member of class EcoListShimBase.

See Also
EcoListShimBase Class
Eco.ObjectImplementation Namespace


EcoListShimBase.IsReadOnly Property

EcoListShimBase.IsReadOnly Property
EcoListShimBase Class Eco.ObjectImplementation Namespace See Also
Collapse All
C#
public virtual bool IsReadOnly;
Remarks

This is IsReadOnly, a member of class EcoListShimBase.

See Also
EcoListShimBase Class
Eco.ObjectImplementation Namespace


EcoListShimBase.IsSynchronized Property

EcoListShimBase.IsSynchronized Property
EcoListShimBase Class Eco.ObjectImplementation Namespace See Also
Collapse All
C#
public bool IsSynchronized;
Remarks

This is IsSynchronized, a member of class EcoListShimBase.

See Also
EcoListShimBase Class
Eco.ObjectImplementation Namespace


EcoListShimBase.ServiceProvider Property

EcoListShimBase.ServiceProvider Property
EcoListShimBase Class Eco.ObjectImplementation Namespace See Also
Collapse All
C#
public IEcoServiceProvider ServiceProvider;
Remarks

This is ServiceProvider, a member of class EcoListShimBase.

See Also
EcoListShimBase Class
Eco.ObjectImplementation Namespace


EcoListShimBase.SyncRoot Property

EcoListShimBase.SyncRoot Property
EcoListShimBase Class Eco.ObjectImplementation Namespace See Also
Collapse All
C#
public object SyncRoot;
Remarks

This is SyncRoot, a member of class EcoListShimBase.

See Also
EcoListShimBase Class
Eco.ObjectImplementation Namespace


EcoObjectListAdapter Class

EcoObjectListAdapter Class
Inheritance Hierarchy See Also
Collapse All
C#
public class EcoObjectListAdapter<T> : System.Object, IEcoList<T>, IList, IBindingList where T : class, IEcoObject;
Remarks

This is class Eco.ObjectImplementation.EcoObjectListAdapter.

Inheritance Hierarchy
Eco.ObjectImplementation.IEcoList
    Eco.ObjectImplementation.EcoObjectListAdapter
File

EcoListAdapter.cs

See Also
Inheritance Hierarchy


EcoObjectListAdapter.EcoObjectListAdapter Constructor

EcoObjectListAdapter.EcoObjectListAdapter Constructor
EcoObjectListAdapter Class Eco.ObjectImplementation Namespace See Also
Collapse All
C#
public EcoObjectListAdapter(
    IObjectList list
);
Remarks

This is EcoObjectListAdapter, a member of class EcoObjectListAdapter.

See Also
EcoObjectListAdapter Class
Eco.ObjectImplementation Namespace


EcoObjectListAdapter Classes

EcoObjectListAdapter Classes
Classes
Collapse All

The classes of the EcoObjectListAdapter class are listed here.

Classes
Name | Description
EcoListEnumerator | This is class Eco.ObjectImplementation.EcoObjectListAdapter.EcoListEnumerator.


EcoObjectListAdapter.EcoListEnumerator Class

EcoObjectListAdapter.EcoListEnumerator Class
Inheritance Hierarchy See Also
Collapse All
C#
public class EcoListEnumerator : IEnumerator<T>;
Remarks

This is class Eco.ObjectImplementation.EcoObjectListAdapter.EcoListEnumerator.

Inheritance Hierarchy
Eco.ObjectImplementation.EcoObjectListAdapter.EcoListEnumerator
File

EcoListAdapter.cs

See Also
Inheritance Hierarchy


EcoObjectListAdapter.EcoListEnumerator.EcoListEnumerator Constructor

EcoObjectListAdapter.EcoListEnumerator.EcoListEnumerator Constructor
EcoObjectListAdapter.EcoListEnumerator Class Eco.ObjectImplementation Namespace See Also
Collapse All
C#
public EcoListEnumerator(
    IObjectList list
);
Remarks

This is EcoListEnumerator, a member of class EcoListEnumerator.

See Also
EcoObjectListAdapter.EcoListEnumerator Class
Eco.ObjectImplementation Namespace


EcoListEnumerator Methods

EcoListEnumerator Methods
Public Methods
Collapse All

The methods of the EcoListEnumerator class are listed here.

Public Methods
Name | Description
Dispose | This is Dispose, a member of class EcoListEnumerator.
MoveNext | This is MoveNext, a member of class EcoListEnumerator.
Reset | This is Reset, a member of class EcoListEnumerator.


EcoObjectListAdapter.EcoListEnumerator.Dispose Method

EcoObjectListAdapter.EcoListEnumerator.Dispose Method
EcoObjectListAdapter.EcoListEnumerator Class Eco.ObjectImplementation Namespace See Also
Collapse All
C#
public void Dispose();
Remarks

This is Dispose, a member of class EcoListEnumerator.

See Also
EcoObjectListAdapter.EcoListEnumerator Class
Eco.ObjectImplementation Namespace


EcoObjectListAdapter.EcoListEnumerator.MoveNext Method

EcoObjectListAdapter.EcoListEnumerator.MoveNext Method
EcoObjectListAdapter.EcoListEnumerator Class Eco.ObjectImplementation Namespace See Also
Collapse All
C#
public bool MoveNext();
Remarks

This is MoveNext, a member of class EcoListEnumerator.

See Also
EcoObjectListAdapter.EcoListEnumerator Class
Eco.ObjectImplementation Namespace


EcoObjectListAdapter.EcoListEnumerator.Reset Method

EcoObjectListAdapter.EcoListEnumerator.Reset Method
EcoObjectListAdapter.EcoListEnumerator Class Eco.ObjectImplementation Namespace See Also
Collapse All
C#
public void Reset();
Remarks

This is Reset, a member of class EcoListEnumerator.

See Also
EcoObjectListAdapter.EcoListEnumerator Class
Eco.ObjectImplementation Namespace


EcoListEnumerator Properties

EcoListEnumerator Properties
Public Properties
Collapse All

The properties of the EcoListEnumerator class are listed here.

Public Properties
Name | Description
Current | This is Current, a member of class EcoListEnumerator.


EcoObjectListAdapter.EcoListEnumerator.Current Property

EcoObjectListAdapter.EcoListEnumerator.Current Property
EcoObjectListAdapter.EcoListEnumerator Class Eco.ObjectImplementation Namespace See Also
Collapse All
C#
public T Current;
Remarks

This is Current, a member of class EcoListEnumerator.

See Also
EcoObjectListAdapter.EcoListEnumerator Class
Eco.ObjectImplementation Namespace


EcoObjectListAdapter Methods

EcoObjectListAdapter Methods
Public Methods
Collapse All

The methods of the EcoObjectListAdapter class are listed here.

Public Methods
Name | Description
Add | This is Add, a member of class EcoObjectListAdapter.
Clear | This is Clear, a member of class EcoObjectListAdapter.
Contains | This is Contains, a member of class EcoObjectListAdapter.
CopyTo | This is CopyTo, a member of class EcoObjectListAdapter.
GetEnumerator | This is GetEnumerator, a member of class EcoObjectListAdapter.
IndexOf | This is IndexOf, a member of class EcoObjectListAdapter.
Insert | This is Insert, a member of class EcoObjectListAdapter.
Remove | This is Remove, a member of class EcoObjectListAdapter.
RemoveAt | This is RemoveAt, a member of class EcoObjectListAdapter.
this | This is this, a member of class EcoObjectListAdapter.


EcoObjectListAdapter.Add Method

EcoObjectListAdapter.Add Method
EcoObjectListAdapter Class Eco.ObjectImplementation Namespace See Also
Collapse All
C#
public void Add(
    T item
);
Remarks

This is Add, a member of class EcoObjectListAdapter.

See Also
EcoObjectListAdapter Class
Eco.ObjectImplementation Namespace


EcoObjectListAdapter.Clear Method

EcoObjectListAdapter.Clear Method
EcoObjectListAdapter Class Eco.ObjectImplementation Namespace See Also
Collapse All
C#
public void Clear();
Remarks

This is Clear, a member of class EcoObjectListAdapter.

See Also
EcoObjectListAdapter Class
Eco.ObjectImplementation Namespace


EcoObjectListAdapter.Contains Method

EcoObjectListAdapter.Contains Method
EcoObjectListAdapter Class Eco.ObjectImplementation Namespace See Also
Collapse All
C#
public bool Contains(
    T item
);
Remarks

This is Contains, a member of class EcoObjectListAdapter.

See Also
EcoObjectListAdapter Class
Eco.ObjectImplementation Namespace


EcoObjectListAdapter.CopyTo Method

EcoObjectListAdapter.CopyTo Method
EcoObjectListAdapter Class Eco.ObjectImplementation Namespace See Also
Collapse All
C#
public void CopyTo(
    T[] arr,
    int index
);
Remarks

This is CopyTo, a member of class EcoObjectListAdapter.

See Also
EcoObjectListAdapter Class
Eco.ObjectImplementation Namespace


EcoObjectListAdapter.GetEnumerator Method

EcoObjectListAdapter.GetEnumerator Method
EcoObjectListAdapter Class Eco.ObjectImplementation Namespace See Also
Collapse All
C#
public IEnumerator<T> GetEnumerator();
Remarks

This is GetEnumerator, a member of class EcoObjectListAdapter.

See Also
EcoObjectListAdapter Class
Eco.ObjectImplementation Namespace


EcoObjectListAdapter.IndexOf Method

EcoObjectListAdapter.IndexOf Method
EcoObjectListAdapter Class Eco.ObjectImplementation Namespace See Also
Collapse All
C#
public int IndexOf(
    T item
);
Remarks

This is IndexOf, a member of class EcoObjectListAdapter.

See Also
EcoObjectListAdapter Class
Eco.ObjectImplementation Namespace


EcoObjectListAdapter.Insert Method

EcoObjectListAdapter.Insert Method
EcoObjectListAdapter Class Eco.ObjectImplementation Namespace See Also
Collapse All
C#
public void Insert(
    int index,
    T item
);
Remarks

This is Insert, a member of class EcoObjectListAdapter.

See Also
EcoObjectListAdapter Class
Eco.ObjectImplementation Namespace


EcoObjectListAdapter.Remove Method

EcoObjectListAdapter.Remove Method
EcoObjectListAdapter Class Eco.ObjectImplementation Namespace See Also
Collapse All
C#
public bool Remove(
    T item
);
Remarks

This is Remove, a member of class EcoObjectListAdapter.

See Also
EcoObjectListAdapter Class
Eco.ObjectImplementation Namespace


EcoObjectListAdapter.RemoveAt Method

EcoObjectListAdapter.RemoveAt Method
EcoObjectListAdapter Class Eco.ObjectImplementation Namespace See Also
Collapse All
C#
public void RemoveAt(
    int index
);
Remarks

This is RemoveAt, a member of class EcoObjectListAdapter.

See Also
EcoObjectListAdapter Class
Eco.ObjectImplementation Namespace


EcoObjectListAdapter.this Indexer

EcoObjectListAdapter.this Indexer
EcoObjectListAdapter Class Eco.ObjectImplementation Namespace See Also
Collapse All
C#
public T this[
    int index
];
Remarks

This is this, a member of class EcoObjectListAdapter.

See Also
EcoObjectListAdapter Class
Eco.ObjectImplementation Namespace


EcoObjectListAdapter Properties

EcoObjectListAdapter Properties
Public Properties Protected Properties
Collapse All

The properties of the EcoObjectListAdapter class are listed here.

Public Properties
Name | Description
AllowNew | This is AllowNew, a member of class EcoObjectListAdapter.
AsIObjectList | This is AsIObjectList, a member of class EcoObjectListAdapter.
Count | This is Count, a member of class EcoObjectListAdapter.
IsReadOnly | This is IsReadOnly, a member of class EcoObjectListAdapter.
ServiceProvider | This is ServiceProvider, a member of class EcoObjectListAdapter.
Top
Protected Properties
Name | Description
Adaptee | This is Adaptee, a member of class EcoObjectListAdapter.


EcoObjectListAdapter.Adaptee Property

EcoObjectListAdapter.Adaptee Property
EcoObjectListAdapter Class Eco.ObjectImplementation Namespace See Also
Collapse All
C#
protected IObjectList Adaptee;
Remarks

This is Adaptee, a member of class EcoObjectListAdapter.

See Also
EcoObjectListAdapter Class
Eco.ObjectImplementation Namespace


EcoObjectListAdapter.AllowNew Property

EcoObjectListAdapter.AllowNew Property
EcoObjectListAdapter Class Eco.ObjectImplementation Namespace See Also
Collapse All
C#
public bool AllowNew;
Remarks

This is AllowNew, a member of class EcoObjectListAdapter.

See Also
EcoObjectListAdapter Class
Eco.ObjectImplementation Namespace


EcoObjectListAdapter.AsIObjectList Property

EcoObjectListAdapter.AsIObjectList Property
EcoObjectListAdapter Class Eco.ObjectImplementation Namespace See Also
Collapse All
C#
public Eco.ObjectRepresentation.IObjectList AsIObjectList;
Remarks

This is AsIObjectList, a member of class EcoObjectListAdapter.

See Also
EcoObjectListAdapter Class
Eco.ObjectImplementation Namespace


EcoObjectListAdapter.Count Property

EcoObjectListAdapter.Count Property
EcoObjectListAdapter Class Eco.ObjectImplementation Namespace See Also
Collapse All
C#
public int Count;
Remarks

This is Count, a member of class EcoObjectListAdapter.

See Also
EcoObjectListAdapter Class
Eco.ObjectImplementation Namespace


EcoObjectListAdapter.IsReadOnly Property

EcoObjectListAdapter.IsReadOnly Property
EcoObjectListAdapter Class Eco.ObjectImplementation Namespace See Also
Collapse All
C#
public bool IsReadOnly;
Remarks

This is IsReadOnly, a member of class EcoObjectListAdapter.

See Also
EcoObjectListAdapter Class
Eco.ObjectImplementation Namespace


EcoObjectListAdapter.ServiceProvider Property

EcoObjectListAdapter.ServiceProvider Property
EcoObjectListAdapter Class Eco.ObjectImplementation Namespace See Also
Collapse All
C#
public IEcoServiceProvider ServiceProvider;
Remarks

This is ServiceProvider, a member of class EcoObjectListAdapter.

See Also
EcoObjectListAdapter Class
Eco.ObjectImplementation Namespace


ObjectEnumeratorAdapter Class

ObjectEnumeratorAdapter Class
Inheritance Hierarchy See Also
Collapse All
C#
public class ObjectEnumeratorAdapter<T> : IEnumerator<T>;
Remarks

This is class Eco.ObjectImplementation.ObjectEnumeratorAdapter.

Inheritance Hierarchy
Eco.ObjectImplementation.ObjectEnumeratorAdapter
File

ObjectImplementation.cs

See Also
Inheritance Hierarchy


ObjectEnumeratorAdapter.ObjectEnumeratorAdapter Constructor

ObjectEnumeratorAdapter.ObjectEnumeratorAdapter Constructor
ObjectEnumeratorAdapter Class Eco.ObjectImplementation Namespace See Also
Collapse All
C#
public ObjectEnumeratorAdapter(
    IEnumerator enumerator
);
Remarks

This is ObjectEnumeratorAdapter, a member of class ObjectEnumeratorAdapter.

See Also
ObjectEnumeratorAdapter Class
Eco.ObjectImplementation Namespace


ObjectListAdapter Class

ObjectListAdapter Class
Inheritance Hierarchy See Also
Collapse All
C#
public sealed class ObjectListAdapter<T> : EcoListShimBase<T> where T : class, IEcoObject;
Remarks

Obsolete("The value returned by get_MemberByIndex can be cast to IEcoListdirectly")

Inheritance Hierarchy
Eco.ObjectImplementation.IEcoList
    Eco.ObjectImplementation.EcoListShimBase
        Eco.ObjectImplementation.ObjectListAdapter
            Eco.ObjectImplementation.ObjectListAdapterX
File

ObjectImplementation.cs

See Also
Inheritance Hierarchy


ObjectListAdapter.ObjectListAdapter Constructor

ObjectListAdapter.ObjectListAdapter Constructor
ObjectListAdapter Class Eco.ObjectImplementation Namespace See Also
Collapse All
C#
public ObjectListAdapter(
    IList adaptee
);
Remarks

This is ObjectListAdapter, a member of class ObjectListAdapter.

See Also
ObjectListAdapter Class
Eco.ObjectImplementation Namespace


ObjectListAdapterX Class

ObjectListAdapterX Class
Inheritance Hierarchy See Also
Collapse All
C#
public class ObjectListAdapterX<T> : ObjectListAdapter, IList<T>;
Remarks

This is class Eco.ObjectImplementation.ObjectListAdapterX.

Inheritance Hierarchy
Eco.ObjectImplementation.IEcoList
    Eco.ObjectImplementation.EcoListShimBase
        Eco.ObjectImplementation.ObjectListAdapter
            Eco.ObjectImplementation.ObjectListAdapterX
File

ObjectImplementation.cs

See Also
Inheritance Hierarchy


ObjectListAdapterX.ObjectListAdapterX Constructor

ObjectListAdapterX.ObjectListAdapterX Constructor
ObjectListAdapterX Class Eco.ObjectImplementation Namespace See Also
Collapse All
C#
public ObjectListAdapterX(
    IList list
);
Remarks

This is ObjectListAdapterX, a member of class ObjectListAdapterX.

See Also
ObjectListAdapterX Class
Eco.ObjectImplementation Namespace


StateName Class

StateName Class
Inheritance Hierarchy See Also
Collapse All
C#
public class StateName : IStateName;
Remarks

This is class Eco.ObjectImplementation.StateName.

Inheritance Hierarchy
Eco.ObjectImplementation.StateName
File

StateMachine.cs

See Also
Inheritance Hierarchy


StateName.StateName Constructor

StateName.StateName Constructor
StateName Class Eco.ObjectImplementation Namespace See Also
Collapse All
C#
public StateName(
    string name
);
Remarks

This is StateName, a member of class StateName.

See Also
StateName Class
Eco.ObjectImplementation Namespace


StateName Methods

StateName Methods
Public Methods
Collapse All

The methods of the StateName class are listed here.

Public Methods
Name | Description
ToString | This is ToString, a member of class StateName.


StateName.ToString Method

StateName.ToString Method
StateName Class Eco.ObjectImplementation Namespace See Also
Collapse All
C#
public override string ToString();
Remarks

This is ToString, a member of class StateName.

See Also
StateName Class
Eco.ObjectImplementation Namespace


StateName Properties

StateName Properties
Public Properties
Collapse All

The properties of the StateName class are listed here.

Public Properties
Name | Description
Name | This is Name, a member of class StateName.


StateName.Name Property

StateName.Name Property
StateName Class Eco.ObjectImplementation Namespace See Also
Collapse All
C#
public string Name;
Remarks

This is Name, a member of class StateName.

See Also
StateName Class
Eco.ObjectImplementation Namespace


IContent Interface

IContent Interface
Inheritance Hierarchy See Also
Collapse All
C#
public interface IContent : INotifyPropertyChanged;
Remarks

This is class Eco.ObjectImplementation.IContent.

Inheritance Hierarchy
Eco.ObjectImplementation.IContent
File

ObjectImplementation.cs

See Also
Inheritance Hierarchy


IContent Methods

IContent Methods
Public Methods
Collapse All

The methods of the IContent class are listed here.

Public Methods
Name | Description
AsIObject | This is AsIObject, a member of class IContent.
AssertLoopbackUnassigned | This is AssertLoopbackUnassigned, a member of class IContent.
get_MemberByIndex | This is get_MemberByIndex, a member of class IContent.
LoopbackValid | This is LoopbackValid, a member of class IContent.
set_MemberByIndex | This is set_MemberByIndex, a member of class IContent.


IContent.AsIObject Method

IContent.AsIObject Method
IContent Interface Eco.ObjectImplementation Namespace See Also
Collapse All
C#
IObjectInstance AsIObject();
Remarks

This is AsIObject, a member of class IContent.

See Also
IContent Interface
Eco.ObjectImplementation Namespace


IContent.AssertLoopbackUnassigned Method

IContent.AssertLoopbackUnassigned Method
IContent Interface Eco.ObjectImplementation Namespace See Also
Collapse All
C#
void AssertLoopbackUnassigned();
Remarks

This is AssertLoopbackUnassigned, a member of class IContent.

See Also
IContent Interface
Eco.ObjectImplementation Namespace


IContent.get_MemberByIndex Method

IContent.get_MemberByIndex Method
IContent Interface Eco.ObjectImplementation Namespace See Also
Collapse All
C#
System.Object get_MemberByIndex(
    int index
);
Remarks

This is get_MemberByIndex, a member of class IContent.

See Also
IContent Interface
Eco.ObjectImplementation Namespace


IContent.LoopbackValid Method

IContent.LoopbackValid Method
IContent Interface Eco.ObjectImplementation Namespace See Also
Collapse All
C#
void LoopbackValid();
Remarks

This is LoopbackValid, a member of class IContent.

See Also
IContent Interface
Eco.ObjectImplementation Namespace


IContent.set_MemberByIndex Method

IContent.set_MemberByIndex Method
IContent Interface Eco.ObjectImplementation Namespace See Also
Collapse All
C#
void set_MemberByIndex(
    int index,
    System.Object value
);
Remarks

This is set_MemberByIndex, a member of class IContent.

See Also
IContent Interface
Eco.ObjectImplementation Namespace


IEcoList Interface

IEcoList Interface
Inheritance Hierarchy See Also
Collapse All

Sub interface of IList<T> that allows navigation back to the IElement world

C#
public interface IEcoList<T> : IList<T> where T : class, IEcoObject;
Inheritance Hierarchy
Eco.ObjectImplementation.IEcoList
    Eco.ObjectImplementation.EcoListShimBase
    Eco.ObjectImplementation.EcoObjectListAdapter
File

ObjectImplementation.cs

See Also
Inheritance Hierarchy


IEcoList Properties

IEcoList Properties
Public Properties
Collapse All

The properties of the IEcoList class are listed here.

Public Properties
Name | Description
AsIObjectList | This is AsIObjectList, a member of class IEcoList.
ServiceProvider | This is ServiceProvider, a member of class IEcoList.


IEcoList.AsIObjectList Property

IEcoList.AsIObjectList Property
IEcoList Interface Eco.ObjectImplementation Namespace See Also
Collapse All
C#
IObjectList AsIObjectList;
Remarks

This is AsIObjectList, a member of class IEcoList.

See Also
IEcoList Interface
Eco.ObjectImplementation Namespace


IEcoList.ServiceProvider Property

IEcoList.ServiceProvider Property
IEcoList Interface Eco.ObjectImplementation Namespace See Also
Collapse All
C#
IEcoServiceProvider ServiceProvider;
Remarks

This is ServiceProvider, a member of class IEcoList.

See Also
IEcoList Interface
Eco.ObjectImplementation Namespace


IInternalObjectContentFactory Interface

IInternalObjectContentFactory Interface
Inheritance Hierarchy See Also
Collapse All
C#
public interface IInternalObjectContentFactory;
Remarks

This is class Eco.ObjectImplementation.IInternalObjectContentFactory.

Inheritance Hierarchy
Eco.ObjectImplementation.IInternalObjectContentFactory
File

ObjectImplementation.cs

See Also
Inheritance Hierarchy


IInternalObjectContentFactory Methods

IInternalObjectContentFactory Methods
Public Methods
Collapse All

The methods of the IInternalObjectContentFactory class are listed here.

Public Methods
Name | Description
CreateContent | This is CreateContent, a member of class IInternalObjectContentFactory.
CreateContentFailed | This is CreateContentFailed, a member of class IInternalObjectContentFactory.


IInternalObjectContentFactory.CreateContent Method

IInternalObjectContentFactory.CreateContent Method
IInternalObjectContentFactory Interface Eco.ObjectImplementation Namespace See Also
Collapse All
C#
IContent CreateContent(
    ILoopBack dotNetObject
);
Remarks

This is CreateContent, a member of class IInternalObjectContentFactory.

See Also
IInternalObjectContentFactory Interface
Eco.ObjectImplementation Namespace


IInternalObjectContentFactory.CreateContentFailed Method

IInternalObjectContentFactory.CreateContentFailed Method
IInternalObjectContentFactory Interface Eco.ObjectImplementation Namespace See Also
Collapse All
C#
void CreateContentFailed(
    IContent obj,
    System.Object dotNetObject
);
Remarks

This is CreateContentFailed, a member of class IInternalObjectContentFactory.

See Also
IInternalObjectContentFactory Interface
Eco.ObjectImplementation Namespace


ILoopBack Interface

ILoopBack Interface
Inheritance Hierarchy See Also
Collapse All
C#
public interface ILoopBack : IObjectProvider;
Remarks

This is class Eco.ObjectImplementation.ILoopBack.

Inheritance Hierarchy
Eco.ObjectImplementation.ILoopBack
    Eco.ObjectImplementation.ILoopBack2
File

ObjectImplementation.cs

See Also
Inheritance Hierarchy


ILoopBack Methods

ILoopBack Methods
Public Methods
Collapse All

The methods of the ILoopBack class are listed here.

Public Methods
Name | Description
get_MemberByIndex | This is get_MemberByIndex, a member of class ILoopBack.
set_MemberByIndex | This is set_MemberByIndex, a member of class ILoopBack.


ILoopBack.get_MemberByIndex Method

ILoopBack.get_MemberByIndex Method
ILoopBack Interface Eco.ObjectImplementation Namespace See Also
Collapse All
C#
System.Object get_MemberByIndex(
    int index
);
Remarks

This is get_MemberByIndex, a member of class ILoopBack.

See Also
ILoopBack Interface
Eco.ObjectImplementation Namespace


ILoopBack.set_MemberByIndex Method

ILoopBack.set_MemberByIndex Method
ILoopBack Interface Eco.ObjectImplementation Namespace See Also
Collapse All
C#
void set_MemberByIndex(
    int index,
    System.Object value
);
Remarks

This is set_MemberByIndex, a member of class ILoopBack.

See Also
ILoopBack Interface
Eco.ObjectImplementation Namespace


ILoopBack2 Interface

ILoopBack2 Interface
Inheritance Hierarchy See Also
Collapse All
C#
public interface ILoopBack2 : ILoopBack, IEcoObject;
Remarks

This is class Eco.ObjectImplementation.ILoopBack2.

Inheritance Hierarchy
Eco.ObjectImplementation.ILoopBack
    Eco.ObjectImplementation.ILoopBack2
File

ObjectImplementation.cs

See Also
Inheritance Hierarchy


ILoopBack2 Methods

ILoopBack2 Methods
Public Methods
Collapse All

The methods of the ILoopBack2 class are listed here.

Public Methods
Name | Description
SetContent | This is SetContent, a member of class ILoopBack2.


ILoopBack2.SetContent Method

ILoopBack2.SetContent Method
ILoopBack2 Interface Eco.ObjectImplementation Namespace See Also
Collapse All
C#
void SetContent(
    IContent content
);
Remarks

This is SetContent, a member of class ILoopBack2.

See Also
ILoopBack2 Interface
Eco.ObjectImplementation Namespace


Eco.ObjectRepresentation Namespace

Eco.ObjectRepresentation Namespace
Classes Enumerations Interfaces
Collapse All

This is namespace Eco.ObjectRepresentation.

Classes
Name | Description
AmbiguousTransitionException | This Exception is raised if a trigger is called on an object with a state-machine and there is more than one transition from the current state, with that trigger and a guard that evaluates as true.
ArgumentNonConformException | This is class Eco.ObjectRepresentation.ArgumentNonConformException.
ArgumentTypeException | This is class Eco.ObjectRepresentation.ArgumentTypeException.
EcoObjectDeleteException | This is class Eco.ObjectRepresentation.EcoObjectDeleteException.
EcoObjectExtensions | This is class Eco.ObjectRepresentation.EcoObjectExtensions.
EcoObservableCollection | This collection class acts as an adapter on top of IEcoList{T} and implements INotifyCollectionChanged
ElementChangedEventArgs | Used internally to notify changes to the local EcoSpace cache.
ElementEqualHash | This is class Eco.ObjectRepresentation.ElementEqualHash.
IObjectPair | Used for indirect associations between objects.
NoTransitionException | This Exception is raised if a trigger is called on an object with a state-machine and there is no transition for the trigger from the current state, with that trigger and a guard that evaluates as true.
OtherEndExtenderHelper | This class is used by extender classes to provide properties for "the other end" for associations between classes in different packages
Top
Enumerations
Name | Description
ContentType | Indentifies the type of an element.
StateFilter | Identifies the type of a state within an ECO state machine.
Top
Interfaces
Name | Description
IConstraintCheck | Used to tie a constraint to an instance of a modeled UML class.
IEcoObject | Implemented by classes that refer to an ECO object.
IEcoServiceProvider | This interface is implemented by objects that can give access to ECO services. The caller can request a service via the Eco.ObjectRepresentation.IEcoServiceProvider.GetEcoService method.
IElement | Interface for all ECO elements
IElementCollection | Holds a collection of IElement.
IElementProvider | When implemented this interface identifies a class as being able to provide an Eco.ObjectRepresentation.IElement.
IExternalVariable | This interface is used for representing a variable in an OCL expression.
IExternalVariableList | This interface is used for representing a collection of variables.
IFeatured | Provides a way of accessing a collection of Eco.ObjectRepresentation.IProperty.
IModifiableVariableList | This is a sub interface of Eco.ObjectRepresentation.IExternalVariableList. is used for representing a collection of variables that can be modfiied by adding or removing variables.
INonDeletableReason | Identifies the reason an object cannot be deleted.
IObject | Provides access to basic object features.
IObjectContainer | Identifies the holder of an IObject or list of IObject.
IObjectInstance | Identifies an Eco.ObjectRepresentation.IObject as an actual object instance rather than a reference to an object instance.
IObjectList | Holds a collection of IObject.
IObjectListProvider | Identifies the implementing class as being able to provide an IObjectList reference.
IObjectProvider | Identifies the implementing class as being able to provide an IObject reference.
IObjectReference | Provides a reference to an IObjectInstance.
IObjectStateMachine | Provides runtime access to the state machine of an ECO object.
IPrimitive | Implemented by Eco.ObjectRepresentation.IProperty instances that hold simple .NET values such as integer, string, and boolean.
IProperty | Provides access to the runtime value of a member of a modeled UML class.
IPropertyCollection | Holds a collection of Eco.ObjectRepresentation.IProperty.
IQualifiedAccess | This is class Eco.ObjectRepresentation.IQualifiedAccess.
ISubscribableElementProvider | Identifies the implementor as a class being able to provide an Eco.ObjectRepresentation.IElement and also providing the additional ability to notify subscribers (observers) whenever the element changes.
ITuple | This is class Eco.ObjectRepresentation.ITuple.
IVariable | Used to define variables for use in OCL evaluation etc.


AmbiguousTransitionException Class

AmbiguousTransitionException Class
Inheritance Hierarchy See Also
Collapse All

This Exception is raised if a trigger is called on an object with a state-machine and there is more than one transition from the current state, with that trigger and a guard that evaluates as true.

C#
public class AmbiguousTransitionException : EcoException;
Inheritance Hierarchy
Eco.ObjectRepresentation.AmbiguousTransitionException
File

ObjectRepresentation.cs

See Also
Inheritance Hierarchy


AmbiguousTransitionException Constructor

AmbiguousTransitionException Constructor

This is the overview for the AmbiguousTransitionException constructor overload.

Overload List
Name | Description
AmbiguousTransitionException.AmbiguousTransitionException () | This is AmbiguousTransitionException, a member of class AmbiguousTransitionException.
AmbiguousTransitionException.AmbiguousTransitionException (SerializationInfo, StreamingContext) | This is AmbiguousTransitionException, a member of class AmbiguousTransitionException.
AmbiguousTransitionException.AmbiguousTransitionException (string) | This is AmbiguousTransitionException, a member of class AmbiguousTransitionException.
AmbiguousTransitionException.AmbiguousTransitionException (string, Exception) | This is AmbiguousTransitionException, a member of class AmbiguousTransitionException.


AmbiguousTransitionException.AmbiguousTransitionException Constructor ()

AmbiguousTransitionException.AmbiguousTransitionException Constructor ()
AmbiguousTransitionException Class Eco.ObjectRepresentation Namespace See Also
Collapse All
C#
public AmbiguousTransitionException();
Remarks

This is AmbiguousTransitionException, a member of class AmbiguousTransitionException.

See Also
AmbiguousTransitionException Class
Eco.ObjectRepresentation Namespace


AmbiguousTransitionException.AmbiguousTransitionException Constructor (SerializationInfo, StreamingContext)

AmbiguousTransitionException.AmbiguousTransitionException Constructor (SerializationInfo, StreamingContext)
AmbiguousTransitionException Class Eco.ObjectRepresentation Namespace See Also
Collapse All
C#
protected AmbiguousTransitionException(
    SerializationInfo info,
    StreamingContext context
);
Remarks

This is AmbiguousTransitionException, a member of class AmbiguousTransitionException.

See Also
AmbiguousTransitionException Class
Eco.ObjectRepresentation Namespace


AmbiguousTransitionException.AmbiguousTransitionException Constructor (string)

AmbiguousTransitionException.AmbiguousTransitionException Constructor (string)
AmbiguousTransitionException Class Eco.ObjectRepresentation Namespace See Also
Collapse All
C#
public AmbiguousTransitionException(
    string message
);
Remarks

This is AmbiguousTransitionException, a member of class AmbiguousTransitionException.

See Also
AmbiguousTransitionException Class
Eco.ObjectRepresentation Namespace


AmbiguousTransitionException.AmbiguousTransitionException Constructor (string, Exception)

AmbiguousTransitionException.AmbiguousTransitionException Constructor (string, Exception)
AmbiguousTransitionException Class Eco.ObjectRepresentation Namespace See Also
Collapse All
C#
public AmbiguousTransitionException(
    string message,
    Exception inner
);
Remarks

This is AmbiguousTransitionException, a member of class AmbiguousTransitionException.

See Also
AmbiguousTransitionException Class
Eco.ObjectRepresentation Namespace


ArgumentNonConformException Class

ArgumentNonConformException Class
Inheritance Hierarchy See Also
Collapse All
C#
public class ArgumentNonConformException : ArgumentException;
Remarks

This is class Eco.ObjectRepresentation.ArgumentNonConformException.

Inheritance Hierarchy
Eco.ObjectRepresentation.ArgumentNonConformException
File

ObjectRepresentation.cs

See Also
Inheritance Hierarchy


ArgumentNonConformException Constructor

ArgumentNonConformException Constructor

This is the overview for the ArgumentNonConformException constructor overload.

Overload List
Name | Description
ArgumentNonConformException.ArgumentNonConformException () | This is ArgumentNonConformException, a member of class ArgumentNonConformException.
ArgumentNonConformException.ArgumentNonConformException (SerializationInfo, StreamingContext) | This is ArgumentNonConformException, a member of class ArgumentNonConformException.
ArgumentNonConformException.ArgumentNonConformException (string, string) | This is ArgumentNonConformException, a member of class ArgumentNonConformException.


ArgumentNonConformException.ArgumentNonConformException Constructor ()

ArgumentNonConformException.ArgumentNonConformException Constructor ()
ArgumentNonConformException Class Eco.ObjectRepresentation Namespace See Also
Collapse All
C#
public ArgumentNonConformException();
Remarks

This is ArgumentNonConformException, a member of class ArgumentNonConformException.

See Also
ArgumentNonConformException Class
Eco.ObjectRepresentation Namespace


ArgumentNonConformException.ArgumentNonConformException Constructor (SerializationInfo, StreamingContext)

ArgumentNonConformException.ArgumentNonConformException Constructor (SerializationInfo, StreamingContext)
ArgumentNonConformException Class Eco.ObjectRepresentation Namespace See Also
Collapse All
C#
protected ArgumentNonConformException(
    SerializationInfo info,
    StreamingContext context
);
Remarks

This is ArgumentNonConformException, a member of class ArgumentNonConformException.

See Also
ArgumentNonConformException Class
Eco.ObjectRepresentation Namespace


ArgumentNonConformException.ArgumentNonConformException Constructor (string, string)

ArgumentNonConformException.ArgumentNonConformException Constructor (string, string)
ArgumentNonConformException Class Eco.ObjectRepresentation Namespace See Also
Collapse All
C#
public ArgumentNonConformException(
    string fromTypeName,
    string toTypeName
);
Remarks

This is ArgumentNonConformException, a member of class ArgumentNonConformException.

See Also
ArgumentNonConformException Class
Eco.ObjectRepresentation Namespace


ArgumentTypeException Class

ArgumentTypeException Class
Inheritance Hierarchy See Also
Collapse All
C#
public class ArgumentTypeException : ArgumentException;
Remarks

This is class Eco.ObjectRepresentation.ArgumentTypeException.

Inheritance Hierarchy
Eco.ObjectRepresentation.ArgumentTypeException
File

ObjectRepresentation.cs

See Also
Inheritance Hierarchy


ArgumentTypeException Constructor

ArgumentTypeException Constructor

This is the overview for the ArgumentTypeException constructor overload.

Overload List
Name | Description
ArgumentTypeException.ArgumentTypeException () | This is ArgumentTypeException, a member of class ArgumentTypeException.
ArgumentTypeException.ArgumentTypeException (SerializationInfo, StreamingContext) | This is ArgumentTypeException, a member of class ArgumentTypeException.
ArgumentTypeException.ArgumentTypeException (Type) | This is ArgumentTypeException, a member of class ArgumentTypeException.
ArgumentTypeException.ArgumentTypeException (Type, Type) | This is ArgumentTypeException, a member of class ArgumentTypeException.


ArgumentTypeException.ArgumentTypeException Constructor ()

ArgumentTypeException.ArgumentTypeException Constructor ()
ArgumentTypeException Class Eco.ObjectRepresentation Namespace See Also
Collapse All
C#
public ArgumentTypeException();
Remarks

This is ArgumentTypeException, a member of class ArgumentTypeException.

See Also
ArgumentTypeException Class
Eco.ObjectRepresentation Namespace


ArgumentTypeException.ArgumentTypeException Constructor (SerializationInfo, StreamingContext)

ArgumentTypeException.ArgumentTypeException Constructor (SerializationInfo, StreamingContext)
ArgumentTypeException Class Eco.ObjectRepresentation Namespace See Also
Collapse All
C#
protected ArgumentTypeException(
    SerializationInfo info,
    StreamingContext context
);
Remarks

This is ArgumentTypeException, a member of class ArgumentTypeException.

See Also
ArgumentTypeException Class
Eco.ObjectRepresentation Namespace


ArgumentTypeException.ArgumentTypeException Constructor (Type)

ArgumentTypeException.ArgumentTypeException Constructor (Type)
ArgumentTypeException Class Eco.ObjectRepresentation Namespace See Also
Collapse All
C#
public ArgumentTypeException(
    Type toType
);
Remarks

This is ArgumentTypeException, a member of class ArgumentTypeException.

See Also
ArgumentTypeException Class
Eco.ObjectRepresentation Namespace


ArgumentTypeException.ArgumentTypeException Constructor (Type, Type)

ArgumentTypeException.ArgumentTypeException Constructor (Type, Type)
ArgumentTypeException Class Eco.ObjectRepresentation Namespace See Also
Collapse All
C#
public ArgumentTypeException(
    Type fromType,
    Type toType
);
Remarks

This is ArgumentTypeException, a member of class ArgumentTypeException.

See Also
ArgumentTypeException Class
Eco.ObjectRepresentation Namespace


EcoObjectDeleteException Class

EcoObjectDeleteException Class
Inheritance Hierarchy See Also
Collapse All
C#
public class EcoObjectDeleteException : EcoException;
Remarks

This is class Eco.ObjectRepresentation.EcoObjectDeleteException.

Inheritance Hierarchy
Eco.ObjectRepresentation.EcoObjectDeleteException
File

ObjectRepresentation.cs

See Also
Inheritance Hierarchy


EcoObjectDeleteException Constructor

EcoObjectDeleteException Constructor

This is the overview for the EcoObjectDeleteException constructor overload.

Overload List
Name | Description
EcoObjectDeleteException.EcoObjectDeleteException () | This is EcoObjectDeleteException, a member of class EcoObjectDeleteException.
EcoObjectDeleteException.EcoObjectDeleteException (SerializationInfo, StreamingContext) | This is EcoObjectDeleteException, a member of class EcoObjectDeleteException.
EcoObjectDeleteException.EcoObjectDeleteException (string) | This is EcoObjectDeleteException, a member of class EcoObjectDeleteException.
EcoObjectDeleteException.EcoObjectDeleteException (string, Exception) | This is EcoObjectDeleteException, a member of class EcoObjectDeleteException.


EcoObjectDeleteException.EcoObjectDeleteException Constructor ()

EcoObjectDeleteException.EcoObjectDeleteException Constructor ()
EcoObjectDeleteException Class Eco.ObjectRepresentation Namespace See Also
Collapse All
C#
public EcoObjectDeleteException();
Remarks

This is EcoObjectDeleteException, a member of class EcoObjectDeleteException.

See Also
EcoObjectDeleteException Class
Eco.ObjectRepresentation Namespace


EcoObjectDeleteException.EcoObjectDeleteException Constructor (SerializationInfo, StreamingContext)

EcoObjectDeleteException.EcoObjectDeleteException Constructor (SerializationInfo, StreamingContext)
EcoObjectDeleteException Class Eco.ObjectRepresentation Namespace See Also
Collapse All
C#
protected EcoObjectDeleteException(
    SerializationInfo info,
    StreamingContext context
);
Remarks

This is EcoObjectDeleteException, a member of class EcoObjectDeleteException.

See Also
EcoObjectDeleteException Class
Eco.ObjectRepresentation Namespace


EcoObjectDeleteException.EcoObjectDeleteException Constructor (string)

EcoObjectDeleteException.EcoObjectDeleteException Constructor (string)
EcoObjectDeleteException Class Eco.ObjectRepresentation Namespace See Also
Collapse All
C#
public EcoObjectDeleteException(
    string message
);
Remarks

This is EcoObjectDeleteException, a member of class EcoObjectDeleteException.

See Also
EcoObjectDeleteException Class
Eco.ObjectRepresentation Namespace


EcoObjectDeleteException.EcoObjectDeleteException Constructor (string, Exception)

EcoObjectDeleteException.EcoObjectDeleteException Constructor (string, Exception)
EcoObjectDeleteException Class Eco.ObjectRepresentation Namespace See Also
Collapse All
C#
public EcoObjectDeleteException(
    string message,
    Exception inner
);
Remarks

This is EcoObjectDeleteException, a member of class EcoObjectDeleteException.

See Also
EcoObjectDeleteException Class
Eco.ObjectRepresentation Namespace


EcoObjectExtensions Class

EcoObjectExtensions Class
Inheritance Hierarchy See Also
Collapse All
C#
public static class EcoObjectExtensions;
Remarks

This is class Eco.ObjectRepresentation.EcoObjectExtensions.

Inheritance Hierarchy
Eco.ObjectRepresentation.EcoObjectExtensions
File

EcoExtenders.cs

See Also
Inheritance Hierarchy


EcoObjectExtensions Methods

EcoObjectExtensions Methods
Public Methods
Collapse All

The methods of the EcoObjectExtensions class are listed here.

Public Methods
Name | Description
IsNull | This is IsNull, a member of class EcoObjectExtensions.
ToEnumerable | This is ToEnumerable, a member of class EcoObjectExtensions.


EcoObjectExtensions.IsNull Method

EcoObjectExtensions.IsNull Method
EcoObjectExtensions Class Eco.ObjectRepresentation Namespace See Also
Collapse All
C#
public static bool IsNull(
    this IEcoObject ecoObject
);
Remarks

This is IsNull, a member of class EcoObjectExtensions.

See Also
EcoObjectExtensions Class
Eco.ObjectRepresentation Namespace


EcoObjectExtensions.ToEnumerable Method

EcoObjectExtensions.ToEnumerable Method
EcoObjectExtensions Class Eco.ObjectRepresentation Namespace See Also
Collapse All
C#
public static IEnumerable<IEcoObject> ToEnumerable(
    this IEcoObject ecoObject
);
Remarks

This is ToEnumerable, a member of class EcoObjectExtensions.

See Also
EcoObjectExtensions Class
Eco.ObjectRepresentation Namespace


EcoObservableCollection Class

EcoObservableCollection Class
Inheritance Hierarchy See Also
Collapse All

This collection class acts as an adapter on top of IEcoList{T} and implements INotifyCollectionChanged

C#
public class EcoObservableCollection<T> : IBindingList, ICollection<T>, INotifyCollectionChanged, INotifyPropertyChanged, INotifyOnIdle where T: class, IEcoObject;
Remarks

The intended use for this collection class is to use as the datasource for a WPF list-control.

Inheritance Hierarchy
Eco.ObjectRepresentation.EcoObservableCollection
File

EcoObservableCollection.cs

See Also
Inheritance Hierarchy


EcoObservableCollection.EcoObservableCollection Constructor

EcoObservableCollection.EcoObservableCollection Constructor
EcoObservableCollection Class Eco.ObjectRepresentation Namespace See Also
Collapse All
C#
public EcoObservableCollection(
    IEcoList<T> list
);
Remarks

This is EcoObservableCollection, a member of class EcoObservableCollection.

See Also
EcoObservableCollection Class
Eco.ObjectRepresentation Namespace


EcoObservableCollection Methods

EcoObservableCollection Methods
Protected Methods Public Methods
Collapse All

The methods of the EcoObservableCollection class are listed here.

Protected Methods
Name | Description
OnPropertyChanged | This is OnPropertyChanged, a member of class EcoObservableCollection.
Top
Public Methods
Name | Description
Add | This is Add, a member of class EcoObservableCollection.
Contains | This is Contains, a member of class EcoObservableCollection.
CopyTo | This is CopyTo, a member of class EcoObservableCollection.
GetEnumerator | This is GetEnumerator, a member of class EcoObservableCollection.
Remove | This is Remove, a member of class EcoObservableCollection.


EcoObservableCollection.Add Method

EcoObservableCollection.Add Method
EcoObservableCollection Class Eco.ObjectRepresentation Namespace See Also
Collapse All
C#
public void Add(
    T item
);
Remarks

This is Add, a member of class EcoObservableCollection.

See Also
EcoObservableCollection Class
Eco.ObjectRepresentation Namespace


EcoObservableCollection.Contains Method

EcoObservableCollection.Contains Method
EcoObservableCollection Class Eco.ObjectRepresentation Namespace See Also
Collapse All
C#
public bool Contains(
    T item
);
Remarks

This is Contains, a member of class EcoObservableCollection.

See Also
EcoObservableCollection Class
Eco.ObjectRepresentation Namespace


EcoObservableCollection.CopyTo Method

EcoObservableCollection.CopyTo Method
EcoObservableCollection Class Eco.ObjectRepresentation Namespace See Also
Collapse All
C#
public void CopyTo(
    T[] array,
    int arrayIndex
);
Remarks

This is CopyTo, a member of class EcoObservableCollection.

See Also
EcoObservableCollection Class
Eco.ObjectRepresentation Namespace


EcoObservableCollection.GetEnumerator Method

EcoObservableCollection.GetEnumerator Method
EcoObservableCollection Class Eco.ObjectRepresentation Namespace See Also
Collapse All
C#
public IEnumerator<T> GetEnumerator();
Remarks

This is GetEnumerator, a member of class EcoObservableCollection.

See Also
EcoObservableCollection Class
Eco.ObjectRepresentation Namespace


EcoObservableCollection.OnPropertyChanged Method

EcoObservableCollection.OnPropertyChanged Method
EcoObservableCollection Class Eco.ObjectRepresentation Namespace See Also
Collapse All
C#
protected virtual void OnPropertyChanged(
    PropertyChangedEventArgs e
);
Remarks

This is OnPropertyChanged, a member of class EcoObservableCollection.

See Also
EcoObservableCollection Class
Eco.ObjectRepresentation Namespace


EcoObservableCollection.Remove Method

EcoObservableCollection.Remove Method
EcoObservableCollection Class Eco.ObjectRepresentation Namespace See Also
Collapse All
C#
public bool Remove(
    T item
);
Remarks

This is Remove, a member of class EcoObservableCollection.

See Also
EcoObservableCollection Class
Eco.ObjectRepresentation Namespace


EcoObservableCollection Properties

EcoObservableCollection Properties
Public Properties
Collapse All

The properties of the EcoObservableCollection class are listed here.

Public Properties
Name | Description
Count | This is Count, a member of class EcoObservableCollection.
IsReadOnly | This is IsReadOnly, a member of class EcoObservableCollection.


EcoObservableCollection.Count Property

EcoObservableCollection.Count Property
EcoObservableCollection Class Eco.ObjectRepresentation Namespace See Also
Collapse All
C#
public int Count;
Remarks

This is Count, a member of class EcoObservableCollection.

See Also
EcoObservableCollection Class
Eco.ObjectRepresentation Namespace


EcoObservableCollection.IsReadOnly Property

EcoObservableCollection.IsReadOnly Property
EcoObservableCollection Class Eco.ObjectRepresentation Namespace See Also
Collapse All
C#
public bool IsReadOnly;
Remarks

This is IsReadOnly, a member of class EcoObservableCollection.

See Also
EcoObservableCollection Class
Eco.ObjectRepresentation Namespace


EcoObservableCollection Events

EcoObservableCollection Events
Public Events
Collapse All

The events of the EcoObservableCollection class are listed here.

Public Events
Name | Description
CollectionChanged | This is CollectionChanged, a member of class EcoObservableCollection.
ListChanged | This is ListChanged, a member of class EcoObservableCollection.
PropertyChanged | This is PropertyChanged, a member of class EcoObservableCollection.


EcoObservableCollection.CollectionChanged Event

EcoObservableCollection.CollectionChanged Event
EcoObservableCollection Class Eco.ObjectRepresentation Namespace See Also
Collapse All
C#
public event NotifyCollectionChangedEventHandler CollectionChanged;
Remarks

This is CollectionChanged, a member of class EcoObservableCollection.

See Also
EcoObservableCollection Class
Eco.ObjectRepresentation Namespace


EcoObservableCollection.ListChanged Event

EcoObservableCollection.ListChanged Event
EcoObservableCollection Class Eco.ObjectRepresentation Namespace See Also
Collapse All
C#
public event ListChangedEventHandler ListChanged;
Remarks

This is ListChanged, a member of class EcoObservableCollection.

See Also
EcoObservableCollection Class
Eco.ObjectRepresentation Namespace


EcoObservableCollection.PropertyChanged Event

EcoObservableCollection.PropertyChanged Event
EcoObservableCollection Class Eco.ObjectRepresentation Namespace See Also
Collapse All
C#
public event PropertyChangedEventHandler PropertyChanged;
Remarks

This is PropertyChanged, a member of class EcoObservableCollection.

See Also
EcoObservableCollection Class
Eco.ObjectRepresentation Namespace


ElementChangedEventArgs Class

ElementChangedEventArgs Class
Inheritance Hierarchy See Also
Collapse All

Used internally to notify changes to the local EcoSpace cache.

C#
public class ElementChangedEventArgs : EventArgs;
Inheritance Hierarchy
Eco.ObjectRepresentation.ElementChangedEventArgs
File

ObjectRepresentation.cs

See Also
Inheritance Hierarchy


ElementChangedEventArgs.ElementChangedEventArgs Constructor

ElementChangedEventArgs.ElementChangedEventArgs Constructor
ElementChangedEventArgs Class Eco.ObjectRepresentation Namespace See Also
Collapse All

Creates a new instance of the class.

C#
public ElementChangedEventArgs(
    IElement element
);
Parameters
Parameters | Description
element | Identifies the changed element.
See Also
ElementChangedEventArgs Class
Eco.ObjectRepresentation Namespace


ElementChangedEventArgs Properties

ElementChangedEventArgs Properties
Public Properties
Collapse All

The properties of the ElementChangedEventArgs class are listed here.

Public Properties
Name | Description
Element | Identifies the element that has changed.


ElementChangedEventArgs.Element Property

ElementChangedEventArgs.Element Property
ElementChangedEventArgs Class Eco.ObjectRepresentation Namespace See Also
Collapse All

Identifies the element that has changed.

C#
public IElement Element;
See Also
ElementChangedEventArgs Class
Eco.ObjectRepresentation Namespace


ElementEqualHash Class

ElementEqualHash Class
Inheritance Hierarchy See Also
Collapse All
C#
public static class ElementEqualHash;
Remarks

This is class Eco.ObjectRepresentation.ElementEqualHash.

Inheritance Hierarchy
Eco.ObjectRepresentation.ElementEqualHash
File

ObjectRepresentation.cs

See Also
Inheritance Hierarchy


ElementEqualHash Properties

ElementEqualHash Properties
Public Properties
Collapse All

The properties of the ElementEqualHash class are listed here.

Public Properties
Name | Description
EqualityComparer | This is EqualityComparer, a member of class ElementEqualHash.
GenericEqualityComparer | This is GenericEqualityComparer, a member of class ElementEqualHash.


ElementEqualHash.EqualityComparer Property

ElementEqualHash.EqualityComparer Property
ElementEqualHash Class Eco.ObjectRepresentation Namespace See Also
Collapse All
C#
public static IEqualityComparer<IElement> EqualityComparer;
Remarks

This is EqualityComparer, a member of class ElementEqualHash.

See Also
ElementEqualHash Class
Eco.ObjectRepresentation Namespace


ElementEqualHash.GenericEqualityComparer Property

ElementEqualHash.GenericEqualityComparer Property
ElementEqualHash Class Eco.ObjectRepresentation Namespace See Also
Collapse All
C#
public static IEqualityComparer<IElement> GenericEqualityComparer;
Remarks

This is GenericEqualityComparer, a member of class ElementEqualHash.

See Also
ElementEqualHash Class
Eco.ObjectRepresentation Namespace


IObjectPair Class

IObjectPair Class
Inheritance Hierarchy See Also
Collapse All

Used for indirect associations between objects.

C#
public class IObjectPair;
Remarks

This class is used to tie two objects together in a multi-multi association, or in any other type of association where neither end is embedded.

Inheritance Hierarchy
Eco.ObjectRepresentation.IObjectPair
File

ObjectRepresentation.cs

See Also
Inheritance Hierarchy


IObjectPair.IObjectPair Constructor

IObjectPair.IObjectPair Constructor
IObjectPair Class Eco.ObjectRepresentation Namespace See Also
Collapse All

Creates a new instance of the class.

C#
public IObjectPair(
    IObjectInstance obj1,
    IObjectInstance obj2
);
Parameters
Parameters | Description
obj1 | The first object in the pairing.
obj2 | The second object in the pairing.
See Also
IObjectPair Class
Eco.ObjectRepresentation Namespace


IObjectPair Properties

IObjectPair Properties
Public Properties
Collapse All

The properties of the IObjectPair class are listed here.

Public Properties
Name | Description
Obj1 | The first object in the pairing.
Obj2 | The second object in the pairing.


IObjectPair.Obj1 Property

IObjectPair.Obj1 Property
IObjectPair Class Eco.ObjectRepresentation Namespace See Also
Collapse All

The first object in the pairing.

C#
public IObjectInstance Obj1;
See Also
IObjectPair Class
Eco.ObjectRepresentation Namespace


IObjectPair.Obj2 Property

IObjectPair.Obj2 Property
IObjectPair Class Eco.ObjectRepresentation Namespace See Also
Collapse All

The second object in the pairing.

C#
public IObjectInstance Obj2;
See Also
IObjectPair Class
Eco.ObjectRepresentation Namespace


NoTransitionException Class

NoTransitionException Class
Inheritance Hierarchy See Also
Collapse All

This Exception is raised if a trigger is called on an object with a state-machine and there is no transition for the trigger from the current state, with that trigger and a guard that evaluates as true.

C#
public class NoTransitionException : EcoException;
Inheritance Hierarchy
Eco.ObjectRepresentation.NoTransitionException
File

ObjectRepresentation.cs

See Also
Inheritance Hierarchy


NoTransitionException Constructor

NoTransitionException Constructor

This is the overview for the NoTransitionException constructor overload.

Overload List
Name | Description
NoTransitionException.NoTransitionException () | This is NoTransitionException, a member of class NoTransitionException.
NoTransitionException.NoTransitionException (SerializationInfo, StreamingContext) | This is NoTransitionException, a member of class NoTransitionException.
NoTransitionException.NoTransitionException (string) | This is NoTransitionException, a member of class NoTransitionException.
NoTransitionException.NoTransitionException (string, Exception) | This is NoTransitionException, a member of class NoTransitionException.


NoTransitionException.NoTransitionException Constructor ()

NoTransitionException.NoTransitionException Constructor ()
NoTransitionException Class Eco.ObjectRepresentation Namespace See Also
Collapse All
C#
public NoTransitionException();
Remarks

This is NoTransitionException, a member of class NoTransitionException.

See Also
NoTransitionException Class
Eco.ObjectRepresentation Namespace


NoTransitionException.NoTransitionException Constructor (SerializationInfo, StreamingContext)

NoTransitionException.NoTransitionException Constructor (SerializationInfo, StreamingContext)
NoTransitionException Class Eco.ObjectRepresentation Namespace See Also
Collapse All
C#
protected NoTransitionException(
    SerializationInfo info,
    StreamingContext context
);
Remarks

This is NoTransitionException, a member of class NoTransitionException.

See Also
NoTransitionException Class
Eco.ObjectRepresentation Namespace


NoTransitionException.NoTransitionException Constructor (string)

NoTransitionException.NoTransitionException Constructor (string)
NoTransitionException Class Eco.ObjectRepresentation Namespace See Also
Collapse All
C#
public NoTransitionException(
    string message
);
Remarks

This is NoTransitionException, a member of class NoTransitionException.

See Also
NoTransitionException Class
Eco.ObjectRepresentation Namespace


NoTransitionException.NoTransitionException Constructor (string, Exception)

NoTransitionException.NoTransitionException Constructor (string, Exception)
NoTransitionException Class Eco.ObjectRepresentation Namespace See Also
Collapse All
C#
public NoTransitionException(
    string message,
    Exception inner
);
Remarks

This is NoTransitionException, a member of class NoTransitionException.

See Also
NoTransitionException Class
Eco.ObjectRepresentation Namespace


OtherEndExtenderHelper Class

OtherEndExtenderHelper Class
Inheritance Hierarchy See Also
Collapse All

This class is used by extender classes to provide properties for "the other end" for associations between classes in different packages

C#
public static class OtherEndExtenderHelper;
Inheritance Hierarchy
Eco.ObjectRepresentation.OtherEndExtenderHelper
File

ObjectRepresentation.cs

See Also
Inheritance Hierarchy


OtherEndExtenderHelper Methods

OtherEndExtenderHelper Methods
Public Methods
Collapse All

The methods of the OtherEndExtenderHelper class are listed here.

Public Methods
Name | Description
GetMemberIndexOfOtherEnd | This is GetMemberIndexOfOtherEnd, a member of class OtherEndExtenderHelper.
GetMultiLink | This is GetMultiLink, a member of class OtherEndExtenderHelper.
GetSingleLink | This is GetSingleLink, a member of class OtherEndExtenderHelper.
SetSingleLink | This is SetSingleLink, a member of class OtherEndExtenderHelper.


OtherEndExtenderHelper.GetMemberIndexOfOtherEnd Method

OtherEndExtenderHelper.GetMemberIndexOfOtherEnd Method
OtherEndExtenderHelper Class Eco.ObjectRepresentation Namespace See Also
Collapse All
C#
public static int GetMemberIndexOfOtherEnd(
    IEcoObject obj,
    Type t,
    int loopbackIndex
);
Remarks

This is GetMemberIndexOfOtherEnd, a member of class OtherEndExtenderHelper.

See Also
OtherEndExtenderHelper Class
Eco.ObjectRepresentation Namespace


OtherEndExtenderHelper.GetMultiLink Method

OtherEndExtenderHelper.GetMultiLink Method
OtherEndExtenderHelper Class Eco.ObjectRepresentation Namespace See Also
Collapse All
C#
public static Eco.ObjectImplementation.IEcoList<T> GetMultiLink<T>(
    IEcoObject obj,
    int memberIndex
) where T : class, IEcoObject;
Remarks

This is GetMultiLink, a member of class OtherEndExtenderHelper.

See Also
OtherEndExtenderHelper Class
Eco.ObjectRepresentation Namespace


OtherEndExtenderHelper.GetSingleLink Method

OtherEndExtenderHelper.GetSingleLink Method
OtherEndExtenderHelper Class Eco.ObjectRepresentation Namespace See Also
Collapse All
C#
public static T GetSingleLink<T>(
    IEcoObject obj,
    int memberIndex
) where T : class, IEcoObject;
Remarks

This is GetSingleLink, a member of class OtherEndExtenderHelper.

See Also
OtherEndExtenderHelper Class
Eco.ObjectRepresentation Namespace


OtherEndExtenderHelper.SetSingleLink Method

OtherEndExtenderHelper.SetSingleLink Method
OtherEndExtenderHelper Class Eco.ObjectRepresentation Namespace See Also
Collapse All
C#
public static void SetSingleLink<T>(
    IEcoObject obj,
    int memberIndex,
    T newValue
) where T : class, IEcoObject;
Remarks

This is SetSingleLink, a member of class OtherEndExtenderHelper.

See Also
OtherEndExtenderHelper Class
Eco.ObjectRepresentation Namespace


IConstraintCheck Interface

IConstraintCheck Interface
Inheritance Hierarchy See Also
Collapse All

Used to tie a constraint to an instance of a modeled UML class.

C#
public interface IConstraintCheck : IElement;
Remarks

This interface is implemented by the objects returned when evaluating the OCL expression

Copy Code
self.constraints

on an instance of a modeled UML class.

Inheritance Hierarchy
Eco.ObjectRepresentation.IElementProvider
    Eco.ObjectRepresentation.IElement
        Eco.ObjectRepresentation.IConstraintCheck
File

ObjectRepresentation.cs

See Also
Inheritance Hierarchy


IConstraintCheck Properties

IConstraintCheck Properties
Public Properties
Collapse All

The properties of the IConstraintCheck class are listed here.

Public Properties
Name | Description
Constraint | The meta-information about the constraint this instance represents.
Subject | The instance of the modeled UML class to evaluate the constraint against.


IConstraintCheck.Constraint Property

IConstraintCheck.Constraint Property
IConstraintCheck Interface Eco.ObjectRepresentation Namespace See Also
Collapse All

The meta-information about the constraint this instance represents.

C#
IConstraint Constraint;
See Also
IConstraintCheck Interface
Eco.ObjectRepresentation Namespace


IConstraintCheck.Subject Property

IConstraintCheck.Subject Property
IConstraintCheck Interface Eco.ObjectRepresentation Namespace See Also
Collapse All

The instance of the modeled UML class to evaluate the constraint against.

C#
IObjectInstance Subject;
See Also
IConstraintCheck Interface
Eco.ObjectRepresentation Namespace


IEcoObject Interface

IEcoObject Interface
Inheritance Hierarchy See Also
Collapse All

Implemented by classes that refer to an ECO object.

C#
public interface IEcoObject;
Remarks

This interface is implemented both by the domain objects in the generated code (such as Invoice or Person), and by IObject which is part of the IElementhiearchy used for untyped access to the EcoSpace. Methods taking an IEcoObject as a parameter will threfore accept either of these.

Inheritance Hierarchy
Eco.ObjectRepresentation.IEcoObject
    Eco.ObjectRepresentation.IObject
    Eco.ObjectRepresentation.IObjectProvider
File

ObjectRepresentation.cs

See Also
Inheritance Hierarchy


IEcoObject Methods

IEcoObject Methods
Public Methods
Collapse All

The methods of the IEcoObject class are listed here.

Public Methods
Name | Description
AsIObject | Returns the IObjectInstance.


IEcoObject.AsIObject Method

IEcoObject.AsIObject Method
IEcoObject Interface Eco.ObjectRepresentation Namespace See Also
Collapse All

Returns the IObjectInstance.

C#
IObjectInstance AsIObject();
Returns

Always return an IObject, never returns null

See Also
IEcoObject Interface
Eco.ObjectRepresentation Namespace


IEcoServiceProvider Interface

IEcoServiceProvider Interface
Inheritance Hierarchy Related Topics See Also
Collapse All

This interface is implemented by objects that can give access to ECO services. The caller can request a service via the Eco.ObjectRepresentation.IEcoServiceProvider.GetEcoService method.

C#
public interface IEcoServiceProvider;
Remarks

From within the application it is possible to access most of the standard ECO services by referring directly to the additional properties added to the application’s EcoSpace (PersistenceService, UndoService, etc).

This interface is useful when you need to retrieve a custom service that has been registered using Eco.Handles.DefaultEcoSpace.RegisterEcoService, or when an ECO service is required within the business classes (it is good practise to create business classes within their own DLL, separate from the application owning the EcoSpace that manages them).

The easiest way to retrieve an instance of an ECO service in the business objects layer is to use the generic GetEcoService method.

Copy Code
IOclService oclService = AsIObject().ServiceProvider.GetEcoService<IOclService>();

Eco.Handles.ElementHandle implements this interface, making it possible to obtain an instance of an ECO service from any of the ECO handle components.

Related Topics

Eco.Services

Inheritance Hierarchy
Eco.ObjectRepresentation.IEcoServiceProvider
File

ObjectRepresentation.cs

See Also
Inheritance Hierarchy
Related Topics


IEcoServiceProvider Methods

IEcoServiceProvider Methods
Public Methods
Collapse All

The methods of the IEcoServiceProvider class are listed here.

Public Methods
Name | Description
GetEcoService | This is the overview for the GetEcoService method overload.
RegisterEcoService | This is the overview for the RegisterEcoService method overload.


GetEcoService Method

GetEcoService Method

This is the overview for the GetEcoService method overload.

Overload List
Name | Description
IEcoServiceProvider.GetEcoService () | Returns a correctly typed instance of an object that implements the service of type T.
IEcoServiceProvider.GetEcoService (object) | Returns a correctly typed instance of an object that implements the service of type T that was registered with the correct key
IEcoServiceProvider.GetEcoService (Type) | /// Returns an instance of an object that implements the reqested service. /// Returns an instance of an object that implements the requested service.


IEcoServiceProvider.GetEcoService Method ()

IEcoServiceProvider.GetEcoService Method ()
IEcoServiceProvider Interface Eco.ObjectRepresentation Namespace Example See Also
Collapse All

Returns a correctly typed instance of an object that implements the service of type T.

C#
T GetEcoService<T>() where T : class;
Returns

If no service of the specified type is registered null will be returned.

Remarks

The .NET type of the ECO service to retrieve an instance of.

Eco.Handles.DefaultEcoSpace.RegisterEcoService

Example
Copy Code
           oclService = serviceProvider.GetEcoService<IOclService>());
Copy Code
           OclService := ServiceProvider.GetEcoService<IOclService>;
See Also
IEcoServiceProvider Interface
Eco.ObjectRepresentation Namespace
Example


IEcoServiceProvider.GetEcoService Method (Type)

IEcoServiceProvider.GetEcoService Method (Type)
IEcoServiceProvider Interface Eco.ObjectRepresentation Namespace Example See Also
Collapse All

/// Returns an instance of an object that implements the reqested service. ///

Returns an instance of an object that implements the requested service.

C#
object GetEcoService(
    Type serviceType
);
Parameters
Parameters | Description
serviceType | The .NET type of the ECO service to retrieve an instance of.
Returns

If no service of the specified type is registered null will be returned.

Remarks

///

///

/// The serviceType parameter should be the Type of the service interface reqested, e.g. /// GetEcoService(typeof(IPersistenceService)) will return an object implementing /// Eco.Services.IPersistenceService. The standard service interfaces can all be found /// in the Eco.Services namespace. They are also implemented directly as properties on /// Eco.Handles.DefaultEcoSpace. ///

Eco.Handles.DefaultEcoSpace.RegisterEcoService

Example
Copy Code
           oclService = (IOclService) serviceProvider.GetEcoService(typeof(IOclService));
Copy Code
           OclService := ServiceProvider.GetEcoService(typeof(IOclService)) as IOclService;
See Also
IEcoServiceProvider Interface
Eco.ObjectRepresentation Namespace
Example


IEcoServiceProvider.GetEcoService Method (object)

IEcoServiceProvider.GetEcoService Method (object)
IEcoServiceProvider Interface Eco.ObjectRepresentation Namespace Example See Also
Collapse All

Returns a correctly typed instance of an object that implements the service of type T that was registered with the correct key

C#
T GetEcoService<T>(
    object key
) where T : class;
Parameters
Parameters | Description
key | The key that the service was registered with. Can be any object, such as an enum value or a string that identifies the service
Returns

If no service of the specified type is registered null will be returned.

Remarks

The .NET type of the ECO service to retrieve an instance of.

Eco.Handles.DefaultEcoSpace.RegisterEcoService

Example
Copy Code
           IMyService myService = serviceProvider.GetEcoService<IMyService>("version1"));
See Also
IEcoServiceProvider Interface
Eco.ObjectRepresentation Namespace
Example


RegisterEcoService Method

RegisterEcoService Method

This is the overview for the RegisterEcoService method overload.

Overload List
Name | Description
IEcoServiceProvider.RegisterEcoService (object, T) | Call this to register a service that can be retrieved later using GetEcoService<T>(object key)
IEcoServiceProvider.RegisterEcoService (T) | Call this to register a service that can be retrieved later using GetEcoService<T>()


IEcoServiceProvider.RegisterEcoService Method (T)

IEcoServiceProvider.RegisterEcoService Method (T)
IEcoServiceProvider Interface Eco.ObjectRepresentation Namespace See Also
Collapse All

Call this to register a service that can be retrieved later using GetEcoService<T>()

C#
void RegisterEcoService<T>(
    T service
) where T : class;
Remarks

Registering a service for a type that already has a registered service will overwrite the existing service without warning

See Also
IEcoServiceProvider Interface
Eco.ObjectRepresentation Namespace


IEcoServiceProvider.RegisterEcoService Method (object, T)

IEcoServiceProvider.RegisterEcoService Method (object, T)
IEcoServiceProvider Interface Eco.ObjectRepresentation Namespace See Also
Collapse All

Call this to register a service that can be retrieved later using GetEcoService<T>(object key)

C#
void RegisterEcoService<T>(
    object key,
    T service
) where T : class;
Remarks

This method allows registration of multiple services of the same type, using the key-parameter to separate them. A service that is registered with a key can only be retrieved using the same key, it can't be retrieved with the GetEcoService<T>() method.

See Also
IEcoServiceProvider Interface
Eco.ObjectRepresentation Namespace


IElement Interface

IElement Interface
Inheritance Hierarchy See Also
Collapse All

Interface for all ECO elements

C#
public interface IElement : IElementProvider;
Remarks

An IElement is any element that is handled by ECO. Different kinds of elements are represented by different subinterfaces. For instance, Eco.ObjectRepresentation.IObjectInstance represents an instance of a domain class in your model, e.g. a Product or Invoice object; Eco.ObjectRepresentation.IProperty represents a property (e.g. Name or InvoiceNumber) of a domain object; and Eco.ObjectRepresentation.IObjectList represents a list of domain objects.

Elements may implement more than one interface inheriting from IElement. Attributes will implement both IProperty and IPrimitive, and associations will implement IProperty and IObjectList.

You can get the IElement - in this case an IObjectInstance - for a domain object from the AsIObject() method in the generated code. You will also get IElements from ECO handles via the ElementHandle.Element property. The ECO service interfaces also primarily deal with IElements.

The Eco.ObjectRepresentation.IElement.AsObject property allows you to get the actual value of the element, such as a string or integer, or an instance of a modeled UML class such as a PurchaseOrder, Invoice, or a .NET value type.

Inheritance Hierarchy
Eco.ObjectRepresentation.IElementProvider
    Eco.ObjectRepresentation.IElement
        Eco.ObjectRepresentation.IConstraintCheck
        Eco.ObjectRepresentation.IElementCollection
        Eco.ObjectRepresentation.IFeatured
        Eco.ObjectRepresentation.IObjectContainer
        Eco.ObjectRepresentation.IPrimitive
        Eco.ObjectRepresentation.IProperty
        Eco.ObjectRepresentation.IVariable
File

ObjectRepresentation.cs

See Also
Inheritance Hierarchy


IElement Methods

IElement Methods
Public Methods
Collapse All

The methods of the IElement class are listed here.

Public Methods
Name | Description
Assign | Copies the value from one element to another
CloneValue | Creates a new element with the same value.
GetAsCollection | Turns the element into a collection
GetAsIList | This is GetAsIList, a member of class IElement.
GetIsEqualHashCode | Returns the hash code of the value held by the element.
GetValue | This is GetValue, a member of class IElement.
IsEqual | Compares the value of two elements for equality.
SetValue | This is SetValue, a member of class IElement.
SubscribeToValue | Add a subscription to the value of the element using the ECO subscription mechanism.


IElement.Assign Method

IElement.Assign Method
IElement Interface Eco.ObjectRepresentation Namespace See Also
Collapse All

Copies the value from one element to another

C#
void Assign(
    IElement element
);
Parameters
Parameters | Description
element | The source element from which to copy the value.
Remarks
Copy Code
targetElement.Assign(sourceElement);

will change the value of targetElement to be the same as the value of sourceElement. The type of the sourceElement must be convertible to the static type of the targetElement, e.g. it is possible to assign a Human into another Human element, but not a Human into a string element.

For primitive types the following conversions apply:

  • Integer types (System.Byte, System.SByte, Int16, UInt16, Int32, Uint32, Int64 and UInt64) can be converted to each other

and to Decimal, Single and Double. If the actual value falls outside the allowed range of the target, an OverflowException is thrown.

  • Single and Double can be converted to each other.
  • String and Char can be converted to each other. Attempting to convert a string longer than one character to a Char

will result in an ArgumentException. Converting the empty string to a Char will result in a space.

For elements that are IObject, the sourceElement's type must be the same class as, or a subclass of, the static type of the targetElement. The targetElement must be either a variable or an association with 0..1 multiplicity. Assign will not attempt to copy all the attributes from one domain object to another.

If the targetElement is read only, Assign throws a NotSupportedException exception.

See Also
IElement Interface
Eco.ObjectRepresentation Namespace


IElement.CloneValue Method

IElement.CloneValue Method
IElement Interface Eco.ObjectRepresentation Namespace See Also
Collapse All

Creates a new element with the same value.

C#
IElement CloneValue(
    bool readOnly
);
Parameters
Parameters | Description
readOnly | If True a read only element (constant) will be returned, otherwise a modifiable element will be returned (variable).
Remarks

Only primitive types such as int, string, boolean are actually cloned. If the element passed is an instance of a modeled UML class the returned element will actually be a cloned reference rather than a deep copy of the original instance. The returned element will also implement Eco.ObjectRepresentation.IVariable.

See Also
IElement Interface
Eco.ObjectRepresentation Namespace


IElement.GetAsCollection Method

IElement.GetAsCollection Method
IElement Interface Eco.ObjectRepresentation Namespace See Also
Collapse All

Turns the element into a collection

C#
IElementCollection GetAsCollection();
Remarks

If the element is a primitive value the returned element is an Eco.ObjectRepresentation.IElementCollection of length 1, containing a clone of the element.

If the element is an object the returned element is an IObjectList containing that object. If it is an object reference - such as an association end with 0..1 multiplicity - that has no object assigned the returned element is an empty list.

If the element is a collection - either an element collection or an object list - then that element is returned.

See Also
IElement Interface
Eco.ObjectRepresentation Namespace


IElement.GetAsIList Method

IElement.GetAsIList Method
IElement Interface Eco.ObjectRepresentation Namespace See Also
Collapse All
C#
IList<T> GetAsIList<T>();
Remarks

This is GetAsIList, a member of class IElement.

See Also
IElement Interface
Eco.ObjectRepresentation Namespace


IElement.GetIsEqualHashCode Method

IElement.GetIsEqualHashCode Method
IElement Interface Eco.ObjectRepresentation Namespace See Also
Collapse All

Returns the hash code of the value held by the element.

C#
int GetIsEqualHashCode();
Remarks

This returns the hash code of the value held by the element, rather than the hash code of the element itself. This is equivalent to

Copy Code
Element.AsObject.GetHashCode();

rather than

Copy Code
Element.GetHashCode();

.

Copy Code
Element.GetHashCode();

will consider two different instances of Eco.ObjectRepresentation.IElement to be different even if they hold a reference to the same value.

See Also
IElement Interface
Eco.ObjectRepresentation Namespace


IElement.GetValue Method

IElement.GetValue Method
IElement Interface Eco.ObjectRepresentation Namespace See Also
Collapse All
C#
T GetValue<T>();
Remarks

This is GetValue, a member of class IElement.

See Also
IElement Interface
Eco.ObjectRepresentation Namespace


IElement.IsEqual Method

IElement.IsEqual Method
IElement Interface Eco.ObjectRepresentation Namespace See Also
Collapse All

Compares the value of two elements for equality.

C#
bool IsEqual(
    IElement element
);
Parameters
Parameters | Description
element | The element to compare value equality with.
Remarks

For primitives the result will the same as comparing the values of Eco.ObjectRepresentation.IElement.AsObject with Equals(). For elements implementing Eco.ObjectRepresentation.IObject - either object references or instances - the result will be True if the element refer to the same instance. It will not compare the attribute values of two objects.

See Also
IElement Interface
Eco.ObjectRepresentation Namespace


IElement.SetValue Method

IElement.SetValue Method
IElement Interface Eco.ObjectRepresentation Namespace See Also
Collapse All
C#
void SetValue<T>(
    T value
);
Remarks

This is SetValue, a member of class IElement.

See Also
IElement Interface
Eco.ObjectRepresentation Namespace


IElement.SubscribeToValue Method

IElement.SubscribeToValue Method
IElement Interface Eco.ObjectRepresentation Namespace See Also
Collapse All

Add a subscription to the value of the element using the ECO subscription mechanism.

C#
void SubscribeToValue(
    ISubscriber subscriber
);
Parameters
Parameters | Description
subscriber | The subscriber to notify when a change occurs to the element.
Remarks

The subscriber’s Receive method will be called when the element’s value changes. If the element is of a primitive data type, such as a string or integer, Receive will be called when that value changes. For lists, it is called when an element is added to, deleted from, replaced or moved in the list. For object instances, the Receive method is called when the object is deleted,(i.e. when its exstence changes) but not when a member of the object changes.

The event is only guaranteed to be sent if the value of the element has changed since the last time it was read. If the value has never been read, the event will in most cases not be sent. And in the same vein, if the value is changed twice without being read inbetween, the event will onloy be sent on the first change.

The sender argument to Receive will be the changed element. The EventArgs e will be an Eco.ObjectRepresentation.ElementChangedEventArgs.

The system is not guaranteed to be in a stable state when Receive is called. For instance, bi-directional associations may not have both ends in sync. It is therefore not advisable to access the changed element, or any other elements, in the Receive method. Recommended practice is to register that the element is out of date, and to deal with it lazily at a later time.

The ECO subscription mechanism uses weak references to ensure that subscribers will not be kept alive even if they have not unsibscribed. This is further described in Eco.Subscription.ISubscriber

See Also
IElement Interface
Eco.ObjectRepresentation Namespace


IElement Properties

IElement Properties
Public Properties
Collapse All

The properties of the IElement class are listed here.

Public Properties
Name | Description
AsObject | Gets or sets the value that the element references.
ContentType | Indicates what type of value the element refers to.
IsProperty | Indicates whether or not the element a property on .NET class generated for a UML modeled class.
Mutable | Whether the element can change value or not
ReadOnly | Indicates whether or not it is possible to alter the value referenced by the element.
ServiceProvider | Provides a reference to the service provider the IElement belongs to
UmlType | Indicates the actual classifier type of the value referenced by the element.


IElement.AsObject Property

IElement.AsObject Property
IElement Interface Eco.ObjectRepresentation Namespace See Also
Collapse All

Gets or sets the value that the element references.

C#
System.Object AsObject;
Remarks

The value must be of a valid type for the element to hold.

Exceptions
Exceptions | Description
System.InvalidOperationException | Thrown if an attempt is made to set a value when ReadOnly is True.
See Also
IElement Interface
Eco.ObjectRepresentation Namespace


IElement.ContentType Property

IElement.ContentType Property
IElement Interface Eco.ObjectRepresentation Namespace Related Topics See Also
Collapse All

Indicates what type of value the element refers to.

C#
ContentType ContentType;
Related Topics

Eco.ObjectRepresentation.ContentType

See Also
IElement Interface
Eco.ObjectRepresentation Namespace
Related Topics


IElement.IsProperty Property

IElement.IsProperty Property
IElement Interface Eco.ObjectRepresentation Namespace See Also
Collapse All

Indicates whether or not the element a property on .NET class generated for a UML modeled class.

C#
bool IsProperty;
Remarks

Properties are attributes and association ends of domain objects. If True the element will also implement IProperty.

See Also
IElement Interface
Eco.ObjectRepresentation Namespace


IElement.Mutable Property

IElement.Mutable Property
IElement Interface Eco.ObjectRepresentation Namespace See Also
Collapse All

Whether the element can change value or not

C#
bool Mutable;
Remarks

If false, the element is immutable, and thus guaranteed to never change its value. If true, the value may change. This is primarily useful for knowing that it is not necessary to subscribe to the element.

Immutable values are always ReadOnly, but the reverse is not always true. E.g. derived attributes cannot be assigned to, but may still change value if the elements they depend upon change.

See Also
IElement Interface
Eco.ObjectRepresentation Namespace


IElement.ReadOnly Property

IElement.ReadOnly Property
IElement Interface Eco.ObjectRepresentation Namespace See Also
Collapse All

Indicates whether or not it is possible to alter the value referenced by the element.

C#
bool ReadOnly;
Remarks

If false, setting the AsObject property will throw an InvalidOperationException.

See Also
IElement Interface
Eco.ObjectRepresentation Namespace


IElement.ServiceProvider Property

IElement.ServiceProvider Property
IElement Interface Eco.ObjectRepresentation Namespace See Also
Collapse All

Provides a reference to the service provider the IElement belongs to

C#
IEcoServiceProvider ServiceProvider;
Remarks

Using the service provider it is possible to gain access to any of the standard ECO services plus any custom services registered with the EcoSpace.

See Also
IElement Interface
Eco.ObjectRepresentation Namespace


IElement.UmlType Property

IElement.UmlType Property
IElement Interface Eco.ObjectRepresentation Namespace See Also
Collapse All

Indicates the actual classifier type of the value referenced by the element.

C#
IClassifier UmlType;
Remarks

For primitives, collections and object instances the static and actual types are the same. However, an object reference can have a different static and actual type, much like object type variables in a programming language. It can be statically typed as an "A" but the actual instance it points to might be a subclass "ASub". In this case UmlType will return the classifier representing "ASub".

The static type is available as IVariable.StaticUmlType, or as the type of IProperty.StructuralFeature.

See Also
IElement Interface
Eco.ObjectRepresentation Namespace


IElement Events

IElement Events
Public Events
Collapse All

The events of the IElement class are listed here.

Public Events
Name | Description
ValueChanged | Occurs when the value of the element changes after the ast time iwas read.


IElement.ValueChanged Event

IElement.ValueChanged Event
IElement Interface Eco.ObjectRepresentation Namespace See Also
Collapse All

Occurs when the value of the element changes after the ast time iwas read.

C#
event EventHandler ValueChanged;
Remarks

The event will occur element’s value changes. If the element is of a primitive data type, such as a string or integer, Receive will be called when that value changes. For lists, it occurs when an element is added to, deleted from, replaced or moved in the list. For object instances, if occurs called when the object is deleted (i.e. when its exstence changes), but not when a member of the object changes.

The event is only guaranteed to be sent if the value of the element has changed since the last time it was read. If the value has never been read, the event will in most cases not be sent. And in the same vein, if the value is changed twice without being read inbetween, the event will onloy be sent on the first change.

The system is not guaranteed to be in a stable state when the event occurs. For instance, bi-directional associations may not have both ends in sync. It is therefore not advisable to access the changed element, or any other elements, in the event handle. Recommended practice is to register that the element is out of date, and to deal with it lazily at a later time.

See Also
IElement Interface
Eco.ObjectRepresentation Namespace


IElementCollection Interface

IElementCollection Interface
Inheritance Hierarchy See Also
Collapse All

Holds a collection of IElement.

C#
public interface IElementCollection : IElement, ICollection;
Inheritance Hierarchy
Eco.ObjectRepresentation.IElementProvider
    Eco.ObjectRepresentation.IElement
        Eco.ObjectRepresentation.IElementCollection
File

ObjectRepresentation.cs

See Also
Inheritance Hierarchy


IElementCollection Methods

IElementCollection Methods
Public Methods
Collapse All

The methods of the IElementCollection class are listed here.

Public Methods
Name | Description
Add | Adds an element to the collection.
AddNew | Creates a new element and adds it to the collection.
Clear | Clears the collection.
Contains | Indicates whether or not the specified element is contained within the collection.
EnsureRange | Ensures the object contents are loaded into the local cache.
IndexOf | Returns the index of the element within the collection.
Insert | Inserts the element at the specific index in the collection.
Move | Changes the position of an element within the collection.
Remove | Removes a specific element from the collection.
RemoveAt | Removes an element at a specific index from the collection.
this | Provides access to elements via their index within the collection.


IElementCollection.Add Method

IElementCollection.Add Method
IElementCollection Interface Eco.ObjectRepresentation Namespace See Also
Collapse All

Adds an element to the collection.

C#
void Add(
    IElement value
);
Parameters
Parameters | Description
value | The element to add.
See Also
IElementCollection Interface
Eco.ObjectRepresentation Namespace


IElementCollection.AddNew Method

IElementCollection.AddNew Method
IElementCollection Interface Eco.ObjectRepresentation Namespace Related Topics See Also
Collapse All

Creates a new element and adds it to the collection.

C#
IElement AddNew();
Remarks

The class implementing this interface will create an instance of an object that is compatible with the types expected within the collection, and then return an IElement holding the value of this new object.

Related Topics

SupportsAddNew

See Also
IElementCollection Interface
Eco.ObjectRepresentation Namespace
Related Topics


IElementCollection.Clear Method

IElementCollection.Clear Method
IElementCollection Interface Eco.ObjectRepresentation Namespace See Also
Collapse All

Clears the collection.

C#
void Clear();
See Also
IElementCollection Interface
Eco.ObjectRepresentation Namespace


IElementCollection.Contains Method

IElementCollection.Contains Method
IElementCollection Interface Eco.ObjectRepresentation Namespace See Also
Collapse All

Indicates whether or not the specified element is contained within the collection.

C#
bool Contains(
    IElement value
);
Parameters
Parameters | Description
value | The element to check for.
See Also
IElementCollection Interface
Eco.ObjectRepresentation Namespace


IElementCollection.EnsureRange Method

IElementCollection.EnsureRange Method
IElementCollection Interface Eco.ObjectRepresentation Namespace Related Topics See Also
Collapse All

Ensures the object contents are loaded into the local cache.

C#
void EnsureRange(
    int fromIndex,
    int toIndex
);
Parameters
Parameters | Description
fromIndex | The index of the first object to fetch.
toIndex | To index of the last object to fetch.
Related Topics

Eco.Services.IPersistenceService.EnsureRange

See Also
IElementCollection Interface
Eco.ObjectRepresentation Namespace
Related Topics


IElementCollection.IndexOf Method

IElementCollection.IndexOf Method
IElementCollection Interface Eco.ObjectRepresentation Namespace See Also
Collapse All

Returns the index of the element within the collection.

C#
int IndexOf(
    IElement value
);
Parameters
Parameters | Description
value | The element to find the index of.
Returns

-1 if the collection does not contain the element, otherwise the zero-based index of the element.

See Also
IElementCollection Interface
Eco.ObjectRepresentation Namespace


IElementCollection.Insert Method

IElementCollection.Insert Method
IElementCollection Interface Eco.ObjectRepresentation Namespace See Also
Collapse All

Inserts the element at the specific index in the collection.

C#
void Insert(
    int index,
    IElement value
);
Parameters
Parameters | Description
index | The index at which to insert the element.
value | The element to add to the collection
Remarks

If the element already exists in the collection and the collection does not allow duplicate values the element will first be removed from the collection before being inserted into the new position.

Exceptions
Exceptions | Description
ArgumentOutOfRangeException | Thrown if the index is less than zero or greater than the total number of elements in the collection.
See Also
IElementCollection Interface
Eco.ObjectRepresentation Namespace


IElementCollection.Move Method

IElementCollection.Move Method
IElementCollection Interface Eco.ObjectRepresentation Namespace See Also
Collapse All

Changes the position of an element within the collection.

C#
void Move(
    int fromPos,
    int toPos
);
Parameters
Parameters | Description
fromPos | The index of the element to move.
toPos | The new index at which the element will be positioned.
Exceptions
Exceptions | Description
ArgumentOutOfRangeException | Thrown if fromPos is less than zero or greater than the total number of elements in the collection - 1. Thrown if toPos is less than zero or greater than the total number of elements in the collection.
See Also
IElementCollection Interface
Eco.ObjectRepresentation Namespace


IElementCollection.Remove Method

IElementCollection.Remove Method
IElementCollection Interface Eco.ObjectRepresentation Namespace See Also
Collapse All

Removes a specific element from the collection.

C#
void Remove(
    IElement value
);
Parameters
Parameters | Description
value | The element to remove from the collection.
Remarks

If the element is not contained within the collection no action will be taken.

See Also
IElementCollection Interface
Eco.ObjectRepresentation Namespace


IElementCollection.RemoveAt Method

IElementCollection.RemoveAt Method
IElementCollection Interface Eco.ObjectRepresentation Namespace See Also
Collapse All

Removes an element at a specific index from the collection.

C#
void RemoveAt(
    int index
);
Parameters
Parameters | Description
index | The index of the element to remove.
Exceptions
Exceptions | Description
ArgumentOutOfRangeException | Thrown if the index is less than zero or greater than the total number of elements - 1.
See Also
IElementCollection Interface
Eco.ObjectRepresentation Namespace


IElementCollection.this Indexer

IElementCollection.this Indexer
IElementCollection Interface Eco.ObjectRepresentation Namespace See Also
Collapse All

Provides access to elements via their index within the collection.

C#
IElement this[
    int index
];
Parameters
Parameters | Description
index | The index of the element to return or set.
See Also
IElementCollection Interface
Eco.ObjectRepresentation Namespace


IElementCollection Properties

IElementCollection Properties
Public Properties
Collapse All

The properties of the IElementCollection class are listed here.

Public Properties
Name | Description
SupportsAddNew | Indicates whether or not the collection will allow new elements to be added.
SupportsMove | Indicates whether or not the collection allows rearranging of its elements.
SupportsRemoveAt | Indicates whether or not the collection will allow the removal of elements.
UmlCollectionType | Returns information about the type of collection.


IElementCollection.SupportsAddNew Property

IElementCollection.SupportsAddNew Property
IElementCollection Interface Eco.ObjectRepresentation Namespace Related Topics See Also
Collapse All

Indicates whether or not the collection will allow new elements to be added.

C#
bool SupportsAddNew;
Remarks

Collection classes implementing this interface will return false if the collection is read-only (derived associations, historic instances of versioned objects) or if the list is untyped and therefore has no known base type to create automatically when IElementCollection.AddNew is called.

Related Topics

IElementCollection.AddNew

See Also
IElementCollection Interface
Eco.ObjectRepresentation Namespace
Related Topics


IElementCollection.SupportsMove Property

IElementCollection.SupportsMove Property
IElementCollection Interface Eco.ObjectRepresentation Namespace Related Topics See Also
Collapse All

Indicates whether or not the collection allows rearranging of its elements.

C#
bool SupportsMove;
Related Topics

IElementCollection.Move

See Also
IElementCollection Interface
Eco.ObjectRepresentation Namespace
Related Topics


IElementCollection.SupportsRemoveAt Property

IElementCollection.SupportsRemoveAt Property
IElementCollection Interface Eco.ObjectRepresentation Namespace See Also
Collapse All

Indicates whether or not the collection will allow the removal of elements.

C#
bool SupportsRemoveAt;
See Also
IElementCollection Interface
Eco.ObjectRepresentation Namespace


IElementCollection.UmlCollectionType Property

IElementCollection.UmlCollectionType Property
IElementCollection Interface Eco.ObjectRepresentation Namespace See Also
Collapse All

Returns information about the type of collection.

C#
ICollectionType UmlCollectionType;
See Also
IElementCollection Interface
Eco.ObjectRepresentation Namespace


IElementProvider Interface

IElementProvider Interface
Inheritance Hierarchy See Also
Collapse All

When implemented this interface identifies a class as being able to provide an Eco.ObjectRepresentation.IElement.

C#
public interface IElementProvider;
Inheritance Hierarchy
Eco.ObjectRepresentation.IElementProvider
    Eco.ObjectRepresentation.IElement
    Eco.ObjectRepresentation.ISubscribableElementProvider
File

ObjectRepresentation.cs

See Also
Inheritance Hierarchy


IElementProvider Properties

IElementProvider Properties
Public Properties
Collapse All

The properties of the IElementProvider class are listed here.

Public Properties
Name | Description
Element | Returns the element provided by the implementor of this interface.


IElementProvider.Element Property

IElementProvider.Element Property
IElementProvider Interface Eco.ObjectRepresentation Namespace See Also
Collapse All

Returns the element provided by the implementor of this interface.

C#
IElement Element;
See Also
IElementProvider Interface
Eco.ObjectRepresentation Namespace


IExternalVariable Interface

IExternalVariable Interface
Inheritance Hierarchy See Also
Collapse All

This interface is used for representing a variable in an OCL expression.

C#
public interface IExternalVariable;
Remarks

It normally only exists as an element in an Eco.ObjectRepresentation.IExternalVariableList.

Inheritance Hierarchy
Eco.ObjectRepresentation.IExternalVariable
File

ObjectRepresentation.cs

See Also
Inheritance Hierarchy


IExternalVariable Methods

IExternalVariable Methods
Public Methods
Collapse All

The methods of the IExternalVariable class are listed here.

Public Methods
Name | Description
Subscribe | Subscribes to the value of the variable.


IExternalVariable.Subscribe Method

IExternalVariable.Subscribe Method
IExternalVariable Interface Eco.ObjectRepresentation Namespace See Also
Collapse All

Subscribes to the value of the variable.

C#
void Subscribe(
    ISubscriber subscriber
);
Remarks

An event will be sent if the Eco.ObjectRepresentation.IExternalVariable.Element changes.

See Also
IExternalVariable Interface
Eco.ObjectRepresentation Namespace


IExternalVariable Properties

IExternalVariable Properties
Public Properties
Collapse All

The properties of the IExternalVariable class are listed here.

Public Properties
Name | Description
Element | An Eco.ObjectRepresentation.IElement which is the value of the variable.
Name | The name of the variable.
StaticUmlType | The static type of varaible.


IExternalVariable.Element Property

IExternalVariable.Element Property
IExternalVariable Interface Eco.ObjectRepresentation Namespace See Also
Collapse All

An Eco.ObjectRepresentation.IElement which is the value of the variable.

C#
IElement Element;
See Also
IExternalVariable Interface
Eco.ObjectRepresentation Namespace


IExternalVariable.Name Property

IExternalVariable.Name Property
IExternalVariable Interface Eco.ObjectRepresentation Namespace See Also
Collapse All

The name of the variable.

C#
string Name;
See Also
IExternalVariable Interface
Eco.ObjectRepresentation Namespace


IExternalVariable.StaticUmlType Property

IExternalVariable.StaticUmlType Property
IExternalVariable Interface Eco.ObjectRepresentation Namespace See Also
Collapse All

The static type of varaible.

C#
IClassifier StaticUmlType;
Remarks

When setting the value of Eco.ObjectRepresentation.IExternalVariable.Element it must be of this type or one of its sub types.

See Also
IExternalVariable Interface
Eco.ObjectRepresentation Namespace


IExternalVariableList Interface

IExternalVariableList Interface
Inheritance Hierarchy Related Topics See Also
Collapse All

This interface is used for representing a collection of variables.

C#
public interface IExternalVariableList;
Remarks

The collection held by this list will be of type Eco.ObjectRepresentation.IExternalVariable. This interface is passed to the methods on the various OCL evaluator interfaces. At design time it is possible to define a variable list using the Eco.Handles.OclVariables" component.

Related Topics

Eco.Services.IOclService, Eco.Services.IOclPsService, Eco.Services.IActionLanguageService, Eco.Services.IVariableFactoryService

Inheritance Hierarchy
Eco.ObjectRepresentation.IExternalVariableList
    Eco.ObjectRepresentation.IModifiableVariableList
File

ObjectRepresentation.cs

See Also
Inheritance Hierarchy
Related Topics


IExternalVariableList Methods

IExternalVariableList Methods
Public Methods
Collapse All

The methods of the IExternalVariableList class are listed here.

Public Methods
Name | Description
GetEnumerator | Returns an IEnumerator for the IExternalVariable elements in the list
Subscribe | Subscribes to changes in the list of the variables (changed names, changed types, added/removed variables.
this | This is the overview for the this indexer overload.


IExternalVariableList.GetEnumerator Method

IExternalVariableList.GetEnumerator Method
IExternalVariableList Interface Eco.ObjectRepresentation Namespace See Also
Collapse All

Returns an IEnumerator for the IExternalVariable elements in the list

C#
IEnumerator GetEnumerator();
See Also
IExternalVariableList Interface
Eco.ObjectRepresentation Namespace


IExternalVariableList.Subscribe Method

IExternalVariableList.Subscribe Method
IExternalVariableList Interface Eco.ObjectRepresentation Namespace See Also
Collapse All

Subscribes to changes in the list of the variables (changed names, changed types, added/removed variables.

C#
void Subscribe(
    ISubscriber subscriber
);
See Also
IExternalVariableList Interface
Eco.ObjectRepresentation Namespace


this Indexer

this Indexer

This is the overview for the this indexer overload.

Overload List
Name | Description
IExternalVariableList.this (int) | Gets a variable by its index within the collection.
IExternalVariableList.this (string) | Gets a variable by its unique name within the collection.


IExternalVariableList.this Indexer (int)

IExternalVariableList.this Indexer (int)
IExternalVariableList Interface Eco.ObjectRepresentation Namespace See Also
Collapse All

Gets a variable by its index within the collection.

C#
IExternalVariable this[
    int index
];
See Also
IExternalVariableList Interface
Eco.ObjectRepresentation Namespace


IExternalVariableList.this Indexer (string)

IExternalVariableList.this Indexer (string)
IExternalVariableList Interface Eco.ObjectRepresentation Namespace See Also
Collapse All

Gets a variable by its unique name within the collection.

C#
IExternalVariable this[
    string name
];
Remarks

If no variable exists within the collection with the given name, null will be returned.

See Also
IExternalVariableList Interface
Eco.ObjectRepresentation Namespace


IExternalVariableList Properties

IExternalVariableList Properties
Public Properties
Collapse All

The properties of the IExternalVariableList class are listed here.

Public Properties
Name | Description
Count | Returns the number of variables in the list.


IExternalVariableList.Count Property

IExternalVariableList.Count Property
IExternalVariableList Interface Eco.ObjectRepresentation Namespace See Also
Collapse All

Returns the number of variables in the list.

C#
int Count;
See Also
IExternalVariableList Interface
Eco.ObjectRepresentation Namespace


IFeatured Interface

IFeatured Interface
Inheritance Hierarchy Related Topics See Also
Collapse All

Provides a way of accessing a collection of Eco.ObjectRepresentation.IProperty.

C#
public interface IFeatured : IElement;
Related Topics

Eco.ObjectRepresentation.IProperty, Eco.ObjectRepresentation.IObject

Inheritance Hierarchy
Eco.ObjectRepresentation.IElementProvider
    Eco.ObjectRepresentation.IElement
        Eco.ObjectRepresentation.IFeatured
            Eco.ObjectRepresentation.IObject
            Eco.ObjectRepresentation.ITuple
File

ObjectRepresentation.cs

See Also
Inheritance Hierarchy
Related Topics


IFeatured Properties

IFeatured Properties
Public Properties
Collapse All

The properties of the IFeatured class are listed here.

Public Properties
Name | Description
Properties | Provides access to a collection of properties owned by the implementor.


IFeatured.Properties Property

IFeatured.Properties Property
IFeatured Interface Eco.ObjectRepresentation Namespace See Also
Collapse All

Provides access to a collection of properties owned by the implementor.

C#
IPropertyCollection Properties;
See Also
IFeatured Interface
Eco.ObjectRepresentation Namespace


IModifiableVariableList Interface

IModifiableVariableList Interface
Inheritance Hierarchy See Also
Collapse All

This is a sub interface of Eco.ObjectRepresentation.IExternalVariableList. is used for representing a collection of variables that can be modfiied by adding or removing variables.

C#
public interface IModifiableVariableList : IExternalVariableList;
Inheritance Hierarchy
Eco.ObjectRepresentation.IExternalVariableList
    Eco.ObjectRepresentation.IModifiableVariableList
File

ObjectRepresentation.cs

See Also
Inheritance Hierarchy


IModifiableVariableList Methods

IModifiableVariableList Methods
Public Methods
Collapse All

The methods of the IModifiableVariableList class are listed here.

Public Methods
Name | Description
Add | This is the overview for the Add method overload.
AddConstant | Adds a named constant to the collection containing the specified value.
Remove | Removes a variable from the collection by its name.
RemoveAt | Removes a variable from the collection by its index.


Add Method

Add Method

This is the overview for the Add method overload.

Overload List
Name | Description
IModifiableVariableList.Add (IExternalVariable) | Adds an existing variable to the collection.
IModifiableVariableList.Add (string, IClassifier) | Adds a named variable to the collection with the default value for the given type.
IModifiableVariableList.Add (string, IElement) | Adds a named variable to the collection.
IModifiableVariableList.Add (string, Type) | Adds a named variable to the collection with the default value for the given type.


IModifiableVariableList.Add Method (IExternalVariable)

IModifiableVariableList.Add Method (IExternalVariable)
IModifiableVariableList Interface Eco.ObjectRepresentation Namespace See Also
Collapse All

Adds an existing variable to the collection.

C#
void Add(
    IExternalVariable variable
);
Parameters
Parameters | Description
variable | The variable to add.
See Also
IModifiableVariableList Interface
Eco.ObjectRepresentation Namespace


IModifiableVariableList.Add Method (string, IClassifier)

IModifiableVariableList.Add Method (string, IClassifier)
IModifiableVariableList Interface Eco.ObjectRepresentation Namespace See Also
Collapse All

Adds a named variable to the collection with the default value for the given type.

C#
void Add(
    string name,
    IClassifier umlType
);
Parameters
Parameters | Description
name | The unique name of the variable to add.
umlType | The model type of the element to create.
Remarks

The Eco.Services.IVariableFactoryService is used to create a new element of the correct type, this element is then added to the collection with the specified name.

See Also
IModifiableVariableList Interface
Eco.ObjectRepresentation Namespace


IModifiableVariableList.Add Method (string, IElement)

IModifiableVariableList.Add Method (string, IElement)
IModifiableVariableList Interface Eco.ObjectRepresentation Namespace See Also
Collapse All

Adds a named variable to the collection.

C#
void Add(
    string name,
    IElement element
);
Parameters
Parameters | Description
name | The unique name of the variable to add.
element | The element to hold for the given name,
See Also
IModifiableVariableList Interface
Eco.ObjectRepresentation Namespace


IModifiableVariableList.Add Method (string, Type)

IModifiableVariableList.Add Method (string, Type)
IModifiableVariableList Interface Eco.ObjectRepresentation Namespace See Also
Collapse All

Adds a named variable to the collection with the default value for the given type.

C#
void Add(
    string name,
    Type t
);
Parameters
Parameters | Description
name | The unique name of the variable to add.
t | The .NET type of the element to create.
Remarks

The correct Eco.UmlRt.IClassifier is found that represents the .NET type passed. The Eco.Services.IVariableFactoryService is then used to create a new element of the correct type, this element is then added to the collection with the specified name.

See Also
IModifiableVariableList Interface
Eco.ObjectRepresentation Namespace


IModifiableVariableList.AddConstant Method

IModifiableVariableList.AddConstant Method
IModifiableVariableList Interface Eco.ObjectRepresentation Namespace See Also
Collapse All

Adds a named constant to the collection containing the specified value.

C#
void AddConstant(
    string name,
    object value
);
Parameters
Parameters | Description
name | The unique name of the variable to add.
value | The value the newly created variable should hold as an element.
Remarks

The correct Eco.UmlRt.IClassifier is found that represents the .NET type of the value passed. The Eco.Services.IVariableFactoryService is then used to create a new element of the correct type, this element is then added to the collection with the specified name and value.

See Also
IModifiableVariableList Interface
Eco.ObjectRepresentation Namespace


IModifiableVariableList.Remove Method

IModifiableVariableList.Remove Method
IModifiableVariableList Interface Eco.ObjectRepresentation Namespace See Also
Collapse All

Removes a variable from the collection by its name.

C#
void Remove(
    string name
);
Parameters
Parameters | Description
name | The unique name of the variable to remove.
See Also
IModifiableVariableList Interface
Eco.ObjectRepresentation Namespace


IModifiableVariableList.RemoveAt Method

IModifiableVariableList.RemoveAt Method
IModifiableVariableList Interface Eco.ObjectRepresentation Namespace See Also
Collapse All

Removes a variable from the collection by its index.

C#
void RemoveAt(
    int i
);
Parameters
Parameters | Description
i | The index of the variable to remove.
See Also
IModifiableVariableList Interface
Eco.ObjectRepresentation Namespace


INonDeletableReason Interface

INonDeletableReason Interface
Inheritance Hierarchy Related Topics See Also
Collapse All

Identifies the reason an object cannot be deleted.

C#
public interface INonDeletableReason;
Related Topics

Eco.ObjectRepresentation.IObject.Delete, Eco.ObjectRepresentation.IObject.IsDeletable

Inheritance Hierarchy
Eco.ObjectRepresentation.INonDeletableReason
File

ObjectRepresentation.cs

See Also
Inheritance Hierarchy
Related Topics


INonDeletableReason Properties

INonDeletableReason Properties
Public Properties
Collapse All

The properties of the INonDeletableReason class are listed here.

Public Properties
Name | Description
AssociationEnd | Identifies the association end involved in preventing deletion.
Obj | Identifies the associated object which prevents deletion.


INonDeletableReason.AssociationEnd Property

INonDeletableReason.AssociationEnd Property
INonDeletableReason Interface Eco.ObjectRepresentation Namespace See Also
Collapse All

Identifies the association end involved in preventing deletion.

C#
IAssociationEnd AssociationEnd;
See Also
INonDeletableReason Interface
Eco.ObjectRepresentation Namespace


INonDeletableReason.Obj Property

INonDeletableReason.Obj Property
INonDeletableReason Interface Eco.ObjectRepresentation Namespace See Also
Collapse All

Identifies the associated object which prevents deletion.

C#
IObjectInstance Obj;
See Also
INonDeletableReason Interface
Eco.ObjectRepresentation Namespace


IObject Interface

IObject Interface
Inheritance Hierarchy Related Topics See Also
Collapse All

Provides access to basic object features.

C#
public interface IObject : IObjectContainer, IFeatured, IEcoObject;
Remarks

This interface provides programmatic access to some ECO features of an instance of a modeled UML class or a reference to an instance. It is accessible via the AsIObject() method of any generated .NET class.

Related Topics

Eco.ObjectRepresentation.IObjectInstance, Eco.ObjectRepresentation.IObjectReference

Inheritance Hierarchy
Eco.ObjectRepresentation.IElementProvider
    Eco.ObjectRepresentation.IElement
        Eco.ObjectRepresentation.IFeatured
        Eco.ObjectRepresentation.IObjectContainer
        Eco.ObjectRepresentation.IEcoObject
            Eco.ObjectRepresentation.IObject
                Eco.ObjectRepresentation.IObjectInstance
                Eco.ObjectRepresentation.IObjectReference
File

ObjectRepresentation.cs

See Also
Inheritance Hierarchy
Related Topics


IObject Methods

IObject Methods
Public Methods
Collapse All

The methods of the IObject class are listed here.

Public Methods
Name | Description
Delete | Marks the object for deletion when the next update to the data store.
EnsureFetched | Calling this method will ensure that the object is fetched from the database


IObject.Delete Method

IObject.Delete Method
IObject Interface Eco.ObjectRepresentation Namespace Related Topics See Also
Collapse All

Marks the object for deletion when the next update to the data store.

C#
void Delete();
Remarks

The object is identified within ECO as deleted and no longer appears in in-memory OCL evaluations such as:

Copy Code
MyClass.allInstances

The object and its contents are not discarded from memory until the data store is updated with this object. This enables objects to be un-deleted and re-deleted repeatedly by using undo blocks.

Related Topics

Eco.Services.IUndoService

See Also
IObject Interface
Eco.ObjectRepresentation Namespace
Related Topics


IObject.EnsureFetched Method

IObject.EnsureFetched Method
IObject Interface Eco.ObjectRepresentation Namespace See Also
Collapse All

Calling this method will ensure that the object is fetched from the database

C#
void EnsureFetched();
See Also
IObject Interface
Eco.ObjectRepresentation Namespace


IObject Properties

IObject Properties
Public Properties
Collapse All

The properties of the IObject class are listed here.

Public Properties
Name | Description
DefaultStringRepresentation | Returns the result of evaluating the OCL expression for DefaultStringRepresentation for the object.
Deleted | Indicates whether or not the object has been deleted, or has been marked for deletion during the next update to the data store.
IsDeletable | Indicates whether or not it is possible to delete the object.
NonDeletableReason | Identifies the associated object and association end which would prevent deletion.
ObjectInstance | Returns the IObjectInstance for this object/reference.


IObject.DefaultStringRepresentation Property

IObject.DefaultStringRepresentation Property
IObject Interface Eco.ObjectRepresentation Namespace See Also
Collapse All

Returns the result of evaluating the OCL expression for DefaultStringRepresentation for the object.

C#
string DefaultStringRepresentation;
See Also
IObject Interface
Eco.ObjectRepresentation Namespace


IObject.Deleted Property

IObject.Deleted Property
IObject Interface Eco.ObjectRepresentation Namespace See Also
Collapse All

Indicates whether or not the object has been deleted, or has been marked for deletion during the next update to the data store.

C#
bool Deleted;
See Also
IObject Interface
Eco.ObjectRepresentation Namespace


IObject.IsDeletable Property

IObject.IsDeletable Property
IObject Interface Eco.ObjectRepresentation Namespace See Also
Collapse All

Indicates whether or not it is possible to delete the object.

C#
bool IsDeletable;
Remarks

IsDeletable returns True if it will be possible to delete the object. It will check if the object has any non-empty associations with the DeleteAction "Prohibit". It will also check recursively along any association with the DeleteAction "Cascade". If an association is found that would prevent deletion it will be identified in the Eco.ObjectRepresentation.IObject.NonDeletableReason property.

See Also
IObject Interface
Eco.ObjectRepresentation Namespace


IObject.NonDeletableReason Property

IObject.NonDeletableReason Property
IObject Interface Eco.ObjectRepresentation Namespace See Also
Collapse All

Identifies the associated object and association end which would prevent deletion.

C#
INonDeletableReason NonDeletableReason;
Remarks

If IsDeletable returns False, then this Property will return an object that contains a reference to the object and the association end that prevents the delete.

See Also
IObject Interface
Eco.ObjectRepresentation Namespace


IObject.ObjectInstance Property

IObject.ObjectInstance Property
IObject Interface Eco.ObjectRepresentation Namespace See Also
Collapse All

Returns the IObjectInstance for this object/reference.

C#
IObjectInstance ObjectInstance;
Remarks

In the case of a true object instance this will return the same object, for an object reference it will return the true Eco.ObjectRepresentation.IObjectInstance. For a object reference that is null, it will return the apropriate null object for the type.

See Also
IObject Interface
Eco.ObjectRepresentation Namespace


IObjectContainer Interface

IObjectContainer Interface
Inheritance Hierarchy See Also
Collapse All

Identifies the holder of an IObject or list of IObject.

C#
public interface IObjectContainer : IElement;
Inheritance Hierarchy
Eco.ObjectRepresentation.IElementProvider
    Eco.ObjectRepresentation.IElement
        Eco.ObjectRepresentation.IObjectContainer
            Eco.ObjectRepresentation.IObject
            Eco.ObjectRepresentation.IObjectList
File

ObjectRepresentation.cs

See Also
Inheritance Hierarchy


IObjectContainer Methods

IObjectContainer Methods
Public Methods
Collapse All

The methods of the IObjectContainer class are listed here.

Public Methods
Name | Description
Clear | For an Eco.ObjectRepresentation.IObjectList this will empty the list, for an Eco.ObjectRepresentation.IObjectInstance this will set the value referenced to null.
GetAsList | Returns an Eco.ObjectRepresentation.IObjectList of objects contained.


IObjectContainer.Clear Method

IObjectContainer.Clear Method
IObjectContainer Interface Eco.ObjectRepresentation Namespace See Also
Collapse All

For an Eco.ObjectRepresentation.IObjectList this will empty the list, for an Eco.ObjectRepresentation.IObjectInstance this will set the value referenced to null.

C#
void Clear();
See Also
IObjectContainer Interface
Eco.ObjectRepresentation Namespace


IObjectContainer.GetAsList Method

IObjectContainer.GetAsList Method
IObjectContainer Interface Eco.ObjectRepresentation Namespace See Also
Collapse All

Returns an Eco.ObjectRepresentation.IObjectList of objects contained.

C#
IObjectList GetAsList();
Remarks

An Eco.ObjectRepresentation.IObjectList will return itself, an Eco.ObjectRepresentation.IObject will return a new IObjectList containing a single item.

See Also
IObjectContainer Interface
Eco.ObjectRepresentation Namespace


IObjectContainer Properties

IObjectContainer Properties
Public Properties
Collapse All

The properties of the IObjectContainer class are listed here.

Public Properties
Name | Description
Count | Returns the number of IObject instances held by the container.
UmlClass | Identifies the base UML class that the container may hold.


IObjectContainer.Count Property

IObjectContainer.Count Property
IObjectContainer Interface Eco.ObjectRepresentation Namespace See Also
Collapse All

Returns the number of IObject instances held by the container.

C#
int Count;
See Also
IObjectContainer Interface
Eco.ObjectRepresentation Namespace


IObjectContainer.UmlClass Property

IObjectContainer.UmlClass Property
IObjectContainer Interface Eco.ObjectRepresentation Namespace See Also
Collapse All

Identifies the base UML class that the container may hold.

C#
IClass UmlClass;
See Also
IObjectContainer Interface
Eco.ObjectRepresentation Namespace


IObjectInstance Interface

IObjectInstance Interface
Inheritance Hierarchy See Also
Collapse All

Identifies an Eco.ObjectRepresentation.IObject as an actual object instance rather than a reference to an object instance.

C#
public interface IObjectInstance : IObject;
Inheritance Hierarchy
Eco.ObjectRepresentation.IElementProvider
    Eco.ObjectRepresentation.IElement
        Eco.ObjectRepresentation.IFeatured
        Eco.ObjectRepresentation.IObjectContainer
        Eco.ObjectRepresentation.IEcoObject
            Eco.ObjectRepresentation.IObject
                Eco.ObjectRepresentation.IObjectInstance
File

ObjectRepresentation.cs

See Also
Inheritance Hierarchy


IObjectInstance Methods

IObjectInstance Methods
Public Methods
Collapse All

The methods of the IObjectInstance class are listed here.

Public Methods
Name | Description
Invoke | This is the overview for the Invoke method overload.
InvokeQuery | Invokes a modeled query method on the object instance.


Invoke Method

Invoke Method

This is the overview for the Invoke method overload.

Overload List
Name | Description
IObjectInstance.Invoke (IMethod, IElement[]) | Invokes a modeled method on the object instance.
IObjectInstance.Invoke (IMethod, object[]) | Invokes a modeled method on the object instance.
IObjectInstance.Invoke (string, object[]) | Invokes a modeled method on the object instance.


IObjectInstance.Invoke Method (IMethod, IElement[])

IObjectInstance.Invoke Method (IMethod, IElement[])
IObjectInstance Interface Eco.ObjectRepresentation Namespace See Also
Collapse All

Invokes a modeled method on the object instance.

C#
object Invoke(
    IMethod method,
    IElement[] parameters
);
Parameters
Parameters | Description
method | The model element identifying the method to execute.
parameters | An array of elements representing the parameter values to pass to the method.
Returns

Returns the return value of the method. Void methods will return null.

Remarks

The method on the instance of the .NET class is found and invoked using .NET reflection.

See Also
IObjectInstance Interface
Eco.ObjectRepresentation Namespace


IObjectInstance.Invoke Method (IMethod, object[])

IObjectInstance.Invoke Method (IMethod, object[])
IObjectInstance Interface Eco.ObjectRepresentation Namespace See Also
Collapse All

Invokes a modeled method on the object instance.

C#
object Invoke(
    IMethod method,
    object[] parameters
);
Parameters
Parameters | Description
method | The model element identifying the method to execute.
parameters | An array of objects to use as the parameters for the method call.
Returns

Returns the return value of the method. Void methods will return null.

Remarks

The method on the instance of the .NET class is found and invoked using .NET reflection.

See Also
IObjectInstance Interface
Eco.ObjectRepresentation Namespace


IObjectInstance.Invoke Method (string, object[])

IObjectInstance.Invoke Method (string, object[])
IObjectInstance Interface Eco.ObjectRepresentation Namespace See Also
Collapse All

Invokes a modeled method on the object instance.

C#
object Invoke(
    string methodName,
    object[] parameters
);
Parameters
Parameters | Description
methodName | The modeled name of the method to invoke.
parameters | An array of objects to use as the parameters for the method call.
Returns

Returns the return value of the method. Void methods will return null.

Remarks

The method on the instance of the .NET class is found and invoked using .NET reflection.

See Also
IObjectInstance Interface
Eco.ObjectRepresentation Namespace


IObjectInstance.InvokeQuery Method

IObjectInstance.InvokeQuery Method
IObjectInstance Interface Eco.ObjectRepresentation Namespace Related Topics See Also
Collapse All

Invokes a modeled query method on the object instance.

C#
object InvokeQuery(
    IMethod method,
    IElement[] parameters,
    ISubscriber reevaluateSubscriber,
    ISubscriber resubscribeSubscriber
);
Parameters
Parameters | Description
method | The model element identifying the method to execute.
parameters | An array of elements representing the parameter values to pass to the method.
reevaluateSubscriber | The subscriber to notify when an element value changes.
resubscribeSubscriber | The subscrber to notify when the list of possible elements to subscribe to has changed.
Related Topics

Eco.UmlRt.IMethod.IsQuery

See Also
IObjectInstance Interface
Eco.ObjectRepresentation Namespace
Related Topics


IObjectInstance Properties

IObjectInstance Properties
Public Properties
Collapse All

The properties of the IObjectInstance class are listed here.

Public Properties
Name | Description
IsNullInstance | This is IsNullInstance, a member of class IObjectInstance.
StateMachine | Provides access to the instance’s state machine and its UML model information.


IObjectInstance.IsNullInstance Property

IObjectInstance.IsNullInstance Property
IObjectInstance Interface Eco.ObjectRepresentation Namespace See Also
Collapse All
C#
bool IsNullInstance;
Remarks

This is IsNullInstance, a member of class IObjectInstance.

See Also
IObjectInstance Interface
Eco.ObjectRepresentation Namespace


IObjectInstance.StateMachine Property

IObjectInstance.StateMachine Property
IObjectInstance Interface Eco.ObjectRepresentation Namespace See Also
Collapse All

Provides access to the instance’s state machine and its UML model information.

C#
IObjectStateMachine StateMachine;
See Also
IObjectInstance Interface
Eco.ObjectRepresentation Namespace


IObjectList Interface

IObjectList Interface
Inheritance Hierarchy See Also
Collapse All

Holds a collection of IObject.

C#
public interface IObjectList : IObjectContainer, IEnumerable<IObjectInstance>;
Inheritance Hierarchy
Eco.ObjectRepresentation.IElementProvider
    Eco.ObjectRepresentation.IElement
        Eco.ObjectRepresentation.IObjectContainer
            Eco.ObjectRepresentation.IObjectList
File

ObjectRepresentation.cs

See Also
Inheritance Hierarchy


IObjectList Methods

IObjectList Methods
Public Methods
Collapse All

The methods of the IObjectList class are listed here.

Public Methods
Name | Description
Add | Adds an object to the list.
AddNew | If the list supports AddNew (see SupportsAddNew), a new object is created and added to the list.
Contains | Indicates whether or not the object is in the list.
EnsureIdsOnly | Ensures that only the object IDs in this list of this are retrieved from the data store.
EnsureObjects | Ensures that the contents of the objects in the list are fetched into the local cache.
EnsureRelatedObjects | Ensures that the contents of the objects in the list are fetched into the local cache, and also all objects available via the association
GetAsEcoList | Returns a strongly typed list that represent the same list of objects as the original list.
IndexOf | Returns the index of the IObject within the collection.
Insert | Inserts the given object at the specified index.
InternalGet | Returns the object at the specified index.
Remove | Removes the specified object from the collection.
RemoveAt | Removes the IObject at the given index from the collection.
this | Returns the object at the specified index.


IObjectList.Add Method

IObjectList.Add Method
IObjectList Interface Eco.ObjectRepresentation Namespace See Also
Collapse All

Adds an object to the list.

C#
void Add(
    IEcoObject value
);
Parameters
Parameters | Description
value | The IObject to add to the list.
Exceptions
Exceptions | Description
ArgumentNullException | Thrown if value is null.
InvalidOperationException | Thrown if the list is read-only.
See Also
IObjectList Interface
Eco.ObjectRepresentation Namespace


IObjectList.AddNew Method

IObjectList.AddNew Method
IObjectList Interface Eco.ObjectRepresentation Namespace See Also
Collapse All

If the list supports AddNew (see SupportsAddNew), a new object is created and added to the list.

C#
IElement AddNew();
See Also
IObjectList Interface
Eco.ObjectRepresentation Namespace


IObjectList.Contains Method

IObjectList.Contains Method
IObjectList Interface Eco.ObjectRepresentation Namespace See Also
Collapse All

Indicates whether or not the object is in the list.

C#
bool Contains(
    IEcoObject value
);
See Also
IObjectList Interface
Eco.ObjectRepresentation Namespace


IObjectList.EnsureIdsOnly Method

IObjectList.EnsureIdsOnly Method
IObjectList Interface Eco.ObjectRepresentation Namespace See Also
Collapse All

Ensures that only the object IDs in this list of this are retrieved from the data store.

C#
void EnsureIdsOnly();
Remarks

This is useful if the list is a multilink that has "LinkFetchStrategy = FetchObjects". By loading the IDs of the list, the contents of the objects can be loaded on demand using Eco.ObjectRepresentation.IElementCollection.EnsureRange.

See Also
IObjectList Interface
Eco.ObjectRepresentation Namespace


IObjectList.EnsureObjects Method

IObjectList.EnsureObjects Method
IObjectList Interface Eco.ObjectRepresentation Namespace See Also
Collapse All

Ensures that the contents of the objects in the list are fetched into the local cache.

C#
void EnsureObjects();
Remarks

The objects will be loaded as efficiently as possible. After calling this method, accessing the objects in the list will not lead to any additional data store accesses.

Note that attributes with "DelayFetch=true" and non-embedded links are not loaded.

See Also
IObjectList Interface
Eco.ObjectRepresentation Namespace


IObjectList.EnsureRelatedObjects Method

IObjectList.EnsureRelatedObjects Method
IObjectList Interface Eco.ObjectRepresentation Namespace See Also
Collapse All

Ensures that the contents of the objects in the list are fetched into the local cache, and also all objects available via the association

C#
IObjectList EnsureRelatedObjects(
    string memberName
);
Parameters
Parameters | Description
memberName | .
Remarks

The objects will be loaded as efficiently as possible. After calling this method, accessing the objects in the list will not lead to any additional data store access.

Note that attributes with "DelayFetch=true" and non-embedded links are not loaded.

See Also
IObjectList Interface
Eco.ObjectRepresentation Namespace


IObjectList.GetAsEcoList Method

IObjectList.GetAsEcoList Method
IObjectList Interface Eco.ObjectRepresentation Namespace See Also
Collapse All

Returns a strongly typed list that represent the same list of objects as the original list.

C#
Eco.ObjectImplementation.IEcoList<T> GetAsEcoList<T>() where T : class, IEcoObject;
See Also
IObjectList Interface
Eco.ObjectRepresentation Namespace


IObjectList.IndexOf Method

IObjectList.IndexOf Method
IObjectList Interface Eco.ObjectRepresentation Namespace See Also
Collapse All

Returns the index of the IObject within the collection.

C#
int IndexOf(
    IEcoObject value
);
Parameters
Parameters | Description
value | The IObject to find the index of.
Returns

-1 if the object is not in the collection, otherwise the object’s index.

Exceptions
Exceptions | Description
ArgumentNullException | Thrown if value is null.
See Also
IObjectList Interface
Eco.ObjectRepresentation Namespace


IObjectList.Insert Method

IObjectList.Insert Method
IObjectList Interface Eco.ObjectRepresentation Namespace See Also
Collapse All

Inserts the given object at the specified index.

C#
void Insert(
    int index,
    IEcoObject value
);
Parameters
Parameters | Description
index | The index at which to insert the object.
value | The IObject to insert into the collection.
Remarks

Note that an un-ordered relation may ignore the index and add the object at the end.

Exceptions
Exceptions | Description
ArgumentNullException | Thrown if value is null.
InvalidOperationException | Thrown if the list is read only.
See Also
IObjectList Interface
Eco.ObjectRepresentation Namespace


IObjectList.InternalGet Method

IObjectList.InternalGet Method
IObjectList Interface Eco.ObjectRepresentation Namespace See Also
Collapse All

Returns the object at the specified index.

C#
IObjectInstance InternalGet(
    int index
);
Parameters
Parameters | Description
index | The index of the object to return.
Remarks

Similar to the indexer (IObjectList[index]) but without any attempts to fetch the objects from the data store.

See Also
IObjectList Interface
Eco.ObjectRepresentation Namespace


IObjectList.Remove Method

IObjectList.Remove Method
IObjectList Interface Eco.ObjectRepresentation Namespace See Also
Collapse All

Removes the specified object from the collection.

C#
void Remove(
    IEcoObject value
);
Parameters
Parameters | Description
value | The IObject to remove from the collection.
Exceptions
Exceptions | Description
NullReferenceException | Throw if value is null.
InvalidOperationException | Thrown if IElement.ReadOnly returns True.
See Also
IObjectList Interface
Eco.ObjectRepresentation Namespace


IObjectList.RemoveAt Method

IObjectList.RemoveAt Method
IObjectList Interface Eco.ObjectRepresentation Namespace See Also
Collapse All

Removes the IObject at the given index from the collection.

C#
void RemoveAt(
    int index
);
Parameters
Parameters | Description
index | The index of the IObject to remove.
Exceptions
Exceptions | Description
InvalidOperationException | Thrown if IObjectList.SupportsRemoveAt returns False.
See Also
IObjectList Interface
Eco.ObjectRepresentation Namespace


IObjectList.this Indexer

IObjectList.this Indexer
IObjectList Interface Eco.ObjectRepresentation Namespace See Also
Collapse All

Returns the object at the specified index.

C#
IObjectInstance this[
    int index
];
Remarks

When retrieving persistent objects from a list their contents will automatically be fetched from the data store. For optimization purposes ECO will fetch a page of objects in one go rather than only the object requested.

See Also
IObjectList Interface
Eco.ObjectRepresentation Namespace


IObjectList Properties

IObjectList Properties
Public Properties
Collapse All

The properties of the IObjectList class are listed here.

Public Properties
Name | Description
RemoveDeletedObjects | Indicates whether or not objects should be automatically removed from the list when they are marked as deleted.
SupportsAddNew | Indicates whether or not it is permissable to execute AddNew.
SupportsRemoveAt | Indicates whether or not it is permissable to execute RemoveAt or Remove.


IObjectList.RemoveDeletedObjects Property

IObjectList.RemoveDeletedObjects Property
IObjectList Interface Eco.ObjectRepresentation Namespace Related Topics See Also
Collapse All

Indicates whether or not objects should be automatically removed from the list when they are marked as deleted.

C#
bool RemoveDeletedObjects;
Remarks

If this property is True, the list will subscribe to the state of the objects it contains. Whenever an object is deleted it will be automatically removed from the list. It is still possible to add already deleted objects to the list.

Related Topics

IObject.Delete

See Also
IObjectList Interface
Eco.ObjectRepresentation Namespace
Related Topics


IObjectList.SupportsAddNew Property

IObjectList.SupportsAddNew Property
IObjectList Interface Eco.ObjectRepresentation Namespace See Also
Collapse All

Indicates whether or not it is permissable to execute AddNew.

C#
bool SupportsAddNew;
Remarks

The class that implements this interface determines whether or not this is supported. One example when this can return False is if the type of the list is that of an abstract class, or if the list is read only.

See Also
IObjectList Interface
Eco.ObjectRepresentation Namespace


IObjectList.SupportsRemoveAt Property

IObjectList.SupportsRemoveAt Property
IObjectList Interface Eco.ObjectRepresentation Namespace See Also
Collapse All

Indicates whether or not it is permissable to execute RemoveAt or Remove.

C#
bool SupportsRemoveAt;
Remarks

The class that implements this interface determines whether or not this is supported. One example when this can return False is if the list is read only.

See Also
IObjectList Interface
Eco.ObjectRepresentation Namespace


IObjectListProvider Interface

IObjectListProvider Interface
Inheritance Hierarchy See Also
Collapse All

Identifies the implementing class as being able to provide an IObjectList reference.

C#
public interface IObjectListProvider;
Inheritance Hierarchy
Eco.ObjectRepresentation.IObjectListProvider
File

ObjectRepresentation.cs

See Also
Inheritance Hierarchy


IObjectListProvider Properties

IObjectListProvider Properties
Public Properties
Collapse All

The properties of the IObjectListProvider class are listed here.

Public Properties
Name | Description
AsIObjectList | Returns the IObjectList instance.


IObjectListProvider.AsIObjectList Property

IObjectListProvider.AsIObjectList Property
IObjectListProvider Interface Eco.ObjectRepresentation Namespace See Also
Collapse All

Returns the IObjectList instance.

C#
IObjectList AsIObjectList;
See Also
IObjectListProvider Interface
Eco.ObjectRepresentation Namespace


IObjectProvider Interface

IObjectProvider Interface
Inheritance Hierarchy See Also
Collapse All

Identifies the implementing class as being able to provide an IObject reference.

C#
public interface IObjectProvider : IEcoObject;
Remarks

This interface is kept for backwaards compatibility only, new applications should use the more descriptive IEcoObject

Inheritance Hierarchy
Eco.ObjectRepresentation.IEcoObject
    Eco.ObjectRepresentation.IObjectProvider
File

ObjectRepresentation.cs

See Also
Inheritance Hierarchy


IObjectProvider Methods

IObjectProvider Methods
Public Methods
Collapse All

The methods of the IObjectProvider class are listed here.

Public Methods
Name | Description
AsIObject | Returns the IObject.


IObjectProvider.AsIObject Method

IObjectProvider.AsIObject Method
IObjectProvider Interface Eco.ObjectRepresentation Namespace See Also
Collapse All

Returns the IObject.

C#
new IObject AsIObject();
Returns

Always return an IObject, never returns null

See Also
IObjectProvider Interface
Eco.ObjectRepresentation Namespace


IObjectReference Interface

IObjectReference Interface
Inheritance Hierarchy See Also
Collapse All

Provides a reference to an IObjectInstance.

C#
public interface IObjectReference : IObject;
Inheritance Hierarchy
Eco.ObjectRepresentation.IElementProvider
    Eco.ObjectRepresentation.IElement
        Eco.ObjectRepresentation.IFeatured
        Eco.ObjectRepresentation.IObjectContainer
        Eco.ObjectRepresentation.IEcoObject
            Eco.ObjectRepresentation.IObject
                Eco.ObjectRepresentation.IObjectReference
File

ObjectRepresentation.cs

See Also
Inheritance Hierarchy


IObjectReference Properties

IObjectReference Properties
Public Properties
Collapse All

The properties of the IObjectReference class are listed here.

Public Properties
Name | Description
ObjectInstance | Gets or sets the reference to the IObject.


IObjectReference.ObjectInstance Property

IObjectReference.ObjectInstance Property
IObjectReference Interface Eco.ObjectRepresentation Namespace See Also
Collapse All

Gets or sets the reference to the IObject.

C#
new IObjectInstance ObjectInstance;
See Also
IObjectReference Interface
Eco.ObjectRepresentation Namespace


IObjectStateMachine Interface

IObjectStateMachine Interface
Inheritance Hierarchy See Also
Collapse All

Provides runtime access to the state machine of an ECO object.

C#
public interface IObjectStateMachine;
Inheritance Hierarchy
Eco.ObjectRepresentation.IObjectStateMachine
File

ObjectRepresentation.cs

See Also
Inheritance Hierarchy


IObjectStateMachine Methods

IObjectStateMachine Methods
Public Methods
Collapse All

The methods of the IObjectStateMachine class are listed here.

Public Methods
Name | Description
CanTrigger | This is the overview for the CanTrigger method overload.
GetStates | This is the overview for the GetStates method overload.
GetTransitions | This is the overview for the GetTransitions method overload.
GetTriggers | This is the overview for the GetTriggers method overload.
IsInRegion | This is the overview for the IsInRegion method overload.
IsInState | This is the overview for the IsInState method overload.
RegionByName | Retrieves a region by its fully qualified name.
StateByName | Retrieves a state by its fully qualified name.
SubscribeToState | Places a subscription on the active state of the state machine changing.
Trigger | This is the overview for the Trigger method overload.


CanTrigger Method

CanTrigger Method

This is the overview for the CanTrigger method overload.

Overload List
Name | Description
IObjectStateMachine.CanTrigger (ITrigger, IElement[]) | Indicates whether or not a trigger may be executed.
IObjectStateMachine.CanTrigger (ITrigger, IElement[], ISubscriber, ISubscriber) | Indicates whether or not a trigger may be executed.
IObjectStateMachine.CanTrigger (ITrigger, object[]) | Indicates whether or not a trigger may be executed.
IObjectStateMachine.CanTrigger (string, IElement[]) | Indicates whether or not a trigger may be executed.
IObjectStateMachine.CanTrigger (string, object[]) | Indicates whether or not a trigger may be executed.


IObjectStateMachine.CanTrigger Method (ITrigger, IElement[])

IObjectStateMachine.CanTrigger Method (ITrigger, IElement[])
IObjectStateMachine Interface Eco.ObjectRepresentation Namespace See Also
Collapse All

Indicates whether or not a trigger may be executed.

C#
bool CanTrigger(
    ITrigger trigger,
    IElement[] parameters
);
Parameters
Parameters | Description
trigger | The trigger to test.
parameters | An array of ECO elements to use as parameters for the trigger method.
Remarks

A trigger cannot be executed for any of the following reasons:

  • There are no outgoing transitions from the current state.
  • There is no outgoing transition from the current state that is invoked by the trigger.
  • A valid outgoing transition exists, but its guard expression evaluates to False.
See Also
IObjectStateMachine Interface
Eco.ObjectRepresentation Namespace


IObjectStateMachine.CanTrigger Method (ITrigger, IElement[], ISubscriber, ISubscriber)

IObjectStateMachine.CanTrigger Method (ITrigger, IElement[], ISubscriber, ISubscriber)
IObjectStateMachine Interface Eco.ObjectRepresentation Namespace See Also
Collapse All

Indicates whether or not a trigger may be executed.

C#
bool CanTrigger(
    ITrigger trigger,
    IElement[] parameters,
    ISubscriber reevaluateSubscriber,
    ISubscriber resubscribeSubscriber
);
Parameters
Parameters | Description
trigger | The trigger to test.
parameters | An array of ECO elements to use as parameters for the trigger method.
reevaluateSubscriber | A subscriber to notify when an element changes which may product a different result
resubscribeSubscriber | A subscriber to notify when subscriptions need to be replaced.
Remarks

A trigger cannot be executed for any of the following reasons:

  • There are no outgoing transitions from the current state.
  • There is no outgoing transition from the current state that is invoked by the trigger.
  • A valid outgoing transition exists, but its guard expression evaluates to False.
See Also
IObjectStateMachine Interface
Eco.ObjectRepresentation Namespace


IObjectStateMachine.CanTrigger Method (ITrigger, object[])

IObjectStateMachine.CanTrigger Method (ITrigger, object[])
IObjectStateMachine Interface Eco.ObjectRepresentation Namespace See Also
Collapse All

Indicates whether or not a trigger may be executed.

C#
bool CanTrigger(
    ITrigger trigger,
    object[] parameters
);
Parameters
Parameters | Description
trigger | The trigger to test.
parameters | An array of .NET objects to use as parameters for the trigger method.
Remarks

A trigger cannot be executed for any of the following reasons:

  • There are no outgoing transitions from the current state.
  • There is no outgoing transition from the current state that is invoked by the trigger.
  • A valid outgoing transition exists, but its guard expression evaluates to False.
See Also
IObjectStateMachine Interface
Eco.ObjectRepresentation Namespace


IObjectStateMachine.CanTrigger Method (string, IElement[])

IObjectStateMachine.CanTrigger Method (string, IElement[])
IObjectStateMachine Interface Eco.ObjectRepresentation Namespace See Also
Collapse All

Indicates whether or not a trigger may be executed.

C#
bool CanTrigger(
    string triggerName,
    IElement[] parameters
);
Parameters
Parameters | Description
triggerName | The name of the trigger to test.
parameters | An array of ECO elements to use as parameters for the trigger method.
Remarks

A trigger cannot be executed for any of the following reasons:

  • There are no outgoing transitions from the current state.
  • There is no outgoing transition from the current state that is invoked by the trigger.
  • A valid outgoing transition exists, but its guard expression evaluates to False.
See Also
IObjectStateMachine Interface
Eco.ObjectRepresentation Namespace


IObjectStateMachine.CanTrigger Method (string, object[])

IObjectStateMachine.CanTrigger Method (string, object[])
IObjectStateMachine Interface Eco.ObjectRepresentation Namespace See Also
Collapse All

Indicates whether or not a trigger may be executed.

C#
bool CanTrigger(
    string triggerName,
    object[] parameters
);
Parameters
Parameters | Description
triggerName | The name of the trigger to test.
parameters | An array of .NET objects to use as parameters for the trigger method.
Remarks

A trigger cannot be executed for any of the following reasons:

  • There are no outgoing transitions from the current state.
  • There is no outgoing transition from the current state that is invoked by the trigger.
  • A valid outgoing transition exists, but its guard expression evaluates to False.
See Also
IObjectStateMachine Interface
Eco.ObjectRepresentation Namespace


GetStates Method

GetStates Method

This is the overview for the GetStates method overload.

Overload List
Name | Description
IObjectStateMachine.GetStates (IRegion, StateFilter) | Returns a collection of states belonging to a region.
IObjectStateMachine.GetStates (StateFilter) | Returns a collection of states belonging to the state machine.
IObjectStateMachine.GetStates (string, StateFilter) | Returns a collection of states belonging to a region.


IObjectStateMachine.GetStates Method (IRegion, StateFilter)

IObjectStateMachine.GetStates Method (IRegion, StateFilter)
IObjectStateMachine Interface Eco.ObjectRepresentation Namespace See Also
Collapse All

Returns a collection of states belonging to a region.

C#
IStateCollection GetStates(
    IRegion region,
    StateFilter filter
);
Parameters
Parameters | Description
region | The region to return the states from.
filter | Only state with the specified type will be included.
See Also
IObjectStateMachine Interface
Eco.ObjectRepresentation Namespace


IObjectStateMachine.GetStates Method (StateFilter)

IObjectStateMachine.GetStates Method (StateFilter)
IObjectStateMachine Interface Eco.ObjectRepresentation Namespace See Also
Collapse All

Returns a collection of states belonging to the state machine.

C#
IStateCollection GetStates(
    StateFilter filter
);
Parameters
Parameters | Description
filter | Only state with the specified type will be included.
See Also
IObjectStateMachine Interface
Eco.ObjectRepresentation Namespace


IObjectStateMachine.GetStates Method (string, StateFilter)

IObjectStateMachine.GetStates Method (string, StateFilter)
IObjectStateMachine Interface Eco.ObjectRepresentation Namespace See Also
Collapse All

Returns a collection of states belonging to a region.

C#
IStateCollection GetStates(
    string regionName,
    StateFilter filter
);
Parameters
Parameters | Description
regionName | The name of the region to return the states from.
filter | Only state with the specified type will be included.
See Also
IObjectStateMachine Interface
Eco.ObjectRepresentation Namespace


GetTransitions Method

GetTransitions Method

This is the overview for the GetTransitions method overload.

Overload List
Name | Description
IObjectStateMachine.GetTransitions () | Returns a collection of transitions within the state machine.
IObjectStateMachine.GetTransitions (IRegion) | Returns a collection of transitions within a region.
IObjectStateMachine.GetTransitions (string) | Returns a collection of transitions within a region.


IObjectStateMachine.GetTransitions Method ()

IObjectStateMachine.GetTransitions Method ()
IObjectStateMachine Interface Eco.ObjectRepresentation Namespace See Also
Collapse All

Returns a collection of transitions within the state machine.

C#
ITransitionCollection GetTransitions();
See Also
IObjectStateMachine Interface
Eco.ObjectRepresentation Namespace


IObjectStateMachine.GetTransitions Method (IRegion)

IObjectStateMachine.GetTransitions Method (IRegion)
IObjectStateMachine Interface Eco.ObjectRepresentation Namespace See Also
Collapse All

Returns a collection of transitions within a region.

C#
ITransitionCollection GetTransitions(
    IRegion region
);
Parameters
Parameters | Description
region | The region to inspect for transitions.
See Also
IObjectStateMachine Interface
Eco.ObjectRepresentation Namespace


IObjectStateMachine.GetTransitions Method (string)

IObjectStateMachine.GetTransitions Method (string)
IObjectStateMachine Interface Eco.ObjectRepresentation Namespace See Also
Collapse All

Returns a collection of transitions within a region.

C#
ITransitionCollection GetTransitions(
    string regionName
);
Parameters
Parameters | Description
regionName | The region to inspect for transitions.
See Also
IObjectStateMachine Interface
Eco.ObjectRepresentation Namespace


GetTriggers Method

GetTriggers Method

This is the overview for the GetTriggers method overload.

Overload List
Name | Description
IObjectStateMachine.GetTriggers () | Returns a collection of triggers belonging to the state machine.
IObjectStateMachine.GetTriggers (IRegion) | Returns a collection of triggers used within a region.
IObjectStateMachine.GetTriggers (string) | Returns a collection of triggers used within a region.


IObjectStateMachine.GetTriggers Method ()

IObjectStateMachine.GetTriggers Method ()
IObjectStateMachine Interface Eco.ObjectRepresentation Namespace See Also
Collapse All

Returns a collection of triggers belonging to the state machine.

C#
ITriggerCollection GetTriggers();
See Also
IObjectStateMachine Interface
Eco.ObjectRepresentation Namespace


IObjectStateMachine.GetTriggers Method (IRegion)

IObjectStateMachine.GetTriggers Method (IRegion)
IObjectStateMachine Interface Eco.ObjectRepresentation Namespace See Also
Collapse All

Returns a collection of triggers used within a region.

C#
ITriggerCollection GetTriggers(
    IRegion region
);
Parameters
Parameters | Description
region | The region to inspect for used triggers.
See Also
IObjectStateMachine Interface
Eco.ObjectRepresentation Namespace


IObjectStateMachine.GetTriggers Method (string)

IObjectStateMachine.GetTriggers Method (string)
IObjectStateMachine Interface Eco.ObjectRepresentation Namespace See Also
Collapse All

Returns a collection of triggers used within a region.

C#
ITriggerCollection GetTriggers(
    string regionName
);
Parameters
Parameters | Description
regionName | The name of the region to inspect for used triggers.
See Also
IObjectStateMachine Interface
Eco.ObjectRepresentation Namespace


IsInRegion Method

IsInRegion Method

This is the overview for the IsInRegion method overload.

Overload List
Name | Description
IObjectStateMachine.IsInRegion (IRegion) | Indicates whether or not the active state belongs to the specified region.
IObjectStateMachine.IsInRegion (string) | Indicates whether or not the active state belongs to the specified region.


IObjectStateMachine.IsInRegion Method (IRegion)

IObjectStateMachine.IsInRegion Method (IRegion)
IObjectStateMachine Interface Eco.ObjectRepresentation Namespace See Also
Collapse All

Indicates whether or not the active state belongs to the specified region.

C#
bool IsInRegion(
    IRegion region
);
Parameters
Parameters | Description
region | The region to inspect.
Returns

True if the active state is owned by this region, or any regions owned by this region.

See Also
IObjectStateMachine Interface
Eco.ObjectRepresentation Namespace


IObjectStateMachine.IsInRegion Method (string)

IObjectStateMachine.IsInRegion Method (string)
IObjectStateMachine Interface Eco.ObjectRepresentation Namespace See Also
Collapse All

Indicates whether or not the active state belongs to the specified region.

C#
bool IsInRegion(
    string regionName
);
Parameters
Parameters | Description
regionName | The name of the region to inspect.
Returns

True if the active state is owned by this region, or any regions owned by this region.

See Also
IObjectStateMachine Interface
Eco.ObjectRepresentation Namespace


IsInState Method

IsInState Method

This is the overview for the IsInState method overload.

Overload List
Name | Description
IObjectStateMachine.IsInState (IState) | Indicates whether or not the specified state is the active state.
IObjectStateMachine.IsInState (IStateName) | Indicates whether or not the specified state is the active state.
IObjectStateMachine.IsInState (string) | Indicates whether or not the specified state is the active state.


IObjectStateMachine.IsInState Method (IState)

IObjectStateMachine.IsInState Method (IState)
IObjectStateMachine Interface Eco.ObjectRepresentation Namespace See Also
Collapse All

Indicates whether or not the specified state is the active state.

C#
bool IsInState(
    IState state
);
Parameters
Parameters | Description
state | The state to check.
See Also
IObjectStateMachine Interface
Eco.ObjectRepresentation Namespace


IObjectStateMachine.IsInState Method (IStateName)

IObjectStateMachine.IsInState Method (IStateName)
IObjectStateMachine Interface Eco.ObjectRepresentation Namespace See Also
Collapse All

Indicates whether or not the specified state is the active state.

C#
bool IsInState(
    IStateName stateName
);
Parameters
Parameters | Description
state | The state to check.
See Also
IObjectStateMachine Interface
Eco.ObjectRepresentation Namespace


IObjectStateMachine.IsInState Method (string)

IObjectStateMachine.IsInState Method (string)
IObjectStateMachine Interface Eco.ObjectRepresentation Namespace See Also
Collapse All

Indicates whether or not the specified state is the active state.

C#
bool IsInState(
    string stateName
);
Parameters
Parameters | Description
stateName | The fully qualified state name, e.g. Region1.Region2.State_1
See Also
IObjectStateMachine Interface
Eco.ObjectRepresentation Namespace


IObjectStateMachine.RegionByName Method

IObjectStateMachine.RegionByName Method
IObjectStateMachine Interface Eco.ObjectRepresentation Namespace See Also
Collapse All

Retrieves a region by its fully qualified name.

C#
IRegion RegionByName(
    string regionName
);
Parameters
Parameters | Description
regionName | The name of the region to retrieve.
See Also
IObjectStateMachine Interface
Eco.ObjectRepresentation Namespace


IObjectStateMachine.StateByName Method

IObjectStateMachine.StateByName Method
IObjectStateMachine Interface Eco.ObjectRepresentation Namespace See Also
Collapse All

Retrieves a state by its fully qualified name.

C#
IState StateByName(
    string stateName
);
Parameters
Parameters | Description
stateName | The name of the state to retrieve.
See Also
IObjectStateMachine Interface
Eco.ObjectRepresentation Namespace


IObjectStateMachine.SubscribeToState Method

IObjectStateMachine.SubscribeToState Method
IObjectStateMachine Interface Eco.ObjectRepresentation Namespace See Also
Collapse All

Places a subscription on the active state of the state machine changing.

C#
void SubscribeToState(
    ISubscriber subscriber
);
Parameters
Parameters | Description
subscriber | The subscriber to notify.
Remarks

The subscriber will be triggered whenever the active state of the state machine changes.

See Also
IObjectStateMachine Interface
Eco.ObjectRepresentation Namespace


Trigger Method

Trigger Method

This is the overview for the Trigger method overload.

Overload List
Name | Description
IObjectStateMachine.Trigger (ITrigger, IElement[]) | Executes the trigger on the object instance’s state machine identified by an Eco.UmlRt.ITrigger.
IObjectStateMachine.Trigger (ITrigger, object[]) | Executes the trigger on the object instance’s state machine identified by an Eco.UmlRt.ITrigger.
IObjectStateMachine.Trigger (string, IElement[]) | Executes the trigger on the object instance’s state machine identified by its modeled method name.
IObjectStateMachine.Trigger (string, object[]) | Executes the trigger on the object instance’s state machine identified by its modeled method name.


IObjectStateMachine.Trigger Method (ITrigger, IElement[])

IObjectStateMachine.Trigger Method (ITrigger, IElement[])
IObjectStateMachine Interface Eco.ObjectRepresentation Namespace See Also
Collapse All

Executes the trigger on the object instance’s state machine identified by an Eco.UmlRt.ITrigger.

C#
IElement Trigger(
    ITrigger trigger,
    IElement[] parameters
);
Parameters
Parameters | Description
trigger | The trigger to execute.
parameters | An array of ECO elements to use as parameters for the trigger method.
Remarks

The types of the parameters must match the method declaration exactly, it is not possible to send an integer value if the formal parameter is a float.

See Also
IObjectStateMachine Interface
Eco.ObjectRepresentation Namespace


IObjectStateMachine.Trigger Method (ITrigger, object[])

IObjectStateMachine.Trigger Method (ITrigger, object[])
IObjectStateMachine Interface Eco.ObjectRepresentation Namespace See Also
Collapse All

Executes the trigger on the object instance’s state machine identified by an Eco.UmlRt.ITrigger.

C#
object Trigger(
    ITrigger trigger,
    object[] parameters
);
Parameters
Parameters | Description
trigger | The trigger to execute.
parameters | An array of .NET objects to use as parameters for the trigger method.
Returns

Returns the value of the effect of the transition

Remarks

The types of the parameters must match the method declaration exactly, it is not possible to send an integer value if the formal parameter is a float.

See Also
IObjectStateMachine Interface
Eco.ObjectRepresentation Namespace


IObjectStateMachine.Trigger Method (string, IElement[])

IObjectStateMachine.Trigger Method (string, IElement[])
IObjectStateMachine Interface Eco.ObjectRepresentation Namespace See Also
Collapse All

Executes the trigger on the object instance’s state machine identified by its modeled method name.

C#
IElement Trigger(
    string triggerName,
    IElement[] parameters
);
Parameters
Parameters | Description
triggerName | The name of the trigger to execute.
parameters | An array of ECO elements to use as parameters for the trigger method.
Remarks

The types of the parameters must match the method declaration exactly, it is not possible to send an integer value if the formal parameter is a float.

See Also
IObjectStateMachine Interface
Eco.ObjectRepresentation Namespace


IObjectStateMachine.Trigger Method (string, object[])

IObjectStateMachine.Trigger Method (string, object[])
IObjectStateMachine Interface Eco.ObjectRepresentation Namespace See Also
Collapse All

Executes the trigger on the object instance’s state machine identified by its modeled method name.

C#
object Trigger(
    string triggerName,
    object[] parameters
);
Parameters
Parameters | Description
triggerName | The name of the trigger to execute.
parameters | An array of .NET objects to use as parameters for the trigger method.
Remarks

The types of the parameters must match the method declaration exactly, it is not possible to send an integer value if the formal parameter is a float.

See Also
IObjectStateMachine Interface
Eco.ObjectRepresentation Namespace


IObjectStateMachine Properties

IObjectStateMachine Properties
Public Properties
Collapse All

The properties of the IObjectStateMachine class are listed here.

Public Properties
Name | Description
Owner | The IObjectInstance the state machine belongs to.
StateMachine | Holds information about the state machine as modeled during design time.


IObjectStateMachine.Owner Property

IObjectStateMachine.Owner Property
IObjectStateMachine Interface Eco.ObjectRepresentation Namespace See Also
Collapse All

The IObjectInstance the state machine belongs to.

C#
IObjectInstance Owner;
See Also
IObjectStateMachine Interface
Eco.ObjectRepresentation Namespace


IObjectStateMachine.StateMachine Property

IObjectStateMachine.StateMachine Property
IObjectStateMachine Interface Eco.ObjectRepresentation Namespace See Also
Collapse All

Holds information about the state machine as modeled during design time.

C#
IStateMachine StateMachine;
See Also
IObjectStateMachine Interface
Eco.ObjectRepresentation Namespace


IPrimitive Interface

IPrimitive Interface
Inheritance Hierarchy See Also
Collapse All

Implemented by Eco.ObjectRepresentation.IProperty instances that hold simple .NET values such as integer, string, and boolean.

C#
public interface IPrimitive : IElement;
Inheritance Hierarchy
Eco.ObjectRepresentation.IElementProvider
    Eco.ObjectRepresentation.IElement
        Eco.ObjectRepresentation.IPrimitive
File

ObjectRepresentation.cs

See Also
Inheritance Hierarchy


IPrimitive Properties

IPrimitive Properties
Public Properties
Collapse All

The properties of the IPrimitive class are listed here.

Public Properties
Name | Description
UmlDataType | Holds a reference to the data type of the property.


IPrimitive.UmlDataType Property

IPrimitive.UmlDataType Property
IPrimitive Interface Eco.ObjectRepresentation Namespace See Also
Collapse All

Holds a reference to the data type of the property.

C#
IDataType UmlDataType;
See Also
IPrimitive Interface
Eco.ObjectRepresentation Namespace


IProperty Interface

IProperty Interface
Inheritance Hierarchy Related Topics See Also
Collapse All

Provides access to the runtime value of a member of a modeled UML class.

C#
public interface IProperty : IElement;
Remarks

This interface provides read/write access to each of the member values of the business class. This includes primitive types such as integer and string, and also single / multi-role associations to other business classes.

In addition to runtime value access this interface also provides access to modeled information, and as an IElement descendant the ability to subscribe to changes.

Related Topics

Eco.ObjectRepresentation.IElement

Inheritance Hierarchy
Eco.ObjectRepresentation.IElementProvider
    Eco.ObjectRepresentation.IElement
        Eco.ObjectRepresentation.IProperty
File

ObjectRepresentation.cs

See Also
Inheritance Hierarchy
Related Topics


IProperty Properties

IProperty Properties
Public Properties
Collapse All

The properties of the IProperty class are listed here.

Public Properties
Name | Description
Owner | Indicates the owner of this IProperty. This is typically an Eco.ObjectRepresentation.IObject but may also be a non domain object such as a collection of parameter values when an ECO method is executed.
StructuralFeature | Provides access to meta-information about the property that was provided at design time, such as the property type, tagged values, etc.


IProperty.Owner Property

IProperty.Owner Property
IProperty Interface Eco.ObjectRepresentation Namespace See Also
Collapse All

Indicates the owner of this IProperty. This is typically an Eco.ObjectRepresentation.IObject but may also be a non domain object such as a collection of parameter values when an ECO method is executed.

C#
IFeatured Owner;
See Also
IProperty Interface
Eco.ObjectRepresentation Namespace


IProperty.StructuralFeature Property

IProperty.StructuralFeature Property
IProperty Interface Eco.ObjectRepresentation Namespace See Also
Collapse All

Provides access to meta-information about the property that was provided at design time, such as the property type, tagged values, etc.

C#
IStructuralFeature StructuralFeature;
See Also
IProperty Interface
Eco.ObjectRepresentation Namespace


IPropertyCollection Interface

IPropertyCollection Interface
Inheritance Hierarchy Related Topics See Also
Collapse All

Holds a collection of Eco.ObjectRepresentation.IProperty.

C#
public interface IPropertyCollection;
Remarks

A collection of properties is created for each in-memory instance of a modeled UML class. Each IProperty contains the appropriate value for each of the instance’s properties. Eco.ObjectRepresentation.IFeatured

Related Topics

Eco.ObjectRepresentation.IProperty

Inheritance Hierarchy
Eco.ObjectRepresentation.IPropertyCollection
File

ObjectRepresentation.cs

See Also
Inheritance Hierarchy
Related Topics


IPropertyCollection Methods

IPropertyCollection Methods
Public Methods
Collapse All

The methods of the IPropertyCollection class are listed here.

Public Methods
Name | Description
GetByLoopbackIndex | Gets a property by its LoopbackIndex.
SubscribeToPropertyChanged | Registers a subcriber to be notified when any property value changes.
this | This is the overview for the this indexer overload.


IPropertyCollection.GetByLoopbackIndex Method

IPropertyCollection.GetByLoopbackIndex Method
IPropertyCollection Interface Eco.ObjectRepresentation Namespace Example See Also
Collapse All

Gets a property by its LoopbackIndex.

C#
IProperty GetByLoopbackIndex(
    int loopbackIndex
);
Parameters
Parameters | Description
loopbackIndex | The loopback index of the IProperty to return.
Remarks

This method provides a safer way of accessing a specific property within the collection. If the name of the property were to be used to retrieve it from the collection there is a possibility that this would fail if the name of the modeled UML attribute (modeled property) were to change. This change would not be discovered until runtime. Whereas using the LoopbackIndex allows the developer to retrieve a specific property by using a constant that is automatically generated by the ECO code generator. Changing the name of the UML attribute during design time will also rename this constant, resulting in a compilation error if all relevant source code is not also updated to reflect the change in the model.

This collection may additionally contain non-modeled properties; for example, when an association is modeled to another class via an association class two properties will be added, the one that was modeled and one that provides access to the association class. Therefore the LoopbackIndex (or modeled index) is not necessarily the same as the property’s actual index within the collection.

Example
Copy Code
       public class Person: object, ILoopBack
{
    public struct Eco_LoopbackIndices
    {
        public const int Eco_FirstMember = 0;
        public const int Eco_MemberCount = (Eco_FirstMember + 2);
        public const int FirstName_MemberIndex = Eco_FirstMember + 0;
        public const int LastName_MemberIndex = Eco_FirstMember + 1;
    }
    ...
}
...
lastNameProperty = myPerson.AsIObject().Properties.GetByLoopbackIndex(Person.Eco_LoopbackIndices.LastName_MemberIndex);
Copy Code
       type
    Person = class(System.Object, ILoopBack)
    public
        type
            Eco_LoopbackIndices = class
            public
                const Eco_FirstMember = 0;
                const Eco_MemberCount = (Eco_FirstMember + 2);
                const FirstName = Eco_FirstMember;
                const LastName = Eco_FirstMember + 1;
            end;
    ...
    end;

    LastNameProperty := MyPerson.AsIObject.Properties.GetByLoopbackIndex(Person.Eco_LoopbackIndices.LastName);
See Also
IPropertyCollection Interface
Eco.ObjectRepresentation Namespace
Example


IPropertyCollection.SubscribeToPropertyChanged Method

IPropertyCollection.SubscribeToPropertyChanged Method
IPropertyCollection Interface Eco.ObjectRepresentation Namespace See Also
Collapse All

Registers a subcriber to be notified when any property value changes.

C#
void SubscribeToPropertyChanged(
    ISubscriber subscriber
);
Parameters
Parameters | Description
subscriber | The subscriber to notify.
See Also
IPropertyCollection Interface
Eco.ObjectRepresentation Namespace


this Indexer

this Indexer

This is the overview for the this indexer overload.

Overload List
Name | Description
IPropertyCollection.this (int) | Gets a property by its index within the collection.
IPropertyCollection.this (string) | Given the modeled name of the feature this method will return the IProperty that represents the value of that modeled feature.
IPropertyCollection.this (UmlRt.IStructuralFeature) | Given an Eco.UmlRt.IStructuralFeature this method will return the IProperty that represents the value of that modeled feature.


IPropertyCollection.this Indexer (UmlRt.IStructuralFeature)

IPropertyCollection.this Indexer (UmlRt.IStructuralFeature)
IPropertyCollection Interface Eco.ObjectRepresentation Namespace See Also
Collapse All

Given an Eco.UmlRt.IStructuralFeature this method will return the IProperty that represents the value of that modeled feature.

C#
IProperty this[
    UmlRt.IStructuralFeature feature
];
Parameters
Parameters | Description
feature | The structural feature to return an IProperty for.
See Also
IPropertyCollection Interface
Eco.ObjectRepresentation Namespace


IPropertyCollection.this Indexer (int)

IPropertyCollection.this Indexer (int)
IPropertyCollection Interface Eco.ObjectRepresentation Namespace Related Topics See Also
Collapse All

Gets a property by its index within the collection.

C#
IProperty this[
    int index
];
Parameters
Parameters | Description
index | The index of the property to retrieve.
Remarks

Retrieving an IProperty by its index within the collection is useful when you intend to loop through each of the properties in turn.

Related Topics

Count

See Also
IPropertyCollection Interface
Eco.ObjectRepresentation Namespace
Related Topics


IPropertyCollection.this Indexer (string)

IPropertyCollection.this Indexer (string)
IPropertyCollection Interface Eco.ObjectRepresentation Namespace See Also
Collapse All

Given the modeled name of the feature this method will return the IProperty that represents the value of that modeled feature.

C#
IProperty this[
    string name
];
Parameters
Parameters | Description
name | The name of the structural feature to return an IProperty for.
See Also
IPropertyCollection Interface
Eco.ObjectRepresentation Namespace


IPropertyCollection Properties

IPropertyCollection Properties
Public Properties
Collapse All

The properties of the IPropertyCollection class are listed here.

Public Properties
Name | Description
Count | Returns the total number of properties in the collection.


IPropertyCollection.Count Property

IPropertyCollection.Count Property
IPropertyCollection Interface Eco.ObjectRepresentation Namespace See Also
Collapse All

Returns the total number of properties in the collection.

C#
int Count;
See Also
IPropertyCollection Interface
Eco.ObjectRepresentation Namespace


IQualifiedAccess Interface

IQualifiedAccess Interface
Inheritance Hierarchy See Also
Collapse All
C#
public interface IQualifiedAccess;
Remarks

This is class Eco.ObjectRepresentation.IQualifiedAccess.

Inheritance Hierarchy
Eco.ObjectRepresentation.IQualifiedAccess
File

ObjectRepresentation.cs

See Also
Inheritance Hierarchy


IQualifiedAccess Methods

IQualifiedAccess Methods
Public Methods
Collapse All

The methods of the IQualifiedAccess class are listed here.

Public Methods
Name | Description
GetByQualifierAndSubscribe | This is GetByQualifierAndSubscribe, a member of class IQualifiedAccess.


IQualifiedAccess.GetByQualifierAndSubscribe Method

IQualifiedAccess.GetByQualifierAndSubscribe Method
IQualifiedAccess Interface Eco.ObjectRepresentation Namespace See Also
Collapse All
C#
IObjectInstance GetByQualifierAndSubscribe(
    IElement[] Qualifiers,
    SubscriberPair Subscribers
);
Remarks

This is GetByQualifierAndSubscribe, a member of class IQualifiedAccess.

See Also
IQualifiedAccess Interface
Eco.ObjectRepresentation Namespace


ISubscribableElementProvider Interface

ISubscribableElementProvider Interface
Inheritance Hierarchy See Also
Collapse All

Identifies the implementor as a class being able to provide an Eco.ObjectRepresentation.IElement and also providing the additional ability to notify subscribers (observers) whenever the element changes.

C#
public interface ISubscribableElementProvider : IElementProvider;
Inheritance Hierarchy
Eco.ObjectRepresentation.IElementProvider
    Eco.ObjectRepresentation.ISubscribableElementProvider
File

ObjectRepresentation.cs

See Also
Inheritance Hierarchy


ISubscribableElementProvider Methods

ISubscribableElementProvider Methods
Public Methods
Collapse All

The methods of the ISubscribableElementProvider class are listed here.

Public Methods
Name | Description
SubscribeToElement | Registers a subscriber to be notified when the element changes.


ISubscribableElementProvider.SubscribeToElement Method

ISubscribableElementProvider.SubscribeToElement Method
ISubscribableElementProvider Interface Eco.ObjectRepresentation Namespace See Also
Collapse All

Registers a subscriber to be notified when the element changes.

C#
void SubscribeToElement(
    ISubscriber subscriber
);
Parameters
Parameters | Description
subscriber | The subscriber to be notified.
See Also
ISubscribableElementProvider Interface
Eco.ObjectRepresentation Namespace


ITuple Interface

ITuple Interface
Inheritance Hierarchy See Also
Collapse All
C#
public interface ITuple : IFeatured;
Remarks

This is class Eco.ObjectRepresentation.ITuple.

Inheritance Hierarchy
Eco.ObjectRepresentation.IElementProvider
    Eco.ObjectRepresentation.IElement
        Eco.ObjectRepresentation.IFeatured
            Eco.ObjectRepresentation.ITuple
File

ObjectRepresentation.cs

See Also
Inheritance Hierarchy


ITuple Properties

ITuple Properties
Public Properties
Collapse All

The properties of the ITuple class are listed here.

Public Properties
Name | Description
UmlTupleType | This is UmlTupleType, a member of class ITuple.


ITuple.UmlTupleType Property

ITuple.UmlTupleType Property
ITuple Interface Eco.ObjectRepresentation Namespace See Also
Collapse All
C#
ITupleType UmlTupleType;
Remarks

This is UmlTupleType, a member of class ITuple.

See Also
ITuple Interface
Eco.ObjectRepresentation Namespace


IVariable Interface

IVariable Interface
Inheritance Hierarchy See Also
Collapse All

Used to define variables for use in OCL evaluation etc.

C#
public interface IVariable : IElement;
Remarks

An IVariable may be added to an Eco.ObjectRepresentation.IExternalVariableList or an Eco.ObjectRepresentation.IModifiableVariableList. To create a new variable use the Eco.Services.IVariableFactoryService. These variable collections are used when evaluating OCL expressions such as the following

Copy Code
Person.allInstances->select(age < v_AgeEntered)

. The naming convention of variables is entirely up to the developer, in this example a "v_" was used to ensure the name does not clash with a modeled element.

Inheritance Hierarchy
Eco.ObjectRepresentation.IElementProvider
    Eco.ObjectRepresentation.IElement
        Eco.ObjectRepresentation.IVariable
File

ObjectRepresentation.cs

See Also
Inheritance Hierarchy


IVariable Properties

IVariable Properties
Public Properties
Collapse All

The properties of the IVariable class are listed here.

Public Properties
Name | Description
StaticUmlType | Identifies the base UML type of the variable. Setting the value of the variable via Eco.ObjectRepresentation.IElement.AsObject will first ensure that the value is compatible with this "static" type. For example, a static type of "LivingOrganism" would allow any instance of Animal, Person, etc, but would not permit an Integer to be assigned. A Decimal would permit an Integer value to be assigned whereas an Integer would not permit a string value.


IVariable.StaticUmlType Property

IVariable.StaticUmlType Property
IVariable Interface Eco.ObjectRepresentation Namespace See Also
Collapse All

Identifies the base UML type of the variable. Setting the value of the variable via Eco.ObjectRepresentation.IElement.AsObject will first ensure that the value is compatible with this "static" type. For example, a static type of "LivingOrganism" would allow any instance of Animal, Person, etc, but would not permit an Integer to be assigned. A Decimal would permit an Integer value to be assigned whereas an Integer would not permit a string value.

C#
IClassifier StaticUmlType;
See Also
IVariable Interface
Eco.ObjectRepresentation Namespace


Eco.ObjectRepresentation.ContentType Enumeration

Eco.ObjectRepresentation.ContentType Enumeration
Related Topics See Also
Collapse All

Indentifies the type of an element.

C#
public enum ContentType {
  Primitive,
  Collection,
  Tuple,
  Object,
  ObjectList
}
Members
Members | Description
Primitive | The element is a primitive .NET value type such as int, string, etc.
Collection | The element is a collection of elements.
Tuple | Not implemented - reserved for future use.
Object | The element is an instance of a modeled UML class.
ObjectList | The element is a collection of instances of a modeled UML class.
Related Topics

Eco.ObjectRepresentation.IElement.ContentType

File

ObjectRepresentation.cs

See Also
Related Topics


Eco.ObjectRepresentation.StateFilter Enumeration

Eco.ObjectRepresentation.StateFilter Enumeration
Related Topics See Also
Collapse All

Identifies the type of a state within an ECO state machine.

C#
public enum StateFilter {
  Simple = 1,
  SingleComposite = 2,
  Orthogonal = 4,
  Recursive = 8,
  AllTopLevel = Simple|SingleComposite|Orthogonal,
  All = Simple|SingleComposite|Orthogonal|Recursive
}
Related Topics

Eco.ObjectRepresentation.IObjectStateMachine.GetStates(StateFilter)

File

ObjectRepresentation.cs

See Also
Related Topics


Eco.Ocl.ParserCore Namespace

Eco.Ocl.ParserCore Namespace
Classes Enumerations
Collapse All

This is namespace Eco.Ocl.ParserCore.

Classes
Name | Description
BoldOclLexClass | This is class Eco.Ocl.ParserCore.BoldOclLexClass.
BoldOclLexTable | This is class Eco.Ocl.ParserCore.BoldOclLexTable.
BoldOclYaccClass | This is class Eco.Ocl.ParserCore.BoldOclYaccClass.
BoldOclYaccTable | This is class Eco.Ocl.ParserCore.BoldOclYaccTable.
InvalidOclException | This is class Eco.Ocl.ParserCore.InvalidOclException.
InvalidOclSyntaxException | This is class Eco.Ocl.ParserCore.InvalidOclSyntaxException.
OclStackElement | This is class Eco.Ocl.ParserCore.OclStackElement.
SSLex | This is class Eco.Ocl.ParserCore.SSLex.
SSLexCharacterClass | This is class Eco.Ocl.ParserCore.SSLexCharacterClass.
SSLexConsumer | This is class Eco.Ocl.ParserCore.SSLexConsumer.
SSLexFinalState | This is class Eco.Ocl.ParserCore.SSLexFinalState.
SSLexKeyTable | This is class Eco.Ocl.ParserCore.SSLexKeyTable.
SSLexLexeme | This is class Eco.Ocl.ParserCore.SSLexLexeme.
SSLexMark | This is class Eco.Ocl.ParserCore.SSLexMark.
SSLexStringConsumer | This is class Eco.Ocl.ParserCore.SSLexStringConsumer.
SSLexTable | This is class Eco.Ocl.ParserCore.SSLexTable.
SSLexTableHeader | This is class Eco.Ocl.ParserCore.SSLexTableHeader.
SSLexTableRow | This is class Eco.Ocl.ParserCore.SSLexTableRow.
SSYacc | This is class Eco.Ocl.ParserCore.SSYacc.
SSYaccCache | This is class Eco.Ocl.ParserCore.SSYaccCache.
SSYaccStackElement | This is class Eco.Ocl.ParserCore.SSYaccStackElement.
SSYaccTable | This is class Eco.Ocl.ParserCore.SSYaccTable.
SSYaccTableHeader | This is class Eco.Ocl.ParserCore.SSYaccTableHeader.
SSYaccTableProd | This is class Eco.Ocl.ParserCore.SSYaccTableProd.
SSYaccTableRow | This is class Eco.Ocl.ParserCore.SSYaccTableRow.
Top
Enumerations
Name | Description
CollectionKind | This is record Eco.Ocl.ParserCore.CollectionKind.


BoldOclLexClass Class

BoldOclLexClass Class
Inheritance Hierarchy See Also
Collapse All
C#
public sealed class BoldOclLexClass : SSLex;
Remarks

This is class Eco.Ocl.ParserCore.BoldOclLexClass.

Inheritance Hierarchy
Eco.Ocl.ParserCore.SSLex
    Eco.Ocl.ParserCore.BoldOclLexClass
File

OclLexClass.cs

See Also
Inheritance Hierarchy


BoldOclLexClass.BoldOclLexClass Constructor

BoldOclLexClass.BoldOclLexClass Constructor
BoldOclLexClass Class Eco.Ocl.ParserCore Namespace See Also
Collapse All
C#
public BoldOclLexClass(
    SSLexTable q_table,
    SSLexConsumer q_consumer
);
Remarks

!!LEXCON Do not edit, move, or duplicate, this marks the constants

See Also
BoldOclLexClass Class
Eco.Ocl.ParserCore Namespace


BoldOclLexClass Fields

BoldOclLexClass Fields
Public Fields
Collapse All

The fields of the BoldOclLexClass class are listed here.

Public Fields
Name | Description
BoldOclLexExprMain | ??!!LEXCON Do not edit, move, or duplicate, this marks the constants
BoldOclLexExprStringLiteral | This is BoldOclLexExprStringLiteral, a member of class BoldOclLexClass.
BoldOclLexTokenAND | This is BoldOclLexTokenAND, a member of class BoldOclLexClass.
BoldOclLexTokenArrow | This is BoldOclLexTokenArrow, a member of class BoldOclLexClass.
BoldOclLexTokenASSIGN | This is BoldOclLexTokenASSIGN, a member of class BoldOclLexClass.
BoldOclLexTokenBAG | This is BoldOclLexTokenBAG, a member of class BoldOclLexClass.
BoldOclLexTokenBAR | This is BoldOclLexTokenBAR, a member of class BoldOclLexClass.
BoldOclLexTokenCOLLECTION | This is BoldOclLexTokenCOLLECTION, a member of class BoldOclLexClass.
BoldOclLexTokenCOLON | This is BoldOclLexTokenCOLON, a member of class BoldOclLexClass.
BoldOclLexTokenComma | This is BoldOclLexTokenComma, a member of class BoldOclLexClass.
BoldOclLexTokenCommercialAt | This is BoldOclLexTokenCommercialAt, a member of class BoldOclLexClass.
BoldOclLexTokenDATE | This is BoldOclLexTokenDATE, a member of class BoldOclLexClass.
BoldOclLexTokenDATETIME | This is BoldOclLexTokenDATETIME, a member of class BoldOclLexClass.
BoldOclLexTokenDiv | This is BoldOclLexTokenDiv, a member of class BoldOclLexClass.
BoldOclLexTokenDot | This is BoldOclLexTokenDot, a member of class BoldOclLexClass.
BoldOclLexTokenDOUBLECOLON | This is BoldOclLexTokenDOUBLECOLON, a member of class BoldOclLexClass.
BoldOclLexTokenDOUBLEDOT | This is BoldOclLexTokenDOUBLEDOT, a member of class BoldOclLexClass.
BoldOclLexTokenELSE | This is BoldOclLexTokenELSE, a member of class BoldOclLexClass.
BoldOclLexTokenENDIF | This is BoldOclLexTokenENDIF, a member of class BoldOclLexClass.
BoldOclLexTokenENUM | This is BoldOclLexTokenENUM, a member of class BoldOclLexClass.
BoldOclLexTokenENUMLITERAL | This is BoldOclLexTokenENUMLITERAL, a member of class BoldOclLexClass.
BoldOclLexTokenEqual | This is BoldOclLexTokenEqual, a member of class BoldOclLexClass.
BoldOclLexTokenFLOAT | This is BoldOclLexTokenFLOAT, a member of class BoldOclLexClass.
BoldOclLexTokenGreater | This is BoldOclLexTokenGreater, a member of class BoldOclLexClass.
BoldOclLexTokenGTEqual | This is BoldOclLexTokenGTEqual, a member of class BoldOclLexClass.
BoldOclLexTokenIF | This is BoldOclLexTokenIF, a member of class BoldOclLexClass.
BoldOclLexTokenIMPLIES | This is BoldOclLexTokenIMPLIES, a member of class BoldOclLexClass.
BoldOclLexTokenIN | This is BoldOclLexTokenIN, a member of class BoldOclLexClass.
BoldOclLexTokenIntDIV | This is BoldOclLexTokenIntDIV, a member of class BoldOclLexClass.
BoldOclLexTokenINTEGER | This is BoldOclLexTokenINTEGER, a member of class BoldOclLexClass.
BoldOclLexTokenLBrace | This is BoldOclLexTokenLBrace, a member of class BoldOclLexClass.
BoldOclLexTokenLBrack | This is BoldOclLexTokenLBrack, a member of class BoldOclLexClass.
BoldOclLexTokenLess | This is BoldOclLexTokenLess, a member of class BoldOclLexClass.
BoldOclLexTokenLET | This is BoldOclLexTokenLET, a member of class BoldOclLexClass.
BoldOclLexTokenLParen | This is BoldOclLexTokenLParen, a member of class BoldOclLexClass.
BoldOclLexTokenLTEqual | This is BoldOclLexTokenLTEqual, a member of class BoldOclLexClass.
BoldOclLexTokenMinus | This is BoldOclLexTokenMinus, a member of class BoldOclLexClass.
BoldOclLexTokenMOD | This is BoldOclLexTokenMOD, a member of class BoldOclLexClass.
BoldOclLexTokenMult | This is BoldOclLexTokenMult, a member of class BoldOclLexClass.
BoldOclLexTokenNAME | This is BoldOclLexTokenNAME, a member of class BoldOclLexClass.
BoldOclLexTokenNEqual | This is BoldOclLexTokenNEqual, a member of class BoldOclLexClass.
BoldOclLexTokenNOT | This is BoldOclLexTokenNOT, a member of class BoldOclLexClass.
BoldOclLexTokenOR | This is BoldOclLexTokenOR, a member of class BoldOclLexClass.
BoldOclLexTokenPlus | This is BoldOclLexTokenPlus, a member of class BoldOclLexClass.
BoldOclLexTokenRBrace | This is BoldOclLexTokenRBrace, a member of class BoldOclLexClass.
BoldOclLexTokenRBrack | This is BoldOclLexTokenRBrack, a member of class BoldOclLexClass.
BoldOclLexTokenRParen | This is BoldOclLexTokenRParen, a member of class BoldOclLexClass.
BoldOclLexTokenSEQUENCE | This is BoldOclLexTokenSEQUENCE, a member of class BoldOclLexClass.
BoldOclLexTokenSET | This is BoldOclLexTokenSET, a member of class BoldOclLexClass.
BoldOclLexTokenSTMTSEPARATOR | This is BoldOclLexTokenSTMTSEPARATOR, a member of class BoldOclLexClass.
BoldOclLexTokenString | This is BoldOclLexTokenString, a member of class BoldOclLexClass.
BoldOclLexTokenStringEnd | This is BoldOclLexTokenStringEnd, a member of class BoldOclLexClass.
BoldOclLexTokenStringSt | This is BoldOclLexTokenStringSt, a member of class BoldOclLexClass.
BoldOclLexTokenTHEN | This is BoldOclLexTokenTHEN, a member of class BoldOclLexClass.
BoldOclLexTokenTIME | This is BoldOclLexTokenTIME, a member of class BoldOclLexClass.
BoldOclLexTokenXOR | This is BoldOclLexTokenXOR, a member of class BoldOclLexClass.


BoldOclLexClass.BoldOclLexExprMain Field

BoldOclLexClass.BoldOclLexExprMain Field
BoldOclLexClass Class Eco.Ocl.ParserCore Namespace See Also
Collapse All
C#
public const int BoldOclLexExprMain = 0;
Remarks

??!!LEXCON Do not edit, move, or duplicate, this marks the constants

See Also
BoldOclLexClass Class
Eco.Ocl.ParserCore Namespace


BoldOclLexClass.BoldOclLexExprStringLiteral Field

BoldOclLexClass.BoldOclLexExprStringLiteral Field
BoldOclLexClass Class Eco.Ocl.ParserCore Namespace See Also
Collapse All
C#
public const int BoldOclLexExprStringLiteral = 1;
Remarks

This is BoldOclLexExprStringLiteral, a member of class BoldOclLexClass.

See Also
BoldOclLexClass Class
Eco.Ocl.ParserCore Namespace


BoldOclLexClass.BoldOclLexTokenAND Field

BoldOclLexClass.BoldOclLexTokenAND Field
BoldOclLexClass Class Eco.Ocl.ParserCore Namespace See Also
Collapse All
C#
public const int BoldOclLexTokenAND = 100;
Remarks

This is BoldOclLexTokenAND, a member of class BoldOclLexClass.

See Also
BoldOclLexClass Class
Eco.Ocl.ParserCore Namespace


BoldOclLexClass.BoldOclLexTokenArrow Field

BoldOclLexClass.BoldOclLexTokenArrow Field
BoldOclLexClass Class Eco.Ocl.ParserCore Namespace See Also
Collapse All
C#
public const int BoldOclLexTokenArrow = 78;
Remarks

This is BoldOclLexTokenArrow, a member of class BoldOclLexClass.

See Also
BoldOclLexClass Class
Eco.Ocl.ParserCore Namespace


BoldOclLexClass.BoldOclLexTokenASSIGN Field

BoldOclLexClass.BoldOclLexTokenASSIGN Field
BoldOclLexClass Class Eco.Ocl.ParserCore Namespace See Also
Collapse All
C#
public const int BoldOclLexTokenASSIGN = 92;
Remarks

This is BoldOclLexTokenASSIGN, a member of class BoldOclLexClass.

See Also
BoldOclLexClass Class
Eco.Ocl.ParserCore Namespace


BoldOclLexClass.BoldOclLexTokenBAG Field

BoldOclLexClass.BoldOclLexTokenBAG Field
BoldOclLexClass Class Eco.Ocl.ParserCore Namespace See Also
Collapse All
C#
public const int BoldOclLexTokenBAG = 94;
Remarks

This is BoldOclLexTokenBAG, a member of class BoldOclLexClass.

See Also
BoldOclLexClass Class
Eco.Ocl.ParserCore Namespace


BoldOclLexClass.BoldOclLexTokenBAR Field

BoldOclLexClass.BoldOclLexTokenBAR Field
BoldOclLexClass Class Eco.Ocl.ParserCore Namespace See Also
Collapse All
C#
public const int BoldOclLexTokenBAR = 88;
Remarks

This is BoldOclLexTokenBAR, a member of class BoldOclLexClass.

See Also
BoldOclLexClass Class
Eco.Ocl.ParserCore Namespace


BoldOclLexClass.BoldOclLexTokenCOLLECTION Field

BoldOclLexClass.BoldOclLexTokenCOLLECTION Field
BoldOclLexClass Class Eco.Ocl.ParserCore Namespace See Also
Collapse All
C#
public const int BoldOclLexTokenCOLLECTION = 97;
Remarks

This is BoldOclLexTokenCOLLECTION, a member of class BoldOclLexClass.

See Also
BoldOclLexClass Class
Eco.Ocl.ParserCore Namespace


BoldOclLexClass.BoldOclLexTokenCOLON Field

BoldOclLexClass.BoldOclLexTokenCOLON Field
BoldOclLexClass Class Eco.Ocl.ParserCore Namespace See Also
Collapse All
C#
public const int BoldOclLexTokenCOLON = 91;
Remarks

This is BoldOclLexTokenCOLON, a member of class BoldOclLexClass.

See Also
BoldOclLexClass Class
Eco.Ocl.ParserCore Namespace


BoldOclLexClass.BoldOclLexTokenComma Field

BoldOclLexClass.BoldOclLexTokenComma Field
BoldOclLexClass Class Eco.Ocl.ParserCore Namespace See Also
Collapse All
C#
public const int BoldOclLexTokenComma = 79;
Remarks

This is BoldOclLexTokenComma, a member of class BoldOclLexClass.

See Also
BoldOclLexClass Class
Eco.Ocl.ParserCore Namespace


BoldOclLexClass.BoldOclLexTokenCommercialAt Field

BoldOclLexClass.BoldOclLexTokenCommercialAt Field
BoldOclLexClass Class Eco.Ocl.ParserCore Namespace See Also
Collapse All
C#
public const int BoldOclLexTokenCommercialAt = 80;
Remarks

This is BoldOclLexTokenCommercialAt, a member of class BoldOclLexClass.

See Also
BoldOclLexClass Class
Eco.Ocl.ParserCore Namespace


BoldOclLexClass.BoldOclLexTokenDATE Field

BoldOclLexClass.BoldOclLexTokenDATE Field
BoldOclLexClass Class Eco.Ocl.ParserCore Namespace See Also
Collapse All
C#
public const int BoldOclLexTokenDATE = 57;
Remarks

This is BoldOclLexTokenDATE, a member of class BoldOclLexClass.

See Also
BoldOclLexClass Class
Eco.Ocl.ParserCore Namespace


BoldOclLexClass.BoldOclLexTokenDATETIME Field

BoldOclLexClass.BoldOclLexTokenDATETIME Field
BoldOclLexClass Class Eco.Ocl.ParserCore Namespace See Also
Collapse All
C#
public const int BoldOclLexTokenDATETIME = 59;
Remarks

This is BoldOclLexTokenDATETIME, a member of class BoldOclLexClass.

See Also
BoldOclLexClass Class
Eco.Ocl.ParserCore Namespace


BoldOclLexClass.BoldOclLexTokenDiv Field

BoldOclLexClass.BoldOclLexTokenDiv Field
BoldOclLexClass Class Eco.Ocl.ParserCore Namespace See Also
Collapse All
C#
public const int BoldOclLexTokenDiv = 76;
Remarks

This is BoldOclLexTokenDiv, a member of class BoldOclLexClass.

See Also
BoldOclLexClass Class
Eco.Ocl.ParserCore Namespace


BoldOclLexClass.BoldOclLexTokenDot Field

BoldOclLexClass.BoldOclLexTokenDot Field
BoldOclLexClass Class Eco.Ocl.ParserCore Namespace See Also
Collapse All
C#
public const int BoldOclLexTokenDot = 77;
Remarks

This is BoldOclLexTokenDot, a member of class BoldOclLexClass.

See Also
BoldOclLexClass Class
Eco.Ocl.ParserCore Namespace


BoldOclLexClass.BoldOclLexTokenDOUBLECOLON Field

BoldOclLexClass.BoldOclLexTokenDOUBLECOLON Field
BoldOclLexClass Class Eco.Ocl.ParserCore Namespace See Also
Collapse All
C#
public const int BoldOclLexTokenDOUBLECOLON = 89;
Remarks

This is BoldOclLexTokenDOUBLECOLON, a member of class BoldOclLexClass.

See Also
BoldOclLexClass Class
Eco.Ocl.ParserCore Namespace


BoldOclLexClass.BoldOclLexTokenDOUBLEDOT Field

BoldOclLexClass.BoldOclLexTokenDOUBLEDOT Field
BoldOclLexClass Class Eco.Ocl.ParserCore Namespace See Also
Collapse All
C#
public const int BoldOclLexTokenDOUBLEDOT = 90;
Remarks

This is BoldOclLexTokenDOUBLEDOT, a member of class BoldOclLexClass.

See Also
BoldOclLexClass Class
Eco.Ocl.ParserCore Namespace


BoldOclLexClass.BoldOclLexTokenELSE Field

BoldOclLexClass.BoldOclLexTokenELSE Field
BoldOclLexClass Class Eco.Ocl.ParserCore Namespace See Also
Collapse All
C#
public const int BoldOclLexTokenELSE = 85;
Remarks

This is BoldOclLexTokenELSE, a member of class BoldOclLexClass.

See Also
BoldOclLexClass Class
Eco.Ocl.ParserCore Namespace


BoldOclLexClass.BoldOclLexTokenENDIF Field

BoldOclLexClass.BoldOclLexTokenENDIF Field
BoldOclLexClass Class Eco.Ocl.ParserCore Namespace See Also
Collapse All
C#
public const int BoldOclLexTokenENDIF = 86;
Remarks

This is BoldOclLexTokenENDIF, a member of class BoldOclLexClass.

See Also
BoldOclLexClass Class
Eco.Ocl.ParserCore Namespace


BoldOclLexClass.BoldOclLexTokenENUM Field

BoldOclLexClass.BoldOclLexTokenENUM Field
BoldOclLexClass Class Eco.Ocl.ParserCore Namespace See Also
Collapse All
C#
public const int BoldOclLexTokenENUM = 87;
Remarks

This is BoldOclLexTokenENUM, a member of class BoldOclLexClass.

See Also
BoldOclLexClass Class
Eco.Ocl.ParserCore Namespace


BoldOclLexClass.BoldOclLexTokenENUMLITERAL Field

BoldOclLexClass.BoldOclLexTokenENUMLITERAL Field
BoldOclLexClass Class Eco.Ocl.ParserCore Namespace See Also
Collapse All
C#
public const int BoldOclLexTokenENUMLITERAL = 56;
Remarks

This is BoldOclLexTokenENUMLITERAL, a member of class BoldOclLexClass.

See Also
BoldOclLexClass Class
Eco.Ocl.ParserCore Namespace


BoldOclLexClass.BoldOclLexTokenEqual Field

BoldOclLexClass.BoldOclLexTokenEqual Field
BoldOclLexClass Class Eco.Ocl.ParserCore Namespace See Also
Collapse All
C#
public const int BoldOclLexTokenEqual = 69;
Remarks

This is BoldOclLexTokenEqual, a member of class BoldOclLexClass.

See Also
BoldOclLexClass Class
Eco.Ocl.ParserCore Namespace


BoldOclLexClass.BoldOclLexTokenFLOAT Field

BoldOclLexClass.BoldOclLexTokenFLOAT Field
BoldOclLexClass Class Eco.Ocl.ParserCore Namespace See Also
Collapse All
C#
public const int BoldOclLexTokenFLOAT = 54;
Remarks

This is BoldOclLexTokenFLOAT, a member of class BoldOclLexClass.

See Also
BoldOclLexClass Class
Eco.Ocl.ParserCore Namespace


BoldOclLexClass.BoldOclLexTokenGreater Field

BoldOclLexClass.BoldOclLexTokenGreater Field
BoldOclLexClass Class Eco.Ocl.ParserCore Namespace See Also
Collapse All
C#
public const int BoldOclLexTokenGreater = 67;
Remarks

This is BoldOclLexTokenGreater, a member of class BoldOclLexClass.

See Also
BoldOclLexClass Class
Eco.Ocl.ParserCore Namespace


BoldOclLexClass.BoldOclLexTokenGTEqual Field

BoldOclLexClass.BoldOclLexTokenGTEqual Field
BoldOclLexClass Class Eco.Ocl.ParserCore Namespace See Also
Collapse All
C#
public const int BoldOclLexTokenGTEqual = 70;
Remarks

This is BoldOclLexTokenGTEqual, a member of class BoldOclLexClass.

See Also
BoldOclLexClass Class
Eco.Ocl.ParserCore Namespace


BoldOclLexClass.BoldOclLexTokenIF Field

BoldOclLexClass.BoldOclLexTokenIF Field
BoldOclLexClass Class Eco.Ocl.ParserCore Namespace See Also
Collapse All
C#
public const int BoldOclLexTokenIF = 81;
Remarks

This is BoldOclLexTokenIF, a member of class BoldOclLexClass.

See Also
BoldOclLexClass Class
Eco.Ocl.ParserCore Namespace


BoldOclLexClass.BoldOclLexTokenIMPLIES Field

BoldOclLexClass.BoldOclLexTokenIMPLIES Field
BoldOclLexClass Class Eco.Ocl.ParserCore Namespace See Also
Collapse All
C#
public const int BoldOclLexTokenIMPLIES = 104;
Remarks

This is BoldOclLexTokenIMPLIES, a member of class BoldOclLexClass.

See Also
BoldOclLexClass Class
Eco.Ocl.ParserCore Namespace


BoldOclLexClass.BoldOclLexTokenIN Field

BoldOclLexClass.BoldOclLexTokenIN Field
BoldOclLexClass Class Eco.Ocl.ParserCore Namespace See Also
Collapse All
C#
public const int BoldOclLexTokenIN = 83;
Remarks

This is BoldOclLexTokenIN, a member of class BoldOclLexClass.

See Also
BoldOclLexClass Class
Eco.Ocl.ParserCore Namespace


BoldOclLexClass.BoldOclLexTokenIntDIV Field

BoldOclLexClass.BoldOclLexTokenIntDIV Field
BoldOclLexClass Class Eco.Ocl.ParserCore Namespace See Also
Collapse All
C#
public const int BoldOclLexTokenIntDIV = 98;
Remarks

This is BoldOclLexTokenIntDIV, a member of class BoldOclLexClass.

See Also
BoldOclLexClass Class
Eco.Ocl.ParserCore Namespace


BoldOclLexClass.BoldOclLexTokenINTEGER Field

BoldOclLexClass.BoldOclLexTokenINTEGER Field
BoldOclLexClass Class Eco.Ocl.ParserCore Namespace See Also
Collapse All
C#
public const int BoldOclLexTokenINTEGER = 53;
Remarks

This is BoldOclLexTokenINTEGER, a member of class BoldOclLexClass.

See Also
BoldOclLexClass Class
Eco.Ocl.ParserCore Namespace


BoldOclLexClass.BoldOclLexTokenLBrace Field

BoldOclLexClass.BoldOclLexTokenLBrace Field
BoldOclLexClass Class Eco.Ocl.ParserCore Namespace See Also
Collapse All
C#
public const int BoldOclLexTokenLBrace = 65;
Remarks

This is BoldOclLexTokenLBrace, a member of class BoldOclLexClass.

See Also
BoldOclLexClass Class
Eco.Ocl.ParserCore Namespace


BoldOclLexClass.BoldOclLexTokenLBrack Field

BoldOclLexClass.BoldOclLexTokenLBrack Field
BoldOclLexClass Class Eco.Ocl.ParserCore Namespace See Also
Collapse All
C#
public const int BoldOclLexTokenLBrack = 61;
Remarks

This is BoldOclLexTokenLBrack, a member of class BoldOclLexClass.

See Also
BoldOclLexClass Class
Eco.Ocl.ParserCore Namespace


BoldOclLexClass.BoldOclLexTokenLess Field

BoldOclLexClass.BoldOclLexTokenLess Field
BoldOclLexClass Class Eco.Ocl.ParserCore Namespace See Also
Collapse All
C#
public const int BoldOclLexTokenLess = 68;
Remarks

This is BoldOclLexTokenLess, a member of class BoldOclLexClass.

See Also
BoldOclLexClass Class
Eco.Ocl.ParserCore Namespace


BoldOclLexClass.BoldOclLexTokenLET Field

BoldOclLexClass.BoldOclLexTokenLET Field
BoldOclLexClass Class Eco.Ocl.ParserCore Namespace See Also
Collapse All
C#
public const int BoldOclLexTokenLET = 82;
Remarks

This is BoldOclLexTokenLET, a member of class BoldOclLexClass.

See Also
BoldOclLexClass Class
Eco.Ocl.ParserCore Namespace


BoldOclLexClass.BoldOclLexTokenLParen Field

BoldOclLexClass.BoldOclLexTokenLParen Field
BoldOclLexClass Class Eco.Ocl.ParserCore Namespace See Also
Collapse All
C#
public const int BoldOclLexTokenLParen = 63;
Remarks

This is BoldOclLexTokenLParen, a member of class BoldOclLexClass.

See Also
BoldOclLexClass Class
Eco.Ocl.ParserCore Namespace


BoldOclLexClass.BoldOclLexTokenLTEqual Field

BoldOclLexClass.BoldOclLexTokenLTEqual Field
BoldOclLexClass Class Eco.Ocl.ParserCore Namespace See Also
Collapse All
C#
public const int BoldOclLexTokenLTEqual = 71;
Remarks

This is BoldOclLexTokenLTEqual, a member of class BoldOclLexClass.

See Also
BoldOclLexClass Class
Eco.Ocl.ParserCore Namespace


BoldOclLexClass.BoldOclLexTokenMinus Field

BoldOclLexClass.BoldOclLexTokenMinus Field
BoldOclLexClass Class Eco.Ocl.ParserCore Namespace See Also
Collapse All
C#
public const int BoldOclLexTokenMinus = 74;
Remarks

This is BoldOclLexTokenMinus, a member of class BoldOclLexClass.

See Also
BoldOclLexClass Class
Eco.Ocl.ParserCore Namespace


BoldOclLexClass.BoldOclLexTokenMOD Field

BoldOclLexClass.BoldOclLexTokenMOD Field
BoldOclLexClass Class Eco.Ocl.ParserCore Namespace See Also
Collapse All
C#
public const int BoldOclLexTokenMOD = 99;
Remarks

This is BoldOclLexTokenMOD, a member of class BoldOclLexClass.

See Also
BoldOclLexClass Class
Eco.Ocl.ParserCore Namespace


BoldOclLexClass.BoldOclLexTokenMult Field

BoldOclLexClass.BoldOclLexTokenMult Field
BoldOclLexClass Class Eco.Ocl.ParserCore Namespace See Also
Collapse All
C#
public const int BoldOclLexTokenMult = 75;
Remarks

This is BoldOclLexTokenMult, a member of class BoldOclLexClass.

See Also
BoldOclLexClass Class
Eco.Ocl.ParserCore Namespace


BoldOclLexClass.BoldOclLexTokenNAME Field

BoldOclLexClass.BoldOclLexTokenNAME Field
BoldOclLexClass Class Eco.Ocl.ParserCore Namespace See Also
Collapse All
C#
public const int BoldOclLexTokenNAME = 55;
Remarks

This is BoldOclLexTokenNAME, a member of class BoldOclLexClass.

See Also
BoldOclLexClass Class
Eco.Ocl.ParserCore Namespace


BoldOclLexClass.BoldOclLexTokenNEqual Field

BoldOclLexClass.BoldOclLexTokenNEqual Field
BoldOclLexClass Class Eco.Ocl.ParserCore Namespace See Also
Collapse All
C#
public const int BoldOclLexTokenNEqual = 72;
Remarks

This is BoldOclLexTokenNEqual, a member of class BoldOclLexClass.

See Also
BoldOclLexClass Class
Eco.Ocl.ParserCore Namespace


BoldOclLexClass.BoldOclLexTokenNOT Field

BoldOclLexClass.BoldOclLexTokenNOT Field
BoldOclLexClass Class Eco.Ocl.ParserCore Namespace See Also
Collapse All
C#
public const int BoldOclLexTokenNOT = 102;
Remarks

This is BoldOclLexTokenNOT, a member of class BoldOclLexClass.

See Also
BoldOclLexClass Class
Eco.Ocl.ParserCore Namespace


BoldOclLexClass.BoldOclLexTokenOR Field

BoldOclLexClass.BoldOclLexTokenOR Field
BoldOclLexClass Class Eco.Ocl.ParserCore Namespace See Also
Collapse All
C#
public const int BoldOclLexTokenOR = 101;
Remarks

This is BoldOclLexTokenOR, a member of class BoldOclLexClass.

See Also
BoldOclLexClass Class
Eco.Ocl.ParserCore Namespace


BoldOclLexClass.BoldOclLexTokenPlus Field

BoldOclLexClass.BoldOclLexTokenPlus Field
BoldOclLexClass Class Eco.Ocl.ParserCore Namespace See Also
Collapse All
C#
public const int BoldOclLexTokenPlus = 73;
Remarks

This is BoldOclLexTokenPlus, a member of class BoldOclLexClass.

See Also
BoldOclLexClass Class
Eco.Ocl.ParserCore Namespace


BoldOclLexClass.BoldOclLexTokenRBrace Field

BoldOclLexClass.BoldOclLexTokenRBrace Field
BoldOclLexClass Class Eco.Ocl.ParserCore Namespace See Also
Collapse All
C#
public const int BoldOclLexTokenRBrace = 66;
Remarks

This is BoldOclLexTokenRBrace, a member of class BoldOclLexClass.

See Also
BoldOclLexClass Class
Eco.Ocl.ParserCore Namespace


BoldOclLexClass.BoldOclLexTokenRBrack Field

BoldOclLexClass.BoldOclLexTokenRBrack Field
BoldOclLexClass Class Eco.Ocl.ParserCore Namespace See Also
Collapse All
C#
public const int BoldOclLexTokenRBrack = 62;
Remarks

This is BoldOclLexTokenRBrack, a member of class BoldOclLexClass.

See Also
BoldOclLexClass Class
Eco.Ocl.ParserCore Namespace


BoldOclLexClass.BoldOclLexTokenRParen Field

BoldOclLexClass.BoldOclLexTokenRParen Field
BoldOclLexClass Class Eco.Ocl.ParserCore Namespace See Also
Collapse All
C#
public const int BoldOclLexTokenRParen = 64;
Remarks

This is BoldOclLexTokenRParen, a member of class BoldOclLexClass.

See Also
BoldOclLexClass Class
Eco.Ocl.ParserCore Namespace


BoldOclLexClass.BoldOclLexTokenSEQUENCE Field

BoldOclLexClass.BoldOclLexTokenSEQUENCE Field
BoldOclLexClass Class Eco.Ocl.ParserCore Namespace See Also
Collapse All
C#
public const int BoldOclLexTokenSEQUENCE = 96;
Remarks

This is BoldOclLexTokenSEQUENCE, a member of class BoldOclLexClass.

See Also
BoldOclLexClass Class
Eco.Ocl.ParserCore Namespace


BoldOclLexClass.BoldOclLexTokenSET Field

BoldOclLexClass.BoldOclLexTokenSET Field
BoldOclLexClass Class Eco.Ocl.ParserCore Namespace See Also
Collapse All
C#
public const int BoldOclLexTokenSET = 95;
Remarks

This is BoldOclLexTokenSET, a member of class BoldOclLexClass.

See Also
BoldOclLexClass Class
Eco.Ocl.ParserCore Namespace


BoldOclLexClass.BoldOclLexTokenSTMTSEPARATOR Field

BoldOclLexClass.BoldOclLexTokenSTMTSEPARATOR Field
BoldOclLexClass Class Eco.Ocl.ParserCore Namespace See Also
Collapse All
C#
public const int BoldOclLexTokenSTMTSEPARATOR = 93;
Remarks

This is BoldOclLexTokenSTMTSEPARATOR, a member of class BoldOclLexClass.

See Also
BoldOclLexClass Class
Eco.Ocl.ParserCore Namespace


BoldOclLexClass.BoldOclLexTokenString Field

BoldOclLexClass.BoldOclLexTokenString Field
BoldOclLexClass Class Eco.Ocl.ParserCore Namespace See Also
Collapse All
C#
public const int BoldOclLexTokenString = 105;
Remarks

This is BoldOclLexTokenString, a member of class BoldOclLexClass.

See Also
BoldOclLexClass Class
Eco.Ocl.ParserCore Namespace


BoldOclLexClass.BoldOclLexTokenStringEnd Field

BoldOclLexClass.BoldOclLexTokenStringEnd Field
BoldOclLexClass Class Eco.Ocl.ParserCore Namespace See Also
Collapse All
C#
public const int BoldOclLexTokenStringEnd = 106;
Remarks

This is BoldOclLexTokenStringEnd, a member of class BoldOclLexClass.

See Also
BoldOclLexClass Class
Eco.Ocl.ParserCore Namespace


BoldOclLexClass.BoldOclLexTokenStringSt Field

BoldOclLexClass.BoldOclLexTokenStringSt Field
BoldOclLexClass Class Eco.Ocl.ParserCore Namespace See Also
Collapse All
C#
public const int BoldOclLexTokenStringSt = 60;
Remarks

This is BoldOclLexTokenStringSt, a member of class BoldOclLexClass.

See Also
BoldOclLexClass Class
Eco.Ocl.ParserCore Namespace


BoldOclLexClass.BoldOclLexTokenTHEN Field

BoldOclLexClass.BoldOclLexTokenTHEN Field
BoldOclLexClass Class Eco.Ocl.ParserCore Namespace See Also
Collapse All
C#
public const int BoldOclLexTokenTHEN = 84;
Remarks

This is BoldOclLexTokenTHEN, a member of class BoldOclLexClass.

See Also
BoldOclLexClass Class
Eco.Ocl.ParserCore Namespace


BoldOclLexClass.BoldOclLexTokenTIME Field

BoldOclLexClass.BoldOclLexTokenTIME Field
BoldOclLexClass Class Eco.Ocl.ParserCore Namespace See Also
Collapse All
C#
public const int BoldOclLexTokenTIME = 58;
Remarks

This is BoldOclLexTokenTIME, a member of class BoldOclLexClass.

See Also
BoldOclLexClass Class
Eco.Ocl.ParserCore Namespace


BoldOclLexClass.BoldOclLexTokenXOR Field

BoldOclLexClass.BoldOclLexTokenXOR Field
BoldOclLexClass Class Eco.Ocl.ParserCore Namespace See Also
Collapse All
C#
public const int BoldOclLexTokenXOR = 103;
Remarks

This is BoldOclLexTokenXOR, a member of class BoldOclLexClass.

See Also
BoldOclLexClass Class
Eco.Ocl.ParserCore Namespace


BoldOclLexTable Class

BoldOclLexTable Class
Inheritance Hierarchy See Also
Collapse All
C#
public sealed class BoldOclLexTable : SSLexTable;
Remarks

This is class Eco.Ocl.ParserCore.BoldOclLexTable.

Inheritance Hierarchy
Eco.Ocl.ParserCore.SSLexTable
    Eco.Ocl.ParserCore.BoldOclLexTable
File

OclLexTable.cs

See Also
Inheritance Hierarchy


BoldOclLexTable.BoldOclLexTable Constructor

BoldOclLexTable.BoldOclLexTable Constructor
BoldOclLexTable Class Eco.Ocl.ParserCore Namespace See Also
Collapse All
C#
public BoldOclLexTable();
Remarks

This is BoldOclLexTable, a member of class BoldOclLexTable.

See Also
BoldOclLexTable Class
Eco.Ocl.ParserCore Namespace


BoldOclYaccClass Class

BoldOclYaccClass Class
Inheritance Hierarchy See Also
Collapse All
C#
public sealed class BoldOclYaccClass : SSYacc;
Remarks

This is class Eco.Ocl.ParserCore.BoldOclYaccClass.

Inheritance Hierarchy
Eco.Ocl.ParserCore.SSYacc
    Eco.Ocl.ParserCore.BoldOclYaccClass
File

OclYaccClass.cs

See Also
Inheritance Hierarchy


BoldOclYaccClass.BoldOclYaccClass Constructor

BoldOclYaccClass.BoldOclYaccClass Constructor
BoldOclYaccClass Class Eco.Ocl.ParserCore Namespace See Also
Collapse All
C#
public BoldOclYaccClass(
    SSYaccTable q_table,
    SSLex q_lex,
    OclParserCoreBackend initBackend
);
Remarks

This is BoldOclYaccClass, a member of class BoldOclYaccClass.

See Also
BoldOclYaccClass Class
Eco.Ocl.ParserCore Namespace


BoldOclYaccClass Fields

BoldOclYaccClass Fields
Public Fields
Collapse All

The fields of the BoldOclYaccClass class are listed here.

Public Fields
Name | Description
BoldOclYaccProdactualParameterList_ety | This is BoldOclYaccProdactualParameterList_ety, a member of class BoldOclYaccClass.
BoldOclYaccProdActualParameterlist_nonEty | This is BoldOclYaccProdActualParameterlist_nonEty, a member of class BoldOclYaccClass.
BoldOclYaccProdanyName_Name | This is BoldOclYaccProdanyName_Name, a member of class BoldOclYaccClass.
BoldOclYaccProdcollectionKind_Bag | This is BoldOclYaccProdcollectionKind_Bag, a member of class BoldOclYaccClass.
BoldOclYaccProdcollectionKind_Collection | This is BoldOclYaccProdcollectionKind_Collection, a member of class BoldOclYaccClass.
BoldOclYaccProdcollectionKind_Sequence | This is BoldOclYaccProdcollectionKind_Sequence, a member of class BoldOclYaccClass.
BoldOclYaccProdcollectionKind_Set | This is BoldOclYaccProdcollectionKind_Set, a member of class BoldOclYaccClass.
BoldOclYaccProdexpressionAdd | This is BoldOclYaccProdexpressionAdd, a member of class BoldOclYaccClass.
BoldOclYaccProdexpressionAnd | This is BoldOclYaccProdexpressionAnd, a member of class BoldOclYaccClass.
BoldOclYaccProdexpressionASSIGN | This is BoldOclYaccProdexpressionASSIGN, a member of class BoldOclYaccClass.
BoldOclYaccProdexpressionDiv | This is BoldOclYaccProdexpressionDiv, a member of class BoldOclYaccClass.
BoldOclYaccProdexpressionDivI | This is BoldOclYaccProdexpressionDivI, a member of class BoldOclYaccClass.
BoldOclYaccProdexpressionEQ | This is BoldOclYaccProdexpressionEQ, a member of class BoldOclYaccClass.
BoldOclYaccProdexpressionGE | This is BoldOclYaccProdexpressionGE, a member of class BoldOclYaccClass.
BoldOclYaccProdexpressionGT | This is BoldOclYaccProdexpressionGT, a member of class BoldOclYaccClass.
BoldOclYaccProdexpressionImp | This is BoldOclYaccProdexpressionImp, a member of class BoldOclYaccClass.
BoldOclYaccProdexpressionLE | This is BoldOclYaccProdexpressionLE, a member of class BoldOclYaccClass.
BoldOclYaccProdexpressionLET | This is BoldOclYaccProdexpressionLET, a member of class BoldOclYaccClass.
BoldOclYaccProdexpressionList | This is BoldOclYaccProdexpressionList, a member of class BoldOclYaccClass.
BoldOclYaccProdexpressionList_Rec | This is BoldOclYaccProdexpressionList_Rec, a member of class BoldOclYaccClass.
BoldOclYaccProdexpressionListOrRange_List | This is BoldOclYaccProdexpressionListOrRange_List, a member of class BoldOclYaccClass.
BoldOclYaccProdexpressionListOrRange_Range | This is BoldOclYaccProdexpressionListOrRange_Range, a member of class BoldOclYaccClass.
BoldOclYaccProdexpressionLT | This is BoldOclYaccProdexpressionLT, a member of class BoldOclYaccClass.
BoldOclYaccProdexpressionMod | This is BoldOclYaccProdexpressionMod, a member of class BoldOclYaccClass.
BoldOclYaccProdexpressionMul | This is BoldOclYaccProdexpressionMul, a member of class BoldOclYaccClass.
BoldOclYaccProdexpressionNE | This is BoldOclYaccProdexpressionNE, a member of class BoldOclYaccClass.
BoldOclYaccProdexpressionNeg | This is BoldOclYaccProdexpressionNeg, a member of class BoldOclYaccClass.
BoldOclYaccProdexpressionNOT | This is BoldOclYaccProdexpressionNOT, a member of class BoldOclYaccClass.
BoldOclYaccProdexpressionOr | This is BoldOclYaccProdexpressionOr, a member of class BoldOclYaccClass.
BoldOclYaccProdexpressionPost | This is BoldOclYaccProdexpressionPost, a member of class BoldOclYaccClass.
BoldOclYaccProdexpressionSTRMSEQUENCE | This is BoldOclYaccProdexpressionSTRMSEQUENCE, a member of class BoldOclYaccClass.
BoldOclYaccProdexpressionSub | This is BoldOclYaccProdexpressionSub, a member of class BoldOclYaccClass.
BoldOclYaccProdexpressionXor | This is BoldOclYaccProdexpressionXor, a member of class BoldOclYaccClass.
BoldOclYaccProdfeatureCallParameters1 | This is BoldOclYaccProdfeatureCallParameters1, a member of class BoldOclYaccClass.
BoldOclYaccProdfeatureCallParameters2 | This is BoldOclYaccProdfeatureCallParameters2, a member of class BoldOclYaccClass.
BoldOclYaccProdGoal | ??!!YACCCON Do not edit, move, or duplicate, this marks the constants
BoldOclYaccProdifExpression | This is BoldOclYaccProdifExpression, a member of class BoldOclYaccClass.
BoldOclYaccProdliteral_Date | This is BoldOclYaccProdliteral_Date, a member of class BoldOclYaccClass.
BoldOclYaccProdliteral_DateTime | This is BoldOclYaccProdliteral_DateTime, a member of class BoldOclYaccClass.
BoldOclYaccProdliteral_EmptyString | This is BoldOclYaccProdliteral_EmptyString, a member of class BoldOclYaccClass.
BoldOclYaccProdliteral_float | This is BoldOclYaccProdliteral_float, a member of class BoldOclYaccClass.
BoldOclYaccProdliteral_Name | This is BoldOclYaccProdliteral_Name, a member of class BoldOclYaccClass.
BoldOclYaccProdliteral_Number | This is BoldOclYaccProdliteral_Number, a member of class BoldOclYaccClass.
BoldOclYaccProdliteral_String | This is BoldOclYaccProdliteral_String, a member of class BoldOclYaccClass.
BoldOclYaccProdliteral_Time | This is BoldOclYaccProdliteral_Time, a member of class BoldOclYaccClass.
BoldOclYaccProdliteralCollection | This is BoldOclYaccProdliteralCollection, a member of class BoldOclYaccClass.
BoldOclYaccProdNonEmptyactualParameterList | This is BoldOclYaccProdNonEmptyactualParameterList, a member of class BoldOclYaccClass.
BoldOclYaccProdNonEmptyactualParameterList_Rec | This is BoldOclYaccProdNonEmptyactualParameterList_Rec, a member of class BoldOclYaccClass.
BoldOclYaccProdpathName | This is BoldOclYaccProdpathName, a member of class BoldOclYaccClass.
BoldOclYaccProdpathName_Rec | This is BoldOclYaccProdpathName_Rec, a member of class BoldOclYaccClass.
BoldOclYaccProdpostFixFirst | This is BoldOclYaccProdpostFixFirst, a member of class BoldOclYaccClass.
BoldOclYaccProdpostFixMember | This is BoldOclYaccProdpostFixMember, a member of class BoldOclYaccClass.
BoldOclYaccProdpostFixMethod | This is BoldOclYaccProdpostFixMethod, a member of class BoldOclYaccClass.
BoldOclYaccProdpostFixOperation | This is BoldOclYaccProdpostFixOperation, a member of class BoldOclYaccClass.
BoldOclYaccProdpostFixOperationParams | This is BoldOclYaccProdpostFixOperationParams, a member of class BoldOclYaccClass.
BoldOclYaccProdprimaryExpIf | This is BoldOclYaccProdprimaryExpIf, a member of class BoldOclYaccClass.
BoldOclYaccProdprimaryExpLitt | This is BoldOclYaccProdprimaryExpLitt, a member of class BoldOclYaccClass.
BoldOclYaccProdprimaryExpLittCollection | This is BoldOclYaccProdprimaryExpLittCollection, a member of class BoldOclYaccClass.
BoldOclYaccProdprimaryExpParen | This is BoldOclYaccProdprimaryExpParen, a member of class BoldOclYaccClass.
BoldOclYaccProdPrimaryNoParams | This is BoldOclYaccProdPrimaryNoParams, a member of class BoldOclYaccClass.
BoldOclYaccProdPrimaryWithParams | This is BoldOclYaccProdPrimaryWithParams, a member of class BoldOclYaccClass.
BoldOclYaccProdqualifiers | This is BoldOclYaccProdqualifiers, a member of class BoldOclYaccClass.
BoldOclYaccProdqualifiers_Ety | This is BoldOclYaccProdqualifiers_Ety, a member of class BoldOclYaccClass.
BoldOclYaccProdtimeExpression | This is BoldOclYaccProdtimeExpression, a member of class BoldOclYaccClass.
BoldOclYaccProdtimeExpression_Ety | This is BoldOclYaccProdtimeExpression_Ety, a member of class BoldOclYaccClass.
finalValue | This is finalValue, a member of class BoldOclYaccClass.


BoldOclYaccClass.BoldOclYaccProdactualParameterList_ety Field

BoldOclYaccClass.BoldOclYaccProdactualParameterList_ety Field
BoldOclYaccClass Class Eco.Ocl.ParserCore Namespace See Also
Collapse All
C#
public const int BoldOclYaccProdactualParameterList_ety = 58;
Remarks

This is BoldOclYaccProdactualParameterList_ety, a member of class BoldOclYaccClass.

See Also
BoldOclYaccClass Class
Eco.Ocl.ParserCore Namespace


BoldOclYaccClass.BoldOclYaccProdActualParameterlist_nonEty Field

BoldOclYaccClass.BoldOclYaccProdActualParameterlist_nonEty Field
BoldOclYaccClass Class Eco.Ocl.ParserCore Namespace See Also
Collapse All
C#
public const int BoldOclYaccProdActualParameterlist_nonEty = 59;
Remarks

This is BoldOclYaccProdActualParameterlist_nonEty, a member of class BoldOclYaccClass.

See Also
BoldOclYaccClass Class
Eco.Ocl.ParserCore Namespace


BoldOclYaccClass.BoldOclYaccProdanyName_Name Field

BoldOclYaccClass.BoldOclYaccProdanyName_Name Field
BoldOclYaccClass Class Eco.Ocl.ParserCore Namespace See Also
Collapse All
C#
public const int BoldOclYaccProdanyName_Name = 55;
Remarks

This is BoldOclYaccProdanyName_Name, a member of class BoldOclYaccClass.

See Also
BoldOclYaccClass Class
Eco.Ocl.ParserCore Namespace


BoldOclYaccClass.BoldOclYaccProdcollectionKind_Bag Field

BoldOclYaccClass.BoldOclYaccProdcollectionKind_Bag Field
BoldOclYaccClass Class Eco.Ocl.ParserCore Namespace See Also
Collapse All
C#
public const int BoldOclYaccProdcollectionKind_Bag = 63;
Remarks

This is BoldOclYaccProdcollectionKind_Bag, a member of class BoldOclYaccClass.

See Also
BoldOclYaccClass Class
Eco.Ocl.ParserCore Namespace


BoldOclYaccClass.BoldOclYaccProdcollectionKind_Collection Field

BoldOclYaccClass.BoldOclYaccProdcollectionKind_Collection Field
BoldOclYaccClass Class Eco.Ocl.ParserCore Namespace See Also
Collapse All
C#
public const int BoldOclYaccProdcollectionKind_Collection = 65;
Remarks

This is BoldOclYaccProdcollectionKind_Collection, a member of class BoldOclYaccClass.

See Also
BoldOclYaccClass Class
Eco.Ocl.ParserCore Namespace


BoldOclYaccClass.BoldOclYaccProdcollectionKind_Sequence Field

BoldOclYaccClass.BoldOclYaccProdcollectionKind_Sequence Field
BoldOclYaccClass Class Eco.Ocl.ParserCore Namespace See Also
Collapse All
C#
public const int BoldOclYaccProdcollectionKind_Sequence = 64;
Remarks

This is BoldOclYaccProdcollectionKind_Sequence, a member of class BoldOclYaccClass.

See Also
BoldOclYaccClass Class
Eco.Ocl.ParserCore Namespace


BoldOclYaccClass.BoldOclYaccProdcollectionKind_Set Field

BoldOclYaccClass.BoldOclYaccProdcollectionKind_Set Field
BoldOclYaccClass Class Eco.Ocl.ParserCore Namespace See Also
Collapse All
C#
public const int BoldOclYaccProdcollectionKind_Set = 62;
Remarks

This is BoldOclYaccProdcollectionKind_Set, a member of class BoldOclYaccClass.

See Also
BoldOclYaccClass Class
Eco.Ocl.ParserCore Namespace


BoldOclYaccClass.BoldOclYaccProdexpressionAdd Field

BoldOclYaccClass.BoldOclYaccProdexpressionAdd Field
BoldOclYaccClass Class Eco.Ocl.ParserCore Namespace See Also
Collapse All
C#
public const int BoldOclYaccProdexpressionAdd = 13;
Remarks

This is BoldOclYaccProdexpressionAdd, a member of class BoldOclYaccClass.

See Also
BoldOclYaccClass Class
Eco.Ocl.ParserCore Namespace


BoldOclYaccClass.BoldOclYaccProdexpressionAnd Field

BoldOclYaccClass.BoldOclYaccProdexpressionAnd Field
BoldOclYaccClass Class Eco.Ocl.ParserCore Namespace See Also
Collapse All
C#
public const int BoldOclYaccProdexpressionAnd = 3;
Remarks

This is BoldOclYaccProdexpressionAnd, a member of class BoldOclYaccClass.

See Also
BoldOclYaccClass Class
Eco.Ocl.ParserCore Namespace


BoldOclYaccClass.BoldOclYaccProdexpressionASSIGN Field

BoldOclYaccClass.BoldOclYaccProdexpressionASSIGN Field
BoldOclYaccClass Class Eco.Ocl.ParserCore Namespace See Also
Collapse All
C#
public const int BoldOclYaccProdexpressionASSIGN = 19;
Remarks

This is BoldOclYaccProdexpressionASSIGN, a member of class BoldOclYaccClass.

See Also
BoldOclYaccClass Class
Eco.Ocl.ParserCore Namespace


BoldOclYaccClass.BoldOclYaccProdexpressionDiv Field

BoldOclYaccClass.BoldOclYaccProdexpressionDiv Field
BoldOclYaccClass Class Eco.Ocl.ParserCore Namespace See Also
Collapse All
C#
public const int BoldOclYaccProdexpressionDiv = 15;
Remarks

This is BoldOclYaccProdexpressionDiv, a member of class BoldOclYaccClass.

See Also
BoldOclYaccClass Class
Eco.Ocl.ParserCore Namespace


BoldOclYaccClass.BoldOclYaccProdexpressionDivI Field

BoldOclYaccClass.BoldOclYaccProdexpressionDivI Field
BoldOclYaccClass Class Eco.Ocl.ParserCore Namespace See Also
Collapse All
C#
public const int BoldOclYaccProdexpressionDivI = 17;
Remarks

This is BoldOclYaccProdexpressionDivI, a member of class BoldOclYaccClass.

See Also
BoldOclYaccClass Class
Eco.Ocl.ParserCore Namespace


BoldOclYaccClass.BoldOclYaccProdexpressionEQ Field

BoldOclYaccClass.BoldOclYaccProdexpressionEQ Field
BoldOclYaccClass Class Eco.Ocl.ParserCore Namespace See Also
Collapse All
C#
public const int BoldOclYaccProdexpressionEQ = 7;
Remarks

This is BoldOclYaccProdexpressionEQ, a member of class BoldOclYaccClass.

See Also
BoldOclYaccClass Class
Eco.Ocl.ParserCore Namespace


BoldOclYaccClass.BoldOclYaccProdexpressionGE Field

BoldOclYaccClass.BoldOclYaccProdexpressionGE Field
BoldOclYaccClass Class Eco.Ocl.ParserCore Namespace See Also
Collapse All
C#
public const int BoldOclYaccProdexpressionGE = 11;
Remarks

This is BoldOclYaccProdexpressionGE, a member of class BoldOclYaccClass.

See Also
BoldOclYaccClass Class
Eco.Ocl.ParserCore Namespace


BoldOclYaccClass.BoldOclYaccProdexpressionGT Field

BoldOclYaccClass.BoldOclYaccProdexpressionGT Field
BoldOclYaccClass Class Eco.Ocl.ParserCore Namespace See Also
Collapse All
C#
public const int BoldOclYaccProdexpressionGT = 9;
Remarks

This is BoldOclYaccProdexpressionGT, a member of class BoldOclYaccClass.

See Also
BoldOclYaccClass Class
Eco.Ocl.ParserCore Namespace


BoldOclYaccClass.BoldOclYaccProdexpressionImp Field

BoldOclYaccClass.BoldOclYaccProdexpressionImp Field
BoldOclYaccClass Class Eco.Ocl.ParserCore Namespace See Also
Collapse All
C#
public const int BoldOclYaccProdexpressionImp = 6;
Remarks

This is BoldOclYaccProdexpressionImp, a member of class BoldOclYaccClass.

See Also
BoldOclYaccClass Class
Eco.Ocl.ParserCore Namespace


BoldOclYaccClass.BoldOclYaccProdexpressionLE Field

BoldOclYaccClass.BoldOclYaccProdexpressionLE Field
BoldOclYaccClass Class Eco.Ocl.ParserCore Namespace See Also
Collapse All
C#
public const int BoldOclYaccProdexpressionLE = 10;
Remarks

This is BoldOclYaccProdexpressionLE, a member of class BoldOclYaccClass.

See Also
BoldOclYaccClass Class
Eco.Ocl.ParserCore Namespace


BoldOclYaccClass.BoldOclYaccProdexpressionLET Field

BoldOclYaccClass.BoldOclYaccProdexpressionLET Field
BoldOclYaccClass Class Eco.Ocl.ParserCore Namespace See Also
Collapse All
C#
public const int BoldOclYaccProdexpressionLET = 21;
Remarks

This is BoldOclYaccProdexpressionLET, a member of class BoldOclYaccClass.

See Also
BoldOclYaccClass Class
Eco.Ocl.ParserCore Namespace


BoldOclYaccClass.BoldOclYaccProdexpressionList Field

BoldOclYaccClass.BoldOclYaccProdexpressionList Field
BoldOclYaccClass Class Eco.Ocl.ParserCore Namespace See Also
Collapse All
C#
public const int BoldOclYaccProdexpressionList = 48;
Remarks

This is BoldOclYaccProdexpressionList, a member of class BoldOclYaccClass.

See Also
BoldOclYaccClass Class
Eco.Ocl.ParserCore Namespace


BoldOclYaccClass.BoldOclYaccProdexpressionList_Rec Field

BoldOclYaccClass.BoldOclYaccProdexpressionList_Rec Field
BoldOclYaccClass Class Eco.Ocl.ParserCore Namespace See Also
Collapse All
C#
public const int BoldOclYaccProdexpressionList_Rec = 49;
Remarks

This is BoldOclYaccProdexpressionList_Rec, a member of class BoldOclYaccClass.

See Also
BoldOclYaccClass Class
Eco.Ocl.ParserCore Namespace


BoldOclYaccClass.BoldOclYaccProdexpressionListOrRange_List Field

BoldOclYaccClass.BoldOclYaccProdexpressionListOrRange_List Field
BoldOclYaccClass Class Eco.Ocl.ParserCore Namespace See Also
Collapse All
C#
public const int BoldOclYaccProdexpressionListOrRange_List = 47;
Remarks

This is BoldOclYaccProdexpressionListOrRange_List, a member of class BoldOclYaccClass.

See Also
BoldOclYaccClass Class
Eco.Ocl.ParserCore Namespace


BoldOclYaccClass.BoldOclYaccProdexpressionListOrRange_Range Field

BoldOclYaccClass.BoldOclYaccProdexpressionListOrRange_Range Field
BoldOclYaccClass Class Eco.Ocl.ParserCore Namespace See Also
Collapse All
C#
public const int BoldOclYaccProdexpressionListOrRange_Range = 50;
Remarks

This is BoldOclYaccProdexpressionListOrRange_Range, a member of class BoldOclYaccClass.

See Also
BoldOclYaccClass Class
Eco.Ocl.ParserCore Namespace


BoldOclYaccClass.BoldOclYaccProdexpressionLT Field

BoldOclYaccClass.BoldOclYaccProdexpressionLT Field
BoldOclYaccClass Class Eco.Ocl.ParserCore Namespace See Also
Collapse All
C#
public const int BoldOclYaccProdexpressionLT = 8;
Remarks

This is BoldOclYaccProdexpressionLT, a member of class BoldOclYaccClass.

See Also
BoldOclYaccClass Class
Eco.Ocl.ParserCore Namespace


BoldOclYaccClass.BoldOclYaccProdexpressionMod Field

BoldOclYaccClass.BoldOclYaccProdexpressionMod Field
BoldOclYaccClass Class Eco.Ocl.ParserCore Namespace See Also
Collapse All
C#
public const int BoldOclYaccProdexpressionMod = 18;
Remarks

This is BoldOclYaccProdexpressionMod, a member of class BoldOclYaccClass.

See Also
BoldOclYaccClass Class
Eco.Ocl.ParserCore Namespace


BoldOclYaccClass.BoldOclYaccProdexpressionMul Field

BoldOclYaccClass.BoldOclYaccProdexpressionMul Field
BoldOclYaccClass Class Eco.Ocl.ParserCore Namespace See Also
Collapse All
C#
public const int BoldOclYaccProdexpressionMul = 16;
Remarks

This is BoldOclYaccProdexpressionMul, a member of class BoldOclYaccClass.

See Also
BoldOclYaccClass Class
Eco.Ocl.ParserCore Namespace


BoldOclYaccClass.BoldOclYaccProdexpressionNE Field

BoldOclYaccClass.BoldOclYaccProdexpressionNE Field
BoldOclYaccClass Class Eco.Ocl.ParserCore Namespace See Also
Collapse All
C#
public const int BoldOclYaccProdexpressionNE = 12;
Remarks

This is BoldOclYaccProdexpressionNE, a member of class BoldOclYaccClass.

See Also
BoldOclYaccClass Class
Eco.Ocl.ParserCore Namespace


BoldOclYaccClass.BoldOclYaccProdexpressionNeg Field

BoldOclYaccClass.BoldOclYaccProdexpressionNeg Field
BoldOclYaccClass Class Eco.Ocl.ParserCore Namespace See Also
Collapse All
C#
public const int BoldOclYaccProdexpressionNeg = 22;
Remarks

This is BoldOclYaccProdexpressionNeg, a member of class BoldOclYaccClass.

See Also
BoldOclYaccClass Class
Eco.Ocl.ParserCore Namespace


BoldOclYaccClass.BoldOclYaccProdexpressionNOT Field

BoldOclYaccClass.BoldOclYaccProdexpressionNOT Field
BoldOclYaccClass Class Eco.Ocl.ParserCore Namespace See Also
Collapse All
C#
public const int BoldOclYaccProdexpressionNOT = 23;
Remarks

This is BoldOclYaccProdexpressionNOT, a member of class BoldOclYaccClass.

See Also
BoldOclYaccClass Class
Eco.Ocl.ParserCore Namespace


BoldOclYaccClass.BoldOclYaccProdexpressionOr Field

BoldOclYaccClass.BoldOclYaccProdexpressionOr Field
BoldOclYaccClass Class Eco.Ocl.ParserCore Namespace See Also
Collapse All
C#
public const int BoldOclYaccProdexpressionOr = 4;
Remarks

This is BoldOclYaccProdexpressionOr, a member of class BoldOclYaccClass.

See Also
BoldOclYaccClass Class
Eco.Ocl.ParserCore Namespace


BoldOclYaccClass.BoldOclYaccProdexpressionPost Field

BoldOclYaccClass.BoldOclYaccProdexpressionPost Field
BoldOclYaccClass Class Eco.Ocl.ParserCore Namespace See Also
Collapse All
C#
public const int BoldOclYaccProdexpressionPost = 2;
Remarks

This is BoldOclYaccProdexpressionPost, a member of class BoldOclYaccClass.

See Also
BoldOclYaccClass Class
Eco.Ocl.ParserCore Namespace


BoldOclYaccClass.BoldOclYaccProdexpressionSTRMSEQUENCE Field

BoldOclYaccClass.BoldOclYaccProdexpressionSTRMSEQUENCE Field
BoldOclYaccClass Class Eco.Ocl.ParserCore Namespace See Also
Collapse All
C#
public const int BoldOclYaccProdexpressionSTRMSEQUENCE = 20;
Remarks

This is BoldOclYaccProdexpressionSTRMSEQUENCE, a member of class BoldOclYaccClass.

See Also
BoldOclYaccClass Class
Eco.Ocl.ParserCore Namespace


BoldOclYaccClass.BoldOclYaccProdexpressionSub Field

BoldOclYaccClass.BoldOclYaccProdexpressionSub Field
BoldOclYaccClass Class Eco.Ocl.ParserCore Namespace See Also
Collapse All
C#
public const int BoldOclYaccProdexpressionSub = 14;
Remarks

This is BoldOclYaccProdexpressionSub, a member of class BoldOclYaccClass.

See Also
BoldOclYaccClass Class
Eco.Ocl.ParserCore Namespace


BoldOclYaccClass.BoldOclYaccProdexpressionXor Field

BoldOclYaccClass.BoldOclYaccProdexpressionXor Field
BoldOclYaccClass Class Eco.Ocl.ParserCore Namespace See Also
Collapse All
C#
public const int BoldOclYaccProdexpressionXor = 5;
Remarks

This is BoldOclYaccProdexpressionXor, a member of class BoldOclYaccClass.

See Also
BoldOclYaccClass Class
Eco.Ocl.ParserCore Namespace


BoldOclYaccClass.BoldOclYaccProdfeatureCallParameters1 Field

BoldOclYaccClass.BoldOclYaccProdfeatureCallParameters1 Field
BoldOclYaccClass Class Eco.Ocl.ParserCore Namespace See Also
Collapse All
C#
public const int BoldOclYaccProdfeatureCallParameters1 = 36;
Remarks

This is BoldOclYaccProdfeatureCallParameters1, a member of class BoldOclYaccClass.

See Also
BoldOclYaccClass Class
Eco.Ocl.ParserCore Namespace


BoldOclYaccClass.BoldOclYaccProdfeatureCallParameters2 Field

BoldOclYaccClass.BoldOclYaccProdfeatureCallParameters2 Field
BoldOclYaccClass Class Eco.Ocl.ParserCore Namespace See Also
Collapse All
C#
public const int BoldOclYaccProdfeatureCallParameters2 = 37;
Remarks

This is BoldOclYaccProdfeatureCallParameters2, a member of class BoldOclYaccClass.

See Also
BoldOclYaccClass Class
Eco.Ocl.ParserCore Namespace


BoldOclYaccClass.BoldOclYaccProdGoal Field

BoldOclYaccClass.BoldOclYaccProdGoal Field
BoldOclYaccClass Class Eco.Ocl.ParserCore Namespace See Also
Collapse All
C#
public const int BoldOclYaccProdGoal = 1;
Remarks

??!!YACCCON Do not edit, move, or duplicate, this marks the constants

See Also
BoldOclYaccClass Class
Eco.Ocl.ParserCore Namespace


BoldOclYaccClass.BoldOclYaccProdifExpression Field

BoldOclYaccClass.BoldOclYaccProdifExpression Field
BoldOclYaccClass Class Eco.Ocl.ParserCore Namespace See Also
Collapse All
C#
public const int BoldOclYaccProdifExpression = 24;
Remarks

This is BoldOclYaccProdifExpression, a member of class BoldOclYaccClass.

See Also
BoldOclYaccClass Class
Eco.Ocl.ParserCore Namespace


BoldOclYaccClass.BoldOclYaccProdliteral_Date Field

BoldOclYaccClass.BoldOclYaccProdliteral_Date Field
BoldOclYaccClass Class Eco.Ocl.ParserCore Namespace See Also
Collapse All
C#
public const int BoldOclYaccProdliteral_Date = 42;
Remarks

This is BoldOclYaccProdliteral_Date, a member of class BoldOclYaccClass.

See Also
BoldOclYaccClass Class
Eco.Ocl.ParserCore Namespace


BoldOclYaccClass.BoldOclYaccProdliteral_DateTime Field

BoldOclYaccClass.BoldOclYaccProdliteral_DateTime Field
BoldOclYaccClass Class Eco.Ocl.ParserCore Namespace See Also
Collapse All
C#
public const int BoldOclYaccProdliteral_DateTime = 43;
Remarks

This is BoldOclYaccProdliteral_DateTime, a member of class BoldOclYaccClass.

See Also
BoldOclYaccClass Class
Eco.Ocl.ParserCore Namespace


BoldOclYaccClass.BoldOclYaccProdliteral_EmptyString Field

BoldOclYaccClass.BoldOclYaccProdliteral_EmptyString Field
BoldOclYaccClass Class Eco.Ocl.ParserCore Namespace See Also
Collapse All
C#
public const int BoldOclYaccProdliteral_EmptyString = 39;
Remarks

This is BoldOclYaccProdliteral_EmptyString, a member of class BoldOclYaccClass.

See Also
BoldOclYaccClass Class
Eco.Ocl.ParserCore Namespace


BoldOclYaccClass.BoldOclYaccProdliteral_float Field

BoldOclYaccClass.BoldOclYaccProdliteral_float Field
BoldOclYaccClass Class Eco.Ocl.ParserCore Namespace See Also
Collapse All
C#
public const int BoldOclYaccProdliteral_float = 41;
Remarks

This is BoldOclYaccProdliteral_float, a member of class BoldOclYaccClass.

See Also
BoldOclYaccClass Class
Eco.Ocl.ParserCore Namespace


BoldOclYaccClass.BoldOclYaccProdliteral_Name Field

BoldOclYaccClass.BoldOclYaccProdliteral_Name Field
BoldOclYaccClass Class Eco.Ocl.ParserCore Namespace See Also
Collapse All
C#
public const int BoldOclYaccProdliteral_Name = 45;
Remarks

This is BoldOclYaccProdliteral_Name, a member of class BoldOclYaccClass.

See Also
BoldOclYaccClass Class
Eco.Ocl.ParserCore Namespace


BoldOclYaccClass.BoldOclYaccProdliteral_Number Field

BoldOclYaccClass.BoldOclYaccProdliteral_Number Field
BoldOclYaccClass Class Eco.Ocl.ParserCore Namespace See Also
Collapse All
C#
public const int BoldOclYaccProdliteral_Number = 40;
Remarks

This is BoldOclYaccProdliteral_Number, a member of class BoldOclYaccClass.

See Also
BoldOclYaccClass Class
Eco.Ocl.ParserCore Namespace


BoldOclYaccClass.BoldOclYaccProdliteral_String Field

BoldOclYaccClass.BoldOclYaccProdliteral_String Field
BoldOclYaccClass Class Eco.Ocl.ParserCore Namespace See Also
Collapse All
C#
public const int BoldOclYaccProdliteral_String = 38;
Remarks

This is BoldOclYaccProdliteral_String, a member of class BoldOclYaccClass.

See Also
BoldOclYaccClass Class
Eco.Ocl.ParserCore Namespace


BoldOclYaccClass.BoldOclYaccProdliteral_Time Field

BoldOclYaccClass.BoldOclYaccProdliteral_Time Field
BoldOclYaccClass Class Eco.Ocl.ParserCore Namespace See Also
Collapse All
C#
public const int BoldOclYaccProdliteral_Time = 44;
Remarks

This is BoldOclYaccProdliteral_Time, a member of class BoldOclYaccClass.

See Also
BoldOclYaccClass Class
Eco.Ocl.ParserCore Namespace


BoldOclYaccClass.BoldOclYaccProdliteralCollection Field

BoldOclYaccClass.BoldOclYaccProdliteralCollection Field
BoldOclYaccClass Class Eco.Ocl.ParserCore Namespace See Also
Collapse All
C#
public const int BoldOclYaccProdliteralCollection = 46;
Remarks

This is BoldOclYaccProdliteralCollection, a member of class BoldOclYaccClass.

See Also
BoldOclYaccClass Class
Eco.Ocl.ParserCore Namespace


BoldOclYaccClass.BoldOclYaccProdNonEmptyactualParameterList Field

BoldOclYaccClass.BoldOclYaccProdNonEmptyactualParameterList Field
BoldOclYaccClass Class Eco.Ocl.ParserCore Namespace See Also
Collapse All
C#
public const int BoldOclYaccProdNonEmptyactualParameterList = 60;
Remarks

This is BoldOclYaccProdNonEmptyactualParameterList, a member of class BoldOclYaccClass.

See Also
BoldOclYaccClass Class
Eco.Ocl.ParserCore Namespace


BoldOclYaccClass.BoldOclYaccProdNonEmptyactualParameterList_Rec Field

BoldOclYaccClass.BoldOclYaccProdNonEmptyactualParameterList_Rec Field
BoldOclYaccClass Class Eco.Ocl.ParserCore Namespace See Also
Collapse All
C#
public const int BoldOclYaccProdNonEmptyactualParameterList_Rec = 61;
Remarks

This is BoldOclYaccProdNonEmptyactualParameterList_Rec, a member of class BoldOclYaccClass.

See Also
BoldOclYaccClass Class
Eco.Ocl.ParserCore Namespace


BoldOclYaccClass.BoldOclYaccProdpathName Field

BoldOclYaccClass.BoldOclYaccProdpathName Field
BoldOclYaccClass Class Eco.Ocl.ParserCore Namespace See Also
Collapse All
C#
public const int BoldOclYaccProdpathName = 53;
Remarks

This is BoldOclYaccProdpathName, a member of class BoldOclYaccClass.

See Also
BoldOclYaccClass Class
Eco.Ocl.ParserCore Namespace


BoldOclYaccClass.BoldOclYaccProdpathName_Rec Field

BoldOclYaccClass.BoldOclYaccProdpathName_Rec Field
BoldOclYaccClass Class Eco.Ocl.ParserCore Namespace See Also
Collapse All
C#
public const int BoldOclYaccProdpathName_Rec = 54;
Remarks

This is BoldOclYaccProdpathName_Rec, a member of class BoldOclYaccClass.

See Also
BoldOclYaccClass Class
Eco.Ocl.ParserCore Namespace


BoldOclYaccClass.BoldOclYaccProdpostFixFirst Field

BoldOclYaccClass.BoldOclYaccProdpostFixFirst Field
BoldOclYaccClass Class Eco.Ocl.ParserCore Namespace See Also
Collapse All
C#
public const int BoldOclYaccProdpostFixFirst = 25;
Remarks

This is BoldOclYaccProdpostFixFirst, a member of class BoldOclYaccClass.

See Also
BoldOclYaccClass Class
Eco.Ocl.ParserCore Namespace


BoldOclYaccClass.BoldOclYaccProdpostFixMember Field

BoldOclYaccClass.BoldOclYaccProdpostFixMember Field
BoldOclYaccClass Class Eco.Ocl.ParserCore Namespace See Also
Collapse All
C#
public const int BoldOclYaccProdpostFixMember = 26;
Remarks

This is BoldOclYaccProdpostFixMember, a member of class BoldOclYaccClass.

See Also
BoldOclYaccClass Class
Eco.Ocl.ParserCore Namespace


BoldOclYaccClass.BoldOclYaccProdpostFixMethod Field

BoldOclYaccClass.BoldOclYaccProdpostFixMethod Field
BoldOclYaccClass Class Eco.Ocl.ParserCore Namespace See Also
Collapse All
C#
public const int BoldOclYaccProdpostFixMethod = 27;
Remarks

This is BoldOclYaccProdpostFixMethod, a member of class BoldOclYaccClass.

See Also
BoldOclYaccClass Class
Eco.Ocl.ParserCore Namespace


BoldOclYaccClass.BoldOclYaccProdpostFixOperation Field

BoldOclYaccClass.BoldOclYaccProdpostFixOperation Field
BoldOclYaccClass Class Eco.Ocl.ParserCore Namespace See Also
Collapse All
C#
public const int BoldOclYaccProdpostFixOperation = 28;
Remarks

This is BoldOclYaccProdpostFixOperation, a member of class BoldOclYaccClass.

See Also
BoldOclYaccClass Class
Eco.Ocl.ParserCore Namespace


BoldOclYaccClass.BoldOclYaccProdpostFixOperationParams Field

BoldOclYaccClass.BoldOclYaccProdpostFixOperationParams Field
BoldOclYaccClass Class Eco.Ocl.ParserCore Namespace See Also
Collapse All
C#
public const int BoldOclYaccProdpostFixOperationParams = 29;
Remarks

This is BoldOclYaccProdpostFixOperationParams, a member of class BoldOclYaccClass.

See Also
BoldOclYaccClass Class
Eco.Ocl.ParserCore Namespace


BoldOclYaccClass.BoldOclYaccProdprimaryExpIf Field

BoldOclYaccClass.BoldOclYaccProdprimaryExpIf Field
BoldOclYaccClass Class Eco.Ocl.ParserCore Namespace See Also
Collapse All
C#
public const int BoldOclYaccProdprimaryExpIf = 33;
Remarks

This is BoldOclYaccProdprimaryExpIf, a member of class BoldOclYaccClass.

See Also
BoldOclYaccClass Class
Eco.Ocl.ParserCore Namespace


BoldOclYaccClass.BoldOclYaccProdprimaryExpLitt Field

BoldOclYaccClass.BoldOclYaccProdprimaryExpLitt Field
BoldOclYaccClass Class Eco.Ocl.ParserCore Namespace See Also
Collapse All
C#
public const int BoldOclYaccProdprimaryExpLitt = 31;
Remarks

This is BoldOclYaccProdprimaryExpLitt, a member of class BoldOclYaccClass.

See Also
BoldOclYaccClass Class
Eco.Ocl.ParserCore Namespace


BoldOclYaccClass.BoldOclYaccProdprimaryExpLittCollection Field

BoldOclYaccClass.BoldOclYaccProdprimaryExpLittCollection Field
BoldOclYaccClass Class Eco.Ocl.ParserCore Namespace See Also
Collapse All
C#
public const int BoldOclYaccProdprimaryExpLittCollection = 30;
Remarks

This is BoldOclYaccProdprimaryExpLittCollection, a member of class BoldOclYaccClass.

See Also
BoldOclYaccClass Class
Eco.Ocl.ParserCore Namespace


BoldOclYaccClass.BoldOclYaccProdprimaryExpParen Field

BoldOclYaccClass.BoldOclYaccProdprimaryExpParen Field
BoldOclYaccClass Class Eco.Ocl.ParserCore Namespace See Also
Collapse All
C#
public const int BoldOclYaccProdprimaryExpParen = 32;
Remarks

This is BoldOclYaccProdprimaryExpParen, a member of class BoldOclYaccClass.

See Also
BoldOclYaccClass Class
Eco.Ocl.ParserCore Namespace


BoldOclYaccClass.BoldOclYaccProdPrimaryNoParams Field

BoldOclYaccClass.BoldOclYaccProdPrimaryNoParams Field
BoldOclYaccClass Class Eco.Ocl.ParserCore Namespace See Also
Collapse All
C#
public const int BoldOclYaccProdPrimaryNoParams = 34;
Remarks

This is BoldOclYaccProdPrimaryNoParams, a member of class BoldOclYaccClass.

See Also
BoldOclYaccClass Class
Eco.Ocl.ParserCore Namespace


BoldOclYaccClass.BoldOclYaccProdPrimaryWithParams Field

BoldOclYaccClass.BoldOclYaccProdPrimaryWithParams Field
BoldOclYaccClass Class Eco.Ocl.ParserCore Namespace See Also
Collapse All
C#
public const int BoldOclYaccProdPrimaryWithParams = 35;
Remarks

This is BoldOclYaccProdPrimaryWithParams, a member of class BoldOclYaccClass.

See Also
BoldOclYaccClass Class
Eco.Ocl.ParserCore Namespace


BoldOclYaccClass.BoldOclYaccProdqualifiers Field

BoldOclYaccClass.BoldOclYaccProdqualifiers Field
BoldOclYaccClass Class Eco.Ocl.ParserCore Namespace See Also
Collapse All
C#
public const int BoldOclYaccProdqualifiers = 52;
Remarks

This is BoldOclYaccProdqualifiers, a member of class BoldOclYaccClass.

See Also
BoldOclYaccClass Class
Eco.Ocl.ParserCore Namespace


BoldOclYaccClass.BoldOclYaccProdqualifiers_Ety Field

BoldOclYaccClass.BoldOclYaccProdqualifiers_Ety Field
BoldOclYaccClass Class Eco.Ocl.ParserCore Namespace See Also
Collapse All
C#
public const int BoldOclYaccProdqualifiers_Ety = 51;
Remarks

This is BoldOclYaccProdqualifiers_Ety, a member of class BoldOclYaccClass.

See Also
BoldOclYaccClass Class
Eco.Ocl.ParserCore Namespace


BoldOclYaccClass.BoldOclYaccProdtimeExpression Field

BoldOclYaccClass.BoldOclYaccProdtimeExpression Field
BoldOclYaccClass Class Eco.Ocl.ParserCore Namespace See Also
Collapse All
C#
public const int BoldOclYaccProdtimeExpression = 56;
Remarks

This is BoldOclYaccProdtimeExpression, a member of class BoldOclYaccClass.

See Also
BoldOclYaccClass Class
Eco.Ocl.ParserCore Namespace


BoldOclYaccClass.BoldOclYaccProdtimeExpression_Ety Field

BoldOclYaccClass.BoldOclYaccProdtimeExpression_Ety Field
BoldOclYaccClass Class Eco.Ocl.ParserCore Namespace See Also
Collapse All
C#
public const int BoldOclYaccProdtimeExpression_Ety = 57;
Remarks

This is BoldOclYaccProdtimeExpression_Ety, a member of class BoldOclYaccClass.

See Also
BoldOclYaccClass Class
Eco.Ocl.ParserCore Namespace


BoldOclYaccClass.finalValue Field

BoldOclYaccClass.finalValue Field
BoldOclYaccClass Class Eco.Ocl.ParserCore Namespace See Also
Collapse All
C#
public SSYaccStackElement finalValue;
Remarks

This is finalValue, a member of class BoldOclYaccClass.

See Also
BoldOclYaccClass Class
Eco.Ocl.ParserCore Namespace


BoldOclYaccClass Methods

BoldOclYaccClass Methods
Public Methods
Collapse All

The methods of the BoldOclYaccClass class are listed here.

Public Methods
Name | Description
reduce |
stackElement | This is stackElement, a member of class BoldOclYaccClass.


BoldOclYaccClass.reduce Method

BoldOclYaccClass.reduce Method
BoldOclYaccClass Class Eco.Ocl.ParserCore Namespace See Also
Collapse All
C#
public override SSYaccStackElement reduce(
    int q_prod,
    int q_size
);
Notes

In order not to confuse the auto-merge parser, it's very important to keep this function clean. To avoid any problems, just make function calls to other functions that do the real work. NEVER include nested switch statements in this function. Do not move the comments after each case statement, they are updated as a part of the auto-merge process.

See Also
BoldOclYaccClass Class
Eco.Ocl.ParserCore Namespace


BoldOclYaccClass.stackElement Method

BoldOclYaccClass.stackElement Method
BoldOclYaccClass Class Eco.Ocl.ParserCore Namespace See Also
Collapse All
C#
public override SSYaccStackElement stackElement();
Remarks

This is stackElement, a member of class BoldOclYaccClass.

See Also
BoldOclYaccClass Class
Eco.Ocl.ParserCore Namespace


BoldOclYaccClass Properties

BoldOclYaccClass Properties
Public Properties
Collapse All

The properties of the BoldOclYaccClass class are listed here.

Public Properties
Name | Description
Errorposition | This is Errorposition, a member of class BoldOclYaccClass.


BoldOclYaccClass.Errorposition Property

BoldOclYaccClass.Errorposition Property
BoldOclYaccClass Class Eco.Ocl.ParserCore Namespace See Also
Collapse All
C#
public int Errorposition;
Remarks

This is Errorposition, a member of class BoldOclYaccClass.

See Also
BoldOclYaccClass Class
Eco.Ocl.ParserCore Namespace


BoldOclYaccTable Class

BoldOclYaccTable Class
Inheritance Hierarchy See Also
Collapse All
C#
public sealed class BoldOclYaccTable : SSYaccTable;
Remarks

This is class Eco.Ocl.ParserCore.BoldOclYaccTable.

Inheritance Hierarchy
Eco.Ocl.ParserCore.SSYaccTable
    Eco.Ocl.ParserCore.BoldOclYaccTable
File

OclYaccTable.cs

See Also
Inheritance Hierarchy


BoldOclYaccTable.BoldOclYaccTable Constructor

BoldOclYaccTable.BoldOclYaccTable Constructor
BoldOclYaccTable Class Eco.Ocl.ParserCore Namespace See Also
Collapse All
C#
public BoldOclYaccTable();
Remarks

This is BoldOclYaccTable, a member of class BoldOclYaccTable.

See Also
BoldOclYaccTable Class
Eco.Ocl.ParserCore Namespace


InvalidOclException Class

InvalidOclException Class
Inheritance Hierarchy See Also
Collapse All
C#
public class InvalidOclException : System.Exception;
Remarks

This is class Eco.Ocl.ParserCore.InvalidOclException.

Inheritance Hierarchy
Eco.Ocl.ParserCore.InvalidOclException
    Eco.Ocl.ParserCore.InvalidOclSyntaxException
File

OclParserCoreInterfaces.cs

See Also
Inheritance Hierarchy


InvalidOclException Constructor

InvalidOclException Constructor

This is the overview for the InvalidOclException constructor overload.

Overload List
Name | Description
InvalidOclException.InvalidOclException () | This is InvalidOclException, a member of class InvalidOclException.
InvalidOclException.InvalidOclException (SerializationInfo, StreamingContext) | This is InvalidOclException, a member of class InvalidOclException.
InvalidOclException.InvalidOclException (string) | This is InvalidOclException, a member of class InvalidOclException.
InvalidOclException.InvalidOclException (string, Exception) | This is InvalidOclException, a member of class InvalidOclException.


InvalidOclException.InvalidOclException Constructor ()

InvalidOclException.InvalidOclException Constructor ()
InvalidOclException Class Eco.Ocl.ParserCore Namespace See Also
Collapse All
C#
public InvalidOclException();
Remarks

This is InvalidOclException, a member of class InvalidOclException.

See Also
InvalidOclException Class
Eco.Ocl.ParserCore Namespace


InvalidOclException.InvalidOclException Constructor (SerializationInfo, StreamingContext)

InvalidOclException.InvalidOclException Constructor (SerializationInfo, StreamingContext)
InvalidOclException Class Eco.Ocl.ParserCore Namespace See Also
Collapse All
C#
protected InvalidOclException(
    SerializationInfo info,
    StreamingContext context
);
Remarks

This is InvalidOclException, a member of class InvalidOclException.

See Also
InvalidOclException Class
Eco.Ocl.ParserCore Namespace


InvalidOclException.InvalidOclException Constructor (string)

InvalidOclException.InvalidOclException Constructor (string)
InvalidOclException Class Eco.Ocl.ParserCore Namespace See Also
Collapse All
C#
public InvalidOclException(
    string message
);
Remarks

This is InvalidOclException, a member of class InvalidOclException.

See Also
InvalidOclException Class
Eco.Ocl.ParserCore Namespace


InvalidOclException.InvalidOclException Constructor (string, Exception)

InvalidOclException.InvalidOclException Constructor (string, Exception)
InvalidOclException Class Eco.Ocl.ParserCore Namespace See Also
Collapse All
C#
public InvalidOclException(
    string message,
    Exception inner
);
Remarks

This is InvalidOclException, a member of class InvalidOclException.

See Also
InvalidOclException Class
Eco.Ocl.ParserCore Namespace


InvalidOclSyntaxException Class

InvalidOclSyntaxException Class
Inheritance Hierarchy See Also
Collapse All
C#
public class InvalidOclSyntaxException : InvalidOclException;
Remarks

This is class Eco.Ocl.ParserCore.InvalidOclSyntaxException.

Inheritance Hierarchy
Eco.Ocl.ParserCore.InvalidOclException
    Eco.Ocl.ParserCore.InvalidOclSyntaxException
File

OclParserCoreInterfaces.cs

See Also
Inheritance Hierarchy


InvalidOclSyntaxException Constructor

InvalidOclSyntaxException Constructor

This is the overview for the InvalidOclSyntaxException constructor overload.

Overload List
Name | Description
InvalidOclSyntaxException.InvalidOclSyntaxException () | This is InvalidOclSyntaxException, a member of class InvalidOclSyntaxException.
InvalidOclSyntaxException.InvalidOclSyntaxException (SerializationInfo, StreamingContext) | This is InvalidOclSyntaxException, a member of class InvalidOclSyntaxException.
InvalidOclSyntaxException.InvalidOclSyntaxException (string) | This is InvalidOclSyntaxException, a member of class InvalidOclSyntaxException.
InvalidOclSyntaxException.InvalidOclSyntaxException (string, Exception) | This is InvalidOclSyntaxException, a member of class InvalidOclSyntaxException.


InvalidOclSyntaxException.InvalidOclSyntaxException Constructor ()

InvalidOclSyntaxException.InvalidOclSyntaxException Constructor ()
InvalidOclSyntaxException Class Eco.Ocl.ParserCore Namespace See Also
Collapse All
C#
public InvalidOclSyntaxException();
Remarks

This is InvalidOclSyntaxException, a member of class InvalidOclSyntaxException.

See Also
InvalidOclSyntaxException Class
Eco.Ocl.ParserCore Namespace


InvalidOclSyntaxException.InvalidOclSyntaxException Constructor (SerializationInfo, StreamingContext)

InvalidOclSyntaxException.InvalidOclSyntaxException Constructor (SerializationInfo, StreamingContext)
InvalidOclSyntaxException Class Eco.Ocl.ParserCore Namespace See Also
Collapse All
C#
protected InvalidOclSyntaxException(
    SerializationInfo info,
    StreamingContext context
);
Remarks

This is InvalidOclSyntaxException, a member of class InvalidOclSyntaxException.

See Also
InvalidOclSyntaxException Class
Eco.Ocl.ParserCore Namespace


InvalidOclSyntaxException.InvalidOclSyntaxException Constructor (string)

InvalidOclSyntaxException.InvalidOclSyntaxException Constructor (string)
InvalidOclSyntaxException Class Eco.Ocl.ParserCore Namespace See Also
Collapse All
C#
public InvalidOclSyntaxException(
    string message
);
Remarks

This is InvalidOclSyntaxException, a member of class InvalidOclSyntaxException.

See Also
InvalidOclSyntaxException Class
Eco.Ocl.ParserCore Namespace


InvalidOclSyntaxException.InvalidOclSyntaxException Constructor (string, Exception)

InvalidOclSyntaxException.InvalidOclSyntaxException Constructor (string, Exception)
InvalidOclSyntaxException Class Eco.Ocl.ParserCore Namespace See Also
Collapse All
C#
public InvalidOclSyntaxException(
    string message,
    Exception inner
);
Remarks

This is InvalidOclSyntaxException, a member of class InvalidOclSyntaxException.

See Also
InvalidOclSyntaxException Class
Eco.Ocl.ParserCore Namespace


OclStackElement Class

OclStackElement Class
Inheritance Hierarchy See Also
Collapse All
C#
public sealed class OclStackElement : SSYaccStackElement;
Remarks

This is class Eco.Ocl.ParserCore.OclStackElement.

Inheritance Hierarchy
Eco.Ocl.ParserCore.SSYaccStackElement
    Eco.Ocl.ParserCore.OclStackElement
File

OclParserCoreInterfaces.cs

See Also
Inheritance Hierarchy


OclStackElement.OclStackElement Constructor

OclStackElement.OclStackElement Constructor
OclStackElement Class Eco.Ocl.ParserCore Namespace See Also
Collapse All
C#
public OclStackElement(
    int InitOffset
);
Remarks

This is OclStackElement, a member of class OclStackElement.

See Also
OclStackElement Class
Eco.Ocl.ParserCore Namespace


OclStackElement Methods

OclStackElement Methods
Public Methods
Collapse All

The methods of the OclStackElement class are listed here.

Public Methods
Name | Description
Clone | This is Clone, a member of class OclStackElement.


OclStackElement.Clone Method

OclStackElement.Clone Method
OclStackElement Class Eco.Ocl.ParserCore Namespace See Also
Collapse All
C#
public OclStackElement Clone();
Remarks

This is Clone, a member of class OclStackElement.

See Also
OclStackElement Class
Eco.Ocl.ParserCore Namespace


OclStackElement Properties

OclStackElement Properties
Public Properties
Collapse All

The properties of the OclStackElement class are listed here.

Public Properties
Name | Description
DeclaratorTypeList | This is DeclaratorTypeList, a member of class OclStackElement.
List | This is List, a member of class OclStackElement.
Name | This is Name, a member of class OclStackElement.
Node | This is Node, a member of class OclStackElement.
Offset | This is Offset, a member of class OclStackElement.
SimpleTypeSpecifierIsEnum | This is SimpleTypeSpecifierIsEnum, a member of class OclStackElement.
Start | This is Start, a member of class OclStackElement.
Stop | This is Stop, a member of class OclStackElement.


OclStackElement.DeclaratorTypeList Property

OclStackElement.DeclaratorTypeList Property
OclStackElement Class Eco.Ocl.ParserCore Namespace See Also
Collapse All
C#
public List<OclStackElement> DeclaratorTypeList;
Remarks

This is DeclaratorTypeList, a member of class OclStackElement.

See Also
OclStackElement Class
Eco.Ocl.ParserCore Namespace


OclStackElement.List Property

OclStackElement.List Property
OclStackElement Class Eco.Ocl.ParserCore Namespace See Also
Collapse All
C#
public List<OclStackElement> List;
Remarks

This is List, a member of class OclStackElement.

See Also
OclStackElement Class
Eco.Ocl.ParserCore Namespace


OclStackElement.Name Property

OclStackElement.Name Property
OclStackElement Class Eco.Ocl.ParserCore Namespace See Also
Collapse All
C#
public string Name;
Remarks

This is Name, a member of class OclStackElement.

See Also
OclStackElement Class
Eco.Ocl.ParserCore Namespace


OclStackElement.Node Property

OclStackElement.Node Property
OclStackElement Class Eco.Ocl.ParserCore Namespace See Also
Collapse All
C#
public OclNode Node;
Remarks

This is Node, a member of class OclStackElement.

See Also
OclStackElement Class
Eco.Ocl.ParserCore Namespace


OclStackElement.Offset Property

OclStackElement.Offset Property
OclStackElement Class Eco.Ocl.ParserCore Namespace See Also
Collapse All
C#
public int Offset;
Remarks

This is Offset, a member of class OclStackElement.

See Also
OclStackElement Class
Eco.Ocl.ParserCore Namespace


OclStackElement.SimpleTypeSpecifierIsEnum Property

OclStackElement.SimpleTypeSpecifierIsEnum Property
OclStackElement Class Eco.Ocl.ParserCore Namespace See Also
Collapse All
C#
public bool SimpleTypeSpecifierIsEnum;
Remarks

This is SimpleTypeSpecifierIsEnum, a member of class OclStackElement.

See Also
OclStackElement Class
Eco.Ocl.ParserCore Namespace


OclStackElement.Start Property

OclStackElement.Start Property
OclStackElement Class Eco.Ocl.ParserCore Namespace See Also
Collapse All
C#
public OclNode Start;
Remarks

This is Start, a member of class OclStackElement.

See Also
OclStackElement Class
Eco.Ocl.ParserCore Namespace


OclStackElement.Stop Property

OclStackElement.Stop Property
OclStackElement Class Eco.Ocl.ParserCore Namespace See Also
Collapse All
C#
public OclNode Stop;
Remarks

This is Stop, a member of class OclStackElement.

See Also
OclStackElement Class
Eco.Ocl.ParserCore Namespace


SSLex Class

SSLex Class
Inheritance Hierarchy See Also
Collapse All
C#
public class SSLex;
Remarks

This is class Eco.Ocl.ParserCore.SSLex.

Inheritance Hierarchy
Eco.Ocl.ParserCore.SSLex
    Eco.Ocl.ParserCore.BoldOclLexClass
File

SSLex.cs

See Also
Inheritance Hierarchy


SSLex Methods

SSLex Methods
Public Methods
Collapse All

The methods of the SSLex class are listed here.

Public Methods
Name | Description
complete | This is complete, a member of class SSLex.
consumer | This is consumer, a member of class SSLex.
error | This is error, a member of class SSLex.
table | This is table, a member of class SSLex.


SSLex.complete Method

SSLex.complete Method
SSLex Class Eco.Ocl.ParserCore Namespace See Also
Collapse All
C#
public virtual Boolean complete(
    SSLexLexeme q_lexeme
);
Remarks

This is complete, a member of class SSLex.

See Also
SSLex Class
Eco.Ocl.ParserCore Namespace


SSLex.consumer Method

SSLex.consumer Method
SSLex Class Eco.Ocl.ParserCore Namespace See Also
Collapse All
C#
public SSLexConsumer consumer();
Remarks

This is consumer, a member of class SSLex.

See Also
SSLex Class
Eco.Ocl.ParserCore Namespace


SSLex.error Method

SSLex.error Method
SSLex Class Eco.Ocl.ParserCore Namespace See Also
Collapse All
C#
public virtual Boolean error(
    SSLexLexeme q_lexeme
);
Remarks

This is error, a member of class SSLex.

See Also
SSLex Class
Eco.Ocl.ParserCore Namespace


SSLex.table Method

SSLex.table Method
SSLex Class Eco.Ocl.ParserCore Namespace See Also
Collapse All
C#
public SSLexTable table();
Remarks

This is table, a member of class SSLex.

See Also
SSLex Class
Eco.Ocl.ParserCore Namespace


SSLexCharacterClass Class

SSLexCharacterClass Class
Inheritance Hierarchy See Also
Collapse All
C#
public class SSLexCharacterClass;
Remarks

This is class Eco.Ocl.ParserCore.SSLexCharacterClass.

Inheritance Hierarchy
Eco.Ocl.ParserCore.SSLexCharacterClass
File

SSLexCharacterClass.cs

See Also
Inheritance Hierarchy


SSLexCharacterClass.SSLexCharacterClass Constructor

SSLexCharacterClass.SSLexCharacterClass Constructor
SSLexCharacterClass Class Eco.Ocl.ParserCore Namespace See Also
Collapse All
C#
public SSLexCharacterClass(
    int q_size,
    int q_min,
    int q_max,
    int[] q_array
);
Remarks

This is SSLexCharacterClass, a member of class SSLexCharacterClass.

See Also
SSLexCharacterClass Class
Eco.Ocl.ParserCore Namespace


SSLexConsumer Class

SSLexConsumer Class
Inheritance Hierarchy See Also
Collapse All
C#
public abstract class SSLexConsumer;
Remarks

This is class Eco.Ocl.ParserCore.SSLexConsumer.

Inheritance Hierarchy
Eco.Ocl.ParserCore.SSLexConsumer
    Eco.Ocl.ParserCore.SSLexStringConsumer
File

SSLexConsumer.cs

See Also
Inheritance Hierarchy


SSLexConsumer Fields

SSLexConsumer Fields
Protected Fields
Collapse All

The fields of the SSLexConsumer class are listed here.

Protected Fields
Name | Description
m_current | This is m_current, a member of class SSLexConsumer.
m_index | This is m_index, a member of class SSLexConsumer.
m_length | This is m_length, a member of class SSLexConsumer.


SSLexConsumer.m_current Field

SSLexConsumer.m_current Field
SSLexConsumer Class Eco.Ocl.ParserCore Namespace See Also
Collapse All
C#
protected char m_current;
Remarks

This is m_current, a member of class SSLexConsumer.

See Also
SSLexConsumer Class
Eco.Ocl.ParserCore Namespace


SSLexConsumer.m_index Field

SSLexConsumer.m_index Field
SSLexConsumer Class Eco.Ocl.ParserCore Namespace See Also
Collapse All
C#
protected int m_index = 0;
Remarks

This is m_index, a member of class SSLexConsumer.

See Also
SSLexConsumer Class
Eco.Ocl.ParserCore Namespace


SSLexConsumer.m_length Field

SSLexConsumer.m_length Field
SSLexConsumer Class Eco.Ocl.ParserCore Namespace See Also
Collapse All
C#
protected int m_length = 0;
Remarks

This is m_length, a member of class SSLexConsumer.

See Also
SSLexConsumer Class
Eco.Ocl.ParserCore Namespace


SSLexConsumer Methods

SSLexConsumer Methods
Public Methods
Collapse All

The methods of the SSLexConsumer class are listed here.

Public Methods
Name | Description
absoluteOffset | This is absoluteOffset, a member of class SSLexConsumer.
flushLexeme | This is flushLexeme, a member of class SSLexConsumer.
getNext | This is getNext, a member of class SSLexConsumer.


SSLexConsumer.absoluteOffset Method

SSLexConsumer.absoluteOffset Method
SSLexConsumer Class Eco.Ocl.ParserCore Namespace See Also
Collapse All
C#
public int absoluteOffset();
Remarks

This is absoluteOffset, a member of class SSLexConsumer.

See Also
SSLexConsumer Class
Eco.Ocl.ParserCore Namespace


SSLexConsumer.flushLexeme Method

SSLexConsumer.flushLexeme Method
SSLexConsumer Class Eco.Ocl.ParserCore Namespace See Also
Collapse All
C#
public virtual void flushLexeme(
    SSLexMark q_mark
);
Remarks

This is flushLexeme, a member of class SSLexConsumer.

See Also
SSLexConsumer Class
Eco.Ocl.ParserCore Namespace


SSLexConsumer.getNext Method

SSLexConsumer.getNext Method
SSLexConsumer Class Eco.Ocl.ParserCore Namespace See Also
Collapse All
C#
public abstract Boolean getNext();
Remarks

This is getNext, a member of class SSLexConsumer.

See Also
SSLexConsumer Class
Eco.Ocl.ParserCore Namespace


SSLexFinalState Class

SSLexFinalState Class
Inheritance Hierarchy See Also
Collapse All
C#
public class SSLexFinalState;
Remarks

This is class Eco.Ocl.ParserCore.SSLexFinalState.

Inheritance Hierarchy
Eco.Ocl.ParserCore.SSLexFinalState
File

SSLexFinalState.cs

See Also
Inheritance Hierarchy


SSLexFinalState.SSLexFinalState Constructor

SSLexFinalState.SSLexFinalState Constructor
SSLexFinalState Class Eco.Ocl.ParserCore Namespace See Also
Collapse All
C#
public SSLexFinalState(
    int[] q_final,
    int q_index
);
Remarks

This is SSLexFinalState, a member of class SSLexFinalState.

See Also
SSLexFinalState Class
Eco.Ocl.ParserCore Namespace


SSLexFinalState Fields

SSLexFinalState Fields
Public Fields
Collapse All

The fields of the SSLexFinalState class are listed here.

Public Fields
Name | Description
m_flagContextEnd | This is m_flagContextEnd, a member of class SSLexFinalState.
m_flagContextStart | This is m_flagContextStart, a member of class SSLexFinalState.
m_flagFinal | This is m_flagFinal, a member of class SSLexFinalState.
m_flagIgnore | This is m_flagIgnore, a member of class SSLexFinalState.
m_flagKeyword | This is m_flagKeyword, a member of class SSLexFinalState.
m_flagParseToken | This is m_flagParseToken, a member of class SSLexFinalState.
m_flagPop | This is m_flagPop, a member of class SSLexFinalState.
m_flagPush | This is m_flagPush, a member of class SSLexFinalState.
m_flagReduce | This is m_flagReduce, a member of class SSLexFinalState.
m_flagStartOfLine | This is m_flagStartOfLine, a member of class SSLexFinalState.


SSLexFinalState.m_flagContextEnd Field

SSLexFinalState.m_flagContextEnd Field
SSLexFinalState Class Eco.Ocl.ParserCore Namespace See Also
Collapse All
C#
public const int m_flagContextEnd = 0x00000080;
Remarks

This is m_flagContextEnd, a member of class SSLexFinalState.

See Also
SSLexFinalState Class
Eco.Ocl.ParserCore Namespace


SSLexFinalState.m_flagContextStart Field

SSLexFinalState.m_flagContextStart Field
SSLexFinalState Class Eco.Ocl.ParserCore Namespace See Also
Collapse All
C#
public const int m_flagContextStart = 0x00000001;
Remarks

This is m_flagContextStart, a member of class SSLexFinalState.

See Also
SSLexFinalState Class
Eco.Ocl.ParserCore Namespace


SSLexFinalState.m_flagFinal Field

SSLexFinalState.m_flagFinal Field
SSLexFinalState Class Eco.Ocl.ParserCore Namespace See Also
Collapse All
C#
public const int m_flagFinal = 0x00000010;
Remarks

This is m_flagFinal, a member of class SSLexFinalState.

See Also
SSLexFinalState Class
Eco.Ocl.ParserCore Namespace


SSLexFinalState.m_flagIgnore Field

SSLexFinalState.m_flagIgnore Field
SSLexFinalState Class Eco.Ocl.ParserCore Namespace See Also
Collapse All
C#
public const int m_flagIgnore = 0x00000040;
Remarks

This is m_flagIgnore, a member of class SSLexFinalState.

See Also
SSLexFinalState Class
Eco.Ocl.ParserCore Namespace


SSLexFinalState.m_flagKeyword Field

SSLexFinalState.m_flagKeyword Field
SSLexFinalState Class Eco.Ocl.ParserCore Namespace See Also
Collapse All
C#
public const int m_flagKeyword = 0x00000200;
Remarks

This is m_flagKeyword, a member of class SSLexFinalState.

See Also
SSLexFinalState Class
Eco.Ocl.ParserCore Namespace


SSLexFinalState.m_flagParseToken Field

SSLexFinalState.m_flagParseToken Field
SSLexFinalState Class Eco.Ocl.ParserCore Namespace See Also
Collapse All
C#
public const int m_flagParseToken = 0x00000400;
Remarks

This is m_flagParseToken, a member of class SSLexFinalState.

See Also
SSLexFinalState Class
Eco.Ocl.ParserCore Namespace


SSLexFinalState.m_flagPop Field

SSLexFinalState.m_flagPop Field
SSLexFinalState Class Eco.Ocl.ParserCore Namespace See Also
Collapse All
C#
public const int m_flagPop = 0x00000008;
Remarks

This is m_flagPop, a member of class SSLexFinalState.

See Also
SSLexFinalState Class
Eco.Ocl.ParserCore Namespace


SSLexFinalState.m_flagPush Field

SSLexFinalState.m_flagPush Field
SSLexFinalState Class Eco.Ocl.ParserCore Namespace See Also
Collapse All
C#
public const int m_flagPush = 0x00000020;
Remarks

This is m_flagPush, a member of class SSLexFinalState.

See Also
SSLexFinalState Class
Eco.Ocl.ParserCore Namespace


SSLexFinalState.m_flagReduce Field

SSLexFinalState.m_flagReduce Field
SSLexFinalState Class Eco.Ocl.ParserCore Namespace See Also
Collapse All
C#
public const int m_flagReduce = 0x00000100;
Remarks

This is m_flagReduce, a member of class SSLexFinalState.

See Also
SSLexFinalState Class
Eco.Ocl.ParserCore Namespace


SSLexFinalState.m_flagStartOfLine Field

SSLexFinalState.m_flagStartOfLine Field
SSLexFinalState Class Eco.Ocl.ParserCore Namespace See Also
Collapse All
C#
public const int m_flagStartOfLine = 0x00000002;
Remarks

This is m_flagStartOfLine, a member of class SSLexFinalState.

See Also
SSLexFinalState Class
Eco.Ocl.ParserCore Namespace


SSLexFinalState Methods

SSLexFinalState Methods
Public Methods
Collapse All

The methods of the SSLexFinalState class are listed here.

Public Methods
Name | Description
isParseToken | 12/27/99 G. Krstic


SSLexFinalState.isParseToken Method

SSLexFinalState.isParseToken Method
SSLexFinalState Class Eco.Ocl.ParserCore Namespace See Also
Collapse All
C#
public Boolean isParseToken();
Remarks

12/27/99 G. Krstic

See Also
SSLexFinalState Class
Eco.Ocl.ParserCore Namespace


SSLexKeyTable Class

SSLexKeyTable Class
Inheritance Hierarchy See Also
Collapse All
C#
public class SSLexKeyTable;
Remarks

This is class Eco.Ocl.ParserCore.SSLexKeyTable.

Inheritance Hierarchy
Eco.Ocl.ParserCore.SSLexKeyTable
File

SSLexKeyTable.cs

See Also
Inheritance Hierarchy


SSLexLexeme Class

SSLexLexeme Class
Inheritance Hierarchy See Also
Collapse All
C#
public class SSLexLexeme;
Remarks

This is class Eco.Ocl.ParserCore.SSLexLexeme.

Inheritance Hierarchy
Eco.Ocl.ParserCore.SSLexLexeme
File

SSLexLexeme.cs

See Also
Inheritance Hierarchy


SSLexLexeme Constructor

SSLexLexeme Constructor

This is the overview for the SSLexLexeme constructor overload.

Overload List
Name
Description
SSLexLexeme.SSLexLexeme (SSLexConsumer)
This is SSLexLexeme, a member of class SSLexLexeme.
SSLexLexeme.SSLexLexeme (SSLexConsumer, SSLexFinalState, SSLexMark)
This is SSLexLexeme, a member of class SSLexLexeme.
SSLexLexeme.SSLexLexeme (String, int)

  • UNUSED

public SSLexLexeme() { m_line = 0; m_token = 0; m_length = 0; m_offset = 0;


SSLexLexeme.SSLexLexeme Constructor (SSLexConsumer)

SSLexLexeme.SSLexLexeme Constructor (SSLexConsumer)
SSLexLexeme Class Eco.Ocl.ParserCore Namespace See Also
Collapse All
C#
public SSLexLexeme(
    SSLexConsumer q_consumer
);
Remarks

This is SSLexLexeme, a member of class SSLexLexeme.

See Also
SSLexLexeme Class
Eco.Ocl.ParserCore Namespace


SSLexLexeme.SSLexLexeme Constructor (SSLexConsumer, SSLexFinalState, SSLexMark)

SSLexLexeme.SSLexLexeme Constructor (SSLexConsumer, SSLexFinalState, SSLexMark)
SSLexLexeme Class Eco.Ocl.ParserCore Namespace See Also
Collapse All
C#
public SSLexLexeme(
    SSLexConsumer q_consumer,
    SSLexFinalState q_final,
    SSLexMark q_mark
);
Remarks

This is SSLexLexeme, a member of class SSLexLexeme.

See Also
SSLexLexeme Class
Eco.Ocl.ParserCore Namespace


SSLexLexeme.SSLexLexeme Constructor (String, int)

SSLexLexeme.SSLexLexeme Constructor (String, int)
SSLexLexeme Class Eco.Ocl.ParserCore Namespace See Also
Collapse All
C#
public SSLexLexeme(
    String q_lexeme,
    int q_token
);
Remarks
  • UNUSED

public SSLexLexeme() { m_line = 0; m_token = 0; m_length = 0; m_offset = 0;

See Also
SSLexLexeme Class
Eco.Ocl.ParserCore Namespace


SSLexLexeme Methods

SSLexLexeme Methods
Public Methods
Collapse All

The methods of the SSLexLexeme class are listed here.

Public Methods
Name | Description
length | This is length, a member of class SSLexLexeme.
lexeme | This is lexeme, a member of class SSLexLexeme.
line | This is line, a member of class SSLexLexeme.
parseToken | 12/28/99 G. Krstic
setLength | This is setLength, a member of class SSLexLexeme.
setLexeme | This is setLexeme, a member of class SSLexLexeme.
setLine | This is setLine, a member of class SSLexLexeme.
setparseToken | 12/28/99 G. Krstic


SSLexLexeme.length Method

SSLexLexeme.length Method
SSLexLexeme Class Eco.Ocl.ParserCore Namespace See Also
Collapse All
C#
public int length();
Remarks

This is length, a member of class SSLexLexeme.

See Also
SSLexLexeme Class
Eco.Ocl.ParserCore Namespace


SSLexLexeme.lexeme Method

SSLexLexeme.lexeme Method
SSLexLexeme Class Eco.Ocl.ParserCore Namespace See Also
Collapse All
C#
public char[] lexeme();
Remarks

This is lexeme, a member of class SSLexLexeme.

See Also
SSLexLexeme Class
Eco.Ocl.ParserCore Namespace


SSLexLexeme.line Method

SSLexLexeme.line Method
SSLexLexeme Class Eco.Ocl.ParserCore Namespace See Also
Collapse All
C#
public int line();
Remarks

This is line, a member of class SSLexLexeme.

See Also
SSLexLexeme Class
Eco.Ocl.ParserCore Namespace


SSLexLexeme.parseToken Method

SSLexLexeme.parseToken Method
SSLexLexeme Class Eco.Ocl.ParserCore Namespace See Also
Collapse All
C#
public int parseToken();
Remarks

12/28/99 G. Krstic

See Also
SSLexLexeme Class
Eco.Ocl.ParserCore Namespace


SSLexLexeme.setLength Method

SSLexLexeme.setLength Method
SSLexLexeme Class Eco.Ocl.ParserCore Namespace See Also
Collapse All
C#
public void setLength(
    int q_length
);
Remarks

This is setLength, a member of class SSLexLexeme.

See Also
SSLexLexeme Class
Eco.Ocl.ParserCore Namespace


SSLexLexeme.setLexeme Method

SSLexLexeme.setLexeme Method
SSLexLexeme Class Eco.Ocl.ParserCore Namespace See Also
Collapse All
C#
public void setLexeme(
    char[] q_lexeme
);
Remarks

This is setLexeme, a member of class SSLexLexeme.

See Also
SSLexLexeme Class
Eco.Ocl.ParserCore Namespace


SSLexLexeme.setLine Method

SSLexLexeme.setLine Method
SSLexLexeme Class Eco.Ocl.ParserCore Namespace See Also
Collapse All
C#
public void setLine(
    int q_line
);
Remarks

This is setLine, a member of class SSLexLexeme.

See Also
SSLexLexeme Class
Eco.Ocl.ParserCore Namespace


SSLexLexeme.setparseToken Method

SSLexLexeme.setparseToken Method
SSLexLexeme Class Eco.Ocl.ParserCore Namespace See Also
Collapse All
C#
public void setparseToken(
    int q_parseToken
);
Remarks

12/28/99 G. Krstic

See Also
SSLexLexeme Class
Eco.Ocl.ParserCore Namespace


SSLexMark Class

SSLexMark Class
Inheritance Hierarchy See Also
Collapse All
C#
public class SSLexMark;
Remarks

This is class Eco.Ocl.ParserCore.SSLexMark.

Inheritance Hierarchy
Eco.Ocl.ParserCore.SSLexMark
File

SSLexMark.cs

See Also
Inheritance Hierarchy


SSLexMark.SSLexMark Constructor

SSLexMark.SSLexMark Constructor
SSLexMark Class Eco.Ocl.ParserCore Namespace See Also
Collapse All
C#
public SSLexMark(
    int q_line,
    int q_offset,
    int q_index
);
Remarks
  • UNUSED

public SSLexMark() {}

See Also
SSLexMark Class
Eco.Ocl.ParserCore Namespace


SSLexStringConsumer Class

SSLexStringConsumer Class
Inheritance Hierarchy See Also
Collapse All
C#
public class SSLexStringConsumer : SSLexConsumer;
Remarks

This is class Eco.Ocl.ParserCore.SSLexStringConsumer.

Inheritance Hierarchy
Eco.Ocl.ParserCore.SSLexConsumer
    Eco.Ocl.ParserCore.SSLexStringConsumer
File

SSLexStringConsumer.cs

See Also
Inheritance Hierarchy


SSLexStringConsumer.SSLexStringConsumer Constructor

SSLexStringConsumer.SSLexStringConsumer Constructor
SSLexStringConsumer Class Eco.Ocl.ParserCore Namespace See Also
Collapse All
C#
public SSLexStringConsumer(
    String q_string
);
Remarks

This is SSLexStringConsumer, a member of class SSLexStringConsumer.

See Also
SSLexStringConsumer Class
Eco.Ocl.ParserCore Namespace


SSLexStringConsumer Methods

SSLexStringConsumer Methods
Public Methods
Collapse All

The methods of the SSLexStringConsumer class are listed here.

Public Methods
Name | Description
getNext | This is getNext, a member of class SSLexStringConsumer.


SSLexStringConsumer.getNext Method

SSLexStringConsumer.getNext Method
SSLexStringConsumer Class Eco.Ocl.ParserCore Namespace See Also
Collapse All
C#
public override Boolean getNext();
Remarks

This is getNext, a member of class SSLexStringConsumer.

See Also
SSLexStringConsumer Class
Eco.Ocl.ParserCore Namespace


SSLexTable Class

SSLexTable Class
Inheritance Hierarchy See Also
Collapse All
C#
public class SSLexTable;
Remarks

This is class Eco.Ocl.ParserCore.SSLexTable.

Inheritance Hierarchy
Eco.Ocl.ParserCore.SSLexTable
    Eco.Ocl.ParserCore.BoldOclLexTable
File

SSLexTable.cs

See Also
Inheritance Hierarchy


SSLexTable.SSLexTable Constructor

SSLexTable.SSLexTable Constructor
SSLexTable Class Eco.Ocl.ParserCore Namespace See Also
Collapse All
C#
public SSLexTable();
Remarks

not used private int SSLexTableHeaderSize = 36; not used private int SSLexDfaTableHeaderSize = 40; not used private int SSLexDfaKeywordTableHeaderSize = 40; not used private int SSLexDfaClassTableHeaderSize = 12; not used private int SSLexDfaClassTableEntryHeaderSize = 8;

See Also
SSLexTable Class
Eco.Ocl.ParserCore Namespace


SSLexTable Fields

SSLexTable Fields
Public Fields
Collapse All

The fields of the SSLexTable class are listed here.

Public Fields
Name | Description
m_final | This is m_final, a member of class SSLexTable.
SSLexStateInvalid | This is SSLexStateInvalid, a member of class SSLexTable.


SSLexTable.m_final Field

SSLexTable.m_final Field
SSLexTable Class Eco.Ocl.ParserCore Namespace See Also
Collapse All
C#
public SSLexFinalState[] m_final;
Remarks

This is m_final, a member of class SSLexTable.

See Also
SSLexTable Class
Eco.Ocl.ParserCore Namespace


SSLexTable.SSLexStateInvalid Field

SSLexTable.SSLexStateInvalid Field
SSLexTable Class Eco.Ocl.ParserCore Namespace See Also
Collapse All
C#
public const int SSLexStateInvalid = -1;
Remarks

This is SSLexStateInvalid, a member of class SSLexTable.

See Also
SSLexTable Class
Eco.Ocl.ParserCore Namespace


SSLexTable Methods

SSLexTable Methods
Public Methods
Collapse All

The methods of the SSLexTable class are listed here.

Public Methods
Name | Description
convertInt | This is convertInt, a member of class SSLexTable.


SSLexTable.convertInt Method

SSLexTable.convertInt Method
SSLexTable Class Eco.Ocl.ParserCore Namespace See Also
Collapse All
C#
public int convertInt(
    byte[] b,
    int offset
);
Remarks

This is convertInt, a member of class SSLexTable.

See Also
SSLexTable Class
Eco.Ocl.ParserCore Namespace


SSLexTableHeader Class

SSLexTableHeader Class
Inheritance Hierarchy See Also
Collapse All
C#
public class SSLexTableHeader;
Remarks

This is class Eco.Ocl.ParserCore.SSLexTableHeader.

Inheritance Hierarchy
Eco.Ocl.ParserCore.SSLexTableHeader
File

SSLexTableHeader.cs

See Also
Inheritance Hierarchy


SSLexTableHeader Fields

SSLexTableHeader Fields
Public Fields
Collapse All

The fields of the SSLexTableHeader class are listed here.

Public Fields
Name | Description
reserved | This is reserved, a member of class SSLexTableHeader.
size | This is size, a member of class SSLexTableHeader.
type | This is type, a member of class SSLexTableHeader.


SSLexTableHeader.reserved Field

SSLexTableHeader.reserved Field
SSLexTableHeader Class Eco.Ocl.ParserCore Namespace See Also
Collapse All
C#
public int[] reserved;
Remarks

This is reserved, a member of class SSLexTableHeader.

See Also
SSLexTableHeader Class
Eco.Ocl.ParserCore Namespace


SSLexTableHeader.size Field

SSLexTableHeader.size Field
SSLexTableHeader Class Eco.Ocl.ParserCore Namespace See Also
Collapse All
C#
public int size;
Remarks

This is size, a member of class SSLexTableHeader.

See Also
SSLexTableHeader Class
Eco.Ocl.ParserCore Namespace


SSLexTableHeader.type Field

SSLexTableHeader.type Field
SSLexTableHeader Class Eco.Ocl.ParserCore Namespace See Also
Collapse All
C#
public int type;
Remarks

This is type, a member of class SSLexTableHeader.

See Also
SSLexTableHeader Class
Eco.Ocl.ParserCore Namespace


SSLexTableRow Class

SSLexTableRow Class
Inheritance Hierarchy See Also
Collapse All
C#
public class SSLexTableRow;
Remarks

This is class Eco.Ocl.ParserCore.SSLexTableRow.

Inheritance Hierarchy
Eco.Ocl.ParserCore.SSLexTableRow
File

SSLexSubtable.cs

See Also
Inheritance Hierarchy


SSLexTableRow.SSLexTableRow Constructor

SSLexTableRow.SSLexTableRow Constructor
SSLexTableRow Class Eco.Ocl.ParserCore Namespace See Also
Collapse All
C#
public SSLexTableRow(
    int[] q_row,
    int q_index
);
Remarks

This is SSLexTableRow, a member of class SSLexTableRow.

See Also
SSLexTableRow Class
Eco.Ocl.ParserCore Namespace


SSYacc Class

SSYacc Class
Inheritance Hierarchy See Also
Collapse All
C#
public class SSYacc;
Remarks

This is class Eco.Ocl.ParserCore.SSYacc.

Inheritance Hierarchy
Eco.Ocl.ParserCore.SSYacc
    Eco.Ocl.ParserCore.BoldOclYaccClass
File

SSYacc.cs

See Also
Inheritance Hierarchy


SSYacc.SSYacc Constructor

SSYacc.SSYacc Constructor
SSYacc Class Eco.Ocl.ParserCore Namespace See Also
Collapse All
C#
protected SSYacc(
    SSYaccTable q_table,
    SSLex q_lex
);
Remarks

This is SSYacc, a member of class SSYacc.

See Also
SSYacc Class
Eco.Ocl.ParserCore Namespace


SSYacc Fields

SSYacc Fields
Public Fields
Collapse All

The fields of the SSYacc class are listed here.

Public Fields
Name | Description
m_eofToken | This is m_eofToken, a member of class SSYacc.
m_errorToken | This is m_errorToken, a member of class SSYacc.
SSYaccActionAccept | This is SSYaccActionAccept, a member of class SSYacc.
SSYaccActionConflict | This is SSYaccActionConflict, a member of class SSYacc.
SSYaccActionError | This is SSYaccActionError, a member of class SSYacc.
SSYaccActionReduce | This is SSYaccActionReduce, a member of class SSYacc.
SSYaccActionShift | This is SSYaccActionShift, a member of class SSYacc.
SSYaccLexemeCacheMax | This is SSYaccLexemeCacheMax, a member of class SSYacc.


SSYacc.m_eofToken Field

SSYacc.m_eofToken Field
SSYacc Class Eco.Ocl.ParserCore Namespace See Also
Collapse All
C#
public const int m_eofToken = -1;
Remarks

This is m_eofToken, a member of class SSYacc.

See Also
SSYacc Class
Eco.Ocl.ParserCore Namespace


SSYacc.m_errorToken Field

SSYacc.m_errorToken Field
SSYacc Class Eco.Ocl.ParserCore Namespace See Also
Collapse All
C#
public const int m_errorToken = -2;
Remarks

This is m_errorToken, a member of class SSYacc.

See Also
SSYacc Class
Eco.Ocl.ParserCore Namespace


SSYacc.SSYaccActionAccept Field

SSYacc.SSYaccActionAccept Field
SSYacc Class Eco.Ocl.ParserCore Namespace See Also
Collapse All
C#
public const int SSYaccActionAccept = 3;
Remarks

This is SSYaccActionAccept, a member of class SSYacc.

See Also
SSYacc Class
Eco.Ocl.ParserCore Namespace


SSYacc.SSYaccActionConflict Field

SSYacc.SSYaccActionConflict Field
SSYacc Class Eco.Ocl.ParserCore Namespace See Also
Collapse All
C#
public const int SSYaccActionConflict = 4;
Remarks

This is SSYaccActionConflict, a member of class SSYacc.

See Also
SSYacc Class
Eco.Ocl.ParserCore Namespace


SSYacc.SSYaccActionError Field

SSYacc.SSYaccActionError Field
SSYacc Class Eco.Ocl.ParserCore Namespace See Also
Collapse All
C#
public const int SSYaccActionError = 1;
Remarks

This is SSYaccActionError, a member of class SSYacc.

See Also
SSYacc Class
Eco.Ocl.ParserCore Namespace


SSYacc.SSYaccActionReduce Field

SSYacc.SSYaccActionReduce Field
SSYacc Class Eco.Ocl.ParserCore Namespace See Also
Collapse All
C#
public const int SSYaccActionReduce = 2;
Remarks

This is SSYaccActionReduce, a member of class SSYacc.

See Also
SSYacc Class
Eco.Ocl.ParserCore Namespace


SSYacc.SSYaccActionShift Field

SSYacc.SSYaccActionShift Field
SSYacc Class Eco.Ocl.ParserCore Namespace See Also
Collapse All
C#
public const int SSYaccActionShift = 0;
Remarks

This is SSYaccActionShift, a member of class SSYacc.

See Also
SSYacc Class
Eco.Ocl.ParserCore Namespace


SSYacc.SSYaccLexemeCacheMax Field

SSYacc.SSYaccLexemeCacheMax Field
SSYacc Class Eco.Ocl.ParserCore Namespace See Also
Collapse All
C#
public const int SSYaccLexemeCacheMax = -1;
Remarks

This is SSYaccLexemeCacheMax, a member of class SSYacc.

See Also
SSYacc Class
Eco.Ocl.ParserCore Namespace


SSYacc Methods

SSYacc Methods
Protected Methods Public Methods
Collapse All

The methods of the SSYacc class are listed here.

Protected Methods
Name | Description
elementFromProduction | This is elementFromProduction, a member of class SSYacc.
Top
Public Methods
Name | Description
addSubTree | This is addSubTree, a member of class SSYacc.
error | This is error, a member of class SSYacc.
nextLexeme | This is nextLexeme, a member of class SSYacc.
parse | This is parse, a member of class SSYacc.
reduce | This is reduce, a member of class SSYacc.
setAbort | This is setAbort, a member of class SSYacc.
shift | This is shift, a member of class SSYacc.
stackElement | This is stackElement, a member of class SSYacc.
treeRoot | This is treeRoot, a member of class SSYacc.
wasAborted | This is wasAborted, a member of class SSYacc.
wasError | This is wasError, a member of class SSYacc.


SSYacc.addSubTree Method

SSYacc.addSubTree Method
SSYacc Class Eco.Ocl.ParserCore Namespace See Also
Collapse All
C#
public SSYaccStackElement addSubTree();
Remarks

This is addSubTree, a member of class SSYacc.

See Also
SSYacc Class
Eco.Ocl.ParserCore Namespace


SSYacc.elementFromProduction Method

SSYacc.elementFromProduction Method
SSYacc Class Eco.Ocl.ParserCore Namespace See Also
Collapse All
C#
protected SSYaccStackElement elementFromProduction(
    int q_index
);
Remarks

This is elementFromProduction, a member of class SSYacc.

See Also
SSYacc Class
Eco.Ocl.ParserCore Namespace


SSYacc.error Method

SSYacc.error Method
SSYacc Class Eco.Ocl.ParserCore Namespace See Also
Collapse All
C#
public virtual Boolean error(
    int q_state,
    SSLexLexeme q_look
);
Remarks

This is error, a member of class SSYacc.

See Also
SSYacc Class
Eco.Ocl.ParserCore Namespace


SSYacc.nextLexeme Method

SSYacc.nextLexeme Method
SSYacc Class Eco.Ocl.ParserCore Namespace See Also
Collapse All
C#
public virtual SSLexLexeme nextLexeme();
Remarks

This is nextLexeme, a member of class SSYacc.

See Also
SSYacc Class
Eco.Ocl.ParserCore Namespace


SSYacc.parse Method

SSYacc.parse Method
SSYacc Class Eco.Ocl.ParserCore Namespace See Also
Collapse All
C#
public Boolean parse();
Remarks

This is parse, a member of class SSYacc.

See Also
SSYacc Class
Eco.Ocl.ParserCore Namespace


SSYacc.reduce Method

SSYacc.reduce Method
SSYacc Class Eco.Ocl.ParserCore Namespace See Also
Collapse All
C#
public virtual SSYaccStackElement reduce(
    int q_prod,
    int q_length
);
Remarks

This is reduce, a member of class SSYacc.

See Also
SSYacc Class
Eco.Ocl.ParserCore Namespace


SSYacc.setAbort Method

SSYacc.setAbort Method
SSYacc Class Eco.Ocl.ParserCore Namespace See Also
Collapse All
C#
public void setAbort();
Remarks

This is setAbort, a member of class SSYacc.

See Also
SSYacc Class
Eco.Ocl.ParserCore Namespace


SSYacc.shift Method

SSYacc.shift Method
SSYacc Class Eco.Ocl.ParserCore Namespace See Also
Collapse All
C#
public virtual SSYaccStackElement shift(
    SSLexLexeme q_lexeme
);
Remarks

This is shift, a member of class SSYacc.

See Also
SSYacc Class
Eco.Ocl.ParserCore Namespace


SSYacc.stackElement Method

SSYacc.stackElement Method
SSYacc Class Eco.Ocl.ParserCore Namespace See Also
Collapse All
C#
public virtual SSYaccStackElement stackElement();
Remarks

This is stackElement, a member of class SSYacc.

See Also
SSYacc Class
Eco.Ocl.ParserCore Namespace


SSYacc.treeRoot Method

SSYacc.treeRoot Method
SSYacc Class Eco.Ocl.ParserCore Namespace See Also
Collapse All
C#
public SSYaccStackElement treeRoot();
Remarks

This is treeRoot, a member of class SSYacc.

See Also
SSYacc Class
Eco.Ocl.ParserCore Namespace


SSYacc.wasAborted Method

SSYacc.wasAborted Method
SSYacc Class Eco.Ocl.ParserCore Namespace See Also
Collapse All
C#
public Boolean wasAborted();
Remarks

This is wasAborted, a member of class SSYacc.

See Also
SSYacc Class
Eco.Ocl.ParserCore Namespace


SSYacc.wasError Method

SSYacc.wasError Method
SSYacc Class Eco.Ocl.ParserCore Namespace See Also
Collapse All
C#
public Boolean wasError();
Remarks

This is wasError, a member of class SSYacc.

See Also
SSYacc Class
Eco.Ocl.ParserCore Namespace


SSYacc Properties

SSYacc Properties
Public Properties
Collapse All

The properties of the SSYacc class are listed here.

Public Properties
Name | Description
Element | This is Element, a member of class SSYacc.


SSYacc.Element Property

SSYacc.Element Property
SSYacc Class Eco.Ocl.ParserCore Namespace See Also
Collapse All
C#
public SSYaccStackElement Element;
Remarks

This is Element, a member of class SSYacc.

See Also
SSYacc Class
Eco.Ocl.ParserCore Namespace


SSYaccCache Class

SSYaccCache Class
Inheritance Hierarchy See Also
Collapse All
C#
public class SSYaccCache : Queue<SSLexLexeme>;
Remarks

This is class Eco.Ocl.ParserCore.SSYaccCache.

Inheritance Hierarchy
Eco.Ocl.ParserCore.SSYaccCache
File

SSYaccCache.cs

See Also
Inheritance Hierarchy


SSYaccCache.SSYaccCache Constructor

SSYaccCache.SSYaccCache Constructor
SSYaccCache Class Eco.Ocl.ParserCore Namespace See Also
Collapse All
C#
public SSYaccCache();
Remarks

This is SSYaccCache, a member of class SSYaccCache.

See Also
SSYaccCache Class
Eco.Ocl.ParserCore Namespace


SSYaccStackElement Class

SSYaccStackElement Class
Inheritance Hierarchy See Also
Collapse All
C#
public class SSYaccStackElement;
Remarks

This is class Eco.Ocl.ParserCore.SSYaccStackElement.

Inheritance Hierarchy
Eco.Ocl.ParserCore.SSYaccStackElement
    Eco.Ocl.ParserCore.OclStackElement
File

SSYaccStackElement.cs

See Also
Inheritance Hierarchy


SSYaccStackElement.SSYaccStackElement Constructor

SSYaccStackElement.SSYaccStackElement Constructor
SSYaccStackElement Class Eco.Ocl.ParserCore Namespace See Also
Collapse All
C#
public SSYaccStackElement();
Remarks

This is SSYaccStackElement, a member of class SSYaccStackElement.

See Also
SSYaccStackElement Class
Eco.Ocl.ParserCore Namespace


SSYaccStackElement Methods

SSYaccStackElement Methods
Public Methods
Collapse All

The methods of the SSYaccStackElement class are listed here.

Public Methods
Name | Description
getSubTree | This is getSubTree, a member of class SSYaccStackElement.
getSubTreeSize | This is getSubTreeSize, a member of class SSYaccStackElement.
lexeme | This is lexeme, a member of class SSYaccStackElement.


SSYaccStackElement.getSubTree Method

SSYaccStackElement.getSubTree Method
SSYaccStackElement Class Eco.Ocl.ParserCore Namespace See Also
Collapse All
C#
public SSYaccStackElement getSubTree(
    int q_index
);
Remarks

This is getSubTree, a member of class SSYaccStackElement.

See Also
SSYaccStackElement Class
Eco.Ocl.ParserCore Namespace


SSYaccStackElement.getSubTreeSize Method

SSYaccStackElement.getSubTreeSize Method
SSYaccStackElement Class Eco.Ocl.ParserCore Namespace See Also
Collapse All
C#
public int getSubTreeSize();
Remarks

This is getSubTreeSize, a member of class SSYaccStackElement.

See Also
SSYaccStackElement Class
Eco.Ocl.ParserCore Namespace


SSYaccStackElement.lexeme Method

SSYaccStackElement.lexeme Method
SSYaccStackElement Class Eco.Ocl.ParserCore Namespace See Also
Collapse All
C#
public SSLexLexeme lexeme();
Remarks

This is lexeme, a member of class SSYaccStackElement.

See Also
SSYaccStackElement Class
Eco.Ocl.ParserCore Namespace


SSYaccTable Class

SSYaccTable Class
Inheritance Hierarchy See Also
Collapse All
C#
public class SSYaccTable;
Remarks

This is class Eco.Ocl.ParserCore.SSYaccTable.

Inheritance Hierarchy
Eco.Ocl.ParserCore.SSYaccTable
    Eco.Ocl.ParserCore.BoldOclYaccTable
File

SSYaccTable.cs

See Also
Inheritance Hierarchy


SSYaccTable.SSYaccTable Constructor

SSYaccTable.SSYaccTable Constructor
SSYaccTable Class Eco.Ocl.ParserCore Namespace See Also
Collapse All
C#
public SSYaccTable();
Remarks

not used private int SSYaccTableHeaderSize = 20; not used private int SSYaccTableEntrySize = 8; not used private int SSYaccTableRowSize = 12;

See Also
SSYaccTable Class
Eco.Ocl.ParserCore Namespace


SSYaccTable Fields

SSYaccTable Fields
Protected Fields
Collapse All

The fields of the SSYaccTable class are listed here.

Protected Fields
Name | Description
m_rows | This is m_rows, a member of class SSYaccTable.


SSYaccTable.m_rows Field

SSYaccTable.m_rows Field
SSYaccTable Class Eco.Ocl.ParserCore Namespace See Also
Collapse All
C#
protected SSYaccTableRow[] m_rows;
Remarks

This is m_rows, a member of class SSYaccTable.

See Also
SSYaccTable Class
Eco.Ocl.ParserCore Namespace


SSYaccTable Methods

SSYaccTable Methods
Public Methods
Collapse All

The methods of the SSYaccTable class are listed here.

Public Methods
Name | Description
convertInt | ************* Unused constructor public SSYaccTable( String q_file) { FileStream z_llr = File.Open( q_file, FileMode.Open, FileAccess.Read, FileShare.Read); int z_len = ( int) z_llr.Length; byte[] z_b = new byte[ z_len]; z_len = z_llr.Read( z_b, 0, z_len); SSYaccTableHeader z_yaccHeader = new SSYaccTableHeader(); z_yaccHeader.type = convertInt( z_b, 0); z_yaccHeader.prodOrLar = convertInt( z_b, 4); z_yaccHeader.numRows = convertInt( z_b, 8); z_yaccHeader.rowOffset = convertInt( z_b, 12); z_yaccHeader.prodOffset = convertInt( z_b, 16); //Initialize production array int z_numProds = z_yaccHeader.numProds(); m_prods = new SSYaccTableProd[ z_numProds]; int z_prodIndex = z_yaccHeader.prodOffset; for ( int i = 0; i < z_numProds; i++) { int z_prodSize = convertInt( z_b, z_prodIndex);... more


SSYaccTable.convertInt Method

SSYaccTable.convertInt Method
SSYaccTable Class Eco.Ocl.ParserCore Namespace See Also
Collapse All
C#
public int convertInt(
    byte[] b,
    int offset
);
Remarks

************* Unused constructor public SSYaccTable( String q_file) { FileStream z_llr = File.Open( q_file, FileMode.Open, FileAccess.Read, FileShare.Read); int z_len = ( int) z_llr.Length; byte[] z_b = new byte[ z_len]; z_len = z_llr.Read( z_b, 0, z_len); SSYaccTableHeader z_yaccHeader = new SSYaccTableHeader(); z_yaccHeader.type = convertInt( z_b, 0); z_yaccHeader.prodOrLar = convertInt( z_b, 4); z_yaccHeader.numRows = convertInt( z_b, 8); z_yaccHeader.rowOffset = convertInt( z_b, 12); z_yaccHeader.prodOffset = convertInt( z_b, 16); //Initialize production array int z_numProds = z_yaccHeader.numProds(); m_prods = new SSYaccTableProd[ z_numProds]; int z_prodIndex = z_yaccHeader.prodOffset; for ( int i = 0; i < z_numProds; i++) { int z_prodSize = convertInt( z_b, z_prodIndex); int z_prodLeftside = convertInt( z_b, z_prodIndex + 4); m_prods[ i] = new SSYaccTableProd( z_prodSize, z_prodLeftside); z_prodIndex += 8; } //Initialize rows m_rows = new SSYaccTableRow[ z_yaccHeader.numRows]; int z_rowIndex = z_yaccHeader.rowOffset; for ( int i = 0; i < z_yaccHeader.numRows; i++) { int z_flags = convertInt( z_b, z_rowIndex); int z_goto = convertInt( z_b, z_rowIndex + 4); int z_action = convertInt( z_b, z_rowIndex + 8); m_rows[ i] = new SSYaccTableRow( z_flags, z_goto, z_action, z_b, z_rowIndex + 12); z_rowIndex += SSYaccTableRowSize + SSYaccTableEntrySize * m_rows[ i].numEntries();

See Also
SSYaccTable Class
Eco.Ocl.ParserCore Namespace


SSYaccTableHeader Class

SSYaccTableHeader Class
Inheritance Hierarchy See Also
Collapse All
C#
public class SSYaccTableHeader;
Remarks

This is class Eco.Ocl.ParserCore.SSYaccTableHeader.

Inheritance Hierarchy
Eco.Ocl.ParserCore.SSYaccTableHeader
File

SSYaccTableHeader.cs

See Also
Inheritance Hierarchy


SSYaccTableHeader Fields

SSYaccTableHeader Fields
Public Fields
Collapse All

The fields of the SSYaccTableHeader class are listed here.

Public Fields
Name | Description
numRows | This is numRows, a member of class SSYaccTableHeader.
prodOffset | This is prodOffset, a member of class SSYaccTableHeader.
rowOffset | This is rowOffset, a member of class SSYaccTableHeader.
type | This is type, a member of class SSYaccTableHeader.


SSYaccTableHeader.numRows Field

SSYaccTableHeader.numRows Field
SSYaccTableHeader Class Eco.Ocl.ParserCore Namespace See Also
Collapse All
C#
public int numRows;
Remarks

This is numRows, a member of class SSYaccTableHeader.

See Also
SSYaccTableHeader Class
Eco.Ocl.ParserCore Namespace


SSYaccTableHeader.prodOffset Field

SSYaccTableHeader.prodOffset Field
SSYaccTableHeader Class Eco.Ocl.ParserCore Namespace See Also
Collapse All
C#
public int prodOffset;
Remarks

This is prodOffset, a member of class SSYaccTableHeader.

See Also
SSYaccTableHeader Class
Eco.Ocl.ParserCore Namespace


SSYaccTableHeader.rowOffset Field

SSYaccTableHeader.rowOffset Field
SSYaccTableHeader Class Eco.Ocl.ParserCore Namespace See Also
Collapse All
C#
public int rowOffset;
Remarks

This is rowOffset, a member of class SSYaccTableHeader.

See Also
SSYaccTableHeader Class
Eco.Ocl.ParserCore Namespace


SSYaccTableHeader.type Field

SSYaccTableHeader.type Field
SSYaccTableHeader Class Eco.Ocl.ParserCore Namespace See Also
Collapse All
C#
public int type;
Remarks

This is type, a member of class SSYaccTableHeader.

See Also
SSYaccTableHeader Class
Eco.Ocl.ParserCore Namespace


SSYaccTableHeader Methods

SSYaccTableHeader Methods
Public Methods
Collapse All

The methods of the SSYaccTableHeader class are listed here.

Public Methods
Name | Description
numLars | This is numLars, a member of class SSYaccTableHeader.
numProds | This is numProds, a member of class SSYaccTableHeader.


SSYaccTableHeader.numLars Method

SSYaccTableHeader.numLars Method
SSYaccTableHeader Class Eco.Ocl.ParserCore Namespace See Also
Collapse All
C#
public int numLars();
Remarks

This is numLars, a member of class SSYaccTableHeader.

See Also
SSYaccTableHeader Class
Eco.Ocl.ParserCore Namespace


SSYaccTableHeader.numProds Method

SSYaccTableHeader.numProds Method
SSYaccTableHeader Class Eco.Ocl.ParserCore Namespace See Also
Collapse All
C#
public int numProds();
Remarks

This is numProds, a member of class SSYaccTableHeader.

See Also
SSYaccTableHeader Class
Eco.Ocl.ParserCore Namespace


SSYaccTableProd Class

SSYaccTableProd Class
Inheritance Hierarchy See Also
Collapse All
C#
public class SSYaccTableProd;
Remarks

This is class Eco.Ocl.ParserCore.SSYaccTableProd.

Inheritance Hierarchy
Eco.Ocl.ParserCore.SSYaccTableProd
File

SSYaccTableProd.cs

See Also
Inheritance Hierarchy


SSYaccTableProd.SSYaccTableProd Constructor

SSYaccTableProd.SSYaccTableProd Constructor
SSYaccTableProd Class Eco.Ocl.ParserCore Namespace See Also
Collapse All
C#
public SSYaccTableProd(
    int q_size,
    int q_leftside
);
Remarks

This is SSYaccTableProd, a member of class SSYaccTableProd.

See Also
SSYaccTableProd Class
Eco.Ocl.ParserCore Namespace


SSYaccTableRow Class

SSYaccTableRow Class
Inheritance Hierarchy See Also
Collapse All
C#
public class SSYaccTableRow;
Remarks

This is class Eco.Ocl.ParserCore.SSYaccTableRow.

Inheritance Hierarchy
Eco.Ocl.ParserCore.SSYaccTableRow
File

SSYaccTableRow.cs

See Also
Inheritance Hierarchy


SSYaccTableRow.SSYaccTableRow Constructor

SSYaccTableRow.SSYaccTableRow Constructor
SSYaccTableRow Class Eco.Ocl.ParserCore Namespace See Also
Collapse All
C#
public SSYaccTableRow(
    int[] q_data,
    int q_index
);
Remarks

This is SSYaccTableRow, a member of class SSYaccTableRow.

See Also
SSYaccTableRow Class
Eco.Ocl.ParserCore Namespace


SSYaccTableRow Fields

SSYaccTableRow Fields
Public Fields
Collapse All

The fields of the SSYaccTableRow class are listed here.

Public Fields
Name | Description
m_flags | This is m_flags, a member of class SSYaccTableRow.


SSYaccTableRow.m_flags Field

SSYaccTableRow.m_flags Field
SSYaccTableRow Class Eco.Ocl.ParserCore Namespace See Also
Collapse All
C#
public int m_flags;
Remarks

This is m_flags, a member of class SSYaccTableRow.

See Also
SSYaccTableRow Class
Eco.Ocl.ParserCore Namespace


Eco.Ocl.ParserCore.CollectionKind Enumeration

Eco.Ocl.ParserCore.CollectionKind Enumeration
C#
public enum CollectionKind {
  Set,
  Bag,
  Sequence
}
Remarks

This is record Eco.Ocl.ParserCore.CollectionKind.

File

OclParserCoreInterfaces.cs


Eco.Ocl.Support Namespace

Eco.Ocl.Support Namespace
Classes Enumerations Interfaces
Collapse All

This is namespace Eco.Ocl.Support.

Classes
Name
Description
AbstractOclInstanceMethod
This is class Eco.Ocl.Support.AbstractOclInstanceMethod.
AbstractTimerbasedOperation
This is class Eco.Ocl.Support.AbstractTimerbasedOperation.
At0
this class implements the operation "at0" in Ocl. It takes a position in the list as a 0-based index.
DateTimeDate
public class DateTimeNow: OclOperationBase { public override void Evaluate(IOclOperationParameters oclParameters) { if (oclParameters == null) throw new ArgumentNullException("oclParameters"); oclParameters.Result.SetOwnedElement(Support.CreateNewConstant(ResultType, DateTime.Now)); }
protected override void Init() { IOclType[] oclParameters = new IOclType[1]; oclParameters[0] = Support.DateTimeType; InternalInit("now", oclParameters, Support.DateTimeType); IsTypeOperation = true;
DateTimeDateWithSubscription
This is class Eco.Ocl.Support.DateTimeDateWithSubscription.
DateTimeNowWithSubscription
This is class Eco.Ocl.Support.DateTimeNowWithSubscription.
DateTimeTime
This is class Eco.Ocl.Support.DateTimeTime.
DateTimeTimeWithSubscription
This is class Eco.Ocl.Support.DateTimeTimeWithSubscription.
EcoOclOperationAttribute
This is class Eco.Ocl.Support.EcoOclOperationAttribute.
EcoOclOperationHelpAttribute
This is class Eco.Ocl.Support.EcoOclOperationHelpAttribute.
EcoOclOperationResourcedHelpAttribute
This is class Eco.Ocl.Support.EcoOclOperationResourcedHelpAttribute.
IndexOf0
this class implements the operation "indexOf0" in Ocl. It returns the position of the element as a 0-based index.
OclAssign
This is class Eco.Ocl.Support.OclAssign.
OclConstructorMethod
This is class Eco.Ocl.Support.OclConstructorMethod.
OclInstanceField
This is class Eco.Ocl.Support.OclInstanceField.
OclInstanceMethod
This is class Eco.Ocl.Support.OclInstanceMethod.
OclMethod
This is class Eco.Ocl.Support.OclMethod.
OclMethodBase
This is class Eco.Ocl.Support.OclMethodBase.
OclMethodInstaller
This is class Eco.Ocl.Support.OclMethodInstaller.
OclOperationBase
This is a suitable base class for Ocl operations. Subclass and override the abstract Init and Evaluate methods. in the Init-method, you should call the InternalInit with a suiteable set of parameters.
OclPreconditionQuery
This is class Eco.Ocl.Support.OclPreconditionQuery.
OclPsStandardOperations
This is class Eco.Ocl.Support.OclPsStandardOperations.
OclStandardOperations
This is class Eco.Ocl.Support.OclStandardOperations.
OclStaticInstanceMethod
This is class Eco.Ocl.Support.OclStaticInstanceMethod.
OclTrigger
This is class Eco.Ocl.Support.OclTrigger.
OclTriggerQuery
This is class Eco.Ocl.Support.OclTriggerQuery.
OclTypeMethod
Th is class can execute arbitrary methods in ocl
OclTypeMethodInstaller
This is class Eco.Ocl.Support.OclTypeMethodInstaller.
ProxyElement
This is class Eco.Ocl.Support.ProxyElement.
SortElement
This is class Eco.Ocl.Support.SortElement.
TimerbasedDateTimeOclOperations
This is class Eco.Ocl.Support.TimerbasedDateTimeOclOperations.
TimerSubscriber
This is class Eco.Ocl.Support.TimerSubscriber.
TimeSpanSum
public class DateTimeSubtraction: OclOperationBase { public override void Evaluate(IOclOperationParameters oclParameters) { if (oclParameters == null) throw new ArgumentNullException("oclParameters"); // Unknown datetime values will default to "now" DateTime dt1 = DateTime.Now; DateTime dt2 = dt1; TimeSpan ts = TimeSpan.Zero; object o = Support.ConvertElement(FormalParameters[0], oclParameters.Values[0].Element); if (o != null) dt1 = (DateTime)o; o = Support.ConvertElement(FormalParameters[1], oclParameters.Values[1].Element); if (o != null) dt2 = (DateTime)o; ts = dt1.Subtract(dt2); oclParameters.Result.SetOwnedElement(Support.CreateNewConstant(ResultType, ts)); }
protected override void Init() { IOclType[] oclParameters = new IOclType[2]; oclParameters[0] = Support.DateTimeType; oclParameters[1] = Support.DateTimeType; InternalInit("-", oclParameters, Support.TimeSpanType);
Top
Enumerations
Name | Description
OclMethodsFilter | This is record Eco.Ocl.Support.OclMethodsFilter.
OclResultTypeDeduceMethod | This is record Eco.Ocl.Support.OclResultTypeDeduceMethod.
OclSortDirection | This is record Eco.Ocl.Support.OclSortDirection.
Top
Interfaces
Name | Description
IOclNamedEnumLiteral | This is class Eco.Ocl.Support.IOclNamedEnumLiteral.
IOclOperation | This interface is implemented by all operations that is installed in the Ocl evaluator (or Eco Action Language executor.
IOclOperationParameters | This is class Eco.Ocl.Support.IOclOperationParameters.
IOclOperationSupport | This is class Eco.Ocl.Support.IOclOperationSupport.
IOclType | This is class Eco.Ocl.Support.IOclType.
IOclTypeFactory | This is class Eco.Ocl.Support.IOclTypeFactory.
IOclValue | This is class Eco.Ocl.Support.IOclValue.


AbstractOclInstanceMethod Class

AbstractOclInstanceMethod Class
Inheritance Hierarchy See Also
Collapse All
C#
public abstract class AbstractOclInstanceMethod : OclTypeMethod;
Remarks

This is class Eco.Ocl.Support.AbstractOclInstanceMethod.

Inheritance Hierarchy
Eco.Ocl.Support.IOclOperation
    Eco.Ocl.Support.OclOperationBase
        Eco.Ocl.Support.OclTypeMethod
            Eco.Ocl.Support.AbstractOclInstanceMethod
                Eco.Ocl.Support.OclInstanceMethod
                Eco.Ocl.Support.OclStaticInstanceMethod
File

OclTypeMethods.cs

See Also
Inheritance Hierarchy


AbstractOclInstanceMethod.AbstractOclInstanceMethod Constructor

AbstractOclInstanceMethod.AbstractOclInstanceMethod Constructor
AbstractOclInstanceMethod Class Eco.Ocl.Support Namespace See Also
Collapse All
C#
public AbstractOclInstanceMethod(
    string name,
    MethodInfo mi,
    IClassifier[] ecoParameters,
    IClassifier returnType,
    bool isProperty,
    bool isInfix
);
Remarks

This is AbstractOclInstanceMethod, a member of class AbstractOclInstanceMethod.

See Also
AbstractOclInstanceMethod Class
Eco.Ocl.Support Namespace


AbstractOclInstanceMethod Methods

AbstractOclInstanceMethod Methods
Protected Methods
Collapse All

The methods of the AbstractOclInstanceMethod class are listed here.

Protected Methods
Name | Description
GetClrParameterType | This is GetClrParameterType, a member of class AbstractOclInstanceMethod.
Init | This is Init, a member of class AbstractOclInstanceMethod.


AbstractOclInstanceMethod.GetClrParameterType Method

AbstractOclInstanceMethod.GetClrParameterType Method
AbstractOclInstanceMethod Class Eco.Ocl.Support Namespace See Also
Collapse All
C#
protected override Type GetClrParameterType(
    int index
);
Remarks

This is GetClrParameterType, a member of class AbstractOclInstanceMethod.

See Also
AbstractOclInstanceMethod Class
Eco.Ocl.Support Namespace


AbstractOclInstanceMethod.Init Method

AbstractOclInstanceMethod.Init Method
AbstractOclInstanceMethod Class Eco.Ocl.Support Namespace See Also
Collapse All
C#
protected override void Init();
Remarks

This is Init, a member of class AbstractOclInstanceMethod.

See Also
AbstractOclInstanceMethod Class
Eco.Ocl.Support Namespace


AbstractOclInstanceMethod Properties

AbstractOclInstanceMethod Properties
Public Properties
Collapse All

The properties of the AbstractOclInstanceMethod class are listed here.

Public Properties
Name | Description
IsProperty | This is IsProperty, a member of class AbstractOclInstanceMethod.
MethodInfo | This is MethodInfo, a member of class AbstractOclInstanceMethod.


AbstractOclInstanceMethod.IsProperty Property

AbstractOclInstanceMethod.IsProperty Property
AbstractOclInstanceMethod Class Eco.Ocl.Support Namespace See Also
Collapse All
C#
public bool IsProperty;
Remarks

This is IsProperty, a member of class AbstractOclInstanceMethod.

See Also
AbstractOclInstanceMethod Class
Eco.Ocl.Support Namespace


AbstractOclInstanceMethod.MethodInfo Property

AbstractOclInstanceMethod.MethodInfo Property
AbstractOclInstanceMethod Class Eco.Ocl.Support Namespace See Also
Collapse All
C#
public MethodInfo MethodInfo;
Remarks

This is MethodInfo, a member of class AbstractOclInstanceMethod.

See Also
AbstractOclInstanceMethod Class
Eco.Ocl.Support Namespace


AbstractTimerbasedOperation Class

AbstractTimerbasedOperation Class
Inheritance Hierarchy See Also
Collapse All
C#
public abstract class AbstractTimerbasedOperation : OclOperationBase;
Remarks

This is class Eco.Ocl.Support.AbstractTimerbasedOperation.

Inheritance Hierarchy
Eco.Ocl.Support.IOclOperation
    Eco.Ocl.Support.OclOperationBase
        Eco.Ocl.Support.AbstractTimerbasedOperation
            Eco.Ocl.Support.DateTimeDateWithSubscription
            Eco.Ocl.Support.DateTimeNowWithSubscription
            Eco.Ocl.Support.DateTimeTimeWithSubscription
File

TimerbasedDateTimeOclOperations.cs

See Also
Inheritance Hierarchy


AbstractTimerbasedOperation Methods

AbstractTimerbasedOperation Methods
Protected Methods
Collapse All

The methods of the AbstractTimerbasedOperation class are listed here.

Protected Methods
Name | Description
Init | This is Init, a member of class AbstractTimerbasedOperation.
Subscribe | This is Subscribe, a member of class AbstractTimerbasedOperation.


AbstractTimerbasedOperation.Init Method

AbstractTimerbasedOperation.Init Method
AbstractTimerbasedOperation Class Eco.Ocl.Support Namespace See Also
Collapse All
C#
protected void Init(
    string name,
    IOclType returnType
);
Remarks

This is Init, a member of class AbstractTimerbasedOperation.

See Also
AbstractTimerbasedOperation Class
Eco.Ocl.Support Namespace


AbstractTimerbasedOperation.Subscribe Method

AbstractTimerbasedOperation.Subscribe Method
AbstractTimerbasedOperation Class Eco.Ocl.Support Namespace See Also
Collapse All
C#
protected void Subscribe(
    IOclOperationParameters oclParameters
);
Remarks

This is Subscribe, a member of class AbstractTimerbasedOperation.

See Also
AbstractTimerbasedOperation Class
Eco.Ocl.Support Namespace


At0 Class

At0 Class
Example Inheritance Hierarchy See Also
Collapse All

this class implements the operation "at0" in Ocl. It takes a position in the list as a 0-based index.

C#
public class At0 : OclOperationBase;
Example

aPerson.ownedBuildings->at0(3) To install in the EcoSpace, add the following attribute: [Eco.Ocl.Support.EcoOclOperation(typeof(Eco.Ocl.Support.At0), true)]

Inheritance Hierarchy
Eco.Ocl.Support.IOclOperation
    Eco.Ocl.Support.OclOperationBase
        Eco.Ocl.Support.At0
File

OclIndexOf0.cs

See Also
Example
Inheritance Hierarchy


At0 Methods

At0 Methods
Protected Methods Public Methods
Collapse All

The methods of the At0 class are listed here.

Protected Methods
Name | Description
Init | This is Init, a member of class At0.
Top
Public Methods
Name | Description
Evaluate | This method performs the actual evaluation (/execution) of the operation
InstallOperation | This is InstallOperation, a member of class At0.


At0.Evaluate Method

At0.Evaluate Method
At0 Class Eco.Ocl.Support Namespace See Also
Collapse All

This method performs the actual evaluation (/execution) of the operation

C#
public override void Evaluate(
    IOclOperationParameters oclParameters
);
See Also
At0 Class
Eco.Ocl.Support Namespace


At0.Init Method

At0.Init Method
At0 Class Eco.Ocl.Support Namespace See Also
Collapse All
C#
protected override void Init();
Remarks

This is Init, a member of class At0.

See Also
At0 Class
Eco.Ocl.Support Namespace


At0.InstallOperation Method

At0.InstallOperation Method
At0 Class Eco.Ocl.Support Namespace See Also
Collapse All
C#
public static void InstallOperation(
    IEcoServiceProvider serviceProvider
);
Remarks

This is InstallOperation, a member of class At0.

See Also
At0 Class
Eco.Ocl.Support Namespace


DateTimeDate Class

DateTimeDate Class
Inheritance Hierarchy See Also
Collapse All
C#
public class DateTimeDate : OclOperationBase;
Remarks

public class DateTimeNow: OclOperationBase { public override void Evaluate(IOclOperationParameters oclParameters) { if (oclParameters == null) throw new ArgumentNullException("oclParameters"); oclParameters.Result.SetOwnedElement(Support.CreateNewConstant(ResultType, DateTime.Now)); }

protected override void Init() { IOclType[] oclParameters = new IOclType[1]; oclParameters[0] = Support.DateTimeType; InternalInit("now", oclParameters, Support.DateTimeType); IsTypeOperation = true;

Inheritance Hierarchy
Eco.Ocl.Support.IOclOperation
    Eco.Ocl.Support.OclOperationBase
        Eco.Ocl.Support.DateTimeDate
File

DateTimeOclOperations.cs

See Also
Inheritance Hierarchy


DateTimeDate Methods

DateTimeDate Methods
Protected Methods Public Methods
Collapse All

The methods of the DateTimeDate class are listed here.

Protected Methods
Name | Description
Init | This is Init, a member of class DateTimeDate.
Top
Public Methods
Name | Description
Evaluate | This method performs the actual evaluation (/execution) of the operation


DateTimeDate.Evaluate Method

DateTimeDate.Evaluate Method
DateTimeDate Class Eco.Ocl.Support Namespace See Also
Collapse All

This method performs the actual evaluation (/execution) of the operation

C#
public override void Evaluate(
    IOclOperationParameters oclParameters
);
See Also
DateTimeDate Class
Eco.Ocl.Support Namespace


DateTimeDate.Init Method

DateTimeDate.Init Method
DateTimeDate Class Eco.Ocl.Support Namespace See Also
Collapse All
C#
protected override void Init();
Remarks

This is Init, a member of class DateTimeDate.

See Also
DateTimeDate Class
Eco.Ocl.Support Namespace


DateTimeDateWithSubscription Class

DateTimeDateWithSubscription Class
Inheritance Hierarchy See Also
Collapse All
C#
public class DateTimeDateWithSubscription : AbstractTimerbasedOperation;
Remarks

This is class Eco.Ocl.Support.DateTimeDateWithSubscription.

Inheritance Hierarchy
Eco.Ocl.Support.IOclOperation
    Eco.Ocl.Support.OclOperationBase
        Eco.Ocl.Support.AbstractTimerbasedOperation
            Eco.Ocl.Support.DateTimeDateWithSubscription
File

TimerbasedDateTimeOclOperations.cs

See Also
Inheritance Hierarchy


DateTimeDateWithSubscription Methods

DateTimeDateWithSubscription Methods
Protected Methods Public Methods
Collapse All

The methods of the DateTimeDateWithSubscription class are listed here.

Protected Methods
Name | Description
Init | This is Init, a member of class DateTimeDateWithSubscription.
Top
Public Methods
Name | Description
Evaluate | This method performs the actual evaluation (/execution) of the operation


DateTimeDateWithSubscription.Evaluate Method

DateTimeDateWithSubscription.Evaluate Method
DateTimeDateWithSubscription Class Eco.Ocl.Support Namespace See Also
Collapse All

This method performs the actual evaluation (/execution) of the operation

C#
public override void Evaluate(
    IOclOperationParameters oclParameters
);
See Also
DateTimeDateWithSubscription Class
Eco.Ocl.Support Namespace


DateTimeDateWithSubscription.Init Method

DateTimeDateWithSubscription.Init Method
DateTimeDateWithSubscription Class Eco.Ocl.Support Namespace See Also
Collapse All
C#
protected override void Init();
Remarks

This is Init, a member of class DateTimeDateWithSubscription.

See Also
DateTimeDateWithSubscription Class
Eco.Ocl.Support Namespace


DateTimeNowWithSubscription Class

DateTimeNowWithSubscription Class
Inheritance Hierarchy See Also
Collapse All
C#
public class DateTimeNowWithSubscription : AbstractTimerbasedOperation;
Remarks

This is class Eco.Ocl.Support.DateTimeNowWithSubscription.

Inheritance Hierarchy
Eco.Ocl.Support.IOclOperation
    Eco.Ocl.Support.OclOperationBase
        Eco.Ocl.Support.AbstractTimerbasedOperation
            Eco.Ocl.Support.DateTimeNowWithSubscription
File

TimerbasedDateTimeOclOperations.cs

See Also
Inheritance Hierarchy


DateTimeNowWithSubscription Methods

DateTimeNowWithSubscription Methods
Protected Methods Public Methods
Collapse All

The methods of the DateTimeNowWithSubscription class are listed here.

Protected Methods
Name | Description
Init | This is Init, a member of class DateTimeNowWithSubscription.
Top
Public Methods
Name | Description
Evaluate | This method performs the actual evaluation (/execution) of the operation


DateTimeNowWithSubscription.Evaluate Method

DateTimeNowWithSubscription.Evaluate Method
DateTimeNowWithSubscription Class Eco.Ocl.Support Namespace See Also
Collapse All

This method performs the actual evaluation (/execution) of the operation

C#
public override void Evaluate(
    IOclOperationParameters oclParameters
);
See Also
DateTimeNowWithSubscription Class
Eco.Ocl.Support Namespace


DateTimeNowWithSubscription.Init Method

DateTimeNowWithSubscription.Init Method
DateTimeNowWithSubscription Class Eco.Ocl.Support Namespace See Also
Collapse All
C#
protected override void Init();
Remarks

This is Init, a member of class DateTimeNowWithSubscription.

See Also
DateTimeNowWithSubscription Class
Eco.Ocl.Support Namespace


DateTimeTime Class

DateTimeTime Class
Inheritance Hierarchy See Also
Collapse All
C#
public class DateTimeTime : OclOperationBase;
Remarks

This is class Eco.Ocl.Support.DateTimeTime.

Inheritance Hierarchy
Eco.Ocl.Support.IOclOperation
    Eco.Ocl.Support.OclOperationBase
        Eco.Ocl.Support.DateTimeTime
File

DateTimeOclOperations.cs

See Also
Inheritance Hierarchy


DateTimeTime Methods

DateTimeTime Methods
Protected Methods Public Methods
Collapse All

The methods of the DateTimeTime class are listed here.

Protected Methods
Name | Description
Init | This is Init, a member of class DateTimeTime.
Top
Public Methods
Name | Description
Evaluate | This method performs the actual evaluation (/execution) of the operation


DateTimeTime.Evaluate Method

DateTimeTime.Evaluate Method
DateTimeTime Class Eco.Ocl.Support Namespace See Also
Collapse All

This method performs the actual evaluation (/execution) of the operation

C#
public override void Evaluate(
    IOclOperationParameters oclParameters
);
See Also
DateTimeTime Class
Eco.Ocl.Support Namespace


DateTimeTime.Init Method

DateTimeTime.Init Method
DateTimeTime Class Eco.Ocl.Support Namespace See Also
Collapse All
C#
protected override void Init();
Remarks

This is Init, a member of class DateTimeTime.

See Also
DateTimeTime Class
Eco.Ocl.Support Namespace


DateTimeTimeWithSubscription Class

DateTimeTimeWithSubscription Class
Inheritance Hierarchy See Also
Collapse All
C#
public class DateTimeTimeWithSubscription : AbstractTimerbasedOperation;
Remarks

This is class Eco.Ocl.Support.DateTimeTimeWithSubscription.

Inheritance Hierarchy
Eco.Ocl.Support.IOclOperation
    Eco.Ocl.Support.OclOperationBase
        Eco.Ocl.Support.AbstractTimerbasedOperation
            Eco.Ocl.Support.DateTimeTimeWithSubscription
File

TimerbasedDateTimeOclOperations.cs

See Also
Inheritance Hierarchy


DateTimeTimeWithSubscription Methods

DateTimeTimeWithSubscription Methods
Protected Methods Public Methods
Collapse All

The methods of the DateTimeTimeWithSubscription class are listed here.

Protected Methods
Name | Description
Init | This is Init, a member of class DateTimeTimeWithSubscription.
Top
Public Methods
Name | Description
Evaluate | This method performs the actual evaluation (/execution) of the operation


DateTimeTimeWithSubscription.Evaluate Method

DateTimeTimeWithSubscription.Evaluate Method
DateTimeTimeWithSubscription Class Eco.Ocl.Support Namespace See Also
Collapse All

This method performs the actual evaluation (/execution) of the operation

C#
public override void Evaluate(
    IOclOperationParameters oclParameters
);
See Also
DateTimeTimeWithSubscription Class
Eco.Ocl.Support Namespace


DateTimeTimeWithSubscription.Init Method

DateTimeTimeWithSubscription.Init Method
DateTimeTimeWithSubscription Class Eco.Ocl.Support Namespace See Also
Collapse All
C#
protected override void Init();
Remarks

This is Init, a member of class DateTimeTimeWithSubscription.

See Also
DateTimeTimeWithSubscription Class
Eco.Ocl.Support Namespace


EcoOclOperationAttribute Class

EcoOclOperationAttribute Class
Inheritance Hierarchy See Also
Collapse All
C#
public sealed class EcoOclOperationAttribute : Attribute;
Remarks

This is class Eco.Ocl.Support.EcoOclOperationAttribute.

Inheritance Hierarchy
Eco.Ocl.Support.EcoOclOperationAttribute
File

OclSupport.cs

See Also
Inheritance Hierarchy


EcoOclOperationAttribute.EcoOclOperationAttribute Constructor

EcoOclOperationAttribute.EcoOclOperationAttribute Constructor
EcoOclOperationAttribute Class Eco.Ocl.Support Namespace See Also
Collapse All

Installs custom ocl-operations in the ecospace, both in designtime and runtime

C#
public EcoOclOperationAttribute(
    System.Type operation,
    bool isQuery
);
Parameters
Parameters | Description
operation | a type that either implements IOclOperation, or a type that defines one or more static methods that can be exposed in ocl.
isQuery | if this is true, then the operation is installed in both the ocl service and the actionlanguage service, otherwise it is only installed in the actionlanguage service.
See Also
EcoOclOperationAttribute Class
Eco.Ocl.Support Namespace


EcoOclOperationAttribute Methods

EcoOclOperationAttribute Methods
Public Methods
Collapse All

The methods of the EcoOclOperationAttribute class are listed here.

Public Methods
Name | Description
InstallCustomOperations | Performs the actual installation of all custom operations for an ecospace.


EcoOclOperationAttribute.InstallCustomOperations Method

EcoOclOperationAttribute.InstallCustomOperations Method
EcoOclOperationAttribute Class Eco.Ocl.Support Namespace See Also
Collapse All

Performs the actual installation of all custom operations for an ecospace.

C#
public static void InstallCustomOperations(
    Type ecoSpaceType,
    ITypeService oclService,
    ITypeService ealService,
    IEcoTypeSystem typeSystem,
    bool validate
);
See Also
EcoOclOperationAttribute Class
Eco.Ocl.Support Namespace


EcoOclOperationAttribute Properties

EcoOclOperationAttribute Properties
Public Properties
Collapse All

The properties of the EcoOclOperationAttribute class are listed here.

Public Properties
Name | Description
IsQuery | This is IsQuery, a member of class EcoOclOperationAttribute.
Operation | This is Operation, a member of class EcoOclOperationAttribute.


EcoOclOperationAttribute.IsQuery Property

EcoOclOperationAttribute.IsQuery Property
EcoOclOperationAttribute Class Eco.Ocl.Support Namespace See Also
Collapse All
C#
public bool IsQuery;
Remarks

This is IsQuery, a member of class EcoOclOperationAttribute.

See Also
EcoOclOperationAttribute Class
Eco.Ocl.Support Namespace


EcoOclOperationAttribute.Operation Property

EcoOclOperationAttribute.Operation Property
EcoOclOperationAttribute Class Eco.Ocl.Support Namespace See Also
Collapse All
C#
public System.Type Operation;
Remarks

This is Operation, a member of class EcoOclOperationAttribute.

See Also
EcoOclOperationAttribute Class
Eco.Ocl.Support Namespace


EcoOclOperationHelpAttribute Class

EcoOclOperationHelpAttribute Class
Inheritance Hierarchy See Also
Collapse All
C#
public sealed class EcoOclOperationHelpAttribute : Attribute;
Remarks

This is class Eco.Ocl.Support.EcoOclOperationHelpAttribute.

Inheritance Hierarchy
Eco.Ocl.Support.EcoOclOperationHelpAttribute
File

OclSupport.cs

See Also
Inheritance Hierarchy


EcoOclOperationHelpAttribute.EcoOclOperationHelpAttribute Constructor

EcoOclOperationHelpAttribute.EcoOclOperationHelpAttribute Constructor
EcoOclOperationHelpAttribute Class Eco.Ocl.Support Namespace See Also
Collapse All
C#
public EcoOclOperationHelpAttribute(
    string helpString
);
Remarks

This is EcoOclOperationHelpAttribute, a member of class EcoOclOperationHelpAttribute.

See Also
EcoOclOperationHelpAttribute Class
Eco.Ocl.Support Namespace


EcoOclOperationHelpAttribute Properties

EcoOclOperationHelpAttribute Properties
Public Properties
Collapse All

The properties of the EcoOclOperationHelpAttribute class are listed here.

Public Properties
Name | Description
HelpString | This is HelpString, a member of class EcoOclOperationHelpAttribute.


EcoOclOperationHelpAttribute.HelpString Property

EcoOclOperationHelpAttribute.HelpString Property
EcoOclOperationHelpAttribute Class Eco.Ocl.Support Namespace See Also
Collapse All
C#
public string HelpString;
Remarks

This is HelpString, a member of class EcoOclOperationHelpAttribute.

See Also
EcoOclOperationHelpAttribute Class
Eco.Ocl.Support Namespace


EcoOclOperationResourcedHelpAttribute Class

EcoOclOperationResourcedHelpAttribute Class
Inheritance Hierarchy See Also
Collapse All
C#
public sealed class EcoOclOperationResourcedHelpAttribute : Attribute;
Remarks

This is class Eco.Ocl.Support.EcoOclOperationResourcedHelpAttribute.

Inheritance Hierarchy
Eco.Ocl.Support.EcoOclOperationResourcedHelpAttribute
File

OclSupport.cs

See Also
Inheritance Hierarchy


EcoOclOperationResourcedHelpAttribute.EcoOclOperationResourcedHelpAttribute Constructor

EcoOclOperationResourcedHelpAttribute.EcoOclOperationResourcedHelpAttribute Constructor
EcoOclOperationResourcedHelpAttribute Class Eco.Ocl.Support Namespace See Also
Collapse All
C#
public EcoOclOperationResourcedHelpAttribute(
    string helpResource
);
Remarks

This is EcoOclOperationResourcedHelpAttribute, a member of class EcoOclOperationResourcedHelpAttribute.

See Also
EcoOclOperationResourcedHelpAttribute Class
Eco.Ocl.Support Namespace


EcoOclOperationResourcedHelpAttribute Methods

EcoOclOperationResourcedHelpAttribute Methods
Public Methods
Collapse All

The methods of the EcoOclOperationResourcedHelpAttribute class are listed here.

Public Methods
Name | Description
HelpString | This is HelpString, a member of class EcoOclOperationResourcedHelpAttribute.


EcoOclOperationResourcedHelpAttribute.HelpString Method

EcoOclOperationResourcedHelpAttribute.HelpString Method
EcoOclOperationResourcedHelpAttribute Class Eco.Ocl.Support Namespace See Also
Collapse All
C#
public string HelpString(
    object requestor
);
Remarks

This is HelpString, a member of class EcoOclOperationResourcedHelpAttribute.

See Also
EcoOclOperationResourcedHelpAttribute Class
Eco.Ocl.Support Namespace


EcoOclOperationResourcedHelpAttribute Properties

EcoOclOperationResourcedHelpAttribute Properties
Public Properties
Collapse All

The properties of the EcoOclOperationResourcedHelpAttribute class are listed here.

Public Properties
Name | Description
HelpResource | This is HelpResource, a member of class EcoOclOperationResourcedHelpAttribute.


EcoOclOperationResourcedHelpAttribute.HelpResource Property

EcoOclOperationResourcedHelpAttribute.HelpResource Property
EcoOclOperationResourcedHelpAttribute Class Eco.Ocl.Support Namespace See Also
Collapse All
C#
public string HelpResource;
Remarks

This is HelpResource, a member of class EcoOclOperationResourcedHelpAttribute.

See Also
EcoOclOperationResourcedHelpAttribute Class
Eco.Ocl.Support Namespace


IndexOf0 Class

IndexOf0 Class
Example Inheritance Hierarchy See Also
Collapse All

this class implements the operation "indexOf0" in Ocl. It returns the position of the element as a 0-based index.

C#
public class IndexOf0 : OclOperationBase;
Example

aPerson.ownedBuildings->indexOf0(home) To install in the EcoSpace, add the following attribute: [Eco.Ocl.Support.EcoOclOperation(typeof(Eco.Ocl.Support.IndexOf0), true)]

Inheritance Hierarchy
Eco.Ocl.Support.IOclOperation
    Eco.Ocl.Support.OclOperationBase
        Eco.Ocl.Support.IndexOf0
File

OclIndexOf0.cs

See Also
Example
Inheritance Hierarchy


IndexOf0 Methods

IndexOf0 Methods
Protected Methods Public Methods
Collapse All

The methods of the IndexOf0 class are listed here.

Protected Methods
Name | Description
Init | This is Init, a member of class IndexOf0.
Top
Public Methods
Name | Description
Evaluate | This method performs the actual evaluation (/execution) of the operation
InstallOperation | This is InstallOperation, a member of class IndexOf0.


IndexOf0.Evaluate Method

IndexOf0.Evaluate Method
IndexOf0 Class Eco.Ocl.Support Namespace See Also
Collapse All

This method performs the actual evaluation (/execution) of the operation

C#
public override void Evaluate(
    IOclOperationParameters oclParameters
);
See Also
IndexOf0 Class
Eco.Ocl.Support Namespace


IndexOf0.Init Method

IndexOf0.Init Method
IndexOf0 Class Eco.Ocl.Support Namespace See Also
Collapse All
C#
protected override void Init();
Remarks

This is Init, a member of class IndexOf0.

See Also
IndexOf0 Class
Eco.Ocl.Support Namespace


IndexOf0.InstallOperation Method

IndexOf0.InstallOperation Method
IndexOf0 Class Eco.Ocl.Support Namespace See Also
Collapse All
C#
public static void InstallOperation(
    IEcoServiceProvider serviceProvider
);
Remarks

This is InstallOperation, a member of class IndexOf0.

See Also
IndexOf0 Class
Eco.Ocl.Support Namespace


OclAssign Class

OclAssign Class
Inheritance Hierarchy See Also
Collapse All
C#
public class OclAssign : OclOperationBase;
Remarks

This is class Eco.Ocl.Support.OclAssign.

Inheritance Hierarchy
Eco.Ocl.Support.IOclOperation
    Eco.Ocl.Support.OclOperationBase
        Eco.Ocl.Support.OclAssign
File

OclAssign.cs

See Also
Inheritance Hierarchy


OclAssign Methods

OclAssign Methods
Protected Methods Public Methods
Collapse All

The methods of the OclAssign class are listed here.

Protected Methods
Name | Description
Init | This is Init, a member of class OclAssign.
Top
Public Methods
Name | Description
Evaluate |


OclAssign.Evaluate Method

OclAssign.Evaluate Method
OclAssign Class Eco.Ocl.Support Namespace See Also
Collapse All
C#
public override void Evaluate(
    IOclOperationParameters oclParameters
);
Exceptions
Exceptions | Description
ArgumentNullException | Thrown if parameters is null.
ArgumentException | Thrown if the first item in parameters is not an IProperty.
See Also
OclAssign Class
Eco.Ocl.Support Namespace


OclAssign.Init Method

OclAssign.Init Method
OclAssign Class Eco.Ocl.Support Namespace See Also
Collapse All
C#
protected override void Init();
Remarks

This is Init, a member of class OclAssign.

See Also
OclAssign Class
Eco.Ocl.Support Namespace


OclConstructorMethod Class

OclConstructorMethod Class
Inheritance Hierarchy See Also
Collapse All
C#
public class OclConstructorMethod : OclTypeMethod;
Remarks

This is class Eco.Ocl.Support.OclConstructorMethod.

Inheritance Hierarchy
Eco.Ocl.Support.IOclOperation
    Eco.Ocl.Support.OclOperationBase
        Eco.Ocl.Support.OclTypeMethod
            Eco.Ocl.Support.OclConstructorMethod
File

OclTypeMethods.cs

See Also
Inheritance Hierarchy


OclConstructorMethod.OclConstructorMethod Constructor

OclConstructorMethod.OclConstructorMethod Constructor
OclConstructorMethod Class Eco.Ocl.Support Namespace See Also
Collapse All
C#
public OclConstructorMethod(
    ConstructorInfo constructor,
    IClassifier[] ecoParameters
);
Remarks

This is OclConstructorMethod, a member of class OclConstructorMethod.

See Also
OclConstructorMethod Class
Eco.Ocl.Support Namespace


OclConstructorMethod Methods

OclConstructorMethod Methods
Protected Methods
Collapse All

The methods of the OclConstructorMethod class are listed here.

Protected Methods
Name | Description
GetClrParameterType | This is GetClrParameterType, a member of class OclConstructorMethod.
Init | This is Init, a member of class OclConstructorMethod.
Invoke | This is Invoke, a member of class OclConstructorMethod.


OclConstructorMethod.GetClrParameterType Method

OclConstructorMethod.GetClrParameterType Method
OclConstructorMethod Class Eco.Ocl.Support Namespace See Also
Collapse All
C#
protected override Type GetClrParameterType(
    int index
);
Remarks

This is GetClrParameterType, a member of class OclConstructorMethod.

See Also
OclConstructorMethod Class
Eco.Ocl.Support Namespace


OclConstructorMethod.Init Method

OclConstructorMethod.Init Method
OclConstructorMethod Class Eco.Ocl.Support Namespace See Also
Collapse All
C#
protected override void Init();
Remarks

This is Init, a member of class OclConstructorMethod.

See Also
OclConstructorMethod Class
Eco.Ocl.Support Namespace


OclConstructorMethod.Invoke Method

OclConstructorMethod.Invoke Method
OclConstructorMethod Class Eco.Ocl.Support Namespace See Also
Collapse All
C#
protected override object Invoke(
    object root,
    object[] parameters
);
Remarks

This is Invoke, a member of class OclConstructorMethod.

See Also
OclConstructorMethod Class
Eco.Ocl.Support Namespace


OclConstructorMethod Properties

OclConstructorMethod Properties
Public Properties
Collapse All

The properties of the OclConstructorMethod class are listed here.

Public Properties
Name | Description
ConstructorInfo | This is ConstructorInfo, a member of class OclConstructorMethod.


OclConstructorMethod.ConstructorInfo Property

OclConstructorMethod.ConstructorInfo Property
OclConstructorMethod Class Eco.Ocl.Support Namespace See Also
Collapse All
C#
public ConstructorInfo ConstructorInfo;
Remarks

This is ConstructorInfo, a member of class OclConstructorMethod.

See Also
OclConstructorMethod Class
Eco.Ocl.Support Namespace


OclInstanceField Class

OclInstanceField Class
Inheritance Hierarchy See Also
Collapse All
C#
public class OclInstanceField : OclTypeMethod;
Remarks

This is class Eco.Ocl.Support.OclInstanceField.

Inheritance Hierarchy
Eco.Ocl.Support.IOclOperation
    Eco.Ocl.Support.OclOperationBase
        Eco.Ocl.Support.OclTypeMethod
            Eco.Ocl.Support.OclInstanceField
File

OclTypeMethods.cs

See Also
Inheritance Hierarchy


OclInstanceField.OclInstanceField Constructor

OclInstanceField.OclInstanceField Constructor
OclInstanceField Class Eco.Ocl.Support Namespace See Also
Collapse All
C#
public OclInstanceField(
    string name,
    FieldInfo fi,
    IClassifier returnType,
    IClassifier[] ecoParameters
);
Remarks

This is OclInstanceField, a member of class OclInstanceField.

See Also
OclInstanceField Class
Eco.Ocl.Support Namespace


OclInstanceField Methods

OclInstanceField Methods
Protected Methods
Collapse All

The methods of the OclInstanceField class are listed here.

Protected Methods
Name | Description
GetClrParameterType | This is GetClrParameterType, a member of class OclInstanceField.
Init | This is Init, a member of class OclInstanceField.
Invoke | This is Invoke, a member of class OclInstanceField.


OclInstanceField.GetClrParameterType Method

OclInstanceField.GetClrParameterType Method
OclInstanceField Class Eco.Ocl.Support Namespace See Also
Collapse All
C#
protected override Type GetClrParameterType(
    int index
);
Remarks

This is GetClrParameterType, a member of class OclInstanceField.

See Also
OclInstanceField Class
Eco.Ocl.Support Namespace


OclInstanceField.Init Method

OclInstanceField.Init Method
OclInstanceField Class Eco.Ocl.Support Namespace See Also
Collapse All
C#
protected override void Init();
Remarks

This is Init, a member of class OclInstanceField.

See Also
OclInstanceField Class
Eco.Ocl.Support Namespace


OclInstanceField.Invoke Method

OclInstanceField.Invoke Method
OclInstanceField Class Eco.Ocl.Support Namespace See Also
Collapse All
C#
protected override object Invoke(
    object root,
    object[] parameters
);
Remarks

This is Invoke, a member of class OclInstanceField.

See Also
OclInstanceField Class
Eco.Ocl.Support Namespace


OclInstanceField Properties

OclInstanceField Properties
Public Properties
Collapse All

The properties of the OclInstanceField class are listed here.

Public Properties
Name | Description
FieldInfo | This is FieldInfo, a member of class OclInstanceField.


OclInstanceField.FieldInfo Property

OclInstanceField.FieldInfo Property
OclInstanceField Class Eco.Ocl.Support Namespace See Also
Collapse All
C#
public FieldInfo FieldInfo;
Remarks

This is FieldInfo, a member of class OclInstanceField.

See Also
OclInstanceField Class
Eco.Ocl.Support Namespace


OclInstanceMethod Class

OclInstanceMethod Class
Inheritance Hierarchy See Also
Collapse All
C#
public class OclInstanceMethod : AbstractOclInstanceMethod;
Remarks

This is class Eco.Ocl.Support.OclInstanceMethod.

Inheritance Hierarchy
Eco.Ocl.Support.IOclOperation
    Eco.Ocl.Support.OclOperationBase
        Eco.Ocl.Support.OclTypeMethod
            Eco.Ocl.Support.AbstractOclInstanceMethod
                Eco.Ocl.Support.OclInstanceMethod
File

OclTypeMethods.cs

See Also
Inheritance Hierarchy


OclInstanceMethod.OclInstanceMethod Constructor

OclInstanceMethod.OclInstanceMethod Constructor
OclInstanceMethod Class Eco.Ocl.Support Namespace See Also
Collapse All
C#
public OclInstanceMethod(
    string name,
    MethodInfo mi,
    IClassifier[] ecoParameters,
    IClassifier returnType,
    bool isProperty,
    bool isInfix
);
Remarks

This is OclInstanceMethod, a member of class OclInstanceMethod.

See Also
OclInstanceMethod Class
Eco.Ocl.Support Namespace


OclInstanceMethod Methods

OclInstanceMethod Methods
Protected Methods
Collapse All

The methods of the OclInstanceMethod class are listed here.

Protected Methods
Name | Description
Init | This is Init, a member of class OclInstanceMethod.
Invoke | This is Invoke, a member of class OclInstanceMethod.


OclInstanceMethod.Init Method

OclInstanceMethod.Init Method
OclInstanceMethod Class Eco.Ocl.Support Namespace See Also
Collapse All
C#
protected override void Init();
Remarks

This is Init, a member of class OclInstanceMethod.

See Also
OclInstanceMethod Class
Eco.Ocl.Support Namespace


OclInstanceMethod.Invoke Method

OclInstanceMethod.Invoke Method
OclInstanceMethod Class Eco.Ocl.Support Namespace See Also
Collapse All
C#
protected override object Invoke(
    object root,
    object[] parameters
);
Remarks

This is Invoke, a member of class OclInstanceMethod.

See Also
OclInstanceMethod Class
Eco.Ocl.Support Namespace


OclMethod Class

OclMethod Class
Inheritance Hierarchy See Also
Collapse All
C#
public sealed class OclMethod : OclMethodBase;
Remarks

This is class Eco.Ocl.Support.OclMethod.

Inheritance Hierarchy
Eco.Ocl.Support.IOclOperation
    Eco.Ocl.Support.OclOperationBase
        Eco.Ocl.Support.OclMethodBase
            Eco.Ocl.Support.OclMethod
File

OclMethods.cs

See Also
Inheritance Hierarchy


OclMethod.OclMethod Constructor

OclMethod.OclMethod Constructor
OclMethod Class Eco.Ocl.Support Namespace See Also
Collapse All
C#
public OclMethod(
    IMethod method
);
Remarks

This is OclMethod, a member of class OclMethod.

See Also
OclMethod Class
Eco.Ocl.Support Namespace


OclMethodBase Class

OclMethodBase Class
Inheritance Hierarchy See Also
Collapse All
C#
public class OclMethodBase : OclOperationBase;
Remarks

This is class Eco.Ocl.Support.OclMethodBase.

Inheritance Hierarchy
Eco.Ocl.Support.IOclOperation
    Eco.Ocl.Support.OclOperationBase
        Eco.Ocl.Support.OclMethodBase
            Eco.Ocl.Support.OclMethod
            Eco.Ocl.Support.OclTrigger
File

OclMethods.cs

See Also
Inheritance Hierarchy


OclMethodBase.OclMethodBase Constructor

OclMethodBase.OclMethodBase Constructor
OclMethodBase Class Eco.Ocl.Support Namespace See Also
Collapse All
C#
public OclMethodBase(
    IMethod method
);
Remarks

This is OclMethodBase, a member of class OclMethodBase.

See Also
OclMethodBase Class
Eco.Ocl.Support Namespace


OclMethodBase Methods

OclMethodBase Methods
Protected Methods Public Methods
Collapse All

The methods of the OclMethodBase class are listed here.

Protected Methods
Name | Description
Init | This is Init, a member of class OclMethodBase.
Top
Public Methods
Name | Description
Evaluate |


OclMethodBase.Evaluate Method

OclMethodBase.Evaluate Method
OclMethodBase Class Eco.Ocl.Support Namespace See Also
Collapse All
C#
public override void Evaluate(
    IOclOperationParameters oclParameters
);
Exceptions
Exceptions | Description
ArgumentNullException | Thrown if oclParameters is null.
See Also
OclMethodBase Class
Eco.Ocl.Support Namespace


OclMethodBase.Init Method

OclMethodBase.Init Method
OclMethodBase Class Eco.Ocl.Support Namespace See Also
Collapse All
C#
protected override void Init();
Remarks

This is Init, a member of class OclMethodBase.

See Also
OclMethodBase Class
Eco.Ocl.Support Namespace


OclMethodInstaller Class

OclMethodInstaller Class
Inheritance Hierarchy See Also
Collapse All
C#
public abstract class OclMethodInstaller;
Remarks

This is class Eco.Ocl.Support.OclMethodInstaller.

Inheritance Hierarchy
Eco.Ocl.Support.OclMethodInstaller
File

OclMethods.cs

See Also
Inheritance Hierarchy


OclMethodInstaller Methods

OclMethodInstaller Methods
Public Methods
Collapse All

The methods of the OclMethodInstaller class are listed here.

Public Methods
Name | Description
InstallMethods |
InstallMethodsForClass |
InstallNonQueryMethods | This is InstallNonQueryMethods, a member of class OclMethodInstaller.
InstallQueryMethods | This is InstallQueryMethods, a member of class OclMethodInstaller.


OclMethodInstaller.InstallMethods Method

OclMethodInstaller.InstallMethods Method
OclMethodInstaller Class Eco.Ocl.Support Namespace See Also
Collapse All
C#
public static void InstallMethods(
    ITypeService typeService,
    IEcoTypeSystem typeSystem,
    OclMethodsFilter filter
);
Exceptions
Exceptions | Description
ArgumentNullException | Thrown if typeSystem is null.
See Also
OclMethodInstaller Class
Eco.Ocl.Support Namespace


OclMethodInstaller.InstallMethodsForClass Method

OclMethodInstaller.InstallMethodsForClass Method
OclMethodInstaller Class Eco.Ocl.Support Namespace See Also
Collapse All
C#
public static void InstallMethodsForClass(
    ITypeService typeService,
    IClass umlClass,
    OclMethodsFilter filter
);
Exceptions
Exceptions | Description
ArgumentNullException | Thrown if umlClass is null. Thrown if typeService is null.
See Also
OclMethodInstaller Class
Eco.Ocl.Support Namespace


OclMethodInstaller.InstallNonQueryMethods Method

OclMethodInstaller.InstallNonQueryMethods Method
OclMethodInstaller Class Eco.Ocl.Support Namespace See Also
Collapse All
C#
public static void InstallNonQueryMethods(
    ITypeService typeService,
    IEcoTypeSystem typeSystem
);
Remarks

This is InstallNonQueryMethods, a member of class OclMethodInstaller.

See Also
OclMethodInstaller Class
Eco.Ocl.Support Namespace


OclMethodInstaller.InstallQueryMethods Method

OclMethodInstaller.InstallQueryMethods Method
OclMethodInstaller Class Eco.Ocl.Support Namespace See Also
Collapse All
C#
public static void InstallQueryMethods(
    ITypeService typeService,
    IEcoTypeSystem typeSystem
);
Remarks

This is InstallQueryMethods, a member of class OclMethodInstaller.

See Also
OclMethodInstaller Class
Eco.Ocl.Support Namespace


OclOperationBase Class

OclOperationBase Class
Inheritance Hierarchy See Also
Collapse All

This is a suitable base class for Ocl operations. Subclass and override the abstract Init and Evaluate methods. in the Init-method, you should call the InternalInit with a suiteable set of parameters.

C#
public abstract class OclOperationBase : System.Object, IOclOperation;
Inheritance Hierarchy
Eco.Ocl.Support.IOclOperation
    Eco.Ocl.Support.OclOperationBase
        Eco.Ocl.Support.AbstractTimerbasedOperation
        Eco.Ocl.Support.At0
        Eco.Ocl.Support.DateTimeDate
        Eco.Ocl.Support.DateTimeTime
        Eco.Ocl.Support.IndexOf0
        Eco.Ocl.Support.OclAssign
        Eco.Ocl.Support.OclMethodBase
        Eco.Ocl.Support.OclPreconditionQuery
        Eco.Ocl.Support.OclTriggerQuery
        Eco.Ocl.Support.OclTypeMethod
        Eco.Ocl.Support.TimeSpanSum
File

OclOperationBase.cs

See Also
Inheritance Hierarchy


OclOperationBase Methods

OclOperationBase Methods
Protected Methods Public Methods
Collapse All

The methods of the OclOperationBase class are listed here.

Protected Methods
Name | Description
Init | This is Init, a member of class OclOperationBase.
InternalInit | This is the overview for the InternalInit method overload.
Top
Public Methods
Name | Description
CalculateReturnType | For operations where the predefined deduce methods are not sufficient, they can specify OclResultTypeDeduceMethod.SymbolCalculated and perform their own calculation here. Default implementation in OclOperationBase is to throw an exception
Evaluate | This method performs the actual evaluation (/execution) of the operation
Initialize |
ResultIsReadOnly | Determines if the result of the operation is readonly based on the readonlyness of the parameters.
SemanticCheck | if the operation has custom semantic validation, it can be implemented here (OclOperationBase has an empty implemenation of this method)


OclOperationBase.CalculateReturnType Method

OclOperationBase.CalculateReturnType Method
OclOperationBase Class Eco.Ocl.Support Namespace See Also
Collapse All

For operations where the predefined deduce methods are not sufficient, they can specify OclResultTypeDeduceMethod.SymbolCalculated and perform their own calculation here. Default implementation in OclOperationBase is to throw an exception

C#
public virtual IOclType CalculateReturnType(
    IOclOperationParameters oclParameters
);
See Also
OclOperationBase Class
Eco.Ocl.Support Namespace


OclOperationBase.Evaluate Method

OclOperationBase.Evaluate Method
OclOperationBase Class Eco.Ocl.Support Namespace See Also
Collapse All

This method performs the actual evaluation (/execution) of the operation

C#
public abstract void Evaluate(
    IOclOperationParameters oclParameters
);
See Also
OclOperationBase Class
Eco.Ocl.Support Namespace


OclOperationBase.Init Method

OclOperationBase.Init Method
OclOperationBase Class Eco.Ocl.Support Namespace See Also
Collapse All
C#
protected abstract void Init();
Remarks

This is Init, a member of class OclOperationBase.

See Also
OclOperationBase Class
Eco.Ocl.Support Namespace


OclOperationBase.Initialize Method

OclOperationBase.Initialize Method
OclOperationBase Class Eco.Ocl.Support Namespace See Also
Collapse All
C#
public void Initialize(
    IOclOperationSupport support
);
Exceptions
Exceptions | Description
ArgumentNullException | Thrown if support is null.
See Also
OclOperationBase Class
Eco.Ocl.Support Namespace


InternalInit Method

InternalInit Method

This is the overview for the InternalInit method overload.

Overload List
Name | Description
OclOperationBase.InternalInit (string, IOclType[], IOclType) | This is InternalInit, a member of class OclOperationBase.
OclOperationBase.InternalInit (string, IOclType[], OclResultTypeDeduceMethod) | This is InternalInit, a member of class OclOperationBase.


OclOperationBase.InternalInit Method (string, IOclType[], IOclType)

OclOperationBase.InternalInit Method (string, IOclType[], IOclType)
OclOperationBase Class Eco.Ocl.Support Namespace See Also
Collapse All
C#
protected void InternalInit(
    string name,
    IOclType[] args,
    IOclType resultType
);
Remarks

This is InternalInit, a member of class OclOperationBase.

See Also
OclOperationBase Class
Eco.Ocl.Support Namespace


OclOperationBase.InternalInit Method (string, IOclType[], OclResultTypeDeduceMethod)

OclOperationBase.InternalInit Method (string, IOclType[], OclResultTypeDeduceMethod)
OclOperationBase Class Eco.Ocl.Support Namespace See Also
Collapse All
C#
protected void InternalInit(
    string name,
    IOclType[] args,
    OclResultTypeDeduceMethod deduceMethod
);
Remarks

This is InternalInit, a member of class OclOperationBase.

See Also
OclOperationBase Class
Eco.Ocl.Support Namespace


OclOperationBase.ResultIsReadOnly Method

OclOperationBase.ResultIsReadOnly Method
OclOperationBase Class Eco.Ocl.Support Namespace See Also
Collapse All

Determines if the result of the operation is readonly based on the readonlyness of the parameters.

C#
public virtual bool ResultIsReadOnly(
    bool[] args
);
See Also
OclOperationBase Class
Eco.Ocl.Support Namespace


OclOperationBase.SemanticCheck Method

OclOperationBase.SemanticCheck Method
OclOperationBase Class Eco.Ocl.Support Namespace See Also
Collapse All

if the operation has custom semantic validation, it can be implemented here (OclOperationBase has an empty implemenation of this method)

C#
public virtual void SemanticCheck(
    IOclOperationParameters oclParameters
);
See Also
OclOperationBase Class
Eco.Ocl.Support Namespace


OclOperationBase Properties

OclOperationBase Properties
Public Properties Protected Properties
Collapse All

The properties of the OclOperationBase class are listed here.

Public Properties
Name | Description
ArgsNeedCommonType | Determines if the operation requires the source and the first parameter to be able to conform to each other one way or the other.
DeduceMethod | Indicates how the resulttype is calculated based on the types of the actual parameters.
FormalParameters | The type of the formal parameters. The sematic check will use this to determine if the actual parameters can be used to call this operation
IsDotNotation | If true, it means that the operation must be prefixed with a ".".
IsPostFix | True for "normal" operations. False for "infix" operations supported by the parser, such as "and", "+", etc.
IsTypeOperation | If this is true, then the operation can be applied to the type directly (corresponds to c# "static" or Delphi "class method").
ModifiesSource | This should be true if the operation has side effects on the source-parameter (such as "clear").
Name | The name of the operation.
RepeatParameters | If this value is non-zero, it means that the last x parameters can be repeated when the operation is called.
ResultType | The return type of the operation. Requires the DeduceMethod to be set to OclResultTypeDeduceMethod.ExplicitType.
Support | This is Support, a member of class OclOperationBase.
Top
Protected Properties
Name | Description
IsInfix | This is IsInfix, a member of class OclOperationBase.


OclOperationBase.ArgsNeedCommonType Property

OclOperationBase.ArgsNeedCommonType Property
OclOperationBase Class Eco.Ocl.Support Namespace See Also
Collapse All

Determines if the operation requires the source and the first parameter to be able to conform to each other one way or the other.

C#
public bool ArgsNeedCommonType;
See Also
OclOperationBase Class
Eco.Ocl.Support Namespace


OclOperationBase.DeduceMethod Property

OclOperationBase.DeduceMethod Property
OclOperationBase Class Eco.Ocl.Support Namespace See Also
Collapse All

Indicates how the resulttype is calculated based on the types of the actual parameters.

C#
public OclResultTypeDeduceMethod DeduceMethod;
See Also
OclOperationBase Class
Eco.Ocl.Support Namespace


OclOperationBase.FormalParameters Property

OclOperationBase.FormalParameters Property
OclOperationBase Class Eco.Ocl.Support Namespace See Also
Collapse All

The type of the formal parameters. The sematic check will use this to determine if the actual parameters can be used to call this operation

C#
public IOclType FormalParameters;
See Also
OclOperationBase Class
Eco.Ocl.Support Namespace


OclOperationBase.IsDotNotation Property

OclOperationBase.IsDotNotation Property
OclOperationBase Class Eco.Ocl.Support Namespace See Also
Collapse All

If true, it means that the operation must be prefixed with a ".".

C#
public bool IsDotNotation;
See Also
OclOperationBase Class
Eco.Ocl.Support Namespace


OclOperationBase.IsInfix Property

OclOperationBase.IsInfix Property
OclOperationBase Class Eco.Ocl.Support Namespace See Also
Collapse All
C#
protected bool IsInfix;
Remarks

This is IsInfix, a member of class OclOperationBase.

See Also
OclOperationBase Class
Eco.Ocl.Support Namespace


OclOperationBase.IsPostFix Property

OclOperationBase.IsPostFix Property
OclOperationBase Class Eco.Ocl.Support Namespace See Also
Collapse All

True for "normal" operations. False for "infix" operations supported by the parser, such as "and", "+", etc.

C#
public bool IsPostFix;
See Also
OclOperationBase Class
Eco.Ocl.Support Namespace


OclOperationBase.IsTypeOperation Property

OclOperationBase.IsTypeOperation Property
OclOperationBase Class Eco.Ocl.Support Namespace See Also
Collapse All

If this is true, then the operation can be applied to the type directly (corresponds to c# "static" or Delphi "class method").

C#
public bool IsTypeOperation;
See Also
OclOperationBase Class
Eco.Ocl.Support Namespace


OclOperationBase.ModifiesSource Property

OclOperationBase.ModifiesSource Property
OclOperationBase Class Eco.Ocl.Support Namespace See Also
Collapse All

This should be true if the operation has side effects on the source-parameter (such as "clear").

C#
public bool ModifiesSource;
See Also
OclOperationBase Class
Eco.Ocl.Support Namespace


OclOperationBase.Name Property

OclOperationBase.Name Property
OclOperationBase Class Eco.Ocl.Support Namespace See Also
Collapse All

The name of the operation.

C#
public string Name;
See Also
OclOperationBase Class
Eco.Ocl.Support Namespace


OclOperationBase.RepeatParameters Property

OclOperationBase.RepeatParameters Property
OclOperationBase Class Eco.Ocl.Support Namespace See Also
Collapse All

If this value is non-zero, it means that the last x parameters can be repeated when the operation is called.

C#
public int RepeatParameters;
See Also
OclOperationBase Class
Eco.Ocl.Support Namespace


OclOperationBase.ResultType Property

OclOperationBase.ResultType Property
OclOperationBase Class Eco.Ocl.Support Namespace See Also
Collapse All

The return type of the operation. Requires the DeduceMethod to be set to OclResultTypeDeduceMethod.ExplicitType.

C#
public IOclType ResultType;
See Also
OclOperationBase Class
Eco.Ocl.Support Namespace


OclOperationBase.Support Property

OclOperationBase.Support Property
OclOperationBase Class Eco.Ocl.Support Namespace See Also
Collapse All
C#
public IOclOperationSupport Support;
Remarks

This is Support, a member of class OclOperationBase.

See Also
OclOperationBase Class
Eco.Ocl.Support Namespace


OclPreconditionQuery Class

OclPreconditionQuery Class
Inheritance Hierarchy See Also
Collapse All
C#
public sealed class OclPreconditionQuery : OclOperationBase;
Remarks

This is class Eco.Ocl.Support.OclPreconditionQuery.

Inheritance Hierarchy
Eco.Ocl.Support.IOclOperation
    Eco.Ocl.Support.OclOperationBase
        Eco.Ocl.Support.OclPreconditionQuery
File

OclMethods.cs

See Also
Inheritance Hierarchy


OclPreconditionQuery.OclPreconditionQuery Constructor

OclPreconditionQuery.OclPreconditionQuery Constructor
OclPreconditionQuery Class Eco.Ocl.Support Namespace See Also
Collapse All
C#
public OclPreconditionQuery(
    IMethod method
);
Remarks

This is OclPreconditionQuery, a member of class OclPreconditionQuery.

See Also
OclPreconditionQuery Class
Eco.Ocl.Support Namespace


OclPreconditionQuery Methods

OclPreconditionQuery Methods
Protected Methods Public Methods
Collapse All

The methods of the OclPreconditionQuery class are listed here.

Protected Methods
Name | Description
Init | This is Init, a member of class OclPreconditionQuery.
Top
Public Methods
Name | Description
Evaluate |


OclPreconditionQuery.Evaluate Method

OclPreconditionQuery.Evaluate Method
OclPreconditionQuery Class Eco.Ocl.Support Namespace See Also
Collapse All
C#
public override void Evaluate(
    IOclOperationParameters oclParameters
);
Exceptions
Exceptions | Description
ArgumentNullException | Thrown if oclParameters is null.
See Also
OclPreconditionQuery Class
Eco.Ocl.Support Namespace


OclPreconditionQuery.Init Method

OclPreconditionQuery.Init Method
OclPreconditionQuery Class Eco.Ocl.Support Namespace See Also
Collapse All
C#
protected override void Init();
Remarks

This is Init, a member of class OclPreconditionQuery.

See Also
OclPreconditionQuery Class
Eco.Ocl.Support Namespace


OclPsStandardOperations Class

OclPsStandardOperations Class
Inheritance Hierarchy See Also
Collapse All
C#
public class OclPsStandardOperations;
Remarks

This is class Eco.Ocl.Support.OclPsStandardOperations.

Inheritance Hierarchy
Eco.Ocl.Support.OclPsStandardOperations
File

OclStandardOperations.cs

See Also
Inheritance Hierarchy


OclPsStandardOperations Methods

OclPsStandardOperations Methods
Public Methods
Collapse All

The methods of the OclPsStandardOperations class are listed here.

Public Methods
Name | Description
average | This is the overview for the average method overload.
maxValue | This is the overview for the maxValue method overload.
minValue | This is the overview for the minValue method overload.
op_Addition | This is the overview for the op_Addition method overload.
op_Division | This is the overview for the op_Division method overload.
op_Multiply | This is the overview for the op_Multiply method overload.
op_Subtraction | This is the overview for the op_Subtraction method overload.
op_UnaryNegation | This is the overview for the op_UnaryNegation method overload.
sum | This is the overview for the sum method overload.


average Method

average Method

This is the overview for the average method overload.

Overload List
Name | Description
OclPsStandardOperations.average (IList<decimal>) | This is average, a member of class OclPsStandardOperations.
OclPsStandardOperations.average (IList<double>) | This is average, a member of class OclPsStandardOperations.
OclPsStandardOperations.average (IList<int>) | This is average, a member of class OclPsStandardOperations.
OclPsStandardOperations.average (IList<long>) | This is average, a member of class OclPsStandardOperations.


OclPsStandardOperations.average Method (IList<decimal>)

OclPsStandardOperations.average Method (IList<decimal>)
OclPsStandardOperations Class Eco.Ocl.Support Namespace See Also
Collapse All
C#
public static decimal average(
    IList<decimal> list
);
Remarks

This is average, a member of class OclPsStandardOperations.

See Also
OclPsStandardOperations Class
Eco.Ocl.Support Namespace


OclPsStandardOperations.average Method (IList<double>)

OclPsStandardOperations.average Method (IList<double>)
OclPsStandardOperations Class Eco.Ocl.Support Namespace See Also
Collapse All
C#
public static double average(
    IList<double> list
);
Remarks

This is average, a member of class OclPsStandardOperations.

See Also
OclPsStandardOperations Class
Eco.Ocl.Support Namespace


OclPsStandardOperations.average Method (IList<int>)

OclPsStandardOperations.average Method (IList<int>)
OclPsStandardOperations Class Eco.Ocl.Support Namespace See Also
Collapse All
C#
public static double average(
    IList<int> list
);
Remarks

This is average, a member of class OclPsStandardOperations.

See Also
OclPsStandardOperations Class
Eco.Ocl.Support Namespace


OclPsStandardOperations.average Method (IList<long>)

OclPsStandardOperations.average Method (IList<long>)
OclPsStandardOperations Class Eco.Ocl.Support Namespace See Also
Collapse All
C#
public static double average(
    IList<long> list
);
Remarks

This is average, a member of class OclPsStandardOperations.

See Also
OclPsStandardOperations Class
Eco.Ocl.Support Namespace


maxValue Method

maxValue Method

This is the overview for the maxValue method overload.

Overload List
Name | Description
OclPsStandardOperations.maxValue (IList<decimal>) | This is maxValue, a member of class OclPsStandardOperations.
OclPsStandardOperations.maxValue (IList<double>) | This is maxValue, a member of class OclPsStandardOperations.
OclPsStandardOperations.maxValue (IList<int>) | This is maxValue, a member of class OclPsStandardOperations.
OclPsStandardOperations.maxValue (IList<long>) | This is maxValue, a member of class OclPsStandardOperations.


OclPsStandardOperations.maxValue Method (IList<decimal>)

OclPsStandardOperations.maxValue Method (IList<decimal>)
OclPsStandardOperations Class Eco.Ocl.Support Namespace See Also
Collapse All
C#
public static decimal maxValue(
    IList<decimal> list
);
Remarks

This is maxValue, a member of class OclPsStandardOperations.

See Also
OclPsStandardOperations Class
Eco.Ocl.Support Namespace


OclPsStandardOperations.maxValue Method (IList<double>)

OclPsStandardOperations.maxValue Method (IList<double>)
OclPsStandardOperations Class Eco.Ocl.Support Namespace See Also
Collapse All
C#
public static double maxValue(
    IList<double> list
);
Remarks

This is maxValue, a member of class OclPsStandardOperations.

See Also
OclPsStandardOperations Class
Eco.Ocl.Support Namespace


OclPsStandardOperations.maxValue Method (IList<int>)

OclPsStandardOperations.maxValue Method (IList<int>)
OclPsStandardOperations Class Eco.Ocl.Support Namespace See Also
Collapse All
C#
public static int maxValue(
    IList<int> list
);
Remarks

This is maxValue, a member of class OclPsStandardOperations.

See Also
OclPsStandardOperations Class
Eco.Ocl.Support Namespace


OclPsStandardOperations.maxValue Method (IList<long>)

OclPsStandardOperations.maxValue Method (IList<long>)
OclPsStandardOperations Class Eco.Ocl.Support Namespace See Also
Collapse All
C#
public static long maxValue(
    IList<long> list
);
Remarks

This is maxValue, a member of class OclPsStandardOperations.

See Also
OclPsStandardOperations Class
Eco.Ocl.Support Namespace


minValue Method

minValue Method

This is the overview for the minValue method overload.

Overload List
Name | Description
OclPsStandardOperations.minValue (IList<decimal>) | This is minValue, a member of class OclPsStandardOperations.
OclPsStandardOperations.minValue (IList<double>) | This is minValue, a member of class OclPsStandardOperations.
OclPsStandardOperations.minValue (IList<int>) | This is minValue, a member of class OclPsStandardOperations.
OclPsStandardOperations.minValue (IList<long>) | This is minValue, a member of class OclPsStandardOperations.


OclPsStandardOperations.minValue Method (IList<decimal>)

OclPsStandardOperations.minValue Method (IList<decimal>)
OclPsStandardOperations Class Eco.Ocl.Support Namespace See Also
Collapse All
C#
public static decimal minValue(
    IList<decimal> list
);
Remarks

This is minValue, a member of class OclPsStandardOperations.

See Also
OclPsStandardOperations Class
Eco.Ocl.Support Namespace


OclPsStandardOperations.minValue Method (IList<double>)

OclPsStandardOperations.minValue Method (IList<double>)
OclPsStandardOperations Class Eco.Ocl.Support Namespace See Also
Collapse All
C#
public static double minValue(
    IList<double> list
);
Remarks

This is minValue, a member of class OclPsStandardOperations.

See Also
OclPsStandardOperations Class
Eco.Ocl.Support Namespace


OclPsStandardOperations.minValue Method (IList<int>)

OclPsStandardOperations.minValue Method (IList<int>)
OclPsStandardOperations Class Eco.Ocl.Support Namespace See Also
Collapse All
C#
public static int minValue(
    IList<int> list
);
Remarks

This is minValue, a member of class OclPsStandardOperations.

See Also
OclPsStandardOperations Class
Eco.Ocl.Support Namespace


OclPsStandardOperations.minValue Method (IList<long>)

OclPsStandardOperations.minValue Method (IList<long>)
OclPsStandardOperations Class Eco.Ocl.Support Namespace See Also
Collapse All
C#
public static long minValue(
    IList<long> list
);
Remarks

This is minValue, a member of class OclPsStandardOperations.

See Also
OclPsStandardOperations Class
Eco.Ocl.Support Namespace


op_Addition Method

op_Addition Method

This is the overview for the op_Addition method overload.

Overload List
Name | Description
OclPsStandardOperations.op_Addition (double, double) | This is op_Addition, a member of class OclPsStandardOperations.
OclPsStandardOperations.op_Addition (int, int) | This is op_Addition, a member of class OclPsStandardOperations.
OclPsStandardOperations.op_Addition (long, long) | This is op_Addition, a member of class OclPsStandardOperations.


OclPsStandardOperations.op_Addition Method (double, double)

OclPsStandardOperations.op_Addition Method (double, double)
OclPsStandardOperations Class Eco.Ocl.Support Namespace See Also
Collapse All
C#
public static double op_Addition(
    double a,
    double b
);
Remarks

This is op_Addition, a member of class OclPsStandardOperations.

See Also
OclPsStandardOperations Class
Eco.Ocl.Support Namespace


OclPsStandardOperations.op_Addition Method (int, int)

OclPsStandardOperations.op_Addition Method (int, int)
OclPsStandardOperations Class Eco.Ocl.Support Namespace See Also
Collapse All
C#
public static int op_Addition(
    int a,
    int b
);
Remarks

This is op_Addition, a member of class OclPsStandardOperations.

See Also
OclPsStandardOperations Class
Eco.Ocl.Support Namespace


OclPsStandardOperations.op_Addition Method (long, long)

OclPsStandardOperations.op_Addition Method (long, long)
OclPsStandardOperations Class Eco.Ocl.Support Namespace See Also
Collapse All
C#
public static long op_Addition(
    long a,
    long b
);
Remarks

This is op_Addition, a member of class OclPsStandardOperations.

See Also
OclPsStandardOperations Class
Eco.Ocl.Support Namespace


op_Division Method

op_Division Method

This is the overview for the op_Division method overload.

Overload List
Name | Description
OclPsStandardOperations.op_Division (double, double) | This is op_Division, a member of class OclPsStandardOperations.
OclPsStandardOperations.op_Division (int, int) | This is op_Division, a member of class OclPsStandardOperations.
OclPsStandardOperations.op_Division (long, long) | This is op_Division, a member of class OclPsStandardOperations.


OclPsStandardOperations.op_Division Method (double, double)

OclPsStandardOperations.op_Division Method (double, double)
OclPsStandardOperations Class Eco.Ocl.Support Namespace See Also
Collapse All
C#
public static double op_Division(
    double a,
    double b
);
Remarks

This is op_Division, a member of class OclPsStandardOperations.

See Also
OclPsStandardOperations Class
Eco.Ocl.Support Namespace


OclPsStandardOperations.op_Division Method (int, int)

OclPsStandardOperations.op_Division Method (int, int)
OclPsStandardOperations Class Eco.Ocl.Support Namespace See Also
Collapse All
C#
public static double op_Division(
    int a,
    int b
);
Remarks

This is op_Division, a member of class OclPsStandardOperations.

See Also
OclPsStandardOperations Class
Eco.Ocl.Support Namespace


OclPsStandardOperations.op_Division Method (long, long)

OclPsStandardOperations.op_Division Method (long, long)
OclPsStandardOperations Class Eco.Ocl.Support Namespace See Also
Collapse All
C#
public static double op_Division(
    long a,
    long b
);
Remarks

This is op_Division, a member of class OclPsStandardOperations.

See Also
OclPsStandardOperations Class
Eco.Ocl.Support Namespace


op_Multiply Method

op_Multiply Method

This is the overview for the op_Multiply method overload.

Overload List
Name | Description
OclPsStandardOperations.op_Multiply (double, double) | This is op_Multiply, a member of class OclPsStandardOperations.
OclPsStandardOperations.op_Multiply (int, int) | This is op_Multiply, a member of class OclPsStandardOperations.
OclPsStandardOperations.op_Multiply (long, long) | This is op_Multiply, a member of class OclPsStandardOperations.


OclPsStandardOperations.op_Multiply Method (double, double)

OclPsStandardOperations.op_Multiply Method (double, double)
OclPsStandardOperations Class Eco.Ocl.Support Namespace See Also
Collapse All
C#
public static double op_Multiply(
    double a,
    double b
);
Remarks

This is op_Multiply, a member of class OclPsStandardOperations.

See Also
OclPsStandardOperations Class
Eco.Ocl.Support Namespace


OclPsStandardOperations.op_Multiply Method (int, int)

OclPsStandardOperations.op_Multiply Method (int, int)
OclPsStandardOperations Class Eco.Ocl.Support Namespace See Also
Collapse All
C#
public static int op_Multiply(
    int a,
    int b
);
Remarks

This is op_Multiply, a member of class OclPsStandardOperations.

See Also
OclPsStandardOperations Class
Eco.Ocl.Support Namespace


OclPsStandardOperations.op_Multiply Method (long, long)

OclPsStandardOperations.op_Multiply Method (long, long)
OclPsStandardOperations Class Eco.Ocl.Support Namespace See Also
Collapse All
C#
public static long op_Multiply(
    long a,
    long b
);
Remarks

This is op_Multiply, a member of class OclPsStandardOperations.

See Also
OclPsStandardOperations Class
Eco.Ocl.Support Namespace


op_Subtraction Method

op_Subtraction Method

This is the overview for the op_Subtraction method overload.

Overload List
Name | Description
OclPsStandardOperations.op_Subtraction (double, double) | This is op_Subtraction, a member of class OclPsStandardOperations.
OclPsStandardOperations.op_Subtraction (int, int) | This is op_Subtraction, a member of class OclPsStandardOperations.
OclPsStandardOperations.op_Subtraction (long, long) | This is op_Subtraction, a member of class OclPsStandardOperations.


OclPsStandardOperations.op_Subtraction Method (double, double)

OclPsStandardOperations.op_Subtraction Method (double, double)
OclPsStandardOperations Class Eco.Ocl.Support Namespace See Also
Collapse All
C#
public static double op_Subtraction(
    double a,
    double b
);
Remarks

This is op_Subtraction, a member of class OclPsStandardOperations.

See Also
OclPsStandardOperations Class
Eco.Ocl.Support Namespace


OclPsStandardOperations.op_Subtraction Method (int, int)

OclPsStandardOperations.op_Subtraction Method (int, int)
OclPsStandardOperations Class Eco.Ocl.Support Namespace See Also
Collapse All
C#
public static int op_Subtraction(
    int a,
    int b
);
Remarks

This is op_Subtraction, a member of class OclPsStandardOperations.

See Also
OclPsStandardOperations Class
Eco.Ocl.Support Namespace


OclPsStandardOperations.op_Subtraction Method (long, long)

OclPsStandardOperations.op_Subtraction Method (long, long)
OclPsStandardOperations Class Eco.Ocl.Support Namespace See Also
Collapse All
C#
public static long op_Subtraction(
    long a,
    long b
);
Remarks

This is op_Subtraction, a member of class OclPsStandardOperations.

See Also
OclPsStandardOperations Class
Eco.Ocl.Support Namespace


op_UnaryNegation Method

op_UnaryNegation Method

This is the overview for the op_UnaryNegation method overload.

Overload List
Name | Description
OclPsStandardOperations.op_UnaryNegation (double) | This is op_UnaryNegation, a member of class OclPsStandardOperations.
OclPsStandardOperations.op_UnaryNegation (int) | This is op_UnaryNegation, a member of class OclPsStandardOperations.
OclPsStandardOperations.op_UnaryNegation (long) | This is op_UnaryNegation, a member of class OclPsStandardOperations.


OclPsStandardOperations.op_UnaryNegation Method (double)

OclPsStandardOperations.op_UnaryNegation Method (double)
OclPsStandardOperations Class Eco.Ocl.Support Namespace See Also
Collapse All
C#
public static double op_UnaryNegation(
    double b
);
Remarks

This is op_UnaryNegation, a member of class OclPsStandardOperations.

See Also
OclPsStandardOperations Class
Eco.Ocl.Support Namespace


OclPsStandardOperations.op_UnaryNegation Method (int)

OclPsStandardOperations.op_UnaryNegation Method (int)
OclPsStandardOperations Class Eco.Ocl.Support Namespace See Also
Collapse All
C#
public static int op_UnaryNegation(
    int b
);
Remarks

This is op_UnaryNegation, a member of class OclPsStandardOperations.

See Also
OclPsStandardOperations Class
Eco.Ocl.Support Namespace


OclPsStandardOperations.op_UnaryNegation Method (long)

OclPsStandardOperations.op_UnaryNegation Method (long)
OclPsStandardOperations Class Eco.Ocl.Support Namespace See Also
Collapse All
C#
public static long op_UnaryNegation(
    long b
);
Remarks

This is op_UnaryNegation, a member of class OclPsStandardOperations.

See Also
OclPsStandardOperations Class
Eco.Ocl.Support Namespace


sum Method

sum Method

This is the overview for the sum method overload.

Overload List
Name | Description
OclPsStandardOperations.sum (IList<decimal>) | This is sum, a member of class OclPsStandardOperations.
OclPsStandardOperations.sum (IList<double>) | This is sum, a member of class OclPsStandardOperations.
OclPsStandardOperations.sum (IList<int>) | This is sum, a member of class OclPsStandardOperations.
OclPsStandardOperations.sum (IList<long>) | This is sum, a member of class OclPsStandardOperations.


OclPsStandardOperations.sum Method (IList<decimal>)

OclPsStandardOperations.sum Method (IList<decimal>)
OclPsStandardOperations Class Eco.Ocl.Support Namespace See Also
Collapse All
C#
public static decimal sum(
    IList<decimal> list
);
Remarks

This is sum, a member of class OclPsStandardOperations.

See Also
OclPsStandardOperations Class
Eco.Ocl.Support Namespace


OclPsStandardOperations.sum Method (IList<double>)

OclPsStandardOperations.sum Method (IList<double>)
OclPsStandardOperations Class Eco.Ocl.Support Namespace See Also
Collapse All
C#
public static double sum(
    IList<double> list
);
Remarks

This is sum, a member of class OclPsStandardOperations.

See Also
OclPsStandardOperations Class
Eco.Ocl.Support Namespace


OclPsStandardOperations.sum Method (IList<int>)

OclPsStandardOperations.sum Method (IList<int>)
OclPsStandardOperations Class Eco.Ocl.Support Namespace See Also
Collapse All
C#
public static int sum(
    IList<int> list
);
Remarks

This is sum, a member of class OclPsStandardOperations.

See Also
OclPsStandardOperations Class
Eco.Ocl.Support Namespace


OclPsStandardOperations.sum Method (IList<long>)

OclPsStandardOperations.sum Method (IList<long>)
OclPsStandardOperations Class Eco.Ocl.Support Namespace See Also
Collapse All
C#
public static long sum(
    IList<long> list
);
Remarks

This is sum, a member of class OclPsStandardOperations.

See Also
OclPsStandardOperations Class
Eco.Ocl.Support Namespace


OclStandardOperations Class

OclStandardOperations Class
Inheritance Hierarchy See Also
Collapse All
C#
public class OclStandardOperations;
Remarks

This is class Eco.Ocl.Support.OclStandardOperations.

Inheritance Hierarchy
Eco.Ocl.Support.OclStandardOperations
File

OclStandardOperations.cs

See Also
Inheritance Hierarchy


OclStandardOperations Methods

OclStandardOperations Methods
Public Methods
Collapse All

The methods of the OclStandardOperations class are listed here.

Public Methods
Name | Description
asCommaList | This is asCommaList, a member of class OclStandardOperations.
asSeparatedList | This is asSeparatedList, a member of class OclStandardOperations.
inDateRange | This is inDateRange, a member of class OclStandardOperations.
inTimeRange | This is inTimeRange, a member of class OclStandardOperations.
op_Addition | This is op_Addition, a member of class OclStandardOperations.
sumTime | This is sumTime, a member of class OclStandardOperations.


OclStandardOperations.asCommaList Method

OclStandardOperations.asCommaList Method
OclStandardOperations Class Eco.Ocl.Support Namespace See Also
Collapse All
C#
public static string asCommaList(
    IList<string> list
);
Remarks

This is asCommaList, a member of class OclStandardOperations.

See Also
OclStandardOperations Class
Eco.Ocl.Support Namespace


OclStandardOperations.asSeparatedList Method

OclStandardOperations.asSeparatedList Method
OclStandardOperations Class Eco.Ocl.Support Namespace See Also
Collapse All
C#
public static string asSeparatedList(
    IList<string> list,
    string separator
);
Remarks

This is asSeparatedList, a member of class OclStandardOperations.

See Also
OclStandardOperations Class
Eco.Ocl.Support Namespace


OclStandardOperations.inDateRange Method

OclStandardOperations.inDateRange Method
OclStandardOperations Class Eco.Ocl.Support Namespace See Also
Collapse All
C#
public static bool inDateRange(
    DateTime dt,
    DateTime start,
    DateTime stop
);
Remarks

This is inDateRange, a member of class OclStandardOperations.

See Also
OclStandardOperations Class
Eco.Ocl.Support Namespace


OclStandardOperations.inTimeRange Method

OclStandardOperations.inTimeRange Method
OclStandardOperations Class Eco.Ocl.Support Namespace See Also
Collapse All
C#
public static bool inTimeRange(
    TimeSpan ts,
    TimeSpan start,
    TimeSpan stop
);
Remarks

This is inTimeRange, a member of class OclStandardOperations.

See Also
OclStandardOperations Class
Eco.Ocl.Support Namespace


OclStandardOperations.op_Addition Method

OclStandardOperations.op_Addition Method
OclStandardOperations Class Eco.Ocl.Support Namespace See Also
Collapse All
C#
public static string op_Addition(
    string a,
    string b
);
Remarks

This is op_Addition, a member of class OclStandardOperations.

See Also
OclStandardOperations Class
Eco.Ocl.Support Namespace


OclStandardOperations.sumTime Method

OclStandardOperations.sumTime Method
OclStandardOperations Class Eco.Ocl.Support Namespace See Also
Collapse All
C#
public static TimeSpan sumTime(
    IList<TimeSpan> list
);
Remarks

This is sumTime, a member of class OclStandardOperations.

See Also
OclStandardOperations Class
Eco.Ocl.Support Namespace


OclStaticInstanceMethod Class

OclStaticInstanceMethod Class
Inheritance Hierarchy See Also
Collapse All
C#
public class OclStaticInstanceMethod : AbstractOclInstanceMethod;
Remarks

This is class Eco.Ocl.Support.OclStaticInstanceMethod.

Inheritance Hierarchy
Eco.Ocl.Support.IOclOperation
    Eco.Ocl.Support.OclOperationBase
        Eco.Ocl.Support.OclTypeMethod
            Eco.Ocl.Support.AbstractOclInstanceMethod
                Eco.Ocl.Support.OclStaticInstanceMethod
File

OclTypeMethods.cs

See Also
Inheritance Hierarchy


OclStaticInstanceMethod.OclStaticInstanceMethod Constructor

OclStaticInstanceMethod.OclStaticInstanceMethod Constructor
OclStaticInstanceMethod Class Eco.Ocl.Support Namespace See Also
Collapse All
C#
public OclStaticInstanceMethod(
    string name,
    MethodInfo mi,
    IClassifier[] ecoParameters,
    IClassifier returnType,
    bool isProperty,
    bool isInfix
);
Remarks

This is OclStaticInstanceMethod, a member of class OclStaticInstanceMethod.

See Also
OclStaticInstanceMethod Class
Eco.Ocl.Support Namespace


OclStaticInstanceMethod Methods

OclStaticInstanceMethod Methods
Protected Methods
Collapse All

The methods of the OclStaticInstanceMethod class are listed here.

Protected Methods
Name | Description
Init | This is Init, a member of class OclStaticInstanceMethod.
Invoke | This is Invoke, a member of class OclStaticInstanceMethod.


OclStaticInstanceMethod.Init Method

OclStaticInstanceMethod.Init Method
OclStaticInstanceMethod Class Eco.Ocl.Support Namespace See Also
Collapse All
C#
protected override void Init();
Remarks

This is Init, a member of class OclStaticInstanceMethod.

See Also
OclStaticInstanceMethod Class
Eco.Ocl.Support Namespace


OclStaticInstanceMethod.Invoke Method

OclStaticInstanceMethod.Invoke Method
OclStaticInstanceMethod Class Eco.Ocl.Support Namespace See Also
Collapse All
C#
protected override object Invoke(
    object root,
    object[] parameters
);
Remarks

This is Invoke, a member of class OclStaticInstanceMethod.

See Also
OclStaticInstanceMethod Class
Eco.Ocl.Support Namespace


OclTrigger Class

OclTrigger Class
Inheritance Hierarchy See Also
Collapse All
C#
public sealed class OclTrigger : OclMethodBase;
Remarks

This is class Eco.Ocl.Support.OclTrigger.

Inheritance Hierarchy
Eco.Ocl.Support.IOclOperation
    Eco.Ocl.Support.OclOperationBase
        Eco.Ocl.Support.OclMethodBase
            Eco.Ocl.Support.OclTrigger
File

OclMethods.cs

See Also
Inheritance Hierarchy


OclTrigger.OclTrigger Constructor

OclTrigger.OclTrigger Constructor
OclTrigger Class Eco.Ocl.Support Namespace See Also
Collapse All
C#
public OclTrigger(
    IMethod method
);
Remarks

This is OclTrigger, a member of class OclTrigger.

See Also
OclTrigger Class
Eco.Ocl.Support Namespace


OclTriggerQuery Class

OclTriggerQuery Class
Inheritance Hierarchy See Also
Collapse All
C#
public sealed class OclTriggerQuery : OclOperationBase;
Remarks

This is class Eco.Ocl.Support.OclTriggerQuery.

Inheritance Hierarchy
Eco.Ocl.Support.IOclOperation
    Eco.Ocl.Support.OclOperationBase
        Eco.Ocl.Support.OclTriggerQuery
File

OclMethods.cs

See Also
Inheritance Hierarchy


OclTriggerQuery.OclTriggerQuery Constructor

OclTriggerQuery.OclTriggerQuery Constructor
OclTriggerQuery Class Eco.Ocl.Support Namespace See Also
Collapse All
C#
public OclTriggerQuery(
    IMethod method
);
Exceptions
Exceptions | Description
ArgumentNullException | Thrown if method is null.
See Also
OclTriggerQuery Class
Eco.Ocl.Support Namespace


OclTriggerQuery Methods

OclTriggerQuery Methods
Protected Methods Public Methods
Collapse All

The methods of the OclTriggerQuery class are listed here.

Protected Methods
Name | Description
Init | This is Init, a member of class OclTriggerQuery.
Top
Public Methods
Name | Description
Evaluate |


OclTriggerQuery.Evaluate Method

OclTriggerQuery.Evaluate Method
OclTriggerQuery Class Eco.Ocl.Support Namespace See Also
Collapse All
C#
public override void Evaluate(
    IOclOperationParameters oclParameters
);
Exceptions
Exceptions | Description
ArgumentNullException | Thrown if oclParameters is null.
See Also
OclTriggerQuery Class
Eco.Ocl.Support Namespace


OclTriggerQuery.Init Method

OclTriggerQuery.Init Method
OclTriggerQuery Class Eco.Ocl.Support Namespace See Also
Collapse All
C#
protected override void Init();
Remarks

This is Init, a member of class OclTriggerQuery.

See Also
OclTriggerQuery Class
Eco.Ocl.Support Namespace


OclTypeMethod Class

OclTypeMethod Class
Inheritance Hierarchy See Also
Collapse All

Th is class can execute arbitrary methods in ocl

C#
public abstract class OclTypeMethod : OclOperationBase;
Inheritance Hierarchy
Eco.Ocl.Support.IOclOperation
    Eco.Ocl.Support.OclOperationBase
        Eco.Ocl.Support.OclTypeMethod
            Eco.Ocl.Support.AbstractOclInstanceMethod
            Eco.Ocl.Support.OclConstructorMethod
            Eco.Ocl.Support.OclInstanceField
File

OclTypeMethods.cs

See Also
Inheritance Hierarchy


OclTypeMethod.OclTypeMethod Constructor

OclTypeMethod.OclTypeMethod Constructor
OclTypeMethod Class Eco.Ocl.Support Namespace See Also
Collapse All
C#
public OclTypeMethod(
    string name,
    IClassifier[] ecoParameters,
    IClassifier returnType
);
Remarks

This is OclTypeMethod, a member of class OclTypeMethod.

See Also
OclTypeMethod Class
Eco.Ocl.Support Namespace


OclTypeMethod Fields

OclTypeMethod Fields
Protected Fields
Collapse All

The fields of the OclTypeMethod class are listed here.

Protected Fields
Name | Description
m_Name | This is m_Name, a member of class OclTypeMethod.


OclTypeMethod.m_Name Field

OclTypeMethod.m_Name Field
OclTypeMethod Class Eco.Ocl.Support Namespace See Also
Collapse All
C#
protected readonly string m_Name;
Remarks

This is m_Name, a member of class OclTypeMethod.

See Also
OclTypeMethod Class
Eco.Ocl.Support Namespace


OclTypeMethod Methods

OclTypeMethod Methods
Protected Methods Public Methods
Collapse All

The methods of the OclTypeMethod class are listed here.

Protected Methods
Name | Description
GetClrParameterType | This is the overview for the GetClrParameterType method overload.
Init | This is Init, a member of class OclTypeMethod.
Invoke | This is Invoke, a member of class OclTypeMethod.
Top
Public Methods
Name | Description
Evaluate | This method performs the actual evaluation (/execution) of the operation


OclTypeMethod.Evaluate Method

OclTypeMethod.Evaluate Method
OclTypeMethod Class Eco.Ocl.Support Namespace See Also
Collapse All

This method performs the actual evaluation (/execution) of the operation

C#
public override void Evaluate(
    IOclOperationParameters oclParameters
);
See Also
OclTypeMethod Class
Eco.Ocl.Support Namespace


GetClrParameterType Method

GetClrParameterType Method

This is the overview for the GetClrParameterType method overload.

Overload List
Name | Description
OclTypeMethod.GetClrParameterType (int) | This is GetClrParameterType, a member of class OclTypeMethod.
OclTypeMethod.GetClrParameterType (int, MethodBase) | This is GetClrParameterType, a member of class OclTypeMethod.


OclTypeMethod.GetClrParameterType Method (int)

OclTypeMethod.GetClrParameterType Method (int)
OclTypeMethod Class Eco.Ocl.Support Namespace See Also
Collapse All
C#
protected abstract Type GetClrParameterType(
    int index
);
Remarks

This is GetClrParameterType, a member of class OclTypeMethod.

See Also
OclTypeMethod Class
Eco.Ocl.Support Namespace


OclTypeMethod.GetClrParameterType Method (int, MethodBase)

OclTypeMethod.GetClrParameterType Method (int, MethodBase)
OclTypeMethod Class Eco.Ocl.Support Namespace See Also
Collapse All
C#
protected Type GetClrParameterType(
    int index,
    MethodBase method
);
Remarks

This is GetClrParameterType, a member of class OclTypeMethod.

See Also
OclTypeMethod Class
Eco.Ocl.Support Namespace


OclTypeMethod.Init Method

OclTypeMethod.Init Method
OclTypeMethod Class Eco.Ocl.Support Namespace See Also
Collapse All
C#
protected override void Init();
Remarks

This is Init, a member of class OclTypeMethod.

See Also
OclTypeMethod Class
Eco.Ocl.Support Namespace


OclTypeMethod.Invoke Method

OclTypeMethod.Invoke Method
OclTypeMethod Class Eco.Ocl.Support Namespace See Also
Collapse All
C#
protected abstract object Invoke(
    object root,
    object[] parameters
);
Remarks

This is Invoke, a member of class OclTypeMethod.

See Also
OclTypeMethod Class
Eco.Ocl.Support Namespace


OclTypeMethod Properties

OclTypeMethod Properties
Public Properties
Collapse All

The properties of the OclTypeMethod class are listed here.

Public Properties
Name | Description
EcoParameters | This is EcoParameters, a member of class OclTypeMethod.


OclTypeMethod.EcoParameters Property

OclTypeMethod.EcoParameters Property
OclTypeMethod Class Eco.Ocl.Support Namespace See Also
Collapse All
C#
public IClassifier EcoParameters;
Remarks

This is EcoParameters, a member of class OclTypeMethod.

See Also
OclTypeMethod Class
Eco.Ocl.Support Namespace


OclTypeMethodInstaller Class

OclTypeMethodInstaller Class
Inheritance Hierarchy See Also
Collapse All
C#
public class OclTypeMethodInstaller;
Remarks

This is class Eco.Ocl.Support.OclTypeMethodInstaller.

Inheritance Hierarchy
Eco.Ocl.Support.OclTypeMethodInstaller
File

OclTypeMethodInstaller.cs

See Also
Inheritance Hierarchy


OclTypeMethodInstaller.OclTypeMethodInstaller Constructor

OclTypeMethodInstaller.OclTypeMethodInstaller Constructor
OclTypeMethodInstaller Class Eco.Ocl.Support Namespace See Also
Collapse All
C#
public OclTypeMethodInstaller(
    ITypeService typeService,
    IEcoTypeSystem typeSystem
);
Remarks

This is OclTypeMethodInstaller, a member of class OclTypeMethodInstaller.

See Also
OclTypeMethodInstaller Class
Eco.Ocl.Support Namespace


OclTypeMethodInstaller Methods

OclTypeMethodInstaller Methods
Public Methods
Collapse All

The methods of the OclTypeMethodInstaller class are listed here.

Public Methods
Name | Description
GetOpSignature | This is GetOpSignature, a member of class OclTypeMethodInstaller.
InstallOperation | This is InstallOperation, a member of class OclTypeMethodInstaller.
InstallStaticMethodsForType | This is InstallStaticMethodsForType, a member of class OclTypeMethodInstaller.
InstallTypeMethods |


OclTypeMethodInstaller.GetOpSignature Method

OclTypeMethodInstaller.GetOpSignature Method
OclTypeMethodInstaller Class Eco.Ocl.Support Namespace See Also
Collapse All
C#
public static string GetOpSignature(
    IOclOperation op
);
Remarks

This is GetOpSignature, a member of class OclTypeMethodInstaller.

See Also
OclTypeMethodInstaller Class
Eco.Ocl.Support Namespace


OclTypeMethodInstaller.InstallOperation Method

OclTypeMethodInstaller.InstallOperation Method
OclTypeMethodInstaller Class Eco.Ocl.Support Namespace See Also
Collapse All
C#
public void InstallOperation(
    IOclOperation op
);
Remarks

This is InstallOperation, a member of class OclTypeMethodInstaller.

See Also
OclTypeMethodInstaller Class
Eco.Ocl.Support Namespace


OclTypeMethodInstaller.InstallStaticMethodsForType Method

OclTypeMethodInstaller.InstallStaticMethodsForType Method
OclTypeMethodInstaller Class Eco.Ocl.Support Namespace See Also
Collapse All
C#
public void InstallStaticMethodsForType(
    System.Type type
);
Remarks

This is InstallStaticMethodsForType, a member of class OclTypeMethodInstaller.

See Also
OclTypeMethodInstaller Class
Eco.Ocl.Support Namespace


OclTypeMethodInstaller.InstallTypeMethods Method

OclTypeMethodInstaller.InstallTypeMethods Method
OclTypeMethodInstaller Class Eco.Ocl.Support Namespace See Also
Collapse All
C#
public void InstallTypeMethods();
Exceptions
Exceptions | Description
ArgumentNullException | Thrown if typeSystem is null.
See Also
OclTypeMethodInstaller Class
Eco.Ocl.Support Namespace


OclTypeMethodInstaller Properties

OclTypeMethodInstaller Properties
Public Properties
Collapse All

The properties of the OclTypeMethodInstaller class are listed here.

Public Properties
Name | Description
Signatures | This is Signatures, a member of class OclTypeMethodInstaller.
TypeService | This is TypeService, a member of class OclTypeMethodInstaller.
TypeSystem | This is TypeSystem, a member of class OclTypeMethodInstaller.


OclTypeMethodInstaller.Signatures Property

OclTypeMethodInstaller.Signatures Property
OclTypeMethodInstaller Class Eco.Ocl.Support Namespace See Also
Collapse All
C#
public string Signatures;
Remarks

This is Signatures, a member of class OclTypeMethodInstaller.

See Also
OclTypeMethodInstaller Class
Eco.Ocl.Support Namespace


OclTypeMethodInstaller.TypeService Property

OclTypeMethodInstaller.TypeService Property
OclTypeMethodInstaller Class Eco.Ocl.Support Namespace See Also
Collapse All
C#
public ITypeService TypeService;
Remarks

This is TypeService, a member of class OclTypeMethodInstaller.

See Also
OclTypeMethodInstaller Class
Eco.Ocl.Support Namespace


OclTypeMethodInstaller.TypeSystem Property

OclTypeMethodInstaller.TypeSystem Property
OclTypeMethodInstaller Class Eco.Ocl.Support Namespace See Also
Collapse All
C#
public IEcoTypeSystem TypeSystem;
Remarks

This is TypeSystem, a member of class OclTypeMethodInstaller.

See Also
OclTypeMethodInstaller Class
Eco.Ocl.Support Namespace


ProxyElement Class

ProxyElement Class
Inheritance Hierarchy See Also
Collapse All
C#
public class ProxyElement : IElement;
Remarks

This is class Eco.Ocl.Support.ProxyElement.

Inheritance Hierarchy
Eco.Ocl.Support.ProxyElement
    Eco.Ocl.Support.SortElement
File

OclSupport.cs

See Also
Inheritance Hierarchy


ProxyElement.ProxyElement Constructor

ProxyElement.ProxyElement Constructor
ProxyElement Class Eco.Ocl.Support Namespace See Also
Collapse All
C#
public ProxyElement(
    IElement el
);
Remarks

This is ProxyElement, a member of class ProxyElement.

See Also
ProxyElement Class
Eco.Ocl.Support Namespace


ProxyElement Properties

ProxyElement Properties
Public Properties
Collapse All

The properties of the ProxyElement class are listed here.

Public Properties
Name | Description
ServiceProvider | This is ServiceProvider, a member of class ProxyElement.


ProxyElement.ServiceProvider Property

ProxyElement.ServiceProvider Property
ProxyElement Class Eco.Ocl.Support Namespace See Also
Collapse All
C#
public IEcoServiceProvider ServiceProvider;
Remarks

This is ServiceProvider, a member of class ProxyElement.

See Also
ProxyElement Class
Eco.Ocl.Support Namespace


SortElement Class

SortElement Class
Inheritance Hierarchy See Also
Collapse All
C#
public class SortElement : ProxyElement;
Remarks

This is class Eco.Ocl.Support.SortElement.

Inheritance Hierarchy
Eco.Ocl.Support.ProxyElement
    Eco.Ocl.Support.SortElement
File

OclSupport.cs

See Also
Inheritance Hierarchy


SortElement.SortElement Constructor

SortElement.SortElement Constructor
SortElement Class Eco.Ocl.Support Namespace See Also
Collapse All
C#
public SortElement(
    IElement el,
    OclSortDirection direction
);
Remarks

This is SortElement, a member of class SortElement.

See Also
SortElement Class
Eco.Ocl.Support Namespace


SortElement Properties

SortElement Properties
Public Properties
Collapse All

The properties of the SortElement class are listed here.

Public Properties
Name | Description
Direction | This is Direction, a member of class SortElement.


SortElement.Direction Property

SortElement.Direction Property
SortElement Class Eco.Ocl.Support Namespace See Also
Collapse All
C#
public OclSortDirection Direction;
Remarks

This is Direction, a member of class SortElement.

See Also
SortElement Class
Eco.Ocl.Support Namespace


TimerbasedDateTimeOclOperations Class

TimerbasedDateTimeOclOperations Class
Inheritance Hierarchy See Also
Collapse All
C#
public class TimerbasedDateTimeOclOperations;
Remarks

This is class Eco.Ocl.Support.TimerbasedDateTimeOclOperations.

Inheritance Hierarchy
Eco.Ocl.Support.TimerbasedDateTimeOclOperations
File

TimerbasedDateTimeOclOperations.cs

See Also
Inheritance Hierarchy


TimerbasedDateTimeOclOperations Methods

TimerbasedDateTimeOclOperations Methods
Public Methods
Collapse All

The methods of the TimerbasedDateTimeOclOperations class are listed here.

Public Methods
Name | Description
InstallOperations |


TimerbasedDateTimeOclOperations.InstallOperations Method

TimerbasedDateTimeOclOperations.InstallOperations Method
TimerbasedDateTimeOclOperations Class Eco.Ocl.Support Namespace See Also
Collapse All
C#
public static void InstallOperations(
    IEcoServiceProvider serviceProvider
);
Exceptions
Exceptions | Description
ArgumentNullException | Thrown if serviceProvider is null.
See Also
TimerbasedDateTimeOclOperations Class
Eco.Ocl.Support Namespace


TimerSubscriber Class

TimerSubscriber Class
Inheritance Hierarchy See Also
Collapse All
C#
public class TimerSubscriber;
Remarks

This is class Eco.Ocl.Support.TimerSubscriber.

Inheritance Hierarchy
Eco.Ocl.Support.TimerSubscriber
File

TimerbasedDateTimeOclOperations.cs

See Also
Inheritance Hierarchy


TimerSubscriber.TimerSubscriber Constructor

TimerSubscriber.TimerSubscriber Constructor
TimerSubscriber Class Eco.Ocl.Support Namespace See Also
Collapse All
C#
public TimerSubscriber();
Remarks

This is TimerSubscriber, a member of class TimerSubscriber.

See Also
TimerSubscriber Class
Eco.Ocl.Support Namespace


TimerSubscriber Methods

TimerSubscriber Methods
Public Methods
Collapse All

The methods of the TimerSubscriber class are listed here.

Public Methods
Name | Description
GetInstance | This is GetInstance, a member of class TimerSubscriber.
Subscribe | This is Subscribe, a member of class TimerSubscriber.


TimerSubscriber.GetInstance Method

TimerSubscriber.GetInstance Method
TimerSubscriber Class Eco.Ocl.Support Namespace See Also
Collapse All
C#
public static TimerSubscriber GetInstance();
Remarks

This is GetInstance, a member of class TimerSubscriber.

See Also
TimerSubscriber Class
Eco.Ocl.Support Namespace


TimerSubscriber.Subscribe Method

TimerSubscriber.Subscribe Method
TimerSubscriber Class Eco.Ocl.Support Namespace See Also
Collapse All
C#
public void Subscribe(
    ISubscriber subscriber,
    TimeSpan interval
);
Remarks

This is Subscribe, a member of class TimerSubscriber.

See Also
TimerSubscriber Class
Eco.Ocl.Support Namespace


TimeSpanSum Class

TimeSpanSum Class
Inheritance Hierarchy See Also
Collapse All
C#
public class TimeSpanSum : OclOperationBase;
Remarks

public class DateTimeSubtraction: OclOperationBase { public override void Evaluate(IOclOperationParameters oclParameters) { if (oclParameters == null) throw new ArgumentNullException("oclParameters"); // Unknown datetime values will default to "now" DateTime dt1 = DateTime.Now; DateTime dt2 = dt1; TimeSpan ts = TimeSpan.Zero; object o = Support.ConvertElement(FormalParameters[0], oclParameters.Values[0].Element); if (o != null) dt1 = (DateTime)o; o = Support.ConvertElement(FormalParameters[1], oclParameters.Values[1].Element); if (o != null) dt2 = (DateTime)o; ts = dt1.Subtract(dt2); oclParameters.Result.SetOwnedElement(Support.CreateNewConstant(ResultType, ts)); }

protected override void Init() { IOclType[] oclParameters = new IOclType[2]; oclParameters[0] = Support.DateTimeType; oclParameters[1] = Support.DateTimeType; InternalInit("-", oclParameters, Support.TimeSpanType);

Inheritance Hierarchy
Eco.Ocl.Support.IOclOperation
    Eco.Ocl.Support.OclOperationBase
        Eco.Ocl.Support.TimeSpanSum
File

DateTimeOclOperations.cs

See Also
Inheritance Hierarchy


TimeSpanSum Methods

TimeSpanSum Methods
Protected Methods Public Methods
Collapse All

The methods of the TimeSpanSum class are listed here.

Protected Methods
Name | Description
Init | This is Init, a member of class TimeSpanSum.
Top
Public Methods
Name | Description
Evaluate | This method performs the actual evaluation (/execution) of the operation


TimeSpanSum.Evaluate Method

TimeSpanSum.Evaluate Method
TimeSpanSum Class Eco.Ocl.Support Namespace See Also
Collapse All

This method performs the actual evaluation (/execution) of the operation

C#
public override void Evaluate(
    IOclOperationParameters oclParameters
);
See Also
TimeSpanSum Class
Eco.Ocl.Support Namespace


TimeSpanSum.Init Method

TimeSpanSum.Init Method
TimeSpanSum Class Eco.Ocl.Support Namespace See Also
Collapse All
C#
protected override void Init();
Remarks

This is Init, a member of class TimeSpanSum.

See Also
TimeSpanSum Class
Eco.Ocl.Support Namespace


IOclNamedEnumLiteral Interface

IOclNamedEnumLiteral Interface
Inheritance Hierarchy See Also
Collapse All
C#
public interface IOclNamedEnumLiteral : IOclValue;
Remarks

This is class Eco.Ocl.Support.IOclNamedEnumLiteral.

Inheritance Hierarchy
Eco.Ocl.Support.IOclValue
    Eco.Ocl.Support.IOclNamedEnumLiteral
File

OclSupport.cs

See Also
Inheritance Hierarchy


IOclNamedEnumLiteral Properties

IOclNamedEnumLiteral Properties
Public Properties
Collapse All

The properties of the IOclNamedEnumLiteral class are listed here.

Public Properties
Name | Description
Name | This is Name, a member of class IOclNamedEnumLiteral.


IOclNamedEnumLiteral.Name Property

IOclNamedEnumLiteral.Name Property
IOclNamedEnumLiteral Interface Eco.Ocl.Support Namespace See Also
Collapse All
C#
string Name;
Remarks

This is Name, a member of class IOclNamedEnumLiteral.

See Also
IOclNamedEnumLiteral Interface
Eco.Ocl.Support Namespace


IOclOperation Interface

IOclOperation Interface
Inheritance Hierarchy See Also
Collapse All

This interface is implemented by all operations that is installed in the Ocl evaluator (or Eco Action Language executor.

C#
public interface IOclOperation;
Remarks

There is a handy base implementation of this interface in Eco.Ocl.Support.OclOperationBase that can be subclassed.

Inheritance Hierarchy
Eco.Ocl.Support.IOclOperation
    Eco.Ocl.Support.OclOperationBase
File

OclSupport.cs

See Also
Inheritance Hierarchy


IOclOperation Methods

IOclOperation Methods
Public Methods
Collapse All

The methods of the IOclOperation class are listed here.

Public Methods
Name | Description
CalculateReturnType | For operations where the predefined deduce methods are not sufficient, they can specify OclResultTypeDeduceMethod.SymbolCalculated and perform their own calculation here. Default implementation in OclOperationBase is to throw an exception
Evaluate | This method performs the actual evaluation (/execution) of the operation
Initialize | This is Initialize, a member of class IOclOperation.
ResultIsReadOnly | Determines if the result of the operation is readonly based on the readonlyness of the parameters.
SemanticCheck | if the operation has custom semantic validation, it can be implemented here (OclOperationBase has an empty implemenation of this method)


IOclOperation.CalculateReturnType Method

IOclOperation.CalculateReturnType Method
IOclOperation Interface Eco.Ocl.Support Namespace See Also
Collapse All

For operations where the predefined deduce methods are not sufficient, they can specify OclResultTypeDeduceMethod.SymbolCalculated and perform their own calculation here. Default implementation in OclOperationBase is to throw an exception

C#
IOclType CalculateReturnType(
    IOclOperationParameters oclParameters
);
See Also
IOclOperation Interface
Eco.Ocl.Support Namespace


IOclOperation.Evaluate Method

IOclOperation.Evaluate Method
IOclOperation Interface Eco.Ocl.Support Namespace See Also
Collapse All

This method performs the actual evaluation (/execution) of the operation

C#
void Evaluate(
    IOclOperationParameters oclParameters
);
See Also
IOclOperation Interface
Eco.Ocl.Support Namespace


IOclOperation.Initialize Method

IOclOperation.Initialize Method
IOclOperation Interface Eco.Ocl.Support Namespace See Also
Collapse All
C#
void Initialize(
    IOclOperationSupport support
);
Remarks

This is Initialize, a member of class IOclOperation.

See Also
IOclOperation Interface
Eco.Ocl.Support Namespace


IOclOperation.ResultIsReadOnly Method

IOclOperation.ResultIsReadOnly Method
IOclOperation Interface Eco.Ocl.Support Namespace See Also
Collapse All

Determines if the result of the operation is readonly based on the readonlyness of the parameters.

C#
bool ResultIsReadOnly(
    bool[] args
);
See Also
IOclOperation Interface
Eco.Ocl.Support Namespace


IOclOperation.SemanticCheck Method

IOclOperation.SemanticCheck Method
IOclOperation Interface Eco.Ocl.Support Namespace See Also
Collapse All

if the operation has custom semantic validation, it can be implemented here (OclOperationBase has an empty implemenation of this method)

C#
void SemanticCheck(
    IOclOperationParameters oclParameters
);
See Also
IOclOperation Interface
Eco.Ocl.Support Namespace


IOclOperation Properties

IOclOperation Properties
Public Properties
Collapse All

The properties of the IOclOperation class are listed here.

Public Properties
Name | Description
ArgsNeedCommonType | Determines if the operation requires the source and the first parameter to be able to conform to each other one way or the other.
DeduceMethod | Indicates how the resulttype is calculated based on the types of the actual parameters.
FormalParameters | The type of the formal parameters. The sematic check will use this to determine if the actual parameters can be used to call this operation
IsDotNotation | If true, it means that the operation must be prefixed with a ".".
IsPostFix | True for "normal" operations. False for "infix" operations supported by the parser, such as "and", "+", etc.
IsTypeOperation | If this is true, then the operation can be applied to the type directly (corresponds to c# "static" or Delphi "class method").
ModifiesSource | This should be true if the operation has side effects on the source-parameter (such as "clear").
Name | The name of the operation.
RepeatParameters | If this value is non-zero, it means that the last x parameters can be repeated when the operation is called.
ResultType | The return type of the operation. Requires the DeduceMethod to be set to OclResultTypeDeduceMethod.ExplicitType.


IOclOperation.ArgsNeedCommonType Property

IOclOperation.ArgsNeedCommonType Property
IOclOperation Interface Eco.Ocl.Support Namespace See Also
Collapse All

Determines if the operation requires the source and the first parameter to be able to conform to each other one way or the other.

C#
bool ArgsNeedCommonType;
See Also
IOclOperation Interface
Eco.Ocl.Support Namespace


IOclOperation.DeduceMethod Property

IOclOperation.DeduceMethod Property
IOclOperation Interface Eco.Ocl.Support Namespace See Also
Collapse All

Indicates how the resulttype is calculated based on the types of the actual parameters.

C#
OclResultTypeDeduceMethod DeduceMethod;
See Also
IOclOperation Interface
Eco.Ocl.Support Namespace


IOclOperation.FormalParameters Property

IOclOperation.FormalParameters Property
IOclOperation Interface Eco.Ocl.Support Namespace See Also
Collapse All

The type of the formal parameters. The sematic check will use this to determine if the actual parameters can be used to call this operation

C#
IOclType FormalParameters;
See Also
IOclOperation Interface
Eco.Ocl.Support Namespace


IOclOperation.IsDotNotation Property

IOclOperation.IsDotNotation Property
IOclOperation Interface Eco.Ocl.Support Namespace See Also
Collapse All

If true, it means that the operation must be prefixed with a ".".

C#
bool IsDotNotation;
See Also
IOclOperation Interface
Eco.Ocl.Support Namespace


IOclOperation.IsPostFix Property

IOclOperation.IsPostFix Property
IOclOperation Interface Eco.Ocl.Support Namespace See Also
Collapse All

True for "normal" operations. False for "infix" operations supported by the parser, such as "and", "+", etc.

C#
bool IsPostFix;
See Also
IOclOperation Interface
Eco.Ocl.Support Namespace


IOclOperation.IsTypeOperation Property

IOclOperation.IsTypeOperation Property
IOclOperation Interface Eco.Ocl.Support Namespace See Also
Collapse All

If this is true, then the operation can be applied to the type directly (corresponds to c# "static" or Delphi "class method").

C#
bool IsTypeOperation;
See Also
IOclOperation Interface
Eco.Ocl.Support Namespace


IOclOperation.ModifiesSource Property

IOclOperation.ModifiesSource Property
IOclOperation Interface Eco.Ocl.Support Namespace See Also
Collapse All

This should be true if the operation has side effects on the source-parameter (such as "clear").

C#
bool ModifiesSource;
See Also
IOclOperation Interface
Eco.Ocl.Support Namespace


IOclOperation.Name Property

IOclOperation.Name Property
IOclOperation Interface Eco.Ocl.Support Namespace See Also
Collapse All

The name of the operation.

C#
string Name;
See Also
IOclOperation Interface
Eco.Ocl.Support Namespace


IOclOperation.RepeatParameters Property

IOclOperation.RepeatParameters Property
IOclOperation Interface Eco.Ocl.Support Namespace See Also
Collapse All

If this value is non-zero, it means that the last x parameters can be repeated when the operation is called.

C#
int RepeatParameters;
See Also
IOclOperation Interface
Eco.Ocl.Support Namespace


IOclOperation.ResultType Property

IOclOperation.ResultType Property
IOclOperation Interface Eco.Ocl.Support Namespace See Also
Collapse All

The return type of the operation. Requires the DeduceMethod to be set to OclResultTypeDeduceMethod.ExplicitType.

C#
IOclType ResultType;
See Also
IOclOperation Interface
Eco.Ocl.Support Namespace


IOclOperationParameters Interface

IOclOperationParameters Interface
Inheritance Hierarchy See Also
Collapse All
C#
public interface IOclOperationParameters;
Remarks

This is class Eco.Ocl.Support.IOclOperationParameters.

Inheritance Hierarchy
Eco.Ocl.Support.IOclOperationParameters
File

OclSupport.cs

See Also
Inheritance Hierarchy


IOclOperationParameters Properties

IOclOperationParameters Properties
Public Properties
Collapse All

The properties of the IOclOperationParameters class are listed here.

Public Properties
Name | Description
ParamCount | This is ParamCount, a member of class IOclOperationParameters.
Pos | This is Pos, a member of class IOclOperationParameters.
Result | This is Result, a member of class IOclOperationParameters.
SubscriberBlock | This is SubscriberBlock, a member of class IOclOperationParameters.
Values | This is Values, a member of class IOclOperationParameters.


IOclOperationParameters.ParamCount Property

IOclOperationParameters.ParamCount Property
IOclOperationParameters Interface Eco.Ocl.Support Namespace See Also
Collapse All
C#
int ParamCount;
Remarks

This is ParamCount, a member of class IOclOperationParameters.

See Also
IOclOperationParameters Interface
Eco.Ocl.Support Namespace


IOclOperationParameters.Pos Property

IOclOperationParameters.Pos Property
IOclOperationParameters Interface Eco.Ocl.Support Namespace See Also
Collapse All
C#
int Pos;
Remarks

This is Pos, a member of class IOclOperationParameters.

See Also
IOclOperationParameters Interface
Eco.Ocl.Support Namespace


IOclOperationParameters.Result Property

IOclOperationParameters.Result Property
IOclOperationParameters Interface Eco.Ocl.Support Namespace See Also
Collapse All
C#
IOclValue Result;
Remarks

This is Result, a member of class IOclOperationParameters.

See Also
IOclOperationParameters Interface
Eco.Ocl.Support Namespace


IOclOperationParameters.SubscriberBlock Property

IOclOperationParameters.SubscriberBlock Property
IOclOperationParameters Interface Eco.Ocl.Support Namespace See Also
Collapse All
C#
SubscriberPair SubscriberBlock;
Remarks

This is SubscriberBlock, a member of class IOclOperationParameters.

See Also
IOclOperationParameters Interface
Eco.Ocl.Support Namespace


IOclOperationParameters.Values Property

IOclOperationParameters.Values Property
IOclOperationParameters Interface Eco.Ocl.Support Namespace See Also
Collapse All
C#
IOclValue Values;
Remarks

This is Values, a member of class IOclOperationParameters.

See Also
IOclOperationParameters Interface
Eco.Ocl.Support Namespace


IOclOperationSupport Interface

IOclOperationSupport Interface
Inheritance Hierarchy See Also
Collapse All
C#
public interface IOclOperationSupport;
Remarks

This is class Eco.Ocl.Support.IOclOperationSupport.

Inheritance Hierarchy
Eco.Ocl.Support.IOclOperationSupport
File

OclSupport.cs

See Also
Inheritance Hierarchy


IOclOperationSupport Methods

IOclOperationSupport Methods
Public Methods
Collapse All

The methods of the IOclOperationSupport class are listed here.

Public Methods
Name | Description
ConvertElement | This is ConvertElement, a member of class IOclOperationSupport.
CreateNewConstant | constructors
CreateNewSimpleVariable | This is CreateNewSimpleVariable, a member of class IOclOperationSupport.
CreateNewVariable | This is CreateNewVariable, a member of class IOclOperationSupport.
GetAsBoolean | accessors
GetAsDateTime | This is GetAsDateTime, a member of class IOclOperationSupport.
GetAsDecimal | This is the overview for the GetAsDecimal method overload.
GetAsInt64 | This is the overview for the GetAsInt64 method overload.
GetAsInteger | This is the overview for the GetAsInteger method overload.
GetAsList | This is GetAsList, a member of class IOclOperationSupport.
GetAsNumeric | This is the overview for the GetAsNumeric method overload.
GetAsString | This is GetAsString, a member of class IOclOperationSupport.
GetAsTimeSpan | This is the overview for the GetAsTimeSpan method overload.
GetAsType | This is GetAsType, a member of class IOclOperationSupport.
GetOclTypeFor | This is GetOclTypeFor, a member of class IOclOperationSupport.
MakeNewBoolean | This is MakeNewBoolean, a member of class IOclOperationSupport.
MakeNewDateTime | This is MakeNewDateTime, a member of class IOclOperationSupport.
MakeNewDecimal | This is MakeNewDecimal, a member of class IOclOperationSupport.
MakeNewInt64 | This is MakeNewInt64, a member of class IOclOperationSupport.
MakeNewInteger | This is MakeNewInteger, a member of class IOclOperationSupport.
MakeNewNumeric | This is MakeNewNumeric, a member of class IOclOperationSupport.
MakeNewString | This is MakeNewString, a member of class IOclOperationSupport.
MakeNewTimeSpan | This is MakeNewTimeSpan, a member of class IOclOperationSupport.
TransferOrClone | other support functions


IOclOperationSupport.ConvertElement Method

IOclOperationSupport.ConvertElement Method
IOclOperationSupport Interface Eco.Ocl.Support Namespace See Also
Collapse All
C#
object ConvertElement(
    IOclType toType,
    IElement Element
);
Remarks

This is ConvertElement, a member of class IOclOperationSupport.

See Also
IOclOperationSupport Interface
Eco.Ocl.Support Namespace


IOclOperationSupport.CreateNewConstant Method

IOclOperationSupport.CreateNewConstant Method
IOclOperationSupport Interface Eco.Ocl.Support Namespace See Also
Collapse All
C#
IElement CreateNewConstant(
    IOclType type,
    object initialValue
);
Remarks

constructors

See Also
IOclOperationSupport Interface
Eco.Ocl.Support Namespace


IOclOperationSupport.CreateNewSimpleVariable Method

IOclOperationSupport.CreateNewSimpleVariable Method
IOclOperationSupport Interface Eco.Ocl.Support Namespace See Also
Collapse All
C#
IElement CreateNewSimpleVariable(
    ISimpleType type
);
Remarks

This is CreateNewSimpleVariable, a member of class IOclOperationSupport.

See Also
IOclOperationSupport Interface
Eco.Ocl.Support Namespace


IOclOperationSupport.CreateNewVariable Method

IOclOperationSupport.CreateNewVariable Method
IOclOperationSupport Interface Eco.Ocl.Support Namespace See Also
Collapse All
C#
IElement CreateNewVariable(
    IOclType type
);
Remarks

This is CreateNewVariable, a member of class IOclOperationSupport.

See Also
IOclOperationSupport Interface
Eco.Ocl.Support Namespace


IOclOperationSupport.GetAsBoolean Method

IOclOperationSupport.GetAsBoolean Method
IOclOperationSupport Interface Eco.Ocl.Support Namespace See Also
Collapse All
C#
bool GetAsBoolean(
    IOclValue node
);
Remarks

accessors

See Also
IOclOperationSupport Interface
Eco.Ocl.Support Namespace


IOclOperationSupport.GetAsDateTime Method

IOclOperationSupport.GetAsDateTime Method
IOclOperationSupport Interface Eco.Ocl.Support Namespace See Also
Collapse All
C#
DateTime GetAsDateTime(
    IOclValue node
);
Remarks

This is GetAsDateTime, a member of class IOclOperationSupport.

See Also
IOclOperationSupport Interface
Eco.Ocl.Support Namespace


GetAsDecimal Method

GetAsDecimal Method

This is the overview for the GetAsDecimal method overload.

Overload List
Name | Description
IOclOperationSupport.GetAsDecimal (IElement) | This is GetAsDecimal, a member of class IOclOperationSupport.
IOclOperationSupport.GetAsDecimal (IOclValue) | This is GetAsDecimal, a member of class IOclOperationSupport.


IOclOperationSupport.GetAsDecimal Method (IElement)

IOclOperationSupport.GetAsDecimal Method (IElement)
IOclOperationSupport Interface Eco.Ocl.Support Namespace See Also
Collapse All
C#
decimal GetAsDecimal(
    IElement element
);
Remarks

This is GetAsDecimal, a member of class IOclOperationSupport.

See Also
IOclOperationSupport Interface
Eco.Ocl.Support Namespace


IOclOperationSupport.GetAsDecimal Method (IOclValue)

IOclOperationSupport.GetAsDecimal Method (IOclValue)
IOclOperationSupport Interface Eco.Ocl.Support Namespace See Also
Collapse All
C#
decimal GetAsDecimal(
    IOclValue node
);
Remarks

This is GetAsDecimal, a member of class IOclOperationSupport.

See Also
IOclOperationSupport Interface
Eco.Ocl.Support Namespace


GetAsInt64 Method

GetAsInt64 Method

This is the overview for the GetAsInt64 method overload.

Overload List
Name | Description
IOclOperationSupport.GetAsInt64 (IElement) | This is GetAsInt64, a member of class IOclOperationSupport.
IOclOperationSupport.GetAsInt64 (IOclValue) | This is GetAsInt64, a member of class IOclOperationSupport.


IOclOperationSupport.GetAsInt64 Method (IElement)

IOclOperationSupport.GetAsInt64 Method (IElement)
IOclOperationSupport Interface Eco.Ocl.Support Namespace See Also
Collapse All
C#
long GetAsInt64(
    IElement element
);
Remarks

This is GetAsInt64, a member of class IOclOperationSupport.

See Also
IOclOperationSupport Interface
Eco.Ocl.Support Namespace


IOclOperationSupport.GetAsInt64 Method (IOclValue)

IOclOperationSupport.GetAsInt64 Method (IOclValue)
IOclOperationSupport Interface Eco.Ocl.Support Namespace See Also
Collapse All
C#
long GetAsInt64(
    IOclValue Node
);
Remarks

This is GetAsInt64, a member of class IOclOperationSupport.

See Also
IOclOperationSupport Interface
Eco.Ocl.Support Namespace


GetAsInteger Method

GetAsInteger Method

This is the overview for the GetAsInteger method overload.

Overload List
Name | Description
IOclOperationSupport.GetAsInteger (IElement) | This is GetAsInteger, a member of class IOclOperationSupport.
IOclOperationSupport.GetAsInteger (IOclValue) | This is GetAsInteger, a member of class IOclOperationSupport.


IOclOperationSupport.GetAsInteger Method (IElement)

IOclOperationSupport.GetAsInteger Method (IElement)
IOclOperationSupport Interface Eco.Ocl.Support Namespace See Also
Collapse All
C#
int GetAsInteger(
    IElement element
);
Remarks

This is GetAsInteger, a member of class IOclOperationSupport.

See Also
IOclOperationSupport Interface
Eco.Ocl.Support Namespace


IOclOperationSupport.GetAsInteger Method (IOclValue)

IOclOperationSupport.GetAsInteger Method (IOclValue)
IOclOperationSupport Interface Eco.Ocl.Support Namespace See Also
Collapse All
C#
int GetAsInteger(
    IOclValue node
);
Remarks

This is GetAsInteger, a member of class IOclOperationSupport.

See Also
IOclOperationSupport Interface
Eco.Ocl.Support Namespace


IOclOperationSupport.GetAsList Method

IOclOperationSupport.GetAsList Method
IOclOperationSupport Interface Eco.Ocl.Support Namespace See Also
Collapse All
C#
IElementCollection GetAsList(
    IOclValue node
);
Remarks

This is GetAsList, a member of class IOclOperationSupport.

See Also
IOclOperationSupport Interface
Eco.Ocl.Support Namespace


GetAsNumeric Method

GetAsNumeric Method

This is the overview for the GetAsNumeric method overload.

Overload List
Name | Description
IOclOperationSupport.GetAsNumeric (IElement) | This is GetAsNumeric, a member of class IOclOperationSupport.
IOclOperationSupport.GetAsNumeric (IOclValue) | This is GetAsNumeric, a member of class IOclOperationSupport.


IOclOperationSupport.GetAsNumeric Method (IElement)

IOclOperationSupport.GetAsNumeric Method (IElement)
IOclOperationSupport Interface Eco.Ocl.Support Namespace See Also
Collapse All
C#
double GetAsNumeric(
    IElement element
);
Remarks

This is GetAsNumeric, a member of class IOclOperationSupport.

See Also
IOclOperationSupport Interface
Eco.Ocl.Support Namespace


IOclOperationSupport.GetAsNumeric Method (IOclValue)

IOclOperationSupport.GetAsNumeric Method (IOclValue)
IOclOperationSupport Interface Eco.Ocl.Support Namespace See Also
Collapse All
C#
double GetAsNumeric(
    IOclValue node
);
Remarks

This is GetAsNumeric, a member of class IOclOperationSupport.

See Also
IOclOperationSupport Interface
Eco.Ocl.Support Namespace


IOclOperationSupport.GetAsString Method

IOclOperationSupport.GetAsString Method
IOclOperationSupport Interface Eco.Ocl.Support Namespace See Also
Collapse All
C#
string GetAsString(
    IOclValue node
);
Remarks

This is GetAsString, a member of class IOclOperationSupport.

See Also
IOclOperationSupport Interface
Eco.Ocl.Support Namespace


GetAsTimeSpan Method

GetAsTimeSpan Method

This is the overview for the GetAsTimeSpan method overload.

Overload List
Name | Description
IOclOperationSupport.GetAsTimeSpan (IElement) | This is GetAsTimeSpan, a member of class IOclOperationSupport.
IOclOperationSupport.GetAsTimeSpan (IOclValue) | This is GetAsTimeSpan, a member of class IOclOperationSupport.


IOclOperationSupport.GetAsTimeSpan Method (IElement)

IOclOperationSupport.GetAsTimeSpan Method (IElement)
IOclOperationSupport Interface Eco.Ocl.Support Namespace See Also
Collapse All
C#
TimeSpan GetAsTimeSpan(
    IElement element
);
Remarks

This is GetAsTimeSpan, a member of class IOclOperationSupport.

See Also
IOclOperationSupport Interface
Eco.Ocl.Support Namespace


IOclOperationSupport.GetAsTimeSpan Method (IOclValue)

IOclOperationSupport.GetAsTimeSpan Method (IOclValue)
IOclOperationSupport Interface Eco.Ocl.Support Namespace See Also
Collapse All
C#
TimeSpan GetAsTimeSpan(
    IOclValue node
);
Remarks

This is GetAsTimeSpan, a member of class IOclOperationSupport.

See Also
IOclOperationSupport Interface
Eco.Ocl.Support Namespace


IOclOperationSupport.GetAsType Method

IOclOperationSupport.GetAsType Method
IOclOperationSupport Interface Eco.Ocl.Support Namespace See Also
Collapse All
C#
IClassifier GetAsType(
    IOclValue bode
);
Remarks

This is GetAsType, a member of class IOclOperationSupport.

See Also
IOclOperationSupport Interface
Eco.Ocl.Support Namespace


IOclOperationSupport.GetOclTypeFor Method

IOclOperationSupport.GetOclTypeFor Method
IOclOperationSupport Interface Eco.Ocl.Support Namespace See Also
Collapse All
C#
IOclType GetOclTypeFor(
    IClassifier classifier
);
Remarks

This is GetOclTypeFor, a member of class IOclOperationSupport.

See Also
IOclOperationSupport Interface
Eco.Ocl.Support Namespace


IOclOperationSupport.MakeNewBoolean Method

IOclOperationSupport.MakeNewBoolean Method
IOclOperationSupport Interface Eco.Ocl.Support Namespace See Also
Collapse All
C#
void MakeNewBoolean(
    IOclValue node,
    bool value
);
Remarks

This is MakeNewBoolean, a member of class IOclOperationSupport.

See Also
IOclOperationSupport Interface
Eco.Ocl.Support Namespace


IOclOperationSupport.MakeNewDateTime Method

IOclOperationSupport.MakeNewDateTime Method
IOclOperationSupport Interface Eco.Ocl.Support Namespace See Also
Collapse All
C#
void MakeNewDateTime(
    IOclValue node,
    DateTime value
);
Remarks

This is MakeNewDateTime, a member of class IOclOperationSupport.

See Also
IOclOperationSupport Interface
Eco.Ocl.Support Namespace


IOclOperationSupport.MakeNewDecimal Method

IOclOperationSupport.MakeNewDecimal Method
IOclOperationSupport Interface Eco.Ocl.Support Namespace See Also
Collapse All
C#
void MakeNewDecimal(
    IOclValue node,
    decimal value
);
Remarks

This is MakeNewDecimal, a member of class IOclOperationSupport.

See Also
IOclOperationSupport Interface
Eco.Ocl.Support Namespace


IOclOperationSupport.MakeNewInt64 Method

IOclOperationSupport.MakeNewInt64 Method
IOclOperationSupport Interface Eco.Ocl.Support Namespace See Also
Collapse All
C#
void MakeNewInt64(
    IOclValue node,
    long value
);
Remarks

This is MakeNewInt64, a member of class IOclOperationSupport.

See Also
IOclOperationSupport Interface
Eco.Ocl.Support Namespace


IOclOperationSupport.MakeNewInteger Method

IOclOperationSupport.MakeNewInteger Method
IOclOperationSupport Interface Eco.Ocl.Support Namespace See Also
Collapse All
C#
void MakeNewInteger(
    IOclValue node,
    int value
);
Remarks

This is MakeNewInteger, a member of class IOclOperationSupport.

See Also
IOclOperationSupport Interface
Eco.Ocl.Support Namespace


IOclOperationSupport.MakeNewNumeric Method

IOclOperationSupport.MakeNewNumeric Method
IOclOperationSupport Interface Eco.Ocl.Support Namespace See Also
Collapse All
C#
void MakeNewNumeric(
    IOclValue node,
    double value
);
Remarks

This is MakeNewNumeric, a member of class IOclOperationSupport.

See Also
IOclOperationSupport Interface
Eco.Ocl.Support Namespace


IOclOperationSupport.MakeNewString Method

IOclOperationSupport.MakeNewString Method
IOclOperationSupport Interface Eco.Ocl.Support Namespace See Also
Collapse All
C#
void MakeNewString(
    IOclValue node,
    string value
);
Remarks

This is MakeNewString, a member of class IOclOperationSupport.

See Also
IOclOperationSupport Interface
Eco.Ocl.Support Namespace


IOclOperationSupport.MakeNewTimeSpan Method

IOclOperationSupport.MakeNewTimeSpan Method
IOclOperationSupport Interface Eco.Ocl.Support Namespace See Also
Collapse All
C#
void MakeNewTimeSpan(
    IOclValue node,
    TimeSpan value
);
Remarks

This is MakeNewTimeSpan, a member of class IOclOperationSupport.

See Also
IOclOperationSupport Interface
Eco.Ocl.Support Namespace


IOclOperationSupport.TransferOrClone Method

IOclOperationSupport.TransferOrClone Method
IOclOperationSupport Interface Eco.Ocl.Support Namespace See Also
Collapse All
C#
void TransferOrClone(
    IOclValue source,
    IOclValue dest
);
Remarks

other support functions

See Also
IOclOperationSupport Interface
Eco.Ocl.Support Namespace


IOclOperationSupport Properties

IOclOperationSupport Properties
Public Properties
Collapse All

The properties of the IOclOperationSupport class are listed here.

Public Properties
Name | Description
AnyType | This is AnyType, a member of class IOclOperationSupport.
AutoSubscriptionService | This is AutoSubscriptionService, a member of class IOclOperationSupport.
BooleanType | This is BooleanType, a member of class IOclOperationSupport.
ByteType | This is ByteType, a member of class IOclOperationSupport.
ConstraintListType | This is ConstraintListType, a member of class IOclOperationSupport.
DateTimeListType | This is DateTimeListType, a member of class IOclOperationSupport.
DateTimeType | This is DateTimeType, a member of class IOclOperationSupport.
DecimalListType | This is DecimalListType, a member of class IOclOperationSupport.
DecimalType | This is DecimalType, a member of class IOclOperationSupport.
EnumLiteralType | This is EnumLiteralType, a member of class IOclOperationSupport.
ExtentService | This is ExtentService, a member of class IOclOperationSupport.
ExternalIdService | This is ExternalIdService, a member of class IOclOperationSupport.
Int16Type | This is Int16Type, a member of class IOclOperationSupport.
Int64ListType | This is Int64ListType, a member of class IOclOperationSupport.
Int64Type | This is Int64Type, a member of class IOclOperationSupport.
IntegerListType | This is IntegerListType, a member of class IOclOperationSupport.
IntegerType | This is IntegerType, a member of class IOclOperationSupport.
ListType | This is ListType, a member of class IOclOperationSupport.
Model | predefined types
NumericListType | This is NumericListType, a member of class IOclOperationSupport.
ObjectFactory | This is ObjectFactory, a member of class IOclOperationSupport.
ObjectListType | This is ObjectListType, a member of class IOclOperationSupport.
ObjectType | This is ObjectType, a member of class IOclOperationSupport.
OclService | This is OclService, a member of class IOclOperationSupport.
OclSortDirection | This is OclSortDirection, a member of class IOclOperationSupport.
PersistenceService | This is PersistenceService, a member of class IOclOperationSupport.
RealType | This is RealType, a member of class IOclOperationSupport.
SByteType | This is SByteType, a member of class IOclOperationSupport.
ServiceProvider | This is ServiceProvider, a member of class IOclOperationSupport.
StringListType | This is StringListType, a member of class IOclOperationSupport.
StringType | This is StringType, a member of class IOclOperationSupport.
TimeSpanListType | This is TimeSpanListType, a member of class IOclOperationSupport.
TimeSpanType | This is TimeSpanType, a member of class IOclOperationSupport.
TypeType | This is TypeType, a member of class IOclOperationSupport.
UInt16Type | This is UInt16Type, a member of class IOclOperationSupport.
UndoService | This is UndoService, a member of class IOclOperationSupport.
VariableFactory | services
VersionService | This is VersionService, a member of class IOclOperationSupport.


IOclOperationSupport.AnyType Property

IOclOperationSupport.AnyType Property
IOclOperationSupport Interface Eco.Ocl.Support Namespace See Also
Collapse All
C#
IOclType AnyType;
Remarks

This is AnyType, a member of class IOclOperationSupport.

See Also
IOclOperationSupport Interface
Eco.Ocl.Support Namespace


IOclOperationSupport.AutoSubscriptionService Property

IOclOperationSupport.AutoSubscriptionService Property
IOclOperationSupport Interface Eco.Ocl.Support Namespace See Also
Collapse All
C#
IAutoSubscriptionService AutoSubscriptionService;
Remarks

This is AutoSubscriptionService, a member of class IOclOperationSupport.

See Also
IOclOperationSupport Interface
Eco.Ocl.Support Namespace


IOclOperationSupport.BooleanType Property

IOclOperationSupport.BooleanType Property
IOclOperationSupport Interface Eco.Ocl.Support Namespace See Also
Collapse All
C#
IOclType BooleanType;
Remarks

This is BooleanType, a member of class IOclOperationSupport.

See Also
IOclOperationSupport Interface
Eco.Ocl.Support Namespace


IOclOperationSupport.ByteType Property

IOclOperationSupport.ByteType Property
IOclOperationSupport Interface Eco.Ocl.Support Namespace See Also
Collapse All
C#
IOclType ByteType;
Remarks

This is ByteType, a member of class IOclOperationSupport.

See Also
IOclOperationSupport Interface
Eco.Ocl.Support Namespace


IOclOperationSupport.ConstraintListType Property

IOclOperationSupport.ConstraintListType Property
IOclOperationSupport Interface Eco.Ocl.Support Namespace See Also
Collapse All
C#
IOclType ConstraintListType;
Remarks

This is ConstraintListType, a member of class IOclOperationSupport.

See Also
IOclOperationSupport Interface
Eco.Ocl.Support Namespace


IOclOperationSupport.DateTimeListType Property

IOclOperationSupport.DateTimeListType Property
IOclOperationSupport Interface Eco.Ocl.Support Namespace See Also
Collapse All
C#
IOclType DateTimeListType;
Remarks

This is DateTimeListType, a member of class IOclOperationSupport.

See Also
IOclOperationSupport Interface
Eco.Ocl.Support Namespace


IOclOperationSupport.DateTimeType Property

IOclOperationSupport.DateTimeType Property
IOclOperationSupport Interface Eco.Ocl.Support Namespace See Also
Collapse All
C#
IOclType DateTimeType;
Remarks

This is DateTimeType, a member of class IOclOperationSupport.

See Also
IOclOperationSupport Interface
Eco.Ocl.Support Namespace


IOclOperationSupport.DecimalListType Property

IOclOperationSupport.DecimalListType Property
IOclOperationSupport Interface Eco.Ocl.Support Namespace See Also
Collapse All
C#
IOclType DecimalListType;
Remarks

This is DecimalListType, a member of class IOclOperationSupport.

See Also
IOclOperationSupport Interface
Eco.Ocl.Support Namespace


IOclOperationSupport.DecimalType Property

IOclOperationSupport.DecimalType Property
IOclOperationSupport Interface Eco.Ocl.Support Namespace See Also
Collapse All
C#
IOclType DecimalType;
Remarks

This is DecimalType, a member of class IOclOperationSupport.

See Also
IOclOperationSupport Interface
Eco.Ocl.Support Namespace


IOclOperationSupport.EnumLiteralType Property

IOclOperationSupport.EnumLiteralType Property
IOclOperationSupport Interface Eco.Ocl.Support Namespace See Also
Collapse All
C#
IOclType EnumLiteralType;
Remarks

This is EnumLiteralType, a member of class IOclOperationSupport.

See Also
IOclOperationSupport Interface
Eco.Ocl.Support Namespace


IOclOperationSupport.ExtentService Property

IOclOperationSupport.ExtentService Property
IOclOperationSupport Interface Eco.Ocl.Support Namespace See Also
Collapse All
C#
IExtentService ExtentService;
Remarks

This is ExtentService, a member of class IOclOperationSupport.

See Also
IOclOperationSupport Interface
Eco.Ocl.Support Namespace


IOclOperationSupport.ExternalIdService Property

IOclOperationSupport.ExternalIdService Property
IOclOperationSupport Interface Eco.Ocl.Support Namespace See Also
Collapse All
C#
IExternalIdService ExternalIdService;
Remarks

This is ExternalIdService, a member of class IOclOperationSupport.

See Also
IOclOperationSupport Interface
Eco.Ocl.Support Namespace


IOclOperationSupport.Int16Type Property

IOclOperationSupport.Int16Type Property
IOclOperationSupport Interface Eco.Ocl.Support Namespace See Also
Collapse All
C#
IOclType Int16Type;
Remarks

This is Int16Type, a member of class IOclOperationSupport.

See Also
IOclOperationSupport Interface
Eco.Ocl.Support Namespace


IOclOperationSupport.Int64ListType Property

IOclOperationSupport.Int64ListType Property
IOclOperationSupport Interface Eco.Ocl.Support Namespace See Also
Collapse All
C#
IOclType Int64ListType;
Remarks

This is Int64ListType, a member of class IOclOperationSupport.

See Also
IOclOperationSupport Interface
Eco.Ocl.Support Namespace


IOclOperationSupport.Int64Type Property

IOclOperationSupport.Int64Type Property
IOclOperationSupport Interface Eco.Ocl.Support Namespace See Also
Collapse All
C#
IOclType Int64Type;
Remarks

This is Int64Type, a member of class IOclOperationSupport.

See Also
IOclOperationSupport Interface
Eco.Ocl.Support Namespace


IOclOperationSupport.IntegerListType Property

IOclOperationSupport.IntegerListType Property
IOclOperationSupport Interface Eco.Ocl.Support Namespace See Also
Collapse All
C#
IOclType IntegerListType;
Remarks

This is IntegerListType, a member of class IOclOperationSupport.

See Also
IOclOperationSupport Interface
Eco.Ocl.Support Namespace


IOclOperationSupport.IntegerType Property

IOclOperationSupport.IntegerType Property
IOclOperationSupport Interface Eco.Ocl.Support Namespace See Also
Collapse All
C#
IOclType IntegerType;
Remarks

This is IntegerType, a member of class IOclOperationSupport.

See Also
IOclOperationSupport Interface
Eco.Ocl.Support Namespace


IOclOperationSupport.ListType Property

IOclOperationSupport.ListType Property
IOclOperationSupport Interface Eco.Ocl.Support Namespace See Also
Collapse All
C#
IOclType ListType;
Remarks

This is ListType, a member of class IOclOperationSupport.

See Also
IOclOperationSupport Interface
Eco.Ocl.Support Namespace


IOclOperationSupport.Model Property

IOclOperationSupport.Model Property
IOclOperationSupport Interface Eco.Ocl.Support Namespace See Also
Collapse All
C#
IEcoTypeSystem Model;
Remarks

predefined types

See Also
IOclOperationSupport Interface
Eco.Ocl.Support Namespace


IOclOperationSupport.NumericListType Property

IOclOperationSupport.NumericListType Property
IOclOperationSupport Interface Eco.Ocl.Support Namespace See Also
Collapse All
C#
IOclType NumericListType;
Remarks

This is NumericListType, a member of class IOclOperationSupport.

See Also
IOclOperationSupport Interface
Eco.Ocl.Support Namespace


IOclOperationSupport.ObjectFactory Property

IOclOperationSupport.ObjectFactory Property
IOclOperationSupport Interface Eco.Ocl.Support Namespace See Also
Collapse All
C#
IObjectFactoryService ObjectFactory;
Remarks

This is ObjectFactory, a member of class IOclOperationSupport.

See Also
IOclOperationSupport Interface
Eco.Ocl.Support Namespace


IOclOperationSupport.ObjectListType Property

IOclOperationSupport.ObjectListType Property
IOclOperationSupport Interface Eco.Ocl.Support Namespace See Also
Collapse All
C#
IOclType ObjectListType;
Remarks

This is ObjectListType, a member of class IOclOperationSupport.

See Also
IOclOperationSupport Interface
Eco.Ocl.Support Namespace


IOclOperationSupport.ObjectType Property

IOclOperationSupport.ObjectType Property
IOclOperationSupport Interface Eco.Ocl.Support Namespace See Also
Collapse All
C#
IOclType ObjectType;
Remarks

This is ObjectType, a member of class IOclOperationSupport.

See Also
IOclOperationSupport Interface
Eco.Ocl.Support Namespace


IOclOperationSupport.OclService Property

IOclOperationSupport.OclService Property
IOclOperationSupport Interface Eco.Ocl.Support Namespace See Also
Collapse All
C#
IOclService OclService;
Remarks

This is OclService, a member of class IOclOperationSupport.

See Also
IOclOperationSupport Interface
Eco.Ocl.Support Namespace


IOclOperationSupport.OclSortDirection Property

IOclOperationSupport.OclSortDirection Property
IOclOperationSupport Interface Eco.Ocl.Support Namespace See Also
Collapse All
C#
IOclType OclSortDirection;
Remarks

This is OclSortDirection, a member of class IOclOperationSupport.

See Also
IOclOperationSupport Interface
Eco.Ocl.Support Namespace


IOclOperationSupport.PersistenceService Property

IOclOperationSupport.PersistenceService Property
IOclOperationSupport Interface Eco.Ocl.Support Namespace See Also
Collapse All
C#
IPersistenceService PersistenceService;
Remarks

This is PersistenceService, a member of class IOclOperationSupport.

See Also
IOclOperationSupport Interface
Eco.Ocl.Support Namespace


IOclOperationSupport.RealType Property

IOclOperationSupport.RealType Property
IOclOperationSupport Interface Eco.Ocl.Support Namespace See Also
Collapse All
C#
IOclType RealType;
Remarks

This is RealType, a member of class IOclOperationSupport.

See Also
IOclOperationSupport Interface
Eco.Ocl.Support Namespace


IOclOperationSupport.SByteType Property

IOclOperationSupport.SByteType Property
IOclOperationSupport Interface Eco.Ocl.Support Namespace See Also
Collapse All
C#
IOclType SByteType;
Remarks

This is SByteType, a member of class IOclOperationSupport.

See Also
IOclOperationSupport Interface
Eco.Ocl.Support Namespace


IOclOperationSupport.ServiceProvider Property

IOclOperationSupport.ServiceProvider Property
IOclOperationSupport Interface Eco.Ocl.Support Namespace See Also
Collapse All
C#
IEcoServiceProvider ServiceProvider;
Remarks

This is ServiceProvider, a member of class IOclOperationSupport.

See Also
IOclOperationSupport Interface
Eco.Ocl.Support Namespace


IOclOperationSupport.StringListType Property

IOclOperationSupport.StringListType Property
IOclOperationSupport Interface Eco.Ocl.Support Namespace See Also
Collapse All
C#
IOclType StringListType;
Remarks

This is StringListType, a member of class IOclOperationSupport.

See Also
IOclOperationSupport Interface
Eco.Ocl.Support Namespace


IOclOperationSupport.StringType Property

IOclOperationSupport.StringType Property
IOclOperationSupport Interface Eco.Ocl.Support Namespace See Also
Collapse All
C#
IOclType StringType;
Remarks

This is StringType, a member of class IOclOperationSupport.

See Also
IOclOperationSupport Interface
Eco.Ocl.Support Namespace


IOclOperationSupport.TimeSpanListType Property

IOclOperationSupport.TimeSpanListType Property
IOclOperationSupport Interface Eco.Ocl.Support Namespace See Also
Collapse All
C#
IOclType TimeSpanListType;
Remarks

This is TimeSpanListType, a member of class IOclOperationSupport.

See Also
IOclOperationSupport Interface
Eco.Ocl.Support Namespace


IOclOperationSupport.TimeSpanType Property

IOclOperationSupport.TimeSpanType Property
IOclOperationSupport Interface Eco.Ocl.Support Namespace See Also
Collapse All
C#
IOclType TimeSpanType;
Remarks

This is TimeSpanType, a member of class IOclOperationSupport.

See Also
IOclOperationSupport Interface
Eco.Ocl.Support Namespace


IOclOperationSupport.TypeType Property

IOclOperationSupport.TypeType Property
IOclOperationSupport Interface Eco.Ocl.Support Namespace See Also
Collapse All
C#
IOclType TypeType;
Remarks

This is TypeType, a member of class IOclOperationSupport.

See Also
IOclOperationSupport Interface
Eco.Ocl.Support Namespace


IOclOperationSupport.UInt16Type Property

IOclOperationSupport.UInt16Type Property
IOclOperationSupport Interface Eco.Ocl.Support Namespace See Also
Collapse All
C#
IOclType UInt16Type;
Remarks

This is UInt16Type, a member of class IOclOperationSupport.

See Also
IOclOperationSupport Interface
Eco.Ocl.Support Namespace


IOclOperationSupport.UndoService Property

IOclOperationSupport.UndoService Property
IOclOperationSupport Interface Eco.Ocl.Support Namespace See Also
Collapse All
C#
IUndoService UndoService;
Remarks

This is UndoService, a member of class IOclOperationSupport.

See Also
IOclOperationSupport Interface
Eco.Ocl.Support Namespace


IOclOperationSupport.VariableFactory Property

IOclOperationSupport.VariableFactory Property
IOclOperationSupport Interface Eco.Ocl.Support Namespace See Also
Collapse All
C#
IVariableFactoryService VariableFactory;
Remarks

services

See Also
IOclOperationSupport Interface
Eco.Ocl.Support Namespace


IOclOperationSupport.VersionService Property

IOclOperationSupport.VersionService Property
IOclOperationSupport Interface Eco.Ocl.Support Namespace See Also
Collapse All
C#
IVersionService VersionService;
Remarks

This is VersionService, a member of class IOclOperationSupport.

See Also
IOclOperationSupport Interface
Eco.Ocl.Support Namespace


IOclType Interface

IOclType Interface
Inheritance Hierarchy See Also
Collapse All
C#
public interface IOclType;
Remarks

This is class Eco.Ocl.Support.IOclType.

Inheritance Hierarchy
Eco.Ocl.Support.IOclType
File

OclSupport.cs

See Also
Inheritance Hierarchy


IOclType Methods

IOclType Methods
Public Methods
Collapse All

The methods of the IOclType class are listed here.

Public Methods
Name | Description
BagType | This is BagType, a member of class IOclType.
ConformsTo | This is ConformsTo, a member of class IOclType.
HasUmlType | This is HasUmlType, a member of class IOclType.
IsEnumType | This is IsEnumType, a member of class IOclType.
IsFeaturedType | This is IsFeaturedType, a member of class IOclType.
IsListType | This is IsListType, a member of class IOclType.
IsObjectListType | This is IsObjectListType, a member of class IOclType.
IsObjectType | This is IsObjectType, a member of class IOclType.
IsPrimitiveType | This is IsPrimitiveType, a member of class IOclType.
IsSameType | This is IsSameType, a member of class IOclType.
IsSimpleType | This is IsSimpleType, a member of class IOclType.
LeastCommonType | This is LeastCommonType, a member of class IOclType.
Name | This is Name, a member of class IOclType.
OrderedSetType | This is OrderedSetType, a member of class IOclType.
SequenceType | This is SequenceType, a member of class IOclType.
SetType | This is SetType, a member of class IOclType.


IOclType.BagType Method

IOclType.BagType Method
IOclType Interface Eco.Ocl.Support Namespace See Also
Collapse All
C#
IOclType BagType();
Remarks

This is BagType, a member of class IOclType.

See Also
IOclType Interface
Eco.Ocl.Support Namespace


IOclType.ConformsTo Method

IOclType.ConformsTo Method
IOclType Interface Eco.Ocl.Support Namespace See Also
Collapse All
C#
bool ConformsTo(
    IOclType oclType
);
Remarks

This is ConformsTo, a member of class IOclType.

See Also
IOclType Interface
Eco.Ocl.Support Namespace


IOclType.HasUmlType Method

IOclType.HasUmlType Method
IOclType Interface Eco.Ocl.Support Namespace See Also
Collapse All
C#
bool HasUmlType();
Remarks

This is HasUmlType, a member of class IOclType.

See Also
IOclType Interface
Eco.Ocl.Support Namespace


IOclType.IsEnumType Method

IOclType.IsEnumType Method
IOclType Interface Eco.Ocl.Support Namespace See Also
Collapse All
C#
bool IsEnumType();
Remarks

This is IsEnumType, a member of class IOclType.

See Also
IOclType Interface
Eco.Ocl.Support Namespace


IOclType.IsFeaturedType Method

IOclType.IsFeaturedType Method
IOclType Interface Eco.Ocl.Support Namespace See Also
Collapse All
C#
bool IsFeaturedType();
Remarks

This is IsFeaturedType, a member of class IOclType.

See Also
IOclType Interface
Eco.Ocl.Support Namespace


IOclType.IsListType Method

IOclType.IsListType Method
IOclType Interface Eco.Ocl.Support Namespace See Also
Collapse All
C#
bool IsListType();
Remarks

This is IsListType, a member of class IOclType.

See Also
IOclType Interface
Eco.Ocl.Support Namespace


IOclType.IsObjectListType Method

IOclType.IsObjectListType Method
IOclType Interface Eco.Ocl.Support Namespace See Also
Collapse All
C#
bool IsObjectListType();
Remarks

This is IsObjectListType, a member of class IOclType.

See Also
IOclType Interface
Eco.Ocl.Support Namespace


IOclType.IsObjectType Method

IOclType.IsObjectType Method
IOclType Interface Eco.Ocl.Support Namespace See Also
Collapse All
C#
bool IsObjectType();
Remarks

This is IsObjectType, a member of class IOclType.

See Also
IOclType Interface
Eco.Ocl.Support Namespace


IOclType.IsPrimitiveType Method

IOclType.IsPrimitiveType Method
IOclType Interface Eco.Ocl.Support Namespace See Also
Collapse All
C#
bool IsPrimitiveType();
Remarks

This is IsPrimitiveType, a member of class IOclType.

See Also
IOclType Interface
Eco.Ocl.Support Namespace


IOclType.IsSameType Method

IOclType.IsSameType Method
IOclType Interface Eco.Ocl.Support Namespace See Also
Collapse All
C#
bool IsSameType(
    IOclType oclType
);
Remarks

This is IsSameType, a member of class IOclType.

See Also
IOclType Interface
Eco.Ocl.Support Namespace


IOclType.IsSimpleType Method

IOclType.IsSimpleType Method
IOclType Interface Eco.Ocl.Support Namespace See Also
Collapse All
C#
bool IsSimpleType();
Remarks

This is IsSimpleType, a member of class IOclType.

See Also
IOclType Interface
Eco.Ocl.Support Namespace


IOclType.LeastCommonType Method

IOclType.LeastCommonType Method
IOclType Interface Eco.Ocl.Support Namespace See Also
Collapse All
C#
IOclType LeastCommonType(
    IOclType oclType
);
Remarks

This is LeastCommonType, a member of class IOclType.

See Also
IOclType Interface
Eco.Ocl.Support Namespace


IOclType.Name Method

IOclType.Name Method
IOclType Interface Eco.Ocl.Support Namespace See Also
Collapse All
C#
string Name();
Remarks

This is Name, a member of class IOclType.

See Also
IOclType Interface
Eco.Ocl.Support Namespace


IOclType.OrderedSetType Method

IOclType.OrderedSetType Method
IOclType Interface Eco.Ocl.Support Namespace See Also
Collapse All
C#
IOclType OrderedSetType();
Remarks

This is OrderedSetType, a member of class IOclType.

See Also
IOclType Interface
Eco.Ocl.Support Namespace


IOclType.SequenceType Method

IOclType.SequenceType Method
IOclType Interface Eco.Ocl.Support Namespace See Also
Collapse All
C#
IOclType SequenceType();
Remarks

This is SequenceType, a member of class IOclType.

See Also
IOclType Interface
Eco.Ocl.Support Namespace


IOclType.SetType Method

IOclType.SetType Method
IOclType Interface Eco.Ocl.Support Namespace See Also
Collapse All
C#
IOclType SetType();
Remarks

This is SetType, a member of class IOclType.

See Also
IOclType Interface
Eco.Ocl.Support Namespace


IOclType Properties

IOclType Properties
Public Properties
Collapse All

The properties of the IOclType class are listed here.

Public Properties
Name | Description
CollectionType | This is CollectionType, a member of class IOclType.
ElementType | This is ElementType, a member of class IOclType.
UMLType | This is UMLType, a member of class IOclType.


IOclType.CollectionType Property

IOclType.CollectionType Property
IOclType Interface Eco.Ocl.Support Namespace See Also
Collapse All
C#
IOclType CollectionType;
Remarks

This is CollectionType, a member of class IOclType.

See Also
IOclType Interface
Eco.Ocl.Support Namespace


IOclType.ElementType Property

IOclType.ElementType Property
IOclType Interface Eco.Ocl.Support Namespace See Also
Collapse All
C#
IOclType ElementType;
Remarks

This is ElementType, a member of class IOclType.

See Also
IOclType Interface
Eco.Ocl.Support Namespace


IOclType.UMLType Property

IOclType.UMLType Property
IOclType Interface Eco.Ocl.Support Namespace See Also
Collapse All
C#
IClassifier UMLType;
Remarks

This is UMLType, a member of class IOclType.

See Also
IOclType Interface
Eco.Ocl.Support Namespace


IOclTypeFactory Interface

IOclTypeFactory Interface
Inheritance Hierarchy See Also
Collapse All
C#
public interface IOclTypeFactory;
Remarks

This is class Eco.Ocl.Support.IOclTypeFactory.

Inheritance Hierarchy
Eco.Ocl.Support.IOclTypeFactory
File

OclSupport.cs

See Also
Inheritance Hierarchy


IOclTypeFactory Methods

IOclTypeFactory Methods
Public Methods
Collapse All

The methods of the IOclTypeFactory class are listed here.

Public Methods
Name | Description
TypeForClassifier | This is TypeForClassifier, a member of class IOclTypeFactory.


IOclTypeFactory.TypeForClassifier Method

IOclTypeFactory.TypeForClassifier Method
IOclTypeFactory Interface Eco.Ocl.Support Namespace See Also
Collapse All
C#
IOclType TypeForClassifier(
    IClassifier classifier
);
Remarks

This is TypeForClassifier, a member of class IOclTypeFactory.

See Also
IOclTypeFactory Interface
Eco.Ocl.Support Namespace


IOclTypeFactory Properties

IOclTypeFactory Properties
Public Properties
Collapse All

The properties of the IOclTypeFactory class are listed here.

Public Properties
Name | Description
TypeType | This is TypeType, a member of class IOclTypeFactory.


IOclTypeFactory.TypeType Property

IOclTypeFactory.TypeType Property
IOclTypeFactory Interface Eco.Ocl.Support Namespace See Also
Collapse All
C#
IOclType TypeType;
Remarks

This is TypeType, a member of class IOclTypeFactory.

See Also
IOclTypeFactory Interface
Eco.Ocl.Support Namespace


IOclValue Interface

IOclValue Interface
Inheritance Hierarchy See Also
Collapse All
C#
public interface IOclValue;
Remarks

This is class Eco.Ocl.Support.IOclValue.

Inheritance Hierarchy
Eco.Ocl.Support.IOclValue
    Eco.Ocl.Support.IOclNamedEnumLiteral
File

OclSupport.cs

See Also
Inheritance Hierarchy


IOclValue Methods

IOclValue Methods
Public Methods
Collapse All

The methods of the IOclValue class are listed here.

Public Methods
Name | Description
SetDefaultValue | This is SetDefaultValue, a member of class IOclValue.
SetOwnedElement | This is SetOwnedElement, a member of class IOclValue.
SetReferenceClassifier | This is SetReferenceClassifier, a member of class IOclValue.
SetReferenceElement | This is SetReferenceElement, a member of class IOclValue.
TransferValue | This is TransferValue, a member of class IOclValue.


IOclValue.SetDefaultValue Method

IOclValue.SetDefaultValue Method
IOclValue Interface Eco.Ocl.Support Namespace See Also
Collapse All
C#
void SetDefaultValue(
    IOclOperationSupport support
);
Remarks

This is SetDefaultValue, a member of class IOclValue.

See Also
IOclValue Interface
Eco.Ocl.Support Namespace


IOclValue.SetOwnedElement Method

IOclValue.SetOwnedElement Method
IOclValue Interface Eco.Ocl.Support Namespace See Also
Collapse All
C#
void SetOwnedElement(
    IElement value
);
Remarks

This is SetOwnedElement, a member of class IOclValue.

See Also
IOclValue Interface
Eco.Ocl.Support Namespace


IOclValue.SetReferenceClassifier Method

IOclValue.SetReferenceClassifier Method
IOclValue Interface Eco.Ocl.Support Namespace See Also
Collapse All
C#
void SetReferenceClassifier(
    IClassifier value
);
Remarks

This is SetReferenceClassifier, a member of class IOclValue.

See Also
IOclValue Interface
Eco.Ocl.Support Namespace


IOclValue.SetReferenceElement Method

IOclValue.SetReferenceElement Method
IOclValue Interface Eco.Ocl.Support Namespace See Also
Collapse All
C#
void SetReferenceElement(
    IElement value
);
Remarks

This is SetReferenceElement, a member of class IOclValue.

See Also
IOclValue Interface
Eco.Ocl.Support Namespace


IOclValue.TransferValue Method

IOclValue.TransferValue Method
IOclValue Interface Eco.Ocl.Support Namespace See Also
Collapse All
C#
void TransferValue(
    IOclValue node
);
Remarks

This is TransferValue, a member of class IOclValue.

See Also
IOclValue Interface
Eco.Ocl.Support Namespace


IOclValue Properties

IOclValue Properties
Public Properties
Collapse All

The properties of the IOclValue class are listed here.

Public Properties
Name | Description
ClassifierValue | This is ClassifierValue, a member of class IOclValue.
Element | This is Element, a member of class IOclValue.
IsTypeNode | This is IsTypeNode, a member of class IOclValue.
ModelName | This is ModelName, a member of class IOclValue.
OclType | This is OclType, a member of class IOclValue.
OwnsValue | This is OwnsValue, a member of class IOclValue.
Pos | This is Pos, a member of class IOclValue.


IOclValue.ClassifierValue Property

IOclValue.ClassifierValue Property
IOclValue Interface Eco.Ocl.Support Namespace See Also
Collapse All
C#
IClassifier ClassifierValue;
Remarks

This is ClassifierValue, a member of class IOclValue.

See Also
IOclValue Interface
Eco.Ocl.Support Namespace


IOclValue.Element Property

IOclValue.Element Property
IOclValue Interface Eco.Ocl.Support Namespace See Also
Collapse All
C#
IElement Element;
Remarks

This is Element, a member of class IOclValue.

See Also
IOclValue Interface
Eco.Ocl.Support Namespace


IOclValue.IsTypeNode Property

IOclValue.IsTypeNode Property
IOclValue Interface Eco.Ocl.Support Namespace See Also
Collapse All
C#
bool IsTypeNode;
Remarks

This is IsTypeNode, a member of class IOclValue.

See Also
IOclValue Interface
Eco.Ocl.Support Namespace


IOclValue.ModelName Property

IOclValue.ModelName Property
IOclValue Interface Eco.Ocl.Support Namespace See Also
Collapse All
C#
string ModelName;
Remarks

This is ModelName, a member of class IOclValue.

See Also
IOclValue Interface
Eco.Ocl.Support Namespace


IOclValue.OclType Property

IOclValue.OclType Property
IOclValue Interface Eco.Ocl.Support Namespace See Also
Collapse All
C#
IOclType OclType;
Remarks

This is OclType, a member of class IOclValue.

See Also
IOclValue Interface
Eco.Ocl.Support Namespace


IOclValue.OwnsValue Property

IOclValue.OwnsValue Property
IOclValue Interface Eco.Ocl.Support Namespace See Also
Collapse All
C#
bool OwnsValue;
Remarks

This is OwnsValue, a member of class IOclValue.

See Also
IOclValue Interface
Eco.Ocl.Support Namespace


IOclValue.Pos Property

IOclValue.Pos Property
IOclValue Interface Eco.Ocl.Support Namespace See Also
Collapse All
C#
int Pos;
Remarks

This is Pos, a member of class IOclValue.

See Also
IOclValue Interface
Eco.Ocl.Support Namespace


Eco.Ocl.Support.OclMethodsFilter Enumeration

Eco.Ocl.Support.OclMethodsFilter Enumeration
C#
public enum OclMethodsFilter {
  NonQuery = 1,
  IsQuery = 2,
  All = NonQuery|IsQuery
}
Remarks

This is record Eco.Ocl.Support.OclMethodsFilter.

File

OclMethods.cs


Eco.Ocl.Support.OclResultTypeDeduceMethod Enumeration

Eco.Ocl.Support.OclResultTypeDeduceMethod Enumeration
C#
public enum OclResultTypeDeduceMethod {
  ExplicitType,
  LoopVariableType,
  TypeOfSource,
  ListElementTypeOfSource,
  TypeOfFirstParam,
  TypeOfSecondParam,
  LeastCommonType_SourceAndFirstParam,
  LeastCommonType_FirstAndSecondParam,
  FirstParamAsSequence,
  ObjectListFromSourceType,
  MetaType,
  TypeCast,
  SourceAsBag,
  SourceAsSet,
  SourceAsSequence,
  SourceAsOrderedSet,
  ObjectListFromFirstParamType,
  Boolean_TypesMustShareDomain,
  ObjectFromSourceType,
  SymbolCalculated
}
Remarks

This is record Eco.Ocl.Support.OclResultTypeDeduceMethod.

File

OclSupport.cs


Eco.Ocl.Support.OclSortDirection Enumeration

Eco.Ocl.Support.OclSortDirection Enumeration
C#
public enum OclSortDirection {
  ascending,
  descending
}
Remarks

This is record Eco.Ocl.Support.OclSortDirection.

File

OclSupport.cs


Eco.Persistence Namespace

Eco.Persistence Namespace
Classes Enumerations Interfaces Types
Collapse All

The following options should be set on the Sybase database:

  • "allow nulls by default" (this is needed when adding new columns during

evolve, especially for relation-columns as they will never have any default values specified by Eco)

  • select into/bulkcopy/pllsort (this is needed since the DDLs are not run in a transaction (AlterTable can not be done in a transaction)
Classes
Name | Description
AbstractAutoGuidKeyMapper | This class implements a key mapper for auto guid fields. The actual id values are allocated by the database
AbstractAutoIncKeyMapper | This class implements a key mapper for autoincremental fields. The actual id values are allocated by the database
AbstractCondition | This is class Eco.Persistence.AbstractCondition.
AbstractDataBlockPersistenceMapper | This is class Eco.Persistence.AbstractDataBlockPersistenceMapper.
AbstractPersistenceMapperBlackfish | This is class Eco.Persistence.AbstractPersistenceMapperBlackfish.
AbstractPersistenceMapperDb | Superclass for all persistence mappers that persist to a relational database.
AbstractPersistenceMapperFile | This is class Eco.Persistence.AbstractPersistenceMapperFile.
AbstractSyncHandler | The base class for implementing a multi-user sync component.
AllInstancesCondition | This is class Eco.Persistence.AllInstancesCondition.
AttributeKeyMapper | This is class Eco.Persistence.AttributeKeyMapper.
AutoGuidKeyMapper | This is class Eco.Persistence.AutoGuidKeyMapper.
AutoInc16KeyMapper | This is class Eco.Persistence.AutoInc16KeyMapper.
AutoIncKeyMapper | This is class Eco.Persistence.AutoIncKeyMapper.
ChainedPersistenceHandlerBase | Base class for persistence handler.
ChainedPersistenceMapperBase | This is a generic component that can be used to plug into the PersistenceMapper chain and intercept calls from the EcoSpace to the persistencemapper To use, subclass and override the methods you need to intercept. Instantiate the new class and set the "NextPersistenceMapper" property to the actual PersistenceMapper
ChainedPersistenceMapperImplBase | This is class Eco.Persistence.ChainedPersistenceMapperImplBase.
ChainedPersistenceServiceBase | Use this class to implement your own IPersistenceService override any of the virtual methods to inject your own behaviour
ChangePointCondition | This is class Eco.Persistence.ChangePointCondition.
ColumnDescription | This class is used by KeyMappers that need to add structure to the database schema
CommitBlock | This is class Eco.Persistence.CommitBlock.
ConnectionPool | Manages a pool of database connections.
ContentEqualArray | This is class Eco.Persistence.ContentEqualArray.
DatablockConverter | This class can convert a datablock to xml and back.
DBChange | Contains change information received from the SyncHandler on a remote persistence.
DBChangeCollection | Collection of changes
DefaultCleanPsConfig | DefaultCleanPSConfig provides a UI less implementation of IConfigureCleanPS. This avoids dependencies to Windows.Forms. FormBasedConfigureCleanPS is the implementation of IConfigureCleanPS which is used at design time.
DefaultEcoIdMapper | This class implements a key mapper for autoincremental fields. The actual id values are allocated by the database
DefaultEcoInt64KeyMapper | This class implements a key mapper for autoincremental fields. The actual id values are allocated by the database
DefaultEcoKeyMapperBase | This is class Eco.Persistence.DefaultEcoKeyMapperBase.
DistributedTransactionManager | This is class Eco.Persistence.DistributedTransactionManager.
EcoCantGetNewObjectIdException | This is class Eco.Persistence.EcoCantGetNewObjectIdException.
FormerNamesHandler | This is class Eco.Persistence.FormerNamesHandler.
GenericKeyMapper | This class is suitable for subclassing if you intend to implement the IKeyMapper interface
GuidKeyMapper | This is class Eco.Persistence.GuidKeyMapper.
LocalTransactionManager | This is class Eco.Persistence.LocalTransactionManager.
MemberIndexColumnIndex | Support class used to pass member index and column index to a key mapper
OclCondition | This is class Eco.Persistence.OclCondition.
OkResult | This is class Eco.Persistence.OkResult.
OptimisticLockingPrecondition | This is class Eco.Persistence.OptimisticLockingPrecondition.
OptimisticLockingResult | This is class Eco.Persistence.OptimisticLockingResult.
PersistenceMapper | This is class Eco.Persistence.PersistenceMapper.
PersistenceMapperAdo2 |
PersistenceMapperBdp | This is class Eco.Persistence.PersistenceMapperBdp.
PersistenceMapperBlackfish | Persistencemapper using BlackfishSQL native connections.
PersistenceMapperBlackfishRemote | Persistencemapper using BlackfishSQL native connections.
PersistenceMapperDb | This is class Eco.Persistence.PersistenceMapperDb.
PersistenceMapperDbCollection | This is class Eco.Persistence.PersistenceMapperDbCollection.
PersistenceMapperDbx | This is class Eco.Persistence.PersistenceMapperDbx.
PersistenceMapperFirebird | This is class Eco.Persistence.PersistenceMapperFirebird.
PersistenceMapperMemory | This is class Eco.Persistence.PersistenceMapperMemory.
PersistenceMapperMimer | This is class Eco.Persistence.PersistenceMapperMimer.
PersistenceMapperMultiDb | This is class Eco.Persistence.PersistenceMapperMultiDb.
PersistenceMapperMySql | Persistencemapper using MySql Connector/Net MySqlConnection.
PersistenceMapperNexusDB | This is class Eco.Persistence.PersistenceMapperNexusDB.
PersistenceMapperOracle | Persistencemapper using OracleConnection connections.
PersistenceMapperProvider | This is class Eco.Persistence.PersistenceMapperProvider.
PersistenceMapperSharer | This is class Eco.Persistence.PersistenceMapperSharer.
PersistenceMapperSQLite | This is class Eco.Persistence.PersistenceMapperSQLite.
PersistenceMapperSqlServer | Persistencemapper using Microsoft SqlConnection connections.
PersistenceMapperSybase | This is class Eco.Persistence.PersistenceMapperSybase.
PersistenceMapperXml | This PersistenceMapper stores the data of the domain objects in an xml-file.
PersistenceStringRes | Autogenerated class to get compiler safe access to resource strings.
PMapperDef | PMapperDef is the itemtype in PersistenceMapperDbCollection.
SimpleORMappingProvider | This is class Eco.Persistence.SimpleORMappingProvider.
SyncHandler | This is class Eco.Persistence.SyncHandler.
SyncVersion | This is class Eco.Persistence.SyncVersion.
TKeyJoinPair | This is class Eco.Persistence.TKeyJoinPair.
TransactionUtil | This is class Eco.Persistence.TransactionUtil.
TSelectQuery | end TKeyJoinPair
UpdatePrecondition | This is class Eco.Persistence.UpdatePrecondition.
UpdateResult | This is class Eco.Persistence.UpdateResult.
VersionConst | This is class Eco.Persistence.VersionConst.
Top
Enumerations
Name | Description
CreateMappingMode | This is record Eco.Persistence.CreateMappingMode.
IdAllocationMode | This is record Eco.Persistence.IdAllocationMode.
PMapperOp | This is record Eco.Persistence.PMapperOp.
RestoreDbStatus | This is record Eco.Persistence.RestoreDbStatus.
TransactionMode | This is record Eco.Persistence.TransactionMode.
Top
Interfaces
Name | Description
IAttributemapping | This interface handles database conversion for values that are stored in multiple columns.
IAutoHookable | Interface used for designer interaction only
IAutoIncAttributemapping | This interface handles database conversion for values that are generated in the database.
IAutoIncIdMapper | This interface needs to be implemented by AutoInc KeyMappers that requires to perform custom initialization of the autoinc fields
IConfigureCleanPS | This is class Eco.Persistence.IConfigureCleanPS.
IDBEvolutor | This is class Eco.Persistence.IDBEvolutor.
IDefaultReverseMapping | This interface indicates that the mapping represents the preferred reverse mapping for the columntype
IDistributedTransactionParticipant | This interface allows multiple databases to participate in a single transaction.
IGenericSingleColumnAttributemapping | This is class Eco.Persistence.IGenericSingleColumnAttributemapping.
IKeyMapper | This interface is used by the Eco persistence mapper to handle different strategies of dealing with database keys.
INonBooleanBooleanMapping | This interface handles database conversion for boolean values that are stored as non-booleans.
IOptimisticLockHandler | This is class Eco.Persistence.IOptimisticLockHandler.
IPersistenceMapper | This is class Eco.Persistence.IPersistenceMapper.
IPersistenceMapperDb | This interface is for internal use, and breaks the dependency between Eco.Handles.Windows and Eco.Persistence (in the DBEvolution form and the ActionExtender).
IPersistencemapperProvider | This is class Eco.Persistence.IPersistencemapperProvider.
IPersistenceMapperWithIDatabase | This is class Eco.Persistence.IPersistenceMapperWithIDatabase.
IRemotePersistenceMapperProvider | This is class Eco.Persistence.IRemotePersistenceMapperProvider.
ISingleColumnAttributemapping | This interface handles database conversion for values that are stored in a single column.
ISyncSink | This is class Eco.Persistence.ISyncSink.
Top
Types
Name | Description
GetDateTimeDelegate | This is type Eco.Persistence.GetDateTimeDelegate.


AbstractAutoGuidKeyMapper Class

AbstractAutoGuidKeyMapper Class
Inheritance Hierarchy See Also
Collapse All

This class implements a key mapper for auto guid fields. The actual id values are allocated by the database

C#
public abstract class AbstractAutoGuidKeyMapper : GenericKeyMapper, IKeyMapper, IAutoIncIdMapper;
Inheritance Hierarchy
Eco.Persistence.GenericKeyMapper
Eco.Persistence.IAutoIncIdMapper
Eco.Persistence.IKeyMapper
    Eco.Persistence.AbstractAutoGuidKeyMapper
        Eco.Persistence.AutoGuidKeyMapper
File

AutoGuidKeyMapper.cs

See Also
Inheritance Hierarchy


AbstractAutoGuidKeyMapper.AbstractAutoGuidKeyMapper Constructor

AbstractAutoGuidKeyMapper.AbstractAutoGuidKeyMapper Constructor
AbstractAutoGuidKeyMapper Class Eco.Persistence Namespace See Also
Collapse All
C#
protected AbstractAutoGuidKeyMapper();
Remarks

This is AbstractAutoGuidKeyMapper, a member of class AbstractAutoGuidKeyMapper.

See Also
AbstractAutoGuidKeyMapper Class
Eco.Persistence Namespace


AbstractAutoGuidKeyMapper Methods

AbstractAutoGuidKeyMapper Methods
Public Methods
Collapse All

The methods of the AbstractAutoGuidKeyMapper class are listed here.

Public Methods
Name | Description
ColumnCount | Returns the number of columns that are used to store the id
ColumnType | Returns the sql type for the respective column.
ColumnTypeForAutoInc | This is ColumnTypeForAutoInc, a member of class AbstractAutoGuidKeyMapper.
GetAutoIncValueRetrievalQuery | This is GetAutoIncValueRetrievalQuery, a member of class AbstractAutoGuidKeyMapper.
GetIdAllocationMode | Indicates the strategy used by the key mapper.
IdFromFields | This method creates a new id based on the values of the field objects
IdListToWhereFragment | This is IdListToWhereFragment, a member of class AbstractAutoGuidKeyMapper.
IdToParameters | This method fills the parameter objects with data from an id
Initialize |
InitializeAutoIncField | This is InitializeAutoIncField, a member of class AbstractAutoGuidKeyMapper.
InitializeDatabase | This method may perform initialization of the database such as installing generators for autoinc mechanisms.
InitializeDatabaseScript | Same as InitializeDatabase, but rather than operating directly on the database, the initializations should be returned as sql statements to be used in a script.
InitializePSDescriptions | This method can add additional tables/columns if the keymapper requires any additional structure in the database schema. It is called once per session.
NewIdFromAttributes | This method is called once for each object before it is updated (if IdAllocationMode = FromAttributes).
NewIdPreUpdate | This method is called once for each object (if IdAllocationMode = PreUpdate) that needs to have a persistent id. It must return a new id with the same ClassId as the old id
ReserveId | This method is called once for each object before objects are updated (if IdAllocationMode = PreUpdate and allows the keymapper to prepare for the number of IDs that needs to be allocated


AbstractAutoGuidKeyMapper.ColumnCount Method

AbstractAutoGuidKeyMapper.ColumnCount Method
AbstractAutoGuidKeyMapper Class Eco.Persistence Namespace See Also
Collapse All

Returns the number of columns that are used to store the id

C#
public int ColumnCount();
See Also
AbstractAutoGuidKeyMapper Class
Eco.Persistence Namespace


AbstractAutoGuidKeyMapper.ColumnType Method

AbstractAutoGuidKeyMapper.ColumnType Method
AbstractAutoGuidKeyMapper Class Eco.Persistence Namespace See Also
Collapse All

Returns the sql type for the respective column.

C#
public string ColumnType(
    ArrayList KeyMappers,
    int columnNum
);
See Also
AbstractAutoGuidKeyMapper Class
Eco.Persistence Namespace


AbstractAutoGuidKeyMapper.ColumnTypeForAutoInc Method

AbstractAutoGuidKeyMapper.ColumnTypeForAutoInc Method
AbstractAutoGuidKeyMapper Class Eco.Persistence Namespace See Also
Collapse All
C#
public string ColumnTypeForAutoInc();
Remarks

This is ColumnTypeForAutoInc, a member of class AbstractAutoGuidKeyMapper.

See Also
AbstractAutoGuidKeyMapper Class
Eco.Persistence Namespace


AbstractAutoGuidKeyMapper.GetAutoIncValueRetrievalQuery Method

AbstractAutoGuidKeyMapper.GetAutoIncValueRetrievalQuery Method
AbstractAutoGuidKeyMapper Class Eco.Persistence Namespace See Also
Collapse All
C#
public virtual string GetAutoIncValueRetrievalQuery(
    string tableName,
    string columnName
);
Remarks

This is GetAutoIncValueRetrievalQuery, a member of class AbstractAutoGuidKeyMapper.

See Also
AbstractAutoGuidKeyMapper Class
Eco.Persistence Namespace


AbstractAutoGuidKeyMapper.GetIdAllocationMode Method

AbstractAutoGuidKeyMapper.GetIdAllocationMode Method
AbstractAutoGuidKeyMapper Class Eco.Persistence Namespace See Also
Collapse All

Indicates the strategy used by the key mapper.

C#
public IdAllocationMode GetIdAllocationMode();
Remarks

FromAttributes means that the key mapper will extract the key values from the contents of the object. PreUpdate means that the id values can be allocated prior to updating the object (used by the default eco key mapper and the guid-mapper). PostUpdate means that the id values can only be obtained after the object has been inserted to the database (used by autoinc mapper).

See Also
AbstractAutoGuidKeyMapper Class
Eco.Persistence Namespace


AbstractAutoGuidKeyMapper.IdFromFields Method

AbstractAutoGuidKeyMapper.IdFromFields Method
AbstractAutoGuidKeyMapper Class Eco.Persistence Namespace See Also
Collapse All

This method creates a new id based on the values of the field objects

C#
public ObjectId IdFromFields(
    IField[] keyFields,
    ArrayList keyMappers,
    int classId,
    int timeStamp
);
See Also
AbstractAutoGuidKeyMapper Class
Eco.Persistence Namespace


AbstractAutoGuidKeyMapper.IdListToWhereFragment Method

AbstractAutoGuidKeyMapper.IdListToWhereFragment Method
AbstractAutoGuidKeyMapper Class Eco.Persistence Namespace See Also
Collapse All
C#
public override string IdListToWhereFragment(
    ObjectIdCollection idList,
    IParameterized parameterized,
    IList<string> idColumns,
    string idPrefix
);
Remarks

This is IdListToWhereFragment, a member of class AbstractAutoGuidKeyMapper.

See Also
AbstractAutoGuidKeyMapper Class
Eco.Persistence Namespace


AbstractAutoGuidKeyMapper.IdToParameters Method

AbstractAutoGuidKeyMapper.IdToParameters Method
AbstractAutoGuidKeyMapper Class Eco.Persistence Namespace See Also
Collapse All

This method fills the parameter objects with data from an id

C#
public void IdToParameters(
    ObjectId id,
    IDataParameter[] parameters
);
See Also
AbstractAutoGuidKeyMapper Class
Eco.Persistence Namespace


AbstractAutoGuidKeyMapper.Initialize Method

AbstractAutoGuidKeyMapper.Initialize Method
AbstractAutoGuidKeyMapper Class Eco.Persistence Namespace See Also
Collapse All
C#
public void Initialize(
    SqlDatabaseConfig config,
    ArrayList keyMappers
);
Exceptions
Exceptions | Description
InvalidOperationException | Thrown if the MapperDictionary does not contain any implementor of IAutoIncAttributemapping.
See Also
AbstractAutoGuidKeyMapper Class
Eco.Persistence Namespace


AbstractAutoGuidKeyMapper.InitializeAutoIncField Method

AbstractAutoGuidKeyMapper.InitializeAutoIncField Method
AbstractAutoGuidKeyMapper Class Eco.Persistence Namespace See Also
Collapse All
C#
public void InitializeAutoIncField(
    string tableName,
    string columnName,
    IDatabase database
);
Remarks

This is InitializeAutoIncField, a member of class AbstractAutoGuidKeyMapper.

See Also
AbstractAutoGuidKeyMapper Class
Eco.Persistence Namespace


AbstractAutoGuidKeyMapper.InitializeDatabase Method

AbstractAutoGuidKeyMapper.InitializeDatabase Method
AbstractAutoGuidKeyMapper Class Eco.Persistence Namespace See Also
Collapse All

This method may perform initialization of the database such as installing generators for autoinc mechanisms.

C#
public void InitializeDatabase(
    IDatabase db
);
See Also
AbstractAutoGuidKeyMapper Class
Eco.Persistence Namespace


AbstractAutoGuidKeyMapper.InitializeDatabaseScript Method

AbstractAutoGuidKeyMapper.InitializeDatabaseScript Method
AbstractAutoGuidKeyMapper Class Eco.Persistence Namespace See Also
Collapse All

Same as InitializeDatabase, but rather than operating directly on the database, the initializations should be returned as sql statements to be used in a script.

C#
public void InitializeDatabaseScript(
    IList<string> script
);
See Also
AbstractAutoGuidKeyMapper Class
Eco.Persistence Namespace


AbstractAutoGuidKeyMapper.InitializePSDescriptions Method

AbstractAutoGuidKeyMapper.InitializePSDescriptions Method
AbstractAutoGuidKeyMapper Class Eco.Persistence Namespace See Also
Collapse All

This method can add additional tables/columns if the keymapper requires any additional structure in the database schema. It is called once per session.

C#
public void InitializePSDescriptions(
    IDatabaseDefinition db
);
See Also
AbstractAutoGuidKeyMapper Class
Eco.Persistence Namespace


AbstractAutoGuidKeyMapper.NewIdFromAttributes Method

AbstractAutoGuidKeyMapper.NewIdFromAttributes Method
AbstractAutoGuidKeyMapper Class Eco.Persistence Namespace See Also
Collapse All

This method is called once for each object before it is updated (if IdAllocationMode = FromAttributes).

C#
public ObjectId NewIdFromAttributes(
    ObjectContents objContents,
    ArrayList memberIndexes,
    IdTranslationList translationList
);
Parameters
Parameters | Description
objContents | The object that needs an id
memberIndexes | An arraylist of MemberIndexColumnIndex objects
translationList | If the new Id contains any information from relations to other objects, it is important that those ids are translated using the translationlist before the related object ids are used
See Also
AbstractAutoGuidKeyMapper Class
Eco.Persistence Namespace


AbstractAutoGuidKeyMapper.NewIdPreUpdate Method

AbstractAutoGuidKeyMapper.NewIdPreUpdate Method
AbstractAutoGuidKeyMapper Class Eco.Persistence Namespace See Also
Collapse All

This method is called once for each object (if IdAllocationMode = PreUpdate) that needs to have a persistent id. It must return a new id with the same ClassId as the old id

C#
public ObjectId NewIdPreUpdate(
    IDatabase db,
    ObjectId oldId
);
See Also
AbstractAutoGuidKeyMapper Class
Eco.Persistence Namespace


AbstractAutoGuidKeyMapper.ReserveId Method

AbstractAutoGuidKeyMapper.ReserveId Method
AbstractAutoGuidKeyMapper Class Eco.Persistence Namespace See Also
Collapse All

This method is called once for each object before objects are updated (if IdAllocationMode = PreUpdate and allows the keymapper to prepare for the number of IDs that needs to be allocated

C#
public void ReserveId();
See Also
AbstractAutoGuidKeyMapper Class
Eco.Persistence Namespace


AbstractAutoGuidKeyMapper Properties

AbstractAutoGuidKeyMapper Properties
Protected Properties
Collapse All

The properties of the AbstractAutoGuidKeyMapper class are listed here.

Protected Properties
Name | Description
AutoGuidAttributeMapperName | This is AutoGuidAttributeMapperName, a member of class AbstractAutoGuidKeyMapper.
GuidAttributeMapperName | This is GuidAttributeMapperName, a member of class AbstractAutoGuidKeyMapper.


AbstractAutoGuidKeyMapper.AutoGuidAttributeMapperName Property

AbstractAutoGuidKeyMapper.AutoGuidAttributeMapperName Property
AbstractAutoGuidKeyMapper Class Eco.Persistence Namespace See Also
Collapse All
C#
protected abstract string AutoGuidAttributeMapperName;
Remarks

This is AutoGuidAttributeMapperName, a member of class AbstractAutoGuidKeyMapper.

See Also
AbstractAutoGuidKeyMapper Class
Eco.Persistence Namespace


AbstractAutoGuidKeyMapper.GuidAttributeMapperName Property

AbstractAutoGuidKeyMapper.GuidAttributeMapperName Property
AbstractAutoGuidKeyMapper Class Eco.Persistence Namespace See Also
Collapse All
C#
protected abstract string GuidAttributeMapperName;
Remarks

This is GuidAttributeMapperName, a member of class AbstractAutoGuidKeyMapper.

See Also
AbstractAutoGuidKeyMapper Class
Eco.Persistence Namespace


AbstractAutoIncKeyMapper Class

AbstractAutoIncKeyMapper Class
Inheritance Hierarchy See Also
Collapse All

This class implements a key mapper for autoincremental fields. The actual id values are allocated by the database

C#
public abstract class AbstractAutoIncKeyMapper : GenericKeyMapper, IKeyMapper, IAutoIncIdMapper;
Inheritance Hierarchy
Eco.Persistence.GenericKeyMapper
Eco.Persistence.IAutoIncIdMapper
Eco.Persistence.IKeyMapper
    Eco.Persistence.AbstractAutoIncKeyMapper
        Eco.Persistence.AutoInc16KeyMapper
        Eco.Persistence.AutoIncKeyMapper
File

AutoIncKeyMapper.cs

See Also
Inheritance Hierarchy


AbstractAutoIncKeyMapper.AbstractAutoIncKeyMapper Constructor

AbstractAutoIncKeyMapper.AbstractAutoIncKeyMapper Constructor
AbstractAutoIncKeyMapper Class Eco.Persistence Namespace See Also
Collapse All
C#
protected AbstractAutoIncKeyMapper();
Remarks

This is AbstractAutoIncKeyMapper, a member of class AbstractAutoIncKeyMapper.

See Also
AbstractAutoIncKeyMapper Class
Eco.Persistence Namespace


AbstractAutoIncKeyMapper Methods

AbstractAutoIncKeyMapper Methods
Public Methods
Collapse All

The methods of the AbstractAutoIncKeyMapper class are listed here.

Public Methods
Name | Description
ColumnCount | Returns the number of columns that are used to store the id
ColumnType | Returns the sql type for the respective column.
ColumnTypeForAutoInc | This is ColumnTypeForAutoInc, a member of class AbstractAutoIncKeyMapper.
GetAutoIncValueRetrievalQuery | protected abstract string IntAttributeMapperName { get;
GetIdAllocationMode | Indicates the strategy used by the key mapper.
IdFromFields |
IdListToWhereFragment | This is IdListToWhereFragment, a member of class AbstractAutoIncKeyMapper.
IdToParameters | This method fills the parameter objects with data from an id
Initialize |
InitializeAutoIncField | This is InitializeAutoIncField, a member of class AbstractAutoIncKeyMapper.
InitializeDatabase | This method may perform initialization of the database such as installing generators for autoinc mechanisms.
InitializeDatabaseScript | Same as InitializeDatabase, but rather than operating directly on the database, the initializations should be returned as sql statements to be used in a script.
InitializePSDescriptions | This method can add additional tables/columns if the keymapper requires any additional structure in the database schema. It is called once per session.
NewIdFromAttributes | This method is called once for each object before it is updated (if IdAllocationMode = FromAttributes).
NewIdPreUpdate | This method is called once for each object (if IdAllocationMode = PreUpdate) that needs to have a persistent id. It must return a new id with the same ClassId as the old id
ReserveId | This method is called once for each object before objects are updated (if IdAllocationMode = PreUpdate and allows the keymapper to prepare for the number of IDs that needs to be allocated


AbstractAutoIncKeyMapper.ColumnCount Method

AbstractAutoIncKeyMapper.ColumnCount Method
AbstractAutoIncKeyMapper Class Eco.Persistence Namespace See Also
Collapse All

Returns the number of columns that are used to store the id

C#
public int ColumnCount();
See Also
AbstractAutoIncKeyMapper Class
Eco.Persistence Namespace


AbstractAutoIncKeyMapper.ColumnType Method

AbstractAutoIncKeyMapper.ColumnType Method
AbstractAutoIncKeyMapper Class Eco.Persistence Namespace See Also
Collapse All

Returns the sql type for the respective column.

C#
public string ColumnType(
    ArrayList KeyMappers,
    int columnNum
);
See Also
AbstractAutoIncKeyMapper Class
Eco.Persistence Namespace


AbstractAutoIncKeyMapper.ColumnTypeForAutoInc Method

AbstractAutoIncKeyMapper.ColumnTypeForAutoInc Method
AbstractAutoIncKeyMapper Class Eco.Persistence Namespace See Also
Collapse All
C#
public string ColumnTypeForAutoInc();
Remarks

This is ColumnTypeForAutoInc, a member of class AbstractAutoIncKeyMapper.

See Also
AbstractAutoIncKeyMapper Class
Eco.Persistence Namespace


AbstractAutoIncKeyMapper.GetAutoIncValueRetrievalQuery Method

AbstractAutoIncKeyMapper.GetAutoIncValueRetrievalQuery Method
AbstractAutoIncKeyMapper Class Eco.Persistence Namespace See Also
Collapse All
C#
public virtual string GetAutoIncValueRetrievalQuery(
    string tableName,
    string columnName
);
Remarks

protected abstract string IntAttributeMapperName { get;

See Also
AbstractAutoIncKeyMapper Class
Eco.Persistence Namespace


AbstractAutoIncKeyMapper.GetIdAllocationMode Method

AbstractAutoIncKeyMapper.GetIdAllocationMode Method
AbstractAutoIncKeyMapper Class Eco.Persistence Namespace See Also
Collapse All

Indicates the strategy used by the key mapper.

C#
public IdAllocationMode GetIdAllocationMode();
Remarks

FromAttributes means that the key mapper will extract the key values from the contents of the object. PreUpdate means that the id values can be allocated prior to updating the object (used by the default eco key mapper and the guid-mapper). PostUpdate means that the id values can only be obtained after the object has been inserted to the database (used by autoinc mapper).

See Also
AbstractAutoIncKeyMapper Class
Eco.Persistence Namespace


AbstractAutoIncKeyMapper.IdFromFields Method

AbstractAutoIncKeyMapper.IdFromFields Method
AbstractAutoIncKeyMapper Class Eco.Persistence Namespace See Also
Collapse All
C#
public ObjectId IdFromFields(
    IField[] keyFields,
    ArrayList keyMappers,
    int classId,
    int timeStamp
);
Exceptions
Exceptions | Description
EcoException | Thrown if timestamp indicates a request for versioned data.
See Also
AbstractAutoIncKeyMapper Class
Eco.Persistence Namespace


AbstractAutoIncKeyMapper.IdListToWhereFragment Method

AbstractAutoIncKeyMapper.IdListToWhereFragment Method
AbstractAutoIncKeyMapper Class Eco.Persistence Namespace See Also
Collapse All
C#
public override string IdListToWhereFragment(
    ObjectIdCollection idList,
    IParameterized parameterized,
    IList<string> idColumns,
    string idPrefix
);
Remarks

This is IdListToWhereFragment, a member of class AbstractAutoIncKeyMapper.

See Also
AbstractAutoIncKeyMapper Class
Eco.Persistence Namespace


AbstractAutoIncKeyMapper.IdToParameters Method

AbstractAutoIncKeyMapper.IdToParameters Method
AbstractAutoIncKeyMapper Class Eco.Persistence Namespace See Also
Collapse All

This method fills the parameter objects with data from an id

C#
public void IdToParameters(
    ObjectId id,
    IDataParameter[] parameters
);
See Also
AbstractAutoIncKeyMapper Class
Eco.Persistence Namespace


AbstractAutoIncKeyMapper.Initialize Method

AbstractAutoIncKeyMapper.Initialize Method
AbstractAutoIncKeyMapper Class Eco.Persistence Namespace See Also
Collapse All
C#
public void Initialize(
    SqlDatabaseConfig config,
    ArrayList keyMappers
);
Exceptions
Exceptions | Description
InvalidOperationException | Thrown if the MapperDictionary does not contain any implementor of IAutoIncAttributemapping.
See Also
AbstractAutoIncKeyMapper Class
Eco.Persistence Namespace


AbstractAutoIncKeyMapper.InitializeAutoIncField Method

AbstractAutoIncKeyMapper.InitializeAutoIncField Method
AbstractAutoIncKeyMapper Class Eco.Persistence Namespace See Also
Collapse All
C#
public void InitializeAutoIncField(
    string tableName,
    string columnName,
    IDatabase database
);
Remarks

This is InitializeAutoIncField, a member of class AbstractAutoIncKeyMapper.

See Also
AbstractAutoIncKeyMapper Class
Eco.Persistence Namespace


AbstractAutoIncKeyMapper.InitializeDatabase Method

AbstractAutoIncKeyMapper.InitializeDatabase Method
AbstractAutoIncKeyMapper Class Eco.Persistence Namespace See Also
Collapse All

This method may perform initialization of the database such as installing generators for autoinc mechanisms.

C#
public void InitializeDatabase(
    IDatabase db
);
See Also
AbstractAutoIncKeyMapper Class
Eco.Persistence Namespace


AbstractAutoIncKeyMapper.InitializeDatabaseScript Method

AbstractAutoIncKeyMapper.InitializeDatabaseScript Method
AbstractAutoIncKeyMapper Class Eco.Persistence Namespace See Also
Collapse All

Same as InitializeDatabase, but rather than operating directly on the database, the initializations should be returned as sql statements to be used in a script.

C#
public void InitializeDatabaseScript(
    IList<string> script
);
See Also
AbstractAutoIncKeyMapper Class
Eco.Persistence Namespace


AbstractAutoIncKeyMapper.InitializePSDescriptions Method

AbstractAutoIncKeyMapper.InitializePSDescriptions Method
AbstractAutoIncKeyMapper Class Eco.Persistence Namespace See Also
Collapse All

This method can add additional tables/columns if the keymapper requires any additional structure in the database schema. It is called once per session.

C#
public void InitializePSDescriptions(
    IDatabaseDefinition db
);
See Also
AbstractAutoIncKeyMapper Class
Eco.Persistence Namespace


AbstractAutoIncKeyMapper.NewIdFromAttributes Method

AbstractAutoIncKeyMapper.NewIdFromAttributes Method
AbstractAutoIncKeyMapper Class Eco.Persistence Namespace See Also
Collapse All

This method is called once for each object before it is updated (if IdAllocationMode = FromAttributes).

C#
public ObjectId NewIdFromAttributes(
    ObjectContents objContents,
    ArrayList memberIndexes,
    IdTranslationList translationList
);
Parameters
Parameters | Description
objContents | The object that needs an id
memberIndexes | An arraylist of MemberIndexColumnIndex objects
translationList | If the new Id contains any information from relations to other objects, it is important that those ids are translated using the translationlist before the related object ids are used
See Also
AbstractAutoIncKeyMapper Class
Eco.Persistence Namespace


AbstractAutoIncKeyMapper.NewIdPreUpdate Method

AbstractAutoIncKeyMapper.NewIdPreUpdate Method
AbstractAutoIncKeyMapper Class Eco.Persistence Namespace See Also
Collapse All

This method is called once for each object (if IdAllocationMode = PreUpdate) that needs to have a persistent id. It must return a new id with the same ClassId as the old id

C#
public ObjectId NewIdPreUpdate(
    IDatabase db,
    ObjectId oldId
);
See Also
AbstractAutoIncKeyMapper Class
Eco.Persistence Namespace


AbstractAutoIncKeyMapper.ReserveId Method

AbstractAutoIncKeyMapper.ReserveId Method
AbstractAutoIncKeyMapper Class Eco.Persistence Namespace See Also
Collapse All

This method is called once for each object before objects are updated (if IdAllocationMode = PreUpdate and allows the keymapper to prepare for the number of IDs that needs to be allocated

C#
public void ReserveId();
See Also
AbstractAutoIncKeyMapper Class
Eco.Persistence Namespace


AbstractAutoIncKeyMapper Properties

AbstractAutoIncKeyMapper Properties
Protected Properties
Collapse All

The properties of the AbstractAutoIncKeyMapper class are listed here.

Protected Properties
Name | Description
AutoIncAttributeMapperName | This is AutoIncAttributeMapperName, a member of class AbstractAutoIncKeyMapper.


AbstractAutoIncKeyMapper.AutoIncAttributeMapperName Property

AbstractAutoIncKeyMapper.AutoIncAttributeMapperName Property
AbstractAutoIncKeyMapper Class Eco.Persistence Namespace See Also
Collapse All
C#
protected abstract string AutoIncAttributeMapperName;
Remarks

This is AutoIncAttributeMapperName, a member of class AbstractAutoIncKeyMapper.

See Also
AbstractAutoIncKeyMapper Class
Eco.Persistence Namespace


AbstractCondition Class

AbstractCondition Class
Inheritance Hierarchy See Also
Collapse All
C#
public abstract class AbstractCondition;
Remarks

This is class Eco.Persistence.AbstractCondition.

Inheritance Hierarchy
Eco.Persistence.AbstractCondition
    Eco.Persistence.AllInstancesCondition
    Eco.Persistence.ChangePointCondition
    Eco.Persistence.OclCondition
File

PersistenceMapperInterfaces.cs

See Also
Inheritance Hierarchy


AbstractCondition Constructor

AbstractCondition Constructor

This is the overview for the AbstractCondition constructor overload.

Overload List
Name | Description
AbstractCondition.AbstractCondition (int) | This is AbstractCondition, a member of class AbstractCondition.
AbstractCondition.AbstractCondition (int, int) | This is AbstractCondition, a member of class AbstractCondition.


AbstractCondition.AbstractCondition Constructor (int)

AbstractCondition.AbstractCondition Constructor (int)
AbstractCondition Class Eco.Persistence Namespace See Also
Collapse All
C#
protected AbstractCondition(
    int classId
);
Remarks

This is AbstractCondition, a member of class AbstractCondition.

See Also
AbstractCondition Class
Eco.Persistence Namespace


AbstractCondition.AbstractCondition Constructor (int, int)

AbstractCondition.AbstractCondition Constructor (int, int)
AbstractCondition Class Eco.Persistence Namespace See Also
Collapse All
C#
protected AbstractCondition(
    int classId,
    int version
);
Remarks

This is AbstractCondition, a member of class AbstractCondition.

See Also
AbstractCondition Class
Eco.Persistence Namespace


AbstractCondition Properties

AbstractCondition Properties
Public Properties
Collapse All

The properties of the AbstractCondition class are listed here.

Public Properties
Name | Description
ClassId | This is ClassId, a member of class AbstractCondition.
Version | This is Version, a member of class AbstractCondition.


AbstractCondition.ClassId Property

AbstractCondition.ClassId Property
AbstractCondition Class Eco.Persistence Namespace See Also
Collapse All
C#
public int ClassId;
Remarks

This is ClassId, a member of class AbstractCondition.

See Also
AbstractCondition Class
Eco.Persistence Namespace


AbstractCondition.Version Property

AbstractCondition.Version Property
AbstractCondition Class Eco.Persistence Namespace See Also
Collapse All
C#
public int Version;
Remarks

This is Version, a member of class AbstractCondition.

See Also
AbstractCondition Class
Eco.Persistence Namespace


AbstractDataBlockPersistenceMapper Class

AbstractDataBlockPersistenceMapper Class
Inheritance Hierarchy See Also
Collapse All
C#
public abstract class AbstractDataBlockPersistenceMapper : PersistenceMapper, IPersistenceMapper;
Remarks

This is class Eco.Persistence.AbstractDataBlockPersistenceMapper.

Inheritance Hierarchy
Eco.Persistence.IPersistencemapperProvider
    Eco.Persistence.PersistenceMapper
    Eco.Persistence.IPersistenceMapper
        Eco.Persistence.AbstractDataBlockPersistenceMapper
            Eco.Persistence.AbstractPersistenceMapperFile
            Eco.Persistence.PersistenceMapperMemory
File

PersistenceMapperXML.cs

See Also
Inheritance Hierarchy


AbstractDataBlockPersistenceMapper Fields

AbstractDataBlockPersistenceMapper Fields
Protected Fields
Collapse All

The fields of the AbstractDataBlockPersistenceMapper class are listed here.

Protected Fields
Name | Description
idkey | This is idkey, a member of class AbstractDataBlockPersistenceMapper.
m_AutoIncValues | This is m_AutoIncValues, a member of class AbstractDataBlockPersistenceMapper.
versionkey | This is versionkey, a member of class AbstractDataBlockPersistenceMapper.


AbstractDataBlockPersistenceMapper.idkey Field

AbstractDataBlockPersistenceMapper.idkey Field
AbstractDataBlockPersistenceMapper Class Eco.Persistence Namespace See Also
Collapse All
C#
protected object idkey = new object();
Remarks

This is idkey, a member of class AbstractDataBlockPersistenceMapper.

See Also
AbstractDataBlockPersistenceMapper Class
Eco.Persistence Namespace


AbstractDataBlockPersistenceMapper.m_AutoIncValues Field

AbstractDataBlockPersistenceMapper.m_AutoIncValues Field
AbstractDataBlockPersistenceMapper Class Eco.Persistence Namespace See Also
Collapse All
C#
protected Dictionary<object, int> m_AutoIncValues;
Remarks

This is m_AutoIncValues, a member of class AbstractDataBlockPersistenceMapper.

See Also
AbstractDataBlockPersistenceMapper Class
Eco.Persistence Namespace


AbstractDataBlockPersistenceMapper.versionkey Field

AbstractDataBlockPersistenceMapper.versionkey Field
AbstractDataBlockPersistenceMapper Class Eco.Persistence Namespace See Also
Collapse All
C#
protected object versionkey = new object();
Remarks

This is versionkey, a member of class AbstractDataBlockPersistenceMapper.

See Also
AbstractDataBlockPersistenceMapper Class
Eco.Persistence Namespace


AbstractDataBlockPersistenceMapper Methods

AbstractDataBlockPersistenceMapper Methods
Protected Methods Public Methods
Collapse All

The methods of the AbstractDataBlockPersistenceMapper class are listed here.

Protected Methods
Name | Description
Activating | IPersistenceHandleImpl
ClearCache | This is ClearCache, a member of class AbstractDataBlockPersistenceMapper.
CompareValues | This is CompareValues, a member of class AbstractDataBlockPersistenceMapper.
Deactivating | This is Deactivating, a member of class AbstractDataBlockPersistenceMapper.
EnsureCache | This is EnsureCache, a member of class AbstractDataBlockPersistenceMapper.
EnsureCacheCurrent | This is EnsureCacheCurrent, a member of class AbstractDataBlockPersistenceMapper.
GetCache | This is GetCache, a member of class AbstractDataBlockPersistenceMapper.
Update | This is Update, a member of class AbstractDataBlockPersistenceMapper.
WriteDatablock | This is WriteDatablock, a member of class AbstractDataBlockPersistenceMapper.
Top
Public Methods
Name | Description
GetPersistenceMapper | This is GetPersistenceMapper, a member of class AbstractDataBlockPersistenceMapper.
ReturnPersistenceMapper | This is ReturnPersistenceMapper, a member of class AbstractDataBlockPersistenceMapper.


AbstractDataBlockPersistenceMapper.Activating Method

AbstractDataBlockPersistenceMapper.Activating Method
AbstractDataBlockPersistenceMapper Class Eco.Persistence Namespace See Also
Collapse All
C#
protected virtual void Activating();
Remarks

IPersistenceHandleImpl

See Also
AbstractDataBlockPersistenceMapper Class
Eco.Persistence Namespace


AbstractDataBlockPersistenceMapper.ClearCache Method

AbstractDataBlockPersistenceMapper.ClearCache Method
AbstractDataBlockPersistenceMapper Class Eco.Persistence Namespace See Also
Collapse All
C#
protected void ClearCache();
Remarks

This is ClearCache, a member of class AbstractDataBlockPersistenceMapper.

See Also
AbstractDataBlockPersistenceMapper Class
Eco.Persistence Namespace


AbstractDataBlockPersistenceMapper.CompareValues Method

AbstractDataBlockPersistenceMapper.CompareValues Method
AbstractDataBlockPersistenceMapper Class Eco.Persistence Namespace See Also
Collapse All
C#
protected bool CompareValues(
    object o1,
    object o2
);
Remarks

This is CompareValues, a member of class AbstractDataBlockPersistenceMapper.

See Also
AbstractDataBlockPersistenceMapper Class
Eco.Persistence Namespace


AbstractDataBlockPersistenceMapper.Deactivating Method

AbstractDataBlockPersistenceMapper.Deactivating Method
AbstractDataBlockPersistenceMapper Class Eco.Persistence Namespace See Also
Collapse All
C#
protected virtual void Deactivating();
Remarks

This is Deactivating, a member of class AbstractDataBlockPersistenceMapper.

See Also
AbstractDataBlockPersistenceMapper Class
Eco.Persistence Namespace


AbstractDataBlockPersistenceMapper.EnsureCache Method

AbstractDataBlockPersistenceMapper.EnsureCache Method
AbstractDataBlockPersistenceMapper Class Eco.Persistence Namespace See Also
Collapse All
C#
protected void EnsureCache();
Remarks

This is EnsureCache, a member of class AbstractDataBlockPersistenceMapper.

See Also
AbstractDataBlockPersistenceMapper Class
Eco.Persistence Namespace


AbstractDataBlockPersistenceMapper.EnsureCacheCurrent Method

AbstractDataBlockPersistenceMapper.EnsureCacheCurrent Method
AbstractDataBlockPersistenceMapper Class Eco.Persistence Namespace See Also
Collapse All
C#
protected abstract void EnsureCacheCurrent();
Remarks

This is EnsureCacheCurrent, a member of class AbstractDataBlockPersistenceMapper.

See Also
AbstractDataBlockPersistenceMapper Class
Eco.Persistence Namespace


AbstractDataBlockPersistenceMapper.GetCache Method

AbstractDataBlockPersistenceMapper.GetCache Method
AbstractDataBlockPersistenceMapper Class Eco.Persistence Namespace See Also
Collapse All
C#
protected virtual Datablock GetCache();
Remarks

This is GetCache, a member of class AbstractDataBlockPersistenceMapper.

See Also
AbstractDataBlockPersistenceMapper Class
Eco.Persistence Namespace


AbstractDataBlockPersistenceMapper.GetPersistenceMapper Method

AbstractDataBlockPersistenceMapper.GetPersistenceMapper Method
AbstractDataBlockPersistenceMapper Class Eco.Persistence Namespace See Also
Collapse All
C#
public override IPersistenceMapper GetPersistenceMapper(
    ITypeSystemService typeSystemService
);
Remarks

This is GetPersistenceMapper, a member of class AbstractDataBlockPersistenceMapper.

See Also
AbstractDataBlockPersistenceMapper Class
Eco.Persistence Namespace


AbstractDataBlockPersistenceMapper.ReturnPersistenceMapper Method

AbstractDataBlockPersistenceMapper.ReturnPersistenceMapper Method
AbstractDataBlockPersistenceMapper Class Eco.Persistence Namespace See Also
Collapse All
C#
public override void ReturnPersistenceMapper(
    IPersistenceMapper persistenceMapper
);
Remarks

This is ReturnPersistenceMapper, a member of class AbstractDataBlockPersistenceMapper.

See Also
AbstractDataBlockPersistenceMapper Class
Eco.Persistence Namespace


AbstractDataBlockPersistenceMapper.Update Method

AbstractDataBlockPersistenceMapper.Update Method
AbstractDataBlockPersistenceMapper Class Eco.Persistence Namespace See Also
Collapse All
C#
protected virtual void Update(
    Datablock datablock,
    out IdTranslationList translationList
);
Remarks

This is Update, a member of class AbstractDataBlockPersistenceMapper.

See Also
AbstractDataBlockPersistenceMapper Class
Eco.Persistence Namespace


AbstractDataBlockPersistenceMapper.WriteDatablock Method

AbstractDataBlockPersistenceMapper.WriteDatablock Method
AbstractDataBlockPersistenceMapper Class Eco.Persistence Namespace See Also
Collapse All
C#
protected abstract void WriteDatablock(
    Datablock datablock
);
Remarks

This is WriteDatablock, a member of class AbstractDataBlockPersistenceMapper.

See Also
AbstractDataBlockPersistenceMapper Class
Eco.Persistence Namespace


AbstractDataBlockPersistenceMapper Properties

AbstractDataBlockPersistenceMapper Properties
Public Properties Protected Properties
Collapse All

The properties of the AbstractDataBlockPersistenceMapper class are listed here.

Public Properties
Name | Description
CacheData | This is CacheData, a member of class AbstractDataBlockPersistenceMapper.
MultiUser | If true, the data file will be reread if it has been modified on disk
SyncHandler | This is SyncHandler, a member of class AbstractDataBlockPersistenceMapper.
Top
Protected Properties
Name | Description
TypeSystem | This is TypeSystem, a member of class AbstractDataBlockPersistenceMapper.


AbstractDataBlockPersistenceMapper.CacheData Property

AbstractDataBlockPersistenceMapper.CacheData Property
AbstractDataBlockPersistenceMapper Class Eco.Persistence Namespace See Also
Collapse All
C#
public bool CacheData;
Remarks

This is CacheData, a member of class AbstractDataBlockPersistenceMapper.

See Also
AbstractDataBlockPersistenceMapper Class
Eco.Persistence Namespace


AbstractDataBlockPersistenceMapper.MultiUser Property

AbstractDataBlockPersistenceMapper.MultiUser Property
AbstractDataBlockPersistenceMapper Class Eco.Persistence Namespace See Also
Collapse All

If true, the data file will be reread if it has been modified on disk

C#
public bool MultiUser;
Remarks

If more than one client is accessing the same datafile, the contents of the file must be reread everytime another client has modified it.

If this property is false, an exception will be thrown if the file has been touched by someone else

See Also
AbstractDataBlockPersistenceMapper Class
Eco.Persistence Namespace


AbstractDataBlockPersistenceMapper.SyncHandler Property

AbstractDataBlockPersistenceMapper.SyncHandler Property
AbstractDataBlockPersistenceMapper Class Eco.Persistence Namespace See Also
Collapse All
C#
public AbstractSyncHandler SyncHandler;
Remarks

This is SyncHandler, a member of class AbstractDataBlockPersistenceMapper.

See Also
AbstractDataBlockPersistenceMapper Class
Eco.Persistence Namespace


AbstractDataBlockPersistenceMapper.TypeSystem Property

AbstractDataBlockPersistenceMapper.TypeSystem Property
AbstractDataBlockPersistenceMapper Class Eco.Persistence Namespace See Also
Collapse All
C#
protected IEcoTypeSystem TypeSystem;
Remarks

This is TypeSystem, a member of class AbstractDataBlockPersistenceMapper.

See Also
AbstractDataBlockPersistenceMapper Class
Eco.Persistence Namespace


AbstractPersistenceMapperBlackfish Class

AbstractPersistenceMapperBlackfish Class
Inheritance Hierarchy See Also
Collapse All
C#
public abstract class AbstractPersistenceMapperBlackfish : PersistenceMapperAdo2, IAutoHookable;
Remarks

This is class Eco.Persistence.AbstractPersistenceMapperBlackfish.

Inheritance Hierarchy
Eco.Persistence.IPersistencemapperProvider
    Eco.Persistence.PersistenceMapper
        Eco.Persistence.AbstractPersistenceMapperDb
        Eco.Persistence.IPersistenceMapperDb
            Eco.Persistence.PersistenceMapperDb
            Eco.Persistence.IAutoHookable
                Eco.Persistence.PersistenceMapperAdo2
                    Eco.Persistence.AbstractPersistenceMapperBlackfish
                        Eco.Persistence.PersistenceMapperBlackfish
                        Eco.Persistence.PersistenceMapperBlackfishRemote
File

AbstractPersistenceMapperBlackfish.cs

See Also
Inheritance Hierarchy


AbstractPersistenceMapperBlackfish Methods

AbstractPersistenceMapperBlackfish Methods
Protected Methods Public Methods
Collapse All

The methods of the AbstractPersistenceMapperBlackfish class are listed here.

Protected Methods
Name | Description
InternalCreateIDatabase | This is InternalCreateIDatabase, a member of class AbstractPersistenceMapperBlackfish.
Top
Public Methods
Name | Description
InitializeSqlDatabaseConfig | Configures the SqlDatabaseConfig with specific settings for this mapper.
RegisterAttributeMappers | This is RegisterAttributeMappers, a member of class AbstractPersistenceMapperBlackfish.


AbstractPersistenceMapperBlackfish.InitializeSqlDatabaseConfig Method

AbstractPersistenceMapperBlackfish.InitializeSqlDatabaseConfig Method
AbstractPersistenceMapperBlackfish Class Eco.Persistence Namespace See Also
Collapse All

Configures the SqlDatabaseConfig with specific settings for this mapper.

C#
public void InitializeSqlDatabaseConfig();
See Also
AbstractPersistenceMapperBlackfish Class
Eco.Persistence Namespace


AbstractPersistenceMapperBlackfish.InternalCreateIDatabase Method

AbstractPersistenceMapperBlackfish.InternalCreateIDatabase Method
AbstractPersistenceMapperBlackfish Class Eco.Persistence Namespace See Also
Collapse All
C#
protected override IDatabase InternalCreateIDatabase(
    DbConnection connection,
    SqlDatabaseConfig config
);
Remarks

This is InternalCreateIDatabase, a member of class AbstractPersistenceMapperBlackfish.

See Also
AbstractPersistenceMapperBlackfish Class
Eco.Persistence Namespace


AbstractPersistenceMapperBlackfish.RegisterAttributeMappers Method

AbstractPersistenceMapperBlackfish.RegisterAttributeMappers Method
AbstractPersistenceMapperBlackfish Class Eco.Persistence Namespace See Also
Collapse All
C#
public static void RegisterAttributeMappers();
Remarks

This is RegisterAttributeMappers, a member of class AbstractPersistenceMapperBlackfish.

See Also
AbstractPersistenceMapperBlackfish Class
Eco.Persistence Namespace


AbstractPersistenceMapperBlackfish Properties

AbstractPersistenceMapperBlackfish Properties
Public Properties
Collapse All

The properties of the AbstractPersistenceMapperBlackfish class are listed here.

Public Properties
Name | Description
Connection | This is Connection, a member of class AbstractPersistenceMapperBlackfish.


AbstractPersistenceMapperBlackfish.Connection Property

AbstractPersistenceMapperBlackfish.Connection Property
AbstractPersistenceMapperBlackfish Class Eco.Persistence Namespace See Also
Collapse All
C#
public DataStoreConnection Connection;
Remarks

This is Connection, a member of class AbstractPersistenceMapperBlackfish.

See Also
AbstractPersistenceMapperBlackfish Class
Eco.Persistence Namespace


AbstractPersistenceMapperDb Class

AbstractPersistenceMapperDb Class
Inheritance Hierarchy See Also
Collapse All

Superclass for all persistence mappers that persist to a relational database.

C#
public abstract class AbstractPersistenceMapperDb : PersistenceMapper;
Inheritance Hierarchy
Eco.Persistence.IPersistencemapperProvider
    Eco.Persistence.PersistenceMapper
        Eco.Persistence.AbstractPersistenceMapperDb
            Eco.Persistence.PersistenceMapperDb
            Eco.Persistence.PersistenceMapperMultiDb
File

AbstractPersistenceMapperDb.cs

See Also
Inheritance Hierarchy


AbstractPersistenceMapperDb.AbstractPersistenceMapperDb Constructor

AbstractPersistenceMapperDb.AbstractPersistenceMapperDb Constructor
AbstractPersistenceMapperDb Class Eco.Persistence Namespace See Also
Collapse All
C#
protected AbstractPersistenceMapperDb();
Remarks

This is AbstractPersistenceMapperDb, a member of class AbstractPersistenceMapperDb.

See Also
AbstractPersistenceMapperDb Class
Eco.Persistence Namespace


AbstractPersistenceMapperDb Methods

AbstractPersistenceMapperDb Methods
Protected Methods Public Methods
Collapse All

The methods of the AbstractPersistenceMapperDb class are listed here.

Protected Methods
Name | Description
CreateSchemaScript | This is CreateSchemaScript, a member of class AbstractPersistenceMapperDb.
Dispose | This is Dispose, a member of class AbstractPersistenceMapperDb.
EnsureNotActive | This is EnsureNotActive, a member of class AbstractPersistenceMapperDb.
GetEvolutor | This is GetEvolutor, a member of class AbstractPersistenceMapperDb.
GetPersistenceMapper | This is GetPersistenceMapper, a member of class AbstractPersistenceMapperDb.
SetCompatibilityMode | This is SetCompatibilityMode, a member of class AbstractPersistenceMapperDb.
SetPersistenceMapperWithIDatabase | This is SetPersistenceMapperWithIDatabase, a member of class AbstractPersistenceMapperDb.
SetTypeSystemService | This is SetTypeSystemService, a member of class AbstractPersistenceMapperDb.
ValidateDataStructure | This is ValidateDataStructure, a member of class AbstractPersistenceMapperDb.
ValidateSchemaStructure | This is ValidateSchemaStructure, a member of class AbstractPersistenceMapperDb.
Top
Public Methods
Name | Description
CloseConnections | This method should be used to close any open database connections.
CreateDatabaseSchema | This is CreateDatabaseSchema, a member of class AbstractPersistenceMapperDb.


AbstractPersistenceMapperDb.CloseConnections Method

AbstractPersistenceMapperDb.CloseConnections Method
AbstractPersistenceMapperDb Class Eco.Persistence Namespace See Also
Collapse All

This method should be used to close any open database connections.

C#
public abstract void CloseConnections(
    bool force
);
Parameters
Parameters | Description
force | This parameter will be true if the component is being disposed.
See Also
AbstractPersistenceMapperDb Class
Eco.Persistence Namespace


AbstractPersistenceMapperDb.CreateDatabaseSchema Method

AbstractPersistenceMapperDb.CreateDatabaseSchema Method
AbstractPersistenceMapperDb Class Eco.Persistence Namespace See Also
Collapse All
C#
public void CreateDatabaseSchema(
    ITypeSystemService typeSystemService,
    IDatabaseCollection databases,
    string databaseName,
    IORMappingProvider newMappingProvider,
    IORMappingProvider oldMappingProvider,
    IConfigureCleanPS configureCleanPS
);
Remarks

This is CreateDatabaseSchema, a member of class AbstractPersistenceMapperDb.

See Also
AbstractPersistenceMapperDb Class
Eco.Persistence Namespace


AbstractPersistenceMapperDb.CreateSchemaScript Method

AbstractPersistenceMapperDb.CreateSchemaScript Method
AbstractPersistenceMapperDb Class Eco.Persistence Namespace See Also
Collapse All
C#
protected IList<string> CreateSchemaScript(
    ITypeSystemService typeSystemService,
    IDatabaseCollection databases,
    string dbName,
    IORMappingProvider newMappingProvider,
    IORMappingProvider oldMappingProvider
);
Remarks

This is CreateSchemaScript, a member of class AbstractPersistenceMapperDb.

See Also
AbstractPersistenceMapperDb Class
Eco.Persistence Namespace


AbstractPersistenceMapperDb.Dispose Method

AbstractPersistenceMapperDb.Dispose Method
AbstractPersistenceMapperDb Class Eco.Persistence Namespace See Also
Collapse All
C#
protected override void Dispose(
    bool disposing
);
Remarks

This is Dispose, a member of class AbstractPersistenceMapperDb.

See Also
AbstractPersistenceMapperDb Class
Eco.Persistence Namespace


AbstractPersistenceMapperDb.EnsureNotActive Method

AbstractPersistenceMapperDb.EnsureNotActive Method
AbstractPersistenceMapperDb Class Eco.Persistence Namespace See Also
Collapse All
C#
protected void EnsureNotActive();
Remarks

This is EnsureNotActive, a member of class AbstractPersistenceMapperDb.

See Also
AbstractPersistenceMapperDb Class
Eco.Persistence Namespace


AbstractPersistenceMapperDb.GetEvolutor Method

AbstractPersistenceMapperDb.GetEvolutor Method
AbstractPersistenceMapperDb Class Eco.Persistence Namespace See Also
Collapse All
C#
protected IDBEvolutor GetEvolutor(
    ITypeSystemService typeSystemService,
    IDatabaseCollection databases,
    string databaseName,
    IORMappingProvider newMappingProvider,
    IORMappingProvider oldMappingProvider
);
Remarks

This is GetEvolutor, a member of class AbstractPersistenceMapperDb.

See Also
AbstractPersistenceMapperDb Class
Eco.Persistence Namespace


AbstractPersistenceMapperDb.GetPersistenceMapper Method

AbstractPersistenceMapperDb.GetPersistenceMapper Method
AbstractPersistenceMapperDb Class Eco.Persistence Namespace See Also
Collapse All
C#
protected IPersistenceMapperWithIDatabase GetPersistenceMapper(
    ITypeSystemService typeSystemService,
    IDatabaseCollection databases,
    ORMappingDefinition mapping,
    TimeSpan VersionGranularity,
    GetDateTimeDelegate GetDateTime
);
Remarks

This is GetPersistenceMapper, a member of class AbstractPersistenceMapperDb.

See Also
AbstractPersistenceMapperDb Class
Eco.Persistence Namespace


AbstractPersistenceMapperDb.SetCompatibilityMode Method

AbstractPersistenceMapperDb.SetCompatibilityMode Method
AbstractPersistenceMapperDb Class Eco.Persistence Namespace See Also
Collapse All
C#
protected virtual void SetCompatibilityMode(
    EcoCompatibilityMode mode
);
Remarks

This is SetCompatibilityMode, a member of class AbstractPersistenceMapperDb.

See Also
AbstractPersistenceMapperDb Class
Eco.Persistence Namespace


AbstractPersistenceMapperDb.SetPersistenceMapperWithIDatabase Method

AbstractPersistenceMapperDb.SetPersistenceMapperWithIDatabase Method
AbstractPersistenceMapperDb Class Eco.Persistence Namespace See Also
Collapse All
C#
protected void SetPersistenceMapperWithIDatabase(
    IPersistenceMapperWithIDatabase value
);
Remarks

This is SetPersistenceMapperWithIDatabase, a member of class AbstractPersistenceMapperDb.

See Also
AbstractPersistenceMapperDb Class
Eco.Persistence Namespace


AbstractPersistenceMapperDb.SetTypeSystemService Method

AbstractPersistenceMapperDb.SetTypeSystemService Method
AbstractPersistenceMapperDb Class Eco.Persistence Namespace See Also
Collapse All
C#
protected void SetTypeSystemService(
    ITypeSystemService value
);
Remarks

This is SetTypeSystemService, a member of class AbstractPersistenceMapperDb.

See Also
AbstractPersistenceMapperDb Class
Eco.Persistence Namespace


AbstractPersistenceMapperDb.ValidateDataStructure Method

AbstractPersistenceMapperDb.ValidateDataStructure Method
AbstractPersistenceMapperDb Class Eco.Persistence Namespace See Also
Collapse All
C#
protected bool ValidateDataStructure(
    IList<string> remedies,
    ITypeSystemService typeSystemService,
    IDatabaseCollection databases,
    string databaseName,
    IORMappingProvider mappingProvider
);
Remarks

This is ValidateDataStructure, a member of class AbstractPersistenceMapperDb.

See Also
AbstractPersistenceMapperDb Class
Eco.Persistence Namespace


AbstractPersistenceMapperDb.ValidateSchemaStructure Method

AbstractPersistenceMapperDb.ValidateSchemaStructure Method
AbstractPersistenceMapperDb Class Eco.Persistence Namespace See Also
Collapse All
C#
protected bool ValidateSchemaStructure(
    IList<string> remedies,
    ITypeSystemService typeSystemService,
    IDatabaseCollection databases,
    string databaseName,
    IORMappingProvider mappingProvider
);
Remarks

This is ValidateSchemaStructure, a member of class AbstractPersistenceMapperDb.

See Also
AbstractPersistenceMapperDb Class
Eco.Persistence Namespace


AbstractPersistenceMapperDb Properties

AbstractPersistenceMapperDb Properties
Public Properties Protected Properties
Collapse All

The properties of the AbstractPersistenceMapperDb class are listed here.

Public Properties
Name | Description
CompatibilityMode | This compatibility mode is only used when the RuntimeMappingProvider is null. It controls the names of system-tables and columns. If you want more control over the settings, add your own DefaultORMappingProvider component and set the RuntimeMappingProvider to this component
EffectiveRunTimeMappingProvider | This property returns the RunTimeMappingProvider that will actually be used in runtime. If the RunTimeMappingProvider property is not set, this property will return a DefaultOrMappingProvider
HistoryLength | Obsolete, use the SyncHandler.HistoryLength property instead.
OnGetCurrentTime | FIXME [LocalizableDescription()
RunTimeMappingProvider | Provides mapping information at runtime.
SyncActive | Obsolete, use the SyncHandler property instead.
SyncHandler | Links the persistence component to a sync handler to enable support for multi-user change notification.
VersionGranularity | This property is used when a class is marked as Versioned in order to determine how much time must elapse between object updates before a new version of the object is created.
Top
Protected Properties
Name | Description
ActiveCount | This is ActiveCount, a member of class AbstractPersistenceMapperDb.
PmapperWithDb | This is PmapperWithDb, a member of class AbstractPersistenceMapperDb.
TypeSystemService | This is TypeSystemService, a member of class AbstractPersistenceMapperDb.


AbstractPersistenceMapperDb.ActiveCount Property

AbstractPersistenceMapperDb.ActiveCount Property
AbstractPersistenceMapperDb Class Eco.Persistence Namespace See Also
Collapse All
C#
protected int ActiveCount;
Remarks

This is ActiveCount, a member of class AbstractPersistenceMapperDb.

See Also
AbstractPersistenceMapperDb Class
Eco.Persistence Namespace


AbstractPersistenceMapperDb.CompatibilityMode Property

AbstractPersistenceMapperDb.CompatibilityMode Property
AbstractPersistenceMapperDb Class Eco.Persistence Namespace See Also
Collapse All

This compatibility mode is only used when the RuntimeMappingProvider is null. It controls the names of system-tables and columns. If you want more control over the settings, add your own DefaultORMappingProvider component and set the RuntimeMappingProvider to this component

C#
public EcoCompatibilityMode CompatibilityMode;
See Also
AbstractPersistenceMapperDb Class
Eco.Persistence Namespace


AbstractPersistenceMapperDb.EffectiveRunTimeMappingProvider Property

AbstractPersistenceMapperDb.EffectiveRunTimeMappingProvider Property
AbstractPersistenceMapperDb Class Eco.Persistence Namespace See Also
Collapse All

This property returns the RunTimeMappingProvider that will actually be used in runtime. If the RunTimeMappingProvider property is not set, this property will return a DefaultOrMappingProvider

C#
public IORMappingProvider EffectiveRunTimeMappingProvider;
See Also
AbstractPersistenceMapperDb Class
Eco.Persistence Namespace


AbstractPersistenceMapperDb.HistoryLength Property

AbstractPersistenceMapperDb.HistoryLength Property
AbstractPersistenceMapperDb Class Eco.Persistence Namespace See Also
Collapse All

Obsolete, use the SyncHandler.HistoryLength property instead.

C#
public int HistoryLength;
See Also
AbstractPersistenceMapperDb Class
Eco.Persistence Namespace


AbstractPersistenceMapperDb.OnGetCurrentTime Property

AbstractPersistenceMapperDb.OnGetCurrentTime Property
AbstractPersistenceMapperDb Class Eco.Persistence Namespace See Also
Collapse All
C#
public GetDateTimeDelegate OnGetCurrentTime;
Remarks

FIXME [LocalizableDescription()

See Also
AbstractPersistenceMapperDb Class
Eco.Persistence Namespace


AbstractPersistenceMapperDb.PmapperWithDb Property

AbstractPersistenceMapperDb.PmapperWithDb Property
AbstractPersistenceMapperDb Class Eco.Persistence Namespace See Also
Collapse All
C#
protected IPersistenceMapperWithIDatabase PmapperWithDb;
Remarks

This is PmapperWithDb, a member of class AbstractPersistenceMapperDb.

See Also
AbstractPersistenceMapperDb Class
Eco.Persistence Namespace


AbstractPersistenceMapperDb.RunTimeMappingProvider Property

AbstractPersistenceMapperDb.RunTimeMappingProvider Property
AbstractPersistenceMapperDb Class Eco.Persistence Namespace See Also
Collapse All

Provides mapping information at runtime.

C#
public IORMappingProvider RunTimeMappingProvider;
Remarks

This property is used when custom mapping is required. The component it links to holds information used at runtime that ECO will use to determine which tables an class should be mapped to.

See Also
AbstractPersistenceMapperDb Class
Eco.Persistence Namespace


AbstractPersistenceMapperDb.SyncActive Property

AbstractPersistenceMapperDb.SyncActive Property
AbstractPersistenceMapperDb Class Eco.Persistence Namespace See Also
Collapse All

Obsolete, use the SyncHandler property instead.

C#
public bool SyncActive;
See Also
AbstractPersistenceMapperDb Class
Eco.Persistence Namespace


AbstractPersistenceMapperDb.SyncHandler Property

AbstractPersistenceMapperDb.SyncHandler Property
AbstractPersistenceMapperDb Class Eco.Persistence Namespace See Also
Collapse All

Links the persistence component to a sync handler to enable support for multi-user change notification.

C#
public AbstractSyncHandler SyncHandler;
See Also
AbstractPersistenceMapperDb Class
Eco.Persistence Namespace


AbstractPersistenceMapperDb.TypeSystemService Property

AbstractPersistenceMapperDb.TypeSystemService Property
AbstractPersistenceMapperDb Class Eco.Persistence Namespace See Also
Collapse All
C#
protected ITypeSystemService TypeSystemService;
Remarks

This is TypeSystemService, a member of class AbstractPersistenceMapperDb.

See Also
AbstractPersistenceMapperDb Class
Eco.Persistence Namespace


AbstractPersistenceMapperDb.VersionGranularity Property

AbstractPersistenceMapperDb.VersionGranularity Property
AbstractPersistenceMapperDb Class Eco.Persistence Namespace See Also
Collapse All

This property is used when a class is marked as Versioned in order to determine how much time must elapse between object updates before a new version of the object is created.

C#
public TimeSpan VersionGranularity;
Remarks

If two changes occur to the same object within the specified time span then the latest saved version will be updated. If the second change occurs after a period of time that is greater than this time span it will cause a new version to be created.

For example, the developer may decide that two updates to the same object within an hour should result in the existing version being updated.

See Also
AbstractPersistenceMapperDb Class
Eco.Persistence Namespace


AbstractPersistenceMapperFile Class

AbstractPersistenceMapperFile Class
Inheritance Hierarchy See Also
Collapse All
C#
public abstract class AbstractPersistenceMapperFile : AbstractDataBlockPersistenceMapper;
Remarks

This is class Eco.Persistence.AbstractPersistenceMapperFile.

Inheritance Hierarchy
Eco.Persistence.IPersistencemapperProvider
    Eco.Persistence.PersistenceMapper
    Eco.Persistence.IPersistenceMapper
        Eco.Persistence.AbstractDataBlockPersistenceMapper
            Eco.Persistence.AbstractPersistenceMapperFile
                Eco.Persistence.PersistenceMapperXml
File

PersistenceMapperXML.cs

See Also
Inheritance Hierarchy


AbstractPersistenceMapperFile Methods

AbstractPersistenceMapperFile Methods
Protected Methods
Collapse All

The methods of the AbstractPersistenceMapperFile class are listed here.

Protected Methods
Name | Description
Activating | IPersistenceHandleImpl
EnsureCacheCurrent | This is EnsureCacheCurrent, a member of class AbstractPersistenceMapperFile.
GetCache | This is GetCache, a member of class AbstractPersistenceMapperFile.
ReadDatablock | This is ReadDatablock, a member of class AbstractPersistenceMapperFile.
Update | This is Update, a member of class AbstractPersistenceMapperFile.


AbstractPersistenceMapperFile.Activating Method

AbstractPersistenceMapperFile.Activating Method
AbstractPersistenceMapperFile Class Eco.Persistence Namespace See Also
Collapse All
C#
protected override void Activating();
Remarks

IPersistenceHandleImpl

See Also
AbstractPersistenceMapperFile Class
Eco.Persistence Namespace


AbstractPersistenceMapperFile.EnsureCacheCurrent Method

AbstractPersistenceMapperFile.EnsureCacheCurrent Method
AbstractPersistenceMapperFile Class Eco.Persistence Namespace See Also
Collapse All
C#
protected override void EnsureCacheCurrent();
Remarks

This is EnsureCacheCurrent, a member of class AbstractPersistenceMapperFile.

See Also
AbstractPersistenceMapperFile Class
Eco.Persistence Namespace


AbstractPersistenceMapperFile.GetCache Method

AbstractPersistenceMapperFile.GetCache Method
AbstractPersistenceMapperFile Class Eco.Persistence Namespace See Also
Collapse All
C#
protected override Datablock GetCache();
Remarks

This is GetCache, a member of class AbstractPersistenceMapperFile.

See Also
AbstractPersistenceMapperFile Class
Eco.Persistence Namespace


AbstractPersistenceMapperFile.ReadDatablock Method

AbstractPersistenceMapperFile.ReadDatablock Method
AbstractPersistenceMapperFile Class Eco.Persistence Namespace See Also
Collapse All
C#
protected abstract Datablock ReadDatablock();
Remarks

This is ReadDatablock, a member of class AbstractPersistenceMapperFile.

See Also
AbstractPersistenceMapperFile Class
Eco.Persistence Namespace


AbstractPersistenceMapperFile.Update Method

AbstractPersistenceMapperFile.Update Method
AbstractPersistenceMapperFile Class Eco.Persistence Namespace See Also
Collapse All
C#
protected override void Update(
    Datablock datablock,
    out IdTranslationList translationList
);
Remarks

This is Update, a member of class AbstractPersistenceMapperFile.

See Also
AbstractPersistenceMapperFile Class
Eco.Persistence Namespace


AbstractPersistenceMapperFile Properties

AbstractPersistenceMapperFile Properties
Public Properties
Collapse All

The properties of the AbstractPersistenceMapperFile class are listed here.

Public Properties
Name | Description
FileName | This is FileName, a member of class AbstractPersistenceMapperFile.


AbstractPersistenceMapperFile.FileName Property

AbstractPersistenceMapperFile.FileName Property
AbstractPersistenceMapperFile Class Eco.Persistence Namespace See Also
Collapse All
C#
public string FileName;
Remarks

This is FileName, a member of class AbstractPersistenceMapperFile.

See Also
AbstractPersistenceMapperFile Class
Eco.Persistence Namespace


AbstractSyncHandler Class

AbstractSyncHandler Class
Inheritance Hierarchy See Also
Collapse All

The base class for implementing a multi-user sync component.

C#
public abstract class AbstractSyncHandler : Component, ISyncSink;
Inheritance Hierarchy
Eco.Persistence.ISyncSink
    Eco.Persistence.AbstractSyncHandler
        Eco.Persistence.SyncHandler
File

AbstractSyncHandler.cs

See Also
Inheritance Hierarchy


AbstractSyncHandler Methods

AbstractSyncHandler Methods
Public Methods
Collapse All

The methods of the AbstractSyncHandler class are listed here.

Public Methods
Name | Description
CurrentSyncVersion | Returns the current sync version.
GetChangesSince | Returns a collection of DBChange since a given time.


AbstractSyncHandler.CurrentSyncVersion Method

AbstractSyncHandler.CurrentSyncVersion Method
AbstractSyncHandler Class Eco.Persistence Namespace See Also
Collapse All

Returns the current sync version.

C#
public abstract SyncVersion CurrentSyncVersion();
See Also
AbstractSyncHandler Class
Eco.Persistence Namespace


AbstractSyncHandler.GetChangesSince Method

AbstractSyncHandler.GetChangesSince Method
AbstractSyncHandler Class Eco.Persistence Namespace See Also
Collapse All

Returns a collection of DBChange since a given time.

C#
public abstract DBChangeCollection GetChangesSince(
    SyncVersion fromVersion,
    SyncVersion[] exclude,
    out SyncVersion lastSyncVersion,
    IEcoTypeSystem typeSystem
);
Parameters
Parameters | Description
fromVersion | The earliest version to start returning changes from.
exclude | An array of version numbers that the client instigated, this prevents a client from receiving a list of its own changes.
lastSyncVersion | Returns the latest sync version.
typeSystem | Provides a reference to model information.
Returns

Returns a collection of changes for the client EcoSpace to process.

See Also
AbstractSyncHandler Class
Eco.Persistence Namespace


AllInstancesCondition Class

AllInstancesCondition Class
Inheritance Hierarchy See Also
Collapse All
C#
public sealed class AllInstancesCondition : AbstractCondition;
Remarks

This is class Eco.Persistence.AllInstancesCondition.

Inheritance Hierarchy
Eco.Persistence.AbstractCondition
    Eco.Persistence.AllInstancesCondition
File

PersistenceMapperInterfaces.cs

See Also
Inheritance Hierarchy


AllInstancesCondition Constructor

AllInstancesCondition Constructor

This is the overview for the AllInstancesCondition constructor overload.

Overload List
Name | Description
AllInstancesCondition.AllInstancesCondition (int) | This is AllInstancesCondition, a member of class AllInstancesCondition.
AllInstancesCondition.AllInstancesCondition (int, int) | This is AllInstancesCondition, a member of class AllInstancesCondition.


AllInstancesCondition.AllInstancesCondition Constructor (int)

AllInstancesCondition.AllInstancesCondition Constructor (int)
AllInstancesCondition Class Eco.Persistence Namespace See Also
Collapse All
C#
public AllInstancesCondition(
    int classId
);
Remarks

This is AllInstancesCondition, a member of class AllInstancesCondition.

See Also
AllInstancesCondition Class
Eco.Persistence Namespace


AllInstancesCondition.AllInstancesCondition Constructor (int, int)

AllInstancesCondition.AllInstancesCondition Constructor (int, int)
AllInstancesCondition Class Eco.Persistence Namespace See Also
Collapse All
C#
public AllInstancesCondition(
    int classId,
    int version
);
Remarks

This is AllInstancesCondition, a member of class AllInstancesCondition.

See Also
AllInstancesCondition Class
Eco.Persistence Namespace


AttributeKeyMapper Class

AttributeKeyMapper Class
Inheritance Hierarchy See Also
Collapse All
C#
public class AttributeKeyMapper : GenericKeyMapper, IKeyMapper;
Remarks

This is class Eco.Persistence.AttributeKeyMapper.

Inheritance Hierarchy
Eco.Persistence.GenericKeyMapper
Eco.Persistence.IKeyMapper
    Eco.Persistence.AttributeKeyMapper
File

AttributeKeyMapper.cs

See Also
Inheritance Hierarchy


AttributeKeyMapper Methods

AttributeKeyMapper Methods
Public Methods
Collapse All

The methods of the AttributeKeyMapper class are listed here.

Public Methods
Name | Description
ColumnCount | Returns the number of columns that are used to store the id
ColumnType |
GetIdAllocationMode | Indicates the strategy used by the key mapper.
IdFromFields | This method creates a new id based on the values of the field objects
IdListToWhereFragment |
IdToParameters | This method fills the parameter objects with data from an id
Initialize | This method is called after the key mapper has been created to initialize the keymapper with some basic configuration.
InitializeDatabase | This method may perform initialization of the database such as installing generators for autoinc mechanisms.
InitializeDatabaseScript | Same as InitializeDatabase, but rather than operating directly on the database, the initializations should be returned as sql statements to be used in a script.
InitializePSDescriptions | This method can add additional tables/columns if the keymapper requires any additional structure in the database schema. It is called once per session.
NewIdFromAttributes |
NewIdPreUpdate | This method is called once for each object (if IdAllocationMode = PreUpdate) that needs to have a persistent id. It must return a new id with the same ClassId as the old id
ReserveId | This method is called once for each object before objects are updated (if IdAllocationMode = PreUpdate and allows the keymapper to prepare for the number of IDs that needs to be allocated


AttributeKeyMapper.ColumnCount Method

AttributeKeyMapper.ColumnCount Method
AttributeKeyMapper Class Eco.Persistence Namespace See Also
Collapse All

Returns the number of columns that are used to store the id

C#
public int ColumnCount();
See Also
AttributeKeyMapper Class
Eco.Persistence Namespace


AttributeKeyMapper.ColumnType Method

AttributeKeyMapper.ColumnType Method
AttributeKeyMapper Class Eco.Persistence Namespace See Also
Collapse All
C#
public string ColumnType(
    ArrayList keyMappers,
    int columnNum
);
Exceptions
Exceptions | Description
ArgumentNullException | Thrown if keyMappers is null
See Also
AttributeKeyMapper Class
Eco.Persistence Namespace


AttributeKeyMapper.GetIdAllocationMode Method

AttributeKeyMapper.GetIdAllocationMode Method
AttributeKeyMapper Class Eco.Persistence Namespace See Also
Collapse All

Indicates the strategy used by the key mapper.

C#
public IdAllocationMode GetIdAllocationMode();
Remarks

FromAttributes means that the key mapper will extract the key values from the contents of the object. PreUpdate means that the id values can be allocated prior to updating the object (used by the default eco key mapper and the guid-mapper). PostUpdate means that the id values can only be obtained after the object has been inserted to the database (used by autoinc mapper).

See Also
AttributeKeyMapper Class
Eco.Persistence Namespace


AttributeKeyMapper.IdFromFields Method

AttributeKeyMapper.IdFromFields Method
AttributeKeyMapper Class Eco.Persistence Namespace See Also
Collapse All

This method creates a new id based on the values of the field objects

C#
public ObjectId IdFromFields(
    IField[] keyFields,
    ArrayList keyMappers,
    int classId,
    int timeStamp
);
See Also
AttributeKeyMapper Class
Eco.Persistence Namespace


AttributeKeyMapper.IdListToWhereFragment Method

AttributeKeyMapper.IdListToWhereFragment Method
AttributeKeyMapper Class Eco.Persistence Namespace See Also
Collapse All
C#
public override string IdListToWhereFragment(
    ObjectIdCollection idList,
    IParameterized parameterized,
    IList<string> idColumns,
    string idPrefix
);
Exceptions
Exceptions | Description
ArgumentNullException | Thrown if idList is null Thrown if idColumns is null
See Also
AttributeKeyMapper Class
Eco.Persistence Namespace


AttributeKeyMapper.IdToParameters Method

AttributeKeyMapper.IdToParameters Method
AttributeKeyMapper Class Eco.Persistence Namespace See Also
Collapse All

This method fills the parameter objects with data from an id

C#
public void IdToParameters(
    ObjectId id,
    IDataParameter[] parameters
);
See Also
AttributeKeyMapper Class
Eco.Persistence Namespace


AttributeKeyMapper.Initialize Method

AttributeKeyMapper.Initialize Method
AttributeKeyMapper Class Eco.Persistence Namespace See Also
Collapse All

This method is called after the key mapper has been created to initialize the keymapper with some basic configuration.

C#
public void Initialize(
    SqlDatabaseConfig config,
    ArrayList keyMappers
);
See Also
AttributeKeyMapper Class
Eco.Persistence Namespace


AttributeKeyMapper.InitializeDatabase Method

AttributeKeyMapper.InitializeDatabase Method
AttributeKeyMapper Class Eco.Persistence Namespace See Also
Collapse All

This method may perform initialization of the database such as installing generators for autoinc mechanisms.

C#
public void InitializeDatabase(
    IDatabase db
);
See Also
AttributeKeyMapper Class
Eco.Persistence Namespace


AttributeKeyMapper.InitializeDatabaseScript Method

AttributeKeyMapper.InitializeDatabaseScript Method
AttributeKeyMapper Class Eco.Persistence Namespace See Also
Collapse All

Same as InitializeDatabase, but rather than operating directly on the database, the initializations should be returned as sql statements to be used in a script.

C#
public void InitializeDatabaseScript(
    IList<string> script
);
See Also
AttributeKeyMapper Class
Eco.Persistence Namespace


AttributeKeyMapper.InitializePSDescriptions Method

AttributeKeyMapper.InitializePSDescriptions Method
AttributeKeyMapper Class Eco.Persistence Namespace See Also
Collapse All

This method can add additional tables/columns if the keymapper requires any additional structure in the database schema. It is called once per session.

C#
public void InitializePSDescriptions(
    IDatabaseDefinition db
);
See Also
AttributeKeyMapper Class
Eco.Persistence Namespace


AttributeKeyMapper.NewIdFromAttributes Method

AttributeKeyMapper.NewIdFromAttributes Method
AttributeKeyMapper Class Eco.Persistence Namespace See Also
Collapse All
C#
public ObjectId NewIdFromAttributes(
    ObjectContents objContents,
    ArrayList memberIndexes,
    IdTranslationList translationList
);
Exceptions
Exceptions | Description
ArgumentNullException | Thrown if memberIndexes is null Thrown if objContents is null
See Also
AttributeKeyMapper Class
Eco.Persistence Namespace


AttributeKeyMapper.NewIdPreUpdate Method

AttributeKeyMapper.NewIdPreUpdate Method
AttributeKeyMapper Class Eco.Persistence Namespace See Also
Collapse All

This method is called once for each object (if IdAllocationMode = PreUpdate) that needs to have a persistent id. It must return a new id with the same ClassId as the old id

C#
public ObjectId NewIdPreUpdate(
    IDatabase db,
    ObjectId oldId
);
See Also
AttributeKeyMapper Class
Eco.Persistence Namespace


AttributeKeyMapper.ReserveId Method

AttributeKeyMapper.ReserveId Method
AttributeKeyMapper Class Eco.Persistence Namespace See Also
Collapse All

This method is called once for each object before objects are updated (if IdAllocationMode = PreUpdate and allows the keymapper to prepare for the number of IDs that needs to be allocated

C#
public void ReserveId();
See Also
AttributeKeyMapper Class
Eco.Persistence Namespace


AutoGuidKeyMapper Class

AutoGuidKeyMapper Class
Inheritance Hierarchy See Also
Collapse All
C#
public class AutoGuidKeyMapper : AbstractAutoGuidKeyMapper, IKeyMapper, IAutoIncIdMapper;
Remarks

This is class Eco.Persistence.AutoGuidKeyMapper.

Inheritance Hierarchy
Eco.Persistence.GenericKeyMapper
Eco.Persistence.IAutoIncIdMapper
Eco.Persistence.IKeyMapper
    Eco.Persistence.AbstractAutoGuidKeyMapper
        Eco.Persistence.AutoGuidKeyMapper
File

AutoGuidKeyMapper.cs

See Also
Inheritance Hierarchy


AutoGuidKeyMapper Properties

AutoGuidKeyMapper Properties
Protected Properties
Collapse All

The properties of the AutoGuidKeyMapper class are listed here.

Protected Properties
Name | Description
AutoGuidAttributeMapperName | do not localize
GuidAttributeMapperName | do not localize


AutoGuidKeyMapper.AutoGuidAttributeMapperName Property

AutoGuidKeyMapper.AutoGuidAttributeMapperName Property
AutoGuidKeyMapper Class Eco.Persistence Namespace See Also
Collapse All
C#
protected override string AutoGuidAttributeMapperName;
Remarks

do not localize

See Also
AutoGuidKeyMapper Class
Eco.Persistence Namespace


AutoGuidKeyMapper.GuidAttributeMapperName Property

AutoGuidKeyMapper.GuidAttributeMapperName Property
AutoGuidKeyMapper Class Eco.Persistence Namespace See Also
Collapse All
C#
protected override string GuidAttributeMapperName;
Remarks

do not localize

See Also
AutoGuidKeyMapper Class
Eco.Persistence Namespace


AutoInc16KeyMapper Class

AutoInc16KeyMapper Class
Inheritance Hierarchy See Also
Collapse All
C#
public class AutoInc16KeyMapper : AbstractAutoIncKeyMapper, IKeyMapper, IAutoIncIdMapper;
Remarks

This is class Eco.Persistence.AutoInc16KeyMapper.

Inheritance Hierarchy
Eco.Persistence.GenericKeyMapper
Eco.Persistence.IAutoIncIdMapper
Eco.Persistence.IKeyMapper
    Eco.Persistence.AbstractAutoIncKeyMapper
        Eco.Persistence.AutoInc16KeyMapper
File

AutoIncKeyMapper.cs

See Also
Inheritance Hierarchy


AutoInc16KeyMapper Properties

AutoInc16KeyMapper Properties
Protected Properties
Collapse All

The properties of the AutoInc16KeyMapper class are listed here.

Protected Properties
Name | Description
AutoIncAttributeMapperName | do not localize protected override string IntAttributeMapperName { get { return "System.Int16"; } } // do not localize


AutoInc16KeyMapper.AutoIncAttributeMapperName Property

AutoInc16KeyMapper.AutoIncAttributeMapperName Property
AutoInc16KeyMapper Class Eco.Persistence Namespace See Also
Collapse All
C#
protected override string AutoIncAttributeMapperName;
Remarks

do not localize protected override string IntAttributeMapperName { get { return "System.Int16"; } } // do not localize

See Also
AutoInc16KeyMapper Class
Eco.Persistence Namespace


AutoIncKeyMapper Class

AutoIncKeyMapper Class
Inheritance Hierarchy See Also
Collapse All
C#
public class AutoIncKeyMapper : AbstractAutoIncKeyMapper, IKeyMapper, IAutoIncIdMapper;
Remarks

This is class Eco.Persistence.AutoIncKeyMapper.

Inheritance Hierarchy
Eco.Persistence.GenericKeyMapper
Eco.Persistence.IAutoIncIdMapper
Eco.Persistence.IKeyMapper
    Eco.Persistence.AbstractAutoIncKeyMapper
        Eco.Persistence.AutoIncKeyMapper
File

AutoIncKeyMapper.cs

See Also
Inheritance Hierarchy


AutoIncKeyMapper Properties

AutoIncKeyMapper Properties
Protected Properties
Collapse All

The properties of the AutoIncKeyMapper class are listed here.

Protected Properties
Name | Description
AutoIncAttributeMapperName | do not localize protected override string IntAttributeMapperName { get { return "System.Int32"; } } // do not localize


AutoIncKeyMapper.AutoIncAttributeMapperName Property

AutoIncKeyMapper.AutoIncAttributeMapperName Property
AutoIncKeyMapper Class Eco.Persistence Namespace See Also
Collapse All
C#
protected override string AutoIncAttributeMapperName;
Remarks

do not localize protected override string IntAttributeMapperName { get { return "System.Int32"; } } // do not localize

See Also
AutoIncKeyMapper Class
Eco.Persistence Namespace


ChainedPersistenceHandlerBase Class

ChainedPersistenceHandlerBase Class
Example Inheritance Hierarchy See Also
Collapse All

Base class for persistence handler.

C#
public class ChainedPersistenceHandlerBase : IPersistenceHandler;
Remarks

Use this class to implement your own IPersistenceHandler override any of the virtual methods to inject your own behaviour and copy the Install-procedure (from the source of this class) for a convenient way to install the new class in the EcoSpace.

Example

In your own subclass, define an install-method like the one below and call it with the appropriate parameters to install it in your ecospace

Copy Code
public class MyPersistenceHandler: ChainedPersistenceHandlerBase
{
   // override some methods, don't forget to call the inherited version

   public static void Install(EcoSpace es, FrontsidePolicy fsp)
   {
       MyPersistenceHandler newPH = new MyPersistenceHandler(es.TypeSystem);
       newPH.NextPersistenceHandler = fsp.PersistenceHandler;
       fsp.PersistenceHandler = newPH;
   }
}
Inheritance Hierarchy
Eco.Persistence.ChainedPersistenceHandlerBase
File

ChainedPersistenceHandlerBase.cs

See Also
Example
Inheritance Hierarchy


ChainedPersistenceHandlerBase.ChainedPersistenceHandlerBase Constructor

ChainedPersistenceHandlerBase.ChainedPersistenceHandlerBase Constructor
ChainedPersistenceHandlerBase Class Eco.Persistence Namespace See Also
Collapse All
C#
public ChainedPersistenceHandlerBase(
    IEcoTypeSystem typeSystem
);
Remarks

This is ChainedPersistenceHandlerBase, a member of class ChainedPersistenceHandlerBase.

See Also
ChainedPersistenceHandlerBase Class
Eco.Persistence Namespace


ChainedPersistenceHandlerBase Methods

ChainedPersistenceHandlerBase Methods
Public Methods
Collapse All

The methods of the ChainedPersistenceHandlerBase class are listed here.

Public Methods
Name | Description
Fetch | This is Fetch, a member of class ChainedPersistenceHandlerBase.
FetchLinksWithObjects | This is FetchLinksWithObjects, a member of class ChainedPersistenceHandlerBase.
GetAllWithCondition | This is GetAllWithCondition, a member of class ChainedPersistenceHandlerBase.
RetrieveChanges | This is RetrieveChanges, a member of class ChainedPersistenceHandlerBase.
TimeForVersion | This is TimeForVersion, a member of class ChainedPersistenceHandlerBase.
UpdateDatabaseWithList | This is UpdateDatabaseWithList, a member of class ChainedPersistenceHandlerBase.
VersionAtTime | This is VersionAtTime, a member of class ChainedPersistenceHandlerBase.


ChainedPersistenceHandlerBase.Fetch Method

ChainedPersistenceHandlerBase.Fetch Method
ChainedPersistenceHandlerBase Class Eco.Persistence Namespace See Also
Collapse All
C#
public virtual void Fetch(
    ICollection<Locator> locators,
    int[] members,
    FetchStrategy FetchStrategy
);
Remarks

This is Fetch, a member of class ChainedPersistenceHandlerBase.

See Also
ChainedPersistenceHandlerBase Class
Eco.Persistence Namespace


ChainedPersistenceHandlerBase.FetchLinksWithObjects Method

ChainedPersistenceHandlerBase.FetchLinksWithObjects Method
ChainedPersistenceHandlerBase Class Eco.Persistence Namespace See Also
Collapse All
C#
public virtual ICollection<Locator> FetchLinksWithObjects(
    ICollection<Locator> objects,
    IAssociationEnd assocEnd
);
Remarks

This is FetchLinksWithObjects, a member of class ChainedPersistenceHandlerBase.

See Also
ChainedPersistenceHandlerBase Class
Eco.Persistence Namespace


ChainedPersistenceHandlerBase.GetAllWithCondition Method

ChainedPersistenceHandlerBase.GetAllWithCondition Method
ChainedPersistenceHandlerBase Class Eco.Persistence Namespace See Also
Collapse All
C#
public virtual ICollection<Locator> GetAllWithCondition(
    AbstractCondition condition,
    int maxAnswers,
    int offset
);
Remarks

This is GetAllWithCondition, a member of class ChainedPersistenceHandlerBase.

See Also
ChainedPersistenceHandlerBase Class
Eco.Persistence Namespace


ChainedPersistenceHandlerBase.RetrieveChanges Method

ChainedPersistenceHandlerBase.RetrieveChanges Method
ChainedPersistenceHandlerBase Class Eco.Persistence Namespace See Also
Collapse All
C#
public virtual void RetrieveChanges(
    out DBChangeCollection ignoredChanges
);
Remarks

This is RetrieveChanges, a member of class ChainedPersistenceHandlerBase.

See Also
ChainedPersistenceHandlerBase Class
Eco.Persistence Namespace


ChainedPersistenceHandlerBase.TimeForVersion Method

ChainedPersistenceHandlerBase.TimeForVersion Method
ChainedPersistenceHandlerBase Class Eco.Persistence Namespace See Also
Collapse All
C#
public virtual DateTime TimeForVersion(
    int version
);
Remarks

This is TimeForVersion, a member of class ChainedPersistenceHandlerBase.

See Also
ChainedPersistenceHandlerBase Class
Eco.Persistence Namespace


ChainedPersistenceHandlerBase.UpdateDatabaseWithList Method

ChainedPersistenceHandlerBase.UpdateDatabaseWithList Method
ChainedPersistenceHandlerBase Class Eco.Persistence Namespace See Also
Collapse All
C#
public virtual void UpdateDatabaseWithList(
    ICollection<Locator> locators
);
Remarks

This is UpdateDatabaseWithList, a member of class ChainedPersistenceHandlerBase.

See Also
ChainedPersistenceHandlerBase Class
Eco.Persistence Namespace


ChainedPersistenceHandlerBase.VersionAtTime Method

ChainedPersistenceHandlerBase.VersionAtTime Method
ChainedPersistenceHandlerBase Class Eco.Persistence Namespace See Also
Collapse All
C#
public virtual int VersionAtTime(
    DateTime time
);
Remarks

This is VersionAtTime, a member of class ChainedPersistenceHandlerBase.

See Also
ChainedPersistenceHandlerBase Class
Eco.Persistence Namespace


ChainedPersistenceHandlerBase Properties

ChainedPersistenceHandlerBase Properties
Public Properties Protected Properties
Collapse All

The properties of the ChainedPersistenceHandlerBase class are listed here.

Public Properties
Name | Description
IsPersistent | This is IsPersistent, a member of class ChainedPersistenceHandlerBase.
MaxSavedVersion | This is MaxSavedVersion, a member of class ChainedPersistenceHandlerBase.
NextPersistenceHandler | This is NextPersistenceHandler, a member of class ChainedPersistenceHandlerBase.
SupportsSync | This is SupportsSync, a member of class ChainedPersistenceHandlerBase.
Top
Protected Properties
Name | Description
TypeSystem | This is TypeSystem, a member of class ChainedPersistenceHandlerBase.


ChainedPersistenceHandlerBase.IsPersistent Property

ChainedPersistenceHandlerBase.IsPersistent Property
ChainedPersistenceHandlerBase Class Eco.Persistence Namespace See Also
Collapse All
C#
public bool IsPersistent;
Remarks

This is IsPersistent, a member of class ChainedPersistenceHandlerBase.

See Also
ChainedPersistenceHandlerBase Class
Eco.Persistence Namespace


ChainedPersistenceHandlerBase.MaxSavedVersion Property

ChainedPersistenceHandlerBase.MaxSavedVersion Property
ChainedPersistenceHandlerBase Class Eco.Persistence Namespace See Also
Collapse All
C#
public virtual int MaxSavedVersion;
Remarks

This is MaxSavedVersion, a member of class ChainedPersistenceHandlerBase.

See Also
ChainedPersistenceHandlerBase Class
Eco.Persistence Namespace


ChainedPersistenceHandlerBase.NextPersistenceHandler Property

ChainedPersistenceHandlerBase.NextPersistenceHandler Property
ChainedPersistenceHandlerBase Class Eco.Persistence Namespace See Also
Collapse All
C#
public IPersistenceHandler NextPersistenceHandler;
Remarks

This is NextPersistenceHandler, a member of class ChainedPersistenceHandlerBase.

See Also
ChainedPersistenceHandlerBase Class
Eco.Persistence Namespace


ChainedPersistenceHandlerBase.SupportsSync Property

ChainedPersistenceHandlerBase.SupportsSync Property
ChainedPersistenceHandlerBase Class Eco.Persistence Namespace See Also
Collapse All
C#
public bool SupportsSync;
Remarks

This is SupportsSync, a member of class ChainedPersistenceHandlerBase.

See Also
ChainedPersistenceHandlerBase Class
Eco.Persistence Namespace


ChainedPersistenceHandlerBase.TypeSystem Property

ChainedPersistenceHandlerBase.TypeSystem Property
ChainedPersistenceHandlerBase Class Eco.Persistence Namespace See Also
Collapse All
C#
protected IEcoTypeSystem TypeSystem;
Remarks

This is TypeSystem, a member of class ChainedPersistenceHandlerBase.

See Also
ChainedPersistenceHandlerBase Class
Eco.Persistence Namespace


ChainedPersistenceHandlerBase Events

ChainedPersistenceHandlerBase Events
Public Events
Collapse All

The events of the ChainedPersistenceHandlerBase class are listed here.

Public Events
Name | Description
ObjectsUpdated | This is ObjectsUpdated, a member of class ChainedPersistenceHandlerBase.


ChainedPersistenceHandlerBase.ObjectsUpdated Event

ChainedPersistenceHandlerBase.ObjectsUpdated Event
ChainedPersistenceHandlerBase Class Eco.Persistence Namespace See Also
Collapse All
C#
public virtual event LocatorArrayEventHandler ObjectsUpdated;
Remarks

This is ObjectsUpdated, a member of class ChainedPersistenceHandlerBase.

See Also
ChainedPersistenceHandlerBase Class
Eco.Persistence Namespace


ChainedPersistenceMapperBase Class

ChainedPersistenceMapperBase Class
Inheritance Hierarchy See Also
Collapse All

This is a generic component that can be used to plug into the PersistenceMapper chain and intercept calls from the EcoSpace to the persistencemapper To use, subclass and override the methods you need to intercept. Instantiate the new class and set the "NextPersistenceMapper" property to the actual PersistenceMapper

C#
public abstract class ChainedPersistenceMapperBase : PersistenceMapper;
Inheritance Hierarchy
Eco.Persistence.IPersistencemapperProvider
    Eco.Persistence.PersistenceMapper
        Eco.Persistence.ChainedPersistenceMapperBase
File

ChainedPersistenceMapperBase.cs

See Also
Inheritance Hierarchy


ChainedPersistenceMapperBase.ChainedPersistenceMapperBase Constructor

ChainedPersistenceMapperBase.ChainedPersistenceMapperBase Constructor
ChainedPersistenceMapperBase Class Eco.Persistence Namespace See Also
Collapse All
C#
protected ChainedPersistenceMapperBase();
Remarks

The constructor does no setup.

See Also
ChainedPersistenceMapperBase Class
Eco.Persistence Namespace


ChainedPersistenceMapperBase Methods

ChainedPersistenceMapperBase Methods
Public Methods
Collapse All

The methods of the ChainedPersistenceMapperBase class are listed here.

Public Methods
Name | Description
CreatePersistenceMapperImpl | This is CreatePersistenceMapperImpl, a member of class ChainedPersistenceMapperBase.
GetPersistenceMapper | This is GetPersistenceMapper, a member of class ChainedPersistenceMapperBase.
ReturnPersistenceMapper | This is ReturnPersistenceMapper, a member of class ChainedPersistenceMapperBase.


ChainedPersistenceMapperBase.CreatePersistenceMapperImpl Method

ChainedPersistenceMapperBase.CreatePersistenceMapperImpl Method
ChainedPersistenceMapperBase Class Eco.Persistence Namespace See Also
Collapse All
C#
public abstract ChainedPersistenceMapperImplBase CreatePersistenceMapperImpl(
    ITypeSystemService typeSystemService,
    IPersistenceMapper nextPersistenceMapper
);
Remarks

This is CreatePersistenceMapperImpl, a member of class ChainedPersistenceMapperBase.

See Also
ChainedPersistenceMapperBase Class
Eco.Persistence Namespace


ChainedPersistenceMapperBase.GetPersistenceMapper Method

ChainedPersistenceMapperBase.GetPersistenceMapper Method
ChainedPersistenceMapperBase Class Eco.Persistence Namespace See Also
Collapse All
C#
public override IPersistenceMapper GetPersistenceMapper(
    ITypeSystemService typeSystemService
);
Remarks

This is GetPersistenceMapper, a member of class ChainedPersistenceMapperBase.

See Also
ChainedPersistenceMapperBase Class
Eco.Persistence Namespace


ChainedPersistenceMapperBase.ReturnPersistenceMapper Method

ChainedPersistenceMapperBase.ReturnPersistenceMapper Method
ChainedPersistenceMapperBase Class Eco.Persistence Namespace See Also
Collapse All
C#
public override void ReturnPersistenceMapper(
    IPersistenceMapper persistenceMapper
);
Remarks

This is ReturnPersistenceMapper, a member of class ChainedPersistenceMapperBase.

See Also
ChainedPersistenceMapperBase Class
Eco.Persistence Namespace


ChainedPersistenceMapperBase Properties

ChainedPersistenceMapperBase Properties
Public Properties
Collapse All

The properties of the ChainedPersistenceMapperBase class are listed here.

Public Properties
Name | Description
NextPersistenceMapper | This is NextPersistenceMapper, a member of class ChainedPersistenceMapperBase.


ChainedPersistenceMapperBase.NextPersistenceMapper Property

ChainedPersistenceMapperBase.NextPersistenceMapper Property
ChainedPersistenceMapperBase Class Eco.Persistence Namespace See Also
Collapse All
C#
public PersistenceMapper NextPersistenceMapper;
Remarks

This is NextPersistenceMapper, a member of class ChainedPersistenceMapperBase.

See Also
ChainedPersistenceMapperBase Class
Eco.Persistence Namespace


ChainedPersistenceMapperImplBase Class

ChainedPersistenceMapperImplBase Class
Inheritance Hierarchy See Also
Collapse All
C#
public class ChainedPersistenceMapperImplBase : MarshalByRefObject, IPersistenceMapper;
Remarks

This is class Eco.Persistence.ChainedPersistenceMapperImplBase.

Inheritance Hierarchy
Eco.Persistence.IPersistenceMapper
    Eco.Persistence.ChainedPersistenceMapperImplBase
File

ChainedPersistenceMapperBase.cs

See Also
Inheritance Hierarchy


ChainedPersistenceMapperImplBase.ChainedPersistenceMapperImplBase Constructor

ChainedPersistenceMapperImplBase.ChainedPersistenceMapperImplBase Constructor
ChainedPersistenceMapperImplBase Class Eco.Persistence Namespace See Also
Collapse All
C#
public ChainedPersistenceMapperImplBase(
    ITypeSystemService typeSystemService,
    IPersistenceMapper nextPersistenceMapper
);
Remarks

This is ChainedPersistenceMapperImplBase, a member of class ChainedPersistenceMapperImplBase.

See Also
ChainedPersistenceMapperImplBase Class
Eco.Persistence Namespace


ChainedPersistenceMapperImplBase Methods

ChainedPersistenceMapperImplBase Methods
Public Methods
Collapse All

The methods of the ChainedPersistenceMapperImplBase class are listed here.

Public Methods
Name | Description
Fetch | This is Fetch, a member of class ChainedPersistenceMapperImplBase.
FetchIDListWithCondition | This is FetchIDListWithCondition, a member of class ChainedPersistenceMapperImplBase.
GetChangesSince | This is GetChangesSince, a member of class ChainedPersistenceMapperImplBase.
TimeForVersion | This is TimeForVersion, a member of class ChainedPersistenceMapperImplBase.
Update | This is Update, a member of class ChainedPersistenceMapperImplBase.
VersionForTime | This is VersionForTime, a member of class ChainedPersistenceMapperImplBase.


ChainedPersistenceMapperImplBase.Fetch Method

ChainedPersistenceMapperImplBase.Fetch Method
ChainedPersistenceMapperImplBase Class Eco.Persistence Namespace See Also
Collapse All
C#
public virtual void Fetch(
    ObjectIdList idList,
    out Datablock datablock,
    int[] memberIdList,
    FetchStrategy fetchStrategy
);
Remarks

This is Fetch, a member of class ChainedPersistenceMapperImplBase.

See Also
ChainedPersistenceMapperImplBase Class
Eco.Persistence Namespace


ChainedPersistenceMapperImplBase.FetchIDListWithCondition Method

ChainedPersistenceMapperImplBase.FetchIDListWithCondition Method
ChainedPersistenceMapperImplBase Class Eco.Persistence Namespace See Also
Collapse All
C#
public virtual void FetchIDListWithCondition(
    AbstractCondition condition,
    out ObjectIdList result,
    int maxResults,
    int offset
);
Remarks

This is FetchIDListWithCondition, a member of class ChainedPersistenceMapperImplBase.

See Also
ChainedPersistenceMapperImplBase Class
Eco.Persistence Namespace


ChainedPersistenceMapperImplBase.GetChangesSince Method

ChainedPersistenceMapperImplBase.GetChangesSince Method
ChainedPersistenceMapperImplBase Class Eco.Persistence Namespace See Also
Collapse All
C#
public virtual void GetChangesSince(
    SyncVersion syncVersion,
    SyncVersion[] excludeList,
    out DBChangeCollection changes,
    out SyncVersion lastSyncVersion
);
Remarks

This is GetChangesSince, a member of class ChainedPersistenceMapperImplBase.

See Also
ChainedPersistenceMapperImplBase Class
Eco.Persistence Namespace


ChainedPersistenceMapperImplBase.TimeForVersion Method

ChainedPersistenceMapperImplBase.TimeForVersion Method
ChainedPersistenceMapperImplBase Class Eco.Persistence Namespace See Also
Collapse All
C#
public virtual void TimeForVersion(
    int version,
    out DateTime clockTime
);
Remarks

This is TimeForVersion, a member of class ChainedPersistenceMapperImplBase.

See Also
ChainedPersistenceMapperImplBase Class
Eco.Persistence Namespace


ChainedPersistenceMapperImplBase.Update Method

ChainedPersistenceMapperImplBase.Update Method
ChainedPersistenceMapperImplBase Class Eco.Persistence Namespace See Also
Collapse All
C#
public virtual void Update(
    Datablock datablock,
    UpdatePrecondition precondition,
    out IdTranslationList translationList,
    out int version,
    out SyncVersion syncVersion,
    out UpdateResult result
);
Remarks

This is Update, a member of class ChainedPersistenceMapperImplBase.

See Also
ChainedPersistenceMapperImplBase Class
Eco.Persistence Namespace


ChainedPersistenceMapperImplBase.VersionForTime Method

ChainedPersistenceMapperImplBase.VersionForTime Method
ChainedPersistenceMapperImplBase Class Eco.Persistence Namespace See Also
Collapse All
C#
public virtual void VersionForTime(
    DateTime clockTime,
    out int version
);
Remarks

This is VersionForTime, a member of class ChainedPersistenceMapperImplBase.

See Also
ChainedPersistenceMapperImplBase Class
Eco.Persistence Namespace


ChainedPersistenceMapperImplBase Properties

ChainedPersistenceMapperImplBase Properties
Public Properties
Collapse All

The properties of the ChainedPersistenceMapperImplBase class are listed here.

Public Properties
Name | Description
CurrentSyncVersion | This is CurrentSyncVersion, a member of class ChainedPersistenceMapperImplBase.
NextPersistenceMapper | This is NextPersistenceMapper, a member of class ChainedPersistenceMapperImplBase.
SupportsSync | This is SupportsSync, a member of class ChainedPersistenceMapperImplBase.
TypeSystemService | This is TypeSystemService, a member of class ChainedPersistenceMapperImplBase.


ChainedPersistenceMapperImplBase.CurrentSyncVersion Property

ChainedPersistenceMapperImplBase.CurrentSyncVersion Property
ChainedPersistenceMapperImplBase Class Eco.Persistence Namespace See Also
Collapse All
C#
public virtual SyncVersion CurrentSyncVersion;
Remarks

This is CurrentSyncVersion, a member of class ChainedPersistenceMapperImplBase.

See Also
ChainedPersistenceMapperImplBase Class
Eco.Persistence Namespace


ChainedPersistenceMapperImplBase.NextPersistenceMapper Property

ChainedPersistenceMapperImplBase.NextPersistenceMapper Property
ChainedPersistenceMapperImplBase Class Eco.Persistence Namespace See Also
Collapse All
C#
public IPersistenceMapper NextPersistenceMapper;
Remarks

This is NextPersistenceMapper, a member of class ChainedPersistenceMapperImplBase.

See Also
ChainedPersistenceMapperImplBase Class
Eco.Persistence Namespace


ChainedPersistenceMapperImplBase.SupportsSync Property

ChainedPersistenceMapperImplBase.SupportsSync Property
ChainedPersistenceMapperImplBase Class Eco.Persistence Namespace See Also
Collapse All
C#
public virtual bool SupportsSync;
Remarks

This is SupportsSync, a member of class ChainedPersistenceMapperImplBase.

See Also
ChainedPersistenceMapperImplBase Class
Eco.Persistence Namespace


ChainedPersistenceMapperImplBase.TypeSystemService Property

ChainedPersistenceMapperImplBase.TypeSystemService Property
ChainedPersistenceMapperImplBase Class Eco.Persistence Namespace See Also
Collapse All
C#
public ITypeSystemService TypeSystemService;
Remarks

This is TypeSystemService, a member of class ChainedPersistenceMapperImplBase.

See Also
ChainedPersistenceMapperImplBase Class
Eco.Persistence Namespace


ChainedPersistenceServiceBase Class

ChainedPersistenceServiceBase Class
Inheritance Hierarchy See Also
Collapse All

Use this class to implement your own IPersistenceService override any of the virtual methods to inject your own behaviour

C#
public class ChainedPersistenceServiceBase : IPersistenceService;
Inheritance Hierarchy
Eco.Persistence.ChainedPersistenceServiceBase
File

ChainedPersistenceServiceBase.cs

See Also
Inheritance Hierarchy


ChainedPersistenceServiceBase Methods

ChainedPersistenceServiceBase Methods
Public Methods
Collapse All

The methods of the ChainedPersistenceServiceBase class are listed here.

Public Methods
Name | Description
ApplyAllChanges | This is ApplyAllChanges, a member of class ChainedPersistenceServiceBase.
DiscardChanges | This is DiscardChanges, a member of class ChainedPersistenceServiceBase.
EnsureEnclosure | This is EnsureEnclosure, a member of class ChainedPersistenceServiceBase.
EnsureObject | This is EnsureObject, a member of class ChainedPersistenceServiceBase.
EnsureRange | This is EnsureRange, a member of class ChainedPersistenceServiceBase.
EnsureRelatedObjects | This is the overview for the EnsureRelatedObjects method overload.
GetAllWithCondition | This is the overview for the GetAllWithCondition method overload.
GetChanges | This is GetChanges, a member of class ChainedPersistenceServiceBase.
IsLoaded | This is IsLoaded, a member of class ChainedPersistenceServiceBase.
Refresh | This is Refresh, a member of class ChainedPersistenceServiceBase.
RetrieveChanges | This is the overview for the RetrieveChanges method overload.
Unload | This is Unload, a member of class ChainedPersistenceServiceBase.
UpdateDatabaseWithList | This is UpdateDatabaseWithList, a member of class ChainedPersistenceServiceBase.


ChainedPersistenceServiceBase.ApplyAllChanges Method

ChainedPersistenceServiceBase.ApplyAllChanges Method
ChainedPersistenceServiceBase Class Eco.Persistence Namespace See Also
Collapse All
C#
public virtual void ApplyAllChanges();
Remarks

This is ApplyAllChanges, a member of class ChainedPersistenceServiceBase.

See Also
ChainedPersistenceServiceBase Class
Eco.Persistence Namespace


ChainedPersistenceServiceBase.DiscardChanges Method

ChainedPersistenceServiceBase.DiscardChanges Method
ChainedPersistenceServiceBase Class Eco.Persistence Namespace See Also
Collapse All
C#
public virtual void DiscardChanges<T>(
    IEnumerable<T> objects
) where T : IEcoObject;
Remarks

This is DiscardChanges, a member of class ChainedPersistenceServiceBase.

See Also
ChainedPersistenceServiceBase Class
Eco.Persistence Namespace


ChainedPersistenceServiceBase.EnsureEnclosure Method

ChainedPersistenceServiceBase.EnsureEnclosure Method
ChainedPersistenceServiceBase Class Eco.Persistence Namespace See Also
Collapse All
C#
public virtual void EnsureEnclosure(
    IObjectList objectList
);
Remarks

This is EnsureEnclosure, a member of class ChainedPersistenceServiceBase.

See Also
ChainedPersistenceServiceBase Class
Eco.Persistence Namespace


ChainedPersistenceServiceBase.EnsureObject Method

ChainedPersistenceServiceBase.EnsureObject Method
ChainedPersistenceServiceBase Class Eco.Persistence Namespace See Also
Collapse All
C#
public virtual void EnsureObject(
    IObjectInstance obj
);
Remarks

This is EnsureObject, a member of class ChainedPersistenceServiceBase.

See Also
ChainedPersistenceServiceBase Class
Eco.Persistence Namespace


ChainedPersistenceServiceBase.EnsureRange Method

ChainedPersistenceServiceBase.EnsureRange Method
ChainedPersistenceServiceBase Class Eco.Persistence Namespace See Also
Collapse All
C#
public virtual void EnsureRange(
    IObjectList objects,
    int fromIndex,
    int toIndex
);
Remarks

This is EnsureRange, a member of class ChainedPersistenceServiceBase.

See Also
ChainedPersistenceServiceBase Class
Eco.Persistence Namespace


EnsureRelatedObjects Method

EnsureRelatedObjects Method

This is the overview for the EnsureRelatedObjects method overload.

Overload List
Name | Description
ChainedPersistenceServiceBase.EnsureRelatedObjects (IEnumerable<T>, IAssociationEnd) | This is EnsureRelatedObjects, a member of class ChainedPersistenceServiceBase.
ChainedPersistenceServiceBase.EnsureRelatedObjects (IEnumerable<T>, string) | This is EnsureRelatedObjects, a member of class ChainedPersistenceServiceBase.


ChainedPersistenceServiceBase.EnsureRelatedObjects Method (IEnumerable<T>, IAssociationEnd)

ChainedPersistenceServiceBase.EnsureRelatedObjects Method (IEnumerable<T>, IAssociationEnd)
ChainedPersistenceServiceBase Class Eco.Persistence Namespace See Also
Collapse All
C#
public virtual IObjectList EnsureRelatedObjects<T>(
    IEnumerable<T> objects,
    IAssociationEnd assocEnd
) where T : IEcoObject;
Remarks

This is EnsureRelatedObjects, a member of class ChainedPersistenceServiceBase.

See Also
ChainedPersistenceServiceBase Class
Eco.Persistence Namespace


ChainedPersistenceServiceBase.EnsureRelatedObjects Method (IEnumerable<T>, string)

ChainedPersistenceServiceBase.EnsureRelatedObjects Method (IEnumerable<T>, string)
ChainedPersistenceServiceBase Class Eco.Persistence Namespace See Also
Collapse All
C#
public virtual IObjectList EnsureRelatedObjects<T>(
    IEnumerable<T> objects,
    string memberName
) where T : IEcoObject;
Remarks

This is EnsureRelatedObjects, a member of class ChainedPersistenceServiceBase.

See Also
ChainedPersistenceServiceBase Class
Eco.Persistence Namespace


GetAllWithCondition Method

GetAllWithCondition Method

This is the overview for the GetAllWithCondition method overload.

Overload List
Name | Description
ChainedPersistenceServiceBase.GetAllWithCondition (AbstractCondition) | This is GetAllWithCondition, a member of class ChainedPersistenceServiceBase.
ChainedPersistenceServiceBase.GetAllWithCondition (AbstractCondition, int, int) | This is GetAllWithCondition, a member of class ChainedPersistenceServiceBase.


ChainedPersistenceServiceBase.GetAllWithCondition Method (AbstractCondition)

ChainedPersistenceServiceBase.GetAllWithCondition Method (AbstractCondition)
ChainedPersistenceServiceBase Class Eco.Persistence Namespace See Also
Collapse All
C#
public virtual IObjectList GetAllWithCondition(
    AbstractCondition condition
);
Remarks

This is GetAllWithCondition, a member of class ChainedPersistenceServiceBase.

See Also
ChainedPersistenceServiceBase Class
Eco.Persistence Namespace


ChainedPersistenceServiceBase.GetAllWithCondition Method (AbstractCondition, int, int)

ChainedPersistenceServiceBase.GetAllWithCondition Method (AbstractCondition, int, int)
ChainedPersistenceServiceBase Class Eco.Persistence Namespace See Also
Collapse All
C#
public virtual IObjectList GetAllWithCondition(
    AbstractCondition condition,
    int maxAnswers,
    int offset
);
Remarks

This is GetAllWithCondition, a member of class ChainedPersistenceServiceBase.

See Also
ChainedPersistenceServiceBase Class
Eco.Persistence Namespace


ChainedPersistenceServiceBase.GetChanges Method

ChainedPersistenceServiceBase.GetChanges Method
ChainedPersistenceServiceBase Class Eco.Persistence Namespace See Also
Collapse All
C#
public virtual IChange[] GetChanges();
Remarks

This is GetChanges, a member of class ChainedPersistenceServiceBase.

See Also
ChainedPersistenceServiceBase Class
Eco.Persistence Namespace


ChainedPersistenceServiceBase.IsLoaded Method

ChainedPersistenceServiceBase.IsLoaded Method
ChainedPersistenceServiceBase Class Eco.Persistence Namespace See Also
Collapse All
C#
public virtual bool IsLoaded(
    IEcoObject obj
);
Remarks

This is IsLoaded, a member of class ChainedPersistenceServiceBase.

See Also
ChainedPersistenceServiceBase Class
Eco.Persistence Namespace


ChainedPersistenceServiceBase.Refresh Method

ChainedPersistenceServiceBase.Refresh Method
ChainedPersistenceServiceBase Class Eco.Persistence Namespace See Also
Collapse All
C#
public virtual void Refresh(
    bool fetchValues
);
Remarks

This is Refresh, a member of class ChainedPersistenceServiceBase.

See Also
ChainedPersistenceServiceBase Class
Eco.Persistence Namespace


RetrieveChanges Method

RetrieveChanges Method

This is the overview for the RetrieveChanges method overload.

Overload List
Name | Description
ChainedPersistenceServiceBase.RetrieveChanges () | This is RetrieveChanges, a member of class ChainedPersistenceServiceBase.
ChainedPersistenceServiceBase.RetrieveChanges (out DBChangeCollection) | This is RetrieveChanges, a member of class ChainedPersistenceServiceBase.


ChainedPersistenceServiceBase.RetrieveChanges Method ()

ChainedPersistenceServiceBase.RetrieveChanges Method ()
ChainedPersistenceServiceBase Class Eco.Persistence Namespace See Also
Collapse All
C#
public virtual void RetrieveChanges();
Remarks

This is RetrieveChanges, a member of class ChainedPersistenceServiceBase.

See Also
ChainedPersistenceServiceBase Class
Eco.Persistence Namespace


ChainedPersistenceServiceBase.RetrieveChanges Method (out DBChangeCollection)

ChainedPersistenceServiceBase.RetrieveChanges Method (out DBChangeCollection)
ChainedPersistenceServiceBase Class Eco.Persistence Namespace See Also
Collapse All
C#
public virtual void RetrieveChanges(
    out DBChangeCollection ignoredChanges
);
Remarks

This is RetrieveChanges, a member of class ChainedPersistenceServiceBase.

See Also
ChainedPersistenceServiceBase Class
Eco.Persistence Namespace


ChainedPersistenceServiceBase.Unload Method

ChainedPersistenceServiceBase.Unload Method
ChainedPersistenceServiceBase Class Eco.Persistence Namespace See Also
Collapse All
C#
public virtual void Unload<T>(
    IEnumerable<T> objects
) where T : IEcoObject;
Remarks

This is Unload, a member of class ChainedPersistenceServiceBase.

See Also
ChainedPersistenceServiceBase Class
Eco.Persistence Namespace


ChainedPersistenceServiceBase.UpdateDatabaseWithList Method

ChainedPersistenceServiceBase.UpdateDatabaseWithList Method
ChainedPersistenceServiceBase Class Eco.Persistence Namespace See Also
Collapse All
C#
public virtual void UpdateDatabaseWithList<T>(
    IEnumerable<T> list
) where T : IEcoObject;
Remarks

This is UpdateDatabaseWithList, a member of class ChainedPersistenceServiceBase.

See Also
ChainedPersistenceServiceBase Class
Eco.Persistence Namespace


ChainedPersistenceServiceBase Properties

ChainedPersistenceServiceBase Properties
Public Properties
Collapse All

The properties of the ChainedPersistenceServiceBase class are listed here.

Public Properties
Name | Description
IsPersistent | This is IsPersistent, a member of class ChainedPersistenceServiceBase.
NextPersistenceService | This is NextPersistenceService, a member of class ChainedPersistenceServiceBase.
SupportsSync | This is SupportsSync, a member of class ChainedPersistenceServiceBase.


ChainedPersistenceServiceBase.IsPersistent Property

ChainedPersistenceServiceBase.IsPersistent Property
ChainedPersistenceServiceBase Class Eco.Persistence Namespace See Also
Collapse All
C#
public virtual bool IsPersistent;
Remarks

This is IsPersistent, a member of class ChainedPersistenceServiceBase.

See Also
ChainedPersistenceServiceBase Class
Eco.Persistence Namespace


ChainedPersistenceServiceBase.NextPersistenceService Property

ChainedPersistenceServiceBase.NextPersistenceService Property
ChainedPersistenceServiceBase Class Eco.Persistence Namespace See Also
Collapse All
C#
public IPersistenceService NextPersistenceService;
Remarks

This is NextPersistenceService, a member of class ChainedPersistenceServiceBase.

See Also
ChainedPersistenceServiceBase Class
Eco.Persistence Namespace


ChainedPersistenceServiceBase.SupportsSync Property

ChainedPersistenceServiceBase.SupportsSync Property
ChainedPersistenceServiceBase Class Eco.Persistence Namespace See Also
Collapse All
C#
public virtual bool SupportsSync;
Remarks

This is SupportsSync, a member of class ChainedPersistenceServiceBase.

See Also
ChainedPersistenceServiceBase Class
Eco.Persistence Namespace


ChangePointCondition Class

ChangePointCondition Class
Inheritance Hierarchy See Also
Collapse All
C#
public sealed class ChangePointCondition : AbstractCondition;
Remarks

This is class Eco.Persistence.ChangePointCondition.

Inheritance Hierarchy
Eco.Persistence.AbstractCondition
    Eco.Persistence.ChangePointCondition
File

PersistenceMapperInterfaces.cs

See Also
Inheritance Hierarchy


ChangePointCondition.ChangePointCondition Constructor

ChangePointCondition.ChangePointCondition Constructor
ChangePointCondition Class Eco.Persistence Namespace See Also
Collapse All
C#
public ChangePointCondition(
    int classId,
    ObjectIdList objectIds,
    int startVersion,
    int endVersion,
    int[] memberIds
);
Remarks

This is ChangePointCondition, a member of class ChangePointCondition.

See Also
ChangePointCondition Class
Eco.Persistence Namespace


ChangePointCondition Properties

ChangePointCondition Properties
Public Properties
Collapse All

The properties of the ChangePointCondition class are listed here.

Public Properties
Name | Description
EndVersion | This is EndVersion, a member of class ChangePointCondition.
MemberIds | This is MemberIds, a member of class ChangePointCondition.
ObjectIds | This is ObjectIds, a member of class ChangePointCondition.
StartVersion | This is StartVersion, a member of class ChangePointCondition.


ChangePointCondition.EndVersion Property

ChangePointCondition.EndVersion Property
ChangePointCondition Class Eco.Persistence Namespace See Also
Collapse All
C#
public int EndVersion;
Remarks

This is EndVersion, a member of class ChangePointCondition.

See Also
ChangePointCondition Class
Eco.Persistence Namespace


ChangePointCondition.MemberIds Property

ChangePointCondition.MemberIds Property
ChangePointCondition Class Eco.Persistence Namespace See Also
Collapse All
C#
public int MemberIds;
Remarks

This is MemberIds, a member of class ChangePointCondition.

See Also
ChangePointCondition Class
Eco.Persistence Namespace


ChangePointCondition.ObjectIds Property

ChangePointCondition.ObjectIds Property
ChangePointCondition Class Eco.Persistence Namespace See Also
Collapse All
C#
public ObjectIdList ObjectIds;
Remarks

This is ObjectIds, a member of class ChangePointCondition.

See Also
ChangePointCondition Class
Eco.Persistence Namespace


ChangePointCondition.StartVersion Property

ChangePointCondition.StartVersion Property
ChangePointCondition Class Eco.Persistence Namespace See Also
Collapse All
C#
public int StartVersion;
Remarks

This is StartVersion, a member of class ChangePointCondition.

See Also
ChangePointCondition Class
Eco.Persistence Namespace


ColumnDescription Class

ColumnDescription Class
Inheritance Hierarchy See Also
Collapse All

This class is used by KeyMappers that need to add structure to the database schema

C#
public class ColumnDescription;
Inheritance Hierarchy
Eco.Persistence.ColumnDescription
File

ColumnDescription.cs

See Also
Inheritance Hierarchy


ColumnDescription.ColumnDescription Constructor

ColumnDescription.ColumnDescription Constructor
ColumnDescription Class Eco.Persistence Namespace See Also
Collapse All
C#
public ColumnDescription(
    string columnName,
    string columnType,
    bool allowNull,
    string defaultDbValue
);
Remarks

This is ColumnDescription, a member of class ColumnDescription.

See Also
ColumnDescription Class
Eco.Persistence Namespace


ColumnDescription Properties

ColumnDescription Properties
Public Properties
Collapse All

The properties of the ColumnDescription class are listed here.

Public Properties
Name | Description
AllowNull | This is AllowNull, a member of class ColumnDescription.
ColumnName | This is ColumnName, a member of class ColumnDescription.
ColumnType | This is ColumnType, a member of class ColumnDescription.
DefaultDBValue | This is DefaultDBValue, a member of class ColumnDescription.


ColumnDescription.AllowNull Property

ColumnDescription.AllowNull Property
ColumnDescription Class Eco.Persistence Namespace See Also
Collapse All
C#
public bool AllowNull;
Remarks

This is AllowNull, a member of class ColumnDescription.

See Also
ColumnDescription Class
Eco.Persistence Namespace


ColumnDescription.ColumnName Property

ColumnDescription.ColumnName Property
ColumnDescription Class Eco.Persistence Namespace See Also
Collapse All
C#
public string ColumnName;
Remarks

This is ColumnName, a member of class ColumnDescription.

See Also
ColumnDescription Class
Eco.Persistence Namespace


ColumnDescription.ColumnType Property

ColumnDescription.ColumnType Property
ColumnDescription Class Eco.Persistence Namespace See Also
Collapse All
C#
public string ColumnType;
Remarks

This is ColumnType, a member of class ColumnDescription.

See Also
ColumnDescription Class
Eco.Persistence Namespace


ColumnDescription.DefaultDBValue Property

ColumnDescription.DefaultDBValue Property
ColumnDescription Class Eco.Persistence Namespace See Also
Collapse All
C#
public string DefaultDBValue;
Remarks

This is DefaultDBValue, a member of class ColumnDescription.

See Also
ColumnDescription Class
Eco.Persistence Namespace


CommitBlock Class

CommitBlock Class
Inheritance Hierarchy See Also
Collapse All
C#
public class CommitBlock;
Remarks

This is class Eco.Persistence.CommitBlock.

Inheritance Hierarchy
Eco.Persistence.CommitBlock
File

PersistenceMapperInterfaces.cs

See Also
Inheritance Hierarchy


CommitBlock.CommitBlock Constructor

CommitBlock.CommitBlock Constructor
CommitBlock Class Eco.Persistence Namespace See Also
Collapse All
C#
public CommitBlock(
    Datablock changes,
    Datablock oldValues
);
Remarks

This is CommitBlock, a member of class CommitBlock.

See Also
CommitBlock Class
Eco.Persistence Namespace


CommitBlock Properties

CommitBlock Properties
Public Properties
Collapse All

The properties of the CommitBlock class are listed here.

Public Properties
Name | Description
Changes | This is Changes, a member of class CommitBlock.
OldValues | This is OldValues, a member of class CommitBlock.


CommitBlock.Changes Property

CommitBlock.Changes Property
CommitBlock Class Eco.Persistence Namespace See Also
Collapse All
C#
public Datablock Changes;
Remarks

This is Changes, a member of class CommitBlock.

See Also
CommitBlock Class
Eco.Persistence Namespace


CommitBlock.OldValues Property

CommitBlock.OldValues Property
CommitBlock Class Eco.Persistence Namespace See Also
Collapse All
C#
public Datablock OldValues;
Remarks

This is OldValues, a member of class CommitBlock.

See Also
CommitBlock Class
Eco.Persistence Namespace


ConnectionPool Class

ConnectionPool Class
Inheritance Hierarchy See Also
Collapse All

Manages a pool of database connections.

C#
public class ConnectionPool;
Inheritance Hierarchy
Eco.Persistence.ConnectionPool
File

ConnectionPool.cs

See Also
Inheritance Hierarchy


ConnectionPool Constructor

ConnectionPool Constructor

This is the overview for the ConnectionPool constructor overload.

Overload List
Name | Description
ConnectionPool.ConnectionPool () | This is ConnectionPool, a member of class ConnectionPool.
ConnectionPool.ConnectionPool (PersistenceMapperDb) | Creates a new instance of the pool.


ConnectionPool.ConnectionPool Constructor ()

ConnectionPool.ConnectionPool Constructor ()
ConnectionPool Class Eco.Persistence Namespace See Also
Collapse All
C#
public ConnectionPool();
Remarks

This is ConnectionPool, a member of class ConnectionPool.

See Also
ConnectionPool Class
Eco.Persistence Namespace


ConnectionPool.ConnectionPool Constructor (PersistenceMapperDb)

ConnectionPool.ConnectionPool Constructor (PersistenceMapperDb)
ConnectionPool Class Eco.Persistence Namespace See Also
Collapse All

Creates a new instance of the pool.

C#
public ConnectionPool(
    PersistenceMapperDb owner
);
Parameters
Parameters | Description
owner | Specifies the owner of the pool.
See Also
ConnectionPool Class
Eco.Persistence Namespace


ConnectionPool Methods

ConnectionPool Methods
Public Methods
Collapse All

The methods of the ConnectionPool class are listed here.

Public Methods
Name | Description
CloseConnections | Closes all connections and returns them to the component’s owner.
RetrieveClosedDatabaseConnection | Returns a database connection but does not open it.
RetrieveDatabaseConnection | Retrieves a database connection and ensures it is open.
ReturnDatabaseConnection | Returns a connection to the pool.


ConnectionPool.CloseConnections Method

ConnectionPool.CloseConnections Method
ConnectionPool Class Eco.Persistence Namespace See Also
Collapse All

Closes all connections and returns them to the component’s owner.

C#
public void CloseConnections(
    bool force
);
Parameters
Parameters | Description
force | This will be true if the pool is being closed as a result of an owning object being disposed.
See Also
ConnectionPool Class
Eco.Persistence Namespace


ConnectionPool.RetrieveClosedDatabaseConnection Method

ConnectionPool.RetrieveClosedDatabaseConnection Method
ConnectionPool Class Eco.Persistence Namespace Related Topics See Also
Collapse All

Returns a database connection but does not open it.

C#
public IDatabase RetrieveClosedDatabaseConnection(
    bool exclusive
);
Parameters
Parameters | Description
exclusive | Specifies whether or not the connection should have exclusive access to the database.
Remarks

Although this method does not open the connection, it may actually be open if it has been previously used.

Exceptions
Exceptions | Description
InvalidOperationException | Thrown if exclusive is true and there already are used connections. Thrown if the retrieved connection is already used.
Related Topics

ConnectionPool.MaxOpenConnections

See Also
ConnectionPool Class
Eco.Persistence Namespace
Related Topics


ConnectionPool.RetrieveDatabaseConnection Method

ConnectionPool.RetrieveDatabaseConnection Method
ConnectionPool Class Eco.Persistence Namespace Related Topics See Also
Collapse All

Retrieves a database connection and ensures it is open.

C#
public IDatabase RetrieveDatabaseConnection(
    bool exclusive
);
Parameters
Parameters | Description
exclusive | Specifies whether or not the connection should have exclusive access to the database.
Related Topics

ConnectionPool.RetrieveClosedDatabaseConnection

See Also
ConnectionPool Class
Eco.Persistence Namespace
Related Topics


ConnectionPool.ReturnDatabaseConnection Method

ConnectionPool.ReturnDatabaseConnection Method
ConnectionPool Class Eco.Persistence Namespace See Also
Collapse All

Returns a connection to the pool.

C#
public void ReturnDatabaseConnection(
    IDatabase database
);
Remarks

If the number of pooled connections would exceed MaxPoolConnections then the connection is returned to this component’s owned for disposal, otherwise it is added to the list of available connections for reuse.

Exceptions
Exceptions | Description
ArgumentNullException | Thrown if database is null.
ArgumentException | Thrown if the connection was not retrieved from this pool. Thrown if the connection is in a transaction.
See Also
ConnectionPool Class
Eco.Persistence Namespace


ConnectionPool Properties

ConnectionPool Properties
Public Properties
Collapse All

The properties of the ConnectionPool class are listed here.

Public Properties
Name | Description
MaxOpenConnections | Specifies the maximum number of connections that may be retrieved before the requesting thread goes into a queue.
MaxPoolConnections | Specifies the number of connections that may be held in the queue.


ConnectionPool.MaxOpenConnections Property

ConnectionPool.MaxOpenConnections Property
ConnectionPool Class Eco.Persistence Namespace See Also
Collapse All

Specifies the maximum number of connections that may be retrieved before the requesting thread goes into a queue.

C#
public int MaxOpenConnections;
Remarks

The pool keeps track of how many connections have been provided. If a request is made for a new connection and this would cause the number of provided connections to exceed MaxOpenConnections then the requesting thread will go into a queue and sleep until a connection becomes available.

See Also
ConnectionPool Class
Eco.Persistence Namespace


ConnectionPool.MaxPoolConnections Property

ConnectionPool.MaxPoolConnections Property
ConnectionPool Class Eco.Persistence Namespace See Also
Collapse All

Specifies the number of connections that may be held in the queue.

C#
public int MaxPoolConnections;
Remarks

When a connection is returned it is either retained or returned to this component’s owner for disposal. If this number is less than MaxOpenConnections then it will be possible to request a total of MaxOpenConnections from the pool without the requesting thread sleeping, but only MaxPoolConnections will be retained upon return, any connections above this number will be created upon demand and then released when they are returned.

See Also
ConnectionPool Class
Eco.Persistence Namespace


ContentEqualArray Class

ContentEqualArray Class
Inheritance Hierarchy See Also
Collapse All
C#
public class ContentEqualArray;
Remarks

This is class Eco.Persistence.ContentEqualArray.

Inheritance Hierarchy
Eco.Persistence.ContentEqualArray
File

ContentEqualArray.cs

See Also
Inheritance Hierarchy


ContentEqualArray.ContentEqualArray Constructor

ContentEqualArray.ContentEqualArray Constructor
ContentEqualArray Class Eco.Persistence Namespace See Also
Collapse All
C#
public ContentEqualArray(
    int size
);
Remarks

This is ContentEqualArray, a member of class ContentEqualArray.

See Also
ContentEqualArray Class
Eco.Persistence Namespace


ContentEqualArray Methods

ContentEqualArray Methods
Public Methods
Collapse All

The methods of the ContentEqualArray class are listed here.

Public Methods
Name | Description
Equals | This is Equals, a member of class ContentEqualArray.
GetHashCode | This is GetHashCode, a member of class ContentEqualArray.
GetItem | This is GetItem, a member of class ContentEqualArray.
SetItem | This is SetItem, a member of class ContentEqualArray.
ToString | This is ToString, a member of class ContentEqualArray.


ContentEqualArray.Equals Method

ContentEqualArray.Equals Method
ContentEqualArray Class Eco.Persistence Namespace See Also
Collapse All
C#
public override bool Equals(
    System.Object obj
);
Remarks

This is Equals, a member of class ContentEqualArray.

See Also
ContentEqualArray Class
Eco.Persistence Namespace


ContentEqualArray.GetHashCode Method

ContentEqualArray.GetHashCode Method
ContentEqualArray Class Eco.Persistence Namespace See Also
Collapse All
C#
public override int GetHashCode();
Remarks

This is GetHashCode, a member of class ContentEqualArray.

See Also
ContentEqualArray Class
Eco.Persistence Namespace


ContentEqualArray.GetItem Method

ContentEqualArray.GetItem Method
ContentEqualArray Class Eco.Persistence Namespace See Also
Collapse All
C#
public System.Object GetItem(
    int index
);
Remarks

This is GetItem, a member of class ContentEqualArray.

See Also
ContentEqualArray Class
Eco.Persistence Namespace


ContentEqualArray.SetItem Method

ContentEqualArray.SetItem Method
ContentEqualArray Class Eco.Persistence Namespace See Also
Collapse All
C#
public void SetItem(
    int index,
    System.Object value
);
Remarks

This is SetItem, a member of class ContentEqualArray.

See Also
ContentEqualArray Class
Eco.Persistence Namespace


ContentEqualArray.ToString Method

ContentEqualArray.ToString Method
ContentEqualArray Class Eco.Persistence Namespace See Also
Collapse All
C#
public override string ToString();
Remarks

This is ToString, a member of class ContentEqualArray.

See Also
ContentEqualArray Class
Eco.Persistence Namespace


ContentEqualArray Properties

ContentEqualArray Properties
Public Properties
Collapse All

The properties of the ContentEqualArray class are listed here.

Public Properties
Name | Description
Size | This is Size, a member of class ContentEqualArray.


ContentEqualArray.Size Property

ContentEqualArray.Size Property
ContentEqualArray Class Eco.Persistence Namespace See Also
Collapse All
C#
public int Size;
Remarks

This is Size, a member of class ContentEqualArray.

See Also
ContentEqualArray Class
Eco.Persistence Namespace


DatablockConverter Class

DatablockConverter Class
Inheritance Hierarchy See Also
Collapse All

This class can convert a datablock to xml and back.

C#
public class DatablockConverter;
Inheritance Hierarchy
Eco.Persistence.DatablockConverter
File

DatablockToXml.cs

See Also
Inheritance Hierarchy


DatablockConverter.DatablockConverter Constructor

DatablockConverter.DatablockConverter Constructor
DatablockConverter Class Eco.Persistence Namespace See Also
Collapse All
C#
public DatablockConverter(
    IEcoTypeSystem typeSystem
);
Remarks

This is DatablockConverter, a member of class DatablockConverter.

See Also
DatablockConverter Class
Eco.Persistence Namespace


DatablockConverter Methods

DatablockConverter Methods
Public Methods
Collapse All

The methods of the DatablockConverter class are listed here.

Public Methods
Name | Description
ByteArraysAreEqual | This is ByteArraysAreEqual, a member of class DatablockConverter.
CharArraysAreEqual | This is CharArraysAreEqual, a member of class DatablockConverter.
ContainsEcoData | This is ContainsEcoData, a member of class DatablockConverter.
ConvertToDatablock | This is the overview for the ConvertToDatablock method overload.
ConvertToXml | This is ConvertToXml, a member of class DatablockConverter.
CreateChild | This is CreateChild, a member of class DatablockConverter.
FindChild | This is FindChild, a member of class DatablockConverter.
GetAssocEndByName | This is GetAssocEndByName, a member of class DatablockConverter.
GetAttributeByName | This is GetAttributeByName, a member of class DatablockConverter.
GetClassById | This is GetClassById, a member of class DatablockConverter.
SetAttribute | This is SetAttribute, a member of class DatablockConverter.


DatablockConverter.ByteArraysAreEqual Method

DatablockConverter.ByteArraysAreEqual Method
DatablockConverter Class Eco.Persistence Namespace See Also
Collapse All
C#
public static bool ByteArraysAreEqual(
    System.Object value,
    System.Object columnValue
);
Remarks

This is ByteArraysAreEqual, a member of class DatablockConverter.

See Also
DatablockConverter Class
Eco.Persistence Namespace


DatablockConverter.CharArraysAreEqual Method

DatablockConverter.CharArraysAreEqual Method
DatablockConverter Class Eco.Persistence Namespace See Also
Collapse All
C#
public static bool CharArraysAreEqual(
    System.Object value,
    System.Object columnValue
);
Remarks

This is CharArraysAreEqual, a member of class DatablockConverter.

See Also
DatablockConverter Class
Eco.Persistence Namespace


DatablockConverter.ContainsEcoData Method

DatablockConverter.ContainsEcoData Method
DatablockConverter Class Eco.Persistence Namespace See Also
Collapse All
C#
public bool ContainsEcoData(
    XmlDocument doc
);
Remarks

This is ContainsEcoData, a member of class DatablockConverter.

See Also
DatablockConverter Class
Eco.Persistence Namespace


ConvertToDatablock Method

ConvertToDatablock Method

This is the overview for the ConvertToDatablock method overload.

Overload List
Name | Description
DatablockConverter.ConvertToDatablock (XmlDocument) | This is ConvertToDatablock, a member of class DatablockConverter.
DatablockConverter.ConvertToDatablock (XmlDocument, bool) | This is ConvertToDatablock, a member of class DatablockConverter.
DatablockConverter.ConvertToDatablock (XmlDocument, bool, Datablock) | This is ConvertToDatablock, a member of class DatablockConverter.


DatablockConverter.ConvertToDatablock Method (XmlDocument)

DatablockConverter.ConvertToDatablock Method (XmlDocument)
DatablockConverter Class Eco.Persistence Namespace See Also
Collapse All
C#
public Datablock ConvertToDatablock(
    XmlDocument doc
);
Remarks

This is ConvertToDatablock, a member of class DatablockConverter.

See Also
DatablockConverter Class
Eco.Persistence Namespace


DatablockConverter.ConvertToDatablock Method (XmlDocument, bool)

DatablockConverter.ConvertToDatablock Method (XmlDocument, bool)
DatablockConverter Class Eco.Persistence Namespace See Also
Collapse All
C#
public Datablock ConvertToDatablock(
    XmlDocument doc,
    bool setInitialValues
);
Remarks

This is ConvertToDatablock, a member of class DatablockConverter.

See Also
DatablockConverter Class
Eco.Persistence Namespace


DatablockConverter.ConvertToDatablock Method (XmlDocument, bool, Datablock)

DatablockConverter.ConvertToDatablock Method (XmlDocument, bool, Datablock)
DatablockConverter Class Eco.Persistence Namespace See Also
Collapse All
C#
public void ConvertToDatablock(
    XmlDocument doc,
    bool setInitialValues,
    Datablock datablock
);
Remarks

This is ConvertToDatablock, a member of class DatablockConverter.

See Also
DatablockConverter Class
Eco.Persistence Namespace


DatablockConverter.ConvertToXml Method

DatablockConverter.ConvertToXml Method
DatablockConverter Class Eco.Persistence Namespace See Also
Collapse All
C#
public XmlDocument ConvertToXml(
    Datablock datablock
);
Remarks

This is ConvertToXml, a member of class DatablockConverter.

See Also
DatablockConverter Class
Eco.Persistence Namespace


DatablockConverter.CreateChild Method

DatablockConverter.CreateChild Method
DatablockConverter Class Eco.Persistence Namespace See Also
Collapse All
C#
public XmlElement CreateChild(
    XmlNode parent,
    string name,
    XmlDocument doc
);
Remarks

This is CreateChild, a member of class DatablockConverter.

See Also
DatablockConverter Class
Eco.Persistence Namespace


DatablockConverter.FindChild Method

DatablockConverter.FindChild Method
DatablockConverter Class Eco.Persistence Namespace See Also
Collapse All
C#
public XmlElement FindChild(
    XmlNode node,
    string name
);
Remarks

This is FindChild, a member of class DatablockConverter.

See Also
DatablockConverter Class
Eco.Persistence Namespace


DatablockConverter.GetAssocEndByName Method

DatablockConverter.GetAssocEndByName Method
DatablockConverter Class Eco.Persistence Namespace See Also
Collapse All
C#
public IAssociationEnd GetAssocEndByName(
    IClass c,
    string oldClassName,
    string name
);
Remarks

This is GetAssocEndByName, a member of class DatablockConverter.

See Also
DatablockConverter Class
Eco.Persistence Namespace


DatablockConverter.GetAttributeByName Method

DatablockConverter.GetAttributeByName Method
DatablockConverter Class Eco.Persistence Namespace See Also
Collapse All
C#
public IAttribute GetAttributeByName(
    IClass c,
    string oldClassName,
    string name
);
Remarks

This is GetAttributeByName, a member of class DatablockConverter.

See Also
DatablockConverter Class
Eco.Persistence Namespace


DatablockConverter.GetClassById Method

DatablockConverter.GetClassById Method
DatablockConverter Class Eco.Persistence Namespace See Also
Collapse All
C#
public IClass GetClassById(
    string name
);
Remarks

This is GetClassById, a member of class DatablockConverter.

See Also
DatablockConverter Class
Eco.Persistence Namespace


DatablockConverter.SetAttribute Method

DatablockConverter.SetAttribute Method
DatablockConverter Class Eco.Persistence Namespace See Also
Collapse All
C#
public void SetAttribute(
    XmlNode node,
    XmlDocument doc,
    string attributeName,
    string value
);
Remarks

This is SetAttribute, a member of class DatablockConverter.

See Also
DatablockConverter Class
Eco.Persistence Namespace


DatablockConverter Properties

DatablockConverter Properties
Public Properties
Collapse All

The properties of the DatablockConverter class are listed here.

Public Properties
Name | Description
Compact | This is Compact, a member of class DatablockConverter.
DebugMode | When DebugMode is true, the xml-conversion routines will check that any value that is converted to a string can be converted back to the same value. if this conversion fails, an exception will be raised. The user then has to implement a conversion event to handle this specific datatype.
StrictParsing | Strict parsing means that unknown elements in the xml-file will result in an exception when the xml is loaded. If strict = false then all unknown elements will be silently ignored. This happens if you have for example removed an attribute/class from the model.
TypeSystem | This is TypeSystem, a member of class DatablockConverter.


DatablockConverter.Compact Property

DatablockConverter.Compact Property
DatablockConverter Class Eco.Persistence Namespace See Also
Collapse All
C#
public bool Compact;
Remarks

This is Compact, a member of class DatablockConverter.

See Also
DatablockConverter Class
Eco.Persistence Namespace


DatablockConverter.DebugMode Property

DatablockConverter.DebugMode Property
DatablockConverter Class Eco.Persistence Namespace See Also
Collapse All

When DebugMode is true, the xml-conversion routines will check that any value that is converted to a string can be converted back to the same value. if this conversion fails, an exception will be raised. The user then has to implement a conversion event to handle this specific datatype.

C#
public bool DebugMode;
See Also
DatablockConverter Class
Eco.Persistence Namespace


DatablockConverter.StrictParsing Property

DatablockConverter.StrictParsing Property
DatablockConverter Class Eco.Persistence Namespace See Also
Collapse All

Strict parsing means that unknown elements in the xml-file will result in an exception when the xml is loaded. If strict = false then all unknown elements will be silently ignored. This happens if you have for example removed an attribute/class from the model.

C#
public bool StrictParsing;
See Also
DatablockConverter Class
Eco.Persistence Namespace


DatablockConverter.TypeSystem Property

DatablockConverter.TypeSystem Property
DatablockConverter Class Eco.Persistence Namespace See Also
Collapse All
C#
public IEcoTypeSystem TypeSystem;
Remarks

This is TypeSystem, a member of class DatablockConverter.

See Also
DatablockConverter Class
Eco.Persistence Namespace


DatablockConverter Delegates

DatablockConverter Delegates
Public Delegates Public Delegates See Also
Collapse All

The delegates of the DatablockConverter class are listed here.

Public Delegates
Name | Description
IdToStringHandler | This is nested type Eco.Persistence.DatablockConverter.IdToStringHandler.
Top
See Also
Public Delegates


DatablockConverter.IdToStringHandler Delegate

DatablockConverter.IdToStringHandler Delegate
DatablockConverter Class Eco.Persistence Namespace See Also
Collapse All
C#
public delegate string IdToStringHandler(ObjectId id);
Remarks

This is nested type Eco.Persistence.DatablockConverter.IdToStringHandler.

See Also
DatablockConverter Class
Eco.Persistence Namespace


DatablockConverter Events

DatablockConverter Events
Public Events
Collapse All

The events of the DatablockConverter class are listed here.

Public Events
Name | Description
IdToString | This is IdToString, a member of class DatablockConverter.


DatablockConverter.IdToString Event

DatablockConverter.IdToString Event
DatablockConverter Class Eco.Persistence Namespace See Also
Collapse All
C#
public event IdToStringHandler IdToString;
Remarks

This is IdToString, a member of class DatablockConverter.

See Also
DatablockConverter Class
Eco.Persistence Namespace


DBChange Class

DBChange Class
Inheritance Hierarchy See Also
Collapse All

Contains change information received from the SyncHandler on a remote persistence.

C#
public sealed class DBChange;
Inheritance Hierarchy
Eco.Persistence.DBChange
File

PersistenceMapperInterfaces.cs

See Also
Inheritance Hierarchy


DBChange.DBChange Constructor

DBChange.DBChange Constructor
DBChange Class Eco.Persistence Namespace See Also
Collapse All
C#
public DBChange(
    ObjectId objectId
);
Remarks

This is DBChange, a member of class DBChange.

See Also
DBChange Class
Eco.Persistence Namespace


DBChange Enumerations

DBChange Enumerations
Enumerations
Collapse All

The enumerations of the DBChange class are listed here.

Enumerations
Name | Description
ChangeKind | Identifies the nature of a DBChange.


Eco.Persistence.DBChange.ChangeKind Enumeration

Eco.Persistence.DBChange.ChangeKind Enumeration

Identifies the nature of a DBChange.

C#
public enum ChangeKind {
  None,
  EmbeddedMembersChanged,
  MembersChanged,
  ObjectCreated,
  ObjectDeleted
}
Members
Members | Description
EmbeddedMembersChanged | One or more of the members of this object were modified.
MembersChanged | One or more of the members of this object were modified.
ObjectCreated | A new instance of the specified class type was created.
ObjectDeleted | The identified object instance was deleted.
File

PersistenceMapperInterfaces.cs


DBChange Methods

DBChange Methods
Public Methods
Collapse All

The methods of the DBChange class are listed here.

Public Methods
Name | Description
MemberChanged | Specifies the identidied member has been modified.
ObjectCreated | Sets the change type to identify a newly created object.
ObjectDeleted | Sets the change type to identify a deleted object.


DBChange.MemberChanged Method

DBChange.MemberChanged Method
DBChange Class Eco.Persistence Namespace See Also
Collapse All

Specifies the identidied member has been modified.

C#
public void MemberChanged(
    int memberId
);
Parameters
Parameters | Description
memberId | The index of the member to mark as modified.
See Also
DBChange Class
Eco.Persistence Namespace


DBChange.ObjectCreated Method

DBChange.ObjectCreated Method
DBChange Class Eco.Persistence Namespace See Also
Collapse All

Sets the change type to identify a newly created object.

C#
public void ObjectCreated();
See Also
DBChange Class
Eco.Persistence Namespace


DBChange.ObjectDeleted Method

DBChange.ObjectDeleted Method
DBChange Class Eco.Persistence Namespace See Also
Collapse All

Sets the change type to identify a deleted object.

C#
public void ObjectDeleted();
See Also
DBChange Class
Eco.Persistence Namespace


DBChange Properties

DBChange Properties
Public Properties
Collapse All

The properties of the DBChange class are listed here.

Public Properties
Name | Description
EmbeddedMembersChanged | Indicates whether or not embedded members of the changed object were also changed.
Kind | Identifies the type of change made to the persistent storage.
MemberIds | Returns a list of indexes identifying modified members.
ObjectId | Returns the ID of the modified object.


DBChange.EmbeddedMembersChanged Property

DBChange.EmbeddedMembersChanged Property
DBChange Class Eco.Persistence Namespace See Also
Collapse All

Indicates whether or not embedded members of the changed object were also changed.

C#
public bool EmbeddedMembersChanged;
See Also
DBChange Class
Eco.Persistence Namespace


DBChange.Kind Property

DBChange.Kind Property
DBChange Class Eco.Persistence Namespace See Also
Collapse All

Identifies the type of change made to the persistent storage.

C#
public ChangeKind Kind;
See Also
DBChange Class
Eco.Persistence Namespace


DBChange.MemberIds Property

DBChange.MemberIds Property
DBChange Class Eco.Persistence Namespace See Also
Collapse All

Returns a list of indexes identifying modified members.

C#
public int MemberIds;
See Also
DBChange Class
Eco.Persistence Namespace


DBChange.ObjectId Property

DBChange.ObjectId Property
DBChange Class Eco.Persistence Namespace See Also
Collapse All

Returns the ID of the modified object.

C#
public ObjectId ObjectId;
See Also
DBChange Class
Eco.Persistence Namespace


DBChangeCollection Class

DBChangeCollection Class
Inheritance Hierarchy See Also
Collapse All

Collection of changes

C#
public sealed class DBChangeCollection : IEnumerable;
Inheritance Hierarchy
Eco.Persistence.DBChangeCollection
File

PersistenceMapperInterfaces.cs

See Also
Inheritance Hierarchy


DBChangeCollection Methods

DBChangeCollection Methods
Public Methods
Collapse All

The methods of the DBChangeCollection class are listed here.

Public Methods
Name | Description
Add |
GetEnsured | This is GetEnsured, a member of class DBChangeCollection.
GetEnumerator | This is GetEnumerator, a member of class DBChangeCollection.
Strip | This is Strip, a member of class DBChangeCollection.
this | This is this, a member of class DBChangeCollection.


DBChangeCollection.Add Method

DBChangeCollection.Add Method
DBChangeCollection Class Eco.Persistence Namespace See Also
Collapse All
C#
public void Add(
    DBChange change
);
Exceptions
Exceptions | Description
ArgumentNullException | Thrown if change is null
See Also
DBChangeCollection Class
Eco.Persistence Namespace


DBChangeCollection.GetEnsured Method

DBChangeCollection.GetEnsured Method
DBChangeCollection Class Eco.Persistence Namespace See Also
Collapse All
C#
public DBChange GetEnsured(
    ObjectId id
);
Remarks

This is GetEnsured, a member of class DBChangeCollection.

See Also
DBChangeCollection Class
Eco.Persistence Namespace


DBChangeCollection.GetEnumerator Method

DBChangeCollection.GetEnumerator Method
DBChangeCollection Class Eco.Persistence Namespace See Also
Collapse All
C#
public IEnumerator GetEnumerator();
Remarks

This is GetEnumerator, a member of class DBChangeCollection.

See Also
DBChangeCollection Class
Eco.Persistence Namespace


DBChangeCollection.Strip Method

DBChangeCollection.Strip Method
DBChangeCollection Class Eco.Persistence Namespace See Also
Collapse All
C#
public void Strip();
Remarks

This is Strip, a member of class DBChangeCollection.

See Also
DBChangeCollection Class
Eco.Persistence Namespace


DBChangeCollection.this Indexer

DBChangeCollection.this Indexer
DBChangeCollection Class Eco.Persistence Namespace See Also
Collapse All
C#
public DBChange this[
    ObjectId id
];
Remarks

This is this, a member of class DBChangeCollection.

See Also
DBChangeCollection Class
Eco.Persistence Namespace


DBChangeCollection Properties

DBChangeCollection Properties
Public Properties
Collapse All

The properties of the DBChangeCollection class are listed here.

Public Properties
Name | Description
All | This is All, a member of class DBChangeCollection.
Count | This is Count, a member of class DBChangeCollection.


DBChangeCollection.All Property

DBChangeCollection.All Property
DBChangeCollection Class Eco.Persistence Namespace See Also
Collapse All
C#
public bool All;
Remarks

This is All, a member of class DBChangeCollection.

See Also
DBChangeCollection Class
Eco.Persistence Namespace


DBChangeCollection.Count Property

DBChangeCollection.Count Property
DBChangeCollection Class Eco.Persistence Namespace See Also
Collapse All
C#
public int Count;
Remarks

This is Count, a member of class DBChangeCollection.

See Also
DBChangeCollection Class
Eco.Persistence Namespace


DefaultCleanPsConfig Class

DefaultCleanPsConfig Class
Inheritance Hierarchy See Also
Collapse All

DefaultCleanPSConfig provides a UI less implementation of IConfigureCleanPS. This avoids dependencies to Windows.Forms. FormBasedConfigureCleanPS is the implementation of IConfigureCleanPS which is used at design time.

C#
public sealed class DefaultCleanPsConfig : System.Object, IConfigureCleanPS;
Inheritance Hierarchy
Eco.Persistence.IConfigureCleanPS
    Eco.Persistence.DefaultCleanPsConfig
File

CleanPersistenceInterfaces.cs

See Also
Inheritance Hierarchy


DefaultCleanPsConfig.DefaultCleanPsConfig Constructor

DefaultCleanPsConfig.DefaultCleanPsConfig Constructor
DefaultCleanPsConfig Class Eco.Persistence Namespace See Also
Collapse All
C#
public DefaultCleanPsConfig(
    bool deleteUnknowTables
);
Remarks

This is DefaultCleanPsConfig, a member of class DefaultCleanPsConfig.

See Also
DefaultCleanPsConfig Class
Eco.Persistence Namespace


DefaultEcoIdMapper Class

DefaultEcoIdMapper Class
Inheritance Hierarchy See Also
Collapse All

This class implements a key mapper for autoincremental fields. The actual id values are allocated by the database

C#
public class DefaultEcoIdMapper : DefaultEcoKeyMapperBase, IKeyMapper;
Inheritance Hierarchy
Eco.Persistence.GenericKeyMapper
    Eco.Persistence.DefaultEcoKeyMapperBase
    Eco.Persistence.IKeyMapper
        Eco.Persistence.DefaultEcoIdMapper
File

DefaultEcoKeyMapper.cs

See Also
Inheritance Hierarchy


DefaultEcoIdMapper.DefaultEcoIdMapper Constructor

DefaultEcoIdMapper.DefaultEcoIdMapper Constructor
DefaultEcoIdMapper Class Eco.Persistence Namespace See Also
Collapse All
C#
public DefaultEcoIdMapper();
Remarks

This is DefaultEcoIdMapper, a member of class DefaultEcoIdMapper.

See Also
DefaultEcoIdMapper Class
Eco.Persistence Namespace


DefaultEcoIdMapper Fields

DefaultEcoIdMapper Fields
Public Fields
Collapse All

The fields of the DefaultEcoIdMapper class are listed here.

Public Fields
Name | Description
DefaultKeyMapperName | This is DefaultKeyMapperName, a member of class DefaultEcoIdMapper.


DefaultEcoIdMapper.DefaultKeyMapperName Field

DefaultEcoIdMapper.DefaultKeyMapperName Field
DefaultEcoIdMapper Class Eco.Persistence Namespace See Also
Collapse All
C#
public static string DefaultKeyMapperName = "DefaultEcoIdMapper";
Remarks

This is DefaultKeyMapperName, a member of class DefaultEcoIdMapper.

See Also
DefaultEcoIdMapper Class
Eco.Persistence Namespace


DefaultEcoIdMapper Methods

DefaultEcoIdMapper Methods
Public Methods
Collapse All

The methods of the DefaultEcoIdMapper class are listed here.

Public Methods
Name | Description
IdFromFields | This method creates a new id based on the values of the field objects
NewIdPreUpdate |


DefaultEcoIdMapper.IdFromFields Method

DefaultEcoIdMapper.IdFromFields Method
DefaultEcoIdMapper Class Eco.Persistence Namespace See Also
Collapse All

This method creates a new id based on the values of the field objects

C#
public override ObjectId IdFromFields(
    IField[] keyFields,
    ArrayList keyMappers,
    int classId,
    int timeStamp
);
See Also
DefaultEcoIdMapper Class
Eco.Persistence Namespace


DefaultEcoIdMapper.NewIdPreUpdate Method

DefaultEcoIdMapper.NewIdPreUpdate Method
DefaultEcoIdMapper Class Eco.Persistence Namespace See Also
Collapse All
C#
public ObjectId NewIdPreUpdate(
    IDatabase db,
    ObjectId oldId
);
Exceptions
Exceptions | Description
ArgumentNullException | Thrown if db or oldId is null.
EcoCantGetNewObjectIdException | Thrown if there was a problem reserving IDs. The original exception is passed as InnerException
See Also
DefaultEcoIdMapper Class
Eco.Persistence Namespace


DefaultEcoIdMapper Properties

DefaultEcoIdMapper Properties
Protected Properties
Collapse All

The properties of the DefaultEcoIdMapper class are listed here.

Protected Properties
Name | Description
KeyMapping | This is KeyMapping, a member of class DefaultEcoIdMapper.


DefaultEcoIdMapper.KeyMapping Property

DefaultEcoIdMapper.KeyMapping Property
DefaultEcoIdMapper Class Eco.Persistence Namespace See Also
Collapse All
C#
protected override ISingleColumnAttributemapping KeyMapping;
Remarks

This is KeyMapping, a member of class DefaultEcoIdMapper.

See Also
DefaultEcoIdMapper Class
Eco.Persistence Namespace


DefaultEcoInt64KeyMapper Class

DefaultEcoInt64KeyMapper Class
Inheritance Hierarchy See Also
Collapse All

This class implements a key mapper for autoincremental fields. The actual id values are allocated by the database

C#
public class DefaultEcoInt64KeyMapper : DefaultEcoKeyMapperBase, IKeyMapper;
Inheritance Hierarchy
Eco.Persistence.GenericKeyMapper
    Eco.Persistence.DefaultEcoKeyMapperBase
    Eco.Persistence.IKeyMapper
        Eco.Persistence.DefaultEcoInt64KeyMapper
File

DefaultEcoInt64KeyMapper.cs

See Also
Inheritance Hierarchy


DefaultEcoInt64KeyMapper.DefaultEcoInt64KeyMapper Constructor

DefaultEcoInt64KeyMapper.DefaultEcoInt64KeyMapper Constructor
DefaultEcoInt64KeyMapper Class Eco.Persistence Namespace See Also
Collapse All
C#
public DefaultEcoInt64KeyMapper();
Remarks

This is DefaultEcoInt64KeyMapper, a member of class DefaultEcoInt64KeyMapper.

See Also
DefaultEcoInt64KeyMapper Class
Eco.Persistence Namespace


DefaultEcoInt64KeyMapper Fields

DefaultEcoInt64KeyMapper Fields
Public Fields
Collapse All

The fields of the DefaultEcoInt64KeyMapper class are listed here.

Public Fields
Name | Description
Int64KeyMapperName | This is Int64KeyMapperName, a member of class DefaultEcoInt64KeyMapper.


DefaultEcoInt64KeyMapper.Int64KeyMapperName Field

DefaultEcoInt64KeyMapper.Int64KeyMapperName Field
DefaultEcoInt64KeyMapper Class Eco.Persistence Namespace See Also
Collapse All
C#
public static string Int64KeyMapperName = "Int64";
Remarks

This is Int64KeyMapperName, a member of class DefaultEcoInt64KeyMapper.

See Also
DefaultEcoInt64KeyMapper Class
Eco.Persistence Namespace


DefaultEcoInt64KeyMapper Methods

DefaultEcoInt64KeyMapper Methods
Protected Methods Public Methods
Collapse All

The methods of the DefaultEcoInt64KeyMapper class are listed here.

Protected Methods
Name | Description
InternalInitialize |
Top
Public Methods
Name | Description
IdFromFields | This method creates a new id based on the values of the field objects
NewIdPreUpdate |


DefaultEcoInt64KeyMapper.IdFromFields Method

DefaultEcoInt64KeyMapper.IdFromFields Method
DefaultEcoInt64KeyMapper Class Eco.Persistence Namespace See Also
Collapse All

This method creates a new id based on the values of the field objects

C#
public override ObjectId IdFromFields(
    IField[] keyFields,
    ArrayList keyMappers,
    int classId,
    int timeStamp
);
See Also
DefaultEcoInt64KeyMapper Class
Eco.Persistence Namespace


DefaultEcoInt64KeyMapper.InternalInitialize Method

DefaultEcoInt64KeyMapper.InternalInitialize Method
DefaultEcoInt64KeyMapper Class Eco.Persistence Namespace See Also
Collapse All
C#
protected override void InternalInitialize(
    SqlDatabaseConfig sqlDatabaseConfig,
    ArrayList keyMappers
);
Exceptions
Exceptions | Description
ArgumentNullException | Thrown if sqlDatabaseConfig is null
See Also
DefaultEcoInt64KeyMapper Class
Eco.Persistence Namespace


DefaultEcoInt64KeyMapper.NewIdPreUpdate Method

DefaultEcoInt64KeyMapper.NewIdPreUpdate Method
DefaultEcoInt64KeyMapper Class Eco.Persistence Namespace See Also
Collapse All
C#
public ObjectId NewIdPreUpdate(
    IDatabase db,
    ObjectId oldId
);
Exceptions
Exceptions | Description
ArgumentNullException | Thrown if db or oldId is null.
EcoCantGetNewObjectIdException | Thrown if there was a problem reserving IDs. The original exception is passed as InnerException
See Also
DefaultEcoInt64KeyMapper Class
Eco.Persistence Namespace


DefaultEcoInt64KeyMapper Properties

DefaultEcoInt64KeyMapper Properties
Public Properties Protected Properties
Collapse All

The properties of the DefaultEcoInt64KeyMapper class are listed here.

Public Properties
Name | Description
Int64Mapper | This is Int64Mapper, a member of class DefaultEcoInt64KeyMapper.
Top
Protected Properties
Name | Description
KeyMapping | This is KeyMapping, a member of class DefaultEcoInt64KeyMapper.


DefaultEcoInt64KeyMapper.Int64Mapper Property

DefaultEcoInt64KeyMapper.Int64Mapper Property
DefaultEcoInt64KeyMapper Class Eco.Persistence Namespace See Also
Collapse All
C#
public ISingleColumnAttributemapping Int64Mapper;
Remarks

This is Int64Mapper, a member of class DefaultEcoInt64KeyMapper.

See Also
DefaultEcoInt64KeyMapper Class
Eco.Persistence Namespace


DefaultEcoInt64KeyMapper.KeyMapping Property

DefaultEcoInt64KeyMapper.KeyMapping Property
DefaultEcoInt64KeyMapper Class Eco.Persistence Namespace See Also
Collapse All
C#
protected override ISingleColumnAttributemapping KeyMapping;
Remarks

This is KeyMapping, a member of class DefaultEcoInt64KeyMapper.

See Also
DefaultEcoInt64KeyMapper Class
Eco.Persistence Namespace


DefaultEcoKeyMapperBase Class

DefaultEcoKeyMapperBase Class
Inheritance Hierarchy See Also
Collapse All
C#
public abstract class DefaultEcoKeyMapperBase : GenericKeyMapper;
Remarks

This is class Eco.Persistence.DefaultEcoKeyMapperBase.

Inheritance Hierarchy
Eco.Persistence.GenericKeyMapper
    Eco.Persistence.DefaultEcoKeyMapperBase
        Eco.Persistence.DefaultEcoIdMapper
        Eco.Persistence.DefaultEcoInt64KeyMapper
File

DefaultEcoKeyMapperBase.cs

See Also
Inheritance Hierarchy


DefaultEcoKeyMapperBase Fields

DefaultEcoKeyMapperBase Fields
Protected Fields
Collapse All

The fields of the DefaultEcoKeyMapperBase class are listed here.

Protected Fields
Name | Description
IDCOLUMN_NAME | do not localize this is the column name used in the generatortable. It could change to ECO_ID, but that would break backwards compatibility
IDTABLE_NAME | do not localize
INTERNALNULLKEY | used for 'databases' without NULL such as paradox and DBase
m_ReservedCount | This is m_ReservedCount, a member of class DefaultEcoKeyMapperBase.


DefaultEcoKeyMapperBase.IDCOLUMN_NAME Field

DefaultEcoKeyMapperBase.IDCOLUMN_NAME Field
DefaultEcoKeyMapperBase Class Eco.Persistence Namespace See Also
Collapse All
C#
protected static string IDCOLUMN_NAME = "BOLD_ID";
Remarks

do not localize this is the column name used in the generatortable. It could change to ECO_ID, but that would break backwards compatibility

See Also
DefaultEcoKeyMapperBase Class
Eco.Persistence Namespace


DefaultEcoKeyMapperBase.IDTABLE_NAME Field

DefaultEcoKeyMapperBase.IDTABLE_NAME Field
DefaultEcoKeyMapperBase Class Eco.Persistence Namespace See Also
Collapse All
C#
protected static string IDTABLE_NAME = "<Prefix>_ID";
Remarks

do not localize

See Also
DefaultEcoKeyMapperBase Class
Eco.Persistence Namespace


DefaultEcoKeyMapperBase.INTERNALNULLKEY Field

DefaultEcoKeyMapperBase.INTERNALNULLKEY Field
DefaultEcoKeyMapperBase Class Eco.Persistence Namespace See Also
Collapse All
C#
protected static int INTERNALNULLKEY = -1;
Remarks

used for 'databases' without NULL such as paradox and DBase

See Also
DefaultEcoKeyMapperBase Class
Eco.Persistence Namespace


DefaultEcoKeyMapperBase.m_ReservedCount Field

DefaultEcoKeyMapperBase.m_ReservedCount Field
DefaultEcoKeyMapperBase Class Eco.Persistence Namespace See Also
Collapse All
C#
protected int m_ReservedCount;
Remarks

This is m_ReservedCount, a member of class DefaultEcoKeyMapperBase.

See Also
DefaultEcoKeyMapperBase Class
Eco.Persistence Namespace


DefaultEcoKeyMapperBase Methods

DefaultEcoKeyMapperBase Methods
Protected Methods Public Methods
Collapse All

The methods of the DefaultEcoKeyMapperBase class are listed here.

Protected Methods
Name | Description
EffectiveIdTableName | This is EffectiveIdTableName, a member of class DefaultEcoKeyMapperBase.
InternalColumnType | This is InternalColumnType, a member of class DefaultEcoKeyMapperBase.
Top
Public Methods
Name | Description
ColumnCount | This is ColumnCount, a member of class DefaultEcoKeyMapperBase.
ColumnType | This is ColumnType, a member of class DefaultEcoKeyMapperBase.
GetIdAllocationMode | This is GetIdAllocationMode, a member of class DefaultEcoKeyMapperBase.
IdFromFields | This is IdFromFields, a member of class DefaultEcoKeyMapperBase.
IdListToWhereFragment | This is IdListToWhereFragment, a member of class DefaultEcoKeyMapperBase.
IdToParameters | This is IdToParameters, a member of class DefaultEcoKeyMapperBase.
Initialize | This is Initialize, a member of class DefaultEcoKeyMapperBase.
InitializeDatabase | This is InitializeDatabase, a member of class DefaultEcoKeyMapperBase.
InitializeDatabaseScript | This is InitializeDatabaseScript, a member of class DefaultEcoKeyMapperBase.
InitializePSDescriptions |
NewIdFromAttributes | This is NewIdFromAttributes, a member of class DefaultEcoKeyMapperBase.
ReserveId | This is ReserveId, a member of class DefaultEcoKeyMapperBase.


DefaultEcoKeyMapperBase.ColumnCount Method

DefaultEcoKeyMapperBase.ColumnCount Method
DefaultEcoKeyMapperBase Class Eco.Persistence Namespace See Also
Collapse All
C#
public int ColumnCount();
Remarks

This is ColumnCount, a member of class DefaultEcoKeyMapperBase.

See Also
DefaultEcoKeyMapperBase Class
Eco.Persistence Namespace


DefaultEcoKeyMapperBase.ColumnType Method

DefaultEcoKeyMapperBase.ColumnType Method
DefaultEcoKeyMapperBase Class Eco.Persistence Namespace See Also
Collapse All
C#
public string ColumnType(
    ArrayList KeyMappers,
    int columnNum
);
Remarks

This is ColumnType, a member of class DefaultEcoKeyMapperBase.

See Also
DefaultEcoKeyMapperBase Class
Eco.Persistence Namespace


DefaultEcoKeyMapperBase.EffectiveIdTableName Method

DefaultEcoKeyMapperBase.EffectiveIdTableName Method
DefaultEcoKeyMapperBase Class Eco.Persistence Namespace See Also
Collapse All
C#
protected string EffectiveIdTableName();
Remarks

This is EffectiveIdTableName, a member of class DefaultEcoKeyMapperBase.

See Also
DefaultEcoKeyMapperBase Class
Eco.Persistence Namespace


DefaultEcoKeyMapperBase.GetIdAllocationMode Method

DefaultEcoKeyMapperBase.GetIdAllocationMode Method
DefaultEcoKeyMapperBase Class Eco.Persistence Namespace See Also
Collapse All
C#
public IdAllocationMode GetIdAllocationMode();
Remarks

This is GetIdAllocationMode, a member of class DefaultEcoKeyMapperBase.

See Also
DefaultEcoKeyMapperBase Class
Eco.Persistence Namespace


DefaultEcoKeyMapperBase.IdFromFields Method

DefaultEcoKeyMapperBase.IdFromFields Method
DefaultEcoKeyMapperBase Class Eco.Persistence Namespace See Also
Collapse All
C#
public abstract ObjectId IdFromFields(
    IField[] keyFields,
    ArrayList keyMappers,
    int classId,
    int timeStamp
);
Remarks

This is IdFromFields, a member of class DefaultEcoKeyMapperBase.

See Also
DefaultEcoKeyMapperBase Class
Eco.Persistence Namespace


DefaultEcoKeyMapperBase.IdListToWhereFragment Method

DefaultEcoKeyMapperBase.IdListToWhereFragment Method
DefaultEcoKeyMapperBase Class Eco.Persistence Namespace See Also
Collapse All
C#
public override string IdListToWhereFragment(
    ObjectIdCollection idList,
    IParameterized parameterized,
    IList<string> idColumns,
    string idPrefix
);
Remarks

This is IdListToWhereFragment, a member of class DefaultEcoKeyMapperBase.

See Also
DefaultEcoKeyMapperBase Class
Eco.Persistence Namespace


DefaultEcoKeyMapperBase.IdToParameters Method

DefaultEcoKeyMapperBase.IdToParameters Method
DefaultEcoKeyMapperBase Class Eco.Persistence Namespace See Also
Collapse All
C#
public void IdToParameters(
    ObjectId id,
    IDataParameter[] parameters
);
Remarks

This is IdToParameters, a member of class DefaultEcoKeyMapperBase.

See Also
DefaultEcoKeyMapperBase Class
Eco.Persistence Namespace


DefaultEcoKeyMapperBase.Initialize Method

DefaultEcoKeyMapperBase.Initialize Method
DefaultEcoKeyMapperBase Class Eco.Persistence Namespace See Also
Collapse All
C#
public void Initialize(
    SqlDatabaseConfig config,
    ArrayList keyMappers
);
Remarks

This is Initialize, a member of class DefaultEcoKeyMapperBase.

See Also
DefaultEcoKeyMapperBase Class
Eco.Persistence Namespace


DefaultEcoKeyMapperBase.InitializeDatabase Method

DefaultEcoKeyMapperBase.InitializeDatabase Method
DefaultEcoKeyMapperBase Class Eco.Persistence Namespace See Also
Collapse All
C#
public void InitializeDatabase(
    IDatabase db
);
Remarks

This is InitializeDatabase, a member of class DefaultEcoKeyMapperBase.

See Also
DefaultEcoKeyMapperBase Class
Eco.Persistence Namespace


DefaultEcoKeyMapperBase.InitializeDatabaseScript Method

DefaultEcoKeyMapperBase.InitializeDatabaseScript Method
DefaultEcoKeyMapperBase Class Eco.Persistence Namespace See Also
Collapse All
C#
public void InitializeDatabaseScript(
    IList<string> script
);
Remarks

This is InitializeDatabaseScript, a member of class DefaultEcoKeyMapperBase.

See Also
DefaultEcoKeyMapperBase Class
Eco.Persistence Namespace


DefaultEcoKeyMapperBase.InitializePSDescriptions Method

DefaultEcoKeyMapperBase.InitializePSDescriptions Method
DefaultEcoKeyMapperBase Class Eco.Persistence Namespace See Also
Collapse All
C#
public void InitializePSDescriptions(
    IDatabaseDefinition idb
);
Exceptions
Exceptions | Description
ArgumentNullException | Thrown if db is null
See Also
DefaultEcoKeyMapperBase Class
Eco.Persistence Namespace


DefaultEcoKeyMapperBase.InternalColumnType Method

DefaultEcoKeyMapperBase.InternalColumnType Method
DefaultEcoKeyMapperBase Class Eco.Persistence Namespace See Also
Collapse All
C#
protected string InternalColumnType(
    int columnNum
);
Remarks

This is InternalColumnType, a member of class DefaultEcoKeyMapperBase.

See Also
DefaultEcoKeyMapperBase Class
Eco.Persistence Namespace


DefaultEcoKeyMapperBase.NewIdFromAttributes Method

DefaultEcoKeyMapperBase.NewIdFromAttributes Method
DefaultEcoKeyMapperBase Class Eco.Persistence Namespace See Also
Collapse All
C#
public ObjectId NewIdFromAttributes(
    ObjectContents objContents,
    ArrayList memberIndexes,
    IdTranslationList translationList
);
Remarks

This is NewIdFromAttributes, a member of class DefaultEcoKeyMapperBase.

See Also
DefaultEcoKeyMapperBase Class
Eco.Persistence Namespace


DefaultEcoKeyMapperBase.ReserveId Method

DefaultEcoKeyMapperBase.ReserveId Method
DefaultEcoKeyMapperBase Class Eco.Persistence Namespace See Also
Collapse All
C#
public void ReserveId();
Remarks

This is ReserveId, a member of class DefaultEcoKeyMapperBase.

See Also
DefaultEcoKeyMapperBase Class
Eco.Persistence Namespace


DefaultEcoKeyMapperBase Properties

DefaultEcoKeyMapperBase Properties
Public Properties Protected Properties
Collapse All

The properties of the DefaultEcoKeyMapperBase class are listed here.

Public Properties
Name | Description
UseInternalNullKey | not used private bool m_UseInternalNullKey;
Top
Protected Properties
Name | Description
KeyMapping | This is KeyMapping, a member of class DefaultEcoKeyMapperBase.


DefaultEcoKeyMapperBase.KeyMapping Property

DefaultEcoKeyMapperBase.KeyMapping Property
DefaultEcoKeyMapperBase Class Eco.Persistence Namespace See Also
Collapse All
C#
protected abstract ISingleColumnAttributemapping KeyMapping;
Remarks

This is KeyMapping, a member of class DefaultEcoKeyMapperBase.

See Also
DefaultEcoKeyMapperBase Class
Eco.Persistence Namespace


DefaultEcoKeyMapperBase.UseInternalNullKey Property

DefaultEcoKeyMapperBase.UseInternalNullKey Property
DefaultEcoKeyMapperBase Class Eco.Persistence Namespace See Also
Collapse All
C#
public bool UseInternalNullKey;
Remarks

not used private bool m_UseInternalNullKey;

See Also
DefaultEcoKeyMapperBase Class
Eco.Persistence Namespace


DistributedTransactionManager Class

DistributedTransactionManager Class
Inheritance Hierarchy See Also
Collapse All
C#
public class DistributedTransactionManager : ITransactionManager;
Remarks

This is class Eco.Persistence.DistributedTransactionManager.

Inheritance Hierarchy
Eco.Persistence.DistributedTransactionManager
File

DistributedTransactionManager.cs

See Also
Inheritance Hierarchy


DistributedTransactionManager.DistributedTransactionManager Constructor

DistributedTransactionManager.DistributedTransactionManager Constructor
DistributedTransactionManager Class Eco.Persistence Namespace See Also
Collapse All
C#
public DistributedTransactionManager();
Remarks

This is DistributedTransactionManager, a member of class DistributedTransactionManager.

See Also
DistributedTransactionManager Class
Eco.Persistence Namespace


EcoCantGetNewObjectIdException Class

EcoCantGetNewObjectIdException Class
Inheritance Hierarchy See Also
Collapse All
C#
public class EcoCantGetNewObjectIdException : EcoException;
Remarks

This is class Eco.Persistence.EcoCantGetNewObjectIdException.

Inheritance Hierarchy
Eco.Persistence.EcoCantGetNewObjectIdException
File

IKeyMapper.cs

See Also
Inheritance Hierarchy


EcoCantGetNewObjectIdException Constructor

EcoCantGetNewObjectIdException Constructor

This is the overview for the EcoCantGetNewObjectIdException constructor overload.

Overload List
Name | Description
EcoCantGetNewObjectIdException.EcoCantGetNewObjectIdException () | This is EcoCantGetNewObjectIdException, a member of class EcoCantGetNewObjectIdException.
EcoCantGetNewObjectIdException.EcoCantGetNewObjectIdException (string) | This is EcoCantGetNewObjectIdException, a member of class EcoCantGetNewObjectIdException.
EcoCantGetNewObjectIdException.EcoCantGetNewObjectIdException (string, Exception) | This is EcoCantGetNewObjectIdException, a member of class EcoCantGetNewObjectIdException.


EcoCantGetNewObjectIdException.EcoCantGetNewObjectIdException Constructor ()

EcoCantGetNewObjectIdException.EcoCantGetNewObjectIdException Constructor ()
EcoCantGetNewObjectIdException Class Eco.Persistence Namespace See Also
Collapse All
C#
public EcoCantGetNewObjectIdException();
Remarks

This is EcoCantGetNewObjectIdException, a member of class EcoCantGetNewObjectIdException.

See Also
EcoCantGetNewObjectIdException Class
Eco.Persistence Namespace


EcoCantGetNewObjectIdException.EcoCantGetNewObjectIdException Constructor (string)

EcoCantGetNewObjectIdException.EcoCantGetNewObjectIdException Constructor (string)
EcoCantGetNewObjectIdException Class Eco.Persistence Namespace See Also
Collapse All
C#
public EcoCantGetNewObjectIdException(
    string message
);
Remarks

This is EcoCantGetNewObjectIdException, a member of class EcoCantGetNewObjectIdException.

See Also
EcoCantGetNewObjectIdException Class
Eco.Persistence Namespace


EcoCantGetNewObjectIdException.EcoCantGetNewObjectIdException Constructor (string, Exception)

EcoCantGetNewObjectIdException.EcoCantGetNewObjectIdException Constructor (string, Exception)
EcoCantGetNewObjectIdException Class Eco.Persistence Namespace See Also
Collapse All
C#
public EcoCantGetNewObjectIdException(
    string message,
    Exception innerException
);
Remarks

This is EcoCantGetNewObjectIdException, a member of class EcoCantGetNewObjectIdException.

See Also
EcoCantGetNewObjectIdException Class
Eco.Persistence Namespace


FormerNamesHandler Class

FormerNamesHandler Class
Inheritance Hierarchy See Also
Collapse All
C#
public sealed class FormerNamesHandler;
Remarks

This is class Eco.Persistence.FormerNamesHandler.

Inheritance Hierarchy
Eco.Persistence.FormerNamesHandler
File

PersistenceMapperInterfaces.cs

See Also
Inheritance Hierarchy


FormerNamesHandler Methods

FormerNamesHandler Methods
Public Methods
Collapse All

The methods of the FormerNamesHandler class are listed here.

Public Methods
Name | Description
AddFormerClassName | This is AddFormerClassName, a member of class FormerNamesHandler.
AddFormerMemberName | This is AddFormerMemberName, a member of class FormerNamesHandler.
FormerClassNames | This is FormerClassNames, a member of class FormerNamesHandler.
FormerMemberNames | This is FormerMemberNames, a member of class FormerNamesHandler.


FormerNamesHandler.AddFormerClassName Method

FormerNamesHandler.AddFormerClassName Method
FormerNamesHandler Class Eco.Persistence Namespace See Also
Collapse All
C#
public void AddFormerClassName(
    string className,
    string formerName
);
Remarks

This is AddFormerClassName, a member of class FormerNamesHandler.

See Also
FormerNamesHandler Class
Eco.Persistence Namespace


FormerNamesHandler.AddFormerMemberName Method

FormerNamesHandler.AddFormerMemberName Method
FormerNamesHandler Class Eco.Persistence Namespace See Also
Collapse All
C#
public void AddFormerMemberName(
    string className,
    string memberName,
    string formerName
);
Remarks

This is AddFormerMemberName, a member of class FormerNamesHandler.

See Also
FormerNamesHandler Class
Eco.Persistence Namespace


FormerNamesHandler.FormerClassNames Method

FormerNamesHandler.FormerClassNames Method
FormerNamesHandler Class Eco.Persistence Namespace See Also
Collapse All
C#
public IList<string> FormerClassNames(
    string className
);
Remarks

This is FormerClassNames, a member of class FormerNamesHandler.

See Also
FormerNamesHandler Class
Eco.Persistence Namespace


FormerNamesHandler.FormerMemberNames Method

FormerNamesHandler.FormerMemberNames Method
FormerNamesHandler Class Eco.Persistence Namespace See Also
Collapse All
C#
public IList<string> FormerMemberNames(
    string className,
    string memberName
);
Remarks

This is FormerMemberNames, a member of class FormerNamesHandler.

See Also
FormerNamesHandler Class
Eco.Persistence Namespace


GenericKeyMapper Class

GenericKeyMapper Class
Inheritance Hierarchy See Also
Collapse All

This class is suitable for subclassing if you intend to implement the IKeyMapper interface

C#
public abstract class GenericKeyMapper : System.Object;
Inheritance Hierarchy
Eco.Persistence.GenericKeyMapper
    Eco.Persistence.AbstractAutoGuidKeyMapper
    Eco.Persistence.AbstractAutoIncKeyMapper
    Eco.Persistence.AttributeKeyMapper
    Eco.Persistence.DefaultEcoKeyMapperBase
    Eco.Persistence.GuidKeyMapper
File

GenericKeyMapper.cs

See Also
Inheritance Hierarchy


GenericKeyMapper Methods

GenericKeyMapper Methods
Protected Methods Public Methods
Collapse All

The methods of the GenericKeyMapper class are listed here.

Protected Methods
Name | Description
InternalIdListToWhereFragment |
InternalInitialize |
Top
Public Methods
Name | Description
GetKeyMapper | This is GetKeyMapper, a member of class GenericKeyMapper.
IdListToWhereFragment | This is the overview for the IdListToWhereFragment method overload.
IdToWhereFragment | This is the overview for the IdToWhereFragment method overload.


GenericKeyMapper.GetKeyMapper Method

GenericKeyMapper.GetKeyMapper Method
GenericKeyMapper Class Eco.Persistence Namespace See Also
Collapse All
C#
public ISingleColumnAttributemapping GetKeyMapper(
    int index
);
Remarks

This is GetKeyMapper, a member of class GenericKeyMapper.

See Also
GenericKeyMapper Class
Eco.Persistence Namespace


IdListToWhereFragment Method

IdListToWhereFragment Method

This is the overview for the IdListToWhereFragment method overload.

Overload List
Name | Description
GenericKeyMapper.IdListToWhereFragment (ObjectIdCollection, IParameterized, IList<string>) | See documentation for IKeyMapper.IdListToWhereFragment(ObjectIdCollection, IParameterized, IList{string}, string)
GenericKeyMapper.IdListToWhereFragment (ObjectIdCollection, IParameterized, IList<string>, string) | This is IdListToWhereFragment, a member of class GenericKeyMapper.


GenericKeyMapper.IdListToWhereFragment Method (ObjectIdCollection, IParameterized, IList<string>)

GenericKeyMapper.IdListToWhereFragment Method (ObjectIdCollection, IParameterized, IList<string>)
GenericKeyMapper Class Eco.Persistence Namespace See Also
Collapse All

See documentation for IKeyMapper.IdListToWhereFragment(ObjectIdCollection, IParameterized, IList{string}, string)

C#
public string IdListToWhereFragment(
    ObjectIdCollection idList,
    IParameterized parameterized,
    IList<string> idColumns
);
See Also
GenericKeyMapper Class
Eco.Persistence Namespace


GenericKeyMapper.IdListToWhereFragment Method (ObjectIdCollection, IParameterized, IList<string>, string)

GenericKeyMapper.IdListToWhereFragment Method (ObjectIdCollection, IParameterized, IList<string>, string)
GenericKeyMapper Class Eco.Persistence Namespace See Also
Collapse All
C#
public abstract string IdListToWhereFragment(
    ObjectIdCollection idList,
    IParameterized parameterized,
    IList<string> idColumns,
    string idPrefix
);
Remarks

This is IdListToWhereFragment, a member of class GenericKeyMapper.

See Also
GenericKeyMapper Class
Eco.Persistence Namespace


IdToWhereFragment Method

IdToWhereFragment Method

This is the overview for the IdToWhereFragment method overload.

Overload List
Name | Description
GenericKeyMapper.IdToWhereFragment (ObjectId, IParameterized, IList<string>) | See documentation for IKeyMapper.IdToWhereFragment(ObjectId, IParameterized, IList{string}, string)
GenericKeyMapper.IdToWhereFragment (ObjectId, IParameterized, IList<string>, string) | This is IdToWhereFragment, a member of class GenericKeyMapper.


GenericKeyMapper.IdToWhereFragment Method (ObjectId, IParameterized, IList<string>)

GenericKeyMapper.IdToWhereFragment Method (ObjectId, IParameterized, IList<string>)
GenericKeyMapper Class Eco.Persistence Namespace See Also
Collapse All

See documentation for IKeyMapper.IdToWhereFragment(ObjectId, IParameterized, IList{string}, string)

C#
public string IdToWhereFragment(
    ObjectId id,
    IParameterized parameterized,
    IList<string> idColumns
);
See Also
GenericKeyMapper Class
Eco.Persistence Namespace


GenericKeyMapper.IdToWhereFragment Method (ObjectId, IParameterized, IList<string>, string)

GenericKeyMapper.IdToWhereFragment Method (ObjectId, IParameterized, IList<string>, string)
GenericKeyMapper Class Eco.Persistence Namespace See Also
Collapse All
C#
public string IdToWhereFragment(
    ObjectId id,
    IParameterized parameterized,
    IList<string> idColumns,
    string idPrefix
);
Remarks

This is IdToWhereFragment, a member of class GenericKeyMapper.

See Also
GenericKeyMapper Class
Eco.Persistence Namespace


GenericKeyMapper.InternalIdListToWhereFragment Method

GenericKeyMapper.InternalIdListToWhereFragment Method
GenericKeyMapper Class Eco.Persistence Namespace See Also
Collapse All
C#
protected string InternalIdListToWhereFragment(
    ObjectIdCollection idList,
    IParameterized parameterized,
    IList<string> idColumns,
    ISingleColumnAttributemapping mapper,
    string idPrefix
);
Exceptions
Exceptions | Description
ArgumentNullException | Thrown if idList is null Thrown if idColumns is null
See Also
GenericKeyMapper Class
Eco.Persistence Namespace


GenericKeyMapper.InternalInitialize Method

GenericKeyMapper.InternalInitialize Method
GenericKeyMapper Class Eco.Persistence Namespace See Also
Collapse All
C#
protected virtual void InternalInitialize(
    SqlDatabaseConfig sqlDatabaseConfig,
    ArrayList keyMappers
);
Exceptions
Exceptions | Description
ArgumentNullException | Thrown if sqlDatabaseConfig is null
See Also
GenericKeyMapper Class
Eco.Persistence Namespace


GenericKeyMapper Properties

GenericKeyMapper Properties
Public Properties
Collapse All

The properties of the GenericKeyMapper class are listed here.

Public Properties
Name | Description
Int32Mapper | This is Int32Mapper, a member of class GenericKeyMapper.
KeyMappers | This is KeyMappers, a member of class GenericKeyMapper.
MapperDictionary | This is MapperDictionary, a member of class GenericKeyMapper.
SqlDatabaseConfig | This is SqlDatabaseConfig, a member of class GenericKeyMapper.


GenericKeyMapper.Int32Mapper Property

GenericKeyMapper.Int32Mapper Property
GenericKeyMapper Class Eco.Persistence Namespace See Also
Collapse All
C#
public ISingleColumnAttributemapping Int32Mapper;
Remarks

This is Int32Mapper, a member of class GenericKeyMapper.

See Also
GenericKeyMapper Class
Eco.Persistence Namespace


GenericKeyMapper.KeyMappers Property

GenericKeyMapper.KeyMappers Property
GenericKeyMapper Class Eco.Persistence Namespace See Also
Collapse All
C#
public ArrayList KeyMappers;
Remarks

This is KeyMappers, a member of class GenericKeyMapper.

See Also
GenericKeyMapper Class
Eco.Persistence Namespace


GenericKeyMapper.MapperDictionary Property

GenericKeyMapper.MapperDictionary Property
GenericKeyMapper Class Eco.Persistence Namespace See Also
Collapse All
C#
public PersistenceMapperDictionary MapperDictionary;
Remarks

This is MapperDictionary, a member of class GenericKeyMapper.

See Also
GenericKeyMapper Class
Eco.Persistence Namespace


GenericKeyMapper.SqlDatabaseConfig Property

GenericKeyMapper.SqlDatabaseConfig Property
GenericKeyMapper Class Eco.Persistence Namespace See Also
Collapse All
C#
public SqlDatabaseConfig SqlDatabaseConfig;
Remarks

This is SqlDatabaseConfig, a member of class GenericKeyMapper.

See Also
GenericKeyMapper Class
Eco.Persistence Namespace


GuidKeyMapper Class

GuidKeyMapper Class
Inheritance Hierarchy See Also
Collapse All
C#
public class GuidKeyMapper : GenericKeyMapper, IKeyMapper;
Remarks

This is class Eco.Persistence.GuidKeyMapper.

Inheritance Hierarchy
Eco.Persistence.GenericKeyMapper
Eco.Persistence.IKeyMapper
    Eco.Persistence.GuidKeyMapper
File

GuidKeyMapper.cs

See Also
Inheritance Hierarchy


GuidKeyMapper.GuidKeyMapper Constructor

GuidKeyMapper.GuidKeyMapper Constructor
GuidKeyMapper Class Eco.Persistence Namespace See Also
Collapse All
C#
public GuidKeyMapper();
Remarks

This is GuidKeyMapper, a member of class GuidKeyMapper.

See Also
GuidKeyMapper Class
Eco.Persistence Namespace


GuidKeyMapper Methods

GuidKeyMapper Methods
Public Methods
Collapse All

The methods of the GuidKeyMapper class are listed here.

Public Methods
Name | Description
ColumnCount | Returns the number of columns that are used to store the id
ColumnType | Returns the sql type for the respective column.
GetIdAllocationMode | Indicates the strategy used by the key mapper.
IdFromFields | This method creates a new id based on the values of the field objects
IdListToWhereFragment | This is IdListToWhereFragment, a member of class GuidKeyMapper.
IdToParameters | This method fills the parameter objects with data from an id
Initialize | This method is called after the key mapper has been created to initialize the keymapper with some basic configuration.
InitializeDatabase | This method may perform initialization of the database such as installing generators for autoinc mechanisms.
InitializeDatabaseScript | Same as InitializeDatabase, but rather than operating directly on the database, the initializations should be returned as sql statements to be used in a script.
InitializePSDescriptions | This method can add additional tables/columns if the keymapper requires any additional structure in the database schema. It is called once per session.
NewIdFromAttributes | This method is called once for each object before it is updated (if IdAllocationMode = FromAttributes).
NewIdPreUpdate |
ReserveId | This method is called once for each object before objects are updated (if IdAllocationMode = PreUpdate and allows the keymapper to prepare for the number of IDs that needs to be allocated


GuidKeyMapper.ColumnCount Method

GuidKeyMapper.ColumnCount Method
GuidKeyMapper Class Eco.Persistence Namespace See Also
Collapse All

Returns the number of columns that are used to store the id

C#
public int ColumnCount();
See Also
GuidKeyMapper Class
Eco.Persistence Namespace


GuidKeyMapper.ColumnType Method

GuidKeyMapper.ColumnType Method
GuidKeyMapper Class Eco.Persistence Namespace See Also
Collapse All

Returns the sql type for the respective column.

C#
public string ColumnType(
    ArrayList KeyMappers,
    int columnNum
);
See Also
GuidKeyMapper Class
Eco.Persistence Namespace


GuidKeyMapper.GetIdAllocationMode Method

GuidKeyMapper.GetIdAllocationMode Method
GuidKeyMapper Class Eco.Persistence Namespace See Also
Collapse All

Indicates the strategy used by the key mapper.

C#
public IdAllocationMode GetIdAllocationMode();
Remarks

FromAttributes means that the key mapper will extract the key values from the contents of the object. PreUpdate means that the id values can be allocated prior to updating the object (used by the default eco key mapper and the guid-mapper). PostUpdate means that the id values can only be obtained after the object has been inserted to the database (used by autoinc mapper).

See Also
GuidKeyMapper Class
Eco.Persistence Namespace


GuidKeyMapper.IdFromFields Method

GuidKeyMapper.IdFromFields Method
GuidKeyMapper Class Eco.Persistence Namespace See Also
Collapse All

This method creates a new id based on the values of the field objects

C#
public ObjectId IdFromFields(
    IField[] keyFields,
    ArrayList keyMappers,
    int classId,
    int timeStamp
);
See Also
GuidKeyMapper Class
Eco.Persistence Namespace


GuidKeyMapper.IdListToWhereFragment Method

GuidKeyMapper.IdListToWhereFragment Method
GuidKeyMapper Class Eco.Persistence Namespace See Also
Collapse All
C#
public override string IdListToWhereFragment(
    ObjectIdCollection idList,
    IParameterized parameterized,
    IList<string> idColumns,
    string idPrefix
);
Remarks

This is IdListToWhereFragment, a member of class GuidKeyMapper.

See Also
GuidKeyMapper Class
Eco.Persistence Namespace


GuidKeyMapper.IdToParameters Method

GuidKeyMapper.IdToParameters Method
GuidKeyMapper Class Eco.Persistence Namespace See Also
Collapse All

This method fills the parameter objects with data from an id

C#
public void IdToParameters(
    ObjectId id,
    IDataParameter[] parameters
);
See Also
GuidKeyMapper Class
Eco.Persistence Namespace


GuidKeyMapper.Initialize Method

GuidKeyMapper.Initialize Method
GuidKeyMapper Class Eco.Persistence Namespace See Also
Collapse All

This method is called after the key mapper has been created to initialize the keymapper with some basic configuration.

C#
public void Initialize(
    SqlDatabaseConfig config,
    ArrayList keyMappers
);
See Also
GuidKeyMapper Class
Eco.Persistence Namespace


GuidKeyMapper.InitializeDatabase Method

GuidKeyMapper.InitializeDatabase Method
GuidKeyMapper Class Eco.Persistence Namespace See Also
Collapse All

This method may perform initialization of the database such as installing generators for autoinc mechanisms.

C#
public void InitializeDatabase(
    IDatabase db
);
See Also
GuidKeyMapper Class
Eco.Persistence Namespace


GuidKeyMapper.InitializeDatabaseScript Method

GuidKeyMapper.InitializeDatabaseScript Method
GuidKeyMapper Class Eco.Persistence Namespace See Also
Collapse All

Same as InitializeDatabase, but rather than operating directly on the database, the initializations should be returned as sql statements to be used in a script.

C#
public void InitializeDatabaseScript(
    IList<string> script
);
See Also
GuidKeyMapper Class
Eco.Persistence Namespace


GuidKeyMapper.InitializePSDescriptions Method

GuidKeyMapper.InitializePSDescriptions Method
GuidKeyMapper Class Eco.Persistence Namespace See Also
Collapse All

This method can add additional tables/columns if the keymapper requires any additional structure in the database schema. It is called once per session.

C#
public void InitializePSDescriptions(
    IDatabaseDefinition db
);
See Also
GuidKeyMapper Class
Eco.Persistence Namespace


GuidKeyMapper.NewIdFromAttributes Method

GuidKeyMapper.NewIdFromAttributes Method
GuidKeyMapper Class Eco.Persistence Namespace See Also
Collapse All

This method is called once for each object before it is updated (if IdAllocationMode = FromAttributes).

C#
public ObjectId NewIdFromAttributes(
    ObjectContents objContents,
    ArrayList memberIndexes,
    IdTranslationList translationList
);
Parameters
Parameters | Description
objContents | The object that needs an id
memberIndexes | An arraylist of MemberIndexColumnIndex objects
translationList | If the new Id contains any information from relations to other objects, it is important that those ids are translated using the translationlist before the related object ids are used
See Also
GuidKeyMapper Class
Eco.Persistence Namespace


GuidKeyMapper.NewIdPreUpdate Method

GuidKeyMapper.NewIdPreUpdate Method
GuidKeyMapper Class Eco.Persistence Namespace See Also
Collapse All
C#
public ObjectId NewIdPreUpdate(
    IDatabase db,
    ObjectId oldId
);
Exceptions
Exceptions | Description
ArgumentNullException | Thrown if oldId is null
See Also
GuidKeyMapper Class
Eco.Persistence Namespace


GuidKeyMapper.ReserveId Method

GuidKeyMapper.ReserveId Method
GuidKeyMapper Class Eco.Persistence Namespace See Also
Collapse All

This method is called once for each object before objects are updated (if IdAllocationMode = PreUpdate and allows the keymapper to prepare for the number of IDs that needs to be allocated

C#
public void ReserveId();
See Also
GuidKeyMapper Class
Eco.Persistence Namespace


LocalTransactionManager Class

LocalTransactionManager Class
Inheritance Hierarchy See Also
Collapse All
C#
public class LocalTransactionManager : ITransactionManager;
Remarks

This is class Eco.Persistence.LocalTransactionManager.

Inheritance Hierarchy
Eco.Persistence.LocalTransactionManager
File

LocalTransactionManager.cs

See Also
Inheritance Hierarchy


MemberIndexColumnIndex Class

MemberIndexColumnIndex Class
Inheritance Hierarchy See Also
Collapse All

Support class used to pass member index and column index to a key mapper

C#
public class MemberIndexColumnIndex;
Inheritance Hierarchy
Eco.Persistence.MemberIndexColumnIndex
File

MemberIndexColumnIndex.cs

See Also
Inheritance Hierarchy


MemberIndexColumnIndex.MemberIndexColumnIndex Constructor

MemberIndexColumnIndex.MemberIndexColumnIndex Constructor
MemberIndexColumnIndex Class Eco.Persistence Namespace See Also
Collapse All
C#
public MemberIndexColumnIndex(
    int memberIndex,
    int columnIndex,
    bool isOrderColumn
);
Remarks

This is MemberIndexColumnIndex, a member of class MemberIndexColumnIndex.

See Also
MemberIndexColumnIndex Class
Eco.Persistence Namespace


MemberIndexColumnIndex Properties

MemberIndexColumnIndex Properties
Public Properties
Collapse All

The properties of the MemberIndexColumnIndex class are listed here.

Public Properties
Name | Description
ColumnIndex | This is ColumnIndex, a member of class MemberIndexColumnIndex.
IsOrderColumn | This is IsOrderColumn, a member of class MemberIndexColumnIndex.
MemberIndex | This is MemberIndex, a member of class MemberIndexColumnIndex.


MemberIndexColumnIndex.ColumnIndex Property

MemberIndexColumnIndex.ColumnIndex Property
MemberIndexColumnIndex Class Eco.Persistence Namespace See Also
Collapse All
C#
public int ColumnIndex;
Remarks

This is ColumnIndex, a member of class MemberIndexColumnIndex.

See Also
MemberIndexColumnIndex Class
Eco.Persistence Namespace


MemberIndexColumnIndex.IsOrderColumn Property

MemberIndexColumnIndex.IsOrderColumn Property
MemberIndexColumnIndex Class Eco.Persistence Namespace See Also
Collapse All
C#
public bool IsOrderColumn;
Remarks

This is IsOrderColumn, a member of class MemberIndexColumnIndex.

See Also
MemberIndexColumnIndex Class
Eco.Persistence Namespace


MemberIndexColumnIndex.MemberIndex Property

MemberIndexColumnIndex.MemberIndex Property
MemberIndexColumnIndex Class Eco.Persistence Namespace See Also
Collapse All
C#
public int MemberIndex;
Remarks

This is MemberIndex, a member of class MemberIndexColumnIndex.

See Also
MemberIndexColumnIndex Class
Eco.Persistence Namespace


OclCondition Class

OclCondition Class
Inheritance Hierarchy See Also
Collapse All
C#
public abstract class OclCondition : AbstractCondition;
Remarks

This is class Eco.Persistence.OclCondition.

Inheritance Hierarchy
Eco.Persistence.AbstractCondition
    Eco.Persistence.OclCondition
File

PersistenceMapperInterfaces.cs

See Also
Inheritance Hierarchy


OclCondition.OclCondition Constructor

OclCondition.OclCondition Constructor
OclCondition Class Eco.Persistence Namespace See Also
Collapse All
C#
public OclCondition(
    int classId,
    string expression
);
Remarks

This is OclCondition, a member of class OclCondition.

See Also
OclCondition Class
Eco.Persistence Namespace


OclCondition Interfaces

OclCondition Interfaces
Interfaces
Collapse All

The interfaces of the OclCondition class are listed here.

Interfaces
Name | Description
IExternalVariable | This is class Eco.Persistence.OclCondition.IExternalVariable.


OclCondition.IExternalVariable Interface

OclCondition.IExternalVariable Interface
Inheritance Hierarchy See Also
Collapse All
C#
public interface IExternalVariable;
Remarks

This is class Eco.Persistence.OclCondition.IExternalVariable.

Inheritance Hierarchy
Eco.Persistence.OclCondition.IExternalVariable
File

PersistenceMapperInterfaces.cs

See Also
Inheritance Hierarchy


IExternalVariable Properties

IExternalVariable Properties
Public Properties
Collapse All

The properties of the IExternalVariable class are listed here.

Public Properties
Name | Description
ClassId | This is ClassId, a member of class IExternalVariable.
ClassifierName | This is ClassifierName, a member of class IExternalVariable.
Name | This is Name, a member of class IExternalVariable.
Value | This is Value, a member of class IExternalVariable.


OclCondition.IExternalVariable.ClassId Property

OclCondition.IExternalVariable.ClassId Property
OclCondition.IExternalVariable Interface Eco.Persistence Namespace See Also
Collapse All
C#
int ClassId;
Remarks

This is ClassId, a member of class IExternalVariable.

See Also
OclCondition.IExternalVariable Interface
Eco.Persistence Namespace


OclCondition.IExternalVariable.ClassifierName Property

OclCondition.IExternalVariable.ClassifierName Property
OclCondition.IExternalVariable Interface Eco.Persistence Namespace See Also
Collapse All
C#
string ClassifierName;
Remarks

This is ClassifierName, a member of class IExternalVariable.

See Also
OclCondition.IExternalVariable Interface
Eco.Persistence Namespace


OclCondition.IExternalVariable.Name Property

OclCondition.IExternalVariable.Name Property
OclCondition.IExternalVariable Interface Eco.Persistence Namespace See Also
Collapse All
C#
string Name;
Remarks

This is Name, a member of class IExternalVariable.

See Also
OclCondition.IExternalVariable Interface
Eco.Persistence Namespace


OclCondition.IExternalVariable.Value Property

OclCondition.IExternalVariable.Value Property
OclCondition.IExternalVariable Interface Eco.Persistence Namespace See Also
Collapse All
C#
object Value;
Remarks

This is Value, a member of class IExternalVariable.

See Also
OclCondition.IExternalVariable Interface
Eco.Persistence Namespace


OclCondition Methods

OclCondition Methods
Public Methods
Collapse All

The methods of the OclCondition class are listed here.

Public Methods
Name | Description
GetExternalVariable | This is GetExternalVariable, a member of class OclCondition.


OclCondition.GetExternalVariable Method

OclCondition.GetExternalVariable Method
OclCondition Class Eco.Persistence Namespace See Also
Collapse All
C#
public abstract IExternalVariable GetExternalVariable(
    int index
);
Remarks

This is GetExternalVariable, a member of class OclCondition.

See Also
OclCondition Class
Eco.Persistence Namespace


OclCondition Properties

OclCondition Properties
Public Properties
Collapse All

The properties of the OclCondition class are listed here.

Public Properties
Name | Description
Context | This is Context, a member of class OclCondition.
Expression | This is Expression, a member of class OclCondition.
ExternalVariableCount | This is ExternalVariableCount, a member of class OclCondition.


OclCondition.Context Property

OclCondition.Context Property
OclCondition Class Eco.Persistence Namespace See Also
Collapse All
C#
public ObjectIdList Context;
Remarks

This is Context, a member of class OclCondition.

See Also
OclCondition Class
Eco.Persistence Namespace


OclCondition.Expression Property

OclCondition.Expression Property
OclCondition Class Eco.Persistence Namespace See Also
Collapse All
C#
public string Expression;
Remarks

This is Expression, a member of class OclCondition.

See Also
OclCondition Class
Eco.Persistence Namespace


OclCondition.ExternalVariableCount Property

OclCondition.ExternalVariableCount Property
OclCondition Class Eco.Persistence Namespace See Also
Collapse All
C#
public abstract int ExternalVariableCount;
Remarks

This is ExternalVariableCount, a member of class OclCondition.

See Also
OclCondition Class
Eco.Persistence Namespace


OkResult Class

OkResult Class
Inheritance Hierarchy See Also
Collapse All
C#
public sealed class OkResult : UpdateResult;
Remarks

This is class Eco.Persistence.OkResult.

Inheritance Hierarchy
Eco.Persistence.UpdateResult
    Eco.Persistence.OkResult
File

PersistenceMapperInterfaces.cs

See Also
Inheritance Hierarchy


OkResult Properties

OkResult Properties
Public Properties
Collapse All

The properties of the OkResult class are listed here.

Public Properties
Name | Description
Failed | This is Failed, a member of class OkResult.
FailureReason | This is FailureReason, a member of class OkResult.


OkResult.Failed Property

OkResult.Failed Property
OkResult Class Eco.Persistence Namespace See Also
Collapse All
C#
public override bool Failed;
Remarks

This is Failed, a member of class OkResult.

See Also
OkResult Class
Eco.Persistence Namespace


OkResult.FailureReason Property

OkResult.FailureReason Property
OkResult Class Eco.Persistence Namespace See Also
Collapse All
C#
public override string FailureReason;
Remarks

This is FailureReason, a member of class OkResult.

See Also
OkResult Class
Eco.Persistence Namespace


OptimisticLockingPrecondition Class

OptimisticLockingPrecondition Class
Inheritance Hierarchy See Also
Collapse All
C#
public sealed class OptimisticLockingPrecondition : UpdatePrecondition;
Remarks

This is class Eco.Persistence.OptimisticLockingPrecondition.

Inheritance Hierarchy
Eco.Persistence.UpdatePrecondition
    Eco.Persistence.OptimisticLockingPrecondition
File

PersistenceMapperInterfaces.cs

See Also
Inheritance Hierarchy


OptimisticLockingPrecondition Properties

OptimisticLockingPrecondition Properties
Public Properties
Collapse All

The properties of the OptimisticLockingPrecondition class are listed here.

Public Properties
Name | Description
Datablock | This is Datablock, a member of class OptimisticLockingPrecondition.
HasOptimisticLocks | This is HasOptimisticLocks, a member of class OptimisticLockingPrecondition.


OptimisticLockingPrecondition.Datablock Property

OptimisticLockingPrecondition.Datablock Property
OptimisticLockingPrecondition Class Eco.Persistence Namespace See Also
Collapse All
C#
public Datablock Datablock;
Remarks

This is Datablock, a member of class OptimisticLockingPrecondition.

See Also
OptimisticLockingPrecondition Class
Eco.Persistence Namespace


OptimisticLockingPrecondition.HasOptimisticLocks Property

OptimisticLockingPrecondition.HasOptimisticLocks Property
OptimisticLockingPrecondition Class Eco.Persistence Namespace See Also
Collapse All
C#
public bool HasOptimisticLocks;
Remarks

This is HasOptimisticLocks, a member of class OptimisticLockingPrecondition.

See Also
OptimisticLockingPrecondition Class
Eco.Persistence Namespace


OptimisticLockingResult Class

OptimisticLockingResult Class
Inheritance Hierarchy See Also
Collapse All
C#
public sealed class OptimisticLockingResult : UpdateResult;
Remarks

This is class Eco.Persistence.OptimisticLockingResult.

Inheritance Hierarchy
Eco.Persistence.UpdateResult
    Eco.Persistence.OptimisticLockingResult
File

PersistenceMapperInterfaces.cs

See Also
Inheritance Hierarchy


OptimisticLockingResult Properties

OptimisticLockingResult Properties
Public Properties
Collapse All

The properties of the OptimisticLockingResult class are listed here.

Public Properties
Name | Description
Conflicts | This is Conflicts, a member of class OptimisticLockingResult.
Failed | This is Failed, a member of class OptimisticLockingResult.
FailureReason | This is FailureReason, a member of class OptimisticLockingResult.


OptimisticLockingResult.Conflicts Property

OptimisticLockingResult.Conflicts Property
OptimisticLockingResult Class Eco.Persistence Namespace See Also
Collapse All
C#
public Datablock Conflicts;
Remarks

This is Conflicts, a member of class OptimisticLockingResult.

See Also
OptimisticLockingResult Class
Eco.Persistence Namespace


OptimisticLockingResult.Failed Property

OptimisticLockingResult.Failed Property
OptimisticLockingResult Class Eco.Persistence Namespace See Also
Collapse All
C#
public override bool Failed;
Remarks

This is Failed, a member of class OptimisticLockingResult.

See Also
OptimisticLockingResult Class
Eco.Persistence Namespace


OptimisticLockingResult.FailureReason Property

OptimisticLockingResult.FailureReason Property
OptimisticLockingResult Class Eco.Persistence Namespace See Also
Collapse All
C#
public override string FailureReason;
Remarks

This is FailureReason, a member of class OptimisticLockingResult.

See Also
OptimisticLockingResult Class
Eco.Persistence Namespace


PersistenceMapper Class

PersistenceMapper Class
Inheritance Hierarchy See Also
Collapse All
C#
public abstract class PersistenceMapper : System.ComponentModel.Component, IPersistencemapperProvider;
Remarks

This is class Eco.Persistence.PersistenceMapper.

Inheritance Hierarchy
Eco.Persistence.IPersistencemapperProvider
    Eco.Persistence.PersistenceMapper
        Eco.Persistence.AbstractDataBlockPersistenceMapper
        Eco.Persistence.AbstractPersistenceMapperDb
        Eco.Persistence.ChainedPersistenceMapperBase
        Eco.Persistence.PersistenceMapperSharer
        Eco.Persistence.Remoting.PersistenceMapperClient
File

PersistenceMapper.cs

See Also
Inheritance Hierarchy


PersistenceMapper Methods

PersistenceMapper Methods
Public Methods
Collapse All

The methods of the PersistenceMapper class are listed here.

Public Methods
Name | Description
GetPersistenceMapper | This is GetPersistenceMapper, a member of class PersistenceMapper.
ReturnPersistenceMapper | This is ReturnPersistenceMapper, a member of class PersistenceMapper.


PersistenceMapper.GetPersistenceMapper Method

PersistenceMapper.GetPersistenceMapper Method
PersistenceMapper Class Eco.Persistence Namespace See Also
Collapse All
C#
public abstract IPersistenceMapper GetPersistenceMapper(
    ITypeSystemService typeSystemService
);
Remarks

This is GetPersistenceMapper, a member of class PersistenceMapper.

See Also
PersistenceMapper Class
Eco.Persistence Namespace


PersistenceMapper.ReturnPersistenceMapper Method

PersistenceMapper.ReturnPersistenceMapper Method
PersistenceMapper Class Eco.Persistence Namespace See Also
Collapse All
C#
public abstract void ReturnPersistenceMapper(
    IPersistenceMapper persistenceMapper
);
Remarks

This is ReturnPersistenceMapper, a member of class PersistenceMapper.

See Also
PersistenceMapper Class
Eco.Persistence Namespace


PersistenceMapperAdo2 Class

PersistenceMapperAdo2 Class
Inheritance Hierarchy See Also
Collapse All
C#
public abstract class PersistenceMapperAdo2 : PersistenceMapperDb, IAutoHookable;
Inheritance Hierarchy
Eco.Persistence.IPersistencemapperProvider
    Eco.Persistence.PersistenceMapper
        Eco.Persistence.AbstractPersistenceMapperDb
        Eco.Persistence.IPersistenceMapperDb
            Eco.Persistence.PersistenceMapperDb
            Eco.Persistence.IAutoHookable
                Eco.Persistence.PersistenceMapperAdo2
                    Eco.Persistence.AbstractPersistenceMapperBlackfish
                    Eco.Persistence.PersistenceMapperDbx
                    Eco.Persistence.PersistenceMapperFirebird
                    Eco.Persistence.PersistenceMapperMimer
                    Eco.Persistence.PersistenceMapperMySql
                    Eco.Persistence.PersistenceMapperNexusDB
                    Eco.Persistence.PersistenceMapperOracle
                    Eco.Persistence.PersistenceMapperSQLite
                    Eco.Persistence.PersistenceMapperSqlServer
File

PersistenceMapperAdo2.cs

See Also
Inheritance Hierarchy


PersistenceMapperAdo2.PersistenceMapperAdo2 Constructor

PersistenceMapperAdo2.PersistenceMapperAdo2 Constructor
PersistenceMapperAdo2 Class Eco.Persistence Namespace See Also
Collapse All
C#
public PersistenceMapperAdo2();
Remarks

This is PersistenceMapperAdo2, a member of class PersistenceMapperAdo2.

See Also
PersistenceMapperAdo2 Class
Eco.Persistence Namespace


PersistenceMapperAdo2 Methods

PersistenceMapperAdo2 Methods
Protected Methods Protected internal Methods
Collapse All

The methods of the PersistenceMapperAdo2 class are listed here.

Protected Methods
Name | Description
ConnectionType | This is ConnectionType, a member of class PersistenceMapperAdo2.
InternalCreateIDatabase | This is InternalCreateIDatabase, a member of class PersistenceMapperAdo2.
Top
Protected internal Methods
Name | Description
MakeDatabase |
ReturnDatabase |


PersistenceMapperAdo2.ConnectionType Method

PersistenceMapperAdo2.ConnectionType Method
PersistenceMapperAdo2 Class Eco.Persistence Namespace See Also
Collapse All
C#
protected abstract Type ConnectionType();
Remarks

This is ConnectionType, a member of class PersistenceMapperAdo2.

See Also
PersistenceMapperAdo2 Class
Eco.Persistence Namespace


PersistenceMapperAdo2.InternalCreateIDatabase Method

PersistenceMapperAdo2.InternalCreateIDatabase Method
PersistenceMapperAdo2 Class Eco.Persistence Namespace See Also
Collapse All
C#
protected abstract IDatabase InternalCreateIDatabase(
    DbConnection connection,
    SqlDatabaseConfig config
);
Remarks

This is InternalCreateIDatabase, a member of class PersistenceMapperAdo2.

See Also
PersistenceMapperAdo2 Class
Eco.Persistence Namespace


PersistenceMapperAdo2.MakeDatabase Method

PersistenceMapperAdo2.MakeDatabase Method
PersistenceMapperAdo2 Class Eco.Persistence Namespace See Also
Collapse All
C#
protected internal override IDatabase MakeDatabase();
Exceptions
Exceptions | Description
InvalidOperationException | Thrown if Connection is null.
See Also
PersistenceMapperAdo2 Class
Eco.Persistence Namespace


PersistenceMapperAdo2.ReturnDatabase Method

PersistenceMapperAdo2.ReturnDatabase Method
PersistenceMapperAdo2 Class Eco.Persistence Namespace See Also
Collapse All
C#
protected internal override void ReturnDatabase(
    IDatabase database
);
Exceptions
Exceptions | Description
ArgumentNullException | Thrown if database is null
See Also
PersistenceMapperAdo2 Class
Eco.Persistence Namespace


PersistenceMapperAdo2 Properties

PersistenceMapperAdo2 Properties
Public Properties Protected Properties
Collapse All

The properties of the PersistenceMapperAdo2 class are listed here.

Public Properties
Name | Description
ConnectionString | This is ConnectionString, a member of class PersistenceMapperAdo2.
HasConnection | Returns true if the connection-property is set.
Top
Protected Properties
Name | Description
DbConnection | This is DbConnection, a member of class PersistenceMapperAdo2.
EffectiveConnection | This is EffectiveConnection, a member of class PersistenceMapperAdo2.


PersistenceMapperAdo2.ConnectionString Property

PersistenceMapperAdo2.ConnectionString Property
PersistenceMapperAdo2 Class Eco.Persistence Namespace See Also
Collapse All
C#
public virtual string ConnectionString;
Remarks

This is ConnectionString, a member of class PersistenceMapperAdo2.

See Also
PersistenceMapperAdo2 Class
Eco.Persistence Namespace


PersistenceMapperAdo2.DbConnection Property

PersistenceMapperAdo2.DbConnection Property
PersistenceMapperAdo2 Class Eco.Persistence Namespace See Also
Collapse All
C#
protected DbConnection DbConnection;
Remarks

This is DbConnection, a member of class PersistenceMapperAdo2.

See Also
PersistenceMapperAdo2 Class
Eco.Persistence Namespace


PersistenceMapperAdo2.EffectiveConnection Property

PersistenceMapperAdo2.EffectiveConnection Property
PersistenceMapperAdo2 Class Eco.Persistence Namespace See Also
Collapse All
C#
protected DbConnection EffectiveConnection;
Remarks

This is EffectiveConnection, a member of class PersistenceMapperAdo2.

See Also
PersistenceMapperAdo2 Class
Eco.Persistence Namespace


PersistenceMapperAdo2.HasConnection Property

PersistenceMapperAdo2.HasConnection Property
PersistenceMapperAdo2 Class Eco.Persistence Namespace See Also
Collapse All

Returns true if the connection-property is set.

C#
public override bool HasConnection;
See Also
PersistenceMapperAdo2 Class
Eco.Persistence Namespace


PersistenceMapperBdp Class

PersistenceMapperBdp Class
Inheritance Hierarchy See Also
Collapse All
C#
public sealed class PersistenceMapperBdp : PersistenceMapperDb, IAutoHookable;
Remarks

This is class Eco.Persistence.PersistenceMapperBdp.

Inheritance Hierarchy
Eco.Persistence.IPersistencemapperProvider
    Eco.Persistence.PersistenceMapper
        Eco.Persistence.AbstractPersistenceMapperDb
        Eco.Persistence.IPersistenceMapperDb
            Eco.Persistence.PersistenceMapperDb
            Eco.Persistence.IAutoHookable
                Eco.Persistence.PersistenceMapperBdp
File

PersistenceMapperBdp.cs

See Also
Inheritance Hierarchy


PersistenceMapperBdp Methods

PersistenceMapperBdp Methods
Protected Methods Public Methods
Collapse All

The methods of the PersistenceMapperBdp class are listed here.

Protected Methods
Name | Description
MakeDatabase |
ReturnDatabase |
Top
Public Methods
Name | Description
RegisterAttributeMappers | This is RegisterAttributeMappers, a member of class PersistenceMapperBdp.


PersistenceMapperBdp.MakeDatabase Method

PersistenceMapperBdp.MakeDatabase Method
PersistenceMapperBdp Class Eco.Persistence Namespace See Also
Collapse All
C#
protected override IDatabase MakeDatabase();
Exceptions
Exceptions | Description
InvalidOperationException | Thrown if Connection is null.
See Also
PersistenceMapperBdp Class
Eco.Persistence Namespace


PersistenceMapperBdp.RegisterAttributeMappers Method

PersistenceMapperBdp.RegisterAttributeMappers Method
PersistenceMapperBdp Class Eco.Persistence Namespace See Also
Collapse All
C#
public static void RegisterAttributeMappers();
Remarks

This is RegisterAttributeMappers, a member of class PersistenceMapperBdp.

See Also
PersistenceMapperBdp Class
Eco.Persistence Namespace


PersistenceMapperBdp.ReturnDatabase Method

PersistenceMapperBdp.ReturnDatabase Method
PersistenceMapperBdp Class Eco.Persistence Namespace See Also
Collapse All
C#
protected override void ReturnDatabase(
    IDatabase database
);
Exceptions
Exceptions | Description
ArgumentNullException | Thrown if database is null
See Also
PersistenceMapperBdp Class
Eco.Persistence Namespace


PersistenceMapperBdp Properties

PersistenceMapperBdp Properties
Public Properties
Collapse All

The properties of the PersistenceMapperBdp class are listed here.

Public Properties
Name | Description
Connection | This is Connection, a member of class PersistenceMapperBdp.
HasConnection | This is HasConnection, a member of class PersistenceMapperBdp.


PersistenceMapperBdp.Connection Property

PersistenceMapperBdp.Connection Property
PersistenceMapperBdp Class Eco.Persistence Namespace See Also
Collapse All
C#
public BdpConnection Connection;
Remarks

This is Connection, a member of class PersistenceMapperBdp.

See Also
PersistenceMapperBdp Class
Eco.Persistence Namespace


PersistenceMapperBdp.HasConnection Property

PersistenceMapperBdp.HasConnection Property
PersistenceMapperBdp Class Eco.Persistence Namespace See Also
Collapse All
C#
public override bool HasConnection;
Remarks

This is HasConnection, a member of class PersistenceMapperBdp.

See Also
PersistenceMapperBdp Class
Eco.Persistence Namespace


PersistenceMapperBlackfish Class

PersistenceMapperBlackfish Class
Inheritance Hierarchy See Also
Collapse All

Persistencemapper using BlackfishSQL native connections.

C#
public class PersistenceMapperBlackfish : AbstractPersistenceMapperBlackfish, IAutoHookable;
Inheritance Hierarchy
Eco.Persistence.IPersistencemapperProvider
    Eco.Persistence.PersistenceMapper
        Eco.Persistence.AbstractPersistenceMapperDb
        Eco.Persistence.IPersistenceMapperDb
            Eco.Persistence.PersistenceMapperDb
            Eco.Persistence.IAutoHookable
                Eco.Persistence.PersistenceMapperAdo2
                    Eco.Persistence.AbstractPersistenceMapperBlackfish
                        Eco.Persistence.PersistenceMapperBlackfish
File

PersistenceMapperBlackfish.cs

See Also
Inheritance Hierarchy


PersistenceMapperBlackfish.PersistenceMapperBlackfish Constructor

PersistenceMapperBlackfish.PersistenceMapperBlackfish Constructor
PersistenceMapperBlackfish Class Eco.Persistence Namespace See Also
Collapse All
C#
public PersistenceMapperBlackfish();
Remarks

This is PersistenceMapperBlackfish, a member of class PersistenceMapperBlackfish.

See Also
PersistenceMapperBlackfish Class
Eco.Persistence Namespace


PersistenceMapperBlackfish Methods

PersistenceMapperBlackfish Methods
Protected Methods
Collapse All

The methods of the PersistenceMapperBlackfish class are listed here.

Protected Methods
Name | Description
ConnectionType | This is ConnectionType, a member of class PersistenceMapperBlackfish.


PersistenceMapperBlackfish.ConnectionType Method

PersistenceMapperBlackfish.ConnectionType Method
PersistenceMapperBlackfish Class Eco.Persistence Namespace See Also
Collapse All
C#
protected override Type ConnectionType();
Remarks

This is ConnectionType, a member of class PersistenceMapperBlackfish.

See Also
PersistenceMapperBlackfish Class
Eco.Persistence Namespace


PersistenceMapperBlackfishRemote Class

PersistenceMapperBlackfishRemote Class
Inheritance Hierarchy See Also
Collapse All

Persistencemapper using BlackfishSQL native connections.

C#
public class PersistenceMapperBlackfishRemote : AbstractPersistenceMapperBlackfish, IAutoHookable;
Inheritance Hierarchy
Eco.Persistence.IPersistencemapperProvider
    Eco.Persistence.PersistenceMapper
        Eco.Persistence.AbstractPersistenceMapperDb
        Eco.Persistence.IPersistenceMapperDb
            Eco.Persistence.PersistenceMapperDb
            Eco.Persistence.IAutoHookable
                Eco.Persistence.PersistenceMapperAdo2
                    Eco.Persistence.AbstractPersistenceMapperBlackfish
                        Eco.Persistence.PersistenceMapperBlackfishRemote
File

PersistenceMapperBlackfishRemote.cs

See Also
Inheritance Hierarchy


PersistenceMapperBlackfishRemote.PersistenceMapperBlackfishRemote Constructor

PersistenceMapperBlackfishRemote.PersistenceMapperBlackfishRemote Constructor
PersistenceMapperBlackfishRemote Class Eco.Persistence Namespace See Also
Collapse All
C#
public PersistenceMapperBlackfishRemote();
Remarks

This is PersistenceMapperBlackfishRemote, a member of class PersistenceMapperBlackfishRemote.

See Also
PersistenceMapperBlackfishRemote Class
Eco.Persistence Namespace


PersistenceMapperBlackfishRemote Methods

PersistenceMapperBlackfishRemote Methods
Protected Methods
Collapse All

The methods of the PersistenceMapperBlackfishRemote class are listed here.

Protected Methods
Name | Description
ConnectionType | This is ConnectionType, a member of class PersistenceMapperBlackfishRemote.


PersistenceMapperBlackfishRemote.ConnectionType Method

PersistenceMapperBlackfishRemote.ConnectionType Method
PersistenceMapperBlackfishRemote Class Eco.Persistence Namespace See Also
Collapse All
C#
protected override Type ConnectionType();
Remarks

This is ConnectionType, a member of class PersistenceMapperBlackfishRemote.

See Also
PersistenceMapperBlackfishRemote Class
Eco.Persistence Namespace


PersistenceMapperDb Class

PersistenceMapperDb Class
Inheritance Hierarchy See Also
Collapse All
C#
public abstract class PersistenceMapperDb : AbstractPersistenceMapperDb, IPersistenceMapperDb;
Remarks

This is class Eco.Persistence.PersistenceMapperDb.

Inheritance Hierarchy
Eco.Persistence.IPersistencemapperProvider
    Eco.Persistence.PersistenceMapper
        Eco.Persistence.AbstractPersistenceMapperDb
        Eco.Persistence.IPersistenceMapperDb
            Eco.Persistence.PersistenceMapperDb
                Eco.Persistence.PersistenceMapperAdo2
                Eco.Persistence.PersistenceMapperBdp
                Eco.Persistence.PersistenceMapperSybase
File

PersistenceMapperDb.cs

See Also
Inheritance Hierarchy


PersistenceMapperDb.PersistenceMapperDb Constructor

PersistenceMapperDb.PersistenceMapperDb Constructor
PersistenceMapperDb Class Eco.Persistence Namespace See Also
Collapse All
C#
protected PersistenceMapperDb();
Remarks

This is PersistenceMapperDb, a member of class PersistenceMapperDb.

See Also
PersistenceMapperDb Class
Eco.Persistence Namespace


PersistenceMapperDb Methods

PersistenceMapperDb Methods
Protected Methods Public Methods Protected internal Methods
Collapse All

The methods of the PersistenceMapperDb class are listed here.

Protected Methods
Name | Description
SetCompatibilityMode | This is SetCompatibilityMode, a member of class PersistenceMapperDb.
Top
Public Methods
Name | Description
ApplyScript | Applies the statements in sqlSqript.
CloseConnections | This method should be used to close any open database connections.
CreateDatabaseSchema | This is the overview for the CreateDatabaseSchema method overload.
CreateSchemaScript | Returns the script required to create the schema for the current model.
DatabaseHasTable | Utility function that will examine if the database contains a table with the specified name.
GetDatabaseConnection | Returns a connection to the database
GetEvolutor | Retrieves an evolutor.
GetPersistenceMapper |
ReturnDatabaseConnection | Use this method to return a database connection that you have previously retrieved using GetDatabaseConnection
ReturnEvolutor | Returns an evolutor after use.
ReturnPersistenceMapper | This is ReturnPersistenceMapper, a member of class PersistenceMapperDb.
SaveMappingInfo | This method will store the mapping information that is needed by DbEvolution in a table in the database.
ValidateDataStructure | Validates that the schema matches the model. remedies will contain the SQL statements to rectify the problems in the data structure.
ValidateSchemaStructure | Validates that the schema matches the model. remedies will contain the SQL statements to rectify the problems in the schema.
Top
Protected internal Methods
Name | Description
MakeDatabase | Reachable by connectionpool
ReturnDatabase | Reachable by connectionpool


PersistenceMapperDb.ApplyScript Method

PersistenceMapperDb.ApplyScript Method
PersistenceMapperDb Class Eco.Persistence Namespace See Also
Collapse All

Applies the statements in sqlSqript.

C#
public void ApplyScript(
    List<string> sqlScript
);
Parameters
Parameters | Description
sqlScript | Sql script to execute.
Remarks

Script executed as ExecuteSql, and must not return an answer set. If SqlDatabaseConfig.AllowMetadataChangesInTransaction is true, execution will be wrapped in a transaction.

Sql-exceptions will be rethrown.

Exceptions
Exceptions | Description
ArgumentNullException | Thrown if sqlScript is null.
InvalidOperationException | Thrown if SqlDatabaseConfig is not configured.
See Also
PersistenceMapperDb Class
Eco.Persistence Namespace


PersistenceMapperDb.CloseConnections Method

PersistenceMapperDb.CloseConnections Method
PersistenceMapperDb Class Eco.Persistence Namespace See Also
Collapse All

This method should be used to close any open database connections.

C#
public override void CloseConnections(
    bool force
);
Parameters
Parameters | Description
force | This parameter will be true if the component is being disposed.
See Also
PersistenceMapperDb Class
Eco.Persistence Namespace


CreateDatabaseSchema Method

CreateDatabaseSchema Method

This is the overview for the CreateDatabaseSchema method overload.

Overload List
Name | Description
PersistenceMapperDb.CreateDatabaseSchema (ITypeSystemService) | This method can be called in runtime to create a database schema in the database refered to by the persistence mapper. DefaultCleanPsConfig(false) will be used as the IConfigureCleanPs instance.
PersistenceMapperDb.CreateDatabaseSchema (ITypeSystemService, IConfigureCleanPS) | This method can be called in runtime to create a database schema in the database refered to by the persistence mapper.


PersistenceMapperDb.CreateDatabaseSchema Method (ITypeSystemService)

PersistenceMapperDb.CreateDatabaseSchema Method (ITypeSystemService)
PersistenceMapperDb Class Eco.Persistence Namespace See Also
Collapse All

This method can be called in runtime to create a database schema in the database refered to by the persistence mapper. DefaultCleanPsConfig(false) will be used as the IConfigureCleanPs instance.

C#
public void CreateDatabaseSchema(
    ITypeSystemService typeSystemService
);
Exceptions
Exceptions | Description
ArgumentNullException | Thrown if typeSystemService is null
See Also
PersistenceMapperDb Class
Eco.Persistence Namespace


PersistenceMapperDb.CreateDatabaseSchema Method (ITypeSystemService, IConfigureCleanPS)

PersistenceMapperDb.CreateDatabaseSchema Method (ITypeSystemService, IConfigureCleanPS)
PersistenceMapperDb Class Eco.Persistence Namespace See Also
Collapse All

This method can be called in runtime to create a database schema in the database refered to by the persistence mapper.

C#
public void CreateDatabaseSchema(
    ITypeSystemService typeSystemService,
    IConfigureCleanPS configureCleanPS
);
Exceptions
Exceptions | Description
ArgumentNullException | Thrown if typeSystemService is null Thrown if configureCleanPS is null
See Also
PersistenceMapperDb Class
Eco.Persistence Namespace


PersistenceMapperDb.CreateSchemaScript Method

PersistenceMapperDb.CreateSchemaScript Method
PersistenceMapperDb Class Eco.Persistence Namespace See Also
Collapse All

Returns the script required to create the schema for the current model.

C#
public IList<string> CreateSchemaScript(
    ITypeSystemService typeSystemService
);
Exceptions
Exceptions | Description
ArgumentNullException | Thrown if typeSystemService is null
See Also
PersistenceMapperDb Class
Eco.Persistence Namespace


PersistenceMapperDb.DatabaseHasTable Method

PersistenceMapperDb.DatabaseHasTable Method
PersistenceMapperDb Class Eco.Persistence Namespace See Also
Collapse All

Utility function that will examine if the database contains a table with the specified name.

C#
public bool DatabaseHasTable(
    string tableName
);
Parameters
Parameters | Description
tableName | name of table to look for.
Returns

True if the table exists in the schema.

See Also
PersistenceMapperDb Class
Eco.Persistence Namespace


PersistenceMapperDb.GetDatabaseConnection Method

PersistenceMapperDb.GetDatabaseConnection Method
PersistenceMapperDb Class Eco.Persistence Namespace See Also
Collapse All

Returns a connection to the database

C#
public IDatabase GetDatabaseConnection(
    bool exclusive
);
Parameters
Parameters | Description
exclusive | Indicates if the connection should have exclusive access to the db
Remarks

A database connection that is retrieved with this method must be returned using

See Also
PersistenceMapperDb Class
Eco.Persistence Namespace


PersistenceMapperDb.GetEvolutor Method

PersistenceMapperDb.GetEvolutor Method
PersistenceMapperDb Class Eco.Persistence Namespace See Also
Collapse All

Retrieves an evolutor.

C#
public IDBEvolutor GetEvolutor(
    ITypeSystemService typeSystemService
);
Exceptions
Exceptions | Description
ArgumentNullException | Thrown if typeSystemService is null
See Also
PersistenceMapperDb Class
Eco.Persistence Namespace


PersistenceMapperDb.GetPersistenceMapper Method

PersistenceMapperDb.GetPersistenceMapper Method
PersistenceMapperDb Class Eco.Persistence Namespace See Also
Collapse All
C#
public override IPersistenceMapper GetPersistenceMapper(
    ITypeSystemService typeSystemService
);
Exceptions
Exceptions | Description
InvalidOperationException | Thrown if ActiveCount > 0.
See Also
PersistenceMapperDb Class
Eco.Persistence Namespace


PersistenceMapperDb.MakeDatabase Method

PersistenceMapperDb.MakeDatabase Method
PersistenceMapperDb Class Eco.Persistence Namespace See Also
Collapse All
C#
protected internal abstract IDatabase MakeDatabase();
Remarks

Reachable by connectionpool

See Also
PersistenceMapperDb Class
Eco.Persistence Namespace


PersistenceMapperDb.ReturnDatabase Method

PersistenceMapperDb.ReturnDatabase Method
PersistenceMapperDb Class Eco.Persistence Namespace See Also
Collapse All
C#
protected internal abstract void ReturnDatabase(
    IDatabase database
);
Remarks

Reachable by connectionpool

See Also
PersistenceMapperDb Class
Eco.Persistence Namespace


PersistenceMapperDb.ReturnDatabaseConnection Method

PersistenceMapperDb.ReturnDatabaseConnection Method
PersistenceMapperDb Class Eco.Persistence Namespace See Also
Collapse All

Use this method to return a database connection that you have previously retrieved using GetDatabaseConnection

C#
public void ReturnDatabaseConnection(
    IDatabase db
);
Parameters
Parameters | Description
db | The database that should be returned
See Also
PersistenceMapperDb Class
Eco.Persistence Namespace


PersistenceMapperDb.ReturnEvolutor Method

PersistenceMapperDb.ReturnEvolutor Method
PersistenceMapperDb Class Eco.Persistence Namespace See Also
Collapse All

Returns an evolutor after use.

C#
public void ReturnEvolutor(
    IDBEvolutor evolutor
);
Exceptions
Exceptions | Description
ArgumentNullException | Thrown if evolutor is null
See Also
PersistenceMapperDb Class
Eco.Persistence Namespace


PersistenceMapperDb.ReturnPersistenceMapper Method

PersistenceMapperDb.ReturnPersistenceMapper Method
PersistenceMapperDb Class Eco.Persistence Namespace See Also
Collapse All
C#
public override void ReturnPersistenceMapper(
    IPersistenceMapper persistenceMapper
);
Remarks

This is ReturnPersistenceMapper, a member of class PersistenceMapperDb.

See Also
PersistenceMapperDb Class
Eco.Persistence Namespace


PersistenceMapperDb.SaveMappingInfo Method

PersistenceMapperDb.SaveMappingInfo Method
PersistenceMapperDb Class Eco.Persistence Namespace See Also
Collapse All

This method will store the mapping information that is needed by DbEvolution in a table in the database.

C#
public void SaveMappingInfo(
    ITypeSystemService typeSystemService
);
Remarks

Normally this information is stored when CreateDatabaseSchema is called, but for databases created with Eco1, this method must be called prior to changing the model.

Exceptions
Exceptions | Description
ArgumentNullException | Thrown if typeSystemService is null
See Also
PersistenceMapperDb Class
Eco.Persistence Namespace


PersistenceMapperDb.SetCompatibilityMode Method

PersistenceMapperDb.SetCompatibilityMode Method
PersistenceMapperDb Class Eco.Persistence Namespace See Also
Collapse All
C#
protected override void SetCompatibilityMode(
    EcoCompatibilityMode mode
);
Remarks

This is SetCompatibilityMode, a member of class PersistenceMapperDb.

See Also
PersistenceMapperDb Class
Eco.Persistence Namespace


PersistenceMapperDb.ValidateDataStructure Method

PersistenceMapperDb.ValidateDataStructure Method
PersistenceMapperDb Class Eco.Persistence Namespace See Also
Collapse All

Validates that the schema matches the model. remedies will contain the SQL statements to rectify the problems in the data structure.

C#
public bool ValidateDataStructure(
    IList<string> remedies,
    ITypeSystemService typeSystemService
);
See Also
PersistenceMapperDb Class
Eco.Persistence Namespace


PersistenceMapperDb.ValidateSchemaStructure Method

PersistenceMapperDb.ValidateSchemaStructure Method
PersistenceMapperDb Class Eco.Persistence Namespace See Also
Collapse All

Validates that the schema matches the model. remedies will contain the SQL statements to rectify the problems in the schema.

C#
public bool ValidateSchemaStructure(
    IList<string> remedies,
    ITypeSystemService typeSystemService
);
Parameters
Parameters | Description
remedies | Will contain SQL statements required to execute against the schema to make it valid.
typeSystemService | The type system used to validate schema against.
Returns

True if the schema is valid relative to the typesystem.

See Also
PersistenceMapperDb Class
Eco.Persistence Namespace


PersistenceMapperDb Properties

PersistenceMapperDb Properties
Public Properties
Collapse All

The properties of the PersistenceMapperDb class are listed here.

Public Properties
Name | Description
Active | This is Active, a member of class PersistenceMapperDb.
ClockLogGranularity | Backwards compatibility
ConnectionPool | This is ConnectionPool, a member of class PersistenceMapperDb.
EffectiveNewMappingProvider | This property returns the NewMappingProvider that will actually be used in runtime. If the NewMappingProvider property is not set, this property will return a DefaultOrMappingProvider
EffectiveOldMappingProvider | This property returns the OldMappingProvider that will actually be used in runtime. If the OldMappingProvider property is not set, this property will return a DbMappingProvider
EvolutionSupport | Backwards compatibility
HasConnection | This is HasConnection, a member of class PersistenceMapperDb.
MaxOpenConnections | MaxOpenConnections is the maximum number of connections that will be open at once.
MaxPoolConnections | MaxPoolConnections is the maximum number of connections that will be pooled.
NewMappingProvider | This is NewMappingProvider, a member of class PersistenceMapperDb.
OldMappingProvider | This is OldMappingProvider, a member of class PersistenceMapperDb.
SqlDatabaseConfig | This is SqlDatabaseConfig, a member of class PersistenceMapperDb.


PersistenceMapperDb.Active Property

PersistenceMapperDb.Active Property
PersistenceMapperDb Class Eco.Persistence Namespace See Also
Collapse All
C#
public bool Active;
Remarks

This is Active, a member of class PersistenceMapperDb.

See Also
PersistenceMapperDb Class
Eco.Persistence Namespace


PersistenceMapperDb.ClockLogGranularity Property

PersistenceMapperDb.ClockLogGranularity Property
PersistenceMapperDb Class Eco.Persistence Namespace See Also
Collapse All
C#
public string ClockLogGranularity;
Remarks

Backwards compatibility

See Also
PersistenceMapperDb Class
Eco.Persistence Namespace


PersistenceMapperDb.ConnectionPool Property

PersistenceMapperDb.ConnectionPool Property
PersistenceMapperDb Class Eco.Persistence Namespace See Also
Collapse All
C#
public ConnectionPool ConnectionPool;
Remarks

This is ConnectionPool, a member of class PersistenceMapperDb.

See Also
PersistenceMapperDb Class
Eco.Persistence Namespace


PersistenceMapperDb.EffectiveNewMappingProvider Property

PersistenceMapperDb.EffectiveNewMappingProvider Property
PersistenceMapperDb Class Eco.Persistence Namespace See Also
Collapse All

This property returns the NewMappingProvider that will actually be used in runtime. If the NewMappingProvider property is not set, this property will return a DefaultOrMappingProvider

C#
public IORMappingProvider EffectiveNewMappingProvider;
See Also
PersistenceMapperDb Class
Eco.Persistence Namespace


PersistenceMapperDb.EffectiveOldMappingProvider Property

PersistenceMapperDb.EffectiveOldMappingProvider Property
PersistenceMapperDb Class Eco.Persistence Namespace See Also
Collapse All

This property returns the OldMappingProvider that will actually be used in runtime. If the OldMappingProvider property is not set, this property will return a DbMappingProvider

C#
public IORMappingProvider EffectiveOldMappingProvider;
See Also
PersistenceMapperDb Class
Eco.Persistence Namespace


PersistenceMapperDb.EvolutionSupport Property

PersistenceMapperDb.EvolutionSupport Property
PersistenceMapperDb Class Eco.Persistence Namespace See Also
Collapse All
C#
public bool EvolutionSupport;
Remarks

Backwards compatibility

See Also
PersistenceMapperDb Class
Eco.Persistence Namespace


PersistenceMapperDb.HasConnection Property

PersistenceMapperDb.HasConnection Property
PersistenceMapperDb Class Eco.Persistence Namespace See Also
Collapse All
C#
public abstract bool HasConnection;
Remarks

This is HasConnection, a member of class PersistenceMapperDb.

See Also
PersistenceMapperDb Class
Eco.Persistence Namespace


PersistenceMapperDb.MaxOpenConnections Property

PersistenceMapperDb.MaxOpenConnections Property
PersistenceMapperDb Class Eco.Persistence Namespace See Also
Collapse All

MaxOpenConnections is the maximum number of connections that will be open at once.

C#
public int MaxOpenConnections;
Remarks

Connections are only used when Eco is actually performing an operation in persistent storage So it can usually be signifcanty less that the number of EcoSpaces sharing the PersistenceMapper.

if MaxOpenConnections is < MaxPoolConnections then the pool will never be fully used.

If the MaxOpenConnections is is > MaxPoolConnections, then the additional connections wil be disposed after use, rather than returned to the pool

If MaxOpenConnections is > the connection will always be cloned, the actual connection instace connected to the PersistenceMapper will not be used as such.

See Also
PersistenceMapperDb Class
Eco.Persistence Namespace


PersistenceMapperDb.MaxPoolConnections Property

PersistenceMapperDb.MaxPoolConnections Property
PersistenceMapperDb Class Eco.Persistence Namespace See Also
Collapse All

MaxPoolConnections is the maximum number of connections that will be pooled.

C#
public int MaxPoolConnections;
See Also
PersistenceMapperDb Class
Eco.Persistence Namespace


PersistenceMapperDb.NewMappingProvider Property

PersistenceMapperDb.NewMappingProvider Property
PersistenceMapperDb Class Eco.Persistence Namespace See Also
Collapse All
C#
public IORMappingProvider NewMappingProvider;
Remarks

This is NewMappingProvider, a member of class PersistenceMapperDb.

See Also
PersistenceMapperDb Class
Eco.Persistence Namespace


PersistenceMapperDb.OldMappingProvider Property

PersistenceMapperDb.OldMappingProvider Property
PersistenceMapperDb Class Eco.Persistence Namespace See Also
Collapse All
C#
public IORMappingProvider OldMappingProvider;
Remarks

This is OldMappingProvider, a member of class PersistenceMapperDb.

See Also
PersistenceMapperDb Class
Eco.Persistence Namespace


PersistenceMapperDb.SqlDatabaseConfig Property

PersistenceMapperDb.SqlDatabaseConfig Property
PersistenceMapperDb Class Eco.Persistence Namespace See Also
Collapse All
C#
public SqlDatabaseConfig SqlDatabaseConfig;
Remarks

This is SqlDatabaseConfig, a member of class PersistenceMapperDb.

See Also
PersistenceMapperDb Class
Eco.Persistence Namespace


PersistenceMapperDbCollection Class

PersistenceMapperDbCollection Class
Inheritance Hierarchy See Also
Collapse All
C#
public sealed class PersistenceMapperDbCollection : System.Collections.CollectionBase;
Remarks

This is class Eco.Persistence.PersistenceMapperDbCollection.

Inheritance Hierarchy
Eco.Persistence.PersistenceMapperDbCollection
File

PMapperDef.cs

See Also
Inheritance Hierarchy


PersistenceMapperDbCollection.PersistenceMapperDbCollection Constructor

PersistenceMapperDbCollection.PersistenceMapperDbCollection Constructor
PersistenceMapperDbCollection Class Eco.Persistence Namespace See Also
Collapse All
C#
public PersistenceMapperDbCollection();
Remarks

This is PersistenceMapperDbCollection, a member of class PersistenceMapperDbCollection.

See Also
PersistenceMapperDbCollection Class
Eco.Persistence Namespace


PersistenceMapperDbCollection Methods

PersistenceMapperDbCollection Methods
Protected Methods Public Methods
Collapse All

The methods of the PersistenceMapperDbCollection class are listed here.

Protected Methods
Name | Description
OnInsertComplete | This is OnInsertComplete, a member of class PersistenceMapperDbCollection.
Top
Public Methods
Name | Description
Add | Adds the specified PMapperDef to the collection.
AddRange | Adds the range of PMapperDef to the collection.
Assign | Assigns the values from source to this instance.
FindByName | Returns the PMapperDef with the specified name.
FindVersionedDatabase | Returns the versioned database within the collection or null if there is none.
NameExists | Returns true if the collection contains a PMapperDef with the specified name.
this | This is this, a member of class PersistenceMapperDbCollection.


PersistenceMapperDbCollection.Add Method

PersistenceMapperDbCollection.Add Method
PersistenceMapperDbCollection Class Eco.Persistence Namespace See Also
Collapse All

Adds the specified PMapperDef to the collection.

C#
public void Add(
    PMapperDef def
);
Parameters
Parameters | Description
def | The PMapperDef to add to the collection.
Remarks

Adds def to the collection. If def.Name is already used by an item in the collection, the item will silently not be added.

Exceptions
Exceptions | Description
ArgumentNullException | Thrown if def is null
See Also
PersistenceMapperDbCollection Class
Eco.Persistence Namespace


PersistenceMapperDbCollection.AddRange Method

PersistenceMapperDbCollection.AddRange Method
PersistenceMapperDbCollection Class Eco.Persistence Namespace See Also
Collapse All

Adds the range of PMapperDef to the collection.

C#
public void AddRange(
    PMapperDef[] defs
);
Remarks

Calls Add for each instance in the array.

See Also
PersistenceMapperDbCollection Class
Eco.Persistence Namespace


PersistenceMapperDbCollection.Assign Method

PersistenceMapperDbCollection.Assign Method
PersistenceMapperDbCollection Class Eco.Persistence Namespace See Also
Collapse All

Assigns the values from source to this instance.

C#
public void Assign(
    PersistenceMapperDbCollection source
);
Parameters
Parameters | Description
source | The PersistenceMapperDbCollection from which to clone the collection.
Remarks

The collection of this instance is cleared, after which the items in the source collection are cloned to this instance.

Exceptions
Exceptions | Description
ArgumentNullException | Thrown if source is null
See Also
PersistenceMapperDbCollection Class
Eco.Persistence Namespace


PersistenceMapperDbCollection.FindByName Method

PersistenceMapperDbCollection.FindByName Method
PersistenceMapperDbCollection Class Eco.Persistence Namespace See Also
Collapse All

Returns the PMapperDef with the specified name.

C#
public PMapperDef FindByName(
    string name
);
Parameters
Parameters | Description
name | The name to look for in the collection.
Remarks

If the collection contains a PMapperDef it is returned. Otherwise null is returned.

See Also
PersistenceMapperDbCollection Class
Eco.Persistence Namespace


PersistenceMapperDbCollection.FindVersionedDatabase Method

PersistenceMapperDbCollection.FindVersionedDatabase Method
PersistenceMapperDbCollection Class Eco.Persistence Namespace See Also
Collapse All

Returns the versioned database within the collection or null if there is none.

C#
public PMapperDef FindVersionedDatabase();
Remarks

The collection is iterated to find and return the first versioned database. If not exactly one such PMapperDef is found an exception is thrown.

Exceptions
Exceptions | Description
EcoException | Thrown if there is not exactly one versioned database found.
See Also
PersistenceMapperDbCollection Class
Eco.Persistence Namespace


PersistenceMapperDbCollection.NameExists Method

PersistenceMapperDbCollection.NameExists Method
PersistenceMapperDbCollection Class Eco.Persistence Namespace See Also
Collapse All

Returns true if the collection contains a PMapperDef with the specified name.

C#
public bool NameExists(
    string name
);
Parameters
Parameters | Description
name | The name to look for in the collection.
Remarks

Returns true if the collection contains a PMapperDef with the specified name.

See Also
PersistenceMapperDbCollection Class
Eco.Persistence Namespace


PersistenceMapperDbCollection.OnInsertComplete Method

PersistenceMapperDbCollection.OnInsertComplete Method
PersistenceMapperDbCollection Class Eco.Persistence Namespace See Also
Collapse All
C#
protected override void OnInsertComplete(
    int index,
    object value
);
Remarks

This is OnInsertComplete, a member of class PersistenceMapperDbCollection.

See Also
PersistenceMapperDbCollection Class
Eco.Persistence Namespace


PersistenceMapperDbCollection.this Indexer

PersistenceMapperDbCollection.this Indexer
PersistenceMapperDbCollection Class Eco.Persistence Namespace See Also
Collapse All
C#
public PMapperDef this[
    int index
];
Remarks

This is this, a member of class PersistenceMapperDbCollection.

See Also
PersistenceMapperDbCollection Class
Eco.Persistence Namespace


PersistenceMapperDbx Class

PersistenceMapperDbx Class
Inheritance Hierarchy See Also
Collapse All
C#
public sealed class PersistenceMapperDbx : PersistenceMapperAdo2, IAutoHookable;
Remarks

This is class Eco.Persistence.PersistenceMapperDbx.

Inheritance Hierarchy
Eco.Persistence.IPersistencemapperProvider
    Eco.Persistence.PersistenceMapper
        Eco.Persistence.AbstractPersistenceMapperDb
        Eco.Persistence.IPersistenceMapperDb
            Eco.Persistence.PersistenceMapperDb
            Eco.Persistence.IAutoHookable
                Eco.Persistence.PersistenceMapperAdo2
                    Eco.Persistence.PersistenceMapperDbx
File

PersistenceMapperDbx.cs

See Also
Inheritance Hierarchy


PersistenceMapperDbx Methods

PersistenceMapperDbx Methods
Protected Methods Public Methods
Collapse All

The methods of the PersistenceMapperDbx class are listed here.

Protected Methods
Name | Description
ConnectionType | This is ConnectionType, a member of class PersistenceMapperDbx.
InternalCreateIDatabase | This is InternalCreateIDatabase, a member of class PersistenceMapperDbx.
Top
Public Methods
Name | Description
RegisterAttributeMappers | This is RegisterAttributeMappers, a member of class PersistenceMapperDbx.


PersistenceMapperDbx.ConnectionType Method

PersistenceMapperDbx.ConnectionType Method
PersistenceMapperDbx Class Eco.Persistence Namespace See Also
Collapse All
C#
protected override Type ConnectionType();
Remarks

This is ConnectionType, a member of class PersistenceMapperDbx.

See Also
PersistenceMapperDbx Class
Eco.Persistence Namespace


PersistenceMapperDbx.InternalCreateIDatabase Method

PersistenceMapperDbx.InternalCreateIDatabase Method
PersistenceMapperDbx Class Eco.Persistence Namespace See Also
Collapse All
C#
protected override IDatabase InternalCreateIDatabase(
    DbConnection connection,
    SqlDatabaseConfig config
);
Remarks

This is InternalCreateIDatabase, a member of class PersistenceMapperDbx.

See Also
PersistenceMapperDbx Class
Eco.Persistence Namespace


PersistenceMapperDbx.RegisterAttributeMappers Method

PersistenceMapperDbx.RegisterAttributeMappers Method
PersistenceMapperDbx Class Eco.Persistence Namespace See Also
Collapse All
C#
public static void RegisterAttributeMappers();
Remarks

This is RegisterAttributeMappers, a member of class PersistenceMapperDbx.

See Also
PersistenceMapperDbx Class
Eco.Persistence Namespace


PersistenceMapperDbx Properties

PersistenceMapperDbx Properties
Public Properties
Collapse All

The properties of the PersistenceMapperDbx class are listed here.

Public Properties
Name | Description
Connection | This is Connection, a member of class PersistenceMapperDbx.


PersistenceMapperDbx.Connection Property

PersistenceMapperDbx.Connection Property
PersistenceMapperDbx Class Eco.Persistence Namespace See Also
Collapse All
C#
public TAdoDbxConnection Connection;
Remarks

This is Connection, a member of class PersistenceMapperDbx.

See Also
PersistenceMapperDbx Class
Eco.Persistence Namespace


PersistenceMapperFirebird Class

PersistenceMapperFirebird Class
Inheritance Hierarchy See Also
Collapse All
C#
public sealed class PersistenceMapperFirebird : PersistenceMapperAdo2, IAutoHookable;
Remarks

This is class Eco.Persistence.PersistenceMapperFirebird.

Inheritance Hierarchy
Eco.Persistence.IPersistencemapperProvider
    Eco.Persistence.PersistenceMapper
        Eco.Persistence.AbstractPersistenceMapperDb
        Eco.Persistence.IPersistenceMapperDb
            Eco.Persistence.PersistenceMapperDb
            Eco.Persistence.IAutoHookable
                Eco.Persistence.PersistenceMapperAdo2
                    Eco.Persistence.PersistenceMapperFirebird
File

PersistenceMapperFirebird.cs

See Also
Inheritance Hierarchy


PersistenceMapperFirebird.PersistenceMapperFirebird Constructor

PersistenceMapperFirebird.PersistenceMapperFirebird Constructor
PersistenceMapperFirebird Class Eco.Persistence Namespace See Also
Collapse All
C#
public PersistenceMapperFirebird();
Remarks

This is PersistenceMapperFirebird, a member of class PersistenceMapperFirebird.

See Also
PersistenceMapperFirebird Class
Eco.Persistence Namespace


PersistenceMapperFirebird Methods

PersistenceMapperFirebird Methods
Protected Methods Public Methods
Collapse All

The methods of the PersistenceMapperFirebird class are listed here.

Protected Methods
Name | Description
ConnectionType | This is ConnectionType, a member of class PersistenceMapperFirebird.
InternalCreateIDatabase | This is InternalCreateIDatabase, a member of class PersistenceMapperFirebird.
Top
Public Methods
Name | Description
InitializeSqlDatabaseConfig | This is the overview for the InitializeSqlDatabaseConfig method overload.


PersistenceMapperFirebird.ConnectionType Method

PersistenceMapperFirebird.ConnectionType Method
PersistenceMapperFirebird Class Eco.Persistence Namespace See Also
Collapse All
C#
protected override Type ConnectionType();
Remarks

This is ConnectionType, a member of class PersistenceMapperFirebird.

See Also
PersistenceMapperFirebird Class
Eco.Persistence Namespace


InitializeSqlDatabaseConfig Method

InitializeSqlDatabaseConfig Method

This is the overview for the InitializeSqlDatabaseConfig method overload.

Overload List
Name | Description
PersistenceMapperFirebird.InitializeSqlDatabaseConfig () | This is InitializeSqlDatabaseConfig, a member of class PersistenceMapperFirebird.
PersistenceMapperFirebird.InitializeSqlDatabaseConfig (SqlDatabaseConfig) | This is InitializeSqlDatabaseConfig, a member of class PersistenceMapperFirebird.


PersistenceMapperFirebird.InitializeSqlDatabaseConfig Method ()

PersistenceMapperFirebird.InitializeSqlDatabaseConfig Method ()
PersistenceMapperFirebird Class Eco.Persistence Namespace See Also
Collapse All
C#
public void InitializeSqlDatabaseConfig();
Remarks

This is InitializeSqlDatabaseConfig, a member of class PersistenceMapperFirebird.

See Also
PersistenceMapperFirebird Class
Eco.Persistence Namespace


PersistenceMapperFirebird.InitializeSqlDatabaseConfig Method (SqlDatabaseConfig)

PersistenceMapperFirebird.InitializeSqlDatabaseConfig Method (SqlDatabaseConfig)
PersistenceMapperFirebird Class Eco.Persistence Namespace See Also
Collapse All
C#
public static void InitializeSqlDatabaseConfig(
    SqlDatabaseConfig config
);
Remarks

This is InitializeSqlDatabaseConfig, a member of class PersistenceMapperFirebird.

See Also
PersistenceMapperFirebird Class
Eco.Persistence Namespace


PersistenceMapperFirebird.InternalCreateIDatabase Method

PersistenceMapperFirebird.InternalCreateIDatabase Method
PersistenceMapperFirebird Class Eco.Persistence Namespace See Also
Collapse All
C#
protected override IDatabase InternalCreateIDatabase(
    DbConnection connection,
    SqlDatabaseConfig config
);
Remarks

This is InternalCreateIDatabase, a member of class PersistenceMapperFirebird.

See Also
PersistenceMapperFirebird Class
Eco.Persistence Namespace


PersistenceMapperFirebird Properties

PersistenceMapperFirebird Properties
Public Properties
Collapse All

The properties of the PersistenceMapperFirebird class are listed here.

Public Properties
Name | Description
Connection | This is Connection, a member of class PersistenceMapperFirebird.


PersistenceMapperFirebird.Connection Property

PersistenceMapperFirebird.Connection Property
PersistenceMapperFirebird Class Eco.Persistence Namespace See Also
Collapse All
C#
public FbConnection Connection;
Remarks

This is Connection, a member of class PersistenceMapperFirebird.

See Also
PersistenceMapperFirebird Class
Eco.Persistence Namespace


PersistenceMapperMemory Class

PersistenceMapperMemory Class
Inheritance Hierarchy See Also
Collapse All
C#
public sealed class PersistenceMapperMemory : AbstractDataBlockPersistenceMapper;
Remarks

This is class Eco.Persistence.PersistenceMapperMemory.

Inheritance Hierarchy
Eco.Persistence.IPersistencemapperProvider
    Eco.Persistence.PersistenceMapper
    Eco.Persistence.IPersistenceMapper
        Eco.Persistence.AbstractDataBlockPersistenceMapper
            Eco.Persistence.PersistenceMapperMemory
File

PersistenceMapperXML.cs

See Also
Inheritance Hierarchy


PersistenceMapperMemory Methods

PersistenceMapperMemory Methods
Protected Methods
Collapse All

The methods of the PersistenceMapperMemory class are listed here.

Protected Methods
Name | Description
Deactivating | This is Deactivating, a member of class PersistenceMapperMemory.
EnsureCacheCurrent | This is EnsureCacheCurrent, a member of class PersistenceMapperMemory.
WriteDatablock | This is WriteDatablock, a member of class PersistenceMapperMemory.


PersistenceMapperMemory.Deactivating Method

PersistenceMapperMemory.Deactivating Method
PersistenceMapperMemory Class Eco.Persistence Namespace See Also
Collapse All
C#
protected override void Deactivating();
Remarks

This is Deactivating, a member of class PersistenceMapperMemory.

See Also
PersistenceMapperMemory Class
Eco.Persistence Namespace


PersistenceMapperMemory.EnsureCacheCurrent Method

PersistenceMapperMemory.EnsureCacheCurrent Method
PersistenceMapperMemory Class Eco.Persistence Namespace See Also
Collapse All
C#
protected override void EnsureCacheCurrent();
Remarks

This is EnsureCacheCurrent, a member of class PersistenceMapperMemory.

See Also
PersistenceMapperMemory Class
Eco.Persistence Namespace


PersistenceMapperMemory.WriteDatablock Method

PersistenceMapperMemory.WriteDatablock Method
PersistenceMapperMemory Class Eco.Persistence Namespace See Also
Collapse All
C#
protected override void WriteDatablock(
    Datablock datablock
);
Remarks

This is WriteDatablock, a member of class PersistenceMapperMemory.

See Also
PersistenceMapperMemory Class
Eco.Persistence Namespace


PersistenceMapperMimer Class

PersistenceMapperMimer Class
Inheritance Hierarchy See Also
Collapse All
C#
public sealed class PersistenceMapperMimer : PersistenceMapperAdo2, IAutoHookable;
Remarks

This is class Eco.Persistence.PersistenceMapperMimer.

Inheritance Hierarchy
Eco.Persistence.IPersistencemapperProvider
    Eco.Persistence.PersistenceMapper
        Eco.Persistence.AbstractPersistenceMapperDb
        Eco.Persistence.IPersistenceMapperDb
            Eco.Persistence.PersistenceMapperDb
            Eco.Persistence.IAutoHookable
                Eco.Persistence.PersistenceMapperAdo2
                    Eco.Persistence.PersistenceMapperMimer
File

PersistenceMapperMimer.cs

See Also
Inheritance Hierarchy


PersistenceMapperMimer.PersistenceMapperMimer Constructor

PersistenceMapperMimer.PersistenceMapperMimer Constructor
PersistenceMapperMimer Class Eco.Persistence Namespace See Also
Collapse All
C#
public PersistenceMapperMimer();
Remarks

This is PersistenceMapperMimer, a member of class PersistenceMapperMimer.

See Also
PersistenceMapperMimer Class
Eco.Persistence Namespace


PersistenceMapperMimer Methods

PersistenceMapperMimer Methods
Protected Methods Public Methods
Collapse All

The methods of the PersistenceMapperMimer class are listed here.

Protected Methods
Name | Description
ConnectionType | This is ConnectionType, a member of class PersistenceMapperMimer.
InternalCreateIDatabase | This is InternalCreateIDatabase, a member of class PersistenceMapperMimer.
Top
Public Methods
Name | Description
InitializeSqlDatabaseConfig | This is the overview for the InitializeSqlDatabaseConfig method overload.


PersistenceMapperMimer.ConnectionType Method

PersistenceMapperMimer.ConnectionType Method
PersistenceMapperMimer Class Eco.Persistence Namespace See Also
Collapse All
C#
protected override Type ConnectionType();
Remarks

This is ConnectionType, a member of class PersistenceMapperMimer.

See Also
PersistenceMapperMimer Class
Eco.Persistence Namespace


InitializeSqlDatabaseConfig Method

InitializeSqlDatabaseConfig Method

This is the overview for the InitializeSqlDatabaseConfig method overload.

Overload List
Name | Description
PersistenceMapperMimer.InitializeSqlDatabaseConfig () | This is InitializeSqlDatabaseConfig, a member of class PersistenceMapperMimer.
PersistenceMapperMimer.InitializeSqlDatabaseConfig (SqlDatabaseConfig) | This is InitializeSqlDatabaseConfig, a member of class PersistenceMapperMimer.


PersistenceMapperMimer.InitializeSqlDatabaseConfig Method ()

PersistenceMapperMimer.InitializeSqlDatabaseConfig Method ()
PersistenceMapperMimer Class Eco.Persistence Namespace See Also
Collapse All
C#
public void InitializeSqlDatabaseConfig();
Remarks

This is InitializeSqlDatabaseConfig, a member of class PersistenceMapperMimer.

See Also
PersistenceMapperMimer Class
Eco.Persistence Namespace


PersistenceMapperMimer.InitializeSqlDatabaseConfig Method (SqlDatabaseConfig)

PersistenceMapperMimer.InitializeSqlDatabaseConfig Method (SqlDatabaseConfig)
PersistenceMapperMimer Class Eco.Persistence Namespace See Also
Collapse All
C#
public static void InitializeSqlDatabaseConfig(
    SqlDatabaseConfig config
);
Remarks

This is InitializeSqlDatabaseConfig, a member of class PersistenceMapperMimer.

See Also
PersistenceMapperMimer Class
Eco.Persistence Namespace


PersistenceMapperMimer.InternalCreateIDatabase Method

PersistenceMapperMimer.InternalCreateIDatabase Method
PersistenceMapperMimer Class Eco.Persistence Namespace See Also
Collapse All
C#
protected override IDatabase InternalCreateIDatabase(
    DbConnection connection,
    SqlDatabaseConfig config
);
Remarks

This is InternalCreateIDatabase, a member of class PersistenceMapperMimer.

See Also
PersistenceMapperMimer Class
Eco.Persistence Namespace


PersistenceMapperMimer Properties

PersistenceMapperMimer Properties
Public Properties
Collapse All

The properties of the PersistenceMapperMimer class are listed here.

Public Properties
Name | Description
Connection | This is Connection, a member of class PersistenceMapperMimer.


PersistenceMapperMimer.Connection Property

PersistenceMapperMimer.Connection Property
PersistenceMapperMimer Class Eco.Persistence Namespace See Also
Collapse All
C#
public MimerConnection Connection;
Remarks

This is Connection, a member of class PersistenceMapperMimer.

See Also
PersistenceMapperMimer Class
Eco.Persistence Namespace


PersistenceMapperMultiDb Class

PersistenceMapperMultiDb Class
Inheritance Hierarchy See Also
Collapse All
C#
public class PersistenceMapperMultiDb : AbstractPersistenceMapperDb;
Remarks

This is class Eco.Persistence.PersistenceMapperMultiDb.

Inheritance Hierarchy
Eco.Persistence.IPersistencemapperProvider
    Eco.Persistence.PersistenceMapper
        Eco.Persistence.AbstractPersistenceMapperDb
            Eco.Persistence.PersistenceMapperMultiDb
File

PersistenceMapperMultiDb.cs

See Also
Inheritance Hierarchy


PersistenceMapperMultiDb.PersistenceMapperMultiDb Constructor

PersistenceMapperMultiDb.PersistenceMapperMultiDb Constructor
PersistenceMapperMultiDb Class Eco.Persistence Namespace See Also
Collapse All
C#
public PersistenceMapperMultiDb();
Remarks

This is PersistenceMapperMultiDb, a member of class PersistenceMapperMultiDb.

See Also
PersistenceMapperMultiDb Class
Eco.Persistence Namespace


PersistenceMapperMultiDb Methods

PersistenceMapperMultiDb Methods
Public Methods
Collapse All

The methods of the PersistenceMapperMultiDb class are listed here.

Public Methods
Name | Description
CloseConnections | This method should be used to close any open database connections.
CreateDatabaseSchema | This is the overview for the CreateDatabaseSchema method overload.
GetPersistenceMapper |
RetrieveDatabaseConnections | This is RetrieveDatabaseConnections, a member of class PersistenceMapperMultiDb.
ReturnDatabaseConnections |
ReturnPersistenceMapper | This is ReturnPersistenceMapper, a member of class PersistenceMapperMultiDb.


PersistenceMapperMultiDb.CloseConnections Method

PersistenceMapperMultiDb.CloseConnections Method
PersistenceMapperMultiDb Class Eco.Persistence Namespace See Also
Collapse All

This method should be used to close any open database connections.

C#
public override void CloseConnections(
    bool force
);
Parameters
Parameters | Description
force | This parameter will be true if the component is being disposed.
See Also
PersistenceMapperMultiDb Class
Eco.Persistence Namespace


CreateDatabaseSchema Method

CreateDatabaseSchema Method

This is the overview for the CreateDatabaseSchema method overload.

Overload List
Name | Description
PersistenceMapperMultiDb.CreateDatabaseSchema (ITypeSystemService, IConfigureCleanPS, string) |
PersistenceMapperMultiDb.CreateDatabaseSchema (ITypeSystemService, string) | This is CreateDatabaseSchema, a member of class PersistenceMapperMultiDb.


PersistenceMapperMultiDb.CreateDatabaseSchema Method (ITypeSystemService, IConfigureCleanPS, string)

PersistenceMapperMultiDb.CreateDatabaseSchema Method (ITypeSystemService, IConfigureCleanPS, string)
PersistenceMapperMultiDb Class Eco.Persistence Namespace See Also
Collapse All
C#
public void CreateDatabaseSchema(
    ITypeSystemService typeSystemService,
    IConfigureCleanPS configureCleanPS,
    string dbName
);
Exceptions
Exceptions | Description
ArgumentNullException | Thrown if configureCleanPS is null. Thrown if typeSystemService is null.
ArgumentException | Thrown if the no definition is found for dbName.
See Also
PersistenceMapperMultiDb Class
Eco.Persistence Namespace


PersistenceMapperMultiDb.CreateDatabaseSchema Method (ITypeSystemService, string)

PersistenceMapperMultiDb.CreateDatabaseSchema Method (ITypeSystemService, string)
PersistenceMapperMultiDb Class Eco.Persistence Namespace See Also
Collapse All
C#
public void CreateDatabaseSchema(
    ITypeSystemService typeSystemService,
    string dbName
);
Remarks

This is CreateDatabaseSchema, a member of class PersistenceMapperMultiDb.

See Also
PersistenceMapperMultiDb Class
Eco.Persistence Namespace


PersistenceMapperMultiDb.GetPersistenceMapper Method

PersistenceMapperMultiDb.GetPersistenceMapper Method
PersistenceMapperMultiDb Class Eco.Persistence Namespace See Also
Collapse All
C#
public override IPersistenceMapper GetPersistenceMapper(
    ITypeSystemService typeSystemService
);
Exceptions
Exceptions | Description
InvalidOperationException | Thrown if the mapper is used with another type system.
See Also
PersistenceMapperMultiDb Class
Eco.Persistence Namespace


PersistenceMapperMultiDb.RetrieveDatabaseConnections Method

PersistenceMapperMultiDb.RetrieveDatabaseConnections Method
PersistenceMapperMultiDb Class Eco.Persistence Namespace See Also
Collapse All
C#
public IDatabaseCollection RetrieveDatabaseConnections();
Remarks

This is RetrieveDatabaseConnections, a member of class PersistenceMapperMultiDb.

See Also
PersistenceMapperMultiDb Class
Eco.Persistence Namespace


PersistenceMapperMultiDb.ReturnDatabaseConnections Method

PersistenceMapperMultiDb.ReturnDatabaseConnections Method
PersistenceMapperMultiDb Class Eco.Persistence Namespace See Also
Collapse All
C#
public void ReturnDatabaseConnections(
    IDatabaseCollection databases
);
Exceptions
Exceptions | Description
ArgumentNullException | Thrown if databases is null
See Also
PersistenceMapperMultiDb Class
Eco.Persistence Namespace


PersistenceMapperMultiDb.ReturnPersistenceMapper Method

PersistenceMapperMultiDb.ReturnPersistenceMapper Method
PersistenceMapperMultiDb Class Eco.Persistence Namespace See Also
Collapse All
C#
public override void ReturnPersistenceMapper(
    IPersistenceMapper persistenceMapper
);
Remarks

This is ReturnPersistenceMapper, a member of class PersistenceMapperMultiDb.

See Also
PersistenceMapperMultiDb Class
Eco.Persistence Namespace


PersistenceMapperMultiDb Properties

PersistenceMapperMultiDb Properties
Public Properties
Collapse All

The properties of the PersistenceMapperMultiDb class are listed here.

Public Properties
Name
Description
DistributedTransactionManager
Setting this property will override the TransactionMode property. To use another transactionmanager than MS DTC, you need an instance of a class that implements ITransactionManager.
PersistenceMappers
This is PersistenceMappers, a member of class PersistenceMapperMultiDb.
TransactionMode
This property controls how transactions are handled when updates are perfomed

  • Disabled - No transactions are performed by Eco
  • Local - Only local transactions are used with each participating database. If one database fails to commit, others may already have committed, thus creating an inconsistency!
  • Distributed - Use Microsoft DTC to handle distributed transactions. This option also supports declarative transactions.


PersistenceMapperMultiDb.DistributedTransactionManager Property

PersistenceMapperMultiDb.DistributedTransactionManager Property
PersistenceMapperMultiDb Class Eco.Persistence Namespace See Also
Collapse All

Setting this property will override the TransactionMode property. To use another transactionmanager than MS DTC, you need an instance of a class that implements ITransactionManager.

C#
public ITransactionManager DistributedTransactionManager;
See Also
PersistenceMapperMultiDb Class
Eco.Persistence Namespace


PersistenceMapperMultiDb.PersistenceMappers Property

PersistenceMapperMultiDb.PersistenceMappers Property
PersistenceMapperMultiDb Class Eco.Persistence Namespace See Also
Collapse All
C#
public PersistenceMapperDbCollection PersistenceMappers;
Remarks

This is PersistenceMappers, a member of class PersistenceMapperMultiDb.

See Also
PersistenceMapperMultiDb Class
Eco.Persistence Namespace


PersistenceMapperMultiDb.TransactionMode Property

PersistenceMapperMultiDb.TransactionMode Property
PersistenceMapperMultiDb Class Eco.Persistence Namespace See Also
Collapse All

This property controls how transactions are handled when updates are perfomed

  • Disabled - No transactions are performed by Eco
  • Local - Only local transactions are used with each participating database. If one database fails to commit, others may already have committed, thus creating an inconsistency!
  • Distributed - Use Microsoft DTC to handle distributed transactions. This option also supports declarative transactions.
C#
public TransactionMode TransactionMode;
See Also
PersistenceMapperMultiDb Class
Eco.Persistence Namespace


PersistenceMapperMySql Class

PersistenceMapperMySql Class
Inheritance Hierarchy See Also
Collapse All

Persistencemapper using MySql Connector/Net MySqlConnection.

C#
public sealed class PersistenceMapperMySql : PersistenceMapperAdo2;
Inheritance Hierarchy
Eco.Persistence.IPersistencemapperProvider
    Eco.Persistence.PersistenceMapper
        Eco.Persistence.AbstractPersistenceMapperDb
        Eco.Persistence.IPersistenceMapperDb
            Eco.Persistence.PersistenceMapperDb
            Eco.Persistence.IAutoHookable
                Eco.Persistence.PersistenceMapperAdo2
                    Eco.Persistence.PersistenceMapperMySql
File

PersistenceMapperMySql.cs

See Also
Inheritance Hierarchy


PersistenceMapperMySql Methods

PersistenceMapperMySql Methods
Protected Methods Public Methods
Collapse All

The methods of the PersistenceMapperMySql class are listed here.

Protected Methods
Name | Description
ConnectionType | This is ConnectionType, a member of class PersistenceMapperMySql.
InternalCreateIDatabase | This is InternalCreateIDatabase, a member of class PersistenceMapperMySql.
Top
Public Methods
Name | Description
RegisterAttributeMappers | This is RegisterAttributeMappers, a member of class PersistenceMapperMySql.


PersistenceMapperMySql.ConnectionType Method

PersistenceMapperMySql.ConnectionType Method
PersistenceMapperMySql Class Eco.Persistence Namespace See Also
Collapse All
C#
protected override Type ConnectionType();
Remarks

This is ConnectionType, a member of class PersistenceMapperMySql.

See Also
PersistenceMapperMySql Class
Eco.Persistence Namespace


PersistenceMapperMySql.InternalCreateIDatabase Method

PersistenceMapperMySql.InternalCreateIDatabase Method
PersistenceMapperMySql Class Eco.Persistence Namespace See Also
Collapse All
C#
protected override IDatabase InternalCreateIDatabase(
    DbConnection connection,
    SqlDatabaseConfig config
);
Remarks

This is InternalCreateIDatabase, a member of class PersistenceMapperMySql.

See Also
PersistenceMapperMySql Class
Eco.Persistence Namespace


PersistenceMapperMySql.RegisterAttributeMappers Method

PersistenceMapperMySql.RegisterAttributeMappers Method
PersistenceMapperMySql Class Eco.Persistence Namespace See Also
Collapse All
C#
public static void RegisterAttributeMappers();
Remarks

This is RegisterAttributeMappers, a member of class PersistenceMapperMySql.

See Also
PersistenceMapperMySql Class
Eco.Persistence Namespace


PersistenceMapperMySql Properties

PersistenceMapperMySql Properties
Public Properties
Collapse All

The properties of the PersistenceMapperMySql class are listed here.

Public Properties
Name | Description
Connection | This is Connection, a member of class PersistenceMapperMySql.
UseInformationSchema | INFORMATION_SCHEMA is a standard way to describe meta data in a sql database. This is supported in MySql 5, but does not seem to work in MySql 4. Fallback is to use "SHOW TABLES" instead, this works in both MySql 4 and MySql 5


PersistenceMapperMySql.Connection Property

PersistenceMapperMySql.Connection Property
PersistenceMapperMySql Class Eco.Persistence Namespace See Also
Collapse All
C#
public MySqlConnection Connection;
Remarks

This is Connection, a member of class PersistenceMapperMySql.

See Also
PersistenceMapperMySql Class
Eco.Persistence Namespace


PersistenceMapperMySql.UseInformationSchema Property

PersistenceMapperMySql.UseInformationSchema Property
PersistenceMapperMySql Class Eco.Persistence Namespace See Also
Collapse All

INFORMATION_SCHEMA is a standard way to describe meta data in a sql database. This is supported in MySql 5, but does not seem to work in MySql 4. Fallback is to use "SHOW TABLES" instead, this works in both MySql 4 and MySql 5

C#
public bool UseInformationSchema;
See Also
PersistenceMapperMySql Class
Eco.Persistence Namespace


PersistenceMapperNexusDB Class

PersistenceMapperNexusDB Class
Inheritance Hierarchy See Also
Collapse All
C#
public class PersistenceMapperNexusDB : PersistenceMapperAdo2, IAutoHookable;
Remarks

This is class Eco.Persistence.PersistenceMapperNexusDB.

Inheritance Hierarchy
Eco.Persistence.IPersistencemapperProvider
    Eco.Persistence.PersistenceMapper
        Eco.Persistence.AbstractPersistenceMapperDb
        Eco.Persistence.IPersistenceMapperDb
            Eco.Persistence.PersistenceMapperDb
            Eco.Persistence.IAutoHookable
                Eco.Persistence.PersistenceMapperAdo2
                    Eco.Persistence.PersistenceMapperNexusDB
File

PersistenceMapperNexusDB.cs

See Also
Inheritance Hierarchy


PersistenceMapperNexusDB Methods

PersistenceMapperNexusDB Methods
Protected Methods Public Methods
Collapse All

The methods of the PersistenceMapperNexusDB class are listed here.

Protected Methods
Name | Description
ConnectionType | This is ConnectionType, a member of class PersistenceMapperNexusDB.
InternalCreateIDatabase | This is InternalCreateIDatabase, a member of class PersistenceMapperNexusDB.
SetSQLConfig | This is SetSQLConfig, a member of class PersistenceMapperNexusDB.
Top
Public Methods
Name | Description
InitializeSqlDatabaseConfig | This is InitializeSqlDatabaseConfig, a member of class PersistenceMapperNexusDB.


PersistenceMapperNexusDB.ConnectionType Method

PersistenceMapperNexusDB.ConnectionType Method
PersistenceMapperNexusDB Class Eco.Persistence Namespace See Also
Collapse All
C#
protected override Type ConnectionType();
Remarks

This is ConnectionType, a member of class PersistenceMapperNexusDB.

See Also
PersistenceMapperNexusDB Class
Eco.Persistence Namespace


PersistenceMapperNexusDB.InitializeSqlDatabaseConfig Method

PersistenceMapperNexusDB.InitializeSqlDatabaseConfig Method
PersistenceMapperNexusDB Class Eco.Persistence Namespace See Also
Collapse All
C#
public void InitializeSqlDatabaseConfig();
Remarks

This is InitializeSqlDatabaseConfig, a member of class PersistenceMapperNexusDB.

See Also
PersistenceMapperNexusDB Class
Eco.Persistence Namespace


PersistenceMapperNexusDB.InternalCreateIDatabase Method

PersistenceMapperNexusDB.InternalCreateIDatabase Method
PersistenceMapperNexusDB Class Eco.Persistence Namespace See Also
Collapse All
C#
protected override IDatabase InternalCreateIDatabase(
    DbConnection connection,
    SqlDatabaseConfig config
);
Remarks

This is InternalCreateIDatabase, a member of class PersistenceMapperNexusDB.

See Also
PersistenceMapperNexusDB Class
Eco.Persistence Namespace


PersistenceMapperNexusDB.SetSQLConfig Method

PersistenceMapperNexusDB.SetSQLConfig Method
PersistenceMapperNexusDB Class Eco.Persistence Namespace See Also
Collapse All
C#
protected void SetSQLConfig(
    SqlDatabaseConfig aConfig
);
Remarks

This is SetSQLConfig, a member of class PersistenceMapperNexusDB.

See Also
PersistenceMapperNexusDB Class
Eco.Persistence Namespace


PersistenceMapperNexusDB Properties

PersistenceMapperNexusDB Properties
Public Properties
Collapse All

The properties of the PersistenceMapperNexusDB class are listed here.

Public Properties
Name | Description
Connection | This is Connection, a member of class PersistenceMapperNexusDB.


PersistenceMapperNexusDB.Connection Property

PersistenceMapperNexusDB.Connection Property
PersistenceMapperNexusDB Class Eco.Persistence Namespace See Also
Collapse All
C#
public NxConnection Connection;
Remarks

This is Connection, a member of class PersistenceMapperNexusDB.

See Also
PersistenceMapperNexusDB Class
Eco.Persistence Namespace


PersistenceMapperOracle Class

PersistenceMapperOracle Class
Inheritance Hierarchy See Also
Collapse All

Persistencemapper using OracleConnection connections.

C#
public sealed class PersistenceMapperOracle : PersistenceMapperAdo2;
Inheritance Hierarchy
Eco.Persistence.IPersistencemapperProvider
    Eco.Persistence.PersistenceMapper
        Eco.Persistence.AbstractPersistenceMapperDb
        Eco.Persistence.IPersistenceMapperDb
            Eco.Persistence.PersistenceMapperDb
            Eco.Persistence.IAutoHookable
                Eco.Persistence.PersistenceMapperAdo2
                    Eco.Persistence.PersistenceMapperOracle
File

PersistenceMapperOracle.cs

See Also
Inheritance Hierarchy


PersistenceMapperOracle Methods

PersistenceMapperOracle Methods
Protected Methods Public Methods
Collapse All

The methods of the PersistenceMapperOracle class are listed here.

Protected Methods
Name | Description
ConnectionType | This is ConnectionType, a member of class PersistenceMapperOracle.
InternalCreateIDatabase | This is InternalCreateIDatabase, a member of class PersistenceMapperOracle.
Top
Public Methods
Name | Description
RegisterAttributeMappers | This is RegisterAttributeMappers, a member of class PersistenceMapperOracle.


PersistenceMapperOracle.ConnectionType Method

PersistenceMapperOracle.ConnectionType Method
PersistenceMapperOracle Class Eco.Persistence Namespace See Also
Collapse All
C#
protected override Type ConnectionType();
Remarks

This is ConnectionType, a member of class PersistenceMapperOracle.

See Also
PersistenceMapperOracle Class
Eco.Persistence Namespace


PersistenceMapperOracle.InternalCreateIDatabase Method

PersistenceMapperOracle.InternalCreateIDatabase Method
PersistenceMapperOracle Class Eco.Persistence Namespace See Also
Collapse All
C#
protected override IDatabase InternalCreateIDatabase(
    DbConnection connection,
    SqlDatabaseConfig config
);
Remarks

This is InternalCreateIDatabase, a member of class PersistenceMapperOracle.

See Also
PersistenceMapperOracle Class
Eco.Persistence Namespace


PersistenceMapperOracle.RegisterAttributeMappers Method

PersistenceMapperOracle.RegisterAttributeMappers Method
PersistenceMapperOracle Class Eco.Persistence Namespace See Also
Collapse All
C#
public static void RegisterAttributeMappers();
Remarks

This is RegisterAttributeMappers, a member of class PersistenceMapperOracle.

See Also
PersistenceMapperOracle Class
Eco.Persistence Namespace


PersistenceMapperOracle Properties

PersistenceMapperOracle Properties
Public Properties
Collapse All

The properties of the PersistenceMapperOracle class are listed here.

Public Properties
Name | Description
Connection | This is Connection, a member of class PersistenceMapperOracle.


PersistenceMapperOracle.Connection Property

PersistenceMapperOracle.Connection Property
PersistenceMapperOracle Class Eco.Persistence Namespace See Also
Collapse All
C#
public OracleConnection Connection;
Remarks

This is Connection, a member of class PersistenceMapperOracle.

See Also
PersistenceMapperOracle Class
Eco.Persistence Namespace


PersistenceMapperProvider Class

PersistenceMapperProvider Class
Inheritance Hierarchy See Also
Collapse All
C#
public class PersistenceMapperProvider : Component, IRemotePersistenceMapperProvider, IPersistencemapperProvider;
Remarks

This is class Eco.Persistence.PersistenceMapperProvider.

Inheritance Hierarchy
Eco.Persistence.IPersistencemapperProvider
Eco.Persistence.IRemotePersistenceMapperProvider
    Eco.Persistence.PersistenceMapperProvider
File

PersistenceMapperProvider.cs

See Also
Inheritance Hierarchy


PersistenceMapperProvider.PersistenceMapperProvider Constructor

PersistenceMapperProvider.PersistenceMapperProvider Constructor
PersistenceMapperProvider Class Eco.Persistence Namespace See Also
Collapse All
C#
public PersistenceMapperProvider();
Remarks

This is PersistenceMapperProvider, a member of class PersistenceMapperProvider.

See Also
PersistenceMapperProvider Class
Eco.Persistence Namespace


PersistenceMapperProvider Methods

PersistenceMapperProvider Methods
Protected Methods Public Methods
Collapse All

The methods of the PersistenceMapperProvider class are listed here.

Protected Methods
Name | Description
CreatePersistenceMapper | Use this method to dynamically create persistencemappers using a providername that has been registered with RegisterPersistenceMapper
RegisterPersistenceMapper | Registers PersistenceMapperProvider types in a registry so they can be easily dynamically created with the CreatePersistenceMapper method
Top
Public Methods
Name | Description
GetInstance | This is the overview for the GetInstance method overload.
GetPersistenceMapper |
GetTypeSystemService |
InitializeLifetimeService | This is InitializeLifetimeService, a member of class PersistenceMapperProvider.
ReturnPersistenceMapper |


PersistenceMapperProvider.CreatePersistenceMapper Method

PersistenceMapperProvider.CreatePersistenceMapper Method
PersistenceMapperProvider Class Eco.Persistence Namespace Example See Also
Collapse All

Use this method to dynamically create persistencemappers using a providername that has been registered with RegisterPersistenceMapper

C#
protected PersistenceMapperAdo2 CreatePersistenceMapper(
    string providerName,
    string connectionString
);
Parameters
Parameters | Description
providerName | The name of the provider
connectionString | The connection string to set in the PersistenceMapper
Returns

A preconfigured PersistenceMapper

Remarks

When the PersistenceMapper is created it can be set as the PersistenceMapper of the PMP.

Example

public EcoProject135PMP(): base() { this.InitializeComponent(); RegisterPersistenceMapper<PersistenceMapperSqlServer>("SqlServer", DataBaseEngine.SqlServerSqlClient); RegisterPersistenceMapper<PersistenceMapperOracle>("Oracle", DataBaseEngine.OracleClient);

string providerName = ... read provider name from config-file string connectionString = ... read connectionstring from config-file this.PersistenceMapper = CreatePersistenceMapper(providerName, connectionString);

See Also
PersistenceMapperProvider Class
Eco.Persistence Namespace
Example


GetInstance Method

GetInstance Method

This is the overview for the GetInstance method overload.

Overload List
Name | Description
PersistenceMapperProvider.GetInstance () | This is GetInstance, a member of class PersistenceMapperProvider.
PersistenceMapperProvider.GetInstance (Type) |


PersistenceMapperProvider.GetInstance Method ()

PersistenceMapperProvider.GetInstance Method ()
PersistenceMapperProvider Class Eco.Persistence Namespace See Also
Collapse All
C#
public static T GetInstance<T>() where T : class;
Remarks

This is GetInstance, a member of class PersistenceMapperProvider.

See Also
PersistenceMapperProvider Class
Eco.Persistence Namespace


PersistenceMapperProvider.GetInstance Method (Type)

PersistenceMapperProvider.GetInstance Method (Type)
PersistenceMapperProvider Class Eco.Persistence Namespace See Also
Collapse All
C#
public static PersistenceMapperProvider GetInstance(
    Type mapperType
);
Exceptions
Exceptions | Description
ArgumentNullException | Thrown if mapperType is null
ArgumentException | Thrown if mapperType is not a subclass of PersistenceMapperProvider.
See Also
PersistenceMapperProvider Class
Eco.Persistence Namespace


PersistenceMapperProvider.GetPersistenceMapper Method

PersistenceMapperProvider.GetPersistenceMapper Method
PersistenceMapperProvider Class Eco.Persistence Namespace See Also
Collapse All
C#
public IPersistenceMapper GetPersistenceMapper(
    ITypeSystemService typeSystemService
);
Exceptions
Exceptions | Description
InvalidOperationException | Thrown if PersistenceMapper is null.
ArgumentException | Thrown if the provider is in use with another ITypeSystemService.
See Also
PersistenceMapperProvider Class
Eco.Persistence Namespace


PersistenceMapperProvider.GetTypeSystemService Method

PersistenceMapperProvider.GetTypeSystemService Method
PersistenceMapperProvider Class Eco.Persistence Namespace See Also
Collapse All
C#
public ITypeSystemService GetTypeSystemService(
    bool required
);
Exceptions
Exceptions | Description
InvalidOperationException | Thrown if required is true and EcoSpaceType not set. Thrown if the method GetTypeSystemService is not defined. Thrown if the return value from GetTypeSystemService is not an IEcoServiceProvider.
See Also
PersistenceMapperProvider Class
Eco.Persistence Namespace


PersistenceMapperProvider.InitializeLifetimeService Method

PersistenceMapperProvider.InitializeLifetimeService Method
PersistenceMapperProvider Class Eco.Persistence Namespace See Also
Collapse All
C#
public override Object InitializeLifetimeService();
Remarks

This is InitializeLifetimeService, a member of class PersistenceMapperProvider.

See Also
PersistenceMapperProvider Class
Eco.Persistence Namespace


PersistenceMapperProvider.RegisterPersistenceMapper Method

PersistenceMapperProvider.RegisterPersistenceMapper Method
PersistenceMapperProvider Class Eco.Persistence Namespace Example See Also
Collapse All

Registers PersistenceMapperProvider types in a registry so they can be easily dynamically created with the CreatePersistenceMapper method

C#
protected void RegisterPersistenceMapper<T>(
    string providerName,
    DataBaseEngine dbEngine
) where T : PersistenceMapperAdo2;
Parameters
Parameters | Description
providerName | The name the mapper should be registered as
dbEngine | The DataBaseEngine enum that should be used to preconfigure the mapper settings
Remarks

The type of a PersistenceMapper (must be a subclass of PersistenceMapperAdo2)

Example

In the constructor of the PersistenceMapperProvider in a project, you could register mappers like this: public EcoProject135PMP(): base() { this.InitializeComponent(); RegisterPersistenceMapper<PersistenceMapperSqlServer>("SqlServer", DataBaseEngine.SqlServerSqlClient); RegisterPersistenceMapper<PersistenceMapperOracle>("Oracle", DataBaseEngine.OracleClient);

See Also
PersistenceMapperProvider Class
Eco.Persistence Namespace
Example


PersistenceMapperProvider.ReturnPersistenceMapper Method

PersistenceMapperProvider.ReturnPersistenceMapper Method
PersistenceMapperProvider Class Eco.Persistence Namespace See Also
Collapse All
C#
public void ReturnPersistenceMapper(
    IPersistenceMapper persistenceMapper
);
Exceptions
Exceptions | Description
InvalidOperationException | Thrown if PersistenceMapper is null.
See Also
PersistenceMapperProvider Class
Eco.Persistence Namespace


PersistenceMapperProvider Properties

PersistenceMapperProvider Properties
Public Properties
Collapse All

The properties of the PersistenceMapperProvider class are listed here.

Public Properties
Name | Description
EcoSpaceType | This is EcoSpaceType, a member of class PersistenceMapperProvider.
EcoSpaceTypeName | This is EcoSpaceTypeName, a member of class PersistenceMapperProvider.
PersistenceMapper | The PersistenceMapper is used to store objects in a database or Xml-file.


PersistenceMapperProvider.EcoSpaceType Property

PersistenceMapperProvider.EcoSpaceType Property
PersistenceMapperProvider Class Eco.Persistence Namespace See Also
Collapse All
C#
public System.Type EcoSpaceType;
Remarks

This is EcoSpaceType, a member of class PersistenceMapperProvider.

See Also
PersistenceMapperProvider Class
Eco.Persistence Namespace


PersistenceMapperProvider.EcoSpaceTypeName Property

PersistenceMapperProvider.EcoSpaceTypeName Property
PersistenceMapperProvider Class Eco.Persistence Namespace See Also
Collapse All
C#
public string EcoSpaceTypeName;
Remarks

This is EcoSpaceTypeName, a member of class PersistenceMapperProvider.

See Also
PersistenceMapperProvider Class
Eco.Persistence Namespace


PersistenceMapperProvider.PersistenceMapper Property

PersistenceMapperProvider.PersistenceMapper Property
PersistenceMapperProvider Class Eco.Persistence Namespace See Also
Collapse All

The PersistenceMapper is used to store objects in a database or Xml-file.

C#
public PersistenceMapper PersistenceMapper;
Remarks

It is possible to use any PersistenceMapper component to store the objects, and while developing a prototype, it can be convenient to use a PersistenceMapperXml, but when deploying a multiuser application it is highly recommended to use a persistencemapper that stores the objects in a relational database for scalability.

See Also
PersistenceMapperProvider Class
Eco.Persistence Namespace


PersistenceMapperSharer Class

PersistenceMapperSharer Class
Inheritance Hierarchy See Also
Collapse All
C#
public class PersistenceMapperSharer : PersistenceMapper;
Remarks

This is class Eco.Persistence.PersistenceMapperSharer.

Inheritance Hierarchy
Eco.Persistence.IPersistencemapperProvider
    Eco.Persistence.PersistenceMapper
        Eco.Persistence.PersistenceMapperSharer
File

PersistenceMapperSharer.cs

See Also
Inheritance Hierarchy


PersistenceMapperSharer Methods

PersistenceMapperSharer Methods
Public Methods
Collapse All

The methods of the PersistenceMapperSharer class are listed here.

Public Methods
Name | Description
GetPersistenceMapper | This is GetPersistenceMapper, a member of class PersistenceMapperSharer.
ReturnPersistenceMapper | This is ReturnPersistenceMapper, a member of class PersistenceMapperSharer.


PersistenceMapperSharer.GetPersistenceMapper Method

PersistenceMapperSharer.GetPersistenceMapper Method
PersistenceMapperSharer Class Eco.Persistence Namespace See Also
Collapse All
C#
public override IPersistenceMapper GetPersistenceMapper(
    ITypeSystemService typeSystemService
);
Remarks

This is GetPersistenceMapper, a member of class PersistenceMapperSharer.

See Also
PersistenceMapperSharer Class
Eco.Persistence Namespace


PersistenceMapperSharer.ReturnPersistenceMapper Method

PersistenceMapperSharer.ReturnPersistenceMapper Method
PersistenceMapperSharer Class Eco.Persistence Namespace See Also
Collapse All
C#
public override void ReturnPersistenceMapper(
    IPersistenceMapper persistenceMapper
);
Remarks

This is ReturnPersistenceMapper, a member of class PersistenceMapperSharer.

See Also
PersistenceMapperSharer Class
Eco.Persistence Namespace


PersistenceMapperSharer Properties

PersistenceMapperSharer Properties
Public Properties
Collapse All

The properties of the PersistenceMapperSharer class are listed here.

Public Properties
Name | Description
MapperProviderType | This is MapperProviderType, a member of class PersistenceMapperSharer.
MapperProviderTypeName |


PersistenceMapperSharer.MapperProviderType Property

PersistenceMapperSharer.MapperProviderType Property
PersistenceMapperSharer Class Eco.Persistence Namespace See Also
Collapse All
C#
public System.Type MapperProviderType;
Remarks

This is MapperProviderType, a member of class PersistenceMapperSharer.

See Also
PersistenceMapperSharer Class
Eco.Persistence Namespace


PersistenceMapperSharer.MapperProviderTypeName Property

PersistenceMapperSharer.MapperProviderTypeName Property
PersistenceMapperSharer Class Eco.Persistence Namespace See Also
Collapse All
C#
public string MapperProviderTypeName;
Exceptions
Exceptions | Description
InvalidOperationException | Thrown if trying to set the property when the sharing has started.
See Also
PersistenceMapperSharer Class
Eco.Persistence Namespace


PersistenceMapperSQLite Class

PersistenceMapperSQLite Class
Inheritance Hierarchy See Also
Collapse All
C#
public sealed class PersistenceMapperSQLite : PersistenceMapperAdo2;
Remarks

This is class Eco.Persistence.PersistenceMapperSQLite.

Inheritance Hierarchy
Eco.Persistence.IPersistencemapperProvider
    Eco.Persistence.PersistenceMapper
        Eco.Persistence.AbstractPersistenceMapperDb
        Eco.Persistence.IPersistenceMapperDb
            Eco.Persistence.PersistenceMapperDb
            Eco.Persistence.IAutoHookable
                Eco.Persistence.PersistenceMapperAdo2
                    Eco.Persistence.PersistenceMapperSQLite
File

PersistenceMapperSQLite.cs

See Also
Inheritance Hierarchy


PersistenceMapperSQLite.PersistenceMapperSQLite Constructor

PersistenceMapperSQLite.PersistenceMapperSQLite Constructor
PersistenceMapperSQLite Class Eco.Persistence Namespace See Also
Collapse All
C#
public PersistenceMapperSQLite();
Remarks

This is PersistenceMapperSQLite, a member of class PersistenceMapperSQLite.

See Also
PersistenceMapperSQLite Class
Eco.Persistence Namespace


PersistenceMapperSQLite Methods

PersistenceMapperSQLite Methods
Protected Methods Public Methods
Collapse All

The methods of the PersistenceMapperSQLite class are listed here.

Protected Methods
Name | Description
ConnectionType | This is ConnectionType, a member of class PersistenceMapperSQLite.
InternalCreateIDatabase | This is InternalCreateIDatabase, a member of class PersistenceMapperSQLite.
Top
Public Methods
Name | Description
InitializeSqlDatabaseConfig | This is the overview for the InitializeSqlDatabaseConfig method overload.


PersistenceMapperSQLite.ConnectionType Method

PersistenceMapperSQLite.ConnectionType Method
PersistenceMapperSQLite Class Eco.Persistence Namespace See Also
Collapse All
C#
protected override Type ConnectionType();
Remarks

This is ConnectionType, a member of class PersistenceMapperSQLite.

See Also
PersistenceMapperSQLite Class
Eco.Persistence Namespace


InitializeSqlDatabaseConfig Method

InitializeSqlDatabaseConfig Method

This is the overview for the InitializeSqlDatabaseConfig method overload.

Overload List
Name | Description
PersistenceMapperSQLite.InitializeSqlDatabaseConfig () | This is InitializeSqlDatabaseConfig, a member of class PersistenceMapperSQLite.
PersistenceMapperSQLite.InitializeSqlDatabaseConfig (SqlDatabaseConfig) | This is InitializeSqlDatabaseConfig, a member of class PersistenceMapperSQLite.


PersistenceMapperSQLite.InitializeSqlDatabaseConfig Method ()

PersistenceMapperSQLite.InitializeSqlDatabaseConfig Method ()
PersistenceMapperSQLite Class Eco.Persistence Namespace See Also
Collapse All
C#
public void InitializeSqlDatabaseConfig();
Remarks

This is InitializeSqlDatabaseConfig, a member of class PersistenceMapperSQLite.

See Also
PersistenceMapperSQLite Class
Eco.Persistence Namespace


PersistenceMapperSQLite.InitializeSqlDatabaseConfig Method (SqlDatabaseConfig)

PersistenceMapperSQLite.InitializeSqlDatabaseConfig Method (SqlDatabaseConfig)
PersistenceMapperSQLite Class Eco.Persistence Namespace See Also
Collapse All
C#
public static void InitializeSqlDatabaseConfig(
    SqlDatabaseConfig config
);
Remarks

This is InitializeSqlDatabaseConfig, a member of class PersistenceMapperSQLite.

See Also
PersistenceMapperSQLite Class
Eco.Persistence Namespace


PersistenceMapperSQLite.InternalCreateIDatabase Method

PersistenceMapperSQLite.InternalCreateIDatabase Method
PersistenceMapperSQLite Class Eco.Persistence Namespace See Also
Collapse All
C#
protected override IDatabase InternalCreateIDatabase(
    DbConnection connection,
    SqlDatabaseConfig config
);
Remarks

This is InternalCreateIDatabase, a member of class PersistenceMapperSQLite.

See Also
PersistenceMapperSQLite Class
Eco.Persistence Namespace


PersistenceMapperSQLite Properties

PersistenceMapperSQLite Properties
Public Properties
Collapse All

The properties of the PersistenceMapperSQLite class are listed here.

Public Properties
Name | Description
Connection | This is Connection, a member of class PersistenceMapperSQLite.


PersistenceMapperSQLite.Connection Property

PersistenceMapperSQLite.Connection Property
PersistenceMapperSQLite Class Eco.Persistence Namespace See Also
Collapse All
C#
public SQLiteConnection Connection;
Remarks

This is Connection, a member of class PersistenceMapperSQLite.

See Also
PersistenceMapperSQLite Class
Eco.Persistence Namespace


PersistenceMapperSqlServer Class

PersistenceMapperSqlServer Class
Inheritance Hierarchy See Also
Collapse All

Persistencemapper using Microsoft SqlConnection connections.

C#
public sealed class PersistenceMapperSqlServer : PersistenceMapperAdo2;
Inheritance Hierarchy
Eco.Persistence.IPersistencemapperProvider
    Eco.Persistence.PersistenceMapper
        Eco.Persistence.AbstractPersistenceMapperDb
        Eco.Persistence.IPersistenceMapperDb
            Eco.Persistence.PersistenceMapperDb
            Eco.Persistence.IAutoHookable
                Eco.Persistence.PersistenceMapperAdo2
                    Eco.Persistence.PersistenceMapperSqlServer
File

PersistenceMapperSqlServer.cs

See Also
Inheritance Hierarchy


PersistenceMapperSqlServer Methods

PersistenceMapperSqlServer Methods
Protected Methods Public Methods
Collapse All

The methods of the PersistenceMapperSqlServer class are listed here.

Protected Methods
Name | Description
ConnectionType | This is ConnectionType, a member of class PersistenceMapperSqlServer.
InternalCreateIDatabase | This is InternalCreateIDatabase, a member of class PersistenceMapperSqlServer.
Top
Public Methods
Name | Description
RegisterAttributeMappers | This is RegisterAttributeMappers, a member of class PersistenceMapperSqlServer.


PersistenceMapperSqlServer.ConnectionType Method

PersistenceMapperSqlServer.ConnectionType Method
PersistenceMapperSqlServer Class Eco.Persistence Namespace See Also
Collapse All
C#
protected override Type ConnectionType();
Remarks

This is ConnectionType, a member of class PersistenceMapperSqlServer.

See Also
PersistenceMapperSqlServer Class
Eco.Persistence Namespace


PersistenceMapperSqlServer.InternalCreateIDatabase Method

PersistenceMapperSqlServer.InternalCreateIDatabase Method
PersistenceMapperSqlServer Class Eco.Persistence Namespace See Also
Collapse All
C#
protected override IDatabase InternalCreateIDatabase(
    DbConnection connection,
    SqlDatabaseConfig config
);
Remarks

This is InternalCreateIDatabase, a member of class PersistenceMapperSqlServer.

See Also
PersistenceMapperSqlServer Class
Eco.Persistence Namespace


PersistenceMapperSqlServer.RegisterAttributeMappers Method

PersistenceMapperSqlServer.RegisterAttributeMappers Method
PersistenceMapperSqlServer Class Eco.Persistence Namespace See Also
Collapse All
C#
public static void RegisterAttributeMappers();
Remarks

This is RegisterAttributeMappers, a member of class PersistenceMapperSqlServer.

See Also
PersistenceMapperSqlServer Class
Eco.Persistence Namespace


PersistenceMapperSqlServer Properties

PersistenceMapperSqlServer Properties
Public Properties
Collapse All

The properties of the PersistenceMapperSqlServer class are listed here.

Public Properties
Name | Description
Connection | This is Connection, a member of class PersistenceMapperSqlServer.
ConnectionString | This is ConnectionString, a member of class PersistenceMapperSqlServer.


PersistenceMapperSqlServer.Connection Property

PersistenceMapperSqlServer.Connection Property
PersistenceMapperSqlServer Class Eco.Persistence Namespace See Also
Collapse All
C#
public SqlConnection Connection;
Remarks

This is Connection, a member of class PersistenceMapperSqlServer.

See Also
PersistenceMapperSqlServer Class
Eco.Persistence Namespace


PersistenceMapperSqlServer.ConnectionString Property

PersistenceMapperSqlServer.ConnectionString Property
PersistenceMapperSqlServer Class Eco.Persistence Namespace See Also
Collapse All
C#
public override string ConnectionString;
Remarks

This is ConnectionString, a member of class PersistenceMapperSqlServer.

See Also
PersistenceMapperSqlServer Class
Eco.Persistence Namespace


PersistenceMapperSybase Class

PersistenceMapperSybase Class
Inheritance Hierarchy See Also
Collapse All
C#
public sealed class PersistenceMapperSybase : PersistenceMapperDb, IAutoHookable;
Remarks

This is class Eco.Persistence.PersistenceMapperSybase.

Inheritance Hierarchy
Eco.Persistence.IPersistencemapperProvider
    Eco.Persistence.PersistenceMapper
        Eco.Persistence.AbstractPersistenceMapperDb
        Eco.Persistence.IPersistenceMapperDb
            Eco.Persistence.PersistenceMapperDb
            Eco.Persistence.IAutoHookable
                Eco.Persistence.PersistenceMapperSybase
File

PersistenceMapperSybase.cs

See Also
Inheritance Hierarchy


PersistenceMapperSybase.PersistenceMapperSybase Constructor

PersistenceMapperSybase.PersistenceMapperSybase Constructor
PersistenceMapperSybase Class Eco.Persistence Namespace See Also
Collapse All
C#
public PersistenceMapperSybase();
Remarks

This is PersistenceMapperSybase, a member of class PersistenceMapperSybase.

See Also
PersistenceMapperSybase Class
Eco.Persistence Namespace


PersistenceMapperSybase Methods

PersistenceMapperSybase Methods
Protected Methods Public Methods
Collapse All

The methods of the PersistenceMapperSybase class are listed here.

Protected Methods
Name | Description
MakeDatabase |
ReturnDatabase | Reachable by connectionpool
Top
Public Methods
Name | Description
InitializeSqlDatabaseConfig | This is InitializeSqlDatabaseConfig, a member of class PersistenceMapperSybase.


PersistenceMapperSybase.InitializeSqlDatabaseConfig Method

PersistenceMapperSybase.InitializeSqlDatabaseConfig Method
PersistenceMapperSybase Class Eco.Persistence Namespace See Also
Collapse All
C#
public void InitializeSqlDatabaseConfig();
Remarks

This is InitializeSqlDatabaseConfig, a member of class PersistenceMapperSybase.

See Also
PersistenceMapperSybase Class
Eco.Persistence Namespace


PersistenceMapperSybase.MakeDatabase Method

PersistenceMapperSybase.MakeDatabase Method
PersistenceMapperSybase Class Eco.Persistence Namespace See Also
Collapse All
C#
protected override IDatabase MakeDatabase();
Exceptions
Exceptions | Description
InvalidOperationException | Thrown if Connection is null.
See Also
PersistenceMapperSybase Class
Eco.Persistence Namespace


PersistenceMapperSybase.ReturnDatabase Method

PersistenceMapperSybase.ReturnDatabase Method
PersistenceMapperSybase Class Eco.Persistence Namespace See Also
Collapse All
C#
protected override void ReturnDatabase(
    IDatabase database
);
Remarks

Reachable by connectionpool

See Also
PersistenceMapperSybase Class
Eco.Persistence Namespace


PersistenceMapperSybase Properties

PersistenceMapperSybase Properties
Public Properties
Collapse All

The properties of the PersistenceMapperSybase class are listed here.

Public Properties
Name | Description
Connection | This is Connection, a member of class PersistenceMapperSybase.
HasConnection | This is HasConnection, a member of class PersistenceMapperSybase.


PersistenceMapperSybase.Connection Property

PersistenceMapperSybase.Connection Property
PersistenceMapperSybase Class Eco.Persistence Namespace See Also
Collapse All
C#
public AseConnection Connection;
Remarks

This is Connection, a member of class PersistenceMapperSybase.

See Also
PersistenceMapperSybase Class
Eco.Persistence Namespace


PersistenceMapperSybase.HasConnection Property

PersistenceMapperSybase.HasConnection Property
PersistenceMapperSybase Class Eco.Persistence Namespace See Also
Collapse All
C#
public override bool HasConnection;
Remarks

This is HasConnection, a member of class PersistenceMapperSybase.

See Also
PersistenceMapperSybase Class
Eco.Persistence Namespace


PersistenceMapperXml Class

PersistenceMapperXml Class
Inheritance Hierarchy See Also
Collapse All

This PersistenceMapper stores the data of the domain objects in an xml-file.

C#
public class PersistenceMapperXml : AbstractPersistenceMapperFile;
Remarks

This component is a lightweight alternative to the persistencemappers that stores data in relational databases. It stores the data in a human readable xml-file. In addition to the data, it also stores some model information to be able to handle changes in the model. Renames, additions and deletes of model elements are handled automatically.

PersistenceMapperXml supports most of the features of the persistence mappers for relational databases, including OclPSHandle, autoinc attributes, synchronization, optimistic locking.

The save-format is human readable xml, but the persistence mapper also supports reading the old (EcoIII) format that was a simple serialization of a Datablock.

If this component is to be used in a web-server running under IIS, the name of the xmlfile must be //server/folder/file.xml

Second you have to give the write permission to the file in the IIS configuration and in the OS security of the file.

Please remember that PersistenceMapperXml is mainly intended for the prototype phase of the project. It does not scale well (at all) when the amount of data increases. Switch to one of the database-related persistencemappers for production.

Inheritance Hierarchy
Eco.Persistence.IPersistencemapperProvider
    Eco.Persistence.PersistenceMapper
    Eco.Persistence.IPersistenceMapper
        Eco.Persistence.AbstractDataBlockPersistenceMapper
            Eco.Persistence.AbstractPersistenceMapperFile
                Eco.Persistence.PersistenceMapperXml
File

PersistenceMapperXML.cs

See Also
Inheritance Hierarchy


PersistenceMapperXml Methods

PersistenceMapperXml Methods
Protected Methods
Collapse All

The methods of the PersistenceMapperXml class are listed here.

Protected Methods
Name | Description
LoadXml | This is LoadXml, a member of class PersistenceMapperXml.
ReadDatablock | This is ReadDatablock, a member of class PersistenceMapperXml.
StoreXml | This is StoreXml, a member of class PersistenceMapperXml.
WriteDatablock | This is WriteDatablock, a member of class PersistenceMapperXml.


PersistenceMapperXml.LoadXml Method

PersistenceMapperXml.LoadXml Method
PersistenceMapperXml Class Eco.Persistence Namespace See Also
Collapse All
C#
protected virtual XmlDocument LoadXml();
Remarks

This is LoadXml, a member of class PersistenceMapperXml.

See Also
PersistenceMapperXml Class
Eco.Persistence Namespace


PersistenceMapperXml.ReadDatablock Method

PersistenceMapperXml.ReadDatablock Method
PersistenceMapperXml Class Eco.Persistence Namespace See Also
Collapse All
C#
protected override Datablock ReadDatablock();
Remarks

This is ReadDatablock, a member of class PersistenceMapperXml.

See Also
PersistenceMapperXml Class
Eco.Persistence Namespace


PersistenceMapperXml.StoreXml Method

PersistenceMapperXml.StoreXml Method
PersistenceMapperXml Class Eco.Persistence Namespace See Also
Collapse All
C#
protected virtual void StoreXml(
    XmlDocument doc
);
Remarks

This is StoreXml, a member of class PersistenceMapperXml.

See Also
PersistenceMapperXml Class
Eco.Persistence Namespace


PersistenceMapperXml.WriteDatablock Method

PersistenceMapperXml.WriteDatablock Method
PersistenceMapperXml Class Eco.Persistence Namespace See Also
Collapse All
C#
protected override void WriteDatablock(
    Datablock datablock
);
Remarks

This is WriteDatablock, a member of class PersistenceMapperXml.

See Also
PersistenceMapperXml Class
Eco.Persistence Namespace


PersistenceMapperXml Properties

PersistenceMapperXml Properties
Public Properties
Collapse All

The properties of the PersistenceMapperXml class are listed here.

Public Properties
Name | Description
DebugMode | When DebugMode is true, the xml-conversion routines will check that any value that is converted to a string can be converted back to the same value. if this conversion fails, an exception will be raised. The user then has to implement a conversion event to handle this specific datatype.
StrictParsing | Strict parsing means that unknown elements in the xml-file will result in an exception when the xml is loaded. If strict = false then all unknown elements will be silently ignored. This happens if you have for example removed an attribute/class from the model.


PersistenceMapperXml.DebugMode Property

PersistenceMapperXml.DebugMode Property
PersistenceMapperXml Class Eco.Persistence Namespace See Also
Collapse All

When DebugMode is true, the xml-conversion routines will check that any value that is converted to a string can be converted back to the same value. if this conversion fails, an exception will be raised. The user then has to implement a conversion event to handle this specific datatype.

C#
public bool DebugMode;
See Also
PersistenceMapperXml Class
Eco.Persistence Namespace


PersistenceMapperXml.StrictParsing Property

PersistenceMapperXml.StrictParsing Property
PersistenceMapperXml Class Eco.Persistence Namespace See Also
Collapse All

Strict parsing means that unknown elements in the xml-file will result in an exception when the xml is loaded. If strict = false then all unknown elements will be silently ignored. This happens if you have for example removed an attribute/class from the model.

C#
public bool StrictParsing;
See Also
PersistenceMapperXml Class
Eco.Persistence Namespace


PersistenceStringRes Class

PersistenceStringRes Class
Inheritance Hierarchy See Also
Collapse All

Autogenerated class to get compiler safe access to resource strings.

C#
public sealed class PersistenceStringRes : StringResources;
Inheritance Hierarchy
Eco.Persistence.PersistenceStringRes
File

Eco.Persistence.Strings.cs

See Also
Inheritance Hierarchy


PersistenceStringRes Methods

PersistenceStringRes Methods
Public Methods
Collapse All

The methods of the PersistenceStringRes class are listed here.

Public Methods
Name | Description
DiscriminatorValueNotDefined | Returns: "Discriminator does not define this value: {0}"
EcoSpaceTypeNameCouldNotBeResolved | Returns: "EcoSpaceTypeName ("{0}") could not be resolved to a type-reference"
MismatchingModelChecksums | Returns: "Model checksum from client does not match the checksum on the server, please verify that the client and server uses the same model. rnServer checksum: {0} rnClient checksum: {1}"
ParamLogLine | Returns: "{0}: {1}({2}) - {3}"
sAttributeMapperNotDefinedForType | Returns: "There is no attribute mapper defined for the type {0}. Please update your PersistenceHandle.SqlDatabaseConfig"
sConnectionMissing | Returns: "The Connection of {0} is not set."
sCouldNotLoadAssembly | Returns: "Could not load {0}"
sDatabaseHasNoMappingInfo | Returns: "Database ({0}) has no mapping information. Use the "Save Mapping Information" tool (with a model and mapping that matches the current database) to insert mapping information in the database"
sErrorExecutingSql | Returns: "Error executing query: {0} rnSQL: {1}"
sErrorHandlingSql | Returns: "Error handling query: {0} rnSQL: {1}"
ServerEcoSpaceBuildTime | Returns: "The EcoSpace on the server was compiled {0}"
sExecSqlError | Returns: "ExecSQL error: {0} rnSQL: {1}rn{2} Parameters:"
sFailedToGetORMapping | Returns: "Failed to retrieve O/R mapping information from the database: {0}"
sGetTypeSystemServiceMissing | Returns: "{0} lacks GetTypeSystemService method."
sInt16AsNumber_CannotConvert | Returns: "Int16AsNumber: Unable to convert value: {0}"
sInt32AsNumber_CannotConvert | Returns: "Int32AsNumber: Unable to convert value: {0}"
sInvalidType | Returns: "Invalid type encountered while transforming data using {0}. Expected {1} but the value ({2}) was {3}. Check your settings in PersistenceMapper.SqlDatabaseConfig.PersistenceMappers"
sNoDatabaseWithName | Returns: "There is no database configured with the name {0}"
sNotATypeSystemProvider | Returns: "{0} is not ITypeSystemProvider."
sORMappingValidationFailed | Returns: "O/R mapping validation failed: {0}"
sPersistenceHandleDoesNotSupportOperation | Returns: "The persistence mapper connected to the ECO Space does not support operation: {0}"
sPersistenceMapperClientFailedToConnect | Returns: "PersistenceMapperClient failed to connect to the server. rnMessage: {1}rnServer URL: {0}"
sSuperclassIsNotPersistent | Returns: "Class {0} is persistent, but superclass {1} is transient"
sUnableToLoadFromFile | Returns: "Unable to load O/R mapping from file {0}"
sUnableToLoadFromResource | Returns: "Unable to load O/R mapping from resource {0}"
sUnknownPrimaryKeyCol | Returns: "Class {0} has a column in the PrimaryKey specification that isn't used by any attribute or embedded singlelink: {1}"
UnableToResolveMapperProviderType | Returns: "Unable to resolve PersistenceMapperSharer.MapperProviderType: "{0}". Does the PersistenceMapperProvider have a "RuntimeRequiredAttribute" defined?"
UnknownMapperTypeForOrMappingProvider | Returns: "Unknown mapper type for OrMappingProvider ({0})"
UnknownValueTypeInEcoOrMappingTable | Returns: "Unknown valuetype in {0} table ({1})"


PersistenceStringRes.DiscriminatorValueNotDefined Method

PersistenceStringRes.DiscriminatorValueNotDefined Method
PersistenceStringRes Class Eco.Persistence Namespace See Also
Collapse All

Returns: "Discriminator does not define this value: {0}"

C#
public static string DiscriminatorValueNotDefined(
    object param0
);
Remarks

For internal use.

See Also
PersistenceStringRes Class
Eco.Persistence Namespace


PersistenceStringRes.EcoSpaceTypeNameCouldNotBeResolved Method

PersistenceStringRes.EcoSpaceTypeNameCouldNotBeResolved Method
PersistenceStringRes Class Eco.Persistence Namespace See Also
Collapse All

Returns: "EcoSpaceTypeName ("{0}") could not be resolved to a type-reference"

C#
public static string EcoSpaceTypeNameCouldNotBeResolved(
    object param0
);
Remarks

For internal use.

See Also
PersistenceStringRes Class
Eco.Persistence Namespace


PersistenceStringRes.MismatchingModelChecksums Method

PersistenceStringRes.MismatchingModelChecksums Method
PersistenceStringRes Class Eco.Persistence Namespace See Also
Collapse All

Returns: "Model checksum from client does not match the checksum on the server, please verify that the client and server uses the same model. rnServer checksum: {0} rnClient checksum: {1}"

C#
public static string MismatchingModelChecksums(
    object param0,
    object param1
);
Remarks

For internal use.

See Also
PersistenceStringRes Class
Eco.Persistence Namespace


PersistenceStringRes.ParamLogLine Method

PersistenceStringRes.ParamLogLine Method
PersistenceStringRes Class Eco.Persistence Namespace See Also
Collapse All

Returns: "{0}: {1}({2}) - {3}"

C#
public static string ParamLogLine(
    object param0,
    object param1,
    object param2,
    object param3
);
Remarks

For internal use.

See Also
PersistenceStringRes Class
Eco.Persistence Namespace


PersistenceStringRes.sAttributeMapperNotDefinedForType Method

PersistenceStringRes.sAttributeMapperNotDefinedForType Method
PersistenceStringRes Class Eco.Persistence Namespace See Also
Collapse All

Returns: "There is no attribute mapper defined for the type {0}. Please update your PersistenceHandle.SqlDatabaseConfig"

C#
public static string sAttributeMapperNotDefinedForType(
    object param0
);
Remarks

For internal use.

See Also
PersistenceStringRes Class
Eco.Persistence Namespace


PersistenceStringRes.sConnectionMissing Method

PersistenceStringRes.sConnectionMissing Method
PersistenceStringRes Class Eco.Persistence Namespace See Also
Collapse All

Returns: "The Connection of {0} is not set."

C#
public static string sConnectionMissing(
    object param0
);
Remarks

For internal use.

See Also
PersistenceStringRes Class
Eco.Persistence Namespace


PersistenceStringRes.sCouldNotLoadAssembly Method

PersistenceStringRes.sCouldNotLoadAssembly Method
PersistenceStringRes Class Eco.Persistence Namespace See Also
Collapse All

Returns: "Could not load {0}"

C#
public static string sCouldNotLoadAssembly(
    object param0
);
Remarks

For internal use.

See Also
PersistenceStringRes Class
Eco.Persistence Namespace


PersistenceStringRes.sDatabaseHasNoMappingInfo Method

PersistenceStringRes.sDatabaseHasNoMappingInfo Method
PersistenceStringRes Class Eco.Persistence Namespace See Also
Collapse All

Returns: "Database ({0}) has no mapping information. Use the "Save Mapping Information" tool (with a model and mapping that matches the current database) to insert mapping information in the database"

C#
public static string sDatabaseHasNoMappingInfo(
    object param0
);
Remarks

For internal use.

See Also
PersistenceStringRes Class
Eco.Persistence Namespace


PersistenceStringRes.sErrorExecutingSql Method

PersistenceStringRes.sErrorExecutingSql Method
PersistenceStringRes Class Eco.Persistence Namespace See Also
Collapse All

Returns: "Error executing query: {0} rnSQL: {1}"

C#
public static string sErrorExecutingSql(
    object param0,
    object param1
);
Remarks

For internal use.

See Also
PersistenceStringRes Class
Eco.Persistence Namespace


PersistenceStringRes.sErrorHandlingSql Method

PersistenceStringRes.sErrorHandlingSql Method
PersistenceStringRes Class Eco.Persistence Namespace See Also
Collapse All

Returns: "Error handling query: {0} rnSQL: {1}"

C#
public static string sErrorHandlingSql(
    object param0,
    object param1
);
Remarks

For internal use.

See Also
PersistenceStringRes Class
Eco.Persistence Namespace


PersistenceStringRes.ServerEcoSpaceBuildTime Method

PersistenceStringRes.ServerEcoSpaceBuildTime Method
PersistenceStringRes Class Eco.Persistence Namespace See Also
Collapse All

Returns: "The EcoSpace on the server was compiled {0}"

C#
public static string ServerEcoSpaceBuildTime(
    object param0
);
Remarks

For internal use.

See Also
PersistenceStringRes Class
Eco.Persistence Namespace


PersistenceStringRes.sExecSqlError Method

PersistenceStringRes.sExecSqlError Method
PersistenceStringRes Class Eco.Persistence Namespace See Also
Collapse All

Returns: "ExecSQL error: {0} rnSQL: {1}rn{2} Parameters:"

C#
public static string sExecSqlError(
    object param0,
    object param1,
    object param2
);
Remarks

For internal use.

See Also
PersistenceStringRes Class
Eco.Persistence Namespace


PersistenceStringRes.sFailedToGetORMapping Method

PersistenceStringRes.sFailedToGetORMapping Method
PersistenceStringRes Class Eco.Persistence Namespace See Also
Collapse All

Returns: "Failed to retrieve O/R mapping information from the database: {0}"

C#
public static string sFailedToGetORMapping(
    object param0
);
Remarks

For internal use.

See Also
PersistenceStringRes Class
Eco.Persistence Namespace


PersistenceStringRes.sGetTypeSystemServiceMissing Method

PersistenceStringRes.sGetTypeSystemServiceMissing Method
PersistenceStringRes Class Eco.Persistence Namespace See Also
Collapse All

Returns: "{0} lacks GetTypeSystemService method."

C#
public static string sGetTypeSystemServiceMissing(
    object param0
);
Remarks

For internal use.

See Also
PersistenceStringRes Class
Eco.Persistence Namespace


PersistenceStringRes.sInt16AsNumber_CannotConvert Method

PersistenceStringRes.sInt16AsNumber_CannotConvert Method
PersistenceStringRes Class Eco.Persistence Namespace See Also
Collapse All

Returns: "Int16AsNumber: Unable to convert value: {0}"

C#
public static string sInt16AsNumber_CannotConvert(
    object param0
);
Remarks

For internal use.

See Also
PersistenceStringRes Class
Eco.Persistence Namespace


PersistenceStringRes.sInt32AsNumber_CannotConvert Method

PersistenceStringRes.sInt32AsNumber_CannotConvert Method
PersistenceStringRes Class Eco.Persistence Namespace See Also
Collapse All

Returns: "Int32AsNumber: Unable to convert value: {0}"

C#
public static string sInt32AsNumber_CannotConvert(
    object param0
);
Remarks

For internal use.

See Also
PersistenceStringRes Class
Eco.Persistence Namespace


PersistenceStringRes.sInvalidType Method

PersistenceStringRes.sInvalidType Method
PersistenceStringRes Class Eco.Persistence Namespace See Also
Collapse All

Returns: "Invalid type encountered while transforming data using {0}. Expected {1} but the value ({2}) was {3}. Check your settings in PersistenceMapper.SqlDatabaseConfig.PersistenceMappers"

C#
public static string sInvalidType(
    object param0,
    object param1,
    object param2,
    object param3
);
Remarks

For internal use.

See Also
PersistenceStringRes Class
Eco.Persistence Namespace


PersistenceStringRes.sNoDatabaseWithName Method

PersistenceStringRes.sNoDatabaseWithName Method
PersistenceStringRes Class Eco.Persistence Namespace See Also
Collapse All

Returns: "There is no database configured with the name {0}"

C#
public static string sNoDatabaseWithName(
    object param0
);
Remarks

For internal use.

See Also
PersistenceStringRes Class
Eco.Persistence Namespace


PersistenceStringRes.sNotATypeSystemProvider Method

PersistenceStringRes.sNotATypeSystemProvider Method
PersistenceStringRes Class Eco.Persistence Namespace See Also
Collapse All

Returns: "{0} is not ITypeSystemProvider."

C#
public static string sNotATypeSystemProvider(
    object param0
);
Remarks

For internal use.

See Also
PersistenceStringRes Class
Eco.Persistence Namespace


PersistenceStringRes.sORMappingValidationFailed Method

PersistenceStringRes.sORMappingValidationFailed Method
PersistenceStringRes Class Eco.Persistence Namespace See Also
Collapse All

Returns: "O/R mapping validation failed: {0}"

C#
public static string sORMappingValidationFailed(
    object param0
);
Remarks

For internal use.

See Also
PersistenceStringRes Class
Eco.Persistence Namespace


PersistenceStringRes.sPersistenceHandleDoesNotSupportOperation Method

PersistenceStringRes.sPersistenceHandleDoesNotSupportOperation Method
PersistenceStringRes Class Eco.Persistence Namespace See Also
Collapse All

Returns: "The persistence mapper connected to the ECO Space does not support operation: {0}"

C#
public static string sPersistenceHandleDoesNotSupportOperation(
    object param0
);
Remarks

For internal use.

See Also
PersistenceStringRes Class
Eco.Persistence Namespace


PersistenceStringRes.sPersistenceMapperClientFailedToConnect Method

PersistenceStringRes.sPersistenceMapperClientFailedToConnect Method
PersistenceStringRes Class Eco.Persistence Namespace See Also
Collapse All

Returns: "PersistenceMapperClient failed to connect to the server. rnMessage: {1}rnServer URL: {0}"

C#
public static string sPersistenceMapperClientFailedToConnect(
    object param0,
    object param1
);
Remarks

For internal use.

See Also
PersistenceStringRes Class
Eco.Persistence Namespace


PersistenceStringRes.sSuperclassIsNotPersistent Method

PersistenceStringRes.sSuperclassIsNotPersistent Method
PersistenceStringRes Class Eco.Persistence Namespace See Also
Collapse All

Returns: "Class {0} is persistent, but superclass {1} is transient"

C#
public static string sSuperclassIsNotPersistent(
    object param0,
    object param1
);
Remarks

For internal use.

See Also
PersistenceStringRes Class
Eco.Persistence Namespace


PersistenceStringRes.sUnableToLoadFromFile Method

PersistenceStringRes.sUnableToLoadFromFile Method
PersistenceStringRes Class Eco.Persistence Namespace See Also
Collapse All

Returns: "Unable to load O/R mapping from file {0}"

C#
public static string sUnableToLoadFromFile(
    object param0
);
Remarks

For internal use.

See Also
PersistenceStringRes Class
Eco.Persistence Namespace


PersistenceStringRes.sUnableToLoadFromResource Method

PersistenceStringRes.sUnableToLoadFromResource Method
PersistenceStringRes Class Eco.Persistence Namespace See Also
Collapse All

Returns: "Unable to load O/R mapping from resource {0}"

C#
public static string sUnableToLoadFromResource(
    object param0
);
Remarks

For internal use.

See Also
PersistenceStringRes Class
Eco.Persistence Namespace


PersistenceStringRes.sUnknownPrimaryKeyCol Method

PersistenceStringRes.sUnknownPrimaryKeyCol Method
PersistenceStringRes Class Eco.Persistence Namespace See Also
Collapse All

Returns: "Class {0} has a column in the PrimaryKey specification that isn't used by any attribute or embedded singlelink: {1}"

C#
public static string sUnknownPrimaryKeyCol(
    object param0,
    object param1
);
Remarks

For internal use.

See Also
PersistenceStringRes Class
Eco.Persistence Namespace


PersistenceStringRes.UnableToResolveMapperProviderType Method

PersistenceStringRes.UnableToResolveMapperProviderType Method
PersistenceStringRes Class Eco.Persistence Namespace See Also
Collapse All

Returns: "Unable to resolve PersistenceMapperSharer.MapperProviderType: "{0}". Does the PersistenceMapperProvider have a "RuntimeRequiredAttribute" defined?"

C#
public static string UnableToResolveMapperProviderType(
    object param0
);
Remarks

For internal use.

See Also
PersistenceStringRes Class
Eco.Persistence Namespace


PersistenceStringRes.UnknownMapperTypeForOrMappingProvider Method

PersistenceStringRes.UnknownMapperTypeForOrMappingProvider Method
PersistenceStringRes Class Eco.Persistence Namespace See Also
Collapse All

Returns: "Unknown mapper type for OrMappingProvider ({0})"

C#
public static string UnknownMapperTypeForOrMappingProvider(
    object param0
);
Remarks

For internal use.

See Also
PersistenceStringRes Class
Eco.Persistence Namespace


PersistenceStringRes.UnknownValueTypeInEcoOrMappingTable Method

PersistenceStringRes.UnknownValueTypeInEcoOrMappingTable Method
PersistenceStringRes Class Eco.Persistence Namespace See Also
Collapse All

Returns: "Unknown valuetype in {0} table ({1})"

C#
public static string UnknownValueTypeInEcoOrMappingTable(
    object param0,
    object param1
);
Remarks

For internal use.

See Also
PersistenceStringRes Class
Eco.Persistence Namespace


PersistenceStringRes Properties

PersistenceStringRes Properties
Public Properties
Collapse All

The properties of the PersistenceStringRes class are listed here.

Public Properties
Name | Description
ClassHasNoDiscriminatorValueDefined | Returns: "Class has no discriminator value defined"
CompilingTheProjectMightHelp | Returns: "Compiling the project might help."
ComponentCategoryPersistence | Returns: "ECO|Persistence"
ConnectionNotSet | Returns: "Connection not set."
ConnectionStringNotSet | Returns: "Connection string not specified."
DiscriminatorIsFinal | Returns: "Discriminator value for class is final"
EnumExpected | Returns: "Expected an enum type"
MappingProviderNotInitialized | Returns: "MappingProvider has not been initialized"
NoTypeSystem | Returns: "No TypeSystem available"
ProviderNotInitialized | Returns: "MappingProvider has not been initialized"
RootclassHasNoDiscriminatorDefined | Returns: "Rootclass has no discriminator defined"
sAccessSetup | Returns: "MS Access se&tup"
sAllocatedExecQueriesNotAllowedWhenStartingTransaction | Returns: "There are allocated ExecQueries that have not been returned. StartTransaction not allowed"
sAllocatedQueriesNotAllowedWhenStartingTransaction | Returns: "There are allocated queries that have not been returned. StartTransaction not allowed"
sANSI92Setup | Returns: "Generic &ANSI92 setup"
sAutoIncIdSetup | Returns: "Setup Autoinc keys"
sBlackfishSetup | Returns: "Blackfish setu&p"
sCannotConvertImageToString | Returns: "Can't convert a string to an image"
sCannotConvertInt64ToTimestamp | Returns: "Can't convert an Int64 to a TimeStamp"
sCannotConvertStringToByteArray | Returns: "Can't convert a string to a byte array"
sCannotConvertStringToTimestamp | Returns: "Can't convert a string to a TimeStamp"
sCantFindInt64Mapper | Returns: "Can't find attributemapping for System.Int64, check your SqlDatabaseConfig"
sCategoryEco | Returns: "ECO"
sCategoryEvolution | Returns: "ECO|Schema Evolution"
sCategoryMapping | Returns: "ECO|OR Mapping"
sCategoryPersistence | Returns: "ECO|Persistence"
sCategoryPooling | Returns: "ECO|Pooling"
sCategoryRemoting | Returns: "ECO|Remoting"
sCategorySynchronization | Returns: "ECO|Synchronization"
sCategoryTypes | Returns: "ECO|Types"
sCategoryVersioning | Returns: "ECO|Object Versioning"
sConnectionDoesntSupportInterface | Returns: "Connection does not support IDistributedTransactionParticipant."
sConnectionNotSetInPMapper | Returns: "PersistenceMapper has no connection"
sDatabaseAlreadyBusy | Returns: "Database already busy"
sDatabaseContainsMappingTable1 | Returns: "The database already contains a table for mapping info."
sDatabaseContainsMappingTable2 | Returns: "This operation only has to be performed to upgrade EcoI databases to EcoII format."
sDatabaseContainsMappingTable3 | Returns: "Do you want to continue anyway?"
sDatabaseNotFromPool | Returns: "Database not from this pool"
sDB2MBCSSetup | Returns: "D&B2 setup (MBCS)"
sDB2Setup | Returns: "&DB2 setup"
sDoNotCallDecimalAsAutoIncStringToParameter | Returns: "DecimalAsAutoInc.StringToParameter should never be called..."
sDoNotCallDecimalAsAutoIncValueToParameter | Returns: "DecimalAsAutoInc.ValueToParameter should never be called..."
sDoNotCallInt16AsAutoIncStringToParameter | Returns: "Int16AsAutoInc.StringToParameter should never be called..."
sDoNotCallInt16AsAutoIncValueToParameter | Returns: "Int16AsAutoInc.ValueToParameter should never be called..."
sDoNotCallInt32AsAutoIncStringToParameter | Returns: "Int32AsAutoInc.StringToParameter should never be called..."
sDoNotCallInt32AsAutoIncValueToParameter | Returns: "Int32AsAutoInc.ValueToParameter should never be called..."
sEcoIIISetup | Returns: "EcoIII compatibility names"
sEcoIISetup | Returns: "EcoII compatibility names"
sEcoISetup | Returns: "EcoI compatibility names"
sEcoSpaceTypeNameNotSetInPMP | Returns: "EcoSpaceTypeName not set in PersistenceMapperProvider"
sEcoToolEvolveSchemaHint | Returns: "&Evolve Schema"
sEcoToolGenerateDefaultMappingXmlHint | Returns: "Generate default mapping &XML"
sEcoToolGenerateSchemaHint | Returns: "&Generate Schema"
sEcoToolSaveMappingInfoHint | Returns: "&Save OR mapping information to DB"
sEcoToolValidateModelHint | Returns: "&Validate Model"
sEvolutionCaption | Returns: "Schema Evolution"
sFailedToStoreMappingInfo | Returns: "Failed to store the O/R mapping information in the database. Please check the BlobSize of your connection"
sFirebirdSetup | Returns: "Firebird setup"
sGenerateDefaultMappingXmlCaption | Returns: "Generate default mapping XML"
sGuidIdSetup | Returns: "Setup Guid keys"
sHelpNewMapperProvider | Returns: "Set the OldMappingProvider"
sHelpOldMapperProvider | Returns: "Set the NewMappingProvider"
sHelpRunTimeMapperProvider | Returns: "Set the RunTimeMappingProvider"
sHelpSpecifyConnection | Returns: "Set the Connection property"
sHelpSqlDatabaseConfig | Returns: "Specify SqlDatabaseConfig (available from context menu)"
sImplicitReadTransactionInProgress | Returns: "An implicit read transaction is already in progress"
sInformixSetup | Returns: "I&nformix setup"
sInt32IdSetup | Returns: "Setup Int32 keys"
sInt64IdSetup | Returns: "Setup Int64 keys"
sInterbase3MBCSSetup | Returns: "InterBase [dialect3] setup (&MBCS)"
sInterbase3Setup | Returns: "&InterBase [dialect3] setup"
sMapperProviderTypeName | Returns: "The name of the type of shared Persistence Mapper"
sMapperTypeNotInHierarchy | Returns: "Parameter is not a valid type. Must inherit from PersistenceMapperProvider."
sMapping | Returns: "ECO|PersistenceMapper sharing"
sMappingDefinesMultipleDatabases | Returns: "O/R mapping defines more than one database"
sMappingDoesNotDefineAnyDatabase | Returns: "O/R mapping does not define any database"
sMappingInformationStored | Returns: "Mapping information stored in database. You may now modify the model and perform Database Evolution"
sMimerSetup | Returns: "Mimer setup"
sMissingFileAndResourceName | Returns: "FileMappingProvider has no filename and no resource name defined"
sModelError | Returns: "Error in reflected model:"
sModelErrors | Returns: "Model errors:"
sModelValidatedOK | Returns: "Model validated OK!"
sModelValidationCaption | Returns: "Model Validation"
sMultipleVersionedDatabasesNotAllowed | Returns: "Multiple versioned databases is not allowed"
sMySql4Setup | Returns: "M&ySQL 4.0 setup"
sMySql5Setup | Returns: "MySQL &5.0 setup"
sNegativeDistanceNotAllowed | Returns: "Negative distances not allowed"
sNoDatabaseMarkedAsVersioned | Returns: "There is no database in the collection that is marked as versioned"
sNoPMapper | Returns: "Persistence mapper not available. Cannot perform operation."
sNotConnected | Returns: "Not Connected"
sNoTransactionToCommit | Returns: "No transaction to Commit"
sNoTransactionToRollback | Returns: "No transaction to Rollback"
sNoValueChangeOnActivePersistenceMapper | Returns: "Can't change value on active PersistenceMapper"
sOldMappingProviderIsNotDb | Returns: "PersistenceHandle.OldMappingProvider is not a DbMappingProvider"
sOperationCreateDatabase | Returns: "Create Database"
sOperationEvolveDB | Returns: "DbEvolution"
sOperationGenerateMappingXml | Returns: "Generate default mapping XML"
sOperationMustBePerformedFromPersistenceMapperProvider | Returns: "This operation must be performed from your PersistenceMapperProvider"
sOracleMBCSSetup | Returns: "Ora&cle setup (MBCS)"
sOracleSetup | Returns: "&Oracle setup"
sPersistenceHandleCaption | Returns: "PersistenceMapper"
sPersistenceHandleMissing | Returns: "The ECO Space has no persistence mapper"
sPersistenceMapperInUseWithOtherTypeSystem | Returns: "Persistence mapper already in use with other type system"
sPersistenceMapperNotSetInPMP | Returns: "PersistenceMapper not set in PersistenceMapperProvider"
sPMapperInUse | Returns: "PersistenceMapper in use"
sPropertyClassNameColumnName | Returns: "Name of the column containing the class names."
sPropertyClassNameSignature | Returns: "Datatype or name of mapper to read class names from ECOTYPES table."
sPropertyClockLogGranularity | Returns: "Granularity of the clock log file."
sPropertyConnection | Returns: "Specify the connection to use for the handle."
sPropertyDatabase | Returns: "The database the mapping builder handles (only for use with multiple data sources)."
sPropertyEcoSpaceTypeName | Returns: "The type of the ECO Space to be persisted."
sPropertyEvolutionSupport | Returns: "Determines if the database supports evolution."
sPropertyHistoryLength | Returns: "Number of updates to Sync."
sPropertyIdColumnName | Returns: "Name of column containing ID."
sPropertyIdIsAutoInc | Returns: "If true, IDs will be generated through auto-incremental fields."
sPropertyIdKeyName | Returns: "Name of key definition in XML file."
sPropertyIdKeySignature | Returns: "Data type of key."
sPropertyIdMapperName | Returns: "Name of the key mapper to use for the id in the XML file."
sPropertyMaxOpenConnections | Returns: "The max number of open connections."
sPropertyMaxPooledConnections | Returns: "The max number of connections that will be pooled."
sPropertyNewMappingProvider | Returns: "Specify a component to provide new O/R mapping configuration for DbEvolution (no setting will derive mapping from model)."
sPropertyOldMappingProvider | Returns: "Specify a component to provide old O/R mapping configuration for DbEvolution (no setting will load mapping from database)."
sPropertyPersistenceMapper | Returns: "The persistence mapper that should be used to persist the data."
sPropertyResourceName | Returns: "Name of resource containing O/R Mapping information."
sPropertyRootTableName | Returns: "Name of the table of the model's implicit root class (defaults to EcoModelRoot)."
sPropertyRunTimeMappingProvider | Returns: "Specify a component to provide Runtime O/R mapping configuration (no setting will derive mapping from model)."
sPropertySqlDatabaseConfig | Returns: "Specify the connection to use for the handle."
sPropertySyncActive | Returns: "Synchronization active."
sPropertySyncHandler | Returns: "Specify a SyncHandler component if Sync is to be active"
sPropertyTablesColumnName | Returns: "Name of the column containing the table names."
sPropertyTablesTableName | Returns: "Name of the table containing the list of tables."
sPropertyTypeColumnName | Returns: "Name of the column containing the type names."
sPropertyTypeDiscriminatorName | Returns: "Name of discriminator definition in XML file."
sPropertyTypeDiscriminatorSignature | Returns: "Data type of discriminator."
sPropertyTypeTableName | Returns: "Name of the table containing the list of types in the model."
sPropertyUrl | Returns: "URL for server, e.g. tcp://localhost:4243/PersistenceServer"
sPropertyXmlFileName | Returns: "Name of file containing O/R Mapping information."
sProviderUsedWithOtherTypeSystem | Returns: "Provider already in use with other type system"
SqlDatabaseConfigNotValid | Returns: "SqlDatabaseConfig is not properly configured."
sReservedWordColumnSuffix | Returns: "Suffix to add to column names to avoid collisions with reserved words"
sReservedWordTableSuffix | Returns: "Suffix to add to table names to avoid collisions with reserved words"
sRootclassIsNotPersistent | Returns: "Rootclass is not persistent"
sSaveMappingInfo | Returns: "Save Mapping Info"
sSaveMappingInfoCaption | Returns: "Save Mapping Information"
sSchemaCreated | Returns: "Database schema created"
sSchemaGenerationCaption | Returns: "Schema Generation"
sSharerInUse | Returns: "Sharer in use"
sSQLConfigDesignerTransactionName | Returns: "Updating DB settings"
sSqlServer7MBCSSetup | Returns: "SQL Se&rver 7 setup (MBCS)"
sSqlServer7Setup | Returns: "SQ&L Server 7 setup"
sSqlServerMBCSSetup | Returns: "SQL S&erver 2k/2k5/2k8 setup (MBCS)"
sSqlServerSetup | Returns: "S&QL Server 2k/2k5/2k8 setup"
sSybaseSetup | Returns: "&Sybase setup"
sSyncNotActive | Returns: "Sync not active"
sTransactionInProgress | Returns: "A transaction is already in progress"
sTransactionNotFinished | Returns: "Transaction not finished"
TypeSystemHasNoClasses | Returns: "TypeSystem has no classes defined"
UnabletoReadParameterValue | Returns: "Unable to read parameter value"
UnsupportedColumnToValueCall | Returns: "This mapper only supports 'ColumnToValue(columnValue, expectedType)'"
UnsupportedStringToParameterCall | Returns: "This mapper only supports 'StringToParameter(parameter, expectedType)'"


PersistenceStringRes.ClassHasNoDiscriminatorValueDefined Property

PersistenceStringRes.ClassHasNoDiscriminatorValueDefined Property
PersistenceStringRes Class Eco.Persistence Namespace See Also
Collapse All

Returns: "Class has no discriminator value defined"

C#
public static string ClassHasNoDiscriminatorValueDefined;
Remarks

For internal use.

See Also
PersistenceStringRes Class
Eco.Persistence Namespace


PersistenceStringRes.CompilingTheProjectMightHelp Property

PersistenceStringRes.CompilingTheProjectMightHelp Property
PersistenceStringRes Class Eco.Persistence Namespace See Also
Collapse All

Returns: "Compiling the project might help."

C#
public static string CompilingTheProjectMightHelp;
Remarks

For internal use.

See Also
PersistenceStringRes Class
Eco.Persistence Namespace


PersistenceStringRes.ComponentCategoryPersistence Property

PersistenceStringRes.ComponentCategoryPersistence Property
PersistenceStringRes Class Eco.Persistence Namespace See Also
Collapse All

Returns: "ECO|Persistence"

C#
public static string ComponentCategoryPersistence;
Remarks

For internal use.

See Also
PersistenceStringRes Class
Eco.Persistence Namespace


PersistenceStringRes.ConnectionNotSet Property

PersistenceStringRes.ConnectionNotSet Property
PersistenceStringRes Class Eco.Persistence Namespace See Also
Collapse All

Returns: "Connection not set."

C#
public static string ConnectionNotSet;
Remarks

For internal use.

See Also
PersistenceStringRes Class
Eco.Persistence Namespace


PersistenceStringRes.ConnectionStringNotSet Property

PersistenceStringRes.ConnectionStringNotSet Property
PersistenceStringRes Class Eco.Persistence Namespace See Also
Collapse All

Returns: "Connection string not specified."

C#
public static string ConnectionStringNotSet;
Remarks

For internal use.

See Also
PersistenceStringRes Class
Eco.Persistence Namespace


PersistenceStringRes.DiscriminatorIsFinal Property

PersistenceStringRes.DiscriminatorIsFinal Property
PersistenceStringRes Class Eco.Persistence Namespace See Also
Collapse All

Returns: "Discriminator value for class is final"

C#
public static string DiscriminatorIsFinal;
Remarks

For internal use.

See Also
PersistenceStringRes Class
Eco.Persistence Namespace


PersistenceStringRes.EnumExpected Property

PersistenceStringRes.EnumExpected Property
PersistenceStringRes Class Eco.Persistence Namespace See Also
Collapse All

Returns: "Expected an enum type"

C#
public static string EnumExpected;
Remarks

For internal use.

See Also
PersistenceStringRes Class
Eco.Persistence Namespace


PersistenceStringRes.MappingProviderNotInitialized Property

PersistenceStringRes.MappingProviderNotInitialized Property
PersistenceStringRes Class Eco.Persistence Namespace See Also
Collapse All

Returns: "MappingProvider has not been initialized"

C#
public static string MappingProviderNotInitialized;
Remarks

For internal use.

See Also
PersistenceStringRes Class
Eco.Persistence Namespace


PersistenceStringRes.NoTypeSystem Property

PersistenceStringRes.NoTypeSystem Property
PersistenceStringRes Class Eco.Persistence Namespace See Also
Collapse All

Returns: "No TypeSystem available"

C#
public static string NoTypeSystem;
Remarks

For internal use.

See Also
PersistenceStringRes Class
Eco.Persistence Namespace


PersistenceStringRes.ProviderNotInitialized Property

PersistenceStringRes.ProviderNotInitialized Property
PersistenceStringRes Class Eco.Persistence Namespace See Also
Collapse All

Returns: "MappingProvider has not been initialized"

C#
public static string ProviderNotInitialized;
Remarks

For internal use.

See Also
PersistenceStringRes Class
Eco.Persistence Namespace


PersistenceStringRes.RootclassHasNoDiscriminatorDefined Property

PersistenceStringRes.RootclassHasNoDiscriminatorDefined Property
PersistenceStringRes Class Eco.Persistence Namespace See Also
Collapse All

Returns: "Rootclass has no discriminator defined"

C#
public static string RootclassHasNoDiscriminatorDefined;
Remarks

For internal use.

See Also
PersistenceStringRes Class
Eco.Persistence Namespace


PersistenceStringRes.sAccessSetup Property

PersistenceStringRes.sAccessSetup Property
PersistenceStringRes Class Eco.Persistence Namespace See Also
Collapse All

Returns: "MS Access se&tup"

C#
public static string sAccessSetup;
Remarks

For internal use.

See Also
PersistenceStringRes Class
Eco.Persistence Namespace


PersistenceStringRes.sAllocatedExecQueriesNotAllowedWhenStartingTransaction Property

PersistenceStringRes.sAllocatedExecQueriesNotAllowedWhenStartingTransaction Property
PersistenceStringRes Class Eco.Persistence Namespace See Also
Collapse All

Returns: "There are allocated ExecQueries that have not been returned. StartTransaction not allowed"

C#
public static string sAllocatedExecQueriesNotAllowedWhenStartingTransaction;
Remarks

For internal use.

See Also
PersistenceStringRes Class
Eco.Persistence Namespace


PersistenceStringRes.sAllocatedQueriesNotAllowedWhenStartingTransaction Property

PersistenceStringRes.sAllocatedQueriesNotAllowedWhenStartingTransaction Property
PersistenceStringRes Class Eco.Persistence Namespace See Also
Collapse All

Returns: "There are allocated queries that have not been returned. StartTransaction not allowed"

C#
public static string sAllocatedQueriesNotAllowedWhenStartingTransaction;
Remarks

For internal use.

See Also
PersistenceStringRes Class
Eco.Persistence Namespace


PersistenceStringRes.sANSI92Setup Property

PersistenceStringRes.sANSI92Setup Property
PersistenceStringRes Class Eco.Persistence Namespace See Also
Collapse All

Returns: "Generic &ANSI92 setup"

C#
public static string sANSI92Setup;
Remarks

For internal use.

See Also
PersistenceStringRes Class
Eco.Persistence Namespace


PersistenceStringRes.sAutoIncIdSetup Property

PersistenceStringRes.sAutoIncIdSetup Property
PersistenceStringRes Class Eco.Persistence Namespace See Also
Collapse All

Returns: "Setup Autoinc keys"

C#
public static string sAutoIncIdSetup;
Remarks

For internal use.

See Also
PersistenceStringRes Class
Eco.Persistence Namespace


PersistenceStringRes.sBlackfishSetup Property

PersistenceStringRes.sBlackfishSetup Property
PersistenceStringRes Class Eco.Persistence Namespace See Also
Collapse All

Returns: "Blackfish setu&p"

C#
public static string sBlackfishSetup;
Remarks

For internal use.

See Also
PersistenceStringRes Class
Eco.Persistence Namespace


PersistenceStringRes.sCannotConvertImageToString Property

PersistenceStringRes.sCannotConvertImageToString Property
PersistenceStringRes Class Eco.Persistence Namespace See Also
Collapse All

Returns: "Can't convert a string to an image"

C#
public static string sCannotConvertImageToString;
Remarks

For internal use.

See Also
PersistenceStringRes Class
Eco.Persistence Namespace


PersistenceStringRes.sCannotConvertInt64ToTimestamp Property

PersistenceStringRes.sCannotConvertInt64ToTimestamp Property
PersistenceStringRes Class Eco.Persistence Namespace See Also
Collapse All

Returns: "Can't convert an Int64 to a TimeStamp"

C#
public static string sCannotConvertInt64ToTimestamp;
Remarks

For internal use.

See Also
PersistenceStringRes Class
Eco.Persistence Namespace


PersistenceStringRes.sCannotConvertStringToByteArray Property

PersistenceStringRes.sCannotConvertStringToByteArray Property
PersistenceStringRes Class Eco.Persistence Namespace See Also
Collapse All

Returns: "Can't convert a string to a byte array"

C#
public static string sCannotConvertStringToByteArray;
Remarks

For internal use.

See Also
PersistenceStringRes Class
Eco.Persistence Namespace


PersistenceStringRes.sCannotConvertStringToTimestamp Property

PersistenceStringRes.sCannotConvertStringToTimestamp Property
PersistenceStringRes Class Eco.Persistence Namespace See Also
Collapse All

Returns: "Can't convert a string to a TimeStamp"

C#
public static string sCannotConvertStringToTimestamp;
Remarks

For internal use.

See Also
PersistenceStringRes Class
Eco.Persistence Namespace


PersistenceStringRes.sCantFindInt64Mapper Property

PersistenceStringRes.sCantFindInt64Mapper Property
PersistenceStringRes Class Eco.Persistence Namespace See Also
Collapse All

Returns: "Can't find attributemapping for System.Int64, check your SqlDatabaseConfig"

C#
public static string sCantFindInt64Mapper;
Remarks

For internal use.

See Also
PersistenceStringRes Class
Eco.Persistence Namespace


PersistenceStringRes.sCategoryEco Property

PersistenceStringRes.sCategoryEco Property
PersistenceStringRes Class Eco.Persistence Namespace See Also
Collapse All

Returns: "ECO"

C#
public static string sCategoryEco;
Remarks

For internal use.

See Also
PersistenceStringRes Class
Eco.Persistence Namespace


PersistenceStringRes.sCategoryEvolution Property

PersistenceStringRes.sCategoryEvolution Property
PersistenceStringRes Class Eco.Persistence Namespace See Also
Collapse All

Returns: "ECO|Schema Evolution"

C#
public static string sCategoryEvolution;
Remarks

For internal use.

See Also
PersistenceStringRes Class
Eco.Persistence Namespace


PersistenceStringRes.sCategoryMapping Property

PersistenceStringRes.sCategoryMapping Property
PersistenceStringRes Class Eco.Persistence Namespace See Also
Collapse All

Returns: "ECO|OR Mapping"

C#
public static string sCategoryMapping;
Remarks

For internal use.

See Also
PersistenceStringRes Class
Eco.Persistence Namespace


PersistenceStringRes.sCategoryPersistence Property

PersistenceStringRes.sCategoryPersistence Property
PersistenceStringRes Class Eco.Persistence Namespace See Also
Collapse All

Returns: "ECO|Persistence"

C#
public static string sCategoryPersistence;
Remarks

For internal use.

See Also
PersistenceStringRes Class
Eco.Persistence Namespace


PersistenceStringRes.sCategoryPooling Property

PersistenceStringRes.sCategoryPooling Property
PersistenceStringRes Class Eco.Persistence Namespace See Also
Collapse All

Returns: "ECO|Pooling"

C#
public static string sCategoryPooling;
Remarks

For internal use.

See Also
PersistenceStringRes Class
Eco.Persistence Namespace


PersistenceStringRes.sCategoryRemoting Property

PersistenceStringRes.sCategoryRemoting Property
PersistenceStringRes Class Eco.Persistence Namespace See Also
Collapse All

Returns: "ECO|Remoting"

C#
public static string sCategoryRemoting;
Remarks

For internal use.

See Also
PersistenceStringRes Class
Eco.Persistence Namespace


PersistenceStringRes.sCategorySynchronization Property

PersistenceStringRes.sCategorySynchronization Property
PersistenceStringRes Class Eco.Persistence Namespace See Also
Collapse All

Returns: "ECO|Synchronization"

C#
public static string sCategorySynchronization;
Remarks

For internal use.

See Also
PersistenceStringRes Class
Eco.Persistence Namespace


PersistenceStringRes.sCategoryTypes Property

PersistenceStringRes.sCategoryTypes Property
PersistenceStringRes Class Eco.Persistence Namespace See Also
Collapse All

Returns: "ECO|Types"

C#
public static string sCategoryTypes;
Remarks

For internal use.

See Also
PersistenceStringRes Class
Eco.Persistence Namespace


PersistenceStringRes.sCategoryVersioning Property

PersistenceStringRes.sCategoryVersioning Property
PersistenceStringRes Class Eco.Persistence Namespace See Also
Collapse All

Returns: "ECO|Object Versioning"

C#
public static string sCategoryVersioning;
Remarks

For internal use.

See Also
PersistenceStringRes Class
Eco.Persistence Namespace


PersistenceStringRes.sConnectionDoesntSupportInterface Property

PersistenceStringRes.sConnectionDoesntSupportInterface Property
PersistenceStringRes Class Eco.Persistence Namespace See Also
Collapse All

Returns: "Connection does not support IDistributedTransactionParticipant."

C#
public static string sConnectionDoesntSupportInterface;
Remarks

For internal use.

See Also
PersistenceStringRes Class
Eco.Persistence Namespace


PersistenceStringRes.sConnectionNotSetInPMapper Property

PersistenceStringRes.sConnectionNotSetInPMapper Property
PersistenceStringRes Class Eco.Persistence Namespace See Also
Collapse All

Returns: "PersistenceMapper has no connection"

C#
public static string sConnectionNotSetInPMapper;
Remarks

For internal use.

See Also
PersistenceStringRes Class
Eco.Persistence Namespace


PersistenceStringRes.sDatabaseAlreadyBusy Property

PersistenceStringRes.sDatabaseAlreadyBusy Property
PersistenceStringRes Class Eco.Persistence Namespace See Also
Collapse All

Returns: "Database already busy"

C#
public static string sDatabaseAlreadyBusy;
Remarks

For internal use.

See Also
PersistenceStringRes Class
Eco.Persistence Namespace


PersistenceStringRes.sDatabaseContainsMappingTable1 Property

PersistenceStringRes.sDatabaseContainsMappingTable1 Property
PersistenceStringRes Class Eco.Persistence Namespace See Also
Collapse All

Returns: "The database already contains a table for mapping info."

C#
public static string sDatabaseContainsMappingTable1;
Remarks

For internal use.

See Also
PersistenceStringRes Class
Eco.Persistence Namespace


PersistenceStringRes.sDatabaseContainsMappingTable2 Property

PersistenceStringRes.sDatabaseContainsMappingTable2 Property
PersistenceStringRes Class Eco.Persistence Namespace See Also
Collapse All

Returns: "This operation only has to be performed to upgrade EcoI databases to EcoII format."

C#
public static string sDatabaseContainsMappingTable2;
Remarks

For internal use.

See Also
PersistenceStringRes Class
Eco.Persistence Namespace


PersistenceStringRes.sDatabaseContainsMappingTable3 Property

PersistenceStringRes.sDatabaseContainsMappingTable3 Property
PersistenceStringRes Class Eco.Persistence Namespace See Also
Collapse All

Returns: "Do you want to continue anyway?"

C#
public static string sDatabaseContainsMappingTable3;
Remarks

For internal use.

See Also
PersistenceStringRes Class
Eco.Persistence Namespace


PersistenceStringRes.sDatabaseNotFromPool Property

PersistenceStringRes.sDatabaseNotFromPool Property
PersistenceStringRes Class Eco.Persistence Namespace See Also
Collapse All

Returns: "Database not from this pool"

C#
public static string sDatabaseNotFromPool;
Remarks

For internal use.

See Also
PersistenceStringRes Class
Eco.Persistence Namespace


PersistenceStringRes.sDB2MBCSSetup Property

PersistenceStringRes.sDB2MBCSSetup Property
PersistenceStringRes Class Eco.Persistence Namespace See Also
Collapse All

Returns: "D&B2 setup (MBCS)"

C#
public static string sDB2MBCSSetup;
Remarks

For internal use.

See Also
PersistenceStringRes Class
Eco.Persistence Namespace


PersistenceStringRes.sDB2Setup Property

PersistenceStringRes.sDB2Setup Property
PersistenceStringRes Class Eco.Persistence Namespace See Also
Collapse All

Returns: "&DB2 setup"

C#
public static string sDB2Setup;
Remarks

For internal use.

See Also
PersistenceStringRes Class
Eco.Persistence Namespace


PersistenceStringRes.sDoNotCallDecimalAsAutoIncStringToParameter Property

PersistenceStringRes.sDoNotCallDecimalAsAutoIncStringToParameter Property
PersistenceStringRes Class Eco.Persistence Namespace See Also
Collapse All

Returns: "DecimalAsAutoInc.StringToParameter should never be called..."

C#
public static string sDoNotCallDecimalAsAutoIncStringToParameter;
Remarks

For internal use.

See Also
PersistenceStringRes Class
Eco.Persistence Namespace


PersistenceStringRes.sDoNotCallDecimalAsAutoIncValueToParameter Property

PersistenceStringRes.sDoNotCallDecimalAsAutoIncValueToParameter Property
PersistenceStringRes Class Eco.Persistence Namespace See Also
Collapse All

Returns: "DecimalAsAutoInc.ValueToParameter should never be called..."

C#
public static string sDoNotCallDecimalAsAutoIncValueToParameter;
Remarks

For internal use.

See Also
PersistenceStringRes Class
Eco.Persistence Namespace


PersistenceStringRes.sDoNotCallInt16AsAutoIncStringToParameter Property

PersistenceStringRes.sDoNotCallInt16AsAutoIncStringToParameter Property
PersistenceStringRes Class Eco.Persistence Namespace See Also
Collapse All

Returns: "Int16AsAutoInc.StringToParameter should never be called..."

C#
public static string sDoNotCallInt16AsAutoIncStringToParameter;
Remarks

For internal use.

See Also
PersistenceStringRes Class
Eco.Persistence Namespace


PersistenceStringRes.sDoNotCallInt16AsAutoIncValueToParameter Property

PersistenceStringRes.sDoNotCallInt16AsAutoIncValueToParameter Property
PersistenceStringRes Class Eco.Persistence Namespace See Also
Collapse All

Returns: "Int16AsAutoInc.ValueToParameter should never be called..."

C#
public static string sDoNotCallInt16AsAutoIncValueToParameter;
Remarks

For internal use.

See Also
PersistenceStringRes Class
Eco.Persistence Namespace


PersistenceStringRes.sDoNotCallInt32AsAutoIncStringToParameter Property

PersistenceStringRes.sDoNotCallInt32AsAutoIncStringToParameter Property
PersistenceStringRes Class Eco.Persistence Namespace See Also
Collapse All

Returns: "Int32AsAutoInc.StringToParameter should never be called..."

C#
public static string sDoNotCallInt32AsAutoIncStringToParameter;
Remarks

For internal use.

See Also
PersistenceStringRes Class
Eco.Persistence Namespace


PersistenceStringRes.sDoNotCallInt32AsAutoIncValueToParameter Property

PersistenceStringRes.sDoNotCallInt32AsAutoIncValueToParameter Property
PersistenceStringRes Class Eco.Persistence Namespace See Also
Collapse All

Returns: "Int32AsAutoInc.ValueToParameter should never be called..."

C#
public static string sDoNotCallInt32AsAutoIncValueToParameter;
Remarks

For internal use.

See Also
PersistenceStringRes Class
Eco.Persistence Namespace


PersistenceStringRes.sEcoIIISetup Property

PersistenceStringRes.sEcoIIISetup Property
PersistenceStringRes Class Eco.Persistence Namespace See Also
Collapse All

Returns: "EcoIII compatibility names"

C#
public static string sEcoIIISetup;
Remarks

For internal use.

See Also
PersistenceStringRes Class
Eco.Persistence Namespace


PersistenceStringRes.sEcoIISetup Property

PersistenceStringRes.sEcoIISetup Property
PersistenceStringRes Class Eco.Persistence Namespace See Also
Collapse All

Returns: "EcoII compatibility names"

C#
public static string sEcoIISetup;
Remarks

For internal use.

See Also
PersistenceStringRes Class
Eco.Persistence Namespace


PersistenceStringRes.sEcoISetup Property

PersistenceStringRes.sEcoISetup Property
PersistenceStringRes Class Eco.Persistence Namespace See Also
Collapse All

Returns: "EcoI compatibility names"

C#
public static string sEcoISetup;
Remarks

For internal use.

See Also
PersistenceStringRes Class
Eco.Persistence Namespace


PersistenceStringRes.sEcoSpaceTypeNameNotSetInPMP Property

PersistenceStringRes.sEcoSpaceTypeNameNotSetInPMP Property
PersistenceStringRes Class Eco.Persistence Namespace See Also
Collapse All

Returns: "EcoSpaceTypeName not set in PersistenceMapperProvider"

C#
public static string sEcoSpaceTypeNameNotSetInPMP;
Remarks

For internal use.

See Also
PersistenceStringRes Class
Eco.Persistence Namespace


PersistenceStringRes.sEcoToolEvolveSchemaHint Property

PersistenceStringRes.sEcoToolEvolveSchemaHint Property
PersistenceStringRes Class Eco.Persistence Namespace See Also
Collapse All

Returns: "&Evolve Schema"

C#
public static string sEcoToolEvolveSchemaHint;
Remarks

For internal use.

See Also
PersistenceStringRes Class
Eco.Persistence Namespace


PersistenceStringRes.sEcoToolGenerateDefaultMappingXmlHint Property

PersistenceStringRes.sEcoToolGenerateDefaultMappingXmlHint Property
PersistenceStringRes Class Eco.Persistence Namespace See Also
Collapse All

Returns: "Generate default mapping &XML"

C#
public static string sEcoToolGenerateDefaultMappingXmlHint;
Remarks

For internal use.

See Also
PersistenceStringRes Class
Eco.Persistence Namespace


PersistenceStringRes.sEcoToolGenerateSchemaHint Property

PersistenceStringRes.sEcoToolGenerateSchemaHint Property
PersistenceStringRes Class Eco.Persistence Namespace See Also
Collapse All

Returns: "&Generate Schema"

C#
public static string sEcoToolGenerateSchemaHint;
Remarks

For internal use.

See Also
PersistenceStringRes Class
Eco.Persistence Namespace


PersistenceStringRes.sEcoToolSaveMappingInfoHint Property

PersistenceStringRes.sEcoToolSaveMappingInfoHint Property
PersistenceStringRes Class Eco.Persistence Namespace See Also
Collapse All

Returns: "&Save OR mapping information to DB"

C#
public static string sEcoToolSaveMappingInfoHint;
Remarks

For internal use.

See Also
PersistenceStringRes Class
Eco.Persistence Namespace


PersistenceStringRes.sEcoToolValidateModelHint Property

PersistenceStringRes.sEcoToolValidateModelHint Property
PersistenceStringRes Class Eco.Persistence Namespace See Also
Collapse All

Returns: "&Validate Model"

C#
public static string sEcoToolValidateModelHint;
Remarks

For internal use.

See Also
PersistenceStringRes Class
Eco.Persistence Namespace


PersistenceStringRes.sEvolutionCaption Property

PersistenceStringRes.sEvolutionCaption Property
PersistenceStringRes Class Eco.Persistence Namespace See Also
Collapse All

Returns: "Schema Evolution"

C#
public static string sEvolutionCaption;
Remarks

For internal use.

See Also
PersistenceStringRes Class
Eco.Persistence Namespace


PersistenceStringRes.sFailedToStoreMappingInfo Property

PersistenceStringRes.sFailedToStoreMappingInfo Property
PersistenceStringRes Class Eco.Persistence Namespace See Also
Collapse All

Returns: "Failed to store the O/R mapping information in the database. Please check the BlobSize of your connection"

C#
public static string sFailedToStoreMappingInfo;
Remarks

For internal use.

See Also
PersistenceStringRes Class
Eco.Persistence Namespace


PersistenceStringRes.sFirebirdSetup Property

PersistenceStringRes.sFirebirdSetup Property
PersistenceStringRes Class Eco.Persistence Namespace See Also
Collapse All

Returns: "Firebird setup"

C#
public static string sFirebirdSetup;
Remarks

For internal use.

See Also
PersistenceStringRes Class
Eco.Persistence Namespace


PersistenceStringRes.sGenerateDefaultMappingXmlCaption Property

PersistenceStringRes.sGenerateDefaultMappingXmlCaption Property
PersistenceStringRes Class Eco.Persistence Namespace See Also
Collapse All

Returns: "Generate default mapping XML"

C#
public static string sGenerateDefaultMappingXmlCaption;
Remarks

For internal use.

See Also
PersistenceStringRes Class
Eco.Persistence Namespace


PersistenceStringRes.sGuidIdSetup Property

PersistenceStringRes.sGuidIdSetup Property
PersistenceStringRes Class Eco.Persistence Namespace See Also
Collapse All

Returns: "Setup Guid keys"

C#
public static string sGuidIdSetup;
Remarks

For internal use.

See Also
PersistenceStringRes Class
Eco.Persistence Namespace


PersistenceStringRes.sHelpNewMapperProvider Property

PersistenceStringRes.sHelpNewMapperProvider Property
PersistenceStringRes Class Eco.Persistence Namespace See Also
Collapse All

Returns: "Set the OldMappingProvider"

C#
public static string sHelpNewMapperProvider;
Remarks

For internal use.

See Also
PersistenceStringRes Class
Eco.Persistence Namespace


PersistenceStringRes.sHelpOldMapperProvider Property

PersistenceStringRes.sHelpOldMapperProvider Property
PersistenceStringRes Class Eco.Persistence Namespace See Also
Collapse All

Returns: "Set the NewMappingProvider"

C#
public static string sHelpOldMapperProvider;
Remarks

For internal use.

See Also
PersistenceStringRes Class
Eco.Persistence Namespace


PersistenceStringRes.sHelpRunTimeMapperProvider Property

PersistenceStringRes.sHelpRunTimeMapperProvider Property
PersistenceStringRes Class Eco.Persistence Namespace See Also
Collapse All

Returns: "Set the RunTimeMappingProvider"

C#
public static string sHelpRunTimeMapperProvider;
Remarks

For internal use.

See Also
PersistenceStringRes Class
Eco.Persistence Namespace


PersistenceStringRes.sHelpSpecifyConnection Property

PersistenceStringRes.sHelpSpecifyConnection Property
PersistenceStringRes Class Eco.Persistence Namespace See Also
Collapse All

Returns: "Set the Connection property"

C#
public static string sHelpSpecifyConnection;
Remarks

For internal use.

See Also
PersistenceStringRes Class
Eco.Persistence Namespace


PersistenceStringRes.sHelpSqlDatabaseConfig Property

PersistenceStringRes.sHelpSqlDatabaseConfig Property
PersistenceStringRes Class Eco.Persistence Namespace See Also
Collapse All

Returns: "Specify SqlDatabaseConfig (available from context menu)"

C#
public static string sHelpSqlDatabaseConfig;
Remarks

For internal use.

See Also
PersistenceStringRes Class
Eco.Persistence Namespace


PersistenceStringRes.sImplicitReadTransactionInProgress Property

PersistenceStringRes.sImplicitReadTransactionInProgress Property
PersistenceStringRes Class Eco.Persistence Namespace See Also
Collapse All

Returns: "An implicit read transaction is already in progress"

C#
public static string sImplicitReadTransactionInProgress;
Remarks

For internal use.

See Also
PersistenceStringRes Class
Eco.Persistence Namespace


PersistenceStringRes.sInformixSetup Property

PersistenceStringRes.sInformixSetup Property
PersistenceStringRes Class Eco.Persistence Namespace See Also
Collapse All

Returns: "I&nformix setup"

C#
public static string sInformixSetup;
Remarks

For internal use.

See Also
PersistenceStringRes Class
Eco.Persistence Namespace


PersistenceStringRes.sInt32IdSetup Property

PersistenceStringRes.sInt32IdSetup Property
PersistenceStringRes Class Eco.Persistence Namespace See Also
Collapse All

Returns: "Setup Int32 keys"

C#
public static string sInt32IdSetup;
Remarks

For internal use.

See Also
PersistenceStringRes Class
Eco.Persistence Namespace


PersistenceStringRes.sInt64IdSetup Property

PersistenceStringRes.sInt64IdSetup Property
PersistenceStringRes Class Eco.Persistence Namespace See Also
Collapse All

Returns: "Setup Int64 keys"

C#
public static string sInt64IdSetup;
Remarks

For internal use.

See Also
PersistenceStringRes Class
Eco.Persistence Namespace


PersistenceStringRes.sInterbase3MBCSSetup Property

PersistenceStringRes.sInterbase3MBCSSetup Property
PersistenceStringRes Class Eco.Persistence Namespace See Also
Collapse All

Returns: "InterBase [dialect3] setup (&MBCS)"

C#
public static string sInterbase3MBCSSetup;
Remarks

For internal use.

See Also
PersistenceStringRes Class
Eco.Persistence Namespace


PersistenceStringRes.sInterbase3Setup Property

PersistenceStringRes.sInterbase3Setup Property
PersistenceStringRes Class Eco.Persistence Namespace See Also
Collapse All

Returns: "&InterBase [dialect3] setup"

C#
public static string sInterbase3Setup;
Remarks

For internal use.

See Also
PersistenceStringRes Class
Eco.Persistence Namespace


PersistenceStringRes.sMapperProviderTypeName Property

PersistenceStringRes.sMapperProviderTypeName Property
PersistenceStringRes Class Eco.Persistence Namespace See Also
Collapse All

Returns: "The name of the type of shared Persistence Mapper"

C#
public static string sMapperProviderTypeName;
Remarks

For internal use.

See Also
PersistenceStringRes Class
Eco.Persistence Namespace


PersistenceStringRes.sMapperTypeNotInHierarchy Property

PersistenceStringRes.sMapperTypeNotInHierarchy Property
PersistenceStringRes Class Eco.Persistence Namespace See Also
Collapse All

Returns: "Parameter is not a valid type. Must inherit from PersistenceMapperProvider."

C#
public static string sMapperTypeNotInHierarchy;
Remarks

For internal use.

See Also
PersistenceStringRes Class
Eco.Persistence Namespace


PersistenceStringRes.sMapping Property

PersistenceStringRes.sMapping Property
PersistenceStringRes Class Eco.Persistence Namespace See Also
Collapse All

Returns: "ECO|PersistenceMapper sharing"

C#
public static string sMapping;
Remarks

For internal use.

See Also
PersistenceStringRes Class
Eco.Persistence Namespace


PersistenceStringRes.sMappingDefinesMultipleDatabases Property

PersistenceStringRes.sMappingDefinesMultipleDatabases Property
PersistenceStringRes Class Eco.Persistence Namespace See Also
Collapse All

Returns: "O/R mapping defines more than one database"

C#
public static string sMappingDefinesMultipleDatabases;
Remarks

For internal use.

See Also
PersistenceStringRes Class
Eco.Persistence Namespace


PersistenceStringRes.sMappingDoesNotDefineAnyDatabase Property

PersistenceStringRes.sMappingDoesNotDefineAnyDatabase Property
PersistenceStringRes Class Eco.Persistence Namespace See Also
Collapse All

Returns: "O/R mapping does not define any database"

C#
public static string sMappingDoesNotDefineAnyDatabase;
Remarks

For internal use.

See Also
PersistenceStringRes Class
Eco.Persistence Namespace


PersistenceStringRes.sMappingInformationStored Property

PersistenceStringRes.sMappingInformationStored Property
PersistenceStringRes Class Eco.Persistence Namespace See Also
Collapse All

Returns: "Mapping information stored in database. You may now modify the model and perform Database Evolution"

C#
public static string sMappingInformationStored;
Remarks

For internal use.

See Also
PersistenceStringRes Class
Eco.Persistence Namespace


PersistenceStringRes.sMimerSetup Property

PersistenceStringRes.sMimerSetup Property
PersistenceStringRes Class Eco.Persistence Namespace See Also
Collapse All

Returns: "Mimer setup"

C#
public static string sMimerSetup;
Remarks

For internal use.

See Also
PersistenceStringRes Class
Eco.Persistence Namespace


PersistenceStringRes.sMissingFileAndResourceName Property

PersistenceStringRes.sMissingFileAndResourceName Property
PersistenceStringRes Class Eco.Persistence Namespace See Also
Collapse All

Returns: "FileMappingProvider has no filename and no resource name defined"

C#
public static string sMissingFileAndResourceName;
Remarks

For internal use.

See Also
PersistenceStringRes Class
Eco.Persistence Namespace


PersistenceStringRes.sModelError Property

PersistenceStringRes.sModelError Property
PersistenceStringRes Class Eco.Persistence Namespace See Also
Collapse All

Returns: "Error in reflected model:"

C#
public static string sModelError;
Remarks

For internal use.

See Also
PersistenceStringRes Class
Eco.Persistence Namespace


PersistenceStringRes.sModelErrors Property

PersistenceStringRes.sModelErrors Property
PersistenceStringRes Class Eco.Persistence Namespace See Also
Collapse All

Returns: "Model errors:"

C#
public static string sModelErrors;
Remarks

For internal use.

See Also
PersistenceStringRes Class
Eco.Persistence Namespace


PersistenceStringRes.sModelValidatedOK Property

PersistenceStringRes.sModelValidatedOK Property
PersistenceStringRes Class Eco.Persistence Namespace See Also
Collapse All

Returns: "Model validated OK!"

C#
public static string sModelValidatedOK;
Remarks

For internal use.

See Also
PersistenceStringRes Class
Eco.Persistence Namespace


PersistenceStringRes.sModelValidationCaption Property

PersistenceStringRes.sModelValidationCaption Property
PersistenceStringRes Class Eco.Persistence Namespace See Also
Collapse All

Returns: "Model Validation"

C#
public static string sModelValidationCaption;
Remarks

For internal use.

See Also
PersistenceStringRes Class
Eco.Persistence Namespace


PersistenceStringRes.sMultipleVersionedDatabasesNotAllowed Property

PersistenceStringRes.sMultipleVersionedDatabasesNotAllowed Property
PersistenceStringRes Class Eco.Persistence Namespace See Also
Collapse All

Returns: "Multiple versioned databases is not allowed"

C#
public static string sMultipleVersionedDatabasesNotAllowed;
Remarks

For internal use.

See Also
PersistenceStringRes Class
Eco.Persistence Namespace


PersistenceStringRes.sMySql4Setup Property

PersistenceStringRes.sMySql4Setup Property
PersistenceStringRes Class Eco.Persistence Namespace See Also
Collapse All

Returns: "M&ySQL 4.0 setup"

C#
public static string sMySql4Setup;
Remarks

For internal use.

See Also
PersistenceStringRes Class
Eco.Persistence Namespace


PersistenceStringRes.sMySql5Setup Property

PersistenceStringRes.sMySql5Setup Property
PersistenceStringRes Class Eco.Persistence Namespace See Also
Collapse All

Returns: "MySQL &5.0 setup"

C#
public static string sMySql5Setup;
Remarks

For internal use.

See Also
PersistenceStringRes Class
Eco.Persistence Namespace


PersistenceStringRes.sNegativeDistanceNotAllowed Property

PersistenceStringRes.sNegativeDistanceNotAllowed Property
PersistenceStringRes Class Eco.Persistence Namespace See Also
Collapse All

Returns: "Negative distances not allowed"

C#
public static string sNegativeDistanceNotAllowed;
Remarks

For internal use.

See Also
PersistenceStringRes Class
Eco.Persistence Namespace


PersistenceStringRes.sNoDatabaseMarkedAsVersioned Property

PersistenceStringRes.sNoDatabaseMarkedAsVersioned Property
PersistenceStringRes Class Eco.Persistence Namespace See Also
Collapse All

Returns: "There is no database in the collection that is marked as versioned"

C#
public static string sNoDatabaseMarkedAsVersioned;
Remarks

For internal use.

See Also
PersistenceStringRes Class
Eco.Persistence Namespace


PersistenceStringRes.sNoPMapper Property

PersistenceStringRes.sNoPMapper Property
PersistenceStringRes Class Eco.Persistence Namespace See Also
Collapse All

Returns: "Persistence mapper not available. Cannot perform operation."

C#
public static string sNoPMapper;
Remarks

For internal use.

See Also
PersistenceStringRes Class
Eco.Persistence Namespace


PersistenceStringRes.sNotConnected Property

PersistenceStringRes.sNotConnected Property
PersistenceStringRes Class Eco.Persistence Namespace See Also
Collapse All

Returns: "Not Connected"

C#
public static string sNotConnected;
Remarks

For internal use.

See Also
PersistenceStringRes Class
Eco.Persistence Namespace


PersistenceStringRes.sNoTransactionToCommit Property

PersistenceStringRes.sNoTransactionToCommit Property
PersistenceStringRes Class Eco.Persistence Namespace See Also
Collapse All

Returns: "No transaction to Commit"

C#
public static string sNoTransactionToCommit;
Remarks

For internal use.

See Also
PersistenceStringRes Class
Eco.Persistence Namespace


PersistenceStringRes.sNoTransactionToRollback Property

PersistenceStringRes.sNoTransactionToRollback Property
PersistenceStringRes Class Eco.Persistence Namespace See Also
Collapse All

Returns: "No transaction to Rollback"

C#
public static string sNoTransactionToRollback;
Remarks

For internal use.

See Also
PersistenceStringRes Class
Eco.Persistence Namespace


PersistenceStringRes.sNoValueChangeOnActivePersistenceMapper Property

PersistenceStringRes.sNoValueChangeOnActivePersistenceMapper Property
PersistenceStringRes Class Eco.Persistence Namespace See Also
Collapse All

Returns: "Can't change value on active PersistenceMapper"

C#
public static string sNoValueChangeOnActivePersistenceMapper;
Remarks

For internal use.

See Also
PersistenceStringRes Class
Eco.Persistence Namespace


PersistenceStringRes.sOldMappingProviderIsNotDb Property

PersistenceStringRes.sOldMappingProviderIsNotDb Property
PersistenceStringRes Class Eco.Persistence Namespace See Also
Collapse All

Returns: "PersistenceHandle.OldMappingProvider is not a DbMappingProvider"

C#
public static string sOldMappingProviderIsNotDb;
Remarks

For internal use.

See Also
PersistenceStringRes Class
Eco.Persistence Namespace


PersistenceStringRes.sOperationCreateDatabase Property

PersistenceStringRes.sOperationCreateDatabase Property
PersistenceStringRes Class Eco.Persistence Namespace See Also
Collapse All

Returns: "Create Database"

C#
public static string sOperationCreateDatabase;
Remarks

For internal use.

See Also
PersistenceStringRes Class
Eco.Persistence Namespace


PersistenceStringRes.sOperationEvolveDB Property

PersistenceStringRes.sOperationEvolveDB Property
PersistenceStringRes Class Eco.Persistence Namespace See Also
Collapse All

Returns: "DbEvolution"

C#
public static string sOperationEvolveDB;
Remarks

For internal use.

See Also
PersistenceStringRes Class
Eco.Persistence Namespace


PersistenceStringRes.sOperationGenerateMappingXml Property

PersistenceStringRes.sOperationGenerateMappingXml Property
PersistenceStringRes Class Eco.Persistence Namespace See Also
Collapse All

Returns: "Generate default mapping XML"

C#
public static string sOperationGenerateMappingXml;
Remarks

For internal use.

See Also
PersistenceStringRes Class
Eco.Persistence Namespace


PersistenceStringRes.sOperationMustBePerformedFromPersistenceMapperProvider Property

PersistenceStringRes.sOperationMustBePerformedFromPersistenceMapperProvider Property
PersistenceStringRes Class Eco.Persistence Namespace See Also
Collapse All

Returns: "This operation must be performed from your PersistenceMapperProvider"

C#
public static string sOperationMustBePerformedFromPersistenceMapperProvider;
Remarks

For internal use.

See Also
PersistenceStringRes Class
Eco.Persistence Namespace


PersistenceStringRes.sOracleMBCSSetup Property

PersistenceStringRes.sOracleMBCSSetup Property
PersistenceStringRes Class Eco.Persistence Namespace See Also
Collapse All

Returns: "Ora&cle setup (MBCS)"

C#
public static string sOracleMBCSSetup;
Remarks

For internal use.

See Also
PersistenceStringRes Class
Eco.Persistence Namespace


PersistenceStringRes.sOracleSetup Property

PersistenceStringRes.sOracleSetup Property
PersistenceStringRes Class Eco.Persistence Namespace See Also
Collapse All

Returns: "&Oracle setup"

C#
public static string sOracleSetup;
Remarks

For internal use.

See Also
PersistenceStringRes Class
Eco.Persistence Namespace


PersistenceStringRes.sPersistenceHandleCaption Property

PersistenceStringRes.sPersistenceHandleCaption Property
PersistenceStringRes Class Eco.Persistence Namespace See Also
Collapse All

Returns: "PersistenceMapper"

C#
public static string sPersistenceHandleCaption;
Remarks

For internal use.

See Also
PersistenceStringRes Class
Eco.Persistence Namespace


PersistenceStringRes.sPersistenceHandleMissing Property

PersistenceStringRes.sPersistenceHandleMissing Property
PersistenceStringRes Class Eco.Persistence Namespace See Also
Collapse All

Returns: "The ECO Space has no persistence mapper"

C#
public static string sPersistenceHandleMissing;
Remarks

For internal use.

See Also
PersistenceStringRes Class
Eco.Persistence Namespace


PersistenceStringRes.sPersistenceMapperInUseWithOtherTypeSystem Property

PersistenceStringRes.sPersistenceMapperInUseWithOtherTypeSystem Property
PersistenceStringRes Class Eco.Persistence Namespace See Also
Collapse All

Returns: "Persistence mapper already in use with other type system"

C#
public static string sPersistenceMapperInUseWithOtherTypeSystem;
Remarks

For internal use.

See Also
PersistenceStringRes Class
Eco.Persistence Namespace


PersistenceStringRes.sPersistenceMapperNotSetInPMP Property

PersistenceStringRes.sPersistenceMapperNotSetInPMP Property
PersistenceStringRes Class Eco.Persistence Namespace See Also
Collapse All

Returns: "PersistenceMapper not set in PersistenceMapperProvider"

C#
public static string sPersistenceMapperNotSetInPMP;
Remarks

For internal use.

See Also
PersistenceStringRes Class
Eco.Persistence Namespace


PersistenceStringRes.sPMapperInUse Property

PersistenceStringRes.sPMapperInUse Property
PersistenceStringRes Class Eco.Persistence Namespace See Also
Collapse All

Returns: "PersistenceMapper in use"

C#
public static string sPMapperInUse;
Remarks

For internal use.

See Also
PersistenceStringRes Class
Eco.Persistence Namespace


PersistenceStringRes.sPropertyClassNameColumnName Property

PersistenceStringRes.sPropertyClassNameColumnName Property
PersistenceStringRes Class Eco.Persistence Namespace See Also
Collapse All

Returns: "Name of the column containing the class names."

C#
public static string sPropertyClassNameColumnName;
Remarks

For internal use.

See Also
PersistenceStringRes Class
Eco.Persistence Namespace


PersistenceStringRes.sPropertyClassNameSignature Property

PersistenceStringRes.sPropertyClassNameSignature Property
PersistenceStringRes Class Eco.Persistence Namespace See Also
Collapse All

Returns: "Datatype or name of mapper to read class names from ECOTYPES table."

C#
public static string sPropertyClassNameSignature;
Remarks

For internal use.

See Also
PersistenceStringRes Class
Eco.Persistence Namespace


PersistenceStringRes.sPropertyClockLogGranularity Property

PersistenceStringRes.sPropertyClockLogGranularity Property
PersistenceStringRes Class Eco.Persistence Namespace See Also
Collapse All

Returns: "Granularity of the clock log file."

C#
public static string sPropertyClockLogGranularity;
Remarks

For internal use.

See Also
PersistenceStringRes Class
Eco.Persistence Namespace


PersistenceStringRes.sPropertyConnection Property

PersistenceStringRes.sPropertyConnection Property
PersistenceStringRes Class Eco.Persistence Namespace See Also
Collapse All

Returns: "Specify the connection to use for the handle."

C#
public static string sPropertyConnection;
Remarks

For internal use.

See Also
PersistenceStringRes Class
Eco.Persistence Namespace


PersistenceStringRes.sPropertyDatabase Property

PersistenceStringRes.sPropertyDatabase Property
PersistenceStringRes Class Eco.Persistence Namespace See Also
Collapse All

Returns: "The database the mapping builder handles (only for use with multiple data sources)."

C#
public static string sPropertyDatabase;
Remarks

For internal use.

See Also
PersistenceStringRes Class
Eco.Persistence Namespace


PersistenceStringRes.sPropertyEcoSpaceTypeName Property

PersistenceStringRes.sPropertyEcoSpaceTypeName Property
PersistenceStringRes Class Eco.Persistence Namespace See Also
Collapse All

Returns: "The type of the ECO Space to be persisted."

C#
public static string sPropertyEcoSpaceTypeName;
Remarks

For internal use.

See Also
PersistenceStringRes Class
Eco.Persistence Namespace


PersistenceStringRes.sPropertyEvolutionSupport Property

PersistenceStringRes.sPropertyEvolutionSupport Property
PersistenceStringRes Class Eco.Persistence Namespace See Also
Collapse All

Returns: "Determines if the database supports evolution."

C#
public static string sPropertyEvolutionSupport;
Remarks

For internal use.

See Also
PersistenceStringRes Class
Eco.Persistence Namespace


PersistenceStringRes.sPropertyHistoryLength Property

PersistenceStringRes.sPropertyHistoryLength Property
PersistenceStringRes Class Eco.Persistence Namespace See Also
Collapse All

Returns: "Number of updates to Sync."

C#
public static string sPropertyHistoryLength;
Remarks

For internal use.

See Also
PersistenceStringRes Class
Eco.Persistence Namespace


PersistenceStringRes.sPropertyIdColumnName Property

PersistenceStringRes.sPropertyIdColumnName Property
PersistenceStringRes Class Eco.Persistence Namespace See Also
Collapse All

Returns: "Name of column containing ID."

C#
public static string sPropertyIdColumnName;
Remarks

For internal use.

See Also
PersistenceStringRes Class
Eco.Persistence Namespace


PersistenceStringRes.sPropertyIdIsAutoInc Property

PersistenceStringRes.sPropertyIdIsAutoInc Property
PersistenceStringRes Class Eco.Persistence Namespace See Also
Collapse All

Returns: "If true, IDs will be generated through auto-incremental fields."

C#
public static string sPropertyIdIsAutoInc;
Remarks

For internal use.

See Also
PersistenceStringRes Class
Eco.Persistence Namespace


PersistenceStringRes.sPropertyIdKeyName Property

PersistenceStringRes.sPropertyIdKeyName Property
PersistenceStringRes Class Eco.Persistence Namespace See Also
Collapse All

Returns: "Name of key definition in XML file."

C#
public static string sPropertyIdKeyName;
Remarks

For internal use.

See Also
PersistenceStringRes Class
Eco.Persistence Namespace


PersistenceStringRes.sPropertyIdKeySignature Property

PersistenceStringRes.sPropertyIdKeySignature Property
PersistenceStringRes Class Eco.Persistence Namespace See Also
Collapse All

Returns: "Data type of key."

C#
public static string sPropertyIdKeySignature;
Remarks

For internal use.

See Also
PersistenceStringRes Class
Eco.Persistence Namespace


PersistenceStringRes.sPropertyIdMapperName Property

PersistenceStringRes.sPropertyIdMapperName Property
PersistenceStringRes Class Eco.Persistence Namespace See Also
Collapse All

Returns: "Name of the key mapper to use for the id in the XML file."

C#
public static string sPropertyIdMapperName;
Remarks

For internal use.

See Also
PersistenceStringRes Class
Eco.Persistence Namespace


PersistenceStringRes.sPropertyMaxOpenConnections Property

PersistenceStringRes.sPropertyMaxOpenConnections Property
PersistenceStringRes Class Eco.Persistence Namespace See Also
Collapse All

Returns: "The max number of open connections."

C#
public static string sPropertyMaxOpenConnections;
Remarks

For internal use.

See Also
PersistenceStringRes Class
Eco.Persistence Namespace


PersistenceStringRes.sPropertyMaxPooledConnections Property

PersistenceStringRes.sPropertyMaxPooledConnections Property
PersistenceStringRes Class Eco.Persistence Namespace See Also
Collapse All

Returns: "The max number of connections that will be pooled."

C#
public static string sPropertyMaxPooledConnections;
Remarks

For internal use.

See Also
PersistenceStringRes Class
Eco.Persistence Namespace


PersistenceStringRes.sPropertyNewMappingProvider Property

PersistenceStringRes.sPropertyNewMappingProvider Property
PersistenceStringRes Class Eco.Persistence Namespace See Also
Collapse All

Returns: "Specify a component to provide new O/R mapping configuration for DbEvolution (no setting will derive mapping from model)."

C#
public static string sPropertyNewMappingProvider;
Remarks

For internal use.

See Also
PersistenceStringRes Class
Eco.Persistence Namespace


PersistenceStringRes.sPropertyOldMappingProvider Property

PersistenceStringRes.sPropertyOldMappingProvider Property
PersistenceStringRes Class Eco.Persistence Namespace See Also
Collapse All

Returns: "Specify a component to provide old O/R mapping configuration for DbEvolution (no setting will load mapping from database)."

C#
public static string sPropertyOldMappingProvider;
Remarks

For internal use.

See Also
PersistenceStringRes Class
Eco.Persistence Namespace


PersistenceStringRes.sPropertyPersistenceMapper Property

PersistenceStringRes.sPropertyPersistenceMapper Property
PersistenceStringRes Class Eco.Persistence Namespace See Also
Collapse All

Returns: "The persistence mapper that should be used to persist the data."

C#
public static string sPropertyPersistenceMapper;
Remarks

For internal use.

See Also
PersistenceStringRes Class
Eco.Persistence Namespace


PersistenceStringRes.sPropertyResourceName Property

PersistenceStringRes.sPropertyResourceName Property
PersistenceStringRes Class Eco.Persistence Namespace See Also
Collapse All

Returns: "Name of resource containing O/R Mapping information."

C#
public static string sPropertyResourceName;
Remarks

For internal use.

See Also
PersistenceStringRes Class
Eco.Persistence Namespace


PersistenceStringRes.sPropertyRootTableName Property

PersistenceStringRes.sPropertyRootTableName Property
PersistenceStringRes Class Eco.Persistence Namespace See Also
Collapse All

Returns: "Name of the table of the model's implicit root class (defaults to EcoModelRoot)."

C#
public static string sPropertyRootTableName;
Remarks

For internal use.

See Also
PersistenceStringRes Class
Eco.Persistence Namespace


PersistenceStringRes.sPropertyRunTimeMappingProvider Property

PersistenceStringRes.sPropertyRunTimeMappingProvider Property
PersistenceStringRes Class Eco.Persistence Namespace See Also
Collapse All

Returns: "Specify a component to provide Runtime O/R mapping configuration (no setting will derive mapping from model)."

C#
public static string sPropertyRunTimeMappingProvider;
Remarks

For internal use.

See Also
PersistenceStringRes Class
Eco.Persistence Namespace


PersistenceStringRes.sPropertySqlDatabaseConfig Property

PersistenceStringRes.sPropertySqlDatabaseConfig Property
PersistenceStringRes Class Eco.Persistence Namespace See Also
Collapse All

Returns: "Specify the connection to use for the handle."

C#
public static string sPropertySqlDatabaseConfig;
Remarks

For internal use.

See Also
PersistenceStringRes Class
Eco.Persistence Namespace


PersistenceStringRes.sPropertySyncActive Property

PersistenceStringRes.sPropertySyncActive Property
PersistenceStringRes Class Eco.Persistence Namespace See Also
Collapse All

Returns: "Synchronization active."

C#
public static string sPropertySyncActive;
Remarks

For internal use.

See Also
PersistenceStringRes Class
Eco.Persistence Namespace


PersistenceStringRes.sPropertySyncHandler Property

PersistenceStringRes.sPropertySyncHandler Property
PersistenceStringRes Class Eco.Persistence Namespace See Also
Collapse All

Returns: "Specify a SyncHandler component if Sync is to be active"

C#
public static string sPropertySyncHandler;
Remarks

For internal use.

See Also
PersistenceStringRes Class
Eco.Persistence Namespace


PersistenceStringRes.sPropertyTablesColumnName Property

PersistenceStringRes.sPropertyTablesColumnName Property
PersistenceStringRes Class Eco.Persistence Namespace See Also
Collapse All

Returns: "Name of the column containing the table names."

C#
public static string sPropertyTablesColumnName;
Remarks

For internal use.

See Also
PersistenceStringRes Class
Eco.Persistence Namespace


PersistenceStringRes.sPropertyTablesTableName Property

PersistenceStringRes.sPropertyTablesTableName Property
PersistenceStringRes Class Eco.Persistence Namespace See Also
Collapse All

Returns: "Name of the table containing the list of tables."

C#
public static string sPropertyTablesTableName;
Remarks

For internal use.

See Also
PersistenceStringRes Class
Eco.Persistence Namespace


PersistenceStringRes.sPropertyTypeColumnName Property

PersistenceStringRes.sPropertyTypeColumnName Property
PersistenceStringRes Class Eco.Persistence Namespace See Also
Collapse All

Returns: "Name of the column containing the type names."

C#
public static string sPropertyTypeColumnName;
Remarks

For internal use.

See Also
PersistenceStringRes Class
Eco.Persistence Namespace


PersistenceStringRes.sPropertyTypeDiscriminatorName Property

PersistenceStringRes.sPropertyTypeDiscriminatorName Property
PersistenceStringRes Class Eco.Persistence Namespace See Also
Collapse All

Returns: "Name of discriminator definition in XML file."

C#
public static string sPropertyTypeDiscriminatorName;
Remarks

For internal use.

See Also
PersistenceStringRes Class
Eco.Persistence Namespace


PersistenceStringRes.sPropertyTypeDiscriminatorSignature Property

PersistenceStringRes.sPropertyTypeDiscriminatorSignature Property
PersistenceStringRes Class Eco.Persistence Namespace See Also
Collapse All

Returns: "Data type of discriminator."

C#
public static string sPropertyTypeDiscriminatorSignature;
Remarks

For internal use.

See Also
PersistenceStringRes Class
Eco.Persistence Namespace


PersistenceStringRes.sPropertyTypeTableName Property

PersistenceStringRes.sPropertyTypeTableName Property
PersistenceStringRes Class Eco.Persistence Namespace See Also
Collapse All

Returns: "Name of the table containing the list of types in the model."

C#
public static string sPropertyTypeTableName;
Remarks

For internal use.

See Also
PersistenceStringRes Class
Eco.Persistence Namespace


PersistenceStringRes.sPropertyUrl Property

PersistenceStringRes.sPropertyUrl Property
PersistenceStringRes Class Eco.Persistence Namespace See Also
Collapse All

Returns: "URL for server, e.g. tcp://localhost:4243/PersistenceServer"

C#
public static string sPropertyUrl;
Remarks

For internal use.

See Also
PersistenceStringRes Class
Eco.Persistence Namespace


PersistenceStringRes.sPropertyXmlFileName Property

PersistenceStringRes.sPropertyXmlFileName Property
PersistenceStringRes Class Eco.Persistence Namespace See Also
Collapse All

Returns: "Name of file containing O/R Mapping information."

C#
public static string sPropertyXmlFileName;
Remarks

For internal use.

See Also
PersistenceStringRes Class
Eco.Persistence Namespace


PersistenceStringRes.sProviderUsedWithOtherTypeSystem Property

PersistenceStringRes.sProviderUsedWithOtherTypeSystem Property
PersistenceStringRes Class Eco.Persistence Namespace See Also
Collapse All

Returns: "Provider already in use with other type system"

C#
public static string sProviderUsedWithOtherTypeSystem;
Remarks

For internal use.

See Also
PersistenceStringRes Class
Eco.Persistence Namespace


PersistenceStringRes.SqlDatabaseConfigNotValid Property

PersistenceStringRes.SqlDatabaseConfigNotValid Property
PersistenceStringRes Class Eco.Persistence Namespace See Also
Collapse All

Returns: "SqlDatabaseConfig is not properly configured."

C#
public static string SqlDatabaseConfigNotValid;
Remarks

For internal use.

See Also
PersistenceStringRes Class
Eco.Persistence Namespace


PersistenceStringRes.sReservedWordColumnSuffix Property

PersistenceStringRes.sReservedWordColumnSuffix Property
PersistenceStringRes Class Eco.Persistence Namespace See Also
Collapse All

Returns: "Suffix to add to column names to avoid collisions with reserved words"

C#
public static string sReservedWordColumnSuffix;
Remarks

For internal use.

See Also
PersistenceStringRes Class
Eco.Persistence Namespace


PersistenceStringRes.sReservedWordTableSuffix Property

PersistenceStringRes.sReservedWordTableSuffix Property
PersistenceStringRes Class Eco.Persistence Namespace See Also
Collapse All

Returns: "Suffix to add to table names to avoid collisions with reserved words"

C#
public static string sReservedWordTableSuffix;
Remarks

For internal use.

See Also
PersistenceStringRes Class
Eco.Persistence Namespace


PersistenceStringRes.sRootclassIsNotPersistent Property

PersistenceStringRes.sRootclassIsNotPersistent Property
PersistenceStringRes Class Eco.Persistence Namespace See Also
Collapse All

Returns: "Rootclass is not persistent"

C#
public static string sRootclassIsNotPersistent;
Remarks

For internal use.

See Also
PersistenceStringRes Class
Eco.Persistence Namespace


PersistenceStringRes.sSaveMappingInfo Property

PersistenceStringRes.sSaveMappingInfo Property
PersistenceStringRes Class Eco.Persistence Namespace See Also
Collapse All

Returns: "Save Mapping Info"

C#
public static string sSaveMappingInfo;
Remarks

For internal use.

See Also
PersistenceStringRes Class
Eco.Persistence Namespace


PersistenceStringRes.sSaveMappingInfoCaption Property

PersistenceStringRes.sSaveMappingInfoCaption Property
PersistenceStringRes Class Eco.Persistence Namespace See Also
Collapse All

Returns: "Save Mapping Information"

C#
public static string sSaveMappingInfoCaption;
Remarks

For internal use.

See Also
PersistenceStringRes Class
Eco.Persistence Namespace


PersistenceStringRes.sSchemaCreated Property

PersistenceStringRes.sSchemaCreated Property
PersistenceStringRes Class Eco.Persistence Namespace See Also
Collapse All

Returns: "Database schema created"

C#
public static string sSchemaCreated;
Remarks

For internal use.

See Also
PersistenceStringRes Class
Eco.Persistence Namespace


PersistenceStringRes.sSchemaGenerationCaption Property

PersistenceStringRes.sSchemaGenerationCaption Property
PersistenceStringRes Class Eco.Persistence Namespace See Also
Collapse All

Returns: "Schema Generation"

C#
public static string sSchemaGenerationCaption;
Remarks

For internal use.

See Also
PersistenceStringRes Class
Eco.Persistence Namespace


PersistenceStringRes.sSharerInUse Property

PersistenceStringRes.sSharerInUse Property
PersistenceStringRes Class Eco.Persistence Namespace See Also
Collapse All

Returns: "Sharer in use"

C#
public static string sSharerInUse;
Remarks

For internal use.

See Also
PersistenceStringRes Class
Eco.Persistence Namespace


PersistenceStringRes.sSQLConfigDesignerTransactionName Property

PersistenceStringRes.sSQLConfigDesignerTransactionName Property
PersistenceStringRes Class Eco.Persistence Namespace See Also
Collapse All

Returns: "Updating DB settings"

C#
public static string sSQLConfigDesignerTransactionName;
Remarks

For internal use.

See Also
PersistenceStringRes Class
Eco.Persistence Namespace


PersistenceStringRes.sSqlServer7MBCSSetup Property

PersistenceStringRes.sSqlServer7MBCSSetup Property
PersistenceStringRes Class Eco.Persistence Namespace See Also
Collapse All

Returns: "SQL Se&rver 7 setup (MBCS)"

C#
public static string sSqlServer7MBCSSetup;
Remarks

For internal use.

See Also
PersistenceStringRes Class
Eco.Persistence Namespace


PersistenceStringRes.sSqlServer7Setup Property

PersistenceStringRes.sSqlServer7Setup Property
PersistenceStringRes Class Eco.Persistence Namespace See Also
Collapse All

Returns: "SQ&L Server 7 setup"

C#
public static string sSqlServer7Setup;
Remarks

For internal use.

See Also
PersistenceStringRes Class
Eco.Persistence Namespace


PersistenceStringRes.sSqlServerMBCSSetup Property

PersistenceStringRes.sSqlServerMBCSSetup Property
PersistenceStringRes Class Eco.Persistence Namespace See Also
Collapse All

Returns: "SQL S&erver 2k/2k5/2k8 setup (MBCS)"

C#
public static string sSqlServerMBCSSetup;
Remarks

For internal use.

See Also
PersistenceStringRes Class
Eco.Persistence Namespace


PersistenceStringRes.sSqlServerSetup Property

PersistenceStringRes.sSqlServerSetup Property
PersistenceStringRes Class Eco.Persistence Namespace See Also
Collapse All

Returns: "S&QL Server 2k/2k5/2k8 setup"

C#
public static string sSqlServerSetup;
Remarks

For internal use.

See Also
PersistenceStringRes Class
Eco.Persistence Namespace


PersistenceStringRes.sSybaseSetup Property

PersistenceStringRes.sSybaseSetup Property
PersistenceStringRes Class Eco.Persistence Namespace See Also
Collapse All

Returns: "&Sybase setup"

C#
public static string sSybaseSetup;
Remarks

For internal use.

See Also
PersistenceStringRes Class
Eco.Persistence Namespace


PersistenceStringRes.sSyncNotActive Property

PersistenceStringRes.sSyncNotActive Property
PersistenceStringRes Class Eco.Persistence Namespace See Also
Collapse All

Returns: "Sync not active"

C#
public static string sSyncNotActive;
Remarks

For internal use.

See Also
PersistenceStringRes Class
Eco.Persistence Namespace


PersistenceStringRes.sTransactionInProgress Property

PersistenceStringRes.sTransactionInProgress Property
PersistenceStringRes Class Eco.Persistence Namespace See Also
Collapse All

Returns: "A transaction is already in progress"

C#
public static string sTransactionInProgress;
Remarks

For internal use.

See Also
PersistenceStringRes Class
Eco.Persistence Namespace


PersistenceStringRes.sTransactionNotFinished Property

PersistenceStringRes.sTransactionNotFinished Property
PersistenceStringRes Class Eco.Persistence Namespace See Also
Collapse All

Returns: "Transaction not finished"

C#
public static string sTransactionNotFinished;
Remarks

For internal use.

See Also
PersistenceStringRes Class
Eco.Persistence Namespace


PersistenceStringRes.TypeSystemHasNoClasses Property

PersistenceStringRes.TypeSystemHasNoClasses Property
PersistenceStringRes Class Eco.Persistence Namespace See Also
Collapse All

Returns: "TypeSystem has no classes defined"

C#
public static string TypeSystemHasNoClasses;
Remarks

For internal use.

See Also
PersistenceStringRes Class
Eco.Persistence Namespace


PersistenceStringRes.UnabletoReadParameterValue Property

PersistenceStringRes.UnabletoReadParameterValue Property
PersistenceStringRes Class Eco.Persistence Namespace See Also
Collapse All

Returns: "Unable to read parameter value"

C#
public static string UnabletoReadParameterValue;
Remarks

For internal use.

See Also
PersistenceStringRes Class
Eco.Persistence Namespace


PersistenceStringRes.UnsupportedColumnToValueCall Property

PersistenceStringRes.UnsupportedColumnToValueCall Property
PersistenceStringRes Class Eco.Persistence Namespace See Also
Collapse All

Returns: "This mapper only supports 'ColumnToValue(columnValue, expectedType)'"

C#
public static string UnsupportedColumnToValueCall;
Remarks

For internal use.

See Also
PersistenceStringRes Class
Eco.Persistence Namespace


PersistenceStringRes.UnsupportedStringToParameterCall Property

PersistenceStringRes.UnsupportedStringToParameterCall Property
PersistenceStringRes Class Eco.Persistence Namespace See Also
Collapse All

Returns: "This mapper only supports 'StringToParameter(parameter, expectedType)'"

C#
public static string UnsupportedStringToParameterCall;
Remarks

For internal use.

See Also
PersistenceStringRes Class
Eco.Persistence Namespace


PMapperDef Class

PMapperDef Class
Inheritance Hierarchy See Also
Collapse All

PMapperDef is the itemtype in PersistenceMapperDbCollection.

C#
public sealed class PMapperDef;
Remarks

This class associated a PersistenceMapperDb with a name. The resulting item is used in PersistenceMapperDbCollection which in turn is used by PersistenceMapperMultiDb.

Inheritance Hierarchy
Eco.Persistence.PMapperDef
File

PMapperDef.cs

See Also
Inheritance Hierarchy


PMapperDef Methods

PMapperDef Methods
Public Methods
Collapse All

The methods of the PMapperDef class are listed here.

Public Methods
Name | Description
ToString | Returns a string representation of the instance.


PMapperDef.ToString Method

PMapperDef.ToString Method
PMapperDef Class Eco.Persistence Namespace See Also
Collapse All

Returns a string representation of the instance.

C#
public override string ToString();
Remarks

The string looks like Name + ": " + Mapper.GetType().ToString().

See Also
PMapperDef Class
Eco.Persistence Namespace


PMapperDef Properties

PMapperDef Properties
Public Properties
Collapse All

The properties of the PMapperDef class are listed here.

Public Properties
Name | Description
ImportConfig | If this property is set, the O/R mapping that is specified for the PersistenceMapper (implicit or explicit) will be used.
IsVersioned | Only one of the databases may contain versioned objects. The database with this property will used for the operations VersionForTime and TimeForVersion
Mapper | The PersistenceMapper that configures the database connection. Must be a subclass of PersistenceMapperDb
Name | Each database must be referenced with a name. This name can be used either in the model (tagged value "Database" for classes) or directly in an O/R mapping file.


PMapperDef.ImportConfig Property

PMapperDef.ImportConfig Property
PMapperDef Class Eco.Persistence Namespace See Also
Collapse All

If this property is set, the O/R mapping that is specified for the PersistenceMapper (implicit or explicit) will be used.

C#
public bool ImportConfig;
See Also
PMapperDef Class
Eco.Persistence Namespace


PMapperDef.IsVersioned Property

PMapperDef.IsVersioned Property
PMapperDef Class Eco.Persistence Namespace See Also
Collapse All

Only one of the databases may contain versioned objects. The database with this property will used for the operations VersionForTime and TimeForVersion

C#
public bool IsVersioned;
See Also
PMapperDef Class
Eco.Persistence Namespace


PMapperDef.Mapper Property

PMapperDef.Mapper Property
PMapperDef Class Eco.Persistence Namespace See Also
Collapse All

The PersistenceMapper that configures the database connection. Must be a subclass of PersistenceMapperDb

C#
public PersistenceMapperDb Mapper;
Remarks

[LocalizableCategory(typeof(PersistenceStringRes), "sCategoryPersistenceTuning")]

See Also
PMapperDef Class
Eco.Persistence Namespace


PMapperDef.Name Property

PMapperDef.Name Property
PMapperDef Class Eco.Persistence Namespace See Also
Collapse All

Each database must be referenced with a name. This name can be used either in the model (tagged value "Database" for classes) or directly in an O/R mapping file.

C#
public string Name;
Remarks

[LocalizableCategory(typeof(PersistenceStringRes), "sCategoryPersistenceTuning")]

See Also
PMapperDef Class
Eco.Persistence Namespace


SimpleORMappingProvider Class

SimpleORMappingProvider Class
Inheritance Hierarchy See Also
Collapse All
C#
public sealed class SimpleORMappingProvider : IORMappingProvider;
Remarks

This is class Eco.Persistence.SimpleORMappingProvider.

Inheritance Hierarchy
Eco.Persistence.SimpleORMappingProvider
File

PersistenceMapperMultiDb.cs

See Also
Inheritance Hierarchy


SimpleORMappingProvider.SimpleORMappingProvider Constructor

SimpleORMappingProvider.SimpleORMappingProvider Constructor
SimpleORMappingProvider Class Eco.Persistence Namespace See Also
Collapse All
C#
public SimpleORMappingProvider(
    ORMappingDefinition mapping,
    IORMappingProvider nextProvider
);
Remarks

This is SimpleORMappingProvider, a member of class SimpleORMappingProvider.

See Also
SimpleORMappingProvider Class
Eco.Persistence Namespace


SimpleORMappingProvider Methods

SimpleORMappingProvider Methods
Public Methods
Collapse All

The methods of the SimpleORMappingProvider class are listed here.

Public Methods
Name | Description
Initialize | This is Initialize, a member of class SimpleORMappingProvider.
PostCreateDb | This is PostCreateDb, a member of class SimpleORMappingProvider.
PostEvolveDb | This is PostEvolveDb, a member of class SimpleORMappingProvider.
PostEvolveDbScript | This is PostEvolveDbScript, a member of class SimpleORMappingProvider.
SaveMappingInfo | This is SaveMappingInfo, a member of class SimpleORMappingProvider.
SystemTableNames | This is SystemTableNames, a member of class SimpleORMappingProvider.


SimpleORMappingProvider.Initialize Method

SimpleORMappingProvider.Initialize Method
SimpleORMappingProvider Class Eco.Persistence Namespace See Also
Collapse All
C#
public void Initialize(
    IEcoTypeSystem typeSystem,
    IDatabase db,
    SqlDatabaseConfig config,
    bool addMissingTypes
);
Remarks

This is Initialize, a member of class SimpleORMappingProvider.

See Also
SimpleORMappingProvider Class
Eco.Persistence Namespace


SimpleORMappingProvider.PostCreateDb Method

SimpleORMappingProvider.PostCreateDb Method
SimpleORMappingProvider Class Eco.Persistence Namespace See Also
Collapse All
C#
public void PostCreateDb(
    IDatabase db,
    SqlDatabaseConfig sqlDatabaseConfig,
    ORMappingDefinition newMapping
);
Remarks

This is PostCreateDb, a member of class SimpleORMappingProvider.

See Also
SimpleORMappingProvider Class
Eco.Persistence Namespace


SimpleORMappingProvider.PostEvolveDb Method

SimpleORMappingProvider.PostEvolveDb Method
SimpleORMappingProvider Class Eco.Persistence Namespace See Also
Collapse All
C#
public void PostEvolveDb(
    IDatabase db,
    SqlDatabaseConfig sqlDatabaseConfig,
    ORMappingDefinition newMapping
);
Remarks

This is PostEvolveDb, a member of class SimpleORMappingProvider.

See Also
SimpleORMappingProvider Class
Eco.Persistence Namespace


SimpleORMappingProvider.PostEvolveDbScript Method

SimpleORMappingProvider.PostEvolveDbScript Method
SimpleORMappingProvider Class Eco.Persistence Namespace See Also
Collapse All
C#
public void PostEvolveDbScript(
    IDatabase db,
    SqlDatabaseConfig sqlDatabaseConfig,
    ORMappingDefinition newMapping,
    IList<string> script
);
Remarks

This is PostEvolveDbScript, a member of class SimpleORMappingProvider.

See Also
SimpleORMappingProvider Class
Eco.Persistence Namespace


SimpleORMappingProvider.SaveMappingInfo Method

SimpleORMappingProvider.SaveMappingInfo Method
SimpleORMappingProvider Class Eco.Persistence Namespace See Also
Collapse All
C#
public void SaveMappingInfo(
    IDatabase db,
    SqlDatabaseConfig sqlDatabaseConfig,
    ORMappingDefinition newMapping
);
Remarks

This is SaveMappingInfo, a member of class SimpleORMappingProvider.

See Also
SimpleORMappingProvider Class
Eco.Persistence Namespace


SimpleORMappingProvider.SystemTableNames Method

SimpleORMappingProvider.SystemTableNames Method
SimpleORMappingProvider Class Eco.Persistence Namespace See Also
Collapse All
C#
public IList<string> SystemTableNames(
    SqlDatabaseConfig config
);
Remarks

This is SystemTableNames, a member of class SimpleORMappingProvider.

See Also
SimpleORMappingProvider Class
Eco.Persistence Namespace


SimpleORMappingProvider Properties

SimpleORMappingProvider Properties
Public Properties
Collapse All

The properties of the SimpleORMappingProvider class are listed here.

Public Properties
Name | Description
Mapping | This is Mapping, a member of class SimpleORMappingProvider.


SimpleORMappingProvider.Mapping Property

SimpleORMappingProvider.Mapping Property
SimpleORMappingProvider Class Eco.Persistence Namespace See Also
Collapse All
C#
public ORMappingDefinition Mapping;
Remarks

This is Mapping, a member of class SimpleORMappingProvider.

See Also
SimpleORMappingProvider Class
Eco.Persistence Namespace


SyncHandler Class

SyncHandler Class
Inheritance Hierarchy See Also
Collapse All
C#
public class SyncHandler : AbstractSyncHandler, ISyncSink;
Remarks

This is class Eco.Persistence.SyncHandler.

Inheritance Hierarchy
Eco.Persistence.ISyncSink
    Eco.Persistence.AbstractSyncHandler
        Eco.Persistence.SyncHandler
File

SyncHandler.cs

See Also
Inheritance Hierarchy


SyncHandler Methods

SyncHandler Methods
Public Methods
Collapse All

The methods of the SyncHandler class are listed here.

Public Methods
Name | Description
CurrentSyncVersion | Returns the current sync version.
GetChangesSince | Returns a collection of DBChange since a given time.


SyncHandler.CurrentSyncVersion Method

SyncHandler.CurrentSyncVersion Method
SyncHandler Class Eco.Persistence Namespace See Also
Collapse All

Returns the current sync version.

C#
public override SyncVersion CurrentSyncVersion();
See Also
SyncHandler Class
Eco.Persistence Namespace


SyncHandler.GetChangesSince Method

SyncHandler.GetChangesSince Method
SyncHandler Class Eco.Persistence Namespace See Also
Collapse All

Returns a collection of DBChange since a given time.

C#
public override DBChangeCollection GetChangesSince(
    SyncVersion fromVersion,
    SyncVersion[] exclude,
    out SyncVersion lastSyncVersion,
    IEcoTypeSystem typeSystem
);
Parameters
Parameters | Description
fromVersion | The earliest version to start returning changes from.
exclude | An array of version numbers that the client instigated, this prevents a client from receiving a list of its own changes.
lastSyncVersion | Returns the latest sync version.
typeSystem | Provides a reference to model information.
Returns

Returns a collection of changes for the client EcoSpace to process.

See Also
SyncHandler Class
Eco.Persistence Namespace


SyncHandler Properties

SyncHandler Properties
Public Properties
Collapse All

The properties of the SyncHandler class are listed here.

Public Properties
Name | Description
HistoryLength | The number of UpdateDatase operations to save in Synchronization history.


SyncHandler.HistoryLength Property

SyncHandler.HistoryLength Property
SyncHandler Class Eco.Persistence Namespace See Also
Collapse All

The number of UpdateDatase operations to save in Synchronization history.

C#
public int HistoryLength;
See Also
SyncHandler Class
Eco.Persistence Namespace


SyncVersion Class

SyncVersion Class
Inheritance Hierarchy See Also
Collapse All
C#
public sealed class SyncVersion;
Remarks

This is class Eco.Persistence.SyncVersion.

Inheritance Hierarchy
Eco.Persistence.SyncVersion
File

PersistenceMapperInterfaces.cs

See Also
Inheritance Hierarchy


SyncVersion.SyncVersion Constructor

SyncVersion.SyncVersion Constructor
SyncVersion Class Eco.Persistence Namespace See Also
Collapse All
C#
public SyncVersion(
    int version,
    Guid guid
);
Remarks

This is SyncVersion, a member of class SyncVersion.

See Also
SyncVersion Class
Eco.Persistence Namespace


SyncVersion Properties

SyncVersion Properties
Public Properties
Collapse All

The properties of the SyncVersion class are listed here.

Public Properties
Name | Description
Guid | This is Guid, a member of class SyncVersion.
None | This is None, a member of class SyncVersion.
Version | This is Version, a member of class SyncVersion.


SyncVersion.Guid Property

SyncVersion.Guid Property
SyncVersion Class Eco.Persistence Namespace See Also
Collapse All
C#
public Guid Guid;
Remarks

This is Guid, a member of class SyncVersion.

See Also
SyncVersion Class
Eco.Persistence Namespace


SyncVersion.None Property

SyncVersion.None Property
SyncVersion Class Eco.Persistence Namespace See Also
Collapse All
C#
public static SyncVersion None;
Remarks

This is None, a member of class SyncVersion.

See Also
SyncVersion Class
Eco.Persistence Namespace


SyncVersion.Version Property

SyncVersion.Version Property
SyncVersion Class Eco.Persistence Namespace See Also
Collapse All
C#
public int Version;
Remarks

This is Version, a member of class SyncVersion.

See Also
SyncVersion Class
Eco.Persistence Namespace


TKeyJoinPair Class

TKeyJoinPair Class
Inheritance Hierarchy See Also
Collapse All
C#
public class TKeyJoinPair;
Remarks

This is class Eco.Persistence.TKeyJoinPair.

Inheritance Hierarchy
Eco.Persistence.TKeyJoinPair
File

Eco.Persistence.SelectQuery.cs

See Also
Inheritance Hierarchy


TKeyJoinPair.TKeyJoinPair Constructor

TKeyJoinPair.TKeyJoinPair Constructor
TKeyJoinPair Class Eco.Persistence Namespace See Also
Collapse All
C#
public TKeyJoinPair(
    KeyImplementation key1,
    KeyImplementation key2
);
Remarks

TKeyJoinPair Constructor Create( key1, key2)

See Also
TKeyJoinPair Class
Eco.Persistence Namespace


TKeyJoinPair Methods

TKeyJoinPair Methods
Public Methods
Collapse All

The methods of the TKeyJoinPair class are listed here.

Public Methods
Name | Description
FindJoinKey | This is FindJoinKey, a member of class TKeyJoinPair.
GenerateJoinConditions | This is GenerateJoinConditions, a member of class TKeyJoinPair.


TKeyJoinPair.FindJoinKey Method

TKeyJoinPair.FindJoinKey Method
TKeyJoinPair Class Eco.Persistence Namespace See Also
Collapse All
C#
public static TKeyJoinPair FindJoinKey(
    AliasDefinition Alias1,
    AliasDefinition Alias2
);
Remarks

This is FindJoinKey, a member of class TKeyJoinPair.

See Also
TKeyJoinPair Class
Eco.Persistence Namespace


TKeyJoinPair.GenerateJoinConditions Method

TKeyJoinPair.GenerateJoinConditions Method
TKeyJoinPair Class Eco.Persistence Namespace See Also
Collapse All
C#
public void GenerateJoinConditions(
    IList<string> list,
    SqlDatabaseConfig config
);
Remarks

This is GenerateJoinConditions, a member of class TKeyJoinPair.

See Also
TKeyJoinPair Class
Eco.Persistence Namespace


TKeyJoinPair Properties

TKeyJoinPair Properties
Public Properties
Collapse All

The properties of the TKeyJoinPair class are listed here.

Public Properties
Name | Description
Alias1EffectiveName | This is Alias1EffectiveName, a member of class TKeyJoinPair.
Alias1PostFix | This is Alias1PostFix, a member of class TKeyJoinPair.
Alias2EffectiveName | This is Alias2EffectiveName, a member of class TKeyJoinPair.
Alias2PostFix | This is Alias2PostFix, a member of class TKeyJoinPair.
IncludeTimeStampInJoin | This is IncludeTimeStampInJoin, a member of class TKeyJoinPair.
Key1 | This is Key1, a member of class TKeyJoinPair.
Key2 | This is Key2, a member of class TKeyJoinPair.


TKeyJoinPair.Alias1EffectiveName Property

TKeyJoinPair.Alias1EffectiveName Property
TKeyJoinPair Class Eco.Persistence Namespace See Also
Collapse All
C#
public string Alias1EffectiveName;
Remarks

This is Alias1EffectiveName, a member of class TKeyJoinPair.

See Also
TKeyJoinPair Class
Eco.Persistence Namespace


TKeyJoinPair.Alias1PostFix Property

TKeyJoinPair.Alias1PostFix Property
TKeyJoinPair Class Eco.Persistence Namespace See Also
Collapse All
C#
public string Alias1PostFix;
Remarks

This is Alias1PostFix, a member of class TKeyJoinPair.

See Also
TKeyJoinPair Class
Eco.Persistence Namespace


TKeyJoinPair.Alias2EffectiveName Property

TKeyJoinPair.Alias2EffectiveName Property
TKeyJoinPair Class Eco.Persistence Namespace See Also
Collapse All
C#
public string Alias2EffectiveName;
Remarks

This is Alias2EffectiveName, a member of class TKeyJoinPair.

See Also
TKeyJoinPair Class
Eco.Persistence Namespace


TKeyJoinPair.Alias2PostFix Property

TKeyJoinPair.Alias2PostFix Property
TKeyJoinPair Class Eco.Persistence Namespace See Also
Collapse All
C#
public string Alias2PostFix;
Remarks

This is Alias2PostFix, a member of class TKeyJoinPair.

See Also
TKeyJoinPair Class
Eco.Persistence Namespace


TKeyJoinPair.IncludeTimeStampInJoin Property

TKeyJoinPair.IncludeTimeStampInJoin Property
TKeyJoinPair Class Eco.Persistence Namespace See Also
Collapse All
C#
public bool IncludeTimeStampInJoin;
Remarks

This is IncludeTimeStampInJoin, a member of class TKeyJoinPair.

See Also
TKeyJoinPair Class
Eco.Persistence Namespace


TKeyJoinPair.Key1 Property

TKeyJoinPair.Key1 Property
TKeyJoinPair Class Eco.Persistence Namespace See Also
Collapse All
C#
public KeyImplementation Key1;
Remarks

This is Key1, a member of class TKeyJoinPair.

See Also
TKeyJoinPair Class
Eco.Persistence Namespace


TKeyJoinPair.Key2 Property

TKeyJoinPair.Key2 Property
TKeyJoinPair Class Eco.Persistence Namespace See Also
Collapse All
C#
public KeyImplementation Key2;
Remarks

This is Key2, a member of class TKeyJoinPair.

See Also
TKeyJoinPair Class
Eco.Persistence Namespace


TransactionUtil Class

TransactionUtil Class
Inheritance Hierarchy See Also
Collapse All
C#
public class TransactionUtil : ServicedComponent;
Remarks

This is class Eco.Persistence.TransactionUtil.

Inheritance Hierarchy
Eco.Persistence.TransactionUtil
File

DistributedTransactionManager.cs

See Also
Inheritance Hierarchy


TransactionUtil.TransactionUtil Constructor

TransactionUtil.TransactionUtil Constructor
TransactionUtil Class Eco.Persistence Namespace See Also
Collapse All
C#
public TransactionUtil();
Remarks

This is TransactionUtil, a member of class TransactionUtil.

See Also
TransactionUtil Class
Eco.Persistence Namespace


TransactionUtil Methods

TransactionUtil Methods
Public Methods
Collapse All

The methods of the TransactionUtil class are listed here.

Public Methods
Name | Description
EnlistDatabases | This is EnlistDatabases, a member of class TransactionUtil.
PerformUpdateInTransaction | This is PerformUpdateInTransaction, a member of class TransactionUtil.


TransactionUtil.EnlistDatabases Method

TransactionUtil.EnlistDatabases Method
TransactionUtil Class Eco.Persistence Namespace See Also
Collapse All
C#
public void EnlistDatabases(
    IDatabaseCollection databases,
    ITransaction tx
);
Remarks

This is EnlistDatabases, a member of class TransactionUtil.

See Also
TransactionUtil Class
Eco.Persistence Namespace


TransactionUtil.PerformUpdateInTransaction Method

TransactionUtil.PerformUpdateInTransaction Method
TransactionUtil Class Eco.Persistence Namespace See Also
Collapse All
C#
public void PerformUpdateInTransaction(
    object operationParams,
    ITransactionable callback,
    IDatabaseCollection databases
);
Remarks

This is PerformUpdateInTransaction, a member of class TransactionUtil.

See Also
TransactionUtil Class
Eco.Persistence Namespace


TSelectQuery Class

TSelectQuery Class
Inheritance Hierarchy See Also
Collapse All
C#
public class TSelectQuery;
Remarks

end TKeyJoinPair

Inheritance Hierarchy
Eco.Persistence.TSelectQuery
File

Eco.Persistence.SelectQuery.cs

See Also
Inheritance Hierarchy


TSelectQuery.TSelectQuery Constructor

TSelectQuery.TSelectQuery Constructor
TSelectQuery Class Eco.Persistence Namespace See Also
Collapse All
C#
public TSelectQuery(
    SqlDatabaseConfig Config
);
Remarks

TSelectQuery Constructor create( Config)

See Also
TSelectQuery Class
Eco.Persistence Namespace


TSelectQuery Methods

TSelectQuery Methods
Public Methods
Collapse All

The methods of the TSelectQuery class are listed here.

Public Methods
Name | Description
AddAlias | This is AddAlias, a member of class TSelectQuery.
AddAliases | This is AddAliases, a member of class TSelectQuery.
AddColumnsFromQuery | This is AddColumnsFromQuery, a member of class TSelectQuery.
AddDiscriminator | This is AddDiscriminator, a member of class TSelectQuery.
CollectDiscriminators | This is CollectDiscriminators, a member of class TSelectQuery.
GenerateSql | This is GenerateSql, a member of class TSelectQuery.
SetTimeStampCondition | This is SetTimeStampCondition, a member of class TSelectQuery.


TSelectQuery.AddAlias Method

TSelectQuery.AddAlias Method
TSelectQuery Class Eco.Persistence Namespace See Also
Collapse All
C#
public void AddAlias(
    AliasDefinition Alias
);
Remarks

This is AddAlias, a member of class TSelectQuery.

See Also
TSelectQuery Class
Eco.Persistence Namespace


TSelectQuery.AddAliases Method

TSelectQuery.AddAliases Method
TSelectQuery Class Eco.Persistence Namespace See Also
Collapse All
C#
public void AddAliases(
    AliasCollection Aliases
);
Remarks

This is AddAliases, a member of class TSelectQuery.

See Also
TSelectQuery Class
Eco.Persistence Namespace


TSelectQuery.AddColumnsFromQuery Method

TSelectQuery.AddColumnsFromQuery Method
TSelectQuery Class Eco.Persistence Namespace See Also
Collapse All
C#
public void AddColumnsFromQuery(
    TSelectQuery Query,
    KeyImplementation KeyImpl,
    KeyDefinition KeyDef
);
Remarks

This is AddColumnsFromQuery, a member of class TSelectQuery.

See Also
TSelectQuery Class
Eco.Persistence Namespace


TSelectQuery.AddDiscriminator Method

TSelectQuery.AddDiscriminator Method
TSelectQuery Class Eco.Persistence Namespace See Also
Collapse All
C#
public void AddDiscriminator(
    DiscriminatorImplementation Discriminator
);
Remarks

This is AddDiscriminator, a member of class TSelectQuery.

See Also
TSelectQuery Class
Eco.Persistence Namespace


TSelectQuery.CollectDiscriminators Method

TSelectQuery.CollectDiscriminators Method
TSelectQuery Class Eco.Persistence Namespace See Also
Collapse All
C#
public void CollectDiscriminators();
Remarks

This is CollectDiscriminators, a member of class TSelectQuery.

See Also
TSelectQuery Class
Eco.Persistence Namespace


TSelectQuery.GenerateSql Method

TSelectQuery.GenerateSql Method
TSelectQuery Class Eco.Persistence Namespace See Also
Collapse All
C#
public string GenerateSql(
    ObjectIdCollection IdList,
    ColumnReferenceCollection ColumnsForIdList,
    IKeyMapper IdMapper,
    bool ImplicitTypeDiscriminators,
    AliasDefinition IdAliasCandidate,
    IParameterized Parameters
);
Remarks

This is GenerateSql, a member of class TSelectQuery.

See Also
TSelectQuery Class
Eco.Persistence Namespace


TSelectQuery.SetTimeStampCondition Method

TSelectQuery.SetTimeStampCondition Method
TSelectQuery Class Eco.Persistence Namespace See Also
Collapse All
C#
public void SetTimeStampCondition(
    int TimeStamp,
    AliasDefinition TSStartAlias,
    AliasDefinition TSStopAlias
);
Remarks

This is SetTimeStampCondition, a member of class TSelectQuery.

See Also
TSelectQuery Class
Eco.Persistence Namespace


TSelectQuery Properties

TSelectQuery Properties
Public Properties
Collapse All

The properties of the TSelectQuery class are listed here.

Public Properties
Name | Description
Aliases | This is Aliases, a member of class TSelectQuery.
Columns | This is Columns, a member of class TSelectQuery.
Config | This is Config, a member of class TSelectQuery.
OrderBy | This is OrderBy, a member of class TSelectQuery.
PrimaryAlias | This is PrimaryAlias, a member of class TSelectQuery.
PrimaryKeyColumnPrefix | This is PrimaryKeyColumnPrefix, a member of class TSelectQuery.
PrimaryKeyImplementation | This is PrimaryKeyImplementation, a member of class TSelectQuery.
TimeStampCondition | This is TimeStampCondition, a member of class TSelectQuery.
TimeStampStartAlias | This is TimeStampStartAlias, a member of class TSelectQuery.
TimeStampStopAlias | This is TimeStampStopAlias, a member of class TSelectQuery.
TypeDiscriminatorImplementations | This is TypeDiscriminatorImplementations, a member of class TSelectQuery.
TypeDiscriminators | This is TypeDiscriminators, a member of class TSelectQuery.
WhereClause | This is WhereClause, a member of class TSelectQuery.


TSelectQuery.Aliases Property

TSelectQuery.Aliases Property
TSelectQuery Class Eco.Persistence Namespace See Also
Collapse All
C#
public AliasCollection Aliases;
Remarks

This is Aliases, a member of class TSelectQuery.

See Also
TSelectQuery Class
Eco.Persistence Namespace


TSelectQuery.Columns Property

TSelectQuery.Columns Property
TSelectQuery Class Eco.Persistence Namespace See Also
Collapse All
C#
public ColumnReferenceCollection Columns;
Remarks

This is Columns, a member of class TSelectQuery.

See Also
TSelectQuery Class
Eco.Persistence Namespace


TSelectQuery.Config Property

TSelectQuery.Config Property
TSelectQuery Class Eco.Persistence Namespace See Also
Collapse All
C#
public SqlDatabaseConfig Config;
Remarks

This is Config, a member of class TSelectQuery.

See Also
TSelectQuery Class
Eco.Persistence Namespace


TSelectQuery.OrderBy Property

TSelectQuery.OrderBy Property
TSelectQuery Class Eco.Persistence Namespace See Also
Collapse All
C#
public IList<string> OrderBy;
Remarks

This is OrderBy, a member of class TSelectQuery.

See Also
TSelectQuery Class
Eco.Persistence Namespace


TSelectQuery.PrimaryAlias Property

TSelectQuery.PrimaryAlias Property
TSelectQuery Class Eco.Persistence Namespace See Also
Collapse All
C#
public AliasDefinition PrimaryAlias;
Remarks

This is PrimaryAlias, a member of class TSelectQuery.

See Also
TSelectQuery Class
Eco.Persistence Namespace


TSelectQuery.PrimaryKeyColumnPrefix Property

TSelectQuery.PrimaryKeyColumnPrefix Property
TSelectQuery Class Eco.Persistence Namespace See Also
Collapse All
C#
public string PrimaryKeyColumnPrefix;
Remarks

This is PrimaryKeyColumnPrefix, a member of class TSelectQuery.

See Also
TSelectQuery Class
Eco.Persistence Namespace


TSelectQuery.PrimaryKeyImplementation Property

TSelectQuery.PrimaryKeyImplementation Property
TSelectQuery Class Eco.Persistence Namespace See Also
Collapse All
C#
public KeyImplementation PrimaryKeyImplementation;
Remarks

This is PrimaryKeyImplementation, a member of class TSelectQuery.

See Also
TSelectQuery Class
Eco.Persistence Namespace


TSelectQuery.TimeStampCondition Property

TSelectQuery.TimeStampCondition Property
TSelectQuery Class Eco.Persistence Namespace See Also
Collapse All
C#
public int TimeStampCondition;
Remarks

This is TimeStampCondition, a member of class TSelectQuery.

See Also
TSelectQuery Class
Eco.Persistence Namespace


TSelectQuery.TimeStampStartAlias Property

TSelectQuery.TimeStampStartAlias Property
TSelectQuery Class Eco.Persistence Namespace See Also
Collapse All
C#
public AliasDefinition TimeStampStartAlias;
Remarks

This is TimeStampStartAlias, a member of class TSelectQuery.

See Also
TSelectQuery Class
Eco.Persistence Namespace


TSelectQuery.TimeStampStopAlias Property

TSelectQuery.TimeStampStopAlias Property
TSelectQuery Class Eco.Persistence Namespace See Also
Collapse All
C#
public AliasDefinition TimeStampStopAlias;
Remarks

This is TimeStampStopAlias, a member of class TSelectQuery.

See Also
TSelectQuery Class
Eco.Persistence Namespace


TSelectQuery.TypeDiscriminatorImplementations Property

TSelectQuery.TypeDiscriminatorImplementations Property
TSelectQuery Class Eco.Persistence Namespace See Also
Collapse All
C#
public DiscriminatorImplementationCollection TypeDiscriminatorImplementations;
Remarks

This is TypeDiscriminatorImplementations, a member of class TSelectQuery.

See Also
TSelectQuery Class
Eco.Persistence Namespace


TSelectQuery.TypeDiscriminators Property

TSelectQuery.TypeDiscriminators Property
TSelectQuery Class Eco.Persistence Namespace See Also
Collapse All
C#
public DiscriminatorDefCollection TypeDiscriminators;
Remarks

This is TypeDiscriminators, a member of class TSelectQuery.

See Also
TSelectQuery Class
Eco.Persistence Namespace


TSelectQuery.WhereClause Property

TSelectQuery.WhereClause Property
TSelectQuery Class Eco.Persistence Namespace See Also
Collapse All
C#
public IList<string> WhereClause;
Remarks

This is WhereClause, a member of class TSelectQuery.

See Also
TSelectQuery Class
Eco.Persistence Namespace


UpdatePrecondition Class

UpdatePrecondition Class
Inheritance Hierarchy See Also
Collapse All
C#
public abstract class UpdatePrecondition;
Remarks

This is class Eco.Persistence.UpdatePrecondition.

Inheritance Hierarchy
Eco.Persistence.UpdatePrecondition
    Eco.Persistence.OptimisticLockingPrecondition
File

PersistenceMapperInterfaces.cs

See Also
Inheritance Hierarchy


UpdateResult Class

UpdateResult Class
Inheritance Hierarchy See Also
Collapse All
C#
public abstract class UpdateResult;
Remarks

This is class Eco.Persistence.UpdateResult.

Inheritance Hierarchy
Eco.Persistence.UpdateResult
    Eco.Persistence.OkResult
    Eco.Persistence.OptimisticLockingResult
File

PersistenceMapperInterfaces.cs

See Also
Inheritance Hierarchy


UpdateResult Properties

UpdateResult Properties
Public Properties
Collapse All

The properties of the UpdateResult class are listed here.

Public Properties
Name | Description
Failed | This is Failed, a member of class UpdateResult.
FailureReason | This is FailureReason, a member of class UpdateResult.


UpdateResult.Failed Property

UpdateResult.Failed Property
UpdateResult Class Eco.Persistence Namespace See Also
Collapse All
C#
public abstract bool Failed;
Remarks

This is Failed, a member of class UpdateResult.

See Also
UpdateResult Class
Eco.Persistence Namespace


UpdateResult.FailureReason Property

UpdateResult.FailureReason Property
UpdateResult Class Eco.Persistence Namespace See Also
Collapse All
C#
public abstract string FailureReason;
Remarks

This is FailureReason, a member of class UpdateResult.

See Also
UpdateResult Class
Eco.Persistence Namespace


VersionConst Class

VersionConst Class
Inheritance Hierarchy See Also
Collapse All
C#
public abstract class VersionConst;
Remarks

This is class Eco.Persistence.VersionConst.

Inheritance Hierarchy
Eco.Persistence.VersionConst
File

PersistenceMapperInterfaces.cs

See Also
Inheritance Hierarchy


VersionConst Fields

VersionConst Fields
Public Fields
Collapse All

The fields of the VersionConst class are listed here.

Public Fields
Name | Description
CurrentVersion | This is CurrentVersion, a member of class VersionConst.
NonVersioned | This is NonVersioned, a member of class VersionConst.


VersionConst.CurrentVersion Field

VersionConst.CurrentVersion Field
VersionConst Class Eco.Persistence Namespace See Also
Collapse All
C#
public const int CurrentVersion = int.MaxValue;
Remarks

This is CurrentVersion, a member of class VersionConst.

See Also
VersionConst Class
Eco.Persistence Namespace


VersionConst.NonVersioned Field

VersionConst.NonVersioned Field
VersionConst Class Eco.Persistence Namespace See Also
Collapse All
C#
public const int NonVersioned = -1;
Remarks

This is NonVersioned, a member of class VersionConst.

See Also
VersionConst Class
Eco.Persistence Namespace


IAttributemapping Interface

IAttributemapping Interface
Inheritance Hierarchy See Also
Collapse All

This interface handles database conversion for values that are stored in multiple columns.

C#
public interface IAttributemapping;
Inheritance Hierarchy
Eco.Persistence.IAttributemapping
    Eco.Persistence.Default.TimeStampAsTwoInt32
File

PersistenceInterfaces.cs

See Also
Inheritance Hierarchy


IAttributemapping Methods

IAttributemapping Methods
Public Methods
Collapse All

The methods of the IAttributemapping class are listed here.

Public Methods
Name | Description
ColumnNames | This is ColumnNames, a member of class IAttributemapping.
ColumnsToValue | This is ColumnsToValue, a member of class IAttributemapping.
ColumnTypes | This is ColumnTypes, a member of class IAttributemapping.
DefaultDbValues | This is DefaultDbValues, a member of class IAttributemapping.
IsEqual | This is IsEqual, a member of class IAttributemapping.
ValueToParameters | This is ValueToParameters, a member of class IAttributemapping.


IAttributemapping.ColumnNames Method

IAttributemapping.ColumnNames Method
IAttributemapping Interface Eco.Persistence Namespace See Also
Collapse All
C#
String[] ColumnNames(
    string name
);
Remarks

This is ColumnNames, a member of class IAttributemapping.

See Also
IAttributemapping Interface
Eco.Persistence Namespace


IAttributemapping.ColumnsToValue Method

IAttributemapping.ColumnsToValue Method
IAttributemapping Interface Eco.Persistence Namespace See Also
Collapse All
C#
System.Object ColumnsToValue(
    System.Object[] columnValues
);
Remarks

This is ColumnsToValue, a member of class IAttributemapping.

See Also
IAttributemapping Interface
Eco.Persistence Namespace


IAttributemapping.ColumnTypes Method

IAttributemapping.ColumnTypes Method
IAttributemapping Interface Eco.Persistence Namespace See Also
Collapse All
C#
String[] ColumnTypes(
    int length
);
Remarks

This is ColumnTypes, a member of class IAttributemapping.

See Also
IAttributemapping Interface
Eco.Persistence Namespace


IAttributemapping.DefaultDbValues Method

IAttributemapping.DefaultDbValues Method
IAttributemapping Interface Eco.Persistence Namespace See Also
Collapse All
C#
String[] DefaultDbValues(
    string modeledValue,
    SqlDatabaseConfig sqlDatabaseConfig
);
Remarks

This is DefaultDbValues, a member of class IAttributemapping.

See Also
IAttributemapping Interface
Eco.Persistence Namespace


IAttributemapping.IsEqual Method

IAttributemapping.IsEqual Method
IAttributemapping Interface Eco.Persistence Namespace See Also
Collapse All
C#
bool IsEqual(
    System.Object value,
    System.Object[] columnValues
);
Remarks

This is IsEqual, a member of class IAttributemapping.

See Also
IAttributemapping Interface
Eco.Persistence Namespace


IAttributemapping.ValueToParameters Method

IAttributemapping.ValueToParameters Method
IAttributemapping Interface Eco.Persistence Namespace See Also
Collapse All
C#
void ValueToParameters(
    System.Object value,
    IDataParameter[] parameters
);
Remarks

This is ValueToParameters, a member of class IAttributemapping.

See Also
IAttributemapping Interface
Eco.Persistence Namespace


IAutoHookable Interface

IAutoHookable Interface
Inheritance Hierarchy See Also
Collapse All

Interface used for designer interaction only

C#
public interface IAutoHookable;
Remarks

This interface should be implemented by every subclass of PersistenceMapperDb. It is used by designers to connect and disconnect components to the Connection (or equivalent).

Inheritance Hierarchy
Eco.Persistence.IAutoHookable
    Eco.Persistence.AbstractPersistenceMapperBlackfish
    Eco.Persistence.PersistenceMapperAdo2
    Eco.Persistence.PersistenceMapperBdp
    Eco.Persistence.PersistenceMapperBlackfish
    Eco.Persistence.PersistenceMapperBlackfishRemote
    Eco.Persistence.PersistenceMapperDbx
    Eco.Persistence.PersistenceMapperFirebird
    Eco.Persistence.PersistenceMapperMimer
    Eco.Persistence.PersistenceMapperNexusDB
    Eco.Persistence.PersistenceMapperSybase
File

PersistenceMapper.cs

See Also
Inheritance Hierarchy


IAutoHookable Methods

IAutoHookable Methods
Public Methods
Collapse All

The methods of the IAutoHookable class are listed here.

Public Methods
Name | Description
AutoHookup | Sets component to the Connection property
CanHookup | Returns true if the component can be used as the Connection property.
IsHookedUpTo | Returns true if the component equals the Connection property.


IAutoHookable.AutoHookup Method

IAutoHookable.AutoHookup Method
IAutoHookable Interface Eco.Persistence Namespace See Also
Collapse All

Sets component to the Connection property

C#
void AutoHookup(
    Component component
);
See Also
IAutoHookable Interface
Eco.Persistence Namespace


IAutoHookable.CanHookup Method

IAutoHookable.CanHookup Method
IAutoHookable Interface Eco.Persistence Namespace See Also
Collapse All

Returns true if the component can be used as the Connection property.

C#
bool CanHookup(
    Component component
);
See Also
IAutoHookable Interface
Eco.Persistence Namespace


IAutoHookable.IsHookedUpTo Method

IAutoHookable.IsHookedUpTo Method
IAutoHookable Interface Eco.Persistence Namespace See Also
Collapse All

Returns true if the component equals the Connection property.

C#
bool IsHookedUpTo(
    Component component
);
See Also
IAutoHookable Interface
Eco.Persistence Namespace


IAutoIncAttributemapping Interface

IAutoIncAttributemapping Interface
Inheritance Hierarchy See Also
Collapse All

This interface handles database conversion for values that are generated in the database.

C#
public interface IAutoIncAttributemapping : ISingleColumnAttributemapping;
Inheritance Hierarchy
Eco.Persistence.ISingleColumnAttributemapping
    Eco.Persistence.IAutoIncAttributemapping
        Eco.Persistence.Blackfish.Int32AsAutoInc
        Eco.Persistence.Interbase.Int16AsAutoInc
        Eco.Persistence.Interbase.Int32AsAutoInc
        Eco.Persistence.Mimer.Int32AsAutoInc
        Eco.Persistence.MySql.Int16AsAutoInc
        Eco.Persistence.MySql.Int32AsAutoInc
        Eco.Persistence.Nexus.Int32AsAutoInc
        Eco.Persistence.Oracle.Int32AsAutoInc
        Eco.Persistence.SQLite.Int32AsAutoInc
        Eco.Persistence.SqlServer.DecimalAsAutoInc
        Eco.Persistence.SqlServer.GuidAsUniqueIdentifierWithDefault
        Eco.Persistence.SqlServer.Int16AsAutoInc
        Eco.Persistence.SqlServer.Int32AsAutoInc
        Eco.Persistence.Sybase.Int32AsNumericIdentity
File

PersistenceInterfaces.cs

See Also
Inheritance Hierarchy


IAutoIncAttributemapping Methods

IAutoIncAttributemapping Methods
Public Methods
Collapse All

The methods of the IAutoIncAttributemapping class are listed here.

Public Methods
Name | Description
MakeColumnAutoInc | If the database requires any additional operations in addition to the column type to give a column "autoinc" behaviour, that should be performed by this method.


IAutoIncAttributemapping.MakeColumnAutoInc Method

IAutoIncAttributemapping.MakeColumnAutoInc Method
IAutoIncAttributemapping Interface Eco.Persistence Namespace See Also
Collapse All

If the database requires any additional operations in addition to the column type to give a column "autoinc" behaviour, that should be performed by this method.

C#
void MakeColumnAutoInc(
    string tableName,
    string columnName,
    IDatabase database
);
Remarks

Even if the database does not require any additional operations, this interface should be implemented by an autoinc attribute mapper, and the implementation of this method should be left blank.

See Also
IAutoIncAttributemapping Interface
Eco.Persistence Namespace


IAutoIncIdMapper Interface

IAutoIncIdMapper Interface
Inheritance Hierarchy See Also
Collapse All

This interface needs to be implemented by AutoInc KeyMappers that requires to perform custom initialization of the autoinc fields

C#
public interface IAutoIncIdMapper;
Inheritance Hierarchy
Eco.Persistence.IAutoIncIdMapper
    Eco.Persistence.AbstractAutoGuidKeyMapper
    Eco.Persistence.AbstractAutoIncKeyMapper
    Eco.Persistence.AutoGuidKeyMapper
    Eco.Persistence.AutoInc16KeyMapper
    Eco.Persistence.AutoIncKeyMapper
File

IAutoIncKeyMapper.cs

See Also
Inheritance Hierarchy


IAutoIncIdMapper Methods

IAutoIncIdMapper Methods
Public Methods
Collapse All

The methods of the IAutoIncIdMapper class are listed here.

Public Methods
Name | Description
ColumnTypeForAutoInc | This is ColumnTypeForAutoInc, a member of class IAutoIncIdMapper.
GetAutoIncValueRetrievalQuery | This is GetAutoIncValueRetrievalQuery, a member of class IAutoIncIdMapper.
InitializeAutoIncField | This is InitializeAutoIncField, a member of class IAutoIncIdMapper.


IAutoIncIdMapper.ColumnTypeForAutoInc Method

IAutoIncIdMapper.ColumnTypeForAutoInc Method
IAutoIncIdMapper Interface Eco.Persistence Namespace See Also
Collapse All
C#
string ColumnTypeForAutoInc();
Remarks

This is ColumnTypeForAutoInc, a member of class IAutoIncIdMapper.

See Also
IAutoIncIdMapper Interface
Eco.Persistence Namespace


IAutoIncIdMapper.GetAutoIncValueRetrievalQuery Method

IAutoIncIdMapper.GetAutoIncValueRetrievalQuery Method
IAutoIncIdMapper Interface Eco.Persistence Namespace See Also
Collapse All
C#
string GetAutoIncValueRetrievalQuery(
    string tableName,
    string columnName
);
Remarks

This is GetAutoIncValueRetrievalQuery, a member of class IAutoIncIdMapper.

See Also
IAutoIncIdMapper Interface
Eco.Persistence Namespace


IAutoIncIdMapper.InitializeAutoIncField Method

IAutoIncIdMapper.InitializeAutoIncField Method
IAutoIncIdMapper Interface Eco.Persistence Namespace See Also
Collapse All
C#
void InitializeAutoIncField(
    string tableName,
    string columnName,
    IDatabase database
);
Remarks

This is InitializeAutoIncField, a member of class IAutoIncIdMapper.

See Also
IAutoIncIdMapper Interface
Eco.Persistence Namespace


IConfigureCleanPS Interface

IConfigureCleanPS Interface
Inheritance Hierarchy See Also
Collapse All
C#
public interface IConfigureCleanPS;
Remarks

This is class Eco.Persistence.IConfigureCleanPS.

Inheritance Hierarchy
Eco.Persistence.IConfigureCleanPS
    Eco.Persistence.DefaultCleanPsConfig
File

CleanPersistenceInterfaces.cs

See Also
Inheritance Hierarchy


IConfigureCleanPS Methods

IConfigureCleanPS Methods
Public Methods
Collapse All

The methods of the IConfigureCleanPS class are listed here.

Public Methods
Name | Description
DetermineTablesToDelete | This is DetermineTablesToDelete, a member of class IConfigureCleanPS.
InstallExternalSystemTables | This is InstallExternalSystemTables, a member of class IConfigureCleanPS.


IConfigureCleanPS.DetermineTablesToDelete Method

IConfigureCleanPS.DetermineTablesToDelete Method
IConfigureCleanPS Interface Eco.Persistence Namespace See Also
Collapse All
C#
IList<string> DetermineTablesToDelete(
    IList<string> allTables,
    IList<string> knownTables,
    IList<string> SQLTables
);
Remarks

This is DetermineTablesToDelete, a member of class IConfigureCleanPS.

See Also
IConfigureCleanPS Interface
Eco.Persistence Namespace


IConfigureCleanPS.InstallExternalSystemTables Method

IConfigureCleanPS.InstallExternalSystemTables Method
IConfigureCleanPS Interface Eco.Persistence Namespace See Also
Collapse All
C#
void InstallExternalSystemTables(
    IList<string> tableNames
);
Remarks

This is InstallExternalSystemTables, a member of class IConfigureCleanPS.

See Also
IConfigureCleanPS Interface
Eco.Persistence Namespace


IDBEvolutor Interface

IDBEvolutor Interface
Inheritance Hierarchy See Also
Collapse All
C#
public interface IDBEvolutor;
Remarks

This is class Eco.Persistence.IDBEvolutor.

Inheritance Hierarchy
Eco.Persistence.IDBEvolutor
    Eco.Persistence.Evolutor.TBoldDataBaseEvolutor
File

PersistenceMapperInterfaces.cs

See Also
Inheritance Hierarchy


IDBEvolutor Methods

IDBEvolutor Methods
Public Methods
Collapse All

The methods of the IDBEvolutor class are listed here.

Public Methods
Name | Description
CalculateScript | This is CalculateScript, a member of class IDBEvolutor.
ExecuteScript | This is ExecuteScript, a member of class IDBEvolutor.
GenerateDbScript | This is GenerateDbScript, a member of class IDBEvolutor.
GenerateErrors | This is GenerateErrors, a member of class IDBEvolutor.
GenerateExecutedStatements | This is GenerateExecutedStatements, a member of class IDBEvolutor.
GenerateMappingScript | This is GenerateMappingScript, a member of class IDBEvolutor.
GenerateWarnings | This is GenerateWarnings, a member of class IDBEvolutor.
GetFormerNamesHandler | This is GetFormerNamesHandler, a member of class IDBEvolutor.


IDBEvolutor.CalculateScript Method

IDBEvolutor.CalculateScript Method
IDBEvolutor Interface Eco.Persistence Namespace See Also
Collapse All
C#
void CalculateScript();
Remarks

This is CalculateScript, a member of class IDBEvolutor.

See Also
IDBEvolutor Interface
Eco.Persistence Namespace


IDBEvolutor.ExecuteScript Method

IDBEvolutor.ExecuteScript Method
IDBEvolutor Interface Eco.Persistence Namespace See Also
Collapse All
C#
void ExecuteScript();
Remarks

This is ExecuteScript, a member of class IDBEvolutor.

See Also
IDBEvolutor Interface
Eco.Persistence Namespace


IDBEvolutor.GenerateDbScript Method

IDBEvolutor.GenerateDbScript Method
IDBEvolutor Interface Eco.Persistence Namespace See Also
Collapse All
C#
string[] GenerateDbScript();
Remarks

This is GenerateDbScript, a member of class IDBEvolutor.

See Also
IDBEvolutor Interface
Eco.Persistence Namespace


IDBEvolutor.GenerateErrors Method

IDBEvolutor.GenerateErrors Method
IDBEvolutor Interface Eco.Persistence Namespace See Also
Collapse All
C#
string[] GenerateErrors();
Remarks

This is GenerateErrors, a member of class IDBEvolutor.

See Also
IDBEvolutor Interface
Eco.Persistence Namespace


IDBEvolutor.GenerateExecutedStatements Method

IDBEvolutor.GenerateExecutedStatements Method
IDBEvolutor Interface Eco.Persistence Namespace See Also
Collapse All
C#
string[] GenerateExecutedStatements();
Remarks

This is GenerateExecutedStatements, a member of class IDBEvolutor.

See Also
IDBEvolutor Interface
Eco.Persistence Namespace


IDBEvolutor.GenerateMappingScript Method

IDBEvolutor.GenerateMappingScript Method
IDBEvolutor Interface Eco.Persistence Namespace See Also
Collapse All
C#
string[] GenerateMappingScript();
Remarks

This is GenerateMappingScript, a member of class IDBEvolutor.

See Also
IDBEvolutor Interface
Eco.Persistence Namespace


IDBEvolutor.GenerateWarnings Method

IDBEvolutor.GenerateWarnings Method
IDBEvolutor Interface Eco.Persistence Namespace See Also
Collapse All
C#
string[] GenerateWarnings();
Remarks

This is GenerateWarnings, a member of class IDBEvolutor.

See Also
IDBEvolutor Interface
Eco.Persistence Namespace


IDBEvolutor.GetFormerNamesHandler Method

IDBEvolutor.GetFormerNamesHandler Method
IDBEvolutor Interface Eco.Persistence Namespace See Also
Collapse All
C#
FormerNamesHandler GetFormerNamesHandler();
Remarks

This is GetFormerNamesHandler, a member of class IDBEvolutor.

See Also
IDBEvolutor Interface
Eco.Persistence Namespace


IDefaultReverseMapping Interface

IDefaultReverseMapping Interface
Inheritance Hierarchy See Also
Collapse All

This interface indicates that the mapping represents the preferred reverse mapping for the columntype

C#
public interface IDefaultReverseMapping;
Inheritance Hierarchy
Eco.Persistence.IDefaultReverseMapping
    Eco.Persistence.Blackfish.BooleanAsBoolean
    Eco.Persistence.Blackfish.Int32AsAutoInc
    Eco.Persistence.Blackfish.Int64AsBigInt
    Eco.Persistence.Blackfish.SingleAsFloat
    Eco.Persistence.Db2.DecimalAsDecimal
    Eco.Persistence.Db2.Int64AsBigInt
    Eco.Persistence.Db2.Int64AsLongInteger
    Eco.Persistence.Db2.SingleAsFloat
    Eco.Persistence.Default.CharAsChar
    Eco.Persistence.Default.CharAsNChar
    Eco.Persistence.Default.DateTimeAsDateTime
    Eco.Persistence.Default.DateTimeAsTimeStamp
    Eco.Persistence.Default.DecimalAsDecimal
    Eco.Persistence.Default.DoubleAsDouble
    Eco.Persistence.Default.Int16AsSmallint
    Eco.Persistence.Default.Int32AsInteger
    Eco.Persistence.Default.Int64AsLongInteger
    Eco.Persistence.Default.SingleAsSingle
    Eco.Persistence.Default.StringAsChar
    Eco.Persistence.Default.StringAsNVarChar
    Eco.Persistence.Default.StringAsVarChar
    Eco.Persistence.Firebird.ByteArrayAsBlob
    Eco.Persistence.Firebird.DecimalAsDecimal
    Eco.Persistence.Firebird.StringAsBlob
    Eco.Persistence.Interbase.BooleanAsBoolean
    Eco.Persistence.Interbase.DecimalAsDecimal
    Eco.Persistence.Interbase.Int64AsLongInteger
    Eco.Persistence.MySql.ByteAsUnsingedTinyInt
    Eco.Persistence.MySql.DateTimeAsDateTime
    Eco.Persistence.MySql.Int16AsAutoInc
    Eco.Persistence.MySql.Int32AsAutoInc
    Eco.Persistence.MySql.Int64AsBigInt
    Eco.Persistence.MySql.MysClient.ByteArrayAsBlob
    Eco.Persistence.MySql.MysClient.Int64AsBigInt
    Eco.Persistence.MySql.MysClient.StringAsLongText
    Eco.Persistence.MySql.MysClient.StringAsUnicodeText
    Eco.Persistence.MySql.MysClient.StringAsUnicodeVarChar
    Eco.Persistence.MySql.UInt16AsUnsignedSmallint
    Eco.Persistence.Nexus.BooleanAsBool
    Eco.Persistence.Nexus.ByteArrayAsNexusDBBlob
    Eco.Persistence.Nexus.DecimalAsDecimal
    Eco.Persistence.Nexus.DoubleAsDouble
    Eco.Persistence.Nexus.GuidAsGuid
    Eco.Persistence.Nexus.Int32AsAutoInc
    Eco.Persistence.Nexus.Int64AsBigInt
    Eco.Persistence.Nexus.SingleAsFloat
    Eco.Persistence.Nexus.StringAsNexusDBClob
    Eco.Persistence.Nexus.StringAsNexusDBNClob
    Eco.Persistence.Nexus.StringAsVarChar
    Eco.Persistence.Oracle.DateTimeAsDate
    Eco.Persistence.Oracle.DateTimeAsTimeStamp
    Eco.Persistence.Oracle.DecimalAsDecimal
    Eco.Persistence.Oracle.DoubleAsNumber
    Eco.Persistence.Oracle.Int32AsNumber
    Eco.Persistence.Oracle.Int64AsLongInteger
    Eco.Persistence.Oracle.SingleAsSingle
    Eco.Persistence.OracleClient.ByteArrayAsBlob
    Eco.Persistence.OracleClient.StringAsClob
    Eco.Persistence.OracleClient.StringAsNClob
    Eco.Persistence.OracleClient.StringAsVarChar2
    Eco.Persistence.SQLite.ByteArrayAsBLOB
    Eco.Persistence.SQLite.Int32AsInteger
    Eco.Persistence.SQLite.SingleAsFloat
    Eco.Persistence.SQLite.StringAsText
    Eco.Persistence.SqlServer.BooleanAsBit
    Eco.Persistence.SqlServer.ByteAsTinyInt
    Eco.Persistence.SqlServer.DateTimeAsDateTime
    Eco.Persistence.SqlServer.DecimalAsAutoInc
    Eco.Persistence.SqlServer.DecimalAsDecimal
    Eco.Persistence.SqlServer.DecimalAsMoney
    Eco.Persistence.SqlServer.DecimalAsSmallMoney
    Eco.Persistence.SqlServer.GuidAsUniqueIdentifier
    Eco.Persistence.SqlServer.Int16AsAutoInc
    Eco.Persistence.SqlServer.Int32AsAutoInc
    Eco.Persistence.SqlServer.Int32AsInt
    Eco.Persistence.SqlServer.Int64AsLongInteger
    Eco.Persistence.SqlServer.SingleAsFloat
    Eco.Persistence.SqlServer.SingleAsReal
    Eco.Persistence.SqlServer.SqlClient.ByteArrayAsImage
    Eco.Persistence.SqlServer.SqlClient.StringAsNText
    Eco.Persistence.SqlServer.SqlClient.StringAsText
    Eco.Persistence.SqlServer.StringAsXml
    Eco.Persistence.Sybase.BooleanAsBit
    Eco.Persistence.Sybase.Int32AsNumericIdentity
    Eco.Persistence.Sybase.SingleAsFloat
File

PersistenceInterfaces.cs

See Also
Inheritance Hierarchy


IDistributedTransactionParticipant Interface

IDistributedTransactionParticipant Interface
Inheritance Hierarchy See Also
Collapse All

This interface allows multiple databases to participate in a single transaction.

C#
public interface IDistributedTransactionParticipant;
Inheritance Hierarchy
Eco.Persistence.IDistributedTransactionParticipant
    Eco.Persistence.Connection.Ado2IDatabaseImpl
File

AbstractPersistenceMapperDb.cs

See Also
Inheritance Hierarchy


IDistributedTransactionParticipant Methods

IDistributedTransactionParticipant Methods
Public Methods
Collapse All

The methods of the IDistributedTransactionParticipant class are listed here.

Public Methods
Name | Description
EnlistInTransaction | Registers the transaction as a participant in the shared transaction.


IDistributedTransactionParticipant.EnlistInTransaction Method

IDistributedTransactionParticipant.EnlistInTransaction Method
IDistributedTransactionParticipant Interface Eco.Persistence Namespace See Also
Collapse All

Registers the transaction as a participant in the shared transaction.

C#
void EnlistInTransaction(
    object transaction
);
Parameters
Parameters | Description
transaction | The transaction to enlist.
Remarks

SHDB ITransaction, but we don't want to depend on using System.EnterpriseServices;

See Also
IDistributedTransactionParticipant Interface
Eco.Persistence Namespace


IGenericSingleColumnAttributemapping Interface

IGenericSingleColumnAttributemapping Interface
Inheritance Hierarchy See Also
Collapse All
C#
public interface IGenericSingleColumnAttributemapping : ISingleColumnAttributemapping;
Remarks

This is class Eco.Persistence.IGenericSingleColumnAttributemapping.

Inheritance Hierarchy
Eco.Persistence.ISingleColumnAttributemapping
    Eco.Persistence.IGenericSingleColumnAttributemapping
        Eco.Persistence.Default.GenericEnumAsInteger
        Eco.Persistence.Default.GenericEnumAsVarChar
File

PersistenceInterfaces.cs

See Also
Inheritance Hierarchy


IGenericSingleColumnAttributemapping Methods

IGenericSingleColumnAttributemapping Methods
Public Methods
Collapse All

The methods of the IGenericSingleColumnAttributemapping class are listed here.

Public Methods
Name | Description
ColumnToValue | This is ColumnToValue, a member of class IGenericSingleColumnAttributemapping.


IGenericSingleColumnAttributemapping.ColumnToValue Method

IGenericSingleColumnAttributemapping.ColumnToValue Method
IGenericSingleColumnAttributemapping Interface Eco.Persistence Namespace See Also
Collapse All
C#
System.Object ColumnToValue(
    System.Object columnValue,
    System.Type expectedType
);
Remarks

This is ColumnToValue, a member of class IGenericSingleColumnAttributemapping.

See Also
IGenericSingleColumnAttributemapping Interface
Eco.Persistence Namespace


IKeyMapper Interface

IKeyMapper Interface
Inheritance Hierarchy See Also
Collapse All

This interface is used by the Eco persistence mapper to handle different strategies of dealing with database keys.

C#
public interface IKeyMapper;
Remarks

There are four different prewritten implementations of this interface that handles the default eco id mechanism, autoinc, keys mapped to attributes and finally keys that are guids.

Inheritance Hierarchy
Eco.Persistence.IKeyMapper
    Eco.Persistence.AbstractAutoGuidKeyMapper
    Eco.Persistence.AbstractAutoIncKeyMapper
    Eco.Persistence.AttributeKeyMapper
    Eco.Persistence.AutoGuidKeyMapper
    Eco.Persistence.AutoInc16KeyMapper
    Eco.Persistence.AutoIncKeyMapper
    Eco.Persistence.DefaultEcoIdMapper
    Eco.Persistence.DefaultEcoInt64KeyMapper
    Eco.Persistence.GuidKeyMapper
File

IKeyMapper.cs

See Also
Inheritance Hierarchy


IKeyMapper Methods

IKeyMapper Methods
Public Methods
Collapse All

The methods of the IKeyMapper class are listed here.

Public Methods
Name | Description
ColumnCount | Returns the number of columns that are used to store the id
ColumnType | Returns the sql type for the respective column.
GetIdAllocationMode | Indicates the strategy used by the key mapper.
IdFromFields | This method creates a new id based on the values of the field objects
IdListToWhereFragment | This is the overview for the IdListToWhereFragment method overload.
IdToParameters | This method fills the parameter objects with data from an id
IdToWhereFragment | This is the overview for the IdToWhereFragment method overload.
Initialize | This method is called after the key mapper has been created to initialize the keymapper with some basic configuration.
InitializeDatabase | This method may perform initialization of the database such as installing generators for autoinc mechanisms.
InitializeDatabaseScript | Same as InitializeDatabase, but rather than operating directly on the database, the initializations should be returned as sql statements to be used in a script.
InitializePSDescriptions | This method can add additional tables/columns if the keymapper requires any additional structure in the database schema. It is called once per session.
NewIdFromAttributes | This method is called once for each object before it is updated (if IdAllocationMode = FromAttributes).
NewIdPreUpdate | This method is called once for each object (if IdAllocationMode = PreUpdate) that needs to have a persistent id. It must return a new id with the same ClassId as the old id
ReserveId | This method is called once for each object before objects are updated (if IdAllocationMode = PreUpdate and allows the keymapper to prepare for the number of IDs that needs to be allocated


IKeyMapper.ColumnCount Method

IKeyMapper.ColumnCount Method
IKeyMapper Interface Eco.Persistence Namespace See Also
Collapse All

Returns the number of columns that are used to store the id

C#
int ColumnCount();
See Also
IKeyMapper Interface
Eco.Persistence Namespace


IKeyMapper.ColumnType Method

IKeyMapper.ColumnType Method
IKeyMapper Interface Eco.Persistence Namespace See Also
Collapse All

Returns the sql type for the respective column.

C#
string ColumnType(
    ArrayList KeyMappers,
    int columnNum
);
See Also
IKeyMapper Interface
Eco.Persistence Namespace


IKeyMapper.GetIdAllocationMode Method

IKeyMapper.GetIdAllocationMode Method
IKeyMapper Interface Eco.Persistence Namespace See Also
Collapse All

Indicates the strategy used by the key mapper.

C#
IdAllocationMode GetIdAllocationMode();
Remarks

FromAttributes means that the key mapper will extract the key values from the contents of the object. PreUpdate means that the id values can be allocated prior to updating the object (used by the default eco key mapper and the guid-mapper). PostUpdate means that the id values can only be obtained after the object has been inserted to the database (used by autoinc mapper).

See Also
IKeyMapper Interface
Eco.Persistence Namespace


IKeyMapper.IdFromFields Method

IKeyMapper.IdFromFields Method
IKeyMapper Interface Eco.Persistence Namespace See Also
Collapse All

This method creates a new id based on the values of the field objects

C#
ObjectId IdFromFields(
    IField[] keyFields,
    ArrayList keyMappers,
    int classId,
    int timeStamp
);
See Also
IKeyMapper Interface
Eco.Persistence Namespace


IdListToWhereFragment Method

IdListToWhereFragment Method

This is the overview for the IdListToWhereFragment method overload.

Overload List
Name | Description
IKeyMapper.IdListToWhereFragment (ObjectIdCollection, IParameterized, IList<string>) | Returns a Where clause condition that specifies a condition that is only met by the objects in the idlist.
IKeyMapper.IdListToWhereFragment (ObjectIdCollection, IParameterized, IList<string>, string) | This is IdListToWhereFragment, a member of class IKeyMapper.


IKeyMapper.IdListToWhereFragment Method (ObjectIdCollection, IParameterized, IList<string>)

IKeyMapper.IdListToWhereFragment Method (ObjectIdCollection, IParameterized, IList<string>)
IKeyMapper Interface Eco.Persistence Namespace See Also
Collapse All

Returns a Where clause condition that specifies a condition that is only met by the objects in the idlist.

C#
string IdListToWhereFragment(
    ObjectIdCollection idList,
    IParameterized parameterized,
    IList<string> idColumns
);
See Also
IKeyMapper Interface
Eco.Persistence Namespace


IKeyMapper.IdListToWhereFragment Method (ObjectIdCollection, IParameterized, IList<string>, string)

IKeyMapper.IdListToWhereFragment Method (ObjectIdCollection, IParameterized, IList<string>, string)
IKeyMapper Interface Eco.Persistence Namespace See Also
Collapse All
C#
string IdListToWhereFragment(
    ObjectIdCollection idList,
    IParameterized parameterized,
    IList<string> idColumns,
    string idPrefix
);
Remarks

This is IdListToWhereFragment, a member of class IKeyMapper.

See Also
IKeyMapper Interface
Eco.Persistence Namespace


IKeyMapper.IdToParameters Method

IKeyMapper.IdToParameters Method
IKeyMapper Interface Eco.Persistence Namespace See Also
Collapse All

This method fills the parameter objects with data from an id

C#
void IdToParameters(
    ObjectId id,
    IDataParameter[] parameters
);
See Also
IKeyMapper Interface
Eco.Persistence Namespace


IdToWhereFragment Method

IdToWhereFragment Method

This is the overview for the IdToWhereFragment method overload.

Overload List
Name | Description
IKeyMapper.IdToWhereFragment (ObjectId, IParameterized, IList<string>) | Returns a Where clause condition that specifies a condition that is only met by the objects with the specified id.
IKeyMapper.IdToWhereFragment (ObjectId, IParameterized, IList<string>, string) | This is IdToWhereFragment, a member of class IKeyMapper.


IKeyMapper.IdToWhereFragment Method (ObjectId, IParameterized, IList<string>)

IKeyMapper.IdToWhereFragment Method (ObjectId, IParameterized, IList<string>)
IKeyMapper Interface Eco.Persistence Namespace Example 1 Example 2 Example 3 See Also
Collapse All

Returns a Where clause condition that specifies a condition that is only met by the objects with the specified id.

C#
string IdToWhereFragment(
    ObjectId id,
    IParameterized parameterized,
    IList<string> idColumns
);
Example 1

ECO_ID in (1, 5, 9)

Example 2

ECO_ID = 2

Example 3

ECO_ID in (?, ?, ?, ?) [actual datavalues are stored in parameters] Example composite key: (FIRSTNAME='Peter' AND LASTNAME='Smith') OR (FIRSTNAME='John' AND LASTNAME='Lane') OR (FIRSTNAME='Dave' AND LASTNAME='Short')

See Also
IKeyMapper Interface
Eco.Persistence Namespace
Example 1
Example 2
Example 3


IKeyMapper.IdToWhereFragment Method (ObjectId, IParameterized, IList<string>, string)

IKeyMapper.IdToWhereFragment Method (ObjectId, IParameterized, IList<string>, string)
IKeyMapper Interface Eco.Persistence Namespace See Also
Collapse All
C#
string IdToWhereFragment(
    ObjectId id,
    IParameterized parameterized,
    IList<string> idColumns,
    string idPrefix
);
Remarks

This is IdToWhereFragment, a member of class IKeyMapper.

See Also
IKeyMapper Interface
Eco.Persistence Namespace


IKeyMapper.Initialize Method

IKeyMapper.Initialize Method
IKeyMapper Interface Eco.Persistence Namespace See Also
Collapse All

This method is called after the key mapper has been created to initialize the keymapper with some basic configuration.

C#
void Initialize(
    SqlDatabaseConfig config,
    ArrayList keyMappers
);
See Also
IKeyMapper Interface
Eco.Persistence Namespace


IKeyMapper.InitializeDatabase Method

IKeyMapper.InitializeDatabase Method
IKeyMapper Interface Eco.Persistence Namespace See Also
Collapse All

This method may perform initialization of the database such as installing generators for autoinc mechanisms.

C#
void InitializeDatabase(
    IDatabase db
);
See Also
IKeyMapper Interface
Eco.Persistence Namespace


IKeyMapper.InitializeDatabaseScript Method

IKeyMapper.InitializeDatabaseScript Method
IKeyMapper Interface Eco.Persistence Namespace See Also
Collapse All

Same as InitializeDatabase, but rather than operating directly on the database, the initializations should be returned as sql statements to be used in a script.

C#
void InitializeDatabaseScript(
    IList<string> script
);
See Also
IKeyMapper Interface
Eco.Persistence Namespace


IKeyMapper.InitializePSDescriptions Method

IKeyMapper.InitializePSDescriptions Method
IKeyMapper Interface Eco.Persistence Namespace See Also
Collapse All

This method can add additional tables/columns if the keymapper requires any additional structure in the database schema. It is called once per session.

C#
void InitializePSDescriptions(
    IDatabaseDefinition db
);
See Also
IKeyMapper Interface
Eco.Persistence Namespace


IKeyMapper.NewIdFromAttributes Method

IKeyMapper.NewIdFromAttributes Method
IKeyMapper Interface Eco.Persistence Namespace See Also
Collapse All

This method is called once for each object before it is updated (if IdAllocationMode = FromAttributes).

C#
ObjectId NewIdFromAttributes(
    ObjectContents objContents,
    ArrayList memberIndexes,
    IdTranslationList translationList
);
Parameters
Parameters | Description
objContents | The object that needs an id
memberIndexes | An arraylist of MemberIndexColumnIndex objects
translationList | If the new Id contains any information from relations to other objects, it is important that those ids are translated using the translationlist before the related object ids are used
See Also
IKeyMapper Interface
Eco.Persistence Namespace


IKeyMapper.NewIdPreUpdate Method

IKeyMapper.NewIdPreUpdate Method
IKeyMapper Interface Eco.Persistence Namespace See Also
Collapse All

This method is called once for each object (if IdAllocationMode = PreUpdate) that needs to have a persistent id. It must return a new id with the same ClassId as the old id

C#
ObjectId NewIdPreUpdate(
    IDatabase db,
    ObjectId oldId
);
See Also
IKeyMapper Interface
Eco.Persistence Namespace


IKeyMapper.ReserveId Method

IKeyMapper.ReserveId Method
IKeyMapper Interface Eco.Persistence Namespace See Also
Collapse All

This method is called once for each object before objects are updated (if IdAllocationMode = PreUpdate and allows the keymapper to prepare for the number of IDs that needs to be allocated

C#
void ReserveId();
See Also
IKeyMapper Interface
Eco.Persistence Namespace


INonBooleanBooleanMapping Interface

INonBooleanBooleanMapping Interface
Inheritance Hierarchy See Also
Collapse All

This interface handles database conversion for boolean values that are stored as non-booleans.

C#
public interface INonBooleanBooleanMapping;
Inheritance Hierarchy
Eco.Persistence.INonBooleanBooleanMapping
    Eco.Persistence.Default.BooleanAsInteger
    Eco.Persistence.Default.BooleanAsYNChar
    Eco.Persistence.Interbase.BooleanAsBoolean
    Eco.Persistence.Nexus.BooleanAsBool
    Eco.Persistence.Oracle.BooleanAsInteger
    Eco.Persistence.SQLite.BooleanAsInteger
File

PersistenceInterfaces.cs

See Also
Inheritance Hierarchy


INonBooleanBooleanMapping Properties

INonBooleanBooleanMapping Properties
Public Properties
Collapse All

The properties of the INonBooleanBooleanMapping class are listed here.

Public Properties
Name | Description
TrueString | Returns the string representation for the "true" value.


INonBooleanBooleanMapping.TrueString Property

INonBooleanBooleanMapping.TrueString Property
INonBooleanBooleanMapping Interface Eco.Persistence Namespace See Also
Collapse All

Returns the string representation for the "true" value.

C#
string TrueString;
Remarks

This could be for example "true", "1", "y" depending on how the value "true" is stored.

See Also
INonBooleanBooleanMapping Interface
Eco.Persistence Namespace


IOptimisticLockHandler Interface

IOptimisticLockHandler Interface
Inheritance Hierarchy See Also
Collapse All
C#
public interface IOptimisticLockHandler;
Remarks

This is class Eco.Persistence.IOptimisticLockHandler.

Inheritance Hierarchy
Eco.Persistence.IOptimisticLockHandler
File

PersistenceMapperInterfaces.cs

See Also
Inheritance Hierarchy


IOptimisticLockHandler Methods

IOptimisticLockHandler Methods
Public Methods
Collapse All

The methods of the IOptimisticLockHandler class are listed here.

Public Methods
Name | Description
CreatePrecondition | This is CreatePrecondition, a member of class IOptimisticLockHandler.


IOptimisticLockHandler.CreatePrecondition Method

IOptimisticLockHandler.CreatePrecondition Method
IOptimisticLockHandler Interface Eco.Persistence Namespace See Also
Collapse All
C#
OptimisticLockingPrecondition CreatePrecondition(
    IEnumerable<Locator> locators
);
Remarks

This is CreatePrecondition, a member of class IOptimisticLockHandler.

See Also
IOptimisticLockHandler Interface
Eco.Persistence Namespace


IPersistenceMapper Interface

IPersistenceMapper Interface
Inheritance Hierarchy See Also
Collapse All
C#
public interface IPersistenceMapper;
Remarks

This is class Eco.Persistence.IPersistenceMapper.

Inheritance Hierarchy
Eco.Persistence.IPersistenceMapper
    Eco.Persistence.AbstractDataBlockPersistenceMapper
    Eco.Persistence.ChainedPersistenceMapperImplBase
File

PersistenceMapperInterfaces.cs

See Also
Inheritance Hierarchy


IPersistenceMapper Methods

IPersistenceMapper Methods
Public Methods
Collapse All

The methods of the IPersistenceMapper class are listed here.

Public Methods
Name | Description
Fetch | This is Fetch, a member of class IPersistenceMapper.
FetchIDListWithCondition | This is FetchIDListWithCondition, a member of class IPersistenceMapper.
GetChangesSince | This is GetChangesSince, a member of class IPersistenceMapper.
TimeForVersion | This is TimeForVersion, a member of class IPersistenceMapper.
Update | This is Update, a member of class IPersistenceMapper.
VersionForTime | This is VersionForTime, a member of class IPersistenceMapper.


IPersistenceMapper.Fetch Method

IPersistenceMapper.Fetch Method
IPersistenceMapper Interface Eco.Persistence Namespace See Also
Collapse All
C#
void Fetch(
    ObjectIdList idList,
    out Datablock datablock,
    int[] memberIdList,
    FetchStrategy fetchStrategy
);
Remarks

This is Fetch, a member of class IPersistenceMapper.

See Also
IPersistenceMapper Interface
Eco.Persistence Namespace


IPersistenceMapper.FetchIDListWithCondition Method

IPersistenceMapper.FetchIDListWithCondition Method
IPersistenceMapper Interface Eco.Persistence Namespace See Also
Collapse All
C#
void FetchIDListWithCondition(
    AbstractCondition condition,
    out ObjectIdList result,
    int maxResults,
    int offset
);
Remarks

This is FetchIDListWithCondition, a member of class IPersistenceMapper.

See Also
IPersistenceMapper Interface
Eco.Persistence Namespace


IPersistenceMapper.GetChangesSince Method

IPersistenceMapper.GetChangesSince Method
IPersistenceMapper Interface Eco.Persistence Namespace See Also
Collapse All
C#
void GetChangesSince(
    SyncVersion syncVersion,
    SyncVersion[] excludeList,
    out DBChangeCollection changes,
    out SyncVersion lastSyncVersion
);
Remarks

This is GetChangesSince, a member of class IPersistenceMapper.

See Also
IPersistenceMapper Interface
Eco.Persistence Namespace


IPersistenceMapper.TimeForVersion Method

IPersistenceMapper.TimeForVersion Method
IPersistenceMapper Interface Eco.Persistence Namespace See Also
Collapse All
C#
void TimeForVersion(
    int version,
    out DateTime clockTime
);
Remarks

This is TimeForVersion, a member of class IPersistenceMapper.

See Also
IPersistenceMapper Interface
Eco.Persistence Namespace


IPersistenceMapper.Update Method

IPersistenceMapper.Update Method
IPersistenceMapper Interface Eco.Persistence Namespace See Also
Collapse All
C#
void Update(
    Datablock datablock,
    UpdatePrecondition precondition,
    out IdTranslationList translationList,
    out int version,
    out SyncVersion syncVersion,
    out UpdateResult result
);
Remarks

This is Update, a member of class IPersistenceMapper.

See Also
IPersistenceMapper Interface
Eco.Persistence Namespace


IPersistenceMapper.VersionForTime Method

IPersistenceMapper.VersionForTime Method
IPersistenceMapper Interface Eco.Persistence Namespace See Also
Collapse All
C#
void VersionForTime(
    DateTime clockTime,
    out int version
);
Remarks

This is VersionForTime, a member of class IPersistenceMapper.

See Also
IPersistenceMapper Interface
Eco.Persistence Namespace


IPersistenceMapper Properties

IPersistenceMapper Properties
Public Properties
Collapse All

The properties of the IPersistenceMapper class are listed here.

Public Properties
Name | Description
CurrentSyncVersion | This is CurrentSyncVersion, a member of class IPersistenceMapper.
SupportsSync | This is SupportsSync, a member of class IPersistenceMapper.


IPersistenceMapper.CurrentSyncVersion Property

IPersistenceMapper.CurrentSyncVersion Property
IPersistenceMapper Interface Eco.Persistence Namespace See Also
Collapse All
C#
SyncVersion CurrentSyncVersion;
Remarks

This is CurrentSyncVersion, a member of class IPersistenceMapper.

See Also
IPersistenceMapper Interface
Eco.Persistence Namespace


IPersistenceMapper.SupportsSync Property

IPersistenceMapper.SupportsSync Property
IPersistenceMapper Interface Eco.Persistence Namespace See Also
Collapse All
C#
bool SupportsSync;
Remarks

This is SupportsSync, a member of class IPersistenceMapper.

See Also
IPersistenceMapper Interface
Eco.Persistence Namespace


IPersistenceMapperDb Interface

IPersistenceMapperDb Interface
Inheritance Hierarchy See Also
Collapse All

This interface is for internal use, and breaks the dependency between Eco.Handles.Windows and Eco.Persistence (in the DBEvolution form and the ActionExtender).

C#
public interface IPersistenceMapperDb;
Inheritance Hierarchy
Eco.Persistence.IPersistenceMapperDb
    Eco.Persistence.PersistenceMapperDb
File

PersistenceMapperInterfaces.cs

See Also
Inheritance Hierarchy


IPersistenceMapperDb Methods

IPersistenceMapperDb Methods
Public Methods
Collapse All

The methods of the IPersistenceMapperDb class are listed here.

Public Methods
Name | Description
CreateDatabaseSchema | This is CreateDatabaseSchema, a member of class IPersistenceMapperDb.
GetEvolutor | This is GetEvolutor, a member of class IPersistenceMapperDb.
ReturnEvolutor | This is ReturnEvolutor, a member of class IPersistenceMapperDb.


IPersistenceMapperDb.CreateDatabaseSchema Method

IPersistenceMapperDb.CreateDatabaseSchema Method
IPersistenceMapperDb Interface Eco.Persistence Namespace See Also
Collapse All
C#
void CreateDatabaseSchema(
    ITypeSystemService typeSystemService,
    IConfigureCleanPS configureCleanPS
);
Remarks

This is CreateDatabaseSchema, a member of class IPersistenceMapperDb.

See Also
IPersistenceMapperDb Interface
Eco.Persistence Namespace


IPersistenceMapperDb.GetEvolutor Method

IPersistenceMapperDb.GetEvolutor Method
IPersistenceMapperDb Interface Eco.Persistence Namespace See Also
Collapse All
C#
IDBEvolutor GetEvolutor(
    ITypeSystemService typeSystemService
);
Remarks

This is GetEvolutor, a member of class IPersistenceMapperDb.

See Also
IPersistenceMapperDb Interface
Eco.Persistence Namespace


IPersistenceMapperDb.ReturnEvolutor Method

IPersistenceMapperDb.ReturnEvolutor Method
IPersistenceMapperDb Interface Eco.Persistence Namespace See Also
Collapse All
C#
void ReturnEvolutor(
    IDBEvolutor evolutor
);
Remarks

This is ReturnEvolutor, a member of class IPersistenceMapperDb.

See Also
IPersistenceMapperDb Interface
Eco.Persistence Namespace


IPersistencemapperProvider Interface

IPersistencemapperProvider Interface
Inheritance Hierarchy See Also
Collapse All
C#
public interface IPersistencemapperProvider;
Remarks

This is class Eco.Persistence.IPersistencemapperProvider.

Inheritance Hierarchy
Eco.Persistence.IPersistencemapperProvider
    Eco.Persistence.PersistenceMapper
    Eco.Persistence.PersistenceMapperProvider
File

PersistenceMapper.cs

See Also
Inheritance Hierarchy


IPersistencemapperProvider Methods

IPersistencemapperProvider Methods
Public Methods
Collapse All

The methods of the IPersistencemapperProvider class are listed here.

Public Methods
Name | Description
GetPersistenceMapper | This is GetPersistenceMapper, a member of class IPersistencemapperProvider.
ReturnPersistenceMapper | This is ReturnPersistenceMapper, a member of class IPersistencemapperProvider.


IPersistencemapperProvider.GetPersistenceMapper Method

IPersistencemapperProvider.GetPersistenceMapper Method
IPersistencemapperProvider Interface Eco.Persistence Namespace See Also
Collapse All
C#
IPersistenceMapper GetPersistenceMapper(
    ITypeSystemService typeSystemService
);
Remarks

This is GetPersistenceMapper, a member of class IPersistencemapperProvider.

See Also
IPersistencemapperProvider Interface
Eco.Persistence Namespace


IPersistencemapperProvider.ReturnPersistenceMapper Method

IPersistencemapperProvider.ReturnPersistenceMapper Method
IPersistencemapperProvider Interface Eco.Persistence Namespace See Also
Collapse All
C#
void ReturnPersistenceMapper(
    IPersistenceMapper persistenceMapper
);
Remarks

This is ReturnPersistenceMapper, a member of class IPersistencemapperProvider.

See Also
IPersistencemapperProvider Interface
Eco.Persistence Namespace


IPersistenceMapperWithIDatabase Interface

IPersistenceMapperWithIDatabase Interface
Inheritance Hierarchy See Also
Collapse All
C#
public interface IPersistenceMapperWithIDatabase;
Remarks

This is class Eco.Persistence.IPersistenceMapperWithIDatabase.

Inheritance Hierarchy
Eco.Persistence.IPersistenceMapperWithIDatabase
File

PersistenceInterfaces.cs

See Also
Inheritance Hierarchy


IPersistenceMapperWithIDatabase Methods

IPersistenceMapperWithIDatabase Methods
Public Methods
Collapse All

The methods of the IPersistenceMapperWithIDatabase class are listed here.

Public Methods
Name | Description
Fetch | This is Fetch, a member of class IPersistenceMapperWithIDatabase.
FetchIDListWithCondition | This is FetchIDListWithCondition, a member of class IPersistenceMapperWithIDatabase.
TimeForVersion | This is TimeForVersion, a member of class IPersistenceMapperWithIDatabase.
Update | This is Update, a member of class IPersistenceMapperWithIDatabase.
VersionForTime | This is VersionForTime, a member of class IPersistenceMapperWithIDatabase.


IPersistenceMapperWithIDatabase.Fetch Method

IPersistenceMapperWithIDatabase.Fetch Method
IPersistenceMapperWithIDatabase Interface Eco.Persistence Namespace See Also
Collapse All
C#
void Fetch(
    IDatabaseCollection databases,
    ObjectIdList idList,
    out Datablock datablock,
    int[] memberIdList,
    FetchStrategy fetchStrategy
);
Remarks

This is Fetch, a member of class IPersistenceMapperWithIDatabase.

See Also
IPersistenceMapperWithIDatabase Interface
Eco.Persistence Namespace


IPersistenceMapperWithIDatabase.FetchIDListWithCondition Method

IPersistenceMapperWithIDatabase.FetchIDListWithCondition Method
IPersistenceMapperWithIDatabase Interface Eco.Persistence Namespace See Also
Collapse All
C#
void FetchIDListWithCondition(
    IDatabaseCollection databases,
    AbstractCondition condition,
    out ObjectIdList result,
    int maxResults,
    int offset
);
Remarks

This is FetchIDListWithCondition, a member of class IPersistenceMapperWithIDatabase.

See Also
IPersistenceMapperWithIDatabase Interface
Eco.Persistence Namespace


IPersistenceMapperWithIDatabase.TimeForVersion Method

IPersistenceMapperWithIDatabase.TimeForVersion Method
IPersistenceMapperWithIDatabase Interface Eco.Persistence Namespace See Also
Collapse All
C#
void TimeForVersion(
    IDatabase database,
    int version,
    out DateTime clockTime
);
Remarks

This is TimeForVersion, a member of class IPersistenceMapperWithIDatabase.

See Also
IPersistenceMapperWithIDatabase Interface
Eco.Persistence Namespace


IPersistenceMapperWithIDatabase.Update Method

IPersistenceMapperWithIDatabase.Update Method
IPersistenceMapperWithIDatabase Interface Eco.Persistence Namespace See Also
Collapse All
C#
void Update(
    IDatabaseCollection databases,
    Datablock datablock,
    UpdatePrecondition Precondition,
    out IdTranslationList translationList,
    out int version,
    out UpdateResult result,
    out SyncVersion syncVersion,
    ISyncSink syncSink
);
Remarks

This is Update, a member of class IPersistenceMapperWithIDatabase.

See Also
IPersistenceMapperWithIDatabase Interface
Eco.Persistence Namespace


IPersistenceMapperWithIDatabase.VersionForTime Method

IPersistenceMapperWithIDatabase.VersionForTime Method
IPersistenceMapperWithIDatabase Interface Eco.Persistence Namespace See Also
Collapse All
C#
void VersionForTime(
    IDatabase database,
    DateTime clockTime,
    out int Version
);
Remarks

This is VersionForTime, a member of class IPersistenceMapperWithIDatabase.

See Also
IPersistenceMapperWithIDatabase Interface
Eco.Persistence Namespace


IRemotePersistenceMapperProvider Interface

IRemotePersistenceMapperProvider Interface
Inheritance Hierarchy See Also
Collapse All
C#
public interface IRemotePersistenceMapperProvider;
Remarks

This is class Eco.Persistence.IRemotePersistenceMapperProvider.

Inheritance Hierarchy
Eco.Persistence.IRemotePersistenceMapperProvider
    Eco.Persistence.PersistenceMapperProvider
File

PersistenceMapperProvider.cs

See Also
Inheritance Hierarchy


IRemotePersistenceMapperProvider Methods

IRemotePersistenceMapperProvider Methods
Public Methods
Collapse All

The methods of the IRemotePersistenceMapperProvider class are listed here.

Public Methods
Name | Description
GetPersistenceMapper | This is GetPersistenceMapper, a member of class IRemotePersistenceMapperProvider.


IRemotePersistenceMapperProvider.GetPersistenceMapper Method

IRemotePersistenceMapperProvider.GetPersistenceMapper Method
IRemotePersistenceMapperProvider Interface Eco.Persistence Namespace See Also
Collapse All
C#
IPersistenceMapper GetPersistenceMapper(
    int typeSystemHash
);
Remarks

This is GetPersistenceMapper, a member of class IRemotePersistenceMapperProvider.

See Also
IRemotePersistenceMapperProvider Interface
Eco.Persistence Namespace


ISingleColumnAttributemapping Interface

ISingleColumnAttributemapping Interface
Inheritance Hierarchy See Also
Collapse All

This interface handles database conversion for values that are stored in a single column.

C#
public interface ISingleColumnAttributemapping;
Inheritance Hierarchy
Eco.Persistence.ISingleColumnAttributemapping
    Eco.Persistence.Blackfish.BooleanAsBoolean
    Eco.Persistence.Blackfish.ByteArrayAsBdpVarBinary
    Eco.Persistence.Blackfish.ByteArrayAsVarBinary
    Eco.Persistence.Blackfish.CharAsVarChar1
    Eco.Persistence.Blackfish.Int64AsBigInt
    Eco.Persistence.Blackfish.SingleAsFloat
    Eco.Persistence.Blackfish.StringAsText
    Eco.Persistence.Db2.DecimalAsDecimal
    Eco.Persistence.Db2.Int64AsBigInt
    Eco.Persistence.Db2.Int64AsLongInteger
    Eco.Persistence.Db2.SingleAsFloat
    Eco.Persistence.Db2.StringAsDbClob
    Eco.Persistence.Dbx.Blackfish.ByteArrayAsDbxVarBinary
    Eco.Persistence.Dbx.Db2.StringAsDbClob
    Eco.Persistence.Dbx.Interbase.ByteArrayAsDbxBlob
    Eco.Persistence.Dbx.Interbase.StringAsDbxBlob
    Eco.Persistence.Dbx.Interbase.StringAsDbxVarChar
    Eco.Persistence.Dbx.MySql.ByteArrayAsDbxBlob
    Eco.Persistence.Dbx.MySql.StringAsLongText
    Eco.Persistence.Dbx.Oracle.ByteArrayAsBlob
    Eco.Persistence.Dbx.Oracle.StringAsClob
    Eco.Persistence.Dbx.Oracle.StringAsNClob
    Eco.Persistence.Dbx.SqlServer.ByteArrayAsImage
    Eco.Persistence.Dbx.SqlServer.ByteAsTinyInt
    Eco.Persistence.Dbx.SqlServer.StringAsNText
    Eco.Persistence.Dbx.SqlServer.StringAsText
    Eco.Persistence.Dbx.Sybase.ByteArrayAsImage
    Eco.Persistence.Dbx.Sybase.StringAsText
    Eco.Persistence.Default.BooleanAsInteger
    Eco.Persistence.Default.BooleanAsYNChar
    Eco.Persistence.Default.ByteAsSmallInt
    Eco.Persistence.Default.CharAsChar
    Eco.Persistence.Default.CharAsNChar
    Eco.Persistence.Default.ColorAsInteger
    Eco.Persistence.Default.DecimalAsDecimal
    Eco.Persistence.Default.DoubleAsDouble
    Eco.Persistence.Default.GenericAttributeMapper
    Eco.Persistence.Default.GenericDateTimeMapper
    Eco.Persistence.Default.GenericTimeSpanMapper
    Eco.Persistence.Default.GuidAsVarChar32
    Eco.Persistence.Default.Int16AsSmallint
    Eco.Persistence.Default.Int32AsInteger
    Eco.Persistence.Default.Int64AsLongInteger
    Eco.Persistence.Default.SByteAsSmallInt
    Eco.Persistence.Default.SingleAsSingle
    Eco.Persistence.Default.StringAsChar
    Eco.Persistence.Default.StringAsNChar
    Eco.Persistence.Default.StringAsNVarChar
    Eco.Persistence.Default.StringAsVarChar
    Eco.Persistence.Default.UInt16AsLongInteger
    Eco.Persistence.Default.UInt32AsLongInteger
    Eco.Persistence.Default.UInt64AsDecimal
    Eco.Persistence.Firebird.ByteArrayAsBlob
    Eco.Persistence.Firebird.DecimalAsDecimal
    Eco.Persistence.Firebird.StringAsBlob
    Eco.Persistence.IAutoIncAttributemapping
    Eco.Persistence.IGenericSingleColumnAttributemapping
    Eco.Persistence.Interbase.BooleanAsBoolean
    Eco.Persistence.Interbase.ByteArrayAsBdpBlob
    Eco.Persistence.Interbase.CharAsNCharUnicode
    Eco.Persistence.Interbase.DecimalAsDecimal
    Eco.Persistence.Interbase.Int64AsLongInteger
    Eco.Persistence.Interbase.StringAsBdpBlob
    Eco.Persistence.Interbase.StringAsNCharUnicode
    Eco.Persistence.Mimer.ByteArrayAsMimerBlob
    Eco.Persistence.Mimer.Int64AsBigInt
    Eco.Persistence.Mimer.SingleAsFloat
    Eco.Persistence.Mimer.StringAsMimerClob
    Eco.Persistence.Mimer.StringAsMimerNClob
    Eco.Persistence.MySql.Bdp.ByteArrayAsBdpBlob
    Eco.Persistence.MySql.Bdp.StringAsLongText
    Eco.Persistence.MySql.ByteAsUnsingedTinyInt
    Eco.Persistence.MySql.DateTimeAsDateTime
    Eco.Persistence.MySql.Int64AsBigInt
    Eco.Persistence.MySql.MysClient.ByteArrayAsBlob
    Eco.Persistence.MySql.MysClient.Int64AsBigInt
    Eco.Persistence.MySql.MysClient.StringAsLongText
    Eco.Persistence.MySql.MysClient.StringAsUnicodeText
    Eco.Persistence.MySql.MysClient.StringAsUnicodeVarChar
    Eco.Persistence.MySql.UInt16AsUnsignedSmallint
    Eco.Persistence.Nexus.BooleanAsBool
    Eco.Persistence.Nexus.ByteArrayAsNexusDBBlob
    Eco.Persistence.Nexus.DecimalAsDecimal
    Eco.Persistence.Nexus.DoubleAsDouble
    Eco.Persistence.Nexus.GuidAsGuid
    Eco.Persistence.Nexus.Int64AsBigInt
    Eco.Persistence.Nexus.SingleAsFloat
    Eco.Persistence.Nexus.StringAsNexusDBClob
    Eco.Persistence.Nexus.StringAsNexusDBNClob
    Eco.Persistence.Nexus.StringAsVarChar
    Eco.Persistence.Oracle.BooleanAsInteger
    Eco.Persistence.Oracle.ByteArrayAsBlob
    Eco.Persistence.Oracle.ByteAsSmallInt
    Eco.Persistence.Oracle.DateTimeAsDate
    Eco.Persistence.Oracle.DateTimeAsTimeStamp
    Eco.Persistence.Oracle.DecimalAsDecimal
    Eco.Persistence.Oracle.DoubleAsNumber
    Eco.Persistence.Oracle.Int16AsNumber
    Eco.Persistence.Oracle.Int32AsNumber
    Eco.Persistence.Oracle.Int64AsLongInteger
    Eco.Persistence.Oracle.SingleAsSingle
    Eco.Persistence.Oracle.StringAsClob
    Eco.Persistence.Oracle.StringAsNClob
    Eco.Persistence.Oracle.StringAsVarChar2
    Eco.Persistence.Oracle.TimeSpanAsDate
    Eco.Persistence.Oracle.TimeSpanAsLongInteger
    Eco.Persistence.OracleClient.ByteArrayAsBlob
    Eco.Persistence.OracleClient.StringAsClob
    Eco.Persistence.OracleClient.StringAsNClob
    Eco.Persistence.OracleClient.StringAsVarChar2
    Eco.Persistence.SQLite.BooleanAsInteger
    Eco.Persistence.SQLite.ByteArrayAsBLOB
    Eco.Persistence.SQLite.Int32AsInteger
    Eco.Persistence.SQLite.Int64AsInteger
    Eco.Persistence.SQLite.SingleAsFloat
    Eco.Persistence.SQLite.StringAsText
    Eco.Persistence.SqlServer.Bdp.ByteArrayAsImage
    Eco.Persistence.SqlServer.Bdp.ByteAsTinyInt
    Eco.Persistence.SqlServer.Bdp.StringAsNText
    Eco.Persistence.SqlServer.Bdp.StringAsText
    Eco.Persistence.SqlServer.BooleanAsBit
    Eco.Persistence.SqlServer.ByteAsTinyInt
    Eco.Persistence.SqlServer.DateTimeAsDateTime
    Eco.Persistence.SqlServer.DateTimeAsDateTimeWithoutMilliseconds
    Eco.Persistence.SqlServer.DecimalAsDecimal
    Eco.Persistence.SqlServer.DecimalAsDecimal28
    Eco.Persistence.SqlServer.DecimalAsMoney
    Eco.Persistence.SqlServer.DecimalAsSmallMoney
    Eco.Persistence.SqlServer.GuidAsUniqueIdentifier
    Eco.Persistence.SqlServer.Int32AsInt
    Eco.Persistence.SqlServer.Int64AsLongInteger
    Eco.Persistence.SqlServer.Int64AsTimeStamp
    Eco.Persistence.SqlServer.SingleAsFloat
    Eco.Persistence.SqlServer.SingleAsReal
    Eco.Persistence.SqlServer.SqlClient.ByteArrayAsImage
    Eco.Persistence.SqlServer.SqlClient.StringAsNText
    Eco.Persistence.SqlServer.SqlClient.StringAsText
    Eco.Persistence.SqlServer.StringAsXml
    Eco.Persistence.SqlServer.TimeSpanAsDateTime
    Eco.Persistence.Sybase.Ase.ByteArrayAsImage
    Eco.Persistence.Sybase.Ase.StringAsText
    Eco.Persistence.Sybase.Ase.StringAsUniVarChar
    Eco.Persistence.Sybase.Bdp.ByteArrayAsImage
    Eco.Persistence.Sybase.Bdp.StringAsText
    Eco.Persistence.Sybase.BooleanAsBit
    Eco.Persistence.Sybase.SingleAsFloat
File

PersistenceInterfaces.cs

See Also
Inheritance Hierarchy


ISingleColumnAttributemapping Methods

ISingleColumnAttributemapping Methods
Public Methods
Collapse All

The methods of the ISingleColumnAttributemapping class are listed here.

Public Methods
Name | Description
ColumnName | The return value of this function will be used for new columns when databases are created/evolved.
ColumnToValue | Converts a value that comes from a database query to an ecospace value.
ColumnType | Specifies the SQL type of the column.
DefaultDbValue | The return value of this function will be used as default value for new columns when databases are created/evolved.
IsEqual | Returns true if an ecospace value ("value") is equal to a database value ("columnValue").
StringToParameter | This is StringToParameter, a member of class ISingleColumnAttributemapping.
ValueToParameter | Converts a value that comes from a database query to an ecospace value.
ValueType | This method returns the type of the value that is returned by ColumnToValue.


ISingleColumnAttributemapping.ColumnName Method

ISingleColumnAttributemapping.ColumnName Method
ISingleColumnAttributemapping Interface Eco.Persistence Namespace See Also
Collapse All

The return value of this function will be used for new columns when databases are created/evolved.

C#
String ColumnName(
    string name
);
See Also
ISingleColumnAttributemapping Interface
Eco.Persistence Namespace


ISingleColumnAttributemapping.ColumnToValue Method

ISingleColumnAttributemapping.ColumnToValue Method
ISingleColumnAttributemapping Interface Eco.Persistence Namespace See Also
Collapse All

Converts a value that comes from a database query to an ecospace value.

C#
System.Object ColumnToValue(
    System.Object columnValue
);
Remarks

In many cases, the implementation of this method mainly converts DBNull-values to null, but it can also change the CLR-type of the database value from for example a char[] to a string. or from an integer to a boolean. This is the reverse operation of ValueToParameter.

See Also
ISingleColumnAttributemapping Interface
Eco.Persistence Namespace


ISingleColumnAttributemapping.ColumnType Method

ISingleColumnAttributemapping.ColumnType Method
ISingleColumnAttributemapping Interface Eco.Persistence Namespace See Also
Collapse All

Specifies the SQL type of the column.

C#
String ColumnType(
    int length
);
See Also
ISingleColumnAttributemapping Interface
Eco.Persistence Namespace


ISingleColumnAttributemapping.DefaultDbValue Method

ISingleColumnAttributemapping.DefaultDbValue Method
ISingleColumnAttributemapping Interface Eco.Persistence Namespace See Also
Collapse All

The return value of this function will be used as default value for new columns when databases are created/evolved.

C#
String DefaultDbValue(
    string modeledValue,
    SqlDatabaseConfig sqlDatabaseConfig
);
See Also
ISingleColumnAttributemapping Interface
Eco.Persistence Namespace


ISingleColumnAttributemapping.IsEqual Method

ISingleColumnAttributemapping.IsEqual Method
ISingleColumnAttributemapping Interface Eco.Persistence Namespace See Also
Collapse All

Returns true if an ecospace value ("value") is equal to a database value ("columnValue").

C#
bool IsEqual(
    System.Object value,
    System.Object columnValue
);
Remarks

This method must handle the conversions between ecospace and database values, it must also handle comparing null/DBNull values.

See Also
ISingleColumnAttributemapping Interface
Eco.Persistence Namespace


ISingleColumnAttributemapping.StringToParameter Method

ISingleColumnAttributemapping.StringToParameter Method
ISingleColumnAttributemapping Interface Eco.Persistence Namespace See Also
Collapse All
C#
void StringToParameter(
    string value,
    IDataParameter parameter
);
Remarks

This is StringToParameter, a member of class ISingleColumnAttributemapping.

See Also
ISingleColumnAttributemapping Interface
Eco.Persistence Namespace


ISingleColumnAttributemapping.ValueToParameter Method

ISingleColumnAttributemapping.ValueToParameter Method
ISingleColumnAttributemapping Interface Eco.Persistence Namespace See Also
Collapse All

Converts a value that comes from a database query to an ecospace value.

C#
void ValueToParameter(
    System.Object value,
    IDataParameter parameter
);
Remarks

In many cases, the implementation of this method mainly converts null to DBNull, but it can also handle conversion from for example booleans to integers, byte[] to database blobs. It also has to set the correct parameter types in the IDataParameter-object. This is the reverse operation of ColumnToValue.

See Also
ISingleColumnAttributemapping Interface
Eco.Persistence Namespace


ISingleColumnAttributemapping.ValueType Method

ISingleColumnAttributemapping.ValueType Method
ISingleColumnAttributemapping Interface Eco.Persistence Namespace See Also
Collapse All

This method returns the type of the value that is returned by ColumnToValue.

C#
System.Type ValueType();
See Also
ISingleColumnAttributemapping Interface
Eco.Persistence Namespace


ISyncSink Interface

ISyncSink Interface
Inheritance Hierarchy See Also
Collapse All
C#
public interface ISyncSink;
Remarks

This is class Eco.Persistence.ISyncSink.

Inheritance Hierarchy
Eco.Persistence.ISyncSink
    Eco.Persistence.AbstractSyncHandler
    Eco.Persistence.SyncHandler
File

PersistenceMapperInterfaces.cs

See Also
Inheritance Hierarchy


ISyncSink Methods

ISyncSink Methods
Public Methods
Collapse All

The methods of the ISyncSink class are listed here.

Public Methods
Name | Description
Submit | This is Submit, a member of class ISyncSink.


ISyncSink.Submit Method

ISyncSink.Submit Method
ISyncSink Interface Eco.Persistence Namespace See Also
Collapse All
C#
SyncVersion Submit(
    CommitBlock commitBlock
);
Remarks

This is Submit, a member of class ISyncSink.

See Also
ISyncSink Interface
Eco.Persistence Namespace


ISyncSink Properties

ISyncSink Properties
Public Properties
Collapse All

The properties of the ISyncSink class are listed here.

Public Properties
Name | Description
SyncRoot | This is SyncRoot, a member of class ISyncSink.


ISyncSink.SyncRoot Property

ISyncSink.SyncRoot Property
ISyncSink Interface Eco.Persistence Namespace See Also
Collapse All
C#
object SyncRoot;
Remarks

This is SyncRoot, a member of class ISyncSink.

See Also
ISyncSink Interface
Eco.Persistence Namespace


Eco.Persistence.CreateMappingMode Enumeration

Eco.Persistence.CreateMappingMode Enumeration
C#
internal enum CreateMappingMode {
  CreateDb,
  Run
}
Remarks

This is record Eco.Persistence.CreateMappingMode.

File

PersistenceMapperMultiDb.cs


Eco.Persistence.IdAllocationMode Enumeration

Eco.Persistence.IdAllocationMode Enumeration
C#
public enum IdAllocationMode {
  FromAttributes,
  PreUpdate,
  PostUpdate
}
Remarks

This is record Eco.Persistence.IdAllocationMode.

File

IKeyMapper.cs


Eco.Persistence.PMapperOp Enumeration

Eco.Persistence.PMapperOp Enumeration
C#
public enum PMapperOp {
  Update,
  Fetch,
  FetchWithCondition,
  VersionForTime,
  TimeForVersion
}
Remarks

This is record Eco.Persistence.PMapperOp.

File

PersistenceMapperDb.cs


Eco.Persistence.RestoreDbStatus Enumeration

Eco.Persistence.RestoreDbStatus Enumeration
C#
public enum RestoreDbStatus {
  TryAgain,
  Failed
}
Remarks

This is record Eco.Persistence.RestoreDbStatus.

File

PersistenceMapperDb.cs


Eco.Persistence.TransactionMode Enumeration

Eco.Persistence.TransactionMode Enumeration
C#
public enum TransactionMode {
  Disabled,
  Local,
  Distributed
}
Remarks

This is record Eco.Persistence.TransactionMode.

File

PersistenceMapperMultiDb.cs


Eco.Persistence.GetDateTimeDelegate Type

Eco.Persistence.GetDateTimeDelegate Type
C#
public delegate DateTime GetDateTimeDelegate();
Remarks

This is type Eco.Persistence.GetDateTimeDelegate.

File

PersistenceInterfaces.cs


Eco.Persistence.Blackfish Namespace

Eco.Persistence.Blackfish Namespace
Classes
Collapse All

This is namespace Eco.Persistence.Blackfish.

Classes
Name | Description
BlackfishIDatabaseImpl | This is class Eco.Persistence.Blackfish.BlackfishIDatabaseImpl.
BooleanAsBoolean | This is class Eco.Persistence.Blackfish.BooleanAsBoolean.
ByteArrayAsBdpVarBinary | This is class Eco.Persistence.Blackfish.ByteArrayAsBdpVarBinary.
ByteArrayAsVarBinary | This is class Eco.Persistence.Blackfish.ByteArrayAsVarBinary.
CharAsVarChar1 | This is class Eco.Persistence.Blackfish.CharAsVarChar1.
GenericByteArrayAsVarBinary | This is class Eco.Persistence.Blackfish.GenericByteArrayAsVarBinary.
Int32AsAutoInc | This is class Eco.Persistence.Blackfish.Int32AsAutoInc.
Int64AsBigInt | This is class Eco.Persistence.Blackfish.Int64AsBigInt.
SingleAsFloat | This is class Eco.Persistence.Blackfish.SingleAsFloat.
StringAsText | This is class Eco.Persistence.Blackfish.StringAsText.


BlackfishIDatabaseImpl Class

BlackfishIDatabaseImpl Class
Inheritance Hierarchy See Also
Collapse All
C#
public sealed class BlackfishIDatabaseImpl : Ado2IDatabaseImpl;
Remarks

This is class Eco.Persistence.Blackfish.BlackfishIDatabaseImpl.

Inheritance Hierarchy
Eco.Persistence.Blackfish.BlackfishIDatabaseImpl
File

NDataStoreDatabaseImpl.cs

See Also
Inheritance Hierarchy


BlackfishIDatabaseImpl.BlackfishIDatabaseImpl Constructor

BlackfishIDatabaseImpl.BlackfishIDatabaseImpl Constructor
BlackfishIDatabaseImpl Class Eco.Persistence.Blackfish Namespace See Also
Collapse All
C#
public BlackfishIDatabaseImpl(
    DbConnection connection,
    SqlDatabaseConfig config
);
Remarks

This is BlackfishIDatabaseImpl, a member of class BlackfishIDatabaseImpl.

See Also
BlackfishIDatabaseImpl Class
Eco.Persistence.Blackfish Namespace


BlackfishIDatabaseImpl Methods

BlackfishIDatabaseImpl Methods
Protected Methods Public Methods
Collapse All

The methods of the BlackfishIDatabaseImpl class are listed here.

Protected Methods
Name | Description
HandleCommandParameters | This is HandleCommandParameters, a member of class BlackfishIDatabaseImpl.
Top
Public Methods
Name | Description
AllTableNames | This is AllTableNames, a member of class BlackfishIDatabaseImpl.
GetIndexDefsForTable | This is GetIndexDefsForTable, a member of class BlackfishIDatabaseImpl.


BlackfishIDatabaseImpl.AllTableNames Method

BlackfishIDatabaseImpl.AllTableNames Method
BlackfishIDatabaseImpl Class Eco.Persistence.Blackfish Namespace See Also
Collapse All
C#
public override IList<string> AllTableNames(
    string pattern
);
Remarks

This is AllTableNames, a member of class BlackfishIDatabaseImpl.

See Also
BlackfishIDatabaseImpl Class
Eco.Persistence.Blackfish Namespace


BlackfishIDatabaseImpl.GetIndexDefsForTable Method

BlackfishIDatabaseImpl.GetIndexDefsForTable Method
BlackfishIDatabaseImpl Class Eco.Persistence.Blackfish Namespace See Also
Collapse All
C#
public override DataTable GetIndexDefsForTable(
    string tableName
);
Remarks

This is GetIndexDefsForTable, a member of class BlackfishIDatabaseImpl.

See Also
BlackfishIDatabaseImpl Class
Eco.Persistence.Blackfish Namespace


BlackfishIDatabaseImpl.HandleCommandParameters Method

BlackfishIDatabaseImpl.HandleCommandParameters Method
BlackfishIDatabaseImpl Class Eco.Persistence.Blackfish Namespace See Also
Collapse All
C#
protected override string HandleCommandParameters(
    string commandText,
    IDataParameterCollection parameters
);
Remarks

This is HandleCommandParameters, a member of class BlackfishIDatabaseImpl.

See Also
BlackfishIDatabaseImpl Class
Eco.Persistence.Blackfish Namespace


BlackfishIDatabaseImpl Properties

BlackfishIDatabaseImpl Properties
Public Properties
Collapse All

The properties of the BlackfishIDatabaseImpl class are listed here.

Public Properties
Name | Description
AlwaysReadInTransactions | This is AlwaysReadInTransactions, a member of class BlackfishIDatabaseImpl.


BlackfishIDatabaseImpl.AlwaysReadInTransactions Property

BlackfishIDatabaseImpl.AlwaysReadInTransactions Property
BlackfishIDatabaseImpl Class Eco.Persistence.Blackfish Namespace See Also
Collapse All
C#
public override bool AlwaysReadInTransactions;
Remarks

This is AlwaysReadInTransactions, a member of class BlackfishIDatabaseImpl.

See Also
BlackfishIDatabaseImpl Class
Eco.Persistence.Blackfish Namespace


BooleanAsBoolean Class

BooleanAsBoolean Class
Inheritance Hierarchy See Also
Collapse All
C#
public sealed class BooleanAsBoolean : AbstractSingleColumnAttribute, ISingleColumnAttributemapping, IDefaultReverseMapping;
Remarks

This is class Eco.Persistence.Blackfish.BooleanAsBoolean.

Inheritance Hierarchy
Eco.Persistence.IDefaultReverseMapping
Eco.Persistence.ISingleColumnAttributemapping
    Eco.Persistence.Blackfish.BooleanAsBoolean
File

NDataStoreAttributeMappersCommon.cs

See Also
Inheritance Hierarchy


BooleanAsBoolean Methods

BooleanAsBoolean Methods
Public Methods
Collapse All

The methods of the BooleanAsBoolean class are listed here.

Public Methods
Name | Description
ColumnToValue | Converts a value that comes from a database query to an ecospace value.
ColumnType | Specifies the SQL type of the column.
DefaultDbValue | The return value of this function will be used as default value for new columns when databases are created/evolved.
StringToParameter | This is StringToParameter, a member of class BooleanAsBoolean.
ValueToParameter | Converts a value that comes from a database query to an ecospace value.
ValueType | This method returns the type of the value that is returned by ColumnToValue.


BooleanAsBoolean.ColumnToValue Method

BooleanAsBoolean.ColumnToValue Method
BooleanAsBoolean Class Eco.Persistence.Blackfish Namespace See Also
Collapse All

Converts a value that comes from a database query to an ecospace value.

C#
public override System.Object ColumnToValue(
    System.Object columnValue
);
Remarks

In many cases, the implementation of this method mainly converts DBNull-values to null, but it can also change the CLR-type of the database value from for example a char[] to a string. or from an integer to a boolean. This is the reverse operation of ValueToParameter.

See Also
BooleanAsBoolean Class
Eco.Persistence.Blackfish Namespace


BooleanAsBoolean.ColumnType Method

BooleanAsBoolean.ColumnType Method
BooleanAsBoolean Class Eco.Persistence.Blackfish Namespace See Also
Collapse All

Specifies the SQL type of the column.

C#
public String ColumnType(
    int length
);
See Also
BooleanAsBoolean Class
Eco.Persistence.Blackfish Namespace


BooleanAsBoolean.DefaultDbValue Method

BooleanAsBoolean.DefaultDbValue Method
BooleanAsBoolean Class Eco.Persistence.Blackfish Namespace See Also
Collapse All

The return value of this function will be used as default value for new columns when databases are created/evolved.

C#
public String DefaultDbValue(
    string modeledValue,
    SqlDatabaseConfig sqlDatabaseConfig
);
See Also
BooleanAsBoolean Class
Eco.Persistence.Blackfish Namespace


BooleanAsBoolean.StringToParameter Method

BooleanAsBoolean.StringToParameter Method
BooleanAsBoolean Class Eco.Persistence.Blackfish Namespace See Also
Collapse All
C#
public void StringToParameter(
    string value,
    IDataParameter parameter
);
Remarks

This is StringToParameter, a member of class BooleanAsBoolean.

See Also
BooleanAsBoolean Class
Eco.Persistence.Blackfish Namespace


BooleanAsBoolean.ValueToParameter Method

BooleanAsBoolean.ValueToParameter Method
BooleanAsBoolean Class Eco.Persistence.Blackfish Namespace See Also
Collapse All

Converts a value that comes from a database query to an ecospace value.

C#
public void ValueToParameter(
    System.Object value,
    IDataParameter parameter
);
Remarks

In many cases, the implementation of this method mainly converts null to DBNull, but it can also handle conversion from for example booleans to integers, byte[] to database blobs. It also has to set the correct parameter types in the IDataParameter-object. This is the reverse operation of ColumnToValue.

See Also
BooleanAsBoolean Class
Eco.Persistence.Blackfish Namespace


BooleanAsBoolean.ValueType Method

BooleanAsBoolean.ValueType Method
BooleanAsBoolean Class Eco.Persistence.Blackfish Namespace See Also
Collapse All

This method returns the type of the value that is returned by ColumnToValue.

C#
public System.Type ValueType();
See Also
BooleanAsBoolean Class
Eco.Persistence.Blackfish Namespace


ByteArrayAsBdpVarBinary Class

ByteArrayAsBdpVarBinary Class
Inheritance Hierarchy See Also
Collapse All
C#
public sealed class ByteArrayAsBdpVarBinary : GenericByteArrayAsVarBinary, ISingleColumnAttributemapping;
Remarks

This is class Eco.Persistence.Blackfish.ByteArrayAsBdpVarBinary.

Inheritance Hierarchy
Eco.Persistence.Blackfish.GenericByteArrayAsVarBinary
Eco.Persistence.ISingleColumnAttributemapping
    Eco.Persistence.Blackfish.ByteArrayAsBdpVarBinary
File

NDataStoreAttributeMappersBdp.cs

See Also
Inheritance Hierarchy


ByteArrayAsBdpVarBinary Methods

ByteArrayAsBdpVarBinary Methods
Public Methods
Collapse All

The methods of the ByteArrayAsBdpVarBinary class are listed here.

Public Methods
Name | Description
ValueToParameter | This is ValueToParameter, a member of class ByteArrayAsBdpVarBinary.
ValueType | This method returns the type of the value that is returned by ColumnToValue.


ByteArrayAsBdpVarBinary.ValueToParameter Method

ByteArrayAsBdpVarBinary.ValueToParameter Method
ByteArrayAsBdpVarBinary Class Eco.Persistence.Blackfish Namespace See Also
Collapse All
C#
public void ValueToParameter(
    object value,
    IDataParameter parameter
);
Remarks

This is ValueToParameter, a member of class ByteArrayAsBdpVarBinary.

See Also
ByteArrayAsBdpVarBinary Class
Eco.Persistence.Blackfish Namespace


ByteArrayAsBdpVarBinary.ValueType Method

ByteArrayAsBdpVarBinary.ValueType Method
ByteArrayAsBdpVarBinary Class Eco.Persistence.Blackfish Namespace See Also
Collapse All

This method returns the type of the value that is returned by ColumnToValue.

C#
public System.Type ValueType();
See Also
ByteArrayAsBdpVarBinary Class
Eco.Persistence.Blackfish Namespace


ByteArrayAsVarBinary Class

ByteArrayAsVarBinary Class
Inheritance Hierarchy See Also
Collapse All
C#
public sealed class ByteArrayAsVarBinary : GenericByteArrayAsVarBinary, ISingleColumnAttributemapping;
Remarks

This is class Eco.Persistence.Blackfish.ByteArrayAsVarBinary.

Inheritance Hierarchy
Eco.Persistence.Blackfish.GenericByteArrayAsVarBinary
Eco.Persistence.ISingleColumnAttributemapping
    Eco.Persistence.Blackfish.ByteArrayAsVarBinary
File

NDataStoreAttributeMappers.cs

See Also
Inheritance Hierarchy


ByteArrayAsVarBinary Methods

ByteArrayAsVarBinary Methods
Public Methods
Collapse All

The methods of the ByteArrayAsVarBinary class are listed here.

Public Methods
Name | Description
ValueToParameter | This is ValueToParameter, a member of class ByteArrayAsVarBinary.
ValueType | This method returns the type of the value that is returned by ColumnToValue.


ByteArrayAsVarBinary.ValueToParameter Method

ByteArrayAsVarBinary.ValueToParameter Method
ByteArrayAsVarBinary Class Eco.Persistence.Blackfish Namespace See Also
Collapse All
C#
public void ValueToParameter(
    object value,
    IDataParameter parameter
);
Remarks

This is ValueToParameter, a member of class ByteArrayAsVarBinary.

See Also
ByteArrayAsVarBinary Class
Eco.Persistence.Blackfish Namespace


ByteArrayAsVarBinary.ValueType Method

ByteArrayAsVarBinary.ValueType Method
ByteArrayAsVarBinary Class Eco.Persistence.Blackfish Namespace See Also
Collapse All

This method returns the type of the value that is returned by ColumnToValue.

C#
public System.Type ValueType();
See Also
ByteArrayAsVarBinary Class
Eco.Persistence.Blackfish Namespace


CharAsVarChar1 Class

CharAsVarChar1 Class
Inheritance Hierarchy See Also
Collapse All
C#
public sealed class CharAsVarChar1 : AbstractStringSingleColumnAttribute, ISingleColumnAttributemapping;
Remarks

This is class Eco.Persistence.Blackfish.CharAsVarChar1.

Inheritance Hierarchy
Eco.Persistence.ISingleColumnAttributemapping
    Eco.Persistence.Blackfish.CharAsVarChar1
File

NDataStoreAttributeMappers.cs

See Also
Inheritance Hierarchy


CharAsVarChar1 Methods

CharAsVarChar1 Methods
Public Methods
Collapse All

The methods of the CharAsVarChar1 class are listed here.

Public Methods
Name | Description
ColumnToValue | Converts a value that comes from a database query to an ecospace value.
ColumnType | Specifies the SQL type of the column.
StringToParameter | This is StringToParameter, a member of class CharAsVarChar1.
ValueToParameter | Converts a value that comes from a database query to an ecospace value.
ValueType | This method returns the type of the value that is returned by ColumnToValue.


CharAsVarChar1.ColumnToValue Method

CharAsVarChar1.ColumnToValue Method
CharAsVarChar1 Class Eco.Persistence.Blackfish Namespace See Also
Collapse All

Converts a value that comes from a database query to an ecospace value.

C#
public override System.Object ColumnToValue(
    System.Object columnValue
);
Remarks

In many cases, the implementation of this method mainly converts DBNull-values to null, but it can also change the CLR-type of the database value from for example a char[] to a string. or from an integer to a boolean. This is the reverse operation of ValueToParameter.

See Also
CharAsVarChar1 Class
Eco.Persistence.Blackfish Namespace


CharAsVarChar1.ColumnType Method

CharAsVarChar1.ColumnType Method
CharAsVarChar1 Class Eco.Persistence.Blackfish Namespace See Also
Collapse All

Specifies the SQL type of the column.

C#
public String ColumnType(
    int length
);
See Also
CharAsVarChar1 Class
Eco.Persistence.Blackfish Namespace


CharAsVarChar1.StringToParameter Method

CharAsVarChar1.StringToParameter Method
CharAsVarChar1 Class Eco.Persistence.Blackfish Namespace See Also
Collapse All
C#
public void StringToParameter(
    string value,
    IDataParameter parameter
);
Remarks

This is StringToParameter, a member of class CharAsVarChar1.

See Also
CharAsVarChar1 Class
Eco.Persistence.Blackfish Namespace


CharAsVarChar1.ValueToParameter Method

CharAsVarChar1.ValueToParameter Method
CharAsVarChar1 Class Eco.Persistence.Blackfish Namespace See Also
Collapse All

Converts a value that comes from a database query to an ecospace value.

C#
public void ValueToParameter(
    System.Object value,
    IDataParameter parameter
);
Remarks

In many cases, the implementation of this method mainly converts null to DBNull, but it can also handle conversion from for example booleans to integers, byte[] to database blobs. It also has to set the correct parameter types in the IDataParameter-object. This is the reverse operation of ColumnToValue.

See Also
CharAsVarChar1 Class
Eco.Persistence.Blackfish Namespace


CharAsVarChar1.ValueType Method

CharAsVarChar1.ValueType Method
CharAsVarChar1 Class Eco.Persistence.Blackfish Namespace See Also
Collapse All

This method returns the type of the value that is returned by ColumnToValue.

C#
public System.Type ValueType();
See Also
CharAsVarChar1 Class
Eco.Persistence.Blackfish Namespace


GenericByteArrayAsVarBinary Class

GenericByteArrayAsVarBinary Class
Inheritance Hierarchy See Also
Collapse All
C#
public class GenericByteArrayAsVarBinary : AbstractSingleColumnAttribute;
Remarks

This is class Eco.Persistence.Blackfish.GenericByteArrayAsVarBinary.

Inheritance Hierarchy
Eco.Persistence.Blackfish.GenericByteArrayAsVarBinary
    Eco.Persistence.Blackfish.ByteArrayAsBdpVarBinary
    Eco.Persistence.Blackfish.ByteArrayAsVarBinary
File

NDataStoreAttributeMappersCommon.cs

See Also
Inheritance Hierarchy


GenericByteArrayAsVarBinary.GenericByteArrayAsVarBinary Constructor

GenericByteArrayAsVarBinary.GenericByteArrayAsVarBinary Constructor
GenericByteArrayAsVarBinary Class Eco.Persistence.Blackfish Namespace See Also
Collapse All
C#
public GenericByteArrayAsVarBinary();
Remarks

This is GenericByteArrayAsVarBinary, a member of class GenericByteArrayAsVarBinary.

See Also
GenericByteArrayAsVarBinary Class
Eco.Persistence.Blackfish Namespace


GenericByteArrayAsVarBinary Methods

GenericByteArrayAsVarBinary Methods
Public Methods
Collapse All

The methods of the GenericByteArrayAsVarBinary class are listed here.

Public Methods
Name | Description
ColumnToValue | This is ColumnToValue, a member of class GenericByteArrayAsVarBinary.
ColumnType | This is ColumnType, a member of class GenericByteArrayAsVarBinary.
DefaultDbValue | This is DefaultDbValue, a member of class GenericByteArrayAsVarBinary.
IsEqual | This is IsEqual, a member of class GenericByteArrayAsVarBinary.
StringToParameter |


GenericByteArrayAsVarBinary.ColumnToValue Method

GenericByteArrayAsVarBinary.ColumnToValue Method
GenericByteArrayAsVarBinary Class Eco.Persistence.Blackfish Namespace See Also
Collapse All
C#
public override object ColumnToValue(
    object columnValue
);
Remarks

This is ColumnToValue, a member of class GenericByteArrayAsVarBinary.

See Also
GenericByteArrayAsVarBinary Class
Eco.Persistence.Blackfish Namespace


GenericByteArrayAsVarBinary.ColumnType Method

GenericByteArrayAsVarBinary.ColumnType Method
GenericByteArrayAsVarBinary Class Eco.Persistence.Blackfish Namespace See Also
Collapse All
C#
public string ColumnType(
    int length
);
Remarks

This is ColumnType, a member of class GenericByteArrayAsVarBinary.

See Also
GenericByteArrayAsVarBinary Class
Eco.Persistence.Blackfish Namespace


GenericByteArrayAsVarBinary.DefaultDbValue Method

GenericByteArrayAsVarBinary.DefaultDbValue Method
GenericByteArrayAsVarBinary Class Eco.Persistence.Blackfish Namespace See Also
Collapse All
C#
public string DefaultDbValue(
    string modeledValue,
    SqlDatabaseConfig sqlDatabaseConfig
);
Remarks

This is DefaultDbValue, a member of class GenericByteArrayAsVarBinary.

See Also
GenericByteArrayAsVarBinary Class
Eco.Persistence.Blackfish Namespace


GenericByteArrayAsVarBinary.IsEqual Method

GenericByteArrayAsVarBinary.IsEqual Method
GenericByteArrayAsVarBinary Class Eco.Persistence.Blackfish Namespace See Also
Collapse All
C#
public override bool IsEqual(
    System.Object value,
    System.Object columnValue
);
Remarks

This is IsEqual, a member of class GenericByteArrayAsVarBinary.

See Also
GenericByteArrayAsVarBinary Class
Eco.Persistence.Blackfish Namespace


GenericByteArrayAsVarBinary.StringToParameter Method

GenericByteArrayAsVarBinary.StringToParameter Method
GenericByteArrayAsVarBinary Class Eco.Persistence.Blackfish Namespace See Also
Collapse All
C#
public void StringToParameter(
    string value,
    IDataParameter parameter
);
Exceptions
Exceptions | Description
InvalidOperationException | Thrown always.
See Also
GenericByteArrayAsVarBinary Class
Eco.Persistence.Blackfish Namespace


Int32AsAutoInc Class

Int32AsAutoInc Class
Inheritance Hierarchy See Also
Collapse All
C#
public sealed class Int32AsAutoInc : AbstractNumericSingleColumnAttribute, IAutoIncAttributemapping, IDefaultReverseMapping;
Remarks

This is class Eco.Persistence.Blackfish.Int32AsAutoInc.

Inheritance Hierarchy
Eco.Persistence.ISingleColumnAttributemapping
    Eco.Persistence.IAutoIncAttributemapping
    Eco.Persistence.IDefaultReverseMapping
        Eco.Persistence.Blackfish.Int32AsAutoInc
File

NDataStoreAttributeMappersCommon.cs

See Also
Inheritance Hierarchy


Int32AsAutoInc Methods

Int32AsAutoInc Methods
Public Methods
Collapse All

The methods of the Int32AsAutoInc class are listed here.

Public Methods
Name | Description
ColumnToValue | Converts a value that comes from a database query to an ecospace value.
ColumnType | Specifies the SQL type of the column.
DefaultDbValue | The return value of this function will be used as default value for new columns when databases are created/evolved.
MakeColumnAutoInc | If the database requires any additional operations in addition to the column type to give a column "autoinc" behaviour, that should be performed by this method.
StringToParameter | This method should never be called. Autoinc values are never stored!
ValueToParameter | This method should never be called. Autoinc values are never stored!
ValueType | This method returns the type of the value that is returned by ColumnToValue.


Int32AsAutoInc.ColumnToValue Method

Int32AsAutoInc.ColumnToValue Method
Int32AsAutoInc Class Eco.Persistence.Blackfish Namespace See Also
Collapse All

Converts a value that comes from a database query to an ecospace value.

C#
public override System.Object ColumnToValue(
    System.Object columnValue
);
Remarks

In many cases, the implementation of this method mainly converts DBNull-values to null, but it can also change the CLR-type of the database value from for example a char[] to a string. or from an integer to a boolean. This is the reverse operation of ValueToParameter.

See Also
Int32AsAutoInc Class
Eco.Persistence.Blackfish Namespace


Int32AsAutoInc.ColumnType Method

Int32AsAutoInc.ColumnType Method
Int32AsAutoInc Class Eco.Persistence.Blackfish Namespace See Also
Collapse All

Specifies the SQL type of the column.

C#
public String ColumnType(
    int length
);
See Also
Int32AsAutoInc Class
Eco.Persistence.Blackfish Namespace


Int32AsAutoInc.DefaultDbValue Method

Int32AsAutoInc.DefaultDbValue Method
Int32AsAutoInc Class Eco.Persistence.Blackfish Namespace See Also
Collapse All

The return value of this function will be used as default value for new columns when databases are created/evolved.

C#
public override String DefaultDbValue(
    string modeledValue,
    SqlDatabaseConfig sqlDatabaseConfig
);
See Also
Int32AsAutoInc Class
Eco.Persistence.Blackfish Namespace


Int32AsAutoInc.MakeColumnAutoInc Method

Int32AsAutoInc.MakeColumnAutoInc Method
Int32AsAutoInc Class Eco.Persistence.Blackfish Namespace See Also
Collapse All

If the database requires any additional operations in addition to the column type to give a column "autoinc" behaviour, that should be performed by this method.

C#
public void MakeColumnAutoInc(
    string tableName,
    string columnName,
    IDatabase database
);
Remarks

Even if the database does not require any additional operations, this interface should be implemented by an autoinc attribute mapper, and the implementation of this method should be left blank.

See Also
Int32AsAutoInc Class
Eco.Persistence.Blackfish Namespace


Int32AsAutoInc.StringToParameter Method

Int32AsAutoInc.StringToParameter Method
Int32AsAutoInc Class Eco.Persistence.Blackfish Namespace See Also
Collapse All

This method should never be called. Autoinc values are never stored!

C#
public void StringToParameter(
    string value,
    IDataParameter parameter
);
Exceptions
Exceptions | Description
NotSupportedException | Thrown always.
See Also
Int32AsAutoInc Class
Eco.Persistence.Blackfish Namespace


Int32AsAutoInc.ValueToParameter Method

Int32AsAutoInc.ValueToParameter Method
Int32AsAutoInc Class Eco.Persistence.Blackfish Namespace See Also
Collapse All

This method should never be called. Autoinc values are never stored!

C#
public void ValueToParameter(
    System.Object value,
    IDataParameter parameter
);
Exceptions
Exceptions | Description
NotSupportedException | Thrown always.
See Also
Int32AsAutoInc Class
Eco.Persistence.Blackfish Namespace


Int32AsAutoInc.ValueType Method

Int32AsAutoInc.ValueType Method
Int32AsAutoInc Class Eco.Persistence.Blackfish Namespace See Also
Collapse All

This method returns the type of the value that is returned by ColumnToValue.

C#
public System.Type ValueType();
See Also
Int32AsAutoInc Class
Eco.Persistence.Blackfish Namespace


Int64AsBigInt Class

Int64AsBigInt Class
Inheritance Hierarchy See Also
Collapse All
C#
public sealed class Int64AsBigInt : AbstractNumericSingleColumnAttribute, ISingleColumnAttributemapping, IDefaultReverseMapping;
Remarks

This is class Eco.Persistence.Blackfish.Int64AsBigInt.

Inheritance Hierarchy
Eco.Persistence.IDefaultReverseMapping
Eco.Persistence.ISingleColumnAttributemapping
    Eco.Persistence.Blackfish.Int64AsBigInt
File

NDataStoreAttributeMappersCommon.cs

See Also
Inheritance Hierarchy


Int64AsBigInt Methods

Int64AsBigInt Methods
Public Methods
Collapse All

The methods of the Int64AsBigInt class are listed here.

Public Methods
Name | Description
ColumnToValue | Converts a value that comes from a database query to an ecospace value.
ColumnType | Specifies the SQL type of the column.
StringToParameter | This is StringToParameter, a member of class Int64AsBigInt.
ValueToParameter | Converts a value that comes from a database query to an ecospace value.
ValueType | This method returns the type of the value that is returned by ColumnToValue.


Int64AsBigInt.ColumnToValue Method

Int64AsBigInt.ColumnToValue Method
Int64AsBigInt Class Eco.Persistence.Blackfish Namespace See Also
Collapse All

Converts a value that comes from a database query to an ecospace value.

C#
public override System.Object ColumnToValue(
    System.Object columnValue
);
Remarks

In many cases, the implementation of this method mainly converts DBNull-values to null, but it can also change the CLR-type of the database value from for example a char[] to a string. or from an integer to a boolean. This is the reverse operation of ValueToParameter.

See Also
Int64AsBigInt Class
Eco.Persistence.Blackfish Namespace


Int64AsBigInt.ColumnType Method

Int64AsBigInt.ColumnType Method
Int64AsBigInt Class Eco.Persistence.Blackfish Namespace See Also
Collapse All

Specifies the SQL type of the column.

C#
public String ColumnType(
    int length
);
See Also
Int64AsBigInt Class
Eco.Persistence.Blackfish Namespace


Int64AsBigInt.StringToParameter Method

Int64AsBigInt.StringToParameter Method
Int64AsBigInt Class Eco.Persistence.Blackfish Namespace See Also
Collapse All
C#
public void StringToParameter(
    string value,
    IDataParameter parameter
);
Remarks

This is StringToParameter, a member of class Int64AsBigInt.

See Also
Int64AsBigInt Class
Eco.Persistence.Blackfish Namespace


Int64AsBigInt.ValueToParameter Method

Int64AsBigInt.ValueToParameter Method
Int64AsBigInt Class Eco.Persistence.Blackfish Namespace See Also
Collapse All

Converts a value that comes from a database query to an ecospace value.

C#
public void ValueToParameter(
    System.Object value,
    IDataParameter parameter
);
Remarks

In many cases, the implementation of this method mainly converts null to DBNull, but it can also handle conversion from for example booleans to integers, byte[] to database blobs. It also has to set the correct parameter types in the IDataParameter-object. This is the reverse operation of ColumnToValue.

See Also
Int64AsBigInt Class
Eco.Persistence.Blackfish Namespace


Int64AsBigInt.ValueType Method

Int64AsBigInt.ValueType Method
Int64AsBigInt Class Eco.Persistence.Blackfish Namespace See Also
Collapse All

This method returns the type of the value that is returned by ColumnToValue.

C#
public System.Type ValueType();
See Also
Int64AsBigInt Class
Eco.Persistence.Blackfish Namespace


SingleAsFloat Class

SingleAsFloat Class
Inheritance Hierarchy See Also
Collapse All
C#
public sealed class SingleAsFloat : AbstractNumericSingleColumnAttribute, ISingleColumnAttributemapping, IDefaultReverseMapping;
Remarks

This is class Eco.Persistence.Blackfish.SingleAsFloat.

Inheritance Hierarchy
Eco.Persistence.IDefaultReverseMapping
Eco.Persistence.ISingleColumnAttributemapping
    Eco.Persistence.Blackfish.SingleAsFloat
File

NDataStoreAttributeMappersCommon.cs

See Also
Inheritance Hierarchy


SingleAsFloat Methods

SingleAsFloat Methods
Public Methods
Collapse All

The methods of the SingleAsFloat class are listed here.

Public Methods
Name | Description
ColumnToValue | Converts a value that comes from a database query to an ecospace value.
ColumnType | Specifies the SQL type of the column.
StringToParameter | This is StringToParameter, a member of class SingleAsFloat.
ValueToParameter | Converts a value that comes from a database query to an ecospace value.
ValueType | This method returns the type of the value that is returned by ColumnToValue.


SingleAsFloat.ColumnToValue Method

SingleAsFloat.ColumnToValue Method
SingleAsFloat Class Eco.Persistence.Blackfish Namespace See Also
Collapse All

Converts a value that comes from a database query to an ecospace value.

C#
public override System.Object ColumnToValue(
    System.Object columnValue
);
Remarks

In many cases, the implementation of this method mainly converts DBNull-values to null, but it can also change the CLR-type of the database value from for example a char[] to a string. or from an integer to a boolean. This is the reverse operation of ValueToParameter.

See Also
SingleAsFloat Class
Eco.Persistence.Blackfish Namespace


SingleAsFloat.ColumnType Method

SingleAsFloat.ColumnType Method
SingleAsFloat Class Eco.Persistence.Blackfish Namespace See Also
Collapse All

Specifies the SQL type of the column.

C#
public String ColumnType(
    int length
);
See Also
SingleAsFloat Class
Eco.Persistence.Blackfish Namespace


SingleAsFloat.StringToParameter Method

SingleAsFloat.StringToParameter Method
SingleAsFloat Class Eco.Persistence.Blackfish Namespace See Also
Collapse All
C#
public void StringToParameter(
    string value,
    IDataParameter parameter
);
Remarks

This is StringToParameter, a member of class SingleAsFloat.

See Also
SingleAsFloat Class
Eco.Persistence.Blackfish Namespace


SingleAsFloat.ValueToParameter Method

SingleAsFloat.ValueToParameter Method
SingleAsFloat Class Eco.Persistence.Blackfish Namespace See Also
Collapse All

Converts a value that comes from a database query to an ecospace value.

C#
public void ValueToParameter(
    System.Object value,
    IDataParameter parameter
);
Remarks

In many cases, the implementation of this method mainly converts null to DBNull, but it can also handle conversion from for example booleans to integers, byte[] to database blobs. It also has to set the correct parameter types in the IDataParameter-object. This is the reverse operation of ColumnToValue.

See Also
SingleAsFloat Class
Eco.Persistence.Blackfish Namespace


SingleAsFloat.ValueType Method

SingleAsFloat.ValueType Method
SingleAsFloat Class Eco.Persistence.Blackfish Namespace See Also
Collapse All

This method returns the type of the value that is returned by ColumnToValue.

C#
public System.Type ValueType();
See Also
SingleAsFloat Class
Eco.Persistence.Blackfish Namespace


StringAsText Class

StringAsText Class
Inheritance Hierarchy See Also
Collapse All
C#
public sealed class StringAsText : AbstractStringSingleColumnAttribute, ISingleColumnAttributemapping;
Remarks

This is class Eco.Persistence.Blackfish.StringAsText.

Inheritance Hierarchy
Eco.Persistence.ISingleColumnAttributemapping
    Eco.Persistence.Blackfish.StringAsText
File

NDataStoreAttributeMappers.cs

See Also
Inheritance Hierarchy


StringAsText Methods

StringAsText Methods
Public Methods
Collapse All

The methods of the StringAsText class are listed here.

Public Methods
Name | Description
ColumnToValue | Converts a value that comes from a database query to an ecospace value.
ColumnType | Specifies the SQL type of the column.
StringToParameter | This is StringToParameter, a member of class StringAsText.
ValueToParameter | Converts a value that comes from a database query to an ecospace value.
ValueType | This method returns the type of the value that is returned by ColumnToValue.


StringAsText.ColumnToValue Method

StringAsText.ColumnToValue Method
StringAsText Class Eco.Persistence.Blackfish Namespace See Also
Collapse All

Converts a value that comes from a database query to an ecospace value.

C#
public override System.Object ColumnToValue(
    System.Object columnValue
);
Remarks

In many cases, the implementation of this method mainly converts DBNull-values to null, but it can also change the CLR-type of the database value from for example a char[] to a string. or from an integer to a boolean. This is the reverse operation of ValueToParameter.

See Also
StringAsText Class
Eco.Persistence.Blackfish Namespace


StringAsText.ColumnType Method

StringAsText.ColumnType Method
StringAsText Class Eco.Persistence.Blackfish Namespace See Also
Collapse All

Specifies the SQL type of the column.

C#
public string ColumnType(
    int length
);
See Also
StringAsText Class
Eco.Persistence.Blackfish Namespace


StringAsText.StringToParameter Method

StringAsText.StringToParameter Method
StringAsText Class Eco.Persistence.Blackfish Namespace See Also
Collapse All
C#
public void StringToParameter(
    string value,
    IDataParameter parameter
);
Remarks

This is StringToParameter, a member of class StringAsText.

See Also
StringAsText Class
Eco.Persistence.Blackfish Namespace


StringAsText.ValueToParameter Method

StringAsText.ValueToParameter Method
StringAsText Class Eco.Persistence.Blackfish Namespace See Also
Collapse All

Converts a value that comes from a database query to an ecospace value.

C#
public void ValueToParameter(
    System.Object value,
    IDataParameter parameter
);
Remarks

In many cases, the implementation of this method mainly converts null to DBNull, but it can also handle conversion from for example booleans to integers, byte[] to database blobs. It also has to set the correct parameter types in the IDataParameter-object. This is the reverse operation of ColumnToValue.

See Also
StringAsText Class
Eco.Persistence.Blackfish Namespace


StringAsText.ValueType Method

StringAsText.ValueType Method
StringAsText Class Eco.Persistence.Blackfish Namespace See Also
Collapse All

This method returns the type of the value that is returned by ColumnToValue.

C#
public System.Type ValueType();
See Also
StringAsText Class
Eco.Persistence.Blackfish Namespace


Eco.Persistence.Configuration Namespace

Eco.Persistence.Configuration Namespace
Classes Enumerations
Collapse All

using Eco.UmlRt.Impl;

Classes
Name | Description
DatabaseEngineInitializer | Primarily intended for use by designers.
IdMapperDefinition | This is class Eco.Persistence.Configuration.IdMapperDefinition.
KeyMapperDefinition | This is class Eco.Persistence.Configuration.KeyMapperDefinition.
KeyMapperDefinitionCollection | Holds a collection of KeyMapperDefinition. Duplicates are avoided by means of the KeyMapperDefinition.Name property. It is used by SqlDatabaseConfig.
KeyMapperDefinitionConverter | IdMapper definitions
MapperDefinition | This class contains a mapper type, it's logical name and a bit-mapped field indicating which DataBaseEngine should use this mapper.
PersistenceMapperDefinition | This is class Eco.Persistence.Configuration.PersistenceMapperDefinition.
PersistenceMapperDefinitionCollection | This is class Eco.Persistence.Configuration.PersistenceMapperDefinitionCollection.
PersistenceMapperDictionary | This is class Eco.Persistence.Configuration.PersistenceMapperDictionary.
PMapperDefinitionConverter | This is class Eco.Persistence.Configuration.PMapperDefinitionConverter.
SqlDatabaseConfig | This is class Eco.Persistence.Configuration.SqlDatabaseConfig.
SqlDatabaseConfigConverter | This is class Eco.Persistence.Configuration.SqlDatabaseConfigConverter.
StringLiterals | This is class Eco.Persistence.Configuration.StringLiterals.
Top
Enumerations
Name | Description
DataBaseEngine | Enumeration passed to DatabaseEngineInitializer.InitializeDbEngineSettings to quickly set the correct properties for an engine.
IdentifierCharacterMode | This is record Eco.Persistence.Configuration.IdentifierCharacterMode.


DatabaseEngineInitializer Class

DatabaseEngineInitializer Class
Inheritance Hierarchy See Also
Collapse All

Primarily intended for use by designers.

C#
public sealed class DatabaseEngineInitializer;
Remarks

Can also be used to switch database engine in run time.

Inheritance Hierarchy
Eco.Persistence.Configuration.DatabaseEngineInitializer
File

InitializeEngine.cs

See Also
Inheritance Hierarchy


DatabaseEngineInitializer Fields

DatabaseEngineInitializer Fields
Public Fields
Collapse All

The fields of the DatabaseEngineInitializer class are listed here.

Public Fields
Name | Description
allEngines | This is allEngines, a member of class DatabaseEngineInitializer.
allInterbaseDialect3 | This is allInterbaseDialect3, a member of class DatabaseEngineInitializer.
blackfish | This is blackfish, a member of class DatabaseEngineInitializer.
db2 | This is db2, a member of class DatabaseEngineInitializer.
genericMbcs | This is genericMbcs, a member of class DatabaseEngineInitializer.
interbaseDialect3 | This is interbaseDialect3, a member of class DatabaseEngineInitializer.
interbaseDialect3Dbx | This is interbaseDialect3Dbx, a member of class DatabaseEngineInitializer.
microsoftEngines | This is microsoftEngines, a member of class DatabaseEngineInitializer.
msAccess | This is msAccess, a member of class DatabaseEngineInitializer.
mysql | This is mysql, a member of class DatabaseEngineInitializer.
mysql4 | This is mysql4, a member of class DatabaseEngineInitializer.
mysql5 | This is mysql5, a member of class DatabaseEngineInitializer.
mysqlBdp | This is mysqlBdp, a member of class DatabaseEngineInitializer.
mysqlDbx | This is mysqlDbx, a member of class DatabaseEngineInitializer.
mysqlMys | This is mysqlMys, a member of class DatabaseEngineInitializer.
oracle | This is oracle, a member of class DatabaseEngineInitializer.
oracleBdp | This is oracleBdp, a member of class DatabaseEngineInitializer.
oracleDbx | This is oracleDbx, a member of class DatabaseEngineInitializer.
sqlServer | This is sqlServer, a member of class DatabaseEngineInitializer.
sqlServer7 | This is sqlServer7, a member of class DatabaseEngineInitializer.
sqlServerBdp | This is sqlServerBdp, a member of class DatabaseEngineInitializer.
sqlServerDbx | This is sqlServerDbx, a member of class DatabaseEngineInitializer.
sqlServerSqlClient | This is sqlServerSqlClient, a member of class DatabaseEngineInitializer.
sybase | This is sybase, a member of class DatabaseEngineInitializer.


DatabaseEngineInitializer.allEngines Field

DatabaseEngineInitializer.allEngines Field
DatabaseEngineInitializer Class Eco.Persistence.Configuration Namespace See Also
Collapse All
C#
public const DataBaseEngine allEngines = DataBaseEngine.Unknown | DataBaseEngine.InterbaseSqlDialect1 | allInterbaseDialect3 | DataBaseEngine.GenericANSISQL92 | microsoftEngines | sybase | oracle | blackfish | db2 | DataBaseEngine.DBISAM | DataBaseEngine.Advantage | DataBaseEngine.Informix | mysql;
Remarks

This is allEngines, a member of class DatabaseEngineInitializer.

See Also
DatabaseEngineInitializer Class
Eco.Persistence.Configuration Namespace


DatabaseEngineInitializer.allInterbaseDialect3 Field

DatabaseEngineInitializer.allInterbaseDialect3 Field
DatabaseEngineInitializer Class Eco.Persistence.Configuration Namespace See Also
Collapse All
C#
public const DataBaseEngine allInterbaseDialect3 = interbaseDialect3 | interbaseDialect3Dbx;
Remarks

This is allInterbaseDialect3, a member of class DatabaseEngineInitializer.

See Also
DatabaseEngineInitializer Class
Eco.Persistence.Configuration Namespace


DatabaseEngineInitializer.blackfish Field

DatabaseEngineInitializer.blackfish Field
DatabaseEngineInitializer Class Eco.Persistence.Configuration Namespace See Also
Collapse All
C#
public const DataBaseEngine blackfish = DataBaseEngine.Blackfish | DataBaseEngine.BlackfishDbx | DataBaseEngine.BlackfishBdp;
Remarks

This is blackfish, a member of class DatabaseEngineInitializer.

See Also
DatabaseEngineInitializer Class
Eco.Persistence.Configuration Namespace


DatabaseEngineInitializer.db2 Field

DatabaseEngineInitializer.db2 Field
DatabaseEngineInitializer Class Eco.Persistence.Configuration Namespace See Also
Collapse All
C#
public const DataBaseEngine db2 = DataBaseEngine.DB2 | DataBaseEngine.DB2Dbx | DataBaseEngine.DB2MBCS;
Remarks

This is db2, a member of class DatabaseEngineInitializer.

See Also
DatabaseEngineInitializer Class
Eco.Persistence.Configuration Namespace


DatabaseEngineInitializer.genericMbcs Field

DatabaseEngineInitializer.genericMbcs Field
DatabaseEngineInitializer Class Eco.Persistence.Configuration Namespace See Also
Collapse All
C#
public const DataBaseEngine genericMbcs = DataBaseEngine.SqlServerMBCSSqlClient | DataBaseEngine.SqlServerMBCSBdp | DataBaseEngine.OracleBdpMBCS;
Remarks

This is genericMbcs, a member of class DatabaseEngineInitializer.

See Also
DatabaseEngineInitializer Class
Eco.Persistence.Configuration Namespace


DatabaseEngineInitializer.interbaseDialect3 Field

DatabaseEngineInitializer.interbaseDialect3 Field
DatabaseEngineInitializer Class Eco.Persistence.Configuration Namespace See Also
Collapse All
C#
public const DataBaseEngine interbaseDialect3 = DataBaseEngine.InterbaseSqlDialect3 | DataBaseEngine.InterbaseSqlDialect3MBCS;
Remarks

This is interbaseDialect3, a member of class DatabaseEngineInitializer.

See Also
DatabaseEngineInitializer Class
Eco.Persistence.Configuration Namespace


DatabaseEngineInitializer.interbaseDialect3Dbx Field

DatabaseEngineInitializer.interbaseDialect3Dbx Field
DatabaseEngineInitializer Class Eco.Persistence.Configuration Namespace See Also
Collapse All
C#
public const DataBaseEngine interbaseDialect3Dbx = DataBaseEngine.InterbaseSqlDialect3Dbx | DataBaseEngine.InterbaseSqlDialect3DbxMBCS;
Remarks

This is interbaseDialect3Dbx, a member of class DatabaseEngineInitializer.

See Also
DatabaseEngineInitializer Class
Eco.Persistence.Configuration Namespace


DatabaseEngineInitializer.microsoftEngines Field

DatabaseEngineInitializer.microsoftEngines Field
DatabaseEngineInitializer Class Eco.Persistence.Configuration Namespace See Also
Collapse All
C#
public const DataBaseEngine microsoftEngines = sqlServerDbx | sqlServerBdp | sqlServerSqlClient | msAccess;
Remarks

This is microsoftEngines, a member of class DatabaseEngineInitializer.

See Also
DatabaseEngineInitializer Class
Eco.Persistence.Configuration Namespace


DatabaseEngineInitializer.msAccess Field

DatabaseEngineInitializer.msAccess Field
DatabaseEngineInitializer Class Eco.Persistence.Configuration Namespace See Also
Collapse All
C#
public const DataBaseEngine msAccess = DataBaseEngine.AccessBdp | DataBaseEngine.AccessDbx | DataBaseEngine.AccessSqlClient;
Remarks

This is msAccess, a member of class DatabaseEngineInitializer.

See Also
DatabaseEngineInitializer Class
Eco.Persistence.Configuration Namespace


DatabaseEngineInitializer.mysql Field

DatabaseEngineInitializer.mysql Field
DatabaseEngineInitializer Class Eco.Persistence.Configuration Namespace See Also
Collapse All
C#
public const DataBaseEngine mysql = mysql4 | mysql5;
Remarks

This is mysql, a member of class DatabaseEngineInitializer.

See Also
DatabaseEngineInitializer Class
Eco.Persistence.Configuration Namespace


DatabaseEngineInitializer.mysql4 Field

DatabaseEngineInitializer.mysql4 Field
DatabaseEngineInitializer Class Eco.Persistence.Configuration Namespace See Also
Collapse All
C#
public const DataBaseEngine mysql4 = DataBaseEngine.MySql4Bdp | DataBaseEngine.MySql4Dbx | DataBaseEngine.MySql4Mys;
Remarks

This is mysql4, a member of class DatabaseEngineInitializer.

See Also
DatabaseEngineInitializer Class
Eco.Persistence.Configuration Namespace


DatabaseEngineInitializer.mysql5 Field

DatabaseEngineInitializer.mysql5 Field
DatabaseEngineInitializer Class Eco.Persistence.Configuration Namespace See Also
Collapse All
C#
public const DataBaseEngine mysql5 = DataBaseEngine.MySql5Bdp | DataBaseEngine.MySql5Dbx | DataBaseEngine.MySql5Mys;
Remarks

This is mysql5, a member of class DatabaseEngineInitializer.

See Also
DatabaseEngineInitializer Class
Eco.Persistence.Configuration Namespace


DatabaseEngineInitializer.mysqlBdp Field

DatabaseEngineInitializer.mysqlBdp Field
DatabaseEngineInitializer Class Eco.Persistence.Configuration Namespace See Also
Collapse All
C#
public const DataBaseEngine mysqlBdp = DataBaseEngine.MySql4Bdp | DataBaseEngine.MySql5Bdp;
Remarks

This is mysqlBdp, a member of class DatabaseEngineInitializer.

See Also
DatabaseEngineInitializer Class
Eco.Persistence.Configuration Namespace


DatabaseEngineInitializer.mysqlDbx Field

DatabaseEngineInitializer.mysqlDbx Field
DatabaseEngineInitializer Class Eco.Persistence.Configuration Namespace See Also
Collapse All
C#
public const DataBaseEngine mysqlDbx = DataBaseEngine.MySql4Dbx | DataBaseEngine.MySql5Dbx;
Remarks

This is mysqlDbx, a member of class DatabaseEngineInitializer.

See Also
DatabaseEngineInitializer Class
Eco.Persistence.Configuration Namespace


DatabaseEngineInitializer.mysqlMys Field

DatabaseEngineInitializer.mysqlMys Field
DatabaseEngineInitializer Class Eco.Persistence.Configuration Namespace See Also
Collapse All
C#
public const DataBaseEngine mysqlMys = DataBaseEngine.MySql4Mys | DataBaseEngine.MySql5Mys;
Remarks

This is mysqlMys, a member of class DatabaseEngineInitializer.

See Also
DatabaseEngineInitializer Class
Eco.Persistence.Configuration Namespace


DatabaseEngineInitializer.oracle Field

DatabaseEngineInitializer.oracle Field
DatabaseEngineInitializer Class Eco.Persistence.Configuration Namespace See Also
Collapse All
C#
public const DataBaseEngine oracle = DataBaseEngine.OracleBdp | DataBaseEngine.OracleBdpMBCS | DataBaseEngine.OracleDbx | DataBaseEngine.OracleClient;
Remarks

This is oracle, a member of class DatabaseEngineInitializer.

See Also
DatabaseEngineInitializer Class
Eco.Persistence.Configuration Namespace


DatabaseEngineInitializer.oracleBdp Field

DatabaseEngineInitializer.oracleBdp Field
DatabaseEngineInitializer Class Eco.Persistence.Configuration Namespace See Also
Collapse All
C#
public const DataBaseEngine oracleBdp = DataBaseEngine.OracleBdp | DataBaseEngine.OracleBdpMBCS;
Remarks

This is oracleBdp, a member of class DatabaseEngineInitializer.

See Also
DatabaseEngineInitializer Class
Eco.Persistence.Configuration Namespace


DatabaseEngineInitializer.oracleDbx Field

DatabaseEngineInitializer.oracleDbx Field
DatabaseEngineInitializer Class Eco.Persistence.Configuration Namespace See Also
Collapse All
C#
public const DataBaseEngine oracleDbx = DataBaseEngine.OracleDbx | DataBaseEngine.OracleDbxMBCS;
Remarks

This is oracleDbx, a member of class DatabaseEngineInitializer.

See Also
DatabaseEngineInitializer Class
Eco.Persistence.Configuration Namespace


DatabaseEngineInitializer.sqlServer Field

DatabaseEngineInitializer.sqlServer Field
DatabaseEngineInitializer Class Eco.Persistence.Configuration Namespace See Also
Collapse All
C#
public const DataBaseEngine sqlServer = sqlServerDbx | sqlServerBdp | sqlServerSqlClient;
Remarks

This is sqlServer, a member of class DatabaseEngineInitializer.

See Also
DatabaseEngineInitializer Class
Eco.Persistence.Configuration Namespace


DatabaseEngineInitializer.sqlServer7 Field

DatabaseEngineInitializer.sqlServer7 Field
DatabaseEngineInitializer Class Eco.Persistence.Configuration Namespace See Also
Collapse All
C#
public const DataBaseEngine sqlServer7 = DataBaseEngine.SqlServer7Bdp | DataBaseEngine.SqlServer7SqlClient | DataBaseEngine.SqlServer7MBCSBdp | DataBaseEngine.SqlServer7MBCSSqlClient;
Remarks

This is sqlServer7, a member of class DatabaseEngineInitializer.

See Also
DatabaseEngineInitializer Class
Eco.Persistence.Configuration Namespace


DatabaseEngineInitializer.sqlServerBdp Field

DatabaseEngineInitializer.sqlServerBdp Field
DatabaseEngineInitializer Class Eco.Persistence.Configuration Namespace See Also
Collapse All
C#
public const DataBaseEngine sqlServerBdp = DataBaseEngine.SqlServerBdp | DataBaseEngine.SqlServerMBCSBdp | DataBaseEngine.SqlServer7Bdp | DataBaseEngine.SqlServer7MBCSBdp;
Remarks

This is sqlServerBdp, a member of class DatabaseEngineInitializer.

See Also
DatabaseEngineInitializer Class
Eco.Persistence.Configuration Namespace


DatabaseEngineInitializer.sqlServerDbx Field

DatabaseEngineInitializer.sqlServerDbx Field
DatabaseEngineInitializer Class Eco.Persistence.Configuration Namespace See Also
Collapse All
C#
public const DataBaseEngine sqlServerDbx = DataBaseEngine.SqlServerDbx | DataBaseEngine.SqlServerMBCSDbx | DataBaseEngine.SqlServer7Dbx | DataBaseEngine.SqlServer7MBCSDbx;
Remarks

This is sqlServerDbx, a member of class DatabaseEngineInitializer.

See Also
DatabaseEngineInitializer Class
Eco.Persistence.Configuration Namespace


DatabaseEngineInitializer.sqlServerSqlClient Field

DatabaseEngineInitializer.sqlServerSqlClient Field
DatabaseEngineInitializer Class Eco.Persistence.Configuration Namespace See Also
Collapse All
C#
public const DataBaseEngine sqlServerSqlClient = DataBaseEngine.SqlServerSqlClient | DataBaseEngine.SqlServer7SqlClient | DataBaseEngine.SqlServerMBCSSqlClient | DataBaseEngine.SqlServer7MBCSSqlClient;
Remarks

This is sqlServerSqlClient, a member of class DatabaseEngineInitializer.

See Also
DatabaseEngineInitializer Class
Eco.Persistence.Configuration Namespace


DatabaseEngineInitializer.sybase Field

DatabaseEngineInitializer.sybase Field
DatabaseEngineInitializer Class Eco.Persistence.Configuration Namespace See Also
Collapse All
C#
public const DataBaseEngine sybase = DataBaseEngine.SybaseCommon | DataBaseEngine.SybaseDbx | DataBaseEngine.SybaseBdp;
Remarks

This is sybase, a member of class DatabaseEngineInitializer.

See Also
DatabaseEngineInitializer Class
Eco.Persistence.Configuration Namespace


DatabaseEngineInitializer Methods

DatabaseEngineInitializer Methods
Public Methods
Collapse All

The methods of the DatabaseEngineInitializer class are listed here.

Public Methods
Name | Description
InitializeDbEngineSettings | Used by designers to configure a persistencemapper's SqlDatabaseConfig.


DatabaseEngineInitializer.InitializeDbEngineSettings Method

DatabaseEngineInitializer.InitializeDbEngineSettings Method
DatabaseEngineInitializer Class Eco.Persistence.Configuration Namespace See Also
Collapse All

Used by designers to configure a persistencemapper's SqlDatabaseConfig.

C#
public static void InitializeDbEngineSettings(
    DataBaseEngine engine,
    SqlDatabaseConfig sqlDatabaseConfig
);
Remarks

Can also be invoked in runtime prior to opening the system.

See Also
DatabaseEngineInitializer Class
Eco.Persistence.Configuration Namespace


DatabaseEngineInitializer Properties

DatabaseEngineInitializer Properties
Public Properties
Collapse All

The properties of the DatabaseEngineInitializer class are listed here.

Public Properties
Name | Description
AttributeMapperList | Contains the list of known attribute mappers, wrapped in a MapperDefinition.
KeyMapperList | Contains the list of known key mappers, wrapped in a MapperDefinition.


DatabaseEngineInitializer.AttributeMapperList Property

DatabaseEngineInitializer.AttributeMapperList Property
DatabaseEngineInitializer Class Eco.Persistence.Configuration Namespace See Also
Collapse All

Contains the list of known attribute mappers, wrapped in a MapperDefinition.

C#
public static List<MapperDefinition> AttributeMapperList;
See Also
DatabaseEngineInitializer Class
Eco.Persistence.Configuration Namespace


DatabaseEngineInitializer.KeyMapperList Property

DatabaseEngineInitializer.KeyMapperList Property
DatabaseEngineInitializer Class Eco.Persistence.Configuration Namespace See Also
Collapse All

Contains the list of known key mappers, wrapped in a MapperDefinition.

C#
public static List<MapperDefinition> KeyMapperList;
See Also
DatabaseEngineInitializer Class
Eco.Persistence.Configuration Namespace


IdMapperDefinition Class

IdMapperDefinition Class
Inheritance Hierarchy See Also
Collapse All
C#
public class IdMapperDefinition : KeyMapperDefinition;
Remarks

This is class Eco.Persistence.Configuration.IdMapperDefinition.

Inheritance Hierarchy
Eco.Persistence.Configuration.KeyMapperDefinition
    Eco.Persistence.Configuration.IdMapperDefinition
File

SqlDatabaseConfig.cs

See Also
Inheritance Hierarchy


KeyMapperDefinition Class

KeyMapperDefinition Class
Inheritance Hierarchy See Also
Collapse All
C#
public class KeyMapperDefinition;
Remarks

This is class Eco.Persistence.Configuration.KeyMapperDefinition.

Inheritance Hierarchy
Eco.Persistence.Configuration.KeyMapperDefinition
    Eco.Persistence.Configuration.IdMapperDefinition
File

SqlDatabaseConfig.cs

See Also
Inheritance Hierarchy


KeyMapperDefinition Methods

KeyMapperDefinition Methods
Public Methods
Collapse All

The methods of the KeyMapperDefinition class are listed here.

Public Methods
Name | Description
ToString | This is ToString, a member of class KeyMapperDefinition.


KeyMapperDefinition.ToString Method

KeyMapperDefinition.ToString Method
KeyMapperDefinition Class Eco.Persistence.Configuration Namespace See Also
Collapse All
C#
public override string ToString();
Remarks

This is ToString, a member of class KeyMapperDefinition.

See Also
KeyMapperDefinition Class
Eco.Persistence.Configuration Namespace


KeyMapperDefinition Properties

KeyMapperDefinition Properties
Public Properties
Collapse All

The properties of the KeyMapperDefinition class are listed here.

Public Properties
Name | Description
Mapper | This is Mapper, a member of class KeyMapperDefinition.
MapperTypeName | This is MapperTypeName, a member of class KeyMapperDefinition.
Name | This is Name, a member of class KeyMapperDefinition.


KeyMapperDefinition.Mapper Property

KeyMapperDefinition.Mapper Property
KeyMapperDefinition Class Eco.Persistence.Configuration Namespace See Also
Collapse All
C#
public System.Type Mapper;
Remarks

This is Mapper, a member of class KeyMapperDefinition.

See Also
KeyMapperDefinition Class
Eco.Persistence.Configuration Namespace


KeyMapperDefinition.MapperTypeName Property

KeyMapperDefinition.MapperTypeName Property
KeyMapperDefinition Class Eco.Persistence.Configuration Namespace See Also
Collapse All
C#
public string MapperTypeName;
Remarks

This is MapperTypeName, a member of class KeyMapperDefinition.

See Also
KeyMapperDefinition Class
Eco.Persistence.Configuration Namespace


KeyMapperDefinition.Name Property

KeyMapperDefinition.Name Property
KeyMapperDefinition Class Eco.Persistence.Configuration Namespace See Also
Collapse All
C#
public string Name;
Remarks

This is Name, a member of class KeyMapperDefinition.

See Also
KeyMapperDefinition Class
Eco.Persistence.Configuration Namespace


KeyMapperDefinitionCollection Class

KeyMapperDefinitionCollection Class
Inheritance Hierarchy See Also
Collapse All

Holds a collection of KeyMapperDefinition. Duplicates are avoided by means of the KeyMapperDefinition.Name property. It is used by SqlDatabaseConfig.

C#
public sealed class KeyMapperDefinitionCollection : System.Collections.CollectionBase;
Inheritance Hierarchy
Eco.Persistence.Configuration.KeyMapperDefinitionCollection
File

SqlDatabaseConfig.cs

See Also
Inheritance Hierarchy


KeyMapperDefinitionCollection.KeyMapperDefinitionCollection Constructor

KeyMapperDefinitionCollection.KeyMapperDefinitionCollection Constructor
KeyMapperDefinitionCollection Class Eco.Persistence.Configuration Namespace See Also
Collapse All
C#
public KeyMapperDefinitionCollection(
    SqlDatabaseConfig config
);
Remarks

This is KeyMapperDefinitionCollection, a member of class KeyMapperDefinitionCollection.

See Also
KeyMapperDefinitionCollection Class
Eco.Persistence.Configuration Namespace


KeyMapperDefinitionCollection Methods

KeyMapperDefinitionCollection Methods
Protected Methods Public Methods
Collapse All

The methods of the KeyMapperDefinitionCollection class are listed here.

Protected Methods
Name | Description
OnInsertComplete | This is OnInsertComplete, a member of class KeyMapperDefinitionCollection.
Top
Public Methods
Name | Description
Add | if def.Name is already present in the collection, no action is taken (and no exception is thrown)
AddRange | Adds multiple KeyMapperDefinition by calling Add for each item in the array.
Assign | Clears this collection and clones all KeyMapperDefinition in source and adds them to this instance.
FindByName | Returns the KeyMapperDefinition with the specified name or null if no match is found.
NameExists | Returns true if the collection contains KeyMapperDefinition with the specified name.
this | Returns the KeyMapperDefinition at position index.


KeyMapperDefinitionCollection.Add Method

KeyMapperDefinitionCollection.Add Method
KeyMapperDefinitionCollection Class Eco.Persistence.Configuration Namespace See Also
Collapse All

if def.Name is already present in the collection, no action is taken (and no exception is thrown)

C#
public void Add(
    KeyMapperDefinition def
);
Parameters
Parameters | Description
def | KeyMapperDefinition instance to add to the collection.
Exceptions
Exceptions | Description
ArgumentNullException | Thrown if def is null
See Also
KeyMapperDefinitionCollection Class
Eco.Persistence.Configuration Namespace


KeyMapperDefinitionCollection.AddRange Method

KeyMapperDefinitionCollection.AddRange Method
KeyMapperDefinitionCollection Class Eco.Persistence.Configuration Namespace See Also
Collapse All

Adds multiple KeyMapperDefinition by calling Add for each item in the array.

C#
public void AddRange(
    KeyMapperDefinition[] defs
);
See Also
KeyMapperDefinitionCollection Class
Eco.Persistence.Configuration Namespace


KeyMapperDefinitionCollection.Assign Method

KeyMapperDefinitionCollection.Assign Method
KeyMapperDefinitionCollection Class Eco.Persistence.Configuration Namespace See Also
Collapse All

Clears this collection and clones all KeyMapperDefinition in source and adds them to this instance.

C#
public void Assign(
    KeyMapperDefinitionCollection source
);
Exceptions
Exceptions | Description
ArgumentNullException | Thrown if source is null
See Also
KeyMapperDefinitionCollection Class
Eco.Persistence.Configuration Namespace


KeyMapperDefinitionCollection.FindByName Method

KeyMapperDefinitionCollection.FindByName Method
KeyMapperDefinitionCollection Class Eco.Persistence.Configuration Namespace See Also
Collapse All

Returns the KeyMapperDefinition with the specified name or null if no match is found.

C#
public KeyMapperDefinition FindByName(
    string name
);
See Also
KeyMapperDefinitionCollection Class
Eco.Persistence.Configuration Namespace


KeyMapperDefinitionCollection.NameExists Method

KeyMapperDefinitionCollection.NameExists Method
KeyMapperDefinitionCollection Class Eco.Persistence.Configuration Namespace See Also
Collapse All

Returns true if the collection contains KeyMapperDefinition with the specified name.

C#
public bool NameExists(
    string name
);
See Also
KeyMapperDefinitionCollection Class
Eco.Persistence.Configuration Namespace


KeyMapperDefinitionCollection.OnInsertComplete Method

KeyMapperDefinitionCollection.OnInsertComplete Method
KeyMapperDefinitionCollection Class Eco.Persistence.Configuration Namespace See Also
Collapse All
C#
protected override void OnInsertComplete(
    int index,
    object value
);
Remarks

This is OnInsertComplete, a member of class KeyMapperDefinitionCollection.

See Also
KeyMapperDefinitionCollection Class
Eco.Persistence.Configuration Namespace


KeyMapperDefinitionCollection.this Indexer

KeyMapperDefinitionCollection.this Indexer
KeyMapperDefinitionCollection Class Eco.Persistence.Configuration Namespace See Also
Collapse All

Returns the KeyMapperDefinition at position index.

C#
public KeyMapperDefinition this[
    int index
];
See Also
KeyMapperDefinitionCollection Class
Eco.Persistence.Configuration Namespace


KeyMapperDefinitionCollection Properties

KeyMapperDefinitionCollection Properties
Public Properties
Collapse All

The properties of the KeyMapperDefinitionCollection class are listed here.

Public Properties
Name | Description
TypeResolutionService | This is TypeResolutionService, a member of class KeyMapperDefinitionCollection.


KeyMapperDefinitionCollection.TypeResolutionService Property

KeyMapperDefinitionCollection.TypeResolutionService Property
KeyMapperDefinitionCollection Class Eco.Persistence.Configuration Namespace See Also
Collapse All
C#
public ITypeResolutionService TypeResolutionService;
Remarks

This is TypeResolutionService, a member of class KeyMapperDefinitionCollection.

See Also
KeyMapperDefinitionCollection Class
Eco.Persistence.Configuration Namespace


KeyMapperDefinitionConverter Class

KeyMapperDefinitionConverter Class
Inheritance Hierarchy See Also
Collapse All
C#
public sealed class KeyMapperDefinitionConverter : ExpandableObjectConverter;
Remarks

IdMapper definitions

Inheritance Hierarchy
Eco.Persistence.Configuration.KeyMapperDefinitionConverter
File

SqlDatabaseConfig.cs

See Also
Inheritance Hierarchy


KeyMapperDefinitionConverter.KeyMapperDefinitionConverter Constructor

KeyMapperDefinitionConverter.KeyMapperDefinitionConverter Constructor
KeyMapperDefinitionConverter Class Eco.Persistence.Configuration Namespace See Also
Collapse All
C#
public KeyMapperDefinitionConverter();
Remarks

This is KeyMapperDefinitionConverter, a member of class KeyMapperDefinitionConverter.

See Also
KeyMapperDefinitionConverter Class
Eco.Persistence.Configuration Namespace


KeyMapperDefinitionConverter Methods

KeyMapperDefinitionConverter Methods
Public Methods
Collapse All

The methods of the KeyMapperDefinitionConverter class are listed here.

Public Methods
Name | Description
CanConvertTo | This is CanConvertTo, a member of class KeyMapperDefinitionConverter.
ConvertTo | This is ConvertTo, a member of class KeyMapperDefinitionConverter.


KeyMapperDefinitionConverter.CanConvertTo Method

KeyMapperDefinitionConverter.CanConvertTo Method
KeyMapperDefinitionConverter Class Eco.Persistence.Configuration Namespace See Also
Collapse All
C#
public override bool CanConvertTo(
    ITypeDescriptorContext context,
    System.Type destinationType
);
Remarks

This is CanConvertTo, a member of class KeyMapperDefinitionConverter.

See Also
KeyMapperDefinitionConverter Class
Eco.Persistence.Configuration Namespace


KeyMapperDefinitionConverter.ConvertTo Method

KeyMapperDefinitionConverter.ConvertTo Method
KeyMapperDefinitionConverter Class Eco.Persistence.Configuration Namespace See Also
Collapse All
C#
public override object ConvertTo(
    ITypeDescriptorContext context,
    CultureInfo culture,
    object value,
    System.Type destinationType
);
Remarks

This is ConvertTo, a member of class KeyMapperDefinitionConverter.

See Also
KeyMapperDefinitionConverter Class
Eco.Persistence.Configuration Namespace


MapperDefinition Class

MapperDefinition Class
Inheritance Hierarchy See Also
Collapse All

This class contains a mapper type, it's logical name and a bit-mapped field indicating which DataBaseEngine should use this mapper.

C#
public class MapperDefinition;
Inheritance Hierarchy
Eco.Persistence.Configuration.MapperDefinition
File

InitializeEngine.cs

See Also
Inheritance Hierarchy


MapperDefinition.MapperDefinition Constructor

MapperDefinition.MapperDefinition Constructor
MapperDefinition Class Eco.Persistence.Configuration Namespace See Also
Collapse All

Creates an instance of MapperDefinition.

C#
public MapperDefinition(
    DataBaseEngine databaseEngine,
    string typeName,
    System.Type mapperType
);
Parameters
Parameters | Description
databaseEngine | A set of DataBaseEngine values the mapper is associated with.
typeName | The model name associated with the MapperType.
mapperType | The actual type implementing the mapper.
See Also
MapperDefinition Class
Eco.Persistence.Configuration Namespace


MapperDefinition Properties

MapperDefinition Properties
Public Properties
Collapse All

The properties of the MapperDefinition class are listed here.

Public Properties
Name | Description
DatabaseEngines | Bit-mapped field of which DataBaseEngine should use this mapper.
MapperType | The actual type implementing the mapper.
TypeName | Model name this mapper corresponds to.


MapperDefinition.DatabaseEngines Property

MapperDefinition.DatabaseEngines Property
MapperDefinition Class Eco.Persistence.Configuration Namespace See Also
Collapse All

Bit-mapped field of which DataBaseEngine should use this mapper.

C#
public DataBaseEngine DatabaseEngines;
See Also
MapperDefinition Class
Eco.Persistence.Configuration Namespace


MapperDefinition.MapperType Property

MapperDefinition.MapperType Property
MapperDefinition Class Eco.Persistence.Configuration Namespace See Also
Collapse All

The actual type implementing the mapper.

C#
public System.Type MapperType;
See Also
MapperDefinition Class
Eco.Persistence.Configuration Namespace


MapperDefinition.TypeName Property

MapperDefinition.TypeName Property
MapperDefinition Class Eco.Persistence.Configuration Namespace See Also
Collapse All

Model name this mapper corresponds to.

C#
public string TypeName;
See Also
MapperDefinition Class
Eco.Persistence.Configuration Namespace


PersistenceMapperDefinition Class

PersistenceMapperDefinition Class
Inheritance Hierarchy See Also
Collapse All
C#
public sealed class PersistenceMapperDefinition;
Remarks

This is class Eco.Persistence.Configuration.PersistenceMapperDefinition.

Inheritance Hierarchy
Eco.Persistence.Configuration.PersistenceMapperDefinition
File

SqlDatabaseConfig.cs

See Also
Inheritance Hierarchy


PersistenceMapperDefinition Methods

PersistenceMapperDefinition Methods
Public Methods
Collapse All

The methods of the PersistenceMapperDefinition class are listed here.

Public Methods
Name | Description
ToString | This is ToString, a member of class PersistenceMapperDefinition.


PersistenceMapperDefinition.ToString Method

PersistenceMapperDefinition.ToString Method
PersistenceMapperDefinition Class Eco.Persistence.Configuration Namespace See Also
Collapse All
C#
public override string ToString();
Remarks

This is ToString, a member of class PersistenceMapperDefinition.

See Also
PersistenceMapperDefinition Class
Eco.Persistence.Configuration Namespace


PersistenceMapperDefinition Properties

PersistenceMapperDefinition Properties
Public Properties
Collapse All

The properties of the PersistenceMapperDefinition class are listed here.

Public Properties
Name | Description
Mapper | This is Mapper, a member of class PersistenceMapperDefinition.
MapperTypeName | This is MapperTypeName, a member of class PersistenceMapperDefinition.
Name | This is Name, a member of class PersistenceMapperDefinition.


PersistenceMapperDefinition.Mapper Property

PersistenceMapperDefinition.Mapper Property
PersistenceMapperDefinition Class Eco.Persistence.Configuration Namespace See Also
Collapse All
C#
public System.Type Mapper;
Remarks

This is Mapper, a member of class PersistenceMapperDefinition.

See Also
PersistenceMapperDefinition Class
Eco.Persistence.Configuration Namespace


PersistenceMapperDefinition.MapperTypeName Property

PersistenceMapperDefinition.MapperTypeName Property
PersistenceMapperDefinition Class Eco.Persistence.Configuration Namespace See Also
Collapse All
C#
public string MapperTypeName;
Remarks

This is MapperTypeName, a member of class PersistenceMapperDefinition.

See Also
PersistenceMapperDefinition Class
Eco.Persistence.Configuration Namespace


PersistenceMapperDefinition.Name Property

PersistenceMapperDefinition.Name Property
PersistenceMapperDefinition Class Eco.Persistence.Configuration Namespace See Also
Collapse All
C#
public string Name;
Remarks

This is Name, a member of class PersistenceMapperDefinition.

See Also
PersistenceMapperDefinition Class
Eco.Persistence.Configuration Namespace


PersistenceMapperDefinitionCollection Class

PersistenceMapperDefinitionCollection Class
Inheritance Hierarchy See Also
Collapse All
C#
public sealed class PersistenceMapperDefinitionCollection : System.Collections.CollectionBase;
Remarks

This is class Eco.Persistence.Configuration.PersistenceMapperDefinitionCollection.

Inheritance Hierarchy
Eco.Persistence.Configuration.PersistenceMapperDefinitionCollection
File

SqlDatabaseConfig.cs

See Also
Inheritance Hierarchy


PersistenceMapperDefinitionCollection.PersistenceMapperDefinitionCollection Constructor

PersistenceMapperDefinitionCollection.PersistenceMapperDefinitionCollection Constructor
PersistenceMapperDefinitionCollection Class Eco.Persistence.Configuration Namespace See Also
Collapse All
C#
public PersistenceMapperDefinitionCollection(
    SqlDatabaseConfig config
);
Remarks

This is PersistenceMapperDefinitionCollection, a member of class PersistenceMapperDefinitionCollection.

See Also
PersistenceMapperDefinitionCollection Class
Eco.Persistence.Configuration Namespace


PersistenceMapperDefinitionCollection Methods

PersistenceMapperDefinitionCollection Methods
Protected Methods Public Methods
Collapse All

The methods of the PersistenceMapperDefinitionCollection class are listed here.

Protected Methods
Name | Description
OnInsertComplete | This is OnInsertComplete, a member of class PersistenceMapperDefinitionCollection.
Top
Public Methods
Name | Description
Add |
AddRange | This is AddRange, a member of class PersistenceMapperDefinitionCollection.
Assign |
FindByName | This is FindByName, a member of class PersistenceMapperDefinitionCollection.
GetMapperDictionary | This is GetMapperDictionary, a member of class PersistenceMapperDefinitionCollection.
NameExists | This is NameExists, a member of class PersistenceMapperDefinitionCollection.
this | This is this, a member of class PersistenceMapperDefinitionCollection.


PersistenceMapperDefinitionCollection.Add Method

PersistenceMapperDefinitionCollection.Add Method
PersistenceMapperDefinitionCollection Class Eco.Persistence.Configuration Namespace See Also
Collapse All
C#
public void Add(
    PersistenceMapperDefinition def
);
Exceptions
Exceptions | Description
ArgumentNullException | Thrown if def is null
See Also
PersistenceMapperDefinitionCollection Class
Eco.Persistence.Configuration Namespace


PersistenceMapperDefinitionCollection.AddRange Method

PersistenceMapperDefinitionCollection.AddRange Method
PersistenceMapperDefinitionCollection Class Eco.Persistence.Configuration Namespace See Also
Collapse All
C#
public void AddRange(
    PersistenceMapperDefinition[] defs
);
Remarks

This is AddRange, a member of class PersistenceMapperDefinitionCollection.

See Also
PersistenceMapperDefinitionCollection Class
Eco.Persistence.Configuration Namespace


PersistenceMapperDefinitionCollection.Assign Method

PersistenceMapperDefinitionCollection.Assign Method
PersistenceMapperDefinitionCollection Class Eco.Persistence.Configuration Namespace See Also
Collapse All
C#
public void Assign(
    PersistenceMapperDefinitionCollection source
);
Exceptions
Exceptions | Description
ArgumentNullException | Thrown if source is null
See Also
PersistenceMapperDefinitionCollection Class
Eco.Persistence.Configuration Namespace


PersistenceMapperDefinitionCollection.FindByName Method

PersistenceMapperDefinitionCollection.FindByName Method
PersistenceMapperDefinitionCollection Class Eco.Persistence.Configuration Namespace See Also
Collapse All
C#
public PersistenceMapperDefinition FindByName(
    string name
);
Remarks

This is FindByName, a member of class PersistenceMapperDefinitionCollection.

See Also
PersistenceMapperDefinitionCollection Class
Eco.Persistence.Configuration Namespace


PersistenceMapperDefinitionCollection.GetMapperDictionary Method

PersistenceMapperDefinitionCollection.GetMapperDictionary Method
PersistenceMapperDefinitionCollection Class Eco.Persistence.Configuration Namespace See Also
Collapse All
C#
public PersistenceMapperDictionary GetMapperDictionary();
Remarks

This is GetMapperDictionary, a member of class PersistenceMapperDefinitionCollection.

See Also
PersistenceMapperDefinitionCollection Class
Eco.Persistence.Configuration Namespace


PersistenceMapperDefinitionCollection.NameExists Method

PersistenceMapperDefinitionCollection.NameExists Method
PersistenceMapperDefinitionCollection Class Eco.Persistence.Configuration Namespace See Also
Collapse All
C#
public bool NameExists(
    string name
);
Remarks

This is NameExists, a member of class PersistenceMapperDefinitionCollection.

See Also
PersistenceMapperDefinitionCollection Class
Eco.Persistence.Configuration Namespace


PersistenceMapperDefinitionCollection.OnInsertComplete Method

PersistenceMapperDefinitionCollection.OnInsertComplete Method
PersistenceMapperDefinitionCollection Class Eco.Persistence.Configuration Namespace See Also
Collapse All
C#
protected override void OnInsertComplete(
    int index,
    object value
);
Remarks

This is OnInsertComplete, a member of class PersistenceMapperDefinitionCollection.

See Also
PersistenceMapperDefinitionCollection Class
Eco.Persistence.Configuration Namespace


PersistenceMapperDefinitionCollection.this Indexer

PersistenceMapperDefinitionCollection.this Indexer
PersistenceMapperDefinitionCollection Class Eco.Persistence.Configuration Namespace See Also
Collapse All
C#
public PersistenceMapperDefinition this[
    int index
];
Remarks

This is this, a member of class PersistenceMapperDefinitionCollection.

See Also
PersistenceMapperDefinitionCollection Class
Eco.Persistence.Configuration Namespace


PersistenceMapperDefinitionCollection Properties

PersistenceMapperDefinitionCollection Properties
Public Properties
Collapse All

The properties of the PersistenceMapperDefinitionCollection class are listed here.

Public Properties
Name | Description
TypeResolutionService | This is TypeResolutionService, a member of class PersistenceMapperDefinitionCollection.


PersistenceMapperDefinitionCollection.TypeResolutionService Property

PersistenceMapperDefinitionCollection.TypeResolutionService Property
PersistenceMapperDefinitionCollection Class Eco.Persistence.Configuration Namespace See Also
Collapse All
C#
public ITypeResolutionService TypeResolutionService;
Remarks

This is TypeResolutionService, a member of class PersistenceMapperDefinitionCollection.

See Also
PersistenceMapperDefinitionCollection Class
Eco.Persistence.Configuration Namespace


PersistenceMapperDictionary Class

PersistenceMapperDictionary Class
Inheritance Hierarchy See Also
Collapse All
C#
public class PersistenceMapperDictionary;
Remarks

This is class Eco.Persistence.Configuration.PersistenceMapperDictionary.

Inheritance Hierarchy
Eco.Persistence.Configuration.PersistenceMapperDictionary
File

SqlDatabaseConfig.cs

See Also
Inheritance Hierarchy


PersistenceMapperDictionary Methods

PersistenceMapperDictionary Methods
Public Methods
Collapse All

The methods of the PersistenceMapperDictionary class are listed here.

Public Methods
Name | Description
FindEnsuredSingleColumnMappingByName | This is FindEnsuredSingleColumnMappingByName, a member of class PersistenceMapperDictionary.
FindEnsuredSingleColumnMappingByType | This is FindEnsuredSingleColumnMappingByType, a member of class PersistenceMapperDictionary.
FindMapping | This is FindMapping, a member of class PersistenceMapperDictionary.
FindSingleColumnMappingByName | This is FindSingleColumnMappingByName, a member of class PersistenceMapperDictionary.
FindSingleColumnMappingByType | This is FindSingleColumnMappingByType, a member of class PersistenceMapperDictionary.


PersistenceMapperDictionary.FindEnsuredSingleColumnMappingByName Method

PersistenceMapperDictionary.FindEnsuredSingleColumnMappingByName Method
PersistenceMapperDictionary Class Eco.Persistence.Configuration Namespace See Also
Collapse All
C#
public ISingleColumnAttributemapping FindEnsuredSingleColumnMappingByName(
    string name
);
Remarks

This is FindEnsuredSingleColumnMappingByName, a member of class PersistenceMapperDictionary.

See Also
PersistenceMapperDictionary Class
Eco.Persistence.Configuration Namespace


PersistenceMapperDictionary.FindEnsuredSingleColumnMappingByType Method

PersistenceMapperDictionary.FindEnsuredSingleColumnMappingByType Method
PersistenceMapperDictionary Class Eco.Persistence.Configuration Namespace See Also
Collapse All
C#
public ISingleColumnAttributemapping FindEnsuredSingleColumnMappingByType(
    System.Type targetType
);
Remarks

This is FindEnsuredSingleColumnMappingByType, a member of class PersistenceMapperDictionary.

See Also
PersistenceMapperDictionary Class
Eco.Persistence.Configuration Namespace


PersistenceMapperDictionary.FindMapping Method

PersistenceMapperDictionary.FindMapping Method
PersistenceMapperDictionary Class Eco.Persistence.Configuration Namespace See Also
Collapse All
C#
public object FindMapping(
    string mapperName,
    string memberName,
    System.Type targetType
);
Remarks

This is FindMapping, a member of class PersistenceMapperDictionary.

See Also
PersistenceMapperDictionary Class
Eco.Persistence.Configuration Namespace


PersistenceMapperDictionary.FindSingleColumnMappingByName Method

PersistenceMapperDictionary.FindSingleColumnMappingByName Method
PersistenceMapperDictionary Class Eco.Persistence.Configuration Namespace See Also
Collapse All
C#
public ISingleColumnAttributemapping FindSingleColumnMappingByName(
    string name
);
Remarks

This is FindSingleColumnMappingByName, a member of class PersistenceMapperDictionary.

See Also
PersistenceMapperDictionary Class
Eco.Persistence.Configuration Namespace


PersistenceMapperDictionary.FindSingleColumnMappingByType Method

PersistenceMapperDictionary.FindSingleColumnMappingByType Method
PersistenceMapperDictionary Class Eco.Persistence.Configuration Namespace See Also
Collapse All
C#
public ISingleColumnAttributemapping FindSingleColumnMappingByType(
    System.Type targetType
);
Remarks

This is FindSingleColumnMappingByType, a member of class PersistenceMapperDictionary.

See Also
PersistenceMapperDictionary Class
Eco.Persistence.Configuration Namespace


PMapperDefinitionConverter Class

PMapperDefinitionConverter Class
Inheritance Hierarchy See Also
Collapse All
C#
public sealed class PMapperDefinitionConverter : ExpandableObjectConverter;
Remarks

This is class Eco.Persistence.Configuration.PMapperDefinitionConverter.

Inheritance Hierarchy
Eco.Persistence.Configuration.PMapperDefinitionConverter
File

SqlDatabaseConfig.cs

See Also
Inheritance Hierarchy


PMapperDefinitionConverter.PMapperDefinitionConverter Constructor

PMapperDefinitionConverter.PMapperDefinitionConverter Constructor
PMapperDefinitionConverter Class Eco.Persistence.Configuration Namespace See Also
Collapse All
C#
public PMapperDefinitionConverter();
Remarks

This is PMapperDefinitionConverter, a member of class PMapperDefinitionConverter.

See Also
PMapperDefinitionConverter Class
Eco.Persistence.Configuration Namespace


PMapperDefinitionConverter Methods

PMapperDefinitionConverter Methods
Public Methods
Collapse All

The methods of the PMapperDefinitionConverter class are listed here.

Public Methods
Name | Description
CanConvertTo | This is CanConvertTo, a member of class PMapperDefinitionConverter.
ConvertTo | This is ConvertTo, a member of class PMapperDefinitionConverter.


PMapperDefinitionConverter.CanConvertTo Method

PMapperDefinitionConverter.CanConvertTo Method
PMapperDefinitionConverter Class Eco.Persistence.Configuration Namespace See Also
Collapse All
C#
public override bool CanConvertTo(
    ITypeDescriptorContext context,
    System.Type destinationType
);
Remarks

This is CanConvertTo, a member of class PMapperDefinitionConverter.

See Also
PMapperDefinitionConverter Class
Eco.Persistence.Configuration Namespace


PMapperDefinitionConverter.ConvertTo Method

PMapperDefinitionConverter.ConvertTo Method
PMapperDefinitionConverter Class Eco.Persistence.Configuration Namespace See Also
Collapse All
C#
public override object ConvertTo(
    ITypeDescriptorContext context,
    CultureInfo culture,
    object value,
    System.Type destinationType
);
Remarks

This is ConvertTo, a member of class PMapperDefinitionConverter.

See Also
PMapperDefinitionConverter Class
Eco.Persistence.Configuration Namespace


SqlDatabaseConfig Class

SqlDatabaseConfig Class
Inheritance Hierarchy See Also
Collapse All
C#
public sealed class SqlDatabaseConfig;
Remarks

This is class Eco.Persistence.Configuration.SqlDatabaseConfig.

Inheritance Hierarchy
Eco.Persistence.Configuration.SqlDatabaseConfig
File

SqlDatabaseConfig.cs

See Also
Inheritance Hierarchy


SqlDatabaseConfig.SqlDatabaseConfig Constructor

SqlDatabaseConfig.SqlDatabaseConfig Constructor
SqlDatabaseConfig Class Eco.Persistence.Configuration Namespace See Also
Collapse All
C#
public SqlDatabaseConfig(
    Component owner
);
Remarks

This is SqlDatabaseConfig, a member of class SqlDatabaseConfig.

See Also
SqlDatabaseConfig Class
Eco.Persistence.Configuration Namespace


SqlDatabaseConfig Methods

SqlDatabaseConfig Methods
Public Methods
Collapse All

The methods of the SqlDatabaseConfig class are listed here.

Public Methods
Name | Description
AddKeywordsFromResource | This is AddKeywordsFromResource, a member of class SqlDatabaseConfig.
AddReservedWord |
ClearReservedWords | This is ClearReservedWords, a member of class SqlDatabaseConfig.
DeQuoteName | removes database specific quote characters from a column or table name
ForcedMakeStringLiteral | Returns a quoted string (with quote characters replaced by SqlQuoteCharInString), if the string is already quoted, the quotecharacters will be quoted too.
ForceQuoteName | Returns a quoted version of the string
GetDropColumnQuery | This is GetDropColumnQuery, a member of class SqlDatabaseConfig.
GetDropIndexQuery | This is GetDropIndexQuery, a member of class SqlDatabaseConfig.
GetDropTableQuery | This is GetDropTableQuery, a member of class SqlDatabaseConfig.
MakeStringLiteral | returns a quoted string (with quote characters replaced by SqlQuoteCharInString), if the string is already quoted, it will be returned as is.
QuoteName | Returns a quoted version of the string if it contains any characters that makes quoting required or if QuoteSqlNames is true
SetInitialValuesForBasicProperties | This is SetInitialValuesForBasicProperties, a member of class SqlDatabaseConfig.
SetKeyMapper | This is SetKeyMapper, a member of class SqlDatabaseConfig.
SetPMapper | This is SetPMapper, a member of class SqlDatabaseConfig.


SqlDatabaseConfig.AddKeywordsFromResource Method

SqlDatabaseConfig.AddKeywordsFromResource Method
SqlDatabaseConfig Class Eco.Persistence.Configuration Namespace See Also
Collapse All
C#
public void AddKeywordsFromResource(
    Assembly assembly,
    string resourceName
);
Remarks

This is AddKeywordsFromResource, a member of class SqlDatabaseConfig.

See Also
SqlDatabaseConfig Class
Eco.Persistence.Configuration Namespace


SqlDatabaseConfig.AddReservedWord Method

SqlDatabaseConfig.AddReservedWord Method
SqlDatabaseConfig Class Eco.Persistence.Configuration Namespace See Also
Collapse All
C#
public void AddReservedWord(
    string word
);
Exceptions
Exceptions | Description
ArgumentNullException | Thrown if word is null
See Also
SqlDatabaseConfig Class
Eco.Persistence.Configuration Namespace


SqlDatabaseConfig.ClearReservedWords Method

SqlDatabaseConfig.ClearReservedWords Method
SqlDatabaseConfig Class Eco.Persistence.Configuration Namespace See Also
Collapse All
C#
public void ClearReservedWords();
Remarks

This is ClearReservedWords, a member of class SqlDatabaseConfig.

See Also
SqlDatabaseConfig Class
Eco.Persistence.Configuration Namespace


SqlDatabaseConfig.DeQuoteName Method

SqlDatabaseConfig.DeQuoteName Method
SqlDatabaseConfig Class Eco.Persistence.Configuration Namespace See Also
Collapse All

removes database specific quote characters from a column or table name

C#
public string DeQuoteName(
    string quotedName
);
Parameters
Parameters | Description
quotedName |
See Also
SqlDatabaseConfig Class
Eco.Persistence.Configuration Namespace


SqlDatabaseConfig.ForcedMakeStringLiteral Method

SqlDatabaseConfig.ForcedMakeStringLiteral Method
SqlDatabaseConfig Class Eco.Persistence.Configuration Namespace See Also
Collapse All

Returns a quoted string (with quote characters replaced by SqlQuoteCharInString), if the string is already quoted, the quotecharacters will be quoted too.

C#
public string ForcedMakeStringLiteral(
    string s
);
Parameters
Parameters | Description
s |
See Also
SqlDatabaseConfig Class
Eco.Persistence.Configuration Namespace


SqlDatabaseConfig.ForceQuoteName Method

SqlDatabaseConfig.ForceQuoteName Method
SqlDatabaseConfig Class Eco.Persistence.Configuration Namespace See Also
Collapse All

Returns a quoted version of the string

C#
public string ForceQuoteName(
    string unquotedName
);
See Also
SqlDatabaseConfig Class
Eco.Persistence.Configuration Namespace


SqlDatabaseConfig.GetDropColumnQuery Method

SqlDatabaseConfig.GetDropColumnQuery Method
SqlDatabaseConfig Class Eco.Persistence.Configuration Namespace See Also
Collapse All
C#
public string GetDropColumnQuery(
    string tableName,
    string columnName
);
Remarks

This is GetDropColumnQuery, a member of class SqlDatabaseConfig.

See Also
SqlDatabaseConfig Class
Eco.Persistence.Configuration Namespace


SqlDatabaseConfig.GetDropIndexQuery Method

SqlDatabaseConfig.GetDropIndexQuery Method
SqlDatabaseConfig Class Eco.Persistence.Configuration Namespace See Also
Collapse All
C#
public string GetDropIndexQuery(
    string tableName,
    string indexName
);
Remarks

This is GetDropIndexQuery, a member of class SqlDatabaseConfig.

See Also
SqlDatabaseConfig Class
Eco.Persistence.Configuration Namespace


SqlDatabaseConfig.GetDropTableQuery Method

SqlDatabaseConfig.GetDropTableQuery Method
SqlDatabaseConfig Class Eco.Persistence.Configuration Namespace See Also
Collapse All
C#
public string GetDropTableQuery(
    string tableName
);
Remarks

This is GetDropTableQuery, a member of class SqlDatabaseConfig.

See Also
SqlDatabaseConfig Class
Eco.Persistence.Configuration Namespace


SqlDatabaseConfig.MakeStringLiteral Method

SqlDatabaseConfig.MakeStringLiteral Method
SqlDatabaseConfig Class Eco.Persistence.Configuration Namespace See Also
Collapse All

returns a quoted string (with quote characters replaced by SqlQuoteCharInString), if the string is already quoted, it will be returned as is.

C#
public string MakeStringLiteral(
    string s
);
Parameters
Parameters | Description
s |
See Also
SqlDatabaseConfig Class
Eco.Persistence.Configuration Namespace


SqlDatabaseConfig.QuoteName Method

SqlDatabaseConfig.QuoteName Method
SqlDatabaseConfig Class Eco.Persistence.Configuration Namespace See Also
Collapse All

Returns a quoted version of the string if it contains any characters that makes quoting required or if QuoteSqlNames is true

C#
public string QuoteName(
    string unquotedName
);
Exceptions
Exceptions | Description
ArgumentNullException | Thrown if unquotedName is null
See Also
SqlDatabaseConfig Class
Eco.Persistence.Configuration Namespace


SqlDatabaseConfig.SetInitialValuesForBasicProperties Method

SqlDatabaseConfig.SetInitialValuesForBasicProperties Method
SqlDatabaseConfig Class Eco.Persistence.Configuration Namespace See Also
Collapse All
C#
public void SetInitialValuesForBasicProperties();
Remarks

This is SetInitialValuesForBasicProperties, a member of class SqlDatabaseConfig.

See Also
SqlDatabaseConfig Class
Eco.Persistence.Configuration Namespace


SqlDatabaseConfig.SetKeyMapper Method

SqlDatabaseConfig.SetKeyMapper Method
SqlDatabaseConfig Class Eco.Persistence.Configuration Namespace See Also
Collapse All
C#
public void SetKeyMapper(
    string name,
    System.Type mapper
);
Remarks

This is SetKeyMapper, a member of class SqlDatabaseConfig.

See Also
SqlDatabaseConfig Class
Eco.Persistence.Configuration Namespace


SqlDatabaseConfig.SetPMapper Method

SqlDatabaseConfig.SetPMapper Method
SqlDatabaseConfig Class Eco.Persistence.Configuration Namespace See Also
Collapse All
C#
public void SetPMapper(
    string name,
    System.Type mapper
);
Remarks

This is SetPMapper, a member of class SqlDatabaseConfig.

See Also
SqlDatabaseConfig Class
Eco.Persistence.Configuration Namespace


SqlDatabaseConfig Properties

SqlDatabaseConfig Properties
Public Properties
Collapse All

The properties of the SqlDatabaseConfig class are listed here.

Public Properties
Name | Description
AllowMetadataChangesInTransaction | This is AllowMetadataChangesInTransaction, a member of class SqlDatabaseConfig.
BooleanTrueLiteral | This is BooleanTrueLiteral, a member of class SqlDatabaseConfig.
ConfigValid | This is ConfigValid, a member of class SqlDatabaseConfig.
DateTimeFormat | This is DateTimeFormat, a member of class SqlDatabaseConfig.
DefaultDateTime | This is DefaultDateTime, a member of class SqlDatabaseConfig.
DefaultStringLength | This is DefaultStringLength, a member of class SqlDatabaseConfig.
DropColumnTemplate | This is DropColumnTemplate, a member of class SqlDatabaseConfig.
DropIndexTemplate | This is DropIndexTemplate, a member of class SqlDatabaseConfig.
DropTableTemplate | This is DropTableTemplate, a member of class SqlDatabaseConfig.
EffectiveSQLForNotNull | This is EffectiveSQLForNotNull, a member of class SqlDatabaseConfig.
FetchBlockSize | This is FetchBlockSize, a member of class SqlDatabaseConfig.
FetchIsolationLevel | This is FetchIsolationLevel, a member of class SqlDatabaseConfig.
ForceUpperCase | This is ForceUpperCase, a member of class SqlDatabaseConfig.
IdentifierCharacterMode | This is IdentifierCharacterMode, a member of class SqlDatabaseConfig.
IdMappers | This is IdMappers, a member of class SqlDatabaseConfig.
KeyMappers | do not translate
LengthFunctionName | This is LengthFunctionName, a member of class SqlDatabaseConfig.
MaxDbIdentifierLength | This is MaxDbIdentifierLength, a member of class SqlDatabaseConfig.
MaxIndexNameLength | This is MaxIndexNameLength, a member of class SqlDatabaseConfig.
MaxParamsInIdList | This is MaxParamsInIdList, a member of class SqlDatabaseConfig.
PersistenceMappers | do not translate
QuoteSqlNames | This is QuoteSqlNames, a member of class SqlDatabaseConfig.
ReservedWords | A comma separated list of words that words are used when deciding the default column and table names. If a column or table name would collide with a reserved word, a suffix will be added to avoid problems
ReservedWordsHash | This is ReservedWordsHash, a member of class SqlDatabaseConfig.
ReservedWordsList | This is ReservedWordsList, a member of class SqlDatabaseConfig.
SQLforAllowNull | SQL template for specifying that an attribute allows NULL. Leave empty for most databases, Sybase defaults a column to "NOT NULL", so sybase needs "NULL" here
SQLforNotNull | This is SQLforNotNull, a member of class SqlDatabaseConfig.
SqlPostQuoteChar | This is SqlPostQuoteChar, a member of class SqlDatabaseConfig.
SqlPreQuoteChar | This is SqlPreQuoteChar, a member of class SqlDatabaseConfig.
SqlQuoteChar | This is SqlQuoteChar, a member of class SqlDatabaseConfig.
SqlQuoteCharInString | This is SqlQuoteCharInString, a member of class SqlDatabaseConfig.
SqlScriptCommentStart | This is SqlScriptCommentStart, a member of class SqlDatabaseConfig.
SqlScriptCommentStop | This is SqlScriptCommentStop, a member of class SqlDatabaseConfig.
SqlScriptCommitTransaction | This is SqlScriptCommitTransaction, a member of class SqlDatabaseConfig.
SqlScriptRollBackTransaction | This is SqlScriptRollBackTransaction, a member of class SqlDatabaseConfig.
SqlScriptSeparator | This is SqlScriptSeparator, a member of class SqlDatabaseConfig.
SqlScriptStartTransaction | This is SqlScriptStartTransaction, a member of class SqlDatabaseConfig.
SqlScriptTerminator | This is SqlScriptTerminator, a member of class SqlDatabaseConfig.
SqlStringQuoteChar | This is SqlStringQuoteChar, a member of class SqlDatabaseConfig.
SupportsConstraintsInCreateTable | This is SupportsConstraintsInCreateTable, a member of class SqlDatabaseConfig.
SupportsDefaultColumnValues | This is SupportsDefaultColumnValues, a member of class SqlDatabaseConfig.
SystemTablePrefix | This is SystemTablePrefix, a member of class SqlDatabaseConfig.
TypeResolutionService | For internal use to aid designtime resolving of types
UpdateIsolationLevel | This is UpdateIsolationLevel, a member of class SqlDatabaseConfig.
UpperCaseFunctionName | This is UpperCaseFunctionName, a member of class SqlDatabaseConfig.
UseClockLog | This is UseClockLog, a member of class SqlDatabaseConfig.
UseSQL92Joins | This is UseSQL92Joins, a member of class SqlDatabaseConfig.
UseTimestamp | This is UseTimestamp, a member of class SqlDatabaseConfig.
UseTimestampColumn | This is UseTimestampColumn, a member of class SqlDatabaseConfig.
UseTimestampTable | This is UseTimestampTable, a member of class SqlDatabaseConfig.


SqlDatabaseConfig.AllowMetadataChangesInTransaction Property

SqlDatabaseConfig.AllowMetadataChangesInTransaction Property
SqlDatabaseConfig Class Eco.Persistence.Configuration Namespace See Also
Collapse All
C#
public bool AllowMetadataChangesInTransaction;
Remarks

This is AllowMetadataChangesInTransaction, a member of class SqlDatabaseConfig.

See Also
SqlDatabaseConfig Class
Eco.Persistence.Configuration Namespace


SqlDatabaseConfig.BooleanTrueLiteral Property

SqlDatabaseConfig.BooleanTrueLiteral Property
SqlDatabaseConfig Class Eco.Persistence.Configuration Namespace See Also
Collapse All
C#
public string BooleanTrueLiteral;
Remarks

This is BooleanTrueLiteral, a member of class SqlDatabaseConfig.

See Also
SqlDatabaseConfig Class
Eco.Persistence.Configuration Namespace


SqlDatabaseConfig.ConfigValid Property

SqlDatabaseConfig.ConfigValid Property
SqlDatabaseConfig Class Eco.Persistence.Configuration Namespace See Also
Collapse All
C#
public bool ConfigValid;
Remarks

This is ConfigValid, a member of class SqlDatabaseConfig.

See Also
SqlDatabaseConfig Class
Eco.Persistence.Configuration Namespace


SqlDatabaseConfig.DateTimeFormat Property

SqlDatabaseConfig.DateTimeFormat Property
SqlDatabaseConfig Class Eco.Persistence.Configuration Namespace See Also
Collapse All
C#
public string DateTimeFormat;
Remarks

This is DateTimeFormat, a member of class SqlDatabaseConfig.

See Also
SqlDatabaseConfig Class
Eco.Persistence.Configuration Namespace


SqlDatabaseConfig.DefaultDateTime Property

SqlDatabaseConfig.DefaultDateTime Property
SqlDatabaseConfig Class Eco.Persistence.Configuration Namespace See Also
Collapse All
C#
public DateTime DefaultDateTime;
Remarks

This is DefaultDateTime, a member of class SqlDatabaseConfig.

See Also
SqlDatabaseConfig Class
Eco.Persistence.Configuration Namespace


SqlDatabaseConfig.DefaultStringLength Property

SqlDatabaseConfig.DefaultStringLength Property
SqlDatabaseConfig Class Eco.Persistence.Configuration Namespace See Also
Collapse All
C#
public int DefaultStringLength;
Remarks

This is DefaultStringLength, a member of class SqlDatabaseConfig.

See Also
SqlDatabaseConfig Class
Eco.Persistence.Configuration Namespace


SqlDatabaseConfig.DropColumnTemplate Property

SqlDatabaseConfig.DropColumnTemplate Property
SqlDatabaseConfig Class Eco.Persistence.Configuration Namespace See Also
Collapse All
C#
public string DropColumnTemplate;
Remarks

This is DropColumnTemplate, a member of class SqlDatabaseConfig.

See Also
SqlDatabaseConfig Class
Eco.Persistence.Configuration Namespace


SqlDatabaseConfig.DropIndexTemplate Property

SqlDatabaseConfig.DropIndexTemplate Property
SqlDatabaseConfig Class Eco.Persistence.Configuration Namespace See Also
Collapse All
C#
public string DropIndexTemplate;
Remarks

This is DropIndexTemplate, a member of class SqlDatabaseConfig.

See Also
SqlDatabaseConfig Class
Eco.Persistence.Configuration Namespace


SqlDatabaseConfig.DropTableTemplate Property

SqlDatabaseConfig.DropTableTemplate Property
SqlDatabaseConfig Class Eco.Persistence.Configuration Namespace See Also
Collapse All
C#
public string DropTableTemplate;
Remarks

This is DropTableTemplate, a member of class SqlDatabaseConfig.

See Also
SqlDatabaseConfig Class
Eco.Persistence.Configuration Namespace


SqlDatabaseConfig.EffectiveSQLForNotNull Property

SqlDatabaseConfig.EffectiveSQLForNotNull Property
SqlDatabaseConfig Class Eco.Persistence.Configuration Namespace See Also
Collapse All
C#
public string EffectiveSQLForNotNull;
Remarks

This is EffectiveSQLForNotNull, a member of class SqlDatabaseConfig.

See Also
SqlDatabaseConfig Class
Eco.Persistence.Configuration Namespace


SqlDatabaseConfig.FetchBlockSize Property

SqlDatabaseConfig.FetchBlockSize Property
SqlDatabaseConfig Class Eco.Persistence.Configuration Namespace See Also
Collapse All
C#
public int FetchBlockSize;
Remarks

This is FetchBlockSize, a member of class SqlDatabaseConfig.

See Also
SqlDatabaseConfig Class
Eco.Persistence.Configuration Namespace


SqlDatabaseConfig.FetchIsolationLevel Property

SqlDatabaseConfig.FetchIsolationLevel Property
SqlDatabaseConfig Class Eco.Persistence.Configuration Namespace See Also
Collapse All
C#
public IsolationLevel FetchIsolationLevel;
Remarks

This is FetchIsolationLevel, a member of class SqlDatabaseConfig.

See Also
SqlDatabaseConfig Class
Eco.Persistence.Configuration Namespace


SqlDatabaseConfig.ForceUpperCase Property

SqlDatabaseConfig.ForceUpperCase Property
SqlDatabaseConfig Class Eco.Persistence.Configuration Namespace See Also
Collapse All
C#
public bool ForceUpperCase;
Remarks

This is ForceUpperCase, a member of class SqlDatabaseConfig.

See Also
SqlDatabaseConfig Class
Eco.Persistence.Configuration Namespace


SqlDatabaseConfig.IdentifierCharacterMode Property

SqlDatabaseConfig.IdentifierCharacterMode Property
SqlDatabaseConfig Class Eco.Persistence.Configuration Namespace See Also
Collapse All
C#
public IdentifierCharacterMode IdentifierCharacterMode;
Remarks

This is IdentifierCharacterMode, a member of class SqlDatabaseConfig.

See Also
SqlDatabaseConfig Class
Eco.Persistence.Configuration Namespace


SqlDatabaseConfig.IdMappers Property

SqlDatabaseConfig.IdMappers Property
SqlDatabaseConfig Class Eco.Persistence.Configuration Namespace See Also
Collapse All
C#
public KeyMapperDefinitionCollection IdMappers;
Remarks

This is IdMappers, a member of class SqlDatabaseConfig.

See Also
SqlDatabaseConfig Class
Eco.Persistence.Configuration Namespace


SqlDatabaseConfig.KeyMappers Property

SqlDatabaseConfig.KeyMappers Property
SqlDatabaseConfig Class Eco.Persistence.Configuration Namespace See Also
Collapse All
C#
public KeyMapperDefinitionCollection KeyMappers;
Remarks

do not translate

See Also
SqlDatabaseConfig Class
Eco.Persistence.Configuration Namespace


SqlDatabaseConfig.LengthFunctionName Property

SqlDatabaseConfig.LengthFunctionName Property
SqlDatabaseConfig Class Eco.Persistence.Configuration Namespace See Also
Collapse All
C#
public string LengthFunctionName;
Remarks

This is LengthFunctionName, a member of class SqlDatabaseConfig.

See Also
SqlDatabaseConfig Class
Eco.Persistence.Configuration Namespace


SqlDatabaseConfig.MaxDbIdentifierLength Property

SqlDatabaseConfig.MaxDbIdentifierLength Property
SqlDatabaseConfig Class Eco.Persistence.Configuration Namespace See Also
Collapse All
C#
public int MaxDbIdentifierLength;
Remarks

This is MaxDbIdentifierLength, a member of class SqlDatabaseConfig.

See Also
SqlDatabaseConfig Class
Eco.Persistence.Configuration Namespace


SqlDatabaseConfig.MaxIndexNameLength Property

SqlDatabaseConfig.MaxIndexNameLength Property
SqlDatabaseConfig Class Eco.Persistence.Configuration Namespace See Also
Collapse All
C#
public int MaxIndexNameLength;
Remarks

This is MaxIndexNameLength, a member of class SqlDatabaseConfig.

See Also
SqlDatabaseConfig Class
Eco.Persistence.Configuration Namespace


SqlDatabaseConfig.MaxParamsInIdList Property

SqlDatabaseConfig.MaxParamsInIdList Property
SqlDatabaseConfig Class Eco.Persistence.Configuration Namespace See Also
Collapse All
C#
public int MaxParamsInIdList;
Remarks

This is MaxParamsInIdList, a member of class SqlDatabaseConfig.

See Also
SqlDatabaseConfig Class
Eco.Persistence.Configuration Namespace


SqlDatabaseConfig.PersistenceMappers Property

SqlDatabaseConfig.PersistenceMappers Property
SqlDatabaseConfig Class Eco.Persistence.Configuration Namespace See Also
Collapse All
C#
public PersistenceMapperDefinitionCollection PersistenceMappers;
Remarks

do not translate

See Also
SqlDatabaseConfig Class
Eco.Persistence.Configuration Namespace


SqlDatabaseConfig.QuoteSqlNames Property

SqlDatabaseConfig.QuoteSqlNames Property
SqlDatabaseConfig Class Eco.Persistence.Configuration Namespace See Also
Collapse All
C#
public bool QuoteSqlNames;
Remarks

This is QuoteSqlNames, a member of class SqlDatabaseConfig.

See Also
SqlDatabaseConfig Class
Eco.Persistence.Configuration Namespace


SqlDatabaseConfig.ReservedWords Property

SqlDatabaseConfig.ReservedWords Property
SqlDatabaseConfig Class Eco.Persistence.Configuration Namespace See Also
Collapse All

A comma separated list of words that words are used when deciding the default column and table names. If a column or table name would collide with a reserved word, a suffix will be added to avoid problems

C#
public string ReservedWords;
See Also
SqlDatabaseConfig Class
Eco.Persistence.Configuration Namespace


SqlDatabaseConfig.ReservedWordsHash Property

SqlDatabaseConfig.ReservedWordsHash Property
SqlDatabaseConfig Class Eco.Persistence.Configuration Namespace See Also
Collapse All
C#
public Hashtable ReservedWordsHash;
Remarks

This is ReservedWordsHash, a member of class SqlDatabaseConfig.

See Also
SqlDatabaseConfig Class
Eco.Persistence.Configuration Namespace


SqlDatabaseConfig.ReservedWordsList Property

SqlDatabaseConfig.ReservedWordsList Property
SqlDatabaseConfig Class Eco.Persistence.Configuration Namespace See Also
Collapse All
C#
public IList<string> ReservedWordsList;
Remarks

This is ReservedWordsList, a member of class SqlDatabaseConfig.

See Also
SqlDatabaseConfig Class
Eco.Persistence.Configuration Namespace


SqlDatabaseConfig.SQLforAllowNull Property

SqlDatabaseConfig.SQLforAllowNull Property
SqlDatabaseConfig Class Eco.Persistence.Configuration Namespace See Also
Collapse All

SQL template for specifying that an attribute allows NULL. Leave empty for most databases, Sybase defaults a column to "NOT NULL", so sybase needs "NULL" here

C#
public string SQLforAllowNull;
See Also
SqlDatabaseConfig Class
Eco.Persistence.Configuration Namespace


SqlDatabaseConfig.SQLforNotNull Property

SqlDatabaseConfig.SQLforNotNull Property
SqlDatabaseConfig Class Eco.Persistence.Configuration Namespace See Also
Collapse All
C#
public string SQLforNotNull;
Remarks

This is SQLforNotNull, a member of class SqlDatabaseConfig.

See Also
SqlDatabaseConfig Class
Eco.Persistence.Configuration Namespace


SqlDatabaseConfig.SqlPostQuoteChar Property

SqlDatabaseConfig.SqlPostQuoteChar Property
SqlDatabaseConfig Class Eco.Persistence.Configuration Namespace See Also
Collapse All
C#
public string SqlPostQuoteChar;
Remarks

This is SqlPostQuoteChar, a member of class SqlDatabaseConfig.

See Also
SqlDatabaseConfig Class
Eco.Persistence.Configuration Namespace


SqlDatabaseConfig.SqlPreQuoteChar Property

SqlDatabaseConfig.SqlPreQuoteChar Property
SqlDatabaseConfig Class Eco.Persistence.Configuration Namespace See Also
Collapse All
C#
public string SqlPreQuoteChar;
Remarks

This is SqlPreQuoteChar, a member of class SqlDatabaseConfig.

See Also
SqlDatabaseConfig Class
Eco.Persistence.Configuration Namespace


SqlDatabaseConfig.SqlQuoteChar Property

SqlDatabaseConfig.SqlQuoteChar Property
SqlDatabaseConfig Class Eco.Persistence.Configuration Namespace See Also
Collapse All
C#
public string SqlQuoteChar;
Remarks

This is SqlQuoteChar, a member of class SqlDatabaseConfig.

See Also
SqlDatabaseConfig Class
Eco.Persistence.Configuration Namespace


SqlDatabaseConfig.SqlQuoteCharInString Property

SqlDatabaseConfig.SqlQuoteCharInString Property
SqlDatabaseConfig Class Eco.Persistence.Configuration Namespace See Also
Collapse All
C#
public string SqlQuoteCharInString;
Remarks

This is SqlQuoteCharInString, a member of class SqlDatabaseConfig.

See Also
SqlDatabaseConfig Class
Eco.Persistence.Configuration Namespace


SqlDatabaseConfig.SqlScriptCommentStart Property

SqlDatabaseConfig.SqlScriptCommentStart Property
SqlDatabaseConfig Class Eco.Persistence.Configuration Namespace See Also
Collapse All
C#
public string SqlScriptCommentStart;
Remarks

This is SqlScriptCommentStart, a member of class SqlDatabaseConfig.

See Also
SqlDatabaseConfig Class
Eco.Persistence.Configuration Namespace


SqlDatabaseConfig.SqlScriptCommentStop Property

SqlDatabaseConfig.SqlScriptCommentStop Property
SqlDatabaseConfig Class Eco.Persistence.Configuration Namespace See Also
Collapse All
C#
public string SqlScriptCommentStop;
Remarks

This is SqlScriptCommentStop, a member of class SqlDatabaseConfig.

See Also
SqlDatabaseConfig Class
Eco.Persistence.Configuration Namespace


SqlDatabaseConfig.SqlScriptCommitTransaction Property

SqlDatabaseConfig.SqlScriptCommitTransaction Property
SqlDatabaseConfig Class Eco.Persistence.Configuration Namespace See Also
Collapse All
C#
public string SqlScriptCommitTransaction;
Remarks

This is SqlScriptCommitTransaction, a member of class SqlDatabaseConfig.

See Also
SqlDatabaseConfig Class
Eco.Persistence.Configuration Namespace


SqlDatabaseConfig.SqlScriptRollBackTransaction Property

SqlDatabaseConfig.SqlScriptRollBackTransaction Property
SqlDatabaseConfig Class Eco.Persistence.Configuration Namespace See Also
Collapse All
C#
public string SqlScriptRollBackTransaction;
Remarks

This is SqlScriptRollBackTransaction, a member of class SqlDatabaseConfig.

See Also
SqlDatabaseConfig Class
Eco.Persistence.Configuration Namespace


SqlDatabaseConfig.SqlScriptSeparator Property

SqlDatabaseConfig.SqlScriptSeparator Property
SqlDatabaseConfig Class Eco.Persistence.Configuration Namespace See Also
Collapse All
C#
public string SqlScriptSeparator;
Remarks

This is SqlScriptSeparator, a member of class SqlDatabaseConfig.

See Also
SqlDatabaseConfig Class
Eco.Persistence.Configuration Namespace


SqlDatabaseConfig.SqlScriptStartTransaction Property

SqlDatabaseConfig.SqlScriptStartTransaction Property
SqlDatabaseConfig Class Eco.Persistence.Configuration Namespace See Also
Collapse All
C#
public string SqlScriptStartTransaction;
Remarks

This is SqlScriptStartTransaction, a member of class SqlDatabaseConfig.

See Also
SqlDatabaseConfig Class
Eco.Persistence.Configuration Namespace


SqlDatabaseConfig.SqlScriptTerminator Property

SqlDatabaseConfig.SqlScriptTerminator Property
SqlDatabaseConfig Class Eco.Persistence.Configuration Namespace See Also
Collapse All
C#
public string SqlScriptTerminator;
Remarks

This is SqlScriptTerminator, a member of class SqlDatabaseConfig.

See Also
SqlDatabaseConfig Class
Eco.Persistence.Configuration Namespace


SqlDatabaseConfig.SqlStringQuoteChar Property

SqlDatabaseConfig.SqlStringQuoteChar Property
SqlDatabaseConfig Class Eco.Persistence.Configuration Namespace See Also
Collapse All
C#
public string SqlStringQuoteChar;
Remarks

This is SqlStringQuoteChar, a member of class SqlDatabaseConfig.

See Also
SqlDatabaseConfig Class
Eco.Persistence.Configuration Namespace


SqlDatabaseConfig.SupportsConstraintsInCreateTable Property

SqlDatabaseConfig.SupportsConstraintsInCreateTable Property
SqlDatabaseConfig Class Eco.Persistence.Configuration Namespace See Also
Collapse All
C#
public bool SupportsConstraintsInCreateTable;
Remarks

This is SupportsConstraintsInCreateTable, a member of class SqlDatabaseConfig.

See Also
SqlDatabaseConfig Class
Eco.Persistence.Configuration Namespace


SqlDatabaseConfig.SupportsDefaultColumnValues Property

SqlDatabaseConfig.SupportsDefaultColumnValues Property
SqlDatabaseConfig Class Eco.Persistence.Configuration Namespace See Also
Collapse All
C#
public bool SupportsDefaultColumnValues;
Remarks

This is SupportsDefaultColumnValues, a member of class SqlDatabaseConfig.

See Also
SqlDatabaseConfig Class
Eco.Persistence.Configuration Namespace


SqlDatabaseConfig.SystemTablePrefix Property

SqlDatabaseConfig.SystemTablePrefix Property
SqlDatabaseConfig Class Eco.Persistence.Configuration Namespace See Also
Collapse All
C#
public string SystemTablePrefix;
Remarks

This is SystemTablePrefix, a member of class SqlDatabaseConfig.

See Also
SqlDatabaseConfig Class
Eco.Persistence.Configuration Namespace


SqlDatabaseConfig.TypeResolutionService Property

SqlDatabaseConfig.TypeResolutionService Property
SqlDatabaseConfig Class Eco.Persistence.Configuration Namespace See Also
Collapse All

For internal use to aid designtime resolving of types

C#
public ITypeResolutionService TypeResolutionService;
See Also
SqlDatabaseConfig Class
Eco.Persistence.Configuration Namespace


SqlDatabaseConfig.UpdateIsolationLevel Property

SqlDatabaseConfig.UpdateIsolationLevel Property
SqlDatabaseConfig Class Eco.Persistence.Configuration Namespace See Also
Collapse All
C#
public IsolationLevel UpdateIsolationLevel;
Remarks

This is UpdateIsolationLevel, a member of class SqlDatabaseConfig.

See Also
SqlDatabaseConfig Class
Eco.Persistence.Configuration Namespace


SqlDatabaseConfig.UpperCaseFunctionName Property

SqlDatabaseConfig.UpperCaseFunctionName Property
SqlDatabaseConfig Class Eco.Persistence.Configuration Namespace See Also
Collapse All
C#
public string UpperCaseFunctionName;
Remarks

This is UpperCaseFunctionName, a member of class SqlDatabaseConfig.

See Also
SqlDatabaseConfig Class
Eco.Persistence.Configuration Namespace


SqlDatabaseConfig.UseClockLog Property

SqlDatabaseConfig.UseClockLog Property
SqlDatabaseConfig Class Eco.Persistence.Configuration Namespace See Also
Collapse All
C#
public bool UseClockLog;
Remarks

This is UseClockLog, a member of class SqlDatabaseConfig.

See Also
SqlDatabaseConfig Class
Eco.Persistence.Configuration Namespace


SqlDatabaseConfig.UseSQL92Joins Property

SqlDatabaseConfig.UseSQL92Joins Property
SqlDatabaseConfig Class Eco.Persistence.Configuration Namespace See Also
Collapse All
C#
public bool UseSQL92Joins;
Remarks

This is UseSQL92Joins, a member of class SqlDatabaseConfig.

See Also
SqlDatabaseConfig Class
Eco.Persistence.Configuration Namespace


SqlDatabaseConfig.UseTimestamp Property

SqlDatabaseConfig.UseTimestamp Property
SqlDatabaseConfig Class Eco.Persistence.Configuration Namespace See Also
Collapse All
C#
public bool UseTimestamp;
Remarks

This is UseTimestamp, a member of class SqlDatabaseConfig.

See Also
SqlDatabaseConfig Class
Eco.Persistence.Configuration Namespace


SqlDatabaseConfig.UseTimestampColumn Property

SqlDatabaseConfig.UseTimestampColumn Property
SqlDatabaseConfig Class Eco.Persistence.Configuration Namespace See Also
Collapse All
C#
public bool UseTimestampColumn;
Remarks

This is UseTimestampColumn, a member of class SqlDatabaseConfig.

See Also
SqlDatabaseConfig Class
Eco.Persistence.Configuration Namespace


SqlDatabaseConfig.UseTimestampTable Property

SqlDatabaseConfig.UseTimestampTable Property
SqlDatabaseConfig Class Eco.Persistence.Configuration Namespace See Also
Collapse All
C#
public bool UseTimestampTable;
Remarks

This is UseTimestampTable, a member of class SqlDatabaseConfig.

See Also
SqlDatabaseConfig Class
Eco.Persistence.Configuration Namespace


SqlDatabaseConfigConverter Class

SqlDatabaseConfigConverter Class
Inheritance Hierarchy See Also
Collapse All
C#
public sealed class SqlDatabaseConfigConverter : ExpandableObjectConverter;
Remarks

This is class Eco.Persistence.Configuration.SqlDatabaseConfigConverter.

Inheritance Hierarchy
Eco.Persistence.Configuration.SqlDatabaseConfigConverter
File

SqlDatabaseConfig.cs

See Also
Inheritance Hierarchy


SqlDatabaseConfigConverter Methods

SqlDatabaseConfigConverter Methods
Public Methods
Collapse All

The methods of the SqlDatabaseConfigConverter class are listed here.

Public Methods
Name | Description
CanConvertTo | This is CanConvertTo, a member of class SqlDatabaseConfigConverter.
ConvertTo | This is ConvertTo, a member of class SqlDatabaseConfigConverter.


SqlDatabaseConfigConverter.CanConvertTo Method

SqlDatabaseConfigConverter.CanConvertTo Method
SqlDatabaseConfigConverter Class Eco.Persistence.Configuration Namespace See Also
Collapse All
C#
public override bool CanConvertTo(
    ITypeDescriptorContext context,
    System.Type destinationType
);
Remarks

This is CanConvertTo, a member of class SqlDatabaseConfigConverter.

See Also
SqlDatabaseConfigConverter Class
Eco.Persistence.Configuration Namespace


SqlDatabaseConfigConverter.ConvertTo Method

SqlDatabaseConfigConverter.ConvertTo Method
SqlDatabaseConfigConverter Class Eco.Persistence.Configuration Namespace See Also
Collapse All
C#
public override object ConvertTo(
    ITypeDescriptorContext context,
    CultureInfo culture,
    object value,
    System.Type destinationType
);
Remarks

This is ConvertTo, a member of class SqlDatabaseConfigConverter.

See Also
SqlDatabaseConfigConverter Class
Eco.Persistence.Configuration Namespace


StringLiterals Class

StringLiterals Class
Inheritance Hierarchy See Also
Collapse All
C#
public sealed class StringLiterals;
Remarks

This is class Eco.Persistence.Configuration.StringLiterals.

Inheritance Hierarchy
Eco.Persistence.Configuration.StringLiterals
File

InitializeEngine.cs

See Also
Inheritance Hierarchy


StringLiterals Fields

StringLiterals Fields
Public Fields
Collapse All

The fields of the StringLiterals class are listed here.

Public Fields
Name | Description
Attribute | This is Attribute, a member of class StringLiterals.
AutoGuid | This is AutoGuid, a member of class StringLiterals.
AutoInc | This is AutoInc, a member of class StringLiterals.
AutoInc16 | This is AutoInc16, a member of class StringLiterals.
AutoIncDecimal | This is AutoIncDecimal, a member of class StringLiterals.
Enum | This is Enum, a member of class StringLiterals.
Guid | This is Guid, a member of class StringLiterals.
GuidAsVarChar32 | This is GuidAsVarChar32, a member of class StringLiterals.
ReservedWords_Access | This is ReservedWords_Access, a member of class StringLiterals.
ReservedWords_Advantage | This is ReservedWords_Advantage, a member of class StringLiterals.
ReservedWords_ANSISQL92 | This is ReservedWords_ANSISQL92, a member of class StringLiterals.
ReservedWords_Blackfish | This is ReservedWords_Blackfish, a member of class StringLiterals.
ReservedWords_DB2 | This is ReservedWords_DB2, a member of class StringLiterals.
ReservedWords_DBISAM | This is ReservedWords_DBISAM, a member of class StringLiterals.
ReservedWords_Default | This is ReservedWords_Default, a member of class StringLiterals.
ReservedWords_Informix | This is ReservedWords_Informix, a member of class StringLiterals.
ReservedWords_InterbaseSQLDialect1 | This is ReservedWords_InterbaseSQLDialect1, a member of class StringLiterals.
ReservedWords_InterbaseSQLDialect3 | This is ReservedWords_InterbaseSQLDialect3, a member of class StringLiterals.
ReservedWords_MySql5 | This is ReservedWords_MySql5, a member of class StringLiterals.
ReservedWords_MySqlCommon | This is ReservedWords_MySqlCommon, a member of class StringLiterals.
ReservedWords_Oracle | This is ReservedWords_Oracle, a member of class StringLiterals.
ReservedWords_SqlServer | This is ReservedWords_SqlServer, a member of class StringLiterals.
ReservedWords_Sybase | This is ReservedWords_Sybase, a member of class StringLiterals.
SystemBoolean | This is SystemBoolean, a member of class StringLiterals.
SystemByte | This is SystemByte, a member of class StringLiterals.
SystemByteArr | This is SystemByteArr, a member of class StringLiterals.
SystemChar | This is SystemChar, a member of class StringLiterals.
SystemDateTime | This is SystemDateTime, a member of class StringLiterals.
SystemDecimal | This is SystemDecimal, a member of class StringLiterals.
SystemDouble | This is SystemDouble, a member of class StringLiterals.
SystemDrawingColor | This is SystemDrawingColor, a member of class StringLiterals.
SystemGuid | This is SystemGuid, a member of class StringLiterals.
SystemInt16 | This is SystemInt16, a member of class StringLiterals.
SystemInt32 | This is SystemInt32, a member of class StringLiterals.
SystemInt64 | This is SystemInt64, a member of class StringLiterals.
SystemSByte | This is SystemSByte, a member of class StringLiterals.
SystemSingle | This is SystemSingle, a member of class StringLiterals.
SystemString | This is SystemString, a member of class StringLiterals.
SystemTimeSpan | This is SystemTimeSpan, a member of class StringLiterals.
SystemUInt16 | This is SystemUInt16, a member of class StringLiterals.
SystemUInt32 | This is SystemUInt32, a member of class StringLiterals.
SystemUInt64 | This is SystemUInt64, a member of class StringLiterals.


StringLiterals.Attribute Field

StringLiterals.Attribute Field
StringLiterals Class Eco.Persistence.Configuration Namespace See Also
Collapse All
C#
public const string Attribute = "Attribute";
Remarks

This is Attribute, a member of class StringLiterals.

See Also
StringLiterals Class
Eco.Persistence.Configuration Namespace


StringLiterals.AutoGuid Field

StringLiterals.AutoGuid Field
StringLiterals Class Eco.Persistence.Configuration Namespace See Also
Collapse All
C#
public const string AutoGuid = "AutoGuid";
Remarks

This is AutoGuid, a member of class StringLiterals.

See Also
StringLiterals Class
Eco.Persistence.Configuration Namespace


StringLiterals.AutoInc Field

StringLiterals.AutoInc Field
StringLiterals Class Eco.Persistence.Configuration Namespace See Also
Collapse All
C#
public const string AutoInc = "AutoInc";
Remarks

This is AutoInc, a member of class StringLiterals.

See Also
StringLiterals Class
Eco.Persistence.Configuration Namespace


StringLiterals.AutoInc16 Field

StringLiterals.AutoInc16 Field
StringLiterals Class Eco.Persistence.Configuration Namespace See Also
Collapse All
C#
public const string AutoInc16 = "AutoInc16";
Remarks

This is AutoInc16, a member of class StringLiterals.

See Also
StringLiterals Class
Eco.Persistence.Configuration Namespace


StringLiterals.AutoIncDecimal Field

StringLiterals.AutoIncDecimal Field
StringLiterals Class Eco.Persistence.Configuration Namespace See Also
Collapse All
C#
public const string AutoIncDecimal = "AutoIncDecimal";
Remarks

This is AutoIncDecimal, a member of class StringLiterals.

See Also
StringLiterals Class
Eco.Persistence.Configuration Namespace


StringLiterals.Enum Field

StringLiterals.Enum Field
StringLiterals Class Eco.Persistence.Configuration Namespace See Also
Collapse All
C#
public const string Enum = "Enum";
Remarks

This is Enum, a member of class StringLiterals.

See Also
StringLiterals Class
Eco.Persistence.Configuration Namespace


StringLiterals.Guid Field

StringLiterals.Guid Field
StringLiterals Class Eco.Persistence.Configuration Namespace See Also
Collapse All
C#
public const string Guid = "Guid";
Remarks

This is Guid, a member of class StringLiterals.

See Also
StringLiterals Class
Eco.Persistence.Configuration Namespace


StringLiterals.GuidAsVarChar32 Field

StringLiterals.GuidAsVarChar32 Field
StringLiterals Class Eco.Persistence.Configuration Namespace See Also
Collapse All
C#
public const string GuidAsVarChar32 = "GuidAsVarChar32";
Remarks

This is GuidAsVarChar32, a member of class StringLiterals.

See Also
StringLiterals Class
Eco.Persistence.Configuration Namespace


StringLiterals.ReservedWords_Access Field

StringLiterals.ReservedWords_Access Field
StringLiterals Class Eco.Persistence.Configuration Namespace See Also
Collapse All
C#
public const string ReservedWords_Access = "Sql_Access.txt";
Remarks

This is ReservedWords_Access, a member of class StringLiterals.

See Also
StringLiterals Class
Eco.Persistence.Configuration Namespace


StringLiterals.ReservedWords_Advantage Field

StringLiterals.ReservedWords_Advantage Field
StringLiterals Class Eco.Persistence.Configuration Namespace See Also
Collapse All
C#
public const string ReservedWords_Advantage = "Sql_Advantage.txt";
Remarks

This is ReservedWords_Advantage, a member of class StringLiterals.

See Also
StringLiterals Class
Eco.Persistence.Configuration Namespace


StringLiterals.ReservedWords_ANSISQL92 Field

StringLiterals.ReservedWords_ANSISQL92 Field
StringLiterals Class Eco.Persistence.Configuration Namespace See Also
Collapse All
C#
public const string ReservedWords_ANSISQL92 = "Sql_AnsiSql92.txt";
Remarks

This is ReservedWords_ANSISQL92, a member of class StringLiterals.

See Also
StringLiterals Class
Eco.Persistence.Configuration Namespace


StringLiterals.ReservedWords_Blackfish Field

StringLiterals.ReservedWords_Blackfish Field
StringLiterals Class Eco.Persistence.Configuration Namespace See Also
Collapse All
C#
public const string ReservedWords_Blackfish = "Sql_Blackfish.txt";
Remarks

This is ReservedWords_Blackfish, a member of class StringLiterals.

See Also
StringLiterals Class
Eco.Persistence.Configuration Namespace


StringLiterals.ReservedWords_DB2 Field

StringLiterals.ReservedWords_DB2 Field
StringLiterals Class Eco.Persistence.Configuration Namespace See Also
Collapse All
C#
public const string ReservedWords_DB2 = "Sql_DB2.txt";
Remarks

This is ReservedWords_DB2, a member of class StringLiterals.

See Also
StringLiterals Class
Eco.Persistence.Configuration Namespace


StringLiterals.ReservedWords_DBISAM Field

StringLiterals.ReservedWords_DBISAM Field
StringLiterals Class Eco.Persistence.Configuration Namespace See Also
Collapse All
C#
public const string ReservedWords_DBISAM = "Sql_DBISAM.txt";
Remarks

This is ReservedWords_DBISAM, a member of class StringLiterals.

See Also
StringLiterals Class
Eco.Persistence.Configuration Namespace


StringLiterals.ReservedWords_Default Field

StringLiterals.ReservedWords_Default Field
StringLiterals Class Eco.Persistence.Configuration Namespace See Also
Collapse All
C#
public const string ReservedWords_Default = "Sql_Default.txt";
Remarks

This is ReservedWords_Default, a member of class StringLiterals.

See Also
StringLiterals Class
Eco.Persistence.Configuration Namespace


StringLiterals.ReservedWords_Informix Field

StringLiterals.ReservedWords_Informix Field
StringLiterals Class Eco.Persistence.Configuration Namespace See Also
Collapse All
C#
public const string ReservedWords_Informix = "Sql_Informix.txt";
Remarks

This is ReservedWords_Informix, a member of class StringLiterals.

See Also
StringLiterals Class
Eco.Persistence.Configuration Namespace


StringLiterals.ReservedWords_InterbaseSQLDialect1 Field

StringLiterals.ReservedWords_InterbaseSQLDialect1 Field
StringLiterals Class Eco.Persistence.Configuration Namespace See Also
Collapse All
C#
public const string ReservedWords_InterbaseSQLDialect1 = "Sql_InterbaseSQLDialect1.txt";
Remarks

This is ReservedWords_InterbaseSQLDialect1, a member of class StringLiterals.

See Also
StringLiterals Class
Eco.Persistence.Configuration Namespace


StringLiterals.ReservedWords_InterbaseSQLDialect3 Field

StringLiterals.ReservedWords_InterbaseSQLDialect3 Field
StringLiterals Class Eco.Persistence.Configuration Namespace See Also
Collapse All
C#
public const string ReservedWords_InterbaseSQLDialect3 = "Sql_InterbaseSQLDialect3.txt";
Remarks

This is ReservedWords_InterbaseSQLDialect3, a member of class StringLiterals.

See Also
StringLiterals Class
Eco.Persistence.Configuration Namespace


StringLiterals.ReservedWords_MySql5 Field

StringLiterals.ReservedWords_MySql5 Field
StringLiterals Class Eco.Persistence.Configuration Namespace See Also
Collapse All
C#
public const string ReservedWords_MySql5 = "Sql_MySql5.txt";
Remarks

This is ReservedWords_MySql5, a member of class StringLiterals.

See Also
StringLiterals Class
Eco.Persistence.Configuration Namespace


StringLiterals.ReservedWords_MySqlCommon Field

StringLiterals.ReservedWords_MySqlCommon Field
StringLiterals Class Eco.Persistence.Configuration Namespace See Also
Collapse All
C#
public const string ReservedWords_MySqlCommon = "Sql_MySqlCommon.txt";
Remarks

This is ReservedWords_MySqlCommon, a member of class StringLiterals.

See Also
StringLiterals Class
Eco.Persistence.Configuration Namespace


StringLiterals.ReservedWords_Oracle Field

StringLiterals.ReservedWords_Oracle Field
StringLiterals Class Eco.Persistence.Configuration Namespace See Also
Collapse All
C#
public const string ReservedWords_Oracle = "Sql_Oracle.txt";
Remarks

This is ReservedWords_Oracle, a member of class StringLiterals.

See Also
StringLiterals Class
Eco.Persistence.Configuration Namespace


StringLiterals.ReservedWords_SqlServer Field

StringLiterals.ReservedWords_SqlServer Field
StringLiterals Class Eco.Persistence.Configuration Namespace See Also
Collapse All
C#
public const string ReservedWords_SqlServer = "Sql_SqlServer.txt";
Remarks

This is ReservedWords_SqlServer, a member of class StringLiterals.

See Also
StringLiterals Class
Eco.Persistence.Configuration Namespace


StringLiterals.ReservedWords_Sybase Field

StringLiterals.ReservedWords_Sybase Field
StringLiterals Class Eco.Persistence.Configuration Namespace See Also
Collapse All
C#
public const string ReservedWords_Sybase = "Sql_Sybase.txt";
Remarks

This is ReservedWords_Sybase, a member of class StringLiterals.

See Also
StringLiterals Class
Eco.Persistence.Configuration Namespace


StringLiterals.SystemBoolean Field

StringLiterals.SystemBoolean Field
StringLiterals Class Eco.Persistence.Configuration Namespace See Also
Collapse All
C#
public const string SystemBoolean = "System.Boolean";
Remarks

This is SystemBoolean, a member of class StringLiterals.

See Also
StringLiterals Class
Eco.Persistence.Configuration Namespace


StringLiterals.SystemByte Field

StringLiterals.SystemByte Field
StringLiterals Class Eco.Persistence.Configuration Namespace See Also
Collapse All
C#
public const string SystemByte = "System.Byte";
Remarks

This is SystemByte, a member of class StringLiterals.

See Also
StringLiterals Class
Eco.Persistence.Configuration Namespace


StringLiterals.SystemByteArr Field

StringLiterals.SystemByteArr Field
StringLiterals Class Eco.Persistence.Configuration Namespace See Also
Collapse All
C#
public const string SystemByteArr = "System.Byte[]";
Remarks

This is SystemByteArr, a member of class StringLiterals.

See Also
StringLiterals Class
Eco.Persistence.Configuration Namespace


StringLiterals.SystemChar Field

StringLiterals.SystemChar Field
StringLiterals Class Eco.Persistence.Configuration Namespace See Also
Collapse All
C#
public const string SystemChar = "System.Char";
Remarks

This is SystemChar, a member of class StringLiterals.

See Also
StringLiterals Class
Eco.Persistence.Configuration Namespace


StringLiterals.SystemDateTime Field

StringLiterals.SystemDateTime Field
StringLiterals Class Eco.Persistence.Configuration Namespace See Also
Collapse All
C#
public const string SystemDateTime = "System.DateTime";
Remarks

This is SystemDateTime, a member of class StringLiterals.

See Also
StringLiterals Class
Eco.Persistence.Configuration Namespace


StringLiterals.SystemDecimal Field

StringLiterals.SystemDecimal Field
StringLiterals Class Eco.Persistence.Configuration Namespace See Also
Collapse All
C#
public const string SystemDecimal = "System.Decimal";
Remarks

This is SystemDecimal, a member of class StringLiterals.

See Also
StringLiterals Class
Eco.Persistence.Configuration Namespace


StringLiterals.SystemDouble Field

StringLiterals.SystemDouble Field
StringLiterals Class Eco.Persistence.Configuration Namespace See Also
Collapse All
C#
public const string SystemDouble = "System.Double";
Remarks

This is SystemDouble, a member of class StringLiterals.

See Also
StringLiterals Class
Eco.Persistence.Configuration Namespace


StringLiterals.SystemDrawingColor Field

StringLiterals.SystemDrawingColor Field
StringLiterals Class Eco.Persistence.Configuration Namespace See Also
Collapse All
C#
public const string SystemDrawingColor = "System.Drawing.Color";
Remarks

This is SystemDrawingColor, a member of class StringLiterals.

See Also
StringLiterals Class
Eco.Persistence.Configuration Namespace


StringLiterals.SystemGuid Field

StringLiterals.SystemGuid Field
StringLiterals Class Eco.Persistence.Configuration Namespace See Also
Collapse All
C#
public const string SystemGuid = "System.Guid";
Remarks

This is SystemGuid, a member of class StringLiterals.

See Also
StringLiterals Class
Eco.Persistence.Configuration Namespace


StringLiterals.SystemInt16 Field

StringLiterals.SystemInt16 Field
StringLiterals Class Eco.Persistence.Configuration Namespace See Also
Collapse All
C#
public const string SystemInt16 = "System.Int16";
Remarks

This is SystemInt16, a member of class StringLiterals.

See Also
StringLiterals Class
Eco.Persistence.Configuration Namespace


StringLiterals.SystemInt32 Field

StringLiterals.SystemInt32 Field
StringLiterals Class Eco.Persistence.Configuration Namespace See Also
Collapse All
C#
public const string SystemInt32 = "System.Int32";
Remarks

This is SystemInt32, a member of class StringLiterals.

See Also
StringLiterals Class
Eco.Persistence.Configuration Namespace


StringLiterals.SystemInt64 Field

StringLiterals.SystemInt64 Field
StringLiterals Class Eco.Persistence.Configuration Namespace See Also
Collapse All
C#
public const string SystemInt64 = "System.Int64";
Remarks

This is SystemInt64, a member of class StringLiterals.

See Also
StringLiterals Class
Eco.Persistence.Configuration Namespace


StringLiterals.SystemSByte Field

StringLiterals.SystemSByte Field
StringLiterals Class Eco.Persistence.Configuration Namespace See Also
Collapse All
C#
public const string SystemSByte = "System.SByte";
Remarks

This is SystemSByte, a member of class StringLiterals.

See Also
StringLiterals Class
Eco.Persistence.Configuration Namespace


StringLiterals.SystemSingle Field

StringLiterals.SystemSingle Field
StringLiterals Class Eco.Persistence.Configuration Namespace See Also
Collapse All
C#
public const string SystemSingle = "System.Single";
Remarks

This is SystemSingle, a member of class StringLiterals.

See Also
StringLiterals Class
Eco.Persistence.Configuration Namespace


StringLiterals.SystemString Field

StringLiterals.SystemString Field
StringLiterals Class Eco.Persistence.Configuration Namespace See Also
Collapse All
C#
public const string SystemString = "System.String";
Remarks

This is SystemString, a member of class StringLiterals.

See Also
StringLiterals Class
Eco.Persistence.Configuration Namespace


StringLiterals.SystemTimeSpan Field

StringLiterals.SystemTimeSpan Field
StringLiterals Class Eco.Persistence.Configuration Namespace See Also
Collapse All
C#
public const string SystemTimeSpan = "System.TimeSpan";
Remarks

This is SystemTimeSpan, a member of class StringLiterals.

See Also
StringLiterals Class
Eco.Persistence.Configuration Namespace


StringLiterals.SystemUInt16 Field

StringLiterals.SystemUInt16 Field
StringLiterals Class Eco.Persistence.Configuration Namespace See Also
Collapse All
C#
public const string SystemUInt16 = "System.UInt16";
Remarks

This is SystemUInt16, a member of class StringLiterals.

See Also
StringLiterals Class
Eco.Persistence.Configuration Namespace


StringLiterals.SystemUInt32 Field

StringLiterals.SystemUInt32 Field
StringLiterals Class Eco.Persistence.Configuration Namespace See Also
Collapse All
C#
public const string SystemUInt32 = "System.UInt32";
Remarks

This is SystemUInt32, a member of class StringLiterals.

See Also
StringLiterals Class
Eco.Persistence.Configuration Namespace


StringLiterals.SystemUInt64 Field

StringLiterals.SystemUInt64 Field
StringLiterals Class Eco.Persistence.Configuration Namespace See Also
Collapse All
C#
public const string SystemUInt64 = "System.UInt64";
Remarks

This is SystemUInt64, a member of class StringLiterals.

See Also
StringLiterals Class
Eco.Persistence.Configuration Namespace


Eco.Persistence.Configuration.DataBaseEngine Enumeration

Eco.Persistence.Configuration.DataBaseEngine Enumeration

Enumeration passed to DatabaseEngineInitializer.InitializeDbEngineSettings to quickly set the correct properties for an engine.

C#
public enum DataBaseEngine : long {
  Unknown = 0,
  InterbaseSqlDialect1 = 1<<1,
  InterbaseSqlDialect3 = 1<<2,
  GenericANSISQL92 = 1<<3,
  SqlServerBdp = 1<<4,
  SqlServerSqlClient = 1<<5,
  SqlServer7Bdp = 1<<6,
  SqlServer7SqlClient = 1<<7,
  DBISAM = 1<<8,
  OracleBdp = 1<<9,
  Advantage = 1<<10,
  Informix = 1<<11,
  DB2 = 1<<12,
  SqlServerMBCSBdp = 1<<13,
  SqlServerMBCSSqlClient = 1<<14,
  SqlServer7MBCSBdp = 1<<15,
  SqlServer7MBCSSqlClient = 1<<16,
  OracleBdpMBCS = 1<<17,
  InterbaseSqlDialect3MBCS = 1<<18,
  DB2MBCS = 1<<19,
  SybaseCommon = 1<<20,
  SybaseBdp = 1<<21,
  AccessBdp = 1<<22,
  AccessSqlClient = 1<<23,
  Blackfish = 1<<24,
  BlackfishBdp = 1<<25,
  MySql4Bdp = 1<<26,
  MySql4Mys = 1<<27,
  MySql5Bdp = 1<<28,
  MySql5Mys = 1<<29,
  OracleClient = 1<<30,
  OracleDbx = ((long)1)<<31,
  AccessDbx = ((long)1)<<32,
  InterbaseSqlDialect3Dbx = ((long)1)<<33,
  MySql4Dbx = ((long)1)<<34,
  SqlServerDbx = ((long)1)<<35,
  SybaseDbx = ((long)1)<<36,
  SqlServerMBCSDbx = ((long)1)<<37,
  SqlServer7Dbx = ((long)1)<<38,
  SqlServer7MBCSDbx = ((long)1)<<39,
  BlackfishDbx = ((long)1)<<40,
  MySql5Dbx = ((long)1)<<41,
  DB2Dbx = ((long)1)<<42,
  OracleDbxMBCS = ((long)1)<<43,
  InterbaseSqlDialect3DbxMBCS = ((long)1)<<44,
  Firebird = ((long)1)<<45
}
Members
Members | Description
InterbaseSqlDialect1 | Interbase, SQL dialect 1
InterbaseSqlDialect3 | Interbase, SQL dialect 3
GenericANSISQL92 | ANSI/SQL 92 standard
SqlServerBdp | SQL Server via BDP
SqlServerSqlClient | SQL Server via SqlClient
SqlServer7Bdp | SQLServer 7 via BDP
SqlServer7SqlClient | SQLServer 7 via SqlClient
DBISAM | DBIsam
OracleBdp | OracleBdp
Advantage | Advantage
Informix | Informix
DB2 | DB2
SqlServerMBCSBdp | SQLServer/Multi Byte Character Set via BDP
SqlServerMBCSSqlClient | SQLServer/Multi Byte Character Set via SqlClient
SqlServer7MBCSBdp | SQLServer 7/Multi Byte Character Set via BDP
SqlServer7MBCSSqlClient | SQLServer 7/Multi Byte Character Set via SqlClient
OracleBdpMBCS | Oracle/Multi Byte Character Set
InterbaseSqlDialect3MBCS | Interbase, SQL dialect 3/Multi Byte Character Set
DB2MBCS | DB2/Multi Byte Character Set
SybaseCommon | Sybase
SybaseBdp | Sybase via BDP
AccessBdp | Access via BDP
AccessSqlClient | Access via SqlClient
Blackfish | Blackfish
BlackfishBdp | Blackfish via BDP
MySql4Bdp | MySQL 4.0 via BDP
MySql4Mys | MySQL 4.0 via MySqlConnection
MySql5Bdp | MySQL 5.x via BDP
MySql5Mys | MySQL 5.x via MySqlConnection
OracleClient | Oracle via OracleClient
File

InitializeEngine.cs


Eco.Persistence.Configuration.IdentifierCharacterMode Enumeration

Eco.Persistence.Configuration.IdentifierCharacterMode Enumeration
Collapse All
C#
public enum IdentifierCharacterMode {
  AllowUnicode,
  MapNationalChars,
  StrictAscii
}
Remarks

This is record Eco.Persistence.Configuration.IdentifierCharacterMode.

File

SqlDatabaseConfig.cs


Eco.Persistence.Connection Namespace

Eco.Persistence.Connection Namespace
Classes Interfaces
Collapse All

This is namespace Eco.Persistence.Connection.

Classes
Name | Description
AbstractIDatabaseImpl | This is class Eco.Persistence.Connection.AbstractIDatabaseImpl.
AbstractIQueryImpl | This is class Eco.Persistence.Connection.AbstractIQueryImpl.
Ado2IDatabaseImpl | This is an abstract class that implements parts of the PersistenceMapper behaviour for connections that implement ADO2.0 DbConnection.
Ado2IQueryImpl | This is an abstract class that implements parts of the PersistenceMapper behaviour for connections that implement ADO2.0 DbConnection.
BdpIDatabaseImpl | This is class Eco.Persistence.Connection.BdpIDatabaseImpl.
DatabaseCollection | This is class Eco.Persistence.Connection.DatabaseCollection.
DatabaseOperationFailedException | This is class Eco.Persistence.Connection.DatabaseOperationFailedException.
DbxIDatabaseImpl | This is class Eco.Persistence.Connection.DbxIDatabaseImpl.
FirebirdIDatabaseImpl | This is class Eco.Persistence.Connection.FirebirdIDatabaseImpl.
MimerIDatabaseImpl | This is class Eco.Persistence.Connection.MimerIDatabaseImpl.
MySqlIDatabaseImpl | This is class Eco.Persistence.Connection.MySqlIDatabaseImpl.
OracleIDatabaseImpl | This is class Eco.Persistence.Connection.OracleIDatabaseImpl.
SqlIDatabaseImpl | This is class Eco.Persistence.Connection.SqlIDatabaseImpl.
SQLiteIDatabaseImpl | This is class Eco.Persistence.Connection.SQLiteIDatabaseImpl.
SybaseIDatabaseImpl | This is class Eco.Persistence.Connection.SybaseIDatabaseImpl.
Top
Interfaces
Name | Description
IDatabase | This is class Eco.Persistence.Connection.IDatabase.
IDatabaseCollection | This is class Eco.Persistence.Connection.IDatabaseCollection.
IDatabaseDefinition |
IDataSet | This is class Eco.Persistence.Connection.IDataSet.
IExecQuery | This is class Eco.Persistence.Connection.IExecQuery.
IField | This is class Eco.Persistence.Connection.IField.
IParameterized | This is class Eco.Persistence.Connection.IParameterized.
IQuery | This is class Eco.Persistence.Connection.IQuery.
IQueryBase | This is class Eco.Persistence.Connection.IQueryBase.
ITransactionable | This is class Eco.Persistence.Connection.ITransactionable.
ITransactionManager | This is class Eco.Persistence.Connection.ITransactionManager.


AbstractIDatabaseImpl Class

AbstractIDatabaseImpl Class
Inheritance Hierarchy See Also
Collapse All
C#
public abstract class AbstractIDatabaseImpl : IDatabase;
Remarks

This is class Eco.Persistence.Connection.AbstractIDatabaseImpl.

Inheritance Hierarchy
Eco.Persistence.Connection.IDatabase
    Eco.Persistence.Connection.AbstractIDatabaseImpl
        Eco.Persistence.Connection.BdpIDatabaseImpl
        Eco.Persistence.Connection.MySqlIDatabaseImpl
        Eco.Persistence.Connection.SybaseIDatabaseImpl
File

DatabaseImpl.cs

See Also
Inheritance Hierarchy


AbstractIDatabaseImpl.AbstractIDatabaseImpl Constructor

AbstractIDatabaseImpl.AbstractIDatabaseImpl Constructor
AbstractIDatabaseImpl Class Eco.Persistence.Connection Namespace See Also
Collapse All
C#
protected AbstractIDatabaseImpl(
    SqlDatabaseConfig config
);
Remarks

This is AbstractIDatabaseImpl, a member of class AbstractIDatabaseImpl.

See Also
AbstractIDatabaseImpl Class
Eco.Persistence.Connection Namespace


AbstractIDatabaseImpl Fields

AbstractIDatabaseImpl Fields
Protected Fields Public Fields
Collapse All

The fields of the AbstractIDatabaseImpl class are listed here.

Protected Fields
Name | Description
HIDE_WORD_REPLACEMENT1 | This is HIDE_WORD_REPLACEMENT1, a member of class AbstractIDatabaseImpl.
HIDE_WORD1 | This is HIDE_WORD1, a member of class AbstractIDatabaseImpl.
Top
Public Fields
Name | Description
TrackQueryAllocation | Set this value to true to enable tracking the callstack for each query allocation


AbstractIDatabaseImpl.HIDE_WORD_REPLACEMENT1 Field

AbstractIDatabaseImpl.HIDE_WORD_REPLACEMENT1 Field
AbstractIDatabaseImpl Class Eco.Persistence.Connection Namespace See Also
Collapse All
C#
protected static string HIDE_WORD_REPLACEMENT1 = "__new.id__";
Remarks

This is HIDE_WORD_REPLACEMENT1, a member of class AbstractIDatabaseImpl.

See Also
AbstractIDatabaseImpl Class
Eco.Persistence.Connection Namespace


AbstractIDatabaseImpl.HIDE_WORD1 Field

AbstractIDatabaseImpl.HIDE_WORD1 Field
AbstractIDatabaseImpl Class Eco.Persistence.Connection Namespace See Also
Collapse All
C#
protected static string HIDE_WORD1 = ":new.id";
Remarks

This is HIDE_WORD1, a member of class AbstractIDatabaseImpl.

See Also
AbstractIDatabaseImpl Class
Eco.Persistence.Connection Namespace


AbstractIDatabaseImpl.TrackQueryAllocation Field

AbstractIDatabaseImpl.TrackQueryAllocation Field
AbstractIDatabaseImpl Class Eco.Persistence.Connection Namespace See Also
Collapse All

Set this value to true to enable tracking the callstack for each query allocation

C#
public static bool TrackQueryAllocation = false;
Remarks

Use this only for debugging purposes

See Also
AbstractIDatabaseImpl Class
Eco.Persistence.Connection Namespace


AbstractIDatabaseImpl Methods

AbstractIDatabaseImpl Methods
Protected Methods Public Methods Protected internal Methods
Collapse All

The methods of the AbstractIDatabaseImpl class are listed here.

Protected Methods
Name | Description
ConvertParametersToAtPrefix | Replaces the parameter names with "@ParamName".
ConvertParametersToColonPrefix | Converts the parameters in the query to ":ParameterName".
ConvertParametersToLiterals | Replaces the parameter names with the literal values of the parameters.
ConvertParametersToPrefixed | Prefixes the parameters in the query with a new prefix-string.
ConvertParametersToQuestionMarks | Replaces the parameters in the query with "?" and reorders the parameters in the list to match the order in the query.
ConvertParametersToUpperCase | Changes the names of the parameters to UPPERCASE.
CreateCommand | This is CreateCommand, a member of class AbstractIDatabaseImpl.
EnsureConnected |
FindFirstParam |
PostProcess | This is PostProcess, a member of class AbstractIDatabaseImpl.
PreProcess | This is PreProcess, a member of class AbstractIDatabaseImpl.
RemoveUnusedVariables | Removes the variables in the list that are not referenced in the query.
Top
Public Methods
Name | Description
AllTableNames | Should return a list of all tables in the database that matches the pattern.
CheckQueryStatus | Returns the current status of allocated and returned queries
Close |
DisposeConnection | This is DisposeConnection, a member of class AbstractIDatabaseImpl.
GetIndexDefsForTable | This method should return a datatable with all the index definitions for the specified table.
GetQuery | This is GetQuery, a member of class AbstractIDatabaseImpl.
ReleaseQuery |
Top
Protected internal Methods
Name | Description
HandleCommandParameters | This method must be overridden to handle how query parameters should be sent to the datbase.


AbstractIDatabaseImpl.AllTableNames Method

AbstractIDatabaseImpl.AllTableNames Method
AbstractIDatabaseImpl Class Eco.Persistence.Connection Namespace See Also
Collapse All

Should return a list of all tables in the database that matches the pattern.

C#
public abstract IList<string> AllTableNames(
    string pattern
);
Parameters
Parameters | Description
pattern | If this parameter is non-empty, only tables with this name should be returned, The name of the table is case insensitive.
See Also
AbstractIDatabaseImpl Class
Eco.Persistence.Connection Namespace


AbstractIDatabaseImpl.CheckQueryStatus Method

AbstractIDatabaseImpl.CheckQueryStatus Method
AbstractIDatabaseImpl Class Eco.Persistence.Connection Namespace See Also
Collapse All

Returns the current status of allocated and returned queries

C#
public string CheckQueryStatus();
Remarks

If there are queries that have been allocated, but not returned, the result will be a non-empty string with a message. if there are no such queries, the return value will be an empty string

See Also
AbstractIDatabaseImpl Class
Eco.Persistence.Connection Namespace


AbstractIDatabaseImpl.Close Method

AbstractIDatabaseImpl.Close Method
AbstractIDatabaseImpl Class Eco.Persistence.Connection Namespace See Also
Collapse All
C#
public void Close();
Exceptions
Exceptions | Description
InvalidOperationException | Thrown if there were any problems closing the connection.
See Also
AbstractIDatabaseImpl Class
Eco.Persistence.Connection Namespace


AbstractIDatabaseImpl.ConvertParametersToAtPrefix Method

AbstractIDatabaseImpl.ConvertParametersToAtPrefix Method
AbstractIDatabaseImpl Class Eco.Persistence.Connection Namespace See Also
Collapse All

Replaces the parameter names with "@ParamName".

C#
protected static string ConvertParametersToAtPrefix(
    string commandText,
    IDataParameterCollection parameters
);
Remarks

This is the syntax expected by SqlServer.

Exceptions
Exceptions | Description
ArgumentNullException | Thrown if parameters is null
See Also
AbstractIDatabaseImpl Class
Eco.Persistence.Connection Namespace


AbstractIDatabaseImpl.ConvertParametersToColonPrefix Method

AbstractIDatabaseImpl.ConvertParametersToColonPrefix Method
AbstractIDatabaseImpl Class Eco.Persistence.Connection Namespace See Also
Collapse All

Converts the parameters in the query to ":ParameterName".

C#
protected static string ConvertParametersToColonPrefix(
    string commandText,
    IDataParameterCollection parameters
);
Remarks

This is the format expected by OracleClient. This operation does not do anything since the sql-text in the parameter should already be in this format. It is recommended to call this method anyway if the original format of the query changes

See Also
AbstractIDatabaseImpl Class
Eco.Persistence.Connection Namespace


AbstractIDatabaseImpl.ConvertParametersToLiterals Method

AbstractIDatabaseImpl.ConvertParametersToLiterals Method
AbstractIDatabaseImpl Class Eco.Persistence.Connection Namespace See Also
Collapse All

Replaces the parameter names with the literal values of the parameters.

C#
protected static string ConvertParametersToLiterals(
    string commandText,
    IDataParameterCollection parameters
);
Remarks

This is not particularly safe since many parameter types can't be converted to strings in a safe way (dates, blobs, decimal values etc)

Exceptions
Exceptions | Description
ArgumentNullException | Thrown if parameters is null
See Also
AbstractIDatabaseImpl Class
Eco.Persistence.Connection Namespace


AbstractIDatabaseImpl.ConvertParametersToPrefixed Method

AbstractIDatabaseImpl.ConvertParametersToPrefixed Method
AbstractIDatabaseImpl Class Eco.Persistence.Connection Namespace See Also
Collapse All

Prefixes the parameters in the query with a new prefix-string.

C#
protected static string ConvertParametersToPrefixed(
    string commandText,
    IDataParameterCollection parameters,
    string prefix,
    bool addPrefixToParam
);
Parameters
Parameters | Description
commandText | The original sql command. all parameters are refered with ":ParamName"
parameters | The (named) parameters that are defined for the query
prefix | The prefix to insert into the query
addPrefixToParam | If this parameter is true, then the prefix will be inserted into the IDataParameter.ParameterName property too
Remarks

The prefixing ":" is removed from the parameter names in the query and a new prefix is inserted instead.

Exceptions
Exceptions | Description
ArgumentNullException | Thrown if parameters is null
See Also
AbstractIDatabaseImpl Class
Eco.Persistence.Connection Namespace


AbstractIDatabaseImpl.ConvertParametersToQuestionMarks Method

AbstractIDatabaseImpl.ConvertParametersToQuestionMarks Method
AbstractIDatabaseImpl Class Eco.Persistence.Connection Namespace See Also
Collapse All

Replaces the parameters in the query with "?" and reorders the parameters in the list to match the order in the query.

C#
protected static string ConvertParametersToQuestionMarks(
    string commandText,
    IDataParameterCollection parameters
);
Remarks

This is the format expected by BDP. Parameters can not be used more than once. .

Exceptions
Exceptions | Description
ArgumentNullException | Thrown if parameters is null
See Also
AbstractIDatabaseImpl Class
Eco.Persistence.Connection Namespace


AbstractIDatabaseImpl.ConvertParametersToUpperCase Method

AbstractIDatabaseImpl.ConvertParametersToUpperCase Method
AbstractIDatabaseImpl Class Eco.Persistence.Connection Namespace See Also
Collapse All

Changes the names of the parameters to UPPERCASE.

C#
protected static string ConvertParametersToUpperCase(
    string commandText,
    IDataParameterCollection parameters
);
Remarks

Both the name in the sql-query and the name in the IDataParameter is updated.

Exceptions
Exceptions | Description
ArgumentNullException | Thrown if parameters is null
See Also
AbstractIDatabaseImpl Class
Eco.Persistence.Connection Namespace


AbstractIDatabaseImpl.CreateCommand Method

AbstractIDatabaseImpl.CreateCommand Method
AbstractIDatabaseImpl Class Eco.Persistence.Connection Namespace See Also
Collapse All
C#
protected abstract AbstractIQueryImpl CreateCommand();
Remarks

This is CreateCommand, a member of class AbstractIDatabaseImpl.

See Also
AbstractIDatabaseImpl Class
Eco.Persistence.Connection Namespace


AbstractIDatabaseImpl.DisposeConnection Method

AbstractIDatabaseImpl.DisposeConnection Method
AbstractIDatabaseImpl Class Eco.Persistence.Connection Namespace See Also
Collapse All
C#
public void DisposeConnection();
Remarks

This is DisposeConnection, a member of class AbstractIDatabaseImpl.

See Also
AbstractIDatabaseImpl Class
Eco.Persistence.Connection Namespace


AbstractIDatabaseImpl.EnsureConnected Method

AbstractIDatabaseImpl.EnsureConnected Method
AbstractIDatabaseImpl Class Eco.Persistence.Connection Namespace See Also
Collapse All
C#
protected void EnsureConnected();
Exceptions
Exceptions | Description
InvalidOperationException | Thrown if the database is not connected.
See Also
AbstractIDatabaseImpl Class
Eco.Persistence.Connection Namespace


AbstractIDatabaseImpl.FindFirstParam Method

AbstractIDatabaseImpl.FindFirstParam Method
AbstractIDatabaseImpl Class Eco.Persistence.Connection Namespace See Also
Collapse All
C#
protected static bool FindFirstParam(
    string text,
    out string head,
    out string name,
    out string tail
);
Exceptions
Exceptions | Description
ArgumentNullException | Thrown if text is null
See Also
AbstractIDatabaseImpl Class
Eco.Persistence.Connection Namespace


AbstractIDatabaseImpl.GetIndexDefsForTable Method

AbstractIDatabaseImpl.GetIndexDefsForTable Method
AbstractIDatabaseImpl Class Eco.Persistence.Connection Namespace See Also
Collapse All

This method should return a datatable with all the index definitions for the specified table.

C#
public abstract DataTable GetIndexDefsForTable(
    string tableName
);
Remarks

The returned datatable should contain one row for each column in each index (with the indexname and the columnname). This is used when a column has to be dropped during Evolve so that any indexes can be dropped first.

See Also
AbstractIDatabaseImpl Class
Eco.Persistence.Connection Namespace


AbstractIDatabaseImpl.GetQuery Method

AbstractIDatabaseImpl.GetQuery Method
AbstractIDatabaseImpl Class Eco.Persistence.Connection Namespace See Also
Collapse All
C#
public IQuery GetQuery();
Remarks

This is GetQuery, a member of class AbstractIDatabaseImpl.

See Also
AbstractIDatabaseImpl Class
Eco.Persistence.Connection Namespace


AbstractIDatabaseImpl.HandleCommandParameters Method

AbstractIDatabaseImpl.HandleCommandParameters Method
AbstractIDatabaseImpl Class Eco.Persistence.Connection Namespace Related Topics See Also
Collapse All

This method must be overridden to handle how query parameters should be sent to the datbase.

C#
protected internal abstract string HandleCommandParameters(
    string commandText,
    IDataParameterCollection parameters
);
Remarks

The sql-commands that are build by eco has all parameters on the form ":ParamName". If your database expects the parameters in a different way, you need to find the parameters and replace then with the kind of parameter identifier that will work. There are a couple of predefined string manipulations that you can use.

Related Topics

ConvertParametersToColonPrefix, ConvertParametersToAtPrefix, ConvertParametersToLiterals, ConvertParametersToQuestionMarks, ConvertParametersToUpperCase

See Also
AbstractIDatabaseImpl Class
Eco.Persistence.Connection Namespace
Related Topics


AbstractIDatabaseImpl.PostProcess Method

AbstractIDatabaseImpl.PostProcess Method
AbstractIDatabaseImpl Class Eco.Persistence.Connection Namespace See Also
Collapse All
C#
protected static string PostProcess(
    string text
);
Remarks

This is PostProcess, a member of class AbstractIDatabaseImpl.

See Also
AbstractIDatabaseImpl Class
Eco.Persistence.Connection Namespace


AbstractIDatabaseImpl.PreProcess Method

AbstractIDatabaseImpl.PreProcess Method
AbstractIDatabaseImpl Class Eco.Persistence.Connection Namespace See Also
Collapse All
C#
protected static string PreProcess(
    string text
);
Remarks

This is PreProcess, a member of class AbstractIDatabaseImpl.

See Also
AbstractIDatabaseImpl Class
Eco.Persistence.Connection Namespace


AbstractIDatabaseImpl.ReleaseQuery Method

AbstractIDatabaseImpl.ReleaseQuery Method
AbstractIDatabaseImpl Class Eco.Persistence.Connection Namespace See Also
Collapse All
C#
public void ReleaseQuery(
    IQuery query
);
Exceptions
Exceptions | Description
ArgumentNullException | Thrown if query is null
See Also
AbstractIDatabaseImpl Class
Eco.Persistence.Connection Namespace


AbstractIDatabaseImpl.RemoveUnusedVariables Method

AbstractIDatabaseImpl.RemoveUnusedVariables Method
AbstractIDatabaseImpl Class Eco.Persistence.Connection Namespace See Also
Collapse All

Removes the variables in the list that are not referenced in the query.

C#
protected void RemoveUnusedVariables(
    string sql,
    IDataParameterCollection parameters
);
Remarks

The check is done case sensitive!

See Also
AbstractIDatabaseImpl Class
Eco.Persistence.Connection Namespace


AbstractIDatabaseImpl Properties

AbstractIDatabaseImpl Properties
Public Properties Protected Properties
Collapse All

The properties of the AbstractIDatabaseImpl class are listed here.

Public Properties
Name | Description
AlwaysReadInTransactions | This is AlwaysReadInTransactions, a member of class AbstractIDatabaseImpl.
Config | Contains database specific configuration.
Connected | This is Connected, a member of class AbstractIDatabaseImpl.
DbConnection | This is DbConnection, a member of class AbstractIDatabaseImpl.
InImplicitTransaction | This is InImplicitTransaction, a member of class AbstractIDatabaseImpl.
InTransaction | This is InTransaction, a member of class AbstractIDatabaseImpl.
Top
Protected Properties
Name | Description
CurrentTransaction | This is CurrentTransaction, a member of class AbstractIDatabaseImpl.
ImplicitTransaction | This is ImplicitTransaction, a member of class AbstractIDatabaseImpl.


AbstractIDatabaseImpl.AlwaysReadInTransactions Property

AbstractIDatabaseImpl.AlwaysReadInTransactions Property
AbstractIDatabaseImpl Class Eco.Persistence.Connection Namespace See Also
Collapse All
C#
public virtual bool AlwaysReadInTransactions;
Remarks

This is AlwaysReadInTransactions, a member of class AbstractIDatabaseImpl.

See Also
AbstractIDatabaseImpl Class
Eco.Persistence.Connection Namespace


AbstractIDatabaseImpl.Config Property

AbstractIDatabaseImpl.Config Property
AbstractIDatabaseImpl Class Eco.Persistence.Connection Namespace See Also
Collapse All

Contains database specific configuration.

C#
public SqlDatabaseConfig Config;
See Also
AbstractIDatabaseImpl Class
Eco.Persistence.Connection Namespace


AbstractIDatabaseImpl.Connected Property

AbstractIDatabaseImpl.Connected Property
AbstractIDatabaseImpl Class Eco.Persistence.Connection Namespace See Also
Collapse All
C#
public bool Connected;
Remarks

This is Connected, a member of class AbstractIDatabaseImpl.

See Also
AbstractIDatabaseImpl Class
Eco.Persistence.Connection Namespace


AbstractIDatabaseImpl.CurrentTransaction Property

AbstractIDatabaseImpl.CurrentTransaction Property
AbstractIDatabaseImpl Class Eco.Persistence.Connection Namespace See Also
Collapse All
C#
protected IDbTransaction CurrentTransaction;
Remarks

This is CurrentTransaction, a member of class AbstractIDatabaseImpl.

See Also
AbstractIDatabaseImpl Class
Eco.Persistence.Connection Namespace


AbstractIDatabaseImpl.DbConnection Property

AbstractIDatabaseImpl.DbConnection Property
AbstractIDatabaseImpl Class Eco.Persistence.Connection Namespace See Also
Collapse All
C#
public abstract IDbConnection DbConnection;
Remarks

This is DbConnection, a member of class AbstractIDatabaseImpl.

See Also
AbstractIDatabaseImpl Class
Eco.Persistence.Connection Namespace


AbstractIDatabaseImpl.ImplicitTransaction Property

AbstractIDatabaseImpl.ImplicitTransaction Property
AbstractIDatabaseImpl Class Eco.Persistence.Connection Namespace See Also
Collapse All
C#
protected IDbTransaction ImplicitTransaction;
Remarks

This is ImplicitTransaction, a member of class AbstractIDatabaseImpl.

See Also
AbstractIDatabaseImpl Class
Eco.Persistence.Connection Namespace


AbstractIDatabaseImpl.InImplicitTransaction Property

AbstractIDatabaseImpl.InImplicitTransaction Property
AbstractIDatabaseImpl Class Eco.Persistence.Connection Namespace See Also
Collapse All
C#
public bool InImplicitTransaction;
Remarks

This is InImplicitTransaction, a member of class AbstractIDatabaseImpl.

See Also
AbstractIDatabaseImpl Class
Eco.Persistence.Connection Namespace


AbstractIDatabaseImpl.InTransaction Property

AbstractIDatabaseImpl.InTransaction Property
AbstractIDatabaseImpl Class Eco.Persistence.Connection Namespace See Also
Collapse All
C#
public bool InTransaction;
Remarks

This is InTransaction, a member of class AbstractIDatabaseImpl.

See Also
AbstractIDatabaseImpl Class
Eco.Persistence.Connection Namespace


AbstractIQueryImpl Class

AbstractIQueryImpl Class
Inheritance Hierarchy See Also
Collapse All
C#
public abstract class AbstractIQueryImpl : IQuery, IExecQuery;
Remarks

This is class Eco.Persistence.Connection.AbstractIQueryImpl.

Inheritance Hierarchy
Eco.Persistence.Connection.IParameterized
    Eco.Persistence.Connection.IQueryBase
        Eco.Persistence.Connection.IExecQuery
        Eco.Persistence.Connection.IDataSet
            Eco.Persistence.Connection.IQuery
                Eco.Persistence.Connection.AbstractIQueryImpl
                    Eco.Persistence.Connection.Ado2IQueryImpl
File

DatabaseImpl.cs

See Also
Inheritance Hierarchy


AbstractIQueryImpl Constructor

AbstractIQueryImpl Constructor

This is the overview for the AbstractIQueryImpl constructor overload.

Overload List
Name | Description
AbstractIQueryImpl.AbstractIQueryImpl () | This is AbstractIQueryImpl, a member of class AbstractIQueryImpl.
AbstractIQueryImpl.AbstractIQueryImpl (IDbCommand, AbstractIDatabaseImpl) | This is AbstractIQueryImpl, a member of class AbstractIQueryImpl.


AbstractIQueryImpl.AbstractIQueryImpl Constructor ()

AbstractIQueryImpl.AbstractIQueryImpl Constructor ()
AbstractIQueryImpl Class Eco.Persistence.Connection Namespace See Also
Collapse All
C#
protected AbstractIQueryImpl();
Remarks

This is AbstractIQueryImpl, a member of class AbstractIQueryImpl.

See Also
AbstractIQueryImpl Class
Eco.Persistence.Connection Namespace


AbstractIQueryImpl.AbstractIQueryImpl Constructor (IDbCommand, AbstractIDatabaseImpl)

AbstractIQueryImpl.AbstractIQueryImpl Constructor (IDbCommand, AbstractIDatabaseImpl)
AbstractIQueryImpl Class Eco.Persistence.Connection Namespace See Also
Collapse All
C#
protected AbstractIQueryImpl(
    IDbCommand dbCommand,
    AbstractIDatabaseImpl connectionAdapter
);
Remarks

This is AbstractIQueryImpl, a member of class AbstractIQueryImpl.

See Also
AbstractIQueryImpl Class
Eco.Persistence.Connection Namespace


AbstractIQueryImpl Methods

AbstractIQueryImpl Methods
Protected Methods Public Methods
Collapse All

The methods of the AbstractIQueryImpl class are listed here.

Protected Methods
Name | Description
CreateParam | This is CreateParam, a member of class AbstractIQueryImpl.
CreateReader | This is CreateReader, a member of class AbstractIQueryImpl.
EndImplicitTransaction | This is EndImplicitTransaction, a member of class AbstractIQueryImpl.
GetParameterTypeDescription |
InternalClose | This is InternalClose, a member of class AbstractIQueryImpl.
ReleaseReader | This is ReleaseReader, a member of class AbstractIQueryImpl.
Top
Public Methods
Name | Description
Close | This is Close, a member of class AbstractIQueryImpl.
EndSqlBatch | This is EndSqlBatch, a member of class AbstractIQueryImpl.
ExecSql |
FailSqlBatch | This is FailSqlBatch, a member of class AbstractIQueryImpl.
Next | This is Next, a member of class AbstractIQueryImpl.
ParamByName | This is ParamByName, a member of class AbstractIQueryImpl.
StartSqlBatch | This is StartSqlBatch, a member of class AbstractIQueryImpl.


AbstractIQueryImpl.Close Method

AbstractIQueryImpl.Close Method
AbstractIQueryImpl Class Eco.Persistence.Connection Namespace See Also
Collapse All
C#
public void Close();
Remarks

This is Close, a member of class AbstractIQueryImpl.

See Also
AbstractIQueryImpl Class
Eco.Persistence.Connection Namespace


AbstractIQueryImpl.CreateParam Method

AbstractIQueryImpl.CreateParam Method
AbstractIQueryImpl Class Eco.Persistence.Connection Namespace See Also
Collapse All
C#
protected abstract IDataParameter CreateParam(
    string paramName
);
Remarks

This is CreateParam, a member of class AbstractIQueryImpl.

See Also
AbstractIQueryImpl Class
Eco.Persistence.Connection Namespace


AbstractIQueryImpl.CreateReader Method

AbstractIQueryImpl.CreateReader Method
AbstractIQueryImpl Class Eco.Persistence.Connection Namespace See Also
Collapse All
C#
protected virtual void CreateReader();
Remarks

This is CreateReader, a member of class AbstractIQueryImpl.

See Also
AbstractIQueryImpl Class
Eco.Persistence.Connection Namespace


AbstractIQueryImpl.EndImplicitTransaction Method

AbstractIQueryImpl.EndImplicitTransaction Method
AbstractIQueryImpl Class Eco.Persistence.Connection Namespace See Also
Collapse All
C#
protected void EndImplicitTransaction();
Remarks

This is EndImplicitTransaction, a member of class AbstractIQueryImpl.

See Also
AbstractIQueryImpl Class
Eco.Persistence.Connection Namespace


AbstractIQueryImpl.EndSqlBatch Method

AbstractIQueryImpl.EndSqlBatch Method
AbstractIQueryImpl Class Eco.Persistence.Connection Namespace See Also
Collapse All
C#
public virtual void EndSqlBatch();
Remarks

This is EndSqlBatch, a member of class AbstractIQueryImpl.

See Also
AbstractIQueryImpl Class
Eco.Persistence.Connection Namespace


AbstractIQueryImpl.ExecSql Method

AbstractIQueryImpl.ExecSql Method
AbstractIQueryImpl Class Eco.Persistence.Connection Namespace See Also
Collapse All
C#
public virtual void ExecSql();
Exceptions
Exceptions | Description
DatabaseOperationFailedException | Thrown if the script execution failed. The original exception is made an inner exception.
See Also
AbstractIQueryImpl Class
Eco.Persistence.Connection Namespace


AbstractIQueryImpl.FailSqlBatch Method

AbstractIQueryImpl.FailSqlBatch Method
AbstractIQueryImpl Class Eco.Persistence.Connection Namespace See Also
Collapse All
C#
public virtual void FailSqlBatch();
Remarks

This is FailSqlBatch, a member of class AbstractIQueryImpl.

See Also
AbstractIQueryImpl Class
Eco.Persistence.Connection Namespace


AbstractIQueryImpl.GetParameterTypeDescription Method

AbstractIQueryImpl.GetParameterTypeDescription Method
AbstractIQueryImpl Class Eco.Persistence.Connection Namespace See Also
Collapse All
C#
protected virtual string GetParameterTypeDescription(
    IDataParameter p
);
Exceptions
Exceptions | Description
ArgumentNullException | Thrown if p is null
See Also
AbstractIQueryImpl Class
Eco.Persistence.Connection Namespace


AbstractIQueryImpl.InternalClose Method

AbstractIQueryImpl.InternalClose Method
AbstractIQueryImpl Class Eco.Persistence.Connection Namespace See Also
Collapse All
C#
protected virtual void InternalClose();
Remarks

This is InternalClose, a member of class AbstractIQueryImpl.

See Also
AbstractIQueryImpl Class
Eco.Persistence.Connection Namespace


AbstractIQueryImpl.Next Method

AbstractIQueryImpl.Next Method
AbstractIQueryImpl Class Eco.Persistence.Connection Namespace See Also
Collapse All
C#
public void Next();
Remarks

This is Next, a member of class AbstractIQueryImpl.

See Also
AbstractIQueryImpl Class
Eco.Persistence.Connection Namespace


AbstractIQueryImpl.ParamByName Method

AbstractIQueryImpl.ParamByName Method
AbstractIQueryImpl Class Eco.Persistence.Connection Namespace See Also
Collapse All
C#
public virtual IDataParameter ParamByName(
    string value
);
Remarks

This is ParamByName, a member of class AbstractIQueryImpl.

See Also
AbstractIQueryImpl Class
Eco.Persistence.Connection Namespace


AbstractIQueryImpl.ReleaseReader Method

AbstractIQueryImpl.ReleaseReader Method
AbstractIQueryImpl Class Eco.Persistence.Connection Namespace See Also
Collapse All
C#
protected void ReleaseReader();
Remarks

This is ReleaseReader, a member of class AbstractIQueryImpl.

See Also
AbstractIQueryImpl Class
Eco.Persistence.Connection Namespace


AbstractIQueryImpl.StartSqlBatch Method

AbstractIQueryImpl.StartSqlBatch Method
AbstractIQueryImpl Class Eco.Persistence.Connection Namespace See Also
Collapse All
C#
public virtual void StartSqlBatch();
Remarks

This is StartSqlBatch, a member of class AbstractIQueryImpl.

See Also
AbstractIQueryImpl Class
Eco.Persistence.Connection Namespace


AbstractIQueryImpl Properties

AbstractIQueryImpl Properties
Public Properties Protected Properties
Collapse All

The properties of the AbstractIQueryImpl class are listed here.

Public Properties
Name | Description
Eof | This is Eof, a member of class AbstractIQueryImpl.
Top
Protected Properties
Name | Description
DataReader | This is DataReader, a member of class AbstractIQueryImpl.
DataRecord | This is DataRecord, a member of class AbstractIQueryImpl.
DbCommand | This is DbCommand, a member of class AbstractIQueryImpl.


AbstractIQueryImpl.DataReader Property

AbstractIQueryImpl.DataReader Property
AbstractIQueryImpl Class Eco.Persistence.Connection Namespace See Also
Collapse All
C#
protected IDataReader DataReader;
Remarks

This is DataReader, a member of class AbstractIQueryImpl.

See Also
AbstractIQueryImpl Class
Eco.Persistence.Connection Namespace


AbstractIQueryImpl.DataRecord Property

AbstractIQueryImpl.DataRecord Property
AbstractIQueryImpl Class Eco.Persistence.Connection Namespace See Also
Collapse All
C#
protected IDataRecord DataRecord;
Remarks

This is DataRecord, a member of class AbstractIQueryImpl.

See Also
AbstractIQueryImpl Class
Eco.Persistence.Connection Namespace


AbstractIQueryImpl.DbCommand Property

AbstractIQueryImpl.DbCommand Property
AbstractIQueryImpl Class Eco.Persistence.Connection Namespace See Also
Collapse All
C#
protected IDbCommand DbCommand;
Remarks

This is DbCommand, a member of class AbstractIQueryImpl.

See Also
AbstractIQueryImpl Class
Eco.Persistence.Connection Namespace


AbstractIQueryImpl.Eof Property

AbstractIQueryImpl.Eof Property
AbstractIQueryImpl Class Eco.Persistence.Connection Namespace See Also
Collapse All
C#
public bool Eof;
Remarks

This is Eof, a member of class AbstractIQueryImpl.

See Also
AbstractIQueryImpl Class
Eco.Persistence.Connection Namespace


Ado2IDatabaseImpl Class

Ado2IDatabaseImpl Class
Inheritance Hierarchy See Also
Collapse All

This is an abstract class that implements parts of the PersistenceMapper behaviour for connections that implement ADO2.0 DbConnection.

C#
public abstract class Ado2IDatabaseImpl : AbstractIDatabaseImplpublicabstractclassAdo2IDatabaseImpl:AbstractIDatabaseImpl, IDistributedTransactionParticipant;
Remarks

This class is intended as base class for PersistenceMappers that support connection components that derive from the ADO2.0 class DbConnection (such as SqlConnection, OracleConnection). It uses the factory-methods to create commands and parameters. It also uses the GetSchema-method to extract metadata from the connection. For examples of subclassing this base class, please see the source of OracleIDatabaseImpl or SqlIDatabaseImpl.

Inheritance Hierarchy
Eco.Persistence.IDistributedTransactionParticipant
    Eco.Persistence.Connection.Ado2IDatabaseImpl
        Eco.Persistence.Connection.DbxIDatabaseImpl
        Eco.Persistence.Connection.FirebirdIDatabaseImpl
        Eco.Persistence.Connection.MimerIDatabaseImpl
        Eco.Persistence.Connection.OracleIDatabaseImpl
        Eco.Persistence.Connection.SqlIDatabaseImpl
        Eco.Persistence.Connection.SQLiteIDatabaseImpl
File

Ado2DatabaseImpl.cs

See Also
Inheritance Hierarchy


Ado2IDatabaseImpl.Ado2IDatabaseImpl Constructor

Ado2IDatabaseImpl.Ado2IDatabaseImpl Constructor
Ado2IDatabaseImpl Class Eco.Persistence.Connection Namespace See Also
Collapse All
C#
public Ado2IDatabaseImpl(
    DbConnection connection,
    SqlDatabaseConfig config
);
Remarks

This is Ado2IDatabaseImpl, a member of class Ado2IDatabaseImpl.

See Also
Ado2IDatabaseImpl Class
Eco.Persistence.Connection Namespace


Ado2IDatabaseImpl Methods

Ado2IDatabaseImpl Methods
Protected Methods Public Methods
Collapse All

The methods of the Ado2IDatabaseImpl class are listed here.

Protected Methods
Name | Description
CreateColumn | This is the overview for the CreateColumn method overload.
CreateCommand | This is CreateCommand, a member of class Ado2IDatabaseImpl.
CreateIndexDefsTable | This is CreateIndexDefsTable, a member of class Ado2IDatabaseImpl.
InternalEnlistInTransaction | Enlists the connection in a distributed transaction.
Top
Public Methods
Name | Description
GetIndexDefsForTable | This method uses the DbConnection.GetSchema method to find all indices defined for a table.


CreateColumn Method

CreateColumn Method

This is the overview for the CreateColumn method overload.

Overload List
Name | Description
Ado2IDatabaseImpl.CreateColumn (String, String) | This is CreateColumn, a member of class Ado2IDatabaseImpl.
Ado2IDatabaseImpl.CreateColumn (String, String, bool) | This is CreateColumn, a member of class Ado2IDatabaseImpl.


Ado2IDatabaseImpl.CreateColumn Method (String, String)

Ado2IDatabaseImpl.CreateColumn Method (String, String)
Ado2IDatabaseImpl Class Eco.Persistence.Connection Namespace See Also
Collapse All
C#
protected static DataColumn CreateColumn(
    String name,
    String dataType
);
Remarks

This is CreateColumn, a member of class Ado2IDatabaseImpl.

See Also
Ado2IDatabaseImpl Class
Eco.Persistence.Connection Namespace


Ado2IDatabaseImpl.CreateColumn Method (String, String, bool)

Ado2IDatabaseImpl.CreateColumn Method (String, String, bool)
Ado2IDatabaseImpl Class Eco.Persistence.Connection Namespace See Also
Collapse All
C#
protected static DataColumn CreateColumn(
    String name,
    String dataType,
    bool readOnly
);
Remarks

This is CreateColumn, a member of class Ado2IDatabaseImpl.

See Also
Ado2IDatabaseImpl Class
Eco.Persistence.Connection Namespace


Ado2IDatabaseImpl.CreateCommand Method

Ado2IDatabaseImpl.CreateCommand Method
Ado2IDatabaseImpl Class Eco.Persistence.Connection Namespace See Also
Collapse All
C#
protected override AbstractIQueryImpl CreateCommand();
Remarks

This is CreateCommand, a member of class Ado2IDatabaseImpl.

See Also
Ado2IDatabaseImpl Class
Eco.Persistence.Connection Namespace


Ado2IDatabaseImpl.CreateIndexDefsTable Method

Ado2IDatabaseImpl.CreateIndexDefsTable Method
Ado2IDatabaseImpl Class Eco.Persistence.Connection Namespace See Also
Collapse All
C#
protected static DataTable CreateIndexDefsTable();
Remarks

This is CreateIndexDefsTable, a member of class Ado2IDatabaseImpl.

See Also
Ado2IDatabaseImpl Class
Eco.Persistence.Connection Namespace


Ado2IDatabaseImpl.GetIndexDefsForTable Method

Ado2IDatabaseImpl.GetIndexDefsForTable Method
Ado2IDatabaseImpl Class Eco.Persistence.Connection Namespace See Also
Collapse All

This method uses the DbConnection.GetSchema method to find all indices defined for a table.

C#
public override DataTable GetIndexDefsForTable(
    string tableName
);
See Also
Ado2IDatabaseImpl Class
Eco.Persistence.Connection Namespace


Ado2IDatabaseImpl.InternalEnlistInTransaction Method

Ado2IDatabaseImpl.InternalEnlistInTransaction Method
Ado2IDatabaseImpl Class Eco.Persistence.Connection Namespace See Also
Collapse All

Enlists the connection in a distributed transaction.

C#
protected virtual void InternalEnlistInTransaction(
    object transaction
);
Remarks

Override this method if the connection supports other transaction mechanisms (such as ITransaction)

See Also
Ado2IDatabaseImpl Class
Eco.Persistence.Connection Namespace


Ado2IDatabaseImpl Properties

Ado2IDatabaseImpl Properties
Public Properties Protected Properties
Collapse All

The properties of the Ado2IDatabaseImpl class are listed here.

Public Properties
Name | Description
DbConnection | This is DbConnection, a member of class Ado2IDatabaseImpl.
Top
Protected Properties
Name | Description
Connection | This is Connection, a member of class Ado2IDatabaseImpl.


Ado2IDatabaseImpl.Connection Property

Ado2IDatabaseImpl.Connection Property
Ado2IDatabaseImpl Class Eco.Persistence.Connection Namespace See Also
Collapse All
C#
protected DbConnection Connection;
Remarks

This is Connection, a member of class Ado2IDatabaseImpl.

See Also
Ado2IDatabaseImpl Class
Eco.Persistence.Connection Namespace


Ado2IDatabaseImpl.DbConnection Property

Ado2IDatabaseImpl.DbConnection Property
Ado2IDatabaseImpl Class Eco.Persistence.Connection Namespace See Also
Collapse All
C#
public override IDbConnection DbConnection;
Remarks

This is DbConnection, a member of class Ado2IDatabaseImpl.

See Also
Ado2IDatabaseImpl Class
Eco.Persistence.Connection Namespace


Ado2IQueryImpl Class

Ado2IQueryImpl Class
Inheritance Hierarchy See Also
Collapse All

This is an abstract class that implements parts of the PersistenceMapper behaviour for connections that implement ADO2.0 DbConnection.

C#
public class Ado2IQueryImpl : AbstractIQueryImpl;
Inheritance Hierarchy
Eco.Persistence.Connection.IParameterized
    Eco.Persistence.Connection.IQueryBase
        Eco.Persistence.Connection.IExecQuery
        Eco.Persistence.Connection.IDataSet
            Eco.Persistence.Connection.IQuery
                Eco.Persistence.Connection.AbstractIQueryImpl
                    Eco.Persistence.Connection.Ado2IQueryImpl
File

Ado2DatabaseImpl.cs

See Also
Inheritance Hierarchy


Ado2IQueryImpl.Ado2IQueryImpl Constructor

Ado2IQueryImpl.Ado2IQueryImpl Constructor
Ado2IQueryImpl Class Eco.Persistence.Connection Namespace See Also
Collapse All
C#
public Ado2IQueryImpl(
    IDbCommand command,
    AbstractIDatabaseImpl connectionAdapter
);
Remarks

This is Ado2IQueryImpl, a member of class Ado2IQueryImpl.

See Also
Ado2IQueryImpl Class
Eco.Persistence.Connection Namespace


Ado2IQueryImpl Methods

Ado2IQueryImpl Methods
Protected Methods
Collapse All

The methods of the Ado2IQueryImpl class are listed here.

Protected Methods
Name | Description
CreateParam | This is CreateParam, a member of class Ado2IQueryImpl.


Ado2IQueryImpl.CreateParam Method

Ado2IQueryImpl.CreateParam Method
Ado2IQueryImpl Class Eco.Persistence.Connection Namespace See Also
Collapse All
C#
protected override IDataParameter CreateParam(
    string paramName
);
Remarks

This is CreateParam, a member of class Ado2IQueryImpl.

See Also
Ado2IQueryImpl Class
Eco.Persistence.Connection Namespace


BdpIDatabaseImpl Class

BdpIDatabaseImpl Class
Inheritance Hierarchy See Also
Collapse All
C#
public sealed class BdpIDatabaseImpl : AbstractIDatabaseImpl;
Remarks

This is class Eco.Persistence.Connection.BdpIDatabaseImpl.

Inheritance Hierarchy
Eco.Persistence.Connection.IDatabase
    Eco.Persistence.Connection.AbstractIDatabaseImpl
        Eco.Persistence.Connection.BdpIDatabaseImpl
File

BdpDatabaseImpl.cs

See Also
Inheritance Hierarchy


BdpIDatabaseImpl.BdpIDatabaseImpl Constructor

BdpIDatabaseImpl.BdpIDatabaseImpl Constructor
BdpIDatabaseImpl Class Eco.Persistence.Connection Namespace See Also
Collapse All
C#
public BdpIDatabaseImpl(
    BdpConnection connection,
    SqlDatabaseConfig config
);
Remarks

This is BdpIDatabaseImpl, a member of class BdpIDatabaseImpl.

See Also
BdpIDatabaseImpl Class
Eco.Persistence.Connection Namespace


BdpIDatabaseImpl Methods

BdpIDatabaseImpl Methods
Protected Methods Public Methods
Collapse All

The methods of the BdpIDatabaseImpl class are listed here.

Protected Methods
Name | Description
CreateCommand | This is CreateCommand, a member of class BdpIDatabaseImpl.
HandleCommandParameters | This method must be overridden to handle how query parameters should be sent to the datbase.
Top
Public Methods
Name | Description
AllTableNames | Should return a list of all tables in the database that matches the pattern.
GetIndexDefsForTable | This method should return a datatable with all the index definitions for the specified table.


BdpIDatabaseImpl.AllTableNames Method

BdpIDatabaseImpl.AllTableNames Method
BdpIDatabaseImpl Class Eco.Persistence.Connection Namespace See Also
Collapse All

Should return a list of all tables in the database that matches the pattern.

C#
public override IList<string> AllTableNames(
    string pattern
);
Parameters
Parameters | Description
pattern | If this parameter is non-empty, only tables with this name should be returned, The name of the table is case insensitive.
See Also
BdpIDatabaseImpl Class
Eco.Persistence.Connection Namespace


BdpIDatabaseImpl.CreateCommand Method

BdpIDatabaseImpl.CreateCommand Method
BdpIDatabaseImpl Class Eco.Persistence.Connection Namespace See Also
Collapse All
C#
protected override AbstractIQueryImpl CreateCommand();
Remarks

This is CreateCommand, a member of class BdpIDatabaseImpl.

See Also
BdpIDatabaseImpl Class
Eco.Persistence.Connection Namespace


BdpIDatabaseImpl.GetIndexDefsForTable Method

BdpIDatabaseImpl.GetIndexDefsForTable Method
BdpIDatabaseImpl Class Eco.Persistence.Connection Namespace See Also
Collapse All

This method should return a datatable with all the index definitions for the specified table.

C#
public override DataTable GetIndexDefsForTable(
    string tableName
);
Remarks

The returned datatable should contain one row for each column in each index (with the indexname and the columnname). This is used when a column has to be dropped during Evolve so that any indexes can be dropped first.

See Also
BdpIDatabaseImpl Class
Eco.Persistence.Connection Namespace


BdpIDatabaseImpl.HandleCommandParameters Method

BdpIDatabaseImpl.HandleCommandParameters Method
BdpIDatabaseImpl Class Eco.Persistence.Connection Namespace Related Topics See Also
Collapse All

This method must be overridden to handle how query parameters should be sent to the datbase.

C#
protected override string HandleCommandParameters(
    string commandText,
    IDataParameterCollection parameters
);
Remarks

The sql-commands that are build by eco has all parameters on the form ":ParamName". If your database expects the parameters in a different way, you need to find the parameters and replace then with the kind of parameter identifier that will work. There are a couple of predefined string manipulations that you can use.

Related Topics

ConvertParametersToColonPrefix, ConvertParametersToAtPrefix, ConvertParametersToLiterals, ConvertParametersToQuestionMarks, ConvertParametersToUpperCase

See Also
BdpIDatabaseImpl Class
Eco.Persistence.Connection Namespace
Related Topics


BdpIDatabaseImpl Properties

BdpIDatabaseImpl Properties
Public Properties
Collapse All

The properties of the BdpIDatabaseImpl class are listed here.

Public Properties
Name | Description
AlwaysReadInTransactions | This is AlwaysReadInTransactions, a member of class BdpIDatabaseImpl.
DbConnection | This is DbConnection, a member of class BdpIDatabaseImpl.


BdpIDatabaseImpl.AlwaysReadInTransactions Property

BdpIDatabaseImpl.AlwaysReadInTransactions Property
BdpIDatabaseImpl Class Eco.Persistence.Connection Namespace See Also
Collapse All
C#
public override bool AlwaysReadInTransactions;
Remarks

This is AlwaysReadInTransactions, a member of class BdpIDatabaseImpl.

See Also
BdpIDatabaseImpl Class
Eco.Persistence.Connection Namespace


BdpIDatabaseImpl.DbConnection Property

BdpIDatabaseImpl.DbConnection Property
BdpIDatabaseImpl Class Eco.Persistence.Connection Namespace See Also
Collapse All
C#
public override IDbConnection DbConnection;
Remarks

This is DbConnection, a member of class BdpIDatabaseImpl.

See Also
BdpIDatabaseImpl Class
Eco.Persistence.Connection Namespace


DatabaseCollection Class

DatabaseCollection Class
Inheritance Hierarchy See Also
Collapse All
C#
public class DatabaseCollection : IDatabaseCollection;
Remarks

This is class Eco.Persistence.Connection.DatabaseCollection.

Inheritance Hierarchy
Eco.Persistence.Connection.IDatabaseCollection
    Eco.Persistence.Connection.DatabaseCollection
File

DataInterfaces.cs

See Also
Inheritance Hierarchy


DatabaseCollection.DatabaseCollection Constructor

DatabaseCollection.DatabaseCollection Constructor
DatabaseCollection Class Eco.Persistence.Connection Namespace See Also
Collapse All
C#
public DatabaseCollection(
    ITransactionManager transactionManager
);
Remarks

This is DatabaseCollection, a member of class DatabaseCollection.

See Also
DatabaseCollection Class
Eco.Persistence.Connection Namespace


DatabaseCollection Methods

DatabaseCollection Methods
Public Methods
Collapse All

The methods of the DatabaseCollection class are listed here.

Public Methods
Name | Description
Add | This is Add, a member of class DatabaseCollection.
GetDatabase | This is GetDatabase, a member of class DatabaseCollection.
GetEnumerator | This is GetEnumerator, a member of class DatabaseCollection.
GetNames | This is GetNames, a member of class DatabaseCollection.


DatabaseCollection.Add Method

DatabaseCollection.Add Method
DatabaseCollection Class Eco.Persistence.Connection Namespace See Also
Collapse All
C#
public void Add(
    IDatabase db,
    string name
);
Remarks

This is Add, a member of class DatabaseCollection.

See Also
DatabaseCollection Class
Eco.Persistence.Connection Namespace


DatabaseCollection.GetDatabase Method

DatabaseCollection.GetDatabase Method
DatabaseCollection Class Eco.Persistence.Connection Namespace See Also
Collapse All
C#
public IDatabase GetDatabase(
    string name
);
Remarks

This is GetDatabase, a member of class DatabaseCollection.

See Also
DatabaseCollection Class
Eco.Persistence.Connection Namespace


DatabaseCollection.GetEnumerator Method

DatabaseCollection.GetEnumerator Method
DatabaseCollection Class Eco.Persistence.Connection Namespace See Also
Collapse All
C#
public IEnumerator GetEnumerator();
Remarks

This is GetEnumerator, a member of class DatabaseCollection.

See Also
DatabaseCollection Class
Eco.Persistence.Connection Namespace


DatabaseCollection.GetNames Method

DatabaseCollection.GetNames Method
DatabaseCollection Class Eco.Persistence.Connection Namespace See Also
Collapse All
C#
public IList<string> GetNames();
Remarks

This is GetNames, a member of class DatabaseCollection.

See Also
DatabaseCollection Class
Eco.Persistence.Connection Namespace


DatabaseCollection Properties

DatabaseCollection Properties
Public Properties
Collapse All

The properties of the DatabaseCollection class are listed here.

Public Properties
Name | Description
HandlesTransactions | This is HandlesTransactions, a member of class DatabaseCollection.
TransactionManager | This is TransactionManager, a member of class DatabaseCollection.


DatabaseCollection.HandlesTransactions Property

DatabaseCollection.HandlesTransactions Property
DatabaseCollection Class Eco.Persistence.Connection Namespace See Also
Collapse All
C#
public bool HandlesTransactions;
Remarks

This is HandlesTransactions, a member of class DatabaseCollection.

See Also
DatabaseCollection Class
Eco.Persistence.Connection Namespace


DatabaseCollection.TransactionManager Property

DatabaseCollection.TransactionManager Property
DatabaseCollection Class Eco.Persistence.Connection Namespace See Also
Collapse All
C#
public ITransactionManager TransactionManager;
Remarks

This is TransactionManager, a member of class DatabaseCollection.

See Also
DatabaseCollection Class
Eco.Persistence.Connection Namespace


DatabaseOperationFailedException Class

DatabaseOperationFailedException Class
Inheritance Hierarchy See Also
Collapse All
C#
public class DatabaseOperationFailedException : Exception;
Remarks

This is class Eco.Persistence.Connection.DatabaseOperationFailedException.

Inheritance Hierarchy
Eco.Persistence.Connection.DatabaseOperationFailedException
File

DatabaseImpl.cs

See Also
Inheritance Hierarchy


DatabaseOperationFailedException Constructor

DatabaseOperationFailedException Constructor

This is the overview for the DatabaseOperationFailedException constructor overload.

Overload List
Name | Description
DatabaseOperationFailedException.DatabaseOperationFailedException (SerializationInfo, StreamingContext) | This is DatabaseOperationFailedException, a member of class DatabaseOperationFailedException.
DatabaseOperationFailedException.DatabaseOperationFailedException (string, Exception) | This is DatabaseOperationFailedException, a member of class DatabaseOperationFailedException.


DatabaseOperationFailedException.DatabaseOperationFailedException Constructor (SerializationInfo, StreamingContext)

DatabaseOperationFailedException.DatabaseOperationFailedException Constructor (SerializationInfo, StreamingContext)
DatabaseOperationFailedException Class Eco.Persistence.Connection Namespace See Also
Collapse All
C#
protected DatabaseOperationFailedException(
    SerializationInfo info,
    StreamingContext context
);
Remarks

This is DatabaseOperationFailedException, a member of class DatabaseOperationFailedException.

See Also
DatabaseOperationFailedException Class
Eco.Persistence.Connection Namespace


DatabaseOperationFailedException.DatabaseOperationFailedException Constructor (string, Exception)

DatabaseOperationFailedException.DatabaseOperationFailedException Constructor (string, Exception)
DatabaseOperationFailedException Class Eco.Persistence.Connection Namespace See Also
Collapse All
C#
public DatabaseOperationFailedException(
    string message,
    Exception innerException
);
Remarks

This is DatabaseOperationFailedException, a member of class DatabaseOperationFailedException.

See Also
DatabaseOperationFailedException Class
Eco.Persistence.Connection Namespace


DbxIDatabaseImpl Class

DbxIDatabaseImpl Class
Inheritance Hierarchy See Also
Collapse All
C#
public sealed class DbxIDatabaseImpl : Ado2IDatabaseImpl;
Remarks

This is class Eco.Persistence.Connection.DbxIDatabaseImpl.

Inheritance Hierarchy
Eco.Persistence.IDistributedTransactionParticipant
    Eco.Persistence.Connection.Ado2IDatabaseImpl
        Eco.Persistence.Connection.DbxIDatabaseImpl
File

DbxDatabaseImpl.cs

See Also
Inheritance Hierarchy


DbxIDatabaseImpl.DbxIDatabaseImpl Constructor

DbxIDatabaseImpl.DbxIDatabaseImpl Constructor
DbxIDatabaseImpl Class Eco.Persistence.Connection Namespace See Also
Collapse All
C#
public DbxIDatabaseImpl(
    DbConnection connection,
    SqlDatabaseConfig config
);
Remarks

This is DbxIDatabaseImpl, a member of class DbxIDatabaseImpl.

See Also
DbxIDatabaseImpl Class
Eco.Persistence.Connection Namespace


DbxIDatabaseImpl Methods

DbxIDatabaseImpl Methods
Protected Methods Public Methods
Collapse All

The methods of the DbxIDatabaseImpl class are listed here.

Protected Methods
Name | Description
HandleCommandParameters | This is HandleCommandParameters, a member of class DbxIDatabaseImpl.
Top
Public Methods
Name | Description
AllTableNames | This is AllTableNames, a member of class DbxIDatabaseImpl.
GetIndexDefsForTable | This method uses the DbConnection.GetSchema method to find all indices defined for a table.


DbxIDatabaseImpl.AllTableNames Method

DbxIDatabaseImpl.AllTableNames Method
DbxIDatabaseImpl Class Eco.Persistence.Connection Namespace See Also
Collapse All
C#
public override IList<string> AllTableNames(
    string pattern
);
Remarks

This is AllTableNames, a member of class DbxIDatabaseImpl.

See Also
DbxIDatabaseImpl Class
Eco.Persistence.Connection Namespace


DbxIDatabaseImpl.GetIndexDefsForTable Method

DbxIDatabaseImpl.GetIndexDefsForTable Method
DbxIDatabaseImpl Class Eco.Persistence.Connection Namespace See Also
Collapse All

This method uses the DbConnection.GetSchema method to find all indices defined for a table.

C#
public override DataTable GetIndexDefsForTable(
    string tableName
);
See Also
DbxIDatabaseImpl Class
Eco.Persistence.Connection Namespace


DbxIDatabaseImpl.HandleCommandParameters Method

DbxIDatabaseImpl.HandleCommandParameters Method
DbxIDatabaseImpl Class Eco.Persistence.Connection Namespace See Also
Collapse All
C#
protected override string HandleCommandParameters(
    string commandText,
    IDataParameterCollection parameters
);
Remarks

This is HandleCommandParameters, a member of class DbxIDatabaseImpl.

See Also
DbxIDatabaseImpl Class
Eco.Persistence.Connection Namespace


DbxIDatabaseImpl Properties

DbxIDatabaseImpl Properties
Public Properties
Collapse All

The properties of the DbxIDatabaseImpl class are listed here.

Public Properties
Name | Description
AlwaysReadInTransactions | This is AlwaysReadInTransactions, a member of class DbxIDatabaseImpl.


DbxIDatabaseImpl.AlwaysReadInTransactions Property

DbxIDatabaseImpl.AlwaysReadInTransactions Property
DbxIDatabaseImpl Class Eco.Persistence.Connection Namespace See Also
Collapse All
C#
public override bool AlwaysReadInTransactions;
Remarks

This is AlwaysReadInTransactions, a member of class DbxIDatabaseImpl.

See Also
DbxIDatabaseImpl Class
Eco.Persistence.Connection Namespace


FirebirdIDatabaseImpl Class

FirebirdIDatabaseImpl Class
Inheritance Hierarchy See Also
Collapse All
C#
public sealed class FirebirdIDatabaseImpl : Ado2IDatabaseImpl;
Remarks

This is class Eco.Persistence.Connection.FirebirdIDatabaseImpl.

Inheritance Hierarchy
Eco.Persistence.IDistributedTransactionParticipant
    Eco.Persistence.Connection.Ado2IDatabaseImpl
        Eco.Persistence.Connection.FirebirdIDatabaseImpl
File

FirebirdDatabaseImpl.cs

See Also
Inheritance Hierarchy


FirebirdIDatabaseImpl.FirebirdIDatabaseImpl Constructor

FirebirdIDatabaseImpl.FirebirdIDatabaseImpl Constructor
FirebirdIDatabaseImpl Class Eco.Persistence.Connection Namespace See Also
Collapse All
C#
public FirebirdIDatabaseImpl(
    DbConnection connection,
    SqlDatabaseConfig config
);
Remarks

This is FirebirdIDatabaseImpl, a member of class FirebirdIDatabaseImpl.

See Also
FirebirdIDatabaseImpl Class
Eco.Persistence.Connection Namespace


FirebirdIDatabaseImpl Methods

FirebirdIDatabaseImpl Methods
Protected Methods Public Methods
Collapse All

The methods of the FirebirdIDatabaseImpl class are listed here.

Protected Methods
Name | Description
HandleCommandParameters | This is HandleCommandParameters, a member of class FirebirdIDatabaseImpl.
Top
Public Methods
Name | Description
AllTableNames | This is AllTableNames, a member of class FirebirdIDatabaseImpl.
GetIndexDefsForTable | This method uses the DbConnection.GetSchema method to find all indices defined for a table.


FirebirdIDatabaseImpl.AllTableNames Method

FirebirdIDatabaseImpl.AllTableNames Method
FirebirdIDatabaseImpl Class Eco.Persistence.Connection Namespace See Also
Collapse All
C#
public override IList<string> AllTableNames(
    string pattern
);
Remarks

This is AllTableNames, a member of class FirebirdIDatabaseImpl.

See Also
FirebirdIDatabaseImpl Class
Eco.Persistence.Connection Namespace


FirebirdIDatabaseImpl.GetIndexDefsForTable Method

FirebirdIDatabaseImpl.GetIndexDefsForTable Method
FirebirdIDatabaseImpl Class Eco.Persistence.Connection Namespace See Also
Collapse All

This method uses the DbConnection.GetSchema method to find all indices defined for a table.

C#
public override DataTable GetIndexDefsForTable(
    string tableName
);
See Also
FirebirdIDatabaseImpl Class
Eco.Persistence.Connection Namespace


FirebirdIDatabaseImpl.HandleCommandParameters Method

FirebirdIDatabaseImpl.HandleCommandParameters Method
FirebirdIDatabaseImpl Class Eco.Persistence.Connection Namespace See Also
Collapse All
C#
protected override string HandleCommandParameters(
    string commandText,
    IDataParameterCollection parameters
);
Remarks

This is HandleCommandParameters, a member of class FirebirdIDatabaseImpl.

See Also
FirebirdIDatabaseImpl Class
Eco.Persistence.Connection Namespace


FirebirdIDatabaseImpl Properties

FirebirdIDatabaseImpl Properties
Public Properties
Collapse All

The properties of the FirebirdIDatabaseImpl class are listed here.

Public Properties
Name | Description
AlwaysReadInTransactions | This is AlwaysReadInTransactions, a member of class FirebirdIDatabaseImpl.


FirebirdIDatabaseImpl.AlwaysReadInTransactions Property

FirebirdIDatabaseImpl.AlwaysReadInTransactions Property
FirebirdIDatabaseImpl Class Eco.Persistence.Connection Namespace See Also
Collapse All
C#
public override bool AlwaysReadInTransactions;
Remarks

This is AlwaysReadInTransactions, a member of class FirebirdIDatabaseImpl.

See Also
FirebirdIDatabaseImpl Class
Eco.Persistence.Connection Namespace


MimerIDatabaseImpl Class

MimerIDatabaseImpl Class
Inheritance Hierarchy See Also
Collapse All
C#
public sealed class MimerIDatabaseImpl : Ado2IDatabaseImpl;
Remarks

This is class Eco.Persistence.Connection.MimerIDatabaseImpl.

Inheritance Hierarchy
Eco.Persistence.IDistributedTransactionParticipant
    Eco.Persistence.Connection.Ado2IDatabaseImpl
        Eco.Persistence.Connection.MimerIDatabaseImpl
File

MimerDatabaseImpl.cs

See Also
Inheritance Hierarchy


MimerIDatabaseImpl.MimerIDatabaseImpl Constructor

MimerIDatabaseImpl.MimerIDatabaseImpl Constructor
MimerIDatabaseImpl Class Eco.Persistence.Connection Namespace See Also
Collapse All
C#
public MimerIDatabaseImpl(
    DbConnection connection,
    SqlDatabaseConfig config
);
Remarks

This is MimerIDatabaseImpl, a member of class MimerIDatabaseImpl.

See Also
MimerIDatabaseImpl Class
Eco.Persistence.Connection Namespace


MimerIDatabaseImpl Methods

MimerIDatabaseImpl Methods
Protected Methods Public Methods
Collapse All

The methods of the MimerIDatabaseImpl class are listed here.

Protected Methods
Name | Description
HandleCommandParameters | This is HandleCommandParameters, a member of class MimerIDatabaseImpl.
Top
Public Methods
Name | Description
AllTableNames | This is AllTableNames, a member of class MimerIDatabaseImpl.
GetIndexDefsForTable | This method uses the DbConnection.GetSchema method to find all indices defined for a table.


MimerIDatabaseImpl.AllTableNames Method

MimerIDatabaseImpl.AllTableNames Method
MimerIDatabaseImpl Class Eco.Persistence.Connection Namespace See Also
Collapse All
C#
public override IList<string> AllTableNames(
    string pattern
);
Remarks

This is AllTableNames, a member of class MimerIDatabaseImpl.

See Also
MimerIDatabaseImpl Class
Eco.Persistence.Connection Namespace


MimerIDatabaseImpl.GetIndexDefsForTable Method

MimerIDatabaseImpl.GetIndexDefsForTable Method
MimerIDatabaseImpl Class Eco.Persistence.Connection Namespace See Also
Collapse All

This method uses the DbConnection.GetSchema method to find all indices defined for a table.

C#
public override DataTable GetIndexDefsForTable(
    string tableName
);
See Also
MimerIDatabaseImpl Class
Eco.Persistence.Connection Namespace


MimerIDatabaseImpl.HandleCommandParameters Method

MimerIDatabaseImpl.HandleCommandParameters Method
MimerIDatabaseImpl Class Eco.Persistence.Connection Namespace See Also
Collapse All
C#
protected override string HandleCommandParameters(
    string commandText,
    IDataParameterCollection parameters
);
Remarks

This is HandleCommandParameters, a member of class MimerIDatabaseImpl.

See Also
MimerIDatabaseImpl Class
Eco.Persistence.Connection Namespace


MimerIDatabaseImpl Properties

MimerIDatabaseImpl Properties
Public Properties
Collapse All

The properties of the MimerIDatabaseImpl class are listed here.

Public Properties
Name | Description
AlwaysReadInTransactions | This is AlwaysReadInTransactions, a member of class MimerIDatabaseImpl.


MimerIDatabaseImpl.AlwaysReadInTransactions Property

MimerIDatabaseImpl.AlwaysReadInTransactions Property
MimerIDatabaseImpl Class Eco.Persistence.Connection Namespace See Also
Collapse All
C#
public override bool AlwaysReadInTransactions;
Remarks

This is AlwaysReadInTransactions, a member of class MimerIDatabaseImpl.

See Also
MimerIDatabaseImpl Class
Eco.Persistence.Connection Namespace


MySqlIDatabaseImpl Class

MySqlIDatabaseImpl Class
Inheritance Hierarchy See Also
Collapse All
C#
public sealed class MySqlIDatabaseImpl : AbstractIDatabaseImpl;
Remarks

This is class Eco.Persistence.Connection.MySqlIDatabaseImpl.

Inheritance Hierarchy
Eco.Persistence.Connection.IDatabase
    Eco.Persistence.Connection.AbstractIDatabaseImpl
        Eco.Persistence.Connection.MySqlIDatabaseImpl
File

MySqlDatabaseImpl.cs

See Also
Inheritance Hierarchy


MySqlIDatabaseImpl.MySqlIDatabaseImpl Constructor

MySqlIDatabaseImpl.MySqlIDatabaseImpl Constructor
MySqlIDatabaseImpl Class Eco.Persistence.Connection Namespace See Also
Collapse All
C#
public MySqlIDatabaseImpl(
    MySqlConnection connection,
    SqlDatabaseConfig config,
    bool useInformationSchema
);
Remarks

This is MySqlIDatabaseImpl, a member of class MySqlIDatabaseImpl.

See Also
MySqlIDatabaseImpl Class
Eco.Persistence.Connection Namespace


MySqlIDatabaseImpl Methods

MySqlIDatabaseImpl Methods
Protected Methods Public Methods
Collapse All

The methods of the MySqlIDatabaseImpl class are listed here.

Protected Methods
Name | Description
CreateCommand | This is CreateCommand, a member of class MySqlIDatabaseImpl.
HandleCommandParameters | This method must be overridden to handle how query parameters should be sent to the datbase.
Top
Public Methods
Name | Description
AllTableNames | Should return a list of all tables in the database that matches the pattern.
CreateColumn | This is the overview for the CreateColumn method overload.
GetIndexDefsForTable | This method should return a datatable with all the index definitions for the specified table.


MySqlIDatabaseImpl.AllTableNames Method

MySqlIDatabaseImpl.AllTableNames Method
MySqlIDatabaseImpl Class Eco.Persistence.Connection Namespace See Also
Collapse All

Should return a list of all tables in the database that matches the pattern.

C#
public override IList<string> AllTableNames(
    string pattern
);
Parameters
Parameters | Description
pattern | If this parameter is non-empty, only tables with this name should be returned, The name of the table is case insensitive.
See Also
MySqlIDatabaseImpl Class
Eco.Persistence.Connection Namespace


CreateColumn Method

CreateColumn Method

This is the overview for the CreateColumn method overload.

Overload List
Name | Description
MySqlIDatabaseImpl.CreateColumn (String, String) | This is CreateColumn, a member of class MySqlIDatabaseImpl.
MySqlIDatabaseImpl.CreateColumn (String, String, bool) | This is CreateColumn, a member of class MySqlIDatabaseImpl.


MySqlIDatabaseImpl.CreateColumn Method (String, String)

MySqlIDatabaseImpl.CreateColumn Method (String, String)
MySqlIDatabaseImpl Class Eco.Persistence.Connection Namespace See Also
Collapse All
C#
public static DataColumn CreateColumn(
    String name,
    String dataType
);
Remarks

This is CreateColumn, a member of class MySqlIDatabaseImpl.

See Also
MySqlIDatabaseImpl Class
Eco.Persistence.Connection Namespace


MySqlIDatabaseImpl.CreateColumn Method (String, String, bool)

MySqlIDatabaseImpl.CreateColumn Method (String, String, bool)
MySqlIDatabaseImpl Class Eco.Persistence.Connection Namespace See Also
Collapse All
C#
public static DataColumn CreateColumn(
    String name,
    String dataType,
    bool readOnly
);
Remarks

This is CreateColumn, a member of class MySqlIDatabaseImpl.

See Also
MySqlIDatabaseImpl Class
Eco.Persistence.Connection Namespace


MySqlIDatabaseImpl.CreateCommand Method

MySqlIDatabaseImpl.CreateCommand Method
MySqlIDatabaseImpl Class Eco.Persistence.Connection Namespace See Also
Collapse All
C#
protected override AbstractIQueryImpl CreateCommand();
Remarks

This is CreateCommand, a member of class MySqlIDatabaseImpl.

See Also
MySqlIDatabaseImpl Class
Eco.Persistence.Connection Namespace


MySqlIDatabaseImpl.GetIndexDefsForTable Method

MySqlIDatabaseImpl.GetIndexDefsForTable Method
MySqlIDatabaseImpl Class Eco.Persistence.Connection Namespace See Also
Collapse All

This method should return a datatable with all the index definitions for the specified table.

C#
public override DataTable GetIndexDefsForTable(
    string tableName
);
Remarks

The returned datatable should contain one row for each column in each index (with the indexname and the columnname). This is used when a column has to be dropped during Evolve so that any indexes can be dropped first.

See Also
MySqlIDatabaseImpl Class
Eco.Persistence.Connection Namespace


MySqlIDatabaseImpl.HandleCommandParameters Method

MySqlIDatabaseImpl.HandleCommandParameters Method
MySqlIDatabaseImpl Class Eco.Persistence.Connection Namespace Related Topics See Also
Collapse All

This method must be overridden to handle how query parameters should be sent to the datbase.

C#
protected override string HandleCommandParameters(
    string commandText,
    IDataParameterCollection parameters
);
Remarks

The sql-commands that are build by eco has all parameters on the form ":ParamName". If your database expects the parameters in a different way, you need to find the parameters and replace then with the kind of parameter identifier that will work. There are a couple of predefined string manipulations that you can use.

Related Topics

ConvertParametersToColonPrefix, ConvertParametersToAtPrefix, ConvertParametersToLiterals, ConvertParametersToQuestionMarks, ConvertParametersToUpperCase

See Also
MySqlIDatabaseImpl Class
Eco.Persistence.Connection Namespace
Related Topics


MySqlIDatabaseImpl Properties

MySqlIDatabaseImpl Properties
Public Properties
Collapse All

The properties of the MySqlIDatabaseImpl class are listed here.

Public Properties
Name | Description
DbConnection | This is DbConnection, a member of class MySqlIDatabaseImpl.


MySqlIDatabaseImpl.DbConnection Property

MySqlIDatabaseImpl.DbConnection Property
MySqlIDatabaseImpl Class Eco.Persistence.Connection Namespace See Also
Collapse All
C#
public override IDbConnection DbConnection;
Remarks

This is DbConnection, a member of class MySqlIDatabaseImpl.

See Also
MySqlIDatabaseImpl Class
Eco.Persistence.Connection Namespace


OracleIDatabaseImpl Class

OracleIDatabaseImpl Class
Inheritance Hierarchy See Also
Collapse All
C#
public sealed class OracleIDatabaseImpl : Ado2IDatabaseImpl;
Remarks

This is class Eco.Persistence.Connection.OracleIDatabaseImpl.

Inheritance Hierarchy
Eco.Persistence.IDistributedTransactionParticipant
    Eco.Persistence.Connection.Ado2IDatabaseImpl
        Eco.Persistence.Connection.OracleIDatabaseImpl
File

OracleDatabaseImpl.cs

See Also
Inheritance Hierarchy


OracleIDatabaseImpl.OracleIDatabaseImpl Constructor

OracleIDatabaseImpl.OracleIDatabaseImpl Constructor
OracleIDatabaseImpl Class Eco.Persistence.Connection Namespace See Also
Collapse All
C#
public OracleIDatabaseImpl(
    DbConnection connection,
    SqlDatabaseConfig config
);
Remarks

This is OracleIDatabaseImpl, a member of class OracleIDatabaseImpl.

See Also
OracleIDatabaseImpl Class
Eco.Persistence.Connection Namespace


OracleIDatabaseImpl Methods

OracleIDatabaseImpl Methods
Protected Methods Public Methods
Collapse All

The methods of the OracleIDatabaseImpl class are listed here.

Protected Methods
Name | Description
HandleCommandParameters | This is HandleCommandParameters, a member of class OracleIDatabaseImpl.
InternalEnlistInTransaction | Enlists the connection in a distributed transaction.
Top
Public Methods
Name | Description
AllTableNames | This is AllTableNames, a member of class OracleIDatabaseImpl.


OracleIDatabaseImpl.AllTableNames Method

OracleIDatabaseImpl.AllTableNames Method
OracleIDatabaseImpl Class Eco.Persistence.Connection Namespace See Also
Collapse All
C#
public override IList<string> AllTableNames(
    string pattern
);
Remarks

This is AllTableNames, a member of class OracleIDatabaseImpl.

See Also
OracleIDatabaseImpl Class
Eco.Persistence.Connection Namespace


OracleIDatabaseImpl.HandleCommandParameters Method

OracleIDatabaseImpl.HandleCommandParameters Method
OracleIDatabaseImpl Class Eco.Persistence.Connection Namespace See Also
Collapse All
C#
protected override string HandleCommandParameters(
    string commandText,
    IDataParameterCollection parameters
);
Remarks

This is HandleCommandParameters, a member of class OracleIDatabaseImpl.

See Also
OracleIDatabaseImpl Class
Eco.Persistence.Connection Namespace


OracleIDatabaseImpl.InternalEnlistInTransaction Method

OracleIDatabaseImpl.InternalEnlistInTransaction Method
OracleIDatabaseImpl Class Eco.Persistence.Connection Namespace See Also
Collapse All

Enlists the connection in a distributed transaction.

C#
protected override void InternalEnlistInTransaction(
    object transaction
);
Remarks

Override this method if the connection supports other transaction mechanisms (such as ITransaction)

See Also
OracleIDatabaseImpl Class
Eco.Persistence.Connection Namespace


SqlIDatabaseImpl Class

SqlIDatabaseImpl Class
Inheritance Hierarchy See Also
Collapse All
C#
public sealed class SqlIDatabaseImpl : Ado2IDatabaseImpl;
Remarks

This is class Eco.Persistence.Connection.SqlIDatabaseImpl.

Inheritance Hierarchy
Eco.Persistence.IDistributedTransactionParticipant
    Eco.Persistence.Connection.Ado2IDatabaseImpl
        Eco.Persistence.Connection.SqlIDatabaseImpl
File

SqlDatabaseImpl.cs

See Also
Inheritance Hierarchy


SqlIDatabaseImpl.SqlIDatabaseImpl Constructor

SqlIDatabaseImpl.SqlIDatabaseImpl Constructor
SqlIDatabaseImpl Class Eco.Persistence.Connection Namespace See Also
Collapse All
C#
public SqlIDatabaseImpl(
    DbConnection connection,
    SqlDatabaseConfig config
);
Remarks

This is SqlIDatabaseImpl, a member of class SqlIDatabaseImpl.

See Also
SqlIDatabaseImpl Class
Eco.Persistence.Connection Namespace


SqlIDatabaseImpl Methods

SqlIDatabaseImpl Methods
Protected Methods Public Methods
Collapse All

The methods of the SqlIDatabaseImpl class are listed here.

Protected Methods
Name | Description
HandleCommandParameters | This is HandleCommandParameters, a member of class SqlIDatabaseImpl.
InternalEnlistInTransaction | Enlists the connection in a distributed transaction.
Top
Public Methods
Name | Description
AllTableNames | This is AllTableNames, a member of class SqlIDatabaseImpl.


SqlIDatabaseImpl.AllTableNames Method

SqlIDatabaseImpl.AllTableNames Method
SqlIDatabaseImpl Class Eco.Persistence.Connection Namespace See Also
Collapse All
C#
public override IList<string> AllTableNames(
    string pattern
);
Remarks

This is AllTableNames, a member of class SqlIDatabaseImpl.

See Also
SqlIDatabaseImpl Class
Eco.Persistence.Connection Namespace


SqlIDatabaseImpl.HandleCommandParameters Method

SqlIDatabaseImpl.HandleCommandParameters Method
SqlIDatabaseImpl Class Eco.Persistence.Connection Namespace See Also
Collapse All
C#
protected override string HandleCommandParameters(
    string commandText,
    IDataParameterCollection parameters
);
Remarks

This is HandleCommandParameters, a member of class SqlIDatabaseImpl.

See Also
SqlIDatabaseImpl Class
Eco.Persistence.Connection Namespace


SqlIDatabaseImpl.InternalEnlistInTransaction Method

SqlIDatabaseImpl.InternalEnlistInTransaction Method
SqlIDatabaseImpl Class Eco.Persistence.Connection Namespace See Also
Collapse All

Enlists the connection in a distributed transaction.

C#
protected override void InternalEnlistInTransaction(
    object transaction
);
Remarks

Override this method if the connection supports other transaction mechanisms (such as ITransaction)

See Also
SqlIDatabaseImpl Class
Eco.Persistence.Connection Namespace


SQLiteIDatabaseImpl Class

SQLiteIDatabaseImpl Class
Inheritance Hierarchy See Also
Collapse All
C#
public sealed class SQLiteIDatabaseImpl : Ado2IDatabaseImpl;
Remarks

This is class Eco.Persistence.Connection.SQLiteIDatabaseImpl.

Inheritance Hierarchy
Eco.Persistence.IDistributedTransactionParticipant
    Eco.Persistence.Connection.Ado2IDatabaseImpl
        Eco.Persistence.Connection.SQLiteIDatabaseImpl
File

SQLiteDatabaseImpl.cs

See Also
Inheritance Hierarchy


SQLiteIDatabaseImpl.SQLiteIDatabaseImpl Constructor

SQLiteIDatabaseImpl.SQLiteIDatabaseImpl Constructor
SQLiteIDatabaseImpl Class Eco.Persistence.Connection Namespace See Also
Collapse All
C#
public SQLiteIDatabaseImpl(
    DbConnection connection,
    SqlDatabaseConfig config
);
Remarks

This is SQLiteIDatabaseImpl, a member of class SQLiteIDatabaseImpl.

See Also
SQLiteIDatabaseImpl Class
Eco.Persistence.Connection Namespace


SQLiteIDatabaseImpl Methods

SQLiteIDatabaseImpl Methods
Protected Methods Public Methods
Collapse All

The methods of the SQLiteIDatabaseImpl class are listed here.

Protected Methods
Name | Description
HandleCommandParameters | This is HandleCommandParameters, a member of class SQLiteIDatabaseImpl.
Top
Public Methods
Name | Description
AllTableNames | This is AllTableNames, a member of class SQLiteIDatabaseImpl.
GetIndexDefsForTable | This method uses the DbConnection.GetSchema method to find all indices defined for a table.


SQLiteIDatabaseImpl.AllTableNames Method

SQLiteIDatabaseImpl.AllTableNames Method
SQLiteIDatabaseImpl Class Eco.Persistence.Connection Namespace See Also
Collapse All
C#
public override IList<string> AllTableNames(
    string pattern
);
Remarks

This is AllTableNames, a member of class SQLiteIDatabaseImpl.

See Also
SQLiteIDatabaseImpl Class
Eco.Persistence.Connection Namespace


SQLiteIDatabaseImpl.GetIndexDefsForTable Method

SQLiteIDatabaseImpl.GetIndexDefsForTable Method
SQLiteIDatabaseImpl Class Eco.Persistence.Connection Namespace See Also
Collapse All

This method uses the DbConnection.GetSchema method to find all indices defined for a table.

C#
public override DataTable GetIndexDefsForTable(
    string tableName
);
See Also
SQLiteIDatabaseImpl Class
Eco.Persistence.Connection Namespace


SQLiteIDatabaseImpl.HandleCommandParameters Method

SQLiteIDatabaseImpl.HandleCommandParameters Method
SQLiteIDatabaseImpl Class Eco.Persistence.Connection Namespace See Also
Collapse All
C#
protected override string HandleCommandParameters(
    string commandText,
    IDataParameterCollection parameters
);
Remarks

This is HandleCommandParameters, a member of class SQLiteIDatabaseImpl.

See Also
SQLiteIDatabaseImpl Class
Eco.Persistence.Connection Namespace


SQLiteIDatabaseImpl Properties

SQLiteIDatabaseImpl Properties
Public Properties
Collapse All

The properties of the SQLiteIDatabaseImpl class are listed here.

Public Properties
Name | Description
AlwaysReadInTransactions | This is AlwaysReadInTransactions, a member of class SQLiteIDatabaseImpl.


SQLiteIDatabaseImpl.AlwaysReadInTransactions Property

SQLiteIDatabaseImpl.AlwaysReadInTransactions Property
SQLiteIDatabaseImpl Class Eco.Persistence.Connection Namespace See Also
Collapse All
C#
public override bool AlwaysReadInTransactions;
Remarks

This is AlwaysReadInTransactions, a member of class SQLiteIDatabaseImpl.

See Also
SQLiteIDatabaseImpl Class
Eco.Persistence.Connection Namespace


SybaseIDatabaseImpl Class

SybaseIDatabaseImpl Class
Inheritance Hierarchy See Also
Collapse All
C#
public sealed class SybaseIDatabaseImpl : AbstractIDatabaseImpl;
Remarks

This is class Eco.Persistence.Connection.SybaseIDatabaseImpl.

Inheritance Hierarchy
Eco.Persistence.Connection.IDatabase
    Eco.Persistence.Connection.AbstractIDatabaseImpl
        Eco.Persistence.Connection.SybaseIDatabaseImpl
File

SybaseDatabaseImpl.cs

See Also
Inheritance Hierarchy


SybaseIDatabaseImpl.SybaseIDatabaseImpl Constructor

SybaseIDatabaseImpl.SybaseIDatabaseImpl Constructor
SybaseIDatabaseImpl Class Eco.Persistence.Connection Namespace See Also
Collapse All
C#
public SybaseIDatabaseImpl(
    AseConnection connection,
    SqlDatabaseConfig config
);
Remarks

This is SybaseIDatabaseImpl, a member of class SybaseIDatabaseImpl.

See Also
SybaseIDatabaseImpl Class
Eco.Persistence.Connection Namespace


SybaseIDatabaseImpl Methods

SybaseIDatabaseImpl Methods
Protected Methods Public Methods
Collapse All

The methods of the SybaseIDatabaseImpl class are listed here.

Protected Methods
Name | Description
CreateCommand | This is CreateCommand, a member of class SybaseIDatabaseImpl.
HandleCommandParameters | This method must be overridden to handle how query parameters should be sent to the datbase.
Top
Public Methods
Name | Description
AllTableNames | Should return a list of all tables in the database that matches the pattern.
CreateColumn | This is the overview for the CreateColumn method overload.
GetIndexDefsForTable | This method should return a datatable with all the index definitions for the specified table.


SybaseIDatabaseImpl.AllTableNames Method

SybaseIDatabaseImpl.AllTableNames Method
SybaseIDatabaseImpl Class Eco.Persistence.Connection Namespace See Also
Collapse All

Should return a list of all tables in the database that matches the pattern.

C#
public override IList<string> AllTableNames(
    string pattern
);
Parameters
Parameters | Description
pattern | If this parameter is non-empty, only tables with this name should be returned, The name of the table is case insensitive.
See Also
SybaseIDatabaseImpl Class
Eco.Persistence.Connection Namespace


CreateColumn Method

CreateColumn Method

This is the overview for the CreateColumn method overload.

Overload List
Name | Description
SybaseIDatabaseImpl.CreateColumn (String, String) | This is CreateColumn, a member of class SybaseIDatabaseImpl.
SybaseIDatabaseImpl.CreateColumn (String, String, bool) | This is CreateColumn, a member of class SybaseIDatabaseImpl.


SybaseIDatabaseImpl.CreateColumn Method (String, String)

SybaseIDatabaseImpl.CreateColumn Method (String, String)
SybaseIDatabaseImpl Class Eco.Persistence.Connection Namespace See Also
Collapse All
C#
public static DataColumn CreateColumn(
    String name,
    String dataType
);
Remarks

This is CreateColumn, a member of class SybaseIDatabaseImpl.

See Also
SybaseIDatabaseImpl Class
Eco.Persistence.Connection Namespace


SybaseIDatabaseImpl.CreateColumn Method (String, String, bool)

SybaseIDatabaseImpl.CreateColumn Method (String, String, bool)
SybaseIDatabaseImpl Class Eco.Persistence.Connection Namespace See Also
Collapse All
C#
public static DataColumn CreateColumn(
    String name,
    String dataType,
    bool readOnly
);
Remarks

This is CreateColumn, a member of class SybaseIDatabaseImpl.

See Also
SybaseIDatabaseImpl Class
Eco.Persistence.Connection Namespace


SybaseIDatabaseImpl.CreateCommand Method

SybaseIDatabaseImpl.CreateCommand Method
SybaseIDatabaseImpl Class Eco.Persistence.Connection Namespace See Also
Collapse All
C#
protected override AbstractIQueryImpl CreateCommand();
Remarks

This is CreateCommand, a member of class SybaseIDatabaseImpl.

See Also
SybaseIDatabaseImpl Class
Eco.Persistence.Connection Namespace


SybaseIDatabaseImpl.GetIndexDefsForTable Method

SybaseIDatabaseImpl.GetIndexDefsForTable Method
SybaseIDatabaseImpl Class Eco.Persistence.Connection Namespace See Also
Collapse All

This method should return a datatable with all the index definitions for the specified table.

C#
public override DataTable GetIndexDefsForTable(
    string tableName
);
Remarks

The returned datatable should contain one row for each column in each index (with the indexname and the columnname). This is used when a column has to be dropped during Evolve so that any indexes can be dropped first.

See Also
SybaseIDatabaseImpl Class
Eco.Persistence.Connection Namespace


SybaseIDatabaseImpl.HandleCommandParameters Method

SybaseIDatabaseImpl.HandleCommandParameters Method
SybaseIDatabaseImpl Class Eco.Persistence.Connection Namespace Related Topics See Also
Collapse All

This method must be overridden to handle how query parameters should be sent to the datbase.

C#
protected override string HandleCommandParameters(
    string commandText,
    IDataParameterCollection parameters
);
Remarks

The sql-commands that are build by eco has all parameters on the form ":ParamName". If your database expects the parameters in a different way, you need to find the parameters and replace then with the kind of parameter identifier that will work. There are a couple of predefined string manipulations that you can use.

Related Topics

ConvertParametersToColonPrefix, ConvertParametersToAtPrefix, ConvertParametersToLiterals, ConvertParametersToQuestionMarks, ConvertParametersToUpperCase

See Also
SybaseIDatabaseImpl Class
Eco.Persistence.Connection Namespace
Related Topics


SybaseIDatabaseImpl Properties

SybaseIDatabaseImpl Properties
Public Properties
Collapse All

The properties of the SybaseIDatabaseImpl class are listed here.

Public Properties
Name | Description
AlwaysReadInTransactions | This is AlwaysReadInTransactions, a member of class SybaseIDatabaseImpl.
DbConnection | This is DbConnection, a member of class SybaseIDatabaseImpl.


SybaseIDatabaseImpl.AlwaysReadInTransactions Property

SybaseIDatabaseImpl.AlwaysReadInTransactions Property
SybaseIDatabaseImpl Class Eco.Persistence.Connection Namespace See Also
Collapse All
C#
public override bool AlwaysReadInTransactions;
Remarks

This is AlwaysReadInTransactions, a member of class SybaseIDatabaseImpl.

See Also
SybaseIDatabaseImpl Class
Eco.Persistence.Connection Namespace


SybaseIDatabaseImpl.DbConnection Property

SybaseIDatabaseImpl.DbConnection Property
SybaseIDatabaseImpl Class Eco.Persistence.Connection Namespace See Also
Collapse All
C#
public override IDbConnection DbConnection;
Remarks

This is DbConnection, a member of class SybaseIDatabaseImpl.

See Also
SybaseIDatabaseImpl Class
Eco.Persistence.Connection Namespace


IDatabase Interface

IDatabase Interface
Inheritance Hierarchy See Also
Collapse All
C#
public interface IDatabase;
Remarks

This is class Eco.Persistence.Connection.IDatabase.

Inheritance Hierarchy
Eco.Persistence.Connection.IDatabase
    Eco.Persistence.Connection.AbstractIDatabaseImpl
File

DataInterfaces.cs

See Also
Inheritance Hierarchy


IDatabase Methods

IDatabase Methods
Public Methods
Collapse All

The methods of the IDatabase class are listed here.

Public Methods
Name | Description
AllTableNames | Should return a list of all tables in the database that matches the pattern.
CheckQueryStatus | Returns the current status of allocated and returned queries
Close | This is Close, a member of class IDatabase.
Commit | This is Commit, a member of class IDatabase.
DisposeConnection | This is DisposeConnection, a member of class IDatabase.
GetExecQuery | This is GetExecQuery, a member of class IDatabase.
GetIndexDefsForTable | This is GetIndexDefsForTable, a member of class IDatabase.
GetQuery | This is GetQuery, a member of class IDatabase.
Open | This is Open, a member of class IDatabase.
ReleaseCachedObjects | This is ReleaseCachedObjects, a member of class IDatabase.
ReleaseExecQuery | This is ReleaseExecQuery, a member of class IDatabase.
ReleaseQuery | This is ReleaseQuery, a member of class IDatabase.
RollBack | This is RollBack, a member of class IDatabase.
StartTransaction | This is StartTransaction, a member of class IDatabase.
TableExists | Returns true if the table exists in the database.


IDatabase.AllTableNames Method

IDatabase.AllTableNames Method
IDatabase Interface Eco.Persistence.Connection Namespace See Also
Collapse All

Should return a list of all tables in the database that matches the pattern.

C#
IList<string> AllTableNames(
    string pattern
);
Parameters
Parameters | Description
pattern | If this parameter is non-empty, only tables with this name should be returned, The name of the table is case insensitive.
See Also
IDatabase Interface
Eco.Persistence.Connection Namespace


IDatabase.CheckQueryStatus Method

IDatabase.CheckQueryStatus Method
IDatabase Interface Eco.Persistence.Connection Namespace See Also
Collapse All

Returns the current status of allocated and returned queries

C#
string CheckQueryStatus();
Remarks

If there are queries that have been allocated, but not returned, the result will be a non-empty string with a message. if there are no such queries, the return value will be an empty string

See Also
IDatabase Interface
Eco.Persistence.Connection Namespace


IDatabase.Close Method

IDatabase.Close Method
IDatabase Interface Eco.Persistence.Connection Namespace See Also
Collapse All
C#
void Close();
Remarks

This is Close, a member of class IDatabase.

See Also
IDatabase Interface
Eco.Persistence.Connection Namespace


IDatabase.Commit Method

IDatabase.Commit Method
IDatabase Interface Eco.Persistence.Connection Namespace See Also
Collapse All
C#
void Commit();
Remarks

This is Commit, a member of class IDatabase.

See Also
IDatabase Interface
Eco.Persistence.Connection Namespace


IDatabase.DisposeConnection Method

IDatabase.DisposeConnection Method
IDatabase Interface Eco.Persistence.Connection Namespace See Also
Collapse All
C#
void DisposeConnection();
Remarks

This is DisposeConnection, a member of class IDatabase.

See Also
IDatabase Interface
Eco.Persistence.Connection Namespace


IDatabase.GetExecQuery Method

IDatabase.GetExecQuery Method
IDatabase Interface Eco.Persistence.Connection Namespace See Also
Collapse All
C#
IExecQuery GetExecQuery();
Remarks

This is GetExecQuery, a member of class IDatabase.

See Also
IDatabase Interface
Eco.Persistence.Connection Namespace


IDatabase.GetIndexDefsForTable Method

IDatabase.GetIndexDefsForTable Method
IDatabase Interface Eco.Persistence.Connection Namespace See Also
Collapse All
C#
DataTable GetIndexDefsForTable(
    string tableName
);
Remarks

This is GetIndexDefsForTable, a member of class IDatabase.

See Also
IDatabase Interface
Eco.Persistence.Connection Namespace


IDatabase.GetQuery Method

IDatabase.GetQuery Method
IDatabase Interface Eco.Persistence.Connection Namespace See Also
Collapse All
C#
IQuery GetQuery();
Remarks

This is GetQuery, a member of class IDatabase.

See Also
IDatabase Interface
Eco.Persistence.Connection Namespace


IDatabase.Open Method

IDatabase.Open Method
IDatabase Interface Eco.Persistence.Connection Namespace See Also
Collapse All
C#
void Open();
Remarks

This is Open, a member of class IDatabase.

See Also
IDatabase Interface
Eco.Persistence.Connection Namespace


IDatabase.ReleaseCachedObjects Method

IDatabase.ReleaseCachedObjects Method
IDatabase Interface Eco.Persistence.Connection Namespace See Also
Collapse All
C#
void ReleaseCachedObjects();
Remarks

This is ReleaseCachedObjects, a member of class IDatabase.

See Also
IDatabase Interface
Eco.Persistence.Connection Namespace


IDatabase.ReleaseExecQuery Method

IDatabase.ReleaseExecQuery Method
IDatabase Interface Eco.Persistence.Connection Namespace See Also
Collapse All
C#
void ReleaseExecQuery(
    IExecQuery query
);
Remarks

This is ReleaseExecQuery, a member of class IDatabase.

See Also
IDatabase Interface
Eco.Persistence.Connection Namespace


IDatabase.ReleaseQuery Method

IDatabase.ReleaseQuery Method
IDatabase Interface Eco.Persistence.Connection Namespace See Also
Collapse All
C#
void ReleaseQuery(
    IQuery query
);
Remarks

This is ReleaseQuery, a member of class IDatabase.

See Also
IDatabase Interface
Eco.Persistence.Connection Namespace


IDatabase.RollBack Method

IDatabase.RollBack Method
IDatabase Interface Eco.Persistence.Connection Namespace See Also
Collapse All
C#
void RollBack();
Remarks

This is RollBack, a member of class IDatabase.

See Also
IDatabase Interface
Eco.Persistence.Connection Namespace


IDatabase.StartTransaction Method

IDatabase.StartTransaction Method
IDatabase Interface Eco.Persistence.Connection Namespace See Also
Collapse All
C#
void StartTransaction();
Remarks

This is StartTransaction, a member of class IDatabase.

See Also
IDatabase Interface
Eco.Persistence.Connection Namespace


IDatabase.TableExists Method

IDatabase.TableExists Method
IDatabase Interface Eco.Persistence.Connection Namespace See Also
Collapse All

Returns true if the table exists in the database.

C#
bool TableExists(
    string tableName
);
Parameters
Parameters | Description
tableName | The name of the table to look for. The name is case insensitive.
See Also
IDatabase Interface
Eco.Persistence.Connection Namespace


IDatabase Properties

IDatabase Properties
Public Properties
Collapse All

The properties of the IDatabase class are listed here.

Public Properties
Name | Description
Config | Contains database specific configuration.
Connected | This is Connected, a member of class IDatabase.
DbConnection | This is DbConnection, a member of class IDatabase.
InTransaction | This is InTransaction, a member of class IDatabase.
OpenSince | The time when the connection to the database was last opened.


IDatabase.Config Property

IDatabase.Config Property
IDatabase Interface Eco.Persistence.Connection Namespace See Also
Collapse All

Contains database specific configuration.

C#
SqlDatabaseConfig Config;
See Also
IDatabase Interface
Eco.Persistence.Connection Namespace


IDatabase.Connected Property

IDatabase.Connected Property
IDatabase Interface Eco.Persistence.Connection Namespace See Also
Collapse All
C#
bool Connected;
Remarks

This is Connected, a member of class IDatabase.

See Also
IDatabase Interface
Eco.Persistence.Connection Namespace


IDatabase.DbConnection Property

IDatabase.DbConnection Property
IDatabase Interface Eco.Persistence.Connection Namespace See Also
Collapse All
C#
IDbConnection DbConnection;
Remarks

This is DbConnection, a member of class IDatabase.

See Also
IDatabase Interface
Eco.Persistence.Connection Namespace


IDatabase.InTransaction Property

IDatabase.InTransaction Property
IDatabase Interface Eco.Persistence.Connection Namespace See Also
Collapse All
C#
bool InTransaction;
Remarks

This is InTransaction, a member of class IDatabase.

See Also
IDatabase Interface
Eco.Persistence.Connection Namespace


IDatabase.OpenSince Property

IDatabase.OpenSince Property
IDatabase Interface Eco.Persistence.Connection Namespace See Also
Collapse All

The time when the connection to the database was last opened.

C#
DateTime OpenSince;
See Also
IDatabase Interface
Eco.Persistence.Connection Namespace


IDatabaseCollection Interface

IDatabaseCollection Interface
Inheritance Hierarchy See Also
Collapse All
C#
public interface IDatabaseCollection : IEnumerable;
Remarks

This is class Eco.Persistence.Connection.IDatabaseCollection.

Inheritance Hierarchy
Eco.Persistence.Connection.IDatabaseCollection
    Eco.Persistence.Connection.DatabaseCollection
File

DataInterfaces.cs

See Also
Inheritance Hierarchy


IDatabaseCollection Methods

IDatabaseCollection Methods
Public Methods
Collapse All

The methods of the IDatabaseCollection class are listed here.

Public Methods
Name | Description
GetDatabase | This is GetDatabase, a member of class IDatabaseCollection.
GetNames | This is GetNames, a member of class IDatabaseCollection.


IDatabaseCollection.GetDatabase Method

IDatabaseCollection.GetDatabase Method
IDatabaseCollection Interface Eco.Persistence.Connection Namespace See Also
Collapse All
C#
IDatabase GetDatabase(
    string name
);
Remarks

This is GetDatabase, a member of class IDatabaseCollection.

See Also
IDatabaseCollection Interface
Eco.Persistence.Connection Namespace


IDatabaseCollection.GetNames Method

IDatabaseCollection.GetNames Method
IDatabaseCollection Interface Eco.Persistence.Connection Namespace See Also
Collapse All
C#
IList<string> GetNames();
Remarks

This is GetNames, a member of class IDatabaseCollection.

See Also
IDatabaseCollection Interface
Eco.Persistence.Connection Namespace


IDatabaseCollection Properties

IDatabaseCollection Properties
Public Properties
Collapse All

The properties of the IDatabaseCollection class are listed here.

Public Properties
Name | Description
TransactionManager | This is TransactionManager, a member of class IDatabaseCollection.


IDatabaseCollection.TransactionManager Property

IDatabaseCollection.TransactionManager Property
IDatabaseCollection Interface Eco.Persistence.Connection Namespace See Also
Collapse All
C#
ITransactionManager TransactionManager;
Remarks

This is TransactionManager, a member of class IDatabaseCollection.

See Also
IDatabaseCollection Interface
Eco.Persistence.Connection Namespace


IDatabaseDefinition Interface

IDatabaseDefinition Interface
Inheritance Hierarchy See Also
Collapse All
C#
public interface IDatabaseDefinition;
Todo

fake bridge, is actually cast down

Inheritance Hierarchy
Eco.Persistence.Connection.IDatabaseDefinition
File

DataInterfaces.cs

See Also
Inheritance Hierarchy


IDataSet Interface

IDataSet Interface
Inheritance Hierarchy See Also
Collapse All
C#
public interface IDataSet;
Remarks

This is class Eco.Persistence.Connection.IDataSet.

Inheritance Hierarchy
Eco.Persistence.Connection.IDataSet
    Eco.Persistence.Connection.IQuery
File

DataInterfaces.cs

See Also
Inheritance Hierarchy


IDataSet Methods

IDataSet Methods
Public Methods
Collapse All

The methods of the IDataSet class are listed here.

Public Methods
Name | Description
Close | This is Close, a member of class IDataSet.
FieldByName | This is FieldByName, a member of class IDataSet.
MoveBy | This is MoveBy, a member of class IDataSet.
Next | This is Next, a member of class IDataSet.
Open | This is Open, a member of class IDataSet.
this | This is this, a member of class IDataSet.


IDataSet.Close Method

IDataSet.Close Method
IDataSet Interface Eco.Persistence.Connection Namespace See Also
Collapse All
C#
void Close();
Remarks

This is Close, a member of class IDataSet.

See Also
IDataSet Interface
Eco.Persistence.Connection Namespace


IDataSet.FieldByName Method

IDataSet.FieldByName Method
IDataSet Interface Eco.Persistence.Connection Namespace See Also
Collapse All
C#
IField FieldByName(
    string fieldName
);
Remarks

This is FieldByName, a member of class IDataSet.

See Also
IDataSet Interface
Eco.Persistence.Connection Namespace


IDataSet.MoveBy Method

IDataSet.MoveBy Method
IDataSet Interface Eco.Persistence.Connection Namespace See Also
Collapse All
C#
int MoveBy(
    int distance
);
Remarks

This is MoveBy, a member of class IDataSet.

See Also
IDataSet Interface
Eco.Persistence.Connection Namespace


IDataSet.Next Method

IDataSet.Next Method
IDataSet Interface Eco.Persistence.Connection Namespace See Also
Collapse All
C#
void Next();
Remarks

This is Next, a member of class IDataSet.

See Also
IDataSet Interface
Eco.Persistence.Connection Namespace


IDataSet.Open Method

IDataSet.Open Method
IDataSet Interface Eco.Persistence.Connection Namespace See Also
Collapse All
C#
void Open();
Remarks

This is Open, a member of class IDataSet.

See Also
IDataSet Interface
Eco.Persistence.Connection Namespace


IDataSet.this Indexer

IDataSet.this Indexer
IDataSet Interface Eco.Persistence.Connection Namespace See Also
Collapse All
C#
IField this[
    int index
];
Remarks

This is this, a member of class IDataSet.

See Also
IDataSet Interface
Eco.Persistence.Connection Namespace


IDataSet Properties

IDataSet Properties
Public Properties
Collapse All

The properties of the IDataSet class are listed here.

Public Properties
Name | Description
Eof | This is Eof, a member of class IDataSet.
FieldCount | This is FieldCount, a member of class IDataSet.


IDataSet.Eof Property

IDataSet.Eof Property
IDataSet Interface Eco.Persistence.Connection Namespace See Also
Collapse All
C#
bool Eof;
Remarks

This is Eof, a member of class IDataSet.

See Also
IDataSet Interface
Eco.Persistence.Connection Namespace


IDataSet.FieldCount Property

IDataSet.FieldCount Property
IDataSet Interface Eco.Persistence.Connection Namespace See Also
Collapse All
C#
int FieldCount;
Remarks

This is FieldCount, a member of class IDataSet.

See Also
IDataSet Interface
Eco.Persistence.Connection Namespace


IExecQuery Interface

IExecQuery Interface
Inheritance Hierarchy See Also
Collapse All
C#
public interface IExecQuery : IQueryBase;
Remarks

This is class Eco.Persistence.Connection.IExecQuery.

Inheritance Hierarchy
Eco.Persistence.Connection.IParameterized
    Eco.Persistence.Connection.IQueryBase
        Eco.Persistence.Connection.IExecQuery
            Eco.Persistence.Connection.AbstractIQueryImpl
File

DataInterfaces.cs

See Also
Inheritance Hierarchy


IExecQuery Methods

IExecQuery Methods
Public Methods
Collapse All

The methods of the IExecQuery class are listed here.

Public Methods
Name | Description
EndSqlBatch | This is EndSqlBatch, a member of class IExecQuery.
ExecSql | This is ExecSql, a member of class IExecQuery.
FailSqlBatch | This is FailSqlBatch, a member of class IExecQuery.
StartSqlBatch | This is StartSqlBatch, a member of class IExecQuery.


IExecQuery.EndSqlBatch Method

IExecQuery.EndSqlBatch Method
IExecQuery Interface Eco.Persistence.Connection Namespace See Also
Collapse All
C#
void EndSqlBatch();
Remarks

This is EndSqlBatch, a member of class IExecQuery.

See Also
IExecQuery Interface
Eco.Persistence.Connection Namespace


IExecQuery.ExecSql Method

IExecQuery.ExecSql Method
IExecQuery Interface Eco.Persistence.Connection Namespace See Also
Collapse All
C#
void ExecSql();
Remarks

This is ExecSql, a member of class IExecQuery.

See Also
IExecQuery Interface
Eco.Persistence.Connection Namespace


IExecQuery.FailSqlBatch Method

IExecQuery.FailSqlBatch Method
IExecQuery Interface Eco.Persistence.Connection Namespace See Also
Collapse All
C#
void FailSqlBatch();
Remarks

This is FailSqlBatch, a member of class IExecQuery.

See Also
IExecQuery Interface
Eco.Persistence.Connection Namespace


IExecQuery.StartSqlBatch Method

IExecQuery.StartSqlBatch Method
IExecQuery Interface Eco.Persistence.Connection Namespace See Also
Collapse All
C#
void StartSqlBatch();
Remarks

This is StartSqlBatch, a member of class IExecQuery.

See Also
IExecQuery Interface
Eco.Persistence.Connection Namespace


IExecQuery Properties

IExecQuery Properties
Public Properties
Collapse All

The properties of the IExecQuery class are listed here.

Public Properties
Name | Description
RowsAffected | This is RowsAffected, a member of class IExecQuery.


IExecQuery.RowsAffected Property

IExecQuery.RowsAffected Property
IExecQuery Interface Eco.Persistence.Connection Namespace See Also
Collapse All
C#
int RowsAffected;
Remarks

This is RowsAffected, a member of class IExecQuery.

See Also
IExecQuery Interface
Eco.Persistence.Connection Namespace


IField Interface

IField Interface
Inheritance Hierarchy See Also
Collapse All
C#
public interface IField;
Remarks

This is class Eco.Persistence.Connection.IField.

Inheritance Hierarchy
Eco.Persistence.Connection.IField
File

DataInterfaces.cs

See Also
Inheritance Hierarchy


IField Properties

IField Properties
Public Properties
Collapse All

The properties of the IField class are listed here.

Public Properties
Name | Description
AsInt16 | This is AsInt16, a member of class IField.
AsInt32 | This is AsInt32, a member of class IField.
Value | This is Value, a member of class IField.


IField.AsInt16 Property

IField.AsInt16 Property
IField Interface Eco.Persistence.Connection Namespace See Also
Collapse All
C#
System.Int16 AsInt16;
Remarks

This is AsInt16, a member of class IField.

See Also
IField Interface
Eco.Persistence.Connection Namespace


IField.AsInt32 Property

IField.AsInt32 Property
IField Interface Eco.Persistence.Connection Namespace See Also
Collapse All
C#
System.Int32 AsInt32;
Remarks

This is AsInt32, a member of class IField.

See Also
IField Interface
Eco.Persistence.Connection Namespace


IField.Value Property

IField.Value Property
IField Interface Eco.Persistence.Connection Namespace See Also
Collapse All
C#
object Value;
Remarks

This is Value, a member of class IField.

See Also
IField Interface
Eco.Persistence.Connection Namespace


IParameterized Interface

IParameterized Interface
Inheritance Hierarchy See Also
Collapse All
C#
public interface IParameterized;
Remarks

This is class Eco.Persistence.Connection.IParameterized.

Inheritance Hierarchy
Eco.Persistence.Connection.IParameterized
    Eco.Persistence.Connection.IQueryBase
File

DataInterfaces.cs

See Also
Inheritance Hierarchy


IParameterized Methods

IParameterized Methods
Public Methods
Collapse All

The methods of the IParameterized class are listed here.

Public Methods
Name | Description
ClearParams | This is ClearParams, a member of class IParameterized.
ParamByName | This is ParamByName, a member of class IParameterized.


IParameterized.ClearParams Method

IParameterized.ClearParams Method
IParameterized Interface Eco.Persistence.Connection Namespace See Also
Collapse All
C#
void ClearParams();
Remarks

This is ClearParams, a member of class IParameterized.

See Also
IParameterized Interface
Eco.Persistence.Connection Namespace


IParameterized.ParamByName Method

IParameterized.ParamByName Method
IParameterized Interface Eco.Persistence.Connection Namespace See Also
Collapse All
C#
System.Data.IDataParameter ParamByName(
    string value
);
Remarks

This is ParamByName, a member of class IParameterized.

See Also
IParameterized Interface
Eco.Persistence.Connection Namespace


IQuery Interface

IQuery Interface
Inheritance Hierarchy See Also
Collapse All
C#
public interface IQuery : IQueryBase, IDataSet;
Remarks

This is class Eco.Persistence.Connection.IQuery.

Inheritance Hierarchy
Eco.Persistence.Connection.IParameterized
    Eco.Persistence.Connection.IQueryBase
    Eco.Persistence.Connection.IDataSet
        Eco.Persistence.Connection.IQuery
            Eco.Persistence.Connection.AbstractIQueryImpl
File

DataInterfaces.cs

See Also
Inheritance Hierarchy


IQueryBase Interface

IQueryBase Interface
Inheritance Hierarchy See Also
Collapse All
C#
public interface IQueryBase : IParameterized;
Remarks

This is class Eco.Persistence.Connection.IQueryBase.

Inheritance Hierarchy
Eco.Persistence.Connection.IParameterized
    Eco.Persistence.Connection.IQueryBase
        Eco.Persistence.Connection.IExecQuery
        Eco.Persistence.Connection.IQuery
File

DataInterfaces.cs

See Also
Inheritance Hierarchy


IQueryBase Methods

IQueryBase Methods
Public Methods
Collapse All

The methods of the IQueryBase class are listed here.

Public Methods
Name | Description
AssignSqlText | This is AssignSqlText, a member of class IQueryBase.


IQueryBase.AssignSqlText Method

IQueryBase.AssignSqlText Method
IQueryBase Interface Eco.Persistence.Connection Namespace See Also
Collapse All
C#
void AssignSqlText(
    string sql
);
Remarks

This is AssignSqlText, a member of class IQueryBase.

See Also
IQueryBase Interface
Eco.Persistence.Connection Namespace


IQueryBase Properties

IQueryBase Properties
Public Properties
Collapse All

The properties of the IQueryBase class are listed here.

Public Properties
Name | Description
SqlText | This is SqlText, a member of class IQueryBase.


IQueryBase.SqlText Property

IQueryBase.SqlText Property
IQueryBase Interface Eco.Persistence.Connection Namespace See Also
Collapse All
C#
string SqlText;
Remarks

This is SqlText, a member of class IQueryBase.

See Also
IQueryBase Interface
Eco.Persistence.Connection Namespace


ITransactionable Interface

ITransactionable Interface
Inheritance Hierarchy See Also
Collapse All
C#
public interface ITransactionable;
Remarks

This is class Eco.Persistence.Connection.ITransactionable.

Inheritance Hierarchy
Eco.Persistence.Connection.ITransactionable
File

DataInterfaces.cs

See Also
Inheritance Hierarchy


ITransactionable Methods

ITransactionable Methods
Public Methods
Collapse All

The methods of the ITransactionable class are listed here.

Public Methods
Name | Description
PerformUpdate | This is PerformUpdate, a member of class ITransactionable.


ITransactionable.PerformUpdate Method

ITransactionable.PerformUpdate Method
ITransactionable Interface Eco.Persistence.Connection Namespace See Also
Collapse All
C#
bool PerformUpdate(
    object operationParams
);
Remarks

This is PerformUpdate, a member of class ITransactionable.

See Also
ITransactionable Interface
Eco.Persistence.Connection Namespace


ITransactionManager Interface

ITransactionManager Interface
Inheritance Hierarchy See Also
Collapse All
C#
public interface ITransactionManager;
Remarks

This is class Eco.Persistence.Connection.ITransactionManager.

Inheritance Hierarchy
Eco.Persistence.Connection.ITransactionManager
File

DataInterfaces.cs

See Also
Inheritance Hierarchy


ITransactionManager Methods

ITransactionManager Methods
Public Methods
Collapse All

The methods of the ITransactionManager class are listed here.

Public Methods
Name | Description
PerformOperationInTransaction | This is PerformOperationInTransaction, a member of class ITransactionManager.


ITransactionManager.PerformOperationInTransaction Method

ITransactionManager.PerformOperationInTransaction Method
ITransactionManager Interface Eco.Persistence.Connection Namespace See Also
Collapse All
C#
void PerformOperationInTransaction(
    object context,
    ITransactionable callback,
    IDatabaseCollection databases
);
Remarks

This is PerformOperationInTransaction, a member of class ITransactionManager.

See Also
ITransactionManager Interface
Eco.Persistence.Connection Namespace


Eco.Persistence.Db2 Namespace

Eco.Persistence.Db2 Namespace
Classes
Collapse All

This is namespace Eco.Persistence.Db2.

Classes
Name | Description
DecimalAsDecimal | This is class Eco.Persistence.Db2.DecimalAsDecimal.
Int64AsBigInt | This is class Eco.Persistence.Db2.Int64AsBigInt.
Int64AsLongInteger | This is class Eco.Persistence.Db2.Int64AsLongInteger.
SingleAsFloat | This is class Eco.Persistence.Db2.SingleAsFloat.
StringAsDbClob | This is class Eco.Persistence.Db2.StringAsDbClob.


DecimalAsDecimal Class

DecimalAsDecimal Class
Inheritance Hierarchy See Also
Collapse All
C#
public sealed class DecimalAsDecimal : AbstractNumericSingleColumnAttribute, ISingleColumnAttributemapping, IDefaultReverseMapping;
Remarks

This is class Eco.Persistence.Db2.DecimalAsDecimal.

Inheritance Hierarchy
Eco.Persistence.IDefaultReverseMapping
Eco.Persistence.ISingleColumnAttributemapping
    Eco.Persistence.Db2.DecimalAsDecimal
File

Db2AttributeMappers.cs

See Also
Inheritance Hierarchy


DecimalAsDecimal Methods

DecimalAsDecimal Methods
Public Methods
Collapse All

The methods of the DecimalAsDecimal class are listed here.

Public Methods
Name | Description
ColumnToValue | Converts a value that comes from a database query to an ecospace value.
ColumnType | Specifies the SQL type of the column.
StringToParameter | This is StringToParameter, a member of class DecimalAsDecimal.
ValueToParameter | Converts a value that comes from a database query to an ecospace value.
ValueType | This method returns the type of the value that is returned by ColumnToValue.


DecimalAsDecimal.ColumnToValue Method

DecimalAsDecimal.ColumnToValue Method
DecimalAsDecimal Class Eco.Persistence.Db2 Namespace See Also
Collapse All

Converts a value that comes from a database query to an ecospace value.

C#
public override System.Object ColumnToValue(
    System.Object columnValue
);
Remarks

In many cases, the implementation of this method mainly converts DBNull-values to null, but it can also change the CLR-type of the database value from for example a char[] to a string. or from an integer to a boolean. This is the reverse operation of ValueToParameter.

See Also
DecimalAsDecimal Class
Eco.Persistence.Db2 Namespace


DecimalAsDecimal.ColumnType Method

DecimalAsDecimal.ColumnType Method
DecimalAsDecimal Class Eco.Persistence.Db2 Namespace See Also
Collapse All

Specifies the SQL type of the column.

C#
public String ColumnType(
    int length
);
See Also
DecimalAsDecimal Class
Eco.Persistence.Db2 Namespace


DecimalAsDecimal.StringToParameter Method

DecimalAsDecimal.StringToParameter Method
DecimalAsDecimal Class Eco.Persistence.Db2 Namespace See Also
Collapse All
C#
public void StringToParameter(
    string value,
    IDataParameter parameter
);
Remarks

This is StringToParameter, a member of class DecimalAsDecimal.

See Also
DecimalAsDecimal Class
Eco.Persistence.Db2 Namespace


DecimalAsDecimal.ValueToParameter Method

DecimalAsDecimal.ValueToParameter Method
DecimalAsDecimal Class Eco.Persistence.Db2 Namespace See Also
Collapse All

Converts a value that comes from a database query to an ecospace value.

C#
public void ValueToParameter(
    System.Object value,
    IDataParameter parameter
);
Remarks

In many cases, the implementation of this method mainly converts null to DBNull, but it can also handle conversion from for example booleans to integers, byte[] to database blobs. It also has to set the correct parameter types in the IDataParameter-object. This is the reverse operation of ColumnToValue.

See Also
DecimalAsDecimal Class
Eco.Persistence.Db2 Namespace


DecimalAsDecimal.ValueType Method

DecimalAsDecimal.ValueType Method
DecimalAsDecimal Class Eco.Persistence.Db2 Namespace See Also
Collapse All

This method returns the type of the value that is returned by ColumnToValue.

C#
public System.Type ValueType();
See Also
DecimalAsDecimal Class
Eco.Persistence.Db2 Namespace


Int64AsBigInt Class

Int64AsBigInt Class
Inheritance Hierarchy See Also
Collapse All
C#
public sealed class Int64AsBigInt : AbstractNumericSingleColumnAttribute, ISingleColumnAttributemapping, IDefaultReverseMapping;
Remarks

This is class Eco.Persistence.Db2.Int64AsBigInt.

Inheritance Hierarchy
Eco.Persistence.IDefaultReverseMapping
Eco.Persistence.ISingleColumnAttributemapping
    Eco.Persistence.Db2.Int64AsBigInt
File

Db2AttributeMappers.cs

See Also
Inheritance Hierarchy


Int64AsBigInt.ColumnToValue Method

Int64AsBigInt.ColumnToValue Method
Int64AsBigInt Class Eco.Persistence.Db2 Namespace See Also
Collapse All

Converts a value that comes from a database query to an ecospace value.

C#
public override System.Object ColumnToValue(
    System.Object columnValue
);
Remarks

In many cases, the implementation of this method mainly converts DBNull-values to null, but it can also change the CLR-type of the database value from for example a char[] to a string. or from an integer to a boolean. This is the reverse operation of ValueToParameter.

See Also
Int64AsBigInt Class
Eco.Persistence.Db2 Namespace


Int64AsBigInt.ColumnType Method

Int64AsBigInt.ColumnType Method
Int64AsBigInt Class Eco.Persistence.Db2 Namespace See Also
Collapse All

Specifies the SQL type of the column.

C#
public String ColumnType(
    int length
);
See Also
Int64AsBigInt Class
Eco.Persistence.Db2 Namespace


Int64AsBigInt.StringToParameter Method

Int64AsBigInt.StringToParameter Method
Int64AsBigInt Class Eco.Persistence.Db2 Namespace See Also
Collapse All
C#
public void StringToParameter(
    string value,
    IDataParameter parameter
);
Remarks

This is StringToParameter, a member of class Int64AsBigInt.

See Also
Int64AsBigInt Class
Eco.Persistence.Db2 Namespace


Int64AsBigInt.ValueToParameter Method

Int64AsBigInt.ValueToParameter Method
Int64AsBigInt Class Eco.Persistence.Db2 Namespace See Also
Collapse All

Converts a value that comes from a database query to an ecospace value.

C#
public void ValueToParameter(
    System.Object value,
    IDataParameter parameter
);
Remarks

In many cases, the implementation of this method mainly converts null to DBNull, but it can also handle conversion from for example booleans to integers, byte[] to database blobs. It also has to set the correct parameter types in the IDataParameter-object. This is the reverse operation of ColumnToValue.

See Also
Int64AsBigInt Class
Eco.Persistence.Db2 Namespace


Int64AsBigInt.ValueType Method

Int64AsBigInt.ValueType Method
Int64AsBigInt Class Eco.Persistence.Db2 Namespace See Also
Collapse All

This method returns the type of the value that is returned by ColumnToValue.

C#
public System.Type ValueType();
See Also
Int64AsBigInt Class
Eco.Persistence.Db2 Namespace


Int64AsLongInteger Class

Int64AsLongInteger Class
Inheritance Hierarchy See Also
Collapse All
C#
public sealed class Int64AsLongInteger : AbstractNumericSingleColumnAttribute, ISingleColumnAttributemapping, IDefaultReverseMapping;
Remarks

This is class Eco.Persistence.Db2.Int64AsLongInteger.

Inheritance Hierarchy
Eco.Persistence.IDefaultReverseMapping
Eco.Persistence.ISingleColumnAttributemapping
    Eco.Persistence.Db2.Int64AsLongInteger
File

Db2AttributeMappers.cs

See Also
Inheritance Hierarchy


Int64AsLongInteger Methods

Int64AsLongInteger Methods
Public Methods
Collapse All

The methods of the Int64AsLongInteger class are listed here.

Public Methods
Name | Description
ColumnToValue | Converts a value that comes from a database query to an ecospace value.
ColumnType | Specifies the SQL type of the column.
StringToParameter | This is StringToParameter, a member of class Int64AsLongInteger.
ValueToParameter | Converts a value that comes from a database query to an ecospace value.
ValueType | This method returns the type of the value that is returned by ColumnToValue.


Int64AsLongInteger.ColumnToValue Method

Int64AsLongInteger.ColumnToValue Method
Int64AsLongInteger Class Eco.Persistence.Db2 Namespace See Also
Collapse All

Converts a value that comes from a database query to an ecospace value.

C#
public override System.Object ColumnToValue(
    System.Object columnValue
);
Remarks

In many cases, the implementation of this method mainly converts DBNull-values to null, but it can also change the CLR-type of the database value from for example a char[] to a string. or from an integer to a boolean. This is the reverse operation of ValueToParameter.

See Also
Int64AsLongInteger Class
Eco.Persistence.Db2 Namespace


Int64AsLongInteger.ColumnType Method

Int64AsLongInteger.ColumnType Method
Int64AsLongInteger Class Eco.Persistence.Db2 Namespace See Also
Collapse All

Specifies the SQL type of the column.

C#
public String ColumnType(
    int length
);
See Also
Int64AsLongInteger Class
Eco.Persistence.Db2 Namespace


Int64AsLongInteger.StringToParameter Method

Int64AsLongInteger.StringToParameter Method
Int64AsLongInteger Class Eco.Persistence.Db2 Namespace See Also
Collapse All
C#
public void StringToParameter(
    string value,
    IDataParameter parameter
);
Remarks

This is StringToParameter, a member of class Int64AsLongInteger.

See Also
Int64AsLongInteger Class
Eco.Persistence.Db2 Namespace


Int64AsLongInteger.ValueToParameter Method

Int64AsLongInteger.ValueToParameter Method
Int64AsLongInteger Class Eco.Persistence.Db2 Namespace See Also
Collapse All

Converts a value that comes from a database query to an ecospace value.

C#
public void ValueToParameter(
    System.Object value,
    IDataParameter parameter
);
Remarks

In many cases, the implementation of this method mainly converts null to DBNull, but it can also handle conversion from for example booleans to integers, byte[] to database blobs. It also has to set the correct parameter types in the IDataParameter-object. This is the reverse operation of ColumnToValue.

See Also
Int64AsLongInteger Class
Eco.Persistence.Db2 Namespace


Int64AsLongInteger.ValueType Method

Int64AsLongInteger.ValueType Method
Int64AsLongInteger Class Eco.Persistence.Db2 Namespace See Also
Collapse All

This method returns the type of the value that is returned by ColumnToValue.

C#
public System.Type ValueType();
See Also
Int64AsLongInteger Class
Eco.Persistence.Db2 Namespace


SingleAsFloat Class

SingleAsFloat Class
Inheritance Hierarchy See Also
Collapse All
C#
public sealed class SingleAsFloat : AbstractNumericSingleColumnAttribute, ISingleColumnAttributemapping, IDefaultReverseMapping;
Remarks

This is class Eco.Persistence.Db2.SingleAsFloat.

Inheritance Hierarchy
Eco.Persistence.IDefaultReverseMapping
Eco.Persistence.ISingleColumnAttributemapping
    Eco.Persistence.Db2.SingleAsFloat
File

Db2AttributeMappers.cs

See Also
Inheritance Hierarchy


SingleAsFloat.ColumnToValue Method

SingleAsFloat.ColumnToValue Method
SingleAsFloat Class Eco.Persistence.Db2 Namespace See Also
Collapse All

Converts a value that comes from a database query to an ecospace value.

C#
public override System.Object ColumnToValue(
    System.Object columnValue
);
Remarks

In many cases, the implementation of this method mainly converts DBNull-values to null, but it can also change the CLR-type of the database value from for example a char[] to a string. or from an integer to a boolean. This is the reverse operation of ValueToParameter.

See Also
SingleAsFloat Class
Eco.Persistence.Db2 Namespace


SingleAsFloat.ColumnType Method

SingleAsFloat.ColumnType Method
SingleAsFloat Class Eco.Persistence.Db2 Namespace See Also
Collapse All

Specifies the SQL type of the column.

C#
public String ColumnType(
    int length
);
See Also
SingleAsFloat Class
Eco.Persistence.Db2 Namespace


SingleAsFloat.StringToParameter Method

SingleAsFloat.StringToParameter Method
SingleAsFloat Class Eco.Persistence.Db2 Namespace See Also
Collapse All
C#
public void StringToParameter(
    string value,
    IDataParameter parameter
);
Remarks

This is StringToParameter, a member of class SingleAsFloat.

See Also
SingleAsFloat Class
Eco.Persistence.Db2 Namespace


SingleAsFloat.ValueToParameter Method

SingleAsFloat.ValueToParameter Method
SingleAsFloat Class Eco.Persistence.Db2 Namespace See Also
Collapse All

Converts a value that comes from a database query to an ecospace value.

C#
public void ValueToParameter(
    System.Object value,
    IDataParameter parameter
);
Remarks

In many cases, the implementation of this method mainly converts null to DBNull, but it can also handle conversion from for example booleans to integers, byte[] to database blobs. It also has to set the correct parameter types in the IDataParameter-object. This is the reverse operation of ColumnToValue.

See Also
SingleAsFloat Class
Eco.Persistence.Db2 Namespace


SingleAsFloat.ValueType Method

SingleAsFloat.ValueType Method
SingleAsFloat Class Eco.Persistence.Db2 Namespace See Also
Collapse All

This method returns the type of the value that is returned by ColumnToValue.

C#
public System.Type ValueType();
See Also
SingleAsFloat Class
Eco.Persistence.Db2 Namespace


StringAsDbClob Class

StringAsDbClob Class
Inheritance Hierarchy See Also
Collapse All
C#
public sealed class StringAsDbClob : AbstractSingleColumnAttribute, ISingleColumnAttributemapping;
Remarks

This is class Eco.Persistence.Db2.StringAsDbClob.

Inheritance Hierarchy
Eco.Persistence.ISingleColumnAttributemapping
    Eco.Persistence.Db2.StringAsDbClob
File

Db2AttributeMappersBdp.cs

See Also
Inheritance Hierarchy


StringAsDbClob Methods

StringAsDbClob Methods
Public Methods
Collapse All

The methods of the StringAsDbClob class are listed here.

Public Methods
Name | Description
ColumnToValue | Converts a value that comes from a database query to an ecospace value.
ColumnType | Specifies the SQL type of the column.
DefaultDbValue | The return value of this function will be used as default value for new columns when databases are created/evolved.
StringToParameter | This is StringToParameter, a member of class StringAsDbClob.
ValueToParameter | Converts a value that comes from a database query to an ecospace value.
ValueType | This method returns the type of the value that is returned by ColumnToValue.


StringAsDbClob.ColumnToValue Method

StringAsDbClob.ColumnToValue Method
StringAsDbClob Class Eco.Persistence.Db2 Namespace See Also
Collapse All

Converts a value that comes from a database query to an ecospace value.

C#
public override System.Object ColumnToValue(
    System.Object columnValue
);
Remarks

In many cases, the implementation of this method mainly converts DBNull-values to null, but it can also change the CLR-type of the database value from for example a char[] to a string. or from an integer to a boolean. This is the reverse operation of ValueToParameter.

See Also
StringAsDbClob Class
Eco.Persistence.Db2 Namespace


StringAsDbClob.ColumnType Method

StringAsDbClob.ColumnType Method
StringAsDbClob Class Eco.Persistence.Db2 Namespace See Also
Collapse All

Specifies the SQL type of the column.

C#
public string ColumnType(
    int length
);
See Also
StringAsDbClob Class
Eco.Persistence.Db2 Namespace


StringAsDbClob.DefaultDbValue Method

StringAsDbClob.DefaultDbValue Method
StringAsDbClob Class Eco.Persistence.Db2 Namespace See Also
Collapse All

The return value of this function will be used as default value for new columns when databases are created/evolved.

C#
public string DefaultDbValue(
    string modeledValue,
    SqlDatabaseConfig sqlDatabaseConfig
);
See Also
StringAsDbClob Class
Eco.Persistence.Db2 Namespace


StringAsDbClob.StringToParameter Method

StringAsDbClob.StringToParameter Method
StringAsDbClob Class Eco.Persistence.Db2 Namespace See Also
Collapse All
C#
public void StringToParameter(
    string value,
    IDataParameter parameter
);
Remarks

This is StringToParameter, a member of class StringAsDbClob.

See Also
StringAsDbClob Class
Eco.Persistence.Db2 Namespace


StringAsDbClob.ValueToParameter Method

StringAsDbClob.ValueToParameter Method
StringAsDbClob Class Eco.Persistence.Db2 Namespace See Also
Collapse All

Converts a value that comes from a database query to an ecospace value.

C#
public void ValueToParameter(
    System.Object value,
    IDataParameter parameter
);
Remarks

In many cases, the implementation of this method mainly converts null to DBNull, but it can also handle conversion from for example booleans to integers, byte[] to database blobs. It also has to set the correct parameter types in the IDataParameter-object. This is the reverse operation of ColumnToValue.

See Also
StringAsDbClob Class
Eco.Persistence.Db2 Namespace


StringAsDbClob.ValueType Method

StringAsDbClob.ValueType Method
StringAsDbClob Class Eco.Persistence.Db2 Namespace See Also
Collapse All

This method returns the type of the value that is returned by ColumnToValue.

C#
public System.Type ValueType();
See Also
StringAsDbClob Class
Eco.Persistence.Db2 Namespace


Eco.Persistence.Dbx.Blackfish Namespace

Eco.Persistence.Dbx.Blackfish Namespace
Classes
Collapse All

This is namespace Eco.Persistence.Dbx.Blackfish.

Classes
Name | Description
ByteArrayAsDbxVarBinary | This is class Eco.Persistence.Dbx.Blackfish.ByteArrayAsDbxVarBinary.


ByteArrayAsDbxVarBinary Class

ByteArrayAsDbxVarBinary Class
Inheritance Hierarchy See Also
Collapse All
C#
public sealed class ByteArrayAsDbxVarBinary : GenericByteArrayAsVarBinary, ISingleColumnAttributemapping;
Remarks

This is class Eco.Persistence.Dbx.Blackfish.ByteArrayAsDbxVarBinary.

Inheritance Hierarchy
Eco.Persistence.ISingleColumnAttributemapping
    Eco.Persistence.Dbx.Blackfish.ByteArrayAsDbxVarBinary
File

NDataStoreAttributeMappersDbx.cs

See Also
Inheritance Hierarchy


ByteArrayAsDbxVarBinary Methods

ByteArrayAsDbxVarBinary Methods
Public Methods
Collapse All

The methods of the ByteArrayAsDbxVarBinary class are listed here.

Public Methods
Name | Description
ValueToParameter | This is ValueToParameter, a member of class ByteArrayAsDbxVarBinary.
ValueType | This method returns the type of the value that is returned by ColumnToValue.


ByteArrayAsDbxVarBinary.ValueToParameter Method

ByteArrayAsDbxVarBinary.ValueToParameter Method
ByteArrayAsDbxVarBinary Class Eco.Persistence.Dbx.Blackfish Namespace See Also
Collapse All
C#
public void ValueToParameter(
    object value,
    IDataParameter parameter
);
Remarks

This is ValueToParameter, a member of class ByteArrayAsDbxVarBinary.

See Also
ByteArrayAsDbxVarBinary Class
Eco.Persistence.Dbx.Blackfish Namespace


ByteArrayAsDbxVarBinary.ValueType Method

ByteArrayAsDbxVarBinary.ValueType Method
ByteArrayAsDbxVarBinary Class Eco.Persistence.Dbx.Blackfish Namespace See Also
Collapse All

This method returns the type of the value that is returned by ColumnToValue.

C#
public System.Type ValueType();
See Also
ByteArrayAsDbxVarBinary Class
Eco.Persistence.Dbx.Blackfish Namespace


Eco.Persistence.Dbx.Db2 Namespace

Eco.Persistence.Dbx.Db2 Namespace
Classes
Collapse All

This is namespace Eco.Persistence.Dbx.Db2.

Classes
Name | Description
StringAsDbClob | This is class Eco.Persistence.Dbx.Db2.StringAsDbClob.


StringAsDbClob Class

StringAsDbClob Class
Inheritance Hierarchy See Also
Collapse All
C#
public sealed class StringAsDbClob : AbstractSingleColumnAttribute, ISingleColumnAttributemapping;
Remarks

This is class Eco.Persistence.Dbx.Db2.StringAsDbClob.

Inheritance Hierarchy
Eco.Persistence.ISingleColumnAttributemapping
    Eco.Persistence.Dbx.Db2.StringAsDbClob
File

Db2AttributeMappersDbx.cs

See Also
Inheritance Hierarchy


StringAsDbClob.ColumnToValue Method

StringAsDbClob.ColumnToValue Method
StringAsDbClob Class Eco.Persistence.Dbx.Db2 Namespace See Also
Collapse All

Converts a value that comes from a database query to an ecospace value.

C#
public override System.Object ColumnToValue(
    System.Object columnValue
);
Remarks

In many cases, the implementation of this method mainly converts DBNull-values to null, but it can also change the CLR-type of the database value from for example a char[] to a string. or from an integer to a boolean. This is the reverse operation of ValueToParameter.

See Also
StringAsDbClob Class
Eco.Persistence.Dbx.Db2 Namespace


StringAsDbClob.ColumnType Method

StringAsDbClob.ColumnType Method
StringAsDbClob Class Eco.Persistence.Dbx.Db2 Namespace See Also
Collapse All

Specifies the SQL type of the column.

C#
public string ColumnType(
    int length
);
See Also
StringAsDbClob Class
Eco.Persistence.Dbx.Db2 Namespace


StringAsDbClob.DefaultDbValue Method

StringAsDbClob.DefaultDbValue Method
StringAsDbClob Class Eco.Persistence.Dbx.Db2 Namespace See Also
Collapse All

The return value of this function will be used as default value for new columns when databases are created/evolved.

C#
public string DefaultDbValue(
    string modeledValue,
    SqlDatabaseConfig sqlDatabaseConfig
);
See Also
StringAsDbClob Class
Eco.Persistence.Dbx.Db2 Namespace


StringAsDbClob.StringToParameter Method

StringAsDbClob.StringToParameter Method
StringAsDbClob Class Eco.Persistence.Dbx.Db2 Namespace See Also
Collapse All
C#
public void StringToParameter(
    string value,
    IDataParameter parameter
);
Remarks

This is StringToParameter, a member of class StringAsDbClob.

See Also
StringAsDbClob Class
Eco.Persistence.Dbx.Db2 Namespace


StringAsDbClob.ValueToParameter Method

StringAsDbClob.ValueToParameter Method
StringAsDbClob Class Eco.Persistence.Dbx.Db2 Namespace See Also
Collapse All

Converts a value that comes from a database query to an ecospace value.

C#
public void ValueToParameter(
    System.Object value,
    IDataParameter parameter
);
Remarks

In many cases, the implementation of this method mainly converts null to DBNull, but it can also handle conversion from for example booleans to integers, byte[] to database blobs. It also has to set the correct parameter types in the IDataParameter-object. This is the reverse operation of ColumnToValue.

See Also
StringAsDbClob Class
Eco.Persistence.Dbx.Db2 Namespace


StringAsDbClob.ValueType Method

StringAsDbClob.ValueType Method
StringAsDbClob Class Eco.Persistence.Dbx.Db2 Namespace See Also
Collapse All

This method returns the type of the value that is returned by ColumnToValue.

C#
public System.Type ValueType();
See Also
StringAsDbClob Class
Eco.Persistence.Dbx.Db2 Namespace


Eco.Persistence.Dbx.Interbase Namespace

Eco.Persistence.Dbx.Interbase Namespace
Classes
Collapse All

This is namespace Eco.Persistence.Dbx.Interbase.

Classes
Name | Description
ByteArrayAsDbxBlob | Mapper between a ByteArray value and its persistent representation as BLOB.
StringAsDbxBlob | This is class Eco.Persistence.Dbx.Interbase.StringAsDbxBlob.
StringAsDbxVarChar | Class for mapping String values to a single column in a database.


ByteArrayAsDbxBlob Class

ByteArrayAsDbxBlob Class
Inheritance Hierarchy See Also
Collapse All

Mapper between a ByteArray value and its persistent representation as BLOB.

C#
public sealed class ByteArrayAsDbxBlob : AbstractSingleColumnAttribute, ISingleColumnAttributemapping;
Inheritance Hierarchy
Eco.Persistence.ISingleColumnAttributemapping
    Eco.Persistence.Dbx.Interbase.ByteArrayAsDbxBlob
File

InterbaseAttributeMappersDbx.cs

See Also
Inheritance Hierarchy


ByteArrayAsDbxBlob Methods

ByteArrayAsDbxBlob Methods
Public Methods
Collapse All

The methods of the ByteArrayAsDbxBlob class are listed here.

Public Methods
Name | Description
ColumnToValue | Converts a value that comes from a database query to an ecospace value.
ColumnType | Specifies the SQL type of the column.
DefaultDbValue | The return value of this function will be used as default value for new columns when databases are created/evolved.
IsEqual | Returns true if an ecospace value ("value") is equal to a database value ("columnValue").
StringToParameter |
ValueToParameter | Converts a value that comes from a database query to an ecospace value.
ValueType | This method returns the type of the value that is returned by ColumnToValue.


ByteArrayAsDbxBlob.ColumnToValue Method

ByteArrayAsDbxBlob.ColumnToValue Method
ByteArrayAsDbxBlob Class Eco.Persistence.Dbx.Interbase Namespace See Also
Collapse All

Converts a value that comes from a database query to an ecospace value.

C#
public override System.Object ColumnToValue(
    System.Object columnValue
);
Remarks

In many cases, the implementation of this method mainly converts DBNull-values to null, but it can also change the CLR-type of the database value from for example a char[] to a string. or from an integer to a boolean. This is the reverse operation of ValueToParameter.

See Also
ByteArrayAsDbxBlob Class
Eco.Persistence.Dbx.Interbase Namespace


ByteArrayAsDbxBlob.ColumnType Method

ByteArrayAsDbxBlob.ColumnType Method
ByteArrayAsDbxBlob Class Eco.Persistence.Dbx.Interbase Namespace See Also
Collapse All

Specifies the SQL type of the column.

C#
public string ColumnType(
    int length
);
See Also
ByteArrayAsDbxBlob Class
Eco.Persistence.Dbx.Interbase Namespace


ByteArrayAsDbxBlob.DefaultDbValue Method

ByteArrayAsDbxBlob.DefaultDbValue Method
ByteArrayAsDbxBlob Class Eco.Persistence.Dbx.Interbase Namespace See Also
Collapse All

The return value of this function will be used as default value for new columns when databases are created/evolved.

C#
public string DefaultDbValue(
    string modeledValue,
    SqlDatabaseConfig sqlDatabaseConfig
);
See Also
ByteArrayAsDbxBlob Class
Eco.Persistence.Dbx.Interbase Namespace


ByteArrayAsDbxBlob.IsEqual Method

ByteArrayAsDbxBlob.IsEqual Method
ByteArrayAsDbxBlob Class Eco.Persistence.Dbx.Interbase Namespace See Also
Collapse All

Returns true if an ecospace value ("value") is equal to a database value ("columnValue").

C#
public override bool IsEqual(
    System.Object value,
    System.Object columnValue
);
Remarks

This method must handle the conversions between ecospace and database values, it must also handle comparing null/DBNull values.

See Also
ByteArrayAsDbxBlob Class
Eco.Persistence.Dbx.Interbase Namespace


ByteArrayAsDbxBlob.StringToParameter Method

ByteArrayAsDbxBlob.StringToParameter Method
ByteArrayAsDbxBlob Class Eco.Persistence.Dbx.Interbase Namespace See Also
Collapse All
C#
public void StringToParameter(
    string value,
    IDataParameter parameter
);
Exceptions
Exceptions | Description
InvalidOperationException | Thrown always.
See Also
ByteArrayAsDbxBlob Class
Eco.Persistence.Dbx.Interbase Namespace


ByteArrayAsDbxBlob.ValueToParameter Method

ByteArrayAsDbxBlob.ValueToParameter Method
ByteArrayAsDbxBlob Class Eco.Persistence.Dbx.Interbase Namespace See Also
Collapse All

Converts a value that comes from a database query to an ecospace value.

C#
public void ValueToParameter(
    System.Object value,
    IDataParameter parameter
);
Remarks

In many cases, the implementation of this method mainly converts null to DBNull, but it can also handle conversion from for example booleans to integers, byte[] to database blobs. It also has to set the correct parameter types in the IDataParameter-object. This is the reverse operation of ColumnToValue.

See Also
ByteArrayAsDbxBlob Class
Eco.Persistence.Dbx.Interbase Namespace


ByteArrayAsDbxBlob.ValueType Method

ByteArrayAsDbxBlob.ValueType Method
ByteArrayAsDbxBlob Class Eco.Persistence.Dbx.Interbase Namespace See Also
Collapse All

This method returns the type of the value that is returned by ColumnToValue.

C#
public System.Type ValueType();
See Also
ByteArrayAsDbxBlob Class
Eco.Persistence.Dbx.Interbase Namespace


StringAsDbxBlob Class

StringAsDbxBlob Class
Inheritance Hierarchy See Also
Collapse All
C#
public sealed class StringAsDbxBlob : AbstractSingleColumnAttribute, ISingleColumnAttributemapping;
Remarks

This is class Eco.Persistence.Dbx.Interbase.StringAsDbxBlob.

Inheritance Hierarchy
Eco.Persistence.ISingleColumnAttributemapping
    Eco.Persistence.Dbx.Interbase.StringAsDbxBlob
File

InterbaseAttributeMappersDbx.cs

See Also
Inheritance Hierarchy


StringAsDbxBlob Methods

StringAsDbxBlob Methods
Public Methods
Collapse All

The methods of the StringAsDbxBlob class are listed here.

Public Methods
Name | Description
ColumnToValue | Converts a value that comes from a database query to an ecospace value.
ColumnType | Specifies the SQL type of the column.
DefaultDbValue | The return value of this function will be used as default value for new columns when databases are created/evolved.
StringToParameter | This is StringToParameter, a member of class StringAsDbxBlob.
ValueToParameter | Converts a value that comes from a database query to an ecospace value.
ValueType | This method returns the type of the value that is returned by ColumnToValue.


StringAsDbxBlob.ColumnToValue Method

StringAsDbxBlob.ColumnToValue Method
StringAsDbxBlob Class Eco.Persistence.Dbx.Interbase Namespace See Also
Collapse All

Converts a value that comes from a database query to an ecospace value.

C#
public override System.Object ColumnToValue(
    System.Object columnValue
);
Remarks

In many cases, the implementation of this method mainly converts DBNull-values to null, but it can also change the CLR-type of the database value from for example a char[] to a string. or from an integer to a boolean. This is the reverse operation of ValueToParameter.

See Also
StringAsDbxBlob Class
Eco.Persistence.Dbx.Interbase Namespace


StringAsDbxBlob.ColumnType Method

StringAsDbxBlob.ColumnType Method
StringAsDbxBlob Class Eco.Persistence.Dbx.Interbase Namespace See Also
Collapse All

Specifies the SQL type of the column.

C#
public string ColumnType(
    int length
);
See Also
StringAsDbxBlob Class
Eco.Persistence.Dbx.Interbase Namespace


StringAsDbxBlob.DefaultDbValue Method

StringAsDbxBlob.DefaultDbValue Method
StringAsDbxBlob Class Eco.Persistence.Dbx.Interbase Namespace See Also
Collapse All

The return value of this function will be used as default value for new columns when databases are created/evolved.

C#
public string DefaultDbValue(
    string modeledValue,
    SqlDatabaseConfig sqlDatabaseConfig
);
See Also
StringAsDbxBlob Class
Eco.Persistence.Dbx.Interbase Namespace


StringAsDbxBlob.StringToParameter Method

StringAsDbxBlob.StringToParameter Method
StringAsDbxBlob Class Eco.Persistence.Dbx.Interbase Namespace See Also
Collapse All
C#
public void StringToParameter(
    string value,
    IDataParameter parameter
);
Remarks

This is StringToParameter, a member of class StringAsDbxBlob.

See Also
StringAsDbxBlob Class
Eco.Persistence.Dbx.Interbase Namespace


StringAsDbxBlob.ValueToParameter Method

StringAsDbxBlob.ValueToParameter Method
StringAsDbxBlob Class Eco.Persistence.Dbx.Interbase Namespace See Also
Collapse All

Converts a value that comes from a database query to an ecospace value.

C#
public void ValueToParameter(
    System.Object value,
    IDataParameter parameter
);
Remarks

In many cases, the implementation of this method mainly converts null to DBNull, but it can also handle conversion from for example booleans to integers, byte[] to database blobs. It also has to set the correct parameter types in the IDataParameter-object. This is the reverse operation of ColumnToValue.

See Also
StringAsDbxBlob Class
Eco.Persistence.Dbx.Interbase Namespace


StringAsDbxBlob.ValueType Method

StringAsDbxBlob.ValueType Method
StringAsDbxBlob Class Eco.Persistence.Dbx.Interbase Namespace See Also
Collapse All

This method returns the type of the value that is returned by ColumnToValue.

C#
public System.Type ValueType();
See Also
StringAsDbxBlob Class
Eco.Persistence.Dbx.Interbase Namespace


StringAsDbxVarChar Class

StringAsDbxVarChar Class
Inheritance Hierarchy See Also
Collapse All

Class for mapping String values to a single column in a database.

C#
public sealed class StringAsDbxVarChar : AbstractStringSingleColumnAttribute, ISingleColumnAttributemapping;
Inheritance Hierarchy
Eco.Persistence.ISingleColumnAttributemapping
    Eco.Persistence.Dbx.Interbase.StringAsDbxVarChar
File

InterbaseAttributeMappersDbx.cs

See Also
Inheritance Hierarchy


StringAsDbxVarChar Methods

StringAsDbxVarChar Methods
Public Methods
Collapse All

The methods of the StringAsDbxVarChar class are listed here.

Public Methods
Name | Description
ColumnToValue | Converts a value that comes from a database query to an ecospace value.
ColumnType | Returns the SQL type used by the database during CREATE TABLE execution.
StringToParameter | Converts a string to the correct data type and then inserts the given value into the IDataParameter.
ValueToParameter | Inserts the given value into the IDataParameter.
ValueType | Returns the .NET type of the column.


StringAsDbxVarChar.ColumnToValue Method

StringAsDbxVarChar.ColumnToValue Method
StringAsDbxVarChar Class Eco.Persistence.Dbx.Interbase Namespace See Also
Collapse All

Converts a value that comes from a database query to an ecospace value.

C#
public override System.Object ColumnToValue(
    System.Object columnValue
);
Remarks

In many cases, the implementation of this method mainly converts DBNull-values to null, but it can also change the CLR-type of the database value from for example a char[] to a string. or from an integer to a boolean. This is the reverse operation of ValueToParameter.

See Also
StringAsDbxVarChar Class
Eco.Persistence.Dbx.Interbase Namespace


StringAsDbxVarChar.ColumnType Method

StringAsDbxVarChar.ColumnType Method
StringAsDbxVarChar Class Eco.Persistence.Dbx.Interbase Namespace See Also
Collapse All

Returns the SQL type used by the database during CREATE TABLE execution.

C#
public string ColumnType(
    int length
);
Parameters
Parameters | Description
length | The column length in the table.
See Also
StringAsDbxVarChar Class
Eco.Persistence.Dbx.Interbase Namespace


StringAsDbxVarChar.StringToParameter Method

StringAsDbxVarChar.StringToParameter Method
StringAsDbxVarChar Class Eco.Persistence.Dbx.Interbase Namespace See Also
Collapse All

Converts a string to the correct data type and then inserts the given value into the IDataParameter.

C#
public void StringToParameter(
    string value,
    IDataParameter parameter
);
Parameters
Parameters | Description
value | The value to use.
parameter | The IDataParameter to update.
See Also
StringAsDbxVarChar Class
Eco.Persistence.Dbx.Interbase Namespace


StringAsDbxVarChar.ValueToParameter Method

StringAsDbxVarChar.ValueToParameter Method
StringAsDbxVarChar Class Eco.Persistence.Dbx.Interbase Namespace See Also
Collapse All

Inserts the given value into the IDataParameter.

C#
public void ValueToParameter(
    System.Object value,
    IDataParameter parameter
);
Parameters
Parameters | Description
value | The value to use.
parameter | The IDataParameter to update.
See Also
StringAsDbxVarChar Class
Eco.Persistence.Dbx.Interbase Namespace


StringAsDbxVarChar.ValueType Method

StringAsDbxVarChar.ValueType Method
StringAsDbxVarChar Class Eco.Persistence.Dbx.Interbase Namespace See Also
Collapse All

Returns the .NET type of the column.

C#
public System.Type ValueType();
See Also
StringAsDbxVarChar Class
Eco.Persistence.Dbx.Interbase Namespace


Eco.Persistence.Dbx.MySql Namespace

Eco.Persistence.Dbx.MySql Namespace
Classes
Collapse All

This is namespace Eco.Persistence.Dbx.MySql.

Classes
Name | Description
ByteArrayAsDbxBlob | Mapper between a ByteArray value and its persistent representation as BLOB.
StringAsLongText | This is class Eco.Persistence.Dbx.MySql.StringAsLongText.


ByteArrayAsDbxBlob Class

ByteArrayAsDbxBlob Class
Inheritance Hierarchy See Also
Collapse All

Mapper between a ByteArray value and its persistent representation as BLOB.

C#
public sealed class ByteArrayAsDbxBlob : AbstractSingleColumnAttribute, ISingleColumnAttributemapping;
Inheritance Hierarchy
Eco.Persistence.ISingleColumnAttributemapping
    Eco.Persistence.Dbx.MySql.ByteArrayAsDbxBlob
File

MySqlAttributeMappersDbx.cs

See Also
Inheritance Hierarchy


ByteArrayAsDbxBlob.ColumnToValue Method

ByteArrayAsDbxBlob.ColumnToValue Method
ByteArrayAsDbxBlob Class Eco.Persistence.Dbx.MySql Namespace See Also
Collapse All

Converts a value that comes from a database query to an ecospace value.

C#
public override System.Object ColumnToValue(
    System.Object columnValue
);
Remarks

In many cases, the implementation of this method mainly converts DBNull-values to null, but it can also change the CLR-type of the database value from for example a char[] to a string. or from an integer to a boolean. This is the reverse operation of ValueToParameter.

See Also
ByteArrayAsDbxBlob Class
Eco.Persistence.Dbx.MySql Namespace


ByteArrayAsDbxBlob.ColumnType Method

ByteArrayAsDbxBlob.ColumnType Method
ByteArrayAsDbxBlob Class Eco.Persistence.Dbx.MySql Namespace See Also
Collapse All

Specifies the SQL type of the column.

C#
public string ColumnType(
    int length
);
See Also
ByteArrayAsDbxBlob Class
Eco.Persistence.Dbx.MySql Namespace


ByteArrayAsDbxBlob.DefaultDbValue Method

ByteArrayAsDbxBlob.DefaultDbValue Method
ByteArrayAsDbxBlob Class Eco.Persistence.Dbx.MySql Namespace See Also
Collapse All

The return value of this function will be used as default value for new columns when databases are created/evolved.

C#
public string DefaultDbValue(
    string modeledValue,
    SqlDatabaseConfig sqlDatabaseConfig
);
See Also
ByteArrayAsDbxBlob Class
Eco.Persistence.Dbx.MySql Namespace


ByteArrayAsDbxBlob.IsEqual Method

ByteArrayAsDbxBlob.IsEqual Method
ByteArrayAsDbxBlob Class Eco.Persistence.Dbx.MySql Namespace See Also
Collapse All

Returns true if an ecospace value ("value") is equal to a database value ("columnValue").

C#
public override bool IsEqual(
    System.Object value,
    System.Object columnValue
);
Remarks

This method must handle the conversions between ecospace and database values, it must also handle comparing null/DBNull values.

See Also
ByteArrayAsDbxBlob Class
Eco.Persistence.Dbx.MySql Namespace


ByteArrayAsDbxBlob.StringToParameter Method

ByteArrayAsDbxBlob.StringToParameter Method
ByteArrayAsDbxBlob Class Eco.Persistence.Dbx.MySql Namespace See Also
Collapse All
C#
public void StringToParameter(
    string value,
    IDataParameter parameter
);
Exceptions
Exceptions | Description
InvalidOperationException | Thrown always.
See Also
ByteArrayAsDbxBlob Class
Eco.Persistence.Dbx.MySql Namespace


ByteArrayAsDbxBlob.ValueToParameter Method

ByteArrayAsDbxBlob.ValueToParameter Method
ByteArrayAsDbxBlob Class Eco.Persistence.Dbx.MySql Namespace See Also
Collapse All

Converts a value that comes from a database query to an ecospace value.

C#
public void ValueToParameter(
    System.Object value,
    IDataParameter parameter
);
Remarks

In many cases, the implementation of this method mainly converts null to DBNull, but it can also handle conversion from for example booleans to integers, byte[] to database blobs. It also has to set the correct parameter types in the IDataParameter-object. This is the reverse operation of ColumnToValue.

See Also
ByteArrayAsDbxBlob Class
Eco.Persistence.Dbx.MySql Namespace


ByteArrayAsDbxBlob.ValueType Method

ByteArrayAsDbxBlob.ValueType Method
ByteArrayAsDbxBlob Class Eco.Persistence.Dbx.MySql Namespace See Also
Collapse All

This method returns the type of the value that is returned by ColumnToValue.

C#
public System.Type ValueType();
See Also
ByteArrayAsDbxBlob Class
Eco.Persistence.Dbx.MySql Namespace


StringAsLongText Class

StringAsLongText Class
Inheritance Hierarchy See Also
Collapse All
C#
public sealed class StringAsLongText : AbstractSingleColumnAttribute, ISingleColumnAttributemapping;
Remarks

This is class Eco.Persistence.Dbx.MySql.StringAsLongText.

Inheritance Hierarchy
Eco.Persistence.ISingleColumnAttributemapping
    Eco.Persistence.Dbx.MySql.StringAsLongText
File

MySqlAttributeMappersDbx.cs

See Also
Inheritance Hierarchy


StringAsLongText Methods

StringAsLongText Methods
Public Methods
Collapse All

The methods of the StringAsLongText class are listed here.

Public Methods
Name | Description
ColumnToValue | Converts a value that comes from a database query to an ecospace value.
ColumnType | Specifies the SQL type of the column.
DefaultDbValue | The return value of this function will be used as default value for new columns when databases are created/evolved.
StringToParameter | This is StringToParameter, a member of class StringAsLongText.
ValueToParameter | Converts a value that comes from a database query to an ecospace value.
ValueType | This method returns the type of the value that is returned by ColumnToValue.


StringAsLongText.ColumnToValue Method

StringAsLongText.ColumnToValue Method
StringAsLongText Class Eco.Persistence.Dbx.MySql Namespace See Also
Collapse All

Converts a value that comes from a database query to an ecospace value.

C#
public override System.Object ColumnToValue(
    System.Object columnValue
);
Remarks

In many cases, the implementation of this method mainly converts DBNull-values to null, but it can also change the CLR-type of the database value from for example a char[] to a string. or from an integer to a boolean. This is the reverse operation of ValueToParameter.

See Also
StringAsLongText Class
Eco.Persistence.Dbx.MySql Namespace


StringAsLongText.ColumnType Method

StringAsLongText.ColumnType Method
StringAsLongText Class Eco.Persistence.Dbx.MySql Namespace See Also
Collapse All

Specifies the SQL type of the column.

C#
public string ColumnType(
    int length
);
See Also
StringAsLongText Class
Eco.Persistence.Dbx.MySql Namespace


StringAsLongText.DefaultDbValue Method

StringAsLongText.DefaultDbValue Method
StringAsLongText Class Eco.Persistence.Dbx.MySql Namespace See Also
Collapse All

The return value of this function will be used as default value for new columns when databases are created/evolved.

C#
public string DefaultDbValue(
    string modeledValue,
    SqlDatabaseConfig sqlDatabaseConfig
);
See Also
StringAsLongText Class
Eco.Persistence.Dbx.MySql Namespace


StringAsLongText.StringToParameter Method

StringAsLongText.StringToParameter Method
StringAsLongText Class Eco.Persistence.Dbx.MySql Namespace See Also
Collapse All
C#
public void StringToParameter(
    string value,
    IDataParameter parameter
);
Remarks

This is StringToParameter, a member of class StringAsLongText.

See Also
StringAsLongText Class
Eco.Persistence.Dbx.MySql Namespace


StringAsLongText.ValueToParameter Method

StringAsLongText.ValueToParameter Method
StringAsLongText Class Eco.Persistence.Dbx.MySql Namespace See Also
Collapse All

Converts a value that comes from a database query to an ecospace value.

C#
public void ValueToParameter(
    System.Object value,
    IDataParameter parameter
);
Remarks

In many cases, the implementation of this method mainly converts null to DBNull, but it can also handle conversion from for example booleans to integers, byte[] to database blobs. It also has to set the correct parameter types in the IDataParameter-object. This is the reverse operation of ColumnToValue.

See Also
StringAsLongText Class
Eco.Persistence.Dbx.MySql Namespace


StringAsLongText.ValueType Method

StringAsLongText.ValueType Method
StringAsLongText Class Eco.Persistence.Dbx.MySql Namespace See Also
Collapse All

This method returns the type of the value that is returned by ColumnToValue.

C#
public System.Type ValueType();
See Also
StringAsLongText Class
Eco.Persistence.Dbx.MySql Namespace


Eco.Persistence.Dbx.Oracle Namespace

Eco.Persistence.Dbx.Oracle Namespace
Classes
Collapse All

This is namespace Eco.Persistence.Dbx.Oracle.

Classes
Name | Description
ByteArrayAsBlob | Mapper between a ByteArray value and its persistent representation as BLOB.
StringAsClob | This is class Eco.Persistence.Dbx.Oracle.StringAsClob.
StringAsNClob | This is class Eco.Persistence.Dbx.Oracle.StringAsNClob.


ByteArrayAsBlob Class

ByteArrayAsBlob Class
Inheritance Hierarchy See Also
Collapse All

Mapper between a ByteArray value and its persistent representation as BLOB.

C#
public sealed class ByteArrayAsBlob : AbstractSingleColumnAttribute, ISingleColumnAttributemapping;
Inheritance Hierarchy
Eco.Persistence.ISingleColumnAttributemapping
    Eco.Persistence.Dbx.Oracle.ByteArrayAsBlob
File

OracleAttributeMappersDbx.cs

See Also
Inheritance Hierarchy


ByteArrayAsBlob Methods

ByteArrayAsBlob Methods
Public Methods
Collapse All

The methods of the ByteArrayAsBlob class are listed here.

Public Methods
Name | Description
ColumnToValue | Converts a value that comes from a database query to an ecospace value.
ColumnType | Specifies the SQL type of the column.
DefaultDbValue | The return value of this function will be used as default value for new columns when databases are created/evolved.
IsEqual | Returns true if an ecospace value ("value") is equal to a database value ("columnValue").
StringToParameter |
ValueToParameter | Converts a value that comes from a database query to an ecospace value.
ValueType | This method returns the type of the value that is returned by ColumnToValue.


ByteArrayAsBlob.ColumnToValue Method

ByteArrayAsBlob.ColumnToValue Method
ByteArrayAsBlob Class Eco.Persistence.Dbx.Oracle Namespace See Also
Collapse All

Converts a value that comes from a database query to an ecospace value.

C#
public override System.Object ColumnToValue(
    System.Object columnValue
);
Remarks

In many cases, the implementation of this method mainly converts DBNull-values to null, but it can also change the CLR-type of the database value from for example a char[] to a string. or from an integer to a boolean. This is the reverse operation of ValueToParameter.

See Also
ByteArrayAsBlob Class
Eco.Persistence.Dbx.Oracle Namespace


ByteArrayAsBlob.ColumnType Method

ByteArrayAsBlob.ColumnType Method
ByteArrayAsBlob Class Eco.Persistence.Dbx.Oracle Namespace See Also
Collapse All

Specifies the SQL type of the column.

C#
public string ColumnType(
    int length
);
See Also
ByteArrayAsBlob Class
Eco.Persistence.Dbx.Oracle Namespace


ByteArrayAsBlob.DefaultDbValue Method

ByteArrayAsBlob.DefaultDbValue Method
ByteArrayAsBlob Class Eco.Persistence.Dbx.Oracle Namespace See Also
Collapse All

The return value of this function will be used as default value for new columns when databases are created/evolved.

C#
public string DefaultDbValue(
    string modeledValue,
    SqlDatabaseConfig sqlDatabaseConfig
);
See Also
ByteArrayAsBlob Class
Eco.Persistence.Dbx.Oracle Namespace


ByteArrayAsBlob.IsEqual Method

ByteArrayAsBlob.IsEqual Method
ByteArrayAsBlob Class Eco.Persistence.Dbx.Oracle Namespace See Also
Collapse All

Returns true if an ecospace value ("value") is equal to a database value ("columnValue").

C#
public override bool IsEqual(
    System.Object value,
    System.Object columnValue
);
Remarks

This method must handle the conversions between ecospace and database values, it must also handle comparing null/DBNull values.

See Also
ByteArrayAsBlob Class
Eco.Persistence.Dbx.Oracle Namespace


ByteArrayAsBlob.StringToParameter Method

ByteArrayAsBlob.StringToParameter Method
ByteArrayAsBlob Class Eco.Persistence.Dbx.Oracle Namespace See Also
Collapse All
C#
public void StringToParameter(
    string value,
    IDataParameter parameter
);
Exceptions
Exceptions | Description
InvalidOperationException | Thrown always.
See Also
ByteArrayAsBlob Class
Eco.Persistence.Dbx.Oracle Namespace


ByteArrayAsBlob.ValueToParameter Method

ByteArrayAsBlob.ValueToParameter Method
ByteArrayAsBlob Class Eco.Persistence.Dbx.Oracle Namespace See Also
Collapse All

Converts a value that comes from a database query to an ecospace value.

C#
public void ValueToParameter(
    System.Object value,
    IDataParameter parameter
);
Remarks

In many cases, the implementation of this method mainly converts null to DBNull, but it can also handle conversion from for example booleans to integers, byte[] to database blobs. It also has to set the correct parameter types in the IDataParameter-object. This is the reverse operation of ColumnToValue.

See Also
ByteArrayAsBlob Class
Eco.Persistence.Dbx.Oracle Namespace


ByteArrayAsBlob.ValueType Method

ByteArrayAsBlob.ValueType Method
ByteArrayAsBlob Class Eco.Persistence.Dbx.Oracle Namespace See Also
Collapse All

This method returns the type of the value that is returned by ColumnToValue.

C#
public System.Type ValueType();
See Also
ByteArrayAsBlob Class
Eco.Persistence.Dbx.Oracle Namespace


StringAsClob Class

StringAsClob Class
Inheritance Hierarchy See Also
Collapse All
C#
public sealed class StringAsClob : AbstractSingleColumnAttribute, ISingleColumnAttributemapping;
Remarks

This is class Eco.Persistence.Dbx.Oracle.StringAsClob.

Inheritance Hierarchy
Eco.Persistence.ISingleColumnAttributemapping
    Eco.Persistence.Dbx.Oracle.StringAsClob
File

OracleAttributeMappersDbx.cs

See Also
Inheritance Hierarchy


StringAsClob Methods

StringAsClob Methods
Public Methods
Collapse All

The methods of the StringAsClob class are listed here.

Public Methods
Name | Description
ColumnToValue | Converts a value that comes from a database query to an ecospace value.
ColumnType | Specifies the SQL type of the column.
DefaultDbValue | The return value of this function will be used as default value for new columns when databases are created/evolved.
StringToParameter | This is StringToParameter, a member of class StringAsClob.
ValueToParameter | Converts a value that comes from a database query to an ecospace value.
ValueType | This method returns the type of the value that is returned by ColumnToValue.


StringAsClob.ColumnToValue Method

StringAsClob.ColumnToValue Method
StringAsClob Class Eco.Persistence.Dbx.Oracle Namespace See Also
Collapse All

Converts a value that comes from a database query to an ecospace value.

C#
public override System.Object ColumnToValue(
    System.Object columnValue
);
Remarks

In many cases, the implementation of this method mainly converts DBNull-values to null, but it can also change the CLR-type of the database value from for example a char[] to a string. or from an integer to a boolean. This is the reverse operation of ValueToParameter.

See Also
StringAsClob Class
Eco.Persistence.Dbx.Oracle Namespace


StringAsClob.ColumnType Method

StringAsClob.ColumnType Method
StringAsClob Class Eco.Persistence.Dbx.Oracle Namespace See Also
Collapse All

Specifies the SQL type of the column.

C#
public string ColumnType(
    int length
);
See Also
StringAsClob Class
Eco.Persistence.Dbx.Oracle Namespace


StringAsClob.DefaultDbValue Method

StringAsClob.DefaultDbValue Method
StringAsClob Class Eco.Persistence.Dbx.Oracle Namespace See Also
Collapse All

The return value of this function will be used as default value for new columns when databases are created/evolved.

C#
public string DefaultDbValue(
    string modeledValue,
    SqlDatabaseConfig sqlDatabaseConfig
);
See Also
StringAsClob Class
Eco.Persistence.Dbx.Oracle Namespace


StringAsClob.StringToParameter Method

StringAsClob.StringToParameter Method
StringAsClob Class Eco.Persistence.Dbx.Oracle Namespace See Also
Collapse All
C#
public void StringToParameter(
    string value,
    IDataParameter parameter
);
Remarks

This is StringToParameter, a member of class StringAsClob.

See Also
StringAsClob Class
Eco.Persistence.Dbx.Oracle Namespace


StringAsClob.ValueToParameter Method

StringAsClob.ValueToParameter Method
StringAsClob Class Eco.Persistence.Dbx.Oracle Namespace See Also
Collapse All

Converts a value that comes from a database query to an ecospace value.

C#
public void ValueToParameter(
    System.Object value,
    IDataParameter parameter
);
Remarks

In many cases, the implementation of this method mainly converts null to DBNull, but it can also handle conversion from for example booleans to integers, byte[] to database blobs. It also has to set the correct parameter types in the IDataParameter-object. This is the reverse operation of ColumnToValue.

See Also
StringAsClob Class
Eco.Persistence.Dbx.Oracle Namespace


StringAsClob.ValueType Method

StringAsClob.ValueType Method
StringAsClob Class Eco.Persistence.Dbx.Oracle Namespace See Also
Collapse All

This method returns the type of the value that is returned by ColumnToValue.

C#
public System.Type ValueType();
See Also
StringAsClob Class
Eco.Persistence.Dbx.Oracle Namespace


StringAsNClob Class

StringAsNClob Class
Inheritance Hierarchy See Also
Collapse All
C#
public sealed class StringAsNClob : AbstractSingleColumnAttribute, ISingleColumnAttributemapping;
Remarks

This is class Eco.Persistence.Dbx.Oracle.StringAsNClob.

Inheritance Hierarchy
Eco.Persistence.ISingleColumnAttributemapping
    Eco.Persistence.Dbx.Oracle.StringAsNClob
File

OracleAttributeMappersDbx.cs

See Also
Inheritance Hierarchy


StringAsNClob Methods

StringAsNClob Methods
Public Methods
Collapse All

The methods of the StringAsNClob class are listed here.

Public Methods
Name | Description
ColumnToValue | Converts a value that comes from a database query to an ecospace value.
ColumnType | Specifies the SQL type of the column.
DefaultDbValue | The return value of this function will be used as default value for new columns when databases are created/evolved.
StringToParameter | This is StringToParameter, a member of class StringAsNClob.
ValueToParameter | Converts a value that comes from a database query to an ecospace value.
ValueType | This method returns the type of the value that is returned by ColumnToValue.


StringAsNClob.ColumnToValue Method

StringAsNClob.ColumnToValue Method
StringAsNClob Class Eco.Persistence.Dbx.Oracle Namespace See Also
Collapse All

Converts a value that comes from a database query to an ecospace value.

C#
public override System.Object ColumnToValue(
    System.Object columnValue
);
Remarks

In many cases, the implementation of this method mainly converts DBNull-values to null, but it can also change the CLR-type of the database value from for example a char[] to a string. or from an integer to a boolean. This is the reverse operation of ValueToParameter.

See Also
StringAsNClob Class
Eco.Persistence.Dbx.Oracle Namespace


StringAsNClob.ColumnType Method

StringAsNClob.ColumnType Method
StringAsNClob Class Eco.Persistence.Dbx.Oracle Namespace See Also
Collapse All

Specifies the SQL type of the column.

C#
public string ColumnType(
    int length
);
See Also
StringAsNClob Class
Eco.Persistence.Dbx.Oracle Namespace


StringAsNClob.DefaultDbValue Method

StringAsNClob.DefaultDbValue Method
StringAsNClob Class Eco.Persistence.Dbx.Oracle Namespace See Also
Collapse All

The return value of this function will be used as default value for new columns when databases are created/evolved.

C#
public string DefaultDbValue(
    string modeledValue,
    SqlDatabaseConfig sqlDatabaseConfig
);
See Also
StringAsNClob Class
Eco.Persistence.Dbx.Oracle Namespace


StringAsNClob.StringToParameter Method

StringAsNClob.StringToParameter Method
StringAsNClob Class Eco.Persistence.Dbx.Oracle Namespace See Also
Collapse All
C#
public void StringToParameter(
    string value,
    IDataParameter parameter
);
Remarks

This is StringToParameter, a member of class StringAsNClob.

See Also
StringAsNClob Class
Eco.Persistence.Dbx.Oracle Namespace


StringAsNClob.ValueToParameter Method

StringAsNClob.ValueToParameter Method
StringAsNClob Class Eco.Persistence.Dbx.Oracle Namespace See Also
Collapse All

Converts a value that comes from a database query to an ecospace value.

C#
public void ValueToParameter(
    System.Object value,
    IDataParameter parameter
);
Remarks

In many cases, the implementation of this method mainly converts null to DBNull, but it can also handle conversion from for example booleans to integers, byte[] to database blobs. It also has to set the correct parameter types in the IDataParameter-object. This is the reverse operation of ColumnToValue.

See Also
StringAsNClob Class
Eco.Persistence.Dbx.Oracle Namespace


StringAsNClob.ValueType Method

StringAsNClob.ValueType Method
StringAsNClob Class Eco.Persistence.Dbx.Oracle Namespace See Also
Collapse All

This method returns the type of the value that is returned by ColumnToValue.

C#
public System.Type ValueType();
See Also
StringAsNClob Class
Eco.Persistence.Dbx.Oracle Namespace


Eco.Persistence.Dbx.SqlServer Namespace

Eco.Persistence.Dbx.SqlServer Namespace
Classes
Collapse All

This is namespace Eco.Persistence.Dbx.SqlServer.

Classes
Name | Description
ByteArrayAsImage | Mapper between a ByteArray value and its persistent representation as IMAGE.
ByteAsTinyInt | This is class Eco.Persistence.Dbx.SqlServer.ByteAsTinyInt.
StringAsNText | This is class Eco.Persistence.Dbx.SqlServer.StringAsNText.
StringAsText | This is class Eco.Persistence.Dbx.SqlServer.StringAsText.


ByteArrayAsImage Class

ByteArrayAsImage Class
Inheritance Hierarchy See Also
Collapse All

Mapper between a ByteArray value and its persistent representation as IMAGE.

C#
public sealed class ByteArrayAsImage : AbstractSingleColumnAttribute, ISingleColumnAttributemapping;
Inheritance Hierarchy
Eco.Persistence.ISingleColumnAttributemapping
    Eco.Persistence.Dbx.SqlServer.ByteArrayAsImage
File

SqlServerAttributeMappersDbx.cs

See Also
Inheritance Hierarchy


ByteArrayAsImage Methods

ByteArrayAsImage Methods
Public Methods
Collapse All

The methods of the ByteArrayAsImage class are listed here.

Public Methods
Name | Description
ColumnToValue | Converts a value that comes from a database query to an ecospace value.
ColumnType | Specifies the SQL type of the column.
DefaultDbValue | The return value of this function will be used as default value for new columns when databases are created/evolved.
IsEqual | Returns true if an ecospace value ("value") is equal to a database value ("columnValue").
StringToParameter |
ValueToParameter | Converts a value that comes from a database query to an ecospace value.
ValueType | This method returns the type of the value that is returned by ColumnToValue.


ByteArrayAsImage.ColumnToValue Method

ByteArrayAsImage.ColumnToValue Method
ByteArrayAsImage Class Eco.Persistence.Dbx.SqlServer Namespace See Also
Collapse All

Converts a value that comes from a database query to an ecospace value.

C#
public override System.Object ColumnToValue(
    System.Object columnValue
);
Remarks

In many cases, the implementation of this method mainly converts DBNull-values to null, but it can also change the CLR-type of the database value from for example a char[] to a string. or from an integer to a boolean. This is the reverse operation of ValueToParameter.

See Also
ByteArrayAsImage Class
Eco.Persistence.Dbx.SqlServer Namespace


ByteArrayAsImage.ColumnType Method

ByteArrayAsImage.ColumnType Method
ByteArrayAsImage Class Eco.Persistence.Dbx.SqlServer Namespace See Also
Collapse All

Specifies the SQL type of the column.

C#
public String ColumnType(
    int length
);
See Also
ByteArrayAsImage Class
Eco.Persistence.Dbx.SqlServer Namespace


ByteArrayAsImage.DefaultDbValue Method

ByteArrayAsImage.DefaultDbValue Method
ByteArrayAsImage Class Eco.Persistence.Dbx.SqlServer Namespace See Also
Collapse All

The return value of this function will be used as default value for new columns when databases are created/evolved.

C#
public String DefaultDbValue(
    string modeledValue,
    SqlDatabaseConfig sqlDatabaseConfig
);
See Also
ByteArrayAsImage Class
Eco.Persistence.Dbx.SqlServer Namespace


ByteArrayAsImage.IsEqual Method

ByteArrayAsImage.IsEqual Method
ByteArrayAsImage Class Eco.Persistence.Dbx.SqlServer Namespace See Also
Collapse All

Returns true if an ecospace value ("value") is equal to a database value ("columnValue").

C#
public override bool IsEqual(
    System.Object value,
    System.Object columnValue
);
Remarks

This method must handle the conversions between ecospace and database values, it must also handle comparing null/DBNull values.

See Also
ByteArrayAsImage Class
Eco.Persistence.Dbx.SqlServer Namespace


ByteArrayAsImage.StringToParameter Method

ByteArrayAsImage.StringToParameter Method
ByteArrayAsImage Class Eco.Persistence.Dbx.SqlServer Namespace See Also
Collapse All
C#
public void StringToParameter(
    string value,
    IDataParameter parameter
);
Exceptions
Exceptions | Description
InvalidOperationException | Thrown always.
See Also
ByteArrayAsImage Class
Eco.Persistence.Dbx.SqlServer Namespace


ByteArrayAsImage.ValueToParameter Method

ByteArrayAsImage.ValueToParameter Method
ByteArrayAsImage Class Eco.Persistence.Dbx.SqlServer Namespace See Also
Collapse All

Converts a value that comes from a database query to an ecospace value.

C#
public void ValueToParameter(
    System.Object value,
    IDataParameter parameter
);
Remarks

In many cases, the implementation of this method mainly converts null to DBNull, but it can also handle conversion from for example booleans to integers, byte[] to database blobs. It also has to set the correct parameter types in the IDataParameter-object. This is the reverse operation of ColumnToValue.

See Also
ByteArrayAsImage Class
Eco.Persistence.Dbx.SqlServer Namespace


ByteArrayAsImage.ValueType Method

ByteArrayAsImage.ValueType Method
ByteArrayAsImage Class Eco.Persistence.Dbx.SqlServer Namespace See Also
Collapse All

This method returns the type of the value that is returned by ColumnToValue.

C#
public System.Type ValueType();
See Also
ByteArrayAsImage Class
Eco.Persistence.Dbx.SqlServer Namespace


ByteAsTinyInt Class

ByteAsTinyInt Class
Inheritance Hierarchy See Also
Collapse All
C#
public sealed class ByteAsTinyInt : AbstractNumericSingleColumnAttribute, ISingleColumnAttributemapping;
Remarks

This is class Eco.Persistence.Dbx.SqlServer.ByteAsTinyInt.

Inheritance Hierarchy
Eco.Persistence.ISingleColumnAttributemapping
    Eco.Persistence.Dbx.SqlServer.ByteAsTinyInt
File

SqlServerAttributeMappersDbx.cs

See Also
Inheritance Hierarchy


ByteAsTinyInt Methods

ByteAsTinyInt Methods
Public Methods
Collapse All

The methods of the ByteAsTinyInt class are listed here.

Public Methods
Name | Description
ColumnToValue | Converts a value that comes from a database query to an ecospace value.
ColumnType | Specifies the SQL type of the column.
StringToParameter | This is StringToParameter, a member of class ByteAsTinyInt.
ValueToParameter | Converts a value that comes from a database query to an ecospace value.
ValueType | This method returns the type of the value that is returned by ColumnToValue.


ByteAsTinyInt.ColumnToValue Method

ByteAsTinyInt.ColumnToValue Method
ByteAsTinyInt Class Eco.Persistence.Dbx.SqlServer Namespace See Also
Collapse All

Converts a value that comes from a database query to an ecospace value.

C#
public override System.Object ColumnToValue(
    System.Object columnValue
);
Remarks

In many cases, the implementation of this method mainly converts DBNull-values to null, but it can also change the CLR-type of the database value from for example a char[] to a string. or from an integer to a boolean. This is the reverse operation of ValueToParameter.

See Also
ByteAsTinyInt Class
Eco.Persistence.Dbx.SqlServer Namespace


ByteAsTinyInt.ColumnType Method

ByteAsTinyInt.ColumnType Method
ByteAsTinyInt Class Eco.Persistence.Dbx.SqlServer Namespace See Also
Collapse All

Specifies the SQL type of the column.

C#
public String ColumnType(
    int length
);
See Also
ByteAsTinyInt Class
Eco.Persistence.Dbx.SqlServer Namespace


ByteAsTinyInt.StringToParameter Method

ByteAsTinyInt.StringToParameter Method
ByteAsTinyInt Class Eco.Persistence.Dbx.SqlServer Namespace See Also
Collapse All
C#
public void StringToParameter(
    string value,
    IDataParameter parameter
);
Remarks

This is StringToParameter, a member of class ByteAsTinyInt.

See Also
ByteAsTinyInt Class
Eco.Persistence.Dbx.SqlServer Namespace


ByteAsTinyInt.ValueToParameter Method

ByteAsTinyInt.ValueToParameter Method
ByteAsTinyInt Class Eco.Persistence.Dbx.SqlServer Namespace See Also
Collapse All

Converts a value that comes from a database query to an ecospace value.

C#
public void ValueToParameter(
    System.Object value,
    IDataParameter parameter
);
Remarks

In many cases, the implementation of this method mainly converts null to DBNull, but it can also handle conversion from for example booleans to integers, byte[] to database blobs. It also has to set the correct parameter types in the IDataParameter-object. This is the reverse operation of ColumnToValue.

See Also
ByteAsTinyInt Class
Eco.Persistence.Dbx.SqlServer Namespace


ByteAsTinyInt.ValueType Method

ByteAsTinyInt.ValueType Method
ByteAsTinyInt Class Eco.Persistence.Dbx.SqlServer Namespace See Also
Collapse All

This method returns the type of the value that is returned by ColumnToValue.

C#
public System.Type ValueType();
See Also
ByteAsTinyInt Class
Eco.Persistence.Dbx.SqlServer Namespace


StringAsNText Class

StringAsNText Class
Inheritance Hierarchy See Also
Collapse All
C#
public sealed class StringAsNText : AbstractSingleColumnAttribute, ISingleColumnAttributemapping;
Remarks

This is class Eco.Persistence.Dbx.SqlServer.StringAsNText.

Inheritance Hierarchy
Eco.Persistence.ISingleColumnAttributemapping
    Eco.Persistence.Dbx.SqlServer.StringAsNText
File

SqlServerAttributeMappersDbx.cs

See Also
Inheritance Hierarchy


StringAsNText Methods

StringAsNText Methods
Public Methods
Collapse All

The methods of the StringAsNText class are listed here.

Public Methods
Name | Description
ColumnToValue | Converts a value that comes from a database query to an ecospace value.
ColumnType | Specifies the SQL type of the column.
DefaultDbValue | The return value of this function will be used as default value for new columns when databases are created/evolved.
StringToParameter | This is StringToParameter, a member of class StringAsNText.
ValueToParameter | Converts a value that comes from a database query to an ecospace value.
ValueType | This method returns the type of the value that is returned by ColumnToValue.


StringAsNText.ColumnToValue Method

StringAsNText.ColumnToValue Method
StringAsNText Class Eco.Persistence.Dbx.SqlServer Namespace See Also
Collapse All

Converts a value that comes from a database query to an ecospace value.

C#
public override System.Object ColumnToValue(
    System.Object columnValue
);
Remarks

In many cases, the implementation of this method mainly converts DBNull-values to null, but it can also change the CLR-type of the database value from for example a char[] to a string. or from an integer to a boolean. This is the reverse operation of ValueToParameter.

See Also
StringAsNText Class
Eco.Persistence.Dbx.SqlServer Namespace


StringAsNText.ColumnType Method

StringAsNText.ColumnType Method
StringAsNText Class Eco.Persistence.Dbx.SqlServer Namespace See Also
Collapse All

Specifies the SQL type of the column.

C#
public String ColumnType(
    int length
);
See Also
StringAsNText Class
Eco.Persistence.Dbx.SqlServer Namespace


StringAsNText.DefaultDbValue Method

StringAsNText.DefaultDbValue Method
StringAsNText Class Eco.Persistence.Dbx.SqlServer Namespace See Also
Collapse All

The return value of this function will be used as default value for new columns when databases are created/evolved.

C#
public String DefaultDbValue(
    string modeledValue,
    SqlDatabaseConfig sqlDatabaseConfig
);
See Also
StringAsNText Class
Eco.Persistence.Dbx.SqlServer Namespace


StringAsNText.StringToParameter Method

StringAsNText.StringToParameter Method
StringAsNText Class Eco.Persistence.Dbx.SqlServer Namespace See Also
Collapse All
C#
public void StringToParameter(
    string value,
    IDataParameter parameter
);
Remarks

This is StringToParameter, a member of class StringAsNText.

See Also
StringAsNText Class
Eco.Persistence.Dbx.SqlServer Namespace


StringAsNText.ValueToParameter Method

StringAsNText.ValueToParameter Method
StringAsNText Class Eco.Persistence.Dbx.SqlServer Namespace See Also
Collapse All

Converts a value that comes from a database query to an ecospace value.

C#
public void ValueToParameter(
    System.Object value,
    IDataParameter parameter
);
Remarks

In many cases, the implementation of this method mainly converts null to DBNull, but it can also handle conversion from for example booleans to integers, byte[] to database blobs. It also has to set the correct parameter types in the IDataParameter-object. This is the reverse operation of ColumnToValue.

See Also
StringAsNText Class
Eco.Persistence.Dbx.SqlServer Namespace


StringAsNText.ValueType Method

StringAsNText.ValueType Method
StringAsNText Class Eco.Persistence.Dbx.SqlServer Namespace See Also
Collapse All

This method returns the type of the value that is returned by ColumnToValue.

C#
public System.Type ValueType();
See Also
StringAsNText Class
Eco.Persistence.Dbx.SqlServer Namespace


StringAsText Class

StringAsText Class
Inheritance Hierarchy See Also
Collapse All
C#
public sealed class StringAsText : AbstractSingleColumnAttribute, ISingleColumnAttributemapping;
Remarks

This is class Eco.Persistence.Dbx.SqlServer.StringAsText.

Inheritance Hierarchy
Eco.Persistence.ISingleColumnAttributemapping
    Eco.Persistence.Dbx.SqlServer.StringAsText
File

SqlServerAttributeMappersDbx.cs

See Also
Inheritance Hierarchy


StringAsText Methods

StringAsText Methods
Public Methods
Collapse All

The methods of the StringAsText class are listed here.

Public Methods
Name | Description
ColumnToValue | Converts a value that comes from a database query to an ecospace value.
ColumnType | Specifies the SQL type of the column.
DefaultDbValue | The return value of this function will be used as default value for new columns when databases are created/evolved.
StringToParameter | This is StringToParameter, a member of class StringAsText.
ValueToParameter | Converts a value that comes from a database query to an ecospace value.
ValueType | This method returns the type of the value that is returned by ColumnToValue.


StringAsText.ColumnToValue Method

StringAsText.ColumnToValue Method
StringAsText Class Eco.Persistence.Dbx.SqlServer Namespace See Also
Collapse All

Converts a value that comes from a database query to an ecospace value.

C#
public override System.Object ColumnToValue(
    System.Object columnValue
);
Remarks

In many cases, the implementation of this method mainly converts DBNull-values to null, but it can also change the CLR-type of the database value from for example a char[] to a string. or from an integer to a boolean. This is the reverse operation of ValueToParameter.

See Also
StringAsText Class
Eco.Persistence.Dbx.SqlServer Namespace


StringAsText.ColumnType Method

StringAsText.ColumnType Method
StringAsText Class Eco.Persistence.Dbx.SqlServer Namespace See Also
Collapse All

Specifies the SQL type of the column.

C#
public String ColumnType(
    int length
);
See Also
StringAsText Class
Eco.Persistence.Dbx.SqlServer Namespace


StringAsText.DefaultDbValue Method

StringAsText.DefaultDbValue Method
StringAsText Class Eco.Persistence.Dbx.SqlServer Namespace See Also
Collapse All

The return value of this function will be used as default value for new columns when databases are created/evolved.

C#
public String DefaultDbValue(
    string modeledValue,
    SqlDatabaseConfig sqlDatabaseConfig
);
See Also
StringAsText Class
Eco.Persistence.Dbx.SqlServer Namespace


StringAsText.StringToParameter Method

StringAsText.StringToParameter Method
StringAsText Class Eco.Persistence.Dbx.SqlServer Namespace See Also
Collapse All
C#
public void StringToParameter(
    string value,
    IDataParameter parameter
);
Remarks

This is StringToParameter, a member of class StringAsText.

See Also
StringAsText Class
Eco.Persistence.Dbx.SqlServer Namespace


StringAsText.ValueToParameter Method

StringAsText.ValueToParameter Method
StringAsText Class Eco.Persistence.Dbx.SqlServer Namespace See Also
Collapse All

Converts a value that comes from a database query to an ecospace value.

C#
public void ValueToParameter(
    System.Object value,
    IDataParameter parameter
);
Remarks

In many cases, the implementation of this method mainly converts null to DBNull, but it can also handle conversion from for example booleans to integers, byte[] to database blobs. It also has to set the correct parameter types in the IDataParameter-object. This is the reverse operation of ColumnToValue.

See Also
StringAsText Class
Eco.Persistence.Dbx.SqlServer Namespace


StringAsText.ValueType Method

StringAsText.ValueType Method
StringAsText Class Eco.Persistence.Dbx.SqlServer Namespace See Also
Collapse All

This method returns the type of the value that is returned by ColumnToValue.

C#
public System.Type ValueType();
See Also
StringAsText Class
Eco.Persistence.Dbx.SqlServer Namespace


Eco.Persistence.Dbx.Sybase Namespace

Eco.Persistence.Dbx.Sybase Namespace
Classes
Collapse All

This is namespace Eco.Persistence.Dbx.Sybase.

Classes
Name | Description
ByteArrayAsImage | Mapper between a ByteArray value and its persistent representation as IMAGE.
StringAsText | This is class Eco.Persistence.Dbx.Sybase.StringAsText.


ByteArrayAsImage Class

ByteArrayAsImage Class
Inheritance Hierarchy See Also
Collapse All

Mapper between a ByteArray value and its persistent representation as IMAGE.

C#
public sealed class ByteArrayAsImage : AbstractSingleColumnAttribute, ISingleColumnAttributemapping;
Inheritance Hierarchy
Eco.Persistence.ISingleColumnAttributemapping
    Eco.Persistence.Dbx.Sybase.ByteArrayAsImage
File

SybaseAttributeMappersDbx.cs

See Also
Inheritance Hierarchy


ByteArrayAsImage.ColumnToValue Method

ByteArrayAsImage.ColumnToValue Method
ByteArrayAsImage Class Eco.Persistence.Dbx.Sybase Namespace See Also
Collapse All

Converts a value that comes from a database query to an ecospace value.

C#
public override System.Object ColumnToValue(
    System.Object columnValue
);
Remarks

In many cases, the implementation of this method mainly converts DBNull-values to null, but it can also change the CLR-type of the database value from for example a char[] to a string. or from an integer to a boolean. This is the reverse operation of ValueToParameter.

See Also
ByteArrayAsImage Class
Eco.Persistence.Dbx.Sybase Namespace


ByteArrayAsImage.ColumnType Method

ByteArrayAsImage.ColumnType Method
ByteArrayAsImage Class Eco.Persistence.Dbx.Sybase Namespace See Also
Collapse All

Specifies the SQL type of the column.

C#
public String ColumnType(
    int length
);
See Also
ByteArrayAsImage Class
Eco.Persistence.Dbx.Sybase Namespace


ByteArrayAsImage.DefaultDbValue Method

ByteArrayAsImage.DefaultDbValue Method
ByteArrayAsImage Class Eco.Persistence.Dbx.Sybase Namespace See Also
Collapse All

The return value of this function will be used as default value for new columns when databases are created/evolved.

C#
public String DefaultDbValue(
    string modeledValue,
    SqlDatabaseConfig sqlDatabaseConfig
);
See Also
ByteArrayAsImage Class
Eco.Persistence.Dbx.Sybase Namespace


ByteArrayAsImage.IsEqual Method

ByteArrayAsImage.IsEqual Method
ByteArrayAsImage Class Eco.Persistence.Dbx.Sybase Namespace See Also
Collapse All

Returns true if an ecospace value ("value") is equal to a database value ("columnValue").

C#
public override bool IsEqual(
    System.Object value,
    System.Object columnValue
);
Remarks

This method must handle the conversions between ecospace and database values, it must also handle comparing null/DBNull values.

See Also
ByteArrayAsImage Class
Eco.Persistence.Dbx.Sybase Namespace


ByteArrayAsImage.StringToParameter Method

ByteArrayAsImage.StringToParameter Method
ByteArrayAsImage Class Eco.Persistence.Dbx.Sybase Namespace See Also
Collapse All
C#
public void StringToParameter(
    string value,
    IDataParameter parameter
);
Exceptions
Exceptions | Description
InvalidOperationException | Thrown always.
See Also
ByteArrayAsImage Class
Eco.Persistence.Dbx.Sybase Namespace


ByteArrayAsImage.ValueToParameter Method

ByteArrayAsImage.ValueToParameter Method
ByteArrayAsImage Class Eco.Persistence.Dbx.Sybase Namespace See Also
Collapse All

Converts a value that comes from a database query to an ecospace value.

C#
public void ValueToParameter(
    System.Object value,
    IDataParameter parameter
);
Remarks

In many cases, the implementation of this method mainly converts null to DBNull, but it can also handle conversion from for example booleans to integers, byte[] to database blobs. It also has to set the correct parameter types in the IDataParameter-object. This is the reverse operation of ColumnToValue.

See Also
ByteArrayAsImage Class
Eco.Persistence.Dbx.Sybase Namespace


ByteArrayAsImage.ValueType Method

ByteArrayAsImage.ValueType Method
ByteArrayAsImage Class Eco.Persistence.Dbx.Sybase Namespace See Also
Collapse All

This method returns the type of the value that is returned by ColumnToValue.

C#
public System.Type ValueType();
See Also
ByteArrayAsImage Class
Eco.Persistence.Dbx.Sybase Namespace


StringAsText Class

StringAsText Class
Inheritance Hierarchy See Also
Collapse All
C#
public sealed class StringAsText : AbstractSingleColumnAttribute, ISingleColumnAttributemapping;
Remarks

This is class Eco.Persistence.Dbx.Sybase.StringAsText.

Inheritance Hierarchy
Eco.Persistence.ISingleColumnAttributemapping
    Eco.Persistence.Dbx.Sybase.StringAsText
File

SybaseAttributeMappersDbx.cs

See Also
Inheritance Hierarchy


StringAsText.ColumnToValue Method

StringAsText.ColumnToValue Method
StringAsText Class Eco.Persistence.Dbx.Sybase Namespace See Also
Collapse All

Converts a value that comes from a database query to an ecospace value.

C#
public override System.Object ColumnToValue(
    System.Object columnValue
);
Remarks

In many cases, the implementation of this method mainly converts DBNull-values to null, but it can also change the CLR-type of the database value from for example a char[] to a string. or from an integer to a boolean. This is the reverse operation of ValueToParameter.

See Also
StringAsText Class
Eco.Persistence.Dbx.Sybase Namespace


StringAsText.ColumnType Method

StringAsText.ColumnType Method
StringAsText Class Eco.Persistence.Dbx.Sybase Namespace See Also
Collapse All

Specifies the SQL type of the column.

C#
public String ColumnType(
    int length
);
See Also
StringAsText Class
Eco.Persistence.Dbx.Sybase Namespace


StringAsText.DefaultDbValue Method

StringAsText.DefaultDbValue Method
StringAsText Class Eco.Persistence.Dbx.Sybase Namespace See Also
Collapse All

The return value of this function will be used as default value for new columns when databases are created/evolved.

C#
public String DefaultDbValue(
    string modeledValue,
    SqlDatabaseConfig sqlDatabaseConfig
);
See Also
StringAsText Class
Eco.Persistence.Dbx.Sybase Namespace


StringAsText.StringToParameter Method

StringAsText.StringToParameter Method
StringAsText Class Eco.Persistence.Dbx.Sybase Namespace See Also
Collapse All
C#
public void StringToParameter(
    string value,
    IDataParameter parameter
);
Remarks

This is StringToParameter, a member of class StringAsText.

See Also
StringAsText Class
Eco.Persistence.Dbx.Sybase Namespace


StringAsText.ValueToParameter Method

StringAsText.ValueToParameter Method
StringAsText Class Eco.Persistence.Dbx.Sybase Namespace See Also
Collapse All

Converts a value that comes from a database query to an ecospace value.

C#
public void ValueToParameter(
    System.Object value,
    IDataParameter parameter
);
Remarks

In many cases, the implementation of this method mainly converts null to DBNull, but it can also handle conversion from for example booleans to integers, byte[] to database blobs. It also has to set the correct parameter types in the IDataParameter-object. This is the reverse operation of ColumnToValue.

See Also
StringAsText Class
Eco.Persistence.Dbx.Sybase Namespace


StringAsText.ValueType Method

StringAsText.ValueType Method
StringAsText Class Eco.Persistence.Dbx.Sybase Namespace See Also
Collapse All

This method returns the type of the value that is returned by ColumnToValue.

C#
public System.Type ValueType();
See Also
StringAsText Class
Eco.Persistence.Dbx.Sybase Namespace


Eco.Persistence.Default Namespace

Eco.Persistence.Default Namespace
Classes
Collapse All

This is namespace Eco.Persistence.Default.

Classes
Name | Description
AbstractNumericSingleColumnAttribute | Class for mapping numeric values to a single column in a database.
AbstractSingleColumnAttribute | The base class for mapping a class property to a single column in a database.
AbstractStringSingleColumnAttribute | Class for mapping Single values to a single column in a database.
BooleanAsInteger | Class for mapping Boolean values to a single column in a database.
BooleanAsYNChar | Class for mapping Boolean values to a single column in a database.
ByteAsSmallInt | Class for mapping Byte values to a single column in a database.
CharAsChar | Class for mapping Char values to a single column in a database.
CharAsNChar | Class for mapping Char values to a single column in a database.
ColorAsInteger | Stores a Color value as an integer value. Handles string-parsing for Handles default values "00ff80ff", "Black", and "Transparent".
DateTimeAsDateTime | Class for mapping DateTime values to a single column in a database.
DateTimeAsTimeStamp | Class for mapping DateTime values to a single column in a database.
DecimalAsDecimal | Class for mapping Decimal values to a single column in a database.
DoubleAsDouble | Class for mapping Double values to a single column in a database.
GenericAttributeMapper | This is class Eco.Persistence.Default.GenericAttributeMapper.
GenericDateTimeMapper | Base class for mapping Single values to a single column in a database.
GenericEnumAsInteger | Generic mapper for enum types.
GenericEnumAsVarChar | Generic mapper for enum types.
GenericTimeSpanMapper | Abstract class for mapping TimeSpan values to a single column in a database.
GuidAsVarChar32 | Class for mapping Guid values to a single column in a database.
Int16AsSmallint | Class for mapping Int16 values to a single column in a database.
Int32AsInteger | Class for mapping Int32 values to a single column in a database.
Int64AsLongInteger | Class for mapping Int64 values to a single column in a database.
InvalidFieldTypeException | Thrown when an attempt is made to convert a value that is not compatible with the expected target type.
MappingUtils | Provides standard routines for common data conversion operations.
SByteAsSmallInt | Class for mapping SByte values to a single column in a database.
SingleAsSingle | Class for mapping Single values to a single column in a database.
StringAsChar | Class for mapping String values to a single column in a database.
StringAsNChar | Class for mapping String values to a single column in a database.
StringAsNVarChar | Class for mapping String values to a single column in a database.
StringAsVarChar | Class for mapping String values to a single column in a database.
TimeSpanAsDateTime | Class for mapping TimeSpan values to a single column in a database.
TimeSpanAsTimeStamp | Class for mapping TimeSpan values to a single column in a database.
TimeStampAsTwoInt32 | Summary description for Class.
UInt16AsLongInteger | Class for mapping UInt16 values to a single column in a database.
UInt32AsLongInteger | Class for mapping UInt32 values to a single column in a database.
UInt64AsDecimal | Class for mapping UInt64 values to a single column in a database.


AbstractNumericSingleColumnAttribute Class

AbstractNumericSingleColumnAttribute Class
Inheritance Hierarchy See Also
Collapse All

Class for mapping numeric values to a single column in a database.

C#
public abstract class AbstractNumericSingleColumnAttribute : AbstractSingleColumnAttribute;
Inheritance Hierarchy
Eco.Persistence.Default.AbstractSingleColumnAttribute
    Eco.Persistence.Default.AbstractNumericSingleColumnAttribute
        Eco.Persistence.Default.ByteAsSmallInt
        Eco.Persistence.Default.DecimalAsDecimal
        Eco.Persistence.Default.DoubleAsDouble
        Eco.Persistence.Default.GenericEnumAsInteger
        Eco.Persistence.Default.Int16AsSmallint
        Eco.Persistence.Default.Int32AsInteger
        Eco.Persistence.Default.Int64AsLongInteger
        Eco.Persistence.Default.SByteAsSmallInt
        Eco.Persistence.Default.SingleAsSingle
        Eco.Persistence.Default.UInt16AsLongInteger
        Eco.Persistence.Default.UInt32AsLongInteger
        Eco.Persistence.Default.UInt64AsDecimal
File

DefaultAttributeMappers.cs

See Also
Inheritance Hierarchy


AbstractNumericSingleColumnAttribute Methods

AbstractNumericSingleColumnAttribute Methods
Public Methods
Collapse All

The methods of the AbstractNumericSingleColumnAttribute class are listed here.

Public Methods
Name | Description
DefaultDbValue | Given the DefaultDBValue in the model this method will return a string to be used by the database during CREATE TABLE execution.


AbstractNumericSingleColumnAttribute.DefaultDbValue Method

AbstractNumericSingleColumnAttribute.DefaultDbValue Method
AbstractNumericSingleColumnAttribute Class Eco.Persistence.Default Namespace See Also
Collapse All

Given the DefaultDBValue in the model this method will return a string to be used by the database during CREATE TABLE execution.

C#
public virtual String DefaultDbValue(
    string modeledValue,
    SqlDatabaseConfig sqlDatabaseConfig
);
Parameters
Parameters | Description
modeledValue | The value entered in the model.
sqlDatabaseConfig | The configuration settings of the target database.
Returns

A string to be used in the CREATE TABLE SQL statement.

See Also
AbstractNumericSingleColumnAttribute Class
Eco.Persistence.Default Namespace


AbstractSingleColumnAttribute Class

AbstractSingleColumnAttribute Class
Inheritance Hierarchy See Also
Collapse All

The base class for mapping a class property to a single column in a database.

C#
public abstract class AbstractSingleColumnAttribute;
Inheritance Hierarchy
Eco.Persistence.Default.AbstractSingleColumnAttribute
    Eco.Persistence.Default.AbstractNumericSingleColumnAttribute
    Eco.Persistence.Default.AbstractStringSingleColumnAttribute
    Eco.Persistence.Default.BooleanAsInteger
    Eco.Persistence.Default.BooleanAsYNChar
    Eco.Persistence.Default.ColorAsInteger
    Eco.Persistence.Default.GenericAttributeMapper
    Eco.Persistence.Default.GenericDateTimeMapper
    Eco.Persistence.Default.GenericTimeSpanMapper
File

DefaultAttributeMappers.cs

See Also
Inheritance Hierarchy


AbstractSingleColumnAttribute Methods

AbstractSingleColumnAttribute Methods
Protected Methods Public Methods
Collapse All

The methods of the AbstractSingleColumnAttribute class are listed here.

Protected Methods
Name | Description
ConvertFromConverter | Converts the given value to the specified type using a .NET TypeConverter.
EnsureConvertibleType | Returns a TypeConverter that is capable of converting the given value to the specified type.
EnsureType | Ensures that the value is valid for the specified type.
Top
Public Methods
Name | Description
ColumnName | Returns a name that is safe to use with the target database.
ColumnToValue | Converts a value from the database column into the modeled type.
IsEqual | Returns whether or not a value of the modeled type equals the value of the object from/to the database column.


AbstractSingleColumnAttribute.ColumnName Method

AbstractSingleColumnAttribute.ColumnName Method
AbstractSingleColumnAttribute Class Eco.Persistence.Default Namespace See Also
Collapse All

Returns a name that is safe to use with the target database.

C#
public String ColumnName(
    string name
);
Parameters
Parameters | Description
name | The name to check.
Returns

A name that is guaranteed to be safe in the target database.

See Also
AbstractSingleColumnAttribute Class
Eco.Persistence.Default Namespace


AbstractSingleColumnAttribute.ColumnToValue Method

AbstractSingleColumnAttribute.ColumnToValue Method
AbstractSingleColumnAttribute Class Eco.Persistence.Default Namespace See Also
Collapse All

Converts a value from the database column into the modeled type.

C#
public abstract System.Object ColumnToValue(
    System.Object columnValue
);
Parameters
Parameters | Description
columnValue | The value returned from the column in the database.
Returns

The value converted to the modeled type.

See Also
AbstractSingleColumnAttribute Class
Eco.Persistence.Default Namespace


AbstractSingleColumnAttribute.ConvertFromConverter Method

AbstractSingleColumnAttribute.ConvertFromConverter Method
AbstractSingleColumnAttribute Class Eco.Persistence.Default Namespace See Also
Collapse All

Converts the given value to the specified type using a .NET TypeConverter.

C#
protected object ConvertFromConverter(
    object value,
    Type type
);
Parameters
Parameters | Description
value | The value to should be converted.
type | The target type to convert to.
Returns

An object converted to the specified type.

Exceptions
Exceptions | Description
InvalidFieldTypeException | Thrown if the value is not null and not the type of t.
See Also
AbstractSingleColumnAttribute Class
Eco.Persistence.Default Namespace


AbstractSingleColumnAttribute.EnsureConvertibleType Method

AbstractSingleColumnAttribute.EnsureConvertibleType Method
AbstractSingleColumnAttribute Class Eco.Persistence.Default Namespace See Also
Collapse All

Returns a TypeConverter that is capable of converting the given value to the specified type.

C#
protected TypeConverter EnsureConvertibleType(
    object value,
    Type t
);
Parameters
Parameters | Description
value | The value that should be converted.
t | The target type to convert to.
Exceptions
Exceptions | Description
InvalidFieldTypeException | Thrown if the value is not null and not the type of t.
See Also
AbstractSingleColumnAttribute Class
Eco.Persistence.Default Namespace


AbstractSingleColumnAttribute.EnsureType Method

AbstractSingleColumnAttribute.EnsureType Method
AbstractSingleColumnAttribute Class Eco.Persistence.Default Namespace See Also
Collapse All

Ensures that the value is valid for the specified type.

C#
protected void EnsureType(
    object value,
    Type t
);
Parameters
Parameters | Description
value | The value to check for compatibility.
t | The .NET type to check for compatibility.
Exceptions
Exceptions | Description
InvalidFieldTypeException | Thrown if the value is not null and not the type of t.
See Also
AbstractSingleColumnAttribute Class
Eco.Persistence.Default Namespace


AbstractSingleColumnAttribute.IsEqual Method

AbstractSingleColumnAttribute.IsEqual Method
AbstractSingleColumnAttribute Class Eco.Persistence.Default Namespace See Also
Collapse All

Returns whether or not a value of the modeled type equals the value of the object from/to the database column.

C#
public virtual bool IsEqual(
    System.Object value,
    System.Object columnValue
);
Parameters
Parameters | Description
value | The value of the class’s property.
columnValue | The value of the database column.
Returns

True if they are equal, otherwise false.

See Also
AbstractSingleColumnAttribute Class
Eco.Persistence.Default Namespace


AbstractStringSingleColumnAttribute Class

AbstractStringSingleColumnAttribute Class
Inheritance Hierarchy See Also
Collapse All

Class for mapping Single values to a single column in a database.

C#
public abstract class AbstractStringSingleColumnAttribute : AbstractSingleColumnAttribute;
Inheritance Hierarchy
Eco.Persistence.Default.AbstractSingleColumnAttribute
    Eco.Persistence.Default.AbstractStringSingleColumnAttribute
        Eco.Persistence.Default.CharAsChar
        Eco.Persistence.Default.CharAsNChar
        Eco.Persistence.Default.GenericEnumAsVarChar
        Eco.Persistence.Default.GuidAsVarChar32
        Eco.Persistence.Default.StringAsChar
        Eco.Persistence.Default.StringAsNChar
        Eco.Persistence.Default.StringAsNVarChar
        Eco.Persistence.Default.StringAsVarChar
File

DefaultAttributeMappers.cs

See Also
Inheritance Hierarchy


AbstractStringSingleColumnAttribute Methods

AbstractStringSingleColumnAttribute Methods
Public Methods
Collapse All

The methods of the AbstractStringSingleColumnAttribute class are listed here.

Public Methods
Name | Description
DefaultDbValue | Given the DefaultDBValue in the model this method will return a string to be used by the database during CREATE TABLE execution.


AbstractStringSingleColumnAttribute.DefaultDbValue Method

AbstractStringSingleColumnAttribute.DefaultDbValue Method
AbstractStringSingleColumnAttribute Class Eco.Persistence.Default Namespace See Also
Collapse All

Given the DefaultDBValue in the model this method will return a string to be used by the database during CREATE TABLE execution.

C#
public String DefaultDbValue(
    string modeledValue,
    SqlDatabaseConfig sqlDatabaseConfig
);
Parameters
Parameters | Description
modeledValue | The value entered in the model.
sqlDatabaseConfig | The configuration settings of the target database.
Returns

A string to be used in the CREATE TABLE SQL statement.

See Also
AbstractStringSingleColumnAttribute Class
Eco.Persistence.Default Namespace


BooleanAsInteger Class

BooleanAsInteger Class
Inheritance Hierarchy See Also
Collapse All

Class for mapping Boolean values to a single column in a database.

C#
public sealed class BooleanAsInteger : AbstractSingleColumnAttribute, ISingleColumnAttributemapping, INonBooleanBooleanMapping;
Inheritance Hierarchy
Eco.Persistence.Default.AbstractSingleColumnAttribute
Eco.Persistence.INonBooleanBooleanMapping
Eco.Persistence.ISingleColumnAttributemapping
    Eco.Persistence.Default.BooleanAsInteger
File

DefaultAttributeMappers.cs

See Also
Inheritance Hierarchy


BooleanAsInteger Methods

BooleanAsInteger Methods
Public Methods
Collapse All

The methods of the BooleanAsInteger class are listed here.

Public Methods
Name | Description
ColumnToValue | Converts a value from the database column into the modeled type.
ColumnType | Returns the SQL type used by the database during CREATE TABLE execution.
DefaultDbValue | Given the DefaultDBValue in the model this method will return a string to be used by the database during CREATE TABLE execution.
StringToParameter | Converts a string to the correct data type and then inserts the given value into the IDataParameter.
ValueToParameter | Inserts the given value into the IDataParameter.
ValueType | Returns the .NET type of the column.


BooleanAsInteger.ColumnToValue Method

BooleanAsInteger.ColumnToValue Method
BooleanAsInteger Class Eco.Persistence.Default Namespace See Also
Collapse All

Converts a value from the database column into the modeled type.

C#
public override System.Object ColumnToValue(
    System.Object columnValue
);
Parameters
Parameters | Description
columnValue | The value returned from the column in the database.
Returns

The value converted to the modeled type.

See Also
BooleanAsInteger Class
Eco.Persistence.Default Namespace


BooleanAsInteger.ColumnType Method

BooleanAsInteger.ColumnType Method
BooleanAsInteger Class Eco.Persistence.Default Namespace See Also
Collapse All

Returns the SQL type used by the database during CREATE TABLE execution.

C#
public String ColumnType(
    int length
);
Parameters
Parameters | Description
length | This parameter is ignored.
See Also
BooleanAsInteger Class
Eco.Persistence.Default Namespace


BooleanAsInteger.DefaultDbValue Method

BooleanAsInteger.DefaultDbValue Method
BooleanAsInteger Class Eco.Persistence.Default Namespace See Also
Collapse All

Given the DefaultDBValue in the model this method will return a string to be used by the database during CREATE TABLE execution.

C#
public String DefaultDbValue(
    string modeledValue,
    SqlDatabaseConfig sqlDatabaseConfig
);
Parameters
Parameters | Description
modeledValue | The value entered in the model.
sqlDatabaseConfig | The configuration settings of the target database.
Returns

A string to be used in the CREATE TABLE SQL statement.

See Also
BooleanAsInteger Class
Eco.Persistence.Default Namespace


BooleanAsInteger.StringToParameter Method

BooleanAsInteger.StringToParameter Method
BooleanAsInteger Class Eco.Persistence.Default Namespace See Also
Collapse All

Converts a string to the correct data type and then inserts the given value into the IDataParameter.

C#
public void StringToParameter(
    string value,
    IDataParameter parameter
);
Parameters
Parameters | Description
value | The value to use.
parameter | The IDataParameter to update.
See Also
BooleanAsInteger Class
Eco.Persistence.Default Namespace


BooleanAsInteger.ValueToParameter Method

BooleanAsInteger.ValueToParameter Method
BooleanAsInteger Class Eco.Persistence.Default Namespace See Also
Collapse All

Inserts the given value into the IDataParameter.

C#
public void ValueToParameter(
    System.Object value,
    IDataParameter parameter
);
Parameters
Parameters | Description
value | The value to use.
parameter | The IDataParameter to update.
See Also
BooleanAsInteger Class
Eco.Persistence.Default Namespace


BooleanAsInteger.ValueType Method

BooleanAsInteger.ValueType Method
BooleanAsInteger Class Eco.Persistence.Default Namespace See Also
Collapse All

Returns the .NET type of the column.

C#
public System.Type ValueType();
See Also
BooleanAsInteger Class
Eco.Persistence.Default Namespace


BooleanAsInteger Properties

BooleanAsInteger Properties
Public Properties
Collapse All

The properties of the BooleanAsInteger class are listed here.

Public Properties
Name | Description
TrueString | Returns the string representation for the "true" value.


BooleanAsInteger.TrueString Property

BooleanAsInteger.TrueString Property
BooleanAsInteger Class Eco.Persistence.Default Namespace See Also
Collapse All

Returns the string representation for the "true" value.

C#
public string TrueString;
Remarks

This could be for example "true", "1", "y" depending on how the value "true" is stored.

See Also
BooleanAsInteger Class
Eco.Persistence.Default Namespace


BooleanAsYNChar Class

BooleanAsYNChar Class
Inheritance Hierarchy See Also
Collapse All

Class for mapping Boolean values to a single column in a database.

C#
public sealed class BooleanAsYNChar : AbstractSingleColumnAttribute, ISingleColumnAttributemapping, INonBooleanBooleanMapping;
Inheritance Hierarchy
Eco.Persistence.Default.AbstractSingleColumnAttribute
Eco.Persistence.INonBooleanBooleanMapping
Eco.Persistence.ISingleColumnAttributemapping
    Eco.Persistence.Default.BooleanAsYNChar
File

DefaultAttributeMappers.cs

See Also
Inheritance Hierarchy


BooleanAsYNChar Methods

BooleanAsYNChar Methods
Public Methods
Collapse All

The methods of the BooleanAsYNChar class are listed here.

Public Methods
Name | Description
ColumnToValue | Converts a value from the database column into the modeled type.
ColumnType | Returns the SQL type used by the database during CREATE TABLE execution.
DefaultDbValue | Given the DefaultDBValue in the model this method will return a string to be used by the database during CREATE TABLE execution.
StringToParameter | Converts a string to the correct data type and then inserts the given value into the IDataParameter.
ValueToParameter | Inserts the given value into the IDataParameter.
ValueType | Returns the .NET type of the column.


BooleanAsYNChar.ColumnToValue Method

BooleanAsYNChar.ColumnToValue Method
BooleanAsYNChar Class Eco.Persistence.Default Namespace See Also
Collapse All

Converts a value from the database column into the modeled type.

C#
public override System.Object ColumnToValue(
    System.Object columnValue
);
Parameters
Parameters | Description
columnValue | The value returned from the column in the database.
Returns

The value converted to the modeled type.

See Also
BooleanAsYNChar Class
Eco.Persistence.Default Namespace


BooleanAsYNChar.ColumnType Method

BooleanAsYNChar.ColumnType Method
BooleanAsYNChar Class Eco.Persistence.Default Namespace See Also
Collapse All

Returns the SQL type used by the database during CREATE TABLE execution.

C#
public String ColumnType(
    int length
);
Parameters
Parameters | Description
length | This parameter is ignored.
See Also
BooleanAsYNChar Class
Eco.Persistence.Default Namespace


BooleanAsYNChar.DefaultDbValue Method

BooleanAsYNChar.DefaultDbValue Method
BooleanAsYNChar Class Eco.Persistence.Default Namespace See Also
Collapse All

Given the DefaultDBValue in the model this method will return a string to be used by the database during CREATE TABLE execution.

C#
public String DefaultDbValue(
    string modeledValue,
    SqlDatabaseConfig sqlDatabaseConfig
);
Parameters
Parameters | Description
modeledValue | The value entered in the model.
sqlDatabaseConfig | The configuration settings of the target database.
Returns

A string to be used in the CREATE TABLE SQL statement.

See Also
BooleanAsYNChar Class
Eco.Persistence.Default Namespace


BooleanAsYNChar.StringToParameter Method

BooleanAsYNChar.StringToParameter Method
BooleanAsYNChar Class Eco.Persistence.Default Namespace See Also
Collapse All

Converts a string to the correct data type and then inserts the given value into the IDataParameter.

C#
public void StringToParameter(
    string value,
    IDataParameter parameter
);
Parameters
Parameters | Description
value | The value to use.
parameter | The IDataParameter to update.
See Also
BooleanAsYNChar Class
Eco.Persistence.Default Namespace


BooleanAsYNChar.ValueToParameter Method

BooleanAsYNChar.ValueToParameter Method
BooleanAsYNChar Class Eco.Persistence.Default Namespace See Also
Collapse All

Inserts the given value into the IDataParameter.

C#
public void ValueToParameter(
    System.Object value,
    IDataParameter parameter
);
Parameters
Parameters | Description
value | The value to use.
parameter | The IDataParameter to update.
See Also
BooleanAsYNChar Class
Eco.Persistence.Default Namespace


BooleanAsYNChar.ValueType Method

BooleanAsYNChar.ValueType Method
BooleanAsYNChar Class Eco.Persistence.Default Namespace See Also
Collapse All

Returns the .NET type of the column.

C#
public System.Type ValueType();
See Also
BooleanAsYNChar Class
Eco.Persistence.Default Namespace


BooleanAsYNChar Properties

BooleanAsYNChar Properties
Public Properties
Collapse All

The properties of the BooleanAsYNChar class are listed here.

Public Properties
Name | Description
TrueString | Returns the string representation for the "true" value.


BooleanAsYNChar.TrueString Property

BooleanAsYNChar.TrueString Property
BooleanAsYNChar Class Eco.Persistence.Default Namespace See Also
Collapse All

Returns the string representation for the "true" value.

C#
public string TrueString;
Remarks

This could be for example "true", "1", "y" depending on how the value "true" is stored.

See Also
BooleanAsYNChar Class
Eco.Persistence.Default Namespace


ByteAsSmallInt Class

ByteAsSmallInt Class
Inheritance Hierarchy See Also
Collapse All

Class for mapping Byte values to a single column in a database.

C#
public sealed class ByteAsSmallInt : AbstractNumericSingleColumnAttribute, ISingleColumnAttributemapping;
Inheritance Hierarchy
Eco.Persistence.Default.AbstractSingleColumnAttribute
    Eco.Persistence.Default.AbstractNumericSingleColumnAttribute
    Eco.Persistence.ISingleColumnAttributemapping
        Eco.Persistence.Default.ByteAsSmallInt
File

DefaultAttributeMappers.cs

See Also
Inheritance Hierarchy


ByteAsSmallInt Methods

ByteAsSmallInt Methods
Public Methods
Collapse All

The methods of the ByteAsSmallInt class are listed here.

Public Methods
Name | Description
ColumnToValue | Converts a value from the database column into the modeled type.
ColumnType | Returns the SQL type used by the database during CREATE TABLE execution.
StringToParameter | Converts a string to the correct data type and then inserts the given value into the IDataParameter.
ValueToParameter | Inserts the given value into the IDataParameter.
ValueType | Returns the .NET type of the column.


ByteAsSmallInt.ColumnToValue Method

ByteAsSmallInt.ColumnToValue Method
ByteAsSmallInt Class Eco.Persistence.Default Namespace See Also
Collapse All

Converts a value from the database column into the modeled type.

C#
public override System.Object ColumnToValue(
    System.Object columnValue
);
Parameters
Parameters | Description
columnValue | The value returned from the column in the database.
Returns

The value converted to the modeled type.

See Also
ByteAsSmallInt Class
Eco.Persistence.Default Namespace


ByteAsSmallInt.ColumnType Method

ByteAsSmallInt.ColumnType Method
ByteAsSmallInt Class Eco.Persistence.Default Namespace See Also
Collapse All

Returns the SQL type used by the database during CREATE TABLE execution.

C#
public String ColumnType(
    int length
);
Parameters
Parameters | Description
length | This parameter is ignored.
See Also
ByteAsSmallInt Class
Eco.Persistence.Default Namespace


ByteAsSmallInt.StringToParameter Method

ByteAsSmallInt.StringToParameter Method
ByteAsSmallInt Class Eco.Persistence.Default Namespace See Also
Collapse All

Converts a string to the correct data type and then inserts the given value into the IDataParameter.

C#
public void StringToParameter(
    string value,
    IDataParameter parameter
);
Parameters
Parameters | Description
value | The value to use.
parameter | The IDataParameter to update.
See Also
ByteAsSmallInt Class
Eco.Persistence.Default Namespace


ByteAsSmallInt.ValueToParameter Method

ByteAsSmallInt.ValueToParameter Method
ByteAsSmallInt Class Eco.Persistence.Default Namespace See Also
Collapse All

Inserts the given value into the IDataParameter.

C#
public void ValueToParameter(
    System.Object value,
    IDataParameter parameter
);
Parameters
Parameters | Description
value | The value to use.
parameter | The IDataParameter to update.
See Also
ByteAsSmallInt Class
Eco.Persistence.Default Namespace


ByteAsSmallInt.ValueType Method

ByteAsSmallInt.ValueType Method
ByteAsSmallInt Class Eco.Persistence.Default Namespace See Also
Collapse All

Returns the .NET type of the column.

C#
public System.Type ValueType();
See Also
ByteAsSmallInt Class
Eco.Persistence.Default Namespace


CharAsChar Class

CharAsChar Class
Inheritance Hierarchy See Also
Collapse All

Class for mapping Char values to a single column in a database.

C#
public sealed class CharAsChar : AbstractStringSingleColumnAttribute, ISingleColumnAttributemapping, IDefaultReverseMapping;
Inheritance Hierarchy
Eco.Persistence.Default.AbstractSingleColumnAttribute
    Eco.Persistence.Default.AbstractStringSingleColumnAttribute
    Eco.Persistence.IDefaultReverseMapping
    Eco.Persistence.ISingleColumnAttributemapping
        Eco.Persistence.Default.CharAsChar
File

DefaultAttributeMappers.cs

See Also
Inheritance Hierarchy


CharAsChar Methods

CharAsChar Methods
Public Methods
Collapse All

The methods of the CharAsChar class are listed here.

Public Methods
Name | Description
ColumnToValue | Converts a value from the database column into the modeled type.
ColumnType | Returns the SQL type used by the database during CREATE TABLE execution.
StringToParameter | Converts a string to the correct data type and then inserts the given value into the IDataParameter.
ValueToParameter | Inserts the given value into the IDataParameter.
ValueType | Returns the .NET type of the column.


CharAsChar.ColumnToValue Method

CharAsChar.ColumnToValue Method
CharAsChar Class Eco.Persistence.Default Namespace See Also
Collapse All

Converts a value from the database column into the modeled type.

C#
public override System.Object ColumnToValue(
    System.Object columnValue
);
Parameters
Parameters | Description
columnValue | The value returned from the column in the database.
Returns

The value converted to the modeled type.

See Also
CharAsChar Class
Eco.Persistence.Default Namespace


CharAsChar.ColumnType Method

CharAsChar.ColumnType Method
CharAsChar Class Eco.Persistence.Default Namespace See Also
Collapse All

Returns the SQL type used by the database during CREATE TABLE execution.

C#
public String ColumnType(
    int length
);
Parameters
Parameters | Description
length | This parameter is ignored
See Also
CharAsChar Class
Eco.Persistence.Default Namespace


CharAsChar.StringToParameter Method

CharAsChar.StringToParameter Method
CharAsChar Class Eco.Persistence.Default Namespace See Also
Collapse All

Converts a string to the correct data type and then inserts the given value into the IDataParameter.

C#
public void StringToParameter(
    string value,
    IDataParameter parameter
);
Parameters
Parameters | Description
value | The value to use.
parameter | The IDataParameter to update.
See Also
CharAsChar Class
Eco.Persistence.Default Namespace


CharAsChar.ValueToParameter Method

CharAsChar.ValueToParameter Method
CharAsChar Class Eco.Persistence.Default Namespace See Also
Collapse All

Inserts the given value into the IDataParameter.

C#
public void ValueToParameter(
    System.Object value,
    IDataParameter parameter
);
Parameters
Parameters | Description
value | The value to use.
parameter | The IDataParameter to update.
See Also
CharAsChar Class
Eco.Persistence.Default Namespace


CharAsChar.ValueType Method

CharAsChar.ValueType Method
CharAsChar Class Eco.Persistence.Default Namespace See Also
Collapse All

Returns the .NET type of the column.

C#
public System.Type ValueType();
See Also
CharAsChar Class
Eco.Persistence.Default Namespace


CharAsNChar Class

CharAsNChar Class
Inheritance Hierarchy See Also
Collapse All

Class for mapping Char values to a single column in a database.

C#
public sealed class CharAsNChar : AbstractStringSingleColumnAttribute, ISingleColumnAttributemapping, IDefaultReverseMapping;
Inheritance Hierarchy
Eco.Persistence.Default.AbstractSingleColumnAttribute
    Eco.Persistence.Default.AbstractStringSingleColumnAttribute
    Eco.Persistence.IDefaultReverseMapping
    Eco.Persistence.ISingleColumnAttributemapping
        Eco.Persistence.Default.CharAsNChar
File

DefaultAttributeMappers.cs

See Also
Inheritance Hierarchy


CharAsNChar Methods

CharAsNChar Methods
Public Methods
Collapse All

The methods of the CharAsNChar class are listed here.

Public Methods
Name | Description
ColumnToValue | Converts a value from the database column into the modeled type.
ColumnType | Returns the SQL type used by the database during CREATE TABLE execution.
StringToParameter | Converts a string to the correct data type and then inserts the given value into the IDataParameter.
ValueToParameter | Inserts the given value into the IDataParameter.
ValueType | Returns the .NET type of the column.


CharAsNChar.ColumnToValue Method

CharAsNChar.ColumnToValue Method
CharAsNChar Class Eco.Persistence.Default Namespace See Also
Collapse All

Converts a value from the database column into the modeled type.

C#
public override System.Object ColumnToValue(
    System.Object columnValue
);
Parameters
Parameters | Description
columnValue | The value returned from the column in the database.
Returns

The value converted to the modeled type.

See Also
CharAsNChar Class
Eco.Persistence.Default Namespace


CharAsNChar.ColumnType Method

CharAsNChar.ColumnType Method
CharAsNChar Class Eco.Persistence.Default Namespace See Also
Collapse All

Returns the SQL type used by the database during CREATE TABLE execution.

C#
public string ColumnType(
    int length
);
Parameters
Parameters | Description
length | This parameter is ignored
See Also
CharAsNChar Class
Eco.Persistence.Default Namespace


CharAsNChar.StringToParameter Method

CharAsNChar.StringToParameter Method
CharAsNChar Class Eco.Persistence.Default Namespace See Also
Collapse All

Converts a string to the correct data type and then inserts the given value into the IDataParameter.

C#
public void StringToParameter(
    string value,
    IDataParameter parameter
);
Parameters
Parameters | Description
value | The value to use.
parameter | The IDataParameter to update.
See Also
CharAsNChar Class
Eco.Persistence.Default Namespace


CharAsNChar.ValueToParameter Method

CharAsNChar.ValueToParameter Method
CharAsNChar Class Eco.Persistence.Default Namespace See Also
Collapse All

Inserts the given value into the IDataParameter.

C#
public void ValueToParameter(
    System.Object value,
    IDataParameter parameter
);
Parameters
Parameters | Description
value | The value to use.
parameter | The IDataParameter to update.
See Also
CharAsNChar Class
Eco.Persistence.Default Namespace


CharAsNChar.ValueType Method

CharAsNChar.ValueType Method
CharAsNChar Class Eco.Persistence.Default Namespace See Also
Collapse All

Returns the .NET type of the column.

C#
public System.Type ValueType();
See Also
CharAsNChar Class
Eco.Persistence.Default Namespace


ColorAsInteger Class

ColorAsInteger Class
Inheritance Hierarchy See Also
Collapse All

Stores a Color value as an integer value. Handles string-parsing for Handles default values "00ff80ff", "Black", and "Transparent".

C#
public sealed class ColorAsInteger : AbstractSingleColumnAttribute, ISingleColumnAttributemapping;
Inheritance Hierarchy
Eco.Persistence.Default.AbstractSingleColumnAttribute
Eco.Persistence.ISingleColumnAttributemapping
    Eco.Persistence.Default.ColorAsInteger
File

ColorAsIntMapper.cs

See Also
Inheritance Hierarchy


ColorAsInteger Methods

ColorAsInteger Methods
Public Methods
Collapse All

The methods of the ColorAsInteger class are listed here.

Public Methods
Name | Description
ColumnToValue | This is ColumnToValue, a member of class ColorAsInteger.
ColumnType | Specifies the SQL type of the column.
DefaultDbValue | This is DefaultDbValue, a member of class ColorAsInteger.
StringToParameter | This is StringToParameter, a member of class ColorAsInteger.
ValueToParameter | This is ValueToParameter, a member of class ColorAsInteger.
ValueType | This method returns the type of the value that is returned by ColumnToValue.


ColorAsInteger.ColumnToValue Method

ColorAsInteger.ColumnToValue Method
ColorAsInteger Class Eco.Persistence.Default Namespace See Also
Collapse All
C#
public override object ColumnToValue(
    object columnValue
);
Remarks

This is ColumnToValue, a member of class ColorAsInteger.

See Also
ColorAsInteger Class
Eco.Persistence.Default Namespace


ColorAsInteger.ColumnType Method

ColorAsInteger.ColumnType Method
ColorAsInteger Class Eco.Persistence.Default Namespace See Also
Collapse All

Specifies the SQL type of the column.

C#
public string ColumnType(
    int length
);
See Also
ColorAsInteger Class
Eco.Persistence.Default Namespace


ColorAsInteger.DefaultDbValue Method

ColorAsInteger.DefaultDbValue Method
ColorAsInteger Class Eco.Persistence.Default Namespace See Also
Collapse All
C#
public string DefaultDbValue(
    string modeledValue,
    global::Eco.Persistence.Configuration.SqlDatabaseConfig sqlDatabaseConfig
);
Remarks

This is DefaultDbValue, a member of class ColorAsInteger.

See Also
ColorAsInteger Class
Eco.Persistence.Default Namespace


ColorAsInteger.StringToParameter Method

ColorAsInteger.StringToParameter Method
ColorAsInteger Class Eco.Persistence.Default Namespace See Also
Collapse All
C#
public void StringToParameter(
    string value,
    System.Data.IDataParameter parameter
);
Remarks

This is StringToParameter, a member of class ColorAsInteger.

See Also
ColorAsInteger Class
Eco.Persistence.Default Namespace


ColorAsInteger.ValueToParameter Method

ColorAsInteger.ValueToParameter Method
ColorAsInteger Class Eco.Persistence.Default Namespace See Also
Collapse All
C#
public void ValueToParameter(
    object value,
    System.Data.IDataParameter parameter
);
Remarks

This is ValueToParameter, a member of class ColorAsInteger.

See Also
ColorAsInteger Class
Eco.Persistence.Default Namespace


ColorAsInteger.ValueType Method

ColorAsInteger.ValueType Method
ColorAsInteger Class Eco.Persistence.Default Namespace See Also
Collapse All

This method returns the type of the value that is returned by ColumnToValue.

C#
public Type ValueType();
See Also
ColorAsInteger Class
Eco.Persistence.Default Namespace


DateTimeAsDateTime Class

DateTimeAsDateTime Class
Inheritance Hierarchy See Also
Collapse All

Class for mapping DateTime values to a single column in a database.

C#
public class DateTimeAsDateTime : GenericDateTimeMapper, IDefaultReverseMapping;
Inheritance Hierarchy
Eco.Persistence.Default.AbstractSingleColumnAttribute
Eco.Persistence.ISingleColumnAttributemapping
    Eco.Persistence.Default.GenericDateTimeMapper
    Eco.Persistence.IDefaultReverseMapping
        Eco.Persistence.Default.DateTimeAsDateTime
File

DefaultAttributeMappers.cs

See Also
Inheritance Hierarchy


DateTimeAsDateTime Methods

DateTimeAsDateTime Methods
Public Methods
Collapse All

The methods of the DateTimeAsDateTime class are listed here.

Public Methods
Name | Description
ColumnType | Returns the SQL type used by the database during CREATE TABLE execution.


DateTimeAsDateTime.ColumnType Method

DateTimeAsDateTime.ColumnType Method
DateTimeAsDateTime Class Eco.Persistence.Default Namespace See Also
Collapse All

Returns the SQL type used by the database during CREATE TABLE execution.

C#
public override String ColumnType(
    int length
);
Parameters
Parameters | Description
length | This parameter is ignored.
See Also
DateTimeAsDateTime Class
Eco.Persistence.Default Namespace


DateTimeAsTimeStamp Class

DateTimeAsTimeStamp Class
Inheritance Hierarchy See Also
Collapse All

Class for mapping DateTime values to a single column in a database.

C#
public class DateTimeAsTimeStamp : GenericDateTimeMapper, IDefaultReverseMapping;
Inheritance Hierarchy
Eco.Persistence.Default.AbstractSingleColumnAttribute
Eco.Persistence.ISingleColumnAttributemapping
    Eco.Persistence.Default.GenericDateTimeMapper
    Eco.Persistence.IDefaultReverseMapping
        Eco.Persistence.Default.DateTimeAsTimeStamp
File

DefaultAttributeMappers.cs

See Also
Inheritance Hierarchy


DateTimeAsTimeStamp Methods

DateTimeAsTimeStamp Methods
Public Methods
Collapse All

The methods of the DateTimeAsTimeStamp class are listed here.

Public Methods
Name | Description
ColumnType | Returns the SQL type used by the database during CREATE TABLE execution.


DateTimeAsTimeStamp.ColumnType Method

DateTimeAsTimeStamp.ColumnType Method
DateTimeAsTimeStamp Class Eco.Persistence.Default Namespace See Also
Collapse All

Returns the SQL type used by the database during CREATE TABLE execution.

C#
public override String ColumnType(
    int length
);
Parameters
Parameters | Description
length | This parameter is ignored.
See Also
DateTimeAsTimeStamp Class
Eco.Persistence.Default Namespace


DecimalAsDecimal Class

DecimalAsDecimal Class
Inheritance Hierarchy See Also
Collapse All

Class for mapping Decimal values to a single column in a database.

C#
public sealed class DecimalAsDecimal : AbstractNumericSingleColumnAttribute, ISingleColumnAttributemapping, IDefaultReverseMapping;
Inheritance Hierarchy
Eco.Persistence.Default.AbstractSingleColumnAttribute
    Eco.Persistence.Default.AbstractNumericSingleColumnAttribute
    Eco.Persistence.IDefaultReverseMapping
    Eco.Persistence.ISingleColumnAttributemapping
        Eco.Persistence.Default.DecimalAsDecimal
File

DefaultAttributeMappers.cs

See Also
Inheritance Hierarchy


DecimalAsDecimal Methods

DecimalAsDecimal Methods
Public Methods
Collapse All

The methods of the DecimalAsDecimal class are listed here.

Public Methods
Name | Description
ColumnToValue | Converts a value from the database column into the modeled type.
ColumnType | Returns the SQL type used by the database during CREATE TABLE execution.
StringToParameter | Converts a string to the correct data type and then inserts the given value into the IDataParameter.
ValueToParameter | Inserts the given value into the IDataParameter.
ValueType | Returns the .NET type of the column.


DecimalAsDecimal.ColumnToValue Method

DecimalAsDecimal.ColumnToValue Method
DecimalAsDecimal Class Eco.Persistence.Default Namespace See Also
Collapse All

Converts a value from the database column into the modeled type.

C#
public override System.Object ColumnToValue(
    System.Object columnValue
);
Parameters
Parameters | Description
columnValue | The value returned from the column in the database.
Returns

The value converted to the modeled type.

See Also
DecimalAsDecimal Class
Eco.Persistence.Default Namespace


DecimalAsDecimal.ColumnType Method

DecimalAsDecimal.ColumnType Method
DecimalAsDecimal Class Eco.Persistence.Default Namespace See Also
Collapse All

Returns the SQL type used by the database during CREATE TABLE execution.

C#
public String ColumnType(
    int length
);
Parameters
Parameters | Description
length | Specifies the precision of the column, the decimal is always 2.
See Also
DecimalAsDecimal Class
Eco.Persistence.Default Namespace


DecimalAsDecimal.StringToParameter Method

DecimalAsDecimal.StringToParameter Method
DecimalAsDecimal Class Eco.Persistence.Default Namespace See Also
Collapse All

Converts a string to the correct data type and then inserts the given value into the IDataParameter.

C#
public void StringToParameter(
    string value,
    IDataParameter parameter
);
Parameters
Parameters | Description
value | The value to use.
parameter | The IDataParameter to update.
See Also
DecimalAsDecimal Class
Eco.Persistence.Default Namespace


DecimalAsDecimal.ValueToParameter Method

DecimalAsDecimal.ValueToParameter Method
DecimalAsDecimal Class Eco.Persistence.Default Namespace See Also
Collapse All

Inserts the given value into the IDataParameter.

C#
public void ValueToParameter(
    System.Object value,
    IDataParameter parameter
);
Parameters
Parameters | Description
value | The value to use.
parameter | The IDataParameter to update.
See Also
DecimalAsDecimal Class
Eco.Persistence.Default Namespace


DecimalAsDecimal.ValueType Method

DecimalAsDecimal.ValueType Method
DecimalAsDecimal Class Eco.Persistence.Default Namespace See Also
Collapse All

Returns the .NET type of the column.

C#
public System.Type ValueType();
See Also
DecimalAsDecimal Class
Eco.Persistence.Default Namespace


DoubleAsDouble Class

DoubleAsDouble Class
Inheritance Hierarchy See Also
Collapse All

Class for mapping Double values to a single column in a database.

C#
public sealed class DoubleAsDouble : AbstractNumericSingleColumnAttribute, ISingleColumnAttributemapping, IDefaultReverseMapping;
Inheritance Hierarchy
Eco.Persistence.Default.AbstractSingleColumnAttribute
    Eco.Persistence.Default.AbstractNumericSingleColumnAttribute
    Eco.Persistence.IDefaultReverseMapping
    Eco.Persistence.ISingleColumnAttributemapping
        Eco.Persistence.Default.DoubleAsDouble
File

DefaultAttributeMappers.cs

See Also
Inheritance Hierarchy


DoubleAsDouble Methods

DoubleAsDouble Methods
Public Methods
Collapse All

The methods of the DoubleAsDouble class are listed here.

Public Methods
Name | Description
ColumnToValue | Converts a value from the database column into the modeled type.
ColumnType | Returns the SQL type used by the database during CREATE TABLE execution.
StringToParameter | Converts a string to the correct data type and then inserts the given value into the IDataParameter.
ValueToParameter | Inserts the given value into the IDataParameter.
ValueType | Returns the .NET type of the column.


DoubleAsDouble.ColumnToValue Method

DoubleAsDouble.ColumnToValue Method
DoubleAsDouble Class Eco.Persistence.Default Namespace See Also
Collapse All

Converts a value from the database column into the modeled type.

C#
public override System.Object ColumnToValue(
    System.Object columnValue
);
Parameters
Parameters | Description
columnValue | The value returned from the column in the database.
Returns

The value converted to the modeled type.

See Also
DoubleAsDouble Class
Eco.Persistence.Default Namespace


DoubleAsDouble.ColumnType Method

DoubleAsDouble.ColumnType Method
DoubleAsDouble Class Eco.Persistence.Default Namespace See Also
Collapse All

Returns the SQL type used by the database during CREATE TABLE execution.

C#
public String ColumnType(
    int length
);
Parameters
Parameters | Description
length | This parameter is ignored.
See Also
DoubleAsDouble Class
Eco.Persistence.Default Namespace


DoubleAsDouble.StringToParameter Method

DoubleAsDouble.StringToParameter Method
DoubleAsDouble Class Eco.Persistence.Default Namespace See Also
Collapse All

Converts a string to the correct data type and then inserts the given value into the IDataParameter.

C#
public void StringToParameter(
    string value,
    IDataParameter parameter
);
Parameters
Parameters | Description
value | The value to use.
parameter | The IDataParameter to update.
See Also
DoubleAsDouble Class
Eco.Persistence.Default Namespace


DoubleAsDouble.ValueToParameter Method

DoubleAsDouble.ValueToParameter Method
DoubleAsDouble Class Eco.Persistence.Default Namespace See Also
Collapse All

Inserts the given value into the IDataParameter.

C#
public void ValueToParameter(
    System.Object value,
    IDataParameter parameter
);
Parameters
Parameters | Description
value | The value to use.
parameter | The IDataParameter to update.
Exceptions
Exceptions | Description
ArgumentNullException | Thrown if parameter is null
See Also
DoubleAsDouble Class
Eco.Persistence.Default Namespace


DoubleAsDouble.ValueType Method

DoubleAsDouble.ValueType Method
DoubleAsDouble Class Eco.Persistence.Default Namespace See Also
Collapse All

Returns the .NET type of the column.

C#
public System.Type ValueType();
See Also
DoubleAsDouble Class
Eco.Persistence.Default Namespace


GenericAttributeMapper Class

GenericAttributeMapper Class
Inheritance Hierarchy See Also
Collapse All
C#
public class GenericAttributeMapper : AbstractSingleColumnAttribute, ISingleColumnAttributemapping;
Remarks

This is class Eco.Persistence.Default.GenericAttributeMapper.

Inheritance Hierarchy
Eco.Persistence.Default.AbstractSingleColumnAttribute
Eco.Persistence.ISingleColumnAttributemapping
    Eco.Persistence.Default.GenericAttributeMapper
File

GenericAttributeMapper.cs

See Also
Inheritance Hierarchy


GenericAttributeMapper Methods

GenericAttributeMapper Methods
Public Methods
Collapse All

The methods of the GenericAttributeMapper class are listed here.

Public Methods
Name | Description
ColumnToValue | Converts a value from the database column into the modeled type.
ColumnType | Specifies the SQL type of the column.
DefaultDbValue |
StringToParameter | This is StringToParameter, a member of class GenericAttributeMapper.
ValueToParameter | Converts a value that comes from a database query to an ecospace value.
ValueType | This method returns the type of the value that is returned by ColumnToValue.


GenericAttributeMapper.ColumnToValue Method

GenericAttributeMapper.ColumnToValue Method
GenericAttributeMapper Class Eco.Persistence.Default Namespace See Also
Collapse All

Converts a value from the database column into the modeled type.

C#
public override System.Object ColumnToValue(
    System.Object columnValue
);
Parameters
Parameters | Description
columnValue | The value returned from the column in the database.
Returns

The value converted to the modeled type.

See Also
GenericAttributeMapper Class
Eco.Persistence.Default Namespace


GenericAttributeMapper.ColumnType Method

GenericAttributeMapper.ColumnType Method
GenericAttributeMapper Class Eco.Persistence.Default Namespace See Also
Collapse All

Specifies the SQL type of the column.

C#
public String ColumnType(
    int length
);
See Also
GenericAttributeMapper Class
Eco.Persistence.Default Namespace


GenericAttributeMapper.DefaultDbValue Method

GenericAttributeMapper.DefaultDbValue Method
GenericAttributeMapper Class Eco.Persistence.Default Namespace See Also
Collapse All
C#
public String DefaultDbValue(
    string modeledValue,
    SqlDatabaseConfig sqlDatabaseConfig
);
Exceptions
Exceptions | Description
ArgumentNullException | Thrown if sqlDatabaseConfig is null
See Also
GenericAttributeMapper Class
Eco.Persistence.Default Namespace


GenericAttributeMapper.StringToParameter Method

GenericAttributeMapper.StringToParameter Method
GenericAttributeMapper Class Eco.Persistence.Default Namespace See Also
Collapse All
C#
public void StringToParameter(
    string value,
    IDataParameter parameter
);
Remarks

This is StringToParameter, a member of class GenericAttributeMapper.

See Also
GenericAttributeMapper Class
Eco.Persistence.Default Namespace


GenericAttributeMapper.ValueToParameter Method

GenericAttributeMapper.ValueToParameter Method
GenericAttributeMapper Class Eco.Persistence.Default Namespace See Also
Collapse All

Converts a value that comes from a database query to an ecospace value.

C#
public void ValueToParameter(
    System.Object value,
    IDataParameter parameter
);
Remarks

In many cases, the implementation of this method mainly converts null to DBNull, but it can also handle conversion from for example booleans to integers, byte[] to database blobs. It also has to set the correct parameter types in the IDataParameter-object. This is the reverse operation of ColumnToValue.

See Also
GenericAttributeMapper Class
Eco.Persistence.Default Namespace


GenericAttributeMapper.ValueType Method

GenericAttributeMapper.ValueType Method
GenericAttributeMapper Class Eco.Persistence.Default Namespace See Also
Collapse All

This method returns the type of the value that is returned by ColumnToValue.

C#
public System.Type ValueType();
See Also
GenericAttributeMapper Class
Eco.Persistence.Default Namespace


GenericDateTimeMapper Class

GenericDateTimeMapper Class
Inheritance Hierarchy See Also
Collapse All

Base class for mapping Single values to a single column in a database.

C#
public abstract class GenericDateTimeMapper : AbstractSingleColumnAttribute, ISingleColumnAttributemapping;
Inheritance Hierarchy
Eco.Persistence.Default.AbstractSingleColumnAttribute
Eco.Persistence.ISingleColumnAttributemapping
    Eco.Persistence.Default.GenericDateTimeMapper
        Eco.Persistence.Default.DateTimeAsDateTime
        Eco.Persistence.Default.DateTimeAsTimeStamp
File

DefaultAttributeMappers.cs

See Also
Inheritance Hierarchy


GenericDateTimeMapper Methods

GenericDateTimeMapper Methods
Public Methods
Collapse All

The methods of the GenericDateTimeMapper class are listed here.

Public Methods
Name | Description
ColumnToValue | Converts a value from the database column into the modeled type.
ColumnType | Returns the SQL type used by the database during CREATE TABLE execution.
DefaultDbValue | Given the DefaultDBValue in the model this method will return a string to be used by the database during CREATE TABLE execution.
IsEqual | Returns whether or not a value of the modeled type equals the value of the object from/to the database column.
StringToParameter | Converts a string to the correct data type and then inserts the given value into the IDataParameter.
ValueToParameter | Inserts the given value into the IDataParameter.
ValueType | Returns the .NET type of the column.


GenericDateTimeMapper.ColumnToValue Method

GenericDateTimeMapper.ColumnToValue Method
GenericDateTimeMapper Class Eco.Persistence.Default Namespace See Also
Collapse All

Converts a value from the database column into the modeled type.

C#
public override System.Object ColumnToValue(
    System.Object columnValue
);
Parameters
Parameters | Description
columnValue | The value returned from the column in the database.
Returns

The value converted to the modeled type.

See Also
GenericDateTimeMapper Class
Eco.Persistence.Default Namespace


GenericDateTimeMapper.ColumnType Method

GenericDateTimeMapper.ColumnType Method
GenericDateTimeMapper Class Eco.Persistence.Default Namespace See Also
Collapse All

Returns the SQL type used by the database during CREATE TABLE execution.

C#
public abstract String ColumnType(
    int length
);
Parameters
Parameters | Description
length | The length specified in the model.
See Also
GenericDateTimeMapper Class
Eco.Persistence.Default Namespace


GenericDateTimeMapper.DefaultDbValue Method

GenericDateTimeMapper.DefaultDbValue Method
GenericDateTimeMapper Class Eco.Persistence.Default Namespace See Also
Collapse All

Given the DefaultDBValue in the model this method will return a string to be used by the database during CREATE TABLE execution.

C#
public String DefaultDbValue(
    string modeledValue,
    SqlDatabaseConfig sqlDatabaseConfig
);
Parameters
Parameters | Description
modeledValue | The value entered in the model.
sqlDatabaseConfig | The configuration settings of the target database.
Returns

A string to be used in the CREATE TABLE SQL statement.

See Also
GenericDateTimeMapper Class
Eco.Persistence.Default Namespace


GenericDateTimeMapper.IsEqual Method

GenericDateTimeMapper.IsEqual Method
GenericDateTimeMapper Class Eco.Persistence.Default Namespace See Also
Collapse All

Returns whether or not a value of the modeled type equals the value of the object from/to the database column.

C#
public override bool IsEqual(
    System.Object value,
    System.Object columnValue
);
Parameters
Parameters | Description
value | The value of the class’s property.
columnValue | The value of the database column.
Returns

True if they are equal, otherwise false.

See Also
GenericDateTimeMapper Class
Eco.Persistence.Default Namespace


GenericDateTimeMapper.StringToParameter Method

GenericDateTimeMapper.StringToParameter Method
GenericDateTimeMapper Class Eco.Persistence.Default Namespace See Also
Collapse All

Converts a string to the correct data type and then inserts the given value into the IDataParameter.

C#
public void StringToParameter(
    string value,
    IDataParameter parameter
);
Parameters
Parameters | Description
value | The value to use.
parameter | The IDataParameter to update.
See Also
GenericDateTimeMapper Class
Eco.Persistence.Default Namespace


GenericDateTimeMapper.ValueToParameter Method

GenericDateTimeMapper.ValueToParameter Method
GenericDateTimeMapper Class Eco.Persistence.Default Namespace See Also
Collapse All

Inserts the given value into the IDataParameter.

C#
public void ValueToParameter(
    System.Object value,
    IDataParameter parameter
);
Parameters
Parameters | Description
value | The value to use.
parameter | The IDataParameter to update.
See Also
GenericDateTimeMapper Class
Eco.Persistence.Default Namespace


GenericDateTimeMapper.ValueType Method

GenericDateTimeMapper.ValueType Method
GenericDateTimeMapper Class Eco.Persistence.Default Namespace See Also
Collapse All

Returns the .NET type of the column.

C#
public System.Type ValueType();
See Also
GenericDateTimeMapper Class
Eco.Persistence.Default Namespace


GenericEnumAsInteger Class

GenericEnumAsInteger Class
Inheritance Hierarchy See Also
Collapse All

Generic mapper for enum types.

C#
public class GenericEnumAsInteger : AbstractNumericSingleColumnAttribute, IGenericSingleColumnAttributemapping;
Remarks

This mapper is able to map any enum type to an INTEGER column in the database. It can be installed as the default mapper for all enum types with the name "Enum" in PersistenceMapperXXX.SqlDatabaseConfig.AttributeMappers

Inheritance Hierarchy
Eco.Persistence.Default.AbstractSingleColumnAttribute
    Eco.Persistence.Default.AbstractNumericSingleColumnAttribute
    Eco.Persistence.ISingleColumnAttributemapping
        Eco.Persistence.IGenericSingleColumnAttributemapping
            Eco.Persistence.Default.GenericEnumAsInteger
File

EnumPMappers.cs

See Also
Inheritance Hierarchy


GenericEnumAsInteger Methods

GenericEnumAsInteger Methods
Public Methods
Collapse All

The methods of the GenericEnumAsInteger class are listed here.

Public Methods
Name | Description
ColumnToValue | This is the overview for the ColumnToValue method overload.
ColumnType | Specifies the SQL type of the column.
IsEqual | Returns whether or not a value of the modeled type equals the value of the object from/to the database column.
StringToParameter | This is the overview for the StringToParameter method overload.
ValueToParameter | Converts a value that comes from a database query to an ecospace value.
ValueType | This method returns the type of the value that is returned by ColumnToValue.


ColumnToValue Method

ColumnToValue Method

This is the overview for the ColumnToValue method overload.

Overload List
Name | Description
GenericEnumAsInteger.ColumnToValue (System.Object) | Converts a value from the database column into the modeled type.
GenericEnumAsInteger.ColumnToValue (System.Object, System.Type) | This is ColumnToValue, a member of class GenericEnumAsInteger.


GenericEnumAsInteger.ColumnToValue Method (System.Object)

GenericEnumAsInteger.ColumnToValue Method (System.Object)
GenericEnumAsInteger Class Eco.Persistence.Default Namespace See Also
Collapse All

Converts a value from the database column into the modeled type.

C#
public override System.Object ColumnToValue(
    System.Object columnValue
);
Parameters
Parameters | Description
columnValue | The value returned from the column in the database.
Returns

The value converted to the modeled type.

See Also
GenericEnumAsInteger Class
Eco.Persistence.Default Namespace


GenericEnumAsInteger.ColumnToValue Method (System.Object, System.Type)

GenericEnumAsInteger.ColumnToValue Method (System.Object, System.Type)
GenericEnumAsInteger Class Eco.Persistence.Default Namespace See Also
Collapse All
C#
public System.Object ColumnToValue(
    System.Object columnValue,
    System.Type expectedType
);
Remarks

This is ColumnToValue, a member of class GenericEnumAsInteger.

See Also
GenericEnumAsInteger Class
Eco.Persistence.Default Namespace


GenericEnumAsInteger.ColumnType Method

GenericEnumAsInteger.ColumnType Method
GenericEnumAsInteger Class Eco.Persistence.Default Namespace See Also
Collapse All

Specifies the SQL type of the column.

C#
public String ColumnType(
    int length
);
See Also
GenericEnumAsInteger Class
Eco.Persistence.Default Namespace


GenericEnumAsInteger.IsEqual Method

GenericEnumAsInteger.IsEqual Method
GenericEnumAsInteger Class Eco.Persistence.Default Namespace See Also
Collapse All

Returns whether or not a value of the modeled type equals the value of the object from/to the database column.

C#
public override bool IsEqual(
    System.Object value,
    System.Object columnValue
);
Parameters
Parameters | Description
value | The value of the class’s property.
columnValue | The value of the database column.
Returns

True if they are equal, otherwise false.

See Also
GenericEnumAsInteger Class
Eco.Persistence.Default Namespace


StringToParameter Method

StringToParameter Method

This is the overview for the StringToParameter method overload.

Overload List
Name | Description
GenericEnumAsInteger.StringToParameter (string, IDataParameter) | This is StringToParameter, a member of class GenericEnumAsInteger.
GenericEnumAsInteger.StringToParameter (string, IDataParameter, System.Type) | This is StringToParameter, a member of class GenericEnumAsInteger.


GenericEnumAsInteger.StringToParameter Method (string, IDataParameter)

GenericEnumAsInteger.StringToParameter Method (string, IDataParameter)
GenericEnumAsInteger Class Eco.Persistence.Default Namespace See Also
Collapse All
C#
public void StringToParameter(
    string value,
    IDataParameter parameter
);
Remarks

This is StringToParameter, a member of class GenericEnumAsInteger.

See Also
GenericEnumAsInteger Class
Eco.Persistence.Default Namespace


GenericEnumAsInteger.StringToParameter Method (string, IDataParameter, System.Type)

GenericEnumAsInteger.StringToParameter Method (string, IDataParameter, System.Type)
GenericEnumAsInteger Class Eco.Persistence.Default Namespace See Also
Collapse All
C#
public void StringToParameter(
    string value,
    IDataParameter parameter,
    System.Type expectedType
);
Remarks

This is StringToParameter, a member of class GenericEnumAsInteger.

See Also
GenericEnumAsInteger Class
Eco.Persistence.Default Namespace


GenericEnumAsInteger.ValueToParameter Method

GenericEnumAsInteger.ValueToParameter Method
GenericEnumAsInteger Class Eco.Persistence.Default Namespace See Also
Collapse All

Converts a value that comes from a database query to an ecospace value.

C#
public void ValueToParameter(
    System.Object value,
    IDataParameter parameter
);
Remarks

In many cases, the implementation of this method mainly converts null to DBNull, but it can also handle conversion from for example booleans to integers, byte[] to database blobs. It also has to set the correct parameter types in the IDataParameter-object. This is the reverse operation of ColumnToValue.

See Also
GenericEnumAsInteger Class
Eco.Persistence.Default Namespace


GenericEnumAsInteger.ValueType Method

GenericEnumAsInteger.ValueType Method
GenericEnumAsInteger Class Eco.Persistence.Default Namespace See Also
Collapse All

This method returns the type of the value that is returned by ColumnToValue.

C#
public System.Type ValueType();
See Also
GenericEnumAsInteger Class
Eco.Persistence.Default Namespace


GenericEnumAsVarChar Class

GenericEnumAsVarChar Class
Inheritance Hierarchy See Also
Collapse All

Generic mapper for enum types.

C#
public class GenericEnumAsVarChar : AbstractStringSingleColumnAttribute, IGenericSingleColumnAttributemapping;
Remarks

This mapper is able to map any enum type to an INTEGER column in the database. It can be installed as the default mapper for all enum types with the name "Enum" in PersistenceMapperXXX.SqlDatabaseConfig.AttributeMappers

Inheritance Hierarchy
Eco.Persistence.Default.AbstractSingleColumnAttribute
    Eco.Persistence.Default.AbstractStringSingleColumnAttribute
    Eco.Persistence.ISingleColumnAttributemapping
        Eco.Persistence.IGenericSingleColumnAttributemapping
            Eco.Persistence.Default.GenericEnumAsVarChar
File

EnumPMappers.cs

See Also
Inheritance Hierarchy


GenericEnumAsVarChar Methods

GenericEnumAsVarChar Methods
Public Methods
Collapse All

The methods of the GenericEnumAsVarChar class are listed here.

Public Methods
Name | Description
ColumnToValue | This is the overview for the ColumnToValue method overload.
ColumnType | Specifies the SQL type of the column.
IsEqual | Returns whether or not a value of the modeled type equals the value of the object from/to the database column.
StringToParameter | This is the overview for the StringToParameter method overload.
ValueToParameter | Converts a value that comes from a database query to an ecospace value.
ValueType | This method returns the type of the value that is returned by ColumnToValue.


ColumnToValue Method

ColumnToValue Method

This is the overview for the ColumnToValue method overload.

Overload List
Name | Description
GenericEnumAsVarChar.ColumnToValue (System.Object) | Converts a value from the database column into the modeled type.
GenericEnumAsVarChar.ColumnToValue (System.Object, System.Type) | This is ColumnToValue, a member of class GenericEnumAsVarChar.


GenericEnumAsVarChar.ColumnToValue Method (System.Object)

GenericEnumAsVarChar.ColumnToValue Method (System.Object)
GenericEnumAsVarChar Class Eco.Persistence.Default Namespace See Also
Collapse All

Converts a value from the database column into the modeled type.

C#
public override System.Object ColumnToValue(
    System.Object columnValue
);
Parameters
Parameters | Description
columnValue | The value returned from the column in the database.
Returns

The value converted to the modeled type.

See Also
GenericEnumAsVarChar Class
Eco.Persistence.Default Namespace


GenericEnumAsVarChar.ColumnToValue Method (System.Object, System.Type)

GenericEnumAsVarChar.ColumnToValue Method (System.Object, System.Type)
GenericEnumAsVarChar Class Eco.Persistence.Default Namespace See Also
Collapse All
C#
public System.Object ColumnToValue(
    System.Object columnValue,
    System.Type expectedType
);
Remarks

This is ColumnToValue, a member of class GenericEnumAsVarChar.

See Also
GenericEnumAsVarChar Class
Eco.Persistence.Default Namespace


GenericEnumAsVarChar.ColumnType Method

GenericEnumAsVarChar.ColumnType Method
GenericEnumAsVarChar Class Eco.Persistence.Default Namespace See Also
Collapse All

Specifies the SQL type of the column.

C#
public String ColumnType(
    int length
);
See Also
GenericEnumAsVarChar Class
Eco.Persistence.Default Namespace


GenericEnumAsVarChar.IsEqual Method

GenericEnumAsVarChar.IsEqual Method
GenericEnumAsVarChar Class Eco.Persistence.Default Namespace See Also
Collapse All

Returns whether or not a value of the modeled type equals the value of the object from/to the database column.

C#
public override bool IsEqual(
    System.Object value,
    System.Object columnValue
);
Parameters
Parameters | Description
value | The value of the class’s property.
columnValue | The value of the database column.
Returns

True if they are equal, otherwise false.

See Also
GenericEnumAsVarChar Class
Eco.Persistence.Default Namespace


StringToParameter Method

StringToParameter Method

This is the overview for the StringToParameter method overload.

Overload List
Name | Description
GenericEnumAsVarChar.StringToParameter (string, IDataParameter) | This is StringToParameter, a member of class GenericEnumAsVarChar.
GenericEnumAsVarChar.StringToParameter (string, IDataParameter, System.Type) | This is StringToParameter, a member of class GenericEnumAsVarChar.


GenericEnumAsVarChar.StringToParameter Method (string, IDataParameter)

GenericEnumAsVarChar.StringToParameter Method (string, IDataParameter)
GenericEnumAsVarChar Class Eco.Persistence.Default Namespace See Also
Collapse All
C#
public void StringToParameter(
    string value,
    IDataParameter parameter
);
Remarks

This is StringToParameter, a member of class GenericEnumAsVarChar.

See Also
GenericEnumAsVarChar Class
Eco.Persistence.Default Namespace


GenericEnumAsVarChar.StringToParameter Method (string, IDataParameter, System.Type)

GenericEnumAsVarChar.StringToParameter Method (string, IDataParameter, System.Type)
GenericEnumAsVarChar Class Eco.Persistence.Default Namespace See Also
Collapse All
C#
public void StringToParameter(
    string value,
    IDataParameter parameter,
    System.Type expectedType
);
Remarks

This is StringToParameter, a member of class GenericEnumAsVarChar.

See Also
GenericEnumAsVarChar Class
Eco.Persistence.Default Namespace


GenericEnumAsVarChar.ValueToParameter Method

GenericEnumAsVarChar.ValueToParameter Method
GenericEnumAsVarChar Class Eco.Persistence.Default Namespace See Also
Collapse All

Converts a value that comes from a database query to an ecospace value.

C#
public void ValueToParameter(
    System.Object value,
    IDataParameter parameter
);
Remarks

In many cases, the implementation of this method mainly converts null to DBNull, but it can also handle conversion from for example booleans to integers, byte[] to database blobs. It also has to set the correct parameter types in the IDataParameter-object. This is the reverse operation of ColumnToValue.

See Also
GenericEnumAsVarChar Class
Eco.Persistence.Default Namespace


GenericEnumAsVarChar.ValueType Method

GenericEnumAsVarChar.ValueType Method
GenericEnumAsVarChar Class Eco.Persistence.Default Namespace See Also
Collapse All

This method returns the type of the value that is returned by ColumnToValue.

C#
public System.Type ValueType();
See Also
GenericEnumAsVarChar Class
Eco.Persistence.Default Namespace


GenericTimeSpanMapper Class

GenericTimeSpanMapper Class
Inheritance Hierarchy See Also
Collapse All

Abstract class for mapping TimeSpan values to a single column in a database.

C#
public abstract class GenericTimeSpanMapper : AbstractSingleColumnAttribute, ISingleColumnAttributemapping;
Inheritance Hierarchy
Eco.Persistence.Default.AbstractSingleColumnAttribute
Eco.Persistence.ISingleColumnAttributemapping
    Eco.Persistence.Default.GenericTimeSpanMapper
        Eco.Persistence.Default.TimeSpanAsDateTime
        Eco.Persistence.Default.TimeSpanAsTimeStamp
File

DefaultAttributeMappers.cs

See Also
Inheritance Hierarchy


GenericTimeSpanMapper Methods

GenericTimeSpanMapper Methods
Public Methods
Collapse All

The methods of the GenericTimeSpanMapper class are listed here.

Public Methods
Name | Description
ColumnToValue | Converts a value from the database column into the modeled type.
ColumnType | Returns the SQL type used by the database during CREATE TABLE execution.
DefaultDbValue | Given the DefaultDBValue in the model this method will return a string to be used by the database during CREATE TABLE execution.
IsEqual | Returns whether or not a value of the modeled type equals the value of the object from/to the database column.
StringToParameter | Converts a string to the correct data type and then inserts the given value into the IDataParameter.
ValueToParameter | Inserts the given value into the IDataParameter.
ValueType | Returns the .NET type of the column.


GenericTimeSpanMapper.ColumnToValue Method

GenericTimeSpanMapper.ColumnToValue Method
GenericTimeSpanMapper Class Eco.Persistence.Default Namespace See Also
Collapse All

Converts a value from the database column into the modeled type.

C#
public override System.Object ColumnToValue(
    System.Object columnValue
);
Parameters
Parameters | Description
columnValue | The value returned from the column in the database.
Returns

The value converted to the modeled type.

See Also
GenericTimeSpanMapper Class
Eco.Persistence.Default Namespace


GenericTimeSpanMapper.ColumnType Method

GenericTimeSpanMapper.ColumnType Method
GenericTimeSpanMapper Class Eco.Persistence.Default Namespace See Also
Collapse All

Returns the SQL type used by the database during CREATE TABLE execution.

C#
public abstract String ColumnType(
    int length
);
Parameters
Parameters | Description
length | The length entered in the model.
See Also
GenericTimeSpanMapper Class
Eco.Persistence.Default Namespace


GenericTimeSpanMapper.DefaultDbValue Method

GenericTimeSpanMapper.DefaultDbValue Method
GenericTimeSpanMapper Class Eco.Persistence.Default Namespace See Also
Collapse All

Given the DefaultDBValue in the model this method will return a string to be used by the database during CREATE TABLE execution.

C#
public String DefaultDbValue(
    string modeledValue,
    SqlDatabaseConfig sqlDatabaseConfig
);
Parameters
Parameters | Description
modeledValue | The value entered in the model.
sqlDatabaseConfig | The configuration settings of the target database.
Returns

A string to be used in the CREATE TABLE SQL statement.

See Also
GenericTimeSpanMapper Class
Eco.Persistence.Default Namespace


GenericTimeSpanMapper.IsEqual Method

GenericTimeSpanMapper.IsEqual Method
GenericTimeSpanMapper Class Eco.Persistence.Default Namespace See Also
Collapse All

Returns whether or not a value of the modeled type equals the value of the object from/to the database column.

C#
public override bool IsEqual(
    System.Object value,
    System.Object columnValue
);
Parameters
Parameters | Description
value | The value of the class’s property.
columnValue | The value of the database column.
Returns

True if they are equal, otherwise false.

See Also
GenericTimeSpanMapper Class
Eco.Persistence.Default Namespace


GenericTimeSpanMapper.StringToParameter Method

GenericTimeSpanMapper.StringToParameter Method
GenericTimeSpanMapper Class Eco.Persistence.Default Namespace See Also
Collapse All

Converts a string to the correct data type and then inserts the given value into the IDataParameter.

C#
public void StringToParameter(
    string value,
    IDataParameter parameter
);
Parameters
Parameters | Description
value | The value to use.
parameter | The IDataParameter to update.
See Also
GenericTimeSpanMapper Class
Eco.Persistence.Default Namespace


GenericTimeSpanMapper.ValueToParameter Method

GenericTimeSpanMapper.ValueToParameter Method
GenericTimeSpanMapper Class Eco.Persistence.Default Namespace See Also
Collapse All

Inserts the given value into the IDataParameter.

C#
public void ValueToParameter(
    System.Object value,
    IDataParameter parameter
);
Parameters
Parameters | Description
value | The value to use.
parameter | The IDataParameter to update.
See Also
GenericTimeSpanMapper Class
Eco.Persistence.Default Namespace


GenericTimeSpanMapper.ValueType Method

GenericTimeSpanMapper.ValueType Method
GenericTimeSpanMapper Class Eco.Persistence.Default Namespace See Also
Collapse All

Returns the .NET type of the column.

C#
public System.Type ValueType();
See Also
GenericTimeSpanMapper Class
Eco.Persistence.Default Namespace


GuidAsVarChar32 Class

GuidAsVarChar32 Class
Inheritance Hierarchy See Also
Collapse All

Class for mapping Guid values to a single column in a database.

C#
public sealed class GuidAsVarChar32 : AbstractStringSingleColumnAttribute, ISingleColumnAttributemapping;
Inheritance Hierarchy
Eco.Persistence.Default.AbstractSingleColumnAttribute
    Eco.Persistence.Default.AbstractStringSingleColumnAttribute
    Eco.Persistence.ISingleColumnAttributemapping
        Eco.Persistence.Default.GuidAsVarChar32
File

DefaultAttributeMappers.cs

See Also
Inheritance Hierarchy


GuidAsVarChar32 Methods

GuidAsVarChar32 Methods
Public Methods
Collapse All

The methods of the GuidAsVarChar32 class are listed here.

Public Methods
Name | Description
ColumnToValue | Converts a value from the database column into the modeled type.
ColumnType | Returns the SQL type used by the database during CREATE TABLE execution.
StringToParameter | Converts a string to the correct data type and then inserts the given value into the IDataParameter.
ValueToParameter | Inserts the given value into the IDataParameter.
ValueType | Returns the .NET type of the column.


GuidAsVarChar32.ColumnToValue Method

GuidAsVarChar32.ColumnToValue Method
GuidAsVarChar32 Class Eco.Persistence.Default Namespace See Also
Collapse All

Converts a value from the database column into the modeled type.

C#
public override System.Object ColumnToValue(
    System.Object columnValue
);
Parameters
Parameters | Description
columnValue | The value returned from the column in the database.
Returns

The value converted to the modeled type.

See Also
GuidAsVarChar32 Class
Eco.Persistence.Default Namespace


GuidAsVarChar32.ColumnType Method

GuidAsVarChar32.ColumnType Method
GuidAsVarChar32 Class Eco.Persistence.Default Namespace See Also
Collapse All

Returns the SQL type used by the database during CREATE TABLE execution.

C#
public string ColumnType(
    int length
);
Parameters
Parameters | Description
length | This parameter is ignored.
See Also
GuidAsVarChar32 Class
Eco.Persistence.Default Namespace


GuidAsVarChar32.StringToParameter Method

GuidAsVarChar32.StringToParameter Method
GuidAsVarChar32 Class Eco.Persistence.Default Namespace See Also
Collapse All

Converts a string to the correct data type and then inserts the given value into the IDataParameter.

C#
public void StringToParameter(
    string value,
    IDataParameter parameter
);
Parameters
Parameters | Description
value | The value to use.
parameter | The IDataParameter to update.
See Also
GuidAsVarChar32 Class
Eco.Persistence.Default Namespace


GuidAsVarChar32.ValueToParameter Method

GuidAsVarChar32.ValueToParameter Method
GuidAsVarChar32 Class Eco.Persistence.Default Namespace See Also
Collapse All

Inserts the given value into the IDataParameter.

C#
public void ValueToParameter(
    System.Object value,
    IDataParameter parameter
);
Parameters
Parameters | Description
value | The value to use.
parameter | The IDataParameter to update.
See Also
GuidAsVarChar32 Class
Eco.Persistence.Default Namespace


GuidAsVarChar32.ValueType Method

GuidAsVarChar32.ValueType Method
GuidAsVarChar32 Class Eco.Persistence.Default Namespace See Also
Collapse All

Returns the .NET type of the column.

C#
public System.Type ValueType();
See Also
GuidAsVarChar32 Class
Eco.Persistence.Default Namespace


Int16AsSmallint Class

Int16AsSmallint Class
Inheritance Hierarchy See Also
Collapse All

Class for mapping Int16 values to a single column in a database.

C#
public sealed class Int16AsSmallint : AbstractNumericSingleColumnAttribute, ISingleColumnAttributemapping, IDefaultReverseMapping;
Inheritance Hierarchy
Eco.Persistence.Default.AbstractSingleColumnAttribute
    Eco.Persistence.Default.AbstractNumericSingleColumnAttribute
    Eco.Persistence.IDefaultReverseMapping
    Eco.Persistence.ISingleColumnAttributemapping
        Eco.Persistence.Default.Int16AsSmallint
File

DefaultAttributeMappers.cs

See Also
Inheritance Hierarchy


Int16AsSmallint Methods

Int16AsSmallint Methods
Public Methods
Collapse All

The methods of the Int16AsSmallint class are listed here.

Public Methods
Name | Description
ColumnToValue | Converts a value from the database column into the modeled type.
ColumnType | Returns the SQL type used by the database during CREATE TABLE execution.
StringToParameter | Converts a string to the correct data type and then inserts the given value into the IDataParameter.
ValueToParameter | Inserts the given value into the IDataParameter.
ValueType | Returns the .NET type of the column.


Int16AsSmallint.ColumnToValue Method

Int16AsSmallint.ColumnToValue Method
Int16AsSmallint Class Eco.Persistence.Default Namespace See Also
Collapse All

Converts a value from the database column into the modeled type.

C#
public override System.Object ColumnToValue(
    System.Object columnValue
);
Parameters
Parameters | Description
columnValue | The value returned from the column in the database.
Returns

The value converted to the modeled type.

See Also
Int16AsSmallint Class
Eco.Persistence.Default Namespace


Int16AsSmallint.ColumnType Method

Int16AsSmallint.ColumnType Method
Int16AsSmallint Class Eco.Persistence.Default Namespace See Also
Collapse All

Returns the SQL type used by the database during CREATE TABLE execution.

C#
public String ColumnType(
    int length
);
Parameters
Parameters | Description
length | This parameter is ignored.
See Also
Int16AsSmallint Class
Eco.Persistence.Default Namespace


Int16AsSmallint.StringToParameter Method

Int16AsSmallint.StringToParameter Method
Int16AsSmallint Class Eco.Persistence.Default Namespace See Also
Collapse All

Converts a string to the correct data type and then inserts the given value into the IDataParameter.

C#
public void StringToParameter(
    string value,
    IDataParameter parameter
);
Parameters
Parameters | Description
value | The value to use.
parameter | The IDataParameter to update.
See Also
Int16AsSmallint Class
Eco.Persistence.Default Namespace


Int16AsSmallint.ValueToParameter Method

Int16AsSmallint.ValueToParameter Method
Int16AsSmallint Class Eco.Persistence.Default Namespace See Also
Collapse All

Inserts the given value into the IDataParameter.

C#
public void ValueToParameter(
    System.Object value,
    IDataParameter parameter
);
Parameters
Parameters | Description
value | The value to use.
parameter | The IDataParameter to update.
See Also
Int16AsSmallint Class
Eco.Persistence.Default Namespace


Int16AsSmallint.ValueType Method

Int16AsSmallint.ValueType Method
Int16AsSmallint Class Eco.Persistence.Default Namespace See Also
Collapse All

Returns the .NET type of the column.

C#
public System.Type ValueType();
See Also
Int16AsSmallint Class
Eco.Persistence.Default Namespace


Int32AsInteger Class

Int32AsInteger Class
Inheritance Hierarchy See Also
Collapse All

Class for mapping Int32 values to a single column in a database.

C#
public sealed class Int32AsInteger : AbstractNumericSingleColumnAttribute, ISingleColumnAttributemapping, IDefaultReverseMapping;
Inheritance Hierarchy
Eco.Persistence.Default.AbstractSingleColumnAttribute
    Eco.Persistence.Default.AbstractNumericSingleColumnAttribute
    Eco.Persistence.IDefaultReverseMapping
    Eco.Persistence.ISingleColumnAttributemapping
        Eco.Persistence.Default.Int32AsInteger
File

DefaultAttributeMappers.cs

See Also
Inheritance Hierarchy


Int32AsInteger Methods

Int32AsInteger Methods
Public Methods
Collapse All

The methods of the Int32AsInteger class are listed here.

Public Methods
Name | Description
ColumnToValue | Converts a value from the database column into the modeled type.
ColumnType | Returns the SQL type used by the database during CREATE TABLE execution.
StringToParameter | Converts a string to the correct data type and then inserts the given value into the IDataParameter.
ValueToParameter | Inserts the given value into the IDataParameter.
ValueType | Returns the .NET type of the column.


Int32AsInteger.ColumnToValue Method

Int32AsInteger.ColumnToValue Method
Int32AsInteger Class Eco.Persistence.Default Namespace See Also
Collapse All

Converts a value from the database column into the modeled type.

C#
public override System.Object ColumnToValue(
    System.Object columnValue
);
Parameters
Parameters | Description
columnValue | The value returned from the column in the database.
Returns

The value converted to the modeled type.

See Also
Int32AsInteger Class
Eco.Persistence.Default Namespace


Int32AsInteger.ColumnType Method

Int32AsInteger.ColumnType Method
Int32AsInteger Class Eco.Persistence.Default Namespace See Also
Collapse All

Returns the SQL type used by the database during CREATE TABLE execution.

C#
public String ColumnType(
    int length
);
Parameters
Parameters | Description
length | This parameter is ignored.
See Also
Int32AsInteger Class
Eco.Persistence.Default Namespace


Int32AsInteger.StringToParameter Method

Int32AsInteger.StringToParameter Method
Int32AsInteger Class Eco.Persistence.Default Namespace See Also
Collapse All

Converts a string to the correct data type and then inserts the given value into the IDataParameter.

C#
public void StringToParameter(
    string value,
    IDataParameter parameter
);
Parameters
Parameters | Description
value | The value to use.
parameter | The IDataParameter to update.
See Also
Int32AsInteger Class
Eco.Persistence.Default Namespace


Int32AsInteger.ValueToParameter Method

Int32AsInteger.ValueToParameter Method
Int32AsInteger Class Eco.Persistence.Default Namespace See Also
Collapse All

Inserts the given value into the IDataParameter.

C#
public void ValueToParameter(
    System.Object value,
    IDataParameter parameter
);
Parameters
Parameters | Description
value | The value to use.
parameter | The IDataParameter to update.
See Also
Int32AsInteger Class
Eco.Persistence.Default Namespace


Int32AsInteger.ValueType Method

Int32AsInteger.ValueType Method
Int32AsInteger Class Eco.Persistence.Default Namespace See Also
Collapse All

Returns the .NET type of the column.

C#
public System.Type ValueType();
See Also
Int32AsInteger Class
Eco.Persistence.Default Namespace


Int64AsLongInteger Class

Int64AsLongInteger Class
Inheritance Hierarchy See Also
Collapse All

Class for mapping Int64 values to a single column in a database.

C#
public sealed class Int64AsLongInteger : AbstractNumericSingleColumnAttribute, ISingleColumnAttributemapping, IDefaultReverseMapping;
Inheritance Hierarchy
Eco.Persistence.Default.AbstractSingleColumnAttribute
    Eco.Persistence.Default.AbstractNumericSingleColumnAttribute
    Eco.Persistence.IDefaultReverseMapping
    Eco.Persistence.ISingleColumnAttributemapping
        Eco.Persistence.Default.Int64AsLongInteger
File

DefaultAttributeMappers.cs

See Also
Inheritance Hierarchy


Int64AsLongInteger Methods

Int64AsLongInteger Methods
Public Methods
Collapse All

The methods of the Int64AsLongInteger class are listed here.

Public Methods
Name | Description
ColumnToValue | Converts a value from the database column into the modeled type.
ColumnType | Returns the SQL type used by the database during CREATE TABLE execution.
StringToParameter | Converts a string to the correct data type and then inserts the given value into the IDataParameter.
ValueToParameter | Inserts the given value into the IDataParameter.
ValueType | Returns the .NET type of the column.


Int64AsLongInteger.ColumnToValue Method

Int64AsLongInteger.ColumnToValue Method
Int64AsLongInteger Class Eco.Persistence.Default Namespace See Also
Collapse All

Converts a value from the database column into the modeled type.

C#
public override System.Object ColumnToValue(
    System.Object columnValue
);
Parameters
Parameters | Description
columnValue | The value returned from the column in the database.
Returns

The value converted to the modeled type.

See Also
Int64AsLongInteger Class
Eco.Persistence.Default Namespace


Int64AsLongInteger.ColumnType Method

Int64AsLongInteger.ColumnType Method
Int64AsLongInteger Class Eco.Persistence.Default Namespace See Also
Collapse All

Returns the SQL type used by the database during CREATE TABLE execution.

C#
public String ColumnType(
    int length
);
Parameters
Parameters | Description
length | This parameter is ignored.
See Also
Int64AsLongInteger Class
Eco.Persistence.Default Namespace


Int64AsLongInteger.StringToParameter Method

Int64AsLongInteger.StringToParameter Method
Int64AsLongInteger Class Eco.Persistence.Default Namespace See Also
Collapse All

Converts a string to the correct data type and then inserts the given value into the IDataParameter.

C#
public void StringToParameter(
    string value,
    IDataParameter parameter
);
Parameters
Parameters | Description
value | The value to use.
parameter | The IDataParameter to update.
See Also
Int64AsLongInteger Class
Eco.Persistence.Default Namespace


Int64AsLongInteger.ValueToParameter Method

Int64AsLongInteger.ValueToParameter Method
Int64AsLongInteger Class Eco.Persistence.Default Namespace See Also
Collapse All

Inserts the given value into the IDataParameter.

C#
public void ValueToParameter(
    System.Object value,
    IDataParameter parameter
);
Parameters
Parameters | Description
value | The value to use.
parameter | The IDataParameter to update.
See Also
Int64AsLongInteger Class
Eco.Persistence.Default Namespace


Int64AsLongInteger.ValueType Method

Int64AsLongInteger.ValueType Method
Int64AsLongInteger Class Eco.Persistence.Default Namespace See Also
Collapse All

Returns the .NET type of the column.

C#
public System.Type ValueType();
See Also
Int64AsLongInteger Class
Eco.Persistence.Default Namespace


InvalidFieldTypeException Class

InvalidFieldTypeException Class
Inheritance Hierarchy See Also
Collapse All

Thrown when an attempt is made to convert a value that is not compatible with the expected target type.

C#
public class InvalidFieldTypeException : Exception;
Inheritance Hierarchy
Eco.Persistence.Default.InvalidFieldTypeException
File

DefaultAttributeMappers.cs

See Also
Inheritance Hierarchy


InvalidFieldTypeException Constructor

InvalidFieldTypeException Constructor

This is the overview for the InvalidFieldTypeException constructor overload.

Overload List
Name | Description
InvalidFieldTypeException.InvalidFieldTypeException () | Creates an instance of the exception.
InvalidFieldTypeException.InvalidFieldTypeException (SerializationInfo, StreamingContext) | Creates an instance of the exception.
InvalidFieldTypeException.InvalidFieldTypeException (string) | Creates an instance of the exception.
InvalidFieldTypeException.InvalidFieldTypeException (string, Exception) | Creates an instance of the exception.


InvalidFieldTypeException.InvalidFieldTypeException Constructor ()

InvalidFieldTypeException.InvalidFieldTypeException Constructor ()
InvalidFieldTypeException Class Eco.Persistence.Default Namespace See Also
Collapse All

Creates an instance of the exception.

C#
public InvalidFieldTypeException();
See Also
InvalidFieldTypeException Class
Eco.Persistence.Default Namespace


InvalidFieldTypeException.InvalidFieldTypeException Constructor (SerializationInfo, StreamingContext)

InvalidFieldTypeException.InvalidFieldTypeException Constructor (SerializationInfo, StreamingContext)
InvalidFieldTypeException Class Eco.Persistence.Default Namespace See Also
Collapse All

Creates an instance of the exception.

C#
protected InvalidFieldTypeException(
    SerializationInfo info,
    StreamingContext context
);
See Also
InvalidFieldTypeException Class
Eco.Persistence.Default Namespace


InvalidFieldTypeException.InvalidFieldTypeException Constructor (string)

InvalidFieldTypeException.InvalidFieldTypeException Constructor (string)
InvalidFieldTypeException Class Eco.Persistence.Default Namespace See Also
Collapse All

Creates an instance of the exception.

C#
public InvalidFieldTypeException(
    string message
);
See Also
InvalidFieldTypeException Class
Eco.Persistence.Default Namespace


InvalidFieldTypeException.InvalidFieldTypeException Constructor (string, Exception)

InvalidFieldTypeException.InvalidFieldTypeException Constructor (string, Exception)
InvalidFieldTypeException Class Eco.Persistence.Default Namespace See Also
Collapse All

Creates an instance of the exception.

C#
public InvalidFieldTypeException(
    string message,
    Exception inner
);
See Also
InvalidFieldTypeException Class
Eco.Persistence.Default Namespace


MappingUtils Class

MappingUtils Class
Inheritance Hierarchy See Also
Collapse All

Provides standard routines for common data conversion operations.

C#
public sealed class MappingUtils;
Inheritance Hierarchy
Eco.Persistence.Default.MappingUtils
File

DefaultAttributeMappers.cs

See Also
Inheritance Hierarchy


MappingUtils Methods

MappingUtils Methods
Public Methods
Collapse All

The methods of the MappingUtils class are listed here.

Public Methods
Name | Description
ByteArraysAreEqual | Checks if two Byte arrays are equal.
CharArraysAreEqual | Checks if two arrays are equal.
ConvertStringToBoolean | Converts a string to a Boolean.
ConvertStringToByte | Converts a string to a Byte.
ConvertStringToChar | Converts a string to a Char.
ConvertStringToDateTime | Converts a string to a DateTime.
ConvertStringToDecimal | Converts a string to a Decimal.
ConvertStringToDouble | Converts a string to a Double.
ConvertStringToInt16 | Converts a string to an Int16.
ConvertStringToInt32 | Converts a string to an Int32.
ConvertStringToInt64 | Converts a string to an Int64.
ConvertStringToSByte | Converts a string to an SByte.
ConvertStringToSingle | Converts a string to a Single.
ConvertStringToTimespan | Converts a string to a TimeSpan.
DateTimeIsEqual | Checks if two DateTime values are equal.
TimeSpanIsEqual | Checks if two TimeSpan values are equal.


MappingUtils.ByteArraysAreEqual Method

MappingUtils.ByteArraysAreEqual Method
MappingUtils Class Eco.Persistence.Default Namespace See Also
Collapse All

Checks if two Byte arrays are equal.

C#
public static bool ByteArraysAreEqual(
    System.Object value,
    System.Object columnValue
);
See Also
MappingUtils Class
Eco.Persistence.Default Namespace


MappingUtils.CharArraysAreEqual Method

MappingUtils.CharArraysAreEqual Method
MappingUtils Class Eco.Persistence.Default Namespace See Also
Collapse All

Checks if two arrays are equal.

C#
public static bool CharArraysAreEqual(
    System.Object value,
    System.Object columnValue
);
See Also
MappingUtils Class
Eco.Persistence.Default Namespace


MappingUtils.ConvertStringToBoolean Method

MappingUtils.ConvertStringToBoolean Method
MappingUtils Class Eco.Persistence.Default Namespace See Also
Collapse All

Converts a string to a Boolean.

C#
public static object ConvertStringToBoolean(
    string value
);
Parameters
Parameters | Description
value | The value to convert.
Returns

Returns false if the value is "0quot; or "false" using the invariant culture, otherwise returns true.

See Also
MappingUtils Class
Eco.Persistence.Default Namespace


MappingUtils.ConvertStringToByte Method

MappingUtils.ConvertStringToByte Method
MappingUtils Class Eco.Persistence.Default Namespace See Also
Collapse All

Converts a string to a Byte.

C#
public static object ConvertStringToByte(
    string value
);
Parameters
Parameters | Description
value | The value to convert.
Returns

A valid Byte if the value is not null or "", otherwise it will return null.

See Also
MappingUtils Class
Eco.Persistence.Default Namespace


MappingUtils.ConvertStringToChar Method

MappingUtils.ConvertStringToChar Method
MappingUtils Class Eco.Persistence.Default Namespace See Also
Collapse All

Converts a string to a Char.

C#
public static object ConvertStringToChar(
    string value
);
Parameters
Parameters | Description
value | The value to convert.
Returns

A valid Char if the value is not null or "", otherwise it will return null.

See Also
MappingUtils Class
Eco.Persistence.Default Namespace


MappingUtils.ConvertStringToDateTime Method

MappingUtils.ConvertStringToDateTime Method
MappingUtils Class Eco.Persistence.Default Namespace See Also
Collapse All

Converts a string to a DateTime.

C#
public static object ConvertStringToDateTime(
    string value
);
Parameters
Parameters | Description
value | The value to convert.
Returns

A valid DateTime if the value is not null or "", otherwise it will return null.

See Also
MappingUtils Class
Eco.Persistence.Default Namespace


MappingUtils.ConvertStringToDecimal Method

MappingUtils.ConvertStringToDecimal Method
MappingUtils Class Eco.Persistence.Default Namespace See Also
Collapse All

Converts a string to a Decimal.

C#
public static object ConvertStringToDecimal(
    string value
);
Parameters
Parameters | Description
value | The value to convert.
Returns

A valid Decimal if the value is not null or "", otherwise it will return null.

See Also
MappingUtils Class
Eco.Persistence.Default Namespace


MappingUtils.ConvertStringToDouble Method

MappingUtils.ConvertStringToDouble Method
MappingUtils Class Eco.Persistence.Default Namespace See Also
Collapse All

Converts a string to a Double.

C#
public static object ConvertStringToDouble(
    string value
);
Parameters
Parameters | Description
value | The value to convert.
Returns

A valid Double if the value is not null or "", otherwise it will return null.

See Also
MappingUtils Class
Eco.Persistence.Default Namespace


MappingUtils.ConvertStringToInt16 Method

MappingUtils.ConvertStringToInt16 Method
MappingUtils Class Eco.Persistence.Default Namespace See Also
Collapse All

Converts a string to an Int16.

C#
public static object ConvertStringToInt16(
    string value
);
Parameters
Parameters | Description
value | The value to convert.
Returns

A valid Int16 if the value is not null or "", otherwise it will return null.

See Also
MappingUtils Class
Eco.Persistence.Default Namespace


MappingUtils.ConvertStringToInt32 Method

MappingUtils.ConvertStringToInt32 Method
MappingUtils Class Eco.Persistence.Default Namespace See Also
Collapse All

Converts a string to an Int32.

C#
public static object ConvertStringToInt32(
    string value
);
Parameters
Parameters | Description
value | The value to convert.
Returns

A valid Int32 if the value is not null or "", otherwise it will return null.

See Also
MappingUtils Class
Eco.Persistence.Default Namespace


MappingUtils.ConvertStringToInt64 Method

MappingUtils.ConvertStringToInt64 Method
MappingUtils Class Eco.Persistence.Default Namespace See Also
Collapse All

Converts a string to an Int64.

C#
public static object ConvertStringToInt64(
    string value
);
Parameters
Parameters | Description
value | The value to convert.
Returns

A valid Int64 if the value is not null or "", otherwise it will return null.

See Also
MappingUtils Class
Eco.Persistence.Default Namespace


MappingUtils.ConvertStringToSByte Method

MappingUtils.ConvertStringToSByte Method
MappingUtils Class Eco.Persistence.Default Namespace See Also
Collapse All

Converts a string to an SByte.

C#
public static object ConvertStringToSByte(
    string value
);
Parameters
Parameters | Description
value | The value to convert.
Returns

A valid SByte if the value is not null or "", otherwise it will return null.

See Also
MappingUtils Class
Eco.Persistence.Default Namespace


MappingUtils.ConvertStringToSingle Method

MappingUtils.ConvertStringToSingle Method
MappingUtils Class Eco.Persistence.Default Namespace See Also
Collapse All

Converts a string to a Single.

C#
public static object ConvertStringToSingle(
    string value
);
Parameters
Parameters | Description
value | The value to convert.
Returns

A valid Single if the value is not null or "", otherwise it will return null.

See Also
MappingUtils Class
Eco.Persistence.Default Namespace


MappingUtils.ConvertStringToTimespan Method

MappingUtils.ConvertStringToTimespan Method
MappingUtils Class Eco.Persistence.Default Namespace See Also
Collapse All

Converts a string to a TimeSpan.

C#
public static object ConvertStringToTimespan(
    string value
);
Parameters
Parameters | Description
value | The value to convert.
Returns

A valid TimeSpan if the value is not null or "", otherwise it will return null.

See Also
MappingUtils Class
Eco.Persistence.Default Namespace


MappingUtils.DateTimeIsEqual Method

MappingUtils.DateTimeIsEqual Method
MappingUtils Class Eco.Persistence.Default Namespace See Also
Collapse All

Checks if two DateTime values are equal.

C#
public static bool DateTimeIsEqual(
    System.Object value,
    System.Object columnValue
);
See Also
MappingUtils Class
Eco.Persistence.Default Namespace


MappingUtils.TimeSpanIsEqual Method

MappingUtils.TimeSpanIsEqual Method
MappingUtils Class Eco.Persistence.Default Namespace See Also
Collapse All

Checks if two TimeSpan values are equal.

C#
public static bool TimeSpanIsEqual(
    System.Object value,
    System.Object columnValue
);
See Also
MappingUtils Class
Eco.Persistence.Default Namespace


SByteAsSmallInt Class

SByteAsSmallInt Class
Inheritance Hierarchy See Also
Collapse All

Class for mapping SByte values to a single column in a database.

C#
public sealed class SByteAsSmallInt : AbstractNumericSingleColumnAttribute, ISingleColumnAttributemapping;
Inheritance Hierarchy
Eco.Persistence.Default.AbstractSingleColumnAttribute
    Eco.Persistence.Default.AbstractNumericSingleColumnAttribute
    Eco.Persistence.ISingleColumnAttributemapping
        Eco.Persistence.Default.SByteAsSmallInt
File

DefaultAttributeMappers.cs

See Also
Inheritance Hierarchy


SByteAsSmallInt Methods

SByteAsSmallInt Methods
Public Methods
Collapse All

The methods of the SByteAsSmallInt class are listed here.

Public Methods
Name | Description
ColumnToValue | Converts a value from the database column into the modeled type.
ColumnType | Returns the SQL type used by the database during CREATE TABLE execution.
StringToParameter | Converts a string to the correct data type and then inserts the given value into the IDataParameter.
ValueToParameter | Inserts the given value into the IDataParameter.
ValueType | Returns the .NET type of the column.


SByteAsSmallInt.ColumnToValue Method

SByteAsSmallInt.ColumnToValue Method
SByteAsSmallInt Class Eco.Persistence.Default Namespace See Also
Collapse All

Converts a value from the database column into the modeled type.

C#
public override System.Object ColumnToValue(
    System.Object columnValue
);
Parameters
Parameters | Description
columnValue | The value returned from the column in the database.
Returns

The value converted to the modeled type.

See Also
SByteAsSmallInt Class
Eco.Persistence.Default Namespace


SByteAsSmallInt.ColumnType Method

SByteAsSmallInt.ColumnType Method
SByteAsSmallInt Class Eco.Persistence.Default Namespace See Also
Collapse All

Returns the SQL type used by the database during CREATE TABLE execution.

C#
public String ColumnType(
    int length
);
Parameters
Parameters | Description
length | This parameter is ignored.
See Also
SByteAsSmallInt Class
Eco.Persistence.Default Namespace


SByteAsSmallInt.StringToParameter Method

SByteAsSmallInt.StringToParameter Method
SByteAsSmallInt Class Eco.Persistence.Default Namespace See Also
Collapse All

Converts a string to the correct data type and then inserts the given value into the IDataParameter.

C#
public void StringToParameter(
    string value,
    IDataParameter parameter
);
Parameters
Parameters | Description
value | The value to use.
parameter | The IDataParameter to update.
See Also
SByteAsSmallInt Class
Eco.Persistence.Default Namespace


SByteAsSmallInt.ValueToParameter Method

SByteAsSmallInt.ValueToParameter Method
SByteAsSmallInt Class Eco.Persistence.Default Namespace See Also
Collapse All

Inserts the given value into the IDataParameter.

C#
public void ValueToParameter(
    System.Object value,
    IDataParameter parameter
);
Parameters
Parameters | Description
value | The value to use.
parameter | The IDataParameter to update.
See Also
SByteAsSmallInt Class
Eco.Persistence.Default Namespace


SByteAsSmallInt.ValueType Method

SByteAsSmallInt.ValueType Method
SByteAsSmallInt Class Eco.Persistence.Default Namespace See Also
Collapse All

Returns the .NET type of the column.

C#
public System.Type ValueType();
See Also
SByteAsSmallInt Class
Eco.Persistence.Default Namespace


SingleAsSingle Class

SingleAsSingle Class
Inheritance Hierarchy See Also
Collapse All

Class for mapping Single values to a single column in a database.

C#
public sealed class SingleAsSingle : AbstractNumericSingleColumnAttribute, ISingleColumnAttributemapping, IDefaultReverseMapping;
Inheritance Hierarchy
Eco.Persistence.Default.AbstractSingleColumnAttribute
    Eco.Persistence.Default.AbstractNumericSingleColumnAttribute
    Eco.Persistence.IDefaultReverseMapping
    Eco.Persistence.ISingleColumnAttributemapping
        Eco.Persistence.Default.SingleAsSingle
File

DefaultAttributeMappers.cs

See Also
Inheritance Hierarchy


SingleAsSingle Methods

SingleAsSingle Methods
Public Methods
Collapse All

The methods of the SingleAsSingle class are listed here.

Public Methods
Name | Description
ColumnToValue | Converts a value from the database column into the modeled type.
ColumnType | Returns the SQL type used by the database during CREATE TABLE execution.
StringToParameter | Converts a string to the correct data type and then inserts the given value into the IDataParameter.
ValueToParameter | Inserts the given value into the IDataParameter.
ValueType | Returns the .NET type of the column.


SingleAsSingle.ColumnToValue Method

SingleAsSingle.ColumnToValue Method
SingleAsSingle Class Eco.Persistence.Default Namespace See Also
Collapse All

Converts a value from the database column into the modeled type.

C#
public override System.Object ColumnToValue(
    System.Object columnValue
);
Parameters
Parameters | Description
columnValue | The value returned from the column in the database.
Returns

The value converted to the modeled type.

See Also
SingleAsSingle Class
Eco.Persistence.Default Namespace


SingleAsSingle.ColumnType Method

SingleAsSingle.ColumnType Method
SingleAsSingle Class Eco.Persistence.Default Namespace See Also
Collapse All

Returns the SQL type used by the database during CREATE TABLE execution.

C#
public String ColumnType(
    int length
);
Parameters
Parameters | Description
length | This parameter is ignored.
See Also
SingleAsSingle Class
Eco.Persistence.Default Namespace


SingleAsSingle.StringToParameter Method

SingleAsSingle.StringToParameter Method
SingleAsSingle Class Eco.Persistence.Default Namespace See Also
Collapse All

Converts a string to the correct data type and then inserts the given value into the IDataParameter.

C#
public void StringToParameter(
    string value,
    IDataParameter parameter
);
Parameters
Parameters | Description
value | The value to use.
parameter | The IDataParameter to update.
See Also
SingleAsSingle Class
Eco.Persistence.Default Namespace


SingleAsSingle.ValueToParameter Method

SingleAsSingle.ValueToParameter Method
SingleAsSingle Class Eco.Persistence.Default Namespace See Also
Collapse All

Inserts the given value into the IDataParameter.

C#
public void ValueToParameter(
    System.Object value,
    IDataParameter parameter
);
Parameters
Parameters | Description
value | The value to use.
parameter | The IDataParameter to update.
See Also
SingleAsSingle Class
Eco.Persistence.Default Namespace


SingleAsSingle.ValueType Method

SingleAsSingle.ValueType Method
SingleAsSingle Class Eco.Persistence.Default Namespace See Also
Collapse All

Returns the .NET type of the column.

C#
public System.Type ValueType();
See Also
SingleAsSingle Class
Eco.Persistence.Default Namespace


StringAsChar Class

StringAsChar Class
Inheritance Hierarchy See Also
Collapse All

Class for mapping String values to a single column in a database.

C#
public sealed class StringAsChar : AbstractStringSingleColumnAttribute, ISingleColumnAttributemapping, IDefaultReverseMapping;
Inheritance Hierarchy
Eco.Persistence.Default.AbstractSingleColumnAttribute
    Eco.Persistence.Default.AbstractStringSingleColumnAttribute
    Eco.Persistence.IDefaultReverseMapping
    Eco.Persistence.ISingleColumnAttributemapping
        Eco.Persistence.Default.StringAsChar
File

DefaultAttributeMappers.cs

See Also
Inheritance Hierarchy


StringAsChar Methods

StringAsChar Methods
Public Methods
Collapse All

The methods of the StringAsChar class are listed here.

Public Methods
Name | Description
ColumnToValue | Converts a value from the database column into the modeled type.
ColumnType | Returns the SQL type used by the database during CREATE TABLE execution.
StringToParameter | Converts a string to the correct data type and then inserts the given value into the IDataParameter.
ValueToParameter | Inserts the given value into the IDataParameter.
ValueType | Returns the .NET type of the column.


StringAsChar.ColumnToValue Method

StringAsChar.ColumnToValue Method
StringAsChar Class Eco.Persistence.Default Namespace See Also
Collapse All

Converts a value from the database column into the modeled type.

C#
public override System.Object ColumnToValue(
    System.Object columnValue
);
Parameters
Parameters | Description
columnValue | The value returned from the column in the database.
Returns

The value converted to the modeled type.

See Also
StringAsChar Class
Eco.Persistence.Default Namespace


StringAsChar.ColumnType Method

StringAsChar.ColumnType Method
StringAsChar Class Eco.Persistence.Default Namespace See Also
Collapse All

Returns the SQL type used by the database during CREATE TABLE execution.

C#
public string ColumnType(
    int length
);
Parameters
Parameters | Description
length | The column length in the table.
See Also
StringAsChar Class
Eco.Persistence.Default Namespace


StringAsChar.StringToParameter Method

StringAsChar.StringToParameter Method
StringAsChar Class Eco.Persistence.Default Namespace See Also
Collapse All

Converts a string to the correct data type and then inserts the given value into the IDataParameter.

C#
public void StringToParameter(
    string value,
    IDataParameter parameter
);
Parameters
Parameters | Description
value | The value to use.
parameter | The IDataParameter to update.
See Also
StringAsChar Class
Eco.Persistence.Default Namespace


StringAsChar.ValueToParameter Method

StringAsChar.ValueToParameter Method
StringAsChar Class Eco.Persistence.Default Namespace See Also
Collapse All

Inserts the given value into the IDataParameter.

C#
public void ValueToParameter(
    System.Object value,
    IDataParameter parameter
);
Parameters
Parameters | Description
value | The value to use.
parameter | The IDataParameter to update.
See Also
StringAsChar Class
Eco.Persistence.Default Namespace


StringAsChar.ValueType Method

StringAsChar.ValueType Method
StringAsChar Class Eco.Persistence.Default Namespace See Also
Collapse All

Returns the .NET type of the column.

C#
public System.Type ValueType();
See Also
StringAsChar Class
Eco.Persistence.Default Namespace


StringAsNChar Class

StringAsNChar Class
Inheritance Hierarchy See Also
Collapse All

Class for mapping String values to a single column in a database.

C#
public sealed class StringAsNChar : AbstractStringSingleColumnAttribute, ISingleColumnAttributemapping;
Inheritance Hierarchy
Eco.Persistence.Default.AbstractSingleColumnAttribute
    Eco.Persistence.Default.AbstractStringSingleColumnAttribute
    Eco.Persistence.ISingleColumnAttributemapping
        Eco.Persistence.Default.StringAsNChar
File

DefaultAttributeMappers.cs

See Also
Inheritance Hierarchy


StringAsNChar Methods

StringAsNChar Methods
Public Methods
Collapse All

The methods of the StringAsNChar class are listed here.

Public Methods
Name | Description
ColumnToValue | Converts a value from the database column into the modeled type.
ColumnType | Returns the SQL type used by the database during CREATE TABLE execution.
StringToParameter | Converts a string to the correct data type and then inserts the given value into the IDataParameter.
ValueToParameter | Inserts the given value into the IDataParameter.
ValueType | Returns the .NET type of the column.


StringAsNChar.ColumnToValue Method

StringAsNChar.ColumnToValue Method
StringAsNChar Class Eco.Persistence.Default Namespace See Also
Collapse All

Converts a value from the database column into the modeled type.

C#
public override System.Object ColumnToValue(
    System.Object columnValue
);
Parameters
Parameters | Description
columnValue | The value returned from the column in the database.
Returns

The value converted to the modeled type.

See Also
StringAsNChar Class
Eco.Persistence.Default Namespace


StringAsNChar.ColumnType Method

StringAsNChar.ColumnType Method
StringAsNChar Class Eco.Persistence.Default Namespace See Also
Collapse All

Returns the SQL type used by the database during CREATE TABLE execution.

C#
public string ColumnType(
    int length
);
Parameters
Parameters | Description
length | The column length in the table.
See Also
StringAsNChar Class
Eco.Persistence.Default Namespace


StringAsNChar.StringToParameter Method

StringAsNChar.StringToParameter Method
StringAsNChar Class Eco.Persistence.Default Namespace See Also
Collapse All

Converts a string to the correct data type and then inserts the given value into the IDataParameter.

C#
public void StringToParameter(
    string value,
    IDataParameter parameter
);
Parameters
Parameters | Description
value | The value to use.
parameter | The IDataParameter to update.
See Also
StringAsNChar Class
Eco.Persistence.Default Namespace


StringAsNChar.ValueToParameter Method

StringAsNChar.ValueToParameter Method
StringAsNChar Class Eco.Persistence.Default Namespace See Also
Collapse All

Inserts the given value into the IDataParameter.

C#
public void ValueToParameter(
    System.Object value,
    IDataParameter parameter
);
Parameters
Parameters | Description
value | The value to use.
parameter | The IDataParameter to update.
See Also
StringAsNChar Class
Eco.Persistence.Default Namespace


StringAsNChar.ValueType Method

StringAsNChar.ValueType Method
StringAsNChar Class Eco.Persistence.Default Namespace See Also
Collapse All

Returns the .NET type of the column.

C#
public System.Type ValueType();
See Also
StringAsNChar Class
Eco.Persistence.Default Namespace


StringAsNVarChar Class

StringAsNVarChar Class
Inheritance Hierarchy See Also
Collapse All

Class for mapping String values to a single column in a database.

C#
public sealed class StringAsNVarChar : AbstractStringSingleColumnAttribute, ISingleColumnAttributemapping, IDefaultReverseMapping;
Inheritance Hierarchy
Eco.Persistence.Default.AbstractSingleColumnAttribute
    Eco.Persistence.Default.AbstractStringSingleColumnAttribute
    Eco.Persistence.IDefaultReverseMapping
    Eco.Persistence.ISingleColumnAttributemapping
        Eco.Persistence.Default.StringAsNVarChar
File

DefaultAttributeMappers.cs

See Also
Inheritance Hierarchy


StringAsNVarChar Methods

StringAsNVarChar Methods
Public Methods
Collapse All

The methods of the StringAsNVarChar class are listed here.

Public Methods
Name | Description
ColumnToValue | Converts a value from the database column into the modeled type.
ColumnType | Returns the SQL type used by the database during CREATE TABLE execution.
StringToParameter | Converts a string to the correct data type and then inserts the given value into the IDataParameter.
ValueToParameter | Inserts the given value into the IDataParameter.
ValueType | Returns the .NET type of the column.


StringAsNVarChar.ColumnToValue Method

StringAsNVarChar.ColumnToValue Method
StringAsNVarChar Class Eco.Persistence.Default Namespace See Also
Collapse All

Converts a value from the database column into the modeled type.

C#
public override System.Object ColumnToValue(
    System.Object columnValue
);
Parameters
Parameters | Description
columnValue | The value returned from the column in the database.
Returns

The value converted to the modeled type.

See Also
StringAsNVarChar Class
Eco.Persistence.Default Namespace


StringAsNVarChar.ColumnType Method

StringAsNVarChar.ColumnType Method
StringAsNVarChar Class Eco.Persistence.Default Namespace See Also
Collapse All

Returns the SQL type used by the database during CREATE TABLE execution.

C#
public string ColumnType(
    int length
);
Parameters
Parameters | Description
length | The column length in the table.
See Also
StringAsNVarChar Class
Eco.Persistence.Default Namespace


StringAsNVarChar.StringToParameter Method

StringAsNVarChar.StringToParameter Method
StringAsNVarChar Class Eco.Persistence.Default Namespace See Also
Collapse All

Converts a string to the correct data type and then inserts the given value into the IDataParameter.

C#
public void StringToParameter(
    string value,
    IDataParameter parameter
);
Parameters
Parameters | Description
value | The value to use.
parameter | The IDataParameter to update.
See Also
StringAsNVarChar Class
Eco.Persistence.Default Namespace


StringAsNVarChar.ValueToParameter Method

StringAsNVarChar.ValueToParameter Method
StringAsNVarChar Class Eco.Persistence.Default Namespace See Also
Collapse All

Inserts the given value into the IDataParameter.

C#
public void ValueToParameter(
    System.Object value,
    IDataParameter parameter
);
Parameters
Parameters | Description
value | The value to use.
parameter | The IDataParameter to update.
See Also
StringAsNVarChar Class
Eco.Persistence.Default Namespace


StringAsNVarChar.ValueType Method

StringAsNVarChar.ValueType Method
StringAsNVarChar Class Eco.Persistence.Default Namespace See Also
Collapse All

Returns the .NET type of the column.

C#
public System.Type ValueType();
See Also
StringAsNVarChar Class
Eco.Persistence.Default Namespace


StringAsVarChar Class

StringAsVarChar Class
Inheritance Hierarchy See Also
Collapse All

Class for mapping String values to a single column in a database.

C#
public sealed class StringAsVarChar : AbstractStringSingleColumnAttribute, ISingleColumnAttributemapping, IDefaultReverseMapping;
Inheritance Hierarchy
Eco.Persistence.Default.AbstractSingleColumnAttribute
    Eco.Persistence.Default.AbstractStringSingleColumnAttribute
    Eco.Persistence.IDefaultReverseMapping
    Eco.Persistence.ISingleColumnAttributemapping
        Eco.Persistence.Default.StringAsVarChar
File

DefaultAttributeMappers.cs

See Also
Inheritance Hierarchy


StringAsVarChar Methods

StringAsVarChar Methods
Public Methods
Collapse All

The methods of the StringAsVarChar class are listed here.

Public Methods
Name | Description
ColumnToValue | Converts a value from the database column into the modeled type.
ColumnType | Returns the SQL type used by the database during CREATE TABLE execution.
StringToParameter | Converts a string to the correct data type and then inserts the given value into the IDataParameter.
ValueToParameter | Inserts the given value into the IDataParameter.
ValueType | Returns the .NET type of the column.


StringAsVarChar.ColumnToValue Method

StringAsVarChar.ColumnToValue Method
StringAsVarChar Class Eco.Persistence.Default Namespace See Also
Collapse All

Converts a value from the database column into the modeled type.

C#
public override System.Object ColumnToValue(
    System.Object columnValue
);
Parameters
Parameters | Description
columnValue | The value returned from the column in the database.
Returns

The value converted to the modeled type.

See Also
StringAsVarChar Class
Eco.Persistence.Default Namespace


StringAsVarChar.ColumnType Method

StringAsVarChar.ColumnType Method
StringAsVarChar Class Eco.Persistence.Default Namespace See Also
Collapse All

Returns the SQL type used by the database during CREATE TABLE execution.

C#
public string ColumnType(
    int length
);
Parameters
Parameters | Description
length | The column length in the table.
See Also
StringAsVarChar Class
Eco.Persistence.Default Namespace


StringAsVarChar.StringToParameter Method

StringAsVarChar.StringToParameter Method
StringAsVarChar Class Eco.Persistence.Default Namespace See Also
Collapse All

Converts a string to the correct data type and then inserts the given value into the IDataParameter.

C#
public void StringToParameter(
    string value,
    IDataParameter parameter
);
Parameters
Parameters | Description
value | The value to use.
parameter | The IDataParameter to update.
See Also
StringAsVarChar Class
Eco.Persistence.Default Namespace


StringAsVarChar.ValueToParameter Method

StringAsVarChar.ValueToParameter Method
StringAsVarChar Class Eco.Persistence.Default Namespace See Also
Collapse All

Inserts the given value into the IDataParameter.

C#
public void ValueToParameter(
    System.Object value,
    IDataParameter parameter
);
Parameters
Parameters | Description
value | The value to use.
parameter | The IDataParameter to update.
See Also
StringAsVarChar Class
Eco.Persistence.Default Namespace


StringAsVarChar.ValueType Method

StringAsVarChar.ValueType Method
StringAsVarChar Class Eco.Persistence.Default Namespace See Also
Collapse All

Returns the .NET type of the column.

C#
public System.Type ValueType();
See Also
StringAsVarChar Class
Eco.Persistence.Default Namespace


TimeSpanAsDateTime Class

TimeSpanAsDateTime Class
Inheritance Hierarchy See Also
Collapse All

Class for mapping TimeSpan values to a single column in a database.

C#
public class TimeSpanAsDateTime : GenericTimeSpanMapper;
Inheritance Hierarchy
Eco.Persistence.Default.AbstractSingleColumnAttribute
Eco.Persistence.ISingleColumnAttributemapping
    Eco.Persistence.Default.GenericTimeSpanMapper
        Eco.Persistence.Default.TimeSpanAsDateTime
File

DefaultAttributeMappers.cs

See Also
Inheritance Hierarchy


TimeSpanAsDateTime Methods

TimeSpanAsDateTime Methods
Public Methods
Collapse All

The methods of the TimeSpanAsDateTime class are listed here.

Public Methods
Name | Description
ColumnType | Returns the SQL type used by the database during CREATE TABLE execution.


TimeSpanAsDateTime.ColumnType Method

TimeSpanAsDateTime.ColumnType Method
TimeSpanAsDateTime Class Eco.Persistence.Default Namespace See Also
Collapse All

Returns the SQL type used by the database during CREATE TABLE execution.

C#
public override String ColumnType(
    int length
);
Parameters
Parameters | Description
length | This parameter is ignored.
See Also
TimeSpanAsDateTime Class
Eco.Persistence.Default Namespace


TimeSpanAsTimeStamp Class

TimeSpanAsTimeStamp Class
Inheritance Hierarchy See Also
Collapse All

Class for mapping TimeSpan values to a single column in a database.

C#
public class TimeSpanAsTimeStamp : GenericTimeSpanMapper;
Inheritance Hierarchy
Eco.Persistence.Default.AbstractSingleColumnAttribute
Eco.Persistence.ISingleColumnAttributemapping
    Eco.Persistence.Default.GenericTimeSpanMapper
        Eco.Persistence.Default.TimeSpanAsTimeStamp
File

DefaultAttributeMappers.cs

See Also
Inheritance Hierarchy


TimeSpanAsTimeStamp Methods

TimeSpanAsTimeStamp Methods
Public Methods
Collapse All

The methods of the TimeSpanAsTimeStamp class are listed here.

Public Methods
Name | Description
ColumnType | Returns the SQL type used by the database during CREATE TABLE execution.


TimeSpanAsTimeStamp.ColumnType Method

TimeSpanAsTimeStamp.ColumnType Method
TimeSpanAsTimeStamp Class Eco.Persistence.Default Namespace See Also
Collapse All

Returns the SQL type used by the database during CREATE TABLE execution.

C#
public override String ColumnType(
    int length
);
Parameters
Parameters | Description
length | This parameter is ignored.
See Also
TimeSpanAsTimeStamp Class
Eco.Persistence.Default Namespace


TimeStampAsTwoInt32 Class

TimeStampAsTwoInt32 Class
Inheritance Hierarchy See Also
Collapse All

Summary description for Class.

C#
public class TimeStampAsTwoInt32 : IAttributemapping;
Inheritance Hierarchy
Eco.Persistence.IAttributemapping
    Eco.Persistence.Default.TimeStampAsTwoInt32
File

TimeSpanAs2Int32Mapper.cs

See Also
Inheritance Hierarchy


TimeStampAsTwoInt32 Methods

TimeStampAsTwoInt32 Methods
Protected Methods Public Methods
Collapse All

The methods of the TimeStampAsTwoInt32 class are listed here.

Protected Methods
Name | Description
EnsureType |
Top
Public Methods
Name | Description
ColumnNames | This is ColumnNames, a member of class TimeStampAsTwoInt32.
ColumnsToValue | This is ColumnsToValue, a member of class TimeStampAsTwoInt32.
ColumnTypes | This is ColumnTypes, a member of class TimeStampAsTwoInt32.
DefaultDbValues | This is DefaultDbValues, a member of class TimeStampAsTwoInt32.
IsEqual | This is IsEqual, a member of class TimeStampAsTwoInt32.
ValueToParameters | This is ValueToParameters, a member of class TimeStampAsTwoInt32.


TimeStampAsTwoInt32.ColumnNames Method

TimeStampAsTwoInt32.ColumnNames Method
TimeStampAsTwoInt32 Class Eco.Persistence.Default Namespace See Also
Collapse All
C#
public String[] ColumnNames(
    string name
);
Remarks

This is ColumnNames, a member of class TimeStampAsTwoInt32.

See Also
TimeStampAsTwoInt32 Class
Eco.Persistence.Default Namespace


TimeStampAsTwoInt32.ColumnsToValue Method

TimeStampAsTwoInt32.ColumnsToValue Method
TimeStampAsTwoInt32 Class Eco.Persistence.Default Namespace See Also
Collapse All
C#
public object ColumnsToValue(
    object[] columnValues
);
Remarks

This is ColumnsToValue, a member of class TimeStampAsTwoInt32.

See Also
TimeStampAsTwoInt32 Class
Eco.Persistence.Default Namespace


TimeStampAsTwoInt32.ColumnTypes Method

TimeStampAsTwoInt32.ColumnTypes Method
TimeStampAsTwoInt32 Class Eco.Persistence.Default Namespace See Also
Collapse All
C#
public String[] ColumnTypes(
    int length
);
Remarks

This is ColumnTypes, a member of class TimeStampAsTwoInt32.

See Also
TimeStampAsTwoInt32 Class
Eco.Persistence.Default Namespace


TimeStampAsTwoInt32.DefaultDbValues Method

TimeStampAsTwoInt32.DefaultDbValues Method
TimeStampAsTwoInt32 Class Eco.Persistence.Default Namespace See Also
Collapse All
C#
public String[] DefaultDbValues(
    string modeledValue,
    SqlDatabaseConfig sqlDatabaseConfig
);
Remarks

This is DefaultDbValues, a member of class TimeStampAsTwoInt32.

See Also
TimeStampAsTwoInt32 Class
Eco.Persistence.Default Namespace


TimeStampAsTwoInt32.EnsureType Method

TimeStampAsTwoInt32.EnsureType Method
TimeStampAsTwoInt32 Class Eco.Persistence.Default Namespace See Also
Collapse All
C#
protected void EnsureType(
    object value,
    Type t
);
Exceptions
Exceptions | Description
InvalidFieldTypeException | Thrown if the value is not null and not the type of t.
See Also
TimeStampAsTwoInt32 Class
Eco.Persistence.Default Namespace


TimeStampAsTwoInt32.IsEqual Method

TimeStampAsTwoInt32.IsEqual Method
TimeStampAsTwoInt32 Class Eco.Persistence.Default Namespace See Also
Collapse All
C#
public bool IsEqual(
    object value,
    object[] columnValues
);
Remarks

This is IsEqual, a member of class TimeStampAsTwoInt32.

See Also
TimeStampAsTwoInt32 Class
Eco.Persistence.Default Namespace


TimeStampAsTwoInt32.ValueToParameters Method

TimeStampAsTwoInt32.ValueToParameters Method
TimeStampAsTwoInt32 Class Eco.Persistence.Default Namespace See Also
Collapse All
C#
public void ValueToParameters(
    object value,
    IDataParameter[] parameters
);
Remarks

This is ValueToParameters, a member of class TimeStampAsTwoInt32.

See Also
TimeStampAsTwoInt32 Class
Eco.Persistence.Default Namespace


UInt16AsLongInteger Class

UInt16AsLongInteger Class
Inheritance Hierarchy See Also
Collapse All

Class for mapping UInt16 values to a single column in a database.

C#
public sealed class UInt16AsLongInteger : AbstractNumericSingleColumnAttribute, ISingleColumnAttributemapping;
Inheritance Hierarchy
Eco.Persistence.Default.AbstractSingleColumnAttribute
    Eco.Persistence.Default.AbstractNumericSingleColumnAttribute
    Eco.Persistence.ISingleColumnAttributemapping
        Eco.Persistence.Default.UInt16AsLongInteger
File

DefaultAttributeMappers.cs

See Also
Inheritance Hierarchy


UInt16AsLongInteger Methods

UInt16AsLongInteger Methods
Public Methods
Collapse All

The methods of the UInt16AsLongInteger class are listed here.

Public Methods
Name | Description
ColumnToValue | Converts a value from the database column into the modeled type.
ColumnType | Returns the SQL type used by the database during CREATE TABLE execution.
StringToParameter | Converts a string to the correct data type and then inserts the given value into the IDataParameter.
ValueToParameter | Inserts the given value into the IDataParameter.
ValueType | Returns the .NET type of the column.


UInt16AsLongInteger.ColumnToValue Method

UInt16AsLongInteger.ColumnToValue Method
UInt16AsLongInteger Class Eco.Persistence.Default Namespace See Also
Collapse All

Converts a value from the database column into the modeled type.

C#
public override System.Object ColumnToValue(
    System.Object columnValue
);
Parameters
Parameters | Description
columnValue | The value returned from the column in the database.
Returns

The value converted to the modeled type.

See Also
UInt16AsLongInteger Class
Eco.Persistence.Default Namespace


UInt16AsLongInteger.ColumnType Method

UInt16AsLongInteger.ColumnType Method
UInt16AsLongInteger Class Eco.Persistence.Default Namespace See Also
Collapse All

Returns the SQL type used by the database during CREATE TABLE execution.

C#
public String ColumnType(
    int length
);
Parameters
Parameters | Description
length | This parameter is ignored.
See Also
UInt16AsLongInteger Class
Eco.Persistence.Default Namespace


UInt16AsLongInteger.StringToParameter Method

UInt16AsLongInteger.StringToParameter Method
UInt16AsLongInteger Class Eco.Persistence.Default Namespace See Also
Collapse All

Converts a string to the correct data type and then inserts the given value into the IDataParameter.

C#
public void StringToParameter(
    string value,
    IDataParameter parameter
);
Parameters
Parameters | Description
value | The value to use.
parameter | The IDataParameter to update.
See Also
UInt16AsLongInteger Class
Eco.Persistence.Default Namespace


UInt16AsLongInteger.ValueToParameter Method

UInt16AsLongInteger.ValueToParameter Method
UInt16AsLongInteger Class Eco.Persistence.Default Namespace See Also
Collapse All

Inserts the given value into the IDataParameter.

C#
public void ValueToParameter(
    System.Object value,
    IDataParameter parameter
);
Parameters
Parameters | Description
value | The value to use.
parameter | The IDataParameter to update.
See Also
UInt16AsLongInteger Class
Eco.Persistence.Default Namespace


UInt16AsLongInteger.ValueType Method

UInt16AsLongInteger.ValueType Method
UInt16AsLongInteger Class Eco.Persistence.Default Namespace See Also
Collapse All

Returns the .NET type of the column.

C#
public System.Type ValueType();
See Also
UInt16AsLongInteger Class
Eco.Persistence.Default Namespace


UInt32AsLongInteger Class

UInt32AsLongInteger Class
Inheritance Hierarchy See Also
Collapse All

Class for mapping UInt32 values to a single column in a database.

C#
public sealed class UInt32AsLongInteger : AbstractNumericSingleColumnAttribute, ISingleColumnAttributemapping;
Inheritance Hierarchy
Eco.Persistence.Default.AbstractSingleColumnAttribute
    Eco.Persistence.Default.AbstractNumericSingleColumnAttribute
    Eco.Persistence.ISingleColumnAttributemapping
        Eco.Persistence.Default.UInt32AsLongInteger
File

DefaultAttributeMappers.cs

See Also
Inheritance Hierarchy


UInt32AsLongInteger Methods

UInt32AsLongInteger Methods
Public Methods
Collapse All

The methods of the UInt32AsLongInteger class are listed here.

Public Methods
Name | Description
ColumnToValue | Converts a value from the database column into the modeled type.
ColumnType | Returns the SQL type used by the database during CREATE TABLE execution.
StringToParameter | Converts a string to the correct data type and then inserts the given value into the IDataParameter.
ValueToParameter | Inserts the given value into the IDataParameter.
ValueType | Returns the .NET type of the column.


UInt32AsLongInteger.ColumnToValue Method

UInt32AsLongInteger.ColumnToValue Method
UInt32AsLongInteger Class Eco.Persistence.Default Namespace See Also
Collapse All

Converts a value from the database column into the modeled type.

C#
public override System.Object ColumnToValue(
    System.Object columnValue
);
Parameters
Parameters | Description
columnValue | The value returned from the column in the database.
Returns

The value converted to the modeled type.

See Also
UInt32AsLongInteger Class
Eco.Persistence.Default Namespace


UInt32AsLongInteger.ColumnType Method

UInt32AsLongInteger.ColumnType Method
UInt32AsLongInteger Class Eco.Persistence.Default Namespace See Also
Collapse All

Returns the SQL type used by the database during CREATE TABLE execution.

C#
public String ColumnType(
    int length
);
Parameters
Parameters | Description
length | This parameter is ignored.
See Also
UInt32AsLongInteger Class
Eco.Persistence.Default Namespace


UInt32AsLongInteger.StringToParameter Method

UInt32AsLongInteger.StringToParameter Method
UInt32AsLongInteger Class Eco.Persistence.Default Namespace See Also
Collapse All

Converts a string to the correct data type and then inserts the given value into the IDataParameter.

C#
public void StringToParameter(
    string value,
    IDataParameter parameter
);
Parameters
Parameters | Description
value | The value to use.
parameter | The IDataParameter to update.
See Also
UInt32AsLongInteger Class
Eco.Persistence.Default Namespace


UInt32AsLongInteger.ValueToParameter Method

UInt32AsLongInteger.ValueToParameter Method
UInt32AsLongInteger Class Eco.Persistence.Default Namespace See Also
Collapse All

Inserts the given value into the IDataParameter.

C#
public void ValueToParameter(
    System.Object value,
    IDataParameter parameter
);
Parameters
Parameters | Description
value | The value to use.
parameter | The IDataParameter to update.
See Also
UInt32AsLongInteger Class
Eco.Persistence.Default Namespace


UInt32AsLongInteger.ValueType Method

UInt32AsLongInteger.ValueType Method
UInt32AsLongInteger Class Eco.Persistence.Default Namespace See Also
Collapse All

Returns the .NET type of the column.

C#
public System.Type ValueType();
See Also
UInt32AsLongInteger Class
Eco.Persistence.Default Namespace


UInt64AsDecimal Class

UInt64AsDecimal Class
Inheritance Hierarchy See Also
Collapse All

Class for mapping UInt64 values to a single column in a database.

C#
public sealed class UInt64AsDecimal : AbstractNumericSingleColumnAttribute, ISingleColumnAttributemapping;
Inheritance Hierarchy
Eco.Persistence.Default.AbstractSingleColumnAttribute
    Eco.Persistence.Default.AbstractNumericSingleColumnAttribute
    Eco.Persistence.ISingleColumnAttributemapping
        Eco.Persistence.Default.UInt64AsDecimal
File

DefaultAttributeMappers.cs

See Also
Inheritance Hierarchy


UInt64AsDecimal Methods

UInt64AsDecimal Methods
Public Methods
Collapse All

The methods of the UInt64AsDecimal class are listed here.

Public Methods
Name | Description
ColumnToValue | Converts a value from the database column into the modeled type.
ColumnType | Returns the SQL type used by the database during CREATE TABLE execution.
StringToParameter | Converts a string to the correct data type and then inserts the given value into the IDataParameter.
ValueToParameter | Inserts the given value into the IDataParameter.
ValueType | Returns the .NET type of the column.


UInt64AsDecimal.ColumnToValue Method

UInt64AsDecimal.ColumnToValue Method
UInt64AsDecimal Class Eco.Persistence.Default Namespace See Also
Collapse All

Converts a value from the database column into the modeled type.

C#
public override System.Object ColumnToValue(
    System.Object columnValue
);
Parameters
Parameters | Description
columnValue | The value returned from the column in the database.
Returns

The value converted to the modeled type.

See Also
UInt64AsDecimal Class
Eco.Persistence.Default Namespace


UInt64AsDecimal.ColumnType Method

UInt64AsDecimal.ColumnType Method
UInt64AsDecimal Class Eco.Persistence.Default Namespace See Also
Collapse All

Returns the SQL type used by the database during CREATE TABLE execution.

C#
public String ColumnType(
    int length
);
Parameters
Parameters | Description
length | This parameter is ignored.
See Also
UInt64AsDecimal Class
Eco.Persistence.Default Namespace


UInt64AsDecimal.StringToParameter Method

UInt64AsDecimal.StringToParameter Method
UInt64AsDecimal Class Eco.Persistence.Default Namespace See Also
Collapse All

Converts a string to the correct data type and then inserts the given value into the IDataParameter.

C#
public void StringToParameter(
    string value,
    IDataParameter parameter
);
Parameters
Parameters | Description
value | The value to use.
parameter | The IDataParameter to update.
See Also
UInt64AsDecimal Class
Eco.Persistence.Default Namespace


UInt64AsDecimal.ValueToParameter Method

UInt64AsDecimal.ValueToParameter Method
UInt64AsDecimal Class Eco.Persistence.Default Namespace See Also
Collapse All

Inserts the given value into the IDataParameter.

C#
public void ValueToParameter(
    System.Object value,
    IDataParameter parameter
);
Parameters
Parameters | Description
value | The value to use.
parameter | The IDataParameter to update.
See Also
UInt64AsDecimal Class
Eco.Persistence.Default Namespace


UInt64AsDecimal.ValueType Method

UInt64AsDecimal.ValueType Method
UInt64AsDecimal Class Eco.Persistence.Default Namespace See Also
Collapse All

Returns the .NET type of the column.

C#
public System.Type ValueType();
See Also
UInt64AsDecimal Class
Eco.Persistence.Default Namespace


Eco.Persistence.Evolutor Namespace

Eco.Persistence.Evolutor Namespace
Classes Types
Collapse All

This is namespace Eco.Persistence.Evolutor.

Classes
Name | Description
TBoldAddColumn | This is class Eco.Persistence.Evolutor.TBoldAddColumn.
TBoldAddTable | This is class Eco.Persistence.Evolutor.TBoldAddTable.
TBoldCopyInstances | This is class Eco.Persistence.Evolutor.TBoldCopyInstances.
TBoldDataBaseEvolutor | This is class Eco.Persistence.Evolutor.TBoldDataBaseEvolutor.
TBoldDataBaseEvolutorScript | This is class Eco.Persistence.Evolutor.TBoldDataBaseEvolutorScript.
TBoldDeleteInstances | This is class Eco.Persistence.Evolutor.TBoldDeleteInstances.
TBoldDropColumn | This is class Eco.Persistence.Evolutor.TBoldDropColumn.
TBoldDropIndex | This is class Eco.Persistence.Evolutor.TBoldDropIndex.
TBoldDropTable | This is class Eco.Persistence.Evolutor.TBoldDropTable.
TBoldMoveData | This is class Eco.Persistence.Evolutor.TBoldMoveData.
TBoldScriptOperation | This is class Eco.Persistence.Evolutor.TBoldScriptOperation.
TBoldTableOperation | TBoldTableOperation
TBoldTwoColumnOperation | This is class Eco.Persistence.Evolutor.TBoldTwoColumnOperation.
TBoldTwoTableOperation | This is class Eco.Persistence.Evolutor.TBoldTwoTableOperation.
Top
Types
Name | Description
TBoldMemberMappingPairAction | This is type Eco.Persistence.Evolutor.TBoldMemberMappingPairAction.


TBoldAddColumn Class

TBoldAddColumn Class
Inheritance Hierarchy See Also
Collapse All
C#
public class TBoldAddColumn : TBoldScriptOperation;
Remarks

This is class Eco.Persistence.Evolutor.TBoldAddColumn.

Inheritance Hierarchy
Eco.Persistence.Evolutor.TBoldScriptOperation
    Eco.Persistence.Evolutor.TBoldAddColumn
File

BoldDbEvolutorScript.cs

See Also
Inheritance Hierarchy


TBoldAddColumn.TBoldAddColumn Constructor

TBoldAddColumn.TBoldAddColumn Constructor
TBoldAddColumn Class Eco.Persistence.Evolutor Namespace See Also
Collapse All
C#
public TBoldAddColumn(
    TBoldDataBaseEvolutorScript script,
    ColumnDefinition columnDesc
);
Remarks

TBoldAddColumn Constructor Create( Script, ColumnDesc)

See Also
TBoldAddColumn Class
Eco.Persistence.Evolutor Namespace


TBoldAddColumn Methods

TBoldAddColumn Methods
Public Methods
Collapse All

The methods of the TBoldAddColumn class are listed here.

Public Methods
Name | Description
Execute | This is Execute, a member of class TBoldAddColumn.


TBoldAddColumn.Execute Method

TBoldAddColumn.Execute Method
TBoldAddColumn Class Eco.Persistence.Evolutor Namespace See Also
Collapse All
C#
public void Execute();
Remarks

This is Execute, a member of class TBoldAddColumn.

See Also
TBoldAddColumn Class
Eco.Persistence.Evolutor Namespace


TBoldAddColumn Properties

TBoldAddColumn Properties
Public Properties
Collapse All

The properties of the TBoldAddColumn class are listed here.

Public Properties
Name | Description
ColumnDesc | This is ColumnDesc, a member of class TBoldAddColumn.


TBoldAddColumn.ColumnDesc Property

TBoldAddColumn.ColumnDesc Property
TBoldAddColumn Class Eco.Persistence.Evolutor Namespace See Also
Collapse All
C#
public ColumnDefinition ColumnDesc;
Remarks

This is ColumnDesc, a member of class TBoldAddColumn.

See Also
TBoldAddColumn Class
Eco.Persistence.Evolutor Namespace


TBoldAddTable Class

TBoldAddTable Class
Inheritance Hierarchy See Also
Collapse All
C#
public class TBoldAddTable : TBoldScriptOperation;
Remarks

This is class Eco.Persistence.Evolutor.TBoldAddTable.

Inheritance Hierarchy
Eco.Persistence.Evolutor.TBoldScriptOperation
    Eco.Persistence.Evolutor.TBoldAddTable
File

BoldDbEvolutorScript.cs

See Also
Inheritance Hierarchy


TBoldAddTable.TBoldAddTable Constructor

TBoldAddTable.TBoldAddTable Constructor
TBoldAddTable Class Eco.Persistence.Evolutor Namespace See Also
Collapse All
C#
public TBoldAddTable(
    TBoldDataBaseEvolutorScript script,
    TableDefinition tableDescr
);
Remarks

This is TBoldAddTable, a member of class TBoldAddTable.

See Also
TBoldAddTable Class
Eco.Persistence.Evolutor Namespace


TBoldAddTable Methods

TBoldAddTable Methods
Public Methods
Collapse All

The methods of the TBoldAddTable class are listed here.

Public Methods
Name | Description
Execute | This is Execute, a member of class TBoldAddTable.


TBoldAddTable.Execute Method

TBoldAddTable.Execute Method
TBoldAddTable Class Eco.Persistence.Evolutor Namespace See Also
Collapse All
C#
public void Execute();
Remarks

This is Execute, a member of class TBoldAddTable.

See Also
TBoldAddTable Class
Eco.Persistence.Evolutor Namespace


TBoldAddTable Properties

TBoldAddTable Properties
Public Properties
Collapse All

The properties of the TBoldAddTable class are listed here.

Public Properties
Name | Description
TableDescr | This is TableDescr, a member of class TBoldAddTable.


TBoldAddTable.TableDescr Property

TBoldAddTable.TableDescr Property
TBoldAddTable Class Eco.Persistence.Evolutor Namespace See Also
Collapse All
C#
public TableDefinition TableDescr;
Remarks

This is TableDescr, a member of class TBoldAddTable.

See Also
TBoldAddTable Class
Eco.Persistence.Evolutor Namespace


TBoldCopyInstances Class

TBoldCopyInstances Class
Inheritance Hierarchy See Also
Collapse All
C#
public class TBoldCopyInstances : TBoldTwoTableOperation;
Remarks

This is class Eco.Persistence.Evolutor.TBoldCopyInstances.

Inheritance Hierarchy
Eco.Persistence.Evolutor.TBoldScriptOperation
    Eco.Persistence.Evolutor.TBoldTwoTableOperation
        Eco.Persistence.Evolutor.TBoldCopyInstances
File

BoldDbEvolutorScript.cs

See Also
Inheritance Hierarchy


TBoldCopyInstances.TBoldCopyInstances Constructor

TBoldCopyInstances.TBoldCopyInstances Constructor
TBoldCopyInstances Class Eco.Persistence.Evolutor Namespace See Also
Collapse All
C#
public TBoldCopyInstances(
    TBoldDataBaseEvolutorScript script,
    string expressionName,
    AliasDefinition sourceAlias,
    AliasDefinition targetAlias,
    ClassDefinition targetClassDef
);
Remarks

This is TBoldCopyInstances, a member of class TBoldCopyInstances.

See Also
TBoldCopyInstances Class
Eco.Persistence.Evolutor Namespace


TBoldCopyInstances Methods

TBoldCopyInstances Methods
Public Methods
Collapse All

The methods of the TBoldCopyInstances class are listed here.

Public Methods
Name | Description
Execute | This is Execute, a member of class TBoldCopyInstances.
Execute_AddTypeDiscriminatorConditions | This is Execute_AddTypeDiscriminatorConditions, a member of class TBoldCopyInstances.


TBoldCopyInstances.Execute Method

TBoldCopyInstances.Execute Method
TBoldCopyInstances Class Eco.Persistence.Evolutor Namespace See Also
Collapse All
C#
public void Execute();
Remarks

This is Execute, a member of class TBoldCopyInstances.

See Also
TBoldCopyInstances Class
Eco.Persistence.Evolutor Namespace


TBoldCopyInstances.Execute_AddTypeDiscriminatorConditions Method

TBoldCopyInstances.Execute_AddTypeDiscriminatorConditions Method
TBoldCopyInstances Class Eco.Persistence.Evolutor Namespace See Also
Collapse All
C#
public void Execute_AddTypeDiscriminatorConditions(
    AliasDefinition Alias,
    IList<string> WhereConds
);
Remarks

This is Execute_AddTypeDiscriminatorConditions, a member of class TBoldCopyInstances.

See Also
TBoldCopyInstances Class
Eco.Persistence.Evolutor Namespace


TBoldCopyInstances Properties

TBoldCopyInstances Properties
Public Properties
Collapse All

The properties of the TBoldCopyInstances class are listed here.

Public Properties
Name | Description
ExpressionName | This is ExpressionName, a member of class TBoldCopyInstances.
MoveData | This is MoveData, a member of class TBoldCopyInstances.
TargetClassDef | This is TargetClassDef, a member of class TBoldCopyInstances.


TBoldCopyInstances.ExpressionName Property

TBoldCopyInstances.ExpressionName Property
TBoldCopyInstances Class Eco.Persistence.Evolutor Namespace See Also
Collapse All
C#
public string ExpressionName;
Remarks

This is ExpressionName, a member of class TBoldCopyInstances.

See Also
TBoldCopyInstances Class
Eco.Persistence.Evolutor Namespace


TBoldCopyInstances.MoveData Property

TBoldCopyInstances.MoveData Property
TBoldCopyInstances Class Eco.Persistence.Evolutor Namespace See Also
Collapse All
C#
public TBoldMoveData MoveData;
Remarks

This is MoveData, a member of class TBoldCopyInstances.

See Also
TBoldCopyInstances Class
Eco.Persistence.Evolutor Namespace


TBoldCopyInstances.TargetClassDef Property

TBoldCopyInstances.TargetClassDef Property
TBoldCopyInstances Class Eco.Persistence.Evolutor Namespace See Also
Collapse All
C#
public ClassDefinition TargetClassDef;
Remarks

This is TargetClassDef, a member of class TBoldCopyInstances.

See Also
TBoldCopyInstances Class
Eco.Persistence.Evolutor Namespace


TBoldDataBaseEvolutor Class

TBoldDataBaseEvolutor Class
Inheritance Hierarchy See Also
Collapse All
C#
public class TBoldDataBaseEvolutor : object, IDBEvolutor;
Remarks

This is class Eco.Persistence.Evolutor.TBoldDataBaseEvolutor.

Inheritance Hierarchy
Eco.Persistence.IDBEvolutor
    Eco.Persistence.Evolutor.TBoldDataBaseEvolutor
File

BoldDbEvolutor.cs

See Also
Inheritance Hierarchy


TBoldDataBaseEvolutor.TBoldDataBaseEvolutor Constructor

TBoldDataBaseEvolutor.TBoldDataBaseEvolutor Constructor
TBoldDataBaseEvolutor Class Eco.Persistence.Evolutor Namespace See Also
Collapse All
C#
public TBoldDataBaseEvolutor(
    IDatabase database,
    SqlDatabaseConfig SqlConfig,
    SystemPersistenceMapper PersistenceMapper,
    IORMappingProvider OldMappingProvider,
    IORMappingProvider NewMappingProvider,
    FormerNamesHandler FormerNames,
    IEcoTypeSystem typeSystem
);
Remarks

This is TBoldDataBaseEvolutor, a member of class TBoldDataBaseEvolutor.

See Also
TBoldDataBaseEvolutor Class
Eco.Persistence.Evolutor Namespace


TBoldDataBaseEvolutor Methods

TBoldDataBaseEvolutor Methods
Public Methods
Collapse All

The methods of the TBoldDataBaseEvolutor class are listed here.

Public Methods
Name | Description
CalculateScript | IDBEvolutor
ExecuteScript | This is ExecuteScript, a member of class TBoldDataBaseEvolutor.
GenerateDbScript | This is GenerateDbScript, a member of class TBoldDataBaseEvolutor.
GenerateErrors | currently unused procedure TBoldDataBaseEvolutor.AddCommandToScript(Script: IList; s: string); begin Script.Add(s + SqlConfig.SqlScriptTerminator); if SqlConfig.SqlScriptSeparator <> '' then Script.Add(SqlConfig.SqlScriptSeparator); end;
GenerateExecutedStatements | This is GenerateExecutedStatements, a member of class TBoldDataBaseEvolutor.
GenerateMappingScript | This is GenerateMappingScript, a member of class TBoldDataBaseEvolutor.
GenerateWarnings | This is GenerateWarnings, a member of class TBoldDataBaseEvolutor.
GetFormerNamesHandler | This is GetFormerNamesHandler, a member of class TBoldDataBaseEvolutor.
InitializeTableData_AddName | This is InitializeTableData_AddName, a member of class TBoldDataBaseEvolutor.


TBoldDataBaseEvolutor.CalculateScript Method

TBoldDataBaseEvolutor.CalculateScript Method
TBoldDataBaseEvolutor Class Eco.Persistence.Evolutor Namespace See Also
Collapse All
C#
public void CalculateScript();
Remarks

IDBEvolutor

See Also
TBoldDataBaseEvolutor Class
Eco.Persistence.Evolutor Namespace


TBoldDataBaseEvolutor.ExecuteScript Method

TBoldDataBaseEvolutor.ExecuteScript Method
TBoldDataBaseEvolutor Class Eco.Persistence.Evolutor Namespace See Also
Collapse All
C#
public void ExecuteScript();
Remarks

This is ExecuteScript, a member of class TBoldDataBaseEvolutor.

See Also
TBoldDataBaseEvolutor Class
Eco.Persistence.Evolutor Namespace


TBoldDataBaseEvolutor.GenerateDbScript Method

TBoldDataBaseEvolutor.GenerateDbScript Method
TBoldDataBaseEvolutor Class Eco.Persistence.Evolutor Namespace See Also
Collapse All
C#
public string[] GenerateDbScript();
Remarks

This is GenerateDbScript, a member of class TBoldDataBaseEvolutor.

See Also
TBoldDataBaseEvolutor Class
Eco.Persistence.Evolutor Namespace


TBoldDataBaseEvolutor.GenerateErrors Method

TBoldDataBaseEvolutor.GenerateErrors Method
TBoldDataBaseEvolutor Class Eco.Persistence.Evolutor Namespace See Also
Collapse All
C#
public string[] GenerateErrors();
Remarks

currently unused

procedure TBoldDataBaseEvolutor.AddCommandToScript(Script: IList; s: string); begin Script.Add(s + SqlConfig.SqlScriptTerminator); if SqlConfig.SqlScriptSeparator <> '' then Script.Add(SqlConfig.SqlScriptSeparator); end;

See Also
TBoldDataBaseEvolutor Class
Eco.Persistence.Evolutor Namespace


TBoldDataBaseEvolutor.GenerateExecutedStatements Method

TBoldDataBaseEvolutor.GenerateExecutedStatements Method
TBoldDataBaseEvolutor Class Eco.Persistence.Evolutor Namespace See Also
Collapse All
C#
public string[] GenerateExecutedStatements();
Remarks

This is GenerateExecutedStatements, a member of class TBoldDataBaseEvolutor.

See Also
TBoldDataBaseEvolutor Class
Eco.Persistence.Evolutor Namespace


TBoldDataBaseEvolutor.GenerateMappingScript Method

TBoldDataBaseEvolutor.GenerateMappingScript Method
TBoldDataBaseEvolutor Class Eco.Persistence.Evolutor Namespace See Also
Collapse All
C#
public string[] GenerateMappingScript();
Remarks

This is GenerateMappingScript, a member of class TBoldDataBaseEvolutor.

See Also
TBoldDataBaseEvolutor Class
Eco.Persistence.Evolutor Namespace


TBoldDataBaseEvolutor.GenerateWarnings Method

TBoldDataBaseEvolutor.GenerateWarnings Method
TBoldDataBaseEvolutor Class Eco.Persistence.Evolutor Namespace See Also
Collapse All
C#
public string[] GenerateWarnings();
Remarks

This is GenerateWarnings, a member of class TBoldDataBaseEvolutor.

See Also
TBoldDataBaseEvolutor Class
Eco.Persistence.Evolutor Namespace


TBoldDataBaseEvolutor.GetFormerNamesHandler Method

TBoldDataBaseEvolutor.GetFormerNamesHandler Method
TBoldDataBaseEvolutor Class Eco.Persistence.Evolutor Namespace See Also
Collapse All
C#
public FormerNamesHandler GetFormerNamesHandler();
Remarks

This is GetFormerNamesHandler, a member of class TBoldDataBaseEvolutor.

See Also
TBoldDataBaseEvolutor Class
Eco.Persistence.Evolutor Namespace


TBoldDataBaseEvolutor.InitializeTableData_AddName Method

TBoldDataBaseEvolutor.InitializeTableData_AddName Method
TBoldDataBaseEvolutor Class Eco.Persistence.Evolutor Namespace See Also
Collapse All
C#
public void InitializeTableData_AddName(
    string Name,
    Hashtable List
);
Remarks

This is InitializeTableData_AddName, a member of class TBoldDataBaseEvolutor.

See Also
TBoldDataBaseEvolutor Class
Eco.Persistence.Evolutor Namespace


TBoldDataBaseEvolutor Properties

TBoldDataBaseEvolutor Properties
Public Properties
Collapse All

The properties of the TBoldDataBaseEvolutor class are listed here.

Public Properties
Name | Description
Database | This is Database, a member of class TBoldDataBaseEvolutor.


TBoldDataBaseEvolutor.Database Property

TBoldDataBaseEvolutor.Database Property
TBoldDataBaseEvolutor Class Eco.Persistence.Evolutor Namespace See Also
Collapse All
C#
public IDatabase Database;
Remarks

This is Database, a member of class TBoldDataBaseEvolutor.

See Also
TBoldDataBaseEvolutor Class
Eco.Persistence.Evolutor Namespace


TBoldDataBaseEvolutorScript Class

TBoldDataBaseEvolutorScript Class
Inheritance Hierarchy See Also
Collapse All
C#
public class TBoldDataBaseEvolutorScript;
Remarks

This is class Eco.Persistence.Evolutor.TBoldDataBaseEvolutorScript.

Inheritance Hierarchy
Eco.Persistence.Evolutor.TBoldDataBaseEvolutorScript
File

BoldDbEvolutorScript.cs

See Also
Inheritance Hierarchy


TBoldDataBaseEvolutorScript.TBoldDataBaseEvolutorScript Constructor

TBoldDataBaseEvolutorScript.TBoldDataBaseEvolutorScript Constructor
TBoldDataBaseEvolutorScript Class Eco.Persistence.Evolutor Namespace See Also
Collapse All
C#
public TBoldDataBaseEvolutorScript();
Remarks

Constructor Create()

See Also
TBoldDataBaseEvolutorScript Class
Eco.Persistence.Evolutor Namespace


TBoldDataBaseEvolutorScript Methods

TBoldDataBaseEvolutorScript Methods
Protected Methods Public Methods
Collapse All

The methods of the TBoldDataBaseEvolutorScript class are listed here.

Protected Methods
Name | Description
Execute | This is Execute, a member of class TBoldDataBaseEvolutorScript.
GetAddedColumns | This is GetAddedColumns, a member of class TBoldDataBaseEvolutorScript.
GetAddedTables | This is GetAddedTables, a member of class TBoldDataBaseEvolutorScript.
GetCopiedInstances | This is GetCopiedInstances, a member of class TBoldDataBaseEvolutorScript.
GetDeletedInstances | This is GetDeletedInstances, a member of class TBoldDataBaseEvolutorScript.
GetDroppedColumns | This is GetDroppedColumns, a member of class TBoldDataBaseEvolutorScript.
GetDroppedTables | This is GetDroppedTables, a member of class TBoldDataBaseEvolutorScript.
GetMovedData | This is GetMovedData, a member of class TBoldDataBaseEvolutorScript.
Top
Public Methods
Name | Description
AddColumn | TBoldDataBaseEvolutorScript
AddSQLStatement | This is AddSQLStatement, a member of class TBoldDataBaseEvolutorScript.
AddTable | This is AddTable, a member of class TBoldDataBaseEvolutorScript.
Comment | This is Comment, a member of class TBoldDataBaseEvolutorScript.
CopyInstances | This is CopyInstances, a member of class TBoldDataBaseEvolutorScript.
DeleteInstances | This is DeleteInstances, a member of class TBoldDataBaseEvolutorScript.
DropColumn | This is DropColumn, a member of class TBoldDataBaseEvolutorScript.
DropIndex | This is DropIndex, a member of class TBoldDataBaseEvolutorScript.
DropTable | This is DropTable, a member of class TBoldDataBaseEvolutorScript.
ExecuteSQL | This is ExecuteSQL, a member of class TBoldDataBaseEvolutorScript.
GenerateScript | This is GenerateScript, a member of class TBoldDataBaseEvolutorScript.
MoveData | This is MoveData, a member of class TBoldDataBaseEvolutorScript.
OptimizeScript | This is OptimizeScript, a member of class TBoldDataBaseEvolutorScript.
UpdateDatabase | This is UpdateDatabase, a member of class TBoldDataBaseEvolutorScript.


TBoldDataBaseEvolutorScript.AddColumn Method

TBoldDataBaseEvolutorScript.AddColumn Method
TBoldDataBaseEvolutorScript Class Eco.Persistence.Evolutor Namespace See Also
Collapse All
C#
public void AddColumn(
    ColumnDefinition ColumnDesc
);
Remarks

TBoldDataBaseEvolutorScript

See Also
TBoldDataBaseEvolutorScript Class
Eco.Persistence.Evolutor Namespace


TBoldDataBaseEvolutorScript.AddSQLStatement Method

TBoldDataBaseEvolutorScript.AddSQLStatement Method
TBoldDataBaseEvolutorScript Class Eco.Persistence.Evolutor Namespace See Also
Collapse All
C#
public void AddSQLStatement(
    string sql
);
Remarks

This is AddSQLStatement, a member of class TBoldDataBaseEvolutorScript.

See Also
TBoldDataBaseEvolutorScript Class
Eco.Persistence.Evolutor Namespace


TBoldDataBaseEvolutorScript.AddTable Method

TBoldDataBaseEvolutorScript.AddTable Method
TBoldDataBaseEvolutorScript Class Eco.Persistence.Evolutor Namespace See Also
Collapse All
C#
public void AddTable(
    TableDefinition TableDescr
);
Remarks

This is AddTable, a member of class TBoldDataBaseEvolutorScript.

See Also
TBoldDataBaseEvolutorScript Class
Eco.Persistence.Evolutor Namespace


TBoldDataBaseEvolutorScript.Comment Method

TBoldDataBaseEvolutorScript.Comment Method
TBoldDataBaseEvolutorScript Class Eco.Persistence.Evolutor Namespace See Also
Collapse All
C#
public void Comment(
    string msg,
    object[] Args
);
Remarks

This is Comment, a member of class TBoldDataBaseEvolutorScript.

See Also
TBoldDataBaseEvolutorScript Class
Eco.Persistence.Evolutor Namespace


TBoldDataBaseEvolutorScript.CopyInstances Method

TBoldDataBaseEvolutorScript.CopyInstances Method
TBoldDataBaseEvolutorScript Class Eco.Persistence.Evolutor Namespace See Also
Collapse All
C#
public void CopyInstances(
    string ExpressionName,
    AliasDefinition SourceAlias,
    AliasDefinition TargetAlias,
    ClassDefinition TargetClassDef
);
Remarks

This is CopyInstances, a member of class TBoldDataBaseEvolutorScript.

See Also
TBoldDataBaseEvolutorScript Class
Eco.Persistence.Evolutor Namespace


TBoldDataBaseEvolutorScript.DeleteInstances Method

TBoldDataBaseEvolutorScript.DeleteInstances Method
TBoldDataBaseEvolutorScript Class Eco.Persistence.Evolutor Namespace See Also
Collapse All
C#
public void DeleteInstances(
    ClassDefinition ClassDef,
    AliasDefinition Alias
);
Remarks

This is DeleteInstances, a member of class TBoldDataBaseEvolutorScript.

See Also
TBoldDataBaseEvolutorScript Class
Eco.Persistence.Evolutor Namespace


TBoldDataBaseEvolutorScript.DropColumn Method

TBoldDataBaseEvolutorScript.DropColumn Method
TBoldDataBaseEvolutorScript Class Eco.Persistence.Evolutor Namespace See Also
Collapse All
C#
public void DropColumn(
    string TableName,
    string ColumnName
);
Remarks

This is DropColumn, a member of class TBoldDataBaseEvolutorScript.

See Also
TBoldDataBaseEvolutorScript Class
Eco.Persistence.Evolutor Namespace


TBoldDataBaseEvolutorScript.DropIndex Method

TBoldDataBaseEvolutorScript.DropIndex Method
TBoldDataBaseEvolutorScript Class Eco.Persistence.Evolutor Namespace See Also
Collapse All
C#
public void DropIndex(
    string IndexName,
    string TableName
);
Remarks

This is DropIndex, a member of class TBoldDataBaseEvolutorScript.

See Also
TBoldDataBaseEvolutorScript Class
Eco.Persistence.Evolutor Namespace


TBoldDataBaseEvolutorScript.DropTable Method

TBoldDataBaseEvolutorScript.DropTable Method
TBoldDataBaseEvolutorScript Class Eco.Persistence.Evolutor Namespace See Also
Collapse All
C#
public void DropTable(
    string TableName
);
Remarks

This is DropTable, a member of class TBoldDataBaseEvolutorScript.

See Also
TBoldDataBaseEvolutorScript Class
Eco.Persistence.Evolutor Namespace


TBoldDataBaseEvolutorScript.Execute Method

TBoldDataBaseEvolutorScript.Execute Method
TBoldDataBaseEvolutorScript Class Eco.Persistence.Evolutor Namespace See Also
Collapse All
C#
protected void Execute();
Remarks

This is Execute, a member of class TBoldDataBaseEvolutorScript.

See Also
TBoldDataBaseEvolutorScript Class
Eco.Persistence.Evolutor Namespace


TBoldDataBaseEvolutorScript.ExecuteSQL Method

TBoldDataBaseEvolutorScript.ExecuteSQL Method
TBoldDataBaseEvolutorScript Class Eco.Persistence.Evolutor Namespace See Also
Collapse All
C#
public void ExecuteSQL(
    string SQL
);
Remarks

This is ExecuteSQL, a member of class TBoldDataBaseEvolutorScript.

See Also
TBoldDataBaseEvolutorScript Class
Eco.Persistence.Evolutor Namespace


TBoldDataBaseEvolutorScript.GenerateScript Method

TBoldDataBaseEvolutorScript.GenerateScript Method
TBoldDataBaseEvolutorScript Class Eco.Persistence.Evolutor Namespace See Also
Collapse All
C#
public void GenerateScript(
    List<string> Script,
    SqlDatabaseConfig SQLDataBaseConfig
);
Remarks

This is GenerateScript, a member of class TBoldDataBaseEvolutorScript.

See Also
TBoldDataBaseEvolutorScript Class
Eco.Persistence.Evolutor Namespace


TBoldDataBaseEvolutorScript.GetAddedColumns Method

TBoldDataBaseEvolutorScript.GetAddedColumns Method
TBoldDataBaseEvolutorScript Class Eco.Persistence.Evolutor Namespace See Also
Collapse All
C#
protected TBoldAddColumn GetAddedColumns(
    int index
);
Remarks

This is GetAddedColumns, a member of class TBoldDataBaseEvolutorScript.

See Also
TBoldDataBaseEvolutorScript Class
Eco.Persistence.Evolutor Namespace


TBoldDataBaseEvolutorScript.GetAddedTables Method

TBoldDataBaseEvolutorScript.GetAddedTables Method
TBoldDataBaseEvolutorScript Class Eco.Persistence.Evolutor Namespace See Also
Collapse All
C#
protected TBoldAddTable GetAddedTables(
    int index
);
Remarks

This is GetAddedTables, a member of class TBoldDataBaseEvolutorScript.

See Also
TBoldDataBaseEvolutorScript Class
Eco.Persistence.Evolutor Namespace


TBoldDataBaseEvolutorScript.GetCopiedInstances Method

TBoldDataBaseEvolutorScript.GetCopiedInstances Method
TBoldDataBaseEvolutorScript Class Eco.Persistence.Evolutor Namespace See Also
Collapse All
C#
protected TBoldCopyInstances GetCopiedInstances(
    int index
);
Remarks

This is GetCopiedInstances, a member of class TBoldDataBaseEvolutorScript.

See Also
TBoldDataBaseEvolutorScript Class
Eco.Persistence.Evolutor Namespace


TBoldDataBaseEvolutorScript.GetDeletedInstances Method

TBoldDataBaseEvolutorScript.GetDeletedInstances Method
TBoldDataBaseEvolutorScript Class Eco.Persistence.Evolutor Namespace See Also
Collapse All
C#
protected TBoldDeleteInstances GetDeletedInstances(
    int index
);
Remarks

This is GetDeletedInstances, a member of class TBoldDataBaseEvolutorScript.

See Also
TBoldDataBaseEvolutorScript Class
Eco.Persistence.Evolutor Namespace


TBoldDataBaseEvolutorScript.GetDroppedColumns Method

TBoldDataBaseEvolutorScript.GetDroppedColumns Method
TBoldDataBaseEvolutorScript Class Eco.Persistence.Evolutor Namespace See Also
Collapse All
C#
protected TBoldDropColumn GetDroppedColumns(
    int index
);
Remarks

This is GetDroppedColumns, a member of class TBoldDataBaseEvolutorScript.

See Also
TBoldDataBaseEvolutorScript Class
Eco.Persistence.Evolutor Namespace


TBoldDataBaseEvolutorScript.GetDroppedTables Method

TBoldDataBaseEvolutorScript.GetDroppedTables Method
TBoldDataBaseEvolutorScript Class Eco.Persistence.Evolutor Namespace See Also
Collapse All
C#
protected TBoldDropTable GetDroppedTables(
    int index
);
Remarks

This is GetDroppedTables, a member of class TBoldDataBaseEvolutorScript.

See Also
TBoldDataBaseEvolutorScript Class
Eco.Persistence.Evolutor Namespace


TBoldDataBaseEvolutorScript.GetMovedData Method

TBoldDataBaseEvolutorScript.GetMovedData Method
TBoldDataBaseEvolutorScript Class Eco.Persistence.Evolutor Namespace See Also
Collapse All
C#
protected TBoldMoveData GetMovedData(
    int index
);
Remarks

This is GetMovedData, a member of class TBoldDataBaseEvolutorScript.

See Also
TBoldDataBaseEvolutorScript Class
Eco.Persistence.Evolutor Namespace


TBoldDataBaseEvolutorScript.MoveData Method

TBoldDataBaseEvolutorScript.MoveData Method
TBoldDataBaseEvolutorScript Class Eco.Persistence.Evolutor Namespace See Also
Collapse All
C#
public void MoveData(
    AliasDefinition SourceAlias,
    AliasDefinition TargetAlias,
    string SourceColumn,
    string TargetColumn,
    ClassDefinition TargetClassDef
);
Remarks

This is MoveData, a member of class TBoldDataBaseEvolutorScript.

See Also
TBoldDataBaseEvolutorScript Class
Eco.Persistence.Evolutor Namespace


TBoldDataBaseEvolutorScript.OptimizeScript Method

TBoldDataBaseEvolutorScript.OptimizeScript Method
TBoldDataBaseEvolutorScript Class Eco.Persistence.Evolutor Namespace See Also
Collapse All
C#
public void OptimizeScript();
Remarks

This is OptimizeScript, a member of class TBoldDataBaseEvolutorScript.

See Also
TBoldDataBaseEvolutorScript Class
Eco.Persistence.Evolutor Namespace


TBoldDataBaseEvolutorScript.UpdateDatabase Method

TBoldDataBaseEvolutorScript.UpdateDatabase Method
TBoldDataBaseEvolutorScript Class Eco.Persistence.Evolutor Namespace See Also
Collapse All
C#
public void UpdateDatabase(
    IDatabase DataBase,
    SqlDatabaseConfig SQLDataBaseConfig
);
Remarks

This is UpdateDatabase, a member of class TBoldDataBaseEvolutorScript.

See Also
TBoldDataBaseEvolutorScript Class
Eco.Persistence.Evolutor Namespace


TBoldDataBaseEvolutorScript Properties

TBoldDataBaseEvolutorScript Properties
Public Properties
Collapse All

The properties of the TBoldDataBaseEvolutorScript class are listed here.

Public Properties
Name | Description
InternalLog | This is InternalLog, a member of class TBoldDataBaseEvolutorScript.
SQLDataBaseConfig | This is SQLDataBaseConfig, a member of class TBoldDataBaseEvolutorScript.


TBoldDataBaseEvolutorScript.InternalLog Property

TBoldDataBaseEvolutorScript.InternalLog Property
TBoldDataBaseEvolutorScript Class Eco.Persistence.Evolutor Namespace See Also
Collapse All
C#
public List<string> InternalLog;
Remarks

This is InternalLog, a member of class TBoldDataBaseEvolutorScript.

See Also
TBoldDataBaseEvolutorScript Class
Eco.Persistence.Evolutor Namespace


TBoldDataBaseEvolutorScript.SQLDataBaseConfig Property

TBoldDataBaseEvolutorScript.SQLDataBaseConfig Property
TBoldDataBaseEvolutorScript Class Eco.Persistence.Evolutor Namespace See Also
Collapse All
C#
public SqlDatabaseConfig SQLDataBaseConfig;
Remarks

This is SQLDataBaseConfig, a member of class TBoldDataBaseEvolutorScript.

See Also
TBoldDataBaseEvolutorScript Class
Eco.Persistence.Evolutor Namespace


TBoldDeleteInstances Class

TBoldDeleteInstances Class
Inheritance Hierarchy See Also
Collapse All
C#
public class TBoldDeleteInstances : TBoldTableOperation;
Remarks

This is class Eco.Persistence.Evolutor.TBoldDeleteInstances.

Inheritance Hierarchy
Eco.Persistence.Evolutor.TBoldScriptOperation
    Eco.Persistence.Evolutor.TBoldTableOperation
        Eco.Persistence.Evolutor.TBoldDeleteInstances
File

BoldDbEvolutorScript.cs

See Also
Inheritance Hierarchy


TBoldDeleteInstances.TBoldDeleteInstances Constructor

TBoldDeleteInstances.TBoldDeleteInstances Constructor
TBoldDeleteInstances Class Eco.Persistence.Evolutor Namespace See Also
Collapse All
C#
public TBoldDeleteInstances(
    TBoldDataBaseEvolutorScript script,
    ClassDefinition classDef,
    AliasDefinition alias
);
Remarks

This is TBoldDeleteInstances, a member of class TBoldDeleteInstances.

See Also
TBoldDeleteInstances Class
Eco.Persistence.Evolutor Namespace


TBoldDeleteInstances Methods

TBoldDeleteInstances Methods
Public Methods
Collapse All

The methods of the TBoldDeleteInstances class are listed here.

Public Methods
Name | Description
Execute | This is Execute, a member of class TBoldDeleteInstances.


TBoldDeleteInstances.Execute Method

TBoldDeleteInstances.Execute Method
TBoldDeleteInstances Class Eco.Persistence.Evolutor Namespace See Also
Collapse All
C#
public void Execute();
Remarks

This is Execute, a member of class TBoldDeleteInstances.

See Also
TBoldDeleteInstances Class
Eco.Persistence.Evolutor Namespace


TBoldDeleteInstances Properties

TBoldDeleteInstances Properties
Public Properties
Collapse All

The properties of the TBoldDeleteInstances class are listed here.

Public Properties
Name | Description
ClassDef | This is ClassDef, a member of class TBoldDeleteInstances.


TBoldDeleteInstances.ClassDef Property

TBoldDeleteInstances.ClassDef Property
TBoldDeleteInstances Class Eco.Persistence.Evolutor Namespace See Also
Collapse All
C#
public ClassDefinition ClassDef;
Remarks

This is ClassDef, a member of class TBoldDeleteInstances.

See Also
TBoldDeleteInstances Class
Eco.Persistence.Evolutor Namespace


TBoldDropColumn Class

TBoldDropColumn Class
Inheritance Hierarchy See Also
Collapse All
C#
public class TBoldDropColumn : TBoldScriptOperation;
Remarks

This is class Eco.Persistence.Evolutor.TBoldDropColumn.

Inheritance Hierarchy
Eco.Persistence.Evolutor.TBoldScriptOperation
    Eco.Persistence.Evolutor.TBoldDropColumn
File

BoldDbEvolutorScript.cs

See Also
Inheritance Hierarchy


TBoldDropColumn.TBoldDropColumn Constructor

TBoldDropColumn.TBoldDropColumn Constructor
TBoldDropColumn Class Eco.Persistence.Evolutor Namespace See Also
Collapse All
C#
public TBoldDropColumn(
    TBoldDataBaseEvolutorScript script,
    string tableName,
    string columnName
);
Remarks

TBoldDropColumn Constructor Create( Script, TableName, ColumnName)

See Also
TBoldDropColumn Class
Eco.Persistence.Evolutor Namespace


TBoldDropColumn Methods

TBoldDropColumn Methods
Public Methods
Collapse All

The methods of the TBoldDropColumn class are listed here.

Public Methods
Name | Description
Execute | This is Execute, a member of class TBoldDropColumn.


TBoldDropColumn.Execute Method

TBoldDropColumn.Execute Method
TBoldDropColumn Class Eco.Persistence.Evolutor Namespace See Also
Collapse All
C#
public void Execute();
Remarks

This is Execute, a member of class TBoldDropColumn.

See Also
TBoldDropColumn Class
Eco.Persistence.Evolutor Namespace


TBoldDropColumn Properties

TBoldDropColumn Properties
Public Properties
Collapse All

The properties of the TBoldDropColumn class are listed here.

Public Properties
Name | Description
ColumnName | This is ColumnName, a member of class TBoldDropColumn.
TableName | This is TableName, a member of class TBoldDropColumn.


TBoldDropColumn.ColumnName Property

TBoldDropColumn.ColumnName Property
TBoldDropColumn Class Eco.Persistence.Evolutor Namespace See Also
Collapse All
C#
public string ColumnName;
Remarks

This is ColumnName, a member of class TBoldDropColumn.

See Also
TBoldDropColumn Class
Eco.Persistence.Evolutor Namespace


TBoldDropColumn.TableName Property

TBoldDropColumn.TableName Property
TBoldDropColumn Class Eco.Persistence.Evolutor Namespace See Also
Collapse All
C#
public string TableName;
Remarks

This is TableName, a member of class TBoldDropColumn.

See Also
TBoldDropColumn Class
Eco.Persistence.Evolutor Namespace


TBoldDropIndex Class

TBoldDropIndex Class
Inheritance Hierarchy See Also
Collapse All
C#
public class TBoldDropIndex : TBoldScriptOperation;
Remarks

This is class Eco.Persistence.Evolutor.TBoldDropIndex.

Inheritance Hierarchy
Eco.Persistence.Evolutor.TBoldScriptOperation
    Eco.Persistence.Evolutor.TBoldDropIndex
File

BoldDbEvolutorScript.cs

See Also
Inheritance Hierarchy


TBoldDropIndex.TBoldDropIndex Constructor

TBoldDropIndex.TBoldDropIndex Constructor
TBoldDropIndex Class Eco.Persistence.Evolutor Namespace See Also
Collapse All
C#
public TBoldDropIndex(
    TBoldDataBaseEvolutorScript script,
    string indexName,
    string tableName
);
Remarks

This is TBoldDropIndex, a member of class TBoldDropIndex.

See Also
TBoldDropIndex Class
Eco.Persistence.Evolutor Namespace


TBoldDropIndex Methods

TBoldDropIndex Methods
Public Methods
Collapse All

The methods of the TBoldDropIndex class are listed here.

Public Methods
Name | Description
Execute | This is Execute, a member of class TBoldDropIndex.


TBoldDropIndex.Execute Method

TBoldDropIndex.Execute Method
TBoldDropIndex Class Eco.Persistence.Evolutor Namespace See Also
Collapse All
C#
public void Execute();
Remarks

This is Execute, a member of class TBoldDropIndex.

See Also
TBoldDropIndex Class
Eco.Persistence.Evolutor Namespace


TBoldDropIndex Properties

TBoldDropIndex Properties
Public Properties
Collapse All

The properties of the TBoldDropIndex class are listed here.

Public Properties
Name | Description
IndexName | This is IndexName, a member of class TBoldDropIndex.
TableName | This is TableName, a member of class TBoldDropIndex.


TBoldDropIndex.IndexName Property

TBoldDropIndex.IndexName Property
TBoldDropIndex Class Eco.Persistence.Evolutor Namespace See Also
Collapse All
C#
public string IndexName;
Remarks

This is IndexName, a member of class TBoldDropIndex.

See Also
TBoldDropIndex Class
Eco.Persistence.Evolutor Namespace


TBoldDropIndex.TableName Property

TBoldDropIndex.TableName Property
TBoldDropIndex Class Eco.Persistence.Evolutor Namespace See Also
Collapse All
C#
public string TableName;
Remarks

This is TableName, a member of class TBoldDropIndex.

See Also
TBoldDropIndex Class
Eco.Persistence.Evolutor Namespace


TBoldDropTable Class

TBoldDropTable Class
Inheritance Hierarchy See Also
Collapse All
C#
public class TBoldDropTable : TBoldScriptOperation;
Remarks

This is class Eco.Persistence.Evolutor.TBoldDropTable.

Inheritance Hierarchy
Eco.Persistence.Evolutor.TBoldScriptOperation
    Eco.Persistence.Evolutor.TBoldDropTable
File

BoldDbEvolutorScript.cs

See Also
Inheritance Hierarchy


TBoldDropTable.TBoldDropTable Constructor

TBoldDropTable.TBoldDropTable Constructor
TBoldDropTable Class Eco.Persistence.Evolutor Namespace See Also
Collapse All
C#
public TBoldDropTable(
    TBoldDataBaseEvolutorScript script,
    string tableName
);
Remarks

This is TBoldDropTable, a member of class TBoldDropTable.

See Also
TBoldDropTable Class
Eco.Persistence.Evolutor Namespace


TBoldDropTable Methods

TBoldDropTable Methods
Public Methods
Collapse All

The methods of the TBoldDropTable class are listed here.

Public Methods
Name | Description
Execute | This is Execute, a member of class TBoldDropTable.


TBoldDropTable.Execute Method

TBoldDropTable.Execute Method
TBoldDropTable Class Eco.Persistence.Evolutor Namespace See Also
Collapse All
C#
public void Execute();
Remarks

This is Execute, a member of class TBoldDropTable.

See Also
TBoldDropTable Class
Eco.Persistence.Evolutor Namespace


TBoldDropTable Properties

TBoldDropTable Properties
Public Properties
Collapse All

The properties of the TBoldDropTable class are listed here.

Public Properties
Name | Description
TableName | This is TableName, a member of class TBoldDropTable.


TBoldDropTable.TableName Property

TBoldDropTable.TableName Property
TBoldDropTable Class Eco.Persistence.Evolutor Namespace See Also
Collapse All
C#
public string TableName;
Remarks

This is TableName, a member of class TBoldDropTable.

See Also
TBoldDropTable Class
Eco.Persistence.Evolutor Namespace


TBoldMoveData Class

TBoldMoveData Class
Inheritance Hierarchy See Also
Collapse All
C#
public class TBoldMoveData : TBoldTwoColumnOperation, IComparable;
Remarks

This is class Eco.Persistence.Evolutor.TBoldMoveData.

Inheritance Hierarchy
Eco.Persistence.Evolutor.TBoldScriptOperation
    Eco.Persistence.Evolutor.TBoldTwoTableOperation
        Eco.Persistence.Evolutor.TBoldTwoColumnOperation
            Eco.Persistence.Evolutor.TBoldMoveData
File

BoldDbEvolutorScript.cs

See Also
Inheritance Hierarchy


TBoldMoveData.TBoldMoveData Constructor

TBoldMoveData.TBoldMoveData Constructor
TBoldMoveData Class Eco.Persistence.Evolutor Namespace See Also
Collapse All
C#
public TBoldMoveData(
    TBoldDataBaseEvolutorScript script,
    AliasDefinition sourceAlias,
    AliasDefinition targetAlias,
    string sourceColumn,
    string targetColumn,
    ClassDefinition targetClassDef
);
Remarks

This is TBoldMoveData, a member of class TBoldMoveData.

See Also
TBoldMoveData Class
Eco.Persistence.Evolutor Namespace


TBoldMoveData Methods

TBoldMoveData Methods
Public Methods
Collapse All

The methods of the TBoldMoveData class are listed here.

Public Methods
Name | Description
CompareTo | This is CompareTo, a member of class TBoldMoveData.
Execute | This is Execute, a member of class TBoldMoveData.


TBoldMoveData.CompareTo Method

TBoldMoveData.CompareTo Method
TBoldMoveData Class Eco.Persistence.Evolutor Namespace See Also
Collapse All
C#
public int CompareTo(
    object o
);
Remarks

This is CompareTo, a member of class TBoldMoveData.

See Also
TBoldMoveData Class
Eco.Persistence.Evolutor Namespace


TBoldMoveData.Execute Method

TBoldMoveData.Execute Method
TBoldMoveData Class Eco.Persistence.Evolutor Namespace See Also
Collapse All
C#
public void Execute();
Remarks

This is Execute, a member of class TBoldMoveData.

See Also
TBoldMoveData Class
Eco.Persistence.Evolutor Namespace


TBoldMoveData Properties

TBoldMoveData Properties
Public Properties
Collapse All

The properties of the TBoldMoveData class are listed here.

Public Properties
Name | Description
AlsoMoveData | This is AlsoMoveData, a member of class TBoldMoveData.
Signature | This is Signature, a member of class TBoldMoveData.
TargetClassDef | This is TargetClassDef, a member of class TBoldMoveData.


TBoldMoveData.AlsoMoveData Property

TBoldMoveData.AlsoMoveData Property
TBoldMoveData Class Eco.Persistence.Evolutor Namespace See Also
Collapse All
C#
public TBoldMoveData AlsoMoveData;
Remarks

This is AlsoMoveData, a member of class TBoldMoveData.

See Also
TBoldMoveData Class
Eco.Persistence.Evolutor Namespace


TBoldMoveData.Signature Property

TBoldMoveData.Signature Property
TBoldMoveData Class Eco.Persistence.Evolutor Namespace See Also
Collapse All
C#
public string Signature;
Remarks

This is Signature, a member of class TBoldMoveData.

See Also
TBoldMoveData Class
Eco.Persistence.Evolutor Namespace


TBoldMoveData.TargetClassDef Property

TBoldMoveData.TargetClassDef Property
TBoldMoveData Class Eco.Persistence.Evolutor Namespace See Also
Collapse All
C#
public ClassDefinition TargetClassDef;
Remarks

This is TargetClassDef, a member of class TBoldMoveData.

See Also
TBoldMoveData Class
Eco.Persistence.Evolutor Namespace


TBoldScriptOperation Class

TBoldScriptOperation Class
Inheritance Hierarchy See Also
Collapse All
C#
public class TBoldScriptOperation;
Remarks

This is class Eco.Persistence.Evolutor.TBoldScriptOperation.

Inheritance Hierarchy
Eco.Persistence.Evolutor.TBoldScriptOperation
    Eco.Persistence.Evolutor.TBoldAddColumn
    Eco.Persistence.Evolutor.TBoldAddTable
    Eco.Persistence.Evolutor.TBoldDropColumn
    Eco.Persistence.Evolutor.TBoldDropIndex
    Eco.Persistence.Evolutor.TBoldDropTable
    Eco.Persistence.Evolutor.TBoldTableOperation
    Eco.Persistence.Evolutor.TBoldTwoTableOperation
File

BoldDbEvolutorScript.cs

See Also
Inheritance Hierarchy


TBoldScriptOperation.TBoldScriptOperation Constructor

TBoldScriptOperation.TBoldScriptOperation Constructor
TBoldScriptOperation Class Eco.Persistence.Evolutor Namespace See Also
Collapse All
C#
public TBoldScriptOperation(
    TBoldDataBaseEvolutorScript script
);
Remarks

This is TBoldScriptOperation, a member of class TBoldScriptOperation.

See Also
TBoldScriptOperation Class
Eco.Persistence.Evolutor Namespace


TBoldScriptOperation Methods

TBoldScriptOperation Methods
Protected Methods
Collapse All

The methods of the TBoldScriptOperation class are listed here.

Protected Methods
Name | Description
QuoteName | This is QuoteName, a member of class TBoldScriptOperation.


TBoldScriptOperation.QuoteName Method

TBoldScriptOperation.QuoteName Method
TBoldScriptOperation Class Eco.Persistence.Evolutor Namespace See Also
Collapse All
C#
protected string QuoteName(
    string name
);
Remarks

This is QuoteName, a member of class TBoldScriptOperation.

See Also
TBoldScriptOperation Class
Eco.Persistence.Evolutor Namespace


TBoldScriptOperation Properties

TBoldScriptOperation Properties
Protected Properties
Collapse All

The properties of the TBoldScriptOperation class are listed here.

Protected Properties
Name | Description
Script | This is Script, a member of class TBoldScriptOperation.


TBoldScriptOperation.Script Property

TBoldScriptOperation.Script Property
TBoldScriptOperation Class Eco.Persistence.Evolutor Namespace See Also
Collapse All
C#
protected TBoldDataBaseEvolutorScript Script;
Remarks

This is Script, a member of class TBoldScriptOperation.

See Also
TBoldScriptOperation Class
Eco.Persistence.Evolutor Namespace


TBoldTableOperation Class

TBoldTableOperation Class
Inheritance Hierarchy See Also
Collapse All
C#
public class TBoldTableOperation : TBoldScriptOperation;
Remarks

TBoldTableOperation

Inheritance Hierarchy
Eco.Persistence.Evolutor.TBoldScriptOperation
    Eco.Persistence.Evolutor.TBoldTableOperation
        Eco.Persistence.Evolutor.TBoldDeleteInstances
File

BoldDbEvolutorScript.cs

See Also
Inheritance Hierarchy


TBoldTableOperation.TBoldTableOperation Constructor

TBoldTableOperation.TBoldTableOperation Constructor
TBoldTableOperation Class Eco.Persistence.Evolutor Namespace See Also
Collapse All
C#
public TBoldTableOperation(
    TBoldDataBaseEvolutorScript script,
    AliasDefinition alias
);
Remarks

This is TBoldTableOperation, a member of class TBoldTableOperation.

See Also
TBoldTableOperation Class
Eco.Persistence.Evolutor Namespace


TBoldTableOperation Properties

TBoldTableOperation Properties
Public Properties
Collapse All

The properties of the TBoldTableOperation class are listed here.

Public Properties
Name | Description
Alias | This is Alias, a member of class TBoldTableOperation.


TBoldTableOperation.Alias Property

TBoldTableOperation.Alias Property
TBoldTableOperation Class Eco.Persistence.Evolutor Namespace See Also
Collapse All
C#
public AliasDefinition Alias;
Remarks

This is Alias, a member of class TBoldTableOperation.

See Also
TBoldTableOperation Class
Eco.Persistence.Evolutor Namespace


TBoldTwoColumnOperation Class

TBoldTwoColumnOperation Class
Inheritance Hierarchy See Also
Collapse All
C#
public class TBoldTwoColumnOperation : TBoldTwoTableOperation;
Remarks

This is class Eco.Persistence.Evolutor.TBoldTwoColumnOperation.

Inheritance Hierarchy
Eco.Persistence.Evolutor.TBoldScriptOperation
    Eco.Persistence.Evolutor.TBoldTwoTableOperation
        Eco.Persistence.Evolutor.TBoldTwoColumnOperation
            Eco.Persistence.Evolutor.TBoldMoveData
File

BoldDbEvolutorScript.cs

See Also
Inheritance Hierarchy


TBoldTwoColumnOperation.TBoldTwoColumnOperation Constructor

TBoldTwoColumnOperation.TBoldTwoColumnOperation Constructor
TBoldTwoColumnOperation Class Eco.Persistence.Evolutor Namespace See Also
Collapse All
C#
public TBoldTwoColumnOperation(
    TBoldDataBaseEvolutorScript script,
    AliasDefinition sourceAlias,
    AliasDefinition targetAlias,
    string sourceColumn,
    string targetColumn
);
Remarks

This is TBoldTwoColumnOperation, a member of class TBoldTwoColumnOperation.

See Also
TBoldTwoColumnOperation Class
Eco.Persistence.Evolutor Namespace


TBoldTwoColumnOperation Properties

TBoldTwoColumnOperation Properties
Public Properties
Collapse All

The properties of the TBoldTwoColumnOperation class are listed here.

Public Properties
Name | Description
SourceColumn | This is SourceColumn, a member of class TBoldTwoColumnOperation.
TargetColumn | This is TargetColumn, a member of class TBoldTwoColumnOperation.


TBoldTwoColumnOperation.SourceColumn Property

TBoldTwoColumnOperation.SourceColumn Property
TBoldTwoColumnOperation Class Eco.Persistence.Evolutor Namespace See Also
Collapse All
C#
public string SourceColumn;
Remarks

This is SourceColumn, a member of class TBoldTwoColumnOperation.

See Also
TBoldTwoColumnOperation Class
Eco.Persistence.Evolutor Namespace


TBoldTwoColumnOperation.TargetColumn Property

TBoldTwoColumnOperation.TargetColumn Property
TBoldTwoColumnOperation Class Eco.Persistence.Evolutor Namespace See Also
Collapse All
C#
public string TargetColumn;
Remarks

This is TargetColumn, a member of class TBoldTwoColumnOperation.

See Also
TBoldTwoColumnOperation Class
Eco.Persistence.Evolutor Namespace


TBoldTwoTableOperation Class

TBoldTwoTableOperation Class
Inheritance Hierarchy See Also
Collapse All
C#
public class TBoldTwoTableOperation : TBoldScriptOperation;
Remarks

This is class Eco.Persistence.Evolutor.TBoldTwoTableOperation.

Inheritance Hierarchy
Eco.Persistence.Evolutor.TBoldScriptOperation
    Eco.Persistence.Evolutor.TBoldTwoTableOperation
        Eco.Persistence.Evolutor.TBoldCopyInstances
        Eco.Persistence.Evolutor.TBoldTwoColumnOperation
File

BoldDbEvolutorScript.cs

See Also
Inheritance Hierarchy


TBoldTwoTableOperation.TBoldTwoTableOperation Constructor

TBoldTwoTableOperation.TBoldTwoTableOperation Constructor
TBoldTwoTableOperation Class Eco.Persistence.Evolutor Namespace See Also
Collapse All
C#
public TBoldTwoTableOperation(
    TBoldDataBaseEvolutorScript script,
    AliasDefinition sourceAlias,
    AliasDefinition targetAlias
);
Remarks

This is TBoldTwoTableOperation, a member of class TBoldTwoTableOperation.

See Also
TBoldTwoTableOperation Class
Eco.Persistence.Evolutor Namespace


TBoldTwoTableOperation Properties

TBoldTwoTableOperation Properties
Public Properties
Collapse All

The properties of the TBoldTwoTableOperation class are listed here.

Public Properties
Name | Description
SourceAlias | This is SourceAlias, a member of class TBoldTwoTableOperation.
TargetAlias | This is TargetAlias, a member of class TBoldTwoTableOperation.


TBoldTwoTableOperation.SourceAlias Property

TBoldTwoTableOperation.SourceAlias Property
TBoldTwoTableOperation Class Eco.Persistence.Evolutor Namespace See Also
Collapse All
C#
public AliasDefinition SourceAlias;
Remarks

This is SourceAlias, a member of class TBoldTwoTableOperation.

See Also
TBoldTwoTableOperation Class
Eco.Persistence.Evolutor Namespace


TBoldTwoTableOperation.TargetAlias Property

TBoldTwoTableOperation.TargetAlias Property
TBoldTwoTableOperation Class Eco.Persistence.Evolutor Namespace See Also
Collapse All
C#
public AliasDefinition TargetAlias;
Remarks

This is TargetAlias, a member of class TBoldTwoTableOperation.

See Also
TBoldTwoTableOperation Class
Eco.Persistence.Evolutor Namespace


Eco.Persistence.Evolutor.TBoldMemberMappingPairAction Type

Eco.Persistence.Evolutor.TBoldMemberMappingPairAction Type
C#
public delegate void TBoldMemberMappingPairAction(ClassDefinition NewClassDef, ClassDefinition OldClassDef, StructuralFeatureDefinition NewMemberMapping, StructuralFeatureDefinition OldMemberMapping, IList<string> Param);
Remarks

This is type Eco.Persistence.Evolutor.TBoldMemberMappingPairAction.

File

BoldDbEvolutor.cs


Eco.Persistence.Firebird Namespace

Eco.Persistence.Firebird Namespace
Classes
Collapse All

This is namespace Eco.Persistence.Firebird.

Classes
Name | Description
ByteArrayAsBlob | This is class Eco.Persistence.Firebird.ByteArrayAsBlob.
DecimalAsDecimal | This is class Eco.Persistence.Firebird.DecimalAsDecimal.
StringAsBlob | This is class Eco.Persistence.Firebird.StringAsBlob.


ByteArrayAsBlob Class

ByteArrayAsBlob Class
Inheritance Hierarchy See Also
Collapse All
C#
public class ByteArrayAsBlob : AbstractSingleColumnAttribute, ISingleColumnAttributemapping, IDefaultReverseMapping;
Remarks

This is class Eco.Persistence.Firebird.ByteArrayAsBlob.

Inheritance Hierarchy
Eco.Persistence.IDefaultReverseMapping
Eco.Persistence.ISingleColumnAttributemapping
    Eco.Persistence.Firebird.ByteArrayAsBlob
File

FirebirdAttributeMappers.cs

See Also
Inheritance Hierarchy


ByteArrayAsBlob.ColumnToValue Method

ByteArrayAsBlob.ColumnToValue Method
ByteArrayAsBlob Class Eco.Persistence.Firebird Namespace See Also
Collapse All

Converts a value that comes from a database query to an ecospace value.

C#
public override System.Object ColumnToValue(
    System.Object columnValue
);
Remarks

In many cases, the implementation of this method mainly converts DBNull-values to null, but it can also change the CLR-type of the database value from for example a char[] to a string. or from an integer to a boolean. This is the reverse operation of ValueToParameter.

See Also
ByteArrayAsBlob Class
Eco.Persistence.Firebird Namespace


ByteArrayAsBlob.ColumnType Method

ByteArrayAsBlob.ColumnType Method
ByteArrayAsBlob Class Eco.Persistence.Firebird Namespace See Also
Collapse All

Specifies the SQL type of the column.

C#
public String ColumnType(
    int length
);
See Also
ByteArrayAsBlob Class
Eco.Persistence.Firebird Namespace


ByteArrayAsBlob.DefaultDbValue Method

ByteArrayAsBlob.DefaultDbValue Method
ByteArrayAsBlob Class Eco.Persistence.Firebird Namespace See Also
Collapse All

The return value of this function will be used as default value for new columns when databases are created/evolved.

C#
public String DefaultDbValue(
    string modeledValue,
    SqlDatabaseConfig sqlDatabaseConfig
);
See Also
ByteArrayAsBlob Class
Eco.Persistence.Firebird Namespace


ByteArrayAsBlob.IsEqual Method

ByteArrayAsBlob.IsEqual Method
ByteArrayAsBlob Class Eco.Persistence.Firebird Namespace See Also
Collapse All

Returns true if an ecospace value ("value") is equal to a database value ("columnValue").

C#
public override bool IsEqual(
    System.Object value,
    System.Object columnValue
);
Remarks

This method must handle the conversions between ecospace and database values, it must also handle comparing null/DBNull values.

See Also
ByteArrayAsBlob Class
Eco.Persistence.Firebird Namespace


ByteArrayAsBlob.StringToParameter Method

ByteArrayAsBlob.StringToParameter Method
ByteArrayAsBlob Class Eco.Persistence.Firebird Namespace See Also
Collapse All
C#
public void StringToParameter(
    string value,
    IDataParameter parameter
);
Exceptions
Exceptions | Description
InvalidOperationException | Thrown always.
See Also
ByteArrayAsBlob Class
Eco.Persistence.Firebird Namespace


ByteArrayAsBlob.ValueToParameter Method

ByteArrayAsBlob.ValueToParameter Method
ByteArrayAsBlob Class Eco.Persistence.Firebird Namespace See Also
Collapse All

Converts a value that comes from a database query to an ecospace value.

C#
public void ValueToParameter(
    System.Object value,
    IDataParameter parameter
);
Remarks

In many cases, the implementation of this method mainly converts null to DBNull, but it can also handle conversion from for example booleans to integers, byte[] to database blobs. It also has to set the correct parameter types in the IDataParameter-object. This is the reverse operation of ColumnToValue.

See Also
ByteArrayAsBlob Class
Eco.Persistence.Firebird Namespace


ByteArrayAsBlob.ValueType Method

ByteArrayAsBlob.ValueType Method
ByteArrayAsBlob Class Eco.Persistence.Firebird Namespace See Also
Collapse All

This method returns the type of the value that is returned by ColumnToValue.

C#
public System.Type ValueType();
See Also
ByteArrayAsBlob Class
Eco.Persistence.Firebird Namespace


DecimalAsDecimal Class

DecimalAsDecimal Class
Inheritance Hierarchy See Also
Collapse All
C#
public sealed class DecimalAsDecimal : AbstractNumericSingleColumnAttribute, ISingleColumnAttributemapping, IDefaultReverseMapping;
Remarks

This is class Eco.Persistence.Firebird.DecimalAsDecimal.

Inheritance Hierarchy
Eco.Persistence.IDefaultReverseMapping
Eco.Persistence.ISingleColumnAttributemapping
    Eco.Persistence.Firebird.DecimalAsDecimal
File

FirebirdAttributeMappers.cs

See Also
Inheritance Hierarchy


DecimalAsDecimal.ColumnToValue Method

DecimalAsDecimal.ColumnToValue Method
DecimalAsDecimal Class Eco.Persistence.Firebird Namespace See Also
Collapse All

Converts a value that comes from a database query to an ecospace value.

C#
public override System.Object ColumnToValue(
    System.Object columnValue
);
Remarks

In many cases, the implementation of this method mainly converts DBNull-values to null, but it can also change the CLR-type of the database value from for example a char[] to a string. or from an integer to a boolean. This is the reverse operation of ValueToParameter.

See Also
DecimalAsDecimal Class
Eco.Persistence.Firebird Namespace


DecimalAsDecimal.ColumnType Method

DecimalAsDecimal.ColumnType Method
DecimalAsDecimal Class Eco.Persistence.Firebird Namespace See Also
Collapse All

Specifies the SQL type of the column.

C#
public String ColumnType(
    int length
);
See Also
DecimalAsDecimal Class
Eco.Persistence.Firebird Namespace


DecimalAsDecimal.StringToParameter Method

DecimalAsDecimal.StringToParameter Method
DecimalAsDecimal Class Eco.Persistence.Firebird Namespace See Also
Collapse All
C#
public void StringToParameter(
    string value,
    IDataParameter parameter
);
Remarks

This is StringToParameter, a member of class DecimalAsDecimal.

See Also
DecimalAsDecimal Class
Eco.Persistence.Firebird Namespace


DecimalAsDecimal.ValueToParameter Method

DecimalAsDecimal.ValueToParameter Method
DecimalAsDecimal Class Eco.Persistence.Firebird Namespace See Also
Collapse All

Converts a value that comes from a database query to an ecospace value.

C#
public void ValueToParameter(
    System.Object value,
    IDataParameter parameter
);
Remarks

In many cases, the implementation of this method mainly converts null to DBNull, but it can also handle conversion from for example booleans to integers, byte[] to database blobs. It also has to set the correct parameter types in the IDataParameter-object. This is the reverse operation of ColumnToValue.

See Also
DecimalAsDecimal Class
Eco.Persistence.Firebird Namespace


DecimalAsDecimal.ValueType Method

DecimalAsDecimal.ValueType Method
DecimalAsDecimal Class Eco.Persistence.Firebird Namespace See Also
Collapse All

This method returns the type of the value that is returned by ColumnToValue.

C#
public System.Type ValueType();
See Also
DecimalAsDecimal Class
Eco.Persistence.Firebird Namespace


StringAsBlob Class

StringAsBlob Class
Inheritance Hierarchy See Also
Collapse All
C#
public class StringAsBlob : AbstractSingleColumnAttribute, ISingleColumnAttributemapping, IDefaultReverseMapping;
Remarks

This is class Eco.Persistence.Firebird.StringAsBlob.

Inheritance Hierarchy
Eco.Persistence.IDefaultReverseMapping
Eco.Persistence.ISingleColumnAttributemapping
    Eco.Persistence.Firebird.StringAsBlob
File

FirebirdAttributeMappers.cs

See Also
Inheritance Hierarchy


StringAsBlob Methods

StringAsBlob Methods
Public Methods
Collapse All

The methods of the StringAsBlob class are listed here.

Public Methods
Name | Description
ColumnToValue | Converts a value that comes from a database query to an ecospace value.
ColumnType | Specifies the SQL type of the column.
DefaultDbValue | The return value of this function will be used as default value for new columns when databases are created/evolved.
StringToParameter |
ValueToParameter | Converts a value that comes from a database query to an ecospace value.
ValueType | This method returns the type of the value that is returned by ColumnToValue.


StringAsBlob.ColumnToValue Method

StringAsBlob.ColumnToValue Method
StringAsBlob Class Eco.Persistence.Firebird Namespace See Also
Collapse All

Converts a value that comes from a database query to an ecospace value.

C#
public override System.Object ColumnToValue(
    System.Object columnValue
);
Remarks

In many cases, the implementation of this method mainly converts DBNull-values to null, but it can also change the CLR-type of the database value from for example a char[] to a string. or from an integer to a boolean. This is the reverse operation of ValueToParameter.

See Also
StringAsBlob Class
Eco.Persistence.Firebird Namespace


StringAsBlob.ColumnType Method

StringAsBlob.ColumnType Method
StringAsBlob Class Eco.Persistence.Firebird Namespace See Also
Collapse All

Specifies the SQL type of the column.

C#
public String ColumnType(
    int length
);
See Also
StringAsBlob Class
Eco.Persistence.Firebird Namespace


StringAsBlob.DefaultDbValue Method

StringAsBlob.DefaultDbValue Method
StringAsBlob Class Eco.Persistence.Firebird Namespace See Also
Collapse All

The return value of this function will be used as default value for new columns when databases are created/evolved.

C#
public String DefaultDbValue(
    string modeledValue,
    SqlDatabaseConfig sqlDatabaseConfig
);
See Also
StringAsBlob Class
Eco.Persistence.Firebird Namespace


StringAsBlob.StringToParameter Method

StringAsBlob.StringToParameter Method
StringAsBlob Class Eco.Persistence.Firebird Namespace See Also
Collapse All
C#
public void StringToParameter(
    string value,
    IDataParameter parameter
);
Exceptions
Exceptions | Description
InvalidOperationException | Thrown always.
See Also
StringAsBlob Class
Eco.Persistence.Firebird Namespace


StringAsBlob.ValueToParameter Method

StringAsBlob.ValueToParameter Method
StringAsBlob Class Eco.Persistence.Firebird Namespace See Also
Collapse All

Converts a value that comes from a database query to an ecospace value.

C#
public void ValueToParameter(
    System.Object value,
    IDataParameter parameter
);
Remarks

In many cases, the implementation of this method mainly converts null to DBNull, but it can also handle conversion from for example booleans to integers, byte[] to database blobs. It also has to set the correct parameter types in the IDataParameter-object. This is the reverse operation of ColumnToValue.

See Also
StringAsBlob Class
Eco.Persistence.Firebird Namespace


StringAsBlob.ValueType Method

StringAsBlob.ValueType Method
StringAsBlob Class Eco.Persistence.Firebird Namespace See Also
Collapse All

This method returns the type of the value that is returned by ColumnToValue.

C#
public System.Type ValueType();
See Also
StringAsBlob Class
Eco.Persistence.Firebird Namespace


Eco.Persistence.Interbase Namespace

Eco.Persistence.Interbase Namespace
Classes
Collapse All

This is namespace Eco.Persistence.Interbase.

Classes
Name | Description
AbstractAutoInc | Base class mapper between an AutoInc value and its persistent representation. This class must be inherited.
BooleanAsBoolean | This is class Eco.Persistence.Interbase.BooleanAsBoolean.
ByteArrayAsBdpBlob | Mapper between a ByteArray value and its persistent representation as BLOB.
CharAsNCharUnicode | This is class Eco.Persistence.Interbase.CharAsNCharUnicode.
DecimalAsDecimal | This is class Eco.Persistence.Interbase.DecimalAsDecimal.
Int16AsAutoInc | This is class Eco.Persistence.Interbase.Int16AsAutoInc.
Int32AsAutoInc | This is class Eco.Persistence.Interbase.Int32AsAutoInc.
Int64AsLongInteger | This is class Eco.Persistence.Interbase.Int64AsLongInteger.
StringAsBdpBlob | This is class Eco.Persistence.Interbase.StringAsBdpBlob.
StringAsNCharUnicode | This is class Eco.Persistence.Interbase.StringAsNCharUnicode.


AbstractAutoInc Class

AbstractAutoInc Class
Inheritance Hierarchy See Also
Collapse All

Base class mapper between an AutoInc value and its persistent representation. This class must be inherited.

C#
public abstract class AbstractAutoInc : AbstractNumericSingleColumnAttribute;
Inheritance Hierarchy
Eco.Persistence.Interbase.AbstractAutoInc
    Eco.Persistence.Interbase.Int16AsAutoInc
    Eco.Persistence.Interbase.Int32AsAutoInc
File

InterbaseAttributeMappers.cs

See Also
Inheritance Hierarchy


AbstractAutoInc Methods

AbstractAutoInc Methods
Public Methods
Collapse All

The methods of the AbstractAutoInc class are listed here.

Public Methods
Name | Description
MakeColumnAutoInc |
StringToParameter | This method should never be called. Autoinc values are never stored!
ValueToParameter | this method should never be called. Autoinc values are never stored!


AbstractAutoInc.MakeColumnAutoInc Method

AbstractAutoInc.MakeColumnAutoInc Method
AbstractAutoInc Class Eco.Persistence.Interbase Namespace See Also
Collapse All
C#
public void MakeColumnAutoInc(
    string tableName,
    string columnName,
    IDatabase database
);
Exceptions
Exceptions | Description
ArgumentNullException | Thrown if database is null
See Also
AbstractAutoInc Class
Eco.Persistence.Interbase Namespace


AbstractAutoInc.StringToParameter Method

AbstractAutoInc.StringToParameter Method
AbstractAutoInc Class Eco.Persistence.Interbase Namespace See Also
Collapse All

This method should never be called. Autoinc values are never stored!

C#
public void StringToParameter(
    string value,
    IDataParameter parameter
);
Exceptions
Exceptions | Description
NotSupportedException | Thrown always.
See Also
AbstractAutoInc Class
Eco.Persistence.Interbase Namespace


AbstractAutoInc.ValueToParameter Method

AbstractAutoInc.ValueToParameter Method
AbstractAutoInc Class Eco.Persistence.Interbase Namespace See Also
Collapse All

this method should never be called. Autoinc values are never stored!

C#
public void ValueToParameter(
    System.Object value,
    IDataParameter parameter
);
Exceptions
Exceptions | Description
NotSupportedException | Thrown always.
See Also
AbstractAutoInc Class
Eco.Persistence.Interbase Namespace


BooleanAsBoolean Class

BooleanAsBoolean Class
Inheritance Hierarchy See Also
Collapse All
C#
public sealed class BooleanAsBoolean : AbstractSingleColumnAttribute, ISingleColumnAttributemapping, INonBooleanBooleanMapping, IDefaultReverseMapping;
Remarks

This is class Eco.Persistence.Interbase.BooleanAsBoolean.

Inheritance Hierarchy
Eco.Persistence.IDefaultReverseMapping
Eco.Persistence.INonBooleanBooleanMapping
Eco.Persistence.ISingleColumnAttributemapping
    Eco.Persistence.Interbase.BooleanAsBoolean
File

InterbaseAttributeMappers.cs

See Also
Inheritance Hierarchy


BooleanAsBoolean.ColumnToValue Method

BooleanAsBoolean.ColumnToValue Method
BooleanAsBoolean Class Eco.Persistence.Interbase Namespace See Also
Collapse All

Converts a value that comes from a database query to an ecospace value.

C#
public override System.Object ColumnToValue(
    System.Object columnValue
);
Remarks

In many cases, the implementation of this method mainly converts DBNull-values to null, but it can also change the CLR-type of the database value from for example a char[] to a string. or from an integer to a boolean. This is the reverse operation of ValueToParameter.

See Also
BooleanAsBoolean Class
Eco.Persistence.Interbase Namespace


BooleanAsBoolean.ColumnType Method

BooleanAsBoolean.ColumnType Method
BooleanAsBoolean Class Eco.Persistence.Interbase Namespace See Also
Collapse All

Specifies the SQL type of the column.

C#
public String ColumnType(
    int length
);
See Also
BooleanAsBoolean Class
Eco.Persistence.Interbase Namespace


BooleanAsBoolean.DefaultDbValue Method

BooleanAsBoolean.DefaultDbValue Method
BooleanAsBoolean Class Eco.Persistence.Interbase Namespace See Also
Collapse All

The return value of this function will be used as default value for new columns when databases are created/evolved.

C#
public String DefaultDbValue(
    string modeledValue,
    SqlDatabaseConfig sqlDatabaseConfig
);
See Also
BooleanAsBoolean Class
Eco.Persistence.Interbase Namespace


BooleanAsBoolean.StringToParameter Method

BooleanAsBoolean.StringToParameter Method
BooleanAsBoolean Class Eco.Persistence.Interbase Namespace See Also
Collapse All
C#
public void StringToParameter(
    string value,
    IDataParameter parameter
);
Remarks

This is StringToParameter, a member of class BooleanAsBoolean.

See Also
BooleanAsBoolean Class
Eco.Persistence.Interbase Namespace


BooleanAsBoolean.ValueToParameter Method

BooleanAsBoolean.ValueToParameter Method
BooleanAsBoolean Class Eco.Persistence.Interbase Namespace See Also
Collapse All

Converts a value that comes from a database query to an ecospace value.

C#
public void ValueToParameter(
    System.Object value,
    IDataParameter parameter
);
Remarks

In many cases, the implementation of this method mainly converts null to DBNull, but it can also handle conversion from for example booleans to integers, byte[] to database blobs. It also has to set the correct parameter types in the IDataParameter-object. This is the reverse operation of ColumnToValue.

See Also
BooleanAsBoolean Class
Eco.Persistence.Interbase Namespace


BooleanAsBoolean.ValueType Method

BooleanAsBoolean.ValueType Method
BooleanAsBoolean Class Eco.Persistence.Interbase Namespace See Also
Collapse All

This method returns the type of the value that is returned by ColumnToValue.

C#
public System.Type ValueType();
See Also
BooleanAsBoolean Class
Eco.Persistence.Interbase Namespace


BooleanAsBoolean Properties

BooleanAsBoolean Properties
Public Properties
Collapse All

The properties of the BooleanAsBoolean class are listed here.

Public Properties
Name | Description
TrueString | Returns the string representation for the "true" value.


BooleanAsBoolean.TrueString Property

BooleanAsBoolean.TrueString Property
BooleanAsBoolean Class Eco.Persistence.Interbase Namespace See Also
Collapse All

Returns the string representation for the "true" value.

C#
public string TrueString;
Remarks

This could be for example "true", "1", "y" depending on how the value "true" is stored.

See Also
BooleanAsBoolean Class
Eco.Persistence.Interbase Namespace


ByteArrayAsBdpBlob Class

ByteArrayAsBdpBlob Class
Inheritance Hierarchy See Also
Collapse All

Mapper between a ByteArray value and its persistent representation as BLOB.

C#
public sealed class ByteArrayAsBdpBlob : AbstractSingleColumnAttribute, ISingleColumnAttributemapping;
Inheritance Hierarchy
Eco.Persistence.ISingleColumnAttributemapping
    Eco.Persistence.Interbase.ByteArrayAsBdpBlob
File

InterbaseAttributeMappersBdp.cs

See Also
Inheritance Hierarchy


ByteArrayAsBdpBlob Methods

ByteArrayAsBdpBlob Methods
Public Methods
Collapse All

The methods of the ByteArrayAsBdpBlob class are listed here.

Public Methods
Name | Description
ColumnToValue | Converts a value that comes from a database query to an ecospace value.
ColumnType | Specifies the SQL type of the column.
DefaultDbValue | The return value of this function will be used as default value for new columns when databases are created/evolved.
IsEqual | Returns true if an ecospace value ("value") is equal to a database value ("columnValue").
StringToParameter |
ValueToParameter | Converts a value that comes from a database query to an ecospace value.
ValueType | This method returns the type of the value that is returned by ColumnToValue.


ByteArrayAsBdpBlob.ColumnToValue Method

ByteArrayAsBdpBlob.ColumnToValue Method
ByteArrayAsBdpBlob Class Eco.Persistence.Interbase Namespace See Also
Collapse All

Converts a value that comes from a database query to an ecospace value.

C#
public override System.Object ColumnToValue(
    System.Object columnValue
);
Remarks

In many cases, the implementation of this method mainly converts DBNull-values to null, but it can also change the CLR-type of the database value from for example a char[] to a string. or from an integer to a boolean. This is the reverse operation of ValueToParameter.

See Also
ByteArrayAsBdpBlob Class
Eco.Persistence.Interbase Namespace


ByteArrayAsBdpBlob.ColumnType Method

ByteArrayAsBdpBlob.ColumnType Method
ByteArrayAsBdpBlob Class Eco.Persistence.Interbase Namespace See Also
Collapse All

Specifies the SQL type of the column.

C#
public string ColumnType(
    int length
);
See Also
ByteArrayAsBdpBlob Class
Eco.Persistence.Interbase Namespace


ByteArrayAsBdpBlob.DefaultDbValue Method

ByteArrayAsBdpBlob.DefaultDbValue Method
ByteArrayAsBdpBlob Class Eco.Persistence.Interbase Namespace See Also
Collapse All

The return value of this function will be used as default value for new columns when databases are created/evolved.

C#
public string DefaultDbValue(
    string modeledValue,
    SqlDatabaseConfig sqlDatabaseConfig
);
See Also
ByteArrayAsBdpBlob Class
Eco.Persistence.Interbase Namespace


ByteArrayAsBdpBlob.IsEqual Method

ByteArrayAsBdpBlob.IsEqual Method
ByteArrayAsBdpBlob Class Eco.Persistence.Interbase Namespace See Also
Collapse All

Returns true if an ecospace value ("value") is equal to a database value ("columnValue").

C#
public override bool IsEqual(
    System.Object value,
    System.Object columnValue
);
Remarks

This method must handle the conversions between ecospace and database values, it must also handle comparing null/DBNull values.

See Also
ByteArrayAsBdpBlob Class
Eco.Persistence.Interbase Namespace


ByteArrayAsBdpBlob.StringToParameter Method

ByteArrayAsBdpBlob.StringToParameter Method
ByteArrayAsBdpBlob Class Eco.Persistence.Interbase Namespace See Also
Collapse All
C#
public void StringToParameter(
    string value,
    IDataParameter parameter
);
Exceptions
Exceptions | Description
InvalidOperationException | Thrown always.
See Also
ByteArrayAsBdpBlob Class
Eco.Persistence.Interbase Namespace


ByteArrayAsBdpBlob.ValueToParameter Method

ByteArrayAsBdpBlob.ValueToParameter Method
ByteArrayAsBdpBlob Class Eco.Persistence.Interbase Namespace See Also
Collapse All

Converts a value that comes from a database query to an ecospace value.

C#
public void ValueToParameter(
    System.Object value,
    IDataParameter parameter
);
Remarks

In many cases, the implementation of this method mainly converts null to DBNull, but it can also handle conversion from for example booleans to integers, byte[] to database blobs. It also has to set the correct parameter types in the IDataParameter-object. This is the reverse operation of ColumnToValue.

See Also
ByteArrayAsBdpBlob Class
Eco.Persistence.Interbase Namespace


ByteArrayAsBdpBlob.ValueType Method

ByteArrayAsBdpBlob.ValueType Method
ByteArrayAsBdpBlob Class Eco.Persistence.Interbase Namespace See Also
Collapse All

This method returns the type of the value that is returned by ColumnToValue.

C#
public System.Type ValueType();
See Also
ByteArrayAsBdpBlob Class
Eco.Persistence.Interbase Namespace


CharAsNCharUnicode Class

CharAsNCharUnicode Class
Inheritance Hierarchy See Also
Collapse All
C#
public sealed class CharAsNCharUnicode : AbstractStringSingleColumnAttribute, ISingleColumnAttributemapping;
Remarks

This is class Eco.Persistence.Interbase.CharAsNCharUnicode.

Inheritance Hierarchy
Eco.Persistence.ISingleColumnAttributemapping
    Eco.Persistence.Interbase.CharAsNCharUnicode
File

InterbaseAttributeMappers.cs

See Also
Inheritance Hierarchy


CharAsNCharUnicode Methods

CharAsNCharUnicode Methods
Public Methods
Collapse All

The methods of the CharAsNCharUnicode class are listed here.

Public Methods
Name | Description
ColumnToValue | Converts a value that comes from a database query to an ecospace value.
ColumnType | Specifies the SQL type of the column.
StringToParameter | This is StringToParameter, a member of class CharAsNCharUnicode.
ValueToParameter | Converts a value that comes from a database query to an ecospace value.
ValueType | This method returns the type of the value that is returned by ColumnToValue.


CharAsNCharUnicode.ColumnToValue Method

CharAsNCharUnicode.ColumnToValue Method
CharAsNCharUnicode Class Eco.Persistence.Interbase Namespace See Also
Collapse All

Converts a value that comes from a database query to an ecospace value.

C#
public override System.Object ColumnToValue(
    System.Object columnValue
);
Remarks

In many cases, the implementation of this method mainly converts DBNull-values to null, but it can also change the CLR-type of the database value from for example a char[] to a string. or from an integer to a boolean. This is the reverse operation of ValueToParameter.

See Also
CharAsNCharUnicode Class
Eco.Persistence.Interbase Namespace


CharAsNCharUnicode.ColumnType Method

CharAsNCharUnicode.ColumnType Method
CharAsNCharUnicode Class Eco.Persistence.Interbase Namespace See Also
Collapse All

Specifies the SQL type of the column.

C#
public string ColumnType(
    int length
);
See Also
CharAsNCharUnicode Class
Eco.Persistence.Interbase Namespace


CharAsNCharUnicode.StringToParameter Method

CharAsNCharUnicode.StringToParameter Method
CharAsNCharUnicode Class Eco.Persistence.Interbase Namespace See Also
Collapse All
C#
public void StringToParameter(
    string value,
    IDataParameter parameter
);
Remarks

This is StringToParameter, a member of class CharAsNCharUnicode.

See Also
CharAsNCharUnicode Class
Eco.Persistence.Interbase Namespace


CharAsNCharUnicode.ValueToParameter Method

CharAsNCharUnicode.ValueToParameter Method
CharAsNCharUnicode Class Eco.Persistence.Interbase Namespace See Also
Collapse All

Converts a value that comes from a database query to an ecospace value.

C#
public void ValueToParameter(
    System.Object value,
    IDataParameter parameter
);
Remarks

In many cases, the implementation of this method mainly converts null to DBNull, but it can also handle conversion from for example booleans to integers, byte[] to database blobs. It also has to set the correct parameter types in the IDataParameter-object. This is the reverse operation of ColumnToValue.

See Also
CharAsNCharUnicode Class
Eco.Persistence.Interbase Namespace


CharAsNCharUnicode.ValueType Method

CharAsNCharUnicode.ValueType Method
CharAsNCharUnicode Class Eco.Persistence.Interbase Namespace See Also
Collapse All

This method returns the type of the value that is returned by ColumnToValue.

C#
public System.Type ValueType();
See Also
CharAsNCharUnicode Class
Eco.Persistence.Interbase Namespace


DecimalAsDecimal Class

DecimalAsDecimal Class
Inheritance Hierarchy See Also
Collapse All
C#
public sealed class DecimalAsDecimal : AbstractNumericSingleColumnAttribute, ISingleColumnAttributemapping, IDefaultReverseMapping;
Remarks

This is class Eco.Persistence.Interbase.DecimalAsDecimal.

Inheritance Hierarchy
Eco.Persistence.IDefaultReverseMapping
Eco.Persistence.ISingleColumnAttributemapping
    Eco.Persistence.Interbase.DecimalAsDecimal
File

InterbaseAttributeMappers.cs

See Also
Inheritance Hierarchy


DecimalAsDecimal.ColumnToValue Method

DecimalAsDecimal.ColumnToValue Method
DecimalAsDecimal Class Eco.Persistence.Interbase Namespace See Also
Collapse All

Converts a value that comes from a database query to an ecospace value.

C#
public override System.Object ColumnToValue(
    System.Object columnValue
);
Remarks

In many cases, the implementation of this method mainly converts DBNull-values to null, but it can also change the CLR-type of the database value from for example a char[] to a string. or from an integer to a boolean. This is the reverse operation of ValueToParameter.

See Also
DecimalAsDecimal Class
Eco.Persistence.Interbase Namespace


DecimalAsDecimal.ColumnType Method

DecimalAsDecimal.ColumnType Method
DecimalAsDecimal Class Eco.Persistence.Interbase Namespace See Also
Collapse All

Specifies the SQL type of the column.

C#
public String ColumnType(
    int length
);
See Also
DecimalAsDecimal Class
Eco.Persistence.Interbase Namespace


DecimalAsDecimal.StringToParameter Method

DecimalAsDecimal.StringToParameter Method
DecimalAsDecimal Class Eco.Persistence.Interbase Namespace See Also
Collapse All
C#
public void StringToParameter(
    string value,
    IDataParameter parameter
);
Remarks

This is StringToParameter, a member of class DecimalAsDecimal.

See Also
DecimalAsDecimal Class
Eco.Persistence.Interbase Namespace


DecimalAsDecimal.ValueToParameter Method

DecimalAsDecimal.ValueToParameter Method
DecimalAsDecimal Class Eco.Persistence.Interbase Namespace See Also
Collapse All

Converts a value that comes from a database query to an ecospace value.

C#
public void ValueToParameter(
    System.Object value,
    IDataParameter parameter
);
Remarks

In many cases, the implementation of this method mainly converts null to DBNull, but it can also handle conversion from for example booleans to integers, byte[] to database blobs. It also has to set the correct parameter types in the IDataParameter-object. This is the reverse operation of ColumnToValue.

See Also
DecimalAsDecimal Class
Eco.Persistence.Interbase Namespace


DecimalAsDecimal.ValueType Method

DecimalAsDecimal.ValueType Method
DecimalAsDecimal Class Eco.Persistence.Interbase Namespace See Also
Collapse All

This method returns the type of the value that is returned by ColumnToValue.

C#
public System.Type ValueType();
See Also
DecimalAsDecimal Class
Eco.Persistence.Interbase Namespace


Int16AsAutoInc Class

Int16AsAutoInc Class
Inheritance Hierarchy See Also
Collapse All
C#
public sealed class Int16AsAutoInc : AbstractAutoInc, IAutoIncAttributemapping;
Remarks

This is class Eco.Persistence.Interbase.Int16AsAutoInc.

Inheritance Hierarchy
Eco.Persistence.ISingleColumnAttributemapping
    Eco.Persistence.IAutoIncAttributemapping
    Eco.Persistence.Interbase.AbstractAutoInc
        Eco.Persistence.Interbase.Int16AsAutoInc
File

InterbaseAttributeMappers.cs

See Also
Inheritance Hierarchy


Int16AsAutoInc Methods

Int16AsAutoInc Methods
Public Methods
Collapse All

The methods of the Int16AsAutoInc class are listed here.

Public Methods
Name | Description
ColumnToValue | Converts a value that comes from a database query to an ecospace value.
ColumnType | Specifies the SQL type of the column.
ValueType | This method returns the type of the value that is returned by ColumnToValue.


Int16AsAutoInc.ColumnToValue Method

Int16AsAutoInc.ColumnToValue Method
Int16AsAutoInc Class Eco.Persistence.Interbase Namespace See Also
Collapse All

Converts a value that comes from a database query to an ecospace value.

C#
public override System.Object ColumnToValue(
    System.Object columnValue
);
Remarks

In many cases, the implementation of this method mainly converts DBNull-values to null, but it can also change the CLR-type of the database value from for example a char[] to a string. or from an integer to a boolean. This is the reverse operation of ValueToParameter.

See Also
Int16AsAutoInc Class
Eco.Persistence.Interbase Namespace


Int16AsAutoInc.ColumnType Method

Int16AsAutoInc.ColumnType Method
Int16AsAutoInc Class Eco.Persistence.Interbase Namespace See Also
Collapse All

Specifies the SQL type of the column.

C#
public String ColumnType(
    int length
);
See Also
Int16AsAutoInc Class
Eco.Persistence.Interbase Namespace


Int16AsAutoInc.ValueType Method

Int16AsAutoInc.ValueType Method
Int16AsAutoInc Class Eco.Persistence.Interbase Namespace See Also
Collapse All

This method returns the type of the value that is returned by ColumnToValue.

C#
public System.Type ValueType();
See Also
Int16AsAutoInc Class
Eco.Persistence.Interbase Namespace


Int32AsAutoInc Class

Int32AsAutoInc Class
Inheritance Hierarchy See Also
Collapse All
C#
public sealed class Int32AsAutoInc : AbstractAutoInc, IAutoIncAttributemapping;
Remarks

This is class Eco.Persistence.Interbase.Int32AsAutoInc.

Inheritance Hierarchy
Eco.Persistence.ISingleColumnAttributemapping
    Eco.Persistence.IAutoIncAttributemapping
    Eco.Persistence.Interbase.AbstractAutoInc
        Eco.Persistence.Interbase.Int32AsAutoInc
File

InterbaseAttributeMappers.cs

See Also
Inheritance Hierarchy


Int32AsAutoInc Methods

Int32AsAutoInc Methods
Public Methods
Collapse All

The methods of the Int32AsAutoInc class are listed here.

Public Methods
Name | Description
ColumnToValue | Converts a value that comes from a database query to an ecospace value.
ColumnType | Specifies the SQL type of the column.
ValueType | This method returns the type of the value that is returned by ColumnToValue.


Int32AsAutoInc.ColumnToValue Method

Int32AsAutoInc.ColumnToValue Method
Int32AsAutoInc Class Eco.Persistence.Interbase Namespace See Also
Collapse All

Converts a value that comes from a database query to an ecospace value.

C#
public override System.Object ColumnToValue(
    System.Object columnValue
);
Remarks

In many cases, the implementation of this method mainly converts DBNull-values to null, but it can also change the CLR-type of the database value from for example a char[] to a string. or from an integer to a boolean. This is the reverse operation of ValueToParameter.

See Also
Int32AsAutoInc Class
Eco.Persistence.Interbase Namespace


Int32AsAutoInc.ColumnType Method

Int32AsAutoInc.ColumnType Method
Int32AsAutoInc Class Eco.Persistence.Interbase Namespace See Also
Collapse All

Specifies the SQL type of the column.

C#
public String ColumnType(
    int length
);
See Also
Int32AsAutoInc Class
Eco.Persistence.Interbase Namespace


Int32AsAutoInc.ValueType Method

Int32AsAutoInc.ValueType Method
Int32AsAutoInc Class Eco.Persistence.Interbase Namespace See Also
Collapse All

This method returns the type of the value that is returned by ColumnToValue.

C#
public System.Type ValueType();
See Also
Int32AsAutoInc Class
Eco.Persistence.Interbase Namespace


Int64AsLongInteger Class

Int64AsLongInteger Class
Inheritance Hierarchy See Also
Collapse All
C#
public sealed class Int64AsLongInteger : AbstractNumericSingleColumnAttribute, ISingleColumnAttributemapping, IDefaultReverseMapping;
Remarks

This is class Eco.Persistence.Interbase.Int64AsLongInteger.

Inheritance Hierarchy
Eco.Persistence.IDefaultReverseMapping
Eco.Persistence.ISingleColumnAttributemapping
    Eco.Persistence.Interbase.Int64AsLongInteger
File

InterbaseAttributeMappers.cs

See Also
Inheritance Hierarchy


Int64AsLongInteger.ColumnToValue Method

Int64AsLongInteger.ColumnToValue Method
Int64AsLongInteger Class Eco.Persistence.Interbase Namespace See Also
Collapse All

Converts a value that comes from a database query to an ecospace value.

C#
public override System.Object ColumnToValue(
    System.Object columnValue
);
Remarks

In many cases, the implementation of this method mainly converts DBNull-values to null, but it can also change the CLR-type of the database value from for example a char[] to a string. or from an integer to a boolean. This is the reverse operation of ValueToParameter.

See Also
Int64AsLongInteger Class
Eco.Persistence.Interbase Namespace


Int64AsLongInteger.ColumnType Method

Int64AsLongInteger.ColumnType Method
Int64AsLongInteger Class Eco.Persistence.Interbase Namespace See Also
Collapse All

Specifies the SQL type of the column.

C#
public String ColumnType(
    int length
);
See Also
Int64AsLongInteger Class
Eco.Persistence.Interbase Namespace


Int64AsLongInteger.StringToParameter Method

Int64AsLongInteger.StringToParameter Method
Int64AsLongInteger Class Eco.Persistence.Interbase Namespace See Also
Collapse All
C#
public void StringToParameter(
    string value,
    IDataParameter parameter
);
Remarks

This is StringToParameter, a member of class Int64AsLongInteger.

See Also
Int64AsLongInteger Class
Eco.Persistence.Interbase Namespace


Int64AsLongInteger.ValueToParameter Method

Int64AsLongInteger.ValueToParameter Method
Int64AsLongInteger Class Eco.Persistence.Interbase Namespace See Also
Collapse All

Converts a value that comes from a database query to an ecospace value.

C#
public void ValueToParameter(
    System.Object value,
    IDataParameter parameter
);
Remarks

In many cases, the implementation of this method mainly converts null to DBNull, but it can also handle conversion from for example booleans to integers, byte[] to database blobs. It also has to set the correct parameter types in the IDataParameter-object. This is the reverse operation of ColumnToValue.

See Also
Int64AsLongInteger Class
Eco.Persistence.Interbase Namespace


Int64AsLongInteger.ValueType Method

Int64AsLongInteger.ValueType Method
Int64AsLongInteger Class Eco.Persistence.Interbase Namespace See Also
Collapse All

This method returns the type of the value that is returned by ColumnToValue.

C#
public System.Type ValueType();
See Also
Int64AsLongInteger Class
Eco.Persistence.Interbase Namespace


StringAsBdpBlob Class

StringAsBdpBlob Class
Inheritance Hierarchy See Also
Collapse All
C#
public sealed class StringAsBdpBlob : AbstractSingleColumnAttribute, ISingleColumnAttributemapping;
Remarks

This is class Eco.Persistence.Interbase.StringAsBdpBlob.

Inheritance Hierarchy
Eco.Persistence.ISingleColumnAttributemapping
    Eco.Persistence.Interbase.StringAsBdpBlob
File

InterbaseAttributeMappersBdp.cs

See Also
Inheritance Hierarchy


StringAsBdpBlob Methods

StringAsBdpBlob Methods
Public Methods
Collapse All

The methods of the StringAsBdpBlob class are listed here.

Public Methods
Name | Description
ColumnToValue | Converts a value that comes from a database query to an ecospace value.
ColumnType | Specifies the SQL type of the column.
DefaultDbValue | The return value of this function will be used as default value for new columns when databases are created/evolved.
StringToParameter | This is StringToParameter, a member of class StringAsBdpBlob.
ValueToParameter | Converts a value that comes from a database query to an ecospace value.
ValueType | This method returns the type of the value that is returned by ColumnToValue.


StringAsBdpBlob.ColumnToValue Method

StringAsBdpBlob.ColumnToValue Method
StringAsBdpBlob Class Eco.Persistence.Interbase Namespace See Also
Collapse All

Converts a value that comes from a database query to an ecospace value.

C#
public override System.Object ColumnToValue(
    System.Object columnValue
);
Remarks

In many cases, the implementation of this method mainly converts DBNull-values to null, but it can also change the CLR-type of the database value from for example a char[] to a string. or from an integer to a boolean. This is the reverse operation of ValueToParameter.

See Also
StringAsBdpBlob Class
Eco.Persistence.Interbase Namespace


StringAsBdpBlob.ColumnType Method

StringAsBdpBlob.ColumnType Method
StringAsBdpBlob Class Eco.Persistence.Interbase Namespace See Also
Collapse All

Specifies the SQL type of the column.

C#
public string ColumnType(
    int length
);
See Also
StringAsBdpBlob Class
Eco.Persistence.Interbase Namespace


StringAsBdpBlob.DefaultDbValue Method

StringAsBdpBlob.DefaultDbValue Method
StringAsBdpBlob Class Eco.Persistence.Interbase Namespace See Also
Collapse All

The return value of this function will be used as default value for new columns when databases are created/evolved.

C#
public string DefaultDbValue(
    string modeledValue,
    SqlDatabaseConfig sqlDatabaseConfig
);
See Also
StringAsBdpBlob Class
Eco.Persistence.Interbase Namespace


StringAsBdpBlob.StringToParameter Method

StringAsBdpBlob.StringToParameter Method
StringAsBdpBlob Class Eco.Persistence.Interbase Namespace See Also
Collapse All
C#
public void StringToParameter(
    string value,
    IDataParameter parameter
);
Remarks

This is StringToParameter, a member of class StringAsBdpBlob.

See Also
StringAsBdpBlob Class
Eco.Persistence.Interbase Namespace


StringAsBdpBlob.ValueToParameter Method

StringAsBdpBlob.ValueToParameter Method
StringAsBdpBlob Class Eco.Persistence.Interbase Namespace See Also
Collapse All

Converts a value that comes from a database query to an ecospace value.

C#
public void ValueToParameter(
    System.Object value,
    IDataParameter parameter
);
Remarks

In many cases, the implementation of this method mainly converts null to DBNull, but it can also handle conversion from for example booleans to integers, byte[] to database blobs. It also has to set the correct parameter types in the IDataParameter-object. This is the reverse operation of ColumnToValue.

See Also
StringAsBdpBlob Class
Eco.Persistence.Interbase Namespace


StringAsBdpBlob.ValueType Method

StringAsBdpBlob.ValueType Method
StringAsBdpBlob Class Eco.Persistence.Interbase Namespace See Also
Collapse All

This method returns the type of the value that is returned by ColumnToValue.

C#
public System.Type ValueType();
See Also
StringAsBdpBlob Class
Eco.Persistence.Interbase Namespace


StringAsNCharUnicode Class

StringAsNCharUnicode Class
Inheritance Hierarchy See Also
Collapse All
C#
public sealed class StringAsNCharUnicode : AbstractStringSingleColumnAttribute, ISingleColumnAttributemapping;
Remarks

This is class Eco.Persistence.Interbase.StringAsNCharUnicode.

Inheritance Hierarchy
Eco.Persistence.ISingleColumnAttributemapping
    Eco.Persistence.Interbase.StringAsNCharUnicode
File

InterbaseAttributeMappers.cs

See Also
Inheritance Hierarchy


StringAsNCharUnicode Methods

StringAsNCharUnicode Methods
Public Methods
Collapse All

The methods of the StringAsNCharUnicode class are listed here.

Public Methods
Name | Description
ColumnToValue | Converts a value that comes from a database query to an ecospace value.
ColumnType | Specifies the SQL type of the column.
StringToParameter | This is StringToParameter, a member of class StringAsNCharUnicode.
ValueToParameter | Converts a value that comes from a database query to an ecospace value.
ValueType | This method returns the type of the value that is returned by ColumnToValue.


StringAsNCharUnicode.ColumnToValue Method

StringAsNCharUnicode.ColumnToValue Method
StringAsNCharUnicode Class Eco.Persistence.Interbase Namespace See Also
Collapse All

Converts a value that comes from a database query to an ecospace value.

C#
public override System.Object ColumnToValue(
    System.Object columnValue
);
Remarks

In many cases, the implementation of this method mainly converts DBNull-values to null, but it can also change the CLR-type of the database value from for example a char[] to a string. or from an integer to a boolean. This is the reverse operation of ValueToParameter.

See Also
StringAsNCharUnicode Class
Eco.Persistence.Interbase Namespace


StringAsNCharUnicode.ColumnType Method

StringAsNCharUnicode.ColumnType Method
StringAsNCharUnicode Class Eco.Persistence.Interbase Namespace See Also
Collapse All

Specifies the SQL type of the column.

C#
public string ColumnType(
    int length
);
See Also
StringAsNCharUnicode Class
Eco.Persistence.Interbase Namespace


StringAsNCharUnicode.StringToParameter Method

StringAsNCharUnicode.StringToParameter Method
StringAsNCharUnicode Class Eco.Persistence.Interbase Namespace See Also
Collapse All
C#
public void StringToParameter(
    string value,
    IDataParameter parameter
);
Remarks

This is StringToParameter, a member of class StringAsNCharUnicode.

See Also
StringAsNCharUnicode Class
Eco.Persistence.Interbase Namespace


StringAsNCharUnicode.ValueToParameter Method

StringAsNCharUnicode.ValueToParameter Method
StringAsNCharUnicode Class Eco.Persistence.Interbase Namespace See Also
Collapse All

Converts a value that comes from a database query to an ecospace value.

C#
public void ValueToParameter(
    System.Object value,
    IDataParameter parameter
);
Remarks

In many cases, the implementation of this method mainly converts null to DBNull, but it can also handle conversion from for example booleans to integers, byte[] to database blobs. It also has to set the correct parameter types in the IDataParameter-object. This is the reverse operation of ColumnToValue.

See Also
StringAsNCharUnicode Class
Eco.Persistence.Interbase Namespace


StringAsNCharUnicode.ValueType Method

StringAsNCharUnicode.ValueType Method
StringAsNCharUnicode Class Eco.Persistence.Interbase Namespace See Also
Collapse All

This method returns the type of the value that is returned by ColumnToValue.

C#
public System.Type ValueType();
See Also
StringAsNCharUnicode Class
Eco.Persistence.Interbase Namespace


Eco.Persistence.Mimer Namespace

Eco.Persistence.Mimer Namespace
Classes
Collapse All

This is namespace Eco.Persistence.Mimer.

Classes
Name | Description
AbstractAutoInc | This is class Eco.Persistence.Mimer.AbstractAutoInc.
AbstractByteArrayAsMimerBlob | This is class Eco.Persistence.Mimer.AbstractByteArrayAsMimerBlob.
AbstractStringAsMimerClob | This is class Eco.Persistence.Mimer.AbstractStringAsMimerClob.
AbstractStringAsMimerNClob | This is class Eco.Persistence.Mimer.AbstractStringAsMimerNClob.
ByteArrayAsMimerBlob | This is class Eco.Persistence.Mimer.ByteArrayAsMimerBlob.
Int32AsAutoInc | This is class Eco.Persistence.Mimer.Int32AsAutoInc.
Int64AsBigInt | This is class Eco.Persistence.Mimer.Int64AsBigInt.
SingleAsFloat | This is class Eco.Persistence.Mimer.SingleAsFloat.
StringAsMimerClob | This is class Eco.Persistence.Mimer.StringAsMimerClob.
StringAsMimerNClob | This is class Eco.Persistence.Mimer.StringAsMimerNClob.


AbstractAutoInc Class

AbstractAutoInc Class
Inheritance Hierarchy See Also
Collapse All
C#
public abstract class AbstractAutoInc : AbstractNumericSingleColumnAttribute;
Remarks

This is class Eco.Persistence.Mimer.AbstractAutoInc.

Inheritance Hierarchy
Eco.Persistence.Mimer.AbstractAutoInc
    Eco.Persistence.Mimer.Int32AsAutoInc
File

MimerAttributeMappers.cs

See Also
Inheritance Hierarchy


AbstractAutoInc Methods

AbstractAutoInc Methods
Public Methods
Collapse All

The methods of the AbstractAutoInc class are listed here.

Public Methods
Name | Description
MakeColumnAutoInc | This is MakeColumnAutoInc, a member of class AbstractAutoInc.
StringToParameter | This method should never be called. Autoinc values are never stored!
ValueToParameter | This method should never be called. Autoinc values are never stored!


AbstractAutoInc.MakeColumnAutoInc Method

AbstractAutoInc.MakeColumnAutoInc Method
AbstractAutoInc Class Eco.Persistence.Mimer Namespace See Also
Collapse All
C#
public void MakeColumnAutoInc(
    string tableName,
    string columnName,
    IDatabase database
);
Remarks

This is MakeColumnAutoInc, a member of class AbstractAutoInc.

See Also
AbstractAutoInc Class
Eco.Persistence.Mimer Namespace


AbstractAutoInc.StringToParameter Method

AbstractAutoInc.StringToParameter Method
AbstractAutoInc Class Eco.Persistence.Mimer Namespace See Also
Collapse All

This method should never be called. Autoinc values are never stored!

C#
public void StringToParameter(
    string value,
    IDataParameter parameter
);
Exceptions
Exceptions | Description
NotSupportedException | Thrown always.
See Also
AbstractAutoInc Class
Eco.Persistence.Mimer Namespace


AbstractAutoInc.ValueToParameter Method

AbstractAutoInc.ValueToParameter Method
AbstractAutoInc Class Eco.Persistence.Mimer Namespace See Also
Collapse All

This method should never be called. Autoinc values are never stored!

C#
public void ValueToParameter(
    System.Object value,
    IDataParameter parameter
);
Exceptions
Exceptions | Description
NotSupportedException | Thrown always.
See Also
AbstractAutoInc Class
Eco.Persistence.Mimer Namespace


AbstractByteArrayAsMimerBlob Class

AbstractByteArrayAsMimerBlob Class
Inheritance Hierarchy See Also
Collapse All
C#
public class AbstractByteArrayAsMimerBlob : AbstractSingleColumnAttribute;
Remarks

This is class Eco.Persistence.Mimer.AbstractByteArrayAsMimerBlob.

Inheritance Hierarchy
Eco.Persistence.Mimer.AbstractByteArrayAsMimerBlob
    Eco.Persistence.Mimer.ByteArrayAsMimerBlob
File

MimerAttributeMappers.cs

See Also
Inheritance Hierarchy


AbstractByteArrayAsMimerBlob Methods

AbstractByteArrayAsMimerBlob Methods
Public Methods
Collapse All

The methods of the AbstractByteArrayAsMimerBlob class are listed here.

Public Methods
Name | Description
ColumnToValue | This is ColumnToValue, a member of class AbstractByteArrayAsMimerBlob.
ColumnType | This is ColumnType, a member of class AbstractByteArrayAsMimerBlob.
DefaultDbValue | This is DefaultDbValue, a member of class AbstractByteArrayAsMimerBlob.
IsEqual | This is IsEqual, a member of class AbstractByteArrayAsMimerBlob.
StringToParameter |


AbstractByteArrayAsMimerBlob.ColumnToValue Method

AbstractByteArrayAsMimerBlob.ColumnToValue Method
AbstractByteArrayAsMimerBlob Class Eco.Persistence.Mimer Namespace See Also
Collapse All
C#
public override System.Object ColumnToValue(
    System.Object columnValue
);
Remarks

This is ColumnToValue, a member of class AbstractByteArrayAsMimerBlob.

See Also
AbstractByteArrayAsMimerBlob Class
Eco.Persistence.Mimer Namespace


AbstractByteArrayAsMimerBlob.ColumnType Method

AbstractByteArrayAsMimerBlob.ColumnType Method
AbstractByteArrayAsMimerBlob Class Eco.Persistence.Mimer Namespace See Also
Collapse All
C#
public String ColumnType(
    int length
);
Remarks

This is ColumnType, a member of class AbstractByteArrayAsMimerBlob.

See Also
AbstractByteArrayAsMimerBlob Class
Eco.Persistence.Mimer Namespace


AbstractByteArrayAsMimerBlob.DefaultDbValue Method

AbstractByteArrayAsMimerBlob.DefaultDbValue Method
AbstractByteArrayAsMimerBlob Class Eco.Persistence.Mimer Namespace See Also
Collapse All
C#
public String DefaultDbValue(
    string modeledValue,
    SqlDatabaseConfig sqlDatabaseConfig
);
Remarks

This is DefaultDbValue, a member of class AbstractByteArrayAsMimerBlob.

See Also
AbstractByteArrayAsMimerBlob Class
Eco.Persistence.Mimer Namespace


AbstractByteArrayAsMimerBlob.IsEqual Method

AbstractByteArrayAsMimerBlob.IsEqual Method
AbstractByteArrayAsMimerBlob Class Eco.Persistence.Mimer Namespace See Also
Collapse All
C#
public override bool IsEqual(
    System.Object value,
    System.Object columnValue
);
Remarks

This is IsEqual, a member of class AbstractByteArrayAsMimerBlob.

See Also
AbstractByteArrayAsMimerBlob Class
Eco.Persistence.Mimer Namespace


AbstractByteArrayAsMimerBlob.StringToParameter Method

AbstractByteArrayAsMimerBlob.StringToParameter Method
AbstractByteArrayAsMimerBlob Class Eco.Persistence.Mimer Namespace See Also
Collapse All
C#
public void StringToParameter(
    string value,
    IDataParameter parameter
);
Exceptions
Exceptions | Description
InvalidOperationException | Thrown always.
See Also
AbstractByteArrayAsMimerBlob Class
Eco.Persistence.Mimer Namespace


AbstractStringAsMimerClob Class

AbstractStringAsMimerClob Class
Inheritance Hierarchy See Also
Collapse All
C#
public abstract class AbstractStringAsMimerClob : AbstractSingleColumnAttribute;
Remarks

This is class Eco.Persistence.Mimer.AbstractStringAsMimerClob.

Inheritance Hierarchy
Eco.Persistence.Mimer.AbstractStringAsMimerClob
    Eco.Persistence.Mimer.StringAsMimerClob
File

MimerAttributeMappers.cs

See Also
Inheritance Hierarchy


AbstractStringAsMimerClob Methods

AbstractStringAsMimerClob Methods
Public Methods
Collapse All

The methods of the AbstractStringAsMimerClob class are listed here.

Public Methods
Name | Description
ColumnType | This is ColumnType, a member of class AbstractStringAsMimerClob.
DefaultDbValue | This is DefaultDbValue, a member of class AbstractStringAsMimerClob.
StringToParameter | This is StringToParameter, a member of class AbstractStringAsMimerClob.
ValueToParameter | This is ValueToParameter, a member of class AbstractStringAsMimerClob.


AbstractStringAsMimerClob.ColumnType Method

AbstractStringAsMimerClob.ColumnType Method
AbstractStringAsMimerClob Class Eco.Persistence.Mimer Namespace See Also
Collapse All
C#
public String ColumnType(
    int length
);
Remarks

This is ColumnType, a member of class AbstractStringAsMimerClob.

See Also
AbstractStringAsMimerClob Class
Eco.Persistence.Mimer Namespace


AbstractStringAsMimerClob.DefaultDbValue Method

AbstractStringAsMimerClob.DefaultDbValue Method
AbstractStringAsMimerClob Class Eco.Persistence.Mimer Namespace See Also
Collapse All
C#
public String DefaultDbValue(
    string modeledValue,
    SqlDatabaseConfig sqlDatabaseConfig
);
Remarks

This is DefaultDbValue, a member of class AbstractStringAsMimerClob.

See Also
AbstractStringAsMimerClob Class
Eco.Persistence.Mimer Namespace


AbstractStringAsMimerClob.StringToParameter Method

AbstractStringAsMimerClob.StringToParameter Method
AbstractStringAsMimerClob Class Eco.Persistence.Mimer Namespace See Also
Collapse All
C#
public void StringToParameter(
    string value,
    IDataParameter parameter
);
Remarks

This is StringToParameter, a member of class AbstractStringAsMimerClob.

See Also
AbstractStringAsMimerClob Class
Eco.Persistence.Mimer Namespace


AbstractStringAsMimerClob.ValueToParameter Method

AbstractStringAsMimerClob.ValueToParameter Method
AbstractStringAsMimerClob Class Eco.Persistence.Mimer Namespace See Also
Collapse All
C#
public abstract void ValueToParameter(
    System.Object value,
    IDataParameter parameter
);
Remarks

This is ValueToParameter, a member of class AbstractStringAsMimerClob.

See Also
AbstractStringAsMimerClob Class
Eco.Persistence.Mimer Namespace


AbstractStringAsMimerNClob Class

AbstractStringAsMimerNClob Class
Inheritance Hierarchy See Also
Collapse All
C#
public abstract class AbstractStringAsMimerNClob : AbstractSingleColumnAttribute;
Remarks

This is class Eco.Persistence.Mimer.AbstractStringAsMimerNClob.

Inheritance Hierarchy
Eco.Persistence.Mimer.AbstractStringAsMimerNClob
    Eco.Persistence.Mimer.StringAsMimerNClob
File

MimerAttributeMappers.cs

See Also
Inheritance Hierarchy


AbstractStringAsMimerNClob Methods

AbstractStringAsMimerNClob Methods
Public Methods
Collapse All

The methods of the AbstractStringAsMimerNClob class are listed here.

Public Methods
Name | Description
ColumnToValue | This is ColumnToValue, a member of class AbstractStringAsMimerNClob.
ColumnType | This is ColumnType, a member of class AbstractStringAsMimerNClob.
DefaultDbValue | This is DefaultDbValue, a member of class AbstractStringAsMimerNClob.
StringToParameter | This is StringToParameter, a member of class AbstractStringAsMimerNClob.
ValueToParameter | This is ValueToParameter, a member of class AbstractStringAsMimerNClob.


AbstractStringAsMimerNClob.ColumnToValue Method

AbstractStringAsMimerNClob.ColumnToValue Method
AbstractStringAsMimerNClob Class Eco.Persistence.Mimer Namespace See Also
Collapse All
C#
public override System.Object ColumnToValue(
    System.Object columnValue
);
Remarks

This is ColumnToValue, a member of class AbstractStringAsMimerNClob.

See Also
AbstractStringAsMimerNClob Class
Eco.Persistence.Mimer Namespace


AbstractStringAsMimerNClob.ColumnType Method

AbstractStringAsMimerNClob.ColumnType Method
AbstractStringAsMimerNClob Class Eco.Persistence.Mimer Namespace See Also
Collapse All
C#
public String ColumnType(
    int length
);
Remarks

This is ColumnType, a member of class AbstractStringAsMimerNClob.

See Also
AbstractStringAsMimerNClob Class
Eco.Persistence.Mimer Namespace


AbstractStringAsMimerNClob.DefaultDbValue Method

AbstractStringAsMimerNClob.DefaultDbValue Method
AbstractStringAsMimerNClob Class Eco.Persistence.Mimer Namespace See Also
Collapse All
C#
public String DefaultDbValue(
    string modeledValue,
    SqlDatabaseConfig sqlDatabaseConfig
);
Remarks

This is DefaultDbValue, a member of class AbstractStringAsMimerNClob.

See Also
AbstractStringAsMimerNClob Class
Eco.Persistence.Mimer Namespace


AbstractStringAsMimerNClob.StringToParameter Method

AbstractStringAsMimerNClob.StringToParameter Method
AbstractStringAsMimerNClob Class Eco.Persistence.Mimer Namespace See Also
Collapse All
C#
public void StringToParameter(
    string value,
    IDataParameter parameter
);
Remarks

This is StringToParameter, a member of class AbstractStringAsMimerNClob.

See Also
AbstractStringAsMimerNClob Class
Eco.Persistence.Mimer Namespace


AbstractStringAsMimerNClob.ValueToParameter Method

AbstractStringAsMimerNClob.ValueToParameter Method
AbstractStringAsMimerNClob Class Eco.Persistence.Mimer Namespace See Also
Collapse All
C#
public abstract void ValueToParameter(
    System.Object value,
    IDataParameter parameter
);
Remarks

This is ValueToParameter, a member of class AbstractStringAsMimerNClob.

See Also
AbstractStringAsMimerNClob Class
Eco.Persistence.Mimer Namespace


ByteArrayAsMimerBlob Class

ByteArrayAsMimerBlob Class
Inheritance Hierarchy See Also
Collapse All
C#
public sealed class ByteArrayAsMimerBlob : AbstractByteArrayAsMimerBlob, ISingleColumnAttributemapping;
Remarks

This is class Eco.Persistence.Mimer.ByteArrayAsMimerBlob.

Inheritance Hierarchy
Eco.Persistence.ISingleColumnAttributemapping
Eco.Persistence.Mimer.AbstractByteArrayAsMimerBlob
    Eco.Persistence.Mimer.ByteArrayAsMimerBlob
File

MimerAttributeMappersMimerClient.cs

See Also
Inheritance Hierarchy


ByteArrayAsMimerBlob Methods

ByteArrayAsMimerBlob Methods
Public Methods
Collapse All

The methods of the ByteArrayAsMimerBlob class are listed here.

Public Methods
Name | Description
ValueToParameter | Converts a value that comes from a database query to an ecospace value.
ValueType | This method returns the type of the value that is returned by ColumnToValue.


ByteArrayAsMimerBlob.ValueToParameter Method

ByteArrayAsMimerBlob.ValueToParameter Method
ByteArrayAsMimerBlob Class Eco.Persistence.Mimer Namespace See Also
Collapse All

Converts a value that comes from a database query to an ecospace value.

C#
public void ValueToParameter(
    System.Object value,
    IDataParameter parameter
);
Remarks

In many cases, the implementation of this method mainly converts null to DBNull, but it can also handle conversion from for example booleans to integers, byte[] to database blobs. It also has to set the correct parameter types in the IDataParameter-object. This is the reverse operation of ColumnToValue.

See Also
ByteArrayAsMimerBlob Class
Eco.Persistence.Mimer Namespace


ByteArrayAsMimerBlob.ValueType Method

ByteArrayAsMimerBlob.ValueType Method
ByteArrayAsMimerBlob Class Eco.Persistence.Mimer Namespace See Also
Collapse All

This method returns the type of the value that is returned by ColumnToValue.

C#
public System.Type ValueType();
See Also
ByteArrayAsMimerBlob Class
Eco.Persistence.Mimer Namespace


Int32AsAutoInc Class

Int32AsAutoInc Class
Inheritance Hierarchy See Also
Collapse All
C#
public sealed class Int32AsAutoInc : AbstractAutoInc, IAutoIncAttributemapping;
Remarks

This is class Eco.Persistence.Mimer.Int32AsAutoInc.

Inheritance Hierarchy
Eco.Persistence.ISingleColumnAttributemapping
    Eco.Persistence.IAutoIncAttributemapping
    Eco.Persistence.Mimer.AbstractAutoInc
        Eco.Persistence.Mimer.Int32AsAutoInc
File

MimerAttributeMappers.cs

See Also
Inheritance Hierarchy


Int32AsAutoInc.ColumnToValue Method

Int32AsAutoInc.ColumnToValue Method
Int32AsAutoInc Class Eco.Persistence.Mimer Namespace See Also
Collapse All

Converts a value that comes from a database query to an ecospace value.

C#
public override System.Object ColumnToValue(
    System.Object columnValue
);
Remarks

In many cases, the implementation of this method mainly converts DBNull-values to null, but it can also change the CLR-type of the database value from for example a char[] to a string. or from an integer to a boolean. This is the reverse operation of ValueToParameter.

See Also
Int32AsAutoInc Class
Eco.Persistence.Mimer Namespace


Int32AsAutoInc.ColumnType Method

Int32AsAutoInc.ColumnType Method
Int32AsAutoInc Class Eco.Persistence.Mimer Namespace See Also
Collapse All

Specifies the SQL type of the column.

C#
public String ColumnType(
    int length
);
See Also
Int32AsAutoInc Class
Eco.Persistence.Mimer Namespace


Int32AsAutoInc.ValueType Method

Int32AsAutoInc.ValueType Method
Int32AsAutoInc Class Eco.Persistence.Mimer Namespace See Also
Collapse All

This method returns the type of the value that is returned by ColumnToValue.

C#
public System.Type ValueType();
See Also
Int32AsAutoInc Class
Eco.Persistence.Mimer Namespace


Int64AsBigInt Class

Int64AsBigInt Class
Inheritance Hierarchy See Also
Collapse All
C#
public sealed class Int64AsBigInt : AbstractNumericSingleColumnAttribute, ISingleColumnAttributemapping;
Remarks

This is class Eco.Persistence.Mimer.Int64AsBigInt.

Inheritance Hierarchy
Eco.Persistence.ISingleColumnAttributemapping
    Eco.Persistence.Mimer.Int64AsBigInt
File

MimerAttributeMappers.cs

See Also
Inheritance Hierarchy


Int64AsBigInt.ColumnToValue Method

Int64AsBigInt.ColumnToValue Method
Int64AsBigInt Class Eco.Persistence.Mimer Namespace See Also
Collapse All

Converts a value that comes from a database query to an ecospace value.

C#
public override System.Object ColumnToValue(
    System.Object columnValue
);
Remarks

In many cases, the implementation of this method mainly converts DBNull-values to null, but it can also change the CLR-type of the database value from for example a char[] to a string. or from an integer to a boolean. This is the reverse operation of ValueToParameter.

See Also
Int64AsBigInt Class
Eco.Persistence.Mimer Namespace


Int64AsBigInt.ColumnType Method

Int64AsBigInt.ColumnType Method
Int64AsBigInt Class Eco.Persistence.Mimer Namespace See Also
Collapse All

Specifies the SQL type of the column.

C#
public String ColumnType(
    int length
);
See Also
Int64AsBigInt Class
Eco.Persistence.Mimer Namespace


Int64AsBigInt.StringToParameter Method

Int64AsBigInt.StringToParameter Method
Int64AsBigInt Class Eco.Persistence.Mimer Namespace See Also
Collapse All
C#
public void StringToParameter(
    string value,
    IDataParameter parameter
);
Remarks

This is StringToParameter, a member of class Int64AsBigInt.

See Also
Int64AsBigInt Class
Eco.Persistence.Mimer Namespace


Int64AsBigInt.ValueToParameter Method

Int64AsBigInt.ValueToParameter Method
Int64AsBigInt Class Eco.Persistence.Mimer Namespace See Also
Collapse All

Converts a value that comes from a database query to an ecospace value.

C#
public void ValueToParameter(
    System.Object value,
    IDataParameter parameter
);
Remarks

In many cases, the implementation of this method mainly converts null to DBNull, but it can also handle conversion from for example booleans to integers, byte[] to database blobs. It also has to set the correct parameter types in the IDataParameter-object. This is the reverse operation of ColumnToValue.

See Also
Int64AsBigInt Class
Eco.Persistence.Mimer Namespace


Int64AsBigInt.ValueType Method

Int64AsBigInt.ValueType Method
Int64AsBigInt Class Eco.Persistence.Mimer Namespace See Also
Collapse All

This method returns the type of the value that is returned by ColumnToValue.

C#
public System.Type ValueType();
See Also
Int64AsBigInt Class
Eco.Persistence.Mimer Namespace


SingleAsFloat Class

SingleAsFloat Class
Inheritance Hierarchy See Also
Collapse All
C#
public sealed class SingleAsFloat : AbstractNumericSingleColumnAttribute, ISingleColumnAttributemapping;
Remarks

This is class Eco.Persistence.Mimer.SingleAsFloat.

Inheritance Hierarchy
Eco.Persistence.ISingleColumnAttributemapping
    Eco.Persistence.Mimer.SingleAsFloat
File

MimerAttributeMappers.cs

See Also
Inheritance Hierarchy


SingleAsFloat.ColumnToValue Method

SingleAsFloat.ColumnToValue Method
SingleAsFloat Class Eco.Persistence.Mimer Namespace See Also
Collapse All

Converts a value that comes from a database query to an ecospace value.

C#
public override System.Object ColumnToValue(
    System.Object columnValue
);
Remarks

In many cases, the implementation of this method mainly converts DBNull-values to null, but it can also change the CLR-type of the database value from for example a char[] to a string. or from an integer to a boolean. This is the reverse operation of ValueToParameter.

See Also
SingleAsFloat Class
Eco.Persistence.Mimer Namespace


SingleAsFloat.ColumnType Method

SingleAsFloat.ColumnType Method
SingleAsFloat Class Eco.Persistence.Mimer Namespace See Also
Collapse All

Specifies the SQL type of the column.

C#
public String ColumnType(
    int length
);
See Also
SingleAsFloat Class
Eco.Persistence.Mimer Namespace


SingleAsFloat.StringToParameter Method

SingleAsFloat.StringToParameter Method
SingleAsFloat Class Eco.Persistence.Mimer Namespace See Also
Collapse All
C#
public void StringToParameter(
    string value,
    IDataParameter parameter
);
Remarks

This is StringToParameter, a member of class SingleAsFloat.

See Also
SingleAsFloat Class
Eco.Persistence.Mimer Namespace


SingleAsFloat.ValueToParameter Method

SingleAsFloat.ValueToParameter Method
SingleAsFloat Class Eco.Persistence.Mimer Namespace See Also
Collapse All

Converts a value that comes from a database query to an ecospace value.

C#
public void ValueToParameter(
    System.Object value,
    IDataParameter parameter
);
Remarks

In many cases, the implementation of this method mainly converts null to DBNull, but it can also handle conversion from for example booleans to integers, byte[] to database blobs. It also has to set the correct parameter types in the IDataParameter-object. This is the reverse operation of ColumnToValue.

See Also
SingleAsFloat Class
Eco.Persistence.Mimer Namespace


SingleAsFloat.ValueType Method

SingleAsFloat.ValueType Method
SingleAsFloat Class Eco.Persistence.Mimer Namespace See Also
Collapse All

This method returns the type of the value that is returned by ColumnToValue.

C#
public System.Type ValueType();
See Also
SingleAsFloat Class
Eco.Persistence.Mimer Namespace


StringAsMimerClob Class

StringAsMimerClob Class
Inheritance Hierarchy See Also
Collapse All
C#
public sealed class StringAsMimerClob : AbstractStringAsMimerClob, ISingleColumnAttributemapping;
Remarks

This is class Eco.Persistence.Mimer.StringAsMimerClob.

Inheritance Hierarchy
Eco.Persistence.ISingleColumnAttributemapping
Eco.Persistence.Mimer.AbstractStringAsMimerClob
    Eco.Persistence.Mimer.StringAsMimerClob
File

MimerAttributeMappersMimerClient.cs

See Also
Inheritance Hierarchy


StringAsMimerClob Methods

StringAsMimerClob Methods
Public Methods
Collapse All

The methods of the StringAsMimerClob class are listed here.

Public Methods
Name | Description
ColumnToValue | Converts a value that comes from a database query to an ecospace value.
ValueToParameter | Converts a value that comes from a database query to an ecospace value.
ValueType | This method returns the type of the value that is returned by ColumnToValue.


StringAsMimerClob.ColumnToValue Method

StringAsMimerClob.ColumnToValue Method
StringAsMimerClob Class Eco.Persistence.Mimer Namespace See Also
Collapse All

Converts a value that comes from a database query to an ecospace value.

C#
public override System.Object ColumnToValue(
    System.Object columnValue
);
Remarks

In many cases, the implementation of this method mainly converts DBNull-values to null, but it can also change the CLR-type of the database value from for example a char[] to a string. or from an integer to a boolean. This is the reverse operation of ValueToParameter.

See Also
StringAsMimerClob Class
Eco.Persistence.Mimer Namespace


StringAsMimerClob.ValueToParameter Method

StringAsMimerClob.ValueToParameter Method
StringAsMimerClob Class Eco.Persistence.Mimer Namespace See Also
Collapse All

Converts a value that comes from a database query to an ecospace value.

C#
public override void ValueToParameter(
    System.Object value,
    IDataParameter parameter
);
Remarks

In many cases, the implementation of this method mainly converts null to DBNull, but it can also handle conversion from for example booleans to integers, byte[] to database blobs. It also has to set the correct parameter types in the IDataParameter-object. This is the reverse operation of ColumnToValue.

See Also
StringAsMimerClob Class
Eco.Persistence.Mimer Namespace


StringAsMimerClob.ValueType Method

StringAsMimerClob.ValueType Method
StringAsMimerClob Class Eco.Persistence.Mimer Namespace See Also
Collapse All

This method returns the type of the value that is returned by ColumnToValue.

C#
public System.Type ValueType();
See Also
StringAsMimerClob Class
Eco.Persistence.Mimer Namespace


StringAsMimerNClob Class

StringAsMimerNClob Class
Inheritance Hierarchy See Also
Collapse All
C#
public sealed class StringAsMimerNClob : AbstractStringAsMimerNClob, ISingleColumnAttributemapping;
Remarks

This is class Eco.Persistence.Mimer.StringAsMimerNClob.

Inheritance Hierarchy
Eco.Persistence.ISingleColumnAttributemapping
Eco.Persistence.Mimer.AbstractStringAsMimerNClob
    Eco.Persistence.Mimer.StringAsMimerNClob
File

MimerAttributeMappersMimerClient.cs

See Also
Inheritance Hierarchy


StringAsMimerNClob Methods

StringAsMimerNClob Methods
Public Methods
Collapse All

The methods of the StringAsMimerNClob class are listed here.

Public Methods
Name | Description
ValueToParameter | Converts a value that comes from a database query to an ecospace value.
ValueType | This method returns the type of the value that is returned by ColumnToValue.


StringAsMimerNClob.ValueToParameter Method

StringAsMimerNClob.ValueToParameter Method
StringAsMimerNClob Class Eco.Persistence.Mimer Namespace See Also
Collapse All

Converts a value that comes from a database query to an ecospace value.

C#
public override void ValueToParameter(
    System.Object value,
    IDataParameter parameter
);
Remarks

In many cases, the implementation of this method mainly converts null to DBNull, but it can also handle conversion from for example booleans to integers, byte[] to database blobs. It also has to set the correct parameter types in the IDataParameter-object. This is the reverse operation of ColumnToValue.

See Also
StringAsMimerNClob Class
Eco.Persistence.Mimer Namespace


StringAsMimerNClob.ValueType Method

StringAsMimerNClob.ValueType Method
StringAsMimerNClob Class Eco.Persistence.Mimer Namespace See Also
Collapse All

This method returns the type of the value that is returned by ColumnToValue.

C#
public System.Type ValueType();
See Also
StringAsMimerNClob Class
Eco.Persistence.Mimer Namespace


Eco.Persistence.MySql Namespace

Eco.Persistence.MySql Namespace
Classes
Collapse All

This is namespace Eco.Persistence.MySql.

Classes
Name | Description
ByteAsUnsingedTinyInt | Class for mapping byte values to a single column in a database.
DateTimeAsDateTime | Mapper between a DateTime value and its persistent representation as DATETIME.
Int16AsAutoInc | Mapper between an AutoInc value of type Int16 and its persistent representation as SMALLINT.
Int32AsAutoInc | Mapper between an AutoInc value of type Int32 and its persistent representation as INTEGER.
Int64AsBigInt | This is class Eco.Persistence.MySql.Int64AsBigInt.
MySqlStringRes | Autogenerated class to get compiler safe access to resource strings.
UInt16AsUnsignedSmallint | Class for mapping Int16 values to a single column in a database.


ByteAsUnsingedTinyInt Class

ByteAsUnsingedTinyInt Class
Inheritance Hierarchy See Also
Collapse All

Class for mapping byte values to a single column in a database.

C#
public sealed class ByteAsUnsingedTinyInt : AbstractNumericSingleColumnAttribute, ISingleColumnAttributemapping, IDefaultReverseMapping;
Inheritance Hierarchy
Eco.Persistence.IDefaultReverseMapping
Eco.Persistence.ISingleColumnAttributemapping
    Eco.Persistence.MySql.ByteAsUnsingedTinyInt
File

MySqlAttributeMappers.cs

See Also
Inheritance Hierarchy


ByteAsUnsingedTinyInt Methods

ByteAsUnsingedTinyInt Methods
Public Methods
Collapse All

The methods of the ByteAsUnsingedTinyInt class are listed here.

Public Methods
Name | Description
ColumnToValue | Converts a value that comes from a database query to an ecospace value.
ColumnType | Returns the SQL type used by the database during CREATE TABLE execution.
StringToParameter | Converts a string to the correct data type and then inserts the given value into the IDataParameter.
ValueToParameter | Inserts the given value into the IDataParameter.
ValueType | Returns the .NET type of the column.


ByteAsUnsingedTinyInt.ColumnToValue Method

ByteAsUnsingedTinyInt.ColumnToValue Method
ByteAsUnsingedTinyInt Class Eco.Persistence.MySql Namespace See Also
Collapse All

Converts a value that comes from a database query to an ecospace value.

C#
public override System.Object ColumnToValue(
    System.Object columnValue
);
Remarks

In many cases, the implementation of this method mainly converts DBNull-values to null, but it can also change the CLR-type of the database value from for example a char[] to a string. or from an integer to a boolean. This is the reverse operation of ValueToParameter.

See Also
ByteAsUnsingedTinyInt Class
Eco.Persistence.MySql Namespace


ByteAsUnsingedTinyInt.ColumnType Method

ByteAsUnsingedTinyInt.ColumnType Method
ByteAsUnsingedTinyInt Class Eco.Persistence.MySql Namespace See Also
Collapse All

Returns the SQL type used by the database during CREATE TABLE execution.

C#
public String ColumnType(
    int length
);
Parameters
Parameters | Description
length | This parameter is ignored.
See Also
ByteAsUnsingedTinyInt Class
Eco.Persistence.MySql Namespace


ByteAsUnsingedTinyInt.StringToParameter Method

ByteAsUnsingedTinyInt.StringToParameter Method
ByteAsUnsingedTinyInt Class Eco.Persistence.MySql Namespace See Also
Collapse All

Converts a string to the correct data type and then inserts the given value into the IDataParameter.

C#
public void StringToParameter(
    string value,
    IDataParameter parameter
);
Parameters
Parameters | Description
value | The value to use.
parameter | The IDataParameter to update.
See Also
ByteAsUnsingedTinyInt Class
Eco.Persistence.MySql Namespace


ByteAsUnsingedTinyInt.ValueToParameter Method

ByteAsUnsingedTinyInt.ValueToParameter Method
ByteAsUnsingedTinyInt Class Eco.Persistence.MySql Namespace See Also
Collapse All

Inserts the given value into the IDataParameter.

C#
public void ValueToParameter(
    System.Object value,
    IDataParameter parameter
);
Parameters
Parameters | Description
value | The value to use.
parameter | The IDataParameter to update.
See Also
ByteAsUnsingedTinyInt Class
Eco.Persistence.MySql Namespace


ByteAsUnsingedTinyInt.ValueType Method

ByteAsUnsingedTinyInt.ValueType Method
ByteAsUnsingedTinyInt Class Eco.Persistence.MySql Namespace See Also
Collapse All

Returns the .NET type of the column.

C#
public System.Type ValueType();
See Also
ByteAsUnsingedTinyInt Class
Eco.Persistence.MySql Namespace


DateTimeAsDateTime Class

DateTimeAsDateTime Class
Inheritance Hierarchy See Also
Collapse All

Mapper between a DateTime value and its persistent representation as DATETIME.

C#
public sealed class DateTimeAsDateTime : AbstractSingleColumnAttribute, ISingleColumnAttributemapping, IDefaultReverseMapping;
Inheritance Hierarchy
Eco.Persistence.IDefaultReverseMapping
Eco.Persistence.ISingleColumnAttributemapping
    Eco.Persistence.MySql.DateTimeAsDateTime
File

MySqlAttributeMappers.cs

See Also
Inheritance Hierarchy


DateTimeAsDateTime Methods

DateTimeAsDateTime Methods
Public Methods
Collapse All

The methods of the DateTimeAsDateTime class are listed here.

Public Methods
Name | Description
ColumnToValue | Converts a value that comes from a database query to an ecospace value.
ColumnType | Specifies the SQL type of the column.
DefaultDbValue |
IsEqual | Returns true if an ecospace value ("value") is equal to a database value ("columnValue").
StringToParameter | This is StringToParameter, a member of class DateTimeAsDateTime.
ValueToParameter | Converts a value that comes from a database query to an ecospace value.
ValueType | This method returns the type of the value that is returned by ColumnToValue.


DateTimeAsDateTime.ColumnToValue Method

DateTimeAsDateTime.ColumnToValue Method
DateTimeAsDateTime Class Eco.Persistence.MySql Namespace See Also
Collapse All

Converts a value that comes from a database query to an ecospace value.

C#
public override System.Object ColumnToValue(
    System.Object columnValue
);
Remarks

In many cases, the implementation of this method mainly converts DBNull-values to null, but it can also change the CLR-type of the database value from for example a char[] to a string. or from an integer to a boolean. This is the reverse operation of ValueToParameter.

See Also
DateTimeAsDateTime Class
Eco.Persistence.MySql Namespace


DateTimeAsDateTime.ColumnType Method

DateTimeAsDateTime.ColumnType Method
DateTimeAsDateTime Class Eco.Persistence.MySql Namespace See Also
Collapse All

Specifies the SQL type of the column.

C#
public String ColumnType(
    int length
);
See Also
DateTimeAsDateTime Class
Eco.Persistence.MySql Namespace


DateTimeAsDateTime.DefaultDbValue Method

DateTimeAsDateTime.DefaultDbValue Method
DateTimeAsDateTime Class Eco.Persistence.MySql Namespace See Also
Collapse All
C#
public String DefaultDbValue(
    string modeledValue,
    SqlDatabaseConfig sqlDatabaseConfig
);
Exceptions
Exceptions | Description
ArgumentNullException | Thrown if sqlDatabaseConfig is null
See Also
DateTimeAsDateTime Class
Eco.Persistence.MySql Namespace


DateTimeAsDateTime.IsEqual Method

DateTimeAsDateTime.IsEqual Method
DateTimeAsDateTime Class Eco.Persistence.MySql Namespace See Also
Collapse All

Returns true if an ecospace value ("value") is equal to a database value ("columnValue").

C#
public override bool IsEqual(
    System.Object value,
    System.Object columnValue
);
Remarks

This method must handle the conversions between ecospace and database values, it must also handle comparing null/DBNull values.

See Also
DateTimeAsDateTime Class
Eco.Persistence.MySql Namespace


DateTimeAsDateTime.StringToParameter Method

DateTimeAsDateTime.StringToParameter Method
DateTimeAsDateTime Class Eco.Persistence.MySql Namespace See Also
Collapse All
C#
public void StringToParameter(
    string value,
    IDataParameter parameter
);
Remarks

This is StringToParameter, a member of class DateTimeAsDateTime.

See Also
DateTimeAsDateTime Class
Eco.Persistence.MySql Namespace


DateTimeAsDateTime.ValueToParameter Method

DateTimeAsDateTime.ValueToParameter Method
DateTimeAsDateTime Class Eco.Persistence.MySql Namespace See Also
Collapse All

Converts a value that comes from a database query to an ecospace value.

C#
public void ValueToParameter(
    System.Object value,
    IDataParameter parameter
);
Remarks

In many cases, the implementation of this method mainly converts null to DBNull, but it can also handle conversion from for example booleans to integers, byte[] to database blobs. It also has to set the correct parameter types in the IDataParameter-object. This is the reverse operation of ColumnToValue.

See Also
DateTimeAsDateTime Class
Eco.Persistence.MySql Namespace


DateTimeAsDateTime.ValueType Method

DateTimeAsDateTime.ValueType Method
DateTimeAsDateTime Class Eco.Persistence.MySql Namespace See Also
Collapse All

This method returns the type of the value that is returned by ColumnToValue.

C#
public System.Type ValueType();
See Also
DateTimeAsDateTime Class
Eco.Persistence.MySql Namespace


Int16AsAutoInc Class

Int16AsAutoInc Class
Inheritance Hierarchy See Also
Collapse All

Mapper between an AutoInc value of type Int16 and its persistent representation as SMALLINT.

C#
public sealed class Int16AsAutoInc : AbstractNumericSingleColumnAttribute, IAutoIncAttributemapping, IDefaultReverseMapping;
Inheritance Hierarchy
Eco.Persistence.ISingleColumnAttributemapping
    Eco.Persistence.IAutoIncAttributemapping
    Eco.Persistence.IDefaultReverseMapping
        Eco.Persistence.MySql.Int16AsAutoInc
File

MySqlAttributeMappers.cs

See Also
Inheritance Hierarchy


Int16AsAutoInc Methods

Int16AsAutoInc Methods
Public Methods
Collapse All

The methods of the Int16AsAutoInc class are listed here.

Public Methods
Name | Description
ColumnToValue | Converts a value that comes from a database query to an ecospace value.
ColumnType | Specifies the SQL type of the column.
DefaultDbValue | The return value of this function will be used as default value for new columns when databases are created/evolved.
MakeColumnAutoInc | If the database requires any additional operations in addition to the column type to give a column "autoinc" behaviour, that should be performed by this method.
StringToParameter | This method should never be called. Autoinc values are never stored!
ValueToParameter | This method should never be called. Autoinc values are never stored!
ValueType | This method returns the type of the value that is returned by ColumnToValue.


Int16AsAutoInc.ColumnToValue Method

Int16AsAutoInc.ColumnToValue Method
Int16AsAutoInc Class Eco.Persistence.MySql Namespace See Also
Collapse All

Converts a value that comes from a database query to an ecospace value.

C#
public override System.Object ColumnToValue(
    System.Object columnValue
);
Remarks

In many cases, the implementation of this method mainly converts DBNull-values to null, but it can also change the CLR-type of the database value from for example a char[] to a string. or from an integer to a boolean. This is the reverse operation of ValueToParameter.

See Also
Int16AsAutoInc Class
Eco.Persistence.MySql Namespace


Int16AsAutoInc.ColumnType Method

Int16AsAutoInc.ColumnType Method
Int16AsAutoInc Class Eco.Persistence.MySql Namespace See Also
Collapse All

Specifies the SQL type of the column.

C#
public String ColumnType(
    int length
);
See Also
Int16AsAutoInc Class
Eco.Persistence.MySql Namespace


Int16AsAutoInc.DefaultDbValue Method

Int16AsAutoInc.DefaultDbValue Method
Int16AsAutoInc Class Eco.Persistence.MySql Namespace See Also
Collapse All

The return value of this function will be used as default value for new columns when databases are created/evolved.

C#
public override String DefaultDbValue(
    string modeledValue,
    SqlDatabaseConfig sqlDatabaseConfig
);
See Also
Int16AsAutoInc Class
Eco.Persistence.MySql Namespace


Int16AsAutoInc.MakeColumnAutoInc Method

Int16AsAutoInc.MakeColumnAutoInc Method
Int16AsAutoInc Class Eco.Persistence.MySql Namespace See Also
Collapse All

If the database requires any additional operations in addition to the column type to give a column "autoinc" behaviour, that should be performed by this method.

C#
public void MakeColumnAutoInc(
    string tableName,
    string columnName,
    IDatabase database
);
Remarks

Even if the database does not require any additional operations, this interface should be implemented by an autoinc attribute mapper, and the implementation of this method should be left blank.

See Also
Int16AsAutoInc Class
Eco.Persistence.MySql Namespace


Int16AsAutoInc.StringToParameter Method

Int16AsAutoInc.StringToParameter Method
Int16AsAutoInc Class Eco.Persistence.MySql Namespace See Also
Collapse All

This method should never be called. Autoinc values are never stored!

C#
public void StringToParameter(
    string value,
    IDataParameter parameter
);
Exceptions
Exceptions | Description
NotSupportedException | Thrown always.
See Also
Int16AsAutoInc Class
Eco.Persistence.MySql Namespace


Int16AsAutoInc.ValueToParameter Method

Int16AsAutoInc.ValueToParameter Method
Int16AsAutoInc Class Eco.Persistence.MySql Namespace See Also
Collapse All

This method should never be called. Autoinc values are never stored!

C#
public void ValueToParameter(
    System.Object value,
    IDataParameter parameter
);
Exceptions
Exceptions | Description
NotSupportedException | Thrown always.
See Also
Int16AsAutoInc Class
Eco.Persistence.MySql Namespace


Int16AsAutoInc.ValueType Method

Int16AsAutoInc.ValueType Method
Int16AsAutoInc Class Eco.Persistence.MySql Namespace See Also
Collapse All

This method returns the type of the value that is returned by ColumnToValue.

C#
public System.Type ValueType();
See Also
Int16AsAutoInc Class
Eco.Persistence.MySql Namespace


Int32AsAutoInc Class

Int32AsAutoInc Class
Inheritance Hierarchy See Also
Collapse All

Mapper between an AutoInc value of type Int32 and its persistent representation as INTEGER.

C#
public sealed class Int32AsAutoInc : AbstractNumericSingleColumnAttribute, IAutoIncAttributemapping, IDefaultReverseMapping;
Inheritance Hierarchy
Eco.Persistence.ISingleColumnAttributemapping
    Eco.Persistence.IAutoIncAttributemapping
    Eco.Persistence.IDefaultReverseMapping
        Eco.Persistence.MySql.Int32AsAutoInc
File

MySqlAttributeMappers.cs

See Also
Inheritance Hierarchy


Int32AsAutoInc.ColumnToValue Method

Int32AsAutoInc.ColumnToValue Method
Int32AsAutoInc Class Eco.Persistence.MySql Namespace See Also
Collapse All

Converts a value that comes from a database query to an ecospace value.

C#
public override System.Object ColumnToValue(
    System.Object columnValue
);
Remarks

In many cases, the implementation of this method mainly converts DBNull-values to null, but it can also change the CLR-type of the database value from for example a char[] to a string. or from an integer to a boolean. This is the reverse operation of ValueToParameter.

See Also
Int32AsAutoInc Class
Eco.Persistence.MySql Namespace


Int32AsAutoInc.ColumnType Method

Int32AsAutoInc.ColumnType Method
Int32AsAutoInc Class Eco.Persistence.MySql Namespace See Also
Collapse All

Specifies the SQL type of the column.

C#
public String ColumnType(
    int length
);
See Also
Int32AsAutoInc Class
Eco.Persistence.MySql Namespace


Int32AsAutoInc.DefaultDbValue Method

Int32AsAutoInc.DefaultDbValue Method
Int32AsAutoInc Class Eco.Persistence.MySql Namespace See Also
Collapse All

The return value of this function will be used as default value for new columns when databases are created/evolved.

C#
public override String DefaultDbValue(
    string modeledValue,
    SqlDatabaseConfig sqlDatabaseConfig
);
See Also
Int32AsAutoInc Class
Eco.Persistence.MySql Namespace


Int32AsAutoInc.MakeColumnAutoInc Method

Int32AsAutoInc.MakeColumnAutoInc Method
Int32AsAutoInc Class Eco.Persistence.MySql Namespace See Also
Collapse All

If the database requires any additional operations in addition to the column type to give a column "autoinc" behaviour, that should be performed by this method.

C#
public void MakeColumnAutoInc(
    string tableName,
    string columnName,
    IDatabase database
);
Remarks

Even if the database does not require any additional operations, this interface should be implemented by an autoinc attribute mapper, and the implementation of this method should be left blank.

See Also
Int32AsAutoInc Class
Eco.Persistence.MySql Namespace


Int32AsAutoInc.StringToParameter Method

Int32AsAutoInc.StringToParameter Method
Int32AsAutoInc Class Eco.Persistence.MySql Namespace See Also
Collapse All

This method should never be called. Autoinc values are never stored!

C#
public void StringToParameter(
    string value,
    IDataParameter parameter
);
Exceptions
Exceptions | Description
NotSupportedException | Thrown always.
See Also
Int32AsAutoInc Class
Eco.Persistence.MySql Namespace


Int32AsAutoInc.ValueToParameter Method

Int32AsAutoInc.ValueToParameter Method
Int32AsAutoInc Class Eco.Persistence.MySql Namespace See Also
Collapse All

This method should never be called. Autoinc values are never stored!

C#
public void ValueToParameter(
    System.Object value,
    IDataParameter parameter
);
Exceptions
Exceptions | Description
NotSupportedException | Thrown always.
See Also
Int32AsAutoInc Class
Eco.Persistence.MySql Namespace


Int32AsAutoInc.ValueType Method

Int32AsAutoInc.ValueType Method
Int32AsAutoInc Class Eco.Persistence.MySql Namespace See Also
Collapse All

This method returns the type of the value that is returned by ColumnToValue.

C#
public System.Type ValueType();
See Also
Int32AsAutoInc Class
Eco.Persistence.MySql Namespace


Int64AsBigInt Class

Int64AsBigInt Class
Inheritance Hierarchy See Also
Collapse All
C#
public sealed class Int64AsBigInt : AbstractNumericSingleColumnAttribute, ISingleColumnAttributemapping, IDefaultReverseMapping;
Remarks

This is class Eco.Persistence.MySql.Int64AsBigInt.

Inheritance Hierarchy
Eco.Persistence.IDefaultReverseMapping
Eco.Persistence.ISingleColumnAttributemapping
    Eco.Persistence.MySql.Int64AsBigInt
File

MySqlAttributeMappers.cs

See Also
Inheritance Hierarchy


Int64AsBigInt.ColumnToValue Method

Int64AsBigInt.ColumnToValue Method
Int64AsBigInt Class Eco.Persistence.MySql Namespace See Also
Collapse All

Converts a value that comes from a database query to an ecospace value.

C#
public override System.Object ColumnToValue(
    System.Object columnValue
);
Remarks

In many cases, the implementation of this method mainly converts DBNull-values to null, but it can also change the CLR-type of the database value from for example a char[] to a string. or from an integer to a boolean. This is the reverse operation of ValueToParameter.

See Also
Int64AsBigInt Class
Eco.Persistence.MySql Namespace


Int64AsBigInt.ColumnType Method

Int64AsBigInt.ColumnType Method
Int64AsBigInt Class Eco.Persistence.MySql Namespace See Also
Collapse All

Specifies the SQL type of the column.

C#
public String ColumnType(
    int length
);
See Also
Int64AsBigInt Class
Eco.Persistence.MySql Namespace


Int64AsBigInt.StringToParameter Method

Int64AsBigInt.StringToParameter Method
Int64AsBigInt Class Eco.Persistence.MySql Namespace See Also
Collapse All
C#
public void StringToParameter(
    string value,
    IDataParameter parameter
);
Remarks

This is StringToParameter, a member of class Int64AsBigInt.

See Also
Int64AsBigInt Class
Eco.Persistence.MySql Namespace


Int64AsBigInt.ValueToParameter Method

Int64AsBigInt.ValueToParameter Method
Int64AsBigInt Class Eco.Persistence.MySql Namespace See Also
Collapse All

Converts a value that comes from a database query to an ecospace value.

C#
public void ValueToParameter(
    System.Object value,
    IDataParameter parameter
);
Remarks

In many cases, the implementation of this method mainly converts null to DBNull, but it can also handle conversion from for example booleans to integers, byte[] to database blobs. It also has to set the correct parameter types in the IDataParameter-object. This is the reverse operation of ColumnToValue.

See Also
Int64AsBigInt Class
Eco.Persistence.MySql Namespace


Int64AsBigInt.ValueType Method

Int64AsBigInt.ValueType Method
Int64AsBigInt Class Eco.Persistence.MySql Namespace See Also
Collapse All

This method returns the type of the value that is returned by ColumnToValue.

C#
public System.Type ValueType();
See Also
Int64AsBigInt Class
Eco.Persistence.MySql Namespace


MySqlStringRes Class

MySqlStringRes Class
Inheritance Hierarchy See Also
Collapse All

Autogenerated class to get compiler safe access to resource strings.

C#
public sealed class MySqlStringRes : StringResources;
Inheritance Hierarchy
Eco.Persistence.MySql.MySqlStringRes
File

Eco.Persistence.MySql.Strings.cs

See Also
Inheritance Hierarchy


MySqlStringRes Properties

MySqlStringRes Properties
Public Properties
Collapse All

The properties of the MySqlStringRes class are listed here.

Public Properties
Name | Description
sHelpConnectionSql | Returns: "Specify the Connection property to point to a MySqlConnection"


MySqlStringRes.sHelpConnectionSql Property

MySqlStringRes.sHelpConnectionSql Property
MySqlStringRes Class Eco.Persistence.MySql Namespace See Also
Collapse All

Returns: "Specify the Connection property to point to a MySqlConnection"

C#
public static string sHelpConnectionSql;
Remarks

For internal use.

See Also
MySqlStringRes Class
Eco.Persistence.MySql Namespace


UInt16AsUnsignedSmallint Class

UInt16AsUnsignedSmallint Class
Inheritance Hierarchy See Also
Collapse All

Class for mapping Int16 values to a single column in a database.

C#
public sealed class UInt16AsUnsignedSmallint : AbstractNumericSingleColumnAttribute, ISingleColumnAttributemapping, IDefaultReverseMapping;
Inheritance Hierarchy
Eco.Persistence.IDefaultReverseMapping
Eco.Persistence.ISingleColumnAttributemapping
    Eco.Persistence.MySql.UInt16AsUnsignedSmallint
File

MySqlAttributeMappers.cs

See Also
Inheritance Hierarchy


UInt16AsUnsignedSmallint Methods

UInt16AsUnsignedSmallint Methods
Public Methods
Collapse All

The methods of the UInt16AsUnsignedSmallint class are listed here.

Public Methods
Name | Description
ColumnToValue | Converts a value that comes from a database query to an ecospace value.
ColumnType | Returns the SQL type used by the database during CREATE TABLE execution.
StringToParameter | Converts a string to the correct data type and then inserts the given value into the IDataParameter.
ValueToParameter | Inserts the given value into the IDataParameter.
ValueType | Returns the .NET type of the column.


UInt16AsUnsignedSmallint.ColumnToValue Method

UInt16AsUnsignedSmallint.ColumnToValue Method
UInt16AsUnsignedSmallint Class Eco.Persistence.MySql Namespace See Also
Collapse All

Converts a value that comes from a database query to an ecospace value.

C#
public override System.Object ColumnToValue(
    System.Object columnValue
);
Remarks

In many cases, the implementation of this method mainly converts DBNull-values to null, but it can also change the CLR-type of the database value from for example a char[] to a string. or from an integer to a boolean. This is the reverse operation of ValueToParameter.

See Also
UInt16AsUnsignedSmallint Class
Eco.Persistence.MySql Namespace


UInt16AsUnsignedSmallint.ColumnType Method

UInt16AsUnsignedSmallint.ColumnType Method
UInt16AsUnsignedSmallint Class Eco.Persistence.MySql Namespace See Also
Collapse All

Returns the SQL type used by the database during CREATE TABLE execution.

C#
public String ColumnType(
    int length
);
Parameters
Parameters | Description
length | This parameter is ignored.
See Also
UInt16AsUnsignedSmallint Class
Eco.Persistence.MySql Namespace


UInt16AsUnsignedSmallint.StringToParameter Method

UInt16AsUnsignedSmallint.StringToParameter Method
UInt16AsUnsignedSmallint Class Eco.Persistence.MySql Namespace See Also
Collapse All

Converts a string to the correct data type and then inserts the given value into the IDataParameter.

C#
public void StringToParameter(
    string value,
    IDataParameter parameter
);
Parameters
Parameters | Description
value | The value to use.
parameter | The IDataParameter to update.
See Also
UInt16AsUnsignedSmallint Class
Eco.Persistence.MySql Namespace


UInt16AsUnsignedSmallint.ValueToParameter Method

UInt16AsUnsignedSmallint.ValueToParameter Method
UInt16AsUnsignedSmallint Class Eco.Persistence.MySql Namespace See Also
Collapse All

Inserts the given value into the IDataParameter.

C#
public void ValueToParameter(
    System.Object value,
    IDataParameter parameter
);
Parameters
Parameters | Description
value | The value to use.
parameter | The IDataParameter to update.
See Also
UInt16AsUnsignedSmallint Class
Eco.Persistence.MySql Namespace


UInt16AsUnsignedSmallint.ValueType Method

UInt16AsUnsignedSmallint.ValueType Method
UInt16AsUnsignedSmallint Class Eco.Persistence.MySql Namespace See Also
Collapse All

Returns the .NET type of the column.

C#
public System.Type ValueType();
See Also
UInt16AsUnsignedSmallint Class
Eco.Persistence.MySql Namespace


Eco.Persistence.MySql.Bdp Namespace

Eco.Persistence.MySql.Bdp Namespace
Classes
Collapse All

This is namespace Eco.Persistence.MySql.Bdp.

Classes
Name | Description
ByteArrayAsBdpBlob | Mapper between a ByteArray value and its persistent representation as BLOB.
StringAsLongText | This is class Eco.Persistence.MySql.Bdp.StringAsLongText.


ByteArrayAsBdpBlob Class

ByteArrayAsBdpBlob Class
Inheritance Hierarchy See Also
Collapse All

Mapper between a ByteArray value and its persistent representation as BLOB.

C#
public sealed class ByteArrayAsBdpBlob : AbstractSingleColumnAttribute, ISingleColumnAttributemapping;
Inheritance Hierarchy
Eco.Persistence.ISingleColumnAttributemapping
    Eco.Persistence.MySql.Bdp.ByteArrayAsBdpBlob
File

MySqlAttributeMappersBdp.cs

See Also
Inheritance Hierarchy


ByteArrayAsBdpBlob.ColumnToValue Method

ByteArrayAsBdpBlob.ColumnToValue Method
ByteArrayAsBdpBlob Class Eco.Persistence.MySql.Bdp Namespace See Also
Collapse All

Converts a value that comes from a database query to an ecospace value.

C#
public override System.Object ColumnToValue(
    System.Object columnValue
);
Remarks

In many cases, the implementation of this method mainly converts DBNull-values to null, but it can also change the CLR-type of the database value from for example a char[] to a string. or from an integer to a boolean. This is the reverse operation of ValueToParameter.

See Also
ByteArrayAsBdpBlob Class
Eco.Persistence.MySql.Bdp Namespace


ByteArrayAsBdpBlob.ColumnType Method

ByteArrayAsBdpBlob.ColumnType Method
ByteArrayAsBdpBlob Class Eco.Persistence.MySql.Bdp Namespace See Also
Collapse All

Specifies the SQL type of the column.

C#
public string ColumnType(
    int length
);
See Also
ByteArrayAsBdpBlob Class
Eco.Persistence.MySql.Bdp Namespace


ByteArrayAsBdpBlob.DefaultDbValue Method

ByteArrayAsBdpBlob.DefaultDbValue Method
ByteArrayAsBdpBlob Class Eco.Persistence.MySql.Bdp Namespace See Also
Collapse All

The return value of this function will be used as default value for new columns when databases are created/evolved.

C#
public string DefaultDbValue(
    string modeledValue,
    SqlDatabaseConfig sqlDatabaseConfig
);
See Also
ByteArrayAsBdpBlob Class
Eco.Persistence.MySql.Bdp Namespace


ByteArrayAsBdpBlob.IsEqual Method

ByteArrayAsBdpBlob.IsEqual Method
ByteArrayAsBdpBlob Class Eco.Persistence.MySql.Bdp Namespace See Also
Collapse All

Returns true if an ecospace value ("value") is equal to a database value ("columnValue").

C#
public override bool IsEqual(
    System.Object value,
    System.Object columnValue
);
Remarks

This method must handle the conversions between ecospace and database values, it must also handle comparing null/DBNull values.

See Also
ByteArrayAsBdpBlob Class
Eco.Persistence.MySql.Bdp Namespace


ByteArrayAsBdpBlob.StringToParameter Method

ByteArrayAsBdpBlob.StringToParameter Method
ByteArrayAsBdpBlob Class Eco.Persistence.MySql.Bdp Namespace See Also
Collapse All
C#
public void StringToParameter(
    string value,
    IDataParameter parameter
);
Exceptions
Exceptions | Description
InvalidOperationException | Thrown always.
See Also
ByteArrayAsBdpBlob Class
Eco.Persistence.MySql.Bdp Namespace


ByteArrayAsBdpBlob.ValueToParameter Method

ByteArrayAsBdpBlob.ValueToParameter Method
ByteArrayAsBdpBlob Class Eco.Persistence.MySql.Bdp Namespace See Also
Collapse All

Converts a value that comes from a database query to an ecospace value.

C#
public void ValueToParameter(
    System.Object value,
    IDataParameter parameter
);
Remarks

In many cases, the implementation of this method mainly converts null to DBNull, but it can also handle conversion from for example booleans to integers, byte[] to database blobs. It also has to set the correct parameter types in the IDataParameter-object. This is the reverse operation of ColumnToValue.

See Also
ByteArrayAsBdpBlob Class
Eco.Persistence.MySql.Bdp Namespace


ByteArrayAsBdpBlob.ValueType Method

ByteArrayAsBdpBlob.ValueType Method
ByteArrayAsBdpBlob Class Eco.Persistence.MySql.Bdp Namespace See Also
Collapse All

This method returns the type of the value that is returned by ColumnToValue.

C#
public System.Type ValueType();
See Also
ByteArrayAsBdpBlob Class
Eco.Persistence.MySql.Bdp Namespace


StringAsLongText Class

StringAsLongText Class
Inheritance Hierarchy See Also
Collapse All
C#
public sealed class StringAsLongText : AbstractSingleColumnAttribute, ISingleColumnAttributemapping;
Remarks

This is class Eco.Persistence.MySql.Bdp.StringAsLongText.

Inheritance Hierarchy
Eco.Persistence.ISingleColumnAttributemapping
    Eco.Persistence.MySql.Bdp.StringAsLongText
File

MySqlAttributeMappersBdp.cs

See Also
Inheritance Hierarchy


StringAsLongText.ColumnToValue Method

StringAsLongText.ColumnToValue Method
StringAsLongText Class Eco.Persistence.MySql.Bdp Namespace See Also
Collapse All

Converts a value that comes from a database query to an ecospace value.

C#
public override System.Object ColumnToValue(
    System.Object columnValue
);
Remarks

In many cases, the implementation of this method mainly converts DBNull-values to null, but it can also change the CLR-type of the database value from for example a char[] to a string. or from an integer to a boolean. This is the reverse operation of ValueToParameter.

See Also
StringAsLongText Class
Eco.Persistence.MySql.Bdp Namespace


StringAsLongText.ColumnType Method

StringAsLongText.ColumnType Method
StringAsLongText Class Eco.Persistence.MySql.Bdp Namespace See Also
Collapse All

Specifies the SQL type of the column.

C#
public string ColumnType(
    int length
);
See Also
StringAsLongText Class
Eco.Persistence.MySql.Bdp Namespace


StringAsLongText.DefaultDbValue Method

StringAsLongText.DefaultDbValue Method
StringAsLongText Class Eco.Persistence.MySql.Bdp Namespace See Also
Collapse All

The return value of this function will be used as default value for new columns when databases are created/evolved.

C#
public string DefaultDbValue(
    string modeledValue,
    SqlDatabaseConfig sqlDatabaseConfig
);
See Also
StringAsLongText Class
Eco.Persistence.MySql.Bdp Namespace


StringAsLongText.StringToParameter Method

StringAsLongText.StringToParameter Method
StringAsLongText Class Eco.Persistence.MySql.Bdp Namespace See Also
Collapse All
C#
public void StringToParameter(
    string value,
    IDataParameter parameter
);
Remarks

This is StringToParameter, a member of class StringAsLongText.

See Also
StringAsLongText Class
Eco.Persistence.MySql.Bdp Namespace


StringAsLongText.ValueToParameter Method

StringAsLongText.ValueToParameter Method
StringAsLongText Class Eco.Persistence.MySql.Bdp Namespace See Also
Collapse All

Converts a value that comes from a database query to an ecospace value.

C#
public void ValueToParameter(
    System.Object value,
    IDataParameter parameter
);
Remarks

In many cases, the implementation of this method mainly converts null to DBNull, but it can also handle conversion from for example booleans to integers, byte[] to database blobs. It also has to set the correct parameter types in the IDataParameter-object. This is the reverse operation of ColumnToValue.

See Also
StringAsLongText Class
Eco.Persistence.MySql.Bdp Namespace


StringAsLongText.ValueType Method

StringAsLongText.ValueType Method
StringAsLongText Class Eco.Persistence.MySql.Bdp Namespace See Also
Collapse All

This method returns the type of the value that is returned by ColumnToValue.

C#
public System.Type ValueType();
See Also
StringAsLongText Class
Eco.Persistence.MySql.Bdp Namespace


Eco.Persistence.MySql.MysClient Namespace

Eco.Persistence.MySql.MysClient Namespace
Classes
Collapse All

This is namespace Eco.Persistence.MySql.MysClient.

Classes
Name | Description
ByteArrayAsBlob | Mapper between a ByteArray value and its persistent representation as BLOB.
Int64AsBigInt | This is class Eco.Persistence.MySql.MysClient.Int64AsBigInt.
StringAsLongText | This is class Eco.Persistence.MySql.MysClient.StringAsLongText.
StringAsUnicodeText | This is class Eco.Persistence.MySql.MysClient.StringAsUnicodeText.
StringAsUnicodeVarChar | This is class Eco.Persistence.MySql.MysClient.StringAsUnicodeVarChar.


ByteArrayAsBlob Class

ByteArrayAsBlob Class
Inheritance Hierarchy See Also
Collapse All

Mapper between a ByteArray value and its persistent representation as BLOB.

C#
public sealed class ByteArrayAsBlob : AbstractSingleColumnAttribute, ISingleColumnAttributemapping, IDefaultReverseMapping;
Inheritance Hierarchy
Eco.Persistence.IDefaultReverseMapping
Eco.Persistence.ISingleColumnAttributemapping
    Eco.Persistence.MySql.MysClient.ByteArrayAsBlob
File

MySqlAttributeMappersMySqlClient.cs

See Also
Inheritance Hierarchy


ByteArrayAsBlob.ColumnToValue Method

ByteArrayAsBlob.ColumnToValue Method
ByteArrayAsBlob Class Eco.Persistence.MySql.MysClient Namespace See Also
Collapse All

Converts a value that comes from a database query to an ecospace value.

C#
public override System.Object ColumnToValue(
    System.Object columnValue
);
Remarks

In many cases, the implementation of this method mainly converts DBNull-values to null, but it can also change the CLR-type of the database value from for example a char[] to a string. or from an integer to a boolean. This is the reverse operation of ValueToParameter.

See Also
ByteArrayAsBlob Class
Eco.Persistence.MySql.MysClient Namespace


ByteArrayAsBlob.ColumnType Method

ByteArrayAsBlob.ColumnType Method
ByteArrayAsBlob Class Eco.Persistence.MySql.MysClient Namespace See Also
Collapse All

Specifies the SQL type of the column.

C#
public string ColumnType(
    int length
);
See Also
ByteArrayAsBlob Class
Eco.Persistence.MySql.MysClient Namespace


ByteArrayAsBlob.DefaultDbValue Method

ByteArrayAsBlob.DefaultDbValue Method
ByteArrayAsBlob Class Eco.Persistence.MySql.MysClient Namespace See Also
Collapse All

The return value of this function will be used as default value for new columns when databases are created/evolved.

C#
public string DefaultDbValue(
    string modeledValue,
    SqlDatabaseConfig sqlDatabaseConfig
);
See Also
ByteArrayAsBlob Class
Eco.Persistence.MySql.MysClient Namespace


ByteArrayAsBlob.IsEqual Method

ByteArrayAsBlob.IsEqual Method
ByteArrayAsBlob Class Eco.Persistence.MySql.MysClient Namespace See Also
Collapse All

Returns true if an ecospace value ("value") is equal to a database value ("columnValue").

C#
public override bool IsEqual(
    System.Object value,
    System.Object columnValue
);
Remarks

This method must handle the conversions between ecospace and database values, it must also handle comparing null/DBNull values.

See Also
ByteArrayAsBlob Class
Eco.Persistence.MySql.MysClient Namespace


ByteArrayAsBlob.StringToParameter Method

ByteArrayAsBlob.StringToParameter Method
ByteArrayAsBlob Class Eco.Persistence.MySql.MysClient Namespace See Also
Collapse All
C#
public void StringToParameter(
    string value,
    IDataParameter parameter
);
Exceptions
Exceptions | Description
InvalidOperationException | Thrown always.
See Also
ByteArrayAsBlob Class
Eco.Persistence.MySql.MysClient Namespace


ByteArrayAsBlob.ValueToParameter Method

ByteArrayAsBlob.ValueToParameter Method
ByteArrayAsBlob Class Eco.Persistence.MySql.MysClient Namespace See Also
Collapse All

Converts a value that comes from a database query to an ecospace value.

C#
public void ValueToParameter(
    System.Object value,
    IDataParameter parameter
);
Remarks

In many cases, the implementation of this method mainly converts null to DBNull, but it can also handle conversion from for example booleans to integers, byte[] to database blobs. It also has to set the correct parameter types in the IDataParameter-object. This is the reverse operation of ColumnToValue.

See Also
ByteArrayAsBlob Class
Eco.Persistence.MySql.MysClient Namespace


ByteArrayAsBlob.ValueType Method

ByteArrayAsBlob.ValueType Method
ByteArrayAsBlob Class Eco.Persistence.MySql.MysClient Namespace See Also
Collapse All

This method returns the type of the value that is returned by ColumnToValue.

C#
public System.Type ValueType();
See Also
ByteArrayAsBlob Class
Eco.Persistence.MySql.MysClient Namespace


Int64AsBigInt Class

Int64AsBigInt Class
Inheritance Hierarchy See Also
Collapse All
C#
public sealed class Int64AsBigInt : AbstractNumericSingleColumnAttribute, ISingleColumnAttributemapping, IDefaultReverseMapping;
Remarks

This is class Eco.Persistence.MySql.MysClient.Int64AsBigInt.

Inheritance Hierarchy
Eco.Persistence.IDefaultReverseMapping
Eco.Persistence.ISingleColumnAttributemapping
    Eco.Persistence.MySql.MysClient.Int64AsBigInt
File

MySqlAttributeMappersMySqlClient.cs

See Also
Inheritance Hierarchy


Int64AsBigInt.ColumnToValue Method

Int64AsBigInt.ColumnToValue Method
Int64AsBigInt Class Eco.Persistence.MySql.MysClient Namespace See Also
Collapse All

Converts a value that comes from a database query to an ecospace value.

C#
public override System.Object ColumnToValue(
    System.Object columnValue
);
Remarks

In many cases, the implementation of this method mainly converts DBNull-values to null, but it can also change the CLR-type of the database value from for example a char[] to a string. or from an integer to a boolean. This is the reverse operation of ValueToParameter.

See Also
Int64AsBigInt Class
Eco.Persistence.MySql.MysClient Namespace


Int64AsBigInt.ColumnType Method

Int64AsBigInt.ColumnType Method
Int64AsBigInt Class Eco.Persistence.MySql.MysClient Namespace See Also
Collapse All

Specifies the SQL type of the column.

C#
public String ColumnType(
    int length
);
See Also
Int64AsBigInt Class
Eco.Persistence.MySql.MysClient Namespace


Int64AsBigInt.StringToParameter Method

Int64AsBigInt.StringToParameter Method
Int64AsBigInt Class Eco.Persistence.MySql.MysClient Namespace See Also
Collapse All
C#
public void StringToParameter(
    string value,
    IDataParameter parameter
);
Remarks

This is StringToParameter, a member of class Int64AsBigInt.

See Also
Int64AsBigInt Class
Eco.Persistence.MySql.MysClient Namespace


Int64AsBigInt.ValueToParameter Method

Int64AsBigInt.ValueToParameter Method
Int64AsBigInt Class Eco.Persistence.MySql.MysClient Namespace See Also
Collapse All

Converts a value that comes from a database query to an ecospace value.

C#
public void ValueToParameter(
    System.Object value,
    IDataParameter parameter
);
Remarks

In many cases, the implementation of this method mainly converts null to DBNull, but it can also handle conversion from for example booleans to integers, byte[] to database blobs. It also has to set the correct parameter types in the IDataParameter-object. This is the reverse operation of ColumnToValue.

See Also
Int64AsBigInt Class
Eco.Persistence.MySql.MysClient Namespace


Int64AsBigInt.ValueType Method

Int64AsBigInt.ValueType Method
Int64AsBigInt Class Eco.Persistence.MySql.MysClient Namespace See Also
Collapse All

This method returns the type of the value that is returned by ColumnToValue.

C#
public System.Type ValueType();
See Also
Int64AsBigInt Class
Eco.Persistence.MySql.MysClient Namespace


StringAsLongText Class

StringAsLongText Class
Inheritance Hierarchy See Also
Collapse All
C#
public sealed class StringAsLongText : AbstractSingleColumnAttribute, ISingleColumnAttributemapping, IDefaultReverseMapping;
Remarks

This is class Eco.Persistence.MySql.MysClient.StringAsLongText.

Inheritance Hierarchy
Eco.Persistence.IDefaultReverseMapping
Eco.Persistence.ISingleColumnAttributemapping
    Eco.Persistence.MySql.MysClient.StringAsLongText
File

MySqlAttributeMappersMySqlClient.cs

See Also
Inheritance Hierarchy


StringAsLongText.ColumnToValue Method

StringAsLongText.ColumnToValue Method
StringAsLongText Class Eco.Persistence.MySql.MysClient Namespace See Also
Collapse All

Converts a value that comes from a database query to an ecospace value.

C#
public override System.Object ColumnToValue(
    System.Object columnValue
);
Remarks

In many cases, the implementation of this method mainly converts DBNull-values to null, but it can also change the CLR-type of the database value from for example a char[] to a string. or from an integer to a boolean. This is the reverse operation of ValueToParameter.

See Also
StringAsLongText Class
Eco.Persistence.MySql.MysClient Namespace


StringAsLongText.ColumnType Method

StringAsLongText.ColumnType Method
StringAsLongText Class Eco.Persistence.MySql.MysClient Namespace See Also
Collapse All

Specifies the SQL type of the column.

C#
public string ColumnType(
    int length
);
See Also
StringAsLongText Class
Eco.Persistence.MySql.MysClient Namespace


StringAsLongText.DefaultDbValue Method

StringAsLongText.DefaultDbValue Method
StringAsLongText Class Eco.Persistence.MySql.MysClient Namespace See Also
Collapse All

The return value of this function will be used as default value for new columns when databases are created/evolved.

C#
public string DefaultDbValue(
    string modeledValue,
    SqlDatabaseConfig sqlDatabaseConfig
);
See Also
StringAsLongText Class
Eco.Persistence.MySql.MysClient Namespace


StringAsLongText.StringToParameter Method

StringAsLongText.StringToParameter Method
StringAsLongText Class Eco.Persistence.MySql.MysClient Namespace See Also
Collapse All
C#
public void StringToParameter(
    string value,
    IDataParameter parameter
);
Remarks

This is StringToParameter, a member of class StringAsLongText.

See Also
StringAsLongText Class
Eco.Persistence.MySql.MysClient Namespace


StringAsLongText.ValueToParameter Method

StringAsLongText.ValueToParameter Method
StringAsLongText Class Eco.Persistence.MySql.MysClient Namespace See Also
Collapse All

Converts a value that comes from a database query to an ecospace value.

C#
public void ValueToParameter(
    System.Object value,
    IDataParameter parameter
);
Remarks

In many cases, the implementation of this method mainly converts null to DBNull, but it can also handle conversion from for example booleans to integers, byte[] to database blobs. It also has to set the correct parameter types in the IDataParameter-object. This is the reverse operation of ColumnToValue.

See Also
StringAsLongText Class
Eco.Persistence.MySql.MysClient Namespace


StringAsLongText.ValueType Method

StringAsLongText.ValueType Method
StringAsLongText Class Eco.Persistence.MySql.MysClient Namespace See Also
Collapse All

This method returns the type of the value that is returned by ColumnToValue.

C#
public System.Type ValueType();
See Also
StringAsLongText Class
Eco.Persistence.MySql.MysClient Namespace


StringAsUnicodeText Class

StringAsUnicodeText Class
Inheritance Hierarchy See Also
Collapse All
C#
public sealed class StringAsUnicodeText : AbstractSingleColumnAttribute, ISingleColumnAttributemapping, IDefaultReverseMapping;
Remarks

This is class Eco.Persistence.MySql.MysClient.StringAsUnicodeText.

Inheritance Hierarchy
Eco.Persistence.IDefaultReverseMapping
Eco.Persistence.ISingleColumnAttributemapping
    Eco.Persistence.MySql.MysClient.StringAsUnicodeText
File

MySqlAttributeMappersMySqlClient.cs

See Also
Inheritance Hierarchy


StringAsUnicodeText Methods

StringAsUnicodeText Methods
Public Methods
Collapse All

The methods of the StringAsUnicodeText class are listed here.

Public Methods
Name | Description
ColumnToValue | Converts a value that comes from a database query to an ecospace value.
ColumnType | Specifies the SQL type of the column.
DefaultDbValue | The return value of this function will be used as default value for new columns when databases are created/evolved.
StringToParameter | This is StringToParameter, a member of class StringAsUnicodeText.
ValueToParameter | Converts a value that comes from a database query to an ecospace value.
ValueType | This method returns the type of the value that is returned by ColumnToValue.


StringAsUnicodeText.ColumnToValue Method

StringAsUnicodeText.ColumnToValue Method
StringAsUnicodeText Class Eco.Persistence.MySql.MysClient Namespace See Also
Collapse All

Converts a value that comes from a database query to an ecospace value.

C#
public override System.Object ColumnToValue(
    System.Object columnValue
);
Remarks

In many cases, the implementation of this method mainly converts DBNull-values to null, but it can also change the CLR-type of the database value from for example a char[] to a string. or from an integer to a boolean. This is the reverse operation of ValueToParameter.

See Also
StringAsUnicodeText Class
Eco.Persistence.MySql.MysClient Namespace


StringAsUnicodeText.ColumnType Method

StringAsUnicodeText.ColumnType Method
StringAsUnicodeText Class Eco.Persistence.MySql.MysClient Namespace See Also
Collapse All

Specifies the SQL type of the column.

C#
public string ColumnType(
    int length
);
See Also
StringAsUnicodeText Class
Eco.Persistence.MySql.MysClient Namespace


StringAsUnicodeText.DefaultDbValue Method

StringAsUnicodeText.DefaultDbValue Method
StringAsUnicodeText Class Eco.Persistence.MySql.MysClient Namespace See Also
Collapse All

The return value of this function will be used as default value for new columns when databases are created/evolved.

C#
public string DefaultDbValue(
    string modeledValue,
    SqlDatabaseConfig sqlDatabaseConfig
);
See Also
StringAsUnicodeText Class
Eco.Persistence.MySql.MysClient Namespace


StringAsUnicodeText.StringToParameter Method

StringAsUnicodeText.StringToParameter Method
StringAsUnicodeText Class Eco.Persistence.MySql.MysClient Namespace See Also
Collapse All
C#
public void StringToParameter(
    string value,
    IDataParameter parameter
);
Remarks

This is StringToParameter, a member of class StringAsUnicodeText.

See Also
StringAsUnicodeText Class
Eco.Persistence.MySql.MysClient Namespace


StringAsUnicodeText.ValueToParameter Method

StringAsUnicodeText.ValueToParameter Method
StringAsUnicodeText Class Eco.Persistence.MySql.MysClient Namespace See Also
Collapse All

Converts a value that comes from a database query to an ecospace value.

C#
public void ValueToParameter(
    System.Object value,
    IDataParameter parameter
);
Remarks

In many cases, the implementation of this method mainly converts null to DBNull, but it can also handle conversion from for example booleans to integers, byte[] to database blobs. It also has to set the correct parameter types in the IDataParameter-object. This is the reverse operation of ColumnToValue.

See Also
StringAsUnicodeText Class
Eco.Persistence.MySql.MysClient Namespace


StringAsUnicodeText.ValueType Method

StringAsUnicodeText.ValueType Method
StringAsUnicodeText Class Eco.Persistence.MySql.MysClient Namespace See Also
Collapse All

This method returns the type of the value that is returned by ColumnToValue.

C#
public System.Type ValueType();
See Also
StringAsUnicodeText Class
Eco.Persistence.MySql.MysClient Namespace


StringAsUnicodeVarChar Class

StringAsUnicodeVarChar Class
Inheritance Hierarchy See Also
Collapse All
C#
public sealed class StringAsUnicodeVarChar : AbstractStringSingleColumnAttribute, ISingleColumnAttributemapping, IDefaultReverseMapping;
Remarks

This is class Eco.Persistence.MySql.MysClient.StringAsUnicodeVarChar.

Inheritance Hierarchy
Eco.Persistence.IDefaultReverseMapping
Eco.Persistence.ISingleColumnAttributemapping
    Eco.Persistence.MySql.MysClient.StringAsUnicodeVarChar
File

MySqlAttributeMappersMySqlClient.cs

See Also
Inheritance Hierarchy


StringAsUnicodeVarChar Methods

StringAsUnicodeVarChar Methods
Public Methods
Collapse All

The methods of the StringAsUnicodeVarChar class are listed here.

Public Methods
Name | Description
ColumnToValue | Converts a value that comes from a database query to an ecospace value.
ColumnType | Specifies the SQL type of the column.
StringToParameter | This is StringToParameter, a member of class StringAsUnicodeVarChar.
ValueToParameter | Converts a value that comes from a database query to an ecospace value.
ValueType | This method returns the type of the value that is returned by ColumnToValue.


StringAsUnicodeVarChar.ColumnToValue Method

StringAsUnicodeVarChar.ColumnToValue Method
StringAsUnicodeVarChar Class Eco.Persistence.MySql.MysClient Namespace See Also
Collapse All

Converts a value that comes from a database query to an ecospace value.

C#
public override System.Object ColumnToValue(
    System.Object columnValue
);
Remarks

In many cases, the implementation of this method mainly converts DBNull-values to null, but it can also change the CLR-type of the database value from for example a char[] to a string. or from an integer to a boolean. This is the reverse operation of ValueToParameter.

See Also
StringAsUnicodeVarChar Class
Eco.Persistence.MySql.MysClient Namespace


StringAsUnicodeVarChar.ColumnType Method

StringAsUnicodeVarChar.ColumnType Method
StringAsUnicodeVarChar Class Eco.Persistence.MySql.MysClient Namespace See Also
Collapse All

Specifies the SQL type of the column.

C#
public string ColumnType(
    int length
);
See Also
StringAsUnicodeVarChar Class
Eco.Persistence.MySql.MysClient Namespace


StringAsUnicodeVarChar.StringToParameter Method

StringAsUnicodeVarChar.StringToParameter Method
StringAsUnicodeVarChar Class Eco.Persistence.MySql.MysClient Namespace See Also
Collapse All
C#
public void StringToParameter(
    string value,
    IDataParameter parameter
);
Remarks

This is StringToParameter, a member of class StringAsUnicodeVarChar.

See Also
StringAsUnicodeVarChar Class
Eco.Persistence.MySql.MysClient Namespace


StringAsUnicodeVarChar.ValueToParameter Method

StringAsUnicodeVarChar.ValueToParameter Method
StringAsUnicodeVarChar Class Eco.Persistence.MySql.MysClient Namespace See Also
Collapse All

Converts a value that comes from a database query to an ecospace value.

C#
public void ValueToParameter(
    System.Object value,
    IDataParameter parameter
);
Remarks

In many cases, the implementation of this method mainly converts null to DBNull, but it can also handle conversion from for example booleans to integers, byte[] to database blobs. It also has to set the correct parameter types in the IDataParameter-object. This is the reverse operation of ColumnToValue.

See Also
StringAsUnicodeVarChar Class
Eco.Persistence.MySql.MysClient Namespace


StringAsUnicodeVarChar.ValueType Method

StringAsUnicodeVarChar.ValueType Method
StringAsUnicodeVarChar Class Eco.Persistence.MySql.MysClient Namespace See Also
Collapse All

This method returns the type of the value that is returned by ColumnToValue.

C#
public System.Type ValueType();
See Also
StringAsUnicodeVarChar Class
Eco.Persistence.MySql.MysClient Namespace


Eco.Persistence.Nexus Namespace

Eco.Persistence.Nexus Namespace
Classes
Collapse All

This is namespace Eco.Persistence.Nexus.

Classes
Name | Description
AbstractAutoInc | This is class Eco.Persistence.Nexus.AbstractAutoInc.
AbstractByteArrayAsNexusDBBlob | This is class Eco.Persistence.Nexus.AbstractByteArrayAsNexusDBBlob.
AbstractStringAsNexusDBClob | This is class Eco.Persistence.Nexus.AbstractStringAsNexusDBClob.
AbstractStringAsNexusDBNClob | This is class Eco.Persistence.Nexus.AbstractStringAsNexusDBNClob.
BooleanAsBool | This is class Eco.Persistence.Nexus.BooleanAsBool.
ByteArrayAsNexusDBBlob | This is class Eco.Persistence.Nexus.ByteArrayAsNexusDBBlob.
DecimalAsDecimal | This is class Eco.Persistence.Nexus.DecimalAsDecimal.
DoubleAsDouble | This is class Eco.Persistence.Nexus.DoubleAsDouble.
GuidAsGuid | This is class Eco.Persistence.Nexus.GuidAsGuid.
Int32AsAutoInc | This is class Eco.Persistence.Nexus.Int32AsAutoInc.
Int64AsBigInt | This is class Eco.Persistence.Nexus.Int64AsBigInt.
NxIDatabaseImpl | This is class Eco.Persistence.Nexus.NxIDatabaseImpl.
SingleAsFloat | This is class Eco.Persistence.Nexus.SingleAsFloat.
StringAsNexusDBClob | This is class Eco.Persistence.Nexus.StringAsNexusDBClob.
StringAsNexusDBNClob | This is class Eco.Persistence.Nexus.StringAsNexusDBNClob.
StringAsVarChar | Class for mapping String values to a single column in a database. Map


AbstractAutoInc Class

AbstractAutoInc Class
Inheritance Hierarchy See Also
Collapse All
C#
public abstract class AbstractAutoInc : AbstractNumericSingleColumnAttribute;
Remarks

This is class Eco.Persistence.Nexus.AbstractAutoInc.

Inheritance Hierarchy
Eco.Persistence.Nexus.AbstractAutoInc
    Eco.Persistence.Nexus.Int32AsAutoInc
File

NexusDBMappers.cs

See Also
Inheritance Hierarchy


AbstractAutoInc Methods

AbstractAutoInc Methods
Public Methods
Collapse All

The methods of the AbstractAutoInc class are listed here.

Public Methods
Name | Description
MakeColumnAutoInc | This is MakeColumnAutoInc, a member of class AbstractAutoInc.
StringToParameter | This is StringToParameter, a member of class AbstractAutoInc.
ValueToParameter | This is ValueToParameter, a member of class AbstractAutoInc.


AbstractAutoInc.MakeColumnAutoInc Method

AbstractAutoInc.MakeColumnAutoInc Method
AbstractAutoInc Class Eco.Persistence.Nexus Namespace See Also
Collapse All
C#
public void MakeColumnAutoInc(
    string tableName,
    string columnName,
    IDatabase database
);
Remarks

This is MakeColumnAutoInc, a member of class AbstractAutoInc.

See Also
AbstractAutoInc Class
Eco.Persistence.Nexus Namespace


AbstractAutoInc.StringToParameter Method

AbstractAutoInc.StringToParameter Method
AbstractAutoInc Class Eco.Persistence.Nexus Namespace See Also
Collapse All
C#
public void StringToParameter(
    string value,
    IDataParameter parameter
);
Remarks

This is StringToParameter, a member of class AbstractAutoInc.

See Also
AbstractAutoInc Class
Eco.Persistence.Nexus Namespace


AbstractAutoInc.ValueToParameter Method

AbstractAutoInc.ValueToParameter Method
AbstractAutoInc Class Eco.Persistence.Nexus Namespace See Also
Collapse All
C#
public void ValueToParameter(
    System.Object value,
    IDataParameter parameter
);
Remarks

This is ValueToParameter, a member of class AbstractAutoInc.

See Also
AbstractAutoInc Class
Eco.Persistence.Nexus Namespace


AbstractByteArrayAsNexusDBBlob Class

AbstractByteArrayAsNexusDBBlob Class
Inheritance Hierarchy See Also
Collapse All
C#
public abstract class AbstractByteArrayAsNexusDBBlob : AbstractSingleColumnAttribute;
Remarks

This is class Eco.Persistence.Nexus.AbstractByteArrayAsNexusDBBlob.

Inheritance Hierarchy
Eco.Persistence.Nexus.AbstractByteArrayAsNexusDBBlob
    Eco.Persistence.Nexus.ByteArrayAsNexusDBBlob
File

NexusDBMappers.cs

See Also
Inheritance Hierarchy


AbstractByteArrayAsNexusDBBlob Methods

AbstractByteArrayAsNexusDBBlob Methods
Public Methods
Collapse All

The methods of the AbstractByteArrayAsNexusDBBlob class are listed here.

Public Methods
Name | Description
ColumnToValue | This is ColumnToValue, a member of class AbstractByteArrayAsNexusDBBlob.
ColumnType | This is ColumnType, a member of class AbstractByteArrayAsNexusDBBlob.
DefaultDbValue | This is DefaultDbValue, a member of class AbstractByteArrayAsNexusDBBlob.
StringToParameter | This is StringToParameter, a member of class AbstractByteArrayAsNexusDBBlob.
ValueType | This is ValueType, a member of class AbstractByteArrayAsNexusDBBlob.


AbstractByteArrayAsNexusDBBlob.ColumnToValue Method

AbstractByteArrayAsNexusDBBlob.ColumnToValue Method
AbstractByteArrayAsNexusDBBlob Class Eco.Persistence.Nexus Namespace See Also
Collapse All
C#
public override System.Object ColumnToValue(
    System.Object columnValue
);
Remarks

This is ColumnToValue, a member of class AbstractByteArrayAsNexusDBBlob.

See Also
AbstractByteArrayAsNexusDBBlob Class
Eco.Persistence.Nexus Namespace


AbstractByteArrayAsNexusDBBlob.ColumnType Method

AbstractByteArrayAsNexusDBBlob.ColumnType Method
AbstractByteArrayAsNexusDBBlob Class Eco.Persistence.Nexus Namespace See Also
Collapse All
C#
public String ColumnType(
    int length
);
Remarks

This is ColumnType, a member of class AbstractByteArrayAsNexusDBBlob.

See Also
AbstractByteArrayAsNexusDBBlob Class
Eco.Persistence.Nexus Namespace


AbstractByteArrayAsNexusDBBlob.DefaultDbValue Method

AbstractByteArrayAsNexusDBBlob.DefaultDbValue Method
AbstractByteArrayAsNexusDBBlob Class Eco.Persistence.Nexus Namespace See Also
Collapse All
C#
public String DefaultDbValue(
    string modeledValue,
    SqlDatabaseConfig sqlDatabaseConfig
);
Remarks

This is DefaultDbValue, a member of class AbstractByteArrayAsNexusDBBlob.

See Also
AbstractByteArrayAsNexusDBBlob Class
Eco.Persistence.Nexus Namespace


AbstractByteArrayAsNexusDBBlob.StringToParameter Method

AbstractByteArrayAsNexusDBBlob.StringToParameter Method
AbstractByteArrayAsNexusDBBlob Class Eco.Persistence.Nexus Namespace See Also
Collapse All
C#
public void StringToParameter(
    string value,
    IDataParameter parameter
);
Remarks

This is StringToParameter, a member of class AbstractByteArrayAsNexusDBBlob.

See Also
AbstractByteArrayAsNexusDBBlob Class
Eco.Persistence.Nexus Namespace


AbstractByteArrayAsNexusDBBlob.ValueType Method

AbstractByteArrayAsNexusDBBlob.ValueType Method
AbstractByteArrayAsNexusDBBlob Class Eco.Persistence.Nexus Namespace See Also
Collapse All
C#
public System.Type ValueType();
Remarks

This is ValueType, a member of class AbstractByteArrayAsNexusDBBlob.

See Also
AbstractByteArrayAsNexusDBBlob Class
Eco.Persistence.Nexus Namespace


AbstractStringAsNexusDBClob Class

AbstractStringAsNexusDBClob Class
Inheritance Hierarchy See Also
Collapse All
C#
public abstract class AbstractStringAsNexusDBClob : AbstractSingleColumnAttribute;
Remarks

This is class Eco.Persistence.Nexus.AbstractStringAsNexusDBClob.

Inheritance Hierarchy
Eco.Persistence.Nexus.AbstractStringAsNexusDBClob
    Eco.Persistence.Nexus.StringAsNexusDBClob
File

NexusDBMappers.cs

See Also
Inheritance Hierarchy


AbstractStringAsNexusDBClob Methods

AbstractStringAsNexusDBClob Methods
Public Methods
Collapse All

The methods of the AbstractStringAsNexusDBClob class are listed here.

Public Methods
Name | Description
ColumnType | This is ColumnType, a member of class AbstractStringAsNexusDBClob.
DefaultDbValue | This is DefaultDbValue, a member of class AbstractStringAsNexusDBClob.
StringToParameter | This is StringToParameter, a member of class AbstractStringAsNexusDBClob.
ValueToParameter | This is ValueToParameter, a member of class AbstractStringAsNexusDBClob.
ValueType | This is ValueType, a member of class AbstractStringAsNexusDBClob.


AbstractStringAsNexusDBClob.ColumnType Method

AbstractStringAsNexusDBClob.ColumnType Method
AbstractStringAsNexusDBClob Class Eco.Persistence.Nexus Namespace See Also
Collapse All
C#
public String ColumnType(
    int length
);
Remarks

This is ColumnType, a member of class AbstractStringAsNexusDBClob.

See Also
AbstractStringAsNexusDBClob Class
Eco.Persistence.Nexus Namespace


AbstractStringAsNexusDBClob.DefaultDbValue Method

AbstractStringAsNexusDBClob.DefaultDbValue Method
AbstractStringAsNexusDBClob Class Eco.Persistence.Nexus Namespace See Also
Collapse All
C#
public String DefaultDbValue(
    string modeledValue,
    SqlDatabaseConfig sqlDatabaseConfig
);
Remarks

This is DefaultDbValue, a member of class AbstractStringAsNexusDBClob.

See Also
AbstractStringAsNexusDBClob Class
Eco.Persistence.Nexus Namespace


AbstractStringAsNexusDBClob.StringToParameter Method

AbstractStringAsNexusDBClob.StringToParameter Method
AbstractStringAsNexusDBClob Class Eco.Persistence.Nexus Namespace See Also
Collapse All
C#
public void StringToParameter(
    string value,
    IDataParameter parameter
);
Remarks

This is StringToParameter, a member of class AbstractStringAsNexusDBClob.

See Also
AbstractStringAsNexusDBClob Class
Eco.Persistence.Nexus Namespace


AbstractStringAsNexusDBClob.ValueToParameter Method

AbstractStringAsNexusDBClob.ValueToParameter Method
AbstractStringAsNexusDBClob Class Eco.Persistence.Nexus Namespace See Also
Collapse All
C#
public abstract void ValueToParameter(
    System.Object value,
    IDataParameter parameter
);
Remarks

This is ValueToParameter, a member of class AbstractStringAsNexusDBClob.

See Also
AbstractStringAsNexusDBClob Class
Eco.Persistence.Nexus Namespace


AbstractStringAsNexusDBClob.ValueType Method

AbstractStringAsNexusDBClob.ValueType Method
AbstractStringAsNexusDBClob Class Eco.Persistence.Nexus Namespace See Also
Collapse All
C#
public System.Type ValueType();
Remarks

This is ValueType, a member of class AbstractStringAsNexusDBClob.

See Also
AbstractStringAsNexusDBClob Class
Eco.Persistence.Nexus Namespace


AbstractStringAsNexusDBNClob Class

AbstractStringAsNexusDBNClob Class
Inheritance Hierarchy See Also
Collapse All
C#
public abstract class AbstractStringAsNexusDBNClob : AbstractSingleColumnAttribute;
Remarks

This is class Eco.Persistence.Nexus.AbstractStringAsNexusDBNClob.

Inheritance Hierarchy
Eco.Persistence.Nexus.AbstractStringAsNexusDBNClob
    Eco.Persistence.Nexus.StringAsNexusDBNClob
File

NexusDBMappers.cs

See Also
Inheritance Hierarchy


AbstractStringAsNexusDBNClob Methods

AbstractStringAsNexusDBNClob Methods
Public Methods
Collapse All

The methods of the AbstractStringAsNexusDBNClob class are listed here.

Public Methods
Name | Description
ColumnToValue | This is ColumnToValue, a member of class AbstractStringAsNexusDBNClob.
ColumnType | This is ColumnType, a member of class AbstractStringAsNexusDBNClob.
DefaultDbValue | This is DefaultDbValue, a member of class AbstractStringAsNexusDBNClob.
StringToParameter | This is StringToParameter, a member of class AbstractStringAsNexusDBNClob.
ValueToParameter | This is ValueToParameter, a member of class AbstractStringAsNexusDBNClob.
ValueType | This is ValueType, a member of class AbstractStringAsNexusDBNClob.


AbstractStringAsNexusDBNClob.ColumnToValue Method

AbstractStringAsNexusDBNClob.ColumnToValue Method
AbstractStringAsNexusDBNClob Class Eco.Persistence.Nexus Namespace See Also
Collapse All
C#
public override System.Object ColumnToValue(
    System.Object columnValue
);
Remarks

This is ColumnToValue, a member of class AbstractStringAsNexusDBNClob.

See Also
AbstractStringAsNexusDBNClob Class
Eco.Persistence.Nexus Namespace


AbstractStringAsNexusDBNClob.ColumnType Method

AbstractStringAsNexusDBNClob.ColumnType Method
AbstractStringAsNexusDBNClob Class Eco.Persistence.Nexus Namespace See Also
Collapse All
C#
public String ColumnType(
    int length
);
Remarks

This is ColumnType, a member of class AbstractStringAsNexusDBNClob.

See Also
AbstractStringAsNexusDBNClob Class
Eco.Persistence.Nexus Namespace


AbstractStringAsNexusDBNClob.DefaultDbValue Method

AbstractStringAsNexusDBNClob.DefaultDbValue Method
AbstractStringAsNexusDBNClob Class Eco.Persistence.Nexus Namespace See Also
Collapse All
C#
public String DefaultDbValue(
    string modeledValue,
    SqlDatabaseConfig sqlDatabaseConfig
);
Remarks

This is DefaultDbValue, a member of class AbstractStringAsNexusDBNClob.

See Also
AbstractStringAsNexusDBNClob Class
Eco.Persistence.Nexus Namespace


AbstractStringAsNexusDBNClob.StringToParameter Method

AbstractStringAsNexusDBNClob.StringToParameter Method
AbstractStringAsNexusDBNClob Class Eco.Persistence.Nexus Namespace See Also
Collapse All
C#
public void StringToParameter(
    string value,
    IDataParameter parameter
);
Remarks

This is StringToParameter, a member of class AbstractStringAsNexusDBNClob.

See Also
AbstractStringAsNexusDBNClob Class
Eco.Persistence.Nexus Namespace


AbstractStringAsNexusDBNClob.ValueToParameter Method

AbstractStringAsNexusDBNClob.ValueToParameter Method
AbstractStringAsNexusDBNClob Class Eco.Persistence.Nexus Namespace See Also
Collapse All
C#
public abstract void ValueToParameter(
    System.Object value,
    IDataParameter parameter
);
Remarks

This is ValueToParameter, a member of class AbstractStringAsNexusDBNClob.

See Also
AbstractStringAsNexusDBNClob Class
Eco.Persistence.Nexus Namespace


AbstractStringAsNexusDBNClob.ValueType Method

AbstractStringAsNexusDBNClob.ValueType Method
AbstractStringAsNexusDBNClob Class Eco.Persistence.Nexus Namespace See Also
Collapse All
C#
public System.Type ValueType();
Remarks

This is ValueType, a member of class AbstractStringAsNexusDBNClob.

See Also
AbstractStringAsNexusDBNClob Class
Eco.Persistence.Nexus Namespace


BooleanAsBool Class

BooleanAsBool Class
Inheritance Hierarchy See Also
Collapse All
C#
public sealed class BooleanAsBool : AbstractSingleColumnAttribute, ISingleColumnAttributemapping, INonBooleanBooleanMapping, IDefaultReverseMapping;
Remarks

This is class Eco.Persistence.Nexus.BooleanAsBool.

Inheritance Hierarchy
Eco.Persistence.IDefaultReverseMapping
Eco.Persistence.INonBooleanBooleanMapping
Eco.Persistence.ISingleColumnAttributemapping
    Eco.Persistence.Nexus.BooleanAsBool
File

NexusDBMappers.cs

See Also
Inheritance Hierarchy


BooleanAsBool Methods

BooleanAsBool Methods
Public Methods
Collapse All

The methods of the BooleanAsBool class are listed here.

Public Methods
Name | Description
ColumnToValue | This is ColumnToValue, a member of class BooleanAsBool.
ColumnType | Specifies the SQL type of the column.
DefaultDbValue | The return value of this function will be used as default value for new columns when databases are created/evolved.
StringToParameter | This is StringToParameter, a member of class BooleanAsBool.
ValueToParameter | This is ValueToParameter, a member of class BooleanAsBool.
ValueType | This method returns the type of the value that is returned by ColumnToValue.


BooleanAsBool.ColumnToValue Method

BooleanAsBool.ColumnToValue Method
BooleanAsBool Class Eco.Persistence.Nexus Namespace See Also
Collapse All
C#
public override object ColumnToValue(
    object columnValue
);
Remarks

This is ColumnToValue, a member of class BooleanAsBool.

See Also
BooleanAsBool Class
Eco.Persistence.Nexus Namespace


BooleanAsBool.ColumnType Method

BooleanAsBool.ColumnType Method
BooleanAsBool Class Eco.Persistence.Nexus Namespace See Also
Collapse All

Specifies the SQL type of the column.

C#
public string ColumnType(
    int length
);
See Also
BooleanAsBool Class
Eco.Persistence.Nexus Namespace


BooleanAsBool.DefaultDbValue Method

BooleanAsBool.DefaultDbValue Method
BooleanAsBool Class Eco.Persistence.Nexus Namespace See Also
Collapse All

The return value of this function will be used as default value for new columns when databases are created/evolved.

C#
public string DefaultDbValue(
    string modeledValue,
    SqlDatabaseConfig sqlDatabaseConfig
);
See Also
BooleanAsBool Class
Eco.Persistence.Nexus Namespace


BooleanAsBool.StringToParameter Method

BooleanAsBool.StringToParameter Method
BooleanAsBool Class Eco.Persistence.Nexus Namespace See Also
Collapse All
C#
public void StringToParameter(
    string value,
    IDataParameter parameter
);
Remarks

This is StringToParameter, a member of class BooleanAsBool.

See Also
BooleanAsBool Class
Eco.Persistence.Nexus Namespace


BooleanAsBool.ValueToParameter Method

BooleanAsBool.ValueToParameter Method
BooleanAsBool Class Eco.Persistence.Nexus Namespace See Also
Collapse All
C#
public void ValueToParameter(
    object value,
    IDataParameter parameter
);
Remarks

This is ValueToParameter, a member of class BooleanAsBool.

See Also
BooleanAsBool Class
Eco.Persistence.Nexus Namespace


BooleanAsBool.ValueType Method

BooleanAsBool.ValueType Method
BooleanAsBool Class Eco.Persistence.Nexus Namespace See Also
Collapse All

This method returns the type of the value that is returned by ColumnToValue.

C#
public System.Type ValueType();
See Also
BooleanAsBool Class
Eco.Persistence.Nexus Namespace


BooleanAsBool Properties

BooleanAsBool Properties
Public Properties
Collapse All

The properties of the BooleanAsBool class are listed here.

Public Properties
Name | Description
TrueString | Returns the string representation for the "true" value.


BooleanAsBool.TrueString Property

BooleanAsBool.TrueString Property
BooleanAsBool Class Eco.Persistence.Nexus Namespace See Also
Collapse All

Returns the string representation for the "true" value.

C#
public string TrueString;
Remarks

This could be for example "true", "1", "y" depending on how the value "true" is stored.

See Also
BooleanAsBool Class
Eco.Persistence.Nexus Namespace


ByteArrayAsNexusDBBlob Class

ByteArrayAsNexusDBBlob Class
Inheritance Hierarchy See Also
Collapse All
C#
public sealed class ByteArrayAsNexusDBBlob : AbstractByteArrayAsNexusDBBlob, ISingleColumnAttributemapping, IDefaultReverseMapping;
Remarks

This is class Eco.Persistence.Nexus.ByteArrayAsNexusDBBlob.

Inheritance Hierarchy
Eco.Persistence.IDefaultReverseMapping
Eco.Persistence.ISingleColumnAttributemapping
Eco.Persistence.Nexus.AbstractByteArrayAsNexusDBBlob
    Eco.Persistence.Nexus.ByteArrayAsNexusDBBlob
File

NexusDBMappers.cs

See Also
Inheritance Hierarchy


ByteArrayAsNexusDBBlob Methods

ByteArrayAsNexusDBBlob Methods
Public Methods
Collapse All

The methods of the ByteArrayAsNexusDBBlob class are listed here.

Public Methods
Name | Description
ValueToParameter | Converts a value that comes from a database query to an ecospace value.


ByteArrayAsNexusDBBlob.ValueToParameter Method

ByteArrayAsNexusDBBlob.ValueToParameter Method
ByteArrayAsNexusDBBlob Class Eco.Persistence.Nexus Namespace See Also
Collapse All

Converts a value that comes from a database query to an ecospace value.

C#
public void ValueToParameter(
    System.Object value,
    IDataParameter parameter
);
Remarks

In many cases, the implementation of this method mainly converts null to DBNull, but it can also handle conversion from for example booleans to integers, byte[] to database blobs. It also has to set the correct parameter types in the IDataParameter-object. This is the reverse operation of ColumnToValue.

See Also
ByteArrayAsNexusDBBlob Class
Eco.Persistence.Nexus Namespace


DecimalAsDecimal Class

DecimalAsDecimal Class
Inheritance Hierarchy See Also
Collapse All
C#
public sealed class DecimalAsDecimal : AbstractNumericSingleColumnAttribute, ISingleColumnAttributemapping, IDefaultReverseMapping;
Remarks

This is class Eco.Persistence.Nexus.DecimalAsDecimal.

Inheritance Hierarchy
Eco.Persistence.IDefaultReverseMapping
Eco.Persistence.ISingleColumnAttributemapping
    Eco.Persistence.Nexus.DecimalAsDecimal
File

NexusDBMappers.cs

See Also
Inheritance Hierarchy


DecimalAsDecimal.ColumnToValue Method

DecimalAsDecimal.ColumnToValue Method
DecimalAsDecimal Class Eco.Persistence.Nexus Namespace See Also
Collapse All

Converts a value that comes from a database query to an ecospace value.

C#
public override System.Object ColumnToValue(
    System.Object columnValue
);
Remarks

In many cases, the implementation of this method mainly converts DBNull-values to null, but it can also change the CLR-type of the database value from for example a char[] to a string. or from an integer to a boolean. This is the reverse operation of ValueToParameter.

See Also
DecimalAsDecimal Class
Eco.Persistence.Nexus Namespace


DecimalAsDecimal.ColumnType Method

DecimalAsDecimal.ColumnType Method
DecimalAsDecimal Class Eco.Persistence.Nexus Namespace See Also
Collapse All

Specifies the SQL type of the column.

C#
public String ColumnType(
    int length
);
See Also
DecimalAsDecimal Class
Eco.Persistence.Nexus Namespace


DecimalAsDecimal.StringToParameter Method

DecimalAsDecimal.StringToParameter Method
DecimalAsDecimal Class Eco.Persistence.Nexus Namespace See Also
Collapse All
C#
public void StringToParameter(
    string value,
    IDataParameter parameter
);
Remarks

This is StringToParameter, a member of class DecimalAsDecimal.

See Also
DecimalAsDecimal Class
Eco.Persistence.Nexus Namespace


DecimalAsDecimal.ValueToParameter Method

DecimalAsDecimal.ValueToParameter Method
DecimalAsDecimal Class Eco.Persistence.Nexus Namespace See Also
Collapse All

Converts a value that comes from a database query to an ecospace value.

C#
public void ValueToParameter(
    System.Object value,
    IDataParameter parameter
);
Remarks

In many cases, the implementation of this method mainly converts null to DBNull, but it can also handle conversion from for example booleans to integers, byte[] to database blobs. It also has to set the correct parameter types in the IDataParameter-object. This is the reverse operation of ColumnToValue.

See Also
DecimalAsDecimal Class
Eco.Persistence.Nexus Namespace


DecimalAsDecimal.ValueType Method

DecimalAsDecimal.ValueType Method
DecimalAsDecimal Class Eco.Persistence.Nexus Namespace See Also
Collapse All

This method returns the type of the value that is returned by ColumnToValue.

C#
public System.Type ValueType();
See Also
DecimalAsDecimal Class
Eco.Persistence.Nexus Namespace


DoubleAsDouble Class

DoubleAsDouble Class
Inheritance Hierarchy See Also
Collapse All
C#
public sealed class DoubleAsDouble : AbstractNumericSingleColumnAttribute, ISingleColumnAttributemapping, IDefaultReverseMapping;
Remarks

This is class Eco.Persistence.Nexus.DoubleAsDouble.

Inheritance Hierarchy
Eco.Persistence.IDefaultReverseMapping
Eco.Persistence.ISingleColumnAttributemapping
    Eco.Persistence.Nexus.DoubleAsDouble
File

NexusDBMappers.cs

See Also
Inheritance Hierarchy


DoubleAsDouble Methods

DoubleAsDouble Methods
Public Methods
Collapse All

The methods of the DoubleAsDouble class are listed here.

Public Methods
Name | Description
ColumnToValue | This is ColumnToValue, a member of class DoubleAsDouble.
ColumnType | Specifies the SQL type of the column.
StringToParameter | This is StringToParameter, a member of class DoubleAsDouble.
ValueToParameter | This is ValueToParameter, a member of class DoubleAsDouble.
ValueType | This method returns the type of the value that is returned by ColumnToValue.


DoubleAsDouble.ColumnToValue Method

DoubleAsDouble.ColumnToValue Method
DoubleAsDouble Class Eco.Persistence.Nexus Namespace See Also
Collapse All
C#
public override object ColumnToValue(
    object columnValue
);
Remarks

This is ColumnToValue, a member of class DoubleAsDouble.

See Also
DoubleAsDouble Class
Eco.Persistence.Nexus Namespace


DoubleAsDouble.ColumnType Method

DoubleAsDouble.ColumnType Method
DoubleAsDouble Class Eco.Persistence.Nexus Namespace See Also
Collapse All

Specifies the SQL type of the column.

C#
public string ColumnType(
    int length
);
See Also
DoubleAsDouble Class
Eco.Persistence.Nexus Namespace


DoubleAsDouble.StringToParameter Method

DoubleAsDouble.StringToParameter Method
DoubleAsDouble Class Eco.Persistence.Nexus Namespace See Also
Collapse All
C#
public void StringToParameter(
    string value,
    IDataParameter parameter
);
Remarks

This is StringToParameter, a member of class DoubleAsDouble.

See Also
DoubleAsDouble Class
Eco.Persistence.Nexus Namespace


DoubleAsDouble.ValueToParameter Method

DoubleAsDouble.ValueToParameter Method
DoubleAsDouble Class Eco.Persistence.Nexus Namespace See Also
Collapse All
C#
public void ValueToParameter(
    object value,
    IDataParameter parameter
);
Remarks

This is ValueToParameter, a member of class DoubleAsDouble.

See Also
DoubleAsDouble Class
Eco.Persistence.Nexus Namespace


DoubleAsDouble.ValueType Method

DoubleAsDouble.ValueType Method
DoubleAsDouble Class Eco.Persistence.Nexus Namespace See Also
Collapse All

This method returns the type of the value that is returned by ColumnToValue.

C#
public System.Type ValueType();
See Also
DoubleAsDouble Class
Eco.Persistence.Nexus Namespace


GuidAsGuid Class

GuidAsGuid Class
Inheritance Hierarchy See Also
Collapse All
C#
public sealed class GuidAsGuid : AbstractSingleColumnAttribute, ISingleColumnAttributemapping, IDefaultReverseMapping;
Remarks

This is class Eco.Persistence.Nexus.GuidAsGuid.

Inheritance Hierarchy
Eco.Persistence.IDefaultReverseMapping
Eco.Persistence.ISingleColumnAttributemapping
    Eco.Persistence.Nexus.GuidAsGuid
File

NexusDBMappers.cs

See Also
Inheritance Hierarchy


GuidAsGuid Methods

GuidAsGuid Methods
Public Methods
Collapse All

The methods of the GuidAsGuid class are listed here.

Public Methods
Name | Description
ColumnToValue | This is ColumnToValue, a member of class GuidAsGuid.
ColumnType | Specifies the SQL type of the column.
DefaultDbValue | The return value of this function will be used as default value for new columns when databases are created/evolved.
StringToParameter | This is StringToParameter, a member of class GuidAsGuid.
ValueToParameter | This is ValueToParameter, a member of class GuidAsGuid.
ValueType | This method returns the type of the value that is returned by ColumnToValue.


GuidAsGuid.ColumnToValue Method

GuidAsGuid.ColumnToValue Method
GuidAsGuid Class Eco.Persistence.Nexus Namespace See Also
Collapse All
C#
public override object ColumnToValue(
    object columnValue
);
Remarks

This is ColumnToValue, a member of class GuidAsGuid.

See Also
GuidAsGuid Class
Eco.Persistence.Nexus Namespace


GuidAsGuid.ColumnType Method

GuidAsGuid.ColumnType Method
GuidAsGuid Class Eco.Persistence.Nexus Namespace See Also
Collapse All

Specifies the SQL type of the column.

C#
public string ColumnType(
    int length
);
See Also
GuidAsGuid Class
Eco.Persistence.Nexus Namespace


GuidAsGuid.DefaultDbValue Method

GuidAsGuid.DefaultDbValue Method
GuidAsGuid Class Eco.Persistence.Nexus Namespace See Also
Collapse All

The return value of this function will be used as default value for new columns when databases are created/evolved.

C#
public string DefaultDbValue(
    string modeledValue,
    SqlDatabaseConfig sqlDatabaseConfig
);
See Also
GuidAsGuid Class
Eco.Persistence.Nexus Namespace


GuidAsGuid.StringToParameter Method

GuidAsGuid.StringToParameter Method
GuidAsGuid Class Eco.Persistence.Nexus Namespace See Also
Collapse All
C#
public void StringToParameter(
    string value,
    IDataParameter parameter
);
Remarks

This is StringToParameter, a member of class GuidAsGuid.

See Also
GuidAsGuid Class
Eco.Persistence.Nexus Namespace


GuidAsGuid.ValueToParameter Method

GuidAsGuid.ValueToParameter Method
GuidAsGuid Class Eco.Persistence.Nexus Namespace See Also
Collapse All
C#
public void ValueToParameter(
    object value,
    IDataParameter parameter
);
Remarks

This is ValueToParameter, a member of class GuidAsGuid.

See Also
GuidAsGuid Class
Eco.Persistence.Nexus Namespace


GuidAsGuid.ValueType Method

GuidAsGuid.ValueType Method
GuidAsGuid Class Eco.Persistence.Nexus Namespace See Also
Collapse All

This method returns the type of the value that is returned by ColumnToValue.

C#
public System.Type ValueType();
See Also
GuidAsGuid Class
Eco.Persistence.Nexus Namespace


Int32AsAutoInc Class

Int32AsAutoInc Class
Inheritance Hierarchy See Also
Collapse All
C#
public sealed class Int32AsAutoInc : AbstractAutoInc, IAutoIncAttributemapping, IDefaultReverseMapping;
Remarks

This is class Eco.Persistence.Nexus.Int32AsAutoInc.

Inheritance Hierarchy
Eco.Persistence.ISingleColumnAttributemapping
    Eco.Persistence.IAutoIncAttributemapping
    Eco.Persistence.IDefaultReverseMapping
    Eco.Persistence.Nexus.AbstractAutoInc
        Eco.Persistence.Nexus.Int32AsAutoInc
File

NexusDBMappers.cs

See Also
Inheritance Hierarchy


Int32AsAutoInc.ColumnToValue Method

Int32AsAutoInc.ColumnToValue Method
Int32AsAutoInc Class Eco.Persistence.Nexus Namespace See Also
Collapse All

Converts a value that comes from a database query to an ecospace value.

C#
public override System.Object ColumnToValue(
    System.Object columnValue
);
Remarks

In many cases, the implementation of this method mainly converts DBNull-values to null, but it can also change the CLR-type of the database value from for example a char[] to a string. or from an integer to a boolean. This is the reverse operation of ValueToParameter.

See Also
Int32AsAutoInc Class
Eco.Persistence.Nexus Namespace


Int32AsAutoInc.ColumnType Method

Int32AsAutoInc.ColumnType Method
Int32AsAutoInc Class Eco.Persistence.Nexus Namespace See Also
Collapse All

Specifies the SQL type of the column.

C#
public String ColumnType(
    int length
);
See Also
Int32AsAutoInc Class
Eco.Persistence.Nexus Namespace


Int32AsAutoInc.ValueType Method

Int32AsAutoInc.ValueType Method
Int32AsAutoInc Class Eco.Persistence.Nexus Namespace See Also
Collapse All

This method returns the type of the value that is returned by ColumnToValue.

C#
public System.Type ValueType();
See Also
Int32AsAutoInc Class
Eco.Persistence.Nexus Namespace


Int64AsBigInt Class

Int64AsBigInt Class
Inheritance Hierarchy See Also
Collapse All
C#
public sealed class Int64AsBigInt : AbstractNumericSingleColumnAttribute, ISingleColumnAttributemapping, IDefaultReverseMapping;
Remarks

This is class Eco.Persistence.Nexus.Int64AsBigInt.

Inheritance Hierarchy
Eco.Persistence.IDefaultReverseMapping
Eco.Persistence.ISingleColumnAttributemapping
    Eco.Persistence.Nexus.Int64AsBigInt
File

NexusDBMappers.cs

See Also
Inheritance Hierarchy


Int64AsBigInt.ColumnToValue Method

Int64AsBigInt.ColumnToValue Method
Int64AsBigInt Class Eco.Persistence.Nexus Namespace See Also
Collapse All

Converts a value that comes from a database query to an ecospace value.

C#
public override System.Object ColumnToValue(
    System.Object columnValue
);
Remarks

In many cases, the implementation of this method mainly converts DBNull-values to null, but it can also change the CLR-type of the database value from for example a char[] to a string. or from an integer to a boolean. This is the reverse operation of ValueToParameter.

See Also
Int64AsBigInt Class
Eco.Persistence.Nexus Namespace


Int64AsBigInt.ColumnType Method

Int64AsBigInt.ColumnType Method
Int64AsBigInt Class Eco.Persistence.Nexus Namespace See Also
Collapse All

Specifies the SQL type of the column.

C#
public String ColumnType(
    int length
);
See Also
Int64AsBigInt Class
Eco.Persistence.Nexus Namespace


Int64AsBigInt.StringToParameter Method

Int64AsBigInt.StringToParameter Method
Int64AsBigInt Class Eco.Persistence.Nexus Namespace See Also
Collapse All
C#
public void StringToParameter(
    string value,
    IDataParameter parameter
);
Remarks

This is StringToParameter, a member of class Int64AsBigInt.

See Also
Int64AsBigInt Class
Eco.Persistence.Nexus Namespace


Int64AsBigInt.ValueToParameter Method

Int64AsBigInt.ValueToParameter Method
Int64AsBigInt Class Eco.Persistence.Nexus Namespace See Also
Collapse All

Converts a value that comes from a database query to an ecospace value.

C#
public void ValueToParameter(
    System.Object value,
    IDataParameter parameter
);
Remarks

In many cases, the implementation of this method mainly converts null to DBNull, but it can also handle conversion from for example booleans to integers, byte[] to database blobs. It also has to set the correct parameter types in the IDataParameter-object. This is the reverse operation of ColumnToValue.

See Also
Int64AsBigInt Class
Eco.Persistence.Nexus Namespace


Int64AsBigInt.ValueType Method

Int64AsBigInt.ValueType Method
Int64AsBigInt Class Eco.Persistence.Nexus Namespace See Also
Collapse All

This method returns the type of the value that is returned by ColumnToValue.

C#
public System.Type ValueType();
See Also
Int64AsBigInt Class
Eco.Persistence.Nexus Namespace


NxIDatabaseImpl Class

NxIDatabaseImpl Class
Inheritance Hierarchy See Also
Collapse All
C#
public sealed class NxIDatabaseImpl : Ado2IDatabaseImpl;
Remarks

This is class Eco.Persistence.Nexus.NxIDatabaseImpl.

Inheritance Hierarchy
Eco.Persistence.Nexus.NxIDatabaseImpl
File

NexusDBDatabaseImpl.cs

See Also
Inheritance Hierarchy


NxIDatabaseImpl.NxIDatabaseImpl Constructor

NxIDatabaseImpl.NxIDatabaseImpl Constructor
NxIDatabaseImpl Class Eco.Persistence.Nexus Namespace See Also
Collapse All
C#
public NxIDatabaseImpl(
    DbConnection connection,
    SqlDatabaseConfig config
);
Remarks

This is NxIDatabaseImpl, a member of class NxIDatabaseImpl.

See Also
NxIDatabaseImpl Class
Eco.Persistence.Nexus Namespace


NxIDatabaseImpl Methods

NxIDatabaseImpl Methods
Protected Methods Public Methods
Collapse All

The methods of the NxIDatabaseImpl class are listed here.

Protected Methods
Name | Description
HandleCommandParameters | This is HandleCommandParameters, a member of class NxIDatabaseImpl.
Top
Public Methods
Name | Description
AllTableNames | This is AllTableNames, a member of class NxIDatabaseImpl.
GetIndexDefsForTable | This method uses the DbConnection.GetSchema method to find all indices defined for a table.


NxIDatabaseImpl.AllTableNames Method

NxIDatabaseImpl.AllTableNames Method
NxIDatabaseImpl Class Eco.Persistence.Nexus Namespace See Also
Collapse All
C#
public override IList<string> AllTableNames(
    string pattern
);
Remarks

This is AllTableNames, a member of class NxIDatabaseImpl.

See Also
NxIDatabaseImpl Class
Eco.Persistence.Nexus Namespace


NxIDatabaseImpl.GetIndexDefsForTable Method

NxIDatabaseImpl.GetIndexDefsForTable Method
NxIDatabaseImpl Class Eco.Persistence.Nexus Namespace See Also
Collapse All

This method uses the DbConnection.GetSchema method to find all indices defined for a table.

C#
public override DataTable GetIndexDefsForTable(
    string tableName
);
See Also
NxIDatabaseImpl Class
Eco.Persistence.Nexus Namespace


NxIDatabaseImpl.HandleCommandParameters Method

NxIDatabaseImpl.HandleCommandParameters Method
NxIDatabaseImpl Class Eco.Persistence.Nexus Namespace See Also
Collapse All
C#
protected override string HandleCommandParameters(
    string commandText,
    IDataParameterCollection parameters
);
Remarks

This is HandleCommandParameters, a member of class NxIDatabaseImpl.

See Also
NxIDatabaseImpl Class
Eco.Persistence.Nexus Namespace


NxIDatabaseImpl Properties

NxIDatabaseImpl Properties
Public Properties
Collapse All

The properties of the NxIDatabaseImpl class are listed here.

Public Properties
Name | Description
AlwaysReadInTransactions | This is AlwaysReadInTransactions, a member of class NxIDatabaseImpl.


NxIDatabaseImpl.AlwaysReadInTransactions Property

NxIDatabaseImpl.AlwaysReadInTransactions Property
NxIDatabaseImpl Class Eco.Persistence.Nexus Namespace See Also
Collapse All
C#
public override bool AlwaysReadInTransactions;
Remarks

This is AlwaysReadInTransactions, a member of class NxIDatabaseImpl.

See Also
NxIDatabaseImpl Class
Eco.Persistence.Nexus Namespace


SingleAsFloat Class

SingleAsFloat Class
Inheritance Hierarchy See Also
Collapse All
C#
public sealed class SingleAsFloat : AbstractNumericSingleColumnAttribute, ISingleColumnAttributemapping, IDefaultReverseMapping;
Remarks

This is class Eco.Persistence.Nexus.SingleAsFloat.

Inheritance Hierarchy
Eco.Persistence.IDefaultReverseMapping
Eco.Persistence.ISingleColumnAttributemapping
    Eco.Persistence.Nexus.SingleAsFloat
File

NexusDBMappers.cs

See Also
Inheritance Hierarchy


SingleAsFloat.ColumnToValue Method

SingleAsFloat.ColumnToValue Method
SingleAsFloat Class Eco.Persistence.Nexus Namespace See Also
Collapse All

Converts a value that comes from a database query to an ecospace value.

C#
public override System.Object ColumnToValue(
    System.Object columnValue
);
Remarks

In many cases, the implementation of this method mainly converts DBNull-values to null, but it can also change the CLR-type of the database value from for example a char[] to a string. or from an integer to a boolean. This is the reverse operation of ValueToParameter.

See Also
SingleAsFloat Class
Eco.Persistence.Nexus Namespace


SingleAsFloat.ColumnType Method

SingleAsFloat.ColumnType Method
SingleAsFloat Class Eco.Persistence.Nexus Namespace See Also
Collapse All

Specifies the SQL type of the column.

C#
public String ColumnType(
    int length
);
See Also
SingleAsFloat Class
Eco.Persistence.Nexus Namespace


SingleAsFloat.StringToParameter Method

SingleAsFloat.StringToParameter Method
SingleAsFloat Class Eco.Persistence.Nexus Namespace See Also
Collapse All
C#
public void StringToParameter(
    string value,
    IDataParameter parameter
);
Remarks

This is StringToParameter, a member of class SingleAsFloat.

See Also
SingleAsFloat Class
Eco.Persistence.Nexus Namespace


SingleAsFloat.ValueToParameter Method

SingleAsFloat.ValueToParameter Method
SingleAsFloat Class Eco.Persistence.Nexus Namespace See Also
Collapse All

Converts a value that comes from a database query to an ecospace value.

C#
public void ValueToParameter(
    System.Object value,
    IDataParameter parameter
);
Remarks

In many cases, the implementation of this method mainly converts null to DBNull, but it can also handle conversion from for example booleans to integers, byte[] to database blobs. It also has to set the correct parameter types in the IDataParameter-object. This is the reverse operation of ColumnToValue.

See Also
SingleAsFloat Class
Eco.Persistence.Nexus Namespace


SingleAsFloat.ValueType Method

SingleAsFloat.ValueType Method
SingleAsFloat Class Eco.Persistence.Nexus Namespace See Also
Collapse All

This method returns the type of the value that is returned by ColumnToValue.

C#
public System.Type ValueType();
See Also
SingleAsFloat Class
Eco.Persistence.Nexus Namespace


StringAsNexusDBClob Class

StringAsNexusDBClob Class
Inheritance Hierarchy See Also
Collapse All
C#
public sealed class StringAsNexusDBClob : AbstractStringAsNexusDBClob, ISingleColumnAttributemapping, IDefaultReverseMapping;
Remarks

This is class Eco.Persistence.Nexus.StringAsNexusDBClob.

Inheritance Hierarchy
Eco.Persistence.IDefaultReverseMapping
Eco.Persistence.ISingleColumnAttributemapping
Eco.Persistence.Nexus.AbstractStringAsNexusDBClob
    Eco.Persistence.Nexus.StringAsNexusDBClob
File

NexusDBMappers.cs

See Also
Inheritance Hierarchy


StringAsNexusDBClob Methods

StringAsNexusDBClob Methods
Public Methods
Collapse All

The methods of the StringAsNexusDBClob class are listed here.

Public Methods
Name | Description
ColumnToValue | Converts a value that comes from a database query to an ecospace value.
ValueToParameter | Converts a value that comes from a database query to an ecospace value.


StringAsNexusDBClob.ColumnToValue Method

StringAsNexusDBClob.ColumnToValue Method
StringAsNexusDBClob Class Eco.Persistence.Nexus Namespace See Also
Collapse All

Converts a value that comes from a database query to an ecospace value.

C#
public override System.Object ColumnToValue(
    System.Object columnValue
);
Remarks

In many cases, the implementation of this method mainly converts DBNull-values to null, but it can also change the CLR-type of the database value from for example a char[] to a string. or from an integer to a boolean. This is the reverse operation of ValueToParameter.

See Also
StringAsNexusDBClob Class
Eco.Persistence.Nexus Namespace


StringAsNexusDBClob.ValueToParameter Method

StringAsNexusDBClob.ValueToParameter Method
StringAsNexusDBClob Class Eco.Persistence.Nexus Namespace See Also
Collapse All

Converts a value that comes from a database query to an ecospace value.

C#
public override void ValueToParameter(
    System.Object value,
    IDataParameter parameter
);
Remarks

In many cases, the implementation of this method mainly converts null to DBNull, but it can also handle conversion from for example booleans to integers, byte[] to database blobs. It also has to set the correct parameter types in the IDataParameter-object. This is the reverse operation of ColumnToValue.

See Also
StringAsNexusDBClob Class
Eco.Persistence.Nexus Namespace


StringAsNexusDBNClob Class

StringAsNexusDBNClob Class
Inheritance Hierarchy See Also
Collapse All
C#
public sealed class StringAsNexusDBNClob : AbstractStringAsNexusDBNClob, ISingleColumnAttributemapping, IDefaultReverseMapping;
Remarks

This is class Eco.Persistence.Nexus.StringAsNexusDBNClob.

Inheritance Hierarchy
Eco.Persistence.IDefaultReverseMapping
Eco.Persistence.ISingleColumnAttributemapping
Eco.Persistence.Nexus.AbstractStringAsNexusDBNClob
    Eco.Persistence.Nexus.StringAsNexusDBNClob
File

NexusDBMappers.cs

See Also
Inheritance Hierarchy


StringAsNexusDBNClob Methods

StringAsNexusDBNClob Methods
Public Methods
Collapse All

The methods of the StringAsNexusDBNClob class are listed here.

Public Methods
Name | Description
ColumnToValue | Converts a value that comes from a database query to an ecospace value.
ValueToParameter | Converts a value that comes from a database query to an ecospace value.


StringAsNexusDBNClob.ColumnToValue Method

StringAsNexusDBNClob.ColumnToValue Method
StringAsNexusDBNClob Class Eco.Persistence.Nexus Namespace See Also
Collapse All

Converts a value that comes from a database query to an ecospace value.

C#
public override System.Object ColumnToValue(
    System.Object columnValue
);
Remarks

In many cases, the implementation of this method mainly converts DBNull-values to null, but it can also change the CLR-type of the database value from for example a char[] to a string. or from an integer to a boolean. This is the reverse operation of ValueToParameter.

See Also
StringAsNexusDBNClob Class
Eco.Persistence.Nexus Namespace


StringAsNexusDBNClob.ValueToParameter Method

StringAsNexusDBNClob.ValueToParameter Method
StringAsNexusDBNClob Class Eco.Persistence.Nexus Namespace See Also
Collapse All

Converts a value that comes from a database query to an ecospace value.

C#
public override void ValueToParameter(
    System.Object value,
    IDataParameter parameter
);
Remarks

In many cases, the implementation of this method mainly converts null to DBNull, but it can also handle conversion from for example booleans to integers, byte[] to database blobs. It also has to set the correct parameter types in the IDataParameter-object. This is the reverse operation of ColumnToValue.

See Also
StringAsNexusDBNClob Class
Eco.Persistence.Nexus Namespace


StringAsVarChar Class

StringAsVarChar Class
Inheritance Hierarchy See Also
Collapse All

Class for mapping String values to a single column in a database. Map

C#
public sealed class StringAsVarChar : AbstractStringSingleColumnAttribute, ISingleColumnAttributemapping, IDefaultReverseMapping;
Inheritance Hierarchy
Eco.Persistence.IDefaultReverseMapping
Eco.Persistence.ISingleColumnAttributemapping
    Eco.Persistence.Nexus.StringAsVarChar
File

NexusDBMappers.cs

See Also
Inheritance Hierarchy


StringAsVarChar Fields

StringAsVarChar Fields
Public Fields
Collapse All

The fields of the StringAsVarChar class are listed here.

Public Fields
Name | Description
EmptyStringMarker | This is EmptyStringMarker, a member of class StringAsVarChar.


StringAsVarChar.EmptyStringMarker Field

StringAsVarChar.EmptyStringMarker Field
StringAsVarChar Class Eco.Persistence.Nexus Namespace See Also
Collapse All
C#
public static string EmptyStringMarker = "<<EMPTY_STRING>>";
Remarks

This is EmptyStringMarker, a member of class StringAsVarChar.

See Also
StringAsVarChar Class
Eco.Persistence.Nexus Namespace


StringAsVarChar Methods

StringAsVarChar Methods
Public Methods
Collapse All

The methods of the StringAsVarChar class are listed here.

Public Methods
Name | Description
ColumnToValue | Converts a value that comes from a database query to an ecospace value.
ColumnType | Returns the SQL type used by the database during CREATE TABLE execution.
StringToParameter | Converts a string to the correct data type and then inserts the given value into the IDataParameter.
ValueToParameter | Inserts the given value into the IDataParameter.
ValueType | Returns the .NET type of the column.


StringAsVarChar.ColumnToValue Method

StringAsVarChar.ColumnToValue Method
StringAsVarChar Class Eco.Persistence.Nexus Namespace See Also
Collapse All

Converts a value that comes from a database query to an ecospace value.

C#
public override System.Object ColumnToValue(
    System.Object columnValue
);
Remarks

In many cases, the implementation of this method mainly converts DBNull-values to null, but it can also change the CLR-type of the database value from for example a char[] to a string. or from an integer to a boolean. This is the reverse operation of ValueToParameter.

See Also
StringAsVarChar Class
Eco.Persistence.Nexus Namespace


StringAsVarChar.ColumnType Method

StringAsVarChar.ColumnType Method
StringAsVarChar Class Eco.Persistence.Nexus Namespace See Also
Collapse All

Returns the SQL type used by the database during CREATE TABLE execution.

C#
public string ColumnType(
    int length
);
Parameters
Parameters | Description
length | The column length in the table.
See Also
StringAsVarChar Class
Eco.Persistence.Nexus Namespace


StringAsVarChar.StringToParameter Method

StringAsVarChar.StringToParameter Method
StringAsVarChar Class Eco.Persistence.Nexus Namespace See Also
Collapse All

Converts a string to the correct data type and then inserts the given value into the IDataParameter.

C#
public void StringToParameter(
    string value,
    IDataParameter parameter
);
Parameters
Parameters | Description
value | The value to use.
parameter | The IDataParameter to update.
See Also
StringAsVarChar Class
Eco.Persistence.Nexus Namespace


StringAsVarChar.ValueToParameter Method

StringAsVarChar.ValueToParameter Method
StringAsVarChar Class Eco.Persistence.Nexus Namespace See Also
Collapse All

Inserts the given value into the IDataParameter.

C#
public void ValueToParameter(
    System.Object value,
    IDataParameter parameter
);
Parameters
Parameters | Description
value | The value to use.
parameter | The IDataParameter to update.
See Also
StringAsVarChar Class
Eco.Persistence.Nexus Namespace


StringAsVarChar.ValueType Method

StringAsVarChar.ValueType Method
StringAsVarChar Class Eco.Persistence.Nexus Namespace See Also
Collapse All

Returns the .NET type of the column.

C#
public System.Type ValueType();
See Also
StringAsVarChar Class
Eco.Persistence.Nexus Namespace


Eco.Persistence.Oracle Namespace

Eco.Persistence.Oracle Namespace
Classes
Collapse All

This is namespace Eco.Persistence.Oracle.

Classes
Name | Description
AbstractAutoInc | Base class mapper between an AutoInc value and its persistent representation. This class must be inherited.
BooleanAsInteger | This is class Eco.Persistence.Oracle.BooleanAsInteger.
ByteArrayAsBlob | Mapper between a ByteArray value and its persistent representation as BLOB.
ByteAsSmallInt | This is class Eco.Persistence.Oracle.ByteAsSmallInt.
DateTimeAsDate | Mapper between an DateTime value and its persistent representation as DATE.
DateTimeAsTimeStamp | Mapper between a DateTime value and its persistent representation as TIMESTAMP.
DecimalAsDecimal | This is class Eco.Persistence.Oracle.DecimalAsDecimal.
DoubleAsNumber | This is class Eco.Persistence.Oracle.DoubleAsNumber.
Int16AsNumber | This is class Eco.Persistence.Oracle.Int16AsNumber.
Int32AsAutoInc | This is class Eco.Persistence.Oracle.Int32AsAutoInc.
Int32AsNumber | This is class Eco.Persistence.Oracle.Int32AsNumber.
Int64AsLongInteger | This is class Eco.Persistence.Oracle.Int64AsLongInteger.
SingleAsSingle | This is class Eco.Persistence.Oracle.SingleAsSingle.
StringAsClob | This is class Eco.Persistence.Oracle.StringAsClob.
StringAsNClob | This is class Eco.Persistence.Oracle.StringAsNClob.
StringAsVarChar2 | This is class Eco.Persistence.Oracle.StringAsVarChar2.
TimeSpanAsDate | This is class Eco.Persistence.Oracle.TimeSpanAsDate.
TimeSpanAsLongInteger | This is class Eco.Persistence.Oracle.TimeSpanAsLongInteger.


AbstractAutoInc Class

AbstractAutoInc Class
Inheritance Hierarchy See Also
Collapse All

Base class mapper between an AutoInc value and its persistent representation. This class must be inherited.

C#
public abstract class AbstractAutoInc : AbstractNumericSingleColumnAttribute;
Inheritance Hierarchy
Eco.Persistence.Oracle.AbstractAutoInc
    Eco.Persistence.Oracle.Int32AsAutoInc
File

OracleAttributeMappers.cs

See Also
Inheritance Hierarchy


AbstractAutoInc Methods

AbstractAutoInc Methods
Public Methods
Collapse All

The methods of the AbstractAutoInc class are listed here.

Public Methods
Name | Description
MakeColumnAutoInc |
StringToParameter | This method should never be called. Autoinc values are never stored!
ValueToParameter | This method should never be called. Autoinc values are never stored!


AbstractAutoInc.MakeColumnAutoInc Method

AbstractAutoInc.MakeColumnAutoInc Method
AbstractAutoInc Class Eco.Persistence.Oracle Namespace See Also
Collapse All
C#
public void MakeColumnAutoInc(
    string tableName,
    string columnName,
    IDatabase database
);
Exceptions
Exceptions | Description
ArgumentNullException | Thrown if database is null
See Also
AbstractAutoInc Class
Eco.Persistence.Oracle Namespace


AbstractAutoInc.StringToParameter Method

AbstractAutoInc.StringToParameter Method
AbstractAutoInc Class Eco.Persistence.Oracle Namespace See Also
Collapse All

This method should never be called. Autoinc values are never stored!

C#
public void StringToParameter(
    string value,
    IDataParameter parameter
);
Exceptions
Exceptions | Description
NotSupportedException | Thrown always.
See Also
AbstractAutoInc Class
Eco.Persistence.Oracle Namespace


AbstractAutoInc.ValueToParameter Method

AbstractAutoInc.ValueToParameter Method
AbstractAutoInc Class Eco.Persistence.Oracle Namespace See Also
Collapse All

This method should never be called. Autoinc values are never stored!

C#
public void ValueToParameter(
    System.Object value,
    IDataParameter parameter
);
Exceptions
Exceptions | Description
NotSupportedException | Thrown always.
See Also
AbstractAutoInc Class
Eco.Persistence.Oracle Namespace


BooleanAsInteger Class

BooleanAsInteger Class
Inheritance Hierarchy See Also
Collapse All
C#
public sealed class BooleanAsInteger : AbstractSingleColumnAttribute, ISingleColumnAttributemapping, INonBooleanBooleanMapping;
Remarks

This is class Eco.Persistence.Oracle.BooleanAsInteger.

Inheritance Hierarchy
Eco.Persistence.INonBooleanBooleanMapping
Eco.Persistence.ISingleColumnAttributemapping
    Eco.Persistence.Oracle.BooleanAsInteger
File

OracleAttributeMappers.cs

See Also
Inheritance Hierarchy


BooleanAsInteger Methods

BooleanAsInteger Methods
Public Methods
Collapse All

The methods of the BooleanAsInteger class are listed here.

Public Methods
Name | Description
ColumnToValue | Converts a value that comes from a database query to an ecospace value.
ColumnType | Specifies the SQL type of the column.
DefaultDbValue | The return value of this function will be used as default value for new columns when databases are created/evolved.
StringToParameter | This is StringToParameter, a member of class BooleanAsInteger.
ValueToParameter | Converts a value that comes from a database query to an ecospace value.
ValueType | This method returns the type of the value that is returned by ColumnToValue.


BooleanAsInteger.ColumnToValue Method

BooleanAsInteger.ColumnToValue Method
BooleanAsInteger Class Eco.Persistence.Oracle Namespace See Also
Collapse All

Converts a value that comes from a database query to an ecospace value.

C#
public override System.Object ColumnToValue(
    System.Object columnValue
);
Remarks

In many cases, the implementation of this method mainly converts DBNull-values to null, but it can also change the CLR-type of the database value from for example a char[] to a string. or from an integer to a boolean. This is the reverse operation of ValueToParameter.

See Also
BooleanAsInteger Class
Eco.Persistence.Oracle Namespace


BooleanAsInteger.ColumnType Method

BooleanAsInteger.ColumnType Method
BooleanAsInteger Class Eco.Persistence.Oracle Namespace See Also
Collapse All

Specifies the SQL type of the column.

C#
public String ColumnType(
    int length
);
See Also
BooleanAsInteger Class
Eco.Persistence.Oracle Namespace


BooleanAsInteger.DefaultDbValue Method

BooleanAsInteger.DefaultDbValue Method
BooleanAsInteger Class Eco.Persistence.Oracle Namespace See Also
Collapse All

The return value of this function will be used as default value for new columns when databases are created/evolved.

C#
public String DefaultDbValue(
    string modeledValue,
    SqlDatabaseConfig sqlDatabaseConfig
);
See Also
BooleanAsInteger Class
Eco.Persistence.Oracle Namespace


BooleanAsInteger.StringToParameter Method

BooleanAsInteger.StringToParameter Method
BooleanAsInteger Class Eco.Persistence.Oracle Namespace See Also
Collapse All
C#
public void StringToParameter(
    string value,
    IDataParameter parameter
);
Remarks

This is StringToParameter, a member of class BooleanAsInteger.

See Also
BooleanAsInteger Class
Eco.Persistence.Oracle Namespace


BooleanAsInteger.ValueToParameter Method

BooleanAsInteger.ValueToParameter Method
BooleanAsInteger Class Eco.Persistence.Oracle Namespace See Also
Collapse All

Converts a value that comes from a database query to an ecospace value.

C#
public void ValueToParameter(
    System.Object value,
    IDataParameter parameter
);
Remarks

In many cases, the implementation of this method mainly converts null to DBNull, but it can also handle conversion from for example booleans to integers, byte[] to database blobs. It also has to set the correct parameter types in the IDataParameter-object. This is the reverse operation of ColumnToValue.

See Also
BooleanAsInteger Class
Eco.Persistence.Oracle Namespace


BooleanAsInteger.ValueType Method

BooleanAsInteger.ValueType Method
BooleanAsInteger Class Eco.Persistence.Oracle Namespace See Also
Collapse All

This method returns the type of the value that is returned by ColumnToValue.

C#
public System.Type ValueType();
See Also
BooleanAsInteger Class
Eco.Persistence.Oracle Namespace


BooleanAsInteger.TrueString Property

BooleanAsInteger.TrueString Property
BooleanAsInteger Class Eco.Persistence.Oracle Namespace See Also
Collapse All

Returns the string representation for the "true" value.

C#
public string TrueString;
Remarks

This could be for example "true", "1", "y" depending on how the value "true" is stored.

See Also
BooleanAsInteger Class
Eco.Persistence.Oracle Namespace


ByteArrayAsBlob Class

ByteArrayAsBlob Class
Inheritance Hierarchy See Also
Collapse All

Mapper between a ByteArray value and its persistent representation as BLOB.

C#
public sealed class ByteArrayAsBlob : AbstractSingleColumnAttribute, ISingleColumnAttributemapping;
Inheritance Hierarchy
Eco.Persistence.ISingleColumnAttributemapping
    Eco.Persistence.Oracle.ByteArrayAsBlob
File

OracleAttributeMappersBdp.cs

See Also
Inheritance Hierarchy


ByteArrayAsBlob.ColumnToValue Method

ByteArrayAsBlob.ColumnToValue Method
ByteArrayAsBlob Class Eco.Persistence.Oracle Namespace See Also
Collapse All

Converts a value that comes from a database query to an ecospace value.

C#
public override System.Object ColumnToValue(
    System.Object columnValue
);
Remarks

In many cases, the implementation of this method mainly converts DBNull-values to null, but it can also change the CLR-type of the database value from for example a char[] to a string. or from an integer to a boolean. This is the reverse operation of ValueToParameter.

See Also
ByteArrayAsBlob Class
Eco.Persistence.Oracle Namespace


ByteArrayAsBlob.ColumnType Method

ByteArrayAsBlob.ColumnType Method
ByteArrayAsBlob Class Eco.Persistence.Oracle Namespace See Also
Collapse All

Specifies the SQL type of the column.

C#
public string ColumnType(
    int length
);
See Also
ByteArrayAsBlob Class
Eco.Persistence.Oracle Namespace


ByteArrayAsBlob.DefaultDbValue Method

ByteArrayAsBlob.DefaultDbValue Method
ByteArrayAsBlob Class Eco.Persistence.Oracle Namespace See Also
Collapse All

The return value of this function will be used as default value for new columns when databases are created/evolved.

C#
public string DefaultDbValue(
    string modeledValue,
    SqlDatabaseConfig sqlDatabaseConfig
);
See Also
ByteArrayAsBlob Class
Eco.Persistence.Oracle Namespace


ByteArrayAsBlob.IsEqual Method

ByteArrayAsBlob.IsEqual Method
ByteArrayAsBlob Class Eco.Persistence.Oracle Namespace See Also
Collapse All

Returns true if an ecospace value ("value") is equal to a database value ("columnValue").

C#
public override bool IsEqual(
    System.Object value,
    System.Object columnValue
);
Remarks

This method must handle the conversions between ecospace and database values, it must also handle comparing null/DBNull values.

See Also
ByteArrayAsBlob Class
Eco.Persistence.Oracle Namespace


ByteArrayAsBlob.StringToParameter Method

ByteArrayAsBlob.StringToParameter Method
ByteArrayAsBlob Class Eco.Persistence.Oracle Namespace See Also
Collapse All
C#
public void StringToParameter(
    string value,
    IDataParameter parameter
);
Exceptions
Exceptions | Description
InvalidOperationException | Thrown always.
See Also
ByteArrayAsBlob Class
Eco.Persistence.Oracle Namespace


ByteArrayAsBlob.ValueToParameter Method

ByteArrayAsBlob.ValueToParameter Method
ByteArrayAsBlob Class Eco.Persistence.Oracle Namespace See Also
Collapse All

Converts a value that comes from a database query to an ecospace value.

C#
public void ValueToParameter(
    System.Object value,
    IDataParameter parameter
);
Remarks

In many cases, the implementation of this method mainly converts null to DBNull, but it can also handle conversion from for example booleans to integers, byte[] to database blobs. It also has to set the correct parameter types in the IDataParameter-object. This is the reverse operation of ColumnToValue.

See Also
ByteArrayAsBlob Class
Eco.Persistence.Oracle Namespace


ByteArrayAsBlob.ValueType Method

ByteArrayAsBlob.ValueType Method
ByteArrayAsBlob Class Eco.Persistence.Oracle Namespace See Also
Collapse All

This method returns the type of the value that is returned by ColumnToValue.

C#
public System.Type ValueType();
See Also
ByteArrayAsBlob Class
Eco.Persistence.Oracle Namespace


ByteAsSmallInt Class

ByteAsSmallInt Class
Inheritance Hierarchy See Also
Collapse All
C#
public sealed class ByteAsSmallInt : AbstractNumericSingleColumnAttribute, ISingleColumnAttributemapping;
Remarks

This is class Eco.Persistence.Oracle.ByteAsSmallInt.

Inheritance Hierarchy
Eco.Persistence.ISingleColumnAttributemapping
    Eco.Persistence.Oracle.ByteAsSmallInt
File

OracleAttributeMappers.cs

See Also
Inheritance Hierarchy


ByteAsSmallInt Methods

ByteAsSmallInt Methods
Public Methods
Collapse All

The methods of the ByteAsSmallInt class are listed here.

Public Methods
Name | Description
ColumnToValue | Converts a value that comes from a database query to an ecospace value.
ColumnType | Specifies the SQL type of the column.
StringToParameter | This is StringToParameter, a member of class ByteAsSmallInt.
ValueToParameter | Converts a value that comes from a database query to an ecospace value.
ValueType | This method returns the type of the value that is returned by ColumnToValue.


ByteAsSmallInt.ColumnToValue Method

ByteAsSmallInt.ColumnToValue Method
ByteAsSmallInt Class Eco.Persistence.Oracle Namespace See Also
Collapse All

Converts a value that comes from a database query to an ecospace value.

C#
public override System.Object ColumnToValue(
    System.Object columnValue
);
Remarks

In many cases, the implementation of this method mainly converts DBNull-values to null, but it can also change the CLR-type of the database value from for example a char[] to a string. or from an integer to a boolean. This is the reverse operation of ValueToParameter.

See Also
ByteAsSmallInt Class
Eco.Persistence.Oracle Namespace


ByteAsSmallInt.ColumnType Method

ByteAsSmallInt.ColumnType Method
ByteAsSmallInt Class Eco.Persistence.Oracle Namespace See Also
Collapse All

Specifies the SQL type of the column.

C#
public String ColumnType(
    int length
);
See Also
ByteAsSmallInt Class
Eco.Persistence.Oracle Namespace


ByteAsSmallInt.StringToParameter Method

ByteAsSmallInt.StringToParameter Method
ByteAsSmallInt Class Eco.Persistence.Oracle Namespace See Also
Collapse All
C#
public void StringToParameter(
    string value,
    IDataParameter parameter
);
Remarks

This is StringToParameter, a member of class ByteAsSmallInt.

See Also
ByteAsSmallInt Class
Eco.Persistence.Oracle Namespace


ByteAsSmallInt.ValueToParameter Method

ByteAsSmallInt.ValueToParameter Method
ByteAsSmallInt Class Eco.Persistence.Oracle Namespace See Also
Collapse All

Converts a value that comes from a database query to an ecospace value.

C#
public void ValueToParameter(
    System.Object value,
    IDataParameter parameter
);
Remarks

In many cases, the implementation of this method mainly converts null to DBNull, but it can also handle conversion from for example booleans to integers, byte[] to database blobs. It also has to set the correct parameter types in the IDataParameter-object. This is the reverse operation of ColumnToValue.

See Also
ByteAsSmallInt Class
Eco.Persistence.Oracle Namespace


ByteAsSmallInt.ValueType Method

ByteAsSmallInt.ValueType Method
ByteAsSmallInt Class Eco.Persistence.Oracle Namespace See Also
Collapse All

This method returns the type of the value that is returned by ColumnToValue.

C#
public System.Type ValueType();
See Also
ByteAsSmallInt Class
Eco.Persistence.Oracle Namespace


DateTimeAsDate Class

DateTimeAsDate Class
Inheritance Hierarchy See Also
Collapse All

Mapper between an DateTime value and its persistent representation as DATE.

C#
public sealed class DateTimeAsDate : AbstractSingleColumnAttribute, ISingleColumnAttributemapping, IDefaultReverseMapping;
Inheritance Hierarchy
Eco.Persistence.IDefaultReverseMapping
Eco.Persistence.ISingleColumnAttributemapping
    Eco.Persistence.Oracle.DateTimeAsDate
File

OracleAttributeMappers.cs

See Also
Inheritance Hierarchy


DateTimeAsDate Methods

DateTimeAsDate Methods
Public Methods
Collapse All

The methods of the DateTimeAsDate class are listed here.

Public Methods
Name | Description
ColumnToValue | Converts a value that comes from a database query to an ecospace value.
ColumnType | Specifies the SQL type of the column.
DefaultDbValue |
IsEqual | Returns true if an ecospace value ("value") is equal to a database value ("columnValue").
StringToParameter | This is StringToParameter, a member of class DateTimeAsDate.
ValueToParameter | Converts a value that comes from a database query to an ecospace value.
ValueType | This method returns the type of the value that is returned by ColumnToValue.


DateTimeAsDate.ColumnToValue Method

DateTimeAsDate.ColumnToValue Method
DateTimeAsDate Class Eco.Persistence.Oracle Namespace See Also
Collapse All

Converts a value that comes from a database query to an ecospace value.

C#
public override System.Object ColumnToValue(
    System.Object columnValue
);
Remarks

In many cases, the implementation of this method mainly converts DBNull-values to null, but it can also change the CLR-type of the database value from for example a char[] to a string. or from an integer to a boolean. This is the reverse operation of ValueToParameter.

See Also
DateTimeAsDate Class
Eco.Persistence.Oracle Namespace


DateTimeAsDate.ColumnType Method

DateTimeAsDate.ColumnType Method
DateTimeAsDate Class Eco.Persistence.Oracle Namespace See Also
Collapse All

Specifies the SQL type of the column.

C#
public String ColumnType(
    int length
);
See Also
DateTimeAsDate Class
Eco.Persistence.Oracle Namespace


DateTimeAsDate.DefaultDbValue Method

DateTimeAsDate.DefaultDbValue Method
DateTimeAsDate Class Eco.Persistence.Oracle Namespace See Also
Collapse All
C#
public String DefaultDbValue(
    string modeledValue,
    SqlDatabaseConfig sqlDatabaseConfig
);
Exceptions
Exceptions | Description
ArgumentNullException | Thrown if sqlDatabaseConfig is null
See Also
DateTimeAsDate Class
Eco.Persistence.Oracle Namespace


DateTimeAsDate.IsEqual Method

DateTimeAsDate.IsEqual Method
DateTimeAsDate Class Eco.Persistence.Oracle Namespace See Also
Collapse All

Returns true if an ecospace value ("value") is equal to a database value ("columnValue").

C#
public override bool IsEqual(
    System.Object value,
    System.Object columnValue
);
Remarks

This method must handle the conversions between ecospace and database values, it must also handle comparing null/DBNull values.

See Also
DateTimeAsDate Class
Eco.Persistence.Oracle Namespace


DateTimeAsDate.StringToParameter Method

DateTimeAsDate.StringToParameter Method
DateTimeAsDate Class Eco.Persistence.Oracle Namespace See Also
Collapse All
C#
public void StringToParameter(
    string value,
    IDataParameter parameter
);
Remarks

This is StringToParameter, a member of class DateTimeAsDate.

See Also
DateTimeAsDate Class
Eco.Persistence.Oracle Namespace


DateTimeAsDate.ValueToParameter Method

DateTimeAsDate.ValueToParameter Method
DateTimeAsDate Class Eco.Persistence.Oracle Namespace See Also
Collapse All

Converts a value that comes from a database query to an ecospace value.

C#
public void ValueToParameter(
    System.Object value,
    IDataParameter parameter
);
Remarks

In many cases, the implementation of this method mainly converts null to DBNull, but it can also handle conversion from for example booleans to integers, byte[] to database blobs. It also has to set the correct parameter types in the IDataParameter-object. This is the reverse operation of ColumnToValue.

See Also
DateTimeAsDate Class
Eco.Persistence.Oracle Namespace


DateTimeAsDate.ValueType Method

DateTimeAsDate.ValueType Method
DateTimeAsDate Class Eco.Persistence.Oracle Namespace See Also
Collapse All

This method returns the type of the value that is returned by ColumnToValue.

C#
public System.Type ValueType();
See Also
DateTimeAsDate Class
Eco.Persistence.Oracle Namespace


DateTimeAsTimeStamp Class

DateTimeAsTimeStamp Class
Inheritance Hierarchy See Also
Collapse All

Mapper between a DateTime value and its persistent representation as TIMESTAMP.

C#
public sealed class DateTimeAsTimeStamp : AbstractSingleColumnAttribute, ISingleColumnAttributemapping, IDefaultReverseMapping;
Inheritance Hierarchy
Eco.Persistence.IDefaultReverseMapping
Eco.Persistence.ISingleColumnAttributemapping
    Eco.Persistence.Oracle.DateTimeAsTimeStamp
File

OracleAttributeMappers.cs

See Also
Inheritance Hierarchy


DateTimeAsTimeStamp Methods

DateTimeAsTimeStamp Methods
Public Methods
Collapse All

The methods of the DateTimeAsTimeStamp class are listed here.

Public Methods
Name | Description
ColumnToValue | Converts a value that comes from a database query to an ecospace value.
ColumnType | Specifies the SQL type of the column.
DefaultDbValue |
IsEqual | Returns true if an ecospace value ("value") is equal to a database value ("columnValue").
StringToParameter | This is StringToParameter, a member of class DateTimeAsTimeStamp.
ValueToParameter | Converts a value that comes from a database query to an ecospace value.
ValueType | This method returns the type of the value that is returned by ColumnToValue.


DateTimeAsTimeStamp.ColumnToValue Method

DateTimeAsTimeStamp.ColumnToValue Method
DateTimeAsTimeStamp Class Eco.Persistence.Oracle Namespace See Also
Collapse All

Converts a value that comes from a database query to an ecospace value.

C#
public override System.Object ColumnToValue(
    System.Object columnValue
);
Remarks

In many cases, the implementation of this method mainly converts DBNull-values to null, but it can also change the CLR-type of the database value from for example a char[] to a string. or from an integer to a boolean. This is the reverse operation of ValueToParameter.

See Also
DateTimeAsTimeStamp Class
Eco.Persistence.Oracle Namespace


DateTimeAsTimeStamp.ColumnType Method

DateTimeAsTimeStamp.ColumnType Method
DateTimeAsTimeStamp Class Eco.Persistence.Oracle Namespace See Also
Collapse All

Specifies the SQL type of the column.

C#
public String ColumnType(
    int length
);
See Also
DateTimeAsTimeStamp Class
Eco.Persistence.Oracle Namespace


DateTimeAsTimeStamp.DefaultDbValue Method

DateTimeAsTimeStamp.DefaultDbValue Method
DateTimeAsTimeStamp Class Eco.Persistence.Oracle Namespace See Also
Collapse All
C#
public String DefaultDbValue(
    string modeledValue,
    SqlDatabaseConfig sqlDatabaseConfig
);
Exceptions
Exceptions | Description
ArgumentNullException | Thrown if sqlDatabaseConfig is null
See Also
DateTimeAsTimeStamp Class
Eco.Persistence.Oracle Namespace


DateTimeAsTimeStamp.IsEqual Method

DateTimeAsTimeStamp.IsEqual Method
DateTimeAsTimeStamp Class Eco.Persistence.Oracle Namespace See Also
Collapse All

Returns true if an ecospace value ("value") is equal to a database value ("columnValue").

C#
public override bool IsEqual(
    System.Object value,
    System.Object columnValue
);
Remarks

This method must handle the conversions between ecospace and database values, it must also handle comparing null/DBNull values.

See Also
DateTimeAsTimeStamp Class
Eco.Persistence.Oracle Namespace


DateTimeAsTimeStamp.StringToParameter Method

DateTimeAsTimeStamp.StringToParameter Method
DateTimeAsTimeStamp Class Eco.Persistence.Oracle Namespace See Also
Collapse All
C#
public void StringToParameter(
    string value,
    IDataParameter parameter
);
Remarks

This is StringToParameter, a member of class DateTimeAsTimeStamp.

See Also
DateTimeAsTimeStamp Class
Eco.Persistence.Oracle Namespace


DateTimeAsTimeStamp.ValueToParameter Method

DateTimeAsTimeStamp.ValueToParameter Method
DateTimeAsTimeStamp Class Eco.Persistence.Oracle Namespace See Also
Collapse All

Converts a value that comes from a database query to an ecospace value.

C#
public void ValueToParameter(
    System.Object value,
    IDataParameter parameter
);
Remarks

In many cases, the implementation of this method mainly converts null to DBNull, but it can also handle conversion from for example booleans to integers, byte[] to database blobs. It also has to set the correct parameter types in the IDataParameter-object. This is the reverse operation of ColumnToValue.

See Also
DateTimeAsTimeStamp Class
Eco.Persistence.Oracle Namespace


DateTimeAsTimeStamp.ValueType Method

DateTimeAsTimeStamp.ValueType Method
DateTimeAsTimeStamp Class Eco.Persistence.Oracle Namespace See Also
Collapse All

This method returns the type of the value that is returned by ColumnToValue.

C#
public System.Type ValueType();
See Also
DateTimeAsTimeStamp Class
Eco.Persistence.Oracle Namespace


DecimalAsDecimal Class

DecimalAsDecimal Class
Inheritance Hierarchy See Also
Collapse All
C#
public sealed class DecimalAsDecimal : AbstractNumericSingleColumnAttribute, ISingleColumnAttributemapping, IDefaultReverseMapping;
Remarks

This is class Eco.Persistence.Oracle.DecimalAsDecimal.

Inheritance Hierarchy
Eco.Persistence.IDefaultReverseMapping
Eco.Persistence.ISingleColumnAttributemapping
    Eco.Persistence.Oracle.DecimalAsDecimal
File

OracleAttributeMappers.cs

See Also
Inheritance Hierarchy


DecimalAsDecimal.ColumnToValue Method

DecimalAsDecimal.ColumnToValue Method
DecimalAsDecimal Class Eco.Persistence.Oracle Namespace See Also
Collapse All

Converts a value that comes from a database query to an ecospace value.

C#
public override System.Object ColumnToValue(
    System.Object columnValue
);
Remarks

In many cases, the implementation of this method mainly converts DBNull-values to null, but it can also change the CLR-type of the database value from for example a char[] to a string. or from an integer to a boolean. This is the reverse operation of ValueToParameter.

See Also
DecimalAsDecimal Class
Eco.Persistence.Oracle Namespace


DecimalAsDecimal.ColumnType Method

DecimalAsDecimal.ColumnType Method
DecimalAsDecimal Class Eco.Persistence.Oracle Namespace See Also
Collapse All

Specifies the SQL type of the column.

C#
public String ColumnType(
    int length
);
See Also
DecimalAsDecimal Class
Eco.Persistence.Oracle Namespace


DecimalAsDecimal.StringToParameter Method

DecimalAsDecimal.StringToParameter Method
DecimalAsDecimal Class Eco.Persistence.Oracle Namespace See Also
Collapse All
C#
public void StringToParameter(
    string value,
    IDataParameter parameter
);
Remarks

This is StringToParameter, a member of class DecimalAsDecimal.

See Also
DecimalAsDecimal Class
Eco.Persistence.Oracle Namespace


DecimalAsDecimal.ValueToParameter Method

DecimalAsDecimal.ValueToParameter Method
DecimalAsDecimal Class Eco.Persistence.Oracle Namespace See Also
Collapse All

Converts a value that comes from a database query to an ecospace value.

C#
public void ValueToParameter(
    System.Object value,
    IDataParameter parameter
);
Remarks

In many cases, the implementation of this method mainly converts null to DBNull, but it can also handle conversion from for example booleans to integers, byte[] to database blobs. It also has to set the correct parameter types in the IDataParameter-object. This is the reverse operation of ColumnToValue.

See Also
DecimalAsDecimal Class
Eco.Persistence.Oracle Namespace


DecimalAsDecimal.ValueType Method

DecimalAsDecimal.ValueType Method
DecimalAsDecimal Class Eco.Persistence.Oracle Namespace See Also
Collapse All

This method returns the type of the value that is returned by ColumnToValue.

C#
public System.Type ValueType();
See Also
DecimalAsDecimal Class
Eco.Persistence.Oracle Namespace


DoubleAsNumber Class

DoubleAsNumber Class
Inheritance Hierarchy See Also
Collapse All
C#
public sealed class DoubleAsNumber : AbstractNumericSingleColumnAttribute, ISingleColumnAttributemapping, IDefaultReverseMapping;
Remarks

This is class Eco.Persistence.Oracle.DoubleAsNumber.

Inheritance Hierarchy
Eco.Persistence.IDefaultReverseMapping
Eco.Persistence.ISingleColumnAttributemapping
    Eco.Persistence.Oracle.DoubleAsNumber
File

OracleAttributeMappers.cs

See Also
Inheritance Hierarchy


DoubleAsNumber Methods

DoubleAsNumber Methods
Public Methods
Collapse All

The methods of the DoubleAsNumber class are listed here.

Public Methods
Name | Description
ColumnToValue | Converts a value that comes from a database query to an ecospace value.
ColumnType | Specifies the SQL type of the column.
StringToParameter | This is StringToParameter, a member of class DoubleAsNumber.
ValueToParameter | Converts a value that comes from a database query to an ecospace value.
ValueType | This method returns the type of the value that is returned by ColumnToValue.


DoubleAsNumber.ColumnToValue Method

DoubleAsNumber.ColumnToValue Method
DoubleAsNumber Class Eco.Persistence.Oracle Namespace See Also
Collapse All

Converts a value that comes from a database query to an ecospace value.

C#
public override System.Object ColumnToValue(
    System.Object columnValue
);
Remarks

In many cases, the implementation of this method mainly converts DBNull-values to null, but it can also change the CLR-type of the database value from for example a char[] to a string. or from an integer to a boolean. This is the reverse operation of ValueToParameter.

See Also
DoubleAsNumber Class
Eco.Persistence.Oracle Namespace


DoubleAsNumber.ColumnType Method

DoubleAsNumber.ColumnType Method
DoubleAsNumber Class Eco.Persistence.Oracle Namespace See Also
Collapse All

Specifies the SQL type of the column.

C#
public String ColumnType(
    int length
);
See Also
DoubleAsNumber Class
Eco.Persistence.Oracle Namespace


DoubleAsNumber.StringToParameter Method

DoubleAsNumber.StringToParameter Method
DoubleAsNumber Class Eco.Persistence.Oracle Namespace See Also
Collapse All
C#
public void StringToParameter(
    string value,
    IDataParameter parameter
);
Remarks

This is StringToParameter, a member of class DoubleAsNumber.

See Also
DoubleAsNumber Class
Eco.Persistence.Oracle Namespace


DoubleAsNumber.ValueToParameter Method

DoubleAsNumber.ValueToParameter Method
DoubleAsNumber Class Eco.Persistence.Oracle Namespace See Also
Collapse All

Converts a value that comes from a database query to an ecospace value.

C#
public void ValueToParameter(
    System.Object value,
    IDataParameter parameter
);
Remarks

In many cases, the implementation of this method mainly converts null to DBNull, but it can also handle conversion from for example booleans to integers, byte[] to database blobs. It also has to set the correct parameter types in the IDataParameter-object. This is the reverse operation of ColumnToValue.

See Also
DoubleAsNumber Class
Eco.Persistence.Oracle Namespace


DoubleAsNumber.ValueType Method

DoubleAsNumber.ValueType Method
DoubleAsNumber Class Eco.Persistence.Oracle Namespace See Also
Collapse All

This method returns the type of the value that is returned by ColumnToValue.

C#
public System.Type ValueType();
See Also
DoubleAsNumber Class
Eco.Persistence.Oracle Namespace


Int16AsNumber Class

Int16AsNumber Class
Inheritance Hierarchy See Also
Collapse All
C#
public sealed class Int16AsNumber : AbstractNumericSingleColumnAttribute, ISingleColumnAttributemapping;
Remarks

This is class Eco.Persistence.Oracle.Int16AsNumber.

Inheritance Hierarchy
Eco.Persistence.ISingleColumnAttributemapping
    Eco.Persistence.Oracle.Int16AsNumber
File

OracleAttributeMappers.cs

See Also
Inheritance Hierarchy


Int16AsNumber Methods

Int16AsNumber Methods
Public Methods
Collapse All

The methods of the Int16AsNumber class are listed here.

Public Methods
Name | Description
ColumnToValue | Converts a value that comes from a database query to an ecospace value.
ColumnType | Specifies the SQL type of the column.
StringToParameter | This is StringToParameter, a member of class Int16AsNumber.
ValueToParameter | Converts a value that comes from a database query to an ecospace value.
ValueType | This method returns the type of the value that is returned by ColumnToValue.


Int16AsNumber.ColumnToValue Method

Int16AsNumber.ColumnToValue Method
Int16AsNumber Class Eco.Persistence.Oracle Namespace See Also
Collapse All

Converts a value that comes from a database query to an ecospace value.

C#
public override System.Object ColumnToValue(
    System.Object columnValue
);
Remarks

In many cases, the implementation of this method mainly converts DBNull-values to null, but it can also change the CLR-type of the database value from for example a char[] to a string. or from an integer to a boolean. This is the reverse operation of ValueToParameter.

See Also
Int16AsNumber Class
Eco.Persistence.Oracle Namespace


Int16AsNumber.ColumnType Method

Int16AsNumber.ColumnType Method
Int16AsNumber Class Eco.Persistence.Oracle Namespace See Also
Collapse All

Specifies the SQL type of the column.

C#
public String ColumnType(
    int length
);
See Also
Int16AsNumber Class
Eco.Persistence.Oracle Namespace


Int16AsNumber.StringToParameter Method

Int16AsNumber.StringToParameter Method
Int16AsNumber Class Eco.Persistence.Oracle Namespace See Also
Collapse All
C#
public void StringToParameter(
    string value,
    IDataParameter parameter
);
Remarks

This is StringToParameter, a member of class Int16AsNumber.

See Also
Int16AsNumber Class
Eco.Persistence.Oracle Namespace


Int16AsNumber.ValueToParameter Method

Int16AsNumber.ValueToParameter Method
Int16AsNumber Class Eco.Persistence.Oracle Namespace See Also
Collapse All

Converts a value that comes from a database query to an ecospace value.

C#
public void ValueToParameter(
    System.Object value,
    IDataParameter parameter
);
Remarks

In many cases, the implementation of this method mainly converts null to DBNull, but it can also handle conversion from for example booleans to integers, byte[] to database blobs. It also has to set the correct parameter types in the IDataParameter-object. This is the reverse operation of ColumnToValue.

See Also
Int16AsNumber Class
Eco.Persistence.Oracle Namespace


Int16AsNumber.ValueType Method

Int16AsNumber.ValueType Method
Int16AsNumber Class Eco.Persistence.Oracle Namespace See Also
Collapse All

This method returns the type of the value that is returned by ColumnToValue.

C#
public System.Type ValueType();
See Also
Int16AsNumber Class
Eco.Persistence.Oracle Namespace


Int32AsAutoInc Class

Int32AsAutoInc Class
Inheritance Hierarchy See Also
Collapse All
C#
public sealed class Int32AsAutoInc : AbstractAutoInc, IAutoIncAttributemapping;
Remarks

This is class Eco.Persistence.Oracle.Int32AsAutoInc.

Inheritance Hierarchy
Eco.Persistence.ISingleColumnAttributemapping
    Eco.Persistence.IAutoIncAttributemapping
    Eco.Persistence.Oracle.AbstractAutoInc
        Eco.Persistence.Oracle.Int32AsAutoInc
File

OracleAttributeMappers.cs

See Also
Inheritance Hierarchy


Int32AsAutoInc.ColumnToValue Method

Int32AsAutoInc.ColumnToValue Method
Int32AsAutoInc Class Eco.Persistence.Oracle Namespace See Also
Collapse All

Converts a value that comes from a database query to an ecospace value.

C#
public override System.Object ColumnToValue(
    System.Object columnValue
);
Remarks

In many cases, the implementation of this method mainly converts DBNull-values to null, but it can also change the CLR-type of the database value from for example a char[] to a string. or from an integer to a boolean. This is the reverse operation of ValueToParameter.

See Also
Int32AsAutoInc Class
Eco.Persistence.Oracle Namespace


Int32AsAutoInc.ColumnType Method

Int32AsAutoInc.ColumnType Method
Int32AsAutoInc Class Eco.Persistence.Oracle Namespace See Also
Collapse All

Specifies the SQL type of the column.

C#
public String ColumnType(
    int length
);
See Also
Int32AsAutoInc Class
Eco.Persistence.Oracle Namespace


Int32AsAutoInc.ValueType Method

Int32AsAutoInc.ValueType Method
Int32AsAutoInc Class Eco.Persistence.Oracle Namespace See Also
Collapse All

This method returns the type of the value that is returned by ColumnToValue.

C#
public System.Type ValueType();
See Also
Int32AsAutoInc Class
Eco.Persistence.Oracle Namespace


Int32AsNumber Class

Int32AsNumber Class
Inheritance Hierarchy See Also
Collapse All
C#
public sealed class Int32AsNumber : AbstractNumericSingleColumnAttribute, ISingleColumnAttributemapping, IDefaultReverseMapping;
Remarks

This is class Eco.Persistence.Oracle.Int32AsNumber.

Inheritance Hierarchy
Eco.Persistence.IDefaultReverseMapping
Eco.Persistence.ISingleColumnAttributemapping
    Eco.Persistence.Oracle.Int32AsNumber
File

OracleAttributeMappers.cs

See Also
Inheritance Hierarchy


Int32AsNumber Methods

Int32AsNumber Methods
Public Methods
Collapse All

The methods of the Int32AsNumber class are listed here.

Public Methods
Name | Description
ColumnToValue | Converts a value that comes from a database query to an ecospace value.
ColumnType | Specifies the SQL type of the column.
StringToParameter | This is StringToParameter, a member of class Int32AsNumber.
ValueToParameter | Converts a value that comes from a database query to an ecospace value.
ValueType | This method returns the type of the value that is returned by ColumnToValue.


Int32AsNumber.ColumnToValue Method

Int32AsNumber.ColumnToValue Method
Int32AsNumber Class Eco.Persistence.Oracle Namespace See Also
Collapse All

Converts a value that comes from a database query to an ecospace value.

C#
public override System.Object ColumnToValue(
    System.Object columnValue
);
Remarks

In many cases, the implementation of this method mainly converts DBNull-values to null, but it can also change the CLR-type of the database value from for example a char[] to a string. or from an integer to a boolean. This is the reverse operation of ValueToParameter.

See Also
Int32AsNumber Class
Eco.Persistence.Oracle Namespace


Int32AsNumber.ColumnType Method

Int32AsNumber.ColumnType Method
Int32AsNumber Class Eco.Persistence.Oracle Namespace See Also
Collapse All

Specifies the SQL type of the column.

C#
public String ColumnType(
    int length
);
See Also
Int32AsNumber Class
Eco.Persistence.Oracle Namespace


Int32AsNumber.StringToParameter Method

Int32AsNumber.StringToParameter Method
Int32AsNumber Class Eco.Persistence.Oracle Namespace See Also
Collapse All
C#
public void StringToParameter(
    string value,
    IDataParameter parameter
);
Remarks

This is StringToParameter, a member of class Int32AsNumber.

See Also
Int32AsNumber Class
Eco.Persistence.Oracle Namespace


Int32AsNumber.ValueToParameter Method

Int32AsNumber.ValueToParameter Method
Int32AsNumber Class Eco.Persistence.Oracle Namespace See Also
Collapse All

Converts a value that comes from a database query to an ecospace value.

C#
public void ValueToParameter(
    System.Object value,
    IDataParameter parameter
);
Remarks

In many cases, the implementation of this method mainly converts null to DBNull, but it can also handle conversion from for example booleans to integers, byte[] to database blobs. It also has to set the correct parameter types in the IDataParameter-object. This is the reverse operation of ColumnToValue.

See Also
Int32AsNumber Class
Eco.Persistence.Oracle Namespace


Int32AsNumber.ValueType Method

Int32AsNumber.ValueType Method
Int32AsNumber Class Eco.Persistence.Oracle Namespace See Also
Collapse All

This method returns the type of the value that is returned by ColumnToValue.

C#
public System.Type ValueType();
See Also
Int32AsNumber Class
Eco.Persistence.Oracle Namespace


Int64AsLongInteger Class

Int64AsLongInteger Class
Inheritance Hierarchy See Also
Collapse All
C#
public sealed class Int64AsLongInteger : AbstractNumericSingleColumnAttribute, ISingleColumnAttributemapping, IDefaultReverseMapping;
Remarks

This is class Eco.Persistence.Oracle.Int64AsLongInteger.

Inheritance Hierarchy
Eco.Persistence.IDefaultReverseMapping
Eco.Persistence.ISingleColumnAttributemapping
    Eco.Persistence.Oracle.Int64AsLongInteger
File

OracleAttributeMappers.cs

See Also
Inheritance Hierarchy


Int64AsLongInteger.ColumnToValue Method

Int64AsLongInteger.ColumnToValue Method
Int64AsLongInteger Class Eco.Persistence.Oracle Namespace See Also
Collapse All

Converts a value that comes from a database query to an ecospace value.

C#
public override System.Object ColumnToValue(
    System.Object columnValue
);
Remarks

In many cases, the implementation of this method mainly converts DBNull-values to null, but it can also change the CLR-type of the database value from for example a char[] to a string. or from an integer to a boolean. This is the reverse operation of ValueToParameter.

See Also
Int64AsLongInteger Class
Eco.Persistence.Oracle Namespace


Int64AsLongInteger.ColumnType Method

Int64AsLongInteger.ColumnType Method
Int64AsLongInteger Class Eco.Persistence.Oracle Namespace See Also
Collapse All

Specifies the SQL type of the column.

C#
public String ColumnType(
    int length
);
See Also
Int64AsLongInteger Class
Eco.Persistence.Oracle Namespace


Int64AsLongInteger.StringToParameter Method

Int64AsLongInteger.StringToParameter Method
Int64AsLongInteger Class Eco.Persistence.Oracle Namespace See Also
Collapse All
C#
public void StringToParameter(
    string value,
    IDataParameter parameter
);
Remarks

This is StringToParameter, a member of class Int64AsLongInteger.

See Also
Int64AsLongInteger Class
Eco.Persistence.Oracle Namespace


Int64AsLongInteger.ValueToParameter Method

Int64AsLongInteger.ValueToParameter Method
Int64AsLongInteger Class Eco.Persistence.Oracle Namespace See Also
Collapse All

Converts a value that comes from a database query to an ecospace value.

C#
public void ValueToParameter(
    System.Object value,
    IDataParameter parameter
);
Remarks

In many cases, the implementation of this method mainly converts null to DBNull, but it can also handle conversion from for example booleans to integers, byte[] to database blobs. It also has to set the correct parameter types in the IDataParameter-object. This is the reverse operation of ColumnToValue.

See Also
Int64AsLongInteger Class
Eco.Persistence.Oracle Namespace


Int64AsLongInteger.ValueType Method

Int64AsLongInteger.ValueType Method
Int64AsLongInteger Class Eco.Persistence.Oracle Namespace See Also
Collapse All

This method returns the type of the value that is returned by ColumnToValue.

C#
public System.Type ValueType();
See Also
Int64AsLongInteger Class
Eco.Persistence.Oracle Namespace


SingleAsSingle Class

SingleAsSingle Class
Inheritance Hierarchy See Also
Collapse All
C#
public sealed class SingleAsSingle : AbstractNumericSingleColumnAttribute, ISingleColumnAttributemapping, IDefaultReverseMapping;
Remarks

This is class Eco.Persistence.Oracle.SingleAsSingle.

Inheritance Hierarchy
Eco.Persistence.IDefaultReverseMapping
Eco.Persistence.ISingleColumnAttributemapping
    Eco.Persistence.Oracle.SingleAsSingle
File

OracleAttributeMappers.cs

See Also
Inheritance Hierarchy


SingleAsSingle Methods

SingleAsSingle Methods
Public Methods
Collapse All

The methods of the SingleAsSingle class are listed here.

Public Methods
Name | Description
ColumnToValue | Converts a value that comes from a database query to an ecospace value.
ColumnType | Specifies the SQL type of the column.
StringToParameter | This is StringToParameter, a member of class SingleAsSingle.
ValueToParameter | Converts a value that comes from a database query to an ecospace value.
ValueType | This method returns the type of the value that is returned by ColumnToValue.


SingleAsSingle.ColumnToValue Method

SingleAsSingle.ColumnToValue Method
SingleAsSingle Class Eco.Persistence.Oracle Namespace See Also
Collapse All

Converts a value that comes from a database query to an ecospace value.

C#
public override System.Object ColumnToValue(
    System.Object columnValue
);
Remarks

In many cases, the implementation of this method mainly converts DBNull-values to null, but it can also change the CLR-type of the database value from for example a char[] to a string. or from an integer to a boolean. This is the reverse operation of ValueToParameter.

See Also
SingleAsSingle Class
Eco.Persistence.Oracle Namespace


SingleAsSingle.ColumnType Method

SingleAsSingle.ColumnType Method
SingleAsSingle Class Eco.Persistence.Oracle Namespace See Also
Collapse All

Specifies the SQL type of the column.

C#
public String ColumnType(
    int length
);
See Also
SingleAsSingle Class
Eco.Persistence.Oracle Namespace


SingleAsSingle.StringToParameter Method

SingleAsSingle.StringToParameter Method
SingleAsSingle Class Eco.Persistence.Oracle Namespace See Also
Collapse All
C#
public void StringToParameter(
    string value,
    IDataParameter parameter
);
Remarks

This is StringToParameter, a member of class SingleAsSingle.

See Also
SingleAsSingle Class
Eco.Persistence.Oracle Namespace


SingleAsSingle.ValueToParameter Method

SingleAsSingle.ValueToParameter Method
SingleAsSingle Class Eco.Persistence.Oracle Namespace See Also
Collapse All

Converts a value that comes from a database query to an ecospace value.

C#
public void ValueToParameter(
    System.Object value,
    IDataParameter parameter
);
Remarks

In many cases, the implementation of this method mainly converts null to DBNull, but it can also handle conversion from for example booleans to integers, byte[] to database blobs. It also has to set the correct parameter types in the IDataParameter-object. This is the reverse operation of ColumnToValue.

See Also
SingleAsSingle Class
Eco.Persistence.Oracle Namespace


SingleAsSingle.ValueType Method

SingleAsSingle.ValueType Method
SingleAsSingle Class Eco.Persistence.Oracle Namespace See Also
Collapse All

This method returns the type of the value that is returned by ColumnToValue.

C#
public System.Type ValueType();
See Also
SingleAsSingle Class
Eco.Persistence.Oracle Namespace


StringAsClob Class

StringAsClob Class
Inheritance Hierarchy See Also
Collapse All
C#
public sealed class StringAsClob : AbstractSingleColumnAttribute, ISingleColumnAttributemapping;
Remarks

This is class Eco.Persistence.Oracle.StringAsClob.

Inheritance Hierarchy
Eco.Persistence.ISingleColumnAttributemapping
    Eco.Persistence.Oracle.StringAsClob
File

OracleAttributeMappersBdp.cs

See Also
Inheritance Hierarchy


StringAsClob.ColumnToValue Method

StringAsClob.ColumnToValue Method
StringAsClob Class Eco.Persistence.Oracle Namespace See Also
Collapse All

Converts a value that comes from a database query to an ecospace value.

C#
public override System.Object ColumnToValue(
    System.Object columnValue
);
Remarks

In many cases, the implementation of this method mainly converts DBNull-values to null, but it can also change the CLR-type of the database value from for example a char[] to a string. or from an integer to a boolean. This is the reverse operation of ValueToParameter.

See Also
StringAsClob Class
Eco.Persistence.Oracle Namespace


StringAsClob.ColumnType Method

StringAsClob.ColumnType Method
StringAsClob Class Eco.Persistence.Oracle Namespace See Also
Collapse All

Specifies the SQL type of the column.

C#
public string ColumnType(
    int length
);
See Also
StringAsClob Class
Eco.Persistence.Oracle Namespace


StringAsClob.DefaultDbValue Method

StringAsClob.DefaultDbValue Method
StringAsClob Class Eco.Persistence.Oracle Namespace See Also
Collapse All

The return value of this function will be used as default value for new columns when databases are created/evolved.

C#
public string DefaultDbValue(
    string modeledValue,
    SqlDatabaseConfig sqlDatabaseConfig
);
See Also
StringAsClob Class
Eco.Persistence.Oracle Namespace


StringAsClob.StringToParameter Method

StringAsClob.StringToParameter Method
StringAsClob Class Eco.Persistence.Oracle Namespace See Also
Collapse All
C#
public void StringToParameter(
    string value,
    IDataParameter parameter
);
Remarks

This is StringToParameter, a member of class StringAsClob.

See Also
StringAsClob Class
Eco.Persistence.Oracle Namespace


StringAsClob.ValueToParameter Method

StringAsClob.ValueToParameter Method
StringAsClob Class Eco.Persistence.Oracle Namespace See Also
Collapse All

Converts a value that comes from a database query to an ecospace value.

C#
public void ValueToParameter(
    System.Object value,
    IDataParameter parameter
);
Remarks

In many cases, the implementation of this method mainly converts null to DBNull, but it can also handle conversion from for example booleans to integers, byte[] to database blobs. It also has to set the correct parameter types in the IDataParameter-object. This is the reverse operation of ColumnToValue.

See Also
StringAsClob Class
Eco.Persistence.Oracle Namespace


StringAsClob.ValueType Method

StringAsClob.ValueType Method
StringAsClob Class Eco.Persistence.Oracle Namespace See Also
Collapse All

This method returns the type of the value that is returned by ColumnToValue.

C#
public System.Type ValueType();
See Also
StringAsClob Class
Eco.Persistence.Oracle Namespace


StringAsNClob Class

StringAsNClob Class
Inheritance Hierarchy See Also
Collapse All
C#
public sealed class StringAsNClob : AbstractSingleColumnAttribute, ISingleColumnAttributemapping;
Remarks

This is class Eco.Persistence.Oracle.StringAsNClob.

Inheritance Hierarchy
Eco.Persistence.ISingleColumnAttributemapping
    Eco.Persistence.Oracle.StringAsNClob
File

OracleAttributeMappersBdp.cs

See Also
Inheritance Hierarchy


StringAsNClob.ColumnToValue Method

StringAsNClob.ColumnToValue Method
StringAsNClob Class Eco.Persistence.Oracle Namespace See Also
Collapse All

Converts a value that comes from a database query to an ecospace value.

C#
public override System.Object ColumnToValue(
    System.Object columnValue
);
Remarks

In many cases, the implementation of this method mainly converts DBNull-values to null, but it can also change the CLR-type of the database value from for example a char[] to a string. or from an integer to a boolean. This is the reverse operation of ValueToParameter.

See Also
StringAsNClob Class
Eco.Persistence.Oracle Namespace


StringAsNClob.ColumnType Method

StringAsNClob.ColumnType Method
StringAsNClob Class Eco.Persistence.Oracle Namespace See Also
Collapse All

Specifies the SQL type of the column.

C#
public string ColumnType(
    int length
);
See Also
StringAsNClob Class
Eco.Persistence.Oracle Namespace


StringAsNClob.DefaultDbValue Method

StringAsNClob.DefaultDbValue Method
StringAsNClob Class Eco.Persistence.Oracle Namespace See Also
Collapse All

The return value of this function will be used as default value for new columns when databases are created/evolved.

C#
public string DefaultDbValue(
    string modeledValue,
    SqlDatabaseConfig sqlDatabaseConfig
);
See Also
StringAsNClob Class
Eco.Persistence.Oracle Namespace


StringAsNClob.StringToParameter Method

StringAsNClob.StringToParameter Method
StringAsNClob Class Eco.Persistence.Oracle Namespace See Also
Collapse All
C#
public void StringToParameter(
    string value,
    IDataParameter parameter
);
Remarks

This is StringToParameter, a member of class StringAsNClob.

See Also
StringAsNClob Class
Eco.Persistence.Oracle Namespace


StringAsNClob.ValueToParameter Method

StringAsNClob.ValueToParameter Method
StringAsNClob Class Eco.Persistence.Oracle Namespace See Also
Collapse All

Converts a value that comes from a database query to an ecospace value.

C#
public void ValueToParameter(
    System.Object value,
    IDataParameter parameter
);
Remarks

In many cases, the implementation of this method mainly converts null to DBNull, but it can also handle conversion from for example booleans to integers, byte[] to database blobs. It also has to set the correct parameter types in the IDataParameter-object. This is the reverse operation of ColumnToValue.

See Also
StringAsNClob Class
Eco.Persistence.Oracle Namespace


StringAsNClob.ValueType Method

StringAsNClob.ValueType Method
StringAsNClob Class Eco.Persistence.Oracle Namespace See Also
Collapse All

This method returns the type of the value that is returned by ColumnToValue.

C#
public System.Type ValueType();
See Also
StringAsNClob Class
Eco.Persistence.Oracle Namespace


StringAsVarChar2 Class

StringAsVarChar2 Class
Inheritance Hierarchy See Also
Collapse All
C#
public sealed class StringAsVarChar2 : AbstractStringSingleColumnAttribute, ISingleColumnAttributemapping;
Remarks

This is class Eco.Persistence.Oracle.StringAsVarChar2.

Inheritance Hierarchy
Eco.Persistence.ISingleColumnAttributemapping
    Eco.Persistence.Oracle.StringAsVarChar2
File

OracleAttributeMappers.cs

See Also
Inheritance Hierarchy


StringAsVarChar2 Methods

StringAsVarChar2 Methods
Public Methods
Collapse All

The methods of the StringAsVarChar2 class are listed here.

Public Methods
Name | Description
ColumnToValue | Converts a value that comes from a database query to an ecospace value.
ColumnType | Specifies the SQL type of the column.
StringToParameter | This is StringToParameter, a member of class StringAsVarChar2.
ValueToParameter | Converts a value that comes from a database query to an ecospace value.
ValueType | This method returns the type of the value that is returned by ColumnToValue.


StringAsVarChar2.ColumnToValue Method

StringAsVarChar2.ColumnToValue Method
StringAsVarChar2 Class Eco.Persistence.Oracle Namespace See Also
Collapse All

Converts a value that comes from a database query to an ecospace value.

C#
public override System.Object ColumnToValue(
    System.Object columnValue
);
Remarks

In many cases, the implementation of this method mainly converts DBNull-values to null, but it can also change the CLR-type of the database value from for example a char[] to a string. or from an integer to a boolean. This is the reverse operation of ValueToParameter.

See Also
StringAsVarChar2 Class
Eco.Persistence.Oracle Namespace


StringAsVarChar2.ColumnType Method

StringAsVarChar2.ColumnType Method
StringAsVarChar2 Class Eco.Persistence.Oracle Namespace See Also
Collapse All

Specifies the SQL type of the column.

C#
public String ColumnType(
    int length
);
See Also
StringAsVarChar2 Class
Eco.Persistence.Oracle Namespace


StringAsVarChar2.StringToParameter Method

StringAsVarChar2.StringToParameter Method
StringAsVarChar2 Class Eco.Persistence.Oracle Namespace See Also
Collapse All
C#
public void StringToParameter(
    string value,
    IDataParameter parameter
);
Remarks

This is StringToParameter, a member of class StringAsVarChar2.

See Also
StringAsVarChar2 Class
Eco.Persistence.Oracle Namespace


StringAsVarChar2.ValueToParameter Method

StringAsVarChar2.ValueToParameter Method
StringAsVarChar2 Class Eco.Persistence.Oracle Namespace See Also
Collapse All

Converts a value that comes from a database query to an ecospace value.

C#
public void ValueToParameter(
    System.Object value,
    IDataParameter parameter
);
Remarks

In many cases, the implementation of this method mainly converts null to DBNull, but it can also handle conversion from for example booleans to integers, byte[] to database blobs. It also has to set the correct parameter types in the IDataParameter-object. This is the reverse operation of ColumnToValue.

See Also
StringAsVarChar2 Class
Eco.Persistence.Oracle Namespace


StringAsVarChar2.ValueType Method

StringAsVarChar2.ValueType Method
StringAsVarChar2 Class Eco.Persistence.Oracle Namespace See Also
Collapse All

This method returns the type of the value that is returned by ColumnToValue.

C#
public System.Type ValueType();
See Also
StringAsVarChar2 Class
Eco.Persistence.Oracle Namespace


TimeSpanAsDate Class

TimeSpanAsDate Class
Inheritance Hierarchy See Also
Collapse All
C#
public sealed class TimeSpanAsDate : AbstractSingleColumnAttribute, ISingleColumnAttributemapping;
Remarks

This is class Eco.Persistence.Oracle.TimeSpanAsDate.

Inheritance Hierarchy
Eco.Persistence.ISingleColumnAttributemapping
    Eco.Persistence.Oracle.TimeSpanAsDate
File

OracleAttributeMappers.cs

See Also
Inheritance Hierarchy


TimeSpanAsDate Methods

TimeSpanAsDate Methods
Public Methods
Collapse All

The methods of the TimeSpanAsDate class are listed here.

Public Methods
Name | Description
ColumnToValue | Converts a value that comes from a database query to an ecospace value.
ColumnType | Specifies the SQL type of the column.
DefaultDbValue | The return value of this function will be used as default value for new columns when databases are created/evolved.
IsEqual | Returns true if an ecospace value ("value") is equal to a database value ("columnValue").
StringToParameter | This is StringToParameter, a member of class TimeSpanAsDate.
ValueToParameter | Converts a value that comes from a database query to an ecospace value.
ValueType | This method returns the type of the value that is returned by ColumnToValue.


TimeSpanAsDate.ColumnToValue Method

TimeSpanAsDate.ColumnToValue Method
TimeSpanAsDate Class Eco.Persistence.Oracle Namespace See Also
Collapse All

Converts a value that comes from a database query to an ecospace value.

C#
public override System.Object ColumnToValue(
    System.Object columnValue
);
Remarks

In many cases, the implementation of this method mainly converts DBNull-values to null, but it can also change the CLR-type of the database value from for example a char[] to a string. or from an integer to a boolean. This is the reverse operation of ValueToParameter.

See Also
TimeSpanAsDate Class
Eco.Persistence.Oracle Namespace


TimeSpanAsDate.ColumnType Method

TimeSpanAsDate.ColumnType Method
TimeSpanAsDate Class Eco.Persistence.Oracle Namespace See Also
Collapse All

Specifies the SQL type of the column.

C#
public String ColumnType(
    int length
);
See Also
TimeSpanAsDate Class
Eco.Persistence.Oracle Namespace


TimeSpanAsDate.DefaultDbValue Method

TimeSpanAsDate.DefaultDbValue Method
TimeSpanAsDate Class Eco.Persistence.Oracle Namespace See Also
Collapse All

The return value of this function will be used as default value for new columns when databases are created/evolved.

C#
public String DefaultDbValue(
    string modeledValue,
    SqlDatabaseConfig sqlDatabaseConfig
);
See Also
TimeSpanAsDate Class
Eco.Persistence.Oracle Namespace


TimeSpanAsDate.IsEqual Method

TimeSpanAsDate.IsEqual Method
TimeSpanAsDate Class Eco.Persistence.Oracle Namespace See Also
Collapse All

Returns true if an ecospace value ("value") is equal to a database value ("columnValue").

C#
public override bool IsEqual(
    System.Object value,
    System.Object columnValue
);
Remarks

This method must handle the conversions between ecospace and database values, it must also handle comparing null/DBNull values.

See Also
TimeSpanAsDate Class
Eco.Persistence.Oracle Namespace


TimeSpanAsDate.StringToParameter Method

TimeSpanAsDate.StringToParameter Method
TimeSpanAsDate Class Eco.Persistence.Oracle Namespace See Also
Collapse All
C#
public void StringToParameter(
    string value,
    IDataParameter parameter
);
Remarks

This is StringToParameter, a member of class TimeSpanAsDate.

See Also
TimeSpanAsDate Class
Eco.Persistence.Oracle Namespace


TimeSpanAsDate.ValueToParameter Method

TimeSpanAsDate.ValueToParameter Method
TimeSpanAsDate Class Eco.Persistence.Oracle Namespace See Also
Collapse All

Converts a value that comes from a database query to an ecospace value.

C#
public void ValueToParameter(
    System.Object value,
    IDataParameter parameter
);
Remarks

In many cases, the implementation of this method mainly converts null to DBNull, but it can also handle conversion from for example booleans to integers, byte[] to database blobs. It also has to set the correct parameter types in the IDataParameter-object. This is the reverse operation of ColumnToValue.

See Also
TimeSpanAsDate Class
Eco.Persistence.Oracle Namespace


TimeSpanAsDate.ValueType Method

TimeSpanAsDate.ValueType Method
TimeSpanAsDate Class Eco.Persistence.Oracle Namespace See Also
Collapse All

This method returns the type of the value that is returned by ColumnToValue.

C#
public System.Type ValueType();
See Also
TimeSpanAsDate Class
Eco.Persistence.Oracle Namespace


TimeSpanAsLongInteger Class

TimeSpanAsLongInteger Class
Inheritance Hierarchy See Also
Collapse All
C#
public sealed class TimeSpanAsLongInteger : AbstractSingleColumnAttribute, ISingleColumnAttributemapping;
Remarks

This is class Eco.Persistence.Oracle.TimeSpanAsLongInteger.

Inheritance Hierarchy
Eco.Persistence.ISingleColumnAttributemapping
    Eco.Persistence.Oracle.TimeSpanAsLongInteger
File

OracleAttributeMappers.cs

See Also
Inheritance Hierarchy


TimeSpanAsLongInteger Methods

TimeSpanAsLongInteger Methods
Public Methods
Collapse All

The methods of the TimeSpanAsLongInteger class are listed here.

Public Methods
Name | Description
ColumnToValue | Converts a value that comes from a database query to an ecospace value.
ColumnType | Specifies the SQL type of the column.
DefaultDbValue | The return value of this function will be used as default value for new columns when databases are created/evolved.
IsEqual | Returns true if an ecospace value ("value") is equal to a database value ("columnValue").
StringToParameter | This is StringToParameter, a member of class TimeSpanAsLongInteger.
ValueToParameter | Converts a value that comes from a database query to an ecospace value.
ValueType | This method returns the type of the value that is returned by ColumnToValue.


TimeSpanAsLongInteger.ColumnToValue Method

TimeSpanAsLongInteger.ColumnToValue Method
TimeSpanAsLongInteger Class Eco.Persistence.Oracle Namespace See Also
Collapse All

Converts a value that comes from a database query to an ecospace value.

C#
public override System.Object ColumnToValue(
    System.Object columnValue
);
Remarks

In many cases, the implementation of this method mainly converts DBNull-values to null, but it can also change the CLR-type of the database value from for example a char[] to a string. or from an integer to a boolean. This is the reverse operation of ValueToParameter.

See Also
TimeSpanAsLongInteger Class
Eco.Persistence.Oracle Namespace


TimeSpanAsLongInteger.ColumnType Method

TimeSpanAsLongInteger.ColumnType Method
TimeSpanAsLongInteger Class Eco.Persistence.Oracle Namespace See Also
Collapse All

Specifies the SQL type of the column.

C#
public String ColumnType(
    int length
);
See Also
TimeSpanAsLongInteger Class
Eco.Persistence.Oracle Namespace


TimeSpanAsLongInteger.DefaultDbValue Method

TimeSpanAsLongInteger.DefaultDbValue Method
TimeSpanAsLongInteger Class Eco.Persistence.Oracle Namespace See Also
Collapse All

The return value of this function will be used as default value for new columns when databases are created/evolved.

C#
public String DefaultDbValue(
    string modeledValue,
    SqlDatabaseConfig sqlDatabaseConfig
);
See Also
TimeSpanAsLongInteger Class
Eco.Persistence.Oracle Namespace


TimeSpanAsLongInteger.IsEqual Method

TimeSpanAsLongInteger.IsEqual Method
TimeSpanAsLongInteger Class Eco.Persistence.Oracle Namespace See Also
Collapse All

Returns true if an ecospace value ("value") is equal to a database value ("columnValue").

C#
public override bool IsEqual(
    System.Object value,
    System.Object columnValue
);
Remarks

This method must handle the conversions between ecospace and database values, it must also handle comparing null/DBNull values.

See Also
TimeSpanAsLongInteger Class
Eco.Persistence.Oracle Namespace


TimeSpanAsLongInteger.StringToParameter Method

TimeSpanAsLongInteger.StringToParameter Method
TimeSpanAsLongInteger Class Eco.Persistence.Oracle Namespace See Also
Collapse All
C#
public void StringToParameter(
    string value,
    IDataParameter parameter
);
Remarks

This is StringToParameter, a member of class TimeSpanAsLongInteger.

See Also
TimeSpanAsLongInteger Class
Eco.Persistence.Oracle Namespace


TimeSpanAsLongInteger.ValueToParameter Method

TimeSpanAsLongInteger.ValueToParameter Method
TimeSpanAsLongInteger Class Eco.Persistence.Oracle Namespace See Also
Collapse All

Converts a value that comes from a database query to an ecospace value.

C#
public void ValueToParameter(
    System.Object value,
    IDataParameter parameter
);
Remarks

In many cases, the implementation of this method mainly converts null to DBNull, but it can also handle conversion from for example booleans to integers, byte[] to database blobs. It also has to set the correct parameter types in the IDataParameter-object. This is the reverse operation of ColumnToValue.

See Also
TimeSpanAsLongInteger Class
Eco.Persistence.Oracle Namespace


TimeSpanAsLongInteger.ValueType Method

TimeSpanAsLongInteger.ValueType Method
TimeSpanAsLongInteger Class Eco.Persistence.Oracle Namespace See Also
Collapse All

This method returns the type of the value that is returned by ColumnToValue.

C#
public System.Type ValueType();
See Also
TimeSpanAsLongInteger Class
Eco.Persistence.Oracle Namespace


Eco.Persistence.OracleClient Namespace

Eco.Persistence.OracleClient Namespace
Classes
Collapse All

This is namespace Eco.Persistence.OracleClient.

Classes
Name | Description
ByteArrayAsBlob | Mapper between a ByteArray value and its persistent representation as BLOB.
StringAsClob | This is class Eco.Persistence.OracleClient.StringAsClob.
StringAsNClob | This is class Eco.Persistence.OracleClient.StringAsNClob.
StringAsVarChar2 | This is class Eco.Persistence.OracleClient.StringAsVarChar2.


ByteArrayAsBlob Class

ByteArrayAsBlob Class
Inheritance Hierarchy See Also
Collapse All

Mapper between a ByteArray value and its persistent representation as BLOB.

C#
public sealed class ByteArrayAsBlob : AbstractSingleColumnAttribute, ISingleColumnAttributemapping, IDefaultReverseMapping;
Inheritance Hierarchy
Eco.Persistence.IDefaultReverseMapping
Eco.Persistence.ISingleColumnAttributemapping
    Eco.Persistence.OracleClient.ByteArrayAsBlob
File

OracleAttributeMappersOracle.cs

See Also
Inheritance Hierarchy


ByteArrayAsBlob.ColumnToValue Method

ByteArrayAsBlob.ColumnToValue Method
ByteArrayAsBlob Class Eco.Persistence.OracleClient Namespace See Also
Collapse All

Converts a value that comes from a database query to an ecospace value.

C#
public override System.Object ColumnToValue(
    System.Object columnValue
);
Remarks

In many cases, the implementation of this method mainly converts DBNull-values to null, but it can also change the CLR-type of the database value from for example a char[] to a string. or from an integer to a boolean. This is the reverse operation of ValueToParameter.

See Also
ByteArrayAsBlob Class
Eco.Persistence.OracleClient Namespace


ByteArrayAsBlob.ColumnType Method

ByteArrayAsBlob.ColumnType Method
ByteArrayAsBlob Class Eco.Persistence.OracleClient Namespace See Also
Collapse All

Specifies the SQL type of the column.

C#
public string ColumnType(
    int length
);
See Also
ByteArrayAsBlob Class
Eco.Persistence.OracleClient Namespace


ByteArrayAsBlob.DefaultDbValue Method

ByteArrayAsBlob.DefaultDbValue Method
ByteArrayAsBlob Class Eco.Persistence.OracleClient Namespace See Also
Collapse All

The return value of this function will be used as default value for new columns when databases are created/evolved.

C#
public string DefaultDbValue(
    string modeledValue,
    SqlDatabaseConfig sqlDatabaseConfig
);
See Also
ByteArrayAsBlob Class
Eco.Persistence.OracleClient Namespace


ByteArrayAsBlob.IsEqual Method

ByteArrayAsBlob.IsEqual Method
ByteArrayAsBlob Class Eco.Persistence.OracleClient Namespace See Also
Collapse All

Returns true if an ecospace value ("value") is equal to a database value ("columnValue").

C#
public override bool IsEqual(
    System.Object value,
    System.Object columnValue
);
Remarks

This method must handle the conversions between ecospace and database values, it must also handle comparing null/DBNull values.

See Also
ByteArrayAsBlob Class
Eco.Persistence.OracleClient Namespace


ByteArrayAsBlob.StringToParameter Method

ByteArrayAsBlob.StringToParameter Method
ByteArrayAsBlob Class Eco.Persistence.OracleClient Namespace See Also
Collapse All
C#
public void StringToParameter(
    string value,
    IDataParameter parameter
);
Exceptions
Exceptions | Description
InvalidOperationException | Thrown always.
See Also
ByteArrayAsBlob Class
Eco.Persistence.OracleClient Namespace


ByteArrayAsBlob.ValueToParameter Method

ByteArrayAsBlob.ValueToParameter Method
ByteArrayAsBlob Class Eco.Persistence.OracleClient Namespace See Also
Collapse All

Converts a value that comes from a database query to an ecospace value.

C#
public void ValueToParameter(
    System.Object value,
    IDataParameter parameter
);
Remarks

In many cases, the implementation of this method mainly converts null to DBNull, but it can also handle conversion from for example booleans to integers, byte[] to database blobs. It also has to set the correct parameter types in the IDataParameter-object. This is the reverse operation of ColumnToValue.

See Also
ByteArrayAsBlob Class
Eco.Persistence.OracleClient Namespace


ByteArrayAsBlob.ValueType Method

ByteArrayAsBlob.ValueType Method
ByteArrayAsBlob Class Eco.Persistence.OracleClient Namespace See Also
Collapse All

This method returns the type of the value that is returned by ColumnToValue.

C#
public System.Type ValueType();
See Also
ByteArrayAsBlob Class
Eco.Persistence.OracleClient Namespace


StringAsClob Class

StringAsClob Class
Inheritance Hierarchy See Also
Collapse All
C#
public sealed class StringAsClob : AbstractSingleColumnAttribute, ISingleColumnAttributemapping, IDefaultReverseMapping;
Remarks

This is class Eco.Persistence.OracleClient.StringAsClob.

Inheritance Hierarchy
Eco.Persistence.IDefaultReverseMapping
Eco.Persistence.ISingleColumnAttributemapping
    Eco.Persistence.OracleClient.StringAsClob
File

OracleAttributeMappersOracle.cs

See Also
Inheritance Hierarchy


StringAsClob.ColumnToValue Method

StringAsClob.ColumnToValue Method
StringAsClob Class Eco.Persistence.OracleClient Namespace See Also
Collapse All

Converts a value that comes from a database query to an ecospace value.

C#
public override System.Object ColumnToValue(
    System.Object columnValue
);
Remarks

In many cases, the implementation of this method mainly converts DBNull-values to null, but it can also change the CLR-type of the database value from for example a char[] to a string. or from an integer to a boolean. This is the reverse operation of ValueToParameter.

See Also
StringAsClob Class
Eco.Persistence.OracleClient Namespace


StringAsClob.ColumnType Method

StringAsClob.ColumnType Method
StringAsClob Class Eco.Persistence.OracleClient Namespace See Also
Collapse All

Specifies the SQL type of the column.

C#
public string ColumnType(
    int length
);
See Also
StringAsClob Class
Eco.Persistence.OracleClient Namespace


StringAsClob.DefaultDbValue Method

StringAsClob.DefaultDbValue Method
StringAsClob Class Eco.Persistence.OracleClient Namespace See Also
Collapse All

The return value of this function will be used as default value for new columns when databases are created/evolved.

C#
public string DefaultDbValue(
    string modeledValue,
    SqlDatabaseConfig sqlDatabaseConfig
);
See Also
StringAsClob Class
Eco.Persistence.OracleClient Namespace


StringAsClob.StringToParameter Method

StringAsClob.StringToParameter Method
StringAsClob Class Eco.Persistence.OracleClient Namespace See Also
Collapse All
C#
public void StringToParameter(
    string value,
    IDataParameter parameter
);
Remarks

This is StringToParameter, a member of class StringAsClob.

See Also
StringAsClob Class
Eco.Persistence.OracleClient Namespace


StringAsClob.ValueToParameter Method

StringAsClob.ValueToParameter Method
StringAsClob Class Eco.Persistence.OracleClient Namespace See Also
Collapse All

Converts a value that comes from a database query to an ecospace value.

C#
public void ValueToParameter(
    System.Object value,
    IDataParameter parameter
);
Remarks

In many cases, the implementation of this method mainly converts null to DBNull, but it can also handle conversion from for example booleans to integers, byte[] to database blobs. It also has to set the correct parameter types in the IDataParameter-object. This is the reverse operation of ColumnToValue.

See Also
StringAsClob Class
Eco.Persistence.OracleClient Namespace


StringAsClob.ValueType Method

StringAsClob.ValueType Method
StringAsClob Class Eco.Persistence.OracleClient Namespace See Also
Collapse All

This method returns the type of the value that is returned by ColumnToValue.

C#
public System.Type ValueType();
See Also
StringAsClob Class
Eco.Persistence.OracleClient Namespace


StringAsNClob Class

StringAsNClob Class
Inheritance Hierarchy See Also
Collapse All
C#
public sealed class StringAsNClob : AbstractSingleColumnAttribute, ISingleColumnAttributemapping, IDefaultReverseMapping;
Remarks

This is class Eco.Persistence.OracleClient.StringAsNClob.

Inheritance Hierarchy
Eco.Persistence.IDefaultReverseMapping
Eco.Persistence.ISingleColumnAttributemapping
    Eco.Persistence.OracleClient.StringAsNClob
File

OracleAttributeMappersOracle.cs

See Also
Inheritance Hierarchy


StringAsNClob.ColumnToValue Method

StringAsNClob.ColumnToValue Method
StringAsNClob Class Eco.Persistence.OracleClient Namespace See Also
Collapse All

Converts a value that comes from a database query to an ecospace value.

C#
public override System.Object ColumnToValue(
    System.Object columnValue
);
Remarks

In many cases, the implementation of this method mainly converts DBNull-values to null, but it can also change the CLR-type of the database value from for example a char[] to a string. or from an integer to a boolean. This is the reverse operation of ValueToParameter.

See Also
StringAsNClob Class
Eco.Persistence.OracleClient Namespace


StringAsNClob.ColumnType Method

StringAsNClob.ColumnType Method
StringAsNClob Class Eco.Persistence.OracleClient Namespace See Also
Collapse All

Specifies the SQL type of the column.

C#
public string ColumnType(
    int length
);
See Also
StringAsNClob Class
Eco.Persistence.OracleClient Namespace


StringAsNClob.DefaultDbValue Method

StringAsNClob.DefaultDbValue Method
StringAsNClob Class Eco.Persistence.OracleClient Namespace See Also
Collapse All

The return value of this function will be used as default value for new columns when databases are created/evolved.

C#
public string DefaultDbValue(
    string modeledValue,
    SqlDatabaseConfig sqlDatabaseConfig
);
See Also
StringAsNClob Class
Eco.Persistence.OracleClient Namespace


StringAsNClob.StringToParameter Method

StringAsNClob.StringToParameter Method
StringAsNClob Class Eco.Persistence.OracleClient Namespace See Also
Collapse All
C#
public void StringToParameter(
    string value,
    IDataParameter parameter
);
Remarks

This is StringToParameter, a member of class StringAsNClob.

See Also
StringAsNClob Class
Eco.Persistence.OracleClient Namespace


StringAsNClob.ValueToParameter Method

StringAsNClob.ValueToParameter Method
StringAsNClob Class Eco.Persistence.OracleClient Namespace See Also
Collapse All

Converts a value that comes from a database query to an ecospace value.

C#
public void ValueToParameter(
    System.Object value,
    IDataParameter parameter
);
Remarks

In many cases, the implementation of this method mainly converts null to DBNull, but it can also handle conversion from for example booleans to integers, byte[] to database blobs. It also has to set the correct parameter types in the IDataParameter-object. This is the reverse operation of ColumnToValue.

See Also
StringAsNClob Class
Eco.Persistence.OracleClient Namespace


StringAsNClob.ValueType Method

StringAsNClob.ValueType Method
StringAsNClob Class Eco.Persistence.OracleClient Namespace See Also
Collapse All

This method returns the type of the value that is returned by ColumnToValue.

C#
public System.Type ValueType();
See Also
StringAsNClob Class
Eco.Persistence.OracleClient Namespace


StringAsVarChar2 Class

StringAsVarChar2 Class
Inheritance Hierarchy See Also
Collapse All
C#
public sealed class StringAsVarChar2 : AbstractStringSingleColumnAttribute, ISingleColumnAttributemapping, IDefaultReverseMapping;
Remarks

This is class Eco.Persistence.OracleClient.StringAsVarChar2.

Inheritance Hierarchy
Eco.Persistence.IDefaultReverseMapping
Eco.Persistence.ISingleColumnAttributemapping
    Eco.Persistence.OracleClient.StringAsVarChar2
File

OracleAttributeMappersOracle.cs

See Also
Inheritance Hierarchy


StringAsVarChar2 Fields

StringAsVarChar2 Fields
Public Fields
Collapse All

The fields of the StringAsVarChar2 class are listed here.

Public Fields
Name | Description
EmptyStringMarker | This is EmptyStringMarker, a member of class StringAsVarChar2.


StringAsVarChar2.EmptyStringMarker Field

StringAsVarChar2.EmptyStringMarker Field
StringAsVarChar2 Class Eco.Persistence.OracleClient Namespace See Also
Collapse All
C#
public static string EmptyStringMarker = "<<EMPTY_STRING>>";
Remarks

This is EmptyStringMarker, a member of class StringAsVarChar2.

See Also
StringAsVarChar2 Class
Eco.Persistence.OracleClient Namespace


StringAsVarChar2.ColumnToValue Method

StringAsVarChar2.ColumnToValue Method
StringAsVarChar2 Class Eco.Persistence.OracleClient Namespace See Also
Collapse All

Converts a value that comes from a database query to an ecospace value.

C#
public override System.Object ColumnToValue(
    System.Object columnValue
);
Remarks

In many cases, the implementation of this method mainly converts DBNull-values to null, but it can also change the CLR-type of the database value from for example a char[] to a string. or from an integer to a boolean. This is the reverse operation of ValueToParameter.

See Also
StringAsVarChar2 Class
Eco.Persistence.OracleClient Namespace


StringAsVarChar2.ColumnType Method

StringAsVarChar2.ColumnType Method
StringAsVarChar2 Class Eco.Persistence.OracleClient Namespace See Also
Collapse All

Specifies the SQL type of the column.

C#
public String ColumnType(
    int length
);
See Also
StringAsVarChar2 Class
Eco.Persistence.OracleClient Namespace


StringAsVarChar2.StringToParameter Method

StringAsVarChar2.StringToParameter Method
StringAsVarChar2 Class Eco.Persistence.OracleClient Namespace See Also
Collapse All
C#
public void StringToParameter(
    string value,
    IDataParameter parameter
);
Remarks

This is StringToParameter, a member of class StringAsVarChar2.

See Also
StringAsVarChar2 Class
Eco.Persistence.OracleClient Namespace


StringAsVarChar2.ValueToParameter Method

StringAsVarChar2.ValueToParameter Method
StringAsVarChar2 Class Eco.Persistence.OracleClient Namespace See Also
Collapse All

Converts a value that comes from a database query to an ecospace value.

C#
public void ValueToParameter(
    System.Object value,
    IDataParameter parameter
);
Remarks

In many cases, the implementation of this method mainly converts null to DBNull, but it can also handle conversion from for example booleans to integers, byte[] to database blobs. It also has to set the correct parameter types in the IDataParameter-object. This is the reverse operation of ColumnToValue.

See Also
StringAsVarChar2 Class
Eco.Persistence.OracleClient Namespace


StringAsVarChar2.ValueType Method

StringAsVarChar2.ValueType Method
StringAsVarChar2 Class Eco.Persistence.OracleClient Namespace See Also
Collapse All

This method returns the type of the value that is returned by ColumnToValue.

C#
public System.Type ValueType();
See Also
StringAsVarChar2 Class
Eco.Persistence.OracleClient Namespace


Eco.Persistence.ORMapping Namespace

Eco.Persistence.ORMapping Namespace
Classes Enumerations Interfaces
Collapse All

This is namespace Eco.Persistence.ORMapping.

Classes
Name | Description
AliasCollection | This is class Eco.Persistence.ORMapping.AliasCollection.
AliasDefinition | This is class Eco.Persistence.ORMapping.AliasDefinition.
AttributeDefinition | This is class Eco.Persistence.ORMapping.AttributeDefinition.
ClassCollection | This is class Eco.Persistence.ORMapping.ClassCollection.
ClassDefinition | This is class Eco.Persistence.ORMapping.ClassDefinition.
ColumnCollection | This is class Eco.Persistence.ORMapping.ColumnCollection.
ColumnDefinition | This is class Eco.Persistence.ORMapping.ColumnDefinition.
ColumnReference | This is class Eco.Persistence.ORMapping.ColumnReference.
ColumnReferenceCollection | This is class Eco.Persistence.ORMapping.ColumnReferenceCollection.
ColumnTypeFixer | Summary description for Class.
Common | This is class Eco.Persistence.ORMapping.Common.
ConstantColumnCollection | This is class Eco.Persistence.ORMapping.ConstantColumnCollection.
ConstantColumnDefinition | This is class Eco.Persistence.ORMapping.ConstantColumnDefinition.
DatabaseCollection | This is class Eco.Persistence.ORMapping.DatabaseCollection.
DatabaseDefinition | This is class Eco.Persistence.ORMapping.DatabaseDefinition.
DbMappingProvider | Designer("Eco.Persistence.Design.DbMappingProvider, Eco.Handles.Design" + VersionInfo.AssemblySuffix, typeof(IDesigner))
DbMetaSupport | This is class Eco.Persistence.ORMapping.DbMetaSupport.
DefaultORMappingBuilder | This class builds an O/R mapping information structure based on an eco model.
DiscriminatorDef | This is class Eco.Persistence.ORMapping.DiscriminatorDef.
DiscriminatorDefCollection | This is class Eco.Persistence.ORMapping.DiscriminatorDefCollection.
DiscriminatorImplementation | This is class Eco.Persistence.ORMapping.DiscriminatorImplementation.
DiscriminatorImplementationCollection | This is class Eco.Persistence.ORMapping.DiscriminatorImplementationCollection.
DiscriminatorValue | This is class Eco.Persistence.ORMapping.DiscriminatorValue.
DiscriminatorValueCollection | This is class Eco.Persistence.ORMapping.DiscriminatorValueCollection.
FeatureCollection | This is class Eco.Persistence.ORMapping.FeatureCollection.
FileMappingProvider | Designer("Eco.Persistence.Design.FileMappingProvider, Eco.Handles.Design" + VersionInfo.AssemblySuffix, typeof(IDesigner))
ForeignKeyCollection | This is class Eco.Persistence.ORMapping.ForeignKeyCollection.
ForeignKeyDefinition | This is class Eco.Persistence.ORMapping.ForeignKeyDefinition.
IndexCollection | This is class Eco.Persistence.ORMapping.IndexCollection.
IndexDefinition | This is class Eco.Persistence.ORMapping.IndexDefinition.
KeyDefinition | This is class Eco.Persistence.ORMapping.KeyDefinition.
KeyDefinitionCollection | This is class Eco.Persistence.ORMapping.KeyDefinitionCollection.
KeyImplementation | This is class Eco.Persistence.ORMapping.KeyImplementation.
KeyImplementationCollection | This is class Eco.Persistence.ORMapping.KeyImplementationCollection.
NamedDefinition | This is class Eco.Persistence.ORMapping.NamedDefinition.
ORMappingDefinition | This is class Eco.Persistence.ORMapping.ORMappingDefinition.
ORMappingValidator | This is class Eco.Persistence.ORMapping.ORMappingValidator.
ORMappingXmlGenerator | This is class Eco.Persistence.ORMapping.ORMappingXmlGenerator.
ORMappingXmlReader | This is class Eco.Persistence.ORMapping.ORMappingXmlReader.
SingleLinkDefinition | This is class Eco.Persistence.ORMapping.SingleLinkDefinition.
StructuralFeatureDefinition | This is class Eco.Persistence.ORMapping.StructuralFeatureDefinition.
TableCollection | This is class Eco.Persistence.ORMapping.TableCollection.
TableDefinition | This is class Eco.Persistence.ORMapping.TableDefinition.
Top
Enumerations
Name | Description
AliasMode | This is record Eco.Persistence.ORMapping.AliasMode.
DiscriminatorMode | This is record Eco.Persistence.ORMapping.DiscriminatorMode.
EcoCompatibilityMode | This is record Eco.Persistence.ORMapping.EcoCompatibilityMode.
KeyCoverage | This is record Eco.Persistence.ORMapping.KeyCoverage.
Top
Interfaces
Name | Description
IORMappingProvider | Summary description for Class.


AliasCollection Class

AliasCollection Class
Inheritance Hierarchy See Also
Collapse All
C#
public sealed class AliasCollection : Eco.Collections.HashBase;
Remarks

This is class Eco.Persistence.ORMapping.AliasCollection.

Inheritance Hierarchy
Eco.Persistence.ORMapping.AliasCollection
File

ORMappingDefinition.cs

See Also
Inheritance Hierarchy


AliasCollection Methods

AliasCollection Methods
Public Methods
Collapse All

The methods of the AliasCollection class are listed here.

Public Methods
Name | Description
Add | This is Add, a member of class AliasCollection.
this | This is this, a member of class AliasCollection.


AliasCollection.Add Method

AliasCollection.Add Method
AliasCollection Class Eco.Persistence.ORMapping Namespace See Also
Collapse All
C#
public void Add(
    AliasDefinition value
);
Remarks

This is Add, a member of class AliasCollection.

See Also
AliasCollection Class
Eco.Persistence.ORMapping Namespace


AliasCollection.this Indexer

AliasCollection.this Indexer
AliasCollection Class Eco.Persistence.ORMapping Namespace See Also
Collapse All
C#
public AliasDefinition this[
    string name
];
Remarks

This is this, a member of class AliasCollection.

See Also
AliasCollection Class
Eco.Persistence.ORMapping Namespace


AliasCollection Properties

AliasCollection Properties
Public Properties
Collapse All

The properties of the AliasCollection class are listed here.

Public Properties
Name | Description
Any | This is Any, a member of class AliasCollection.


AliasCollection.Any Property

AliasCollection.Any Property
AliasCollection Class Eco.Persistence.ORMapping Namespace See Also
Collapse All
C#
public AliasDefinition Any;
Remarks

This is Any, a member of class AliasCollection.

See Also
AliasCollection Class
Eco.Persistence.ORMapping Namespace


AliasDefinition Class

AliasDefinition Class
Inheritance Hierarchy See Also
Collapse All
C#
public sealed class AliasDefinition : NamedDefinition;
Remarks

This is class Eco.Persistence.ORMapping.AliasDefinition.

Inheritance Hierarchy
Eco.Persistence.ORMapping.NamedDefinition
    Eco.Persistence.ORMapping.AliasDefinition
File

ORMappingDefinition.cs

See Also
Inheritance Hierarchy


AliasDefinition Methods

AliasDefinition Methods
Public Methods
Collapse All

The methods of the AliasDefinition class are listed here.

Public Methods
Name | Description
AliasTable | This is AliasTable, a member of class AliasDefinition.
FindCommonKey |
MarkHasIdKey | This is MarkHasIdKey, a member of class AliasDefinition.


AliasDefinition.AliasTable Method

AliasDefinition.AliasTable Method
AliasDefinition Class Eco.Persistence.ORMapping Namespace See Also
Collapse All
C#
public string AliasTable(
    SqlDatabaseConfig config
);
Remarks

This is AliasTable, a member of class AliasDefinition.

See Also
AliasDefinition Class
Eco.Persistence.ORMapping Namespace


AliasDefinition.FindCommonKey Method

AliasDefinition.FindCommonKey Method
AliasDefinition Class Eco.Persistence.ORMapping Namespace See Also
Collapse All
C#
public KeyDefinition FindCommonKey(
    AliasDefinition alias
);
Exceptions
Exceptions | Description
ArgumentNullException | Thrown if alias is null
See Also
AliasDefinition Class
Eco.Persistence.ORMapping Namespace


AliasDefinition.MarkHasIdKey Method

AliasDefinition.MarkHasIdKey Method
AliasDefinition Class Eco.Persistence.ORMapping Namespace See Also
Collapse All
C#
public void MarkHasIdKey();
Remarks

This is MarkHasIdKey, a member of class AliasDefinition.

See Also
AliasDefinition Class
Eco.Persistence.ORMapping Namespace


AliasDefinition Properties

AliasDefinition Properties
Public Properties
Collapse All

The properties of the AliasDefinition class are listed here.

Public Properties
Name | Description
Discriminators | This is Discriminators, a member of class AliasDefinition.
ExtentRequiresDiscriminator | This is ExtentRequiresDiscriminator, a member of class AliasDefinition.
HasIdKey | This is HasIdKey, a member of class AliasDefinition.
IdKey | This is IdKey, a member of class AliasDefinition.
IsMainAlias | This is IsMainAlias, a member of class AliasDefinition.
Keys | This is Keys, a member of class AliasDefinition.
Name | This is Name, a member of class AliasDefinition.
StartTimeColumn | This is StartTimeColumn, a member of class AliasDefinition.
StopTimeColumn | This is StopTimeColumn, a member of class AliasDefinition.
Table | This is Table, a member of class AliasDefinition.


AliasDefinition.Discriminators Property

AliasDefinition.Discriminators Property
AliasDefinition Class Eco.Persistence.ORMapping Namespace See Also
Collapse All
C#
public DiscriminatorImplementationCollection Discriminators;
Remarks

This is Discriminators, a member of class AliasDefinition.

See Also
AliasDefinition Class
Eco.Persistence.ORMapping Namespace


AliasDefinition.ExtentRequiresDiscriminator Property

AliasDefinition.ExtentRequiresDiscriminator Property
AliasDefinition Class Eco.Persistence.ORMapping Namespace See Also
Collapse All
C#
public bool ExtentRequiresDiscriminator;
Remarks

This is ExtentRequiresDiscriminator, a member of class AliasDefinition.

See Also
AliasDefinition Class
Eco.Persistence.ORMapping Namespace


AliasDefinition.HasIdKey Property

AliasDefinition.HasIdKey Property
AliasDefinition Class Eco.Persistence.ORMapping Namespace See Also
Collapse All
C#
public bool HasIdKey;
Remarks

This is HasIdKey, a member of class AliasDefinition.

See Also
AliasDefinition Class
Eco.Persistence.ORMapping Namespace


AliasDefinition.IdKey Property

AliasDefinition.IdKey Property
AliasDefinition Class Eco.Persistence.ORMapping Namespace See Also
Collapse All
C#
public KeyImplementation IdKey;
Remarks

This is IdKey, a member of class AliasDefinition.

See Also
AliasDefinition Class
Eco.Persistence.ORMapping Namespace


AliasDefinition.IsMainAlias Property

AliasDefinition.IsMainAlias Property
AliasDefinition Class Eco.Persistence.ORMapping Namespace See Also
Collapse All
C#
public bool IsMainAlias;
Remarks

This is IsMainAlias, a member of class AliasDefinition.

See Also
AliasDefinition Class
Eco.Persistence.ORMapping Namespace


AliasDefinition.Keys Property

AliasDefinition.Keys Property
AliasDefinition Class Eco.Persistence.ORMapping Namespace See Also
Collapse All
C#
public KeyImplementationCollection Keys;
Remarks

This is Keys, a member of class AliasDefinition.

See Also
AliasDefinition Class
Eco.Persistence.ORMapping Namespace


AliasDefinition.Name Property

AliasDefinition.Name Property
AliasDefinition Class Eco.Persistence.ORMapping Namespace See Also
Collapse All
C#
public override string Name;
Remarks

This is Name, a member of class AliasDefinition.

See Also
AliasDefinition Class
Eco.Persistence.ORMapping Namespace


AliasDefinition.StartTimeColumn Property

AliasDefinition.StartTimeColumn Property
AliasDefinition Class Eco.Persistence.ORMapping Namespace See Also
Collapse All
C#
public ColumnReference StartTimeColumn;
Remarks

This is StartTimeColumn, a member of class AliasDefinition.

See Also
AliasDefinition Class
Eco.Persistence.ORMapping Namespace


AliasDefinition.StopTimeColumn Property

AliasDefinition.StopTimeColumn Property
AliasDefinition Class Eco.Persistence.ORMapping Namespace See Also
Collapse All
C#
public ColumnReference StopTimeColumn;
Remarks

This is StopTimeColumn, a member of class AliasDefinition.

See Also
AliasDefinition Class
Eco.Persistence.ORMapping Namespace


AliasDefinition.Table Property

AliasDefinition.Table Property
AliasDefinition Class Eco.Persistence.ORMapping Namespace See Also
Collapse All
C#
public TableDefinition Table;
Remarks

This is Table, a member of class AliasDefinition.

See Also
AliasDefinition Class
Eco.Persistence.ORMapping Namespace


AttributeDefinition Class

AttributeDefinition Class
Inheritance Hierarchy See Also
Collapse All
C#
public sealed class AttributeDefinition : StructuralFeatureDefinition;
Remarks

This is class Eco.Persistence.ORMapping.AttributeDefinition.

Inheritance Hierarchy
Eco.Persistence.ORMapping.NamedDefinition
    Eco.Persistence.ORMapping.StructuralFeatureDefinition
        Eco.Persistence.ORMapping.AttributeDefinition
File

ORMappingDefinition.cs

See Also
Inheritance Hierarchy


AttributeDefinition Properties

AttributeDefinition Properties
Public Properties
Collapse All

The properties of the AttributeDefinition class are listed here.

Public Properties
Name | Description
AttributeMapper | This is AttributeMapper, a member of class AttributeDefinition.
Pseudo | This is Pseudo, a member of class AttributeDefinition.


AttributeDefinition.AttributeMapper Property

AttributeDefinition.AttributeMapper Property
AttributeDefinition Class Eco.Persistence.ORMapping Namespace See Also
Collapse All
C#
public string AttributeMapper;
Remarks

This is AttributeMapper, a member of class AttributeDefinition.

See Also
AttributeDefinition Class
Eco.Persistence.ORMapping Namespace


AttributeDefinition.Pseudo Property

AttributeDefinition.Pseudo Property
AttributeDefinition Class Eco.Persistence.ORMapping Namespace See Also
Collapse All
C#
public override bool Pseudo;
Remarks

This is Pseudo, a member of class AttributeDefinition.

See Also
AttributeDefinition Class
Eco.Persistence.ORMapping Namespace


ClassCollection Class

ClassCollection Class
Inheritance Hierarchy See Also
Collapse All
C#
public sealed class ClassCollection : Eco.Collections.HashBase;
Remarks

This is class Eco.Persistence.ORMapping.ClassCollection.

Inheritance Hierarchy
Eco.Persistence.ORMapping.ClassCollection
File

ORMappingDefinition.cs

See Also
Inheritance Hierarchy


ClassCollection Methods

ClassCollection Methods
Public Methods
Collapse All

The methods of the ClassCollection class are listed here.

Public Methods
Name | Description
Add | This is Add, a member of class ClassCollection.
this | This is this, a member of class ClassCollection.


ClassCollection.Add Method

ClassCollection.Add Method
ClassCollection Class Eco.Persistence.ORMapping Namespace See Also
Collapse All
C#
public void Add(
    ClassDefinition value
);
Remarks

This is Add, a member of class ClassCollection.

See Also
ClassCollection Class
Eco.Persistence.ORMapping Namespace


ClassCollection.this Indexer

ClassCollection.this Indexer
ClassCollection Class Eco.Persistence.ORMapping Namespace See Also
Collapse All
C#
public ClassDefinition this[
    string name
];
Remarks

This is this, a member of class ClassCollection.

See Also
ClassCollection Class
Eco.Persistence.ORMapping Namespace


ClassDefinition Class

ClassDefinition Class
Inheritance Hierarchy See Also
Collapse All
C#
public sealed class ClassDefinition : NamedDefinition;
Remarks

This is class Eco.Persistence.ORMapping.ClassDefinition.

Inheritance Hierarchy
Eco.Persistence.ORMapping.NamedDefinition
    Eco.Persistence.ORMapping.ClassDefinition
File

ORMappingDefinition.cs

See Also
Inheritance Hierarchy


ClassDefinition.ClassDefinition Constructor

ClassDefinition.ClassDefinition Constructor
ClassDefinition Class Eco.Persistence.ORMapping Namespace See Also
Collapse All
C#
public ClassDefinition(
    ORMappingDefinition mapping
);
Remarks

This is ClassDefinition, a member of class ClassDefinition.

See Also
ClassDefinition Class
Eco.Persistence.ORMapping Namespace


ClassDefinition Methods

ClassDefinition Methods
Public Methods
Collapse All

The methods of the ClassDefinition class are listed here.

Public Methods
Name | Description
GetValueForDiscriminator |


ClassDefinition.GetValueForDiscriminator Method

ClassDefinition.GetValueForDiscriminator Method
ClassDefinition Class Eco.Persistence.ORMapping Namespace See Also
Collapse All
C#
public DiscriminatorValue GetValueForDiscriminator(
    DiscriminatorDef disc
);
Exceptions
Exceptions | Description
ArgumentNullException | Thrown if disc is null
See Also
ClassDefinition Class
Eco.Persistence.ORMapping Namespace


ClassDefinition Properties

ClassDefinition Properties
Public Properties
Collapse All

The properties of the ClassDefinition class are listed here.

Public Properties
Name | Description
Aliases | This is Aliases, a member of class ClassDefinition.
AllAliases | This is AllAliases, a member of class ClassDefinition.
AllFeatures | This is AllFeatures, a member of class ClassDefinition.
ClassId | This is ClassId, a member of class ClassDefinition.
Database | This is Database, a member of class ClassDefinition.
Discriminators | This is Discriminators, a member of class ClassDefinition.
DiscriminatorValues | This is DiscriminatorValues, a member of class ClassDefinition.
Features | This is Features, a member of class ClassDefinition.
Id | This is Id, a member of class ClassDefinition.
Keys | This is Keys, a member of class ClassDefinition.
MainAlias | This is MainAlias, a member of class ClassDefinition.
Mapping | This is Mapping, a member of class ClassDefinition.
SuperClass | This is SuperClass, a member of class ClassDefinition.


ClassDefinition.Aliases Property

ClassDefinition.Aliases Property
ClassDefinition Class Eco.Persistence.ORMapping Namespace See Also
Collapse All
C#
public AliasCollection Aliases;
Remarks

This is Aliases, a member of class ClassDefinition.

See Also
ClassDefinition Class
Eco.Persistence.ORMapping Namespace


ClassDefinition.AllAliases Property

ClassDefinition.AllAliases Property
ClassDefinition Class Eco.Persistence.ORMapping Namespace See Also
Collapse All
C#
public AliasCollection AllAliases;
Remarks

This is AllAliases, a member of class ClassDefinition.

See Also
ClassDefinition Class
Eco.Persistence.ORMapping Namespace


ClassDefinition.AllFeatures Property

ClassDefinition.AllFeatures Property
ClassDefinition Class Eco.Persistence.ORMapping Namespace See Also
Collapse All
C#
public FeatureCollection AllFeatures;
Remarks

This is AllFeatures, a member of class ClassDefinition.

See Also
ClassDefinition Class
Eco.Persistence.ORMapping Namespace


ClassDefinition.ClassId Property

ClassDefinition.ClassId Property
ClassDefinition Class Eco.Persistence.ORMapping Namespace See Also
Collapse All
C#
public int ClassId;
Remarks

This is ClassId, a member of class ClassDefinition.

See Also
ClassDefinition Class
Eco.Persistence.ORMapping Namespace


ClassDefinition.Database Property

ClassDefinition.Database Property
ClassDefinition Class Eco.Persistence.ORMapping Namespace See Also
Collapse All
C#
public DatabaseDefinition Database;
Remarks

This is Database, a member of class ClassDefinition.

See Also
ClassDefinition Class
Eco.Persistence.ORMapping Namespace


ClassDefinition.Discriminators Property

ClassDefinition.Discriminators Property
ClassDefinition Class Eco.Persistence.ORMapping Namespace See Also
Collapse All
C#
public DiscriminatorDefCollection Discriminators;
Remarks

This is Discriminators, a member of class ClassDefinition.

See Also
ClassDefinition Class
Eco.Persistence.ORMapping Namespace


ClassDefinition.DiscriminatorValues Property

ClassDefinition.DiscriminatorValues Property
ClassDefinition Class Eco.Persistence.ORMapping Namespace See Also
Collapse All
C#
public DiscriminatorValueCollection DiscriminatorValues;
Remarks

This is DiscriminatorValues, a member of class ClassDefinition.

See Also
ClassDefinition Class
Eco.Persistence.ORMapping Namespace


ClassDefinition.Features Property

ClassDefinition.Features Property
ClassDefinition Class Eco.Persistence.ORMapping Namespace See Also
Collapse All
C#
public FeatureCollection Features;
Remarks

This is Features, a member of class ClassDefinition.

See Also
ClassDefinition Class
Eco.Persistence.ORMapping Namespace


ClassDefinition.Id Property

ClassDefinition.Id Property
ClassDefinition Class Eco.Persistence.ORMapping Namespace See Also
Collapse All
C#
public KeyDefinition Id;
Remarks

This is Id, a member of class ClassDefinition.

See Also
ClassDefinition Class
Eco.Persistence.ORMapping Namespace


ClassDefinition.Keys Property

ClassDefinition.Keys Property
ClassDefinition Class Eco.Persistence.ORMapping Namespace See Also
Collapse All
C#
public KeyDefinitionCollection Keys;
Remarks

This is Keys, a member of class ClassDefinition.

See Also
ClassDefinition Class
Eco.Persistence.ORMapping Namespace


ClassDefinition.MainAlias Property

ClassDefinition.MainAlias Property
ClassDefinition Class Eco.Persistence.ORMapping Namespace See Also
Collapse All
C#
public AliasDefinition MainAlias;
Remarks

This is MainAlias, a member of class ClassDefinition.

See Also
ClassDefinition Class
Eco.Persistence.ORMapping Namespace


ClassDefinition.Mapping Property

ClassDefinition.Mapping Property
ClassDefinition Class Eco.Persistence.ORMapping Namespace See Also
Collapse All
C#
public ORMappingDefinition Mapping;
Remarks

This is Mapping, a member of class ClassDefinition.

See Also
ClassDefinition Class
Eco.Persistence.ORMapping Namespace


ClassDefinition.SuperClass Property

ClassDefinition.SuperClass Property
ClassDefinition Class Eco.Persistence.ORMapping Namespace See Also
Collapse All
C#
public ClassDefinition SuperClass;
Remarks

This is SuperClass, a member of class ClassDefinition.

See Also
ClassDefinition Class
Eco.Persistence.ORMapping Namespace


ColumnCollection Class

ColumnCollection Class
Inheritance Hierarchy See Also
Collapse All
C#
public sealed class ColumnCollection : Eco.Collections.CollectionBase;
Remarks

This is class Eco.Persistence.ORMapping.ColumnCollection.

Inheritance Hierarchy
Eco.Persistence.ORMapping.ColumnCollection
File

ORMappingDefinition.cs

See Also
Inheritance Hierarchy


ColumnCollection Methods

ColumnCollection Methods
Public Methods
Collapse All

The methods of the ColumnCollection class are listed here.

Public Methods
Name | Description
Add |
CommaList | This is CommaList, a member of class ColumnCollection.
this | This is the overview for the this indexer overload.


ColumnCollection.Add Method

ColumnCollection.Add Method
ColumnCollection Class Eco.Persistence.ORMapping Namespace See Also
Collapse All
C#
public void Add(
    ColumnDefinition value
);
Exceptions
Exceptions | Description
ArgumentNullException | Thrown if value is null
See Also
ColumnCollection Class
Eco.Persistence.ORMapping Namespace


ColumnCollection.CommaList Method

ColumnCollection.CommaList Method
ColumnCollection Class Eco.Persistence.ORMapping Namespace See Also
Collapse All
C#
public string CommaList();
Remarks

This is CommaList, a member of class ColumnCollection.

See Also
ColumnCollection Class
Eco.Persistence.ORMapping Namespace


this Indexer

this Indexer

This is the overview for the this indexer overload.

Overload List
Name | Description
ColumnCollection.this (int) | This is this, a member of class ColumnCollection.
ColumnCollection.this (string) | This is this, a member of class ColumnCollection.


ColumnCollection.this Indexer (int)

ColumnCollection.this Indexer (int)
ColumnCollection Class Eco.Persistence.ORMapping Namespace See Also
Collapse All
C#
public ColumnDefinition this[
    int index
];
Remarks

This is this, a member of class ColumnCollection.

See Also
ColumnCollection Class
Eco.Persistence.ORMapping Namespace


ColumnCollection.this Indexer (string)

ColumnCollection.this Indexer (string)
ColumnCollection Class Eco.Persistence.ORMapping Namespace See Also
Collapse All
C#
public ColumnDefinition this[
    string name
];
Remarks

This is this, a member of class ColumnCollection.

See Also
ColumnCollection Class
Eco.Persistence.ORMapping Namespace


ColumnDefinition Class

ColumnDefinition Class
Inheritance Hierarchy See Also
Collapse All
C#
public sealed class ColumnDefinition : NamedDefinition;
Remarks

This is class Eco.Persistence.ORMapping.ColumnDefinition.

Inheritance Hierarchy
Eco.Persistence.ORMapping.NamedDefinition
    Eco.Persistence.ORMapping.ColumnDefinition
File

ORMappingDefinition.cs

See Also
Inheritance Hierarchy


ColumnDefinition.ColumnDefinition Constructor

ColumnDefinition.ColumnDefinition Constructor
ColumnDefinition Class Eco.Persistence.ORMapping Namespace See Also
Collapse All
C#
public ColumnDefinition(
    TableDefinition table,
    string columnName
);
Exceptions
Exceptions | Description
ArgumentNullException | Thrown if table is null
See Also
ColumnDefinition Class
Eco.Persistence.ORMapping Namespace


ColumnDefinition Properties

ColumnDefinition Properties
Public Properties
Collapse All

The properties of the ColumnDefinition class are listed here.

Public Properties
Name | Description
AllowNull | This is AllowNull, a member of class ColumnDefinition.
DefaultValue | This is DefaultValue, a member of class ColumnDefinition.
Length | This is Length, a member of class ColumnDefinition.
ParamName | This is ParamName, a member of class ColumnDefinition.
SqlName | This is SqlName, a member of class ColumnDefinition.
SqlType | This is SqlType, a member of class ColumnDefinition.
Table | This is Table, a member of class ColumnDefinition.
TypeIsExplicit | This is TypeIsExplicit, a member of class ColumnDefinition.
UnquotedName | This is UnquotedName, a member of class ColumnDefinition.


ColumnDefinition.AllowNull Property

ColumnDefinition.AllowNull Property
ColumnDefinition Class Eco.Persistence.ORMapping Namespace See Also
Collapse All
C#
public bool AllowNull;
Remarks

This is AllowNull, a member of class ColumnDefinition.

See Also
ColumnDefinition Class
Eco.Persistence.ORMapping Namespace


ColumnDefinition.DefaultValue Property

ColumnDefinition.DefaultValue Property
ColumnDefinition Class Eco.Persistence.ORMapping Namespace See Also
Collapse All
C#
public string DefaultValue;
Remarks

This is DefaultValue, a member of class ColumnDefinition.

See Also
ColumnDefinition Class
Eco.Persistence.ORMapping Namespace


ColumnDefinition.Length Property

ColumnDefinition.Length Property
ColumnDefinition Class Eco.Persistence.ORMapping Namespace See Also
Collapse All
C#
public int Length;
Remarks

This is Length, a member of class ColumnDefinition.

See Also
ColumnDefinition Class
Eco.Persistence.ORMapping Namespace


ColumnDefinition.ParamName Property

ColumnDefinition.ParamName Property
ColumnDefinition Class Eco.Persistence.ORMapping Namespace See Also
Collapse All
C#
public string ParamName;
Remarks

This is ParamName, a member of class ColumnDefinition.

See Also
ColumnDefinition Class
Eco.Persistence.ORMapping Namespace


ColumnDefinition.SqlName Property

ColumnDefinition.SqlName Property
ColumnDefinition Class Eco.Persistence.ORMapping Namespace See Also
Collapse All
C#
public string SqlName;
Remarks

This is SqlName, a member of class ColumnDefinition.

See Also
ColumnDefinition Class
Eco.Persistence.ORMapping Namespace


ColumnDefinition.SqlType Property

ColumnDefinition.SqlType Property
ColumnDefinition Class Eco.Persistence.ORMapping Namespace See Also
Collapse All
C#
public string SqlType;
Remarks

This is SqlType, a member of class ColumnDefinition.

See Also
ColumnDefinition Class
Eco.Persistence.ORMapping Namespace


ColumnDefinition.Table Property

ColumnDefinition.Table Property
ColumnDefinition Class Eco.Persistence.ORMapping Namespace See Also
Collapse All
C#
public TableDefinition Table;
Remarks

This is Table, a member of class ColumnDefinition.

See Also
ColumnDefinition Class
Eco.Persistence.ORMapping Namespace


ColumnDefinition.TypeIsExplicit Property

ColumnDefinition.TypeIsExplicit Property
ColumnDefinition Class Eco.Persistence.ORMapping Namespace See Also
Collapse All
C#
public bool TypeIsExplicit;
Remarks

This is TypeIsExplicit, a member of class ColumnDefinition.

See Also
ColumnDefinition Class
Eco.Persistence.ORMapping Namespace


ColumnDefinition.UnquotedName Property

ColumnDefinition.UnquotedName Property
ColumnDefinition Class Eco.Persistence.ORMapping Namespace See Also
Collapse All
C#
public string UnquotedName;
Remarks

This is UnquotedName, a member of class ColumnDefinition.

See Also
ColumnDefinition Class
Eco.Persistence.ORMapping Namespace


ColumnReference Class

ColumnReference Class
Inheritance Hierarchy See Also
Collapse All
C#
public sealed class ColumnReference;
Remarks

This is class Eco.Persistence.ORMapping.ColumnReference.

Inheritance Hierarchy
Eco.Persistence.ORMapping.ColumnReference
File

ORMappingDefinition.cs

See Also
Inheritance Hierarchy


ColumnReference.ColumnReference Constructor

ColumnReference.ColumnReference Constructor
ColumnReference Class Eco.Persistence.ORMapping Namespace See Also
Collapse All
C#
public ColumnReference(
    AliasDefinition alias,
    ColumnDefinition column
);
Remarks

This is ColumnReference, a member of class ColumnReference.

See Also
ColumnReference Class
Eco.Persistence.ORMapping Namespace


ColumnReference Methods

ColumnReference Methods
Public Methods
Collapse All

The methods of the ColumnReference class are listed here.

Public Methods
Name | Description
AliasColumn | This is the overview for the AliasColumn method overload.


AliasColumn Method

AliasColumn Method

This is the overview for the AliasColumn method overload.

Overload List
Name | Description
ColumnReference.AliasColumn (SqlDatabaseConfig) | This is AliasColumn, a member of class ColumnReference.
ColumnReference.AliasColumn (SqlDatabaseConfig, string) | This is AliasColumn, a member of class ColumnReference.


ColumnReference.AliasColumn Method (SqlDatabaseConfig)

ColumnReference.AliasColumn Method (SqlDatabaseConfig)
ColumnReference Class Eco.Persistence.ORMapping Namespace See Also
Collapse All
C#
public string AliasColumn(
    SqlDatabaseConfig config
);
Remarks

This is AliasColumn, a member of class ColumnReference.

See Also
ColumnReference Class
Eco.Persistence.ORMapping Namespace


ColumnReference.AliasColumn Method (SqlDatabaseConfig, string)

ColumnReference.AliasColumn Method (SqlDatabaseConfig, string)
ColumnReference Class Eco.Persistence.ORMapping Namespace See Also
Collapse All
C#
public string AliasColumn(
    SqlDatabaseConfig config,
    string columnPrefix
);
Remarks

This is AliasColumn, a member of class ColumnReference.

See Also
ColumnReference Class
Eco.Persistence.ORMapping Namespace


ColumnReference Properties

ColumnReference Properties
Public Properties
Collapse All

The properties of the ColumnReference class are listed here.

Public Properties
Name | Description
Alias | This is Alias, a member of class ColumnReference.
Column | This is Column, a member of class ColumnReference.
IsReadonly | This is IsReadonly, a member of class ColumnReference.


ColumnReference.Alias Property

ColumnReference.Alias Property
ColumnReference Class Eco.Persistence.ORMapping Namespace See Also
Collapse All
C#
public AliasDefinition Alias;
Remarks

This is Alias, a member of class ColumnReference.

See Also
ColumnReference Class
Eco.Persistence.ORMapping Namespace


ColumnReference.Column Property

ColumnReference.Column Property
ColumnReference Class Eco.Persistence.ORMapping Namespace See Also
Collapse All
C#
public ColumnDefinition Column;
Remarks

This is Column, a member of class ColumnReference.

See Also
ColumnReference Class
Eco.Persistence.ORMapping Namespace


ColumnReference.IsReadonly Property

ColumnReference.IsReadonly Property
ColumnReference Class Eco.Persistence.ORMapping Namespace See Also
Collapse All
C#
public bool IsReadonly;
Remarks

This is IsReadonly, a member of class ColumnReference.

See Also
ColumnReference Class
Eco.Persistence.ORMapping Namespace


ColumnReferenceCollection Class

ColumnReferenceCollection Class
Inheritance Hierarchy See Also
Collapse All
C#
public sealed class ColumnReferenceCollection : Eco.Collections.CollectionBase;
Remarks

This is class Eco.Persistence.ORMapping.ColumnReferenceCollection.

Inheritance Hierarchy
Eco.Persistence.ORMapping.ColumnReferenceCollection
File

ORMappingDefinition.cs

See Also
Inheritance Hierarchy


ColumnReferenceCollection Methods

ColumnReferenceCollection Methods
Public Methods
Collapse All

The methods of the ColumnReferenceCollection class are listed here.

Public Methods
Name | Description
Add | This is Add, a member of class ColumnReferenceCollection.
AddRange | This is AddRange, a member of class ColumnReferenceCollection.
CreateStringCollection | This is CreateStringCollection, a member of class ColumnReferenceCollection.
this | This is this, a member of class ColumnReferenceCollection.


ColumnReferenceCollection.Add Method

ColumnReferenceCollection.Add Method
ColumnReferenceCollection Class Eco.Persistence.ORMapping Namespace See Also
Collapse All
C#
public int Add(
    ColumnReference value
);
Remarks

This is Add, a member of class ColumnReferenceCollection.

See Also
ColumnReferenceCollection Class
Eco.Persistence.ORMapping Namespace


ColumnReferenceCollection.AddRange Method

ColumnReferenceCollection.AddRange Method
ColumnReferenceCollection Class Eco.Persistence.ORMapping Namespace See Also
Collapse All
C#
public void AddRange(
    ColumnReferenceCollection range
);
Remarks

This is AddRange, a member of class ColumnReferenceCollection.

See Also
ColumnReferenceCollection Class
Eco.Persistence.ORMapping Namespace


ColumnReferenceCollection.CreateStringCollection Method

ColumnReferenceCollection.CreateStringCollection Method
ColumnReferenceCollection Class Eco.Persistence.ORMapping Namespace See Also
Collapse All
C#
public IList<string> CreateStringCollection(
    AliasMode mode,
    SqlDatabaseConfig config
);
Remarks

This is CreateStringCollection, a member of class ColumnReferenceCollection.

See Also
ColumnReferenceCollection Class
Eco.Persistence.ORMapping Namespace


ColumnReferenceCollection.this Indexer

ColumnReferenceCollection.this Indexer
ColumnReferenceCollection Class Eco.Persistence.ORMapping Namespace See Also
Collapse All
C#
public ColumnReference this[
    int index
];
Remarks

This is this, a member of class ColumnReferenceCollection.

See Also
ColumnReferenceCollection Class
Eco.Persistence.ORMapping Namespace


ColumnTypeFixer Class

ColumnTypeFixer Class
Inheritance Hierarchy See Also
Collapse All

Summary description for Class.

C#
public class ColumnTypeFixer;
Inheritance Hierarchy
Eco.Persistence.ORMapping.ColumnTypeFixer
File

ORMappingTypeFixer.cs

See Also
Inheritance Hierarchy


ColumnTypeFixer Methods

ColumnTypeFixer Methods
Public Methods
Collapse All

The methods of the ColumnTypeFixer class are listed here.

Public Methods
Name | Description
FixTypes | This is FixTypes, a member of class ColumnTypeFixer.


ColumnTypeFixer.FixTypes Method

ColumnTypeFixer.FixTypes Method
ColumnTypeFixer Class Eco.Persistence.ORMapping Namespace See Also
Collapse All
C#
public static void FixTypes(
    ORMappingDefinition mapping,
    SqlDatabaseConfig config,
    IEcoTypeSystem model
);
Remarks

This is FixTypes, a member of class ColumnTypeFixer.

See Also
ColumnTypeFixer Class
Eco.Persistence.ORMapping Namespace


Common Class

Common Class
Inheritance Hierarchy See Also
Collapse All
C#
public abstract class Common;
Remarks

This is class Eco.Persistence.ORMapping.Common.

Inheritance Hierarchy
Eco.Persistence.ORMapping.Common
File

ORMappingCommonDefs.cs

See Also
Inheritance Hierarchy


Common Fields

Common Fields
Public Fields
Collapse All

The fields of the Common class are listed here.

Public Fields
Name | Description
Primary | This is Primary, a member of class Common.
STARTTIMECOLUMNNAME | This is STARTTIMECOLUMNNAME, a member of class Common.
STOPTIMECOLUMNNAME | This is STOPTIMECOLUMNNAME, a member of class Common.
TV_NAME | This is TV_NAME, a member of class Common.
TV_PREFIX | This is TV_PREFIX, a member of class Common.


Common.Primary Field

Common.Primary Field
Common Class Eco.Persistence.ORMapping Namespace See Also
Collapse All
C#
public const string Primary = "<Primary>";
Remarks

This is Primary, a member of class Common.

See Also
Common Class
Eco.Persistence.ORMapping Namespace


Common.STARTTIMECOLUMNNAME Field

Common.STARTTIMECOLUMNNAME Field
Common Class Eco.Persistence.ORMapping Namespace See Also
Collapse All
C#
public const string STARTTIMECOLUMNNAME = "TIMESTAMPSTART";
Remarks

This is STARTTIMECOLUMNNAME, a member of class Common.

See Also
Common Class
Eco.Persistence.ORMapping Namespace


Common.STOPTIMECOLUMNNAME Field

Common.STOPTIMECOLUMNNAME Field
Common Class Eco.Persistence.ORMapping Namespace See Also
Collapse All
C#
public const string STOPTIMECOLUMNNAME = "TIMESTAMPSTOP";
Remarks

This is STOPTIMECOLUMNNAME, a member of class Common.

See Also
Common Class
Eco.Persistence.ORMapping Namespace


Common.TV_NAME Field

Common.TV_NAME Field
Common Class Eco.Persistence.ORMapping Namespace See Also
Collapse All
C#
public const string TV_NAME = "<Name>";
Remarks

This is TV_NAME, a member of class Common.

See Also
Common Class
Eco.Persistence.ORMapping Namespace


Common.TV_PREFIX Field

Common.TV_PREFIX Field
Common Class Eco.Persistence.ORMapping Namespace See Also
Collapse All
C#
public const string TV_PREFIX = "<Prefix>";
Remarks

This is TV_PREFIX, a member of class Common.

See Also
Common Class
Eco.Persistence.ORMapping Namespace


Common Methods

Common Methods
Public Methods
Collapse All

The methods of the Common class are listed here.

Public Methods
Name | Description
ExpandName |
GetSuperClass | This is GetSuperClass, a member of class Common.
MapCharacters | This is MapCharacters, a member of class Common.


Common.ExpandName Method

Common.ExpandName Method
Common Class Eco.Persistence.ORMapping Namespace See Also
Collapse All
C#
public static string ExpandName(
    string name,
    string defaultName,
    int maxLength,
    SqlDatabaseConfig config,
    string suffix
);
Exceptions
Exceptions | Description
ArgumentNullException | Thrown if config is null Thrown if name is null
See Also
Common Class
Eco.Persistence.ORMapping Namespace


Common.GetSuperClass Method

Common.GetSuperClass Method
Common Class Eco.Persistence.ORMapping Namespace See Also
Collapse All
C#
public static IClass GetSuperClass(
    IClass c
);
Remarks

This is GetSuperClass, a member of class Common.

See Also
Common Class
Eco.Persistence.ORMapping Namespace


Common.MapCharacters Method

Common.MapCharacters Method
Common Class Eco.Persistence.ORMapping Namespace See Also
Collapse All
C#
public static string MapCharacters(
    string s,
    IdentifierCharacterMode charMode
);
Remarks

This is MapCharacters, a member of class Common.

See Also
Common Class
Eco.Persistence.ORMapping Namespace


ConstantColumnCollection Class

ConstantColumnCollection Class
Inheritance Hierarchy See Also
Collapse All
C#
public sealed class ConstantColumnCollection : Eco.Collections.CollectionBase;
Remarks

This is class Eco.Persistence.ORMapping.ConstantColumnCollection.

Inheritance Hierarchy
Eco.Persistence.ORMapping.ConstantColumnCollection
File

ORMappingDefinition.cs

See Also
Inheritance Hierarchy


ConstantColumnCollection Methods

ConstantColumnCollection Methods
Public Methods
Collapse All

The methods of the ConstantColumnCollection class are listed here.

Public Methods
Name | Description
Add | This is Add, a member of class ConstantColumnCollection.
Insert | This is Insert, a member of class ConstantColumnCollection.
this | This is this, a member of class ConstantColumnCollection.


ConstantColumnCollection.Add Method

ConstantColumnCollection.Add Method
ConstantColumnCollection Class Eco.Persistence.ORMapping Namespace See Also
Collapse All
C#
public int Add(
    ConstantColumnDefinition value
);
Remarks

This is Add, a member of class ConstantColumnCollection.

See Also
ConstantColumnCollection Class
Eco.Persistence.ORMapping Namespace


ConstantColumnCollection.Insert Method

ConstantColumnCollection.Insert Method
ConstantColumnCollection Class Eco.Persistence.ORMapping Namespace See Also
Collapse All
C#
public void Insert(
    int index,
    ConstantColumnDefinition value
);
Remarks

This is Insert, a member of class ConstantColumnCollection.

See Also
ConstantColumnCollection Class
Eco.Persistence.ORMapping Namespace


ConstantColumnCollection.this Indexer

ConstantColumnCollection.this Indexer
ConstantColumnCollection Class Eco.Persistence.ORMapping Namespace See Also
Collapse All
C#
public ConstantColumnDefinition this[
    int index
];
Remarks

This is this, a member of class ConstantColumnCollection.

See Also
ConstantColumnCollection Class
Eco.Persistence.ORMapping Namespace


ConstantColumnDefinition Class

ConstantColumnDefinition Class
Inheritance Hierarchy See Also
Collapse All
C#
public sealed class ConstantColumnDefinition;
Remarks

This is class Eco.Persistence.ORMapping.ConstantColumnDefinition.

Inheritance Hierarchy
Eco.Persistence.ORMapping.ConstantColumnDefinition
File

ORMappingDefinition.cs

See Also
Inheritance Hierarchy


ConstantColumnDefinition Properties

ConstantColumnDefinition Properties
Public Properties
Collapse All

The properties of the ConstantColumnDefinition class are listed here.

Public Properties
Name | Description
ColumnRef | This is ColumnRef, a member of class ConstantColumnDefinition.
Mapper | This is Mapper, a member of class ConstantColumnDefinition.
Signature | This is Signature, a member of class ConstantColumnDefinition.
Value | This is Value, a member of class ConstantColumnDefinition.


ConstantColumnDefinition.ColumnRef Property

ConstantColumnDefinition.ColumnRef Property
ConstantColumnDefinition Class Eco.Persistence.ORMapping Namespace See Also
Collapse All
C#
public ColumnReference ColumnRef;
Remarks

This is ColumnRef, a member of class ConstantColumnDefinition.

See Also
ConstantColumnDefinition Class
Eco.Persistence.ORMapping Namespace


ConstantColumnDefinition.Mapper Property

ConstantColumnDefinition.Mapper Property
ConstantColumnDefinition Class Eco.Persistence.ORMapping Namespace See Also
Collapse All
C#
public ISingleColumnAttributemapping Mapper;
Remarks

This is Mapper, a member of class ConstantColumnDefinition.

See Also
ConstantColumnDefinition Class
Eco.Persistence.ORMapping Namespace


ConstantColumnDefinition.Signature Property

ConstantColumnDefinition.Signature Property
ConstantColumnDefinition Class Eco.Persistence.ORMapping Namespace See Also
Collapse All
C#
public string Signature;
Remarks

This is Signature, a member of class ConstantColumnDefinition.

See Also
ConstantColumnDefinition Class
Eco.Persistence.ORMapping Namespace


ConstantColumnDefinition.Value Property

ConstantColumnDefinition.Value Property
ConstantColumnDefinition Class Eco.Persistence.ORMapping Namespace See Also
Collapse All
C#
public string Value;
Remarks

This is Value, a member of class ConstantColumnDefinition.

See Also
ConstantColumnDefinition Class
Eco.Persistence.ORMapping Namespace


DatabaseCollection Class

DatabaseCollection Class
Inheritance Hierarchy See Also
Collapse All
C#
public sealed class DatabaseCollection : Eco.Collections.HashBase;
Remarks

This is class Eco.Persistence.ORMapping.DatabaseCollection.

Inheritance Hierarchy
Eco.Persistence.ORMapping.DatabaseCollection
File

ORMappingDefinition.cs

See Also
Inheritance Hierarchy


DatabaseCollection Methods

DatabaseCollection Methods
Public Methods
Collapse All

The methods of the DatabaseCollection class are listed here.

Public Methods
Name | Description
Add | This is Add, a member of class DatabaseCollection.
this | This is this, a member of class DatabaseCollection.


DatabaseCollection.Add Method

DatabaseCollection.Add Method
DatabaseCollection Class Eco.Persistence.ORMapping Namespace See Also
Collapse All
C#
public void Add(
    DatabaseDefinition value
);
Remarks

This is Add, a member of class DatabaseCollection.

See Also
DatabaseCollection Class
Eco.Persistence.ORMapping Namespace


DatabaseCollection.this Indexer

DatabaseCollection.this Indexer
DatabaseCollection Class Eco.Persistence.ORMapping Namespace See Also
Collapse All
C#
public DatabaseDefinition this[
    string name
];
Remarks

This is this, a member of class DatabaseCollection.

See Also
DatabaseCollection Class
Eco.Persistence.ORMapping Namespace


DatabaseCollection Properties

DatabaseCollection Properties
Public Properties
Collapse All

The properties of the DatabaseCollection class are listed here.

Public Properties
Name | Description
Any | This is Any, a member of class DatabaseCollection.


DatabaseCollection.Any Property

DatabaseCollection.Any Property
DatabaseCollection Class Eco.Persistence.ORMapping Namespace See Also
Collapse All
C#
public DatabaseDefinition Any;
Remarks

This is Any, a member of class DatabaseCollection.

See Also
DatabaseCollection Class
Eco.Persistence.ORMapping Namespace


DatabaseDefinition Class

DatabaseDefinition Class
Inheritance Hierarchy See Also
Collapse All
C#
public sealed class DatabaseDefinition : NamedDefinition, IDatabaseDefinition;
Remarks

This is class Eco.Persistence.ORMapping.DatabaseDefinition.

Inheritance Hierarchy
Eco.Persistence.ORMapping.NamedDefinition
    Eco.Persistence.ORMapping.DatabaseDefinition
File

ORMappingDefinition.cs

See Also
Inheritance Hierarchy


DatabaseDefinition.DatabaseDefinition Constructor

DatabaseDefinition.DatabaseDefinition Constructor
DatabaseDefinition Class Eco.Persistence.ORMapping Namespace See Also
Collapse All
C#
public DatabaseDefinition(
    ORMappingDefinition mapping,
    string name
);
Exceptions
Exceptions | Description
ArgumentNullException | Thrown if mapping is null
See Also
DatabaseDefinition Class
Eco.Persistence.ORMapping Namespace


DatabaseDefinition Methods

DatabaseDefinition Methods
Public Methods
Collapse All

The methods of the DatabaseDefinition class are listed here.

Public Methods
Name | Description
EnsureTable | This is EnsureTable, a member of class DatabaseDefinition.
GetTable | This is GetTable, a member of class DatabaseDefinition.


DatabaseDefinition.EnsureTable Method

DatabaseDefinition.EnsureTable Method
DatabaseDefinition Class Eco.Persistence.ORMapping Namespace See Also
Collapse All
C#
public TableDefinition EnsureTable(
    string tableName
);
Remarks

This is EnsureTable, a member of class DatabaseDefinition.

See Also
DatabaseDefinition Class
Eco.Persistence.ORMapping Namespace


DatabaseDefinition.GetTable Method

DatabaseDefinition.GetTable Method
DatabaseDefinition Class Eco.Persistence.ORMapping Namespace See Also
Collapse All
C#
public TableDefinition GetTable(
    string tableName
);
Remarks

This is GetTable, a member of class DatabaseDefinition.

See Also
DatabaseDefinition Class
Eco.Persistence.ORMapping Namespace


DatabaseDefinition Properties

DatabaseDefinition Properties
Public Properties
Collapse All

The properties of the DatabaseDefinition class are listed here.

Public Properties
Name | Description
AllowImplicitDefinitions | This is AllowImplicitDefinitions, a member of class DatabaseDefinition.
Mapping | This is Mapping, a member of class DatabaseDefinition.
Tables | This is Tables, a member of class DatabaseDefinition.


DatabaseDefinition.AllowImplicitDefinitions Property

DatabaseDefinition.AllowImplicitDefinitions Property
DatabaseDefinition Class Eco.Persistence.ORMapping Namespace See Also
Collapse All
C#
public bool AllowImplicitDefinitions;
Remarks

This is AllowImplicitDefinitions, a member of class DatabaseDefinition.

See Also
DatabaseDefinition Class
Eco.Persistence.ORMapping Namespace


DatabaseDefinition.Mapping Property

DatabaseDefinition.Mapping Property
DatabaseDefinition Class Eco.Persistence.ORMapping Namespace See Also
Collapse All
C#
public ORMappingDefinition Mapping;
Remarks

This is Mapping, a member of class DatabaseDefinition.

See Also
DatabaseDefinition Class
Eco.Persistence.ORMapping Namespace


DatabaseDefinition.Tables Property

DatabaseDefinition.Tables Property
DatabaseDefinition Class Eco.Persistence.ORMapping Namespace See Also
Collapse All
C#
public TableCollection Tables;
Remarks

This is Tables, a member of class DatabaseDefinition.

See Also
DatabaseDefinition Class
Eco.Persistence.ORMapping Namespace


DbMappingProvider Class

DbMappingProvider Class
Inheritance Hierarchy See Also
Collapse All
C#
public sealed class DbMappingProvider : System.ComponentModel.Component, IORMappingProvider;
Remarks

Designer("Eco.Persistence.Design.DbMappingProvider, Eco.Handles.Design" + VersionInfo.AssemblySuffix, typeof(IDesigner))

Inheritance Hierarchy
Eco.Persistence.ORMapping.IORMappingProvider
    Eco.Persistence.ORMapping.DbMappingProvider
File

DbMappingProvider.cs

See Also
Inheritance Hierarchy


DbMappingProvider Methods

DbMappingProvider Methods
Public Methods
Collapse All

The methods of the DbMappingProvider class are listed here.

Public Methods
Name | Description
Initialize | Initialize reads the OR mapping information from <MappingTableName>.<ColumnName> (default is ECO_ORMAPPING.ECO_ORMAPPING)
PostCreateDb | Required to fulfill interface IORMappingProvider. This implementation does nothing.
PostEvolveDb | Required to fulfill interface IORMappingProvider. This implementation does nothing.
PostEvolveDbScript | Required to fulfill interface IORMappingProvider. This implementation does nothing.
SaveMappingInfo | Saves mapping info into the table <MappingTableName>.<ColumnName> (default is ECO_ORMAPPING.ECO_ORMAPPING).
SystemTableNames | This is SystemTableNames, a member of class DbMappingProvider.


DbMappingProvider.Initialize Method

DbMappingProvider.Initialize Method
DbMappingProvider Class Eco.Persistence.ORMapping Namespace See Also
Collapse All

Initialize reads the OR mapping information from <MappingTableName>.<ColumnName> (default is ECO_ORMAPPING.ECO_ORMAPPING)

C#
public void Initialize(
    IEcoTypeSystem typeSystem,
    IDatabase db,
    SqlDatabaseConfig config,
    bool addMissingTypes
);
Exceptions
Exceptions | Description
 | Exception thrown if there is no mapper for System.Byte[] and System.String.
 | ArgumentException thrown if db is not connected.
See Also
DbMappingProvider Class
Eco.Persistence.ORMapping Namespace


DbMappingProvider.PostCreateDb Method

DbMappingProvider.PostCreateDb Method
DbMappingProvider Class Eco.Persistence.ORMapping Namespace See Also
Collapse All

Required to fulfill interface IORMappingProvider. This implementation does nothing.

C#
public void PostCreateDb(
    IDatabase db,
    SqlDatabaseConfig sqlDatabaseConfig,
    ORMappingDefinition newMapping
);
See Also
DbMappingProvider Class
Eco.Persistence.ORMapping Namespace


DbMappingProvider.PostEvolveDb Method

DbMappingProvider.PostEvolveDb Method
DbMappingProvider Class Eco.Persistence.ORMapping Namespace See Also
Collapse All

Required to fulfill interface IORMappingProvider. This implementation does nothing.

C#
public void PostEvolveDb(
    IDatabase db,
    SqlDatabaseConfig sqlDatabaseConfig,
    ORMappingDefinition newMapping
);
See Also
DbMappingProvider Class
Eco.Persistence.ORMapping Namespace


DbMappingProvider.PostEvolveDbScript Method

DbMappingProvider.PostEvolveDbScript Method
DbMappingProvider Class Eco.Persistence.ORMapping Namespace See Also
Collapse All

Required to fulfill interface IORMappingProvider. This implementation does nothing.

C#
public void PostEvolveDbScript(
    IDatabase db,
    SqlDatabaseConfig sqlDatabaseConfig,
    ORMappingDefinition newMapping,
    IList<string> script
);
See Also
DbMappingProvider Class
Eco.Persistence.ORMapping Namespace


DbMappingProvider.SaveMappingInfo Method

DbMappingProvider.SaveMappingInfo Method
DbMappingProvider Class Eco.Persistence.ORMapping Namespace See Also
Collapse All

Saves mapping info into the table <MappingTableName>.<ColumnName> (default is ECO_ORMAPPING.ECO_ORMAPPING).

C#
public void SaveMappingInfo(
    IDatabase db,
    SqlDatabaseConfig sqlDatabaseConfig,
    ORMappingDefinition newMapping
);
Exceptions
Exceptions | Description
 | ArgumentException if thrown if the db is not connected.
 | Exception thrown if there is no mapper for System.Byte[] and System.String.
ArgumentNullException | Thrown if db is null
ArgumentException | Thrown if db is not connected.
See Also
DbMappingProvider Class
Eco.Persistence.ORMapping Namespace


DbMappingProvider.SystemTableNames Method

DbMappingProvider.SystemTableNames Method
DbMappingProvider Class Eco.Persistence.ORMapping Namespace See Also
Collapse All
C#
public IList<string> SystemTableNames(
    SqlDatabaseConfig config
);
Remarks

This is SystemTableNames, a member of class DbMappingProvider.

See Also
DbMappingProvider Class
Eco.Persistence.ORMapping Namespace


DbMappingProvider Properties

DbMappingProvider Properties
Public Properties
Collapse All

The properties of the DbMappingProvider class are listed here.

Public Properties
Name | Description
ColumnName | This is ColumnName, a member of class DbMappingProvider.
EffectiveMappingTableName | This is EffectiveMappingTableName, a member of class DbMappingProvider.
Mapping | Mapping contains the ORMappingDefinition.
MappingTableName | This is MappingTableName, a member of class DbMappingProvider.
TableName | do not localize


DbMappingProvider.ColumnName Property

DbMappingProvider.ColumnName Property
DbMappingProvider Class Eco.Persistence.ORMapping Namespace See Also
Collapse All
C#
public string ColumnName;
Remarks

This is ColumnName, a member of class DbMappingProvider.

See Also
DbMappingProvider Class
Eco.Persistence.ORMapping Namespace


DbMappingProvider.EffectiveMappingTableName Property

DbMappingProvider.EffectiveMappingTableName Property
DbMappingProvider Class Eco.Persistence.ORMapping Namespace See Also
Collapse All
C#
public string EffectiveMappingTableName;
Remarks

This is EffectiveMappingTableName, a member of class DbMappingProvider.

See Also
DbMappingProvider Class
Eco.Persistence.ORMapping Namespace


DbMappingProvider.Mapping Property

DbMappingProvider.Mapping Property
DbMappingProvider Class Eco.Persistence.ORMapping Namespace See Also
Collapse All

Mapping contains the ORMappingDefinition.

C#
public ORMappingDefinition Mapping;
Remarks

Note that the Mapping must be initialized (Initialize) prior to retrieving it. Normal framework operations ensure things happen in the correct order. This data is not primarily intended for inspection by programmers.

See Also
DbMappingProvider Class
Eco.Persistence.ORMapping Namespace


DbMappingProvider.MappingTableName Property

DbMappingProvider.MappingTableName Property
DbMappingProvider Class Eco.Persistence.ORMapping Namespace See Also
Collapse All
C#
public string MappingTableName;
Remarks

This is MappingTableName, a member of class DbMappingProvider.

See Also
DbMappingProvider Class
Eco.Persistence.ORMapping Namespace


DbMappingProvider.TableName Property

DbMappingProvider.TableName Property
DbMappingProvider Class Eco.Persistence.ORMapping Namespace See Also
Collapse All
C#
public string TableName;
Remarks

do not localize

See Also
DbMappingProvider Class
Eco.Persistence.ORMapping Namespace


DbMetaSupport Class

DbMetaSupport Class
Inheritance Hierarchy See Also
Collapse All
C#
public sealed class DbMetaSupport;
Remarks

This is class Eco.Persistence.ORMapping.DbMetaSupport.

Inheritance Hierarchy
Eco.Persistence.ORMapping.DbMetaSupport
File

DbMetaSupport.cs

See Also
Inheritance Hierarchy


DbMetaSupport Methods

DbMetaSupport Methods
Public Methods
Collapse All

The methods of the DbMetaSupport class are listed here.

Public Methods
Name | Description
SqlForColumn |
SqlForCreateTable |
SqlForPrimaryKey |
SqlForSecondaryIndex |


DbMetaSupport.SqlForColumn Method

DbMetaSupport.SqlForColumn Method
DbMetaSupport Class Eco.Persistence.ORMapping Namespace See Also
Collapse All
C#
public static string SqlForColumn(
    ColumnDefinition col,
    SqlDatabaseConfig config
);
Exceptions
Exceptions | Description
ArgumentNullException | Thrown if col is null Thrown if config is null
See Also
DbMetaSupport Class
Eco.Persistence.ORMapping Namespace


DbMetaSupport.SqlForCreateTable Method

DbMetaSupport.SqlForCreateTable Method
DbMetaSupport Class Eco.Persistence.ORMapping Namespace See Also
Collapse All
C#
public static string SqlForCreateTable(
    TableDefinition table,
    SqlDatabaseConfig config
);
Exceptions
Exceptions | Description
ArgumentNullException | Thrown if table is null Thrown if config is null
See Also
DbMetaSupport Class
Eco.Persistence.ORMapping Namespace


DbMetaSupport.SqlForPrimaryKey Method

DbMetaSupport.SqlForPrimaryKey Method
DbMetaSupport Class Eco.Persistence.ORMapping Namespace See Also
Collapse All
C#
public static string SqlForPrimaryKey(
    IndexDefinition index,
    SqlDatabaseConfig config
);
Exceptions
Exceptions | Description
ArgumentNullException | Thrown if index is null
See Also
DbMetaSupport Class
Eco.Persistence.ORMapping Namespace


DbMetaSupport.SqlForSecondaryIndex Method

DbMetaSupport.SqlForSecondaryIndex Method
DbMetaSupport Class Eco.Persistence.ORMapping Namespace See Also
Collapse All
C#
public static string SqlForSecondaryIndex(
    IndexDefinition index,
    SqlDatabaseConfig config
);
Exceptions
Exceptions | Description
ArgumentNullException | Thrown if index is null
See Also
DbMetaSupport Class
Eco.Persistence.ORMapping Namespace


DefaultORMappingBuilder Class

DefaultORMappingBuilder Class
Inheritance Hierarchy See Also
Collapse All

This class builds an O/R mapping information structure based on an eco model.

C#
public class DefaultORMappingBuilder : System.ComponentModel.Component, IORMappingProvider;
Inheritance Hierarchy
Eco.Persistence.ORMapping.IORMappingProvider
    Eco.Persistence.ORMapping.DefaultORMappingBuilder
File

DefaultORMappingBuilder.cs

See Also
Inheritance Hierarchy


DefaultORMappingBuilder.DefaultORMappingBuilder Constructor

DefaultORMappingBuilder.DefaultORMappingBuilder Constructor
DefaultORMappingBuilder Class Eco.Persistence.ORMapping Namespace See Also
Collapse All
C#
public DefaultORMappingBuilder();
Remarks

This is DefaultORMappingBuilder, a member of class DefaultORMappingBuilder.

See Also
DefaultORMappingBuilder Class
Eco.Persistence.ORMapping Namespace


DefaultORMappingBuilder Methods

DefaultORMappingBuilder Methods
Protected Methods Public Methods
Collapse All

The methods of the DefaultORMappingBuilder class are listed here.

Protected Methods
Name | Description
ExpandName | This is ExpandName, a member of class DefaultORMappingBuilder.
Top
Public Methods
Name | Description
Initialize |
MyInterfaceFilter | This is MyInterfaceFilter, a member of class DefaultORMappingBuilder.
PostCreateDb |
PostEvolveDb |
PostEvolveDbScript | This is PostEvolveDbScript, a member of class DefaultORMappingBuilder.
SaveMappingInfo | This is SaveMappingInfo, a member of class DefaultORMappingBuilder.
SetAutoIncIdDefaults | This is SetAutoIncIdDefaults, a member of class DefaultORMappingBuilder.
SetEcoCompatibilityMode | This is SetEcoCompatibilityMode, a member of class DefaultORMappingBuilder.
SetEcoIDefaults | This is SetEcoIDefaults, a member of class DefaultORMappingBuilder.
SetEcoIIDefaults | This is SetEcoIIDefaults, a member of class DefaultORMappingBuilder.
SetEcoIIIDefaults | This is SetEcoIIIDefaults, a member of class DefaultORMappingBuilder.
SetGuidIdDefaults | This is SetGuidIdDefaults, a member of class DefaultORMappingBuilder.
SetInt32IdDefaults | This is SetInt32IdDefaults, a member of class DefaultORMappingBuilder.
SetInt64IdDefaults | This is SetInt64IdDefaults, a member of class DefaultORMappingBuilder.
SystemTableNames | This is SystemTableNames, a member of class DefaultORMappingBuilder.


DefaultORMappingBuilder.ExpandName Method

DefaultORMappingBuilder.ExpandName Method
DefaultORMappingBuilder Class Eco.Persistence.ORMapping Namespace See Also
Collapse All
C#
protected virtual string ExpandName(
    string name,
    string defaultName,
    int maxLength,
    SqlDatabaseConfig config,
    string suffix
);
Remarks

This is ExpandName, a member of class DefaultORMappingBuilder.

See Also
DefaultORMappingBuilder Class
Eco.Persistence.ORMapping Namespace


DefaultORMappingBuilder.Initialize Method

DefaultORMappingBuilder.Initialize Method
DefaultORMappingBuilder Class Eco.Persistence.ORMapping Namespace See Also
Collapse All
C#
public void Initialize(
    IEcoTypeSystem typeSystem,
    IDatabase db,
    SqlDatabaseConfig config,
    bool addMissingTypes
);
Exceptions
Exceptions | Description
ArgumentNullException | Thrown if config is null
ArgumentException | Thrown if db is not connected.
See Also
DefaultORMappingBuilder Class
Eco.Persistence.ORMapping Namespace


DefaultORMappingBuilder.MyInterfaceFilter Method

DefaultORMappingBuilder.MyInterfaceFilter Method
DefaultORMappingBuilder Class Eco.Persistence.ORMapping Namespace See Also
Collapse All
C#
public static bool MyInterfaceFilter(
    Type typeObj,
    Object criteriaObj
);
Remarks

This is MyInterfaceFilter, a member of class DefaultORMappingBuilder.

See Also
DefaultORMappingBuilder Class
Eco.Persistence.ORMapping Namespace


DefaultORMappingBuilder.PostCreateDb Method

DefaultORMappingBuilder.PostCreateDb Method
DefaultORMappingBuilder Class Eco.Persistence.ORMapping Namespace See Also
Collapse All
C#
public void PostCreateDb(
    IDatabase db,
    SqlDatabaseConfig sqlDatabaseConfig,
    ORMappingDefinition newMapping
);
Exceptions
Exceptions | Description
ArgumentNullException | Thrown if db is null. Thrown if sqlDatabaseConfig is null.
ArgumentException | Thrown if db is not connected.
See Also
DefaultORMappingBuilder Class
Eco.Persistence.ORMapping Namespace


DefaultORMappingBuilder.PostEvolveDb Method

DefaultORMappingBuilder.PostEvolveDb Method
DefaultORMappingBuilder Class Eco.Persistence.ORMapping Namespace See Also
Collapse All
C#
public void PostEvolveDb(
    IDatabase db,
    SqlDatabaseConfig sqlDatabaseConfig,
    ORMappingDefinition newMapping
);
Exceptions
Exceptions | Description
ArgumentNullException | Thrown if db is null
See Also
DefaultORMappingBuilder Class
Eco.Persistence.ORMapping Namespace


DefaultORMappingBuilder.PostEvolveDbScript Method

DefaultORMappingBuilder.PostEvolveDbScript Method
DefaultORMappingBuilder Class Eco.Persistence.ORMapping Namespace See Also
Collapse All
C#
public void PostEvolveDbScript(
    IDatabase db,
    SqlDatabaseConfig sqlDatabaseConfig,
    ORMappingDefinition newMapping,
    IList<string> script
);
Remarks

This is PostEvolveDbScript, a member of class DefaultORMappingBuilder.

See Also
DefaultORMappingBuilder Class
Eco.Persistence.ORMapping Namespace


DefaultORMappingBuilder.SaveMappingInfo Method

DefaultORMappingBuilder.SaveMappingInfo Method
DefaultORMappingBuilder Class Eco.Persistence.ORMapping Namespace See Also
Collapse All
C#
public void SaveMappingInfo(
    IDatabase db,
    SqlDatabaseConfig sqlDatabaseConfig,
    ORMappingDefinition newMapping
);
Remarks

This is SaveMappingInfo, a member of class DefaultORMappingBuilder.

See Also
DefaultORMappingBuilder Class
Eco.Persistence.ORMapping Namespace


DefaultORMappingBuilder.SetAutoIncIdDefaults Method

DefaultORMappingBuilder.SetAutoIncIdDefaults Method
DefaultORMappingBuilder Class Eco.Persistence.ORMapping Namespace See Also
Collapse All
C#
public void SetAutoIncIdDefaults();
Remarks

This is SetAutoIncIdDefaults, a member of class DefaultORMappingBuilder.

See Also
DefaultORMappingBuilder Class
Eco.Persistence.ORMapping Namespace


DefaultORMappingBuilder.SetEcoCompatibilityMode Method

DefaultORMappingBuilder.SetEcoCompatibilityMode Method
DefaultORMappingBuilder Class Eco.Persistence.ORMapping Namespace See Also
Collapse All
C#
public void SetEcoCompatibilityMode(
    EcoCompatibilityMode mode
);
Remarks

This is SetEcoCompatibilityMode, a member of class DefaultORMappingBuilder.

See Also
DefaultORMappingBuilder Class
Eco.Persistence.ORMapping Namespace


DefaultORMappingBuilder.SetEcoIDefaults Method

DefaultORMappingBuilder.SetEcoIDefaults Method
DefaultORMappingBuilder Class Eco.Persistence.ORMapping Namespace See Also
Collapse All
C#
public void SetEcoIDefaults();
Remarks

This is SetEcoIDefaults, a member of class DefaultORMappingBuilder.

See Also
DefaultORMappingBuilder Class
Eco.Persistence.ORMapping Namespace


DefaultORMappingBuilder.SetEcoIIDefaults Method

DefaultORMappingBuilder.SetEcoIIDefaults Method
DefaultORMappingBuilder Class Eco.Persistence.ORMapping Namespace See Also
Collapse All
C#
public void SetEcoIIDefaults();
Remarks

This is SetEcoIIDefaults, a member of class DefaultORMappingBuilder.

See Also
DefaultORMappingBuilder Class
Eco.Persistence.ORMapping Namespace


DefaultORMappingBuilder.SetEcoIIIDefaults Method

DefaultORMappingBuilder.SetEcoIIIDefaults Method
DefaultORMappingBuilder Class Eco.Persistence.ORMapping Namespace See Also
Collapse All
C#
public void SetEcoIIIDefaults();
Remarks

This is SetEcoIIIDefaults, a member of class DefaultORMappingBuilder.

See Also
DefaultORMappingBuilder Class
Eco.Persistence.ORMapping Namespace


DefaultORMappingBuilder.SetGuidIdDefaults Method

DefaultORMappingBuilder.SetGuidIdDefaults Method
DefaultORMappingBuilder Class Eco.Persistence.ORMapping Namespace See Also
Collapse All
C#
public void SetGuidIdDefaults();
Remarks

This is SetGuidIdDefaults, a member of class DefaultORMappingBuilder.

See Also
DefaultORMappingBuilder Class
Eco.Persistence.ORMapping Namespace


DefaultORMappingBuilder.SetInt32IdDefaults Method

DefaultORMappingBuilder.SetInt32IdDefaults Method
DefaultORMappingBuilder Class Eco.Persistence.ORMapping Namespace See Also
Collapse All
C#
public void SetInt32IdDefaults();
Remarks

This is SetInt32IdDefaults, a member of class DefaultORMappingBuilder.

See Also
DefaultORMappingBuilder Class
Eco.Persistence.ORMapping Namespace


DefaultORMappingBuilder.SetInt64IdDefaults Method

DefaultORMappingBuilder.SetInt64IdDefaults Method
DefaultORMappingBuilder Class Eco.Persistence.ORMapping Namespace See Also
Collapse All
C#
public void SetInt64IdDefaults();
Remarks

This is SetInt64IdDefaults, a member of class DefaultORMappingBuilder.

See Also
DefaultORMappingBuilder Class
Eco.Persistence.ORMapping Namespace


DefaultORMappingBuilder.SystemTableNames Method

DefaultORMappingBuilder.SystemTableNames Method
DefaultORMappingBuilder Class Eco.Persistence.ORMapping Namespace See Also
Collapse All
C#
public IList<string> SystemTableNames(
    SqlDatabaseConfig config
);
Remarks

This is SystemTableNames, a member of class DefaultORMappingBuilder.

See Also
DefaultORMappingBuilder Class
Eco.Persistence.ORMapping Namespace


DefaultORMappingBuilder Properties

DefaultORMappingBuilder Properties
Public Properties
Collapse All

The properties of the DefaultORMappingBuilder class are listed here.

Public Properties
Name | Description
AssignDefaultTypeConditions | This is AssignDefaultTypeConditions, a member of class DefaultORMappingBuilder.
ChildMapRootClass | The root class normally does not contain any data, and does not really need a table of its own. Childmapping the root class means that it will not get a table of its own. The root class table can be used to determine the type of an arbitrary id. if it does not exist, this operation must be performed in the tables of the childclasses instead
ClassNameColumnName | This is ClassNameColumnName, a member of class DefaultORMappingBuilder.
ClassNameMapper | This is ClassNameMapper, a member of class DefaultORMappingBuilder.
ClassNameSignature | This is ClassNameSignature, a member of class DefaultORMappingBuilder.
Config | This is Config, a member of class DefaultORMappingBuilder.
Database | Only classes where the tagged value Eco.Database has this value will be included int he mapping
DefaultSingleLinkColumnName | This is DefaultSingleLinkColumnName, a member of class DefaultORMappingBuilder.
DiscriminatorMapper | This is DiscriminatorMapper, a member of class DefaultORMappingBuilder.
IdColumnName | This is IdColumnName, a member of class DefaultORMappingBuilder.
IdIsAutoInc | This property must be true to use AutoInc keys
IdKeyMapper | This is IdKeyMapper, a member of class DefaultORMappingBuilder.
IdKeyName | This is IdKeyName, a member of class DefaultORMappingBuilder.
IdKeySignature | This is IdKeySignature, a member of class DefaultORMappingBuilder.
IdMapperName | This is the name of the KeyMapper used to store the primary key
Int32Mapper | This is Int32Mapper, a member of class DefaultORMappingBuilder.
MapperDictionary | This is MapperDictionary, a member of class DefaultORMappingBuilder.
Mapping | This is Mapping, a member of class DefaultORMappingBuilder.
ReservedWordColumnSuffix | This is ReservedWordColumnSuffix, a member of class DefaultORMappingBuilder.
ReservedWordTableSuffix | This is ReservedWordTableSuffix, a member of class DefaultORMappingBuilder.
RootClass | This is RootClass, a member of class DefaultORMappingBuilder.
RootTableName | This is RootTableName, a member of class DefaultORMappingBuilder.
TablesColumnName | This is TablesColumnName, a member of class DefaultORMappingBuilder.
TablesTableName | This is TablesTableName, a member of class DefaultORMappingBuilder.
TypeColumnName | This is TypeColumnName, a member of class DefaultORMappingBuilder.
TypeDiscriminatorName | This is TypeDiscriminatorName, a member of class DefaultORMappingBuilder.
TypeDiscriminatorSignature | This is TypeDiscriminatorSignature, a member of class DefaultORMappingBuilder.
TypeTableName | This is TypeTableName, a member of class DefaultORMappingBuilder.


DefaultORMappingBuilder.AssignDefaultTypeConditions Property

DefaultORMappingBuilder.AssignDefaultTypeConditions Property
DefaultORMappingBuilder Class Eco.Persistence.ORMapping Namespace See Also
Collapse All
C#
public bool AssignDefaultTypeConditions;
Remarks

This is AssignDefaultTypeConditions, a member of class DefaultORMappingBuilder.

See Also
DefaultORMappingBuilder Class
Eco.Persistence.ORMapping Namespace


DefaultORMappingBuilder.ChildMapRootClass Property

DefaultORMappingBuilder.ChildMapRootClass Property
DefaultORMappingBuilder Class Eco.Persistence.ORMapping Namespace See Also
Collapse All

The root class normally does not contain any data, and does not really need a table of its own. Childmapping the root class means that it will not get a table of its own. The root class table can be used to determine the type of an arbitrary id. if it does not exist, this operation must be performed in the tables of the childclasses instead

C#
public bool ChildMapRootClass;
See Also
DefaultORMappingBuilder Class
Eco.Persistence.ORMapping Namespace


DefaultORMappingBuilder.ClassNameColumnName Property

DefaultORMappingBuilder.ClassNameColumnName Property
DefaultORMappingBuilder Class Eco.Persistence.ORMapping Namespace See Also
Collapse All
C#
public string ClassNameColumnName;
Remarks

This is ClassNameColumnName, a member of class DefaultORMappingBuilder.

See Also
DefaultORMappingBuilder Class
Eco.Persistence.ORMapping Namespace


DefaultORMappingBuilder.ClassNameMapper Property

DefaultORMappingBuilder.ClassNameMapper Property
DefaultORMappingBuilder Class Eco.Persistence.ORMapping Namespace See Also
Collapse All
C#
public ISingleColumnAttributemapping ClassNameMapper;
Remarks

This is ClassNameMapper, a member of class DefaultORMappingBuilder.

See Also
DefaultORMappingBuilder Class
Eco.Persistence.ORMapping Namespace


DefaultORMappingBuilder.ClassNameSignature Property

DefaultORMappingBuilder.ClassNameSignature Property
DefaultORMappingBuilder Class Eco.Persistence.ORMapping Namespace See Also
Collapse All
C#
public string ClassNameSignature;
Remarks

This is ClassNameSignature, a member of class DefaultORMappingBuilder.

See Also
DefaultORMappingBuilder Class
Eco.Persistence.ORMapping Namespace


DefaultORMappingBuilder.Config Property

DefaultORMappingBuilder.Config Property
DefaultORMappingBuilder Class Eco.Persistence.ORMapping Namespace See Also
Collapse All
C#
public SqlDatabaseConfig Config;
Remarks

This is Config, a member of class DefaultORMappingBuilder.

See Also
DefaultORMappingBuilder Class
Eco.Persistence.ORMapping Namespace


DefaultORMappingBuilder.Database Property

DefaultORMappingBuilder.Database Property
DefaultORMappingBuilder Class Eco.Persistence.ORMapping Namespace See Also
Collapse All

Only classes where the tagged value Eco.Database has this value will be included int he mapping

C#
public string Database;
See Also
DefaultORMappingBuilder Class
Eco.Persistence.ORMapping Namespace


DefaultORMappingBuilder.DefaultSingleLinkColumnName Property

DefaultORMappingBuilder.DefaultSingleLinkColumnName Property
DefaultORMappingBuilder Class Eco.Persistence.ORMapping Namespace See Also
Collapse All
C#
public string DefaultSingleLinkColumnName;
Remarks

This is DefaultSingleLinkColumnName, a member of class DefaultORMappingBuilder.

See Also
DefaultORMappingBuilder Class
Eco.Persistence.ORMapping Namespace


DefaultORMappingBuilder.DiscriminatorMapper Property

DefaultORMappingBuilder.DiscriminatorMapper Property
DefaultORMappingBuilder Class Eco.Persistence.ORMapping Namespace See Also
Collapse All
C#
public ISingleColumnAttributemapping DiscriminatorMapper;
Remarks

This is DiscriminatorMapper, a member of class DefaultORMappingBuilder.

See Also
DefaultORMappingBuilder Class
Eco.Persistence.ORMapping Namespace


DefaultORMappingBuilder.IdColumnName Property

DefaultORMappingBuilder.IdColumnName Property
DefaultORMappingBuilder Class Eco.Persistence.ORMapping Namespace See Also
Collapse All
C#
public string IdColumnName;
Remarks

This is IdColumnName, a member of class DefaultORMappingBuilder.

See Also
DefaultORMappingBuilder Class
Eco.Persistence.ORMapping Namespace


DefaultORMappingBuilder.IdIsAutoInc Property

DefaultORMappingBuilder.IdIsAutoInc Property
DefaultORMappingBuilder Class Eco.Persistence.ORMapping Namespace See Also
Collapse All

This property must be true to use AutoInc keys

C#
public bool IdIsAutoInc;
See Also
DefaultORMappingBuilder Class
Eco.Persistence.ORMapping Namespace


DefaultORMappingBuilder.IdKeyMapper Property

DefaultORMappingBuilder.IdKeyMapper Property
DefaultORMappingBuilder Class Eco.Persistence.ORMapping Namespace See Also
Collapse All
C#
public ISingleColumnAttributemapping IdKeyMapper;
Remarks

This is IdKeyMapper, a member of class DefaultORMappingBuilder.

See Also
DefaultORMappingBuilder Class
Eco.Persistence.ORMapping Namespace


DefaultORMappingBuilder.IdKeyName Property

DefaultORMappingBuilder.IdKeyName Property
DefaultORMappingBuilder Class Eco.Persistence.ORMapping Namespace See Also
Collapse All
C#
public string IdKeyName;
Remarks

This is IdKeyName, a member of class DefaultORMappingBuilder.

See Also
DefaultORMappingBuilder Class
Eco.Persistence.ORMapping Namespace


DefaultORMappingBuilder.IdKeySignature Property

DefaultORMappingBuilder.IdKeySignature Property
DefaultORMappingBuilder Class Eco.Persistence.ORMapping Namespace See Also
Collapse All
C#
public string IdKeySignature;
Remarks

This is IdKeySignature, a member of class DefaultORMappingBuilder.

See Also
DefaultORMappingBuilder Class
Eco.Persistence.ORMapping Namespace


DefaultORMappingBuilder.IdMapperName Property

DefaultORMappingBuilder.IdMapperName Property
DefaultORMappingBuilder Class Eco.Persistence.ORMapping Namespace See Also
Collapse All

This is the name of the KeyMapper used to store the primary key

C#
public string IdMapperName;
See Also
DefaultORMappingBuilder Class
Eco.Persistence.ORMapping Namespace


DefaultORMappingBuilder.Int32Mapper Property

DefaultORMappingBuilder.Int32Mapper Property
DefaultORMappingBuilder Class Eco.Persistence.ORMapping Namespace See Also
Collapse All
C#
public ISingleColumnAttributemapping Int32Mapper;
Remarks

This is Int32Mapper, a member of class DefaultORMappingBuilder.

See Also
DefaultORMappingBuilder Class
Eco.Persistence.ORMapping Namespace


DefaultORMappingBuilder.MapperDictionary Property

DefaultORMappingBuilder.MapperDictionary Property
DefaultORMappingBuilder Class Eco.Persistence.ORMapping Namespace See Also
Collapse All
C#
public PersistenceMapperDictionary MapperDictionary;
Remarks

This is MapperDictionary, a member of class DefaultORMappingBuilder.

See Also
DefaultORMappingBuilder Class
Eco.Persistence.ORMapping Namespace


DefaultORMappingBuilder.Mapping Property

DefaultORMappingBuilder.Mapping Property
DefaultORMappingBuilder Class Eco.Persistence.ORMapping Namespace See Also
Collapse All
C#
public ORMappingDefinition Mapping;
Remarks

This is Mapping, a member of class DefaultORMappingBuilder.

See Also
DefaultORMappingBuilder Class
Eco.Persistence.ORMapping Namespace


DefaultORMappingBuilder.ReservedWordColumnSuffix Property

DefaultORMappingBuilder.ReservedWordColumnSuffix Property
DefaultORMappingBuilder Class Eco.Persistence.ORMapping Namespace See Also
Collapse All
C#
public string ReservedWordColumnSuffix;
Remarks

This is ReservedWordColumnSuffix, a member of class DefaultORMappingBuilder.

See Also
DefaultORMappingBuilder Class
Eco.Persistence.ORMapping Namespace


DefaultORMappingBuilder.ReservedWordTableSuffix Property

DefaultORMappingBuilder.ReservedWordTableSuffix Property
DefaultORMappingBuilder Class Eco.Persistence.ORMapping Namespace See Also
Collapse All
C#
public string ReservedWordTableSuffix;
Remarks

This is ReservedWordTableSuffix, a member of class DefaultORMappingBuilder.

See Also
DefaultORMappingBuilder Class
Eco.Persistence.ORMapping Namespace


DefaultORMappingBuilder.RootClass Property

DefaultORMappingBuilder.RootClass Property
DefaultORMappingBuilder Class Eco.Persistence.ORMapping Namespace See Also
Collapse All
C#
public IClass RootClass;
Remarks

This is RootClass, a member of class DefaultORMappingBuilder.

See Also
DefaultORMappingBuilder Class
Eco.Persistence.ORMapping Namespace


DefaultORMappingBuilder.RootTableName Property

DefaultORMappingBuilder.RootTableName Property
DefaultORMappingBuilder Class Eco.Persistence.ORMapping Namespace See Also
Collapse All
C#
public string RootTableName;
Remarks

This is RootTableName, a member of class DefaultORMappingBuilder.

See Also
DefaultORMappingBuilder Class
Eco.Persistence.ORMapping Namespace


DefaultORMappingBuilder.TablesColumnName Property

DefaultORMappingBuilder.TablesColumnName Property
DefaultORMappingBuilder Class Eco.Persistence.ORMapping Namespace See Also
Collapse All
C#
public string TablesColumnName;
Remarks

This is TablesColumnName, a member of class DefaultORMappingBuilder.

See Also
DefaultORMappingBuilder Class
Eco.Persistence.ORMapping Namespace


DefaultORMappingBuilder.TablesTableName Property

DefaultORMappingBuilder.TablesTableName Property
DefaultORMappingBuilder Class Eco.Persistence.ORMapping Namespace See Also
Collapse All
C#
public string TablesTableName;
Remarks

This is TablesTableName, a member of class DefaultORMappingBuilder.

See Also
DefaultORMappingBuilder Class
Eco.Persistence.ORMapping Namespace


DefaultORMappingBuilder.TypeColumnName Property

DefaultORMappingBuilder.TypeColumnName Property
DefaultORMappingBuilder Class Eco.Persistence.ORMapping Namespace See Also
Collapse All
C#
public string TypeColumnName;
Remarks

This is TypeColumnName, a member of class DefaultORMappingBuilder.

See Also
DefaultORMappingBuilder Class
Eco.Persistence.ORMapping Namespace


DefaultORMappingBuilder.TypeDiscriminatorName Property

DefaultORMappingBuilder.TypeDiscriminatorName Property
DefaultORMappingBuilder Class Eco.Persistence.ORMapping Namespace See Also
Collapse All
C#
public string TypeDiscriminatorName;
Remarks

This is TypeDiscriminatorName, a member of class DefaultORMappingBuilder.

See Also
DefaultORMappingBuilder Class
Eco.Persistence.ORMapping Namespace


DefaultORMappingBuilder.TypeDiscriminatorSignature Property

DefaultORMappingBuilder.TypeDiscriminatorSignature Property
DefaultORMappingBuilder Class Eco.Persistence.ORMapping Namespace See Also
Collapse All
C#
public string TypeDiscriminatorSignature;
Remarks

This is TypeDiscriminatorSignature, a member of class DefaultORMappingBuilder.

See Also
DefaultORMappingBuilder Class
Eco.Persistence.ORMapping Namespace


DefaultORMappingBuilder.TypeTableName Property

DefaultORMappingBuilder.TypeTableName Property
DefaultORMappingBuilder Class Eco.Persistence.ORMapping Namespace See Also
Collapse All
C#
public string TypeTableName;
Remarks

This is TypeTableName, a member of class DefaultORMappingBuilder.

See Also
DefaultORMappingBuilder Class
Eco.Persistence.ORMapping Namespace


DiscriminatorDef Class

DiscriminatorDef Class
Inheritance Hierarchy See Also
Collapse All
C#
public sealed class DiscriminatorDef : NamedDefinition;
Remarks

This is class Eco.Persistence.ORMapping.DiscriminatorDef.

Inheritance Hierarchy
Eco.Persistence.ORMapping.NamedDefinition
    Eco.Persistence.ORMapping.DiscriminatorDef
File

ORMappingDefinition.cs

See Also
Inheritance Hierarchy


DiscriminatorDef Methods

DiscriminatorDef Methods
Public Methods
Collapse All

The methods of the DiscriminatorDef class are listed here.

Public Methods
Name | Description
DiscriminatorValuesByClassId | This is DiscriminatorValuesByClassId, a member of class DiscriminatorDef.
SetDiscriminatorValuesByClassId | This is SetDiscriminatorValuesByClassId, a member of class DiscriminatorDef.


DiscriminatorDef.DiscriminatorValuesByClassId Method

DiscriminatorDef.DiscriminatorValuesByClassId Method
DiscriminatorDef Class Eco.Persistence.ORMapping Namespace See Also
Collapse All
C#
public DiscriminatorValue DiscriminatorValuesByClassId(
    int classId
);
Remarks

This is DiscriminatorValuesByClassId, a member of class DiscriminatorDef.

See Also
DiscriminatorDef Class
Eco.Persistence.ORMapping Namespace


DiscriminatorDef.SetDiscriminatorValuesByClassId Method

DiscriminatorDef.SetDiscriminatorValuesByClassId Method
DiscriminatorDef Class Eco.Persistence.ORMapping Namespace See Also
Collapse All
C#
public void SetDiscriminatorValuesByClassId(
    int classId,
    DiscriminatorValue value
);
Remarks

This is SetDiscriminatorValuesByClassId, a member of class DiscriminatorDef.

See Also
DiscriminatorDef Class
Eco.Persistence.ORMapping Namespace


DiscriminatorDef Properties

DiscriminatorDef Properties
Public Properties
Collapse All

The properties of the DiscriminatorDef class are listed here.

Public Properties
Name | Description
IsStringType | This is IsStringType, a member of class DiscriminatorDef.
Mapper | This is Mapper, a member of class DiscriminatorDef.
Signature | This is Signature, a member of class DiscriminatorDef.
Values | This is Values, a member of class DiscriminatorDef.


DiscriminatorDef.IsStringType Property

DiscriminatorDef.IsStringType Property
DiscriminatorDef Class Eco.Persistence.ORMapping Namespace See Also
Collapse All
C#
public bool IsStringType;
Remarks

This is IsStringType, a member of class DiscriminatorDef.

See Also
DiscriminatorDef Class
Eco.Persistence.ORMapping Namespace


DiscriminatorDef.Mapper Property

DiscriminatorDef.Mapper Property
DiscriminatorDef Class Eco.Persistence.ORMapping Namespace See Also
Collapse All
C#
public ISingleColumnAttributemapping Mapper;
Remarks

This is Mapper, a member of class DiscriminatorDef.

See Also
DiscriminatorDef Class
Eco.Persistence.ORMapping Namespace


DiscriminatorDef.Signature Property

DiscriminatorDef.Signature Property
DiscriminatorDef Class Eco.Persistence.ORMapping Namespace See Also
Collapse All
C#
public String Signature;
Remarks

This is Signature, a member of class DiscriminatorDef.

See Also
DiscriminatorDef Class
Eco.Persistence.ORMapping Namespace


DiscriminatorDef.Values Property

DiscriminatorDef.Values Property
DiscriminatorDef Class Eco.Persistence.ORMapping Namespace See Also
Collapse All
C#
public DiscriminatorValueCollection Values;
Remarks

This is Values, a member of class DiscriminatorDef.

See Also
DiscriminatorDef Class
Eco.Persistence.ORMapping Namespace


DiscriminatorDefCollection Class

DiscriminatorDefCollection Class
Inheritance Hierarchy See Also
Collapse All
C#
public sealed class DiscriminatorDefCollection : Eco.Collections.HashBase;
Remarks

This is class Eco.Persistence.ORMapping.DiscriminatorDefCollection.

Inheritance Hierarchy
Eco.Persistence.ORMapping.DiscriminatorDefCollection
File

ORMappingDefinition.cs

See Also
Inheritance Hierarchy


DiscriminatorDefCollection Methods

DiscriminatorDefCollection Methods
Public Methods
Collapse All

The methods of the DiscriminatorDefCollection class are listed here.

Public Methods
Name | Description
Add | This is Add, a member of class DiscriminatorDefCollection.
this | This is this, a member of class DiscriminatorDefCollection.


DiscriminatorDefCollection.Add Method

DiscriminatorDefCollection.Add Method
DiscriminatorDefCollection Class Eco.Persistence.ORMapping Namespace See Also
Collapse All
C#
public void Add(
    DiscriminatorDef value
);
Remarks

This is Add, a member of class DiscriminatorDefCollection.

See Also
DiscriminatorDefCollection Class
Eco.Persistence.ORMapping Namespace


DiscriminatorDefCollection.this Indexer

DiscriminatorDefCollection.this Indexer
DiscriminatorDefCollection Class Eco.Persistence.ORMapping Namespace See Also
Collapse All
C#
public DiscriminatorDef this[
    string name
];
Remarks

This is this, a member of class DiscriminatorDefCollection.

See Also
DiscriminatorDefCollection Class
Eco.Persistence.ORMapping Namespace


DiscriminatorImplementation Class

DiscriminatorImplementation Class
Inheritance Hierarchy See Also
Collapse All
C#
public sealed class DiscriminatorImplementation : IHashBaseElement;
Remarks

This is class Eco.Persistence.ORMapping.DiscriminatorImplementation.

Inheritance Hierarchy
Eco.Persistence.ORMapping.DiscriminatorImplementation
File

ORMappingDefinition.cs

See Also
Inheritance Hierarchy


DiscriminatorImplementation.DiscriminatorImplementation Constructor

DiscriminatorImplementation.DiscriminatorImplementation Constructor
DiscriminatorImplementation Class Eco.Persistence.ORMapping Namespace See Also
Collapse All
C#
public DiscriminatorImplementation(
    AliasDefinition alias
);
Remarks

This is DiscriminatorImplementation, a member of class DiscriminatorImplementation.

See Also
DiscriminatorImplementation Class
Eco.Persistence.ORMapping Namespace


DiscriminatorImplementation Properties

DiscriminatorImplementation Properties
Public Properties
Collapse All

The properties of the DiscriminatorImplementation class are listed here.

Public Properties
Name | Description
Alias | This is Alias, a member of class DiscriminatorImplementation.
ColumnRef | This is ColumnRef, a member of class DiscriminatorImplementation.
Discriminator | This is Discriminator, a member of class DiscriminatorImplementation.


DiscriminatorImplementation.Alias Property

DiscriminatorImplementation.Alias Property
DiscriminatorImplementation Class Eco.Persistence.ORMapping Namespace See Also
Collapse All
C#
public AliasDefinition Alias;
Remarks

This is Alias, a member of class DiscriminatorImplementation.

See Also
DiscriminatorImplementation Class
Eco.Persistence.ORMapping Namespace


DiscriminatorImplementation.ColumnRef Property

DiscriminatorImplementation.ColumnRef Property
DiscriminatorImplementation Class Eco.Persistence.ORMapping Namespace See Also
Collapse All
C#
public ColumnReference ColumnRef;
Remarks

This is ColumnRef, a member of class DiscriminatorImplementation.

See Also
DiscriminatorImplementation Class
Eco.Persistence.ORMapping Namespace


DiscriminatorImplementation.Discriminator Property

DiscriminatorImplementation.Discriminator Property
DiscriminatorImplementation Class Eco.Persistence.ORMapping Namespace See Also
Collapse All
C#
public DiscriminatorDef Discriminator;
Remarks

This is Discriminator, a member of class DiscriminatorImplementation.

See Also
DiscriminatorImplementation Class
Eco.Persistence.ORMapping Namespace


DiscriminatorImplementationCollection Class

DiscriminatorImplementationCollection Class
Inheritance Hierarchy See Also
Collapse All
C#
public sealed class DiscriminatorImplementationCollection : Eco.Collections.HashBase;
Remarks

This is class Eco.Persistence.ORMapping.DiscriminatorImplementationCollection.

Inheritance Hierarchy
Eco.Persistence.ORMapping.DiscriminatorImplementationCollection
File

ORMappingDefinition.cs

See Also
Inheritance Hierarchy


DiscriminatorImplementationCollection Methods

DiscriminatorImplementationCollection Methods
Public Methods
Collapse All

The methods of the DiscriminatorImplementationCollection class are listed here.

Public Methods
Name | Description
Add | This is Add, a member of class DiscriminatorImplementationCollection.
this | This is this, a member of class DiscriminatorImplementationCollection.


DiscriminatorImplementationCollection.Add Method

DiscriminatorImplementationCollection.Add Method
DiscriminatorImplementationCollection Class Eco.Persistence.ORMapping Namespace See Also
Collapse All
C#
public void Add(
    DiscriminatorImplementation value
);
Remarks

This is Add, a member of class DiscriminatorImplementationCollection.

See Also
DiscriminatorImplementationCollection Class
Eco.Persistence.ORMapping Namespace


DiscriminatorImplementationCollection.this Indexer

DiscriminatorImplementationCollection.this Indexer
DiscriminatorImplementationCollection Class Eco.Persistence.ORMapping Namespace See Also
Collapse All
C#
public DiscriminatorImplementation this[
    string name
];
Remarks

This is this, a member of class DiscriminatorImplementationCollection.

See Also
DiscriminatorImplementationCollection Class
Eco.Persistence.ORMapping Namespace


DiscriminatorValue Class

DiscriminatorValue Class
Inheritance Hierarchy See Also
Collapse All
C#
public sealed class DiscriminatorValue : IHashBaseElement;
Remarks

This is class Eco.Persistence.ORMapping.DiscriminatorValue.

Inheritance Hierarchy
Eco.Persistence.ORMapping.DiscriminatorValue
File

ORMappingDefinition.cs

See Also
Inheritance Hierarchy


DiscriminatorValue Properties

DiscriminatorValue Properties
Public Properties
Collapse All

The properties of the DiscriminatorValue class are listed here.

Public Properties
Name | Description
Class_ | This is Class_, a member of class DiscriminatorValue.
Discriminator | This is Discriminator, a member of class DiscriminatorValue.
IsFinal | This is IsFinal, a member of class DiscriminatorValue.
Value | This is Value, a member of class DiscriminatorValue.


DiscriminatorValue.Class_ Property

DiscriminatorValue.Class_ Property
DiscriminatorValue Class Eco.Persistence.ORMapping Namespace See Also
Collapse All
C#
public ClassDefinition Class_;
Remarks

This is Class_, a member of class DiscriminatorValue.

See Also
DiscriminatorValue Class
Eco.Persistence.ORMapping Namespace


DiscriminatorValue.Discriminator Property

DiscriminatorValue.Discriminator Property
DiscriminatorValue Class Eco.Persistence.ORMapping Namespace See Also
Collapse All
C#
public DiscriminatorDef Discriminator;
Remarks

This is Discriminator, a member of class DiscriminatorValue.

See Also
DiscriminatorValue Class
Eco.Persistence.ORMapping Namespace


DiscriminatorValue.IsFinal Property

DiscriminatorValue.IsFinal Property
DiscriminatorValue Class Eco.Persistence.ORMapping Namespace See Also
Collapse All
C#
public bool IsFinal;
Remarks

This is IsFinal, a member of class DiscriminatorValue.

See Also
DiscriminatorValue Class
Eco.Persistence.ORMapping Namespace


DiscriminatorValue.Value Property

DiscriminatorValue.Value Property
DiscriminatorValue Class Eco.Persistence.ORMapping Namespace See Also
Collapse All
C#
public string Value;
Remarks

This is Value, a member of class DiscriminatorValue.

See Also
DiscriminatorValue Class
Eco.Persistence.ORMapping Namespace


DiscriminatorValueCollection Class

DiscriminatorValueCollection Class
Inheritance Hierarchy See Also
Collapse All
C#
public sealed class DiscriminatorValueCollection : Eco.Collections.CollectionBase;
Remarks

This is class Eco.Persistence.ORMapping.DiscriminatorValueCollection.

Inheritance Hierarchy
Eco.Persistence.ORMapping.DiscriminatorValueCollection
File

ORMappingDefinition.cs

See Also
Inheritance Hierarchy


DiscriminatorValueCollection Methods

DiscriminatorValueCollection Methods
Public Methods
Collapse All

The methods of the DiscriminatorValueCollection class are listed here.

Public Methods
Name | Description
Add | This is Add, a member of class DiscriminatorValueCollection.
FindByName | This is FindByName, a member of class DiscriminatorValueCollection.
FindByValue | This is FindByValue, a member of class DiscriminatorValueCollection.
this | This is this, a member of class DiscriminatorValueCollection.


DiscriminatorValueCollection.Add Method

DiscriminatorValueCollection.Add Method
DiscriminatorValueCollection Class Eco.Persistence.ORMapping Namespace See Also
Collapse All
C#
public void Add(
    DiscriminatorValue value
);
Remarks

This is Add, a member of class DiscriminatorValueCollection.

See Also
DiscriminatorValueCollection Class
Eco.Persistence.ORMapping Namespace


DiscriminatorValueCollection.FindByName Method

DiscriminatorValueCollection.FindByName Method
DiscriminatorValueCollection Class Eco.Persistence.ORMapping Namespace See Also
Collapse All
C#
public DiscriminatorValue FindByName(
    string name
);
Remarks

This is FindByName, a member of class DiscriminatorValueCollection.

See Also
DiscriminatorValueCollection Class
Eco.Persistence.ORMapping Namespace


DiscriminatorValueCollection.FindByValue Method

DiscriminatorValueCollection.FindByValue Method
DiscriminatorValueCollection Class Eco.Persistence.ORMapping Namespace See Also
Collapse All
C#
public DiscriminatorValue FindByValue(
    string value
);
Remarks

This is FindByValue, a member of class DiscriminatorValueCollection.

See Also
DiscriminatorValueCollection Class
Eco.Persistence.ORMapping Namespace


DiscriminatorValueCollection.this Indexer

DiscriminatorValueCollection.this Indexer
DiscriminatorValueCollection Class Eco.Persistence.ORMapping Namespace See Also
Collapse All
C#
public DiscriminatorValue this[
    int index
];
Remarks

This is this, a member of class DiscriminatorValueCollection.

See Also
DiscriminatorValueCollection Class
Eco.Persistence.ORMapping Namespace


FeatureCollection Class

FeatureCollection Class
Inheritance Hierarchy See Also
Collapse All
C#
public sealed class FeatureCollection : Eco.Collections.HashBase;
Remarks

This is class Eco.Persistence.ORMapping.FeatureCollection.

Inheritance Hierarchy
Eco.Persistence.ORMapping.FeatureCollection
File

ORMappingDefinition.cs

See Also
Inheritance Hierarchy


FeatureCollection Methods

FeatureCollection Methods
Public Methods
Collapse All

The methods of the FeatureCollection class are listed here.

Public Methods
Name | Description
Add | This is Add, a member of class FeatureCollection.
this | This is this, a member of class FeatureCollection.


FeatureCollection.Add Method

FeatureCollection.Add Method
FeatureCollection Class Eco.Persistence.ORMapping Namespace See Also
Collapse All
C#
public void Add(
    StructuralFeatureDefinition value
);
Remarks

This is Add, a member of class FeatureCollection.

See Also
FeatureCollection Class
Eco.Persistence.ORMapping Namespace


FeatureCollection.this Indexer

FeatureCollection.this Indexer
FeatureCollection Class Eco.Persistence.ORMapping Namespace See Also
Collapse All
C#
public StructuralFeatureDefinition this[
    string name
];
Remarks

This is this, a member of class FeatureCollection.

See Also
FeatureCollection Class
Eco.Persistence.ORMapping Namespace


FileMappingProvider Class

FileMappingProvider Class
Inheritance Hierarchy See Also
Collapse All
C#
public sealed class FileMappingProvider : System.ComponentModel.Component, IORMappingProvider;
Remarks

Designer("Eco.Persistence.Design.FileMappingProvider, Eco.Handles.Design" + VersionInfo.AssemblySuffix, typeof(IDesigner))

Inheritance Hierarchy
Eco.Persistence.ORMapping.IORMappingProvider
    Eco.Persistence.ORMapping.FileMappingProvider
File

FileMappingProvider.cs

See Also
Inheritance Hierarchy


FileMappingProvider Methods

FileMappingProvider Methods
Public Methods
Collapse All

The methods of the FileMappingProvider class are listed here.

Public Methods
Name | Description
Initialize | This is Initialize, a member of class FileMappingProvider.
PostCreateDb | This is PostCreateDb, a member of class FileMappingProvider.
PostEvolveDb | This is PostEvolveDb, a member of class FileMappingProvider.
PostEvolveDbScript | Required to fulfill interface IORMappingProvider. This implementation does nothing.
SaveMappingInfo | This is SaveMappingInfo, a member of class FileMappingProvider.
SystemTableNames | This is SystemTableNames, a member of class FileMappingProvider.


FileMappingProvider.Initialize Method

FileMappingProvider.Initialize Method
FileMappingProvider Class Eco.Persistence.ORMapping Namespace See Also
Collapse All
C#
public void Initialize(
    IEcoTypeSystem typeSystem,
    IDatabase db,
    SqlDatabaseConfig config,
    bool addMissingTypes
);
Remarks

This is Initialize, a member of class FileMappingProvider.

See Also
FileMappingProvider Class
Eco.Persistence.ORMapping Namespace


FileMappingProvider.PostCreateDb Method

FileMappingProvider.PostCreateDb Method
FileMappingProvider Class Eco.Persistence.ORMapping Namespace See Also
Collapse All
C#
public void PostCreateDb(
    IDatabase db,
    SqlDatabaseConfig sqlDatabaseConfig,
    ORMappingDefinition newMapping
);
Remarks

This is PostCreateDb, a member of class FileMappingProvider.

See Also
FileMappingProvider Class
Eco.Persistence.ORMapping Namespace


FileMappingProvider.PostEvolveDb Method

FileMappingProvider.PostEvolveDb Method
FileMappingProvider Class Eco.Persistence.ORMapping Namespace See Also
Collapse All
C#
public void PostEvolveDb(
    IDatabase db,
    SqlDatabaseConfig sqlDatabaseConfig,
    ORMappingDefinition newMapping
);
Remarks

This is PostEvolveDb, a member of class FileMappingProvider.

See Also
FileMappingProvider Class
Eco.Persistence.ORMapping Namespace


FileMappingProvider.PostEvolveDbScript Method

FileMappingProvider.PostEvolveDbScript Method
FileMappingProvider Class Eco.Persistence.ORMapping Namespace See Also
Collapse All

Required to fulfill interface IORMappingProvider. This implementation does nothing.

C#
public void PostEvolveDbScript(
    IDatabase db,
    SqlDatabaseConfig sqlDatabaseConfig,
    ORMappingDefinition newMapping,
    IList<string> script
);
See Also
FileMappingProvider Class
Eco.Persistence.ORMapping Namespace


FileMappingProvider.SaveMappingInfo Method

FileMappingProvider.SaveMappingInfo Method
FileMappingProvider Class Eco.Persistence.ORMapping Namespace See Also
Collapse All
C#
public void SaveMappingInfo(
    IDatabase db,
    SqlDatabaseConfig sqlDatabaseConfig,
    ORMappingDefinition newMapping
);
Remarks

This is SaveMappingInfo, a member of class FileMappingProvider.

See Also
FileMappingProvider Class
Eco.Persistence.ORMapping Namespace


FileMappingProvider.SystemTableNames Method

FileMappingProvider.SystemTableNames Method
FileMappingProvider Class Eco.Persistence.ORMapping Namespace See Also
Collapse All
C#
public IList<string> SystemTableNames(
    SqlDatabaseConfig config
);
Remarks

This is SystemTableNames, a member of class FileMappingProvider.

See Also
FileMappingProvider Class
Eco.Persistence.ORMapping Namespace


FileMappingProvider Properties

FileMappingProvider Properties
Public Properties
Collapse All

The properties of the FileMappingProvider class are listed here.

Public Properties
Name | Description
FileName | If this property is set, the component will try to load O/R mapping configuration from the specified file. If the file does not exist, the component will first try to fallback to loading the config from a resource using the ResourceName property. Note: the path relative to the executable
Mapping | This is Mapping, a member of class FileMappingProvider.
ResourceName | If this property is set (and either the FileName property is empty, or the file indicated does not exist), the component will try to load O/R mapping configuration from the resource with the specified name). If the resource does not exist, an exception will be thrown


FileMappingProvider.FileName Property

FileMappingProvider.FileName Property
FileMappingProvider Class Eco.Persistence.ORMapping Namespace See Also
Collapse All

If this property is set, the component will try to load O/R mapping configuration from the specified file. If the file does not exist, the component will first try to fallback to loading the config from a resource using the ResourceName property.

Note: the path relative to the executable

C#
public string FileName;
See Also
FileMappingProvider Class
Eco.Persistence.ORMapping Namespace


FileMappingProvider.Mapping Property

FileMappingProvider.Mapping Property
FileMappingProvider Class Eco.Persistence.ORMapping Namespace See Also
Collapse All
C#
public ORMappingDefinition Mapping;
Remarks

This is Mapping, a member of class FileMappingProvider.

See Also
FileMappingProvider Class
Eco.Persistence.ORMapping Namespace


FileMappingProvider.ResourceName Property

FileMappingProvider.ResourceName Property
FileMappingProvider Class Eco.Persistence.ORMapping Namespace See Also
Collapse All

If this property is set (and either the FileName property is empty, or the file indicated does not exist), the component will try to load O/R mapping configuration from the resource with the specified name). If the resource does not exist, an exception will be thrown

C#
public string ResourceName;
See Also
FileMappingProvider Class
Eco.Persistence.ORMapping Namespace


ForeignKeyCollection Class

ForeignKeyCollection Class
Inheritance Hierarchy See Also
Collapse All
C#
public sealed class ForeignKeyCollection : Eco.Collections.HashBase;
Remarks

This is class Eco.Persistence.ORMapping.ForeignKeyCollection.

Inheritance Hierarchy
Eco.Persistence.ORMapping.ForeignKeyCollection
File

ORMappingDefinition.cs

See Also
Inheritance Hierarchy


ForeignKeyCollection Methods

ForeignKeyCollection Methods
Public Methods
Collapse All

The methods of the ForeignKeyCollection class are listed here.

Public Methods
Name | Description
Add | This is Add, a member of class ForeignKeyCollection.
this | This is this, a member of class ForeignKeyCollection.


ForeignKeyCollection.Add Method

ForeignKeyCollection.Add Method
ForeignKeyCollection Class Eco.Persistence.ORMapping Namespace See Also
Collapse All
C#
public void Add(
    ForeignKeyDefinition value
);
Remarks

This is Add, a member of class ForeignKeyCollection.

See Also
ForeignKeyCollection Class
Eco.Persistence.ORMapping Namespace


ForeignKeyCollection.this Indexer

ForeignKeyCollection.this Indexer
ForeignKeyCollection Class Eco.Persistence.ORMapping Namespace See Also
Collapse All
C#
public ForeignKeyDefinition this[
    string name
];
Remarks

This is this, a member of class ForeignKeyCollection.

See Also
ForeignKeyCollection Class
Eco.Persistence.ORMapping Namespace


ForeignKeyDefinition Class

ForeignKeyDefinition Class
Inheritance Hierarchy See Also
Collapse All
C#
public sealed class ForeignKeyDefinition : NamedDefinition;
Remarks

This is class Eco.Persistence.ORMapping.ForeignKeyDefinition.

Inheritance Hierarchy
Eco.Persistence.ORMapping.NamedDefinition
    Eco.Persistence.ORMapping.ForeignKeyDefinition
File

ORMappingDefinition.cs

See Also
Inheritance Hierarchy


ForeignKeyDefinition.ForeignKeyDefinition Constructor

ForeignKeyDefinition.ForeignKeyDefinition Constructor
ForeignKeyDefinition Class Eco.Persistence.ORMapping Namespace See Also
Collapse All
C#
public ForeignKeyDefinition(
    TableDefinition table,
    string name
);
Remarks

This is ForeignKeyDefinition, a member of class ForeignKeyDefinition.

See Also
ForeignKeyDefinition Class
Eco.Persistence.ORMapping Namespace


ForeignKeyDefinition Properties

ForeignKeyDefinition Properties
Public Properties
Collapse All

The properties of the ForeignKeyDefinition class are listed here.

Public Properties
Name | Description
ForeignColumns | This is ForeignColumns, a member of class ForeignKeyDefinition.
OwnColumns | This is OwnColumns, a member of class ForeignKeyDefinition.
Table | This is Table, a member of class ForeignKeyDefinition.


ForeignKeyDefinition.ForeignColumns Property

ForeignKeyDefinition.ForeignColumns Property
ForeignKeyDefinition Class Eco.Persistence.ORMapping Namespace See Also
Collapse All
C#
public ColumnCollection ForeignColumns;
Remarks

This is ForeignColumns, a member of class ForeignKeyDefinition.

See Also
ForeignKeyDefinition Class
Eco.Persistence.ORMapping Namespace


ForeignKeyDefinition.OwnColumns Property

ForeignKeyDefinition.OwnColumns Property
ForeignKeyDefinition Class Eco.Persistence.ORMapping Namespace See Also
Collapse All
C#
public ColumnCollection OwnColumns;
Remarks

This is OwnColumns, a member of class ForeignKeyDefinition.

See Also
ForeignKeyDefinition Class
Eco.Persistence.ORMapping Namespace


ForeignKeyDefinition.Table Property

ForeignKeyDefinition.Table Property
ForeignKeyDefinition Class Eco.Persistence.ORMapping Namespace See Also
Collapse All
C#
public TableDefinition Table;
Remarks

This is Table, a member of class ForeignKeyDefinition.

See Also
ForeignKeyDefinition Class
Eco.Persistence.ORMapping Namespace


IndexCollection Class

IndexCollection Class
Inheritance Hierarchy See Also
Collapse All
C#
public sealed class IndexCollection : Eco.Collections.CollectionBase;
Remarks

This is class Eco.Persistence.ORMapping.IndexCollection.

Inheritance Hierarchy
Eco.Persistence.ORMapping.IndexCollection
File

ORMappingDefinition.cs

See Also
Inheritance Hierarchy


IndexCollection Methods

IndexCollection Methods
Public Methods
Collapse All

The methods of the IndexCollection class are listed here.

Public Methods
Name | Description
Add | This is Add, a member of class IndexCollection.
this | This is this, a member of class IndexCollection.


IndexCollection.Add Method

IndexCollection.Add Method
IndexCollection Class Eco.Persistence.ORMapping Namespace See Also
Collapse All
C#
public void Add(
    IndexDefinition value
);
Remarks

This is Add, a member of class IndexCollection.

See Also
IndexCollection Class
Eco.Persistence.ORMapping Namespace


IndexCollection.this Indexer

IndexCollection.this Indexer
IndexCollection Class Eco.Persistence.ORMapping Namespace See Also
Collapse All
C#
public IndexDefinition this[
    int index
];
Remarks

This is this, a member of class IndexCollection.

See Also
IndexCollection Class
Eco.Persistence.ORMapping Namespace


IndexDefinition Class

IndexDefinition Class
Inheritance Hierarchy See Also
Collapse All
C#
public sealed class IndexDefinition : NamedDefinition;
Remarks

This is class Eco.Persistence.ORMapping.IndexDefinition.

Inheritance Hierarchy
Eco.Persistence.ORMapping.NamedDefinition
    Eco.Persistence.ORMapping.IndexDefinition
File

ORMappingDefinition.cs

See Also
Inheritance Hierarchy


IndexDefinition.IndexDefinition Constructor

IndexDefinition.IndexDefinition Constructor
IndexDefinition Class Eco.Persistence.ORMapping Namespace See Also
Collapse All
C#
public IndexDefinition(
    TableDefinition table,
    string name
);
Remarks

This is IndexDefinition, a member of class IndexDefinition.

See Also
IndexDefinition Class
Eco.Persistence.ORMapping Namespace


IndexDefinition Properties

IndexDefinition Properties
Public Properties
Collapse All

The properties of the IndexDefinition class are listed here.

Public Properties
Name | Description
Columns | This is Columns, a member of class IndexDefinition.
IsCaseInsensitive | This is IsCaseInsensitive, a member of class IndexDefinition.
IsDescending | This is IsDescending, a member of class IndexDefinition.
IsPrimary | This is IsPrimary, a member of class IndexDefinition.
IsUnique | This is IsUnique, a member of class IndexDefinition.
Table | This is Table, a member of class IndexDefinition.


IndexDefinition.Columns Property

IndexDefinition.Columns Property
IndexDefinition Class Eco.Persistence.ORMapping Namespace See Also
Collapse All
C#
public ColumnCollection Columns;
Remarks

This is Columns, a member of class IndexDefinition.

See Also
IndexDefinition Class
Eco.Persistence.ORMapping Namespace


IndexDefinition.IsCaseInsensitive Property

IndexDefinition.IsCaseInsensitive Property
IndexDefinition Class Eco.Persistence.ORMapping Namespace See Also
Collapse All
C#
public bool IsCaseInsensitive;
Remarks

This is IsCaseInsensitive, a member of class IndexDefinition.

See Also
IndexDefinition Class
Eco.Persistence.ORMapping Namespace


IndexDefinition.IsDescending Property

IndexDefinition.IsDescending Property
IndexDefinition Class Eco.Persistence.ORMapping Namespace See Also
Collapse All
C#
public bool IsDescending;
Remarks

This is IsDescending, a member of class IndexDefinition.

See Also
IndexDefinition Class
Eco.Persistence.ORMapping Namespace


IndexDefinition.IsPrimary Property

IndexDefinition.IsPrimary Property
IndexDefinition Class Eco.Persistence.ORMapping Namespace See Also
Collapse All
C#
public bool IsPrimary;
Remarks

This is IsPrimary, a member of class IndexDefinition.

See Also
IndexDefinition Class
Eco.Persistence.ORMapping Namespace


IndexDefinition.IsUnique Property

IndexDefinition.IsUnique Property
IndexDefinition Class Eco.Persistence.ORMapping Namespace See Also
Collapse All
C#
public bool IsUnique;
Remarks

This is IsUnique, a member of class IndexDefinition.

See Also
IndexDefinition Class
Eco.Persistence.ORMapping Namespace


IndexDefinition.Table Property

IndexDefinition.Table Property
IndexDefinition Class Eco.Persistence.ORMapping Namespace See Also
Collapse All
C#
public TableDefinition Table;
Remarks

This is Table, a member of class IndexDefinition.

See Also
IndexDefinition Class
Eco.Persistence.ORMapping Namespace


KeyDefinition Class

KeyDefinition Class
Inheritance Hierarchy See Also
Collapse All
C#
public sealed class KeyDefinition : NamedDefinition;
Remarks

This is class Eco.Persistence.ORMapping.KeyDefinition.

Inheritance Hierarchy
Eco.Persistence.ORMapping.NamedDefinition
    Eco.Persistence.ORMapping.KeyDefinition
File

ORMappingDefinition.cs

See Also
Inheritance Hierarchy


KeyDefinition Methods

KeyDefinition Methods
Public Methods
Collapse All

The methods of the KeyDefinition class are listed here.

Public Methods
Name | Description
MarkAutoInc | This is MarkAutoInc, a member of class KeyDefinition.
SetKeyMapper | This is SetKeyMapper, a member of class KeyDefinition.


KeyDefinition.MarkAutoInc Method

KeyDefinition.MarkAutoInc Method
KeyDefinition Class Eco.Persistence.ORMapping Namespace See Also
Collapse All
C#
public void MarkAutoInc();
Remarks

This is MarkAutoInc, a member of class KeyDefinition.

See Also
KeyDefinition Class
Eco.Persistence.ORMapping Namespace


KeyDefinition.SetKeyMapper Method

KeyDefinition.SetKeyMapper Method
KeyDefinition Class Eco.Persistence.ORMapping Namespace See Also
Collapse All
C#
public void SetKeyMapper(
    IKeyMapper keyMapper
);
Remarks

This is SetKeyMapper, a member of class KeyDefinition.

See Also
KeyDefinition Class
Eco.Persistence.ORMapping Namespace


KeyDefinition Properties

KeyDefinition Properties
Public Properties
Collapse All

The properties of the KeyDefinition class are listed here.

Public Properties
Name | Description
Attributemappings | This is Attributemappings, a member of class KeyDefinition.
IsAutoInc | properties that are initialized by the PersistenceMapper
IsId | This is IsId, a member of class KeyDefinition.
KeyColumnCount | This is KeyColumnCount, a member of class KeyDefinition.
KeyImplementations | This is KeyImplementations, a member of class KeyDefinition.
KeyMapper | This is KeyMapper, a member of class KeyDefinition.
KeyMapperName | This is KeyMapperName, a member of class KeyDefinition.
Signature | This is Signature, a member of class KeyDefinition.


KeyDefinition.Attributemappings Property

KeyDefinition.Attributemappings Property
KeyDefinition Class Eco.Persistence.ORMapping Namespace See Also
Collapse All
C#
public ArrayList Attributemappings;
Remarks

This is Attributemappings, a member of class KeyDefinition.

See Also
KeyDefinition Class
Eco.Persistence.ORMapping Namespace


KeyDefinition.IsAutoInc Property

KeyDefinition.IsAutoInc Property
KeyDefinition Class Eco.Persistence.ORMapping Namespace See Also
Collapse All
C#
public bool IsAutoInc;
Remarks

properties that are initialized by the PersistenceMapper

See Also
KeyDefinition Class
Eco.Persistence.ORMapping Namespace


KeyDefinition.IsId Property

KeyDefinition.IsId Property
KeyDefinition Class Eco.Persistence.ORMapping Namespace See Also
Collapse All
C#
public bool IsId;
Remarks

This is IsId, a member of class KeyDefinition.

See Also
KeyDefinition Class
Eco.Persistence.ORMapping Namespace


KeyDefinition.KeyColumnCount Property

KeyDefinition.KeyColumnCount Property
KeyDefinition Class Eco.Persistence.ORMapping Namespace See Also
Collapse All
C#
public int KeyColumnCount;
Remarks

This is KeyColumnCount, a member of class KeyDefinition.

See Also
KeyDefinition Class
Eco.Persistence.ORMapping Namespace


KeyDefinition.KeyImplementations Property

KeyDefinition.KeyImplementations Property
KeyDefinition Class Eco.Persistence.ORMapping Namespace See Also
Collapse All
C#
public KeyImplementationCollection KeyImplementations;
Remarks

This is KeyImplementations, a member of class KeyDefinition.

See Also
KeyDefinition Class
Eco.Persistence.ORMapping Namespace


KeyDefinition.KeyMapper Property

KeyDefinition.KeyMapper Property
KeyDefinition Class Eco.Persistence.ORMapping Namespace See Also
Collapse All
C#
public IKeyMapper KeyMapper;
Remarks

This is KeyMapper, a member of class KeyDefinition.

See Also
KeyDefinition Class
Eco.Persistence.ORMapping Namespace


KeyDefinition.KeyMapperName Property

KeyDefinition.KeyMapperName Property
KeyDefinition Class Eco.Persistence.ORMapping Namespace See Also
Collapse All
C#
public string KeyMapperName;
Remarks

This is KeyMapperName, a member of class KeyDefinition.

See Also
KeyDefinition Class
Eco.Persistence.ORMapping Namespace


KeyDefinition.Signature Property

KeyDefinition.Signature Property
KeyDefinition Class Eco.Persistence.ORMapping Namespace See Also
Collapse All
C#
public List<string> Signature;
Remarks

This is Signature, a member of class KeyDefinition.

See Also
KeyDefinition Class
Eco.Persistence.ORMapping Namespace


KeyDefinitionCollection Class

KeyDefinitionCollection Class
Inheritance Hierarchy See Also
Collapse All
C#
public sealed class KeyDefinitionCollection : Eco.Collections.HashBase;
Remarks

This is class Eco.Persistence.ORMapping.KeyDefinitionCollection.

Inheritance Hierarchy
Eco.Persistence.ORMapping.KeyDefinitionCollection
File

ORMappingDefinition.cs

See Also
Inheritance Hierarchy


KeyDefinitionCollection Methods

KeyDefinitionCollection Methods
Public Methods
Collapse All

The methods of the KeyDefinitionCollection class are listed here.

Public Methods
Name | Description
Add | This is Add, a member of class KeyDefinitionCollection.
this | This is this, a member of class KeyDefinitionCollection.


KeyDefinitionCollection.Add Method

KeyDefinitionCollection.Add Method
KeyDefinitionCollection Class Eco.Persistence.ORMapping Namespace See Also
Collapse All
C#
public void Add(
    KeyDefinition value
);
Remarks

This is Add, a member of class KeyDefinitionCollection.

See Also
KeyDefinitionCollection Class
Eco.Persistence.ORMapping Namespace


KeyDefinitionCollection.this Indexer

KeyDefinitionCollection.this Indexer
KeyDefinitionCollection Class Eco.Persistence.ORMapping Namespace See Also
Collapse All
C#
public KeyDefinition this[
    string name
];
Remarks

This is this, a member of class KeyDefinitionCollection.

See Also
KeyDefinitionCollection Class
Eco.Persistence.ORMapping Namespace


KeyImplementation Class

KeyImplementation Class
Inheritance Hierarchy See Also
Collapse All
C#
public sealed class KeyImplementation : IHashBaseElement;
Remarks

This is class Eco.Persistence.ORMapping.KeyImplementation.

Inheritance Hierarchy
Eco.Persistence.ORMapping.KeyImplementation
File

ORMappingDefinition.cs

See Also
Inheritance Hierarchy


KeyImplementation.KeyImplementation Constructor

KeyImplementation.KeyImplementation Constructor
KeyImplementation Class Eco.Persistence.ORMapping Namespace See Also
Collapse All
C#
public KeyImplementation(
    AliasDefinition alias
);
Remarks

This is KeyImplementation, a member of class KeyImplementation.

See Also
KeyImplementation Class
Eco.Persistence.ORMapping Namespace


KeyImplementation Properties

KeyImplementation Properties
Public Properties
Collapse All

The properties of the KeyImplementation class are listed here.

Public Properties
Name | Description
Alias | This is Alias, a member of class KeyImplementation.
AutoInc | This is AutoInc, a member of class KeyImplementation.
ColumnsCoveredByMember | properties set by PMapper
ConstantColumns | This is ConstantColumns, a member of class KeyImplementation.
DiscriminatorColumns | This is DiscriminatorColumns, a member of class KeyImplementation.
Key | This is Key, a member of class KeyImplementation.
KeyColumns | This is KeyColumns, a member of class KeyImplementation.


KeyImplementation.Alias Property

KeyImplementation.Alias Property
KeyImplementation Class Eco.Persistence.ORMapping Namespace See Also
Collapse All
C#
public AliasDefinition Alias;
Remarks

This is Alias, a member of class KeyImplementation.

See Also
KeyImplementation Class
Eco.Persistence.ORMapping Namespace


KeyImplementation.AutoInc Property

KeyImplementation.AutoInc Property
KeyImplementation Class Eco.Persistence.ORMapping Namespace See Also
Collapse All
C#
public bool AutoInc;
Remarks

This is AutoInc, a member of class KeyImplementation.

See Also
KeyImplementation Class
Eco.Persistence.ORMapping Namespace


KeyImplementation.ColumnsCoveredByMember Property

KeyImplementation.ColumnsCoveredByMember Property
KeyImplementation Class Eco.Persistence.ORMapping Namespace See Also
Collapse All
C#
public KeyCoverage ColumnsCoveredByMember;
Remarks

properties set by PMapper

See Also
KeyImplementation Class
Eco.Persistence.ORMapping Namespace


KeyImplementation.ConstantColumns Property

KeyImplementation.ConstantColumns Property
KeyImplementation Class Eco.Persistence.ORMapping Namespace See Also
Collapse All
C#
public ConstantColumnCollection ConstantColumns;
Remarks

This is ConstantColumns, a member of class KeyImplementation.

See Also
KeyImplementation Class
Eco.Persistence.ORMapping Namespace


KeyImplementation.DiscriminatorColumns Property

KeyImplementation.DiscriminatorColumns Property
KeyImplementation Class Eco.Persistence.ORMapping Namespace See Also
Collapse All
C#
public ColumnReferenceCollection DiscriminatorColumns;
Remarks

This is DiscriminatorColumns, a member of class KeyImplementation.

See Also
KeyImplementation Class
Eco.Persistence.ORMapping Namespace


KeyImplementation.Key Property

KeyImplementation.Key Property
KeyImplementation Class Eco.Persistence.ORMapping Namespace See Also
Collapse All
C#
public KeyDefinition Key;
Remarks

This is Key, a member of class KeyImplementation.

See Also
KeyImplementation Class
Eco.Persistence.ORMapping Namespace


KeyImplementation.KeyColumns Property

KeyImplementation.KeyColumns Property
KeyImplementation Class Eco.Persistence.ORMapping Namespace See Also
Collapse All
C#
public ColumnReferenceCollection KeyColumns;
Remarks

This is KeyColumns, a member of class KeyImplementation.

See Also
KeyImplementation Class
Eco.Persistence.ORMapping Namespace


KeyImplementationCollection Class

KeyImplementationCollection Class
Inheritance Hierarchy See Also
Collapse All
C#
public sealed class KeyImplementationCollection : Eco.Collections.CollectionBase;
Remarks

This is class Eco.Persistence.ORMapping.KeyImplementationCollection.

Inheritance Hierarchy
Eco.Persistence.ORMapping.KeyImplementationCollection
File

ORMappingDefinition.cs

See Also
Inheritance Hierarchy


KeyImplementationCollection Methods

KeyImplementationCollection Methods
Public Methods
Collapse All

The methods of the KeyImplementationCollection class are listed here.

Public Methods
Name | Description
Add | This is Add, a member of class KeyImplementationCollection.
this | This is the overview for the this indexer overload.


KeyImplementationCollection.Add Method

KeyImplementationCollection.Add Method
KeyImplementationCollection Class Eco.Persistence.ORMapping Namespace See Also
Collapse All
C#
public int Add(
    KeyImplementation value
);
Remarks

This is Add, a member of class KeyImplementationCollection.

See Also
KeyImplementationCollection Class
Eco.Persistence.ORMapping Namespace


this Indexer

this Indexer

This is the overview for the this indexer overload.

Overload List
Name | Description
KeyImplementationCollection.this (int) | This is this, a member of class KeyImplementationCollection.
KeyImplementationCollection.this (string) | This is this, a member of class KeyImplementationCollection.


KeyImplementationCollection.this Indexer (int)

KeyImplementationCollection.this Indexer (int)
KeyImplementationCollection Class Eco.Persistence.ORMapping Namespace See Also
Collapse All
C#
public KeyImplementation this[
    int index
];
Remarks

This is this, a member of class KeyImplementationCollection.

See Also
KeyImplementationCollection Class
Eco.Persistence.ORMapping Namespace


KeyImplementationCollection.this Indexer (string)

KeyImplementationCollection.this Indexer (string)
KeyImplementationCollection Class Eco.Persistence.ORMapping Namespace See Also
Collapse All
C#
public KeyImplementation this[
    string name
];
Remarks

This is this, a member of class KeyImplementationCollection.

See Also
KeyImplementationCollection Class
Eco.Persistence.ORMapping Namespace


NamedDefinition Class

NamedDefinition Class
Inheritance Hierarchy See Also
Collapse All
C#
public class NamedDefinition : IHashBaseElement;
Remarks

This is class Eco.Persistence.ORMapping.NamedDefinition.

Inheritance Hierarchy
Eco.Persistence.ORMapping.NamedDefinition
    Eco.Persistence.ORMapping.AliasDefinition
    Eco.Persistence.ORMapping.ClassDefinition
    Eco.Persistence.ORMapping.ColumnDefinition
    Eco.Persistence.ORMapping.DatabaseDefinition
    Eco.Persistence.ORMapping.DiscriminatorDef
    Eco.Persistence.ORMapping.ForeignKeyDefinition
    Eco.Persistence.ORMapping.IndexDefinition
    Eco.Persistence.ORMapping.KeyDefinition
    Eco.Persistence.ORMapping.StructuralFeatureDefinition
    Eco.Persistence.ORMapping.TableDefinition
File

ORMappingDefinition.cs

See Also
Inheritance Hierarchy


NamedDefinition Methods

NamedDefinition Methods
Public Methods
Collapse All

The methods of the NamedDefinition class are listed here.

Public Methods
Name | Description
CleanName | This is CleanName, a member of class NamedDefinition.


NamedDefinition.CleanName Method

NamedDefinition.CleanName Method
NamedDefinition Class Eco.Persistence.ORMapping Namespace See Also
Collapse All
C#
public static string CleanName(
    string name
);
Remarks

This is CleanName, a member of class NamedDefinition.

See Also
NamedDefinition Class
Eco.Persistence.ORMapping Namespace


NamedDefinition Properties

NamedDefinition Properties
Public Properties
Collapse All

The properties of the NamedDefinition class are listed here.

Public Properties
Name | Description
Name | This is Name, a member of class NamedDefinition.


NamedDefinition.Name Property

NamedDefinition.Name Property
NamedDefinition Class Eco.Persistence.ORMapping Namespace See Also
Collapse All
C#
public virtual string Name;
Remarks

This is Name, a member of class NamedDefinition.

See Also
NamedDefinition Class
Eco.Persistence.ORMapping Namespace


ORMappingDefinition Class

ORMappingDefinition Class
Inheritance Hierarchy See Also
Collapse All
C#
public sealed class ORMappingDefinition;
Remarks

This is class Eco.Persistence.ORMapping.ORMappingDefinition.

Inheritance Hierarchy
Eco.Persistence.ORMapping.ORMappingDefinition
File

ORMappingDefinition.cs

See Also
Inheritance Hierarchy


ORMappingDefinition Methods

ORMappingDefinition Methods
Public Methods
Collapse All

The methods of the ORMappingDefinition class are listed here.

Public Methods
Name | Description
Error | This is Error, a member of class ORMappingDefinition.
FindDiscriminator | This is FindDiscriminator, a member of class ORMappingDefinition.
FindKeyDefinition | This is FindKeyDefinition, a member of class ORMappingDefinition.
FindPrimaryKeyDefinition | This is FindPrimaryKeyDefinition, a member of class ORMappingDefinition.
Merge | This is Merge, a member of class ORMappingDefinition.
Validate | This is Validate, a member of class ORMappingDefinition.
Warning | This is Warning, a member of class ORMappingDefinition.


ORMappingDefinition.Error Method

ORMappingDefinition.Error Method
ORMappingDefinition Class Eco.Persistence.ORMapping Namespace See Also
Collapse All
C#
public void Error(
    string msg
);
Remarks

This is Error, a member of class ORMappingDefinition.

See Also
ORMappingDefinition Class
Eco.Persistence.ORMapping Namespace


ORMappingDefinition.FindDiscriminator Method

ORMappingDefinition.FindDiscriminator Method
ORMappingDefinition Class Eco.Persistence.ORMapping Namespace See Also
Collapse All
C#
public static DiscriminatorDef FindDiscriminator(
    ClassDefinition c,
    string name
);
Remarks

This is FindDiscriminator, a member of class ORMappingDefinition.

See Also
ORMappingDefinition Class
Eco.Persistence.ORMapping Namespace


ORMappingDefinition.FindKeyDefinition Method

ORMappingDefinition.FindKeyDefinition Method
ORMappingDefinition Class Eco.Persistence.ORMapping Namespace See Also
Collapse All
C#
public static KeyDefinition FindKeyDefinition(
    ClassDefinition c,
    string keyName
);
Remarks

This is FindKeyDefinition, a member of class ORMappingDefinition.

See Also
ORMappingDefinition Class
Eco.Persistence.ORMapping Namespace


ORMappingDefinition.FindPrimaryKeyDefinition Method

ORMappingDefinition.FindPrimaryKeyDefinition Method
ORMappingDefinition Class Eco.Persistence.ORMapping Namespace See Also
Collapse All
C#
public KeyDefinition FindPrimaryKeyDefinition(
    ClassDefinition c
);
Remarks

This is FindPrimaryKeyDefinition, a member of class ORMappingDefinition.

See Also
ORMappingDefinition Class
Eco.Persistence.ORMapping Namespace


ORMappingDefinition.Merge Method

ORMappingDefinition.Merge Method
ORMappingDefinition Class Eco.Persistence.ORMapping Namespace See Also
Collapse All
C#
public void Merge(
    ORMappingDefinition def,
    string dbName
);
Remarks

This is Merge, a member of class ORMappingDefinition.

See Also
ORMappingDefinition Class
Eco.Persistence.ORMapping Namespace


ORMappingDefinition.Validate Method

ORMappingDefinition.Validate Method
ORMappingDefinition Class Eco.Persistence.ORMapping Namespace See Also
Collapse All
C#
public void Validate(
    SqlDatabaseConfig config,
    IEcoTypeSystem typeSystem
);
Remarks

This is Validate, a member of class ORMappingDefinition.

See Also
ORMappingDefinition Class
Eco.Persistence.ORMapping Namespace


ORMappingDefinition.Warning Method

ORMappingDefinition.Warning Method
ORMappingDefinition Class Eco.Persistence.ORMapping Namespace See Also
Collapse All
C#
public void Warning(
    string msg
);
Remarks

This is Warning, a member of class ORMappingDefinition.

See Also
ORMappingDefinition Class
Eco.Persistence.ORMapping Namespace


ORMappingDefinition Properties

ORMappingDefinition Properties
Public Properties
Collapse All

The properties of the ORMappingDefinition class are listed here.

Public Properties
Name | Description
Classes | This is Classes, a member of class ORMappingDefinition.
Databases | This is Databases, a member of class ORMappingDefinition.
DefaultDatabase | This is DefaultDatabase, a member of class ORMappingDefinition.
HasErrors | This is HasErrors, a member of class ORMappingDefinition.
HasWarnings | This is HasWarnings, a member of class ORMappingDefinition.
IsValidated | This is IsValidated, a member of class ORMappingDefinition.
Messages | This is Messages, a member of class ORMappingDefinition.
ValidatedOK | This is ValidatedOK, a member of class ORMappingDefinition.


ORMappingDefinition.Classes Property

ORMappingDefinition.Classes Property
ORMappingDefinition Class Eco.Persistence.ORMapping Namespace See Also
Collapse All
C#
public ClassCollection Classes;
Remarks

This is Classes, a member of class ORMappingDefinition.

See Also
ORMappingDefinition Class
Eco.Persistence.ORMapping Namespace


ORMappingDefinition.Databases Property

ORMappingDefinition.Databases Property
ORMappingDefinition Class Eco.Persistence.ORMapping Namespace See Also
Collapse All
C#
public DatabaseCollection Databases;
Remarks

This is Databases, a member of class ORMappingDefinition.

See Also
ORMappingDefinition Class
Eco.Persistence.ORMapping Namespace


ORMappingDefinition.DefaultDatabase Property

ORMappingDefinition.DefaultDatabase Property
ORMappingDefinition Class Eco.Persistence.ORMapping Namespace See Also
Collapse All
C#
public DatabaseDefinition DefaultDatabase;
Remarks

This is DefaultDatabase, a member of class ORMappingDefinition.

See Also
ORMappingDefinition Class
Eco.Persistence.ORMapping Namespace


ORMappingDefinition.HasErrors Property

ORMappingDefinition.HasErrors Property
ORMappingDefinition Class Eco.Persistence.ORMapping Namespace See Also
Collapse All
C#
public bool HasErrors;
Remarks

This is HasErrors, a member of class ORMappingDefinition.

See Also
ORMappingDefinition Class
Eco.Persistence.ORMapping Namespace


ORMappingDefinition.HasWarnings Property

ORMappingDefinition.HasWarnings Property
ORMappingDefinition Class Eco.Persistence.ORMapping Namespace See Also
Collapse All
C#
public bool HasWarnings;
Remarks

This is HasWarnings, a member of class ORMappingDefinition.

See Also
ORMappingDefinition Class
Eco.Persistence.ORMapping Namespace


ORMappingDefinition.IsValidated Property

ORMappingDefinition.IsValidated Property
ORMappingDefinition Class Eco.Persistence.ORMapping Namespace See Also
Collapse All
C#
public bool IsValidated;
Remarks

This is IsValidated, a member of class ORMappingDefinition.

See Also
ORMappingDefinition Class
Eco.Persistence.ORMapping Namespace


ORMappingDefinition.Messages Property

ORMappingDefinition.Messages Property
ORMappingDefinition Class Eco.Persistence.ORMapping Namespace See Also
Collapse All
C#
public IList<string> Messages;
Remarks

This is Messages, a member of class ORMappingDefinition.

See Also
ORMappingDefinition Class
Eco.Persistence.ORMapping Namespace


ORMappingDefinition.ValidatedOK Property

ORMappingDefinition.ValidatedOK Property
ORMappingDefinition Class Eco.Persistence.ORMapping Namespace See Also
Collapse All
C#
public bool ValidatedOK;
Remarks

This is ValidatedOK, a member of class ORMappingDefinition.

See Also
ORMappingDefinition Class
Eco.Persistence.ORMapping Namespace


ORMappingValidator Class

ORMappingValidator Class
Inheritance Hierarchy See Also
Collapse All
C#
public class ORMappingValidator;
Remarks

This is class Eco.Persistence.ORMapping.ORMappingValidator.

Inheritance Hierarchy
Eco.Persistence.ORMapping.ORMappingValidator
File

ORMappingValidator.cs

See Also
Inheritance Hierarchy


ORMappingValidator.ORMappingValidator Constructor

ORMappingValidator.ORMappingValidator Constructor
ORMappingValidator Class Eco.Persistence.ORMapping Namespace See Also
Collapse All
C#
public ORMappingValidator(
    ORMappingDefinition mapping,
    IEcoTypeSystem typeSystem,
    SqlDatabaseConfig config
);
Remarks

This is ORMappingValidator, a member of class ORMappingValidator.

See Also
ORMappingValidator Class
Eco.Persistence.ORMapping Namespace


ORMappingValidator Methods

ORMappingValidator Methods
Public Methods
Collapse All

The methods of the ORMappingValidator class are listed here.

Public Methods
Name | Description
ValidateMapping | This is ValidateMapping, a member of class ORMappingValidator.


ORMappingValidator.ValidateMapping Method

ORMappingValidator.ValidateMapping Method
ORMappingValidator Class Eco.Persistence.ORMapping Namespace See Also
Collapse All
C#
public void ValidateMapping();
Remarks

This is ValidateMapping, a member of class ORMappingValidator.

See Also
ORMappingValidator Class
Eco.Persistence.ORMapping Namespace


ORMappingValidator Properties

ORMappingValidator Properties
Public Properties
Collapse All

The properties of the ORMappingValidator class are listed here.

Public Properties
Name | Description
Config | This is Config, a member of class ORMappingValidator.
Mapping | This is Mapping, a member of class ORMappingValidator.
TypeSystem | This is TypeSystem, a member of class ORMappingValidator.


ORMappingValidator.Config Property

ORMappingValidator.Config Property
ORMappingValidator Class Eco.Persistence.ORMapping Namespace See Also
Collapse All
C#
public SqlDatabaseConfig Config;
Remarks

This is Config, a member of class ORMappingValidator.

See Also
ORMappingValidator Class
Eco.Persistence.ORMapping Namespace


ORMappingValidator.Mapping Property

ORMappingValidator.Mapping Property
ORMappingValidator Class Eco.Persistence.ORMapping Namespace See Also
Collapse All
C#
public ORMappingDefinition Mapping;
Remarks

This is Mapping, a member of class ORMappingValidator.

See Also
ORMappingValidator Class
Eco.Persistence.ORMapping Namespace


ORMappingValidator.TypeSystem Property

ORMappingValidator.TypeSystem Property
ORMappingValidator Class Eco.Persistence.ORMapping Namespace See Also
Collapse All
C#
public IEcoTypeSystem TypeSystem;
Remarks

This is TypeSystem, a member of class ORMappingValidator.

See Also
ORMappingValidator Class
Eco.Persistence.ORMapping Namespace


ORMappingXmlGenerator Class

ORMappingXmlGenerator Class
Inheritance Hierarchy See Also
Collapse All
C#
public sealed class ORMappingXmlGenerator;
Remarks

This is class Eco.Persistence.ORMapping.ORMappingXmlGenerator.

Inheritance Hierarchy
Eco.Persistence.ORMapping.ORMappingXmlGenerator
File

ORMappingXmlGenerator.cs

See Also
Inheritance Hierarchy


ORMappingXmlGenerator Methods

ORMappingXmlGenerator Methods
Public Methods
Collapse All

The methods of the ORMappingXmlGenerator class are listed here.

Public Methods
Name | Description
GenerateMappingXml | This is the overview for the GenerateMappingXml method overload.
GenerateMappingXmlString | This is GenerateMappingXmlString, a member of class ORMappingXmlGenerator.


GenerateMappingXml Method

GenerateMappingXml Method

This is the overview for the GenerateMappingXml method overload.

Overload List
Name | Description
ORMappingXmlGenerator.GenerateMappingXml (ORMappingDefinition) |
ORMappingXmlGenerator.GenerateMappingXml (ORMappingDefinition, string) | This is GenerateMappingXml, a member of class ORMappingXmlGenerator.


ORMappingXmlGenerator.GenerateMappingXml Method (ORMappingDefinition)

ORMappingXmlGenerator.GenerateMappingXml Method (ORMappingDefinition)
ORMappingXmlGenerator Class Eco.Persistence.ORMapping Namespace See Also
Collapse All
C#
public XmlDocument GenerateMappingXml(
    ORMappingDefinition mapping
);
Exceptions
Exceptions | Description
ArgumentNullException | Thrown if mapping is null
See Also
ORMappingXmlGenerator Class
Eco.Persistence.ORMapping Namespace


ORMappingXmlGenerator.GenerateMappingXml Method (ORMappingDefinition, string)

ORMappingXmlGenerator.GenerateMappingXml Method (ORMappingDefinition, string)
ORMappingXmlGenerator Class Eco.Persistence.ORMapping Namespace See Also
Collapse All
C#
public void GenerateMappingXml(
    ORMappingDefinition mapping,
    string fileName
);
Remarks

This is GenerateMappingXml, a member of class ORMappingXmlGenerator.

See Also
ORMappingXmlGenerator Class
Eco.Persistence.ORMapping Namespace


ORMappingXmlGenerator.GenerateMappingXmlString Method

ORMappingXmlGenerator.GenerateMappingXmlString Method
ORMappingXmlGenerator Class Eco.Persistence.ORMapping Namespace See Also
Collapse All
C#
public string GenerateMappingXmlString(
    ORMappingDefinition mapping
);
Remarks

This is GenerateMappingXmlString, a member of class ORMappingXmlGenerator.

See Also
ORMappingXmlGenerator Class
Eco.Persistence.ORMapping Namespace


ORMappingXmlReader Class

ORMappingXmlReader Class
Inheritance Hierarchy See Also
Collapse All
C#
public sealed class ORMappingXmlReader;
Remarks

This is class Eco.Persistence.ORMapping.ORMappingXmlReader.

Inheritance Hierarchy
Eco.Persistence.ORMapping.ORMappingXmlReader
File

ORMappingXmlReader.cs

See Also
Inheritance Hierarchy


ORMappingXmlReader.ORMappingXmlReader Constructor

ORMappingXmlReader.ORMappingXmlReader Constructor
ORMappingXmlReader Class Eco.Persistence.ORMapping Namespace See Also
Collapse All
C#
public ORMappingXmlReader();
Remarks

This is ORMappingXmlReader, a member of class ORMappingXmlReader.

See Also
ORMappingXmlReader Class
Eco.Persistence.ORMapping Namespace


ORMappingXmlReader Methods

ORMappingXmlReader Methods
Public Methods
Collapse All

The methods of the ORMappingXmlReader class are listed here.

Public Methods
Name | Description
ReadAliasPass1 |
ReadAliasPass3 | This is ReadAliasPass3, a member of class ORMappingXmlReader.
ReadAttribute | This is ReadAttribute, a member of class ORMappingXmlReader.
ReadClassPass1 | This is ReadClassPass1, a member of class ORMappingXmlReader.
ReadClassPass3 | This is ReadClassPass3, a member of class ORMappingXmlReader.
ReadClassSuperClasses | This is ReadClassSuperClasses, a member of class ORMappingXmlReader.
ReadDiscriminatorDef | This is ReadDiscriminatorDef, a member of class ORMappingXmlReader.
ReadDiscriminatorImpl | This is ReadDiscriminatorImpl, a member of class ORMappingXmlReader.
ReadDiscriminatorValue | This is ReadDiscriminatorValue, a member of class ORMappingXmlReader.
ReadKeyDefinition | This is ReadKeyDefinition, a member of class ORMappingXmlReader.
ReadKeyImpl | This is ReadKeyImpl, a member of class ORMappingXmlReader.
ReadMappingXml | This is the overview for the ReadMappingXml method overload.
ReadSingleLink | This is ReadSingleLink, a member of class ORMappingXmlReader.


ORMappingXmlReader.ReadAliasPass1 Method

ORMappingXmlReader.ReadAliasPass1 Method
ORMappingXmlReader Class Eco.Persistence.ORMapping Namespace See Also
Collapse All
C#
public void ReadAliasPass1(
    XmlNode node,
    ClassDefinition classDef
);
Exceptions
Exceptions | Description
ArgumentNullException | Thrown if classDef is null
See Also
ORMappingXmlReader Class
Eco.Persistence.ORMapping Namespace


ORMappingXmlReader.ReadAliasPass3 Method

ORMappingXmlReader.ReadAliasPass3 Method
ORMappingXmlReader Class Eco.Persistence.ORMapping Namespace See Also
Collapse All
C#
public void ReadAliasPass3(
    XmlNode node,
    ClassDefinition classDef
);
Remarks

This is ReadAliasPass3, a member of class ORMappingXmlReader.

See Also
ORMappingXmlReader Class
Eco.Persistence.ORMapping Namespace


ORMappingXmlReader.ReadAttribute Method

ORMappingXmlReader.ReadAttribute Method
ORMappingXmlReader Class Eco.Persistence.ORMapping Namespace See Also
Collapse All
C#
public void ReadAttribute(
    XmlNode node,
    ClassDefinition classDef
);
Remarks

This is ReadAttribute, a member of class ORMappingXmlReader.

See Also
ORMappingXmlReader Class
Eco.Persistence.ORMapping Namespace


ORMappingXmlReader.ReadClassPass1 Method

ORMappingXmlReader.ReadClassPass1 Method
ORMappingXmlReader Class Eco.Persistence.ORMapping Namespace See Also
Collapse All
C#
public void ReadClassPass1(
    XmlNode node
);
Remarks

This is ReadClassPass1, a member of class ORMappingXmlReader.

See Also
ORMappingXmlReader Class
Eco.Persistence.ORMapping Namespace


ORMappingXmlReader.ReadClassPass3 Method

ORMappingXmlReader.ReadClassPass3 Method
ORMappingXmlReader Class Eco.Persistence.ORMapping Namespace See Also
Collapse All
C#
public void ReadClassPass3(
    XmlNode node
);
Remarks

This is ReadClassPass3, a member of class ORMappingXmlReader.

See Also
ORMappingXmlReader Class
Eco.Persistence.ORMapping Namespace


ORMappingXmlReader.ReadClassSuperClasses Method

ORMappingXmlReader.ReadClassSuperClasses Method
ORMappingXmlReader Class Eco.Persistence.ORMapping Namespace See Also
Collapse All
C#
public void ReadClassSuperClasses(
    XmlNode node
);
Remarks

This is ReadClassSuperClasses, a member of class ORMappingXmlReader.

See Also
ORMappingXmlReader Class
Eco.Persistence.ORMapping Namespace


ORMappingXmlReader.ReadDiscriminatorDef Method

ORMappingXmlReader.ReadDiscriminatorDef Method
ORMappingXmlReader Class Eco.Persistence.ORMapping Namespace See Also
Collapse All
C#
public void ReadDiscriminatorDef(
    XmlNode node,
    ClassDefinition classDef
);
Remarks

This is ReadDiscriminatorDef, a member of class ORMappingXmlReader.

See Also
ORMappingXmlReader Class
Eco.Persistence.ORMapping Namespace


ORMappingXmlReader.ReadDiscriminatorImpl Method

ORMappingXmlReader.ReadDiscriminatorImpl Method
ORMappingXmlReader Class Eco.Persistence.ORMapping Namespace See Also
Collapse All
C#
public void ReadDiscriminatorImpl(
    XmlNode node,
    AliasDefinition aliasDef,
    ClassDefinition classDef
);
Remarks

This is ReadDiscriminatorImpl, a member of class ORMappingXmlReader.

See Also
ORMappingXmlReader Class
Eco.Persistence.ORMapping Namespace


ORMappingXmlReader.ReadDiscriminatorValue Method

ORMappingXmlReader.ReadDiscriminatorValue Method
ORMappingXmlReader Class Eco.Persistence.ORMapping Namespace See Also
Collapse All
C#
public void ReadDiscriminatorValue(
    XmlNode node,
    ClassDefinition classDef
);
Remarks

This is ReadDiscriminatorValue, a member of class ORMappingXmlReader.

See Also
ORMappingXmlReader Class
Eco.Persistence.ORMapping Namespace


ORMappingXmlReader.ReadKeyDefinition Method

ORMappingXmlReader.ReadKeyDefinition Method
ORMappingXmlReader Class Eco.Persistence.ORMapping Namespace See Also
Collapse All
C#
public void ReadKeyDefinition(
    XmlNode node,
    ClassDefinition classDef
);
Remarks

This is ReadKeyDefinition, a member of class ORMappingXmlReader.

See Also
ORMappingXmlReader Class
Eco.Persistence.ORMapping Namespace


ORMappingXmlReader.ReadKeyImpl Method

ORMappingXmlReader.ReadKeyImpl Method
ORMappingXmlReader Class Eco.Persistence.ORMapping Namespace See Also
Collapse All
C#
public void ReadKeyImpl(
    XmlNode node,
    ClassDefinition classDef,
    AliasDefinition aliasDef
);
Remarks

This is ReadKeyImpl, a member of class ORMappingXmlReader.

See Also
ORMappingXmlReader Class
Eco.Persistence.ORMapping Namespace


ReadMappingXml Method

ReadMappingXml Method

This is the overview for the ReadMappingXml method overload.

Overload List
Name | Description
ORMappingXmlReader.ReadMappingXml (string) |
ORMappingXmlReader.ReadMappingXml (XmlDocument) |


ORMappingXmlReader.ReadMappingXml Method (XmlDocument)

ORMappingXmlReader.ReadMappingXml Method (XmlDocument)
ORMappingXmlReader Class Eco.Persistence.ORMapping Namespace See Also
Collapse All
C#
public ORMappingDefinition ReadMappingXml(
    XmlDocument doc
);
Exceptions
Exceptions | Description
ArgumentNullException | Thrown if doc is null
See Also
ORMappingXmlReader Class
Eco.Persistence.ORMapping Namespace


ORMappingXmlReader.ReadMappingXml Method (string)

ORMappingXmlReader.ReadMappingXml Method (string)
ORMappingXmlReader Class Eco.Persistence.ORMapping Namespace See Also
Collapse All
C#
public ORMappingDefinition ReadMappingXml(
    string fileName
);
Exceptions
Exceptions | Description
ArgumentNullException | Thrown if fileName is null
See Also
ORMappingXmlReader Class
Eco.Persistence.ORMapping Namespace


ORMappingXmlReader.ReadSingleLink Method

ORMappingXmlReader.ReadSingleLink Method
ORMappingXmlReader Class Eco.Persistence.ORMapping Namespace See Also
Collapse All
C#
public void ReadSingleLink(
    XmlNode node,
    ClassDefinition classDef
);
Remarks

This is ReadSingleLink, a member of class ORMappingXmlReader.

See Also
ORMappingXmlReader Class
Eco.Persistence.ORMapping Namespace


ORMappingXmlReader Properties

ORMappingXmlReader Properties
Public Properties
Collapse All

The properties of the ORMappingXmlReader class are listed here.

Public Properties
Name | Description
Mapping | This is Mapping, a member of class ORMappingXmlReader.


ORMappingXmlReader.Mapping Property

ORMappingXmlReader.Mapping Property
ORMappingXmlReader Class Eco.Persistence.ORMapping Namespace See Also
Collapse All
C#
public ORMappingDefinition Mapping;
Remarks

This is Mapping, a member of class ORMappingXmlReader.

See Also
ORMappingXmlReader Class
Eco.Persistence.ORMapping Namespace


SingleLinkDefinition Class

SingleLinkDefinition Class
Inheritance Hierarchy See Also
Collapse All
C#
public sealed class SingleLinkDefinition : StructuralFeatureDefinition;
Remarks

This is class Eco.Persistence.ORMapping.SingleLinkDefinition.

Inheritance Hierarchy
Eco.Persistence.ORMapping.NamedDefinition
    Eco.Persistence.ORMapping.StructuralFeatureDefinition
        Eco.Persistence.ORMapping.SingleLinkDefinition
File

ORMappingDefinition.cs

See Also
Inheritance Hierarchy


SingleLinkDefinition Properties

SingleLinkDefinition Properties
Public Properties
Collapse All

The properties of the SingleLinkDefinition class are listed here.

Public Properties
Name | Description
IsConstrained | This is IsConstrained, a member of class SingleLinkDefinition.
Key | This is Key, a member of class SingleLinkDefinition.
KeyName | This is KeyName, a member of class SingleLinkDefinition.
Mandatory | This is Mandatory, a member of class SingleLinkDefinition.
OrderColumn | This is OrderColumn, a member of class SingleLinkDefinition.
OtherEnd | This is OtherEnd, a member of class SingleLinkDefinition.
OtherEndName | This is OtherEndName, a member of class SingleLinkDefinition.


SingleLinkDefinition.IsConstrained Property

SingleLinkDefinition.IsConstrained Property
SingleLinkDefinition Class Eco.Persistence.ORMapping Namespace See Also
Collapse All
C#
public bool IsConstrained;
Remarks

This is IsConstrained, a member of class SingleLinkDefinition.

See Also
SingleLinkDefinition Class
Eco.Persistence.ORMapping Namespace


SingleLinkDefinition.Key Property

SingleLinkDefinition.Key Property
SingleLinkDefinition Class Eco.Persistence.ORMapping Namespace See Also
Collapse All
C#
public KeyDefinition Key;
Remarks

This is Key, a member of class SingleLinkDefinition.

See Also
SingleLinkDefinition Class
Eco.Persistence.ORMapping Namespace


SingleLinkDefinition.KeyName Property

SingleLinkDefinition.KeyName Property
SingleLinkDefinition Class Eco.Persistence.ORMapping Namespace See Also
Collapse All
C#
public string KeyName;
Remarks

This is KeyName, a member of class SingleLinkDefinition.

See Also
SingleLinkDefinition Class
Eco.Persistence.ORMapping Namespace


SingleLinkDefinition.Mandatory Property

SingleLinkDefinition.Mandatory Property
SingleLinkDefinition Class Eco.Persistence.ORMapping Namespace See Also
Collapse All
C#
public bool Mandatory;
Remarks

This is Mandatory, a member of class SingleLinkDefinition.

See Also
SingleLinkDefinition Class
Eco.Persistence.ORMapping Namespace


SingleLinkDefinition.OrderColumn Property

SingleLinkDefinition.OrderColumn Property
SingleLinkDefinition Class Eco.Persistence.ORMapping Namespace See Also
Collapse All
C#
public ColumnReference OrderColumn;
Remarks

This is OrderColumn, a member of class SingleLinkDefinition.

See Also
SingleLinkDefinition Class
Eco.Persistence.ORMapping Namespace


SingleLinkDefinition.OtherEnd Property

SingleLinkDefinition.OtherEnd Property
SingleLinkDefinition Class Eco.Persistence.ORMapping Namespace See Also
Collapse All
C#
public ClassDefinition OtherEnd;
Remarks

This is OtherEnd, a member of class SingleLinkDefinition.

See Also
SingleLinkDefinition Class
Eco.Persistence.ORMapping Namespace


SingleLinkDefinition.OtherEndName Property

SingleLinkDefinition.OtherEndName Property
SingleLinkDefinition Class Eco.Persistence.ORMapping Namespace See Also
Collapse All
C#
public string OtherEndName;
Remarks

This is OtherEndName, a member of class SingleLinkDefinition.

See Also
SingleLinkDefinition Class
Eco.Persistence.ORMapping Namespace


StructuralFeatureDefinition Class

StructuralFeatureDefinition Class
Inheritance Hierarchy See Also
Collapse All
C#
public class StructuralFeatureDefinition : NamedDefinition;
Remarks

This is class Eco.Persistence.ORMapping.StructuralFeatureDefinition.

Inheritance Hierarchy
Eco.Persistence.ORMapping.NamedDefinition
    Eco.Persistence.ORMapping.StructuralFeatureDefinition
        Eco.Persistence.ORMapping.AttributeDefinition
        Eco.Persistence.ORMapping.SingleLinkDefinition
File

ORMappingDefinition.cs

See Also
Inheritance Hierarchy


StructuralFeatureDefinition Properties

StructuralFeatureDefinition Properties
Public Properties
Collapse All

The properties of the StructuralFeatureDefinition class are listed here.

Public Properties
Name | Description
Alias | This is Alias, a member of class StructuralFeatureDefinition.
Columns | This is Columns, a member of class StructuralFeatureDefinition.
ColumnsAsString | This is ColumnsAsString, a member of class StructuralFeatureDefinition.
ColumnTypesAsString | This is ColumnTypesAsString, a member of class StructuralFeatureDefinition.
Pseudo | This is Pseudo, a member of class StructuralFeatureDefinition.
ReadonlyColumns | This is ReadonlyColumns, a member of class StructuralFeatureDefinition.


StructuralFeatureDefinition.Alias Property

StructuralFeatureDefinition.Alias Property
StructuralFeatureDefinition Class Eco.Persistence.ORMapping Namespace See Also
Collapse All
C#
public AliasDefinition Alias;
Remarks

This is Alias, a member of class StructuralFeatureDefinition.

See Also
StructuralFeatureDefinition Class
Eco.Persistence.ORMapping Namespace


StructuralFeatureDefinition.Columns Property

StructuralFeatureDefinition.Columns Property
StructuralFeatureDefinition Class Eco.Persistence.ORMapping Namespace See Also
Collapse All
C#
public ColumnCollection Columns;
Remarks

This is Columns, a member of class StructuralFeatureDefinition.

See Also
StructuralFeatureDefinition Class
Eco.Persistence.ORMapping Namespace


StructuralFeatureDefinition.ColumnsAsString Property

StructuralFeatureDefinition.ColumnsAsString Property
StructuralFeatureDefinition Class Eco.Persistence.ORMapping Namespace See Also
Collapse All
C#
public string ColumnsAsString;
Remarks

This is ColumnsAsString, a member of class StructuralFeatureDefinition.

See Also
StructuralFeatureDefinition Class
Eco.Persistence.ORMapping Namespace


StructuralFeatureDefinition.ColumnTypesAsString Property

StructuralFeatureDefinition.ColumnTypesAsString Property
StructuralFeatureDefinition Class Eco.Persistence.ORMapping Namespace See Also
Collapse All
C#
public string ColumnTypesAsString;
Remarks

This is ColumnTypesAsString, a member of class StructuralFeatureDefinition.

See Also
StructuralFeatureDefinition Class
Eco.Persistence.ORMapping Namespace


StructuralFeatureDefinition.Pseudo Property

StructuralFeatureDefinition.Pseudo Property
StructuralFeatureDefinition Class Eco.Persistence.ORMapping Namespace See Also
Collapse All
C#
public virtual bool Pseudo;
Remarks

This is Pseudo, a member of class StructuralFeatureDefinition.

See Also
StructuralFeatureDefinition Class
Eco.Persistence.ORMapping Namespace


StructuralFeatureDefinition.ReadonlyColumns Property

StructuralFeatureDefinition.ReadonlyColumns Property
StructuralFeatureDefinition Class Eco.Persistence.ORMapping Namespace See Also
Collapse All
C#
public ColumnCollection ReadonlyColumns;
Remarks

This is ReadonlyColumns, a member of class StructuralFeatureDefinition.

See Also
StructuralFeatureDefinition Class
Eco.Persistence.ORMapping Namespace


TableCollection Class

TableCollection Class
Inheritance Hierarchy See Also
Collapse All
C#
public sealed class TableCollection : Eco.Collections.CollectionBase;
Remarks

This is class Eco.Persistence.ORMapping.TableCollection.

Inheritance Hierarchy
Eco.Persistence.ORMapping.TableCollection
File

ORMappingDefinition.cs

See Also
Inheritance Hierarchy


TableCollection Methods

TableCollection Methods
Public Methods
Collapse All

The methods of the TableCollection class are listed here.

Public Methods
Name | Description
Add |
this | This is the overview for the this indexer overload.


TableCollection.Add Method

TableCollection.Add Method
TableCollection Class Eco.Persistence.ORMapping Namespace See Also
Collapse All
C#
public void Add(
    TableDefinition value
);
Exceptions
Exceptions | Description
ArgumentNullException | Thrown if value is null
See Also
TableCollection Class
Eco.Persistence.ORMapping Namespace


this Indexer

this Indexer

This is the overview for the this indexer overload.

Overload List
Name | Description
TableCollection.this (int) | This is this, a member of class TableCollection.
TableCollection.this (string) | This is this, a member of class TableCollection.


TableCollection.this Indexer (int)

TableCollection.this Indexer (int)
TableCollection Class Eco.Persistence.ORMapping Namespace See Also
Collapse All
C#
public TableDefinition this[
    int index
];
Remarks

This is this, a member of class TableCollection.

See Also
TableCollection Class
Eco.Persistence.ORMapping Namespace


TableCollection.this Indexer (string)

TableCollection.this Indexer (string)
TableCollection Class Eco.Persistence.ORMapping Namespace See Also
Collapse All
C#
public TableDefinition this[
    string name
];
Remarks

This is this, a member of class TableCollection.

See Also
TableCollection Class
Eco.Persistence.ORMapping Namespace


TableDefinition Class

TableDefinition Class
Inheritance Hierarchy See Also
Collapse All
C#
public sealed class TableDefinition : NamedDefinition;
Remarks

This is class Eco.Persistence.ORMapping.TableDefinition.

Inheritance Hierarchy
Eco.Persistence.ORMapping.NamedDefinition
    Eco.Persistence.ORMapping.TableDefinition
File

ORMappingDefinition.cs

See Also
Inheritance Hierarchy


TableDefinition.TableDefinition Constructor

TableDefinition.TableDefinition Constructor
TableDefinition Class Eco.Persistence.ORMapping Namespace See Also
Collapse All
C#
public TableDefinition(
    DatabaseDefinition db,
    string tableName
);
Exceptions
Exceptions | Description
ArgumentNullException | Thrown if db is null
See Also
TableDefinition Class
Eco.Persistence.ORMapping Namespace


TableDefinition Methods

TableDefinition Methods
Public Methods
Collapse All

The methods of the TableDefinition class are listed here.

Public Methods
Name | Description
EnsureColumn | This is EnsureColumn, a member of class TableDefinition.
GetColumn | This is GetColumn, a member of class TableDefinition.


TableDefinition.EnsureColumn Method

TableDefinition.EnsureColumn Method
TableDefinition Class Eco.Persistence.ORMapping Namespace See Also
Collapse All
C#
public ColumnDefinition EnsureColumn(
    string columnName
);
Remarks

This is EnsureColumn, a member of class TableDefinition.

See Also
TableDefinition Class
Eco.Persistence.ORMapping Namespace


TableDefinition.GetColumn Method

TableDefinition.GetColumn Method
TableDefinition Class Eco.Persistence.ORMapping Namespace See Also
Collapse All
C#
public ColumnDefinition GetColumn(
    string columnName
);
Remarks

This is GetColumn, a member of class TableDefinition.

See Also
TableDefinition Class
Eco.Persistence.ORMapping Namespace


TableDefinition Properties

TableDefinition Properties
Public Properties
Collapse All

The properties of the TableDefinition class are listed here.

Public Properties
Name | Description
Columns | This is Columns, a member of class TableDefinition.
Database | This is Database, a member of class TableDefinition.
ForeignKeys | This is ForeignKeys, a member of class TableDefinition.
HasPrimaryKeyIndex | This is HasPrimaryKeyIndex, a member of class TableDefinition.
Indices | This is Indices, a member of class TableDefinition.
PrimaryKeyIndex | This is PrimaryKeyIndex, a member of class TableDefinition.
SqlName | This is SqlName, a member of class TableDefinition.


TableDefinition.Columns Property

TableDefinition.Columns Property
TableDefinition Class Eco.Persistence.ORMapping Namespace See Also
Collapse All
C#
public ColumnCollection Columns;
Remarks

This is Columns, a member of class TableDefinition.

See Also
TableDefinition Class
Eco.Persistence.ORMapping Namespace


TableDefinition.Database Property

TableDefinition.Database Property
TableDefinition Class Eco.Persistence.ORMapping Namespace See Also
Collapse All
C#
public DatabaseDefinition Database;
Remarks

This is Database, a member of class TableDefinition.

See Also
TableDefinition Class
Eco.Persistence.ORMapping Namespace


TableDefinition.ForeignKeys Property

TableDefinition.ForeignKeys Property
TableDefinition Class Eco.Persistence.ORMapping Namespace See Also
Collapse All
C#
public ForeignKeyCollection ForeignKeys;
Remarks

This is ForeignKeys, a member of class TableDefinition.

See Also
TableDefinition Class
Eco.Persistence.ORMapping Namespace


TableDefinition.HasPrimaryKeyIndex Property

TableDefinition.HasPrimaryKeyIndex Property
TableDefinition Class Eco.Persistence.ORMapping Namespace See Also
Collapse All
C#
public bool HasPrimaryKeyIndex;
Remarks

This is HasPrimaryKeyIndex, a member of class TableDefinition.

See Also
TableDefinition Class
Eco.Persistence.ORMapping Namespace


TableDefinition.Indices Property

TableDefinition.Indices Property
TableDefinition Class Eco.Persistence.ORMapping Namespace See Also
Collapse All
C#
public IndexCollection Indices;
Remarks

This is Indices, a member of class TableDefinition.

See Also
TableDefinition Class
Eco.Persistence.ORMapping Namespace


TableDefinition.PrimaryKeyIndex Property

TableDefinition.PrimaryKeyIndex Property
TableDefinition Class Eco.Persistence.ORMapping Namespace See Also
Collapse All
C#
public IndexDefinition PrimaryKeyIndex;
Remarks

This is PrimaryKeyIndex, a member of class TableDefinition.

See Also
TableDefinition Class
Eco.Persistence.ORMapping Namespace


TableDefinition.SqlName Property

TableDefinition.SqlName Property
TableDefinition Class Eco.Persistence.ORMapping Namespace See Also
Collapse All
C#
public string SqlName;
Remarks

This is SqlName, a member of class TableDefinition.

See Also
TableDefinition Class
Eco.Persistence.ORMapping Namespace


IORMappingProvider Interface

IORMappingProvider Interface
Inheritance Hierarchy See Also
Collapse All

Summary description for Class.

C#
public interface IORMappingProvider;
Inheritance Hierarchy
Eco.Persistence.ORMapping.IORMappingProvider
    Eco.Persistence.ORMapping.DbMappingProvider
    Eco.Persistence.ORMapping.DefaultORMappingBuilder
    Eco.Persistence.ORMapping.FileMappingProvider
File

ORMappingProvider.cs

See Also
Inheritance Hierarchy


IORMappingProvider Methods

IORMappingProvider Methods
Public Methods
Collapse All

The methods of the IORMappingProvider class are listed here.

Public Methods
Name | Description
Initialize | This is Initialize, a member of class IORMappingProvider.
PostCreateDb | This is PostCreateDb, a member of class IORMappingProvider.
PostEvolveDb | This is PostEvolveDb, a member of class IORMappingProvider.
PostEvolveDbScript | This is PostEvolveDbScript, a member of class IORMappingProvider.
SaveMappingInfo | This is SaveMappingInfo, a member of class IORMappingProvider.
SystemTableNames | This is SystemTableNames, a member of class IORMappingProvider.


IORMappingProvider.Initialize Method

IORMappingProvider.Initialize Method
IORMappingProvider Interface Eco.Persistence.ORMapping Namespace See Also
Collapse All
C#
void Initialize(
    IEcoTypeSystem typeSystem,
    IDatabase db,
    SqlDatabaseConfig config,
    bool addMissingTypes
);
Remarks

This is Initialize, a member of class IORMappingProvider.

See Also
IORMappingProvider Interface
Eco.Persistence.ORMapping Namespace


IORMappingProvider.PostCreateDb Method

IORMappingProvider.PostCreateDb Method
IORMappingProvider Interface Eco.Persistence.ORMapping Namespace See Also
Collapse All
C#
void PostCreateDb(
    IDatabase db,
    SqlDatabaseConfig sqlDatabaseConfig,
    ORMappingDefinition newMapping
);
Remarks

This is PostCreateDb, a member of class IORMappingProvider.

See Also
IORMappingProvider Interface
Eco.Persistence.ORMapping Namespace


IORMappingProvider.PostEvolveDb Method

IORMappingProvider.PostEvolveDb Method
IORMappingProvider Interface Eco.Persistence.ORMapping Namespace See Also
Collapse All
C#
void PostEvolveDb(
    IDatabase db,
    SqlDatabaseConfig sqlDatabaseConfig,
    ORMappingDefinition newMapping
);
Remarks

This is PostEvolveDb, a member of class IORMappingProvider.

See Also
IORMappingProvider Interface
Eco.Persistence.ORMapping Namespace


IORMappingProvider.PostEvolveDbScript Method

IORMappingProvider.PostEvolveDbScript Method
IORMappingProvider Interface Eco.Persistence.ORMapping Namespace See Also
Collapse All
C#
void PostEvolveDbScript(
    IDatabase db,
    SqlDatabaseConfig sqlDatabaseConfig,
    ORMappingDefinition newMapping,
    IList<string> script
);
Remarks

This is PostEvolveDbScript, a member of class IORMappingProvider.

See Also
IORMappingProvider Interface
Eco.Persistence.ORMapping Namespace


IORMappingProvider.SaveMappingInfo Method

IORMappingProvider.SaveMappingInfo Method
IORMappingProvider Interface Eco.Persistence.ORMapping Namespace See Also
Collapse All
C#
void SaveMappingInfo(
    IDatabase db,
    SqlDatabaseConfig sqlDatabaseConfig,
    ORMappingDefinition newMapping
);
Remarks

This is SaveMappingInfo, a member of class IORMappingProvider.

See Also
IORMappingProvider Interface
Eco.Persistence.ORMapping Namespace


IORMappingProvider.SystemTableNames Method

IORMappingProvider.SystemTableNames Method
IORMappingProvider Interface Eco.Persistence.ORMapping Namespace See Also
Collapse All
C#
IList<string> SystemTableNames(
    SqlDatabaseConfig config
);
Remarks

This is SystemTableNames, a member of class IORMappingProvider.

See Also
IORMappingProvider Interface
Eco.Persistence.ORMapping Namespace


IORMappingProvider Properties

IORMappingProvider Properties
Public Properties
Collapse All

The properties of the IORMappingProvider class are listed here.

Public Properties
Name | Description
Mapping | This is Mapping, a member of class IORMappingProvider.


IORMappingProvider.Mapping Property

IORMappingProvider.Mapping Property
IORMappingProvider Interface Eco.Persistence.ORMapping Namespace See Also
Collapse All
C#
ORMappingDefinition Mapping;
Remarks

This is Mapping, a member of class IORMappingProvider.

See Also
IORMappingProvider Interface
Eco.Persistence.ORMapping Namespace


Eco.Persistence.ORMapping.AliasMode Enumeration

Eco.Persistence.ORMapping.AliasMode Enumeration
C#
public enum AliasMode {
  UseAlias,
  SkipAlias
}
Remarks

This is record Eco.Persistence.ORMapping.AliasMode.

File

ORMappingDefinition.cs


Eco.Persistence.ORMapping.DiscriminatorMode Enumeration

Eco.Persistence.ORMapping.DiscriminatorMode Enumeration
C#
public enum DiscriminatorMode {
  Default,
  Custom,
  None
}
Remarks

This is record Eco.Persistence.ORMapping.DiscriminatorMode.

File

DefaultORMappingBuilder.cs


Eco.Persistence.ORMapping.EcoCompatibilityMode Enumeration

Eco.Persistence.ORMapping.EcoCompatibilityMode Enumeration
C#
public enum EcoCompatibilityMode {
  EcoI,
  EcoII,
  EcoIII
}
Remarks

This is record Eco.Persistence.ORMapping.EcoCompatibilityMode.

File

DefaultORMappingBuilder.cs


Eco.Persistence.ORMapping.KeyCoverage Enumeration

Eco.Persistence.ORMapping.KeyCoverage Enumeration
C#
public enum KeyCoverage {
  NotCovered,
  CoveredByDbAssigned,
  CoveredByFrozen
}
Remarks

This is record Eco.Persistence.ORMapping.KeyCoverage.

File

ORMappingDefinition.cs


Eco.Persistence.Remoting Namespace

Eco.Persistence.Remoting Namespace
Classes
Collapse All

This is namespace Eco.Persistence.Remoting.

Classes
Name | Description
PersistenceMapperClient | This is class Eco.Persistence.Remoting.PersistenceMapperClient.
RemotingException | This is class Eco.Persistence.Remoting.RemotingException.


PersistenceMapperClient Class

PersistenceMapperClient Class
Inheritance Hierarchy See Also
Collapse All
C#
public sealed class PersistenceMapperClient : PersistenceMapper;
Remarks

This is class Eco.Persistence.Remoting.PersistenceMapperClient.

Inheritance Hierarchy
Eco.Persistence.IPersistencemapperProvider
    Eco.Persistence.PersistenceMapper
        Eco.Persistence.Remoting.PersistenceMapperClient
File

PersistenceMapperClient.cs

See Also
Inheritance Hierarchy


PersistenceMapperClient Methods

PersistenceMapperClient Methods
Public Methods
Collapse All

The methods of the PersistenceMapperClient class are listed here.

Public Methods
Name | Description
GetPersistenceMapper |
ReturnPersistenceMapper |


PersistenceMapperClient.GetPersistenceMapper Method

PersistenceMapperClient.GetPersistenceMapper Method
PersistenceMapperClient Class Eco.Persistence.Remoting Namespace See Also
Collapse All
C#
public override IPersistenceMapper GetPersistenceMapper(
    ITypeSystemService typeSystemService
);
Exceptions
Exceptions | Description
InvalidOperationException | Thrown if the client is already set up with a different ITypeSystemService.
See Also
PersistenceMapperClient Class
Eco.Persistence.Remoting Namespace


PersistenceMapperClient.ReturnPersistenceMapper Method

PersistenceMapperClient.ReturnPersistenceMapper Method
PersistenceMapperClient Class Eco.Persistence.Remoting Namespace See Also
Collapse All
C#
public override void ReturnPersistenceMapper(
    IPersistenceMapper persistenceMapper
);
Exceptions
Exceptions | Description
ArgumentNullException | Thrown if persistenceMapper is null
See Also
PersistenceMapperClient Class
Eco.Persistence.Remoting Namespace


PersistenceMapperClient Properties

PersistenceMapperClient Properties
Public Properties
Collapse All

The properties of the PersistenceMapperClient class are listed here.

Public Properties
Name | Description
Url | This is Url, a member of class PersistenceMapperClient.


PersistenceMapperClient.Url Property

PersistenceMapperClient.Url Property
PersistenceMapperClient Class Eco.Persistence.Remoting Namespace See Also
Collapse All
C#
public string Url;
Remarks

This is Url, a member of class PersistenceMapperClient.

See Also
PersistenceMapperClient Class
Eco.Persistence.Remoting Namespace


RemotingException Class

RemotingException Class
Inheritance Hierarchy See Also
Collapse All
C#
public class RemotingException : Exception;
Remarks

This is class Eco.Persistence.Remoting.RemotingException.

Inheritance Hierarchy
Eco.Persistence.Remoting.RemotingException
File

PersistenceMapperClient.cs

See Also
Inheritance Hierarchy


Eco.Persistence.SQLite Namespace

Eco.Persistence.SQLite Namespace
Classes
Collapse All

This is namespace Eco.Persistence.SQLite.

Classes
Name | Description
BooleanAsInteger | This is class Eco.Persistence.SQLite.BooleanAsInteger.
ByteArrayAsBLOB | This is class Eco.Persistence.SQLite.ByteArrayAsBLOB.
Int32AsAutoInc | Mapper between an AutoInc value of type Int32 and its persistent representation as INTEGER.
Int32AsInteger | this has a more relaxed handling of int-values from the db
Int64AsInteger | This is class Eco.Persistence.SQLite.Int64AsInteger.
SingleAsFloat | This is class Eco.Persistence.SQLite.SingleAsFloat.
StringAsText | This is class Eco.Persistence.SQLite.StringAsText.


BooleanAsInteger Class

BooleanAsInteger Class
Inheritance Hierarchy See Also
Collapse All
C#
public sealed class BooleanAsInteger : AbstractSingleColumnAttribute, ISingleColumnAttributemapping, INonBooleanBooleanMapping;
Remarks

This is class Eco.Persistence.SQLite.BooleanAsInteger.

Inheritance Hierarchy
Eco.Persistence.INonBooleanBooleanMapping
Eco.Persistence.ISingleColumnAttributemapping
    Eco.Persistence.SQLite.BooleanAsInteger
File

SQLiteAttributeMappers.cs

See Also
Inheritance Hierarchy


BooleanAsInteger.ColumnToValue Method

BooleanAsInteger.ColumnToValue Method
BooleanAsInteger Class Eco.Persistence.SQLite Namespace See Also
Collapse All

Converts a value that comes from a database query to an ecospace value.

C#
public override System.Object ColumnToValue(
    System.Object columnValue
);
Remarks

In many cases, the implementation of this method mainly converts DBNull-values to null, but it can also change the CLR-type of the database value from for example a char[] to a string. or from an integer to a boolean. This is the reverse operation of ValueToParameter.

See Also
BooleanAsInteger Class
Eco.Persistence.SQLite Namespace


BooleanAsInteger.ColumnType Method

BooleanAsInteger.ColumnType Method
BooleanAsInteger Class Eco.Persistence.SQLite Namespace See Also
Collapse All

Specifies the SQL type of the column.

C#
public String ColumnType(
    int length
);
See Also
BooleanAsInteger Class
Eco.Persistence.SQLite Namespace


BooleanAsInteger.DefaultDbValue Method

BooleanAsInteger.DefaultDbValue Method
BooleanAsInteger Class Eco.Persistence.SQLite Namespace See Also
Collapse All

The return value of this function will be used as default value for new columns when databases are created/evolved.

C#
public String DefaultDbValue(
    string modeledValue,
    SqlDatabaseConfig sqlDatabaseConfig
);
See Also
BooleanAsInteger Class
Eco.Persistence.SQLite Namespace


BooleanAsInteger.StringToParameter Method

BooleanAsInteger.StringToParameter Method
BooleanAsInteger Class Eco.Persistence.SQLite Namespace See Also
Collapse All
C#
public void StringToParameter(
    string value,
    IDataParameter parameter
);
Remarks

This is StringToParameter, a member of class BooleanAsInteger.

See Also
BooleanAsInteger Class
Eco.Persistence.SQLite Namespace


BooleanAsInteger.ValueToParameter Method

BooleanAsInteger.ValueToParameter Method
BooleanAsInteger Class Eco.Persistence.SQLite Namespace See Also
Collapse All

Converts a value that comes from a database query to an ecospace value.

C#
public void ValueToParameter(
    System.Object value,
    IDataParameter parameter
);
Remarks

In many cases, the implementation of this method mainly converts null to DBNull, but it can also handle conversion from for example booleans to integers, byte[] to database blobs. It also has to set the correct parameter types in the IDataParameter-object. This is the reverse operation of ColumnToValue.

See Also
BooleanAsInteger Class
Eco.Persistence.SQLite Namespace


BooleanAsInteger.ValueType Method

BooleanAsInteger.ValueType Method
BooleanAsInteger Class Eco.Persistence.SQLite Namespace See Also
Collapse All

This method returns the type of the value that is returned by ColumnToValue.

C#
public System.Type ValueType();
See Also
BooleanAsInteger Class
Eco.Persistence.SQLite Namespace


BooleanAsInteger.TrueString Property

BooleanAsInteger.TrueString Property
BooleanAsInteger Class Eco.Persistence.SQLite Namespace See Also
Collapse All

Returns the string representation for the "true" value.

C#
public string TrueString;
Remarks

This could be for example "true", "1", "y" depending on how the value "true" is stored.

See Also
BooleanAsInteger Class
Eco.Persistence.SQLite Namespace


ByteArrayAsBLOB Class

ByteArrayAsBLOB Class
Inheritance Hierarchy See Also
Collapse All
C#
public sealed class ByteArrayAsBLOB : AbstractSingleColumnAttribute, ISingleColumnAttributemapping, IDefaultReverseMapping;
Remarks

This is class Eco.Persistence.SQLite.ByteArrayAsBLOB.

Inheritance Hierarchy
Eco.Persistence.IDefaultReverseMapping
Eco.Persistence.ISingleColumnAttributemapping
    Eco.Persistence.SQLite.ByteArrayAsBLOB
File

SQLiteAttributeMappers.cs

See Also
Inheritance Hierarchy


ByteArrayAsBLOB Methods

ByteArrayAsBLOB Methods
Public Methods
Collapse All

The methods of the ByteArrayAsBLOB class are listed here.

Public Methods
Name | Description
ColumnToValue | Converts a value that comes from a database query to an ecospace value.
ColumnType | Specifies the SQL type of the column.
DefaultDbValue | The return value of this function will be used as default value for new columns when databases are created/evolved.
IsEqual | Returns true if an ecospace value ("value") is equal to a database value ("columnValue").
StringToParameter |
ValueToParameter | Converts a value that comes from a database query to an ecospace value.
ValueType | This method returns the type of the value that is returned by ColumnToValue.


ByteArrayAsBLOB.ColumnToValue Method

ByteArrayAsBLOB.ColumnToValue Method
ByteArrayAsBLOB Class Eco.Persistence.SQLite Namespace See Also
Collapse All

Converts a value that comes from a database query to an ecospace value.

C#
public override System.Object ColumnToValue(
    System.Object columnValue
);
Remarks

In many cases, the implementation of this method mainly converts DBNull-values to null, but it can also change the CLR-type of the database value from for example a char[] to a string. or from an integer to a boolean. This is the reverse operation of ValueToParameter.

See Also
ByteArrayAsBLOB Class
Eco.Persistence.SQLite Namespace


ByteArrayAsBLOB.ColumnType Method

ByteArrayAsBLOB.ColumnType Method
ByteArrayAsBLOB Class Eco.Persistence.SQLite Namespace See Also
Collapse All

Specifies the SQL type of the column.

C#
public String ColumnType(
    int length
);
See Also
ByteArrayAsBLOB Class
Eco.Persistence.SQLite Namespace


ByteArrayAsBLOB.DefaultDbValue Method

ByteArrayAsBLOB.DefaultDbValue Method
ByteArrayAsBLOB Class Eco.Persistence.SQLite Namespace See Also
Collapse All

The return value of this function will be used as default value for new columns when databases are created/evolved.

C#
public String DefaultDbValue(
    string modeledValue,
    SqlDatabaseConfig sqlDatabaseConfig
);
See Also
ByteArrayAsBLOB Class
Eco.Persistence.SQLite Namespace


ByteArrayAsBLOB.IsEqual Method

ByteArrayAsBLOB.IsEqual Method
ByteArrayAsBLOB Class Eco.Persistence.SQLite Namespace See Also
Collapse All

Returns true if an ecospace value ("value") is equal to a database value ("columnValue").

C#
public override bool IsEqual(
    System.Object value,
    System.Object columnValue
);
Remarks

This method must handle the conversions between ecospace and database values, it must also handle comparing null/DBNull values.

See Also
ByteArrayAsBLOB Class
Eco.Persistence.SQLite Namespace


ByteArrayAsBLOB.StringToParameter Method

ByteArrayAsBLOB.StringToParameter Method
ByteArrayAsBLOB Class Eco.Persistence.SQLite Namespace See Also
Collapse All
C#
public void StringToParameter(
    string value,
    IDataParameter parameter
);
Exceptions
Exceptions | Description
InvalidOperationException | Thrown always.
See Also
ByteArrayAsBLOB Class
Eco.Persistence.SQLite Namespace


ByteArrayAsBLOB.ValueToParameter Method

ByteArrayAsBLOB.ValueToParameter Method
ByteArrayAsBLOB Class Eco.Persistence.SQLite Namespace See Also
Collapse All

Converts a value that comes from a database query to an ecospace value.

C#
public void ValueToParameter(
    System.Object value,
    IDataParameter parameter
);
Remarks

In many cases, the implementation of this method mainly converts null to DBNull, but it can also handle conversion from for example booleans to integers, byte[] to database blobs. It also has to set the correct parameter types in the IDataParameter-object. This is the reverse operation of ColumnToValue.

See Also
ByteArrayAsBLOB Class
Eco.Persistence.SQLite Namespace


ByteArrayAsBLOB.ValueType Method

ByteArrayAsBLOB.ValueType Method
ByteArrayAsBLOB Class Eco.Persistence.SQLite Namespace See Also
Collapse All

This method returns the type of the value that is returned by ColumnToValue.

C#
public System.Type ValueType();
See Also
ByteArrayAsBLOB Class
Eco.Persistence.SQLite Namespace


Int32AsAutoInc Class

Int32AsAutoInc Class
Inheritance Hierarchy See Also
Collapse All

Mapper between an AutoInc value of type Int32 and its persistent representation as INTEGER.

C#
public sealed class Int32AsAutoInc : AbstractNumericSingleColumnAttribute, IAutoIncAttributemapping;
Inheritance Hierarchy
Eco.Persistence.ISingleColumnAttributemapping
    Eco.Persistence.IAutoIncAttributemapping
        Eco.Persistence.SQLite.Int32AsAutoInc
File

SQLiteAttributeMappers.cs

See Also
Inheritance Hierarchy


Int32AsAutoInc.ColumnToValue Method

Int32AsAutoInc.ColumnToValue Method
Int32AsAutoInc Class Eco.Persistence.SQLite Namespace See Also
Collapse All

Converts a value that comes from a database query to an ecospace value.

C#
public override System.Object ColumnToValue(
    System.Object columnValue
);
Remarks

In many cases, the implementation of this method mainly converts DBNull-values to null, but it can also change the CLR-type of the database value from for example a char[] to a string. or from an integer to a boolean. This is the reverse operation of ValueToParameter.

See Also
Int32AsAutoInc Class
Eco.Persistence.SQLite Namespace


Int32AsAutoInc.ColumnType Method

Int32AsAutoInc.ColumnType Method
Int32AsAutoInc Class Eco.Persistence.SQLite Namespace See Also
Collapse All

Specifies the SQL type of the column.

C#
public String ColumnType(
    int length
);
See Also
Int32AsAutoInc Class
Eco.Persistence.SQLite Namespace


Int32AsAutoInc.DefaultDbValue Method

Int32AsAutoInc.DefaultDbValue Method
Int32AsAutoInc Class Eco.Persistence.SQLite Namespace See Also
Collapse All

The return value of this function will be used as default value for new columns when databases are created/evolved.

C#
public override String DefaultDbValue(
    string modeledValue,
    SqlDatabaseConfig sqlDatabaseConfig
);
See Also
Int32AsAutoInc Class
Eco.Persistence.SQLite Namespace


Int32AsAutoInc.MakeColumnAutoInc Method

Int32AsAutoInc.MakeColumnAutoInc Method
Int32AsAutoInc Class Eco.Persistence.SQLite Namespace See Also
Collapse All

If the database requires any additional operations in addition to the column type to give a column "autoinc" behaviour, that should be performed by this method.

C#
public void MakeColumnAutoInc(
    string tableName,
    string columnName,
    IDatabase database
);
Remarks

Even if the database does not require any additional operations, this interface should be implemented by an autoinc attribute mapper, and the implementation of this method should be left blank.

See Also
Int32AsAutoInc Class
Eco.Persistence.SQLite Namespace


Int32AsAutoInc.StringToParameter Method

Int32AsAutoInc.StringToParameter Method
Int32AsAutoInc Class Eco.Persistence.SQLite Namespace See Also
Collapse All

This method should never be called. Autoinc values are never stored!

C#
public void StringToParameter(
    string value,
    IDataParameter parameter
);
Exceptions
Exceptions | Description
NotSupportedException | Thrown always.
See Also
Int32AsAutoInc Class
Eco.Persistence.SQLite Namespace


Int32AsAutoInc.ValueToParameter Method

Int32AsAutoInc.ValueToParameter Method
Int32AsAutoInc Class Eco.Persistence.SQLite Namespace See Also
Collapse All

This method should never be called. Autoinc values are never stored!

C#
public void ValueToParameter(
    System.Object value,
    IDataParameter parameter
);
Exceptions
Exceptions | Description
NotSupportedException | Thrown always.
See Also
Int32AsAutoInc Class
Eco.Persistence.SQLite Namespace


Int32AsAutoInc.ValueType Method

Int32AsAutoInc.ValueType Method
Int32AsAutoInc Class Eco.Persistence.SQLite Namespace See Also
Collapse All

This method returns the type of the value that is returned by ColumnToValue.

C#
public System.Type ValueType();
See Also
Int32AsAutoInc Class
Eco.Persistence.SQLite Namespace


Int32AsInteger Class

Int32AsInteger Class
Inheritance Hierarchy See Also
Collapse All
C#
public sealed class Int32AsInteger : AbstractNumericSingleColumnAttribute, ISingleColumnAttributemapping, IDefaultReverseMapping;
Remarks

this has a more relaxed handling of int-values from the db

Inheritance Hierarchy
Eco.Persistence.IDefaultReverseMapping
Eco.Persistence.ISingleColumnAttributemapping
    Eco.Persistence.SQLite.Int32AsInteger
File

SQLiteAttributeMappers.cs

See Also
Inheritance Hierarchy


Int32AsInteger Methods

Int32AsInteger Methods
Public Methods
Collapse All

The methods of the Int32AsInteger class are listed here.

Public Methods
Name | Description
ColumnToValue | Converts a value that comes from a database query to an ecospace value.
ColumnType | Specifies the SQL type of the column.
StringToParameter | This is StringToParameter, a member of class Int32AsInteger.
ValueToParameter | Converts a value that comes from a database query to an ecospace value.
ValueType | This method returns the type of the value that is returned by ColumnToValue.


Int32AsInteger.ColumnToValue Method

Int32AsInteger.ColumnToValue Method
Int32AsInteger Class Eco.Persistence.SQLite Namespace See Also
Collapse All

Converts a value that comes from a database query to an ecospace value.

C#
public override System.Object ColumnToValue(
    System.Object columnValue
);
Remarks

In many cases, the implementation of this method mainly converts DBNull-values to null, but it can also change the CLR-type of the database value from for example a char[] to a string. or from an integer to a boolean. This is the reverse operation of ValueToParameter.

See Also
Int32AsInteger Class
Eco.Persistence.SQLite Namespace


Int32AsInteger.ColumnType Method

Int32AsInteger.ColumnType Method
Int32AsInteger Class Eco.Persistence.SQLite Namespace See Also
Collapse All

Specifies the SQL type of the column.

C#
public String ColumnType(
    int length
);
See Also
Int32AsInteger Class
Eco.Persistence.SQLite Namespace


Int32AsInteger.StringToParameter Method

Int32AsInteger.StringToParameter Method
Int32AsInteger Class Eco.Persistence.SQLite Namespace See Also
Collapse All
C#
public void StringToParameter(
    string value,
    IDataParameter parameter
);
Remarks

This is StringToParameter, a member of class Int32AsInteger.

See Also
Int32AsInteger Class
Eco.Persistence.SQLite Namespace


Int32AsInteger.ValueToParameter Method

Int32AsInteger.ValueToParameter Method
Int32AsInteger Class Eco.Persistence.SQLite Namespace See Also
Collapse All

Converts a value that comes from a database query to an ecospace value.

C#
public void ValueToParameter(
    System.Object value,
    IDataParameter parameter
);
Remarks

In many cases, the implementation of this method mainly converts null to DBNull, but it can also handle conversion from for example booleans to integers, byte[] to database blobs. It also has to set the correct parameter types in the IDataParameter-object. This is the reverse operation of ColumnToValue.

See Also
Int32AsInteger Class
Eco.Persistence.SQLite Namespace


Int32AsInteger.ValueType Method

Int32AsInteger.ValueType Method
Int32AsInteger Class Eco.Persistence.SQLite Namespace See Also
Collapse All

This method returns the type of the value that is returned by ColumnToValue.

C#
public System.Type ValueType();
See Also
Int32AsInteger Class
Eco.Persistence.SQLite Namespace


Int64AsInteger Class

Int64AsInteger Class
Inheritance Hierarchy See Also
Collapse All
C#
public sealed class Int64AsInteger : AbstractNumericSingleColumnAttribute, ISingleColumnAttributemapping;
Remarks

This is class Eco.Persistence.SQLite.Int64AsInteger.

Inheritance Hierarchy
Eco.Persistence.ISingleColumnAttributemapping
    Eco.Persistence.SQLite.Int64AsInteger
File

SQLiteAttributeMappers.cs

See Also
Inheritance Hierarchy


Int64AsInteger Methods

Int64AsInteger Methods
Public Methods
Collapse All

The methods of the Int64AsInteger class are listed here.

Public Methods
Name | Description
ColumnToValue | Converts a value that comes from a database query to an ecospace value.
ColumnType | Specifies the SQL type of the column.
StringToParameter | This is StringToParameter, a member of class Int64AsInteger.
ValueToParameter | Converts a value that comes from a database query to an ecospace value.
ValueType | This method returns the type of the value that is returned by ColumnToValue.


Int64AsInteger.ColumnToValue Method

Int64AsInteger.ColumnToValue Method
Int64AsInteger Class Eco.Persistence.SQLite Namespace See Also
Collapse All

Converts a value that comes from a database query to an ecospace value.

C#
public override System.Object ColumnToValue(
    System.Object columnValue
);
Remarks

In many cases, the implementation of this method mainly converts DBNull-values to null, but it can also change the CLR-type of the database value from for example a char[] to a string. or from an integer to a boolean. This is the reverse operation of ValueToParameter.

See Also
Int64AsInteger Class
Eco.Persistence.SQLite Namespace


Int64AsInteger.ColumnType Method

Int64AsInteger.ColumnType Method
Int64AsInteger Class Eco.Persistence.SQLite Namespace See Also
Collapse All

Specifies the SQL type of the column.

C#
public String ColumnType(
    int length
);
See Also
Int64AsInteger Class
Eco.Persistence.SQLite Namespace


Int64AsInteger.StringToParameter Method

Int64AsInteger.StringToParameter Method
Int64AsInteger Class Eco.Persistence.SQLite Namespace See Also
Collapse All
C#
public void StringToParameter(
    string value,
    IDataParameter parameter
);
Remarks

This is StringToParameter, a member of class Int64AsInteger.

See Also
Int64AsInteger Class
Eco.Persistence.SQLite Namespace


Int64AsInteger.ValueToParameter Method

Int64AsInteger.ValueToParameter Method
Int64AsInteger Class Eco.Persistence.SQLite Namespace See Also
Collapse All

Converts a value that comes from a database query to an ecospace value.

C#
public void ValueToParameter(
    System.Object value,
    IDataParameter parameter
);
Remarks

In many cases, the implementation of this method mainly converts null to DBNull, but it can also handle conversion from for example booleans to integers, byte[] to database blobs. It also has to set the correct parameter types in the IDataParameter-object. This is the reverse operation of ColumnToValue.

See Also
Int64AsInteger Class
Eco.Persistence.SQLite Namespace


Int64AsInteger.ValueType Method

Int64AsInteger.ValueType Method
Int64AsInteger Class Eco.Persistence.SQLite Namespace See Also
Collapse All

This method returns the type of the value that is returned by ColumnToValue.

C#
public System.Type ValueType();
See Also
Int64AsInteger Class
Eco.Persistence.SQLite Namespace


SingleAsFloat Class

SingleAsFloat Class
Inheritance Hierarchy See Also
Collapse All
C#
public sealed class SingleAsFloat : AbstractNumericSingleColumnAttribute, ISingleColumnAttributemapping, IDefaultReverseMapping;
Remarks

This is class Eco.Persistence.SQLite.SingleAsFloat.

Inheritance Hierarchy
Eco.Persistence.IDefaultReverseMapping
Eco.Persistence.ISingleColumnAttributemapping
    Eco.Persistence.SQLite.SingleAsFloat
File

SQLiteAttributeMappers.cs

See Also
Inheritance Hierarchy


SingleAsFloat.ColumnToValue Method

SingleAsFloat.ColumnToValue Method
SingleAsFloat Class Eco.Persistence.SQLite Namespace See Also
Collapse All

Converts a value that comes from a database query to an ecospace value.

C#
public override System.Object ColumnToValue(
    System.Object columnValue
);
Remarks

In many cases, the implementation of this method mainly converts DBNull-values to null, but it can also change the CLR-type of the database value from for example a char[] to a string. or from an integer to a boolean. This is the reverse operation of ValueToParameter.

See Also
SingleAsFloat Class
Eco.Persistence.SQLite Namespace


SingleAsFloat.ColumnType Method

SingleAsFloat.ColumnType Method
SingleAsFloat Class Eco.Persistence.SQLite Namespace See Also
Collapse All

Specifies the SQL type of the column.

C#
public String ColumnType(
    int length
);
See Also
SingleAsFloat Class
Eco.Persistence.SQLite Namespace


SingleAsFloat.StringToParameter Method

SingleAsFloat.StringToParameter Method
SingleAsFloat Class Eco.Persistence.SQLite Namespace See Also
Collapse All
C#
public void StringToParameter(
    string value,
    IDataParameter parameter
);
Remarks

This is StringToParameter, a member of class SingleAsFloat.

See Also
SingleAsFloat Class
Eco.Persistence.SQLite Namespace


SingleAsFloat.ValueToParameter Method

SingleAsFloat.ValueToParameter Method
SingleAsFloat Class Eco.Persistence.SQLite Namespace See Also
Collapse All

Converts a value that comes from a database query to an ecospace value.

C#
public void ValueToParameter(
    System.Object value,
    IDataParameter parameter
);
Remarks

In many cases, the implementation of this method mainly converts null to DBNull, but it can also handle conversion from for example booleans to integers, byte[] to database blobs. It also has to set the correct parameter types in the IDataParameter-object. This is the reverse operation of ColumnToValue.

See Also
SingleAsFloat Class
Eco.Persistence.SQLite Namespace


SingleAsFloat.ValueType Method

SingleAsFloat.ValueType Method
SingleAsFloat Class Eco.Persistence.SQLite Namespace See Also
Collapse All

This method returns the type of the value that is returned by ColumnToValue.

C#
public System.Type ValueType();
See Also
SingleAsFloat Class
Eco.Persistence.SQLite Namespace


StringAsText Class

StringAsText Class
Inheritance Hierarchy See Also
Collapse All
C#
public sealed class StringAsText : AbstractSingleColumnAttribute, ISingleColumnAttributemapping, IDefaultReverseMapping;
Remarks

This is class Eco.Persistence.SQLite.StringAsText.

Inheritance Hierarchy
Eco.Persistence.IDefaultReverseMapping
Eco.Persistence.ISingleColumnAttributemapping
    Eco.Persistence.SQLite.StringAsText
File

SQLiteAttributeMappers.cs

See Also
Inheritance Hierarchy


StringAsText.ColumnToValue Method

StringAsText.ColumnToValue Method
StringAsText Class Eco.Persistence.SQLite Namespace See Also
Collapse All

Converts a value that comes from a database query to an ecospace value.

C#
public override System.Object ColumnToValue(
    System.Object columnValue
);
Remarks

In many cases, the implementation of this method mainly converts DBNull-values to null, but it can also change the CLR-type of the database value from for example a char[] to a string. or from an integer to a boolean. This is the reverse operation of ValueToParameter.

See Also
StringAsText Class
Eco.Persistence.SQLite Namespace


StringAsText.ColumnType Method

StringAsText.ColumnType Method
StringAsText Class Eco.Persistence.SQLite Namespace See Also
Collapse All

Specifies the SQL type of the column.

C#
public String ColumnType(
    int length
);
See Also
StringAsText Class
Eco.Persistence.SQLite Namespace


StringAsText.DefaultDbValue Method

StringAsText.DefaultDbValue Method
StringAsText Class Eco.Persistence.SQLite Namespace See Also
Collapse All

The return value of this function will be used as default value for new columns when databases are created/evolved.

C#
public String DefaultDbValue(
    string modeledValue,
    SqlDatabaseConfig sqlDatabaseConfig
);
See Also
StringAsText Class
Eco.Persistence.SQLite Namespace


StringAsText.StringToParameter Method

StringAsText.StringToParameter Method
StringAsText Class Eco.Persistence.SQLite Namespace See Also
Collapse All
C#
public void StringToParameter(
    string value,
    IDataParameter parameter
);
Remarks

This is StringToParameter, a member of class StringAsText.

See Also
StringAsText Class
Eco.Persistence.SQLite Namespace


StringAsText.ValueToParameter Method

StringAsText.ValueToParameter Method
StringAsText Class Eco.Persistence.SQLite Namespace See Also
Collapse All

Converts a value that comes from a database query to an ecospace value.

C#
public void ValueToParameter(
    System.Object value,
    IDataParameter parameter
);
Remarks

In many cases, the implementation of this method mainly converts null to DBNull, but it can also handle conversion from for example booleans to integers, byte[] to database blobs. It also has to set the correct parameter types in the IDataParameter-object. This is the reverse operation of ColumnToValue.

See Also
StringAsText Class
Eco.Persistence.SQLite Namespace


StringAsText.ValueType Method

StringAsText.ValueType Method
StringAsText Class Eco.Persistence.SQLite Namespace See Also
Collapse All

This method returns the type of the value that is returned by ColumnToValue.

C#
public System.Type ValueType();
See Also
StringAsText Class
Eco.Persistence.SQLite Namespace


Eco.Persistence.SqlServer Namespace

Eco.Persistence.SqlServer Namespace
Classes
Collapse All

This is namespace Eco.Persistence.SqlServer.

Classes
Name | Description
BooleanAsBit | This is class Eco.Persistence.SqlServer.BooleanAsBit.
ByteAsTinyInt | This is class Eco.Persistence.SqlServer.ByteAsTinyInt.
DateTimeAsDateTime | Mapper between a DateTime value and its persistent representation as DATETIME.
DateTimeAsDateTimeWithoutMilliseconds | Mapper between a DateTime value and its persistent representation as DATETIME. Used for Access that does not support storing milliseconds
DecimalAsAutoInc | Mapper between an AutoInc value of type Decimal and its persistent representation as NUMERIC(18,0).
DecimalAsDecimal | This is class Eco.Persistence.SqlServer.DecimalAsDecimal.
DecimalAsDecimal28 | This is class Eco.Persistence.SqlServer.DecimalAsDecimal28.
DecimalAsMoney | This is class Eco.Persistence.SqlServer.DecimalAsMoney.
DecimalAsSmallMoney | This is class Eco.Persistence.SqlServer.DecimalAsSmallMoney.
GuidAsUniqueIdentifier | This is class Eco.Persistence.SqlServer.GuidAsUniqueIdentifier.
GuidAsUniqueIdentifierWithDefault | Mapper between a GUID value of type Decimal and its persistent representation using a new GUID as default value.
Int16AsAutoInc | Mapper between an AutoInc value of type Int16 and its persistent representation as SMALLINT.
Int32AsAutoInc | Mapper between an AutoInc value of type Int32 and its persistent representation as INTEGER.
Int32AsInt | Class for mapping Int32 values to a single column in a database.
Int64AsLongInteger | This is class Eco.Persistence.SqlServer.Int64AsLongInteger.
Int64AsTimeStamp | This is class Eco.Persistence.SqlServer.Int64AsTimeStamp.
SingleAsFloat | This is class Eco.Persistence.SqlServer.SingleAsFloat.
SingleAsReal | This is class Eco.Persistence.SqlServer.SingleAsReal.
SqlServerStringRes | Autogenerated class to get compiler safe access to resource strings.
StringAsXml | Class for mapping String values to a single column in a database.
TimeSpanAsDateTime | This is class Eco.Persistence.SqlServer.TimeSpanAsDateTime.


BooleanAsBit Class

BooleanAsBit Class
Inheritance Hierarchy See Also
Collapse All
C#
public sealed class BooleanAsBit : AbstractSingleColumnAttribute, ISingleColumnAttributemapping, IDefaultReverseMapping;
Remarks

This is class Eco.Persistence.SqlServer.BooleanAsBit.

Inheritance Hierarchy
Eco.Persistence.IDefaultReverseMapping
Eco.Persistence.ISingleColumnAttributemapping
    Eco.Persistence.SqlServer.BooleanAsBit
File

SqlServerAttributeMappers.cs

See Also
Inheritance Hierarchy


BooleanAsBit Methods

BooleanAsBit Methods
Public Methods
Collapse All

The methods of the BooleanAsBit class are listed here.

Public Methods
Name | Description
ColumnToValue | Converts a value that comes from a database query to an ecospace value.
ColumnType | Specifies the SQL type of the column.
DefaultDbValue | The return value of this function will be used as default value for new columns when databases are created/evolved.
StringToParameter | This is StringToParameter, a member of class BooleanAsBit.
ValueToParameter | Converts a value that comes from a database query to an ecospace value.
ValueType | This method returns the type of the value that is returned by ColumnToValue.


BooleanAsBit.ColumnToValue Method

BooleanAsBit.ColumnToValue Method
BooleanAsBit Class Eco.Persistence.SqlServer Namespace See Also
Collapse All

Converts a value that comes from a database query to an ecospace value.

C#
public override System.Object ColumnToValue(
    System.Object columnValue
);
Remarks

In many cases, the implementation of this method mainly converts DBNull-values to null, but it can also change the CLR-type of the database value from for example a char[] to a string. or from an integer to a boolean. This is the reverse operation of ValueToParameter.

See Also
BooleanAsBit Class
Eco.Persistence.SqlServer Namespace


BooleanAsBit.ColumnType Method

BooleanAsBit.ColumnType Method
BooleanAsBit Class Eco.Persistence.SqlServer Namespace See Also
Collapse All

Specifies the SQL type of the column.

C#
public String ColumnType(
    int length
);
See Also
BooleanAsBit Class
Eco.Persistence.SqlServer Namespace


BooleanAsBit.DefaultDbValue Method

BooleanAsBit.DefaultDbValue Method
BooleanAsBit Class Eco.Persistence.SqlServer Namespace See Also
Collapse All

The return value of this function will be used as default value for new columns when databases are created/evolved.

C#
public String DefaultDbValue(
    string modeledValue,
    SqlDatabaseConfig sqlDatabaseConfig
);
See Also
BooleanAsBit Class
Eco.Persistence.SqlServer Namespace


BooleanAsBit.StringToParameter Method

BooleanAsBit.StringToParameter Method
BooleanAsBit Class Eco.Persistence.SqlServer Namespace See Also
Collapse All
C#
public void StringToParameter(
    string value,
    IDataParameter parameter
);
Remarks

This is StringToParameter, a member of class BooleanAsBit.

See Also
BooleanAsBit Class
Eco.Persistence.SqlServer Namespace


BooleanAsBit.ValueToParameter Method

BooleanAsBit.ValueToParameter Method
BooleanAsBit Class Eco.Persistence.SqlServer Namespace See Also
Collapse All

Converts a value that comes from a database query to an ecospace value.

C#
public void ValueToParameter(
    System.Object value,
    IDataParameter parameter
);
Remarks

In many cases, the implementation of this method mainly converts null to DBNull, but it can also handle conversion from for example booleans to integers, byte[] to database blobs. It also has to set the correct parameter types in the IDataParameter-object. This is the reverse operation of ColumnToValue.

See Also
BooleanAsBit Class
Eco.Persistence.SqlServer Namespace


BooleanAsBit.ValueType Method

BooleanAsBit.ValueType Method
BooleanAsBit Class Eco.Persistence.SqlServer Namespace See Also
Collapse All

This method returns the type of the value that is returned by ColumnToValue.

C#
public System.Type ValueType();
See Also
BooleanAsBit Class
Eco.Persistence.SqlServer Namespace


BooleanAsBit Properties

BooleanAsBit Properties
Public Properties
Collapse All

The properties of the BooleanAsBit class are listed here.

Public Properties
Name | Description
TrueString | This is TrueString, a member of class BooleanAsBit.


BooleanAsBit.TrueString Property

BooleanAsBit.TrueString Property
BooleanAsBit Class Eco.Persistence.SqlServer Namespace See Also
Collapse All
C#
public string TrueString;
Remarks

This is TrueString, a member of class BooleanAsBit.

See Also
BooleanAsBit Class
Eco.Persistence.SqlServer Namespace


ByteAsTinyInt Class

ByteAsTinyInt Class
Inheritance Hierarchy See Also
Collapse All
C#
public sealed class ByteAsTinyInt : AbstractNumericSingleColumnAttribute, ISingleColumnAttributemapping, IDefaultReverseMapping;
Remarks

This is class Eco.Persistence.SqlServer.ByteAsTinyInt.

Inheritance Hierarchy
Eco.Persistence.IDefaultReverseMapping
Eco.Persistence.ISingleColumnAttributemapping
    Eco.Persistence.SqlServer.ByteAsTinyInt
File

SqlServerAttributeMappers.cs

See Also
Inheritance Hierarchy


ByteAsTinyInt.ColumnToValue Method

ByteAsTinyInt.ColumnToValue Method
ByteAsTinyInt Class Eco.Persistence.SqlServer Namespace See Also
Collapse All

Converts a value that comes from a database query to an ecospace value.

C#
public override System.Object ColumnToValue(
    System.Object columnValue
);
Remarks

In many cases, the implementation of this method mainly converts DBNull-values to null, but it can also change the CLR-type of the database value from for example a char[] to a string. or from an integer to a boolean. This is the reverse operation of ValueToParameter.

See Also
ByteAsTinyInt Class
Eco.Persistence.SqlServer Namespace


ByteAsTinyInt.ColumnType Method

ByteAsTinyInt.ColumnType Method
ByteAsTinyInt Class Eco.Persistence.SqlServer Namespace See Also
Collapse All

Specifies the SQL type of the column.

C#
public String ColumnType(
    int length
);
See Also
ByteAsTinyInt Class
Eco.Persistence.SqlServer Namespace


ByteAsTinyInt.StringToParameter Method

ByteAsTinyInt.StringToParameter Method
ByteAsTinyInt Class Eco.Persistence.SqlServer Namespace See Also
Collapse All
C#
public void StringToParameter(
    string value,
    IDataParameter parameter
);
Remarks

This is StringToParameter, a member of class ByteAsTinyInt.

See Also
ByteAsTinyInt Class
Eco.Persistence.SqlServer Namespace


ByteAsTinyInt.ValueToParameter Method

ByteAsTinyInt.ValueToParameter Method
ByteAsTinyInt Class Eco.Persistence.SqlServer Namespace See Also
Collapse All

Converts a value that comes from a database query to an ecospace value.

C#
public void ValueToParameter(
    System.Object value,
    IDataParameter parameter
);
Remarks

In many cases, the implementation of this method mainly converts null to DBNull, but it can also handle conversion from for example booleans to integers, byte[] to database blobs. It also has to set the correct parameter types in the IDataParameter-object. This is the reverse operation of ColumnToValue.

See Also
ByteAsTinyInt Class
Eco.Persistence.SqlServer Namespace


ByteAsTinyInt.ValueType Method

ByteAsTinyInt.ValueType Method
ByteAsTinyInt Class Eco.Persistence.SqlServer Namespace See Also
Collapse All

This method returns the type of the value that is returned by ColumnToValue.

C#
public System.Type ValueType();
See Also
ByteAsTinyInt Class
Eco.Persistence.SqlServer Namespace


DateTimeAsDateTime Class

DateTimeAsDateTime Class
Inheritance Hierarchy See Also
Collapse All

Mapper between a DateTime value and its persistent representation as DATETIME.

C#
public sealed class DateTimeAsDateTime : AbstractSingleColumnAttribute, ISingleColumnAttributemapping, IDefaultReverseMapping;
Inheritance Hierarchy
Eco.Persistence.IDefaultReverseMapping
Eco.Persistence.ISingleColumnAttributemapping
    Eco.Persistence.SqlServer.DateTimeAsDateTime
File

SqlServerAttributeMappers.cs

See Also
Inheritance Hierarchy


DateTimeAsDateTime.ColumnToValue Method

DateTimeAsDateTime.ColumnToValue Method
DateTimeAsDateTime Class Eco.Persistence.SqlServer Namespace See Also
Collapse All

Converts a value that comes from a database query to an ecospace value.

C#
public override System.Object ColumnToValue(
    System.Object columnValue
);
Remarks

In many cases, the implementation of this method mainly converts DBNull-values to null, but it can also change the CLR-type of the database value from for example a char[] to a string. or from an integer to a boolean. This is the reverse operation of ValueToParameter.

See Also
DateTimeAsDateTime Class
Eco.Persistence.SqlServer Namespace


DateTimeAsDateTime.ColumnType Method

DateTimeAsDateTime.ColumnType Method
DateTimeAsDateTime Class Eco.Persistence.SqlServer Namespace See Also
Collapse All

Specifies the SQL type of the column.

C#
public String ColumnType(
    int length
);
See Also
DateTimeAsDateTime Class
Eco.Persistence.SqlServer Namespace


DateTimeAsDateTime.DefaultDbValue Method

DateTimeAsDateTime.DefaultDbValue Method
DateTimeAsDateTime Class Eco.Persistence.SqlServer Namespace See Also
Collapse All
C#
public String DefaultDbValue(
    string modeledValue,
    SqlDatabaseConfig sqlDatabaseConfig
);
Exceptions
Exceptions | Description
ArgumentNullException | Thrown if sqlDatabaseConfig is null
See Also
DateTimeAsDateTime Class
Eco.Persistence.SqlServer Namespace


DateTimeAsDateTime.IsEqual Method

DateTimeAsDateTime.IsEqual Method
DateTimeAsDateTime Class Eco.Persistence.SqlServer Namespace See Also
Collapse All

Returns true if an ecospace value ("value") is equal to a database value ("columnValue").

C#
public override bool IsEqual(
    System.Object value,
    System.Object columnValue
);
Remarks

This method must handle the conversions between ecospace and database values, it must also handle comparing null/DBNull values.

See Also
DateTimeAsDateTime Class
Eco.Persistence.SqlServer Namespace


DateTimeAsDateTime.StringToParameter Method

DateTimeAsDateTime.StringToParameter Method
DateTimeAsDateTime Class Eco.Persistence.SqlServer Namespace See Also
Collapse All
C#
public void StringToParameter(
    string value,
    IDataParameter parameter
);
Remarks

This is StringToParameter, a member of class DateTimeAsDateTime.

See Also
DateTimeAsDateTime Class
Eco.Persistence.SqlServer Namespace


DateTimeAsDateTime.ValueToParameter Method

DateTimeAsDateTime.ValueToParameter Method
DateTimeAsDateTime Class Eco.Persistence.SqlServer Namespace See Also
Collapse All

Converts a value that comes from a database query to an ecospace value.

C#
public void ValueToParameter(
    System.Object value,
    IDataParameter parameter
);
Remarks

In many cases, the implementation of this method mainly converts null to DBNull, but it can also handle conversion from for example booleans to integers, byte[] to database blobs. It also has to set the correct parameter types in the IDataParameter-object. This is the reverse operation of ColumnToValue.

See Also
DateTimeAsDateTime Class
Eco.Persistence.SqlServer Namespace


DateTimeAsDateTime.ValueType Method

DateTimeAsDateTime.ValueType Method
DateTimeAsDateTime Class Eco.Persistence.SqlServer Namespace See Also
Collapse All

This method returns the type of the value that is returned by ColumnToValue.

C#
public System.Type ValueType();
See Also
DateTimeAsDateTime Class
Eco.Persistence.SqlServer Namespace


DateTimeAsDateTimeWithoutMilliseconds Class

DateTimeAsDateTimeWithoutMilliseconds Class
Inheritance Hierarchy See Also
Collapse All

Mapper between a DateTime value and its persistent representation as DATETIME. Used for Access that does not support storing milliseconds

C#
public sealed class DateTimeAsDateTimeWithoutMilliseconds : AbstractSingleColumnAttribute, ISingleColumnAttributemapping;
Inheritance Hierarchy
Eco.Persistence.ISingleColumnAttributemapping
    Eco.Persistence.SqlServer.DateTimeAsDateTimeWithoutMilliseconds
File

SqlServerAttributeMappers.cs

See Also
Inheritance Hierarchy


DateTimeAsDateTimeWithoutMilliseconds Methods

DateTimeAsDateTimeWithoutMilliseconds Methods
Public Methods
Collapse All

The methods of the DateTimeAsDateTimeWithoutMilliseconds class are listed here.

Public Methods
Name | Description
ColumnToValue | Converts a value that comes from a database query to an ecospace value.
ColumnType | Specifies the SQL type of the column.
DefaultDbValue |
IsEqual | Returns true if an ecospace value ("value") is equal to a database value ("columnValue").
StringToParameter | This is StringToParameter, a member of class DateTimeAsDateTimeWithoutMilliseconds.
ValueToParameter | Converts a value that comes from a database query to an ecospace value.
ValueType | This method returns the type of the value that is returned by ColumnToValue.


DateTimeAsDateTimeWithoutMilliseconds.ColumnToValue Method

DateTimeAsDateTimeWithoutMilliseconds.ColumnToValue Method
DateTimeAsDateTimeWithoutMilliseconds Class Eco.Persistence.SqlServer Namespace See Also
Collapse All

Converts a value that comes from a database query to an ecospace value.

C#
public override System.Object ColumnToValue(
    System.Object columnValue
);
Remarks

In many cases, the implementation of this method mainly converts DBNull-values to null, but it can also change the CLR-type of the database value from for example a char[] to a string. or from an integer to a boolean. This is the reverse operation of ValueToParameter.

See Also
DateTimeAsDateTimeWithoutMilliseconds Class
Eco.Persistence.SqlServer Namespace


DateTimeAsDateTimeWithoutMilliseconds.ColumnType Method

DateTimeAsDateTimeWithoutMilliseconds.ColumnType Method
DateTimeAsDateTimeWithoutMilliseconds Class Eco.Persistence.SqlServer Namespace See Also
Collapse All

Specifies the SQL type of the column.

C#
public String ColumnType(
    int length
);
See Also
DateTimeAsDateTimeWithoutMilliseconds Class
Eco.Persistence.SqlServer Namespace


DateTimeAsDateTimeWithoutMilliseconds.DefaultDbValue Method

DateTimeAsDateTimeWithoutMilliseconds.DefaultDbValue Method
DateTimeAsDateTimeWithoutMilliseconds Class Eco.Persistence.SqlServer Namespace See Also
Collapse All
C#
public String DefaultDbValue(
    string modeledValue,
    SqlDatabaseConfig sqlDatabaseConfig
);
Exceptions
Exceptions | Description
ArgumentNullException | Thrown if sqlDatabaseConfig is null
See Also
DateTimeAsDateTimeWithoutMilliseconds Class
Eco.Persistence.SqlServer Namespace


DateTimeAsDateTimeWithoutMilliseconds.IsEqual Method

DateTimeAsDateTimeWithoutMilliseconds.IsEqual Method
DateTimeAsDateTimeWithoutMilliseconds Class Eco.Persistence.SqlServer Namespace See Also
Collapse All

Returns true if an ecospace value ("value") is equal to a database value ("columnValue").

C#
public override bool IsEqual(
    System.Object value,
    System.Object columnValue
);
Remarks

This method must handle the conversions between ecospace and database values, it must also handle comparing null/DBNull values.

See Also
DateTimeAsDateTimeWithoutMilliseconds Class
Eco.Persistence.SqlServer Namespace


DateTimeAsDateTimeWithoutMilliseconds.StringToParameter Method

DateTimeAsDateTimeWithoutMilliseconds.StringToParameter Method
DateTimeAsDateTimeWithoutMilliseconds Class Eco.Persistence.SqlServer Namespace See Also
Collapse All
C#
public void StringToParameter(
    string value,
    IDataParameter parameter
);
Remarks

This is StringToParameter, a member of class DateTimeAsDateTimeWithoutMilliseconds.

See Also
DateTimeAsDateTimeWithoutMilliseconds Class
Eco.Persistence.SqlServer Namespace


DateTimeAsDateTimeWithoutMilliseconds.ValueToParameter Method

DateTimeAsDateTimeWithoutMilliseconds.ValueToParameter Method
DateTimeAsDateTimeWithoutMilliseconds Class Eco.Persistence.SqlServer Namespace See Also
Collapse All

Converts a value that comes from a database query to an ecospace value.

C#
public void ValueToParameter(
    System.Object value,
    IDataParameter parameter
);
Remarks

In many cases, the implementation of this method mainly converts null to DBNull, but it can also handle conversion from for example booleans to integers, byte[] to database blobs. It also has to set the correct parameter types in the IDataParameter-object. This is the reverse operation of ColumnToValue.

See Also
DateTimeAsDateTimeWithoutMilliseconds Class
Eco.Persistence.SqlServer Namespace


DateTimeAsDateTimeWithoutMilliseconds.ValueType Method

DateTimeAsDateTimeWithoutMilliseconds.ValueType Method
DateTimeAsDateTimeWithoutMilliseconds Class Eco.Persistence.SqlServer Namespace See Also
Collapse All

This method returns the type of the value that is returned by ColumnToValue.

C#
public System.Type ValueType();
See Also
DateTimeAsDateTimeWithoutMilliseconds Class
Eco.Persistence.SqlServer Namespace


DecimalAsAutoInc Class

DecimalAsAutoInc Class
Inheritance Hierarchy See Also
Collapse All

Mapper between an AutoInc value of type Decimal and its persistent representation as NUMERIC(18,0).

C#
public sealed class DecimalAsAutoInc : AbstractNumericSingleColumnAttribute, IAutoIncAttributemapping, IDefaultReverseMapping;
Inheritance Hierarchy
Eco.Persistence.ISingleColumnAttributemapping
    Eco.Persistence.IAutoIncAttributemapping
    Eco.Persistence.IDefaultReverseMapping
        Eco.Persistence.SqlServer.DecimalAsAutoInc
File

SqlServerAttributeMappers.cs

See Also
Inheritance Hierarchy


DecimalAsAutoInc Methods

DecimalAsAutoInc Methods
Public Methods
Collapse All

The methods of the DecimalAsAutoInc class are listed here.

Public Methods
Name | Description
ColumnToValue | Converts a value that comes from a database query to an ecospace value.
ColumnType | Specifies the SQL type of the column.
DefaultDbValue | The return value of this function will be used as default value for new columns when databases are created/evolved.
MakeColumnAutoInc | If the database requires any additional operations in addition to the column type to give a column "autoinc" behaviour, that should be performed by this method.
StringToParameter | This method should never be called. Autoinc values are never stored!
ValueToParameter | This method should never be called. Autoinc values are never stored!
ValueType | This method returns the type of the value that is returned by ColumnToValue.


DecimalAsAutoInc.ColumnToValue Method

DecimalAsAutoInc.ColumnToValue Method
DecimalAsAutoInc Class Eco.Persistence.SqlServer Namespace See Also
Collapse All

Converts a value that comes from a database query to an ecospace value.

C#
public override System.Object ColumnToValue(
    System.Object columnValue
);
Remarks

In many cases, the implementation of this method mainly converts DBNull-values to null, but it can also change the CLR-type of the database value from for example a char[] to a string. or from an integer to a boolean. This is the reverse operation of ValueToParameter.

See Also
DecimalAsAutoInc Class
Eco.Persistence.SqlServer Namespace


DecimalAsAutoInc.ColumnType Method

DecimalAsAutoInc.ColumnType Method
DecimalAsAutoInc Class Eco.Persistence.SqlServer Namespace See Also
Collapse All

Specifies the SQL type of the column.

C#
public String ColumnType(
    int length
);
See Also
DecimalAsAutoInc Class
Eco.Persistence.SqlServer Namespace


DecimalAsAutoInc.DefaultDbValue Method

DecimalAsAutoInc.DefaultDbValue Method
DecimalAsAutoInc Class Eco.Persistence.SqlServer Namespace See Also
Collapse All

The return value of this function will be used as default value for new columns when databases are created/evolved.

C#
public override String DefaultDbValue(
    string modeledValue,
    SqlDatabaseConfig sqlDatabaseConfig
);
See Also
DecimalAsAutoInc Class
Eco.Persistence.SqlServer Namespace


DecimalAsAutoInc.MakeColumnAutoInc Method

DecimalAsAutoInc.MakeColumnAutoInc Method
DecimalAsAutoInc Class Eco.Persistence.SqlServer Namespace See Also
Collapse All

If the database requires any additional operations in addition to the column type to give a column "autoinc" behaviour, that should be performed by this method.

C#
public void MakeColumnAutoInc(
    string tableName,
    string columnName,
    IDatabase database
);
Remarks

Even if the database does not require any additional operations, this interface should be implemented by an autoinc attribute mapper, and the implementation of this method should be left blank.

See Also
DecimalAsAutoInc Class
Eco.Persistence.SqlServer Namespace


DecimalAsAutoInc.StringToParameter Method

DecimalAsAutoInc.StringToParameter Method
DecimalAsAutoInc Class Eco.Persistence.SqlServer Namespace See Also
Collapse All

This method should never be called. Autoinc values are never stored!

C#
public void StringToParameter(
    string value,
    IDataParameter parameter
);
Exceptions
Exceptions | Description
NotSupportedException | Thrown always.
See Also
DecimalAsAutoInc Class
Eco.Persistence.SqlServer Namespace


DecimalAsAutoInc.ValueToParameter Method

DecimalAsAutoInc.ValueToParameter Method
DecimalAsAutoInc Class Eco.Persistence.SqlServer Namespace See Also
Collapse All

This method should never be called. Autoinc values are never stored!

C#
public void ValueToParameter(
    System.Object value,
    IDataParameter parameter
);
Exceptions
Exceptions | Description
NotSupportedException | Thrown always.
See Also
DecimalAsAutoInc Class
Eco.Persistence.SqlServer Namespace


DecimalAsAutoInc.ValueType Method

DecimalAsAutoInc.ValueType Method
DecimalAsAutoInc Class Eco.Persistence.SqlServer Namespace See Also
Collapse All

This method returns the type of the value that is returned by ColumnToValue.

C#
public System.Type ValueType();
See Also
DecimalAsAutoInc Class
Eco.Persistence.SqlServer Namespace


DecimalAsDecimal Class

DecimalAsDecimal Class
Inheritance Hierarchy See Also
Collapse All
C#
public sealed class DecimalAsDecimal : AbstractNumericSingleColumnAttribute, ISingleColumnAttributemapping, IDefaultReverseMapping;
Remarks

This is class Eco.Persistence.SqlServer.DecimalAsDecimal.

Inheritance Hierarchy
Eco.Persistence.IDefaultReverseMapping
Eco.Persistence.ISingleColumnAttributemapping
    Eco.Persistence.SqlServer.DecimalAsDecimal
File

SqlServerAttributeMappers.cs

See Also
Inheritance Hierarchy


DecimalAsDecimal.ColumnToValue Method

DecimalAsDecimal.ColumnToValue Method
DecimalAsDecimal Class Eco.Persistence.SqlServer Namespace See Also
Collapse All

Converts a value that comes from a database query to an ecospace value.

C#
public override System.Object ColumnToValue(
    System.Object columnValue
);
Remarks

In many cases, the implementation of this method mainly converts DBNull-values to null, but it can also change the CLR-type of the database value from for example a char[] to a string. or from an integer to a boolean. This is the reverse operation of ValueToParameter.

See Also
DecimalAsDecimal Class
Eco.Persistence.SqlServer Namespace


DecimalAsDecimal.ColumnType Method

DecimalAsDecimal.ColumnType Method
DecimalAsDecimal Class Eco.Persistence.SqlServer Namespace See Also
Collapse All

Specifies the SQL type of the column.

C#
public String ColumnType(
    int length
);
See Also
DecimalAsDecimal Class
Eco.Persistence.SqlServer Namespace


DecimalAsDecimal.StringToParameter Method

DecimalAsDecimal.StringToParameter Method
DecimalAsDecimal Class Eco.Persistence.SqlServer Namespace See Also
Collapse All
C#
public void StringToParameter(
    string value,
    IDataParameter parameter
);
Remarks

This is StringToParameter, a member of class DecimalAsDecimal.

See Also
DecimalAsDecimal Class
Eco.Persistence.SqlServer Namespace


DecimalAsDecimal.ValueToParameter Method

DecimalAsDecimal.ValueToParameter Method
DecimalAsDecimal Class Eco.Persistence.SqlServer Namespace See Also
Collapse All

Converts a value that comes from a database query to an ecospace value.

C#
public void ValueToParameter(
    System.Object value,
    IDataParameter parameter
);
Remarks

In many cases, the implementation of this method mainly converts null to DBNull, but it can also handle conversion from for example booleans to integers, byte[] to database blobs. It also has to set the correct parameter types in the IDataParameter-object. This is the reverse operation of ColumnToValue.

See Also
DecimalAsDecimal Class
Eco.Persistence.SqlServer Namespace


DecimalAsDecimal.ValueType Method

DecimalAsDecimal.ValueType Method
DecimalAsDecimal Class Eco.Persistence.SqlServer Namespace See Also
Collapse All

This method returns the type of the value that is returned by ColumnToValue.

C#
public System.Type ValueType();
See Also
DecimalAsDecimal Class
Eco.Persistence.SqlServer Namespace


DecimalAsDecimal28 Class

DecimalAsDecimal28 Class
Inheritance Hierarchy See Also
Collapse All
C#
public sealed class DecimalAsDecimal28 : AbstractNumericSingleColumnAttribute, ISingleColumnAttributemapping;
Remarks

This is class Eco.Persistence.SqlServer.DecimalAsDecimal28.

Inheritance Hierarchy
Eco.Persistence.ISingleColumnAttributemapping
    Eco.Persistence.SqlServer.DecimalAsDecimal28
File

SqlServerAttributeMappers.cs

See Also
Inheritance Hierarchy


DecimalAsDecimal28 Methods

DecimalAsDecimal28 Methods
Public Methods
Collapse All

The methods of the DecimalAsDecimal28 class are listed here.

Public Methods
Name | Description
ColumnToValue | Converts a value that comes from a database query to an ecospace value.
ColumnType | Specifies the SQL type of the column.
StringToParameter | This is StringToParameter, a member of class DecimalAsDecimal28.
ValueToParameter | Converts a value that comes from a database query to an ecospace value.
ValueType | This method returns the type of the value that is returned by ColumnToValue.


DecimalAsDecimal28.ColumnToValue Method

DecimalAsDecimal28.ColumnToValue Method
DecimalAsDecimal28 Class Eco.Persistence.SqlServer Namespace See Also
Collapse All

Converts a value that comes from a database query to an ecospace value.

C#
public override System.Object ColumnToValue(
    System.Object columnValue
);
Remarks

In many cases, the implementation of this method mainly converts DBNull-values to null, but it can also change the CLR-type of the database value from for example a char[] to a string. or from an integer to a boolean. This is the reverse operation of ValueToParameter.

See Also
DecimalAsDecimal28 Class
Eco.Persistence.SqlServer Namespace


DecimalAsDecimal28.ColumnType Method

DecimalAsDecimal28.ColumnType Method
DecimalAsDecimal28 Class Eco.Persistence.SqlServer Namespace See Also
Collapse All

Specifies the SQL type of the column.

C#
public String ColumnType(
    int length
);
See Also
DecimalAsDecimal28 Class
Eco.Persistence.SqlServer Namespace


DecimalAsDecimal28.StringToParameter Method

DecimalAsDecimal28.StringToParameter Method
DecimalAsDecimal28 Class Eco.Persistence.SqlServer Namespace See Also
Collapse All
C#
public void StringToParameter(
    string value,
    IDataParameter parameter
);
Remarks

This is StringToParameter, a member of class DecimalAsDecimal28.

See Also
DecimalAsDecimal28 Class
Eco.Persistence.SqlServer Namespace


DecimalAsDecimal28.ValueToParameter Method

DecimalAsDecimal28.ValueToParameter Method
DecimalAsDecimal28 Class Eco.Persistence.SqlServer Namespace See Also
Collapse All

Converts a value that comes from a database query to an ecospace value.

C#
public void ValueToParameter(
    System.Object value,
    IDataParameter parameter
);
Remarks

In many cases, the implementation of this method mainly converts null to DBNull, but it can also handle conversion from for example booleans to integers, byte[] to database blobs. It also has to set the correct parameter types in the IDataParameter-object. This is the reverse operation of ColumnToValue.

See Also
DecimalAsDecimal28 Class
Eco.Persistence.SqlServer Namespace


DecimalAsDecimal28.ValueType Method

DecimalAsDecimal28.ValueType Method
DecimalAsDecimal28 Class Eco.Persistence.SqlServer Namespace See Also
Collapse All

This method returns the type of the value that is returned by ColumnToValue.

C#
public System.Type ValueType();
See Also
DecimalAsDecimal28 Class
Eco.Persistence.SqlServer Namespace


DecimalAsMoney Class

DecimalAsMoney Class
Inheritance Hierarchy See Also
Collapse All
C#
public sealed class DecimalAsMoney : AbstractNumericSingleColumnAttribute, ISingleColumnAttributemapping, IDefaultReverseMapping;
Remarks

This is class Eco.Persistence.SqlServer.DecimalAsMoney.

Inheritance Hierarchy
Eco.Persistence.IDefaultReverseMapping
Eco.Persistence.ISingleColumnAttributemapping
    Eco.Persistence.SqlServer.DecimalAsMoney
File

SqlServerAttributeMappers.cs

See Also
Inheritance Hierarchy


DecimalAsMoney Methods

DecimalAsMoney Methods
Public Methods
Collapse All

The methods of the DecimalAsMoney class are listed here.

Public Methods
Name | Description
ColumnToValue | Converts a value that comes from a database query to an ecospace value.
ColumnType | Specifies the SQL type of the column.
StringToParameter | This is StringToParameter, a member of class DecimalAsMoney.
ValueToParameter | Converts a value that comes from a database query to an ecospace value.
ValueType | This method returns the type of the value that is returned by ColumnToValue.


DecimalAsMoney.ColumnToValue Method

DecimalAsMoney.ColumnToValue Method
DecimalAsMoney Class Eco.Persistence.SqlServer Namespace See Also
Collapse All

Converts a value that comes from a database query to an ecospace value.

C#
public override System.Object ColumnToValue(
    System.Object columnValue
);
Remarks

In many cases, the implementation of this method mainly converts DBNull-values to null, but it can also change the CLR-type of the database value from for example a char[] to a string. or from an integer to a boolean. This is the reverse operation of ValueToParameter.

See Also
DecimalAsMoney Class
Eco.Persistence.SqlServer Namespace


DecimalAsMoney.ColumnType Method

DecimalAsMoney.ColumnType Method
DecimalAsMoney Class Eco.Persistence.SqlServer Namespace See Also
Collapse All

Specifies the SQL type of the column.

C#
public String ColumnType(
    int length
);
See Also
DecimalAsMoney Class
Eco.Persistence.SqlServer Namespace


DecimalAsMoney.StringToParameter Method

DecimalAsMoney.StringToParameter Method
DecimalAsMoney Class Eco.Persistence.SqlServer Namespace See Also
Collapse All
C#
public void StringToParameter(
    string value,
    IDataParameter parameter
);
Remarks

This is StringToParameter, a member of class DecimalAsMoney.

See Also
DecimalAsMoney Class
Eco.Persistence.SqlServer Namespace


DecimalAsMoney.ValueToParameter Method

DecimalAsMoney.ValueToParameter Method
DecimalAsMoney Class Eco.Persistence.SqlServer Namespace See Also
Collapse All

Converts a value that comes from a database query to an ecospace value.

C#
public void ValueToParameter(
    System.Object value,
    IDataParameter parameter
);
Remarks

In many cases, the implementation of this method mainly converts null to DBNull, but it can also handle conversion from for example booleans to integers, byte[] to database blobs. It also has to set the correct parameter types in the IDataParameter-object. This is the reverse operation of ColumnToValue.

See Also
DecimalAsMoney Class
Eco.Persistence.SqlServer Namespace


DecimalAsMoney.ValueType Method

DecimalAsMoney.ValueType Method
DecimalAsMoney Class Eco.Persistence.SqlServer Namespace See Also
Collapse All

This method returns the type of the value that is returned by ColumnToValue.

C#
public System.Type ValueType();
See Also
DecimalAsMoney Class
Eco.Persistence.SqlServer Namespace


DecimalAsSmallMoney Class

DecimalAsSmallMoney Class
Inheritance Hierarchy See Also
Collapse All
C#
public sealed class DecimalAsSmallMoney : AbstractNumericSingleColumnAttribute, ISingleColumnAttributemapping, IDefaultReverseMapping;
Remarks

This is class Eco.Persistence.SqlServer.DecimalAsSmallMoney.

Inheritance Hierarchy
Eco.Persistence.IDefaultReverseMapping
Eco.Persistence.ISingleColumnAttributemapping
    Eco.Persistence.SqlServer.DecimalAsSmallMoney
File

SqlServerAttributeMappers.cs

See Also
Inheritance Hierarchy


DecimalAsSmallMoney Methods

DecimalAsSmallMoney Methods
Public Methods
Collapse All

The methods of the DecimalAsSmallMoney class are listed here.

Public Methods
Name | Description
ColumnToValue | Converts a value that comes from a database query to an ecospace value.
ColumnType | Specifies the SQL type of the column.
StringToParameter | This is StringToParameter, a member of class DecimalAsSmallMoney.
ValueToParameter | Converts a value that comes from a database query to an ecospace value.
ValueType | This method returns the type of the value that is returned by ColumnToValue.


DecimalAsSmallMoney.ColumnToValue Method

DecimalAsSmallMoney.ColumnToValue Method
DecimalAsSmallMoney Class Eco.Persistence.SqlServer Namespace See Also
Collapse All

Converts a value that comes from a database query to an ecospace value.

C#
public override System.Object ColumnToValue(
    System.Object columnValue
);
Remarks

In many cases, the implementation of this method mainly converts DBNull-values to null, but it can also change the CLR-type of the database value from for example a char[] to a string. or from an integer to a boolean. This is the reverse operation of ValueToParameter.

See Also
DecimalAsSmallMoney Class
Eco.Persistence.SqlServer Namespace


DecimalAsSmallMoney.ColumnType Method

DecimalAsSmallMoney.ColumnType Method
DecimalAsSmallMoney Class Eco.Persistence.SqlServer Namespace See Also
Collapse All

Specifies the SQL type of the column.

C#
public String ColumnType(
    int length
);
See Also
DecimalAsSmallMoney Class
Eco.Persistence.SqlServer Namespace


DecimalAsSmallMoney.StringToParameter Method

DecimalAsSmallMoney.StringToParameter Method
DecimalAsSmallMoney Class Eco.Persistence.SqlServer Namespace See Also
Collapse All
C#
public void StringToParameter(
    string value,
    IDataParameter parameter
);
Remarks

This is StringToParameter, a member of class DecimalAsSmallMoney.

See Also
DecimalAsSmallMoney Class
Eco.Persistence.SqlServer Namespace


DecimalAsSmallMoney.ValueToParameter Method

DecimalAsSmallMoney.ValueToParameter Method
DecimalAsSmallMoney Class Eco.Persistence.SqlServer Namespace See Also
Collapse All

Converts a value that comes from a database query to an ecospace value.

C#
public void ValueToParameter(
    System.Object value,
    IDataParameter parameter
);
Remarks

In many cases, the implementation of this method mainly converts null to DBNull, but it can also handle conversion from for example booleans to integers, byte[] to database blobs. It also has to set the correct parameter types in the IDataParameter-object. This is the reverse operation of ColumnToValue.

See Also
DecimalAsSmallMoney Class
Eco.Persistence.SqlServer Namespace


DecimalAsSmallMoney.ValueType Method

DecimalAsSmallMoney.ValueType Method
DecimalAsSmallMoney Class Eco.Persistence.SqlServer Namespace See Also
Collapse All

This method returns the type of the value that is returned by ColumnToValue.

C#
public System.Type ValueType();
See Also
DecimalAsSmallMoney Class
Eco.Persistence.SqlServer Namespace


GuidAsUniqueIdentifier Class

GuidAsUniqueIdentifier Class
Inheritance Hierarchy See Also
Collapse All
C#
public sealed class GuidAsUniqueIdentifier : AbstractSingleColumnAttribute, ISingleColumnAttributemapping, IDefaultReverseMapping;
Remarks

This is class Eco.Persistence.SqlServer.GuidAsUniqueIdentifier.

Inheritance Hierarchy
Eco.Persistence.IDefaultReverseMapping
Eco.Persistence.ISingleColumnAttributemapping
    Eco.Persistence.SqlServer.GuidAsUniqueIdentifier
File

SqlServerAttributeMappers.cs

See Also
Inheritance Hierarchy


GuidAsUniqueIdentifier Methods

GuidAsUniqueIdentifier Methods
Public Methods
Collapse All

The methods of the GuidAsUniqueIdentifier class are listed here.

Public Methods
Name | Description
ColumnToValue | Converts a value that comes from a database query to an ecospace value.
ColumnType | Specifies the SQL type of the column.
DefaultDbValue | The return value of this function will be used as default value for new columns when databases are created/evolved.
StringToParameter | This is StringToParameter, a member of class GuidAsUniqueIdentifier.
ValueToParameter | Converts a value that comes from a database query to an ecospace value.
ValueType | This method returns the type of the value that is returned by ColumnToValue.


GuidAsUniqueIdentifier.ColumnToValue Method

GuidAsUniqueIdentifier.ColumnToValue Method
GuidAsUniqueIdentifier Class Eco.Persistence.SqlServer Namespace See Also
Collapse All

Converts a value that comes from a database query to an ecospace value.

C#
public override System.Object ColumnToValue(
    System.Object columnValue
);
Remarks

In many cases, the implementation of this method mainly converts DBNull-values to null, but it can also change the CLR-type of the database value from for example a char[] to a string. or from an integer to a boolean. This is the reverse operation of ValueToParameter.

See Also
GuidAsUniqueIdentifier Class
Eco.Persistence.SqlServer Namespace


GuidAsUniqueIdentifier.ColumnType Method

GuidAsUniqueIdentifier.ColumnType Method
GuidAsUniqueIdentifier Class Eco.Persistence.SqlServer Namespace See Also
Collapse All

Specifies the SQL type of the column.

C#
public string ColumnType(
    int length
);
See Also
GuidAsUniqueIdentifier Class
Eco.Persistence.SqlServer Namespace


GuidAsUniqueIdentifier.DefaultDbValue Method

GuidAsUniqueIdentifier.DefaultDbValue Method
GuidAsUniqueIdentifier Class Eco.Persistence.SqlServer Namespace See Also
Collapse All

The return value of this function will be used as default value for new columns when databases are created/evolved.

C#
public String DefaultDbValue(
    string modeledValue,
    SqlDatabaseConfig sqlDatabaseConfig
);
See Also
GuidAsUniqueIdentifier Class
Eco.Persistence.SqlServer Namespace


GuidAsUniqueIdentifier.StringToParameter Method

GuidAsUniqueIdentifier.StringToParameter Method
GuidAsUniqueIdentifier Class Eco.Persistence.SqlServer Namespace See Also
Collapse All
C#
public void StringToParameter(
    string value,
    IDataParameter parameter
);
Remarks

This is StringToParameter, a member of class GuidAsUniqueIdentifier.

See Also
GuidAsUniqueIdentifier Class
Eco.Persistence.SqlServer Namespace


GuidAsUniqueIdentifier.ValueToParameter Method

GuidAsUniqueIdentifier.ValueToParameter Method
GuidAsUniqueIdentifier Class Eco.Persistence.SqlServer Namespace See Also
Collapse All

Converts a value that comes from a database query to an ecospace value.

C#
public void ValueToParameter(
    System.Object value,
    IDataParameter parameter
);
Remarks

In many cases, the implementation of this method mainly converts null to DBNull, but it can also handle conversion from for example booleans to integers, byte[] to database blobs. It also has to set the correct parameter types in the IDataParameter-object. This is the reverse operation of ColumnToValue.

See Also
GuidAsUniqueIdentifier Class
Eco.Persistence.SqlServer Namespace


GuidAsUniqueIdentifier.ValueType Method

GuidAsUniqueIdentifier.ValueType Method
GuidAsUniqueIdentifier Class Eco.Persistence.SqlServer Namespace See Also
Collapse All

This method returns the type of the value that is returned by ColumnToValue.

C#
public System.Type ValueType();
See Also
GuidAsUniqueIdentifier Class
Eco.Persistence.SqlServer Namespace


GuidAsUniqueIdentifierWithDefault Class

GuidAsUniqueIdentifierWithDefault Class
Inheritance Hierarchy See Also
Collapse All

Mapper between a GUID value of type Decimal and its persistent representation using a new GUID as default value.

C#
public sealed class GuidAsUniqueIdentifierWithDefault : AbstractSingleColumnAttribute, IAutoIncAttributemapping;
Inheritance Hierarchy
Eco.Persistence.ISingleColumnAttributemapping
    Eco.Persistence.IAutoIncAttributemapping
        Eco.Persistence.SqlServer.GuidAsUniqueIdentifierWithDefault
File

SqlServerAttributeMappers.cs

See Also
Inheritance Hierarchy


GuidAsUniqueIdentifierWithDefault Methods

GuidAsUniqueIdentifierWithDefault Methods
Public Methods
Collapse All

The methods of the GuidAsUniqueIdentifierWithDefault class are listed here.

Public Methods
Name | Description
ColumnToValue | Converts a value that comes from a database query to an ecospace value.
ColumnType | Specifies the SQL type of the column.
DefaultDbValue | The return value of this function will be used as default value for new columns when databases are created/evolved.
MakeColumnAutoInc | If the database requires any additional operations in addition to the column type to give a column "autoinc" behaviour, that should be performed by this method.
StringToParameter | This method should never be called. Autoinc values are never stored!
ValueToParameter | This method should never be called. Autoinc values are never stored!
ValueType | This method returns the type of the value that is returned by ColumnToValue.


GuidAsUniqueIdentifierWithDefault.ColumnToValue Method

GuidAsUniqueIdentifierWithDefault.ColumnToValue Method
GuidAsUniqueIdentifierWithDefault Class Eco.Persistence.SqlServer Namespace See Also
Collapse All

Converts a value that comes from a database query to an ecospace value.

C#
public override System.Object ColumnToValue(
    System.Object columnValue
);
Remarks

In many cases, the implementation of this method mainly converts DBNull-values to null, but it can also change the CLR-type of the database value from for example a char[] to a string. or from an integer to a boolean. This is the reverse operation of ValueToParameter.

See Also
GuidAsUniqueIdentifierWithDefault Class
Eco.Persistence.SqlServer Namespace


GuidAsUniqueIdentifierWithDefault.ColumnType Method

GuidAsUniqueIdentifierWithDefault.ColumnType Method
GuidAsUniqueIdentifierWithDefault Class Eco.Persistence.SqlServer Namespace See Also
Collapse All

Specifies the SQL type of the column.

C#
public String ColumnType(
    int length
);
See Also
GuidAsUniqueIdentifierWithDefault Class
Eco.Persistence.SqlServer Namespace


GuidAsUniqueIdentifierWithDefault.DefaultDbValue Method

GuidAsUniqueIdentifierWithDefault.DefaultDbValue Method
GuidAsUniqueIdentifierWithDefault Class Eco.Persistence.SqlServer Namespace See Also
Collapse All

The return value of this function will be used as default value for new columns when databases are created/evolved.

C#
public String DefaultDbValue(
    string modeledValue,
    SqlDatabaseConfig sqlDatabaseConfig
);
See Also
GuidAsUniqueIdentifierWithDefault Class
Eco.Persistence.SqlServer Namespace


GuidAsUniqueIdentifierWithDefault.MakeColumnAutoInc Method

GuidAsUniqueIdentifierWithDefault.MakeColumnAutoInc Method
GuidAsUniqueIdentifierWithDefault Class Eco.Persistence.SqlServer Namespace See Also
Collapse All

If the database requires any additional operations in addition to the column type to give a column "autoinc" behaviour, that should be performed by this method.

C#
public void MakeColumnAutoInc(
    string tableName,
    string columnName,
    IDatabase database
);
Remarks

Even if the database does not require any additional operations, this interface should be implemented by an autoinc attribute mapper, and the implementation of this method should be left blank.

See Also
GuidAsUniqueIdentifierWithDefault Class
Eco.Persistence.SqlServer Namespace


GuidAsUniqueIdentifierWithDefault.StringToParameter Method

GuidAsUniqueIdentifierWithDefault.StringToParameter Method
GuidAsUniqueIdentifierWithDefault Class Eco.Persistence.SqlServer Namespace See Also
Collapse All

This method should never be called. Autoinc values are never stored!

C#
public void StringToParameter(
    string value,
    IDataParameter parameter
);
Exceptions
Exceptions | Description
NotSupportedException | Thrown always.
See Also
GuidAsUniqueIdentifierWithDefault Class
Eco.Persistence.SqlServer Namespace


GuidAsUniqueIdentifierWithDefault.ValueToParameter Method

GuidAsUniqueIdentifierWithDefault.ValueToParameter Method
GuidAsUniqueIdentifierWithDefault Class Eco.Persistence.SqlServer Namespace See Also
Collapse All

This method should never be called. Autoinc values are never stored!

C#
public void ValueToParameter(
    System.Object value,
    IDataParameter parameter
);
Exceptions
Exceptions | Description
NotSupportedException | Thrown always.
See Also
GuidAsUniqueIdentifierWithDefault Class
Eco.Persistence.SqlServer Namespace


GuidAsUniqueIdentifierWithDefault.ValueType Method

GuidAsUniqueIdentifierWithDefault.ValueType Method
GuidAsUniqueIdentifierWithDefault Class Eco.Persistence.SqlServer Namespace See Also
Collapse All

This method returns the type of the value that is returned by ColumnToValue.

C#
public System.Type ValueType();
See Also
GuidAsUniqueIdentifierWithDefault Class
Eco.Persistence.SqlServer Namespace


Int16AsAutoInc Class

Int16AsAutoInc Class
Inheritance Hierarchy See Also
Collapse All

Mapper between an AutoInc value of type Int16 and its persistent representation as SMALLINT.

C#
public sealed class Int16AsAutoInc : AbstractNumericSingleColumnAttribute, IAutoIncAttributemapping, IDefaultReverseMapping;
Inheritance Hierarchy
Eco.Persistence.ISingleColumnAttributemapping
    Eco.Persistence.IAutoIncAttributemapping
    Eco.Persistence.IDefaultReverseMapping
        Eco.Persistence.SqlServer.Int16AsAutoInc
File

SqlServerAttributeMappers.cs

See Also
Inheritance Hierarchy


Int16AsAutoInc.ColumnToValue Method

Int16AsAutoInc.ColumnToValue Method
Int16AsAutoInc Class Eco.Persistence.SqlServer Namespace See Also
Collapse All

Converts a value that comes from a database query to an ecospace value.

C#
public override System.Object ColumnToValue(
    System.Object columnValue
);
Remarks

In many cases, the implementation of this method mainly converts DBNull-values to null, but it can also change the CLR-type of the database value from for example a char[] to a string. or from an integer to a boolean. This is the reverse operation of ValueToParameter.

See Also
Int16AsAutoInc Class
Eco.Persistence.SqlServer Namespace


Int16AsAutoInc.ColumnType Method

Int16AsAutoInc.ColumnType Method
Int16AsAutoInc Class Eco.Persistence.SqlServer Namespace See Also
Collapse All

Specifies the SQL type of the column.

C#
public String ColumnType(
    int length
);
See Also
Int16AsAutoInc Class
Eco.Persistence.SqlServer Namespace


Int16AsAutoInc.DefaultDbValue Method

Int16AsAutoInc.DefaultDbValue Method
Int16AsAutoInc Class Eco.Persistence.SqlServer Namespace See Also
Collapse All

The return value of this function will be used as default value for new columns when databases are created/evolved.

C#
public override String DefaultDbValue(
    string modeledValue,
    SqlDatabaseConfig sqlDatabaseConfig
);
See Also
Int16AsAutoInc Class
Eco.Persistence.SqlServer Namespace


Int16AsAutoInc.MakeColumnAutoInc Method

Int16AsAutoInc.MakeColumnAutoInc Method
Int16AsAutoInc Class Eco.Persistence.SqlServer Namespace See Also
Collapse All

If the database requires any additional operations in addition to the column type to give a column "autoinc" behaviour, that should be performed by this method.

C#
public void MakeColumnAutoInc(
    string tableName,
    string columnName,
    IDatabase database
);
Remarks

Even if the database does not require any additional operations, this interface should be implemented by an autoinc attribute mapper, and the implementation of this method should be left blank.

See Also
Int16AsAutoInc Class
Eco.Persistence.SqlServer Namespace


Int16AsAutoInc.StringToParameter Method

Int16AsAutoInc.StringToParameter Method
Int16AsAutoInc Class Eco.Persistence.SqlServer Namespace See Also
Collapse All

This method should never be called. Autoinc values are never stored!

C#
public void StringToParameter(
    string value,
    IDataParameter parameter
);
Exceptions
Exceptions | Description
NotSupportedException | Thrown always.
See Also
Int16AsAutoInc Class
Eco.Persistence.SqlServer Namespace


Int16AsAutoInc.ValueToParameter Method

Int16AsAutoInc.ValueToParameter Method
Int16AsAutoInc Class Eco.Persistence.SqlServer Namespace See Also
Collapse All

This method should never be called. Autoinc values are never stored!

C#
public void ValueToParameter(
    System.Object value,
    IDataParameter parameter
);
Exceptions
Exceptions | Description
NotSupportedException | Thrown always.
See Also
Int16AsAutoInc Class
Eco.Persistence.SqlServer Namespace


Int16AsAutoInc.ValueType Method

Int16AsAutoInc.ValueType Method
Int16AsAutoInc Class Eco.Persistence.SqlServer Namespace See Also
Collapse All

This method returns the type of the value that is returned by ColumnToValue.

C#
public System.Type ValueType();
See Also
Int16AsAutoInc Class
Eco.Persistence.SqlServer Namespace


Int32AsAutoInc Class

Int32AsAutoInc Class
Inheritance Hierarchy See Also
Collapse All

Mapper between an AutoInc value of type Int32 and its persistent representation as INTEGER.

C#
public sealed class Int32AsAutoInc : AbstractNumericSingleColumnAttribute, IAutoIncAttributemapping, IDefaultReverseMapping;
Inheritance Hierarchy
Eco.Persistence.ISingleColumnAttributemapping
    Eco.Persistence.IAutoIncAttributemapping
    Eco.Persistence.IDefaultReverseMapping
        Eco.Persistence.SqlServer.Int32AsAutoInc
File

SqlServerAttributeMappers.cs

See Also
Inheritance Hierarchy


Int32AsAutoInc.ColumnToValue Method

Int32AsAutoInc.ColumnToValue Method
Int32AsAutoInc Class Eco.Persistence.SqlServer Namespace See Also
Collapse All

Converts a value that comes from a database query to an ecospace value.

C#
public override System.Object ColumnToValue(
    System.Object columnValue
);
Remarks

In many cases, the implementation of this method mainly converts DBNull-values to null, but it can also change the CLR-type of the database value from for example a char[] to a string. or from an integer to a boolean. This is the reverse operation of ValueToParameter.

See Also
Int32AsAutoInc Class
Eco.Persistence.SqlServer Namespace


Int32AsAutoInc.ColumnType Method

Int32AsAutoInc.ColumnType Method
Int32AsAutoInc Class Eco.Persistence.SqlServer Namespace See Also
Collapse All

Specifies the SQL type of the column.

C#
public String ColumnType(
    int length
);
See Also
Int32AsAutoInc Class
Eco.Persistence.SqlServer Namespace


Int32AsAutoInc.DefaultDbValue Method

Int32AsAutoInc.DefaultDbValue Method
Int32AsAutoInc Class Eco.Persistence.SqlServer Namespace See Also
Collapse All

The return value of this function will be used as default value for new columns when databases are created/evolved.

C#
public override String DefaultDbValue(
    string modeledValue,
    SqlDatabaseConfig sqlDatabaseConfig
);
See Also
Int32AsAutoInc Class
Eco.Persistence.SqlServer Namespace


Int32AsAutoInc.MakeColumnAutoInc Method

Int32AsAutoInc.MakeColumnAutoInc Method
Int32AsAutoInc Class Eco.Persistence.SqlServer Namespace See Also
Collapse All

If the database requires any additional operations in addition to the column type to give a column "autoinc" behaviour, that should be performed by this method.

C#
public void MakeColumnAutoInc(
    string tableName,
    string columnName,
    IDatabase database
);
Remarks

Even if the database does not require any additional operations, this interface should be implemented by an autoinc attribute mapper, and the implementation of this method should be left blank.

See Also
Int32AsAutoInc Class
Eco.Persistence.SqlServer Namespace


Int32AsAutoInc.StringToParameter Method

Int32AsAutoInc.StringToParameter Method
Int32AsAutoInc Class Eco.Persistence.SqlServer Namespace See Also
Collapse All

This method should never be called. Autoinc values are never stored!

C#
public void StringToParameter(
    string value,
    IDataParameter parameter
);
Exceptions
Exceptions | Description
NotSupportedException | Thrown always.
See Also
Int32AsAutoInc Class
Eco.Persistence.SqlServer Namespace


Int32AsAutoInc.ValueToParameter Method

Int32AsAutoInc.ValueToParameter Method
Int32AsAutoInc Class Eco.Persistence.SqlServer Namespace See Also
Collapse All

This method should never be called. Autoinc values are never stored!

C#
public void ValueToParameter(
    System.Object value,
    IDataParameter parameter
);
Exceptions
Exceptions | Description
NotSupportedException | Thrown always.
See Also
Int32AsAutoInc Class
Eco.Persistence.SqlServer Namespace


Int32AsAutoInc.ValueType Method

Int32AsAutoInc.ValueType Method
Int32AsAutoInc Class Eco.Persistence.SqlServer Namespace See Also
Collapse All

This method returns the type of the value that is returned by ColumnToValue.

C#
public System.Type ValueType();
See Also
Int32AsAutoInc Class
Eco.Persistence.SqlServer Namespace


Int32AsInt Class

Int32AsInt Class
Inheritance Hierarchy See Also
Collapse All

Class for mapping Int32 values to a single column in a database.

C#
public sealed class Int32AsInt : AbstractNumericSingleColumnAttribute, ISingleColumnAttributemapping, IDefaultReverseMapping;
Inheritance Hierarchy
Eco.Persistence.IDefaultReverseMapping
Eco.Persistence.ISingleColumnAttributemapping
    Eco.Persistence.SqlServer.Int32AsInt
File

SqlServerAttributeMappers.cs

See Also
Inheritance Hierarchy


Int32AsInt Methods

Int32AsInt Methods
Public Methods
Collapse All

The methods of the Int32AsInt class are listed here.

Public Methods
Name | Description
ColumnToValue | Converts a value that comes from a database query to an ecospace value.
ColumnType | Returns the SQL type used by the database during CREATE TABLE execution.
StringToParameter | Converts a string to the correct data type and then inserts the given value into the IDataParameter.
ValueToParameter | Inserts the given value into the IDataParameter.
ValueType | Returns the .NET type of the column.


Int32AsInt.ColumnToValue Method

Int32AsInt.ColumnToValue Method
Int32AsInt Class Eco.Persistence.SqlServer Namespace See Also
Collapse All

Converts a value that comes from a database query to an ecospace value.

C#
public override System.Object ColumnToValue(
    System.Object columnValue
);
Remarks

In many cases, the implementation of this method mainly converts DBNull-values to null, but it can also change the CLR-type of the database value from for example a char[] to a string. or from an integer to a boolean. This is the reverse operation of ValueToParameter.

See Also
Int32AsInt Class
Eco.Persistence.SqlServer Namespace


Int32AsInt.ColumnType Method

Int32AsInt.ColumnType Method
Int32AsInt Class Eco.Persistence.SqlServer Namespace See Also
Collapse All

Returns the SQL type used by the database during CREATE TABLE execution.

C#
public String ColumnType(
    int length
);
Parameters
Parameters | Description
length | This parameter is ignored.
See Also
Int32AsInt Class
Eco.Persistence.SqlServer Namespace


Int32AsInt.StringToParameter Method

Int32AsInt.StringToParameter Method
Int32AsInt Class Eco.Persistence.SqlServer Namespace See Also
Collapse All

Converts a string to the correct data type and then inserts the given value into the IDataParameter.

C#
public void StringToParameter(
    string value,
    IDataParameter parameter
);
Parameters
Parameters | Description
value | The value to use.
parameter | The IDataParameter to update.
See Also
Int32AsInt Class
Eco.Persistence.SqlServer Namespace


Int32AsInt.ValueToParameter Method

Int32AsInt.ValueToParameter Method
Int32AsInt Class Eco.Persistence.SqlServer Namespace See Also
Collapse All

Inserts the given value into the IDataParameter.

C#
public void ValueToParameter(
    System.Object value,
    IDataParameter parameter
);
Parameters
Parameters | Description
value | The value to use.
parameter | The IDataParameter to update.
See Also
Int32AsInt Class
Eco.Persistence.SqlServer Namespace


Int32AsInt.ValueType Method

Int32AsInt.ValueType Method
Int32AsInt Class Eco.Persistence.SqlServer Namespace See Also
Collapse All

Returns the .NET type of the column.

C#
public System.Type ValueType();
See Also
Int32AsInt Class
Eco.Persistence.SqlServer Namespace


Int64AsLongInteger Class

Int64AsLongInteger Class
Inheritance Hierarchy See Also
Collapse All
C#
public sealed class Int64AsLongInteger : AbstractNumericSingleColumnAttribute, ISingleColumnAttributemapping, IDefaultReverseMapping;
Remarks

This is class Eco.Persistence.SqlServer.Int64AsLongInteger.

Inheritance Hierarchy
Eco.Persistence.IDefaultReverseMapping
Eco.Persistence.ISingleColumnAttributemapping
    Eco.Persistence.SqlServer.Int64AsLongInteger
File

SqlServerAttributeMappers.cs

See Also
Inheritance Hierarchy


Int64AsLongInteger.ColumnToValue Method

Int64AsLongInteger.ColumnToValue Method
Int64AsLongInteger Class Eco.Persistence.SqlServer Namespace See Also
Collapse All

Converts a value that comes from a database query to an ecospace value.

C#
public override System.Object ColumnToValue(
    System.Object columnValue
);
Remarks

In many cases, the implementation of this method mainly converts DBNull-values to null, but it can also change the CLR-type of the database value from for example a char[] to a string. or from an integer to a boolean. This is the reverse operation of ValueToParameter.

See Also
Int64AsLongInteger Class
Eco.Persistence.SqlServer Namespace


Int64AsLongInteger.ColumnType Method

Int64AsLongInteger.ColumnType Method
Int64AsLongInteger Class Eco.Persistence.SqlServer Namespace See Also
Collapse All

Specifies the SQL type of the column.

C#
public String ColumnType(
    int length
);
See Also
Int64AsLongInteger Class
Eco.Persistence.SqlServer Namespace


Int64AsLongInteger.StringToParameter Method

Int64AsLongInteger.StringToParameter Method
Int64AsLongInteger Class Eco.Persistence.SqlServer Namespace See Also
Collapse All
C#
public void StringToParameter(
    string value,
    IDataParameter parameter
);
Remarks

This is StringToParameter, a member of class Int64AsLongInteger.

See Also
Int64AsLongInteger Class
Eco.Persistence.SqlServer Namespace


Int64AsLongInteger.ValueToParameter Method

Int64AsLongInteger.ValueToParameter Method
Int64AsLongInteger Class Eco.Persistence.SqlServer Namespace See Also
Collapse All

Converts a value that comes from a database query to an ecospace value.

C#
public void ValueToParameter(
    System.Object value,
    IDataParameter parameter
);
Remarks

In many cases, the implementation of this method mainly converts null to DBNull, but it can also handle conversion from for example booleans to integers, byte[] to database blobs. It also has to set the correct parameter types in the IDataParameter-object. This is the reverse operation of ColumnToValue.

See Also
Int64AsLongInteger Class
Eco.Persistence.SqlServer Namespace


Int64AsLongInteger.ValueType Method

Int64AsLongInteger.ValueType Method
Int64AsLongInteger Class Eco.Persistence.SqlServer Namespace See Also
Collapse All

This method returns the type of the value that is returned by ColumnToValue.

C#
public System.Type ValueType();
See Also
Int64AsLongInteger Class
Eco.Persistence.SqlServer Namespace


Int64AsTimeStamp Class

Int64AsTimeStamp Class
Inheritance Hierarchy See Also
Collapse All
C#
public sealed class Int64AsTimeStamp : AbstractSingleColumnAttribute, ISingleColumnAttributemapping;
Remarks

This is class Eco.Persistence.SqlServer.Int64AsTimeStamp.

Inheritance Hierarchy
Eco.Persistence.ISingleColumnAttributemapping
    Eco.Persistence.SqlServer.Int64AsTimeStamp
File

SqlServerAttributeMappers.cs

See Also
Inheritance Hierarchy


Int64AsTimeStamp Methods

Int64AsTimeStamp Methods
Public Methods
Collapse All

The methods of the Int64AsTimeStamp class are listed here.

Public Methods
Name | Description
ColumnToValue | Converts a value that comes from a database query to an ecospace value.
ColumnType | Specifies the SQL type of the column.
DefaultDbValue | The return value of this function will be used as default value for new columns when databases are created/evolved.
IsEqual | Returns true if an ecospace value ("value") is equal to a database value ("columnValue").
StringToParameter |
ValueToParameter |
ValueType | This method returns the type of the value that is returned by ColumnToValue.


Int64AsTimeStamp.ColumnToValue Method

Int64AsTimeStamp.ColumnToValue Method
Int64AsTimeStamp Class Eco.Persistence.SqlServer Namespace See Also
Collapse All

Converts a value that comes from a database query to an ecospace value.

C#
public override System.Object ColumnToValue(
    System.Object columnValue
);
Remarks

In many cases, the implementation of this method mainly converts DBNull-values to null, but it can also change the CLR-type of the database value from for example a char[] to a string. or from an integer to a boolean. This is the reverse operation of ValueToParameter.

See Also
Int64AsTimeStamp Class
Eco.Persistence.SqlServer Namespace


Int64AsTimeStamp.ColumnType Method

Int64AsTimeStamp.ColumnType Method
Int64AsTimeStamp Class Eco.Persistence.SqlServer Namespace See Also
Collapse All

Specifies the SQL type of the column.

C#
public String ColumnType(
    int length
);
See Also
Int64AsTimeStamp Class
Eco.Persistence.SqlServer Namespace


Int64AsTimeStamp.DefaultDbValue Method

Int64AsTimeStamp.DefaultDbValue Method
Int64AsTimeStamp Class Eco.Persistence.SqlServer Namespace See Also
Collapse All

The return value of this function will be used as default value for new columns when databases are created/evolved.

C#
public String DefaultDbValue(
    string modeledValue,
    SqlDatabaseConfig sqlDatabaseConfig
);
See Also
Int64AsTimeStamp Class
Eco.Persistence.SqlServer Namespace


Int64AsTimeStamp.IsEqual Method

Int64AsTimeStamp.IsEqual Method
Int64AsTimeStamp Class Eco.Persistence.SqlServer Namespace See Also
Collapse All

Returns true if an ecospace value ("value") is equal to a database value ("columnValue").

C#
public override bool IsEqual(
    System.Object value,
    System.Object columnValue
);
Remarks

This method must handle the conversions between ecospace and database values, it must also handle comparing null/DBNull values.

See Also
Int64AsTimeStamp Class
Eco.Persistence.SqlServer Namespace


Int64AsTimeStamp.StringToParameter Method

Int64AsTimeStamp.StringToParameter Method
Int64AsTimeStamp Class Eco.Persistence.SqlServer Namespace See Also
Collapse All
C#
public void StringToParameter(
    string value,
    IDataParameter parameter
);
Exceptions
Exceptions | Description
InvalidOperationException | Thrown always.
See Also
Int64AsTimeStamp Class
Eco.Persistence.SqlServer Namespace


Int64AsTimeStamp.ValueToParameter Method

Int64AsTimeStamp.ValueToParameter Method
Int64AsTimeStamp Class Eco.Persistence.SqlServer Namespace See Also
Collapse All
C#
public void ValueToParameter(
    System.Object value,
    IDataParameter parameter
);
Exceptions
Exceptions | Description
InvalidOperationException | Thrown always.
See Also
Int64AsTimeStamp Class
Eco.Persistence.SqlServer Namespace


Int64AsTimeStamp.ValueType Method

Int64AsTimeStamp.ValueType Method
Int64AsTimeStamp Class Eco.Persistence.SqlServer Namespace See Also
Collapse All

This method returns the type of the value that is returned by ColumnToValue.

C#
public System.Type ValueType();
See Also
Int64AsTimeStamp Class
Eco.Persistence.SqlServer Namespace


SingleAsFloat Class

SingleAsFloat Class
Inheritance Hierarchy See Also
Collapse All
C#
public sealed class SingleAsFloat : AbstractNumericSingleColumnAttribute, ISingleColumnAttributemapping, IDefaultReverseMapping;
Remarks

This is class Eco.Persistence.SqlServer.SingleAsFloat.

Inheritance Hierarchy
Eco.Persistence.IDefaultReverseMapping
Eco.Persistence.ISingleColumnAttributemapping
    Eco.Persistence.SqlServer.SingleAsFloat
File

SqlServerAttributeMappers.cs

See Also
Inheritance Hierarchy


SingleAsFloat.ColumnToValue Method

SingleAsFloat.ColumnToValue Method
SingleAsFloat Class Eco.Persistence.SqlServer Namespace See Also
Collapse All

Converts a value that comes from a database query to an ecospace value.

C#
public override System.Object ColumnToValue(
    System.Object columnValue
);
Remarks

In many cases, the implementation of this method mainly converts DBNull-values to null, but it can also change the CLR-type of the database value from for example a char[] to a string. or from an integer to a boolean. This is the reverse operation of ValueToParameter.

See Also
SingleAsFloat Class
Eco.Persistence.SqlServer Namespace


SingleAsFloat.ColumnType Method

SingleAsFloat.ColumnType Method
SingleAsFloat Class Eco.Persistence.SqlServer Namespace See Also
Collapse All

Specifies the SQL type of the column.

C#
public String ColumnType(
    int length
);
See Also
SingleAsFloat Class
Eco.Persistence.SqlServer Namespace


SingleAsFloat.StringToParameter Method

SingleAsFloat.StringToParameter Method
SingleAsFloat Class Eco.Persistence.SqlServer Namespace See Also
Collapse All
C#
public void StringToParameter(
    string value,
    IDataParameter parameter
);
Remarks

This is StringToParameter, a member of class SingleAsFloat.

See Also
SingleAsFloat Class
Eco.Persistence.SqlServer Namespace


SingleAsFloat.ValueToParameter Method

SingleAsFloat.ValueToParameter Method
SingleAsFloat Class Eco.Persistence.SqlServer Namespace See Also
Collapse All

Converts a value that comes from a database query to an ecospace value.

C#
public void ValueToParameter(
    System.Object value,
    IDataParameter parameter
);
Remarks

In many cases, the implementation of this method mainly converts null to DBNull, but it can also handle conversion from for example booleans to integers, byte[] to database blobs. It also has to set the correct parameter types in the IDataParameter-object. This is the reverse operation of ColumnToValue.

See Also
SingleAsFloat Class
Eco.Persistence.SqlServer Namespace


SingleAsFloat.ValueType Method

SingleAsFloat.ValueType Method
SingleAsFloat Class Eco.Persistence.SqlServer Namespace See Also
Collapse All

This method returns the type of the value that is returned by ColumnToValue.

C#
public System.Type ValueType();
See Also
SingleAsFloat Class
Eco.Persistence.SqlServer Namespace


SingleAsReal Class

SingleAsReal Class
Inheritance Hierarchy See Also
Collapse All
C#
public sealed class SingleAsReal : AbstractNumericSingleColumnAttribute, ISingleColumnAttributemapping, IDefaultReverseMapping;
Remarks

This is class Eco.Persistence.SqlServer.SingleAsReal.

Inheritance Hierarchy
Eco.Persistence.IDefaultReverseMapping
Eco.Persistence.ISingleColumnAttributemapping
    Eco.Persistence.SqlServer.SingleAsReal
File

SqlServerAttributeMappers.cs

See Also
Inheritance Hierarchy


SingleAsReal Methods

SingleAsReal Methods
Public Methods
Collapse All

The methods of the SingleAsReal class are listed here.

Public Methods
Name | Description
ColumnToValue | Converts a value that comes from a database query to an ecospace value.
ColumnType | Specifies the SQL type of the column.
StringToParameter | This is StringToParameter, a member of class SingleAsReal.
ValueToParameter | Converts a value that comes from a database query to an ecospace value.
ValueType | This method returns the type of the value that is returned by ColumnToValue.


SingleAsReal.ColumnToValue Method

SingleAsReal.ColumnToValue Method
SingleAsReal Class Eco.Persistence.SqlServer Namespace See Also
Collapse All

Converts a value that comes from a database query to an ecospace value.

C#
public override System.Object ColumnToValue(
    System.Object columnValue
);
Remarks

In many cases, the implementation of this method mainly converts DBNull-values to null, but it can also change the CLR-type of the database value from for example a char[] to a string. or from an integer to a boolean. This is the reverse operation of ValueToParameter.

See Also
SingleAsReal Class
Eco.Persistence.SqlServer Namespace


SingleAsReal.ColumnType Method

SingleAsReal.ColumnType Method
SingleAsReal Class Eco.Persistence.SqlServer Namespace See Also
Collapse All

Specifies the SQL type of the column.

C#
public String ColumnType(
    int length
);
See Also
SingleAsReal Class
Eco.Persistence.SqlServer Namespace


SingleAsReal.StringToParameter Method

SingleAsReal.StringToParameter Method
SingleAsReal Class Eco.Persistence.SqlServer Namespace See Also
Collapse All
C#
public void StringToParameter(
    string value,
    IDataParameter parameter
);
Remarks

This is StringToParameter, a member of class SingleAsReal.

See Also
SingleAsReal Class
Eco.Persistence.SqlServer Namespace


SingleAsReal.ValueToParameter Method

SingleAsReal.ValueToParameter Method
SingleAsReal Class Eco.Persistence.SqlServer Namespace See Also
Collapse All

Converts a value that comes from a database query to an ecospace value.

C#
public void ValueToParameter(
    System.Object value,
    IDataParameter parameter
);
Remarks

In many cases, the implementation of this method mainly converts null to DBNull, but it can also handle conversion from for example booleans to integers, byte[] to database blobs. It also has to set the correct parameter types in the IDataParameter-object. This is the reverse operation of ColumnToValue.

See Also
SingleAsReal Class
Eco.Persistence.SqlServer Namespace


SingleAsReal.ValueType Method

SingleAsReal.ValueType Method
SingleAsReal Class Eco.Persistence.SqlServer Namespace See Also
Collapse All

This method returns the type of the value that is returned by ColumnToValue.

C#
public System.Type ValueType();
See Also
SingleAsReal Class
Eco.Persistence.SqlServer Namespace


SqlServerStringRes Class

SqlServerStringRes Class
Inheritance Hierarchy See Also
Collapse All

Autogenerated class to get compiler safe access to resource strings.

C#
public sealed class SqlServerStringRes : StringResources;
Inheritance Hierarchy
Eco.Persistence.SqlServer.SqlServerStringRes
File

Eco.Persistence.SqlServer.Strings.cs

See Also
Inheritance Hierarchy


StringAsXml Class

StringAsXml Class
Inheritance Hierarchy See Also
Collapse All

Class for mapping String values to a single column in a database.

C#
public sealed class StringAsXml : AbstractStringSingleColumnAttribute, ISingleColumnAttributemapping, IDefaultReverseMapping;
Inheritance Hierarchy
Eco.Persistence.IDefaultReverseMapping
Eco.Persistence.ISingleColumnAttributemapping
    Eco.Persistence.SqlServer.StringAsXml
File

SqlServerAttributeMappers.cs

See Also
Inheritance Hierarchy


StringAsXml Methods

StringAsXml Methods
Public Methods
Collapse All

The methods of the StringAsXml class are listed here.

Public Methods
Name | Description
ColumnToValue | Converts a value that comes from a database query to an ecospace value.
ColumnType | Returns the SQL type used by the database during CREATE TABLE execution.
StringToParameter | Converts a string to the correct data type and then inserts the given value into the IDataParameter.
ValueToParameter | Inserts the given value into the IDataParameter.
ValueType | Returns the .NET type of the column.


StringAsXml.ColumnToValue Method

StringAsXml.ColumnToValue Method
StringAsXml Class Eco.Persistence.SqlServer Namespace See Also
Collapse All

Converts a value that comes from a database query to an ecospace value.

C#
public override System.Object ColumnToValue(
    System.Object columnValue
);
Remarks

In many cases, the implementation of this method mainly converts DBNull-values to null, but it can also change the CLR-type of the database value from for example a char[] to a string. or from an integer to a boolean. This is the reverse operation of ValueToParameter.

See Also
StringAsXml Class
Eco.Persistence.SqlServer Namespace


StringAsXml.ColumnType Method

StringAsXml.ColumnType Method
StringAsXml Class Eco.Persistence.SqlServer Namespace See Also
Collapse All

Returns the SQL type used by the database during CREATE TABLE execution.

C#
public string ColumnType(
    int length
);
Parameters
Parameters | Description
length | The column length in the table.
See Also
StringAsXml Class
Eco.Persistence.SqlServer Namespace


StringAsXml.StringToParameter Method

StringAsXml.StringToParameter Method
StringAsXml Class Eco.Persistence.SqlServer Namespace See Also
Collapse All

Converts a string to the correct data type and then inserts the given value into the IDataParameter.

C#
public void StringToParameter(
    string value,
    IDataParameter parameter
);
Parameters
Parameters | Description
value | The value to use.
parameter | The IDataParameter to update.
See Also
StringAsXml Class
Eco.Persistence.SqlServer Namespace


StringAsXml.ValueToParameter Method

StringAsXml.ValueToParameter Method
StringAsXml Class Eco.Persistence.SqlServer Namespace See Also
Collapse All

Inserts the given value into the IDataParameter.

C#
public void ValueToParameter(
    System.Object value,
    IDataParameter parameter
);
Parameters
Parameters | Description
value | The value to use.
parameter | The IDataParameter to update.
See Also
StringAsXml Class
Eco.Persistence.SqlServer Namespace


StringAsXml.ValueType Method

StringAsXml.ValueType Method
StringAsXml Class Eco.Persistence.SqlServer Namespace See Also
Collapse All

Returns the .NET type of the column.

C#
public System.Type ValueType();
See Also
StringAsXml Class
Eco.Persistence.SqlServer Namespace


TimeSpanAsDateTime Class

TimeSpanAsDateTime Class
Inheritance Hierarchy See Also
Collapse All
C#
public sealed class TimeSpanAsDateTime : AbstractSingleColumnAttribute, ISingleColumnAttributemapping;
Remarks

This is class Eco.Persistence.SqlServer.TimeSpanAsDateTime.

Inheritance Hierarchy
Eco.Persistence.ISingleColumnAttributemapping
    Eco.Persistence.SqlServer.TimeSpanAsDateTime
File

SqlServerAttributeMappers.cs

See Also
Inheritance Hierarchy


TimeSpanAsDateTime Methods

TimeSpanAsDateTime Methods
Public Methods
Collapse All

The methods of the TimeSpanAsDateTime class are listed here.

Public Methods
Name | Description
ColumnToValue | Converts a value that comes from a database query to an ecospace value.
ColumnType | Specifies the SQL type of the column.
DefaultDbValue | The return value of this function will be used as default value for new columns when databases are created/evolved.
IsEqual | Returns true if an ecospace value ("value") is equal to a database value ("columnValue").
StringToParameter | This is StringToParameter, a member of class TimeSpanAsDateTime.
ValueToParameter | Converts a value that comes from a database query to an ecospace value.
ValueType | This method returns the type of the value that is returned by ColumnToValue.


TimeSpanAsDateTime.ColumnToValue Method

TimeSpanAsDateTime.ColumnToValue Method
TimeSpanAsDateTime Class Eco.Persistence.SqlServer Namespace See Also
Collapse All

Converts a value that comes from a database query to an ecospace value.

C#
public override System.Object ColumnToValue(
    System.Object columnValue
);
Remarks

In many cases, the implementation of this method mainly converts DBNull-values to null, but it can also change the CLR-type of the database value from for example a char[] to a string. or from an integer to a boolean. This is the reverse operation of ValueToParameter.

See Also
TimeSpanAsDateTime Class
Eco.Persistence.SqlServer Namespace


TimeSpanAsDateTime.ColumnType Method

TimeSpanAsDateTime.ColumnType Method
TimeSpanAsDateTime Class Eco.Persistence.SqlServer Namespace See Also
Collapse All

Specifies the SQL type of the column.

C#
public String ColumnType(
    int length
);
See Also
TimeSpanAsDateTime Class
Eco.Persistence.SqlServer Namespace


TimeSpanAsDateTime.DefaultDbValue Method

TimeSpanAsDateTime.DefaultDbValue Method
TimeSpanAsDateTime Class Eco.Persistence.SqlServer Namespace See Also
Collapse All

The return value of this function will be used as default value for new columns when databases are created/evolved.

C#
public String DefaultDbValue(
    string modeledValue,
    SqlDatabaseConfig sqlDatabaseConfig
);
See Also
TimeSpanAsDateTime Class
Eco.Persistence.SqlServer Namespace


TimeSpanAsDateTime.IsEqual Method

TimeSpanAsDateTime.IsEqual Method
TimeSpanAsDateTime Class Eco.Persistence.SqlServer Namespace See Also
Collapse All

Returns true if an ecospace value ("value") is equal to a database value ("columnValue").

C#
public override bool IsEqual(
    System.Object value,
    System.Object columnValue
);
Remarks

This method must handle the conversions between ecospace and database values, it must also handle comparing null/DBNull values.

See Also
TimeSpanAsDateTime Class
Eco.Persistence.SqlServer Namespace


TimeSpanAsDateTime.StringToParameter Method

TimeSpanAsDateTime.StringToParameter Method
TimeSpanAsDateTime Class Eco.Persistence.SqlServer Namespace See Also
Collapse All
C#
public void StringToParameter(
    string value,
    IDataParameter parameter
);
Remarks

This is StringToParameter, a member of class TimeSpanAsDateTime.

See Also
TimeSpanAsDateTime Class
Eco.Persistence.SqlServer Namespace


TimeSpanAsDateTime.ValueToParameter Method

TimeSpanAsDateTime.ValueToParameter Method
TimeSpanAsDateTime Class Eco.Persistence.SqlServer Namespace See Also
Collapse All

Converts a value that comes from a database query to an ecospace value.

C#
public void ValueToParameter(
    System.Object value,
    IDataParameter parameter
);
Remarks

In many cases, the implementation of this method mainly converts null to DBNull, but it can also handle conversion from for example booleans to integers, byte[] to database blobs. It also has to set the correct parameter types in the IDataParameter-object. This is the reverse operation of ColumnToValue.

See Also
TimeSpanAsDateTime Class
Eco.Persistence.SqlServer Namespace


TimeSpanAsDateTime.ValueType Method

TimeSpanAsDateTime.ValueType Method
TimeSpanAsDateTime Class Eco.Persistence.SqlServer Namespace See Also
Collapse All

This method returns the type of the value that is returned by ColumnToValue.

C#
public System.Type ValueType();
See Also
TimeSpanAsDateTime Class
Eco.Persistence.SqlServer Namespace


Eco.Persistence.SqlServer.Bdp Namespace

Eco.Persistence.SqlServer.Bdp Namespace
Classes
Collapse All

This is namespace Eco.Persistence.SqlServer.Bdp.

Classes
Name | Description
ByteArrayAsImage | Mapper between a ByteArray value and its persistent representation as IMAGE.
ByteAsTinyInt | This is class Eco.Persistence.SqlServer.Bdp.ByteAsTinyInt.
StringAsNText | This is class Eco.Persistence.SqlServer.Bdp.StringAsNText.
StringAsText | This is class Eco.Persistence.SqlServer.Bdp.StringAsText.


ByteArrayAsImage Class

ByteArrayAsImage Class
Inheritance Hierarchy See Also
Collapse All

Mapper between a ByteArray value and its persistent representation as IMAGE.

C#
public sealed class ByteArrayAsImage : AbstractSingleColumnAttribute, ISingleColumnAttributemapping;
Inheritance Hierarchy
Eco.Persistence.ISingleColumnAttributemapping
    Eco.Persistence.SqlServer.Bdp.ByteArrayAsImage
File

SqlServerAttributeMappersBdp.cs

See Also
Inheritance Hierarchy


ByteArrayAsImage.ColumnToValue Method

ByteArrayAsImage.ColumnToValue Method
ByteArrayAsImage Class Eco.Persistence.SqlServer.Bdp Namespace See Also
Collapse All

Converts a value that comes from a database query to an ecospace value.

C#
public override System.Object ColumnToValue(
    System.Object columnValue
);
Remarks

In many cases, the implementation of this method mainly converts DBNull-values to null, but it can also change the CLR-type of the database value from for example a char[] to a string. or from an integer to a boolean. This is the reverse operation of ValueToParameter.

See Also
ByteArrayAsImage Class
Eco.Persistence.SqlServer.Bdp Namespace


ByteArrayAsImage.ColumnType Method

ByteArrayAsImage.ColumnType Method
ByteArrayAsImage Class Eco.Persistence.SqlServer.Bdp Namespace See Also
Collapse All

Specifies the SQL type of the column.

C#
public String ColumnType(
    int length
);
See Also
ByteArrayAsImage Class
Eco.Persistence.SqlServer.Bdp Namespace


ByteArrayAsImage.DefaultDbValue Method

ByteArrayAsImage.DefaultDbValue Method
ByteArrayAsImage Class Eco.Persistence.SqlServer.Bdp Namespace See Also
Collapse All

The return value of this function will be used as default value for new columns when databases are created/evolved.

C#
public String DefaultDbValue(
    string modeledValue,
    SqlDatabaseConfig sqlDatabaseConfig
);
See Also
ByteArrayAsImage Class
Eco.Persistence.SqlServer.Bdp Namespace


ByteArrayAsImage.IsEqual Method

ByteArrayAsImage.IsEqual Method
ByteArrayAsImage Class Eco.Persistence.SqlServer.Bdp Namespace See Also
Collapse All

Returns true if an ecospace value ("value") is equal to a database value ("columnValue").

C#
public override bool IsEqual(
    System.Object value,
    System.Object columnValue
);
Remarks

This method must handle the conversions between ecospace and database values, it must also handle comparing null/DBNull values.

See Also
ByteArrayAsImage Class
Eco.Persistence.SqlServer.Bdp Namespace


ByteArrayAsImage.StringToParameter Method

ByteArrayAsImage.StringToParameter Method
ByteArrayAsImage Class Eco.Persistence.SqlServer.Bdp Namespace See Also
Collapse All
C#
public void StringToParameter(
    string value,
    IDataParameter parameter
);
Exceptions
Exceptions | Description
InvalidOperationException | Thrown always.
See Also
ByteArrayAsImage Class
Eco.Persistence.SqlServer.Bdp Namespace


ByteArrayAsImage.ValueToParameter Method

ByteArrayAsImage.ValueToParameter Method
ByteArrayAsImage Class Eco.Persistence.SqlServer.Bdp Namespace See Also
Collapse All

Converts a value that comes from a database query to an ecospace value.

C#
public void ValueToParameter(
    System.Object value,
    IDataParameter parameter
);
Remarks

In many cases, the implementation of this method mainly converts null to DBNull, but it can also handle conversion from for example booleans to integers, byte[] to database blobs. It also has to set the correct parameter types in the IDataParameter-object. This is the reverse operation of ColumnToValue.

See Also
ByteArrayAsImage Class
Eco.Persistence.SqlServer.Bdp Namespace


ByteArrayAsImage.ValueType Method

ByteArrayAsImage.ValueType Method
ByteArrayAsImage Class Eco.Persistence.SqlServer.Bdp Namespace See Also
Collapse All

This method returns the type of the value that is returned by ColumnToValue.

C#
public System.Type ValueType();
See Also
ByteArrayAsImage Class
Eco.Persistence.SqlServer.Bdp Namespace


ByteAsTinyInt Class

ByteAsTinyInt Class
Inheritance Hierarchy See Also
Collapse All
C#
public sealed class ByteAsTinyInt : AbstractNumericSingleColumnAttribute, ISingleColumnAttributemapping;
Remarks

This is class Eco.Persistence.SqlServer.Bdp.ByteAsTinyInt.

Inheritance Hierarchy
Eco.Persistence.ISingleColumnAttributemapping
    Eco.Persistence.SqlServer.Bdp.ByteAsTinyInt
File

SqlServerAttributeMappersBdp.cs

See Also
Inheritance Hierarchy


ByteAsTinyInt.ColumnToValue Method

ByteAsTinyInt.ColumnToValue Method
ByteAsTinyInt Class Eco.Persistence.SqlServer.Bdp Namespace See Also
Collapse All

Converts a value that comes from a database query to an ecospace value.

C#
public override System.Object ColumnToValue(
    System.Object columnValue
);
Remarks

In many cases, the implementation of this method mainly converts DBNull-values to null, but it can also change the CLR-type of the database value from for example a char[] to a string. or from an integer to a boolean. This is the reverse operation of ValueToParameter.

See Also
ByteAsTinyInt Class
Eco.Persistence.SqlServer.Bdp Namespace


ByteAsTinyInt.ColumnType Method

ByteAsTinyInt.ColumnType Method
ByteAsTinyInt Class Eco.Persistence.SqlServer.Bdp Namespace See Also
Collapse All

Specifies the SQL type of the column.

C#
public String ColumnType(
    int length
);
See Also
ByteAsTinyInt Class
Eco.Persistence.SqlServer.Bdp Namespace


ByteAsTinyInt.StringToParameter Method

ByteAsTinyInt.StringToParameter Method
ByteAsTinyInt Class Eco.Persistence.SqlServer.Bdp Namespace See Also
Collapse All
C#
public void StringToParameter(
    string value,
    IDataParameter parameter
);
Remarks

This is StringToParameter, a member of class ByteAsTinyInt.

See Also
ByteAsTinyInt Class
Eco.Persistence.SqlServer.Bdp Namespace


ByteAsTinyInt.ValueToParameter Method

ByteAsTinyInt.ValueToParameter Method
ByteAsTinyInt Class Eco.Persistence.SqlServer.Bdp Namespace See Also
Collapse All

Converts a value that comes from a database query to an ecospace value.

C#
public void ValueToParameter(
    System.Object value,
    IDataParameter parameter
);
Remarks

In many cases, the implementation of this method mainly converts null to DBNull, but it can also handle conversion from for example booleans to integers, byte[] to database blobs. It also has to set the correct parameter types in the IDataParameter-object. This is the reverse operation of ColumnToValue.

See Also
ByteAsTinyInt Class
Eco.Persistence.SqlServer.Bdp Namespace


ByteAsTinyInt.ValueType Method

ByteAsTinyInt.ValueType Method
ByteAsTinyInt Class Eco.Persistence.SqlServer.Bdp Namespace See Also
Collapse All

This method returns the type of the value that is returned by ColumnToValue.

C#
public System.Type ValueType();
See Also
ByteAsTinyInt Class
Eco.Persistence.SqlServer.Bdp Namespace


StringAsNText Class

StringAsNText Class
Inheritance Hierarchy See Also
Collapse All
C#
public sealed class StringAsNText : AbstractSingleColumnAttribute, ISingleColumnAttributemapping;
Remarks

This is class Eco.Persistence.SqlServer.Bdp.StringAsNText.

Inheritance Hierarchy
Eco.Persistence.ISingleColumnAttributemapping
    Eco.Persistence.SqlServer.Bdp.StringAsNText
File

SqlServerAttributeMappersBdp.cs

See Also
Inheritance Hierarchy


StringAsNText.ColumnToValue Method

StringAsNText.ColumnToValue Method
StringAsNText Class Eco.Persistence.SqlServer.Bdp Namespace See Also
Collapse All

Converts a value that comes from a database query to an ecospace value.

C#
public override System.Object ColumnToValue(
    System.Object columnValue
);
Remarks

In many cases, the implementation of this method mainly converts DBNull-values to null, but it can also change the CLR-type of the database value from for example a char[] to a string. or from an integer to a boolean. This is the reverse operation of ValueToParameter.

See Also
StringAsNText Class
Eco.Persistence.SqlServer.Bdp Namespace


StringAsNText.ColumnType Method

StringAsNText.ColumnType Method
StringAsNText Class Eco.Persistence.SqlServer.Bdp Namespace See Also
Collapse All

Specifies the SQL type of the column.

C#
public String ColumnType(
    int length
);
See Also
StringAsNText Class
Eco.Persistence.SqlServer.Bdp Namespace


StringAsNText.DefaultDbValue Method

StringAsNText.DefaultDbValue Method
StringAsNText Class Eco.Persistence.SqlServer.Bdp Namespace See Also
Collapse All

The return value of this function will be used as default value for new columns when databases are created/evolved.

C#
public String DefaultDbValue(
    string modeledValue,
    SqlDatabaseConfig sqlDatabaseConfig
);
See Also
StringAsNText Class
Eco.Persistence.SqlServer.Bdp Namespace


StringAsNText.StringToParameter Method

StringAsNText.StringToParameter Method
StringAsNText Class Eco.Persistence.SqlServer.Bdp Namespace See Also
Collapse All
C#
public void StringToParameter(
    string value,
    IDataParameter parameter
);
Remarks

This is StringToParameter, a member of class StringAsNText.

See Also
StringAsNText Class
Eco.Persistence.SqlServer.Bdp Namespace


StringAsNText.ValueToParameter Method

StringAsNText.ValueToParameter Method
StringAsNText Class Eco.Persistence.SqlServer.Bdp Namespace See Also
Collapse All

Converts a value that comes from a database query to an ecospace value.

C#
public void ValueToParameter(
    System.Object value,
    IDataParameter parameter
);
Remarks

In many cases, the implementation of this method mainly converts null to DBNull, but it can also handle conversion from for example booleans to integers, byte[] to database blobs. It also has to set the correct parameter types in the IDataParameter-object. This is the reverse operation of ColumnToValue.

See Also
StringAsNText Class
Eco.Persistence.SqlServer.Bdp Namespace


StringAsNText.ValueType Method

StringAsNText.ValueType Method
StringAsNText Class Eco.Persistence.SqlServer.Bdp Namespace See Also
Collapse All

This method returns the type of the value that is returned by ColumnToValue.

C#
public System.Type ValueType();
See Also
StringAsNText Class
Eco.Persistence.SqlServer.Bdp Namespace


StringAsText Class

StringAsText Class
Inheritance Hierarchy See Also
Collapse All
C#
public sealed class StringAsText : AbstractSingleColumnAttribute, ISingleColumnAttributemapping;
Remarks

This is class Eco.Persistence.SqlServer.Bdp.StringAsText.

Inheritance Hierarchy
Eco.Persistence.ISingleColumnAttributemapping
    Eco.Persistence.SqlServer.Bdp.StringAsText
File

SqlServerAttributeMappersBdp.cs

See Also
Inheritance Hierarchy


StringAsText.ColumnToValue Method

StringAsText.ColumnToValue Method
StringAsText Class Eco.Persistence.SqlServer.Bdp Namespace See Also
Collapse All

Converts a value that comes from a database query to an ecospace value.

C#
public override System.Object ColumnToValue(
    System.Object columnValue
);
Remarks

In many cases, the implementation of this method mainly converts DBNull-values to null, but it can also change the CLR-type of the database value from for example a char[] to a string. or from an integer to a boolean. This is the reverse operation of ValueToParameter.

See Also
StringAsText Class
Eco.Persistence.SqlServer.Bdp Namespace


StringAsText.ColumnType Method

StringAsText.ColumnType Method
StringAsText Class Eco.Persistence.SqlServer.Bdp Namespace See Also
Collapse All

Specifies the SQL type of the column.

C#
public String ColumnType(
    int length
);
See Also
StringAsText Class
Eco.Persistence.SqlServer.Bdp Namespace


StringAsText.DefaultDbValue Method

StringAsText.DefaultDbValue Method
StringAsText Class Eco.Persistence.SqlServer.Bdp Namespace See Also
Collapse All

The return value of this function will be used as default value for new columns when databases are created/evolved.

C#
public String DefaultDbValue(
    string modeledValue,
    SqlDatabaseConfig sqlDatabaseConfig
);
See Also
StringAsText Class
Eco.Persistence.SqlServer.Bdp Namespace


StringAsText.StringToParameter Method

StringAsText.StringToParameter Method
StringAsText Class Eco.Persistence.SqlServer.Bdp Namespace See Also
Collapse All
C#
public void StringToParameter(
    string value,
    IDataParameter parameter
);
Remarks

This is StringToParameter, a member of class StringAsText.

See Also
StringAsText Class
Eco.Persistence.SqlServer.Bdp Namespace


StringAsText.ValueToParameter Method

StringAsText.ValueToParameter Method
StringAsText Class Eco.Persistence.SqlServer.Bdp Namespace See Also
Collapse All

Converts a value that comes from a database query to an ecospace value.

C#
public void ValueToParameter(
    System.Object value,
    IDataParameter parameter
);
Remarks

In many cases, the implementation of this method mainly converts null to DBNull, but it can also handle conversion from for example booleans to integers, byte[] to database blobs. It also has to set the correct parameter types in the IDataParameter-object. This is the reverse operation of ColumnToValue.

See Also
StringAsText Class
Eco.Persistence.SqlServer.Bdp Namespace


StringAsText.ValueType Method

StringAsText.ValueType Method
StringAsText Class Eco.Persistence.SqlServer.Bdp Namespace See Also
Collapse All

This method returns the type of the value that is returned by ColumnToValue.

C#
public System.Type ValueType();
See Also
StringAsText Class
Eco.Persistence.SqlServer.Bdp Namespace


Eco.Persistence.SqlServer.SqlClient Namespace

Eco.Persistence.SqlServer.SqlClient Namespace
Classes
Collapse All

This is namespace Eco.Persistence.SqlServer.SqlClient.

Classes
Name | Description
ByteArrayAsImage | Mapper between a ByteArray value and its persistent representation as IMAGE.
StringAsNText | This is class Eco.Persistence.SqlServer.SqlClient.StringAsNText.
StringAsText | This is class Eco.Persistence.SqlServer.SqlClient.StringAsText.


ByteArrayAsImage Class

ByteArrayAsImage Class
Inheritance Hierarchy See Also
Collapse All

Mapper between a ByteArray value and its persistent representation as IMAGE.

C#
public sealed class ByteArrayAsImage : AbstractSingleColumnAttribute, ISingleColumnAttributemapping, IDefaultReverseMapping;
Inheritance Hierarchy
Eco.Persistence.IDefaultReverseMapping
Eco.Persistence.ISingleColumnAttributemapping
    Eco.Persistence.SqlServer.SqlClient.ByteArrayAsImage
File

SqlServerAttributeMappersSqlClient.cs

See Also
Inheritance Hierarchy


ByteArrayAsImage.ColumnToValue Method

ByteArrayAsImage.ColumnToValue Method
ByteArrayAsImage Class Eco.Persistence.SqlServer.SqlClient Namespace See Also
Collapse All

Converts a value that comes from a database query to an ecospace value.

C#
public override System.Object ColumnToValue(
    System.Object columnValue
);
Remarks

In many cases, the implementation of this method mainly converts DBNull-values to null, but it can also change the CLR-type of the database value from for example a char[] to a string. or from an integer to a boolean. This is the reverse operation of ValueToParameter.

See Also
ByteArrayAsImage Class
Eco.Persistence.SqlServer.SqlClient Namespace


ByteArrayAsImage.ColumnType Method

ByteArrayAsImage.ColumnType Method
ByteArrayAsImage Class Eco.Persistence.SqlServer.SqlClient Namespace See Also
Collapse All

Specifies the SQL type of the column.

C#
public String ColumnType(
    int length
);
See Also
ByteArrayAsImage Class
Eco.Persistence.SqlServer.SqlClient Namespace


ByteArrayAsImage.DefaultDbValue Method

ByteArrayAsImage.DefaultDbValue Method
ByteArrayAsImage Class Eco.Persistence.SqlServer.SqlClient Namespace See Also
Collapse All

The return value of this function will be used as default value for new columns when databases are created/evolved.

C#
public String DefaultDbValue(
    string modeledValue,
    SqlDatabaseConfig sqlDatabaseConfig
);
See Also
ByteArrayAsImage Class
Eco.Persistence.SqlServer.SqlClient Namespace


ByteArrayAsImage.IsEqual Method

ByteArrayAsImage.IsEqual Method
ByteArrayAsImage Class Eco.Persistence.SqlServer.SqlClient Namespace See Also
Collapse All

Returns true if an ecospace value ("value") is equal to a database value ("columnValue").

C#
public override bool IsEqual(
    System.Object value,
    System.Object columnValue
);
Remarks

This method must handle the conversions between ecospace and database values, it must also handle comparing null/DBNull values.

See Also
ByteArrayAsImage Class
Eco.Persistence.SqlServer.SqlClient Namespace


ByteArrayAsImage.StringToParameter Method

ByteArrayAsImage.StringToParameter Method
ByteArrayAsImage Class Eco.Persistence.SqlServer.SqlClient Namespace See Also
Collapse All
C#
public void StringToParameter(
    string value,
    IDataParameter parameter
);
Exceptions
Exceptions | Description
InvalidOperationException | Thrown always.
See Also
ByteArrayAsImage Class
Eco.Persistence.SqlServer.SqlClient Namespace


ByteArrayAsImage.ValueToParameter Method

ByteArrayAsImage.ValueToParameter Method
ByteArrayAsImage Class Eco.Persistence.SqlServer.SqlClient Namespace See Also
Collapse All

Converts a value that comes from a database query to an ecospace value.

C#
public void ValueToParameter(
    System.Object value,
    IDataParameter parameter
);
Remarks

In many cases, the implementation of this method mainly converts null to DBNull, but it can also handle conversion from for example booleans to integers, byte[] to database blobs. It also has to set the correct parameter types in the IDataParameter-object. This is the reverse operation of ColumnToValue.

See Also
ByteArrayAsImage Class
Eco.Persistence.SqlServer.SqlClient Namespace


ByteArrayAsImage.ValueType Method

ByteArrayAsImage.ValueType Method
ByteArrayAsImage Class Eco.Persistence.SqlServer.SqlClient Namespace See Also
Collapse All

This method returns the type of the value that is returned by ColumnToValue.

C#
public System.Type ValueType();
See Also
ByteArrayAsImage Class
Eco.Persistence.SqlServer.SqlClient Namespace


StringAsNText Class

StringAsNText Class
Inheritance Hierarchy See Also
Collapse All
C#
public sealed class StringAsNText : AbstractSingleColumnAttribute, ISingleColumnAttributemapping, IDefaultReverseMapping;
Remarks

This is class Eco.Persistence.SqlServer.SqlClient.StringAsNText.

Inheritance Hierarchy
Eco.Persistence.IDefaultReverseMapping
Eco.Persistence.ISingleColumnAttributemapping
    Eco.Persistence.SqlServer.SqlClient.StringAsNText
File

SqlServerAttributeMappersSqlClient.cs

See Also
Inheritance Hierarchy


StringAsNText.ColumnToValue Method

StringAsNText.ColumnToValue Method
StringAsNText Class Eco.Persistence.SqlServer.SqlClient Namespace See Also
Collapse All

Converts a value that comes from a database query to an ecospace value.

C#
public override System.Object ColumnToValue(
    System.Object columnValue
);
Remarks

In many cases, the implementation of this method mainly converts DBNull-values to null, but it can also change the CLR-type of the database value from for example a char[] to a string. or from an integer to a boolean. This is the reverse operation of ValueToParameter.

See Also
StringAsNText Class
Eco.Persistence.SqlServer.SqlClient Namespace


StringAsNText.ColumnType Method

StringAsNText.ColumnType Method
StringAsNText Class Eco.Persistence.SqlServer.SqlClient Namespace See Also
Collapse All

Specifies the SQL type of the column.

C#
public String ColumnType(
    int length
);
See Also
StringAsNText Class
Eco.Persistence.SqlServer.SqlClient Namespace


StringAsNText.DefaultDbValue Method

StringAsNText.DefaultDbValue Method
StringAsNText Class Eco.Persistence.SqlServer.SqlClient Namespace See Also
Collapse All

The return value of this function will be used as default value for new columns when databases are created/evolved.

C#
public String DefaultDbValue(
    string modeledValue,
    SqlDatabaseConfig sqlDatabaseConfig
);
See Also
StringAsNText Class
Eco.Persistence.SqlServer.SqlClient Namespace


StringAsNText.StringToParameter Method

StringAsNText.StringToParameter Method
StringAsNText Class Eco.Persistence.SqlServer.SqlClient Namespace See Also
Collapse All
C#
public void StringToParameter(
    string value,
    IDataParameter parameter
);
Remarks

This is StringToParameter, a member of class StringAsNText.

See Also
StringAsNText Class
Eco.Persistence.SqlServer.SqlClient Namespace


StringAsNText.ValueToParameter Method

StringAsNText.ValueToParameter Method
StringAsNText Class Eco.Persistence.SqlServer.SqlClient Namespace See Also
Collapse All

Converts a value that comes from a database query to an ecospace value.

C#
public void ValueToParameter(
    System.Object value,
    IDataParameter parameter
);
Remarks

In many cases, the implementation of this method mainly converts null to DBNull, but it can also handle conversion from for example booleans to integers, byte[] to database blobs. It also has to set the correct parameter types in the IDataParameter-object. This is the reverse operation of ColumnToValue.

See Also
StringAsNText Class
Eco.Persistence.SqlServer.SqlClient Namespace


StringAsNText.ValueType Method

StringAsNText.ValueType Method
StringAsNText Class Eco.Persistence.SqlServer.SqlClient Namespace See Also
Collapse All

This method returns the type of the value that is returned by ColumnToValue.

C#
public System.Type ValueType();
See Also
StringAsNText Class
Eco.Persistence.SqlServer.SqlClient Namespace


StringAsText Class

StringAsText Class
Inheritance Hierarchy See Also
Collapse All
C#
public sealed class StringAsText : AbstractSingleColumnAttribute, ISingleColumnAttributemapping, IDefaultReverseMapping;
Remarks

This is class Eco.Persistence.SqlServer.SqlClient.StringAsText.

Inheritance Hierarchy
Eco.Persistence.IDefaultReverseMapping
Eco.Persistence.ISingleColumnAttributemapping
    Eco.Persistence.SqlServer.SqlClient.StringAsText
File

SqlServerAttributeMappersSqlClient.cs

See Also
Inheritance Hierarchy


StringAsText.ColumnToValue Method

StringAsText.ColumnToValue Method
StringAsText Class Eco.Persistence.SqlServer.SqlClient Namespace See Also
Collapse All

Converts a value that comes from a database query to an ecospace value.

C#
public override System.Object ColumnToValue(
    System.Object columnValue
);
Remarks

In many cases, the implementation of this method mainly converts DBNull-values to null, but it can also change the CLR-type of the database value from for example a char[] to a string. or from an integer to a boolean. This is the reverse operation of ValueToParameter.

See Also
StringAsText Class
Eco.Persistence.SqlServer.SqlClient Namespace


StringAsText.ColumnType Method

StringAsText.ColumnType Method
StringAsText Class Eco.Persistence.SqlServer.SqlClient Namespace See Also
Collapse All

Specifies the SQL type of the column.

C#
public String ColumnType(
    int length
);
See Also
StringAsText Class
Eco.Persistence.SqlServer.SqlClient Namespace


StringAsText.DefaultDbValue Method

StringAsText.DefaultDbValue Method
StringAsText Class Eco.Persistence.SqlServer.SqlClient Namespace See Also
Collapse All

The return value of this function will be used as default value for new columns when databases are created/evolved.

C#
public String DefaultDbValue(
    string modeledValue,
    SqlDatabaseConfig sqlDatabaseConfig
);
See Also
StringAsText Class
Eco.Persistence.SqlServer.SqlClient Namespace


StringAsText.StringToParameter Method

StringAsText.StringToParameter Method
StringAsText Class Eco.Persistence.SqlServer.SqlClient Namespace See Also
Collapse All
C#
public void StringToParameter(
    string value,
    IDataParameter parameter
);
Remarks

This is StringToParameter, a member of class StringAsText.

See Also
StringAsText Class
Eco.Persistence.SqlServer.SqlClient Namespace


StringAsText.ValueToParameter Method

StringAsText.ValueToParameter Method
StringAsText Class Eco.Persistence.SqlServer.SqlClient Namespace See Also
Collapse All

Converts a value that comes from a database query to an ecospace value.

C#
public void ValueToParameter(
    System.Object value,
    IDataParameter parameter
);
Remarks

In many cases, the implementation of this method mainly converts null to DBNull, but it can also handle conversion from for example booleans to integers, byte[] to database blobs. It also has to set the correct parameter types in the IDataParameter-object. This is the reverse operation of ColumnToValue.

See Also
StringAsText Class
Eco.Persistence.SqlServer.SqlClient Namespace


StringAsText.ValueType Method

StringAsText.ValueType Method
StringAsText Class Eco.Persistence.SqlServer.SqlClient Namespace See Also
Collapse All

This method returns the type of the value that is returned by ColumnToValue.

C#
public System.Type ValueType();
See Also
StringAsText Class
Eco.Persistence.SqlServer.SqlClient Namespace


Eco.Persistence.Sybase Namespace

Eco.Persistence.Sybase Namespace
Classes
Collapse All

This is namespace Eco.Persistence.Sybase.

Classes
Name | Description
BooleanAsBit | This is class Eco.Persistence.Sybase.BooleanAsBit.
Int32AsNumericIdentity | Mapper between an AutoInc value of type Int32 and its persistent representation as NUMERIC(9,0).
SingleAsFloat | This is class Eco.Persistence.Sybase.SingleAsFloat.


BooleanAsBit Class

BooleanAsBit Class
Inheritance Hierarchy See Also
Collapse All
C#
public sealed class BooleanAsBit : AbstractSingleColumnAttribute, ISingleColumnAttributemapping, IDefaultReverseMapping;
Remarks

This is class Eco.Persistence.Sybase.BooleanAsBit.

Inheritance Hierarchy
Eco.Persistence.IDefaultReverseMapping
Eco.Persistence.ISingleColumnAttributemapping
    Eco.Persistence.Sybase.BooleanAsBit
File

SybaseAttributeMappersCommon.cs

See Also
Inheritance Hierarchy


BooleanAsBit.ColumnToValue Method

BooleanAsBit.ColumnToValue Method
BooleanAsBit Class Eco.Persistence.Sybase Namespace See Also
Collapse All

Converts a value that comes from a database query to an ecospace value.

C#
public override System.Object ColumnToValue(
    System.Object columnValue
);
Remarks

In many cases, the implementation of this method mainly converts DBNull-values to null, but it can also change the CLR-type of the database value from for example a char[] to a string. or from an integer to a boolean. This is the reverse operation of ValueToParameter.

See Also
BooleanAsBit Class
Eco.Persistence.Sybase Namespace


BooleanAsBit.ColumnType Method

BooleanAsBit.ColumnType Method
BooleanAsBit Class Eco.Persistence.Sybase Namespace See Also
Collapse All

Specifies the SQL type of the column.

C#
public String ColumnType(
    int length
);
See Also
BooleanAsBit Class
Eco.Persistence.Sybase Namespace


BooleanAsBit.DefaultDbValue Method

BooleanAsBit.DefaultDbValue Method
BooleanAsBit Class Eco.Persistence.Sybase Namespace See Also
Collapse All

The return value of this function will be used as default value for new columns when databases are created/evolved.

C#
public String DefaultDbValue(
    string modeledValue,
    SqlDatabaseConfig sqlDatabaseConfig
);
See Also
BooleanAsBit Class
Eco.Persistence.Sybase Namespace


BooleanAsBit.StringToParameter Method

BooleanAsBit.StringToParameter Method
BooleanAsBit Class Eco.Persistence.Sybase Namespace See Also
Collapse All
C#
public void StringToParameter(
    string value,
    IDataParameter parameter
);
Remarks

This is StringToParameter, a member of class BooleanAsBit.

See Also
BooleanAsBit Class
Eco.Persistence.Sybase Namespace


BooleanAsBit.ValueToParameter Method

BooleanAsBit.ValueToParameter Method
BooleanAsBit Class Eco.Persistence.Sybase Namespace See Also
Collapse All

Converts a value that comes from a database query to an ecospace value.

C#
public void ValueToParameter(
    System.Object value,
    IDataParameter parameter
);
Remarks

In many cases, the implementation of this method mainly converts null to DBNull, but it can also handle conversion from for example booleans to integers, byte[] to database blobs. It also has to set the correct parameter types in the IDataParameter-object. This is the reverse operation of ColumnToValue.

See Also
BooleanAsBit Class
Eco.Persistence.Sybase Namespace


BooleanAsBit.ValueType Method

BooleanAsBit.ValueType Method
BooleanAsBit Class Eco.Persistence.Sybase Namespace See Also
Collapse All

This method returns the type of the value that is returned by ColumnToValue.

C#
public System.Type ValueType();
See Also
BooleanAsBit Class
Eco.Persistence.Sybase Namespace


Int32AsNumericIdentity Class

Int32AsNumericIdentity Class
Inheritance Hierarchy See Also
Collapse All

Mapper between an AutoInc value of type Int32 and its persistent representation as NUMERIC(9,0).

C#
public sealed class Int32AsNumericIdentity : AbstractNumericSingleColumnAttribute, IAutoIncAttributemapping, IDefaultReverseMapping;
Inheritance Hierarchy
Eco.Persistence.ISingleColumnAttributemapping
    Eco.Persistence.IAutoIncAttributemapping
    Eco.Persistence.IDefaultReverseMapping
        Eco.Persistence.Sybase.Int32AsNumericIdentity
File

SybaseAttributeMappersCommon.cs

See Also
Inheritance Hierarchy


Int32AsNumericIdentity Methods

Int32AsNumericIdentity Methods
Public Methods
Collapse All

The methods of the Int32AsNumericIdentity class are listed here.

Public Methods
Name | Description
ColumnToValue | Converts a value that comes from a database query to an ecospace value.
ColumnType | Specifies the SQL type of the column.
DefaultDbValue | The return value of this function will be used as default value for new columns when databases are created/evolved.
MakeColumnAutoInc | If the database requires any additional operations in addition to the column type to give a column "autoinc" behaviour, that should be performed by this method.
StringToParameter | This method should never be called. Autoinc values are never stored!
ValueToParameter | This method should never be called. Autoinc values are never stored!
ValueType | This method returns the type of the value that is returned by ColumnToValue.


Int32AsNumericIdentity.ColumnToValue Method

Int32AsNumericIdentity.ColumnToValue Method
Int32AsNumericIdentity Class Eco.Persistence.Sybase Namespace See Also
Collapse All

Converts a value that comes from a database query to an ecospace value.

C#
public override System.Object ColumnToValue(
    System.Object columnValue
);
Remarks

In many cases, the implementation of this method mainly converts DBNull-values to null, but it can also change the CLR-type of the database value from for example a char[] to a string. or from an integer to a boolean. This is the reverse operation of ValueToParameter.

See Also
Int32AsNumericIdentity Class
Eco.Persistence.Sybase Namespace


Int32AsNumericIdentity.ColumnType Method

Int32AsNumericIdentity.ColumnType Method
Int32AsNumericIdentity Class Eco.Persistence.Sybase Namespace See Also
Collapse All

Specifies the SQL type of the column.

C#
public String ColumnType(
    int length
);
See Also
Int32AsNumericIdentity Class
Eco.Persistence.Sybase Namespace


Int32AsNumericIdentity.DefaultDbValue Method

Int32AsNumericIdentity.DefaultDbValue Method
Int32AsNumericIdentity Class Eco.Persistence.Sybase Namespace See Also
Collapse All

The return value of this function will be used as default value for new columns when databases are created/evolved.

C#
public override String DefaultDbValue(
    string modeledValue,
    SqlDatabaseConfig sqlDatabaseConfig
);
See Also
Int32AsNumericIdentity Class
Eco.Persistence.Sybase Namespace


Int32AsNumericIdentity.MakeColumnAutoInc Method

Int32AsNumericIdentity.MakeColumnAutoInc Method
Int32AsNumericIdentity Class Eco.Persistence.Sybase Namespace See Also
Collapse All

If the database requires any additional operations in addition to the column type to give a column "autoinc" behaviour, that should be performed by this method.

C#
public void MakeColumnAutoInc(
    string tableName,
    string columnName,
    IDatabase database
);
Remarks

Even if the database does not require any additional operations, this interface should be implemented by an autoinc attribute mapper, and the implementation of this method should be left blank.

See Also
Int32AsNumericIdentity Class
Eco.Persistence.Sybase Namespace


Int32AsNumericIdentity.StringToParameter Method

Int32AsNumericIdentity.StringToParameter Method
Int32AsNumericIdentity Class Eco.Persistence.Sybase Namespace See Also
Collapse All

This method should never be called. Autoinc values are never stored!

C#
public void StringToParameter(
    string value,
    IDataParameter parameter
);
Exceptions
Exceptions | Description
NotSupportedException | Thrown always.
See Also
Int32AsNumericIdentity Class
Eco.Persistence.Sybase Namespace


Int32AsNumericIdentity.ValueToParameter Method

Int32AsNumericIdentity.ValueToParameter Method
Int32AsNumericIdentity Class Eco.Persistence.Sybase Namespace See Also
Collapse All

This method should never be called. Autoinc values are never stored!

C#
public void ValueToParameter(
    System.Object value,
    IDataParameter parameter
);
Exceptions
Exceptions | Description
NotSupportedException | Thrown always.
See Also
Int32AsNumericIdentity Class
Eco.Persistence.Sybase Namespace


Int32AsNumericIdentity.ValueType Method

Int32AsNumericIdentity.ValueType Method
Int32AsNumericIdentity Class Eco.Persistence.Sybase Namespace See Also
Collapse All

This method returns the type of the value that is returned by ColumnToValue.

C#
public System.Type ValueType();
See Also
Int32AsNumericIdentity Class
Eco.Persistence.Sybase Namespace


SingleAsFloat Class

SingleAsFloat Class
Inheritance Hierarchy See Also
Collapse All
C#
public sealed class SingleAsFloat : AbstractNumericSingleColumnAttribute, ISingleColumnAttributemapping, IDefaultReverseMapping;
Remarks

This is class Eco.Persistence.Sybase.SingleAsFloat.

Inheritance Hierarchy
Eco.Persistence.IDefaultReverseMapping
Eco.Persistence.ISingleColumnAttributemapping
    Eco.Persistence.Sybase.SingleAsFloat
File

SybaseAttributeMappersCommon.cs

See Also
Inheritance Hierarchy


SingleAsFloat.ColumnToValue Method

SingleAsFloat.ColumnToValue Method
SingleAsFloat Class Eco.Persistence.Sybase Namespace See Also
Collapse All

Converts a value that comes from a database query to an ecospace value.

C#
public override System.Object ColumnToValue(
    System.Object columnValue
);
Remarks

In many cases, the implementation of this method mainly converts DBNull-values to null, but it can also change the CLR-type of the database value from for example a char[] to a string. or from an integer to a boolean. This is the reverse operation of ValueToParameter.

See Also
SingleAsFloat Class
Eco.Persistence.Sybase Namespace


SingleAsFloat.ColumnType Method

SingleAsFloat.ColumnType Method
SingleAsFloat Class Eco.Persistence.Sybase Namespace See Also
Collapse All

Specifies the SQL type of the column.

C#
public String ColumnType(
    int length
);
See Also
SingleAsFloat Class
Eco.Persistence.Sybase Namespace


SingleAsFloat.StringToParameter Method

SingleAsFloat.StringToParameter Method
SingleAsFloat Class Eco.Persistence.Sybase Namespace See Also
Collapse All
C#
public void StringToParameter(
    string value,
    IDataParameter parameter
);
Remarks

This is StringToParameter, a member of class SingleAsFloat.

See Also
SingleAsFloat Class
Eco.Persistence.Sybase Namespace


SingleAsFloat.ValueToParameter Method

SingleAsFloat.ValueToParameter Method
SingleAsFloat Class Eco.Persistence.Sybase Namespace See Also
Collapse All

Converts a value that comes from a database query to an ecospace value.

C#
public void ValueToParameter(
    System.Object value,
    IDataParameter parameter
);
Remarks

In many cases, the implementation of this method mainly converts null to DBNull, but it can also handle conversion from for example booleans to integers, byte[] to database blobs. It also has to set the correct parameter types in the IDataParameter-object. This is the reverse operation of ColumnToValue.

See Also
SingleAsFloat Class
Eco.Persistence.Sybase Namespace


SingleAsFloat.ValueType Method

SingleAsFloat.ValueType Method
SingleAsFloat Class Eco.Persistence.Sybase Namespace See Also
Collapse All

This method returns the type of the value that is returned by ColumnToValue.

C#
public System.Type ValueType();
See Also
SingleAsFloat Class
Eco.Persistence.Sybase Namespace


Eco.Persistence.Sybase.Ase Namespace

Eco.Persistence.Sybase.Ase Namespace
Classes
Collapse All

This is namespace Eco.Persistence.Sybase.Ase.

Classes
Name | Description
ByteArrayAsImage | Mapper between a ByteArray value and its persistent representation as IMAGE.
StringAsText | This is class Eco.Persistence.Sybase.Ase.StringAsText.
StringAsUniVarChar | This is class Eco.Persistence.Sybase.Ase.StringAsUniVarChar.


ByteArrayAsImage Class

ByteArrayAsImage Class
Inheritance Hierarchy See Also
Collapse All

Mapper between a ByteArray value and its persistent representation as IMAGE.

C#
public sealed class ByteArrayAsImage : AbstractSingleColumnAttribute, ISingleColumnAttributemapping;
Inheritance Hierarchy
Eco.Persistence.ISingleColumnAttributemapping
    Eco.Persistence.Sybase.Ase.ByteArrayAsImage
File

SybaseAttributeMappersAse.cs

See Also
Inheritance Hierarchy


ByteArrayAsImage Methods

ByteArrayAsImage Methods
Public Methods
Collapse All

The methods of the ByteArrayAsImage class are listed here.

Public Methods
Name | Description
ColumnToValue | Converts a value that comes from a database query to an ecospace value.
ColumnType | Specifies the SQL type of the column.
DefaultDbValue | The return value of this function will be used as default value for new columns when databases are created/evolved.
StringToParameter |
ValueToParameter | Converts a value that comes from a database query to an ecospace value.
ValueType | This method returns the type of the value that is returned by ColumnToValue.


ByteArrayAsImage.ColumnToValue Method

ByteArrayAsImage.ColumnToValue Method
ByteArrayAsImage Class Eco.Persistence.Sybase.Ase Namespace See Also
Collapse All

Converts a value that comes from a database query to an ecospace value.

C#
public override System.Object ColumnToValue(
    System.Object columnValue
);
Remarks

In many cases, the implementation of this method mainly converts DBNull-values to null, but it can also change the CLR-type of the database value from for example a char[] to a string. or from an integer to a boolean. This is the reverse operation of ValueToParameter.

See Also
ByteArrayAsImage Class
Eco.Persistence.Sybase.Ase Namespace


ByteArrayAsImage.ColumnType Method

ByteArrayAsImage.ColumnType Method
ByteArrayAsImage Class Eco.Persistence.Sybase.Ase Namespace See Also
Collapse All

Specifies the SQL type of the column.

C#
public String ColumnType(
    int length
);
See Also
ByteArrayAsImage Class
Eco.Persistence.Sybase.Ase Namespace


ByteArrayAsImage.DefaultDbValue Method

ByteArrayAsImage.DefaultDbValue Method
ByteArrayAsImage Class Eco.Persistence.Sybase.Ase Namespace See Also
Collapse All

The return value of this function will be used as default value for new columns when databases are created/evolved.

C#
public String DefaultDbValue(
    string modeledValue,
    SqlDatabaseConfig sqlDatabaseConfig
);
See Also
ByteArrayAsImage Class
Eco.Persistence.Sybase.Ase Namespace


ByteArrayAsImage.StringToParameter Method

ByteArrayAsImage.StringToParameter Method
ByteArrayAsImage Class Eco.Persistence.Sybase.Ase Namespace See Also
Collapse All
C#
public void StringToParameter(
    string value,
    IDataParameter parameter
);
Exceptions
Exceptions | Description
InvalidOperationException | Thrown always.
See Also
ByteArrayAsImage Class
Eco.Persistence.Sybase.Ase Namespace


ByteArrayAsImage.ValueToParameter Method

ByteArrayAsImage.ValueToParameter Method
ByteArrayAsImage Class Eco.Persistence.Sybase.Ase Namespace See Also
Collapse All

Converts a value that comes from a database query to an ecospace value.

C#
public void ValueToParameter(
    System.Object value,
    IDataParameter parameter
);
Remarks

In many cases, the implementation of this method mainly converts null to DBNull, but it can also handle conversion from for example booleans to integers, byte[] to database blobs. It also has to set the correct parameter types in the IDataParameter-object. This is the reverse operation of ColumnToValue.

See Also
ByteArrayAsImage Class
Eco.Persistence.Sybase.Ase Namespace


ByteArrayAsImage.ValueType Method

ByteArrayAsImage.ValueType Method
ByteArrayAsImage Class Eco.Persistence.Sybase.Ase Namespace See Also
Collapse All

This method returns the type of the value that is returned by ColumnToValue.

C#
public System.Type ValueType();
See Also
ByteArrayAsImage Class
Eco.Persistence.Sybase.Ase Namespace


StringAsText Class

StringAsText Class
Inheritance Hierarchy See Also
Collapse All
C#
public sealed class StringAsText : AbstractSingleColumnAttribute, ISingleColumnAttributemapping;
Remarks

This is class Eco.Persistence.Sybase.Ase.StringAsText.

Inheritance Hierarchy
Eco.Persistence.ISingleColumnAttributemapping
    Eco.Persistence.Sybase.Ase.StringAsText
File

SybaseAttributeMappersAse.cs

See Also
Inheritance Hierarchy


StringAsText.ColumnToValue Method

StringAsText.ColumnToValue Method
StringAsText Class Eco.Persistence.Sybase.Ase Namespace See Also
Collapse All

Converts a value that comes from a database query to an ecospace value.

C#
public override System.Object ColumnToValue(
    System.Object columnValue
);
Remarks

In many cases, the implementation of this method mainly converts DBNull-values to null, but it can also change the CLR-type of the database value from for example a char[] to a string. or from an integer to a boolean. This is the reverse operation of ValueToParameter.

See Also
StringAsText Class
Eco.Persistence.Sybase.Ase Namespace


StringAsText.ColumnType Method

StringAsText.ColumnType Method
StringAsText Class Eco.Persistence.Sybase.Ase Namespace See Also
Collapse All

Specifies the SQL type of the column.

C#
public String ColumnType(
    int length
);
See Also
StringAsText Class
Eco.Persistence.Sybase.Ase Namespace


StringAsText.DefaultDbValue Method

StringAsText.DefaultDbValue Method
StringAsText Class Eco.Persistence.Sybase.Ase Namespace See Also
Collapse All

The return value of this function will be used as default value for new columns when databases are created/evolved.

C#
public String DefaultDbValue(
    string modeledValue,
    SqlDatabaseConfig sqlDatabaseConfig
);
See Also
StringAsText Class
Eco.Persistence.Sybase.Ase Namespace


StringAsText.StringToParameter Method

StringAsText.StringToParameter Method
StringAsText Class Eco.Persistence.Sybase.Ase Namespace See Also
Collapse All
C#
public void StringToParameter(
    string value,
    IDataParameter parameter
);
Remarks

This is StringToParameter, a member of class StringAsText.

See Also
StringAsText Class
Eco.Persistence.Sybase.Ase Namespace


StringAsText.ValueToParameter Method

StringAsText.ValueToParameter Method
StringAsText Class Eco.Persistence.Sybase.Ase Namespace See Also
Collapse All

Converts a value that comes from a database query to an ecospace value.

C#
public void ValueToParameter(
    System.Object value,
    IDataParameter parameter
);
Remarks

In many cases, the implementation of this method mainly converts null to DBNull, but it can also handle conversion from for example booleans to integers, byte[] to database blobs. It also has to set the correct parameter types in the IDataParameter-object. This is the reverse operation of ColumnToValue.

See Also
StringAsText Class
Eco.Persistence.Sybase.Ase Namespace


StringAsText.ValueType Method

StringAsText.ValueType Method
StringAsText Class Eco.Persistence.Sybase.Ase Namespace See Also
Collapse All

This method returns the type of the value that is returned by ColumnToValue.

C#
public System.Type ValueType();
See Also
StringAsText Class
Eco.Persistence.Sybase.Ase Namespace


StringAsUniVarChar Class

StringAsUniVarChar Class
Inheritance Hierarchy See Also
Collapse All
C#
public sealed class StringAsUniVarChar : AbstractSingleColumnAttribute, ISingleColumnAttributemapping;
Remarks

This is class Eco.Persistence.Sybase.Ase.StringAsUniVarChar.

Inheritance Hierarchy
Eco.Persistence.ISingleColumnAttributemapping
    Eco.Persistence.Sybase.Ase.StringAsUniVarChar
File

SybaseAttributeMappersAse.cs

See Also
Inheritance Hierarchy


StringAsUniVarChar Methods

StringAsUniVarChar Methods
Public Methods
Collapse All

The methods of the StringAsUniVarChar class are listed here.

Public Methods
Name | Description
ColumnToValue | Converts a value that comes from a database query to an ecospace value.
ColumnType | Specifies the SQL type of the column.
DefaultDbValue | The return value of this function will be used as default value for new columns when databases are created/evolved.
StringToParameter | This is StringToParameter, a member of class StringAsUniVarChar.
ValueToParameter | Converts a value that comes from a database query to an ecospace value.
ValueType | This method returns the type of the value that is returned by ColumnToValue.


StringAsUniVarChar.ColumnToValue Method

StringAsUniVarChar.ColumnToValue Method
StringAsUniVarChar Class Eco.Persistence.Sybase.Ase Namespace See Also
Collapse All

Converts a value that comes from a database query to an ecospace value.

C#
public override System.Object ColumnToValue(
    System.Object columnValue
);
Remarks

In many cases, the implementation of this method mainly converts DBNull-values to null, but it can also change the CLR-type of the database value from for example a char[] to a string. or from an integer to a boolean. This is the reverse operation of ValueToParameter.

See Also
StringAsUniVarChar Class
Eco.Persistence.Sybase.Ase Namespace


StringAsUniVarChar.ColumnType Method

StringAsUniVarChar.ColumnType Method
StringAsUniVarChar Class Eco.Persistence.Sybase.Ase Namespace See Also
Collapse All

Specifies the SQL type of the column.

C#
public String ColumnType(
    int length
);
See Also
StringAsUniVarChar Class
Eco.Persistence.Sybase.Ase Namespace


StringAsUniVarChar.DefaultDbValue Method

StringAsUniVarChar.DefaultDbValue Method
StringAsUniVarChar Class Eco.Persistence.Sybase.Ase Namespace See Also
Collapse All

The return value of this function will be used as default value for new columns when databases are created/evolved.

C#
public String DefaultDbValue(
    string modeledValue,
    SqlDatabaseConfig sqlDatabaseConfig
);
See Also
StringAsUniVarChar Class
Eco.Persistence.Sybase.Ase Namespace


StringAsUniVarChar.StringToParameter Method

StringAsUniVarChar.StringToParameter Method
StringAsUniVarChar Class Eco.Persistence.Sybase.Ase Namespace See Also
Collapse All
C#
public void StringToParameter(
    string value,
    IDataParameter parameter
);
Remarks

This is StringToParameter, a member of class StringAsUniVarChar.

See Also
StringAsUniVarChar Class
Eco.Persistence.Sybase.Ase Namespace


StringAsUniVarChar.ValueToParameter Method

StringAsUniVarChar.ValueToParameter Method
StringAsUniVarChar Class Eco.Persistence.Sybase.Ase Namespace See Also
Collapse All

Converts a value that comes from a database query to an ecospace value.

C#
public void ValueToParameter(
    System.Object value,
    IDataParameter parameter
);
Remarks

In many cases, the implementation of this method mainly converts null to DBNull, but it can also handle conversion from for example booleans to integers, byte[] to database blobs. It also has to set the correct parameter types in the IDataParameter-object. This is the reverse operation of ColumnToValue.

See Also
StringAsUniVarChar Class
Eco.Persistence.Sybase.Ase Namespace


StringAsUniVarChar.ValueType Method

StringAsUniVarChar.ValueType Method
StringAsUniVarChar Class Eco.Persistence.Sybase.Ase Namespace See Also
Collapse All

This method returns the type of the value that is returned by ColumnToValue.

C#
public System.Type ValueType();
See Also
StringAsUniVarChar Class
Eco.Persistence.Sybase.Ase Namespace


Eco.Persistence.Sybase.Bdp Namespace

Eco.Persistence.Sybase.Bdp Namespace
Classes
Collapse All

This is namespace Eco.Persistence.Sybase.Bdp.

Classes
Name | Description
ByteArrayAsImage | Mapper between a ByteArray value and its persistent representation as IMAGE.
StringAsText | This is class Eco.Persistence.Sybase.Bdp.StringAsText.


ByteArrayAsImage Class

ByteArrayAsImage Class
Inheritance Hierarchy See Also
Collapse All

Mapper between a ByteArray value and its persistent representation as IMAGE.

C#
public sealed class ByteArrayAsImage : AbstractSingleColumnAttribute, ISingleColumnAttributemapping;
Inheritance Hierarchy
Eco.Persistence.ISingleColumnAttributemapping
    Eco.Persistence.Sybase.Bdp.ByteArrayAsImage
File

SybaseAttributeMappersBdp.cs

See Also
Inheritance Hierarchy


ByteArrayAsImage.ColumnToValue Method

ByteArrayAsImage.ColumnToValue Method
ByteArrayAsImage Class Eco.Persistence.Sybase.Bdp Namespace See Also
Collapse All

Converts a value that comes from a database query to an ecospace value.

C#
public override System.Object ColumnToValue(
    System.Object columnValue
);
Remarks

In many cases, the implementation of this method mainly converts DBNull-values to null, but it can also change the CLR-type of the database value from for example a char[] to a string. or from an integer to a boolean. This is the reverse operation of ValueToParameter.

See Also
ByteArrayAsImage Class
Eco.Persistence.Sybase.Bdp Namespace


ByteArrayAsImage.ColumnType Method

ByteArrayAsImage.ColumnType Method
ByteArrayAsImage Class Eco.Persistence.Sybase.Bdp Namespace See Also
Collapse All

Specifies the SQL type of the column.

C#
public String ColumnType(
    int length
);
See Also
ByteArrayAsImage Class
Eco.Persistence.Sybase.Bdp Namespace


ByteArrayAsImage.DefaultDbValue Method

ByteArrayAsImage.DefaultDbValue Method
ByteArrayAsImage Class Eco.Persistence.Sybase.Bdp Namespace See Also
Collapse All

The return value of this function will be used as default value for new columns when databases are created/evolved.

C#
public String DefaultDbValue(
    string modeledValue,
    SqlDatabaseConfig sqlDatabaseConfig
);
See Also
ByteArrayAsImage Class
Eco.Persistence.Sybase.Bdp Namespace


ByteArrayAsImage.IsEqual Method

ByteArrayAsImage.IsEqual Method
ByteArrayAsImage Class Eco.Persistence.Sybase.Bdp Namespace See Also
Collapse All

Returns true if an ecospace value ("value") is equal to a database value ("columnValue").

C#
public override bool IsEqual(
    System.Object value,
    System.Object columnValue
);
Remarks

This method must handle the conversions between ecospace and database values, it must also handle comparing null/DBNull values.

See Also
ByteArrayAsImage Class
Eco.Persistence.Sybase.Bdp Namespace


ByteArrayAsImage.StringToParameter Method

ByteArrayAsImage.StringToParameter Method
ByteArrayAsImage Class Eco.Persistence.Sybase.Bdp Namespace See Also
Collapse All
C#
public void StringToParameter(
    string value,
    IDataParameter parameter
);
Exceptions
Exceptions | Description
InvalidOperationException | Thrown always.
See Also
ByteArrayAsImage Class
Eco.Persistence.Sybase.Bdp Namespace


ByteArrayAsImage.ValueToParameter Method

ByteArrayAsImage.ValueToParameter Method
ByteArrayAsImage Class Eco.Persistence.Sybase.Bdp Namespace See Also
Collapse All

Converts a value that comes from a database query to an ecospace value.

C#
public void ValueToParameter(
    System.Object value,
    IDataParameter parameter
);
Remarks

In many cases, the implementation of this method mainly converts null to DBNull, but it can also handle conversion from for example booleans to integers, byte[] to database blobs. It also has to set the correct parameter types in the IDataParameter-object. This is the reverse operation of ColumnToValue.

See Also
ByteArrayAsImage Class
Eco.Persistence.Sybase.Bdp Namespace


ByteArrayAsImage.ValueType Method

ByteArrayAsImage.ValueType Method
ByteArrayAsImage Class Eco.Persistence.Sybase.Bdp Namespace See Also
Collapse All

This method returns the type of the value that is returned by ColumnToValue.

C#
public System.Type ValueType();
See Also
ByteArrayAsImage Class
Eco.Persistence.Sybase.Bdp Namespace


StringAsText Class

StringAsText Class
Inheritance Hierarchy See Also
Collapse All
C#
public sealed class StringAsText : AbstractSingleColumnAttribute, ISingleColumnAttributemapping;
Remarks

This is class Eco.Persistence.Sybase.Bdp.StringAsText.

Inheritance Hierarchy
Eco.Persistence.ISingleColumnAttributemapping
    Eco.Persistence.Sybase.Bdp.StringAsText
File

SybaseAttributeMappersBdp.cs

See Also
Inheritance Hierarchy


StringAsText.ColumnToValue Method

StringAsText.ColumnToValue Method
StringAsText Class Eco.Persistence.Sybase.Bdp Namespace See Also
Collapse All

Converts a value that comes from a database query to an ecospace value.

C#
public override System.Object ColumnToValue(
    System.Object columnValue
);
Remarks

In many cases, the implementation of this method mainly converts DBNull-values to null, but it can also change the CLR-type of the database value from for example a char[] to a string. or from an integer to a boolean. This is the reverse operation of ValueToParameter.

See Also
StringAsText Class
Eco.Persistence.Sybase.Bdp Namespace


StringAsText.ColumnType Method

StringAsText.ColumnType Method
StringAsText Class Eco.Persistence.Sybase.Bdp Namespace See Also
Collapse All

Specifies the SQL type of the column.

C#
public String ColumnType(
    int length
);
See Also
StringAsText Class
Eco.Persistence.Sybase.Bdp Namespace


StringAsText.DefaultDbValue Method

StringAsText.DefaultDbValue Method
StringAsText Class Eco.Persistence.Sybase.Bdp Namespace See Also
Collapse All

The return value of this function will be used as default value for new columns when databases are created/evolved.

C#
public String DefaultDbValue(
    string modeledValue,
    SqlDatabaseConfig sqlDatabaseConfig
);
See Also
StringAsText Class
Eco.Persistence.Sybase.Bdp Namespace


StringAsText.StringToParameter Method

StringAsText.StringToParameter Method
StringAsText Class Eco.Persistence.Sybase.Bdp Namespace See Also
Collapse All
C#
public void StringToParameter(
    string value,
    IDataParameter parameter
);
Remarks

This is StringToParameter, a member of class StringAsText.

See Also
StringAsText Class
Eco.Persistence.Sybase.Bdp Namespace


StringAsText.ValueToParameter Method

StringAsText.ValueToParameter Method
StringAsText Class Eco.Persistence.Sybase.Bdp Namespace See Also
Collapse All

Converts a value that comes from a database query to an ecospace value.

C#
public void ValueToParameter(
    System.Object value,
    IDataParameter parameter
);
Remarks

In many cases, the implementation of this method mainly converts null to DBNull, but it can also handle conversion from for example booleans to integers, byte[] to database blobs. It also has to set the correct parameter types in the IDataParameter-object. This is the reverse operation of ColumnToValue.

See Also
StringAsText Class
Eco.Persistence.Sybase.Bdp Namespace


StringAsText.ValueType Method

StringAsText.ValueType Method
StringAsText Class Eco.Persistence.Sybase.Bdp Namespace See Also
Collapse All

This method returns the type of the value that is returned by ColumnToValue.

C#
public System.Type ValueType();
See Also
StringAsText Class
Eco.Persistence.Sybase.Bdp Namespace


Eco.Persistence.Validator Namespace

Eco.Persistence.Validator Namespace
Classes
Collapse All

This is namespace Eco.Persistence.Validator.

Classes
Name | Description
TBoldDbDataValidator | This is class Eco.Persistence.Validator.TBoldDbDataValidator.
TBoldDbStructureValidator | This is class Eco.Persistence.Validator.TBoldDbStructureValidator.
TBoldDbValidator | This is class Eco.Persistence.Validator.TBoldDbValidator.


TBoldDbDataValidator Class

TBoldDbDataValidator Class
Inheritance Hierarchy See Also
Collapse All
C#
public class TBoldDbDataValidator : TBoldDbValidator;
Remarks

This is class Eco.Persistence.Validator.TBoldDbDataValidator.

Inheritance Hierarchy
Eco.Persistence.Validator.TBoldDbValidator
    Eco.Persistence.Validator.TBoldDbDataValidator
File

BoldDbDataValidator.cs

See Also
Inheritance Hierarchy


TBoldDbDataValidator.TBoldDbDataValidator Constructor

TBoldDbDataValidator.TBoldDbDataValidator Constructor
TBoldDbDataValidator Class Eco.Persistence.Validator Namespace See Also
Collapse All
C#
public TBoldDbDataValidator(
    IDatabase Database,
    SystemPersistenceMapper Mapper
);
Remarks

RemedyCleanRelation: string = 'UPDATE %s SET %s = -1 WHERE BOLD_ID IN (%s);'; RemedyDeleteObjects: string = 'DELETE FROM %s WHERE BOLD_ID IN (%s);'; SQLSelectByID: string = 'SELECT * FROM %s WHERE BOLD_ID IN (%s)'; TBoldDbDataValidator Constructor Create( Database, Mapper)

See Also
TBoldDbDataValidator Class
Eco.Persistence.Validator Namespace


TBoldDbDataValidator Methods

TBoldDbDataValidator Methods
Protected Methods
Collapse All

The methods of the TBoldDbDataValidator class are listed here.

Protected Methods
Name | Description
Validate | This is Validate, a member of class TBoldDbDataValidator.


TBoldDbDataValidator.Validate Method

TBoldDbDataValidator.Validate Method
TBoldDbDataValidator Class Eco.Persistence.Validator Namespace See Also
Collapse All
C#
protected override void Validate();
Remarks

This is Validate, a member of class TBoldDbDataValidator.

See Also
TBoldDbDataValidator Class
Eco.Persistence.Validator Namespace


TBoldDbDataValidator Properties

TBoldDbDataValidator Properties
Public Properties
Collapse All

The properties of the TBoldDbDataValidator class are listed here.

Public Properties
Name | Description
IdColumnName | This is IdColumnName, a member of class TBoldDbDataValidator.


TBoldDbDataValidator.IdColumnName Property

TBoldDbDataValidator.IdColumnName Property
TBoldDbDataValidator Class Eco.Persistence.Validator Namespace See Also
Collapse All
C#
public string IdColumnName;
Remarks

This is IdColumnName, a member of class TBoldDbDataValidator.

See Also
TBoldDbDataValidator Class
Eco.Persistence.Validator Namespace


TBoldDbStructureValidator Class

TBoldDbStructureValidator Class
Inheritance Hierarchy See Also
Collapse All
C#
public class TBoldDbStructureValidator : TBoldDbValidator;
Remarks

This is class Eco.Persistence.Validator.TBoldDbStructureValidator.

Inheritance Hierarchy
Eco.Persistence.Validator.TBoldDbValidator
    Eco.Persistence.Validator.TBoldDbStructureValidator
File

BoldDbStructureValidator.cs

See Also
Inheritance Hierarchy


TBoldDbStructureValidator.TBoldDbStructureValidator Constructor

TBoldDbStructureValidator.TBoldDbStructureValidator Constructor
TBoldDbStructureValidator Class Eco.Persistence.Validator Namespace See Also
Collapse All
C#
public TBoldDbStructureValidator(
    IDatabase Database,
    SystemPersistenceMapper Mapper
);
Remarks

This is TBoldDbStructureValidator, a member of class TBoldDbStructureValidator.

See Also
TBoldDbStructureValidator Class
Eco.Persistence.Validator Namespace


TBoldDbStructureValidator Methods

TBoldDbStructureValidator Methods
Protected Methods
Collapse All

The methods of the TBoldDbStructureValidator class are listed here.

Protected Methods
Name | Description
Validate | This is Validate, a member of class TBoldDbStructureValidator.


TBoldDbStructureValidator.Validate Method

TBoldDbStructureValidator.Validate Method
TBoldDbStructureValidator Class Eco.Persistence.Validator Namespace See Also
Collapse All
C#
protected override void Validate();
Remarks

This is Validate, a member of class TBoldDbStructureValidator.

See Also
TBoldDbStructureValidator Class
Eco.Persistence.Validator Namespace


TBoldDbValidator Class

TBoldDbValidator Class
Inheritance Hierarchy See Also
Collapse All
C#
public abstract class TBoldDbValidator;
Remarks

This is class Eco.Persistence.Validator.TBoldDbValidator.

Inheritance Hierarchy
Eco.Persistence.Validator.TBoldDbValidator
    Eco.Persistence.Validator.TBoldDbDataValidator
    Eco.Persistence.Validator.TBoldDbStructureValidator
File

BoldDbValidator.cs

See Also
Inheritance Hierarchy


TBoldDbValidator.TBoldDbValidator Constructor

TBoldDbValidator.TBoldDbValidator Constructor
TBoldDbValidator Class Eco.Persistence.Validator Namespace See Also
Collapse All
C#
public TBoldDbValidator(
    IDatabase database,
    SystemPersistenceMapper mapper
);
Remarks

This is TBoldDbValidator, a member of class TBoldDbValidator.

See Also
TBoldDbValidator Class
Eco.Persistence.Validator Namespace


TBoldDbValidator Methods

TBoldDbValidator Methods
Protected Methods Public Methods
Collapse All

The methods of the TBoldDbValidator class are listed here.

Protected Methods
Name | Description
Validate | This is Validate, a member of class TBoldDbValidator.
Top
Public Methods
Name | Description
Execute | This is Execute, a member of class TBoldDbValidator.
ValidationLog | TBoldDbValidator


TBoldDbValidator.Execute Method

TBoldDbValidator.Execute Method
TBoldDbValidator Class Eco.Persistence.Validator Namespace See Also
Collapse All
C#
public bool Execute();
Remarks

This is Execute, a member of class TBoldDbValidator.

See Also
TBoldDbValidator Class
Eco.Persistence.Validator Namespace


TBoldDbValidator.Validate Method

TBoldDbValidator.Validate Method
TBoldDbValidator Class Eco.Persistence.Validator Namespace See Also
Collapse All
C#
protected abstract void Validate();
Remarks

This is Validate, a member of class TBoldDbValidator.

See Also
TBoldDbValidator Class
Eco.Persistence.Validator Namespace


TBoldDbValidator.ValidationLog Method

TBoldDbValidator.ValidationLog Method
TBoldDbValidator Class Eco.Persistence.Validator Namespace See Also
Collapse All
C#
public static void ValidationLog(
    string message
);
Remarks

TBoldDbValidator

See Also
TBoldDbValidator Class
Eco.Persistence.Validator Namespace


TBoldDbValidator Properties

TBoldDbValidator Properties
Public Properties Protected Properties
Collapse All

The properties of the TBoldDbValidator class are listed here.

Public Properties
Name | Description
Remedy | This is Remedy, a member of class TBoldDbValidator.
Top
Protected Properties
Name | Description
DataBase | This is DataBase, a member of class TBoldDbValidator.
SystemSQLMapper | This is SystemSQLMapper, a member of class TBoldDbValidator.


TBoldDbValidator.DataBase Property

TBoldDbValidator.DataBase Property
TBoldDbValidator Class Eco.Persistence.Validator Namespace See Also
Collapse All
C#
protected IDatabase DataBase;
Remarks

This is DataBase, a member of class TBoldDbValidator.

See Also
TBoldDbValidator Class
Eco.Persistence.Validator Namespace


TBoldDbValidator.Remedy Property

TBoldDbValidator.Remedy Property
TBoldDbValidator Class Eco.Persistence.Validator Namespace See Also
Collapse All
C#
public IList<string> Remedy;
Remarks

This is Remedy, a member of class TBoldDbValidator.

See Also
TBoldDbValidator Class
Eco.Persistence.Validator Namespace


TBoldDbValidator.SystemSQLMapper Property

TBoldDbValidator.SystemSQLMapper Property
TBoldDbValidator Class Eco.Persistence.Validator Namespace See Also
Collapse All
C#
protected SystemPersistenceMapper SystemSQLMapper;
Remarks

This is SystemSQLMapper, a member of class TBoldDbValidator.

See Also
TBoldDbValidator Class
Eco.Persistence.Validator Namespace


Eco.ReflectionReader Namespace

Eco.ReflectionReader Namespace
Classes
Collapse All

FIXME: Cleanup after conversion

Classes
Name | Description
AssociationClassLink | This is class Eco.ReflectionReader.AssociationClassLink.
AssociationLink | This is class Eco.ReflectionReader.AssociationLink.
ClassData | This is class Eco.ReflectionReader.ClassData.
CustomAttributeCracker | This is class Eco.ReflectionReader.CustomAttributeCracker.
NonNavigableAssociationEndData | This is class Eco.ReflectionReader.NonNavigableAssociationEndData.
ReflectionReader | This is class Eco.ReflectionReader.ReflectionReader.
StateMachineReader | This is class Eco.ReflectionReader.StateMachineReader.


AssociationClassLink Class

AssociationClassLink Class
Inheritance Hierarchy See Also
Collapse All
C#
public class AssociationClassLink;
Remarks

This is class Eco.ReflectionReader.AssociationClassLink.

Inheritance Hierarchy
Eco.ReflectionReader.AssociationClassLink
File

ReflectionReader.cs

See Also
Inheritance Hierarchy


AssociationClassLink.AssociationClassLink Constructor

AssociationClassLink.AssociationClassLink Constructor
AssociationClassLink Class Eco.ReflectionReader Namespace See Also
Collapse All
C#
public AssociationClassLink(
    string association,
    UmlClass class_
);
Remarks

This is AssociationClassLink, a member of class AssociationClassLink.

See Also
AssociationClassLink Class
Eco.ReflectionReader Namespace


AssociationClassLink Fields

AssociationClassLink Fields
Public Fields
Collapse All

The fields of the AssociationClassLink class are listed here.

Public Fields
Name | Description
Association | This is Association, a member of class AssociationClassLink.
Class_ | This is Class_, a member of class AssociationClassLink.


AssociationClassLink.Association Field

AssociationClassLink.Association Field
AssociationClassLink Class Eco.ReflectionReader Namespace See Also
Collapse All
C#
public readonly string Association;
Remarks

This is Association, a member of class AssociationClassLink.

See Also
AssociationClassLink Class
Eco.ReflectionReader Namespace


AssociationClassLink.Class_ Field

AssociationClassLink.Class_ Field
AssociationClassLink Class Eco.ReflectionReader Namespace See Also
Collapse All
C#
public readonly UmlClass Class_;
Remarks

This is Class_, a member of class AssociationClassLink.

See Also
AssociationClassLink Class
Eco.ReflectionReader Namespace


AssociationLink Class

AssociationLink Class
Inheritance Hierarchy See Also
Collapse All
C#
public class AssociationLink;
Remarks

This is class Eco.ReflectionReader.AssociationLink.

Inheritance Hierarchy
Eco.ReflectionReader.AssociationLink
File

ReflectionReader.cs

See Also
Inheritance Hierarchy


AssociationLink.AssociationLink Constructor

AssociationLink.AssociationLink Constructor
AssociationLink Class Eco.ReflectionReader Namespace See Also
Collapse All
C#
public AssociationLink(
    string association,
    AssociationEndNormal associationEnd,
    int index
);
Remarks

This is AssociationLink, a member of class AssociationLink.

See Also
AssociationLink Class
Eco.ReflectionReader Namespace


AssociationLink Fields

AssociationLink Fields
Public Fields
Collapse All

The fields of the AssociationLink class are listed here.

Public Fields
Name | Description
Association | This is Association, a member of class AssociationLink.
AssociationEnd | This is AssociationEnd, a member of class AssociationLink.
Index | This is Index, a member of class AssociationLink.


AssociationLink.Association Field

AssociationLink.Association Field
AssociationLink Class Eco.ReflectionReader Namespace See Also
Collapse All
C#
public readonly string Association;
Remarks

This is Association, a member of class AssociationLink.

See Also
AssociationLink Class
Eco.ReflectionReader Namespace


AssociationLink.AssociationEnd Field

AssociationLink.AssociationEnd Field
AssociationLink Class Eco.ReflectionReader Namespace See Also
Collapse All
C#
public readonly AssociationEndNormal AssociationEnd;
Remarks

This is AssociationEnd, a member of class AssociationLink.

See Also
AssociationLink Class
Eco.ReflectionReader Namespace


AssociationLink.Index Field

AssociationLink.Index Field
AssociationLink Class Eco.ReflectionReader Namespace See Also
Collapse All
C#
public readonly int Index;
Remarks

This is Index, a member of class AssociationLink.

See Also
AssociationLink Class
Eco.ReflectionReader Namespace


ClassData Class

ClassData Class
Inheritance Hierarchy See Also
Collapse All
C#
public class ClassData;
Remarks

This is class Eco.ReflectionReader.ClassData.

Inheritance Hierarchy
Eco.ReflectionReader.ClassData
File

ReflectionReader.cs

See Also
Inheritance Hierarchy


ClassData.ClassData Constructor

ClassData.ClassData Constructor
ClassData Class Eco.ReflectionReader Namespace See Also
Collapse All
C#
public ClassData(
    UmlClass Class_,
    IList<StateMachineTransport> StateMachineTransports
);
Remarks

This is ClassData, a member of class ClassData.

See Also
ClassData Class
Eco.ReflectionReader Namespace


ClassData Properties

ClassData Properties
Public Properties
Collapse All

The properties of the ClassData class are listed here.

Public Properties
Name | Description
FoundInPackage | This is FoundInPackage, a member of class ClassData.
IsOldStyleAssociationClass | This is IsOldStyleAssociationClass, a member of class ClassData.
StateMachineTransports | This is StateMachineTransports, a member of class ClassData.
UmlClass | This is UmlClass, a member of class ClassData.


ClassData.FoundInPackage Property

ClassData.FoundInPackage Property
ClassData Class Eco.ReflectionReader Namespace See Also
Collapse All
C#
public bool FoundInPackage;
Remarks

This is FoundInPackage, a member of class ClassData.

See Also
ClassData Class
Eco.ReflectionReader Namespace


ClassData.IsOldStyleAssociationClass Property

ClassData.IsOldStyleAssociationClass Property
ClassData Class Eco.ReflectionReader Namespace See Also
Collapse All
C#
public bool IsOldStyleAssociationClass;
Remarks

This is IsOldStyleAssociationClass, a member of class ClassData.

See Also
ClassData Class
Eco.ReflectionReader Namespace


ClassData.StateMachineTransports Property

ClassData.StateMachineTransports Property
ClassData Class Eco.ReflectionReader Namespace See Also
Collapse All
C#
public IList<StateMachineTransport> StateMachineTransports;
Remarks

This is StateMachineTransports, a member of class ClassData.

See Also
ClassData Class
Eco.ReflectionReader Namespace


ClassData.UmlClass Property

ClassData.UmlClass Property
ClassData Class Eco.ReflectionReader Namespace See Also
Collapse All
C#
public UmlClass UmlClass;
Remarks

This is UmlClass, a member of class ClassData.

See Also
ClassData Class
Eco.ReflectionReader Namespace


CustomAttributeCracker Class

CustomAttributeCracker Class
Inheritance Hierarchy See Also
Collapse All
C#
public class CustomAttributeCracker;
Remarks

This is class Eco.ReflectionReader.CustomAttributeCracker.

Inheritance Hierarchy
Eco.ReflectionReader.CustomAttributeCracker
File

ReflectionReader.cs

See Also
Inheritance Hierarchy


CustomAttributeCracker.CustomAttributeCracker Constructor

CustomAttributeCracker.CustomAttributeCracker Constructor
CustomAttributeCracker Class Eco.ReflectionReader Namespace See Also
Collapse All
C#
public CustomAttributeCracker(
    MemberInfo m
);
Remarks

This is CustomAttributeCracker, a member of class CustomAttributeCracker.

See Also
CustomAttributeCracker Class
Eco.ReflectionReader Namespace


CustomAttributeCracker Properties

CustomAttributeCracker Properties
Public Properties
Collapse All

The properties of the CustomAttributeCracker class are listed here.

Public Properties
Name | Description
EcoAutoGenerated | This is EcoAutoGenerated, a member of class CustomAttributeCracker.
EcoAutoMaintained | This is EcoAutoMaintained, a member of class CustomAttributeCracker.
MetaAttributes | This is MetaAttributes, a member of class CustomAttributeCracker.
StateMachines | This is StateMachines, a member of class CustomAttributeCracker.
TaggedValues | This is TaggedValues, a member of class CustomAttributeCracker.
UmlElement | This is UmlElement, a member of class CustomAttributeCracker.


CustomAttributeCracker.EcoAutoGenerated Property

CustomAttributeCracker.EcoAutoGenerated Property
CustomAttributeCracker Class Eco.ReflectionReader Namespace See Also
Collapse All
C#
public bool EcoAutoGenerated;
Remarks

This is EcoAutoGenerated, a member of class CustomAttributeCracker.

See Also
CustomAttributeCracker Class
Eco.ReflectionReader Namespace


CustomAttributeCracker.EcoAutoMaintained Property

CustomAttributeCracker.EcoAutoMaintained Property
CustomAttributeCracker Class Eco.ReflectionReader Namespace See Also
Collapse All
C#
public bool EcoAutoMaintained;
Remarks

This is EcoAutoMaintained, a member of class CustomAttributeCracker.

See Also
CustomAttributeCracker Class
Eco.ReflectionReader Namespace


CustomAttributeCracker.MetaAttributes Property

CustomAttributeCracker.MetaAttributes Property
CustomAttributeCracker Class Eco.ReflectionReader Namespace See Also
Collapse All
C#
public IList<UmlMetaAttributeAttribute> MetaAttributes;
Remarks

This is MetaAttributes, a member of class CustomAttributeCracker.

See Also
CustomAttributeCracker Class
Eco.ReflectionReader Namespace


CustomAttributeCracker.StateMachines Property

CustomAttributeCracker.StateMachines Property
CustomAttributeCracker Class Eco.ReflectionReader Namespace See Also
Collapse All
C#
public IList<StateMachineTransport> StateMachines;
Remarks

This is StateMachines, a member of class CustomAttributeCracker.

See Also
CustomAttributeCracker Class
Eco.ReflectionReader Namespace


CustomAttributeCracker.TaggedValues Property

CustomAttributeCracker.TaggedValues Property
CustomAttributeCracker Class Eco.ReflectionReader Namespace See Also
Collapse All
C#
public IList<UmlTaggedValueAttribute> TaggedValues;
Remarks

This is TaggedValues, a member of class CustomAttributeCracker.

See Also
CustomAttributeCracker Class
Eco.ReflectionReader Namespace


CustomAttributeCracker.UmlElement Property

CustomAttributeCracker.UmlElement Property
CustomAttributeCracker Class Eco.ReflectionReader Namespace See Also
Collapse All
C#
public Eco.UmlCodeAttributes.UmlElementAttribute UmlElement;
Remarks

This is UmlElement, a member of class CustomAttributeCracker.

See Also
CustomAttributeCracker Class
Eco.ReflectionReader Namespace


NonNavigableAssociationEndData Class

NonNavigableAssociationEndData Class
Inheritance Hierarchy See Also
Collapse All
C#
public class NonNavigableAssociationEndData;
Remarks

This is class Eco.ReflectionReader.NonNavigableAssociationEndData.

Inheritance Hierarchy
Eco.ReflectionReader.NonNavigableAssociationEndData
File

ReflectionReader.cs

See Also
Inheritance Hierarchy


NonNavigableAssociationEndData.NonNavigableAssociationEndData Constructor

NonNavigableAssociationEndData.NonNavigableAssociationEndData Constructor
NonNavigableAssociationEndData Class Eco.ReflectionReader Namespace See Also
Collapse All
C#
public NonNavigableAssociationEndData(
    System.Type t,
    CustomAttributeCracker endAttributes,
    UmlAssociation association
);
Remarks

This is NonNavigableAssociationEndData, a member of class NonNavigableAssociationEndData.

See Also
NonNavigableAssociationEndData Class
Eco.ReflectionReader Namespace


NonNavigableAssociationEndData Fields

NonNavigableAssociationEndData Fields
Public Fields
Collapse All

The fields of the NonNavigableAssociationEndData class are listed here.

Public Fields
Name | Description
Association | This is Association, a member of class NonNavigableAssociationEndData.
EndAttributes | This is EndAttributes, a member of class NonNavigableAssociationEndData.
Type_ | This is Type_, a member of class NonNavigableAssociationEndData.


NonNavigableAssociationEndData.Association Field

NonNavigableAssociationEndData.Association Field
NonNavigableAssociationEndData Class Eco.ReflectionReader Namespace See Also
Collapse All
C#
public UmlAssociation Association;
Remarks

This is Association, a member of class NonNavigableAssociationEndData.

See Also
NonNavigableAssociationEndData Class
Eco.ReflectionReader Namespace


NonNavigableAssociationEndData.EndAttributes Field

NonNavigableAssociationEndData.EndAttributes Field
NonNavigableAssociationEndData Class Eco.ReflectionReader Namespace See Also
Collapse All
C#
public CustomAttributeCracker EndAttributes;
Remarks

This is EndAttributes, a member of class NonNavigableAssociationEndData.

See Also
NonNavigableAssociationEndData Class
Eco.ReflectionReader Namespace


NonNavigableAssociationEndData.Type_ Field

NonNavigableAssociationEndData.Type_ Field
NonNavigableAssociationEndData Class Eco.ReflectionReader Namespace See Also
Collapse All
C#
public readonly System.Type Type_;
Remarks

This is Type_, a member of class NonNavigableAssociationEndData.

See Also
NonNavigableAssociationEndData Class
Eco.ReflectionReader Namespace


ReflectionReader Class

ReflectionReader Class
Inheritance Hierarchy See Also
Collapse All
C#
public class ReflectionReader;
Remarks

This is class Eco.ReflectionReader.ReflectionReader.

Inheritance Hierarchy
Eco.ReflectionReader.ReflectionReader
File

ReflectionReader.cs

See Also
Inheritance Hierarchy


ReflectionReader Methods

ReflectionReader Methods
Public Methods
Collapse All

The methods of the ReflectionReader class are listed here.

Public Methods
Name | Description
ConvertStructuralFeature | This is ConvertStructuralFeature, a member of class ReflectionReader.
EnsuredModelName | This is EnsuredModelName, a member of class ReflectionReader.
EnsureElement_GetAssociation | This is EnsureElement_GetAssociation, a member of class ReflectionReader.
GetAsString | This is GetAsString, a member of class ReflectionReader.
GetTaggedValues | This is GetTaggedValues, a member of class ReflectionReader.
ReadAttributeUmlAttributes | This is ReadAttributeUmlAttributes, a member of class ReflectionReader.
ReadMethodUmlAttributes | This is ReadMethodUmlAttributes, a member of class ReflectionReader.
StripEqual | This is StripEqual, a member of class ReflectionReader.


ReflectionReader.ConvertStructuralFeature Method

ReflectionReader.ConvertStructuralFeature Method
ReflectionReader Class Eco.ReflectionReader Namespace See Also
Collapse All
C#
public static void ConvertStructuralFeature(
    PropertyInfo p,
    CustomAttributeCracker attributes,
    StructuralFeature member
);
Remarks

This is ConvertStructuralFeature, a member of class ReflectionReader.

See Also
ReflectionReader Class
Eco.ReflectionReader Namespace


ReflectionReader.EnsuredModelName Method

ReflectionReader.EnsuredModelName Method
ReflectionReader Class Eco.ReflectionReader Namespace See Also
Collapse All
C#
public static string EnsuredModelName(
    EcoSpaceAttribute nameAttribute
);
Remarks

This is EnsuredModelName, a member of class ReflectionReader.

See Also
ReflectionReader Class
Eco.ReflectionReader Namespace


ReflectionReader.EnsureElement_GetAssociation Method

ReflectionReader.EnsureElement_GetAssociation Method
ReflectionReader Class Eco.ReflectionReader Namespace See Also
Collapse All
C#
public UmlAssociation EnsureElement_GetAssociation(
    System.Type t,
    CustomAttributeCracker attributes
);
Remarks

This is EnsureElement_GetAssociation, a member of class ReflectionReader.

See Also
ReflectionReader Class
Eco.ReflectionReader Namespace


ReflectionReader.GetAsString Method

ReflectionReader.GetAsString Method
ReflectionReader Class Eco.ReflectionReader Namespace See Also
Collapse All
C#
public static string GetAsString(
    Object value
);
Remarks

This is GetAsString, a member of class ReflectionReader.

See Also
ReflectionReader Class
Eco.ReflectionReader Namespace


ReflectionReader.GetTaggedValues Method

ReflectionReader.GetTaggedValues Method
ReflectionReader Class Eco.ReflectionReader Namespace See Also
Collapse All
C#
public static void GetTaggedValues(
    MemberInfo e,
    CustomAttributeCracker Attributes,
    UmlRtElement Element
);
Remarks

This is GetTaggedValues, a member of class ReflectionReader.

See Also
ReflectionReader Class
Eco.ReflectionReader Namespace


ReflectionReader.ReadAttributeUmlAttributes Method

ReflectionReader.ReadAttributeUmlAttributes Method
ReflectionReader Class Eco.ReflectionReader Namespace See Also
Collapse All
C#
public static void ReadAttributeUmlAttributes(
    CustomAttributeCracker Attributes,
    UmlAttribute Attr
);
Remarks

This is ReadAttributeUmlAttributes, a member of class ReflectionReader.

See Also
ReflectionReader Class
Eco.ReflectionReader Namespace


ReflectionReader.ReadMethodUmlAttributes Method

ReflectionReader.ReadMethodUmlAttributes Method
ReflectionReader Class Eco.ReflectionReader Namespace See Also
Collapse All
C#
public static void ReadMethodUmlAttributes(
    MethodInfo mi,
    CustomAttributeCracker Attributes,
    Eco.UmlRt.Impl.Method Method
);
Remarks

This is ReadMethodUmlAttributes, a member of class ReflectionReader.

See Also
ReflectionReader Class
Eco.ReflectionReader Namespace


ReflectionReader.StripEqual Method

ReflectionReader.StripEqual Method
ReflectionReader Class Eco.ReflectionReader Namespace See Also
Collapse All
C#
public static string StripEqual(
    string s
);
Remarks

This is StripEqual, a member of class ReflectionReader.

See Also
ReflectionReader Class
Eco.ReflectionReader Namespace


StateMachineReader Class

StateMachineReader Class
Inheritance Hierarchy See Also
Collapse All
C#
public class StateMachineReader;
Remarks

This is class Eco.ReflectionReader.StateMachineReader.

Inheritance Hierarchy
Eco.ReflectionReader.StateMachineReader
File

StateMachineReader.cs

See Also
Inheritance Hierarchy


StateMachineReader.StateMachineReader Constructor

StateMachineReader.StateMachineReader Constructor
StateMachineReader Class Eco.ReflectionReader Namespace See Also
Collapse All
C#
public StateMachineReader();
Remarks

This is StateMachineReader, a member of class StateMachineReader.

See Also
StateMachineReader Class
Eco.ReflectionReader Namespace


StateMachineReader Methods

StateMachineReader Methods
Public Methods
Collapse All

The methods of the StateMachineReader class are listed here.

Public Methods
Name | Description
Read | This is Read, a member of class StateMachineReader.


StateMachineReader.Read Method

StateMachineReader.Read Method
StateMachineReader Class Eco.ReflectionReader Namespace See Also
Collapse All
C#
public static StateMachineImpl Read(
    string name,
    ICollection<StateMachineTransport> stateMachineTransports,
    UmlClass umlClass
);
Remarks

This is Read, a member of class StateMachineReader.

See Also
StateMachineReader Class
Eco.ReflectionReader Namespace


Eco.Services Namespace

Eco.Services Namespace
Classes Enumerations Interfaces
Collapse All

This is namespace Eco.Services.

Classes
Name | Description
ChainedUndoServiceBase | This class implements the IUndoService interface by simply passing all calls on to another IUndoService implementation It is intended for subclassing by IUndoService implementations that need to implement only a subset of the features of the interface. Override any methods you need to intercept and at the end of the overridden methods, either call the base method, or call the same method on NextUndoService manually. If the behaviour of the original UndoService is not wanted at all, then just skip calling it.
EcoServiceHelper | This class contains a collection of useful utility methods for working with the services. All the methods are static.
IActionLanguageServiceExtensions | This is class Eco.Services.IActionLanguageServiceExtensions.
IOclPsServiceExtensions | This is class Eco.Services.IOclPsServiceExtensions.
IOclServiceExtensions | This is class Eco.Services.IOclServiceExtensions.
ObjectListHelper | This is class Eco.Services.ObjectListHelper.
OptimisticLockException | This Exception is thrown by IPersistenceService.UpdateDatabaseWithList if there is a optimistic locking conflict.
PersistenceServiceExtensions | This is class Eco.Services.PersistenceServiceExtensions.
Top
Enumerations
Name | Description
ChangeActionKind | Specifies what kind of action should be taken when IPersistenceService.ApplyAllChanges is executed.
ChangeKind | Identifies the kind of change that has taken place to an object in the persistent storage.
Top
Interfaces
Name | Description
IActionLanguageService | This interface allows programmatic access to evaluating OCL expressions and performing modifications to the EcoSpace by executing commands.
IActionLanguageTypeService | The methods of this interface performs static analysis of OCL expressions. This is mainly used during designtime to calculate static types of handles.
IAutoSubscriptionContext | This is class Eco.Services.IAutoSubscriptionContext.
IAutoSubscriptionService | Provides a way to automatically place subscriptions.
ICacheContentService | Provides a way to inject data into the local EcoSpace cache.
IChange | Holds information about a change conflict.
IDirtyListService | This service provides information about modifications made to objects in the local cache.
IExtentService | Allows you to query the EcoSpace for all a list of all instances of a class, including instances of all subclasses.
IExternalIdService | Provides a way of uniquely identifying object instances and also retrieving them from the persistent storage using this unique ID.
IObjectFactoryService | Provides methods for you to create new instances of the classes in your model.
IOclPsService | This interface allows evaluation OCL expressions directly in the persistent storage (typically a database).
IOclPsTypeService | The methods of this interface performs static analysis of OCl expressions. Mainly intended to be used in designtime to calculate static types of handles.
IOclService | This interface allows programmatic access to evaluating OCL expressions. Expressions using the IOclService are always evaluated in memory. Any data required to fulfil the evaluation will be fetched automatically from the persistent storage as needed.
IOclTypeService | The methods of this interface performs static analysis of OCL expressions. Mainly intended to be used during design time to calculate static types of handles.
IPersistenceService | This interface provides a collection of persistence functions in the form of a service.
IStateService | Allows you to discover whether a particular object or property in the ECO space has been modified.
IStaticContext | This interface is mainly intended for the internal use of the ElementHandles.
ITypeService | This service is used at design time to perform analysis of OCL expressions. It is mainly used to calculate the static types of handles.
ITypeSystemService | Allows you to get the type system of the model, and to validate the model programmatically.
IUndoBlock | Contains a collection of changes to elements within the local EcoSpace cache. Using the IUndoService these changes may be reversed or re-applied multiple times.
IUndoBlockList | Contains a collection of IUndoBlock and provides controlled access to rearranging the blocks.
IUndoService | Provides in-memory transaction and undo/redo support.
IVariableFactoryService | Provides a programmatic interface for creating what are essentially VariableHandle components. Variables created with this service can be used directly with the IOclService.
IVersionService | This service provides a way of working with modeled UML classes marked as Versioned in the model.


ChainedUndoServiceBase Class

ChainedUndoServiceBase Class
Inheritance Hierarchy See Also
Collapse All

This class implements the IUndoService interface by simply passing all calls on to another IUndoService implementation It is intended for subclassing by IUndoService implementations that need to implement only a subset of the features of the interface.

Override any methods you need to intercept and at the end of the overridden methods, either call the base method, or call the same method on NextUndoService manually. If the behaviour of the original UndoService is not wanted at all, then just skip calling it.

C#
public class ChainedUndoServiceBase : IUndoService;
Inheritance Hierarchy
Eco.Services.IUndoService
    Eco.Services.ChainedUndoServiceBase
File

AbstractUndoService.cs

See Also
Inheritance Hierarchy


ChainedUndoServiceBase.ChainedUndoServiceBase Constructor

ChainedUndoServiceBase.ChainedUndoServiceBase Constructor
ChainedUndoServiceBase Class Eco.Services Namespace See Also
Collapse All
C#
public ChainedUndoServiceBase(
    IUndoService nextUndoService
);
Remarks

This is ChainedUndoServiceBase, a member of class ChainedUndoServiceBase.

See Also
ChainedUndoServiceBase Class
Eco.Services Namespace


ChainedUndoServiceBase Methods

ChainedUndoServiceBase Methods
Public Methods
Collapse All

The methods of the ChainedUndoServiceBase class are listed here.

Public Methods
Name | Description
CanRedoBlock | Default implementation that will only call the same method on the "NextUndoService"
CanUndoBlock | Default implementation that will only call the same method on the "NextUndoService"
ClearAllUndoBlocks | Default implementation that will only call the same method on the "NextUndoService"
CommitTransaction | Default implementation that will only call the same method on the "NextUndoService"
GetUniqueBlockName | Default implementation that will only call the same method on the "NextUndoService"
RedoBlock | Default implementation that will only call the same method on the "NextUndoService"
RedoLatest | Default implementation that will only call the same method on the "NextUndoService"
RollbackTransaction | Default implementation that will only call the same method on the "NextUndoService"
StartTransaction | Default implementation that will only call the same method on the "NextUndoService"
StartUndoBlock | This is the overview for the StartUndoBlock method overload.
UndoBlock | Default implementation that will only call the same method on the "NextUndoService"
UndoLatest | Default implementation that will only call the same method on the "NextUndoService"


ChainedUndoServiceBase.CanRedoBlock Method

ChainedUndoServiceBase.CanRedoBlock Method
ChainedUndoServiceBase Class Eco.Services Namespace See Also
Collapse All

Default implementation that will only call the same method on the "NextUndoService"

C#
public virtual bool CanRedoBlock(
    string blockName
);
See Also
ChainedUndoServiceBase Class
Eco.Services Namespace


ChainedUndoServiceBase.CanUndoBlock Method

ChainedUndoServiceBase.CanUndoBlock Method
ChainedUndoServiceBase Class Eco.Services Namespace See Also
Collapse All

Default implementation that will only call the same method on the "NextUndoService"

C#
public virtual bool CanUndoBlock(
    string blockName
);
See Also
ChainedUndoServiceBase Class
Eco.Services Namespace


ChainedUndoServiceBase.ClearAllUndoBlocks Method

ChainedUndoServiceBase.ClearAllUndoBlocks Method
ChainedUndoServiceBase Class Eco.Services Namespace See Also
Collapse All

Default implementation that will only call the same method on the "NextUndoService"

C#
public virtual void ClearAllUndoBlocks();
See Also
ChainedUndoServiceBase Class
Eco.Services Namespace


ChainedUndoServiceBase.CommitTransaction Method

ChainedUndoServiceBase.CommitTransaction Method
ChainedUndoServiceBase Class Eco.Services Namespace See Also
Collapse All

Default implementation that will only call the same method on the "NextUndoService"

C#
public virtual void CommitTransaction();
See Also
ChainedUndoServiceBase Class
Eco.Services Namespace


ChainedUndoServiceBase.GetUniqueBlockName Method

ChainedUndoServiceBase.GetUniqueBlockName Method
ChainedUndoServiceBase Class Eco.Services Namespace See Also
Collapse All

Default implementation that will only call the same method on the "NextUndoService"

C#
public virtual string GetUniqueBlockName(
    string suggestedName
);
See Also
ChainedUndoServiceBase Class
Eco.Services Namespace


ChainedUndoServiceBase.RedoBlock Method

ChainedUndoServiceBase.RedoBlock Method
ChainedUndoServiceBase Class Eco.Services Namespace See Also
Collapse All

Default implementation that will only call the same method on the "NextUndoService"

C#
public virtual void RedoBlock(
    string blockName
);
See Also
ChainedUndoServiceBase Class
Eco.Services Namespace


ChainedUndoServiceBase.RedoLatest Method

ChainedUndoServiceBase.RedoLatest Method
ChainedUndoServiceBase Class Eco.Services Namespace See Also
Collapse All

Default implementation that will only call the same method on the "NextUndoService"

C#
public virtual void RedoLatest();
See Also
ChainedUndoServiceBase Class
Eco.Services Namespace


ChainedUndoServiceBase.RollbackTransaction Method

ChainedUndoServiceBase.RollbackTransaction Method
ChainedUndoServiceBase Class Eco.Services Namespace See Also
Collapse All

Default implementation that will only call the same method on the "NextUndoService"

C#
public virtual void RollbackTransaction();
See Also
ChainedUndoServiceBase Class
Eco.Services Namespace


ChainedUndoServiceBase.StartTransaction Method

ChainedUndoServiceBase.StartTransaction Method
ChainedUndoServiceBase Class Eco.Services Namespace See Also
Collapse All

Default implementation that will only call the same method on the "NextUndoService"

C#
public virtual void StartTransaction();
See Also
ChainedUndoServiceBase Class
Eco.Services Namespace


StartUndoBlock Method

StartUndoBlock Method

This is the overview for the StartUndoBlock method overload.

Overload List
Name | Description
ChainedUndoServiceBase.StartUndoBlock () | Default implementation that will only call the same method on the "NextUndoService"
ChainedUndoServiceBase.StartUndoBlock (string) | Default implementation that will only call the same method on the "NextUndoService"


ChainedUndoServiceBase.StartUndoBlock Method ()

ChainedUndoServiceBase.StartUndoBlock Method ()
ChainedUndoServiceBase Class Eco.Services Namespace See Also
Collapse All

Default implementation that will only call the same method on the "NextUndoService"

C#
public virtual void StartUndoBlock();
See Also
ChainedUndoServiceBase Class
Eco.Services Namespace


ChainedUndoServiceBase.StartUndoBlock Method (string)

ChainedUndoServiceBase.StartUndoBlock Method (string)
ChainedUndoServiceBase Class Eco.Services Namespace See Also
Collapse All

Default implementation that will only call the same method on the "NextUndoService"

C#
public virtual void StartUndoBlock(
    string blockName
);
See Also
ChainedUndoServiceBase Class
Eco.Services Namespace


ChainedUndoServiceBase.UndoBlock Method

ChainedUndoServiceBase.UndoBlock Method
ChainedUndoServiceBase Class Eco.Services Namespace See Also
Collapse All

Default implementation that will only call the same method on the "NextUndoService"

C#
public virtual void UndoBlock(
    string blockName
);
See Also
ChainedUndoServiceBase Class
Eco.Services Namespace


ChainedUndoServiceBase.UndoLatest Method

ChainedUndoServiceBase.UndoLatest Method
ChainedUndoServiceBase Class Eco.Services Namespace See Also
Collapse All

Default implementation that will only call the same method on the "NextUndoService"

C#
public virtual void UndoLatest();
See Also
ChainedUndoServiceBase Class
Eco.Services Namespace


ChainedUndoServiceBase Properties

ChainedUndoServiceBase Properties
Public Properties
Collapse All

The properties of the ChainedUndoServiceBase class are listed here.

Public Properties
Name | Description
IsInTransaction | Default implementation that will only call the same method on the "NextUndoService"
NextUndoService | This is NextUndoService, a member of class ChainedUndoServiceBase.
RedoList | Default implementation that will only call the same method on the "NextUndoService"
TransactionNesting | Default implementation that will only call the same method on the "NextUndoService"
UndoList | Default implementation that will only call the same method on the "NextUndoService"


ChainedUndoServiceBase.IsInTransaction Property

ChainedUndoServiceBase.IsInTransaction Property
ChainedUndoServiceBase Class Eco.Services Namespace See Also
Collapse All

Default implementation that will only call the same method on the "NextUndoService"

C#
public virtual bool IsInTransaction;
See Also
ChainedUndoServiceBase Class
Eco.Services Namespace


ChainedUndoServiceBase.NextUndoService Property

ChainedUndoServiceBase.NextUndoService Property
ChainedUndoServiceBase Class Eco.Services Namespace See Also
Collapse All
C#
public IUndoService NextUndoService;
Remarks

This is NextUndoService, a member of class ChainedUndoServiceBase.

See Also
ChainedUndoServiceBase Class
Eco.Services Namespace


ChainedUndoServiceBase.RedoList Property

ChainedUndoServiceBase.RedoList Property
ChainedUndoServiceBase Class Eco.Services Namespace See Also
Collapse All

Default implementation that will only call the same method on the "NextUndoService"

C#
public virtual IUndoBlockList RedoList;
See Also
ChainedUndoServiceBase Class
Eco.Services Namespace


ChainedUndoServiceBase.TransactionNesting Property

ChainedUndoServiceBase.TransactionNesting Property
ChainedUndoServiceBase Class Eco.Services Namespace See Also
Collapse All

Default implementation that will only call the same method on the "NextUndoService"

C#
public virtual int TransactionNesting;
See Also
ChainedUndoServiceBase Class
Eco.Services Namespace


ChainedUndoServiceBase.UndoList Property

ChainedUndoServiceBase.UndoList Property
ChainedUndoServiceBase Class Eco.Services Namespace See Also
Collapse All

Default implementation that will only call the same method on the "NextUndoService"

C#
public virtual IUndoBlockList UndoList;
See Also
ChainedUndoServiceBase Class
Eco.Services Namespace


EcoServiceHelper Class

EcoServiceHelper Class
Inheritance Hierarchy See Also
Collapse All

This class contains a collection of useful utility methods for working with the services. All the methods are static.

C#
public sealed class EcoServiceHelper;
Inheritance Hierarchy
Eco.Services.EcoServiceHelper
File

Services.cs

See Also
Inheritance Hierarchy


EcoServiceHelper Methods

EcoServiceHelper Methods
Public Methods
Collapse All

The methods of the EcoServiceHelper class are listed here.

Public Methods
Name | Description
GetActionLanguageService | Get an IEcoServiceProvider using GetServiceProvider, and retrieve IActionLanguageService from it.
GetActionLanguageTypeService | Get an IEcoServiceProvider using GetServiceProvider, and retrieve IActionLanguageTypeService from it.
GetCacheContentService | Get an IEcoServiceProvider using GetServiceProvider, and retrieve ICacheContentService from it.
GetDirtyListService | Get an IEcoServiceProvider using GetServiceProvider, and retrieve IDirtyListService from it.
GetEcoService | Get an IEcoServiceProvider using GetServiceProvider, and retrieve a generic service from it
GetExtentService | Get an IEcoServiceProvider using GetServiceProvider, and retrieve IExtentService from it.
GetExternalIdService | Get an IEcoServiceProvider using GetServiceProvider, and retrieve IExternalIdService from it.
GetObjectFactoryService | Get an IEcoServiceProvider using GetServiceProvider, and retrieve IObjectFactoryService from it.
GetOclPsService | Get an IEcoServiceProvider using GetServiceProvider, and retrieve IOclPsService from it.
GetOclPsTypeService | Get an IEcoServiceProvider using GetServiceProvider, and retrieve IOclPsTypeService from it.
GetOclService | Get an IEcoServiceProvider using GetServiceProvider, and retrieve IOclService from it.
GetOclTypeService | Get an IEcoServiceProvider using GetServiceProvider, and retrieve IOclTypeService from it.
GetPersistenceService | Get an IEcoServiceProvider using GetServiceProvider, and retrieve IPersistenceService from it.
GetServiceProvider | Check if obj is of a type that can be used to reach a IEcoServiceProvider and if so return it. This method will be sucessfull if obj implements IEcoObject, IProperty, IObjectProvder or IEcoServiceProvider. This includes ECO Objects, EcoSpaces and ElementHandles.
GetStateService | Get an IEcoServiceProvider using GetServiceProvider, and retrieve IStateService from it.
GetTypeService | Get an IEcoServiceProvider using GetServiceProvider, and retrieve ITypeService from it.
GetTypeSystemService | Get an IEcoServiceProvider using GetServiceProvider, and retrieve ITypeSystemService from it.
GetUndoService | Get an IEcoServiceProvider using GetServiceProvider, and retrieve IUndoService from it.
GetVariableFactoryService | Get an IEcoServiceProvider using GetServiceProvider, and retrieve IVariableFactoryService from it.
GetVersionService | Get an IEcoServiceProvider using GetServiceProvider, and retrieve IVersionService from it.
SafeGetServiceProvider | Check if obj is of a type that can be used to reach a IEcoServiceProvider and if so return it. If it can't reach an IEcoServiceProvider, it will return null.


EcoServiceHelper.GetActionLanguageService Method

EcoServiceHelper.GetActionLanguageService Method
EcoServiceHelper Class Eco.Services Namespace See Also
Collapse All

Get an IEcoServiceProvider using GetServiceProvider, and retrieve IActionLanguageService from it.

C#
public static IActionLanguageService GetActionLanguageService(
    object obj
);
See Also
EcoServiceHelper Class
Eco.Services Namespace


EcoServiceHelper.GetActionLanguageTypeService Method

EcoServiceHelper.GetActionLanguageTypeService Method
EcoServiceHelper Class Eco.Services Namespace See Also
Collapse All

Get an IEcoServiceProvider using GetServiceProvider, and retrieve IActionLanguageTypeService from it.

C#
public static IActionLanguageTypeService GetActionLanguageTypeService(
    object obj
);
See Also
EcoServiceHelper Class
Eco.Services Namespace


EcoServiceHelper.GetCacheContentService Method

EcoServiceHelper.GetCacheContentService Method
EcoServiceHelper Class Eco.Services Namespace See Also
Collapse All

Get an IEcoServiceProvider using GetServiceProvider, and retrieve ICacheContentService from it.

C#
public static ICacheContentService GetCacheContentService(
    object obj
);
See Also
EcoServiceHelper Class
Eco.Services Namespace


EcoServiceHelper.GetDirtyListService Method

EcoServiceHelper.GetDirtyListService Method
EcoServiceHelper Class Eco.Services Namespace See Also
Collapse All

Get an IEcoServiceProvider using GetServiceProvider, and retrieve IDirtyListService from it.

C#
public static IDirtyListService GetDirtyListService(
    object obj
);
See Also
EcoServiceHelper Class
Eco.Services Namespace


EcoServiceHelper.GetEcoService Method

EcoServiceHelper.GetEcoService Method
EcoServiceHelper Class Eco.Services Namespace See Also
Collapse All

Get an IEcoServiceProvider using GetServiceProvider, and retrieve a generic service from it

C#
public static T GetEcoService<T>(
    object obj
) where T : class;
See Also
EcoServiceHelper Class
Eco.Services Namespace


EcoServiceHelper.GetExtentService Method

EcoServiceHelper.GetExtentService Method
EcoServiceHelper Class Eco.Services Namespace See Also
Collapse All

Get an IEcoServiceProvider using GetServiceProvider, and retrieve IExtentService from it.

C#
public static IExtentService GetExtentService(
    object obj
);
See Also
EcoServiceHelper Class
Eco.Services Namespace


EcoServiceHelper.GetExternalIdService Method

EcoServiceHelper.GetExternalIdService Method
EcoServiceHelper Class Eco.Services Namespace See Also
Collapse All

Get an IEcoServiceProvider using GetServiceProvider, and retrieve IExternalIdService from it.

C#
public static IExternalIdService GetExternalIdService(
    object obj
);
See Also
EcoServiceHelper Class
Eco.Services Namespace


EcoServiceHelper.GetObjectFactoryService Method

EcoServiceHelper.GetObjectFactoryService Method
EcoServiceHelper Class Eco.Services Namespace See Also
Collapse All

Get an IEcoServiceProvider using GetServiceProvider, and retrieve IObjectFactoryService from it.

C#
public static IObjectFactoryService GetObjectFactoryService(
    object obj
);
See Also
EcoServiceHelper Class
Eco.Services Namespace


EcoServiceHelper.GetOclPsService Method

EcoServiceHelper.GetOclPsService Method
EcoServiceHelper Class Eco.Services Namespace See Also
Collapse All

Get an IEcoServiceProvider using GetServiceProvider, and retrieve IOclPsService from it.

C#
public static IOclPsService GetOclPsService(
    object obj
);
See Also
EcoServiceHelper Class
Eco.Services Namespace


EcoServiceHelper.GetOclPsTypeService Method

EcoServiceHelper.GetOclPsTypeService Method
EcoServiceHelper Class Eco.Services Namespace See Also
Collapse All

Get an IEcoServiceProvider using GetServiceProvider, and retrieve IOclPsTypeService from it.

C#
public static IOclPsTypeService GetOclPsTypeService(
    object obj
);
See Also
EcoServiceHelper Class
Eco.Services Namespace


EcoServiceHelper.GetOclService Method

EcoServiceHelper.GetOclService Method
EcoServiceHelper Class Eco.Services Namespace See Also
Collapse All

Get an IEcoServiceProvider using GetServiceProvider, and retrieve IOclService from it.

C#
public static IOclService GetOclService(
    object obj
);
See Also
EcoServiceHelper Class
Eco.Services Namespace


EcoServiceHelper.GetOclTypeService Method

EcoServiceHelper.GetOclTypeService Method
EcoServiceHelper Class Eco.Services Namespace See Also
Collapse All

Get an IEcoServiceProvider using GetServiceProvider, and retrieve IOclTypeService from it.

C#
public static IOclTypeService GetOclTypeService(
    object obj
);
See Also
EcoServiceHelper Class
Eco.Services Namespace


EcoServiceHelper.GetPersistenceService Method

EcoServiceHelper.GetPersistenceService Method
EcoServiceHelper Class Eco.Services Namespace See Also
Collapse All

Get an IEcoServiceProvider using GetServiceProvider, and retrieve IPersistenceService from it.

C#
public static IPersistenceService GetPersistenceService(
    object obj
);
See Also
EcoServiceHelper Class
Eco.Services Namespace


EcoServiceHelper.GetServiceProvider Method

EcoServiceHelper.GetServiceProvider Method
EcoServiceHelper Class Eco.Services Namespace See Also
Collapse All

Check if obj is of a type that can be used to reach a IEcoServiceProvider and if so return it. This method will be sucessfull if obj implements IEcoObject, IProperty, IObjectProvder or IEcoServiceProvider. This includes ECO Objects, EcoSpaces and ElementHandles.

C#
public static IEcoServiceProvider GetServiceProvider(
    object obj
);
Parameters
Parameters | Description
obj | The object to retrieve an IEcoServiceProvider reference from.
Exceptions
Exceptions | Description
ArgumentNullException | Thrown if obj is null.
ArgumentException | Thrown if obj obj cannot be used to reach a IEcoServiceProvider.
See Also
EcoServiceHelper Class
Eco.Services Namespace


EcoServiceHelper.GetStateService Method

EcoServiceHelper.GetStateService Method
EcoServiceHelper Class Eco.Services Namespace See Also
Collapse All

Get an IEcoServiceProvider using GetServiceProvider, and retrieve IStateService from it.

C#
public static IStateService GetStateService(
    object obj
);
See Also
EcoServiceHelper Class
Eco.Services Namespace


EcoServiceHelper.GetTypeService Method

EcoServiceHelper.GetTypeService Method
EcoServiceHelper Class Eco.Services Namespace See Also
Collapse All

Get an IEcoServiceProvider using GetServiceProvider, and retrieve ITypeService from it.

C#
public static ITypeService GetTypeService(
    object obj
);
See Also
EcoServiceHelper Class
Eco.Services Namespace


EcoServiceHelper.GetTypeSystemService Method

EcoServiceHelper.GetTypeSystemService Method
EcoServiceHelper Class Eco.Services Namespace See Also
Collapse All

Get an IEcoServiceProvider using GetServiceProvider, and retrieve ITypeSystemService from it.

C#
public static ITypeSystemService GetTypeSystemService(
    object obj
);
See Also
EcoServiceHelper Class
Eco.Services Namespace


EcoServiceHelper.GetUndoService Method

EcoServiceHelper.GetUndoService Method
EcoServiceHelper Class Eco.Services Namespace See Also
Collapse All

Get an IEcoServiceProvider using GetServiceProvider, and retrieve IUndoService from it.

C#
public static IUndoService GetUndoService(
    object obj
);
See Also
EcoServiceHelper Class
Eco.Services Namespace


EcoServiceHelper.GetVariableFactoryService Method

EcoServiceHelper.GetVariableFactoryService Method
EcoServiceHelper Class Eco.Services Namespace See Also
Collapse All

Get an IEcoServiceProvider using GetServiceProvider, and retrieve IVariableFactoryService from it.

C#
public static IVariableFactoryService GetVariableFactoryService(
    object obj
);
See Also
EcoServiceHelper Class
Eco.Services Namespace


EcoServiceHelper.GetVersionService Method

EcoServiceHelper.GetVersionService Method
EcoServiceHelper Class Eco.Services Namespace See Also
Collapse All

Get an IEcoServiceProvider using GetServiceProvider, and retrieve IVersionService from it.

C#
public static IVersionService GetVersionService(
    object obj
);
See Also
EcoServiceHelper Class
Eco.Services Namespace


EcoServiceHelper.SafeGetServiceProvider Method

EcoServiceHelper.SafeGetServiceProvider Method
EcoServiceHelper Class Eco.Services Namespace See Also
Collapse All

Check if obj is of a type that can be used to reach a IEcoServiceProvider and if so return it. If it can't reach an IEcoServiceProvider, it will return null.

C#
public static IEcoServiceProvider SafeGetServiceProvider(
    object obj
);
Parameters
Parameters | Description
obj | The object to retrieve an IEcoServiceProvider reference from.
See Also
EcoServiceHelper Class
Eco.Services Namespace


IActionLanguageServiceExtensions Class

IActionLanguageServiceExtensions Class
Inheritance Hierarchy See Also
Collapse All
C#
public static class IActionLanguageServiceExtensions;
Remarks

This is class Eco.Services.IActionLanguageServiceExtensions.

Inheritance Hierarchy
Eco.Services.IActionLanguageServiceExtensions
File

EcoExtenders.cs

See Also
Inheritance Hierarchy


IActionLanguageServiceExtensions Methods

IActionLanguageServiceExtensions Methods
Public Methods
Collapse All

The methods of the IActionLanguageServiceExtensions class are listed here.

Public Methods
Name | Description
Evaluate | This is the overview for the Evaluate method overload.
Execute | This is the overview for the Execute method overload.


Evaluate Method

Evaluate Method

This is the overview for the Evaluate method overload.

Overload List
Name | Description
IActionLanguageServiceExtensions.Evaluate (this IActionLanguageService, IEcoObject, string) | This is Evaluate, a member of class IActionLanguageServiceExtensions.
IActionLanguageServiceExtensions.Evaluate (this IActionLanguageService, IEcoObject, string, IExternalVariableList) | This is Evaluate, a member of class IActionLanguageServiceExtensions.


IActionLanguageServiceExtensions.Evaluate Method (this IActionLanguageService, IEcoObject, string)

IActionLanguageServiceExtensions.Evaluate Method (this IActionLanguageService, IEcoObject, string)
IActionLanguageServiceExtensions Class Eco.Services Namespace See Also
Collapse All
C#
public static IElement Evaluate(
    this IActionLanguageService service,
    IEcoObject root,
    string expression
);
Remarks

This is Evaluate, a member of class IActionLanguageServiceExtensions.

See Also
IActionLanguageServiceExtensions Class
Eco.Services Namespace


IActionLanguageServiceExtensions.Evaluate Method (this IActionLanguageService, IEcoObject, string, IExternalVariableList)

IActionLanguageServiceExtensions.Evaluate Method (this IActionLanguageService, IEcoObject, string, IExternalVariableList)
IActionLanguageServiceExtensions Class Eco.Services Namespace See Also
Collapse All
C#
public static IElement Evaluate(
    this IActionLanguageService service,
    IEcoObject root,
    string expression,
    IExternalVariableList variableList
);
Remarks

This is Evaluate, a member of class IActionLanguageServiceExtensions.

See Also
IActionLanguageServiceExtensions Class
Eco.Services Namespace


Execute Method

Execute Method

This is the overview for the Execute method overload.

Overload List
Name | Description
IActionLanguageServiceExtensions.Execute (this IActionLanguageService, IEcoObject, string) | This is Execute, a member of class IActionLanguageServiceExtensions.
IActionLanguageServiceExtensions.Execute (this IActionLanguageService, IEcoObject, string, IExternalVariableList) | This is Execute, a member of class IActionLanguageServiceExtensions.


IActionLanguageServiceExtensions.Execute Method (this IActionLanguageService, IEcoObject, string)

IActionLanguageServiceExtensions.Execute Method (this IActionLanguageService, IEcoObject, string)
IActionLanguageServiceExtensions Class Eco.Services Namespace See Also
Collapse All
C#
public static void Execute(
    this IActionLanguageService service,
    IEcoObject root,
    string expression
);
Remarks

This is Execute, a member of class IActionLanguageServiceExtensions.

See Also
IActionLanguageServiceExtensions Class
Eco.Services Namespace


IActionLanguageServiceExtensions.Execute Method (this IActionLanguageService, IEcoObject, string, IExternalVariableList)

IActionLanguageServiceExtensions.Execute Method (this IActionLanguageService, IEcoObject, string, IExternalVariableList)
IActionLanguageServiceExtensions Class Eco.Services Namespace See Also
Collapse All
C#
public static void Execute(
    this IActionLanguageService service,
    IEcoObject root,
    string expression,
    IExternalVariableList variableList
);
Remarks

This is Execute, a member of class IActionLanguageServiceExtensions.

See Also
IActionLanguageServiceExtensions Class
Eco.Services Namespace


IOclPsServiceExtensions Class

IOclPsServiceExtensions Class
Inheritance Hierarchy See Also
Collapse All
C#
public static class IOclPsServiceExtensions;
Remarks

This is class Eco.Services.IOclPsServiceExtensions.

Inheritance Hierarchy
Eco.Services.IOclPsServiceExtensions
File

EcoExtenders.cs

See Also
Inheritance Hierarchy


IOclPsServiceExtensions Methods

IOclPsServiceExtensions Methods
Public Methods
Collapse All

The methods of the IOclPsServiceExtensions class are listed here.

Public Methods
Name | Description
Execute | This is the overview for the Execute method overload.


Execute Method

Execute Method

This is the overview for the Execute method overload.

Overload List
Name | Description
IOclPsServiceExtensions.Execute (this IOclPsService, IEcoObject, string) | This is Execute, a member of class IOclPsServiceExtensions.
IOclPsServiceExtensions.Execute (this IOclPsService, IEcoObject, string, IExternalVariableList) | This is Execute, a member of class IOclPsServiceExtensions.
IOclPsServiceExtensions.Execute (this IOclPsService, IEcoObject, string, IExternalVariableList, int, int) | This is Execute, a member of class IOclPsServiceExtensions.


IOclPsServiceExtensions.Execute Method (this IOclPsService, IEcoObject, string)

IOclPsServiceExtensions.Execute Method (this IOclPsService, IEcoObject, string)
IOclPsServiceExtensions Class Eco.Services Namespace See Also
Collapse All
C#
public static IElement Execute(
    this IOclPsService service,
    IEcoObject root,
    string expression
);
Remarks

This is Execute, a member of class IOclPsServiceExtensions.

See Also
IOclPsServiceExtensions Class
Eco.Services Namespace


IOclPsServiceExtensions.Execute Method (this IOclPsService, IEcoObject, string, IExternalVariableList)

IOclPsServiceExtensions.Execute Method (this IOclPsService, IEcoObject, string, IExternalVariableList)
IOclPsServiceExtensions Class Eco.Services Namespace See Also
Collapse All
C#
public static IElement Execute(
    this IOclPsService service,
    IEcoObject root,
    string expression,
    IExternalVariableList variables
);
Remarks

This is Execute, a member of class IOclPsServiceExtensions.

See Also
IOclPsServiceExtensions Class
Eco.Services Namespace


IOclPsServiceExtensions.Execute Method (this IOclPsService, IEcoObject, string, IExternalVariableList, int, int)

IOclPsServiceExtensions.Execute Method (this IOclPsService, IEcoObject, string, IExternalVariableList, int, int)
IOclPsServiceExtensions Class Eco.Services Namespace See Also
Collapse All
C#
public static IElement Execute(
    this IOclPsService service,
    IEcoObject root,
    string expression,
    IExternalVariableList variables,
    int maxAnswers,
    int offset
);
Remarks

This is Execute, a member of class IOclPsServiceExtensions.

See Also
IOclPsServiceExtensions Class
Eco.Services Namespace


IOclServiceExtensions Class

IOclServiceExtensions Class
Inheritance Hierarchy See Also
Collapse All
C#
public static class IOclServiceExtensions;
Remarks

This is class Eco.Services.IOclServiceExtensions.

Inheritance Hierarchy
Eco.Services.IOclServiceExtensions
File

EcoExtenders.cs

See Also
Inheritance Hierarchy


IOclServiceExtensions Methods

IOclServiceExtensions Methods
Public Methods
Collapse All

The methods of the IOclServiceExtensions class are listed here.

Public Methods
Name | Description
Evaluate | This is the overview for the Evaluate method overload.


Evaluate Method

Evaluate Method

This is the overview for the Evaluate method overload.

Overload List
Name | Description
IOclServiceExtensions.Evaluate (this IOclService, IEcoObject, string) | This is Evaluate, a member of class IOclServiceExtensions.
IOclServiceExtensions.Evaluate (this IOclService, IEcoObject, string, IExternalVariableList) | This is Evaluate, a member of class IOclServiceExtensions.


IOclServiceExtensions.Evaluate Method (this IOclService, IEcoObject, string)

IOclServiceExtensions.Evaluate Method (this IOclService, IEcoObject, string)
IOclServiceExtensions Class Eco.Services Namespace See Also
Collapse All
C#
public static IElement Evaluate(
    this IOclService service,
    IEcoObject root,
    string expression
);
Remarks

This is Evaluate, a member of class IOclServiceExtensions.

See Also
IOclServiceExtensions Class
Eco.Services Namespace


IOclServiceExtensions.Evaluate Method (this IOclService, IEcoObject, string, IExternalVariableList)

IOclServiceExtensions.Evaluate Method (this IOclService, IEcoObject, string, IExternalVariableList)
IOclServiceExtensions Class Eco.Services Namespace See Also
Collapse All
C#
public static IElement Evaluate(
    this IOclService service,
    IEcoObject root,
    string expression,
    IExternalVariableList variables
);
Remarks

This is Evaluate, a member of class IOclServiceExtensions.

See Also
IOclServiceExtensions Class
Eco.Services Namespace


ObjectListHelper Class

ObjectListHelper Class
Inheritance Hierarchy See Also
Collapse All
C#
public sealed class ObjectListHelper;
Remarks

This is class Eco.Services.ObjectListHelper.

Inheritance Hierarchy
Eco.Services.ObjectListHelper
File

Services.cs

See Also
Inheritance Hierarchy


ObjectListHelper Methods

ObjectListHelper Methods
Public Methods
Collapse All

The methods of the ObjectListHelper class are listed here.

Public Methods
Name | Description
EnsureFetchedPage | This is EnsureFetchedPage, a member of class ObjectListHelper.


ObjectListHelper.EnsureFetchedPage Method

ObjectListHelper.EnsureFetchedPage Method
ObjectListHelper Class Eco.Services Namespace See Also
Collapse All
C#
public static void EnsureFetchedPage(
    IObjectList list,
    IObjectInstance obj,
    int index
);
Remarks

This is EnsureFetchedPage, a member of class ObjectListHelper.

See Also
ObjectListHelper Class
Eco.Services Namespace


OptimisticLockException Class

OptimisticLockException Class
Inheritance Hierarchy See Also
Collapse All

This Exception is thrown by IPersistenceService.UpdateDatabaseWithList if there is a optimistic locking conflict.

C#
public class OptimisticLockException : InvalidOperationException;
Inheritance Hierarchy
Eco.Services.OptimisticLockException
File

Services.cs

See Also
Inheritance Hierarchy


OptimisticLockException Constructor

OptimisticLockException Constructor

This is the overview for the OptimisticLockException constructor overload.

Overload List
Name | Description
OptimisticLockException.OptimisticLockException () | Creates a new instance of the exception.
OptimisticLockException.OptimisticLockException (SerializationInfo, StreamingContext) | Creates a new instance of the exception.
OptimisticLockException.OptimisticLockException (string) | Creates a new instance of the exception.
OptimisticLockException.OptimisticLockException (string, Exception) | Creates a new instance of the exception.


OptimisticLockException.OptimisticLockException Constructor ()

OptimisticLockException.OptimisticLockException Constructor ()
OptimisticLockException Class Eco.Services Namespace See Also
Collapse All

Creates a new instance of the exception.

C#
public OptimisticLockException();
protected OptimisticLockException(
    SerializationInfo info,
    StreamingContext context
);
See Also
OptimisticLockException Class
Eco.Services Namespace


OptimisticLockException.OptimisticLockException Constructor (string)

OptimisticLockException.OptimisticLockException Constructor (string)
OptimisticLockException Class Eco.Services Namespace See Also
Collapse All

Creates a new instance of the exception.

C#
public OptimisticLockException(
    string message
);
See Also
OptimisticLockException Class
Eco.Services Namespace


OptimisticLockException.OptimisticLockException Constructor (string, Exception)

OptimisticLockException.OptimisticLockException Constructor (string, Exception)
OptimisticLockException Class Eco.Services Namespace See Also
Collapse All

Creates a new instance of the exception.

C#
public OptimisticLockException(
    string message,
    Exception inner
);
See Also
OptimisticLockException Class
Eco.Services Namespace


PersistenceServiceExtensions Class

PersistenceServiceExtensions Class
Inheritance Hierarchy See Also
Collapse All
C#
public static class PersistenceServiceExtensions;
Remarks

This is class Eco.Services.PersistenceServiceExtensions.

Inheritance Hierarchy
Eco.Services.PersistenceServiceExtensions
File

EcoExtenders.cs

See Also
Inheritance Hierarchy


PersistenceServiceExtensions Methods

PersistenceServiceExtensions Methods
Public Methods
Collapse All

The methods of the PersistenceServiceExtensions class are listed here.

Public Methods
Name | Description
DiscardChanges | This method will mark the modified contents of this object in the local cache as invalid.
Unload | This method will mark the contents of this object in the local cache as invalid.
UpdateDatabase | Saves a single object to the persistent storage.


PersistenceServiceExtensions.DiscardChanges Method

PersistenceServiceExtensions.DiscardChanges Method
PersistenceServiceExtensions Class Eco.Services Namespace See Also
Collapse All

This method will mark the modified contents of this object in the local cache as invalid.

C#
public static void DiscardChanges(
    this IPersistenceService persistenceService,
    IEcoObject obj
);
Remarks

This method will only touch modified data. To get rid of unmodified data, use the Unload method. The object's contents will not be reloaded from the persistent storage unless the application attempts to read them. This is similar to the Dispose pattern except that only the objects' data is disposed, it is safe to hold references to the objects in the list and also to continue to read/write their contents.

See Also
PersistenceServiceExtensions Class
Eco.Services Namespace


PersistenceServiceExtensions.Unload Method

PersistenceServiceExtensions.Unload Method
PersistenceServiceExtensions Class Eco.Services Namespace See Also
Collapse All

This method will mark the contents of this object in the local cache as invalid.

C#
public static void Unload(
    this IPersistenceService persistenceService,
    IEcoObject obj
);
Remarks

This method will only unload unmodified objects. To get rid of modified objects, use the DiscardChanges method. The objects' contents will not be reloaded from the persistent storage unless the application attempts to read them. This is similar to the Dispose pattern except that only the objects' data is disposed, it is safe to hold references to the objects in the list and also to continue to read/write their contents.

See Also
PersistenceServiceExtensions Class
Eco.Services Namespace


PersistenceServiceExtensions.UpdateDatabase Method

PersistenceServiceExtensions.UpdateDatabase Method
PersistenceServiceExtensions Class Eco.Services Namespace Related Topics See Also
Collapse All

Saves a single object to the persistent storage.

C#
public static void UpdateDatabase(
    this IPersistenceService persistenceService,
    IEcoObject obj
);
Remarks

Instructs ECO to save all changes to a single object to the persistent storage. Before updating the persistent storage ECO will first ensure integrity is not comprimised by executing IPersistenceService.EnsureEnclosure.

Related Topics

IPersistenceService.EnsureEnclosure

See Also
PersistenceServiceExtensions Class
Eco.Services Namespace
Related Topics


IActionLanguageService Interface

IActionLanguageService Interface
Inheritance Hierarchy Related Topics See Also
Collapse All

This interface allows programmatic access to evaluating OCL expressions and performing modifications to the EcoSpace by executing commands.

C#
public interface IActionLanguageService : IActionLanguageTypeService;
Related Topics

IOclPsService, IOclService

Inheritance Hierarchy
Eco.Services.ITypeService
    Eco.Services.IActionLanguageTypeService
        Eco.Services.IActionLanguageService
File

Services.cs

See Also
Inheritance Hierarchy
Related Topics


IActionLanguageService Methods

IActionLanguageService Methods
Public Methods
Collapse All

The methods of the IActionLanguageService class are listed here.

Public Methods
Name | Description
Evaluate | This is the overview for the Evaluate method overload.
Execute | This is the overview for the Execute method overload.


Evaluate Method

Evaluate Method

This is the overview for the Evaluate method overload.

Overload List
Name | Description
IActionLanguageService.Evaluate (IElement, string) | Executes an OCL Action Language script in the context specified and returns a result.
IActionLanguageService.Evaluate (IElement, string, IExternalVariableList) | Executes an OCL Action Language script in the context specified and returns a result.
IActionLanguageService.Evaluate (string) | Executes an OCL Action Language script in the context of the EcoSpace and returns a result.
IActionLanguageService.Evaluate (string, IExternalVariableList) | Executes an OCL Action Language script in the context of the EcoSpace and returns a result.


IActionLanguageService.Evaluate Method (IElement, string)

IActionLanguageService.Evaluate Method (IElement, string)
IActionLanguageService Interface Eco.Services Namespace See Also
Collapse All

Executes an OCL Action Language script in the context specified and returns a result.

C#
IElement Evaluate(
    IElement root,
    string expression
);
Parameters
Parameters | Description
root | The context to use during execution.
expression | The OCL Action Language script to execute.
See Also
IActionLanguageService Interface
Eco.Services Namespace


IActionLanguageService.Evaluate Method (IElement, string, IExternalVariableList)

IActionLanguageService.Evaluate Method (IElement, string, IExternalVariableList)
IActionLanguageService Interface Eco.Services Namespace See Also
Collapse All

Executes an OCL Action Language script in the context specified and returns a result.

C#
IElement Evaluate(
    IElement root,
    string expression,
    IExternalVariableList variableList
);
Parameters
Parameters | Description
root | The context to use during execution.
expression | The OCL Action Language script to execute.
variableList | A list of variables to use when parsing the script.
See Also
IActionLanguageService Interface
Eco.Services Namespace


IActionLanguageService.Evaluate Method (string)

IActionLanguageService.Evaluate Method (string)
IActionLanguageService Interface Eco.Services Namespace See Also
Collapse All

Executes an OCL Action Language script in the context of the EcoSpace and returns a result.

C#
IElement Evaluate(
    string expression
);
Parameters
Parameters | Description
expression | The OCL Action Language script to execute.
See Also
IActionLanguageService Interface
Eco.Services Namespace


IActionLanguageService.Evaluate Method (string, IExternalVariableList)

IActionLanguageService.Evaluate Method (string, IExternalVariableList)
IActionLanguageService Interface Eco.Services Namespace See Also
Collapse All

Executes an OCL Action Language script in the context of the EcoSpace and returns a result.

C#
IElement Evaluate(
    string expression,
    IExternalVariableList variableList
);
Parameters
Parameters | Description
expression | The OCL Action Language script to execute.
variableList | A list of variables to use when parsing the script.
See Also
IActionLanguageService Interface
Eco.Services Namespace


Execute Method

Execute Method

This is the overview for the Execute method overload.

Overload List
Name | Description
IActionLanguageService.Execute (IElement, string) | Executes an OCL Action Language script in the context specified.
IActionLanguageService.Execute (IElement, string, IExternalVariableList) | Executes an OCL Action Language script in the context specified.
IActionLanguageService.Execute (string) | Executes an OCL Action Language script in the context of the EcoSpace.
IActionLanguageService.Execute (string, IExternalVariableList) | Executes an OCL Action Language script in the context of the EcoSpace.


IActionLanguageService.Execute Method (IElement, string)

IActionLanguageService.Execute Method (IElement, string)
IActionLanguageService Interface Eco.Services Namespace See Also
Collapse All

Executes an OCL Action Language script in the context specified.

C#
void Execute(
    IElement root,
    string expression
);
Parameters
Parameters | Description
root | The context to use during execution.
expression | The OCL Action Language script to execute.
See Also
IActionLanguageService Interface
Eco.Services Namespace


IActionLanguageService.Execute Method (IElement, string, IExternalVariableList)

IActionLanguageService.Execute Method (IElement, string, IExternalVariableList)
IActionLanguageService Interface Eco.Services Namespace See Also
Collapse All

Executes an OCL Action Language script in the context specified.

C#
void Execute(
    IElement root,
    string expression,
    IExternalVariableList variableList
);
Parameters
Parameters | Description
root | The context to use during execution.
expression | The OCL Action Language script to execute.
variableList | A list of variables to use when parsing the script.
See Also
IActionLanguageService Interface
Eco.Services Namespace


IActionLanguageService.Execute Method (string)

IActionLanguageService.Execute Method (string)
IActionLanguageService Interface Eco.Services Namespace See Also
Collapse All

Executes an OCL Action Language script in the context of the EcoSpace.

C#
void Execute(
    string expression
);
Parameters
Parameters | Description
expression | The OCL Action Language script to execute.
See Also
IActionLanguageService Interface
Eco.Services Namespace


IActionLanguageService.Execute Method (string, IExternalVariableList)

IActionLanguageService.Execute Method (string, IExternalVariableList)
IActionLanguageService Interface Eco.Services Namespace See Also
Collapse All

Executes an OCL Action Language script in the context of the EcoSpace.

C#
void Execute(
    string expression,
    IExternalVariableList variableList
);
Parameters
Parameters | Description
expression | The OCL Action Language script to execute.
variableList | A list of variables to use when parsing the script.
See Also
IActionLanguageService Interface
Eco.Services Namespace


IActionLanguageTypeService Interface

IActionLanguageTypeService Interface
Inheritance Hierarchy See Also
Collapse All

The methods of this interface performs static analysis of OCL expressions. This is mainly used during designtime to calculate static types of handles.

C#
public interface IActionLanguageTypeService : ITypeService;
Inheritance Hierarchy
Eco.Services.ITypeService
    Eco.Services.IActionLanguageTypeService
        Eco.Services.IActionLanguageService
File

Services.cs

See Also
Inheritance Hierarchy


IAutoSubscriptionContext Interface

IAutoSubscriptionContext Interface
Inheritance Hierarchy See Also
Collapse All
C#
public interface IAutoSubscriptionContext : IDisposable;
Remarks

This is class Eco.Services.IAutoSubscriptionContext.

Inheritance Hierarchy
Eco.Services.IAutoSubscriptionContext
File

Services.cs

See Also
Inheritance Hierarchy


IAutoSubscriptionContext Properties

IAutoSubscriptionContext Properties
Public Properties
Collapse All

The properties of the IAutoSubscriptionContext class are listed here.

Public Properties
Name | Description
Subscriber | This is Subscriber, a member of class IAutoSubscriptionContext.


IAutoSubscriptionContext.Subscriber Property

IAutoSubscriptionContext.Subscriber Property
IAutoSubscriptionContext Interface Eco.Services Namespace See Also
Collapse All
C#
ISubscriber Subscriber;
Remarks

This is Subscriber, a member of class IAutoSubscriptionContext.

See Also
IAutoSubscriptionContext Interface
Eco.Services Namespace


IAutoSubscriptionService Interface

IAutoSubscriptionService Interface
Inheritance Hierarchy See Also
Collapse All

Provides a way to automatically place subscriptions.

C#
public interface IAutoSubscriptionService;
Remarks

This service is used to automatically place subscriptions. It is used internally by Eco for autosubscribed derived members, but may also be used by the developer, e.g. for defining code-derived properties on ElementHandle or EcoDataSource. When an auto subscription is active, automatic subscriptions are placed in the following cases:

  • Reading the value of an element in the EcoSpace, i.e. an object, attribute, associationend.
  • Reading the value of a IElement obtained from the IVariableFactoryService of that EcoSpace. Since this service is used internally, this

includes any result of an OCL evaluations.

  • Reading the value of

A subscriber is registered to recieve the automatic subscriptions by calling IAutoSubscriptionService.StartSubscribe. The IAutoSubscriptionContext returnes by StartSubsribe implements IDisposable, and the autosubscription is ended by disposing this object. This allows for the folling use: FIXME format example, and use signature from event for deriving column for EcoDataSoure

Copy Code
public IElement dosubscribe(ISubscriber reevaluateSubsriber, ISubscriber resubscribeSubsriber.
{
       using (autosubscribeService.StartSubscribe(resubscribeSubsriber)
       {
           FIXME actual sample code
       }
}

The subscribers form a stack, where autosubscriptions are only placed for the top subsscriber in the stack.

Inheritance Hierarchy
Eco.Services.IAutoSubscriptionService
File

Services.cs

See Also
Inheritance Hierarchy


IAutoSubscriptionService Methods

IAutoSubscriptionService Methods
Public Methods
Collapse All

The methods of the IAutoSubscriptionService class are listed here.

Public Methods
Name | Description
StartSubscribe | Register a subscriber to recieve subscriptions.


IAutoSubscriptionService.StartSubscribe Method

IAutoSubscriptionService.StartSubscribe Method
IAutoSubscriptionService Interface Eco.Services Namespace See Also
Collapse All

Register a subscriber to recieve subscriptions.

C#
IAutoSubscriptionContext StartSubscribe(
    ISubscriber subscriber
);
Parameters
Parameters | Description
subscriber | The ISubscriber to register for automatic subscriptions.
Remarks

FIXME more or less repeat code an example from description of class.

See Also
IAutoSubscriptionService Interface
Eco.Services Namespace


IAutoSubscriptionService Properties

IAutoSubscriptionService Properties
Public Properties
Collapse All

The properties of the IAutoSubscriptionService class are listed here.

Public Properties
Name | Description
ActiveContext | This is ActiveContext, a member of class IAutoSubscriptionService.
ActiveSubscriber | This is ActiveSubscriber, a member of class IAutoSubscriptionService.


IAutoSubscriptionService.ActiveContext Property

IAutoSubscriptionService.ActiveContext Property
IAutoSubscriptionService Interface Eco.Services Namespace See Also
Collapse All
C#
IAutoSubscriptionContext ActiveContext;
Remarks

This is ActiveContext, a member of class IAutoSubscriptionService.

See Also
IAutoSubscriptionService Interface
Eco.Services Namespace


IAutoSubscriptionService.ActiveSubscriber Property

IAutoSubscriptionService.ActiveSubscriber Property
IAutoSubscriptionService Interface Eco.Services Namespace See Also
Collapse All
C#
ISubscriber ActiveSubscriber;
Remarks

This is ActiveSubscriber, a member of class IAutoSubscriptionService.

See Also
IAutoSubscriptionService Interface
Eco.Services Namespace


ICacheContentService Interface

ICacheContentService Interface
Inheritance Hierarchy See Also
Collapse All

Provides a way to inject data into the local EcoSpace cache.

C#
public interface ICacheContentService;
Remarks

This service allows the developer to inject data into the cache as if it had been fetched by ECO. This makes it simple to load data more efficiently using custom SQL queries performed directly on the database; or to retrieve data from external data sources such as web services, custom XML files, etc.

It will automatically handle the setting of persistence states and detecting conflicts with values that are already in the cache.

Setting a value via this service will automatically handle the correct setting of persistence states and also handle conflicts with values already in the local EcoSpace cache. When setting a value with this service the action taken will depend on the persistence state of the existing value:

  • Invalid: The cache will be updated immediately with the value specified.
  • Current, Modified: If the existing cache value is the same then nothing will happen, otherwise a conflict will be recorded as if it had occured in a multi-user scenario. The changes may be retrieved using IPersistenceService.GetChanges.

In addition to setting the new value, the CacheContentService will detect certain scenarios where a new value for a link can be in conflict with an already known value for another link.

In the C# examples folder, there is an example application (CacheContentService) that illustrates how to use this service to load data using custom sql queries and xml-files.

Inheritance Hierarchy
Eco.Services.ICacheContentService
File

Services.cs

See Also
Inheritance Hierarchy


ICacheContentService Methods

ICacheContentService Methods
Public Methods
Collapse All

The methods of the ICacheContentService class are listed here.

Public Methods
Name | Description
ApplyDatablock | Applies all the contents of the datablock to the cache
GetKey | Gets the primary key of an object.
GetObject | This is the overview for the GetObject method overload.
SetAttribute | This is the overview for the SetAttribute method overload.
SetExtentCurrent | This is the overview for the SetExtentCurrent method overload.
SetIndirectMultilink | This is the overview for the SetIndirectMultilink method overload.
SetIndirectSinglelink | This is the overview for the SetIndirectSinglelink method overload.
SetMultilink | This is the overview for the SetMultilink method overload.
SetMultilinkCurrent | This is the overview for the SetMultilinkCurrent method overload.
SetSinglelink | This is the overview for the SetSinglelink method overload.


ICacheContentService.ApplyDatablock Method

ICacheContentService.ApplyDatablock Method
ICacheContentService Interface Eco.Services Namespace See Also
Collapse All

Applies all the contents of the datablock to the cache

C#
void ApplyDatablock(
    Eco.DataRepresentation.Datablock datablock
);
Parameters
Parameters | Description
datablock | The data that should be injected into the cache.
See Also
ICacheContentService Interface
Eco.Services Namespace


ICacheContentService.GetKey Method

ICacheContentService.GetKey Method
ICacheContentService Interface Eco.Services Namespace See Also
Collapse All

Gets the primary key of an object.

C#
object GetKey(
    IObject obj
);
Parameters
Parameters | Description
obj | The object to return a primary key for.
See Also
ICacheContentService Interface
Eco.Services Namespace


GetObject Method

GetObject Method

This is the overview for the GetObject method overload.

Overload List
Name | Description
ICacheContentService.GetObject (object) | Registers a known object in the cache by its primary key in the data store.
ICacheContentService.GetObject (object, IClass) | Registers a known object in the cache by its primary key in the data store.
ICacheContentService.GetObject (object, string) | Registers a known object in the cache by its primary key in the data store.
ICacheContentService.GetObject (object, Type) | Registers a known object in the cache by its primary key in the data store.


ICacheContentService.GetObject Method (object)

ICacheContentService.GetObject Method (object)
ICacheContentService Interface Eco.Services Namespace See Also
Collapse All

Registers a known object in the cache by its primary key in the data store.

C#
T GetObject<T>(
    object key
) where T : class;
Parameters
Parameters | Description
key | The primary key of the object.
Returns

A reference to the object with the specified type

Remarks

No check is made to ensure that the object actually exists in the data store, nor is any checking done to ensure it is of the correct type. The contents of the object is not automatically fetched from the database. The class of the object to find.

See Also
ICacheContentService Interface
Eco.Services Namespace


ICacheContentService.GetObject Method (object, IClass)

ICacheContentService.GetObject Method (object, IClass)
ICacheContentService Interface Eco.Services Namespace See Also
Collapse All

Registers a known object in the cache by its primary key in the data store.

C#
IObjectInstance GetObject(
    object key,
    IClass c
);
Parameters
Parameters | Description
key | The primary key of the object.
c | The class of the object to find.
Remarks

No check is made to ensure that the object actually exists in the data store, nor is any checking done to ensure it is of the correct type.

See Also
ICacheContentService Interface
Eco.Services Namespace


ICacheContentService.GetObject Method (object, Type)

ICacheContentService.GetObject Method (object, Type)
ICacheContentService Interface Eco.Services Namespace See Also
Collapse All

Registers a known object in the cache by its primary key in the data store.

C#
IObjectInstance GetObject(
    object key,
    Type t
);
Parameters
Parameters | Description
key | The primary key of the object.
t | The class of the object to find.
Remarks

No check is made to ensure that the object actually exists in the data store, nor is any checking done to ensure it is of the correct type.

See Also
ICacheContentService Interface
Eco.Services Namespace


ICacheContentService.GetObject Method (object, string)

ICacheContentService.GetObject Method (object, string)
ICacheContentService Interface Eco.Services Namespace See Also
Collapse All

Registers a known object in the cache by its primary key in the data store.

C#
IObjectInstance GetObject(
    object key,
    string className
);
Parameters
Parameters | Description
key | The primary key of the object.
className | The name of the class of the object to find.
Returns

A reference to the IObjectInstance interface for the object

Remarks

No check is made to ensure that the object actually exists in the data store, nor is any checking done to ensure it is of the correct type. The contents of the object is not automatically fetched from the database.

See Also
ICacheContentService Interface
Eco.Services Namespace


SetAttribute Method

SetAttribute Method

This is the overview for the SetAttribute method overload.

Overload List
Name | Description
ICacheContentService.SetAttribute (IObject, IAttribute, object) | Sets the value of an attribute in the cache as if it had been fetched.
ICacheContentService.SetAttribute (IObject, int, object) | Sets the value of an attribute in the cache as if it had been fetched.
ICacheContentService.SetAttribute (IObject, string, object) | Sets the value of an attribute in the cache as if it had been fetched.


ICacheContentService.SetAttribute Method (IObject, IAttribute, object)

ICacheContentService.SetAttribute Method (IObject, IAttribute, object)
ICacheContentService Interface Eco.Services Namespace See Also
Collapse All

Sets the value of an attribute in the cache as if it had been fetched.

C#
void SetAttribute(
    IObject obj,
    IAttribute attribute,
    object value
);
Parameters
Parameters | Description
obj | The object to which the cached value belongs.
attribute | The UML attribute of the object to set the cached value for.
value | The value to set in the cache.
See Also
ICacheContentService Interface
Eco.Services Namespace


ICacheContentService.SetAttribute Method (IObject, int, object)

ICacheContentService.SetAttribute Method (IObject, int, object)
ICacheContentService Interface Eco.Services Namespace See Also
Collapse All

Sets the value of an attribute in the cache as if it had been fetched.

C#
void SetAttribute(
    IObject obj,
    int loopbackIndex,
    object value
);
Parameters
Parameters | Description
obj | The object to which the cached value belongs.
loopbackIndex | The loopback index of the object's attribute to set the cached value for.
value | The value to set in the cache.
See Also
ICacheContentService Interface
Eco.Services Namespace


ICacheContentService.SetAttribute Method (IObject, string, object)

ICacheContentService.SetAttribute Method (IObject, string, object)
ICacheContentService Interface Eco.Services Namespace See Also
Collapse All

Sets the value of an attribute in the cache as if it had been fetched.

C#
void SetAttribute(
    IObject obj,
    string attributeName,
    object value
);
Parameters
Parameters | Description
obj | The object to which the cached value belongs.
attributeName | The name of the object's attribute to set the cached value for.
value | The value to set in the cache.
See Also
ICacheContentService Interface
Eco.Services Namespace


SetExtentCurrent Method

SetExtentCurrent Method

This is the overview for the SetExtentCurrent method overload.

Overload List
Name | Description
ICacheContentService.SetExtentCurrent (IClass) | This method can be used if all objects of a class (including all of its subclasses) has been loaded into the cache.
ICacheContentService.SetExtentCurrent (string) | This method can be used if all objects of a class (including all of its subclasses) has been loaded into the cache.
ICacheContentService.SetExtentCurrent (Type) | This method can be used if all objects of a class (including all of its subclasses) has been loaded into the cache.


ICacheContentService.SetExtentCurrent Method (IClass)

ICacheContentService.SetExtentCurrent Method (IClass)
ICacheContentService Interface Eco.Services Namespace See Also
Collapse All

This method can be used if all objects of a class (including all of its subclasses) has been loaded into the cache.

C#
void SetExtentCurrent(
    IClass c
);
Parameters
Parameters | Description
c | The UML class to mark as current in the IExtentService.
Remarks

Informing the cache that the extent is current will prevent the cache from trying to fetch it the next time it is accessed.

See Also
ICacheContentService Interface
Eco.Services Namespace


ICacheContentService.SetExtentCurrent Method (Type)

ICacheContentService.SetExtentCurrent Method (Type)
ICacheContentService Interface Eco.Services Namespace See Also
Collapse All

This method can be used if all objects of a class (including all of its subclasses) has been loaded into the cache.

C#
void SetExtentCurrent(
    Type t
);
Parameters
Parameters | Description
t | The .NET type used to determine the UML class to mark as current in the IExtentService.
Remarks

Informing the cache that the extent is current will prevent the cache from trying to fetch it the next time it is accessed.

See Also
ICacheContentService Interface
Eco.Services Namespace


ICacheContentService.SetExtentCurrent Method (string)

ICacheContentService.SetExtentCurrent Method (string)
ICacheContentService Interface Eco.Services Namespace See Also
Collapse All

This method can be used if all objects of a class (including all of its subclasses) has been loaded into the cache.

C#
void SetExtentCurrent(
    string className
);
Parameters
Parameters | Description
className | The modeled name of the UML class to mark as current in the IExtentService.
Remarks

Informing the cache that the extent is current will prevent the cache from trying to fetch it the next time it is accessed.

See Also
ICacheContentService Interface
Eco.Services Namespace


SetIndirectMultilink Method

SetIndirectMultilink Method

This is the overview for the SetIndirectMultilink method overload.

Overload List
Name | Description
ICacheContentService.SetIndirectMultilink (IObject, IAssociationEnd, IEnumerable) | Sets the value of an indirect multilink (a link with link-class).
ICacheContentService.SetIndirectMultilink (IObject, int, IEnumerable) | Sets the value of an indirect multilink (a link with link-class).
ICacheContentService.SetIndirectMultilink (IObject, string, IEnumerable) | Sets the value of an indirect multilink (a link with link-class).


ICacheContentService.SetIndirectMultilink Method (IObject, IAssociationEnd, IEnumerable)

ICacheContentService.SetIndirectMultilink Method (IObject, IAssociationEnd, IEnumerable)
ICacheContentService Interface Eco.Services Namespace See Also
Collapse All

Sets the value of an indirect multilink (a link with link-class).

C#
void SetIndirectMultilink(
    IObject obj,
    IAssociationEnd assocEnd,
    IEnumerable value
);
Parameters
Parameters | Description
obj | The object to which the cached value belongs.
assocEnd | The association end to set the value for.
value | The list of IObjectPair to set in the cache.
Remarks

Indirect multilinks consists of a collection of pairs of objects. In each pair, the first object is a link-object, and the second object is the "real" object on the other end.

See Also
ICacheContentService Interface
Eco.Services Namespace


ICacheContentService.SetIndirectMultilink Method (IObject, int, IEnumerable)

ICacheContentService.SetIndirectMultilink Method (IObject, int, IEnumerable)
ICacheContentService Interface Eco.Services Namespace See Also
Collapse All

Sets the value of an indirect multilink (a link with link-class).

C#
void SetIndirectMultilink(
    IObject obj,
    int loopbackIndex,
    IEnumerable value
);
Parameters
Parameters | Description
obj | The object to which the cached value belongs.
loopbackIndex | The loopback index of the association end to set the value for.
value | The list of IObjectPair to set in the cache.
Remarks

Indirect multilinks consists of a collection of pairs of objects. In each pair, the first object is a link-object, and the second object is the "real" object on the other end.

See Also
ICacheContentService Interface
Eco.Services Namespace


ICacheContentService.SetIndirectMultilink Method (IObject, string, IEnumerable)

ICacheContentService.SetIndirectMultilink Method (IObject, string, IEnumerable)
ICacheContentService Interface Eco.Services Namespace See Also
Collapse All

Sets the value of an indirect multilink (a link with link-class).

C#
void SetIndirectMultilink(
    IObject obj,
    string assocEndName,
    IEnumerable value
);
Parameters
Parameters | Description
obj | The object to which the cached value belongs.
assocEndName | The name of the association end to set the value for.
value | The list of IObjectPair to set in the cache.
Remarks

Indirect multilinks consists of a collection of pairs of objects. In each pair, the first object is a link-object, and the second object is the "real" object on the other end.

See Also
ICacheContentService Interface
Eco.Services Namespace


SetIndirectSinglelink Method

SetIndirectSinglelink Method

This is the overview for the SetIndirectSinglelink method overload.

Overload List
Name | Description
ICacheContentService.SetIndirectSinglelink (IObject, IAssociationEnd, IObjectPair) | Sets the value of an indirect singlelink (a link with link-class).
ICacheContentService.SetIndirectSinglelink (IObject, int, IObjectPair) | Sets the value of an indirect singlelink (a link with link-class).
ICacheContentService.SetIndirectSinglelink (IObject, string, IObjectPair) | Sets the value of an indirect singlelink (a link with link-class).


ICacheContentService.SetIndirectSinglelink Method (IObject, IAssociationEnd, IObjectPair)

ICacheContentService.SetIndirectSinglelink Method (IObject, IAssociationEnd, IObjectPair)
ICacheContentService Interface Eco.Services Namespace See Also
Collapse All

Sets the value of an indirect singlelink (a link with link-class).

C#
void SetIndirectSinglelink(
    IObject obj,
    IAssociationEnd assocEnd,
    IObjectPair value
);
Parameters
Parameters | Description
obj | The object to which the cached value belongs.
assocEnd | The association end to set the value for.
value | The IObjectPair to set in the cache.
Remarks

Indirect singlelinks consists of a pair of objects. The first object is a link-object, and the second object is the "real" object on the other end.

See Also
ICacheContentService Interface
Eco.Services Namespace


ICacheContentService.SetIndirectSinglelink Method (IObject, int, IObjectPair)

ICacheContentService.SetIndirectSinglelink Method (IObject, int, IObjectPair)
ICacheContentService Interface Eco.Services Namespace See Also
Collapse All

Sets the value of an indirect singlelink (a link with link-class).

C#
void SetIndirectSinglelink(
    IObject obj,
    int loopbackIndex,
    IObjectPair value
);
Parameters
Parameters | Description
obj | The object to which the cached value belongs.
loopbackIndex | The loopback index of the association end to set the value for.
value | The IObjectPair to set in the cache.
Remarks

Indirect singlelinks consists of a pair of objects. The first object is a link-object, and the second object is the "real" object on the other end.

See Also
ICacheContentService Interface
Eco.Services Namespace


ICacheContentService.SetIndirectSinglelink Method (IObject, string, IObjectPair)

ICacheContentService.SetIndirectSinglelink Method (IObject, string, IObjectPair)
ICacheContentService Interface Eco.Services Namespace See Also
Collapse All

Sets the value of an indirect singlelink (a link with link-class).

C#
void SetIndirectSinglelink(
    IObject obj,
    string assocEndName,
    IObjectPair value
);
Parameters
Parameters | Description
obj | The object to which the cached value belongs.
assocEndName | The name of the association end to set the value for.
value | The IObjectPair to set in the cache.
Remarks

Indirect singlelinks consists of a pair of objects. The first object is a link-object, and the second object is the "real" object on the other end.

See Also
ICacheContentService Interface
Eco.Services Namespace


SetMultilink Method

SetMultilink Method

This is the overview for the SetMultilink method overload.

Overload List
Name | Description
ICacheContentService.SetMultilink (IObject, IAssociationEnd, IEnumerable) | Sets the value of a multi-role association.
ICacheContentService.SetMultilink (IObject, int, IEnumerable) | Sets the value of a multi-role association.
ICacheContentService.SetMultilink (IObject, string, IEnumerable) | Sets the value of a multi-role association.


ICacheContentService.SetMultilink Method (IObject, IAssociationEnd, IEnumerable)

ICacheContentService.SetMultilink Method (IObject, IAssociationEnd, IEnumerable)
ICacheContentService Interface Eco.Services Namespace See Also
Collapse All

Sets the value of a multi-role association.

C#
void SetMultilink(
    IObject obj,
    IAssociationEnd assocEnd,
    IEnumerable value
);
Parameters
Parameters | Description
obj | The object to which the cached value belongs.
assocEnd | The association end to set the value for.
value | The list of objects to set in the cache.
See Also
ICacheContentService Interface
Eco.Services Namespace


ICacheContentService.SetMultilink Method (IObject, int, IEnumerable)

ICacheContentService.SetMultilink Method (IObject, int, IEnumerable)
ICacheContentService Interface Eco.Services Namespace See Also
Collapse All

Sets the value of a multi-role association.

C#
void SetMultilink(
    IObject obj,
    int loopbackIndex,
    IEnumerable value
);
Parameters
Parameters | Description
obj | The object to which the cached value belongs.
loopbackIndex | The loopback index of the association end to set the value for.
value | The list of objects to set in the cache.
See Also
ICacheContentService Interface
Eco.Services Namespace


ICacheContentService.SetMultilink Method (IObject, string, IEnumerable)

ICacheContentService.SetMultilink Method (IObject, string, IEnumerable)
ICacheContentService Interface Eco.Services Namespace See Also
Collapse All

Sets the value of a multi-role association.

C#
void SetMultilink(
    IObject obj,
    string assocEndName,
    IEnumerable value
);
Parameters
Parameters | Description
obj | The object to which the cached value belongs.
assocEndName | The name of the association end to set the value for.
value | The list of objects to set in the cache.
See Also
ICacheContentService Interface
Eco.Services Namespace


SetMultilinkCurrent Method

SetMultilinkCurrent Method

This is the overview for the SetMultilinkCurrent method overload.

Overload List
Name | Description
ICacheContentService.SetMultilinkCurrent (IObject, IAssociationEnd) | Marks a link as "already loaded" so no attempt will be made to fetch it.
ICacheContentService.SetMultilinkCurrent (IObject, int) | Marks a link as "already loaded" so no attempt will be made to fetch it.
ICacheContentService.SetMultilinkCurrent (IObject, string) | Marks a link as "already loaded" so no attempt will be made to fetch it.


ICacheContentService.SetMultilinkCurrent Method (IObject, IAssociationEnd)

ICacheContentService.SetMultilinkCurrent Method (IObject, IAssociationEnd)
ICacheContentService Interface Eco.Services Namespace See Also
Collapse All

Marks a link as "already loaded" so no attempt will be made to fetch it.

C#
void SetMultilinkCurrent(
    IObject obj,
    IAssociationEnd assocEnd
);
Parameters
Parameters | Description
obj | The object to which the cached value belongs.
assocEnd | The association end to mark as current.
Remarks

This method can be used if all of the singlelinks that make up the other end of a particular multilink is known to be loaded into the cache.

Informing the cache that the multilink is current will prevent the cache from trying to fetch it the next time it is accessed.

See Also
ICacheContentService Interface
Eco.Services Namespace


ICacheContentService.SetMultilinkCurrent Method (IObject, int)

ICacheContentService.SetMultilinkCurrent Method (IObject, int)
ICacheContentService Interface Eco.Services Namespace See Also
Collapse All

Marks a link as "already loaded" so no attempt will be made to fetch it.

C#
void SetMultilinkCurrent(
    IObject obj,
    int loopbackIndex
);
Parameters
Parameters | Description
obj | The object to which the cached value belongs.
loopbackIndex | The loopback index of the association end to mark as current.
Remarks

This method can be used if all of the singlelinks that make up the other end of a particular multilink is known to be loaded into the cache.

Informing the cache that the multilink is current will prevent the cache from trying to fetch it the next time it is accessed.

See Also
ICacheContentService Interface
Eco.Services Namespace


ICacheContentService.SetMultilinkCurrent Method (IObject, string)

ICacheContentService.SetMultilinkCurrent Method (IObject, string)
ICacheContentService Interface Eco.Services Namespace See Also
Collapse All

Marks a link as "already loaded" so no attempt will be made to fetch it.

C#
void SetMultilinkCurrent(
    IObject obj,
    string assocEndName
);
Parameters
Parameters | Description
obj | The object to which the cached value belongs.
assocEndName | The name of the association end to mark as current.
Remarks

This method can be used if all of the singlelinks that make up the other end of a particular multilink is known to be loaded into the cache.

Informing the cache that the multilink is current will prevent the cache from trying to fetch it the next time it is accessed.

See Also
ICacheContentService Interface
Eco.Services Namespace


SetSinglelink Method

SetSinglelink Method

This is the overview for the SetSinglelink method overload.

Overload List
Name | Description
ICacheContentService.SetSinglelink (IObject, IAssociationEnd, IObject, int) | Sets the value of a single-role association end (both embedded an non-embedded).
ICacheContentService.SetSinglelink (IObject, int, IObject, int) | Sets the value of a single-role association end (both embedded an non-embedded).
ICacheContentService.SetSinglelink (IObject, string, IObject, int) | Sets the value of a single-role association end (both embedded an non-embedded).


ICacheContentService.SetSinglelink Method (IObject, IAssociationEnd, IObject, int)

ICacheContentService.SetSinglelink Method (IObject, IAssociationEnd, IObject, int)
ICacheContentService Interface Eco.Services Namespace See Also
Collapse All

Sets the value of a single-role association end (both embedded an non-embedded).

C#
void SetSinglelink(
    IObject obj,
    IAssociationEnd assocEnd,
    IObject value,
    int orderNo
);
Parameters
Parameters | Description
obj | The object to which the cached value belongs.
assocEnd | The association end to set the value for.
value | The value to set in the cache.
orderNo | If the opposite association end is ordered, this will specify which index position to use for the opposite end.
See Also
ICacheContentService Interface
Eco.Services Namespace


ICacheContentService.SetSinglelink Method (IObject, int, IObject, int)

ICacheContentService.SetSinglelink Method (IObject, int, IObject, int)
ICacheContentService Interface Eco.Services Namespace See Also
Collapse All

Sets the value of a single-role association end (both embedded an non-embedded).

C#
void SetSinglelink(
    IObject obj,
    int loopbackIndex,
    IObject value,
    int orderNo
);
Parameters
Parameters | Description
obj | The object to which the cached value belongs.
loopbackIndex | The loopback index of the association end to set the value for.
value | The value to set in the cache.
orderNo | If the opposite association end is ordered, this will specify which index position to use for the opposite end.
See Also
ICacheContentService Interface
Eco.Services Namespace


ICacheContentService.SetSinglelink Method (IObject, string, IObject, int)

ICacheContentService.SetSinglelink Method (IObject, string, IObject, int)
ICacheContentService Interface Eco.Services Namespace See Also
Collapse All

Sets the value of a single-role association end (both embedded an non-embedded).

C#
void SetSinglelink(
    IObject obj,
    string assocEndName,
    IObject value,
    int orderNo
);
Parameters
Parameters | Description
obj | The object to which the cached value belongs.
assocEndName | The name of the association end to set the value for.
value | The value to set in the cache.
orderNo | If the opposite association end is ordered, this will specify which index position to use for the opposite end.
See Also
ICacheContentService Interface
Eco.Services Namespace


IChange Interface

IChange Interface
Inheritance Hierarchy See Also
Collapse All

Holds information about a change conflict.

C#
public interface IChange;
Remarks

A "change" represents knowledge about discrepancies between an EcoSpace and its persistent storage. A change can be created as a result of a call to a change handler, or an optimistic locking failure. Not all changes means that there is a conflict between changes in the EcoSpace and the database

Inheritance Hierarchy
Eco.Services.IChange
File

Services.cs

See Also
Inheritance Hierarchy


IChange Methods

IChange Methods
Public Methods
Collapse All

The methods of the IChange class are listed here.

Public Methods
Name | Description
Apply | Call this to execute the action specified by the Action property.


IChange.Apply Method

IChange.Apply Method
IChange Interface Eco.Services Namespace See Also
Collapse All

Call this to execute the action specified by the Action property.

C#
void Apply();
See Also
IChange Interface
Eco.Services Namespace


IChange Properties

IChange Properties
Public Properties
Collapse All

The properties of the IChange class are listed here.

Public Properties
Name | Description
Action | The action to take for this change conflict.
Applied | Indicates whether this change has been applied or not.
ChangedElement | This is the element that has been changed in the database.
ChangedElementType | This is the type of the object that has been changed in the database.
IsDirectConflict | Indicates whether or not the change is in direct conflict.
Kind | The Kind explains what kind of change this Change element represents.


IChange.Action Property

IChange.Action Property
IChange Interface Eco.Services Namespace See Also
Collapse All

The action to take for this change conflict.

C#
ChangeActionKind Action;
Remarks

This property controls what happens when the Apply-method is called. Default value is Undecided.

See Also
IChange Interface
Eco.Services Namespace


IChange.Applied Property

IChange.Applied Property
IChange Interface Eco.Services Namespace See Also
Collapse All

Indicates whether this change has been applied or not.

C#
bool Applied;
See Also
IChange Interface
Eco.Services Namespace


IChange.ChangedElement Property

IChange.ChangedElement Property
IChange Interface Eco.Services Namespace See Also
Collapse All

This is the element that has been changed in the database.

C#
IElement ChangedElement;
See Also
IChange Interface
Eco.Services Namespace


IChange.ChangedElementType Property

IChange.ChangedElementType Property
IChange Interface Eco.Services Namespace See Also
Collapse All

This is the type of the object that has been changed in the database.

C#
IClass ChangedElementType;
Remarks

If the element that has changed is a member (attribute or role), this will be the type of the owning object.

See Also
IChange Interface
Eco.Services Namespace


IChange.IsDirectConflict Property

IChange.IsDirectConflict Property
IChange Interface Eco.Services Namespace See Also
Collapse All

Indicates whether or not the change is in direct conflict.

C#
bool IsDirectConflict;
Remarks

If this property is true, that means that the element refered to be ChangedElement has been changed in both the EcoSpace and the persistent storage. Some kind of conflict resolution has to be applied.

See Also
IChange Interface
Eco.Services Namespace


IChange.Kind Property

IChange.Kind Property
IChange Interface Eco.Services Namespace See Also
Collapse All

The Kind explains what kind of change this Change element represents.

C#
ChangeKind Kind;
See Also
IChange Interface
Eco.Services Namespace


IDirtyListService Interface

IDirtyListService Interface
Inheritance Hierarchy See Also
Collapse All

This service provides information about modifications made to objects in the local cache.

C#
public interface IDirtyListService;
Remarks

This information is used by ECO to determine which objects need to be updated to the persistent storage. This includes new objects, deleted objects, and modified objects.

Only persistent objects may be considered to be "dirty".

Inheritance Hierarchy
Eco.Services.IDirtyListService
File

Services.cs

See Also
Inheritance Hierarchy


IDirtyListService Methods

IDirtyListService Methods
Public Methods
Collapse All

The methods of the IDirtyListService class are listed here.

Public Methods
Name | Description
AllDirtyObjects | Returns a list of all new, deleted, and modified objects.
HasDirtyObjects | Returns true AllDirtyObjects.Count <> 0.
Subscribe | This methods registers a subscriber and executes it whenever an object is added to or removed from the list of modified objects.


IDirtyListService.AllDirtyObjects Method

IDirtyListService.AllDirtyObjects Method
IDirtyListService Interface Eco.Services Namespace See Also
Collapse All

Returns a list of all new, deleted, and modified objects.

C#
IObjectList AllDirtyObjects();
See Also
IDirtyListService Interface
Eco.Services Namespace


IDirtyListService.HasDirtyObjects Method

IDirtyListService.HasDirtyObjects Method
IDirtyListService Interface Eco.Services Namespace See Also
Collapse All

Returns true AllDirtyObjects.Count <> 0.

C#
bool HasDirtyObjects();
See Also
IDirtyListService Interface
Eco.Services Namespace


IDirtyListService.Subscribe Method

IDirtyListService.Subscribe Method
IDirtyListService Interface Eco.Services Namespace See Also
Collapse All

This methods registers a subscriber and executes it whenever an object is added to or removed from the list of modified objects.

C#
void Subscribe(
    ISubscriber subscriber
);
See Also
IDirtyListService Interface
Eco.Services Namespace


IDirtyListService Events

IDirtyListService Events
Public Events
Collapse All

The events of the IDirtyListService class are listed here.

Public Events
Name | Description
DirtyListChanged | Occurs whenever an object is added to or removed from the list of modified objects..


IDirtyListService.DirtyListChanged Event

IDirtyListService.DirtyListChanged Event
IDirtyListService Interface Eco.Services Namespace See Also
Collapse All

Occurs whenever an object is added to or removed from the list of modified objects..

C#
event EventHandler DirtyListChanged;
See Also
IDirtyListService Interface
Eco.Services Namespace


IExtentService Interface

IExtentService Interface
Inheritance Hierarchy See Also
Collapse All

Allows you to query the EcoSpace for all a list of all instances of a class, including instances of all subclasses.

C#
public interface IExtentService;
Remarks

The Extent Service only holds the ID of all instances for each class. It does not fetch the object data itself, object data is only fetched from the persistent storage when an attempt is made to read it.

Once a list of all object ID's for a specific class has been fetched from the persistent storage it will not be fetched again. The class's list will only be modified as a result of one of the following:

  • Unload is executed.
  • An IChange notification with a ChangeKind of ObjectAdded or ObjectDeleted is applied using the IPersistenceService.
  • The application creates a new object instance or deletes an existing object instance.
  • Object ID's become known due to navigating through associations.
  • Object ID's become known as a result of evaluating OCL expressions directly in the persistent storage (i.e. OCL as SQL) using IOclPsService.Execute(string).
Inheritance Hierarchy
Eco.Services.IExtentService
File

Services.cs

See Also
Inheritance Hierarchy


IExtentService Methods

IExtentService Methods
Public Methods
Collapse All

The methods of the IExtentService class are listed here.

Public Methods
Name | Description
AllInstances | This is the overview for the AllInstances method overload.
AllLoadedInstances | This is the overview for the AllLoadedInstances method overload.
SubscribeToObjectAdded | This is the overview for the SubscribeToObjectAdded method overload.
SubscribeToObjectRemoved | This is the overview for the SubscribeToObjectRemoved method overload.
Unload | This will free the memory used for storing the list of known objects of a specific class.


AllInstances Method

AllInstances Method

This is the overview for the AllInstances method overload.

Overload List
Name | Description
IExtentService.AllInstances () | Gets a strongly typed list of all known objects in the persistent storage of the specified class.
IExtentService.AllInstances (IClass) | Gets a list of all known objects in the persistent storage of the specified class.
IExtentService.AllInstances (string) | Gets a list of all known objects in the persistent storage of the specified class.
IExtentService.AllInstances (System.Type) | Gets a list of all known objects in the persistent storage of the specified class.


IExtentService.AllInstances Method ()

IExtentService.AllInstances Method ()
IExtentService Interface Eco.Services Namespace See Also
Collapse All

Gets a strongly typed list of all known objects in the persistent storage of the specified class.

C#
Eco.ObjectImplementation.IEcoList<T> AllInstances<T>() where T : class, IEcoObject;
Remarks

Returns the list of all objects of the specified class (including subclasses). If the list has not previously been fetched from the persistent storage it will be fetched.

See Also
IExtentService Interface
Eco.Services Namespace


IExtentService.AllInstances Method (IClass)

IExtentService.AllInstances Method (IClass)
IExtentService Interface Eco.Services Namespace See Also
Collapse All

Gets a list of all known objects in the persistent storage of the specified class.

C#
IObjectList AllInstances(
    IClass c
);
Parameters
Parameters | Description
c | The modeled UML class to retrieve a list for.
Remarks

Returns the list of all objects of the specified class (including subclasses). If the list has not previously been fetched from the persistent storage it will be fetched.

See Also
IExtentService Interface
Eco.Services Namespace


IExtentService.AllInstances Method (System.Type)

IExtentService.AllInstances Method (System.Type)
IExtentService Interface Eco.Services Namespace See Also
Collapse All

Gets a list of all known objects in the persistent storage of the specified class.

C#
IObjectList AllInstances(
    System.Type t
);
Parameters
Parameters | Description
t | The .NET class that will be used to determine the modeled UML class to retrieve a list for.
Remarks

Returns the list of all objects of the specified class (including subclasses). If the list has not previously been fetched from the persistent storage it will be fetched.

See Also
IExtentService Interface
Eco.Services Namespace


IExtentService.AllInstances Method (string)

IExtentService.AllInstances Method (string)
IExtentService Interface Eco.Services Namespace See Also
Collapse All

Gets a list of all known objects in the persistent storage of the specified class.

C#
IObjectList AllInstances(
    string className
);
Parameters
Parameters | Description
className | The name of the modeled UML class to retrieve a list for.
Remarks

Returns the list of all objects of the specified class (including subclasses). If the list has not previously been fetched from the persistent storage it will be fetched.

See Also
IExtentService Interface
Eco.Services Namespace


AllLoadedInstances Method

AllLoadedInstances Method

This is the overview for the AllLoadedInstances method overload.

Overload List
Name | Description
IExtentService.AllLoadedInstances () | Gets a strongly typed list of all known objects in the local EcoSpace cache of the specified class.
IExtentService.AllLoadedInstances (IClass) | Gets a list of all known objects in the local EcoSpace cache of the specified class.
IExtentService.AllLoadedInstances (string) | Gets a list of all known objects in the local EcoSpace cache of the specified class.
IExtentService.AllLoadedInstances (System.Type) | Gets a list of all known objects in the local EcoSpace cache of the specified class.


IExtentService.AllLoadedInstances Method ()

IExtentService.AllLoadedInstances Method ()
IExtentService Interface Eco.Services Namespace See Also
Collapse All

Gets a strongly typed list of all known objects in the local EcoSpace cache of the specified class.

C#
Eco.ObjectImplementation.IEcoList<T> AllLoadedInstances<T>() where T : class, IEcoObject;
Remarks

The same as AllInstances(IClass) except it will not fetch any information from the persistent storage. If the extent list for the specified class has not yet been fetched this list will contain a list of ID's only for new objects, objects discovered by navigating from other classes via associations, objects added due to applying an IChange, and objects discovered by evaluating OCL expressions using IOclPsService.Execute(string).

See Also
IExtentService Interface
Eco.Services Namespace


IExtentService.AllLoadedInstances Method (IClass)

IExtentService.AllLoadedInstances Method (IClass)
IExtentService Interface Eco.Services Namespace See Also
Collapse All

Gets a list of all known objects in the local EcoSpace cache of the specified class.

C#
IObjectList AllLoadedInstances(
    IClass c
);
Parameters
Parameters | Description
c | The modeled UML class to retrieve a list of already known objects for.
Remarks

The same as AllInstances(Eco.UmlRt.IClass) except it will not fetch any information from the persistent storage. If the extent list for the specified class has not yet been fetched this list will contain a list of ID's only for new objects, objects discovered by navigating from other classes via associations, objects added due to applying an IChange, and objects discovered by evaluating OCL expressions using IOclPsService.Execute(string).

See Also
IExtentService Interface
Eco.Services Namespace


IExtentService.AllLoadedInstances Method (System.Type)

IExtentService.AllLoadedInstances Method (System.Type)
IExtentService Interface Eco.Services Namespace See Also
Collapse All

Gets a list of all known objects in the local EcoSpace cache of the specified class.

C#
IObjectList AllLoadedInstances(
    System.Type t
);
Parameters
Parameters | Description
t | The .NET class that will be used to determine the modeled UML class to retrieve a list of already known objects for.
Remarks

The same as AllInstances(System.Type) except it will not fetch any information from the persistent storage. If the extent list for the specified class has not yet been fetched this list will contain a list of ID's only for new objects, objects discovered by navigating from other classes via associations, objects added due to applying an IChange, and objects discovered by evaluating OCL expressions using IOclPsService.Execute(string).

See Also
IExtentService Interface
Eco.Services Namespace


IExtentService.AllLoadedInstances Method (string)

IExtentService.AllLoadedInstances Method (string)
IExtentService Interface Eco.Services Namespace See Also
Collapse All

Gets a list of all known objects in the local EcoSpace cache of the specified class.

C#
IObjectList AllLoadedInstances(
    string className
);
Parameters
Parameters | Description
className | The name of the modeled UML class to retrieve a list of already known objects for.
Remarks

The same as AllInstances(string) except it will not fetch any information from the persistent storage. If the extent list for the specified class has not yet been fetched this list will contain a list of ID's only for new objects, objects discovered by navigating from other classes via associations, objects added due to applying an IChange, and objects discovered by evaluating OCL expressions using IOclPsService.Execute(string).

See Also
IExtentService Interface
Eco.Services Namespace


SubscribeToObjectAdded Method

SubscribeToObjectAdded Method

This is the overview for the SubscribeToObjectAdded method overload.

Overload List
Name | Description
IExtentService.SubscribeToObjectAdded (ISubscriber, IClass) | Provides the ability to be notitified whenever an object of a specific class or its subclasses is added to the list of known objects.
IExtentService.SubscribeToObjectAdded (ISubscriber, string) | Provides the ability to be notitified whenever an object of a specific class or its subclasses is added to the list of known objects.
IExtentService.SubscribeToObjectAdded (ISubscriber, System.Type) | Provides the ability to be notitified whenever an object of a specific class or its subclasses is added to the list of known objects.


IExtentService.SubscribeToObjectAdded Method (ISubscriber, IClass)

IExtentService.SubscribeToObjectAdded Method (ISubscriber, IClass)
IExtentService Interface Eco.Services Namespace See Also
Collapse All

Provides the ability to be notitified whenever an object of a specific class or its subclasses is added to the list of known objects.

C#
void SubscribeToObjectAdded(
    ISubscriber subscriber,
    IClass c
);
Parameters
Parameters | Description
subscriber | The subscriber instance to trigger whenever an object is added to the list.
c | The modeled UML class for which to subscribe to notifications.
See Also
IExtentService Interface
Eco.Services Namespace


IExtentService.SubscribeToObjectAdded Method (ISubscriber, System.Type)

IExtentService.SubscribeToObjectAdded Method (ISubscriber, System.Type)
IExtentService Interface Eco.Services Namespace See Also
Collapse All

Provides the ability to be notitified whenever an object of a specific class or its subclasses is added to the list of known objects.

C#
void SubscribeToObjectAdded(
    ISubscriber subscriber,
    System.Type t
);
Parameters
Parameters | Description
subscriber | The subscriber instance to trigger whenever an object is added to the list.
t | The .NET class that will be used to determine the modeled UML class for which to subscribe to notifications.
See Also
IExtentService Interface
Eco.Services Namespace


IExtentService.SubscribeToObjectAdded Method (ISubscriber, string)

IExtentService.SubscribeToObjectAdded Method (ISubscriber, string)
IExtentService Interface Eco.Services Namespace See Also
Collapse All

Provides the ability to be notitified whenever an object of a specific class or its subclasses is added to the list of known objects.

C#
void SubscribeToObjectAdded(
    ISubscriber subscriber,
    string className
);
Parameters
Parameters | Description
subscriber | The subscriber instance to trigger whenever an object is added to the list.
className | The name of the modeled UML class for which to subscribe to notifications.
See Also
IExtentService Interface
Eco.Services Namespace


SubscribeToObjectRemoved Method

SubscribeToObjectRemoved Method

This is the overview for the SubscribeToObjectRemoved method overload.

Overload List
Name | Description
IExtentService.SubscribeToObjectRemoved (ISubscriber, IClass) | Provides the ability to be notitified whenever an object of a specific class or its subclasses is deleted.
IExtentService.SubscribeToObjectRemoved (ISubscriber, string) | Provides the ability to be notitified whenever an object of a specific class or its subclasses is deleted.
IExtentService.SubscribeToObjectRemoved (ISubscriber, System.Type) | Provides the ability to be notitified whenever an object of a specific class or its subclasses is deleted.


IExtentService.SubscribeToObjectRemoved Method (ISubscriber, IClass)

IExtentService.SubscribeToObjectRemoved Method (ISubscriber, IClass)
IExtentService Interface Eco.Services Namespace See Also
Collapse All

Provides the ability to be notitified whenever an object of a specific class or its subclasses is deleted.

C#
void SubscribeToObjectRemoved(
    ISubscriber subscriber,
    IClass c
);
Parameters
Parameters | Description
subscriber | The subscriber instance to trigger whenever an object is deleted.
c | The modeled UML class for which to subscribe to notifications.
See Also
IExtentService Interface
Eco.Services Namespace


IExtentService.SubscribeToObjectRemoved Method (ISubscriber, System.Type)

IExtentService.SubscribeToObjectRemoved Method (ISubscriber, System.Type)
IExtentService Interface Eco.Services Namespace See Also
Collapse All

Provides the ability to be notitified whenever an object of a specific class or its subclasses is deleted.

C#
void SubscribeToObjectRemoved(
    ISubscriber subscriber,
    System.Type t
);
Parameters
Parameters | Description
subscriber | The subscriber instance to trigger whenever an object is deleted.
t | The .NET class that will be used to determine the modeled UML class for which to subscribe to notifications.
See Also
IExtentService Interface
Eco.Services Namespace


IExtentService.SubscribeToObjectRemoved Method (ISubscriber, string)

IExtentService.SubscribeToObjectRemoved Method (ISubscriber, string)
IExtentService Interface Eco.Services Namespace See Also
Collapse All

Provides the ability to be notitified whenever an object of a specific class or its subclasses is deleted.

C#
void SubscribeToObjectRemoved(
    ISubscriber subscriber,
    string className
);
Parameters
Parameters | Description
subscriber | The subscriber instance to trigger whenever an object is deleted.
className | The name of the modeled UML class for which to subscribe to notifications.
See Also
IExtentService Interface
Eco.Services Namespace


IExtentService.Unload Method

IExtentService.Unload Method
IExtentService Interface Eco.Services Namespace See Also
Collapse All

This will free the memory used for storing the list of known objects of a specific class.

C#
void Unload(
    IClass c
);
Parameters
Parameters | Description
c | The class to unload the extent for.
Remarks

This will then ensure that the extent is reread from the persistent storage the next time AllInstances is called for the class. Note that Unload() for a class also unloads the extent for each of its superclasses.

See Also
IExtentService Interface
Eco.Services Namespace


IExternalIdService Interface

IExternalIdService Interface
Inheritance Hierarchy See Also
Collapse All

Provides a way of uniquely identifying object instances and also retrieving them from the persistent storage using this unique ID.

C#
public interface IExternalIdService;
Remarks

This service provides ids for objects that are guaranteed to be stable within the ecospace regardless of whether the objects have been stored or not.

Normally, an object has an internal id when it is first created, and then changes id to a persistent id the first time it is stored in the database.

This service is intended to be used by asp-clients so that the id handed to the web page can be converted back to the same object when an update is posted from the web page.

Inheritance Hierarchy
Eco.Services.IExternalIdService
File

Services.cs

See Also
Inheritance Hierarchy


IExternalIdService Methods

IExternalIdService Methods
Public Methods
Collapse All

The methods of the IExternalIdService class are listed here.

Public Methods
Name | Description
IdForObject | Creates and returns a stable ID for the specified object. This ID is then stable within the lifetime of the EcoSpace.
ObjectForId | Returns the object with the unique ID specified.


IExternalIdService.IdForObject Method

IExternalIdService.IdForObject Method
IExternalIdService Interface Eco.Services Namespace See Also
Collapse All

Creates and returns a stable ID for the specified object. This ID is then stable within the lifetime of the EcoSpace.

C#
string IdForObject(
    IEcoObject obj
);
See Also
IExternalIdService Interface
Eco.Services Namespace


IExternalIdService.ObjectForId Method

IExternalIdService.ObjectForId Method
IExternalIdService Interface Eco.Services Namespace See Also
Collapse All

Returns the object with the unique ID specified.

C#
IObjectInstance ObjectForId(
    string id
);
See Also
IExternalIdService Interface
Eco.Services Namespace


IObjectFactoryService Interface

IObjectFactoryService Interface
Inheritance Hierarchy See Also
Collapse All

Provides methods for you to create new instances of the classes in your model.

C#
public interface IObjectFactoryService;
Remarks

The IObjectFactoryService interface methods create new objects using their type information. This approach is more generic than directly creating a new object by calling the C# new method, or the Delphi Create method.

This service returns ECO types rather than .NET types, these types may be used with the various other services for performing operations such as OCL evaluation.

Inheritance Hierarchy
Eco.Services.IObjectFactoryService
File

Services.cs

See Also
Inheritance Hierarchy


IObjectFactoryService Methods

IObjectFactoryService Methods
Public Methods
Collapse All

The methods of the IObjectFactoryService class are listed here.

Public Methods
Name | Description
CreateNewLinkObject | This is the overview for the CreateNewLinkObject method overload.
CreateNewObject | This is the overview for the CreateNewObject method overload.
DeleteObjects | This operation will delete all objects in the list


CreateNewLinkObject Method

CreateNewLinkObject Method

This is the overview for the CreateNewLinkObject method overload.

Overload List
Name | Description
IObjectFactoryService.CreateNewLinkObject (IEcoObject, IEcoObject) | If an association between two classes requires a link class (a link table in RDBMS) this method will create an association between the two objects and return the link object.
IObjectFactoryService.CreateNewLinkObject (IEcoObject, IEcoObject, IAssociation) | If an association between two classes requires a link class (a link table in RDBMS) this method will create an association between the two objects and return the link class.
IObjectFactoryService.CreateNewLinkObject (IEcoObject, IEcoObject, Type) | If an association between two classes requires a link class (a link table in RDBMS) this method will create an association between the two objects and return the link class.


IObjectFactoryService.CreateNewLinkObject Method (IEcoObject, IEcoObject)

IObjectFactoryService.CreateNewLinkObject Method (IEcoObject, IEcoObject)
IObjectFactoryService Interface Eco.Services Namespace See Also
Collapse All

If an association between two classes requires a link class (a link table in RDBMS) this method will create an association between the two objects and return the link object.

C#
IObjectInstance CreateNewLinkObject(
    IEcoObject end1,
    IEcoObject end2
);
Parameters
Parameters | Description
end1 | The first object to link.
end2 | The second object to link.
Remarks

If more than one association has been modeled between the classes of the specified objects then another overloaded version of this method should be used.

See Also
IObjectFactoryService Interface
Eco.Services Namespace


IObjectFactoryService.CreateNewLinkObject Method (IEcoObject, IEcoObject, IAssociation)

IObjectFactoryService.CreateNewLinkObject Method (IEcoObject, IEcoObject, IAssociation)
IObjectFactoryService Interface Eco.Services Namespace See Also
Collapse All

If an association between two classes requires a link class (a link table in RDBMS) this method will create an association between the two objects and return the link class.

C#
IObjectInstance CreateNewLinkObject(
    IEcoObject end1,
    IEcoObject end2,
    IAssociation assoc
);
Parameters
Parameters | Description
end1 | The first object to link.
end2 | The second object to link.
assoc | The modeled association that will be used to link the two objects.
Remarks

This overloaded method accepts an association reference, this is useful when more than one association has been modeled between the classes of the specified objects.

See Also
IObjectFactoryService Interface
Eco.Services Namespace


IObjectFactoryService.CreateNewLinkObject Method (IEcoObject, IEcoObject, Type)

IObjectFactoryService.CreateNewLinkObject Method (IEcoObject, IEcoObject, Type)
IObjectFactoryService Interface Eco.Services Namespace See Also
Collapse All

If an association between two classes requires a link class (a link table in RDBMS) this method will create an association between the two objects and return the link class.

C#
object CreateNewLinkObject(
    IEcoObject end1,
    IEcoObject end2,
    Type assocClass
);
Parameters
Parameters | Description
end1 | The first object to link.
end2 | The second object to link.
assocClass | The .NET class that will be used to determine the modeled association that will be used to link the two objects.
Remarks

This overloaded method accepts an association reference, this is useful when more than one association has been modeled between the classes of the specified objects.

See Also
IObjectFactoryService Interface
Eco.Services Namespace


CreateNewObject Method

CreateNewObject Method

This is the overview for the CreateNewObject method overload.

Overload List
Name | Description
IObjectFactoryService.CreateNewObject (IClass) | Creates a new object instace of the specified modeled UML class belonging to the EcoSpace from which this service reference was obtained.
IObjectFactoryService.CreateNewObject (string) | Creates a new object instace of the specified modeled UML class belonging to the EcoSpace from which this service reference was obtained.
IObjectFactoryService.CreateNewObject (Type) | Creates a new object instace of the specified modeled UML class belonging to the EcoSpace from which this service reference was obtained.


IObjectFactoryService.CreateNewObject Method (IClass)

IObjectFactoryService.CreateNewObject Method (IClass)
IObjectFactoryService Interface Eco.Services Namespace See Also
Collapse All

Creates a new object instace of the specified modeled UML class belonging to the EcoSpace from which this service reference was obtained.

C#
IObjectInstance CreateNewObject(
    IClass c
);
Parameters
Parameters | Description
c | The modeled UML class to create an instance of.
See Also
IObjectFactoryService Interface
Eco.Services Namespace


IObjectFactoryService.CreateNewObject Method (Type)

IObjectFactoryService.CreateNewObject Method (Type)
IObjectFactoryService Interface Eco.Services Namespace See Also
Collapse All

Creates a new object instace of the specified modeled UML class belonging to the EcoSpace from which this service reference was obtained.

C#
IObjectInstance CreateNewObject(
    Type t
);
Parameters
Parameters | Description
t | The .NET class that will be used to determine the modeled UML class to create an instance of.
See Also
IObjectFactoryService Interface
Eco.Services Namespace


IObjectFactoryService.CreateNewObject Method (string)

IObjectFactoryService.CreateNewObject Method (string)
IObjectFactoryService Interface Eco.Services Namespace See Also
Collapse All

Creates a new object instace of the specified modeled UML class belonging to the EcoSpace from which this service reference was obtained.

C#
IObjectInstance CreateNewObject(
    string className
);
Parameters
Parameters | Description
className | The name of the modeled UML class to create an instance of.
See Also
IObjectFactoryService Interface
Eco.Services Namespace


IObjectFactoryService.DeleteObjects Method

IObjectFactoryService.DeleteObjects Method
IObjectFactoryService Interface Eco.Services Namespace See Also
Collapse All

This operation will delete all objects in the list

C#
void DeleteObjects(
    IEnumerable<IEcoObject> list
);
Remarks

It will safely handle objects that are both in the list themselves and cascade-deleted by other objects in the list

See Also
IObjectFactoryService Interface
Eco.Services Namespace


IOclPsService Interface

IOclPsService Interface
Inheritance Hierarchy Related Topics See Also
Collapse All

This interface allows evaluation OCL expressions directly in the persistent storage (typically a database).

C#
public interface IOclPsService : IOclPsTypeService;
Remarks

The OCL expression will be translated to SQL and executed directly in the database. When executing the query, only the identities of the objects will be fetched, not the contents. These object ID's are then added to the relevant class extents in the IExtentService allowing IOclService evaluations such as "Person.allLoadedObjects" to operate correctly.

The OCL expressions that can be evaluated in the database are a subset of all expressions. The result of the expression must always be an object, or a list of objects.

Related Topics

IOclService, IActionLanguageService

Inheritance Hierarchy
Eco.Services.ITypeService
    Eco.Services.IOclPsTypeService
        Eco.Services.IOclPsService
File

Services.cs

See Also
Inheritance Hierarchy
Related Topics


IOclPsService Methods

IOclPsService Methods
Public Methods
Collapse All

The methods of the IOclPsService class are listed here.

Public Methods
Name | Description
CreateRetrieveCondition | This method creates a retrieve condition based on a root context, variable list, and an OCL expression.
Execute | This is the overview for the Execute method overload.


IOclPsService.CreateRetrieveCondition Method

IOclPsService.CreateRetrieveCondition Method
IOclPsService Interface Eco.Services Namespace See Also
Collapse All

This method creates a retrieve condition based on a root context, variable list, and an OCL expression.

C#
AbstractCondition CreateRetrieveCondition(
    IElement root,
    IExternalVariableList variableList,
    string expression
);
See Also
IOclPsService Interface
Eco.Services Namespace


Execute Method

Execute Method

This is the overview for the Execute method overload.

Overload List
Name | Description
IOclPsService.Execute (IElement, IExternalVariableList, string, int, int) | Converts the specified OCL to SQL and executes it in the database without having to fetch all objects into the local EcoSpace cache.
IOclPsService.Execute (IElement, string) | Converts the specified OCL to SQL and executes it in the database without having to fetch all objects into the local EcoSpace cache.
IOclPsService.Execute (string) | Converts the specified OCL to SQL and executes it in the database without having to fetch all objects into the local EcoSpace cache.
IOclPsService.Execute (string, int, int) | Converts the specified OCL to SQL and executes it in the database without having to fetch all objects into the local EcoSpace cache. This overloaded version of Execute will return a subsequence of the total objects returned by the database.


IOclPsService.Execute Method (IElement, IExternalVariableList, string, int, int)

IOclPsService.Execute Method (IElement, IExternalVariableList, string, int, int)
IOclPsService Interface Eco.Services Namespace See Also
Collapse All

Converts the specified OCL to SQL and executes it in the database without having to fetch all objects into the local EcoSpace cache.

C#
IObjectList Execute(
    IElement root,
    IExternalVariableList variableList,
    string expression,
    int maxAnswers,
    int offset
);
Parameters
Parameters | Description
root | The root context to evaluate the expression against.
variableList | A list of variables to use when evaluating the OCL expression.
expression | The OCL expression to convert to SQL and evaluate in the database.
maxAnswers | The maximum number of objects to return, or -1 if all answers should be returned.
offset | The zero based index of the first object in the result set to return.
Remarks

If any of the objects returned have been modified in the local EcoSpace cache they may no longer match the criteria specified yet will still appear in the result set. To ensure that the objects in the result set do actually match the criteria it is possible to use the result element as the root when evaluating in memory using the IOclService.

See Also
IOclPsService Interface
Eco.Services Namespace


IOclPsService.Execute Method (IElement, string)

IOclPsService.Execute Method (IElement, string)
IOclPsService Interface Eco.Services Namespace See Also
Collapse All

Converts the specified OCL to SQL and executes it in the database without having to fetch all objects into the local EcoSpace cache.

C#
IObjectList Execute(
    IElement root,
    string expression
);
Parameters
Parameters | Description
root | The root context to evaluate the expression against.
expression | The OCL expression to convert to SQL and evaluate in the database.
Remarks

If any of the objects returned have been modified in the local EcoSpace cache they may no longer match the criteria specified yet will still appear in the result set. To ensure that the objects in the result set do actually match the criteria it is possible to use the result element as the root when evaluating in memory using the IOclService.

See Also
IOclPsService Interface
Eco.Services Namespace


IOclPsService.Execute Method (string)

IOclPsService.Execute Method (string)
IOclPsService Interface Eco.Services Namespace See Also
Collapse All

Converts the specified OCL to SQL and executes it in the database without having to fetch all objects into the local EcoSpace cache.

C#
IObjectList Execute(
    string expression
);
Parameters
Parameters | Description
expression | The OCL expression to convert to SQL and evaluate in the database.
Remarks

If any of the objects returned have been modified in the local EcoSpace cache they may no longer match the criteria specified yet will still appear in the result set. To ensure that the objects in the result set do actually match the criteria it is possible to use the result element as the root when evaluating in memory using the IOclService.

See Also
IOclPsService Interface
Eco.Services Namespace


IOclPsService.Execute Method (string, int, int)

IOclPsService.Execute Method (string, int, int)
IOclPsService Interface Eco.Services Namespace See Also
Collapse All

Converts the specified OCL to SQL and executes it in the database without having to fetch all objects into the local EcoSpace cache. This overloaded version of Execute will return a subsequence of the total objects returned by the database.

C#
IObjectList Execute(
    string expression,
    int maxAnswers,
    int offset
);
Parameters
Parameters | Description
expression | The OCL expression to convert to SQL and evaluate in the database.
maxAnswers | The maximum number of objects to return, or -1 if all answers should be returned.
offset | The zero based index of the first object in the result set to return.
Remarks

If any of the objects returned have been modified in the local EcoSpace cache they may no longer match the criteria specified yet will still appear in the result set. To ensure that the objects in the result set do actually match the criteria it is possible to use the result element as the root when evaluating in memory using the IOclService.

See Also
IOclPsService Interface
Eco.Services Namespace


IOclPsTypeService Interface

IOclPsTypeService Interface
Inheritance Hierarchy See Also
Collapse All

The methods of this interface performs static analysis of OCl expressions. Mainly intended to be used in designtime to calculate static types of handles.

C#
public interface IOclPsTypeService : ITypeService;
Inheritance Hierarchy
Eco.Services.ITypeService
    Eco.Services.IOclPsTypeService
        Eco.Services.IOclPsService
File

Services.cs

See Also
Inheritance Hierarchy


IOclService Interface

IOclService Interface
Inheritance Hierarchy Related Topics See Also
Collapse All

This interface allows programmatic access to evaluating OCL expressions. Expressions using the IOclService are always evaluated in memory. Any data required to fulfil the evaluation will be fetched automatically from the persistent storage as needed.

C#
public interface IOclService : IOclTypeService;
Remarks

Evaluating expressions such as "Person.allInstances->select(name = 'Fred')" will result in all instances of Person being loaded into memory before the ->select condition is evaluated locally. To retrieve a list of objects without fetching all instances into memory use IOclPsService.Execute(string), to evaluate an expression only against objects in memory use "allLoadedObjects" instead of "allInstances"

Related Topics

IOclPsService, IActionLanguageService

Inheritance Hierarchy
Eco.Services.ITypeService
    Eco.Services.IOclTypeService
        Eco.Services.IOclService
File

Services.cs

See Also
Inheritance Hierarchy
Related Topics


IOclService Methods

IOclService Methods
Public Methods
Collapse All

The methods of the IOclService class are listed here.

Public Methods
Name | Description
Evaluate | This is the overview for the Evaluate method overload.
EvaluateAndSubscribe | This is the overview for the EvaluateAndSubscribe method overload.
GetDerivedElement | Evaluates an expression against the specified root, but instead of returning a one-off evaluation will ensure that the value is up to date any time it is read.


Evaluate Method

Evaluate Method

This is the overview for the Evaluate method overload.

Overload List
Name | Description
IOclService.Evaluate (IElement, string) | Evaluates an OCL expression in the context of the root element.
IOclService.Evaluate (IElement, string, IExternalVariableList) | Evaluates an OCL expression in the context of the root element with external variables.
IOclService.Evaluate (string) | Evaluates an OCL expression in the context of the EcoSpace.
IOclService.Evaluate (string, IExternalVariableList) | Evaluates an OCL expression in the context of the EcoSpace with external variables.


IOclService.Evaluate Method (IElement, string)

IOclService.Evaluate Method (IElement, string)
IOclService Interface Eco.Services Namespace See Also
Collapse All

Evaluates an OCL expression in the context of the root element.

C#
IElement Evaluate(
    IElement root,
    string expression
);
Parameters
Parameters | Description
root | The element against which to evaluated the OCL expression.
expression | The OCL expression to be evaluated.
See Also
IOclService Interface
Eco.Services Namespace


IOclService.Evaluate Method (IElement, string, IExternalVariableList)

IOclService.Evaluate Method (IElement, string, IExternalVariableList)
IOclService Interface Eco.Services Namespace See Also
Collapse All

Evaluates an OCL expression in the context of the root element with external variables.

C#
IElement Evaluate(
    IElement root,
    string expression,
    IExternalVariableList variableList
);
Parameters
Parameters | Description
root | The element against which to evaluated the OCL expression.
expression | The OCL expression to be evaluated.
variableList | A list of variables to be used during evaluation of the expression.
See Also
IOclService Interface
Eco.Services Namespace


IOclService.Evaluate Method (string)

IOclService.Evaluate Method (string)
IOclService Interface Eco.Services Namespace See Also
Collapse All

Evaluates an OCL expression in the context of the EcoSpace.

C#
IElement Evaluate(
    string expression
);
Parameters
Parameters | Description
expression | The OCL expression to be evaluated.
See Also
IOclService Interface
Eco.Services Namespace


IOclService.Evaluate Method (string, IExternalVariableList)

IOclService.Evaluate Method (string, IExternalVariableList)
IOclService Interface Eco.Services Namespace See Also
Collapse All

Evaluates an OCL expression in the context of the EcoSpace with external variables.

C#
IElement Evaluate(
    string expression,
    IExternalVariableList variableList
);
Parameters
Parameters | Description
expression | The OCL expression to be evaluated.
variableList | A list of variables to be used during evaluation of the expression.
See Also
IOclService Interface
Eco.Services Namespace


EvaluateAndSubscribe Method

EvaluateAndSubscribe Method

This is the overview for the EvaluateAndSubscribe method overload.

Overload List
Name | Description
IOclService.EvaluateAndSubscribe (IElement, IClassifier, IExternalVariableList, string, ISubscriber, ISubscriber) | Evaluates an OCL expression in the context of the root element typecast to the specified type.
IOclService.EvaluateAndSubscribe (IElement, IClassifier, string, ISubscriber, ISubscriber) |
IOclService.EvaluateAndSubscribe (IElement, IExternalVariableList, string, ISubscriber, ISubscriber) |
IOclService.EvaluateAndSubscribe (IElement, string, ISubscriber, ISubscriber) | Evaluates an OCL expression in the context of the root element.


IOclService.EvaluateAndSubscribe Method (IElement, IClassifier, IExternalVariableList, string, ISubscriber, ISubscriber)

IOclService.EvaluateAndSubscribe Method (IElement, IClassifier, IExternalVariableList, string, ISubscriber, ISubscriber)
IOclService Interface Eco.Services Namespace See Also
Collapse All

Evaluates an OCL expression in the context of the root element typecast to the specified type.

C#
IElement EvaluateAndSubscribe(
    IElement root,
    IClassifier rootType,
    IExternalVariableList variableList,
    string expression,
    ISubscriber reevaluateSubscriber,
    ISubscriber resubscribeSubscriber
);
Parameters
Parameters | Description
root | The element against which to evaluated the OCL expression.
rootType | The modeled UML class type to cast the root to.
variableList | A list of variables to be used during evaluation of the expression.
expression | The OCL expression to be evaluated.
reevaluateSubscriber | The subscriber that should be notified if an element value changes.
resubscribeSubscriber | If an element changes in such a way that the list of elements subscribed to would need to change (e.g. if a new object is added to an association) then this subscriber will be notified.
See Also
IOclService Interface
Eco.Services Namespace


IOclService.EvaluateAndSubscribe Method (IElement, IClassifier, string, ISubscriber, ISubscriber)

IOclService.EvaluateAndSubscribe Method (IElement, IClassifier, string, ISubscriber, ISubscriber)
IOclService Interface Eco.Services Namespace See Also
Collapse All
C#
IElement EvaluateAndSubscribe(
    IElement root,
    IClassifier rootType,
    string expression,
    ISubscriber reevaluateSubscriber,
    ISubscriber resubscribeSubscriber
);
Parameters
Parameters | Description
root | The element against which to evaluated the OCL expression.
rootType | The modeled UML class type to cast the root to.
expression | The OCL expression to be evaluated.
reevaluateSubscriber | The subscriber that should be notified if an element value changes.
resubscribeSubscriber | If an element changes in such a way that the list of elements subscribed to would need to change (e.g. if a new object is added to an association) then this subscriber will be notified.
See Also
IOclService Interface
Eco.Services Namespace


IOclService.EvaluateAndSubscribe Method (IElement, IExternalVariableList, string, ISubscriber, ISubscriber)

IOclService.EvaluateAndSubscribe Method (IElement, IExternalVariableList, string, ISubscriber, ISubscriber)
IOclService Interface Eco.Services Namespace See Also
Collapse All
C#
IElement EvaluateAndSubscribe(
    IElement root,
    IExternalVariableList variableList,
    string expression,
    ISubscriber reevaluateSubscriber,
    ISubscriber resubscribeSubscriber
);
Parameters
Parameters | Description
root | The element against which to evaluated the OCL expression.
variableList | A list of variables to be used during evaluation of the expression.
expression | The OCL expression to be evaluated.
reevaluateSubscriber | The subscriber that should be notified if an element value changes.
resubscribeSubscriber | If an element changes in such a way that the list of elements subscribed to would need to change (e.g. if a new object is added to an association) then this subscriber will be notified.
See Also
IOclService Interface
Eco.Services Namespace


IOclService.EvaluateAndSubscribe Method (IElement, string, ISubscriber, ISubscriber)

IOclService.EvaluateAndSubscribe Method (IElement, string, ISubscriber, ISubscriber)
IOclService Interface Eco.Services Namespace See Also
Collapse All

Evaluates an OCL expression in the context of the root element.

C#
IElement EvaluateAndSubscribe(
    IElement root,
    string expression,
    ISubscriber reevaluateSubscriber,
    ISubscriber resubscribeSubscriber
);
Parameters
Parameters | Description
root | The element against which to evaluated the OCL expression.
expression | The OCL expression to be evaluated.
reevaluateSubscriber | The subscriber that should be notified if an element value changes.
resubscribeSubscriber | If an element changes in such a way that the list of elements subscribed to would need to change (e.g. if a new object is added to an association) then this subscriber will be notified.
Remarks

During the evaluation ECO will place subscriptions on each element used to determine the result. If any of the elements change the appropriate subscriber will be notified.

See Also
IOclService Interface
Eco.Services Namespace


IOclService.GetDerivedElement Method

IOclService.GetDerivedElement Method
IOclService Interface Eco.Services Namespace See Also
Collapse All

Evaluates an expression against the specified root, but instead of returning a one-off evaluation will ensure that the value is up to date any time it is read.

C#
IElement GetDerivedElement(
    IElement root,
    string expression
);
Parameters
Parameters | Description
root | The context to evaluate the expression against.
expression | The OCL expression to evaluate and provide a result for.
Remarks

ECO will automatically place all required suscriptions internally so that the value may be cached in order to prevent the OCL from being evaluated each time its value is read.

See Also
IOclService Interface
Eco.Services Namespace


IOclTypeService Interface

IOclTypeService Interface
Inheritance Hierarchy See Also
Collapse All

The methods of this interface performs static analysis of OCL expressions. Mainly intended to be used during design time to calculate static types of handles.

C#
public interface IOclTypeService : ITypeService;
Inheritance Hierarchy
Eco.Services.ITypeService
    Eco.Services.IOclTypeService
        Eco.Services.IOclService
File

Services.cs

See Also
Inheritance Hierarchy


IPersistenceService Interface

IPersistenceService Interface
Inheritance Hierarchy Related Topics See Also
Collapse All

This interface provides a collection of persistence functions in the form of a service.

C#
public interface IPersistenceService;
Related Topics

Eco.ObjectRepresentation.IEcoServiceProvider

Inheritance Hierarchy
Eco.Services.IPersistenceService
File

Services.cs

See Also
Inheritance Hierarchy
Related Topics


IPersistenceService Methods

IPersistenceService Methods
Public Methods
Collapse All

The methods of the IPersistenceService class are listed here.

Public Methods
Name | Description
ApplyAllChanges | Applies the specified action for each conflict change to the local EcoSpace cache.
DiscardChanges | This method will iterate through every object in the list and mark all of its modified contents in the local cache as invalid.
EnsureEnclosure | Given a list of objects this method will return a list of objects required to perform a logical update to the persistent storage.
EnsureObject | This is EnsureObject, a member of class IPersistenceService.
EnsureRange | Fetches the contents of a list of objects from the persistent storage more efficiently.
EnsureRelatedObjects | This is the overview for the EnsureRelatedObjects method overload.
GetAllWithCondition | This is the overview for the GetAllWithCondition method overload.
GetChanges | This method will return a list of known changes.
IsLoaded | Indicates whether or not an object's contents have been loaded into the local EcoSpace cache.
Refresh | Refreshes the local EcoSpace cache with values in the persistent storage.
RetrieveChanges | This is the overview for the RetrieveChanges method overload.
Unload | This method will iterate through every object in the list and mark all of its contents in the local cache as invalid.
UpdateDatabaseWithList | Saves a list of objects to the persistent storage.


IPersistenceService.ApplyAllChanges Method

IPersistenceService.ApplyAllChanges Method
IPersistenceService Interface Eco.Services Namespace See Also
Collapse All

Applies the specified action for each conflict change to the local EcoSpace cache.

C#
void ApplyAllChanges();
Remarks

Performs the action as specified by Eco.Services.ChangeActionKind for each IChange in the list of known changes returned from GetChanges.

See Also
IPersistenceService Interface
Eco.Services Namespace


IPersistenceService.DiscardChanges Method

IPersistenceService.DiscardChanges Method
IPersistenceService Interface Eco.Services Namespace See Also
Collapse All

This method will iterate through every object in the list and mark all of its modified contents in the local cache as invalid.

C#
void DiscardChanges<T>(
    IEnumerable<T> objects
) where T : IEcoObject;
Parameters
Parameters | Description
objects | A list of objects to unload.
Remarks

This method will only touch modified data. To get rid of unmodified data, use the Unload method. The objects' contents will not be reloaded from the persistent storage unless the application attempts to read them. This is similar to the Dispose pattern except that only the objects' data is disposed, it is safe to hold references to the objects in the list and also to continue to read/write their contents.

See Also
IPersistenceService Interface
Eco.Services Namespace


IPersistenceService.EnsureEnclosure Method

IPersistenceService.EnsureEnclosure Method
IPersistenceService Interface Eco.Services Namespace See Also
Collapse All

Given a list of objects this method will return a list of objects required to perform a logical update to the persistent storage.

C#
void EnsureEnclosure(
    IObjectList objects
);
Remarks

This method will inspect each object in the list, and recursively all objects associated with it. ECO will then ensure that the list contains all of the objects required to perform a consistent update to the persistent storage. Associated objects will be added to the list if they match any of the following criteria:

  • An association is mapped into the table of the current object, and its associated object is new. This prevents the object from being saved with a reference to a non-existent object.
  • Persistence mapping specifies that the DB reference between two objects is stored in the table belonging to the class at the other end of the association. If the current object is deleted these associated objects need also to be deleted or removed from the association.

EnsureEnclosure is executed internally whenever an update is made to the persistent storage; it is also useful for application developers to be able to determine exactly which objects will be updated.

See Also
IPersistenceService Interface
Eco.Services Namespace


IPersistenceService.EnsureObject Method

IPersistenceService.EnsureObject Method
IPersistenceService Interface Eco.Services Namespace See Also
Collapse All
C#
void EnsureObject(
    IObjectInstance obj
);
Remarks

This is EnsureObject, a member of class IPersistenceService.

See Also
IPersistenceService Interface
Eco.Services Namespace


IPersistenceService.EnsureRange Method

IPersistenceService.EnsureRange Method
IPersistenceService Interface Eco.Services Namespace See Also
Collapse All

Fetches the contents of a list of objects from the persistent storage more efficiently.

C#
void EnsureRange(
    IObjectList objects,
    int fromIndex,
    int toIndex
);
Parameters
Parameters | Description
objects | A list of objects to fetch the contents of.
fromIndex | The zero based index of the first object in the list to fetch contents for.
toIndex | The zero based index of the last object in the list to fetch contents for.
Remarks

When the contents of a list of objects are going to be read (using an enumerator, or a loop) it is more efficient to fetch the contents of the objects as a single persistence operation rather fetching each of the object's individually when an attempt is made to read a property of the object instance.

See Also
IPersistenceService Interface
Eco.Services Namespace


EnsureRelatedObjects Method

EnsureRelatedObjects Method

This is the overview for the EnsureRelatedObjects method overload.

Overload List
Name | Description
IPersistenceService.EnsureRelatedObjects (IEnumerable<T>, IAssociationEnd) | Fetches the contents of a list of objects from the persistent storage more efficiently.
IPersistenceService.EnsureRelatedObjects (IEnumerable<T>, string) | Fetches the contents of a list of objects from the persistent storage more efficiently.


IPersistenceService.EnsureRelatedObjects Method (IEnumerable<T>, IAssociationEnd)

IPersistenceService.EnsureRelatedObjects Method (IEnumerable<T>, IAssociationEnd)
IPersistenceService Interface Eco.Services Namespace See Also
Collapse All

Fetches the contents of a list of objects from the persistent storage more efficiently.

C#
IObjectList EnsureRelatedObjects<T>(
    IEnumerable<T> objects,
    IAssociationEnd associationEnd
) where T : IEcoObject;
Parameters
Parameters | Description
objects | A list of objects to fetch the contents of.
associationEnd | The modeled association to traverse.
Remarks

This method is the same as EnsureRange except that in addition to fetching all of the contents of the objects in the list ECO will fetch additional objects based on the specified association end.

  • The contents of all objects in the list are fetched.
  • All objects associated via the specified association end have their contents fetched.
See Also
IPersistenceService Interface
Eco.Services Namespace


IPersistenceService.EnsureRelatedObjects Method (IEnumerable<T>, string)

IPersistenceService.EnsureRelatedObjects Method (IEnumerable<T>, string)
IPersistenceService Interface Eco.Services Namespace See Also
Collapse All

Fetches the contents of a list of objects from the persistent storage more efficiently.

C#
IObjectList EnsureRelatedObjects<T>(
    IEnumerable<T> objects,
    string memberName
) where T : IEcoObject;
Parameters
Parameters | Description
objects | A list of objects to fetch the contents of.
memberName | The member name to traverse.
Remarks

This method is the same as EnsureRange except that in addition to fetching all of the contents of the objects in the list ECO will fetch additional objects based on the specified member name.

  • The contents of all objects in the list are fetched.
  • All objects associated via the specified member name have their contents fetched.
See Also
IPersistenceService Interface
Eco.Services Namespace


GetAllWithCondition Method

GetAllWithCondition Method

This is the overview for the GetAllWithCondition method overload.

Overload List
Name | Description
IPersistenceService.GetAllWithCondition (AbstractCondition) | Returns a set of objects that matches the specified condition.
IPersistenceService.GetAllWithCondition (AbstractCondition, int, int) | Returns a subset of objects that matches the condition.


IPersistenceService.GetAllWithCondition Method (AbstractCondition)

IPersistenceService.GetAllWithCondition Method (AbstractCondition)
IPersistenceService Interface Eco.Services Namespace See Also
Collapse All

Returns a set of objects that matches the specified condition.

C#
IObjectList GetAllWithCondition(
    AbstractCondition condition
);
Parameters
Parameters | Description
condition | The condition which should be matched for an object to be added to the result.
Remarks

The condition is normally generated by calling IOclPsService.CreateRetrieveCondition.

See Also
IPersistenceService Interface
Eco.Services Namespace


IPersistenceService.GetAllWithCondition Method (AbstractCondition, int, int)

IPersistenceService.GetAllWithCondition Method (AbstractCondition, int, int)
IPersistenceService Interface Eco.Services Namespace See Also
Collapse All

Returns a subset of objects that matches the condition.

C#
IObjectList GetAllWithCondition(
    AbstractCondition condition,
    int maxAnswers,
    int offset
);
Parameters
Parameters | Description
condition | The condition which should be matched for an object to be added to the result.
maxAnswers | The maximum number of objects to return, or -1 if all answers should be returned.
offset | The zero based index of the first object in the result list to include.
Remarks

The condition is normally generated by calling IOclPsService.CreateRetrieveCondition.

See Also
IPersistenceService Interface
Eco.Services Namespace


IPersistenceService.GetChanges Method

IPersistenceService.GetChanges Method
IPersistenceService Interface Eco.Services Namespace See Also
Collapse All

This method will return a list of known changes.

C#
IChange[] GetChanges();
Remarks

Changes by other users or other EcoSpaces made to the persistent storage enter this list either as a result of executing RetrieveChanges() or as a result of experiencing an OptimisticLockException when attempting to save changes to the persistent storage.

See Also
IPersistenceService Interface
Eco.Services Namespace


IPersistenceService.IsLoaded Method

IPersistenceService.IsLoaded Method
IPersistenceService Interface Eco.Services Namespace See Also
Collapse All

Indicates whether or not an object's contents have been loaded into the local EcoSpace cache.

C#
bool IsLoaded(
    IEcoObject obj
);
Parameters
Parameters | Description
obj | The object to inspect.
Remarks

This will check if all the properties that are loaded by default for an object have been loaded. DelayedFetch attributes and multilinks are not considered.

See Also
IPersistenceService Interface
Eco.Services Namespace


IPersistenceService.Refresh Method

IPersistenceService.Refresh Method
IPersistenceService Interface Eco.Services Namespace Related Topics See Also
Collapse All

Refreshes the local EcoSpace cache with values in the persistent storage.

C#
void Refresh(
    bool fetchValues
);
Parameters
Parameters | Description
fetchValues | If True non-conflicting changes will be re-read immediately, otherwise non-conflicting changes will be invalidated.
Remarks

Instructs ECO to retrieve a list of changes from the sync handler. All changes that are not in direct conflict with changes made to the local EcoSpace cache will be applied. ChangeActionKind.Discard ChangeActionKind.Reread

Related Topics

SupportsSync

See Also
IPersistenceService Interface
Eco.Services Namespace
Related Topics


RetrieveChanges Method

RetrieveChanges Method

This is the overview for the RetrieveChanges method overload.

Overload List
Name | Description
IPersistenceService.RetrieveChanges () | Gets a list of changes by other users from a central change server.
IPersistenceService.RetrieveChanges (out DBChangeCollection) | Gets a list of changes by other users from a central change server.


IPersistenceService.RetrieveChanges Method ()

IPersistenceService.RetrieveChanges Method ()
IPersistenceService Interface Eco.Services Namespace See Also
Collapse All

Gets a list of changes by other users from a central change server.

C#
void RetrieveChanges();
Remarks

This procedure will retrieve information of changes made by other clients from a central change server. None of the changes will be automatically applied to the local cache, the changes will be added to the list retrieved by calling GetChanges.

See Also
IPersistenceService Interface
Eco.Services Namespace


IPersistenceService.RetrieveChanges Method (out DBChangeCollection)

IPersistenceService.RetrieveChanges Method (out DBChangeCollection)
IPersistenceService Interface Eco.Services Namespace See Also
Collapse All

Gets a list of changes by other users from a central change server.

C#
void RetrieveChanges(
    out DBChangeCollection ignoredChanges
);
Parameters
Parameters | Description
ignoredChanges | Returns a collection of DBChange objects that were not converted into an IChange.
Remarks

This procedure will retrieve information of changes made by other clients from a central change server. None of the changes will be automatically applied to the local cache, the changes will be added to the list retrieved by calling GetChanges. A list of Eco.Persistence.DBChange is retrieved from a sync server. Each DBChange is then processed, changes that refer to objects loaded into the EcoSpace’s cache will be converted into an Eco.Services.IChange which is then accessed via GetChanges. Any DBChange that does not refer to a loaded object will normally be discarded, this overload provides access to the discarded change notifications so that the application may inspect them and choose to take an appropriate action, such as re-executing an OclPsHandle.

See Also
IPersistenceService Interface
Eco.Services Namespace


IPersistenceService.Unload Method

IPersistenceService.Unload Method
IPersistenceService Interface Eco.Services Namespace See Also
Collapse All

This method will iterate through every object in the list and mark all of its contents in the local cache as invalid.

C#
void Unload<T>(
    IEnumerable<T> objects
) where T : IEcoObject;
Parameters
Parameters | Description
objects | A list of objects to unload.
Remarks

This method will only unload unmodified objects. To get rid of modified objects, use the DiscardChanges method. The objects' contents will not be reloaded from the persistent storage unless the application attempts to read them. This is similar to the Dispose pattern except that only the objects' data is disposed, it is safe to hold references to the objects in the list and also to continue to read/write their contents.

Exceptions
Exceptions | Description
InvalidOperationException | Thrown if any of the objects have been modified.
See Also
IPersistenceService Interface
Eco.Services Namespace


IPersistenceService.UpdateDatabaseWithList Method

IPersistenceService.UpdateDatabaseWithList Method
IPersistenceService Interface Eco.Services Namespace Related Topics See Also
Collapse All

Saves a list of objects to the persistent storage.

C#
void UpdateDatabaseWithList<T>(
    IEnumerable<T> list
) where T : IEcoObject;
Parameters
Parameters | Description
list | The list of objects to save.
Remarks

Instructs ECO to save all changes to a list of objects to the persistent storage. Before updating the persistent storage ECO will first ensure integrity is not comprimised by executing EnsureEnclosure.

Related Topics

IDirtyListService.AllDirtyObjects, EnsureEnclosure

See Also
IPersistenceService Interface
Eco.Services Namespace
Related Topics


IPersistenceService Properties

IPersistenceService Properties
Public Properties
Collapse All

The properties of the IPersistenceService class are listed here.

Public Properties
Name | Description
IsPersistent | Indicates whether or not the EcoSpace is able to persist objects.
SupportsSync | If the EcoSpace is connected to a persistence mechanism that supports multi-user change notification then this property will return True.


IPersistenceService.IsPersistent Property

IPersistenceService.IsPersistent Property
IPersistenceService Interface Eco.Services Namespace See Also
Collapse All

Indicates whether or not the EcoSpace is able to persist objects.

C#
bool IsPersistent;
Remarks

If the EcoSpace has a persistence mapper specified to provide persistence operations this property will return True, otherwise it will return False.

See Also
IPersistenceService Interface
Eco.Services Namespace


IPersistenceService.SupportsSync Property

IPersistenceService.SupportsSync Property
IPersistenceService Interface Eco.Services Namespace See Also
Collapse All

If the EcoSpace is connected to a persistence mechanism that supports multi-user change notification then this property will return True.

C#
bool SupportsSync;
See Also
IPersistenceService Interface
Eco.Services Namespace


IStateService Interface

IStateService Interface
Inheritance Hierarchy See Also
Collapse All

Allows you to discover whether a particular object or property in the ECO space has been modified.

C#
public interface IStateService;
Inheritance Hierarchy
Eco.Services.IStateService
File

Services.cs

See Also
Inheritance Hierarchy


IStateService Methods

IStateService Methods
Public Methods
Collapse All

The methods of the IStateService class are listed here.

Public Methods
Name | Description
IsDirty | This is the overview for the IsDirty method overload.
IsInvalid | Returns true if the value of the property is not available in the cache.
IsNew | Returns true if the object has not yet been saved to the database.


IsDirty Method

IsDirty Method

This is the overview for the IsDirty method overload.

Overload List
Name | Description
IStateService.IsDirty (IEcoObject) | Returns true if the object has any modified members or if it has been created/deleted.
IStateService.IsDirty (IProperty) | Returns true if the property has been modified since it was loaded from the database.


IStateService.IsDirty Method (IEcoObject)

IStateService.IsDirty Method (IEcoObject)
IStateService Interface Eco.Services Namespace See Also
Collapse All

Returns true if the object has any modified members or if it has been created/deleted.

C#
bool IsDirty(
    IEcoObject obj
);
See Also
IStateService Interface
Eco.Services Namespace


IStateService.IsDirty Method (IProperty)

IStateService.IsDirty Method (IProperty)
IStateService Interface Eco.Services Namespace See Also
Collapse All

Returns true if the property has been modified since it was loaded from the database.

C#
bool IsDirty(
    IProperty prop
);
See Also
IStateService Interface
Eco.Services Namespace


IStateService.IsInvalid Method

IStateService.IsInvalid Method
IStateService Interface Eco.Services Namespace See Also
Collapse All

Returns true if the value of the property is not available in the cache.

C#
bool IsInvalid(
    IProperty prop
);
See Also
IStateService Interface
Eco.Services Namespace


IStateService.IsNew Method

IStateService.IsNew Method
IStateService Interface Eco.Services Namespace See Also
Collapse All

Returns true if the object has not yet been saved to the database.

C#
bool IsNew(
    IEcoObject obj
);
See Also
IStateService Interface
Eco.Services Namespace


IStaticContext Interface

IStaticContext Interface
Inheritance Hierarchy See Also
Collapse All

This interface is mainly intended for the internal use of the ElementHandles.

C#
public interface IStaticContext;
Inheritance Hierarchy
Eco.Services.IStaticContext
File

Services.cs

See Also
Inheritance Hierarchy


IStaticContext Properties

IStaticContext Properties
Public Properties
Collapse All

The properties of the IStaticContext class are listed here.

Public Properties
Name | Description
ActionLanguageTypeService | This is ActionLanguageTypeService, a member of class IStaticContext.
OclPsTypeService | This is OclPsTypeService, a member of class IStaticContext.
OclTypeService | This is OclTypeService, a member of class IStaticContext.
StaticUmlType | This is StaticUmlType, a member of class IStaticContext.
TypeSystem | This is TypeSystem, a member of class IStaticContext.
VariableList | This is VariableList, a member of class IStaticContext.


IStaticContext.ActionLanguageTypeService Property

IStaticContext.ActionLanguageTypeService Property
IStaticContext Interface Eco.Services Namespace See Also
Collapse All
C#
IActionLanguageTypeService ActionLanguageTypeService;
Remarks

This is ActionLanguageTypeService, a member of class IStaticContext.

See Also
IStaticContext Interface
Eco.Services Namespace


IStaticContext.OclPsTypeService Property

IStaticContext.OclPsTypeService Property
IStaticContext Interface Eco.Services Namespace See Also
Collapse All
C#
IOclPsTypeService OclPsTypeService;
Remarks

This is OclPsTypeService, a member of class IStaticContext.

See Also
IStaticContext Interface
Eco.Services Namespace


IStaticContext.OclTypeService Property

IStaticContext.OclTypeService Property
IStaticContext Interface Eco.Services Namespace See Also
Collapse All
C#
IOclTypeService OclTypeService;
Remarks

This is OclTypeService, a member of class IStaticContext.

See Also
IStaticContext Interface
Eco.Services Namespace


IStaticContext.StaticUmlType Property

IStaticContext.StaticUmlType Property
IStaticContext Interface Eco.Services Namespace See Also
Collapse All
C#
IClassifier StaticUmlType;
Remarks

This is StaticUmlType, a member of class IStaticContext.

See Also
IStaticContext Interface
Eco.Services Namespace


IStaticContext.TypeSystem Property

IStaticContext.TypeSystem Property
IStaticContext Interface Eco.Services Namespace See Also
Collapse All
C#
IEcoTypeSystem TypeSystem;
Remarks

This is TypeSystem, a member of class IStaticContext.

See Also
IStaticContext Interface
Eco.Services Namespace


IStaticContext.VariableList Property

IStaticContext.VariableList Property
IStaticContext Interface Eco.Services Namespace See Also
Collapse All
C#
IExternalVariableList VariableList;
Remarks

This is VariableList, a member of class IStaticContext.

See Also
IStaticContext Interface
Eco.Services Namespace


ITypeService Interface

ITypeService Interface
Inheritance Hierarchy See Also
Collapse All

This service is used at design time to perform analysis of OCL expressions. It is mainly used to calculate the static types of handles.

C#
public interface ITypeService;
Inheritance Hierarchy
Eco.Services.ITypeService
    Eco.Services.IActionLanguageTypeService
    Eco.Services.IOclPsTypeService
    Eco.Services.IOclTypeService
File

Services.cs

See Also
Inheritance Hierarchy


ITypeService Methods

ITypeService Methods
Public Methods
Collapse All

The methods of the ITypeService class are listed here.

Public Methods
Name | Description
ExpressionIsReadOnly | This is the overview for the ExpressionIsReadOnly method overload.
ExpressionModelInfo | This is the overview for the ExpressionModelInfo method overload.
ExpressionType | This is the overview for the ExpressionType method overload.
InstallOperation | Registers a custom OCL operation for the OCL evaluator to use when evaluating OCL expressions.


ExpressionIsReadOnly Method

ExpressionIsReadOnly Method

This is the overview for the ExpressionIsReadOnly method overload.

Overload List
Name | Description
ITypeService.ExpressionIsReadOnly (string, IClassifier, bool) | Determines whether or not evaluating the expression would result in a read-only element. An element is considered read only if it does not result in a structural feature (class member) that is writable.
ITypeService.ExpressionIsReadOnly (string, IClassifier, bool, IExternalVariableList) | Determines whether or not evaluating the expression would result in a read-only element. An element is considered read only if it does not result in a structural feature (class member) that is writable.


ITypeService.ExpressionIsReadOnly Method (string, IClassifier, bool)

ITypeService.ExpressionIsReadOnly Method (string, IClassifier, bool)
ITypeService Interface Eco.Services Namespace See Also
Collapse All

Determines whether or not evaluating the expression would result in a read-only element. An element is considered read only if it does not result in a structural feature (class member) that is writable.

C#
bool ExpressionIsReadOnly(
    string expression,
    IClassifier context,
    bool reRaise
);
Parameters
Parameters | Description
expression | The OCL expression to parse.
context | The element type against which the OCL would be evaluated.
reRaise | If True then any exception encountered during evaluation will be rethrown.
See Also
ITypeService Interface
Eco.Services Namespace


ITypeService.ExpressionIsReadOnly Method (string, IClassifier, bool, IExternalVariableList)

ITypeService.ExpressionIsReadOnly Method (string, IClassifier, bool, IExternalVariableList)
ITypeService Interface Eco.Services Namespace See Also
Collapse All

Determines whether or not evaluating the expression would result in a read-only element. An element is considered read only if it does not result in a structural feature (class member) that is writable.

C#
bool ExpressionIsReadOnly(
    string expression,
    IClassifier context,
    bool reRaise,
    IExternalVariableList variableList
);
Parameters
Parameters | Description
expression | The OCL expression to parse.
context | The element type against which the OCL would be evaluated.
reRaise | If True then any exception encountered during evaluation will be rethrown.
variableList | A list of variables to use during the evaluation.
See Also
ITypeService Interface
Eco.Services Namespace


ExpressionModelInfo Method

ExpressionModelInfo Method

This is the overview for the ExpressionModelInfo method overload.

Overload List
Name | Description
ITypeService.ExpressionModelInfo (string, IClassifier, bool) | Returns the structural feature identified by an OCL expression.
ITypeService.ExpressionModelInfo (string, IClassifier, bool, IExternalVariableList) | Returns the structural feature identified by an OCL expression.


ITypeService.ExpressionModelInfo Method (string, IClassifier, bool)

ITypeService.ExpressionModelInfo Method (string, IClassifier, bool)
ITypeService Interface Eco.Services Namespace See Also
Collapse All

Returns the structural feature identified by an OCL expression.

C#
IStructuralFeature ExpressionModelInfo(
    string expression,
    IClassifier context,
    bool reRaise
);
Parameters
Parameters | Description
expression | The OCL expression to parse.
context | The element type against which the OCL would be evaluated.
reRaise | If True then any exception encountered during evaluation will be rethrown.
Remarks

If evaluating an OCL expression would return a structural feature ("self.name") rather than a calculated value (self.age + 1) then this method will return the relevant structural feature, otherwise it will return null.

See Also
ITypeService Interface
Eco.Services Namespace


ITypeService.ExpressionModelInfo Method (string, IClassifier, bool, IExternalVariableList)

ITypeService.ExpressionModelInfo Method (string, IClassifier, bool, IExternalVariableList)
ITypeService Interface Eco.Services Namespace See Also
Collapse All

Returns the structural feature identified by an OCL expression.

C#
IStructuralFeature ExpressionModelInfo(
    string expression,
    IClassifier context,
    bool reRaise,
    IExternalVariableList variableList
);
Parameters
Parameters | Description
expression | The OCL expression to parse.
context | The element type against which the OCL would be evaluated.
reRaise | If True then any exception encountered during evaluation will be rethrown.
variableList | A list of variables to use during the evaluation.
Remarks

If evaluating an OCL expression would return a structural feature ("self.name") rather than a calculated value (self.age + 1) then this method will return the relevant structural feature, otherwise it will return null.

See Also
ITypeService Interface
Eco.Services Namespace


ExpressionType Method

ExpressionType Method

This is the overview for the ExpressionType method overload.

Overload List
Name | Description
ITypeService.ExpressionType (string, IClassifier, bool) | Gets the classifier that the result of evaluating the expression would have.
ITypeService.ExpressionType (string, IClassifier, bool, IExternalVariableList) | Gets the classifier that the result of evaluating the expression would have.


ITypeService.ExpressionType Method (string, IClassifier, bool)

ITypeService.ExpressionType Method (string, IClassifier, bool)
ITypeService Interface Eco.Services Namespace See Also
Collapse All

Gets the classifier that the result of evaluating the expression would have.

C#
IClassifier ExpressionType(
    string expression,
    IClassifier context,
    bool reRaise
);
Parameters
Parameters | Description
expression | The OCL expression to parse.
context | The element type against which the OCL would be evaluated.
reRaise | If True then any exception encountered during evaluation will be rethrown.
See Also
ITypeService Interface
Eco.Services Namespace


ITypeService.ExpressionType Method (string, IClassifier, bool, IExternalVariableList)

ITypeService.ExpressionType Method (string, IClassifier, bool, IExternalVariableList)
ITypeService Interface Eco.Services Namespace See Also
Collapse All

Gets the classifier that the result of evaluating the expression would have.

C#
IClassifier ExpressionType(
    string expression,
    IClassifier context,
    bool reRaise,
    IExternalVariableList variableList
);
Parameters
Parameters | Description
expression | The OCL expression to parse.
context | The element type against which the OCL would be evaluated.
reRaise | If True then any exception encountered during evaluation will be rethrown.
variableList | A list of variables to use during the evaluation.
See Also
ITypeService Interface
Eco.Services Namespace


ITypeService.InstallOperation Method

ITypeService.InstallOperation Method
ITypeService Interface Eco.Services Namespace See Also
Collapse All

Registers a custom OCL operation for the OCL evaluator to use when evaluating OCL expressions.

C#
void InstallOperation(
    IOclOperation operation
);
Parameters
Parameters | Description
operation | An instance of the operation to register.
See Also
ITypeService Interface
Eco.Services Namespace


ITypeService Properties

ITypeService Properties
Public Properties
Collapse All

The properties of the ITypeService class are listed here.

Public Properties
Name | Description
InstalledOclOperations | Returns the set of all standard and custom installed operations in the OCL evaluator.


ITypeService.InstalledOclOperations Property

ITypeService.InstalledOclOperations Property
ITypeService Interface Eco.Services Namespace See Also
Collapse All

Returns the set of all standard and custom installed operations in the OCL evaluator.

C#
IOclOperation InstalledOclOperations;
See Also
ITypeService Interface
Eco.Services Namespace


ITypeSystemService Interface

ITypeSystemService Interface
Inheritance Hierarchy See Also
Collapse All

Allows you to get the type system of the model, and to validate the model programmatically.

C#
public interface ITypeSystemService;
Inheritance Hierarchy
Eco.Services.ITypeSystemService
File

Services.cs

See Also
Inheritance Hierarchy


ITypeSystemService Properties

ITypeSystemService Properties
Public Properties
Collapse All

The properties of the ITypeSystemService class are listed here.

Public Properties
Name | Description
StaticEcoServices | The services that are available when there is no active EcoSpace. This is used mainly to provide support during design time.
TypeSystem | Returns the type system used by the EcoSpace. This may be used to read model information at runtime.


ITypeSystemService.StaticEcoServices Property

ITypeSystemService.StaticEcoServices Property
ITypeSystemService Interface Eco.Services Namespace See Also
Collapse All

The services that are available when there is no active EcoSpace. This is used mainly to provide support during design time.

C#
IEcoServiceProvider StaticEcoServices;
See Also
ITypeSystemService Interface
Eco.Services Namespace


ITypeSystemService.TypeSystem Property

ITypeSystemService.TypeSystem Property
ITypeSystemService Interface Eco.Services Namespace See Also
Collapse All

Returns the type system used by the EcoSpace. This may be used to read model information at runtime.

C#
IEcoTypeSystem TypeSystem;
See Also
ITypeSystemService Interface
Eco.Services Namespace


IUndoBlock Interface

IUndoBlock Interface
Inheritance Hierarchy See Also
Collapse All

Contains a collection of changes to elements within the local EcoSpace cache. Using the IUndoService these changes may be reversed or re-applied multiple times.

C#
public interface IUndoBlock;
Inheritance Hierarchy
Eco.Services.IUndoBlock
File

Services.cs

See Also
Inheritance Hierarchy


IUndoBlock Methods

IUndoBlock Methods
Public Methods
Collapse All

The methods of the IUndoBlock class are listed here.

Public Methods
Name | Description
GetChangedObjects | Iterates all element changes within the undo block and returns a list of modified objects.
Subscribe | This methods registers a subscriber and executes it whenever an object or a property is added to the undoblock.


IUndoBlock.GetChangedObjects Method

IUndoBlock.GetChangedObjects Method
IUndoBlock Interface Eco.Services Namespace See Also
Collapse All

Iterates all element changes within the undo block and returns a list of modified objects.

C#
IObjectList GetChangedObjects();
Remarks

If additional objects are modified and end up in the undoblock, the list will change automatically

See Also
IUndoBlock Interface
Eco.Services Namespace


IUndoBlock.Subscribe Method

IUndoBlock.Subscribe Method
IUndoBlock Interface Eco.Services Namespace See Also
Collapse All

This methods registers a subscriber and executes it whenever an object or a property is added to the undoblock.

C#
void Subscribe(
    ISubscriber subscriber
);
See Also
IUndoBlock Interface
Eco.Services Namespace


IUndoBlock Properties

IUndoBlock Properties
Public Properties
Collapse All

The properties of the IUndoBlock class are listed here.

Public Properties
Name | Description
ContainsChanges | Indicates whether or not the undo block contains any changes.
Name | The unique name of the undo block. Block names cannot be duplicated within the list they belong to.


IUndoBlock.ContainsChanges Property

IUndoBlock.ContainsChanges Property
IUndoBlock Interface Eco.Services Namespace See Also
Collapse All

Indicates whether or not the undo block contains any changes.

C#
bool ContainsChanges;
See Also
IUndoBlock Interface
Eco.Services Namespace


IUndoBlock.Name Property

IUndoBlock.Name Property
IUndoBlock Interface Eco.Services Namespace See Also
Collapse All

The unique name of the undo block. Block names cannot be duplicated within the list they belong to.

C#
string Name;
See Also
IUndoBlock Interface
Eco.Services Namespace


IUndoBlockList Interface

IUndoBlockList Interface
Inheritance Hierarchy See Also
Collapse All

Contains a collection of IUndoBlock and provides controlled access to rearranging the blocks.

C#
public interface IUndoBlockList : IEnumerable;
Inheritance Hierarchy
Eco.Services.IUndoBlockList
File

Services.cs

See Also
Inheritance Hierarchy


IUndoBlockList Methods

IUndoBlockList Methods
Public Methods
Collapse All

The methods of the IUndoBlockList class are listed here.

Public Methods
Name | Description
CanMergeBlock | Indicates whether or not the contents of two undo blocks may be merged into a single undo block.
CanMoveBlock | Determines whether or not it is possible to move a block to a new index.
IndexOf | Returns the index of the block named blockName.
MergeBlocks | Merges the contents of an undo block into the specified destination block.
MoveBlock | Moves an undo block to a new index in the list. An undo block must be at the top of the list (index 0) before its contents may be reversed or reapplied.
MoveToTop | Locates the specified block and moves it to the top of the list using MoveBlock.
RemoveBlock | Locates the specified block and removes it from the list. Once removed the contents of the undo block cannot be reversed or re-applied.
RenameBlock | Changes the name of an undo block in the list.
this | This is the overview for the this indexer overload.


IUndoBlockList.CanMergeBlock Method

IUndoBlockList.CanMergeBlock Method
IUndoBlockList Interface Eco.Services Namespace See Also
Collapse All

Indicates whether or not the contents of two undo blocks may be merged into a single undo block.

C#
bool CanMergeBlock(
    int curIndex,
    int newIndex
);
Parameters
Parameters | Description
curIndex | The index of the source block that should be tested.
newIndex | The index of the target block into which the source would be merged.
Returns

True if the merge is allowed.

Remarks

Examines if the block at curIndex can be merged with the block at newIndex. A merge will be denied if any of the undo blocks between the two indexes contain changes to any of the elements within the block referenced by curIndex.

See Also
IUndoBlockList Interface
Eco.Services Namespace


IUndoBlockList.CanMoveBlock Method

IUndoBlockList.CanMoveBlock Method
IUndoBlockList Interface Eco.Services Namespace See Also
Collapse All

Determines whether or not it is possible to move a block to a new index.

C#
bool CanMoveBlock(
    int curIndex,
    int newIndex
);
Parameters
Parameters | Description
curIndex | The index of the source block that should be tested.
newIndex | The new index for the block to be moved to.
Returns

True if the move is allowed.

Remarks

The move will be denied if any of the undo blocks between the two indexes contain changes to any of the elements within the block referenced by curIndex.

See Also
IUndoBlockList Interface
Eco.Services Namespace


IUndoBlockList.IndexOf Method

IUndoBlockList.IndexOf Method
IUndoBlockList Interface Eco.Services Namespace See Also
Collapse All

Returns the index of the block named blockName.

C#
int IndexOf(
    string blockName
);
Parameters
Parameters | Description
blockName | The name of the block for which to find the index.
Returns

Returns -1 if the blockName is not in the list, otherwise returns the zero based index of the block.

See Also
IUndoBlockList Interface
Eco.Services Namespace


IUndoBlockList.MergeBlocks Method

IUndoBlockList.MergeBlocks Method
IUndoBlockList Interface Eco.Services Namespace See Also
Collapse All

Merges the contents of an undo block into the specified destination block.

C#
void MergeBlocks(
    string destinationBlockName,
    string sourceBlockName
);
Parameters
Parameters | Description
destinationBlockName | The name of the block into which to merge the source block.
sourceBlockName | The name of the block to merge.
Remarks

Merges the changes of the source block into the destination block, and then removes the source block from the list. If both blocks contain a change to the same element then the earliest change will be kept.

Exceptions
Exceptions | Description
System.ArgumentException | Thrown if destinationBlockName or sourceBlockName are not in the list.
System.InvalidOperationException | Thrown if the blocks may not be merged.
See Also
IUndoBlockList Interface
Eco.Services Namespace


IUndoBlockList.MoveBlock Method

IUndoBlockList.MoveBlock Method
IUndoBlockList Interface Eco.Services Namespace See Also
Collapse All

Moves an undo block to a new index in the list. An undo block must be at the top of the list (index 0) before its contents may be reversed or reapplied.

C#
void MoveBlock(
    int curIndex,
    int newIndex
);
Parameters
Parameters | Description
curIndex | The index of the block that should be moved.
newIndex | The index of the target position.
Exceptions
Exceptions | Description
System.InvalidOperationException | Thrown if CanMoveBlock returns False.
See Also
IUndoBlockList Interface
Eco.Services Namespace


IUndoBlockList.MoveToTop Method

IUndoBlockList.MoveToTop Method
IUndoBlockList Interface Eco.Services Namespace See Also
Collapse All

Locates the specified block and moves it to the top of the list using MoveBlock.

C#
void MoveToTop(
    string blockName
);
Parameters
Parameters | Description
 | The name of the block to move to the top of the list.
Exceptions
Exceptions | Description
System.ArgumentException | Thrown if blockName is not found
System.InvalidOperationException | Thrown if CanMoveBlock returns false.
See Also
IUndoBlockList Interface
Eco.Services Namespace


IUndoBlockList.RemoveBlock Method

IUndoBlockList.RemoveBlock Method
IUndoBlockList Interface Eco.Services Namespace Related Topics See Also
Collapse All

Locates the specified block and removes it from the list. Once removed the contents of the undo block cannot be reversed or re-applied.

C#
bool RemoveBlock(
    string blockName
);
Parameters
Parameters | Description
blockName | The name of the block to remove.
Returns

Returns True if the block was removed.

Exceptions
Exceptions | Description
System.ArgumentException | Thrown if blockName is not found
System.InvalidOperationException | Thrown if the undo block cannot first be moved to the top of the list.
Related Topics

CanMoveBlock

See Also
IUndoBlockList Interface
Eco.Services Namespace
Related Topics


IUndoBlockList.RenameBlock Method

IUndoBlockList.RenameBlock Method
IUndoBlockList Interface Eco.Services Namespace See Also
Collapse All

Changes the name of an undo block in the list.

C#
void RenameBlock(
    string oldName,
    string newName
);
Parameters
Parameters | Description
oldName | Original name of block.
newName | New name of block.
Exceptions
Exceptions | Description
System.ArgumentException | Thrown if there is a block named newName. Thrown if there is no block named oldName.
See Also
IUndoBlockList Interface
Eco.Services Namespace


this Indexer

this Indexer

This is the overview for the this indexer overload.

Overload List
Name | Description
IUndoBlockList.this (int) | Returns the block at the specified index.
IUndoBlockList.this (string) | Returns the block in the list with the specified unique name.


IUndoBlockList.this Indexer (int)

IUndoBlockList.this Indexer (int)
IUndoBlockList Interface Eco.Services Namespace See Also
Collapse All

Returns the block at the specified index.

C#
IUndoBlock this[
    int index
];
Parameters
Parameters | Description
index | The index of the undo block to get.
Returns

Returns null if index is out of range.

See Also
IUndoBlockList Interface
Eco.Services Namespace


IUndoBlockList.this Indexer (string)

IUndoBlockList.this Indexer (string)
IUndoBlockList Interface Eco.Services Namespace See Also
Collapse All

Returns the block in the list with the specified unique name.

C#
IUndoBlock this[
    string name
];
Parameters
Parameters | Description
name | The unique name of the undo block to return.
Returns

Returns null if the undo block was not found.

See Also
IUndoBlockList Interface
Eco.Services Namespace


IUndoBlockList Properties

IUndoBlockList Properties
Public Properties
Collapse All

The properties of the IUndoBlockList class are listed here.

Public Properties
Name | Description
Count | Returns the number of blocks in the list.
TopBlock | Returns the undo block at the top of the list (index 0). If there are no undo blocks in the list then a new unnamed undo block will first be added to the list.


IUndoBlockList.Count Property

IUndoBlockList.Count Property
IUndoBlockList Interface Eco.Services Namespace See Also
Collapse All

Returns the number of blocks in the list.

C#
int Count;
See Also
IUndoBlockList Interface
Eco.Services Namespace


IUndoBlockList.TopBlock Property

IUndoBlockList.TopBlock Property
IUndoBlockList Interface Eco.Services Namespace See Also
Collapse All

Returns the undo block at the top of the list (index 0). If there are no undo blocks in the list then a new unnamed undo block will first be added to the list.

C#
IUndoBlock TopBlock;
See Also
IUndoBlockList Interface
Eco.Services Namespace


IUndoService Interface

IUndoService Interface
Inheritance Hierarchy See Also
Collapse All

Provides in-memory transaction and undo/redo support.

C#
public interface IUndoService;
Remarks

Using the IUndoService, the programmer is able to perform in-memory transactions on objects within the EcoSpace. These transactions may be committed or reversed at any point, ensuring that if an application process fails the objects affected by the process are returned to a previous state.

Inheritance Hierarchy
Eco.Services.IUndoService
    Eco.Services.ChainedUndoServiceBase
File

Services.cs

See Also
Inheritance Hierarchy


IUndoService Methods

IUndoService Methods
Public Methods
Collapse All

The methods of the IUndoService class are listed here.

Public Methods
Name | Description
CanRedoBlock | Indicates whether or not an undo block's contents may be re-applied.
CanUndoBlock | Indicates whether or not an undo block's contents may be reversed.
ClearAllUndoBlocks | Removes all undoblocks from the undo stack.
CommitTransaction | Keeps the changes recorded in an in-memory transaction.
GetUniqueBlockName | Creates and returns a new unique block name.
RedoBlock | Locates the undo block with the specified name and re-applies the changes stored within it.
RedoLatest | Re-applies the changes stored in the top most block of the redo list.
RollbackTransaction | Reverses the changes recorded in an in-memory transaction.
StartTransaction | Starts in in-memory transaction. Must be matched by either a call to CommitTransaction or RollbackTransaction.
StartUndoBlock | This is the overview for the StartUndoBlock method overload.
UndoBlock | Locates the undo block with the specified name and reverses the changes stored within it.
UndoLatest | Reverses the changes stored in the top most block of the undo list.


IUndoService.CanRedoBlock Method

IUndoService.CanRedoBlock Method
IUndoService Interface Eco.Services Namespace Related Topics See Also
Collapse All

Indicates whether or not an undo block's contents may be re-applied.

C#
bool CanRedoBlock(
    string blockName
);
Remarks

Before an undo block's contents may be re-applied the block must first be moved to the top of the redo list. This method returns whether or not the current block may be moved to the top of the list.

Exceptions
Exceptions | Description
System.ArgumentException | Thrown if blockName does not represent an existing block.
Related Topics

IUndoBlockList.CanMoveBlock

See Also
IUndoService Interface
Eco.Services Namespace
Related Topics


IUndoService.CanUndoBlock Method

IUndoService.CanUndoBlock Method
IUndoService Interface Eco.Services Namespace Related Topics See Also
Collapse All

Indicates whether or not an undo block's contents may be reversed.

C#
bool CanUndoBlock(
    string blockName
);
Remarks

Before an undo block's contents may be reversed the block must first be moved to the top of the undo list. This method returns whether or not the current block may be moved to the top of the list.

Exceptions
Exceptions | Description
System.ArgumentException | Thrown if blockName does not represent an existing block.
Related Topics

IUndoBlockList.CanMoveBlock

See Also
IUndoService Interface
Eco.Services Namespace
Related Topics


IUndoService.ClearAllUndoBlocks Method

IUndoService.ClearAllUndoBlocks Method
IUndoService Interface Eco.Services Namespace See Also
Collapse All

Removes all undoblocks from the undo stack.

C#
void ClearAllUndoBlocks();
Remarks

The contents of the undo blocks are not reversed, removing an undo block eliminates it from the system, making it impossible to use.

See Also
IUndoService Interface
Eco.Services Namespace


IUndoService.CommitTransaction Method

IUndoService.CommitTransaction Method
IUndoService Interface Eco.Services Namespace Related Topics See Also
Collapse All

Keeps the changes recorded in an in-memory transaction.

C#
void CommitTransaction();
Remarks

Committing a transaction will result it the EcoSpace removing any undo information it had stored to allow a rollback. Any changes made will be considered to be permanently applied to the local EcoSpace cache. Each call to CommitTransaction will decrement TransactionNesting. A transaction may not be comitted if any nested transaction was rolled back.

Exceptions
Exceptions | Description
System.InvalidOperationException | Thrown if there is no active transaction. Thrown if RollbackTransaction was executed on an nested transaction.
Related Topics

StartTransaction, RollbackTransaction

See Also
IUndoService Interface
Eco.Services Namespace
Related Topics


IUndoService.GetUniqueBlockName Method

IUndoService.GetUniqueBlockName Method
IUndoService Interface Eco.Services Namespace See Also
Collapse All

Creates and returns a new unique block name.

C#
string GetUniqueBlockName(
    string suggestedName
);
Parameters
Parameters | Description
suggestedName | The preferred name of the undo block.
Remarks

All undo blocks should have a unique name. This method returns a name for an undo block that is guaranteed to be unique. If the suggested name is not in use then its value will be returned unmodified, otherwise a unique variation of the suggested value is returned.

See Also
IUndoService Interface
Eco.Services Namespace


IUndoService.RedoBlock Method

IUndoService.RedoBlock Method
IUndoService Interface Eco.Services Namespace Related Topics See Also
Collapse All

Locates the undo block with the specified name and re-applies the changes stored within it.

C#
void RedoBlock(
    string blockName
);
Exceptions
Exceptions | Description
System.InvalidOperationException | Thrown if system is in a transaction. Thrown if the block cannot be undone
System.ArgumentException | Thrown if blockName does not represent an existing block.
Related Topics

IUndoService.CanUndoBlock

See Also
IUndoService Interface
Eco.Services Namespace
Related Topics


IUndoService.RedoLatest Method

IUndoService.RedoLatest Method
IUndoService Interface Eco.Services Namespace Related Topics See Also
Collapse All

Re-applies the changes stored in the top most block of the redo list.

C#
void RedoLatest();
Exceptions
Exceptions | Description
System.InvalidOperationException | Thrown if the EcoSpace is in a transaction.
Related Topics

IUndoService.CanUndoBlock

See Also
IUndoService Interface
Eco.Services Namespace
Related Topics


IUndoService.RollbackTransaction Method

IUndoService.RollbackTransaction Method
IUndoService Interface Eco.Services Namespace Related Topics See Also
Collapse All

Reverses the changes recorded in an in-memory transaction.

C#
void RollbackTransaction();
Remarks

Reverses the changes done since the first call to StartTransaction. Each call to RollbackTransaction will increment TransactionNesting. A transaction may not be comitted if any nested transaction was rolled back.

Exceptions
Exceptions | Description
System.InvalidOperationException | Thrown if there is no active transaction.
Related Topics

StartTransaction, CommitTransaction

See Also
IUndoService Interface
Eco.Services Namespace
Related Topics


IUndoService.StartTransaction Method

IUndoService.StartTransaction Method
IUndoService Interface Eco.Services Namespace Related Topics See Also
Collapse All

Starts in in-memory transaction. Must be matched by either a call to CommitTransaction or RollbackTransaction.

C#
void StartTransaction();
Remarks

Each call to StartTransaction will increment TransactionNesting. Having a TransactionNesting > 0 (IsInTransaction = true) will prevent used of the Undo features of this service.

Related Topics

CommitTransaction, RollbackTransaction

See Also
IUndoService Interface
Eco.Services Namespace
Related Topics


StartUndoBlock Method

StartUndoBlock Method

This is the overview for the StartUndoBlock method overload.

Overload List
Name | Description
IUndoService.StartUndoBlock () | Creates a new undo block with a unique name and positions it at the top of the undo list.
IUndoService.StartUndoBlock (string) | Creates a new undo block with a specified name and positions it at the top of the undo list.


IUndoService.StartUndoBlock Method ()

IUndoService.StartUndoBlock Method ()
IUndoService Interface Eco.Services Namespace See Also
Collapse All

Creates a new undo block with a unique name and positions it at the top of the undo list.

C#
void StartUndoBlock();
See Also
IUndoService Interface
Eco.Services Namespace


IUndoService.StartUndoBlock Method (string)

IUndoService.StartUndoBlock Method (string)
IUndoService Interface Eco.Services Namespace See Also
Collapse All

Creates a new undo block with a specified name and positions it at the top of the undo list.

C#
void StartUndoBlock(
    string blockName
);
Parameters
Parameters | Description
blockName | The name to use for the new undo block.
Exceptions
Exceptions | Description
System.InvalidOperationException | Thrown if name is already in use.
System.ArgumentException | Thrown if blockName exists.
See Also
IUndoService Interface
Eco.Services Namespace


IUndoService.UndoBlock Method

IUndoService.UndoBlock Method
IUndoService Interface Eco.Services Namespace Related Topics See Also
Collapse All

Locates the undo block with the specified name and reverses the changes stored within it.

C#
void UndoBlock(
    string blockName
);
Exceptions
Exceptions | Description
System.InvalidOperationException | Thrown if system is in a transaction. Thrown if the block cannot be undone
System.ArgumentException | Thrown if blockName does not represent an existing block.
Related Topics

IUndoService.CanUndoBlock

See Also
IUndoService Interface
Eco.Services Namespace
Related Topics


IUndoService.UndoLatest Method

IUndoService.UndoLatest Method
IUndoService Interface Eco.Services Namespace Related Topics See Also
Collapse All

Reverses the changes stored in the top most block of the undo list.

C#
void UndoLatest();
Exceptions
Exceptions | Description
System.InvalidOperationException | Thrown if the EcoSpace is in a transaction.
Related Topics

IUndoService.CanUndoBlock

See Also
IUndoService Interface
Eco.Services Namespace
Related Topics


IUndoService Properties

IUndoService Properties
Public Properties
Collapse All

The properties of the IUndoService class are listed here.

Public Properties
Name | Description
IsInTransaction | Returns True is TransactionNesting > 0, indicating there is an active transaction.
RedoList | Holds a collection of all undo blocks that may have their contents re-applied.
TransactionNesting | The number of times StartTransaction was called without a matching call to either CommitTransaction or RollbackTransaction.
UndoList | Holds a collection of all undo blocks that may have their contents reversed.


IUndoService.IsInTransaction Property

IUndoService.IsInTransaction Property
IUndoService Interface Eco.Services Namespace See Also
Collapse All

Returns True is TransactionNesting > 0, indicating there is an active transaction.

C#
bool IsInTransaction;
See Also
IUndoService Interface
Eco.Services Namespace


IUndoService.RedoList Property

IUndoService.RedoList Property
IUndoService Interface Eco.Services Namespace See Also
Collapse All

Holds a collection of all undo blocks that may have their contents re-applied.

C#
IUndoBlockList RedoList;
See Also
IUndoService Interface
Eco.Services Namespace


IUndoService.TransactionNesting Property

IUndoService.TransactionNesting Property
IUndoService Interface Eco.Services Namespace See Also
Collapse All

The number of times StartTransaction was called without a matching call to either CommitTransaction or RollbackTransaction.

C#
int TransactionNesting;
See Also
IUndoService Interface
Eco.Services Namespace


IUndoService.UndoList Property

IUndoService.UndoList Property
IUndoService Interface Eco.Services Namespace See Also
Collapse All

Holds a collection of all undo blocks that may have their contents reversed.

C#
IUndoBlockList UndoList;
See Also
IUndoService Interface
Eco.Services Namespace


IVariableFactoryService Interface

IVariableFactoryService Interface
Inheritance Hierarchy See Also
Collapse All

Provides a programmatic interface for creating what are essentially VariableHandle components. Variables created with this service can be used directly with the IOclService.

C#
public interface IVariableFactoryService;
Inheritance Hierarchy
Eco.Services.IVariableFactoryService
File

Services.cs

See Also
Inheritance Hierarchy


IVariableFactoryService Methods

IVariableFactoryService Methods
Public Methods
Collapse All

The methods of the IVariableFactoryService class are listed here.

Public Methods
Name | Description
CreateConstant | This is the overview for the CreateConstant method overload.
CreateConstraintCheck | Create ConstantCheck. Mainly for the internal use of the OCL evaluator.
CreateTypedNullReference | This is CreateTypedNullReference, a member of class IVariableFactoryService.
CreateTypedObjectList | This is the overview for the CreateTypedObjectList method overload.
CreateUntypedElementCollection | Creates a list that can contain any IElement.
CreateUntypedObjectList | Creates an object list that can contain any mix of objects from the model.
CreateVariable | This is the overview for the CreateVariable method overload.
CreateVariableList | This is the overview for the CreateVariableList method overload.


CreateConstant Method

CreateConstant Method

This is the overview for the CreateConstant method overload.

Overload List
Name | Description
IVariableFactoryService.CreateConstant (IClassifier, System.Object) | Creates a constant variable of the specified type with the specified value.
IVariableFactoryService.CreateConstant (System.Object) | Creates a constant variable with the specified value. The type of the variable is determined automatically.


IVariableFactoryService.CreateConstant Method (IClassifier, System.Object)

IVariableFactoryService.CreateConstant Method (IClassifier, System.Object)
IVariableFactoryService Interface Eco.Services Namespace See Also
Collapse All

Creates a constant variable of the specified type with the specified value.

C#
IElement CreateConstant(
    IClassifier classifier,
    System.Object asObject
);
Parameters
Parameters | Description
classifier | The type of the variable to create.
asObject | An object representing the value to assign to the new variable.
See Also
IVariableFactoryService Interface
Eco.Services Namespace


IVariableFactoryService.CreateConstant Method (System.Object)

IVariableFactoryService.CreateConstant Method (System.Object)
IVariableFactoryService Interface Eco.Services Namespace See Also
Collapse All

Creates a constant variable with the specified value. The type of the variable is determined automatically.

C#
IElement CreateConstant(
    System.Object asObject
);
See Also
IVariableFactoryService Interface
Eco.Services Namespace


IVariableFactoryService.CreateConstraintCheck Method

IVariableFactoryService.CreateConstraintCheck Method
IVariableFactoryService Interface Eco.Services Namespace See Also
Collapse All

Create ConstantCheck. Mainly for the internal use of the OCL evaluator.

C#
IConstraintCheck CreateConstraintCheck(
    object initialValue,
    IConstraint constraint,
    IObjectInstance subject
);
See Also
IVariableFactoryService Interface
Eco.Services Namespace


IVariableFactoryService.CreateTypedNullReference Method

IVariableFactoryService.CreateTypedNullReference Method
IVariableFactoryService Interface Eco.Services Namespace See Also
Collapse All
C#
IObjectInstance CreateTypedNullReference(
    IClass umlClass
);
Remarks

This is CreateTypedNullReference, a member of class IVariableFactoryService.

See Also
IVariableFactoryService Interface
Eco.Services Namespace


CreateTypedObjectList Method

CreateTypedObjectList Method

This is the overview for the CreateTypedObjectList method overload.

Overload List
Name | Description
IVariableFactoryService.CreateTypedObjectList (IClass, bool) | Creates an object list that can contain object instances of a specific modeled UML class and its subclasses.
IVariableFactoryService.CreateTypedObjectList (Type, bool) | Creates an object list that can contain object instances of a specific modeled UML class and its subclasses.


IVariableFactoryService.CreateTypedObjectList Method (IClass, bool)

IVariableFactoryService.CreateTypedObjectList Method (IClass, bool)
IVariableFactoryService Interface Eco.Services Namespace See Also
Collapse All

Creates an object list that can contain object instances of a specific modeled UML class and its subclasses.

C#
IObjectList CreateTypedObjectList(
    IClass umlClass,
    bool allowDuplicates
);
Parameters
Parameters | Description
umlClass | The modeled UML class to used to identify the what kind of object instances may be added to the list.
allowDuplicates | Specifies whehter or not the same object may be added twice.
See Also
IVariableFactoryService Interface
Eco.Services Namespace


IVariableFactoryService.CreateTypedObjectList Method (Type, bool)

IVariableFactoryService.CreateTypedObjectList Method (Type, bool)
IVariableFactoryService Interface Eco.Services Namespace See Also
Collapse All

Creates an object list that can contain object instances of a specific modeled UML class and its subclasses.

C#
IObjectList CreateTypedObjectList(
    Type type,
    bool allowDuplicates
);
Parameters
Parameters | Description
type | The .Net type to used to identify the what kind of object instances may be added to the list.
allowDuplicates | Specifies whehter or not the same object may be added twice.
See Also
IVariableFactoryService Interface
Eco.Services Namespace


IVariableFactoryService.CreateUntypedElementCollection Method

IVariableFactoryService.CreateUntypedElementCollection Method
IVariableFactoryService Interface Eco.Services Namespace See Also
Collapse All

Creates a list that can contain any IElement.

C#
IElementCollection CreateUntypedElementCollection(
    bool allowDuplicates
);
Parameters
Parameters | Description
allowDuplicates | Specifies whether or not two objects of equal value may be added.
See Also
IVariableFactoryService Interface
Eco.Services Namespace


IVariableFactoryService.CreateUntypedObjectList Method

IVariableFactoryService.CreateUntypedObjectList Method
IVariableFactoryService Interface Eco.Services Namespace See Also
Collapse All

Creates an object list that can contain any mix of objects from the model.

C#
IObjectList CreateUntypedObjectList(
    bool allowDuplicates
);
Parameters
Parameters | Description
allowDuplicates | Specifies whether or not the same object may be added twice.
See Also
IVariableFactoryService Interface
Eco.Services Namespace


CreateVariable Method

CreateVariable Method

This is the overview for the CreateVariable method overload.

Overload List
Name | Description
IVariableFactoryService.CreateVariable (IClassifier) | Creates a variable of the specified type.
IVariableFactoryService.CreateVariable (string) | Creates a variable of the specified type.
IVariableFactoryService.CreateVariable (Type) | Creates a variable of the specified type.


IVariableFactoryService.CreateVariable Method (IClassifier)

IVariableFactoryService.CreateVariable Method (IClassifier)
IVariableFactoryService Interface Eco.Services Namespace See Also
Collapse All

Creates a variable of the specified type.

C#
IElement CreateVariable(
    IClassifier classifier
);
Parameters
Parameters | Description
classifier | The type of variable to create.
See Also
IVariableFactoryService Interface
Eco.Services Namespace


IVariableFactoryService.CreateVariable Method (Type)

IVariableFactoryService.CreateVariable Method (Type)
IVariableFactoryService Interface Eco.Services Namespace See Also
Collapse All

Creates a variable of the specified type.

C#
IElement CreateVariable(
    Type type
);
Parameters
Parameters | Description
type | The .NET type that will be used to determine the type of variable to create.
See Also
IVariableFactoryService Interface
Eco.Services Namespace


IVariableFactoryService.CreateVariable Method (string)

IVariableFactoryService.CreateVariable Method (string)
IVariableFactoryService Interface Eco.Services Namespace See Also
Collapse All

Creates a variable of the specified type.

C#
IElement CreateVariable(
    string typeName
);
Parameters
Parameters | Description
typeName | The name of the IClassifier that will be used to determine the type of variable to create.
See Also
IVariableFactoryService Interface
Eco.Services Namespace


CreateVariableList Method

CreateVariableList Method

This is the overview for the CreateVariableList method overload.

Overload List
Name | Description
IVariableFactoryService.CreateVariableList () | Returns a variable list that can be used as a parameter to call IOclService.EvaluateAndSubscribe(Eco.ObjectRepresentation.IElement, Eco.UmlRt.IClassifier, Eco.ObjectRepresentation.IExternalVariableList, string, Eco.Subscription.ISubscriber, Eco.Subscription.ISubscriber).
IVariableFactoryService.CreateVariableList (string, IClassifier) | Returns a variable list that can be used as a parameter to call IOclService.EvaluateAndSubscribe(Eco.ObjectRepresentation.IElement, Eco.UmlRt.IClassifier, Eco.ObjectRepresentation.IExternalVariableList, string, Eco.Subscription.ISubscriber, Eco.Subscription.ISubscriber). Additionally a variable of a specific type is added to the list.
IVariableFactoryService.CreateVariableList (string, IElement) | Returns a variable list that can be used as a parameter to call IOclService.EvaluateAndSubscribe(Eco.ObjectRepresentation.IElement, Eco.UmlRt.IClassifier, Eco.ObjectRepresentation.IExternalVariableList, string, Eco.Subscription.ISubscriber, Eco.Subscription.ISubscriber). Additionally a variable with a specific value is added to the list.
IVariableFactoryService.CreateVariableList (string, object) | Returns a variable list that can be used as a parameter to call IOclService.EvaluateAndSubscribe(Eco.ObjectRepresentation.IElement, Eco.UmlRt.IClassifier, Eco.ObjectRepresentation.IExternalVariableList, string, Eco.Subscription.ISubscriber, Eco.Subscription.ISubscriber). Additionally a variable with a specific value is added to the list.
IVariableFactoryService.CreateVariableList (string, Type) | Returns a variable list that can be used as a parameter to call IOclService.EvaluateAndSubscribe(Eco.ObjectRepresentation.IElement, Eco.UmlRt.IClassifier, Eco.ObjectRepresentation.IExternalVariableList, string, Eco.Subscription.ISubscriber, Eco.Subscription.ISubscriber). Additionally a variable of a specific type is added to the list.


IVariableFactoryService.CreateVariableList Method ()

IVariableFactoryService.CreateVariableList Method ()
IVariableFactoryService Interface Eco.Services Namespace See Also
Collapse All

Returns a variable list that can be used as a parameter to call IOclService.EvaluateAndSubscribe(Eco.ObjectRepresentation.IElement, Eco.UmlRt.IClassifier, Eco.ObjectRepresentation.IExternalVariableList, string, Eco.Subscription.ISubscriber, Eco.Subscription.ISubscriber).

C#
IModifiableVariableList CreateVariableList();
See Also
IVariableFactoryService Interface
Eco.Services Namespace


IVariableFactoryService.CreateVariableList Method (string, IClassifier)

IVariableFactoryService.CreateVariableList Method (string, IClassifier)
IVariableFactoryService Interface Eco.Services Namespace See Also
Collapse All

Returns a variable list that can be used as a parameter to call IOclService.EvaluateAndSubscribe(Eco.ObjectRepresentation.IElement, Eco.UmlRt.IClassifier, Eco.ObjectRepresentation.IExternalVariableList, string, Eco.Subscription.ISubscriber, Eco.Subscription.ISubscriber). Additionally a variable of a specific type is added to the list.

C#
IModifiableVariableList CreateVariableList(
    string name,
    IClassifier classifier
);
Parameters
Parameters | Description
name | The name of the initial variable to add to the list.
classifier | The ECO type of the variable.
See Also
IVariableFactoryService Interface
Eco.Services Namespace


IVariableFactoryService.CreateVariableList Method (string, IElement)

IVariableFactoryService.CreateVariableList Method (string, IElement)
IVariableFactoryService Interface Eco.Services Namespace See Also
Collapse All

Returns a variable list that can be used as a parameter to call IOclService.EvaluateAndSubscribe(Eco.ObjectRepresentation.IElement, Eco.UmlRt.IClassifier, Eco.ObjectRepresentation.IExternalVariableList, string, Eco.Subscription.ISubscriber, Eco.Subscription.ISubscriber). Additionally a variable with a specific value is added to the list.

C#
IModifiableVariableList CreateVariableList(
    string name,
    IElement value
);
Parameters
Parameters | Description
name | The name of the initial variable to add to the list.
value | The value of the initial value.
See Also
IVariableFactoryService Interface
Eco.Services Namespace


IVariableFactoryService.CreateVariableList Method (string, Type)

IVariableFactoryService.CreateVariableList Method (string, Type)
IVariableFactoryService Interface Eco.Services Namespace See Also
Collapse All

Returns a variable list that can be used as a parameter to call IOclService.EvaluateAndSubscribe(Eco.ObjectRepresentation.IElement, Eco.UmlRt.IClassifier, Eco.ObjectRepresentation.IExternalVariableList, string, Eco.Subscription.ISubscriber, Eco.Subscription.ISubscriber). Additionally a variable of a specific type is added to the list.

C#
IModifiableVariableList CreateVariableList(
    string name,
    Type type
);
Parameters
Parameters | Description
name | The name of the initial variable to add to the list.
type | The .NET type used to determine the ECO type of the variable.
See Also
IVariableFactoryService Interface
Eco.Services Namespace


IVariableFactoryService.CreateVariableList Method (string, object)

IVariableFactoryService.CreateVariableList Method (string, object)
IVariableFactoryService Interface Eco.Services Namespace See Also
Collapse All

Returns a variable list that can be used as a parameter to call IOclService.EvaluateAndSubscribe(Eco.ObjectRepresentation.IElement, Eco.UmlRt.IClassifier, Eco.ObjectRepresentation.IExternalVariableList, string, Eco.Subscription.ISubscriber, Eco.Subscription.ISubscriber). Additionally a variable with a specific value is added to the list.

C#
IModifiableVariableList CreateVariableList(
    string name,
    object valueAsObject
);
Parameters
Parameters | Description
name | The name of the initial variable to add to the list.
valueAsObject | The value of the initial value.
See Also
IVariableFactoryService Interface
Eco.Services Namespace


IVariableFactoryService Properties

IVariableFactoryService Properties
Public Properties
Collapse All

The properties of the IVariableFactoryService class are listed here.

Public Properties
Name | Description
EmptyVariableList | Returns an Empty list that can be used as a parameter to call IOclService.EvaluateAndSubscribe(Eco.ObjectRepresentation.IElement, Eco.UmlRt.IClassifier, Eco.ObjectRepresentation.IExternalVariableList, string, Eco.Subscription.ISubscriber, Eco.Subscription.ISubscriber).
NullReference | Returns an ECO object used to represent a Null in OCL evaluations.


IVariableFactoryService.EmptyVariableList Property

IVariableFactoryService.EmptyVariableList Property
IVariableFactoryService Interface Eco.Services Namespace See Also
Collapse All

Returns an Empty list that can be used as a parameter to call IOclService.EvaluateAndSubscribe(Eco.ObjectRepresentation.IElement, Eco.UmlRt.IClassifier, Eco.ObjectRepresentation.IExternalVariableList, string, Eco.Subscription.ISubscriber, Eco.Subscription.ISubscriber).

C#
IExternalVariableList EmptyVariableList;
See Also
IVariableFactoryService Interface
Eco.Services Namespace


IVariableFactoryService.NullReference Property

IVariableFactoryService.NullReference Property
IVariableFactoryService Interface Eco.Services Namespace See Also
Collapse All

Returns an ECO object used to represent a Null in OCL evaluations.

C#
IObjectInstance NullReference;
See Also
IVariableFactoryService Interface
Eco.Services Namespace


IVersionService Interface

IVersionService Interface
Inheritance Hierarchy See Also
Collapse All

This service provides a way of working with modeled UML classes marked as Versioned in the model.

C#
public interface IVersionService;
Remarks

Versioned objects allow the application to browse through historical versions of business objects. Whenever a modification to a versioned object is saved to the persistent storage the previous information will be kept rather than replaced. When a historical representation of an object or one of its members is retrieved from the persistent storage all of its members will be read only.

Inheritance Hierarchy
Eco.Services.IVersionService
File

Services.cs

See Also
Inheritance Hierarchy


IVersionService Methods

IVersionService Methods
Public Methods
Collapse All

The methods of the IVersionService class are listed here.

Public Methods
Name | Description
ElementVersion | Returns the current version number of the specified element.
GetChangePointCondition | This is the overview for the GetChangePointCondition method overload.
GetVersion | Gets a historical prepresentation of the specified object or one of its members from the persistent storage.
TimeForVersion | Returns the date and time of the specified version number.
VersionAtTime | Returns the version number for the given date.


IVersionService.ElementVersion Method

IVersionService.ElementVersion Method
IVersionService Interface Eco.Services Namespace See Also
Collapse All

Returns the current version number of the specified element.

C#
int ElementVersion(
    IElement element
);
See Also
IVersionService Interface
Eco.Services Namespace


GetChangePointCondition Method

GetChangePointCondition Method

This is the overview for the GetChangePointCondition method overload.

Overload List
Name | Description
IVersionService.GetChangePointCondition (IEcoObject, int, int) | Creates an AbstractCondition which may then be used as a parameter for IPersistenceService.GetAllWithCondition(AbstractCondition) to return an IObjectList of all historical versions of a single object.
IVersionService.GetChangePointCondition (IEcoObject, int, int, string[]) | Creates an AbstractCondition which may then be used as a parameter for IPersistenceService.GetAllWithCondition(AbstractCondition) to return an IObjectList of all historical versions of a single object.
IVersionService.GetChangePointCondition (IObjectList, int, int) | Creates an AbstractCondition which may then be used as a parameter for IPersistenceService.GetAllWithCondition(AbstractCondition) to return an IObjectList of all historical versions of a list of objects.
IVersionService.GetChangePointCondition (IObjectList, int, int, string[]) | Creates an AbstractCondition which may then be used as a parameter for IPersistenceService.GetAllWithCondition(AbstractCondition) to return an IObjectList of all historical versions of a list of objects.


IVersionService.GetChangePointCondition Method (IEcoObject, int, int)

IVersionService.GetChangePointCondition Method (IEcoObject, int, int)
IVersionService Interface Eco.Services Namespace See Also
Collapse All

Creates an AbstractCondition which may then be used as a parameter for IPersistenceService.GetAllWithCondition(AbstractCondition) to return an IObjectList of all historical versions of a single object.

C#
AbstractCondition GetChangePointCondition(
    IEcoObject obj,
    int startVersion,
    int stopVersion
);
Parameters
Parameters | Description
obj | The object to retrieve historical information for.
startVersion | The first historical version to include.
stopVersion | The last inclusive version to include.
See Also
IVersionService Interface
Eco.Services Namespace


IVersionService.GetChangePointCondition Method (IEcoObject, int, int, string[])

IVersionService.GetChangePointCondition Method (IEcoObject, int, int, string[])
IVersionService Interface Eco.Services Namespace See Also
Collapse All

Creates an AbstractCondition which may then be used as a parameter for IPersistenceService.GetAllWithCondition(AbstractCondition) to return an IObjectList of all historical versions of a single object.

C#
AbstractCondition GetChangePointCondition(
    IEcoObject obj,
    int startVersion,
    int stopVersion,
    string[] members
);
Parameters
Parameters | Description
obj | The object to retrieve historical information for.
startVersion | The first historical version to include.
stopVersion | The last inclusive version to include.
members | If a historical version of a parent object such as a PurchaseOrder is required, where changes where made to its OrderLines collection (lines added/removed) you should specify "OrderLines" in this parameter. This is because the embedding for the object will belong to the OrderLine class (The OrderLine table will own the ID of the PurchaseOrder).
See Also
IVersionService Interface
Eco.Services Namespace


IVersionService.GetChangePointCondition Method (IObjectList, int, int)

IVersionService.GetChangePointCondition Method (IObjectList, int, int)
IVersionService Interface Eco.Services Namespace See Also
Collapse All

Creates an AbstractCondition which may then be used as a parameter for IPersistenceService.GetAllWithCondition(AbstractCondition) to return an IObjectList of all historical versions of a list of objects.

C#
AbstractCondition GetChangePointCondition(
    IObjectList objects,
    int startVersion,
    int stopVersion
);
Parameters
Parameters | Description
objects | A list of objects to include in the condition.
startVersion | The first historical version to include.
stopVersion | The last inclusive version to include.
See Also
IVersionService Interface
Eco.Services Namespace


IVersionService.GetChangePointCondition Method (IObjectList, int, int, string[])

IVersionService.GetChangePointCondition Method (IObjectList, int, int, string[])
IVersionService Interface Eco.Services Namespace See Also
Collapse All

Creates an AbstractCondition which may then be used as a parameter for IPersistenceService.GetAllWithCondition(AbstractCondition) to return an IObjectList of all historical versions of a list of objects.

C#
AbstractCondition GetChangePointCondition(
    IObjectList objects,
    int startVersion,
    int stopVersion,
    string[] members
);
Parameters
Parameters | Description
objects | A list of objects to include in the condition.
startVersion | The first historical version to include.
stopVersion | The last inclusive version to include.
members | If a historical version of a parent object such as a PurchaseOrder is required, where changes where made to its OrderLines collection (lines added/removed) you should specify "OrderLines" in this parameter. This is because the embedding for the object will belong to the OrderLine class (The OrderLine table will own the ID of the PurchaseOrder).
See Also
IVersionService Interface
Eco.Services Namespace


IVersionService.GetVersion Method

IVersionService.GetVersion Method
IVersionService Interface Eco.Services Namespace See Also
Collapse All

Gets a historical prepresentation of the specified object or one of its members from the persistent storage.

C#
IElement GetVersion(
    int version,
    IElement element
);
Parameters
Parameters | Description
version | The version number to retrieve.
element | The element of which to retrieve a historical version.
See Also
IVersionService Interface
Eco.Services Namespace


IVersionService.TimeForVersion Method

IVersionService.TimeForVersion Method
IVersionService Interface Eco.Services Namespace See Also
Collapse All

Returns the date and time of the specified version number.

C#
DateTime TimeForVersion(
    int version
);
Parameters
Parameters | Description
version | The version number to return the date and time for.
See Also
IVersionService Interface
Eco.Services Namespace


IVersionService.VersionAtTime Method

IVersionService.VersionAtTime Method
IVersionService Interface Eco.Services Namespace See Also
Collapse All

Returns the version number for the given date.

C#
int VersionAtTime(
    DateTime time
);
Parameters
Parameters | Description
time | The date and time to convert to an ordinal version number.
See Also
IVersionService Interface
Eco.Services Namespace


IVersionService Properties

IVersionService Properties
Public Properties
Collapse All

The properties of the IVersionService class are listed here.

Public Properties
Name | Description
CurrentVersion | Returns the version number used to represent "Now".
MaxSavedVersion | Returns the last version number saved to the persistent storage by the EcoSpace that provided this service reference.


IVersionService.CurrentVersion Property

IVersionService.CurrentVersion Property
IVersionService Interface Eco.Services Namespace See Also
Collapse All

Returns the version number used to represent "Now".

C#
int CurrentVersion;
Remarks

This property is for convenience only. It will always return the integer timestamp value of Int32.MaxValue (2147483647), this can be compared with the result obtained from ElementVersion() in order to determine whether or not an element is historical.

See Also
IVersionService Interface
Eco.Services Namespace


IVersionService.MaxSavedVersion Property

IVersionService.MaxSavedVersion Property
IVersionService Interface Eco.Services Namespace See Also
Collapse All

Returns the last version number saved to the persistent storage by the EcoSpace that provided this service reference.

C#
int MaxSavedVersion;
Remarks

Each time UpdateDatabase is executed, ECO will record the timestamp used by storing it in this property. Before any database updates are performed this property will return –1.

See Also
IVersionService Interface
Eco.Services Namespace


Eco.Services.ChangeActionKind Enumeration

Eco.Services.ChangeActionKind Enumeration

Specifies what kind of action should be taken when IPersistenceService.ApplyAllChanges is executed.

C#
public enum ChangeActionKind {
  Ignore,
  Discard,
  Keep,
  Verify,
  Reread,
  Undecided
}
Members
Members | Description
Ignore | Disregards the conflict.
Discard | Discards the local value.
Keep | Keeps the local value.
Verify | Checks the value in the persistent storage to confirm there is a conflicting value.
Reread | Re-reads the local value from the persistent storage.
Undecided | Temporarily ignores the conflict.
File

Services.cs


Eco.Services.ChangeKind Enumeration

Eco.Services.ChangeKind Enumeration

Identifies the kind of change that has taken place to an object in the persistent storage.

C#
public enum ChangeKind {
  MemberChanged,
  ObjectCreated,
  ObjectDeleted,
  LinkConflict,
  All
}
Members
Members | Description
MemberChanged | A member of the object was modified and saved to the database by another user.
ObjectCreated | Indicates that a new object instance has been created.
ObjectDeleted | Indicates that an existing object has been deleted by another user or another EcoSpace.
LinkConflict | Indicates that an object has added to or removed from an association.
All | Indicates that a number of changes may have taken place and that the whole object should be reloaded from the persistent storage.
File

Services.cs


Eco.Subscription Namespace

Eco.Subscription Namespace
Classes Interfaces
Collapse All

This is namespace Eco.Subscription.

Classes
Name | Description
EventSubscriber | Helper class for placing ECO subscriptions using .Net events.
Publisher | The publisher supports both ECO events (I.e. ISubscribers) and regular .NET events.
PublisherList | This is class Eco.Subscription.PublisherList.
PublisherListMulti | This is class Eco.Subscription.PublisherListMulti.
PublisherListSingle | This is class Eco.Subscription.PublisherListSingle.
SubscriberAdapterBase | This is class Eco.Subscription.SubscriberAdapterBase.
SubscriberPair | This is class Eco.Subscription.SubscriberPair.
TestSubscriber | Subscriber for testing, saves all recieved events. Deactivate() must be called after use to free resources, since it will otherwise be kept alive as long as Pulisher lives.
Top
Interfaces
Name | Description
ISubscriber | This is class Eco.Subscription.ISubscriber.


EventSubscriber Class

EventSubscriber Class
Inheritance Hierarchy See Also
Collapse All

Helper class for placing ECO subscriptions using .Net events.

C#
public sealed class EventSubscriber;
Remarks

This class is intended for using for subscribing to ECO events without the need for implementing ISubscriber or subclassing SubscriberAdapterBase. AsISubscriber is used as the subscriber parameter when subscribing to ECO events, Each time an ECO event is fired, it is passed on to Receive. The class it designed so that it will not be kept alive by the subscriptions as such, so if all references to it are gone, it will be garbage collected, and all subscriptions will be cancelled. Therefore you must keep a reference to the EventSubscriber for as long as the subscriptions shall be in place. Thus is normally done by assigning it to an instance variable e.g. on a form.

In many cases the EventSubscriber will be owned by a form, and in this case it is recomended that System.ComponentModel.Component.Dispose(bool) is overridden, and CancelAllSubscriptions is called if disposing is true. Otherwise, events may reach the disposed form before it (and thus the EventSubscriber) have been garbage-collected.

Inheritance Hierarchy
Eco.Subscription.EventSubscriber
File

EventSubscriber.cs

See Also
Inheritance Hierarchy


EventSubscriber Methods

EventSubscriber Methods
Public Methods
Collapse All

The methods of the EventSubscriber class are listed here.

Public Methods
Name | Description
CancelAllSubscriptions | Cancel all subscriptions. No further events vill be sent until new subscriptions are placed.


EventSubscriber.CancelAllSubscriptions Method

EventSubscriber.CancelAllSubscriptions Method
EventSubscriber Class Eco.Subscription Namespace See Also
Collapse All

Cancel all subscriptions. No further events vill be sent until new subscriptions are placed.

C#
public void CancelAllSubscriptions();
See Also
EventSubscriber Class
Eco.Subscription Namespace


EventSubscriber Properties

EventSubscriber Properties
Public Properties
Collapse All

The properties of the EventSubscriber class are listed here.

Public Properties
Name | Description
AsISubscriber | ISubscriber intended to be used as parameter when placing ECO subscription.


EventSubscriber.AsISubscriber Property

EventSubscriber.AsISubscriber Property
EventSubscriber Class Eco.Subscription Namespace See Also
Collapse All

ISubscriber intended to be used as parameter when placing ECO subscription.

C#
public ISubscriber AsISubscriber;
See Also
EventSubscriber Class
Eco.Subscription Namespace


EventSubscriber Events

EventSubscriber Events
Public Events
Collapse All

The events of the EventSubscriber class are listed here.

Public Events
Name | Description
Receive | Event that the ECO events are passed on to.


EventSubscriber.Receive Event

EventSubscriber.Receive Event
EventSubscriber Class Eco.Subscription Namespace See Also
Collapse All

Event that the ECO events are passed on to.

C#
public event System.EventHandler Receive;
See Also
EventSubscriber Class
Eco.Subscription Namespace


Publisher Class

Publisher Class
Inheritance Hierarchy See Also
Collapse All
C#
public sealed class Publisher;
Remarks

The publisher supports both ECO events (I.e. ISubscribers) and regular .NET events.

Inheritance Hierarchy
Eco.Subscription.Publisher
File

SupportClasses.cs

See Also
Inheritance Hierarchy


Publisher.Publisher Constructor

Publisher.Publisher Constructor
Publisher Class Eco.Subscription Namespace See Also
Collapse All
C#
public Publisher();
Remarks

This is Publisher, a member of class Publisher.

See Also
Publisher Class
Eco.Subscription Namespace


Publisher Methods

Publisher Methods
Public Methods
Collapse All

The methods of the Publisher class are listed here.

Public Methods
Name | Description
AddSubscription |
CollectSubscribers | This is CollectSubscribers, a member of class Publisher.
ContainsSubscriber | This is ContainsSubscriber, a member of class Publisher.
Send | This is Send, a member of class Publisher.


Publisher.AddSubscription Method

Publisher.AddSubscription Method
Publisher Class Eco.Subscription Namespace See Also
Collapse All
C#
public void AddSubscription(
    ISubscriber subscriber
);
Exceptions
Exceptions | Description
ArgumentNullException | Thrown if subscriber is null
See Also
Publisher Class
Eco.Subscription Namespace


Publisher.CollectSubscribers Method

Publisher.CollectSubscribers Method
Publisher Class Eco.Subscription Namespace See Also
Collapse All
C#
public void CollectSubscribers();
Remarks

This is CollectSubscribers, a member of class Publisher.

See Also
Publisher Class
Eco.Subscription Namespace


Publisher.ContainsSubscriber Method

Publisher.ContainsSubscriber Method
Publisher Class Eco.Subscription Namespace See Also
Collapse All
C#
public bool ContainsSubscriber(
    ISubscriber subscriber
);
Remarks

This is ContainsSubscriber, a member of class Publisher.

See Also
Publisher Class
Eco.Subscription Namespace


Publisher.Send Method

Publisher.Send Method
Publisher Class Eco.Subscription Namespace See Also
Collapse All
C#
public bool Send(
    System.Object sender,
    EventArgs e
);
Remarks

This is Send, a member of class Publisher.

See Also
Publisher Class
Eco.Subscription Namespace


Publisher Properties

Publisher Properties
Public Properties
Collapse All

The properties of the Publisher class are listed here.

Public Properties
Name | Description
HasSubscribers | This is HasSubscribers, a member of class Publisher.


Publisher.HasSubscribers Property

Publisher.HasSubscribers Property
Publisher Class Eco.Subscription Namespace See Also
Collapse All
C#
public bool HasSubscribers;
Remarks

This is HasSubscribers, a member of class Publisher.

See Also
Publisher Class
Eco.Subscription Namespace


Publisher Events

Publisher Events
Public Events
Collapse All

The events of the Publisher class are listed here.

Public Events
Name | Description
Event | This is Event, a member of class Publisher.


Publisher.Event Event

Publisher.Event Event
Publisher Class Eco.Subscription Namespace See Also
Collapse All
C#
public event EventHandler Event;
Remarks

This is Event, a member of class Publisher.

See Also
Publisher Class
Eco.Subscription Namespace


PublisherList Class

PublisherList Class
Inheritance Hierarchy See Also
Collapse All
C#
public abstract class PublisherList;
Remarks

This is class Eco.Subscription.PublisherList.

Inheritance Hierarchy
Eco.Subscription.PublisherList
    Eco.Subscription.PublisherListMulti
    Eco.Subscription.PublisherListSingle
File

SupportClasses.cs

See Also
Inheritance Hierarchy


PublisherList Methods

PublisherList Methods
Protected Methods Public Methods
Collapse All

The methods of the PublisherList class are listed here.

Protected Methods
Name | Description
TryAdd | This is TryAdd, a member of class PublisherList.
Top
Public Methods
Name | Description
EnsurePublisher | This is EnsurePublisher, a member of class PublisherList.
Remove | This is Remove, a member of class PublisherList.
this | This is this, a member of class PublisherList.


PublisherList.EnsurePublisher Method

PublisherList.EnsurePublisher Method
PublisherList Class Eco.Subscription Namespace See Also
Collapse All
C#
public static PublisherList EnsurePublisher(
    PublisherList oldList,
    int newIndex
);
Remarks

This is EnsurePublisher, a member of class PublisherList.

See Also
PublisherList Class
Eco.Subscription Namespace


PublisherList.Remove Method

PublisherList.Remove Method
PublisherList Class Eco.Subscription Namespace See Also
Collapse All
C#
public abstract PublisherList Remove(
    int index
);
Remarks

This is Remove, a member of class PublisherList.

See Also
PublisherList Class
Eco.Subscription Namespace


PublisherList.this Indexer

PublisherList.this Indexer
PublisherList Class Eco.Subscription Namespace See Also
Collapse All
C#
public abstract Publisher this[
    int index
];
Remarks

This is this, a member of class PublisherList.

See Also
PublisherList Class
Eco.Subscription Namespace


PublisherList.TryAdd Method

PublisherList.TryAdd Method
PublisherList Class Eco.Subscription Namespace See Also
Collapse All
C#
protected abstract bool TryAdd(
    int index,
    Publisher publisher
);
Remarks

This is TryAdd, a member of class PublisherList.

See Also
PublisherList Class
Eco.Subscription Namespace


PublisherList Properties

PublisherList Properties
Public Properties
Collapse All

The properties of the PublisherList class are listed here.

Public Properties
Name | Description
Length | This is Length, a member of class PublisherList.
MinIndex | This is MinIndex, a member of class PublisherList.


PublisherList.Length Property

PublisherList.Length Property
PublisherList Class Eco.Subscription Namespace See Also
Collapse All
C#
public abstract int Length;
Remarks

This is Length, a member of class PublisherList.

See Also
PublisherList Class
Eco.Subscription Namespace


PublisherList.MinIndex Property

PublisherList.MinIndex Property
PublisherList Class Eco.Subscription Namespace See Also
Collapse All
C#
public abstract int MinIndex;
Remarks

This is MinIndex, a member of class PublisherList.

See Also
PublisherList Class
Eco.Subscription Namespace


PublisherListMulti Class

PublisherListMulti Class
Inheritance Hierarchy See Also
Collapse All
C#
public sealed class PublisherListMulti : PublisherList;
Remarks

This is class Eco.Subscription.PublisherListMulti.

Inheritance Hierarchy
Eco.Subscription.PublisherList
    Eco.Subscription.PublisherListMulti
File

SupportClasses.cs

See Also
Inheritance Hierarchy


PublisherListMulti.PublisherListMulti Constructor

PublisherListMulti.PublisherListMulti Constructor
PublisherListMulti Class Eco.Subscription Namespace See Also
Collapse All
C#
public PublisherListMulti(
    int minIndex,
    int size
);
Remarks

This is PublisherListMulti, a member of class PublisherListMulti.

See Also
PublisherListMulti Class
Eco.Subscription Namespace


PublisherListMulti Methods

PublisherListMulti Methods
Protected Methods Public Methods
Collapse All

The methods of the PublisherListMulti class are listed here.

Protected Methods
Name | Description
TryAdd | This is TryAdd, a member of class PublisherListMulti.
Top
Public Methods
Name | Description
Remove | This is Remove, a member of class PublisherListMulti.
this | This is this, a member of class PublisherListMulti.


PublisherListMulti.Remove Method

PublisherListMulti.Remove Method
PublisherListMulti Class Eco.Subscription Namespace See Also
Collapse All
C#
public override PublisherList Remove(
    int index
);
Remarks

This is Remove, a member of class PublisherListMulti.

See Also
PublisherListMulti Class
Eco.Subscription Namespace


PublisherListMulti.this Indexer

PublisherListMulti.this Indexer
PublisherListMulti Class Eco.Subscription Namespace See Also
Collapse All
C#
public override Publisher this[
    int index
];
Remarks

This is this, a member of class PublisherListMulti.

See Also
PublisherListMulti Class
Eco.Subscription Namespace


PublisherListMulti.TryAdd Method

PublisherListMulti.TryAdd Method
PublisherListMulti Class Eco.Subscription Namespace See Also
Collapse All
C#
protected override bool TryAdd(
    int index,
    Publisher publisher
);
Remarks

This is TryAdd, a member of class PublisherListMulti.

See Also
PublisherListMulti Class
Eco.Subscription Namespace


PublisherListMulti Properties

PublisherListMulti Properties
Public Properties
Collapse All

The properties of the PublisherListMulti class are listed here.

Public Properties
Name | Description
Length | This is Length, a member of class PublisherListMulti.
MinIndex | This is MinIndex, a member of class PublisherListMulti.


PublisherListMulti.Length Property

PublisherListMulti.Length Property
PublisherListMulti Class Eco.Subscription Namespace See Also
Collapse All
C#
public override int Length;
Remarks

This is Length, a member of class PublisherListMulti.

See Also
PublisherListMulti Class
Eco.Subscription Namespace


PublisherListMulti.MinIndex Property

PublisherListMulti.MinIndex Property
PublisherListMulti Class Eco.Subscription Namespace See Also
Collapse All
C#
public override int MinIndex;
Remarks

This is MinIndex, a member of class PublisherListMulti.

See Also
PublisherListMulti Class
Eco.Subscription Namespace


PublisherListSingle Class

PublisherListSingle Class
Inheritance Hierarchy See Also
Collapse All
C#
public sealed class PublisherListSingle : PublisherList;
Remarks

This is class Eco.Subscription.PublisherListSingle.

Inheritance Hierarchy
Eco.Subscription.PublisherList
    Eco.Subscription.PublisherListSingle
File

SupportClasses.cs

See Also
Inheritance Hierarchy


PublisherListSingle.PublisherListSingle Constructor

PublisherListSingle.PublisherListSingle Constructor
PublisherListSingle Class Eco.Subscription Namespace See Also
Collapse All
C#
public PublisherListSingle(
    int index,
    Publisher publisher
);
Remarks

This is PublisherListSingle, a member of class PublisherListSingle.

See Also
PublisherListSingle Class
Eco.Subscription Namespace


PublisherListSingle Methods

PublisherListSingle Methods
Protected Methods Public Methods
Collapse All

The methods of the PublisherListSingle class are listed here.

Protected Methods
Name | Description
TryAdd | This is TryAdd, a member of class PublisherListSingle.
Top
Public Methods
Name | Description
Remove | This is Remove, a member of class PublisherListSingle.
this | This is this, a member of class PublisherListSingle.


PublisherListSingle.Remove Method

PublisherListSingle.Remove Method
PublisherListSingle Class Eco.Subscription Namespace See Also
Collapse All
C#
public override PublisherList Remove(
    int index
);
Remarks

This is Remove, a member of class PublisherListSingle.

See Also
PublisherListSingle Class
Eco.Subscription Namespace


PublisherListSingle.this Indexer

PublisherListSingle.this Indexer
PublisherListSingle Class Eco.Subscription Namespace See Also
Collapse All
C#
public override Publisher this[
    int index
];
Remarks

This is this, a member of class PublisherListSingle.

See Also
PublisherListSingle Class
Eco.Subscription Namespace


PublisherListSingle.TryAdd Method

PublisherListSingle.TryAdd Method
PublisherListSingle Class Eco.Subscription Namespace See Also
Collapse All
C#
protected override bool TryAdd(
    int index,
    Publisher publisher
);
Remarks

This is TryAdd, a member of class PublisherListSingle.

See Also
PublisherListSingle Class
Eco.Subscription Namespace


PublisherListSingle Properties

PublisherListSingle Properties
Public Properties
Collapse All

The properties of the PublisherListSingle class are listed here.

Public Properties
Name | Description
Length | This is Length, a member of class PublisherListSingle.
MinIndex | This is MinIndex, a member of class PublisherListSingle.


PublisherListSingle.Length Property

PublisherListSingle.Length Property
PublisherListSingle Class Eco.Subscription Namespace See Also
Collapse All
C#
public override int Length;
Remarks

This is Length, a member of class PublisherListSingle.

See Also
PublisherListSingle Class
Eco.Subscription Namespace


PublisherListSingle.MinIndex Property

PublisherListSingle.MinIndex Property
PublisherListSingle Class Eco.Subscription Namespace See Also
Collapse All
C#
public override int MinIndex;
Remarks

This is MinIndex, a member of class PublisherListSingle.

See Also
PublisherListSingle Class
Eco.Subscription Namespace


SubscriberAdapterBase Class

SubscriberAdapterBase Class
Inheritance Hierarchy See Also
Collapse All
C#
public abstract class SubscriberAdapterBase : ISubscriber;
Remarks

This is class Eco.Subscription.SubscriberAdapterBase.

Inheritance Hierarchy
Eco.Subscription.ISubscriber
    Eco.Subscription.SubscriberAdapterBase
File

SupportClasses.cs

See Also
Inheritance Hierarchy


SubscriberAdapterBase.SubscriberAdapterBase Constructor

SubscriberAdapterBase.SubscriberAdapterBase Constructor
SubscriberAdapterBase Class Eco.Subscription Namespace See Also
Collapse All
C#
protected SubscriberAdapterBase(
    object subscriber
);
Remarks

This is SubscriberAdapterBase, a member of class SubscriberAdapterBase.

See Also
SubscriberAdapterBase Class
Eco.Subscription Namespace


SubscriberAdapterBase Methods

SubscriberAdapterBase Methods
Protected Methods Public Methods
Collapse All

The methods of the SubscriberAdapterBase class are listed here.

Protected Methods
Name | Description
DoReceive | This is DoReceive, a member of class SubscriberAdapterBase.
Top
Public Methods
Name | Description
Deactivate | This is Deactivate, a member of class SubscriberAdapterBase.
IsAlive | This is IsAlive, a member of class SubscriberAdapterBase.


SubscriberAdapterBase.Deactivate Method

SubscriberAdapterBase.Deactivate Method
SubscriberAdapterBase Class Eco.Subscription Namespace See Also
Collapse All
C#
public void Deactivate();
Remarks

This is Deactivate, a member of class SubscriberAdapterBase.

See Also
SubscriberAdapterBase Class
Eco.Subscription Namespace


SubscriberAdapterBase.DoReceive Method

SubscriberAdapterBase.DoReceive Method
SubscriberAdapterBase Class Eco.Subscription Namespace See Also
Collapse All
C#
protected abstract void DoReceive(
    object sender,
    EventArgs e,
    object actualSubscriber
);
Remarks

This is DoReceive, a member of class SubscriberAdapterBase.

See Also
SubscriberAdapterBase Class
Eco.Subscription Namespace


SubscriberAdapterBase.IsAlive Method

SubscriberAdapterBase.IsAlive Method
SubscriberAdapterBase Class Eco.Subscription Namespace See Also
Collapse All
C#
public bool IsAlive();
Remarks

This is IsAlive, a member of class SubscriberAdapterBase.

See Also
SubscriberAdapterBase Class
Eco.Subscription Namespace


SubscriberAdapterBase Properties

SubscriberAdapterBase Properties
Public Properties
Collapse All

The properties of the SubscriberAdapterBase class are listed here.

Public Properties
Name | Description
ActualSubscriber | This is ActualSubscriber, a member of class SubscriberAdapterBase.


SubscriberAdapterBase.ActualSubscriber Property

SubscriberAdapterBase.ActualSubscriber Property
SubscriberAdapterBase Class Eco.Subscription Namespace See Also
Collapse All
C#
public object ActualSubscriber;
Remarks

This is ActualSubscriber, a member of class SubscriberAdapterBase.

See Also
SubscriberAdapterBase Class
Eco.Subscription Namespace


SubscriberPair Class

SubscriberPair Class
Inheritance Hierarchy See Also
Collapse All
C#
public sealed class SubscriberPair;
Remarks

This is class Eco.Subscription.SubscriberPair.

Inheritance Hierarchy
Eco.Subscription.SubscriberPair
File

SubscriptionInterface.cs

See Also
Inheritance Hierarchy


SubscriberPair.SubscriberPair Constructor

SubscriberPair.SubscriberPair Constructor
SubscriberPair Class Eco.Subscription Namespace See Also
Collapse All
C#
public SubscriberPair(
    ISubscriber valueChangeSubscriber,
    ISubscriber resubscribeSubscriber
);
Remarks

This is SubscriberPair, a member of class SubscriberPair.

See Also
SubscriberPair Class
Eco.Subscription Namespace


SubscriberPair Properties

SubscriberPair Properties
Public Properties
Collapse All

The properties of the SubscriberPair class are listed here.

Public Properties
Name | Description
Empty | This is Empty, a member of class SubscriberPair.
ResubscribeSubscriber | This is ResubscribeSubscriber, a member of class SubscriberPair.
ValueChangeSubscriber | This is ValueChangeSubscriber, a member of class SubscriberPair.


SubscriberPair.Empty Property

SubscriberPair.Empty Property
SubscriberPair Class Eco.Subscription Namespace See Also
Collapse All
C#
public static SubscriberPair Empty;
Remarks

This is Empty, a member of class SubscriberPair.

See Also
SubscriberPair Class
Eco.Subscription Namespace


SubscriberPair.ResubscribeSubscriber Property

SubscriberPair.ResubscribeSubscriber Property
SubscriberPair Class Eco.Subscription Namespace See Also
Collapse All
C#
public ISubscriber ResubscribeSubscriber;
Remarks

This is ResubscribeSubscriber, a member of class SubscriberPair.

See Also
SubscriberPair Class
Eco.Subscription Namespace


SubscriberPair.ValueChangeSubscriber Property

SubscriberPair.ValueChangeSubscriber Property
SubscriberPair Class Eco.Subscription Namespace See Also
Collapse All
C#
public ISubscriber ValueChangeSubscriber;
Remarks

This is ValueChangeSubscriber, a member of class SubscriberPair.

See Also
SubscriberPair Class
Eco.Subscription Namespace


TestSubscriber Class

TestSubscriber Class
Inheritance Hierarchy See Also
Collapse All
C#
public sealed class TestSubscriber : ISubscriber;
Remarks

Subscriber for testing, saves all recieved events. Deactivate() must be called after use to free resources, since it will otherwise be kept alive as long as Pulisher lives.

Inheritance Hierarchy
Eco.Subscription.ISubscriber
    Eco.Subscription.TestSubscriber
File

SupportClasses.cs

See Also
Inheritance Hierarchy


TestSubscriber.TestSubscriber Constructor

TestSubscriber.TestSubscriber Constructor
TestSubscriber Class Eco.Subscription Namespace See Also
Collapse All
C#
public TestSubscriber(
    object subscriber
);
Remarks

This is TestSubscriber, a member of class TestSubscriber.

See Also
TestSubscriber Class
Eco.Subscription Namespace


TestSubscriber Methods

TestSubscriber Methods
Public Methods
Collapse All

The methods of the TestSubscriber class are listed here.

Public Methods
Name | Description
Clear | This is Clear, a member of class TestSubscriber.
Deactivate | This is Deactivate, a member of class TestSubscriber.


TestSubscriber.Clear Method

TestSubscriber.Clear Method
TestSubscriber Class Eco.Subscription Namespace See Also
Collapse All
C#
public void Clear();
Remarks

This is Clear, a member of class TestSubscriber.

See Also
TestSubscriber Class
Eco.Subscription Namespace


TestSubscriber.Deactivate Method

TestSubscriber.Deactivate Method
TestSubscriber Class Eco.Subscription Namespace See Also
Collapse All
C#
public void Deactivate();
Remarks

This is Deactivate, a member of class TestSubscriber.

See Also
TestSubscriber Class
Eco.Subscription Namespace


TestSubscriber Properties

TestSubscriber Properties
Public Properties
Collapse All

The properties of the TestSubscriber class are listed here.

Public Properties
Name | Description
Events | This is Events, a member of class TestSubscriber.


TestSubscriber.Events Property

TestSubscriber.Events Property
TestSubscriber Class Eco.Subscription Namespace See Also
Collapse All
C#
public EventArgs Events;
Remarks

This is Events, a member of class TestSubscriber.

See Also
TestSubscriber Class
Eco.Subscription Namespace


ISubscriber Interface

ISubscriber Interface
Inheritance Hierarchy See Also
Collapse All
C#
public interface ISubscriber;
Remarks

This is class Eco.Subscription.ISubscriber.

Inheritance Hierarchy
Eco.Subscription.ISubscriber
    Eco.Subscription.SubscriberAdapterBase
    Eco.Subscription.TestSubscriber
File

SubscriptionInterface.cs

See Also
Inheritance Hierarchy


ISubscriber Methods

ISubscriber Methods
Public Methods
Collapse All

The methods of the ISubscriber class are listed here.

Public Methods
Name | Description
IsAlive | This is IsAlive, a member of class ISubscriber.
Receive | Return False if no longer alive


ISubscriber.IsAlive Method

ISubscriber.IsAlive Method
ISubscriber Interface Eco.Subscription Namespace See Also
Collapse All
C#
bool IsAlive();
Remarks

This is IsAlive, a member of class ISubscriber.

See Also
ISubscriber Interface
Eco.Subscription Namespace


ISubscriber.Receive Method

ISubscriber.Receive Method
ISubscriber Interface Eco.Subscription Namespace See Also
Collapse All
C#
bool Receive(
    System.Object sender,
    EventArgs e
);
Remarks

Return False if no longer alive

See Also
ISubscriber Interface
Eco.Subscription Namespace


Eco.Support Namespace

Eco.Support Namespace
Classes
Collapse All

This is namespace Eco.Support.

Classes
Name | Description
CommaTextSupport | This is class Eco.Support.CommaTextSupport.
EcoSupport | Helper class used internally
HelpHelpers | For internal use only
SerializationSupport | This is class Eco.Support.SerializationSupport.
TypeSupport | This is class Eco.Support.TypeSupport.


CommaTextSupport Class

CommaTextSupport Class
Inheritance Hierarchy See Also
Collapse All
C#
public abstract class CommaTextSupport;
Remarks

This is class Eco.Support.CommaTextSupport.

Inheritance Hierarchy
Eco.Support.CommaTextSupport
File

EcoSupport.cs

See Also
Inheritance Hierarchy


CommaTextSupport Methods

CommaTextSupport Methods
Public Methods
Collapse All

The methods of the CommaTextSupport class are listed here.

Public Methods
Name | Description
CommaTextToStringCollection | Note this implementation strips only extra spaces, which makes it slightly incompatible with the old version, but on the other hand allows quoting strings with arbitrary characters.
StringCollectionToCommaText | This is StringCollectionToCommaText, a member of class CommaTextSupport.


CommaTextSupport.CommaTextToStringCollection Method

CommaTextSupport.CommaTextToStringCollection Method
CommaTextSupport Class Eco.Support Namespace See Also
Collapse All
C#
public static IList<string> CommaTextToStringCollection(
    string s
);
Remarks

Note this implementation strips only extra spaces, which makes it slightly incompatible with the old version, but on the other hand allows quoting strings with arbitrary characters.

See Also
CommaTextSupport Class
Eco.Support Namespace


CommaTextSupport.StringCollectionToCommaText Method

CommaTextSupport.StringCollectionToCommaText Method
CommaTextSupport Class Eco.Support Namespace See Also
Collapse All
C#
public static string StringCollectionToCommaText(
    ICollection<string> strCollection
);
Remarks

This is StringCollectionToCommaText, a member of class CommaTextSupport.

See Also
CommaTextSupport Class
Eco.Support Namespace


EcoSupport Class

EcoSupport Class
Inheritance Hierarchy See Also
Collapse All

Helper class used internally

C#
public static class EcoSupport;
Inheritance Hierarchy
Eco.Support.EcoSupport
File

EcoSupport.cs

See Also
Inheritance Hierarchy


EcoSupport Fields

EcoSupport Fields
Public Fields
Collapse All

The fields of the EcoSupport class are listed here.

Public Fields
Name | Description
EmptyAttributeCollection | This is EmptyAttributeCollection, a member of class EcoSupport.
EmptyEventDescriptorCollection | This is EmptyEventDescriptorCollection, a member of class EcoSupport.


EcoSupport.EmptyAttributeCollection Field

EcoSupport.EmptyAttributeCollection Field
EcoSupport Class Eco.Support Namespace See Also
Collapse All
C#
public static readonly AttributeCollection EmptyAttributeCollection = AttributeCollection.Empty;
Remarks

This is EmptyAttributeCollection, a member of class EcoSupport.

See Also
EcoSupport Class
Eco.Support Namespace


EcoSupport.EmptyEventDescriptorCollection Field

EcoSupport.EmptyEventDescriptorCollection Field
EcoSupport Class Eco.Support Namespace See Also
Collapse All
C#
public static readonly EventDescriptorCollection EmptyEventDescriptorCollection = EventDescriptorCollection.Empty;
Remarks

This is EmptyEventDescriptorCollection, a member of class EcoSupport.

See Also
EcoSupport Class
Eco.Support Namespace


EcoSupport Methods

EcoSupport Methods
Public Methods
Collapse All

The methods of the EcoSupport class are listed here.

Public Methods
Name | Description
ByteArraysAreEqual | This is ByteArraysAreEqual, a member of class EcoSupport.
CaseIndependentCompare | This is CaseIndependentCompare, a member of class EcoSupport.
CaseIndependentEqual | This is CaseIndependentEqual, a member of class EcoSupport.
CharArraysAreEqual | This is CharArraysAreEqual, a member of class EcoSupport.
FixLocalizedLineFeeds | This is FixLocalizedLineFeeds, a member of class EcoSupport.
GetHashCode | This is GetHashCode, a member of class EcoSupport.
GetMethod | This is GetMethod, a member of class EcoSupport.
MakeRelativePath | This is MakeRelativePath, a member of class EcoSupport.
ReferenceEqualsFix | FIx for fact that = on object does an Equals in Delphi.Net. Need own method since System.Object.ReferenceEquals is not available for CF Can't be named ReferenceEquals due to Delphi compiler treating it as ambiguos overload.
SeparateStringCollection | This is SeparateStringCollection, a member of class EcoSupport.
StringsToLines | This is StringsToLines, a member of class EcoSupport.
StrToIntDef | This is StrToIntDef, a member of class EcoSupport.
TraceLogConditional | This is TraceLogConditional, a member of class EcoSupport.


EcoSupport.ByteArraysAreEqual Method

EcoSupport.ByteArraysAreEqual Method
EcoSupport Class Eco.Support Namespace See Also
Collapse All
C#
public static bool ByteArraysAreEqual(
    System.Object value1,
    System.Object value2
);
Remarks

This is ByteArraysAreEqual, a member of class EcoSupport.

See Also
EcoSupport Class
Eco.Support Namespace


EcoSupport.CaseIndependentCompare Method

EcoSupport.CaseIndependentCompare Method
EcoSupport Class Eco.Support Namespace See Also
Collapse All
C#
public static int CaseIndependentCompare(
    string s1,
    string s2
);
Remarks

This is CaseIndependentCompare, a member of class EcoSupport.

See Also
EcoSupport Class
Eco.Support Namespace


EcoSupport.CaseIndependentEqual Method

EcoSupport.CaseIndependentEqual Method
EcoSupport Class Eco.Support Namespace See Also
Collapse All
C#
public static bool CaseIndependentEqual(
    string s1,
    string s2
);
Remarks

This is CaseIndependentEqual, a member of class EcoSupport.

See Also
EcoSupport Class
Eco.Support Namespace


EcoSupport.CharArraysAreEqual Method

EcoSupport.CharArraysAreEqual Method
EcoSupport Class Eco.Support Namespace See Also
Collapse All
C#
public static bool CharArraysAreEqual(
    System.Object value1,
    System.Object value2
);
Remarks

This is CharArraysAreEqual, a member of class EcoSupport.

See Also
EcoSupport Class
Eco.Support Namespace


EcoSupport.FixLocalizedLineFeeds Method

EcoSupport.FixLocalizedLineFeeds Method
EcoSupport Class Eco.Support Namespace See Also
Collapse All
C#
public static string FixLocalizedLineFeeds(
    string s
);
Remarks

This is FixLocalizedLineFeeds, a member of class EcoSupport.

See Also
EcoSupport Class
Eco.Support Namespace


EcoSupport.GetHashCode Method

EcoSupport.GetHashCode Method
EcoSupport Class Eco.Support Namespace See Also
Collapse All
C#
public static int GetHashCode(
    string value
);
Remarks

This is GetHashCode, a member of class EcoSupport.

See Also
EcoSupport Class
Eco.Support Namespace


EcoSupport.GetMethod Method

EcoSupport.GetMethod Method
EcoSupport Class Eco.Support Namespace See Also
Collapse All
C#
public static MethodInfo GetMethod(
    System.Type type,
    string name,
    Type[] signature
);
Remarks

This is GetMethod, a member of class EcoSupport.

See Also
EcoSupport Class
Eco.Support Namespace


EcoSupport.MakeRelativePath Method

EcoSupport.MakeRelativePath Method
EcoSupport Class Eco.Support Namespace See Also
Collapse All
C#
public static string MakeRelativePath(
    string rootPath,
    string fileName
);
Remarks

This is MakeRelativePath, a member of class EcoSupport.

See Also
EcoSupport Class
Eco.Support Namespace


EcoSupport.ReferenceEqualsFix Method

EcoSupport.ReferenceEqualsFix Method
EcoSupport Class Eco.Support Namespace See Also
Collapse All
C#
public static bool ReferenceEqualsFix(
    object o1,
    object o2
);
Remarks

FIx for fact that = on object does an Equals in Delphi.Net. Need own method since System.Object.ReferenceEquals is not available for CF Can't be named ReferenceEquals due to Delphi compiler treating it as ambiguos overload.

See Also
EcoSupport Class
Eco.Support Namespace


EcoSupport.SeparateStringCollection Method

EcoSupport.SeparateStringCollection Method
EcoSupport Class Eco.Support Namespace See Also
Collapse All
C#
public static string SeparateStringCollection(
    ICollection<string> strings,
    string separator,
    string preString,
    string postString
);
Remarks

This is SeparateStringCollection, a member of class EcoSupport.

See Also
EcoSupport Class
Eco.Support Namespace


EcoSupport.StringsToLines Method

EcoSupport.StringsToLines Method
EcoSupport Class Eco.Support Namespace See Also
Collapse All
C#
public static string StringsToLines(
    IEnumerable objs
);
Remarks

This is StringsToLines, a member of class EcoSupport.

See Also
EcoSupport Class
Eco.Support Namespace


EcoSupport.StrToIntDef Method

EcoSupport.StrToIntDef Method
EcoSupport Class Eco.Support Namespace See Also
Collapse All
C#
public static int StrToIntDef(
    string s,
    int defaultValue
);
Remarks

This is StrToIntDef, a member of class EcoSupport.

See Also
EcoSupport Class
Eco.Support Namespace


EcoSupport.TraceLogConditional Method

EcoSupport.TraceLogConditional Method
EcoSupport Class Eco.Support Namespace See Also
Collapse All
C#
public static void TraceLogConditional(
    bool condition,
    string logMessage,
    string category
);
Remarks

This is TraceLogConditional, a member of class EcoSupport.

See Also
EcoSupport Class
Eco.Support Namespace


EcoSupport Properties

EcoSupport Properties
Public Properties
Collapse All

The properties of the EcoSupport class are listed here.

Public Properties
Name | Description
CurrentCultureInfo | This is CurrentCultureInfo, a member of class EcoSupport.


EcoSupport.CurrentCultureInfo Property

EcoSupport.CurrentCultureInfo Property
EcoSupport Class Eco.Support Namespace See Also
Collapse All
C#
public static CultureInfo CurrentCultureInfo;
Remarks

This is CurrentCultureInfo, a member of class EcoSupport.

See Also
EcoSupport Class
Eco.Support Namespace


HelpHelpers Class

HelpHelpers Class
Inheritance Hierarchy See Also
Collapse All

For internal use only

C#
public sealed class HelpHelpers;
Remarks

HelpContexts must also be defined in appcoreideContext.pas!

Inheritance Hierarchy
Eco.Support.HelpHelpers
File

HelpHelpers.cs

See Also
Inheritance Hierarchy


HelpHelpers Fields

HelpHelpers Fields
Public Fields
Collapse All

The fields of the HelpHelpers class are listed here.

Public Fields
Name | Description
hcCodegenAutoform | This is hcCodegenAutoform, a member of class HelpHelpers.
hcEcoConfigureCleanPSForm | This is hcEcoConfigureCleanPSForm, a member of class HelpHelpers.
hcEcoDbEvolutionForm | This is hcEcoDbEvolutionForm, a member of class HelpHelpers.
hcEcoPackageSelector | This is hcEcoPackageSelector, a member of class HelpHelpers.
hcEcoPrototyper | This is hcEcoPrototyper, a member of class HelpHelpers.
hcEcoSpaceDesignerForm | This is hcEcoSpaceDesignerForm, a member of class HelpHelpers.
hcOCLEditor | This is hcOCLEditor, a member of class HelpHelpers.
hcReferredECOPackages | This is hcReferredECOPackages, a member of class HelpHelpers.


HelpHelpers.hcCodegenAutoform Field

HelpHelpers.hcCodegenAutoform Field
HelpHelpers Class Eco.Support Namespace See Also
Collapse All
C#
public static string hcCodegenAutoform = HelpALinkPrefix + "13338";
Remarks

This is hcCodegenAutoform, a member of class HelpHelpers.

See Also
HelpHelpers Class
Eco.Support Namespace


HelpHelpers.hcEcoConfigureCleanPSForm Field

HelpHelpers.hcEcoConfigureCleanPSForm Field
HelpHelpers Class Eco.Support Namespace See Also
Collapse All
C#
public static string hcEcoConfigureCleanPSForm = HelpALinkPrefix + "13336";
Remarks

This is hcEcoConfigureCleanPSForm, a member of class HelpHelpers.

See Also
HelpHelpers Class
Eco.Support Namespace


HelpHelpers.hcEcoDbEvolutionForm Field

HelpHelpers.hcEcoDbEvolutionForm Field
HelpHelpers Class Eco.Support Namespace See Also
Collapse All
C#
public static string hcEcoDbEvolutionForm = HelpALinkPrefix + "13335";
Remarks

This is hcEcoDbEvolutionForm, a member of class HelpHelpers.

See Also
HelpHelpers Class
Eco.Support Namespace


HelpHelpers.hcEcoPackageSelector Field

HelpHelpers.hcEcoPackageSelector Field
HelpHelpers Class Eco.Support Namespace See Also
Collapse All
C#
public static string hcEcoPackageSelector = HelpALinkPrefix + "13333";
Remarks

This is hcEcoPackageSelector, a member of class HelpHelpers.

See Also
HelpHelpers Class
Eco.Support Namespace


HelpHelpers.hcEcoPrototyper Field

HelpHelpers.hcEcoPrototyper Field
HelpHelpers Class Eco.Support Namespace See Also
Collapse All
C#
public static string hcEcoPrototyper = HelpALinkPrefix + "13339";
Remarks

This is hcEcoPrototyper, a member of class HelpHelpers.

See Also
HelpHelpers Class
Eco.Support Namespace


HelpHelpers.hcEcoSpaceDesignerForm Field

HelpHelpers.hcEcoSpaceDesignerForm Field
HelpHelpers Class Eco.Support Namespace See Also
Collapse All
C#
public static string hcEcoSpaceDesignerForm = HelpALinkPrefix + "13332";
Remarks

This is hcEcoSpaceDesignerForm, a member of class HelpHelpers.

See Also
HelpHelpers Class
Eco.Support Namespace


HelpHelpers.hcOCLEditor Field

HelpHelpers.hcOCLEditor Field
HelpHelpers Class Eco.Support Namespace See Also
Collapse All
C#
public static string hcOCLEditor = HelpALinkPrefix + "13331";
Remarks

This is hcOCLEditor, a member of class HelpHelpers.

See Also
HelpHelpers Class
Eco.Support Namespace


HelpHelpers.hcReferredECOPackages Field

HelpHelpers.hcReferredECOPackages Field
HelpHelpers Class Eco.Support Namespace See Also
Collapse All
C#
public static string hcReferredECOPackages = HelpALinkPrefix + "13337";
Remarks

This is hcReferredECOPackages, a member of class HelpHelpers.

See Also
HelpHelpers Class
Eco.Support Namespace


SerializationSupport Class

SerializationSupport Class
Inheritance Hierarchy See Also
Collapse All
C#
public abstract class SerializationSupport;
Remarks

This is class Eco.Support.SerializationSupport.

Inheritance Hierarchy
Eco.Support.SerializationSupport
File

EcoSupport.cs

See Also
Inheritance Hierarchy


SerializationSupport Methods

SerializationSupport Methods
Public Methods
Collapse All

The methods of the SerializationSupport class are listed here.

Public Methods
Name | Description
Read | This is Read, a member of class SerializationSupport.
Write | This is Write, a member of class SerializationSupport.


SerializationSupport.Read Method

SerializationSupport.Read Method
SerializationSupport Class Eco.Support Namespace See Also
Collapse All
C#
public static object Read(
    Stream source,
    System.Type type,
    bool allowNull
);
Remarks

This is Read, a member of class SerializationSupport.

See Also
SerializationSupport Class
Eco.Support Namespace


SerializationSupport.Write Method

SerializationSupport.Write Method
SerializationSupport Class Eco.Support Namespace See Also
Collapse All
C#
public static void Write(
    Stream target,
    object value,
    bool allowNull
);
Remarks

This is Write, a member of class SerializationSupport.

See Also
SerializationSupport Class
Eco.Support Namespace


TypeSupport Class

TypeSupport Class
Inheritance Hierarchy See Also
Collapse All
C#
public sealed class TypeSupport;
Remarks

This is class Eco.Support.TypeSupport.

Inheritance Hierarchy
Eco.Support.TypeSupport
File

EcoSupport.cs

See Also
Inheritance Hierarchy


TypeSupport Fields

TypeSupport Fields
Public Fields
Collapse All

The fields of the TypeSupport class are listed here.

Public Fields
Name | Description
elapsedTime | This is elapsedTime, a member of class TypeSupport.
IsRunningInIDE | This is IsRunningInIDE, a member of class TypeSupport.


TypeSupport.elapsedTime Field

TypeSupport.elapsedTime Field
TypeSupport Class Eco.Support Namespace See Also
Collapse All
C#
public static TimeSpan elapsedTime = new TimeSpan();
Remarks

This is elapsedTime, a member of class TypeSupport.

See Also
TypeSupport Class
Eco.Support Namespace


TypeSupport.IsRunningInIDE Field

TypeSupport.IsRunningInIDE Field
TypeSupport Class Eco.Support Namespace See Also
Collapse All
C#
public static bool IsRunningInIDE = false;
Remarks

This is IsRunningInIDE, a member of class TypeSupport.

See Also
TypeSupport Class
Eco.Support Namespace


TypeSupport Methods

TypeSupport Methods
Public Methods
Collapse All

The methods of the TypeSupport class are listed here.

Public Methods
Name | Description
GetAssemblyNameValue | This is the overview for the GetAssemblyNameValue method overload.
GetObjectFromType | This is GetObjectFromType, a member of class TypeSupport.
IsNullable | This is IsNullable, a member of class TypeSupport.
ResolveType | This is the overview for the ResolveType method overload.


GetAssemblyNameValue Method

GetAssemblyNameValue Method

This is the overview for the GetAssemblyNameValue method overload.

Overload List
Name | Description
TypeSupport.GetAssemblyNameValue (Assembly, string) | This is GetAssemblyNameValue, a member of class TypeSupport.
TypeSupport.GetAssemblyNameValue (string, string) | This is GetAssemblyNameValue, a member of class TypeSupport.


TypeSupport.GetAssemblyNameValue Method (Assembly, string)

TypeSupport.GetAssemblyNameValue Method (Assembly, string)
TypeSupport Class Eco.Support Namespace See Also
Collapse All
C#
public static string GetAssemblyNameValue(
    Assembly assembly,
    string name
);
Remarks

This is GetAssemblyNameValue, a member of class TypeSupport.

See Also
TypeSupport Class
Eco.Support Namespace


TypeSupport.GetAssemblyNameValue Method (string, string)

TypeSupport.GetAssemblyNameValue Method (string, string)
TypeSupport Class Eco.Support Namespace See Also
Collapse All
C#
public static string GetAssemblyNameValue(
    string fullName,
    string name
);
Remarks

This is GetAssemblyNameValue, a member of class TypeSupport.

See Also
TypeSupport Class
Eco.Support Namespace


TypeSupport.GetObjectFromType Method

TypeSupport.GetObjectFromType Method
TypeSupport Class Eco.Support Namespace See Also
Collapse All
C#
public static object GetObjectFromType(
    Assembly checkFirst,
    string assemblyName,
    string typeName,
    ISite site
);
Remarks

This is GetObjectFromType, a member of class TypeSupport.

See Also
TypeSupport Class
Eco.Support Namespace


TypeSupport.IsNullable Method

TypeSupport.IsNullable Method
TypeSupport Class Eco.Support Namespace See Also
Collapse All
C#
public static bool IsNullable(
    System.Type type
);
Remarks

This is IsNullable, a member of class TypeSupport.

See Also
TypeSupport Class
Eco.Support Namespace


ResolveType Method

ResolveType Method

This is the overview for the ResolveType method overload.

Overload List
Name | Description
TypeSupport.ResolveType (string, ISite, Type) | This is ResolveType, a member of class TypeSupport.
TypeSupport.ResolveType (string, ITypeResolutionService, Type) | Resolves the typename of an ecospace to the type


TypeSupport.ResolveType Method (string, ISite, Type)

TypeSupport.ResolveType Method (string, ISite, Type)
TypeSupport Class Eco.Support Namespace See Also
Collapse All
C#
public static System.Type ResolveType(
    string typeName,
    ISite site,
    Type requiredSuperclass
);
Remarks

This is ResolveType, a member of class TypeSupport.

See Also
TypeSupport Class
Eco.Support Namespace


TypeSupport.ResolveType Method (string, ITypeResolutionService, Type)

TypeSupport.ResolveType Method (string, ITypeResolutionService, Type)
TypeSupport Class Eco.Support Namespace See Also
Collapse All

Resolves the typename of an ecospace to the type

C#
public static System.Type ResolveType(
    string typeName,
    ITypeResolutionService trs,
    Type requiredSuperclass
);
Remarks

Primarily intended for internal use

See Also
TypeSupport Class
Eco.Support Namespace


Eco.Support.Deriver Namespace

Eco.Support.Deriver Namespace
Classes
Collapse All

This is namespace Eco.Support.Deriver.

Classes
Name | Description
AbstractDeriver | This is class Eco.Support.Deriver.AbstractDeriver.


AbstractDeriver Class

AbstractDeriver Class
Inheritance Hierarchy See Also
Collapse All
C#
public abstract class AbstractDeriver;
Remarks

This is class Eco.Support.Deriver.AbstractDeriver.

Inheritance Hierarchy
Eco.Support.Deriver.AbstractDeriver
File

AbstractDeriver.cs

See Also
Inheritance Hierarchy


AbstractDeriver Methods

AbstractDeriver Methods
Protected Methods Public Methods
Collapse All

The methods of the AbstractDeriver class are listed here.

Protected Methods
Name | Description
CancelAllSubscriptions | This is CancelAllSubscriptions, a member of class AbstractDeriver.
DoDeriveAndSubscribe | This is DoDeriveAndSubscribe, a member of class AbstractDeriver.
DoNotifyOutOfDate | This is DoNotifyOutOfDate, a member of class AbstractDeriver.
HandleRecursiveDerive | This is HandleRecursiveDerive, a member of class AbstractDeriver.
Top
Public Methods
Name | Description
EnsureCurrent | This is EnsureCurrent, a member of class AbstractDeriver.
MarkOutOfDate | This is MarkOutOfDate, a member of class AbstractDeriver.
MarkSubscriptionOutOfDate | This is MarkSubscriptionOutOfDate, a member of class AbstractDeriver.


AbstractDeriver.CancelAllSubscriptions Method

AbstractDeriver.CancelAllSubscriptions Method
AbstractDeriver Class Eco.Support.Deriver Namespace See Also
Collapse All
C#
protected void CancelAllSubscriptions();
Remarks

This is CancelAllSubscriptions, a member of class AbstractDeriver.

See Also
AbstractDeriver Class
Eco.Support.Deriver Namespace


AbstractDeriver.DoDeriveAndSubscribe Method

AbstractDeriver.DoDeriveAndSubscribe Method
AbstractDeriver Class Eco.Support.Deriver Namespace See Also
Collapse All
C#
protected abstract void DoDeriveAndSubscribe(
    bool subscribe
);
Remarks

This is DoDeriveAndSubscribe, a member of class AbstractDeriver.

See Also
AbstractDeriver Class
Eco.Support.Deriver Namespace


AbstractDeriver.DoNotifyOutOfDate Method

AbstractDeriver.DoNotifyOutOfDate Method
AbstractDeriver Class Eco.Support.Deriver Namespace See Also
Collapse All
C#
protected virtual void DoNotifyOutOfDate();
Remarks

This is DoNotifyOutOfDate, a member of class AbstractDeriver.

See Also
AbstractDeriver Class
Eco.Support.Deriver Namespace


AbstractDeriver.EnsureCurrent Method

AbstractDeriver.EnsureCurrent Method
AbstractDeriver Class Eco.Support.Deriver Namespace See Also
Collapse All
C#
public void EnsureCurrent();
Remarks

This is EnsureCurrent, a member of class AbstractDeriver.

See Also
AbstractDeriver Class
Eco.Support.Deriver Namespace


AbstractDeriver.HandleRecursiveDerive Method

AbstractDeriver.HandleRecursiveDerive Method
AbstractDeriver Class Eco.Support.Deriver Namespace See Also
Collapse All
C#
protected virtual void HandleRecursiveDerive();
Remarks

This is HandleRecursiveDerive, a member of class AbstractDeriver.

See Also
AbstractDeriver Class
Eco.Support.Deriver Namespace


AbstractDeriver.MarkOutOfDate Method

AbstractDeriver.MarkOutOfDate Method
AbstractDeriver Class Eco.Support.Deriver Namespace See Also
Collapse All
C#
public void MarkOutOfDate();
Remarks

This is MarkOutOfDate, a member of class AbstractDeriver.

See Also
AbstractDeriver Class
Eco.Support.Deriver Namespace


AbstractDeriver.MarkSubscriptionOutOfDate Method

AbstractDeriver.MarkSubscriptionOutOfDate Method
AbstractDeriver Class Eco.Support.Deriver Namespace See Also
Collapse All
C#
public void MarkSubscriptionOutOfDate();
Remarks

This is MarkSubscriptionOutOfDate, a member of class AbstractDeriver.

See Also
AbstractDeriver Class
Eco.Support.Deriver Namespace


AbstractDeriver Properties

AbstractDeriver Properties
Public Properties Protected Properties
Collapse All

The properties of the AbstractDeriver class are listed here.

Public Properties
Name | Description
IsDeriving | This is IsDeriving, a member of class AbstractDeriver.
Top
Protected Properties
Name | Description
ReevaluateSubscriber | This is ReevaluateSubscriber, a member of class AbstractDeriver.
ResubscribeSubscriber | This is ResubscribeSubscriber, a member of class AbstractDeriver.


AbstractDeriver.IsDeriving Property

AbstractDeriver.IsDeriving Property
AbstractDeriver Class Eco.Support.Deriver Namespace See Also
Collapse All
C#
public bool IsDeriving;
Remarks

This is IsDeriving, a member of class AbstractDeriver.

See Also
AbstractDeriver Class
Eco.Support.Deriver Namespace


AbstractDeriver.ReevaluateSubscriber Property

AbstractDeriver.ReevaluateSubscriber Property
AbstractDeriver Class Eco.Support.Deriver Namespace See Also
Collapse All
C#
protected ISubscriber ReevaluateSubscriber;
Remarks

This is ReevaluateSubscriber, a member of class AbstractDeriver.

See Also
AbstractDeriver Class
Eco.Support.Deriver Namespace


AbstractDeriver.ResubscribeSubscriber Property

AbstractDeriver.ResubscribeSubscriber Property
AbstractDeriver Class Eco.Support.Deriver Namespace See Also
Collapse All
C#
protected ISubscriber ResubscribeSubscriber;
Remarks

This is ResubscribeSubscriber, a member of class AbstractDeriver.

See Also
AbstractDeriver Class
Eco.Support.Deriver Namespace


Eco.Tree Namespace

Eco.Tree Namespace
Classes
Collapse All

This is namespace Eco.Tree.

Classes
Name
Description
EcoTreeAbstractNodeDefinition
This is class Eco.Tree.EcoTreeAbstractNodeDefinition.
EcoTreeDefinition
The EcoTreeDefinition is a collection of root nodes that are named and point out an IClass. The subnodes of the root nodes build up navigations over associations available in the IClass.
EcoTreeDefinitionEditor
Interaction logic for EcoTreeDefinitionEditor.xaml
EcoTreeDefinitionHandle
ToolboxBitmap(typeof(ReferenceHandle))
EcoTreeDefinitionWinForm
This is class Eco.Tree.EcoTreeDefinitionWinForm.
EcoTreeRootNodeDefinition
This is a root node in an EcoTreeDefinition. A Root node has a name and a class. You can use the name from a sub node to call a root node. The reason for calling a root node from a sub node can be one of two:

  1. You want to recurse or for some other reason call a "procedure" to minimize the definition
  2. You want to upcast to a higher class; from fruit to apple.

The call to a root node filters the calling nodes on type so bananas are ignored, just apples are handled by apple root node.... more

EcoTreeSubNodeDefinition
This is a sub node in an EcoTreeDefinition. A subnode is a navigation following an association from an IClass, or a call to s Root node.
EcoTreeUtility
This is class Eco.Tree.EcoTreeUtility.


EcoTreeAbstractNodeDefinition Class

EcoTreeAbstractNodeDefinition Class
Inheritance Hierarchy See Also
Collapse All
C#
public abstract class EcoTreeAbstractNodeDefinition;
Remarks

This is class Eco.Tree.EcoTreeAbstractNodeDefinition.

Inheritance Hierarchy
Eco.Tree.EcoTreeAbstractNodeDefinition
    Eco.Tree.EcoTreeRootNodeDefinition
    Eco.Tree.EcoTreeSubNodeDefinition
File

EcoTreeNodes.cs

See Also
Inheritance Hierarchy


EcoTreeAbstractNodeDefinition Fields

EcoTreeAbstractNodeDefinition Fields
Protected Fields
Collapse All

The fields of the EcoTreeAbstractNodeDefinition class are listed here.

Protected Fields
Name | Description
childNavigations | This is childNavigations, a member of class EcoTreeAbstractNodeDefinition.


EcoTreeAbstractNodeDefinition.childNavigations Field

EcoTreeAbstractNodeDefinition.childNavigations Field
EcoTreeAbstractNodeDefinition Class Eco.Tree Namespace See Also
Collapse All
C#
protected ObservableCollection<EcoTreeSubNodeDefinition> childNavigations;
Remarks

This is childNavigations, a member of class EcoTreeAbstractNodeDefinition.

See Also
EcoTreeAbstractNodeDefinition Class
Eco.Tree Namespace


EcoTreeAbstractNodeDefinition Methods

EcoTreeAbstractNodeDefinition Methods
Protected Methods Public Methods
Collapse All

The methods of the EcoTreeAbstractNodeDefinition class are listed here.

Protected Methods
Name | Description
LookUpFeatureFromClassNameAndId | This is LookUpFeatureFromClassNameAndId, a member of class EcoTreeAbstractNodeDefinition.
Valid | This is Valid, a member of class EcoTreeAbstractNodeDefinition.
Top
Public Methods
Name | Description
GetIClass | This is GetIClass, a member of class EcoTreeAbstractNodeDefinition.
Save | This is Save, a member of class EcoTreeAbstractNodeDefinition.


EcoTreeAbstractNodeDefinition.GetIClass Method

EcoTreeAbstractNodeDefinition.GetIClass Method
EcoTreeAbstractNodeDefinition Class Eco.Tree Namespace See Also
Collapse All
C#
public abstract IClass GetIClass();
Remarks

This is GetIClass, a member of class EcoTreeAbstractNodeDefinition.

See Also
EcoTreeAbstractNodeDefinition Class
Eco.Tree Namespace


EcoTreeAbstractNodeDefinition.LookUpFeatureFromClassNameAndId Method

EcoTreeAbstractNodeDefinition.LookUpFeatureFromClassNameAndId Method
EcoTreeAbstractNodeDefinition Class Eco.Tree Namespace See Also
Collapse All
C#
protected IStructuralFeature LookUpFeatureFromClassNameAndId(
    IClass c,
    string name,
    string id
);
Remarks

This is LookUpFeatureFromClassNameAndId, a member of class EcoTreeAbstractNodeDefinition.

See Also
EcoTreeAbstractNodeDefinition Class
Eco.Tree Namespace


EcoTreeAbstractNodeDefinition.Save Method

EcoTreeAbstractNodeDefinition.Save Method
EcoTreeAbstractNodeDefinition Class Eco.Tree Namespace See Also
Collapse All
C#
public abstract XElement Save();
Remarks

This is Save, a member of class EcoTreeAbstractNodeDefinition.

See Also
EcoTreeAbstractNodeDefinition Class
Eco.Tree Namespace


EcoTreeAbstractNodeDefinition.Valid Method

EcoTreeAbstractNodeDefinition.Valid Method
EcoTreeAbstractNodeDefinition Class Eco.Tree Namespace See Also
Collapse All
C#
protected abstract bool Valid(
    IObject io
);
Remarks

This is Valid, a member of class EcoTreeAbstractNodeDefinition.

See Also
EcoTreeAbstractNodeDefinition Class
Eco.Tree Namespace


EcoTreeAbstractNodeDefinition Properties

EcoTreeAbstractNodeDefinition Properties
Public Properties
Collapse All

The properties of the EcoTreeAbstractNodeDefinition class are listed here.

Public Properties
Name | Description
SubNodes | This is SubNodes, a member of class EcoTreeAbstractNodeDefinition.


EcoTreeAbstractNodeDefinition.SubNodes Property

EcoTreeAbstractNodeDefinition.SubNodes Property
EcoTreeAbstractNodeDefinition Class Eco.Tree Namespace See Also
Collapse All
C#
public ObservableCollection<EcoTreeSubNodeDefinition> SubNodes;
Remarks

This is SubNodes, a member of class EcoTreeAbstractNodeDefinition.

See Also
EcoTreeAbstractNodeDefinition Class
Eco.Tree Namespace


EcoTreeDefinition Class

EcoTreeDefinition Class
Inheritance Hierarchy See Also
Collapse All

The EcoTreeDefinition is a collection of root nodes that are named and point out an IClass. The subnodes of the root nodes build up navigations over associations available in the IClass.

C#
public class EcoTreeDefinition;
Inheritance Hierarchy
Eco.Tree.EcoTreeDefinition
File

EcoTreeDefinition.cs

See Also
Inheritance Hierarchy


EcoTreeDefinition Methods

EcoTreeDefinition Methods
Public Methods
Collapse All

The methods of the EcoTreeDefinition class are listed here.

Public Methods
Name | Description
Delete | This is Delete, a member of class EcoTreeDefinition.
Load | This is Load, a member of class EcoTreeDefinition.
LoadFromString | This is LoadFromString, a member of class EcoTreeDefinition.
MakeNameUnique | This is MakeNameUnique, a member of class EcoTreeDefinition.
Save | This is Save, a member of class EcoTreeDefinition.
SaveToString | This is SaveToString, a member of class EcoTreeDefinition.
WalkNamedTree | This is the overview for the WalkNamedTree method overload.


EcoTreeDefinition.Delete Method

EcoTreeDefinition.Delete Method
EcoTreeDefinition Class Eco.Tree Namespace See Also
Collapse All
C#
public void Delete(
    EcoTreeAbstractNodeDefinition node
);
Remarks

This is Delete, a member of class EcoTreeDefinition.

See Also
EcoTreeDefinition Class
Eco.Tree Namespace


EcoTreeDefinition.Load Method

EcoTreeDefinition.Load Method
EcoTreeDefinition Class Eco.Tree Namespace See Also
Collapse All
C#
public void Load(
    IEcoTypeSystem ts,
    XDocument xdoc
);
Remarks

This is Load, a member of class EcoTreeDefinition.

See Also
EcoTreeDefinition Class
Eco.Tree Namespace


EcoTreeDefinition.LoadFromString Method

EcoTreeDefinition.LoadFromString Method
EcoTreeDefinition Class Eco.Tree Namespace See Also
Collapse All
C#
public void LoadFromString(
    IEcoTypeSystem ts,
    string xmlDefinition
);
Remarks

This is LoadFromString, a member of class EcoTreeDefinition.

See Also
EcoTreeDefinition Class
Eco.Tree Namespace


EcoTreeDefinition.MakeNameUnique Method

EcoTreeDefinition.MakeNameUnique Method
EcoTreeDefinition Class Eco.Tree Namespace See Also
Collapse All
C#
public string MakeNameUnique(
    string aName
);
Remarks

This is MakeNameUnique, a member of class EcoTreeDefinition.

See Also
EcoTreeDefinition Class
Eco.Tree Namespace


EcoTreeDefinition.Save Method

EcoTreeDefinition.Save Method
EcoTreeDefinition Class Eco.Tree Namespace See Also
Collapse All
C#
public XDocument Save();
Remarks

This is Save, a member of class EcoTreeDefinition.

See Also
EcoTreeDefinition Class
Eco.Tree Namespace


EcoTreeDefinition.SaveToString Method

EcoTreeDefinition.SaveToString Method
EcoTreeDefinition Class Eco.Tree Namespace See Also
Collapse All
C#
public string SaveToString();
Remarks

This is SaveToString, a member of class EcoTreeDefinition.

See Also
EcoTreeDefinition Class
Eco.Tree Namespace


WalkNamedTree Method

WalkNamedTree Method

This is the overview for the WalkNamedTree method overload.

Overload List
Name | Description
EcoTreeDefinition.WalkNamedTree (IEnumerable, string, object, Func<IProperty, object, object>, Func<IObject, object, object>) | This is WalkNamedTree, a member of class EcoTreeDefinition.
EcoTreeDefinition.WalkNamedTree (IObject, string, object, Func<IProperty, object, object>, Func<IObject, object, object>) | This is WalkNamedTree, a member of class EcoTreeDefinition.


EcoTreeDefinition.WalkNamedTree Method (IEnumerable, string, object, Func<IProperty, object, object>, Func<IObject, object, object>)

EcoTreeDefinition.WalkNamedTree Method (IEnumerable, string, object, Func<IProperty, object, object>, Func<IObject, object, object>)
EcoTreeDefinition Class Eco.Tree Namespace See Also
Collapse All
C#
public void WalkNamedTree(
    IEnumerable contextstart,
    string nameOfTreeToWalk,
    object usercontext,
    Func<IProperty, object, object> HandleProperty,
    Func<IObject, object, object> HandleObject
);
Remarks

This is WalkNamedTree, a member of class EcoTreeDefinition.

See Also
EcoTreeDefinition Class
Eco.Tree Namespace


EcoTreeDefinition.WalkNamedTree Method (IObject, string, object, Func<IProperty, object, object>, Func<IObject, object, object>)

EcoTreeDefinition.WalkNamedTree Method (IObject, string, object, Func<IProperty, object, object>, Func<IObject, object, object>)
EcoTreeDefinition Class Eco.Tree Namespace See Also
Collapse All
C#
public void WalkNamedTree(
    IObject contextstart,
    string nameOfTreeToWalk,
    object usercontext,
    Func<IProperty, object, object> HandleProperty,
    Func<IObject, object, object> HandleObject
);
Remarks

This is WalkNamedTree, a member of class EcoTreeDefinition.

See Also
EcoTreeDefinition Class
Eco.Tree Namespace


EcoTreeDefinition Properties

EcoTreeDefinition Properties
Public Properties
Collapse All

The properties of the EcoTreeDefinition class are listed here.

Public Properties
Name | Description
RootNodes | This is RootNodes, a member of class EcoTreeDefinition.


EcoTreeDefinition.RootNodes Property

EcoTreeDefinition.RootNodes Property
EcoTreeDefinition Class Eco.Tree Namespace See Also
Collapse All
C#
public ObservableCollection<EcoTreeRootNodeDefinition> RootNodes;
Remarks

This is RootNodes, a member of class EcoTreeDefinition.

See Also
EcoTreeDefinition Class
Eco.Tree Namespace


EcoTreeDefinitionEditor Class

EcoTreeDefinitionEditor Class
Inheritance Hierarchy See Also
Collapse All

Interaction logic for EcoTreeDefinitionEditor.xaml

C#
public class EcoTreeDefinitionEditor : UserControl;
Inheritance Hierarchy
Eco.Tree.EcoTreeDefinitionEditor
File

EcoTreeDefinitionEditor.xaml.cs

See Also
Inheritance Hierarchy


EcoTreeDefinitionEditor.EcoTreeDefinitionEditor Constructor

EcoTreeDefinitionEditor.EcoTreeDefinitionEditor Constructor
EcoTreeDefinitionEditor Class Eco.Tree Namespace See Also
Collapse All
C#
public EcoTreeDefinitionEditor(
    IEcoTypeSystem typeSystem,
    string xmlDefinition
);
Remarks

This is EcoTreeDefinitionEditor, a member of class EcoTreeDefinitionEditor.

See Also
EcoTreeDefinitionEditor Class
Eco.Tree Namespace


EcoTreeDefinitionEditor Properties

EcoTreeDefinitionEditor Properties
Public Properties
Collapse All

The properties of the EcoTreeDefinitionEditor class are listed here.

Public Properties
Name | Description
EcoTreeDefinition | This is EcoTreeDefinition, a member of class EcoTreeDefinitionEditor.
TypeSystem | This is TypeSystem, a member of class EcoTreeDefinitionEditor.


EcoTreeDefinitionEditor.EcoTreeDefinition Property

EcoTreeDefinitionEditor.EcoTreeDefinition Property
EcoTreeDefinitionEditor Class Eco.Tree Namespace See Also
Collapse All
C#
public EcoTreeDefinition EcoTreeDefinition;
Remarks

This is EcoTreeDefinition, a member of class EcoTreeDefinitionEditor.

See Also
EcoTreeDefinitionEditor Class
Eco.Tree Namespace


EcoTreeDefinitionEditor.TypeSystem Property

EcoTreeDefinitionEditor.TypeSystem Property
EcoTreeDefinitionEditor Class Eco.Tree Namespace See Also
Collapse All
C#
public IEcoTypeSystem TypeSystem;
Remarks

This is TypeSystem, a member of class EcoTreeDefinitionEditor.

See Also
EcoTreeDefinitionEditor Class
Eco.Tree Namespace


EcoTreeDefinitionHandle Class

EcoTreeDefinitionHandle Class
Inheritance Hierarchy See Also
Collapse All
C#
public class EcoTreeDefinitionHandle : System.ComponentModel.Component, IStaticContext, IEcoServiceProvider, IHasTypeSystem;
Remarks

ToolboxBitmap(typeof(ReferenceHandle))

Inheritance Hierarchy
Eco.Tree.EcoTreeDefinitionHandle
File

EcoTree.cs

See Also
Inheritance Hierarchy


EcoTreeDefinitionHandle Methods

EcoTreeDefinitionHandle Methods
Protected Methods Public Methods
Collapse All

The methods of the EcoTreeDefinitionHandle class are listed here.

Protected Methods
Name | Description
EffectiveVariables | This is EffectiveVariables, a member of class EcoTreeDefinitionHandle.
GetInternalServiceProvider | This is GetInternalServiceProvider, a member of class EcoTreeDefinitionHandle.
GetTypeSystem | This is GetTypeSystem, a member of class EcoTreeDefinitionHandle.
Top
Public Methods
Name | Description
GetEcoService | This is the overview for the GetEcoService method overload.
RegisterEcoService | This is the overview for the RegisterEcoService method overload.


EcoTreeDefinitionHandle.EffectiveVariables Method

EcoTreeDefinitionHandle.EffectiveVariables Method
EcoTreeDefinitionHandle Class Eco.Tree Namespace See Also
Collapse All
C#
protected virtual IExternalVariableList EffectiveVariables();
Remarks

This is EffectiveVariables, a member of class EcoTreeDefinitionHandle.

See Also
EcoTreeDefinitionHandle Class
Eco.Tree Namespace


GetEcoService Method

GetEcoService Method

This is the overview for the GetEcoService method overload.

Overload List
Name | Description
EcoTreeDefinitionHandle.GetEcoService () | This is GetEcoService, a member of class EcoTreeDefinitionHandle.
EcoTreeDefinitionHandle.GetEcoService (object) | This is GetEcoService, a member of class EcoTreeDefinitionHandle.
EcoTreeDefinitionHandle.GetEcoService (System.Type) | This is GetEcoService, a member of class EcoTreeDefinitionHandle.


EcoTreeDefinitionHandle.GetEcoService Method ()

EcoTreeDefinitionHandle.GetEcoService Method ()
EcoTreeDefinitionHandle Class Eco.Tree Namespace See Also
Collapse All
C#
public T GetEcoService<T>() where T : class;
Remarks

This is GetEcoService, a member of class EcoTreeDefinitionHandle.

See Also
EcoTreeDefinitionHandle Class
Eco.Tree Namespace


EcoTreeDefinitionHandle.GetEcoService Method (System.Type)

EcoTreeDefinitionHandle.GetEcoService Method (System.Type)
EcoTreeDefinitionHandle Class Eco.Tree Namespace See Also
Collapse All
C#
public object GetEcoService(
    System.Type serviceType
);
Remarks

This is GetEcoService, a member of class EcoTreeDefinitionHandle.

See Also
EcoTreeDefinitionHandle Class
Eco.Tree Namespace


EcoTreeDefinitionHandle.GetEcoService Method (object)

EcoTreeDefinitionHandle.GetEcoService Method (object)
EcoTreeDefinitionHandle Class Eco.Tree Namespace See Also
Collapse All
C#
public T GetEcoService<T>(
    object key
) where T : class;
Remarks

This is GetEcoService, a member of class EcoTreeDefinitionHandle.

See Also
EcoTreeDefinitionHandle Class
Eco.Tree Namespace


EcoTreeDefinitionHandle.GetInternalServiceProvider Method

EcoTreeDefinitionHandle.GetInternalServiceProvider Method
EcoTreeDefinitionHandle Class Eco.Tree Namespace See Also
Collapse All
C#
protected IEcoServiceProvider GetInternalServiceProvider();
Remarks

This is GetInternalServiceProvider, a member of class EcoTreeDefinitionHandle.

See Also
EcoTreeDefinitionHandle Class
Eco.Tree Namespace


EcoTreeDefinitionHandle.GetTypeSystem Method

EcoTreeDefinitionHandle.GetTypeSystem Method
EcoTreeDefinitionHandle Class Eco.Tree Namespace See Also
Collapse All
C#
protected IEcoTypeSystem GetTypeSystem();
Remarks

This is GetTypeSystem, a member of class EcoTreeDefinitionHandle.

See Also
EcoTreeDefinitionHandle Class
Eco.Tree Namespace


RegisterEcoService Method

RegisterEcoService Method

This is the overview for the RegisterEcoService method overload.

Overload List
Name | Description
EcoTreeDefinitionHandle.RegisterEcoService (object, T) | This is RegisterEcoService, a member of class EcoTreeDefinitionHandle.
EcoTreeDefinitionHandle.RegisterEcoService (T) | This is RegisterEcoService, a member of class EcoTreeDefinitionHandle.


EcoTreeDefinitionHandle.RegisterEcoService Method (T)

EcoTreeDefinitionHandle.RegisterEcoService Method (T)
EcoTreeDefinitionHandle Class Eco.Tree Namespace See Also
Collapse All
C#
public void RegisterEcoService<T>(
    T service
) where T : class;
Remarks

This is RegisterEcoService, a member of class EcoTreeDefinitionHandle.

See Also
EcoTreeDefinitionHandle Class
Eco.Tree Namespace


EcoTreeDefinitionHandle.RegisterEcoService Method (object, T)

EcoTreeDefinitionHandle.RegisterEcoService Method (object, T)
EcoTreeDefinitionHandle Class Eco.Tree Namespace See Also
Collapse All
C#
public void RegisterEcoService<T>(
    object key,
    T service
) where T : class;
Remarks

This is RegisterEcoService, a member of class EcoTreeDefinitionHandle.

See Also
EcoTreeDefinitionHandle Class
Eco.Tree Namespace


EcoTreeDefinitionHandle Properties

EcoTreeDefinitionHandle Properties
Public Properties
Collapse All

The properties of the EcoTreeDefinitionHandle class are listed here.

Public Properties
Name | Description
ActionLanguageTypeService | This is ActionLanguageTypeService, a member of class EcoTreeDefinitionHandle.
Definition | Editor(typeof(EcoTreeEditorWakeup), typeof(UITypeEditor))
EcoSpace | This is EcoSpace, a member of class EcoTreeDefinitionHandle.
EcoSpaceType | This is EcoSpaceType, a member of class EcoTreeDefinitionHandle.
EcoSpaceTypeName | This is EcoSpaceTypeName, a member of class EcoTreeDefinitionHandle.
OclPsTypeService | This is OclPsTypeService, a member of class EcoTreeDefinitionHandle.
OclTypeService | This is OclTypeService, a member of class EcoTreeDefinitionHandle.
StaticUmlType | This is StaticUmlType, a member of class EcoTreeDefinitionHandle.
TypeSystem | This is TypeSystem, a member of class EcoTreeDefinitionHandle.
VariableList | This is VariableList, a member of class EcoTreeDefinitionHandle.


EcoTreeDefinitionHandle.ActionLanguageTypeService Property

EcoTreeDefinitionHandle.ActionLanguageTypeService Property
EcoTreeDefinitionHandle Class Eco.Tree Namespace See Also
Collapse All
C#
public IActionLanguageTypeService ActionLanguageTypeService;
Remarks

This is ActionLanguageTypeService, a member of class EcoTreeDefinitionHandle.

See Also
EcoTreeDefinitionHandle Class
Eco.Tree Namespace


EcoTreeDefinitionHandle.Definition Property

EcoTreeDefinitionHandle.Definition Property
EcoTreeDefinitionHandle Class Eco.Tree Namespace See Also
Collapse All
C#
public string Definition;
Remarks

Editor(typeof(EcoTreeEditorWakeup), typeof(UITypeEditor))

See Also
EcoTreeDefinitionHandle Class
Eco.Tree Namespace


EcoTreeDefinitionHandle.EcoSpace Property

EcoTreeDefinitionHandle.EcoSpace Property
EcoTreeDefinitionHandle Class Eco.Tree Namespace See Also
Collapse All
C#
public EcoSpace EcoSpace;
Remarks

This is EcoSpace, a member of class EcoTreeDefinitionHandle.

See Also
EcoTreeDefinitionHandle Class
Eco.Tree Namespace


EcoTreeDefinitionHandle.EcoSpaceType Property

EcoTreeDefinitionHandle.EcoSpaceType Property
EcoTreeDefinitionHandle Class Eco.Tree Namespace See Also
Collapse All
C#
public System.Type EcoSpaceType;
Remarks

This is EcoSpaceType, a member of class EcoTreeDefinitionHandle.

See Also
EcoTreeDefinitionHandle Class
Eco.Tree Namespace


EcoTreeDefinitionHandle.EcoSpaceTypeName Property

EcoTreeDefinitionHandle.EcoSpaceTypeName Property
EcoTreeDefinitionHandle Class Eco.Tree Namespace See Also
Collapse All
C#
public string EcoSpaceTypeName;
Remarks

This is EcoSpaceTypeName, a member of class EcoTreeDefinitionHandle.

See Also
EcoTreeDefinitionHandle Class
Eco.Tree Namespace


EcoTreeDefinitionHandle.OclPsTypeService Property

EcoTreeDefinitionHandle.OclPsTypeService Property
EcoTreeDefinitionHandle Class Eco.Tree Namespace See Also
Collapse All
C#
public IOclPsTypeService OclPsTypeService;
Remarks

This is OclPsTypeService, a member of class EcoTreeDefinitionHandle.

See Also
EcoTreeDefinitionHandle Class
Eco.Tree Namespace


EcoTreeDefinitionHandle.OclTypeService Property

EcoTreeDefinitionHandle.OclTypeService Property
EcoTreeDefinitionHandle Class Eco.Tree Namespace See Also
Collapse All
C#
public IOclTypeService OclTypeService;
Remarks

This is OclTypeService, a member of class EcoTreeDefinitionHandle.

See Also
EcoTreeDefinitionHandle Class
Eco.Tree Namespace


EcoTreeDefinitionHandle.StaticUmlType Property

EcoTreeDefinitionHandle.StaticUmlType Property
EcoTreeDefinitionHandle Class Eco.Tree Namespace See Also
Collapse All
C#
public IClassifier StaticUmlType;
Remarks

This is StaticUmlType, a member of class EcoTreeDefinitionHandle.

See Also
EcoTreeDefinitionHandle Class
Eco.Tree Namespace


EcoTreeDefinitionHandle.TypeSystem Property

EcoTreeDefinitionHandle.TypeSystem Property
EcoTreeDefinitionHandle Class Eco.Tree Namespace See Also
Collapse All
C#
public IEcoTypeSystem TypeSystem;
Remarks

This is TypeSystem, a member of class EcoTreeDefinitionHandle.

See Also
EcoTreeDefinitionHandle Class
Eco.Tree Namespace


EcoTreeDefinitionHandle.VariableList Property

EcoTreeDefinitionHandle.VariableList Property
EcoTreeDefinitionHandle Class Eco.Tree Namespace See Also
Collapse All
C#
public IExternalVariableList VariableList;
Remarks

This is VariableList, a member of class EcoTreeDefinitionHandle.

See Also
EcoTreeDefinitionHandle Class
Eco.Tree Namespace


EcoTreeDefinitionWinForm Class

EcoTreeDefinitionWinForm Class
Inheritance Hierarchy See Also
Collapse All
C#
public class EcoTreeDefinitionWinForm : Form;
Remarks

This is class Eco.Tree.EcoTreeDefinitionWinForm.

Inheritance Hierarchy
Eco.Tree.EcoTreeDefinitionWinForm
File

EcoTreeDefinitionWinForm.designer.cs

See Also
Inheritance Hierarchy


EcoTreeDefinitionWinForm.EcoTreeDefinitionWinForm Constructor

EcoTreeDefinitionWinForm.EcoTreeDefinitionWinForm Constructor
EcoTreeDefinitionWinForm Class Eco.Tree Namespace See Also
Collapse All
C#
public EcoTreeDefinitionWinForm();
Remarks

This is EcoTreeDefinitionWinForm, a member of class EcoTreeDefinitionWinForm.

See Also
EcoTreeDefinitionWinForm Class
Eco.Tree Namespace


EcoTreeDefinitionWinForm Methods

EcoTreeDefinitionWinForm Methods
Protected Methods Public Methods
Collapse All

The methods of the EcoTreeDefinitionWinForm class are listed here.

Protected Methods
Name | Description
Dispose | Clean up any resources being used.
Top
Public Methods
Name | Description
Show | This is Show, a member of class EcoTreeDefinitionWinForm.


EcoTreeDefinitionWinForm.Dispose Method

EcoTreeDefinitionWinForm.Dispose Method
EcoTreeDefinitionWinForm Class Eco.Tree Namespace See Also
Collapse All

Clean up any resources being used.

C#
protected override void Dispose(
    bool disposing
);
Parameters
Parameters | Description
disposing | true if managed resources should be disposed; otherwise, false.
See Also
EcoTreeDefinitionWinForm Class
Eco.Tree Namespace


EcoTreeDefinitionWinForm.Show Method

EcoTreeDefinitionWinForm.Show Method
EcoTreeDefinitionWinForm Class Eco.Tree Namespace See Also
Collapse All
C#
public DialogResult Show(
    Eco.UmlRt.IEcoTypeSystem iEcoTypeSystem,
    ref string xmlDefinition
);
Remarks

This is Show, a member of class EcoTreeDefinitionWinForm.

See Also
EcoTreeDefinitionWinForm Class
Eco.Tree Namespace


EcoTreeRootNodeDefinition Class

EcoTreeRootNodeDefinition Class
Inheritance Hierarchy See Also
Collapse All

This is a root node in an EcoTreeDefinition. A Root node has a name and a class. You can use the name from a sub node to call a root node. The reason for calling a root node from a sub node can be one of two:

  1. You want to recurse or for some other reason call a "procedure" to minimize the definition
  2. You want to upcast to a higher class; from fruit to apple.

The call to a root node filters the calling nodes on type so bananas are ignored, just apples are handled by apple root node. This makes it possible to call several root nodes from a sub node; sub node of type fruit may call both banana and apple to handle the suclasses diffferently.

C#
public class EcoTreeRootNodeDefinition : EcoTreeAbstractNodeDefinition;
Inheritance Hierarchy
Eco.Tree.EcoTreeAbstractNodeDefinition
    Eco.Tree.EcoTreeRootNodeDefinition
File

EcoTreeNodes.cs

See Also
Inheritance Hierarchy


EcoTreeRootNodeDefinition.EcoTreeRootNodeDefinition Constructor

EcoTreeRootNodeDefinition.EcoTreeRootNodeDefinition Constructor
EcoTreeRootNodeDefinition Class Eco.Tree Namespace See Also
Collapse All
C#
public EcoTreeRootNodeDefinition(
    string validForClass,
    string nameOfNode,
    IClass aClass
);
Remarks

This is EcoTreeRootNodeDefinition, a member of class EcoTreeRootNodeDefinition.

See Also
EcoTreeRootNodeDefinition Class
Eco.Tree Namespace


EcoTreeRootNodeDefinition Methods

EcoTreeRootNodeDefinition Methods
Protected Methods Public Methods
Collapse All

The methods of the EcoTreeRootNodeDefinition class are listed here.

Protected Methods
Name | Description
Valid | This is Valid, a member of class EcoTreeRootNodeDefinition.
Top
Public Methods
Name | Description
GetIClass | This is GetIClass, a member of class EcoTreeRootNodeDefinition.
Save | This is Save, a member of class EcoTreeRootNodeDefinition.


EcoTreeRootNodeDefinition.GetIClass Method

EcoTreeRootNodeDefinition.GetIClass Method
EcoTreeRootNodeDefinition Class Eco.Tree Namespace See Also
Collapse All
C#
public override IClass GetIClass();
Remarks

This is GetIClass, a member of class EcoTreeRootNodeDefinition.

See Also
EcoTreeRootNodeDefinition Class
Eco.Tree Namespace


EcoTreeRootNodeDefinition.Save Method

EcoTreeRootNodeDefinition.Save Method
EcoTreeRootNodeDefinition Class Eco.Tree Namespace See Also
Collapse All
C#
public override XElement Save();
Remarks

This is Save, a member of class EcoTreeRootNodeDefinition.

See Also
EcoTreeRootNodeDefinition Class
Eco.Tree Namespace


EcoTreeRootNodeDefinition.Valid Method

EcoTreeRootNodeDefinition.Valid Method
EcoTreeRootNodeDefinition Class Eco.Tree Namespace See Also
Collapse All
C#
protected override bool Valid(
    IObject io
);
Remarks

This is Valid, a member of class EcoTreeRootNodeDefinition.

See Also
EcoTreeRootNodeDefinition Class
Eco.Tree Namespace


EcoTreeRootNodeDefinition Properties

EcoTreeRootNodeDefinition Properties
Public Properties
Collapse All

The properties of the EcoTreeRootNodeDefinition class are listed here.

Public Properties
Name | Description
Name | This is Name, a member of class EcoTreeRootNodeDefinition.
ValidForClass | This is ValidForClass, a member of class EcoTreeRootNodeDefinition.


EcoTreeRootNodeDefinition.Name Property

EcoTreeRootNodeDefinition.Name Property
EcoTreeRootNodeDefinition Class Eco.Tree Namespace See Also
Collapse All
C#
public string Name;
Remarks

This is Name, a member of class EcoTreeRootNodeDefinition.

See Also
EcoTreeRootNodeDefinition Class
Eco.Tree Namespace


EcoTreeRootNodeDefinition.ValidForClass Property

EcoTreeRootNodeDefinition.ValidForClass Property
EcoTreeRootNodeDefinition Class Eco.Tree Namespace See Also
Collapse All
C#
public string ValidForClass;
Remarks

This is ValidForClass, a member of class EcoTreeRootNodeDefinition.

See Also
EcoTreeRootNodeDefinition Class
Eco.Tree Namespace


EcoTreeSubNodeDefinition Class

EcoTreeSubNodeDefinition Class
Inheritance Hierarchy See Also
Collapse All

This is a sub node in an EcoTreeDefinition. A subnode is a navigation following an association from an IClass, or a call to s Root node.

C#
public class EcoTreeSubNodeDefinition : EcoTreeAbstractNodeDefinition;
Inheritance Hierarchy
Eco.Tree.EcoTreeAbstractNodeDefinition
    Eco.Tree.EcoTreeSubNodeDefinition
File

EcoTreeNodes.cs

See Also
Inheritance Hierarchy


EcoTreeSubNodeDefinition Constructor

EcoTreeSubNodeDefinition Constructor

This is the overview for the EcoTreeSubNodeDefinition constructor overload.

Overload List
Name | Description
EcoTreeSubNodeDefinition.EcoTreeSubNodeDefinition (string) | This is EcoTreeSubNodeDefinition, a member of class EcoTreeSubNodeDefinition.
EcoTreeSubNodeDefinition.EcoTreeSubNodeDefinition (string, string, IStructuralFeature) | This is EcoTreeSubNodeDefinition, a member of class EcoTreeSubNodeDefinition.


EcoTreeSubNodeDefinition.EcoTreeSubNodeDefinition Constructor (string)

EcoTreeSubNodeDefinition.EcoTreeSubNodeDefinition Constructor (string)
EcoTreeSubNodeDefinition Class Eco.Tree Namespace See Also
Collapse All
C#
public EcoTreeSubNodeDefinition(
    string callRootNodeWithName
);
Remarks

This is EcoTreeSubNodeDefinition, a member of class EcoTreeSubNodeDefinition.

See Also
EcoTreeSubNodeDefinition Class
Eco.Tree Namespace


EcoTreeSubNodeDefinition.EcoTreeSubNodeDefinition Constructor (string, string, IStructuralFeature)

EcoTreeSubNodeDefinition.EcoTreeSubNodeDefinition Constructor (string, string, IStructuralFeature)
EcoTreeSubNodeDefinition Class Eco.Tree Namespace See Also
Collapse All
C#
public EcoTreeSubNodeDefinition(
    string navigationproperty,
    string filterexpression,
    IStructuralFeature aFeature
);
Remarks

This is EcoTreeSubNodeDefinition, a member of class EcoTreeSubNodeDefinition.

See Also
EcoTreeSubNodeDefinition Class
Eco.Tree Namespace


EcoTreeSubNodeDefinition Methods

EcoTreeSubNodeDefinition Methods
Protected Methods Public Methods
Collapse All

The methods of the EcoTreeSubNodeDefinition class are listed here.

Protected Methods
Name | Description
Valid | This is Valid, a member of class EcoTreeSubNodeDefinition.
Top
Public Methods
Name | Description
GetIClass | This is GetIClass, a member of class EcoTreeSubNodeDefinition.
Save | This is Save, a member of class EcoTreeSubNodeDefinition.


EcoTreeSubNodeDefinition.GetIClass Method

EcoTreeSubNodeDefinition.GetIClass Method
EcoTreeSubNodeDefinition Class Eco.Tree Namespace See Also
Collapse All
C#
public override IClass GetIClass();
Remarks

This is GetIClass, a member of class EcoTreeSubNodeDefinition.

See Also
EcoTreeSubNodeDefinition Class
Eco.Tree Namespace


EcoTreeSubNodeDefinition.Save Method

EcoTreeSubNodeDefinition.Save Method
EcoTreeSubNodeDefinition Class Eco.Tree Namespace See Also
Collapse All
C#
public override XElement Save();
Remarks

This is Save, a member of class EcoTreeSubNodeDefinition.

See Also
EcoTreeSubNodeDefinition Class
Eco.Tree Namespace


EcoTreeSubNodeDefinition.Valid Method

EcoTreeSubNodeDefinition.Valid Method
EcoTreeSubNodeDefinition Class Eco.Tree Namespace See Also
Collapse All
C#
protected override bool Valid(
    IObject io
);
Remarks

This is Valid, a member of class EcoTreeSubNodeDefinition.

See Also
EcoTreeSubNodeDefinition Class
Eco.Tree Namespace


EcoTreeSubNodeDefinition Properties

EcoTreeSubNodeDefinition Properties
Public Properties
Collapse All

The properties of the EcoTreeSubNodeDefinition class are listed here.

Public Properties
Name | Description
Filter | This is Filter, a member of class EcoTreeSubNodeDefinition.
Navigation | This is Navigation, a member of class EcoTreeSubNodeDefinition.
Presentation | This is Presentation, a member of class EcoTreeSubNodeDefinition.


EcoTreeSubNodeDefinition.Filter Property

EcoTreeSubNodeDefinition.Filter Property
EcoTreeSubNodeDefinition Class Eco.Tree Namespace See Also
Collapse All
C#
public string Filter;
Remarks

This is Filter, a member of class EcoTreeSubNodeDefinition.

See Also
EcoTreeSubNodeDefinition Class
Eco.Tree Namespace


EcoTreeSubNodeDefinition.Navigation Property

EcoTreeSubNodeDefinition.Navigation Property
EcoTreeSubNodeDefinition Class Eco.Tree Namespace See Also
Collapse All
C#
public string Navigation;
Remarks

This is Navigation, a member of class EcoTreeSubNodeDefinition.

See Also
EcoTreeSubNodeDefinition Class
Eco.Tree Namespace


EcoTreeSubNodeDefinition.Presentation Property

EcoTreeSubNodeDefinition.Presentation Property
EcoTreeSubNodeDefinition Class Eco.Tree Namespace See Also
Collapse All
C#
public string Presentation;
Remarks

This is Presentation, a member of class EcoTreeSubNodeDefinition.

See Also
EcoTreeSubNodeDefinition Class
Eco.Tree Namespace


EcoTreeUtility Class

EcoTreeUtility Class
Inheritance Hierarchy See Also
Collapse All
C#
public class EcoTreeUtility;
Remarks

This is class Eco.Tree.EcoTreeUtility.

Inheritance Hierarchy
Eco.Tree.EcoTreeUtility
File

EcoTreeNodes.cs

See Also
Inheritance Hierarchy


EcoTreeUtility Methods

EcoTreeUtility Methods
Public Methods
Collapse All

The methods of the EcoTreeUtility class are listed here.

Public Methods
Name | Description
AttributesToXElements | This is AttributesToXElements, a member of class EcoTreeUtility.
ObjectToXElementWithIndentation | This is ObjectToXElementWithIndentation, a member of class EcoTreeUtility.


EcoTreeUtility.AttributesToXElements Method

EcoTreeUtility.AttributesToXElements Method
EcoTreeUtility Class Eco.Tree Namespace See Also
Collapse All
C#
public static object AttributesToXElements(
    IProperty prop,
    object usercontext
);
Remarks

This is AttributesToXElements, a member of class EcoTreeUtility.

See Also
EcoTreeUtility Class
Eco.Tree Namespace


EcoTreeUtility.ObjectToXElementWithIndentation Method

EcoTreeUtility.ObjectToXElementWithIndentation Method
EcoTreeUtility Class Eco.Tree Namespace See Also
Collapse All
C#
public static object ObjectToXElementWithIndentation(
    IObject io,
    object usercontext
);
Remarks

This is ObjectToXElementWithIndentation, a member of class EcoTreeUtility.

See Also
EcoTreeUtility Class
Eco.Tree Namespace


Eco.UmlCodeAttributes Namespace

Eco.UmlCodeAttributes Namespace
Classes
Collapse All

using Eco.Ocl.Support;

Classes
Name | Description
EcoAutoGeneratedAttribute | This is class Eco.UmlCodeAttributes.EcoAutoGeneratedAttribute.
EcoAutoMaintainedAttribute | This is class Eco.UmlCodeAttributes.EcoAutoMaintainedAttribute.
EcoCodeGenVersionAttribute | This is class Eco.UmlCodeAttributes.EcoCodeGenVersionAttribute.
EcoSpaceAttribute | This is class Eco.UmlCodeAttributes.EcoSpaceAttribute.
EcoSpacePackageAttribute | This is class Eco.UmlCodeAttributes.EcoSpacePackageAttribute.
InnerLinkAttribute | This is class Eco.UmlCodeAttributes.InnerLinkAttribute.
LinkRoleAttribute | This is class Eco.UmlCodeAttributes.LinkRoleAttribute.
StateMachineAttribute | This is class Eco.UmlCodeAttributes.StateMachineAttribute.
UmlCollectionAttribute | This is class Eco.UmlCodeAttributes.UmlCollectionAttribute.
UmlElementAttribute | This is class Eco.UmlCodeAttributes.UmlElementAttribute.
UmlMetaAttributeAttribute | This is class Eco.UmlCodeAttributes.UmlMetaAttributeAttribute.
UmlTaggedValueAttribute | This is class Eco.UmlCodeAttributes.UmlTaggedValueAttribute.


EcoAutoGeneratedAttribute Class

EcoAutoGeneratedAttribute Class
Inheritance Hierarchy See Also
Collapse All
C#
public sealed class EcoAutoGeneratedAttribute : Attribute;
Remarks

This is class Eco.UmlCodeAttributes.EcoAutoGeneratedAttribute.

Inheritance Hierarchy
Eco.UmlCodeAttributes.EcoAutoGeneratedAttribute
File

UmlCodeAttributes.cs

See Also
Inheritance Hierarchy


EcoAutoGeneratedAttribute.EcoAutoGeneratedAttribute Constructor

EcoAutoGeneratedAttribute.EcoAutoGeneratedAttribute Constructor
EcoAutoGeneratedAttribute Class Eco.UmlCodeAttributes Namespace See Also
Collapse All
C#
public EcoAutoGeneratedAttribute();
Remarks

This is EcoAutoGeneratedAttribute, a member of class EcoAutoGeneratedAttribute.

See Also
EcoAutoGeneratedAttribute Class
Eco.UmlCodeAttributes Namespace


EcoAutoMaintainedAttribute Class

EcoAutoMaintainedAttribute Class
Inheritance Hierarchy See Also
Collapse All
C#
public sealed class EcoAutoMaintainedAttribute : Attribute;
Remarks

This is class Eco.UmlCodeAttributes.EcoAutoMaintainedAttribute.

Inheritance Hierarchy
Eco.UmlCodeAttributes.EcoAutoMaintainedAttribute
File

UmlCodeAttributes.cs

See Also
Inheritance Hierarchy


EcoAutoMaintainedAttribute.EcoAutoMaintainedAttribute Constructor

EcoAutoMaintainedAttribute.EcoAutoMaintainedAttribute Constructor
EcoAutoMaintainedAttribute Class Eco.UmlCodeAttributes Namespace See Also
Collapse All
C#
public EcoAutoMaintainedAttribute();
Remarks

This is EcoAutoMaintainedAttribute, a member of class EcoAutoMaintainedAttribute.

See Also
EcoAutoMaintainedAttribute Class
Eco.UmlCodeAttributes Namespace


EcoCodeGenVersionAttribute Class

EcoCodeGenVersionAttribute Class
Inheritance Hierarchy See Also
Collapse All
C#
public sealed class EcoCodeGenVersionAttribute : Attribute;
Remarks

This is class Eco.UmlCodeAttributes.EcoCodeGenVersionAttribute.

Inheritance Hierarchy
Eco.UmlCodeAttributes.EcoCodeGenVersionAttribute
File

UmlCodeAttributes.cs

See Also
Inheritance Hierarchy


EcoCodeGenVersionAttribute Constructor

EcoCodeGenVersionAttribute Constructor

This is the overview for the EcoCodeGenVersionAttribute constructor overload.

Overload List
Name | Description
EcoCodeGenVersionAttribute.EcoCodeGenVersionAttribute () | This is EcoCodeGenVersionAttribute, a member of class EcoCodeGenVersionAttribute.
EcoCodeGenVersionAttribute.EcoCodeGenVersionAttribute (string) | This is EcoCodeGenVersionAttribute, a member of class EcoCodeGenVersionAttribute.
EcoCodeGenVersionAttribute.EcoCodeGenVersionAttribute (string, string) | This is EcoCodeGenVersionAttribute, a member of class EcoCodeGenVersionAttribute.


EcoCodeGenVersionAttribute.EcoCodeGenVersionAttribute Constructor ()

EcoCodeGenVersionAttribute.EcoCodeGenVersionAttribute Constructor ()
EcoCodeGenVersionAttribute Class Eco.UmlCodeAttributes Namespace See Also
Collapse All
C#
public EcoCodeGenVersionAttribute();
Remarks

This is EcoCodeGenVersionAttribute, a member of class EcoCodeGenVersionAttribute.

See Also
EcoCodeGenVersionAttribute Class
Eco.UmlCodeAttributes Namespace


EcoCodeGenVersionAttribute.EcoCodeGenVersionAttribute Constructor (string)

EcoCodeGenVersionAttribute.EcoCodeGenVersionAttribute Constructor (string)
EcoCodeGenVersionAttribute Class Eco.UmlCodeAttributes Namespace See Also
Collapse All
C#
public EcoCodeGenVersionAttribute(
    string version
);
Remarks

This is EcoCodeGenVersionAttribute, a member of class EcoCodeGenVersionAttribute.

See Also
EcoCodeGenVersionAttribute Class
Eco.UmlCodeAttributes Namespace


EcoCodeGenVersionAttribute.EcoCodeGenVersionAttribute Constructor (string, string)

EcoCodeGenVersionAttribute.EcoCodeGenVersionAttribute Constructor (string, string)
EcoCodeGenVersionAttribute Class Eco.UmlCodeAttributes Namespace See Also
Collapse All
C#
public EcoCodeGenVersionAttribute(
    string generator,
    string version
);
Remarks

This is EcoCodeGenVersionAttribute, a member of class EcoCodeGenVersionAttribute.

See Also
EcoCodeGenVersionAttribute Class
Eco.UmlCodeAttributes Namespace


EcoCodeGenVersionAttribute Properties

EcoCodeGenVersionAttribute Properties
Public Properties
Collapse All

The properties of the EcoCodeGenVersionAttribute class are listed here.

Public Properties
Name | Description
Generator | This is Generator, a member of class EcoCodeGenVersionAttribute.
Version | This is Version, a member of class EcoCodeGenVersionAttribute.


EcoCodeGenVersionAttribute.Generator Property

EcoCodeGenVersionAttribute.Generator Property
EcoCodeGenVersionAttribute Class Eco.UmlCodeAttributes Namespace See Also
Collapse All
C#
public string Generator;
Remarks

This is Generator, a member of class EcoCodeGenVersionAttribute.

See Also
EcoCodeGenVersionAttribute Class
Eco.UmlCodeAttributes Namespace


EcoCodeGenVersionAttribute.Version Property

EcoCodeGenVersionAttribute.Version Property
EcoCodeGenVersionAttribute Class Eco.UmlCodeAttributes Namespace See Also
Collapse All
C#
public string Version;
Remarks

This is Version, a member of class EcoCodeGenVersionAttribute.

See Also
EcoCodeGenVersionAttribute Class
Eco.UmlCodeAttributes Namespace


EcoSpaceAttribute Class

EcoSpaceAttribute Class
Inheritance Hierarchy See Also
Collapse All
C#
public sealed class EcoSpaceAttribute : Attribute;
Remarks

This is class Eco.UmlCodeAttributes.EcoSpaceAttribute.

Inheritance Hierarchy
Eco.UmlCodeAttributes.EcoSpaceAttribute
File

UmlCodeAttributes.cs

See Also
Inheritance Hierarchy


EcoSpaceAttribute Constructor

EcoSpaceAttribute Constructor

This is the overview for the EcoSpaceAttribute constructor overload.

Overload List
Name | Description
EcoSpaceAttribute.EcoSpaceAttribute () | This is EcoSpaceAttribute, a member of class EcoSpaceAttribute.
EcoSpaceAttribute.EcoSpaceAttribute (string) | This is EcoSpaceAttribute, a member of class EcoSpaceAttribute.


EcoSpaceAttribute.EcoSpaceAttribute Constructor ()

EcoSpaceAttribute.EcoSpaceAttribute Constructor ()
EcoSpaceAttribute Class Eco.UmlCodeAttributes Namespace See Also
Collapse All
C#
public EcoSpaceAttribute();
Remarks

This is EcoSpaceAttribute, a member of class EcoSpaceAttribute.

See Also
EcoSpaceAttribute Class
Eco.UmlCodeAttributes Namespace


EcoSpaceAttribute.EcoSpaceAttribute Constructor (string)

EcoSpaceAttribute.EcoSpaceAttribute Constructor (string)
EcoSpaceAttribute Class Eco.UmlCodeAttributes Namespace See Also
Collapse All
C#
public EcoSpaceAttribute(
    string name
);
Remarks

This is EcoSpaceAttribute, a member of class EcoSpaceAttribute.

See Also
EcoSpaceAttribute Class
Eco.UmlCodeAttributes Namespace


EcoSpaceAttribute Fields

EcoSpaceAttribute Fields
Public Fields
Collapse All

The fields of the EcoSpaceAttribute class are listed here.

Public Fields
Name | Description
DefaultName | do not localize


EcoSpaceAttribute.DefaultName Field

EcoSpaceAttribute.DefaultName Field
EcoSpaceAttribute Class Eco.UmlCodeAttributes Namespace See Also
Collapse All
C#
public const string DefaultName = "ECOModel";
Remarks

do not localize

See Also
EcoSpaceAttribute Class
Eco.UmlCodeAttributes Namespace


EcoSpaceAttribute Properties

EcoSpaceAttribute Properties
Public Properties
Collapse All

The properties of the EcoSpaceAttribute class are listed here.

Public Properties
Name | Description
Name | This is Name, a member of class EcoSpaceAttribute.


EcoSpaceAttribute.Name Property

EcoSpaceAttribute.Name Property
EcoSpaceAttribute Class Eco.UmlCodeAttributes Namespace See Also
Collapse All
C#
public string Name;
Remarks

This is Name, a member of class EcoSpaceAttribute.

See Also
EcoSpaceAttribute Class
Eco.UmlCodeAttributes Namespace


EcoSpacePackageAttribute Class

EcoSpacePackageAttribute Class
Inheritance Hierarchy See Also
Collapse All
C#
public sealed class EcoSpacePackageAttribute : Attribute;
Remarks

This is class Eco.UmlCodeAttributes.EcoSpacePackageAttribute.

Inheritance Hierarchy
Eco.UmlCodeAttributes.EcoSpacePackageAttribute
File

UmlCodeAttributes.cs

See Also
Inheritance Hierarchy


EcoSpacePackageAttribute.EcoSpacePackageAttribute Constructor

EcoSpacePackageAttribute.EcoSpacePackageAttribute Constructor
EcoSpacePackageAttribute Class Eco.UmlCodeAttributes Namespace See Also
Collapse All
C#
public EcoSpacePackageAttribute(
    System.Type package
);
Remarks

This is EcoSpacePackageAttribute, a member of class EcoSpacePackageAttribute.

See Also
EcoSpacePackageAttribute Class
Eco.UmlCodeAttributes Namespace


EcoSpacePackageAttribute Fields

EcoSpacePackageAttribute Fields
Public Fields
Collapse All

The fields of the EcoSpacePackageAttribute class are listed here.

Public Fields
Name | Description
EcoSpacePackageFieldPrefix | This is EcoSpacePackageFieldPrefix, a member of class EcoSpacePackageAttribute.


EcoSpacePackageAttribute.EcoSpacePackageFieldPrefix Field

EcoSpacePackageAttribute.EcoSpacePackageFieldPrefix Field
EcoSpacePackageAttribute Class Eco.UmlCodeAttributes Namespace See Also
Collapse All
C#
public const string EcoSpacePackageFieldPrefix = "IncludeEcoPackage_";
Remarks

This is EcoSpacePackageFieldPrefix, a member of class EcoSpacePackageAttribute.

See Also
EcoSpacePackageAttribute Class
Eco.UmlCodeAttributes Namespace


EcoSpacePackageAttribute Properties

EcoSpacePackageAttribute Properties
Public Properties
Collapse All

The properties of the EcoSpacePackageAttribute class are listed here.

Public Properties
Name | Description
Package | This is Package, a member of class EcoSpacePackageAttribute.


EcoSpacePackageAttribute.Package Property

EcoSpacePackageAttribute.Package Property
EcoSpacePackageAttribute Class Eco.UmlCodeAttributes Namespace See Also
Collapse All
C#
public System.Type Package;
Remarks

This is Package, a member of class EcoSpacePackageAttribute.

See Also
EcoSpacePackageAttribute Class
Eco.UmlCodeAttributes Namespace


InnerLinkAttribute Class

InnerLinkAttribute Class
Inheritance Hierarchy See Also
Collapse All
C#
public sealed class InnerLinkAttribute : Attribute;
Remarks

This is class Eco.UmlCodeAttributes.InnerLinkAttribute.

Inheritance Hierarchy
Eco.UmlCodeAttributes.InnerLinkAttribute
File

UmlCodeAttributes.cs

See Also
Inheritance Hierarchy


InnerLinkAttribute.InnerLinkAttribute Constructor

InnerLinkAttribute.InnerLinkAttribute Constructor
InnerLinkAttribute Class Eco.UmlCodeAttributes Namespace See Also
Collapse All
C#
public InnerLinkAttribute(
    string id
);
Remarks

This is InnerLinkAttribute, a member of class InnerLinkAttribute.

See Also
InnerLinkAttribute Class
Eco.UmlCodeAttributes Namespace


InnerLinkAttribute Properties

InnerLinkAttribute Properties
Public Properties
Collapse All

The properties of the InnerLinkAttribute class are listed here.

Public Properties
Name | Description
Id | This is Id, a member of class InnerLinkAttribute.


InnerLinkAttribute.Id Property

InnerLinkAttribute.Id Property
InnerLinkAttribute Class Eco.UmlCodeAttributes Namespace See Also
Collapse All
C#
public string Id;
Remarks

This is Id, a member of class InnerLinkAttribute.

See Also
InnerLinkAttribute Class
Eco.UmlCodeAttributes Namespace


LinkRoleAttribute Class

LinkRoleAttribute Class
Inheritance Hierarchy See Also
Collapse All
C#
public sealed class LinkRoleAttribute : Attribute;
Remarks

This is class Eco.UmlCodeAttributes.LinkRoleAttribute.

Inheritance Hierarchy
Eco.UmlCodeAttributes.LinkRoleAttribute
File

UmlCodeAttributes.cs

See Also
Inheritance Hierarchy


LinkRoleAttribute.LinkRoleAttribute Constructor

LinkRoleAttribute.LinkRoleAttribute Constructor
LinkRoleAttribute Class Eco.UmlCodeAttributes Namespace See Also
Collapse All
C#
public LinkRoleAttribute(
    string id
);
Remarks

This is LinkRoleAttribute, a member of class LinkRoleAttribute.

See Also
LinkRoleAttribute Class
Eco.UmlCodeAttributes Namespace


LinkRoleAttribute Properties

LinkRoleAttribute Properties
Public Properties
Collapse All

The properties of the LinkRoleAttribute class are listed here.

Public Properties
Name | Description
Id | This is Id, a member of class LinkRoleAttribute.


LinkRoleAttribute.Id Property

LinkRoleAttribute.Id Property
LinkRoleAttribute Class Eco.UmlCodeAttributes Namespace See Also
Collapse All
C#
public string Id;
Remarks

This is Id, a member of class LinkRoleAttribute.

See Also
LinkRoleAttribute Class
Eco.UmlCodeAttributes Namespace


StateMachineAttribute Class

StateMachineAttribute Class
Inheritance Hierarchy See Also
Collapse All
C#
public sealed class StateMachineAttribute : Attribute;
Remarks

This is class Eco.UmlCodeAttributes.StateMachineAttribute.

Inheritance Hierarchy
Eco.UmlCodeAttributes.StateMachineAttribute
File

UmlCodeAttributes.cs

See Also
Inheritance Hierarchy


StateMachineAttribute.StateMachineAttribute Constructor

StateMachineAttribute.StateMachineAttribute Constructor
StateMachineAttribute Class Eco.UmlCodeAttributes Namespace See Also
Collapse All
C#
public StateMachineAttribute(
    string name,
    string value
);
Remarks

This is StateMachineAttribute, a member of class StateMachineAttribute.

See Also
StateMachineAttribute Class
Eco.UmlCodeAttributes Namespace


StateMachineAttribute Properties

StateMachineAttribute Properties
Public Properties
Collapse All

The properties of the StateMachineAttribute class are listed here.

Public Properties
Name | Description
Name | This is Name, a member of class StateMachineAttribute.
Value | This is Value, a member of class StateMachineAttribute.


StateMachineAttribute.Name Property

StateMachineAttribute.Name Property
StateMachineAttribute Class Eco.UmlCodeAttributes Namespace See Also
Collapse All
C#
public string Name;
Remarks

This is Name, a member of class StateMachineAttribute.

See Also
StateMachineAttribute Class
Eco.UmlCodeAttributes Namespace


StateMachineAttribute.Value Property

StateMachineAttribute.Value Property
StateMachineAttribute Class Eco.UmlCodeAttributes Namespace See Also
Collapse All
C#
public string Value;
Remarks

This is Value, a member of class StateMachineAttribute.

See Also
StateMachineAttribute Class
Eco.UmlCodeAttributes Namespace


UmlCollectionAttribute Class

UmlCollectionAttribute Class
Inheritance Hierarchy See Also
Collapse All
C#
public sealed class UmlCollectionAttribute : Attribute;
Remarks

This is class Eco.UmlCodeAttributes.UmlCollectionAttribute.

Inheritance Hierarchy
Eco.UmlCodeAttributes.UmlCollectionAttribute
File

UmlCodeAttributes.cs

See Also
Inheritance Hierarchy


UmlCollectionAttribute.UmlCollectionAttribute Constructor

UmlCollectionAttribute.UmlCollectionAttribute Constructor
UmlCollectionAttribute Class Eco.UmlCodeAttributes Namespace See Also
Collapse All
C#
public UmlCollectionAttribute(
    System.Type elementType
);
Remarks

This is UmlCollectionAttribute, a member of class UmlCollectionAttribute.

See Also
UmlCollectionAttribute Class
Eco.UmlCodeAttributes Namespace


UmlCollectionAttribute Properties

UmlCollectionAttribute Properties
Public Properties
Collapse All

The properties of the UmlCollectionAttribute class are listed here.

Public Properties
Name | Description
ElementType | This is ElementType, a member of class UmlCollectionAttribute.


UmlCollectionAttribute.ElementType Property

UmlCollectionAttribute.ElementType Property
UmlCollectionAttribute Class Eco.UmlCodeAttributes Namespace See Also
Collapse All
C#
public System.Type ElementType;
Remarks

This is ElementType, a member of class UmlCollectionAttribute.

See Also
UmlCollectionAttribute Class
Eco.UmlCodeAttributes Namespace


UmlElementAttribute Class

UmlElementAttribute Class
Inheritance Hierarchy See Also
Collapse All
C#
public sealed class UmlElementAttribute : Attribute;
Remarks

This is class Eco.UmlCodeAttributes.UmlElementAttribute.

Inheritance Hierarchy
Eco.UmlCodeAttributes.UmlElementAttribute
File

UmlCodeAttributes.cs

See Also
Inheritance Hierarchy


UmlElementAttribute Constructor

UmlElementAttribute Constructor

This is the overview for the UmlElementAttribute constructor overload.

Overload List
Name | Description
UmlElementAttribute.UmlElementAttribute () | This is UmlElementAttribute, a member of class UmlElementAttribute.
UmlElementAttribute.UmlElementAttribute (string) | This is UmlElementAttribute, a member of class UmlElementAttribute.


UmlElementAttribute.UmlElementAttribute Constructor ()

UmlElementAttribute.UmlElementAttribute Constructor ()
UmlElementAttribute Class Eco.UmlCodeAttributes Namespace See Also
Collapse All
C#
public UmlElementAttribute();
Remarks

This is UmlElementAttribute, a member of class UmlElementAttribute.

See Also
UmlElementAttribute Class
Eco.UmlCodeAttributes Namespace


UmlElementAttribute.UmlElementAttribute Constructor (string)

UmlElementAttribute.UmlElementAttribute Constructor (string)
UmlElementAttribute Class Eco.UmlCodeAttributes Namespace See Also
Collapse All
C#
public UmlElementAttribute(
    string metaType
);
Remarks

This is UmlElementAttribute, a member of class UmlElementAttribute.

See Also
UmlElementAttribute Class
Eco.UmlCodeAttributes Namespace


UmlElementAttribute Properties

UmlElementAttribute Properties
Public Properties
Collapse All

The properties of the UmlElementAttribute class are listed here.

Public Properties
Name | Description
Id | This is Id, a member of class UmlElementAttribute.
Index | This is Index, a member of class UmlElementAttribute.
MetaType | This is MetaType, a member of class UmlElementAttribute.


UmlElementAttribute.Id Property

UmlElementAttribute.Id Property
UmlElementAttribute Class Eco.UmlCodeAttributes Namespace See Also
Collapse All
C#
public string Id;
Remarks

This is Id, a member of class UmlElementAttribute.

See Also
UmlElementAttribute Class
Eco.UmlCodeAttributes Namespace


UmlElementAttribute.Index Property

UmlElementAttribute.Index Property
UmlElementAttribute Class Eco.UmlCodeAttributes Namespace See Also
Collapse All
C#
public int Index;
Remarks

This is Index, a member of class UmlElementAttribute.

See Also
UmlElementAttribute Class
Eco.UmlCodeAttributes Namespace


UmlElementAttribute.MetaType Property

UmlElementAttribute.MetaType Property
UmlElementAttribute Class Eco.UmlCodeAttributes Namespace See Also
Collapse All
C#
public string MetaType;
Remarks

This is MetaType, a member of class UmlElementAttribute.

See Also
UmlElementAttribute Class
Eco.UmlCodeAttributes Namespace


UmlMetaAttributeAttribute Class

UmlMetaAttributeAttribute Class
Inheritance Hierarchy See Also
Collapse All
C#
public sealed class UmlMetaAttributeAttribute : Attribute;
Remarks

This is class Eco.UmlCodeAttributes.UmlMetaAttributeAttribute.

Inheritance Hierarchy
Eco.UmlCodeAttributes.UmlMetaAttributeAttribute
File

UmlCodeAttributes.cs

See Also
Inheritance Hierarchy


UmlMetaAttributeAttribute Constructor

UmlMetaAttributeAttribute Constructor

This is the overview for the UmlMetaAttributeAttribute constructor overload.

Overload List
Name | Description
UmlMetaAttributeAttribute.UmlMetaAttributeAttribute (string, bool) | This is UmlMetaAttributeAttribute, a member of class UmlMetaAttributeAttribute.
UmlMetaAttributeAttribute.UmlMetaAttributeAttribute (string, int) | This is UmlMetaAttributeAttribute, a member of class UmlMetaAttributeAttribute.
UmlMetaAttributeAttribute.UmlMetaAttributeAttribute (string, object) | This is UmlMetaAttributeAttribute, a member of class UmlMetaAttributeAttribute.
UmlMetaAttributeAttribute.UmlMetaAttributeAttribute (string, System.Type) | This is UmlMetaAttributeAttribute, a member of class UmlMetaAttributeAttribute.


UmlMetaAttributeAttribute.UmlMetaAttributeAttribute Constructor (string, System.Type)

UmlMetaAttributeAttribute.UmlMetaAttributeAttribute Constructor (string, System.Type)
UmlMetaAttributeAttribute Class Eco.UmlCodeAttributes Namespace See Also
Collapse All
C#
public UmlMetaAttributeAttribute(
    string name,
    System.Type value
);
Remarks

This is UmlMetaAttributeAttribute, a member of class UmlMetaAttributeAttribute.

See Also
UmlMetaAttributeAttribute Class
Eco.UmlCodeAttributes Namespace


UmlMetaAttributeAttribute.UmlMetaAttributeAttribute Constructor (string, bool)

UmlMetaAttributeAttribute.UmlMetaAttributeAttribute Constructor (string, bool)
UmlMetaAttributeAttribute Class Eco.UmlCodeAttributes Namespace See Also
Collapse All
C#
public UmlMetaAttributeAttribute(
    string name,
    bool value
);
Remarks

This is UmlMetaAttributeAttribute, a member of class UmlMetaAttributeAttribute.

See Also
UmlMetaAttributeAttribute Class
Eco.UmlCodeAttributes Namespace


UmlMetaAttributeAttribute.UmlMetaAttributeAttribute Constructor (string, int)

UmlMetaAttributeAttribute.UmlMetaAttributeAttribute Constructor (string, int)
UmlMetaAttributeAttribute Class Eco.UmlCodeAttributes Namespace See Also
Collapse All
C#
public UmlMetaAttributeAttribute(
    string name,
    int value
);
Remarks

This is UmlMetaAttributeAttribute, a member of class UmlMetaAttributeAttribute.

See Also
UmlMetaAttributeAttribute Class
Eco.UmlCodeAttributes Namespace


UmlMetaAttributeAttribute.UmlMetaAttributeAttribute Constructor (string, object)

UmlMetaAttributeAttribute.UmlMetaAttributeAttribute Constructor (string, object)
UmlMetaAttributeAttribute Class Eco.UmlCodeAttributes Namespace See Also
Collapse All
C#
public UmlMetaAttributeAttribute(
    string name,
    object value
);
Remarks

This is UmlMetaAttributeAttribute, a member of class UmlMetaAttributeAttribute.

See Also
UmlMetaAttributeAttribute Class
Eco.UmlCodeAttributes Namespace


UmlMetaAttributeAttribute Properties

UmlMetaAttributeAttribute Properties
Public Properties
Collapse All

The properties of the UmlMetaAttributeAttribute class are listed here.

Public Properties
Name | Description
Index | This is Index, a member of class UmlMetaAttributeAttribute.
Name | This is Name, a member of class UmlMetaAttributeAttribute.
Value | This is Value, a member of class UmlMetaAttributeAttribute.


UmlMetaAttributeAttribute.Index Property

UmlMetaAttributeAttribute.Index Property
UmlMetaAttributeAttribute Class Eco.UmlCodeAttributes Namespace See Also
Collapse All
C#
public int Index;
Remarks

This is Index, a member of class UmlMetaAttributeAttribute.

See Also
UmlMetaAttributeAttribute Class
Eco.UmlCodeAttributes Namespace


UmlMetaAttributeAttribute.Name Property

UmlMetaAttributeAttribute.Name Property
UmlMetaAttributeAttribute Class Eco.UmlCodeAttributes Namespace See Also
Collapse All
C#
public string Name;
Remarks

This is Name, a member of class UmlMetaAttributeAttribute.

See Also
UmlMetaAttributeAttribute Class
Eco.UmlCodeAttributes Namespace


UmlMetaAttributeAttribute.Value Property

UmlMetaAttributeAttribute.Value Property
UmlMetaAttributeAttribute Class Eco.UmlCodeAttributes Namespace See Also
Collapse All
C#
public object Value;
Remarks

This is Value, a member of class UmlMetaAttributeAttribute.

See Also
UmlMetaAttributeAttribute Class
Eco.UmlCodeAttributes Namespace


UmlTaggedValueAttribute Class

UmlTaggedValueAttribute Class
Inheritance Hierarchy See Also
Collapse All
C#
public sealed class UmlTaggedValueAttribute : Attribute;
Remarks

This is class Eco.UmlCodeAttributes.UmlTaggedValueAttribute.

Inheritance Hierarchy
Eco.UmlCodeAttributes.UmlTaggedValueAttribute
File

UmlCodeAttributes.cs

See Also
Inheritance Hierarchy


UmlTaggedValueAttribute.UmlTaggedValueAttribute Constructor

UmlTaggedValueAttribute.UmlTaggedValueAttribute Constructor
UmlTaggedValueAttribute Class Eco.UmlCodeAttributes Namespace See Also
Collapse All
C#
public UmlTaggedValueAttribute(
    string tag,
    string value
);
Remarks

This is UmlTaggedValueAttribute, a member of class UmlTaggedValueAttribute.

See Also
UmlTaggedValueAttribute Class
Eco.UmlCodeAttributes Namespace


UmlTaggedValueAttribute Properties

UmlTaggedValueAttribute Properties
Public Properties
Collapse All

The properties of the UmlTaggedValueAttribute class are listed here.

Public Properties
Name | Description
Tag | This is Tag, a member of class UmlTaggedValueAttribute.
Value | This is Value, a member of class UmlTaggedValueAttribute.


UmlTaggedValueAttribute.Tag Property

UmlTaggedValueAttribute.Tag Property
UmlTaggedValueAttribute Class Eco.UmlCodeAttributes Namespace See Also
Collapse All
C#
public string Tag;
Remarks

This is Tag, a member of class UmlTaggedValueAttribute.

See Also
UmlTaggedValueAttribute Class
Eco.UmlCodeAttributes Namespace


UmlTaggedValueAttribute.Value Property

UmlTaggedValueAttribute.Value Property
UmlTaggedValueAttribute Class Eco.UmlCodeAttributes Namespace See Also
Collapse All
C#
public string Value;
Remarks

This is Value, a member of class UmlTaggedValueAttribute.

See Also
UmlTaggedValueAttribute Class
Eco.UmlCodeAttributes Namespace


Eco.UmlRt Namespace

Eco.UmlRt Namespace
Classes Enumerations Interfaces Structures
Collapse All

This is namespace Eco.UmlRt.

Classes
Name | Description
EcoTaggedValues | This is class Eco.UmlRt.EcoTaggedValues.
ModelElementSameHash | This is class Eco.UmlRt.ModelElementSameHash.
UmlTaggedValues | This is class Eco.UmlRt.UmlTaggedValues.
Top
Enumerations
Name | Description
AggregationKind | Specifies the "default" delete action that ECO should take when an associated object is deleted.
AssociationEndDefaultRegionMode | This is record Eco.UmlRt.AssociationEndDefaultRegionMode.
AssociationEndKind | Specifies the type of object at the other end of an association.
ChangeableKind | This enum is used to identify whether a feature of a UML class is readonly or not.
ClassifierType | Specifies the type of an element.
CollectionTypeKind | Specifies the type of a collection of elements.
DeleteAction | Specifies how associated objects are to be treated when an object is deleted.
FeatureType | Specifies the type of a feature (member) in an ECO class.
LinkFetchStrategy | This enum is used to control how relations are fetched from the persistent storage.
OptimisticLockingMode | This enum is used to specify which optimistic locking technique to use when updating an object instance to the persistent storage.
OrderingKind | Specifies whether or not additional information will be stored in the persistent storage to remember any custom reordering of objects in the association.
ParameterDirectionKind | Specifies the direction of a method's parameter.
PseudostateKind | This enum is used to identify the type of a pseudo state in a state machine.
SaveAction | Specifies the behavior of a class's member after a new instance has been saved to the persistent storage.
ScopeKind | Specifies whether a member is an instance member or a static (class) member.
TableMapping | When ECO is responsible for maintaining the struture of a database this enum will specify how to create table information for the current persistent class.
VisibilityKind | Specifies the visibility of a class's members.
Top
Interfaces
Name | Description
IActivity | Contains model information about a UML modeled method that has been implemented using the Action OCL language rather than as a .NET method.
IAssociation | Contains information about an association between two UML classes that has been defined in the model.
IAssociationCollection | Holds a collection of Eco.UmlRt.IAssociation.
IAssociationEnd | Contains model information about a single end of an association between two modeled classes.
IAttribute | Contains information about a modeled UML attribute.
IAttributeCollection | Holds a collection of Eco.UmlRt.IAttribute.
IBagType | A collection where elements may be added more than once.
IClass | Contains information about a UML class in the model.
IClassCollection | Holds a collection of Eco.UmlRt.IClass.
IClassifier | Contains information about an element within the model.
IClassifierCollection | Holds a collection of Eco.UmlRt.IClassifier
ICollectionKinds | This is class Eco.UmlRt.ICollectionKinds.
ICollectionType | This data type is used to hold a collection of data types.
IConstraint | Contains model information about a constraint.
IConstraintCollection | Holds a collection of Eco.UmlRt.IConstraint.
IDataType | Identifies a model element as a data type such as a collection or a simple type.
IEcoAssociation | This is class Eco.UmlRt.IEcoAssociation.
IEcoAssociationEnd | This is class Eco.UmlRt.IEcoAssociationEnd.
IEcoAttribute | This is class Eco.UmlRt.IEcoAttribute.
IEcoClass | This is class Eco.UmlRt.IEcoClass.
IEcoClassifier | This is class Eco.UmlRt.IEcoClassifier.
IEcoConstraint | This is class Eco.UmlRt.IEcoConstraint.
IEcoEnumerationLiteral | This is class Eco.UmlRt.IEcoEnumerationLiteral.
IEcoFeature | This is class Eco.UmlRt.IEcoFeature.
IEcoMethod | This is class Eco.UmlRt.IEcoMethod.
IEcoPackage | This is class Eco.UmlRt.IEcoPackage.
IEcoPredefinedTypes | This interface provides an appropriate Eco.UmlRt.IDataType.
IEcoPrimitiveType | This is class Eco.UmlRt.IEcoPrimitiveType.
IEcoRegion | This is class Eco.UmlRt.IEcoRegion.
IEcoRegionContainer | Additional support methods for IRegionContainer.
IEcoSimpleType | This is class Eco.UmlRt.IEcoSimpleType.
IEcoState | This is class Eco.UmlRt.IEcoState.
IEcoStateMachine | This is class Eco.UmlRt.IEcoStateMachine.
IEcoStructuralFeature | This is class Eco.UmlRt.IEcoStructuralFeature.
IEcoTypeSystem | Provides model information to the application at runtime.
IEcoVertex | This is class Eco.UmlRt.IEcoVertex.
IEnumerationLiteral | Identifies a single value of an enumeration which may be assigned to a variable of this enumeration type.
IEnumerationLiteralCollection | Holds a collection of Eco.UmlRt.IEnumerationLiteral.
IEnumerationType | Identifies a model element as an enumeration type.
IExpression | Holds modeled expression information.
IFeature | This is the base interface used to represent all features of a modeled UML class.
IFeatureCollection | Holds a collection of Eco.UmlRt.IFeature.
IFeaturedType | This is class Eco.UmlRt.IFeaturedType.
IFinalState | Represents a final state within a modeled state machine.
IMethod | Contains model information about a method added to the model at design time.
IMethodCollection | Holds a collection of Eco.UmlRt.IMethod.
IMethodTrigger | Represents a trigger within a modeled state machine that is invoked via a method call.
IModelElement | The IModelElement is the base interface for all interface types used to represent parts of the business model, such as packages, classes, methods, etc.
IModelElementCollection | Holds a collection of Eco.UmlRt.IModelElement.
IMultiplicity | Contains model information about the multiplicity of an association end.
IOrderedSetType | A collection where elements may be added only once.
IPackage | Contains information about a package in the model.
IPackageCollection | Holds a collection of Eco.UmlRt.IPackage.
IParameter | Contains information about a parameter of a modeled method.
IParameterCollection | Hold a collection of Eco.UmlRt.IParameter.
IPrimitiveType | Identifies a model element as a primitive type, capable of holding primitive .NET values (value types) such as integers, decimals, etc.
IPseudostate | Contains model information about a pseudo state (which is a type of vertex) in a state machine.
IRegion | Contains model information about a region within a state machine.
IRegionCollection | Holds a collection of state machine regions.
IRegionContainer | Identifies a state machine element as being able to contain a collection of state machine regions.
ISequenceType | A collection where elements may be added more than once.
ISetType | A collection where elements may be added only once.
ISimpleType | Identifies a model element as a simple type.
ISimpleTypeCollection | Holds a collection of Eco.UmlRt.ISimpleType.
IState | Contains model information about a state in a state machine.
IStateCollection | Holds a collection of state machine states.
IStateMachine | Contains modeled information about a state machine defined against a modeled UML class.
IStateName | This is class Eco.UmlRt.IStateName.
IStateNamedCollection | This is class Eco.UmlRt.IStateNamedCollection.
IStateRepresentationPart | Provides information about the runtime representation of part of a state (i.e. the state itself and its regions).
IStateRepresentationPartCollection | Holds a collection of state representation parts.
IStereotype | Represents a stereotype entered against a model element. The name of the stereotype is contained in the Name property.
IStereotypeCollection | Holds a collection of Eco.UmlRt.IStereotype
IStructuralFeature | Contains model information about any structural feature on a UML class.
IStructuralFeatureCollection | Holds a collection of Eco.UmlRt.IStructuralFeature.
ITaggedValue | Contains information about a tagged value added to model elements during design time.
ITaggedValueCollection | Holds a collection of tagged values added to the model during design time.
ITransition | Contains model information about a transition from one state to another within a state machine.
ITransitionCollection | Holds a collection of state machine transitions.
ITrigger | Represents a trigger within a modeled state machine.
ITriggerCollection | Holds a collection of state machine triggers.
ITupleType | This is class Eco.UmlRt.ITupleType.
ITypeConverter | This is class Eco.UmlRt.ITypeConverter.
IVertex | Contains model information about a vertex in a state machine.
IVertexCollection | Holds a collection of state machine vertexes.
Top
Structures
Name | Description
ClassifierNamePair | This struct is used while constructing tuples


EcoTaggedValues Class

EcoTaggedValues Class
Inheritance Hierarchy See Also
Collapse All
C#
public abstract class EcoTaggedValues : UmlTaggedValues;
Remarks

This is class Eco.UmlRt.EcoTaggedValues.

Inheritance Hierarchy
Eco.UmlRt.UmlTaggedValues
    Eco.UmlRt.EcoTaggedValues
File

UmlRt.cs

See Also
Inheritance Hierarchy


EcoTaggedValues Classes

EcoTaggedValues Classes
Classes
Collapse All

The classes of the EcoTaggedValues class are listed here.

Classes
Name | Description
DefaultRegionModeTV | Determines how default regions are to be exanded across an association
DeleteActionTV | Determines how to treat the association end when the owning object is deleted
LengthTV | This is class Eco.UmlRt.EcoTaggedValues.LengthTV.
LinkFetchStrategyTV | Controls if fetching a non-embedded link should also fetch the object contents of the related objects.
OptimisticLockingTV | How the object should handle optimistic locking
SaveActionTV | How a member should be handled when written to the database
TableMappingTV | Controls in what table to map instances of a class


EcoTaggedValues.DefaultRegionModeTV Class

EcoTaggedValues.DefaultRegionModeTV Class
Inheritance Hierarchy See Also
Collapse All

Determines how default regions are to be exanded across an association

C#
public class DefaultRegionModeTV : EnumTV;
Inheritance Hierarchy
Eco.UmlRt.EcoTaggedValues.DefaultRegionModeTV
File

UmlRt.cs

See Also
Inheritance Hierarchy


DefaultRegionModeTV Fields

DefaultRegionModeTV Fields
Public Fields
Collapse All

The fields of the DefaultRegionModeTV class are listed here.

Public Fields
Name | Description
Cascade | This is Cascade, a member of class DefaultRegionModeTV.
Default | This is Default, a member of class DefaultRegionModeTV.
Existence | This is Existence, a member of class DefaultRegionModeTV.
IndependentCascade | This is IndependentCascade, a member of class DefaultRegionModeTV.
None | This is None, a member of class DefaultRegionModeTV.


EcoTaggedValues.DefaultRegionModeTV.Cascade Field

EcoTaggedValues.DefaultRegionModeTV.Cascade Field
EcoTaggedValues.DefaultRegionModeTV Class Eco.UmlRt Namespace See Also
Collapse All
C#
public const string Cascade = "Cascade";
Remarks

This is Cascade, a member of class DefaultRegionModeTV.

See Also
EcoTaggedValues.DefaultRegionModeTV Class
Eco.UmlRt Namespace


EcoTaggedValues.DefaultRegionModeTV.Default Field

EcoTaggedValues.DefaultRegionModeTV.Default Field
EcoTaggedValues.DefaultRegionModeTV Class Eco.UmlRt Namespace See Also
Collapse All
C#
public const string Default = "Default";
Remarks

This is Default, a member of class DefaultRegionModeTV.

See Also
EcoTaggedValues.DefaultRegionModeTV Class
Eco.UmlRt Namespace


EcoTaggedValues.DefaultRegionModeTV.Existence Field

EcoTaggedValues.DefaultRegionModeTV.Existence Field
EcoTaggedValues.DefaultRegionModeTV Class Eco.UmlRt Namespace See Also
Collapse All
C#
public const string Existence = "Existence";
Remarks

This is Existence, a member of class DefaultRegionModeTV.

See Also
EcoTaggedValues.DefaultRegionModeTV Class
Eco.UmlRt Namespace


EcoTaggedValues.DefaultRegionModeTV.IndependentCascade Field

EcoTaggedValues.DefaultRegionModeTV.IndependentCascade Field
EcoTaggedValues.DefaultRegionModeTV Class Eco.UmlRt Namespace See Also
Collapse All
C#
public const string IndependentCascade = "IndependentCascade";
Remarks

This is IndependentCascade, a member of class DefaultRegionModeTV.

See Also
EcoTaggedValues.DefaultRegionModeTV Class
Eco.UmlRt Namespace


EcoTaggedValues.DefaultRegionModeTV.None Field

EcoTaggedValues.DefaultRegionModeTV.None Field
EcoTaggedValues.DefaultRegionModeTV Class Eco.UmlRt Namespace See Also
Collapse All
C#
public const string None = "None";
Remarks

This is None, a member of class DefaultRegionModeTV.

See Also
EcoTaggedValues.DefaultRegionModeTV Class
Eco.UmlRt Namespace


DefaultRegionModeTV Methods

DefaultRegionModeTV Methods
Public Methods
Collapse All

The methods of the DefaultRegionModeTV class are listed here.

Public Methods
Name | Description
GetValue |


EcoTaggedValues.DefaultRegionModeTV.GetValue Method

EcoTaggedValues.DefaultRegionModeTV.GetValue Method
EcoTaggedValues.DefaultRegionModeTV Class Eco.UmlRt Namespace See Also
Collapse All
C#
public AssociationEndDefaultRegionMode GetValue(
    ITaggedValueCollection taggedValues,
    AssociationEndDefaultRegionMode defaultValue
);
Exceptions
Exceptions | Description
ArgumentNullException | Thrown if taggedValues is null.
ArgumentOutOfRangeException | Thrown if tagged value is not one of the legal values in AssociationEndDefaultRegionMode.
See Also
EcoTaggedValues.DefaultRegionModeTV Class
Eco.UmlRt Namespace


DefaultRegionModeTV Properties

DefaultRegionModeTV Properties
Public Properties
Collapse All

The properties of the DefaultRegionModeTV class are listed here.

Public Properties
Name | Description
AllValues | This is AllValues, a member of class DefaultRegionModeTV.
Tag | This is Tag, a member of class DefaultRegionModeTV.


EcoTaggedValues.DefaultRegionModeTV.AllValues Property

EcoTaggedValues.DefaultRegionModeTV.AllValues Property
EcoTaggedValues.DefaultRegionModeTV Class Eco.UmlRt Namespace See Also
Collapse All
C#
public override IEnumerable<string> AllValues;
Remarks

This is AllValues, a member of class DefaultRegionModeTV.

See Also
EcoTaggedValues.DefaultRegionModeTV Class
Eco.UmlRt Namespace


EcoTaggedValues.DefaultRegionModeTV.Tag Property

EcoTaggedValues.DefaultRegionModeTV.Tag Property
EcoTaggedValues.DefaultRegionModeTV Class Eco.UmlRt Namespace See Also
Collapse All
C#
public override string Tag;
Remarks

This is Tag, a member of class DefaultRegionModeTV.

See Also
EcoTaggedValues.DefaultRegionModeTV Class
Eco.UmlRt Namespace


EcoTaggedValues.DeleteActionTV Class

EcoTaggedValues.DeleteActionTV Class
Inheritance Hierarchy See Also
Collapse All

Determines how to treat the association end when the owning object is deleted

C#
public class DeleteActionTV : EnumTV;
Inheritance Hierarchy
Eco.UmlRt.EcoTaggedValues.DeleteActionTV
File

UmlRt.cs

See Also
Inheritance Hierarchy


DeleteActionTV Fields

DeleteActionTV Fields
Public Fields
Collapse All

The fields of the DeleteActionTV class are listed here.

Public Fields
Name | Description
Allow | This is Allow, a member of class DeleteActionTV.
Cascade | This is Cascade, a member of class DeleteActionTV.
Default | This is Default, a member of class DeleteActionTV.
Prohibit | This is Prohibit, a member of class DeleteActionTV.


EcoTaggedValues.DeleteActionTV.Allow Field

EcoTaggedValues.DeleteActionTV.Allow Field
EcoTaggedValues.DeleteActionTV Class Eco.UmlRt Namespace See Also
Collapse All
C#
public const string Allow = "Allow";
Remarks

This is Allow, a member of class DeleteActionTV.

See Also
EcoTaggedValues.DeleteActionTV Class
Eco.UmlRt Namespace


EcoTaggedValues.DeleteActionTV.Cascade Field

EcoTaggedValues.DeleteActionTV.Cascade Field
EcoTaggedValues.DeleteActionTV Class Eco.UmlRt Namespace See Also
Collapse All
C#
public const string Cascade = "Cascade";
Remarks

This is Cascade, a member of class DeleteActionTV.

See Also
EcoTaggedValues.DeleteActionTV Class
Eco.UmlRt Namespace


EcoTaggedValues.DeleteActionTV.Default Field

EcoTaggedValues.DeleteActionTV.Default Field
EcoTaggedValues.DeleteActionTV Class Eco.UmlRt Namespace See Also
Collapse All
C#
public const string Default = Default_Value;
Remarks

This is Default, a member of class DeleteActionTV.

See Also
EcoTaggedValues.DeleteActionTV Class
Eco.UmlRt Namespace


EcoTaggedValues.DeleteActionTV.Prohibit Field

EcoTaggedValues.DeleteActionTV.Prohibit Field
EcoTaggedValues.DeleteActionTV Class Eco.UmlRt Namespace See Also
Collapse All
C#
public const string Prohibit = "Prohibit";
Remarks

This is Prohibit, a member of class DeleteActionTV.

See Also
EcoTaggedValues.DeleteActionTV Class
Eco.UmlRt Namespace


DeleteActionTV Methods

DeleteActionTV Methods
Public Methods
Collapse All

The methods of the DeleteActionTV class are listed here.

Public Methods
Name | Description
GetValue |
StringToDeleteAction | Converts a string to the corresponding DeleteAction-value


EcoTaggedValues.DeleteActionTV.GetValue Method

EcoTaggedValues.DeleteActionTV.GetValue Method
EcoTaggedValues.DeleteActionTV Class Eco.UmlRt Namespace See Also
Collapse All
C#
public UmlRt.DeleteAction GetValue(
    ITaggedValueCollection taggedValues,
    UmlRt.DeleteAction defaultValue
);
Exceptions
Exceptions | Description
ArgumentNullException | Thrown if taggedValues is null.
See Also
EcoTaggedValues.DeleteActionTV Class
Eco.UmlRt Namespace


EcoTaggedValues.DeleteActionTV.StringToDeleteAction Method

EcoTaggedValues.DeleteActionTV.StringToDeleteAction Method
EcoTaggedValues.DeleteActionTV Class Eco.UmlRt Namespace See Also
Collapse All

Converts a string to the corresponding DeleteAction-value

C#
public UmlRt.DeleteAction StringToDeleteAction(
    string value,
    UmlRt.DeleteAction defaultValue
);
Exceptions
Exceptions | Description
ArgumentOutOfRangeException | Thrown if tagged value is not one of the legal values in DeleteAction.
See Also
EcoTaggedValues.DeleteActionTV Class
Eco.UmlRt Namespace


DeleteActionTV Properties

DeleteActionTV Properties
Public Properties
Collapse All

The properties of the DeleteActionTV class are listed here.

Public Properties
Name | Description
AllValues | This is AllValues, a member of class DeleteActionTV.
Tag | This is Tag, a member of class DeleteActionTV.


EcoTaggedValues.DeleteActionTV.AllValues Property

EcoTaggedValues.DeleteActionTV.AllValues Property
EcoTaggedValues.DeleteActionTV Class Eco.UmlRt Namespace See Also
Collapse All
C#
public override IEnumerable<string> AllValues;
Remarks

This is AllValues, a member of class DeleteActionTV.

See Also
EcoTaggedValues.DeleteActionTV Class
Eco.UmlRt Namespace


EcoTaggedValues.DeleteActionTV.Tag Property

EcoTaggedValues.DeleteActionTV.Tag Property
EcoTaggedValues.DeleteActionTV Class Eco.UmlRt Namespace See Also
Collapse All
C#
public override string Tag;
Remarks

This is Tag, a member of class DeleteActionTV.

See Also
EcoTaggedValues.DeleteActionTV Class
Eco.UmlRt Namespace


EcoTaggedValues.LengthTV Class

EcoTaggedValues.LengthTV Class
Inheritance Hierarchy See Also
Collapse All
C#
public class LengthTV : StringTV;
Remarks

This is class Eco.UmlRt.EcoTaggedValues.LengthTV.

Inheritance Hierarchy
Eco.UmlRt.EcoTaggedValues.LengthTV
File

UmlRt.cs

See Also
Inheritance Hierarchy


EcoTaggedValues.LengthTV.LengthTV Constructor

EcoTaggedValues.LengthTV.LengthTV Constructor
EcoTaggedValues.LengthTV Class Eco.UmlRt Namespace See Also
Collapse All
C#
public LengthTV(
    string tag
);
Remarks

This is LengthTV, a member of class LengthTV.

See Also
EcoTaggedValues.LengthTV Class
Eco.UmlRt Namespace


LengthTV Fields

LengthTV Fields
Public Fields
Collapse All

The fields of the LengthTV class are listed here.

Public Fields
Name | Description
DefaultLength | This is DefaultLength, a member of class LengthTV.


EcoTaggedValues.LengthTV.DefaultLength Field

EcoTaggedValues.LengthTV.DefaultLength Field
EcoTaggedValues.LengthTV Class Eco.UmlRt Namespace See Also
Collapse All
C#
public const int DefaultLength = 255;
Remarks

This is DefaultLength, a member of class LengthTV.

See Also
EcoTaggedValues.LengthTV Class
Eco.UmlRt Namespace


EcoTaggedValues.LinkFetchStrategyTV Class

EcoTaggedValues.LinkFetchStrategyTV Class
Inheritance Hierarchy See Also
Collapse All

Controls if fetching a non-embedded link should also fetch the object contents of the related objects.

C#
public class LinkFetchStrategyTV : EnumTV;
Inheritance Hierarchy
Eco.UmlRt.EcoTaggedValues.LinkFetchStrategyTV
File

UmlRt.cs

See Also
Inheritance Hierarchy


LinkFetchStrategyTV Fields

LinkFetchStrategyTV Fields
Public Fields
Collapse All

The fields of the LinkFetchStrategyTV class are listed here.

Public Fields
Name | Description
Default | This is Default, a member of class LinkFetchStrategyTV.
FetchObjects | This is FetchObjects, a member of class LinkFetchStrategyTV.
IdsOnly | This is IdsOnly, a member of class LinkFetchStrategyTV.


EcoTaggedValues.LinkFetchStrategyTV.Default Field

EcoTaggedValues.LinkFetchStrategyTV.Default Field
EcoTaggedValues.LinkFetchStrategyTV Class Eco.UmlRt Namespace See Also
Collapse All
C#
public const string Default = Default_Value;
Remarks

This is Default, a member of class LinkFetchStrategyTV.

See Also
EcoTaggedValues.LinkFetchStrategyTV Class
Eco.UmlRt Namespace


EcoTaggedValues.LinkFetchStrategyTV.FetchObjects Field

EcoTaggedValues.LinkFetchStrategyTV.FetchObjects Field
EcoTaggedValues.LinkFetchStrategyTV Class Eco.UmlRt Namespace See Also
Collapse All
C#
public const string FetchObjects = "FetchObjects";
Remarks

This is FetchObjects, a member of class LinkFetchStrategyTV.

See Also
EcoTaggedValues.LinkFetchStrategyTV Class
Eco.UmlRt Namespace


EcoTaggedValues.LinkFetchStrategyTV.IdsOnly Field

EcoTaggedValues.LinkFetchStrategyTV.IdsOnly Field
EcoTaggedValues.LinkFetchStrategyTV Class Eco.UmlRt Namespace See Also
Collapse All
C#
public const string IdsOnly = "IdsOnly";
Remarks

This is IdsOnly, a member of class LinkFetchStrategyTV.

See Also
EcoTaggedValues.LinkFetchStrategyTV Class
Eco.UmlRt Namespace


LinkFetchStrategyTV Methods

LinkFetchStrategyTV Methods
Public Methods
Collapse All

The methods of the LinkFetchStrategyTV class are listed here.

Public Methods
Name | Description
GetValue |


EcoTaggedValues.LinkFetchStrategyTV.GetValue Method

EcoTaggedValues.LinkFetchStrategyTV.GetValue Method
EcoTaggedValues.LinkFetchStrategyTV Class Eco.UmlRt Namespace See Also
Collapse All
C#
public UmlRt.LinkFetchStrategy GetValue(
    ITaggedValueCollection taggedValues
);
Exceptions
Exceptions | Description
ArgumentNullException | Thrown if taggedValues is null.
ArgumentOutOfRangeException | Thrown if tagged value is not one of the legal values in TableMapping.
See Also
EcoTaggedValues.LinkFetchStrategyTV Class
Eco.UmlRt Namespace


LinkFetchStrategyTV Properties

LinkFetchStrategyTV Properties
Public Properties
Collapse All

The properties of the LinkFetchStrategyTV class are listed here.

Public Properties
Name | Description
AllValues | This is AllValues, a member of class LinkFetchStrategyTV.
Tag | This is Tag, a member of class LinkFetchStrategyTV.


EcoTaggedValues.LinkFetchStrategyTV.AllValues Property

EcoTaggedValues.LinkFetchStrategyTV.AllValues Property
EcoTaggedValues.LinkFetchStrategyTV Class Eco.UmlRt Namespace See Also
Collapse All
C#
public override IEnumerable<string> AllValues;
Remarks

This is AllValues, a member of class LinkFetchStrategyTV.

See Also
EcoTaggedValues.LinkFetchStrategyTV Class
Eco.UmlRt Namespace


EcoTaggedValues.LinkFetchStrategyTV.Tag Property

EcoTaggedValues.LinkFetchStrategyTV.Tag Property
EcoTaggedValues.LinkFetchStrategyTV Class Eco.UmlRt Namespace See Also
Collapse All
C#
public override string Tag;
Remarks

This is Tag, a member of class LinkFetchStrategyTV.

See Also
EcoTaggedValues.LinkFetchStrategyTV Class
Eco.UmlRt Namespace


EcoTaggedValues.OptimisticLockingTV Class

EcoTaggedValues.OptimisticLockingTV Class
Inheritance Hierarchy See Also
Collapse All

How the object should handle optimistic locking

C#
public class OptimisticLockingTV : EnumTV;
Inheritance Hierarchy
Eco.UmlRt.EcoTaggedValues.OptimisticLockingTV
File

UmlRt.cs

See Also
Inheritance Hierarchy


OptimisticLockingTV Fields

OptimisticLockingTV Fields
Public Fields
Collapse All

The fields of the OptimisticLockingTV class are listed here.

Public Fields
Name | Description
AllMembers | This is AllMembers, a member of class OptimisticLockingTV.
Default | This is Default, a member of class OptimisticLockingTV.
ModifiedMembers | This is ModifiedMembers, a member of class OptimisticLockingTV.
Off | This is Off, a member of class OptimisticLockingTV.
TimeStamp | This is TimeStamp, a member of class OptimisticLockingTV.


EcoTaggedValues.OptimisticLockingTV.AllMembers Field

EcoTaggedValues.OptimisticLockingTV.AllMembers Field
EcoTaggedValues.OptimisticLockingTV Class Eco.UmlRt Namespace See Also
Collapse All
C#
public const string AllMembers = "AllMembers";
Remarks

This is AllMembers, a member of class OptimisticLockingTV.

See Also
EcoTaggedValues.OptimisticLockingTV Class
Eco.UmlRt Namespace


EcoTaggedValues.OptimisticLockingTV.Default Field

EcoTaggedValues.OptimisticLockingTV.Default Field
EcoTaggedValues.OptimisticLockingTV Class Eco.UmlRt Namespace See Also
Collapse All
C#
public const string Default = Default_Value;
Remarks

This is Default, a member of class OptimisticLockingTV.

See Also
EcoTaggedValues.OptimisticLockingTV Class
Eco.UmlRt Namespace


EcoTaggedValues.OptimisticLockingTV.ModifiedMembers Field

EcoTaggedValues.OptimisticLockingTV.ModifiedMembers Field
EcoTaggedValues.OptimisticLockingTV Class Eco.UmlRt Namespace See Also
Collapse All
C#
public const string ModifiedMembers = "ModifiedMembers";
Remarks

This is ModifiedMembers, a member of class OptimisticLockingTV.

See Also
EcoTaggedValues.OptimisticLockingTV Class
Eco.UmlRt Namespace


EcoTaggedValues.OptimisticLockingTV.Off Field

EcoTaggedValues.OptimisticLockingTV.Off Field
EcoTaggedValues.OptimisticLockingTV Class Eco.UmlRt Namespace See Also
Collapse All
C#
public const string Off = "Off";
Remarks

This is Off, a member of class OptimisticLockingTV.

See Also
EcoTaggedValues.OptimisticLockingTV Class
Eco.UmlRt Namespace


EcoTaggedValues.OptimisticLockingTV.TimeStamp Field

EcoTaggedValues.OptimisticLockingTV.TimeStamp Field
EcoTaggedValues.OptimisticLockingTV Class Eco.UmlRt Namespace See Also
Collapse All
C#
public const string TimeStamp = "TimeStamp";
Remarks

This is TimeStamp, a member of class OptimisticLockingTV.

See Also
EcoTaggedValues.OptimisticLockingTV Class
Eco.UmlRt Namespace


OptimisticLockingTV Methods

OptimisticLockingTV Methods
Public Methods
Collapse All

The methods of the OptimisticLockingTV class are listed here.

Public Methods
Name | Description
GetValue |


EcoTaggedValues.OptimisticLockingTV.GetValue Method

EcoTaggedValues.OptimisticLockingTV.GetValue Method
EcoTaggedValues.OptimisticLockingTV Class Eco.UmlRt Namespace See Also
Collapse All
C#
public OptimisticLockingMode GetValue(
    ITaggedValueCollection taggedValues,
    OptimisticLockingMode defaultValue
);
Exceptions
Exceptions | Description
ArgumentNullException | Thrown if taggedValues is null.
ArgumentOutOfRangeException | Thrown if tagged value is not one of the legal values in OptimisticLockingMode.
See Also
EcoTaggedValues.OptimisticLockingTV Class
Eco.UmlRt Namespace


OptimisticLockingTV Properties

OptimisticLockingTV Properties
Public Properties
Collapse All

The properties of the OptimisticLockingTV class are listed here.

Public Properties
Name | Description
AllValues | This is AllValues, a member of class OptimisticLockingTV.
Tag | This is Tag, a member of class OptimisticLockingTV.


EcoTaggedValues.OptimisticLockingTV.AllValues Property

EcoTaggedValues.OptimisticLockingTV.AllValues Property
EcoTaggedValues.OptimisticLockingTV Class Eco.UmlRt Namespace See Also
Collapse All
C#
public override IEnumerable<string> AllValues;
Remarks

This is AllValues, a member of class OptimisticLockingTV.

See Also
EcoTaggedValues.OptimisticLockingTV Class
Eco.UmlRt Namespace


EcoTaggedValues.OptimisticLockingTV.Tag Property

EcoTaggedValues.OptimisticLockingTV.Tag Property
EcoTaggedValues.OptimisticLockingTV Class Eco.UmlRt Namespace See Also
Collapse All
C#
public override string Tag;
Remarks

This is Tag, a member of class OptimisticLockingTV.

See Also
EcoTaggedValues.OptimisticLockingTV Class
Eco.UmlRt Namespace


EcoTaggedValues.SaveActionTV Class

EcoTaggedValues.SaveActionTV Class
Inheritance Hierarchy See Also
Collapse All

How a member should be handled when written to the database

C#
public class SaveActionTV : EnumTV;
Inheritance Hierarchy
Eco.UmlRt.EcoTaggedValues.SaveActionTV
File

UmlRt.cs

See Also
Inheritance Hierarchy


SaveActionTV Fields

SaveActionTV Fields
Public Fields
Collapse All

The fields of the SaveActionTV class are listed here.

Public Fields
Name | Description
DbAssign | This is DbAssign, a member of class SaveActionTV.
Freeze | This is Freeze, a member of class SaveActionTV.
None | This is None, a member of class SaveActionTV.


EcoTaggedValues.SaveActionTV.DbAssign Field

EcoTaggedValues.SaveActionTV.DbAssign Field
EcoTaggedValues.SaveActionTV Class Eco.UmlRt Namespace See Also
Collapse All
C#
public const string DbAssign = "DbAssign";
Remarks

This is DbAssign, a member of class SaveActionTV.

See Also
EcoTaggedValues.SaveActionTV Class
Eco.UmlRt Namespace


EcoTaggedValues.SaveActionTV.Freeze Field

EcoTaggedValues.SaveActionTV.Freeze Field
EcoTaggedValues.SaveActionTV Class Eco.UmlRt Namespace See Also
Collapse All
C#
public const string Freeze = "Freeze";
Remarks

This is Freeze, a member of class SaveActionTV.

See Also
EcoTaggedValues.SaveActionTV Class
Eco.UmlRt Namespace


EcoTaggedValues.SaveActionTV.None Field

EcoTaggedValues.SaveActionTV.None Field
EcoTaggedValues.SaveActionTV Class Eco.UmlRt Namespace See Also
Collapse All
C#
public const string None = "None";
Remarks

This is None, a member of class SaveActionTV.

See Also
EcoTaggedValues.SaveActionTV Class
Eco.UmlRt Namespace


SaveActionTV Methods

SaveActionTV Methods
Public Methods
Collapse All

The methods of the SaveActionTV class are listed here.

Public Methods
Name | Description
GetValue |


EcoTaggedValues.SaveActionTV.GetValue Method

EcoTaggedValues.SaveActionTV.GetValue Method
EcoTaggedValues.SaveActionTV Class Eco.UmlRt Namespace See Also
Collapse All
C#
public UmlRt.SaveAction GetValue(
    ITaggedValueCollection taggedValues
);
Exceptions
Exceptions | Description
ArgumentNullException | Thrown if taggedValues is null.
ArgumentOutOfRangeException | Thrown if tagged value is not one of the legal values in SaveAction.
See Also
EcoTaggedValues.SaveActionTV Class
Eco.UmlRt Namespace


SaveActionTV Properties

SaveActionTV Properties
Public Properties
Collapse All

The properties of the SaveActionTV class are listed here.

Public Properties
Name | Description
AllValues | This is AllValues, a member of class SaveActionTV.
Instance | This is Instance, a member of class SaveActionTV.
Tag | This is Tag, a member of class SaveActionTV.


EcoTaggedValues.SaveActionTV.AllValues Property

EcoTaggedValues.SaveActionTV.AllValues Property
EcoTaggedValues.SaveActionTV Class Eco.UmlRt Namespace See Also
Collapse All
C#
public override IEnumerable<string> AllValues;
Remarks

This is AllValues, a member of class SaveActionTV.

See Also
EcoTaggedValues.SaveActionTV Class
Eco.UmlRt Namespace


EcoTaggedValues.SaveActionTV.Instance Property

EcoTaggedValues.SaveActionTV.Instance Property
EcoTaggedValues.SaveActionTV Class Eco.UmlRt Namespace See Also
Collapse All
C#
public static SaveAction Instance;
Remarks

This is Instance, a member of class SaveActionTV.

See Also
EcoTaggedValues.SaveActionTV Class
Eco.UmlRt Namespace


EcoTaggedValues.SaveActionTV.Tag Property

EcoTaggedValues.SaveActionTV.Tag Property
EcoTaggedValues.SaveActionTV Class Eco.UmlRt Namespace See Also
Collapse All
C#
public override string Tag;
Remarks

This is Tag, a member of class SaveActionTV.

See Also
EcoTaggedValues.SaveActionTV Class
Eco.UmlRt Namespace


EcoTaggedValues.TableMappingTV Class

EcoTaggedValues.TableMappingTV Class
Inheritance Hierarchy See Also
Collapse All

Controls in what table to map instances of a class

C#
public class TableMappingTV : EnumTV;
Inheritance Hierarchy
Eco.UmlRt.EcoTaggedValues.TableMappingTV
File

UmlRt.cs

See Also
Inheritance Hierarchy


TableMappingTV Fields

TableMappingTV Fields
Public Fields
Collapse All

The fields of the TableMappingTV class are listed here.

Public Fields
Name | Description
Children | This is Children, a member of class TableMappingTV.
Own | This is Own, a member of class TableMappingTV.
Parent | This is Parent, a member of class TableMappingTV.


EcoTaggedValues.TableMappingTV.Children Field

EcoTaggedValues.TableMappingTV.Children Field
EcoTaggedValues.TableMappingTV Class Eco.UmlRt Namespace See Also
Collapse All
C#
public const string Children = "Children";
Remarks

This is Children, a member of class TableMappingTV.

See Also
EcoTaggedValues.TableMappingTV Class
Eco.UmlRt Namespace


EcoTaggedValues.TableMappingTV.Own Field

EcoTaggedValues.TableMappingTV.Own Field
EcoTaggedValues.TableMappingTV Class Eco.UmlRt Namespace See Also
Collapse All
C#
public const string Own = "Own";
Remarks

This is Own, a member of class TableMappingTV.

See Also
EcoTaggedValues.TableMappingTV Class
Eco.UmlRt Namespace


EcoTaggedValues.TableMappingTV.Parent Field

EcoTaggedValues.TableMappingTV.Parent Field
EcoTaggedValues.TableMappingTV Class Eco.UmlRt Namespace See Also
Collapse All
C#
public const string Parent = "Parent";
Remarks

This is Parent, a member of class TableMappingTV.

See Also
EcoTaggedValues.TableMappingTV Class
Eco.UmlRt Namespace


TableMappingTV Methods

TableMappingTV Methods
Public Methods
Collapse All

The methods of the TableMappingTV class are listed here.

Public Methods
Name | Description
GetValue |


EcoTaggedValues.TableMappingTV.GetValue Method

EcoTaggedValues.TableMappingTV.GetValue Method
EcoTaggedValues.TableMappingTV Class Eco.UmlRt Namespace See Also
Collapse All
C#
public UmlRt.TableMapping GetValue(
    ITaggedValueCollection taggedValues
);
Exceptions
Exceptions | Description
ArgumentNullException | Thrown if taggedValues is null.
ArgumentOutOfRangeException | Thrown if tagged value is not one of the legal values in TableMapping.
See Also
EcoTaggedValues.TableMappingTV Class
Eco.UmlRt Namespace


TableMappingTV Properties

TableMappingTV Properties
Public Properties
Collapse All

The properties of the TableMappingTV class are listed here.

Public Properties
Name | Description
AllValues | This is AllValues, a member of class TableMappingTV.
Tag | This is Tag, a member of class TableMappingTV.


EcoTaggedValues.TableMappingTV.AllValues Property

EcoTaggedValues.TableMappingTV.AllValues Property
EcoTaggedValues.TableMappingTV Class Eco.UmlRt Namespace See Also
Collapse All
C#
public override IEnumerable<string> AllValues;
Remarks

This is AllValues, a member of class TableMappingTV.

See Also
EcoTaggedValues.TableMappingTV Class
Eco.UmlRt Namespace


EcoTaggedValues.TableMappingTV.Tag Property

EcoTaggedValues.TableMappingTV.Tag Property
EcoTaggedValues.TableMappingTV Class Eco.UmlRt Namespace See Also
Collapse All
C#
public override string Tag;
Remarks

This is Tag, a member of class TableMappingTV.

See Also
EcoTaggedValues.TableMappingTV Class
Eco.UmlRt Namespace


EcoTaggedValues Fields

EcoTaggedValues Fields
Public Fields
Collapse All

The fields of the EcoTaggedValues class are listed here.

Public Fields
Name | Description
AllowNULL | This is AllowNULL, a member of class EcoTaggedValues.
Body | This is Body, a member of class EcoTaggedValues.
ColumnName | This is ColumnName, a member of class EcoTaggedValues.
DatabaseName | This is DatabaseName, a member of class EcoTaggedValues.
DbSignature | This is DbSignature, a member of class EcoTaggedValues.
Default_Value | This is Default_Value, a member of class EcoTaggedValues.
DefaultColor | This is DefaultColor, a member of class EcoTaggedValues.
DefaultDBValue | This is DefaultDBValue, a member of class EcoTaggedValues.
DefaultRegionMode | This is DefaultRegionMode, a member of class EcoTaggedValues.
DefaultStringRepresentation | This is DefaultStringRepresentation, a member of class EcoTaggedValues.
DelayedFetch | This is DelayedFetch, a member of class EcoTaggedValues.
DeleteAction | This is DeleteAction, a member of class EcoTaggedValues.
DerivationExpressions | This is DerivationExpressions, a member of class EcoTaggedValues.
DerivationOCL | This is DerivationOCL, a member of class EcoTaggedValues.
DerivedSettable | This is DerivedSettable, a member of class EcoTaggedValues.
Discriminator | This is Discriminator, a member of class EcoTaggedValues.
DiscriminatorImpl | This is DiscriminatorImpl, a member of class EcoTaggedValues.
DiscriminatorValue | This is DiscriminatorValue, a member of class EcoTaggedValues.
EcoPrefix | This is EcoPrefix, a member of class EcoTaggedValues.
Embed | This is Embed, a member of class EcoTaggedValues.
FormerNames | This is FormerNames, a member of class EcoTaggedValues.
GenerateDefaultRegion | This is GenerateDefaultRegion, a member of class EcoTaggedValues.
GenerateDefaultRegions | This is GenerateDefaultRegions, a member of class EcoTaggedValues.
GenerateMultiplicityConstraints | This is GenerateMultiplicityConstraints, a member of class EcoTaggedValues.
HasUserCode | This is HasUserCode, a member of class EcoTaggedValues.
IsConstrained | This is IsConstrained, a member of class EcoTaggedValues.
IsStateAttribute | This is IsStateAttribute, a member of class EcoTaggedValues.
IsTrigger | This is IsTrigger, a member of class EcoTaggedValues.
Length | This is Length, a member of class EcoTaggedValues.
LinkFetchStrategy | This is LinkFetchStrategy, a member of class EcoTaggedValues.
Name | This is Name, a member of class EcoTaggedValues.
OptimisticLocking | This is OptimisticLocking, a member of class EcoTaggedValues.
Ordered | This is Ordered, a member of class EcoTaggedValues.
PMapperName | This is PMapperName, a member of class EcoTaggedValues.
Precondition | This is Precondition, a member of class EcoTaggedValues.
PrimaryKey | This is PrimaryKey, a member of class EcoTaggedValues.
PrimaryKeyMapper | This is PrimaryKeyMapper, a member of class EcoTaggedValues.
RegionDefinitions | This is RegionDefinitions, a member of class EcoTaggedValues.
Representation | This is Representation, a member of class EcoTaggedValues.
SaveAction | This is SaveAction, a member of class EcoTaggedValues.
StateAttributeDeprecated | This is StateAttributeDeprecated, a member of class EcoTaggedValues.
TableMapping | This is TableMapping, a member of class EcoTaggedValues.
TableName | This is TableName, a member of class EcoTaggedValues.
Versioned | This is Versioned, a member of class EcoTaggedValues.


EcoTaggedValues.AllowNULL Field

EcoTaggedValues.AllowNULL Field
EcoTaggedValues Class Eco.UmlRt Namespace See Also
Collapse All
C#
public static readonly BooleanTV AllowNULL = new BooleanTV(EcoPrefix + "AllowNULL");
Remarks

This is AllowNULL, a member of class EcoTaggedValues.

See Also
EcoTaggedValues Class
Eco.UmlRt Namespace


EcoTaggedValues.Body Field

EcoTaggedValues.Body Field
EcoTaggedValues Class Eco.UmlRt Namespace See Also
Collapse All
C#
public static readonly StringTV Body = new StringTV(EcoPrefix + "Body");
Remarks

This is Body, a member of class EcoTaggedValues.

See Also
EcoTaggedValues Class
Eco.UmlRt Namespace


EcoTaggedValues.ColumnName Field

EcoTaggedValues.ColumnName Field
EcoTaggedValues Class Eco.UmlRt Namespace See Also
Collapse All
C#
public static readonly StringTV ColumnName = new StringTV(EcoPrefix + "ColumnName");
Remarks

This is ColumnName, a member of class EcoTaggedValues.

See Also
EcoTaggedValues Class
Eco.UmlRt Namespace


EcoTaggedValues.DatabaseName Field

EcoTaggedValues.DatabaseName Field
EcoTaggedValues Class Eco.UmlRt Namespace See Also
Collapse All
C#
public static readonly StringTV DatabaseName = new StringTV(EcoPrefix + "Database");
Remarks

This is DatabaseName, a member of class EcoTaggedValues.

See Also
EcoTaggedValues Class
Eco.UmlRt Namespace


EcoTaggedValues.DbSignature Field

EcoTaggedValues.DbSignature Field
EcoTaggedValues Class Eco.UmlRt Namespace See Also
Collapse All
C#
public static readonly StringTV DbSignature = new StringTV(EcoPrefix + "DbSignature");
Remarks

This is DbSignature, a member of class EcoTaggedValues.

See Also
EcoTaggedValues Class
Eco.UmlRt Namespace


EcoTaggedValues.Default_Value Field

EcoTaggedValues.Default_Value Field
EcoTaggedValues Class Eco.UmlRt Namespace See Also
Collapse All
C#
public const string Default_Value = "<Default>";
Remarks

This is Default_Value, a member of class EcoTaggedValues.

See Also
EcoTaggedValues Class
Eco.UmlRt Namespace


EcoTaggedValues.DefaultColor Field

EcoTaggedValues.DefaultColor Field
EcoTaggedValues Class Eco.UmlRt Namespace See Also
Collapse All
C#
public static readonly StringTV DefaultColor = new StringTV(EcoPrefix + "DefaultColor");
Remarks

This is DefaultColor, a member of class EcoTaggedValues.

See Also
EcoTaggedValues Class
Eco.UmlRt Namespace


EcoTaggedValues.DefaultDBValue Field

EcoTaggedValues.DefaultDBValue Field
EcoTaggedValues Class Eco.UmlRt Namespace See Also
Collapse All
C#
public static readonly StringTV DefaultDBValue = new StringTV(EcoPrefix + "DefaultDBValue");
Remarks

This is DefaultDBValue, a member of class EcoTaggedValues.

See Also
EcoTaggedValues Class
Eco.UmlRt Namespace


EcoTaggedValues.DefaultRegionMode Field

EcoTaggedValues.DefaultRegionMode Field
EcoTaggedValues Class Eco.UmlRt Namespace See Also
Collapse All
C#
public static readonly DefaultRegionModeTV DefaultRegionMode = new DefaultRegionModeTV();
Remarks

This is DefaultRegionMode, a member of class EcoTaggedValues.

See Also
EcoTaggedValues Class
Eco.UmlRt Namespace


EcoTaggedValues.DefaultStringRepresentation Field

EcoTaggedValues.DefaultStringRepresentation Field
EcoTaggedValues Class Eco.UmlRt Namespace See Also
Collapse All
C#
public static readonly StringTV DefaultStringRepresentation = new StringTV(EcoPrefix + "DefaultStringRepresentation");
Remarks

This is DefaultStringRepresentation, a member of class EcoTaggedValues.

See Also
EcoTaggedValues Class
Eco.UmlRt Namespace


EcoTaggedValues.DelayedFetch Field

EcoTaggedValues.DelayedFetch Field
EcoTaggedValues Class Eco.UmlRt Namespace See Also
Collapse All
C#
public static readonly BooleanTV DelayedFetch = new BooleanTV(EcoPrefix + "DelayedFetch");
Remarks

This is DelayedFetch, a member of class EcoTaggedValues.

See Also
EcoTaggedValues Class
Eco.UmlRt Namespace


EcoTaggedValues.DeleteAction Field

EcoTaggedValues.DeleteAction Field
EcoTaggedValues Class Eco.UmlRt Namespace See Also
Collapse All
C#
public static readonly DeleteActionTV DeleteAction = new DeleteActionTV();
Remarks

This is DeleteAction, a member of class EcoTaggedValues.

See Also
EcoTaggedValues Class
Eco.UmlRt Namespace


EcoTaggedValues.DerivationExpressions Field

EcoTaggedValues.DerivationExpressions Field
EcoTaggedValues Class Eco.UmlRt Namespace See Also
Collapse All
C#
public static readonly StringTV DerivationExpressions = new StringTV(EcoPrefix + "DerivationExpressions");
Remarks

This is DerivationExpressions, a member of class EcoTaggedValues.

See Also
EcoTaggedValues Class
Eco.UmlRt Namespace


EcoTaggedValues.DerivationOCL Field

EcoTaggedValues.DerivationOCL Field
EcoTaggedValues Class Eco.UmlRt Namespace See Also
Collapse All
C#
public static readonly StringTV DerivationOCL = new StringTV(EcoPrefix + "DerivationOCL");
Remarks

This is DerivationOCL, a member of class EcoTaggedValues.

See Also
EcoTaggedValues Class
Eco.UmlRt Namespace


EcoTaggedValues.DerivedSettable Field

EcoTaggedValues.DerivedSettable Field
EcoTaggedValues Class Eco.UmlRt Namespace See Also
Collapse All
C#
public static readonly BooleanTV DerivedSettable = new BooleanTV(EcoPrefix + "DerivedSettable");
Remarks

This is DerivedSettable, a member of class EcoTaggedValues.

See Also
EcoTaggedValues Class
Eco.UmlRt Namespace


EcoTaggedValues.Discriminator Field

EcoTaggedValues.Discriminator Field
EcoTaggedValues Class Eco.UmlRt Namespace See Also
Collapse All
C#
public static readonly StringTV Discriminator = new StringTV(EcoPrefix + "Discriminator");
Remarks

This is Discriminator, a member of class EcoTaggedValues.

See Also
EcoTaggedValues Class
Eco.UmlRt Namespace


EcoTaggedValues.DiscriminatorImpl Field

EcoTaggedValues.DiscriminatorImpl Field
EcoTaggedValues Class Eco.UmlRt Namespace See Also
Collapse All
C#
public static readonly StringTV DiscriminatorImpl = new StringTV(EcoPrefix + "DiscriminatorImpl");
Remarks

This is DiscriminatorImpl, a member of class EcoTaggedValues.

See Also
EcoTaggedValues Class
Eco.UmlRt Namespace


EcoTaggedValues.DiscriminatorValue Field

EcoTaggedValues.DiscriminatorValue Field
EcoTaggedValues Class Eco.UmlRt Namespace See Also
Collapse All
C#
public static readonly StringTV DiscriminatorValue = new StringTV(EcoPrefix + "DiscriminatorValue");
Remarks

This is DiscriminatorValue, a member of class EcoTaggedValues.

See Also
EcoTaggedValues Class
Eco.UmlRt Namespace


EcoTaggedValues.EcoPrefix Field

EcoTaggedValues.EcoPrefix Field
EcoTaggedValues Class Eco.UmlRt Namespace See Also
Collapse All
C#
public const string EcoPrefix = "Eco.";
Remarks

This is EcoPrefix, a member of class EcoTaggedValues.

See Also
EcoTaggedValues Class
Eco.UmlRt Namespace


EcoTaggedValues.Embed Field

EcoTaggedValues.Embed Field
EcoTaggedValues Class Eco.UmlRt Namespace See Also
Collapse All
C#
public static readonly BooleanTV Embed = new BooleanTV(EcoPrefix + "Embed");
Remarks

This is Embed, a member of class EcoTaggedValues.

See Also
EcoTaggedValues Class
Eco.UmlRt Namespace


EcoTaggedValues.FormerNames Field

EcoTaggedValues.FormerNames Field
EcoTaggedValues Class Eco.UmlRt Namespace See Also
Collapse All
C#
public static readonly StringTV FormerNames = new StringTV(EcoPrefix + "FormerNames");
Remarks

This is FormerNames, a member of class EcoTaggedValues.

See Also
EcoTaggedValues Class
Eco.UmlRt Namespace


EcoTaggedValues.GenerateDefaultRegion Field

EcoTaggedValues.GenerateDefaultRegion Field
EcoTaggedValues Class Eco.UmlRt Namespace See Also
Collapse All
C#
public static readonly BooleanTV GenerateDefaultRegion = new BooleanTV(EcoPrefix + "GenerateDefaultRegion");
Remarks

This is GenerateDefaultRegion, a member of class EcoTaggedValues.

See Also
EcoTaggedValues Class
Eco.UmlRt Namespace


EcoTaggedValues.GenerateDefaultRegions Field

EcoTaggedValues.GenerateDefaultRegions Field
EcoTaggedValues Class Eco.UmlRt Namespace See Also
Collapse All
C#
public static readonly BooleanTV GenerateDefaultRegions = new BooleanTV(EcoPrefix + "GenerateDefaultRegions");
Remarks

This is GenerateDefaultRegions, a member of class EcoTaggedValues.

See Also
EcoTaggedValues Class
Eco.UmlRt Namespace


EcoTaggedValues.GenerateMultiplicityConstraints Field

EcoTaggedValues.GenerateMultiplicityConstraints Field
EcoTaggedValues Class Eco.UmlRt Namespace See Also
Collapse All
C#
public static readonly BooleanTV GenerateMultiplicityConstraints = new BooleanTV(EcoPrefix + "GenerateMultiplicityConstraints");
Remarks

This is GenerateMultiplicityConstraints, a member of class EcoTaggedValues.

See Also
EcoTaggedValues Class
Eco.UmlRt Namespace


EcoTaggedValues.HasUserCode Field

EcoTaggedValues.HasUserCode Field
EcoTaggedValues Class Eco.UmlRt Namespace See Also
Collapse All
C#
public static readonly BooleanTV HasUserCode = new BooleanTV(EcoPrefix + "HasUserCode");
Remarks

This is HasUserCode, a member of class EcoTaggedValues.

See Also
EcoTaggedValues Class
Eco.UmlRt Namespace


EcoTaggedValues.IsConstrained Field

EcoTaggedValues.IsConstrained Field
EcoTaggedValues Class Eco.UmlRt Namespace See Also
Collapse All
C#
public static readonly BooleanTV IsConstrained = new BooleanTV(EcoPrefix + "IsConstrained");
Remarks

This is IsConstrained, a member of class EcoTaggedValues.

See Also
EcoTaggedValues Class
Eco.UmlRt Namespace


EcoTaggedValues.IsStateAttribute Field

EcoTaggedValues.IsStateAttribute Field
EcoTaggedValues Class Eco.UmlRt Namespace See Also
Collapse All
C#
public static readonly BooleanTV IsStateAttribute = new BooleanTV(EcoPrefix + "IsStateAttribute");
Remarks

This is IsStateAttribute, a member of class EcoTaggedValues.

See Also
EcoTaggedValues Class
Eco.UmlRt Namespace


EcoTaggedValues.IsTrigger Field

EcoTaggedValues.IsTrigger Field
EcoTaggedValues Class Eco.UmlRt Namespace See Also
Collapse All
C#
public static readonly BooleanTV IsTrigger = new BooleanTV(EcoPrefix + "IsTrigger");
Remarks

This is IsTrigger, a member of class EcoTaggedValues.

See Also
EcoTaggedValues Class
Eco.UmlRt Namespace


EcoTaggedValues.Length Field

EcoTaggedValues.Length Field
EcoTaggedValues Class Eco.UmlRt Namespace See Also
Collapse All
C#
public static readonly LengthTV Length = new LengthTV(EcoPrefix + "Length");
Remarks

This is Length, a member of class EcoTaggedValues.

See Also
EcoTaggedValues Class
Eco.UmlRt Namespace


EcoTaggedValues.LinkFetchStrategy Field

EcoTaggedValues.LinkFetchStrategy Field
EcoTaggedValues Class Eco.UmlRt Namespace See Also
Collapse All
C#
public static readonly LinkFetchStrategyTV LinkFetchStrategy = new LinkFetchStrategyTV();
Remarks

This is LinkFetchStrategy, a member of class EcoTaggedValues.

See Also
EcoTaggedValues Class
Eco.UmlRt Namespace


EcoTaggedValues.Name Field

EcoTaggedValues.Name Field
EcoTaggedValues Class Eco.UmlRt Namespace See Also
Collapse All
C#
public const string Name = "<Name>";
Remarks

This is Name, a member of class EcoTaggedValues.

See Also
EcoTaggedValues Class
Eco.UmlRt Namespace


EcoTaggedValues.OptimisticLocking Field

EcoTaggedValues.OptimisticLocking Field
EcoTaggedValues Class Eco.UmlRt Namespace See Also
Collapse All
C#
public static readonly OptimisticLockingTV OptimisticLocking = new OptimisticLockingTV();
Remarks

This is OptimisticLocking, a member of class EcoTaggedValues.

See Also
EcoTaggedValues Class
Eco.UmlRt Namespace


EcoTaggedValues.Ordered Field

EcoTaggedValues.Ordered Field
EcoTaggedValues Class Eco.UmlRt Namespace See Also
Collapse All
C#
public static readonly BooleanTV Ordered = new BooleanTV(EcoPrefix + "Ordered");
Remarks

This is Ordered, a member of class EcoTaggedValues.

See Also
EcoTaggedValues Class
Eco.UmlRt Namespace


EcoTaggedValues.PMapperName Field

EcoTaggedValues.PMapperName Field
EcoTaggedValues Class Eco.UmlRt Namespace See Also
Collapse All
C#
public static readonly StringTV PMapperName = new StringTV(EcoPrefix + "PMapper");
Remarks

This is PMapperName, a member of class EcoTaggedValues.

See Also
EcoTaggedValues Class
Eco.UmlRt Namespace


EcoTaggedValues.Precondition Field

EcoTaggedValues.Precondition Field
EcoTaggedValues Class Eco.UmlRt Namespace See Also
Collapse All
C#
public static readonly StringTV Precondition = new StringTV(EcoPrefix + "Precondition");
Remarks

This is Precondition, a member of class EcoTaggedValues.

See Also
EcoTaggedValues Class
Eco.UmlRt Namespace


EcoTaggedValues.PrimaryKey Field

EcoTaggedValues.PrimaryKey Field
EcoTaggedValues Class Eco.UmlRt Namespace See Also
Collapse All
C#
public static readonly StringTV PrimaryKey = new StringTV(EcoPrefix + "PrimaryKey");
Remarks

This is PrimaryKey, a member of class EcoTaggedValues.

See Also
EcoTaggedValues Class
Eco.UmlRt Namespace


EcoTaggedValues.PrimaryKeyMapper Field

EcoTaggedValues.PrimaryKeyMapper Field
EcoTaggedValues Class Eco.UmlRt Namespace See Also
Collapse All
C#
public static readonly StringTV PrimaryKeyMapper = new StringTV(EcoPrefix + "PrimaryKeyMapper");
Remarks

This is PrimaryKeyMapper, a member of class EcoTaggedValues.

See Also
EcoTaggedValues Class
Eco.UmlRt Namespace


EcoTaggedValues.RegionDefinitions Field

EcoTaggedValues.RegionDefinitions Field
EcoTaggedValues Class Eco.UmlRt Namespace See Also
Collapse All
C#
public static readonly StringTV RegionDefinitions = new StringTV(EcoPrefix + "RegionDefinitions");
Remarks

This is RegionDefinitions, a member of class EcoTaggedValues.

See Also
EcoTaggedValues Class
Eco.UmlRt Namespace


EcoTaggedValues.Representation Field

EcoTaggedValues.Representation Field
EcoTaggedValues Class Eco.UmlRt Namespace See Also
Collapse All
C#
public static readonly StringTV Representation = new StringTV(EcoPrefix + "Representation");
Remarks

This is Representation, a member of class EcoTaggedValues.

See Also
EcoTaggedValues Class
Eco.UmlRt Namespace


EcoTaggedValues.SaveAction Field

EcoTaggedValues.SaveAction Field
EcoTaggedValues Class Eco.UmlRt Namespace See Also
Collapse All
C#
public static readonly SaveActionTV SaveAction = new SaveActionTV();
Remarks

This is SaveAction, a member of class EcoTaggedValues.

See Also
EcoTaggedValues Class
Eco.UmlRt Namespace


EcoTaggedValues.StateAttributeDeprecated Field

EcoTaggedValues.StateAttributeDeprecated Field
EcoTaggedValues Class Eco.UmlRt Namespace See Also
Collapse All
C#
public static readonly StringTV StateAttributeDeprecated = new StringTV(EcoPrefix + "StateAttribute");
Remarks

This is StateAttributeDeprecated, a member of class EcoTaggedValues.

See Also
EcoTaggedValues Class
Eco.UmlRt Namespace


EcoTaggedValues.TableMapping Field

EcoTaggedValues.TableMapping Field
EcoTaggedValues Class Eco.UmlRt Namespace See Also
Collapse All
C#
public static readonly TableMappingTV TableMapping = new TableMappingTV();
Remarks

This is TableMapping, a member of class EcoTaggedValues.

See Also
EcoTaggedValues Class
Eco.UmlRt Namespace


EcoTaggedValues.TableName Field

EcoTaggedValues.TableName Field
EcoTaggedValues Class Eco.UmlRt Namespace See Also
Collapse All
C#
public static readonly StringTV TableName = new StringTV(EcoPrefix + "TableName");
Remarks

This is TableName, a member of class EcoTaggedValues.

See Also
EcoTaggedValues Class
Eco.UmlRt Namespace


EcoTaggedValues.Versioned Field

EcoTaggedValues.Versioned Field
EcoTaggedValues Class Eco.UmlRt Namespace See Also
Collapse All
C#
public static readonly BooleanTV Versioned = new BooleanTV(EcoPrefix + "Versioned");
Remarks

This is Versioned, a member of class EcoTaggedValues.

See Also
EcoTaggedValues Class
Eco.UmlRt Namespace


ModelElementSameHash Class

ModelElementSameHash Class
Inheritance Hierarchy See Also
Collapse All
C#
public static class ModelElementSameHash;
Remarks

This is class Eco.UmlRt.ModelElementSameHash.

Inheritance Hierarchy
Eco.UmlRt.ModelElementSameHash
File

UmlRt.cs

See Also
Inheritance Hierarchy


ModelElementSameHash Properties

ModelElementSameHash Properties
Public Properties
Collapse All

The properties of the ModelElementSameHash class are listed here.

Public Properties
Name | Description
ClasssifierEqualityComparer | This is ClasssifierEqualityComparer, a member of class ModelElementSameHash.
ElementEqualityComparer | This is ElementEqualityComparer, a member of class ModelElementSameHash.
OldEqualityComparer | This is OldEqualityComparer, a member of class ModelElementSameHash.


ModelElementSameHash.ClasssifierEqualityComparer Property

ModelElementSameHash.ClasssifierEqualityComparer Property
ModelElementSameHash Class Eco.UmlRt Namespace See Also
Collapse All
C#
public static IEqualityComparer<IClassifier> ClasssifierEqualityComparer;
Remarks

This is ClasssifierEqualityComparer, a member of class ModelElementSameHash.

See Also
ModelElementSameHash Class
Eco.UmlRt Namespace


ModelElementSameHash.ElementEqualityComparer Property

ModelElementSameHash.ElementEqualityComparer Property
ModelElementSameHash Class Eco.UmlRt Namespace See Also
Collapse All
C#
public static IEqualityComparer<IModelElement> ElementEqualityComparer;
Remarks

This is ElementEqualityComparer, a member of class ModelElementSameHash.

See Also
ModelElementSameHash Class
Eco.UmlRt Namespace


ModelElementSameHash.OldEqualityComparer Property

ModelElementSameHash.OldEqualityComparer Property
ModelElementSameHash Class Eco.UmlRt Namespace See Also
Collapse All
C#
public static IEqualityComparer OldEqualityComparer;
Remarks

This is OldEqualityComparer, a member of class ModelElementSameHash.

See Also
ModelElementSameHash Class
Eco.UmlRt Namespace


UmlTaggedValues Class

UmlTaggedValues Class
Inheritance Hierarchy See Also
Collapse All
C#
public abstract class UmlTaggedValues;
Remarks

This is class Eco.UmlRt.UmlTaggedValues.

Inheritance Hierarchy
Eco.UmlRt.UmlTaggedValues
    Eco.UmlRt.EcoTaggedValues
File

UmlRt.cs

See Also
Inheritance Hierarchy


UmlTaggedValues Classes

UmlTaggedValues Classes
Classes
Collapse All

The classes of the UmlTaggedValues class are listed here.

Classes
Name | Description
BooleanTV | This is class Eco.UmlRt.UmlTaggedValues.BooleanTV.
EnumTV | This is class Eco.UmlRt.UmlTaggedValues.EnumTV.
PersistenceTV | If the element is persistent or transient
StringTV | This is class Eco.UmlRt.UmlTaggedValues.StringTV.
TaggedValue | This is class Eco.UmlRt.UmlTaggedValues.TaggedValue.


UmlTaggedValues.BooleanTV Class

UmlTaggedValues.BooleanTV Class
Inheritance Hierarchy See Also
Collapse All
C#
public class BooleanTV : TaggedValue;
Remarks

This is class Eco.UmlRt.UmlTaggedValues.BooleanTV.

Inheritance Hierarchy
Eco.UmlRt.UmlTaggedValues.BooleanTV
File

UmlRt.cs

See Also
Inheritance Hierarchy


UmlTaggedValues.BooleanTV.BooleanTV Constructor

UmlTaggedValues.BooleanTV.BooleanTV Constructor
UmlTaggedValues.BooleanTV Class Eco.UmlRt Namespace See Also
Collapse All
C#
public BooleanTV(
    string tag
);
Remarks

This is BooleanTV, a member of class BooleanTV.

See Also
UmlTaggedValues.BooleanTV Class
Eco.UmlRt Namespace


BooleanTV Methods

BooleanTV Methods
Public Methods
Collapse All

The methods of the BooleanTV class are listed here.

Public Methods
Name | Description
GetValue | This is the overview for the GetValue method overload.


GetValue Method

GetValue Method

This is the overview for the GetValue method overload.

Overload List
Name | Description
UmlTaggedValues.BooleanTV.GetValue (ITaggedValueCollection) | This is GetValue, a member of class BooleanTV.
UmlTaggedValues.BooleanTV.GetValue (ITaggedValueCollection, bool) | This is GetValue, a member of class BooleanTV.


UmlTaggedValues.BooleanTV.GetValue Method (ITaggedValueCollection)

UmlTaggedValues.BooleanTV.GetValue Method (ITaggedValueCollection)
UmlTaggedValues.BooleanTV Class Eco.UmlRt Namespace See Also
Collapse All
C#
public bool GetValue(
    ITaggedValueCollection taggedValues
);
Remarks

This is GetValue, a member of class BooleanTV.

See Also
UmlTaggedValues.BooleanTV Class
Eco.UmlRt Namespace


UmlTaggedValues.BooleanTV.GetValue Method (ITaggedValueCollection, bool)

UmlTaggedValues.BooleanTV.GetValue Method (ITaggedValueCollection, bool)
UmlTaggedValues.BooleanTV Class Eco.UmlRt Namespace See Also
Collapse All
C#
public bool GetValue(
    ITaggedValueCollection taggedValues,
    bool defaultValue
);
Remarks

This is GetValue, a member of class BooleanTV.

See Also
UmlTaggedValues.BooleanTV Class
Eco.UmlRt Namespace


BooleanTV Properties

BooleanTV Properties
Public Properties
Collapse All

The properties of the BooleanTV class are listed here.

Public Properties
Name | Description
Tag | This is Tag, a member of class BooleanTV.


UmlTaggedValues.BooleanTV.Tag Property

UmlTaggedValues.BooleanTV.Tag Property
UmlTaggedValues.BooleanTV Class Eco.UmlRt Namespace See Also
Collapse All
C#
public override string Tag;
Remarks

This is Tag, a member of class BooleanTV.

See Also
UmlTaggedValues.BooleanTV Class
Eco.UmlRt Namespace


UmlTaggedValues.EnumTV Class

UmlTaggedValues.EnumTV Class
Inheritance Hierarchy See Also
Collapse All
C#
public abstract class EnumTV : TaggedValue;
Remarks

This is class Eco.UmlRt.UmlTaggedValues.EnumTV.

Inheritance Hierarchy
Eco.UmlRt.UmlTaggedValues.EnumTV
File

UmlRt.cs

See Also
Inheritance Hierarchy


EnumTV Methods

EnumTV Methods
Public Methods
Collapse All

The methods of the EnumTV class are listed here.

Public Methods
Name | Description
FormatAllValues | This is FormatAllValues, a member of class EnumTV.


UmlTaggedValues.EnumTV.FormatAllValues Method

UmlTaggedValues.EnumTV.FormatAllValues Method
UmlTaggedValues.EnumTV Class Eco.UmlRt Namespace See Also
Collapse All
C#
public string FormatAllValues();
Remarks

This is FormatAllValues, a member of class EnumTV.

See Also
UmlTaggedValues.EnumTV Class
Eco.UmlRt Namespace


EnumTV Properties

EnumTV Properties
Public Properties
Collapse All

The properties of the EnumTV class are listed here.

Public Properties
Name | Description
AllValues | This is AllValues, a member of class EnumTV.


UmlTaggedValues.EnumTV.AllValues Property

UmlTaggedValues.EnumTV.AllValues Property
UmlTaggedValues.EnumTV Class Eco.UmlRt Namespace See Also
Collapse All
C#
public abstract IEnumerable<string> AllValues;
Remarks

This is AllValues, a member of class EnumTV.

See Also
UmlTaggedValues.EnumTV Class
Eco.UmlRt Namespace


UmlTaggedValues.PersistenceTV Class

UmlTaggedValues.PersistenceTV Class
Inheritance Hierarchy See Also
Collapse All

If the element is persistent or transient

C#
public class PersistenceTV : EnumTV;
Inheritance Hierarchy
Eco.UmlRt.UmlTaggedValues.PersistenceTV
File

UmlRt.cs

See Also
Inheritance Hierarchy


PersistenceTV Methods

PersistenceTV Methods
Public Methods
Collapse All

The methods of the PersistenceTV class are listed here.

Public Methods
Name | Description
GetIsPersistent |


UmlTaggedValues.PersistenceTV.GetIsPersistent Method

UmlTaggedValues.PersistenceTV.GetIsPersistent Method
UmlTaggedValues.PersistenceTV Class Eco.UmlRt Namespace See Also
Collapse All
C#
public bool GetIsPersistent(
    ITaggedValueCollection taggedValues
);
Exceptions
Exceptions | Description
ArgumentNullException | Thrown if taggedValues is null.
ArgumentOutOfRangeException | Thrown if tagged value is not one of the legal values in Persistence.
See Also
UmlTaggedValues.PersistenceTV Class
Eco.UmlRt Namespace


PersistenceTV Properties

PersistenceTV Properties
Public Properties
Collapse All

The properties of the PersistenceTV class are listed here.

Public Properties
Name | Description
AllValues | This is AllValues, a member of class PersistenceTV.
Persistent | This is Persistent, a member of class PersistenceTV.
Tag | This is Tag, a member of class PersistenceTV.
Transient | This is Transient, a member of class PersistenceTV.


UmlTaggedValues.PersistenceTV.AllValues Property

UmlTaggedValues.PersistenceTV.AllValues Property
UmlTaggedValues.PersistenceTV Class Eco.UmlRt Namespace See Also
Collapse All
C#
public override IEnumerable<string> AllValues;
Remarks

This is AllValues, a member of class PersistenceTV.

See Also
UmlTaggedValues.PersistenceTV Class
Eco.UmlRt Namespace


UmlTaggedValues.PersistenceTV.Persistent Property

UmlTaggedValues.PersistenceTV.Persistent Property
UmlTaggedValues.PersistenceTV Class Eco.UmlRt Namespace See Also
Collapse All
C#
public static string Persistent;
Remarks

This is Persistent, a member of class PersistenceTV.

See Also
UmlTaggedValues.PersistenceTV Class
Eco.UmlRt Namespace


UmlTaggedValues.PersistenceTV.Tag Property

UmlTaggedValues.PersistenceTV.Tag Property
UmlTaggedValues.PersistenceTV Class Eco.UmlRt Namespace See Also
Collapse All
C#
public override string Tag;
Remarks

This is Tag, a member of class PersistenceTV.

See Also
UmlTaggedValues.PersistenceTV Class
Eco.UmlRt Namespace


UmlTaggedValues.PersistenceTV.Transient Property

UmlTaggedValues.PersistenceTV.Transient Property
UmlTaggedValues.PersistenceTV Class Eco.UmlRt Namespace See Also
Collapse All
C#
public static string Transient;
Remarks

This is Transient, a member of class PersistenceTV.

See Also
UmlTaggedValues.PersistenceTV Class
Eco.UmlRt Namespace


UmlTaggedValues.StringTV Class

UmlTaggedValues.StringTV Class
Inheritance Hierarchy See Also
Collapse All
C#
public class StringTV : TaggedValue;
Remarks

This is class Eco.UmlRt.UmlTaggedValues.StringTV.

Inheritance Hierarchy
Eco.UmlRt.UmlTaggedValues.StringTV
File

UmlRt.cs

See Also
Inheritance Hierarchy


UmlTaggedValues.StringTV.StringTV Constructor

UmlTaggedValues.StringTV.StringTV Constructor
UmlTaggedValues.StringTV Class Eco.UmlRt Namespace See Also
Collapse All
C#
public StringTV(
    string tag
);
Remarks

This is StringTV, a member of class StringTV.

See Also
UmlTaggedValues.StringTV Class
Eco.UmlRt Namespace


StringTV Methods

StringTV Methods
Public Methods
Collapse All

The methods of the StringTV class are listed here.

Public Methods
Name | Description
GetValue | This is the overview for the GetValue method overload.


GetValue Method

GetValue Method

This is the overview for the GetValue method overload.

Overload List
Name | Description
UmlTaggedValues.StringTV.GetValue (ITaggedValueCollection) |
UmlTaggedValues.StringTV.GetValue (ITaggedValueCollection, string) |


UmlTaggedValues.StringTV.GetValue Method (ITaggedValueCollection)

UmlTaggedValues.StringTV.GetValue Method (ITaggedValueCollection)
UmlTaggedValues.StringTV Class Eco.UmlRt Namespace See Also
Collapse All
C#
public string GetValue(
    ITaggedValueCollection taggedValues
);
Exceptions
Exceptions | Description
ArgumentNullException | Thrown if taggedValues is null.
See Also
UmlTaggedValues.StringTV Class
Eco.UmlRt Namespace


UmlTaggedValues.StringTV.GetValue Method (ITaggedValueCollection, string)

UmlTaggedValues.StringTV.GetValue Method (ITaggedValueCollection, string)
UmlTaggedValues.StringTV Class Eco.UmlRt Namespace See Also
Collapse All
C#
public string GetValue(
    ITaggedValueCollection taggedValues,
    string defaultValue
);
Exceptions
Exceptions | Description
ArgumentNullException | Thrown if taggedValues is null.
See Also
UmlTaggedValues.StringTV Class
Eco.UmlRt Namespace


StringTV Properties

StringTV Properties
Public Properties
Collapse All

The properties of the StringTV class are listed here.

Public Properties
Name | Description
Tag | This is Tag, a member of class StringTV.


UmlTaggedValues.StringTV.Tag Property

UmlTaggedValues.StringTV.Tag Property
UmlTaggedValues.StringTV Class Eco.UmlRt Namespace See Also
Collapse All
C#
public override string Tag;
Remarks

This is Tag, a member of class StringTV.

See Also
UmlTaggedValues.StringTV Class
Eco.UmlRt Namespace


UmlTaggedValues.TaggedValue Class

UmlTaggedValues.TaggedValue Class
Inheritance Hierarchy See Also
Collapse All
C#
public abstract class TaggedValue;
Remarks

This is class Eco.UmlRt.UmlTaggedValues.TaggedValue.

Inheritance Hierarchy
Eco.UmlRt.UmlTaggedValues.TaggedValue
File

UmlRt.cs

See Also
Inheritance Hierarchy


TaggedValue Properties

TaggedValue Properties
Public Properties
Collapse All

The properties of the TaggedValue class are listed here.

Public Properties
Name | Description
Tag | This is Tag, a member of class TaggedValue.


UmlTaggedValues.TaggedValue.Tag Property

UmlTaggedValues.TaggedValue.Tag Property
UmlTaggedValues.TaggedValue Class Eco.UmlRt Namespace See Also
Collapse All
C#
public abstract string Tag;
Remarks

This is Tag, a member of class TaggedValue.

See Also
UmlTaggedValues.TaggedValue Class
Eco.UmlRt Namespace


UmlTaggedValues Fields

UmlTaggedValues Fields
Public Fields
Collapse All

The fields of the UmlTaggedValues class are listed here.

Public Fields
Name | Description
Derived | This is Derived, a member of class UmlTaggedValues.
Documentation | This is Documentation, a member of class UmlTaggedValues.
FalseString | This is FalseString, a member of class UmlTaggedValues.
Persistence | This is Persistence, a member of class UmlTaggedValues.
TrueString | This is TrueString, a member of class UmlTaggedValues.


UmlTaggedValues.Derived Field

UmlTaggedValues.Derived Field
UmlTaggedValues Class Eco.UmlRt Namespace See Also
Collapse All
C#
public static readonly BooleanTV Derived = new BooleanTV("derived");
Remarks

This is Derived, a member of class UmlTaggedValues.

See Also
UmlTaggedValues Class
Eco.UmlRt Namespace


UmlTaggedValues.Documentation Field

UmlTaggedValues.Documentation Field
UmlTaggedValues Class Eco.UmlRt Namespace See Also
Collapse All
C#
public static readonly StringTV Documentation = new StringTV("documentation");
Remarks

This is Documentation, a member of class UmlTaggedValues.

See Also
UmlTaggedValues Class
Eco.UmlRt Namespace


UmlTaggedValues.FalseString Field

UmlTaggedValues.FalseString Field
UmlTaggedValues Class Eco.UmlRt Namespace See Also
Collapse All
C#
public const string FalseString = "False";
Remarks

This is FalseString, a member of class UmlTaggedValues.

See Also
UmlTaggedValues Class
Eco.UmlRt Namespace


UmlTaggedValues.Persistence Field

UmlTaggedValues.Persistence Field
UmlTaggedValues Class Eco.UmlRt Namespace See Also
Collapse All
C#
public static readonly PersistenceTV Persistence = new PersistenceTV();
Remarks

This is Persistence, a member of class UmlTaggedValues.

See Also
UmlTaggedValues Class
Eco.UmlRt Namespace


UmlTaggedValues.TrueString Field

UmlTaggedValues.TrueString Field
UmlTaggedValues Class Eco.UmlRt Namespace See Also
Collapse All
C#
public const string TrueString = "True";
Remarks

This is TrueString, a member of class UmlTaggedValues.

See Also
UmlTaggedValues Class
Eco.UmlRt Namespace


UmlTaggedValues Methods

UmlTaggedValues Methods
Protected Methods Public Methods
Collapse All

The methods of the UmlTaggedValues class are listed here.

Protected Methods
Name | Description
StrEqual | This is StrEqual, a member of class UmlTaggedValues.
Top
Public Methods
Name | Description
AsBool | This is the overview for the AsBool method overload.
BoolAsString | This is BoolAsString, a member of class UmlTaggedValues.


AsBool Method

AsBool Method

This is the overview for the AsBool method overload.

Overload List
Name | Description
UmlTaggedValues.AsBool (ITaggedValueCollection, string) |
UmlTaggedValues.AsBool (ITaggedValueCollection, string, bool) |
UmlTaggedValues.AsBool (string) |


UmlTaggedValues.AsBool Method (ITaggedValueCollection, string)

UmlTaggedValues.AsBool Method (ITaggedValueCollection, string)
UmlTaggedValues Class Eco.UmlRt Namespace See Also
Collapse All
C#
public static bool AsBool(
    ITaggedValueCollection taggedValues,
    string tag
);
Exceptions
Exceptions | Description
ArgumentNullException | Thrown if taggedValues is null.
ArgumentOutOfRangeException | Thrown if tagged value is not available.
See Also
UmlTaggedValues Class
Eco.UmlRt Namespace


UmlTaggedValues.AsBool Method (ITaggedValueCollection, string, bool)

UmlTaggedValues.AsBool Method (ITaggedValueCollection, string, bool)
UmlTaggedValues Class Eco.UmlRt Namespace See Also
Collapse All
C#
public static bool AsBool(
    ITaggedValueCollection taggedValues,
    string tag,
    bool defaultValue
);
Exceptions
Exceptions | Description
ArgumentNullException | Thrown if taggedValues is null.
See Also
UmlTaggedValues Class
Eco.UmlRt Namespace


UmlTaggedValues.AsBool Method (string)

UmlTaggedValues.AsBool Method (string)
UmlTaggedValues Class Eco.UmlRt Namespace See Also
Collapse All
C#
public static bool AsBool(
    string value
);
Exceptions
Exceptions | Description
ArgumentOutOfRangeException | Thrown if value does not represent a boolean string.
See Also
UmlTaggedValues Class
Eco.UmlRt Namespace


UmlTaggedValues.BoolAsString Method

UmlTaggedValues.BoolAsString Method
UmlTaggedValues Class Eco.UmlRt Namespace See Also
Collapse All
C#
public static string BoolAsString(
    bool value
);
Remarks

This is BoolAsString, a member of class UmlTaggedValues.

See Also
UmlTaggedValues Class
Eco.UmlRt Namespace


UmlTaggedValues.StrEqual Method

UmlTaggedValues.StrEqual Method
UmlTaggedValues Class Eco.UmlRt Namespace See Also
Collapse All
C#
protected static bool StrEqual(
    string s1,
    string s2
);
Remarks

This is StrEqual, a member of class UmlTaggedValues.

See Also
UmlTaggedValues Class
Eco.UmlRt Namespace


IActivity Interface

IActivity Interface
Inheritance Hierarchy See Also
Collapse All

Contains model information about a UML modeled method that has been implemented using the Action OCL language rather than as a .NET method.

C#
public interface IActivity;
Remarks

A .NET method is still generated for activity methods, but it merely instructs ECO to execute the expression modeled into the activity, developers should not add custom code to activity methods as this code will not be executed.

Inheritance Hierarchy
Eco.UmlRt.IActivity
File

UmlRt.cs

See Also
Inheritance Hierarchy


IActivity Properties

IActivity Properties
Public Properties
Collapse All

The properties of the IActivity class are listed here.

Public Properties
Name | Description
Body | Contains the modeled OCL action language expression to execute.
Language | Identifies the language used for the expression.


IActivity.Body Property

IActivity.Body Property
IActivity Interface Eco.UmlRt Namespace See Also
Collapse All

Contains the modeled OCL action language expression to execute.

C#
string Body;
See Also
IActivity Interface
Eco.UmlRt Namespace


IActivity.Language Property

IActivity.Language Property
IActivity Interface Eco.UmlRt Namespace See Also
Collapse All

Identifies the language used for the expression.

C#
string Language;
Remarks

Currently this will always be "OCL".

See Also
IActivity Interface
Eco.UmlRt Namespace


IAssociation Interface

IAssociation Interface
Inheritance Hierarchy See Also
Collapse All

Contains information about an association between two UML classes that has been defined in the model.

C#
public interface IAssociation : IModelElement;
Inheritance Hierarchy
Eco.UmlRt.IModelElement
    Eco.UmlRt.IAssociation
        Eco.UmlRt.IEcoAssociation
File

UmlRt.cs

See Also
Inheritance Hierarchy


IAssociation Methods

IAssociation Methods
Public Methods
Collapse All

The methods of the IAssociation class are listed here.

Public Methods
Name | Description
this | Returns the specified association end.


IAssociation.this Indexer

IAssociation.this Indexer
IAssociation Interface Eco.UmlRt Namespace See Also
Collapse All

Returns the specified association end.

C#
IAssociationEnd this[
    int index
];
Parameters
Parameters | Description
index | The association end number, this should be no less than zero and no greater than Count - 1.
See Also
IAssociation Interface
Eco.UmlRt Namespace


IAssociation Properties

IAssociation Properties
Public Properties
Collapse All

The properties of the IAssociation class are listed here.

Public Properties
Name | Description
AssociationClass | If the association uses an association class this will return its IClass.
Count | Returns the number of association ends. Currently this will always be two.
EcoAssociation | This is EcoAssociation, a member of class IAssociation.
Id | Contains a unique ID for the association.
IsDerived | Indicates whether or not the values of the association ends are derived (calculated) either by OCL or a method implementation.


IAssociation.AssociationClass Property

IAssociation.AssociationClass Property
IAssociation Interface Eco.UmlRt Namespace See Also
Collapse All

If the association uses an association class this will return its IClass.

C#
IClass AssociationClass;
See Also
IAssociation Interface
Eco.UmlRt Namespace


IAssociation.Count Property

IAssociation.Count Property
IAssociation Interface Eco.UmlRt Namespace See Also
Collapse All

Returns the number of association ends. Currently this will always be two.

C#
int Count;
See Also
IAssociation Interface
Eco.UmlRt Namespace


IAssociation.EcoAssociation Property

IAssociation.EcoAssociation Property
IAssociation Interface Eco.UmlRt Namespace See Also
Collapse All
C#
IEcoAssociation EcoAssociation;
Remarks

This is EcoAssociation, a member of class IAssociation.

See Also
IAssociation Interface
Eco.UmlRt Namespace


IAssociation.Id Property

IAssociation.Id Property
IAssociation Interface Eco.UmlRt Namespace See Also
Collapse All

Contains a unique ID for the association.

C#
string Id;
See Also
IAssociation Interface
Eco.UmlRt Namespace


IAssociation.IsDerived Property

IAssociation.IsDerived Property
IAssociation Interface Eco.UmlRt Namespace See Also
Collapse All

Indicates whether or not the values of the association ends are derived (calculated) either by OCL or a method implementation.

C#
bool IsDerived;
See Also
IAssociation Interface
Eco.UmlRt Namespace


IAssociationCollection Interface

IAssociationCollection Interface
Inheritance Hierarchy See Also
Collapse All

Holds a collection of Eco.UmlRt.IAssociation.

C#
public interface IAssociationCollection : ICollection;
Inheritance Hierarchy
Eco.UmlRt.IAssociationCollection
File

UmlRt.cs

See Also
Inheritance Hierarchy


IAssociationCollection Methods

IAssociationCollection Methods
Public Methods
Collapse All

The methods of the IAssociationCollection class are listed here.

Public Methods
Name | Description
GetItemByName | Gets an association by its name.
this | Gets an association by its index within the collection.


IAssociationCollection.GetItemByName Method

IAssociationCollection.GetItemByName Method
IAssociationCollection Interface Eco.UmlRt Namespace See Also
Collapse All

Gets an association by its name.

C#
IAssociation GetItemByName(
    string name
);
Parameters
Parameters | Description
name | The name of the association.
See Also
IAssociationCollection Interface
Eco.UmlRt Namespace


IAssociationCollection.this Indexer

IAssociationCollection.this Indexer
IAssociationCollection Interface Eco.UmlRt Namespace See Also
Collapse All

Gets an association by its index within the collection.

C#
IAssociation this[
    int index
];
See Also
IAssociationCollection Interface
Eco.UmlRt Namespace


IAssociationEnd Interface

IAssociationEnd Interface
Inheritance Hierarchy See Also
Collapse All

Contains model information about a single end of an association between two modeled classes.

C#
public interface IAssociationEnd : IStructuralFeature;
Inheritance Hierarchy
Eco.UmlRt.IModelElement
    Eco.UmlRt.IFeature
        Eco.UmlRt.IStructuralFeature
            Eco.UmlRt.IAssociationEnd
                Eco.UmlRt.IEcoAssociationEnd
File

UmlRt.cs

See Also
Inheritance Hierarchy


IAssociationEnd Properties

IAssociationEnd Properties
Public Properties
Collapse All

The properties of the IAssociationEnd class are listed here.

Public Properties
Name | Description
Aggregation | Indicates the type of aggregation applied in the model to this association end.
Association | Holds a reference to the model information of the association itself.
AssociationClass | Holds a reference to the model information describing the class used to represent the association class.
AssociationClassEndPointingAway | This is AssociationClassEndPointingAway, a member of class IAssociationEnd.
AssociationClassEndPointingHere | This is AssociationClassEndPointingHere, a member of class IAssociationEnd.
AssociationEndKind | Identifies the kind of association end this feature represents.
Class_ | This is Class_, a member of class IAssociationEnd.
DefaultRegionMode | This is DefaultRegionMode, a member of class IAssociationEnd.
DeleteAction | Indicates what action should be taken when the object at the opposite end of the association is deleted.
EcoAssociationEnd | This is EcoAssociationEnd, a member of class IAssociationEnd.
EndPointingToAssociationClass | This is EndPointingToAssociationClass, a member of class IAssociationEnd.
IsNavigable | Indicates whether or not this association end may be reached from the UML class at the other end of the association.
LinkFetchStrategy | Specifies the way in which associated objects should be fetched from the persistent storage.
MainAssociationEnd | This is MainAssociationEnd, a member of class IAssociationEnd.
OppositeEnd | Holds a reference to model information of the opposite end of the association.
Ordering | Specifies how an association end is ordered.


IAssociationEnd.Aggregation Property

IAssociationEnd.Aggregation Property
IAssociationEnd Interface Eco.UmlRt Namespace See Also
Collapse All

Indicates the type of aggregation applied in the model to this association end.

C#
AggregationKind Aggregation;
See Also
IAssociationEnd Interface
Eco.UmlRt Namespace


IAssociationEnd.Association Property

IAssociationEnd.Association Property
IAssociationEnd Interface Eco.UmlRt Namespace See Also
Collapse All

Holds a reference to the model information of the association itself.

C#
IAssociation Association;
See Also
IAssociationEnd Interface
Eco.UmlRt Namespace


IAssociationEnd.AssociationClass Property

IAssociationEnd.AssociationClass Property
IAssociationEnd Interface Eco.UmlRt Namespace See Also
Collapse All

Holds a reference to the model information describing the class used to represent the association class.

C#
IClass AssociationClass;
See Also
IAssociationEnd Interface
Eco.UmlRt Namespace


IAssociationEnd.AssociationClassEndPointingAway Property

IAssociationEnd.AssociationClassEndPointingAway Property
IAssociationEnd Interface Eco.UmlRt Namespace See Also
Collapse All
C#
IAssociationEnd AssociationClassEndPointingAway;
Remarks

This is AssociationClassEndPointingAway, a member of class IAssociationEnd.

See Also
IAssociationEnd Interface
Eco.UmlRt Namespace


IAssociationEnd.AssociationClassEndPointingHere Property

IAssociationEnd.AssociationClassEndPointingHere Property
IAssociationEnd Interface Eco.UmlRt Namespace See Also
Collapse All
C#
IAssociationEnd AssociationClassEndPointingHere;
Remarks

This is AssociationClassEndPointingHere, a member of class IAssociationEnd.

See Also
IAssociationEnd Interface
Eco.UmlRt Namespace


IAssociationEnd.AssociationEndKind Property

IAssociationEnd.AssociationEndKind Property
IAssociationEnd Interface Eco.UmlRt Namespace See Also
Collapse All

Identifies the kind of association end this feature represents.

C#
AssociationEndKind AssociationEndKind;
See Also
IAssociationEnd Interface
Eco.UmlRt Namespace


IAssociationEnd.Class_ Property

IAssociationEnd.Class_ Property
IAssociationEnd Interface Eco.UmlRt Namespace See Also
Collapse All
C#
IClass Class_;
Remarks

This is Class_, a member of class IAssociationEnd.

See Also
IAssociationEnd Interface
Eco.UmlRt Namespace


IAssociationEnd.DefaultRegionMode Property

IAssociationEnd.DefaultRegionMode Property
IAssociationEnd Interface Eco.UmlRt Namespace See Also
Collapse All
C#
AssociationEndDefaultRegionMode DefaultRegionMode;
Remarks

This is DefaultRegionMode, a member of class IAssociationEnd.

See Also
IAssociationEnd Interface
Eco.UmlRt Namespace


IAssociationEnd.DeleteAction Property

IAssociationEnd.DeleteAction Property
IAssociationEnd Interface Eco.UmlRt Namespace See Also
Collapse All

Indicates what action should be taken when the object at the opposite end of the association is deleted.

C#
DeleteAction DeleteAction;
See Also
IAssociationEnd Interface
Eco.UmlRt Namespace


IAssociationEnd.EcoAssociationEnd Property

IAssociationEnd.EcoAssociationEnd Property
IAssociationEnd Interface Eco.UmlRt Namespace See Also
Collapse All
C#
IEcoAssociationEnd EcoAssociationEnd;
Remarks

This is EcoAssociationEnd, a member of class IAssociationEnd.

See Also
IAssociationEnd Interface
Eco.UmlRt Namespace


IAssociationEnd.EndPointingToAssociationClass Property

IAssociationEnd.EndPointingToAssociationClass Property
IAssociationEnd Interface Eco.UmlRt Namespace See Also
Collapse All
C#
IAssociationEnd EndPointingToAssociationClass;
Remarks

This is EndPointingToAssociationClass, a member of class IAssociationEnd.

See Also
IAssociationEnd Interface
Eco.UmlRt Namespace


IAssociationEnd.IsNavigable Property

IAssociationEnd.IsNavigable Property
IAssociationEnd Interface Eco.UmlRt Namespace See Also
Collapse All

Indicates whether or not this association end may be reached from the UML class at the other end of the association.

C#
bool IsNavigable;
Remarks

If both ends of an association are navigable then both .NET classes will have properties generated to reference each other, if one end is marked as non-navigable then the property on the relevant .NET class will not be generated. Additionally, non-navigable association ends cannot be reached via OCL expressions:

Copy Code
self.navigableAssociationEndName (ok)
self.nonNavigableAssociationEndName (error)
See Also
IAssociationEnd Interface
Eco.UmlRt Namespace


IAssociationEnd.LinkFetchStrategy Property

IAssociationEnd.LinkFetchStrategy Property
IAssociationEnd Interface Eco.UmlRt Namespace See Also
Collapse All

Specifies the way in which associated objects should be fetched from the persistent storage.

C#
LinkFetchStrategy LinkFetchStrategy;
Remarks

The value specified here determines how the object(s) at this end of the association should be retrieved when the object at the other end of the association is fetched from the persistent storage.

See Also
IAssociationEnd Interface
Eco.UmlRt Namespace


IAssociationEnd.MainAssociationEnd Property

IAssociationEnd.MainAssociationEnd Property
IAssociationEnd Interface Eco.UmlRt Namespace See Also
Collapse All
C#
IAssociationEnd MainAssociationEnd;
Remarks

This is MainAssociationEnd, a member of class IAssociationEnd.

See Also
IAssociationEnd Interface
Eco.UmlRt Namespace


IAssociationEnd.OppositeEnd Property

IAssociationEnd.OppositeEnd Property
IAssociationEnd Interface Eco.UmlRt Namespace See Also
Collapse All

Holds a reference to model information of the opposite end of the association.

C#
IAssociationEnd OppositeEnd;
See Also
IAssociationEnd Interface
Eco.UmlRt Namespace


IAssociationEnd.Ordering Property

IAssociationEnd.Ordering Property
IAssociationEnd Interface Eco.UmlRt Namespace See Also
Collapse All

Specifies how an association end is ordered.

C#
OrderingKind Ordering;
Remarks

If this association end has a multiple mulitplicity (upper bound > 1) then this property will indicate whether or not any custom reordering of objects in the association will be persisted to the persistent storage.

See Also
IAssociationEnd Interface
Eco.UmlRt Namespace


IAttribute Interface

IAttribute Interface
Inheritance Hierarchy See Also
Collapse All

Contains information about a modeled UML attribute.

C#
public interface IAttribute : IStructuralFeature;
Remarks

A UML attribute is the equivalent of a property on a .NET class. UML attributes may not represent a modeled UML class instance.

Inheritance Hierarchy
Eco.UmlRt.IModelElement
    Eco.UmlRt.IFeature
        Eco.UmlRt.IStructuralFeature
            Eco.UmlRt.IAttribute
                Eco.UmlRt.IEcoAttribute
File

UmlRt.cs

See Also
Inheritance Hierarchy


IAttribute Properties

IAttribute Properties
Public Properties
Collapse All

The properties of the IAttribute class are listed here.

Public Properties
Name | Description
AllowNull | Indicates whether or not a NULL value is permissable.
DefaultDbValue | This literal value specifies a default value to specify when creating a column for this UML attribute in an RDBMS based persistent storage.
EcoAttribute | This is EcoAttribute, a member of class IAttribute.
InitialValue | Contains the OCL expression specified in the model.
InitialValueAsObject | Evaluates the OCL in InitialValue and returns the result as a .NET object.
IsStateAttribute | Indicates whether or not the UML attribute is used to store the current state of a state machine or a region within the instance's state machine.
Length | Indicates the maximum allowed data size permitted for this UML attribute.


IAttribute.AllowNull Property

IAttribute.AllowNull Property
IAttribute Interface Eco.UmlRt Namespace See Also
Collapse All

Indicates whether or not a NULL value is permissable.

C#
bool AllowNull;
See Also
IAttribute Interface
Eco.UmlRt Namespace


IAttribute.DefaultDbValue Property

IAttribute.DefaultDbValue Property
IAttribute Interface Eco.UmlRt Namespace See Also
Collapse All

This literal value specifies a default value to specify when creating a column for this UML attribute in an RDBMS based persistent storage.

C#
string DefaultDbValue;
See Also
IAttribute Interface
Eco.UmlRt Namespace


IAttribute.EcoAttribute Property

IAttribute.EcoAttribute Property
IAttribute Interface Eco.UmlRt Namespace See Also
Collapse All
C#
IEcoAttribute EcoAttribute;
Remarks

This is EcoAttribute, a member of class IAttribute.

See Also
IAttribute Interface
Eco.UmlRt Namespace


IAttribute.InitialValue Property

IAttribute.InitialValue Property
IAttribute Interface Eco.UmlRt Namespace See Also
Collapse All

Contains the OCL expression specified in the model.

C#
IExpression InitialValue;
Remarks

Whenever a new instance of the owning class is created each UML attribute's InitialValue expression (if specified) is evaluated and the resulting value is assigned to the class's property.

See Also
IAttribute Interface
Eco.UmlRt Namespace


IAttribute.InitialValueAsObject Property

IAttribute.InitialValueAsObject Property
IAttribute Interface Eco.UmlRt Namespace See Also
Collapse All

Evaluates the OCL in InitialValue and returns the result as a .NET object.

C#
object InitialValueAsObject;
See Also
IAttribute Interface
Eco.UmlRt Namespace


IAttribute.IsStateAttribute Property

IAttribute.IsStateAttribute Property
IAttribute Interface Eco.UmlRt Namespace See Also
Collapse All

Indicates whether or not the UML attribute is used to store the current state of a state machine or a region within the instance's state machine.

C#
bool IsStateAttribute;
See Also
IAttribute Interface
Eco.UmlRt Namespace


IAttribute.Length Property

IAttribute.Length Property
IAttribute Interface Eco.UmlRt Namespace See Also
Collapse All

Indicates the maximum allowed data size permitted for this UML attribute.

C#
int Length;
Remarks

This size is used (where relevant) when creating columns in an RDBMS based persistent storage; to enforce a maximum data size when setting a property value if Eco.Handles.DefaultEcoSpace.EnforceDefaultStringLength is set to True; and also when setting the maximum input sizes of GUI controls using Eco.Handles.MaxLengthSupportFunctions.GetMaxLength

See Also
IAttribute Interface
Eco.UmlRt Namespace


IAttributeCollection Interface

IAttributeCollection Interface
Inheritance Hierarchy See Also
Collapse All

Holds a collection of Eco.UmlRt.IAttribute.

C#
public interface IAttributeCollection : ICollection;
Inheritance Hierarchy
Eco.UmlRt.IAttributeCollection
File

UmlRt.cs

See Also
Inheritance Hierarchy


IAttributeCollection Methods

IAttributeCollection Methods
Public Methods
Collapse All

The methods of the IAttributeCollection class are listed here.

Public Methods
Name | Description
GetItemByName | Gets a UML attribute by its name.
this | Gets a UML attribute by its index within the collection.


IAttributeCollection.GetItemByName Method

IAttributeCollection.GetItemByName Method
IAttributeCollection Interface Eco.UmlRt Namespace See Also
Collapse All

Gets a UML attribute by its name.

C#
IAttribute GetItemByName(
    string name
);
Parameters
Parameters | Description
name | The name of the UML method.
See Also
IAttributeCollection Interface
Eco.UmlRt Namespace


IAttributeCollection.this Indexer

IAttributeCollection.this Indexer
IAttributeCollection Interface Eco.UmlRt Namespace See Also
Collapse All

Gets a UML attribute by its index within the collection.

C#
IAttribute this[
    int index
];
See Also
IAttributeCollection Interface
Eco.UmlRt Namespace


IBagType Interface

IBagType Interface
Inheritance Hierarchy See Also
Collapse All

A collection where elements may be added more than once.

C#
public interface IBagType : ICollectionType;
Inheritance Hierarchy
Eco.UmlRt.IModelElement
    Eco.UmlRt.IClassifier
        Eco.UmlRt.IDataType
            Eco.UmlRt.ICollectionType
                Eco.UmlRt.IBagType
File

UmlRt.cs

See Also
Inheritance Hierarchy


IClass Interface

IClass Interface
Inheritance Hierarchy See Also
Collapse All

Contains information about a UML class in the model.

C#
public interface IClass : IClassifier, IFeaturedType;
Inheritance Hierarchy
Eco.UmlRt.IModelElement
    Eco.UmlRt.IClassifier
    Eco.UmlRt.IFeaturedType
        Eco.UmlRt.IClass
            Eco.UmlRt.IEcoClass
File

UmlRt.cs

See Also
Inheritance Hierarchy


IClass Methods

IClass Methods
Public Methods
Collapse All

The methods of the IClass class are listed here.

Public Methods
Name | Description
GetDerivationOcl | Returns the OCL expression used to determine the value of an OCL derived (calculated) feature (UML attribute or association).
GetStructuralFeatureIndexByLoopbackIndex | Using the loopback index of a member in the current .NET class this method will return the corresponding index for the IFeaturedType.AllStructuralFeatures collection.


IClass.GetDerivationOcl Method

IClass.GetDerivationOcl Method
IClass Interface Eco.UmlRt Namespace See Also
Collapse All

Returns the OCL expression used to determine the value of an OCL derived (calculated) feature (UML attribute or association).

C#
string GetDerivationOcl(
    IStructuralFeature feature
);
Parameters
Parameters | Description
feature | The OCL derived feature to return the OCL expression for.
See Also
IClass Interface
Eco.UmlRt Namespace


IClass.GetStructuralFeatureIndexByLoopbackIndex Method

IClass.GetStructuralFeatureIndexByLoopbackIndex Method
IClass Interface Eco.UmlRt Namespace See Also
Collapse All

Using the loopback index of a member in the current .NET class this method will return the corresponding index for the IFeaturedType.AllStructuralFeatures collection.

C#
int GetStructuralFeatureIndexByLoopbackIndex(
    int loopbackIndex
);
Parameters
Parameters | Description
loopbackIndex | The loopback index defined within the .NET class.
See Also
IClass Interface
Eco.UmlRt Namespace


IClass Properties

IClass Properties
Public Properties
Collapse All

The properties of the IClass class are listed here.

Public Properties
Name | Description
AllMethods | A collection containing a combination of all methods defined for the current UML class and all inherited methods.
Association | If the current UML class is an association class this property will hold a reference to the association.
DefaultStringRepresentation | Contains the OCL expression that should be evaluated in order to provide a default description for an instance of the modeled UML class. This expression is specified during design time.
EcoClass | This is EcoClass, a member of class IClass.
FirstOwnStructuralFeatureIndex | Indicates the integer index of the first member introduced by this class. If for example this class inherits from a UML class with 5 features then this property will return the number 5.
GenerateDefaultRegion | Indicates whether or not default optimistic locking regions were generated for this class.
Id | The unique name of the UML class.
InternalIndex | This is InternalIndex, a member of class IClass.
IsAssociationClass | Indicates whether or not the current class is an association class, used to link two classes together in an association.
IsImplicit | This is IsImplicit, a member of class IClass.
IsLinkClass | Specifies whether or not the current UML class is a class that is used to link to other classes in an association.
OptimisticLockingMode | Indicates the optimistic locking mode used for this UML class.
Persistent | Indicates whether or not the current UML class is persistent.
StateMachine | Holds a reference to the UML class's state machine.
SuperClass | Holds a reference to the super class of this UML class.
Versioned | Indicates whether or not the current UML class is marked as versioned.


IClass.AllMethods Property

IClass.AllMethods Property
IClass Interface Eco.UmlRt Namespace See Also
Collapse All

A collection containing a combination of all methods defined for the current UML class and all inherited methods.

C#
IMethodCollection AllMethods;
See Also
IClass Interface
Eco.UmlRt Namespace


IClass.Association Property

IClass.Association Property
IClass Interface Eco.UmlRt Namespace See Also
Collapse All

If the current UML class is an association class this property will hold a reference to the association.

C#
IAssociation Association;
See Also
IClass Interface
Eco.UmlRt Namespace


IClass.DefaultStringRepresentation Property

IClass.DefaultStringRepresentation Property
IClass Interface Eco.UmlRt Namespace See Also
Collapse All

Contains the OCL expression that should be evaluated in order to provide a default description for an instance of the modeled UML class. This expression is specified during design time.

C#
string DefaultStringRepresentation;
See Also
IClass Interface
Eco.UmlRt Namespace


IClass.EcoClass Property

IClass.EcoClass Property
IClass Interface Eco.UmlRt Namespace See Also
Collapse All
C#
IEcoClass EcoClass;
Remarks

This is EcoClass, a member of class IClass.

See Also
IClass Interface
Eco.UmlRt Namespace


IClass.FirstOwnStructuralFeatureIndex Property

IClass.FirstOwnStructuralFeatureIndex Property
IClass Interface Eco.UmlRt Namespace See Also
Collapse All

Indicates the integer index of the first member introduced by this class. If for example this class inherits from a UML class with 5 features then this property will return the number 5.

C#
int FirstOwnStructuralFeatureIndex;
See Also
IClass Interface
Eco.UmlRt Namespace


IClass.GenerateDefaultRegion Property

IClass.GenerateDefaultRegion Property
IClass Interface Eco.UmlRt Namespace See Also
Collapse All

Indicates whether or not default optimistic locking regions were generated for this class.

C#
bool GenerateDefaultRegion;
See Also
IClass Interface
Eco.UmlRt Namespace


IClass.Id Property

IClass.Id Property
IClass Interface Eco.UmlRt Namespace See Also
Collapse All

The unique name of the UML class.

C#
string Id;
See Also
IClass Interface
Eco.UmlRt Namespace


IClass.InternalIndex Property

IClass.InternalIndex Property
IClass Interface Eco.UmlRt Namespace See Also
Collapse All
C#
int InternalIndex;
Remarks

This is InternalIndex, a member of class IClass.

See Also
IClass Interface
Eco.UmlRt Namespace


IClass.IsAssociationClass Property

IClass.IsAssociationClass Property
IClass Interface Eco.UmlRt Namespace See Also
Collapse All

Indicates whether or not the current class is an association class, used to link two classes together in an association.

C#
bool IsAssociationClass;
See Also
IClass Interface
Eco.UmlRt Namespace


IClass.IsImplicit Property

IClass.IsImplicit Property
IClass Interface Eco.UmlRt Namespace See Also
Collapse All
C#
bool IsImplicit;
Remarks

This is IsImplicit, a member of class IClass.

See Also
IClass Interface
Eco.UmlRt Namespace


IClass.IsLinkClass Property

IClass.IsLinkClass Property
IClass Interface Eco.UmlRt Namespace See Also
Collapse All

Specifies whether or not the current UML class is a class that is used to link to other classes in an association.

C#
bool IsLinkClass;
See Also
IClass Interface
Eco.UmlRt Namespace


IClass.OptimisticLockingMode Property

IClass.OptimisticLockingMode Property
IClass Interface Eco.UmlRt Namespace See Also
Collapse All

Indicates the optimistic locking mode used for this UML class.

C#
OptimisticLockingMode OptimisticLockingMode;
See Also
IClass Interface
Eco.UmlRt Namespace


IClass.Persistent Property

IClass.Persistent Property
IClass Interface Eco.UmlRt Namespace See Also
Collapse All

Indicates whether or not the current UML class is persistent.

C#
bool Persistent;
See Also
IClass Interface
Eco.UmlRt Namespace


IClass.StateMachine Property

IClass.StateMachine Property
IClass Interface Eco.UmlRt Namespace See Also
Collapse All

Holds a reference to the UML class's state machine.

C#
IStateMachine StateMachine;
See Also
IClass Interface
Eco.UmlRt Namespace


IClass.SuperClass Property

IClass.SuperClass Property
IClass Interface Eco.UmlRt Namespace See Also
Collapse All

Holds a reference to the super class of this UML class.

C#
IClass SuperClass;
See Also
IClass Interface
Eco.UmlRt Namespace


IClass.Versioned Property

IClass.Versioned Property
IClass Interface Eco.UmlRt Namespace Related Topics See Also
Collapse All

Indicates whether or not the current UML class is marked as versioned.

C#
bool Versioned;
Related Topics

Eco.Services.IVersionService

See Also
IClass Interface
Eco.UmlRt Namespace
Related Topics


IClassCollection Interface

IClassCollection Interface
Inheritance Hierarchy See Also
Collapse All

Holds a collection of Eco.UmlRt.IClass.

C#
public interface IClassCollection : ICollection;
Inheritance Hierarchy
Eco.UmlRt.IClassCollection
File

UmlRt.cs

See Also
Inheritance Hierarchy


IClassCollection Methods

IClassCollection Methods
Public Methods
Collapse All

The methods of the IClassCollection class are listed here.

Public Methods
Name | Description
GetItemByName | Gets a class by its name.
this | Gets a class by its index within the collection.


IClassCollection.GetItemByName Method

IClassCollection.GetItemByName Method
IClassCollection Interface Eco.UmlRt Namespace See Also
Collapse All

Gets a class by its name.

C#
IClass GetItemByName(
    string name
);
Parameters
Parameters | Description
name | The name of the class.
See Also
IClassCollection Interface
Eco.UmlRt Namespace


IClassCollection.this Indexer

IClassCollection.this Indexer
IClassCollection Interface Eco.UmlRt Namespace See Also
Collapse All

Gets a class by its index within the collection.

C#
IClass this[
    int index
];
See Also
IClassCollection Interface
Eco.UmlRt Namespace


IClassifier Interface

IClassifier Interface
Inheritance Hierarchy See Also
Collapse All

Contains information about an element within the model.

C#
public interface IClassifier : IModelElement;
Remarks

An IClassifier is used to represent primitive types such as integers and strings, additionally it is used to represent modeled UML classes Eco.UmlRt.IClass.

Inheritance Hierarchy
Eco.UmlRt.IModelElement
    Eco.UmlRt.IClassifier
        Eco.UmlRt.IClass
        Eco.UmlRt.IDataType
        Eco.UmlRt.IEcoClassifier
File

UmlRt.cs

See Also
Inheritance Hierarchy


IClassifier Methods

IClassifier Methods
Public Methods
Collapse All

The methods of the IClassifier class are listed here.

Public Methods
Name | Description
ConformsTo | Returns True if the current classifier inherits from the specified classifier or is the same type of classifier, otherwise returns false.
ConvertAsObject | Attempts to convert a given object to the specified type.
IsA | Returns True if the current classifier inherits from the specified classifier or is the same type of classifier, otherwise returns false.
LeastCommonType | Inspects the hierarchy of both classes and returns the first base class that both share.


IClassifier.ConformsTo Method

IClassifier.ConformsTo Method
IClassifier Interface Eco.UmlRt Namespace See Also
Collapse All

Returns True if the current classifier inherits from the specified classifier or is the same type of classifier, otherwise returns false.

C#
bool ConformsTo(
    IClassifier classifier
);
Parameters
Parameters | Description
classifier | The classifier to compare with.
See Also
IClassifier Interface
Eco.UmlRt Namespace


IClassifier.ConvertAsObject Method

IClassifier.ConvertAsObject Method
IClassifier Interface Eco.UmlRt Namespace See Also
Collapse All

Attempts to convert a given object to the specified type.

C#
System.Object ConvertAsObject(
    object value,
    IClassifier toType
);
Parameters
Parameters | Description
value | The object to convert.
toType | The type of model element to convert the object to.
Remarks

If conversion is not possible a Eco.ObjectRepresentation.ArgumentNonConformException exception will be thrown.

See Also
IClassifier Interface
Eco.UmlRt Namespace


IClassifier.IsA Method

IClassifier.IsA Method
IClassifier Interface Eco.UmlRt Namespace See Also
Collapse All

Returns True if the current classifier inherits from the specified classifier or is the same type of classifier, otherwise returns false.

C#
bool IsA(
    IClassifier classifier
);
Parameters
Parameters | Description
classifier | The classifier to compare with.
See Also
IClassifier Interface
Eco.UmlRt Namespace


IClassifier.LeastCommonType Method

IClassifier.LeastCommonType Method
IClassifier Interface Eco.UmlRt Namespace See Also
Collapse All

Inspects the hierarchy of both classes and returns the first base class that both share.

C#
IClassifier LeastCommonType(
    IClassifier classifier
);
Parameters
Parameters | Description
classifier | The classifier to compare with.
See Also
IClassifier Interface
Eco.UmlRt Namespace


IClassifier Properties

IClassifier Properties
Public Properties
Collapse All

The properties of the IClassifier class are listed here.

Public Properties
Name | Description
ClassifierType | Specifies the Eco.UmlRt.ClassifierType of of the current classifier.
CollectionType | Specifies the collection type for this classifier.
EcoClassifier | This is EcoClassifier, a member of class IClassifier.
Features | A collection of all features owned by the classifier.
IsAbstract | Specifies whether or not the classifier is an abstract class.
ObjectType | Returns the .NET type associated with this classifier.
SubTypes | Returns an IClassifier collection that contains all immediate descendants of this type.
SuperTypes | Returns an IClassifier collection that contains all immediate ancestors of this type.
TypeSystem | Holds a reference to the ECO type system containing all model information.


IClassifier.ClassifierType Property

IClassifier.ClassifierType Property
IClassifier Interface Eco.UmlRt Namespace See Also
Collapse All

Specifies the Eco.UmlRt.ClassifierType of of the current classifier.

C#
ClassifierType ClassifierType;
See Also
IClassifier Interface
Eco.UmlRt Namespace


IClassifier.CollectionType Property

IClassifier.CollectionType Property
IClassifier Interface Eco.UmlRt Namespace See Also
Collapse All

Specifies the collection type for this classifier.

C#
ICollectionType CollectionType;
See Also
IClassifier Interface
Eco.UmlRt Namespace


IClassifier.EcoClassifier Property

IClassifier.EcoClassifier Property
IClassifier Interface Eco.UmlRt Namespace See Also
Collapse All
C#
IEcoClassifier EcoClassifier;
Remarks

This is EcoClassifier, a member of class IClassifier.

See Also
IClassifier Interface
Eco.UmlRt Namespace


IClassifier.Features Property

IClassifier.Features Property
IClassifier Interface Eco.UmlRt Namespace See Also
Collapse All

A collection of all features owned by the classifier.

C#
IFeatureCollection Features;
See Also
IClassifier Interface
Eco.UmlRt Namespace


IClassifier.IsAbstract Property

IClassifier.IsAbstract Property
IClassifier Interface Eco.UmlRt Namespace See Also
Collapse All

Specifies whether or not the classifier is an abstract class.

C#
bool IsAbstract;
See Also
IClassifier Interface
Eco.UmlRt Namespace


IClassifier.ObjectType Property

IClassifier.ObjectType Property
IClassifier Interface Eco.UmlRt Namespace See Also
Collapse All

Returns the .NET type associated with this classifier.

C#
System.Type ObjectType;
See Also
IClassifier Interface
Eco.UmlRt Namespace


IClassifier.SubTypes Property

IClassifier.SubTypes Property
IClassifier Interface Eco.UmlRt Namespace See Also
Collapse All

Returns an IClassifier collection that contains all immediate descendants of this type.

C#
IClassifierCollection SubTypes;
See Also
IClassifier Interface
Eco.UmlRt Namespace


IClassifier.SuperTypes Property

IClassifier.SuperTypes Property
IClassifier Interface Eco.UmlRt Namespace See Also
Collapse All

Returns an IClassifier collection that contains all immediate ancestors of this type.

C#
IClassifierCollection SuperTypes;
Remarks

Note that this collection will only contain zero or one entries, multiple entries are supported in order to be UML compliant.

See Also
IClassifier Interface
Eco.UmlRt Namespace


IClassifier.TypeSystem Property

IClassifier.TypeSystem Property
IClassifier Interface Eco.UmlRt Namespace See Also
Collapse All

Holds a reference to the ECO type system containing all model information.

C#
IEcoTypeSystem TypeSystem;
See Also
IClassifier Interface
Eco.UmlRt Namespace


IClassifierCollection Interface

IClassifierCollection Interface
Inheritance Hierarchy See Also
Collapse All

Holds a collection of Eco.UmlRt.IClassifier

C#
public interface IClassifierCollection : ICollection;
Inheritance Hierarchy
Eco.UmlRt.IClassifierCollection
File

UmlRt.cs

See Also
Inheritance Hierarchy


IClassifierCollection Methods

IClassifierCollection Methods
Public Methods
Collapse All

The methods of the IClassifierCollection class are listed here.

Public Methods
Name | Description
GetItemByName | Gets a classifier by its name.
this | Gets a classifier by its index within the collection.


IClassifierCollection.GetItemByName Method

IClassifierCollection.GetItemByName Method
IClassifierCollection Interface Eco.UmlRt Namespace See Also
Collapse All

Gets a classifier by its name.

C#
IClassifier GetItemByName(
    string name
);
Parameters
Parameters | Description
name | The name of the classifier.
See Also
IClassifierCollection Interface
Eco.UmlRt Namespace


IClassifierCollection.this Indexer

IClassifierCollection.this Indexer
IClassifierCollection Interface Eco.UmlRt Namespace See Also
Collapse All

Gets a classifier by its index within the collection.

C#
IClassifier this[
    int index
];
See Also
IClassifierCollection Interface
Eco.UmlRt Namespace


ICollectionKinds Interface

ICollectionKinds Interface
Inheritance Hierarchy See Also
Collapse All
C#
public interface ICollectionKinds;
Remarks

This is class Eco.UmlRt.ICollectionKinds.

Inheritance Hierarchy
Eco.UmlRt.ICollectionKinds
File

UmlRt.cs

See Also
Inheritance Hierarchy


ICollectionKinds Properties

ICollectionKinds Properties
Public Properties
Collapse All

The properties of the ICollectionKinds class are listed here.

Public Properties
Name | Description
BagType | This is BagType, a member of class ICollectionKinds.
CollectionType | This is CollectionType, a member of class ICollectionKinds.
OrderedSetType | This is OrderedSetType, a member of class ICollectionKinds.
SequenceType | This is SequenceType, a member of class ICollectionKinds.
SetType | This is SetType, a member of class ICollectionKinds.


ICollectionKinds.BagType Property

ICollectionKinds.BagType Property
ICollectionKinds Interface Eco.UmlRt Namespace See Also
Collapse All
C#
IBagType BagType;
Remarks

This is BagType, a member of class ICollectionKinds.

See Also
ICollectionKinds Interface
Eco.UmlRt Namespace


ICollectionKinds.CollectionType Property

ICollectionKinds.CollectionType Property
ICollectionKinds Interface Eco.UmlRt Namespace See Also
Collapse All
C#
ICollectionType CollectionType;
Remarks

This is CollectionType, a member of class ICollectionKinds.

See Also
ICollectionKinds Interface
Eco.UmlRt Namespace


ICollectionKinds.OrderedSetType Property

ICollectionKinds.OrderedSetType Property
ICollectionKinds Interface Eco.UmlRt Namespace See Also
Collapse All
C#
IOrderedSetType OrderedSetType;
Remarks

This is OrderedSetType, a member of class ICollectionKinds.

See Also
ICollectionKinds Interface
Eco.UmlRt Namespace


ICollectionKinds.SequenceType Property

ICollectionKinds.SequenceType Property
ICollectionKinds Interface Eco.UmlRt Namespace See Also
Collapse All
C#
ISequenceType SequenceType;
Remarks

This is SequenceType, a member of class ICollectionKinds.

See Also
ICollectionKinds Interface
Eco.UmlRt Namespace


ICollectionKinds.SetType Property

ICollectionKinds.SetType Property
ICollectionKinds Interface Eco.UmlRt Namespace See Also
Collapse All
C#
ISetType SetType;
Remarks

This is SetType, a member of class ICollectionKinds.

See Also
ICollectionKinds Interface
Eco.UmlRt Namespace


ICollectionType Interface

ICollectionType Interface
Inheritance Hierarchy See Also
Collapse All

This data type is used to hold a collection of data types.

C#
public interface ICollectionType : IDataType;
Inheritance Hierarchy
Eco.UmlRt.IModelElement
    Eco.UmlRt.IClassifier
        Eco.UmlRt.IDataType
            Eco.UmlRt.ICollectionType
                Eco.UmlRt.IBagType
                Eco.UmlRt.IOrderedSetType
                Eco.UmlRt.ISequenceType
                Eco.UmlRt.ISetType
File

UmlRt.cs

See Also
Inheritance Hierarchy


ICollectionType Properties

ICollectionType Properties
Public Properties
Collapse All

The properties of the ICollectionType class are listed here.

Public Properties
Name | Description
CollectionKinds | This is CollectionKinds, a member of class ICollectionType.
ElementType | Specifies the data type that the collection holds.
Kind | Specifies how the collection should behave with regards to entering duplicate values etc.


ICollectionType.CollectionKinds Property

ICollectionType.CollectionKinds Property
ICollectionType Interface Eco.UmlRt Namespace See Also
Collapse All
C#
ICollectionKinds CollectionKinds;
Remarks

This is CollectionKinds, a member of class ICollectionType.

See Also
ICollectionType Interface
Eco.UmlRt Namespace


ICollectionType.ElementType Property

ICollectionType.ElementType Property
ICollectionType Interface Eco.UmlRt Namespace See Also
Collapse All

Specifies the data type that the collection holds.

C#
IClassifier ElementType;
See Also
ICollectionType Interface
Eco.UmlRt Namespace


ICollectionType.Kind Property

ICollectionType.Kind Property
ICollectionType Interface Eco.UmlRt Namespace See Also
Collapse All

Specifies how the collection should behave with regards to entering duplicate values etc.

C#
CollectionTypeKind Kind;
See Also
ICollectionType Interface
Eco.UmlRt Namespace


IConstraint Interface

IConstraint Interface
Inheritance Hierarchy See Also
Collapse All

Contains model information about a constraint.

C#
public interface IConstraint : IModelElement;
Inheritance Hierarchy
Eco.UmlRt.IModelElement
    Eco.UmlRt.IConstraint
        Eco.UmlRt.IEcoConstraint
File

UmlRt.cs

See Also
Inheritance Hierarchy


IConstraint Properties

IConstraint Properties
Public Properties
Collapse All

The properties of the IConstraint class are listed here.

Public Properties
Name | Description
Body | Holds the details of the constraint.
Description | Provides the name of the constraint as provided in the model during design time. The description is taken as all of the text before a colon in the constraint.
EcoConstraint | This is EcoConstraint, a member of class IConstraint.
IsAutoGenerated | Specifies whether or not the constraint was automatically generated when the EcoSpace was activated. Typically multiplicity constraints are generated automatically.


IConstraint.Body Property

IConstraint.Body Property
IConstraint Interface Eco.UmlRt Namespace See Also
Collapse All

Holds the details of the constraint.

C#
IExpression Body;
See Also
IConstraint Interface
Eco.UmlRt Namespace


IConstraint.Description Property

IConstraint.Description Property
IConstraint Interface Eco.UmlRt Namespace Example See Also
Collapse All

Provides the name of the constraint as provided in the model during design time. The description is taken as all of the text before a colon in the constraint.

C#
string Description;
Example

This is the description:name.length > 0

See Also
IConstraint Interface
Eco.UmlRt Namespace
Example


IConstraint.EcoConstraint Property

IConstraint.EcoConstraint Property
IConstraint Interface Eco.UmlRt Namespace See Also
Collapse All
C#
IEcoConstraint EcoConstraint;
Remarks

This is EcoConstraint, a member of class IConstraint.

See Also
IConstraint Interface
Eco.UmlRt Namespace


IConstraint.IsAutoGenerated Property

IConstraint.IsAutoGenerated Property
IConstraint Interface Eco.UmlRt Namespace Example See Also
Collapse All

Specifies whether or not the constraint was automatically generated when the EcoSpace was activated. Typically multiplicity constraints are generated automatically.

C#
bool IsAutoGenerated;
Remarks

To disable the automatic creation of multiplicity constraints add the following .NET attribute to the EcoSpace class in your application.

Example

[UmlTaggedValue("Eco.GenerateMultiplicityConstraints", "False")]

See Also
IConstraint Interface
Eco.UmlRt Namespace
Example


IConstraintCollection Interface

IConstraintCollection Interface
Inheritance Hierarchy See Also
Collapse All

Holds a collection of Eco.UmlRt.IConstraint.

C#
public interface IConstraintCollection : ICollection;
Inheritance Hierarchy
Eco.UmlRt.IConstraintCollection
File

UmlRt.cs

See Also
Inheritance Hierarchy


IConstraintCollection Methods

IConstraintCollection Methods
Public Methods
Collapse All

The methods of the IConstraintCollection class are listed here.

Public Methods
Name | Description
GetItemByName | Gets a constraint by its name.
this | Gets a constraint by its index within the collection.


IConstraintCollection.GetItemByName Method

IConstraintCollection.GetItemByName Method
IConstraintCollection Interface Eco.UmlRt Namespace See Also
Collapse All

Gets a constraint by its name.

C#
IConstraint GetItemByName(
    string name
);
Parameters
Parameters | Description
name | The name of the constraint.
See Also
IConstraintCollection Interface
Eco.UmlRt Namespace


IConstraintCollection.this Indexer

IConstraintCollection.this Indexer
IConstraintCollection Interface Eco.UmlRt Namespace See Also
Collapse All

Gets a constraint by its index within the collection.

C#
IConstraint this[
    int index
];
See Also
IConstraintCollection Interface
Eco.UmlRt Namespace


IDataType Interface

IDataType Interface
Inheritance Hierarchy See Also
Collapse All

Identifies a model element as a data type such as a collection or a simple type.

C#
public interface IDataType : IClassifier;
Inheritance Hierarchy
Eco.UmlRt.IModelElement
    Eco.UmlRt.IClassifier
        Eco.UmlRt.IDataType
            Eco.UmlRt.ICollectionType
            Eco.UmlRt.ISimpleType
            Eco.UmlRt.ITupleType
File

UmlRt.cs

See Also
Inheritance Hierarchy


IEcoAssociation Interface

IEcoAssociation Interface
Inheritance Hierarchy See Also
Collapse All
C#
public interface IEcoAssociation : IAssociation;
Remarks

This is class Eco.UmlRt.IEcoAssociation.

Inheritance Hierarchy
Eco.UmlRt.IModelElement
    Eco.UmlRt.IAssociation
        Eco.UmlRt.IEcoAssociation
File

UmlRt.cs

See Also
Inheritance Hierarchy


IEcoAssociationEnd Interface

IEcoAssociationEnd Interface
Inheritance Hierarchy See Also
Collapse All
C#
public interface IEcoAssociationEnd : IAssociationEnd;
Remarks

This is class Eco.UmlRt.IEcoAssociationEnd.

Inheritance Hierarchy
Eco.UmlRt.IModelElement
    Eco.UmlRt.IFeature
        Eco.UmlRt.IStructuralFeature
            Eco.UmlRt.IAssociationEnd
                Eco.UmlRt.IEcoAssociationEnd
File

UmlRt.cs

See Also
Inheritance Hierarchy


IEcoAttribute Interface

IEcoAttribute Interface
Inheritance Hierarchy See Also
Collapse All
C#
public interface IEcoAttribute : IAttribute;
Remarks

This is class Eco.UmlRt.IEcoAttribute.

Inheritance Hierarchy
Eco.UmlRt.IModelElement
    Eco.UmlRt.IFeature
        Eco.UmlRt.IStructuralFeature
            Eco.UmlRt.IAttribute
                Eco.UmlRt.IEcoAttribute
File

UmlRt.cs

See Also
Inheritance Hierarchy


IEcoClass Interface

IEcoClass Interface
Inheritance Hierarchy See Also
Collapse All
C#
public interface IEcoClass : IClass;
Remarks

This is class Eco.UmlRt.IEcoClass.

Inheritance Hierarchy
Eco.UmlRt.IModelElement
    Eco.UmlRt.IClassifier
    Eco.UmlRt.IFeaturedType
        Eco.UmlRt.IClass
            Eco.UmlRt.IEcoClass
File

UmlRt.cs

See Also
Inheritance Hierarchy


IEcoClassifier Interface

IEcoClassifier Interface
Inheritance Hierarchy See Also
Collapse All
C#
public interface IEcoClassifier : IClassifier;
Remarks

This is class Eco.UmlRt.IEcoClassifier.

Inheritance Hierarchy
Eco.UmlRt.IModelElement
    Eco.UmlRt.IClassifier
        Eco.UmlRt.IEcoClassifier
File

UmlRt.cs

See Also
Inheritance Hierarchy


IEcoConstraint Interface

IEcoConstraint Interface
Inheritance Hierarchy See Also
Collapse All
C#
public interface IEcoConstraint : IConstraint;
Remarks

This is class Eco.UmlRt.IEcoConstraint.

Inheritance Hierarchy
Eco.UmlRt.IModelElement
    Eco.UmlRt.IConstraint
        Eco.UmlRt.IEcoConstraint
File

UmlRt.cs

See Also
Inheritance Hierarchy


IEcoEnumerationLiteral Interface

IEcoEnumerationLiteral Interface
Inheritance Hierarchy See Also
Collapse All
C#
public interface IEcoEnumerationLiteral : IEnumerationLiteral;
Remarks

This is class Eco.UmlRt.IEcoEnumerationLiteral.

Inheritance Hierarchy
Eco.UmlRt.IModelElement
    Eco.UmlRt.IEnumerationLiteral
        Eco.UmlRt.IEcoEnumerationLiteral
File

UmlRt.cs

See Also
Inheritance Hierarchy


IEcoFeature Interface

IEcoFeature Interface
Inheritance Hierarchy See Also
Collapse All
C#
public interface IEcoFeature : IFeature;
Remarks

This is class Eco.UmlRt.IEcoFeature.

Inheritance Hierarchy
Eco.UmlRt.IModelElement
    Eco.UmlRt.IFeature
        Eco.UmlRt.IEcoFeature
File

UmlRt.cs

See Also
Inheritance Hierarchy


IEcoMethod Interface

IEcoMethod Interface
Inheritance Hierarchy See Also
Collapse All
C#
public interface IEcoMethod : IMethod;
Remarks

This is class Eco.UmlRt.IEcoMethod.

Inheritance Hierarchy
Eco.UmlRt.IModelElement
    Eco.UmlRt.IFeature
        Eco.UmlRt.IMethod
            Eco.UmlRt.IEcoMethod
File

UmlRt.cs

See Also
Inheritance Hierarchy


IEcoPackage Interface

IEcoPackage Interface
Inheritance Hierarchy See Also
Collapse All
C#
public interface IEcoPackage : IPackage;
Remarks

This is class Eco.UmlRt.IEcoPackage.

Inheritance Hierarchy
Eco.UmlRt.IModelElement
    Eco.UmlRt.IPackage
        Eco.UmlRt.IEcoPackage
File

UmlRt.cs

See Also
Inheritance Hierarchy


IEcoPredefinedTypes Interface

IEcoPredefinedTypes Interface
Inheritance Hierarchy See Also
Collapse All

This interface provides an appropriate Eco.UmlRt.IDataType.

C#
public interface IEcoPredefinedTypes;
Inheritance Hierarchy
Eco.UmlRt.IEcoPredefinedTypes
File

UmlRt.cs

See Also
Inheritance Hierarchy


IEcoPredefinedTypes Properties

IEcoPredefinedTypes Properties
Public Properties
Collapse All

The properties of the IEcoPredefinedTypes class are listed here.

Public Properties
Name | Description
Boolean | Returns a data type representing a boolean.
Byte | Returns a data type representing a byte.
Char | Returns a data type representing a single character.
DateTime | Returns a data type representing a date and time.
Decimal | Returns a data type representing a signed 128 bit precise fractional number.
Double | Returns a data type representing a signed 64 bit floating point number.
GenericCollectionType | Returns a data type representing generic element collection.
Guid | Returns a data type representing a Guid.
Int16 | Returns a data type representing a signed 16 bit integer.
Int32 | Returns a data type representing a signed 32 bit integer.
Int64 | Returns a data type representing a signed 64 bit integer.
NullType | Returns a data type representing a null.
OclSortDirection | Returns a data type representing an Eco.Ocl.Support.OclSortDirection.
RootClassType | Returns a data type representing the root class of the model.
SByte | Returns a data type representing a signed byte.
Single | Returns a data type representing a signed 32 bit floating point number.
String_ | Returns a data type representing a sring.
TimeSpan | Returns a data type representing an amount of time.
UInt16 | Returns a data type representing an unsigned 16 bit integer.
UInt32 | Returns a data type representing an unsigned 32 bit integer.
UInt64 | Returns a data type representing an unsigned 64 bit integer.


IEcoPredefinedTypes.Boolean Property

IEcoPredefinedTypes.Boolean Property
IEcoPredefinedTypes Interface Eco.UmlRt Namespace See Also
Collapse All

Returns a data type representing a boolean.

C#
IDataType Boolean;
See Also
IEcoPredefinedTypes Interface
Eco.UmlRt Namespace


IEcoPredefinedTypes.Byte Property

IEcoPredefinedTypes.Byte Property
IEcoPredefinedTypes Interface Eco.UmlRt Namespace See Also
Collapse All

Returns a data type representing a byte.

C#
IDataType Byte;
See Also
IEcoPredefinedTypes Interface
Eco.UmlRt Namespace


IEcoPredefinedTypes.Char Property

IEcoPredefinedTypes.Char Property
IEcoPredefinedTypes Interface Eco.UmlRt Namespace See Also
Collapse All

Returns a data type representing a single character.

C#
IDataType Char;
See Also
IEcoPredefinedTypes Interface
Eco.UmlRt Namespace


IEcoPredefinedTypes.DateTime Property

IEcoPredefinedTypes.DateTime Property
IEcoPredefinedTypes Interface Eco.UmlRt Namespace See Also
Collapse All

Returns a data type representing a date and time.

C#
IDataType DateTime;
See Also
IEcoPredefinedTypes Interface
Eco.UmlRt Namespace


IEcoPredefinedTypes.Decimal Property

IEcoPredefinedTypes.Decimal Property
IEcoPredefinedTypes Interface Eco.UmlRt Namespace See Also
Collapse All

Returns a data type representing a signed 128 bit precise fractional number.

C#
IDataType Decimal;
See Also
IEcoPredefinedTypes Interface
Eco.UmlRt Namespace


IEcoPredefinedTypes.Double Property

IEcoPredefinedTypes.Double Property
IEcoPredefinedTypes Interface Eco.UmlRt Namespace See Also
Collapse All

Returns a data type representing a signed 64 bit floating point number.

C#
IDataType Double;
See Also
IEcoPredefinedTypes Interface
Eco.UmlRt Namespace


IEcoPredefinedTypes.GenericCollectionType Property

IEcoPredefinedTypes.GenericCollectionType Property
IEcoPredefinedTypes Interface Eco.UmlRt Namespace See Also
Collapse All

Returns a data type representing generic element collection.

C#
ICollectionType GenericCollectionType;
See Also
IEcoPredefinedTypes Interface
Eco.UmlRt Namespace


IEcoPredefinedTypes.Guid Property

IEcoPredefinedTypes.Guid Property
IEcoPredefinedTypes Interface Eco.UmlRt Namespace See Also
Collapse All

Returns a data type representing a Guid.

C#
IDataType Guid;
See Also
IEcoPredefinedTypes Interface
Eco.UmlRt Namespace


IEcoPredefinedTypes.Int16 Property

IEcoPredefinedTypes.Int16 Property
IEcoPredefinedTypes Interface Eco.UmlRt Namespace See Also
Collapse All

Returns a data type representing a signed 16 bit integer.

C#
IDataType Int16;
See Also
IEcoPredefinedTypes Interface
Eco.UmlRt Namespace


IEcoPredefinedTypes.Int32 Property

IEcoPredefinedTypes.Int32 Property
IEcoPredefinedTypes Interface Eco.UmlRt Namespace See Also
Collapse All

Returns a data type representing a signed 32 bit integer.

C#
IDataType Int32;
See Also
IEcoPredefinedTypes Interface
Eco.UmlRt Namespace


IEcoPredefinedTypes.Int64 Property

IEcoPredefinedTypes.Int64 Property
IEcoPredefinedTypes Interface Eco.UmlRt Namespace See Also
Collapse All

Returns a data type representing a signed 64 bit integer.

C#
IDataType Int64;
See Also
IEcoPredefinedTypes Interface
Eco.UmlRt Namespace


IEcoPredefinedTypes.NullType Property

IEcoPredefinedTypes.NullType Property
IEcoPredefinedTypes Interface Eco.UmlRt Namespace See Also
Collapse All

Returns a data type representing a null.

C#
IClass NullType;
See Also
IEcoPredefinedTypes Interface
Eco.UmlRt Namespace


IEcoPredefinedTypes.OclSortDirection Property

IEcoPredefinedTypes.OclSortDirection Property
IEcoPredefinedTypes Interface Eco.UmlRt Namespace See Also
Collapse All

Returns a data type representing an Eco.Ocl.Support.OclSortDirection.

C#
IEnumerationType OclSortDirection;
See Also
IEcoPredefinedTypes Interface
Eco.UmlRt Namespace


IEcoPredefinedTypes.RootClassType Property

IEcoPredefinedTypes.RootClassType Property
IEcoPredefinedTypes Interface Eco.UmlRt Namespace See Also
Collapse All

Returns a data type representing the root class of the model.

C#
IClass RootClassType;
See Also
IEcoPredefinedTypes Interface
Eco.UmlRt Namespace


IEcoPredefinedTypes.SByte Property

IEcoPredefinedTypes.SByte Property
IEcoPredefinedTypes Interface Eco.UmlRt Namespace See Also
Collapse All

Returns a data type representing a signed byte.

C#
IDataType SByte;
See Also
IEcoPredefinedTypes Interface
Eco.UmlRt Namespace


IEcoPredefinedTypes.Single Property

IEcoPredefinedTypes.Single Property
IEcoPredefinedTypes Interface Eco.UmlRt Namespace See Also
Collapse All

Returns a data type representing a signed 32 bit floating point number.

C#
IDataType Single;
See Also
IEcoPredefinedTypes Interface
Eco.UmlRt Namespace


IEcoPredefinedTypes.String_ Property

IEcoPredefinedTypes.String_ Property
IEcoPredefinedTypes Interface Eco.UmlRt Namespace See Also
Collapse All

Returns a data type representing a sring.

C#
IDataType String_;
See Also
IEcoPredefinedTypes Interface
Eco.UmlRt Namespace


IEcoPredefinedTypes.TimeSpan Property

IEcoPredefinedTypes.TimeSpan Property
IEcoPredefinedTypes Interface Eco.UmlRt Namespace See Also
Collapse All

Returns a data type representing an amount of time.

C#
IDataType TimeSpan;
See Also
IEcoPredefinedTypes Interface
Eco.UmlRt Namespace


IEcoPredefinedTypes.UInt16 Property

IEcoPredefinedTypes.UInt16 Property
IEcoPredefinedTypes Interface Eco.UmlRt Namespace See Also
Collapse All

Returns a data type representing an unsigned 16 bit integer.

C#
IDataType UInt16;
See Also
IEcoPredefinedTypes Interface
Eco.UmlRt Namespace


IEcoPredefinedTypes.UInt32 Property

IEcoPredefinedTypes.UInt32 Property
IEcoPredefinedTypes Interface Eco.UmlRt Namespace See Also
Collapse All

Returns a data type representing an unsigned 32 bit integer.

C#
IDataType UInt32;
See Also
IEcoPredefinedTypes Interface
Eco.UmlRt Namespace


IEcoPredefinedTypes.UInt64 Property

IEcoPredefinedTypes.UInt64 Property
IEcoPredefinedTypes Interface Eco.UmlRt Namespace See Also
Collapse All

Returns a data type representing an unsigned 64 bit integer.

C#
IDataType UInt64;
See Also
IEcoPredefinedTypes Interface
Eco.UmlRt Namespace


IEcoPrimitiveType Interface

IEcoPrimitiveType Interface
Inheritance Hierarchy See Also
Collapse All
C#
public interface IEcoPrimitiveType : IPrimitiveType;
Remarks

This is class Eco.UmlRt.IEcoPrimitiveType.

Inheritance Hierarchy
Eco.UmlRt.IModelElement
    Eco.UmlRt.IClassifier
        Eco.UmlRt.IDataType
            Eco.UmlRt.ISimpleType
                Eco.UmlRt.IPrimitiveType
                    Eco.UmlRt.IEcoPrimitiveType
File

UmlRt.cs

See Also
Inheritance Hierarchy


IEcoRegion Interface

IEcoRegion Interface
Inheritance Hierarchy See Also
Collapse All
C#
public interface IEcoRegion : IRegion;
Remarks

This is class Eco.UmlRt.IEcoRegion.

Inheritance Hierarchy
Eco.UmlRt.IModelElement
    Eco.UmlRt.IRegion
        Eco.UmlRt.IEcoRegion
File

UmlRt.cs

See Also
Inheritance Hierarchy


IEcoRegionContainer Interface

IEcoRegionContainer Interface
Inheritance Hierarchy See Also
Collapse All

Additional support methods for IRegionContainer.

C#
public interface IEcoRegionContainer : IRegionContainer;
Inheritance Hierarchy
Eco.UmlRt.IRegionContainer
    Eco.UmlRt.IEcoRegionContainer
File

UmlRt.cs

See Also
Inheritance Hierarchy


IEcoSimpleType Interface

IEcoSimpleType Interface
Inheritance Hierarchy See Also
Collapse All
C#
public interface IEcoSimpleType : ISimpleType;
Remarks

This is class Eco.UmlRt.IEcoSimpleType.

Inheritance Hierarchy
Eco.UmlRt.IModelElement
    Eco.UmlRt.IClassifier
        Eco.UmlRt.IDataType
            Eco.UmlRt.ISimpleType
                Eco.UmlRt.IEcoSimpleType
File

UmlRt.cs

See Also
Inheritance Hierarchy


IEcoState Interface

IEcoState Interface
Inheritance Hierarchy See Also
Collapse All
C#
public interface IEcoState : IState;
Remarks

This is class Eco.UmlRt.IEcoState.

Inheritance Hierarchy
Eco.UmlRt.IModelElement
    Eco.UmlRt.IVertex
    Eco.UmlRt.IRegionContainer
        Eco.UmlRt.IState
            Eco.UmlRt.IEcoState
File

UmlRt.cs

See Also
Inheritance Hierarchy


IEcoStateMachine Interface

IEcoStateMachine Interface
Inheritance Hierarchy See Also
Collapse All
C#
public interface IEcoStateMachine : IStateMachine;
Remarks

This is class Eco.UmlRt.IEcoStateMachine.

Inheritance Hierarchy
Eco.UmlRt.IModelElement
Eco.UmlRt.IRegionContainer
    Eco.UmlRt.IStateMachine
        Eco.UmlRt.IEcoStateMachine
File

UmlRt.cs

See Also
Inheritance Hierarchy


IEcoStructuralFeature Interface

IEcoStructuralFeature Interface
Inheritance Hierarchy See Also
Collapse All
C#
public interface IEcoStructuralFeature : IStructuralFeature;
Remarks

This is class Eco.UmlRt.IEcoStructuralFeature.

Inheritance Hierarchy
Eco.UmlRt.IModelElement
    Eco.UmlRt.IFeature
        Eco.UmlRt.IStructuralFeature
            Eco.UmlRt.IEcoStructuralFeature
File

UmlRt.cs

See Also
Inheritance Hierarchy


IEcoTypeSystem Interface

IEcoTypeSystem Interface
Inheritance Hierarchy See Also
Collapse All

Provides model information to the application at runtime.

C#
public interface IEcoTypeSystem : IModelElement;
Inheritance Hierarchy
Eco.UmlRt.IModelElement
    Eco.UmlRt.IEcoTypeSystem
File

UmlRt.cs

See Also
Inheritance Hierarchy


IEcoTypeSystem Methods

IEcoTypeSystem Methods
Public Methods
Collapse All

The methods of the IEcoTypeSystem class are listed here.

Public Methods
Name | Description
GetClassByType | Gets an IClass by its .NET class type.
GetClassifierByName | Gets a UML classifier by its name.
GetClassifierByType | Gets a UML classifier by its .NET class type.
GetTupleType | This is the overview for the GetTupleType method overload.


IEcoTypeSystem.GetClassByType Method

IEcoTypeSystem.GetClassByType Method
IEcoTypeSystem Interface Eco.UmlRt Namespace See Also
Collapse All

Gets an IClass by its .NET class type.

C#
IClass GetClassByType(
    System.Type t
);
Parameters
Parameters | Description
t | The .NET class type.
See Also
IEcoTypeSystem Interface
Eco.UmlRt Namespace


IEcoTypeSystem.GetClassifierByName Method

IEcoTypeSystem.GetClassifierByName Method
IEcoTypeSystem Interface Eco.UmlRt Namespace See Also
Collapse All

Gets a UML classifier by its name.

C#
IClassifier GetClassifierByName(
    string name
);
Parameters
Parameters | Description
name | The name of the UML classifier.
See Also
IEcoTypeSystem Interface
Eco.UmlRt Namespace


IEcoTypeSystem.GetClassifierByType Method

IEcoTypeSystem.GetClassifierByType Method
IEcoTypeSystem Interface Eco.UmlRt Namespace See Also
Collapse All

Gets a UML classifier by its .NET class type.

C#
IClassifier GetClassifierByType(
    System.Type t
);
Parameters
Parameters | Description
t | The .NET class type.
See Also
IEcoTypeSystem Interface
Eco.UmlRt Namespace


GetTupleType Method

GetTupleType Method

This is the overview for the GetTupleType method overload.

Overload List
Name | Description
IEcoTypeSystem.GetTupleType (IList<ClassifierNamePair>) | Returns a tupletype with an autogenerated name based on the signature
IEcoTypeSystem.GetTupleType (string, IList<ClassifierNamePair>) | Returns a tupletype with with the requested name and signature.


IEcoTypeSystem.GetTupleType Method (IList<ClassifierNamePair>)

IEcoTypeSystem.GetTupleType Method (IList<ClassifierNamePair>)
IEcoTypeSystem Interface Eco.UmlRt Namespace See Also
Collapse All

Returns a tupletype with an autogenerated name based on the signature

C#
ITupleType GetTupleType(
    IList<ClassifierNamePair> parts
);
See Also
IEcoTypeSystem Interface
Eco.UmlRt Namespace


IEcoTypeSystem.GetTupleType Method (string, IList<ClassifierNamePair>)

IEcoTypeSystem.GetTupleType Method (string, IList<ClassifierNamePair>)
IEcoTypeSystem Interface Eco.UmlRt Namespace See Also
Collapse All

Returns a tupletype with with the requested name and signature.

C#
ITupleType GetTupleType(
    string name,
    IList<ClassifierNamePair> parts
);
See Also
IEcoTypeSystem Interface
Eco.UmlRt Namespace


IEcoTypeSystem Properties

IEcoTypeSystem Properties
Public Properties
Collapse All

The properties of the IEcoTypeSystem class are listed here.

Public Properties
Name | Description
AllAssociations | A collection of all associations within the model.
AllClasses | A collection of all IClass within the model.
AllDatatypes | A collection of all modeled UML classes within the model.
AllPackages | This is AllPackages, a member of class IEcoTypeSystem.
CheckSum | Returns a checksum for the entire model
Errors | This property contains a list of critical and non-critical errors in the model.
GenerateDefaultRegions | Specifies whether or not the EcoSpace creates logical optimistic locking regions automatically when the model is first determined at runtime.
IsBrowsable | This is IsBrowsable, a member of class IEcoTypeSystem.
IsRunnable | Indicates whether or not the model is free of any critical errors which would prevent an EcoSpace from being made active.
NonRunnableReason | If the model contains critical errors this property will provide the cause of the error.
Packages | A collection of all packages used in the model.
PredefinedTypes | Provides an Eco.UmlRt.IDataType for various standard .NET value types such.
RegionDefinitions | A collection of logical regions defined in the model to aid in optimistic locking.


IEcoTypeSystem.AllAssociations Property

IEcoTypeSystem.AllAssociations Property
IEcoTypeSystem Interface Eco.UmlRt Namespace See Also
Collapse All

A collection of all associations within the model.

C#
IAssociationCollection AllAssociations;
See Also
IEcoTypeSystem Interface
Eco.UmlRt Namespace


IEcoTypeSystem.AllClasses Property

IEcoTypeSystem.AllClasses Property
IEcoTypeSystem Interface Eco.UmlRt Namespace See Also
Collapse All

A collection of all IClass within the model.

C#
IClassCollection AllClasses;
See Also
IEcoTypeSystem Interface
Eco.UmlRt Namespace


IEcoTypeSystem.AllDatatypes Property

IEcoTypeSystem.AllDatatypes Property
IEcoTypeSystem Interface Eco.UmlRt Namespace See Also
Collapse All

A collection of all modeled UML classes within the model.

C#
IClassifierCollection AllDatatypes;
See Also
IEcoTypeSystem Interface
Eco.UmlRt Namespace


IEcoTypeSystem.AllPackages Property

IEcoTypeSystem.AllPackages Property
IEcoTypeSystem Interface Eco.UmlRt Namespace See Also
Collapse All
C#
IPackageCollection AllPackages;
Remarks

This is AllPackages, a member of class IEcoTypeSystem.

See Also
IEcoTypeSystem Interface
Eco.UmlRt Namespace


IEcoTypeSystem.CheckSum Property

IEcoTypeSystem.CheckSum Property
IEcoTypeSystem Interface Eco.UmlRt Namespace See Also
Collapse All

Returns a checksum for the entire model

C#
int CheckSum;
Remarks

The checksum is calculated from all the parts of the model (classes, attributes, methods, associations) and can be used to verify that two models are the same.

One example of usage is to check the checksum in a remote persistence server to ensure that the client is using the same model version as the server.

Recompiling a model from the same model source code files should result in the same checksum. This only includes the structure (interface) of the model and not implementation details or manually added non-ECO members such as methods.

See Also
IEcoTypeSystem Interface
Eco.UmlRt Namespace


IEcoTypeSystem.Errors Property

IEcoTypeSystem.Errors Property
IEcoTypeSystem Interface Eco.UmlRt Namespace See Also
Collapse All

This property contains a list of critical and non-critical errors in the model.

C#
string Errors;
See Also
IEcoTypeSystem Interface
Eco.UmlRt Namespace


IEcoTypeSystem.GenerateDefaultRegions Property

IEcoTypeSystem.GenerateDefaultRegions Property
IEcoTypeSystem Interface Eco.UmlRt Namespace See Also
Collapse All

Specifies whether or not the EcoSpace creates logical optimistic locking regions automatically when the model is first determined at runtime.

C#
bool GenerateDefaultRegions;
See Also
IEcoTypeSystem Interface
Eco.UmlRt Namespace


IEcoTypeSystem.IsBrowsable Property

IEcoTypeSystem.IsBrowsable Property
IEcoTypeSystem Interface Eco.UmlRt Namespace See Also
Collapse All
C#
bool IsBrowsable;
Remarks

This is IsBrowsable, a member of class IEcoTypeSystem.

See Also
IEcoTypeSystem Interface
Eco.UmlRt Namespace


IEcoTypeSystem.IsRunnable Property

IEcoTypeSystem.IsRunnable Property
IEcoTypeSystem Interface Eco.UmlRt Namespace See Also
Collapse All

Indicates whether or not the model is free of any critical errors which would prevent an EcoSpace from being made active.

C#
bool IsRunnable;
See Also
IEcoTypeSystem Interface
Eco.UmlRt Namespace


IEcoTypeSystem.NonRunnableReason Property

IEcoTypeSystem.NonRunnableReason Property
IEcoTypeSystem Interface Eco.UmlRt Namespace See Also
Collapse All

If the model contains critical errors this property will provide the cause of the error.

C#
string NonRunnableReason;
See Also
IEcoTypeSystem Interface
Eco.UmlRt Namespace


IEcoTypeSystem.Packages Property

IEcoTypeSystem.Packages Property
IEcoTypeSystem Interface Eco.UmlRt Namespace See Also
Collapse All

A collection of all packages used in the model.

C#
IPackageCollection Packages;
See Also
IEcoTypeSystem Interface
Eco.UmlRt Namespace


IEcoTypeSystem.PredefinedTypes Property

IEcoTypeSystem.PredefinedTypes Property
IEcoTypeSystem Interface Eco.UmlRt Namespace See Also
Collapse All

Provides an Eco.UmlRt.IDataType for various standard .NET value types such.

C#
IEcoPredefinedTypes PredefinedTypes;
See Also
IEcoTypeSystem Interface
Eco.UmlRt Namespace


IEcoTypeSystem.RegionDefinitions Property

IEcoTypeSystem.RegionDefinitions Property
IEcoTypeSystem Interface Eco.UmlRt Namespace See Also
Collapse All

A collection of logical regions defined in the model to aid in optimistic locking.

C#
string RegionDefinitions;
See Also
IEcoTypeSystem Interface
Eco.UmlRt Namespace


IEcoVertex Interface

IEcoVertex Interface
Inheritance Hierarchy See Also
Collapse All
C#
public interface IEcoVertex : IVertex;
Remarks

This is class Eco.UmlRt.IEcoVertex.

Inheritance Hierarchy
Eco.UmlRt.IModelElement
    Eco.UmlRt.IVertex
        Eco.UmlRt.IEcoVertex
File

UmlRt.cs

See Also
Inheritance Hierarchy


IEnumerationLiteral Interface

IEnumerationLiteral Interface
Inheritance Hierarchy See Also
Collapse All

Identifies a single value of an enumeration which may be assigned to a variable of this enumeration type.

C#
public interface IEnumerationLiteral : IModelElement;
Inheritance Hierarchy
Eco.UmlRt.IModelElement
    Eco.UmlRt.IEnumerationLiteral
        Eco.UmlRt.IEcoEnumerationLiteral
File

UmlRt.cs

See Also
Inheritance Hierarchy


IEnumerationLiteral Properties

IEnumerationLiteral Properties
Public Properties
Collapse All

The properties of the IEnumerationLiteral class are listed here.

Public Properties
Name | Description
EcoEnumerationLiteral | This is EcoEnumerationLiteral, a member of class IEnumerationLiteral.
EnumValue | Holds an object reference to the actual enum value which may be assigned to variables of this enumeration type.
IntegerValue | Specifies the ordinal value of the enumeration value.


IEnumerationLiteral.EcoEnumerationLiteral Property

IEnumerationLiteral.EcoEnumerationLiteral Property
IEnumerationLiteral Interface Eco.UmlRt Namespace See Also
Collapse All
C#
IEcoEnumerationLiteral EcoEnumerationLiteral;
Remarks

This is EcoEnumerationLiteral, a member of class IEnumerationLiteral.

See Also
IEnumerationLiteral Interface
Eco.UmlRt Namespace


IEnumerationLiteral.EnumValue Property

IEnumerationLiteral.EnumValue Property
IEnumerationLiteral Interface Eco.UmlRt Namespace See Also
Collapse All

Holds an object reference to the actual enum value which may be assigned to variables of this enumeration type.

C#
object EnumValue;
See Also
IEnumerationLiteral Interface
Eco.UmlRt Namespace


IEnumerationLiteral.IntegerValue Property

IEnumerationLiteral.IntegerValue Property
IEnumerationLiteral Interface Eco.UmlRt Namespace See Also
Collapse All

Specifies the ordinal value of the enumeration value.

C#
int IntegerValue;
Remarks

If a specific value has been assigned in the source code then this value will be returned, otherwise a sequencial number starting at zero will be returned, as per the standard behavior of the .NET runtime.

See Also
IEnumerationLiteral Interface
Eco.UmlRt Namespace


IEnumerationLiteralCollection Interface

IEnumerationLiteralCollection Interface
Inheritance Hierarchy See Also
Collapse All

Holds a collection of Eco.UmlRt.IEnumerationLiteral.

C#
public interface IEnumerationLiteralCollection : ICollection;
Inheritance Hierarchy
Eco.UmlRt.IEnumerationLiteralCollection
File

UmlRt.cs

See Also
Inheritance Hierarchy


IEnumerationLiteralCollection Methods

IEnumerationLiteralCollection Methods
Public Methods
Collapse All

The methods of the IEnumerationLiteralCollection class are listed here.

Public Methods
Name | Description
this | Gets an enumeration literal by its index within the collection.


IEnumerationLiteralCollection.this Indexer

IEnumerationLiteralCollection.this Indexer
IEnumerationLiteralCollection Interface Eco.UmlRt Namespace See Also
Collapse All

Gets an enumeration literal by its index within the collection.

C#
IEnumerationLiteral this[
    int index
];
See Also
IEnumerationLiteralCollection Interface
Eco.UmlRt Namespace


IEnumerationType Interface

IEnumerationType Interface
Inheritance Hierarchy See Also
Collapse All

Identifies a model element as an enumeration type.

C#
public interface IEnumerationType : ISimpleType;
Inheritance Hierarchy
Eco.UmlRt.IModelElement
    Eco.UmlRt.IClassifier
        Eco.UmlRt.IDataType
            Eco.UmlRt.ISimpleType
                Eco.UmlRt.IEnumerationType
File

UmlRt.cs

See Also
Inheritance Hierarchy


IEnumerationType Properties

IEnumerationType Properties
Public Properties
Collapse All

The properties of the IEnumerationType class are listed here.

Public Properties
Name | Description
Literals | Contains a collection of values which may be assigned to a variable of this enumeration type.


IEnumerationType.Literals Property

IEnumerationType.Literals Property
IEnumerationType Interface Eco.UmlRt Namespace See Also
Collapse All

Contains a collection of values which may be assigned to a variable of this enumeration type.

C#
IEnumerationLiteralCollection Literals;
See Also
IEnumerationType Interface
Eco.UmlRt Namespace


IExpression Interface

IExpression Interface
Inheritance Hierarchy See Also
Collapse All

Holds modeled expression information.

C#
public interface IExpression;
Remarks

This is used in various places throughout the ECO model whenever an OCL expression is modeled, such as constraints, pre-conditions, and transition guards.

Inheritance Hierarchy
Eco.UmlRt.IExpression
File

UmlRt.cs

See Also
Inheritance Hierarchy


IExpression Properties

IExpression Properties
Public Properties
Collapse All

The properties of the IExpression class are listed here.

Public Properties
Name | Description
Body | Specifies the body of the expression.
Language | Identifies the language used to define the expression.


IExpression.Body Property

IExpression.Body Property
IExpression Interface Eco.UmlRt Namespace See Also
Collapse All

Specifies the body of the expression.

C#
string Body;
See Also
IExpression Interface
Eco.UmlRt Namespace


IExpression.Language Property

IExpression.Language Property
IExpression Interface Eco.UmlRt Namespace See Also
Collapse All

Identifies the language used to define the expression.

C#
string Language;
Remarks

This will currently always return "OCL".

See Also
IExpression Interface
Eco.UmlRt Namespace


IFeature Interface

IFeature Interface
Inheritance Hierarchy See Also
Collapse All

This is the base interface used to represent all features of a modeled UML class.

C#
public interface IFeature : IModelElement;
Inheritance Hierarchy
Eco.UmlRt.IModelElement
    Eco.UmlRt.IFeature
        Eco.UmlRt.IEcoFeature
        Eco.UmlRt.IMethod
        Eco.UmlRt.IStructuralFeature
File

UmlRt.cs

See Also
Inheritance Hierarchy


IFeature Properties

IFeature Properties
Public Properties
Collapse All

The properties of the IFeature class are listed here.

Public Properties
Name | Description
EcoFeature | This is EcoFeature, a member of class IFeature.
FeatureType | Identifies what type of feature this is.
Id | Contains an ID for the feature that is unique for the owning UML class.
Owner | Holds a reference to the modeled UML class that owns the feature.
OwnerScope | Indicates whether this is a class or instance feature.
Visibility | Indicates the encapsulation visibility of the feature.


IFeature.EcoFeature Property

IFeature.EcoFeature Property
IFeature Interface Eco.UmlRt Namespace See Also
Collapse All
C#
IEcoFeature EcoFeature;
Remarks

This is EcoFeature, a member of class IFeature.

See Also
IFeature Interface
Eco.UmlRt Namespace


IFeature.FeatureType Property

IFeature.FeatureType Property
IFeature Interface Eco.UmlRt Namespace See Also
Collapse All

Identifies what type of feature this is.

C#
FeatureType FeatureType;
See Also
IFeature Interface
Eco.UmlRt Namespace


IFeature.Id Property

IFeature.Id Property
IFeature Interface Eco.UmlRt Namespace See Also
Collapse All

Contains an ID for the feature that is unique for the owning UML class.

C#
string Id;
See Also
IFeature Interface
Eco.UmlRt Namespace


IFeature.Owner Property

IFeature.Owner Property
IFeature Interface Eco.UmlRt Namespace See Also
Collapse All

Holds a reference to the modeled UML class that owns the feature.

C#
IClassifier Owner;
See Also
IFeature Interface
Eco.UmlRt Namespace


IFeature.OwnerScope Property

IFeature.OwnerScope Property
IFeature Interface Eco.UmlRt Namespace See Also
Collapse All

Indicates whether this is a class or instance feature.

C#
ScopeKind OwnerScope;
See Also
IFeature Interface
Eco.UmlRt Namespace


IFeature.Visibility Property

IFeature.Visibility Property
IFeature Interface Eco.UmlRt Namespace See Also
Collapse All

Indicates the encapsulation visibility of the feature.

C#
VisibilityKind Visibility;
See Also
IFeature Interface
Eco.UmlRt Namespace


IFeatureCollection Interface

IFeatureCollection Interface
Inheritance Hierarchy See Also
Collapse All

Holds a collection of Eco.UmlRt.IFeature.

C#
public interface IFeatureCollection : ICollection;
Inheritance Hierarchy
Eco.UmlRt.IFeatureCollection
File

UmlRt.cs

See Also
Inheritance Hierarchy


IFeatureCollection Methods

IFeatureCollection Methods
Public Methods
Collapse All

The methods of the IFeatureCollection class are listed here.

Public Methods
Name | Description
GetItemByName | Gets a feature by its name.
this | Gets a feature by its index within the collection.


IFeatureCollection.GetItemByName Method

IFeatureCollection.GetItemByName Method
IFeatureCollection Interface Eco.UmlRt Namespace See Also
Collapse All

Gets a feature by its name.

C#
IFeature GetItemByName(
    string name
);
Parameters
Parameters | Description
name | The name of the feature.
See Also
IFeatureCollection Interface
Eco.UmlRt Namespace


IFeatureCollection.this Indexer

IFeatureCollection.this Indexer
IFeatureCollection Interface Eco.UmlRt Namespace See Also
Collapse All

Gets a feature by its index within the collection.

C#
IFeature this[
    int index
];
See Also
IFeatureCollection Interface
Eco.UmlRt Namespace


IFeaturedType Interface

IFeaturedType Interface
Inheritance Hierarchy See Also
Collapse All
C#
public interface IFeaturedType;
Remarks

This is class Eco.UmlRt.IFeaturedType.

Inheritance Hierarchy
Eco.UmlRt.IFeaturedType
    Eco.UmlRt.IClass
    Eco.UmlRt.ITupleType
File

UmlRt.cs

See Also
Inheritance Hierarchy


IFeaturedType Properties

IFeaturedType Properties
Public Properties
Collapse All

The properties of the IFeaturedType class are listed here.

Public Properties
Name | Description
AllStructuralFeatures | A collection containing a combination of all features defined for the type.
Properties | A PropertyDescriptorCollection suitable e.g. for implementing ICustomTypeDescriptor. Mostly for internal use.


IFeaturedType.AllStructuralFeatures Property

IFeaturedType.AllStructuralFeatures Property
IFeaturedType Interface Eco.UmlRt Namespace See Also
Collapse All

A collection containing a combination of all features defined for the type.

C#
IStructuralFeatureCollection AllStructuralFeatures;
See Also
IFeaturedType Interface
Eco.UmlRt Namespace


IFeaturedType.Properties Property

IFeaturedType.Properties Property
IFeaturedType Interface Eco.UmlRt Namespace See Also
Collapse All

A PropertyDescriptorCollection suitable e.g. for implementing ICustomTypeDescriptor. Mostly for internal use.

C#
PropertyDescriptorCollection Properties;
See Also
IFeaturedType Interface
Eco.UmlRt Namespace


IFinalState Interface

IFinalState Interface
Inheritance Hierarchy See Also
Collapse All

Represents a final state within a modeled state machine.

C#
public interface IFinalState : IState;
Inheritance Hierarchy
Eco.UmlRt.IModelElement
    Eco.UmlRt.IVertex
    Eco.UmlRt.IRegionContainer
        Eco.UmlRt.IState
            Eco.UmlRt.IFinalState
File

UmlRt.cs

See Also
Inheritance Hierarchy


IMethod Interface

IMethod Interface
Inheritance Hierarchy See Also
Collapse All

Contains model information about a method added to the model at design time.

C#
public interface IMethod : IFeature;
Inheritance Hierarchy
Eco.UmlRt.IModelElement
    Eco.UmlRt.IFeature
        Eco.UmlRt.IMethod
            Eco.UmlRt.IEcoMethod
File

UmlRt.cs

See Also
Inheritance Hierarchy


IMethod Properties

IMethod Properties
Public Properties
Collapse All

The properties of the IMethod class are listed here.

Public Properties
Name | Description
EcoMethod | This is EcoMethod, a member of class IMethod.
Implementation | If the current method is implemented using the Action OCL language this property will contain information about the implementation.
IsEcoCallable | Indicates whether or not the method is callable from within ECO itself.
IsImplementedAsActivity | Indicates whether or not the current method is implemented using the Action OCL language.
IsQuery | Indicates whether or not the current method has been marked as a Query method.
IsTrigger | Specifies whether or not the method is used to trigger a state transition on the modeled UML class's state machine.
MethodInfo | Holds reflection information about the method on the generated .NET class.
Parameters | Holds a collection of parameters this method expects.
Precondition | The modeled pre-condition for the current method.
ReturnType | Identifies the return type of the method.
Triggers | Holds a collection of triggers that this method should invoke when executed.


IMethod.EcoMethod Property

IMethod.EcoMethod Property
IMethod Interface Eco.UmlRt Namespace See Also
Collapse All
C#
IEcoMethod EcoMethod;
Remarks

This is EcoMethod, a member of class IMethod.

See Also
IMethod Interface
Eco.UmlRt Namespace


IMethod.Implementation Property

IMethod.Implementation Property
IMethod Interface Eco.UmlRt Namespace See Also
Collapse All

If the current method is implemented using the Action OCL language this property will contain information about the implementation.

C#
IActivity Implementation;
See Also
IMethod Interface
Eco.UmlRt Namespace


IMethod.IsEcoCallable Property

IMethod.IsEcoCallable Property
IMethod Interface Eco.UmlRt Namespace See Also
Collapse All

Indicates whether or not the method is callable from within ECO itself.

C#
Boolean IsEcoCallable;
Remarks

If a method has a parameter or return type that is not compatible with the EcoSpace cache (such as value types, ECO objects, and lists of ECO objects) then this property will return False.

See Also
IMethod Interface
Eco.UmlRt Namespace


IMethod.IsImplementedAsActivity Property

IMethod.IsImplementedAsActivity Property
IMethod Interface Eco.UmlRt Namespace See Also
Collapse All

Indicates whether or not the current method is implemented using the Action OCL language.

C#
Boolean IsImplementedAsActivity;
Remarks

If False then executing this method from within the Action OCL language will invoke the .NET method, otherwise the Action OCL assigned to the method in the model will be executed.

See Also
IMethod Interface
Eco.UmlRt Namespace


IMethod.IsQuery Property

IMethod.IsQuery Property
IMethod Interface Eco.UmlRt Namespace See Also
Collapse All

Indicates whether or not the current method has been marked as a Query method.

C#
Boolean IsQuery;
Remarks

If True then the current method has been identified by the developer as one with no side affects, meaning that no data within the EcoSpace cache will be modified. A method marked as a query is available in OCL.

See Also
IMethod Interface
Eco.UmlRt Namespace


IMethod.IsTrigger Property

IMethod.IsTrigger Property
IMethod Interface Eco.UmlRt Namespace See Also
Collapse All

Specifies whether or not the method is used to trigger a state transition on the modeled UML class's state machine.

C#
Boolean IsTrigger;
See Also
IMethod Interface
Eco.UmlRt Namespace


IMethod.MethodInfo Property

IMethod.MethodInfo Property
IMethod Interface Eco.UmlRt Namespace See Also
Collapse All

Holds reflection information about the method on the generated .NET class.

C#
MethodInfo MethodInfo;
See Also
IMethod Interface
Eco.UmlRt Namespace


IMethod.Parameters Property

IMethod.Parameters Property
IMethod Interface Eco.UmlRt Namespace See Also
Collapse All

Holds a collection of parameters this method expects.

C#
IParameterCollection Parameters;
See Also
IMethod Interface
Eco.UmlRt Namespace


IMethod.Precondition Property

IMethod.Precondition Property
IMethod Interface Eco.UmlRt Namespace See Also
Collapse All

The modeled pre-condition for the current method.

C#
IExpression Precondition;
Remarks

Contains the OCL pre-condition expression that may be evaluated before deciding whether or not to execute this method. The expression should return a boolean result. The method pre-condition is used to evaluate the result of the OCL query

Copy Code
"self.MethodName?"

When the method is also a trigger a list of transitions will be retrieved from each of the modeled UML class's state machines, a transition will then only be considered to be possible if the transition's guard expression and the method's precondition evaluate to True.

See Also
IMethod Interface
Eco.UmlRt Namespace


IMethod.ReturnType Property

IMethod.ReturnType Property
IMethod Interface Eco.UmlRt Namespace See Also
Collapse All

Identifies the return type of the method.

C#
IClassifier ReturnType;
See Also
IMethod Interface
Eco.UmlRt Namespace


IMethod.Triggers Property

IMethod.Triggers Property
IMethod Interface Eco.UmlRt Namespace See Also
Collapse All

Holds a collection of triggers that this method should invoke when executed.

C#
ITriggerCollection Triggers;
Remarks

A modeled UML class may contain multiple state machines, therefore the same method may act as a trigger in more than one of these state machines. One trigger will exist in this collection for each.

See Also
IMethod Interface
Eco.UmlRt Namespace


IMethodCollection Interface

IMethodCollection Interface
Inheritance Hierarchy See Also
Collapse All

Holds a collection of Eco.UmlRt.IMethod.

C#
public interface IMethodCollection : ICollection;
Inheritance Hierarchy
Eco.UmlRt.IMethodCollection
File

UmlRt.cs

See Also
Inheritance Hierarchy


IMethodCollection Methods

IMethodCollection Methods
Public Methods
Collapse All

The methods of the IMethodCollection class are listed here.

Public Methods
Name | Description
GetItemByName | Gets a UML method by its name.
this | Gets a UML method by its index within the collection.


IMethodCollection.GetItemByName Method

IMethodCollection.GetItemByName Method
IMethodCollection Interface Eco.UmlRt Namespace See Also
Collapse All

Gets a UML method by its name.

C#
IMethod GetItemByName(
    string name
);
Parameters
Parameters | Description
name | The name of the method.
See Also
IMethodCollection Interface
Eco.UmlRt Namespace


IMethodCollection.this Indexer

IMethodCollection.this Indexer
IMethodCollection Interface Eco.UmlRt Namespace See Also
Collapse All

Gets a UML method by its index within the collection.

C#
IMethod this[
    int index
];
See Also
IMethodCollection Interface
Eco.UmlRt Namespace


IMethodTrigger Interface

IMethodTrigger Interface
Inheritance Hierarchy See Also
Collapse All

Represents a trigger within a modeled state machine that is invoked via a method call.

C#
public interface IMethodTrigger : ITrigger;
Inheritance Hierarchy
Eco.UmlRt.ITrigger
    Eco.UmlRt.IMethodTrigger
File

UmlRt.cs

See Also
Inheritance Hierarchy


IMethodTrigger Properties

IMethodTrigger Properties
Public Properties
Collapse All

The properties of the IMethodTrigger class are listed here.

Public Properties
Name | Description
Method | Holds a reference to the modeled information of the method that invokes this trigger.


IMethodTrigger.Method Property

IMethodTrigger.Method Property
IMethodTrigger Interface Eco.UmlRt Namespace See Also
Collapse All

Holds a reference to the modeled information of the method that invokes this trigger.

C#
IMethod Method;
See Also
IMethodTrigger Interface
Eco.UmlRt Namespace


IModelElement Interface

IModelElement Interface
Inheritance Hierarchy See Also
Collapse All

The IModelElement is the base interface for all interface types used to represent parts of the business model, such as packages, classes, methods, etc.

C#
public interface IModelElement;
Inheritance Hierarchy
Eco.UmlRt.IModelElement
    Eco.UmlRt.IAssociation
    Eco.UmlRt.IClassifier
    Eco.UmlRt.IConstraint
    Eco.UmlRt.IEcoTypeSystem
    Eco.UmlRt.IEnumerationLiteral
    Eco.UmlRt.IFeature
    Eco.UmlRt.IPackage
    Eco.UmlRt.IParameter
    Eco.UmlRt.IRegion
    Eco.UmlRt.IStateMachine
    Eco.UmlRt.IStereotype
    Eco.UmlRt.IVertex
File

UmlRt.cs

See Also
Inheritance Hierarchy


IModelElement Methods

IModelElement Methods
Public Methods
Collapse All

The methods of the IModelElement class are listed here.

Public Methods
Name | Description
GetIsSameHashCode | Returns the hash code for this element.
IsSame | Compares two elements for equality.


IModelElement.GetIsSameHashCode Method

IModelElement.GetIsSameHashCode Method
IModelElement Interface Eco.UmlRt Namespace See Also
Collapse All

Returns the hash code for this element.

C#
int GetIsSameHashCode();
See Also
IModelElement Interface
Eco.UmlRt Namespace


IModelElement.IsSame Method

IModelElement.IsSame Method
IModelElement Interface Eco.UmlRt Namespace See Also
Collapse All

Compares two elements for equality.

C#
Boolean IsSame(
    IModelElement value
);
Parameters
Parameters | Description
value | The element to compare with.
See Also
IModelElement Interface
Eco.UmlRt Namespace


IModelElement Properties

IModelElement Properties
Public Properties
Collapse All

The properties of the IModelElement class are listed here.

Public Properties
Name | Description
Constraints | A collection of modeled constraints for this element.
Name | The name of the element.
Package | The package to which this element belongs.
TaggedValues | A collection of modeled tagged values for this element.


IModelElement.Constraints Property

IModelElement.Constraints Property
IModelElement Interface Eco.UmlRt Namespace See Also
Collapse All

A collection of modeled constraints for this element.

C#
IConstraintCollection Constraints;
See Also
IModelElement Interface
Eco.UmlRt Namespace


IModelElement.Name Property

IModelElement.Name Property
IModelElement Interface Eco.UmlRt Namespace See Also
Collapse All

The name of the element.

C#
String Name;
See Also
IModelElement Interface
Eco.UmlRt Namespace


IModelElement.Package Property

IModelElement.Package Property
IModelElement Interface Eco.UmlRt Namespace See Also
Collapse All

The package to which this element belongs.

C#
IPackage Package;
See Also
IModelElement Interface
Eco.UmlRt Namespace


IModelElement.TaggedValues Property

IModelElement.TaggedValues Property
IModelElement Interface Eco.UmlRt Namespace See Also
Collapse All

A collection of modeled tagged values for this element.

C#
ITaggedValueCollection TaggedValues;
See Also
IModelElement Interface
Eco.UmlRt Namespace


IModelElementCollection Interface

IModelElementCollection Interface
Inheritance Hierarchy See Also
Collapse All

Holds a collection of Eco.UmlRt.IModelElement.

C#
public interface IModelElementCollection : ICollection;
Inheritance Hierarchy
Eco.UmlRt.IModelElementCollection
File

UmlRt.cs

See Also
Inheritance Hierarchy


IModelElementCollection Methods

IModelElementCollection Methods
Public Methods
Collapse All

The methods of the IModelElementCollection class are listed here.

Public Methods
Name | Description
Contains | Returns true or false depending on whether or not the collection contains a specific model element.
GetItemByName | Gets a model element by its name.
this | Gets a model element by its index within the collection.


IModelElementCollection.Contains Method

IModelElementCollection.Contains Method
IModelElementCollection Interface Eco.UmlRt Namespace See Also
Collapse All

Returns true or false depending on whether or not the collection contains a specific model element.

C#
bool Contains(
    IModelElement value
);
Returns

True if the collection contains the model element, otherwise returns false.

See Also
IModelElementCollection Interface
Eco.UmlRt Namespace


IModelElementCollection.GetItemByName Method

IModelElementCollection.GetItemByName Method
IModelElementCollection Interface Eco.UmlRt Namespace See Also
Collapse All

Gets a model element by its name.

C#
IModelElement GetItemByName(
    string name
);
Parameters
Parameters | Description
name | The name of the model element to find.
See Also
IModelElementCollection Interface
Eco.UmlRt Namespace


IModelElementCollection.this Indexer

IModelElementCollection.this Indexer
IModelElementCollection Interface Eco.UmlRt Namespace See Also
Collapse All

Gets a model element by its index within the collection.

C#
IModelElement this[
    int index
];
See Also
IModelElementCollection Interface
Eco.UmlRt Namespace


IMultiplicity Interface

IMultiplicity Interface
Inheritance Hierarchy See Also
Collapse All

Contains model information about the multiplicity of an association end.

C#
public interface IMultiplicity;
Inheritance Hierarchy
Eco.UmlRt.IMultiplicity
File

UmlRt.cs

See Also
Inheritance Hierarchy


IMultiplicity Properties

IMultiplicity Properties
Public Properties
Collapse All

The properties of the IMultiplicity class are listed here.

Public Properties
Name | Description
IsSingle | Indicates whether or not the association end may contain only a single object instance, this will be true if Upper is 1.
IsUnbounded | Indicates whether or not an association allows unlimited items.
Lower | Indicates the minimum number of objects that must be assigned to the association end in order for it to be considered to be valid.
Upper | Indicates the maximum number of objects that may be assigned to the association end in order for it to be considered to be valid.


IMultiplicity.IsSingle Property

IMultiplicity.IsSingle Property
IMultiplicity Interface Eco.UmlRt Namespace See Also
Collapse All

Indicates whether or not the association end may contain only a single object instance, this will be true if Upper is 1.

C#
bool IsSingle;
See Also
IMultiplicity Interface
Eco.UmlRt Namespace


IMultiplicity.IsUnbounded Property

IMultiplicity.IsUnbounded Property
IMultiplicity Interface Eco.UmlRt Namespace See Also
Collapse All

Indicates whether or not an association allows unlimited items.

C#
bool IsUnbounded;
Remarks

If the Upper bound is modeled as "*" then the association end is considered to be unbounded, meaning that it accepts multiple object instances with no explicit limit on the total number referenced.

See Also
IMultiplicity Interface
Eco.UmlRt Namespace


IMultiplicity.Lower Property

IMultiplicity.Lower Property
IMultiplicity Interface Eco.UmlRt Namespace See Also
Collapse All

Indicates the minimum number of objects that must be assigned to the association end in order for it to be considered to be valid.

C#
int Lower;
See Also
IMultiplicity Interface
Eco.UmlRt Namespace


IMultiplicity.Upper Property

IMultiplicity.Upper Property
IMultiplicity Interface Eco.UmlRt Namespace See Also
Collapse All

Indicates the maximum number of objects that may be assigned to the association end in order for it to be considered to be valid.

C#
int Upper;
Remarks

Additionally, if the upper multiplicity is greater than 1 then a property representing a collection of object instances will be generated, whereas a multiplicity of 1 will result in a property representing a single object instance will be generated.

See Also
IMultiplicity Interface
Eco.UmlRt Namespace


IOrderedSetType Interface

IOrderedSetType Interface
Inheritance Hierarchy See Also
Collapse All

A collection where elements may be added only once.

C#
public interface IOrderedSetType : ICollectionType;
Remarks

Additionally this collection indicates that if persisted the order of the elements must be maintained.

Inheritance Hierarchy
Eco.UmlRt.IModelElement
    Eco.UmlRt.IClassifier
        Eco.UmlRt.IDataType
            Eco.UmlRt.ICollectionType
                Eco.UmlRt.IOrderedSetType
File

UmlRt.cs

See Also
Inheritance Hierarchy


IPackage Interface

IPackage Interface
Inheritance Hierarchy See Also
Collapse All

Contains information about a package in the model.

C#
public interface IPackage : IModelElement;
Inheritance Hierarchy
Eco.UmlRt.IModelElement
    Eco.UmlRt.IPackage
        Eco.UmlRt.IEcoPackage
File

UmlRt.cs

See Also
Inheritance Hierarchy


IPackage Properties

IPackage Properties
Public Properties
Collapse All

The properties of the IPackage class are listed here.

Public Properties
Name | Description
Associations | Contains a collection of associations belonging to the package.
Classes | Contains a collection of modeled UML classes.
EcoPackage | This is EcoPackage, a member of class IPackage.
Id | Contains a unique ID for the package.
OwnedElements | Contains a list of all elements in the model including modeled UML classes and primitive data types.
Packages | Contains a list of packages on which this package is dependant. A dependency is formed when a modeled UML class within the package refers to a modeled UMl class within another package. A reference could be an association or generalization (inheritance).


IPackage.Associations Property

IPackage.Associations Property
IPackage Interface Eco.UmlRt Namespace See Also
Collapse All

Contains a collection of associations belonging to the package.

C#
IAssociationCollection Associations;
See Also
IPackage Interface
Eco.UmlRt Namespace


IPackage.Classes Property

IPackage.Classes Property
IPackage Interface Eco.UmlRt Namespace See Also
Collapse All

Contains a collection of modeled UML classes.

C#
IClassCollection Classes;
See Also
IPackage Interface
Eco.UmlRt Namespace


IPackage.EcoPackage Property

IPackage.EcoPackage Property
IPackage Interface Eco.UmlRt Namespace See Also
Collapse All
C#
IEcoPackage EcoPackage;
Remarks

This is EcoPackage, a member of class IPackage.

See Also
IPackage Interface
Eco.UmlRt Namespace


IPackage.Id Property

IPackage.Id Property
IPackage Interface Eco.UmlRt Namespace See Also
Collapse All

Contains a unique ID for the package.

C#
string Id;
See Also
IPackage Interface
Eco.UmlRt Namespace


IPackage.OwnedElements Property

IPackage.OwnedElements Property
IPackage Interface Eco.UmlRt Namespace See Also
Collapse All

Contains a list of all elements in the model including modeled UML classes and primitive data types.

C#
IModelElementCollection OwnedElements;
See Also
IPackage Interface
Eco.UmlRt Namespace


IPackage.Packages Property

IPackage.Packages Property
IPackage Interface Eco.UmlRt Namespace See Also
Collapse All

Contains a list of packages on which this package is dependant. A dependency is formed when a modeled UML class within the package refers to a modeled UMl class within another package. A reference could be an association or generalization (inheritance).

C#
IPackageCollection Packages;
See Also
IPackage Interface
Eco.UmlRt Namespace


IPackageCollection Interface

IPackageCollection Interface
Inheritance Hierarchy See Also
Collapse All

Holds a collection of Eco.UmlRt.IPackage.

C#
public interface IPackageCollection : ICollection;
Inheritance Hierarchy
Eco.UmlRt.IPackageCollection
File

UmlRt.cs

See Also
Inheritance Hierarchy


IPackageCollection Methods

IPackageCollection Methods
Public Methods
Collapse All

The methods of the IPackageCollection class are listed here.

Public Methods
Name | Description
GetItemByName | Gets a package by its name.
this | Gets a package by its index within the collection.


IPackageCollection.GetItemByName Method

IPackageCollection.GetItemByName Method
IPackageCollection Interface Eco.UmlRt Namespace See Also
Collapse All

Gets a package by its name.

C#
IPackage GetItemByName(
    string name
);
Parameters
Parameters | Description
name | The name of the package.
See Also
IPackageCollection Interface
Eco.UmlRt Namespace


IPackageCollection.this Indexer

IPackageCollection.this Indexer
IPackageCollection Interface Eco.UmlRt Namespace See Also
Collapse All

Gets a package by its index within the collection.

C#
IPackage this[
    int index
];
See Also
IPackageCollection Interface
Eco.UmlRt Namespace


IParameter Interface

IParameter Interface
Inheritance Hierarchy See Also
Collapse All

Contains information about a parameter of a modeled method.

C#
public interface IParameter : IModelElement;
Inheritance Hierarchy
Eco.UmlRt.IModelElement
    Eco.UmlRt.IParameter
File

UmlRt.cs

See Also
Inheritance Hierarchy


IParameter Properties

IParameter Properties
Public Properties
Collapse All

The properties of the IParameter class are listed here.

Public Properties
Name | Description
Kind | Specifies the direction of the parameter.
Type | Identifies the data type of the parameter.


IParameter.Kind Property

IParameter.Kind Property
IParameter Interface Eco.UmlRt Namespace See Also
Collapse All

Specifies the direction of the parameter.

C#
ParameterDirectionKind Kind;
See Also
IParameter Interface
Eco.UmlRt Namespace


IParameter.Type Property

IParameter.Type Property
IParameter Interface Eco.UmlRt Namespace Related Topics See Also
Collapse All

Identifies the data type of the parameter.

C#
IClassifier Type;
Related Topics

IClass, IDataType

See Also
IParameter Interface
Eco.UmlRt Namespace
Related Topics


IParameterCollection Interface

IParameterCollection Interface
Inheritance Hierarchy See Also
Collapse All

Hold a collection of Eco.UmlRt.IParameter.

C#
public interface IParameterCollection : ICollection;
Inheritance Hierarchy
Eco.UmlRt.IParameterCollection
File

UmlRt.cs

See Also
Inheritance Hierarchy


IParameterCollection Methods

IParameterCollection Methods
Public Methods
Collapse All

The methods of the IParameterCollection class are listed here.

Public Methods
Name | Description
GetItemByName | Gets a parameter by its name.
this | Gets a parameter by its index within the collection.


IParameterCollection.GetItemByName Method

IParameterCollection.GetItemByName Method
IParameterCollection Interface Eco.UmlRt Namespace See Also
Collapse All

Gets a parameter by its name.

C#
IParameter GetItemByName(
    string name
);
Parameters
Parameters | Description
name | The name of the parameter.
See Also
IParameterCollection Interface
Eco.UmlRt Namespace


IParameterCollection.this Indexer

IParameterCollection.this Indexer
IParameterCollection Interface Eco.UmlRt Namespace See Also
Collapse All

Gets a parameter by its index within the collection.

C#
IParameter this[
    int index
];
See Also
IParameterCollection Interface
Eco.UmlRt Namespace


IPrimitiveType Interface

IPrimitiveType Interface
Inheritance Hierarchy See Also
Collapse All

Identifies a model element as a primitive type, capable of holding primitive .NET values (value types) such as integers, decimals, etc.

C#
public interface IPrimitiveType : ISimpleType;
Inheritance Hierarchy
Eco.UmlRt.IModelElement
    Eco.UmlRt.IClassifier
        Eco.UmlRt.IDataType
            Eco.UmlRt.ISimpleType
                Eco.UmlRt.IPrimitiveType
                    Eco.UmlRt.IEcoPrimitiveType
File

UmlRt.cs

See Also
Inheritance Hierarchy


IPrimitiveType Methods

IPrimitiveType Methods
Public Methods
Collapse All

The methods of the IPrimitiveType class are listed here.

Public Methods
Name | Description
AssignConvertAsObject | Provides a way of parsing a string value into an object of the specified data type.


IPrimitiveType.AssignConvertAsObject Method

IPrimitiveType.AssignConvertAsObject Method
IPrimitiveType Interface Eco.UmlRt Namespace Related Topics See Also
Collapse All

Provides a way of parsing a string value into an object of the specified data type.

C#
System.Object AssignConvertAsObject(
    object value,
    IClassifier toType
);
Parameters
Parameters | Description
value | The string value to convert.
toType | An IClassifier that represents the type of .NET object to create.
Related Topics

Eco.UmlRt.IEcoTypeSystem.GetClassifierByType, Eco.Services.ITypeSystemService.TypeSystem

See Also
IPrimitiveType Interface
Eco.UmlRt Namespace
Related Topics


IPrimitiveType Properties

IPrimitiveType Properties
Public Properties
Collapse All

The properties of the IPrimitiveType class are listed here.

Public Properties
Name | Description
EcoPrimitiveType | This is EcoPrimitiveType, a member of class IPrimitiveType.


IPrimitiveType.EcoPrimitiveType Property

IPrimitiveType.EcoPrimitiveType Property
IPrimitiveType Interface Eco.UmlRt Namespace See Also
Collapse All
C#
IEcoPrimitiveType EcoPrimitiveType;
Remarks

This is EcoPrimitiveType, a member of class IPrimitiveType.

See Also
IPrimitiveType Interface
Eco.UmlRt Namespace


IPseudostate Interface

IPseudostate Interface
Inheritance Hierarchy See Also
Collapse All

Contains model information about a pseudo state (which is a type of vertex) in a state machine.

C#
public interface IPseudostate : IVertex;
Inheritance Hierarchy
Eco.UmlRt.IModelElement
    Eco.UmlRt.IVertex
        Eco.UmlRt.IPseudostate
File

UmlRt.cs

See Also
Inheritance Hierarchy


IPseudostate Properties

IPseudostate Properties
Public Properties
Collapse All

The properties of the IPseudostate class are listed here.

Public Properties
Name | Description
Kind | Identifies the type of pseudo state.


IPseudostate.Kind Property

IPseudostate.Kind Property
IPseudostate Interface Eco.UmlRt Namespace See Also
Collapse All

Identifies the type of pseudo state.

C#
PseudostateKind Kind;
See Also
IPseudostate Interface
Eco.UmlRt Namespace


IRegion Interface

IRegion Interface
Inheritance Hierarchy See Also
Collapse All

Contains model information about a region within a state machine.

C#
public interface IRegion : IModelElement;
Remarks

Regions are used to define sub-state machines within states.

Inheritance Hierarchy
Eco.UmlRt.IModelElement
    Eco.UmlRt.IRegion
        Eco.UmlRt.IEcoRegion
File

UmlRt.cs

See Also
Inheritance Hierarchy


IRegion Properties

IRegion Properties
Public Properties
Collapse All

The properties of the IRegion class are listed here.

Public Properties
Name | Description
AllStates | A collection of all states owned by this region.
Container | Holds a reference to the container that owns this region.
EcoRegion | This is EcoRegion, a member of class IRegion.
FullStatemachineName | Returns the fully qualified name of this region.
InitialState | Holds a reference to the initial state of the region.
IsTopLevel | Returns True if the region is owned directly by the state machine, otherwise returns False.
StateAttribute | Identifies which UML attribute, if any, is used to store the state for this region.
StateMachine | This is StateMachine, a member of class IRegion.
States | Contains a collection of states within the region, accessible by name.
Transitions | Holds a collection of transitions in the region.
Vertexes | Holds a collection of vertexes (states) in the region.


IRegion.AllStates Property

IRegion.AllStates Property
IRegion Interface Eco.UmlRt Namespace See Also
Collapse All

A collection of all states owned by this region.

C#
IStateCollection AllStates;
Remarks

This includes states owned directly by this region and all states within its owned regions (recursively).

See Also
IRegion Interface
Eco.UmlRt Namespace


IRegion.Container Property

IRegion.Container Property
IRegion Interface Eco.UmlRt Namespace See Also
Collapse All

Holds a reference to the container that owns this region.

C#
IRegionContainer Container;
See Also
IRegion Interface
Eco.UmlRt Namespace


IRegion.EcoRegion Property

IRegion.EcoRegion Property
IRegion Interface Eco.UmlRt Namespace See Also
Collapse All
C#
IEcoRegion EcoRegion;
Remarks

This is EcoRegion, a member of class IRegion.

See Also
IRegion Interface
Eco.UmlRt Namespace


IRegion.FullStatemachineName Property

IRegion.FullStatemachineName Property
IRegion Interface Eco.UmlRt Namespace See Also
Collapse All

Returns the fully qualified name of this region.

C#
string FullStatemachineName;
Remarks

This includes names of any parent regions, parents of those regions, etc.

See Also
IRegion Interface
Eco.UmlRt Namespace


IRegion.InitialState Property

IRegion.InitialState Property
IRegion Interface Eco.UmlRt Namespace See Also
Collapse All

Holds a reference to the initial state of the region.

C#
IPseudostate InitialState;
Remarks

The initial state is the default point of entry for a region or state machine.

See Also
IRegion Interface
Eco.UmlRt Namespace


IRegion.IsTopLevel Property

IRegion.IsTopLevel Property
IRegion Interface Eco.UmlRt Namespace See Also
Collapse All

Returns True if the region is owned directly by the state machine, otherwise returns False.

C#
bool IsTopLevel;
See Also
IRegion Interface
Eco.UmlRt Namespace


IRegion.StateAttribute Property

IRegion.StateAttribute Property
IRegion Interface Eco.UmlRt Namespace See Also
Collapse All

Identifies which UML attribute, if any, is used to store the state for this region.

C#
IAttribute StateAttribute;
Remarks

It is only mandatory to define a state attribute for a region when there is more than one region within a state (an orthogonal state).

See Also
IRegion Interface
Eco.UmlRt Namespace


IRegion.StateMachine Property

IRegion.StateMachine Property
IRegion Interface Eco.UmlRt Namespace See Also
Collapse All
C#
IStateMachine StateMachine;
Remarks

This is StateMachine, a member of class IRegion.

See Also
IRegion Interface
Eco.UmlRt Namespace


IRegion.States Property

IRegion.States Property
IRegion Interface Eco.UmlRt Namespace See Also
Collapse All

Contains a collection of states within the region, accessible by name.

C#
IStateNamedCollection States;
See Also
IRegion Interface
Eco.UmlRt Namespace


IRegion.Transitions Property

IRegion.Transitions Property
IRegion Interface Eco.UmlRt Namespace See Also
Collapse All

Holds a collection of transitions in the region.

C#
ITransitionCollection Transitions;
See Also
IRegion Interface
Eco.UmlRt Namespace


IRegion.Vertexes Property

IRegion.Vertexes Property
IRegion Interface Eco.UmlRt Namespace See Also
Collapse All

Holds a collection of vertexes (states) in the region.

C#
IVertexCollection Vertexes;
See Also
IRegion Interface
Eco.UmlRt Namespace


IRegionCollection Interface

IRegionCollection Interface
Inheritance Hierarchy See Also
Collapse All

Holds a collection of state machine regions.

C#
public interface IRegionCollection : ICollection;
Inheritance Hierarchy
Eco.UmlRt.IRegionCollection
File

UmlRt.cs

See Also
Inheritance Hierarchy


IRegionCollection Methods

IRegionCollection Methods
Public Methods
Collapse All

The methods of the IRegionCollection class are listed here.

Public Methods
Name | Description
GetItemByName | Gets a region by its name.
this | Gets a region by its index within the collection.


IRegionCollection.GetItemByName Method

IRegionCollection.GetItemByName Method
IRegionCollection Interface Eco.UmlRt Namespace See Also
Collapse All

Gets a region by its name.

C#
IRegion GetItemByName(
    string name
);
Parameters
Parameters | Description
name | The name of the region to return.
Remarks

The name of the region must be unique within the collection.

See Also
IRegionCollection Interface
Eco.UmlRt Namespace


IRegionCollection.this Indexer

IRegionCollection.this Indexer
IRegionCollection Interface Eco.UmlRt Namespace See Also
Collapse All

Gets a region by its index within the collection.

C#
IRegion this[
    int index
];
Parameters
Parameters | Description
index | The index of the transition.
See Also
IRegionCollection Interface
Eco.UmlRt Namespace


IRegionContainer Interface

IRegionContainer Interface
Inheritance Hierarchy Related Topics See Also
Collapse All

Identifies a state machine element as being able to contain a collection of state machine regions.

C#
public interface IRegionContainer;
Related Topics

IStateMachine, IState

Inheritance Hierarchy
Eco.UmlRt.IRegionContainer
    Eco.UmlRt.IEcoRegionContainer
    Eco.UmlRt.IState
    Eco.UmlRt.IStateMachine
File

UmlRt.cs

See Also
Inheritance Hierarchy
Related Topics


IRegionContainer Methods

IRegionContainer Methods
Public Methods
Collapse All

The methods of the IRegionContainer class are listed here.

Public Methods
Name | Description
Contains | Indicates whether or not the state is ultimately owned by this region.


IRegionContainer.Contains Method

IRegionContainer.Contains Method
IRegionContainer Interface Eco.UmlRt Namespace See Also
Collapse All

Indicates whether or not the state is ultimately owned by this region.

C#
bool Contains(
    IState state
);
Parameters
Parameters | Description
state | The name of the state to find.
Remarks

Returns whether or not the region directly contains the specified state, or contains it indirectly via any of the regions it owns (recursively).

See Also
IRegionContainer Interface
Eco.UmlRt Namespace


IRegionContainer Properties

IRegionContainer Properties
Public Properties
Collapse All

The properties of the IRegionContainer class are listed here.

Public Properties
Name | Description
EcoRegionContainer | This is EcoRegionContainer, a member of class IRegionContainer.
FullStatemachineName | Returns the fully qualified name of this region, this includes names of any parent regions, parents of those regions, etc.
Regions | The regions that this element owns.


IRegionContainer.EcoRegionContainer Property

IRegionContainer.EcoRegionContainer Property
IRegionContainer Interface Eco.UmlRt Namespace See Also
Collapse All
C#
IEcoRegionContainer EcoRegionContainer;
Remarks

This is EcoRegionContainer, a member of class IRegionContainer.

See Also
IRegionContainer Interface
Eco.UmlRt Namespace


IRegionContainer.FullStatemachineName Property

IRegionContainer.FullStatemachineName Property
IRegionContainer Interface Eco.UmlRt Namespace See Also
Collapse All

Returns the fully qualified name of this region, this includes names of any parent regions, parents of those regions, etc.

C#
string FullStatemachineName;
See Also
IRegionContainer Interface
Eco.UmlRt Namespace


IRegionContainer.Regions Property

IRegionContainer.Regions Property
IRegionContainer Interface Eco.UmlRt Namespace See Also
Collapse All

The regions that this element owns.

C#
IRegionCollection Regions;
See Also
IRegionContainer Interface
Eco.UmlRt Namespace


ISequenceType Interface

ISequenceType Interface
Inheritance Hierarchy See Also
Collapse All

A collection where elements may be added more than once.

C#
public interface ISequenceType : ICollectionType;
Remarks

Additionally this collection indicates that if persisted the order of the elements must be maintained.

Inheritance Hierarchy
Eco.UmlRt.IModelElement
    Eco.UmlRt.IClassifier
        Eco.UmlRt.IDataType
            Eco.UmlRt.ICollectionType
                Eco.UmlRt.ISequenceType
File

UmlRt.cs

See Also
Inheritance Hierarchy


ISetType Interface

ISetType Interface
Inheritance Hierarchy See Also
Collapse All

A collection where elements may be added only once.

C#
public interface ISetType : ICollectionType;
Inheritance Hierarchy
Eco.UmlRt.IModelElement
    Eco.UmlRt.IClassifier
        Eco.UmlRt.IDataType
            Eco.UmlRt.ICollectionType
                Eco.UmlRt.ISetType
File

UmlRt.cs

See Also
Inheritance Hierarchy


ISimpleType Interface

ISimpleType Interface
Inheritance Hierarchy See Also
Collapse All

Identifies a model element as a simple type.

C#
public interface ISimpleType : IDataType;
Remarks

A simple type is capable of holding information such as enumerations or primitive types such as integers, strings, etc.

Inheritance Hierarchy
Eco.UmlRt.IModelElement
    Eco.UmlRt.IClassifier
        Eco.UmlRt.IDataType
            Eco.UmlRt.ISimpleType
                Eco.UmlRt.IEcoSimpleType
                Eco.UmlRt.IEnumerationType
                Eco.UmlRt.IPrimitiveType
File

UmlRt.cs

See Also
Inheritance Hierarchy


ISimpleType Methods

ISimpleType Methods
Public Methods
Collapse All

The methods of the ISimpleType class are listed here.

Public Methods
Name | Description
AsObjectFromString | Provides a way of parsing a string value into the correct object for this data type.


ISimpleType.AsObjectFromString Method

ISimpleType.AsObjectFromString Method
ISimpleType Interface Eco.UmlRt Namespace See Also
Collapse All

Provides a way of parsing a string value into the correct object for this data type.

C#
System.Object AsObjectFromString(
    string value
);
Parameters
Parameters | Description
value | The string value to convert.
See Also
ISimpleType Interface
Eco.UmlRt Namespace


ISimpleType Properties

ISimpleType Properties
Public Properties
Collapse All

The properties of the ISimpleType class are listed here.

Public Properties
Name | Description
DefaultContent | Holds an object representation of the default value that should be used for this data type.
EcoSimpleType | This is EcoSimpleType, a member of class ISimpleType.


ISimpleType.DefaultContent Property

ISimpleType.DefaultContent Property
ISimpleType Interface Eco.UmlRt Namespace See Also
Collapse All

Holds an object representation of the default value that should be used for this data type.

C#
System.Object DefaultContent;
Remarks

This is used as the default value in OCL when the value is NULL but NULL is not permitted. For example, if "BestFriend" is NULL then the following OCL evaluation would return zero.

Copy Code
self.bestFriend.age
See Also
ISimpleType Interface
Eco.UmlRt Namespace


ISimpleType.EcoSimpleType Property

ISimpleType.EcoSimpleType Property
ISimpleType Interface Eco.UmlRt Namespace See Also
Collapse All
C#
IEcoSimpleType EcoSimpleType;
Remarks

This is EcoSimpleType, a member of class ISimpleType.

See Also
ISimpleType Interface
Eco.UmlRt Namespace


ISimpleTypeCollection Interface

ISimpleTypeCollection Interface
Inheritance Hierarchy See Also
Collapse All

Holds a collection of Eco.UmlRt.ISimpleType.

C#
public interface ISimpleTypeCollection : ICollection;
Inheritance Hierarchy
Eco.UmlRt.ISimpleTypeCollection
File

UmlRt.cs

See Also
Inheritance Hierarchy


ISimpleTypeCollection Methods

ISimpleTypeCollection Methods
Public Methods
Collapse All

The methods of the ISimpleTypeCollection class are listed here.

Public Methods
Name | Description
GetItemByName | Gets a simple type by its name.
this | Gets a simple type by its index within the collection.


ISimpleTypeCollection.GetItemByName Method

ISimpleTypeCollection.GetItemByName Method
ISimpleTypeCollection Interface Eco.UmlRt Namespace See Also
Collapse All

Gets a simple type by its name.

C#
ISimpleType GetItemByName(
    string name
);
Parameters
Parameters | Description
name | The name of the simple type.
See Also
ISimpleTypeCollection Interface
Eco.UmlRt Namespace


ISimpleTypeCollection.this Indexer

ISimpleTypeCollection.this Indexer
ISimpleTypeCollection Interface Eco.UmlRt Namespace See Also
Collapse All

Gets a simple type by its index within the collection.

C#
ISimpleType this[
    int index
];
See Also
ISimpleTypeCollection Interface
Eco.UmlRt Namespace


IState Interface

IState Interface
Inheritance Hierarchy See Also
Collapse All

Contains model information about a state in a state machine.

C#
public interface IState : IVertex, IRegionContainer;
Inheritance Hierarchy
Eco.UmlRt.IModelElement
    Eco.UmlRt.IVertex
    Eco.UmlRt.IRegionContainer
        Eco.UmlRt.IState
            Eco.UmlRt.IEcoState
            Eco.UmlRt.IFinalState
File

UmlRt.cs

See Also
Inheritance Hierarchy


IState Properties

IState Properties
Public Properties
Collapse All

The properties of the IState class are listed here.

Public Properties
Name | Description
EcoState | This is EcoState, a member of class IState.
Entry | Specifies optional actions ECO should perform when the state is entered.
Exit | Specifies an optional actions ECO should perform when the state is exited.
IsComposite | Returns True if the state contains a single region.
IsOrthogonal | Returns True if the state contains two or more regions.
IsSimple | Returns True if the state does not contain any regions.
Representation | Holds a collection of state representation parts which contain information about each of the parts the current state consists of.


IState.EcoState Property

IState.EcoState Property
IState Interface Eco.UmlRt Namespace See Also
Collapse All
C#
IEcoState EcoState;
Remarks

This is EcoState, a member of class IState.

See Also
IState Interface
Eco.UmlRt Namespace


IState.Entry Property

IState.Entry Property
IState Interface Eco.UmlRt Namespace See Also
Collapse All

Specifies optional actions ECO should perform when the state is entered.

C#
IActivity Entry;
See Also
IState Interface
Eco.UmlRt Namespace


IState.Exit Property

IState.Exit Property
IState Interface Eco.UmlRt Namespace See Also
Collapse All

Specifies an optional actions ECO should perform when the state is exited.

C#
IActivity Exit;
See Also
IState Interface
Eco.UmlRt Namespace


IState.IsComposite Property

IState.IsComposite Property
IState Interface Eco.UmlRt Namespace See Also
Collapse All

Returns True if the state contains a single region.

C#
bool IsComposite;
See Also
IState Interface
Eco.UmlRt Namespace


IState.IsOrthogonal Property

IState.IsOrthogonal Property
IState Interface Eco.UmlRt Namespace See Also
Collapse All

Returns True if the state contains two or more regions.

C#
bool IsOrthogonal;
See Also
IState Interface
Eco.UmlRt Namespace


IState.IsSimple Property

IState.IsSimple Property
IState Interface Eco.UmlRt Namespace See Also
Collapse All

Returns True if the state does not contain any regions.

C#
bool IsSimple;
See Also
IState Interface
Eco.UmlRt Namespace


IState.Representation Property

IState.Representation Property
IState Interface Eco.UmlRt Namespace See Also
Collapse All

Holds a collection of state representation parts which contain information about each of the parts the current state consists of.

C#
IStateRepresentationPartCollection Representation;
See Also
IState Interface
Eco.UmlRt Namespace


IStateCollection Interface

IStateCollection Interface
Inheritance Hierarchy See Also
Collapse All

Holds a collection of state machine states.

C#
public interface IStateCollection : ICollection;
Inheritance Hierarchy
Eco.UmlRt.IStateCollection
    Eco.UmlRt.IStateNamedCollection
File

UmlRt.cs

See Also
Inheritance Hierarchy


IStateCollection Methods

IStateCollection Methods
Public Methods
Collapse All

The methods of the IStateCollection class are listed here.

Public Methods
Name | Description
Contains | Indicates whether or not the collection contains a specific instance of a state.
this | Gets a state by its index within the collection.


IStateCollection.Contains Method

IStateCollection.Contains Method
IStateCollection Interface Eco.UmlRt Namespace See Also
Collapse All

Indicates whether or not the collection contains a specific instance of a state.

C#
bool Contains(
    IState value
);
Parameters
Parameters | Description
value | The state to find.
See Also
IStateCollection Interface
Eco.UmlRt Namespace


IStateCollection.this Indexer

IStateCollection.this Indexer
IStateCollection Interface Eco.UmlRt Namespace See Also
Collapse All

Gets a state by its index within the collection.

C#
IState this[
    int index
];
Parameters
Parameters | Description
index | The index of the state to return.
See Also
IStateCollection Interface
Eco.UmlRt Namespace


IStateMachine Interface

IStateMachine Interface
Inheritance Hierarchy See Also
Collapse All

Contains modeled information about a state machine defined against a modeled UML class.

C#
public interface IStateMachine : IModelElement, IRegionContainer;
Inheritance Hierarchy
Eco.UmlRt.IModelElement
Eco.UmlRt.IRegionContainer
    Eco.UmlRt.IStateMachine
        Eco.UmlRt.IEcoStateMachine
File

UmlRt.cs

See Also
Inheritance Hierarchy


IStateMachine Methods

IStateMachine Methods
Public Methods
Collapse All

The methods of the IStateMachine class are listed here.

Public Methods
Name | Description
GetRegionByFullName | Returns a region by its name.
GetRegionByPartialName | Recursively searches all owned regions to try to find a region with the given name.
GetTriggerByName | Returns the trigger with the specified name.
GetVertexByFullName | Gets a vertex by its name.
GetVertexByPartialName | Recursively searches all owned regions to try to find a vertex with the given name.


IStateMachine.GetRegionByFullName Method

IStateMachine.GetRegionByFullName Method
IStateMachine Interface Eco.UmlRt Namespace See Also
Collapse All

Returns a region by its name.

C#
IRegion GetRegionByFullName(
    string name
);
Parameters
Parameters | Description
name | The fully qualified name of the region to find.
Remarks

Given a fully qualified region name (RegionName.SubRegionName) this method will return the specified region.

See Also
IStateMachine Interface
Eco.UmlRt Namespace


IStateMachine.GetRegionByPartialName Method

IStateMachine.GetRegionByPartialName Method
IStateMachine Interface Eco.UmlRt Namespace See Also
Collapse All

Recursively searches all owned regions to try to find a region with the given name.

C#
IRegion GetRegionByPartialName(
    string name
);
Parameters
Parameters | Description
name | The name of the region to find.
See Also
IStateMachine Interface
Eco.UmlRt Namespace


IStateMachine.GetTriggerByName Method

IStateMachine.GetTriggerByName Method
IStateMachine Interface Eco.UmlRt Namespace See Also
Collapse All

Returns the trigger with the specified name.

C#
ITrigger GetTriggerByName(
    string name
);
Parameters
Parameters | Description
name | The name of the trigger to find.
See Also
IStateMachine Interface
Eco.UmlRt Namespace


IStateMachine.GetVertexByFullName Method

IStateMachine.GetVertexByFullName Method
IStateMachine Interface Eco.UmlRt Namespace See Also
Collapse All

Gets a vertex by its name.

C#
IVertex GetVertexByFullName(
    string name
);
Parameters
Parameters | Description
name | The fully qualified name of the vertex to find.
Remarks

Given a fully qualified vertex name (RegionName.SubRegionName.VertexName) this method will return the specified vertex.

See Also
IStateMachine Interface
Eco.UmlRt Namespace


IStateMachine.GetVertexByPartialName Method

IStateMachine.GetVertexByPartialName Method
IStateMachine Interface Eco.UmlRt Namespace See Also
Collapse All

Recursively searches all owned regions to try to find a vertex with the given name.

C#
IVertex GetVertexByPartialName(
    string name
);
Parameters
Parameters | Description
name | The name of the vertex to find.
See Also
IStateMachine Interface
Eco.UmlRt Namespace


IStateMachine Properties

IStateMachine Properties
Public Properties
Collapse All

The properties of the IStateMachine class are listed here.

Public Properties
Name | Description
AllStateAttributes | Returns a collection of state attributes of the owning class.
Class_ | Identifies the modeled UML class against which this state machine was defined.
EcoStateMachine | This is EcoStateMachine, a member of class IStateMachine.


IStateMachine.AllStateAttributes Property

IStateMachine.AllStateAttributes Property
IStateMachine Interface Eco.UmlRt Namespace See Also
Collapse All

Returns a collection of state attributes of the owning class.

C#
IAttributeCollection AllStateAttributes;
Remarks

Returns a collection containing all UML attributes that have been identified during the modeling process as holding state information necessary to persist state machine information.

See Also
IStateMachine Interface
Eco.UmlRt Namespace


IStateMachine.Class_ Property

IStateMachine.Class_ Property
IStateMachine Interface Eco.UmlRt Namespace See Also
Collapse All

Identifies the modeled UML class against which this state machine was defined.

C#
IClass Class_;
See Also
IStateMachine Interface
Eco.UmlRt Namespace


IStateMachine.EcoStateMachine Property

IStateMachine.EcoStateMachine Property
IStateMachine Interface Eco.UmlRt Namespace See Also
Collapse All
C#
IEcoStateMachine EcoStateMachine;
Remarks

This is EcoStateMachine, a member of class IStateMachine.

See Also
IStateMachine Interface
Eco.UmlRt Namespace


IStateName Interface

IStateName Interface
Inheritance Hierarchy See Also
Collapse All
C#
public interface IStateName;
Remarks

This is class Eco.UmlRt.IStateName.

Inheritance Hierarchy
Eco.UmlRt.IStateName
File

UmlRt.cs

See Also
Inheritance Hierarchy


IStateName Properties

IStateName Properties
Public Properties
Collapse All

The properties of the IStateName class are listed here.

Public Properties
Name | Description
Name | This is Name, a member of class IStateName.


IStateName.Name Property

IStateName.Name Property
IStateName Interface Eco.UmlRt Namespace See Also
Collapse All
C#
string Name;
Remarks

This is Name, a member of class IStateName.

See Also
IStateName Interface
Eco.UmlRt Namespace


IStateNamedCollection Interface

IStateNamedCollection Interface
Inheritance Hierarchy See Also
Collapse All
C#
public interface IStateNamedCollection : IStateCollection;
Remarks

This is class Eco.UmlRt.IStateNamedCollection.

Inheritance Hierarchy
Eco.UmlRt.IStateCollection
    Eco.UmlRt.IStateNamedCollection
File

UmlRt.cs

See Also
Inheritance Hierarchy


IStateNamedCollection Methods

IStateNamedCollection Methods
Public Methods
Collapse All

The methods of the IStateNamedCollection class are listed here.

Public Methods
Name | Description
GetItemByName | Gets a state within the collection by its name.


IStateNamedCollection.GetItemByName Method

IStateNamedCollection.GetItemByName Method
IStateNamedCollection Interface Eco.UmlRt Namespace See Also
Collapse All

Gets a state within the collection by its name.

C#
IState GetItemByName(
    string name
);
Parameters
Parameters | Description
name | The name of the state to return.
See Also
IStateNamedCollection Interface
Eco.UmlRt Namespace


IStateRepresentationPart Interface

IStateRepresentationPart Interface
Inheritance Hierarchy See Also
Collapse All

Provides information about the runtime representation of part of a state (i.e. the state itself and its regions).

C#
public interface IStateRepresentationPart;
Inheritance Hierarchy
Eco.UmlRt.IStateRepresentationPart
File

UmlRt.cs

See Also
Inheritance Hierarchy


IStateRepresentationPart Properties

IStateRepresentationPart Properties
Public Properties
Collapse All

The properties of the IStateRepresentationPart class are listed here.

Public Properties
Name | Description
Attribute | Identifies which UML attribute on the modeled UML class will store the state information.
Value | Returns the value of this state part as an object.


IStateRepresentationPart.Attribute Property

IStateRepresentationPart.Attribute Property
IStateRepresentationPart Interface Eco.UmlRt Namespace See Also
Collapse All

Identifies which UML attribute on the modeled UML class will store the state information.

C#
IAttribute Attribute;
See Also
IStateRepresentationPart Interface
Eco.UmlRt Namespace


IStateRepresentationPart.Value Property

IStateRepresentationPart.Value Property
IStateRepresentationPart Interface Eco.UmlRt Namespace See Also
Collapse All

Returns the value of this state part as an object.

C#
object Value;
See Also
IStateRepresentationPart Interface
Eco.UmlRt Namespace


IStateRepresentationPartCollection Interface

IStateRepresentationPartCollection Interface
Inheritance Hierarchy See Also
Collapse All

Holds a collection of state representation parts.

C#
public interface IStateRepresentationPartCollection : ICollection;
Inheritance Hierarchy
Eco.UmlRt.IStateRepresentationPartCollection
File

UmlRt.cs

See Also
Inheritance Hierarchy


IStateRepresentationPartCollection Methods

IStateRepresentationPartCollection Methods
Public Methods
Collapse All

The methods of the IStateRepresentationPartCollection class are listed here.

Public Methods
Name | Description
this | Gets a state representation part by its index within the collection.


IStateRepresentationPartCollection.this Indexer

IStateRepresentationPartCollection.this Indexer
IStateRepresentationPartCollection Interface Eco.UmlRt Namespace See Also
Collapse All

Gets a state representation part by its index within the collection.

C#
IStateRepresentationPart this[
    int index
];
Parameters
Parameters | Description
index | The index of the part representation to return.
See Also
IStateRepresentationPartCollection Interface
Eco.UmlRt Namespace


IStereotype Interface

IStereotype Interface
Inheritance Hierarchy See Also
Collapse All

Represents a stereotype entered against a model element. The name of the stereotype is contained in the Name property.

C#
public interface IStereotype : IModelElement;
Inheritance Hierarchy
Eco.UmlRt.IModelElement
    Eco.UmlRt.IStereotype
File

UmlRt.cs

See Also
Inheritance Hierarchy


IStereotypeCollection Interface

IStereotypeCollection Interface
Inheritance Hierarchy See Also
Collapse All

Holds a collection of Eco.UmlRt.IStereotype

C#
public interface IStereotypeCollection : ICollection;
Inheritance Hierarchy
Eco.UmlRt.IStereotypeCollection
File

UmlRt.cs

See Also
Inheritance Hierarchy


IStereotypeCollection Methods

IStereotypeCollection Methods
Public Methods
Collapse All

The methods of the IStereotypeCollection class are listed here.

Public Methods
Name | Description
GetItemByName | Gets a stereotype by its name.
this | Gets a stereotype by its index within the collection.


IStereotypeCollection.GetItemByName Method

IStereotypeCollection.GetItemByName Method
IStereotypeCollection Interface Eco.UmlRt Namespace See Also
Collapse All

Gets a stereotype by its name.

C#
IStereotype GetItemByName(
    string name
);
Parameters
Parameters | Description
name | The name of the stereotype.
See Also
IStereotypeCollection Interface
Eco.UmlRt Namespace


IStereotypeCollection.this Indexer

IStereotypeCollection.this Indexer
IStereotypeCollection Interface Eco.UmlRt Namespace See Also
Collapse All

Gets a stereotype by its index within the collection.

C#
IStereotype this[
    int index
];
See Also
IStereotypeCollection Interface
Eco.UmlRt Namespace


IStructuralFeature Interface

IStructuralFeature Interface
Inheritance Hierarchy See Also
Collapse All

Contains model information about any structural feature on a UML class.

C#
public interface IStructuralFeature : IFeature;
Remarks

A structural feature is an IFeature that defines the structure of a class such as association ends and UML attributes, excluding non-structural features such as methods.

Inheritance Hierarchy
Eco.UmlRt.IModelElement
    Eco.UmlRt.IFeature
        Eco.UmlRt.IStructuralFeature
            Eco.UmlRt.IAssociationEnd
            Eco.UmlRt.IAttribute
            Eco.UmlRt.IEcoStructuralFeature
File

UmlRt.cs

See Also
Inheritance Hierarchy


IStructuralFeature Properties

IStructuralFeature Properties
Public Properties
Collapse All

The properties of the IStructuralFeature class are listed here.

Public Properties
Name | Description
CanHaveOldValue | Indicates whether or not the feature holds the last known persisted value.
Changeability | Indicates whether or not a feature was modeled read only.
DeriveAndSubscribeMethod | Holds a reference to the method to invoke in order to derive (calculate) the value of the feature if the feature has been marked as code-derived in the model.
EcoStructuralFeature | This is EcoStructuralFeature, a member of class IStructuralFeature.
EncouragesOptimisticLockingOnDeletedOnly | This is EncouragesOptimisticLockingOnDeletedOnly, a member of class IStructuralFeature.
HasUserCode | Indicates whether or not there is getter/setter code in the .NET class.
IndexInAllStructuralFeatures | Returns the index of this feature in the owning UML class's IFeaturedType.AllStructuralFeatures collection.
IsAutoDerived | True if DeriveAndSubscribeMethod has signature MemberNameDerive()
IsDelayedFetch | Indicates that the feature was marked DelayedFetch in the model.
IsDerived | Indicates whether or not the feature is derived (calculated).
IsReverseDerived | Indicates whether or not a derived feature is capable of having its value set.
IsStoredInObject | Indicates whether or not the owning UML class physically stores the data value of the feature.
LoopbackIndex | Contains the LoopbackIndex of the feature. This is the index used by Eco.ObjectRepresentation.IPropertyCollection.GetByLoopbackIndex.
Multiplicity | Contains model information about association end multiplicity.
Persistent | Indicates whether the feature's value is stored in the persistent storage or not. Non-persistent features include features marked as Transient, and features that are derived.
PropertyDescriptor | A Proertydescriptor that can be used e.g. for implementing ICustomTypeDescriptor. Mostly for internal use. feature.
PropertyInfo | Holds reflection information about the property of the .NET class that represents this feature.
SaveAction | Indicates the behaviour the feature should adopt after it's owning object instance has been saved for the first time.
Type_ | Returns an IClassifier which contains meta information about the .NET type of this feature.


IStructuralFeature.CanHaveOldValue Property

IStructuralFeature.CanHaveOldValue Property
IStructuralFeature Interface Eco.UmlRt Namespace See Also
Collapse All

Indicates whether or not the feature holds the last known persisted value.

C#
bool CanHaveOldValue;
Remarks

This property will return true if the optimistic locking strategy chosen would require the feature to hold its original "fetched" value in order to determine whether or not the object has been modified by another user.

See Also
IStructuralFeature Interface
Eco.UmlRt Namespace


IStructuralFeature.Changeability Property

IStructuralFeature.Changeability Property
IStructuralFeature Interface Eco.UmlRt Namespace See Also
Collapse All

Indicates whether or not a feature was modeled read only.

C#
ChangeableKind Changeability;
Remarks

Indicates whether the feature was modeled in such a way as to always force it to be readonly, for example by making it an OCL derived feature or a code derived feature that is not derived settable.

See Also
IStructuralFeature Interface
Eco.UmlRt Namespace


IStructuralFeature.DeriveAndSubscribeMethod Property

IStructuralFeature.DeriveAndSubscribeMethod Property
IStructuralFeature Interface Eco.UmlRt Namespace See Also
Collapse All

Holds a reference to the method to invoke in order to derive (calculate) the value of the feature if the feature has been marked as code-derived in the model.

C#
MethodInfo DeriveAndSubscribeMethod;
See Also
IStructuralFeature Interface
Eco.UmlRt Namespace


IStructuralFeature.EcoStructuralFeature Property

IStructuralFeature.EcoStructuralFeature Property
IStructuralFeature Interface Eco.UmlRt Namespace See Also
Collapse All
C#
IEcoStructuralFeature EcoStructuralFeature;
Remarks

This is EcoStructuralFeature, a member of class IStructuralFeature.

See Also
IStructuralFeature Interface
Eco.UmlRt Namespace


IStructuralFeature.EncouragesOptimisticLockingOnDeletedOnly Property

IStructuralFeature.EncouragesOptimisticLockingOnDeletedOnly Property
IStructuralFeature Interface Eco.UmlRt Namespace See Also
Collapse All
C#
bool EncouragesOptimisticLockingOnDeletedOnly;
Remarks

This is EncouragesOptimisticLockingOnDeletedOnly, a member of class IStructuralFeature.

See Also
IStructuralFeature Interface
Eco.UmlRt Namespace


IStructuralFeature.HasUserCode Property

IStructuralFeature.HasUserCode Property
IStructuralFeature Interface Eco.UmlRt Namespace See Also
Collapse All

Indicates whether or not there is getter/setter code in the .NET class.

C#
bool HasUserCode;
Remarks

If a class instance's member is modified using the OCL action language the .NET class's property is bypassed and the value is modified directly in the EcoSpace's cache. If the model requires that the .NET property should have additional code in either the GET or SET then HasUserCode should be set to True at design time. When ECO attempts to read or write a member value in OCL it will first check if HasUserCode is True, if it is then the read/write operation will be routed via the .NET class instance's property to ensure that this code is executed.

See Also
IStructuralFeature Interface
Eco.UmlRt Namespace


IStructuralFeature.IndexInAllStructuralFeatures Property

IStructuralFeature.IndexInAllStructuralFeatures Property
IStructuralFeature Interface Eco.UmlRt Namespace See Also
Collapse All

Returns the index of this feature in the owning UML class's IFeaturedType.AllStructuralFeatures collection.

C#
int IndexInAllStructuralFeatures;
See Also
IStructuralFeature Interface
Eco.UmlRt Namespace


IStructuralFeature.IsAutoDerived Property

IStructuralFeature.IsAutoDerived Property
IStructuralFeature Interface Eco.UmlRt Namespace See Also
Collapse All

True if DeriveAndSubscribeMethod has signature MemberNameDerive()

C#
bool IsAutoDerived;
See Also
IStructuralFeature Interface
Eco.UmlRt Namespace


IStructuralFeature.IsDelayedFetch Property

IStructuralFeature.IsDelayedFetch Property
IStructuralFeature Interface Eco.UmlRt Namespace See Also
Collapse All

Indicates that the feature was marked DelayedFetch in the model.

C#
bool IsDelayedFetch;
Remarks

A delayed fetched feature will not fetch its value from the persistent storage until the application attempts to read its value. This is useful for large properties (such as binary attachments) which may consume a lot of memory and are unlikely to be used by the application every time the owning object instance is used.

See Also
IStructuralFeature Interface
Eco.UmlRt Namespace


IStructuralFeature.IsDerived Property

IStructuralFeature.IsDerived Property
IStructuralFeature Interface Eco.UmlRt Namespace See Also
Collapse All

Indicates whether or not the feature is derived (calculated).

C#
bool IsDerived;
See Also
IStructuralFeature Interface
Eco.UmlRt Namespace


IStructuralFeature.IsReverseDerived Property

IStructuralFeature.IsReverseDerived Property
IStructuralFeature Interface Eco.UmlRt Namespace See Also
Collapse All

Indicates whether or not a derived feature is capable of having its value set.

C#
bool IsReverseDerived;
See Also
IStructuralFeature Interface
Eco.UmlRt Namespace


IStructuralFeature.IsStoredInObject Property

IStructuralFeature.IsStoredInObject Property
IStructuralFeature Interface Eco.UmlRt Namespace See Also
Collapse All

Indicates whether or not the owning UML class physically stores the data value of the feature.

C#
bool IsStoredInObject;
Remarks

>

If the owner does store the feature's value then modifying this feature's value on a class instance will result in the instance being marked as "Dirty"; meaning that it needs to update the persistent storage.

A feature may exist on a UML class but not be stored due to one of the following reasons:

  • A class association where both ends have a multiplicity > 1.
  • A class association where neither end is marked as embedded.
  • A class association where the opposite association end is marked as embedded.

See Also
IStructuralFeature Interface
Eco.UmlRt Namespace


IStructuralFeature.LoopbackIndex Property

IStructuralFeature.LoopbackIndex Property
IStructuralFeature Interface Eco.UmlRt Namespace See Also
Collapse All

Contains the LoopbackIndex of the feature. This is the index used by Eco.ObjectRepresentation.IPropertyCollection.GetByLoopbackIndex.

C#
int LoopbackIndex;
See Also
IStructuralFeature Interface
Eco.UmlRt Namespace


IStructuralFeature.Multiplicity Property

IStructuralFeature.Multiplicity Property
IStructuralFeature Interface Eco.UmlRt Namespace See Also
Collapse All

Contains model information about association end multiplicity.

C#
IMultiplicity Multiplicity;
See Also
IStructuralFeature Interface
Eco.UmlRt Namespace


IStructuralFeature.Persistent Property

IStructuralFeature.Persistent Property
IStructuralFeature Interface Eco.UmlRt Namespace See Also
Collapse All

Indicates whether the feature's value is stored in the persistent storage or not. Non-persistent features include features marked as Transient, and features that are derived.

C#
bool Persistent;
See Also
IStructuralFeature Interface
Eco.UmlRt Namespace


IStructuralFeature.PropertyDescriptor Property

IStructuralFeature.PropertyDescriptor Property
IStructuralFeature Interface Eco.UmlRt Namespace See Also
Collapse All

A Proertydescriptor that can be used e.g. for implementing ICustomTypeDescriptor. Mostly for internal use. feature.

C#
PropertyDescriptor PropertyDescriptor;
See Also
IStructuralFeature Interface
Eco.UmlRt Namespace


IStructuralFeature.PropertyInfo Property

IStructuralFeature.PropertyInfo Property
IStructuralFeature Interface Eco.UmlRt Namespace See Also
Collapse All

Holds reflection information about the property of the .NET class that represents this feature.

C#
PropertyInfo PropertyInfo;
See Also
IStructuralFeature Interface
Eco.UmlRt Namespace


IStructuralFeature.SaveAction Property

IStructuralFeature.SaveAction Property
IStructuralFeature Interface Eco.UmlRt Namespace See Also
Collapse All

Indicates the behaviour the feature should adopt after it's owning object instance has been saved for the first time.

C#
SaveAction SaveAction;
See Also
IStructuralFeature Interface
Eco.UmlRt Namespace


IStructuralFeature.Type_ Property

IStructuralFeature.Type_ Property
IStructuralFeature Interface Eco.UmlRt Namespace See Also
Collapse All

Returns an IClassifier which contains meta information about the .NET type of this feature.

C#
IClassifier Type_;
See Also
IStructuralFeature Interface
Eco.UmlRt Namespace


IStructuralFeatureCollection Interface

IStructuralFeatureCollection Interface
Inheritance Hierarchy See Also
Collapse All

Holds a collection of Eco.UmlRt.IStructuralFeature.

C#
public interface IStructuralFeatureCollection : ICollection;
Inheritance Hierarchy
Eco.UmlRt.IStructuralFeatureCollection
File

UmlRt.cs

See Also
Inheritance Hierarchy


IStructuralFeatureCollection Methods

IStructuralFeatureCollection Methods
Public Methods
Collapse All

The methods of the IStructuralFeatureCollection class are listed here.

Public Methods
Name | Description
GetItemByName | Gets a structural feature by its name.
this | Gets a structural feature by its index within the collection.


IStructuralFeatureCollection.GetItemByName Method

IStructuralFeatureCollection.GetItemByName Method
IStructuralFeatureCollection Interface Eco.UmlRt Namespace See Also
Collapse All

Gets a structural feature by its name.

C#
IStructuralFeature GetItemByName(
    string name
);
Parameters
Parameters | Description
name | The name of the structural feature.
See Also
IStructuralFeatureCollection Interface
Eco.UmlRt Namespace


IStructuralFeatureCollection.this Indexer

IStructuralFeatureCollection.this Indexer
IStructuralFeatureCollection Interface Eco.UmlRt Namespace See Also
Collapse All

Gets a structural feature by its index within the collection.

C#
IStructuralFeature this[
    int index
];
See Also
IStructuralFeatureCollection Interface
Eco.UmlRt Namespace


ITaggedValue Interface

ITaggedValue Interface
Example Inheritance Hierarchy See Also
Collapse All

Contains information about a tagged value added to model elements during design time.

C#
public interface ITaggedValue;
Remarks

Tagged values are a useful way of adding additional meta information about elements within a model.

Example

MyCompany.HumanReadibleName = First name

Inheritance Hierarchy
Eco.UmlRt.ITaggedValue
File

UmlRt.cs

See Also
Example
Inheritance Hierarchy


ITaggedValue Properties

ITaggedValue Properties
Public Properties
Collapse All

The properties of the ITaggedValue class are listed here.

Public Properties
Name | Description
Tag | Specifies the name of the tagged value.
Value | Specifies the value associated with the tagged value.


ITaggedValue.Tag Property

ITaggedValue.Tag Property
ITaggedValue Interface Eco.UmlRt Namespace See Also
Collapse All

Specifies the name of the tagged value.

C#
string Tag;
See Also
ITaggedValue Interface
Eco.UmlRt Namespace


ITaggedValue.Value Property

ITaggedValue.Value Property
ITaggedValue Interface Eco.UmlRt Namespace See Also
Collapse All

Specifies the value associated with the tagged value.

C#
string Value;
See Also
ITaggedValue Interface
Eco.UmlRt Namespace


ITaggedValueCollection Interface

ITaggedValueCollection Interface
Inheritance Hierarchy See Also
Collapse All

Holds a collection of tagged values added to the model during design time.

C#
public interface ITaggedValueCollection : ICollection;
Inheritance Hierarchy
Eco.UmlRt.ITaggedValueCollection
File

UmlRt.cs

See Also
Inheritance Hierarchy


ITaggedValueCollection Methods

ITaggedValueCollection Methods
Public Methods
Collapse All

The methods of the ITaggedValueCollection class are listed here.

Public Methods
Name | Description
GetItemByTag | Gets a tagged value by its tag.
this | Gets a tagged value by its index within the collection.
ValueForTag | This is the overview for the ValueForTag method overload.


ITaggedValueCollection.GetItemByTag Method

ITaggedValueCollection.GetItemByTag Method
ITaggedValueCollection Interface Eco.UmlRt Namespace See Also
Collapse All

Gets a tagged value by its tag.

C#
ITaggedValue GetItemByTag(
    string tag
);
See Also
ITaggedValueCollection Interface
Eco.UmlRt Namespace


ITaggedValueCollection.this Indexer

ITaggedValueCollection.this Indexer
ITaggedValueCollection Interface Eco.UmlRt Namespace See Also
Collapse All

Gets a tagged value by its index within the collection.

C#
ITaggedValue this[
    int index
];
See Also
ITaggedValueCollection Interface
Eco.UmlRt Namespace


ValueForTag Method

ValueForTag Method

This is the overview for the ValueForTag method overload.

Overload List
Name | Description
ITaggedValueCollection.ValueForTag (string) | Gets the value of a tagged value with a specific name. If no tagged value exists with the given name an exception will be thrown.
ITaggedValueCollection.ValueForTag (string, string) | Gets the value of a tagged value with a specific name. If no tagged value exists with the given name the defaultValue will be returned.


ITaggedValueCollection.ValueForTag Method (string)

ITaggedValueCollection.ValueForTag Method (string)
ITaggedValueCollection Interface Eco.UmlRt Namespace See Also
Collapse All

Gets the value of a tagged value with a specific name. If no tagged value exists with the given name an exception will be thrown.

C#
string ValueForTag(
    string tag
);
Parameters
Parameters | Description
tag | The name of the tagged value.
See Also
ITaggedValueCollection Interface
Eco.UmlRt Namespace


ITaggedValueCollection.ValueForTag Method (string, string)

ITaggedValueCollection.ValueForTag Method (string, string)
ITaggedValueCollection Interface Eco.UmlRt Namespace See Also
Collapse All

Gets the value of a tagged value with a specific name. If no tagged value exists with the given name the defaultValue will be returned.

C#
string ValueForTag(
    string tag,
    string defaultValue
);
Parameters
Parameters | Description
tag | The name of the tagged value.
defaultValue | The value to return if no such tagged value exists.
See Also
ITaggedValueCollection Interface
Eco.UmlRt Namespace


ITransition Interface

ITransition Interface
Inheritance Hierarchy See Also
Collapse All

Contains model information about a transition from one state to another within a state machine.

C#
public interface ITransition;
Inheritance Hierarchy
Eco.UmlRt.ITransition
File

UmlRt.cs

See Also
Inheritance Hierarchy


ITransition Properties

ITransition Properties
Public Properties
Collapse All

The properties of the ITransition class are listed here.

Public Properties
Name | Description
Effect | Contains an optional OCL action language expression entered in the model during design time.
Guard | Contains an OCL expression which will determine whether or not the current transition is possible.
Region | Holds a reference to the owning region.
Source | Identifies the state from which the transition will originate.
Target | Identifies the state the transition will cause the state machine to move into.
Trigger | Identifies which trigger will cause this transition to occur (if any).


ITransition.Effect Property

ITransition.Effect Property
ITransition Interface Eco.UmlRt Namespace See Also
Collapse All

Contains an optional OCL action language expression entered in the model during design time.

C#
IActivity Effect;
Remarks

If this expression is not empty ECO will execute the expression when the transition is taken.

See Also
ITransition Interface
Eco.UmlRt Namespace


ITransition.Guard Property

ITransition.Guard Property
ITransition Interface Eco.UmlRt Namespace See Also
Collapse All

Contains an OCL expression which will determine whether or not the current transition is possible.

C#
IExpression Guard;
Remarks

When ECO searches for a valid transition it will first build a list of all transitions out of the current state, it will then evaluate the guard expression on each, if only a single evaluation evaluates to True then the transition will be taken, otherwise an exception will be thrown.

See Also
ITransition Interface
Eco.UmlRt Namespace


ITransition.Region Property

ITransition.Region Property
ITransition Interface Eco.UmlRt Namespace See Also
Collapse All

Holds a reference to the owning region.

C#
IRegion Region;
See Also
ITransition Interface
Eco.UmlRt Namespace


ITransition.Source Property

ITransition.Source Property
ITransition Interface Eco.UmlRt Namespace See Also
Collapse All

Identifies the state from which the transition will originate.

C#
IVertex Source;
See Also
ITransition Interface
Eco.UmlRt Namespace


ITransition.Target Property

ITransition.Target Property
ITransition Interface Eco.UmlRt Namespace See Also
Collapse All

Identifies the state the transition will cause the state machine to move into.

C#
IVertex Target;
See Also
ITransition Interface
Eco.UmlRt Namespace


ITransition.Trigger Property

ITransition.Trigger Property
ITransition Interface Eco.UmlRt Namespace See Also
Collapse All

Identifies which trigger will cause this transition to occur (if any).

C#
ITrigger Trigger;
Remarks

When a trigger is executed ECO will find all outgoing transitions from the current state that are attached to the trigger. If more than one transition is found the Guard will be used to determine which one should be taken.

See Also
ITransition Interface
Eco.UmlRt Namespace


ITransitionCollection Interface

ITransitionCollection Interface
Inheritance Hierarchy See Also
Collapse All

Holds a collection of state machine transitions.

C#
public interface ITransitionCollection : ICollection;
Inheritance Hierarchy
Eco.UmlRt.ITransitionCollection
File

UmlRt.cs

See Also
Inheritance Hierarchy


ITransitionCollection Methods

ITransitionCollection Methods
Public Methods
Collapse All

The methods of the ITransitionCollection class are listed here.

Public Methods
Name | Description
this | Gets a transition by its index within the collection.


ITransitionCollection.this Indexer

ITransitionCollection.this Indexer
ITransitionCollection Interface Eco.UmlRt Namespace See Also
Collapse All

Gets a transition by its index within the collection.

C#
ITransition this[
    int index
];
Parameters
Parameters | Description
index | The index of the transition.
See Also
ITransitionCollection Interface
Eco.UmlRt Namespace


ITrigger Interface

ITrigger Interface
Inheritance Hierarchy See Also
Collapse All

Represents a trigger within a modeled state machine.

C#
public interface ITrigger;
Inheritance Hierarchy
Eco.UmlRt.ITrigger
    Eco.UmlRt.IMethodTrigger
File

UmlRt.cs

See Also
Inheritance Hierarchy


ITrigger Properties

ITrigger Properties
Public Properties
Collapse All

The properties of the ITrigger class are listed here.

Public Properties
Name | Description
Name | Contains the name of the trigger.


ITrigger.Name Property

ITrigger.Name Property
ITrigger Interface Eco.UmlRt Namespace See Also
Collapse All

Contains the name of the trigger.

C#
string Name;
See Also
ITrigger Interface
Eco.UmlRt Namespace


ITriggerCollection Interface

ITriggerCollection Interface
Inheritance Hierarchy See Also
Collapse All

Holds a collection of state machine triggers.

C#
public interface ITriggerCollection : ICollection;
Inheritance Hierarchy
Eco.UmlRt.ITriggerCollection
File

UmlRt.cs

See Also
Inheritance Hierarchy


ITriggerCollection Methods

ITriggerCollection Methods
Public Methods
Collapse All

The methods of the ITriggerCollection class are listed here.

Public Methods
Name | Description
Contains | Indicates whether or not the collection contains the specific instance of a trigger.
this | Gets a trigger by its index within the collection.


ITriggerCollection.Contains Method

ITriggerCollection.Contains Method
ITriggerCollection Interface Eco.UmlRt Namespace See Also
Collapse All

Indicates whether or not the collection contains the specific instance of a trigger.

C#
bool Contains(
    ITrigger value
);
Parameters
Parameters | Description
value | The trigger to find.
See Also
ITriggerCollection Interface
Eco.UmlRt Namespace


ITriggerCollection.this Indexer

ITriggerCollection.this Indexer
ITriggerCollection Interface Eco.UmlRt Namespace See Also
Collapse All

Gets a trigger by its index within the collection.

C#
ITrigger this[
    int index
];
Parameters
Parameters | Description
index | The index of the trigger to return.
See Also
ITriggerCollection Interface
Eco.UmlRt Namespace


ITupleType Interface

ITupleType Interface
Inheritance Hierarchy See Also
Collapse All
C#
public interface ITupleType : IDataType, IFeaturedType;
Remarks

This is class Eco.UmlRt.ITupleType.

Inheritance Hierarchy
Eco.UmlRt.IModelElement
    Eco.UmlRt.IClassifier
        Eco.UmlRt.IDataType
        Eco.UmlRt.IFeaturedType
            Eco.UmlRt.ITupleType
File

UmlRt.cs

See Also
Inheritance Hierarchy


ITypeConverter Interface

ITypeConverter Interface
Inheritance Hierarchy See Also
Collapse All
C#
public interface ITypeConverter;
Remarks

This is class Eco.UmlRt.ITypeConverter.

Inheritance Hierarchy
Eco.UmlRt.ITypeConverter
File

UmlRt.cs

See Also
Inheritance Hierarchy


ITypeConverter Methods

ITypeConverter Methods
Public Methods
Collapse All

The methods of the ITypeConverter class are listed here.

Public Methods
Name | Description
Convert | This is Convert, a member of class ITypeConverter.


ITypeConverter.Convert Method

ITypeConverter.Convert Method
ITypeConverter Interface Eco.UmlRt Namespace See Also
Collapse All
C#
System.Object Convert(
    System.Object value
);
Remarks

This is Convert, a member of class ITypeConverter.

See Also
ITypeConverter Interface
Eco.UmlRt Namespace


IVertex Interface

IVertex Interface
Inheritance Hierarchy See Also
Collapse All

Contains model information about a vertex in a state machine.

C#
public interface IVertex : IModelElement;
Remarks

A vertex is the base type for the various types of state within a state machine such as IPseudostate used to identify Initial states, and IState used to identify states and Final states.

Inheritance Hierarchy
Eco.UmlRt.IModelElement
    Eco.UmlRt.IVertex
        Eco.UmlRt.IEcoVertex
        Eco.UmlRt.IPseudostate
        Eco.UmlRt.IState
File

UmlRt.cs

See Also
Inheritance Hierarchy


IVertex Properties

IVertex Properties
Public Properties
Collapse All

The properties of the IVertex class are listed here.

Public Properties
Name | Description
Container | Holds a reference to the owner of this vertex.
EcoVertex | This is EcoVertex, a member of class IVertex.
FullStatemachineName | Returns the fully qualified name of this region.
HasUntriggeredOutgoing | Indicates whether or not there are outgoing transitions without triggers.
Incoming | Contains a collection of all transitions that lead into this state.
IsFinalState | Returns True if this vertex is a Final state, otherwise returns false.
Outgoing | Contains a collection of all transitions that exit this state.
TopSimpleRegion | Holds a reference to the topmost region of the state machine.


IVertex.Container Property

IVertex.Container Property
IVertex Interface Eco.UmlRt Namespace See Also
Collapse All

Holds a reference to the owner of this vertex.

C#
IRegion Container;
See Also
IVertex Interface
Eco.UmlRt Namespace


IVertex.EcoVertex Property

IVertex.EcoVertex Property
IVertex Interface Eco.UmlRt Namespace See Also
Collapse All
C#
IEcoVertex EcoVertex;
Remarks

This is EcoVertex, a member of class IVertex.

See Also
IVertex Interface
Eco.UmlRt Namespace


IVertex.FullStatemachineName Property

IVertex.FullStatemachineName Property
IVertex Interface Eco.UmlRt Namespace See Also
Collapse All

Returns the fully qualified name of this region.

C#
string FullStatemachineName;
Remarks

This includes names of any parent regions, parents of those regions, etc.

See Also
IVertex Interface
Eco.UmlRt Namespace


IVertex.HasUntriggeredOutgoing Property

IVertex.HasUntriggeredOutgoing Property
IVertex Interface Eco.UmlRt Namespace See Also
Collapse All

Indicates whether or not there are outgoing transitions without triggers.

C#
bool HasUntriggeredOutgoing;
See Also
IVertex Interface
Eco.UmlRt Namespace


IVertex.Incoming Property

IVertex.Incoming Property
IVertex Interface Eco.UmlRt Namespace See Also
Collapse All

Contains a collection of all transitions that lead into this state.

C#
ITransitionCollection Incoming;
See Also
IVertex Interface
Eco.UmlRt Namespace


IVertex.IsFinalState Property

IVertex.IsFinalState Property
IVertex Interface Eco.UmlRt Namespace See Also
Collapse All

Returns True if this vertex is a Final state, otherwise returns false.

C#
bool IsFinalState;
See Also
IVertex Interface
Eco.UmlRt Namespace


IVertex.Outgoing Property

IVertex.Outgoing Property
IVertex Interface Eco.UmlRt Namespace See Also
Collapse All

Contains a collection of all transitions that exit this state.

C#
ITransitionCollection Outgoing;
See Also
IVertex Interface
Eco.UmlRt Namespace


IVertex.TopSimpleRegion Property

IVertex.TopSimpleRegion Property
IVertex Interface Eco.UmlRt Namespace See Also
Collapse All

Holds a reference to the topmost region of the state machine.

C#
IRegion TopSimpleRegion;
See Also
IVertex Interface
Eco.UmlRt Namespace


IVertexCollection Interface

IVertexCollection Interface
Inheritance Hierarchy See Also
Collapse All

Holds a collection of state machine vertexes.

C#
public interface IVertexCollection : ICollection;
Inheritance Hierarchy
Eco.UmlRt.IVertexCollection
File

UmlRt.cs

See Also
Inheritance Hierarchy


IVertexCollection Methods

IVertexCollection Methods
Public Methods
Collapse All

The methods of the IVertexCollection class are listed here.

Public Methods
Name | Description
GetItemByName | Gets a vertex by its name.
this | Gets a vertex by its index within the collection.


IVertexCollection.GetItemByName Method

IVertexCollection.GetItemByName Method
IVertexCollection Interface Eco.UmlRt Namespace See Also
Collapse All

Gets a vertex by its name.

C#
IVertex GetItemByName(
    string name
);
Parameters
Parameters | Description
name | The name of the vertex to return.
Remarks

The name of the vertex must be unique within the collection.

See Also
IVertexCollection Interface
Eco.UmlRt Namespace


IVertexCollection.this Indexer

IVertexCollection.this Indexer
IVertexCollection Interface Eco.UmlRt Namespace See Also
Collapse All

Gets a vertex by its index within the collection.

C#
IVertex this[
    int index
];
Parameters
Parameters | Description
index | The index of the vertex.
See Also
IVertexCollection Interface
Eco.UmlRt Namespace


Eco.UmlRt.AggregationKind Enumeration

Eco.UmlRt.AggregationKind Enumeration

Specifies the "default" delete action that ECO should take when an associated object is deleted.

C#
public enum AggregationKind {
  None,
  Aggregate,
  Composite
}
Members
Members | Description
None | There is no aggregation, associated objects will be unlinked.
Aggregate | If an attempt is made to delete an object that refers to aggregated objects then the deletion will be disallowed.
Composite | When an object is deleted that owns composite objects those composite objects will also be deleted.
File

UmlRt.cs


Eco.UmlRt.AssociationEndDefaultRegionMode Enumeration

Eco.UmlRt.AssociationEndDefaultRegionMode Enumeration
C#
public enum AssociationEndDefaultRegionMode {
  Default,
  None,
  Cascade,
  IndependentCascade,
  Existence
}
Remarks

This is record Eco.UmlRt.AssociationEndDefaultRegionMode.

File

UmlRt.cs


Eco.UmlRt.AssociationEndKind Enumeration

Eco.UmlRt.AssociationEndKind Enumeration

Specifies the type of object at the other end of an association.

C#
public enum AssociationEndKind {
  Normal,
  ToLinkObject,
  InnerLink
}
Members
Members | Description
Normal | The object at the other end of the association is another ECO class.
ToLinkObject | The object at the other end of the association is an association class.
InnerLink | The object at the other end of the association is another ECO class. This association kind is an automatically created link on an association class.
File

UmlRt.cs


Eco.UmlRt.ChangeableKind Enumeration

Eco.UmlRt.ChangeableKind Enumeration

This enum is used to identify whether a feature of a UML class is readonly or not.

C#
public enum ChangeableKind {
  Frozen,
  Changeable
}
Members
Members | Description
Frozen | Indicates that the feature is readonly.
Changeable | Indicates that the feature is modifyable.
File

UmlRt.cs


Eco.UmlRt.ClassifierNamePair Structure

Eco.UmlRt.ClassifierNamePair Structure

This struct is used while constructing tuples

C#
public struct ClassifierNamePair {
  public IClassifier Classifier;
  public string Name;
}
File

UmlRt.cs


Eco.UmlRt.ClassifierType Enumeration

Eco.UmlRt.ClassifierType Enumeration

Specifies the type of an element.

C#
public enum ClassifierType {
  Class,
  Collection,
  Primitive,
  Enumeration,
  Tuple
}
Members
Members | Description
Class | The element is an instance of an ECO class.
Collection | The element is a collection of elements.
Primitive | The element is a primitive type, such as an integer or a string.
Enumeration | The element is an enumeration.
Tuple | The element is a Tuple
File

UmlRt.cs


Eco.UmlRt.CollectionTypeKind Enumeration

Eco.UmlRt.CollectionTypeKind Enumeration

Specifies the type of a collection of elements.

C#
public enum CollectionTypeKind {
  Collection,
  Bag,
  Set,
  Sequence,
  OrderedSet
}
Members
Members | Description
Bag | Elements within the collection may occur more than once.
Set | Elements within the collection may occur no more than once.
Sequence | A bag in which the elements may be manually reordered.
OrderedSet | Elements within the collection may occur no more than once and have an index. The elements are not necessarily ordered based on some kind of value, but instead posses the ability to be reordered manually.
File

UmlRt.cs


Eco.UmlRt.DeleteAction Enumeration

Eco.UmlRt.DeleteAction Enumeration

Specifies how associated objects are to be treated when an object is deleted.

C#
public enum DeleteAction {
  Cascade,
  Allow,
  Prohibit
}
Members
Members | Description
Cascade | The objects at the other end of the association will be deleted along with the current object.
Allow | Before the object is deleted all referenced objects will first be unassociated.
Prohibit | If any objects exist at the other end of the association then any attempt to delete this object will fail.
File

UmlRt.cs


Eco.UmlRt.FeatureType Enumeration

Eco.UmlRt.FeatureType Enumeration

Specifies the type of a feature (member) in an ECO class.

C#
public enum FeatureType {
  Attribute,
  AssociationEnd,
  Method,
  TuplePart
}
Members
Members | Description
Attribute | The feature is an attribute.
AssociationEnd | The feature is an association end.
Method | The feature is a method.
TuplePart | The feature is a part of a tuple.
File

UmlRt.cs


Eco.UmlRt.LinkFetchStrategy Enumeration

Eco.UmlRt.LinkFetchStrategy Enumeration

This enum is used to control how relations are fetched from the persistent storage.

C#
public enum LinkFetchStrategy {
  Default,
  IdsOnly,
  FetchObjects
}
Members
Members | Description
Default | This option will defer the decision to a setting on the EcoSpace.
IdsOnly | This option ensures that only the ID of objects in an asssociation are retrieved rather than the associated objects themselves.
FetchObjects | When this option is chosen the object(s) at the other end of the association are fetched from the persistent storage along with the current object.
File

UmlRt.cs


Eco.UmlRt.OptimisticLockingMode Enumeration

Eco.UmlRt.OptimisticLockingMode Enumeration

This enum is used to specify which optimistic locking technique to use when updating an object instance to the persistent storage.

C#
public enum OptimisticLockingMode {
  Off,
  ModifiedMembers,
  AllMembers,
  TimeStamp
}
Members
Members | Description
Off | No optimistic locking.
ModifiedMembers | Lock modified members only.
AllMembers | Lock whole objects.
TimeStamp | Use a time stamp to lock whole objects.
File

UmlRt.cs


Eco.UmlRt.OrderingKind Enumeration

Eco.UmlRt.OrderingKind Enumeration

Specifies whether or not additional information will be stored in the persistent storage to remember any custom reordering of objects in the association.

C#
public enum OrderingKind {
  Ordered,
  Unordered
}
Members
Members | Description
Ordered | Additional information is added to the persistent storage to ensure that any custom ordering is persisted.
Unordered | The order of the objects in the association is unimportant and will not be persisted.
File

UmlRt.cs


Eco.UmlRt.ParameterDirectionKind Enumeration

Eco.UmlRt.ParameterDirectionKind Enumeration

Specifies the direction of a method's parameter.

C#
public enum ParameterDirectionKind {
  In,
  Out,
  InOut
}
Members
Members | Description
In | The calling code must pass a value for this parameter.
Out | The calling code need not pass a value for this parameter, but should expect its value to be modified by the method.
InOut | The calling code must pass a value for this parameter, and should expect its value to be modified by the method.
File

UmlRt.cs


Eco.UmlRt.PseudostateKind Enumeration

Eco.UmlRt.PseudostateKind Enumeration

This enum is used to identify the type of a pseudo state in a state machine.

C#
public enum PseudostateKind {
  Initial
}
Members
Members | Description
Initial | The pseudo state is an Initial state.
File

UmlRt.cs


Eco.UmlRt.SaveAction Enumeration

Eco.UmlRt.SaveAction Enumeration

Specifies the behavior of a class's member after a new instance has been saved to the persistent storage.

C#
public enum SaveAction {
  None,
  Freeze,
  DbAssign
}
Members
Members | Description
None | The member behaves no differently.
Freeze | The value of the member should be made read-only.
DbAssign | The value of the member is determined outside of the model and should therefore be read back from the persistent storage after the object instance has been saved. This is typical for DB assigned values such as auto-incrementing sequence numbers.
File

UmlRt.cs


Eco.UmlRt.ScopeKind Enumeration

Eco.UmlRt.ScopeKind Enumeration

Specifies whether a member is an instance member or a static (class) member.

C#
public enum ScopeKind {
  Instance,
  Classifier
}
Members
Members | Description
Instance | The member belongs to object instances.
Classifier | The member is static, shared by all instances of the same class.
File

UmlRt.cs


Eco.UmlRt.TableMapping Enumeration

Eco.UmlRt.TableMapping Enumeration

When ECO is responsible for maintaining the struture of a database this enum will specify how to create table information for the current persistent class.

C#
public enum TableMapping {
  Own,
  Parent,
  Children,
  Imported
}
Members
Members | Description
Own | A table will be created for the current class.
Parent | No table will be created for the current class, instead its members will be added to the table belonging to its parent class.
Children | No table will be created for the current class, instead its members will be added to each of the tables belonging to descendant classes.
File

UmlRt.cs


Eco.UmlRt.VisibilityKind Enumeration

Eco.UmlRt.VisibilityKind Enumeration

Specifies the visibility of a class's members.

C#
public enum VisibilityKind {
  Private_,
  Protected_,
  Public_,
  Package
}
Members
Members | Description
Private_ | The member is only accessible by instances of the class itself.
Protected_ | The member is only accessible by instances of the class and instances of any subclasses.
Public_ | The member is accessible by any instance of any class.
Package | The member is accessible by any instance of any class defined within the same assembly.
File

UmlRt.cs


Eco.Wcf.Client Namespace

Eco.Wcf.Client Namespace
Classes
Collapse All

This is namespace Eco.Wcf.Client.

Classes
Name | Description
PersistenceMapperWCFClient | This is class Eco.Wcf.Client.PersistenceMapperWCFClient.


PersistenceMapperWCFClient Class

PersistenceMapperWCFClient Class
Inheritance Hierarchy See Also
Collapse All
C#
public class PersistenceMapperWCFClient : Eco.Persistence.PersistenceMapper, IPersistenceMapper;
Remarks

This is class Eco.Wcf.Client.PersistenceMapperWCFClient.

Inheritance Hierarchy
Eco.Wcf.Client.PersistenceMapperWCFClient
File

PersistenceMapperWCFClient.cs

See Also
Inheritance Hierarchy


PersistenceMapperWCFClient.PersistenceMapperWCFClient Constructor

PersistenceMapperWCFClient.PersistenceMapperWCFClient Constructor
PersistenceMapperWCFClient Class Eco.Wcf.Client Namespace See Also
Collapse All
C#
public PersistenceMapperWCFClient();
Remarks

This is PersistenceMapperWCFClient, a member of class PersistenceMapperWCFClient.

See Also
PersistenceMapperWCFClient Class
Eco.Wcf.Client Namespace


PersistenceMapperWCFClient Methods

PersistenceMapperWCFClient Methods
Public Methods
Collapse All

The methods of the PersistenceMapperWCFClient class are listed here.

Public Methods
Name | Description
Connect | This is Connect, a member of class PersistenceMapperWCFClient.
GetPersistenceMapper | This is GetPersistenceMapper, a member of class PersistenceMapperWCFClient.
ReturnPersistenceMapper | This is ReturnPersistenceMapper, a member of class PersistenceMapperWCFClient.


PersistenceMapperWCFClient.Connect Method

PersistenceMapperWCFClient.Connect Method
PersistenceMapperWCFClient Class Eco.Wcf.Client Namespace See Also
Collapse All
C#
public void Connect();
Remarks

This is Connect, a member of class PersistenceMapperWCFClient.

See Also
PersistenceMapperWCFClient Class
Eco.Wcf.Client Namespace


PersistenceMapperWCFClient.GetPersistenceMapper Method

PersistenceMapperWCFClient.GetPersistenceMapper Method
PersistenceMapperWCFClient Class Eco.Wcf.Client Namespace See Also
Collapse All
C#
public override Eco.Persistence.IPersistenceMapper GetPersistenceMapper(
    Eco.Services.ITypeSystemService typeSystemService
);
Remarks

This is GetPersistenceMapper, a member of class PersistenceMapperWCFClient.

See Also
PersistenceMapperWCFClient Class
Eco.Wcf.Client Namespace


PersistenceMapperWCFClient.ReturnPersistenceMapper Method

PersistenceMapperWCFClient.ReturnPersistenceMapper Method
PersistenceMapperWCFClient Class Eco.Wcf.Client Namespace See Also
Collapse All
C#
public override void ReturnPersistenceMapper(
    Eco.Persistence.IPersistenceMapper persistenceMapper
);
Remarks

This is ReturnPersistenceMapper, a member of class PersistenceMapperWCFClient.

See Also
PersistenceMapperWCFClient Class
Eco.Wcf.Client Namespace


PersistenceMapperWCFClient Properties

PersistenceMapperWCFClient Properties
Public Properties
Collapse All

The properties of the PersistenceMapperWCFClient class are listed here.

Public Properties
Name | Description
Service | This is Service, a member of class PersistenceMapperWCFClient.
Uri | This is Uri, a member of class PersistenceMapperWCFClient.


PersistenceMapperWCFClient.Service Property

PersistenceMapperWCFClient.Service Property
PersistenceMapperWCFClient Class Eco.Wcf.Client Namespace See Also
Collapse All
C#
public string Service;
Remarks

This is Service, a member of class PersistenceMapperWCFClient.

See Also
PersistenceMapperWCFClient Class
Eco.Wcf.Client Namespace


PersistenceMapperWCFClient.Uri Property

PersistenceMapperWCFClient.Uri Property
PersistenceMapperWCFClient Class Eco.Wcf.Client Namespace See Also
Collapse All
C#
public string Uri;
Remarks

This is Uri, a member of class PersistenceMapperWCFClient.

See Also
PersistenceMapperWCFClient Class
Eco.Wcf.Client Namespace


Eco.Wcf.Common Namespace

Eco.Wcf.Common Namespace
Classes Interfaces
Collapse All

This is namespace Eco.Wcf.Common.

Classes
Name | Description
AbstractConditionTransfer | This is class Eco.Wcf.Common.AbstractConditionTransfer.
AllInstancesConditionTransfer | This is class Eco.Wcf.Common.AllInstancesConditionTransfer.
DatablockTransfer | This is class Eco.Wcf.Common.DatablockTransfer.
DBChangeCollectionTransfer | This is class Eco.Wcf.Common.DBChangeCollectionTransfer.
DBChangeTransfer | This is class Eco.Wcf.Common.DBChangeTransfer.
DefaultIdTransfer | This is class Eco.Wcf.Common.DefaultIdTransfer.
IdTranslationListTransfer | This is class Eco.Wcf.Common.IdTranslationListTransfer.
InternalObjectIdTransfer | This is class Eco.Wcf.Common.InternalObjectIdTransfer.
ObjectIdListTransfer | This is class Eco.Wcf.Common.ObjectIdListTransfer.
ObjectIdTransfer | This is class Eco.Wcf.Common.ObjectIdTransfer.
OclConditionTransfer | This is class Eco.Wcf.Common.OclConditionTransfer.
OptimisticLockingPreconditionTransfer | This is class Eco.Wcf.Common.OptimisticLockingPreconditionTransfer.
TimestampedDefaultIdTransfer | This is class Eco.Wcf.Common.TimestampedDefaultIdTransfer.
UpdatePreconditionTransfer | This is class Eco.Wcf.Common.UpdatePreconditionTransfer.
UpdateResultTransfer | This is class Eco.Wcf.Common.UpdateResultTransfer.
Top
Interfaces
Name | Description
IPersistenceMapperWCF | This is class Eco.Wcf.Common.IPersistenceMapperWCF.


AbstractConditionTransfer Class

AbstractConditionTransfer Class
Inheritance Hierarchy See Also
Collapse All
C#
public abstract class AbstractConditionTransfer;
Remarks

This is class Eco.Wcf.Common.AbstractConditionTransfer.

Inheritance Hierarchy
Eco.Wcf.Common.AbstractConditionTransfer
    Eco.Wcf.Common.AllInstancesConditionTransfer
    Eco.Wcf.Common.OclConditionTransfer
File

WcfTransportClasses.cs

See Also
Inheritance Hierarchy


AbstractConditionTransfer Constructor

AbstractConditionTransfer Constructor

This is the overview for the AbstractConditionTransfer constructor overload.

Overload List
Name | Description
AbstractConditionTransfer.AbstractConditionTransfer () | This is AbstractConditionTransfer, a member of class AbstractConditionTransfer.
AbstractConditionTransfer.AbstractConditionTransfer (AbstractCondition) | This is AbstractConditionTransfer, a member of class AbstractConditionTransfer.


AbstractConditionTransfer.AbstractConditionTransfer Constructor ()

AbstractConditionTransfer.AbstractConditionTransfer Constructor ()
AbstractConditionTransfer Class Eco.Wcf.Common Namespace See Also
Collapse All
C#
protected AbstractConditionTransfer();
Remarks

This is AbstractConditionTransfer, a member of class AbstractConditionTransfer.

See Also
AbstractConditionTransfer Class
Eco.Wcf.Common Namespace


AbstractConditionTransfer.AbstractConditionTransfer Constructor (AbstractCondition)

AbstractConditionTransfer.AbstractConditionTransfer Constructor (AbstractCondition)
AbstractConditionTransfer Class Eco.Wcf.Common Namespace See Also
Collapse All
C#
protected AbstractConditionTransfer(
    AbstractCondition org
);
Remarks

This is AbstractConditionTransfer, a member of class AbstractConditionTransfer.

See Also
AbstractConditionTransfer Class
Eco.Wcf.Common Namespace


AbstractConditionTransfer Methods

AbstractConditionTransfer Methods
Protected Methods Public Methods
Collapse All

The methods of the AbstractConditionTransfer class are listed here.

Protected Methods
Name | Description
CreateCondition | This is CreateCondition, a member of class AbstractConditionTransfer.
Top
Public Methods
Name | Description
CreateFromCondition | This is CreateFromCondition, a member of class AbstractConditionTransfer.
ToAbstractCondition | This is ToAbstractCondition, a member of class AbstractConditionTransfer.


AbstractConditionTransfer.CreateCondition Method

AbstractConditionTransfer.CreateCondition Method
AbstractConditionTransfer Class Eco.Wcf.Common Namespace See Also
Collapse All
C#
protected abstract AbstractCondition CreateCondition();
Remarks

This is CreateCondition, a member of class AbstractConditionTransfer.

See Also
AbstractConditionTransfer Class
Eco.Wcf.Common Namespace


AbstractConditionTransfer.CreateFromCondition Method

AbstractConditionTransfer.CreateFromCondition Method
AbstractConditionTransfer Class Eco.Wcf.Common Namespace See Also
Collapse All
C#
public static AbstractConditionTransfer CreateFromCondition(
    AbstractCondition condition
);
Remarks

This is CreateFromCondition, a member of class AbstractConditionTransfer.

See Also
AbstractConditionTransfer Class
Eco.Wcf.Common Namespace


AbstractConditionTransfer.ToAbstractCondition Method

AbstractConditionTransfer.ToAbstractCondition Method
AbstractConditionTransfer Class Eco.Wcf.Common Namespace See Also
Collapse All
C#
public AbstractCondition ToAbstractCondition();
Remarks

This is ToAbstractCondition, a member of class AbstractConditionTransfer.

See Also
AbstractConditionTransfer Class
Eco.Wcf.Common Namespace


AbstractConditionTransfer Properties

AbstractConditionTransfer Properties
Public Properties
Collapse All

The properties of the AbstractConditionTransfer class are listed here.

Public Properties
Name | Description
ClassId | This is ClassId, a member of class AbstractConditionTransfer.
Version | This is Version, a member of class AbstractConditionTransfer.


AbstractConditionTransfer.ClassId Property

AbstractConditionTransfer.ClassId Property
AbstractConditionTransfer Class Eco.Wcf.Common Namespace See Also
Collapse All
C#
public int ClassId;
Remarks

This is ClassId, a member of class AbstractConditionTransfer.

See Also
AbstractConditionTransfer Class
Eco.Wcf.Common Namespace


AbstractConditionTransfer.Version Property

AbstractConditionTransfer.Version Property
AbstractConditionTransfer Class Eco.Wcf.Common Namespace See Also
Collapse All
C#
public int Version;
Remarks

This is Version, a member of class AbstractConditionTransfer.

See Also
AbstractConditionTransfer Class
Eco.Wcf.Common Namespace


AllInstancesConditionTransfer Class

AllInstancesConditionTransfer Class
Inheritance Hierarchy See Also
Collapse All
C#
public sealed class AllInstancesConditionTransfer : AbstractConditionTransfer;
Remarks

This is class Eco.Wcf.Common.AllInstancesConditionTransfer.

Inheritance Hierarchy
Eco.Wcf.Common.AbstractConditionTransfer
    Eco.Wcf.Common.AllInstancesConditionTransfer
File

WcfTransportClasses.cs

See Also
Inheritance Hierarchy


AllInstancesConditionTransfer Constructor

AllInstancesConditionTransfer Constructor

This is the overview for the AllInstancesConditionTransfer constructor overload.

Overload List
Name | Description
AllInstancesConditionTransfer.AllInstancesConditionTransfer () | This is AllInstancesConditionTransfer, a member of class AllInstancesConditionTransfer.
AllInstancesConditionTransfer.AllInstancesConditionTransfer (AllInstancesCondition) | This is AllInstancesConditionTransfer, a member of class AllInstancesConditionTransfer.


AllInstancesConditionTransfer.AllInstancesConditionTransfer Constructor ()

AllInstancesConditionTransfer.AllInstancesConditionTransfer Constructor ()
AllInstancesConditionTransfer Class Eco.Wcf.Common Namespace See Also
Collapse All
C#
public AllInstancesConditionTransfer();
Remarks

This is AllInstancesConditionTransfer, a member of class AllInstancesConditionTransfer.

See Also
AllInstancesConditionTransfer Class
Eco.Wcf.Common Namespace


AllInstancesConditionTransfer.AllInstancesConditionTransfer Constructor (AllInstancesCondition)

AllInstancesConditionTransfer.AllInstancesConditionTransfer Constructor (AllInstancesCondition)
AllInstancesConditionTransfer Class Eco.Wcf.Common Namespace See Also
Collapse All
C#
public AllInstancesConditionTransfer(
    AllInstancesCondition cond
);
Remarks

This is AllInstancesConditionTransfer, a member of class AllInstancesConditionTransfer.

See Also
AllInstancesConditionTransfer Class
Eco.Wcf.Common Namespace


AllInstancesConditionTransfer Methods

AllInstancesConditionTransfer Methods
Protected Methods
Collapse All

The methods of the AllInstancesConditionTransfer class are listed here.

Protected Methods
Name | Description
CreateCondition | This is CreateCondition, a member of class AllInstancesConditionTransfer.


AllInstancesConditionTransfer.CreateCondition Method

AllInstancesConditionTransfer.CreateCondition Method
AllInstancesConditionTransfer Class Eco.Wcf.Common Namespace See Also
Collapse All
C#
protected override AbstractCondition CreateCondition();
Remarks

This is CreateCondition, a member of class AllInstancesConditionTransfer.

See Also
AllInstancesConditionTransfer Class
Eco.Wcf.Common Namespace


DatablockTransfer Class

DatablockTransfer Class
Inheritance Hierarchy See Also
Collapse All
C#
public class DatablockTransfer;
Remarks

This is class Eco.Wcf.Common.DatablockTransfer.

Inheritance Hierarchy
Eco.Wcf.Common.DatablockTransfer
File

WcfTransportClasses.cs

See Also
Inheritance Hierarchy


DatablockTransfer Constructor

DatablockTransfer Constructor

This is the overview for the DatablockTransfer constructor overload.

Overload List
Name | Description
DatablockTransfer.DatablockTransfer () | This is DatablockTransfer, a member of class DatablockTransfer.
DatablockTransfer.DatablockTransfer (Datablock, IEcoTypeSystem) | This is DatablockTransfer, a member of class DatablockTransfer.


DatablockTransfer.DatablockTransfer Constructor ()

DatablockTransfer.DatablockTransfer Constructor ()
DatablockTransfer Class Eco.Wcf.Common Namespace See Also
Collapse All
C#
public DatablockTransfer();
Remarks

This is DatablockTransfer, a member of class DatablockTransfer.

See Also
DatablockTransfer Class
Eco.Wcf.Common Namespace


DatablockTransfer.DatablockTransfer Constructor (Datablock, IEcoTypeSystem)

DatablockTransfer.DatablockTransfer Constructor (Datablock, IEcoTypeSystem)
DatablockTransfer Class Eco.Wcf.Common Namespace See Also
Collapse All
C#
public DatablockTransfer(
    Datablock datablock,
    IEcoTypeSystem typeSystem
);
Remarks

This is DatablockTransfer, a member of class DatablockTransfer.

See Also
DatablockTransfer Class
Eco.Wcf.Common Namespace


DatablockTransfer Methods

DatablockTransfer Methods
Public Methods
Collapse All

The methods of the DatablockTransfer class are listed here.

Public Methods
Name | Description
ToDatablock | This is ToDatablock, a member of class DatablockTransfer.


DatablockTransfer.ToDatablock Method

DatablockTransfer.ToDatablock Method
DatablockTransfer Class Eco.Wcf.Common Namespace See Also
Collapse All
C#
public Datablock ToDatablock(
    IEcoTypeSystem typeSystem
);
Remarks

This is ToDatablock, a member of class DatablockTransfer.

See Also
DatablockTransfer Class
Eco.Wcf.Common Namespace


DBChangeCollectionTransfer Class

DBChangeCollectionTransfer Class
Inheritance Hierarchy See Also
Collapse All
C#
public class DBChangeCollectionTransfer;
Remarks

This is class Eco.Wcf.Common.DBChangeCollectionTransfer.

Inheritance Hierarchy
Eco.Wcf.Common.DBChangeCollectionTransfer
File

WcfTransportClasses.cs

See Also
Inheritance Hierarchy


DBChangeCollectionTransfer.DBChangeCollectionTransfer Constructor

DBChangeCollectionTransfer.DBChangeCollectionTransfer Constructor
DBChangeCollectionTransfer Class Eco.Wcf.Common Namespace See Also
Collapse All
C#
public DBChangeCollectionTransfer(
    DBChangeCollection org
);
Remarks

This is DBChangeCollectionTransfer, a member of class DBChangeCollectionTransfer.

See Also
DBChangeCollectionTransfer Class
Eco.Wcf.Common Namespace


DBChangeCollectionTransfer Methods

DBChangeCollectionTransfer Methods
Public Methods
Collapse All

The methods of the DBChangeCollectionTransfer class are listed here.

Public Methods
Name | Description
ToChangeCollection | This is ToChangeCollection, a member of class DBChangeCollectionTransfer.


DBChangeCollectionTransfer.ToChangeCollection Method

DBChangeCollectionTransfer.ToChangeCollection Method
DBChangeCollectionTransfer Class Eco.Wcf.Common Namespace See Also
Collapse All
C#
public DBChangeCollection ToChangeCollection();
Remarks

This is ToChangeCollection, a member of class DBChangeCollectionTransfer.

See Also
DBChangeCollectionTransfer Class
Eco.Wcf.Common Namespace


DBChangeTransfer Class

DBChangeTransfer Class
Inheritance Hierarchy See Also
Collapse All
C#
public class DBChangeTransfer;
Remarks

This is class Eco.Wcf.Common.DBChangeTransfer.

Inheritance Hierarchy
Eco.Wcf.Common.DBChangeTransfer
File

WcfTransportClasses.cs

See Also
Inheritance Hierarchy


DBChangeTransfer.DBChangeTransfer Constructor

DBChangeTransfer.DBChangeTransfer Constructor
DBChangeTransfer Class Eco.Wcf.Common Namespace See Also
Collapse All
C#
public DBChangeTransfer(
    DBChange change
);
Remarks

This is DBChangeTransfer, a member of class DBChangeTransfer.

See Also
DBChangeTransfer Class
Eco.Wcf.Common Namespace


DBChangeTransfer Methods

DBChangeTransfer Methods
Public Methods
Collapse All

The methods of the DBChangeTransfer class are listed here.

Public Methods
Name | Description
ToDbChange | This is ToDbChange, a member of class DBChangeTransfer.


DBChangeTransfer.ToDbChange Method

DBChangeTransfer.ToDbChange Method
DBChangeTransfer Class Eco.Wcf.Common Namespace See Also
Collapse All
C#
public DBChange ToDbChange();
Remarks

This is ToDbChange, a member of class DBChangeTransfer.

See Also
DBChangeTransfer Class
Eco.Wcf.Common Namespace


DBChangeTransfer Properties

DBChangeTransfer Properties
Public Properties
Collapse All

The properties of the DBChangeTransfer class are listed here.

Public Properties
Name | Description
ChangeKind | This is ChangeKind, a member of class DBChangeTransfer.
Id | This is Id, a member of class DBChangeTransfer.


DBChangeTransfer.ChangeKind Property

DBChangeTransfer.ChangeKind Property
DBChangeTransfer Class Eco.Wcf.Common Namespace See Also
Collapse All
C#
public DBChange.ChangeKind ChangeKind;
Remarks

This is ChangeKind, a member of class DBChangeTransfer.

See Also
DBChangeTransfer Class
Eco.Wcf.Common Namespace


DBChangeTransfer.Id Property

DBChangeTransfer.Id Property
DBChangeTransfer Class Eco.Wcf.Common Namespace See Also
Collapse All
C#
public ObjectIdTransfer Id;
Remarks

This is Id, a member of class DBChangeTransfer.

See Also
DBChangeTransfer Class
Eco.Wcf.Common Namespace


DefaultIdTransfer Class

DefaultIdTransfer Class
Inheritance Hierarchy See Also
Collapse All
C#
public class DefaultIdTransfer : ObjectIdTransfer;
Remarks

This is class Eco.Wcf.Common.DefaultIdTransfer.

Inheritance Hierarchy
Eco.Wcf.Common.ObjectIdTransfer
    Eco.Wcf.Common.DefaultIdTransfer
        Eco.Wcf.Common.TimestampedDefaultIdTransfer
File

WcfTransportClasses.cs

See Also
Inheritance Hierarchy


DefaultIdTransfer.DefaultIdTransfer Constructor

DefaultIdTransfer.DefaultIdTransfer Constructor
DefaultIdTransfer Class Eco.Wcf.Common Namespace See Also
Collapse All
C#
public DefaultIdTransfer(
    DefaultId id
);
Remarks

This is DefaultIdTransfer, a member of class DefaultIdTransfer.

See Also
DefaultIdTransfer Class
Eco.Wcf.Common Namespace


DefaultIdTransfer Methods

DefaultIdTransfer Methods
Public Methods
Collapse All

The methods of the DefaultIdTransfer class are listed here.

Public Methods
Name | Description
ToId | This is ToId, a member of class DefaultIdTransfer.


DefaultIdTransfer.ToId Method

DefaultIdTransfer.ToId Method
DefaultIdTransfer Class Eco.Wcf.Common Namespace See Also
Collapse All
C#
public override ObjectId ToId();
Remarks

This is ToId, a member of class DefaultIdTransfer.

See Also
DefaultIdTransfer Class
Eco.Wcf.Common Namespace


IdTranslationListTransfer Class

IdTranslationListTransfer Class
Inheritance Hierarchy See Also
Collapse All
C#
public class IdTranslationListTransfer;
Remarks

This is class Eco.Wcf.Common.IdTranslationListTransfer.

Inheritance Hierarchy
Eco.Wcf.Common.IdTranslationListTransfer
File

WcfTransportClasses.cs

See Also
Inheritance Hierarchy


IdTranslationListTransfer Constructor

IdTranslationListTransfer Constructor

This is the overview for the IdTranslationListTransfer constructor overload.

Overload List
Name | Description
IdTranslationListTransfer.IdTranslationListTransfer () | This is IdTranslationListTransfer, a member of class IdTranslationListTransfer.
IdTranslationListTransfer.IdTranslationListTransfer (IdTranslationList) | This is IdTranslationListTransfer, a member of class IdTranslationListTransfer.


IdTranslationListTransfer.IdTranslationListTransfer Constructor ()

IdTranslationListTransfer.IdTranslationListTransfer Constructor ()
IdTranslationListTransfer Class Eco.Wcf.Common Namespace See Also
Collapse All
C#
public IdTranslationListTransfer();
Remarks

This is IdTranslationListTransfer, a member of class IdTranslationListTransfer.

See Also
IdTranslationListTransfer Class
Eco.Wcf.Common Namespace


IdTranslationListTransfer.IdTranslationListTransfer Constructor (IdTranslationList)

IdTranslationListTransfer.IdTranslationListTransfer Constructor (IdTranslationList)
IdTranslationListTransfer Class Eco.Wcf.Common Namespace See Also
Collapse All
C#
public IdTranslationListTransfer(
    IdTranslationList translationList
);
Remarks

This is IdTranslationListTransfer, a member of class IdTranslationListTransfer.

See Also
IdTranslationListTransfer Class
Eco.Wcf.Common Namespace


IdTranslationListTransfer Methods

IdTranslationListTransfer Methods
Public Methods
Collapse All

The methods of the IdTranslationListTransfer class are listed here.

Public Methods
Name | Description
ToTranslationList | This is ToTranslationList, a member of class IdTranslationListTransfer.


IdTranslationListTransfer.ToTranslationList Method

IdTranslationListTransfer.ToTranslationList Method
IdTranslationListTransfer Class Eco.Wcf.Common Namespace See Also
Collapse All
C#
public IdTranslationList ToTranslationList();
Remarks

This is ToTranslationList, a member of class IdTranslationListTransfer.

See Also
IdTranslationListTransfer Class
Eco.Wcf.Common Namespace


IdTranslationListTransfer Properties

IdTranslationListTransfer Properties
Public Properties
Collapse All

The properties of the IdTranslationListTransfer class are listed here.

Public Properties
Name | Description
NewIds | This is NewIds, a member of class IdTranslationListTransfer.
OldIds | This is OldIds, a member of class IdTranslationListTransfer.


IdTranslationListTransfer.NewIds Property

IdTranslationListTransfer.NewIds Property
IdTranslationListTransfer Class Eco.Wcf.Common Namespace See Also
Collapse All
C#
public List<ObjectIdTransfer> NewIds;
Remarks

This is NewIds, a member of class IdTranslationListTransfer.

See Also
IdTranslationListTransfer Class
Eco.Wcf.Common Namespace


IdTranslationListTransfer.OldIds Property

IdTranslationListTransfer.OldIds Property
IdTranslationListTransfer Class Eco.Wcf.Common Namespace See Also
Collapse All
C#
public List<ObjectIdTransfer> OldIds;
Remarks

This is OldIds, a member of class IdTranslationListTransfer.

See Also
IdTranslationListTransfer Class
Eco.Wcf.Common Namespace


InternalObjectIdTransfer Class

InternalObjectIdTransfer Class
Inheritance Hierarchy See Also
Collapse All
C#
public class InternalObjectIdTransfer : ObjectIdTransfer;
Remarks

This is class Eco.Wcf.Common.InternalObjectIdTransfer.

Inheritance Hierarchy
Eco.Wcf.Common.ObjectIdTransfer
    Eco.Wcf.Common.InternalObjectIdTransfer
File

WcfTransportClasses.cs

See Also
Inheritance Hierarchy


InternalObjectIdTransfer.InternalObjectIdTransfer Constructor

InternalObjectIdTransfer.InternalObjectIdTransfer Constructor
InternalObjectIdTransfer Class Eco.Wcf.Common Namespace See Also
Collapse All
C#
public InternalObjectIdTransfer(
    InternalObjectId id
);
Remarks

This is InternalObjectIdTransfer, a member of class InternalObjectIdTransfer.

See Also
InternalObjectIdTransfer Class
Eco.Wcf.Common Namespace


InternalObjectIdTransfer Methods

InternalObjectIdTransfer Methods
Public Methods
Collapse All

The methods of the InternalObjectIdTransfer class are listed here.

Public Methods
Name | Description
ToId | This is ToId, a member of class InternalObjectIdTransfer.


InternalObjectIdTransfer.ToId Method

InternalObjectIdTransfer.ToId Method
InternalObjectIdTransfer Class Eco.Wcf.Common Namespace See Also
Collapse All
C#
public override ObjectId ToId();
Remarks

This is ToId, a member of class InternalObjectIdTransfer.

See Also
InternalObjectIdTransfer Class
Eco.Wcf.Common Namespace


ObjectIdListTransfer Class

ObjectIdListTransfer Class
Inheritance Hierarchy See Also
Collapse All
C#
public class ObjectIdListTransfer;
Remarks

This is class Eco.Wcf.Common.ObjectIdListTransfer.

Inheritance Hierarchy
Eco.Wcf.Common.ObjectIdListTransfer
File

WcfTransportClasses.cs

See Also
Inheritance Hierarchy


ObjectIdListTransfer.ObjectIdListTransfer Constructor

ObjectIdListTransfer.ObjectIdListTransfer Constructor
ObjectIdListTransfer Class Eco.Wcf.Common Namespace See Also
Collapse All
C#
public ObjectIdListTransfer(
    ObjectIdList org
);
Remarks

This is ObjectIdListTransfer, a member of class ObjectIdListTransfer.

See Also
ObjectIdListTransfer Class
Eco.Wcf.Common Namespace


ObjectIdListTransfer Methods

ObjectIdListTransfer Methods
Public Methods
Collapse All

The methods of the ObjectIdListTransfer class are listed here.

Public Methods
Name | Description
ToIdList | This is ToIdList, a member of class ObjectIdListTransfer.


ObjectIdListTransfer.ToIdList Method

ObjectIdListTransfer.ToIdList Method
ObjectIdListTransfer Class Eco.Wcf.Common Namespace See Also
Collapse All
C#
public ObjectIdList ToIdList();
Remarks

This is ToIdList, a member of class ObjectIdListTransfer.

See Also
ObjectIdListTransfer Class
Eco.Wcf.Common Namespace


ObjectIdListTransfer Properties

ObjectIdListTransfer Properties
Public Properties
Collapse All

The properties of the ObjectIdListTransfer class are listed here.

Public Properties
Name | Description
Ids | This is Ids, a member of class ObjectIdListTransfer.


ObjectIdListTransfer.Ids Property

ObjectIdListTransfer.Ids Property
ObjectIdListTransfer Class Eco.Wcf.Common Namespace See Also
Collapse All
C#
public List<ObjectIdTransfer> Ids;
Remarks

This is Ids, a member of class ObjectIdListTransfer.

See Also
ObjectIdListTransfer Class
Eco.Wcf.Common Namespace


ObjectIdTransfer Class

ObjectIdTransfer Class
Inheritance Hierarchy See Also
Collapse All
C#
public abstract class ObjectIdTransfer;
Remarks

This is class Eco.Wcf.Common.ObjectIdTransfer.

Inheritance Hierarchy
Eco.Wcf.Common.ObjectIdTransfer
    Eco.Wcf.Common.DefaultIdTransfer
    Eco.Wcf.Common.InternalObjectIdTransfer
File

WcfTransportClasses.cs

See Also
Inheritance Hierarchy


ObjectIdTransfer.ObjectIdTransfer Constructor

ObjectIdTransfer.ObjectIdTransfer Constructor
ObjectIdTransfer Class Eco.Wcf.Common Namespace See Also
Collapse All
C#
public ObjectIdTransfer(
    ObjectId id
);
Remarks

This is ObjectIdTransfer, a member of class ObjectIdTransfer.

See Also
ObjectIdTransfer Class
Eco.Wcf.Common Namespace


ObjectIdTransfer Methods

ObjectIdTransfer Methods
Public Methods
Collapse All

The methods of the ObjectIdTransfer class are listed here.

Public Methods
Name | Description
CreateId | This is CreateId, a member of class ObjectIdTransfer.
ToId | This is ToId, a member of class ObjectIdTransfer.


ObjectIdTransfer.CreateId Method

ObjectIdTransfer.CreateId Method
ObjectIdTransfer Class Eco.Wcf.Common Namespace See Also
Collapse All
C#
public static ObjectIdTransfer CreateId(
    ObjectId id
);
Remarks

This is CreateId, a member of class ObjectIdTransfer.

See Also
ObjectIdTransfer Class
Eco.Wcf.Common Namespace


ObjectIdTransfer.ToId Method

ObjectIdTransfer.ToId Method
ObjectIdTransfer Class Eco.Wcf.Common Namespace See Also
Collapse All
C#
public abstract ObjectId ToId();
Remarks

This is ToId, a member of class ObjectIdTransfer.

See Also
ObjectIdTransfer Class
Eco.Wcf.Common Namespace


ObjectIdTransfer Properties

ObjectIdTransfer Properties
Public Properties
Collapse All

The properties of the ObjectIdTransfer class are listed here.

Public Properties
Name | Description
ClassId | This is ClassId, a member of class ObjectIdTransfer.
Key | This is Key, a member of class ObjectIdTransfer.


ObjectIdTransfer.ClassId Property

ObjectIdTransfer.ClassId Property
ObjectIdTransfer Class Eco.Wcf.Common Namespace See Also
Collapse All
C#
public int ClassId;
Remarks

This is ClassId, a member of class ObjectIdTransfer.

See Also
ObjectIdTransfer Class
Eco.Wcf.Common Namespace


ObjectIdTransfer.Key Property

ObjectIdTransfer.Key Property
ObjectIdTransfer Class Eco.Wcf.Common Namespace See Also
Collapse All
C#
public object Key;
Remarks

This is Key, a member of class ObjectIdTransfer.

See Also
ObjectIdTransfer Class
Eco.Wcf.Common Namespace


OclConditionTransfer Class

OclConditionTransfer Class
Inheritance Hierarchy See Also
Collapse All
C#
public abstract class OclConditionTransfer : AbstractConditionTransfer;
Remarks

This is class Eco.Wcf.Common.OclConditionTransfer.

Inheritance Hierarchy
Eco.Wcf.Common.AbstractConditionTransfer
    Eco.Wcf.Common.OclConditionTransfer
File

WcfTransportClasses.cs

See Also
Inheritance Hierarchy


OclConditionTransfer Constructor

OclConditionTransfer Constructor

This is the overview for the OclConditionTransfer constructor overload.

Overload List
Name | Description
OclConditionTransfer.OclConditionTransfer () | This is OclConditionTransfer, a member of class OclConditionTransfer.
OclConditionTransfer.OclConditionTransfer (OclCondition) | This is OclConditionTransfer, a member of class OclConditionTransfer.


OclConditionTransfer.OclConditionTransfer Constructor ()

OclConditionTransfer.OclConditionTransfer Constructor ()
OclConditionTransfer Class Eco.Wcf.Common Namespace See Also
Collapse All
C#
protected OclConditionTransfer();
Remarks

This is OclConditionTransfer, a member of class OclConditionTransfer.

See Also
OclConditionTransfer Class
Eco.Wcf.Common Namespace


OclConditionTransfer.OclConditionTransfer Constructor (OclCondition)

OclConditionTransfer.OclConditionTransfer Constructor (OclCondition)
OclConditionTransfer Class Eco.Wcf.Common Namespace See Also
Collapse All
C#
protected OclConditionTransfer(
    OclCondition org
);
Remarks

This is OclConditionTransfer, a member of class OclConditionTransfer.

See Also
OclConditionTransfer Class
Eco.Wcf.Common Namespace


OclConditionTransfer Properties

OclConditionTransfer Properties
Public Properties
Collapse All

The properties of the OclConditionTransfer class are listed here.

Public Properties
Name | Description
Context | This is Context, a member of class OclConditionTransfer.
Expression | This is Expression, a member of class OclConditionTransfer.


OclConditionTransfer.Context Property

OclConditionTransfer.Context Property
OclConditionTransfer Class Eco.Wcf.Common Namespace See Also
Collapse All
C#
public ObjectIdList Context;
Remarks

This is Context, a member of class OclConditionTransfer.

See Also
OclConditionTransfer Class
Eco.Wcf.Common Namespace


OclConditionTransfer.Expression Property

OclConditionTransfer.Expression Property
OclConditionTransfer Class Eco.Wcf.Common Namespace See Also
Collapse All
C#
public string Expression;
Remarks

This is Expression, a member of class OclConditionTransfer.

See Also
OclConditionTransfer Class
Eco.Wcf.Common Namespace


OptimisticLockingPreconditionTransfer Class

OptimisticLockingPreconditionTransfer Class
Inheritance Hierarchy See Also
Collapse All
C#
public sealed class OptimisticLockingPreconditionTransfer : UpdatePreconditionTransfer;
Remarks

This is class Eco.Wcf.Common.OptimisticLockingPreconditionTransfer.

Inheritance Hierarchy
Eco.Wcf.Common.UpdatePreconditionTransfer
    Eco.Wcf.Common.OptimisticLockingPreconditionTransfer
File

WcfTransportClasses.cs

See Also
Inheritance Hierarchy


OptimisticLockingPreconditionTransfer.OptimisticLockingPreconditionTransfer Constructor

OptimisticLockingPreconditionTransfer.OptimisticLockingPreconditionTransfer Constructor
OptimisticLockingPreconditionTransfer Class Eco.Wcf.Common Namespace See Also
Collapse All
C#
public OptimisticLockingPreconditionTransfer(
    OptimisticLockingPrecondition cond,
    IEcoTypeSystem typeSystem
);
Remarks

This is OptimisticLockingPreconditionTransfer, a member of class OptimisticLockingPreconditionTransfer.

See Also
OptimisticLockingPreconditionTransfer Class
Eco.Wcf.Common Namespace


OptimisticLockingPreconditionTransfer Methods

OptimisticLockingPreconditionTransfer Methods
Public Methods
Collapse All

The methods of the OptimisticLockingPreconditionTransfer class are listed here.

Public Methods
Name | Description
ToPrecondition | This is ToPrecondition, a member of class OptimisticLockingPreconditionTransfer.


OptimisticLockingPreconditionTransfer.ToPrecondition Method

OptimisticLockingPreconditionTransfer.ToPrecondition Method
OptimisticLockingPreconditionTransfer Class Eco.Wcf.Common Namespace See Also
Collapse All
C#
public override UpdatePrecondition ToPrecondition(
    IEcoTypeSystem typeSystem
);
Remarks

This is ToPrecondition, a member of class OptimisticLockingPreconditionTransfer.

See Also
OptimisticLockingPreconditionTransfer Class
Eco.Wcf.Common Namespace


OptimisticLockingPreconditionTransfer Properties

OptimisticLockingPreconditionTransfer Properties
Public Properties
Collapse All

The properties of the OptimisticLockingPreconditionTransfer class are listed here.

Public Properties
Name | Description
Data | This is Data, a member of class OptimisticLockingPreconditionTransfer.


OptimisticLockingPreconditionTransfer.Data Property

OptimisticLockingPreconditionTransfer.Data Property
OptimisticLockingPreconditionTransfer Class Eco.Wcf.Common Namespace See Also
Collapse All
C#
public string Data;
Remarks

This is Data, a member of class OptimisticLockingPreconditionTransfer.

See Also
OptimisticLockingPreconditionTransfer Class
Eco.Wcf.Common Namespace


TimestampedDefaultIdTransfer Class

TimestampedDefaultIdTransfer Class
Inheritance Hierarchy See Also
Collapse All
C#
public class TimestampedDefaultIdTransfer : DefaultIdTransfer;
Remarks

This is class Eco.Wcf.Common.TimestampedDefaultIdTransfer.

Inheritance Hierarchy
Eco.Wcf.Common.ObjectIdTransfer
    Eco.Wcf.Common.DefaultIdTransfer
        Eco.Wcf.Common.TimestampedDefaultIdTransfer
File

WcfTransportClasses.cs

See Also
Inheritance Hierarchy


TimestampedDefaultIdTransfer.TimestampedDefaultIdTransfer Constructor

TimestampedDefaultIdTransfer.TimestampedDefaultIdTransfer Constructor
TimestampedDefaultIdTransfer Class Eco.Wcf.Common Namespace See Also
Collapse All
C#
public TimestampedDefaultIdTransfer(
    TimestampedDefaultId id
);
Remarks

This is TimestampedDefaultIdTransfer, a member of class TimestampedDefaultIdTransfer.

See Also
TimestampedDefaultIdTransfer Class
Eco.Wcf.Common Namespace


TimestampedDefaultIdTransfer Methods

TimestampedDefaultIdTransfer Methods
Public Methods
Collapse All

The methods of the TimestampedDefaultIdTransfer class are listed here.

Public Methods
Name | Description
ToId | This is ToId, a member of class TimestampedDefaultIdTransfer.


TimestampedDefaultIdTransfer.ToId Method

TimestampedDefaultIdTransfer.ToId Method
TimestampedDefaultIdTransfer Class Eco.Wcf.Common Namespace See Also
Collapse All
C#
public override ObjectId ToId();
Remarks

This is ToId, a member of class TimestampedDefaultIdTransfer.

See Also
TimestampedDefaultIdTransfer Class
Eco.Wcf.Common Namespace


TimestampedDefaultIdTransfer Properties

TimestampedDefaultIdTransfer Properties
Public Properties
Collapse All

The properties of the TimestampedDefaultIdTransfer class are listed here.

Public Properties
Name | Description
TimeStamp | This is TimeStamp, a member of class TimestampedDefaultIdTransfer.


TimestampedDefaultIdTransfer.TimeStamp Property

TimestampedDefaultIdTransfer.TimeStamp Property
TimestampedDefaultIdTransfer Class Eco.Wcf.Common Namespace See Also
Collapse All
C#
public int TimeStamp;
Remarks

This is TimeStamp, a member of class TimestampedDefaultIdTransfer.

See Also
TimestampedDefaultIdTransfer Class
Eco.Wcf.Common Namespace


UpdatePreconditionTransfer Class

UpdatePreconditionTransfer Class
Inheritance Hierarchy See Also
Collapse All
C#
public abstract class UpdatePreconditionTransfer;
Remarks

This is class Eco.Wcf.Common.UpdatePreconditionTransfer.

Inheritance Hierarchy
Eco.Wcf.Common.UpdatePreconditionTransfer
    Eco.Wcf.Common.OptimisticLockingPreconditionTransfer
File

WcfTransportClasses.cs

See Also
Inheritance Hierarchy


UpdatePreconditionTransfer Constructor

UpdatePreconditionTransfer Constructor

This is the overview for the UpdatePreconditionTransfer constructor overload.

Overload List
Name | Description
UpdatePreconditionTransfer.UpdatePreconditionTransfer () | This is UpdatePreconditionTransfer, a member of class UpdatePreconditionTransfer.
UpdatePreconditionTransfer.UpdatePreconditionTransfer (UpdatePrecondition) | This is UpdatePreconditionTransfer, a member of class UpdatePreconditionTransfer.


UpdatePreconditionTransfer.UpdatePreconditionTransfer Constructor ()

UpdatePreconditionTransfer.UpdatePreconditionTransfer Constructor ()
UpdatePreconditionTransfer Class Eco.Wcf.Common Namespace See Also
Collapse All
C#
public UpdatePreconditionTransfer();
Remarks

This is UpdatePreconditionTransfer, a member of class UpdatePreconditionTransfer.

See Also
UpdatePreconditionTransfer Class
Eco.Wcf.Common Namespace


UpdatePreconditionTransfer.UpdatePreconditionTransfer Constructor (UpdatePrecondition)

UpdatePreconditionTransfer.UpdatePreconditionTransfer Constructor (UpdatePrecondition)
UpdatePreconditionTransfer Class Eco.Wcf.Common Namespace See Also
Collapse All
C#
public UpdatePreconditionTransfer(
    UpdatePrecondition condition
);
Remarks

This is UpdatePreconditionTransfer, a member of class UpdatePreconditionTransfer.

See Also
UpdatePreconditionTransfer Class
Eco.Wcf.Common Namespace


UpdatePreconditionTransfer Methods

UpdatePreconditionTransfer Methods
Public Methods
Collapse All

The methods of the UpdatePreconditionTransfer class are listed here.

Public Methods
Name | Description
CreateCondition | This is CreateCondition, a member of class UpdatePreconditionTransfer.
ToPrecondition | This is ToPrecondition, a member of class UpdatePreconditionTransfer.


UpdatePreconditionTransfer.CreateCondition Method

UpdatePreconditionTransfer.CreateCondition Method
UpdatePreconditionTransfer Class Eco.Wcf.Common Namespace See Also
Collapse All
C#
public static UpdatePreconditionTransfer CreateCondition(
    UpdatePrecondition precondition,
    IEcoTypeSystem typeSystem
);
Remarks

This is CreateCondition, a member of class UpdatePreconditionTransfer.

See Also
UpdatePreconditionTransfer Class
Eco.Wcf.Common Namespace


UpdatePreconditionTransfer.ToPrecondition Method

UpdatePreconditionTransfer.ToPrecondition Method
UpdatePreconditionTransfer Class Eco.Wcf.Common Namespace See Also
Collapse All
C#
public abstract UpdatePrecondition ToPrecondition(
    IEcoTypeSystem typeSystem
);
Remarks

This is ToPrecondition, a member of class UpdatePreconditionTransfer.

See Also
UpdatePreconditionTransfer Class
Eco.Wcf.Common Namespace


UpdateResultTransfer Class

UpdateResultTransfer Class
Inheritance Hierarchy See Also
Collapse All
C#
public class UpdateResultTransfer;
Remarks

This is class Eco.Wcf.Common.UpdateResultTransfer.

Inheritance Hierarchy
Eco.Wcf.Common.UpdateResultTransfer
File

WcfTransportClasses.cs

See Also
Inheritance Hierarchy


UpdateResultTransfer Constructor

UpdateResultTransfer Constructor

This is the overview for the UpdateResultTransfer constructor overload.

Overload List
Name | Description
UpdateResultTransfer.UpdateResultTransfer () | This is UpdateResultTransfer, a member of class UpdateResultTransfer.
UpdateResultTransfer.UpdateResultTransfer (UpdateResult) | This is UpdateResultTransfer, a member of class UpdateResultTransfer.


UpdateResultTransfer.UpdateResultTransfer Constructor ()

UpdateResultTransfer.UpdateResultTransfer Constructor ()
UpdateResultTransfer Class Eco.Wcf.Common Namespace See Also
Collapse All
C#
public UpdateResultTransfer();
Remarks

This is UpdateResultTransfer, a member of class UpdateResultTransfer.

See Also
UpdateResultTransfer Class
Eco.Wcf.Common Namespace


UpdateResultTransfer.UpdateResultTransfer Constructor (UpdateResult)

UpdateResultTransfer.UpdateResultTransfer Constructor (UpdateResult)
UpdateResultTransfer Class Eco.Wcf.Common Namespace See Also
Collapse All
C#
public UpdateResultTransfer(
    UpdateResult res
);
Remarks

This is UpdateResultTransfer, a member of class UpdateResultTransfer.

See Also
UpdateResultTransfer Class
Eco.Wcf.Common Namespace


UpdateResultTransfer Methods

UpdateResultTransfer Methods
Public Methods
Collapse All

The methods of the UpdateResultTransfer class are listed here.

Public Methods
Name | Description
ToUpdateResult | This is ToUpdateResult, a member of class UpdateResultTransfer.


UpdateResultTransfer.ToUpdateResult Method

UpdateResultTransfer.ToUpdateResult Method
UpdateResultTransfer Class Eco.Wcf.Common Namespace See Also
Collapse All
C#
public UpdateResult ToUpdateResult();
Remarks

This is ToUpdateResult, a member of class UpdateResultTransfer.

See Also
UpdateResultTransfer Class
Eco.Wcf.Common Namespace


IPersistenceMapperWCF Interface

IPersistenceMapperWCF Interface
Inheritance Hierarchy See Also
Collapse All
C#
public interface IPersistenceMapperWCF;
Remarks

This is class Eco.Wcf.Common.IPersistenceMapperWCF.

Inheritance Hierarchy
Eco.Wcf.Common.IPersistenceMapperWCF
File

IPersistenceMapperWCF.cs

See Also
Inheritance Hierarchy


IPersistenceMapperWCF Methods

IPersistenceMapperWCF Methods
Public Methods
Collapse All

The methods of the IPersistenceMapperWCF class are listed here.

Public Methods
Name | Description
CurrentSyncVersion | This is CurrentSyncVersion, a member of class IPersistenceMapperWCF.
Fetch | This is Fetch, a member of class IPersistenceMapperWCF.
FetchIDListWithCondition | This is FetchIDListWithCondition, a member of class IPersistenceMapperWCF.
GetChangesSince | This is GetChangesSince, a member of class IPersistenceMapperWCF.
SupportsSync | This is SupportsSync, a member of class IPersistenceMapperWCF.
TimeForVersion | This is TimeForVersion, a member of class IPersistenceMapperWCF.
Update | This is Update, a member of class IPersistenceMapperWCF.
VersionForTime | This is VersionForTime, a member of class IPersistenceMapperWCF.


IPersistenceMapperWCF.CurrentSyncVersion Method

IPersistenceMapperWCF.CurrentSyncVersion Method
IPersistenceMapperWCF Interface Eco.Wcf.Common Namespace See Also
Collapse All
C#
SyncVersion CurrentSyncVersion();
Remarks

This is CurrentSyncVersion, a member of class IPersistenceMapperWCF.

See Also
IPersistenceMapperWCF Interface
Eco.Wcf.Common Namespace


IPersistenceMapperWCF.Fetch Method

IPersistenceMapperWCF.Fetch Method
IPersistenceMapperWCF Interface Eco.Wcf.Common Namespace See Also
Collapse All
C#
void Fetch(
    ObjectIdListTransfer idList,
    out DatablockTransfer datablock,
    int[] memberIdList,
    FetchStrategy fetchStrategy
);
Remarks

This is Fetch, a member of class IPersistenceMapperWCF.

See Also
IPersistenceMapperWCF Interface
Eco.Wcf.Common Namespace


IPersistenceMapperWCF.FetchIDListWithCondition Method

IPersistenceMapperWCF.FetchIDListWithCondition Method
IPersistenceMapperWCF Interface Eco.Wcf.Common Namespace See Also
Collapse All
C#
void FetchIDListWithCondition(
    AbstractConditionTransfer condition,
    out ObjectIdListTransfer result,
    int maxResults,
    int offset
);
Remarks

This is FetchIDListWithCondition, a member of class IPersistenceMapperWCF.

See Also
IPersistenceMapperWCF Interface
Eco.Wcf.Common Namespace


IPersistenceMapperWCF.GetChangesSince Method

IPersistenceMapperWCF.GetChangesSince Method
IPersistenceMapperWCF Interface Eco.Wcf.Common Namespace See Also
Collapse All
C#
void GetChangesSince(
    SyncVersion syncVersion,
    SyncVersion[] excludeList,
    out DBChangeCollectionTransfer changes,
    out SyncVersion lastSyncVersion
);
Remarks

This is GetChangesSince, a member of class IPersistenceMapperWCF.

See Also
IPersistenceMapperWCF Interface
Eco.Wcf.Common Namespace


IPersistenceMapperWCF.SupportsSync Method

IPersistenceMapperWCF.SupportsSync Method
IPersistenceMapperWCF Interface Eco.Wcf.Common Namespace See Also
Collapse All
C#
bool SupportsSync();
Remarks

This is SupportsSync, a member of class IPersistenceMapperWCF.

See Also
IPersistenceMapperWCF Interface
Eco.Wcf.Common Namespace


IPersistenceMapperWCF.TimeForVersion Method

IPersistenceMapperWCF.TimeForVersion Method
IPersistenceMapperWCF Interface Eco.Wcf.Common Namespace See Also
Collapse All
C#
void TimeForVersion(
    int version,
    out DateTime clockTime
);
Remarks

This is TimeForVersion, a member of class IPersistenceMapperWCF.

See Also
IPersistenceMapperWCF Interface
Eco.Wcf.Common Namespace


IPersistenceMapperWCF.Update Method

IPersistenceMapperWCF.Update Method
IPersistenceMapperWCF Interface Eco.Wcf.Common Namespace See Also
Collapse All
C#
void Update(
    DatablockTransfer datablock,
    UpdatePreconditionTransfer precondition,
    out IdTranslationListTransfer translationList,
    out int version,
    out SyncVersion syncVersion,
    out UpdateResultTransfer result
);
Remarks

This is Update, a member of class IPersistenceMapperWCF.

See Also
IPersistenceMapperWCF Interface
Eco.Wcf.Common Namespace


IPersistenceMapperWCF.VersionForTime Method

IPersistenceMapperWCF.VersionForTime Method
IPersistenceMapperWCF Interface Eco.Wcf.Common Namespace See Also
Collapse All
C#
void VersionForTime(
    DateTime clockTime,
    out int version
);
Remarks

This is VersionForTime, a member of class IPersistenceMapperWCF.

See Also
IPersistenceMapperWCF Interface
Eco.Wcf.Common Namespace


Eco.Wcf.Server Namespace

Eco.Wcf.Server Namespace
Classes
Collapse All

This is namespace Eco.Wcf.Server.

Classes
Name | Description
PersistenceMapperProviderWCF | This is class Eco.Wcf.Server.PersistenceMapperProviderWCF.


PersistenceMapperProviderWCF Class

PersistenceMapperProviderWCF Class
Inheritance Hierarchy See Also
Collapse All
C#
public class PersistenceMapperProviderWCF<T> : IPersistenceMapperWCF where T : Eco.Persistence.PersistenceMapperProvider;
Remarks

This is class Eco.Wcf.Server.PersistenceMapperProviderWCF.

Inheritance Hierarchy
Eco.Wcf.Server.PersistenceMapperProviderWCF
File

PersistenceMapperProviderWCF.cs

See Also
Inheritance Hierarchy


PersistenceMapperProviderWCF Methods

PersistenceMapperProviderWCF Methods
Public Methods
Collapse All

The methods of the PersistenceMapperProviderWCF class are listed here.

Public Methods
Name | Description
Register | This is the overview for the Register method overload.


Register Method

Register Method

This is the overview for the Register method overload.

Overload List
Name | Description
PersistenceMapperProviderWCF.Register () | This is Register, a member of class PersistenceMapperProviderWCF.
PersistenceMapperProviderWCF.Register (string, string) | This is Register, a member of class PersistenceMapperProviderWCF.


PersistenceMapperProviderWCF.Register Method ()

PersistenceMapperProviderWCF.Register Method ()
PersistenceMapperProviderWCF Class Eco.Wcf.Server Namespace See Also
Collapse All
C#
public static void Register();
Remarks

This is Register, a member of class PersistenceMapperProviderWCF.

See Also
PersistenceMapperProviderWCF Class
Eco.Wcf.Server Namespace


PersistenceMapperProviderWCF.Register Method (string, string)

PersistenceMapperProviderWCF.Register Method (string, string)
PersistenceMapperProviderWCF Class Eco.Wcf.Server Namespace See Also
Collapse All
C#
public static void Register(
    string uri,
    string service
);
Remarks

This is Register, a member of class PersistenceMapperProviderWCF.

See Also
PersistenceMapperProviderWCF Class
Eco.Wcf.Server Namespace


Eco.Web Namespace

Eco.Web Namespace
Classes Enumerations
Collapse All

This is namespace Eco.Web.

Classes
Name | Description
ActionExecutor | A helper class used mainly by Eco.Web.AutoForm.
AutoForm | Superclass of ECO web autoforms
AutoFormDataGrid | This is class Eco.Web.AutoFormDataGrid.
CheckBoxAsBooleanBinding | Summary description for CheckBoxAsBooleanBinding.
ControlBuilder | Summary description for Class.
EcoAspListActionExtender | EcoAspListActionExtender extends ASP-buttons with a new property EcoListAction. This allows code free execution of common things to do in an EcoSpace. Currently only AddNew is supported.
EcoCssClassNames | Names for css classes
EcoPropertyBinding | Summary description for EcoPropertyBinding.
EcoQueryVariableNames | Names for css classes
EcoSpaceStrategyHandler | The EcoSpaceStrategyHandler is responsible for serving the ecospaces to pages
MethodButtonBinding | Summary description for MethodButtonBinding.
MethodCallBuilder | Summary description for MethodCallBuilder.
MultiLinkBuilder | Summary description for MultiLinkBuilder.
Navigator | Navigator
ParameterBinding | Summary description for ParameterBinding.
StatePageBuilder | This class builds controls representing the state machines of a type on a surface. It is used by the DefaultAutoForm/> but can be used stand alone if there is need to quickly get a UI representations of an object's state machine and valid transitions.
TextBoxAsAttributeBinding | Summary description for Class.
TriggerControlsRefresher | This is class Eco.Web.TriggerControlsRefresher.
WebStringRes | Autogenerated class to get compiler safe access to resource strings.
WebUtils | Summary description for WebUtils.
Top
Enumerations
Name | Description
EcoPropertyType | This is record Eco.Web.EcoPropertyType.
ListAction | Enum for available actions.


ActionExecutor Class

ActionExecutor Class
Inheritance Hierarchy See Also
Collapse All

A helper class used mainly by Eco.Web.AutoForm.

C#
public class ActionExecutor;
Inheritance Hierarchy
Eco.Web.ActionExecutor
File

ActionExecutor.cs

See Also
Inheritance Hierarchy


ActionExecutor Methods

ActionExecutor Methods
Public Methods
Collapse All

The methods of the ActionExecutor class are listed here.

Public Methods
Name | Description
CreateObject | Creates an instance of the specified class name.
Delete | This is the overview for the Delete method overload.
Link | Links an object to an association end.
LinkMulti | Links an object to a multi-role.
LinkSingle | Links an object to a single role.
Unlink | Unlinks an object from an association end.
UnlinkMulti | Unlinks an object from a multi-role.
UnlinkSingle | Unlinks an object from a single-role


ActionExecutor.CreateObject Method

ActionExecutor.CreateObject Method
ActionExecutor Class Eco.Web Namespace See Also
Collapse All

Creates an instance of the specified class name.

C#
public static IObject CreateObject(
    EcoSpace ecoSpace,
    string className,
    bool save
);
Parameters
Parameters | Description
ecoSpace | The EcoSpace that will own the newly created object instance.
className | The modeled name of the class to create an instance of.
save | If true then IPersistenceService.UpdateDatabaseWithList as extracted from the ecoSpace parameter will be used to immediately persist the new object instance.
Returns

An Eco.ObjectRepresentation.IObject which may be used to retrieve the newly created object.

Exceptions
Exceptions | Description
ArgumentNullException | Thrown if ecoSpace is null.
See Also
ActionExecutor Class
Eco.Web Namespace


Delete Method

Delete Method

This is the overview for the Delete method overload.

Overload List
Name | Description
ActionExecutor.Delete (EcoSpace, IObject) | Marks the specified object for deletion.
ActionExecutor.Delete (EcoSpace, string) | Marks the specified object for deletion.


ActionExecutor.Delete Method (EcoSpace, IObject)

ActionExecutor.Delete Method (EcoSpace, IObject)
ActionExecutor Class Eco.Web Namespace See Also
Collapse All

Marks the specified object for deletion.

C#
public static void Delete(
    EcoSpace ecoSpace,
    IObject obj
);
Parameters
Parameters | Description
ecoSpace | The EcoSpace that owns the object to be deleted.
obj | The Eco.ObjectRepresentation.IObject identifying the object to delete.
Exceptions
Exceptions | Description
ArgumentNullException | Thrown if obj is null.
See Also
ActionExecutor Class
Eco.Web Namespace


ActionExecutor.Delete Method (EcoSpace, string)

ActionExecutor.Delete Method (EcoSpace, string)
ActionExecutor Class Eco.Web Namespace See Also
Collapse All

Marks the specified object for deletion.

C#
public static void Delete(
    EcoSpace ecoSpace,
    string deleteId
);
Parameters
Parameters | Description
ecoSpace | The EcoSpace to use to retrieve the object instance and delete it.
deleteId | The External ID of the object to delete.
See Also
ActionExecutor Class
Eco.Web Namespace


ActionExecutor.Link Method

ActionExecutor.Link Method
ActionExecutor Class Eco.Web Namespace See Also
Collapse All

Links an object to an association end.

C#
public static void Link(
    EcoSpace ecoSpace,
    IObject obj,
    int propertyIndex,
    string linkId
);
Parameters
Parameters | Description
ecoSpace | The EcoSpace owning the object.
obj | The object to add to the association end.
propertyIndex | The index of the object's Eco.ObjectRepresentation.IProperty to modify.
linkId | The external ID of the object to add to the property.
Remarks

If the propertyIndex identifies a single role then LinkSingle will be used to associate the objects, otherwise LinkMulti will be used.

Exceptions
Exceptions | Description
ArgumentNullException | Thrown if obj is null.
See Also
ActionExecutor Class
Eco.Web Namespace


ActionExecutor.LinkMulti Method

ActionExecutor.LinkMulti Method
ActionExecutor Class Eco.Web Namespace See Also
Collapse All

Links an object to a multi-role.

C#
public static void LinkMulti(
    IObjectList list,
    IObject unlinked
);
Parameters
Parameters | Description
list | The list to add the specified object to.
unlinked | The object to add to the list.
Exceptions
Exceptions | Description
ArgumentNullException | Thrown if list is null.
See Also
ActionExecutor Class
Eco.Web Namespace


ActionExecutor.LinkSingle Method

ActionExecutor.LinkSingle Method
ActionExecutor Class Eco.Web Namespace See Also
Collapse All

Links an object to a single role.

C#
public static void LinkSingle(
    IProperty prop,
    IObject unlinked
);
Parameters
Parameters | Description
prop | Identifies the property to set to the specified object.
unlinked | The object to set the property value to.
Exceptions
Exceptions | Description
ArgumentNullException | Thrown if prop is null.
See Also
ActionExecutor Class
Eco.Web Namespace


ActionExecutor.Unlink Method

ActionExecutor.Unlink Method
ActionExecutor Class Eco.Web Namespace See Also
Collapse All

Unlinks an object from an association end.

C#
public static void Unlink(
    EcoSpace ecoSpace,
    IObject obj,
    int propertyIndex,
    string unlinkId
);
Parameters
Parameters | Description
ecoSpace | The EcoSpace owning the object.
obj | The object owning the property to be modified.
propertyIndex | The index of the object's Eco.ObjectRepresentation.IProperty to modify.
unlinkId | The external ID of the object to remove from the property.
Remarks

If the propertyIndex identifies a single role then UnlinkSingle will be used to unlink the objects, otherwise UnlinkMulti will be used.

Exceptions
Exceptions | Description
ArgumentNullException | Thrown if obj is null.
See Also
ActionExecutor Class
Eco.Web Namespace


ActionExecutor.UnlinkMulti Method

ActionExecutor.UnlinkMulti Method
ActionExecutor Class Eco.Web Namespace See Also
Collapse All

Unlinks an object from a multi-role.

C#
public static void UnlinkMulti(
    IObjectList list,
    IObject linked
);
Parameters
Parameters | Description
list | The list from which to remove the specified object.
linked | The object to remove from the list.
Exceptions
Exceptions | Description
ArgumentNullException | Thrown if list is null.
See Also
ActionExecutor Class
Eco.Web Namespace


ActionExecutor.UnlinkSingle Method

ActionExecutor.UnlinkSingle Method
ActionExecutor Class Eco.Web Namespace See Also
Collapse All

Unlinks an object from a single-role

C#
public static void UnlinkSingle(
    IProperty prop,
    IObject linked
);
Parameters
Parameters | Description
prop | Identifies the property to set to null.
linked | Reserved for future use.
Exceptions
Exceptions | Description
ArgumentNullException | Thrown if prop is null.
See Also
ActionExecutor Class
Eco.Web Namespace


AutoForm Class

AutoForm Class
Inheritance Hierarchy See Also
Collapse All

Superclass of ECO web autoforms

C#
public class AutoForm : System.Web.UI.Page;
Inheritance Hierarchy
Eco.Web.AutoForm
File

AutoForm.cs

See Also
Inheritance Hierarchy


AutoForm Methods

AutoForm Methods
Protected Methods Public Methods
Collapse All

The methods of the AutoForm class are listed here.

Protected Methods
Name | Description
DoneWithEcoSpace | This is DoneWithEcoSpace, a member of class AutoForm.
OnInit | This is OnInit, a member of class AutoForm.
RetrieveEcoSpace | This is RetrieveEcoSpace, a member of class AutoForm.
Top
Public Methods
Name | Description
DataBind | This is DataBind, a member of class AutoForm.
RefreshPropertyControls | This is RefreshPropertyControls, a member of class AutoForm.
SetMethodButtonsEnabledStatus | This is SetMethodButtonsEnabledStatus, a member of class AutoForm.
ShowMessage | This is ShowMessage, a member of class AutoForm.
UpdateDatabase | This is UpdateDatabase, a member of class AutoForm.


AutoForm.DataBind Method

AutoForm.DataBind Method
AutoForm Class Eco.Web Namespace See Also
Collapse All
C#
public override void DataBind();
Remarks

This is DataBind, a member of class AutoForm.

See Also
AutoForm Class
Eco.Web Namespace


AutoForm.DoneWithEcoSpace Method

AutoForm.DoneWithEcoSpace Method
AutoForm Class Eco.Web Namespace See Also
Collapse All
C#
protected virtual void DoneWithEcoSpace();
Remarks

This is DoneWithEcoSpace, a member of class AutoForm.

See Also
AutoForm Class
Eco.Web Namespace


AutoForm.OnInit Method

AutoForm.OnInit Method
AutoForm Class Eco.Web Namespace See Also
Collapse All
C#
protected override void OnInit(
    EventArgs e
);
Remarks

This is OnInit, a member of class AutoForm.

See Also
AutoForm Class
Eco.Web Namespace


AutoForm.RefreshPropertyControls Method

AutoForm.RefreshPropertyControls Method
AutoForm Class Eco.Web Namespace See Also
Collapse All
C#
public void RefreshPropertyControls();
Remarks

This is RefreshPropertyControls, a member of class AutoForm.

See Also
AutoForm Class
Eco.Web Namespace


AutoForm.RetrieveEcoSpace Method

AutoForm.RetrieveEcoSpace Method
AutoForm Class Eco.Web Namespace See Also
Collapse All
C#
protected virtual void RetrieveEcoSpace();
Remarks

This is RetrieveEcoSpace, a member of class AutoForm.

See Also
AutoForm Class
Eco.Web Namespace


AutoForm.SetMethodButtonsEnabledStatus Method

AutoForm.SetMethodButtonsEnabledStatus Method
AutoForm Class Eco.Web Namespace See Also
Collapse All
C#
public void SetMethodButtonsEnabledStatus();
Remarks

This is SetMethodButtonsEnabledStatus, a member of class AutoForm.

See Also
AutoForm Class
Eco.Web Namespace


AutoForm.ShowMessage Method

AutoForm.ShowMessage Method
AutoForm Class Eco.Web Namespace See Also
Collapse All
C#
public void ShowMessage(
    string msg
);
Remarks

This is ShowMessage, a member of class AutoForm.

See Also
AutoForm Class
Eco.Web Namespace


AutoForm.UpdateDatabase Method

AutoForm.UpdateDatabase Method
AutoForm Class Eco.Web Namespace See Also
Collapse All
C#
public void UpdateDatabase();
Remarks

This is UpdateDatabase, a member of class AutoForm.

See Also
AutoForm Class
Eco.Web Namespace


AutoForm Properties

AutoForm Properties
Protected Properties
Collapse All

The properties of the AutoForm class are listed here.

Protected Properties
Name | Description
EcoSpace | This is EcoSpace, a member of class AutoForm.
ParentControl | This is ParentControl, a member of class AutoForm.


AutoForm.EcoSpace Property

AutoForm.EcoSpace Property
AutoForm Class Eco.Web Namespace See Also
Collapse All
C#
protected virtual Eco.Handles.EcoSpace EcoSpace;
Remarks

This is EcoSpace, a member of class AutoForm.

See Also
AutoForm Class
Eco.Web Namespace


AutoForm.ParentControl Property

AutoForm.ParentControl Property
AutoForm Class Eco.Web Namespace See Also
Collapse All
C#
protected virtual Control ParentControl;
Remarks

This is ParentControl, a member of class AutoForm.

See Also
AutoForm Class
Eco.Web Namespace


AutoFormDataGrid Class

AutoFormDataGrid Class
Inheritance Hierarchy See Also
Collapse All
C#
public class AutoFormDataGrid : DataGrid;
Remarks

This is class Eco.Web.AutoFormDataGrid.

Inheritance Hierarchy
Eco.Web.AutoFormDataGrid
File

MultiLinkBuilder.cs

See Also
Inheritance Hierarchy


AutoFormDataGrid.AutoFormDataGrid Constructor

AutoFormDataGrid.AutoFormDataGrid Constructor
AutoFormDataGrid Class Eco.Web Namespace See Also
Collapse All
C#
public AutoFormDataGrid(
    EcoSpace es,
    IObjectList list,
    string className,
    HttpRequest request,
    Control host
);
Remarks

This is AutoFormDataGrid, a member of class AutoFormDataGrid.

See Also
AutoFormDataGrid Class
Eco.Web Namespace


AutoFormDataGrid Methods

AutoFormDataGrid Methods
Public Methods
Collapse All

The methods of the AutoFormDataGrid class are listed here.

Public Methods
Name | Description
UpdateList | This is UpdateList, a member of class AutoFormDataGrid.


AutoFormDataGrid.UpdateList Method

AutoFormDataGrid.UpdateList Method
AutoFormDataGrid Class Eco.Web Namespace See Also
Collapse All
C#
public void UpdateList(
    IObjectList list
);
Remarks

This is UpdateList, a member of class AutoFormDataGrid.

See Also
AutoFormDataGrid Class
Eco.Web Namespace


AutoFormDataGrid Properties

AutoFormDataGrid Properties
Public Properties
Collapse All

The properties of the AutoFormDataGrid class are listed here.

Public Properties
Name | Description
ExpressionHandle | This is ExpressionHandle, a member of class AutoFormDataGrid.
Navigator | This is Navigator, a member of class AutoFormDataGrid.


AutoFormDataGrid.ExpressionHandle Property

AutoFormDataGrid.ExpressionHandle Property
AutoFormDataGrid Class Eco.Web Namespace See Also
Collapse All
C#
public ExpressionHandle ExpressionHandle;
Remarks

This is ExpressionHandle, a member of class AutoFormDataGrid.

See Also
AutoFormDataGrid Class
Eco.Web Namespace


AutoFormDataGrid.Navigator Property

AutoFormDataGrid.Navigator Property
AutoFormDataGrid Class Eco.Web Namespace See Also
Collapse All
C#
public Navigator Navigator;
Remarks

This is Navigator, a member of class AutoFormDataGrid.

See Also
AutoFormDataGrid Class
Eco.Web Namespace


CheckBoxAsBooleanBinding Class

CheckBoxAsBooleanBinding Class
Inheritance Hierarchy See Also
Collapse All

Summary description for CheckBoxAsBooleanBinding.

C#
public class CheckBoxAsBooleanBinding : EcoPropertyBinding;
Inheritance Hierarchy
Eco.Web.EcoPropertyBinding
    Eco.Web.CheckBoxAsBooleanBinding
File

CheckBoxAsBooleanBinding.cs

See Also
Inheritance Hierarchy


CheckBoxAsBooleanBinding.CheckBoxAsBooleanBinding Constructor

CheckBoxAsBooleanBinding.CheckBoxAsBooleanBinding Constructor
CheckBoxAsBooleanBinding Class Eco.Web Namespace See Also
Collapse All
C#
public CheckBoxAsBooleanBinding(
    CheckBox cbx,
    CheckBox cbxNull,
    IStructuralFeature sf,
    IObject obj
);
Remarks

This is CheckBoxAsBooleanBinding, a member of class CheckBoxAsBooleanBinding.

See Also
CheckBoxAsBooleanBinding Class
Eco.Web Namespace


CheckBoxAsBooleanBinding Methods

CheckBoxAsBooleanBinding Methods
Public Methods
Collapse All

The methods of the CheckBoxAsBooleanBinding class are listed here.

Public Methods
Name | Description
AppendToFilter | This is AppendToFilter, a member of class CheckBoxAsBooleanBinding.
Apply | This is Apply, a member of class CheckBoxAsBooleanBinding.
Refresh | This is Refresh, a member of class CheckBoxAsBooleanBinding.


CheckBoxAsBooleanBinding.AppendToFilter Method

CheckBoxAsBooleanBinding.AppendToFilter Method
CheckBoxAsBooleanBinding Class Eco.Web Namespace See Also
Collapse All
C#
public override string AppendToFilter();
Remarks

This is AppendToFilter, a member of class CheckBoxAsBooleanBinding.

See Also
CheckBoxAsBooleanBinding Class
Eco.Web Namespace


CheckBoxAsBooleanBinding.Apply Method

CheckBoxAsBooleanBinding.Apply Method
CheckBoxAsBooleanBinding Class Eco.Web Namespace See Also
Collapse All
C#
public override void Apply();
Remarks

This is Apply, a member of class CheckBoxAsBooleanBinding.

See Also
CheckBoxAsBooleanBinding Class
Eco.Web Namespace


CheckBoxAsBooleanBinding.Refresh Method

CheckBoxAsBooleanBinding.Refresh Method
CheckBoxAsBooleanBinding Class Eco.Web Namespace See Also
Collapse All
C#
public override void Refresh();
Remarks

This is Refresh, a member of class CheckBoxAsBooleanBinding.

See Also
CheckBoxAsBooleanBinding Class
Eco.Web Namespace


ControlBuilder Class

ControlBuilder Class
Inheritance Hierarchy See Also
Collapse All

Summary description for Class.

C#
public static class ControlBuilder;
Inheritance Hierarchy
Eco.Web.ControlBuilder
File

ControlBuilder.cs

See Also
Inheritance Hierarchy


ControlBuilder Methods

ControlBuilder Methods
Public Methods
Collapse All

The methods of the ControlBuilder class are listed here.

Public Methods
Name | Description
BuildControl | Builds a control for a member. The actual control depends of the type of the member.
MakeDropDownList | This is MakeDropDownList, a member of class ControlBuilder.
MakeListBox | This is MakeListBox, a member of class ControlBuilder.
MakeNewBoldText | This is MakeNewBoldText, a member of class ControlBuilder.
MakeNewCheckBox | This is the overview for the MakeNewCheckBox method overload.
MakeNewHyperLink | This is MakeNewHyperLink, a member of class ControlBuilder.
MakeNewLabel | This is the overview for the MakeNewLabel method overload.
MakeNewLinkButton | This is MakeNewLinkButton, a member of class ControlBuilder.
MakeNewNbsp | This is MakeNewNbsp, a member of class ControlBuilder.
MakeNewSpace | This is MakeNewSpace, a member of class ControlBuilder.
MakeNewTable | This is MakeNewTable, a member of class ControlBuilder.
MakeNewTableCell | This is MakeNewTableCell, a member of class ControlBuilder.
MakeNewTableRow | This is MakeNewTableRow, a member of class ControlBuilder.
MakeNewTextBox | This is MakeNewTextBox, a member of class ControlBuilder.


ControlBuilder.BuildControl Method

ControlBuilder.BuildControl Method
ControlBuilder Class Eco.Web Namespace See Also
Collapse All

Builds a control for a member. The actual control depends of the type of the member.

C#
public static Control BuildControl(
    string controlName,
    Control hostControl,
    ElementHandle handle,
    string memberName,
    IClassifier classifier,
    bool allowNull,
    bool readOnly
);
Parameters
Parameters | Description
controlName | The name you want to give your control, uniquely identifying it among the controls on the page.
hostControl | The control used as container for created control.
handle | The handle is used for data binding.
memberName | Binding name of member.
classifier | The type of the member.
allowNull | Indicates if the member allows null values.
readOnly | Indicates if the member is readonly.
Exceptions
Exceptions | Description
ArgumentNullException | Thrown if hostControl is null. Thrown if handle is null. Thrown if classifier is null.
See Also
ControlBuilder Class
Eco.Web Namespace


ControlBuilder.MakeDropDownList Method

ControlBuilder.MakeDropDownList Method
ControlBuilder Class Eco.Web Namespace See Also
Collapse All
C#
public static DropDownList MakeDropDownList(
    string name,
    Control host
);
Remarks

This is MakeDropDownList, a member of class ControlBuilder.

See Also
ControlBuilder Class
Eco.Web Namespace


ControlBuilder.MakeListBox Method

ControlBuilder.MakeListBox Method
ControlBuilder Class Eco.Web Namespace See Also
Collapse All
C#
public static ListBox MakeListBox(
    string name,
    Control host
);
Remarks

This is MakeListBox, a member of class ControlBuilder.

See Also
ControlBuilder Class
Eco.Web Namespace


ControlBuilder.MakeNewBoldText Method

ControlBuilder.MakeNewBoldText Method
ControlBuilder Class Eco.Web Namespace See Also
Collapse All
C#
public static void MakeNewBoldText(
    Control host,
    string text
);
Remarks

This is MakeNewBoldText, a member of class ControlBuilder.

See Also
ControlBuilder Class
Eco.Web Namespace


MakeNewCheckBox Method

MakeNewCheckBox Method

This is the overview for the MakeNewCheckBox method overload.

Overload List
Name | Description
ControlBuilder.MakeNewCheckBox (string, Control) | This is MakeNewCheckBox, a member of class ControlBuilder.
ControlBuilder.MakeNewCheckBox (string, Control, IFeature) | This is MakeNewCheckBox, a member of class ControlBuilder.
ControlBuilder.MakeNewCheckBox (string, Control, string) | This is MakeNewCheckBox, a member of class ControlBuilder.


ControlBuilder.MakeNewCheckBox Method (string, Control)

ControlBuilder.MakeNewCheckBox Method (string, Control)
ControlBuilder Class Eco.Web Namespace See Also
Collapse All
C#
public static CheckBox MakeNewCheckBox(
    string name,
    Control host
);
Remarks

This is MakeNewCheckBox, a member of class ControlBuilder.

See Also
ControlBuilder Class
Eco.Web Namespace


ControlBuilder.MakeNewCheckBox Method (string, Control, IFeature)

ControlBuilder.MakeNewCheckBox Method (string, Control, IFeature)
ControlBuilder Class Eco.Web Namespace See Also
Collapse All
C#
public static CheckBox MakeNewCheckBox(
    string name,
    Control host,
    IFeature sf
);
Remarks

This is MakeNewCheckBox, a member of class ControlBuilder.

See Also
ControlBuilder Class
Eco.Web Namespace


ControlBuilder.MakeNewCheckBox Method (string, Control, string)

ControlBuilder.MakeNewCheckBox Method (string, Control, string)
ControlBuilder Class Eco.Web Namespace See Also
Collapse All
C#
public static CheckBox MakeNewCheckBox(
    string name,
    Control host,
    string text
);
Remarks

This is MakeNewCheckBox, a member of class ControlBuilder.

See Also
ControlBuilder Class
Eco.Web Namespace


ControlBuilder.MakeNewHyperLink Method

ControlBuilder.MakeNewHyperLink Method
ControlBuilder Class Eco.Web Namespace See Also
Collapse All
C#
public static HyperLink MakeNewHyperLink(
    string name,
    Control host
);
Remarks

This is MakeNewHyperLink, a member of class ControlBuilder.

See Also
ControlBuilder Class
Eco.Web Namespace


MakeNewLabel Method

MakeNewLabel Method

This is the overview for the MakeNewLabel method overload.

Overload List
Name | Description
ControlBuilder.MakeNewLabel (Control, IFeature) | This is MakeNewLabel, a member of class ControlBuilder.
ControlBuilder.MakeNewLabel (Control, string) | This is MakeNewLabel, a member of class ControlBuilder.


ControlBuilder.MakeNewLabel Method (Control, IFeature)

ControlBuilder.MakeNewLabel Method (Control, IFeature)
ControlBuilder Class Eco.Web Namespace See Also
Collapse All
C#
public static Label MakeNewLabel(
    Control host,
    IFeature sf
);
Remarks

This is MakeNewLabel, a member of class ControlBuilder.

See Also
ControlBuilder Class
Eco.Web Namespace


ControlBuilder.MakeNewLabel Method (Control, string)

ControlBuilder.MakeNewLabel Method (Control, string)
ControlBuilder Class Eco.Web Namespace See Also
Collapse All
C#
public static Label MakeNewLabel(
    Control host,
    string text
);
Remarks

This is MakeNewLabel, a member of class ControlBuilder.

See Also
ControlBuilder Class
Eco.Web Namespace


ControlBuilder.MakeNewLinkButton Method

ControlBuilder.MakeNewLinkButton Method
ControlBuilder Class Eco.Web Namespace See Also
Collapse All
C#
public static LinkButton MakeNewLinkButton(
    string name,
    Control host
);
Remarks

This is MakeNewLinkButton, a member of class ControlBuilder.

See Also
ControlBuilder Class
Eco.Web Namespace


ControlBuilder.MakeNewNbsp Method

ControlBuilder.MakeNewNbsp Method
ControlBuilder Class Eco.Web Namespace See Also
Collapse All
C#
public static void MakeNewNbsp(
    Control host
);
Remarks

This is MakeNewNbsp, a member of class ControlBuilder.

See Also
ControlBuilder Class
Eco.Web Namespace


ControlBuilder.MakeNewSpace Method

ControlBuilder.MakeNewSpace Method
ControlBuilder Class Eco.Web Namespace See Also
Collapse All
C#
public static void MakeNewSpace(
    Control host
);
Remarks

This is MakeNewSpace, a member of class ControlBuilder.

See Also
ControlBuilder Class
Eco.Web Namespace


ControlBuilder.MakeNewTable Method

ControlBuilder.MakeNewTable Method
ControlBuilder Class Eco.Web Namespace See Also
Collapse All
C#
public static Table MakeNewTable(
    string name,
    Control host
);
Remarks

This is MakeNewTable, a member of class ControlBuilder.

See Also
ControlBuilder Class
Eco.Web Namespace


ControlBuilder.MakeNewTableCell Method

ControlBuilder.MakeNewTableCell Method
ControlBuilder Class Eco.Web Namespace See Also
Collapse All
C#
public static TableCell MakeNewTableCell(
    string name,
    TableRow tableRow
);
Remarks

This is MakeNewTableCell, a member of class ControlBuilder.

See Also
ControlBuilder Class
Eco.Web Namespace


ControlBuilder.MakeNewTableRow Method

ControlBuilder.MakeNewTableRow Method
ControlBuilder Class Eco.Web Namespace See Also
Collapse All
C#
public static TableRow MakeNewTableRow(
    string name,
    Table table
);
Remarks

This is MakeNewTableRow, a member of class ControlBuilder.

See Also
ControlBuilder Class
Eco.Web Namespace


ControlBuilder.MakeNewTextBox Method

ControlBuilder.MakeNewTextBox Method
ControlBuilder Class Eco.Web Namespace See Also
Collapse All
C#
public static TextBox MakeNewTextBox(
    string name,
    Control host
);
Remarks

This is MakeNewTextBox, a member of class ControlBuilder.

See Also
ControlBuilder Class
Eco.Web Namespace


EcoAspListActionExtender Class

EcoAspListActionExtender Class
Inheritance Hierarchy See Also
Collapse All

EcoAspListActionExtender extends ASP-buttons with a new property EcoListAction.

This allows code free execution of common things to do in an EcoSpace. Currently only AddNew is supported.

C#
public class EcoAspListActionExtender : System.ComponentModel.Component, System.ComponentModel.IExtenderProvider;
Inheritance Hierarchy
Eco.Web.EcoAspListActionExtender
File

AspListActionExtender.cs

See Also
Inheritance Hierarchy


EcoAspListActionExtender.EcoAspListActionExtender Constructor

EcoAspListActionExtender.EcoAspListActionExtender Constructor
EcoAspListActionExtender Class Eco.Web Namespace See Also
Collapse All

Constructor. Creates an instance of the class.

C#
public EcoAspListActionExtender();
See Also
EcoAspListActionExtender Class
Eco.Web Namespace


EcoAspListActionExtender Methods

EcoAspListActionExtender Methods
Public Methods
Collapse All

The methods of the EcoAspListActionExtender class are listed here.

Public Methods
Name | Description
GetEcoListAction | Getter for EcoListAction
GetRootHandle | Getter for RootHandle
SetEcoListAction | Sets the EcoListAction on the extendee. Also sets caption - if caption has not been changed from a default value and hooks up/removed ImageList and ImageIndex on extendee.
SetRootHandle | Setter for RootHandle


EcoAspListActionExtender.GetEcoListAction Method

EcoAspListActionExtender.GetEcoListAction Method
EcoAspListActionExtender Class Eco.Web Namespace See Also
Collapse All

Getter for EcoListAction

C#
public ListAction GetEcoListAction(
    System.Web.UI.Control control
);
Remarks

[LocalizableCategory("sCategoryEcoListAction")] [LocalizableDescription("sPropertyEcoListAction")]

See Also
EcoAspListActionExtender Class
Eco.Web Namespace


EcoAspListActionExtender.GetRootHandle Method

EcoAspListActionExtender.GetRootHandle Method
EcoAspListActionExtender Class Eco.Web Namespace See Also
Collapse All

Getter for RootHandle

C#
public ElementHandle GetRootHandle(
    System.Web.UI.Control control
);
Remarks

[LocalizableCategory("sCategoryEcoListAction")] [LocalizableDescription("sPropertyRootHandle")]

See Also
EcoAspListActionExtender Class
Eco.Web Namespace


EcoAspListActionExtender.SetEcoListAction Method

EcoAspListActionExtender.SetEcoListAction Method
EcoAspListActionExtender Class Eco.Web Namespace See Also
Collapse All

Sets the EcoListAction on the extendee. Also sets caption - if caption has not been changed from a default value and hooks up/removed ImageList and ImageIndex on extendee.

C#
public void SetEcoListAction(
    System.Web.UI.Control control,
    ListAction value
);
See Also
EcoAspListActionExtender Class
Eco.Web Namespace


EcoAspListActionExtender.SetRootHandle Method

EcoAspListActionExtender.SetRootHandle Method
EcoAspListActionExtender Class Eco.Web Namespace See Also
Collapse All

Setter for RootHandle

C#
public void SetRootHandle(
    System.Web.UI.Control control,
    ElementHandle value
);
See Also
EcoAspListActionExtender Class
Eco.Web Namespace


EcoCssClassNames Class

EcoCssClassNames Class
Inheritance Hierarchy See Also
Collapse All

Names for css classes

C#
public class EcoCssClassNames;
Inheritance Hierarchy
Eco.Web.EcoCssClassNames
File

EcoCssClassNames.cs

See Also
Inheritance Hierarchy


EcoCssClassNames Fields

EcoCssClassNames Fields
Public Fields
Collapse All

The fields of the EcoCssClassNames class are listed here.

Public Fields
Name | Description
EcoAutoFormActionLink | do not localize
EcoAutoFormButton | do not localize
EcoAutoFormControl | do not localize
EcoAutoFormControlCell | do not localize
EcoAutoFormHeaderButton | do not localize
EcoAutoFormHeaderButtonCell | do not localize
EcoAutoFormHeaderCell | do not localize
EcoAutoFormHeaderLabel | do not localize
EcoAutoFormHeaderLabelCell | do not localize
EcoAutoFormLabelCell | do not localize
EcoAutoFormMainTable | do not localize
EcoAutoFormMethodButton | do not localize
EcoAutoFormMultiLinkHeaderCell | do not localize
EcoAutoFormObjectLink | do not localize
EcoAutoFormParameterHeaderCell | do not localize
EcoAutoFormStateTable | do not localize
EcoAutoFormTable | do not localize
EcoAutoFormTitleCell | do not localize


EcoCssClassNames.EcoAutoFormActionLink Field

EcoCssClassNames.EcoAutoFormActionLink Field
EcoCssClassNames Class Eco.Web Namespace See Also
Collapse All
C#
public const string EcoAutoFormActionLink = "EcoAutoFormActionLink";
Remarks

do not localize

See Also
EcoCssClassNames Class
Eco.Web Namespace


EcoCssClassNames.EcoAutoFormButton Field

EcoCssClassNames.EcoAutoFormButton Field
EcoCssClassNames Class Eco.Web Namespace See Also
Collapse All
C#
public const string EcoAutoFormButton = "EcoAutoFormButton";
Remarks

do not localize

See Also
EcoCssClassNames Class
Eco.Web Namespace


EcoCssClassNames.EcoAutoFormControl Field

EcoCssClassNames.EcoAutoFormControl Field
EcoCssClassNames Class Eco.Web Namespace See Also
Collapse All
C#
public const string EcoAutoFormControl = "EcoAutoFormControl";
Remarks

do not localize

See Also
EcoCssClassNames Class
Eco.Web Namespace


EcoCssClassNames.EcoAutoFormControlCell Field

EcoCssClassNames.EcoAutoFormControlCell Field
EcoCssClassNames Class Eco.Web Namespace See Also
Collapse All
C#
public const string EcoAutoFormControlCell = "EcoAutoFormControlCell";
Remarks

do not localize

See Also
EcoCssClassNames Class
Eco.Web Namespace


EcoCssClassNames.EcoAutoFormHeaderButton Field

EcoCssClassNames.EcoAutoFormHeaderButton Field
EcoCssClassNames Class Eco.Web Namespace See Also
Collapse All
C#
public const string EcoAutoFormHeaderButton = "EcoAutoFormHeaderButton";
Remarks

do not localize

See Also
EcoCssClassNames Class
Eco.Web Namespace


EcoCssClassNames.EcoAutoFormHeaderButtonCell Field

EcoCssClassNames.EcoAutoFormHeaderButtonCell Field
EcoCssClassNames Class Eco.Web Namespace See Also
Collapse All
C#
public const string EcoAutoFormHeaderButtonCell = "EcoAutoFormHeaderButtonCell";
Remarks

do not localize

See Also
EcoCssClassNames Class
Eco.Web Namespace


EcoCssClassNames.EcoAutoFormHeaderCell Field

EcoCssClassNames.EcoAutoFormHeaderCell Field
EcoCssClassNames Class Eco.Web Namespace See Also
Collapse All
C#
public const string EcoAutoFormHeaderCell = "EcoAutoFormHeaderCell";
Remarks

do not localize

See Also
EcoCssClassNames Class
Eco.Web Namespace


EcoCssClassNames.EcoAutoFormHeaderLabel Field

EcoCssClassNames.EcoAutoFormHeaderLabel Field
EcoCssClassNames Class Eco.Web Namespace See Also
Collapse All
C#
public const string EcoAutoFormHeaderLabel = "EcoAutoFormHeaderLabel";
Remarks

do not localize

See Also
EcoCssClassNames Class
Eco.Web Namespace


EcoCssClassNames.EcoAutoFormHeaderLabelCell Field

EcoCssClassNames.EcoAutoFormHeaderLabelCell Field
EcoCssClassNames Class Eco.Web Namespace See Also
Collapse All
C#
public const string EcoAutoFormHeaderLabelCell = "EcoAutoFormHeaderLabelCell";
Remarks

do not localize

See Also
EcoCssClassNames Class
Eco.Web Namespace


EcoCssClassNames.EcoAutoFormLabelCell Field

EcoCssClassNames.EcoAutoFormLabelCell Field
EcoCssClassNames Class Eco.Web Namespace See Also
Collapse All
C#
public const string EcoAutoFormLabelCell = "EcoAutoFormLabelCell";
Remarks

do not localize

See Also
EcoCssClassNames Class
Eco.Web Namespace


EcoCssClassNames.EcoAutoFormMainTable Field

EcoCssClassNames.EcoAutoFormMainTable Field
EcoCssClassNames Class Eco.Web Namespace See Also
Collapse All
C#
public const string EcoAutoFormMainTable = "EcoAutoFormMainTable";
Remarks

do not localize

See Also
EcoCssClassNames Class
Eco.Web Namespace


EcoCssClassNames.EcoAutoFormMethodButton Field

EcoCssClassNames.EcoAutoFormMethodButton Field
EcoCssClassNames Class Eco.Web Namespace See Also
Collapse All
C#
public const string EcoAutoFormMethodButton = "EcoAutoFormMethodButton";
Remarks

do not localize

See Also
EcoCssClassNames Class
Eco.Web Namespace


EcoCssClassNames.EcoAutoFormMultiLinkHeaderCell Field

EcoCssClassNames.EcoAutoFormMultiLinkHeaderCell Field
EcoCssClassNames Class Eco.Web Namespace See Also
Collapse All
C#
public const string EcoAutoFormMultiLinkHeaderCell = "EcoAutoFormMultiLinkHeaderCell";
Remarks

do not localize

See Also
EcoCssClassNames Class
Eco.Web Namespace


EcoCssClassNames.EcoAutoFormObjectLink Field

EcoCssClassNames.EcoAutoFormObjectLink Field
EcoCssClassNames Class Eco.Web Namespace See Also
Collapse All
C#
public const string EcoAutoFormObjectLink = "EcoAutoFormObjectLink";
Remarks

do not localize

See Also
EcoCssClassNames Class
Eco.Web Namespace


EcoCssClassNames.EcoAutoFormParameterHeaderCell Field

EcoCssClassNames.EcoAutoFormParameterHeaderCell Field
EcoCssClassNames Class Eco.Web Namespace See Also
Collapse All
C#
public const string EcoAutoFormParameterHeaderCell = "EcoAutoFormParameterHeaderCell";
Remarks

do not localize

See Also
EcoCssClassNames Class
Eco.Web Namespace


EcoCssClassNames.EcoAutoFormStateTable Field

EcoCssClassNames.EcoAutoFormStateTable Field
EcoCssClassNames Class Eco.Web Namespace See Also
Collapse All
C#
public const string EcoAutoFormStateTable = "EcoAutoFormHeaderLabelCell";
Remarks

do not localize

See Also
EcoCssClassNames Class
Eco.Web Namespace


EcoCssClassNames.EcoAutoFormTable Field

EcoCssClassNames.EcoAutoFormTable Field
EcoCssClassNames Class Eco.Web Namespace See Also
Collapse All
C#
public const string EcoAutoFormTable = "EcoAutoFormTable";
Remarks

do not localize

See Also
EcoCssClassNames Class
Eco.Web Namespace


EcoCssClassNames.EcoAutoFormTitleCell Field

EcoCssClassNames.EcoAutoFormTitleCell Field
EcoCssClassNames Class Eco.Web Namespace See Also
Collapse All
C#
public const string EcoAutoFormTitleCell = "EcoAutoFormTitleCell";
Remarks

do not localize

See Also
EcoCssClassNames Class
Eco.Web Namespace


EcoPropertyBinding Class

EcoPropertyBinding Class
Inheritance Hierarchy See Also
Collapse All

Summary description for EcoPropertyBinding.

C#
public abstract class EcoPropertyBinding;
Inheritance Hierarchy
Eco.Web.EcoPropertyBinding
    Eco.Web.CheckBoxAsBooleanBinding
    Eco.Web.TextBoxAsAttributeBinding
File

EcoPropertyBinding.cs

See Also
Inheritance Hierarchy


EcoPropertyBinding Methods

EcoPropertyBinding Methods
Public Methods
Collapse All

The methods of the EcoPropertyBinding class are listed here.

Public Methods
Name | Description
AppendToFilter | This is AppendToFilter, a member of class EcoPropertyBinding.
Apply | This is Apply, a member of class EcoPropertyBinding.
Refresh | This is Refresh, a member of class EcoPropertyBinding.


EcoPropertyBinding.AppendToFilter Method

EcoPropertyBinding.AppendToFilter Method
EcoPropertyBinding Class Eco.Web Namespace See Also
Collapse All
C#
public abstract string AppendToFilter();
Remarks

This is AppendToFilter, a member of class EcoPropertyBinding.

See Also
EcoPropertyBinding Class
Eco.Web Namespace


EcoPropertyBinding.Apply Method

EcoPropertyBinding.Apply Method
EcoPropertyBinding Class Eco.Web Namespace See Also
Collapse All
C#
public abstract void Apply();
Remarks

This is Apply, a member of class EcoPropertyBinding.

See Also
EcoPropertyBinding Class
Eco.Web Namespace


EcoPropertyBinding.Refresh Method

EcoPropertyBinding.Refresh Method
EcoPropertyBinding Class Eco.Web Namespace See Also
Collapse All
C#
public abstract void Refresh();
Remarks

This is Refresh, a member of class EcoPropertyBinding.

See Also
EcoPropertyBinding Class
Eco.Web Namespace


EcoQueryVariableNames Class

EcoQueryVariableNames Class
Inheritance Hierarchy See Also
Collapse All

Names for css classes

C#
public class EcoQueryVariableNames;
Inheritance Hierarchy
Eco.Web.EcoQueryVariableNames
File

EcoQueryVariableNames.cs

See Also
Inheritance Hierarchy


EcoQueryVariableNames Fields

EcoQueryVariableNames Fields
Public Fields
Collapse All

The fields of the EcoQueryVariableNames class are listed here.

Public Fields
Name | Description
Class | do not localize
Collapse | do not localize
Create | do not localize
DeleteId | do not localize
Expand | do not localize
LinkId | do not localize
OwnerId | do not localize
OwnerParameter | do not localize
OwnerProperty | do not localize
RootId | do not localize
UnlinkId | do not localize


EcoQueryVariableNames.Class Field

EcoQueryVariableNames.Class Field
EcoQueryVariableNames Class Eco.Web Namespace See Also
Collapse All
C#
public const string Class = "Class";
Remarks

do not localize

See Also
EcoQueryVariableNames Class
Eco.Web Namespace


EcoQueryVariableNames.Collapse Field

EcoQueryVariableNames.Collapse Field
EcoQueryVariableNames Class Eco.Web Namespace See Also
Collapse All
C#
public const string Collapse = "Collapse";
Remarks

do not localize

See Also
EcoQueryVariableNames Class
Eco.Web Namespace


EcoQueryVariableNames.Create Field

EcoQueryVariableNames.Create Field
EcoQueryVariableNames Class Eco.Web Namespace See Also
Collapse All
C#
public const string Create = "Create";
Remarks

do not localize

See Also
EcoQueryVariableNames Class
Eco.Web Namespace


EcoQueryVariableNames.DeleteId Field

EcoQueryVariableNames.DeleteId Field
EcoQueryVariableNames Class Eco.Web Namespace See Also
Collapse All
C#
public const string DeleteId = "DeleteId";
Remarks

do not localize

See Also
EcoQueryVariableNames Class
Eco.Web Namespace


EcoQueryVariableNames.Expand Field

EcoQueryVariableNames.Expand Field
EcoQueryVariableNames Class Eco.Web Namespace See Also
Collapse All
C#
public const string Expand = "Expand";
Remarks

do not localize

See Also
EcoQueryVariableNames Class
Eco.Web Namespace


EcoQueryVariableNames.LinkId Field

EcoQueryVariableNames.LinkId Field
EcoQueryVariableNames Class Eco.Web Namespace See Also
Collapse All
C#
public const string LinkId = "LinkId";
Remarks

do not localize

See Also
EcoQueryVariableNames Class
Eco.Web Namespace


EcoQueryVariableNames.OwnerId Field

EcoQueryVariableNames.OwnerId Field
EcoQueryVariableNames Class Eco.Web Namespace See Also
Collapse All
C#
public const string OwnerId = "OwnerId";
Remarks

do not localize

See Also
EcoQueryVariableNames Class
Eco.Web Namespace


EcoQueryVariableNames.OwnerParameter Field

EcoQueryVariableNames.OwnerParameter Field
EcoQueryVariableNames Class Eco.Web Namespace See Also
Collapse All
C#
public const string OwnerParameter = "OwnerParameter";
Remarks

do not localize

See Also
EcoQueryVariableNames Class
Eco.Web Namespace


EcoQueryVariableNames.OwnerProperty Field

EcoQueryVariableNames.OwnerProperty Field
EcoQueryVariableNames Class Eco.Web Namespace See Also
Collapse All
C#
public const string OwnerProperty = "OwnerProperty";
Remarks

do not localize

See Also
EcoQueryVariableNames Class
Eco.Web Namespace


EcoQueryVariableNames.RootId Field

EcoQueryVariableNames.RootId Field
EcoQueryVariableNames Class Eco.Web Namespace See Also
Collapse All
C#
public const string RootId = "RootId";
Remarks

do not localize

See Also
EcoQueryVariableNames Class
Eco.Web Namespace


EcoQueryVariableNames.UnlinkId Field

EcoQueryVariableNames.UnlinkId Field
EcoQueryVariableNames Class Eco.Web Namespace See Also
Collapse All
C#
public const string UnlinkId = "UnlinkId";
Remarks

do not localize

See Also
EcoQueryVariableNames Class
Eco.Web Namespace


EcoSpaceStrategyHandler Class

EcoSpaceStrategyHandler Class
Inheritance Hierarchy See Also
Collapse All

The EcoSpaceStrategyHandler is responsible for serving the ecospaces to pages

C#
public class EcoSpaceStrategyHandler;
Remarks

If the strategyhandler is created with SessionStateMode.IfDirty or Always, it will store ecospaces in the Session area. To support serialization of the session state, the object that is actually stored in the session is an EcoSpaceSerializer. This means that the session can be handled InProc, using a central StateServer or persisted to a database.

To control where the session state is stored, modify Web.config like this (for a local StateServer):

Copy Code
    <sessionState
        mode="StateServer"
        stateConnectionString="tcpip=127.0.0.1:42424"
    />

You also need to turn on the "ASP.NET State Service" service on your machine

The recommended solution for scalability is avoid leaving modified objects in the ecospace between pages and store all state in the persistent domain objects instead.

Inheritance Hierarchy
Eco.Web.EcoSpaceStrategyHandler
File

EcoSpaceStrategyHandler.cs

See Also
Inheritance Hierarchy


EcoSpaceStrategyHandler Constructor

EcoSpaceStrategyHandler Constructor

This is the overview for the EcoSpaceStrategyHandler constructor overload.

Overload List
Name | Description
EcoSpaceStrategyHandler.EcoSpaceStrategyHandler (SessionStateMode, Type) |
EcoSpaceStrategyHandler.EcoSpaceStrategyHandler (SessionStateMode, Type, string, bool) |


EcoSpaceStrategyHandler.EcoSpaceStrategyHandler Constructor (SessionStateMode, Type)

EcoSpaceStrategyHandler.EcoSpaceStrategyHandler Constructor (SessionStateMode, Type)
EcoSpaceStrategyHandler Class Eco.Web Namespace See Also
Collapse All
C#
public EcoSpaceStrategyHandler(
    SessionStateMode sessionStateMode,
    Type ecoSpaceType
);
Exceptions
Exceptions | Description
ArgumentNullException | Thrown if ecoSpaceType is null.
See Also
EcoSpaceStrategyHandler Class
Eco.Web Namespace


EcoSpaceStrategyHandler.EcoSpaceStrategyHandler Constructor (SessionStateMode, Type, string, bool)

EcoSpaceStrategyHandler.EcoSpaceStrategyHandler Constructor (SessionStateMode, Type, string, bool)
EcoSpaceStrategyHandler Class Eco.Web Namespace See Also
Collapse All
C#
public EcoSpaceStrategyHandler(
    SessionStateMode sessionStateMode,
    Type ecoSpaceType,
    string sessionStateKey,
    bool usePool
);
Exceptions
Exceptions | Description
ArgumentNullException | Thrown if ecoSpaceType is null.
See Also
EcoSpaceStrategyHandler Class
Eco.Web Namespace


EcoSpaceStrategyHandler Enumerations

EcoSpaceStrategyHandler Enumerations
Enumerations
Collapse All

The enumerations of the EcoSpaceStrategyHandler class are listed here.

Enumerations
Name | Description
SessionStateMode | Enumeration to indicate how The EcoSpace whan be handled when it is returned to the EcoSpaceManager


Eco.Web.EcoSpaceStrategyHandler.SessionStateMode Enumeration

Eco.Web.EcoSpaceStrategyHandler.SessionStateMode Enumeration

Enumeration to indicate how The EcoSpace whan be handled when it is returned to the EcoSpaceManager

C#
public enum SessionStateMode {
  IfDirty,
  HasUnsavedState,
  Always,
  Never
}
Members
Members | Description
IfDirty | Keep the EcoSpace in the session state if it has any dirty objects when it is returned, otherwise return it to the pool.
HasUnsavedState | Keep the EcoSpace in the session state if it has any state that is not saved to the database.
Always | Keep the EcoSpace in the session state for the entire duration of session.
Never | Never keep EcoSpace in Session State.
Remarks

interesting link about sessionstate and webfarms: http://www.eggheadcafe.com/articles/20021016.asp

File

EcoSpaceStrategyHandler.cs


EcoSpaceStrategyHandler Methods

EcoSpaceStrategyHandler Methods
Public Methods
Collapse All

The methods of the EcoSpaceStrategyHandler class are listed here.

Public Methods
Name | Description
ClearSessionState | This is ClearSessionState, a member of class EcoSpaceStrategyHandler.
GetEcoSpace | This is GetEcoSpace, a member of class EcoSpaceStrategyHandler.
GetSessionFreeEcoSpace | This is GetSessionFreeEcoSpace, a member of class EcoSpaceStrategyHandler.
ReturnEcoSpace | This is ReturnEcoSpace, a member of class EcoSpaceStrategyHandler.
ReturnSessionFreeEcoSpace | This is ReturnSessionFreeEcoSpace, a member of class EcoSpaceStrategyHandler.


EcoSpaceStrategyHandler.ClearSessionState Method

EcoSpaceStrategyHandler.ClearSessionState Method
EcoSpaceStrategyHandler Class Eco.Web Namespace See Also
Collapse All
C#
public void ClearSessionState();
Remarks

This is ClearSessionState, a member of class EcoSpaceStrategyHandler.

See Also
EcoSpaceStrategyHandler Class
Eco.Web Namespace


EcoSpaceStrategyHandler.GetEcoSpace Method

EcoSpaceStrategyHandler.GetEcoSpace Method
EcoSpaceStrategyHandler Class Eco.Web Namespace See Also
Collapse All
C#
public EcoSpace GetEcoSpace();
Remarks

This is GetEcoSpace, a member of class EcoSpaceStrategyHandler.

See Also
EcoSpaceStrategyHandler Class
Eco.Web Namespace


EcoSpaceStrategyHandler.GetSessionFreeEcoSpace Method

EcoSpaceStrategyHandler.GetSessionFreeEcoSpace Method
EcoSpaceStrategyHandler Class Eco.Web Namespace See Also
Collapse All
C#
public EcoSpace GetSessionFreeEcoSpace();
Remarks

This is GetSessionFreeEcoSpace, a member of class EcoSpaceStrategyHandler.

See Also
EcoSpaceStrategyHandler Class
Eco.Web Namespace


EcoSpaceStrategyHandler.ReturnEcoSpace Method

EcoSpaceStrategyHandler.ReturnEcoSpace Method
EcoSpaceStrategyHandler Class Eco.Web Namespace See Also
Collapse All
C#
public void ReturnEcoSpace(
    EcoSpace ecoSpace
);
Remarks

This is ReturnEcoSpace, a member of class EcoSpaceStrategyHandler.

See Also
EcoSpaceStrategyHandler Class
Eco.Web Namespace


EcoSpaceStrategyHandler.ReturnSessionFreeEcoSpace Method

EcoSpaceStrategyHandler.ReturnSessionFreeEcoSpace Method
EcoSpaceStrategyHandler Class Eco.Web Namespace See Also
Collapse All
C#
public void ReturnSessionFreeEcoSpace(
    EcoSpace ecoSpace
);
Remarks

This is ReturnSessionFreeEcoSpace, a member of class EcoSpaceStrategyHandler.

See Also
EcoSpaceStrategyHandler Class
Eco.Web Namespace


MethodButtonBinding Class

MethodButtonBinding Class
Inheritance Hierarchy See Also
Collapse All

Summary description for MethodButtonBinding.

C#
public class MethodButtonBinding;
Inheritance Hierarchy
Eco.Web.MethodButtonBinding
File

MethodButtonBinding.cs

See Also
Inheritance Hierarchy


MethodButtonBinding.MethodButtonBinding Constructor

MethodButtonBinding.MethodButtonBinding Constructor
MethodButtonBinding Class Eco.Web Namespace See Also
Collapse All
C#
public MethodButtonBinding(
    ElementHandle handle,
    IMethod method,
    OclVariables variables,
    Button button,
    EcoSpace ecoSpace
);
Remarks

This is MethodButtonBinding, a member of class MethodButtonBinding.

See Also
MethodButtonBinding Class
Eco.Web Namespace


MethodButtonBinding Methods

MethodButtonBinding Methods
Public Methods
Collapse All

The methods of the MethodButtonBinding class are listed here.

Public Methods
Name | Description
SetButtonEnabledState | This is SetButtonEnabledState, a member of class MethodButtonBinding.


MethodButtonBinding.SetButtonEnabledState Method

MethodButtonBinding.SetButtonEnabledState Method
MethodButtonBinding Class Eco.Web Namespace See Also
Collapse All
C#
public void SetButtonEnabledState();
Remarks

This is SetButtonEnabledState, a member of class MethodButtonBinding.

See Also
MethodButtonBinding Class
Eco.Web Namespace


MethodCallBuilder Class

MethodCallBuilder Class
Inheritance Hierarchy See Also
Collapse All

Summary description for MethodCallBuilder.

C#
public class MethodCallBuilder;
Inheritance Hierarchy
Eco.Web.MethodCallBuilder
File

MethodCallBuilder.cs

See Also
Inheritance Hierarchy


MethodCallBuilder Methods

MethodCallBuilder Methods
Public Methods
Collapse All

The methods of the MethodCallBuilder class are listed here.

Public Methods
Name | Description
BuildControls | This is the overview for the BuildControls method overload.
BuildControlsForMethod | Builds controls for a single method on hostControl.
IsMethodEnabled | This is IsMethodEnabled, a member of class MethodCallBuilder.


BuildControls Method

BuildControls Method

This is the overview for the BuildControls method overload.

Overload List
Name | Description
MethodCallBuilder.BuildControls (Control, EcoSpace, ElementHandle, IClass, Table, IList, AutoForm, HttpResponse, HttpRequest, HttpSessionState) | This is BuildControls, a member of class MethodCallBuilder.
MethodCallBuilder.BuildControls (Control, EcoSpace, ElementHandle, IClass, Table, IList, AutoForm, string, HttpResponse, HttpRequest, HttpSessionState) | Builds controls for the methods of modelElement on hostControl and binds them to the handle.


MethodCallBuilder.BuildControls Method (Control, EcoSpace, ElementHandle, IClass, Table, IList, AutoForm, HttpResponse, HttpRequest, HttpSessionState)

MethodCallBuilder.BuildControls Method (Control, EcoSpace, ElementHandle, IClass, Table, IList, AutoForm, HttpResponse, HttpRequest, HttpSessionState)
MethodCallBuilder Class Eco.Web Namespace See Also
Collapse All
C#
public static void BuildControls(
    Control hostControl,
    EcoSpace ecoSpace,
    ElementHandle handle,
    IClass umlClass,
    Table table,
    IList myMethodBindings,
    AutoForm autoForm,
    HttpResponse response,
    HttpRequest request,
    HttpSessionState session
);
Remarks

This is BuildControls, a member of class MethodCallBuilder.

See Also
MethodCallBuilder Class
Eco.Web Namespace


MethodCallBuilder.BuildControls Method (Control, EcoSpace, ElementHandle, IClass, Table, IList, AutoForm, string, HttpResponse, HttpRequest, HttpSessionState)

MethodCallBuilder.BuildControls Method (Control, EcoSpace, ElementHandle, IClass, Table, IList, AutoForm, string, HttpResponse, HttpRequest, HttpSessionState)
MethodCallBuilder Class Eco.Web Namespace See Also
Collapse All

Builds controls for the methods of modelElement on hostControl and binds them to the handle.

C#
public static void BuildControls(
    Control hostControl,
    EcoSpace ecoSpace,
    ElementHandle handle,
    IClass umlClass,
    Table table,
    IList myMethodBindings,
    AutoForm autoForm,
    string controlPrefix,
    HttpResponse response,
    HttpRequest request,
    HttpSessionState session
);
Parameters
Parameters | Description
hostControl | The control used as container for created controls.
ecoSpace | AutoContainerArgs used when bringing up new autoforms.
handle | The handle is used for data binding.
umlClass | The IModelElement used to get the static information about the methods.
table | The html table taht you want to add controls to.
myMethodBindings | List of bindings between controls and methods.
autoForm | The form responsible for presentation.
controlPrefix | Prefix that will be prepended to the name of your control (used for recursive nestling of state machine regions).
response | The HttpResponse from the asp page.
request | The HttpRequest from the asp page.
session | The HttpSessionState from the asp page.
Exceptions
Exceptions | Description
ArgumentNullException | Thrown if hostControl is null.
See Also
MethodCallBuilder Class
Eco.Web Namespace


MethodCallBuilder.BuildControlsForMethod Method

MethodCallBuilder.BuildControlsForMethod Method
MethodCallBuilder Class Eco.Web Namespace See Also
Collapse All

Builds controls for a single method on hostControl.

C#
public static void BuildControlsForMethod(
    Control hostControl,
    EcoSpace ecoSpace,
    ElementHandle handle,
    IMethod method,
    Table table,
    IList myMethodBindings,
    AutoForm autoForm,
    string controlPrefix,
    HttpResponse response,
    HttpRequest request,
    HttpSessionState session
);
Parameters
Parameters | Description
hostControl | The control used as container for created controls.
ecoSpace | AutoContainerArgs used when bringing up new autoforms.
handle | The handle is used for data binding.
method | The IMethod used to get the static information about the parameters.
table | The html table taht you want to add controls to.
myMethodBindings | List of bindings between controls and methods.
autoForm | The form responsible for presentation.
controlPrefix | Prefix that will be prepended to the name of your control (used for recursive nestling of state machine regions).
response | The HttpResponse from the asp page.
request | The HttpRequest from the asp page.
session | The HttpSessionState from the asp page.
Exceptions
Exceptions | Description
ArgumentNullException | Thrown if hostControl is null.
See Also
MethodCallBuilder Class
Eco.Web Namespace


MethodCallBuilder.IsMethodEnabled Method

MethodCallBuilder.IsMethodEnabled Method
MethodCallBuilder Class Eco.Web Namespace See Also
Collapse All
C#
public static bool IsMethodEnabled(
    ElementHandle handle,
    IMethod method,
    OclVariables variables,
    EcoSpace ecoSpace
);
Remarks

This is IsMethodEnabled, a member of class MethodCallBuilder.

See Also
MethodCallBuilder Class
Eco.Web Namespace


MultiLinkBuilder Class

MultiLinkBuilder Class
Inheritance Hierarchy See Also
Collapse All

Summary description for MultiLinkBuilder.

C#
public class MultiLinkBuilder;
Inheritance Hierarchy
Eco.Web.MultiLinkBuilder
File

MultiLinkBuilder.cs

See Also
Inheritance Hierarchy


MultiLinkBuilder Methods

MultiLinkBuilder Methods
Public Methods
Collapse All

The methods of the MultiLinkBuilder class are listed here.

Public Methods
Name | Description
MakeNewDataGrid | This is the overview for the MakeNewDataGrid method overload.


MakeNewDataGrid Method

MakeNewDataGrid Method

This is the overview for the MakeNewDataGrid method overload.

Overload List
Name | Description
MultiLinkBuilder.MakeNewDataGrid (string, Control, HttpRequest, HttpSessionState, EcoSpace, IObjectList) | This is MakeNewDataGrid, a member of class MultiLinkBuilder.
MultiLinkBuilder.MakeNewDataGrid (string, Control, HttpRequest, HttpSessionState, EcoSpace, IObjectList, string, int, bool, string, IProperty) | This is MakeNewDataGrid, a member of class MultiLinkBuilder.


MultiLinkBuilder.MakeNewDataGrid Method (string, Control, HttpRequest, HttpSessionState, EcoSpace, IObjectList)

MultiLinkBuilder.MakeNewDataGrid Method (string, Control, HttpRequest, HttpSessionState, EcoSpace, IObjectList)
MultiLinkBuilder Class Eco.Web Namespace See Also
Collapse All
C#
public static AutoFormDataGrid MakeNewDataGrid(
    string controlName,
    Control host,
    HttpRequest request,
    HttpSessionState session,
    EcoSpace ecoSpace,
    IObjectList list
);
Remarks

This is MakeNewDataGrid, a member of class MultiLinkBuilder.

See Also
MultiLinkBuilder Class
Eco.Web Namespace


MultiLinkBuilder.MakeNewDataGrid Method (string, Control, HttpRequest, HttpSessionState, EcoSpace, IObjectList, string, int, bool, string, IProperty)

MultiLinkBuilder.MakeNewDataGrid Method (string, Control, HttpRequest, HttpSessionState, EcoSpace, IObjectList, string, int, bool, string, IProperty)
MultiLinkBuilder Class Eco.Web Namespace See Also
Collapse All
C#
public static AutoFormDataGrid MakeNewDataGrid(
    string controlName,
    Control host,
    HttpRequest request,
    HttpSessionState session,
    EcoSpace ecoSpace,
    IObjectList list,
    string ownerId,
    int ownerProperty,
    bool selector,
    string className,
    IProperty prop
);
Remarks

This is MakeNewDataGrid, a member of class MultiLinkBuilder.

See Also
MultiLinkBuilder Class
Eco.Web Namespace


Navigator Class

Navigator Class
Inheritance Hierarchy See Also
Collapse All

Navigator

C#
public class Navigator : System.Web.UI.WebControls.WebControl, INamingContainer;
Inheritance Hierarchy
Eco.Web.Navigator
File

Navigator.cs

See Also
Inheritance Hierarchy


Navigator.Navigator Constructor

Navigator.Navigator Constructor
Navigator Class Eco.Web Namespace See Also
Collapse All
C#
public Navigator();
Remarks

This is Navigator, a member of class Navigator.

See Also
Navigator Class
Eco.Web Namespace


Navigator Methods

Navigator Methods
Protected Methods
Collapse All

The methods of the Navigator class are listed here.

Protected Methods
Name | Description
Render | This is Render, a member of class Navigator.


Navigator.Render Method

Navigator.Render Method
Navigator Class Eco.Web Namespace See Also
Collapse All
C#
protected override void Render(
    HtmlTextWriter writer
);
Remarks

This is Render, a member of class Navigator.

See Also
Navigator Class
Eco.Web Namespace


Navigator Properties

Navigator Properties
Public Properties
Collapse All

The properties of the Navigator class are listed here.

Public Properties
Name | Description
FirstDisabledUrl | This is FirstDisabledUrl, a member of class Navigator.
FirstEnabledUrl | This is FirstEnabledUrl, a member of class Navigator.
FirstItem | FirstItem
ItemCount | ItemCount
ItemsPerPage | ItemsPerPage
LastDisabledUrl | This is LastDisabledUrl, a member of class Navigator.
LastEnabledUrl | This is LastEnabledUrl, a member of class Navigator.
LastItem | LastItem
NextDisabledUrl | This is NextDisabledUrl, a member of class Navigator.
NextEnabledUrl | This is NextEnabledUrl, a member of class Navigator.
PageCount | PageCount
PageNumber | PageNumber
PageQueryString | This is PageQueryString, a member of class Navigator.
PageUrl | This is PageUrl, a member of class Navigator.
PreviousDisabledUrl | This is PreviousDisabledUrl, a member of class Navigator.
PreviousEnabledUrl | This is PreviousEnabledUrl, a member of class Navigator.


Navigator.FirstDisabledUrl Property

Navigator.FirstDisabledUrl Property
Navigator Class Eco.Web Namespace See Also
Collapse All
C#
public string FirstDisabledUrl;
Remarks

This is FirstDisabledUrl, a member of class Navigator.

See Also
Navigator Class
Eco.Web Namespace


Navigator.FirstEnabledUrl Property

Navigator.FirstEnabledUrl Property
Navigator Class Eco.Web Namespace See Also
Collapse All
C#
public string FirstEnabledUrl;
Remarks

This is FirstEnabledUrl, a member of class Navigator.

See Also
Navigator Class
Eco.Web Namespace


Navigator.FirstItem Property

Navigator.FirstItem Property
Navigator Class Eco.Web Namespace See Also
Collapse All
C#
public int FirstItem;
Remarks

FirstItem

See Also
Navigator Class
Eco.Web Namespace


Navigator.ItemCount Property

Navigator.ItemCount Property
Navigator Class Eco.Web Namespace See Also
Collapse All
C#
public int ItemCount;
Remarks

ItemCount

See Also
Navigator Class
Eco.Web Namespace


Navigator.ItemsPerPage Property

Navigator.ItemsPerPage Property
Navigator Class Eco.Web Namespace See Also
Collapse All
C#
public int ItemsPerPage;
Remarks

ItemsPerPage

See Also
Navigator Class
Eco.Web Namespace


Navigator.LastDisabledUrl Property

Navigator.LastDisabledUrl Property
Navigator Class Eco.Web Namespace See Also
Collapse All
C#
public string LastDisabledUrl;
Remarks

This is LastDisabledUrl, a member of class Navigator.

See Also
Navigator Class
Eco.Web Namespace


Navigator.LastEnabledUrl Property

Navigator.LastEnabledUrl Property
Navigator Class Eco.Web Namespace See Also
Collapse All
C#
public string LastEnabledUrl;
Remarks

This is LastEnabledUrl, a member of class Navigator.

See Also
Navigator Class
Eco.Web Namespace


Navigator.LastItem Property

Navigator.LastItem Property
Navigator Class Eco.Web Namespace See Also
Collapse All
C#
public int LastItem;
Remarks

LastItem

See Also
Navigator Class
Eco.Web Namespace


Navigator.NextDisabledUrl Property

Navigator.NextDisabledUrl Property
Navigator Class Eco.Web Namespace See Also
Collapse All
C#
public string NextDisabledUrl;
Remarks

This is NextDisabledUrl, a member of class Navigator.

See Also
Navigator Class
Eco.Web Namespace


Navigator.NextEnabledUrl Property

Navigator.NextEnabledUrl Property
Navigator Class Eco.Web Namespace See Also
Collapse All
C#
public string NextEnabledUrl;
Remarks

This is NextEnabledUrl, a member of class Navigator.

See Also
Navigator Class
Eco.Web Namespace


Navigator.PageCount Property

Navigator.PageCount Property
Navigator Class Eco.Web Namespace See Also
Collapse All
C#
public int PageCount;
Remarks

PageCount

See Also
Navigator Class
Eco.Web Namespace


Navigator.PageNumber Property

Navigator.PageNumber Property
Navigator Class Eco.Web Namespace See Also
Collapse All
C#
public int PageNumber;
Remarks

PageNumber

See Also
Navigator Class
Eco.Web Namespace


Navigator.PageQueryString Property

Navigator.PageQueryString Property
Navigator Class Eco.Web Namespace See Also
Collapse All
C#
public string PageQueryString;
Remarks

This is PageQueryString, a member of class Navigator.

See Also
Navigator Class
Eco.Web Namespace


Navigator.PageUrl Property

Navigator.PageUrl Property
Navigator Class Eco.Web Namespace See Also
Collapse All
C#
public string PageUrl;
Remarks

This is PageUrl, a member of class Navigator.

See Also
Navigator Class
Eco.Web Namespace


Navigator.PreviousDisabledUrl Property

Navigator.PreviousDisabledUrl Property
Navigator Class Eco.Web Namespace See Also
Collapse All
C#
public string PreviousDisabledUrl;
Remarks

This is PreviousDisabledUrl, a member of class Navigator.

See Also
Navigator Class
Eco.Web Namespace


Navigator.PreviousEnabledUrl Property

Navigator.PreviousEnabledUrl Property
Navigator Class Eco.Web Namespace See Also
Collapse All
C#
public string PreviousEnabledUrl;
Remarks

This is PreviousEnabledUrl, a member of class Navigator.

See Also
Navigator Class
Eco.Web Namespace


ParameterBinding Class

ParameterBinding Class
Inheritance Hierarchy See Also
Collapse All

Summary description for ParameterBinding.

C#
public class ParameterBinding;
Inheritance Hierarchy
Eco.Web.ParameterBinding
File

ParameterBinding.cs

See Also
Inheritance Hierarchy


ParameterBinding.ParameterBinding Constructor

ParameterBinding.ParameterBinding Constructor
ParameterBinding Class Eco.Web Namespace See Also
Collapse All
C#
public ParameterBinding(
    Control ctrl,
    OclVariable var
);
Remarks

This is ParameterBinding, a member of class ParameterBinding.

See Also
ParameterBinding Class
Eco.Web Namespace


ParameterBinding Methods

ParameterBinding Methods
Public Methods
Collapse All

The methods of the ParameterBinding class are listed here.

Public Methods
Name | Description
Apply | This is Apply, a member of class ParameterBinding.


ParameterBinding.Apply Method

ParameterBinding.Apply Method
ParameterBinding Class Eco.Web Namespace See Also
Collapse All
C#
public void Apply();
Remarks

This is Apply, a member of class ParameterBinding.

See Also
ParameterBinding Class
Eco.Web Namespace


StatePageBuilder Class

StatePageBuilder Class
Inheritance Hierarchy See Also
Collapse All

This class builds controls representing the state machines of a type on a surface. It is used by the DefaultAutoForm/> but can be used stand alone if there is need to quickly get a UI representations of an object's state machine and valid transitions.

C#
public sealed class StatePageBuilder;
Inheritance Hierarchy
Eco.Web.StatePageBuilder
File

StatePageBuilder.cs

See Also
Inheritance Hierarchy


StatePageBuilder Methods

StatePageBuilder Methods
Public Methods
Collapse All

The methods of the StatePageBuilder class are listed here.

Public Methods
Name | Description
BuildControls | Builds controls representing the state machine of the Element of the handle on hostControl.
BuildRegion |
BuildRegionContainer |


StatePageBuilder.BuildControls Method

StatePageBuilder.BuildControls Method
StatePageBuilder Class Eco.Web Namespace See Also
Collapse All

Builds controls representing the state machine of the Element of the handle on hostControl.

C#
public static TriggerControlsRefresher BuildControls(
    Control hostControl,
    EcoSpace ecoSpace,
    ElementHandle handle,
    Table table,
    IList myMethodBindings,
    AutoForm autoForm,
    string controlPrefix,
    HttpResponse response,
    HttpRequest request,
    HttpSessionState session
);
Parameters
Parameters | Description
hostControl | The control used as container for created controls.
ecoSpace | Used when bringing up new autoforms.
handle | The handle is used for data binding.
table | The html table taht you want to add controls to.
myMethodBindings | List of bindings between controls and methods.
autoForm | The form responsible for presentation.
controlPrefix | Prefix that will be prepended to the name of your control (used for recursive nestling of state machine regions).
response | The HttpResponse from the asp page.
request | The HttpRequest from the asp page.
session | The HttpSessionState from the asp page.
Exceptions
Exceptions | Description
ArgumentNullException | Thrown if hostControl is null. Thrown if handle is null. Thrown if ecoSpace is null.
See Also
StatePageBuilder Class
Eco.Web Namespace


StatePageBuilder.BuildRegion Method

StatePageBuilder.BuildRegion Method
StatePageBuilder Class Eco.Web Namespace See Also
Collapse All
C#
public static void BuildRegion(
    Control hostControl,
    IRegion region,
    EcoSpace ecoSpace,
    ElementHandle handle,
    TableRow tableRow,
    IList myMethodBindings,
    AutoForm autoForm,
    string controlPrefix,
    HttpResponse response,
    HttpRequest request,
    HttpSessionState session
);
Exceptions
Exceptions | Description
ArgumentNullException | Thrown if hostControl is null. Thrown if handle is null. Thrown if region is null.
See Also
StatePageBuilder Class
Eco.Web Namespace


StatePageBuilder.BuildRegionContainer Method

StatePageBuilder.BuildRegionContainer Method
StatePageBuilder Class Eco.Web Namespace See Also
Collapse All
C#
public static void BuildRegionContainer(
    Control hostControl,
    IRegionContainer regionContainer,
    EcoSpace ecoSpace,
    ElementHandle handle,
    Table table,
    IList myMethodBindings,
    AutoForm autoForm,
    string controlPrefix,
    HttpResponse response,
    HttpRequest request,
    HttpSessionState session
);
Exceptions
Exceptions | Description
ArgumentNullException | Thrown if hostControl is null. Thrown if handle is null. Thrown if regionContainer is null.
See Also
StatePageBuilder Class
Eco.Web Namespace


TextBoxAsAttributeBinding Class

TextBoxAsAttributeBinding Class
Inheritance Hierarchy See Also
Collapse All

Summary description for Class.

C#
public class TextBoxAsAttributeBinding : EcoPropertyBinding;
Inheritance Hierarchy
Eco.Web.EcoPropertyBinding
    Eco.Web.TextBoxAsAttributeBinding
File

TextBoxAsAttributeBinding.cs

See Also
Inheritance Hierarchy


TextBoxAsAttributeBinding.TextBoxAsAttributeBinding Constructor

TextBoxAsAttributeBinding.TextBoxAsAttributeBinding Constructor
TextBoxAsAttributeBinding Class Eco.Web Namespace See Also
Collapse All
C#
public TextBoxAsAttributeBinding(
    TextBox tbx,
    IStructuralFeature sf,
    IObject obj
);
Remarks

This is TextBoxAsAttributeBinding, a member of class TextBoxAsAttributeBinding.

See Also
TextBoxAsAttributeBinding Class
Eco.Web Namespace


TextBoxAsAttributeBinding Methods

TextBoxAsAttributeBinding Methods
Public Methods
Collapse All

The methods of the TextBoxAsAttributeBinding class are listed here.

Public Methods
Name | Description
AppendToFilter | This is AppendToFilter, a member of class TextBoxAsAttributeBinding.
Apply | This is Apply, a member of class TextBoxAsAttributeBinding.
Refresh | This is Refresh, a member of class TextBoxAsAttributeBinding.


TextBoxAsAttributeBinding.AppendToFilter Method

TextBoxAsAttributeBinding.AppendToFilter Method
TextBoxAsAttributeBinding Class Eco.Web Namespace See Also
Collapse All
C#
public override string AppendToFilter();
Remarks

This is AppendToFilter, a member of class TextBoxAsAttributeBinding.

See Also
TextBoxAsAttributeBinding Class
Eco.Web Namespace


TextBoxAsAttributeBinding.Apply Method

TextBoxAsAttributeBinding.Apply Method
TextBoxAsAttributeBinding Class Eco.Web Namespace See Also
Collapse All
C#
public override void Apply();
Remarks

This is Apply, a member of class TextBoxAsAttributeBinding.

See Also
TextBoxAsAttributeBinding Class
Eco.Web Namespace


TextBoxAsAttributeBinding.Refresh Method

TextBoxAsAttributeBinding.Refresh Method
TextBoxAsAttributeBinding Class Eco.Web Namespace See Also
Collapse All
C#
public override void Refresh();
Remarks

This is Refresh, a member of class TextBoxAsAttributeBinding.

See Also
TextBoxAsAttributeBinding Class
Eco.Web Namespace


TriggerControlsRefresher Class

TriggerControlsRefresher Class
Inheritance Hierarchy See Also
Collapse All
C#
public sealed class TriggerControlsRefresher;
Remarks

This is class Eco.Web.TriggerControlsRefresher.

Inheritance Hierarchy
Eco.Web.TriggerControlsRefresher
File

StatePageBuilder.cs

See Also
Inheritance Hierarchy


TriggerControlsRefresher.TriggerControlsRefresher Constructor

TriggerControlsRefresher.TriggerControlsRefresher Constructor
TriggerControlsRefresher Class Eco.Web Namespace See Also
Collapse All
C#
public TriggerControlsRefresher(
    Control triggerHost,
    EcoSpace ecoSpace,
    ElementHandle handle
);
Remarks

This is TriggerControlsRefresher, a member of class TriggerControlsRefresher.

See Also
TriggerControlsRefresher Class
Eco.Web Namespace


WebStringRes Class

WebStringRes Class
Inheritance Hierarchy See Also
Collapse All

Autogenerated class to get compiler safe access to resource strings.

C#
public sealed class WebStringRes : StringResources;
Inheritance Hierarchy
Eco.Web.WebStringRes
File

Eco.Web.Strings.cs

See Also
Inheritance Hierarchy


WebStringRes Methods

WebStringRes Methods
Public Methods
Collapse All

The methods of the WebStringRes class are listed here.

Public Methods
Name | Description
EcoSpaceManagerIDCouldNotBeResolved | Returns: "EcoSpaceManagerID ("{0}") could not be resolved to an EcoSpaceManager"
EcoSpaceTypeNameCouldNotBeResolved | Returns: "EcoSpaceTypeName ("{0}") could not be resolved to a type-reference"
sAllObjectsOfClassTitle | Returns: "{0}"
sControlNonVisual | Returns: "Control of type '{0}' is not visual"
sCreateNewOfClass | Returns: "New {0}"
sInfoLabelText | Returns: "Page {0}/{1} - Objects {2}-{3}"
sNoFocusSupport | Returns: "Control of type '{0}' does not support focusing"
sNoSession_Redirect | Returns: "No Session. Use '{0}' instead."
sNoThemingSupport | Returns: "Control of type '{0}' does not support theming"
sNotIdOfEcoSpaceManager | Returns: "EcoSpaceManagerID must be set to the ID of an EcoSpaceManager. There is no EcoSpaceManager with an ID of {0}"
sPageNumberCannotBeGreaterThan | Returns: "PageNumber cannot be greater than {0}"
sSelectedObjectAsString | Returns: "{0}"
sSelectedObjectTitle | Returns: "Object: {0} ({1})"
sUnableToConvert | Returns: "Unable to convert a {0} to a {1}"


WebStringRes.EcoSpaceManagerIDCouldNotBeResolved Method

WebStringRes.EcoSpaceManagerIDCouldNotBeResolved Method
WebStringRes Class Eco.Web Namespace See Also
Collapse All

Returns: "EcoSpaceManagerID ("{0}") could not be resolved to an EcoSpaceManager"

C#
public static string EcoSpaceManagerIDCouldNotBeResolved(
    object param0
);
Remarks

For internal use.

See Also
WebStringRes Class
Eco.Web Namespace


WebStringRes.EcoSpaceTypeNameCouldNotBeResolved Method

WebStringRes.EcoSpaceTypeNameCouldNotBeResolved Method
WebStringRes Class Eco.Web Namespace See Also
Collapse All

Returns: "EcoSpaceTypeName ("{0}") could not be resolved to a type-reference"

C#
public static string EcoSpaceTypeNameCouldNotBeResolved(
    object param0
);
Remarks

For internal use.

See Also
WebStringRes Class
Eco.Web Namespace


WebStringRes.sAllObjectsOfClassTitle Method

WebStringRes.sAllObjectsOfClassTitle Method
WebStringRes Class Eco.Web Namespace See Also
Collapse All

Returns: "{0}"

C#
public static string sAllObjectsOfClassTitle(
    object param0
);
Remarks

For internal use.

See Also
WebStringRes Class
Eco.Web Namespace


WebStringRes.sControlNonVisual Method

WebStringRes.sControlNonVisual Method
WebStringRes Class Eco.Web Namespace See Also
Collapse All

Returns: "Control of type '{0}' is not visual"

C#
public static string sControlNonVisual(
    object param0
);
Remarks

For internal use.

See Also
WebStringRes Class
Eco.Web Namespace


WebStringRes.sCreateNewOfClass Method

WebStringRes.sCreateNewOfClass Method
WebStringRes Class Eco.Web Namespace See Also
Collapse All

Returns: "New {0}"

C#
public static string sCreateNewOfClass(
    object param0
);
Remarks

For internal use.

See Also
WebStringRes Class
Eco.Web Namespace


WebStringRes.sInfoLabelText Method

WebStringRes.sInfoLabelText Method
WebStringRes Class Eco.Web Namespace See Also
Collapse All

Returns: "Page {0}/{1} - Objects {2}-{3}"

C#
public static string sInfoLabelText(
    object param0,
    object param1,
    object param2,
    object param3
);
Remarks

For internal use.

See Also
WebStringRes Class
Eco.Web Namespace


WebStringRes.sNoFocusSupport Method

WebStringRes.sNoFocusSupport Method
WebStringRes Class Eco.Web Namespace See Also
Collapse All

Returns: "Control of type '{0}' does not support focusing"

C#
public static string sNoFocusSupport(
    object param0
);
Remarks

For internal use.

See Also
WebStringRes Class
Eco.Web Namespace


WebStringRes.sNoSession_Redirect Method

WebStringRes.sNoSession_Redirect Method
WebStringRes Class Eco.Web Namespace See Also
Collapse All

Returns: "No Session. Use '{0}' instead."

C#
public static string sNoSession_Redirect(
    object param0
);
Remarks

For internal use.

See Also
WebStringRes Class
Eco.Web Namespace


WebStringRes.sNoThemingSupport Method

WebStringRes.sNoThemingSupport Method
WebStringRes Class Eco.Web Namespace See Also
Collapse All

Returns: "Control of type '{0}' does not support theming"

C#
public static string sNoThemingSupport(
    object param0
);
Remarks

For internal use.

See Also
WebStringRes Class
Eco.Web Namespace


WebStringRes.sNotIdOfEcoSpaceManager Method

WebStringRes.sNotIdOfEcoSpaceManager Method
WebStringRes Class Eco.Web Namespace See Also
Collapse All

Returns: "EcoSpaceManagerID must be set to the ID of an EcoSpaceManager. There is no EcoSpaceManager with an ID of {0}"

C#
public static string sNotIdOfEcoSpaceManager(
    object param0
);
Remarks

For internal use.

See Also
WebStringRes Class
Eco.Web Namespace


WebStringRes.sPageNumberCannotBeGreaterThan Method

WebStringRes.sPageNumberCannotBeGreaterThan Method
WebStringRes Class Eco.Web Namespace See Also
Collapse All

Returns: "PageNumber cannot be greater than {0}"

C#
public static string sPageNumberCannotBeGreaterThan(
    object param0
);
Remarks

For internal use.

See Also
WebStringRes Class
Eco.Web Namespace


WebStringRes.sSelectedObjectAsString Method

WebStringRes.sSelectedObjectAsString Method
WebStringRes Class Eco.Web Namespace See Also
Collapse All

Returns: "{0}"

C#
public static string sSelectedObjectAsString(
    object param0
);
Remarks

For internal use.

See Also
WebStringRes Class
Eco.Web Namespace


WebStringRes.sSelectedObjectTitle Method

WebStringRes.sSelectedObjectTitle Method
WebStringRes Class Eco.Web Namespace See Also
Collapse All

Returns: "Object: {0} ({1})"

C#
public static string sSelectedObjectTitle(
    object param0,
    object param1
);
Remarks

For internal use.

See Also
WebStringRes Class
Eco.Web Namespace


WebStringRes.sUnableToConvert Method

WebStringRes.sUnableToConvert Method
WebStringRes Class Eco.Web Namespace See Also
Collapse All

Returns: "Unable to convert a {0} to a {1}"

C#
public static string sUnableToConvert(
    object param0,
    object param1
);
Remarks

For internal use.

See Also
WebStringRes Class
Eco.Web Namespace


WebStringRes Properties

WebStringRes Properties
Public Properties
Collapse All

The properties of the WebStringRes class are listed here.

Public Properties
Name | Description
ComponentCategoryWeb | Returns: "ECO|Web"
EcoSpaceManagerIDMissing | Returns: "EcoDataSource has no EcoSpaceManagerID"
EcoSpaceTypeNameMissing | Returns: "EcoSpaceManager has no EcoSpaceTypeName"
sAddExisting | Returns: "Add Existing"
sAddNew | Returns: "Add New"
sAllClassesTitle | Returns: "All classes"
sCannotReturnDirtyEcoSpace | Returns: "Can't return Dirty EcoSpace to pool"
sCantChangeTypeEcospaceActive | Returns: "Can't change type when EcoSpace has been provided"
sCategoryBehaviour | Returns: "ECO|Behaviour"
sCategoryBinding | Returns: "ECO|DataBinding"
sCategoryConnections | Returns: "ECO|Connections"
sCategoryData | Returns: "Data"
sCategoryDerivation | Returns: "ECO|Derivation"
sCategoryNesting | Returns: "ECO|Nesting"
sCategoryOCL | Returns: "ECO|OCL"
sCategoryPresentation | Returns: "ECO|Presentation"
sCategoryTypes | Returns: "ECO|Types"
sCreate | Returns: "Create"
sDelete | Returns: "Delete"
sDeleteButtonText | Returns: "Delete Instance"
sDetail | Returns: "Detail"
sEcoSpaceAlreadyInPool | Returns: "EcoSpace already in pool"
sEventDeleted | Returns: "Fires after the Delete operation has finished"
sEventDeleting | Returns: "Fires before the Delete operation is executed"
sEventInserted | Returns: "Fires after the Insert operation has finished"
sEventInserting | Returns: "Fires before the Insert operation is executed"
sEventSelected | Returns: "Fires after the Select operation has finished"
sEventSelecting | Returns: "Fires before the Select operation is executed"
sEventUpdated | Returns: "Fires after the Select operation has finished"
sEventUpdating | Returns: "Fires before the Select operation is executed"
sFilterButtonText | Returns: "Filter"
sFilterHeader | Returns: "Filter"
sFirst | Returns: "First"
sItemCountCannotBeLessThan0 | Returns: "ItemCount cannot be less than 0"
sItemsPerPageCannotBeLessThan1 | Returns: "ItemsPerPage cannot be less than 1"
sKeyAttributesHeader | Returns: "Key Attributes"
sLast | Returns: "Last"
sLink | Returns: "Link"
sMethodsHeader | Returns: "Operations"
sNext | Returns: "Next"
sNoSession | Returns: "No Session"
sNullValue | Returns: "Null"
sOperationCallFailed | Returns: "Operation call failed"
sPageNumberCannotBeLessThan0 | Returns: "PageNumber cannot be less than 0"
sParameters | Returns: "Parameters"
sPrevious | Returns: "Prev"
sPropertiesHeader | Returns: "Attributes"
sPropertyAddDefaultProperties | Returns: "Add the default columns."
sPropertyAddExternalId | Returns: "Add column for external ID."
sPropertyColumns | Returns: "Designed Colums."
sPropertyDeleteMode | Returns: "Behaviour on Delete."
sPropertyEcoSpaceManagerID | Returns: "ID of EcoSpaceManager to component is connected to."
sPropertyEcoSpaceTypeName | Returns: "The name of the type of the EcoSpace to be provided"
sPropertyExpression | Returns: "Ocl Expression evaluated in core, after PsExpression if any."
sPropertyInsertMode | Returns: "Behaviour on Insert."
sPropertyManualUpdate | Returns: "Don't update database automatially after edit/delete/insert."
sPropertyMemberVisibility | Returns: "Filter exposed members based on their visibility."
sPropertyNullRowMode | Returns: "Conditonally add row for 'null' object."
sPropertyParameters | Returns: "Parameters defining OCL variables"
sPropertyPsExpression | Returns: "Ocl Expression evaluated in Database."
sPropertySessionStateKey | Returns: "Key for EcoSpace in Session state"
sPropertySessionStateMode | Returns: "When to save EcoSpace in Session state"
sResultsHeader | Returns: "Results"
sRolesHeader | Returns: "Roles"
sSessionStateContainsDifferentEcoSpace | Returns: "Session state already contains a different EcoSpace"
sSessionStateContainsValueOfWrongType | Returns: "Session state contains value of wrong type"
sShow | Returns: "Show"
sStateMachinesHeader | Returns: "State Machines"
sSubmitButtonText | Returns: "Submit Changes"
sTranslateNullToEmptyString | Returns: "Translate null to empty string."
sUnlink | Returns: "Unlink"
sUsePool | Returns: "Use EcoSpace pool if enabled in Web.config"


WebStringRes.ComponentCategoryWeb Property

WebStringRes.ComponentCategoryWeb Property
WebStringRes Class Eco.Web Namespace See Also
Collapse All

Returns: "ECO|Web"

C#
public static string ComponentCategoryWeb;
Remarks

For internal use.

See Also
WebStringRes Class
Eco.Web Namespace


WebStringRes.EcoSpaceManagerIDMissing Property

WebStringRes.EcoSpaceManagerIDMissing Property
WebStringRes Class Eco.Web Namespace See Also
Collapse All

Returns: "EcoDataSource has no EcoSpaceManagerID"

C#
public static string EcoSpaceManagerIDMissing;
Remarks

For internal use.

See Also
WebStringRes Class
Eco.Web Namespace


WebStringRes.EcoSpaceTypeNameMissing Property

WebStringRes.EcoSpaceTypeNameMissing Property
WebStringRes Class Eco.Web Namespace See Also
Collapse All

Returns: "EcoSpaceManager has no EcoSpaceTypeName"

C#
public static string EcoSpaceTypeNameMissing;
Remarks

For internal use.

See Also
WebStringRes Class
Eco.Web Namespace


WebStringRes.sAddExisting Property

WebStringRes.sAddExisting Property
WebStringRes Class Eco.Web Namespace See Also
Collapse All

Returns: "Add Existing"

C#
public static string sAddExisting;
Remarks

For internal use.

See Also
WebStringRes Class
Eco.Web Namespace


WebStringRes.sAddNew Property

WebStringRes.sAddNew Property
WebStringRes Class Eco.Web Namespace See Also
Collapse All

Returns: "Add New"

C#
public static string sAddNew;
Remarks

For internal use.

See Also
WebStringRes Class
Eco.Web Namespace


WebStringRes.sAllClassesTitle Property

WebStringRes.sAllClassesTitle Property
WebStringRes Class Eco.Web Namespace See Also
Collapse All

Returns: "All classes"

C#
public static string sAllClassesTitle;
Remarks

For internal use.

See Also
WebStringRes Class
Eco.Web Namespace


WebStringRes.sCannotReturnDirtyEcoSpace Property

WebStringRes.sCannotReturnDirtyEcoSpace Property
WebStringRes Class Eco.Web Namespace See Also
Collapse All

Returns: "Can't return Dirty EcoSpace to pool"

C#
public static string sCannotReturnDirtyEcoSpace;
Remarks

For internal use.

See Also
WebStringRes Class
Eco.Web Namespace


WebStringRes.sCantChangeTypeEcospaceActive Property

WebStringRes.sCantChangeTypeEcospaceActive Property
WebStringRes Class Eco.Web Namespace See Also
Collapse All

Returns: "Can't change type when EcoSpace has been provided"

C#
public static string sCantChangeTypeEcospaceActive;
Remarks

For internal use.

See Also
WebStringRes Class
Eco.Web Namespace


WebStringRes.sCategoryBehaviour Property

WebStringRes.sCategoryBehaviour Property
WebStringRes Class Eco.Web Namespace See Also
Collapse All

Returns: "ECO|Behaviour"

C#
public static string sCategoryBehaviour;
Remarks

For internal use.

See Also
WebStringRes Class
Eco.Web Namespace


WebStringRes.sCategoryBinding Property

WebStringRes.sCategoryBinding Property
WebStringRes Class Eco.Web Namespace See Also
Collapse All

Returns: "ECO|DataBinding"

C#
public static string sCategoryBinding;
Remarks

For internal use.

See Also
WebStringRes Class
Eco.Web Namespace


WebStringRes.sCategoryConnections Property

WebStringRes.sCategoryConnections Property
WebStringRes Class Eco.Web Namespace See Also
Collapse All

Returns: "ECO|Connections"

C#
public static string sCategoryConnections;
Remarks

For internal use.

See Also
WebStringRes Class
Eco.Web Namespace


WebStringRes.sCategoryData Property

WebStringRes.sCategoryData Property
WebStringRes Class Eco.Web Namespace See Also
Collapse All

Returns: "Data"

C#
public static string sCategoryData;
Remarks

For internal use.

See Also
WebStringRes Class
Eco.Web Namespace


WebStringRes.sCategoryDerivation Property

WebStringRes.sCategoryDerivation Property
WebStringRes Class Eco.Web Namespace See Also
Collapse All

Returns: "ECO|Derivation"

C#
public static string sCategoryDerivation;
Remarks

For internal use.

See Also
WebStringRes Class
Eco.Web Namespace


WebStringRes.sCategoryNesting Property

WebStringRes.sCategoryNesting Property
WebStringRes Class Eco.Web Namespace See Also
Collapse All

Returns: "ECO|Nesting"

C#
public static string sCategoryNesting;
Remarks

For internal use.

See Also
WebStringRes Class
Eco.Web Namespace


WebStringRes.sCategoryOCL Property

WebStringRes.sCategoryOCL Property
WebStringRes Class Eco.Web Namespace See Also
Collapse All

Returns: "ECO|OCL"

C#
public static string sCategoryOCL;
Remarks

For internal use.

See Also
WebStringRes Class
Eco.Web Namespace


WebStringRes.sCategoryPresentation Property

WebStringRes.sCategoryPresentation Property
WebStringRes Class Eco.Web Namespace See Also
Collapse All

Returns: "ECO|Presentation"

C#
public static string sCategoryPresentation;
Remarks

For internal use.

See Also
WebStringRes Class
Eco.Web Namespace


WebStringRes.sCategoryTypes Property

WebStringRes.sCategoryTypes Property
WebStringRes Class Eco.Web Namespace See Also
Collapse All

Returns: "ECO|Types"

C#
public static string sCategoryTypes;
Remarks

For internal use.

See Also
WebStringRes Class
Eco.Web Namespace


WebStringRes.sCreate Property

WebStringRes.sCreate Property
WebStringRes Class Eco.Web Namespace See Also
Collapse All

Returns: "Create"

C#
public static string sCreate;
Remarks

For internal use.

See Also
WebStringRes Class
Eco.Web Namespace


WebStringRes.sDelete Property

WebStringRes.sDelete Property
WebStringRes Class Eco.Web Namespace See Also
Collapse All

Returns: "Delete"

C#
public static string sDelete;
Remarks

For internal use.

See Also
WebStringRes Class
Eco.Web Namespace


WebStringRes.sDeleteButtonText Property

WebStringRes.sDeleteButtonText Property
WebStringRes Class Eco.Web Namespace See Also
Collapse All

Returns: "Delete Instance"

C#
public static string sDeleteButtonText;
Remarks

For internal use.

See Also
WebStringRes Class
Eco.Web Namespace


WebStringRes.sDetail Property

WebStringRes.sDetail Property
WebStringRes Class Eco.Web Namespace See Also
Collapse All

Returns: "Detail"

C#
public static string sDetail;
Remarks

For internal use.

See Also
WebStringRes Class
Eco.Web Namespace


WebStringRes.sEcoSpaceAlreadyInPool Property

WebStringRes.sEcoSpaceAlreadyInPool Property
WebStringRes Class Eco.Web Namespace See Also
Collapse All

Returns: "EcoSpace already in pool"

C#
public static string sEcoSpaceAlreadyInPool;
Remarks

For internal use.

See Also
WebStringRes Class
Eco.Web Namespace


WebStringRes.sEventDeleted Property

WebStringRes.sEventDeleted Property
WebStringRes Class Eco.Web Namespace See Also
Collapse All

Returns: "Fires after the Delete operation has finished"

C#
public static string sEventDeleted;
Remarks

For internal use.

See Also
WebStringRes Class
Eco.Web Namespace


WebStringRes.sEventDeleting Property

WebStringRes.sEventDeleting Property
WebStringRes Class Eco.Web Namespace See Also
Collapse All

Returns: "Fires before the Delete operation is executed"

C#
public static string sEventDeleting;
Remarks

For internal use.

See Also
WebStringRes Class
Eco.Web Namespace


WebStringRes.sEventInserted Property

WebStringRes.sEventInserted Property
WebStringRes Class Eco.Web Namespace See Also
Collapse All

Returns: "Fires after the Insert operation has finished"

C#
public static string sEventInserted;
Remarks

For internal use.

See Also
WebStringRes Class
Eco.Web Namespace


WebStringRes.sEventInserting Property

WebStringRes.sEventInserting Property
WebStringRes Class Eco.Web Namespace See Also
Collapse All

Returns: "Fires before the Insert operation is executed"

C#
public static string sEventInserting;
Remarks

For internal use.

See Also
WebStringRes Class
Eco.Web Namespace


WebStringRes.sEventSelected Property

WebStringRes.sEventSelected Property
WebStringRes Class Eco.Web Namespace See Also
Collapse All

Returns: "Fires after the Select operation has finished"

C#
public static string sEventSelected;
Remarks

For internal use.

See Also
WebStringRes Class
Eco.Web Namespace


WebStringRes.sEventSelecting Property

WebStringRes.sEventSelecting Property
WebStringRes Class Eco.Web Namespace See Also
Collapse All

Returns: "Fires before the Select operation is executed"

C#
public static string sEventSelecting;
Remarks

For internal use.

See Also
WebStringRes Class
Eco.Web Namespace


WebStringRes.sEventUpdated Property

WebStringRes.sEventUpdated Property
WebStringRes Class Eco.Web Namespace See Also
Collapse All

Returns: "Fires after the Select operation has finished"

C#
public static string sEventUpdated;
Remarks

For internal use.

See Also
WebStringRes Class
Eco.Web Namespace


WebStringRes.sEventUpdating Property

WebStringRes.sEventUpdating Property
WebStringRes Class Eco.Web Namespace See Also
Collapse All

Returns: "Fires before the Select operation is executed"

C#
public static string sEventUpdating;
Remarks

For internal use.

See Also
WebStringRes Class
Eco.Web Namespace


WebStringRes.sFilterButtonText Property

WebStringRes.sFilterButtonText Property
WebStringRes Class Eco.Web Namespace See Also
Collapse All

Returns: "Filter"

C#
public static string sFilterButtonText;
Remarks

For internal use.

See Also
WebStringRes Class
Eco.Web Namespace


WebStringRes.sFilterHeader Property

WebStringRes.sFilterHeader Property
WebStringRes Class Eco.Web Namespace See Also
Collapse All

Returns: "Filter"

C#
public static string sFilterHeader;
Remarks

For internal use.

See Also
WebStringRes Class
Eco.Web Namespace


WebStringRes.sFirst Property

WebStringRes.sFirst Property
WebStringRes Class Eco.Web Namespace See Also
Collapse All

Returns: "First"

C#
public static string sFirst;
Remarks

For internal use.

See Also
WebStringRes Class
Eco.Web Namespace


WebStringRes.sItemCountCannotBeLessThan0 Property

WebStringRes.sItemCountCannotBeLessThan0 Property
WebStringRes Class Eco.Web Namespace See Also
Collapse All

Returns: "ItemCount cannot be less than 0"

C#
public static string sItemCountCannotBeLessThan0;
Remarks

For internal use.

See Also
WebStringRes Class
Eco.Web Namespace


WebStringRes.sItemsPerPageCannotBeLessThan1 Property

WebStringRes.sItemsPerPageCannotBeLessThan1 Property
WebStringRes Class Eco.Web Namespace See Also
Collapse All

Returns: "ItemsPerPage cannot be less than 1"

C#
public static string sItemsPerPageCannotBeLessThan1;
Remarks

For internal use.

See Also
WebStringRes Class
Eco.Web Namespace


WebStringRes.sKeyAttributesHeader Property

WebStringRes.sKeyAttributesHeader Property
WebStringRes Class Eco.Web Namespace See Also
Collapse All

Returns: "Key Attributes"

C#
public static string sKeyAttributesHeader;
Remarks

For internal use.

See Also
WebStringRes Class
Eco.Web Namespace


WebStringRes.sLast Property

WebStringRes.sLast Property
WebStringRes Class Eco.Web Namespace See Also
Collapse All

Returns: "Last"

C#
public static string sLast;
Remarks

For internal use.

See Also
WebStringRes Class
Eco.Web Namespace


WebStringRes.sLink Property

WebStringRes.sLink Property
WebStringRes Class Eco.Web Namespace See Also
Collapse All

Returns: "Link"

C#
public static string sLink;
Remarks

For internal use.

See Also
WebStringRes Class
Eco.Web Namespace


WebStringRes.sMethodsHeader Property

WebStringRes.sMethodsHeader Property
WebStringRes Class Eco.Web Namespace See Also
Collapse All

Returns: "Operations"

C#
public static string sMethodsHeader;
Remarks

For internal use.

See Also
WebStringRes Class
Eco.Web Namespace


WebStringRes.sNext Property

WebStringRes.sNext Property
WebStringRes Class Eco.Web Namespace See Also
Collapse All

Returns: "Next"

C#
public static string sNext;
Remarks

For internal use.

See Also
WebStringRes Class
Eco.Web Namespace


WebStringRes.sNoSession Property

WebStringRes.sNoSession Property
WebStringRes Class Eco.Web Namespace See Also
Collapse All

Returns: "No Session"

C#
public static string sNoSession;
Remarks

For internal use.

See Also
WebStringRes Class
Eco.Web Namespace


WebStringRes.sNullValue Property

WebStringRes.sNullValue Property
WebStringRes Class Eco.Web Namespace See Also
Collapse All

Returns: "Null"

C#
public static string sNullValue;
Remarks

For internal use.

See Also
WebStringRes Class
Eco.Web Namespace


WebStringRes.sOperationCallFailed Property

WebStringRes.sOperationCallFailed Property
WebStringRes Class Eco.Web Namespace See Also
Collapse All

Returns: "Operation call failed"

C#
public static string sOperationCallFailed;
Remarks

For internal use.

See Also
WebStringRes Class
Eco.Web Namespace


WebStringRes.sPageNumberCannotBeLessThan0 Property

WebStringRes.sPageNumberCannotBeLessThan0 Property
WebStringRes Class Eco.Web Namespace See Also
Collapse All

Returns: "PageNumber cannot be less than 0"

C#
public static string sPageNumberCannotBeLessThan0;
Remarks

For internal use.

See Also
WebStringRes Class
Eco.Web Namespace


WebStringRes.sParameters Property

WebStringRes.sParameters Property
WebStringRes Class Eco.Web Namespace See Also
Collapse All

Returns: "Parameters"

C#
public static string sParameters;
Remarks

For internal use.

See Also
WebStringRes Class
Eco.Web Namespace


WebStringRes.sPrevious Property

WebStringRes.sPrevious Property
WebStringRes Class Eco.Web Namespace See Also
Collapse All

Returns: "Prev"

C#
public static string sPrevious;
Remarks

For internal use.

See Also
WebStringRes Class
Eco.Web Namespace


WebStringRes.sPropertiesHeader Property

WebStringRes.sPropertiesHeader Property
WebStringRes Class Eco.Web Namespace See Also
Collapse All

Returns: "Attributes"

C#
public static string sPropertiesHeader;
Remarks

For internal use.

See Also
WebStringRes Class
Eco.Web Namespace


WebStringRes.sPropertyAddDefaultProperties Property

WebStringRes.sPropertyAddDefaultProperties Property
WebStringRes Class Eco.Web Namespace See Also
Collapse All

Returns: "Add the default columns."

C#
public static string sPropertyAddDefaultProperties;
Remarks

For internal use.

See Also
WebStringRes Class
Eco.Web Namespace


WebStringRes.sPropertyAddExternalId Property

WebStringRes.sPropertyAddExternalId Property
WebStringRes Class Eco.Web Namespace See Also
Collapse All

Returns: "Add column for external ID."

C#
public static string sPropertyAddExternalId;
Remarks

For internal use.

See Also
WebStringRes Class
Eco.Web Namespace


WebStringRes.sPropertyColumns Property

WebStringRes.sPropertyColumns Property
WebStringRes Class Eco.Web Namespace See Also
Collapse All

Returns: "Designed Colums."

C#
public static string sPropertyColumns;
Remarks

For internal use.

See Also
WebStringRes Class
Eco.Web Namespace


WebStringRes.sPropertyDeleteMode Property

WebStringRes.sPropertyDeleteMode Property
WebStringRes Class Eco.Web Namespace See Also
Collapse All

Returns: "Behaviour on Delete."

C#
public static string sPropertyDeleteMode;
Remarks

For internal use.

See Also
WebStringRes Class
Eco.Web Namespace


WebStringRes.sPropertyEcoSpaceManagerID Property

WebStringRes.sPropertyEcoSpaceManagerID Property
WebStringRes Class Eco.Web Namespace See Also
Collapse All

Returns: "ID of EcoSpaceManager to component is connected to."

C#
public static string sPropertyEcoSpaceManagerID;
Remarks

For internal use.

See Also
WebStringRes Class
Eco.Web Namespace


WebStringRes.sPropertyEcoSpaceTypeName Property

WebStringRes.sPropertyEcoSpaceTypeName Property
WebStringRes Class Eco.Web Namespace See Also
Collapse All

Returns: "The name of the type of the EcoSpace to be provided"

C#
public static string sPropertyEcoSpaceTypeName;
Remarks

For internal use.

See Also
WebStringRes Class
Eco.Web Namespace


WebStringRes.sPropertyExpression Property

WebStringRes.sPropertyExpression Property
WebStringRes Class Eco.Web Namespace See Also
Collapse All

Returns: "Ocl Expression evaluated in core, after PsExpression if any."

C#
public static string sPropertyExpression;
Remarks

For internal use.

See Also
WebStringRes Class
Eco.Web Namespace


WebStringRes.sPropertyInsertMode Property

WebStringRes.sPropertyInsertMode Property
WebStringRes Class Eco.Web Namespace See Also
Collapse All

Returns: "Behaviour on Insert."

C#
public static string sPropertyInsertMode;
Remarks

For internal use.

See Also
WebStringRes Class
Eco.Web Namespace


WebStringRes.sPropertyManualUpdate Property

WebStringRes.sPropertyManualUpdate Property
WebStringRes Class Eco.Web Namespace See Also
Collapse All

Returns: "Don't update database automatially after edit/delete/insert."

C#
public static string sPropertyManualUpdate;
Remarks

For internal use.

See Also
WebStringRes Class
Eco.Web Namespace


WebStringRes.sPropertyMemberVisibility Property

WebStringRes.sPropertyMemberVisibility Property
WebStringRes Class Eco.Web Namespace See Also
Collapse All

Returns: "Filter exposed members based on their visibility."

C#
public static string sPropertyMemberVisibility;
Remarks

For internal use.

See Also
WebStringRes Class
Eco.Web Namespace


WebStringRes.sPropertyNullRowMode Property

WebStringRes.sPropertyNullRowMode Property
WebStringRes Class Eco.Web Namespace See Also
Collapse All

Returns: "Conditonally add row for 'null' object."

C#
public static string sPropertyNullRowMode;
Remarks

For internal use.

See Also
WebStringRes Class
Eco.Web Namespace


WebStringRes.sPropertyParameters Property

WebStringRes.sPropertyParameters Property
WebStringRes Class Eco.Web Namespace See Also
Collapse All

Returns: "Parameters defining OCL variables"

C#
public static string sPropertyParameters;
Remarks

For internal use.

See Also
WebStringRes Class
Eco.Web Namespace


WebStringRes.sPropertyPsExpression Property

WebStringRes.sPropertyPsExpression Property
WebStringRes Class Eco.Web Namespace See Also
Collapse All

Returns: "Ocl Expression evaluated in Database."

C#
public static string sPropertyPsExpression;
Remarks

For internal use.

See Also
WebStringRes Class
Eco.Web Namespace


WebStringRes.sPropertySessionStateKey Property

WebStringRes.sPropertySessionStateKey Property
WebStringRes Class Eco.Web Namespace See Also
Collapse All

Returns: "Key for EcoSpace in Session state"

C#
public static string sPropertySessionStateKey;
Remarks

For internal use.

See Also
WebStringRes Class
Eco.Web Namespace


WebStringRes.sPropertySessionStateMode Property

WebStringRes.sPropertySessionStateMode Property
WebStringRes Class Eco.Web Namespace See Also
Collapse All

Returns: "When to save EcoSpace in Session state"

C#
public static string sPropertySessionStateMode;
Remarks

For internal use.

See Also
WebStringRes Class
Eco.Web Namespace


WebStringRes.sResultsHeader Property

WebStringRes.sResultsHeader Property
WebStringRes Class Eco.Web Namespace See Also
Collapse All

Returns: "Results"

C#
public static string sResultsHeader;
Remarks

For internal use.

See Also
WebStringRes Class
Eco.Web Namespace


WebStringRes.sRolesHeader Property

WebStringRes.sRolesHeader Property
WebStringRes Class Eco.Web Namespace See Also
Collapse All

Returns: "Roles"

C#
public static string sRolesHeader;
Remarks

For internal use.

See Also
WebStringRes Class
Eco.Web Namespace


WebStringRes.sSessionStateContainsDifferentEcoSpace Property

WebStringRes.sSessionStateContainsDifferentEcoSpace Property
WebStringRes Class Eco.Web Namespace See Also
Collapse All

Returns: "Session state already contains a different EcoSpace"

C#
public static string sSessionStateContainsDifferentEcoSpace;
Remarks

For internal use.

See Also
WebStringRes Class
Eco.Web Namespace


WebStringRes.sSessionStateContainsValueOfWrongType Property

WebStringRes.sSessionStateContainsValueOfWrongType Property
WebStringRes Class Eco.Web Namespace See Also
Collapse All

Returns: "Session state contains value of wrong type"

C#
public static string sSessionStateContainsValueOfWrongType;
Remarks

For internal use.

See Also
WebStringRes Class
Eco.Web Namespace


WebStringRes.sShow Property

WebStringRes.sShow Property
WebStringRes Class Eco.Web Namespace See Also
Collapse All

Returns: "Show"

C#
public static string sShow;
Remarks

For internal use.

See Also
WebStringRes Class
Eco.Web Namespace


WebStringRes.sStateMachinesHeader Property

WebStringRes.sStateMachinesHeader Property
WebStringRes Class Eco.Web Namespace See Also
Collapse All

Returns: "State Machines"

C#
public static string sStateMachinesHeader;
Remarks

For internal use.

See Also
WebStringRes Class
Eco.Web Namespace


WebStringRes.sSubmitButtonText Property

WebStringRes.sSubmitButtonText Property
WebStringRes Class Eco.Web Namespace See Also
Collapse All

Returns: "Submit Changes"

C#
public static string sSubmitButtonText;
Remarks

For internal use.

See Also
WebStringRes Class
Eco.Web Namespace


WebStringRes.sTranslateNullToEmptyString Property

WebStringRes.sTranslateNullToEmptyString Property
WebStringRes Class Eco.Web Namespace See Also
Collapse All

Returns: "Translate null to empty string."

C#
public static string sTranslateNullToEmptyString;
Remarks

For internal use.

See Also
WebStringRes Class
Eco.Web Namespace


WebStringRes.sUnlink Property

WebStringRes.sUnlink Property
WebStringRes Class Eco.Web Namespace See Also
Collapse All

Returns: "Unlink"

C#
public static string sUnlink;
Remarks

For internal use.

See Also
WebStringRes Class
Eco.Web Namespace


WebStringRes.sUsePool Property

WebStringRes.sUsePool Property
WebStringRes Class Eco.Web Namespace See Also
Collapse All

Returns: "Use EcoSpace pool if enabled in Web.config"

C#
public static string sUsePool;
Remarks

For internal use.

See Also
WebStringRes Class
Eco.Web Namespace


WebUtils Class

WebUtils Class
Inheritance Hierarchy See Also
Collapse All

Summary description for WebUtils.

C#
public sealed class WebUtils;
Inheritance Hierarchy
Eco.Web.WebUtils
File

WebUtils.cs

See Also
Inheritance Hierarchy


WebUtils Methods

WebUtils Methods
Public Methods
Collapse All

The methods of the WebUtils class are listed here.

Public Methods
Name | Description
AddHeaderRow | This is AddHeaderRow, a member of class WebUtils.
AddHeaderTableToCell |
GetObjectClassLink |
GetObjectClassName |
GetObjectDisplayName |
GetPropertyType |
HasFrozenAttribute | This is HasFrozenAttribute, a member of class WebUtils.
IdForObject |
IsAbstractClass |
IsAbstractOrLinkClass | This is IsAbstractOrLinkClass, a member of class WebUtils.
IsCollapsedSection |
IsImplicitLinkClass | This is IsImplicitLinkClass, a member of class WebUtils.
IsInnerLink | This is IsInnerLink, a member of class WebUtils.
IsLinkClass |
ObjectForId |
SaveSpace |


WebUtils.AddHeaderRow Method

WebUtils.AddHeaderRow Method
WebUtils Class Eco.Web Namespace See Also
Collapse All
C#
public static void AddHeaderRow(
    Table table,
    string title,
    string text,
    HttpRequest request,
    HttpSessionState session
);
Remarks

This is AddHeaderRow, a member of class WebUtils.

See Also
WebUtils Class
Eco.Web Namespace


WebUtils.AddHeaderTableToCell Method

WebUtils.AddHeaderTableToCell Method
WebUtils Class Eco.Web Namespace See Also
Collapse All
C#
public static TableCell AddHeaderTableToCell(
    TableCell tableCell,
    string title,
    string text,
    HttpRequest request,
    HttpSessionState session
);
Exceptions
Exceptions | Description
ArgumentNullException | Thrown if region is null.
See Also
WebUtils Class
Eco.Web Namespace


WebUtils.GetObjectClassLink Method

WebUtils.GetObjectClassLink Method
WebUtils Class Eco.Web Namespace See Also
Collapse All
C#
public static HyperLink GetObjectClassLink(
    HttpRequest request,
    EcoSpace ecoSpace,
    IObject obj
);
Exceptions
Exceptions | Description
ArgumentNullException | Thrown if request is null. Thrown if ecoSpace is null. Thrown if obj is null.
See Also
WebUtils Class
Eco.Web Namespace


WebUtils.GetObjectClassName Method

WebUtils.GetObjectClassName Method
WebUtils Class Eco.Web Namespace See Also
Collapse All
C#
public static string GetObjectClassName(
    IObject obj
);
Exceptions
Exceptions | Description
ArgumentNullException | Thrown if obj is null.
See Also
WebUtils Class
Eco.Web Namespace


WebUtils.GetObjectDisplayName Method

WebUtils.GetObjectDisplayName Method
WebUtils Class Eco.Web Namespace See Also
Collapse All
C#
public static string GetObjectDisplayName(
    EcoSpace ecoSpace,
    IObject obj
);
Exceptions
Exceptions | Description
ArgumentNullException | Thrown if ecoSpace is null.
See Also
WebUtils Class
Eco.Web Namespace


WebUtils.GetPropertyType Method

WebUtils.GetPropertyType Method
WebUtils Class Eco.Web Namespace See Also
Collapse All
C#
public static EcoPropertyType GetPropertyType(
    IProperty property
);
Exceptions
Exceptions | Description
ArgumentNullException | Thrown if property is null.
See Also
WebUtils Class
Eco.Web Namespace


WebUtils.HasFrozenAttribute Method

WebUtils.HasFrozenAttribute Method
WebUtils Class Eco.Web Namespace See Also
Collapse All
C#
public static bool HasFrozenAttribute(
    EcoSpace es,
    string className
);
Remarks

This is HasFrozenAttribute, a member of class WebUtils.

See Also
WebUtils Class
Eco.Web Namespace


WebUtils.IdForObject Method

WebUtils.IdForObject Method
WebUtils Class Eco.Web Namespace See Also
Collapse All
C#
public static string IdForObject(
    EcoSpace ecoSpace,
    IObject obj
);
Exceptions
Exceptions | Description
ArgumentNullException | Thrown if ecoSpace is null.
See Also
WebUtils Class
Eco.Web Namespace


WebUtils.IsAbstractClass Method

WebUtils.IsAbstractClass Method
WebUtils Class Eco.Web Namespace See Also
Collapse All
C#
public static bool IsAbstractClass(
    EcoSpace ecoSpace,
    string className
);
Exceptions
Exceptions | Description
ArgumentNullException | Thrown if ecoSpace is null.
See Also
WebUtils Class
Eco.Web Namespace


WebUtils.IsAbstractOrLinkClass Method

WebUtils.IsAbstractOrLinkClass Method
WebUtils Class Eco.Web Namespace See Also
Collapse All
C#
public static bool IsAbstractOrLinkClass(
    EcoSpace ecoSpace,
    string className
);
Remarks

This is IsAbstractOrLinkClass, a member of class WebUtils.

See Also
WebUtils Class
Eco.Web Namespace


WebUtils.IsCollapsedSection Method

WebUtils.IsCollapsedSection Method
WebUtils Class Eco.Web Namespace See Also
Collapse All
C#
public static bool IsCollapsedSection(
    HttpSessionState session,
    string title
);
Exceptions
Exceptions | Description
ArgumentNullException | Thrown if session is null.
See Also
WebUtils Class
Eco.Web Namespace


WebUtils.IsImplicitLinkClass Method

WebUtils.IsImplicitLinkClass Method
WebUtils Class Eco.Web Namespace See Also
Collapse All
C#
public static bool IsImplicitLinkClass(
    EcoSpace ecoSpace,
    string className
);
Remarks

This is IsImplicitLinkClass, a member of class WebUtils.

See Also
WebUtils Class
Eco.Web Namespace


WebUtils.IsInnerLink Method

WebUtils.IsInnerLink Method
WebUtils Class Eco.Web Namespace See Also
Collapse All
C#
public static bool IsInnerLink(
    IStructuralFeature sf
);
Remarks

This is IsInnerLink, a member of class WebUtils.

See Also
WebUtils Class
Eco.Web Namespace


WebUtils.IsLinkClass Method

WebUtils.IsLinkClass Method
WebUtils Class Eco.Web Namespace See Also
Collapse All
C#
public static bool IsLinkClass(
    EcoSpace ecoSpace,
    string className
);
Exceptions
Exceptions | Description
ArgumentNullException | Thrown if ecoSpace is null.
See Also
WebUtils Class
Eco.Web Namespace


WebUtils.ObjectForId Method

WebUtils.ObjectForId Method
WebUtils Class Eco.Web Namespace See Also
Collapse All
C#
public static IObject ObjectForId(
    EcoSpace ecoSpace,
    string id
);
Exceptions
Exceptions | Description
ArgumentNullException | Thrown if ecoSpace is null.
See Also
WebUtils Class
Eco.Web Namespace


WebUtils.SaveSpace Method

WebUtils.SaveSpace Method
WebUtils Class Eco.Web Namespace See Also
Collapse All
C#
public static void SaveSpace(
    EcoSpace ecoSpace
);
Exceptions
Exceptions | Description
ArgumentNullException | Thrown if ecoSpace is null.
See Also
WebUtils Class
Eco.Web Namespace


Eco.Web.EcoPropertyType Enumeration

Eco.Web.EcoPropertyType Enumeration
C#
public enum EcoPropertyType {
  Undefined = 0,
  Attribute = 1,
  SingleLink = 2,
  MultiLink = 3,
  ExplicitLinkRole = 4
}
Remarks

This is record Eco.Web.EcoPropertyType.

File

WebUtils.cs


Eco.Web.ListAction Enumeration

Eco.Web.ListAction Enumeration

Enum for available actions.

C#
public enum ListAction {
  None,
  AddNew
}
Members
Members | Description
None | No action will be performed.
AddNew | A new object of the handles type will be created.
File

AspListActionExtender.cs


Eco.Web.AspProviders Namespace

Eco.Web.AspProviders Namespace
Classes
Collapse All

Providers to implement

  • PersonalizationProvider
  • WebEventProvider (BufferedWebEventProvider)
Classes
Name | Description
ASP_BlobPropValue | This is class Eco.Web.AspProviders.ASP_BlobPropValue.
ASP_IntPropValue | This is class Eco.Web.AspProviders.ASP_IntPropValue.
ASP_PersonalizationInfo | This is class Eco.Web.AspProviders.ASP_PersonalizationInfo.
ASP_PersonalizationShared | This is class Eco.Web.AspProviders.ASP_PersonalizationShared.
ASP_PersonalizationUser | This is class Eco.Web.AspProviders.ASP_PersonalizationUser.
ASP_Profile | This is class Eco.Web.AspProviders.ASP_Profile.
ASP_ProfilePropValue | This is class Eco.Web.AspProviders.ASP_ProfilePropValue.
ASP_Role | This is class Eco.Web.AspProviders.ASP_Role.
ASP_RoleUser | This is class Eco.Web.AspProviders.ASP_RoleUser.
ASP_Session | This is class Eco.Web.AspProviders.ASP_Session.
ASP_StringPropValue | This is class Eco.Web.AspProviders.ASP_StringPropValue.
ASP_User | This is class Eco.Web.AspProviders.ASP_User.
ASP_WebEvent | This is class Eco.Web.AspProviders.ASP_WebEvent.
ASP_XmlPropValue | This is class Eco.Web.AspProviders.ASP_XmlPropValue.
EcoAspProviderPackage | This is class Eco.Web.AspProviders.EcoAspProviderPackage.
EcoMembershipProvider | This class implements the ASP.Net Membership Provider mechanism
EcoPersonalizationProvider | This class implements the ASP Personalization provider API with an Eco backend
EcoProfileProvider | This is class Eco.Web.AspProviders.EcoProfileProvider.
EcoProviderSupport | Summary description for Class1.
EcoRoleProvider | This is class Eco.Web.AspProviders.EcoRoleProvider.
EcoSessionStateStoreProvider | This is class Eco.Web.AspProviders.EcoSessionStateStoreProvider.
EcoWebEventProvider | Implements a custom event provider.


ASP_BlobPropValue Class

ASP_BlobPropValue Class
Inheritance Hierarchy See Also
Collapse All
C#
public class ASP_BlobPropValue : Eco.Web.AspProviders.ASP_ProfilePropValue;
Remarks

This is class Eco.Web.AspProviders.ASP_BlobPropValue.

Inheritance Hierarchy
Eco.Web.AspProviders.ASP_BlobPropValue
File

ASP_BlobPropValue.eco.cs

See Also
Inheritance Hierarchy


ASP_BlobPropValue Constructor

ASP_BlobPropValue Constructor

This is the overview for the ASP_BlobPropValue constructor overload.

Overload List
Name | Description
ASP_BlobPropValue.ASP_BlobPropValue (Eco.ObjectImplementation.IContent) | For framework internal use only
ASP_BlobPropValue.ASP_BlobPropValue (Eco.ObjectRepresentation.IEcoServiceProvider) | This is ASP_BlobPropValue, a member of class ASP_BlobPropValue.


ASP_BlobPropValue.ASP_BlobPropValue Constructor (Eco.ObjectImplementation.IContent)

ASP_BlobPropValue.ASP_BlobPropValue Constructor (Eco.ObjectImplementation.IContent)
ASP_BlobPropValue Class Eco.Web.AspProviders Namespace See Also
Collapse All
C#
protected ASP_BlobPropValue(
    Eco.ObjectImplementation.IContent content
);
Remarks

For framework internal use only

See Also
ASP_BlobPropValue Class
Eco.Web.AspProviders Namespace


ASP_BlobPropValue.ASP_BlobPropValue Constructor (Eco.ObjectRepresentation.IEcoServiceProvider)

ASP_BlobPropValue.ASP_BlobPropValue Constructor (Eco.ObjectRepresentation.IEcoServiceProvider)
ASP_BlobPropValue Class Eco.Web.AspProviders Namespace See Also
Collapse All
C#
public ASP_BlobPropValue(
    Eco.ObjectRepresentation.IEcoServiceProvider serviceProvider
);
Remarks

This is ASP_BlobPropValue, a member of class ASP_BlobPropValue.

See Also
ASP_BlobPropValue Class
Eco.Web.AspProviders Namespace


ASP_BlobPropValue Classes

ASP_BlobPropValue Classes
Classes
Collapse All

The classes of the ASP_BlobPropValue class are listed here.

Classes
Name | Description
Eco_LoopbackIndices | This is class Eco.Web.AspProviders.ASP_BlobPropValue.Eco_LoopbackIndices.


ASP_BlobPropValue.Eco_LoopbackIndices Class

ASP_BlobPropValue.Eco_LoopbackIndices Class
Inheritance Hierarchy See Also
Collapse All
C#
public new class Eco_LoopbackIndices;
Remarks

This is class Eco.Web.AspProviders.ASP_BlobPropValue.Eco_LoopbackIndices.

Inheritance Hierarchy
Eco.Web.AspProviders.ASP_BlobPropValue.Eco_LoopbackIndices
File

ASP_BlobPropValue.eco.cs

See Also
Inheritance Hierarchy


Eco_LoopbackIndices Fields

Eco_LoopbackIndices Fields
Public Fields
Collapse All

The fields of the Eco_LoopbackIndices class are listed here.

Public Fields
Name | Description
Eco_FirstMember | This is Eco_FirstMember, a member of class Eco_LoopbackIndices.
Eco_MemberCount | This is Eco_MemberCount, a member of class Eco_LoopbackIndices.
IsSerialized | This is IsSerialized, a member of class Eco_LoopbackIndices.
Value | This is Value, a member of class Eco_LoopbackIndices.


ASP_BlobPropValue.Eco_LoopbackIndices.Eco_FirstMember Field

ASP_BlobPropValue.Eco_LoopbackIndices.Eco_FirstMember Field
ASP_BlobPropValue.Eco_LoopbackIndices Class Eco.Web.AspProviders Namespace See Also
Collapse All
C#
public const int Eco_FirstMember = Eco.Web.AspProviders.ASP_ProfilePropValue.Eco_LoopbackIndices.Eco_MemberCount;
Remarks

This is Eco_FirstMember, a member of class Eco_LoopbackIndices.

See Also
ASP_BlobPropValue.Eco_LoopbackIndices Class
Eco.Web.AspProviders Namespace


ASP_BlobPropValue.Eco_LoopbackIndices.Eco_MemberCount Field

ASP_BlobPropValue.Eco_LoopbackIndices.Eco_MemberCount Field
ASP_BlobPropValue.Eco_LoopbackIndices Class Eco.Web.AspProviders Namespace See Also
Collapse All
C#
public const int Eco_MemberCount = (Value + 1);
Remarks

This is Eco_MemberCount, a member of class Eco_LoopbackIndices.

See Also
ASP_BlobPropValue.Eco_LoopbackIndices Class
Eco.Web.AspProviders Namespace


ASP_BlobPropValue.Eco_LoopbackIndices.IsSerialized Field

ASP_BlobPropValue.Eco_LoopbackIndices.IsSerialized Field
ASP_BlobPropValue.Eco_LoopbackIndices Class Eco.Web.AspProviders Namespace See Also
Collapse All
C#
public const int IsSerialized = Eco_FirstMember;
Remarks

This is IsSerialized, a member of class Eco_LoopbackIndices.

See Also
ASP_BlobPropValue.Eco_LoopbackIndices Class
Eco.Web.AspProviders Namespace


ASP_BlobPropValue.Eco_LoopbackIndices.Value Field

ASP_BlobPropValue.Eco_LoopbackIndices.Value Field
ASP_BlobPropValue.Eco_LoopbackIndices Class Eco.Web.AspProviders Namespace See Also
Collapse All
C#
public const int Value = (IsSerialized + 1);
Remarks

This is Value, a member of class Eco_LoopbackIndices.

See Also
ASP_BlobPropValue.Eco_LoopbackIndices Class
Eco.Web.AspProviders Namespace


ASP_BlobPropValue Methods

ASP_BlobPropValue Methods
Public Methods
Collapse All

The methods of the ASP_BlobPropValue class are listed here.

Public Methods
Name | Description
get_MemberByIndex | This is get_MemberByIndex, a member of class ASP_BlobPropValue.
GetValue | This is GetValue, a member of class ASP_BlobPropValue.
set_MemberByIndex | This is set_MemberByIndex, a member of class ASP_BlobPropValue.
SetValue | This is SetValue, a member of class ASP_BlobPropValue.


ASP_BlobPropValue.get_MemberByIndex Method

ASP_BlobPropValue.get_MemberByIndex Method
ASP_BlobPropValue Class Eco.Web.AspProviders Namespace See Also
Collapse All
C#
public override object get_MemberByIndex(
    int index
);
Remarks

This is get_MemberByIndex, a member of class ASP_BlobPropValue.

See Also
ASP_BlobPropValue Class
Eco.Web.AspProviders Namespace


ASP_BlobPropValue.GetValue Method

ASP_BlobPropValue.GetValue Method
ASP_BlobPropValue Class Eco.Web.AspProviders Namespace See Also
Collapse All
C#
public override object GetValue();
Remarks

This is GetValue, a member of class ASP_BlobPropValue.

See Also
ASP_BlobPropValue Class
Eco.Web.AspProviders Namespace


ASP_BlobPropValue.set_MemberByIndex Method

ASP_BlobPropValue.set_MemberByIndex Method
ASP_BlobPropValue Class Eco.Web.AspProviders Namespace See Also
Collapse All
C#
public override void set_MemberByIndex(
    int index,
    object value
);
Remarks

This is set_MemberByIndex, a member of class ASP_BlobPropValue.

See Also
ASP_BlobPropValue Class
Eco.Web.AspProviders Namespace


ASP_BlobPropValue.SetValue Method

ASP_BlobPropValue.SetValue Method
ASP_BlobPropValue Class Eco.Web.AspProviders Namespace See Also
Collapse All
C#
public void SetValue(
    object value
);
Remarks

This is SetValue, a member of class ASP_BlobPropValue.

See Also
ASP_BlobPropValue Class
Eco.Web.AspProviders Namespace


ASP_BlobPropValue Properties

ASP_BlobPropValue Properties
Public Properties
Collapse All

The properties of the ASP_BlobPropValue class are listed here.

Public Properties
Name | Description
IsSerialized | This is IsSerialized, a member of class ASP_BlobPropValue.
Value | This is Value, a member of class ASP_BlobPropValue.


ASP_BlobPropValue.IsSerialized Property

ASP_BlobPropValue.IsSerialized Property
ASP_BlobPropValue Class Eco.Web.AspProviders Namespace See Also
Collapse All
C#
public bool IsSerialized;
Remarks

This is IsSerialized, a member of class ASP_BlobPropValue.

See Also
ASP_BlobPropValue Class
Eco.Web.AspProviders Namespace


ASP_BlobPropValue.Value Property

ASP_BlobPropValue.Value Property
ASP_BlobPropValue Class Eco.Web.AspProviders Namespace See Also
Collapse All
C#
public byte Value;
Remarks

This is Value, a member of class ASP_BlobPropValue.

See Also
ASP_BlobPropValue Class
Eco.Web.AspProviders Namespace


ASP_IntPropValue Class

ASP_IntPropValue Class
Inheritance Hierarchy See Also
Collapse All
C#
public class ASP_IntPropValue : Eco.Web.AspProviders.ASP_ProfilePropValue;
Remarks

This is class Eco.Web.AspProviders.ASP_IntPropValue.

Inheritance Hierarchy
Eco.Web.AspProviders.ASP_IntPropValue
File

ASP_IntPropValue.eco.cs

See Also
Inheritance Hierarchy


ASP_IntPropValue Constructor

ASP_IntPropValue Constructor

This is the overview for the ASP_IntPropValue constructor overload.

Overload List
Name | Description
ASP_IntPropValue.ASP_IntPropValue (Eco.ObjectImplementation.IContent) | For framework internal use only
ASP_IntPropValue.ASP_IntPropValue (Eco.ObjectRepresentation.IEcoServiceProvider) | This is ASP_IntPropValue, a member of class ASP_IntPropValue.


ASP_IntPropValue.ASP_IntPropValue Constructor (Eco.ObjectImplementation.IContent)

ASP_IntPropValue.ASP_IntPropValue Constructor (Eco.ObjectImplementation.IContent)
ASP_IntPropValue Class Eco.Web.AspProviders Namespace See Also
Collapse All
C#
protected ASP_IntPropValue(
    Eco.ObjectImplementation.IContent content
);
Remarks

For framework internal use only

See Also
ASP_IntPropValue Class
Eco.Web.AspProviders Namespace


ASP_IntPropValue.ASP_IntPropValue Constructor (Eco.ObjectRepresentation.IEcoServiceProvider)

ASP_IntPropValue.ASP_IntPropValue Constructor (Eco.ObjectRepresentation.IEcoServiceProvider)
ASP_IntPropValue Class Eco.Web.AspProviders Namespace See Also
Collapse All
C#
public ASP_IntPropValue(
    Eco.ObjectRepresentation.IEcoServiceProvider serviceProvider
);
Remarks

This is ASP_IntPropValue, a member of class ASP_IntPropValue.

See Also
ASP_IntPropValue Class
Eco.Web.AspProviders Namespace


ASP_IntPropValue Classes

ASP_IntPropValue Classes
Classes
Collapse All

The classes of the ASP_IntPropValue class are listed here.

Classes
Name | Description
Eco_LoopbackIndices | This is class Eco.Web.AspProviders.ASP_IntPropValue.Eco_LoopbackIndices.


ASP_IntPropValue.Eco_LoopbackIndices Class

ASP_IntPropValue.Eco_LoopbackIndices Class
Inheritance Hierarchy See Also
Collapse All
C#
public new class Eco_LoopbackIndices;
Remarks

This is class Eco.Web.AspProviders.ASP_IntPropValue.Eco_LoopbackIndices.

Inheritance Hierarchy
Eco.Web.AspProviders.ASP_IntPropValue.Eco_LoopbackIndices
File

ASP_IntPropValue.eco.cs

See Also
Inheritance Hierarchy


Eco_LoopbackIndices Fields

Eco_LoopbackIndices Fields
Public Fields
Collapse All

The fields of the Eco_LoopbackIndices class are listed here.

Public Fields
Name | Description
Eco_FirstMember | This is Eco_FirstMember, a member of class Eco_LoopbackIndices.
Eco_MemberCount | This is Eco_MemberCount, a member of class Eco_LoopbackIndices.
Value | This is Value, a member of class Eco_LoopbackIndices.


ASP_IntPropValue.Eco_LoopbackIndices.Eco_FirstMember Field

ASP_IntPropValue.Eco_LoopbackIndices.Eco_FirstMember Field
ASP_IntPropValue.Eco_LoopbackIndices Class Eco.Web.AspProviders Namespace See Also
Collapse All
C#
public const int Eco_FirstMember = Eco.Web.AspProviders.ASP_ProfilePropValue.Eco_LoopbackIndices.Eco_MemberCount;
Remarks

This is Eco_FirstMember, a member of class Eco_LoopbackIndices.

See Also
ASP_IntPropValue.Eco_LoopbackIndices Class
Eco.Web.AspProviders Namespace


ASP_IntPropValue.Eco_LoopbackIndices.Eco_MemberCount Field

ASP_IntPropValue.Eco_LoopbackIndices.Eco_MemberCount Field
ASP_IntPropValue.Eco_LoopbackIndices Class Eco.Web.AspProviders Namespace See Also
Collapse All
C#
public const int Eco_MemberCount = (Value + 1);
Remarks

This is Eco_MemberCount, a member of class Eco_LoopbackIndices.

See Also
ASP_IntPropValue.Eco_LoopbackIndices Class
Eco.Web.AspProviders Namespace


ASP_IntPropValue.Eco_LoopbackIndices.Value Field

ASP_IntPropValue.Eco_LoopbackIndices.Value Field
ASP_IntPropValue.Eco_LoopbackIndices Class Eco.Web.AspProviders Namespace See Also
Collapse All
C#
public const int Value = Eco_FirstMember;
Remarks

This is Value, a member of class Eco_LoopbackIndices.

See Also
ASP_IntPropValue.Eco_LoopbackIndices Class
Eco.Web.AspProviders Namespace


ASP_IntPropValue Methods

ASP_IntPropValue Methods
Public Methods
Collapse All

The methods of the ASP_IntPropValue class are listed here.

Public Methods
Name | Description
get_MemberByIndex | This is get_MemberByIndex, a member of class ASP_IntPropValue.
GetValue | This is GetValue, a member of class ASP_IntPropValue.
set_MemberByIndex | This is set_MemberByIndex, a member of class ASP_IntPropValue.


ASP_IntPropValue.get_MemberByIndex Method

ASP_IntPropValue.get_MemberByIndex Method
ASP_IntPropValue Class Eco.Web.AspProviders Namespace See Also
Collapse All
C#
public override object get_MemberByIndex(
    int index
);
Remarks

This is get_MemberByIndex, a member of class ASP_IntPropValue.

See Also
ASP_IntPropValue Class
Eco.Web.AspProviders Namespace


ASP_IntPropValue.GetValue Method

ASP_IntPropValue.GetValue Method
ASP_IntPropValue Class Eco.Web.AspProviders Namespace See Also
Collapse All
C#
public override object GetValue();
Remarks

This is GetValue, a member of class ASP_IntPropValue.

See Also
ASP_IntPropValue Class
Eco.Web.AspProviders Namespace


ASP_IntPropValue.set_MemberByIndex Method

ASP_IntPropValue.set_MemberByIndex Method
ASP_IntPropValue Class Eco.Web.AspProviders Namespace See Also
Collapse All
C#
public override void set_MemberByIndex(
    int index,
    object value
);
Remarks

This is set_MemberByIndex, a member of class ASP_IntPropValue.

See Also
ASP_IntPropValue Class
Eco.Web.AspProviders Namespace


ASP_IntPropValue Properties

ASP_IntPropValue Properties
Public Properties
Collapse All

The properties of the ASP_IntPropValue class are listed here.

Public Properties
Name | Description
Value | This is Value, a member of class ASP_IntPropValue.


ASP_IntPropValue.Value Property

ASP_IntPropValue.Value Property
ASP_IntPropValue Class Eco.Web.AspProviders Namespace See Also
Collapse All
C#
public int Value;
Remarks

This is Value, a member of class ASP_IntPropValue.

See Also
ASP_IntPropValue Class
Eco.Web.AspProviders Namespace


ASP_PersonalizationInfo Class

ASP_PersonalizationInfo Class
Inheritance Hierarchy See Also
Collapse All
C#
public abstract class ASP_PersonalizationInfo : Eco.ObjectImplementation.ILoopBack2, System.ComponentModel.INotifyPropertyChanged;
Remarks

This is class Eco.Web.AspProviders.ASP_PersonalizationInfo.

Inheritance Hierarchy
Eco.Web.AspProviders.ASP_PersonalizationInfo
File

ASP_PersonalizationInfo.eco.cs

See Also
Inheritance Hierarchy


ASP_PersonalizationInfo Constructor

ASP_PersonalizationInfo Constructor

This is the overview for the ASP_PersonalizationInfo constructor overload.

Overload List
Name | Description
ASP_PersonalizationInfo.ASP_PersonalizationInfo (Eco.ObjectImplementation.IContent) | For framework internal use only
ASP_PersonalizationInfo.ASP_PersonalizationInfo (Eco.ObjectRepresentation.IEcoServiceProvider) | This is ASP_PersonalizationInfo, a member of class ASP_PersonalizationInfo.


ASP_PersonalizationInfo.ASP_PersonalizationInfo Constructor (Eco.ObjectImplementation.IContent)

ASP_PersonalizationInfo.ASP_PersonalizationInfo Constructor (Eco.ObjectImplementation.IContent)
ASP_PersonalizationInfo Class Eco.Web.AspProviders Namespace See Also
Collapse All
C#
protected ASP_PersonalizationInfo(
    Eco.ObjectImplementation.IContent content
);
Remarks

For framework internal use only

See Also
ASP_PersonalizationInfo Class
Eco.Web.AspProviders Namespace


ASP_PersonalizationInfo.ASP_PersonalizationInfo Constructor (Eco.ObjectRepresentation.IEcoServiceProvider)

ASP_PersonalizationInfo.ASP_PersonalizationInfo Constructor (Eco.ObjectRepresentation.IEcoServiceProvider)
ASP_PersonalizationInfo Class Eco.Web.AspProviders Namespace See Also
Collapse All
C#
public ASP_PersonalizationInfo(
    Eco.ObjectRepresentation.IEcoServiceProvider serviceProvider
);
Remarks

This is ASP_PersonalizationInfo, a member of class ASP_PersonalizationInfo.

See Also
ASP_PersonalizationInfo Class
Eco.Web.AspProviders Namespace


ASP_PersonalizationInfo Classes

ASP_PersonalizationInfo Classes
Classes
Collapse All

The classes of the ASP_PersonalizationInfo class are listed here.

Classes
Name | Description
Eco_LoopbackIndices | This is class Eco.Web.AspProviders.ASP_PersonalizationInfo.Eco_LoopbackIndices.


ASP_PersonalizationInfo.Eco_LoopbackIndices Class

ASP_PersonalizationInfo.Eco_LoopbackIndices Class
Inheritance Hierarchy See Also
Collapse All
C#
public class Eco_LoopbackIndices;
Remarks

This is class Eco.Web.AspProviders.ASP_PersonalizationInfo.Eco_LoopbackIndices.

Inheritance Hierarchy
Eco.Web.AspProviders.ASP_PersonalizationInfo.Eco_LoopbackIndices
File

ASP_PersonalizationInfo.eco.cs

See Also
Inheritance Hierarchy


Eco_LoopbackIndices Fields

Eco_LoopbackIndices Fields
Public Fields
Collapse All

The fields of the Eco_LoopbackIndices class are listed here.

Public Fields
Name | Description
ApplicationName | This is ApplicationName, a member of class Eco_LoopbackIndices.
Eco_FirstMember | This is Eco_FirstMember, a member of class Eco_LoopbackIndices.
Eco_MemberCount | This is Eco_MemberCount, a member of class Eco_LoopbackIndices.
LastUpdated | This is LastUpdated, a member of class Eco_LoopbackIndices.
Path | This is Path, a member of class Eco_LoopbackIndices.
Settings | This is Settings, a member of class Eco_LoopbackIndices.
Size | This is Size, a member of class Eco_LoopbackIndices.


ASP_PersonalizationInfo.Eco_LoopbackIndices.ApplicationName Field

ASP_PersonalizationInfo.Eco_LoopbackIndices.ApplicationName Field
ASP_PersonalizationInfo.Eco_LoopbackIndices Class Eco.Web.AspProviders Namespace See Also
Collapse All
C#
public const int ApplicationName = (Size + 1);
Remarks

This is ApplicationName, a member of class Eco_LoopbackIndices.

See Also
ASP_PersonalizationInfo.Eco_LoopbackIndices Class
Eco.Web.AspProviders Namespace


ASP_PersonalizationInfo.Eco_LoopbackIndices.Eco_FirstMember Field

ASP_PersonalizationInfo.Eco_LoopbackIndices.Eco_FirstMember Field
ASP_PersonalizationInfo.Eco_LoopbackIndices Class Eco.Web.AspProviders Namespace See Also
Collapse All
C#
public const int Eco_FirstMember = 0;
Remarks

This is Eco_FirstMember, a member of class Eco_LoopbackIndices.

See Also
ASP_PersonalizationInfo.Eco_LoopbackIndices Class
Eco.Web.AspProviders Namespace


ASP_PersonalizationInfo.Eco_LoopbackIndices.Eco_MemberCount Field

ASP_PersonalizationInfo.Eco_LoopbackIndices.Eco_MemberCount Field
ASP_PersonalizationInfo.Eco_LoopbackIndices Class Eco.Web.AspProviders Namespace See Also
Collapse All
C#
public const int Eco_MemberCount = (LastUpdated + 1);
Remarks

This is Eco_MemberCount, a member of class Eco_LoopbackIndices.

See Also
ASP_PersonalizationInfo.Eco_LoopbackIndices Class
Eco.Web.AspProviders Namespace


ASP_PersonalizationInfo.Eco_LoopbackIndices.LastUpdated Field

ASP_PersonalizationInfo.Eco_LoopbackIndices.LastUpdated Field
ASP_PersonalizationInfo.Eco_LoopbackIndices Class Eco.Web.AspProviders Namespace See Also
Collapse All
C#
public const int LastUpdated = (Settings + 1);
Remarks

This is LastUpdated, a member of class Eco_LoopbackIndices.

See Also
ASP_PersonalizationInfo.Eco_LoopbackIndices Class
Eco.Web.AspProviders Namespace


ASP_PersonalizationInfo.Eco_LoopbackIndices.Path Field

ASP_PersonalizationInfo.Eco_LoopbackIndices.Path Field
ASP_PersonalizationInfo.Eco_LoopbackIndices Class Eco.Web.AspProviders Namespace See Also
Collapse All
C#
public const int Path = (ApplicationName + 1);
Remarks

This is Path, a member of class Eco_LoopbackIndices.

See Also
ASP_PersonalizationInfo.Eco_LoopbackIndices Class
Eco.Web.AspProviders Namespace


ASP_PersonalizationInfo.Eco_LoopbackIndices.Settings Field

ASP_PersonalizationInfo.Eco_LoopbackIndices.Settings Field
ASP_PersonalizationInfo.Eco_LoopbackIndices Class Eco.Web.AspProviders Namespace See Also
Collapse All
C#
public const int Settings = (Path + 1);
Remarks

This is Settings, a member of class Eco_LoopbackIndices.

See Also
ASP_PersonalizationInfo.Eco_LoopbackIndices Class
Eco.Web.AspProviders Namespace


ASP_PersonalizationInfo.Eco_LoopbackIndices.Size Field

ASP_PersonalizationInfo.Eco_LoopbackIndices.Size Field
ASP_PersonalizationInfo.Eco_LoopbackIndices Class Eco.Web.AspProviders Namespace See Also
Collapse All
C#
public const int Size = Eco_FirstMember;
Remarks

This is Size, a member of class Eco_LoopbackIndices.

See Also
ASP_PersonalizationInfo.Eco_LoopbackIndices Class
Eco.Web.AspProviders Namespace


ASP_PersonalizationInfo Fields

ASP_PersonalizationInfo Fields
Protected Fields
Collapse All

The fields of the ASP_PersonalizationInfo class are listed here.

Protected Fields
Name | Description
eco_Content | This is eco_Content, a member of class ASP_PersonalizationInfo.


ASP_PersonalizationInfo.eco_Content Field

ASP_PersonalizationInfo.eco_Content Field
ASP_PersonalizationInfo Class Eco.Web.AspProviders Namespace See Also
Collapse All
C#
protected Eco.ObjectImplementation.IContent eco_Content;
Remarks

This is eco_Content, a member of class ASP_PersonalizationInfo.

See Also
ASP_PersonalizationInfo Class
Eco.Web.AspProviders Namespace


ASP_PersonalizationInfo Methods

ASP_PersonalizationInfo Methods
Protected Methods Public Methods
Collapse All

The methods of the ASP_PersonalizationInfo class are listed here.

Protected Methods
Name | Description
Deinitialize | This is Deinitialize, a member of class ASP_PersonalizationInfo.
Initialize | This is Initialize, a member of class ASP_PersonalizationInfo.
Top
Public Methods
Name | Description
AsIObject | This is AsIObject, a member of class ASP_PersonalizationInfo.
get_MemberByIndex | This is get_MemberByIndex, a member of class ASP_PersonalizationInfo.
set_MemberByIndex | This is set_MemberByIndex, a member of class ASP_PersonalizationInfo.


ASP_PersonalizationInfo.AsIObject Method

ASP_PersonalizationInfo.AsIObject Method
ASP_PersonalizationInfo Class Eco.Web.AspProviders Namespace See Also
Collapse All
C#
public virtual Eco.ObjectRepresentation.IObjectInstance AsIObject();
Remarks

This is AsIObject, a member of class ASP_PersonalizationInfo.

See Also
ASP_PersonalizationInfo Class
Eco.Web.AspProviders Namespace


ASP_PersonalizationInfo.Deinitialize Method

ASP_PersonalizationInfo.Deinitialize Method
ASP_PersonalizationInfo Class Eco.Web.AspProviders Namespace See Also
Collapse All
C#
protected virtual void Deinitialize(
    Eco.ObjectRepresentation.IEcoServiceProvider serviceProvider
);
Remarks

This is Deinitialize, a member of class ASP_PersonalizationInfo.

See Also
ASP_PersonalizationInfo Class
Eco.Web.AspProviders Namespace


ASP_PersonalizationInfo.get_MemberByIndex Method

ASP_PersonalizationInfo.get_MemberByIndex Method
ASP_PersonalizationInfo Class Eco.Web.AspProviders Namespace See Also
Collapse All
C#
public virtual object get_MemberByIndex(
    int index
);
Remarks

This is get_MemberByIndex, a member of class ASP_PersonalizationInfo.

See Also
ASP_PersonalizationInfo Class
Eco.Web.AspProviders Namespace


ASP_PersonalizationInfo.Initialize Method

ASP_PersonalizationInfo.Initialize Method
ASP_PersonalizationInfo Class Eco.Web.AspProviders Namespace See Also
Collapse All
C#
protected virtual void Initialize(
    Eco.ObjectRepresentation.IEcoServiceProvider serviceProvider
);
Remarks

This is Initialize, a member of class ASP_PersonalizationInfo.

See Also
ASP_PersonalizationInfo Class
Eco.Web.AspProviders Namespace


ASP_PersonalizationInfo.set_MemberByIndex Method

ASP_PersonalizationInfo.set_MemberByIndex Method
ASP_PersonalizationInfo Class Eco.Web.AspProviders Namespace See Also
Collapse All
C#
public virtual void set_MemberByIndex(
    int index,
    object value
);
Remarks

This is set_MemberByIndex, a member of class ASP_PersonalizationInfo.

See Also
ASP_PersonalizationInfo Class
Eco.Web.AspProviders Namespace


ASP_PersonalizationInfo Properties

ASP_PersonalizationInfo Properties
Public Properties
Collapse All

The properties of the ASP_PersonalizationInfo class are listed here.

Public Properties
Name | Description
ApplicationName | This is ApplicationName, a member of class ASP_PersonalizationInfo.
LastUpdated | This is LastUpdated, a member of class ASP_PersonalizationInfo.
Path | This is Path, a member of class ASP_PersonalizationInfo.
Settings | This is Settings, a member of class ASP_PersonalizationInfo.
Size | This is Size, a member of class ASP_PersonalizationInfo.


ASP_PersonalizationInfo.ApplicationName Property

ASP_PersonalizationInfo.ApplicationName Property
ASP_PersonalizationInfo Class Eco.Web.AspProviders Namespace See Also
Collapse All
C#
public string ApplicationName;
Remarks

This is ApplicationName, a member of class ASP_PersonalizationInfo.

See Also
ASP_PersonalizationInfo Class
Eco.Web.AspProviders Namespace


ASP_PersonalizationInfo.LastUpdated Property

ASP_PersonalizationInfo.LastUpdated Property
ASP_PersonalizationInfo Class Eco.Web.AspProviders Namespace See Also
Collapse All
C#
public System.DateTime LastUpdated;
Remarks

This is LastUpdated, a member of class ASP_PersonalizationInfo.

See Also
ASP_PersonalizationInfo Class
Eco.Web.AspProviders Namespace


ASP_PersonalizationInfo.Path Property

ASP_PersonalizationInfo.Path Property
ASP_PersonalizationInfo Class Eco.Web.AspProviders Namespace See Also
Collapse All
C#
public string Path;
Remarks

This is Path, a member of class ASP_PersonalizationInfo.

See Also
ASP_PersonalizationInfo Class
Eco.Web.AspProviders Namespace


ASP_PersonalizationInfo.Settings Property

ASP_PersonalizationInfo.Settings Property
ASP_PersonalizationInfo Class Eco.Web.AspProviders Namespace See Also
Collapse All
C#
public byte Settings;
Remarks

This is Settings, a member of class ASP_PersonalizationInfo.

See Also
ASP_PersonalizationInfo Class
Eco.Web.AspProviders Namespace


ASP_PersonalizationInfo.Size Property

ASP_PersonalizationInfo.Size Property
ASP_PersonalizationInfo Class Eco.Web.AspProviders Namespace See Also
Collapse All
C#
public int Size;
Remarks

This is Size, a member of class ASP_PersonalizationInfo.

See Also
ASP_PersonalizationInfo Class
Eco.Web.AspProviders Namespace


ASP_PersonalizationShared Class

ASP_PersonalizationShared Class
Inheritance Hierarchy See Also
Collapse All
C#
public class ASP_PersonalizationShared : Eco.Web.AspProviders.ASP_PersonalizationInfo;
Remarks

This is class Eco.Web.AspProviders.ASP_PersonalizationShared.

Inheritance Hierarchy
Eco.Web.AspProviders.ASP_PersonalizationShared
File

ASP_PersonalizationShared.eco.cs

See Also
Inheritance Hierarchy


ASP_PersonalizationShared Constructor

ASP_PersonalizationShared Constructor

This is the overview for the ASP_PersonalizationShared constructor overload.

Overload List
Name | Description
ASP_PersonalizationShared.ASP_PersonalizationShared (Eco.ObjectImplementation.IContent) | For framework internal use only
ASP_PersonalizationShared.ASP_PersonalizationShared (Eco.ObjectRepresentation.IEcoServiceProvider) | This is ASP_PersonalizationShared, a member of class ASP_PersonalizationShared.


ASP_PersonalizationShared.ASP_PersonalizationShared Constructor (Eco.ObjectImplementation.IContent)

ASP_PersonalizationShared.ASP_PersonalizationShared Constructor (Eco.ObjectImplementation.IContent)
ASP_PersonalizationShared Class Eco.Web.AspProviders Namespace See Also
Collapse All
C#
protected ASP_PersonalizationShared(
    Eco.ObjectImplementation.IContent content
);
Remarks

For framework internal use only

See Also
ASP_PersonalizationShared Class
Eco.Web.AspProviders Namespace


ASP_PersonalizationShared.ASP_PersonalizationShared Constructor (Eco.ObjectRepresentation.IEcoServiceProvider)

ASP_PersonalizationShared.ASP_PersonalizationShared Constructor (Eco.ObjectRepresentation.IEcoServiceProvider)
ASP_PersonalizationShared Class Eco.Web.AspProviders Namespace See Also
Collapse All
C#
public ASP_PersonalizationShared(
    Eco.ObjectRepresentation.IEcoServiceProvider serviceProvider
);
Remarks

This is ASP_PersonalizationShared, a member of class ASP_PersonalizationShared.

See Also
ASP_PersonalizationShared Class
Eco.Web.AspProviders Namespace


ASP_PersonalizationShared Classes

ASP_PersonalizationShared Classes
Classes
Collapse All

The classes of the ASP_PersonalizationShared class are listed here.

Classes
Name | Description
Eco_LoopbackIndices | This is class Eco.Web.AspProviders.ASP_PersonalizationShared.Eco_LoopbackIndices.


ASP_PersonalizationShared.Eco_LoopbackIndices Class

ASP_PersonalizationShared.Eco_LoopbackIndices Class
Inheritance Hierarchy See Also
Collapse All
C#
public new class Eco_LoopbackIndices;
Remarks

This is class Eco.Web.AspProviders.ASP_PersonalizationShared.Eco_LoopbackIndices.

Inheritance Hierarchy
Eco.Web.AspProviders.ASP_PersonalizationShared.Eco_LoopbackIndices
File

ASP_PersonalizationShared.eco.cs

See Also
Inheritance Hierarchy


Eco_LoopbackIndices Fields

Eco_LoopbackIndices Fields
Public Fields
Collapse All

The fields of the Eco_LoopbackIndices class are listed here.

Public Fields
Name | Description
Eco_FirstMember | This is Eco_FirstMember, a member of class Eco_LoopbackIndices.
Eco_MemberCount | This is Eco_MemberCount, a member of class Eco_LoopbackIndices.


ASP_PersonalizationShared.Eco_LoopbackIndices.Eco_FirstMember Field

ASP_PersonalizationShared.Eco_LoopbackIndices.Eco_FirstMember Field
ASP_PersonalizationShared.Eco_LoopbackIndices Class Eco.Web.AspProviders Namespace See Also
Collapse All
C#
public const int Eco_FirstMember = Eco.Web.AspProviders.ASP_PersonalizationInfo.Eco_LoopbackIndices.Eco_MemberCount;
Remarks

This is Eco_FirstMember, a member of class Eco_LoopbackIndices.

See Also
ASP_PersonalizationShared.Eco_LoopbackIndices Class
Eco.Web.AspProviders Namespace


ASP_PersonalizationShared.Eco_LoopbackIndices.Eco_MemberCount Field

ASP_PersonalizationShared.Eco_LoopbackIndices.Eco_MemberCount Field
ASP_PersonalizationShared.Eco_LoopbackIndices Class Eco.Web.AspProviders Namespace See Also
Collapse All
C#
public const int Eco_MemberCount = Eco_FirstMember;
Remarks

This is Eco_MemberCount, a member of class Eco_LoopbackIndices.

See Also
ASP_PersonalizationShared.Eco_LoopbackIndices Class
Eco.Web.AspProviders Namespace


ASP_PersonalizationShared Methods

ASP_PersonalizationShared Methods
Public Methods
Collapse All

The methods of the ASP_PersonalizationShared class are listed here.

Public Methods
Name | Description
get_MemberByIndex | This is get_MemberByIndex, a member of class ASP_PersonalizationShared.
set_MemberByIndex | This is set_MemberByIndex, a member of class ASP_PersonalizationShared.


ASP_PersonalizationShared.get_MemberByIndex Method

ASP_PersonalizationShared.get_MemberByIndex Method
ASP_PersonalizationShared Class Eco.Web.AspProviders Namespace See Also
Collapse All
C#
public override object get_MemberByIndex(
    int index
);
Remarks

This is get_MemberByIndex, a member of class ASP_PersonalizationShared.

See Also
ASP_PersonalizationShared Class
Eco.Web.AspProviders Namespace


ASP_PersonalizationShared.set_MemberByIndex Method

ASP_PersonalizationShared.set_MemberByIndex Method
ASP_PersonalizationShared Class Eco.Web.AspProviders Namespace See Also
Collapse All
C#
public override void set_MemberByIndex(
    int index,
    object value
);
Remarks

This is set_MemberByIndex, a member of class ASP_PersonalizationShared.

See Also
ASP_PersonalizationShared Class
Eco.Web.AspProviders Namespace


ASP_PersonalizationUser Class

ASP_PersonalizationUser Class
Inheritance Hierarchy See Also
Collapse All
C#
public class ASP_PersonalizationUser : Eco.Web.AspProviders.ASP_PersonalizationInfo;
Remarks

This is class Eco.Web.AspProviders.ASP_PersonalizationUser.

Inheritance Hierarchy
Eco.Web.AspProviders.ASP_PersonalizationUser
File

ASP_PersonalizationUser.eco.cs

See Also
Inheritance Hierarchy


ASP_PersonalizationUser Constructor

ASP_PersonalizationUser Constructor

This is the overview for the ASP_PersonalizationUser constructor overload.

Overload List
Name | Description
ASP_PersonalizationUser.ASP_PersonalizationUser (Eco.ObjectImplementation.IContent) | For framework internal use only
ASP_PersonalizationUser.ASP_PersonalizationUser (Eco.ObjectRepresentation.IEcoServiceProvider) | This is ASP_PersonalizationUser, a member of class ASP_PersonalizationUser.


ASP_PersonalizationUser.ASP_PersonalizationUser Constructor (Eco.ObjectImplementation.IContent)

ASP_PersonalizationUser.ASP_PersonalizationUser Constructor (Eco.ObjectImplementation.IContent)
ASP_PersonalizationUser Class Eco.Web.AspProviders Namespace See Also
Collapse All
C#
protected ASP_PersonalizationUser(
    Eco.ObjectImplementation.IContent content
);
Remarks

For framework internal use only

See Also
ASP_PersonalizationUser Class
Eco.Web.AspProviders Namespace


ASP_PersonalizationUser.ASP_PersonalizationUser Constructor (Eco.ObjectRepresentation.IEcoServiceProvider)

ASP_PersonalizationUser.ASP_PersonalizationUser Constructor (Eco.ObjectRepresentation.IEcoServiceProvider)
ASP_PersonalizationUser Class Eco.Web.AspProviders Namespace See Also
Collapse All
C#
public ASP_PersonalizationUser(
    Eco.ObjectRepresentation.IEcoServiceProvider serviceProvider
);
Remarks

This is ASP_PersonalizationUser, a member of class ASP_PersonalizationUser.

See Also
ASP_PersonalizationUser Class
Eco.Web.AspProviders Namespace


ASP_PersonalizationUser Classes

ASP_PersonalizationUser Classes
Classes
Collapse All

The classes of the ASP_PersonalizationUser class are listed here.

Classes
Name | Description
Eco_LoopbackIndices | This is class Eco.Web.AspProviders.ASP_PersonalizationUser.Eco_LoopbackIndices.


ASP_PersonalizationUser.Eco_LoopbackIndices Class

ASP_PersonalizationUser.Eco_LoopbackIndices Class
Inheritance Hierarchy See Also
Collapse All
C#
public new class Eco_LoopbackIndices;
Remarks

This is class Eco.Web.AspProviders.ASP_PersonalizationUser.Eco_LoopbackIndices.

Inheritance Hierarchy
Eco.Web.AspProviders.ASP_PersonalizationUser.Eco_LoopbackIndices
File

ASP_PersonalizationUser.eco.cs

See Also
Inheritance Hierarchy


Eco_LoopbackIndices Fields

Eco_LoopbackIndices Fields
Public Fields
Collapse All

The fields of the Eco_LoopbackIndices class are listed here.

Public Fields
Name | Description
Eco_FirstMember | This is Eco_FirstMember, a member of class Eco_LoopbackIndices.
Eco_MemberCount | This is Eco_MemberCount, a member of class Eco_LoopbackIndices.
LastActivityDate | This is LastActivityDate, a member of class Eco_LoopbackIndices.
UserName | This is UserName, a member of class Eco_LoopbackIndices.


ASP_PersonalizationUser.Eco_LoopbackIndices.Eco_FirstMember Field

ASP_PersonalizationUser.Eco_LoopbackIndices.Eco_FirstMember Field
ASP_PersonalizationUser.Eco_LoopbackIndices Class Eco.Web.AspProviders Namespace See Also
Collapse All
C#
public const int Eco_FirstMember = Eco.Web.AspProviders.ASP_PersonalizationInfo.Eco_LoopbackIndices.Eco_MemberCount;
Remarks

This is Eco_FirstMember, a member of class Eco_LoopbackIndices.

See Also
ASP_PersonalizationUser.Eco_LoopbackIndices Class
Eco.Web.AspProviders Namespace


ASP_PersonalizationUser.Eco_LoopbackIndices.Eco_MemberCount Field

ASP_PersonalizationUser.Eco_LoopbackIndices.Eco_MemberCount Field
ASP_PersonalizationUser.Eco_LoopbackIndices Class Eco.Web.AspProviders Namespace See Also
Collapse All
C#
public const int Eco_MemberCount = (LastActivityDate + 1);
Remarks

This is Eco_MemberCount, a member of class Eco_LoopbackIndices.

See Also
ASP_PersonalizationUser.Eco_LoopbackIndices Class
Eco.Web.AspProviders Namespace


ASP_PersonalizationUser.Eco_LoopbackIndices.LastActivityDate Field

ASP_PersonalizationUser.Eco_LoopbackIndices.LastActivityDate Field
ASP_PersonalizationUser.Eco_LoopbackIndices Class Eco.Web.AspProviders Namespace See Also
Collapse All
C#
public const int LastActivityDate = (UserName + 1);
Remarks

This is LastActivityDate, a member of class Eco_LoopbackIndices.

See Also
ASP_PersonalizationUser.Eco_LoopbackIndices Class
Eco.Web.AspProviders Namespace


ASP_PersonalizationUser.Eco_LoopbackIndices.UserName Field

ASP_PersonalizationUser.Eco_LoopbackIndices.UserName Field
ASP_PersonalizationUser.Eco_LoopbackIndices Class Eco.Web.AspProviders Namespace See Also
Collapse All
C#
public const int UserName = Eco_FirstMember;
Remarks

This is UserName, a member of class Eco_LoopbackIndices.

See Also
ASP_PersonalizationUser.Eco_LoopbackIndices Class
Eco.Web.AspProviders Namespace


ASP_PersonalizationUser Methods

ASP_PersonalizationUser Methods
Public Methods
Collapse All

The methods of the ASP_PersonalizationUser class are listed here.

Public Methods
Name | Description
get_MemberByIndex | This is get_MemberByIndex, a member of class ASP_PersonalizationUser.
set_MemberByIndex | This is set_MemberByIndex, a member of class ASP_PersonalizationUser.


ASP_PersonalizationUser.get_MemberByIndex Method

ASP_PersonalizationUser.get_MemberByIndex Method
ASP_PersonalizationUser Class Eco.Web.AspProviders Namespace See Also
Collapse All
C#
public override object get_MemberByIndex(
    int index
);
Remarks

This is get_MemberByIndex, a member of class ASP_PersonalizationUser.

See Also
ASP_PersonalizationUser Class
Eco.Web.AspProviders Namespace


ASP_PersonalizationUser.set_MemberByIndex Method

ASP_PersonalizationUser.set_MemberByIndex Method
ASP_PersonalizationUser Class Eco.Web.AspProviders Namespace See Also
Collapse All
C#
public override void set_MemberByIndex(
    int index,
    object value
);
Remarks

This is set_MemberByIndex, a member of class ASP_PersonalizationUser.

See Also
ASP_PersonalizationUser Class
Eco.Web.AspProviders Namespace


ASP_PersonalizationUser Properties

ASP_PersonalizationUser Properties
Public Properties
Collapse All

The properties of the ASP_PersonalizationUser class are listed here.

Public Properties
Name | Description
LastActivityDate | This is LastActivityDate, a member of class ASP_PersonalizationUser.
UserName | This is UserName, a member of class ASP_PersonalizationUser.


ASP_PersonalizationUser.LastActivityDate Property

ASP_PersonalizationUser.LastActivityDate Property
ASP_PersonalizationUser Class Eco.Web.AspProviders Namespace See Also
Collapse All
C#
public System.DateTime LastActivityDate;
Remarks

This is LastActivityDate, a member of class ASP_PersonalizationUser.

See Also
ASP_PersonalizationUser Class
Eco.Web.AspProviders Namespace


ASP_PersonalizationUser.UserName Property

ASP_PersonalizationUser.UserName Property
ASP_PersonalizationUser Class Eco.Web.AspProviders Namespace See Also
Collapse All
C#
public string UserName;
Remarks

This is UserName, a member of class ASP_PersonalizationUser.

See Also
ASP_PersonalizationUser Class
Eco.Web.AspProviders Namespace


ASP_Profile Class

ASP_Profile Class
Inheritance Hierarchy See Also
Collapse All
C#
public class ASP_Profile : Eco.ObjectImplementation.ILoopBack2, System.ComponentModel.INotifyPropertyChanged;
Remarks

This is class Eco.Web.AspProviders.ASP_Profile.

Inheritance Hierarchy
Eco.Web.AspProviders.ASP_Profile
File

ASP_Profile.eco.cs

See Also
Inheritance Hierarchy


ASP_Profile Constructor

ASP_Profile Constructor

This is the overview for the ASP_Profile constructor overload.

Overload List
Name | Description
ASP_Profile.ASP_Profile (Eco.ObjectImplementation.IContent) | For framework internal use only
ASP_Profile.ASP_Profile (Eco.ObjectRepresentation.IEcoServiceProvider) | This is ASP_Profile, a member of class ASP_Profile.


ASP_Profile.ASP_Profile Constructor (Eco.ObjectImplementation.IContent)

ASP_Profile.ASP_Profile Constructor (Eco.ObjectImplementation.IContent)
ASP_Profile Class Eco.Web.AspProviders Namespace See Also
Collapse All
C#
protected ASP_Profile(
    Eco.ObjectImplementation.IContent content
);
Remarks

For framework internal use only

See Also
ASP_Profile Class
Eco.Web.AspProviders Namespace


ASP_Profile.ASP_Profile Constructor (Eco.ObjectRepresentation.IEcoServiceProvider)

ASP_Profile.ASP_Profile Constructor (Eco.ObjectRepresentation.IEcoServiceProvider)
ASP_Profile Class Eco.Web.AspProviders Namespace See Also
Collapse All
C#
public ASP_Profile(
    Eco.ObjectRepresentation.IEcoServiceProvider serviceProvider
);
Remarks

This is ASP_Profile, a member of class ASP_Profile.

See Also
ASP_Profile Class
Eco.Web.AspProviders Namespace


ASP_Profile Classes

ASP_Profile Classes
Classes
Collapse All

The classes of the ASP_Profile class are listed here.

Classes
Name | Description
Eco_LoopbackIndices | This is class Eco.Web.AspProviders.ASP_Profile.Eco_LoopbackIndices.


ASP_Profile.Eco_LoopbackIndices Class

ASP_Profile.Eco_LoopbackIndices Class
Inheritance Hierarchy See Also
Collapse All
C#
public class Eco_LoopbackIndices;
Remarks

This is class Eco.Web.AspProviders.ASP_Profile.Eco_LoopbackIndices.

Inheritance Hierarchy
Eco.Web.AspProviders.ASP_Profile.Eco_LoopbackIndices
File

ASP_Profile.eco.cs

See Also
Inheritance Hierarchy


Eco_LoopbackIndices Fields

Eco_LoopbackIndices Fields
Public Fields
Collapse All

The fields of the Eco_LoopbackIndices class are listed here.

Public Fields
Name | Description
ApplicationName | This is ApplicationName, a member of class Eco_LoopbackIndices.
Eco_FirstMember | This is Eco_FirstMember, a member of class Eco_LoopbackIndices.
Eco_MemberCount | This is Eco_MemberCount, a member of class Eco_LoopbackIndices.
IsAuthenticated | This is IsAuthenticated, a member of class Eco_LoopbackIndices.
LastActivityDate | This is LastActivityDate, a member of class Eco_LoopbackIndices.
LastUpdatedDate | This is LastUpdatedDate, a member of class Eco_LoopbackIndices.
User | This is User, a member of class Eco_LoopbackIndices.
UserName | This is UserName, a member of class Eco_LoopbackIndices.
Values | This is Values, a member of class Eco_LoopbackIndices.


ASP_Profile.Eco_LoopbackIndices.ApplicationName Field

ASP_Profile.Eco_LoopbackIndices.ApplicationName Field
ASP_Profile.Eco_LoopbackIndices Class Eco.Web.AspProviders Namespace See Also
Collapse All
C#
public const int ApplicationName = (UserName + 1);
Remarks

This is ApplicationName, a member of class Eco_LoopbackIndices.

See Also
ASP_Profile.Eco_LoopbackIndices Class
Eco.Web.AspProviders Namespace


ASP_Profile.Eco_LoopbackIndices.Eco_FirstMember Field

ASP_Profile.Eco_LoopbackIndices.Eco_FirstMember Field
ASP_Profile.Eco_LoopbackIndices Class Eco.Web.AspProviders Namespace See Also
Collapse All
C#
public const int Eco_FirstMember = 0;
Remarks

This is Eco_FirstMember, a member of class Eco_LoopbackIndices.

See Also
ASP_Profile.Eco_LoopbackIndices Class
Eco.Web.AspProviders Namespace


ASP_Profile.Eco_LoopbackIndices.Eco_MemberCount Field

ASP_Profile.Eco_LoopbackIndices.Eco_MemberCount Field
ASP_Profile.Eco_LoopbackIndices Class Eco.Web.AspProviders Namespace See Also
Collapse All
C#
public const int Eco_MemberCount = (User + 1);
Remarks

This is Eco_MemberCount, a member of class Eco_LoopbackIndices.

See Also
ASP_Profile.Eco_LoopbackIndices Class
Eco.Web.AspProviders Namespace


ASP_Profile.Eco_LoopbackIndices.IsAuthenticated Field

ASP_Profile.Eco_LoopbackIndices.IsAuthenticated Field
ASP_Profile.Eco_LoopbackIndices Class Eco.Web.AspProviders Namespace See Also
Collapse All
C#
public const int IsAuthenticated = (LastActivityDate + 1);
Remarks

This is IsAuthenticated, a member of class Eco_LoopbackIndices.

See Also
ASP_Profile.Eco_LoopbackIndices Class
Eco.Web.AspProviders Namespace


ASP_Profile.Eco_LoopbackIndices.LastActivityDate Field

ASP_Profile.Eco_LoopbackIndices.LastActivityDate Field
ASP_Profile.Eco_LoopbackIndices Class Eco.Web.AspProviders Namespace See Also
Collapse All
C#
public const int LastActivityDate = (ApplicationName + 1);
Remarks

This is LastActivityDate, a member of class Eco_LoopbackIndices.

See Also
ASP_Profile.Eco_LoopbackIndices Class
Eco.Web.AspProviders Namespace


ASP_Profile.Eco_LoopbackIndices.LastUpdatedDate Field

ASP_Profile.Eco_LoopbackIndices.LastUpdatedDate Field
ASP_Profile.Eco_LoopbackIndices Class Eco.Web.AspProviders Namespace See Also
Collapse All
C#
public const int LastUpdatedDate = (IsAuthenticated + 1);
Remarks

This is LastUpdatedDate, a member of class Eco_LoopbackIndices.

See Also
ASP_Profile.Eco_LoopbackIndices Class
Eco.Web.AspProviders Namespace


ASP_Profile.Eco_LoopbackIndices.User Field

ASP_Profile.Eco_LoopbackIndices.User Field
ASP_Profile.Eco_LoopbackIndices Class Eco.Web.AspProviders Namespace See Also
Collapse All
C#
public const int User = (Values + 1);
Remarks

This is User, a member of class Eco_LoopbackIndices.

See Also
ASP_Profile.Eco_LoopbackIndices Class
Eco.Web.AspProviders Namespace


ASP_Profile.Eco_LoopbackIndices.UserName Field

ASP_Profile.Eco_LoopbackIndices.UserName Field
ASP_Profile.Eco_LoopbackIndices Class Eco.Web.AspProviders Namespace See Also
Collapse All
C#
public const int UserName = Eco_FirstMember;
Remarks

This is UserName, a member of class Eco_LoopbackIndices.

See Also
ASP_Profile.Eco_LoopbackIndices Class
Eco.Web.AspProviders Namespace


ASP_Profile.Eco_LoopbackIndices.Values Field

ASP_Profile.Eco_LoopbackIndices.Values Field
ASP_Profile.Eco_LoopbackIndices Class Eco.Web.AspProviders Namespace See Also
Collapse All
C#
public const int Values = (LastUpdatedDate + 1);
Remarks

This is Values, a member of class Eco_LoopbackIndices.

See Also
ASP_Profile.Eco_LoopbackIndices Class
Eco.Web.AspProviders Namespace


ASP_Profile Fields

ASP_Profile Fields
Protected Fields
Collapse All

The fields of the ASP_Profile class are listed here.

Protected Fields
Name | Description
eco_Content | This is eco_Content, a member of class ASP_Profile.


ASP_Profile.eco_Content Field

ASP_Profile.eco_Content Field
ASP_Profile Class Eco.Web.AspProviders Namespace See Also
Collapse All
C#
protected Eco.ObjectImplementation.IContent eco_Content;
Remarks

This is eco_Content, a member of class ASP_Profile.

See Also
ASP_Profile Class
Eco.Web.AspProviders Namespace


ASP_Profile Methods

ASP_Profile Methods
Protected Methods Public Methods
Collapse All

The methods of the ASP_Profile class are listed here.

Protected Methods
Name | Description
Deinitialize | This is Deinitialize, a member of class ASP_Profile.
Initialize | This is Initialize, a member of class ASP_Profile.
Top
Public Methods
Name | Description
AsIObject | This is AsIObject, a member of class ASP_Profile.
get_MemberByIndex | This is get_MemberByIndex, a member of class ASP_Profile.
set_MemberByIndex | This is set_MemberByIndex, a member of class ASP_Profile.


ASP_Profile.AsIObject Method

ASP_Profile.AsIObject Method
ASP_Profile Class Eco.Web.AspProviders Namespace See Also
Collapse All
C#
public virtual Eco.ObjectRepresentation.IObjectInstance AsIObject();
Remarks

This is AsIObject, a member of class ASP_Profile.

See Also
ASP_Profile Class
Eco.Web.AspProviders Namespace


ASP_Profile.Deinitialize Method

ASP_Profile.Deinitialize Method
ASP_Profile Class Eco.Web.AspProviders Namespace See Also
Collapse All
C#
protected virtual void Deinitialize(
    Eco.ObjectRepresentation.IEcoServiceProvider serviceProvider
);
Remarks

This is Deinitialize, a member of class ASP_Profile.

See Also
ASP_Profile Class
Eco.Web.AspProviders Namespace


ASP_Profile.get_MemberByIndex Method

ASP_Profile.get_MemberByIndex Method
ASP_Profile Class Eco.Web.AspProviders Namespace See Also
Collapse All
C#
public virtual object get_MemberByIndex(
    int index
);
Remarks

This is get_MemberByIndex, a member of class ASP_Profile.

See Also
ASP_Profile Class
Eco.Web.AspProviders Namespace


ASP_Profile.Initialize Method

ASP_Profile.Initialize Method
ASP_Profile Class Eco.Web.AspProviders Namespace See Also
Collapse All
C#
protected virtual void Initialize(
    Eco.ObjectRepresentation.IEcoServiceProvider serviceProvider
);
Remarks

This is Initialize, a member of class ASP_Profile.

See Also
ASP_Profile Class
Eco.Web.AspProviders Namespace


ASP_Profile.set_MemberByIndex Method

ASP_Profile.set_MemberByIndex Method
ASP_Profile Class Eco.Web.AspProviders Namespace See Also
Collapse All
C#
public virtual void set_MemberByIndex(
    int index,
    object value
);
Remarks

This is set_MemberByIndex, a member of class ASP_Profile.

See Also
ASP_Profile Class
Eco.Web.AspProviders Namespace


ASP_Profile Properties

ASP_Profile Properties
Public Properties
Collapse All

The properties of the ASP_Profile class are listed here.

Public Properties
Name | Description
ApplicationName | This is ApplicationName, a member of class ASP_Profile.
IsAuthenticated | This is IsAuthenticated, a member of class ASP_Profile.
LastActivityDate | This is LastActivityDate, a member of class ASP_Profile.
LastUpdatedDate | This is LastUpdatedDate, a member of class ASP_Profile.
User | This is User, a member of class ASP_Profile.
UserName | This is UserName, a member of class ASP_Profile.
Values | This is Values, a member of class ASP_Profile.


ASP_Profile.ApplicationName Property

ASP_Profile.ApplicationName Property
ASP_Profile Class Eco.Web.AspProviders Namespace See Also
Collapse All
C#
public string ApplicationName;
Remarks

This is ApplicationName, a member of class ASP_Profile.

See Also
ASP_Profile Class
Eco.Web.AspProviders Namespace


ASP_Profile.IsAuthenticated Property

ASP_Profile.IsAuthenticated Property
ASP_Profile Class Eco.Web.AspProviders Namespace See Also
Collapse All
C#
public bool IsAuthenticated;
Remarks

This is IsAuthenticated, a member of class ASP_Profile.

See Also
ASP_Profile Class
Eco.Web.AspProviders Namespace


ASP_Profile.LastActivityDate Property

ASP_Profile.LastActivityDate Property
ASP_Profile Class Eco.Web.AspProviders Namespace See Also
Collapse All
C#
public System.DateTime LastActivityDate;
Remarks

This is LastActivityDate, a member of class ASP_Profile.

See Also
ASP_Profile Class
Eco.Web.AspProviders Namespace


ASP_Profile.LastUpdatedDate Property

ASP_Profile.LastUpdatedDate Property
ASP_Profile Class Eco.Web.AspProviders Namespace See Also
Collapse All
C#
public System.DateTime LastUpdatedDate;
Remarks

This is LastUpdatedDate, a member of class ASP_Profile.

See Also
ASP_Profile Class
Eco.Web.AspProviders Namespace


ASP_Profile.User Property

ASP_Profile.User Property
ASP_Profile Class Eco.Web.AspProviders Namespace See Also
Collapse All
C#
public ASP_User User;
Remarks

This is User, a member of class ASP_Profile.

See Also
ASP_Profile Class
Eco.Web.AspProviders Namespace


ASP_Profile.UserName Property

ASP_Profile.UserName Property
ASP_Profile Class Eco.Web.AspProviders Namespace See Also
Collapse All
C#
public string UserName;
Remarks

This is UserName, a member of class ASP_Profile.

See Also
ASP_Profile Class
Eco.Web.AspProviders Namespace


ASP_Profile.Values Property

ASP_Profile.Values Property
ASP_Profile Class Eco.Web.AspProviders Namespace See Also
Collapse All
C#
public IEcoList<ASP_ProfilePropValue> Values;
Remarks

This is Values, a member of class ASP_Profile.

See Also
ASP_Profile Class
Eco.Web.AspProviders Namespace


ASP_ProfilePropValue Class

ASP_ProfilePropValue Class
Inheritance Hierarchy See Also
Collapse All
C#
public abstract class ASP_ProfilePropValue : Eco.ObjectImplementation.ILoopBack2, System.ComponentModel.INotifyPropertyChanged;
Remarks

This is class Eco.Web.AspProviders.ASP_ProfilePropValue.

Inheritance Hierarchy
Eco.Web.AspProviders.ASP_ProfilePropValue
File

ASP_ProfilePropValue.eco.cs

See Also
Inheritance Hierarchy


ASP_ProfilePropValue Constructor

ASP_ProfilePropValue Constructor

This is the overview for the ASP_ProfilePropValue constructor overload.

Overload List
Name | Description
ASP_ProfilePropValue.ASP_ProfilePropValue (Eco.ObjectImplementation.IContent) | For framework internal use only
ASP_ProfilePropValue.ASP_ProfilePropValue (Eco.ObjectRepresentation.IEcoServiceProvider) | This is ASP_ProfilePropValue, a member of class ASP_ProfilePropValue.


ASP_ProfilePropValue.ASP_ProfilePropValue Constructor (Eco.ObjectImplementation.IContent)

ASP_ProfilePropValue.ASP_ProfilePropValue Constructor (Eco.ObjectImplementation.IContent)
ASP_ProfilePropValue Class Eco.Web.AspProviders Namespace See Also
Collapse All
C#
protected ASP_ProfilePropValue(
    Eco.ObjectImplementation.IContent content
);
Remarks

For framework internal use only

See Also
ASP_ProfilePropValue Class
Eco.Web.AspProviders Namespace


ASP_ProfilePropValue.ASP_ProfilePropValue Constructor (Eco.ObjectRepresentation.IEcoServiceProvider)

ASP_ProfilePropValue.ASP_ProfilePropValue Constructor (Eco.ObjectRepresentation.IEcoServiceProvider)
ASP_ProfilePropValue Class Eco.Web.AspProviders Namespace See Also
Collapse All
C#
public ASP_ProfilePropValue(
    Eco.ObjectRepresentation.IEcoServiceProvider serviceProvider
);
Remarks

This is ASP_ProfilePropValue, a member of class ASP_ProfilePropValue.

See Also
ASP_ProfilePropValue Class
Eco.Web.AspProviders Namespace


ASP_ProfilePropValue Classes

ASP_ProfilePropValue Classes
Classes
Collapse All

The classes of the ASP_ProfilePropValue class are listed here.

Classes
Name | Description
Eco_LoopbackIndices | This is class Eco.Web.AspProviders.ASP_ProfilePropValue.Eco_LoopbackIndices.


ASP_ProfilePropValue.Eco_LoopbackIndices Class

ASP_ProfilePropValue.Eco_LoopbackIndices Class
Inheritance Hierarchy See Also
Collapse All
C#
public class Eco_LoopbackIndices;
Remarks

This is class Eco.Web.AspProviders.ASP_ProfilePropValue.Eco_LoopbackIndices.

Inheritance Hierarchy
Eco.Web.AspProviders.ASP_ProfilePropValue.Eco_LoopbackIndices
File

ASP_ProfilePropValue.eco.cs

See Also
Inheritance Hierarchy


Eco_LoopbackIndices Fields

Eco_LoopbackIndices Fields
Public Fields
Collapse All

The fields of the Eco_LoopbackIndices class are listed here.

Public Fields
Name | Description
Eco_FirstMember | This is Eco_FirstMember, a member of class Eco_LoopbackIndices.
Eco_MemberCount | This is Eco_MemberCount, a member of class Eco_LoopbackIndices.
Name | This is Name, a member of class Eco_LoopbackIndices.
Profile | This is Profile, a member of class Eco_LoopbackIndices.


ASP_ProfilePropValue.Eco_LoopbackIndices.Eco_FirstMember Field

ASP_ProfilePropValue.Eco_LoopbackIndices.Eco_FirstMember Field
ASP_ProfilePropValue.Eco_LoopbackIndices Class Eco.Web.AspProviders Namespace See Also
Collapse All
C#
public const int Eco_FirstMember = 0;
Remarks

This is Eco_FirstMember, a member of class Eco_LoopbackIndices.

See Also
ASP_ProfilePropValue.Eco_LoopbackIndices Class
Eco.Web.AspProviders Namespace


ASP_ProfilePropValue.Eco_LoopbackIndices.Eco_MemberCount Field

ASP_ProfilePropValue.Eco_LoopbackIndices.Eco_MemberCount Field
ASP_ProfilePropValue.Eco_LoopbackIndices Class Eco.Web.AspProviders Namespace See Also
Collapse All
C#
public const int Eco_MemberCount = (Profile + 1);
Remarks

This is Eco_MemberCount, a member of class Eco_LoopbackIndices.

See Also
ASP_ProfilePropValue.Eco_LoopbackIndices Class
Eco.Web.AspProviders Namespace


ASP_ProfilePropValue.Eco_LoopbackIndices.Name Field

ASP_ProfilePropValue.Eco_LoopbackIndices.Name Field
ASP_ProfilePropValue.Eco_LoopbackIndices Class Eco.Web.AspProviders Namespace See Also
Collapse All
C#
public const int Name = Eco_FirstMember;
Remarks

This is Name, a member of class Eco_LoopbackIndices.

See Also
ASP_ProfilePropValue.Eco_LoopbackIndices Class
Eco.Web.AspProviders Namespace


ASP_ProfilePropValue.Eco_LoopbackIndices.Profile Field

ASP_ProfilePropValue.Eco_LoopbackIndices.Profile Field
ASP_ProfilePropValue.Eco_LoopbackIndices Class Eco.Web.AspProviders Namespace See Also
Collapse All
C#
public const int Profile = (Name + 1);
Remarks

This is Profile, a member of class Eco_LoopbackIndices.

See Also
ASP_ProfilePropValue.Eco_LoopbackIndices Class
Eco.Web.AspProviders Namespace


ASP_ProfilePropValue Fields

ASP_ProfilePropValue Fields
Protected Fields
Collapse All

The fields of the ASP_ProfilePropValue class are listed here.

Protected Fields
Name | Description
eco_Content | This is eco_Content, a member of class ASP_ProfilePropValue.


ASP_ProfilePropValue.eco_Content Field

ASP_ProfilePropValue.eco_Content Field
ASP_ProfilePropValue Class Eco.Web.AspProviders Namespace See Also
Collapse All
C#
protected Eco.ObjectImplementation.IContent eco_Content;
Remarks

This is eco_Content, a member of class ASP_ProfilePropValue.

See Also
ASP_ProfilePropValue Class
Eco.Web.AspProviders Namespace


ASP_ProfilePropValue Methods

ASP_ProfilePropValue Methods
Protected Methods Public Methods
Collapse All

The methods of the ASP_ProfilePropValue class are listed here.

Protected Methods
Name | Description
Deinitialize | This is Deinitialize, a member of class ASP_ProfilePropValue.
Initialize | This is Initialize, a member of class ASP_ProfilePropValue.
Top
Public Methods
Name | Description
AsIObject | This is AsIObject, a member of class ASP_ProfilePropValue.
get_MemberByIndex | This is get_MemberByIndex, a member of class ASP_ProfilePropValue.
GetValue | This is GetValue, a member of class ASP_ProfilePropValue.
set_MemberByIndex | This is set_MemberByIndex, a member of class ASP_ProfilePropValue.


ASP_ProfilePropValue.AsIObject Method

ASP_ProfilePropValue.AsIObject Method
ASP_ProfilePropValue Class Eco.Web.AspProviders Namespace See Also
Collapse All
C#
public virtual Eco.ObjectRepresentation.IObjectInstance AsIObject();
Remarks

This is AsIObject, a member of class ASP_ProfilePropValue.

See Also
ASP_ProfilePropValue Class
Eco.Web.AspProviders Namespace


ASP_ProfilePropValue.Deinitialize Method

ASP_ProfilePropValue.Deinitialize Method
ASP_ProfilePropValue Class Eco.Web.AspProviders Namespace See Also
Collapse All
C#
protected virtual void Deinitialize(
    Eco.ObjectRepresentation.IEcoServiceProvider serviceProvider
);
Remarks

This is Deinitialize, a member of class ASP_ProfilePropValue.

See Also
ASP_ProfilePropValue Class
Eco.Web.AspProviders Namespace


ASP_ProfilePropValue.get_MemberByIndex Method

ASP_ProfilePropValue.get_MemberByIndex Method
ASP_ProfilePropValue Class Eco.Web.AspProviders Namespace See Also
Collapse All
C#
public virtual object get_MemberByIndex(
    int index
);
Remarks

This is get_MemberByIndex, a member of class ASP_ProfilePropValue.

See Also
ASP_ProfilePropValue Class
Eco.Web.AspProviders Namespace


ASP_ProfilePropValue.GetValue Method

ASP_ProfilePropValue.GetValue Method
ASP_ProfilePropValue Class Eco.Web.AspProviders Namespace See Also
Collapse All
C#
public abstract object GetValue();
Remarks

This is GetValue, a member of class ASP_ProfilePropValue.

See Also
ASP_ProfilePropValue Class
Eco.Web.AspProviders Namespace


ASP_ProfilePropValue.Initialize Method

ASP_ProfilePropValue.Initialize Method
ASP_ProfilePropValue Class Eco.Web.AspProviders Namespace See Also
Collapse All
C#
protected virtual void Initialize(
    Eco.ObjectRepresentation.IEcoServiceProvider serviceProvider
);
Remarks

This is Initialize, a member of class ASP_ProfilePropValue.

See Also
ASP_ProfilePropValue Class
Eco.Web.AspProviders Namespace


ASP_ProfilePropValue.set_MemberByIndex Method

ASP_ProfilePropValue.set_MemberByIndex Method
ASP_ProfilePropValue Class Eco.Web.AspProviders Namespace See Also
Collapse All
C#
public virtual void set_MemberByIndex(
    int index,
    object value
);
Remarks

This is set_MemberByIndex, a member of class ASP_ProfilePropValue.

See Also
ASP_ProfilePropValue Class
Eco.Web.AspProviders Namespace


ASP_ProfilePropValue Properties

ASP_ProfilePropValue Properties
Public Properties
Collapse All

The properties of the ASP_ProfilePropValue class are listed here.

Public Properties
Name | Description
Name | This is Name, a member of class ASP_ProfilePropValue.
Profile | This is Profile, a member of class ASP_ProfilePropValue.


ASP_ProfilePropValue.Name Property

ASP_ProfilePropValue.Name Property
ASP_ProfilePropValue Class Eco.Web.AspProviders Namespace See Also
Collapse All
C#
public string Name;
Remarks

This is Name, a member of class ASP_ProfilePropValue.

See Also
ASP_ProfilePropValue Class
Eco.Web.AspProviders Namespace


ASP_ProfilePropValue.Profile Property

ASP_ProfilePropValue.Profile Property
ASP_ProfilePropValue Class Eco.Web.AspProviders Namespace See Also
Collapse All
C#
public ASP_Profile Profile;
Remarks

This is Profile, a member of class ASP_ProfilePropValue.

See Also
ASP_ProfilePropValue Class
Eco.Web.AspProviders Namespace


ASP_Role Class

ASP_Role Class
Inheritance Hierarchy See Also
Collapse All
C#
public class ASP_Role : Eco.ObjectImplementation.ILoopBack2, System.ComponentModel.INotifyPropertyChanged;
Remarks

This is class Eco.Web.AspProviders.ASP_Role.

Inheritance Hierarchy
Eco.Web.AspProviders.ASP_Role
File

ASP_Role.eco.cs

See Also
Inheritance Hierarchy


ASP_Role Constructor

ASP_Role Constructor

This is the overview for the ASP_Role constructor overload.

Overload List
Name | Description
ASP_Role.ASP_Role (Eco.ObjectImplementation.IContent) | For framework internal use only
ASP_Role.ASP_Role (Eco.ObjectRepresentation.IEcoServiceProvider) | This is ASP_Role, a member of class ASP_Role.


ASP_Role.ASP_Role Constructor (Eco.ObjectImplementation.IContent)

ASP_Role.ASP_Role Constructor (Eco.ObjectImplementation.IContent)
ASP_Role Class Eco.Web.AspProviders Namespace See Also
Collapse All
C#
protected ASP_Role(
    Eco.ObjectImplementation.IContent content
);
Remarks

For framework internal use only

See Also
ASP_Role Class
Eco.Web.AspProviders Namespace


ASP_Role.ASP_Role Constructor (Eco.ObjectRepresentation.IEcoServiceProvider)

ASP_Role.ASP_Role Constructor (Eco.ObjectRepresentation.IEcoServiceProvider)
ASP_Role Class Eco.Web.AspProviders Namespace See Also
Collapse All
C#
public ASP_Role(
    Eco.ObjectRepresentation.IEcoServiceProvider serviceProvider
);
Remarks

This is ASP_Role, a member of class ASP_Role.

See Also
ASP_Role Class
Eco.Web.AspProviders Namespace


ASP_Role Classes

ASP_Role Classes
Classes
Collapse All

The classes of the ASP_Role class are listed here.

Classes
Name | Description
Eco_LoopbackIndices | This is class Eco.Web.AspProviders.ASP_Role.Eco_LoopbackIndices.


ASP_Role.Eco_LoopbackIndices Class

ASP_Role.Eco_LoopbackIndices Class
Inheritance Hierarchy See Also
Collapse All
C#
public class Eco_LoopbackIndices;
Remarks

This is class Eco.Web.AspProviders.ASP_Role.Eco_LoopbackIndices.

Inheritance Hierarchy
Eco.Web.AspProviders.ASP_Role.Eco_LoopbackIndices
File

ASP_Role.eco.cs

See Also
Inheritance Hierarchy


Eco_LoopbackIndices Fields

Eco_LoopbackIndices Fields
Public Fields
Collapse All

The fields of the Eco_LoopbackIndices class are listed here.

Public Fields
Name | Description
ApplicationName | This is ApplicationName, a member of class Eco_LoopbackIndices.
Eco_FirstMember | This is Eco_FirstMember, a member of class Eco_LoopbackIndices.
Eco_MemberCount | This is Eco_MemberCount, a member of class Eco_LoopbackIndices.
Name | This is Name, a member of class Eco_LoopbackIndices.
RoleUsers | This is RoleUsers, a member of class Eco_LoopbackIndices.
Users | This is Users, a member of class Eco_LoopbackIndices.


ASP_Role.Eco_LoopbackIndices.ApplicationName Field

ASP_Role.Eco_LoopbackIndices.ApplicationName Field
ASP_Role.Eco_LoopbackIndices Class Eco.Web.AspProviders Namespace See Also
Collapse All
C#
public const int ApplicationName = Eco_FirstMember;
Remarks

This is ApplicationName, a member of class Eco_LoopbackIndices.

See Also
ASP_Role.Eco_LoopbackIndices Class
Eco.Web.AspProviders Namespace


ASP_Role.Eco_LoopbackIndices.Eco_FirstMember Field

ASP_Role.Eco_LoopbackIndices.Eco_FirstMember Field
ASP_Role.Eco_LoopbackIndices Class Eco.Web.AspProviders Namespace See Also
Collapse All
C#
public const int Eco_FirstMember = 0;
Remarks

This is Eco_FirstMember, a member of class Eco_LoopbackIndices.

See Also
ASP_Role.Eco_LoopbackIndices Class
Eco.Web.AspProviders Namespace


ASP_Role.Eco_LoopbackIndices.Eco_MemberCount Field

ASP_Role.Eco_LoopbackIndices.Eco_MemberCount Field
ASP_Role.Eco_LoopbackIndices Class Eco.Web.AspProviders Namespace See Also
Collapse All
C#
public const int Eco_MemberCount = (Users + 1);
Remarks

This is Eco_MemberCount, a member of class Eco_LoopbackIndices.

See Also
ASP_Role.Eco_LoopbackIndices Class
Eco.Web.AspProviders Namespace


ASP_Role.Eco_LoopbackIndices.Name Field

ASP_Role.Eco_LoopbackIndices.Name Field
ASP_Role.Eco_LoopbackIndices Class Eco.Web.AspProviders Namespace See Also
Collapse All
C#
public const int Name = (ApplicationName + 1);
Remarks

This is Name, a member of class Eco_LoopbackIndices.

See Also
ASP_Role.Eco_LoopbackIndices Class
Eco.Web.AspProviders Namespace


ASP_Role.Eco_LoopbackIndices.RoleUsers Field

ASP_Role.Eco_LoopbackIndices.RoleUsers Field
ASP_Role.Eco_LoopbackIndices Class Eco.Web.AspProviders Namespace See Also
Collapse All
C#
public const int RoleUsers = (Name + 1);
Remarks

This is RoleUsers, a member of class Eco_LoopbackIndices.

See Also
ASP_Role.Eco_LoopbackIndices Class
Eco.Web.AspProviders Namespace


ASP_Role.Eco_LoopbackIndices.Users Field

ASP_Role.Eco_LoopbackIndices.Users Field
ASP_Role.Eco_LoopbackIndices Class Eco.Web.AspProviders Namespace See Also
Collapse All
C#
public const int Users = (RoleUsers + 1);
Remarks

This is Users, a member of class Eco_LoopbackIndices.

See Also
ASP_Role.Eco_LoopbackIndices Class
Eco.Web.AspProviders Namespace


ASP_Role Fields

ASP_Role Fields
Protected Fields
Collapse All

The fields of the ASP_Role class are listed here.

Protected Fields
Name | Description
eco_Content | This is eco_Content, a member of class ASP_Role.


ASP_Role.eco_Content Field

ASP_Role.eco_Content Field
ASP_Role Class Eco.Web.AspProviders Namespace See Also
Collapse All
C#
protected Eco.ObjectImplementation.IContent eco_Content;
Remarks

This is eco_Content, a member of class ASP_Role.

See Also
ASP_Role Class
Eco.Web.AspProviders Namespace


ASP_Role Methods

ASP_Role Methods
Protected Methods Public Methods
Collapse All

The methods of the ASP_Role class are listed here.

Protected Methods
Name | Description
Deinitialize | This is Deinitialize, a member of class ASP_Role.
Initialize | This is Initialize, a member of class ASP_Role.
Top
Public Methods
Name | Description
AsIObject | This is AsIObject, a member of class ASP_Role.
get_MemberByIndex | This is get_MemberByIndex, a member of class ASP_Role.
set_MemberByIndex | This is set_MemberByIndex, a member of class ASP_Role.


ASP_Role.AsIObject Method

ASP_Role.AsIObject Method
ASP_Role Class Eco.Web.AspProviders Namespace See Also
Collapse All
C#
public virtual Eco.ObjectRepresentation.IObjectInstance AsIObject();
Remarks

This is AsIObject, a member of class ASP_Role.

See Also
ASP_Role Class
Eco.Web.AspProviders Namespace


ASP_Role.Deinitialize Method

ASP_Role.Deinitialize Method
ASP_Role Class Eco.Web.AspProviders Namespace See Also
Collapse All
C#
protected virtual void Deinitialize(
    Eco.ObjectRepresentation.IEcoServiceProvider serviceProvider
);
Remarks

This is Deinitialize, a member of class ASP_Role.

See Also
ASP_Role Class
Eco.Web.AspProviders Namespace


ASP_Role.get_MemberByIndex Method

ASP_Role.get_MemberByIndex Method
ASP_Role Class Eco.Web.AspProviders Namespace See Also
Collapse All
C#
public virtual object get_MemberByIndex(
    int index
);
Remarks

This is get_MemberByIndex, a member of class ASP_Role.

See Also
ASP_Role Class
Eco.Web.AspProviders Namespace


ASP_Role.Initialize Method

ASP_Role.Initialize Method
ASP_Role Class Eco.Web.AspProviders Namespace See Also
Collapse All
C#
protected virtual void Initialize(
    Eco.ObjectRepresentation.IEcoServiceProvider serviceProvider
);
Remarks

This is Initialize, a member of class ASP_Role.

See Also
ASP_Role Class
Eco.Web.AspProviders Namespace


ASP_Role.set_MemberByIndex Method

ASP_Role.set_MemberByIndex Method
ASP_Role Class Eco.Web.AspProviders Namespace See Also
Collapse All
C#
public virtual void set_MemberByIndex(
    int index,
    object value
);
Remarks

This is set_MemberByIndex, a member of class ASP_Role.

See Also
ASP_Role Class
Eco.Web.AspProviders Namespace


ASP_Role Properties

ASP_Role Properties
Public Properties
Collapse All

The properties of the ASP_Role class are listed here.

Public Properties
Name | Description
ApplicationName | This is ApplicationName, a member of class ASP_Role.
Name | This is Name, a member of class ASP_Role.
RoleUsers | This is RoleUsers, a member of class ASP_Role.
Users | This is Users, a member of class ASP_Role.


ASP_Role.ApplicationName Property

ASP_Role.ApplicationName Property
ASP_Role Class Eco.Web.AspProviders Namespace See Also
Collapse All
C#
public string ApplicationName;
Remarks

This is ApplicationName, a member of class ASP_Role.

See Also
ASP_Role Class
Eco.Web.AspProviders Namespace


ASP_Role.Name Property

ASP_Role.Name Property
ASP_Role Class Eco.Web.AspProviders Namespace See Also
Collapse All
C#
public string Name;
Remarks

This is Name, a member of class ASP_Role.

See Also
ASP_Role Class
Eco.Web.AspProviders Namespace


ASP_Role.RoleUsers Property

ASP_Role.RoleUsers Property
ASP_Role Class Eco.Web.AspProviders Namespace See Also
Collapse All
C#
public IEcoList<ASP_RoleUser> RoleUsers;
Remarks

This is RoleUsers, a member of class ASP_Role.

See Also
ASP_Role Class
Eco.Web.AspProviders Namespace


ASP_Role.Users Property

ASP_Role.Users Property
ASP_Role Class Eco.Web.AspProviders Namespace See Also
Collapse All
C#
public IEcoList<ASP_User> Users;
Remarks

This is Users, a member of class ASP_Role.

See Also
ASP_Role Class
Eco.Web.AspProviders Namespace


ASP_RoleUser Class

ASP_RoleUser Class
Inheritance Hierarchy See Also
Collapse All
C#
public class ASP_RoleUser : Eco.ObjectImplementation.ILoopBack2, System.ComponentModel.INotifyPropertyChanged;
Remarks

This is class Eco.Web.AspProviders.ASP_RoleUser.

Inheritance Hierarchy
Eco.Web.AspProviders.ASP_RoleUser
File

ASP_RoleUser.eco.cs

See Also
Inheritance Hierarchy


ASP_RoleUser Constructor

ASP_RoleUser Constructor

This is the overview for the ASP_RoleUser constructor overload.

Overload List
Name | Description
ASP_RoleUser.ASP_RoleUser (Eco.ObjectImplementation.IContent) | For framework internal use only
ASP_RoleUser.ASP_RoleUser (Eco.ObjectRepresentation.IEcoServiceProvider) | This is ASP_RoleUser, a member of class ASP_RoleUser.


ASP_RoleUser.ASP_RoleUser Constructor (Eco.ObjectImplementation.IContent)

ASP_RoleUser.ASP_RoleUser Constructor (Eco.ObjectImplementation.IContent)
ASP_RoleUser Class Eco.Web.AspProviders Namespace See Also
Collapse All
C#
protected ASP_RoleUser(
    Eco.ObjectImplementation.IContent content
);
Remarks

For framework internal use only

See Also
ASP_RoleUser Class
Eco.Web.AspProviders Namespace


ASP_RoleUser.ASP_RoleUser Constructor (Eco.ObjectRepresentation.IEcoServiceProvider)

ASP_RoleUser.ASP_RoleUser Constructor (Eco.ObjectRepresentation.IEcoServiceProvider)
ASP_RoleUser Class Eco.Web.AspProviders Namespace See Also
Collapse All
C#
public ASP_RoleUser(
    Eco.ObjectRepresentation.IEcoServiceProvider serviceProvider
);
Remarks

This is ASP_RoleUser, a member of class ASP_RoleUser.

See Also
ASP_RoleUser Class
Eco.Web.AspProviders Namespace


ASP_RoleUser Classes

ASP_RoleUser Classes
Classes
Collapse All

The classes of the ASP_RoleUser class are listed here.

Classes
Name | Description
Eco_LoopbackIndices | This is class Eco.Web.AspProviders.ASP_RoleUser.Eco_LoopbackIndices.


ASP_RoleUser.Eco_LoopbackIndices Class

ASP_RoleUser.Eco_LoopbackIndices Class
Inheritance Hierarchy See Also
Collapse All
C#
public class Eco_LoopbackIndices;
Remarks

This is class Eco.Web.AspProviders.ASP_RoleUser.Eco_LoopbackIndices.

Inheritance Hierarchy
Eco.Web.AspProviders.ASP_RoleUser.Eco_LoopbackIndices
File

ASP_RoleUser.eco.cs

See Also
Inheritance Hierarchy


Eco_LoopbackIndices Fields

Eco_LoopbackIndices Fields
Public Fields
Collapse All

The fields of the Eco_LoopbackIndices class are listed here.

Public Fields
Name | Description
ApplicationName | This is ApplicationName, a member of class Eco_LoopbackIndices.
Eco_FirstMember | This is Eco_FirstMember, a member of class Eco_LoopbackIndices.
Eco_MemberCount | This is Eco_MemberCount, a member of class Eco_LoopbackIndices.
Roles | This is Roles, a member of class Eco_LoopbackIndices.
User | This is User, a member of class Eco_LoopbackIndices.
UserName | This is UserName, a member of class Eco_LoopbackIndices.


ASP_RoleUser.Eco_LoopbackIndices.ApplicationName Field

ASP_RoleUser.Eco_LoopbackIndices.ApplicationName Field
ASP_RoleUser.Eco_LoopbackIndices Class Eco.Web.AspProviders Namespace See Also
Collapse All
C#
public const int ApplicationName = (UserName + 1);
Remarks

This is ApplicationName, a member of class Eco_LoopbackIndices.

See Also
ASP_RoleUser.Eco_LoopbackIndices Class
Eco.Web.AspProviders Namespace


ASP_RoleUser.Eco_LoopbackIndices.Eco_FirstMember Field

ASP_RoleUser.Eco_LoopbackIndices.Eco_FirstMember Field
ASP_RoleUser.Eco_LoopbackIndices Class Eco.Web.AspProviders Namespace See Also
Collapse All
C#
public const int Eco_FirstMember = 0;
Remarks

This is Eco_FirstMember, a member of class Eco_LoopbackIndices.

See Also
ASP_RoleUser.Eco_LoopbackIndices Class
Eco.Web.AspProviders Namespace


ASP_RoleUser.Eco_LoopbackIndices.Eco_MemberCount Field

ASP_RoleUser.Eco_LoopbackIndices.Eco_MemberCount Field
ASP_RoleUser.Eco_LoopbackIndices Class Eco.Web.AspProviders Namespace See Also
Collapse All
C#
public const int Eco_MemberCount = (Roles + 1);
Remarks

This is Eco_MemberCount, a member of class Eco_LoopbackIndices.

See Also
ASP_RoleUser.Eco_LoopbackIndices Class
Eco.Web.AspProviders Namespace


ASP_RoleUser.Eco_LoopbackIndices.Roles Field

ASP_RoleUser.Eco_LoopbackIndices.Roles Field
ASP_RoleUser.Eco_LoopbackIndices Class Eco.Web.AspProviders Namespace See Also
Collapse All
C#
public const int Roles = (User + 1);
Remarks

This is Roles, a member of class Eco_LoopbackIndices.

See Also
ASP_RoleUser.Eco_LoopbackIndices Class
Eco.Web.AspProviders Namespace


ASP_RoleUser.Eco_LoopbackIndices.User Field

ASP_RoleUser.Eco_LoopbackIndices.User Field
ASP_RoleUser.Eco_LoopbackIndices Class Eco.Web.AspProviders Namespace See Also
Collapse All
C#
public const int User = (ApplicationName + 1);
Remarks

This is User, a member of class Eco_LoopbackIndices.

See Also
ASP_RoleUser.Eco_LoopbackIndices Class
Eco.Web.AspProviders Namespace


ASP_RoleUser.Eco_LoopbackIndices.UserName Field

ASP_RoleUser.Eco_LoopbackIndices.UserName Field
ASP_RoleUser.Eco_LoopbackIndices Class Eco.Web.AspProviders Namespace See Also
Collapse All
C#
public const int UserName = Eco_FirstMember;
Remarks

This is UserName, a member of class Eco_LoopbackIndices.

See Also
ASP_RoleUser.Eco_LoopbackIndices Class
Eco.Web.AspProviders Namespace


ASP_RoleUser Fields

ASP_RoleUser Fields
Protected Fields
Collapse All

The fields of the ASP_RoleUser class are listed here.

Protected Fields
Name | Description
eco_Content | This is eco_Content, a member of class ASP_RoleUser.


ASP_RoleUser.eco_Content Field

ASP_RoleUser.eco_Content Field
ASP_RoleUser Class Eco.Web.AspProviders Namespace See Also
Collapse All
C#
protected Eco.ObjectImplementation.IContent eco_Content;
Remarks

This is eco_Content, a member of class ASP_RoleUser.

See Also
ASP_RoleUser Class
Eco.Web.AspProviders Namespace


ASP_RoleUser Methods

ASP_RoleUser Methods
Protected Methods Public Methods
Collapse All

The methods of the ASP_RoleUser class are listed here.

Protected Methods
Name | Description
Deinitialize | This is Deinitialize, a member of class ASP_RoleUser.
Initialize | This is Initialize, a member of class ASP_RoleUser.
Top
Public Methods
Name | Description
AsIObject | This is AsIObject, a member of class ASP_RoleUser.
get_MemberByIndex | This is get_MemberByIndex, a member of class ASP_RoleUser.
set_MemberByIndex | This is set_MemberByIndex, a member of class ASP_RoleUser.


ASP_RoleUser.AsIObject Method

ASP_RoleUser.AsIObject Method
ASP_RoleUser Class Eco.Web.AspProviders Namespace See Also
Collapse All
C#
public virtual Eco.ObjectRepresentation.IObjectInstance AsIObject();
Remarks

This is AsIObject, a member of class ASP_RoleUser.

See Also
ASP_RoleUser Class
Eco.Web.AspProviders Namespace


ASP_RoleUser.Deinitialize Method

ASP_RoleUser.Deinitialize Method
ASP_RoleUser Class Eco.Web.AspProviders Namespace See Also
Collapse All
C#
protected virtual void Deinitialize(
    Eco.ObjectRepresentation.IEcoServiceProvider serviceProvider
);
Remarks

This is Deinitialize, a member of class ASP_RoleUser.

See Also
ASP_RoleUser Class
Eco.Web.AspProviders Namespace


ASP_RoleUser.get_MemberByIndex Method

ASP_RoleUser.get_MemberByIndex Method
ASP_RoleUser Class Eco.Web.AspProviders Namespace See Also
Collapse All
C#
public virtual object get_MemberByIndex(
    int index
);
Remarks

This is get_MemberByIndex, a member of class ASP_RoleUser.

See Also
ASP_RoleUser Class
Eco.Web.AspProviders Namespace


ASP_RoleUser.Initialize Method

ASP_RoleUser.Initialize Method
ASP_RoleUser Class Eco.Web.AspProviders Namespace See Also
Collapse All
C#
protected virtual void Initialize(
    Eco.ObjectRepresentation.IEcoServiceProvider serviceProvider
);
Remarks

This is Initialize, a member of class ASP_RoleUser.

See Also
ASP_RoleUser Class
Eco.Web.AspProviders Namespace


ASP_RoleUser.set_MemberByIndex Method

ASP_RoleUser.set_MemberByIndex Method
ASP_RoleUser Class Eco.Web.AspProviders Namespace See Also
Collapse All
C#
public virtual void set_MemberByIndex(
    int index,
    object value
);
Remarks

This is set_MemberByIndex, a member of class ASP_RoleUser.

See Also
ASP_RoleUser Class
Eco.Web.AspProviders Namespace


ASP_RoleUser Properties

ASP_RoleUser Properties
Public Properties
Collapse All

The properties of the ASP_RoleUser class are listed here.

Public Properties
Name | Description
ApplicationName | This is ApplicationName, a member of class ASP_RoleUser.
Roles | This is Roles, a member of class ASP_RoleUser.
User | This is User, a member of class ASP_RoleUser.
UserName | This is UserName, a member of class ASP_RoleUser.


ASP_RoleUser.ApplicationName Property

ASP_RoleUser.ApplicationName Property
ASP_RoleUser Class Eco.Web.AspProviders Namespace See Also
Collapse All
C#
public string ApplicationName;
Remarks

This is ApplicationName, a member of class ASP_RoleUser.

See Also
ASP_RoleUser Class
Eco.Web.AspProviders Namespace


ASP_RoleUser.Roles Property

ASP_RoleUser.Roles Property
ASP_RoleUser Class Eco.Web.AspProviders Namespace See Also
Collapse All
C#
public IEcoList<ASP_Role> Roles;
Remarks

This is Roles, a member of class ASP_RoleUser.

See Also
ASP_RoleUser Class
Eco.Web.AspProviders Namespace


ASP_RoleUser.User Property

ASP_RoleUser.User Property
ASP_RoleUser Class Eco.Web.AspProviders Namespace See Also
Collapse All
C#
public ASP_User User;
Remarks

This is User, a member of class ASP_RoleUser.

See Also
ASP_RoleUser Class
Eco.Web.AspProviders Namespace


ASP_RoleUser.UserName Property

ASP_RoleUser.UserName Property
ASP_RoleUser Class Eco.Web.AspProviders Namespace See Also
Collapse All
C#
public string UserName;
Remarks

This is UserName, a member of class ASP_RoleUser.

See Also
ASP_RoleUser Class
Eco.Web.AspProviders Namespace


ASP_Session Class

ASP_Session Class
Inheritance Hierarchy See Also
Collapse All
C#
public class ASP_Session : Eco.ObjectImplementation.ILoopBack2, System.ComponentModel.INotifyPropertyChanged;
Remarks

This is class Eco.Web.AspProviders.ASP_Session.

Inheritance Hierarchy
Eco.Web.AspProviders.ASP_Session
File

ASP_Session.eco.cs

See Also
Inheritance Hierarchy


ASP_Session Constructor

ASP_Session Constructor

This is the overview for the ASP_Session constructor overload.

Overload List
Name | Description
ASP_Session.ASP_Session (Eco.ObjectImplementation.IContent) | For framework internal use only
ASP_Session.ASP_Session (Eco.ObjectRepresentation.IEcoServiceProvider) | This is ASP_Session, a member of class ASP_Session.


ASP_Session.ASP_Session Constructor (Eco.ObjectImplementation.IContent)

ASP_Session.ASP_Session Constructor (Eco.ObjectImplementation.IContent)
ASP_Session Class Eco.Web.AspProviders Namespace See Also
Collapse All
C#
protected ASP_Session(
    Eco.ObjectImplementation.IContent content
);
Remarks

For framework internal use only

See Also
ASP_Session Class
Eco.Web.AspProviders Namespace


ASP_Session.ASP_Session Constructor (Eco.ObjectRepresentation.IEcoServiceProvider)

ASP_Session.ASP_Session Constructor (Eco.ObjectRepresentation.IEcoServiceProvider)
ASP_Session Class Eco.Web.AspProviders Namespace See Also
Collapse All
C#
public ASP_Session(
    Eco.ObjectRepresentation.IEcoServiceProvider serviceProvider
);
Remarks

This is ASP_Session, a member of class ASP_Session.

See Also
ASP_Session Class
Eco.Web.AspProviders Namespace


ASP_Session Classes

ASP_Session Classes
Classes
Collapse All

The classes of the ASP_Session class are listed here.

Classes
Name | Description
Eco_LoopbackIndices | This is class Eco.Web.AspProviders.ASP_Session.Eco_LoopbackIndices.


ASP_Session.Eco_LoopbackIndices Class

ASP_Session.Eco_LoopbackIndices Class
Inheritance Hierarchy See Also
Collapse All
C#
public class Eco_LoopbackIndices;
Remarks

This is class Eco.Web.AspProviders.ASP_Session.Eco_LoopbackIndices.

Inheritance Hierarchy
Eco.Web.AspProviders.ASP_Session.Eco_LoopbackIndices
File

ASP_Session.eco.cs

See Also
Inheritance Hierarchy


Eco_LoopbackIndices Fields

Eco_LoopbackIndices Fields
Public Fields
Collapse All

The fields of the Eco_LoopbackIndices class are listed here.

Public Fields
Name | Description
ApplicationName | This is ApplicationName, a member of class Eco_LoopbackIndices.
Created | This is Created, a member of class Eco_LoopbackIndices.
Eco_FirstMember | This is Eco_FirstMember, a member of class Eco_LoopbackIndices.
Eco_MemberCount | This is Eco_MemberCount, a member of class Eco_LoopbackIndices.
Expires | This is Expires, a member of class Eco_LoopbackIndices.
Flags | This is Flags, a member of class Eco_LoopbackIndices.
LockDate | This is LockDate, a member of class Eco_LoopbackIndices.
Locked | This is Locked, a member of class Eco_LoopbackIndices.
LockId | This is LockId, a member of class Eco_LoopbackIndices.
SessionId | This is SessionId, a member of class Eco_LoopbackIndices.
SessionItems | This is SessionItems, a member of class Eco_LoopbackIndices.
TimeOut | This is TimeOut, a member of class Eco_LoopbackIndices.


ASP_Session.Eco_LoopbackIndices.ApplicationName Field

ASP_Session.Eco_LoopbackIndices.ApplicationName Field
ASP_Session.Eco_LoopbackIndices Class Eco.Web.AspProviders Namespace See Also
Collapse All
C#
public const int ApplicationName = (Locked + 1);
Remarks

This is ApplicationName, a member of class Eco_LoopbackIndices.

See Also
ASP_Session.Eco_LoopbackIndices Class
Eco.Web.AspProviders Namespace


ASP_Session.Eco_LoopbackIndices.Created Field

ASP_Session.Eco_LoopbackIndices.Created Field
ASP_Session.Eco_LoopbackIndices Class Eco.Web.AspProviders Namespace See Also
Collapse All
C#
public const int Created = (SessionItems + 1);
Remarks

This is Created, a member of class Eco_LoopbackIndices.

See Also
ASP_Session.Eco_LoopbackIndices Class
Eco.Web.AspProviders Namespace


ASP_Session.Eco_LoopbackIndices.Eco_FirstMember Field

ASP_Session.Eco_LoopbackIndices.Eco_FirstMember Field
ASP_Session.Eco_LoopbackIndices Class Eco.Web.AspProviders Namespace See Also
Collapse All
C#
public const int Eco_FirstMember = 0;
Remarks

This is Eco_FirstMember, a member of class Eco_LoopbackIndices.

See Also
ASP_Session.Eco_LoopbackIndices Class
Eco.Web.AspProviders Namespace


ASP_Session.Eco_LoopbackIndices.Eco_MemberCount Field

ASP_Session.Eco_LoopbackIndices.Eco_MemberCount Field
ASP_Session.Eco_LoopbackIndices Class Eco.Web.AspProviders Namespace See Also
Collapse All
C#
public const int Eco_MemberCount = (ApplicationName + 1);
Remarks

This is Eco_MemberCount, a member of class Eco_LoopbackIndices.

See Also
ASP_Session.Eco_LoopbackIndices Class
Eco.Web.AspProviders Namespace


ASP_Session.Eco_LoopbackIndices.Expires Field

ASP_Session.Eco_LoopbackIndices.Expires Field
ASP_Session.Eco_LoopbackIndices Class Eco.Web.AspProviders Namespace See Also
Collapse All
C#
public const int Expires = (TimeOut + 1);
Remarks

This is Expires, a member of class Eco_LoopbackIndices.

See Also
ASP_Session.Eco_LoopbackIndices Class
Eco.Web.AspProviders Namespace


ASP_Session.Eco_LoopbackIndices.Flags Field

ASP_Session.Eco_LoopbackIndices.Flags Field
ASP_Session.Eco_LoopbackIndices Class Eco.Web.AspProviders Namespace See Also
Collapse All
C#
public const int Flags = Eco_FirstMember;
Remarks

This is Flags, a member of class Eco_LoopbackIndices.

See Also
ASP_Session.Eco_LoopbackIndices Class
Eco.Web.AspProviders Namespace


ASP_Session.Eco_LoopbackIndices.LockDate Field

ASP_Session.Eco_LoopbackIndices.LockDate Field
ASP_Session.Eco_LoopbackIndices Class Eco.Web.AspProviders Namespace See Also
Collapse All
C#
public const int LockDate = (Flags + 1);
Remarks

This is LockDate, a member of class Eco_LoopbackIndices.

See Also
ASP_Session.Eco_LoopbackIndices Class
Eco.Web.AspProviders Namespace


ASP_Session.Eco_LoopbackIndices.Locked Field

ASP_Session.Eco_LoopbackIndices.Locked Field
ASP_Session.Eco_LoopbackIndices Class Eco.Web.AspProviders Namespace See Also
Collapse All
C#
public const int Locked = (SessionId + 1);
Remarks

This is Locked, a member of class Eco_LoopbackIndices.

See Also
ASP_Session.Eco_LoopbackIndices Class
Eco.Web.AspProviders Namespace


ASP_Session.Eco_LoopbackIndices.LockId Field

ASP_Session.Eco_LoopbackIndices.LockId Field
ASP_Session.Eco_LoopbackIndices Class Eco.Web.AspProviders Namespace See Also
Collapse All
C#
public const int LockId = (Created + 1);
Remarks

This is LockId, a member of class Eco_LoopbackIndices.

See Also
ASP_Session.Eco_LoopbackIndices Class
Eco.Web.AspProviders Namespace


ASP_Session.Eco_LoopbackIndices.SessionId Field

ASP_Session.Eco_LoopbackIndices.SessionId Field
ASP_Session.Eco_LoopbackIndices Class Eco.Web.AspProviders Namespace See Also
Collapse All
C#
public const int SessionId = (Expires + 1);
Remarks

This is SessionId, a member of class Eco_LoopbackIndices.

See Also
ASP_Session.Eco_LoopbackIndices Class
Eco.Web.AspProviders Namespace


ASP_Session.Eco_LoopbackIndices.SessionItems Field

ASP_Session.Eco_LoopbackIndices.SessionItems Field
ASP_Session.Eco_LoopbackIndices Class Eco.Web.AspProviders Namespace See Also
Collapse All
C#
public const int SessionItems = (LockDate + 1);
Remarks

This is SessionItems, a member of class Eco_LoopbackIndices.

See Also
ASP_Session.Eco_LoopbackIndices Class
Eco.Web.AspProviders Namespace


ASP_Session.Eco_LoopbackIndices.TimeOut Field

ASP_Session.Eco_LoopbackIndices.TimeOut Field
ASP_Session.Eco_LoopbackIndices Class Eco.Web.AspProviders Namespace See Also
Collapse All
C#
public const int TimeOut = (LockId + 1);
Remarks

This is TimeOut, a member of class Eco_LoopbackIndices.

See Also
ASP_Session.Eco_LoopbackIndices Class
Eco.Web.AspProviders Namespace


ASP_Session Fields

ASP_Session Fields
Protected Fields
Collapse All

The fields of the ASP_Session class are listed here.

Protected Fields
Name | Description
eco_Content | This is eco_Content, a member of class ASP_Session.


ASP_Session.eco_Content Field

ASP_Session.eco_Content Field
ASP_Session Class Eco.Web.AspProviders Namespace See Also
Collapse All
C#
protected Eco.ObjectImplementation.IContent eco_Content;
Remarks

This is eco_Content, a member of class ASP_Session.

See Also
ASP_Session Class
Eco.Web.AspProviders Namespace


ASP_Session Methods

ASP_Session Methods
Protected Methods Public Methods
Collapse All

The methods of the ASP_Session class are listed here.

Protected Methods
Name | Description
Deinitialize | This is Deinitialize, a member of class ASP_Session.
Initialize | This is Initialize, a member of class ASP_Session.
Top
Public Methods
Name | Description
AsIObject | This is AsIObject, a member of class ASP_Session.
get_MemberByIndex | This is get_MemberByIndex, a member of class ASP_Session.
set_MemberByIndex | This is set_MemberByIndex, a member of class ASP_Session.


ASP_Session.AsIObject Method

ASP_Session.AsIObject Method
ASP_Session Class Eco.Web.AspProviders Namespace See Also
Collapse All
C#
public virtual Eco.ObjectRepresentation.IObjectInstance AsIObject();
Remarks

This is AsIObject, a member of class ASP_Session.

See Also
ASP_Session Class
Eco.Web.AspProviders Namespace


ASP_Session.Deinitialize Method

ASP_Session.Deinitialize Method
ASP_Session Class Eco.Web.AspProviders Namespace See Also
Collapse All
C#
protected virtual void Deinitialize(
    Eco.ObjectRepresentation.IEcoServiceProvider serviceProvider
);
Remarks

This is Deinitialize, a member of class ASP_Session.

See Also
ASP_Session Class
Eco.Web.AspProviders Namespace


ASP_Session.get_MemberByIndex Method

ASP_Session.get_MemberByIndex Method
ASP_Session Class Eco.Web.AspProviders Namespace See Also
Collapse All
C#
public virtual object get_MemberByIndex(
    int index
);
Remarks

This is get_MemberByIndex, a member of class ASP_Session.

See Also
ASP_Session Class
Eco.Web.AspProviders Namespace


ASP_Session.Initialize Method

ASP_Session.Initialize Method
ASP_Session Class Eco.Web.AspProviders Namespace See Also
Collapse All
C#
protected virtual void Initialize(
    Eco.ObjectRepresentation.IEcoServiceProvider serviceProvider
);
Remarks

This is Initialize, a member of class ASP_Session.

See Also
ASP_Session Class
Eco.Web.AspProviders Namespace


ASP_Session.set_MemberByIndex Method

ASP_Session.set_MemberByIndex Method
ASP_Session Class Eco.Web.AspProviders Namespace See Also
Collapse All
C#
public virtual void set_MemberByIndex(
    int index,
    object value
);
Remarks

This is set_MemberByIndex, a member of class ASP_Session.

See Also
ASP_Session Class
Eco.Web.AspProviders Namespace


ASP_Session Properties

ASP_Session Properties
Public Properties
Collapse All

The properties of the ASP_Session class are listed here.

Public Properties
Name | Description
ApplicationName | This is ApplicationName, a member of class ASP_Session.
Created | This is Created, a member of class ASP_Session.
Expires | This is Expires, a member of class ASP_Session.
Flags | This is Flags, a member of class ASP_Session.
LockDate | This is LockDate, a member of class ASP_Session.
Locked | This is Locked, a member of class ASP_Session.
LockId | This is LockId, a member of class ASP_Session.
SessionId | This is SessionId, a member of class ASP_Session.
SessionItems | This is SessionItems, a member of class ASP_Session.
TimeOut | This is TimeOut, a member of class ASP_Session.


ASP_Session.ApplicationName Property

ASP_Session.ApplicationName Property
ASP_Session Class Eco.Web.AspProviders Namespace See Also
Collapse All
C#
public string ApplicationName;
Remarks

This is ApplicationName, a member of class ASP_Session.

See Also
ASP_Session Class
Eco.Web.AspProviders Namespace


ASP_Session.Created Property

ASP_Session.Created Property
ASP_Session Class Eco.Web.AspProviders Namespace See Also
Collapse All
C#
public System.DateTime Created;
Remarks

This is Created, a member of class ASP_Session.

See Also
ASP_Session Class
Eco.Web.AspProviders Namespace


ASP_Session.Expires Property

ASP_Session.Expires Property
ASP_Session Class Eco.Web.AspProviders Namespace See Also
Collapse All
C#
public System.DateTime Expires;
Remarks

This is Expires, a member of class ASP_Session.

See Also
ASP_Session Class
Eco.Web.AspProviders Namespace


ASP_Session.Flags Property

ASP_Session.Flags Property
ASP_Session Class Eco.Web.AspProviders Namespace See Also
Collapse All
C#
public int Flags;
Remarks

This is Flags, a member of class ASP_Session.

See Also
ASP_Session Class
Eco.Web.AspProviders Namespace


ASP_Session.LockDate Property

ASP_Session.LockDate Property
ASP_Session Class Eco.Web.AspProviders Namespace See Also
Collapse All
C#
public System.DateTime LockDate;
Remarks

This is LockDate, a member of class ASP_Session.

See Also
ASP_Session Class
Eco.Web.AspProviders Namespace


ASP_Session.Locked Property

ASP_Session.Locked Property
ASP_Session Class Eco.Web.AspProviders Namespace See Also
Collapse All
C#
public bool Locked;
Remarks

This is Locked, a member of class ASP_Session.

See Also
ASP_Session Class
Eco.Web.AspProviders Namespace


ASP_Session.LockId Property

ASP_Session.LockId Property
ASP_Session Class Eco.Web.AspProviders Namespace See Also
Collapse All
C#
public int LockId;
Remarks

This is LockId, a member of class ASP_Session.

See Also
ASP_Session Class
Eco.Web.AspProviders Namespace


ASP_Session.SessionId Property

ASP_Session.SessionId Property
ASP_Session Class Eco.Web.AspProviders Namespace See Also
Collapse All
C#
public string SessionId;
Remarks

This is SessionId, a member of class ASP_Session.

See Also
ASP_Session Class
Eco.Web.AspProviders Namespace


ASP_Session.SessionItems Property

ASP_Session.SessionItems Property
ASP_Session Class Eco.Web.AspProviders Namespace See Also
Collapse All
C#
public string SessionItems;
Remarks

This is SessionItems, a member of class ASP_Session.

See Also
ASP_Session Class
Eco.Web.AspProviders Namespace


ASP_Session.TimeOut Property

ASP_Session.TimeOut Property
ASP_Session Class Eco.Web.AspProviders Namespace See Also
Collapse All
C#
public int TimeOut;
Remarks

This is TimeOut, a member of class ASP_Session.

See Also
ASP_Session Class
Eco.Web.AspProviders Namespace


ASP_StringPropValue Class

ASP_StringPropValue Class
Inheritance Hierarchy See Also
Collapse All
C#
public class ASP_StringPropValue : Eco.Web.AspProviders.ASP_ProfilePropValue;
Remarks

This is class Eco.Web.AspProviders.ASP_StringPropValue.

Inheritance Hierarchy
Eco.Web.AspProviders.ASP_StringPropValue
File

ASP_StringPropValue.eco.cs

See Also
Inheritance Hierarchy


ASP_StringPropValue Constructor

ASP_StringPropValue Constructor

This is the overview for the ASP_StringPropValue constructor overload.

Overload List
Name | Description
ASP_StringPropValue.ASP_StringPropValue (Eco.ObjectImplementation.IContent) | For framework internal use only
ASP_StringPropValue.ASP_StringPropValue (Eco.ObjectRepresentation.IEcoServiceProvider) | This is ASP_StringPropValue, a member of class ASP_StringPropValue.


ASP_StringPropValue.ASP_StringPropValue Constructor (Eco.ObjectImplementation.IContent)

ASP_StringPropValue.ASP_StringPropValue Constructor (Eco.ObjectImplementation.IContent)
ASP_StringPropValue Class Eco.Web.AspProviders Namespace See Also
Collapse All
C#
protected ASP_StringPropValue(
    Eco.ObjectImplementation.IContent content
);
Remarks

For framework internal use only

See Also
ASP_StringPropValue Class
Eco.Web.AspProviders Namespace


ASP_StringPropValue.ASP_StringPropValue Constructor (Eco.ObjectRepresentation.IEcoServiceProvider)

ASP_StringPropValue.ASP_StringPropValue Constructor (Eco.ObjectRepresentation.IEcoServiceProvider)
ASP_StringPropValue Class Eco.Web.AspProviders Namespace See Also
Collapse All
C#
public ASP_StringPropValue(
    Eco.ObjectRepresentation.IEcoServiceProvider serviceProvider
);
Remarks

This is ASP_StringPropValue, a member of class ASP_StringPropValue.

See Also
ASP_StringPropValue Class
Eco.Web.AspProviders Namespace


ASP_StringPropValue Classes

ASP_StringPropValue Classes
Classes
Collapse All

The classes of the ASP_StringPropValue class are listed here.

Classes
Name | Description
Eco_LoopbackIndices | This is class Eco.Web.AspProviders.ASP_StringPropValue.Eco_LoopbackIndices.


ASP_StringPropValue.Eco_LoopbackIndices Class

ASP_StringPropValue.Eco_LoopbackIndices Class
Inheritance Hierarchy See Also
Collapse All
C#
public new class Eco_LoopbackIndices;
Remarks

This is class Eco.Web.AspProviders.ASP_StringPropValue.Eco_LoopbackIndices.

Inheritance Hierarchy
Eco.Web.AspProviders.ASP_StringPropValue.Eco_LoopbackIndices
File

ASP_StringPropValue.eco.cs

See Also
Inheritance Hierarchy


ASP_StringPropValue.Eco_LoopbackIndices.Eco_FirstMember Field

ASP_StringPropValue.Eco_LoopbackIndices.Eco_FirstMember Field
ASP_StringPropValue.Eco_LoopbackIndices Class Eco.Web.AspProviders Namespace See Also
Collapse All
C#
public const int Eco_FirstMember = Eco.Web.AspProviders.ASP_ProfilePropValue.Eco_LoopbackIndices.Eco_MemberCount;
Remarks

This is Eco_FirstMember, a member of class Eco_LoopbackIndices.

See Also
ASP_StringPropValue.Eco_LoopbackIndices Class
Eco.Web.AspProviders Namespace


ASP_StringPropValue.Eco_LoopbackIndices.Eco_MemberCount Field

ASP_StringPropValue.Eco_LoopbackIndices.Eco_MemberCount Field
ASP_StringPropValue.Eco_LoopbackIndices Class Eco.Web.AspProviders Namespace See Also
Collapse All
C#
public const int Eco_MemberCount = (Value + 1);
Remarks

This is Eco_MemberCount, a member of class Eco_LoopbackIndices.

See Also
ASP_StringPropValue.Eco_LoopbackIndices Class
Eco.Web.AspProviders Namespace


ASP_StringPropValue.Eco_LoopbackIndices.Value Field

ASP_StringPropValue.Eco_LoopbackIndices.Value Field
ASP_StringPropValue.Eco_LoopbackIndices Class Eco.Web.AspProviders Namespace See Also
Collapse All
C#
public const int Value = Eco_FirstMember;
Remarks

This is Value, a member of class Eco_LoopbackIndices.

See Also
ASP_StringPropValue.Eco_LoopbackIndices Class
Eco.Web.AspProviders Namespace


ASP_StringPropValue Methods

ASP_StringPropValue Methods
Public Methods
Collapse All

The methods of the ASP_StringPropValue class are listed here.

Public Methods
Name | Description
get_MemberByIndex | This is get_MemberByIndex, a member of class ASP_StringPropValue.
GetValue | This is GetValue, a member of class ASP_StringPropValue.
set_MemberByIndex | This is set_MemberByIndex, a member of class ASP_StringPropValue.


ASP_StringPropValue.get_MemberByIndex Method

ASP_StringPropValue.get_MemberByIndex Method
ASP_StringPropValue Class Eco.Web.AspProviders Namespace See Also
Collapse All
C#
public override object get_MemberByIndex(
    int index
);
Remarks

This is get_MemberByIndex, a member of class ASP_StringPropValue.

See Also
ASP_StringPropValue Class
Eco.Web.AspProviders Namespace


ASP_StringPropValue.GetValue Method

ASP_StringPropValue.GetValue Method
ASP_StringPropValue Class Eco.Web.AspProviders Namespace See Also
Collapse All
C#
public override object GetValue();
Remarks

This is GetValue, a member of class ASP_StringPropValue.

See Also
ASP_StringPropValue Class
Eco.Web.AspProviders Namespace


ASP_StringPropValue.set_MemberByIndex Method

ASP_StringPropValue.set_MemberByIndex Method
ASP_StringPropValue Class Eco.Web.AspProviders Namespace See Also
Collapse All
C#
public override void set_MemberByIndex(
    int index,
    object value
);
Remarks

This is set_MemberByIndex, a member of class ASP_StringPropValue.

See Also
ASP_StringPropValue Class
Eco.Web.AspProviders Namespace


ASP_StringPropValue Properties

ASP_StringPropValue Properties
Public Properties
Collapse All

The properties of the ASP_StringPropValue class are listed here.

Public Properties
Name | Description
Value | This is Value, a member of class ASP_StringPropValue.


ASP_StringPropValue.Value Property

ASP_StringPropValue.Value Property
ASP_StringPropValue Class Eco.Web.AspProviders Namespace See Also
Collapse All
C#
public string Value;
Remarks

This is Value, a member of class ASP_StringPropValue.

See Also
ASP_StringPropValue Class
Eco.Web.AspProviders Namespace


ASP_User Class

ASP_User Class
Inheritance Hierarchy See Also
Collapse All
C#
public class ASP_User : Eco.ObjectImplementation.ILoopBack2, System.ComponentModel.INotifyPropertyChanged;
Remarks

This is class Eco.Web.AspProviders.ASP_User.

Inheritance Hierarchy
Eco.Web.AspProviders.ASP_User
File

ASP_User.eco.cs

See Also
Inheritance Hierarchy


ASP_User Constructor

ASP_User Constructor

This is the overview for the ASP_User constructor overload.

Overload List
Name | Description
ASP_User.ASP_User (Eco.ObjectImplementation.IContent) | For framework internal use only
ASP_User.ASP_User (Eco.ObjectRepresentation.IEcoServiceProvider) | This is ASP_User, a member of class ASP_User.


ASP_User.ASP_User Constructor (Eco.ObjectImplementation.IContent)

ASP_User.ASP_User Constructor (Eco.ObjectImplementation.IContent)
ASP_User Class Eco.Web.AspProviders Namespace See Also
Collapse All
C#
protected ASP_User(
    Eco.ObjectImplementation.IContent content
);
Remarks

For framework internal use only

See Also
ASP_User Class
Eco.Web.AspProviders Namespace


ASP_User.ASP_User Constructor (Eco.ObjectRepresentation.IEcoServiceProvider)

ASP_User.ASP_User Constructor (Eco.ObjectRepresentation.IEcoServiceProvider)
ASP_User Class Eco.Web.AspProviders Namespace See Also
Collapse All
C#
public ASP_User(
    Eco.ObjectRepresentation.IEcoServiceProvider serviceProvider
);
Remarks

This is ASP_User, a member of class ASP_User.

See Also
ASP_User Class
Eco.Web.AspProviders Namespace


ASP_User Classes

ASP_User Classes
Classes
Collapse All

The classes of the ASP_User class are listed here.

Classes
Name | Description
Eco_LoopbackIndices | This is class Eco.Web.AspProviders.ASP_User.Eco_LoopbackIndices.


ASP_User.Eco_LoopbackIndices Class

ASP_User.Eco_LoopbackIndices Class
Inheritance Hierarchy See Also
Collapse All
C#
public class Eco_LoopbackIndices;
Remarks

This is class Eco.Web.AspProviders.ASP_User.Eco_LoopbackIndices.

Inheritance Hierarchy
Eco.Web.AspProviders.ASP_User.Eco_LoopbackIndices
File

ASP_User.eco.cs

See Also
Inheritance Hierarchy


Eco_LoopbackIndices Fields

Eco_LoopbackIndices Fields
Public Fields
Collapse All

The fields of the Eco_LoopbackIndices class are listed here.

Public Fields
Name | Description
ApplicationName | This is ApplicationName, a member of class Eco_LoopbackIndices.
Comment | This is Comment, a member of class Eco_LoopbackIndices.
CreationDate | This is CreationDate, a member of class Eco_LoopbackIndices.
Eco_FirstMember | This is Eco_FirstMember, a member of class Eco_LoopbackIndices.
Eco_MemberCount | This is Eco_MemberCount, a member of class Eco_LoopbackIndices.
Email | This is Email, a member of class Eco_LoopbackIndices.
FailedPasswordAnswerAttemptCount | This is FailedPasswordAnswerAttemptCount, a member of class Eco_LoopbackIndices.
FailedPasswordAnswerAttemptWindowStart | This is FailedPasswordAnswerAttemptWindowStart, a member of class Eco_LoopbackIndices.
FailedPasswordAttemptCount | This is FailedPasswordAttemptCount, a member of class Eco_LoopbackIndices.
FailedPasswordAttemptWindowStart | This is FailedPasswordAttemptWindowStart, a member of class Eco_LoopbackIndices.
IsApproved | This is IsApproved, a member of class Eco_LoopbackIndices.
IsLockedOut | This is IsLockedOut, a member of class Eco_LoopbackIndices.
IsOnLine | This is IsOnLine, a member of class Eco_LoopbackIndices.
LastActivityDate | This is LastActivityDate, a member of class Eco_LoopbackIndices.
LastLockedOutDate | This is LastLockedOutDate, a member of class Eco_LoopbackIndices.
LastLoginDate | This is LastLoginDate, a member of class Eco_LoopbackIndices.
LastPasswordChangedDate | This is LastPasswordChangedDate, a member of class Eco_LoopbackIndices.
Name | This is Name, a member of class Eco_LoopbackIndices.
Password | This is Password, a member of class Eco_LoopbackIndices.
PasswordAnswer | This is PasswordAnswer, a member of class Eco_LoopbackIndices.
PasswordQuestion | This is PasswordQuestion, a member of class Eco_LoopbackIndices.
Profile | This is Profile, a member of class Eco_LoopbackIndices.
Roles | This is Roles, a member of class Eco_LoopbackIndices.
RoleUser | This is RoleUser, a member of class Eco_LoopbackIndices.


ASP_User.Eco_LoopbackIndices.ApplicationName Field

ASP_User.Eco_LoopbackIndices.ApplicationName Field
ASP_User.Eco_LoopbackIndices Class Eco.Web.AspProviders Namespace See Also
Collapse All
C#
public const int ApplicationName = (PasswordAnswer + 1);
Remarks

This is ApplicationName, a member of class Eco_LoopbackIndices.

See Also
ASP_User.Eco_LoopbackIndices Class
Eco.Web.AspProviders Namespace


ASP_User.Eco_LoopbackIndices.Comment Field

ASP_User.Eco_LoopbackIndices.Comment Field
ASP_User.Eco_LoopbackIndices Class Eco.Web.AspProviders Namespace See Also
Collapse All
C#
public const int Comment = (CreationDate + 1);
Remarks

This is Comment, a member of class Eco_LoopbackIndices.

See Also
ASP_User.Eco_LoopbackIndices Class
Eco.Web.AspProviders Namespace


ASP_User.Eco_LoopbackIndices.CreationDate Field

ASP_User.Eco_LoopbackIndices.CreationDate Field
ASP_User.Eco_LoopbackIndices Class Eco.Web.AspProviders Namespace See Also
Collapse All
C#
public const int CreationDate = (FailedPasswordAttemptCount + 1);
Remarks

This is CreationDate, a member of class Eco_LoopbackIndices.

See Also
ASP_User.Eco_LoopbackIndices Class
Eco.Web.AspProviders Namespace


ASP_User.Eco_LoopbackIndices.Eco_FirstMember Field

ASP_User.Eco_LoopbackIndices.Eco_FirstMember Field
ASP_User.Eco_LoopbackIndices Class Eco.Web.AspProviders Namespace See Also
Collapse All
C#
public const int Eco_FirstMember = 0;
Remarks

This is Eco_FirstMember, a member of class Eco_LoopbackIndices.

See Also
ASP_User.Eco_LoopbackIndices Class
Eco.Web.AspProviders Namespace


ASP_User.Eco_LoopbackIndices.Eco_MemberCount Field

ASP_User.Eco_LoopbackIndices.Eco_MemberCount Field
ASP_User.Eco_LoopbackIndices Class Eco.Web.AspProviders Namespace See Also
Collapse All
C#
public const int Eco_MemberCount = (Profile + 1);
Remarks

This is Eco_MemberCount, a member of class Eco_LoopbackIndices.

See Also
ASP_User.Eco_LoopbackIndices Class
Eco.Web.AspProviders Namespace


ASP_User.Eco_LoopbackIndices.Email Field

ASP_User.Eco_LoopbackIndices.Email Field
ASP_User.Eco_LoopbackIndices Class Eco.Web.AspProviders Namespace See Also
Collapse All
C#
public const int Email = (IsOnLine + 1);
Remarks

This is Email, a member of class Eco_LoopbackIndices.

See Also
ASP_User.Eco_LoopbackIndices Class
Eco.Web.AspProviders Namespace


ASP_User.Eco_LoopbackIndices.FailedPasswordAnswerAttemptCount Field

ASP_User.Eco_LoopbackIndices.FailedPasswordAnswerAttemptCount Field
ASP_User.Eco_LoopbackIndices Class Eco.Web.AspProviders Namespace See Also
Collapse All
C#
public const int FailedPasswordAnswerAttemptCount = (FailedPasswordAnswerAttemptWindowStart + 1);
Remarks

This is FailedPasswordAnswerAttemptCount, a member of class Eco_LoopbackIndices.

See Also
ASP_User.Eco_LoopbackIndices Class
Eco.Web.AspProviders Namespace


ASP_User.Eco_LoopbackIndices.FailedPasswordAnswerAttemptWindowStart Field

ASP_User.Eco_LoopbackIndices.FailedPasswordAnswerAttemptWindowStart Field
ASP_User.Eco_LoopbackIndices Class Eco.Web.AspProviders Namespace See Also
Collapse All
C#
public const int FailedPasswordAnswerAttemptWindowStart = (LastLoginDate + 1);
Remarks

This is FailedPasswordAnswerAttemptWindowStart, a member of class Eco_LoopbackIndices.

See Also
ASP_User.Eco_LoopbackIndices Class
Eco.Web.AspProviders Namespace


ASP_User.Eco_LoopbackIndices.FailedPasswordAttemptCount Field

ASP_User.Eco_LoopbackIndices.FailedPasswordAttemptCount Field
ASP_User.Eco_LoopbackIndices Class Eco.Web.AspProviders Namespace See Also
Collapse All
C#
public const int FailedPasswordAttemptCount = (IsApproved + 1);
Remarks

This is FailedPasswordAttemptCount, a member of class Eco_LoopbackIndices.

See Also
ASP_User.Eco_LoopbackIndices Class
Eco.Web.AspProviders Namespace


ASP_User.Eco_LoopbackIndices.FailedPasswordAttemptWindowStart Field

ASP_User.Eco_LoopbackIndices.FailedPasswordAttemptWindowStart Field
ASP_User.Eco_LoopbackIndices Class Eco.Web.AspProviders Namespace See Also
Collapse All
C#
public const int FailedPasswordAttemptWindowStart = (FailedPasswordAnswerAttemptCount + 1);
Remarks

This is FailedPasswordAttemptWindowStart, a member of class Eco_LoopbackIndices.

See Also
ASP_User.Eco_LoopbackIndices Class
Eco.Web.AspProviders Namespace


ASP_User.Eco_LoopbackIndices.IsApproved Field

ASP_User.Eco_LoopbackIndices.IsApproved Field
ASP_User.Eco_LoopbackIndices Class Eco.Web.AspProviders Namespace See Also
Collapse All
C#
public const int IsApproved = (ApplicationName + 1);
Remarks

This is IsApproved, a member of class Eco_LoopbackIndices.

See Also
ASP_User.Eco_LoopbackIndices Class
Eco.Web.AspProviders Namespace


ASP_User.Eco_LoopbackIndices.IsLockedOut Field

ASP_User.Eco_LoopbackIndices.IsLockedOut Field
ASP_User.Eco_LoopbackIndices Class Eco.Web.AspProviders Namespace See Also
Collapse All
C#
public const int IsLockedOut = (LastActivityDate + 1);
Remarks

This is IsLockedOut, a member of class Eco_LoopbackIndices.

See Also
ASP_User.Eco_LoopbackIndices Class
Eco.Web.AspProviders Namespace


ASP_User.Eco_LoopbackIndices.IsOnLine Field

ASP_User.Eco_LoopbackIndices.IsOnLine Field
ASP_User.Eco_LoopbackIndices Class Eco.Web.AspProviders Namespace See Also
Collapse All
C#
public const int IsOnLine = (Password + 1);
Remarks

This is IsOnLine, a member of class Eco_LoopbackIndices.

See Also
ASP_User.Eco_LoopbackIndices Class
Eco.Web.AspProviders Namespace


ASP_User.Eco_LoopbackIndices.LastActivityDate Field

ASP_User.Eco_LoopbackIndices.LastActivityDate Field
ASP_User.Eco_LoopbackIndices Class Eco.Web.AspProviders Namespace See Also
Collapse All
C#
public const int LastActivityDate = (Name + 1);
Remarks

This is LastActivityDate, a member of class Eco_LoopbackIndices.

See Also
ASP_User.Eco_LoopbackIndices Class
Eco.Web.AspProviders Namespace


ASP_User.Eco_LoopbackIndices.LastLockedOutDate Field

ASP_User.Eco_LoopbackIndices.LastLockedOutDate Field
ASP_User.Eco_LoopbackIndices Class Eco.Web.AspProviders Namespace See Also
Collapse All
C#
public const int LastLockedOutDate = (Comment + 1);
Remarks

This is LastLockedOutDate, a member of class Eco_LoopbackIndices.

See Also
ASP_User.Eco_LoopbackIndices Class
Eco.Web.AspProviders Namespace


ASP_User.Eco_LoopbackIndices.LastLoginDate Field

ASP_User.Eco_LoopbackIndices.LastLoginDate Field
ASP_User.Eco_LoopbackIndices Class Eco.Web.AspProviders Namespace See Also
Collapse All
C#
public const int LastLoginDate = (IsLockedOut + 1);
Remarks

This is LastLoginDate, a member of class Eco_LoopbackIndices.

See Also
ASP_User.Eco_LoopbackIndices Class
Eco.Web.AspProviders Namespace


ASP_User.Eco_LoopbackIndices.LastPasswordChangedDate Field

ASP_User.Eco_LoopbackIndices.LastPasswordChangedDate Field
ASP_User.Eco_LoopbackIndices Class Eco.Web.AspProviders Namespace See Also
Collapse All
C#
public const int LastPasswordChangedDate = (FailedPasswordAttemptWindowStart + 1);
Remarks

This is LastPasswordChangedDate, a member of class Eco_LoopbackIndices.

See Also
ASP_User.Eco_LoopbackIndices Class
Eco.Web.AspProviders Namespace


ASP_User.Eco_LoopbackIndices.Name Field

ASP_User.Eco_LoopbackIndices.Name Field
ASP_User.Eco_LoopbackIndices Class Eco.Web.AspProviders Namespace See Also
Collapse All
C#
public const int Name = Eco_FirstMember;
Remarks

This is Name, a member of class Eco_LoopbackIndices.

See Also
ASP_User.Eco_LoopbackIndices Class
Eco.Web.AspProviders Namespace


ASP_User.Eco_LoopbackIndices.Password Field

ASP_User.Eco_LoopbackIndices.Password Field
ASP_User.Eco_LoopbackIndices Class Eco.Web.AspProviders Namespace See Also
Collapse All
C#
public const int Password = (PasswordQuestion + 1);
Remarks

This is Password, a member of class Eco_LoopbackIndices.

See Also
ASP_User.Eco_LoopbackIndices Class
Eco.Web.AspProviders Namespace


ASP_User.Eco_LoopbackIndices.PasswordAnswer Field

ASP_User.Eco_LoopbackIndices.PasswordAnswer Field
ASP_User.Eco_LoopbackIndices Class Eco.Web.AspProviders Namespace See Also
Collapse All
C#
public const int PasswordAnswer = (LastPasswordChangedDate + 1);
Remarks

This is PasswordAnswer, a member of class Eco_LoopbackIndices.

See Also
ASP_User.Eco_LoopbackIndices Class
Eco.Web.AspProviders Namespace


ASP_User.Eco_LoopbackIndices.PasswordQuestion Field

ASP_User.Eco_LoopbackIndices.PasswordQuestion Field
ASP_User.Eco_LoopbackIndices Class Eco.Web.AspProviders Namespace See Also
Collapse All
C#
public const int PasswordQuestion = (LastLockedOutDate + 1);
Remarks

This is PasswordQuestion, a member of class Eco_LoopbackIndices.

See Also
ASP_User.Eco_LoopbackIndices Class
Eco.Web.AspProviders Namespace


ASP_User.Eco_LoopbackIndices.Profile Field

ASP_User.Eco_LoopbackIndices.Profile Field
ASP_User.Eco_LoopbackIndices Class Eco.Web.AspProviders Namespace See Also
Collapse All
C#
public const int Profile = (Roles + 1);
Remarks

This is Profile, a member of class Eco_LoopbackIndices.

See Also
ASP_User.Eco_LoopbackIndices Class
Eco.Web.AspProviders Namespace


ASP_User.Eco_LoopbackIndices.Roles Field

ASP_User.Eco_LoopbackIndices.Roles Field
ASP_User.Eco_LoopbackIndices Class Eco.Web.AspProviders Namespace See Also
Collapse All
C#
public const int Roles = (RoleUser + 1);
Remarks

This is Roles, a member of class Eco_LoopbackIndices.

See Also
ASP_User.Eco_LoopbackIndices Class
Eco.Web.AspProviders Namespace


ASP_User.Eco_LoopbackIndices.RoleUser Field

ASP_User.Eco_LoopbackIndices.RoleUser Field
ASP_User.Eco_LoopbackIndices Class Eco.Web.AspProviders Namespace See Also
Collapse All
C#
public const int RoleUser = (Email + 1);
Remarks

This is RoleUser, a member of class Eco_LoopbackIndices.

See Also
ASP_User.Eco_LoopbackIndices Class
Eco.Web.AspProviders Namespace


ASP_User Fields

ASP_User Fields
Protected Fields
Collapse All

The fields of the ASP_User class are listed here.

Protected Fields
Name | Description
eco_Content | This is eco_Content, a member of class ASP_User.


ASP_User.eco_Content Field

ASP_User.eco_Content Field
ASP_User Class Eco.Web.AspProviders Namespace See Also
Collapse All
C#
protected Eco.ObjectImplementation.IContent eco_Content;
Remarks

This is eco_Content, a member of class ASP_User.

See Also
ASP_User Class
Eco.Web.AspProviders Namespace


ASP_User Methods

ASP_User Methods
Protected Methods Public Methods
Collapse All

The methods of the ASP_User class are listed here.

Protected Methods
Name | Description
Deinitialize | This is Deinitialize, a member of class ASP_User.
Initialize | This is Initialize, a member of class ASP_User.
Top
Public Methods
Name | Description
AsIObject | This is AsIObject, a member of class ASP_User.
ConvertToMembershipUser | This is ConvertToMembershipUser, a member of class ASP_User.
get_MemberByIndex | This is get_MemberByIndex, a member of class ASP_User.
set_MemberByIndex | This is set_MemberByIndex, a member of class ASP_User.


ASP_User.AsIObject Method

ASP_User.AsIObject Method
ASP_User Class Eco.Web.AspProviders Namespace See Also
Collapse All
C#
public virtual Eco.ObjectRepresentation.IObjectInstance AsIObject();
Remarks

This is AsIObject, a member of class ASP_User.

See Also
ASP_User Class
Eco.Web.AspProviders Namespace


ASP_User.ConvertToMembershipUser Method

ASP_User.ConvertToMembershipUser Method
ASP_User Class Eco.Web.AspProviders Namespace See Also
Collapse All
C#
public MembershipUser ConvertToMembershipUser();
Remarks

This is ConvertToMembershipUser, a member of class ASP_User.

See Also
ASP_User Class
Eco.Web.AspProviders Namespace


ASP_User.Deinitialize Method

ASP_User.Deinitialize Method
ASP_User Class Eco.Web.AspProviders Namespace See Also
Collapse All
C#
protected virtual void Deinitialize(
    Eco.ObjectRepresentation.IEcoServiceProvider serviceProvider
);
Remarks

This is Deinitialize, a member of class ASP_User.

See Also
ASP_User Class
Eco.Web.AspProviders Namespace


ASP_User.get_MemberByIndex Method

ASP_User.get_MemberByIndex Method
ASP_User Class Eco.Web.AspProviders Namespace See Also
Collapse All
C#
public virtual object get_MemberByIndex(
    int index
);
Remarks

This is get_MemberByIndex, a member of class ASP_User.

See Also
ASP_User Class
Eco.Web.AspProviders Namespace


ASP_User.Initialize Method

ASP_User.Initialize Method
ASP_User Class Eco.Web.AspProviders Namespace See Also
Collapse All
C#
protected virtual void Initialize(
    Eco.ObjectRepresentation.IEcoServiceProvider serviceProvider
);
Remarks

This is Initialize, a member of class ASP_User.

See Also
ASP_User Class
Eco.Web.AspProviders Namespace


ASP_User.set_MemberByIndex Method

ASP_User.set_MemberByIndex Method
ASP_User Class Eco.Web.AspProviders Namespace See Also
Collapse All
C#
public virtual void set_MemberByIndex(
    int index,
    object value
);
Remarks

This is set_MemberByIndex, a member of class ASP_User.

See Also
ASP_User Class
Eco.Web.AspProviders Namespace


ASP_User Properties

ASP_User Properties
Public Properties
Collapse All

The properties of the ASP_User class are listed here.

Public Properties
Name | Description
ApplicationName | This is ApplicationName, a member of class ASP_User.
Comment | This is Comment, a member of class ASP_User.
CreationDate | This is CreationDate, a member of class ASP_User.
Email | This is Email, a member of class ASP_User.
FailedPasswordAnswerAttemptCount | This is FailedPasswordAnswerAttemptCount, a member of class ASP_User.
FailedPasswordAnswerAttemptWindowStart | This is FailedPasswordAnswerAttemptWindowStart, a member of class ASP_User.
FailedPasswordAttemptCount | This is FailedPasswordAttemptCount, a member of class ASP_User.
FailedPasswordAttemptWindowStart | This is FailedPasswordAttemptWindowStart, a member of class ASP_User.
IsApproved | This is IsApproved, a member of class ASP_User.
IsLockedOut | This is IsLockedOut, a member of class ASP_User.
IsOnLine | This is IsOnLine, a member of class ASP_User.
LastActivityDate | This is LastActivityDate, a member of class ASP_User.
LastLockedOutDate | This is LastLockedOutDate, a member of class ASP_User.
LastLoginDate | This is LastLoginDate, a member of class ASP_User.
LastPasswordChangedDate | This is LastPasswordChangedDate, a member of class ASP_User.
Name | This is Name, a member of class ASP_User.
Password | This is Password, a member of class ASP_User.
PasswordAnswer | This is PasswordAnswer, a member of class ASP_User.
PasswordQuestion | This is PasswordQuestion, a member of class ASP_User.
Profile | This is Profile, a member of class ASP_User.
Roles | This is Roles, a member of class ASP_User.
RoleUser | This is RoleUser, a member of class ASP_User.


ASP_User.ApplicationName Property

ASP_User.ApplicationName Property
ASP_User Class Eco.Web.AspProviders Namespace See Also
Collapse All
C#
public string ApplicationName;
Remarks

This is ApplicationName, a member of class ASP_User.

See Also
ASP_User Class
Eco.Web.AspProviders Namespace


ASP_User.Comment Property

ASP_User.Comment Property
ASP_User Class Eco.Web.AspProviders Namespace See Also
Collapse All
C#
public string Comment;
Remarks

This is Comment, a member of class ASP_User.

See Also
ASP_User Class
Eco.Web.AspProviders Namespace


ASP_User.CreationDate Property

ASP_User.CreationDate Property
ASP_User Class Eco.Web.AspProviders Namespace See Also
Collapse All
C#
public System.DateTime CreationDate;
Remarks

This is CreationDate, a member of class ASP_User.

See Also
ASP_User Class
Eco.Web.AspProviders Namespace


ASP_User.Email Property

ASP_User.Email Property
ASP_User Class Eco.Web.AspProviders Namespace See Also
Collapse All
C#
public string Email;
Remarks

This is Email, a member of class ASP_User.

See Also
ASP_User Class
Eco.Web.AspProviders Namespace


ASP_User.FailedPasswordAnswerAttemptCount Property

ASP_User.FailedPasswordAnswerAttemptCount Property
ASP_User Class Eco.Web.AspProviders Namespace See Also
Collapse All
C#
public int FailedPasswordAnswerAttemptCount;
Remarks

This is FailedPasswordAnswerAttemptCount, a member of class ASP_User.

See Also
ASP_User Class
Eco.Web.AspProviders Namespace


ASP_User.FailedPasswordAnswerAttemptWindowStart Property

ASP_User.FailedPasswordAnswerAttemptWindowStart Property
ASP_User Class Eco.Web.AspProviders Namespace See Also
Collapse All
C#
public System.DateTime FailedPasswordAnswerAttemptWindowStart;
Remarks

This is FailedPasswordAnswerAttemptWindowStart, a member of class ASP_User.

See Also
ASP_User Class
Eco.Web.AspProviders Namespace


ASP_User.FailedPasswordAttemptCount Property

ASP_User.FailedPasswordAttemptCount Property
ASP_User Class Eco.Web.AspProviders Namespace See Also
Collapse All
C#
public int FailedPasswordAttemptCount;
Remarks

This is FailedPasswordAttemptCount, a member of class ASP_User.

See Also
ASP_User Class
Eco.Web.AspProviders Namespace


ASP_User.FailedPasswordAttemptWindowStart Property

ASP_User.FailedPasswordAttemptWindowStart Property
ASP_User Class Eco.Web.AspProviders Namespace See Also
Collapse All
C#
public System.DateTime FailedPasswordAttemptWindowStart;
Remarks

This is FailedPasswordAttemptWindowStart, a member of class ASP_User.

See Also
ASP_User Class
Eco.Web.AspProviders Namespace


ASP_User.IsApproved Property

ASP_User.IsApproved Property
ASP_User Class Eco.Web.AspProviders Namespace See Also
Collapse All
C#
public bool IsApproved;
Remarks

This is IsApproved, a member of class ASP_User.

See Also
ASP_User Class
Eco.Web.AspProviders Namespace


ASP_User.IsLockedOut Property

ASP_User.IsLockedOut Property
ASP_User Class Eco.Web.AspProviders Namespace See Also
Collapse All
C#
public bool IsLockedOut;
Remarks

This is IsLockedOut, a member of class ASP_User.

See Also
ASP_User Class
Eco.Web.AspProviders Namespace


ASP_User.IsOnLine Property

ASP_User.IsOnLine Property
ASP_User Class Eco.Web.AspProviders Namespace See Also
Collapse All
C#
public bool IsOnLine;
Remarks

This is IsOnLine, a member of class ASP_User.

See Also
ASP_User Class
Eco.Web.AspProviders Namespace


ASP_User.LastActivityDate Property

ASP_User.LastActivityDate Property
ASP_User Class Eco.Web.AspProviders Namespace See Also
Collapse All
C#
public System.DateTime LastActivityDate;
Remarks

This is LastActivityDate, a member of class ASP_User.

See Also
ASP_User Class
Eco.Web.AspProviders Namespace


ASP_User.LastLockedOutDate Property

ASP_User.LastLockedOutDate Property
ASP_User Class Eco.Web.AspProviders Namespace See Also
Collapse All
C#
public System.DateTime LastLockedOutDate;
Remarks

This is LastLockedOutDate, a member of class ASP_User.

See Also
ASP_User Class
Eco.Web.AspProviders Namespace


ASP_User.LastLoginDate Property

ASP_User.LastLoginDate Property
ASP_User Class Eco.Web.AspProviders Namespace See Also
Collapse All
C#
public System.DateTime LastLoginDate;
Remarks

This is LastLoginDate, a member of class ASP_User.

See Also
ASP_User Class
Eco.Web.AspProviders Namespace


ASP_User.LastPasswordChangedDate Property

ASP_User.LastPasswordChangedDate Property
ASP_User Class Eco.Web.AspProviders Namespace See Also
Collapse All
C#
public System.DateTime LastPasswordChangedDate;
Remarks

This is LastPasswordChangedDate, a member of class ASP_User.

See Also
ASP_User Class
Eco.Web.AspProviders Namespace


ASP_User.Name Property

ASP_User.Name Property
ASP_User Class Eco.Web.AspProviders Namespace See Also
Collapse All
C#
public string Name;
Remarks

This is Name, a member of class ASP_User.

See Also
ASP_User Class
Eco.Web.AspProviders Namespace


ASP_User.Password Property

ASP_User.Password Property
ASP_User Class Eco.Web.AspProviders Namespace See Also
Collapse All
C#
public string Password;
Remarks

This is Password, a member of class ASP_User.

See Also
ASP_User Class
Eco.Web.AspProviders Namespace


ASP_User.PasswordAnswer Property

ASP_User.PasswordAnswer Property
ASP_User Class Eco.Web.AspProviders Namespace See Also
Collapse All
C#
public string PasswordAnswer;
Remarks

This is PasswordAnswer, a member of class ASP_User.

See Also
ASP_User Class
Eco.Web.AspProviders Namespace


ASP_User.PasswordQuestion Property

ASP_User.PasswordQuestion Property
ASP_User Class Eco.Web.AspProviders Namespace See Also
Collapse All
C#
public string PasswordQuestion;
Remarks

This is PasswordQuestion, a member of class ASP_User.

See Also
ASP_User Class
Eco.Web.AspProviders Namespace


ASP_User.Profile Property

ASP_User.Profile Property
ASP_User Class Eco.Web.AspProviders Namespace See Also
Collapse All
C#
public ASP_Profile Profile;
Remarks

This is Profile, a member of class ASP_User.

See Also
ASP_User Class
Eco.Web.AspProviders Namespace


ASP_User.Roles Property

ASP_User.Roles Property
ASP_User Class Eco.Web.AspProviders Namespace See Also
Collapse All
C#
public IEcoList<ASP_Role> Roles;
Remarks

This is Roles, a member of class ASP_User.

See Also
ASP_User Class
Eco.Web.AspProviders Namespace


ASP_User.RoleUser Property

ASP_User.RoleUser Property
ASP_User Class Eco.Web.AspProviders Namespace See Also
Collapse All
C#
public ASP_RoleUser RoleUser;
Remarks

This is RoleUser, a member of class ASP_User.

See Also
ASP_User Class
Eco.Web.AspProviders Namespace


ASP_WebEvent Class

ASP_WebEvent Class
Inheritance Hierarchy See Also
Collapse All
C#
public class ASP_WebEvent : Eco.ObjectImplementation.ILoopBack2, System.ComponentModel.INotifyPropertyChanged;
Remarks

This is class Eco.Web.AspProviders.ASP_WebEvent.

Inheritance Hierarchy
Eco.Web.AspProviders.ASP_WebEvent
File

ASP_WebEvent.eco.cs

See Also
Inheritance Hierarchy


ASP_WebEvent Constructor

ASP_WebEvent Constructor

This is the overview for the ASP_WebEvent constructor overload.

Overload List
Name | Description
ASP_WebEvent.ASP_WebEvent (Eco.ObjectImplementation.IContent) | For framework internal use only
ASP_WebEvent.ASP_WebEvent (Eco.ObjectRepresentation.IEcoServiceProvider) | This is ASP_WebEvent, a member of class ASP_WebEvent.


ASP_WebEvent.ASP_WebEvent Constructor (Eco.ObjectImplementation.IContent)

ASP_WebEvent.ASP_WebEvent Constructor (Eco.ObjectImplementation.IContent)
ASP_WebEvent Class Eco.Web.AspProviders Namespace See Also
Collapse All
C#
protected ASP_WebEvent(
    Eco.ObjectImplementation.IContent content
);
Remarks

For framework internal use only

See Also
ASP_WebEvent Class
Eco.Web.AspProviders Namespace


ASP_WebEvent.ASP_WebEvent Constructor (Eco.ObjectRepresentation.IEcoServiceProvider)

ASP_WebEvent.ASP_WebEvent Constructor (Eco.ObjectRepresentation.IEcoServiceProvider)
ASP_WebEvent Class Eco.Web.AspProviders Namespace See Also
Collapse All
C#
public ASP_WebEvent(
    Eco.ObjectRepresentation.IEcoServiceProvider serviceProvider
);
Remarks

This is ASP_WebEvent, a member of class ASP_WebEvent.

See Also
ASP_WebEvent Class
Eco.Web.AspProviders Namespace


ASP_WebEvent Classes

ASP_WebEvent Classes
Classes
Collapse All

The classes of the ASP_WebEvent class are listed here.

Classes
Name | Description
Eco_LoopbackIndices | This is class Eco.Web.AspProviders.ASP_WebEvent.Eco_LoopbackIndices.


ASP_WebEvent.Eco_LoopbackIndices Class

ASP_WebEvent.Eco_LoopbackIndices Class
Inheritance Hierarchy See Also
Collapse All
C#
public class Eco_LoopbackIndices;
Remarks

This is class Eco.Web.AspProviders.ASP_WebEvent.Eco_LoopbackIndices.

Inheritance Hierarchy
Eco.Web.AspProviders.ASP_WebEvent.Eco_LoopbackIndices
File

ASP_WebEvent.eco.cs

See Also
Inheritance Hierarchy


Eco_LoopbackIndices Fields

Eco_LoopbackIndices Fields
Public Fields
Collapse All

The fields of the Eco_LoopbackIndices class are listed here.

Public Fields
Name | Description
ApplicationPath | This is ApplicationPath, a member of class Eco_LoopbackIndices.
ApplicationVirtualPath | This is ApplicationVirtualPath, a member of class Eco_LoopbackIndices.
Details | This is Details, a member of class Eco_LoopbackIndices.
Eco_FirstMember | This is Eco_FirstMember, a member of class Eco_LoopbackIndices.
Eco_MemberCount | This is Eco_MemberCount, a member of class Eco_LoopbackIndices.
EventCode | This is EventCode, a member of class Eco_LoopbackIndices.
EventDetailCode | This is EventDetailCode, a member of class Eco_LoopbackIndices.
EventId | This is EventId, a member of class Eco_LoopbackIndices.
EventOccurrence | This is EventOccurrence, a member of class Eco_LoopbackIndices.
EventSequence | This is EventSequence, a member of class Eco_LoopbackIndices.
EventTime | This is EventTime, a member of class Eco_LoopbackIndices.
EventTimeUtc | This is EventTimeUtc, a member of class Eco_LoopbackIndices.
EventType | This is EventType, a member of class Eco_LoopbackIndices.
ExceptionType | This is ExceptionType, a member of class Eco_LoopbackIndices.
MachineName | This is MachineName, a member of class Eco_LoopbackIndices.
Message | This is Message, a member of class Eco_LoopbackIndices.
RequestUrl | This is RequestUrl, a member of class Eco_LoopbackIndices.


ASP_WebEvent.Eco_LoopbackIndices.ApplicationPath Field

ASP_WebEvent.Eco_LoopbackIndices.ApplicationPath Field
ASP_WebEvent.Eco_LoopbackIndices Class Eco.Web.AspProviders Namespace See Also
Collapse All
C#
public const int ApplicationPath = (EventDetailCode + 1);
Remarks

This is ApplicationPath, a member of class Eco_LoopbackIndices.

See Also
ASP_WebEvent.Eco_LoopbackIndices Class
Eco.Web.AspProviders Namespace


ASP_WebEvent.Eco_LoopbackIndices.ApplicationVirtualPath Field

ASP_WebEvent.Eco_LoopbackIndices.ApplicationVirtualPath Field
ASP_WebEvent.Eco_LoopbackIndices Class Eco.Web.AspProviders Namespace See Also
Collapse All
C#
public const int ApplicationVirtualPath = (Message + 1);
Remarks

This is ApplicationVirtualPath, a member of class Eco_LoopbackIndices.

See Also
ASP_WebEvent.Eco_LoopbackIndices Class
Eco.Web.AspProviders Namespace


ASP_WebEvent.Eco_LoopbackIndices.Details Field

ASP_WebEvent.Eco_LoopbackIndices.Details Field
ASP_WebEvent.Eco_LoopbackIndices Class Eco.Web.AspProviders Namespace See Also
Collapse All
C#
public const int Details = (EventOccurrence + 1);
Remarks

This is Details, a member of class Eco_LoopbackIndices.

See Also
ASP_WebEvent.Eco_LoopbackIndices Class
Eco.Web.AspProviders Namespace


ASP_WebEvent.Eco_LoopbackIndices.Eco_FirstMember Field

ASP_WebEvent.Eco_LoopbackIndices.Eco_FirstMember Field
ASP_WebEvent.Eco_LoopbackIndices Class Eco.Web.AspProviders Namespace See Also
Collapse All
C#
public const int Eco_FirstMember = 0;
Remarks

This is Eco_FirstMember, a member of class Eco_LoopbackIndices.

See Also
ASP_WebEvent.Eco_LoopbackIndices Class
Eco.Web.AspProviders Namespace


ASP_WebEvent.Eco_LoopbackIndices.Eco_MemberCount Field

ASP_WebEvent.Eco_LoopbackIndices.Eco_MemberCount Field
ASP_WebEvent.Eco_LoopbackIndices Class Eco.Web.AspProviders Namespace See Also
Collapse All
C#
public const int Eco_MemberCount = (EventType + 1);
Remarks

This is Eco_MemberCount, a member of class Eco_LoopbackIndices.

See Also
ASP_WebEvent.Eco_LoopbackIndices Class
Eco.Web.AspProviders Namespace


ASP_WebEvent.Eco_LoopbackIndices.EventCode Field

ASP_WebEvent.Eco_LoopbackIndices.EventCode Field
ASP_WebEvent.Eco_LoopbackIndices Class Eco.Web.AspProviders Namespace See Also
Collapse All
C#
public const int EventCode = (EventTimeUtc + 1);
Remarks

This is EventCode, a member of class Eco_LoopbackIndices.

See Also
ASP_WebEvent.Eco_LoopbackIndices Class
Eco.Web.AspProviders Namespace


ASP_WebEvent.Eco_LoopbackIndices.EventDetailCode Field

ASP_WebEvent.Eco_LoopbackIndices.EventDetailCode Field
ASP_WebEvent.Eco_LoopbackIndices Class Eco.Web.AspProviders Namespace See Also
Collapse All
C#
public const int EventDetailCode = (RequestUrl + 1);
Remarks

This is EventDetailCode, a member of class Eco_LoopbackIndices.

See Also
ASP_WebEvent.Eco_LoopbackIndices Class
Eco.Web.AspProviders Namespace


ASP_WebEvent.Eco_LoopbackIndices.EventId Field

ASP_WebEvent.Eco_LoopbackIndices.EventId Field
ASP_WebEvent.Eco_LoopbackIndices Class Eco.Web.AspProviders Namespace See Also
Collapse All
C#
public const int EventId = (MachineName + 1);
Remarks

This is EventId, a member of class Eco_LoopbackIndices.

See Also
ASP_WebEvent.Eco_LoopbackIndices Class
Eco.Web.AspProviders Namespace


ASP_WebEvent.Eco_LoopbackIndices.EventOccurrence Field

ASP_WebEvent.Eco_LoopbackIndices.EventOccurrence Field
ASP_WebEvent.Eco_LoopbackIndices Class Eco.Web.AspProviders Namespace See Also
Collapse All
C#
public const int EventOccurrence = (EventSequence + 1);
Remarks

This is EventOccurrence, a member of class Eco_LoopbackIndices.

See Also
ASP_WebEvent.Eco_LoopbackIndices Class
Eco.Web.AspProviders Namespace


ASP_WebEvent.Eco_LoopbackIndices.EventSequence Field

ASP_WebEvent.Eco_LoopbackIndices.EventSequence Field
ASP_WebEvent.Eco_LoopbackIndices Class Eco.Web.AspProviders Namespace See Also
Collapse All
C#
public const int EventSequence = (ExceptionType + 1);
Remarks

This is EventSequence, a member of class Eco_LoopbackIndices.

See Also
ASP_WebEvent.Eco_LoopbackIndices Class
Eco.Web.AspProviders Namespace


ASP_WebEvent.Eco_LoopbackIndices.EventTime Field

ASP_WebEvent.Eco_LoopbackIndices.EventTime Field
ASP_WebEvent.Eco_LoopbackIndices Class Eco.Web.AspProviders Namespace See Also
Collapse All
C#
public const int EventTime = (EventId + 1);
Remarks

This is EventTime, a member of class Eco_LoopbackIndices.

See Also
ASP_WebEvent.Eco_LoopbackIndices Class
Eco.Web.AspProviders Namespace


ASP_WebEvent.Eco_LoopbackIndices.EventTimeUtc Field

ASP_WebEvent.Eco_LoopbackIndices.EventTimeUtc Field
ASP_WebEvent.Eco_LoopbackIndices Class Eco.Web.AspProviders Namespace See Also
Collapse All
C#
public const int EventTimeUtc = (ApplicationPath + 1);
Remarks

This is EventTimeUtc, a member of class Eco_LoopbackIndices.

See Also
ASP_WebEvent.Eco_LoopbackIndices Class
Eco.Web.AspProviders Namespace


ASP_WebEvent.Eco_LoopbackIndices.EventType Field

ASP_WebEvent.Eco_LoopbackIndices.EventType Field
ASP_WebEvent.Eco_LoopbackIndices Class Eco.Web.AspProviders Namespace See Also
Collapse All
C#
public const int EventType = (EventCode + 1);
Remarks

This is EventType, a member of class Eco_LoopbackIndices.

See Also
ASP_WebEvent.Eco_LoopbackIndices Class
Eco.Web.AspProviders Namespace


ASP_WebEvent.Eco_LoopbackIndices.ExceptionType Field

ASP_WebEvent.Eco_LoopbackIndices.ExceptionType Field
ASP_WebEvent.Eco_LoopbackIndices Class Eco.Web.AspProviders Namespace See Also
Collapse All
C#
public const int ExceptionType = Eco_FirstMember;
Remarks

This is ExceptionType, a member of class Eco_LoopbackIndices.

See Also
ASP_WebEvent.Eco_LoopbackIndices Class
Eco.Web.AspProviders Namespace


ASP_WebEvent.Eco_LoopbackIndices.MachineName Field

ASP_WebEvent.Eco_LoopbackIndices.MachineName Field
ASP_WebEvent.Eco_LoopbackIndices Class Eco.Web.AspProviders Namespace See Also
Collapse All
C#
public const int MachineName = (ApplicationVirtualPath + 1);
Remarks

This is MachineName, a member of class Eco_LoopbackIndices.

See Also
ASP_WebEvent.Eco_LoopbackIndices Class
Eco.Web.AspProviders Namespace


ASP_WebEvent.Eco_LoopbackIndices.Message Field

ASP_WebEvent.Eco_LoopbackIndices.Message Field
ASP_WebEvent.Eco_LoopbackIndices Class Eco.Web.AspProviders Namespace See Also
Collapse All
C#
public const int Message = (Details + 1);
Remarks

This is Message, a member of class Eco_LoopbackIndices.

See Also
ASP_WebEvent.Eco_LoopbackIndices Class
Eco.Web.AspProviders Namespace


ASP_WebEvent.Eco_LoopbackIndices.RequestUrl Field

ASP_WebEvent.Eco_LoopbackIndices.RequestUrl Field
ASP_WebEvent.Eco_LoopbackIndices Class Eco.Web.AspProviders Namespace See Also
Collapse All
C#
public const int RequestUrl = (EventTime + 1);
Remarks

This is RequestUrl, a member of class Eco_LoopbackIndices.

See Also
ASP_WebEvent.Eco_LoopbackIndices Class
Eco.Web.AspProviders Namespace


ASP_WebEvent Fields

ASP_WebEvent Fields
Protected Fields
Collapse All

The fields of the ASP_WebEvent class are listed here.

Protected Fields
Name | Description
eco_Content | This is eco_Content, a member of class ASP_WebEvent.


ASP_WebEvent.eco_Content Field

ASP_WebEvent.eco_Content Field
ASP_WebEvent Class Eco.Web.AspProviders Namespace See Also
Collapse All
C#
protected Eco.ObjectImplementation.IContent eco_Content;
Remarks

This is eco_Content, a member of class ASP_WebEvent.

See Also
ASP_WebEvent Class
Eco.Web.AspProviders Namespace


ASP_WebEvent Methods

ASP_WebEvent Methods
Protected Methods Public Methods
Collapse All

The methods of the ASP_WebEvent class are listed here.

Protected Methods
Name | Description
Deinitialize | This is Deinitialize, a member of class ASP_WebEvent.
Initialize | This is Initialize, a member of class ASP_WebEvent.
Top
Public Methods
Name | Description
AsIObject | This is AsIObject, a member of class ASP_WebEvent.
get_MemberByIndex | This is get_MemberByIndex, a member of class ASP_WebEvent.
set_MemberByIndex | This is set_MemberByIndex, a member of class ASP_WebEvent.


ASP_WebEvent.AsIObject Method

ASP_WebEvent.AsIObject Method
ASP_WebEvent Class Eco.Web.AspProviders Namespace See Also
Collapse All
C#
public virtual Eco.ObjectRepresentation.IObjectInstance AsIObject();
Remarks

This is AsIObject, a member of class ASP_WebEvent.

See Also
ASP_WebEvent Class
Eco.Web.AspProviders Namespace


ASP_WebEvent.Deinitialize Method

ASP_WebEvent.Deinitialize Method
ASP_WebEvent Class Eco.Web.AspProviders Namespace See Also
Collapse All
C#
protected virtual void Deinitialize(
    Eco.ObjectRepresentation.IEcoServiceProvider serviceProvider
);
Remarks

This is Deinitialize, a member of class ASP_WebEvent.

See Also
ASP_WebEvent Class
Eco.Web.AspProviders Namespace


ASP_WebEvent.get_MemberByIndex Method

ASP_WebEvent.get_MemberByIndex Method
ASP_WebEvent Class Eco.Web.AspProviders Namespace See Also
Collapse All
C#
public virtual object get_MemberByIndex(
    int index
);
Remarks

This is get_MemberByIndex, a member of class ASP_WebEvent.

See Also
ASP_WebEvent Class
Eco.Web.AspProviders Namespace


ASP_WebEvent.Initialize Method

ASP_WebEvent.Initialize Method
ASP_WebEvent Class Eco.Web.AspProviders Namespace See Also
Collapse All
C#
protected virtual void Initialize(
    Eco.ObjectRepresentation.IEcoServiceProvider serviceProvider
);
Remarks

This is Initialize, a member of class ASP_WebEvent.

See Also
ASP_WebEvent Class
Eco.Web.AspProviders Namespace


ASP_WebEvent.set_MemberByIndex Method

ASP_WebEvent.set_MemberByIndex Method
ASP_WebEvent Class Eco.Web.AspProviders Namespace See Also
Collapse All
C#
public virtual void set_MemberByIndex(
    int index,
    object value
);
Remarks

This is set_MemberByIndex, a member of class ASP_WebEvent.

See Also
ASP_WebEvent Class
Eco.Web.AspProviders Namespace


ASP_WebEvent Properties

ASP_WebEvent Properties
Public Properties
Collapse All

The properties of the ASP_WebEvent class are listed here.

Public Properties
Name | Description
ApplicationPath | This is ApplicationPath, a member of class ASP_WebEvent.
ApplicationVirtualPath | This is ApplicationVirtualPath, a member of class ASP_WebEvent.
Details | This is Details, a member of class ASP_WebEvent.
EventCode | This is EventCode, a member of class ASP_WebEvent.
EventDetailCode | This is EventDetailCode, a member of class ASP_WebEvent.
EventId | This is EventId, a member of class ASP_WebEvent.
EventOccurrence | This is EventOccurrence, a member of class ASP_WebEvent.
EventSequence | This is EventSequence, a member of class ASP_WebEvent.
EventTime | This is EventTime, a member of class ASP_WebEvent.
EventTimeUtc | This is EventTimeUtc, a member of class ASP_WebEvent.
EventType | This is EventType, a member of class ASP_WebEvent.
ExceptionType | This is ExceptionType, a member of class ASP_WebEvent.
MachineName | This is MachineName, a member of class ASP_WebEvent.
Message | This is Message, a member of class ASP_WebEvent.
RequestUrl | This is RequestUrl, a member of class ASP_WebEvent.


ASP_WebEvent.ApplicationPath Property

ASP_WebEvent.ApplicationPath Property
ASP_WebEvent Class Eco.Web.AspProviders Namespace See Also
Collapse All
C#
public string ApplicationPath;
Remarks

This is ApplicationPath, a member of class ASP_WebEvent.

See Also
ASP_WebEvent Class
Eco.Web.AspProviders Namespace


ASP_WebEvent.ApplicationVirtualPath Property

ASP_WebEvent.ApplicationVirtualPath Property
ASP_WebEvent Class Eco.Web.AspProviders Namespace See Also
Collapse All
C#
public string ApplicationVirtualPath;
Remarks

This is ApplicationVirtualPath, a member of class ASP_WebEvent.

See Also
ASP_WebEvent Class
Eco.Web.AspProviders Namespace


ASP_WebEvent.Details Property

ASP_WebEvent.Details Property
ASP_WebEvent Class Eco.Web.AspProviders Namespace See Also
Collapse All
C#
public string Details;
Remarks

This is Details, a member of class ASP_WebEvent.

See Also
ASP_WebEvent Class
Eco.Web.AspProviders Namespace


ASP_WebEvent.EventCode Property

ASP_WebEvent.EventCode Property
ASP_WebEvent Class Eco.Web.AspProviders Namespace See Also
Collapse All
C#
public int EventCode;
Remarks

This is EventCode, a member of class ASP_WebEvent.

See Also
ASP_WebEvent Class
Eco.Web.AspProviders Namespace


ASP_WebEvent.EventDetailCode Property

ASP_WebEvent.EventDetailCode Property
ASP_WebEvent Class Eco.Web.AspProviders Namespace See Also
Collapse All
C#
public int EventDetailCode;
Remarks

This is EventDetailCode, a member of class ASP_WebEvent.

See Also
ASP_WebEvent Class
Eco.Web.AspProviders Namespace


ASP_WebEvent.EventId Property

ASP_WebEvent.EventId Property
ASP_WebEvent Class Eco.Web.AspProviders Namespace See Also
Collapse All
C#
public System.Guid EventId;
Remarks

This is EventId, a member of class ASP_WebEvent.

See Also
ASP_WebEvent Class
Eco.Web.AspProviders Namespace


ASP_WebEvent.EventOccurrence Property

ASP_WebEvent.EventOccurrence Property
ASP_WebEvent Class Eco.Web.AspProviders Namespace See Also
Collapse All
C#
public long EventOccurrence;
Remarks

This is EventOccurrence, a member of class ASP_WebEvent.

See Also
ASP_WebEvent Class
Eco.Web.AspProviders Namespace


ASP_WebEvent.EventSequence Property

ASP_WebEvent.EventSequence Property
ASP_WebEvent Class Eco.Web.AspProviders Namespace See Also
Collapse All
C#
public long EventSequence;
Remarks

This is EventSequence, a member of class ASP_WebEvent.

See Also
ASP_WebEvent Class
Eco.Web.AspProviders Namespace


ASP_WebEvent.EventTime Property

ASP_WebEvent.EventTime Property
ASP_WebEvent Class Eco.Web.AspProviders Namespace See Also
Collapse All
C#
public System.DateTime EventTime;
Remarks

This is EventTime, a member of class ASP_WebEvent.

See Also
ASP_WebEvent Class
Eco.Web.AspProviders Namespace


ASP_WebEvent.EventTimeUtc Property

ASP_WebEvent.EventTimeUtc Property
ASP_WebEvent Class Eco.Web.AspProviders Namespace See Also
Collapse All
C#
public System.DateTime EventTimeUtc;
Remarks

This is EventTimeUtc, a member of class ASP_WebEvent.

See Also
ASP_WebEvent Class
Eco.Web.AspProviders Namespace


ASP_WebEvent.EventType Property

ASP_WebEvent.EventType Property
ASP_WebEvent Class Eco.Web.AspProviders Namespace See Also
Collapse All
C#
public string EventType;
Remarks

This is EventType, a member of class ASP_WebEvent.

See Also
ASP_WebEvent Class
Eco.Web.AspProviders Namespace


ASP_WebEvent.ExceptionType Property

ASP_WebEvent.ExceptionType Property
ASP_WebEvent Class Eco.Web.AspProviders Namespace See Also
Collapse All
C#
public string ExceptionType;
Remarks

This is ExceptionType, a member of class ASP_WebEvent.

See Also
ASP_WebEvent Class
Eco.Web.AspProviders Namespace


ASP_WebEvent.MachineName Property

ASP_WebEvent.MachineName Property
ASP_WebEvent Class Eco.Web.AspProviders Namespace See Also
Collapse All
C#
public string MachineName;
Remarks

This is MachineName, a member of class ASP_WebEvent.

See Also
ASP_WebEvent Class
Eco.Web.AspProviders Namespace


ASP_WebEvent.Message Property

ASP_WebEvent.Message Property
ASP_WebEvent Class Eco.Web.AspProviders Namespace See Also
Collapse All
C#
public string Message;
Remarks

This is Message, a member of class ASP_WebEvent.

See Also
ASP_WebEvent Class
Eco.Web.AspProviders Namespace


ASP_WebEvent.RequestUrl Property

ASP_WebEvent.RequestUrl Property
ASP_WebEvent Class Eco.Web.AspProviders Namespace See Also
Collapse All
C#
public string RequestUrl;
Remarks

This is RequestUrl, a member of class ASP_WebEvent.

See Also
ASP_WebEvent Class
Eco.Web.AspProviders Namespace


ASP_XmlPropValue Class

ASP_XmlPropValue Class
Inheritance Hierarchy See Also
Collapse All
C#
public class ASP_XmlPropValue : Eco.Web.AspProviders.ASP_ProfilePropValue;
Remarks

This is class Eco.Web.AspProviders.ASP_XmlPropValue.

Inheritance Hierarchy
Eco.Web.AspProviders.ASP_XmlPropValue
File

ASP_XmlPropValue.eco.cs

See Also
Inheritance Hierarchy


ASP_XmlPropValue Constructor

ASP_XmlPropValue Constructor

This is the overview for the ASP_XmlPropValue constructor overload.

Overload List
Name | Description
ASP_XmlPropValue.ASP_XmlPropValue (Eco.ObjectImplementation.IContent) | For framework internal use only
ASP_XmlPropValue.ASP_XmlPropValue (Eco.ObjectRepresentation.IEcoServiceProvider) | This is ASP_XmlPropValue, a member of class ASP_XmlPropValue.


ASP_XmlPropValue.ASP_XmlPropValue Constructor (Eco.ObjectImplementation.IContent)

ASP_XmlPropValue.ASP_XmlPropValue Constructor (Eco.ObjectImplementation.IContent)
ASP_XmlPropValue Class Eco.Web.AspProviders Namespace See Also
Collapse All
C#
protected ASP_XmlPropValue(
    Eco.ObjectImplementation.IContent content
);
Remarks

For framework internal use only

See Also
ASP_XmlPropValue Class
Eco.Web.AspProviders Namespace


ASP_XmlPropValue.ASP_XmlPropValue Constructor (Eco.ObjectRepresentation.IEcoServiceProvider)

ASP_XmlPropValue.ASP_XmlPropValue Constructor (Eco.ObjectRepresentation.IEcoServiceProvider)
ASP_XmlPropValue Class Eco.Web.AspProviders Namespace See Also
Collapse All
C#
public ASP_XmlPropValue(
    Eco.ObjectRepresentation.IEcoServiceProvider serviceProvider
);
Remarks

This is ASP_XmlPropValue, a member of class ASP_XmlPropValue.

See Also
ASP_XmlPropValue Class
Eco.Web.AspProviders Namespace


ASP_XmlPropValue Classes

ASP_XmlPropValue Classes
Classes
Collapse All

The classes of the ASP_XmlPropValue class are listed here.

Classes
Name | Description
Eco_LoopbackIndices | This is class Eco.Web.AspProviders.ASP_XmlPropValue.Eco_LoopbackIndices.


ASP_XmlPropValue.Eco_LoopbackIndices Class

ASP_XmlPropValue.Eco_LoopbackIndices Class
Inheritance Hierarchy See Also
Collapse All
C#
public new class Eco_LoopbackIndices;
Remarks

This is class Eco.Web.AspProviders.ASP_XmlPropValue.Eco_LoopbackIndices.

Inheritance Hierarchy
Eco.Web.AspProviders.ASP_XmlPropValue.Eco_LoopbackIndices
File

ASP_XmlPropValue.eco.cs

See Also
Inheritance Hierarchy


Eco_LoopbackIndices Fields

Eco_LoopbackIndices Fields
Public Fields
Collapse All

The fields of the Eco_LoopbackIndices class are listed here.

Public Fields
Name | Description
Eco_FirstMember | This is Eco_FirstMember, a member of class Eco_LoopbackIndices.
Eco_MemberCount | This is Eco_MemberCount, a member of class Eco_LoopbackIndices.
Value | This is Value, a member of class Eco_LoopbackIndices.
ValueType | This is ValueType, a member of class Eco_LoopbackIndices.


ASP_XmlPropValue.Eco_LoopbackIndices.Eco_FirstMember Field

ASP_XmlPropValue.Eco_LoopbackIndices.Eco_FirstMember Field
ASP_XmlPropValue.Eco_LoopbackIndices Class Eco.Web.AspProviders Namespace See Also
Collapse All
C#
public const int Eco_FirstMember = Eco.Web.AspProviders.ASP_ProfilePropValue.Eco_LoopbackIndices.Eco_MemberCount;
Remarks

This is Eco_FirstMember, a member of class Eco_LoopbackIndices.

See Also
ASP_XmlPropValue.Eco_LoopbackIndices Class
Eco.Web.AspProviders Namespace


ASP_XmlPropValue.Eco_LoopbackIndices.Eco_MemberCount Field

ASP_XmlPropValue.Eco_LoopbackIndices.Eco_MemberCount Field
ASP_XmlPropValue.Eco_LoopbackIndices Class Eco.Web.AspProviders Namespace See Also
Collapse All
C#
public const int Eco_MemberCount = (Value + 1);
Remarks

This is Eco_MemberCount, a member of class Eco_LoopbackIndices.

See Also
ASP_XmlPropValue.Eco_LoopbackIndices Class
Eco.Web.AspProviders Namespace


ASP_XmlPropValue.Eco_LoopbackIndices.Value Field

ASP_XmlPropValue.Eco_LoopbackIndices.Value Field
ASP_XmlPropValue.Eco_LoopbackIndices Class Eco.Web.AspProviders Namespace See Also
Collapse All
C#
public const int Value = (ValueType + 1);
Remarks

This is Value, a member of class Eco_LoopbackIndices.

See Also
ASP_XmlPropValue.Eco_LoopbackIndices Class
Eco.Web.AspProviders Namespace


ASP_XmlPropValue.Eco_LoopbackIndices.ValueType Field

ASP_XmlPropValue.Eco_LoopbackIndices.ValueType Field
ASP_XmlPropValue.Eco_LoopbackIndices Class Eco.Web.AspProviders Namespace See Also
Collapse All
C#
public const int ValueType = Eco_FirstMember;
Remarks

This is ValueType, a member of class Eco_LoopbackIndices.

See Also
ASP_XmlPropValue.Eco_LoopbackIndices Class
Eco.Web.AspProviders Namespace


ASP_XmlPropValue Methods

ASP_XmlPropValue Methods
Public Methods
Collapse All

The methods of the ASP_XmlPropValue class are listed here.

Public Methods
Name | Description
get_MemberByIndex | This is get_MemberByIndex, a member of class ASP_XmlPropValue.
GetValue | This is GetValue, a member of class ASP_XmlPropValue.
set_MemberByIndex | This is set_MemberByIndex, a member of class ASP_XmlPropValue.
SetValue | This is SetValue, a member of class ASP_XmlPropValue.


ASP_XmlPropValue.get_MemberByIndex Method

ASP_XmlPropValue.get_MemberByIndex Method
ASP_XmlPropValue Class Eco.Web.AspProviders Namespace See Also
Collapse All
C#
public override object get_MemberByIndex(
    int index
);
Remarks

This is get_MemberByIndex, a member of class ASP_XmlPropValue.

See Also
ASP_XmlPropValue Class
Eco.Web.AspProviders Namespace


ASP_XmlPropValue.GetValue Method

ASP_XmlPropValue.GetValue Method
ASP_XmlPropValue Class Eco.Web.AspProviders Namespace See Also
Collapse All
C#
public override object GetValue();
Remarks

This is GetValue, a member of class ASP_XmlPropValue.

See Also
ASP_XmlPropValue Class
Eco.Web.AspProviders Namespace


ASP_XmlPropValue.set_MemberByIndex Method

ASP_XmlPropValue.set_MemberByIndex Method
ASP_XmlPropValue Class Eco.Web.AspProviders Namespace See Also
Collapse All
C#
public override void set_MemberByIndex(
    int index,
    object value
);
Remarks

This is set_MemberByIndex, a member of class ASP_XmlPropValue.

See Also
ASP_XmlPropValue Class
Eco.Web.AspProviders Namespace


ASP_XmlPropValue.SetValue Method

ASP_XmlPropValue.SetValue Method
ASP_XmlPropValue Class Eco.Web.AspProviders Namespace See Also
Collapse All
C#
public void SetValue(
    object value
);
Remarks

This is SetValue, a member of class ASP_XmlPropValue.

See Also
ASP_XmlPropValue Class
Eco.Web.AspProviders Namespace


ASP_XmlPropValue Properties

ASP_XmlPropValue Properties
Public Properties
Collapse All

The properties of the ASP_XmlPropValue class are listed here.

Public Properties
Name | Description
Value | This is Value, a member of class ASP_XmlPropValue.
ValueType | This is ValueType, a member of class ASP_XmlPropValue.


ASP_XmlPropValue.Value Property

ASP_XmlPropValue.Value Property
ASP_XmlPropValue Class Eco.Web.AspProviders Namespace See Also
Collapse All
C#
public string Value;
Remarks

This is Value, a member of class ASP_XmlPropValue.

See Also
ASP_XmlPropValue Class
Eco.Web.AspProviders Namespace


ASP_XmlPropValue.ValueType Property

ASP_XmlPropValue.ValueType Property
ASP_XmlPropValue Class Eco.Web.AspProviders Namespace See Also
Collapse All
C#
public string ValueType;
Remarks

This is ValueType, a member of class ASP_XmlPropValue.

See Also
ASP_XmlPropValue Class
Eco.Web.AspProviders Namespace


EcoAspProviderPackage Class

EcoAspProviderPackage Class
Inheritance Hierarchy See Also
Collapse All
C#
public abstract class EcoAspProviderPackage;
Remarks

This is class Eco.Web.AspProviders.EcoAspProviderPackage.

Inheritance Hierarchy
Eco.Web.AspProviders.EcoAspProviderPackage
File

EcoAspProvider.eco.cs

See Also
Inheritance Hierarchy


EcoAspProviderPackage Classes

EcoAspProviderPackage Classes
Classes
Collapse All

The classes of the EcoAspProviderPackage class are listed here.

Classes
Name | Description
ASP_ProfileProfileASP_ProfilePropValueValues | This is class Eco.Web.AspProviders.EcoAspProviderPackage.ASP_ProfileProfileASP_ProfilePropValueValues.
ASP_ProfileProfileASP_UserUser | This is class Eco.Web.AspProviders.EcoAspProviderPackage.ASP_ProfileProfileASP_UserUser.
ASP_RoleRolesASP_RoleUserRoleUsers | This is class Eco.Web.AspProviders.EcoAspProviderPackage.ASP_RoleRolesASP_RoleUserRoleUsers.
ASP_RoleRolesASP_UserUsers | This is class Eco.Web.AspProviders.EcoAspProviderPackage.ASP_RoleRolesASP_UserUsers.
ASP_RoleUserRoleUserASP_UserUser | This is class Eco.Web.AspProviders.EcoAspProviderPackage.ASP_RoleUserRoleUserASP_UserUser.


EcoAspProviderPackage.ASP_ProfileProfileASP_ProfilePropValueValues Class

EcoAspProviderPackage.ASP_ProfileProfileASP_ProfilePropValueValues Class
Inheritance Hierarchy See Also
Collapse All
C#
public class ASP_ProfileProfileASP_ProfilePropValueValues;
Remarks

This is class Eco.Web.AspProviders.EcoAspProviderPackage.ASP_ProfileProfileASP_ProfilePropValueValues.

Inheritance Hierarchy
Eco.Web.AspProviders.EcoAspProviderPackage.ASP_ProfileProfileASP_ProfilePropValueValues
File

EcoAspProvider.eco.cs

See Also
Inheritance Hierarchy


EcoAspProviderPackage.ASP_ProfileProfileASP_UserUser Class

EcoAspProviderPackage.ASP_ProfileProfileASP_UserUser Class
Inheritance Hierarchy See Also
Collapse All
C#
public class ASP_ProfileProfileASP_UserUser;
Remarks

This is class Eco.Web.AspProviders.EcoAspProviderPackage.ASP_ProfileProfileASP_UserUser.

Inheritance Hierarchy
Eco.Web.AspProviders.EcoAspProviderPackage.ASP_ProfileProfileASP_UserUser
File

EcoAspProvider.eco.cs

See Also
Inheritance Hierarchy


EcoAspProviderPackage.ASP_RoleRolesASP_RoleUserRoleUsers Class

EcoAspProviderPackage.ASP_RoleRolesASP_RoleUserRoleUsers Class
Inheritance Hierarchy See Also
Collapse All
C#
public class ASP_RoleRolesASP_RoleUserRoleUsers;
Remarks

This is class Eco.Web.AspProviders.EcoAspProviderPackage.ASP_RoleRolesASP_RoleUserRoleUsers.

Inheritance Hierarchy
Eco.Web.AspProviders.EcoAspProviderPackage.ASP_RoleRolesASP_RoleUserRoleUsers
File

EcoAspProvider.eco.cs

See Also
Inheritance Hierarchy


EcoAspProviderPackage.ASP_RoleRolesASP_UserUsers Class

EcoAspProviderPackage.ASP_RoleRolesASP_UserUsers Class
Inheritance Hierarchy See Also
Collapse All
C#
public class ASP_RoleRolesASP_UserUsers;
Remarks

This is class Eco.Web.AspProviders.EcoAspProviderPackage.ASP_RoleRolesASP_UserUsers.

Inheritance Hierarchy
Eco.Web.AspProviders.EcoAspProviderPackage.ASP_RoleRolesASP_UserUsers
File

EcoAspProvider.eco.cs

See Also
Inheritance Hierarchy


EcoAspProviderPackage.ASP_RoleUserRoleUserASP_UserUser Class

EcoAspProviderPackage.ASP_RoleUserRoleUserASP_UserUser Class
Inheritance Hierarchy See Also
Collapse All
C#
public class ASP_RoleUserRoleUserASP_UserUser;
Remarks

This is class Eco.Web.AspProviders.EcoAspProviderPackage.ASP_RoleUserRoleUserASP_UserUser.

Inheritance Hierarchy
Eco.Web.AspProviders.EcoAspProviderPackage.ASP_RoleUserRoleUserASP_UserUser
File

EcoAspProvider.eco.cs

See Also
Inheritance Hierarchy


EcoMembershipProvider Class

EcoMembershipProvider Class
Inheritance Hierarchy See Also
Collapse All

This class implements the ASP.Net Membership Provider mechanism

C#
public sealed class EcoMembershipProvider : System.Web.Security.MembershipProvider;
Inheritance Hierarchy
Eco.Web.AspProviders.EcoMembershipProvider
File

EcoMembershipProvider.cs

See Also
Inheritance Hierarchy


EcoMembershipProvider.EcoMembershipProvider Constructor

EcoMembershipProvider.EcoMembershipProvider Constructor
EcoMembershipProvider Class Eco.Web.AspProviders Namespace See Also
Collapse All
C#
public EcoMembershipProvider();
Remarks

This is EcoMembershipProvider, a member of class EcoMembershipProvider.

See Also
EcoMembershipProvider Class
Eco.Web.AspProviders Namespace


EcoMembershipProvider Methods

EcoMembershipProvider Methods
Public Methods
Collapse All

The methods of the EcoMembershipProvider class are listed here.

Public Methods
Name | Description
ChangePassword | MembershipProvider.ChangePassword
ChangePasswordQuestionAndAnswer | MembershipProvider.ChangePasswordQuestionAndAnswer
CreateUser | MembershipProvider.CreateUser
DeleteUser | MembershipProvider.DeleteUser
FindUsersByEmail | MembershipProvider.FindUsersByEmail
FindUsersByName | MembershipProvider.FindUsersByName
GetAllUsers | MembershipProvider.GetAllUsers
GetNumberOfUsersOnline | MembershipProvider.GetNumberOfUsersOnline
GetPassword | MembershipProvider.GetPassword
GetUser | This is the overview for the GetUser method overload.
GetUserNameByEmail | MembershipProvider.GetUserNameByEmail
Initialize | System.Configuration.Provider.ProviderBase.Initialize Method
LogOrThrow | WriteToEventLog A helper function that writes exception detail to the event log. Exceptions are written to the event log as a security measure to avoid private database details from being returned to the browser. If a method does not return a status or boolean indicating the action succeeded or failed, a generic exception is also thrown by the caller.
ResetPassword | MembershipProvider.ResetPassword
UnlockUser | MembershipProvider.UnlockUser
UpdateUser | This is the overview for the UpdateUser method overload.
ValidateUser | MembershipProvider.ValidateUser


EcoMembershipProvider.ChangePassword Method

EcoMembershipProvider.ChangePassword Method
EcoMembershipProvider Class Eco.Web.AspProviders Namespace See Also
Collapse All
C#
public override bool ChangePassword(
    string username,
    string oldPwd,
    string newPwd
);
Remarks

MembershipProvider.ChangePassword

See Also
EcoMembershipProvider Class
Eco.Web.AspProviders Namespace


EcoMembershipProvider.ChangePasswordQuestionAndAnswer Method

EcoMembershipProvider.ChangePasswordQuestionAndAnswer Method
EcoMembershipProvider Class Eco.Web.AspProviders Namespace See Also
Collapse All
C#
public override bool ChangePasswordQuestionAndAnswer(
    string username,
    string password,
    string newPwdQuestion,
    string newPwdAnswer
);
Remarks

MembershipProvider.ChangePasswordQuestionAndAnswer

See Also
EcoMembershipProvider Class
Eco.Web.AspProviders Namespace


EcoMembershipProvider.CreateUser Method

EcoMembershipProvider.CreateUser Method
EcoMembershipProvider Class Eco.Web.AspProviders Namespace See Also
Collapse All
C#
public override MembershipUser CreateUser(
    string username,
    string password,
    string email,
    string passwordQuestion,
    string passwordAnswer,
    bool isApproved,
    object providerUserKey,
    out MembershipCreateStatus status
);
Remarks

MembershipProvider.CreateUser

See Also
EcoMembershipProvider Class
Eco.Web.AspProviders Namespace


EcoMembershipProvider.DeleteUser Method

EcoMembershipProvider.DeleteUser Method
EcoMembershipProvider Class Eco.Web.AspProviders Namespace See Also
Collapse All
C#
public override bool DeleteUser(
    string username,
    bool deleteAllRelatedData
);
Remarks

MembershipProvider.DeleteUser

See Also
EcoMembershipProvider Class
Eco.Web.AspProviders Namespace


EcoMembershipProvider.FindUsersByEmail Method

EcoMembershipProvider.FindUsersByEmail Method
EcoMembershipProvider Class Eco.Web.AspProviders Namespace See Also
Collapse All
C#
public override MembershipUserCollection FindUsersByEmail(
    string emailToMatch,
    int pageIndex,
    int pageSize,
    out int totalRecords
);
Remarks

MembershipProvider.FindUsersByEmail

See Also
EcoMembershipProvider Class
Eco.Web.AspProviders Namespace


EcoMembershipProvider.FindUsersByName Method

EcoMembershipProvider.FindUsersByName Method
EcoMembershipProvider Class Eco.Web.AspProviders Namespace See Also
Collapse All
C#
public override MembershipUserCollection FindUsersByName(
    string usernameToMatch,
    int pageIndex,
    int pageSize,
    out int totalRecords
);
Remarks

MembershipProvider.FindUsersByName

See Also
EcoMembershipProvider Class
Eco.Web.AspProviders Namespace


EcoMembershipProvider.GetAllUsers Method

EcoMembershipProvider.GetAllUsers Method
EcoMembershipProvider Class Eco.Web.AspProviders Namespace See Also
Collapse All
C#
public override MembershipUserCollection GetAllUsers(
    int pageIndex,
    int pageSize,
    out int totalRecords
);
Remarks

MembershipProvider.GetAllUsers

See Also
EcoMembershipProvider Class
Eco.Web.AspProviders Namespace


EcoMembershipProvider.GetNumberOfUsersOnline Method

EcoMembershipProvider.GetNumberOfUsersOnline Method
EcoMembershipProvider Class Eco.Web.AspProviders Namespace See Also
Collapse All
C#
public override int GetNumberOfUsersOnline();
Remarks

MembershipProvider.GetNumberOfUsersOnline

See Also
EcoMembershipProvider Class
Eco.Web.AspProviders Namespace


EcoMembershipProvider.GetPassword Method

EcoMembershipProvider.GetPassword Method
EcoMembershipProvider Class Eco.Web.AspProviders Namespace See Also
Collapse All
C#
public override string GetPassword(
    string username,
    string answer
);
Remarks

MembershipProvider.GetPassword

See Also
EcoMembershipProvider Class
Eco.Web.AspProviders Namespace


GetUser Method

GetUser Method

This is the overview for the GetUser method overload.

Overload List
Name | Description
EcoMembershipProvider.GetUser (object, bool) | MembershipProvider.GetUser(object, bool)
EcoMembershipProvider.GetUser (string) | This is GetUser, a member of class EcoMembershipProvider.
EcoMembershipProvider.GetUser (string, bool) | MembershipProvider.GetUser(string, bool)


EcoMembershipProvider.GetUser Method (object, bool)

EcoMembershipProvider.GetUser Method (object, bool)
EcoMembershipProvider Class Eco.Web.AspProviders Namespace See Also
Collapse All
C#
public override MembershipUser GetUser(
    object providerUserKey,
    bool userIsOnline
);
Remarks

MembershipProvider.GetUser(object, bool)

See Also
EcoMembershipProvider Class
Eco.Web.AspProviders Namespace


EcoMembershipProvider.GetUser Method (string)

EcoMembershipProvider.GetUser Method (string)
EcoMembershipProvider Class Eco.Web.AspProviders Namespace See Also
Collapse All
C#
public ASP_User GetUser(
    string username
);
Remarks

This is GetUser, a member of class EcoMembershipProvider.

See Also
EcoMembershipProvider Class
Eco.Web.AspProviders Namespace


EcoMembershipProvider.GetUser Method (string, bool)

EcoMembershipProvider.GetUser Method (string, bool)
EcoMembershipProvider Class Eco.Web.AspProviders Namespace See Also
Collapse All
C#
public override MembershipUser GetUser(
    string username,
    bool userIsOnline
);
Remarks

MembershipProvider.GetUser(string, bool)

See Also
EcoMembershipProvider Class
Eco.Web.AspProviders Namespace


EcoMembershipProvider.GetUserNameByEmail Method

EcoMembershipProvider.GetUserNameByEmail Method
EcoMembershipProvider Class Eco.Web.AspProviders Namespace See Also
Collapse All
C#
public override string GetUserNameByEmail(
    string email
);
Remarks

MembershipProvider.GetUserNameByEmail

See Also
EcoMembershipProvider Class
Eco.Web.AspProviders Namespace


EcoMembershipProvider.Initialize Method

EcoMembershipProvider.Initialize Method
EcoMembershipProvider Class Eco.Web.AspProviders Namespace See Also
Collapse All
C#
public override void Initialize(
    string name,
    NameValueCollection config
);
Remarks

System.Configuration.Provider.ProviderBase.Initialize Method

See Also
EcoMembershipProvider Class
Eco.Web.AspProviders Namespace


EcoMembershipProvider.LogOrThrow Method

EcoMembershipProvider.LogOrThrow Method
EcoMembershipProvider Class Eco.Web.AspProviders Namespace See Also
Collapse All
C#
public void LogOrThrow(
    Exception e,
    string operation
);
Remarks

WriteToEventLog A helper function that writes exception detail to the event log. Exceptions are written to the event log as a security measure to avoid private database details from being returned to the browser. If a method does not return a status or boolean indicating the action succeeded or failed, a generic exception is also thrown by the caller.

See Also
EcoMembershipProvider Class
Eco.Web.AspProviders Namespace


EcoMembershipProvider.ResetPassword Method

EcoMembershipProvider.ResetPassword Method
EcoMembershipProvider Class Eco.Web.AspProviders Namespace See Also
Collapse All
C#
public override string ResetPassword(
    string username,
    string answer
);
Remarks

MembershipProvider.ResetPassword

See Also
EcoMembershipProvider Class
Eco.Web.AspProviders Namespace


EcoMembershipProvider.UnlockUser Method

EcoMembershipProvider.UnlockUser Method
EcoMembershipProvider Class Eco.Web.AspProviders Namespace See Also
Collapse All
C#
public override bool UnlockUser(
    string username
);
Remarks

MembershipProvider.UnlockUser

See Also
EcoMembershipProvider Class
Eco.Web.AspProviders Namespace


UpdateUser Method

UpdateUser Method

This is the overview for the UpdateUser method overload.

Overload List
Name | Description
EcoMembershipProvider.UpdateUser (ASP_User) | This is UpdateUser, a member of class EcoMembershipProvider.
EcoMembershipProvider.UpdateUser (MembershipUser) | MembershipProvider.UpdateUser


EcoMembershipProvider.UpdateUser Method (ASP_User)

EcoMembershipProvider.UpdateUser Method (ASP_User)
EcoMembershipProvider Class Eco.Web.AspProviders Namespace See Also
Collapse All
C#
public bool UpdateUser(
    ASP_User u
);
Remarks

This is UpdateUser, a member of class EcoMembershipProvider.

See Also
EcoMembershipProvider Class
Eco.Web.AspProviders Namespace


EcoMembershipProvider.UpdateUser Method (MembershipUser)

EcoMembershipProvider.UpdateUser Method (MembershipUser)
EcoMembershipProvider Class Eco.Web.AspProviders Namespace See Also
Collapse All
C#
public override void UpdateUser(
    MembershipUser user
);
Remarks

MembershipProvider.UpdateUser

See Also
EcoMembershipProvider Class
Eco.Web.AspProviders Namespace


EcoMembershipProvider.ValidateUser Method

EcoMembershipProvider.ValidateUser Method
EcoMembershipProvider Class Eco.Web.AspProviders Namespace See Also
Collapse All
C#
public override bool ValidateUser(
    string username,
    string password
);
Remarks

MembershipProvider.ValidateUser

See Also
EcoMembershipProvider Class
Eco.Web.AspProviders Namespace


EcoMembershipProvider Properties

EcoMembershipProvider Properties
Public Properties
Collapse All

The properties of the EcoMembershipProvider class are listed here.

Public Properties
Name | Description
ApplicationName | This is ApplicationName, a member of class EcoMembershipProvider.
EnablePasswordReset | This is EnablePasswordReset, a member of class EcoMembershipProvider.
EnablePasswordRetrieval | This is EnablePasswordRetrieval, a member of class EcoMembershipProvider.
MaxInvalidPasswordAttempts | This is MaxInvalidPasswordAttempts, a member of class EcoMembershipProvider.
MinRequiredNonAlphanumericCharacters | This is MinRequiredNonAlphanumericCharacters, a member of class EcoMembershipProvider.
MinRequiredPasswordLength | This is MinRequiredPasswordLength, a member of class EcoMembershipProvider.
PasswordAttemptWindow | This is PasswordAttemptWindow, a member of class EcoMembershipProvider.
PasswordFormat | This is PasswordFormat, a member of class EcoMembershipProvider.
PasswordStrengthRegularExpression | This is PasswordStrengthRegularExpression, a member of class EcoMembershipProvider.
RequiresQuestionAndAnswer | This is RequiresQuestionAndAnswer, a member of class EcoMembershipProvider.
RequiresUniqueEmail | This is RequiresUniqueEmail, a member of class EcoMembershipProvider.


EcoMembershipProvider.ApplicationName Property

EcoMembershipProvider.ApplicationName Property
EcoMembershipProvider Class Eco.Web.AspProviders Namespace See Also
Collapse All
C#
public override string ApplicationName;
Remarks

This is ApplicationName, a member of class EcoMembershipProvider.

See Also
EcoMembershipProvider Class
Eco.Web.AspProviders Namespace


EcoMembershipProvider.EnablePasswordReset Property

EcoMembershipProvider.EnablePasswordReset Property
EcoMembershipProvider Class Eco.Web.AspProviders Namespace See Also
Collapse All
C#
public override bool EnablePasswordReset;
Remarks

This is EnablePasswordReset, a member of class EcoMembershipProvider.

See Also
EcoMembershipProvider Class
Eco.Web.AspProviders Namespace


EcoMembershipProvider.EnablePasswordRetrieval Property

EcoMembershipProvider.EnablePasswordRetrieval Property
EcoMembershipProvider Class Eco.Web.AspProviders Namespace See Also
Collapse All
C#
public override bool EnablePasswordRetrieval;
Remarks

This is EnablePasswordRetrieval, a member of class EcoMembershipProvider.

See Also
EcoMembershipProvider Class
Eco.Web.AspProviders Namespace


EcoMembershipProvider.MaxInvalidPasswordAttempts Property

EcoMembershipProvider.MaxInvalidPasswordAttempts Property
EcoMembershipProvider Class Eco.Web.AspProviders Namespace See Also
Collapse All
C#
public override int MaxInvalidPasswordAttempts;
Remarks

This is MaxInvalidPasswordAttempts, a member of class EcoMembershipProvider.

See Also
EcoMembershipProvider Class
Eco.Web.AspProviders Namespace


EcoMembershipProvider.MinRequiredNonAlphanumericCharacters Property

EcoMembershipProvider.MinRequiredNonAlphanumericCharacters Property
EcoMembershipProvider Class Eco.Web.AspProviders Namespace See Also
Collapse All
C#
public override int MinRequiredNonAlphanumericCharacters;
Remarks

This is MinRequiredNonAlphanumericCharacters, a member of class EcoMembershipProvider.

See Also
EcoMembershipProvider Class
Eco.Web.AspProviders Namespace


EcoMembershipProvider.MinRequiredPasswordLength Property

EcoMembershipProvider.MinRequiredPasswordLength Property
EcoMembershipProvider Class Eco.Web.AspProviders Namespace See Also
Collapse All
C#
public override int MinRequiredPasswordLength;
Remarks

This is MinRequiredPasswordLength, a member of class EcoMembershipProvider.

See Also
EcoMembershipProvider Class
Eco.Web.AspProviders Namespace


EcoMembershipProvider.PasswordAttemptWindow Property

EcoMembershipProvider.PasswordAttemptWindow Property
EcoMembershipProvider Class Eco.Web.AspProviders Namespace See Also
Collapse All
C#
public override int PasswordAttemptWindow;
Remarks

This is PasswordAttemptWindow, a member of class EcoMembershipProvider.

See Also
EcoMembershipProvider Class
Eco.Web.AspProviders Namespace


EcoMembershipProvider.PasswordFormat Property

EcoMembershipProvider.PasswordFormat Property
EcoMembershipProvider Class Eco.Web.AspProviders Namespace See Also
Collapse All
C#
public override MembershipPasswordFormat PasswordFormat;
Remarks

This is PasswordFormat, a member of class EcoMembershipProvider.

See Also
EcoMembershipProvider Class
Eco.Web.AspProviders Namespace


EcoMembershipProvider.PasswordStrengthRegularExpression Property

EcoMembershipProvider.PasswordStrengthRegularExpression Property
EcoMembershipProvider Class Eco.Web.AspProviders Namespace See Also
Collapse All
C#
public override string PasswordStrengthRegularExpression;
Remarks

This is PasswordStrengthRegularExpression, a member of class EcoMembershipProvider.

See Also
EcoMembershipProvider Class
Eco.Web.AspProviders Namespace


EcoMembershipProvider.RequiresQuestionAndAnswer Property

EcoMembershipProvider.RequiresQuestionAndAnswer Property
EcoMembershipProvider Class Eco.Web.AspProviders Namespace See Also
Collapse All
C#
public override bool RequiresQuestionAndAnswer;
Remarks

This is RequiresQuestionAndAnswer, a member of class EcoMembershipProvider.

See Also
EcoMembershipProvider Class
Eco.Web.AspProviders Namespace


EcoMembershipProvider.RequiresUniqueEmail Property

EcoMembershipProvider.RequiresUniqueEmail Property
EcoMembershipProvider Class Eco.Web.AspProviders Namespace See Also
Collapse All
C#
public override bool RequiresUniqueEmail;
Remarks

This is RequiresUniqueEmail, a member of class EcoMembershipProvider.

See Also
EcoMembershipProvider Class
Eco.Web.AspProviders Namespace


EcoPersonalizationProvider Class

EcoPersonalizationProvider Class
Inheritance Hierarchy See Also
Collapse All

This class implements the ASP Personalization provider API with an Eco backend

C#
public class EcoPersonalizationProvider : PersonalizationProvider;
Inheritance Hierarchy
Eco.Web.AspProviders.EcoPersonalizationProvider
File

EcoPersonalizationProvider.cs

See Also
Inheritance Hierarchy


EcoPersonalizationProvider Methods

EcoPersonalizationProvider Methods
Protected Methods Public Methods
Collapse All

The methods of the EcoPersonalizationProvider class are listed here.

Protected Methods
Name | Description
LoadPersonalizationBlobs | webPartManager The WebPartManager managing the personalization data. path The path for personalization information to be used as the retrieval key. userName The user name for personalization information to be used as the retrieval key. sharedDataBlob The returned data for the Shared scope. userDataBlob The returned data for the User scope. Classes that derive from PersonalizationProvider and implement this method should use the webPartManager, path, and username parameters as retrieval keys. Regardless of how the data is stored in the data store (some data stores might perform some type of intelligent storage), the personalization data must be returned as a packed... more
ResetPersonalizationBlob | When overridden in a derived class, deletes raw personalization data from the underlying data store. Classes that derive from PersonalizationProvider and implement this method should use the webPartManager, path, and userName parameters as storage keys. Derived implementations must modify the data store so that personalization data for supplied storage keys is effectively deleted. It is up to the derived implementations as to how they physically accomplish this. The derived personalization provider must be able to distinguish personalization data on a per-page basis. Furthermore, for a given page's state, the personalization provider must be able to distinguish between Shared and User... more
SavePersonalizationBlob | This method is the override definition of the method used for saving raw personalization data to the underlying data store. Derived implementations should use the webPartManager, path, and userName parameters as storage keys. The derived personalization provider must be able to distinguish personalization data on a per-page basis. Furthermore, for a given page's state, the provider must be able to distinguish between Shared and User scope. If a non-a null reference user name is provided, then the dataBlob parameter is in User scope; otherwise, the dataBlob parameter is assumed to be in Shared scope.
Top
Public Methods
Name | Description
DetermineInitialScope | This is DetermineInitialScope, a member of class EcoPersonalizationProvider.
DetermineUserCapabilities | This is DetermineUserCapabilities, a member of class EcoPersonalizationProvider.
FindState | When overridden in a derived class, returns a collection containing zero or more PersonalizationStateInfo-derived objects based on scope and specific query parameters. query.UsernameToMatch The set of returned items is constrained by the pageSize and pageIndex parameters, where pageSize controls the number of records to return and pageIndex controls which records to return. For example, a pageIndex of 0 and a pageSize of 25 would return the first 25 occurrences, while a pageIndex of 1 and a pageSize of 25 would return occurrences 26-50. If you want to fetch all available records, set pageIndex to 0, and pageSize to MaxValue. The... more
GetCountOfState | When overridden in a derived class, returns the number of rows in the underlying data store that exist within the specified scope.
Initialize | This is Initialize, a member of class EcoPersonalizationProvider.
ResetState | When overridden in a derived class, deletes personalization state from the underlying data store based on the specified parameters. scope A PersonalizationScope of the personalization information to be reset. This value cannot be a null reference . paths The paths for personalization information to be deleted. usernames The user names for personalization information to be deleted.
ResetUserState | When overridden in a derived class, deletes Web Parts personalization data from the underlying data store based on the specified parameters. This method is the override definition of an administrative method for deleting personalization data. Note that this method affects only user personalization data, and not shared data. Derived implementations should follow the logic described below: The path parameter cannot contain wildcard characters. If the provider exposes data from a transaction-aware data store, this method should perform its operations in a single atomic transaction. If the path parameter is non-a null reference , then only per-user personalization records associated with... more


EcoPersonalizationProvider.DetermineInitialScope Method

EcoPersonalizationProvider.DetermineInitialScope Method
EcoPersonalizationProvider Class Eco.Web.AspProviders Namespace See Also
Collapse All
C#
public override PersonalizationScope DetermineInitialScope(
    WebPartManager webPartManager,
    PersonalizationState loadedState
);
Remarks

This is DetermineInitialScope, a member of class EcoPersonalizationProvider.

See Also
EcoPersonalizationProvider Class
Eco.Web.AspProviders Namespace


EcoPersonalizationProvider.DetermineUserCapabilities Method

EcoPersonalizationProvider.DetermineUserCapabilities Method
EcoPersonalizationProvider Class Eco.Web.AspProviders Namespace See Also
Collapse All
C#
public override IDictionary DetermineUserCapabilities(
    WebPartManager webPartManager
);
Remarks

This is DetermineUserCapabilities, a member of class EcoPersonalizationProvider.

See Also
EcoPersonalizationProvider Class
Eco.Web.AspProviders Namespace


EcoPersonalizationProvider.FindState Method

EcoPersonalizationProvider.FindState Method
EcoPersonalizationProvider Class Eco.Web.AspProviders Namespace See Also
Collapse All
C#
public override PersonalizationStateInfoCollection FindState(
    PersonalizationScope scope,
    PersonalizationStateQuery query,
    int pageIndex,
    int pageSize,
    out int totalRecords
);
Remarks

When overridden in a derived class, returns a collection containing zero or more PersonalizationStateInfo-derived objects based on scope and specific query parameters. query.UsernameToMatch

The set of returned items is constrained by the pageSize and pageIndex parameters, where pageSize controls the number of records to return and pageIndex controls which records to return. For example, a pageIndex of 0 and a pageSize of 25 would return the first 25 occurrences, while a pageIndex of 1 and a pageSize of 25 would return occurrences 26-50. If you want to fetch all available records, set pageIndex to 0, and pageSize to MaxValue.

The PersonalizationStateInfo-derived objects are returned in alphabetical order sorted by Path and Username, both in ascending order.

This method passes query wildcard characters to the underlying data store. Support for wildcard characters is currently dependent on how each provider handles characters such as an asterisk (*), a percent symbol (%), or an underscore (_).

Normally, for SQL-compliant data stores, you can perform a wildcard search on a partial path with the wildcard character appearing at the beginning, the end, or the middle of the search string text in the PathToMatch property. For example, to find all paths that start with "~/approot", the PathToMatch property would be set to "~/approot%".

Likewise, a wildcard search on a partial user name could have the wildcard character appear at any point in the text string of the UsernameToMatch property. For example, to find all user names that start with "John", the UsernameToMatch parameter would look like "John%".

The following query constraints apply:

If only scope is provided, and query is a null reference (Nothing in Visual Basic) or all the properties on query return either a null reference or default values, then all records matching the indicated scope parameter are returned.

If the PathToMatch property is not a null reference (Nothing in Visual Basic), the returned records are also filtered based on paths that match the PathToMatch property value.

If the UsernameToMatch property is not a null reference (Nothing in Visual Basic), the returned records are also filtered based on user names that match the UsernameToMatch property value.

If the UserInactiveSinceDate property is not equal to MaxValue, then the returned records are also filtered to return only those records associated with inactive users. The comparison includes records where the LastActivityDate property is less than or equal to the UserInactiveSinceDate property.

Note that this method does not validate combinations of query parameters. For example, code can request a set of personalization state records associated with a specific user name in the shared scope. Because user names are not associated with shared information, the returned collection would be empty.

Parameter combinations that have the potential to return a non-empty collection include:

Shared scope in combination with PathToMatch.

User scope in combination with the values for any or all of the PathToMatch, UsernameToMatch, and UserInactiveSinceDate properties.

See Also
EcoPersonalizationProvider Class
Eco.Web.AspProviders Namespace


EcoPersonalizationProvider.GetCountOfState Method

EcoPersonalizationProvider.GetCountOfState Method
EcoPersonalizationProvider Class Eco.Web.AspProviders Namespace See Also
Collapse All
C#
public override int GetCountOfState(
    PersonalizationScope scope,
    PersonalizationStateQuery query
);
Remarks

When overridden in a derived class, returns the number of rows in the underlying data store that exist within the specified scope.

See Also
EcoPersonalizationProvider Class
Eco.Web.AspProviders Namespace


EcoPersonalizationProvider.Initialize Method

EcoPersonalizationProvider.Initialize Method
EcoPersonalizationProvider Class Eco.Web.AspProviders Namespace See Also
Collapse All
C#
public override void Initialize(
    string name,
    NameValueCollection config
);
Remarks

This is Initialize, a member of class EcoPersonalizationProvider.

See Also
EcoPersonalizationProvider Class
Eco.Web.AspProviders Namespace


EcoPersonalizationProvider.LoadPersonalizationBlobs Method

EcoPersonalizationProvider.LoadPersonalizationBlobs Method
EcoPersonalizationProvider Class Eco.Web.AspProviders Namespace See Also
Collapse All
C#
protected override void LoadPersonalizationBlobs(
    WebPartManager webPartManager,
    string path,
    string userName,
    ref byte[] sharedDataBlob,
    ref byte[] userDataBlob
);
Remarks

webPartManager The WebPartManager managing the personalization data.

path The path for personalization information to be used as the retrieval key.

userName The user name for personalization information to be used as the retrieval key.

sharedDataBlob The returned data for the Shared scope.

userDataBlob The returned data for the User scope.

Classes that derive from PersonalizationProvider and implement this method should use the webPartManager, path, and username parameters as retrieval keys. Regardless of how the data is stored in the data store (some data stores might perform some type of intelligent storage), the personalization data must be returned as a packed set of bytes in two arrays. The returned data must conform to the following rules:

The data for the Shared scope must always be returned in the sharedDataBlob parameter.

Depending on the key values, User data is returned in the userDataBlob parameter. A non-a null reference value for the userName parameter indicates that User data should also be retrieved.

A personalization provider that derives from PersonalizationProvider and implements this method can optimize interactions with its data store by retrieving all personalization data in one round trip, as opposed to retrieving Shared and User data in two separate round trips.

See Also
EcoPersonalizationProvider Class
Eco.Web.AspProviders Namespace


EcoPersonalizationProvider.ResetPersonalizationBlob Method

EcoPersonalizationProvider.ResetPersonalizationBlob Method
EcoPersonalizationProvider Class Eco.Web.AspProviders Namespace See Also
Collapse All
C#
protected override void ResetPersonalizationBlob(
    WebPartManager webPartManager,
    string path,
    string userName
);
Remarks

When overridden in a derived class, deletes raw personalization data from the underlying data store.

Classes that derive from PersonalizationProvider and implement this method should use the webPartManager, path, and userName parameters as storage keys. Derived implementations must modify the data store so that personalization data for supplied storage keys is effectively deleted. It is up to the derived implementations as to how they physically accomplish this.

The derived personalization provider must be able to distinguish personalization data on a per-page basis. Furthermore, for a given page's state, the personalization provider must be able to distinguish between Shared and User scope data. If a non-a null reference user name is provided, then the reset operation applies to the User scope; otherwise, the reset operation applies to the Shared scope.

See Also
EcoPersonalizationProvider Class
Eco.Web.AspProviders Namespace


EcoPersonalizationProvider.ResetState Method

EcoPersonalizationProvider.ResetState Method
EcoPersonalizationProvider Class Eco.Web.AspProviders Namespace See Also
Collapse All
C#
public override int ResetState(
    PersonalizationScope scope,
    string[] paths,
    string[] usernames
);
Returns

The number of rows deleted.

This method is the abstract definition of an administrative method for deleting personalization data. Derived implementations should follow the logic described below.

No wildcard character searches are supported by this method. If the personalization provider exposes data from a transaction-aware data store, this method should perform its operations as a single atomic transaction.

Only the following combinations of parameters are allowed:

The scope parameter is set, and all other parameters are set to a null reference . This combination deletes all Web Parts personalization data associated with the personalization scope indicated by scope.

The scope parameter is set, and the paths parameter contains at least one value. This combination deletes all Web Parts personalization data for the specified path or paths in the personalization scope indicated by scope.

The scope parameter is set to User, the paths parameter is set and contains only one value, and the usernames parameter contains at least one value. This combination deletes all user personalization Web Parts data for the given path that is associated with the user or users contained in usernames.

The scope parameter is set to User, the paths parameter is set to a null reference , and the usernames parameter contains at least one value. This combination deletes all per-user personalization Web Parts data, across all paths, associated with the user or users contained in usernames.

Any other combination of parameter values is invalid and will throw an ArgumentException exception. Specifically, the following two combinations are not allowed:

The usernames parameter cannot be provided when scope is set to Shared.

The paths parameter cannot contain more than one entry when the usernames parameter is not a null reference .

Any paths and usernames parameter values contained within the respective arrays must meet the following validation rules. If any validation rules fail for any member of the parameter arrays, an ArgumentException exception is thrown. The validation rules are:

a null reference values are not allowed.

An empty string ("") is not allowed. Parameters should be trimmed prior to performing an empty string check.

The usernames parameter cannot contain commas (,).

The length of the paths parameter cannot be greater than 256 characters for a SQL database.

The length of the usernames parameter cannot be greater than 256 characters for a SQL database.

Remarks

When overridden in a derived class, deletes personalization state from the underlying data store based on the specified parameters.

scope A PersonalizationScope of the personalization information to be reset. This value cannot be a null reference .

paths The paths for personalization information to be deleted.

usernames The user names for personalization information to be deleted.

See Also
EcoPersonalizationProvider Class
Eco.Web.AspProviders Namespace


EcoPersonalizationProvider.ResetUserState Method

EcoPersonalizationProvider.ResetUserState Method
EcoPersonalizationProvider Class Eco.Web.AspProviders Namespace See Also
Collapse All
C#
public override int ResetUserState(
    string path,
    DateTime userInactiveSinceDate
);
Remarks

When overridden in a derived class, deletes Web Parts personalization data from the underlying data store based on the specified parameters.

This method is the override definition of an administrative method for deleting personalization data. Note that this method affects only user personalization data, and not shared data.

Derived implementations should follow the logic described below:

The path parameter cannot contain wildcard characters.

If the provider exposes data from a transaction-aware data store, this method should perform its operations in a single atomic transaction.

If the path parameter is non-a null reference , then only per-user personalization records associated with path will be deleted.

Only per-user personalization records associated with users that are considered inactive since the date indicated in the userInactiveSinceDate parameter will be deleted. Specifically, records where LastActivityDate is less than or equal to UserInactiveSinceDate are deleted.

If both parameters are provided, then records that match both constraints are deleted.

The path parameter can be a null reference .

The path parameter cannot be an empty string. It should be trimmed prior to performing this check.

The UserInactiveSinceDate property cannot be a null reference

See Also
EcoPersonalizationProvider Class
Eco.Web.AspProviders Namespace


EcoPersonalizationProvider.SavePersonalizationBlob Method

EcoPersonalizationProvider.SavePersonalizationBlob Method
EcoPersonalizationProvider Class Eco.Web.AspProviders Namespace See Also
Collapse All
C#
protected override void SavePersonalizationBlob(
    WebPartManager webPartManager,
    string path,
    string userName,
    byte[] dataBlob
);
Remarks

This method is the override definition of the method used for saving raw personalization data to the underlying data store.

Derived implementations should use the webPartManager, path, and userName parameters as storage keys. The derived personalization provider must be able to distinguish personalization data on a per-page basis. Furthermore, for a given page's state, the provider must be able to distinguish between Shared and User scope. If a non-a null reference user name is provided, then the dataBlob parameter is in User scope; otherwise, the dataBlob parameter is assumed to be in Shared scope.

See Also
EcoPersonalizationProvider Class
Eco.Web.AspProviders Namespace


EcoPersonalizationProvider Properties

EcoPersonalizationProvider Properties
Public Properties Protected Properties
Collapse All

The properties of the EcoPersonalizationProvider class are listed here.

Public Properties
Name | Description
ApplicationName | This is ApplicationName, a member of class EcoPersonalizationProvider.
Top
Protected Properties
Name | Description
EcoSpace | This is EcoSpace, a member of class EcoPersonalizationProvider.


EcoPersonalizationProvider.ApplicationName Property

EcoPersonalizationProvider.ApplicationName Property
EcoPersonalizationProvider Class Eco.Web.AspProviders Namespace See Also
Collapse All
C#
public override string ApplicationName;
Remarks

This is ApplicationName, a member of class EcoPersonalizationProvider.

See Also
EcoPersonalizationProvider Class
Eco.Web.AspProviders Namespace


EcoPersonalizationProvider.EcoSpace Property

EcoPersonalizationProvider.EcoSpace Property
EcoPersonalizationProvider Class Eco.Web.AspProviders Namespace See Also
Collapse All
C#
protected EcoSpace EcoSpace;
Remarks

This is EcoSpace, a member of class EcoPersonalizationProvider.

See Also
EcoPersonalizationProvider Class
Eco.Web.AspProviders Namespace


EcoProfileProvider Class

EcoProfileProvider Class
Inheritance Hierarchy See Also
Collapse All
C#
public class EcoProfileProvider : ProfileProvider;
Remarks

This is class Eco.Web.AspProviders.EcoProfileProvider.

Inheritance Hierarchy
Eco.Web.AspProviders.EcoProfileProvider
File

EcoProfileProvider.cs

See Also
Inheritance Hierarchy


EcoProfileProvider Methods

EcoProfileProvider Methods
Public Methods
Collapse All

The methods of the EcoProfileProvider class are listed here.

Public Methods
Name | Description
DeleteInactiveProfiles | ProfileProvider.DeleteInactiveProfiles
DeleteProfiles | This is the overview for the DeleteProfiles method overload.
FindInactiveProfilesByUserName | ProfileProvider.FindInactiveProfilesByUserName
FindProfilesByUserName | ProfileProvider.FindProfilesByUserName
GetAllInactiveProfiles | ProfileProvider.GetAllInactiveProfiles
GetAllProfiles | ProfileProvider.GetAllProfiles
GetNumberOfInactiveProfiles | ProfileProvider.GetNumberOfInactiveProfiles
GetPropertyValues | SettingsProvider.GetPropertyValues
Initialize | System.Configuration.Provider.ProviderBase.Initialize Method
LogOrThrow | This is LogOrThrow, a member of class EcoProfileProvider.
SetPropertyValues | SettingsProvider.SetPropertyValues


EcoProfileProvider.DeleteInactiveProfiles Method

EcoProfileProvider.DeleteInactiveProfiles Method
EcoProfileProvider Class Eco.Web.AspProviders Namespace See Also
Collapse All
C#
public override int DeleteInactiveProfiles(
    ProfileAuthenticationOption authenticationOption,
    DateTime userInactiveSinceDate
);
Remarks

ProfileProvider.DeleteInactiveProfiles

See Also
EcoProfileProvider Class
Eco.Web.AspProviders Namespace


DeleteProfiles Method

DeleteProfiles Method

This is the overview for the DeleteProfiles method overload.

Overload List
Name | Description
EcoProfileProvider.DeleteProfiles (ProfileInfoCollection) | ProfileProvider.DeleteProfiles(ProfileInfoCollection)
EcoProfileProvider.DeleteProfiles (string[]) | ProfileProvider.DeleteProfiles(string[])


EcoProfileProvider.DeleteProfiles Method (ProfileInfoCollection)

EcoProfileProvider.DeleteProfiles Method (ProfileInfoCollection)
EcoProfileProvider Class Eco.Web.AspProviders Namespace See Also
Collapse All
C#
public override int DeleteProfiles(
    ProfileInfoCollection profiles
);
Remarks

ProfileProvider.DeleteProfiles(ProfileInfoCollection)

See Also
EcoProfileProvider Class
Eco.Web.AspProviders Namespace


EcoProfileProvider.DeleteProfiles Method (string[])

EcoProfileProvider.DeleteProfiles Method (string[])
EcoProfileProvider Class Eco.Web.AspProviders Namespace See Also
Collapse All
C#
public override int DeleteProfiles(
    string[] usernames
);
Remarks

ProfileProvider.DeleteProfiles(string[])

See Also
EcoProfileProvider Class
Eco.Web.AspProviders Namespace


EcoProfileProvider.FindInactiveProfilesByUserName Method

EcoProfileProvider.FindInactiveProfilesByUserName Method
EcoProfileProvider Class Eco.Web.AspProviders Namespace See Also
Collapse All
C#
public override ProfileInfoCollection FindInactiveProfilesByUserName(
    ProfileAuthenticationOption authenticationOption,
    string usernameToMatch,
    DateTime userInactiveSinceDate,
    int pageIndex,
    int pageSize,
    out int totalRecords
);
Remarks

ProfileProvider.FindInactiveProfilesByUserName

See Also
EcoProfileProvider Class
Eco.Web.AspProviders Namespace


EcoProfileProvider.FindProfilesByUserName Method

EcoProfileProvider.FindProfilesByUserName Method
EcoProfileProvider Class Eco.Web.AspProviders Namespace See Also
Collapse All
C#
public override ProfileInfoCollection FindProfilesByUserName(
    ProfileAuthenticationOption authenticationOption,
    string usernameToMatch,
    int pageIndex,
    int pageSize,
    out int totalRecords
);
Remarks

ProfileProvider.FindProfilesByUserName

See Also
EcoProfileProvider Class
Eco.Web.AspProviders Namespace


EcoProfileProvider.GetAllInactiveProfiles Method

EcoProfileProvider.GetAllInactiveProfiles Method
EcoProfileProvider Class Eco.Web.AspProviders Namespace See Also
Collapse All
C#
public override ProfileInfoCollection GetAllInactiveProfiles(
    ProfileAuthenticationOption authenticationOption,
    DateTime userInactiveSinceDate,
    int pageIndex,
    int pageSize,
    out int totalRecords
);
Remarks

ProfileProvider.GetAllInactiveProfiles

See Also
EcoProfileProvider Class
Eco.Web.AspProviders Namespace


EcoProfileProvider.GetAllProfiles Method

EcoProfileProvider.GetAllProfiles Method
EcoProfileProvider Class Eco.Web.AspProviders Namespace See Also
Collapse All
C#
public override ProfileInfoCollection GetAllProfiles(
    ProfileAuthenticationOption authenticationOption,
    int pageIndex,
    int pageSize,
    out int totalRecords
);
Remarks

ProfileProvider.GetAllProfiles

See Also
EcoProfileProvider Class
Eco.Web.AspProviders Namespace


EcoProfileProvider.GetNumberOfInactiveProfiles Method

EcoProfileProvider.GetNumberOfInactiveProfiles Method
EcoProfileProvider Class Eco.Web.AspProviders Namespace See Also
Collapse All
C#
public override int GetNumberOfInactiveProfiles(
    ProfileAuthenticationOption authenticationOption,
    DateTime userInactiveSinceDate
);
Remarks

ProfileProvider.GetNumberOfInactiveProfiles

See Also
EcoProfileProvider Class
Eco.Web.AspProviders Namespace


EcoProfileProvider.GetPropertyValues Method

EcoProfileProvider.GetPropertyValues Method
EcoProfileProvider Class Eco.Web.AspProviders Namespace See Also
Collapse All
C#
public override SettingsPropertyValueCollection GetPropertyValues(
    SettingsContext context,
    SettingsPropertyCollection ppc
);
Remarks

SettingsProvider.GetPropertyValues

See Also
EcoProfileProvider Class
Eco.Web.AspProviders Namespace


EcoProfileProvider.Initialize Method

EcoProfileProvider.Initialize Method
EcoProfileProvider Class Eco.Web.AspProviders Namespace See Also
Collapse All
C#
public override void Initialize(
    string name,
    NameValueCollection config
);
Remarks

System.Configuration.Provider.ProviderBase.Initialize Method

See Also
EcoProfileProvider Class
Eco.Web.AspProviders Namespace


EcoProfileProvider.LogOrThrow Method

EcoProfileProvider.LogOrThrow Method
EcoProfileProvider Class Eco.Web.AspProviders Namespace See Also
Collapse All
C#
public void LogOrThrow(
    Exception e,
    string operation
);
Remarks

This is LogOrThrow, a member of class EcoProfileProvider.

See Also
EcoProfileProvider Class
Eco.Web.AspProviders Namespace


EcoProfileProvider.SetPropertyValues Method

EcoProfileProvider.SetPropertyValues Method
EcoProfileProvider Class Eco.Web.AspProviders Namespace See Also
Collapse All
C#
public override void SetPropertyValues(
    SettingsContext context,
    SettingsPropertyValueCollection ppvc
);
Remarks

SettingsProvider.SetPropertyValues

See Also
EcoProfileProvider Class
Eco.Web.AspProviders Namespace


EcoProfileProvider Properties

EcoProfileProvider Properties
Public Properties Protected Properties
Collapse All

The properties of the EcoProfileProvider class are listed here.

Public Properties
Name | Description
ApplicationName | System.Configuration.SettingsProvider.ApplicationName
Top
Protected Properties
Name | Description
EcoSpace | This is EcoSpace, a member of class EcoProfileProvider.


EcoProfileProvider.ApplicationName Property

EcoProfileProvider.ApplicationName Property
EcoProfileProvider Class Eco.Web.AspProviders Namespace See Also
Collapse All
C#
public override string ApplicationName;
Remarks

System.Configuration.SettingsProvider.ApplicationName

See Also
EcoProfileProvider Class
Eco.Web.AspProviders Namespace


EcoProfileProvider.EcoSpace Property

EcoProfileProvider.EcoSpace Property
EcoProfileProvider Class Eco.Web.AspProviders Namespace See Also
Collapse All
C#
protected EcoSpace EcoSpace;
Remarks

This is EcoSpace, a member of class EcoProfileProvider.

See Also
EcoProfileProvider Class
Eco.Web.AspProviders Namespace


EcoProviderSupport Class

EcoProviderSupport Class
Inheritance Hierarchy See Also
Collapse All

Summary description for Class1.

C#
public class EcoProviderSupport;
Inheritance Hierarchy
Eco.Web.AspProviders.EcoProviderSupport
File

EcoProviderSupport.cs

See Also
Inheritance Hierarchy


EcoProviderSupport.EcoProviderSupport Constructor

EcoProviderSupport.EcoProviderSupport Constructor
EcoProviderSupport Class Eco.Web.AspProviders Namespace See Also
Collapse All
C#
public EcoProviderSupport(
    NameValueCollection config,
    string eventSource
);
Remarks

This is EcoProviderSupport, a member of class EcoProviderSupport.

See Also
EcoProviderSupport Class
Eco.Web.AspProviders Namespace


EcoProviderSupport Methods

EcoProviderSupport Methods
Public Methods
Collapse All

The methods of the EcoProviderSupport class are listed here.

Public Methods
Name | Description
DeleteAllInList | This is the overview for the DeleteAllInList method overload.
GetConfigValue | This is GetConfigValue, a member of class EcoProviderSupport.
GetProfile | This is GetProfile, a member of class EcoProviderSupport.
GetRole | This is GetRole, a member of class EcoProviderSupport.
GetRoleUser | This is GetRoleUser, a member of class EcoProviderSupport.
LogOrThrow | This is LogOrThrow, a member of class EcoProviderSupport.
OclPsQuery | This is the overview for the OclPsQuery method overload.
ReleaseEcoSpace | This is ReleaseEcoSpace, a member of class EcoProviderSupport.
UpdateAll | This is UpdateAll, a member of class EcoProviderSupport.
WriteToEventLog | WriteToEventLog A helper function that writes exception detail to the event log. Exceptions are written to the event log as a security measure to avoid private database details from being returned to the browser. If a method does not return a status or boolean indicating the action succeeded or failed, a generic exception is also thrown by the caller.


DeleteAllInList Method

DeleteAllInList Method

This is the overview for the DeleteAllInList method overload.

Overload List
Name | Description
EcoProviderSupport.DeleteAllInList (IObjectList) | This is DeleteAllInList, a member of class EcoProviderSupport.
EcoProviderSupport.DeleteAllInList (List<IObjectInstance>) | This is DeleteAllInList, a member of class EcoProviderSupport.


EcoProviderSupport.DeleteAllInList Method (IObjectList)

EcoProviderSupport.DeleteAllInList Method (IObjectList)
EcoProviderSupport Class Eco.Web.AspProviders Namespace See Also
Collapse All
C#
public int DeleteAllInList(
    IObjectList list
);
Remarks

This is DeleteAllInList, a member of class EcoProviderSupport.

See Also
EcoProviderSupport Class
Eco.Web.AspProviders Namespace


EcoProviderSupport.DeleteAllInList Method (List<IObjectInstance>)

EcoProviderSupport.DeleteAllInList Method (List<IObjectInstance>)
EcoProviderSupport Class Eco.Web.AspProviders Namespace See Also
Collapse All
C#
public int DeleteAllInList(
    List<IObjectInstance> list
);
Remarks

This is DeleteAllInList, a member of class EcoProviderSupport.

See Also
EcoProviderSupport Class
Eco.Web.AspProviders Namespace


EcoProviderSupport.GetConfigValue Method

EcoProviderSupport.GetConfigValue Method
EcoProviderSupport Class Eco.Web.AspProviders Namespace See Also
Collapse All
C#
public static string GetConfigValue(
    string configValue,
    string defaultValue
);
Remarks

This is GetConfigValue, a member of class EcoProviderSupport.

See Also
EcoProviderSupport Class
Eco.Web.AspProviders Namespace


EcoProviderSupport.GetProfile Method

EcoProviderSupport.GetProfile Method
EcoProviderSupport Class Eco.Web.AspProviders Namespace See Also
Collapse All
C#
public ASP_Profile GetProfile(
    string username
);
Remarks

This is GetProfile, a member of class EcoProviderSupport.

See Also
EcoProviderSupport Class
Eco.Web.AspProviders Namespace


EcoProviderSupport.GetRole Method

EcoProviderSupport.GetRole Method
EcoProviderSupport Class Eco.Web.AspProviders Namespace See Also
Collapse All
C#
public ASP_Role GetRole(
    string rolename
);
Remarks

This is GetRole, a member of class EcoProviderSupport.

See Also
EcoProviderSupport Class
Eco.Web.AspProviders Namespace


EcoProviderSupport.GetRoleUser Method

EcoProviderSupport.GetRoleUser Method
EcoProviderSupport Class Eco.Web.AspProviders Namespace See Also
Collapse All
C#
public ASP_RoleUser GetRoleUser(
    string username
);
Remarks

This is GetRoleUser, a member of class EcoProviderSupport.

See Also
EcoProviderSupport Class
Eco.Web.AspProviders Namespace


EcoProviderSupport.LogOrThrow Method

EcoProviderSupport.LogOrThrow Method
EcoProviderSupport Class Eco.Web.AspProviders Namespace See Also
Collapse All
C#
public void LogOrThrow(
    Exception e,
    string operation
);
Remarks

This is LogOrThrow, a member of class EcoProviderSupport.

See Also
EcoProviderSupport Class
Eco.Web.AspProviders Namespace


OclPsQuery Method

OclPsQuery Method

This is the overview for the OclPsQuery method overload.

Overload List
Name | Description
EcoProviderSupport.OclPsQuery (string, string, object) | This is OclPsQuery, a member of class EcoProviderSupport.
EcoProviderSupport.OclPsQuery (string, string, object, int, int) | This is OclPsQuery, a member of class EcoProviderSupport.
EcoProviderSupport.OclPsQuery (string, string, object, string, object) | This is OclPsQuery, a member of class EcoProviderSupport.
EcoProviderSupport.OclPsQuery (string, string, object, string, object, int, int) | This is OclPsQuery, a member of class EcoProviderSupport.


EcoProviderSupport.OclPsQuery Method (string, string, object)

EcoProviderSupport.OclPsQuery Method (string, string, object)
EcoProviderSupport Class Eco.Web.AspProviders Namespace See Also
Collapse All
C#
public IObjectList OclPsQuery(
    string expr,
    string vName,
    object vValue
);
Remarks

This is OclPsQuery, a member of class EcoProviderSupport.

See Also
EcoProviderSupport Class
Eco.Web.AspProviders Namespace


EcoProviderSupport.OclPsQuery Method (string, string, object, int, int)

EcoProviderSupport.OclPsQuery Method (string, string, object, int, int)
EcoProviderSupport Class Eco.Web.AspProviders Namespace See Also
Collapse All
C#
public IObjectList OclPsQuery(
    string expr,
    string vName,
    object vValue,
    int max,
    int offset
);
Remarks

This is OclPsQuery, a member of class EcoProviderSupport.

See Also
EcoProviderSupport Class
Eco.Web.AspProviders Namespace


EcoProviderSupport.OclPsQuery Method (string, string, object, string, object)

EcoProviderSupport.OclPsQuery Method (string, string, object, string, object)
EcoProviderSupport Class Eco.Web.AspProviders Namespace See Also
Collapse All
C#
public IObjectList OclPsQuery(
    string expr,
    string vName,
    object vValue,
    string vName2,
    object vValue2
);
Remarks

This is OclPsQuery, a member of class EcoProviderSupport.

See Also
EcoProviderSupport Class
Eco.Web.AspProviders Namespace


EcoProviderSupport.OclPsQuery Method (string, string, object, string, object, int, int)

EcoProviderSupport.OclPsQuery Method (string, string, object, string, object, int, int)
EcoProviderSupport Class Eco.Web.AspProviders Namespace See Also
Collapse All
C#
public IObjectList OclPsQuery(
    string expr,
    string vName,
    object vValue,
    string vName2,
    object vValue2,
    int max,
    int offset
);
Remarks

This is OclPsQuery, a member of class EcoProviderSupport.

See Also
EcoProviderSupport Class
Eco.Web.AspProviders Namespace


EcoProviderSupport.ReleaseEcoSpace Method

EcoProviderSupport.ReleaseEcoSpace Method
EcoProviderSupport Class Eco.Web.AspProviders Namespace See Also
Collapse All
C#
public void ReleaseEcoSpace();
Remarks

This is ReleaseEcoSpace, a member of class EcoProviderSupport.

See Also
EcoProviderSupport Class
Eco.Web.AspProviders Namespace


EcoProviderSupport.UpdateAll Method

EcoProviderSupport.UpdateAll Method
EcoProviderSupport Class Eco.Web.AspProviders Namespace See Also
Collapse All
C#
public void UpdateAll();
Remarks

This is UpdateAll, a member of class EcoProviderSupport.

See Also
EcoProviderSupport Class
Eco.Web.AspProviders Namespace


EcoProviderSupport.WriteToEventLog Method

EcoProviderSupport.WriteToEventLog Method
EcoProviderSupport Class Eco.Web.AspProviders Namespace See Also
Collapse All
C#
public void WriteToEventLog(
    Exception e,
    string action
);
Remarks

WriteToEventLog A helper function that writes exception detail to the event log. Exceptions are written to the event log as a security measure to avoid private database details from being returned to the browser. If a method does not return a status or boolean indicating the action succeeded or failed, a generic exception is also thrown by the caller.

See Also
EcoProviderSupport Class
Eco.Web.AspProviders Namespace


EcoProviderSupport Properties

EcoProviderSupport Properties
Public Properties
Collapse All

The properties of the EcoProviderSupport class are listed here.

Public Properties
Name | Description
ApplicationName | This is ApplicationName, a member of class EcoProviderSupport.
EcoSpace | This is EcoSpace, a member of class EcoProviderSupport.
RoleClass | This is RoleClass, a member of class EcoProviderSupport.
UserClass | This is UserClass, a member of class EcoProviderSupport.
WriteExceptionsToEventLog | This is WriteExceptionsToEventLog, a member of class EcoProviderSupport.


EcoProviderSupport.ApplicationName Property

EcoProviderSupport.ApplicationName Property
EcoProviderSupport Class Eco.Web.AspProviders Namespace See Also
Collapse All
C#
public string ApplicationName;
Remarks

This is ApplicationName, a member of class EcoProviderSupport.

See Also
EcoProviderSupport Class
Eco.Web.AspProviders Namespace


EcoProviderSupport.EcoSpace Property

EcoProviderSupport.EcoSpace Property
EcoProviderSupport Class Eco.Web.AspProviders Namespace See Also
Collapse All
C#
public EcoSpace EcoSpace;
Remarks

This is EcoSpace, a member of class EcoProviderSupport.

See Also
EcoProviderSupport Class
Eco.Web.AspProviders Namespace


EcoProviderSupport.RoleClass Property

EcoProviderSupport.RoleClass Property
EcoProviderSupport Class Eco.Web.AspProviders Namespace See Also
Collapse All
C#
public IClass RoleClass;
Remarks

This is RoleClass, a member of class EcoProviderSupport.

See Also
EcoProviderSupport Class
Eco.Web.AspProviders Namespace


EcoProviderSupport.UserClass Property

EcoProviderSupport.UserClass Property
EcoProviderSupport Class Eco.Web.AspProviders Namespace See Also
Collapse All
C#
public IClass UserClass;
Remarks

This is UserClass, a member of class EcoProviderSupport.

See Also
EcoProviderSupport Class
Eco.Web.AspProviders Namespace


EcoProviderSupport.WriteExceptionsToEventLog Property

EcoProviderSupport.WriteExceptionsToEventLog Property
EcoProviderSupport Class Eco.Web.AspProviders Namespace See Also
Collapse All
C#
public bool WriteExceptionsToEventLog;
Remarks

This is WriteExceptionsToEventLog, a member of class EcoProviderSupport.

See Also
EcoProviderSupport Class
Eco.Web.AspProviders Namespace


EcoRoleProvider Class

EcoRoleProvider Class
Inheritance Hierarchy See Also
Collapse All
C#
public class EcoRoleProvider : RoleProvider;
Remarks

This is class Eco.Web.AspProviders.EcoRoleProvider.

Inheritance Hierarchy
Eco.Web.AspProviders.EcoRoleProvider
File

EcoRoleProvider.cs

See Also
Inheritance Hierarchy


EcoRoleProvider Methods

EcoRoleProvider Methods
Protected Methods Public Methods
Collapse All

The methods of the EcoRoleProvider class are listed here.

Protected Methods
Name | Description
GetRole | This is GetRole, a member of class EcoRoleProvider.
GetRoleUser | This is GetRoleUser, a member of class EcoRoleProvider.
Top
Public Methods
Name | Description
AddUsersToRoles | RoleProvider.AddUsersToRoles
CreateRole | RoleProvider.CreateRole
DeleteRole | RoleProvider.DeleteRole
FindUsersInRole | RoleProvider.FindUsersInRole
GetAllRoles | RoleProvider.GetAllRoles
GetRolesForUser | RoleProvider.GetRolesForUser
GetUsersInRole | RoleProvider.GetUsersInRole
Initialize | System.Configuration.Provider.ProviderBase.Initialize Method
IsUserInRole | RoleProvider.IsUserInRole
LogOrThrow | This is LogOrThrow, a member of class EcoRoleProvider.
RemoveUsersFromRoles | RoleProvider.RemoveUsersFromRoles
RoleExists | RoleProvider.RoleExists


EcoRoleProvider.AddUsersToRoles Method

EcoRoleProvider.AddUsersToRoles Method
EcoRoleProvider Class Eco.Web.AspProviders Namespace See Also
Collapse All
C#
public override void AddUsersToRoles(
    string[] usernames,
    string[] rolenames
);
Remarks

RoleProvider.AddUsersToRoles

See Also
EcoRoleProvider Class
Eco.Web.AspProviders Namespace


EcoRoleProvider.CreateRole Method

EcoRoleProvider.CreateRole Method
EcoRoleProvider Class Eco.Web.AspProviders Namespace See Also
Collapse All
C#
public override void CreateRole(
    string rolename
);
Remarks

RoleProvider.CreateRole

See Also
EcoRoleProvider Class
Eco.Web.AspProviders Namespace


EcoRoleProvider.DeleteRole Method

EcoRoleProvider.DeleteRole Method
EcoRoleProvider Class Eco.Web.AspProviders Namespace See Also
Collapse All
C#
public override bool DeleteRole(
    string rolename,
    bool throwOnPopulatedRole
);
Remarks

RoleProvider.DeleteRole

See Also
EcoRoleProvider Class
Eco.Web.AspProviders Namespace


EcoRoleProvider.FindUsersInRole Method

EcoRoleProvider.FindUsersInRole Method
EcoRoleProvider Class Eco.Web.AspProviders Namespace See Also
Collapse All
C#
public override string[] FindUsersInRole(
    string rolename,
    string usernameToMatch
);
Remarks

RoleProvider.FindUsersInRole

See Also
EcoRoleProvider Class
Eco.Web.AspProviders Namespace


EcoRoleProvider.GetAllRoles Method

EcoRoleProvider.GetAllRoles Method
EcoRoleProvider Class Eco.Web.AspProviders Namespace See Also
Collapse All
C#
public override string[] GetAllRoles();
Remarks

RoleProvider.GetAllRoles

See Also
EcoRoleProvider Class
Eco.Web.AspProviders Namespace


EcoRoleProvider.GetRole Method

EcoRoleProvider.GetRole Method
EcoRoleProvider Class Eco.Web.AspProviders Namespace See Also
Collapse All
C#
protected ASP_Role GetRole(
    string rolename
);
Remarks

This is GetRole, a member of class EcoRoleProvider.

See Also
EcoRoleProvider Class
Eco.Web.AspProviders Namespace


EcoRoleProvider.GetRolesForUser Method

EcoRoleProvider.GetRolesForUser Method
EcoRoleProvider Class Eco.Web.AspProviders Namespace See Also
Collapse All
C#
public override string[] GetRolesForUser(
    string username
);
Remarks

RoleProvider.GetRolesForUser

See Also
EcoRoleProvider Class
Eco.Web.AspProviders Namespace


EcoRoleProvider.GetRoleUser Method

EcoRoleProvider.GetRoleUser Method
EcoRoleProvider Class Eco.Web.AspProviders Namespace See Also
Collapse All
C#
protected ASP_RoleUser GetRoleUser(
    string username
);
Remarks

This is GetRoleUser, a member of class EcoRoleProvider.

See Also
EcoRoleProvider Class
Eco.Web.AspProviders Namespace


EcoRoleProvider.GetUsersInRole Method

EcoRoleProvider.GetUsersInRole Method
EcoRoleProvider Class Eco.Web.AspProviders Namespace See Also
Collapse All
C#
public override string[] GetUsersInRole(
    string rolename
);
Remarks

RoleProvider.GetUsersInRole

See Also
EcoRoleProvider Class
Eco.Web.AspProviders Namespace


EcoRoleProvider.Initialize Method

EcoRoleProvider.Initialize Method
EcoRoleProvider Class Eco.Web.AspProviders Namespace See Also
Collapse All
C#
public override void Initialize(
    string name,
    NameValueCollection config
);
Remarks

System.Configuration.Provider.ProviderBase.Initialize Method

See Also
EcoRoleProvider Class
Eco.Web.AspProviders Namespace


EcoRoleProvider.IsUserInRole Method

EcoRoleProvider.IsUserInRole Method
EcoRoleProvider Class Eco.Web.AspProviders Namespace See Also
Collapse All
C#
public override bool IsUserInRole(
    string username,
    string rolename
);
Remarks

RoleProvider.IsUserInRole

See Also
EcoRoleProvider Class
Eco.Web.AspProviders Namespace


EcoRoleProvider.LogOrThrow Method

EcoRoleProvider.LogOrThrow Method
EcoRoleProvider Class Eco.Web.AspProviders Namespace See Also
Collapse All
C#
public void LogOrThrow(
    Exception e,
    string operation
);
Remarks

This is LogOrThrow, a member of class EcoRoleProvider.

See Also
EcoRoleProvider Class
Eco.Web.AspProviders Namespace


EcoRoleProvider.RemoveUsersFromRoles Method

EcoRoleProvider.RemoveUsersFromRoles Method
EcoRoleProvider Class Eco.Web.AspProviders Namespace See Also
Collapse All
C#
public override void RemoveUsersFromRoles(
    string[] usernames,
    string[] rolenames
);
Remarks

RoleProvider.RemoveUsersFromRoles

See Also
EcoRoleProvider Class
Eco.Web.AspProviders Namespace


EcoRoleProvider.RoleExists Method

EcoRoleProvider.RoleExists Method
EcoRoleProvider Class Eco.Web.AspProviders Namespace See Also
Collapse All
C#
public override bool RoleExists(
    string rolename
);
Remarks

RoleProvider.RoleExists

See Also
EcoRoleProvider Class
Eco.Web.AspProviders Namespace


EcoRoleProvider Properties

EcoRoleProvider Properties
Public Properties Protected Properties
Collapse All

The properties of the EcoRoleProvider class are listed here.

Public Properties
Name | Description
ApplicationName | This is ApplicationName, a member of class EcoRoleProvider.
Top
Protected Properties
Name | Description
EcoSpace | This is EcoSpace, a member of class EcoRoleProvider.


EcoRoleProvider.ApplicationName Property

EcoRoleProvider.ApplicationName Property
EcoRoleProvider Class Eco.Web.AspProviders Namespace See Also
Collapse All
C#
public override string ApplicationName;
Remarks

This is ApplicationName, a member of class EcoRoleProvider.

See Also
EcoRoleProvider Class
Eco.Web.AspProviders Namespace


EcoRoleProvider.EcoSpace Property

EcoRoleProvider.EcoSpace Property
EcoRoleProvider Class Eco.Web.AspProviders Namespace See Also
Collapse All
C#
protected EcoSpace EcoSpace;
Remarks

This is EcoSpace, a member of class EcoRoleProvider.

See Also
EcoRoleProvider Class
Eco.Web.AspProviders Namespace


EcoSessionStateStoreProvider Class

EcoSessionStateStoreProvider Class
Inheritance Hierarchy See Also
Collapse All
C#
public sealed class EcoSessionStateStoreProvider : SessionStateStoreProviderBase;
Remarks

This is class Eco.Web.AspProviders.EcoSessionStateStoreProvider.

Inheritance Hierarchy
Eco.Web.AspProviders.EcoSessionStateStoreProvider
File

EcoSessionStateStoreProvider.cs

See Also
Inheritance Hierarchy


EcoSessionStateStoreProvider Methods

EcoSessionStateStoreProvider Methods
Public Methods
Collapse All

The methods of the EcoSessionStateStoreProvider class are listed here.

Public Methods
Name | Description
CreateNewStoreData | SessionStateProviderBase.CreateNewStoreData
CreateUninitializedItem | SessionStateProviderBase.CreateUninitializedItem
Dispose | SessionStateStoreProviderBase members
EndRequest | SessionStateProviderBase.EndRequest
GetItem | SessionStateProviderBase.GetItem
GetItemExclusive | SessionStateProviderBase.GetItemExclusive
Initialize | This is Initialize, a member of class EcoSessionStateStoreProvider.
InitializeRequest | SessionStateProviderBase.InitializeRequest
ReleaseItemExclusive | SessionStateProviderBase.ReleaseItemExclusive
RemoveItem | SessionStateProviderBase.RemoveItem
ResetItemTimeout | SessionStateProviderBase.ResetItemTimeout
SetAndReleaseItemExclusive | SessionStateProviderBase.SetAndReleaseItemExclusive
SetItemExpireCallback | SessionStateProviderBase.SetItemExpireCallback


EcoSessionStateStoreProvider.CreateNewStoreData Method

EcoSessionStateStoreProvider.CreateNewStoreData Method
EcoSessionStateStoreProvider Class Eco.Web.AspProviders Namespace See Also
Collapse All
C#
public override SessionStateStoreData CreateNewStoreData(
    HttpContext context,
    int timeout
);
Remarks

SessionStateProviderBase.CreateNewStoreData

See Also
EcoSessionStateStoreProvider Class
Eco.Web.AspProviders Namespace


EcoSessionStateStoreProvider.CreateUninitializedItem Method

EcoSessionStateStoreProvider.CreateUninitializedItem Method
EcoSessionStateStoreProvider Class Eco.Web.AspProviders Namespace See Also
Collapse All
C#
public override void CreateUninitializedItem(
    HttpContext context,
    string id,
    int timeout
);
Remarks

SessionStateProviderBase.CreateUninitializedItem

See Also
EcoSessionStateStoreProvider Class
Eco.Web.AspProviders Namespace


EcoSessionStateStoreProvider.Dispose Method

EcoSessionStateStoreProvider.Dispose Method
EcoSessionStateStoreProvider Class Eco.Web.AspProviders Namespace See Also
Collapse All
C#
public override void Dispose();
Remarks

SessionStateStoreProviderBase members

See Also
EcoSessionStateStoreProvider Class
Eco.Web.AspProviders Namespace


EcoSessionStateStoreProvider.EndRequest Method

EcoSessionStateStoreProvider.EndRequest Method
EcoSessionStateStoreProvider Class Eco.Web.AspProviders Namespace See Also
Collapse All
C#
public override void EndRequest(
    HttpContext context
);
Remarks

SessionStateProviderBase.EndRequest

See Also
EcoSessionStateStoreProvider Class
Eco.Web.AspProviders Namespace


EcoSessionStateStoreProvider.GetItem Method

EcoSessionStateStoreProvider.GetItem Method
EcoSessionStateStoreProvider Class Eco.Web.AspProviders Namespace See Also
Collapse All
C#
public override SessionStateStoreData GetItem(
    HttpContext context,
    string id,
    out bool locked,
    out TimeSpan lockAge,
    out object lockId,
    out SessionStateActions actionFlags
);
Remarks

SessionStateProviderBase.GetItem

See Also
EcoSessionStateStoreProvider Class
Eco.Web.AspProviders Namespace


EcoSessionStateStoreProvider.GetItemExclusive Method

EcoSessionStateStoreProvider.GetItemExclusive Method
EcoSessionStateStoreProvider Class Eco.Web.AspProviders Namespace See Also
Collapse All
C#
public override SessionStateStoreData GetItemExclusive(
    HttpContext context,
    string id,
    out bool locked,
    out TimeSpan lockAge,
    out object lockId,
    out SessionStateActions actionFlags
);
Remarks

SessionStateProviderBase.GetItemExclusive

See Also
EcoSessionStateStoreProvider Class
Eco.Web.AspProviders Namespace


EcoSessionStateStoreProvider.Initialize Method

EcoSessionStateStoreProvider.Initialize Method
EcoSessionStateStoreProvider Class Eco.Web.AspProviders Namespace See Also
Collapse All
C#
public override void Initialize(
    string name,
    NameValueCollection config
);
Remarks

This is Initialize, a member of class EcoSessionStateStoreProvider.

See Also
EcoSessionStateStoreProvider Class
Eco.Web.AspProviders Namespace


EcoSessionStateStoreProvider.InitializeRequest Method

EcoSessionStateStoreProvider.InitializeRequest Method
EcoSessionStateStoreProvider Class Eco.Web.AspProviders Namespace See Also
Collapse All
C#
public override void InitializeRequest(
    HttpContext context
);
Remarks

SessionStateProviderBase.InitializeRequest

See Also
EcoSessionStateStoreProvider Class
Eco.Web.AspProviders Namespace


EcoSessionStateStoreProvider.ReleaseItemExclusive Method

EcoSessionStateStoreProvider.ReleaseItemExclusive Method
EcoSessionStateStoreProvider Class Eco.Web.AspProviders Namespace See Also
Collapse All
C#
public override void ReleaseItemExclusive(
    HttpContext context,
    string id,
    object lockId
);
Remarks

SessionStateProviderBase.ReleaseItemExclusive

See Also
EcoSessionStateStoreProvider Class
Eco.Web.AspProviders Namespace


EcoSessionStateStoreProvider.RemoveItem Method

EcoSessionStateStoreProvider.RemoveItem Method
EcoSessionStateStoreProvider Class Eco.Web.AspProviders Namespace See Also
Collapse All
C#
public override void RemoveItem(
    HttpContext context,
    string id,
    object lockId,
    SessionStateStoreData item
);
Remarks

SessionStateProviderBase.RemoveItem

See Also
EcoSessionStateStoreProvider Class
Eco.Web.AspProviders Namespace


EcoSessionStateStoreProvider.ResetItemTimeout Method

EcoSessionStateStoreProvider.ResetItemTimeout Method
EcoSessionStateStoreProvider Class Eco.Web.AspProviders Namespace See Also
Collapse All
C#
public override void ResetItemTimeout(
    HttpContext context,
    string id
);
Remarks

SessionStateProviderBase.ResetItemTimeout

See Also
EcoSessionStateStoreProvider Class
Eco.Web.AspProviders Namespace


EcoSessionStateStoreProvider.SetAndReleaseItemExclusive Method

EcoSessionStateStoreProvider.SetAndReleaseItemExclusive Method
EcoSessionStateStoreProvider Class Eco.Web.AspProviders Namespace See Also
Collapse All
C#
public override void SetAndReleaseItemExclusive(
    HttpContext context,
    string id,
    SessionStateStoreData item,
    object lockId,
    bool newItem
);
Remarks

SessionStateProviderBase.SetAndReleaseItemExclusive

See Also
EcoSessionStateStoreProvider Class
Eco.Web.AspProviders Namespace


EcoSessionStateStoreProvider.SetItemExpireCallback Method

EcoSessionStateStoreProvider.SetItemExpireCallback Method
EcoSessionStateStoreProvider Class Eco.Web.AspProviders Namespace See Also
Collapse All
C#
public override bool SetItemExpireCallback(
    SessionStateItemExpireCallback expireCallback
);
Remarks

SessionStateProviderBase.SetItemExpireCallback

See Also
EcoSessionStateStoreProvider Class
Eco.Web.AspProviders Namespace


EcoSessionStateStoreProvider Properties

EcoSessionStateStoreProvider Properties
Public Properties
Collapse All

The properties of the EcoSessionStateStoreProvider class are listed here.

Public Properties
Name | Description
ApplicationName | This is ApplicationName, a member of class EcoSessionStateStoreProvider.


EcoSessionStateStoreProvider.ApplicationName Property

EcoSessionStateStoreProvider.ApplicationName Property
EcoSessionStateStoreProvider Class Eco.Web.AspProviders Namespace See Also
Collapse All
C#
public string ApplicationName;
Remarks

This is ApplicationName, a member of class EcoSessionStateStoreProvider.

See Also
EcoSessionStateStoreProvider Class
Eco.Web.AspProviders Namespace


EcoWebEventProvider Class

EcoWebEventProvider Class
Inheritance Hierarchy See Also
Collapse All
C#
public class EcoWebEventProvider : BufferedWebEventProvider;
Remarks

Implements a custom event provider.

Inheritance Hierarchy
Eco.Web.AspProviders.EcoWebEventProvider
File

EcoBufferedEventProvider.cs

See Also
Inheritance Hierarchy


EcoWebEventProvider Methods

EcoWebEventProvider Methods
Public Methods
Collapse All

The methods of the EcoWebEventProvider class are listed here.

Public Methods
Name | Description
Initialize | Initializes the provider.
ProcessEvent | Processes the incoming events. This method performs custom processing and, if buffering is enabled, it calls the base.ProcessEvent to buffer the event information.
ProcessEventFlush | Processes the messages that have been buffered. It is called by the ASP.NET when the flushing of the buffer is required according to the parameters defined in the element of the configuration section.
Shutdown | Performs standard shutdown.


EcoWebEventProvider.Initialize Method

EcoWebEventProvider.Initialize Method
EcoWebEventProvider Class Eco.Web.AspProviders Namespace See Also
Collapse All
C#
public override void Initialize(
    string name,
    NameValueCollection config
);
Remarks

Initializes the provider.

See Also
EcoWebEventProvider Class
Eco.Web.AspProviders Namespace


EcoWebEventProvider.ProcessEvent Method

EcoWebEventProvider.ProcessEvent Method
EcoWebEventProvider Class Eco.Web.AspProviders Namespace See Also
Collapse All
C#
public override void ProcessEvent(
    WebBaseEvent eventRaised
);
Remarks

Processes the incoming events. This method performs custom processing and, if buffering is enabled, it calls the base.ProcessEvent to buffer the event information.

See Also
EcoWebEventProvider Class
Eco.Web.AspProviders Namespace


EcoWebEventProvider.ProcessEventFlush Method

EcoWebEventProvider.ProcessEventFlush Method
EcoWebEventProvider Class Eco.Web.AspProviders Namespace See Also
Collapse All
C#
public override void ProcessEventFlush(
    WebEventBufferFlushInfo flushInfo
);
Remarks

Processes the messages that have been buffered. It is called by the ASP.NET when the flushing of the buffer is required according to the parameters defined in the element of the configuration section.

See Also
EcoWebEventProvider Class
Eco.Web.AspProviders Namespace


EcoWebEventProvider.Shutdown Method

EcoWebEventProvider.Shutdown Method
EcoWebEventProvider Class Eco.Web.AspProviders Namespace See Also
Collapse All
C#
public override void Shutdown();
Remarks

Performs standard shutdown.

See Also
EcoWebEventProvider Class
Eco.Web.AspProviders Namespace


Eco.Web.DynamicData Namespace

Eco.Web.DynamicData Namespace
Classes
Collapse All

This is namespace Eco.Web.DynamicData.

Classes
Name | Description
EcoAttributeColumnProvider | This is class Eco.Web.DynamicData.EcoAttributeColumnProvider.
EcoDataModelProvider | This is class Eco.Web.DynamicData.EcoDataModelProvider.
EcoIdColumnProvider | This is class Eco.Web.DynamicData.EcoIdColumnProvider.
EcoTableProvider | This is class Eco.Web.DynamicData.EcoTableProvider.


EcoAttributeColumnProvider Class

EcoAttributeColumnProvider Class
Inheritance Hierarchy See Also
Collapse All
C#
public class EcoAttributeColumnProvider : ColumnProvider;
Remarks

This is class Eco.Web.DynamicData.EcoAttributeColumnProvider.

Inheritance Hierarchy
Eco.Web.DynamicData.EcoAttributeColumnProvider
File

EcoDataModelProvider.cs

See Also
Inheritance Hierarchy


EcoAttributeColumnProvider.EcoAttributeColumnProvider Constructor

EcoAttributeColumnProvider.EcoAttributeColumnProvider Constructor
EcoAttributeColumnProvider Class Eco.Web.DynamicData Namespace See Also
Collapse All
C#
public EcoAttributeColumnProvider(
    EcoTableProvider tableProvider,
    IAttribute attr
);
Remarks

This is EcoAttributeColumnProvider, a member of class EcoAttributeColumnProvider.

See Also
EcoAttributeColumnProvider Class
Eco.Web.DynamicData Namespace


EcoDataModelProvider Class

EcoDataModelProvider Class
Inheritance Hierarchy See Also
Collapse All
C#
public class EcoDataModelProvider : DataModelProvider;
Remarks

This is class Eco.Web.DynamicData.EcoDataModelProvider.

Inheritance Hierarchy
Eco.Web.DynamicData.EcoDataModelProvider
File

EcoDataModelProvider.cs

See Also
Inheritance Hierarchy


EcoDataModelProvider.EcoDataModelProvider Constructor

EcoDataModelProvider.EcoDataModelProvider Constructor
EcoDataModelProvider Class Eco.Web.DynamicData Namespace See Also
Collapse All
C#
public EcoDataModelProvider(
    Type ecoSpaceType,
    Type context
);
Remarks

This is EcoDataModelProvider, a member of class EcoDataModelProvider.

See Also
EcoDataModelProvider Class
Eco.Web.DynamicData Namespace


EcoDataModelProvider Methods

EcoDataModelProvider Methods
Public Methods
Collapse All

The methods of the EcoDataModelProvider class are listed here.

Public Methods
Name | Description
CreateContext | This is CreateContext, a member of class EcoDataModelProvider.
GetTypeSystemService |


EcoDataModelProvider.CreateContext Method

EcoDataModelProvider.CreateContext Method
EcoDataModelProvider Class Eco.Web.DynamicData Namespace See Also
Collapse All
C#
public override object CreateContext();
Remarks

This is CreateContext, a member of class EcoDataModelProvider.

See Also
EcoDataModelProvider Class
Eco.Web.DynamicData Namespace


EcoDataModelProvider.GetTypeSystemService Method

EcoDataModelProvider.GetTypeSystemService Method
EcoDataModelProvider Class Eco.Web.DynamicData Namespace See Also
Collapse All
C#
public ITypeSystemService GetTypeSystemService();
Exceptions
Exceptions | Description
InvalidOperationException | Thrown if required is true and EcoSpaceType not set. Thrown if the method GetTypeSystemService is not defined. Thrown if the return value from GetTypeSystemService is not an IEcoServiceProvider.
See Also
EcoDataModelProvider Class
Eco.Web.DynamicData Namespace


EcoDataModelProvider Properties

EcoDataModelProvider Properties
Public Properties
Collapse All

The properties of the EcoDataModelProvider class are listed here.

Public Properties
Name | Description
Tables | This is Tables, a member of class EcoDataModelProvider.


EcoDataModelProvider.Tables Property

EcoDataModelProvider.Tables Property
EcoDataModelProvider Class Eco.Web.DynamicData Namespace See Also
Collapse All
C#
public override ReadOnlyCollection<TableProvider> Tables;
Remarks

This is Tables, a member of class EcoDataModelProvider.

See Also
EcoDataModelProvider Class
Eco.Web.DynamicData Namespace


EcoIdColumnProvider Class

EcoIdColumnProvider Class
Inheritance Hierarchy See Also
Collapse All
C#
public class EcoIdColumnProvider : ColumnProvider;
Remarks

This is class Eco.Web.DynamicData.EcoIdColumnProvider.

Inheritance Hierarchy
Eco.Web.DynamicData.EcoIdColumnProvider
File

EcoDataModelProvider.cs

See Also
Inheritance Hierarchy


EcoIdColumnProvider.EcoIdColumnProvider Constructor

EcoIdColumnProvider.EcoIdColumnProvider Constructor
EcoIdColumnProvider Class Eco.Web.DynamicData Namespace See Also
Collapse All
C#
public EcoIdColumnProvider(
    EcoTableProvider tableProvider
);
Remarks

This is EcoIdColumnProvider, a member of class EcoIdColumnProvider.

See Also
EcoIdColumnProvider Class
Eco.Web.DynamicData Namespace


EcoTableProvider Class

EcoTableProvider Class
Inheritance Hierarchy See Also
Collapse All
C#
public class EcoTableProvider : TableProvider;
Remarks

This is class Eco.Web.DynamicData.EcoTableProvider.

Inheritance Hierarchy
Eco.Web.DynamicData.EcoTableProvider
File

EcoDataModelProvider.cs

See Also
Inheritance Hierarchy


EcoTableProvider.EcoTableProvider Constructor

EcoTableProvider.EcoTableProvider Constructor
EcoTableProvider Class Eco.Web.DynamicData Namespace See Also
Collapse All
C#
public EcoTableProvider(
    EcoDataModelProvider modelProvider,
    IClass c
);
Remarks

This is EcoTableProvider, a member of class EcoTableProvider.

See Also
EcoTableProvider Class
Eco.Web.DynamicData Namespace


EcoTableProvider Methods

EcoTableProvider Methods
Public Methods
Collapse All

The methods of the EcoTableProvider class are listed here.

Public Methods
Name | Description
GetQuery | This is GetQuery, a member of class EcoTableProvider.


EcoTableProvider.GetQuery Method

EcoTableProvider.GetQuery Method
EcoTableProvider Class Eco.Web.DynamicData Namespace See Also
Collapse All
C#
public override IQueryable GetQuery(
    object context
);
Remarks

This is GetQuery, a member of class EcoTableProvider.

See Also
EcoTableProvider Class
Eco.Web.DynamicData Namespace


EcoTableProvider Properties

EcoTableProvider Properties
Public Properties
Collapse All

The properties of the EcoTableProvider class are listed here.

Public Properties
Name | Description
Columns | This is Columns, a member of class EcoTableProvider.


EcoTableProvider.Columns Property

EcoTableProvider.Columns Property
EcoTableProvider Class Eco.Web.DynamicData Namespace See Also
Collapse All
C#
public override System.Collections.ObjectModel.ReadOnlyCollection<ColumnProvider> Columns;
Remarks

This is Columns, a member of class EcoTableProvider.

See Also
EcoTableProvider Class
Eco.Web.DynamicData Namespace


Eco.Web.Providers Namespace

Eco.Web.Providers Namespace
Classes
Collapse All

This is namespace Eco.Web.Providers.

Classes
Name | Description
ProvidersStringRes | Autogenerated class to get compiler safe access to resource strings.


ProvidersStringRes Class

ProvidersStringRes Class
Inheritance Hierarchy See Also
Collapse All

Autogenerated class to get compiler safe access to resource strings.

C#
public sealed class ProvidersStringRes : StringResources;
Inheritance Hierarchy
Eco.Web.Providers.ProvidersStringRes
File

Eco.Web.Providers.Strings.cs

See Also
Inheritance Hierarchy


ProvidersStringRes Methods

ProvidersStringRes Methods
Public Methods
Collapse All

The methods of the ProvidersStringRes class are listed here.

Public Methods
Name | Description
InvalidEcoSpaceTypeName | Returns: "Invalid EcoSpace type name: {0}"


ProvidersStringRes.InvalidEcoSpaceTypeName Method

ProvidersStringRes.InvalidEcoSpaceTypeName Method
ProvidersStringRes Class Eco.Web.Providers Namespace See Also
Collapse All

Returns: "Invalid EcoSpace type name: {0}"

C#
public static string InvalidEcoSpaceTypeName(
    object param0
);
Remarks

For internal use.

See Also
ProvidersStringRes Class
Eco.Web.Providers Namespace


ProvidersStringRes Properties

ProvidersStringRes Properties
Public Properties
Collapse All

The properties of the ProvidersStringRes class are listed here.

Public Properties
Name | Description
AmbiguousUserName | Returns: "Ambiguous username"
CannotDeletePopulatedRole | Returns: "Cannot delete a populated role."
CannotRetrieveHashedPasswords | Returns: "Cannot retrieve Hashed passwords."
CannotUnencodeHashedPassword | Returns: "Cannot unencode a hashed password."
IncorrectPasswordAnswer | Returns: "Incorrect password answer."
NewPasswordValidationFailure | Returns: "Change password canceled due to new password validation failure."
NoEcoSpaceTypeName | Returns: "No EcoSpace type name defined"
PageIndexMustBeZeroOrMore | Returns: "Page index must 0 or greater."
PageSizeMustBeGreaterThanZero | Returns: "Page size must be greater than 0."
PasswordAnswerRequiredForReset | Returns: "Password answer required for password reset."
PasswordFormatNotSupported | Returns: "Password format not supported."
PasswordResetNotEnabled | Returns: "Password reset is not enabled."
PasswordRetrievalNotEnabled | Returns: "Password Retrieval Not Enabled."
PasswordValidationFailure | Returns: "Reset password canceled due to password validation failure."
RoleDoesNotExist | Returns: "Role does not exist."
RoleNameExists | Returns: "Role name already exists."
RoleNameNotFound | Returns: "Role name not found."
UserAlreadyInARole | Returns: "User is already in role."
UserLockedOut | Returns: "The supplied user is locked out."
UserNameCannotBeNull | Returns: "User name cannot be null."
UserNamesCannotContainComma | Returns: "User names cannot contain commas."
UserNameTooLong | Returns: "User name exceeds 255 characters."
UserNotFound | Returns: "The supplied user name is not found."
UserNotInARole | Returns: "User is not in role."


ProvidersStringRes.AmbiguousUserName Property

ProvidersStringRes.AmbiguousUserName Property
ProvidersStringRes Class Eco.Web.Providers Namespace See Also
Collapse All

Returns: "Ambiguous username"

C#
public static string AmbiguousUserName;
Remarks

For internal use.

See Also
ProvidersStringRes Class
Eco.Web.Providers Namespace


ProvidersStringRes.CannotDeletePopulatedRole Property

ProvidersStringRes.CannotDeletePopulatedRole Property
ProvidersStringRes Class Eco.Web.Providers Namespace See Also
Collapse All

Returns: "Cannot delete a populated role."

C#
public static string CannotDeletePopulatedRole;
Remarks

For internal use.

See Also
ProvidersStringRes Class
Eco.Web.Providers Namespace


ProvidersStringRes.CannotRetrieveHashedPasswords Property

ProvidersStringRes.CannotRetrieveHashedPasswords Property
ProvidersStringRes Class Eco.Web.Providers Namespace See Also
Collapse All

Returns: "Cannot retrieve Hashed passwords."

C#
public static string CannotRetrieveHashedPasswords;
Remarks

For internal use.

See Also
ProvidersStringRes Class
Eco.Web.Providers Namespace


ProvidersStringRes.CannotUnencodeHashedPassword Property

ProvidersStringRes.CannotUnencodeHashedPassword Property
ProvidersStringRes Class Eco.Web.Providers Namespace See Also
Collapse All

Returns: "Cannot unencode a hashed password."

C#
public static string CannotUnencodeHashedPassword;
Remarks

For internal use.

See Also
ProvidersStringRes Class
Eco.Web.Providers Namespace


ProvidersStringRes.IncorrectPasswordAnswer Property

ProvidersStringRes.IncorrectPasswordAnswer Property
ProvidersStringRes Class Eco.Web.Providers Namespace See Also
Collapse All

Returns: "Incorrect password answer."

C#
public static string IncorrectPasswordAnswer;
Remarks

For internal use.

See Also
ProvidersStringRes Class
Eco.Web.Providers Namespace


ProvidersStringRes.NewPasswordValidationFailure Property

ProvidersStringRes.NewPasswordValidationFailure Property
ProvidersStringRes Class Eco.Web.Providers Namespace See Also
Collapse All

Returns: "Change password canceled due to new password validation failure."

C#
public static string NewPasswordValidationFailure;
Remarks

For internal use.

See Also
ProvidersStringRes Class
Eco.Web.Providers Namespace


ProvidersStringRes.NoEcoSpaceTypeName Property

ProvidersStringRes.NoEcoSpaceTypeName Property
ProvidersStringRes Class Eco.Web.Providers Namespace See Also
Collapse All

Returns: "No EcoSpace type name defined"

C#
public static string NoEcoSpaceTypeName;
Remarks

For internal use.

See Also
ProvidersStringRes Class
Eco.Web.Providers Namespace


ProvidersStringRes.PageIndexMustBeZeroOrMore Property

ProvidersStringRes.PageIndexMustBeZeroOrMore Property
ProvidersStringRes Class Eco.Web.Providers Namespace See Also
Collapse All

Returns: "Page index must 0 or greater."

C#
public static string PageIndexMustBeZeroOrMore;
Remarks

For internal use.

See Also
ProvidersStringRes Class
Eco.Web.Providers Namespace


ProvidersStringRes.PageSizeMustBeGreaterThanZero Property

ProvidersStringRes.PageSizeMustBeGreaterThanZero Property
ProvidersStringRes Class Eco.Web.Providers Namespace See Also
Collapse All

Returns: "Page size must be greater than 0."

C#
public static string PageSizeMustBeGreaterThanZero;
Remarks

For internal use.

See Also
ProvidersStringRes Class
Eco.Web.Providers Namespace


ProvidersStringRes.PasswordAnswerRequiredForReset Property

ProvidersStringRes.PasswordAnswerRequiredForReset Property
ProvidersStringRes Class Eco.Web.Providers Namespace See Also
Collapse All

Returns: "Password answer required for password reset."

C#
public static string PasswordAnswerRequiredForReset;
Remarks

For internal use.

See Also
ProvidersStringRes Class
Eco.Web.Providers Namespace


ProvidersStringRes.PasswordFormatNotSupported Property

ProvidersStringRes.PasswordFormatNotSupported Property
ProvidersStringRes Class Eco.Web.Providers Namespace See Also
Collapse All

Returns: "Password format not supported."

C#
public static string PasswordFormatNotSupported;
Remarks

For internal use.

See Also
ProvidersStringRes Class
Eco.Web.Providers Namespace


ProvidersStringRes.PasswordResetNotEnabled Property

ProvidersStringRes.PasswordResetNotEnabled Property
ProvidersStringRes Class Eco.Web.Providers Namespace See Also
Collapse All

Returns: "Password reset is not enabled."

C#
public static string PasswordResetNotEnabled;
Remarks

For internal use.

See Also
ProvidersStringRes Class
Eco.Web.Providers Namespace


ProvidersStringRes.PasswordRetrievalNotEnabled Property

ProvidersStringRes.PasswordRetrievalNotEnabled Property
ProvidersStringRes Class Eco.Web.Providers Namespace See Also
Collapse All

Returns: "Password Retrieval Not Enabled."

C#
public static string PasswordRetrievalNotEnabled;
Remarks

For internal use.

See Also
ProvidersStringRes Class
Eco.Web.Providers Namespace


ProvidersStringRes.PasswordValidationFailure Property

ProvidersStringRes.PasswordValidationFailure Property
ProvidersStringRes Class Eco.Web.Providers Namespace See Also
Collapse All

Returns: "Reset password canceled due to password validation failure."

C#
public static string PasswordValidationFailure;
Remarks

For internal use.

See Also
ProvidersStringRes Class
Eco.Web.Providers Namespace


ProvidersStringRes.RoleDoesNotExist Property

ProvidersStringRes.RoleDoesNotExist Property
ProvidersStringRes Class Eco.Web.Providers Namespace See Also
Collapse All

Returns: "Role does not exist."

C#
public static string RoleDoesNotExist;
Remarks

For internal use.

See Also
ProvidersStringRes Class
Eco.Web.Providers Namespace


ProvidersStringRes.RoleNameExists Property

ProvidersStringRes.RoleNameExists Property
ProvidersStringRes Class Eco.Web.Providers Namespace See Also
Collapse All

Returns: "Role name already exists."

C#
public static string RoleNameExists;
Remarks

For internal use.

See Also
ProvidersStringRes Class
Eco.Web.Providers Namespace


ProvidersStringRes.RoleNameNotFound Property

ProvidersStringRes.RoleNameNotFound Property
ProvidersStringRes Class Eco.Web.Providers Namespace See Also
Collapse All

Returns: "Role name not found."

C#
public static string RoleNameNotFound;
Remarks

For internal use.

See Also
ProvidersStringRes Class
Eco.Web.Providers Namespace


ProvidersStringRes.UserAlreadyInARole Property

ProvidersStringRes.UserAlreadyInARole Property
ProvidersStringRes Class Eco.Web.Providers Namespace See Also
Collapse All

Returns: "User is already in role."

C#
public static string UserAlreadyInARole;
Remarks

For internal use.

See Also
ProvidersStringRes Class
Eco.Web.Providers Namespace


ProvidersStringRes.UserLockedOut Property

ProvidersStringRes.UserLockedOut Property
ProvidersStringRes Class Eco.Web.Providers Namespace See Also
Collapse All

Returns: "The supplied user is locked out."

C#
public static string UserLockedOut;
Remarks

For internal use.

See Also
ProvidersStringRes Class
Eco.Web.Providers Namespace


ProvidersStringRes.UserNameCannotBeNull Property

ProvidersStringRes.UserNameCannotBeNull Property
ProvidersStringRes Class Eco.Web.Providers Namespace See Also
Collapse All

Returns: "User name cannot be null."

C#
public static string UserNameCannotBeNull;
Remarks

For internal use.

See Also
ProvidersStringRes Class
Eco.Web.Providers Namespace


ProvidersStringRes.UserNamesCannotContainComma Property

ProvidersStringRes.UserNamesCannotContainComma Property
ProvidersStringRes Class Eco.Web.Providers Namespace See Also
Collapse All

Returns: "User names cannot contain commas."

C#
public static string UserNamesCannotContainComma;
Remarks

For internal use.

See Also
ProvidersStringRes Class
Eco.Web.Providers Namespace


ProvidersStringRes.UserNameTooLong Property

ProvidersStringRes.UserNameTooLong Property
ProvidersStringRes Class Eco.Web.Providers Namespace See Also
Collapse All

Returns: "User name exceeds 255 characters."

C#
public static string UserNameTooLong;
Remarks

For internal use.

See Also
ProvidersStringRes Class
Eco.Web.Providers Namespace


ProvidersStringRes.UserNotFound Property

ProvidersStringRes.UserNotFound Property
ProvidersStringRes Class Eco.Web.Providers Namespace See Also
Collapse All

Returns: "The supplied user name is not found."

C#
public static string UserNotFound;
Remarks

For internal use.

See Also
ProvidersStringRes Class
Eco.Web.Providers Namespace


ProvidersStringRes.UserNotInARole Property

ProvidersStringRes.UserNotInARole Property
ProvidersStringRes Class Eco.Web.Providers Namespace See Also
Collapse All

Returns: "User is not in role."

C#
public static string UserNotInARole;
Remarks

For internal use.

See Also
ProvidersStringRes Class
Eco.Web.Providers Namespace


Eco.Web.UI.WebControls Namespace

Eco.Web.UI.WebControls Namespace
Classes Enumerations Types
Collapse All

This is namespace Eco.Web.UI.WebControls.

Classes
Name | Description
AbstractColumn | This is class Eco.Web.UI.WebControls.AbstractColumn.
EcoDataSource | A DataSource that gets its values by from an EcoSpace using OCL expressions.
EcoDataSourceColumnCollection | This is class Eco.Web.UI.WebControls.EcoDataSourceColumnCollection.
EcoDataSourceObjectEventArgs | This is class Eco.Web.UI.WebControls.EcoDataSourceObjectEventArgs.
EcoDataSourceSelectingEventArgs | This is class Eco.Web.UI.WebControls.EcoDataSourceSelectingEventArgs.
EcoDataSourceStatusEventArgs | This is class Eco.Web.UI.WebControls.EcoDataSourceStatusEventArgs.
EcoDataSourceView |
EcoSpaceManager | Provides and EcoSpace instance of the specified type for use on a web page.
EcoSpaceManagerBuilder | Supports the page parser in building the EcoSpaceManager control.
EcoSpaceManagerIDConverter | Type converter that retrieves a list of EcoSpaceManager IDs in the current container as the value of TypeConverter.StandardValuesCollection.
EventDerivedColumn | This is class Eco.Web.UI.WebControls.EventDerivedColumn.
OclColumn | This is class Eco.Web.UI.WebControls.OclColumn.
OclParameter | This is class Eco.Web.UI.WebControls.OclParameter.
RowValidationFailedException | This is class Eco.Web.UI.WebControls.RowValidationFailedException.
Top
Enumerations
Name | Description
DeleteMode | Specifies the action to perform when an object is deleted.
InsertMode | Action to perform when Insert is called on a EcoDataSource
Top
Types
Name | Description
EcoDataSourceInsertingEventHandler | This is type Eco.Web.UI.WebControls.EcoDataSourceInsertingEventHandler.
EcoDataSourceObjectEventHandler | This is type Eco.Web.UI.WebControls.EcoDataSourceObjectEventHandler.
EcoDataSourceSelectingEventHandler | This is type Eco.Web.UI.WebControls.EcoDataSourceSelectingEventHandler.
EcoDataSourceStatusEventHandler | This is type Eco.Web.UI.WebControls.EcoDataSourceStatusEventHandler.
GetEcoSpaceDelegate | This is type Eco.Web.UI.WebControls.GetEcoSpaceDelegate.


AbstractColumn Class

AbstractColumn Class
Inheritance Hierarchy See Also
Collapse All
C#
public abstract class AbstractColumn : IStateManager, IColumn;
Remarks

This is class Eco.Web.UI.WebControls.AbstractColumn.

Inheritance Hierarchy
Eco.Web.UI.WebControls.AbstractColumn
    Eco.Web.UI.WebControls.EventDerivedColumn
    Eco.Web.UI.WebControls.OclColumn
File

EcoDataSourceColumns.cs

See Also
Inheritance Hierarchy


AbstractColumn.AbstractColumn Constructor

AbstractColumn.AbstractColumn Constructor
AbstractColumn Class Eco.Web.UI.WebControls Namespace See Also
Collapse All
C#
protected AbstractColumn();
Remarks

Methods

See Also
AbstractColumn Class
Eco.Web.UI.WebControls Namespace


AbstractColumn Methods

AbstractColumn Methods
Protected Methods Public Methods Protected internal Methods
Collapse All

The methods of the AbstractColumn class are listed here.

Protected Methods
Name | Description
CopyProperties | This is CopyProperties, a member of class AbstractColumn.
CreateColumn | This is CreateColumn, a member of class AbstractColumn.
LoadViewState | This is LoadViewState, a member of class AbstractColumn.
OnColumnChanged | This is OnColumnChanged, a member of class AbstractColumn.
SaveViewState | This is SaveViewState, a member of class AbstractColumn.
TrackViewState | This is TrackViewState, a member of class AbstractColumn.
Top
Public Methods
Name | Description
ToString | This is ToString, a member of class AbstractColumn.
Top
Protected internal Methods
Name | Description
CloneColumn | This is CloneColumn, a member of class AbstractColumn.


AbstractColumn.CloneColumn Method

AbstractColumn.CloneColumn Method
AbstractColumn Class Eco.Web.UI.WebControls Namespace See Also
Collapse All
C#
protected internal AbstractColumn CloneColumn();
Remarks

This is CloneColumn, a member of class AbstractColumn.

See Also
AbstractColumn Class
Eco.Web.UI.WebControls Namespace


AbstractColumn.CopyProperties Method

AbstractColumn.CopyProperties Method
AbstractColumn Class Eco.Web.UI.WebControls Namespace See Also
Collapse All
C#
protected virtual void CopyProperties(
    AbstractColumn newColumn
);
Remarks

This is CopyProperties, a member of class AbstractColumn.

See Also
AbstractColumn Class
Eco.Web.UI.WebControls Namespace


AbstractColumn.CreateColumn Method

AbstractColumn.CreateColumn Method
AbstractColumn Class Eco.Web.UI.WebControls Namespace See Also
Collapse All
C#
protected abstract AbstractColumn CreateColumn();
Remarks

This is CreateColumn, a member of class AbstractColumn.

See Also
AbstractColumn Class
Eco.Web.UI.WebControls Namespace


AbstractColumn.LoadViewState Method

AbstractColumn.LoadViewState Method
AbstractColumn Class Eco.Web.UI.WebControls Namespace See Also
Collapse All
C#
protected virtual void LoadViewState(
    object savedState
);
Remarks

This is LoadViewState, a member of class AbstractColumn.

See Also
AbstractColumn Class
Eco.Web.UI.WebControls Namespace


AbstractColumn.OnColumnChanged Method

AbstractColumn.OnColumnChanged Method
AbstractColumn Class Eco.Web.UI.WebControls Namespace See Also
Collapse All
C#
protected virtual void OnColumnChanged();
Remarks

This is OnColumnChanged, a member of class AbstractColumn.

See Also
AbstractColumn Class
Eco.Web.UI.WebControls Namespace


AbstractColumn.SaveViewState Method

AbstractColumn.SaveViewState Method
AbstractColumn Class Eco.Web.UI.WebControls Namespace See Also
Collapse All
C#
protected virtual object SaveViewState();
Remarks

This is SaveViewState, a member of class AbstractColumn.

See Also
AbstractColumn Class
Eco.Web.UI.WebControls Namespace


AbstractColumn.ToString Method

AbstractColumn.ToString Method
AbstractColumn Class Eco.Web.UI.WebControls Namespace See Also
Collapse All
C#
public override string ToString();
Remarks

This is ToString, a member of class AbstractColumn.

See Also
AbstractColumn Class
Eco.Web.UI.WebControls Namespace


AbstractColumn.TrackViewState Method

AbstractColumn.TrackViewState Method
AbstractColumn Class Eco.Web.UI.WebControls Namespace See Also
Collapse All
C#
protected virtual void TrackViewState();
Remarks

This is TrackViewState, a member of class AbstractColumn.

See Also
AbstractColumn Class
Eco.Web.UI.WebControls Namespace


AbstractColumn Properties

AbstractColumn Properties
Public Properties Protected Properties
Collapse All

The properties of the AbstractColumn class are listed here.

Public Properties
Name | Description
AsExternalId | Set this value to true to indicate that the property shall be represented by its ExternalId. Setting this value to true for a property that represents an ECO object will render the property as a string returned by IExternalIdService. And on setting it will accept a string which is produced by that service. This is mainly for use in ASP.Net databinding, where only value types survive.
EventDerivedValue | This is EventDerivedValue, a member of class AbstractColumn.
Expression | OCL expression used to compute the value of the column unless EventDerivedValue is true.
IsReadOnly | Set this value to true to indicate that the property shall be read only. If this value is false for an OclColumn, the readablility will be decided by the Ocl expression If this value is false for an EventDerviedColumn, setting is handled by ElementHandle.ReverseDeriveValue
Name | This is the name given to the property added to the binding list. This name is used when binding to a data aware control.
Nested | Set this property to true to make the property in the binding list a list rather than a single value.
NestingName | Nesting definition to use
NullElementRepresentation | Representation for null rows.
TypeName | This is TypeName, a member of class AbstractColumn.
Top
Protected Properties
Name | Description
IsTrackingViewState | This is IsTrackingViewState, a member of class AbstractColumn.
ViewState | This is ViewState, a member of class AbstractColumn.


AbstractColumn.AsExternalId Property

AbstractColumn.AsExternalId Property
AbstractColumn Class Eco.Web.UI.WebControls Namespace See Also
Collapse All

Set this value to true to indicate that the property shall be represented by its ExternalId.

Setting this value to true for a property that represents an ECO object will render the property as a string returned by IExternalIdService. And on setting it will accept a string which is produced by that service. This is mainly for use in ASP.Net databinding, where only value types survive.

C#
public bool AsExternalId;
Remarks

FIXME[LocalizableCategory(typeof(HandlesStringRes), "sCategoryBinding")] FIXME[LocalizableDescription(typeof(HandlesStringRes), "sPropertyIsReadOnly")]

See Also
AbstractColumn Class
Eco.Web.UI.WebControls Namespace


AbstractColumn.EventDerivedValue Property

AbstractColumn.EventDerivedValue Property
AbstractColumn Class Eco.Web.UI.WebControls Namespace See Also
Collapse All
C#
public abstract bool EventDerivedValue;
Remarks

This is EventDerivedValue, a member of class AbstractColumn.

See Also
AbstractColumn Class
Eco.Web.UI.WebControls Namespace


AbstractColumn.Expression Property

AbstractColumn.Expression Property
AbstractColumn Class Eco.Web.UI.WebControls Namespace See Also
Collapse All

OCL expression used to compute the value of the column unless EventDerivedValue is true.

C#
public abstract string Expression;
See Also
AbstractColumn Class
Eco.Web.UI.WebControls Namespace


AbstractColumn.IsReadOnly Property

AbstractColumn.IsReadOnly Property
AbstractColumn Class Eco.Web.UI.WebControls Namespace See Also
Collapse All

Set this value to true to indicate that the property shall be read only.

If this value is false for an OclColumn, the readablility will be decided by the Ocl expression

If this value is false for an EventDerviedColumn, setting is handled by ElementHandle.ReverseDeriveValue

C#
public bool IsReadOnly;
Remarks

FIXME[LocalizableCategory(typeof(HandlesStringRes), "sCategoryBinding")] FIXME[LocalizableDescription(typeof(HandlesStringRes), "sPropertyIsReadOnly")]

See Also
AbstractColumn Class
Eco.Web.UI.WebControls Namespace


AbstractColumn.IsTrackingViewState Property

AbstractColumn.IsTrackingViewState Property
AbstractColumn Class Eco.Web.UI.WebControls Namespace See Also
Collapse All
C#
protected bool IsTrackingViewState;
Remarks

This is IsTrackingViewState, a member of class AbstractColumn.

See Also
AbstractColumn Class
Eco.Web.UI.WebControls Namespace


AbstractColumn.Name Property

AbstractColumn.Name Property
AbstractColumn Class Eco.Web.UI.WebControls Namespace See Also
Collapse All

This is the name given to the property added to the binding list.

This name is used when binding to a data aware control.

C#
public String Name;
Remarks

FIXME[LocalizableCategory(typeof(HandlesStringRes), "sCategoryBinding")] FIXME[LocalizableDescription(typeof(HandlesStringRes), "sPropertyColumnName")]

Exceptions
Exceptions | Description
InvalidOperationException | Thrown if the name of the column is not unique in the owner's column collection.
See Also
AbstractColumn Class
Eco.Web.UI.WebControls Namespace


AbstractColumn.Nested Property

AbstractColumn.Nested Property
AbstractColumn Class Eco.Web.UI.WebControls Namespace See Also
Collapse All

Set this property to true to make the property in the binding list a list rather than a single value.

C#
public bool Nested;
Remarks

FIXME[LocalizableCategory(typeof(HandlesStringRes), "sCategoryNesting")] FIXME[LocalizableDescription(typeof(HandlesStringRes), "sPropertyNested")]

See Also
AbstractColumn Class
Eco.Web.UI.WebControls Namespace


AbstractColumn.NestingName Property

AbstractColumn.NestingName Property
AbstractColumn Class Eco.Web.UI.WebControls Namespace See Also
Collapse All

Nesting definition to use

C#
public string NestingName;
Remarks

If this name is set, a Nesting with that name must exist in the ElementHandle.Nestings of the owning handle. If the name is empty, default columns will be created for the nesting.

FIXM[LocalizableCategory(typeof(HandlesStringRes), "sCategoryNesting")] FIXME[LocalizableDescription(typeof(HandlesStringRes), "sPropertyNesting")]

See Also
AbstractColumn Class
Eco.Web.UI.WebControls Namespace


AbstractColumn.NullElementRepresentation Property

AbstractColumn.NullElementRepresentation Property
AbstractColumn Class Eco.Web.UI.WebControls Namespace See Also
Collapse All

Representation for null rows.

C#
public abstract string NullElementRepresentation;
Remarks

This property controls the column is presented for a "null" row created by setting ElementHandle.NullRowMode to something toher than NullRowMode.None

The property is a string that will be convereted to the type of the column.

Two special values are recognized, <Null> which will represent the column as null and <DbNull> which will represent the column as DbNull.Value". The default is <Null>.

See Also
AbstractColumn Class
Eco.Web.UI.WebControls Namespace


AbstractColumn.TypeName Property

AbstractColumn.TypeName Property
AbstractColumn Class Eco.Web.UI.WebControls Namespace See Also
Collapse All
C#
public virtual string TypeName;
Remarks

This is TypeName, a member of class AbstractColumn.

See Also
AbstractColumn Class
Eco.Web.UI.WebControls Namespace


AbstractColumn.ViewState Property

AbstractColumn.ViewState Property
AbstractColumn Class Eco.Web.UI.WebControls Namespace See Also
Collapse All
C#
protected StateBag ViewState;
Remarks

This is ViewState, a member of class AbstractColumn.

See Also
AbstractColumn Class
Eco.Web.UI.WebControls Namespace


EcoDataSource Class

EcoDataSource Class
Inheritance Hierarchy See Also
Collapse All

A DataSource that gets its values by from an EcoSpace using OCL expressions.

C#
public class EcoDataSource : DataSourceControl, IHasEditableExpression, IHasSecondEditableExpression, IHasTypeSystem;
Remarks

EcoDataSource is a System.Web.UI.DataSourceControl, and as such can be used for databinding to ASP.Net 2.0 databound controls such as System.Web.UI.WebControls.GridView, System.Web.UI.WebControls.DetailsView and System.Web.UI.WebControls.FormView.

The EcoDataSource has two OCL expressions, EcoDataSource.PsExpression and EcoDataSource.Expression, either of which may be empty. If PsExpresion is non-empty it will be translated to SQL and evaluated in the database. If Expression is non-empty it will be evaluted in the EcoSpace. If both are non-empty, Expression will be evaluated with the result of PsExpression as a context.

The result of this evalutaion will be taken as a list of ECO Objects, with the DataSource containing one row for each ECO Object in the list. The columns are define by a combination of the properties EcoDataSource.AddDefaultProperties, EcoDataSource.AddExternalId, EcoDataSource.MemberVisibility and EcoDataSource.Columns.

Inheritance Hierarchy
Eco.Web.UI.WebControls.EcoDataSource
File

EcoDataSource.cs

See Also
Inheritance Hierarchy


EcoDataSource.EcoDataSource Constructor

EcoDataSource.EcoDataSource Constructor
EcoDataSource Class Eco.Web.UI.WebControls Namespace See Also
Collapse All

Creates a new instance of this control.

C#
public EcoDataSource();
See Also
EcoDataSource Class
Eco.Web.UI.WebControls Namespace


EcoDataSource Fields

EcoDataSource Fields
Public Fields
Collapse All

The fields of the EcoDataSource class are listed here.

Public Fields
Name | Description
DefaultViewName | This is DefaultViewName, a member of class EcoDataSource.
KeyColumnName | This is KeyColumnName, a member of class EcoDataSource.


EcoDataSource.DefaultViewName Field

EcoDataSource.DefaultViewName Field
EcoDataSource Class Eco.Web.UI.WebControls Namespace See Also
Collapse All
C#
public const string DefaultViewName = "DefaultView";
Remarks

This is DefaultViewName, a member of class EcoDataSource.

See Also
EcoDataSource Class
Eco.Web.UI.WebControls Namespace


EcoDataSource.KeyColumnName Field

EcoDataSource.KeyColumnName Field
EcoDataSource Class Eco.Web.UI.WebControls Namespace See Also
Collapse All
C#
public const string KeyColumnName = "ExternalId";
Remarks

This is KeyColumnName, a member of class EcoDataSource.

See Also
EcoDataSource Class
Eco.Web.UI.WebControls Namespace


EcoDataSource Methods

EcoDataSource Methods
Protected Methods Public Methods
Collapse All

The methods of the EcoDataSource class are listed here.

Protected Methods
Name | Description
GetView | Returns a DataSourceView with the specified name.
GetViewNames | This is GetViewNames, a member of class EcoDataSource.
LoadViewState | Loads properties from the ViewState.
SaveViewState | Saves the properties to the ViewState.
TrackViewState | This is TrackViewState, a member of class EcoDataSource.
Top
Public Methods
Name | Description
CreateDefaultColumns | Checks each structural feature of the current type of the datasource and if no column exists with the same name it will create a column for it.
Insert | This is the overview for the Insert method overload.
IsValidNewValues | Checks if the combination of keys/values represents valid values for an object.
Select | Performs data retrieval for UI controls to data bind to.


EcoDataSource.CreateDefaultColumns Method

EcoDataSource.CreateDefaultColumns Method
EcoDataSource Class Eco.Web.UI.WebControls Namespace Related Topics See Also
Collapse All

Checks each structural feature of the current type of the datasource and if no column exists with the same name it will create a column for it.

C#
public void CreateDefaultColumns();
Remarks

If the type is an IPrimitiveType (int, string, etc) then only a single unnamed column will be created with the expression "self".

MemberVisibility will be honoured when creating columns.

Related Topics

AddExternalId, Columns, MemberVisibility

See Also
EcoDataSource Class
Eco.Web.UI.WebControls Namespace
Related Topics


EcoDataSource.GetView Method

EcoDataSource.GetView Method
EcoDataSource Class Eco.Web.UI.WebControls Namespace See Also
Collapse All

Returns a DataSourceView with the specified name.

C#
protected override DataSourceView GetView(
    string viewName
);
Parameters
Parameters | Description
viewName | The name of the view to retrieve.
Exceptions
Exceptions | Description
ArgumentException | Thrown if no view exists with the specified name.
See Also
EcoDataSource Class
Eco.Web.UI.WebControls Namespace


EcoDataSource.GetViewNames Method

EcoDataSource.GetViewNames Method
EcoDataSource Class Eco.Web.UI.WebControls Namespace See Also
Collapse All
C#
protected override ICollection GetViewNames();
Remarks

This is GetViewNames, a member of class EcoDataSource.

See Also
EcoDataSource Class
Eco.Web.UI.WebControls Namespace


Insert Method

Insert Method

This is the overview for the Insert method overload.

Overload List
Name | Description
EcoDataSource.Insert () | Inserts a new row by creating an object of the relevant type.
EcoDataSource.Insert (IDictionary) | Inserts a new row by creating an object of the relevant type, taking a dictionary of initial values.


EcoDataSource.Insert Method ()

EcoDataSource.Insert Method ()
EcoDataSource Class Eco.Web.UI.WebControls Namespace See Also
Collapse All

Inserts a new row by creating an object of the relevant type.

C#
public int Insert();
Returns

A value specifying how many objects were created.

See Also
EcoDataSource Class
Eco.Web.UI.WebControls Namespace


EcoDataSource.Insert Method (IDictionary)

EcoDataSource.Insert Method (IDictionary)
EcoDataSource Class Eco.Web.UI.WebControls Namespace See Also
Collapse All

Inserts a new row by creating an object of the relevant type, taking a dictionary of initial values.

C#
public int Insert(
    IDictionary values
);
Parameters
Parameters | Description
values | The initial values to be applied to the new object (columnnames/values).
Returns

A value specifying how many objects were created.

See Also
EcoDataSource Class
Eco.Web.UI.WebControls Namespace


EcoDataSource.IsValidNewValues Method

EcoDataSource.IsValidNewValues Method
EcoDataSource Class Eco.Web.UI.WebControls Namespace See Also
Collapse All

Checks if the combination of keys/values represents valid values for an object.

C#
public bool IsValidNewValues(
    IDictionary keys,
    IDictionary values
);
Parameters
Parameters | Description
keys | A dictinary that contains the ExternalId of the object, or null for a new object.
values | The values (columnnames/values) that should be applied to the object before validation.
Remarks

It will start a transaction, create an object, set the values and call OnValidatingRow. Finally, the transaction will be rolled back. If the object validated, then the method will return true, otherwise false.

See Also
EcoDataSource Class
Eco.Web.UI.WebControls Namespace


EcoDataSource.LoadViewState Method

EcoDataSource.LoadViewState Method
EcoDataSource Class Eco.Web.UI.WebControls Namespace See Also
Collapse All

Loads properties from the ViewState.

C#
protected override void LoadViewState(
    object savedState
);
Parameters
Parameters | Description
savedState |
See Also
EcoDataSource Class
Eco.Web.UI.WebControls Namespace


EcoDataSource.SaveViewState Method

EcoDataSource.SaveViewState Method
EcoDataSource Class Eco.Web.UI.WebControls Namespace See Also
Collapse All

Saves the properties to the ViewState.

C#
protected override object SaveViewState();
See Also
EcoDataSource Class
Eco.Web.UI.WebControls Namespace


EcoDataSource.Select Method

EcoDataSource.Select Method
EcoDataSource Class Eco.Web.UI.WebControls Namespace See Also
Collapse All

Performs data retrieval for UI controls to data bind to.

C#
public IEnumerable Select();
Returns

An enumerable list of data rows.

See Also
EcoDataSource Class
Eco.Web.UI.WebControls Namespace


EcoDataSource.TrackViewState Method

EcoDataSource.TrackViewState Method
EcoDataSource Class Eco.Web.UI.WebControls Namespace See Also
Collapse All
C#
protected override void TrackViewState();
Remarks

This is TrackViewState, a member of class EcoDataSource.

See Also
EcoDataSource Class
Eco.Web.UI.WebControls Namespace


EcoDataSource Properties

EcoDataSource Properties
Public Properties
Collapse All

The properties of the EcoDataSource class are listed here.

Public Properties
Name | Description
AddDefaultProperties | Indicates whether or not to add a column for each simple structural feature of the class.
AddExternalId | Specifies whether or not a read-only column named "ExternalId" should be added automatically.
Columns | A collection of columns that the data source exposes for data binding
DeleteMode | Specifies the action to take when deleting a row.
EcoSpaceManager | The EcospaceManager refered by EcoSpaceManagerID
EcoSpaceManagerID | The ID of the EcoSpaceManager to bind to.
Expression | The OCL expression that will be evaluated in memory.
InsertMode | Specifies the action to take when inserting a new row.
ManualUpdate | Specifies whether or not EcoSpaceManager.UpdateDatabase will be called automatically when appropriate.
MemberVisibility | Specifies the maximum visibility of features to automatically expose as columns.
NullRowMode | Specifies whether or not to add an additional "null" row to the list supplied by the EcoDataSource.
Parameters | A collection of runtime parameters which may be used in OCL expressions.
PsExpression | The OCL expression that will be evaluated in the persistence storage.
SupportSorting | Identifies whether or not this component should support sorting.
TranslateNullToEmptyString | Indicates whether a null string returned from the DataBinding should be translated into an emtpy string for ECO.
TypedList | This property is for the internal use of the EcoDataSourceDesigner.
ValidateRowOnInsert | Indicates whether the ValidateRow event shall fire when inserting a new object.
ValidateRowOnUpdate | Indicates whether the ValidateRow event shall fire when inserting a new object.


EcoDataSource.AddDefaultProperties Property

EcoDataSource.AddDefaultProperties Property
EcoDataSource Class Eco.Web.UI.WebControls Namespace Related Topics See Also
Collapse All

Indicates whether or not to add a column for each simple structural feature of the class.

C#
public bool AddDefaultProperties;
Remarks

If this property is True then the result type of evaluating the Expression and PsExpression will be determined, and then a column will be added for each of its simple features (int, string, etc), and also each of its association ends that refer to a single object instance.

For the singular association ends the expression added will be self.membername.asString, so the column will show a string representation of the object rather than containing the object itself. The string displayed will be the result of evaluating the DefaultStringRepresentation set in the model for the target class.

If the Columns collection already contains a column with the same name the existing column will take priority and remain untouched, no new column will not be added. This enables the developer to override the definition of default columns at design time.

Related Topics

AddExternalId, Columns, MemberVisibility

See Also
EcoDataSource Class
Eco.Web.UI.WebControls Namespace
Related Topics


EcoDataSource.AddExternalId Property

EcoDataSource.AddExternalId Property
EcoDataSource Class Eco.Web.UI.WebControls Namespace Related Topics See Also
Collapse All

Specifies whether or not a read-only column named "ExternalId" should be added automatically.

C#
public bool AddExternalId;
Remarks

The ExternalId column is used to represent the identity of an ECO object at runtime as a string.

The column added will be of type "string". This value is suitable for use as a DataBinding key by setting the DataKeyNames for example on a System.Web.UI.WebControls.GridView.

Related Topics

Eco.Services.IExternalIdService

See Also
EcoDataSource Class
Eco.Web.UI.WebControls Namespace
Related Topics


EcoDataSource.Columns Property

EcoDataSource.Columns Property
EcoDataSource Class Eco.Web.UI.WebControls Namespace Related Topics See Also
Collapse All

A collection of columns that the data source exposes for data binding

C#
public EcoDataSourceColumnCollection Columns;
Remarks

This property affects the appearance of the list returned by EcoDataSourceView.Select and used when data binding ASP.NET components.

Each column in the collection will add a property to the list in addition to the ones defined by AddDefaultProperties and AddExternalId.

If AddDefaultProperties is True and the developer is able to override the settings of columns that will be automatically generated by manually adding a column with the same name.

Related Topics

EcoDataSource.AddDefaultProperties, EcoDataSource.AddExternalId, EcoDataSource.MemberVisibility

See Also
EcoDataSource Class
Eco.Web.UI.WebControls Namespace
Related Topics


EcoDataSource.DeleteMode Property

EcoDataSource.DeleteMode Property
EcoDataSource Class Eco.Web.UI.WebControls Namespace See Also
Collapse All

Specifies the action to take when deleting a row.

C#
public DeleteMode DeleteMode;
Remarks

Note that DeleteMode.Unlink will only work if the navigation to the multilink is done by Expression, rather than by PsExpression.

See Also
EcoDataSource Class
Eco.Web.UI.WebControls Namespace


EcoDataSource.EcoSpaceManager Property

EcoDataSource.EcoSpaceManager Property
EcoDataSource Class Eco.Web.UI.WebControls Namespace See Also
Collapse All

The EcospaceManager refered by EcoSpaceManagerID

C#
public EcoSpaceManager EcoSpaceManager;
Remarks

This property may be used at runtime to obtain an EcoSpace instance of type specified by the Eco.Web.UI.WebControls.EcoSpaceManager.EcoSpaceTypeName.

See Also
EcoDataSource Class
Eco.Web.UI.WebControls Namespace


EcoDataSource.EcoSpaceManagerID Property

EcoDataSource.EcoSpaceManagerID Property
EcoDataSource Class Eco.Web.UI.WebControls Namespace See Also
Collapse All

The ID of the EcoSpaceManager to bind to.

C#
public string EcoSpaceManagerID;
Remarks

A single webform may use multiple instances of EcoSpaces during its lifetime, these may be multiple instances of the same type of EcoSpace, or the web application may utilize multiple models / persistence storages by instantiating instances of different types of EcoSpace.

This property identifies which EcoSpaceManager to use as a provider of its EcoSpace.

See Also
EcoDataSource Class
Eco.Web.UI.WebControls Namespace


EcoDataSource.Expression Property

EcoDataSource.Expression Property
EcoDataSource Class Eco.Web.UI.WebControls Namespace See Also
Collapse All

The OCL expression that will be evaluated in memory.

C#
public string Expression;
Remarks

If no PsExpression has been entered then this expression will be evaluated against the EcoSpace, otherwise the PsExpression will first be evaluated and then this expression will be evaluated using its result for a context.

When evaluating this OCL any required objects will be retrieve from the persistence storage automatically, any filtering of the objects using OCL such as "->select()" will be performed in memory rather than by the persistence storage. This technique is useful for evaluating more advanced OCL statements which are not possible in SQL, and for filtering the result set based on derived members which are calculated in memory and therefore not available in the persistence storage.

Copy Code
Author.allInstances->select(not suspended)
Copy Code
self->select(mostRecentArticle.datePublished > DateTime.Now.Date.AddDays(-7))
See Also
EcoDataSource Class
Eco.Web.UI.WebControls Namespace


EcoDataSource.InsertMode Property

EcoDataSource.InsertMode Property
EcoDataSource Class Eco.Web.UI.WebControls Namespace See Also
Collapse All

Specifies the action to take when inserting a new row.

C#
public InsertMode InsertMode;
See Also
EcoDataSource Class
Eco.Web.UI.WebControls Namespace


EcoDataSource.ManualUpdate Property

EcoDataSource.ManualUpdate Property
EcoDataSource Class Eco.Web.UI.WebControls Namespace See Also
Collapse All

Specifies whether or not EcoSpaceManager.UpdateDatabase will be called automatically when appropriate.

C#
public bool ManualUpdate;
Remarks

If ManualUpdate is False (the default value) Eco.Web.UI.WebControls.EcoSpaceManager.UpdateDatabase will be called after each Update, Insert or Delete is performed on the EcoDataSet. If it is set to True, the changes will be applied to the EcoSpace cache but not propagated to the persistence storage until the application explicitly calls Eco.Web.UI.WebControls.EcoSpaceManager.UpdateDatabase.

See Also
EcoDataSource Class
Eco.Web.UI.WebControls Namespace


EcoDataSource.MemberVisibility Property

EcoDataSource.MemberVisibility Property
EcoDataSource Class Eco.Web.UI.WebControls Namespace See Also
Collapse All

Specifies the maximum visibility of features to automatically expose as columns.

C#
public MemberVisibility MemberVisibility;
Remarks

This property allows the developer to restrict which class features are added as columns based on the visibility defined during modeling.

See Also
EcoDataSource Class
Eco.Web.UI.WebControls Namespace


EcoDataSource.NullRowMode Property

EcoDataSource.NullRowMode Property
EcoDataSource Class Eco.Web.UI.WebControls Namespace See Also
Collapse All

Specifies whether or not to add an additional "null" row to the list supplied by the EcoDataSource.

C#
public NullRowMode NullRowMode;
Remarks

A null row may be useful in various scenarios, for example you may wish to add a null row at the top of the list so that the user is presented with a selection of countries where the first item in the list is "Please select...",or maybe to allow the user to select "None".

The display of columns of the null row are controlled by AbstractColumn.NullElementRepresentation

Or you may want to make a System.Web.UI.WebControls.GridView visible when there is no data in the EcoDataSource, although using System.Web.UI.WebControls.GridView.EmptyDataText might be a better option.

See Also
EcoDataSource Class
Eco.Web.UI.WebControls Namespace


EcoDataSource.Parameters Property

EcoDataSource.Parameters Property
EcoDataSource Class Eco.Web.UI.WebControls Namespace Related Topics See Also
Collapse All

A collection of runtime parameters which may be used in OCL expressions.

C#
public ParameterCollection Parameters;
Remarks

This collection allows the developer to specify named values which may be used in Expression and PsExpression when determining which objects to include in the result set. Any System.Web.UI.WebControls.Parameter added to this collection will be available as OCL variables during the evaluation of those expressions.

Whan binding to an EcoObject, the Parameter should bind to an ExternalId, and the OCL expression should contain a fragment such as "Order.objectfromExternalId(OrderId)" Two common cases are binding to a System.Web.UI.WebControls.QueryStringParameter for a form showing a given object, and binding to a ControlParameter for a master/detail view. In particular System.Web.UI.WebControls.GridView.SelectedValue will contain the ExternalId, provided that System.Web.UI.WebControls.GridView.DataKeyNames is set to ExternalId, and AddExternalId is True.

Related Topics

EcoDataSource.AddDefaultProperties, EcoDataSource.AddExternalId, EcoDataSource.MemberVisibility

See Also
EcoDataSource Class
Eco.Web.UI.WebControls Namespace
Related Topics


EcoDataSource.PsExpression Property

EcoDataSource.PsExpression Property
EcoDataSource Class Eco.Web.UI.WebControls Namespace See Also
Collapse All

The OCL expression that will be evaluated in the persistence storage.

C#
public string PsExpression;
Remarks

When the persistence storage is an SQL compliant database the expression will be converted to SQL and evaluated in the database. This expression is more limited than full OCL due to the fact that not all OCL operations are available within all SQL databases.

This property is useful when you wish to restrict the number of objects displayed and do not wish to load all instances from the persistence storage into the EcoSpace cache in order to perform the filtering. For example

Copy Code
Article.allInstances->select(mainState = #Published)
See Also
EcoDataSource Class
Eco.Web.UI.WebControls Namespace


EcoDataSource.SupportSorting Property

EcoDataSource.SupportSorting Property
EcoDataSource Class Eco.Web.UI.WebControls Namespace See Also
Collapse All

Identifies whether or not this component should support sorting.

C#
public bool SupportSorting;
Remarks

If set to True this component will report to GUI controls that it is capable of supporting sorting. This provides the application with the ability to reorder the user’s view of the data at runtime using GUI controls that are databound to it.

See Also
EcoDataSource Class
Eco.Web.UI.WebControls Namespace


EcoDataSource.TranslateNullToEmptyString Property

EcoDataSource.TranslateNullToEmptyString Property
EcoDataSource Class Eco.Web.UI.WebControls Namespace See Also
Collapse All

Indicates whether a null string returned from the DataBinding should be translated into an emtpy string for ECO.

C#
public bool TranslateNullToEmptyString;
Remarks

This property is True by default, to compensate for the fact that System.Web.UI.WebControls.BoundField.ConvertEmptyStringToNull is True by default. The only time this value should be set to False is if you have a bound string field with ConvertEmptyStringToNull set to False.

See Also
EcoDataSource Class
Eco.Web.UI.WebControls Namespace


EcoDataSource.TypedList Property

EcoDataSource.TypedList Property
EcoDataSource Class Eco.Web.UI.WebControls Namespace See Also
Collapse All

This property is for the internal use of the EcoDataSourceDesigner.

C#
public ITypedList TypedList;
Remarks

Used by designer only

See Also
EcoDataSource Class
Eco.Web.UI.WebControls Namespace


EcoDataSource.ValidateRowOnInsert Property

EcoDataSource.ValidateRowOnInsert Property
EcoDataSource Class Eco.Web.UI.WebControls Namespace See Also
Collapse All

Indicates whether the ValidateRow event shall fire when inserting a new object.

C#
public bool ValidateRowOnInsert;
Remarks

If this property is true ValidateRow will be called after the new values have been set, but before then changes are commited to the EcoSpace

See Also
EcoDataSource Class
Eco.Web.UI.WebControls Namespace


EcoDataSource.ValidateRowOnUpdate Property

EcoDataSource.ValidateRowOnUpdate Property
EcoDataSource Class Eco.Web.UI.WebControls Namespace See Also
Collapse All

Indicates whether the ValidateRow event shall fire when inserting a new object.

C#
public bool ValidateRowOnUpdate;
Remarks

If this property is true ValidateRow will be called after the new values have been set, but before then changes are commited to the EcoSpace

See Also
EcoDataSource Class
Eco.Web.UI.WebControls Namespace


EcoDataSource Events

EcoDataSource Events
Public Events
Collapse All

The events of the EcoDataSource class are listed here.

Public Events
Name | Description
Deleted | This event is executed after an object has been deleted or removed from the result set.
Deleting | This event is executed when an attempt is made to delete a row from the result set.
DeriveValue | This is DeriveValue, a member of class EcoDataSource.
Inserted | This event is executed after an object has been created and added to the result set.
Inserting | This event is executed when the user tries to insert a new row.
ReverseDeriveValue | This is ReverseDeriveValue, a member of class EcoDataSource.
Selected | Executed after the data retrieval has completed.
Selecting | Executed before any data retrieval is performed.
Updated | This event is executed after GUI changes to an object have been applied to the EcoSpace.
Updating | This event is executed before GUI changes to an object have been applied to the EcoSpace.
ValidatingRow | This event is executed when a row is validated.


EcoDataSource.Deleted Event

EcoDataSource.Deleted Event
EcoDataSource Class Eco.Web.UI.WebControls Namespace Related Topics See Also
Collapse All

This event is executed after an object has been deleted or removed from the result set.

C#
public event EcoDataSourceStatusEventHandler Deleted;
Remarks

This event provides the developer with the opportunity to handle any exceptions which may have occurred during the Delete operation. If an exception occurred it will be available via the EcoDataSourceStatusEventArgs parameter.

Related Topics

Eco.Web.UI.WebControls.DeleteMode

See Also
EcoDataSource Class
Eco.Web.UI.WebControls Namespace
Related Topics


EcoDataSource.Deleting Event

EcoDataSource.Deleting Event
EcoDataSource Class Eco.Web.UI.WebControls Namespace Related Topics See Also
Collapse All

This event is executed when an attempt is made to delete a row from the result set.

C#
public event EcoDataSourceObjectEventHandler Deleting;
Remarks

The event code is triggered after the control requests a deletion but before the object is actually deleted or removed from the result set. This provides the application with the ability to cancel the deletion / removal.

Related Topics

Eco.Web.UI.WebControls.DeleteMode

See Also
EcoDataSource Class
Eco.Web.UI.WebControls Namespace
Related Topics


EcoDataSource.DeriveValue Event

EcoDataSource.DeriveValue Event
EcoDataSource Class Eco.Web.UI.WebControls Namespace See Also
Collapse All
C#
public event DeriveEventHandler DeriveValue;
Remarks

This is DeriveValue, a member of class EcoDataSource.

See Also
EcoDataSource Class
Eco.Web.UI.WebControls Namespace


EcoDataSource.Inserted Event

EcoDataSource.Inserted Event
EcoDataSource Class Eco.Web.UI.WebControls Namespace See Also
Collapse All

This event is executed after an object has been created and added to the result set.

C#
public event EcoDataSourceStatusEventHandler Inserted;
Remarks

This event provides the developer with the opportunity to handle any exceptions which may have occurred during the Insert operation. If an exception occurred it will be available via the EcoDataSourceStatusEventArgs parameter.

See Also
EcoDataSource Class
Eco.Web.UI.WebControls Namespace


EcoDataSource.Inserting Event

EcoDataSource.Inserting Event
EcoDataSource Class Eco.Web.UI.WebControls Namespace See Also
Collapse All

This event is executed when the user tries to insert a new row.

C#
public event EcoDataSourceInsertingEventHandler Inserting;
Remarks

The event code is triggered after the control requests an insert but before the object is actually created. This provides the application with the ability to cancel the creation.

See Also
EcoDataSource Class
Eco.Web.UI.WebControls Namespace


EcoDataSource.ReverseDeriveValue Event

EcoDataSource.ReverseDeriveValue Event
EcoDataSource Class Eco.Web.UI.WebControls Namespace See Also
Collapse All
C#
public event ReverseDeriveEventHandler ReverseDeriveValue;
Remarks

This is ReverseDeriveValue, a member of class EcoDataSource.

See Also
EcoDataSource Class
Eco.Web.UI.WebControls Namespace


EcoDataSource.Selected Event

EcoDataSource.Selected Event
EcoDataSource Class Eco.Web.UI.WebControls Namespace See Also
Collapse All

Executed after the data retrieval has completed.

C#
public event EcoDataSourceStatusEventHandler Selected;
Remarks

This event provides the developer with the opportunity to handle any exceptions which may have occurred during the Select phase. If an exception occurred it will be available via the EcoDataSourceStatusEventArgs parameter.

See Also
EcoDataSource Class
Eco.Web.UI.WebControls Namespace


EcoDataSource.Selecting Event

EcoDataSource.Selecting Event
EcoDataSource Class Eco.Web.UI.WebControls Namespace See Also
Collapse All

Executed before any data retrieval is performed.

C#
public event EcoDataSourceSelectingEventHandler Selecting;
Remarks

This event is executed just before the EcoDataSource uses the EcoSpace to determine which objects to include in its result set for data binding.

Using this event it is possible to perform any additional initialization required by your application.

See Also
EcoDataSource Class
Eco.Web.UI.WebControls Namespace


EcoDataSource.Updated Event

EcoDataSource.Updated Event
EcoDataSource Class Eco.Web.UI.WebControls Namespace See Also
Collapse All

This event is executed after GUI changes to an object have been applied to the EcoSpace.

C#
public event EcoDataSourceStatusEventHandler Updated;
Remarks

This event provides the developer with the opportunity to handle any exceptions which may have occurred during the Update operation. If an exception occurred it will be available via the EcoDataSourceStatusEventArgs parameter.

See Also
EcoDataSource Class
Eco.Web.UI.WebControls Namespace


EcoDataSource.Updating Event

EcoDataSource.Updating Event
EcoDataSource Class Eco.Web.UI.WebControls Namespace See Also
Collapse All

This event is executed before GUI changes to an object have been applied to the EcoSpace.

C#
public event EcoDataSourceObjectEventHandler Updating;
Remarks

The event code is triggered after the control requests an update but before the object is actually updated. This provides the application with the ability to cancel the update.

See Also
EcoDataSource Class
Eco.Web.UI.WebControls Namespace


EcoDataSource.ValidatingRow Event

EcoDataSource.ValidatingRow Event
EcoDataSource Class Eco.Web.UI.WebControls Namespace See Also
Collapse All

This event is executed when a row is validated.

C#
public event EcoDataSourceObjectEventHandler ValidatingRow;
Remarks

The event code is triggered to validate an entire object after the new values have been applied. Applying the values, and calling this event is done within a transaction, so that if Cancel is set by the event, the entire operation is rolled back.

The event is always called by IsValidNewValues, and will also be called by Update if ValidateRowOnUpdate is true, and and Insert if ValidateRowOnInsert is true.

If keys == null a new object will be created or added depending on the value of InsertMode, and validation will be performed on that object.

See Also
EcoDataSource Class
Eco.Web.UI.WebControls Namespace


EcoDataSourceColumnCollection Class

EcoDataSourceColumnCollection Class
Inheritance Hierarchy See Also
Collapse All
C#
public sealed class EcoDataSourceColumnCollection : StateManagedCollection;
Remarks

This is class Eco.Web.UI.WebControls.EcoDataSourceColumnCollection.

Inheritance Hierarchy
Eco.Web.UI.WebControls.EcoDataSourceColumnCollection
File

EcoDataSourceColumns.cs

See Also
Inheritance Hierarchy


EcoDataSourceColumnCollection.EcoDataSourceColumnCollection Constructor

EcoDataSourceColumnCollection.EcoDataSourceColumnCollection Constructor
EcoDataSourceColumnCollection Class Eco.Web.UI.WebControls Namespace See Also
Collapse All

Creates an instance of the class.

C#
public EcoDataSourceColumnCollection(
    IStaticContext staticContext
);
See Also
EcoDataSourceColumnCollection Class
Eco.Web.UI.WebControls Namespace


EcoDataSourceColumnCollection Methods

EcoDataSourceColumnCollection Methods
Protected Methods Public Methods
Collapse All

The methods of the EcoDataSourceColumnCollection class are listed here.

Protected Methods
Name | Description
CreateKnownType | This is CreateKnownType, a member of class EcoDataSourceColumnCollection.
GetKnownTypes | This is GetKnownTypes, a member of class EcoDataSourceColumnCollection.
OnClearComplete | This is OnClearComplete, a member of class EcoDataSourceColumnCollection.
OnInsert | This is OnInsert, a member of class EcoDataSourceColumnCollection.
OnInsertComplete | This is OnInsertComplete, a member of class EcoDataSourceColumnCollection.
OnRemoveComplete | This is OnRemoveComplete, a member of class EcoDataSourceColumnCollection.
OnValidate | This is OnValidate, a member of class EcoDataSourceColumnCollection.
SetDirtyObject | This is SetDirtyObject, a member of class EcoDataSourceColumnCollection.
Top
Public Methods
Name | Description
Add | This is Add, a member of class EcoDataSourceColumnCollection.
AddRange | Adds an array of columns to the collection.
Contains | This is Contains, a member of class EcoDataSourceColumnCollection.
CopyTo | This is CopyTo, a member of class EcoDataSourceColumnCollection.
IndexOf | This is IndexOf, a member of class EcoDataSourceColumnCollection.
Insert | This is Insert, a member of class EcoDataSourceColumnCollection.
Remove | This is Remove, a member of class EcoDataSourceColumnCollection.
RemoveAt | This is RemoveAt, a member of class EcoDataSourceColumnCollection.
this | This is the overview for the this indexer overload.


EcoDataSourceColumnCollection.Add Method

EcoDataSourceColumnCollection.Add Method
EcoDataSourceColumnCollection Class Eco.Web.UI.WebControls Namespace See Also
Collapse All
C#
public void Add(
    AbstractColumn column
);
Remarks

This is Add, a member of class EcoDataSourceColumnCollection.

See Also
EcoDataSourceColumnCollection Class
Eco.Web.UI.WebControls Namespace


EcoDataSourceColumnCollection.AddRange Method

EcoDataSourceColumnCollection.AddRange Method
EcoDataSourceColumnCollection Class Eco.Web.UI.WebControls Namespace See Also
Collapse All

Adds an array of columns to the collection.

C#
public void AddRange(
    AbstractColumn[] columns
);
See Also
EcoDataSourceColumnCollection Class
Eco.Web.UI.WebControls Namespace


EcoDataSourceColumnCollection.Contains Method

EcoDataSourceColumnCollection.Contains Method
EcoDataSourceColumnCollection Class Eco.Web.UI.WebControls Namespace See Also
Collapse All
C#
public bool Contains(
    AbstractColumn Column
);
Remarks

This is Contains, a member of class EcoDataSourceColumnCollection.

See Also
EcoDataSourceColumnCollection Class
Eco.Web.UI.WebControls Namespace


EcoDataSourceColumnCollection.CopyTo Method

EcoDataSourceColumnCollection.CopyTo Method
EcoDataSourceColumnCollection Class Eco.Web.UI.WebControls Namespace See Also
Collapse All
C#
public void CopyTo(
    AbstractColumn[] array,
    int index
);
Remarks

This is CopyTo, a member of class EcoDataSourceColumnCollection.

See Also
EcoDataSourceColumnCollection Class
Eco.Web.UI.WebControls Namespace


EcoDataSourceColumnCollection.CreateKnownType Method

EcoDataSourceColumnCollection.CreateKnownType Method
EcoDataSourceColumnCollection Class Eco.Web.UI.WebControls Namespace See Also
Collapse All
C#
protected override object CreateKnownType(
    int index
);
Remarks

This is CreateKnownType, a member of class EcoDataSourceColumnCollection.

See Also
EcoDataSourceColumnCollection Class
Eco.Web.UI.WebControls Namespace


EcoDataSourceColumnCollection.GetKnownTypes Method

EcoDataSourceColumnCollection.GetKnownTypes Method
EcoDataSourceColumnCollection Class Eco.Web.UI.WebControls Namespace See Also
Collapse All
C#
protected override Type[] GetKnownTypes();
Remarks

This is GetKnownTypes, a member of class EcoDataSourceColumnCollection.

See Also
EcoDataSourceColumnCollection Class
Eco.Web.UI.WebControls Namespace


EcoDataSourceColumnCollection.IndexOf Method

EcoDataSourceColumnCollection.IndexOf Method
EcoDataSourceColumnCollection Class Eco.Web.UI.WebControls Namespace See Also
Collapse All
C#
public int IndexOf(
    AbstractColumn column
);
Remarks

This is IndexOf, a member of class EcoDataSourceColumnCollection.

See Also
EcoDataSourceColumnCollection Class
Eco.Web.UI.WebControls Namespace


EcoDataSourceColumnCollection.Insert Method

EcoDataSourceColumnCollection.Insert Method
EcoDataSourceColumnCollection Class Eco.Web.UI.WebControls Namespace See Also
Collapse All
C#
public void Insert(
    int index,
    AbstractColumn column
);
Remarks

This is Insert, a member of class EcoDataSourceColumnCollection.

See Also
EcoDataSourceColumnCollection Class
Eco.Web.UI.WebControls Namespace


EcoDataSourceColumnCollection.OnClearComplete Method

EcoDataSourceColumnCollection.OnClearComplete Method
EcoDataSourceColumnCollection Class Eco.Web.UI.WebControls Namespace See Also
Collapse All
C#
protected override void OnClearComplete();
Remarks

This is OnClearComplete, a member of class EcoDataSourceColumnCollection.

See Also
EcoDataSourceColumnCollection Class
Eco.Web.UI.WebControls Namespace


EcoDataSourceColumnCollection.OnInsert Method

EcoDataSourceColumnCollection.OnInsert Method
EcoDataSourceColumnCollection Class Eco.Web.UI.WebControls Namespace See Also
Collapse All
C#
protected override void OnInsert(
    int index,
    object value
);
Remarks

This is OnInsert, a member of class EcoDataSourceColumnCollection.

See Also
EcoDataSourceColumnCollection Class
Eco.Web.UI.WebControls Namespace


EcoDataSourceColumnCollection.OnInsertComplete Method

EcoDataSourceColumnCollection.OnInsertComplete Method
EcoDataSourceColumnCollection Class Eco.Web.UI.WebControls Namespace See Also
Collapse All
C#
protected override void OnInsertComplete(
    int index,
    object value
);
Remarks

This is OnInsertComplete, a member of class EcoDataSourceColumnCollection.

See Also
EcoDataSourceColumnCollection Class
Eco.Web.UI.WebControls Namespace


EcoDataSourceColumnCollection.OnRemoveComplete Method

EcoDataSourceColumnCollection.OnRemoveComplete Method
EcoDataSourceColumnCollection Class Eco.Web.UI.WebControls Namespace See Also
Collapse All
C#
protected override void OnRemoveComplete(
    int index,
    object value
);
Remarks

This is OnRemoveComplete, a member of class EcoDataSourceColumnCollection.

See Also
EcoDataSourceColumnCollection Class
Eco.Web.UI.WebControls Namespace


EcoDataSourceColumnCollection.OnValidate Method

EcoDataSourceColumnCollection.OnValidate Method
EcoDataSourceColumnCollection Class Eco.Web.UI.WebControls Namespace See Also
Collapse All
C#
protected override void OnValidate(
    object o
);
Remarks

This is OnValidate, a member of class EcoDataSourceColumnCollection.

See Also
EcoDataSourceColumnCollection Class
Eco.Web.UI.WebControls Namespace


EcoDataSourceColumnCollection.Remove Method

EcoDataSourceColumnCollection.Remove Method
EcoDataSourceColumnCollection Class Eco.Web.UI.WebControls Namespace See Also
Collapse All
C#
public void Remove(
    AbstractColumn Column
);
Remarks

This is Remove, a member of class EcoDataSourceColumnCollection.

See Also
EcoDataSourceColumnCollection Class
Eco.Web.UI.WebControls Namespace


EcoDataSourceColumnCollection.RemoveAt Method

EcoDataSourceColumnCollection.RemoveAt Method
EcoDataSourceColumnCollection Class Eco.Web.UI.WebControls Namespace See Also
Collapse All
C#
public void RemoveAt(
    int index
);
Remarks

This is RemoveAt, a member of class EcoDataSourceColumnCollection.

See Also
EcoDataSourceColumnCollection Class
Eco.Web.UI.WebControls Namespace


EcoDataSourceColumnCollection.SetDirtyObject Method

EcoDataSourceColumnCollection.SetDirtyObject Method
EcoDataSourceColumnCollection Class Eco.Web.UI.WebControls Namespace See Also
Collapse All
C#
protected override void SetDirtyObject(
    object o
);
Remarks

This is SetDirtyObject, a member of class EcoDataSourceColumnCollection.

See Also
EcoDataSourceColumnCollection Class
Eco.Web.UI.WebControls Namespace


this Indexer

this Indexer

This is the overview for the this indexer overload.

Overload List
Name | Description
EcoDataSourceColumnCollection.this (int) | Properties
EcoDataSourceColumnCollection.this (string) | Returns the column named name.


EcoDataSourceColumnCollection.this Indexer (int)

EcoDataSourceColumnCollection.this Indexer (int)
EcoDataSourceColumnCollection Class Eco.Web.UI.WebControls Namespace See Also
Collapse All
C#
public AbstractColumn this[
    int index
];
Remarks

Properties

See Also
EcoDataSourceColumnCollection Class
Eco.Web.UI.WebControls Namespace


EcoDataSourceColumnCollection.this Indexer (string)

EcoDataSourceColumnCollection.this Indexer (string)
EcoDataSourceColumnCollection Class Eco.Web.UI.WebControls Namespace See Also
Collapse All

Returns the column named name.

C#
public AbstractColumn this[
    string name
];
See Also
EcoDataSourceColumnCollection Class
Eco.Web.UI.WebControls Namespace


EcoDataSourceColumnCollection Properties

EcoDataSourceColumnCollection Properties
Public Properties
Collapse All

The properties of the EcoDataSourceColumnCollection class are listed here.

Public Properties
Name | Description
StaticContext | This is StaticContext, a member of class EcoDataSourceColumnCollection.


EcoDataSourceColumnCollection.StaticContext Property

EcoDataSourceColumnCollection.StaticContext Property
EcoDataSourceColumnCollection Class Eco.Web.UI.WebControls Namespace See Also
Collapse All
C#
public IStaticContext StaticContext;
Remarks

This is StaticContext, a member of class EcoDataSourceColumnCollection.

See Also
EcoDataSourceColumnCollection Class
Eco.Web.UI.WebControls Namespace


EcoDataSourceColumnCollection Events

EcoDataSourceColumnCollection Events
Public Events
Collapse All

The events of the EcoDataSourceColumnCollection class are listed here.

Public Events
Name | Description
ColumnsChanged | Events


EcoDataSourceColumnCollection.ColumnsChanged Event

EcoDataSourceColumnCollection.ColumnsChanged Event
EcoDataSourceColumnCollection Class Eco.Web.UI.WebControls Namespace See Also
Collapse All
C#
public event EventHandler ColumnsChanged;
Remarks

Events

See Also
EcoDataSourceColumnCollection Class
Eco.Web.UI.WebControls Namespace


EcoDataSourceObjectEventArgs Class

EcoDataSourceObjectEventArgs Class
Inheritance Hierarchy See Also
Collapse All
C#
public class EcoDataSourceObjectEventArgs : CancelEventArgs;
Remarks

This is class Eco.Web.UI.WebControls.EcoDataSourceObjectEventArgs.

Inheritance Hierarchy
Eco.Web.UI.WebControls.EcoDataSourceObjectEventArgs
File

EcoDataSourceView.cs

See Also
Inheritance Hierarchy


EcoDataSourceObjectEventArgs.EcoDataSourceObjectEventArgs Constructor

EcoDataSourceObjectEventArgs.EcoDataSourceObjectEventArgs Constructor
EcoDataSourceObjectEventArgs Class Eco.Web.UI.WebControls Namespace See Also
Collapse All
C#
public EcoDataSourceObjectEventArgs(
    IObjectInstance affectedObject
);
Remarks

This is EcoDataSourceObjectEventArgs, a member of class EcoDataSourceObjectEventArgs.

See Also
EcoDataSourceObjectEventArgs Class
Eco.Web.UI.WebControls Namespace


EcoDataSourceObjectEventArgs Properties

EcoDataSourceObjectEventArgs Properties
Public Properties
Collapse All

The properties of the EcoDataSourceObjectEventArgs class are listed here.

Public Properties
Name | Description
AffectedObject | This is AffectedObject, a member of class EcoDataSourceObjectEventArgs.


EcoDataSourceObjectEventArgs.AffectedObject Property

EcoDataSourceObjectEventArgs.AffectedObject Property
EcoDataSourceObjectEventArgs Class Eco.Web.UI.WebControls Namespace See Also
Collapse All
C#
public IObjectInstance AffectedObject;
Remarks

This is AffectedObject, a member of class EcoDataSourceObjectEventArgs.

See Also
EcoDataSourceObjectEventArgs Class
Eco.Web.UI.WebControls Namespace


EcoDataSourceSelectingEventArgs Class

EcoDataSourceSelectingEventArgs Class
Inheritance Hierarchy See Also
Collapse All
C#
public class EcoDataSourceSelectingEventArgs : CancelEventArgs;
Remarks

This is class Eco.Web.UI.WebControls.EcoDataSourceSelectingEventArgs.

Inheritance Hierarchy
Eco.Web.UI.WebControls.EcoDataSourceSelectingEventArgs
File

EcoDataSourceView.cs

See Also
Inheritance Hierarchy


EcoDataSourceSelectingEventArgs.EcoDataSourceSelectingEventArgs Constructor

EcoDataSourceSelectingEventArgs.EcoDataSourceSelectingEventArgs Constructor
EcoDataSourceSelectingEventArgs Class Eco.Web.UI.WebControls Namespace See Also
Collapse All
C#
public EcoDataSourceSelectingEventArgs(
    DataSourceSelectArguments arguments
);
Remarks

This is EcoDataSourceSelectingEventArgs, a member of class EcoDataSourceSelectingEventArgs.

See Also
EcoDataSourceSelectingEventArgs Class
Eco.Web.UI.WebControls Namespace


EcoDataSourceSelectingEventArgs Properties

EcoDataSourceSelectingEventArgs Properties
Public Properties
Collapse All

The properties of the EcoDataSourceSelectingEventArgs class are listed here.

Public Properties
Name | Description
Arguments | This is Arguments, a member of class EcoDataSourceSelectingEventArgs.


EcoDataSourceSelectingEventArgs.Arguments Property

EcoDataSourceSelectingEventArgs.Arguments Property
EcoDataSourceSelectingEventArgs Class Eco.Web.UI.WebControls Namespace See Also
Collapse All
C#
public DataSourceSelectArguments Arguments;
Remarks

This is Arguments, a member of class EcoDataSourceSelectingEventArgs.

See Also
EcoDataSourceSelectingEventArgs Class
Eco.Web.UI.WebControls Namespace


EcoDataSourceStatusEventArgs Class

EcoDataSourceStatusEventArgs Class
Inheritance Hierarchy See Also
Collapse All
C#
public class EcoDataSourceStatusEventArgs : EventArgs;
Remarks

This is class Eco.Web.UI.WebControls.EcoDataSourceStatusEventArgs.

Inheritance Hierarchy
Eco.Web.UI.WebControls.EcoDataSourceStatusEventArgs
File

EcoDataSourceView.cs

See Also
Inheritance Hierarchy


EcoDataSourceStatusEventArgs.EcoDataSourceStatusEventArgs Constructor

EcoDataSourceStatusEventArgs.EcoDataSourceStatusEventArgs Constructor
EcoDataSourceStatusEventArgs Class Eco.Web.UI.WebControls Namespace See Also
Collapse All
C#
public EcoDataSourceStatusEventArgs(
    Exception exception
);
Remarks

This is EcoDataSourceStatusEventArgs, a member of class EcoDataSourceStatusEventArgs.

See Also
EcoDataSourceStatusEventArgs Class
Eco.Web.UI.WebControls Namespace


EcoDataSourceStatusEventArgs Properties

EcoDataSourceStatusEventArgs Properties
Public Properties
Collapse All

The properties of the EcoDataSourceStatusEventArgs class are listed here.

Public Properties
Name | Description
Exception | This is Exception, a member of class EcoDataSourceStatusEventArgs.
ExceptionHandled | This is ExceptionHandled, a member of class EcoDataSourceStatusEventArgs.


EcoDataSourceStatusEventArgs.Exception Property

EcoDataSourceStatusEventArgs.Exception Property
EcoDataSourceStatusEventArgs Class Eco.Web.UI.WebControls Namespace See Also
Collapse All
C#
public Exception Exception;
Remarks

This is Exception, a member of class EcoDataSourceStatusEventArgs.

See Also
EcoDataSourceStatusEventArgs Class
Eco.Web.UI.WebControls Namespace


EcoDataSourceStatusEventArgs.ExceptionHandled Property

EcoDataSourceStatusEventArgs.ExceptionHandled Property
EcoDataSourceStatusEventArgs Class Eco.Web.UI.WebControls Namespace See Also
Collapse All
C#
public bool ExceptionHandled;
Remarks

This is ExceptionHandled, a member of class EcoDataSourceStatusEventArgs.

See Also
EcoDataSourceStatusEventArgs Class
Eco.Web.UI.WebControls Namespace


EcoDataSourceView Class

EcoDataSourceView Class
Inheritance Hierarchy See Also
Collapse All
C#
public class EcoDataSourceView : DataSourceView, IStateManager;
Inheritance Hierarchy
Eco.Web.UI.WebControls.EcoDataSourceView
File

EcoDataSourceView.cs

See Also
Inheritance Hierarchy


EcoDataSourceView.EcoDataSourceView Constructor

EcoDataSourceView.EcoDataSourceView Constructor
EcoDataSourceView Class Eco.Web.UI.WebControls Namespace See Also
Collapse All
C#
public EcoDataSourceView(
    EcoDataSource owner,
    string name,
    HttpContext context
);
Remarks

This is EcoDataSourceView, a member of class EcoDataSourceView.

See Also
EcoDataSourceView Class
Eco.Web.UI.WebControls Namespace


EcoDataSourceView Fields

EcoDataSourceView Fields
Public Fields
Collapse All

The fields of the EcoDataSourceView class are listed here.

Public Fields
Name | Description
m_Parameters | This is m_Parameters, a member of class EcoDataSourceView.


EcoDataSourceView.m_Parameters Field

EcoDataSourceView.m_Parameters Field
EcoDataSourceView Class Eco.Web.UI.WebControls Namespace See Also
Collapse All
C#
public ParameterCollection m_Parameters;
Remarks

This is m_Parameters, a member of class EcoDataSourceView.

See Also
EcoDataSourceView Class
Eco.Web.UI.WebControls Namespace


EcoDataSourceView Methods

EcoDataSourceView Methods
Protected Methods Public Methods
Collapse All

The methods of the EcoDataSourceView class are listed here.

Protected Methods
Name | Description
ExecuteDelete | This is ExecuteDelete, a member of class EcoDataSourceView.
ExecuteInsert | This is ExecuteInsert, a member of class EcoDataSourceView.
ExecuteSelect | This is ExecuteSelect, a member of class EcoDataSourceView.
ExecuteUpdate | This is ExecuteUpdate, a member of class EcoDataSourceView.
OnDeleted | This is OnDeleted, a member of class EcoDataSourceView.
OnDeleting | This is OnDeleting, a member of class EcoDataSourceView.
OnInserted | This is OnInserted, a member of class EcoDataSourceView.
OnInserting | This is OnInserting, a member of class EcoDataSourceView.
OnSelected | This is OnSelected, a member of class EcoDataSourceView.
OnSelecting | This is OnSelecting, a member of class EcoDataSourceView.
OnUpdated | This is OnUpdated, a member of class EcoDataSourceView.
OnUpdating | This is OnUpdating, a member of class EcoDataSourceView.
OnValidatingRow | This is OnValidatingRow, a member of class EcoDataSourceView.
Top
Public Methods
Name | Description
Delete | This is Delete, a member of class EcoDataSourceView.
GetDesignTimeData | This is GetDesignTimeData, a member of class EcoDataSourceView.
Insert | This is Insert, a member of class EcoDataSourceView.
IsValidNewValues | This is IsValidNewValues, a member of class EcoDataSourceView.
Select | This is Select, a member of class EcoDataSourceView.
Update | This is Update, a member of class EcoDataSourceView.


EcoDataSourceView.Delete Method

EcoDataSourceView.Delete Method
EcoDataSourceView Class Eco.Web.UI.WebControls Namespace See Also
Collapse All
C#
public int Delete(
    IDictionary keys,
    IDictionary oldValues
);
Remarks

This is Delete, a member of class EcoDataSourceView.

See Also
EcoDataSourceView Class
Eco.Web.UI.WebControls Namespace


EcoDataSourceView.ExecuteDelete Method

EcoDataSourceView.ExecuteDelete Method
EcoDataSourceView Class Eco.Web.UI.WebControls Namespace See Also
Collapse All
C#
protected override int ExecuteDelete(
    IDictionary keys,
    IDictionary oldValues
);
Remarks

This is ExecuteDelete, a member of class EcoDataSourceView.

See Also
EcoDataSourceView Class
Eco.Web.UI.WebControls Namespace


EcoDataSourceView.ExecuteInsert Method

EcoDataSourceView.ExecuteInsert Method
EcoDataSourceView Class Eco.Web.UI.WebControls Namespace See Also
Collapse All
C#
protected override int ExecuteInsert(
    IDictionary values
);
Remarks

This is ExecuteInsert, a member of class EcoDataSourceView.

See Also
EcoDataSourceView Class
Eco.Web.UI.WebControls Namespace


EcoDataSourceView.ExecuteSelect Method

EcoDataSourceView.ExecuteSelect Method
EcoDataSourceView Class Eco.Web.UI.WebControls Namespace See Also
Collapse All
C#
protected override IEnumerable ExecuteSelect(
    DataSourceSelectArguments arguments
);
Remarks

This is ExecuteSelect, a member of class EcoDataSourceView.

See Also
EcoDataSourceView Class
Eco.Web.UI.WebControls Namespace


EcoDataSourceView.ExecuteUpdate Method

EcoDataSourceView.ExecuteUpdate Method
EcoDataSourceView Class Eco.Web.UI.WebControls Namespace See Also
Collapse All
C#
protected override int ExecuteUpdate(
    IDictionary keys,
    IDictionary values,
    IDictionary oldValues
);
Remarks

This is ExecuteUpdate, a member of class EcoDataSourceView.

See Also
EcoDataSourceView Class
Eco.Web.UI.WebControls Namespace


EcoDataSourceView.GetDesignTimeData Method

EcoDataSourceView.GetDesignTimeData Method
EcoDataSourceView Class Eco.Web.UI.WebControls Namespace See Also
Collapse All
C#
public IEnumerable GetDesignTimeData(
    int minimumRows,
    out bool isSampleData
);
Remarks

This is GetDesignTimeData, a member of class EcoDataSourceView.

See Also
EcoDataSourceView Class
Eco.Web.UI.WebControls Namespace


EcoDataSourceView.Insert Method

EcoDataSourceView.Insert Method
EcoDataSourceView Class Eco.Web.UI.WebControls Namespace See Also
Collapse All
C#
public int Insert(
    IDictionary values
);
Remarks

This is Insert, a member of class EcoDataSourceView.

See Also
EcoDataSourceView Class
Eco.Web.UI.WebControls Namespace


EcoDataSourceView.IsValidNewValues Method

EcoDataSourceView.IsValidNewValues Method
EcoDataSourceView Class Eco.Web.UI.WebControls Namespace See Also
Collapse All
C#
public bool IsValidNewValues(
    IDictionary keys,
    IDictionary values
);
Remarks

This is IsValidNewValues, a member of class EcoDataSourceView.

See Also
EcoDataSourceView Class
Eco.Web.UI.WebControls Namespace


EcoDataSourceView.OnDeleted Method

EcoDataSourceView.OnDeleted Method
EcoDataSourceView Class Eco.Web.UI.WebControls Namespace See Also
Collapse All
C#
protected virtual void OnDeleted(
    EcoDataSourceStatusEventArgs e
);
Remarks

This is OnDeleted, a member of class EcoDataSourceView.

See Also
EcoDataSourceView Class
Eco.Web.UI.WebControls Namespace


EcoDataSourceView.OnDeleting Method

EcoDataSourceView.OnDeleting Method
EcoDataSourceView Class Eco.Web.UI.WebControls Namespace See Also
Collapse All
C#
protected virtual void OnDeleting(
    EcoDataSourceObjectEventArgs e
);
Remarks

This is OnDeleting, a member of class EcoDataSourceView.

See Also
EcoDataSourceView Class
Eco.Web.UI.WebControls Namespace


EcoDataSourceView.OnInserted Method

EcoDataSourceView.OnInserted Method
EcoDataSourceView Class Eco.Web.UI.WebControls Namespace See Also
Collapse All
C#
protected virtual void OnInserted(
    EcoDataSourceStatusEventArgs e
);
Remarks

This is OnInserted, a member of class EcoDataSourceView.

See Also
EcoDataSourceView Class
Eco.Web.UI.WebControls Namespace


EcoDataSourceView.OnInserting Method

EcoDataSourceView.OnInserting Method
EcoDataSourceView Class Eco.Web.UI.WebControls Namespace See Also
Collapse All
C#
protected virtual void OnInserting(
    CancelEventArgs e
);
Remarks

This is OnInserting, a member of class EcoDataSourceView.

See Also
EcoDataSourceView Class
Eco.Web.UI.WebControls Namespace


EcoDataSourceView.OnSelected Method

EcoDataSourceView.OnSelected Method
EcoDataSourceView Class Eco.Web.UI.WebControls Namespace See Also
Collapse All
C#
protected virtual void OnSelected(
    EcoDataSourceStatusEventArgs e
);
Remarks

This is OnSelected, a member of class EcoDataSourceView.

See Also
EcoDataSourceView Class
Eco.Web.UI.WebControls Namespace


EcoDataSourceView.OnSelecting Method

EcoDataSourceView.OnSelecting Method
EcoDataSourceView Class Eco.Web.UI.WebControls Namespace See Also
Collapse All
C#
protected virtual void OnSelecting(
    EcoDataSourceSelectingEventArgs e
);
Remarks

This is OnSelecting, a member of class EcoDataSourceView.

See Also
EcoDataSourceView Class
Eco.Web.UI.WebControls Namespace


EcoDataSourceView.OnUpdated Method

EcoDataSourceView.OnUpdated Method
EcoDataSourceView Class Eco.Web.UI.WebControls Namespace See Also
Collapse All
C#
protected virtual void OnUpdated(
    EcoDataSourceStatusEventArgs e
);
Remarks

This is OnUpdated, a member of class EcoDataSourceView.

See Also
EcoDataSourceView Class
Eco.Web.UI.WebControls Namespace


EcoDataSourceView.OnUpdating Method

EcoDataSourceView.OnUpdating Method
EcoDataSourceView Class Eco.Web.UI.WebControls Namespace See Also
Collapse All
C#
protected virtual void OnUpdating(
    EcoDataSourceObjectEventArgs e
);
Remarks

This is OnUpdating, a member of class EcoDataSourceView.

See Also
EcoDataSourceView Class
Eco.Web.UI.WebControls Namespace


EcoDataSourceView.OnValidatingRow Method

EcoDataSourceView.OnValidatingRow Method
EcoDataSourceView Class Eco.Web.UI.WebControls Namespace See Also
Collapse All
C#
protected virtual void OnValidatingRow(
    EcoDataSourceObjectEventArgs e
);
Remarks

This is OnValidatingRow, a member of class EcoDataSourceView.

See Also
EcoDataSourceView Class
Eco.Web.UI.WebControls Namespace


EcoDataSourceView.Select Method

EcoDataSourceView.Select Method
EcoDataSourceView Class Eco.Web.UI.WebControls Namespace See Also
Collapse All
C#
public IEnumerable Select(
    DataSourceSelectArguments arguments
);
Remarks

This is Select, a member of class EcoDataSourceView.

See Also
EcoDataSourceView Class
Eco.Web.UI.WebControls Namespace


EcoDataSourceView.Update Method

EcoDataSourceView.Update Method
EcoDataSourceView Class Eco.Web.UI.WebControls Namespace See Also
Collapse All
C#
public int Update(
    IDictionary keys,
    IDictionary values,
    IDictionary oldValues
);
Remarks

This is Update, a member of class EcoDataSourceView.

See Also
EcoDataSourceView Class
Eco.Web.UI.WebControls Namespace


EcoDataSourceView Properties

EcoDataSourceView Properties
Public Properties
Collapse All

The properties of the EcoDataSourceView class are listed here.

Public Properties
Name | Description
AddDefaultProperties | This is AddDefaultProperties, a member of class EcoDataSourceView.
AddExternalId | This is AddExternalId, a member of class EcoDataSourceView.
CanDelete | This is CanDelete, a member of class EcoDataSourceView.
CanInsert | This is CanInsert, a member of class EcoDataSourceView.
CanPage | This is CanPage, a member of class EcoDataSourceView.
CanRetrieveTotalRowCount | This is CanRetrieveTotalRowCount, a member of class EcoDataSourceView.
CanSort | This is CanSort, a member of class EcoDataSourceView.
CanUpdate | This is CanUpdate, a member of class EcoDataSourceView.
Columns | This is Columns, a member of class EcoDataSourceView.
DeleteMode | This is DeleteMode, a member of class EcoDataSourceView.
EcoSpace | This is EcoSpace, a member of class EcoDataSourceView.
EcoSpaceType | This is EcoSpaceType, a member of class EcoDataSourceView.
Element | This is Element, a member of class EcoDataSourceView.
ElementStaticContext | This is ElementStaticContext, a member of class EcoDataSourceView.
Expression | This is Expression, a member of class EcoDataSourceView.
ExpressionStaticContext | This is ExpressionStaticContext, a member of class EcoDataSourceView.
InsertMode | This is InsertMode, a member of class EcoDataSourceView.
MemberVisibility | This is MemberVisibility, a member of class EcoDataSourceView.
NullRowMode | This is NullRowMode, a member of class EcoDataSourceView.
OclVariables | This is OclVariables, a member of class EcoDataSourceView.
OclVariablesForOclParameters | This is OclVariablesForOclParameters, a member of class EcoDataSourceView.
Parameters | This is Parameters, a member of class EcoDataSourceView.
PsExpression | This is PsExpression, a member of class EcoDataSourceView.
PsExpressionStaticContext | This is PsExpressionStaticContext, a member of class EcoDataSourceView.
SupportSorting | This is SupportSorting, a member of class EcoDataSourceView.
TranslateNullToEmptyString | This is TranslateNullToEmptyString, a member of class EcoDataSourceView.
TypedList | Only usable for schema-information
TypeSystem | This is TypeSystem, a member of class EcoDataSourceView.
ValidateRowOnInsert | This is ValidateRowOnInsert, a member of class EcoDataSourceView.
ValidateRowOnUpdate | This is ValidateRowOnUpdate, a member of class EcoDataSourceView.


EcoDataSourceView.AddDefaultProperties Property

EcoDataSourceView.AddDefaultProperties Property
EcoDataSourceView Class Eco.Web.UI.WebControls Namespace See Also
Collapse All
C#
public bool AddDefaultProperties;
Remarks

This is AddDefaultProperties, a member of class EcoDataSourceView.

See Also
EcoDataSourceView Class
Eco.Web.UI.WebControls Namespace


EcoDataSourceView.AddExternalId Property

EcoDataSourceView.AddExternalId Property
EcoDataSourceView Class Eco.Web.UI.WebControls Namespace See Also
Collapse All
C#
public bool AddExternalId;
Remarks

This is AddExternalId, a member of class EcoDataSourceView.

See Also
EcoDataSourceView Class
Eco.Web.UI.WebControls Namespace


EcoDataSourceView.CanDelete Property

EcoDataSourceView.CanDelete Property
EcoDataSourceView Class Eco.Web.UI.WebControls Namespace See Also
Collapse All
C#
public override bool CanDelete;
Remarks

This is CanDelete, a member of class EcoDataSourceView.

See Also
EcoDataSourceView Class
Eco.Web.UI.WebControls Namespace


EcoDataSourceView.CanInsert Property

EcoDataSourceView.CanInsert Property
EcoDataSourceView Class Eco.Web.UI.WebControls Namespace See Also
Collapse All
C#
public override bool CanInsert;
Remarks

This is CanInsert, a member of class EcoDataSourceView.

See Also
EcoDataSourceView Class
Eco.Web.UI.WebControls Namespace


EcoDataSourceView.CanPage Property

EcoDataSourceView.CanPage Property
EcoDataSourceView Class Eco.Web.UI.WebControls Namespace See Also
Collapse All
C#
public override bool CanPage;
Remarks

This is CanPage, a member of class EcoDataSourceView.

See Also
EcoDataSourceView Class
Eco.Web.UI.WebControls Namespace


EcoDataSourceView.CanRetrieveTotalRowCount Property

EcoDataSourceView.CanRetrieveTotalRowCount Property
EcoDataSourceView Class Eco.Web.UI.WebControls Namespace See Also
Collapse All
C#
public override bool CanRetrieveTotalRowCount;
Remarks

This is CanRetrieveTotalRowCount, a member of class EcoDataSourceView.

See Also
EcoDataSourceView Class
Eco.Web.UI.WebControls Namespace


EcoDataSourceView.CanSort Property

EcoDataSourceView.CanSort Property
EcoDataSourceView Class Eco.Web.UI.WebControls Namespace See Also
Collapse All
C#
public override bool CanSort;
Remarks

This is CanSort, a member of class EcoDataSourceView.

See Also
EcoDataSourceView Class
Eco.Web.UI.WebControls Namespace


EcoDataSourceView.CanUpdate Property

EcoDataSourceView.CanUpdate Property
EcoDataSourceView Class Eco.Web.UI.WebControls Namespace See Also
Collapse All
C#
public override bool CanUpdate;
Remarks

This is CanUpdate, a member of class EcoDataSourceView.

See Also
EcoDataSourceView Class
Eco.Web.UI.WebControls Namespace


EcoDataSourceView.Columns Property

EcoDataSourceView.Columns Property
EcoDataSourceView Class Eco.Web.UI.WebControls Namespace See Also
Collapse All
C#
public EcoDataSourceColumnCollection Columns;
Remarks

This is Columns, a member of class EcoDataSourceView.

See Also
EcoDataSourceView Class
Eco.Web.UI.WebControls Namespace


EcoDataSourceView.DeleteMode Property

EcoDataSourceView.DeleteMode Property
EcoDataSourceView Class Eco.Web.UI.WebControls Namespace See Also
Collapse All
C#
public DeleteMode DeleteMode;
Remarks

This is DeleteMode, a member of class EcoDataSourceView.

See Also
EcoDataSourceView Class
Eco.Web.UI.WebControls Namespace


EcoDataSourceView.EcoSpace Property

EcoDataSourceView.EcoSpace Property
EcoDataSourceView Class Eco.Web.UI.WebControls Namespace See Also
Collapse All
C#
public EcoSpace EcoSpace;
Remarks

This is EcoSpace, a member of class EcoDataSourceView.

See Also
EcoDataSourceView Class
Eco.Web.UI.WebControls Namespace


EcoDataSourceView.EcoSpaceType Property

EcoDataSourceView.EcoSpaceType Property
EcoDataSourceView Class Eco.Web.UI.WebControls Namespace See Also
Collapse All
C#
public Type EcoSpaceType;
Remarks

This is EcoSpaceType, a member of class EcoDataSourceView.

See Also
EcoDataSourceView Class
Eco.Web.UI.WebControls Namespace


EcoDataSourceView.Element Property

EcoDataSourceView.Element Property
EcoDataSourceView Class Eco.Web.UI.WebControls Namespace See Also
Collapse All
C#
public IElement Element;
Remarks

This is Element, a member of class EcoDataSourceView.

See Also
EcoDataSourceView Class
Eco.Web.UI.WebControls Namespace


EcoDataSourceView.ElementStaticContext Property

EcoDataSourceView.ElementStaticContext Property
EcoDataSourceView Class Eco.Web.UI.WebControls Namespace See Also
Collapse All
C#
public IStaticContext ElementStaticContext;
Remarks

This is ElementStaticContext, a member of class EcoDataSourceView.

See Also
EcoDataSourceView Class
Eco.Web.UI.WebControls Namespace


EcoDataSourceView.Expression Property

EcoDataSourceView.Expression Property
EcoDataSourceView Class Eco.Web.UI.WebControls Namespace See Also
Collapse All
C#
public string Expression;
Remarks

This is Expression, a member of class EcoDataSourceView.

See Also
EcoDataSourceView Class
Eco.Web.UI.WebControls Namespace


EcoDataSourceView.ExpressionStaticContext Property

EcoDataSourceView.ExpressionStaticContext Property
EcoDataSourceView Class Eco.Web.UI.WebControls Namespace See Also
Collapse All
C#
public IStaticContext ExpressionStaticContext;
Remarks

This is ExpressionStaticContext, a member of class EcoDataSourceView.

See Also
EcoDataSourceView Class
Eco.Web.UI.WebControls Namespace


EcoDataSourceView.InsertMode Property

EcoDataSourceView.InsertMode Property
EcoDataSourceView Class Eco.Web.UI.WebControls Namespace See Also
Collapse All
C#
public InsertMode InsertMode;
Remarks

This is InsertMode, a member of class EcoDataSourceView.

See Also
EcoDataSourceView Class
Eco.Web.UI.WebControls Namespace


EcoDataSourceView.MemberVisibility Property

EcoDataSourceView.MemberVisibility Property
EcoDataSourceView Class Eco.Web.UI.WebControls Namespace See Also
Collapse All
C#
public MemberVisibility MemberVisibility;
Remarks

This is MemberVisibility, a member of class EcoDataSourceView.

See Also
EcoDataSourceView Class
Eco.Web.UI.WebControls Namespace


EcoDataSourceView.NullRowMode Property

EcoDataSourceView.NullRowMode Property
EcoDataSourceView Class Eco.Web.UI.WebControls Namespace See Also
Collapse All
C#
public NullRowMode NullRowMode;
Remarks

This is NullRowMode, a member of class EcoDataSourceView.

See Also
EcoDataSourceView Class
Eco.Web.UI.WebControls Namespace


EcoDataSourceView.OclVariables Property

EcoDataSourceView.OclVariables Property
EcoDataSourceView Class Eco.Web.UI.WebControls Namespace See Also
Collapse All
C#
public IExternalVariableList OclVariables;
Remarks

This is OclVariables, a member of class EcoDataSourceView.

See Also
EcoDataSourceView Class
Eco.Web.UI.WebControls Namespace


EcoDataSourceView.OclVariablesForOclParameters Property

EcoDataSourceView.OclVariablesForOclParameters Property
EcoDataSourceView Class Eco.Web.UI.WebControls Namespace See Also
Collapse All
C#
public IExternalVariableList OclVariablesForOclParameters;
Remarks

This is OclVariablesForOclParameters, a member of class EcoDataSourceView.

See Also
EcoDataSourceView Class
Eco.Web.UI.WebControls Namespace


EcoDataSourceView.Parameters Property

EcoDataSourceView.Parameters Property
EcoDataSourceView Class Eco.Web.UI.WebControls Namespace See Also
Collapse All
C#
public ParameterCollection Parameters;
Remarks

This is Parameters, a member of class EcoDataSourceView.

See Also
EcoDataSourceView Class
Eco.Web.UI.WebControls Namespace


EcoDataSourceView.PsExpression Property

EcoDataSourceView.PsExpression Property
EcoDataSourceView Class Eco.Web.UI.WebControls Namespace See Also
Collapse All
C#
public string PsExpression;
Remarks

This is PsExpression, a member of class EcoDataSourceView.

See Also
EcoDataSourceView Class
Eco.Web.UI.WebControls Namespace


EcoDataSourceView.PsExpressionStaticContext Property

EcoDataSourceView.PsExpressionStaticContext Property
EcoDataSourceView Class Eco.Web.UI.WebControls Namespace See Also
Collapse All
C#
public IStaticContext PsExpressionStaticContext;
Remarks

This is PsExpressionStaticContext, a member of class EcoDataSourceView.

See Also
EcoDataSourceView Class
Eco.Web.UI.WebControls Namespace


EcoDataSourceView.SupportSorting Property

EcoDataSourceView.SupportSorting Property
EcoDataSourceView Class Eco.Web.UI.WebControls Namespace See Also
Collapse All
C#
public bool SupportSorting;
Remarks

This is SupportSorting, a member of class EcoDataSourceView.

See Also
EcoDataSourceView Class
Eco.Web.UI.WebControls Namespace


EcoDataSourceView.TranslateNullToEmptyString Property

EcoDataSourceView.TranslateNullToEmptyString Property
EcoDataSourceView Class Eco.Web.UI.WebControls Namespace See Also
Collapse All
C#
public bool TranslateNullToEmptyString;
Remarks

This is TranslateNullToEmptyString, a member of class EcoDataSourceView.

See Also
EcoDataSourceView Class
Eco.Web.UI.WebControls Namespace


EcoDataSourceView.TypedList Property

EcoDataSourceView.TypedList Property
EcoDataSourceView Class Eco.Web.UI.WebControls Namespace See Also
Collapse All
C#
public ITypedList TypedList;
Remarks

Only usable for schema-information

See Also
EcoDataSourceView Class
Eco.Web.UI.WebControls Namespace


EcoDataSourceView.TypeSystem Property

EcoDataSourceView.TypeSystem Property
EcoDataSourceView Class Eco.Web.UI.WebControls Namespace See Also
Collapse All
C#
public IEcoTypeSystem TypeSystem;
Remarks

This is TypeSystem, a member of class EcoDataSourceView.

See Also
EcoDataSourceView Class
Eco.Web.UI.WebControls Namespace


EcoDataSourceView.ValidateRowOnInsert Property

EcoDataSourceView.ValidateRowOnInsert Property
EcoDataSourceView Class Eco.Web.UI.WebControls Namespace See Also
Collapse All
C#
public bool ValidateRowOnInsert;
Remarks

This is ValidateRowOnInsert, a member of class EcoDataSourceView.

See Also
EcoDataSourceView Class
Eco.Web.UI.WebControls Namespace


EcoDataSourceView.ValidateRowOnUpdate Property

EcoDataSourceView.ValidateRowOnUpdate Property
EcoDataSourceView Class Eco.Web.UI.WebControls Namespace See Also
Collapse All
C#
public bool ValidateRowOnUpdate;
Remarks

This is ValidateRowOnUpdate, a member of class EcoDataSourceView.

See Also
EcoDataSourceView Class
Eco.Web.UI.WebControls Namespace


EcoDataSourceView Events

EcoDataSourceView Events
Public Events
Collapse All

The events of the EcoDataSourceView class are listed here.

Public Events
Name | Description
Deleted | This is Deleted, a member of class EcoDataSourceView.
Deleting | This is Deleting, a member of class EcoDataSourceView.
DeriveValue | This is DeriveValue, a member of class EcoDataSourceView.
Inserted | This is Inserted, a member of class EcoDataSourceView.
Inserting | This is Inserting, a member of class EcoDataSourceView.
ReverseDeriveValue | This is ReverseDeriveValue, a member of class EcoDataSourceView.
Selected | This is Selected, a member of class EcoDataSourceView.
Selecting | This is Selecting, a member of class EcoDataSourceView.
Updated | This is Updated, a member of class EcoDataSourceView.
Updating | This is Updating, a member of class EcoDataSourceView.
ValidatingRow | This is ValidatingRow, a member of class EcoDataSourceView.


EcoDataSourceView.Deleted Event

EcoDataSourceView.Deleted Event
EcoDataSourceView Class Eco.Web.UI.WebControls Namespace See Also
Collapse All
C#
public event EcoDataSourceStatusEventHandler Deleted;
Remarks

This is Deleted, a member of class EcoDataSourceView.

See Also
EcoDataSourceView Class
Eco.Web.UI.WebControls Namespace


EcoDataSourceView.Deleting Event

EcoDataSourceView.Deleting Event
EcoDataSourceView Class Eco.Web.UI.WebControls Namespace See Also
Collapse All
C#
public event EcoDataSourceObjectEventHandler Deleting;
Remarks

This is Deleting, a member of class EcoDataSourceView.

See Also
EcoDataSourceView Class
Eco.Web.UI.WebControls Namespace


EcoDataSourceView.DeriveValue Event

EcoDataSourceView.DeriveValue Event
EcoDataSourceView Class Eco.Web.UI.WebControls Namespace See Also
Collapse All
C#
public event DeriveEventHandler DeriveValue;
Remarks

This is DeriveValue, a member of class EcoDataSourceView.

See Also
EcoDataSourceView Class
Eco.Web.UI.WebControls Namespace


EcoDataSourceView.Inserted Event

EcoDataSourceView.Inserted Event
EcoDataSourceView Class Eco.Web.UI.WebControls Namespace See Also
Collapse All
C#
public event EcoDataSourceStatusEventHandler Inserted;
Remarks

This is Inserted, a member of class EcoDataSourceView.

See Also
EcoDataSourceView Class
Eco.Web.UI.WebControls Namespace


EcoDataSourceView.Inserting Event

EcoDataSourceView.Inserting Event
EcoDataSourceView Class Eco.Web.UI.WebControls Namespace See Also
Collapse All
C#
public event EcoDataSourceInsertingEventHandler Inserting;
Remarks

This is Inserting, a member of class EcoDataSourceView.

See Also
EcoDataSourceView Class
Eco.Web.UI.WebControls Namespace


EcoDataSourceView.ReverseDeriveValue Event

EcoDataSourceView.ReverseDeriveValue Event
EcoDataSourceView Class Eco.Web.UI.WebControls Namespace See Also
Collapse All
C#
public event ReverseDeriveEventHandler ReverseDeriveValue;
Remarks

This is ReverseDeriveValue, a member of class EcoDataSourceView.

See Also
EcoDataSourceView Class
Eco.Web.UI.WebControls Namespace


EcoDataSourceView.Selected Event

EcoDataSourceView.Selected Event
EcoDataSourceView Class Eco.Web.UI.WebControls Namespace See Also
Collapse All
C#
public event EcoDataSourceStatusEventHandler Selected;
Remarks

This is Selected, a member of class EcoDataSourceView.

See Also
EcoDataSourceView Class
Eco.Web.UI.WebControls Namespace


EcoDataSourceView.Selecting Event

EcoDataSourceView.Selecting Event
EcoDataSourceView Class Eco.Web.UI.WebControls Namespace See Also
Collapse All
C#
public event EcoDataSourceSelectingEventHandler Selecting;
Remarks

This is Selecting, a member of class EcoDataSourceView.

See Also
EcoDataSourceView Class
Eco.Web.UI.WebControls Namespace


EcoDataSourceView.Updated Event

EcoDataSourceView.Updated Event
EcoDataSourceView Class Eco.Web.UI.WebControls Namespace See Also
Collapse All
C#
public event EcoDataSourceStatusEventHandler Updated;
Remarks

This is Updated, a member of class EcoDataSourceView.

See Also
EcoDataSourceView Class
Eco.Web.UI.WebControls Namespace


EcoDataSourceView.Updating Event

EcoDataSourceView.Updating Event
EcoDataSourceView Class Eco.Web.UI.WebControls Namespace See Also
Collapse All
C#
public event EcoDataSourceObjectEventHandler Updating;
Remarks

This is Updating, a member of class EcoDataSourceView.

See Also
EcoDataSourceView Class
Eco.Web.UI.WebControls Namespace


EcoDataSourceView.ValidatingRow Event

EcoDataSourceView.ValidatingRow Event
EcoDataSourceView Class Eco.Web.UI.WebControls Namespace See Also
Collapse All
C#
public event EcoDataSourceObjectEventHandler ValidatingRow;
Remarks

This is ValidatingRow, a member of class EcoDataSourceView.

See Also
EcoDataSourceView Class
Eco.Web.UI.WebControls Namespace


EcoSpaceManager Class

EcoSpaceManager Class
Inheritance Hierarchy Related Topics See Also
Collapse All

Provides and EcoSpace instance of the specified type for use on a web page.

C#
public class EcoSpaceManager : Control;
Remarks

The EcoSpace manager provides an EcoSpace instance for use on a WEB page. It is mainly intended to be used by the EcoDataSource component although the EcoSpace instance may also be obtained programmatically, using the EcoSpace property. The EcoSpaceManager uses a EcoSpaceStrategyHandler to determine how to retrieve/return the EcoSpace instance, the handing of this is determined by SessionStateMode.

EcoSpaceManager is a System.Web.UI.Control with no visual representation at runtime, allowing it to store values into the page’s view state.

Notes

Unlike other ECO handles the EcoSpaceManager and EcoDataSource can (and should) be used on a regular ASP.Net page with no ECO specific template code.

Related Topics

EcoDataSource

Inheritance Hierarchy
Eco.Web.UI.WebControls.EcoSpaceManager
File

EcoSpaceManager.cs

See Also
Inheritance Hierarchy
Related Topics


EcoSpaceManager Methods

EcoSpaceManager Methods
Protected Methods Public Methods
Collapse All

The methods of the EcoSpaceManager class are listed here.

Protected Methods
Name | Description
CreateControlCollection | This is CreateControlCollection, a member of class EcoSpaceManager.
OnUnload | Override of base.OnUnload()
Top
Public Methods
Name | Description
ApplyStyleSheetSkin | This is ApplyStyleSheetSkin, a member of class EcoSpaceManager.
ClearSessionState | Clears the session state of the EcoSpace.
FindControl | This is FindControl, a member of class EcoSpaceManager.
Focus | This is Focus, a member of class EcoSpaceManager.
GetEcoService | This is GetEcoService, a member of class EcoSpaceManager.
HasControls | This is HasControls, a member of class EcoSpaceManager.
RenderControl | This is RenderControl, a member of class EcoSpaceManager.
UpdateDatabase | Updates the changes in the EcoSpace cache to its persistence storage.


EcoSpaceManager.ApplyStyleSheetSkin Method

EcoSpaceManager.ApplyStyleSheetSkin Method
EcoSpaceManager Class Eco.Web.UI.WebControls Namespace See Also
Collapse All
C#
public override void ApplyStyleSheetSkin(
    Page page
);
Remarks

This is ApplyStyleSheetSkin, a member of class EcoSpaceManager.

See Also
EcoSpaceManager Class
Eco.Web.UI.WebControls Namespace


EcoSpaceManager.ClearSessionState Method

EcoSpaceManager.ClearSessionState Method
EcoSpaceManager Class Eco.Web.UI.WebControls Namespace See Also
Collapse All

Clears the session state of the EcoSpace.

C#
public void ClearSessionState();
Remarks

If there is an EcoSpace stored in SessionState it will be removed. If it is not dirty, it will returned to the pool, otherwise the changes within it will be discarded.

See Also
EcoSpaceManager Class
Eco.Web.UI.WebControls Namespace


EcoSpaceManager.CreateControlCollection Method

EcoSpaceManager.CreateControlCollection Method
EcoSpaceManager Class Eco.Web.UI.WebControls Namespace See Also
Collapse All
C#
protected override ControlCollection CreateControlCollection();
Remarks

This is CreateControlCollection, a member of class EcoSpaceManager.

See Also
EcoSpaceManager Class
Eco.Web.UI.WebControls Namespace


EcoSpaceManager.FindControl Method

EcoSpaceManager.FindControl Method
EcoSpaceManager Class Eco.Web.UI.WebControls Namespace See Also
Collapse All
C#
public override Control FindControl(
    string id
);
Remarks

This is FindControl, a member of class EcoSpaceManager.

See Also
EcoSpaceManager Class
Eco.Web.UI.WebControls Namespace


EcoSpaceManager.Focus Method

EcoSpaceManager.Focus Method
EcoSpaceManager Class Eco.Web.UI.WebControls Namespace See Also
Collapse All
C#
public override void Focus();
Remarks

This is Focus, a member of class EcoSpaceManager.

See Also
EcoSpaceManager Class
Eco.Web.UI.WebControls Namespace


EcoSpaceManager.GetEcoService Method

EcoSpaceManager.GetEcoService Method
EcoSpaceManager Class Eco.Web.UI.WebControls Namespace See Also
Collapse All
C#
public T GetEcoService<T>() where T : class;
Remarks

This is GetEcoService, a member of class EcoSpaceManager.

See Also
EcoSpaceManager Class
Eco.Web.UI.WebControls Namespace


EcoSpaceManager.HasControls Method

EcoSpaceManager.HasControls Method
EcoSpaceManager Class Eco.Web.UI.WebControls Namespace See Also
Collapse All
C#
public override bool HasControls();
Remarks

This is HasControls, a member of class EcoSpaceManager.

See Also
EcoSpaceManager Class
Eco.Web.UI.WebControls Namespace


EcoSpaceManager.OnUnload Method

EcoSpaceManager.OnUnload Method
EcoSpaceManager Class Eco.Web.UI.WebControls Namespace See Also
Collapse All

Override of base.OnUnload()

C#
protected override void OnUnload(
    EventArgs e
);
Remarks

Will return the EcoSpace when the control is unloaded.

See Also
EcoSpaceManager Class
Eco.Web.UI.WebControls Namespace


EcoSpaceManager.RenderControl Method

EcoSpaceManager.RenderControl Method
EcoSpaceManager Class Eco.Web.UI.WebControls Namespace See Also
Collapse All
C#
public override void RenderControl(
    HtmlTextWriter writer
);
Remarks

This is RenderControl, a member of class EcoSpaceManager.

See Also
EcoSpaceManager Class
Eco.Web.UI.WebControls Namespace


EcoSpaceManager.UpdateDatabase Method

EcoSpaceManager.UpdateDatabase Method
EcoSpaceManager Class Eco.Web.UI.WebControls Namespace See Also
Collapse All

Updates the changes in the EcoSpace cache to its persistence storage.

C#
public void UpdateDatabase();
Remarks

This method is mostly used in event-handlers that manipulate the EcoSpace, for example by creating or deleting objets.

When the DataSource data binding is used, this method is called autmatically, unless EcoDataSource.ManualUpdate is set to true.

See Also
EcoSpaceManager Class
Eco.Web.UI.WebControls Namespace


EcoSpaceManager Properties

EcoSpaceManager Properties
Public Properties
Collapse All

The properties of the EcoSpaceManager class are listed here.

Public Properties
Name | Description
ClientID | Properties
Controls | This is Controls, a member of class EcoSpaceManager.
EcoSpace | The EcoSpace instance provided by the EcoSpaceManager.
EcoSpaceType | The System.Type of the EcoSpace provided by the EcoSpaceManager.
EcoSpaceTypeName | The name of the type of the EcoSpace to be provided by the EcoSpaceManager.
EnableTheming | This is EnableTheming, a member of class EcoSpaceManager.
EnsuredEcoSpaceType | This is EnsuredEcoSpaceType, a member of class EcoSpaceManager.
SessionStateKey | The key to use for the EcoSpace in SessionState
SessionStateMode | The seesion state mode
SkinID | This is SkinID, a member of class EcoSpaceManager.
UsePool | Use EcoSpace pool if enabled in Web.config
Visible | This is Visible, a member of class EcoSpaceManager.


EcoSpaceManager.ClientID Property

EcoSpaceManager.ClientID Property
EcoSpaceManager Class Eco.Web.UI.WebControls Namespace See Also
Collapse All
C#
public override string ClientID;
Remarks

Properties

See Also
EcoSpaceManager Class
Eco.Web.UI.WebControls Namespace


EcoSpaceManager.Controls Property

EcoSpaceManager.Controls Property
EcoSpaceManager Class Eco.Web.UI.WebControls Namespace See Also
Collapse All
C#
public override ControlCollection Controls;
Remarks

This is Controls, a member of class EcoSpaceManager.

See Also
EcoSpaceManager Class
Eco.Web.UI.WebControls Namespace


EcoSpaceManager.EcoSpace Property

EcoSpaceManager.EcoSpace Property
EcoSpaceManager Class Eco.Web.UI.WebControls Namespace Related Topics See Also
Collapse All

The EcoSpace instance provided by the EcoSpaceManager.

C#
public EcoSpace EcoSpace;
Remarks

This property will be an EcoSpace instance of the type defined by EcoSpaceTypeName. This instace will be retrieved the first time the property is read, and returned when the EcoSpaceManager is unloaded. The handling of the instance is determined by SessionStateMode. It is permissable to change the value of SeesionStateMode after the EcoSpace has been retrieved, and prior to UnLoading the page.

Related Topics

EcoSpaceTypeName

See Also
EcoSpaceManager Class
Eco.Web.UI.WebControls Namespace
Related Topics


EcoSpaceManager.EcoSpaceType Property

EcoSpaceManager.EcoSpaceType Property
EcoSpaceManager Class Eco.Web.UI.WebControls Namespace Related Topics See Also
Collapse All

The System.Type of the EcoSpace provided by the EcoSpaceManager.

C#
public System.Type EcoSpaceType;
Remarks

The value is determined by the EcoSpaceTypeName, and is available both at runtime and at designtime.

Related Topics

EcoSpaceTypeName

See Also
EcoSpaceManager Class
Eco.Web.UI.WebControls Namespace
Related Topics


EcoSpaceManager.EcoSpaceTypeName Property

EcoSpaceManager.EcoSpaceTypeName Property
EcoSpaceManager Class Eco.Web.UI.WebControls Namespace Related Topics See Also
Collapse All

The name of the type of the EcoSpace to be provided by the EcoSpaceManager.

C#
public string EcoSpaceTypeName;
Related Topics

EcoSpaceType, EcoSpace

See Also
EcoSpaceManager Class
Eco.Web.UI.WebControls Namespace
Related Topics


EcoSpaceManager.EnableTheming Property

EcoSpaceManager.EnableTheming Property
EcoSpaceManager Class Eco.Web.UI.WebControls Namespace See Also
Collapse All
C#
public override bool EnableTheming;
Remarks

This is EnableTheming, a member of class EcoSpaceManager.

See Also
EcoSpaceManager Class
Eco.Web.UI.WebControls Namespace


EcoSpaceManager.EnsuredEcoSpaceType Property

EcoSpaceManager.EnsuredEcoSpaceType Property
EcoSpaceManager Class Eco.Web.UI.WebControls Namespace See Also
Collapse All
C#
public System.Type EnsuredEcoSpaceType;
Remarks

This is EnsuredEcoSpaceType, a member of class EcoSpaceManager.

See Also
EcoSpaceManager Class
Eco.Web.UI.WebControls Namespace


EcoSpaceManager.SessionStateKey Property

EcoSpaceManager.SessionStateKey Property
EcoSpaceManager Class Eco.Web.UI.WebControls Namespace See Also
Collapse All

The key to use for the EcoSpace in SessionState

C#
public string SessionStateKey;
Remarks

This value specified the Key that will be used to store the EcoSpace in SessionState if SessionStateMode is not equal to SessionStateMode.Never. The default value will be the same as the value in the EcoSpaceTypeName property. You should not need to change the value of this property unless you intend to store more than one EcoSpace instance in the current user’s session at the same time.

See Also
EcoSpaceManager Class
Eco.Web.UI.WebControls Namespace


EcoSpaceManager.SessionStateMode Property

EcoSpaceManager.SessionStateMode Property
EcoSpaceManager Class Eco.Web.UI.WebControls Namespace See Also
Collapse All

The seesion state mode

C#
public EcoSpaceStrategyHandler.SessionStateMode SessionStateMode;
Remarks

The session state mode determines what will happen to the EcoSpace instance when the form is UnLoaded.

See Also
EcoSpaceManager Class
Eco.Web.UI.WebControls Namespace


EcoSpaceManager.SkinID Property

EcoSpaceManager.SkinID Property
EcoSpaceManager Class Eco.Web.UI.WebControls Namespace See Also
Collapse All
C#
public override string SkinID;
Remarks

This is SkinID, a member of class EcoSpaceManager.

See Also
EcoSpaceManager Class
Eco.Web.UI.WebControls Namespace


EcoSpaceManager.UsePool Property

EcoSpaceManager.UsePool Property
EcoSpaceManager Class Eco.Web.UI.WebControls Namespace See Also
Collapse All

Use EcoSpace pool if enabled in Web.config

C#
public bool UsePool;
Remarks

If theis value is true the EcoSpace will be taken from, and returned to the EcoSpace pool, provided that Eco.Web.MaxPool has been set to a value >0 in Web.config

See Also
EcoSpaceManager Class
Eco.Web.UI.WebControls Namespace


EcoSpaceManager.Visible Property

EcoSpaceManager.Visible Property
EcoSpaceManager Class Eco.Web.UI.WebControls Namespace See Also
Collapse All
C#
public override bool Visible;
Remarks

This is Visible, a member of class EcoSpaceManager.

See Also
EcoSpaceManager Class
Eco.Web.UI.WebControls Namespace


EcoSpaceManager Events

EcoSpaceManager Events
Public Events
Collapse All

The events of the EcoSpaceManager class are listed here.

Public Events
Name | Description
GetEcoSpace | Define this event if you need to override how the ecospace is created.


EcoSpaceManager.GetEcoSpace Event

EcoSpaceManager.GetEcoSpace Event
EcoSpaceManager Class Eco.Web.UI.WebControls Namespace See Also
Collapse All

Define this event if you need to override how the ecospace is created.

C#
public event GetEcoSpaceDelegate GetEcoSpace;
See Also
EcoSpaceManager Class
Eco.Web.UI.WebControls Namespace


EcoSpaceManagerBuilder Class

EcoSpaceManagerBuilder Class
Inheritance Hierarchy See Also
Collapse All

Supports the page parser in building the EcoSpaceManager control.

C#
public sealed class EcoSpaceManagerBuilder : System.Web.UI.ControlBuilder;
Remarks

Overrides EcoSpaceManagerBuilder.AllowWhitespaceLiterals() to ensure that whitespace is trimmed from the content.

Inheritance Hierarchy
Eco.Web.UI.WebControls.EcoSpaceManagerBuilder
File

EcoSpaceManager.cs

See Also
Inheritance Hierarchy


EcoSpaceManagerBuilder Methods

EcoSpaceManagerBuilder Methods
Public Methods
Collapse All

The methods of the EcoSpaceManagerBuilder class are listed here.

Public Methods
Name | Description
AllowWhitespaceLiterals | Determines whether white-space literals are permitted in the content between a control's opening and closing tags.


EcoSpaceManagerBuilder.AllowWhitespaceLiterals Method

EcoSpaceManagerBuilder.AllowWhitespaceLiterals Method
EcoSpaceManagerBuilder Class Eco.Web.UI.WebControls Namespace See Also
Collapse All

Determines whether white-space literals are permitted in the content between a control's opening and closing tags.

C#
public override bool AllowWhitespaceLiterals();
Remarks

Always return false, ensuring that whitespace is trimmed by parser.

See Also
EcoSpaceManagerBuilder Class
Eco.Web.UI.WebControls Namespace


EcoSpaceManagerIDConverter Class

EcoSpaceManagerIDConverter Class
Inheritance Hierarchy See Also
Collapse All

Type converter that retrieves a list of EcoSpaceManager IDs in the current container as the value of TypeConverter.StandardValuesCollection.

C#
public sealed class EcoSpaceManagerIDConverter : ControlIDConverter;
Remarks

Overrides FilterControl(Control) Filtering out EcoSpaceManager IDs only.

Inheritance Hierarchy
Eco.Web.UI.WebControls.EcoSpaceManagerIDConverter
File

EcoSpaceManager.cs

See Also
Inheritance Hierarchy


EcoSpaceManagerIDConverter Methods

EcoSpaceManagerIDConverter Methods
Protected Methods
Collapse All

The methods of the EcoSpaceManagerIDConverter class are listed here.

Protected Methods
Name | Description
FilterControl | Determines if a control should be included in TypeConverter.StandardValuesCollection.


EcoSpaceManagerIDConverter.FilterControl Method

EcoSpaceManagerIDConverter.FilterControl Method
EcoSpaceManagerIDConverter Class Eco.Web.UI.WebControls Namespace See Also
Collapse All

Determines if a control should be included in TypeConverter.StandardValuesCollection.

C#
protected override bool FilterControl(
    Control control
);
Parameters
Parameters | Description
control | The control to test for inclusion in TypeConverter.StandardValuesCollection.
See Also
EcoSpaceManagerIDConverter Class
Eco.Web.UI.WebControls Namespace


EventDerivedColumn Class

EventDerivedColumn Class
Inheritance Hierarchy See Also
Collapse All
C#
public sealed class EventDerivedColumn : AbstractColumn, IHasTypeSystem;
Remarks

This is class Eco.Web.UI.WebControls.EventDerivedColumn.

Inheritance Hierarchy
Eco.Web.UI.WebControls.AbstractColumn
    Eco.Web.UI.WebControls.EventDerivedColumn
File

EcoDataSourceColumns.cs

See Also
Inheritance Hierarchy


EventDerivedColumn Methods

EventDerivedColumn Methods
Protected Methods
Collapse All

The methods of the EventDerivedColumn class are listed here.

Protected Methods
Name | Description
CopyProperties | This is CopyProperties, a member of class EventDerivedColumn.
CreateColumn | This is CreateColumn, a member of class EventDerivedColumn.


EventDerivedColumn.CopyProperties Method

EventDerivedColumn.CopyProperties Method
EventDerivedColumn Class Eco.Web.UI.WebControls Namespace See Also
Collapse All
C#
protected override void CopyProperties(
    AbstractColumn newColumn
);
Remarks

This is CopyProperties, a member of class EventDerivedColumn.

See Also
EventDerivedColumn Class
Eco.Web.UI.WebControls Namespace


EventDerivedColumn.CreateColumn Method

EventDerivedColumn.CreateColumn Method
EventDerivedColumn Class Eco.Web.UI.WebControls Namespace See Also
Collapse All
C#
protected override AbstractColumn CreateColumn();
Remarks

This is CreateColumn, a member of class EventDerivedColumn.

See Also
EventDerivedColumn Class
Eco.Web.UI.WebControls Namespace


EventDerivedColumn.EventDerivedValue Property

EventDerivedColumn.EventDerivedValue Property
EventDerivedColumn Class Eco.Web.UI.WebControls Namespace See Also
Collapse All

The property EventDerivedValue is not settable in the class EventDerivedColumn. It is always true.

C#
public override bool EventDerivedValue;
See Also
EventDerivedColumn Class
Eco.Web.UI.WebControls Namespace


EventDerivedColumn.Expression Property

EventDerivedColumn.Expression Property
EventDerivedColumn Class Eco.Web.UI.WebControls Namespace See Also
Collapse All

The property Expression is not settable in the class EventDerivedColumn. For a column deriving its value using an OCL expression, use an OclColumn.

C#
public override string Expression;
See Also
EventDerivedColumn Class
Eco.Web.UI.WebControls Namespace


EventDerivedColumn.NullElementRepresentation Property

EventDerivedColumn.NullElementRepresentation Property
EventDerivedColumn Class Eco.Web.UI.WebControls Namespace See Also
Collapse All

The property NullElementRepresentation is not settable in the class EventDerivedColumn.

C#
public override string NullElementRepresentation;
See Also
EventDerivedColumn Class
Eco.Web.UI.WebControls Namespace


EventDerivedColumn.TypeName Property

EventDerivedColumn.TypeName Property
EventDerivedColumn Class Eco.Web.UI.WebControls Namespace See Also
Collapse All

The is the type of the derived value

The eventhandler for ElementHandle.DeriveValue must set e.ResultElement to an element of this type

C#
public override string TypeName;
Remarks

FIXME[LocalizableCategory(typeof(HandlesStringRes), "sCategoryDerivation")] FIXME[LocalizableDescription(typeof(HandlesStringRes), "sPropertyTypeName")]

See Also
EventDerivedColumn Class
Eco.Web.UI.WebControls Namespace


OclColumn Class

OclColumn Class
Inheritance Hierarchy See Also
Collapse All
C#
public sealed class OclColumn : AbstractColumn, IHasEditableExpression, IStaticContext;
Remarks

This is class Eco.Web.UI.WebControls.OclColumn.

Inheritance Hierarchy
Eco.Web.UI.WebControls.AbstractColumn
    Eco.Web.UI.WebControls.OclColumn
File

EcoDataSourceColumns.cs

See Also
Inheritance Hierarchy


OclColumn Methods

OclColumn Methods
Protected Methods
Collapse All

The methods of the OclColumn class are listed here.

Protected Methods
Name | Description
CopyProperties | This is CopyProperties, a member of class OclColumn.
CreateColumn | This is CreateColumn, a member of class OclColumn.


OclColumn.CopyProperties Method

OclColumn.CopyProperties Method
OclColumn Class Eco.Web.UI.WebControls Namespace See Also
Collapse All
C#
protected override void CopyProperties(
    AbstractColumn newColumn
);
Remarks

This is CopyProperties, a member of class OclColumn.

See Also
OclColumn Class
Eco.Web.UI.WebControls Namespace


OclColumn.CreateColumn Method

OclColumn.CreateColumn Method
OclColumn Class Eco.Web.UI.WebControls Namespace See Also
Collapse All
C#
protected override AbstractColumn CreateColumn();
Remarks

This is CreateColumn, a member of class OclColumn.

See Also
OclColumn Class
Eco.Web.UI.WebControls Namespace


OclColumn Properties

OclColumn Properties
Public Properties
Collapse All

The properties of the OclColumn class are listed here.

Public Properties
Name | Description
EventDerivedValue | This property is always false for an OclColumn. For a column deriving its value by an event, use an EventDerivedColumn.
Expression | FIXME[LocalizableCategory(typeof(HandlesStringRes), "sCategoryDerivation") FIXME[LocalizableDescription(typeof(HandlesStringRes), "sPropertyDerivationExpression")
NullElementRepresentation | FIXME[LocalizableCategory(typeof(HandlesStringRes), "sCategoryDerivation") FIXME [LocalizableDescription(typeof(HandlesStringRes), "sPropertyNullElementRepresentation")


OclColumn.EventDerivedValue Property

OclColumn.EventDerivedValue Property
OclColumn Class Eco.Web.UI.WebControls Namespace See Also
Collapse All

This property is always false for an OclColumn. For a column deriving its value by an event, use an EventDerivedColumn.

C#
public override bool EventDerivedValue;
See Also
OclColumn Class
Eco.Web.UI.WebControls Namespace


OclColumn.Expression Property

OclColumn.Expression Property
OclColumn Class Eco.Web.UI.WebControls Namespace See Also
Collapse All
C#
public override string Expression;
Remarks

FIXME[LocalizableCategory(typeof(HandlesStringRes), "sCategoryDerivation") FIXME[LocalizableDescription(typeof(HandlesStringRes), "sPropertyDerivationExpression")

See Also
OclColumn Class
Eco.Web.UI.WebControls Namespace


OclColumn.NullElementRepresentation Property

OclColumn.NullElementRepresentation Property
OclColumn Class Eco.Web.UI.WebControls Namespace See Also
Collapse All
C#
public override string NullElementRepresentation;
Remarks

FIXME[LocalizableCategory(typeof(HandlesStringRes), "sCategoryDerivation") FIXME [LocalizableDescription(typeof(HandlesStringRes), "sPropertyNullElementRepresentation")

See Also
OclColumn Class
Eco.Web.UI.WebControls Namespace


OclParameter Class

OclParameter Class
Inheritance Hierarchy See Also
Collapse All
C#
public class OclParameter : System.Web.UI.WebControls.Parameter;
Remarks

This is class Eco.Web.UI.WebControls.OclParameter.

Inheritance Hierarchy
Eco.Web.UI.WebControls.OclParameter
File

OclParameter.cs

See Also
Inheritance Hierarchy


OclParameter Constructor

OclParameter Constructor

This is the overview for the OclParameter constructor overload.

Overload List
Name | Description
OclParameter.OclParameter () | This is OclParameter, a member of class OclParameter.
OclParameter.OclParameter (OclParameter) | This is OclParameter, a member of class OclParameter.


OclParameter.OclParameter Constructor ()

OclParameter.OclParameter Constructor ()
OclParameter Class Eco.Web.UI.WebControls Namespace See Also
Collapse All
C#
public OclParameter();
Remarks

This is OclParameter, a member of class OclParameter.

See Also
OclParameter Class
Eco.Web.UI.WebControls Namespace


OclParameter.OclParameter Constructor (OclParameter)

OclParameter.OclParameter Constructor (OclParameter)
OclParameter Class Eco.Web.UI.WebControls Namespace See Also
Collapse All
C#
protected OclParameter(
    OclParameter original
);
Remarks

This is OclParameter, a member of class OclParameter.

See Also
OclParameter Class
Eco.Web.UI.WebControls Namespace


OclParameter Methods

OclParameter Methods
Protected Methods
Collapse All

The methods of the OclParameter class are listed here.

Protected Methods
Name | Description
Clone | This is Clone, a member of class OclParameter.
Evaluate | This is Evaluate, a member of class OclParameter.
SaveViewState | This is SaveViewState, a member of class OclParameter.


OclParameter.Clone Method

OclParameter.Clone Method
OclParameter Class Eco.Web.UI.WebControls Namespace See Also
Collapse All
C#
protected override Parameter Clone();
Remarks

This is Clone, a member of class OclParameter.

See Also
OclParameter Class
Eco.Web.UI.WebControls Namespace


OclParameter.Evaluate Method

OclParameter.Evaluate Method
OclParameter Class Eco.Web.UI.WebControls Namespace See Also
Collapse All
C#
protected override object Evaluate(
    HttpContext context,
    Control control
);
Remarks

This is Evaluate, a member of class OclParameter.

See Also
OclParameter Class
Eco.Web.UI.WebControls Namespace


OclParameter.SaveViewState Method

OclParameter.SaveViewState Method
OclParameter Class Eco.Web.UI.WebControls Namespace See Also
Collapse All
C#
protected override object SaveViewState();
Remarks

This is SaveViewState, a member of class OclParameter.

See Also
OclParameter Class
Eco.Web.UI.WebControls Namespace


OclParameter Properties

OclParameter Properties
Public Properties
Collapse All

The properties of the OclParameter class are listed here.

Public Properties
Name | Description
Expression | This is Expression, a member of class OclParameter.


OclParameter.Expression Property

OclParameter.Expression Property
OclParameter Class Eco.Web.UI.WebControls Namespace See Also
Collapse All
C#
public string Expression;
Remarks

This is Expression, a member of class OclParameter.

See Also
OclParameter Class
Eco.Web.UI.WebControls Namespace


RowValidationFailedException Class

RowValidationFailedException Class
Inheritance Hierarchy See Also
Collapse All
C#
public class RowValidationFailedException : Exception;
Remarks

This is class Eco.Web.UI.WebControls.RowValidationFailedException.

Inheritance Hierarchy
Eco.Web.UI.WebControls.RowValidationFailedException
File

EcoDataSourceView.cs

See Also
Inheritance Hierarchy


RowValidationFailedException Constructor

RowValidationFailedException Constructor

This is the overview for the RowValidationFailedException constructor overload.

Overload List
Name | Description
RowValidationFailedException.RowValidationFailedException () | This is RowValidationFailedException, a member of class RowValidationFailedException.
RowValidationFailedException.RowValidationFailedException (SerializationInfo, StreamingContext) | This is RowValidationFailedException, a member of class RowValidationFailedException.
RowValidationFailedException.RowValidationFailedException (string) | This is RowValidationFailedException, a member of class RowValidationFailedException.
RowValidationFailedException.RowValidationFailedException (string, Exception) | This is RowValidationFailedException, a member of class RowValidationFailedException.


RowValidationFailedException.RowValidationFailedException Constructor ()

RowValidationFailedException.RowValidationFailedException Constructor ()
RowValidationFailedException Class Eco.Web.UI.WebControls Namespace See Also
Collapse All
C#
public RowValidationFailedException();
Remarks

This is RowValidationFailedException, a member of class RowValidationFailedException.

See Also
RowValidationFailedException Class
Eco.Web.UI.WebControls Namespace


RowValidationFailedException.RowValidationFailedException Constructor (SerializationInfo, StreamingContext)

RowValidationFailedException.RowValidationFailedException Constructor (SerializationInfo, StreamingContext)
RowValidationFailedException Class Eco.Web.UI.WebControls Namespace See Also
Collapse All
C#
protected RowValidationFailedException(
    SerializationInfo info,
    StreamingContext context
);
Remarks

This is RowValidationFailedException, a member of class RowValidationFailedException.

See Also
RowValidationFailedException Class
Eco.Web.UI.WebControls Namespace


RowValidationFailedException.RowValidationFailedException Constructor (string)

RowValidationFailedException.RowValidationFailedException Constructor (string)
RowValidationFailedException Class Eco.Web.UI.WebControls Namespace See Also
Collapse All
C#
public RowValidationFailedException(
    string message
);
Remarks

This is RowValidationFailedException, a member of class RowValidationFailedException.

See Also
RowValidationFailedException Class
Eco.Web.UI.WebControls Namespace


RowValidationFailedException.RowValidationFailedException Constructor (string, Exception)

RowValidationFailedException.RowValidationFailedException Constructor (string, Exception)
RowValidationFailedException Class Eco.Web.UI.WebControls Namespace See Also
Collapse All
C#
public RowValidationFailedException(
    string message,
    Exception inner
);
Remarks

This is RowValidationFailedException, a member of class RowValidationFailedException.

See Also
RowValidationFailedException Class
Eco.Web.UI.WebControls Namespace


Eco.Web.UI.WebControls.DeleteMode Enumeration

Eco.Web.UI.WebControls.DeleteMode Enumeration
Related Topics See Also
Collapse All

Specifies the action to perform when an object is deleted.

C#
public enum DeleteMode {
  Disallow,
  Delete,
  Unlink
}
Members
Members | Description
Disallow | Deletion will not be permitted.
Delete | Deleting the row in the EcoDataSource will result in the corresponding ECO object instance being deleted.
Unlink | Remove the object from the list.
Related Topics

EcoDataSource

File

EcoDataSource.cs

See Also
Related Topics


Eco.Web.UI.WebControls.InsertMode Enumeration

Eco.Web.UI.WebControls.InsertMode Enumeration

Action to perform when Insert is called on a EcoDataSource

C#
public enum InsertMode {
  Disallow,
  AddNew,
  CreateNew
}
Members
Members | Description
Disallow | No inserts will be permitted.
AddNew | Executes Eco.ObjectRepresentation.IObjectList.AddNew
CreateNew | Creates a new EcoObject of the same type as the objects in the List but does not add it to the list.
File

EcoDataSource.cs


Eco.Web.UI.WebControls.EcoDataSourceInsertingEventHandler Type

Eco.Web.UI.WebControls.EcoDataSourceInsertingEventHandler Type
Collapse All
C#
public delegate void EcoDataSourceInsertingEventHandler(object sender, CancelEventArgs e);
Remarks

This is type Eco.Web.UI.WebControls.EcoDataSourceInsertingEventHandler.

File

EcoDataSourceView.cs


Eco.Web.UI.WebControls.EcoDataSourceObjectEventHandler Type

Eco.Web.UI.WebControls.EcoDataSourceObjectEventHandler Type
C#
public delegate void EcoDataSourceObjectEventHandler(object sender, EcoDataSourceObjectEventArgs e);
Remarks

This is type Eco.Web.UI.WebControls.EcoDataSourceObjectEventHandler.

File

EcoDataSourceView.cs


Eco.Web.UI.WebControls.EcoDataSourceSelectingEventHandler Type

Eco.Web.UI.WebControls.EcoDataSourceSelectingEventHandler Type
Collapse All
C#
public delegate void EcoDataSourceSelectingEventHandler(object sender, EcoDataSourceSelectingEventArgs e);
Remarks

This is type Eco.Web.UI.WebControls.EcoDataSourceSelectingEventHandler.

File

EcoDataSourceView.cs


Eco.Web.UI.WebControls.EcoDataSourceStatusEventHandler Type

Eco.Web.UI.WebControls.EcoDataSourceStatusEventHandler Type
C#
public delegate void EcoDataSourceStatusEventHandler(object sender, EcoDataSourceStatusEventArgs e);
Remarks

This is type Eco.Web.UI.WebControls.EcoDataSourceStatusEventHandler.

File

EcoDataSourceView.cs


Eco.Web.UI.WebControls.GetEcoSpaceDelegate Type

Eco.Web.UI.WebControls.GetEcoSpaceDelegate Type
C#
public delegate EcoSpace GetEcoSpaceDelegate(EcoSpaceStrategyHandler strategyHandler);
Remarks

This is type Eco.Web.UI.WebControls.GetEcoSpaceDelegate.

File

EcoSpaceManager.cs


Eco.Windows.Forms Namespace

Eco.Windows.Forms Namespace
Classes Interfaces
Collapse All

This is namespace Eco.Windows.Forms.

Classes
Name | Description
ClassAndOclDebuggerPanel | This class form part of the EcoSpace debugger. It is not intended to be used directly.
ConfigureCleanPSForm | This is class Eco.Windows.Forms.ConfigureCleanPSForm.
ConstraintInfoBuilder | This class builds a CheckedListBox on a surface. It is used by the DefaultAutoForm but can be used stand alone if there is need to quickly get a UI representations of the constraints of an object.
ControlBuilder | This class builds controls representing the members (attributes and single association ends) on a surface. It is used by the DefaultAutoForm but can be used stand alone if there is need to quickly get a UI representations of an object.
DBEvolutionForm | Summary description for DBEvolutionForm.
DirtyObjectsDebuggerPanel | This class form part of the EcoSpace debugger. It is not intended to be used directly.
EcoSpaceDebugger | Host form for the debugger plugin panels.
ErrorHandler | this exception handler must be installed prior to Application.Run: [STAThreadAttribute] public static void Main() { WinFormDequeuer.Active = true; Eco.Diagnostics.ErrorHandler.InstallExceptionHandler(); System.Windows.Forms.Application.Run(new MainForm());
FormBasedConfigureCleanPS | Implementor of IConfigureCleanPS, wraps a GUI form
FormsStringRes | Autogenerated class to get compiler safe access to resource strings.
LoggerDebuggerPanel | This class form part of the EcoSpace debugger. It is not intended to be used directly.
MethodCallBuilder | This class builds controls representing the method members of a type on a surface. It is used by the DefaultAutoForm but can be used stand alone if there is need to quickly get a UI representations of an object's methods.
MultilinkBuilder | This class builds controls representing a multi link member on a surface. It is used by the DefaultAutoForm but can be used stand alone if there is need to quickly get a UI representations of an object's multilink.
MyNumericUpDown | This is class Eco.Windows.Forms.MyNumericUpDown.
OclEditor | Summary description for OclEditor.
StatePageBuilder | This class builds controls representing the state machines of a type on a surface. It is used by the DefaultAutoForm but can be used stand alone if there is need to quickly get a UI representations of an object's state machine and valid transitions.
SyncDebuggerPanel | This is class Eco.Windows.Forms.SyncDebuggerPanel.
TriggerControlsRefresher | This is class Eco.Windows.Forms.TriggerControlsRefresher.
UndoDebuggerPanel | This class form part of the EcoSpace debugger. It is not intended to be used directly.
WinFormDequeuer | The WinFormDequeuer makes sure the presentation layer (UI layer) is updated with the information in the objects. This is done by hooking into the OnIdle loop where the static method ElementHandle.EnsureAllBindingLists is called. This class cannot be instantiated. Its only property, Active is static.
Top
Interfaces
Name | Description
IEcoSpaceDebuggerPanel | This is class Eco.Windows.Forms.IEcoSpaceDebuggerPanel.


ClassAndOclDebuggerPanel Class

ClassAndOclDebuggerPanel Class
Inheritance Hierarchy See Also
Collapse All

This class form part of the EcoSpace debugger. It is not intended to be used directly.

C#
public class ClassAndOclDebuggerPanel : System.Windows.Forms.Form, IEcoSpaceDebuggerPanel;
Inheritance Hierarchy
Eco.Windows.Forms.IEcoSpaceDebuggerPanel
System.Windows.Forms.Form
    Eco.Windows.Forms.ClassAndOclDebuggerPanel
File

Eco.Windows.Forms.ClassAndOclDebuggerPanel.cs

See Also
Inheritance Hierarchy


ClassAndOclDebuggerPanel.ClassAndOclDebuggerPanel Constructor

ClassAndOclDebuggerPanel.ClassAndOclDebuggerPanel Constructor
ClassAndOclDebuggerPanel Class Eco.Windows.Forms Namespace See Also
Collapse All
C#
public ClassAndOclDebuggerPanel();
Remarks

This is ClassAndOclDebuggerPanel, a member of class ClassAndOclDebuggerPanel.

See Also
ClassAndOclDebuggerPanel Class
Eco.Windows.Forms Namespace


ClassAndOclDebuggerPanel Fields

ClassAndOclDebuggerPanel Fields
Protected internal Fields
Collapse All

The fields of the ClassAndOclDebuggerPanel class are listed here.

Protected internal Fields
Name | Description
cbUseContext | This is cbUseContext, a member of class ClassAndOclDebuggerPanel.
tbOclExpression | This is tbOclExpression, a member of class ClassAndOclDebuggerPanel.


ClassAndOclDebuggerPanel.cbUseContext Field

ClassAndOclDebuggerPanel.cbUseContext Field
ClassAndOclDebuggerPanel Class Eco.Windows.Forms Namespace See Also
Collapse All
C#
protected internal System.Windows.Forms.CheckBox cbUseContext;
Remarks

This is cbUseContext, a member of class ClassAndOclDebuggerPanel.

See Also
ClassAndOclDebuggerPanel Class
Eco.Windows.Forms Namespace


ClassAndOclDebuggerPanel.tbOclExpression Field

ClassAndOclDebuggerPanel.tbOclExpression Field
ClassAndOclDebuggerPanel Class Eco.Windows.Forms Namespace See Also
Collapse All
C#
protected internal System.Windows.Forms.TextBox tbOclExpression;
Remarks

This is tbOclExpression, a member of class ClassAndOclDebuggerPanel.

See Also
ClassAndOclDebuggerPanel Class
Eco.Windows.Forms Namespace


ClassAndOclDebuggerPanel Methods

ClassAndOclDebuggerPanel Methods
Protected Methods
Collapse All

The methods of the ClassAndOclDebuggerPanel class are listed here.

Protected Methods
Name | Description
Dispose | Clean up any resources being used.


ClassAndOclDebuggerPanel.Dispose Method

ClassAndOclDebuggerPanel.Dispose Method
ClassAndOclDebuggerPanel Class Eco.Windows.Forms Namespace See Also
Collapse All

Clean up any resources being used.

C#
protected override void Dispose(
    bool disposing
);
See Also
ClassAndOclDebuggerPanel Class
Eco.Windows.Forms Namespace


ClassAndOclDebuggerPanel Properties

ClassAndOclDebuggerPanel Properties
Public Properties
Collapse All

The properties of the ClassAndOclDebuggerPanel class are listed here.

Public Properties
Name | Description
ActionService | This is ActionService, a member of class ClassAndOclDebuggerPanel.
ActiveExpressionService | This is ActiveExpressionService, a member of class ClassAndOclDebuggerPanel.
DirtyListService | This is DirtyListService, a member of class ClassAndOclDebuggerPanel.
EcoSpace | This is EcoSpace, a member of class ClassAndOclDebuggerPanel.
ExpressionIsAction | This is ExpressionIsAction, a member of class ClassAndOclDebuggerPanel.
ExpressionIsOcl | This is ExpressionIsOcl, a member of class ClassAndOclDebuggerPanel.
ExpressionIsOclPS | This is ExpressionIsOclPS, a member of class ClassAndOclDebuggerPanel.
ExtentService | This is ExtentService, a member of class ClassAndOclDebuggerPanel.
ObjectFactoryService | This is ObjectFactoryService, a member of class ClassAndOclDebuggerPanel.
OclExpression | This is OclExpression, a member of class ClassAndOclDebuggerPanel.
OclPsService | This is OclPsService, a member of class ClassAndOclDebuggerPanel.
OclService | This is OclService, a member of class ClassAndOclDebuggerPanel.
PersistenceService | This is PersistenceService, a member of class ClassAndOclDebuggerPanel.
TypeSystemService | This is TypeSystemService, a member of class ClassAndOclDebuggerPanel.
UndoService | This is UndoService, a member of class ClassAndOclDebuggerPanel.
UseContext | This is UseContext, a member of class ClassAndOclDebuggerPanel.
VariableFactoryService | This is VariableFactoryService, a member of class ClassAndOclDebuggerPanel.


ClassAndOclDebuggerPanel.ActionService Property

ClassAndOclDebuggerPanel.ActionService Property
ClassAndOclDebuggerPanel Class Eco.Windows.Forms Namespace See Also
Collapse All
C#
public IActionLanguageService ActionService;
Remarks

This is ActionService, a member of class ClassAndOclDebuggerPanel.

See Also
ClassAndOclDebuggerPanel Class
Eco.Windows.Forms Namespace


ClassAndOclDebuggerPanel.ActiveExpressionService Property

ClassAndOclDebuggerPanel.ActiveExpressionService Property
ClassAndOclDebuggerPanel Class Eco.Windows.Forms Namespace See Also
Collapse All
C#
public ITypeService ActiveExpressionService;
Remarks

This is ActiveExpressionService, a member of class ClassAndOclDebuggerPanel.

See Also
ClassAndOclDebuggerPanel Class
Eco.Windows.Forms Namespace


ClassAndOclDebuggerPanel.DirtyListService Property

ClassAndOclDebuggerPanel.DirtyListService Property
ClassAndOclDebuggerPanel Class Eco.Windows.Forms Namespace See Also
Collapse All
C#
public IDirtyListService DirtyListService;
Remarks

This is DirtyListService, a member of class ClassAndOclDebuggerPanel.

See Also
ClassAndOclDebuggerPanel Class
Eco.Windows.Forms Namespace


ClassAndOclDebuggerPanel.EcoSpace Property

ClassAndOclDebuggerPanel.EcoSpace Property
ClassAndOclDebuggerPanel Class Eco.Windows.Forms Namespace See Also
Collapse All
C#
public Eco.Handles.EcoSpace EcoSpace;
Remarks

This is EcoSpace, a member of class ClassAndOclDebuggerPanel.

See Also
ClassAndOclDebuggerPanel Class
Eco.Windows.Forms Namespace


ClassAndOclDebuggerPanel.ExpressionIsAction Property

ClassAndOclDebuggerPanel.ExpressionIsAction Property
ClassAndOclDebuggerPanel Class Eco.Windows.Forms Namespace See Also
Collapse All
C#
public bool ExpressionIsAction;
Remarks

This is ExpressionIsAction, a member of class ClassAndOclDebuggerPanel.

See Also
ClassAndOclDebuggerPanel Class
Eco.Windows.Forms Namespace


ClassAndOclDebuggerPanel.ExpressionIsOcl Property

ClassAndOclDebuggerPanel.ExpressionIsOcl Property
ClassAndOclDebuggerPanel Class Eco.Windows.Forms Namespace See Also
Collapse All
C#
public bool ExpressionIsOcl;
Remarks

This is ExpressionIsOcl, a member of class ClassAndOclDebuggerPanel.

See Also
ClassAndOclDebuggerPanel Class
Eco.Windows.Forms Namespace


ClassAndOclDebuggerPanel.ExpressionIsOclPS Property

ClassAndOclDebuggerPanel.ExpressionIsOclPS Property
ClassAndOclDebuggerPanel Class Eco.Windows.Forms Namespace See Also
Collapse All
C#
public bool ExpressionIsOclPS;
Remarks

This is ExpressionIsOclPS, a member of class ClassAndOclDebuggerPanel.

See Also
ClassAndOclDebuggerPanel Class
Eco.Windows.Forms Namespace


ClassAndOclDebuggerPanel.ExtentService Property

ClassAndOclDebuggerPanel.ExtentService Property
ClassAndOclDebuggerPanel Class Eco.Windows.Forms Namespace See Also
Collapse All
C#
public IExtentService ExtentService;
Remarks

This is ExtentService, a member of class ClassAndOclDebuggerPanel.

See Also
ClassAndOclDebuggerPanel Class
Eco.Windows.Forms Namespace


ClassAndOclDebuggerPanel.ObjectFactoryService Property

ClassAndOclDebuggerPanel.ObjectFactoryService Property
ClassAndOclDebuggerPanel Class Eco.Windows.Forms Namespace See Also
Collapse All
C#
public IObjectFactoryService ObjectFactoryService;
Remarks

This is ObjectFactoryService, a member of class ClassAndOclDebuggerPanel.

See Also
ClassAndOclDebuggerPanel Class
Eco.Windows.Forms Namespace


ClassAndOclDebuggerPanel.OclExpression Property

ClassAndOclDebuggerPanel.OclExpression Property
ClassAndOclDebuggerPanel Class Eco.Windows.Forms Namespace See Also
Collapse All
C#
public string OclExpression;
Remarks

This is OclExpression, a member of class ClassAndOclDebuggerPanel.

See Also
ClassAndOclDebuggerPanel Class
Eco.Windows.Forms Namespace


ClassAndOclDebuggerPanel.OclPsService Property

ClassAndOclDebuggerPanel.OclPsService Property
ClassAndOclDebuggerPanel Class Eco.Windows.Forms Namespace See Also
Collapse All
C#
public IOclPsService OclPsService;
Remarks

This is OclPsService, a member of class ClassAndOclDebuggerPanel.

See Also
ClassAndOclDebuggerPanel Class
Eco.Windows.Forms Namespace


ClassAndOclDebuggerPanel.OclService Property

ClassAndOclDebuggerPanel.OclService Property
ClassAndOclDebuggerPanel Class Eco.Windows.Forms Namespace See Also
Collapse All
C#
public IOclService OclService;
Remarks

This is OclService, a member of class ClassAndOclDebuggerPanel.

See Also
ClassAndOclDebuggerPanel Class
Eco.Windows.Forms Namespace


ClassAndOclDebuggerPanel.PersistenceService Property

ClassAndOclDebuggerPanel.PersistenceService Property
ClassAndOclDebuggerPanel Class Eco.Windows.Forms Namespace See Also
Collapse All
C#
public IPersistenceService PersistenceService;
Remarks

This is PersistenceService, a member of class ClassAndOclDebuggerPanel.

See Also
ClassAndOclDebuggerPanel Class
Eco.Windows.Forms Namespace


ClassAndOclDebuggerPanel.TypeSystemService Property

ClassAndOclDebuggerPanel.TypeSystemService Property
ClassAndOclDebuggerPanel Class Eco.Windows.Forms Namespace See Also
Collapse All
C#
public ITypeSystemService TypeSystemService;
Remarks

This is TypeSystemService, a member of class ClassAndOclDebuggerPanel.

See Also
ClassAndOclDebuggerPanel Class
Eco.Windows.Forms Namespace


ClassAndOclDebuggerPanel.UndoService Property

ClassAndOclDebuggerPanel.UndoService Property
ClassAndOclDebuggerPanel Class Eco.Windows.Forms Namespace See Also
Collapse All
C#
public IUndoService UndoService;
Remarks

This is UndoService, a member of class ClassAndOclDebuggerPanel.

See Also
ClassAndOclDebuggerPanel Class
Eco.Windows.Forms Namespace


ClassAndOclDebuggerPanel.UseContext Property

ClassAndOclDebuggerPanel.UseContext Property
ClassAndOclDebuggerPanel Class Eco.Windows.Forms Namespace See Also
Collapse All
C#
public bool UseContext;
Remarks

This is UseContext, a member of class ClassAndOclDebuggerPanel.

See Also
ClassAndOclDebuggerPanel Class
Eco.Windows.Forms Namespace


ClassAndOclDebuggerPanel.VariableFactoryService Property

ClassAndOclDebuggerPanel.VariableFactoryService Property
ClassAndOclDebuggerPanel Class Eco.Windows.Forms Namespace See Also
Collapse All
C#
public IVariableFactoryService VariableFactoryService;
Remarks

This is VariableFactoryService, a member of class ClassAndOclDebuggerPanel.

See Also
ClassAndOclDebuggerPanel Class
Eco.Windows.Forms Namespace


ConfigureCleanPSForm Class

ConfigureCleanPSForm Class
Inheritance Hierarchy See Also
Collapse All
C#
public class ConfigureCleanPSForm : System.Windows.Forms.Form;
Remarks

This is class Eco.Windows.Forms.ConfigureCleanPSForm.

Inheritance Hierarchy
System.Windows.Forms.Form
    Eco.Windows.Forms.ConfigureCleanPSForm
File

Eco.Windows.Forms.ConfigureCleanPSForm.cs

See Also
Inheritance Hierarchy


ConfigureCleanPSForm Constructor

ConfigureCleanPSForm Constructor

This is the overview for the ConfigureCleanPSForm constructor overload.

Overload List
Name | Description
ConfigureCleanPSForm.ConfigureCleanPSForm () | This is ConfigureCleanPSForm, a member of class ConfigureCleanPSForm.
ConfigureCleanPSForm.ConfigureCleanPSForm (IServiceProvider) | This is ConfigureCleanPSForm, a member of class ConfigureCleanPSForm.


ConfigureCleanPSForm.ConfigureCleanPSForm Constructor ()

ConfigureCleanPSForm.ConfigureCleanPSForm Constructor ()
ConfigureCleanPSForm Class Eco.Windows.Forms Namespace See Also
Collapse All
C#
public ConfigureCleanPSForm();
Remarks

This is ConfigureCleanPSForm, a member of class ConfigureCleanPSForm.

See Also
ConfigureCleanPSForm Class
Eco.Windows.Forms Namespace


ConfigureCleanPSForm.ConfigureCleanPSForm Constructor (IServiceProvider)

ConfigureCleanPSForm.ConfigureCleanPSForm Constructor (IServiceProvider)
ConfigureCleanPSForm Class Eco.Windows.Forms Namespace See Also
Collapse All
C#
public ConfigureCleanPSForm(
    IServiceProvider serviceProvider
);
Remarks

This is ConfigureCleanPSForm, a member of class ConfigureCleanPSForm.

See Also
ConfigureCleanPSForm Class
Eco.Windows.Forms Namespace


ConfigureCleanPSForm Fields

ConfigureCleanPSForm Fields
Public Fields
Collapse All

The fields of the ConfigureCleanPSForm class are listed here.

Public Fields
Name | Description
btnCancel | This is btnCancel, a member of class ConfigureCleanPSForm.
btnOK | This is btnOK, a member of class ConfigureCleanPSForm.


ConfigureCleanPSForm.btnCancel Field

ConfigureCleanPSForm.btnCancel Field
ConfigureCleanPSForm Class Eco.Windows.Forms Namespace See Also
Collapse All
C#
public System.Windows.Forms.Button btnCancel;
Remarks

This is btnCancel, a member of class ConfigureCleanPSForm.

See Also
ConfigureCleanPSForm Class
Eco.Windows.Forms Namespace


ConfigureCleanPSForm.btnOK Field

ConfigureCleanPSForm.btnOK Field
ConfigureCleanPSForm Class Eco.Windows.Forms Namespace See Also
Collapse All
C#
public System.Windows.Forms.Button btnOK;
Remarks

This is btnOK, a member of class ConfigureCleanPSForm.

See Also
ConfigureCleanPSForm Class
Eco.Windows.Forms Namespace


ConfigureCleanPSForm Methods

ConfigureCleanPSForm Methods
Protected Methods Public Methods
Collapse All

The methods of the ConfigureCleanPSForm class are listed here.

Protected Methods
Name | Description
Dispose | Clean up any resources being used.
Top
Public Methods
Name | Description
AddTableInfo | This is AddTableInfo, a member of class ConfigureCleanPSForm.
TablesToDelete | This is TablesToDelete, a member of class ConfigureCleanPSForm.


ConfigureCleanPSForm.AddTableInfo Method

ConfigureCleanPSForm.AddTableInfo Method
ConfigureCleanPSForm Class Eco.Windows.Forms Namespace See Also
Collapse All
C#
public void AddTableInfo(
    IList<string> allTables,
    IList<string> knownTables,
    IList<string> sqlTables
);
Remarks

This is AddTableInfo, a member of class ConfigureCleanPSForm.

See Also
ConfigureCleanPSForm Class
Eco.Windows.Forms Namespace


ConfigureCleanPSForm.Dispose Method

ConfigureCleanPSForm.Dispose Method
ConfigureCleanPSForm Class Eco.Windows.Forms Namespace See Also
Collapse All

Clean up any resources being used.

C#
protected override void Dispose(
    bool disposing
);
See Also
ConfigureCleanPSForm Class
Eco.Windows.Forms Namespace


ConfigureCleanPSForm.TablesToDelete Method

ConfigureCleanPSForm.TablesToDelete Method
ConfigureCleanPSForm Class Eco.Windows.Forms Namespace See Also
Collapse All
C#
public IList<string> TablesToDelete();
Remarks

This is TablesToDelete, a member of class ConfigureCleanPSForm.

See Also
ConfigureCleanPSForm Class
Eco.Windows.Forms Namespace


ConstraintInfoBuilder Class

ConstraintInfoBuilder Class
Inheritance Hierarchy See Also
Collapse All

This class builds a CheckedListBox on a surface. It is used by the DefaultAutoForm but can be used stand alone if there is need to quickly get a UI representations of the constraints of an object.

C#
public sealed class ConstraintInfoBuilder;
Inheritance Hierarchy
Eco.Windows.Forms.ConstraintInfoBuilder
File

ConstraintInfoBuilder.cs

See Also
Inheritance Hierarchy


ConstraintInfoBuilder Methods

ConstraintInfoBuilder Methods
Public Methods
Collapse All

The methods of the ConstraintInfoBuilder class are listed here.

Public Methods
Name | Description
BuildControls | The handle will be used to find the actual object when the constraint information is displayed/refreshed.
HasConstraints | Returns true if the If the modelElement has more than zero constraints defined.


ConstraintInfoBuilder.BuildControls Method

ConstraintInfoBuilder.BuildControls Method
ConstraintInfoBuilder Class Eco.Windows.Forms Namespace See Also
Collapse All

The handle will be used to find the actual object when the constraint information is displayed/refreshed.

C#
public static void BuildControls(
    Control hostControl,
    ElementHandle handle,
    IModelElement modelElement,
    AutoContainerArgs autoContainerArgs
);
Parameters
Parameters | Description
hostControl | The control used as container for created controls.
handle | The element of the handle is used when determining the actual state of the constraints.
modelElement | The IModelElement used to get the static information of constrains.
autoContainerArgs | Information about how the autocontainer was invoked.
Exceptions
Exceptions | Description
ArgumentNullException | Thrown if handle is null. Thrown if hostControl is null.
See Also
ConstraintInfoBuilder Class
Eco.Windows.Forms Namespace


ConstraintInfoBuilder.HasConstraints Method

ConstraintInfoBuilder.HasConstraints Method
ConstraintInfoBuilder Class Eco.Windows.Forms Namespace See Also
Collapse All

Returns true if the If the modelElement has more than zero constraints defined.

C#
public static bool HasConstraints(
    IModelElement modelElement
);
Exceptions
Exceptions | Description
ArgumentNullException | Thrown if modelElement is null.
See Also
ConstraintInfoBuilder Class
Eco.Windows.Forms Namespace


ControlBuilder Class

ControlBuilder Class
Inheritance Hierarchy See Also
Collapse All

This class builds controls representing the members (attributes and single association ends) on a surface. It is used by the DefaultAutoForm but can be used stand alone if there is need to quickly get a UI representations of an object.

C#
public sealed class ControlBuilder;
Inheritance Hierarchy
Eco.Windows.Forms.ControlBuilder
File

ControlBuilder.cs

See Also
Inheritance Hierarchy


ControlBuilder Classes

ControlBuilder Classes
Classes
Collapse All

The classes of the ControlBuilder class are listed here.

Classes
Name | Description
NavigationalContext | This is class Eco.Windows.Forms.ControlBuilder.NavigationalContext.


ControlBuilder.NavigationalContext Class

ControlBuilder.NavigationalContext Class
Inheritance Hierarchy See Also
Collapse All
C#
public class NavigationalContext;
Remarks

This is class Eco.Windows.Forms.ControlBuilder.NavigationalContext.

Inheritance Hierarchy
Eco.Windows.Forms.ControlBuilder.NavigationalContext
File

ControlBuilder.cs

See Also
Inheritance Hierarchy


ControlBuilder.NavigationalContext.NavigationalContext Constructor

ControlBuilder.NavigationalContext.NavigationalContext Constructor
ControlBuilder.NavigationalContext Class Eco.Windows.Forms Namespace See Also
Collapse All
C#
public NavigationalContext(
    ElementHandle elementHandle,
    string expression,
    AutoContainerArgs autoContainerArgs
);
Remarks

This is NavigationalContext, a member of class NavigationalContext.

See Also
ControlBuilder.NavigationalContext Class
Eco.Windows.Forms Namespace


NavigationalContext Methods

NavigationalContext Methods
Public Methods
Collapse All

The methods of the NavigationalContext class are listed here.

Public Methods
Name | Description
AddToMultiLink | This is AddToMultiLink, a member of class NavigationalContext.
AddToSingleLink | This is AddToSingleLink, a member of class NavigationalContext.
Delete | This is Delete, a member of class NavigationalContext.
GetNavigationalContext | This is GetNavigationalContext, a member of class NavigationalContext.
Navigate | This is Navigate, a member of class NavigationalContext.
Unlink | This is Unlink, a member of class NavigationalContext.


ControlBuilder.NavigationalContext.AddToMultiLink Method

ControlBuilder.NavigationalContext.AddToMultiLink Method
ControlBuilder.NavigationalContext Class Eco.Windows.Forms Namespace See Also
Collapse All
C#
public IObject AddToMultiLink(
    string className
);
Remarks

This is AddToMultiLink, a member of class NavigationalContext.

See Also
ControlBuilder.NavigationalContext Class
Eco.Windows.Forms Namespace


ControlBuilder.NavigationalContext.AddToSingleLink Method

ControlBuilder.NavigationalContext.AddToSingleLink Method
ControlBuilder.NavigationalContext Class Eco.Windows.Forms Namespace See Also
Collapse All
C#
public IObject AddToSingleLink(
    string className
);
Remarks

This is AddToSingleLink, a member of class NavigationalContext.

See Also
ControlBuilder.NavigationalContext Class
Eco.Windows.Forms Namespace


ControlBuilder.NavigationalContext.Delete Method

ControlBuilder.NavigationalContext.Delete Method
ControlBuilder.NavigationalContext Class Eco.Windows.Forms Namespace See Also
Collapse All
C#
public void Delete();
Remarks

This is Delete, a member of class NavigationalContext.

See Also
ControlBuilder.NavigationalContext Class
Eco.Windows.Forms Namespace


ControlBuilder.NavigationalContext.GetNavigationalContext Method

ControlBuilder.NavigationalContext.GetNavigationalContext Method
ControlBuilder.NavigationalContext Class Eco.Windows.Forms Namespace See Also
Collapse All
C#
public static NavigationalContext GetNavigationalContext(
    object sender
);
Remarks

This is GetNavigationalContext, a member of class NavigationalContext.

See Also
ControlBuilder.NavigationalContext Class
Eco.Windows.Forms Namespace


ControlBuilder.NavigationalContext.Navigate Method

ControlBuilder.NavigationalContext.Navigate Method
ControlBuilder.NavigationalContext Class Eco.Windows.Forms Namespace See Also
Collapse All
C#
public void Navigate();
Remarks

This is Navigate, a member of class NavigationalContext.

See Also
ControlBuilder.NavigationalContext Class
Eco.Windows.Forms Namespace


ControlBuilder.NavigationalContext.Unlink Method

ControlBuilder.NavigationalContext.Unlink Method
ControlBuilder.NavigationalContext Class Eco.Windows.Forms Namespace See Also
Collapse All
C#
public void Unlink();
Remarks

This is Unlink, a member of class NavigationalContext.

See Also
ControlBuilder.NavigationalContext Class
Eco.Windows.Forms Namespace


NavigationalContext Properties

NavigationalContext Properties
Public Properties
Collapse All

The properties of the NavigationalContext class are listed here.

Public Properties
Name | Description
Expression | This is Expression, a member of class NavigationalContext.
RootHandle | This is RootHandle, a member of class NavigationalContext.


ControlBuilder.NavigationalContext.Expression Property

ControlBuilder.NavigationalContext.Expression Property
ControlBuilder.NavigationalContext Class Eco.Windows.Forms Namespace See Also
Collapse All
C#
public string Expression;
Remarks

This is Expression, a member of class NavigationalContext.

See Also
ControlBuilder.NavigationalContext Class
Eco.Windows.Forms Namespace


ControlBuilder.NavigationalContext.RootHandle Property

ControlBuilder.NavigationalContext.RootHandle Property
ControlBuilder.NavigationalContext Class Eco.Windows.Forms Namespace See Also
Collapse All
C#
public ElementHandle RootHandle;
Remarks

This is RootHandle, a member of class NavigationalContext.

See Also
ControlBuilder.NavigationalContext Class
Eco.Windows.Forms Namespace


ControlBuilder Methods

ControlBuilder Methods
Public Methods
Collapse All

The methods of the ControlBuilder class are listed here.

Public Methods
Name | Description
BuildControl | Builds a control for a member. The actual control depends of the type of the member.
BuildControls | Builds controls for the modelElement on hostControl and binds them to the handle. Only single valued members will be considered. To build a UI for multi links, use MultilinkBuilder.


ControlBuilder.BuildControl Method

ControlBuilder.BuildControl Method
ControlBuilder Class Eco.Windows.Forms Namespace See Also
Collapse All

Builds a control for a member. The actual control depends of the type of the member.

C#
public static Size BuildControl(
    Control hostControl,
    ElementHandle handle,
    string memberName,
    IClassifier classifier,
    Point location,
    bool allowNull,
    bool readOnly,
    AutoContainerArgs autoContainerArgs
);
Parameters
Parameters | Description
hostControl | The control used as container for created control.
handle | The handle is used for data binding.
memberName | Binding name of member.
classifier | The type of the member.
location | Location the component will be placed on.
allowNull | Indicates if the member allows null values.
readOnly | Indicates if the member is readonly.
autoContainerArgs | AutoContainerArgs used when navigating to ends of single links.
Returns

The lower right corner of the created control.

Exceptions
Exceptions | Description
ArgumentNullException | Thrown if hostControl is null. Thrown if handle is null. Thrown if classifier is null.
See Also
ControlBuilder Class
Eco.Windows.Forms Namespace


ControlBuilder.BuildControls Method

ControlBuilder.BuildControls Method
ControlBuilder Class Eco.Windows.Forms Namespace See Also
Collapse All

Builds controls for the modelElement on hostControl and binds them to the handle. Only single valued members will be considered. To build a UI for multi links, use MultilinkBuilder.

C#
public static Size BuildControls(
    Control hostControl,
    ElementHandle handle,
    IModelElement modelElement,
    AutoContainerArgs autoContainerArgs
);
Parameters
Parameters | Description
hostControl | The control used as container for created controls.
handle | The handle is used for data binding.
modelElement | The IModelElement used to get the static information of constrains.
autoContainerArgs | AutoContainerArgs used when navigating to ends of single links as well as controlling which attributes get included in the form.
Returns

The lower right corner of the last created control.

Exceptions
Exceptions | Description
ArgumentNullException | Thrown if hostControl is null. Thrown if handle is null. Thrown if autoContainerArgs is null.
See Also
ControlBuilder Class
Eco.Windows.Forms Namespace


DBEvolutionForm Class

DBEvolutionForm Class
Inheritance Hierarchy See Also
Collapse All

Summary description for DBEvolutionForm.

C#
public sealed class DBEvolutionForm : System.Windows.Forms.Form;
Inheritance Hierarchy
System.Windows.Forms.Form
    Eco.Windows.Forms.DBEvolutionForm
File

Eco.Windows.Forms.DbEvolutionForm.cs

See Also
Inheritance Hierarchy


DBEvolutionForm Constructor

DBEvolutionForm Constructor

This is the overview for the DBEvolutionForm constructor overload.

Overload List
Name | Description
DBEvolutionForm.DBEvolutionForm () | This is DBEvolutionForm, a member of class DBEvolutionForm.
DBEvolutionForm.DBEvolutionForm (IServiceProvider) | This is DBEvolutionForm, a member of class DBEvolutionForm.


DBEvolutionForm.DBEvolutionForm Constructor ()

DBEvolutionForm.DBEvolutionForm Constructor ()
DBEvolutionForm Class Eco.Windows.Forms Namespace See Also
Collapse All
C#
public DBEvolutionForm();
Remarks

This is DBEvolutionForm, a member of class DBEvolutionForm.

See Also
DBEvolutionForm Class
Eco.Windows.Forms Namespace


DBEvolutionForm.DBEvolutionForm Constructor (IServiceProvider)

DBEvolutionForm.DBEvolutionForm Constructor (IServiceProvider)
DBEvolutionForm Class Eco.Windows.Forms Namespace See Also
Collapse All
C#
public DBEvolutionForm(
    IServiceProvider serviceProvider
);
Remarks

This is DBEvolutionForm, a member of class DBEvolutionForm.

See Also
DBEvolutionForm Class
Eco.Windows.Forms Namespace


DBEvolutionForm Methods

DBEvolutionForm Methods
Protected Methods Public Methods
Collapse All

The methods of the DBEvolutionForm class are listed here.

Protected Methods
Name | Description
Dispose | Clean up any resources being used.
Top
Public Methods
Name | Description
EvolveDB | This is the overview for the EvolveDB method overload.


DBEvolutionForm.Dispose Method

DBEvolutionForm.Dispose Method
DBEvolutionForm Class Eco.Windows.Forms Namespace See Also
Collapse All

Clean up any resources being used.

C#
protected override void Dispose(
    bool disposing
);
See Also
DBEvolutionForm Class
Eco.Windows.Forms Namespace


EvolveDB Method

EvolveDB Method

This is the overview for the EvolveDB method overload.

Overload List
Name | Description
DBEvolutionForm.EvolveDB (IDBEvolutor, bool) | This is EvolveDB, a member of class DBEvolutionForm.
DBEvolutionForm.EvolveDB (IPersistenceMapperDb, ITypeSystemService) | This is EvolveDB, a member of class DBEvolutionForm.
DBEvolutionForm.EvolveDB (IPersistenceMapperDb, ITypeSystemService, bool) | This is EvolveDB, a member of class DBEvolutionForm.
DBEvolutionForm.EvolveDB (IServiceProvider, IDBEvolutor, bool) |
DBEvolutionForm.EvolveDB (IServiceProvider, IPersistenceMapperDb, ITypeSystemService) | This is EvolveDB, a member of class DBEvolutionForm.
DBEvolutionForm.EvolveDB (IServiceProvider, IPersistenceMapperDb, ITypeSystemService, bool) |


DBEvolutionForm.EvolveDB Method (IDBEvolutor, bool)

DBEvolutionForm.EvolveDB Method (IDBEvolutor, bool)
DBEvolutionForm Class Eco.Windows.Forms Namespace See Also
Collapse All
C#
public static void EvolveDB(
    IDBEvolutor evolutor,
    bool silent
);
Remarks

This is EvolveDB, a member of class DBEvolutionForm.

See Also
DBEvolutionForm Class
Eco.Windows.Forms Namespace


DBEvolutionForm.EvolveDB Method (IPersistenceMapperDb, ITypeSystemService)

DBEvolutionForm.EvolveDB Method (IPersistenceMapperDb, ITypeSystemService)
DBEvolutionForm Class Eco.Windows.Forms Namespace See Also
Collapse All
C#
public static void EvolveDB(
    IPersistenceMapperDb persistenceMapper,
    ITypeSystemService typeSystemService
);
Remarks

This is EvolveDB, a member of class DBEvolutionForm.

See Also
DBEvolutionForm Class
Eco.Windows.Forms Namespace


DBEvolutionForm.EvolveDB Method (IPersistenceMapperDb, ITypeSystemService, bool)

DBEvolutionForm.EvolveDB Method (IPersistenceMapperDb, ITypeSystemService, bool)
DBEvolutionForm Class Eco.Windows.Forms Namespace See Also
Collapse All
C#
public static void EvolveDB(
    IPersistenceMapperDb persistenceMapper,
    ITypeSystemService typeSystemService,
    bool silent
);
Remarks

This is EvolveDB, a member of class DBEvolutionForm.

See Also
DBEvolutionForm Class
Eco.Windows.Forms Namespace


DBEvolutionForm.EvolveDB Method (IServiceProvider, IDBEvolutor, bool)

DBEvolutionForm.EvolveDB Method (IServiceProvider, IDBEvolutor, bool)
DBEvolutionForm Class Eco.Windows.Forms Namespace See Also
Collapse All
C#
public static void EvolveDB(
    IServiceProvider serviceProvider,
    IDBEvolutor evolutor,
    bool silent
);
Exceptions
Exceptions | Description
ArgumentNullException | Thrown if evolutor is null.
See Also
DBEvolutionForm Class
Eco.Windows.Forms Namespace


DBEvolutionForm.EvolveDB Method (IServiceProvider, IPersistenceMapperDb, ITypeSystemService)

DBEvolutionForm.EvolveDB Method (IServiceProvider, IPersistenceMapperDb, ITypeSystemService)
DBEvolutionForm Class Eco.Windows.Forms Namespace See Also
Collapse All
C#
public static void EvolveDB(
    IServiceProvider serviceProvider,
    IPersistenceMapperDb persistenceMapper,
    ITypeSystemService typeSystemService
);
Remarks

This is EvolveDB, a member of class DBEvolutionForm.

See Also
DBEvolutionForm Class
Eco.Windows.Forms Namespace


DBEvolutionForm.EvolveDB Method (IServiceProvider, IPersistenceMapperDb, ITypeSystemService, bool)

DBEvolutionForm.EvolveDB Method (IServiceProvider, IPersistenceMapperDb, ITypeSystemService, bool)
DBEvolutionForm Class Eco.Windows.Forms Namespace See Also
Collapse All
C#
public static void EvolveDB(
    IServiceProvider serviceProvider,
    IPersistenceMapperDb persistenceMapper,
    ITypeSystemService typeSystemService,
    bool silent
);
Exceptions
Exceptions | Description
ArgumentNullException | Thrown if persistenceMapper is null.
See Also
DBEvolutionForm Class
Eco.Windows.Forms Namespace


DBEvolutionForm Properties

DBEvolutionForm Properties
Public Properties
Collapse All

The properties of the DBEvolutionForm class are listed here.

Public Properties
Name | Description
MessageDisplay | This is MessageDisplay, a member of class DBEvolutionForm.


DBEvolutionForm.MessageDisplay Property

DBEvolutionForm.MessageDisplay Property
DBEvolutionForm Class Eco.Windows.Forms Namespace See Also
Collapse All
C#
public static IMessageDisplay MessageDisplay;
Remarks

This is MessageDisplay, a member of class DBEvolutionForm.

See Also
DBEvolutionForm Class
Eco.Windows.Forms Namespace


DirtyObjectsDebuggerPanel Class

DirtyObjectsDebuggerPanel Class
Inheritance Hierarchy See Also
Collapse All

This class form part of the EcoSpace debugger. It is not intended to be used directly.

C#
public class DirtyObjectsDebuggerPanel : System.Windows.Forms.Form, IEcoSpaceDebuggerPanel;
Inheritance Hierarchy
Eco.Windows.Forms.IEcoSpaceDebuggerPanel
System.Windows.Forms.Form
    Eco.Windows.Forms.DirtyObjectsDebuggerPanel
File

Eco.Windows.Forms.DirtyObjectsDebuggerPanel.cs

See Also
Inheritance Hierarchy


DirtyObjectsDebuggerPanel.DirtyObjectsDebuggerPanel Constructor

DirtyObjectsDebuggerPanel.DirtyObjectsDebuggerPanel Constructor
DirtyObjectsDebuggerPanel Class Eco.Windows.Forms Namespace See Also
Collapse All
C#
public DirtyObjectsDebuggerPanel();
Remarks

This is DirtyObjectsDebuggerPanel, a member of class DirtyObjectsDebuggerPanel.

See Also
DirtyObjectsDebuggerPanel Class
Eco.Windows.Forms Namespace


DirtyObjectsDebuggerPanel Methods

DirtyObjectsDebuggerPanel Methods
Protected Methods
Collapse All

The methods of the DirtyObjectsDebuggerPanel class are listed here.

Protected Methods
Name | Description
Dispose | Clean up any resources being used.


DirtyObjectsDebuggerPanel.Dispose Method

DirtyObjectsDebuggerPanel.Dispose Method
DirtyObjectsDebuggerPanel Class Eco.Windows.Forms Namespace See Also
Collapse All

Clean up any resources being used.

C#
protected override void Dispose(
    bool disposing
);
See Also
DirtyObjectsDebuggerPanel Class
Eco.Windows.Forms Namespace


DirtyObjectsDebuggerPanel Properties

DirtyObjectsDebuggerPanel Properties
Public Properties
Collapse All

The properties of the DirtyObjectsDebuggerPanel class are listed here.

Public Properties
Name | Description
DirtyListService | This is DirtyListService, a member of class DirtyObjectsDebuggerPanel.
EcoSpace | This is EcoSpace, a member of class DirtyObjectsDebuggerPanel.
ExtentService | This is ExtentService, a member of class DirtyObjectsDebuggerPanel.
ObjectFactoryService | This is ObjectFactoryService, a member of class DirtyObjectsDebuggerPanel.
OclService | This is OclService, a member of class DirtyObjectsDebuggerPanel.
PersistenceService | This is PersistenceService, a member of class DirtyObjectsDebuggerPanel.
TypeSystemService | This is TypeSystemService, a member of class DirtyObjectsDebuggerPanel.
UndoService | This is UndoService, a member of class DirtyObjectsDebuggerPanel.
VariableFactoryService | This is VariableFactoryService, a member of class DirtyObjectsDebuggerPanel.


DirtyObjectsDebuggerPanel.DirtyListService Property

DirtyObjectsDebuggerPanel.DirtyListService Property
DirtyObjectsDebuggerPanel Class Eco.Windows.Forms Namespace See Also
Collapse All
C#
public IDirtyListService DirtyListService;
Remarks

This is DirtyListService, a member of class DirtyObjectsDebuggerPanel.

See Also
DirtyObjectsDebuggerPanel Class
Eco.Windows.Forms Namespace


DirtyObjectsDebuggerPanel.EcoSpace Property

DirtyObjectsDebuggerPanel.EcoSpace Property
DirtyObjectsDebuggerPanel Class Eco.Windows.Forms Namespace See Also
Collapse All
C#
public Eco.Handles.EcoSpace EcoSpace;
Remarks

This is EcoSpace, a member of class DirtyObjectsDebuggerPanel.

See Also
DirtyObjectsDebuggerPanel Class
Eco.Windows.Forms Namespace


DirtyObjectsDebuggerPanel.ExtentService Property

DirtyObjectsDebuggerPanel.ExtentService Property
DirtyObjectsDebuggerPanel Class Eco.Windows.Forms Namespace See Also
Collapse All
C#
public IExtentService ExtentService;
Remarks

This is ExtentService, a member of class DirtyObjectsDebuggerPanel.

See Also
DirtyObjectsDebuggerPanel Class
Eco.Windows.Forms Namespace


DirtyObjectsDebuggerPanel.ObjectFactoryService Property

DirtyObjectsDebuggerPanel.ObjectFactoryService Property
DirtyObjectsDebuggerPanel Class Eco.Windows.Forms Namespace See Also
Collapse All
C#
public IObjectFactoryService ObjectFactoryService;
Remarks

This is ObjectFactoryService, a member of class DirtyObjectsDebuggerPanel.

See Also
DirtyObjectsDebuggerPanel Class
Eco.Windows.Forms Namespace


DirtyObjectsDebuggerPanel.OclService Property

DirtyObjectsDebuggerPanel.OclService Property
DirtyObjectsDebuggerPanel Class Eco.Windows.Forms Namespace See Also
Collapse All
C#
public IOclService OclService;
Remarks

This is OclService, a member of class DirtyObjectsDebuggerPanel.

See Also
DirtyObjectsDebuggerPanel Class
Eco.Windows.Forms Namespace


DirtyObjectsDebuggerPanel.PersistenceService Property

DirtyObjectsDebuggerPanel.PersistenceService Property
DirtyObjectsDebuggerPanel Class Eco.Windows.Forms Namespace See Also
Collapse All
C#
public IPersistenceService PersistenceService;
Remarks

This is PersistenceService, a member of class DirtyObjectsDebuggerPanel.

See Also
DirtyObjectsDebuggerPanel Class
Eco.Windows.Forms Namespace


DirtyObjectsDebuggerPanel.TypeSystemService Property

DirtyObjectsDebuggerPanel.TypeSystemService Property
DirtyObjectsDebuggerPanel Class Eco.Windows.Forms Namespace See Also
Collapse All
C#
public ITypeSystemService TypeSystemService;
Remarks

This is TypeSystemService, a member of class DirtyObjectsDebuggerPanel.

See Also
DirtyObjectsDebuggerPanel Class
Eco.Windows.Forms Namespace


DirtyObjectsDebuggerPanel.UndoService Property

DirtyObjectsDebuggerPanel.UndoService Property
DirtyObjectsDebuggerPanel Class Eco.Windows.Forms Namespace See Also
Collapse All
C#
public IUndoService UndoService;
Remarks

This is UndoService, a member of class DirtyObjectsDebuggerPanel.

See Also
DirtyObjectsDebuggerPanel Class
Eco.Windows.Forms Namespace


DirtyObjectsDebuggerPanel.VariableFactoryService Property

DirtyObjectsDebuggerPanel.VariableFactoryService Property
DirtyObjectsDebuggerPanel Class Eco.Windows.Forms Namespace See Also
Collapse All
C#
public IVariableFactoryService VariableFactoryService;
Remarks

This is VariableFactoryService, a member of class DirtyObjectsDebuggerPanel.

See Also
DirtyObjectsDebuggerPanel Class
Eco.Windows.Forms Namespace


EcoSpaceDebugger Class

EcoSpaceDebugger Class
Inheritance Hierarchy See Also
Collapse All

Host form for the debugger plugin panels.

C#
public class EcoSpaceDebugger : System.Windows.Forms.Form;
Inheritance Hierarchy
System.Windows.Forms.Form
    Eco.Windows.Forms.EcoSpaceDebugger
File

Eco.Windows.Forms.EcoSpaceDebugger.cs

See Also
Inheritance Hierarchy


EcoSpaceDebugger Constructor

EcoSpaceDebugger Constructor

This is the overview for the EcoSpaceDebugger constructor overload.

Overload List
Name | Description
EcoSpaceDebugger.EcoSpaceDebugger (EcoSpace) | This is EcoSpaceDebugger, a member of class EcoSpaceDebugger.
EcoSpaceDebugger.EcoSpaceDebugger (EcoSpace, IHelpService) | This is EcoSpaceDebugger, a member of class EcoSpaceDebugger.


EcoSpaceDebugger.EcoSpaceDebugger Constructor (EcoSpace)

EcoSpaceDebugger.EcoSpaceDebugger Constructor (EcoSpace)
EcoSpaceDebugger Class Eco.Windows.Forms Namespace See Also
Collapse All
C#
public EcoSpaceDebugger(
    EcoSpace es
);
Remarks

This is EcoSpaceDebugger, a member of class EcoSpaceDebugger.

See Also
EcoSpaceDebugger Class
Eco.Windows.Forms Namespace


EcoSpaceDebugger.EcoSpaceDebugger Constructor (EcoSpace, IHelpService)

EcoSpaceDebugger.EcoSpaceDebugger Constructor (EcoSpace, IHelpService)
EcoSpaceDebugger Class Eco.Windows.Forms Namespace See Also
Collapse All
C#
public EcoSpaceDebugger(
    EcoSpace es,
    IHelpService helpService
);
Remarks

This is EcoSpaceDebugger, a member of class EcoSpaceDebugger.

See Also
EcoSpaceDebugger Class
Eco.Windows.Forms Namespace


EcoSpaceDebugger Methods

EcoSpaceDebugger Methods
Protected Methods Public Methods
Collapse All

The methods of the EcoSpaceDebugger class are listed here.

Protected Methods
Name | Description
Dispose | Clean up any resources being used.
Top
Public Methods
Name | Description
UpdateTransient | This is UpdateTransient, a member of class EcoSpaceDebugger.


EcoSpaceDebugger.Dispose Method

EcoSpaceDebugger.Dispose Method
EcoSpaceDebugger Class Eco.Windows.Forms Namespace See Also
Collapse All

Clean up any resources being used.

C#
protected override void Dispose(
    bool disposing
);
See Also
EcoSpaceDebugger Class
Eco.Windows.Forms Namespace


EcoSpaceDebugger.UpdateTransient Method

EcoSpaceDebugger.UpdateTransient Method
EcoSpaceDebugger Class Eco.Windows.Forms Namespace See Also
Collapse All
C#
public void UpdateTransient();
Remarks

This is UpdateTransient, a member of class EcoSpaceDebugger.

See Also
EcoSpaceDebugger Class
Eco.Windows.Forms Namespace


EcoSpaceDebugger Properties

EcoSpaceDebugger Properties
Public Properties
Collapse All

The properties of the EcoSpaceDebugger class are listed here.

Public Properties
Name | Description
EcoSpace | This is EcoSpace, a member of class EcoSpaceDebugger.


EcoSpaceDebugger.EcoSpace Property

EcoSpaceDebugger.EcoSpace Property
EcoSpaceDebugger Class Eco.Windows.Forms Namespace See Also
Collapse All
C#
public EcoSpace EcoSpace;
Remarks

This is EcoSpace, a member of class EcoSpaceDebugger.

See Also
EcoSpaceDebugger Class
Eco.Windows.Forms Namespace


ErrorHandler Class

ErrorHandler Class
Inheritance Hierarchy See Also
Collapse All
C#
public class ErrorHandler;
Remarks

this exception handler must be installed prior to Application.Run:

[STAThreadAttribute] public static void Main() { WinFormDequeuer.Active = true; Eco.Diagnostics.ErrorHandler.InstallExceptionHandler(); System.Windows.Forms.Application.Run(new MainForm());

Inheritance Hierarchy
Eco.Windows.Forms.ErrorHandler
File

Eco.Windows.Forms.EcoSpaceDebugger.cs

See Also
Inheritance Hierarchy


ErrorHandler Methods

ErrorHandler Methods
Public Methods
Collapse All

The methods of the ErrorHandler class are listed here.

Public Methods
Name | Description
InstallExceptionHandler | This is InstallExceptionHandler, a member of class ErrorHandler.
UninstallExceptionHandler | This is UninstallExceptionHandler, a member of class ErrorHandler.


ErrorHandler.InstallExceptionHandler Method

ErrorHandler.InstallExceptionHandler Method
ErrorHandler Class Eco.Windows.Forms Namespace See Also
Collapse All
C#
public static void InstallExceptionHandler();
Remarks

This is InstallExceptionHandler, a member of class ErrorHandler.

See Also
ErrorHandler Class
Eco.Windows.Forms Namespace


ErrorHandler.UninstallExceptionHandler Method

ErrorHandler.UninstallExceptionHandler Method
ErrorHandler Class Eco.Windows.Forms Namespace See Also
Collapse All
C#
public static void UninstallExceptionHandler();
Remarks

This is UninstallExceptionHandler, a member of class ErrorHandler.

See Also
ErrorHandler Class
Eco.Windows.Forms Namespace


FormBasedConfigureCleanPS Class

FormBasedConfigureCleanPS Class
Inheritance Hierarchy See Also
Collapse All

Implementor of IConfigureCleanPS, wraps a GUI form

C#
public class FormBasedConfigureCleanPS : IConfigureCleanPS;
Inheritance Hierarchy
Eco.Windows.Forms.FormBasedConfigureCleanPS
File

Eco.Windows.Forms.ConfigureCleanPSForm.cs

See Also
Inheritance Hierarchy


FormBasedConfigureCleanPS Constructor

FormBasedConfigureCleanPS Constructor

This is the overview for the FormBasedConfigureCleanPS constructor overload.

Overload List
Name | Description
FormBasedConfigureCleanPS.FormBasedConfigureCleanPS () | This is FormBasedConfigureCleanPS, a member of class FormBasedConfigureCleanPS.
FormBasedConfigureCleanPS.FormBasedConfigureCleanPS (IServiceProvider) | This is FormBasedConfigureCleanPS, a member of class FormBasedConfigureCleanPS.


FormBasedConfigureCleanPS.FormBasedConfigureCleanPS Constructor ()

FormBasedConfigureCleanPS.FormBasedConfigureCleanPS Constructor ()
FormBasedConfigureCleanPS Class Eco.Windows.Forms Namespace See Also
Collapse All
C#
public FormBasedConfigureCleanPS();
Remarks

This is FormBasedConfigureCleanPS, a member of class FormBasedConfigureCleanPS.

See Also
FormBasedConfigureCleanPS Class
Eco.Windows.Forms Namespace


FormBasedConfigureCleanPS.FormBasedConfigureCleanPS Constructor (IServiceProvider)

FormBasedConfigureCleanPS.FormBasedConfigureCleanPS Constructor (IServiceProvider)
FormBasedConfigureCleanPS Class Eco.Windows.Forms Namespace See Also
Collapse All
C#
public FormBasedConfigureCleanPS(
    IServiceProvider serviceProvider
);
Remarks

This is FormBasedConfigureCleanPS, a member of class FormBasedConfigureCleanPS.

See Also
FormBasedConfigureCleanPS Class
Eco.Windows.Forms Namespace


FormBasedConfigureCleanPS Methods

FormBasedConfigureCleanPS Methods
Public Methods
Collapse All

The methods of the FormBasedConfigureCleanPS class are listed here.

Public Methods
Name | Description
DetermineTablesToDelete |
InstallExternalSystemTables | This is InstallExternalSystemTables, a member of class FormBasedConfigureCleanPS.


FormBasedConfigureCleanPS.DetermineTablesToDelete Method

FormBasedConfigureCleanPS.DetermineTablesToDelete Method
FormBasedConfigureCleanPS Class Eco.Windows.Forms Namespace See Also
Collapse All
C#
public IList<string> DetermineTablesToDelete(
    IList<string> allTables,
    IList<string> knownTables,
    IList<string> SQLTables
);
Exceptions
Exceptions | Description
ArgumentNullException | Thrown if SQLtables is null.
InvalidOperationException | Thrown if the user aborts by pressing Cancel in the ensuing dialog.
See Also
FormBasedConfigureCleanPS Class
Eco.Windows.Forms Namespace


FormBasedConfigureCleanPS.InstallExternalSystemTables Method

FormBasedConfigureCleanPS.InstallExternalSystemTables Method
FormBasedConfigureCleanPS Class Eco.Windows.Forms Namespace See Also
Collapse All
C#
public void InstallExternalSystemTables(
    IList<string> tableNames
);
Remarks

This is InstallExternalSystemTables, a member of class FormBasedConfigureCleanPS.

See Also
FormBasedConfigureCleanPS Class
Eco.Windows.Forms Namespace


FormBasedConfigureCleanPS Properties

FormBasedConfigureCleanPS Properties
Public Properties
Collapse All

The properties of the FormBasedConfigureCleanPS class are listed here.

Public Properties
Name | Description
CurrentForm | This is CurrentForm, a member of class FormBasedConfigureCleanPS.


FormBasedConfigureCleanPS.CurrentForm Property

FormBasedConfigureCleanPS.CurrentForm Property
FormBasedConfigureCleanPS Class Eco.Windows.Forms Namespace See Also
Collapse All
C#
public ConfigureCleanPSForm CurrentForm;
Remarks

This is CurrentForm, a member of class FormBasedConfigureCleanPS.

See Also
FormBasedConfigureCleanPS Class
Eco.Windows.Forms Namespace


FormsStringRes Class

FormsStringRes Class
Inheritance Hierarchy See Also
Collapse All

Autogenerated class to get compiler safe access to resource strings.

C#
public sealed class FormsStringRes : StringResources;
Inheritance Hierarchy
Eco.Windows.Forms.FormsStringRes
File

Eco.Windows.Forms.Strings.cs

See Also
Inheritance Hierarchy


FormsStringRes Methods

FormsStringRes Methods
Public Methods
Collapse All

The methods of the FormsStringRes class are listed here.

Public Methods
Name | Description
CannotFindBindingContext | Returns: "{0}: Can not find any binding context"
sCreateNewInstance | Returns: "Create new instance of {0}"
sCurrentType | Returns: "Current type is: {0}"
sEvolutionFailed | Returns: "Failed to Evolve database: {0}{1}See LogWindow for executed statements"
sFailedToDetectChanges | Returns: "Failed to detect changes: {0}"
sInternalOclError | Returns: "Internal Error: {0}"
sLogDone | Returns: "{0}: Done {1}"
sLogStart | Returns: "{0}: Starting {1}"
sResultTypeIs | Returns: "rnrnResult Type is: {0}"


FormsStringRes.CannotFindBindingContext Method

FormsStringRes.CannotFindBindingContext Method
FormsStringRes Class Eco.Windows.Forms Namespace See Also
Collapse All

Returns: "{0}: Can not find any binding context"

C#
public static string CannotFindBindingContext(
    object param0
);
Remarks

For internal use.

See Also
FormsStringRes Class
Eco.Windows.Forms Namespace


FormsStringRes.sCreateNewInstance Method

FormsStringRes.sCreateNewInstance Method
FormsStringRes Class Eco.Windows.Forms Namespace See Also
Collapse All

Returns: "Create new instance of {0}"

C#
public static string sCreateNewInstance(
    object param0
);
Remarks

For internal use.

See Also
FormsStringRes Class
Eco.Windows.Forms Namespace


FormsStringRes.sCurrentType Method

FormsStringRes.sCurrentType Method
FormsStringRes Class Eco.Windows.Forms Namespace See Also
Collapse All

Returns: "Current type is: {0}"

C#
public static string sCurrentType(
    object param0
);
Remarks

For internal use.

See Also
FormsStringRes Class
Eco.Windows.Forms Namespace


FormsStringRes.sEvolutionFailed Method

FormsStringRes.sEvolutionFailed Method
FormsStringRes Class Eco.Windows.Forms Namespace See Also
Collapse All

Returns: "Failed to Evolve database: {0}{1}See LogWindow for executed statements"

C#
public static string sEvolutionFailed(
    object param0,
    object param1
);
Remarks

For internal use.

See Also
FormsStringRes Class
Eco.Windows.Forms Namespace


FormsStringRes.sFailedToDetectChanges Method

FormsStringRes.sFailedToDetectChanges Method
FormsStringRes Class Eco.Windows.Forms Namespace See Also
Collapse All

Returns: "Failed to detect changes: {0}"

C#
public static string sFailedToDetectChanges(
    object param0
);
Remarks

For internal use.

See Also
FormsStringRes Class
Eco.Windows.Forms Namespace


FormsStringRes.sInternalOclError Method

FormsStringRes.sInternalOclError Method
FormsStringRes Class Eco.Windows.Forms Namespace See Also
Collapse All

Returns: "Internal Error: {0}"

C#
public static string sInternalOclError(
    object param0
);
Remarks

For internal use.

See Also
FormsStringRes Class
Eco.Windows.Forms Namespace


FormsStringRes.sLogDone Method

FormsStringRes.sLogDone Method
FormsStringRes Class Eco.Windows.Forms Namespace See Also
Collapse All

Returns: "{0}: Done {1}"

C#
public static string sLogDone(
    object param0,
    object param1
);
Remarks

For internal use.

See Also
FormsStringRes Class
Eco.Windows.Forms Namespace


FormsStringRes.sLogStart Method

FormsStringRes.sLogStart Method
FormsStringRes Class Eco.Windows.Forms Namespace See Also
Collapse All

Returns: "{0}: Starting {1}"

C#
public static string sLogStart(
    object param0,
    object param1
);
Remarks

For internal use.

See Also
FormsStringRes Class
Eco.Windows.Forms Namespace


FormsStringRes.sResultTypeIs Method

FormsStringRes.sResultTypeIs Method
FormsStringRes Class Eco.Windows.Forms Namespace See Also
Collapse All

Returns: "rnrnResult Type is: {0}"

C#
public static string sResultTypeIs(
    object param0
);
Remarks

For internal use.

See Also
FormsStringRes Class
Eco.Windows.Forms Namespace


FormsStringRes Properties

FormsStringRes Properties
Public Properties
Collapse All

The properties of the FormsStringRes class are listed here.

Public Properties
Name | Description
ActionExecuted | Returns: "Action executed"
CaptionConfirm | Returns: "Confirm"
ClassAndOclDebuggerCaption | Returns: "Classes and OCL"
ComponentCategoryExtenders | Returns: "ECO|Extenders"
ComponentCategoryWinforms | Returns: "ECO|WinForm"
EvaluteButton_Eval | Returns: "Eval"
EvaluteButton_Exec | Returns: "Exec"
sActionLanguageEditorCaption | Returns: "ActionLanguage editor"
sBindingContextControl | Returns: "Control whose BindingContext shall be used"
sCannotLinkBindingContextToSelf | Returns: "BindingContext must point to another control."
sCannotReloadDirtyObject | Returns: "Cannot reload. Object is dirty."
sCaptionAction | Returns: "Perform Action"
sCaptionAdd | Returns: "Add"
sCaptionCreateSchema | Returns: "Create Schema"
sCaptionDelete | Returns: "Delete"
sCaptionEvolveSchema | Returns: "Evolve Schema"
sCaptionMoveDown | Returns: "Down"
sCaptionMoveFirst | Returns: "First"
sCaptionMoveLast | Returns: "Last"
sCaptionMoveNext | Returns: "Next"
sCaptionMovePrev | Returns: "Prev"
sCaptionMoveUp | Returns: "Up"
sCaptionRedo | Returns: "Redo"
sCaptionReload | Returns: "Reload"
sCaptionSetCheckpoint | Returns: "Set Checkpoint"
sCaptionShowAutoForm | Returns: "Show Autoform"
sCaptionShowDebugger | Returns: "Show ECO debugger"
sCaptionToggleActive | Returns: "Activate"
sCaptionToggleDeactivate | Returns: "Deactivate"
sCaptionUndo | Returns: "Undo"
sCaptionUnlink | Returns: "Unlink"
sCategoryBehaviour | Returns: "Behaviour"
sCategoryConnections | Returns: "ECO|Connections"
sCategoryEcoGui | Returns: "ECO|GUI"
sCategoryEcoListAction | Returns: "ECO|ListAction"
sCategoryPresentation | Returns: "ECO|Presentation"
sClassesAndOcl | Returns: "Classes and OCL"
sClassHasNoConstraints | Returns: "Class has no constraints"
sCleaningPSAborted | Returns: "Cleaning of Persistent Storage Aborted"
sCloseCaption | Returns: "Close"
sCMNotConnectedToElementHandle | Returns: "CurrencyManager not representing an ElementHandle"
sConstraintsBroken | Returns: "Constraints Broken"
sConstraintsOk | Returns: "Constraints not broken"
sCreationAborted | Returns: "Creation aborted"
sCurrencyManagerHandleHasNoBindingContext | Returns: "CurrencyManagerHandle has no BindingContext"
sDatabaseUpgradeSuccessful | Returns: "Database successfully updated"
sDataSourceRootHandleIncompatible | Returns: "DataSource for the BindingContext must be the same as the RootHandle for this CurrencyManagerHandle"
sDeleteQuestion | Returns: "Delete object(s)?"
sDirtyObjects | Returns: "Dirty Objects"
sDiscardChanges | Returns: "Discard Changes"
sEcoLog | Returns: "ECO Log"
sEmptyExpression | Returns: "Empty Expression"
sErrorEcoSpaceNotSet | Returns: "Could not find EcoSpace"
sErrorNotRooted | Returns: "Uplink chain not complete"
sErrorRootInactive | Returns: "Uplink handle not active"
sErrorSystemActive | Returns: "Cannot create schema on an active EcoSpace"
sErrorSystemInactive | Returns: "Cannot perform operation on an inactive EcoSpace"
sEvolutionAborted | Returns: "Evolution of Schema Aborted on User Request."
sEvolutionCaption | Returns: "Schema Evolution"
sExecutedStatementsWere | Returns: "The following statements were executed before evolution failed:"
sExpressionIsOk | Returns: "OCL Expression is OK"
sFatalError | Returns: "Fatal Error"
sHandleHasNoList | Returns: "Could not extract object list from handle"
sHandleNotSet | Returns: "Cannot look up CurrencyManager because RootHandle not found (or not set)"
sInvalidModel | Returns: "Model is invalid:"
sMethodsTabCaption | Returns: "Methods"
sNeedRecompile | Returns: "[Model not recently compiled]"
sNoActionNeeded | Returns: "No action needed"
sNoContext | Returns: "There is no context for this expression"
sNodeNameAttributes | Returns: "Attributes"
sNodeNameClasses | Returns: "Classes"
sNodeNameMethods | Returns: "Methods"
sNodeNameOcloperations | Returns: "OCL operations"
sNodeNameRoles | Returns: "Roles"
sNodeNameTriggerqueries | Returns: "Trigger queries"
sNodeNameTriggers | Returns: "Triggers"
sNodeNameVariables | Returns: "Variables"
sNoTablesToSelectFrom | Returns: "<<no tables to select from>>"
sNoUpdateNeeded | Returns: "No update needed!"
sOclEditorCaption | Returns: "OCL editor"
sOclPsEditorCaption | Returns: "OclPs editor"
sOperationCallFailed | Returns: "Operation call failed"
sPropertyActionExtenderElementHandle | Returns: "This property should be set to a handle ultimately linked to an EcoSpace."
sPropertyActionOcl | Returns: "EcoActionLanguage expression to be executed."
sPropertyCaptionAction | Returns: "Default caption used when action-property set to Action."
sPropertyCaptionAdd | Returns: "Default caption used when action-property set to Add."
sPropertyCaptionCreateSchema | Returns: "Default caption used when action-property set to CreateSchema."
sPropertyCaptionDelete | Returns: "Default caption used when action-property set to Delete."
sPropertyCaptionDiscardChanges | Returns: "Default caption used when action-property set to DiscardChanges."
sPropertyCaptionEvolveSchema | Returns: "Default caption used when action-property set to EvolveSchema."
sPropertyCaptionMoveDown | Returns: "Default caption used when action-property set to MoveDown."
sPropertyCaptionMoveFirst | Returns: "Default caption used when action-property set to MoveFirst."
sPropertyCaptionMoveLast | Returns: "Default caption used when action-property set to MoveLast."
sPropertyCaptionMoveNext | Returns: "Default caption used when action-property set to MoveNext."
sPropertyCaptionMovePrev | Returns: "Default caption used when action-property set to MovePrev."
sPropertyCaptionMoveUp | Returns: "Default caption used when action-property set to MoveUp."
sPropertyCaptionRedo | Returns: "Default caption used when action-property set to Redo."
sPropertyCaptionReload | Returns: "Default caption used when action-property set to Reload."
sPropertyCaptionSetCheckpoint | Returns: "Default caption used when action-property set to SetCheckPoint."
sPropertyCaptionShowAutoForm | Returns: "Default caption used when action-property set to ShowAutoform."
sPropertyCaptionShowDebugger | Returns: "Default caption used when action-property set to ShowDebugger."
sPropertyCaptionToggleActive | Returns: "Default caption used when action-property set to ToggleActive and EcoSpace is inactive."
sPropertyCaptionToggleDeactivate | Returns: "Default caption used when action-property set to ToggleActive and EcoSpace is active."
sPropertyCaptionUndo | Returns: "Default caption used when action-property set to Undo."
sPropertyCaptionUnlink | Returns: "Default caption used when action-property set to Unlink."
sPropertyCaptionUpdateDatabase | Returns: "Default caption used when action-property set to UpdateDatabase."
sPropertyDeleteQuestion | Returns: "Question used when action-property set to Delete and action is performed."
sPropertyEcoAutoForm | Returns: "Enables autoforms to show on double-click."
sPropertyEcoAutoFormReadOnly | Returns: "Makes the Autoform Readonly."
sPropertyEcoDragSource | Returns: "Allows component to be drag source in model driven D&&D."
sPropertyEcoDropTarget | Returns: "Allows component to be drop target in model driven D&&D."
sPropertyEcoListAction | Returns: "Action to perform."
sPropertyEnabledOcl | Returns: "OCL expression controlling the enabled property of this control."
sPropertyExtenderContainerReusage | Returns: "Controls how new forms should be created or reused."
sPropertyExtenderEnabled | Returns: "Indicates whether the control is enabled."
sPropertyExtenderMemberVisibility | Returns: "Determines which level of visibility for members will be included in auto form."
sPropertyExtenderShowModal | Returns: "Show the autoforms modally."
sPropertyRootHandle | Returns: "Handle supplying uplink value."
sPropertyUnlinkQuestion | Returns: "Question used when action-property set to Unlink and action is performed."
sPropertyVisibleOcl | Returns: "OCL expression controlling the visible property of this control."
sRefreshConstraints | Returns: "Refresh Constraints"
sReviewChangesCarefully | Returns: "Please inspect the planned actions and decide if you want to execute them. Make sure you back up your critical data before evolving the schema!!!"
sStartDetectChanges | Returns: "Detecting changes"
sStateTabCaption | Returns: "State"
sSyntaxIsOk | Returns: "Syntax is OK."
sUndoRedo | Returns: "Undo/Redo"
sUnknown | Returns: "unknown"
sUnlinkQuestion | Returns: "Unlink object?"
sUpdateDatabase | Returns: "Update DB"
sWrongExpectedType | Returns: "Syntax is OK, but the return type is invalid."


FormsStringRes.ActionExecuted Property

FormsStringRes.ActionExecuted Property
FormsStringRes Class Eco.Windows.Forms Namespace See Also
Collapse All

Returns: "Action executed"

C#
public static string ActionExecuted;
Remarks

For internal use.

See Also
FormsStringRes Class
Eco.Windows.Forms Namespace


FormsStringRes.CaptionConfirm Property

FormsStringRes.CaptionConfirm Property
FormsStringRes Class Eco.Windows.Forms Namespace See Also
Collapse All

Returns: "Confirm"

C#
public static string CaptionConfirm;
Remarks

For internal use.

See Also
FormsStringRes Class
Eco.Windows.Forms Namespace


FormsStringRes.ClassAndOclDebuggerCaption Property

FormsStringRes.ClassAndOclDebuggerCaption Property
FormsStringRes Class Eco.Windows.Forms Namespace See Also
Collapse All

Returns: "Classes and OCL"

C#
public static string ClassAndOclDebuggerCaption;
Remarks

For internal use.

See Also
FormsStringRes Class
Eco.Windows.Forms Namespace


FormsStringRes.ComponentCategoryExtenders Property

FormsStringRes.ComponentCategoryExtenders Property
FormsStringRes Class Eco.Windows.Forms Namespace See Also
Collapse All

Returns: "ECO|Extenders"

C#
public static string ComponentCategoryExtenders;
Remarks

For internal use.

See Also
FormsStringRes Class
Eco.Windows.Forms Namespace


FormsStringRes.ComponentCategoryWinforms Property

FormsStringRes.ComponentCategoryWinforms Property
FormsStringRes Class Eco.Windows.Forms Namespace See Also
Collapse All

Returns: "ECO|WinForm"

C#
public static string ComponentCategoryWinforms;
Remarks

For internal use.

See Also
FormsStringRes Class
Eco.Windows.Forms Namespace


FormsStringRes.EvaluteButton_Eval Property

FormsStringRes.EvaluteButton_Eval Property
FormsStringRes Class Eco.Windows.Forms Namespace See Also
Collapse All

Returns: "Eval"

C#
public static string EvaluteButton_Eval;
Remarks

For internal use.

See Also
FormsStringRes Class
Eco.Windows.Forms Namespace


FormsStringRes.EvaluteButton_Exec Property

FormsStringRes.EvaluteButton_Exec Property
FormsStringRes Class Eco.Windows.Forms Namespace See Also
Collapse All

Returns: "Exec"

C#
public static string EvaluteButton_Exec;
Remarks

For internal use.

See Also
FormsStringRes Class
Eco.Windows.Forms Namespace


FormsStringRes.sActionLanguageEditorCaption Property

FormsStringRes.sActionLanguageEditorCaption Property
FormsStringRes Class Eco.Windows.Forms Namespace See Also
Collapse All

Returns: "ActionLanguage editor"

C#
public static string sActionLanguageEditorCaption;
Remarks

For internal use.

See Also
FormsStringRes Class
Eco.Windows.Forms Namespace


FormsStringRes.sBindingContextControl Property

FormsStringRes.sBindingContextControl Property
FormsStringRes Class Eco.Windows.Forms Namespace See Also
Collapse All

Returns: "Control whose BindingContext shall be used"

C#
public static string sBindingContextControl;
Remarks

For internal use.

See Also
FormsStringRes Class
Eco.Windows.Forms Namespace


FormsStringRes.sCannotLinkBindingContextToSelf Property

FormsStringRes.sCannotLinkBindingContextToSelf Property
FormsStringRes Class Eco.Windows.Forms Namespace See Also
Collapse All

Returns: "BindingContext must point to another control."

C#
public static string sCannotLinkBindingContextToSelf;
Remarks

For internal use.

See Also
FormsStringRes Class
Eco.Windows.Forms Namespace


FormsStringRes.sCannotReloadDirtyObject Property

FormsStringRes.sCannotReloadDirtyObject Property
FormsStringRes Class Eco.Windows.Forms Namespace See Also
Collapse All

Returns: "Cannot reload. Object is dirty."

C#
public static string sCannotReloadDirtyObject;
Remarks

For internal use.

See Also
FormsStringRes Class
Eco.Windows.Forms Namespace


FormsStringRes.sCaptionAction Property

FormsStringRes.sCaptionAction Property
FormsStringRes Class Eco.Windows.Forms Namespace See Also
Collapse All

Returns: "Perform Action"

C#
public static string sCaptionAction;
Remarks

For internal use.

See Also
FormsStringRes Class
Eco.Windows.Forms Namespace


FormsStringRes.sCaptionAdd Property

FormsStringRes.sCaptionAdd Property
FormsStringRes Class Eco.Windows.Forms Namespace See Also
Collapse All

Returns: "Add"

C#
public static string sCaptionAdd;
Remarks

For internal use.

See Also
FormsStringRes Class
Eco.Windows.Forms Namespace


FormsStringRes.sCaptionCreateSchema Property

FormsStringRes.sCaptionCreateSchema Property
FormsStringRes Class Eco.Windows.Forms Namespace See Also
Collapse All

Returns: "Create Schema"

C#
public static string sCaptionCreateSchema;
Remarks

For internal use.

See Also
FormsStringRes Class
Eco.Windows.Forms Namespace


FormsStringRes.sCaptionDelete Property

FormsStringRes.sCaptionDelete Property
FormsStringRes Class Eco.Windows.Forms Namespace See Also
Collapse All

Returns: "Delete"

C#
public static string sCaptionDelete;
Remarks

For internal use.

See Also
FormsStringRes Class
Eco.Windows.Forms Namespace


FormsStringRes.sCaptionEvolveSchema Property

FormsStringRes.sCaptionEvolveSchema Property
FormsStringRes Class Eco.Windows.Forms Namespace See Also
Collapse All

Returns: "Evolve Schema"

C#
public static string sCaptionEvolveSchema;
Remarks

For internal use.

See Also
FormsStringRes Class
Eco.Windows.Forms Namespace


FormsStringRes.sCaptionMoveDown Property

FormsStringRes.sCaptionMoveDown Property
FormsStringRes Class Eco.Windows.Forms Namespace See Also
Collapse All

Returns: "Down"

C#
public static string sCaptionMoveDown;
Remarks

For internal use.

See Also
FormsStringRes Class
Eco.Windows.Forms Namespace


FormsStringRes.sCaptionMoveFirst Property

FormsStringRes.sCaptionMoveFirst Property
FormsStringRes Class Eco.Windows.Forms Namespace See Also
Collapse All

Returns: "First"

C#
public static string sCaptionMoveFirst;
Remarks

For internal use.

See Also
FormsStringRes Class
Eco.Windows.Forms Namespace


FormsStringRes.sCaptionMoveLast Property

FormsStringRes.sCaptionMoveLast Property
FormsStringRes Class Eco.Windows.Forms Namespace See Also
Collapse All

Returns: "Last"

C#
public static string sCaptionMoveLast;
Remarks

For internal use.

See Also
FormsStringRes Class
Eco.Windows.Forms Namespace


FormsStringRes.sCaptionMoveNext Property

FormsStringRes.sCaptionMoveNext Property
FormsStringRes Class Eco.Windows.Forms Namespace See Also
Collapse All

Returns: "Next"

C#
public static string sCaptionMoveNext;
Remarks

For internal use.

See Also
FormsStringRes Class
Eco.Windows.Forms Namespace


FormsStringRes.sCaptionMovePrev Property

FormsStringRes.sCaptionMovePrev Property
FormsStringRes Class Eco.Windows.Forms Namespace See Also
Collapse All

Returns: "Prev"

C#
public static string sCaptionMovePrev;
Remarks

For internal use.

See Also
FormsStringRes Class
Eco.Windows.Forms Namespace


FormsStringRes.sCaptionMoveUp Property

FormsStringRes.sCaptionMoveUp Property
FormsStringRes Class Eco.Windows.Forms Namespace See Also
Collapse All

Returns: "Up"

C#
public static string sCaptionMoveUp;
Remarks

For internal use.

See Also
FormsStringRes Class
Eco.Windows.Forms Namespace


FormsStringRes.sCaptionRedo Property

FormsStringRes.sCaptionRedo Property
FormsStringRes Class Eco.Windows.Forms Namespace See Also
Collapse All

Returns: "Redo"

C#
public static string sCaptionRedo;
Remarks

For internal use.

See Also
FormsStringRes Class
Eco.Windows.Forms Namespace


FormsStringRes.sCaptionReload Property

FormsStringRes.sCaptionReload Property
FormsStringRes Class Eco.Windows.Forms Namespace See Also
Collapse All

Returns: "Reload"

C#
public static string sCaptionReload;
Remarks

For internal use.

See Also
FormsStringRes Class
Eco.Windows.Forms Namespace


FormsStringRes.sCaptionSetCheckpoint Property

FormsStringRes.sCaptionSetCheckpoint Property
FormsStringRes Class Eco.Windows.Forms Namespace See Also
Collapse All

Returns: "Set Checkpoint"

C#
public static string sCaptionSetCheckpoint;
Remarks

For internal use.

See Also
FormsStringRes Class
Eco.Windows.Forms Namespace


FormsStringRes.sCaptionShowAutoForm Property

FormsStringRes.sCaptionShowAutoForm Property
FormsStringRes Class Eco.Windows.Forms Namespace See Also
Collapse All

Returns: "Show Autoform"

C#
public static string sCaptionShowAutoForm;
Remarks

For internal use.

See Also
FormsStringRes Class
Eco.Windows.Forms Namespace


FormsStringRes.sCaptionShowDebugger Property

FormsStringRes.sCaptionShowDebugger Property
FormsStringRes Class Eco.Windows.Forms Namespace See Also
Collapse All

Returns: "Show ECO debugger"

C#
public static string sCaptionShowDebugger;
Remarks

For internal use.

See Also
FormsStringRes Class
Eco.Windows.Forms Namespace


FormsStringRes.sCaptionToggleActive Property

FormsStringRes.sCaptionToggleActive Property
FormsStringRes Class Eco.Windows.Forms Namespace See Also
Collapse All

Returns: "Activate"

C#
public static string sCaptionToggleActive;
Remarks

For internal use.

See Also
FormsStringRes Class
Eco.Windows.Forms Namespace


FormsStringRes.sCaptionToggleDeactivate Property

FormsStringRes.sCaptionToggleDeactivate Property
FormsStringRes Class Eco.Windows.Forms Namespace See Also
Collapse All

Returns: "Deactivate"

C#
public static string sCaptionToggleDeactivate;
Remarks

For internal use.

See Also
FormsStringRes Class
Eco.Windows.Forms Namespace


FormsStringRes.sCaptionUndo Property

FormsStringRes.sCaptionUndo Property
FormsStringRes Class Eco.Windows.Forms Namespace See Also
Collapse All

Returns: "Undo"

C#
public static string sCaptionUndo;
Remarks

For internal use.

See Also
FormsStringRes Class
Eco.Windows.Forms Namespace


FormsStringRes.sCaptionUnlink Property

FormsStringRes.sCaptionUnlink Property
FormsStringRes Class Eco.Windows.Forms Namespace See Also
Collapse All

Returns: "Unlink"

C#
public static string sCaptionUnlink;
Remarks

For internal use.

See Also
FormsStringRes Class
Eco.Windows.Forms Namespace


FormsStringRes.sCategoryBehaviour Property

FormsStringRes.sCategoryBehaviour Property
FormsStringRes Class Eco.Windows.Forms Namespace See Also
Collapse All

Returns: "Behaviour"

C#
public static string sCategoryBehaviour;
Remarks

For internal use.

See Also
FormsStringRes Class
Eco.Windows.Forms Namespace


FormsStringRes.sCategoryConnections Property

FormsStringRes.sCategoryConnections Property
FormsStringRes Class Eco.Windows.Forms Namespace See Also
Collapse All

Returns: "ECO|Connections"

C#
public static string sCategoryConnections;
Remarks

For internal use.

See Also
FormsStringRes Class
Eco.Windows.Forms Namespace


FormsStringRes.sCategoryEcoGui Property

FormsStringRes.sCategoryEcoGui Property
FormsStringRes Class Eco.Windows.Forms Namespace See Also
Collapse All

Returns: "ECO|GUI"

C#
public static string sCategoryEcoGui;
Remarks

For internal use.

See Also
FormsStringRes Class
Eco.Windows.Forms Namespace


FormsStringRes.sCategoryEcoListAction Property

FormsStringRes.sCategoryEcoListAction Property
FormsStringRes Class Eco.Windows.Forms Namespace See Also
Collapse All

Returns: "ECO|ListAction"

C#
public static string sCategoryEcoListAction;
Remarks

For internal use.

See Also
FormsStringRes Class
Eco.Windows.Forms Namespace


FormsStringRes.sCategoryPresentation Property

FormsStringRes.sCategoryPresentation Property
FormsStringRes Class Eco.Windows.Forms Namespace See Also
Collapse All

Returns: "ECO|Presentation"

C#
public static string sCategoryPresentation;
Remarks

For internal use.

See Also
FormsStringRes Class
Eco.Windows.Forms Namespace


FormsStringRes.sClassesAndOcl Property

FormsStringRes.sClassesAndOcl Property
FormsStringRes Class Eco.Windows.Forms Namespace See Also
Collapse All

Returns: "Classes and OCL"

C#
public static string sClassesAndOcl;
Remarks

For internal use.

See Also
FormsStringRes Class
Eco.Windows.Forms Namespace


FormsStringRes.sClassHasNoConstraints Property

FormsStringRes.sClassHasNoConstraints Property
FormsStringRes Class Eco.Windows.Forms Namespace See Also
Collapse All

Returns: "Class has no constraints"

C#
public static string sClassHasNoConstraints;
Remarks

For internal use.

See Also
FormsStringRes Class
Eco.Windows.Forms Namespace


FormsStringRes.sCleaningPSAborted Property

FormsStringRes.sCleaningPSAborted Property
FormsStringRes Class Eco.Windows.Forms Namespace See Also
Collapse All

Returns: "Cleaning of Persistent Storage Aborted"

C#
public static string sCleaningPSAborted;
Remarks

For internal use.

See Also
FormsStringRes Class
Eco.Windows.Forms Namespace


FormsStringRes.sCloseCaption Property

FormsStringRes.sCloseCaption Property
FormsStringRes Class Eco.Windows.Forms Namespace See Also
Collapse All

Returns: "Close"

C#
public static string sCloseCaption;
Remarks

For internal use.

See Also
FormsStringRes Class
Eco.Windows.Forms Namespace


FormsStringRes.sCMNotConnectedToElementHandle Property

FormsStringRes.sCMNotConnectedToElementHandle Property
FormsStringRes Class Eco.Windows.Forms Namespace See Also
Collapse All

Returns: "CurrencyManager not representing an ElementHandle"

C#
public static string sCMNotConnectedToElementHandle;
Remarks

For internal use.

See Also
FormsStringRes Class
Eco.Windows.Forms Namespace


FormsStringRes.sConstraintsBroken Property

FormsStringRes.sConstraintsBroken Property
FormsStringRes Class Eco.Windows.Forms Namespace See Also
Collapse All

Returns: "Constraints Broken"

C#
public static string sConstraintsBroken;
Remarks

For internal use.

See Also
FormsStringRes Class
Eco.Windows.Forms Namespace


FormsStringRes.sConstraintsOk Property

FormsStringRes.sConstraintsOk Property
FormsStringRes Class Eco.Windows.Forms Namespace See Also
Collapse All

Returns: "Constraints not broken"

C#
public static string sConstraintsOk;
Remarks

For internal use.

See Also
FormsStringRes Class
Eco.Windows.Forms Namespace


FormsStringRes.sCreationAborted Property

FormsStringRes.sCreationAborted Property
FormsStringRes Class Eco.Windows.Forms Namespace See Also
Collapse All

Returns: "Creation aborted"

C#
public static string sCreationAborted;
Remarks

For internal use.

See Also
FormsStringRes Class
Eco.Windows.Forms Namespace


FormsStringRes.sCurrencyManagerHandleHasNoBindingContext Property

FormsStringRes.sCurrencyManagerHandleHasNoBindingContext Property
FormsStringRes Class Eco.Windows.Forms Namespace See Also
Collapse All

Returns: "CurrencyManagerHandle has no BindingContext"

C#
public static string sCurrencyManagerHandleHasNoBindingContext;
Remarks

For internal use.

See Also
FormsStringRes Class
Eco.Windows.Forms Namespace


FormsStringRes.sDatabaseUpgradeSuccessful Property

FormsStringRes.sDatabaseUpgradeSuccessful Property
FormsStringRes Class Eco.Windows.Forms Namespace See Also
Collapse All

Returns: "Database successfully updated"

C#
public static string sDatabaseUpgradeSuccessful;
Remarks

For internal use.

See Also
FormsStringRes Class
Eco.Windows.Forms Namespace


FormsStringRes.sDataSourceRootHandleIncompatible Property

FormsStringRes.sDataSourceRootHandleIncompatible Property
FormsStringRes Class Eco.Windows.Forms Namespace See Also
Collapse All

Returns: "DataSource for the BindingContext must be the same as the RootHandle for this CurrencyManagerHandle"

C#
public static string sDataSourceRootHandleIncompatible;
Remarks

For internal use.

See Also
FormsStringRes Class
Eco.Windows.Forms Namespace


FormsStringRes.sDeleteQuestion Property

FormsStringRes.sDeleteQuestion Property
FormsStringRes Class Eco.Windows.Forms Namespace See Also
Collapse All

Returns: "Delete object(s)?"

C#
public static string sDeleteQuestion;
Remarks

For internal use.

See Also
FormsStringRes Class
Eco.Windows.Forms Namespace


FormsStringRes.sDirtyObjects Property

FormsStringRes.sDirtyObjects Property
FormsStringRes Class Eco.Windows.Forms Namespace See Also
Collapse All

Returns: "Dirty Objects"

C#
public static string sDirtyObjects;
Remarks

For internal use.

See Also
FormsStringRes Class
Eco.Windows.Forms Namespace


FormsStringRes.sDiscardChanges Property

FormsStringRes.sDiscardChanges Property
FormsStringRes Class Eco.Windows.Forms Namespace See Also
Collapse All

Returns: "Discard Changes"

C#
public static string sDiscardChanges;
Remarks

For internal use.

See Also
FormsStringRes Class
Eco.Windows.Forms Namespace


FormsStringRes.sEcoLog Property

FormsStringRes.sEcoLog Property
FormsStringRes Class Eco.Windows.Forms Namespace See Also
Collapse All

Returns: "ECO Log"

C#
public static string sEcoLog;
Remarks

For internal use.

See Also
FormsStringRes Class
Eco.Windows.Forms Namespace


FormsStringRes.sEmptyExpression Property

FormsStringRes.sEmptyExpression Property
FormsStringRes Class Eco.Windows.Forms Namespace See Also
Collapse All

Returns: "Empty Expression"

C#
public static string sEmptyExpression;
Remarks

For internal use.

See Also
FormsStringRes Class
Eco.Windows.Forms Namespace


FormsStringRes.sErrorEcoSpaceNotSet Property

FormsStringRes.sErrorEcoSpaceNotSet Property
FormsStringRes Class Eco.Windows.Forms Namespace See Also
Collapse All

Returns: "Could not find EcoSpace"

C#
public static string sErrorEcoSpaceNotSet;
Remarks

For internal use.

See Also
FormsStringRes Class
Eco.Windows.Forms Namespace


FormsStringRes.sErrorNotRooted Property

FormsStringRes.sErrorNotRooted Property
FormsStringRes Class Eco.Windows.Forms Namespace See Also
Collapse All

Returns: "Uplink chain not complete"

C#
public static string sErrorNotRooted;
Remarks

For internal use.

See Also
FormsStringRes Class
Eco.Windows.Forms Namespace


FormsStringRes.sErrorRootInactive Property

FormsStringRes.sErrorRootInactive Property
FormsStringRes Class Eco.Windows.Forms Namespace See Also
Collapse All

Returns: "Uplink handle not active"

C#
public static string sErrorRootInactive;
Remarks

For internal use.

See Also
FormsStringRes Class
Eco.Windows.Forms Namespace


FormsStringRes.sErrorSystemActive Property

FormsStringRes.sErrorSystemActive Property
FormsStringRes Class Eco.Windows.Forms Namespace See Also
Collapse All

Returns: "Cannot create schema on an active EcoSpace"

C#
public static string sErrorSystemActive;
Remarks

For internal use.

See Also
FormsStringRes Class
Eco.Windows.Forms Namespace


FormsStringRes.sErrorSystemInactive Property

FormsStringRes.sErrorSystemInactive Property
FormsStringRes Class Eco.Windows.Forms Namespace See Also
Collapse All

Returns: "Cannot perform operation on an inactive EcoSpace"

C#
public static string sErrorSystemInactive;
Remarks

For internal use.

See Also
FormsStringRes Class
Eco.Windows.Forms Namespace


FormsStringRes.sEvolutionAborted Property

FormsStringRes.sEvolutionAborted Property
FormsStringRes Class Eco.Windows.Forms Namespace See Also
Collapse All

Returns: "Evolution of Schema Aborted on User Request."

C#
public static string sEvolutionAborted;
Remarks

For internal use.

See Also
FormsStringRes Class
Eco.Windows.Forms Namespace


FormsStringRes.sEvolutionCaption Property

FormsStringRes.sEvolutionCaption Property
FormsStringRes Class Eco.Windows.Forms Namespace See Also
Collapse All

Returns: "Schema Evolution"

C#
public static string sEvolutionCaption;
Remarks

For internal use.

See Also
FormsStringRes Class
Eco.Windows.Forms Namespace


FormsStringRes.sExecutedStatementsWere Property

FormsStringRes.sExecutedStatementsWere Property
FormsStringRes Class Eco.Windows.Forms Namespace See Also
Collapse All

Returns: "The following statements were executed before evolution failed:"

C#
public static string sExecutedStatementsWere;
Remarks

For internal use.

See Also
FormsStringRes Class
Eco.Windows.Forms Namespace


FormsStringRes.sExpressionIsOk Property

FormsStringRes.sExpressionIsOk Property
FormsStringRes Class Eco.Windows.Forms Namespace See Also
Collapse All

Returns: "OCL Expression is OK"

C#
public static string sExpressionIsOk;
Remarks

For internal use.

See Also
FormsStringRes Class
Eco.Windows.Forms Namespace


FormsStringRes.sFatalError Property

FormsStringRes.sFatalError Property
FormsStringRes Class Eco.Windows.Forms Namespace See Also
Collapse All

Returns: "Fatal Error"

C#
public static string sFatalError;
Remarks

For internal use.

See Also
FormsStringRes Class
Eco.Windows.Forms Namespace


FormsStringRes.sHandleHasNoList Property

FormsStringRes.sHandleHasNoList Property
FormsStringRes Class Eco.Windows.Forms Namespace See Also
Collapse All

Returns: "Could not extract object list from handle"

C#
public static string sHandleHasNoList;
Remarks

For internal use.

See Also
FormsStringRes Class
Eco.Windows.Forms Namespace


FormsStringRes.sHandleNotSet Property

FormsStringRes.sHandleNotSet Property
FormsStringRes Class Eco.Windows.Forms Namespace See Also
Collapse All

Returns: "Cannot look up CurrencyManager because RootHandle not found (or not set)"

C#
public static string sHandleNotSet;
Remarks

For internal use.

See Also
FormsStringRes Class
Eco.Windows.Forms Namespace


FormsStringRes.sInvalidModel Property

FormsStringRes.sInvalidModel Property
FormsStringRes Class Eco.Windows.Forms Namespace See Also
Collapse All

Returns: "Model is invalid:"

C#
public static string sInvalidModel;
Remarks

For internal use.

See Also
FormsStringRes Class
Eco.Windows.Forms Namespace


FormsStringRes.sMethodsTabCaption Property

FormsStringRes.sMethodsTabCaption Property
FormsStringRes Class Eco.Windows.Forms Namespace See Also
Collapse All

Returns: "Methods"

C#
public static string sMethodsTabCaption;
Remarks

For internal use.

See Also
FormsStringRes Class
Eco.Windows.Forms Namespace


FormsStringRes.sNeedRecompile Property

FormsStringRes.sNeedRecompile Property
FormsStringRes Class Eco.Windows.Forms Namespace See Also
Collapse All

Returns: "[Model not recently compiled]"

C#
public static string sNeedRecompile;
Remarks

For internal use.

See Also
FormsStringRes Class
Eco.Windows.Forms Namespace


FormsStringRes.sNoActionNeeded Property

FormsStringRes.sNoActionNeeded Property
FormsStringRes Class Eco.Windows.Forms Namespace See Also
Collapse All

Returns: "No action needed"

C#
public static string sNoActionNeeded;
Remarks

For internal use.

See Also
FormsStringRes Class
Eco.Windows.Forms Namespace


FormsStringRes.sNoContext Property

FormsStringRes.sNoContext Property
FormsStringRes Class Eco.Windows.Forms Namespace See Also
Collapse All

Returns: "There is no context for this expression"

C#
public static string sNoContext;
Remarks

For internal use.

See Also
FormsStringRes Class
Eco.Windows.Forms Namespace


FormsStringRes.sNodeNameAttributes Property

FormsStringRes.sNodeNameAttributes Property
FormsStringRes Class Eco.Windows.Forms Namespace See Also
Collapse All

Returns: "Attributes"

C#
public static string sNodeNameAttributes;
Remarks

For internal use.

See Also
FormsStringRes Class
Eco.Windows.Forms Namespace


FormsStringRes.sNodeNameClasses Property

FormsStringRes.sNodeNameClasses Property
FormsStringRes Class Eco.Windows.Forms Namespace See Also
Collapse All

Returns: "Classes"

C#
public static string sNodeNameClasses;
Remarks

For internal use.

See Also
FormsStringRes Class
Eco.Windows.Forms Namespace


FormsStringRes.sNodeNameMethods Property

FormsStringRes.sNodeNameMethods Property
FormsStringRes Class Eco.Windows.Forms Namespace See Also
Collapse All

Returns: "Methods"

C#
public static string sNodeNameMethods;
Remarks

For internal use.

See Also
FormsStringRes Class
Eco.Windows.Forms Namespace


FormsStringRes.sNodeNameOcloperations Property

FormsStringRes.sNodeNameOcloperations Property
FormsStringRes Class Eco.Windows.Forms Namespace See Also
Collapse All

Returns: "OCL operations"

C#
public static string sNodeNameOcloperations;
Remarks

For internal use.

See Also
FormsStringRes Class
Eco.Windows.Forms Namespace


FormsStringRes.sNodeNameRoles Property

FormsStringRes.sNodeNameRoles Property
FormsStringRes Class Eco.Windows.Forms Namespace See Also
Collapse All

Returns: "Roles"

C#
public static string sNodeNameRoles;
Remarks

For internal use.

See Also
FormsStringRes Class
Eco.Windows.Forms Namespace


FormsStringRes.sNodeNameTriggerqueries Property

FormsStringRes.sNodeNameTriggerqueries Property
FormsStringRes Class Eco.Windows.Forms Namespace See Also
Collapse All

Returns: "Trigger queries"

C#
public static string sNodeNameTriggerqueries;
Remarks

For internal use.

See Also
FormsStringRes Class
Eco.Windows.Forms Namespace


FormsStringRes.sNodeNameTriggers Property

FormsStringRes.sNodeNameTriggers Property
FormsStringRes Class Eco.Windows.Forms Namespace See Also
Collapse All

Returns: "Triggers"

C#
public static string sNodeNameTriggers;
Remarks

For internal use.

See Also
FormsStringRes Class
Eco.Windows.Forms Namespace


FormsStringRes.sNodeNameVariables Property

FormsStringRes.sNodeNameVariables Property
FormsStringRes Class Eco.Windows.Forms Namespace See Also
Collapse All

Returns: "Variables"

C#
public static string sNodeNameVariables;
Remarks

For internal use.

See Also
FormsStringRes Class
Eco.Windows.Forms Namespace


FormsStringRes.sNoTablesToSelectFrom Property

FormsStringRes.sNoTablesToSelectFrom Property
FormsStringRes Class Eco.Windows.Forms Namespace See Also
Collapse All

Returns: "<<no tables to select from>>"

C#
public static string sNoTablesToSelectFrom;
Remarks

For internal use.

See Also
FormsStringRes Class
Eco.Windows.Forms Namespace


FormsStringRes.sNoUpdateNeeded Property

FormsStringRes.sNoUpdateNeeded Property
FormsStringRes Class Eco.Windows.Forms Namespace See Also
Collapse All

Returns: "No update needed!"

C#
public static string sNoUpdateNeeded;
Remarks

For internal use.

See Also
FormsStringRes Class
Eco.Windows.Forms Namespace


FormsStringRes.sOclEditorCaption Property

FormsStringRes.sOclEditorCaption Property
FormsStringRes Class Eco.Windows.Forms Namespace See Also
Collapse All

Returns: "OCL editor"

C#
public static string sOclEditorCaption;
Remarks

For internal use.

See Also
FormsStringRes Class
Eco.Windows.Forms Namespace


FormsStringRes.sOclPsEditorCaption Property

FormsStringRes.sOclPsEditorCaption Property
FormsStringRes Class Eco.Windows.Forms Namespace See Also
Collapse All

Returns: "OclPs editor"

C#
public static string sOclPsEditorCaption;
Remarks

For internal use.

See Also
FormsStringRes Class
Eco.Windows.Forms Namespace


FormsStringRes.sOperationCallFailed Property

FormsStringRes.sOperationCallFailed Property
FormsStringRes Class Eco.Windows.Forms Namespace See Also
Collapse All

Returns: "Operation call failed"

C#
public static string sOperationCallFailed;
Remarks

For internal use.

See Also
FormsStringRes Class
Eco.Windows.Forms Namespace


FormsStringRes.sPropertyActionExtenderElementHandle Property

FormsStringRes.sPropertyActionExtenderElementHandle Property
FormsStringRes Class Eco.Windows.Forms Namespace See Also
Collapse All

Returns: "This property should be set to a handle ultimately linked to an EcoSpace."

C#
public static string sPropertyActionExtenderElementHandle;
Remarks

For internal use.

See Also
FormsStringRes Class
Eco.Windows.Forms Namespace


FormsStringRes.sPropertyActionOcl Property

FormsStringRes.sPropertyActionOcl Property
FormsStringRes Class Eco.Windows.Forms Namespace See Also
Collapse All

Returns: "EcoActionLanguage expression to be executed."

C#
public static string sPropertyActionOcl;
Remarks

For internal use.

See Also
FormsStringRes Class
Eco.Windows.Forms Namespace


FormsStringRes.sPropertyCaptionAction Property

FormsStringRes.sPropertyCaptionAction Property
FormsStringRes Class Eco.Windows.Forms Namespace See Also
Collapse All

Returns: "Default caption used when action-property set to Action."

C#
public static string sPropertyCaptionAction;
Remarks

For internal use.

See Also
FormsStringRes Class
Eco.Windows.Forms Namespace


FormsStringRes.sPropertyCaptionAdd Property

FormsStringRes.sPropertyCaptionAdd Property
FormsStringRes Class Eco.Windows.Forms Namespace See Also
Collapse All

Returns: "Default caption used when action-property set to Add."

C#
public static string sPropertyCaptionAdd;
Remarks

For internal use.

See Also
FormsStringRes Class
Eco.Windows.Forms Namespace


FormsStringRes.sPropertyCaptionCreateSchema Property

FormsStringRes.sPropertyCaptionCreateSchema Property
FormsStringRes Class Eco.Windows.Forms Namespace See Also
Collapse All

Returns: "Default caption used when action-property set to CreateSchema."

C#
public static string sPropertyCaptionCreateSchema;
Remarks

For internal use.

See Also
FormsStringRes Class
Eco.Windows.Forms Namespace


FormsStringRes.sPropertyCaptionDelete Property

FormsStringRes.sPropertyCaptionDelete Property
FormsStringRes Class Eco.Windows.Forms Namespace See Also
Collapse All

Returns: "Default caption used when action-property set to Delete."

C#
public static string sPropertyCaptionDelete;
Remarks

For internal use.

See Also
FormsStringRes Class
Eco.Windows.Forms Namespace


FormsStringRes.sPropertyCaptionDiscardChanges Property

FormsStringRes.sPropertyCaptionDiscardChanges Property
FormsStringRes Class Eco.Windows.Forms Namespace See Also
Collapse All

Returns: "Default caption used when action-property set to DiscardChanges."

C#
public static string sPropertyCaptionDiscardChanges;
Remarks

For internal use.

See Also
FormsStringRes Class
Eco.Windows.Forms Namespace


FormsStringRes.sPropertyCaptionEvolveSchema Property

FormsStringRes.sPropertyCaptionEvolveSchema Property
FormsStringRes Class Eco.Windows.Forms Namespace See Also
Collapse All

Returns: "Default caption used when action-property set to EvolveSchema."

C#
public static string sPropertyCaptionEvolveSchema;
Remarks

For internal use.

See Also
FormsStringRes Class
Eco.Windows.Forms Namespace


FormsStringRes.sPropertyCaptionMoveDown Property

FormsStringRes.sPropertyCaptionMoveDown Property
FormsStringRes Class Eco.Windows.Forms Namespace See Also
Collapse All

Returns: "Default caption used when action-property set to MoveDown."

C#
public static string sPropertyCaptionMoveDown;
Remarks

For internal use.

See Also
FormsStringRes Class
Eco.Windows.Forms Namespace


FormsStringRes.sPropertyCaptionMoveFirst Property

FormsStringRes.sPropertyCaptionMoveFirst Property
FormsStringRes Class Eco.Windows.Forms Namespace See Also
Collapse All

Returns: "Default caption used when action-property set to MoveFirst."

C#
public static string sPropertyCaptionMoveFirst;
Remarks

For internal use.

See Also
FormsStringRes Class
Eco.Windows.Forms Namespace


FormsStringRes.sPropertyCaptionMoveLast Property

FormsStringRes.sPropertyCaptionMoveLast Property
FormsStringRes Class Eco.Windows.Forms Namespace See Also
Collapse All

Returns: "Default caption used when action-property set to MoveLast."

C#
public static string sPropertyCaptionMoveLast;
Remarks

For internal use.

See Also
FormsStringRes Class
Eco.Windows.Forms Namespace


FormsStringRes.sPropertyCaptionMoveNext Property

FormsStringRes.sPropertyCaptionMoveNext Property
FormsStringRes Class Eco.Windows.Forms Namespace See Also
Collapse All

Returns: "Default caption used when action-property set to MoveNext."

C#
public static string sPropertyCaptionMoveNext;
Remarks

For internal use.

See Also
FormsStringRes Class
Eco.Windows.Forms Namespace


FormsStringRes.sPropertyCaptionMovePrev Property

FormsStringRes.sPropertyCaptionMovePrev Property
FormsStringRes Class Eco.Windows.Forms Namespace See Also
Collapse All

Returns: "Default caption used when action-property set to MovePrev."

C#
public static string sPropertyCaptionMovePrev;
Remarks

For internal use.

See Also
FormsStringRes Class
Eco.Windows.Forms Namespace


FormsStringRes.sPropertyCaptionMoveUp Property

FormsStringRes.sPropertyCaptionMoveUp Property
FormsStringRes Class Eco.Windows.Forms Namespace See Also
Collapse All

Returns: "Default caption used when action-property set to MoveUp."

C#
public static string sPropertyCaptionMoveUp;
Remarks

For internal use.

See Also
FormsStringRes Class
Eco.Windows.Forms Namespace


FormsStringRes.sPropertyCaptionRedo Property

FormsStringRes.sPropertyCaptionRedo Property
FormsStringRes Class Eco.Windows.Forms Namespace See Also
Collapse All

Returns: "Default caption used when action-property set to Redo."

C#
public static string sPropertyCaptionRedo;
Remarks

For internal use.

See Also
FormsStringRes Class
Eco.Windows.Forms Namespace


FormsStringRes.sPropertyCaptionReload Property

FormsStringRes.sPropertyCaptionReload Property
FormsStringRes Class Eco.Windows.Forms Namespace See Also
Collapse All

Returns: "Default caption used when action-property set to Reload."

C#
public static string sPropertyCaptionReload;
Remarks

For internal use.

See Also
FormsStringRes Class
Eco.Windows.Forms Namespace


FormsStringRes.sPropertyCaptionSetCheckpoint Property

FormsStringRes.sPropertyCaptionSetCheckpoint Property
FormsStringRes Class Eco.Windows.Forms Namespace See Also
Collapse All

Returns: "Default caption used when action-property set to SetCheckPoint."

C#
public static string sPropertyCaptionSetCheckpoint;
Remarks

For internal use.

See Also
FormsStringRes Class
Eco.Windows.Forms Namespace


FormsStringRes.sPropertyCaptionShowAutoForm Property

FormsStringRes.sPropertyCaptionShowAutoForm Property
FormsStringRes Class Eco.Windows.Forms Namespace See Also
Collapse All

Returns: "Default caption used when action-property set to ShowAutoform."

C#
public static string sPropertyCaptionShowAutoForm;
Remarks

For internal use.

See Also
FormsStringRes Class
Eco.Windows.Forms Namespace


FormsStringRes.sPropertyCaptionShowDebugger Property

FormsStringRes.sPropertyCaptionShowDebugger Property
FormsStringRes Class Eco.Windows.Forms Namespace See Also
Collapse All

Returns: "Default caption used when action-property set to ShowDebugger."

C#
public static string sPropertyCaptionShowDebugger;
Remarks

For internal use.

See Also
FormsStringRes Class
Eco.Windows.Forms Namespace


FormsStringRes.sPropertyCaptionToggleActive Property

FormsStringRes.sPropertyCaptionToggleActive Property
FormsStringRes Class Eco.Windows.Forms Namespace See Also
Collapse All

Returns: "Default caption used when action-property set to ToggleActive and EcoSpace is inactive."

C#
public static string sPropertyCaptionToggleActive;
Remarks

For internal use.

See Also
FormsStringRes Class
Eco.Windows.Forms Namespace


FormsStringRes.sPropertyCaptionToggleDeactivate Property

FormsStringRes.sPropertyCaptionToggleDeactivate Property
FormsStringRes Class Eco.Windows.Forms Namespace See Also
Collapse All

Returns: "Default caption used when action-property set to ToggleActive and EcoSpace is active."

C#
public static string sPropertyCaptionToggleDeactivate;
Remarks

For internal use.

See Also
FormsStringRes Class
Eco.Windows.Forms Namespace


FormsStringRes.sPropertyCaptionUndo Property

FormsStringRes.sPropertyCaptionUndo Property
FormsStringRes Class Eco.Windows.Forms Namespace See Also
Collapse All

Returns: "Default caption used when action-property set to Undo."

C#
public static string sPropertyCaptionUndo;
Remarks

For internal use.

See Also
FormsStringRes Class
Eco.Windows.Forms Namespace


FormsStringRes.sPropertyCaptionUnlink Property

FormsStringRes.sPropertyCaptionUnlink Property
FormsStringRes Class Eco.Windows.Forms Namespace See Also
Collapse All

Returns: "Default caption used when action-property set to Unlink."

C#
public static string sPropertyCaptionUnlink;
Remarks

For internal use.

See Also
FormsStringRes Class
Eco.Windows.Forms Namespace


FormsStringRes.sPropertyCaptionUpdateDatabase Property

FormsStringRes.sPropertyCaptionUpdateDatabase Property
FormsStringRes Class Eco.Windows.Forms Namespace See Also
Collapse All

Returns: "Default caption used when action-property set to UpdateDatabase."

C#
public static string sPropertyCaptionUpdateDatabase;
Remarks

For internal use.

See Also
FormsStringRes Class
Eco.Windows.Forms Namespace


FormsStringRes.sPropertyDeleteQuestion Property

FormsStringRes.sPropertyDeleteQuestion Property
FormsStringRes Class Eco.Windows.Forms Namespace See Also
Collapse All

Returns: "Question used when action-property set to Delete and action is performed."

C#
public static string sPropertyDeleteQuestion;
Remarks

For internal use.

See Also
FormsStringRes Class
Eco.Windows.Forms Namespace


FormsStringRes.sPropertyEcoAutoForm Property

FormsStringRes.sPropertyEcoAutoForm Property
FormsStringRes Class Eco.Windows.Forms Namespace See Also
Collapse All

Returns: "Enables autoforms to show on double-click."

C#
public static string sPropertyEcoAutoForm;
Remarks

For internal use.

See Also
FormsStringRes Class
Eco.Windows.Forms Namespace


FormsStringRes.sPropertyEcoAutoFormReadOnly Property

FormsStringRes.sPropertyEcoAutoFormReadOnly Property
FormsStringRes Class Eco.Windows.Forms Namespace See Also
Collapse All

Returns: "Makes the Autoform Readonly."

C#
public static string sPropertyEcoAutoFormReadOnly;
Remarks

For internal use.

See Also
FormsStringRes Class
Eco.Windows.Forms Namespace


FormsStringRes.sPropertyEcoDragSource Property

FormsStringRes.sPropertyEcoDragSource Property
FormsStringRes Class Eco.Windows.Forms Namespace See Also
Collapse All

Returns: "Allows component to be drag source in model driven D&&D."

C#
public static string sPropertyEcoDragSource;
Remarks

For internal use.

See Also
FormsStringRes Class
Eco.Windows.Forms Namespace


FormsStringRes.sPropertyEcoDropTarget Property

FormsStringRes.sPropertyEcoDropTarget Property
FormsStringRes Class Eco.Windows.Forms Namespace See Also
Collapse All

Returns: "Allows component to be drop target in model driven D&&D."

C#
public static string sPropertyEcoDropTarget;
Remarks

For internal use.

See Also
FormsStringRes Class
Eco.Windows.Forms Namespace


FormsStringRes.sPropertyEcoListAction Property

FormsStringRes.sPropertyEcoListAction Property
FormsStringRes Class Eco.Windows.Forms Namespace See Also
Collapse All

Returns: "Action to perform."

C#
public static string sPropertyEcoListAction;
Remarks

For internal use.

See Also
FormsStringRes Class
Eco.Windows.Forms Namespace


FormsStringRes.sPropertyEnabledOcl Property

FormsStringRes.sPropertyEnabledOcl Property
FormsStringRes Class Eco.Windows.Forms Namespace See Also
Collapse All

Returns: "OCL expression controlling the enabled property of this control."

C#
public static string sPropertyEnabledOcl;
Remarks

For internal use.

See Also
FormsStringRes Class
Eco.Windows.Forms Namespace


FormsStringRes.sPropertyExtenderContainerReusage Property

FormsStringRes.sPropertyExtenderContainerReusage Property
FormsStringRes Class Eco.Windows.Forms Namespace See Also
Collapse All

Returns: "Controls how new forms should be created or reused."

C#
public static string sPropertyExtenderContainerReusage;
Remarks

For internal use.

See Also
FormsStringRes Class
Eco.Windows.Forms Namespace


FormsStringRes.sPropertyExtenderEnabled Property

FormsStringRes.sPropertyExtenderEnabled Property
FormsStringRes Class Eco.Windows.Forms Namespace See Also
Collapse All

Returns: "Indicates whether the control is enabled."

C#
public static string sPropertyExtenderEnabled;
Remarks

For internal use.

See Also
FormsStringRes Class
Eco.Windows.Forms Namespace


FormsStringRes.sPropertyExtenderMemberVisibility Property

FormsStringRes.sPropertyExtenderMemberVisibility Property
FormsStringRes Class Eco.Windows.Forms Namespace See Also
Collapse All

Returns: "Determines which level of visibility for members will be included in auto form."

C#
public static string sPropertyExtenderMemberVisibility;
Remarks

For internal use.

See Also
FormsStringRes Class
Eco.Windows.Forms Namespace


FormsStringRes.sPropertyExtenderShowModal Property

FormsStringRes.sPropertyExtenderShowModal Property
FormsStringRes Class Eco.Windows.Forms Namespace See Also
Collapse All

Returns: "Show the autoforms modally."

C#
public static string sPropertyExtenderShowModal;
Remarks

For internal use.

See Also
FormsStringRes Class
Eco.Windows.Forms Namespace


FormsStringRes.sPropertyRootHandle Property

FormsStringRes.sPropertyRootHandle Property
FormsStringRes Class Eco.Windows.Forms Namespace See Also
Collapse All

Returns: "Handle supplying uplink value."

C#
public static string sPropertyRootHandle;
Remarks

For internal use.

See Also
FormsStringRes Class
Eco.Windows.Forms Namespace


FormsStringRes.sPropertyUnlinkQuestion Property

FormsStringRes.sPropertyUnlinkQuestion Property
FormsStringRes Class Eco.Windows.Forms Namespace See Also
Collapse All

Returns: "Question used when action-property set to Unlink and action is performed."

C#
public static string sPropertyUnlinkQuestion;
Remarks

For internal use.

See Also
FormsStringRes Class
Eco.Windows.Forms Namespace


FormsStringRes.sPropertyVisibleOcl Property

FormsStringRes.sPropertyVisibleOcl Property
FormsStringRes Class Eco.Windows.Forms Namespace See Also
Collapse All

Returns: "OCL expression controlling the visible property of this control."

C#
public static string sPropertyVisibleOcl;
Remarks

For internal use.

See Also
FormsStringRes Class
Eco.Windows.Forms Namespace


FormsStringRes.sRefreshConstraints Property

FormsStringRes.sRefreshConstraints Property
FormsStringRes Class Eco.Windows.Forms Namespace See Also
Collapse All

Returns: "Refresh Constraints"

C#
public static string sRefreshConstraints;
Remarks

For internal use.

See Also
FormsStringRes Class
Eco.Windows.Forms Namespace


FormsStringRes.sReviewChangesCarefully Property

FormsStringRes.sReviewChangesCarefully Property
FormsStringRes Class Eco.Windows.Forms Namespace See Also
Collapse All

Returns: "Please inspect the planned actions and decide if you want to execute them. Make sure you back up your critical data before evolving the schema!!!"

C#
public static string sReviewChangesCarefully;
Remarks

For internal use.

See Also
FormsStringRes Class
Eco.Windows.Forms Namespace


FormsStringRes.sStartDetectChanges Property

FormsStringRes.sStartDetectChanges Property
FormsStringRes Class Eco.Windows.Forms Namespace See Also
Collapse All

Returns: "Detecting changes"

C#
public static string sStartDetectChanges;
Remarks

For internal use.

See Also
FormsStringRes Class
Eco.Windows.Forms Namespace


FormsStringRes.sStateTabCaption Property

FormsStringRes.sStateTabCaption Property
FormsStringRes Class Eco.Windows.Forms Namespace See Also
Collapse All

Returns: "State"

C#
public static string sStateTabCaption;
Remarks

For internal use.

See Also
FormsStringRes Class
Eco.Windows.Forms Namespace


FormsStringRes.sSyntaxIsOk Property

FormsStringRes.sSyntaxIsOk Property
FormsStringRes Class Eco.Windows.Forms Namespace See Also
Collapse All

Returns: "Syntax is OK."

C#
public static string sSyntaxIsOk;
Remarks

For internal use.

See Also
FormsStringRes Class
Eco.Windows.Forms Namespace


FormsStringRes.sUndoRedo Property

FormsStringRes.sUndoRedo Property
FormsStringRes Class Eco.Windows.Forms Namespace See Also
Collapse All

Returns: "Undo/Redo"

C#
public static string sUndoRedo;
Remarks

For internal use.

See Also
FormsStringRes Class
Eco.Windows.Forms Namespace


FormsStringRes.sUnknown Property

FormsStringRes.sUnknown Property
FormsStringRes Class Eco.Windows.Forms Namespace See Also
Collapse All

Returns: "unknown"

C#
public static string sUnknown;
Remarks

For internal use.

See Also
FormsStringRes Class
Eco.Windows.Forms Namespace


FormsStringRes.sUnlinkQuestion Property

FormsStringRes.sUnlinkQuestion Property
FormsStringRes Class Eco.Windows.Forms Namespace See Also
Collapse All

Returns: "Unlink object?"

C#
public static string sUnlinkQuestion;
Remarks

For internal use.

See Also
FormsStringRes Class
Eco.Windows.Forms Namespace


FormsStringRes.sUpdateDatabase Property

FormsStringRes.sUpdateDatabase Property
FormsStringRes Class Eco.Windows.Forms Namespace See Also
Collapse All

Returns: "Update DB"

C#
public static string sUpdateDatabase;
Remarks

For internal use.

See Also
FormsStringRes Class
Eco.Windows.Forms Namespace


FormsStringRes.sWrongExpectedType Property

FormsStringRes.sWrongExpectedType Property
FormsStringRes Class Eco.Windows.Forms Namespace See Also
Collapse All

Returns: "Syntax is OK, but the return type is invalid."

C#
public static string sWrongExpectedType;
Remarks

For internal use.

See Also
FormsStringRes Class
Eco.Windows.Forms Namespace


LoggerDebuggerPanel Class

LoggerDebuggerPanel Class
Inheritance Hierarchy See Also
Collapse All

This class form part of the EcoSpace debugger. It is not intended to be used directly.

C#
public class LoggerDebuggerPanel : System.Windows.Forms.Form, IEcoSpaceDebuggerPanel;
Inheritance Hierarchy
Eco.Windows.Forms.IEcoSpaceDebuggerPanel
System.Windows.Forms.Form
    Eco.Windows.Forms.LoggerDebuggerPanel
File

Eco.Windows.Forms.LoggerDebuggerPanel.cs

See Also
Inheritance Hierarchy


LoggerDebuggerPanel.LoggerDebuggerPanel Constructor

LoggerDebuggerPanel.LoggerDebuggerPanel Constructor
LoggerDebuggerPanel Class Eco.Windows.Forms Namespace See Also
Collapse All
C#
public LoggerDebuggerPanel();
Remarks

This is LoggerDebuggerPanel, a member of class LoggerDebuggerPanel.

See Also
LoggerDebuggerPanel Class
Eco.Windows.Forms Namespace


LoggerDebuggerPanel Methods

LoggerDebuggerPanel Methods
Protected Methods
Collapse All

The methods of the LoggerDebuggerPanel class are listed here.

Protected Methods
Name | Description
Dispose | Clean up any resources being used.


LoggerDebuggerPanel.Dispose Method

LoggerDebuggerPanel.Dispose Method
LoggerDebuggerPanel Class Eco.Windows.Forms Namespace See Also
Collapse All

Clean up any resources being used.

C#
protected override void Dispose(
    bool disposing
);
See Also
LoggerDebuggerPanel Class
Eco.Windows.Forms Namespace


LoggerDebuggerPanel Properties

LoggerDebuggerPanel Properties
Public Properties
Collapse All

The properties of the LoggerDebuggerPanel class are listed here.

Public Properties
Name | Description
DirtyListService | This is DirtyListService, a member of class LoggerDebuggerPanel.
EcoSpace | This is EcoSpace, a member of class LoggerDebuggerPanel.
ExtentService | This is ExtentService, a member of class LoggerDebuggerPanel.
ObjectFactoryService | This is ObjectFactoryService, a member of class LoggerDebuggerPanel.
OclService | This is OclService, a member of class LoggerDebuggerPanel.
PersistenceService | This is PersistenceService, a member of class LoggerDebuggerPanel.
TypeSystemService | This is TypeSystemService, a member of class LoggerDebuggerPanel.
UndoService | This is UndoService, a member of class LoggerDebuggerPanel.
VariableFactoryService | This is VariableFactoryService, a member of class LoggerDebuggerPanel.


LoggerDebuggerPanel.DirtyListService Property

LoggerDebuggerPanel.DirtyListService Property
LoggerDebuggerPanel Class Eco.Windows.Forms Namespace See Also
Collapse All
C#
public IDirtyListService DirtyListService;
Remarks

This is DirtyListService, a member of class LoggerDebuggerPanel.

See Also
LoggerDebuggerPanel Class
Eco.Windows.Forms Namespace


LoggerDebuggerPanel.EcoSpace Property

LoggerDebuggerPanel.EcoSpace Property
LoggerDebuggerPanel Class Eco.Windows.Forms Namespace See Also
Collapse All
C#
public Eco.Handles.EcoSpace EcoSpace;
Remarks

This is EcoSpace, a member of class LoggerDebuggerPanel.

See Also
LoggerDebuggerPanel Class
Eco.Windows.Forms Namespace


LoggerDebuggerPanel.ExtentService Property

LoggerDebuggerPanel.ExtentService Property
LoggerDebuggerPanel Class Eco.Windows.Forms Namespace See Also
Collapse All
C#
public IExtentService ExtentService;
Remarks

This is ExtentService, a member of class LoggerDebuggerPanel.

See Also
LoggerDebuggerPanel Class
Eco.Windows.Forms Namespace


LoggerDebuggerPanel.ObjectFactoryService Property

LoggerDebuggerPanel.ObjectFactoryService Property
LoggerDebuggerPanel Class Eco.Windows.Forms Namespace See Also
Collapse All
C#
public IObjectFactoryService ObjectFactoryService;
Remarks

This is ObjectFactoryService, a member of class LoggerDebuggerPanel.

See Also
LoggerDebuggerPanel Class
Eco.Windows.Forms Namespace


LoggerDebuggerPanel.OclService Property

LoggerDebuggerPanel.OclService Property
LoggerDebuggerPanel Class Eco.Windows.Forms Namespace See Also
Collapse All
C#
public IOclService OclService;
Remarks

This is OclService, a member of class LoggerDebuggerPanel.

See Also
LoggerDebuggerPanel Class
Eco.Windows.Forms Namespace


LoggerDebuggerPanel.PersistenceService Property

LoggerDebuggerPanel.PersistenceService Property
LoggerDebuggerPanel Class Eco.Windows.Forms Namespace See Also
Collapse All
C#
public IPersistenceService PersistenceService;
Remarks

This is PersistenceService, a member of class LoggerDebuggerPanel.

See Also
LoggerDebuggerPanel Class
Eco.Windows.Forms Namespace


LoggerDebuggerPanel.TypeSystemService Property

LoggerDebuggerPanel.TypeSystemService Property
LoggerDebuggerPanel Class Eco.Windows.Forms Namespace See Also
Collapse All
C#
public ITypeSystemService TypeSystemService;
Remarks

This is TypeSystemService, a member of class LoggerDebuggerPanel.

See Also
LoggerDebuggerPanel Class
Eco.Windows.Forms Namespace


LoggerDebuggerPanel.UndoService Property

LoggerDebuggerPanel.UndoService Property
LoggerDebuggerPanel Class Eco.Windows.Forms Namespace See Also
Collapse All
C#
public IUndoService UndoService;
Remarks

This is UndoService, a member of class LoggerDebuggerPanel.

See Also
LoggerDebuggerPanel Class
Eco.Windows.Forms Namespace


LoggerDebuggerPanel.VariableFactoryService Property

LoggerDebuggerPanel.VariableFactoryService Property
LoggerDebuggerPanel Class Eco.Windows.Forms Namespace See Also
Collapse All
C#
public IVariableFactoryService VariableFactoryService;
Remarks

This is VariableFactoryService, a member of class LoggerDebuggerPanel.

See Also
LoggerDebuggerPanel Class
Eco.Windows.Forms Namespace


MethodCallBuilder Class

MethodCallBuilder Class
Inheritance Hierarchy See Also
Collapse All

This class builds controls representing the method members of a type on a surface. It is used by the DefaultAutoForm but can be used stand alone if there is need to quickly get a UI representations of an object's methods.

C#
public sealed class MethodCallBuilder;
Inheritance Hierarchy
Eco.Windows.Forms.MethodCallBuilder
File

MethodCallBuilder.cs

See Also
Inheritance Hierarchy


MethodCallBuilder Methods

MethodCallBuilder Methods
Public Methods
Collapse All

The methods of the MethodCallBuilder class are listed here.

Public Methods
Name | Description
BuildControls | Builds controls for the methods of modelElement on hostControl and binds them to the handle.
BuildControlsForMethod | Builds controls for a single method on hostControl.


MethodCallBuilder.BuildControls Method

MethodCallBuilder.BuildControls Method
MethodCallBuilder Class Eco.Windows.Forms Namespace See Also
Collapse All

Builds controls for the methods of modelElement on hostControl and binds them to the handle.

C#
public static void BuildControls(
    Control hostControl,
    EcoSpace ecoSpace,
    ElementHandle handle,
    IClass umlClass,
    AutoContainerArgs autoContainerArgs
);
Parameters
Parameters | Description
hostControl | The control used as container for created controls.
ecoSpace | AutoContainerArgs used when bringing up new autoforms.
handle | The handle is used for data binding.
umlClass | The IModelElement used to get the static information about the methods.
autoContainerArgs | AutoContainerArgs used to control which methods get included in the form.
Exceptions
Exceptions | Description
ArgumentNullException | Thrown if hostControl is null. Thrown if umlClass is null.
See Also
MethodCallBuilder Class
Eco.Windows.Forms Namespace


MethodCallBuilder.BuildControlsForMethod Method

MethodCallBuilder.BuildControlsForMethod Method
MethodCallBuilder Class Eco.Windows.Forms Namespace See Also
Collapse All

Builds controls for a single method on hostControl.

C#
public static void BuildControlsForMethod(
    Control hostControl,
    EcoSpace ecoSpace,
    ElementHandle handle,
    IMethod method
);
Parameters
Parameters | Description
hostControl | The control used as container for created controls.
ecoSpace | EcoSpace used when bringing up new autoforms.
handle | The handle is used for data binding.
method | The IMethod used to get the static information about the parameters.
Exceptions
Exceptions | Description
ArgumentNullException | Thrown if hostControl is null.
See Also
MethodCallBuilder Class
Eco.Windows.Forms Namespace


MultilinkBuilder Class

MultilinkBuilder Class
Inheritance Hierarchy See Also
Collapse All

This class builds controls representing a multi link member on a surface. It is used by the DefaultAutoForm but can be used stand alone if there is need to quickly get a UI representations of an object's multilink.

C#
public sealed class MultilinkBuilder;
Inheritance Hierarchy
Eco.Windows.Forms.MultilinkBuilder
File

MultilinkBuilder.cs

See Also
Inheritance Hierarchy


MultilinkBuilder Classes

MultilinkBuilder Classes
Classes
Collapse All

The classes of the MultilinkBuilder class are listed here.

Classes
Name | Description
MultilinkTabPage | This is class Eco.Windows.Forms.MultilinkBuilder.MultilinkTabPage.


MultilinkBuilder.MultilinkTabPage Class

MultilinkBuilder.MultilinkTabPage Class
Inheritance Hierarchy See Also
Collapse All
C#
public class MultilinkTabPage : TabPage;
Remarks

This is class Eco.Windows.Forms.MultilinkBuilder.MultilinkTabPage.

Inheritance Hierarchy
System.Windows.Forms.TabPage
    Eco.Windows.Forms.MultilinkBuilder.MultilinkTabPage
File

MultilinkBuilder.cs

See Also
Inheritance Hierarchy


MultilinkTabPage Fields

MultilinkTabPage Fields
Public Fields
Collapse All

The fields of the MultilinkTabPage class are listed here.

Public Fields
Name | Description
eh | This is eh, a member of class MultilinkTabPage.


MultilinkBuilder.MultilinkTabPage.eh Field

MultilinkBuilder.MultilinkTabPage.eh Field
MultilinkBuilder.MultilinkTabPage Class Eco.Windows.Forms Namespace See Also
Collapse All
C#
public ExpressionHandle eh;
Remarks

This is eh, a member of class MultilinkTabPage.

See Also
MultilinkBuilder.MultilinkTabPage Class
Eco.Windows.Forms Namespace


MultilinkTabPage Methods

MultilinkTabPage Methods
Public Methods
Collapse All

The methods of the MultilinkTabPage class are listed here.

Public Methods
Name | Description
SelectedIndexChanged | This is SelectedIndexChanged, a member of class MultilinkTabPage.


MultilinkBuilder.MultilinkTabPage.SelectedIndexChanged Method

MultilinkBuilder.MultilinkTabPage.SelectedIndexChanged Method
MultilinkBuilder.MultilinkTabPage Class Eco.Windows.Forms Namespace See Also
Collapse All
C#
public void SelectedIndexChanged(
    object sender,
    EventArgs e
);
Remarks

This is SelectedIndexChanged, a member of class MultilinkTabPage.

See Also
MultilinkBuilder.MultilinkTabPage Class
Eco.Windows.Forms Namespace


MultilinkBuilder Methods

MultilinkBuilder Methods
Public Methods
Collapse All

The methods of the MultilinkBuilder class are listed here.

Public Methods
Name | Description
BuildControls | Builds controls for the (multilink member) modelElement on hostControl and binds them to the handle. The controls are a grid and buttons to add/remove/unlink objects. Text-property of the hostControl will be set to the name of the modelElement.


MultilinkBuilder.BuildControls Method

MultilinkBuilder.BuildControls Method
MultilinkBuilder Class Eco.Windows.Forms Namespace See Also
Collapse All

Builds controls for the (multilink member) modelElement on hostControl and binds them to the handle. The controls are a grid and buttons to add/remove/unlink objects. Text-property of the hostControl will be set to the name of the modelElement.

C#
public static void BuildControls(
    Control hostControl,
    ElementHandle handle,
    IModelElement modelElement,
    AutoContainerArgs autoContainerArgs
);
Parameters
Parameters | Description
hostControl | The control used as container for created controls.
handle | The handle is used for data binding.
modelElement | The IModelElement used to get the static information from.
autoContainerArgs | AutoContainerArgs used when bringing up new autoforms. If this parameter is null, the grid will not support bringing up new autoforms.
Exceptions
Exceptions | Description
ArgumentNullException | Thrown if hostControl is null. Thrown if handle is null. Thrown if modelElement is null.
See Also
MultilinkBuilder Class
Eco.Windows.Forms Namespace


MyNumericUpDown Class

MyNumericUpDown Class
Inheritance Hierarchy See Also
Collapse All
C#
public class MyNumericUpDown : NumericUpDown;
Remarks

This is class Eco.Windows.Forms.MyNumericUpDown.

Inheritance Hierarchy
System.Windows.Forms.NumericUpDown
    Eco.Windows.Forms.MyNumericUpDown
File

ControlBuilder.cs

See Also
Inheritance Hierarchy


MyNumericUpDown Methods

MyNumericUpDown Methods
Protected Methods
Collapse All

The methods of the MyNumericUpDown class are listed here.

Protected Methods
Name | Description
OnTextBoxKeyPress |
UpdateEditText | This is UpdateEditText, a member of class MyNumericUpDown.


MyNumericUpDown.OnTextBoxKeyPress Method

MyNumericUpDown.OnTextBoxKeyPress Method
MyNumericUpDown Class Eco.Windows.Forms Namespace See Also
Collapse All
C#
protected override void OnTextBoxKeyPress(
    object source,
    KeyPressEventArgs e
);
Exceptions
Exceptions | Description
ArgumentNullException | Thrown if e is null.
See Also
MyNumericUpDown Class
Eco.Windows.Forms Namespace


MyNumericUpDown.UpdateEditText Method

MyNumericUpDown.UpdateEditText Method
MyNumericUpDown Class Eco.Windows.Forms Namespace See Also
Collapse All
C#
protected override void UpdateEditText();
Remarks

This is UpdateEditText, a member of class MyNumericUpDown.

See Also
MyNumericUpDown Class
Eco.Windows.Forms Namespace


OclEditor Class

OclEditor Class
Inheritance Hierarchy See Also
Collapse All

Summary description for OclEditor.

C#
public class OclEditor : System.Windows.Forms.Form;
Inheritance Hierarchy
System.Windows.Forms.Form
    Eco.Windows.Forms.OclEditor
File

Eco.Windows.Forms.OclEditor.cs

See Also
Inheritance Hierarchy


OclEditor.OclEditor Constructor

OclEditor.OclEditor Constructor
OclEditor Class Eco.Windows.Forms Namespace See Also
Collapse All
C#
public OclEditor(
    bool binariesOutOfDate,
    string oldExpression,
    ITypeService typeService,
    IEcoTypeSystem typeSystem,
    IExternalVariableList variables,
    IClassifier context,
    IClassifier expectedType,
    IHelpService helpService
);
Remarks

This is OclEditor, a member of class OclEditor.

See Also
OclEditor Class
Eco.Windows.Forms Namespace


OclEditor Methods

OclEditor Methods
Protected Methods Public Methods
Collapse All

The methods of the OclEditor class are listed here.

Protected Methods
Name | Description
Dispose | Clean up any resources being used.
Top
Public Methods
Name | Description
DoCancel | This is DoCancel, a member of class OclEditor.
DoClear | This is DoClear, a member of class OclEditor.
DoRemoveLast | these methods are only used by the testcases
SetOcl | This is SetOcl, a member of class OclEditor.


OclEditor.Dispose Method

OclEditor.Dispose Method
OclEditor Class Eco.Windows.Forms Namespace See Also
Collapse All

Clean up any resources being used.

C#
protected override void Dispose(
    bool disposing
);
See Also
OclEditor Class
Eco.Windows.Forms Namespace


OclEditor.DoCancel Method

OclEditor.DoCancel Method
OclEditor Class Eco.Windows.Forms Namespace See Also
Collapse All
C#
public void DoCancel();
Remarks

This is DoCancel, a member of class OclEditor.

See Also
OclEditor Class
Eco.Windows.Forms Namespace


OclEditor.DoClear Method

OclEditor.DoClear Method
OclEditor Class Eco.Windows.Forms Namespace See Also
Collapse All
C#
public void DoClear();
Remarks

This is DoClear, a member of class OclEditor.

See Also
OclEditor Class
Eco.Windows.Forms Namespace


OclEditor.DoRemoveLast Method

OclEditor.DoRemoveLast Method
OclEditor Class Eco.Windows.Forms Namespace See Also
Collapse All
C#
public void DoRemoveLast();
Remarks

these methods are only used by the testcases

See Also
OclEditor Class
Eco.Windows.Forms Namespace


OclEditor.SetOcl Method

OclEditor.SetOcl Method
OclEditor Class Eco.Windows.Forms Namespace See Also
Collapse All
C#
public void SetOcl(
    string expression
);
Remarks

This is SetOcl, a member of class OclEditor.

See Also
OclEditor Class
Eco.Windows.Forms Namespace


OclEditor Properties

OclEditor Properties
Public Properties
Collapse All

The properties of the OclEditor class are listed here.

Public Properties
Name | Description
OclExpr | This is OclExpr, a member of class OclEditor.


OclEditor.OclExpr Property

OclEditor.OclExpr Property
OclEditor Class Eco.Windows.Forms Namespace See Also
Collapse All
C#
public string OclExpr;
Remarks

This is OclExpr, a member of class OclEditor.

See Also
OclEditor Class
Eco.Windows.Forms Namespace


StatePageBuilder Class

StatePageBuilder Class
Inheritance Hierarchy See Also
Collapse All

This class builds controls representing the state machines of a type on a surface. It is used by the DefaultAutoForm but can be used stand alone if there is need to quickly get a UI representations of an object's state machine and valid transitions.

C#
public sealed class StatePageBuilder;
Inheritance Hierarchy
Eco.Windows.Forms.StatePageBuilder
File

StatePageBuilder.cs

See Also
Inheritance Hierarchy


StatePageBuilder.BuildControls Method

StatePageBuilder.BuildControls Method
StatePageBuilder Class Eco.Windows.Forms Namespace See Also
Collapse All

Builds controls representing the state machine of the Element of the handle on hostControl.

C#
public static TriggerControlsRefresher BuildControls(
    Control hostControl,
    EcoSpace ecoSpace,
    ElementHandle handle,
    TriggerControlsRefresher triggerControlsRefresher
);
Parameters
Parameters | Description
hostControl | The control used as container for created controls.
ecoSpace | Used when bringing up new autoforms.
handle | The handle is used for data binding.
triggerControlsRefresher | An instance of TriggerControlsRefresher. If this instance is null, a new will be created and returned, otherwise, the one passed will be returned.
Exceptions
Exceptions | Description
ArgumentNullException | Thrown if hostControl is null. Thrown if handle is null. Thrown if ecoSpace is null.
See Also
StatePageBuilder Class
Eco.Windows.Forms Namespace


StatePageBuilder.BuildRegion Method

StatePageBuilder.BuildRegion Method
StatePageBuilder Class Eco.Windows.Forms Namespace See Also
Collapse All
C#
public static Size BuildRegion(
    Control hostControl,
    Point location,
    IRegion region,
    EcoSpace ecoSpace,
    ElementHandle handle
);
Exceptions
Exceptions | Description
ArgumentNullException | Thrown if hostControl is null. Thrown if handle is null.
See Also
StatePageBuilder Class
Eco.Windows.Forms Namespace


StatePageBuilder.BuildRegionContainer Method

StatePageBuilder.BuildRegionContainer Method
StatePageBuilder Class Eco.Windows.Forms Namespace See Also
Collapse All
C#
public static Size BuildRegionContainer(
    Control hostControl,
    Point location,
    IRegionContainer regionContainer,
    EcoSpace ecoSpace,
    ElementHandle handle
);
Exceptions
Exceptions | Description
ArgumentNullException | Thrown if hostControl is null. Thrown if handle is null. Thrown if regionContainer is null.
See Also
StatePageBuilder Class
Eco.Windows.Forms Namespace


SyncDebuggerPanel Class

SyncDebuggerPanel Class
Inheritance Hierarchy See Also
Collapse All
C#
public class SyncDebuggerPanel : Form, IEcoSpaceDebuggerPanel;
Remarks

This is class Eco.Windows.Forms.SyncDebuggerPanel.

Inheritance Hierarchy
Eco.Windows.Forms.IEcoSpaceDebuggerPanel
    Eco.Windows.Forms.SyncDebuggerPanel
File

Eco.Windows.Forms.SyncDebuggerPanel.Designer.cs

See Also
Inheritance Hierarchy


SyncDebuggerPanel.SyncDebuggerPanel Constructor

SyncDebuggerPanel.SyncDebuggerPanel Constructor
SyncDebuggerPanel Class Eco.Windows.Forms Namespace See Also
Collapse All
C#
public SyncDebuggerPanel();
Remarks

This is SyncDebuggerPanel, a member of class SyncDebuggerPanel.

See Also
SyncDebuggerPanel Class
Eco.Windows.Forms Namespace


SyncDebuggerPanel Methods

SyncDebuggerPanel Methods
Protected Methods Public Methods
Collapse All

The methods of the SyncDebuggerPanel class are listed here.

Protected Methods
Name | Description
Dispose | Clean up any resources being used.
Top
Public Methods
Name | Description
Init | This is Init, a member of class SyncDebuggerPanel.
Remove | This is Remove, a member of class SyncDebuggerPanel.


SyncDebuggerPanel.Dispose Method

SyncDebuggerPanel.Dispose Method
SyncDebuggerPanel Class Eco.Windows.Forms Namespace See Also
Collapse All

Clean up any resources being used.

C#
protected override void Dispose(
    bool disposing
);
Parameters
Parameters | Description
disposing | true if managed resources should be disposed; otherwise, false.
See Also
SyncDebuggerPanel Class
Eco.Windows.Forms Namespace


SyncDebuggerPanel.Init Method

SyncDebuggerPanel.Init Method
SyncDebuggerPanel Class Eco.Windows.Forms Namespace See Also
Collapse All
C#
public void Init(
    Eco.Handles.EcoSpace es
);
Remarks

This is Init, a member of class SyncDebuggerPanel.

See Also
SyncDebuggerPanel Class
Eco.Windows.Forms Namespace


SyncDebuggerPanel.Remove Method

SyncDebuggerPanel.Remove Method
SyncDebuggerPanel Class Eco.Windows.Forms Namespace See Also
Collapse All
C#
public void Remove();
Remarks

This is Remove, a member of class SyncDebuggerPanel.

See Also
SyncDebuggerPanel Class
Eco.Windows.Forms Namespace


SyncDebuggerPanel Properties

SyncDebuggerPanel Properties
Public Properties
Collapse All

The properties of the SyncDebuggerPanel class are listed here.

Public Properties
Name | Description
Caption | This is Caption, a member of class SyncDebuggerPanel.
EcoSpace | This is EcoSpace, a member of class SyncDebuggerPanel.
MainMenu | This is MainMenu, a member of class SyncDebuggerPanel.
Panel | This is Panel, a member of class SyncDebuggerPanel.


SyncDebuggerPanel.Caption Property

SyncDebuggerPanel.Caption Property
SyncDebuggerPanel Class Eco.Windows.Forms Namespace See Also
Collapse All
C#
public string Caption;
Remarks

This is Caption, a member of class SyncDebuggerPanel.

See Also
SyncDebuggerPanel Class
Eco.Windows.Forms Namespace


SyncDebuggerPanel.EcoSpace Property

SyncDebuggerPanel.EcoSpace Property
SyncDebuggerPanel Class Eco.Windows.Forms Namespace See Also
Collapse All
C#
public Eco.Handles.EcoSpace EcoSpace;
Remarks

This is EcoSpace, a member of class SyncDebuggerPanel.

See Also
SyncDebuggerPanel Class
Eco.Windows.Forms Namespace


SyncDebuggerPanel.MainMenu Property

SyncDebuggerPanel.MainMenu Property
SyncDebuggerPanel Class Eco.Windows.Forms Namespace See Also
Collapse All
C#
public MainMenu MainMenu;
Remarks

This is MainMenu, a member of class SyncDebuggerPanel.

See Also
SyncDebuggerPanel Class
Eco.Windows.Forms Namespace


SyncDebuggerPanel.Panel Property

SyncDebuggerPanel.Panel Property
SyncDebuggerPanel Class Eco.Windows.Forms Namespace See Also
Collapse All
C#
public Panel Panel;
Remarks

This is Panel, a member of class SyncDebuggerPanel.

See Also
SyncDebuggerPanel Class
Eco.Windows.Forms Namespace


TriggerControlsRefresher Class

TriggerControlsRefresher Class
Inheritance Hierarchy See Also
Collapse All
C#
public sealed class TriggerControlsRefresher;
Remarks

This is class Eco.Windows.Forms.TriggerControlsRefresher.

Inheritance Hierarchy
Eco.Windows.Forms.TriggerControlsRefresher
File

StatePageBuilder.cs

See Also
Inheritance Hierarchy


TriggerControlsRefresher.TriggerControlsRefresher Constructor

TriggerControlsRefresher.TriggerControlsRefresher Constructor
TriggerControlsRefresher Class Eco.Windows.Forms Namespace See Also
Collapse All
C#
public TriggerControlsRefresher(
    Control triggerHost,
    EcoSpace ecoSpace,
    ElementHandle handle
);
Remarks

This is TriggerControlsRefresher, a member of class TriggerControlsRefresher.

See Also
TriggerControlsRefresher Class
Eco.Windows.Forms Namespace


TriggerControlsRefresher Methods

TriggerControlsRefresher Methods
Public Methods
Collapse All

The methods of the TriggerControlsRefresher class are listed here.

Public Methods
Name | Description
Resubscribe | Subscribe to everything, and always resubscribe


TriggerControlsRefresher.Resubscribe Method

TriggerControlsRefresher.Resubscribe Method
TriggerControlsRefresher Class Eco.Windows.Forms Namespace See Also
Collapse All
C#
public void Resubscribe();
Remarks

Subscribe to everything, and always resubscribe

See Also
TriggerControlsRefresher Class
Eco.Windows.Forms Namespace


UndoDebuggerPanel Class

UndoDebuggerPanel Class
Inheritance Hierarchy See Also
Collapse All

This class form part of the EcoSpace debugger. It is not intended to be used directly.

C#
public class UndoDebuggerPanel : System.Windows.Forms.Form, IEcoSpaceDebuggerPanel;
Inheritance Hierarchy
Eco.Windows.Forms.IEcoSpaceDebuggerPanel
System.Windows.Forms.Form
    Eco.Windows.Forms.UndoDebuggerPanel
File

Eco.Windows.Forms.UndoDebuggerPanel.cs

See Also
Inheritance Hierarchy


UndoDebuggerPanel.UndoDebuggerPanel Constructor

UndoDebuggerPanel.UndoDebuggerPanel Constructor
UndoDebuggerPanel Class Eco.Windows.Forms Namespace See Also
Collapse All
C#
public UndoDebuggerPanel();
Remarks

This is UndoDebuggerPanel, a member of class UndoDebuggerPanel.

See Also
UndoDebuggerPanel Class
Eco.Windows.Forms Namespace


UndoDebuggerPanel Methods

UndoDebuggerPanel Methods
Protected Methods
Collapse All

The methods of the UndoDebuggerPanel class are listed here.

Protected Methods
Name | Description
Dispose | Clean up any resources being used.


UndoDebuggerPanel.Dispose Method

UndoDebuggerPanel.Dispose Method
UndoDebuggerPanel Class Eco.Windows.Forms Namespace See Also
Collapse All

Clean up any resources being used.

C#
protected override void Dispose(
    bool disposing
);
See Also
UndoDebuggerPanel Class
Eco.Windows.Forms Namespace


UndoDebuggerPanel Properties

UndoDebuggerPanel Properties
Public Properties
Collapse All

The properties of the UndoDebuggerPanel class are listed here.

Public Properties
Name | Description
DirtyListService | This is DirtyListService, a member of class UndoDebuggerPanel.
EcoSpace | This is EcoSpace, a member of class UndoDebuggerPanel.
ExtentService | This is ExtentService, a member of class UndoDebuggerPanel.
ObjectFactoryService | This is ObjectFactoryService, a member of class UndoDebuggerPanel.
OclService | This is OclService, a member of class UndoDebuggerPanel.
PersistenceService | This is PersistenceService, a member of class UndoDebuggerPanel.
TypeSystemService | This is TypeSystemService, a member of class UndoDebuggerPanel.
UndoService | This is UndoService, a member of class UndoDebuggerPanel.
VariableFactoryService | This is VariableFactoryService, a member of class UndoDebuggerPanel.


UndoDebuggerPanel.DirtyListService Property

UndoDebuggerPanel.DirtyListService Property
UndoDebuggerPanel Class Eco.Windows.Forms Namespace See Also
Collapse All
C#
public IDirtyListService DirtyListService;
Remarks

This is DirtyListService, a member of class UndoDebuggerPanel.

See Also
UndoDebuggerPanel Class
Eco.Windows.Forms Namespace


UndoDebuggerPanel.EcoSpace Property

UndoDebuggerPanel.EcoSpace Property
UndoDebuggerPanel Class Eco.Windows.Forms Namespace See Also
Collapse All
C#
public Eco.Handles.EcoSpace EcoSpace;
Remarks

This is EcoSpace, a member of class UndoDebuggerPanel.

See Also
UndoDebuggerPanel Class
Eco.Windows.Forms Namespace


UndoDebuggerPanel.ExtentService Property

UndoDebuggerPanel.ExtentService Property
UndoDebuggerPanel Class Eco.Windows.Forms Namespace See Also
Collapse All
C#
public IExtentService ExtentService;
Remarks

This is ExtentService, a member of class UndoDebuggerPanel.

See Also
UndoDebuggerPanel Class
Eco.Windows.Forms Namespace


UndoDebuggerPanel.ObjectFactoryService Property

UndoDebuggerPanel.ObjectFactoryService Property
UndoDebuggerPanel Class Eco.Windows.Forms Namespace See Also
Collapse All
C#
public IObjectFactoryService ObjectFactoryService;
Remarks

This is ObjectFactoryService, a member of class UndoDebuggerPanel.

See Also
UndoDebuggerPanel Class
Eco.Windows.Forms Namespace


UndoDebuggerPanel.OclService Property

UndoDebuggerPanel.OclService Property
UndoDebuggerPanel Class Eco.Windows.Forms Namespace See Also
Collapse All
C#
public IOclService OclService;
Remarks

This is OclService, a member of class UndoDebuggerPanel.

See Also
UndoDebuggerPanel Class
Eco.Windows.Forms Namespace


UndoDebuggerPanel.PersistenceService Property

UndoDebuggerPanel.PersistenceService Property
UndoDebuggerPanel Class Eco.Windows.Forms Namespace See Also
Collapse All
C#
public IPersistenceService PersistenceService;
Remarks

This is PersistenceService, a member of class UndoDebuggerPanel.

See Also
UndoDebuggerPanel Class
Eco.Windows.Forms Namespace


UndoDebuggerPanel.TypeSystemService Property

UndoDebuggerPanel.TypeSystemService Property
UndoDebuggerPanel Class Eco.Windows.Forms Namespace See Also
Collapse All
C#
public ITypeSystemService TypeSystemService;
Remarks

This is TypeSystemService, a member of class UndoDebuggerPanel.

See Also
UndoDebuggerPanel Class
Eco.Windows.Forms Namespace


UndoDebuggerPanel.UndoService Property

UndoDebuggerPanel.UndoService Property
UndoDebuggerPanel Class Eco.Windows.Forms Namespace See Also
Collapse All
C#
public IUndoService UndoService;
Remarks

This is UndoService, a member of class UndoDebuggerPanel.

See Also
UndoDebuggerPanel Class
Eco.Windows.Forms Namespace


UndoDebuggerPanel.VariableFactoryService Property

UndoDebuggerPanel.VariableFactoryService Property
UndoDebuggerPanel Class Eco.Windows.Forms Namespace See Also
Collapse All
C#
public IVariableFactoryService VariableFactoryService;
Remarks

This is VariableFactoryService, a member of class UndoDebuggerPanel.

See Also
UndoDebuggerPanel Class
Eco.Windows.Forms Namespace


WinFormDequeuer Class

WinFormDequeuer Class
Inheritance Hierarchy See Also
Collapse All

The WinFormDequeuer makes sure the presentation layer (UI layer) is updated with the information in the objects. This is done by hooking into the OnIdle loop where the static method ElementHandle.EnsureAllBindingLists is called. This class cannot be instantiated. Its only property, Active is static.

C#
public abstract class WinFormDequeuer;
Inheritance Hierarchy
Eco.Windows.Forms.WinFormDequeuer
File

Dequeuer.cs

See Also
Inheritance Hierarchy


WinFormDequeuer Properties

WinFormDequeuer Properties
Public Properties
Collapse All

The properties of the WinFormDequeuer class are listed here.

Public Properties
Name | Description
Active | Toggles if the presentation is updating or not. Setting the value of the property to the value it currently holds does nothing.


WinFormDequeuer.Active Property

WinFormDequeuer.Active Property
WinFormDequeuer Class Eco.Windows.Forms Namespace See Also
Collapse All

Toggles if the presentation is updating or not. Setting the value of the property to the value it currently holds does nothing.

C#
public static bool Active;
See Also
WinFormDequeuer Class
Eco.Windows.Forms Namespace


IEcoSpaceDebuggerPanel Interface

IEcoSpaceDebuggerPanel Interface
Inheritance Hierarchy See Also
Collapse All
C#
public interface IEcoSpaceDebuggerPanel;
Remarks

This is class Eco.Windows.Forms.IEcoSpaceDebuggerPanel.

Inheritance Hierarchy
Eco.Windows.Forms.IEcoSpaceDebuggerPanel
    Eco.Windows.Forms.ClassAndOclDebuggerPanel
    Eco.Windows.Forms.DirtyObjectsDebuggerPanel
    Eco.Windows.Forms.LoggerDebuggerPanel
    Eco.Windows.Forms.SyncDebuggerPanel
    Eco.Windows.Forms.UndoDebuggerPanel
File

Eco.Windows.Forms.EcoSpaceDebugger.cs

See Also
Inheritance Hierarchy


IEcoSpaceDebuggerPanel Methods

IEcoSpaceDebuggerPanel Methods
Public Methods
Collapse All

The methods of the IEcoSpaceDebuggerPanel class are listed here.

Public Methods
Name | Description
Init | This is Init, a member of class IEcoSpaceDebuggerPanel.
Remove | This is Remove, a member of class IEcoSpaceDebuggerPanel.


IEcoSpaceDebuggerPanel.Init Method

IEcoSpaceDebuggerPanel.Init Method
IEcoSpaceDebuggerPanel Interface Eco.Windows.Forms Namespace See Also
Collapse All
C#
void Init(
    EcoSpace es
);
Remarks

This is Init, a member of class IEcoSpaceDebuggerPanel.

See Also
IEcoSpaceDebuggerPanel Interface
Eco.Windows.Forms Namespace


IEcoSpaceDebuggerPanel.Remove Method

IEcoSpaceDebuggerPanel.Remove Method
IEcoSpaceDebuggerPanel Interface Eco.Windows.Forms Namespace See Also
Collapse All
C#
void Remove();
Remarks

This is Remove, a member of class IEcoSpaceDebuggerPanel.

See Also
IEcoSpaceDebuggerPanel Interface
Eco.Windows.Forms Namespace


IEcoSpaceDebuggerPanel Properties

IEcoSpaceDebuggerPanel Properties
Public Properties
Collapse All

The properties of the IEcoSpaceDebuggerPanel class are listed here.

Public Properties
Name | Description
Caption | This is Caption, a member of class IEcoSpaceDebuggerPanel.
MainMenu | This is MainMenu, a member of class IEcoSpaceDebuggerPanel.
Panel | This is Panel, a member of class IEcoSpaceDebuggerPanel.


IEcoSpaceDebuggerPanel.Caption Property

IEcoSpaceDebuggerPanel.Caption Property
IEcoSpaceDebuggerPanel Interface Eco.Windows.Forms Namespace See Also
Collapse All
C#
string Caption;
Remarks

This is Caption, a member of class IEcoSpaceDebuggerPanel.

See Also
IEcoSpaceDebuggerPanel Interface
Eco.Windows.Forms Namespace


IEcoSpaceDebuggerPanel.MainMenu Property

IEcoSpaceDebuggerPanel.MainMenu Property
IEcoSpaceDebuggerPanel Interface Eco.Windows.Forms Namespace See Also
Collapse All
C#
MainMenu MainMenu;
Remarks

This is MainMenu, a member of class IEcoSpaceDebuggerPanel.

See Also
IEcoSpaceDebuggerPanel Interface
Eco.Windows.Forms Namespace


IEcoSpaceDebuggerPanel.Panel Property

IEcoSpaceDebuggerPanel.Panel Property
IEcoSpaceDebuggerPanel Interface Eco.Windows.Forms Namespace See Also
Collapse All
C#
Panel Panel;
Remarks

This is Panel, a member of class IEcoSpaceDebuggerPanel.

See Also
IEcoSpaceDebuggerPanel Interface
Eco.Windows.Forms Namespace


Eco.WinForm Namespace

Eco.WinForm Namespace
Classes Enumerations
Collapse All

This is namespace Eco.WinForm.

Classes
Name | Description
DataGridMaxLengthSupportProvider | This is class Eco.WinForm.DataGridMaxLengthSupportProvider.
DraggedElement | This is class Eco.WinForm.DraggedElement.
EcoActionExtender | EcoActionExtender extends buttons with a new property EcoAction. This allows code free execution of a number of common (and some not so common) things to do in an ecospace, such as undo/redo, update database etc
EcoAutoFormExtender | This class extends grids and listboxes with new properties; EcoAutoForm and EcoAutoFormReadOnly. The purpose is to allow double-click on the extended components to bring up an ECO autocontainer without having to go through the hassle of writing code.
EcoDataGridTextBoxColumn | This is class Eco.WinForm.EcoDataGridTextBoxColumn.
EcoDragDropExtender | This is class Eco.WinForm.EcoDragDropExtender.
EcoListActionExtender | This class extends buttons with new properties; EcoListAction, RootHandle, BindingContext, ActionOCL, EnabledOCL and VisibleOCL. The purpose of these are to provide a code free interface to manipulate lists.
EcoWinFormHelper | A collection of useful helper functions pertaining to Windows.Forms.
TextBoxMaxLengthSupportProvider | This is class Eco.WinForm.TextBoxMaxLengthSupportProvider.
Top
Enumerations
Name | Description
EcoAction | Valid EcoActions for the EcoActionExtender.
ListAction | ListAction enumeration lists implemented actions that the EcoListActionExtender offers. If an ImageList is hooked up to the extender component, the ordinal position of the action in the enumeration will be used as ImageIndex on the extendee.


DataGridMaxLengthSupportProvider Class

DataGridMaxLengthSupportProvider Class
Inheritance Hierarchy See Also
Collapse All
C#
public class DataGridMaxLengthSupportProvider : IMaxLengthSupportProvider;
Remarks

This is class Eco.WinForm.DataGridMaxLengthSupportProvider.

Inheritance Hierarchy
Eco.WinForm.DataGridMaxLengthSupportProvider
File

MaxLengthSupportProviders.cs

See Also
Inheritance Hierarchy


DataGridMaxLengthSupportProvider.DataGridMaxLengthSupportProvider Constructor

DataGridMaxLengthSupportProvider.DataGridMaxLengthSupportProvider Constructor
DataGridMaxLengthSupportProvider Class Eco.WinForm Namespace See Also
Collapse All
C#
public DataGridMaxLengthSupportProvider();
Remarks

This is DataGridMaxLengthSupportProvider, a member of class DataGridMaxLengthSupportProvider.

See Also
DataGridMaxLengthSupportProvider Class
Eco.WinForm Namespace


DataGridMaxLengthSupportProvider Methods

DataGridMaxLengthSupportProvider Methods
Public Methods
Collapse All

The methods of the DataGridMaxLengthSupportProvider class are listed here.

Public Methods
Name | Description
SetMaxLength | This is the overview for the SetMaxLength method overload.


SetMaxLength Method

SetMaxLength Method

This is the overview for the SetMaxLength method overload.

Overload List
Name | Description
DataGridMaxLengthSupportProvider.SetMaxLength (DataGridColumnStyle, ElementHandle) | This is SetMaxLength, a member of class DataGridMaxLengthSupportProvider.
DataGridMaxLengthSupportProvider.SetMaxLength (object) | This is SetMaxLength, a member of class DataGridMaxLengthSupportProvider.


DataGridMaxLengthSupportProvider.SetMaxLength Method (DataGridColumnStyle, ElementHandle)

DataGridMaxLengthSupportProvider.SetMaxLength Method (DataGridColumnStyle, ElementHandle)
DataGridMaxLengthSupportProvider Class Eco.WinForm Namespace See Also
Collapse All
C#
public void SetMaxLength(
    DataGridColumnStyle columnStyle,
    ElementHandle handle
);
Remarks

This is SetMaxLength, a member of class DataGridMaxLengthSupportProvider.

See Also
DataGridMaxLengthSupportProvider Class
Eco.WinForm Namespace


DataGridMaxLengthSupportProvider.SetMaxLength Method (object)

DataGridMaxLengthSupportProvider.SetMaxLength Method (object)
DataGridMaxLengthSupportProvider Class Eco.WinForm Namespace See Also
Collapse All
C#
public void SetMaxLength(
    object obj
);
Remarks

This is SetMaxLength, a member of class DataGridMaxLengthSupportProvider.

See Also
DataGridMaxLengthSupportProvider Class
Eco.WinForm Namespace


DraggedElement Class

DraggedElement Class
Inheritance Hierarchy See Also
Collapse All
C#
public sealed class DraggedElement;
Remarks

This is class Eco.WinForm.DraggedElement.

Inheritance Hierarchy
Eco.WinForm.DraggedElement
File

WinFormHelpers.cs

See Also
Inheritance Hierarchy


DraggedElement.DraggedElement Constructor

DraggedElement.DraggedElement Constructor
DraggedElement Class Eco.WinForm Namespace See Also
Collapse All
C#
public DraggedElement(
    IElement element
);
Remarks

This is DraggedElement, a member of class DraggedElement.

See Also
DraggedElement Class
Eco.WinForm Namespace


DraggedElement Properties

DraggedElement Properties
Public Properties
Collapse All

The properties of the DraggedElement class are listed here.

Public Properties
Name | Description
Element | This is Element, a member of class DraggedElement.


DraggedElement.Element Property

DraggedElement.Element Property
DraggedElement Class Eco.WinForm Namespace See Also
Collapse All
C#
public IElement Element;
Remarks

This is Element, a member of class DraggedElement.

See Also
DraggedElement Class
Eco.WinForm Namespace


EcoActionExtender Class

EcoActionExtender Class
Inheritance Hierarchy See Also
Collapse All

EcoActionExtender extends buttons with a new property EcoAction.

This allows code free execution of a number of common (and some not so common) things to do in an ecospace, such as undo/redo, update database etc

C#
public class EcoActionExtender : System.ComponentModel.Component, System.ComponentModel.IExtenderProvider;
Inheritance Hierarchy
Eco.WinForm.EcoActionExtender
File

ActionExtender.cs

See Also
Inheritance Hierarchy


EcoActionExtender Methods

EcoActionExtender Methods
Protected Methods Public Methods
Collapse All

The methods of the EcoActionExtender class are listed here.

Protected Methods
Name | Description
Hookup | This virtual method hooks up the extended control's event. The default case is to hook the protected method OnClick to Click, but you may want some other event hooked, or hook to something else.
OnClick | This is OnClick, a member of class EcoActionExtender.
Unhook | This virtual method unhooks up the extended controls event. The default case is to unhook the protected method OnClick to Click, but if you have hooked some other event you probably want to override this too, for the sake of symmetry.
Top
Public Methods
Name | Description
CanExtend | This method determines which controls are to be considered extensible, i.e. receive new properties. You may override this method in a subclass if you need additional (or other) rules to determine which controls to extend.
ComponentDisposed | This is ComponentDisposed, a member of class EcoActionExtender.
ExecuteAction | Performs the activity specified by the action.
GetEcoAction | Getter for the extended property EcoAction.
SetEcoAction | Setter for the extended property EcoAction.


EcoActionExtender.CanExtend Method

EcoActionExtender.CanExtend Method
EcoActionExtender Class Eco.WinForm Namespace See Also
Collapse All

This method determines which controls are to be considered extensible, i.e. receive new properties. You may override this method in a subclass if you need additional (or other) rules to determine which controls to extend.

C#
public virtual bool CanExtend(
    object extendee
);
See Also
EcoActionExtender Class
Eco.WinForm Namespace


EcoActionExtender.ComponentDisposed Method

EcoActionExtender.ComponentDisposed Method
EcoActionExtender Class Eco.WinForm Namespace See Also
Collapse All
C#
public void ComponentDisposed(
    object sender,
    EventArgs e
);
Remarks

This is ComponentDisposed, a member of class EcoActionExtender.

See Also
EcoActionExtender Class
Eco.WinForm Namespace


EcoActionExtender.ExecuteAction Method

EcoActionExtender.ExecuteAction Method
EcoActionExtender Class Eco.WinForm Namespace See Also
Collapse All

Performs the activity specified by the action.

C#
public void ExecuteAction(
    EcoAction action,
    Component component
);
Parameters
Parameters | Description
action | The action to perform.
component | An extended control, required to find a root handle.
See Also
EcoActionExtender Class
Eco.WinForm Namespace


EcoActionExtender.GetEcoAction Method

EcoActionExtender.GetEcoAction Method
EcoActionExtender Class Eco.WinForm Namespace See Also
Collapse All

Getter for the extended property EcoAction.

C#
public EcoAction GetEcoAction(
    Component component
);
See Also
EcoActionExtender Class
Eco.WinForm Namespace


EcoActionExtender.Hookup Method

EcoActionExtender.Hookup Method
EcoActionExtender Class Eco.WinForm Namespace See Also
Collapse All

This virtual method hooks up the extended control's event. The default case is to hook the protected method OnClick to Click, but you may want some other event hooked, or hook to something else.

C#
protected virtual void Hookup(
    Component component
);
Exceptions
Exceptions | Description
ArgumentNullException | Thrown if component is null.
See Also
EcoActionExtender Class
Eco.WinForm Namespace


EcoActionExtender.OnClick Method

EcoActionExtender.OnClick Method
EcoActionExtender Class Eco.WinForm Namespace See Also
Collapse All
C#
protected void OnClick(
    object sender,
    EventArgs e
);
Remarks

This is OnClick, a member of class EcoActionExtender.

See Also
EcoActionExtender Class
Eco.WinForm Namespace


EcoActionExtender.SetEcoAction Method

EcoActionExtender.SetEcoAction Method
EcoActionExtender Class Eco.WinForm Namespace See Also
Collapse All

Setter for the extended property EcoAction.

C#
public void SetEcoAction(
    Component component,
    EcoAction value
);
Exceptions
Exceptions | Description
ArgumentNullException | Thrown if component is null.
See Also
EcoActionExtender Class
Eco.WinForm Namespace


EcoActionExtender.Unhook Method

EcoActionExtender.Unhook Method
EcoActionExtender Class Eco.WinForm Namespace See Also
Collapse All

This virtual method unhooks up the extended controls event. The default case is to unhook the protected method OnClick to Click, but if you have hooked some other event you probably want to override this too, for the sake of symmetry.

C#
protected virtual void Unhook(
    Component component
);
Exceptions
Exceptions | Description
ArgumentNullException | Thrown if component is null.
See Also
EcoActionExtender Class
Eco.WinForm Namespace


EcoActionExtender Properties

EcoActionExtender Properties
Public Properties
Collapse All

The properties of the EcoActionExtender class are listed here.

Public Properties
Name | Description
CaptionCreateSchema | The caption that will be set on all buttons connected to the extender, and set their EcoAction to CreateSchema.
CaptionDiscardChanges | The caption that will be set on all buttons connected to the extender, and set their EcoAction to UpdateDatabase.
CaptionEvolveSchema | The caption that will be set on all buttons connected to the extender, and set their EcoAction to EvolveSchema.
CaptionRedo | The caption that will be set on all buttons connected to the extender, and set their EcoAction to Redo.
CaptionSetCheckPoint | The caption that will be set on all buttons connected to the extender, and set their EcoAction to SetCheckPoint.
CaptionShowDebugger | The caption that will be set on all buttons connected to the extender, and set their EcoAction to EvolveSchema.
CaptionToggleActive | The caption that will be set on all buttons connected to the extender, and set their EcoAction to ToggleActive when the system is inactive.
CaptionToggleDeactivate | The caption that will be set on all buttons connected to the extender, and set their EcoAction to ToggleActive when the system is active.
CaptionUndo | The caption that will be set on all buttons connected to the extender, and set their EcoAction to Undo.
CaptionUpdateDatabase | The caption that will be set on all buttons connected to the extender, and set their EcoAction to UpdateDatabase.


EcoActionExtender.CaptionCreateSchema Property

EcoActionExtender.CaptionCreateSchema Property
EcoActionExtender Class Eco.WinForm Namespace See Also
Collapse All

The caption that will be set on all buttons connected to the extender, and set their EcoAction to CreateSchema.

C#
public string CaptionCreateSchema;
See Also
EcoActionExtender Class
Eco.WinForm Namespace


EcoActionExtender.CaptionDiscardChanges Property

EcoActionExtender.CaptionDiscardChanges Property
EcoActionExtender Class Eco.WinForm Namespace See Also
Collapse All

The caption that will be set on all buttons connected to the extender, and set their EcoAction to UpdateDatabase.

C#
public string CaptionDiscardChanges;
See Also
EcoActionExtender Class
Eco.WinForm Namespace


EcoActionExtender.CaptionEvolveSchema Property

EcoActionExtender.CaptionEvolveSchema Property
EcoActionExtender Class Eco.WinForm Namespace See Also
Collapse All

The caption that will be set on all buttons connected to the extender, and set their EcoAction to EvolveSchema.

C#
public string CaptionEvolveSchema;
See Also
EcoActionExtender Class
Eco.WinForm Namespace


EcoActionExtender.CaptionRedo Property

EcoActionExtender.CaptionRedo Property
EcoActionExtender Class Eco.WinForm Namespace See Also
Collapse All

The caption that will be set on all buttons connected to the extender, and set their EcoAction to Redo.

C#
public string CaptionRedo;
See Also
EcoActionExtender Class
Eco.WinForm Namespace


EcoActionExtender.CaptionSetCheckPoint Property

EcoActionExtender.CaptionSetCheckPoint Property
EcoActionExtender Class Eco.WinForm Namespace See Also
Collapse All

The caption that will be set on all buttons connected to the extender, and set their EcoAction to SetCheckPoint.

C#
public string CaptionSetCheckPoint;
See Also
EcoActionExtender Class
Eco.WinForm Namespace


EcoActionExtender.CaptionShowDebugger Property

EcoActionExtender.CaptionShowDebugger Property
EcoActionExtender Class Eco.WinForm Namespace See Also
Collapse All

The caption that will be set on all buttons connected to the extender, and set their EcoAction to EvolveSchema.

C#
public string CaptionShowDebugger;
See Also
EcoActionExtender Class
Eco.WinForm Namespace


EcoActionExtender.CaptionToggleActive Property

EcoActionExtender.CaptionToggleActive Property
EcoActionExtender Class Eco.WinForm Namespace See Also
Collapse All

The caption that will be set on all buttons connected to the extender, and set their EcoAction to ToggleActive when the system is inactive.

C#
public string CaptionToggleActive;
See Also
EcoActionExtender Class
Eco.WinForm Namespace


EcoActionExtender.CaptionToggleDeactivate Property

EcoActionExtender.CaptionToggleDeactivate Property
EcoActionExtender Class Eco.WinForm Namespace See Also
Collapse All

The caption that will be set on all buttons connected to the extender, and set their EcoAction to ToggleActive when the system is active.

C#
public string CaptionToggleDeactivate;
See Also
EcoActionExtender Class
Eco.WinForm Namespace


EcoActionExtender.CaptionUndo Property

EcoActionExtender.CaptionUndo Property
EcoActionExtender Class Eco.WinForm Namespace See Also
Collapse All

The caption that will be set on all buttons connected to the extender, and set their EcoAction to Undo.

C#
public string CaptionUndo;
See Also
EcoActionExtender Class
Eco.WinForm Namespace


EcoActionExtender.CaptionUpdateDatabase Property

EcoActionExtender.CaptionUpdateDatabase Property
EcoActionExtender Class Eco.WinForm Namespace See Also
Collapse All

The caption that will be set on all buttons connected to the extender, and set their EcoAction to UpdateDatabase.

C#
public string CaptionUpdateDatabase;
See Also
EcoActionExtender Class
Eco.WinForm Namespace


EcoAutoFormExtender Class

EcoAutoFormExtender Class
Inheritance Hierarchy See Also
Collapse All

This class extends grids and listboxes with new properties; EcoAutoForm and EcoAutoFormReadOnly. The purpose is to allow double-click on the extended components to bring up an ECO autocontainer without having to go through the hassle of writing code.

C#
public class EcoAutoFormExtender : System.ComponentModel.Component, System.ComponentModel.IExtenderProvider;
Inheritance Hierarchy
Eco.WinForm.EcoAutoFormExtender
File

AutoFormExtender.cs

See Also
Inheritance Hierarchy


EcoAutoFormExtender.EcoAutoFormExtender Constructor

EcoAutoFormExtender.EcoAutoFormExtender Constructor
EcoAutoFormExtender Class Eco.WinForm Namespace See Also
Collapse All
C#
public EcoAutoFormExtender();
Remarks

This is EcoAutoFormExtender, a member of class EcoAutoFormExtender.

See Also
EcoAutoFormExtender Class
Eco.WinForm Namespace


EcoAutoFormExtender Methods

EcoAutoFormExtender Methods
Protected Methods Public Methods
Collapse All

The methods of the EcoAutoFormExtender class are listed here.

Protected Methods
Name | Description
EffectiveEcoSpace | This is EffectiveEcoSpace, a member of class EcoAutoFormExtender.
Hookup | This virtual method hooks up the extended control's event. You may want some other event hooked, or hook to something else.
OnDoubleClick | This is OnDoubleClick, a member of class EcoAutoFormExtender.
OnMouseDown |
ShowAutoContainer | This is ShowAutoContainer, a member of class EcoAutoFormExtender.
Unhook | This virtual method unhooks up the extended controls event.
Top
Public Methods
Name | Description
CanExtend | This method determines which controls are to be considered extensible, i.e. receive new properties. You may override this method in a subclass if you need additional (or other) rules to determine which controls to extend.
GetEcoAutoForm | Determines if the extendee should bring up an autoform on doubleclick.
GetEcoAutoFormReadOnly | Determines if the autoform should be read only.
SetEcoAutoForm | Setter for EcoAutoForm.
SetEcoAutoFormReadOnly | Setter for EcoAutoFormReadOnly. Determines if the autoform should be read only.


EcoAutoFormExtender.CanExtend Method

EcoAutoFormExtender.CanExtend Method
EcoAutoFormExtender Class Eco.WinForm Namespace See Also
Collapse All

This method determines which controls are to be considered extensible, i.e. receive new properties. You may override this method in a subclass if you need additional (or other) rules to determine which controls to extend.

C#
public virtual bool CanExtend(
    object extendee
);
See Also
EcoAutoFormExtender Class
Eco.WinForm Namespace


EcoAutoFormExtender.EffectiveEcoSpace Method

EcoAutoFormExtender.EffectiveEcoSpace Method
EcoAutoFormExtender Class Eco.WinForm Namespace See Also
Collapse All
C#
protected EcoSpace EffectiveEcoSpace(
    object o
);
Remarks

This is EffectiveEcoSpace, a member of class EcoAutoFormExtender.

See Also
EcoAutoFormExtender Class
Eco.WinForm Namespace


EcoAutoFormExtender.GetEcoAutoForm Method

EcoAutoFormExtender.GetEcoAutoForm Method
EcoAutoFormExtender Class Eco.WinForm Namespace See Also
Collapse All

Determines if the extendee should bring up an autoform on doubleclick.

C#
public bool GetEcoAutoForm(
    Control control
);
Parameters
Parameters | Description
control | Control to query.
See Also
EcoAutoFormExtender Class
Eco.WinForm Namespace


EcoAutoFormExtender.GetEcoAutoFormReadOnly Method

EcoAutoFormExtender.GetEcoAutoFormReadOnly Method
EcoAutoFormExtender Class Eco.WinForm Namespace See Also
Collapse All

Determines if the autoform should be read only.

C#
public bool GetEcoAutoFormReadOnly(
    Control control
);
Parameters
Parameters | Description
control | Control to query.
See Also
EcoAutoFormExtender Class
Eco.WinForm Namespace


EcoAutoFormExtender.Hookup Method

EcoAutoFormExtender.Hookup Method
EcoAutoFormExtender Class Eco.WinForm Namespace See Also
Collapse All

This virtual method hooks up the extended control's event. You may want some other event hooked, or hook to something else.

C#
protected virtual void Hookup(
    Control control
);
Exceptions
Exceptions | Description
ArgumentNullException | Thrown if control is null.
See Also
EcoAutoFormExtender Class
Eco.WinForm Namespace


EcoAutoFormExtender.OnDoubleClick Method

EcoAutoFormExtender.OnDoubleClick Method
EcoAutoFormExtender Class Eco.WinForm Namespace See Also
Collapse All
C#
protected void OnDoubleClick(
    object sender,
    EventArgs e
);
Remarks

This is OnDoubleClick, a member of class EcoAutoFormExtender.

See Also
EcoAutoFormExtender Class
Eco.WinForm Namespace


EcoAutoFormExtender.OnMouseDown Method

EcoAutoFormExtender.OnMouseDown Method
EcoAutoFormExtender Class Eco.WinForm Namespace See Also
Collapse All
C#
protected void OnMouseDown(
    object sender,
    MouseEventArgs e
);
Exceptions
Exceptions | Description
ArgumentNullException | Thrown if e is null.
See Also
EcoAutoFormExtender Class
Eco.WinForm Namespace


EcoAutoFormExtender.SetEcoAutoForm Method

EcoAutoFormExtender.SetEcoAutoForm Method
EcoAutoFormExtender Class Eco.WinForm Namespace See Also
Collapse All

Setter for EcoAutoForm.

C#
public void SetEcoAutoForm(
    Control control,
    bool value
);
Parameters
Parameters | Description
control | Control to extend.
value | Determines if the control should bring up an autoform on doubleclick.
Exceptions
Exceptions | Description
ArgumentNullException | Thrown if control is null.
See Also
EcoAutoFormExtender Class
Eco.WinForm Namespace


EcoAutoFormExtender.SetEcoAutoFormReadOnly Method

EcoAutoFormExtender.SetEcoAutoFormReadOnly Method
EcoAutoFormExtender Class Eco.WinForm Namespace See Also
Collapse All

Setter for EcoAutoFormReadOnly. Determines if the autoform should be read only.

C#
public void SetEcoAutoFormReadOnly(
    Control control,
    bool value
);
Parameters
Parameters | Description
control | Control to extend.
value | Determines if the autoform is readonly.
Exceptions
Exceptions | Description
ArgumentNullException | Thrown if control is null.
See Also
EcoAutoFormExtender Class
Eco.WinForm Namespace


EcoAutoFormExtender.ShowAutoContainer Method

EcoAutoFormExtender.ShowAutoContainer Method
EcoAutoFormExtender Class Eco.WinForm Namespace See Also
Collapse All
C#
protected void ShowAutoContainer(
    EcoSpace ecoSpace,
    IElement element,
    bool forceReadonly
);
Remarks

This is ShowAutoContainer, a member of class EcoAutoFormExtender.

See Also
EcoAutoFormExtender Class
Eco.WinForm Namespace


EcoAutoFormExtender.Unhook Method

EcoAutoFormExtender.Unhook Method
EcoAutoFormExtender Class Eco.WinForm Namespace See Also
Collapse All

This virtual method unhooks up the extended controls event.

C#
protected virtual void Unhook(
    Control control
);
Exceptions
Exceptions | Description
ArgumentNullException | Thrown if control is null.
See Also
EcoAutoFormExtender Class
Eco.WinForm Namespace


EcoAutoFormExtender Properties

EcoAutoFormExtender Properties
Public Properties
Collapse All

The properties of the EcoAutoFormExtender class are listed here.

Public Properties
Name | Description
ContainerReusage | Determines how the autocontainers will be reused on a second request. Default is ContainerReusage.NeverReuse.
EcoSpace | Used as a fall back alternative to locate an EcoSpace. First the datasource of the extendee is followed to the root.
Enabled | Determines if the extdner is active or not. Default is true.
MemberVisibility | Determines what visibility of members will be shown on the autoform. Default is AutoContainerMemberVisibility.AllMembers.
ShowModal | If true, the autocontainer will show modally if the container supports it (i.e. is a form)


EcoAutoFormExtender.ContainerReusage Property

EcoAutoFormExtender.ContainerReusage Property
EcoAutoFormExtender Class Eco.WinForm Namespace See Also
Collapse All

Determines how the autocontainers will be reused on a second request. Default is ContainerReusage.NeverReuse.

C#
public ContainerReusage ContainerReusage;
See Also
EcoAutoFormExtender Class
Eco.WinForm Namespace


EcoAutoFormExtender.EcoSpace Property

EcoAutoFormExtender.EcoSpace Property
EcoAutoFormExtender Class Eco.WinForm Namespace See Also
Collapse All

Used as a fall back alternative to locate an EcoSpace. First the datasource of the extendee is followed to the root.

C#
public EcoSpace EcoSpace;
See Also
EcoAutoFormExtender Class
Eco.WinForm Namespace


EcoAutoFormExtender.Enabled Property

EcoAutoFormExtender.Enabled Property
EcoAutoFormExtender Class Eco.WinForm Namespace See Also
Collapse All

Determines if the extdner is active or not. Default is true.

C#
public bool Enabled;
See Also
EcoAutoFormExtender Class
Eco.WinForm Namespace


EcoAutoFormExtender.MemberVisibility Property

EcoAutoFormExtender.MemberVisibility Property
EcoAutoFormExtender Class Eco.WinForm Namespace See Also
Collapse All

Determines what visibility of members will be shown on the autoform. Default is AutoContainerMemberVisibility.AllMembers.

C#
public AutoContainerMemberVisibility MemberVisibility;
See Also
EcoAutoFormExtender Class
Eco.WinForm Namespace


EcoAutoFormExtender.ShowModal Property

EcoAutoFormExtender.ShowModal Property
EcoAutoFormExtender Class Eco.WinForm Namespace See Also
Collapse All

If true, the autocontainer will show modally if the container supports it (i.e. is a form)

C#
public bool ShowModal;
See Also
EcoAutoFormExtender Class
Eco.WinForm Namespace


EcoDataGridTextBoxColumn Class

EcoDataGridTextBoxColumn Class
Inheritance Hierarchy See Also
Collapse All
C#
public class EcoDataGridTextBoxColumn : DataGridTextBoxColumn;
Remarks

This is class Eco.WinForm.EcoDataGridTextBoxColumn.

Inheritance Hierarchy
System.Windows.Forms.DataGridTextBoxColumn
    Eco.WinForm.EcoDataGridTextBoxColumn
File

EcoDataGridTextBoxColumn.cs

See Also
Inheritance Hierarchy


EcoDataGridTextBoxColumn Properties

EcoDataGridTextBoxColumn Properties
Public Properties
Collapse All

The properties of the EcoDataGridTextBoxColumn class are listed here.

Public Properties
Name | Description
PropertyDescriptor | This is PropertyDescriptor, a member of class EcoDataGridTextBoxColumn.


EcoDataGridTextBoxColumn.PropertyDescriptor Property

EcoDataGridTextBoxColumn.PropertyDescriptor Property
EcoDataGridTextBoxColumn Class Eco.WinForm Namespace See Also
Collapse All
C#
public override PropertyDescriptor PropertyDescriptor;
Remarks

This is PropertyDescriptor, a member of class EcoDataGridTextBoxColumn.

See Also
EcoDataGridTextBoxColumn Class
Eco.WinForm Namespace


EcoDragDropExtender Class

EcoDragDropExtender Class
Inheritance Hierarchy See Also
Collapse All
C#
public class EcoDragDropExtender : System.ComponentModel.Component, System.ComponentModel.IExtenderProvider;
Remarks

This is class Eco.WinForm.EcoDragDropExtender.

Inheritance Hierarchy
Eco.WinForm.EcoDragDropExtender
File

DragDropExtender.cs

See Also
Inheritance Hierarchy


EcoDragDropExtender Methods

EcoDragDropExtender Methods
Protected Methods Public Methods
Collapse All

The methods of the EcoDragDropExtender class are listed here.

Protected Methods
Name | Description
HookupSource | This virtual method hooks up the extended control's event. You may want some other event hooked, or hook to something else.
HookupTarget | This virtual method hooks up the extended control's event. You may want some other event hooked, or hook to something else.
OnDragDrop | This is OnDragDrop, a member of class EcoDragDropExtender.
OnDragOver | This is OnDragOver, a member of class EcoDragDropExtender.
OnMouseDown |
OnMouseMove | This is OnMouseMove, a member of class EcoDragDropExtender.
OnMouseUp | This is OnMouseUp, a member of class EcoDragDropExtender.
UnhookSource | This virtual method unhooks up the extended controls event.
UnhookTarget | This virtual method unhooks up the extended controls event.
Top
Public Methods
Name | Description
AppropriateEffect | Helps determine tha appropriate drag-drop effect based on e.AllowedEffect and key state.
CanExtend | This is CanExtend, a member of class EcoDragDropExtender.
GetEcoDragSource | This is GetEcoDragSource, a member of class EcoDragDropExtender.
GetEcoDropTarget | This is GetEcoDropTarget, a member of class EcoDragDropExtender.
SetEcoDragSource |
SetEcoDropTarget |


EcoDragDropExtender.AppropriateEffect Method

EcoDragDropExtender.AppropriateEffect Method
EcoDragDropExtender Class Eco.WinForm Namespace See Also
Collapse All

Helps determine tha appropriate drag-drop effect based on e.AllowedEffect and key state.

C#
public static DragDropEffects AppropriateEffect(
    System.Windows.Forms.DragEventArgs e
);
Exceptions
Exceptions | Description
ArgumentNullException | Thrown if e is null.
See Also
EcoDragDropExtender Class
Eco.WinForm Namespace


EcoDragDropExtender.CanExtend Method

EcoDragDropExtender.CanExtend Method
EcoDragDropExtender Class Eco.WinForm Namespace See Also
Collapse All
C#
public virtual bool CanExtend(
    object extendee
);
Remarks

This is CanExtend, a member of class EcoDragDropExtender.

See Also
EcoDragDropExtender Class
Eco.WinForm Namespace


EcoDragDropExtender.GetEcoDragSource Method

EcoDragDropExtender.GetEcoDragSource Method
EcoDragDropExtender Class Eco.WinForm Namespace See Also
Collapse All
C#
public bool GetEcoDragSource(
    Control control
);
Remarks

This is GetEcoDragSource, a member of class EcoDragDropExtender.

See Also
EcoDragDropExtender Class
Eco.WinForm Namespace


EcoDragDropExtender.GetEcoDropTarget Method

EcoDragDropExtender.GetEcoDropTarget Method
EcoDragDropExtender Class Eco.WinForm Namespace See Also
Collapse All
C#
public bool GetEcoDropTarget(
    Control control
);
Remarks

This is GetEcoDropTarget, a member of class EcoDragDropExtender.

See Also
EcoDragDropExtender Class
Eco.WinForm Namespace


EcoDragDropExtender.HookupSource Method

EcoDragDropExtender.HookupSource Method
EcoDragDropExtender Class Eco.WinForm Namespace See Also
Collapse All

This virtual method hooks up the extended control's event. You may want some other event hooked, or hook to something else.

C#
protected virtual void HookupSource(
    Control control
);
Exceptions
Exceptions | Description
ArgumentNullException | Thrown if control is null.
See Also
EcoDragDropExtender Class
Eco.WinForm Namespace


EcoDragDropExtender.HookupTarget Method

EcoDragDropExtender.HookupTarget Method
EcoDragDropExtender Class Eco.WinForm Namespace See Also
Collapse All

This virtual method hooks up the extended control's event. You may want some other event hooked, or hook to something else.

C#
protected virtual void HookupTarget(
    Control control
);
Exceptions
Exceptions | Description
ArgumentNullException | Thrown if control is null.
See Also
EcoDragDropExtender Class
Eco.WinForm Namespace


EcoDragDropExtender.OnDragDrop Method

EcoDragDropExtender.OnDragDrop Method
EcoDragDropExtender Class Eco.WinForm Namespace See Also
Collapse All
C#
protected void OnDragDrop(
    object sender,
    System.Windows.Forms.DragEventArgs e
);
Remarks

This is OnDragDrop, a member of class EcoDragDropExtender.

See Also
EcoDragDropExtender Class
Eco.WinForm Namespace


EcoDragDropExtender.OnDragOver Method

EcoDragDropExtender.OnDragOver Method
EcoDragDropExtender Class Eco.WinForm Namespace See Also
Collapse All
C#
protected void OnDragOver(
    object sender,
    System.Windows.Forms.DragEventArgs e
);
Remarks

This is OnDragOver, a member of class EcoDragDropExtender.

See Also
EcoDragDropExtender Class
Eco.WinForm Namespace


EcoDragDropExtender.OnMouseDown Method

EcoDragDropExtender.OnMouseDown Method
EcoDragDropExtender Class Eco.WinForm Namespace See Also
Collapse All
C#
protected void OnMouseDown(
    object sender,
    System.Windows.Forms.MouseEventArgs e
);
Exceptions
Exceptions | Description
ArgumentNullException | Thrown if e is null.
See Also
EcoDragDropExtender Class
Eco.WinForm Namespace


EcoDragDropExtender.OnMouseMove Method

EcoDragDropExtender.OnMouseMove Method
EcoDragDropExtender Class Eco.WinForm Namespace See Also
Collapse All
C#
protected void OnMouseMove(
    object sender,
    System.Windows.Forms.MouseEventArgs e
);
Remarks

This is OnMouseMove, a member of class EcoDragDropExtender.

See Also
EcoDragDropExtender Class
Eco.WinForm Namespace


EcoDragDropExtender.OnMouseUp Method

EcoDragDropExtender.OnMouseUp Method
EcoDragDropExtender Class Eco.WinForm Namespace See Also
Collapse All
C#
protected void OnMouseUp(
    object sender,
    System.Windows.Forms.MouseEventArgs e
);
Remarks

This is OnMouseUp, a member of class EcoDragDropExtender.

See Also
EcoDragDropExtender Class
Eco.WinForm Namespace


EcoDragDropExtender.SetEcoDragSource Method

EcoDragDropExtender.SetEcoDragSource Method
EcoDragDropExtender Class Eco.WinForm Namespace See Also
Collapse All
C#
public void SetEcoDragSource(
    Control control,
    bool value
);
Exceptions
Exceptions | Description
ArgumentNullException | Thrown if control is null.
See Also
EcoDragDropExtender Class
Eco.WinForm Namespace


EcoDragDropExtender.SetEcoDropTarget Method

EcoDragDropExtender.SetEcoDropTarget Method
EcoDragDropExtender Class Eco.WinForm Namespace See Also
Collapse All
C#
public void SetEcoDropTarget(
    Control control,
    bool value
);
Exceptions
Exceptions | Description
ArgumentNullException | Thrown if control is null.
See Also
EcoDragDropExtender Class
Eco.WinForm Namespace


EcoDragDropExtender.UnhookSource Method

EcoDragDropExtender.UnhookSource Method
EcoDragDropExtender Class Eco.WinForm Namespace See Also
Collapse All

This virtual method unhooks up the extended controls event.

C#
protected virtual void UnhookSource(
    Control control
);
Exceptions
Exceptions | Description
ArgumentNullException | Thrown if control is null.
See Also
EcoDragDropExtender Class
Eco.WinForm Namespace


EcoDragDropExtender.UnhookTarget Method

EcoDragDropExtender.UnhookTarget Method
EcoDragDropExtender Class Eco.WinForm Namespace See Also
Collapse All

This virtual method unhooks up the extended controls event.

C#
protected virtual void UnhookTarget(
    Control control
);
Exceptions
Exceptions | Description
ArgumentNullException | Thrown if control is null.
See Also
EcoDragDropExtender Class
Eco.WinForm Namespace


EcoListActionExtender Class

EcoListActionExtender Class
Inheritance Hierarchy See Also
Collapse All

This class extends buttons with new properties; EcoListAction, RootHandle, BindingContext, ActionOCL, EnabledOCL and VisibleOCL. The purpose of these are to provide a code free interface to manipulate lists.

C#
public class EcoListActionExtender : System.ComponentModel.Component, System.ComponentModel.IExtenderProvider, IStaticContextFromObject;
Inheritance Hierarchy
Eco.WinForm.EcoListActionExtender
File

ListActionExtender.cs

See Also
Inheritance Hierarchy


EcoListActionExtender Classes

EcoListActionExtender Classes
Classes
Collapse All

The classes of the EcoListActionExtender class are listed here.

Classes
Name | Description
CurrencyManagerWrapper | This is class Eco.WinForm.EcoListActionExtender.CurrencyManagerWrapper.


EcoListActionExtender.CurrencyManagerWrapper Class

EcoListActionExtender.CurrencyManagerWrapper Class
Inheritance Hierarchy See Also
Collapse All
C#
public class CurrencyManagerWrapper : ICurrencyManager;
Remarks

This is class Eco.WinForm.EcoListActionExtender.CurrencyManagerWrapper.

Inheritance Hierarchy
Eco.WinForm.EcoListActionExtender.CurrencyManagerWrapper
File

ListActionExtender.cs

See Also
Inheritance Hierarchy


EcoListActionExtender.CurrencyManagerWrapper.CurrencyManagerWrapper Constructor

EcoListActionExtender.CurrencyManagerWrapper.CurrencyManagerWrapper Constructor
EcoListActionExtender.CurrencyManagerWrapper Class Eco.WinForm Namespace See Also
Collapse All
C#
public CurrencyManagerWrapper(
    CurrencyManager cm
);
Remarks

This is CurrencyManagerWrapper, a member of class CurrencyManagerWrapper.

See Also
EcoListActionExtender.CurrencyManagerWrapper Class
Eco.WinForm Namespace


CurrencyManagerWrapper Methods

CurrencyManagerWrapper Methods
Public Methods
Collapse All

The methods of the CurrencyManagerWrapper class are listed here.

Public Methods
Name | Description
MoveObject | This is MoveObject, a member of class CurrencyManagerWrapper.


EcoListActionExtender.CurrencyManagerWrapper.MoveObject Method

EcoListActionExtender.CurrencyManagerWrapper.MoveObject Method
EcoListActionExtender.CurrencyManagerWrapper Class Eco.WinForm Namespace See Also
Collapse All
C#
public void MoveObject(
    IElement element,
    int delta
);
Remarks

This is MoveObject, a member of class CurrencyManagerWrapper.

See Also
EcoListActionExtender.CurrencyManagerWrapper Class
Eco.WinForm Namespace


CurrencyManagerWrapper Properties

CurrencyManagerWrapper Properties
Public Properties
Collapse All

The properties of the CurrencyManagerWrapper class are listed here.

Public Properties
Name | Description
Collection | This is Collection, a member of class CurrencyManagerWrapper.
Count | This is Count, a member of class CurrencyManagerWrapper.
Current | This is Current, a member of class CurrencyManagerWrapper.
Element | This is Element, a member of class CurrencyManagerWrapper.
EnsuredCollection | This is EnsuredCollection, a member of class CurrencyManagerWrapper.
List | This is List, a member of class CurrencyManagerWrapper.
Position | This is Position, a member of class CurrencyManagerWrapper.


EcoListActionExtender.CurrencyManagerWrapper.Collection Property

EcoListActionExtender.CurrencyManagerWrapper.Collection Property
EcoListActionExtender.CurrencyManagerWrapper Class Eco.WinForm Namespace See Also
Collapse All
C#
public IElementCollection Collection;
Remarks

This is Collection, a member of class CurrencyManagerWrapper.

See Also
EcoListActionExtender.CurrencyManagerWrapper Class
Eco.WinForm Namespace


EcoListActionExtender.CurrencyManagerWrapper.Count Property

EcoListActionExtender.CurrencyManagerWrapper.Count Property
EcoListActionExtender.CurrencyManagerWrapper Class Eco.WinForm Namespace See Also
Collapse All
C#
public int Count;
Remarks

This is Count, a member of class CurrencyManagerWrapper.

See Also
EcoListActionExtender.CurrencyManagerWrapper Class
Eco.WinForm Namespace


EcoListActionExtender.CurrencyManagerWrapper.Current Property

EcoListActionExtender.CurrencyManagerWrapper.Current Property
EcoListActionExtender.CurrencyManagerWrapper Class Eco.WinForm Namespace See Also
Collapse All
C#
public object Current;
Remarks

This is Current, a member of class CurrencyManagerWrapper.

See Also
EcoListActionExtender.CurrencyManagerWrapper Class
Eco.WinForm Namespace


EcoListActionExtender.CurrencyManagerWrapper.Element Property

EcoListActionExtender.CurrencyManagerWrapper.Element Property
EcoListActionExtender.CurrencyManagerWrapper Class Eco.WinForm Namespace See Also
Collapse All
C#
public IElement Element;
Remarks

This is Element, a member of class CurrencyManagerWrapper.

See Also
EcoListActionExtender.CurrencyManagerWrapper Class
Eco.WinForm Namespace


EcoListActionExtender.CurrencyManagerWrapper.EnsuredCollection Property

EcoListActionExtender.CurrencyManagerWrapper.EnsuredCollection Property
EcoListActionExtender.CurrencyManagerWrapper Class Eco.WinForm Namespace See Also
Collapse All
C#
public IElementCollection EnsuredCollection;
Remarks

This is EnsuredCollection, a member of class CurrencyManagerWrapper.

See Also
EcoListActionExtender.CurrencyManagerWrapper Class
Eco.WinForm Namespace


EcoListActionExtender.CurrencyManagerWrapper.List Property

EcoListActionExtender.CurrencyManagerWrapper.List Property
EcoListActionExtender.CurrencyManagerWrapper Class Eco.WinForm Namespace See Also
Collapse All
C#
public IList List;
Remarks

This is List, a member of class CurrencyManagerWrapper.

See Also
EcoListActionExtender.CurrencyManagerWrapper Class
Eco.WinForm Namespace


EcoListActionExtender.CurrencyManagerWrapper.Position Property

EcoListActionExtender.CurrencyManagerWrapper.Position Property
EcoListActionExtender.CurrencyManagerWrapper Class Eco.WinForm Namespace See Also
Collapse All
C#
public int Position;
Remarks

This is Position, a member of class CurrencyManagerWrapper.

See Also
EcoListActionExtender.CurrencyManagerWrapper Class
Eco.WinForm Namespace


EcoListActionExtender Interfaces

EcoListActionExtender Interfaces
Interfaces
Collapse All

The interfaces of the EcoListActionExtender class are listed here.

Interfaces
Name | Description
ICurrencyManager | This is class Eco.WinForm.EcoListActionExtender.ICurrencyManager.


EcoListActionExtender.ICurrencyManager Interface

EcoListActionExtender.ICurrencyManager Interface
Inheritance Hierarchy See Also
Collapse All
C#
public interface ICurrencyManager;
Remarks

This is class Eco.WinForm.EcoListActionExtender.ICurrencyManager.

Inheritance Hierarchy
Eco.WinForm.EcoListActionExtender.ICurrencyManager
File

ListActionExtender.cs

See Also
Inheritance Hierarchy


ICurrencyManager Methods

ICurrencyManager Methods
Public Methods
Collapse All

The methods of the ICurrencyManager class are listed here.

Public Methods
Name | Description
MoveObject | This is MoveObject, a member of class ICurrencyManager.


EcoListActionExtender.ICurrencyManager.MoveObject Method

EcoListActionExtender.ICurrencyManager.MoveObject Method
EcoListActionExtender.ICurrencyManager Interface Eco.WinForm Namespace See Also
Collapse All
C#
void MoveObject(
    IElement element,
    int delta
);
Remarks

This is MoveObject, a member of class ICurrencyManager.

See Also
EcoListActionExtender.ICurrencyManager Interface
Eco.WinForm Namespace


ICurrencyManager Properties

ICurrencyManager Properties
Public Properties
Collapse All

The properties of the ICurrencyManager class are listed here.

Public Properties
Name | Description
Collection | This is Collection, a member of class ICurrencyManager.
Count | This is Count, a member of class ICurrencyManager.
Current | This is Current, a member of class ICurrencyManager.
Element | This is Element, a member of class ICurrencyManager.
EnsuredCollection | This is EnsuredCollection, a member of class ICurrencyManager.
List | This is List, a member of class ICurrencyManager.
Position | This is Position, a member of class ICurrencyManager.


EcoListActionExtender.ICurrencyManager.Collection Property

EcoListActionExtender.ICurrencyManager.Collection Property
EcoListActionExtender.ICurrencyManager Interface Eco.WinForm Namespace See Also
Collapse All
C#
IElementCollection Collection;
Remarks

This is Collection, a member of class ICurrencyManager.

See Also
EcoListActionExtender.ICurrencyManager Interface
Eco.WinForm Namespace


EcoListActionExtender.ICurrencyManager.Count Property

EcoListActionExtender.ICurrencyManager.Count Property
EcoListActionExtender.ICurrencyManager Interface Eco.WinForm Namespace See Also
Collapse All
C#
int Count;
Remarks

This is Count, a member of class ICurrencyManager.

See Also
EcoListActionExtender.ICurrencyManager Interface
Eco.WinForm Namespace


EcoListActionExtender.ICurrencyManager.Current Property

EcoListActionExtender.ICurrencyManager.Current Property
EcoListActionExtender.ICurrencyManager Interface Eco.WinForm Namespace See Also
Collapse All
C#
object Current;
Remarks

This is Current, a member of class ICurrencyManager.

See Also
EcoListActionExtender.ICurrencyManager Interface
Eco.WinForm Namespace


EcoListActionExtender.ICurrencyManager.Element Property

EcoListActionExtender.ICurrencyManager.Element Property
EcoListActionExtender.ICurrencyManager Interface Eco.WinForm Namespace See Also
Collapse All
C#
IElement Element;
Remarks

This is Element, a member of class ICurrencyManager.

See Also
EcoListActionExtender.ICurrencyManager Interface
Eco.WinForm Namespace


EcoListActionExtender.ICurrencyManager.EnsuredCollection Property

EcoListActionExtender.ICurrencyManager.EnsuredCollection Property
EcoListActionExtender.ICurrencyManager Interface Eco.WinForm Namespace See Also
Collapse All
C#
IElementCollection EnsuredCollection;
Remarks

This is EnsuredCollection, a member of class ICurrencyManager.

See Also
EcoListActionExtender.ICurrencyManager Interface
Eco.WinForm Namespace


EcoListActionExtender.ICurrencyManager.List Property

EcoListActionExtender.ICurrencyManager.List Property
EcoListActionExtender.ICurrencyManager Interface Eco.WinForm Namespace See Also
Collapse All
C#
IList List;
Remarks

This is List, a member of class ICurrencyManager.

See Also
EcoListActionExtender.ICurrencyManager Interface
Eco.WinForm Namespace


EcoListActionExtender.ICurrencyManager.Position Property

EcoListActionExtender.ICurrencyManager.Position Property
EcoListActionExtender.ICurrencyManager Interface Eco.WinForm Namespace See Also
Collapse All
C#
int Position;
Remarks

This is Position, a member of class ICurrencyManager.

See Also
EcoListActionExtender.ICurrencyManager Interface
Eco.WinForm Namespace


EcoListActionExtender Methods

EcoListActionExtender Methods
Protected Methods Public Methods
Collapse All

The methods of the EcoListActionExtender class are listed here.

Protected Methods
Name | Description
GetCurrencyManager | This is GetCurrencyManager, a member of class EcoListActionExtender.
Hookup | This virtual method hooks up the extended control's event. The default case is to hook the protected method OnClick to Click, but you may want some other event hooked, or hook to something else.
OnClick | This is OnClick, a member of class EcoListActionExtender.
SetEnabled | Sets the property Enabled on the extended component
SetImageList | This is SetImageList, a member of class EcoListActionExtender.
SetVisible | Sets the property Visible on the extended component
Unhook | This virtual method unhooks up the extended controls event. The default case is to unhook the protected method OnClick to Click, but if you have hooked some other event you probably want to override this too, for the sake of symmetry.
Top
Public Methods
Name | Description
CanExtend | This method determines which controls are to be considered extensible, i.e. receive new properties. You may override this method in a subclass if you need additional (or other) rules to determine which controls to extend.
ExecuteAction | Performs the activity specified by the action.
GetActionExpression | Getter for ActionExpression. ActionExpression is an expression of ECO ActionLanguage that will be executed if the Action-property is set to ExecuteAction
GetBindingContext | Returns BindingContext if it is set, else the control itself
GetEcoListAction | Getter for EcoListAction.
GetEnabledOcl | Getter for EnabledOcl. EnabledOcl is an OCL expression controlling if the extended control should be enabled or not. If left blank, ECO will not modify the control's Enabled property.
GetExpectedType | This is GetExpectedType, a member of class EcoListActionExtender.
GetRootHandle | Getter for RootHandle.
GetVisibleOcl | Getter for VisibleOcl. EnabledOcl is an OCL expression controlling if the extended control should be visible or not. If left blank, ECO will not modify the control's Visible property.
SetActionExpression | Setter for ActionOcl.
SetBindingContext | Setter for BindingContext.
SetEcoListAction | Sets the EcoListAction on the extendee. Also sets caption - if caption has not been changed from a default value and hooks up/removed ImageList and ImageIndex on extendee.
SetEnabledOcl | Setter for EnabledOcl.
SetRootHandle | Setter for RootHandle
SetVisibleOcl | Setter for VisibleOcl.
StaticContextForObject | For internal use.


EcoListActionExtender.CanExtend Method

EcoListActionExtender.CanExtend Method
EcoListActionExtender Class Eco.WinForm Namespace See Also
Collapse All

This method determines which controls are to be considered extensible, i.e. receive new properties. You may override this method in a subclass if you need additional (or other) rules to determine which controls to extend.

C#
public virtual bool CanExtend(
    object extendee
);
See Also
EcoListActionExtender Class
Eco.WinForm Namespace


EcoListActionExtender.ExecuteAction Method

EcoListActionExtender.ExecuteAction Method
EcoListActionExtender Class Eco.WinForm Namespace See Also
Collapse All

Performs the activity specified by the action.

C#
public void ExecuteAction(
    ListAction action,
    Component component
);
Parameters
Parameters | Description
action | The action to perform.
component | An extended component, required to find the extended properties.
Exceptions
Exceptions | Description
InvalidOperationException | Thrown if a the component does not have the RootHandle set.
ArgumentException | Thrown if a CurrencyManager cannot be found linking the control and the RootHandle set to that control.
See Also
EcoListActionExtender Class
Eco.WinForm Namespace


EcoListActionExtender.GetActionExpression Method

EcoListActionExtender.GetActionExpression Method
EcoListActionExtender Class Eco.WinForm Namespace See Also
Collapse All

Getter for ActionExpression. ActionExpression is an expression of ECO ActionLanguage that will be executed if the Action-property is set to ExecuteAction

C#
public string GetActionExpression(
    Component component
);
Parameters
Parameters | Description
component | Component to query.
See Also
EcoListActionExtender Class
Eco.WinForm Namespace


EcoListActionExtender.GetBindingContext Method

EcoListActionExtender.GetBindingContext Method
EcoListActionExtender Class Eco.WinForm Namespace See Also
Collapse All

Returns BindingContext if it is set, else the control itself

C#
public Control GetBindingContext(
    Component component
);
Parameters
Parameters | Description
component | Component to query.
See Also
EcoListActionExtender Class
Eco.WinForm Namespace


EcoListActionExtender.GetCurrencyManager Method

EcoListActionExtender.GetCurrencyManager Method
EcoListActionExtender Class Eco.WinForm Namespace See Also
Collapse All
C#
protected virtual ICurrencyManager GetCurrencyManager(
    Control bindingContext,
    object bindingContextKey
);
Remarks

This is GetCurrencyManager, a member of class EcoListActionExtender.

See Also
EcoListActionExtender Class
Eco.WinForm Namespace


EcoListActionExtender.GetEcoListAction Method

EcoListActionExtender.GetEcoListAction Method
EcoListActionExtender Class Eco.WinForm Namespace See Also
Collapse All

Getter for EcoListAction.

C#
public ListAction GetEcoListAction(
    Component component
);
Parameters
Parameters | Description
component | component to query for.
See Also
EcoListActionExtender Class
Eco.WinForm Namespace


EcoListActionExtender.GetEnabledOcl Method

EcoListActionExtender.GetEnabledOcl Method
EcoListActionExtender Class Eco.WinForm Namespace See Also
Collapse All

Getter for EnabledOcl. EnabledOcl is an OCL expression controlling if the extended control should be enabled or not. If left blank, ECO will not modify the control's Enabled property.

C#
public string GetEnabledOcl(
    Component component
);
Parameters
Parameters | Description
component | Component to query.
See Also
EcoListActionExtender Class
Eco.WinForm Namespace


EcoListActionExtender.GetExpectedType Method

EcoListActionExtender.GetExpectedType Method
EcoListActionExtender Class Eco.WinForm Namespace See Also
Collapse All
C#
public IClassifier GetExpectedType(
    ExtenderProvidedPropertyAttribute prop,
    IStaticContext context
);
Remarks

This is GetExpectedType, a member of class EcoListActionExtender.

See Also
EcoListActionExtender Class
Eco.WinForm Namespace


EcoListActionExtender.GetRootHandle Method

EcoListActionExtender.GetRootHandle Method
EcoListActionExtender Class Eco.WinForm Namespace See Also
Collapse All

Getter for RootHandle.

C#
public ElementHandle GetRootHandle(
    Component component
);
Parameters
Parameters | Description
component | Component to query.
See Also
EcoListActionExtender Class
Eco.WinForm Namespace


EcoListActionExtender.GetVisibleOcl Method

EcoListActionExtender.GetVisibleOcl Method
EcoListActionExtender Class Eco.WinForm Namespace See Also
Collapse All

Getter for VisibleOcl. EnabledOcl is an OCL expression controlling if the extended control should be visible or not. If left blank, ECO will not modify the control's Visible property.

C#
public string GetVisibleOcl(
    Component component
);
Parameters
Parameters | Description
component | Component to query.
See Also
EcoListActionExtender Class
Eco.WinForm Namespace


EcoListActionExtender.Hookup Method

EcoListActionExtender.Hookup Method
EcoListActionExtender Class Eco.WinForm Namespace See Also
Collapse All

This virtual method hooks up the extended control's event. The default case is to hook the protected method OnClick to Click, but you may want some other event hooked, or hook to something else.

C#
protected virtual void Hookup(
    Component component
);
Exceptions
Exceptions | Description
ArgumentNullException | Thrown if component is null.
See Also
EcoListActionExtender Class
Eco.WinForm Namespace


EcoListActionExtender.OnClick Method

EcoListActionExtender.OnClick Method
EcoListActionExtender Class Eco.WinForm Namespace See Also
Collapse All
C#
protected void OnClick(
    object sender,
    EventArgs e
);
Remarks

This is OnClick, a member of class EcoListActionExtender.

See Also
EcoListActionExtender Class
Eco.WinForm Namespace


EcoListActionExtender.SetActionExpression Method

EcoListActionExtender.SetActionExpression Method
EcoListActionExtender Class Eco.WinForm Namespace See Also
Collapse All

Setter for ActionOcl.

C#
public void SetActionExpression(
    Component component,
    string value
);
Parameters
Parameters | Description
component | Component to extend.
value | The string representing the ActionExpression with which the control will be associated.
See Also
EcoListActionExtender Class
Eco.WinForm Namespace


EcoListActionExtender.SetBindingContext Method

EcoListActionExtender.SetBindingContext Method
EcoListActionExtender Class Eco.WinForm Namespace See Also
Collapse All

Setter for BindingContext.

C#
public void SetBindingContext(
    Component component,
    Control value
);
Parameters
Parameters | Description
component | Component to extend.
value | The Control the control will use as its associated binding context.
Exceptions
Exceptions | Description
InvalidOperationException | Thrown if called with value equalling control.
See Also
EcoListActionExtender Class
Eco.WinForm Namespace


EcoListActionExtender.SetEcoListAction Method

EcoListActionExtender.SetEcoListAction Method
EcoListActionExtender Class Eco.WinForm Namespace See Also
Collapse All

Sets the EcoListAction on the extendee. Also sets caption - if caption has not been changed from a default value and hooks up/removed ImageList and ImageIndex on extendee.

C#
public void SetEcoListAction(
    Component component,
    ListAction value
);
Parameters
Parameters | Description
component | Component to extend.
value | The ListAction to associate with control.
Exceptions
Exceptions | Description
ArgumentNullException | Thrown if component is null.
See Also
EcoListActionExtender Class
Eco.WinForm Namespace


EcoListActionExtender.SetEnabled Method

EcoListActionExtender.SetEnabled Method
EcoListActionExtender Class Eco.WinForm Namespace See Also
Collapse All

Sets the property Enabled on the extended component

C#
protected virtual void SetEnabled(
    object extendee,
    bool value
);
Remarks

Controls and MenuItems are handled by typecasting the extended component, other componets are checked for a property called "Enabled". If you need to extend a component that sets its visibility some other way, you need to subclass this extender and override this method.

See Also
EcoListActionExtender Class
Eco.WinForm Namespace


EcoListActionExtender.SetEnabledOcl Method

EcoListActionExtender.SetEnabledOcl Method
EcoListActionExtender Class Eco.WinForm Namespace See Also
Collapse All

Setter for EnabledOcl.

C#
public void SetEnabledOcl(
    Component component,
    string value
);
Parameters
Parameters | Description
component | Component to extend.
value | The OCL expression used that will be bound to the Enabled-property of the control.
See Also
EcoListActionExtender Class
Eco.WinForm Namespace


EcoListActionExtender.SetImageList Method

EcoListActionExtender.SetImageList Method
EcoListActionExtender Class Eco.WinForm Namespace See Also
Collapse All
C#
protected virtual void SetImageList(
    Component component,
    ImageList oldImageList,
    ImageList newImageList,
    int imageIndex
);
Remarks

This is SetImageList, a member of class EcoListActionExtender.

See Also
EcoListActionExtender Class
Eco.WinForm Namespace


EcoListActionExtender.SetRootHandle Method

EcoListActionExtender.SetRootHandle Method
EcoListActionExtender Class Eco.WinForm Namespace See Also
Collapse All

Setter for RootHandle

C#
public void SetRootHandle(
    Component component,
    ElementHandle value
);
Parameters
Parameters | Description
component | Component to extend.
value | The ElementHandle to associate with control.
See Also
EcoListActionExtender Class
Eco.WinForm Namespace


EcoListActionExtender.SetVisible Method

EcoListActionExtender.SetVisible Method
EcoListActionExtender Class Eco.WinForm Namespace See Also
Collapse All

Sets the property Visible on the extended component

C#
protected virtual void SetVisible(
    object extendee,
    bool value
);
Remarks

Controls and MenuItems are handled by typecasting the extended component, other componets are checked for a property called "Visible". If you need to extend a component that sets its visibility some other way, you need to subclass this extender and override this method.

See Also
EcoListActionExtender Class
Eco.WinForm Namespace


EcoListActionExtender.SetVisibleOcl Method

EcoListActionExtender.SetVisibleOcl Method
EcoListActionExtender Class Eco.WinForm Namespace See Also
Collapse All

Setter for VisibleOcl.

C#
public void SetVisibleOcl(
    Component component,
    string value
);
Parameters
Parameters | Description
component | Component to extend.
value | The OCL expression used that will be bound to the Visible-property of the control.
See Also
EcoListActionExtender Class
Eco.WinForm Namespace


EcoListActionExtender.StaticContextForObject Method

EcoListActionExtender.StaticContextForObject Method
EcoListActionExtender Class Eco.WinForm Namespace See Also
Collapse All

For internal use.

C#
public IStaticContext StaticContextForObject(
    object o
);
See Also
EcoListActionExtender Class
Eco.WinForm Namespace


EcoListActionExtender.Unhook Method

EcoListActionExtender.Unhook Method
EcoListActionExtender Class Eco.WinForm Namespace See Also
Collapse All

This virtual method unhooks up the extended controls event. The default case is to unhook the protected method OnClick to Click, but if you have hooked some other event you probably want to override this too, for the sake of symmetry.

C#
protected virtual void Unhook(
    Component component
);
Exceptions
Exceptions | Description
ArgumentNullException | Thrown if control is null.
See Also
EcoListActionExtender Class
Eco.WinForm Namespace


EcoListActionExtender Properties

EcoListActionExtender Properties
Public Properties
Collapse All

The properties of the EcoListActionExtender class are listed here.

Public Properties
Name | Description
CaptionAdd | The default caption used when the action is set to Add.
CaptionDelete | The default caption used when the action is set to Delete.
CaptionExecuteAction | The default caption used when the action is set to Action.
CaptionMoveDown | The default caption used when the action is set to MoveDown.
CaptionMoveFirst | The default caption used when the action is set to MoveFirst.
CaptionMoveLast | The default caption used when the action is set to MoveLast.
CaptionMoveNext | The default caption used when the action is set to MoveNext.
CaptionMovePrev | The default caption used when the action is set to MovePrev.
CaptionMoveUp | The default caption used when the action is set to MoveUp.
CaptionReload | The default caption used when the action is set to Reload.
CaptionShowAutoForm | The default caption used when the action is set to ShowAutoForm.
CaptionUnlink | The default caption used when the action is set to Unlink.
DeleteQuestion | The default text used when querying user to delete object.
EcoSpace | Obsolete, for backwards compatibility. No longer does anything.
Enabled | Controls if the extender component to Enabled. If it is not, none of the connected buttons will perform their action.
ImageList | By hooking up an image list to the extender, each connected button can get an image "automatically" by specifying the ImageIndex property.
UnlinkQuestion | The default text used when querying user to unlink object.


EcoListActionExtender.CaptionAdd Property

EcoListActionExtender.CaptionAdd Property
EcoListActionExtender Class Eco.WinForm Namespace See Also
Collapse All

The default caption used when the action is set to Add.

C#
public string CaptionAdd;
See Also
EcoListActionExtender Class
Eco.WinForm Namespace


EcoListActionExtender.CaptionDelete Property

EcoListActionExtender.CaptionDelete Property
EcoListActionExtender Class Eco.WinForm Namespace See Also
Collapse All

The default caption used when the action is set to Delete.

C#
public string CaptionDelete;
See Also
EcoListActionExtender Class
Eco.WinForm Namespace


EcoListActionExtender.CaptionExecuteAction Property

EcoListActionExtender.CaptionExecuteAction Property
EcoListActionExtender Class Eco.WinForm Namespace See Also
Collapse All

The default caption used when the action is set to Action.

C#
public string CaptionExecuteAction;
See Also
EcoListActionExtender Class
Eco.WinForm Namespace


EcoListActionExtender.CaptionMoveDown Property

EcoListActionExtender.CaptionMoveDown Property
EcoListActionExtender Class Eco.WinForm Namespace See Also
Collapse All

The default caption used when the action is set to MoveDown.

C#
public string CaptionMoveDown;
See Also
EcoListActionExtender Class
Eco.WinForm Namespace


EcoListActionExtender.CaptionMoveFirst Property

EcoListActionExtender.CaptionMoveFirst Property
EcoListActionExtender Class Eco.WinForm Namespace See Also
Collapse All

The default caption used when the action is set to MoveFirst.

C#
public string CaptionMoveFirst;
See Also
EcoListActionExtender Class
Eco.WinForm Namespace


EcoListActionExtender.CaptionMoveLast Property

EcoListActionExtender.CaptionMoveLast Property
EcoListActionExtender Class Eco.WinForm Namespace See Also
Collapse All

The default caption used when the action is set to MoveLast.

C#
public string CaptionMoveLast;
See Also
EcoListActionExtender Class
Eco.WinForm Namespace


EcoListActionExtender.CaptionMoveNext Property

EcoListActionExtender.CaptionMoveNext Property
EcoListActionExtender Class Eco.WinForm Namespace See Also
Collapse All

The default caption used when the action is set to MoveNext.

C#
public string CaptionMoveNext;
See Also
EcoListActionExtender Class
Eco.WinForm Namespace


EcoListActionExtender.CaptionMovePrev Property

EcoListActionExtender.CaptionMovePrev Property
EcoListActionExtender Class Eco.WinForm Namespace See Also
Collapse All

The default caption used when the action is set to MovePrev.

C#
public string CaptionMovePrev;
See Also
EcoListActionExtender Class
Eco.WinForm Namespace


EcoListActionExtender.CaptionMoveUp Property

EcoListActionExtender.CaptionMoveUp Property
EcoListActionExtender Class Eco.WinForm Namespace See Also
Collapse All

The default caption used when the action is set to MoveUp.

C#
public string CaptionMoveUp;
See Also
EcoListActionExtender Class
Eco.WinForm Namespace


EcoListActionExtender.CaptionReload Property

EcoListActionExtender.CaptionReload Property
EcoListActionExtender Class Eco.WinForm Namespace See Also
Collapse All

The default caption used when the action is set to Reload.

C#
public string CaptionReload;
See Also
EcoListActionExtender Class
Eco.WinForm Namespace


EcoListActionExtender.CaptionShowAutoForm Property

EcoListActionExtender.CaptionShowAutoForm Property
EcoListActionExtender Class Eco.WinForm Namespace See Also
Collapse All

The default caption used when the action is set to ShowAutoForm.

C#
public string CaptionShowAutoForm;
See Also
EcoListActionExtender Class
Eco.WinForm Namespace


EcoListActionExtender.CaptionUnlink Property

EcoListActionExtender.CaptionUnlink Property
EcoListActionExtender Class Eco.WinForm Namespace See Also
Collapse All

The default caption used when the action is set to Unlink.

C#
public string CaptionUnlink;
See Also
EcoListActionExtender Class
Eco.WinForm Namespace


EcoListActionExtender.DeleteQuestion Property

EcoListActionExtender.DeleteQuestion Property
EcoListActionExtender Class Eco.WinForm Namespace See Also
Collapse All

The default text used when querying user to delete object.

C#
public string DeleteQuestion;
See Also
EcoListActionExtender Class
Eco.WinForm Namespace


EcoListActionExtender.EcoSpace Property

EcoListActionExtender.EcoSpace Property
EcoListActionExtender Class Eco.WinForm Namespace See Also
Collapse All

Obsolete, for backwards compatibility. No longer does anything.

C#
public EcoSpace EcoSpace;
See Also
EcoListActionExtender Class
Eco.WinForm Namespace


EcoListActionExtender.Enabled Property

EcoListActionExtender.Enabled Property
EcoListActionExtender Class Eco.WinForm Namespace See Also
Collapse All

Controls if the extender component to Enabled. If it is not, none of the connected buttons will perform their action.

C#
public bool Enabled;
See Also
EcoListActionExtender Class
Eco.WinForm Namespace


EcoListActionExtender.ImageList Property

EcoListActionExtender.ImageList Property
EcoListActionExtender Class Eco.WinForm Namespace See Also
Collapse All

By hooking up an image list to the extender, each connected button can get an image "automatically" by specifying the ImageIndex property.

C#
public ImageList ImageList;
See Also
EcoListActionExtender Class
Eco.WinForm Namespace


EcoListActionExtender.UnlinkQuestion Property

EcoListActionExtender.UnlinkQuestion Property
EcoListActionExtender Class Eco.WinForm Namespace See Also
Collapse All

The default text used when querying user to unlink object.

C#
public string UnlinkQuestion;
See Also
EcoListActionExtender Class
Eco.WinForm Namespace


EcoWinFormHelper Class

EcoWinFormHelper Class
Inheritance Hierarchy See Also
Collapse All

A collection of useful helper functions pertaining to Windows.Forms.

C#
public sealed class EcoWinFormHelper;
Inheritance Hierarchy
Eco.WinForm.EcoWinFormHelper
File

WinFormHelpers.cs

See Also
Inheritance Hierarchy


EcoWinFormHelper Fields

EcoWinFormHelper Fields
Public Fields
Collapse All

The fields of the EcoWinFormHelper class are listed here.

Public Fields
Name | Description
PropertyNameDataSource | This is PropertyNameDataSource, a member of class EcoWinFormHelper.
PropertyNameReadOnly | This is PropertyNameReadOnly, a member of class EcoWinFormHelper.


EcoWinFormHelper.PropertyNameDataSource Field

EcoWinFormHelper.PropertyNameDataSource Field
EcoWinFormHelper Class Eco.WinForm Namespace See Also
Collapse All
C#
public const string PropertyNameDataSource = "DataSource";
Remarks

This is PropertyNameDataSource, a member of class EcoWinFormHelper.

See Also
EcoWinFormHelper Class
Eco.WinForm Namespace


EcoWinFormHelper.PropertyNameReadOnly Field

EcoWinFormHelper.PropertyNameReadOnly Field
EcoWinFormHelper Class Eco.WinForm Namespace See Also
Collapse All
C#
public const string PropertyNameReadOnly = "ReadOnly";
Remarks

This is PropertyNameReadOnly, a member of class EcoWinFormHelper.

See Also
EcoWinFormHelper Class
Eco.WinForm Namespace


EcoWinFormHelper Methods

EcoWinFormHelper Methods
Public Methods
Collapse All

The methods of the EcoWinFormHelper class are listed here.

Public Methods
Name | Description
CaptionFromComponent | Gets the caption on a component if the component is a Control or a MenuItem. Helper function for extenders.
ConnectedDataSource | Returns the value of the property DataSource or null if not applicable.
ConnectedEcoSpace | Returns the EcoSpace the elementHandle is ultimately connected to - or null if the handle is not connected to an EcoSpace.
ConnectedHandle | Returns the datasource cast to an ElementHandle.
ContainsDroppable |
GetCurrentIndex |
GetDroppedElement |
GetElementCollectionFromDataSource | This is GetElementCollectionFromDataSource, a member of class EcoWinFormHelper.
GetIsReadOnly | Returns the value of the boolean property ReadOnly. Default is false.
SetCaptionOnComponent | Sets the caption on a component if the component is a Control or a MenuItem. Helper function for extenders.
SetEnabledOnComponent | Sets the Enabled-property on a component if the component is a Control or a MenuItem. Helper function for extenders.


EcoWinFormHelper.CaptionFromComponent Method

EcoWinFormHelper.CaptionFromComponent Method
EcoWinFormHelper Class Eco.WinForm Namespace See Also
Collapse All

Gets the caption on a component if the component is a Control or a MenuItem. Helper function for extenders.

C#
public static string CaptionFromComponent(
    Component component
);
See Also
EcoWinFormHelper Class
Eco.WinForm Namespace


EcoWinFormHelper.ConnectedDataSource Method

EcoWinFormHelper.ConnectedDataSource Method
EcoWinFormHelper Class Eco.WinForm Namespace See Also
Collapse All

Returns the value of the property DataSource or null if not applicable.

C#
public static object ConnectedDataSource(
    object o
);
Returns

Returns null if there is no property named DataSource - or the value of that property.

Exceptions
Exceptions | Description
ArgumentNullException | Thrown if control is null.
See Also
EcoWinFormHelper Class
Eco.WinForm Namespace


EcoWinFormHelper.ConnectedEcoSpace Method

EcoWinFormHelper.ConnectedEcoSpace Method
EcoWinFormHelper Class Eco.WinForm Namespace See Also
Collapse All

Returns the EcoSpace the elementHandle is ultimately connected to - or null if the handle is not connected to an EcoSpace.

C#
public static EcoSpace ConnectedEcoSpace(
    ElementHandle elementHandle
);
See Also
EcoWinFormHelper Class
Eco.WinForm Namespace


EcoWinFormHelper.ConnectedHandle Method

EcoWinFormHelper.ConnectedHandle Method
EcoWinFormHelper Class Eco.WinForm Namespace See Also
Collapse All

Returns the datasource cast to an ElementHandle.

C#
public static ElementHandle ConnectedHandle(
    object o
);
Remarks

If the datasource is a BindingSource, follow its datasource uplink chain until the source is not a BindingSource.

See Also
EcoWinFormHelper Class
Eco.WinForm Namespace


EcoWinFormHelper.ContainsDroppable Method

EcoWinFormHelper.ContainsDroppable Method
EcoWinFormHelper Class Eco.WinForm Namespace See Also
Collapse All
C#
public static bool ContainsDroppable(
    System.Windows.Forms.DragEventArgs e
);
Exceptions
Exceptions | Description
ArgumentNullException | Thrown if e is null.
See Also
EcoWinFormHelper Class
Eco.WinForm Namespace


EcoWinFormHelper.GetCurrentIndex Method

EcoWinFormHelper.GetCurrentIndex Method
EcoWinFormHelper Class Eco.WinForm Namespace See Also
Collapse All
C#
public static int GetCurrentIndex(
    Control control
);
Exceptions
Exceptions | Description
ArgumentNullException | Thrown if control is null.
See Also
EcoWinFormHelper Class
Eco.WinForm Namespace


EcoWinFormHelper.GetDroppedElement Method

EcoWinFormHelper.GetDroppedElement Method
EcoWinFormHelper Class Eco.WinForm Namespace See Also
Collapse All
C#
public static IElement GetDroppedElement(
    System.Windows.Forms.DragEventArgs e
);
Exceptions
Exceptions | Description
ArgumentNullException | Thrown if e is null.
See Also
EcoWinFormHelper Class
Eco.WinForm Namespace


EcoWinFormHelper.GetElementCollectionFromDataSource Method

EcoWinFormHelper.GetElementCollectionFromDataSource Method
EcoWinFormHelper Class Eco.WinForm Namespace See Also
Collapse All
C#
public static IElementCollection GetElementCollectionFromDataSource(
    object sender
);
Remarks

This is GetElementCollectionFromDataSource, a member of class EcoWinFormHelper.

See Also
EcoWinFormHelper Class
Eco.WinForm Namespace


EcoWinFormHelper.GetIsReadOnly Method

EcoWinFormHelper.GetIsReadOnly Method
EcoWinFormHelper Class Eco.WinForm Namespace See Also
Collapse All

Returns the value of the boolean property ReadOnly. Default is false.

C#
public static bool GetIsReadOnly(
    object sender
);
Exceptions
Exceptions | Description
ArgumentNullException | Thrown if sender is null.
See Also
EcoWinFormHelper Class
Eco.WinForm Namespace


EcoWinFormHelper.SetCaptionOnComponent Method

EcoWinFormHelper.SetCaptionOnComponent Method
EcoWinFormHelper Class Eco.WinForm Namespace See Also
Collapse All

Sets the caption on a component if the component is a Control or a MenuItem. Helper function for extenders.

C#
public static void SetCaptionOnComponent(
    Component component,
    string caption
);
See Also
EcoWinFormHelper Class
Eco.WinForm Namespace


EcoWinFormHelper.SetEnabledOnComponent Method

EcoWinFormHelper.SetEnabledOnComponent Method
EcoWinFormHelper Class Eco.WinForm Namespace See Also
Collapse All

Sets the Enabled-property on a component if the component is a Control or a MenuItem. Helper function for extenders.

C#
public static void SetEnabledOnComponent(
    Component component,
    bool enabled
);
See Also
EcoWinFormHelper Class
Eco.WinForm Namespace


TextBoxMaxLengthSupportProvider Class

TextBoxMaxLengthSupportProvider Class
Inheritance Hierarchy See Also
Collapse All
C#
public class TextBoxMaxLengthSupportProvider : IMaxLengthSupportProvider;
Remarks

This is class Eco.WinForm.TextBoxMaxLengthSupportProvider.

Inheritance Hierarchy
Eco.WinForm.TextBoxMaxLengthSupportProvider
File

MaxLengthSupportProviders.cs

See Also
Inheritance Hierarchy


TextBoxMaxLengthSupportProvider.TextBoxMaxLengthSupportProvider Constructor

TextBoxMaxLengthSupportProvider.TextBoxMaxLengthSupportProvider Constructor
TextBoxMaxLengthSupportProvider Class Eco.WinForm Namespace See Also
Collapse All
C#
public TextBoxMaxLengthSupportProvider();
Remarks

This is TextBoxMaxLengthSupportProvider, a member of class TextBoxMaxLengthSupportProvider.

See Also
TextBoxMaxLengthSupportProvider Class
Eco.WinForm Namespace


TextBoxMaxLengthSupportProvider Methods

TextBoxMaxLengthSupportProvider Methods
Public Methods
Collapse All

The methods of the TextBoxMaxLengthSupportProvider class are listed here.

Public Methods
Name | Description
SetMaxLength | This is SetMaxLength, a member of class TextBoxMaxLengthSupportProvider.


TextBoxMaxLengthSupportProvider.SetMaxLength Method

TextBoxMaxLengthSupportProvider.SetMaxLength Method
TextBoxMaxLengthSupportProvider Class Eco.WinForm Namespace See Also
Collapse All
C#
public void SetMaxLength(
    object obj
);
Remarks

This is SetMaxLength, a member of class TextBoxMaxLengthSupportProvider.

See Also
TextBoxMaxLengthSupportProvider Class
Eco.WinForm Namespace


Eco.WinForm.EcoAction Enumeration

Eco.WinForm.EcoAction Enumeration

Valid EcoActions for the EcoActionExtender.

C#
public enum EcoAction {
  None,
  UpdateDatabase,
  Undo,
  Redo,
  SetCheckPoint,
  ToggleActive,
  CreateSchema,
  EvolveSchema,
  ShowDebugger,
  DiscardChanges
}
Members
Members | Description
None | No action is performed.
UpdateDatabase | All persistent changes in object state are committed.
Undo | The latest undoblock is undone.
Redo | The latest redoblock is redone.
SetCheckPoint | An undo-checkpoint is set.
ToggleActive | The EcoSpace.Active property is toggled.
CreateSchema | A new database schema is generated.
EvolveSchema | The schema is evolved to match the current model.
ShowDebugger | Shows the ecospace debugger.
DiscardChanges | Throws out all modified values from the cache but keeps the unmodified.
File

ActionExtender.cs


Eco.WinForm.ListAction Enumeration

Eco.WinForm.ListAction Enumeration

ListAction enumeration lists implemented actions that the EcoListActionExtender offers. If an ImageList is hooked up to the extender component, the ordinal position of the action in the enumeration will be used as ImageIndex on the extendee.

C#
public enum ListAction {
  None,
  Add,
  Delete,
  MovePrev,
  MoveNext,
  MoveFirst,
  MoveLast,
  Unlink,
  Reload,
  ShowAutoForm,
  MoveUp,
  MoveDown,
  ExecuteAction
}
Members
Members | Description
None | No action is performed.
Add | An element of the type of the list is added.
Delete | The current element in the list is deleted.
MovePrev | The next element in the list is made current.
MoveNext | The previous element in the list is made current.
MoveFirst | The first element in the list is made current.
MoveLast | The last element in the list is made current.
Unlink | The current element in the list is removed from the list.
Reload | The current element is reloaded from the persistent store.
ShowAutoForm | An autoform is showed for the current element.
MoveUp | The current element is moved towards the end of the list. This makes sense if the list is an ordered relation.
MoveDown | The current element is moved towards the beginning of the list. This makes sense if the list is an ordered relation.
ExecuteAction | The Action specified in ActionExpression is performed.
File

ListActionExtender.cs


Eco.WPF Namespace

Eco.WPF Namespace
Classes
Collapse All

This is namespace Eco.WPF.

Classes
Name | Description
EcoBinding | EcoBinding enabled xaml markup with ocl Must Reference a EcoServiceProviderReference like this: ItemsSource="{eco3:EcoBinding Expression=Class2.allinstances , EcoProvider={StaticResource ecoServiceProviderRef}}
EcoBindingInstance | This is class Eco.WPF.EcoBindingInstance.
EcoServiceProviderReference | CHECKME : I need someway to get the IEcoServiceProvider to the EcoBinding, this approach introduces a "handle" that needs to be "filled" in its Provider property with code in the form; (this.Resources["ecoServiceProviderRef"] as EcoServiceProviderReference).Provider=ecoSpace;
WPFDequeuer | The WPFDequeuer makes sure the presentation layer (UI layer) is updated with the information in the objects. This is done by hooking into the OnIdle loop where the static method ElementHandle.EnsureAllBindingLists is called. This class cannot be instantiated. Its only property, Active is static.


EcoBinding Class

EcoBinding Class
Inheritance Hierarchy See Also
Collapse All

EcoBinding enabled xaml markup with ocl Must Reference a EcoServiceProviderReference like this: ItemsSource="{eco3:EcoBinding Expression=Class2.allinstances , EcoProvider={StaticResource ecoServiceProviderRef}}

C#
public class EcoBinding : MarkupExtension;
Inheritance Hierarchy
Eco.WPF.EcoBinding
File

EcoBinding.cs

See Also
Inheritance Hierarchy


EcoBinding.EcoBinding Constructor

EcoBinding.EcoBinding Constructor
EcoBinding Class Eco.WPF Namespace See Also
Collapse All

Default and only constructor

C#
public EcoBinding();
See Also
EcoBinding Class
Eco.WPF Namespace


EcoBinding Methods

EcoBinding Methods
Protected Methods Public Methods
Collapse All

The methods of the EcoBinding class are listed here.

Protected Methods
Name | Description
TryGetTargetItems |
Top
Public Methods
Name | Description
ProvideValue | The action is in the EcoDataProvider.BeginQuery


EcoBinding.ProvideValue Method

EcoBinding.ProvideValue Method
EcoBinding Class Eco.WPF Namespace See Also
Collapse All

The action is in the EcoDataProvider.BeginQuery

C#
public override object ProvideValue(
    IServiceProvider provider
);
See Also
EcoBinding Class
Eco.WPF Namespace


EcoBinding.TryGetTargetItems Method

EcoBinding.TryGetTargetItems Method
EcoBinding Class Eco.WPF Namespace See Also
Collapse All
C#
protected virtual bool TryGetTargetItems(
    IServiceProvider provider,
    out DependencyObject target,
    out DependencyProperty dp
);
See Also
EcoBinding Class
Eco.WPF Namespace


EcoBinding Properties

EcoBinding Properties
Public Properties
Collapse All

The properties of the EcoBinding class are listed here.

Public Properties
Name | Description
BindsDirectlyToSource | Gets or sets a value that indicates whether to evaluate the Path relative to the data item or the DataSourceProvider object.
Converter | This is Converter, a member of class EcoBinding.
ConverterCulture | This is ConverterCulture, a member of class EcoBinding.
ConverterParameter | This is ConverterParameter, a member of class EcoBinding.
EcoProvider | Point out the EcoProvider that holds a IEcoServiceProvider in its Provider property
Expression | The Expression that will be evaluated with the EcoProvider and in the context of "OclContext", if "OclContext" is null, the ocl must be non-relative (like Class1.allinstances)
HasCode | This is HasCode, a member of class EcoBinding.
Mode | This is Mode, a member of class EcoBinding.
NotifyOnSourceUpdated | This is NotifyOnSourceUpdated, a member of class EcoBinding.
NotifyOnTargetUpdated | This is NotifyOnTargetUpdated, a member of class EcoBinding.
NotifyOnValidationError | This is NotifyOnValidationError, a member of class EcoBinding.
OclContext | When the context evaluates to a type in your ecoSpace, the ocl may be relative to this
RelativeSource | This is RelativeSource, a member of class EcoBinding.
UpdateSourceExceptionFilter | This is UpdateSourceExceptionFilter, a member of class EcoBinding.
UpdateSourceTrigger | This is UpdateSourceTrigger, a member of class EcoBinding.
ValidatesOnDataErrors | This is ValidatesOnDataErrors, a member of class EcoBinding.
ValidatesOnExceptions | This is ValidatesOnExceptions, a member of class EcoBinding.
ValidationRules | This is ValidationRules, a member of class EcoBinding.


EcoBinding.BindsDirectlyToSource Property

EcoBinding.BindsDirectlyToSource Property
EcoBinding Class Eco.WPF Namespace See Also
Collapse All

Gets or sets a value that indicates whether to evaluate the Path relative to the data item or the DataSourceProvider object.

C#
public bool BindsDirectlyToSource;
See Also
EcoBinding Class
Eco.WPF Namespace


EcoBinding.Converter Property

EcoBinding.Converter Property
EcoBinding Class Eco.WPF Namespace See Also
Collapse All
C#
public IValueConverter Converter;
Remarks

This is Converter, a member of class EcoBinding.

See Also
EcoBinding Class
Eco.WPF Namespace


EcoBinding.ConverterCulture Property

EcoBinding.ConverterCulture Property
EcoBinding Class Eco.WPF Namespace See Also
Collapse All
C#
public CultureInfo ConverterCulture;
Remarks

This is ConverterCulture, a member of class EcoBinding.

See Also
EcoBinding Class
Eco.WPF Namespace


EcoBinding.ConverterParameter Property

EcoBinding.ConverterParameter Property
EcoBinding Class Eco.WPF Namespace See Also
Collapse All
C#
public object ConverterParameter;
Remarks

This is ConverterParameter, a member of class EcoBinding.

See Also
EcoBinding Class
Eco.WPF Namespace


EcoBinding.EcoProvider Property

EcoBinding.EcoProvider Property
EcoBinding Class Eco.WPF Namespace See Also
Collapse All

Point out the EcoProvider that holds a IEcoServiceProvider in its Provider property

C#
public EcoServiceProviderReference EcoProvider;
See Also
EcoBinding Class
Eco.WPF Namespace


EcoBinding.Expression Property

EcoBinding.Expression Property
EcoBinding Class Eco.WPF Namespace See Also
Collapse All

The Expression that will be evaluated with the EcoProvider and in the context of "OclContext", if "OclContext" is null, the ocl must be non-relative (like Class1.allinstances)

C#
public string Expression;
See Also
EcoBinding Class
Eco.WPF Namespace


EcoBinding.HasCode Property

EcoBinding.HasCode Property
EcoBinding Class Eco.WPF Namespace See Also
Collapse All
C#
public bool HasCode;
Remarks

This is HasCode, a member of class EcoBinding.

See Also
EcoBinding Class
Eco.WPF Namespace


EcoBinding.Mode Property

EcoBinding.Mode Property
EcoBinding Class Eco.WPF Namespace See Also
Collapse All
C#
public BindingMode Mode;
Remarks

This is Mode, a member of class EcoBinding.

See Also
EcoBinding Class
Eco.WPF Namespace


EcoBinding.NotifyOnSourceUpdated Property

EcoBinding.NotifyOnSourceUpdated Property
EcoBinding Class Eco.WPF Namespace See Also
Collapse All
C#
public bool NotifyOnSourceUpdated;
Remarks

This is NotifyOnSourceUpdated, a member of class EcoBinding.

See Also
EcoBinding Class
Eco.WPF Namespace


EcoBinding.NotifyOnTargetUpdated Property

EcoBinding.NotifyOnTargetUpdated Property
EcoBinding Class Eco.WPF Namespace See Also
Collapse All
C#
public bool NotifyOnTargetUpdated;
Remarks

This is NotifyOnTargetUpdated, a member of class EcoBinding.

See Also
EcoBinding Class
Eco.WPF Namespace


EcoBinding.NotifyOnValidationError Property

EcoBinding.NotifyOnValidationError Property
EcoBinding Class Eco.WPF Namespace See Also
Collapse All
C#
public bool NotifyOnValidationError;
Remarks

This is NotifyOnValidationError, a member of class EcoBinding.

See Also
EcoBinding Class
Eco.WPF Namespace


EcoBinding.OclContext Property

EcoBinding.OclContext Property
EcoBinding Class Eco.WPF Namespace See Also
Collapse All

When the context evaluates to a type in your ecoSpace, the ocl may be relative to this

C#
public object OclContext;
See Also
EcoBinding Class
Eco.WPF Namespace


EcoBinding.RelativeSource Property

EcoBinding.RelativeSource Property
EcoBinding Class Eco.WPF Namespace See Also
Collapse All
C#
public RelativeSource RelativeSource;
Remarks

This is RelativeSource, a member of class EcoBinding.

See Also
EcoBinding Class
Eco.WPF Namespace


EcoBinding.UpdateSourceExceptionFilter Property

EcoBinding.UpdateSourceExceptionFilter Property
EcoBinding Class Eco.WPF Namespace See Also
Collapse All
C#
public UpdateSourceExceptionFilterCallback UpdateSourceExceptionFilter;
Remarks

This is UpdateSourceExceptionFilter, a member of class EcoBinding.

See Also
EcoBinding Class
Eco.WPF Namespace


EcoBinding.UpdateSourceTrigger Property

EcoBinding.UpdateSourceTrigger Property
EcoBinding Class Eco.WPF Namespace See Also
Collapse All
C#
public UpdateSourceTrigger UpdateSourceTrigger;
Remarks

This is UpdateSourceTrigger, a member of class EcoBinding.

See Also
EcoBinding Class
Eco.WPF Namespace


EcoBinding.ValidatesOnDataErrors Property

EcoBinding.ValidatesOnDataErrors Property
EcoBinding Class Eco.WPF Namespace See Also
Collapse All
C#
public bool ValidatesOnDataErrors;
Remarks

This is ValidatesOnDataErrors, a member of class EcoBinding.

See Also
EcoBinding Class
Eco.WPF Namespace


EcoBinding.ValidatesOnExceptions Property

EcoBinding.ValidatesOnExceptions Property
EcoBinding Class Eco.WPF Namespace See Also
Collapse All
C#
public bool ValidatesOnExceptions;
Remarks

This is ValidatesOnExceptions, a member of class EcoBinding.

See Also
EcoBinding Class
Eco.WPF Namespace


EcoBinding.ValidationRules Property

EcoBinding.ValidationRules Property
EcoBinding Class Eco.WPF Namespace See Also
Collapse All
C#
public Collection<ValidationRule> ValidationRules;
Remarks

This is ValidationRules, a member of class EcoBinding.

See Also
EcoBinding Class
Eco.WPF Namespace


EcoBindingInstance Class

EcoBindingInstance Class
Inheritance Hierarchy See Also
Collapse All
C#
public class EcoBindingInstance : INotifyOnIdle;
Remarks

This is class Eco.WPF.EcoBindingInstance.

Inheritance Hierarchy
Eco.WPF.EcoBindingInstance
File

EcoBinding.cs

See Also
Inheritance Hierarchy


EcoBindingInstance.EcoBindingInstance Constructor

EcoBindingInstance.EcoBindingInstance Constructor
EcoBindingInstance Class Eco.WPF Namespace See Also
Collapse All
C#
public EcoBindingInstance(
    EcoBinding eb,
    IServiceProvider provider,
    DependencyObject targetControl,
    DependencyProperty targetProperty
);
Remarks

This is EcoBindingInstance, a member of class EcoBindingInstance.

See Also
EcoBindingInstance Class
Eco.WPF Namespace


EcoBindingInstance Classes

EcoBindingInstance Classes
Classes
Collapse All

The classes of the EcoBindingInstance class are listed here.

Classes
Name | Description
ValueHolder | nested class to hold target for twowaybind


EcoBindingInstance.ValueHolder Class

EcoBindingInstance.ValueHolder Class
Inheritance Hierarchy See Also
Collapse All
C#
public class ValueHolder : object;
Remarks

nested class to hold target for twowaybind

Inheritance Hierarchy
Eco.WPF.EcoBindingInstance.ValueHolder
File

EcoBinding.cs

See Also
Inheritance Hierarchy


ValueHolder Properties

ValueHolder Properties
Public Properties
Collapse All

The properties of the ValueHolder class are listed here.

Public Properties
Name | Description
Value | This is Value, a member of class ValueHolder.


EcoBindingInstance.ValueHolder.Value Property

EcoBindingInstance.ValueHolder.Value Property
EcoBindingInstance.ValueHolder Class Eco.WPF Namespace See Also
Collapse All
C#
public object Value;
Remarks

This is Value, a member of class ValueHolder.

See Also
EcoBindingInstance.ValueHolder Class
Eco.WPF Namespace


EcoBindingInstance Methods

EcoBindingInstance Methods
Public Methods
Collapse All

The methods of the EcoBindingInstance class are listed here.

Public Methods
Name | Description
NotifyOnIdle | This is NotifyOnIdle, a member of class EcoBindingInstance.


EcoBindingInstance.NotifyOnIdle Method

EcoBindingInstance.NotifyOnIdle Method
EcoBindingInstance Class Eco.WPF Namespace See Also
Collapse All
C#
public void NotifyOnIdle();
Remarks

This is NotifyOnIdle, a member of class EcoBindingInstance.

See Also
EcoBindingInstance Class
Eco.WPF Namespace


EcoServiceProviderReference Class

EcoServiceProviderReference Class
Inheritance Hierarchy See Also
Collapse All

CHECKME : I need someway to get the IEcoServiceProvider to the EcoBinding, this approach introduces a "handle" that needs to be "filled" in its Provider property with code in the form; (this.Resources["ecoServiceProviderRef"] as EcoServiceProviderReference).Provider=ecoSpace;

C#
public class EcoServiceProviderReference : INotifyPropertyChanged;
Inheritance Hierarchy
Eco.WPF.EcoServiceProviderReference
File

EcoBinding.cs

See Also
Inheritance Hierarchy


EcoServiceProviderReference.EcoServiceProviderReference Constructor

EcoServiceProviderReference.EcoServiceProviderReference Constructor
EcoServiceProviderReference Class Eco.WPF Namespace See Also
Collapse All
C#
public EcoServiceProviderReference();
Remarks

This is EcoServiceProviderReference, a member of class EcoServiceProviderReference.

See Also
EcoServiceProviderReference Class
Eco.WPF Namespace


EcoServiceProviderReference Properties

EcoServiceProviderReference Properties
Public Properties
Collapse All

The properties of the EcoServiceProviderReference class are listed here.

Public Properties
Name | Description
Provider | This is Provider, a member of class EcoServiceProviderReference.


EcoServiceProviderReference.Provider Property

EcoServiceProviderReference.Provider Property
EcoServiceProviderReference Class Eco.WPF Namespace See Also
Collapse All
C#
public IEcoServiceProvider Provider;
Remarks

This is Provider, a member of class EcoServiceProviderReference.

See Also
EcoServiceProviderReference Class
Eco.WPF Namespace


EcoServiceProviderReference Events

EcoServiceProviderReference Events
Public Events
Collapse All

The events of the EcoServiceProviderReference class are listed here.

Public Events
Name | Description
PropertyChanged | This is PropertyChanged, a member of class EcoServiceProviderReference.


EcoServiceProviderReference.PropertyChanged Event

EcoServiceProviderReference.PropertyChanged Event
EcoServiceProviderReference Class Eco.WPF Namespace See Also
Collapse All
C#
public event PropertyChangedEventHandler PropertyChanged;
Remarks

This is PropertyChanged, a member of class EcoServiceProviderReference.

See Also
EcoServiceProviderReference Class
Eco.WPF Namespace


WPFDequeuer Class

WPFDequeuer Class
Inheritance Hierarchy See Also
Collapse All

The WPFDequeuer makes sure the presentation layer (UI layer) is updated with the information in the objects. This is done by hooking into the OnIdle loop where the static method ElementHandle.EnsureAllBindingLists is called. This class cannot be instantiated. Its only property, Active is static.

C#
public class WPFDequeuer;
Inheritance Hierarchy
Eco.WPF.WPFDequeuer
File

WPFDequeuer.cs

See Also
Inheritance Hierarchy


WPFDequeuer Properties

WPFDequeuer Properties
Public Properties
Collapse All

The properties of the WPFDequeuer class are listed here.

Public Properties
Name | Description
Active | Toggles if the presentation is updating or not. Setting the value of the property to the value it currently holds does nothing.


WPFDequeuer.Active Property

WPFDequeuer.Active Property
WPFDequeuer Class Eco.WPF Namespace See Also
Collapse All

Toggles if the presentation is updating or not. Setting the value of the property to the value it currently holds does nothing.

C#
public static bool Active;
See Also
WPFDequeuer Class
Eco.WPF Namespace


WPFDequeuer Delegates

WPFDequeuer Delegates
Public Delegates Public Delegates See Also
Collapse All

The delegates of the WPFDequeuer class are listed here.

Public Delegates
Name | Description
EmptyAction | This is nested type Eco.WPF.WPFDequeuer.EmptyAction.
Top
See Also
Public Delegates


WPFDequeuer.EmptyAction Delegate

WPFDequeuer.EmptyAction Delegate
WPFDequeuer Class Eco.WPF Namespace See Also
Collapse All
C#
public delegate void EmptyAction();
Remarks

This is nested type Eco.WPF.WPFDequeuer.EmptyAction.

See Also
WPFDequeuer Class
Eco.WPF Namespace


System.Collections.Generic Namespace

System.Collections.Generic Namespace
Classes
Collapse All

This is namespace System.Collections.Generic.

Classes
Name | Description
ECO_IListOfStringExtender | this is needed for backwards compatibility for the ReservedWords in SqlDatabaseConfig (used to be a StringCollection)


ECO_IListOfStringExtender Class

ECO_IListOfStringExtender Class
Inheritance Hierarchy See Also
Collapse All
C#
public static class ECO_IListOfStringExtender;
Remarks

this is needed for backwards compatibility for the ReservedWords in SqlDatabaseConfig (used to be a StringCollection)

Inheritance Hierarchy
System.Collections.Generic.ECO_IListOfStringExtender
File

EcoExtenders.cs

See Also
Inheritance Hierarchy


ECO_IListOfStringExtender Methods

ECO_IListOfStringExtender Methods
Public Methods
Collapse All

The methods of the ECO_IListOfStringExtender class are listed here.

Public Methods
Name | Description
AddRange | Adds a list of strings to another list of strings.


ECO_IListOfStringExtender.AddRange Method

ECO_IListOfStringExtender.AddRange Method
ECO_IListOfStringExtender Class System.Collections.Generic Namespace See Also
Collapse All

Adds a list of strings to another list of strings.

C#
public static void AddRange(
    this IList<string> list,
    IList<string> range
);
See Also
ECO_IListOfStringExtender Class
System.Collections.Generic Namespace


EcoQuery Delegates Public Delegates

EcoQuery Delegates Public Delegates
Public Delegates
Name | Description
ErrorHandler | This is nested type Eco.Linq.EcoQuery.ErrorHandler.


DatablockConverter Delegates Public Delegates

DatablockConverter Delegates Public Delegates
Public Delegates
Name | Description
IdToStringHandler | This is nested type Eco.Persistence.DatablockConverter.IdToStringHandler.


WPFDequeuer Delegates Public Delegates

WPFDequeuer Delegates Public Delegates
Public Delegates
Name | Description
EmptyAction | This is nested type Eco.WPF.WPFDequeuer.EmptyAction.


Inheritance Hierarchy

Inheritance Hierarchy
Inheritance Hierarchy
BoldSqlNodeMaker.TBoldSqlNodeMaker


Inheritance Hierarchy

Inheritance Hierarchy
Inheritance Hierarchy
BoldSqlNodes.TBoldSqlNode
    BoldSqlNodes.TBoldSqlLiteral
        BoldSqlNodes.TBoldSqlDateLiteral


Inheritance Hierarchy

Inheritance Hierarchy
Inheritance Hierarchy
BoldSqlNodes.TBoldSqlNode
    BoldSqlNodes.TBoldSqlLiteral
        BoldSqlNodes.TBoldSqlEnumLiteral


Inheritance Hierarchy

Inheritance Hierarchy
Inheritance Hierarchy
BoldSqlNodes.TBoldSqlNode
    BoldSqlNodes.TBoldSqlLiteral
        BoldSqlNodes.TBoldSqlFloatLiteral


Inheritance Hierarchy

Inheritance Hierarchy
Inheritance Hierarchy
BoldSqlNodes.TBoldSqlNode
    BoldSqlNodes.TBoldSqlLiteral
        BoldSqlNodes.TBoldSqlIntLiteral


Inheritance Hierarchy

Inheritance Hierarchy
Inheritance Hierarchy
BoldSqlNodes.TBoldSqlNode
    BoldSqlNodes.TBoldSqlOperation
        BoldSqlNodes.TBoldSqlIteration


Inheritance Hierarchy

Inheritance Hierarchy
Inheritance Hierarchy
BoldSqlNodes.TBoldSqlNode
    BoldSqlNodes.TBoldSqlListCoercion


Inheritance Hierarchy

Inheritance Hierarchy
Inheritance Hierarchy
BoldSqlNodes.TBoldSqlNode
    BoldSqlNodes.TBoldSqlLiteral
        BoldSqlNodes.TBoldSqlDateLiteral
        BoldSqlNodes.TBoldSqlEnumLiteral
        BoldSqlNodes.TBoldSqlFloatLiteral
        BoldSqlNodes.TBoldSqlIntLiteral
        BoldSqlNodes.TBoldSqlStrLiteral
        BoldSqlNodes.TBoldSqlTimeLiteral


Inheritance Hierarchy

Inheritance Hierarchy
Inheritance Hierarchy
BoldSqlNodes.TBoldSqlNode
    BoldSqlNodes.TBoldSqlMember


Inheritance Hierarchy

Inheritance Hierarchy
Inheritance Hierarchy
BoldSqlNodes.TBoldSqlNode
    BoldSqlNodes.TBoldSqlListCoercion
    BoldSqlNodes.TBoldSqlLiteral
    BoldSqlNodes.TBoldSqlMember
    BoldSqlNodes.TBoldSqlOperation
    BoldSqlNodes.TBoldSqlTypeNode
    BoldSqlNodes.TBoldSqlVariableBinding
    BoldSqlNodes.TBoldSqlVariableReference


Inheritance Hierarchy

Inheritance Hierarchy
Inheritance Hierarchy
BoldSqlNodes.TBoldSqlNodeList


Inheritance Hierarchy

Inheritance Hierarchy
Inheritance Hierarchy
BoldSqlNodes.TBoldSqlNodeVisitor
    BoldSqlNodesResolver.TBoldSqlNodeResolver
    BoldSqlQueryGenerator.TBoldSqlQueryGenerator


Inheritance Hierarchy

Inheritance Hierarchy
Inheritance Hierarchy
BoldSqlNodes.TBoldSqlNode
    BoldSqlNodes.TBoldSqlLiteral
        BoldSqlNodes.TBoldSqlStrLiteral


Inheritance Hierarchy

Inheritance Hierarchy
Inheritance Hierarchy
BoldSqlNodes.TBoldSqlSymbol
    BoldSqlSymbols.TBSS_Symbol


Inheritance Hierarchy

Inheritance Hierarchy
Inheritance Hierarchy
BoldSqlNodes.TBoldSqlNode
    BoldSqlNodes.TBoldSqlLiteral
        BoldSqlNodes.TBoldSqlTimeLiteral


Inheritance Hierarchy

Inheritance Hierarchy
Inheritance Hierarchy
BoldSqlNodes.TBoldSqlNode
    BoldSqlNodes.TBoldSqlTypeNode


Inheritance Hierarchy

Inheritance Hierarchy
Inheritance Hierarchy
BoldSqlNodes.TBoldSqlNode
    BoldSqlNodes.TBoldSqlVariableBinding


Inheritance Hierarchy

Inheritance Hierarchy
Inheritance Hierarchy
BoldSqlNodes.TBoldSqlNode
    BoldSqlNodes.TBoldSqlVariableReference


Inheritance Hierarchy

Inheritance Hierarchy
Inheritance Hierarchy
BoldSQLQuery.TBoldSqlWCF
    BoldSqlNodes.TBoldSQLWCFVariable


Inheritance Hierarchy

Inheritance Hierarchy
Inheritance Hierarchy
BoldSqlNodes.TBoldSqlNodeVisitor
    BoldSqlNodesResolver.TBoldSqlNodeResolver


Inheritance Hierarchy

Inheritance Hierarchy
Inheritance Hierarchy
BoldSQLQuery.TBoldSQLAliasReference


Inheritance Hierarchy

Inheritance Hierarchy
Inheritance Hierarchy
BoldSQLQuery.TBoldSqlAliasReferenceList


Inheritance Hierarchy

Inheritance Hierarchy
Inheritance Hierarchy
BoldSQLQuery.TBoldSQLColumnReference


Inheritance Hierarchy

Inheritance Hierarchy
Inheritance Hierarchy
BoldSQLQuery.TBoldSQLJoin


Inheritance Hierarchy

Inheritance Hierarchy
Inheritance Hierarchy
BoldSQLQuery.TBoldSQLNameSpace


Inheritance Hierarchy

Inheritance Hierarchy
Inheritance Hierarchy
BoldSQLQuery.TBoldSqlOrderByColumn


Inheritance Hierarchy

Inheritance Hierarchy
Inheritance Hierarchy
BoldSQLQuery.TBoldSQLQuery


Inheritance Hierarchy

Inheritance Hierarchy
Inheritance Hierarchy
BoldSQLQuery.TBoldSqlQueryParameter


Inheritance Hierarchy

Inheritance Hierarchy
Inheritance Hierarchy
BoldSQLQuery.TBoldSqlQueryParameterList


Inheritance Hierarchy

Inheritance Hierarchy
Inheritance Hierarchy
BoldSQLQuery.TBoldSqlWCF
    BoldSqlNodes.TBoldSQLWCFVariable
    BoldSQLQuery.TBoldSQLWCFBinary
    BoldSQLQuery.TBoldSQLWCFColumnRef
    BoldSQLQuery.TBoldSQLWCFDate
    BoldSQLQuery.TBoldSQLWCFFloat
    BoldSQLQuery.TBoldSQLWCFGenericExpression
    BoldSQLQuery.TBoldSQLWCFInteger
    BoldSQLQuery.TBoldSQLWCFJoin
    BoldSQLQuery.TBoldSQLWCFLiteralString
    BoldSQLQuery.TBoldSQLWCFString
    BoldSQLQuery.TBoldSQLWCFTime
    BoldSQLQuery.TBoldSQLWCFUnary
    BoldSQLQuery.TBoldSQLWCFWithQuery


Inheritance Hierarchy

Inheritance Hierarchy
Inheritance Hierarchy
BoldSQLQuery.TBoldSqlWCF
    BoldSQLQuery.TBoldSQLWCFBinary
        BoldSQLQuery.TBoldSQLWCFBinaryInfix
        BoldSQLQuery.TBoldSQLWCFBinaryPrefix


Inheritance Hierarchy

Inheritance Hierarchy
Inheritance Hierarchy
BoldSQLQuery.TBoldSqlWCF
    BoldSQLQuery.TBoldSQLWCFBinary
        BoldSQLQuery.TBoldSQLWCFBinaryInfix


Inheritance Hierarchy

Inheritance Hierarchy
Inheritance Hierarchy
BoldSQLQuery.TBoldSqlWCF
    BoldSQLQuery.TBoldSQLWCFBinary
        BoldSQLQuery.TBoldSQLWCFBinaryPrefix


Inheritance Hierarchy

Inheritance Hierarchy
Inheritance Hierarchy
BoldSQLQuery.TBoldSqlWCF
    BoldSQLQuery.TBoldSQLWCFColumnRef


Inheritance Hierarchy

Inheritance Hierarchy
Inheritance Hierarchy
BoldSQLQuery.TBoldSqlWCF
    BoldSQLQuery.TBoldSQLWCFDate


Inheritance Hierarchy

Inheritance Hierarchy
Inheritance Hierarchy
BoldSQLQuery.TBoldSqlWCF
    BoldSQLQuery.TBoldSQLWCFWithQuery
        BoldSQLQuery.TBoldSQLWCFExists


Inheritance Hierarchy

Inheritance Hierarchy
Inheritance Hierarchy
BoldSQLQuery.TBoldSqlWCF
    BoldSQLQuery.TBoldSQLWCFFloat


Inheritance Hierarchy

Inheritance Hierarchy
Inheritance Hierarchy
BoldSQLQuery.TBoldSqlWCF
    BoldSQLQuery.TBoldSQLWCFGenericExpression


Inheritance Hierarchy

Inheritance Hierarchy
Inheritance Hierarchy
BoldSQLQuery.TBoldSqlWCF
    BoldSQLQuery.TBoldSQLWCFWithQuery
        BoldSQLQuery.TBoldSQLWCFGroupFunction
            BoldSQLQuery.TBoldSQLWCFGroupFunctionWithColumn
            BoldSQLQuery.TBoldSQLWCFSize


Inheritance Hierarchy

Inheritance Hierarchy
Inheritance Hierarchy
BoldSQLQuery.TBoldSqlWCF
    BoldSQLQuery.TBoldSQLWCFWithQuery
        BoldSQLQuery.TBoldSQLWCFGroupFunction
            BoldSQLQuery.TBoldSQLWCFGroupFunctionWithColumn


Inheritance Hierarchy

Inheritance Hierarchy
Inheritance Hierarchy
BoldSQLQuery.TBoldSqlWCF
    BoldSQLQuery.TBoldSQLWCFWithQuery
        BoldSQLQuery.TBoldSQLWCFInQuery


Inheritance Hierarchy

Inheritance Hierarchy
Inheritance Hierarchy
BoldSQLQuery.TBoldSqlWCF
    BoldSQLQuery.TBoldSQLWCFInteger


Inheritance Hierarchy

Inheritance Hierarchy
Inheritance Hierarchy
BoldSQLQuery.TBoldSqlWCF
    BoldSQLQuery.TBoldSQLWCFJoin


Inheritance Hierarchy

Inheritance Hierarchy
Inheritance Hierarchy
BoldSQLQuery.TBoldSqlWCF
    BoldSQLQuery.TBoldSQLWCFLiteralString


Inheritance Hierarchy

Inheritance Hierarchy
Inheritance Hierarchy
BoldSQLQuery.TBoldSqlWCF
    BoldSQLQuery.TBoldSQLWCFWithQuery
        BoldSQLQuery.TBoldSQLWCFGroupFunction
            BoldSQLQuery.TBoldSQLWCFSize


Inheritance Hierarchy

Inheritance Hierarchy
Inheritance Hierarchy
BoldSQLQuery.TBoldSqlWCF
    BoldSQLQuery.TBoldSQLWCFString


Inheritance Hierarchy

Inheritance Hierarchy
Inheritance Hierarchy
BoldSQLQuery.TBoldSqlWCF
    BoldSQLQuery.TBoldSQLWCFTime


Inheritance Hierarchy

Inheritance Hierarchy
Inheritance Hierarchy
BoldSQLQuery.TBoldSqlWCF
    BoldSQLQuery.TBoldSQLWCFUnary
        BoldSQLQuery.TBoldSQLWCFUnaryPostfix
        BoldSQLQuery.TBoldSQLWCFUnaryPrefix


Inheritance Hierarchy

Inheritance Hierarchy
Inheritance Hierarchy
BoldSQLQuery.TBoldSqlWCF
    BoldSQLQuery.TBoldSQLWCFUnary
        BoldSQLQuery.TBoldSQLWCFUnaryPostfix


Inheritance Hierarchy

Inheritance Hierarchy
Inheritance Hierarchy
BoldSQLQuery.TBoldSqlWCF
    BoldSQLQuery.TBoldSQLWCFUnary
        BoldSQLQuery.TBoldSQLWCFUnaryPrefix


Inheritance Hierarchy

Inheritance Hierarchy
Inheritance Hierarchy
BoldSQLQuery.TBoldSqlWCF
    BoldSQLQuery.TBoldSQLWCFWithQuery
        BoldSQLQuery.TBoldSQLWCFExists
        BoldSQLQuery.TBoldSQLWCFGroupFunction
        BoldSQLQuery.TBoldSQLWCFInQuery


Inheritance Hierarchy

Inheritance Hierarchy
Inheritance Hierarchy
BoldSqlNodes.TBoldSqlNodeVisitor
    BoldSqlQueryGenerator.TBoldSqlQueryGenerator


Inheritance Hierarchy

Inheritance Hierarchy
Inheritance Hierarchy
BoldSqlSymbols.TBoldSqlSymbols


Inheritance Hierarchy

Inheritance Hierarchy
Inheritance Hierarchy
BoldSqlNodes.TBoldSqlSymbol
    BoldSqlSymbols.TBSS_Symbol
        BoldSqlSymbols.TBSS_UnarySymbol
            BoldSqlSymbols.TBSS_Abs


Inheritance Hierarchy

Inheritance Hierarchy
Inheritance Hierarchy
BoldSqlNodes.TBoldSqlSymbol
    BoldSqlSymbols.TBSS_Symbol
        BoldSqlSymbols.TBSS_Iteration
            BoldSqlSymbols.TBSS_AbstractOrder
                BoldSqlSymbols.TBSS_orderby
                BoldSqlSymbols.TBSS_orderDescending
                BoldSqlSymbols.TBSS_orderGeneric


Inheritance Hierarchy

Inheritance Hierarchy
Inheritance Hierarchy
BoldSqlNodes.TBoldSqlSymbol
    BoldSqlSymbols.TBSS_Symbol
        BoldSqlSymbols.TBSS_BinarySymbol
            BoldSqlSymbols.TBSS_Add


Inheritance Hierarchy

Inheritance Hierarchy
Inheritance Hierarchy
BoldSqlNodes.TBoldSqlSymbol
    BoldSqlSymbols.TBSS_Symbol
        BoldSqlSymbols.TBSS_AllInstances


Inheritance Hierarchy

Inheritance Hierarchy
Inheritance Hierarchy
BoldSqlNodes.TBoldSqlSymbol
    BoldSqlSymbols.TBSS_Symbol
        BoldSqlSymbols.TBSS_BinarySymbol
            BoldSqlSymbols.TBSS_and


Inheritance Hierarchy

Inheritance Hierarchy
Inheritance Hierarchy
BoldSqlNodes.TBoldSqlSymbol
    BoldSqlSymbols.TBSS_Symbol
        BoldSqlSymbols.TBSS_GroupFunctions
            BoldSqlSymbols.TBSS_Average


Inheritance Hierarchy

Inheritance Hierarchy
Inheritance Hierarchy
BoldSqlNodes.TBoldSqlSymbol
    BoldSqlSymbols.TBSS_Symbol
        BoldSqlSymbols.TBSS_BinarySymbol
            BoldSqlSymbols.TBSS_BinaryBooleanSymbol
                BoldSqlSymbols.TBSS_Equal
                BoldSqlSymbols.TBSS_Greater
                BoldSqlSymbols.TBSS_GreaterEQ
                BoldSqlSymbols.TBSS_Less
                BoldSqlSymbols.TBSS_LessEQ
                BoldSqlSymbols.TBSS_NotEqual


Inheritance Hierarchy

Inheritance Hierarchy
Inheritance Hierarchy
BoldSqlNodes.TBoldSqlSymbol
    BoldSqlSymbols.TBSS_Symbol
        BoldSqlSymbols.TBSS_BinarySymbol
            BoldSqlSymbols.TBSS_Add
            BoldSqlSymbols.TBSS_and
            BoldSqlSymbols.TBSS_BinaryBooleanSymbol
            BoldSqlSymbols.TBSS_Divide
            BoldSqlSymbols.TBSS_implies
            BoldSqlSymbols.TBSS_ModifiedSinceTimeStamp
            BoldSqlSymbols.TBSS_Multiply
            BoldSqlSymbols.TBSS_or
            BoldSqlSymbols.TBSS_SQLLike
            BoldSqlSymbols.TBSS_SqlLikeUsersBase
            BoldSqlSymbols.TBSS_Subtract
            BoldSqlSymbols.TBSS_xor


Inheritance Hierarchy

Inheritance Hierarchy
Inheritance Hierarchy
BoldSqlNodes.TBoldSqlSymbol
    BoldSqlSymbols.TBSS_Symbol
        BoldSqlSymbols.TBSS_BinarySymbol
            BoldSqlSymbols.TBSS_SqlLikeUsersBase
                BoldSqlSymbols.TBSS_Contains


Inheritance Hierarchy

Inheritance Hierarchy
Inheritance Hierarchy
BoldSqlNodes.TBoldSqlSymbol
    BoldSqlSymbols.TBSS_Symbol
        BoldSqlSymbols.TBSS_ListOperations
            BoldSqlSymbols.TBSS_Difference


Inheritance Hierarchy

Inheritance Hierarchy
Inheritance Hierarchy
BoldSqlNodes.TBoldSqlSymbol
    BoldSqlSymbols.TBSS_Symbol
        BoldSqlSymbols.TBSS_PrefixBinarySymbol
            BoldSqlSymbols.TBSS_Div


Inheritance Hierarchy

Inheritance Hierarchy
Inheritance Hierarchy
BoldSqlNodes.TBoldSqlSymbol
    BoldSqlSymbols.TBSS_Symbol
        BoldSqlSymbols.TBSS_BinarySymbol
            BoldSqlSymbols.TBSS_Divide


Inheritance Hierarchy

Inheritance Hierarchy
Inheritance Hierarchy
BoldSqlNodes.TBoldSqlSymbol
    BoldSqlSymbols.TBSS_Symbol
        BoldSqlSymbols.TBSS_BinarySymbol
            BoldSqlSymbols.TBSS_BinaryBooleanSymbol
                BoldSqlSymbols.TBSS_Equal


Inheritance Hierarchy

Inheritance Hierarchy
Inheritance Hierarchy
BoldSqlNodes.TBoldSqlSymbol
    BoldSqlSymbols.TBSS_Symbol
        BoldSqlSymbols.TBSS_Iteration
            BoldSqlSymbols.TBSS_Exists


Inheritance Hierarchy

Inheritance Hierarchy
Inheritance Hierarchy
BoldSqlNodes.TBoldSqlSymbol
    BoldSqlSymbols.TBSS_Symbol
        BoldSqlSymbols.TBSS_UnarySymbol
            BoldSqlSymbols.TBSS_Floor


Inheritance Hierarchy

Inheritance Hierarchy
Inheritance Hierarchy
BoldSqlNodes.TBoldSqlSymbol
    BoldSqlSymbols.TBSS_Symbol
        BoldSqlSymbols.TBSS_Iteration
            BoldSqlSymbols.TBSS_ForAll


Inheritance Hierarchy

Inheritance Hierarchy
Inheritance Hierarchy
BoldSqlNodes.TBoldSqlSymbol
    BoldSqlSymbols.TBSS_Symbol
        BoldSqlSymbols.TBSS_BinarySymbol
            BoldSqlSymbols.TBSS_BinaryBooleanSymbol
                BoldSqlSymbols.TBSS_Greater


Inheritance Hierarchy

Inheritance Hierarchy
Inheritance Hierarchy
BoldSqlNodes.TBoldSqlSymbol
    BoldSqlSymbols.TBSS_Symbol
        BoldSqlSymbols.TBSS_BinarySymbol
            BoldSqlSymbols.TBSS_BinaryBooleanSymbol
                BoldSqlSymbols.TBSS_GreaterEQ


Inheritance Hierarchy

Inheritance Hierarchy
Inheritance Hierarchy
BoldSqlNodes.TBoldSqlSymbol
    BoldSqlSymbols.TBSS_Symbol
        BoldSqlSymbols.TBSS_GroupFunctions
            BoldSqlSymbols.TBSS_Average
            BoldSqlSymbols.TBSS_Maxvalue
            BoldSqlSymbols.TBSS_MinValue
            BoldSqlSymbols.TBSS_Sum


Inheritance Hierarchy

Inheritance Hierarchy
Inheritance Hierarchy
BoldSqlNodes.TBoldSqlSymbol
    BoldSqlSymbols.TBSS_Symbol
        BoldSqlSymbols.TBSS_BinarySymbol
            BoldSqlSymbols.TBSS_implies


Inheritance Hierarchy

Inheritance Hierarchy
Inheritance Hierarchy
BoldSqlNodes.TBoldSqlSymbol
    BoldSqlSymbols.TBSS_Symbol
        BoldSqlSymbols.TBSS_includes


Inheritance Hierarchy

Inheritance Hierarchy
Inheritance Hierarchy
BoldSqlNodes.TBoldSqlSymbol
    BoldSqlSymbols.TBSS_Symbol
        BoldSqlSymbols.TBSS_ListOperations
            BoldSqlSymbols.TBSS_Intersection


Inheritance Hierarchy

Inheritance Hierarchy
Inheritance Hierarchy
BoldSqlNodes.TBoldSqlSymbol
    BoldSqlSymbols.TBSS_Symbol
        BoldSqlSymbols.TBSS_isEmpty


Inheritance Hierarchy

Inheritance Hierarchy
Inheritance Hierarchy
BoldSqlNodes.TBoldSqlSymbol
    BoldSqlSymbols.TBSS_Symbol
        BoldSqlSymbols.TBSS_isNull


Inheritance Hierarchy

Inheritance Hierarchy
Inheritance Hierarchy
BoldSqlNodes.TBoldSqlSymbol
    BoldSqlSymbols.TBSS_Symbol
        BoldSqlSymbols.TBSS_Iteration
            BoldSqlSymbols.TBSS_AbstractOrder
            BoldSqlSymbols.TBSS_Exists
            BoldSqlSymbols.TBSS_ForAll
            BoldSqlSymbols.TBSS_reject
            BoldSqlSymbols.TBSS_Select


Inheritance Hierarchy

Inheritance Hierarchy
Inheritance Hierarchy
BoldSqlNodes.TBoldSqlSymbol
    BoldSqlSymbols.TBSS_Symbol
        BoldSqlSymbols.TBSS_UnarySymbol
            BoldSqlSymbols.TBSS_Length


Inheritance Hierarchy

Inheritance Hierarchy
Inheritance Hierarchy
BoldSqlNodes.TBoldSqlSymbol
    BoldSqlSymbols.TBSS_Symbol
        BoldSqlSymbols.TBSS_BinarySymbol
            BoldSqlSymbols.TBSS_BinaryBooleanSymbol
                BoldSqlSymbols.TBSS_Less


Inheritance Hierarchy

Inheritance Hierarchy
Inheritance Hierarchy
BoldSqlNodes.TBoldSqlSymbol
    BoldSqlSymbols.TBSS_Symbol
        BoldSqlSymbols.TBSS_BinarySymbol
            BoldSqlSymbols.TBSS_BinaryBooleanSymbol
                BoldSqlSymbols.TBSS_LessEQ


Inheritance Hierarchy

Inheritance Hierarchy
Inheritance Hierarchy
BoldSqlNodes.TBoldSqlSymbol
    BoldSqlSymbols.TBSS_Symbol
        BoldSqlSymbols.TBSS_ListOperations
            BoldSqlSymbols.TBSS_Difference
            BoldSqlSymbols.TBSS_Intersection
            BoldSqlSymbols.TBSS_SymmetricDifference
            BoldSqlSymbols.TBSS_union


Inheritance Hierarchy

Inheritance Hierarchy
Inheritance Hierarchy
BoldSqlNodes.TBoldSqlSymbol
    BoldSqlSymbols.TBSS_Symbol
        BoldSqlSymbols.TBSS_GroupFunctions
            BoldSqlSymbols.TBSS_Maxvalue


Inheritance Hierarchy

Inheritance Hierarchy
Inheritance Hierarchy
BoldSqlNodes.TBoldSqlSymbol
    BoldSqlSymbols.TBSS_Symbol
        BoldSqlSymbols.TBSS_GroupFunctions
            BoldSqlSymbols.TBSS_MinValue


Inheritance Hierarchy

Inheritance Hierarchy
Inheritance Hierarchy
BoldSqlNodes.TBoldSqlSymbol
    BoldSqlSymbols.TBSS_Symbol
        BoldSqlSymbols.TBSS_PrefixBinarySymbol
            BoldSqlSymbols.TBSS_Mod


Inheritance Hierarchy

Inheritance Hierarchy
Inheritance Hierarchy
BoldSqlNodes.TBoldSqlSymbol
    BoldSqlSymbols.TBSS_Symbol
        BoldSqlSymbols.TBSS_BinarySymbol
            BoldSqlSymbols.TBSS_ModifiedSinceTimeStamp


Inheritance Hierarchy

Inheritance Hierarchy
Inheritance Hierarchy
BoldSqlNodes.TBoldSqlSymbol
    BoldSqlSymbols.TBSS_Symbol
        BoldSqlSymbols.TBSS_BinarySymbol
            BoldSqlSymbols.TBSS_Multiply


Inheritance Hierarchy

Inheritance Hierarchy
Inheritance Hierarchy
BoldSqlNodes.TBoldSqlSymbol
    BoldSqlSymbols.TBSS_Symbol
        BoldSqlSymbols.TBSS_UnarySymbol
            BoldSqlSymbols.TBSS_not


Inheritance Hierarchy

Inheritance Hierarchy
Inheritance Hierarchy
BoldSqlNodes.TBoldSqlSymbol
    BoldSqlSymbols.TBSS_Symbol
        BoldSqlSymbols.TBSS_NotEmpty


Inheritance Hierarchy

Inheritance Hierarchy
Inheritance Hierarchy
BoldSqlNodes.TBoldSqlSymbol
    BoldSqlSymbols.TBSS_Symbol
        BoldSqlSymbols.TBSS_BinarySymbol
            BoldSqlSymbols.TBSS_BinaryBooleanSymbol
                BoldSqlSymbols.TBSS_NotEqual


Inheritance Hierarchy

Inheritance Hierarchy
Inheritance Hierarchy
BoldSqlNodes.TBoldSqlSymbol
    BoldSqlSymbols.TBSS_Symbol
        BoldSqlSymbols.TBSS_OclAsType


Inheritance Hierarchy

Inheritance Hierarchy
Inheritance Hierarchy
BoldSqlNodes.TBoldSqlSymbol
    BoldSqlSymbols.TBSS_Symbol
        BoldSqlSymbols.TBSS_BinarySymbol
            BoldSqlSymbols.TBSS_or


Inheritance Hierarchy

Inheritance Hierarchy
Inheritance Hierarchy
BoldSqlNodes.TBoldSqlSymbol
    BoldSqlSymbols.TBSS_Symbol
        BoldSqlSymbols.TBSS_Iteration
            BoldSqlSymbols.TBSS_AbstractOrder
                BoldSqlSymbols.TBSS_orderby


Inheritance Hierarchy

Inheritance Hierarchy
Inheritance Hierarchy
BoldSqlNodes.TBoldSqlSymbol
    BoldSqlSymbols.TBSS_Symbol
        BoldSqlSymbols.TBSS_Iteration
            BoldSqlSymbols.TBSS_AbstractOrder
                BoldSqlSymbols.TBSS_orderDescending


Inheritance Hierarchy

Inheritance Hierarchy
Inheritance Hierarchy
BoldSqlNodes.TBoldSqlSymbol
    BoldSqlSymbols.TBSS_Symbol
        BoldSqlSymbols.TBSS_Iteration
            BoldSqlSymbols.TBSS_AbstractOrder
                BoldSqlSymbols.TBSS_orderGeneric


Inheritance Hierarchy

Inheritance Hierarchy
Inheritance Hierarchy
BoldSqlNodes.TBoldSqlSymbol
    BoldSqlSymbols.TBSS_Symbol
        BoldSqlSymbols.TBSS_PrefixBinarySymbol
            BoldSqlSymbols.TBSS_Div
            BoldSqlSymbols.TBSS_Mod


Inheritance Hierarchy

Inheritance Hierarchy
Inheritance Hierarchy
BoldSqlNodes.TBoldSqlSymbol
    BoldSqlSymbols.TBSS_Symbol
        BoldSqlSymbols.TBSS_Iteration
            BoldSqlSymbols.TBSS_reject


Inheritance Hierarchy

Inheritance Hierarchy
Inheritance Hierarchy
BoldSqlNodes.TBoldSqlSymbol
    BoldSqlSymbols.TBSS_Symbol
        BoldSqlSymbols.TBSS_UnarySymbol
            BoldSqlSymbols.TBSS_Round


Inheritance Hierarchy

Inheritance Hierarchy
Inheritance Hierarchy
BoldSqlNodes.TBoldSqlSymbol
    BoldSqlSymbols.TBSS_Symbol
        BoldSqlSymbols.TBSS_Iteration
            BoldSqlSymbols.TBSS_Select


Inheritance Hierarchy

Inheritance Hierarchy
Inheritance Hierarchy
BoldSqlNodes.TBoldSqlSymbol
    BoldSqlSymbols.TBSS_Symbol
        BoldSqlSymbols.TBSS_Size


Inheritance Hierarchy

Inheritance Hierarchy
Inheritance Hierarchy
BoldSqlNodes.TBoldSqlSymbol
    BoldSqlSymbols.TBSS_Symbol
        BoldSqlSymbols.TBSS_BinarySymbol
            BoldSqlSymbols.TBSS_SQLLike
                BoldSqlSymbols.TBSS_SQLLikeCaseInsensitive


Inheritance Hierarchy

Inheritance Hierarchy
Inheritance Hierarchy
BoldSqlNodes.TBoldSqlSymbol
    BoldSqlSymbols.TBSS_Symbol
        BoldSqlSymbols.TBSS_BinarySymbol
            BoldSqlSymbols.TBSS_SqlLikeUsersBase
                BoldSqlSymbols.TBSS_Contains
                BoldSqlSymbols.TBSS_StartsWith


Inheritance Hierarchy

Inheritance Hierarchy
Inheritance Hierarchy
BoldSqlNodes.TBoldSqlSymbol
    BoldSqlSymbols.TBSS_Symbol
        BoldSqlSymbols.TBSS_BinarySymbol
            BoldSqlSymbols.TBSS_SqlLikeUsersBase
                BoldSqlSymbols.TBSS_StartsWith


Inheritance Hierarchy

Inheritance Hierarchy
Inheritance Hierarchy
BoldSqlNodes.TBoldSqlSymbol
    BoldSqlSymbols.TBSS_Symbol
        BoldSqlSymbols.TBSS_BinarySymbol
            BoldSqlSymbols.TBSS_Subtract


Inheritance Hierarchy

Inheritance Hierarchy
Inheritance Hierarchy
BoldSqlNodes.TBoldSqlSymbol
    BoldSqlSymbols.TBSS_Symbol
        BoldSqlSymbols.TBSS_GroupFunctions
            BoldSqlSymbols.TBSS_Sum


Inheritance Hierarchy

Inheritance Hierarchy
Inheritance Hierarchy
BoldSqlNodes.TBoldSqlSymbol
    BoldSqlSymbols.TBSS_Symbol
        BoldSqlSymbols.TBSS_AllInstances
        BoldSqlSymbols.TBSS_BinarySymbol
        BoldSqlSymbols.TBSS_GroupFunctions
        BoldSqlSymbols.TBSS_includes
        BoldSqlSymbols.TBSS_isEmpty
        BoldSqlSymbols.TBSS_isNull
        BoldSqlSymbols.TBSS_Iteration
        BoldSqlSymbols.TBSS_ListOperations
        BoldSqlSymbols.TBSS_NotEmpty
        BoldSqlSymbols.TBSS_OclAsType
        BoldSqlSymbols.TBSS_PrefixBinarySymbol
        BoldSqlSymbols.TBSS_Size
        BoldSqlSymbols.TBSS_toLower
        BoldSqlSymbols.TBSS_ToUpper
        BoldSqlSymbols.TBSS_UnarySymbol


Inheritance Hierarchy

Inheritance Hierarchy
Inheritance Hierarchy
BoldSqlNodes.TBoldSqlSymbol
    BoldSqlSymbols.TBSS_Symbol
        BoldSqlSymbols.TBSS_ListOperations
            BoldSqlSymbols.TBSS_SymmetricDifference


Inheritance Hierarchy

Inheritance Hierarchy
Inheritance Hierarchy
BoldSqlNodes.TBoldSqlSymbol
    BoldSqlSymbols.TBSS_Symbol
        BoldSqlSymbols.TBSS_toLower


Inheritance Hierarchy

Inheritance Hierarchy
Inheritance Hierarchy
BoldSqlNodes.TBoldSqlSymbol
    BoldSqlSymbols.TBSS_Symbol
        BoldSqlSymbols.TBSS_ToUpper


Inheritance Hierarchy

Inheritance Hierarchy
Inheritance Hierarchy
BoldSqlNodes.TBoldSqlSymbol
    BoldSqlSymbols.TBSS_Symbol
        BoldSqlSymbols.TBSS_UnarySymbol
            BoldSqlSymbols.TBSS_UnaryMinus


Inheritance Hierarchy

Inheritance Hierarchy
Inheritance Hierarchy
BoldSqlNodes.TBoldSqlSymbol
    BoldSqlSymbols.TBSS_Symbol
        BoldSqlSymbols.TBSS_UnarySymbol
            BoldSqlSymbols.TBSS_Abs
            BoldSqlSymbols.TBSS_Floor
            BoldSqlSymbols.TBSS_Length
            BoldSqlSymbols.TBSS_not
            BoldSqlSymbols.TBSS_Round
            BoldSqlSymbols.TBSS_UnaryMinus


Inheritance Hierarchy

Inheritance Hierarchy
Inheritance Hierarchy
BoldSqlNodes.TBoldSqlSymbol
    BoldSqlSymbols.TBSS_Symbol
        BoldSqlSymbols.TBSS_ListOperations
            BoldSqlSymbols.TBSS_union


Inheritance Hierarchy

Inheritance Hierarchy
Inheritance Hierarchy
BoldSqlNodes.TBoldSqlSymbol
    BoldSqlSymbols.TBSS_Symbol
        BoldSqlSymbols.TBSS_BinarySymbol
            BoldSqlSymbols.TBSS_xor


Inheritance Hierarchy

Inheritance Hierarchy
Inheritance Hierarchy
Eco.AutoContainers.AutoContainerArgs


Inheritance Hierarchy

Inheritance Hierarchy
Inheritance Hierarchy
Eco.AutoContainers.IAutoContainerFactory
    Eco.AutoContainers.AutoContainerFactory


Inheritance Hierarchy

Inheritance Hierarchy
Inheritance Hierarchy
Eco.AutoContainers.AutoContainerProvider


Inheritance Hierarchy

Inheritance Hierarchy
Inheritance Hierarchy
Eco.AutoContainers.IAutoContainerService
    Eco.AutoContainers.AutoContainerService


Inheritance Hierarchy

Inheritance Hierarchy
Inheritance Hierarchy
Eco.AutoContainers.IAutoContainer
System.Windows.Forms.Form
    Eco.AutoContainers.DefaultAutoForm


Inheritance Hierarchy

Inheritance Hierarchy
Inheritance Hierarchy
Eco.AutoContainers.IAutoContainerFactory
    Eco.AutoContainers.DefaultListContainerFactory


Inheritance Hierarchy

Inheritance Hierarchy
Inheritance Hierarchy
Eco.AutoContainers.IAutoContainer
    Eco.AutoContainers.DefaultAutoForm


Inheritance Hierarchy

Inheritance Hierarchy
Inheritance Hierarchy
Eco.AutoContainers.IAutoContainerFactory
    Eco.AutoContainers.AutoContainerFactory
    Eco.AutoContainers.DefaultListContainerFactory


Inheritance Hierarchy

Inheritance Hierarchy
Inheritance Hierarchy
Eco.AutoContainers.LayoutInfo


Inheritance Hierarchy

Inheritance Hierarchy
Inheritance Hierarchy
Eco.Cache.CanReleaseResult


Inheritance Hierarchy

Inheritance Hierarchy
Inheritance Hierarchy
Eco.Cache.ICache
    Eco.Cache.ChainedCacheBase


Inheritance Hierarchy

Inheritance Hierarchy
Inheritance Hierarchy
Eco.Cache.GenericCollection


Inheritance Hierarchy

Inheritance Hierarchy
Inheritance Hierarchy
Eco.Cache.Locator


Inheritance Hierarchy

Inheritance Hierarchy
Inheritance Hierarchy
Eco.Cache.LocatorEventArgs


Inheritance Hierarchy

Inheritance Hierarchy
Inheritance Hierarchy
Eco.Cache.LocatorPair


Inheritance Hierarchy

Inheritance Hierarchy
Inheritance Hierarchy
Eco.Collections.CollectionBase


Inheritance Hierarchy

Inheritance Hierarchy
Inheritance Hierarchy
Eco.Collections.HashBase


Inheritance Hierarchy

Inheritance Hierarchy
Inheritance Hierarchy
Eco.Collections.IHashBaseElement


Inheritance Hierarchy

Inheritance Hierarchy
Inheritance Hierarchy
Eco.DataRepresentation.AssociationEnd
    Eco.DataRepresentation.IndirectMultiAssociationEnd
    Eco.DataRepresentation.IndirectSingleAssociationEnd
    Eco.DataRepresentation.MultiAssociationEnd
    Eco.DataRepresentation.SingleAssociationEnd


Inheritance Hierarchy

Inheritance Hierarchy
Inheritance Hierarchy
Eco.DataRepresentation.Datablock


Inheritance Hierarchy

Inheritance Hierarchy
Inheritance Hierarchy
Eco.DataRepresentation.ObjectId
    Eco.DataRepresentation.DefaultId
        Eco.DataRepresentation.TimestampedDefaultId


Inheritance Hierarchy

Inheritance Hierarchy
Inheritance Hierarchy
Eco.DataRepresentation.IdTranslationList


Inheritance Hierarchy

Inheritance Hierarchy
Inheritance Hierarchy
Eco.DataRepresentation.AssociationEnd
    Eco.DataRepresentation.IndirectMultiAssociationEnd


Inheritance Hierarchy

Inheritance Hierarchy
Inheritance Hierarchy
Eco.DataRepresentation.AssociationEnd
    Eco.DataRepresentation.IndirectSingleAssociationEnd


Inheritance Hierarchy

Inheritance Hierarchy
Inheritance Hierarchy
Eco.DataRepresentation.ObjectId
    Eco.DataRepresentation.InternalObjectId


Inheritance Hierarchy

Inheritance Hierarchy
Inheritance Hierarchy
Eco.DataRepresentation.MemberNotAssignedException


Inheritance Hierarchy

Inheritance Hierarchy
Inheritance Hierarchy
Eco.DataRepresentation.AssociationEnd
    Eco.DataRepresentation.MultiAssociationEnd


Inheritance Hierarchy

Inheritance Hierarchy
Inheritance Hierarchy
Eco.DataRepresentation.ObjectContents


Inheritance Hierarchy

Inheritance Hierarchy
Inheritance Hierarchy
Eco.DataRepresentation.ObjectId
    Eco.DataRepresentation.DefaultId
    Eco.DataRepresentation.InternalObjectId


Inheritance Hierarchy

Inheritance Hierarchy
Inheritance Hierarchy
Eco.DataRepresentation.ObjectIdCollection


Inheritance Hierarchy

Inheritance Hierarchy
Inheritance Hierarchy
Eco.DataRepresentation.ObjectIdList


Inheritance Hierarchy

Inheritance Hierarchy
Inheritance Hierarchy
Eco.DataRepresentation.AssociationEnd
    Eco.DataRepresentation.SingleAssociationEnd


Inheritance Hierarchy

Inheritance Hierarchy
Inheritance Hierarchy
System.Windows.Forms.Form
    Eco.Diagnostics.TemplateDebuggerPanel


Inheritance Hierarchy

Inheritance Hierarchy
Inheritance Hierarchy
Eco.Exceptions.EcoException
    Eco.Exceptions.BadLockExpressionException


Inheritance Hierarchy

Inheritance Hierarchy
Inheritance Hierarchy
Eco.Exceptions.EcoException
    Eco.Exceptions.BadLockExpressionException
    Eco.Exceptions.EcoInternalErrorException
    Eco.Exceptions.EcoOclErrorException
    Eco.Exceptions.InvalidMappingException
    Eco.Exceptions.UserAbortException


Inheritance Hierarchy

Inheritance Hierarchy
Inheritance Hierarchy
Eco.Exceptions.EcoException
    Eco.Exceptions.EcoInternalErrorException


Inheritance Hierarchy

Inheritance Hierarchy
Inheritance Hierarchy
Eco.Exceptions.EcoException
    Eco.Exceptions.EcoOclErrorException


Inheritance Hierarchy

Inheritance Hierarchy
Inheritance Hierarchy
Eco.Exceptions.EcoException
    Eco.Exceptions.InvalidMappingException


Inheritance Hierarchy

Inheritance Hierarchy
Inheritance Hierarchy
Eco.Exceptions.EcoException
    Eco.Exceptions.UserAbortException


Inheritance Hierarchy

Inheritance Hierarchy
Inheritance Hierarchy
Eco.Framework.IDerivedMemberManager
    Eco.Framework.DerivedMemberManager


Inheritance Hierarchy

Inheritance Hierarchy
Inheritance Hierarchy
Eco.Framework.EcoServiceProvider


Inheritance Hierarchy

Inheritance Hierarchy
Inheritance Hierarchy
Eco.Framework.EcoSpacePart
    Eco.Framework.EcoSpacePartWithTypeSystem
    Eco.Framework.Impl.Frontside.DefaultFrontsidePolicy


Related Topics

Related Topics
Related Topics

EcoSpacePart.Serialize


Inheritance Hierarchy

Inheritance Hierarchy
Inheritance Hierarchy
Eco.Framework.EcoSpacePartList


Related Topics

Related Topics
Related Topics

EcoSpacePart.Activate


Related Topics

Related Topics
Related Topics

EcoSpacePart.Deactivate


Inheritance Hierarchy

Inheritance Hierarchy
Inheritance Hierarchy
Eco.Framework.EcoSpacePart
    Eco.Framework.EcoSpacePartWithTypeSystem
        Eco.Framework.Impl.CacheImpl


Inheritance Hierarchy

Inheritance Hierarchy
Inheritance Hierarchy
Eco.Framework.EcoSpaceSerializationConfig


Inheritance Hierarchy

Inheritance Hierarchy
Inheritance Hierarchy
Eco.Framework.IChangeHandler


Inheritance Hierarchy

Inheritance Hierarchy
Inheritance Hierarchy
Eco.Framework.IFetchHandler


Inheritance Hierarchy

Inheritance Hierarchy
Inheritance Hierarchy
Eco.Framework.Impl.MemberCachePolicy
    Eco.Framework.Impl.AttributeCachePolicy
        Eco.Framework.Impl.ArrayAttributeCachePolicy


Inheritance Hierarchy

Inheritance Hierarchy
Inheritance Hierarchy
Eco.Framework.Impl.MemberCachePolicy
    Eco.Framework.Impl.AssociationEndCachePolicy
        Eco.Framework.Impl.MultiAssociationEndCachePolicy
        Eco.Framework.Impl.SingleAssociationEndCachePolicy


Inheritance Hierarchy

Inheritance Hierarchy
Inheritance Hierarchy
Eco.Framework.Impl.CacheLocator
    Eco.Framework.Impl.Frontside.DefaultFrontsideLocator


Inheritance Hierarchy

Inheritance Hierarchy
Inheritance Hierarchy
Eco.Framework.Impl.CacheMultilinkAdapter
    Eco.Framework.Impl.CacheMultilinkCurrentValueAdapter
    Eco.Framework.Impl.CacheMultilinkFetchedValueAdapter


Inheritance Hierarchy

Inheritance Hierarchy
Inheritance Hierarchy
Eco.Framework.Impl.CacheMultilinkAdapter
    Eco.Framework.Impl.CacheMultilinkCurrentValueAdapter


Inheritance Hierarchy

Inheritance Hierarchy
Inheritance Hierarchy
Eco.Framework.Impl.CacheMultilinkEnumerator


Inheritance Hierarchy

Inheritance Hierarchy
Inheritance Hierarchy
Eco.Framework.Impl.CacheMultilinkAdapter
    Eco.Framework.Impl.CacheMultilinkFetchedValueAdapter


Inheritance Hierarchy

Inheritance Hierarchy
Inheritance Hierarchy
Eco.Framework.Impl.ClassCachePolicy


Inheritance Hierarchy

Inheritance Hierarchy
Inheritance Hierarchy
Eco.Framework.Impl.MemberCachePolicy
    Eco.Framework.Impl.AssociationEndCachePolicy
        Eco.Framework.Impl.MultiAssociationEndCachePolicy
            Eco.Framework.Impl.MainMultiAssociationEndCachePolicy
            Eco.Framework.Impl.IOtherEndController
                Eco.Framework.Impl.DirectMultiAssociationEndCachePolicy


Inheritance Hierarchy

Inheritance Hierarchy
Inheritance Hierarchy
Eco.Framework.Impl.MemberCachePolicy
    Eco.Framework.Impl.AssociationEndCachePolicy
        Eco.Framework.Impl.SingleAssociationEndCachePolicy
        Eco.Framework.Impl.IOtherEndController
            Eco.Framework.Impl.DirectSingleAssociationEndCachePolicy
                Eco.Framework.Impl.InnerAssociationEndCachePolicy


Inheritance Hierarchy

Inheritance Hierarchy
Inheritance Hierarchy
Eco.Framework.Impl.Frontside.MemberFrontsidePolicy
    Eco.Framework.Impl.Frontside.AssociationEndFrontsidePolicy
        Eco.Framework.Impl.Frontside.MultAssociationEndFrontsidePolicy
        Eco.Framework.Impl.Frontside.SingleAssociationEndFrontsidePolicy


Inheritance Hierarchy

Inheritance Hierarchy
Inheritance Hierarchy
Eco.Framework.Impl.Frontside.MemberFrontsidePolicy
    Eco.Framework.Impl.Frontside.AttributeFrontsidePolicy


Inheritance Hierarchy

Inheritance Hierarchy
Inheritance Hierarchy
Eco.Framework.Impl.Frontside.MemberPropertyAdapter
    Eco.Framework.Impl.Frontside.AttributePropertyAdapter


Inheritance Hierarchy

Inheritance Hierarchy
Inheritance Hierarchy
Eco.Framework.Impl.Frontside.ClassFrontsidePolicy


Inheritance Hierarchy

Inheritance Hierarchy
Inheritance Hierarchy
Eco.Framework.EcoSpacePart
Eco.Framework.IObjectRepresentationProvider
    Eco.Framework.Impl.Frontside.DefaultFrontsidePolicy


Inheritance Hierarchy

Inheritance Hierarchy
Inheritance Hierarchy
Eco.Framework.Impl.Frontside.DefaultLoopback


Inheritance Hierarchy

Inheritance Hierarchy
Inheritance Hierarchy
Eco.Framework.Impl.Frontside.MemberFrontsidePolicy
    Eco.Framework.Impl.Frontside.DerivedMemberFrontsidePolicy
        Eco.Framework.Impl.Frontside.DerivedAttributeFrontsidePolicy


Inheritance Hierarchy

Inheritance Hierarchy
Inheritance Hierarchy
Eco.Framework.Impl.Frontside.MemberFrontsidePolicy
    Eco.Framework.Impl.Frontside.DerivedMemberFrontsidePolicy
        Eco.Framework.Impl.Frontside.DerivedAttributeFrontsidePolicy
        Eco.Framework.Impl.Frontside.DerivedMultilinkFrontsidePolicy
        Eco.Framework.Impl.Frontside.DerivedSingleLinkFrontsidePolicy


Inheritance Hierarchy

Inheritance Hierarchy
Inheritance Hierarchy
Eco.Framework.Impl.Frontside.MemberFrontsidePolicy
    Eco.Framework.Impl.Frontside.DerivedMemberFrontsidePolicy
        Eco.Framework.Impl.Frontside.DerivedMultilinkFrontsidePolicy


Inheritance Hierarchy

Inheritance Hierarchy
Inheritance Hierarchy
Eco.Framework.Impl.Frontside.MemberFrontsidePolicy
    Eco.Framework.Impl.Frontside.DerivedMemberFrontsidePolicy
        Eco.Framework.Impl.Frontside.DerivedSingleLinkFrontsidePolicy


Inheritance Hierarchy

Inheritance Hierarchy
Inheritance Hierarchy
Eco.Framework.Impl.Frontside.MemberFrontsidePolicy
    Eco.Framework.Impl.Frontside.AssociationEndFrontsidePolicy
        Eco.Framework.Impl.Frontside.MultAssociationEndFrontsidePolicy
            Eco.Framework.Impl.Frontside.DirectMultiFrontsidePolicy


Inheritance Hierarchy

Inheritance Hierarchy
Inheritance Hierarchy
Eco.Framework.Impl.Frontside.MemberFrontsidePolicy
    Eco.Framework.Impl.Frontside.AssociationEndFrontsidePolicy
        Eco.Framework.Impl.Frontside.SingleAssociationEndFrontsidePolicy
            Eco.Framework.Impl.Frontside.DirectSingleMultiFrontsidePolicy


Inheritance Hierarchy

Inheritance Hierarchy
Inheritance Hierarchy
Eco.Framework.Impl.Frontside.MemberFrontsidePolicy
    Eco.Framework.Impl.Frontside.AssociationEndFrontsidePolicy
        Eco.Framework.Impl.Frontside.SingleAssociationEndFrontsidePolicy
            Eco.Framework.Impl.Frontside.DirectSingleSingleEmbeddedFrontsidePolicy


Inheritance Hierarchy

Inheritance Hierarchy
Inheritance Hierarchy
Eco.Framework.Impl.Frontside.MemberFrontsidePolicy
    Eco.Framework.Impl.Frontside.AssociationEndFrontsidePolicy
        Eco.Framework.Impl.Frontside.SingleAssociationEndFrontsidePolicy
            Eco.Framework.Impl.Frontside.DirectSingleSingleNonembeddedFrontsidePolicy


Inheritance Hierarchy

Inheritance Hierarchy
Inheritance Hierarchy
Eco.Framework.Impl.Frontside.IFrontsideAdapterFactory
    Eco.Framework.Impl.Frontside.FrontSideAdapterFactory


Inheritance Hierarchy

Inheritance Hierarchy
Inheritance Hierarchy
Eco.Framework.Impl.Frontside.IFrontsideDerivedAdapterFactory
    Eco.Framework.Impl.Frontside.FrontSideDerivedAdapterFactory


Inheritance Hierarchy

Inheritance Hierarchy
Inheritance Hierarchy
Eco.Framework.Impl.Frontside.FrontsideDerivedMultilinkAdapter


Inheritance Hierarchy

Inheritance Hierarchy
Inheritance Hierarchy
Eco.Framework.Impl.Frontside.FrontsideMultilinkAdapter


Inheritance Hierarchy

Inheritance Hierarchy
Inheritance Hierarchy
Eco.Framework.Impl.Frontside.FrontsideUtils


Inheritance Hierarchy

Inheritance Hierarchy
Inheritance Hierarchy
Eco.Framework.Impl.Frontside.MemberFrontsidePolicy
    Eco.Framework.Impl.Frontside.AssociationEndFrontsidePolicy
        Eco.Framework.Impl.Frontside.MultAssociationEndFrontsidePolicy
            Eco.Framework.Impl.Frontside.IndirectMultiFrontsidePolicy
                Eco.Framework.Impl.Frontside.IndirectMultiSingleFrontsidePolicy
                Eco.Framework.Impl.Frontside.MultiMultiFrontsidePolicy


Inheritance Hierarchy

Inheritance Hierarchy
Inheritance Hierarchy
Eco.Framework.Impl.Frontside.MemberFrontsidePolicy
    Eco.Framework.Impl.Frontside.AssociationEndFrontsidePolicy
        Eco.Framework.Impl.Frontside.MultAssociationEndFrontsidePolicy
            Eco.Framework.Impl.Frontside.IndirectMultiFrontsidePolicy
                Eco.Framework.Impl.Frontside.IndirectMultiSingleFrontsidePolicy


Inheritance Hierarchy

Inheritance Hierarchy
Inheritance Hierarchy
Eco.Framework.Impl.Frontside.MemberFrontsidePolicy
    Eco.Framework.Impl.Frontside.AssociationEndFrontsidePolicy
        Eco.Framework.Impl.Frontside.SingleAssociationEndFrontsidePolicy
            Eco.Framework.Impl.Frontside.IndirectSingleFrontsidePolicy


Inheritance Hierarchy

Inheritance Hierarchy
Inheritance Hierarchy
Eco.Framework.Impl.Frontside.MemberFrontsidePolicy
    Eco.Framework.Impl.Frontside.AssociationEndFrontsidePolicy
        Eco.Framework.Impl.Frontside.SingleAssociationEndFrontsidePolicy
            Eco.Framework.Impl.Frontside.InnerLinkFrontsidePolicy


Inheritance Hierarchy

Inheritance Hierarchy
Inheritance Hierarchy
Eco.Framework.Impl.Frontside.LocatorFactory


Inheritance Hierarchy

Inheritance Hierarchy
Inheritance Hierarchy
Eco.Framework.Impl.Frontside.MemberFrontsidePolicy
    Eco.Framework.Impl.Frontside.AssociationEndFrontsidePolicy
    Eco.Framework.Impl.Frontside.AttributeFrontsidePolicy
    Eco.Framework.Impl.Frontside.DerivedMemberFrontsidePolicy


Inheritance Hierarchy

Inheritance Hierarchy
Inheritance Hierarchy
Eco.Framework.Impl.Frontside.MemberPropertyAdapter
    Eco.Framework.Impl.Frontside.AttributePropertyAdapter
    Eco.Framework.Impl.Frontside.ObjectListPropertyAdapter
    Eco.Framework.Impl.Frontside.ObjectReferencePropertyAdapter


Inheritance Hierarchy

Inheritance Hierarchy
Inheritance Hierarchy
Eco.Framework.Impl.Frontside.MemberFrontsidePolicy
    Eco.Framework.Impl.Frontside.AssociationEndFrontsidePolicy
        Eco.Framework.Impl.Frontside.MultAssociationEndFrontsidePolicy
            Eco.Framework.Impl.Frontside.DirectMultiFrontsidePolicy
            Eco.Framework.Impl.Frontside.IndirectMultiFrontsidePolicy
            Eco.Framework.Impl.Frontside.ToInnerMultiFrontsidePolicy


Inheritance Hierarchy

Inheritance Hierarchy
Inheritance Hierarchy
Eco.Framework.Impl.Frontside.MultiLinkAdapterEnumerator


Inheritance Hierarchy

Inheritance Hierarchy
Inheritance Hierarchy
Eco.Framework.Impl.Frontside.MemberFrontsidePolicy
    Eco.Framework.Impl.Frontside.AssociationEndFrontsidePolicy
        Eco.Framework.Impl.Frontside.MultAssociationEndFrontsidePolicy
            Eco.Framework.Impl.Frontside.IndirectMultiFrontsidePolicy
                Eco.Framework.Impl.Frontside.MultiMultiFrontsidePolicy


Inheritance Hierarchy

Inheritance Hierarchy
Inheritance Hierarchy
Eco.Framework.Impl.Frontside.NonDeletableReason


Inheritance Hierarchy

Inheritance Hierarchy
Inheritance Hierarchy
Eco.Framework.Impl.Frontside.MemberPropertyAdapter
    Eco.Framework.Impl.Frontside.ObjectListPropertyAdapter


Inheritance Hierarchy

Inheritance Hierarchy
Inheritance Hierarchy
Eco.Framework.Impl.Frontside.MemberPropertyAdapter
    Eco.Framework.Impl.Frontside.ObjectReferencePropertyAdapter


Inheritance Hierarchy

Inheritance Hierarchy
Inheritance Hierarchy
Eco.Framework.Impl.Frontside.MemberFrontsidePolicy
    Eco.Framework.Impl.Frontside.AssociationEndFrontsidePolicy
        Eco.Framework.Impl.Frontside.SingleAssociationEndFrontsidePolicy
            Eco.Framework.Impl.Frontside.DirectSingleMultiFrontsidePolicy
            Eco.Framework.Impl.Frontside.DirectSingleSingleEmbeddedFrontsidePolicy
            Eco.Framework.Impl.Frontside.DirectSingleSingleNonembeddedFrontsidePolicy
            Eco.Framework.Impl.Frontside.IndirectSingleFrontsidePolicy
            Eco.Framework.Impl.Frontside.InnerLinkFrontsidePolicy
            Eco.Framework.Impl.Frontside.ToInnerSingleFrontsidePolicy


Inheritance Hierarchy

Inheritance Hierarchy
Inheritance Hierarchy
Eco.Framework.Impl.Frontside.MemberFrontsidePolicy
    Eco.Framework.Impl.Frontside.AssociationEndFrontsidePolicy
        Eco.Framework.Impl.Frontside.MultAssociationEndFrontsidePolicy
            Eco.Framework.Impl.Frontside.ToInnerMultiFrontsidePolicy


Inheritance Hierarchy

Inheritance Hierarchy
Inheritance Hierarchy
Eco.Framework.Impl.Frontside.MemberFrontsidePolicy
    Eco.Framework.Impl.Frontside.AssociationEndFrontsidePolicy
        Eco.Framework.Impl.Frontside.SingleAssociationEndFrontsidePolicy
            Eco.Framework.Impl.Frontside.ToInnerSingleFrontsidePolicy


Inheritance Hierarchy

Inheritance Hierarchy
Inheritance Hierarchy
Eco.Framework.Impl.IIndirectController
    Eco.Framework.Impl.IndirectMultiAssociationEndCachePolicy
    Eco.Framework.Impl.IndirectSingleAssociationEndCachePolicy


Inheritance Hierarchy

Inheritance Hierarchy
Inheritance Hierarchy
Eco.Framework.Impl.MemberCachePolicy
    Eco.Framework.Impl.AssociationEndCachePolicy
        Eco.Framework.Impl.MultiAssociationEndCachePolicy
            Eco.Framework.Impl.MainMultiAssociationEndCachePolicy
            Eco.Framework.Impl.IIndirectController
            Eco.Framework.Impl.IOtherEndController
                Eco.Framework.Impl.IndirectMultiAssociationEndCachePolicy


Inheritance Hierarchy

Inheritance Hierarchy
Inheritance Hierarchy
Eco.Framework.Impl.MemberCachePolicy
    Eco.Framework.Impl.AssociationEndCachePolicy
        Eco.Framework.Impl.SingleAssociationEndCachePolicy
        Eco.Framework.Impl.IIndirectController
        Eco.Framework.Impl.IOtherEndController
            Eco.Framework.Impl.IndirectSingleAssociationEndCachePolicy


Inheritance Hierarchy

Inheritance Hierarchy
Inheritance Hierarchy
Eco.Framework.Impl.IOtherEndController
    Eco.Framework.Impl.DirectMultiAssociationEndCachePolicy
    Eco.Framework.Impl.DirectSingleAssociationEndCachePolicy
    Eco.Framework.Impl.IndirectMultiAssociationEndCachePolicy
    Eco.Framework.Impl.IndirectSingleAssociationEndCachePolicy


Inheritance Hierarchy

Inheritance Hierarchy
Inheritance Hierarchy
Eco.Framework.Impl.MemberCachePolicy
    Eco.Framework.Impl.AssociationEndCachePolicy
        Eco.Framework.Impl.MultiAssociationEndCachePolicy
            Eco.Framework.Impl.LinkObjectMultiAssociationEndCachePolicy


Inheritance Hierarchy

Inheritance Hierarchy
Inheritance Hierarchy
Eco.Framework.Impl.MemberCachePolicy
    Eco.Framework.Impl.AssociationEndCachePolicy
        Eco.Framework.Impl.SingleAssociationEndCachePolicy
            Eco.Framework.Impl.LinkObjectSingleAssociationEndCachePolicy


Inheritance Hierarchy

Inheritance Hierarchy
Inheritance Hierarchy
Eco.Framework.Impl.LocatorDictionary


Inheritance Hierarchy

Inheritance Hierarchy
Inheritance Hierarchy
Eco.Framework.Impl.MemberCachePolicy
    Eco.Framework.Impl.AssociationEndCachePolicy
        Eco.Framework.Impl.MultiAssociationEndCachePolicy
            Eco.Framework.Impl.MainMultiAssociationEndCachePolicy
                Eco.Framework.Impl.DirectMultiAssociationEndCachePolicy
                Eco.Framework.Impl.IndirectMultiAssociationEndCachePolicy


Inheritance Hierarchy

Inheritance Hierarchy
Inheritance Hierarchy
Eco.Framework.Impl.MemberCachePolicy
    Eco.Framework.Impl.AssociationEndCachePolicy
    Eco.Framework.Impl.AttributeCachePolicy


Inheritance Hierarchy

Inheritance Hierarchy
Inheritance Hierarchy
Eco.Framework.Impl.MemberCachePolicy.MemberFlags


Inheritance Hierarchy

Inheritance Hierarchy
Inheritance Hierarchy
Eco.Framework.Impl.MemberCachePolicy
    Eco.Framework.Impl.AssociationEndCachePolicy
        Eco.Framework.Impl.MultiAssociationEndCachePolicy
            Eco.Framework.Impl.LinkObjectMultiAssociationEndCachePolicy
            Eco.Framework.Impl.MainMultiAssociationEndCachePolicy


Inheritance Hierarchy

Inheritance Hierarchy
Inheritance Hierarchy
Eco.Framework.Impl.MemberCachePolicy
    Eco.Framework.Impl.AssociationEndCachePolicy
        Eco.Framework.Impl.SingleAssociationEndCachePolicy
            Eco.Framework.Impl.DirectSingleAssociationEndCachePolicy
            Eco.Framework.Impl.IndirectSingleAssociationEndCachePolicy
            Eco.Framework.Impl.LinkObjectSingleAssociationEndCachePolicy


Inheritance Hierarchy

Inheritance Hierarchy
Inheritance Hierarchy
Eco.Framework.IObjectRepresentationProvider
    Eco.Framework.Impl.Frontside.DefaultFrontsidePolicy


Inheritance Hierarchy

Inheritance Hierarchy
Inheritance Hierarchy
Eco.Framework.IPersistenceHandler


Inheritance Hierarchy

Inheritance Hierarchy
Inheritance Hierarchy
Eco.Framework.LocatorCollectionEventArgs


Inheritance Hierarchy

Inheritance Hierarchy
Inheritance Hierarchy
Eco.Framework.MemberDeriveException


Inheritance Hierarchy

Inheritance Hierarchy
Inheritance Hierarchy
Eco.FrameworkImpl.Frontside.IStateMachineAccess


Inheritance Hierarchy

Inheritance Hierarchy
Inheritance Hierarchy
Eco.FrameworkImpl.Frontside.ObjectStateMachine


Inheritance Hierarchy

Inheritance Hierarchy
Inheritance Hierarchy
Eco.FrameworkImpl.LockRegions.ConcreteRegionDefinitionList


Inheritance Hierarchy

Inheritance Hierarchy
Inheritance Hierarchy
Eco.FrameworkImpl.LockRegions.IdChangedEventargs


Inheritance Hierarchy

Inheritance Hierarchy
Inheritance Hierarchy
Eco.FrameworkImpl.LockRegions.ILockRegion
    Eco.FrameworkImpl.LockRegions.LockRegionImpl


Inheritance Hierarchy

Inheritance Hierarchy
Inheritance Hierarchy
Eco.FrameworkImpl.LockRegions.IRegionFactory
    Eco.FrameworkImpl.LockRegions.TBoldRegionFactory


Example

Example

Region1[Person]: firstName, lastName | Region2[home] Region1[Building]: zipCode Region1[Residential_Building]: totalRent


Inheritance Hierarchy

Inheritance Hierarchy
Inheritance Hierarchy
Eco.FrameworkImpl.LockRegions.RegionExpressionSyntaxErrorException


Inheritance Hierarchy

Inheritance Hierarchy
Inheritance Hierarchy
Eco.FrameworkImpl.LockRegions.RegionParser


Inheritance Hierarchy

Inheritance Hierarchy
Inheritance Hierarchy
Eco.FrameworkImpl.LockRegions.TBoldConcreteRegionDefinition


Inheritance Hierarchy

Inheritance Hierarchy
Inheritance Hierarchy
Eco.FrameworkImpl.LockRegions.TBoldIdChangedAdapter


Inheritance Hierarchy

Inheritance Hierarchy
Inheritance Hierarchy
Eco.FrameworkImpl.LockRegions.TBoldRegionLookup
    Eco.FrameworkImpl.LockRegions.TBoldOrderedRegionLookup


Inheritance Hierarchy

Inheritance Hierarchy
Inheritance Hierarchy
Eco.FrameworkImpl.LockRegions.TBoldRegionChangedAdapter


Inheritance Hierarchy

Inheritance Hierarchy
Inheritance Hierarchy
Eco.FrameworkImpl.LockRegions.TBoldRegionCoreDefinition


Inheritance Hierarchy

Inheritance Hierarchy
Inheritance Hierarchy
Eco.FrameworkImpl.LockRegions.TBoldRegionDefinitions


Inheritance Hierarchy

Inheritance Hierarchy
Inheritance Hierarchy
Eco.FrameworkImpl.LockRegions.TBoldRegionDefinitions.ClassListType


Inheritance Hierarchy

Inheritance Hierarchy
Inheritance Hierarchy
Eco.FrameworkImpl.LockRegions.TBoldRegionDefinitions.MemberListItemType


Inheritance Hierarchy

Inheritance Hierarchy
Inheritance Hierarchy
Eco.FrameworkImpl.LockRegions.TBoldRegionDefinitions.MemberListType


Inheritance Hierarchy

Inheritance Hierarchy
Inheritance Hierarchy
Eco.FrameworkImpl.LockRegions.TBoldRegionElementInclusion


Inheritance Hierarchy

Inheritance Hierarchy
Inheritance Hierarchy
Eco.FrameworkImpl.LockRegions.TBoldRegionExpander


Inheritance Hierarchy

Inheritance Hierarchy
Inheritance Hierarchy
Eco.FrameworkImpl.LockRegions.TBoldSubregionReference


Inheritance Hierarchy

Inheritance Hierarchy
Inheritance Hierarchy
Eco.FrameworkImpl.Ocl.BoldOclError


Inheritance Hierarchy

Inheritance Hierarchy
Inheritance Hierarchy
Eco.FrameworkImpl.Ocl.EBoldOCLError
    Eco.FrameworkImpl.Ocl.EBoldOCLAbort


Inheritance Hierarchy

Inheritance Hierarchy
Inheritance Hierarchy
Eco.FrameworkImpl.Ocl.EBoldOCLError
    Eco.FrameworkImpl.Ocl.EBoldOCLAbort
    Eco.FrameworkImpl.Ocl.EBoldOCLInternalError
    Eco.FrameworkImpl.Ocl.EBoldOclRunTimeError


Inheritance Hierarchy

Inheritance Hierarchy
Inheritance Hierarchy
Eco.FrameworkImpl.Ocl.EBoldOCLError
    Eco.FrameworkImpl.Ocl.EBoldOCLInternalError


Inheritance Hierarchy

Inheritance Hierarchy
Inheritance Hierarchy
Eco.FrameworkImpl.Ocl.EBoldOCLError
    Eco.FrameworkImpl.Ocl.EBoldOclRunTimeError


Inheritance Hierarchy

Inheritance Hierarchy
Inheritance Hierarchy
Eco.FrameworkImpl.Ocl.Ocl__ListCopier
    Eco.FrameworkImpl.Ocl.Ocl_AsBag
    Eco.FrameworkImpl.Ocl.Ocl_AsOrderedSet
    Eco.FrameworkImpl.Ocl.Ocl_AsSequence
    Eco.FrameworkImpl.Ocl.Ocl_AsSet


Inheritance Hierarchy

Inheritance Hierarchy
Inheritance Hierarchy
Eco.FrameworkImpl.Ocl.Ocl_AbstractCompare
    Eco.FrameworkImpl.Ocl.Ocl_Equal
    Eco.FrameworkImpl.Ocl.Ocl_NotEqual


Inheritance Hierarchy

Inheritance Hierarchy
Inheritance Hierarchy
Eco.FrameworkImpl.Ocl.Ocl_AbstractOrder
    Eco.FrameworkImpl.Ocl.Ocl_orderby
    Eco.FrameworkImpl.Ocl.Ocl_orderDescending


Inheritance Hierarchy

Inheritance Hierarchy
Inheritance Hierarchy
Eco.FrameworkImpl.Ocl.Ocl_AllInstances


Inheritance Hierarchy

Inheritance Hierarchy
Inheritance Hierarchy
Eco.FrameworkImpl.Ocl.Ocl_AllInstancesAtTime


Inheritance Hierarchy

Inheritance Hierarchy
Inheritance Hierarchy
Eco.FrameworkImpl.Ocl.Ocl_AllLoadedObjects


Inheritance Hierarchy

Inheritance Hierarchy
Inheritance Hierarchy
Eco.FrameworkImpl.Ocl.Ocl_AllSubClasses


Inheritance Hierarchy

Inheritance Hierarchy
Inheritance Hierarchy
Eco.FrameworkImpl.Ocl.Ocl_AllSuperTypes


Inheritance Hierarchy

Inheritance Hierarchy
Inheritance Hierarchy
Eco.FrameworkImpl.Ocl.Ocl_and


Inheritance Hierarchy

Inheritance Hierarchy
Inheritance Hierarchy
Eco.FrameworkImpl.Ocl.Ocl_Append


Inheritance Hierarchy

Inheritance Hierarchy
Inheritance Hierarchy
Eco.FrameworkImpl.Ocl.Ocl__ListCopier
    Eco.FrameworkImpl.Ocl.Ocl_AsBag


Inheritance Hierarchy

Inheritance Hierarchy
Inheritance Hierarchy
Eco.FrameworkImpl.Ocl.Ocl__ListCopier
    Eco.FrameworkImpl.Ocl.Ocl_AsOrderedSet


Inheritance Hierarchy

Inheritance Hierarchy
Inheritance Hierarchy
Eco.FrameworkImpl.Ocl.Ocl__ListCopier
    Eco.FrameworkImpl.Ocl.Ocl_AsSequence


Inheritance Hierarchy

Inheritance Hierarchy
Inheritance Hierarchy
Eco.FrameworkImpl.Ocl.Ocl__ListCopier
    Eco.FrameworkImpl.Ocl.Ocl_AsSet


Inheritance Hierarchy

Inheritance Hierarchy
Inheritance Hierarchy
Eco.FrameworkImpl.Ocl.Ocl_AssociationEnds


Inheritance Hierarchy

Inheritance Hierarchy
Inheritance Hierarchy
Eco.FrameworkImpl.Ocl.Ocl_asString


Inheritance Hierarchy

Inheritance Hierarchy
Inheritance Hierarchy
Eco.FrameworkImpl.Ocl.Ocl_at


Inheritance Hierarchy

Inheritance Hierarchy
Inheritance Hierarchy
Eco.FrameworkImpl.Ocl.Ocl_AtTime


Inheritance Hierarchy

Inheritance Hierarchy
Inheritance Hierarchy
Eco.FrameworkImpl.Ocl.Ocl_Attributes


Inheritance Hierarchy

Inheritance Hierarchy
Inheritance Hierarchy
Eco.FrameworkImpl.Ocl.Ocl_TupleOperation
    Eco.FrameworkImpl.Ocl.Ocl_collect


Inheritance Hierarchy

Inheritance Hierarchy
Inheritance Hierarchy
Eco.FrameworkImpl.Ocl.Ocl_concat


Inheritance Hierarchy

Inheritance Hierarchy
Inheritance Hierarchy
Eco.FrameworkImpl.Ocl.Ocl_Constraints


Inheritance Hierarchy

Inheritance Hierarchy
Inheritance Hierarchy
Eco.FrameworkImpl.Ocl.Ocl_Count


Inheritance Hierarchy

Inheritance Hierarchy
Inheritance Hierarchy
Eco.FrameworkImpl.Ocl.Ocl_Create


Inheritance Hierarchy

Inheritance Hierarchy
Inheritance Hierarchy
Eco.FrameworkImpl.Ocl.Ocl_Delete


Inheritance Hierarchy

Inheritance Hierarchy
Inheritance Hierarchy
Eco.FrameworkImpl.Ocl.Ocl_difference


Inheritance Hierarchy

Inheritance Hierarchy
Inheritance Hierarchy
Eco.FrameworkImpl.Ocl.Ocl_Div


Inheritance Hierarchy

Inheritance Hierarchy
Inheritance Hierarchy
Eco.FrameworkImpl.Ocl.Ocl_EmptyList


Inheritance Hierarchy

Inheritance Hierarchy
Inheritance Hierarchy
Eco.FrameworkImpl.Ocl.Ocl_AbstractCompare
    Eco.FrameworkImpl.Ocl.Ocl_Equal


Inheritance Hierarchy

Inheritance Hierarchy
Inheritance Hierarchy
Eco.FrameworkImpl.Ocl.Ocl_excluding


Inheritance Hierarchy

Inheritance Hierarchy
Inheritance Hierarchy
Eco.FrameworkImpl.Ocl.Ocl_Existing


Inheritance Hierarchy

Inheritance Hierarchy
Inheritance Hierarchy
Eco.FrameworkImpl.Ocl.Ocl_Exists


Inheritance Hierarchy

Inheritance Hierarchy
Inheritance Hierarchy
Eco.FrameworkImpl.Ocl.Ocl_ExternalId


Inheritance Hierarchy

Inheritance Hierarchy
Inheritance Hierarchy
Eco.FrameworkImpl.Ocl.Ocl_FilterOnType


Inheritance Hierarchy

Inheritance Hierarchy
Inheritance Hierarchy
Eco.FrameworkImpl.Ocl.Ocl_first


Inheritance Hierarchy

Inheritance Hierarchy
Inheritance Hierarchy
Eco.FrameworkImpl.Ocl.Ocl_ForAll


Inheritance Hierarchy

Inheritance Hierarchy
Inheritance Hierarchy
Eco.FrameworkImpl.Ocl.Ocl_Format


Inheritance Hierarchy

Inheritance Hierarchy
Inheritance Hierarchy
Eco.FrameworkImpl.Ocl.Ocl_FormatDateTime


Inheritance Hierarchy

Inheritance Hierarchy
Inheritance Hierarchy
Eco.FrameworkImpl.Ocl.Ocl_Greater


Inheritance Hierarchy

Inheritance Hierarchy
Inheritance Hierarchy
Eco.FrameworkImpl.Ocl.Ocl_GreaterEQ


Inheritance Hierarchy

Inheritance Hierarchy
Inheritance Hierarchy
Eco.FrameworkImpl.Ocl.Ocl_TupleOperation
    Eco.FrameworkImpl.Ocl.Ocl_GroupBy


Inheritance Hierarchy

Inheritance Hierarchy
Inheritance Hierarchy
Eco.FrameworkImpl.Ocl.Ocl_if


Inheritance Hierarchy

Inheritance Hierarchy
Inheritance Hierarchy
Eco.FrameworkImpl.Ocl.Ocl_implies


Inheritance Hierarchy

Inheritance Hierarchy
Inheritance Hierarchy
Eco.FrameworkImpl.Ocl.Ocl_includes


Inheritance Hierarchy

Inheritance Hierarchy
Inheritance Hierarchy
Eco.FrameworkImpl.Ocl.Ocl_IncludesAll


Inheritance Hierarchy

Inheritance Hierarchy
Inheritance Hierarchy
Eco.FrameworkImpl.Ocl.Ocl_Including


Inheritance Hierarchy

Inheritance Hierarchy
Inheritance Hierarchy
Eco.FrameworkImpl.Ocl.Ocl_IndexOf


Inheritance Hierarchy

Inheritance Hierarchy
Inheritance Hierarchy
Eco.FrameworkImpl.Ocl.Ocl_Intersection


Inheritance Hierarchy

Inheritance Hierarchy
Inheritance Hierarchy
Eco.FrameworkImpl.Ocl.Ocl_isEmpty


Inheritance Hierarchy

Inheritance Hierarchy
Inheritance Hierarchy
Eco.FrameworkImpl.Ocl.Ocl_isNull


Inheritance Hierarchy

Inheritance Hierarchy
Inheritance Hierarchy
Eco.FrameworkImpl.Ocl.Ocl_last


Inheritance Hierarchy

Inheritance Hierarchy
Inheritance Hierarchy
Eco.FrameworkImpl.Ocl.OclPsOperationBase
    Eco.FrameworkImpl.Ocl.Ocl_Length


Inheritance Hierarchy

Inheritance Hierarchy
Inheritance Hierarchy
Eco.FrameworkImpl.Ocl.Ocl_Less


Inheritance Hierarchy

Inheritance Hierarchy
Inheritance Hierarchy
Eco.FrameworkImpl.Ocl.Ocl_LessEQ


Inheritance Hierarchy

Inheritance Hierarchy
Inheritance Hierarchy
Eco.FrameworkImpl.Ocl.Ocl_Let


Inheritance Hierarchy

Inheritance Hierarchy
Inheritance Hierarchy
Eco.FrameworkImpl.Ocl.Ocl_ListAdd


Inheritance Hierarchy

Inheritance Hierarchy
Inheritance Hierarchy
Eco.FrameworkImpl.Ocl.Ocl_ListClear


Inheritance Hierarchy

Inheritance Hierarchy
Inheritance Hierarchy
Eco.FrameworkImpl.Ocl.Ocl_ListRemove


Inheritance Hierarchy

Inheritance Hierarchy
Inheritance Hierarchy
Eco.FrameworkImpl.Ocl.Ocl_ListRemoveAt


Inheritance Hierarchy

Inheritance Hierarchy
Inheritance Hierarchy
Eco.FrameworkImpl.Ocl.Ocl_MaxLength


Inheritance Hierarchy

Inheritance Hierarchy
Inheritance Hierarchy
Eco.FrameworkImpl.Ocl.Ocl_Mod


Inheritance Hierarchy

Inheritance Hierarchy
Inheritance Hierarchy
Eco.FrameworkImpl.Ocl.Ocl_not


Inheritance Hierarchy

Inheritance Hierarchy
Inheritance Hierarchy
Eco.FrameworkImpl.Ocl.Ocl_NotEmpty


Inheritance Hierarchy

Inheritance Hierarchy
Inheritance Hierarchy
Eco.FrameworkImpl.Ocl.Ocl_AbstractCompare
    Eco.FrameworkImpl.Ocl.Ocl_NotEqual


Inheritance Hierarchy

Inheritance Hierarchy
Inheritance Hierarchy
Eco.FrameworkImpl.Ocl.Ocl_ObjectFromExternalId


Inheritance Hierarchy

Inheritance Hierarchy
Inheritance Hierarchy
Eco.FrameworkImpl.Ocl.Ocl_ObjectTimeStamp


Inheritance Hierarchy

Inheritance Hierarchy
Inheritance Hierarchy
Eco.FrameworkImpl.Ocl.Ocl_OclAsType


Inheritance Hierarchy

Inheritance Hierarchy
Inheritance Hierarchy
Eco.FrameworkImpl.Ocl.Ocl_oclGetStates


Inheritance Hierarchy

Inheritance Hierarchy
Inheritance Hierarchy
Eco.FrameworkImpl.Ocl.Ocl_oclGetTriggers


Inheritance Hierarchy

Inheritance Hierarchy
Inheritance Hierarchy
Eco.FrameworkImpl.Ocl.Ocl_oclIsInState


Inheritance Hierarchy

Inheritance Hierarchy
Inheritance Hierarchy
Eco.FrameworkImpl.Ocl.Ocl_oclIsKindOf


Inheritance Hierarchy

Inheritance Hierarchy
Inheritance Hierarchy
Eco.FrameworkImpl.Ocl.Ocl_OclIsTypeOf


Inheritance Hierarchy

Inheritance Hierarchy
Inheritance Hierarchy
Eco.FrameworkImpl.Ocl.Ocl_OclType


Inheritance Hierarchy

Inheritance Hierarchy
Inheritance Hierarchy
Eco.FrameworkImpl.Ocl.Ocl_or


Inheritance Hierarchy

Inheritance Hierarchy
Inheritance Hierarchy
Eco.FrameworkImpl.Ocl.Ocl_AbstractOrder
    Eco.FrameworkImpl.Ocl.Ocl_orderby


Inheritance Hierarchy

Inheritance Hierarchy
Inheritance Hierarchy
Eco.FrameworkImpl.Ocl.Ocl_AbstractOrder
    Eco.FrameworkImpl.Ocl.Ocl_orderDescending


Inheritance Hierarchy

Inheritance Hierarchy
Inheritance Hierarchy
Eco.FrameworkImpl.Ocl.Ocl_OrderGeneric


Inheritance Hierarchy

Inheritance Hierarchy
Inheritance Hierarchy
Eco.FrameworkImpl.Ocl.Ocl_Pad


Inheritance Hierarchy

Inheritance Hierarchy
Inheritance Hierarchy
Eco.FrameworkImpl.Ocl.Ocl_PostPad


Inheritance Hierarchy

Inheritance Hierarchy
Inheritance Hierarchy
Eco.FrameworkImpl.Ocl.Ocl_Prepend


Inheritance Hierarchy

Inheritance Hierarchy
Inheritance Hierarchy
Eco.FrameworkImpl.Ocl.Ocl_RegExpMatch


Inheritance Hierarchy

Inheritance Hierarchy
Inheritance Hierarchy
Eco.FrameworkImpl.Ocl.Ocl_reject


Inheritance Hierarchy

Inheritance Hierarchy
Inheritance Hierarchy
Eco.FrameworkImpl.Ocl.Ocl_safeCast


Inheritance Hierarchy

Inheritance Hierarchy
Inheritance Hierarchy
Eco.FrameworkImpl.Ocl.Ocl_Select


Inheritance Hierarchy

Inheritance Hierarchy
Inheritance Hierarchy
Eco.FrameworkImpl.Ocl.Ocl_Size


Inheritance Hierarchy

Inheritance Hierarchy
Inheritance Hierarchy
Eco.FrameworkImpl.Ocl.Ocl_SqlLikeCommon
    Eco.FrameworkImpl.Ocl.Ocl_SQLLike


Inheritance Hierarchy

Inheritance Hierarchy
Inheritance Hierarchy
Eco.FrameworkImpl.Ocl.Ocl_SqlLikeCommon
    Eco.FrameworkImpl.Ocl.Ocl_SQLLikeCaseInsensitive


Inheritance Hierarchy

Inheritance Hierarchy
Inheritance Hierarchy
Eco.FrameworkImpl.Ocl.Ocl_SqlLikeCommon
    Eco.FrameworkImpl.Ocl.Ocl_SQLLike
    Eco.FrameworkImpl.Ocl.Ocl_SQLLikeCaseInsensitive


Inheritance Hierarchy

Inheritance Hierarchy
Inheritance Hierarchy
Eco.FrameworkImpl.Ocl.Ocl_StatementSequence


Inheritance Hierarchy

Inheritance Hierarchy
Inheritance Hierarchy
Eco.FrameworkImpl.Ocl.Ocl_StrToDate


Inheritance Hierarchy

Inheritance Hierarchy
Inheritance Hierarchy
Eco.FrameworkImpl.Ocl.Ocl_StrToDateTime


Inheritance Hierarchy

Inheritance Hierarchy
Inheritance Hierarchy
Eco.FrameworkImpl.Ocl.Ocl_strToInt


Inheritance Hierarchy

Inheritance Hierarchy
Inheritance Hierarchy
Eco.FrameworkImpl.Ocl.Ocl_StrToTime


Inheritance Hierarchy

Inheritance Hierarchy
Inheritance Hierarchy
Eco.FrameworkImpl.Ocl.Ocl_SubSequence


Inheritance Hierarchy

Inheritance Hierarchy
Inheritance Hierarchy
Eco.FrameworkImpl.Ocl.Ocl_SubString


Inheritance Hierarchy

Inheritance Hierarchy
Inheritance Hierarchy
Eco.FrameworkImpl.Ocl.Ocl_SuperTypes


Inheritance Hierarchy

Inheritance Hierarchy
Inheritance Hierarchy
Eco.FrameworkImpl.Ocl.Ocl_SymmetricDifference


Inheritance Hierarchy

Inheritance Hierarchy
Inheritance Hierarchy
Eco.FrameworkImpl.Ocl.Ocl_TaggedValue


Inheritance Hierarchy

Inheritance Hierarchy
Inheritance Hierarchy
Eco.FrameworkImpl.Ocl.Ocl_TimeStampToTime


Inheritance Hierarchy

Inheritance Hierarchy
Inheritance Hierarchy
Eco.FrameworkImpl.Ocl.Ocl_TimeToTimeStamp


Inheritance Hierarchy

Inheritance Hierarchy
Inheritance Hierarchy
Eco.FrameworkImpl.Ocl.OclPsOperationBase
    Eco.FrameworkImpl.Ocl.Ocl_toLower


Inheritance Hierarchy

Inheritance Hierarchy
Inheritance Hierarchy
Eco.FrameworkImpl.Ocl.OclPsOperationBase
    Eco.FrameworkImpl.Ocl.Ocl_ToUpper


Inheritance Hierarchy

Inheritance Hierarchy
Inheritance Hierarchy
Eco.FrameworkImpl.Ocl.Ocl_TupleOperation
    Eco.FrameworkImpl.Ocl.Ocl_collect
    Eco.FrameworkImpl.Ocl.Ocl_GroupBy


Inheritance Hierarchy

Inheritance Hierarchy
Inheritance Hierarchy
Eco.FrameworkImpl.Ocl.Ocl_TypeName


Inheritance Hierarchy

Inheritance Hierarchy
Inheritance Hierarchy
Eco.FrameworkImpl.Ocl.Ocl_union


Inheritance Hierarchy

Inheritance Hierarchy
Inheritance Hierarchy
Eco.FrameworkImpl.Ocl.Ocl_xor


Inheritance Hierarchy

Inheritance Hierarchy
Inheritance Hierarchy
Eco.FrameworkImpl.Ocl.OclPsOperationBase
    Eco.FrameworkImpl.Ocl.Ocl_Length
    Eco.FrameworkImpl.Ocl.Ocl_toLower
    Eco.FrameworkImpl.Ocl.Ocl_ToUpper


Inheritance Hierarchy

Inheritance Hierarchy
Inheritance Hierarchy
Eco.FrameworkImpl.Ocl.SymbolImplementationUtils


Inheritance Hierarchy

Inheritance Hierarchy
Inheritance Hierarchy
Eco.FrameworkImpl.Ocl.TBoldDefaultActionLanguageSymbolFactory


Inheritance Hierarchy

Inheritance Hierarchy
Inheritance Hierarchy
Eco.FrameworkImpl.Ocl.TBoldDefaultOclPsSymbolFactory


Inheritance Hierarchy

Inheritance Hierarchy
Inheritance Hierarchy
Eco.FrameworkImpl.Ocl.TBoldDefaultOclSymbolFactory


Inheritance Hierarchy

Inheritance Hierarchy
Inheritance Hierarchy
Eco.FrameworkImpl.OptimisticLocking.OptimisticLockHandler


Inheritance Hierarchy

Inheritance Hierarchy
Inheritance Hierarchy
Eco.Handles.IColumn
    Eco.Handles.AbstractColumn
        Eco.Handles.EventDerivedColumn
        Eco.Handles.OclColumn


Inheritance Hierarchy

Inheritance Hierarchy
Inheritance Hierarchy
Eco.Handles.AbstractColumnConverter
    Eco.Handles.ColumnConverter
    Eco.Handles.EventDerivedColumnConverter
    Eco.Handles.OclColumnConverter


Inheritance Hierarchy

Inheritance Hierarchy
Inheritance Hierarchy
Eco.Handles.IElementHandle
Eco.Handles.INotifyOnIdle
    Eco.Handles.ElementHandle
    Eco.Handles.IRooted
        Eco.Handles.RootedHandle
            Eco.Handles.AbstractCursorHandle
                Eco.Handles.CurrencyManagerHandle
                Eco.Handles.CursorHandle


Inheritance Hierarchy

Inheritance Hierarchy
Inheritance Hierarchy
Eco.Handles.IRenderingContext
    Eco.Handles.ITuplePropertyRenderingContext
        Eco.Handles.AbstractRenderedTuple
            Eco.Handles.RenderedTestTuple
            Eco.Handles.RenderedTuple


Inheritance Hierarchy

Inheritance Hierarchy
Inheritance Hierarchy
Eco.Handles.AbstractRenderedTupleProperty
    Eco.Handles.RenderedTupleListProperty
    Eco.Handles.RenderedTupleProperty
    Eco.Handles.RenderedTupleTestProperty


Inheritance Hierarchy

Inheritance Hierarchy
Inheritance Hierarchy
Eco.Handles.IColumn
    Eco.Handles.AbstractColumn
    Eco.Handles.IHasEditableExpression
        Eco.Handles.OclColumn
            Eco.Handles.Column


Inheritance Hierarchy

Inheritance Hierarchy
Inheritance Hierarchy
Eco.Handles.ColumnCollection


Inheritance Hierarchy

Inheritance Hierarchy
Inheritance Hierarchy
Eco.Handles.ColumnConstants


Inheritance Hierarchy

Inheritance Hierarchy
Inheritance Hierarchy
Eco.Handles.AbstractColumnConverter
    Eco.Handles.ColumnConverter


Inheritance Hierarchy

Inheritance Hierarchy
Inheritance Hierarchy
Eco.Handles.IElementHandle
Eco.Handles.INotifyOnIdle
    Eco.Handles.ElementHandle
    Eco.Handles.IRooted
        Eco.Handles.RootedHandle
            Eco.Handles.AbstractCursorHandle
                Eco.Handles.CurrencyManagerHandle


Inheritance Hierarchy

Inheritance Hierarchy
Inheritance Hierarchy
Eco.Handles.IElementHandle
Eco.Handles.INotifyOnIdle
    Eco.Handles.ElementHandle
    Eco.Handles.IRooted
        Eco.Handles.RootedHandle
            Eco.Handles.AbstractCursorHandle
                Eco.Handles.CursorHandle


Inheritance Hierarchy

Inheritance Hierarchy
Inheritance Hierarchy
Eco.Handles.EcoSpaceBase
    Eco.Handles.EcoSpace
        Eco.Handles.DefaultEcoSpace
            Eco.Handles.PrototypeEcoSpace


Example

Example

This method will install the ExternalIdService implementation that uses the name of the class rather than the internal index of the class

Copy Code
protected override ExternalIdServiceBase CreateExternalIdService(IEcoTypeSystem typeSystem)
{
    return new ExternalIdServiceImpl_Name(typeSystem);
}


Inheritance Hierarchy

Inheritance Hierarchy
Inheritance Hierarchy
Eco.Handles.DeriveEventArgs


Inheritance Hierarchy

Inheritance Hierarchy
Inheritance Hierarchy
Eco.Handles.DescriptorFactory


Inheritance Hierarchy

Inheritance Hierarchy
Inheritance Hierarchy
Eco.Handles.DisplayQueue


Inheritance Hierarchy

Inheritance Hierarchy
Inheritance Hierarchy
Eco.Handles.EcoSpaceBase
    Eco.Handles.EcoSpace
        Eco.Handles.DefaultEcoSpace


Inheritance Hierarchy

Inheritance Hierarchy
Inheritance Hierarchy
Eco.Handles.EcoSpaceBase
    Eco.Handles.EcoSpace


Inheritance Hierarchy

Inheritance Hierarchy
Inheritance Hierarchy
Eco.Handles.EcoSpaceSerializer


Inheritance Hierarchy

Inheritance Hierarchy
Inheritance Hierarchy
Eco.Handles.IElementHandle
Eco.Handles.INotifyOnIdle
    Eco.Handles.ElementHandle
        Eco.Handles.RootedHandle
        Eco.Handles.RootHandle


Related Topics

Related Topics
Related Topics

AddExternalId, AddDefaultProperties, Columns, MemberVisibility


Related Topics

Related Topics
Related Topics

AddExternalId, AddDefaultNestings, Columns, MemberVisibility


Related Topics

Related Topics
Related Topics

Eco.Services.IExternalIdService


Related Topics

Related Topics
Related Topics

Columns


Related Topics

Related Topics
Related Topics

AddDefaultProperties, AddDefaultNestings, AddSelfColumn, MemberVisibility


Related Topics

Related Topics
Related Topics

AddExternalId, AddDefaultNestings, Columns, MemberVisibility, Nestings


Example 1

Example 1
Copy Code
procedure TWinForm.ExpressionHandle1_DeriveValue(sender: object; e: Eco.Handles.DeriveEventArgs);
var
CurrentPerson: Person;
Age: Integer;
DateOfBirthProperty: IProperty;
begin
       if e.Name = 'Age' then
       begin
       CurrentPerson := e.RootElement.AsObject as Person;
       Age := (DateTime.Now.Year - 1) - CurrentPerson.DateOfBirth.Year;
       if (DateTime.Now.Month >= CurrentPerson.DateOfBirth.Month) and
         (DateTime.Now.Day >= CurrentPerson.DateOfBirth.Day) then
         Inc(Age);
       e.ResultElement := EcoSpace.VariableFactoryService.CreateConstant(Age);
       if e.ValueChangeSubscriber <> nil then
       begin
         DateOfBirthProperty := CurrentPerson.AsIObject.Properties.GetByLoopbackIndex(Person.Eco_LoopbackIndices.DateOfBirth);
         DateOfBirthProperty.SubscribeToValue(e.ValueChangeSubscriber);
       end;
     end else
       raise InvalidOperationException.Create('No derivation code for ' + e.Name);
   end;


Example 2

Example 2
Copy Code
private void ExpressionHandle1_DeriveValue(object sender, Eco.Handles.DeriveEventArgs e)
{
       switch (e.Name)
       {
           case "Age":
           {
               Person currentPerson = e.RootElement.AsObject as Person;
               int age = (DateTime.Now.Year - 1) - currentPerson.DateOfBirth.Year;
               if (DateTime.Now.Month >= currentPerson.DateOfBirth.Month && (DateTime.Now.Day >= currentPerson.DateOfBirth.Day)
                   age = age++;
               e.ResultElement = EcoSpace.VariableFactoryService.CreateConstant(age);
               if (e.ValueChangeSubscriber != null)
               {
                   IProperty dateOfBirthProperty = durrentPerson.AsIObject.Properties.GetByLoopbackIndex(Person.Eco_LoopbackIndices.DateOfBirth);
                   dateOfBirthProperty.SubscribeToValue(e.ValueChangeSubscriber);
               }
           }

           default:
               throw new InvalidOperationException("No derivation code for " + e.Name);
       }
}


Related Topics

Related Topics
Related Topics

EventDerivedColumn, ReverseDeriveValue


Related Topics

Related Topics
Related Topics

AddDefaultNestings, AddDefaultProperties, Columns


Related Topics

Related Topics
Related Topics

AddDefaultNestings, GetList


Example 1

Example 1
Copy Code
procedure TWinForm.ExpressionHandle1_ReverseDeriveValue(sender: object; e: Eco.Handles.ReverseDeriveEventArgs);
var
  NewAge: Integer;
  NewYearOfBirth: Integer;
  CurrentPerson: Person;
begin
  if e.Name = 'Age' then
  begin
    NewAge := Convert.ToInt16(e.Value);
    CurrentPerson := e.RootElement.AsObject as Person;
    NewYearOfBirth := (DateTime.Now.Year - 1) - NewAge;
    if (DateTime.Now.Month >= CurrentPerson.DateOfBirth.Month) and
      (DateTime.Now.Day >= CurrentPerson.DateOfBirth.Day) then
      Inc(NewYearOfBirth);
    CurrentPerson.DateOfBirth := DateTime.Create(NewYearOfBirth, CurrentPerson.DateOfBirth.Month, CurrentPerson.DateOfBirth.Day);
  end else
    raise InvalidOperationException.Create('No reverse derivation code for ' + e.Name);
end;


Example 2

Example 2
Copy Code
private void ExpressionHandle1_ReverseDeriveValue(sender: object; e: Eco.Handles.ReverseDeriveEventArgs);
   {
       switch (e.Name)
       {
           case "Age":
           {
               int newAge = Convert.ToInt16(e.Value);
               Person currentPerson = e.RootElement.AsObject as Person;
               int newYearOfBirth = (DateTime.Now.Year - 1) - newAge;
               if (DateTime.Now.Month >= currentPerson.DateOfBirth.Month &&
                   DateTime.Now.Day >= currentPerson.DateOfBirth.Day)
                   Inc(newYearOfBirth);
               currentPerson.DateOfBirth = new DateTime(newYearOfBirth, currentPerson.DateOfBirth.Month, currentPerson.DateOfBirth.Day);
           }

           default:
               throw new InvalidOperationException("No reverse derivation code for " + e.Name);
       }
}


Related Topics

Related Topics
Related Topics

DeriveValue, EventDerivedColumn


Related Topics

Related Topics
Related Topics

SubscribeToEffectiveEnabled


Inheritance Hierarchy

Inheritance Hierarchy
Inheritance Hierarchy
Eco.Handles.IColumn
    Eco.Handles.AbstractColumn
    Eco.Handles.IHasTypeSystem
        Eco.Handles.EventDerivedColumn


Inheritance Hierarchy

Inheritance Hierarchy
Inheritance Hierarchy
Eco.Handles.AbstractColumnConverter
    Eco.Handles.EventDerivedColumnConverter


Related Topics

Related Topics
Related Topics

ExpressionHandle.Expression, OclPSHandle


Inheritance Hierarchy

Inheritance Hierarchy
Inheritance Hierarchy
Eco.Handles.IElementHandle
Eco.Handles.INotifyOnIdle
    Eco.Handles.ElementHandle
    Eco.Handles.IRooted
        Eco.Handles.RootedHandle
        Eco.Handles.IHasEditableExpression
            Eco.Handles.ExpressionHandle


Example

Example
Copy Code
           Person.allInstances->select(firstName = 'Pete')->first
Copy Code
           self.homeResidence.address


Inheritance Hierarchy

Inheritance Hierarchy
Inheritance Hierarchy
Eco.Handles.IRenderingContext
    Eco.Handles.ITupleRenderingContext
        Eco.Handles.ITupleListRenderingContext
        Eco.Handles.INotifyOnIdle
            Eco.Handles.HandleAdapter


Inheritance Hierarchy

Inheritance Hierarchy
Inheritance Hierarchy
Eco.Handles.HandlesStringRes


Inheritance Hierarchy

Inheritance Hierarchy
Inheritance Hierarchy
Eco.Handles.HandleUtils


Inheritance Hierarchy

Inheritance Hierarchy
Inheritance Hierarchy
Eco.Handles.IColumn
    Eco.Handles.AbstractColumn


Inheritance Hierarchy

Inheritance Hierarchy
Inheritance Hierarchy
Eco.Handles.IEcoSpaceTypeLookupService


Inheritance Hierarchy

Inheritance Hierarchy
Inheritance Hierarchy
Eco.Handles.IElementHandle
    Eco.Handles.ElementHandle


Inheritance Hierarchy

Inheritance Hierarchy
Inheritance Hierarchy
Eco.Handles.IHasEditableExpression
    Eco.Handles.ExpressionHandle
    Eco.Handles.OclColumn
    Eco.Handles.OclPSHandle


Inheritance Hierarchy

Inheritance Hierarchy
Inheritance Hierarchy
Eco.Handles.IHasSecondEditableExpression


Inheritance Hierarchy

Inheritance Hierarchy
Inheritance Hierarchy
Eco.Handles.IHasTypeSystem
    Eco.Handles.EventDerivedColumn
    Eco.Handles.Nesting
    Eco.Handles.RootHandle


Inheritance Hierarchy

Inheritance Hierarchy
Inheritance Hierarchy
Eco.Handles.IMaxLengthSupportProvider


Inheritance Hierarchy

Inheritance Hierarchy
Inheritance Hierarchy
Eco.Handles.INesting
    Eco.Handles.Nesting


Inheritance Hierarchy

Inheritance Hierarchy
Inheritance Hierarchy
Eco.Handles.INestingProvider
    Eco.Handles.NestingCollection


Inheritance Hierarchy

Inheritance Hierarchy
Inheritance Hierarchy
Eco.Handles.INotifyOnIdle
    Eco.Handles.ElementHandle
    Eco.Handles.HandleAdapter


Inheritance Hierarchy

Inheritance Hierarchy
Inheritance Hierarchy
Eco.Handles.IOclVariables
    Eco.Handles.OclVariables


Inheritance Hierarchy

Inheritance Hierarchy
Inheritance Hierarchy
Eco.Handles.IRenderingContext
    Eco.Handles.ITuplePropertyRenderingContext
    Eco.Handles.ITupleRenderingContext


Inheritance Hierarchy

Inheritance Hierarchy
Inheritance Hierarchy
Eco.Handles.IReorderableList
    Eco.Handles.RenderedList


Inheritance Hierarchy

Inheritance Hierarchy
Inheritance Hierarchy
Eco.Handles.IRooted
    Eco.Handles.RootedHandle


Inheritance Hierarchy

Inheritance Hierarchy
Inheritance Hierarchy
Eco.Handles.IStaticContextFromObject


Inheritance Hierarchy

Inheritance Hierarchy
Inheritance Hierarchy
Eco.Handles.ItemStaticContext


Inheritance Hierarchy

Inheritance Hierarchy
Inheritance Hierarchy
Eco.Handles.IRenderingContext
    Eco.Handles.ITupleRenderingContext
        Eco.Handles.ITupleListRenderingContext
            Eco.Handles.HandleAdapter
            Eco.Handles.RenderedTupleListProperty


Inheritance Hierarchy

Inheritance Hierarchy
Inheritance Hierarchy
Eco.Handles.IRenderingContext
    Eco.Handles.ITuplePropertyRenderingContext
        Eco.Handles.AbstractRenderedTuple


Inheritance Hierarchy

Inheritance Hierarchy
Inheritance Hierarchy
Eco.Handles.IRenderingContext
    Eco.Handles.ITupleRenderingContext
        Eco.Handles.ITupleListRenderingContext
        Eco.Handles.TupleContext


Inheritance Hierarchy

Inheritance Hierarchy
Inheritance Hierarchy
Eco.Handles.MaxLengthSupportFunctions


Example

Example

This code registers the class MyMaxLengthSupportProvider to handle Textbox components

Copy Code
MaxLengthSupportFunctions.RegisterMaxLengthSupportProvider(
    new MyMaxLengthSupportProvider(),
    typeof(Textbox));


Inheritance Hierarchy

Inheritance Hierarchy
Inheritance Hierarchy
Eco.Handles.MaxLengthSupportLibraryAttribute


Inheritance Hierarchy

Inheritance Hierarchy
Inheritance Hierarchy
Eco.Handles.MaxLengthSupportProviderAttribute


Inheritance Hierarchy

Inheritance Hierarchy
Inheritance Hierarchy
Eco.Handles.NameValidator


Inheritance Hierarchy

Inheritance Hierarchy
Inheritance Hierarchy
Eco.Handles.IHasTypeSystem
Eco.Handles.INesting
    Eco.Handles.Nesting


Inheritance Hierarchy

Inheritance Hierarchy
Inheritance Hierarchy
Eco.Handles.NestingConverter


Inheritance Hierarchy

Inheritance Hierarchy
Inheritance Hierarchy
Eco.Handles.AbstractColumnConverter
    Eco.Handles.OclColumnConverter


Inheritance Hierarchy

Inheritance Hierarchy
Inheritance Hierarchy
Eco.Handles.OclEditorResult


Inheritance Hierarchy

Inheritance Hierarchy
Inheritance Hierarchy
Eco.Handles.OclEditorSupport


Related Topics

Related Topics
Related Topics

OclPSHandle.Expression, ExpressionHandle


Inheritance Hierarchy

Inheritance Hierarchy
Inheritance Hierarchy
Eco.Handles.IElementHandle
Eco.Handles.INotifyOnIdle
    Eco.Handles.ElementHandle
    Eco.Handles.IRooted
        Eco.Handles.RootedHandle
        Eco.Handles.IHasEditableExpression
            Eco.Handles.OclPSHandle


Related Topics

Related Topics
Related Topics

Expression


Example

Example
Copy Code
           Person.allInstances->select(firstName = 'Pete')->first
Copy Code
           self.homeResidence.tenants


Related Topics

Related Topics
Related Topics

Execute


Related Topics

Related Topics
Related Topics

Offset


Related Topics

Related Topics
Related Topics

MaxAnswers


Inheritance Hierarchy

Inheritance Hierarchy
Inheritance Hierarchy
Eco.Handles.OclVariable


Inheritance Hierarchy

Inheritance Hierarchy
Inheritance Hierarchy
Eco.Handles.OclVariableCollection


Inheritance Hierarchy

Inheritance Hierarchy
Inheritance Hierarchy
Eco.Handles.PropertyComparer


Inheritance Hierarchy

Inheritance Hierarchy
Inheritance Hierarchy
Eco.Handles.IElementHandle
Eco.Handles.INotifyOnIdle
    Eco.Handles.ElementHandle
    Eco.Handles.IHasTypeSystem
        Eco.Handles.RootHandle
            Eco.Handles.ReferenceHandle


Related Topics

Related Topics
Related Topics

Eco.ObjectRepresentation.IElement, Eco.ObjectRepresentation.IElementProvider, Eco.ObjectRepresentation.IEcoObject


Inheritance Hierarchy

Inheritance Hierarchy
Inheritance Hierarchy
Eco.Handles.IRenderingContext
    Eco.Handles.ITuplePropertyRenderingContext
        Eco.Handles.AbstractRenderedTuple
            Eco.Handles.RenderedTestTuple


Inheritance Hierarchy

Inheritance Hierarchy
Inheritance Hierarchy
Eco.Handles.IRenderingContext
    Eco.Handles.ITuplePropertyRenderingContext
        Eco.Handles.AbstractRenderedTuple
            Eco.Handles.RenderedTuple


Inheritance Hierarchy

Inheritance Hierarchy
Inheritance Hierarchy
Eco.Handles.RenderedTupleDescriptor


Inheritance Hierarchy

Inheritance Hierarchy
Inheritance Hierarchy
Eco.Handles.RenderedTupleFilter


Inheritance Hierarchy

Inheritance Hierarchy
Inheritance Hierarchy
Eco.Handles.IRenderingContext
    Eco.Handles.ITupleRenderingContext
        Eco.Handles.ITupleListRenderingContext
        Eco.Handles.AbstractRenderedTupleProperty
            Eco.Handles.RenderedTupleListProperty


Inheritance Hierarchy

Inheritance Hierarchy
Inheritance Hierarchy
Eco.Handles.AbstractRenderedTupleProperty
    Eco.Handles.RenderedTupleProperty


Inheritance Hierarchy

Inheritance Hierarchy
Inheritance Hierarchy
Eco.Handles.RenderedTuplePropertyDescriptor


Inheritance Hierarchy

Inheritance Hierarchy
Inheritance Hierarchy
Eco.Handles.AbstractRenderedTupleProperty
    Eco.Handles.RenderedTupleTestProperty


Inheritance Hierarchy

Inheritance Hierarchy
Inheritance Hierarchy
Eco.Handles.ReverseDeriveEventArgs


Inheritance Hierarchy

Inheritance Hierarchy
Inheritance Hierarchy
Eco.Handles.IElementHandle
Eco.Handles.INotifyOnIdle
    Eco.Handles.ElementHandle
    Eco.Handles.IRooted
        Eco.Handles.RootedHandle
            Eco.Handles.AbstractCursorHandle
            Eco.Handles.ExpressionHandle
            Eco.Handles.OclPSHandle


Inheritance Hierarchy

Inheritance Hierarchy
Inheritance Hierarchy
Eco.Handles.IElementHandle
Eco.Handles.INotifyOnIdle
    Eco.Handles.ElementHandle
    Eco.Handles.IHasTypeSystem
        Eco.Handles.RootHandle
            Eco.Handles.ReferenceHandle
            Eco.Handles.VariableHandle


Related Topics

Related Topics
Related Topics

EcoSpaceTypeName


Related Topics

Related Topics
Related Topics

Eco.Handles.DefaultEcoSpace.RegisterEcoService


Inheritance Hierarchy

Inheritance Hierarchy
Inheritance Hierarchy
Eco.Handles.IRenderingContext
    Eco.Handles.ITupleRenderingContext
        Eco.Handles.TupleContext


Inheritance Hierarchy

Inheritance Hierarchy
Inheritance Hierarchy
Eco.Handles.IElementHandle
Eco.Handles.INotifyOnIdle
    Eco.Handles.ElementHandle
    Eco.Handles.IHasTypeSystem
        Eco.Handles.RootHandle
            Eco.Handles.VariableHandle


Inheritance Hierarchy

Inheritance Hierarchy
Inheritance Hierarchy
Eco.Interfaces.InterfacesStringRes


Inheritance Hierarchy

Inheritance Hierarchy
Inheritance Hierarchy
Eco.Linq.EcoLinqExtender


Inheritance Hierarchy

Inheritance Hierarchy
Inheritance Hierarchy
Eco.Linq.EcoQuery


Inheritance Hierarchy

Inheritance Hierarchy
Inheritance Hierarchy
Eco.Linq.EcoQuery.OutEventArgs


Inheritance Hierarchy

Inheritance Hierarchy
Inheritance Hierarchy
Eco.Linq.ProviderException


Inheritance Hierarchy

Inheritance Hierarchy
Inheritance Hierarchy
Eco.Logging.EcoListener


Inheritance Hierarchy

Inheritance Hierarchy
Inheritance Hierarchy
Eco.Logging.EcoLogSwitches


Inheritance Hierarchy

Inheritance Hierarchy
Inheritance Hierarchy
Eco.Logging.EcoTraceCategories


Inheritance Hierarchy

Inheritance Hierarchy
Inheritance Hierarchy
Eco.Logging.IMessageDisplay


Inheritance Hierarchy

Inheritance Hierarchy
Inheritance Hierarchy
Eco.Logging.OclTraceSwitch


Inheritance Hierarchy

Inheritance Hierarchy
Inheritance Hierarchy
Eco.Logging.PMapperTraceSwitch


Inheritance Hierarchy

Inheritance Hierarchy
Inheritance Hierarchy
Eco.Logging.RegionTraceSwitch


Inheritance Hierarchy

Inheritance Hierarchy
Inheritance Hierarchy
Eco.Logging.SqlMetaTraceSwitch


Inheritance Hierarchy

Inheritance Hierarchy
Inheritance Hierarchy
Eco.Logging.SqlTraceSwitch


Inheritance Hierarchy

Inheritance Hierarchy
Inheritance Hierarchy
Eco.Logging.TraceEventArgs


Inheritance Hierarchy

Inheritance Hierarchy
Inheritance Hierarchy
Eco.Logging.ValidationTraceSwitch


Inheritance Hierarchy

Inheritance Hierarchy
Inheritance Hierarchy
Eco.MySql.FullTextSupport.FullTextIndexer


Inheritance Hierarchy

Inheritance Hierarchy
Inheritance Hierarchy
Eco.ObjectImplementation.IEcoList
    Eco.ObjectImplementation.EcoListShimBase
        Eco.ObjectImplementation.ObjectListAdapter


Inheritance Hierarchy

Inheritance Hierarchy
Inheritance Hierarchy
Eco.ObjectImplementation.IEcoList
    Eco.ObjectImplementation.EcoObjectListAdapter


Inheritance Hierarchy

Inheritance Hierarchy
Inheritance Hierarchy
Eco.ObjectImplementation.EcoObjectListAdapter.EcoListEnumerator


Inheritance Hierarchy

Inheritance Hierarchy
Inheritance Hierarchy
Eco.ObjectImplementation.IContent


Inheritance Hierarchy

Inheritance Hierarchy
Inheritance Hierarchy
Eco.ObjectImplementation.IEcoList
    Eco.ObjectImplementation.EcoListShimBase
    Eco.ObjectImplementation.EcoObjectListAdapter


Inheritance Hierarchy

Inheritance Hierarchy
Inheritance Hierarchy
Eco.ObjectImplementation.IInternalObjectContentFactory


Inheritance Hierarchy

Inheritance Hierarchy
Inheritance Hierarchy
Eco.ObjectImplementation.ILoopBack
    Eco.ObjectImplementation.ILoopBack2


Inheritance Hierarchy

Inheritance Hierarchy
Inheritance Hierarchy
Eco.ObjectImplementation.ObjectEnumeratorAdapter


Inheritance Hierarchy

Inheritance Hierarchy
Inheritance Hierarchy
Eco.ObjectImplementation.IEcoList
    Eco.ObjectImplementation.EcoListShimBase
        Eco.ObjectImplementation.ObjectListAdapter
            Eco.ObjectImplementation.ObjectListAdapterX


Inheritance Hierarchy

Inheritance Hierarchy
Inheritance Hierarchy
Eco.ObjectImplementation.StateName


Inheritance Hierarchy

Inheritance Hierarchy
Inheritance Hierarchy
Eco.ObjectRepresentation.AmbiguousTransitionException


Inheritance Hierarchy

Inheritance Hierarchy
Inheritance Hierarchy
Eco.ObjectRepresentation.ArgumentNonConformException


Inheritance Hierarchy

Inheritance Hierarchy
Inheritance Hierarchy
Eco.ObjectRepresentation.ArgumentTypeException


Related Topics

Related Topics
Related Topics

Eco.ObjectRepresentation.IElement.ContentType


Inheritance Hierarchy

Inheritance Hierarchy
Inheritance Hierarchy
Eco.ObjectRepresentation.EcoObjectDeleteException


Inheritance Hierarchy

Inheritance Hierarchy
Inheritance Hierarchy
Eco.ObjectRepresentation.EcoObjectExtensions


Inheritance Hierarchy

Inheritance Hierarchy
Inheritance Hierarchy
Eco.ObjectRepresentation.EcoObservableCollection


Inheritance Hierarchy

Inheritance Hierarchy
Inheritance Hierarchy
Eco.ObjectRepresentation.ElementChangedEventArgs


Inheritance Hierarchy

Inheritance Hierarchy
Inheritance Hierarchy
Eco.ObjectRepresentation.ElementEqualHash


Inheritance Hierarchy

Inheritance Hierarchy
Inheritance Hierarchy
Eco.ObjectRepresentation.IElementProvider
    Eco.ObjectRepresentation.IElement
        Eco.ObjectRepresentation.IConstraintCheck


Inheritance Hierarchy

Inheritance Hierarchy
Inheritance Hierarchy
Eco.ObjectRepresentation.IEcoObject
    Eco.ObjectRepresentation.IObject
    Eco.ObjectRepresentation.IObjectProvider


Related Topics

Related Topics
Related Topics

Eco.Services


Inheritance Hierarchy

Inheritance Hierarchy
Inheritance Hierarchy
Eco.ObjectRepresentation.IEcoServiceProvider


Example

Example
Copy Code
           IMyService myService = serviceProvider.GetEcoService<IMyService>("version1"));


Example

Example
Copy Code
           oclService = (IOclService) serviceProvider.GetEcoService(typeof(IOclService));
Copy Code
           OclService := ServiceProvider.GetEcoService(typeof(IOclService)) as IOclService;


Example

Example
Copy Code
           oclService = serviceProvider.GetEcoService<IOclService>());
Copy Code
           OclService := ServiceProvider.GetEcoService<IOclService>;


Inheritance Hierarchy

Inheritance Hierarchy
Inheritance Hierarchy
Eco.ObjectRepresentation.IElementProvider
    Eco.ObjectRepresentation.IElement
        Eco.ObjectRepresentation.IConstraintCheck
        Eco.ObjectRepresentation.IElementCollection
        Eco.ObjectRepresentation.IFeatured
        Eco.ObjectRepresentation.IObjectContainer
        Eco.ObjectRepresentation.IPrimitive
        Eco.ObjectRepresentation.IProperty
        Eco.ObjectRepresentation.IVariable


Related Topics

Related Topics
Related Topics

Eco.ObjectRepresentation.ContentType


Inheritance Hierarchy

Inheritance Hierarchy
Inheritance Hierarchy
Eco.ObjectRepresentation.IElementProvider
    Eco.ObjectRepresentation.IElement
        Eco.ObjectRepresentation.IElementCollection


Related Topics

Related Topics
Related Topics

SupportsAddNew


Related Topics

Related Topics
Related Topics

Eco.Services.IPersistenceService.EnsureRange


Related Topics

Related Topics
Related Topics

IElementCollection.AddNew


Related Topics

Related Topics
Related Topics

IElementCollection.Move


Inheritance Hierarchy

Inheritance Hierarchy
Inheritance Hierarchy
Eco.ObjectRepresentation.IElementProvider
    Eco.ObjectRepresentation.IElement
    Eco.ObjectRepresentation.ISubscribableElementProvider


Inheritance Hierarchy

Inheritance Hierarchy
Inheritance Hierarchy
Eco.ObjectRepresentation.IExternalVariable


Related Topics

Related Topics
Related Topics

Eco.Services.IOclService, Eco.Services.IOclPsService, Eco.Services.IActionLanguageService, Eco.Services.IVariableFactoryService


Inheritance Hierarchy

Inheritance Hierarchy
Inheritance Hierarchy
Eco.ObjectRepresentation.IExternalVariableList
    Eco.ObjectRepresentation.IModifiableVariableList


Related Topics

Related Topics
Related Topics

Eco.ObjectRepresentation.IProperty, Eco.ObjectRepresentation.IObject


Inheritance Hierarchy

Inheritance Hierarchy
Inheritance Hierarchy
Eco.ObjectRepresentation.IElementProvider
    Eco.ObjectRepresentation.IElement
        Eco.ObjectRepresentation.IFeatured
            Eco.ObjectRepresentation.IObject
            Eco.ObjectRepresentation.ITuple


Related Topics

Related Topics
Related Topics

Eco.ObjectRepresentation.IObject.Delete, Eco.ObjectRepresentation.IObject.IsDeletable


Inheritance Hierarchy

Inheritance Hierarchy
Inheritance Hierarchy
Eco.ObjectRepresentation.INonDeletableReason


Related Topics

Related Topics
Related Topics

Eco.ObjectRepresentation.IObjectInstance, Eco.ObjectRepresentation.IObjectReference


Inheritance Hierarchy

Inheritance Hierarchy
Inheritance Hierarchy
Eco.ObjectRepresentation.IElementProvider
    Eco.ObjectRepresentation.IElement
        Eco.ObjectRepresentation.IFeatured
        Eco.ObjectRepresentation.IObjectContainer
        Eco.ObjectRepresentation.IEcoObject
            Eco.ObjectRepresentation.IObject
                Eco.ObjectRepresentation.IObjectInstance
                Eco.ObjectRepresentation.IObjectReference


Related Topics

Related Topics
Related Topics

Eco.Services.IUndoService


Inheritance Hierarchy

Inheritance Hierarchy
Inheritance Hierarchy
Eco.ObjectRepresentation.IElementProvider
    Eco.ObjectRepresentation.IElement
        Eco.ObjectRepresentation.IObjectContainer
            Eco.ObjectRepresentation.IObject
            Eco.ObjectRepresentation.IObjectList


Inheritance Hierarchy

Inheritance Hierarchy
Inheritance Hierarchy
Eco.ObjectRepresentation.IElementProvider
    Eco.ObjectRepresentation.IElement
        Eco.ObjectRepresentation.IFeatured
        Eco.ObjectRepresentation.IObjectContainer
        Eco.ObjectRepresentation.IEcoObject
            Eco.ObjectRepresentation.IObject
                Eco.ObjectRepresentation.IObjectInstance


Related Topics

Related Topics
Related Topics

Eco.UmlRt.IMethod.IsQuery


Inheritance Hierarchy

Inheritance Hierarchy
Inheritance Hierarchy
Eco.ObjectRepresentation.IElementProvider
    Eco.ObjectRepresentation.IElement
        Eco.ObjectRepresentation.IObjectContainer
            Eco.ObjectRepresentation.IObjectList


Related Topics

Related Topics
Related Topics

IObject.Delete


Inheritance Hierarchy

Inheritance Hierarchy
Inheritance Hierarchy
Eco.ObjectRepresentation.IObjectListProvider


Inheritance Hierarchy

Inheritance Hierarchy
Inheritance Hierarchy
Eco.ObjectRepresentation.IObjectPair


Inheritance Hierarchy

Inheritance Hierarchy
Inheritance Hierarchy
Eco.ObjectRepresentation.IEcoObject
    Eco.ObjectRepresentation.IObjectProvider


Inheritance Hierarchy

Inheritance Hierarchy
Inheritance Hierarchy
Eco.ObjectRepresentation.IElementProvider
    Eco.ObjectRepresentation.IElement
        Eco.ObjectRepresentation.IFeatured
        Eco.ObjectRepresentation.IObjectContainer
        Eco.ObjectRepresentation.IEcoObject
            Eco.ObjectRepresentation.IObject
                Eco.ObjectRepresentation.IObjectReference


Inheritance Hierarchy

Inheritance Hierarchy
Inheritance Hierarchy
Eco.ObjectRepresentation.IObjectStateMachine


Inheritance Hierarchy

Inheritance Hierarchy
Inheritance Hierarchy
Eco.ObjectRepresentation.IElementProvider
    Eco.ObjectRepresentation.IElement
        Eco.ObjectRepresentation.IPrimitive


Related Topics

Related Topics
Related Topics

Eco.ObjectRepresentation.IElement


Inheritance Hierarchy

Inheritance Hierarchy
Inheritance Hierarchy
Eco.ObjectRepresentation.IElementProvider
    Eco.ObjectRepresentation.IElement
        Eco.ObjectRepresentation.IProperty


Related Topics

Related Topics
Related Topics

Eco.ObjectRepresentation.IProperty


Inheritance Hierarchy

Inheritance Hierarchy
Inheritance Hierarchy
Eco.ObjectRepresentation.IPropertyCollection


Example

Example
Copy Code
       public class Person: object, ILoopBack
{
    public struct Eco_LoopbackIndices
    {
        public const int Eco_FirstMember = 0;
        public const int Eco_MemberCount = (Eco_FirstMember + 2);
        public const int FirstName_MemberIndex = Eco_FirstMember + 0;
        public const int LastName_MemberIndex = Eco_FirstMember + 1;
    }
    ...
}
...
lastNameProperty = myPerson.AsIObject().Properties.GetByLoopbackIndex(Person.Eco_LoopbackIndices.LastName_MemberIndex);
Copy Code
       type
    Person = class(System.Object, ILoopBack)
    public
        type
            Eco_LoopbackIndices = class
            public
                const Eco_FirstMember = 0;
                const Eco_MemberCount = (Eco_FirstMember + 2);
                const FirstName = Eco_FirstMember;
                const LastName = Eco_FirstMember + 1;
            end;
    ...
    end;

    LastNameProperty := MyPerson.AsIObject.Properties.GetByLoopbackIndex(Person.Eco_LoopbackIndices.LastName);


Related Topics

Related Topics
Related Topics

Count


Inheritance Hierarchy

Inheritance Hierarchy
Inheritance Hierarchy
Eco.ObjectRepresentation.IQualifiedAccess


Inheritance Hierarchy

Inheritance Hierarchy
Inheritance Hierarchy
Eco.ObjectRepresentation.IElementProvider
    Eco.ObjectRepresentation.ISubscribableElementProvider


Inheritance Hierarchy

Inheritance Hierarchy
Inheritance Hierarchy
Eco.ObjectRepresentation.IElementProvider
    Eco.ObjectRepresentation.IElement
        Eco.ObjectRepresentation.IFeatured
            Eco.ObjectRepresentation.ITuple


Inheritance Hierarchy

Inheritance Hierarchy
Inheritance Hierarchy
Eco.ObjectRepresentation.IElementProvider
    Eco.ObjectRepresentation.IElement
        Eco.ObjectRepresentation.IVariable


Inheritance Hierarchy

Inheritance Hierarchy
Inheritance Hierarchy
Eco.ObjectRepresentation.NoTransitionException


Inheritance Hierarchy

Inheritance Hierarchy
Inheritance Hierarchy
Eco.ObjectRepresentation.OtherEndExtenderHelper


Related Topics

Related Topics
Related Topics

Eco.ObjectRepresentation.IObjectStateMachine.GetStates(StateFilter)


Inheritance Hierarchy

Inheritance Hierarchy
Inheritance Hierarchy
Eco.Ocl.ParserCore.SSLex
    Eco.Ocl.ParserCore.BoldOclLexClass


Inheritance Hierarchy

Inheritance Hierarchy
Inheritance Hierarchy
Eco.Ocl.ParserCore.SSLexTable
    Eco.Ocl.ParserCore.BoldOclLexTable


Inheritance Hierarchy

Inheritance Hierarchy
Inheritance Hierarchy
Eco.Ocl.ParserCore.SSYacc
    Eco.Ocl.ParserCore.BoldOclYaccClass


Inheritance Hierarchy

Inheritance Hierarchy
Inheritance Hierarchy
Eco.Ocl.ParserCore.SSYaccTable
    Eco.Ocl.ParserCore.BoldOclYaccTable


Inheritance Hierarchy

Inheritance Hierarchy
Inheritance Hierarchy
Eco.Ocl.ParserCore.InvalidOclException
    Eco.Ocl.ParserCore.InvalidOclSyntaxException


Inheritance Hierarchy

Inheritance Hierarchy
Inheritance Hierarchy
Eco.Ocl.ParserCore.SSYaccStackElement
    Eco.Ocl.ParserCore.OclStackElement


Inheritance Hierarchy

Inheritance Hierarchy
Inheritance Hierarchy
Eco.Ocl.ParserCore.SSLexCharacterClass


Inheritance Hierarchy

Inheritance Hierarchy
Inheritance Hierarchy
Eco.Ocl.ParserCore.SSLexConsumer
    Eco.Ocl.ParserCore.SSLexStringConsumer


Inheritance Hierarchy

Inheritance Hierarchy
Inheritance Hierarchy
Eco.Ocl.ParserCore.SSLexFinalState


Inheritance Hierarchy

Inheritance Hierarchy
Inheritance Hierarchy
Eco.Ocl.ParserCore.SSLexKeyTable


Inheritance Hierarchy

Inheritance Hierarchy
Inheritance Hierarchy
Eco.Ocl.ParserCore.SSLexLexeme


Inheritance Hierarchy

Inheritance Hierarchy
Inheritance Hierarchy
Eco.Ocl.ParserCore.SSLexMark


Inheritance Hierarchy

Inheritance Hierarchy
Inheritance Hierarchy
Eco.Ocl.ParserCore.SSLexTableHeader


Inheritance Hierarchy

Inheritance Hierarchy
Inheritance Hierarchy
Eco.Ocl.ParserCore.SSLexTableRow


Inheritance Hierarchy

Inheritance Hierarchy
Inheritance Hierarchy
Eco.Ocl.ParserCore.SSYaccCache


Inheritance Hierarchy

Inheritance Hierarchy
Inheritance Hierarchy
Eco.Ocl.ParserCore.SSYaccTableHeader


Inheritance Hierarchy

Inheritance Hierarchy
Inheritance Hierarchy
Eco.Ocl.ParserCore.SSYaccTableProd


Inheritance Hierarchy

Inheritance Hierarchy
Inheritance Hierarchy
Eco.Ocl.ParserCore.SSYaccTableRow


Inheritance Hierarchy

Inheritance Hierarchy
Inheritance Hierarchy
Eco.Ocl.Support.IOclOperation
    Eco.Ocl.Support.OclOperationBase
        Eco.Ocl.Support.OclTypeMethod
            Eco.Ocl.Support.AbstractOclInstanceMethod
                Eco.Ocl.Support.OclInstanceMethod
                Eco.Ocl.Support.OclStaticInstanceMethod


Inheritance Hierarchy

Inheritance Hierarchy
Inheritance Hierarchy
Eco.Ocl.Support.IOclOperation
    Eco.Ocl.Support.OclOperationBase
        Eco.Ocl.Support.AbstractTimerbasedOperation
            Eco.Ocl.Support.DateTimeDateWithSubscription
            Eco.Ocl.Support.DateTimeNowWithSubscription
            Eco.Ocl.Support.DateTimeTimeWithSubscription


Example

Example

aPerson.ownedBuildings->at0(3) To install in the EcoSpace, add the following attribute: [Eco.Ocl.Support.EcoOclOperation(typeof(Eco.Ocl.Support.At0), true)]


Inheritance Hierarchy

Inheritance Hierarchy
Inheritance Hierarchy
Eco.Ocl.Support.IOclOperation
    Eco.Ocl.Support.OclOperationBase
        Eco.Ocl.Support.At0


Inheritance Hierarchy

Inheritance Hierarchy
Inheritance Hierarchy
Eco.Ocl.Support.IOclOperation
    Eco.Ocl.Support.OclOperationBase
        Eco.Ocl.Support.DateTimeDate


Inheritance Hierarchy

Inheritance Hierarchy
Inheritance Hierarchy
Eco.Ocl.Support.IOclOperation
    Eco.Ocl.Support.OclOperationBase
        Eco.Ocl.Support.AbstractTimerbasedOperation
            Eco.Ocl.Support.DateTimeDateWithSubscription


Inheritance Hierarchy

Inheritance Hierarchy
Inheritance Hierarchy
Eco.Ocl.Support.IOclOperation
    Eco.Ocl.Support.OclOperationBase
        Eco.Ocl.Support.AbstractTimerbasedOperation
            Eco.Ocl.Support.DateTimeNowWithSubscription


Inheritance Hierarchy

Inheritance Hierarchy
Inheritance Hierarchy
Eco.Ocl.Support.IOclOperation
    Eco.Ocl.Support.OclOperationBase
        Eco.Ocl.Support.DateTimeTime


Inheritance Hierarchy

Inheritance Hierarchy
Inheritance Hierarchy
Eco.Ocl.Support.IOclOperation
    Eco.Ocl.Support.OclOperationBase
        Eco.Ocl.Support.AbstractTimerbasedOperation
            Eco.Ocl.Support.DateTimeTimeWithSubscription


Inheritance Hierarchy

Inheritance Hierarchy
Inheritance Hierarchy
Eco.Ocl.Support.EcoOclOperationAttribute


Inheritance Hierarchy

Inheritance Hierarchy
Inheritance Hierarchy
Eco.Ocl.Support.EcoOclOperationHelpAttribute


Inheritance Hierarchy

Inheritance Hierarchy
Inheritance Hierarchy
Eco.Ocl.Support.EcoOclOperationResourcedHelpAttribute


Example

Example

aPerson.ownedBuildings->indexOf0(home) To install in the EcoSpace, add the following attribute: [Eco.Ocl.Support.EcoOclOperation(typeof(Eco.Ocl.Support.IndexOf0), true)]


Inheritance Hierarchy

Inheritance Hierarchy
Inheritance Hierarchy
Eco.Ocl.Support.IOclOperation
    Eco.Ocl.Support.OclOperationBase
        Eco.Ocl.Support.IndexOf0


Inheritance Hierarchy

Inheritance Hierarchy
Inheritance Hierarchy
Eco.Ocl.Support.IOclValue
    Eco.Ocl.Support.IOclNamedEnumLiteral


Inheritance Hierarchy

Inheritance Hierarchy
Inheritance Hierarchy
Eco.Ocl.Support.IOclOperation
    Eco.Ocl.Support.OclOperationBase


Inheritance Hierarchy

Inheritance Hierarchy
Inheritance Hierarchy
Eco.Ocl.Support.IOclOperationParameters


Inheritance Hierarchy

Inheritance Hierarchy
Inheritance Hierarchy
Eco.Ocl.Support.IOclOperationSupport


Inheritance Hierarchy

Inheritance Hierarchy
Inheritance Hierarchy
Eco.Ocl.Support.IOclType


Inheritance Hierarchy

Inheritance Hierarchy
Inheritance Hierarchy
Eco.Ocl.Support.IOclTypeFactory


Inheritance Hierarchy

Inheritance Hierarchy
Inheritance Hierarchy
Eco.Ocl.Support.IOclOperation
    Eco.Ocl.Support.OclOperationBase
        Eco.Ocl.Support.OclAssign


Inheritance Hierarchy

Inheritance Hierarchy
Inheritance Hierarchy
Eco.Ocl.Support.IOclOperation
    Eco.Ocl.Support.OclOperationBase
        Eco.Ocl.Support.OclTypeMethod
            Eco.Ocl.Support.OclConstructorMethod


Inheritance Hierarchy

Inheritance Hierarchy
Inheritance Hierarchy
Eco.Ocl.Support.IOclOperation
    Eco.Ocl.Support.OclOperationBase
        Eco.Ocl.Support.OclTypeMethod
            Eco.Ocl.Support.OclInstanceField


Inheritance Hierarchy

Inheritance Hierarchy
Inheritance Hierarchy
Eco.Ocl.Support.IOclOperation
    Eco.Ocl.Support.OclOperationBase
        Eco.Ocl.Support.OclTypeMethod
            Eco.Ocl.Support.AbstractOclInstanceMethod
                Eco.Ocl.Support.OclInstanceMethod


Inheritance Hierarchy

Inheritance Hierarchy
Inheritance Hierarchy
Eco.Ocl.Support.IOclOperation
    Eco.Ocl.Support.OclOperationBase
        Eco.Ocl.Support.OclMethodBase
            Eco.Ocl.Support.OclMethod


Inheritance Hierarchy

Inheritance Hierarchy
Inheritance Hierarchy
Eco.Ocl.Support.IOclOperation
    Eco.Ocl.Support.OclOperationBase
        Eco.Ocl.Support.OclMethodBase
            Eco.Ocl.Support.OclMethod
            Eco.Ocl.Support.OclTrigger


Inheritance Hierarchy

Inheritance Hierarchy
Inheritance Hierarchy
Eco.Ocl.Support.OclMethodInstaller


Inheritance Hierarchy

Inheritance Hierarchy
Inheritance Hierarchy
Eco.Ocl.Support.IOclOperation
    Eco.Ocl.Support.OclOperationBase
        Eco.Ocl.Support.AbstractTimerbasedOperation
        Eco.Ocl.Support.At0
        Eco.Ocl.Support.DateTimeDate
        Eco.Ocl.Support.DateTimeTime
        Eco.Ocl.Support.IndexOf0
        Eco.Ocl.Support.OclAssign
        Eco.Ocl.Support.OclMethodBase
        Eco.Ocl.Support.OclPreconditionQuery
        Eco.Ocl.Support.OclTriggerQuery
        Eco.Ocl.Support.OclTypeMethod
        Eco.Ocl.Support.TimeSpanSum


Inheritance Hierarchy

Inheritance Hierarchy
Inheritance Hierarchy
Eco.Ocl.Support.IOclOperation
    Eco.Ocl.Support.OclOperationBase
        Eco.Ocl.Support.OclPreconditionQuery


Inheritance Hierarchy

Inheritance Hierarchy
Inheritance Hierarchy
Eco.Ocl.Support.OclPsStandardOperations


Inheritance Hierarchy

Inheritance Hierarchy
Inheritance Hierarchy
Eco.Ocl.Support.OclStandardOperations


Inheritance Hierarchy

Inheritance Hierarchy
Inheritance Hierarchy
Eco.Ocl.Support.IOclOperation
    Eco.Ocl.Support.OclOperationBase
        Eco.Ocl.Support.OclTypeMethod
            Eco.Ocl.Support.AbstractOclInstanceMethod
                Eco.Ocl.Support.OclStaticInstanceMethod


Inheritance Hierarchy

Inheritance Hierarchy
Inheritance Hierarchy
Eco.Ocl.Support.IOclOperation
    Eco.Ocl.Support.OclOperationBase
        Eco.Ocl.Support.OclMethodBase
            Eco.Ocl.Support.OclTrigger


Inheritance Hierarchy

Inheritance Hierarchy
Inheritance Hierarchy
Eco.Ocl.Support.IOclOperation
    Eco.Ocl.Support.OclOperationBase
        Eco.Ocl.Support.OclTriggerQuery


Inheritance Hierarchy

Inheritance Hierarchy
Inheritance Hierarchy
Eco.Ocl.Support.IOclOperation
    Eco.Ocl.Support.OclOperationBase
        Eco.Ocl.Support.OclTypeMethod
            Eco.Ocl.Support.AbstractOclInstanceMethod
            Eco.Ocl.Support.OclConstructorMethod
            Eco.Ocl.Support.OclInstanceField


Inheritance Hierarchy

Inheritance Hierarchy
Inheritance Hierarchy
Eco.Ocl.Support.OclTypeMethodInstaller


Inheritance Hierarchy

Inheritance Hierarchy
Inheritance Hierarchy
Eco.Ocl.Support.ProxyElement
    Eco.Ocl.Support.SortElement


Inheritance Hierarchy

Inheritance Hierarchy
Inheritance Hierarchy
Eco.Ocl.Support.TimerbasedDateTimeOclOperations


Inheritance Hierarchy

Inheritance Hierarchy
Inheritance Hierarchy
Eco.Ocl.Support.TimerSubscriber


Inheritance Hierarchy

Inheritance Hierarchy
Inheritance Hierarchy
Eco.Ocl.Support.IOclOperation
    Eco.Ocl.Support.OclOperationBase
        Eco.Ocl.Support.TimeSpanSum


Inheritance Hierarchy

Inheritance Hierarchy
Inheritance Hierarchy
Eco.Persistence.GenericKeyMapper
Eco.Persistence.IAutoIncIdMapper
Eco.Persistence.IKeyMapper
    Eco.Persistence.AbstractAutoGuidKeyMapper
        Eco.Persistence.AutoGuidKeyMapper


Inheritance Hierarchy

Inheritance Hierarchy
Inheritance Hierarchy
Eco.Persistence.GenericKeyMapper
Eco.Persistence.IAutoIncIdMapper
Eco.Persistence.IKeyMapper
    Eco.Persistence.AbstractAutoIncKeyMapper
        Eco.Persistence.AutoInc16KeyMapper
        Eco.Persistence.AutoIncKeyMapper


Inheritance Hierarchy

Inheritance Hierarchy
Inheritance Hierarchy
Eco.Persistence.AbstractCondition
    Eco.Persistence.AllInstancesCondition
    Eco.Persistence.ChangePointCondition
    Eco.Persistence.OclCondition


Inheritance Hierarchy

Inheritance Hierarchy
Inheritance Hierarchy
Eco.Persistence.IPersistencemapperProvider
    Eco.Persistence.PersistenceMapper
    Eco.Persistence.IPersistenceMapper
        Eco.Persistence.AbstractDataBlockPersistenceMapper
            Eco.Persistence.AbstractPersistenceMapperFile
            Eco.Persistence.PersistenceMapperMemory


Inheritance Hierarchy

Inheritance Hierarchy
Inheritance Hierarchy
Eco.Persistence.IPersistencemapperProvider
    Eco.Persistence.PersistenceMapper
        Eco.Persistence.AbstractPersistenceMapperDb
        Eco.Persistence.IPersistenceMapperDb
            Eco.Persistence.PersistenceMapperDb
            Eco.Persistence.IAutoHookable
                Eco.Persistence.PersistenceMapperAdo2
                    Eco.Persistence.AbstractPersistenceMapperBlackfish
                        Eco.Persistence.PersistenceMapperBlackfish
                        Eco.Persistence.PersistenceMapperBlackfishRemote


Inheritance Hierarchy

Inheritance Hierarchy
Inheritance Hierarchy
Eco.Persistence.IPersistencemapperProvider
    Eco.Persistence.PersistenceMapper
        Eco.Persistence.AbstractPersistenceMapperDb
            Eco.Persistence.PersistenceMapperDb
            Eco.Persistence.PersistenceMapperMultiDb


Inheritance Hierarchy

Inheritance Hierarchy
Inheritance Hierarchy
Eco.Persistence.IPersistencemapperProvider
    Eco.Persistence.PersistenceMapper
    Eco.Persistence.IPersistenceMapper
        Eco.Persistence.AbstractDataBlockPersistenceMapper
            Eco.Persistence.AbstractPersistenceMapperFile
                Eco.Persistence.PersistenceMapperXml


Inheritance Hierarchy

Inheritance Hierarchy
Inheritance Hierarchy
Eco.Persistence.ISyncSink
    Eco.Persistence.AbstractSyncHandler
        Eco.Persistence.SyncHandler


Inheritance Hierarchy

Inheritance Hierarchy
Inheritance Hierarchy
Eco.Persistence.AbstractCondition
    Eco.Persistence.AllInstancesCondition


Inheritance Hierarchy

Inheritance Hierarchy
Inheritance Hierarchy
Eco.Persistence.GenericKeyMapper
Eco.Persistence.IKeyMapper
    Eco.Persistence.AttributeKeyMapper


Inheritance Hierarchy

Inheritance Hierarchy
Inheritance Hierarchy
Eco.Persistence.GenericKeyMapper
Eco.Persistence.IAutoIncIdMapper
Eco.Persistence.IKeyMapper
    Eco.Persistence.AbstractAutoIncKeyMapper
        Eco.Persistence.AutoInc16KeyMapper


Inheritance Hierarchy

Inheritance Hierarchy
Inheritance Hierarchy
Eco.Persistence.GenericKeyMapper
Eco.Persistence.IAutoIncIdMapper
Eco.Persistence.IKeyMapper
    Eco.Persistence.AbstractAutoIncKeyMapper
        Eco.Persistence.AutoIncKeyMapper


Inheritance Hierarchy

Inheritance Hierarchy
Inheritance Hierarchy
Eco.Persistence.Blackfish.BlackfishIDatabaseImpl


Inheritance Hierarchy

Inheritance Hierarchy
Inheritance Hierarchy
Eco.Persistence.IDefaultReverseMapping
Eco.Persistence.ISingleColumnAttributemapping
    Eco.Persistence.Blackfish.BooleanAsBoolean


Inheritance Hierarchy

Inheritance Hierarchy
Inheritance Hierarchy
Eco.Persistence.Blackfish.GenericByteArrayAsVarBinary
Eco.Persistence.ISingleColumnAttributemapping
    Eco.Persistence.Blackfish.ByteArrayAsBdpVarBinary


Inheritance Hierarchy

Inheritance Hierarchy
Inheritance Hierarchy
Eco.Persistence.Blackfish.GenericByteArrayAsVarBinary
Eco.Persistence.ISingleColumnAttributemapping
    Eco.Persistence.Blackfish.ByteArrayAsVarBinary


Inheritance Hierarchy

Inheritance Hierarchy
Inheritance Hierarchy
Eco.Persistence.ISingleColumnAttributemapping
    Eco.Persistence.Blackfish.CharAsVarChar1


Inheritance Hierarchy

Inheritance Hierarchy
Inheritance Hierarchy
Eco.Persistence.Blackfish.GenericByteArrayAsVarBinary
    Eco.Persistence.Blackfish.ByteArrayAsBdpVarBinary
    Eco.Persistence.Blackfish.ByteArrayAsVarBinary


Inheritance Hierarchy

Inheritance Hierarchy
Inheritance Hierarchy
Eco.Persistence.ISingleColumnAttributemapping
    Eco.Persistence.IAutoIncAttributemapping
    Eco.Persistence.IDefaultReverseMapping
        Eco.Persistence.Blackfish.Int32AsAutoInc


Inheritance Hierarchy

Inheritance Hierarchy
Inheritance Hierarchy
Eco.Persistence.IDefaultReverseMapping
Eco.Persistence.ISingleColumnAttributemapping
    Eco.Persistence.Blackfish.Int64AsBigInt


Inheritance Hierarchy

Inheritance Hierarchy
Inheritance Hierarchy
Eco.Persistence.IDefaultReverseMapping
Eco.Persistence.ISingleColumnAttributemapping
    Eco.Persistence.Blackfish.SingleAsFloat


Inheritance Hierarchy

Inheritance Hierarchy
Inheritance Hierarchy
Eco.Persistence.ISingleColumnAttributemapping
    Eco.Persistence.Blackfish.StringAsText


Example

Example

In your own subclass, define an install-method like the one below and call it with the appropriate parameters to install it in your ecospace

Copy Code
public class MyPersistenceHandler: ChainedPersistenceHandlerBase
{
   // override some methods, don't forget to call the inherited version

   public static void Install(EcoSpace es, FrontsidePolicy fsp)
   {
       MyPersistenceHandler newPH = new MyPersistenceHandler(es.TypeSystem);
       newPH.NextPersistenceHandler = fsp.PersistenceHandler;
       fsp.PersistenceHandler = newPH;
   }
}


Inheritance Hierarchy

Inheritance Hierarchy
Inheritance Hierarchy
Eco.Persistence.ChainedPersistenceHandlerBase


Inheritance Hierarchy

Inheritance Hierarchy
Inheritance Hierarchy
Eco.Persistence.IPersistencemapperProvider
    Eco.Persistence.PersistenceMapper
        Eco.Persistence.ChainedPersistenceMapperBase


Inheritance Hierarchy

Inheritance Hierarchy
Inheritance Hierarchy
Eco.Persistence.IPersistenceMapper
    Eco.Persistence.ChainedPersistenceMapperImplBase


Inheritance Hierarchy

Inheritance Hierarchy
Inheritance Hierarchy
Eco.Persistence.ChainedPersistenceServiceBase


Inheritance Hierarchy

Inheritance Hierarchy
Inheritance Hierarchy
Eco.Persistence.AbstractCondition
    Eco.Persistence.ChangePointCondition


Inheritance Hierarchy

Inheritance Hierarchy
Inheritance Hierarchy
Eco.Persistence.ColumnDescription


Inheritance Hierarchy

Inheritance Hierarchy
Inheritance Hierarchy
Eco.Persistence.CommitBlock


Inheritance Hierarchy

Inheritance Hierarchy
Inheritance Hierarchy
Eco.Persistence.Configuration.DatabaseEngineInitializer


Inheritance Hierarchy

Inheritance Hierarchy
Inheritance Hierarchy
Eco.Persistence.Configuration.KeyMapperDefinition
    Eco.Persistence.Configuration.IdMapperDefinition


Inheritance Hierarchy

Inheritance Hierarchy
Inheritance Hierarchy
Eco.Persistence.Configuration.KeyMapperDefinitionCollection


Inheritance Hierarchy

Inheritance Hierarchy
Inheritance Hierarchy
Eco.Persistence.Configuration.KeyMapperDefinitionConverter


Inheritance Hierarchy

Inheritance Hierarchy
Inheritance Hierarchy
Eco.Persistence.Configuration.MapperDefinition


Inheritance Hierarchy

Inheritance Hierarchy
Inheritance Hierarchy
Eco.Persistence.Configuration.PersistenceMapperDefinition


Inheritance Hierarchy

Inheritance Hierarchy
Inheritance Hierarchy
Eco.Persistence.Configuration.PersistenceMapperDefinitionCollection


Inheritance Hierarchy

Inheritance Hierarchy
Inheritance Hierarchy
Eco.Persistence.Configuration.PersistenceMapperDictionary


Inheritance Hierarchy

Inheritance Hierarchy
Inheritance Hierarchy
Eco.Persistence.Configuration.PMapperDefinitionConverter


Inheritance Hierarchy

Inheritance Hierarchy
Inheritance Hierarchy
Eco.Persistence.Configuration.SqlDatabaseConfig


Inheritance Hierarchy

Inheritance Hierarchy
Inheritance Hierarchy
Eco.Persistence.Configuration.SqlDatabaseConfigConverter


Inheritance Hierarchy

Inheritance Hierarchy
Inheritance Hierarchy
Eco.Persistence.Configuration.StringLiterals


Inheritance Hierarchy

Inheritance Hierarchy
Inheritance Hierarchy
Eco.Persistence.Connection.IDatabase
    Eco.Persistence.Connection.AbstractIDatabaseImpl
        Eco.Persistence.Connection.BdpIDatabaseImpl
        Eco.Persistence.Connection.MySqlIDatabaseImpl
        Eco.Persistence.Connection.SybaseIDatabaseImpl


Related Topics

Related Topics
Related Topics

ConvertParametersToColonPrefix, ConvertParametersToAtPrefix, ConvertParametersToLiterals, ConvertParametersToQuestionMarks, ConvertParametersToUpperCase


Inheritance Hierarchy

Inheritance Hierarchy
Inheritance Hierarchy
Eco.Persistence.Connection.IParameterized
    Eco.Persistence.Connection.IQueryBase
        Eco.Persistence.Connection.IExecQuery
        Eco.Persistence.Connection.IDataSet
            Eco.Persistence.Connection.IQuery
                Eco.Persistence.Connection.AbstractIQueryImpl
                    Eco.Persistence.Connection.Ado2IQueryImpl


Inheritance Hierarchy

Inheritance Hierarchy
Inheritance Hierarchy
Eco.Persistence.IDistributedTransactionParticipant
    Eco.Persistence.Connection.Ado2IDatabaseImpl
        Eco.Persistence.Connection.DbxIDatabaseImpl
        Eco.Persistence.Connection.FirebirdIDatabaseImpl
        Eco.Persistence.Connection.MimerIDatabaseImpl
        Eco.Persistence.Connection.OracleIDatabaseImpl
        Eco.Persistence.Connection.SqlIDatabaseImpl
        Eco.Persistence.Connection.SQLiteIDatabaseImpl


Inheritance Hierarchy

Inheritance Hierarchy
Inheritance Hierarchy
Eco.Persistence.Connection.IDatabase
    Eco.Persistence.Connection.AbstractIDatabaseImpl
        Eco.Persistence.Connection.BdpIDatabaseImpl


Inheritance Hierarchy

Inheritance Hierarchy
Inheritance Hierarchy
Eco.Persistence.Connection.IDatabaseCollection
    Eco.Persistence.Connection.DatabaseCollection


Inheritance Hierarchy

Inheritance Hierarchy
Inheritance Hierarchy
Eco.Persistence.Connection.DatabaseOperationFailedException


Inheritance Hierarchy

Inheritance Hierarchy
Inheritance Hierarchy
Eco.Persistence.IDistributedTransactionParticipant
    Eco.Persistence.Connection.Ado2IDatabaseImpl
        Eco.Persistence.Connection.DbxIDatabaseImpl


Inheritance Hierarchy

Inheritance Hierarchy
Inheritance Hierarchy
Eco.Persistence.IDistributedTransactionParticipant
    Eco.Persistence.Connection.Ado2IDatabaseImpl
        Eco.Persistence.Connection.FirebirdIDatabaseImpl


Inheritance Hierarchy

Inheritance Hierarchy
Inheritance Hierarchy
Eco.Persistence.Connection.IDatabase
    Eco.Persistence.Connection.AbstractIDatabaseImpl


Inheritance Hierarchy

Inheritance Hierarchy
Inheritance Hierarchy
Eco.Persistence.Connection.IDatabaseDefinition


Inheritance Hierarchy

Inheritance Hierarchy
Inheritance Hierarchy
Eco.Persistence.Connection.IDataSet
    Eco.Persistence.Connection.IQuery


Inheritance Hierarchy

Inheritance Hierarchy
Inheritance Hierarchy
Eco.Persistence.Connection.IParameterized
    Eco.Persistence.Connection.IQueryBase
        Eco.Persistence.Connection.IExecQuery
            Eco.Persistence.Connection.AbstractIQueryImpl


Inheritance Hierarchy

Inheritance Hierarchy
Inheritance Hierarchy
Eco.Persistence.Connection.IField


Inheritance Hierarchy

Inheritance Hierarchy
Inheritance Hierarchy
Eco.Persistence.Connection.IParameterized
    Eco.Persistence.Connection.IQueryBase


Inheritance Hierarchy

Inheritance Hierarchy
Inheritance Hierarchy
Eco.Persistence.Connection.IParameterized
    Eco.Persistence.Connection.IQueryBase
    Eco.Persistence.Connection.IDataSet
        Eco.Persistence.Connection.IQuery
            Eco.Persistence.Connection.AbstractIQueryImpl


Inheritance Hierarchy

Inheritance Hierarchy
Inheritance Hierarchy
Eco.Persistence.Connection.IParameterized
    Eco.Persistence.Connection.IQueryBase
        Eco.Persistence.Connection.IExecQuery
        Eco.Persistence.Connection.IQuery


Inheritance Hierarchy

Inheritance Hierarchy
Inheritance Hierarchy
Eco.Persistence.Connection.ITransactionable


Inheritance Hierarchy

Inheritance Hierarchy
Inheritance Hierarchy
Eco.Persistence.Connection.ITransactionManager


Inheritance Hierarchy

Inheritance Hierarchy
Inheritance Hierarchy
Eco.Persistence.IDistributedTransactionParticipant
    Eco.Persistence.Connection.Ado2IDatabaseImpl
        Eco.Persistence.Connection.MimerIDatabaseImpl


Inheritance Hierarchy

Inheritance Hierarchy
Inheritance Hierarchy
Eco.Persistence.Connection.IDatabase
    Eco.Persistence.Connection.AbstractIDatabaseImpl
        Eco.Persistence.Connection.MySqlIDatabaseImpl


Inheritance Hierarchy

Inheritance Hierarchy
Inheritance Hierarchy
Eco.Persistence.IDistributedTransactionParticipant
    Eco.Persistence.Connection.Ado2IDatabaseImpl
        Eco.Persistence.Connection.OracleIDatabaseImpl


Inheritance Hierarchy

Inheritance Hierarchy
Inheritance Hierarchy
Eco.Persistence.IDistributedTransactionParticipant
    Eco.Persistence.Connection.Ado2IDatabaseImpl
        Eco.Persistence.Connection.SqlIDatabaseImpl


Inheritance Hierarchy

Inheritance Hierarchy
Inheritance Hierarchy
Eco.Persistence.IDistributedTransactionParticipant
    Eco.Persistence.Connection.Ado2IDatabaseImpl
        Eco.Persistence.Connection.SQLiteIDatabaseImpl


Inheritance Hierarchy

Inheritance Hierarchy
Inheritance Hierarchy
Eco.Persistence.Connection.IDatabase
    Eco.Persistence.Connection.AbstractIDatabaseImpl
        Eco.Persistence.Connection.SybaseIDatabaseImpl


Inheritance Hierarchy

Inheritance Hierarchy
Inheritance Hierarchy
Eco.Persistence.ConnectionPool


Related Topics

Related Topics
Related Topics

ConnectionPool.MaxOpenConnections


Related Topics

Related Topics
Related Topics

ConnectionPool.RetrieveClosedDatabaseConnection


Inheritance Hierarchy

Inheritance Hierarchy
Inheritance Hierarchy
Eco.Persistence.ContentEqualArray


Inheritance Hierarchy

Inheritance Hierarchy
Inheritance Hierarchy
Eco.Persistence.DatablockConverter


Inheritance Hierarchy

Inheritance Hierarchy
Inheritance Hierarchy
Eco.Persistence.IDefaultReverseMapping
Eco.Persistence.ISingleColumnAttributemapping
    Eco.Persistence.Db2.DecimalAsDecimal


Inheritance Hierarchy

Inheritance Hierarchy
Inheritance Hierarchy
Eco.Persistence.IDefaultReverseMapping
Eco.Persistence.ISingleColumnAttributemapping
    Eco.Persistence.Db2.Int64AsBigInt


Inheritance Hierarchy

Inheritance Hierarchy
Inheritance Hierarchy
Eco.Persistence.IDefaultReverseMapping
Eco.Persistence.ISingleColumnAttributemapping
    Eco.Persistence.Db2.Int64AsLongInteger


Inheritance Hierarchy

Inheritance Hierarchy
Inheritance Hierarchy
Eco.Persistence.IDefaultReverseMapping
Eco.Persistence.ISingleColumnAttributemapping
    Eco.Persistence.Db2.SingleAsFloat


Inheritance Hierarchy

Inheritance Hierarchy
Inheritance Hierarchy
Eco.Persistence.ISingleColumnAttributemapping
    Eco.Persistence.Db2.StringAsDbClob


Inheritance Hierarchy

Inheritance Hierarchy
Inheritance Hierarchy
Eco.Persistence.DBChange


Inheritance Hierarchy

Inheritance Hierarchy
Inheritance Hierarchy
Eco.Persistence.DBChangeCollection


Inheritance Hierarchy

Inheritance Hierarchy
Inheritance Hierarchy
Eco.Persistence.ISingleColumnAttributemapping
    Eco.Persistence.Dbx.Blackfish.ByteArrayAsDbxVarBinary


Inheritance Hierarchy

Inheritance Hierarchy
Inheritance Hierarchy
Eco.Persistence.ISingleColumnAttributemapping
    Eco.Persistence.Dbx.Db2.StringAsDbClob


Inheritance Hierarchy

Inheritance Hierarchy
Inheritance Hierarchy
Eco.Persistence.ISingleColumnAttributemapping
    Eco.Persistence.Dbx.Interbase.ByteArrayAsDbxBlob


Inheritance Hierarchy

Inheritance Hierarchy
Inheritance Hierarchy
Eco.Persistence.ISingleColumnAttributemapping
    Eco.Persistence.Dbx.Interbase.StringAsDbxBlob


Inheritance Hierarchy

Inheritance Hierarchy
Inheritance Hierarchy
Eco.Persistence.ISingleColumnAttributemapping
    Eco.Persistence.Dbx.Interbase.StringAsDbxVarChar


Inheritance Hierarchy

Inheritance Hierarchy
Inheritance Hierarchy
Eco.Persistence.ISingleColumnAttributemapping
    Eco.Persistence.Dbx.MySql.ByteArrayAsDbxBlob


Inheritance Hierarchy

Inheritance Hierarchy
Inheritance Hierarchy
Eco.Persistence.ISingleColumnAttributemapping
    Eco.Persistence.Dbx.MySql.StringAsLongText


Inheritance Hierarchy

Inheritance Hierarchy
Inheritance Hierarchy
Eco.Persistence.ISingleColumnAttributemapping
    Eco.Persistence.Dbx.Oracle.ByteArrayAsBlob


Inheritance Hierarchy

Inheritance Hierarchy
Inheritance Hierarchy
Eco.Persistence.ISingleColumnAttributemapping
    Eco.Persistence.Dbx.Oracle.StringAsClob


Inheritance Hierarchy

Inheritance Hierarchy
Inheritance Hierarchy
Eco.Persistence.ISingleColumnAttributemapping
    Eco.Persistence.Dbx.Oracle.StringAsNClob


Inheritance Hierarchy

Inheritance Hierarchy
Inheritance Hierarchy
Eco.Persistence.ISingleColumnAttributemapping
    Eco.Persistence.Dbx.SqlServer.ByteArrayAsImage


Inheritance Hierarchy

Inheritance Hierarchy
Inheritance Hierarchy
Eco.Persistence.ISingleColumnAttributemapping
    Eco.Persistence.Dbx.SqlServer.ByteAsTinyInt


Inheritance Hierarchy

Inheritance Hierarchy
Inheritance Hierarchy
Eco.Persistence.ISingleColumnAttributemapping
    Eco.Persistence.Dbx.SqlServer.StringAsNText


Inheritance Hierarchy

Inheritance Hierarchy
Inheritance Hierarchy
Eco.Persistence.ISingleColumnAttributemapping
    Eco.Persistence.Dbx.SqlServer.StringAsText


Inheritance Hierarchy

Inheritance Hierarchy
Inheritance Hierarchy
Eco.Persistence.ISingleColumnAttributemapping
    Eco.Persistence.Dbx.Sybase.ByteArrayAsImage


Inheritance Hierarchy

Inheritance Hierarchy
Inheritance Hierarchy
Eco.Persistence.ISingleColumnAttributemapping
    Eco.Persistence.Dbx.Sybase.StringAsText


Inheritance Hierarchy

Inheritance Hierarchy
Inheritance Hierarchy
Eco.Persistence.Default.AbstractSingleColumnAttribute
    Eco.Persistence.Default.AbstractNumericSingleColumnAttribute
        Eco.Persistence.Default.ByteAsSmallInt
        Eco.Persistence.Default.DecimalAsDecimal
        Eco.Persistence.Default.DoubleAsDouble
        Eco.Persistence.Default.GenericEnumAsInteger
        Eco.Persistence.Default.Int16AsSmallint
        Eco.Persistence.Default.Int32AsInteger
        Eco.Persistence.Default.Int64AsLongInteger
        Eco.Persistence.Default.SByteAsSmallInt
        Eco.Persistence.Default.SingleAsSingle
        Eco.Persistence.Default.UInt16AsLongInteger
        Eco.Persistence.Default.UInt32AsLongInteger
        Eco.Persistence.Default.UInt64AsDecimal


Inheritance Hierarchy

Inheritance Hierarchy
Inheritance Hierarchy
Eco.Persistence.Default.AbstractSingleColumnAttribute
    Eco.Persistence.Default.AbstractNumericSingleColumnAttribute
    Eco.Persistence.Default.AbstractStringSingleColumnAttribute
    Eco.Persistence.Default.BooleanAsInteger
    Eco.Persistence.Default.BooleanAsYNChar
    Eco.Persistence.Default.ColorAsInteger
    Eco.Persistence.Default.GenericAttributeMapper
    Eco.Persistence.Default.GenericDateTimeMapper
    Eco.Persistence.Default.GenericTimeSpanMapper


Inheritance Hierarchy

Inheritance Hierarchy
Inheritance Hierarchy
Eco.Persistence.Default.AbstractSingleColumnAttribute
    Eco.Persistence.Default.AbstractStringSingleColumnAttribute
        Eco.Persistence.Default.CharAsChar
        Eco.Persistence.Default.CharAsNChar
        Eco.Persistence.Default.GenericEnumAsVarChar
        Eco.Persistence.Default.GuidAsVarChar32
        Eco.Persistence.Default.StringAsChar
        Eco.Persistence.Default.StringAsNChar
        Eco.Persistence.Default.StringAsNVarChar
        Eco.Persistence.Default.StringAsVarChar


Inheritance Hierarchy

Inheritance Hierarchy
Inheritance Hierarchy
Eco.Persistence.Default.AbstractSingleColumnAttribute
Eco.Persistence.INonBooleanBooleanMapping
Eco.Persistence.ISingleColumnAttributemapping
    Eco.Persistence.Default.BooleanAsInteger


Inheritance Hierarchy

Inheritance Hierarchy
Inheritance Hierarchy
Eco.Persistence.Default.AbstractSingleColumnAttribute
Eco.Persistence.INonBooleanBooleanMapping
Eco.Persistence.ISingleColumnAttributemapping
    Eco.Persistence.Default.BooleanAsYNChar


Inheritance Hierarchy

Inheritance Hierarchy
Inheritance Hierarchy
Eco.Persistence.Default.AbstractSingleColumnAttribute
    Eco.Persistence.Default.AbstractNumericSingleColumnAttribute
    Eco.Persistence.ISingleColumnAttributemapping
        Eco.Persistence.Default.ByteAsSmallInt


Inheritance Hierarchy

Inheritance Hierarchy
Inheritance Hierarchy
Eco.Persistence.Default.AbstractSingleColumnAttribute
    Eco.Persistence.Default.AbstractStringSingleColumnAttribute
    Eco.Persistence.IDefaultReverseMapping
    Eco.Persistence.ISingleColumnAttributemapping
        Eco.Persistence.Default.CharAsChar


Inheritance Hierarchy

Inheritance Hierarchy
Inheritance Hierarchy
Eco.Persistence.Default.AbstractSingleColumnAttribute
    Eco.Persistence.Default.AbstractStringSingleColumnAttribute
    Eco.Persistence.IDefaultReverseMapping
    Eco.Persistence.ISingleColumnAttributemapping
        Eco.Persistence.Default.CharAsNChar


Inheritance Hierarchy

Inheritance Hierarchy
Inheritance Hierarchy
Eco.Persistence.Default.AbstractSingleColumnAttribute
Eco.Persistence.ISingleColumnAttributemapping
    Eco.Persistence.Default.ColorAsInteger


Inheritance Hierarchy

Inheritance Hierarchy
Inheritance Hierarchy
Eco.Persistence.Default.AbstractSingleColumnAttribute
Eco.Persistence.ISingleColumnAttributemapping
    Eco.Persistence.Default.GenericDateTimeMapper
    Eco.Persistence.IDefaultReverseMapping
        Eco.Persistence.Default.DateTimeAsDateTime


Inheritance Hierarchy

Inheritance Hierarchy
Inheritance Hierarchy
Eco.Persistence.Default.AbstractSingleColumnAttribute
Eco.Persistence.ISingleColumnAttributemapping
    Eco.Persistence.Default.GenericDateTimeMapper
    Eco.Persistence.IDefaultReverseMapping
        Eco.Persistence.Default.DateTimeAsTimeStamp


Inheritance Hierarchy

Inheritance Hierarchy
Inheritance Hierarchy
Eco.Persistence.Default.AbstractSingleColumnAttribute
    Eco.Persistence.Default.AbstractNumericSingleColumnAttribute
    Eco.Persistence.IDefaultReverseMapping
    Eco.Persistence.ISingleColumnAttributemapping
        Eco.Persistence.Default.DecimalAsDecimal


Inheritance Hierarchy

Inheritance Hierarchy
Inheritance Hierarchy
Eco.Persistence.Default.AbstractSingleColumnAttribute
    Eco.Persistence.Default.AbstractNumericSingleColumnAttribute
    Eco.Persistence.IDefaultReverseMapping
    Eco.Persistence.ISingleColumnAttributemapping
        Eco.Persistence.Default.DoubleAsDouble


Inheritance Hierarchy

Inheritance Hierarchy
Inheritance Hierarchy
Eco.Persistence.Default.AbstractSingleColumnAttribute
Eco.Persistence.ISingleColumnAttributemapping
    Eco.Persistence.Default.GenericAttributeMapper


Inheritance Hierarchy

Inheritance Hierarchy
Inheritance Hierarchy
Eco.Persistence.Default.AbstractSingleColumnAttribute
Eco.Persistence.ISingleColumnAttributemapping
    Eco.Persistence.Default.GenericDateTimeMapper
        Eco.Persistence.Default.DateTimeAsDateTime
        Eco.Persistence.Default.DateTimeAsTimeStamp


Inheritance Hierarchy

Inheritance Hierarchy
Inheritance Hierarchy
Eco.Persistence.Default.AbstractSingleColumnAttribute
    Eco.Persistence.Default.AbstractNumericSingleColumnAttribute
    Eco.Persistence.ISingleColumnAttributemapping
        Eco.Persistence.IGenericSingleColumnAttributemapping
            Eco.Persistence.Default.GenericEnumAsInteger


Inheritance Hierarchy

Inheritance Hierarchy
Inheritance Hierarchy
Eco.Persistence.Default.AbstractSingleColumnAttribute
    Eco.Persistence.Default.AbstractStringSingleColumnAttribute
    Eco.Persistence.ISingleColumnAttributemapping
        Eco.Persistence.IGenericSingleColumnAttributemapping
            Eco.Persistence.Default.GenericEnumAsVarChar


Inheritance Hierarchy

Inheritance Hierarchy
Inheritance Hierarchy
Eco.Persistence.Default.AbstractSingleColumnAttribute
Eco.Persistence.ISingleColumnAttributemapping
    Eco.Persistence.Default.GenericTimeSpanMapper
        Eco.Persistence.Default.TimeSpanAsDateTime
        Eco.Persistence.Default.TimeSpanAsTimeStamp


Inheritance Hierarchy

Inheritance Hierarchy
Inheritance Hierarchy
Eco.Persistence.Default.AbstractSingleColumnAttribute
    Eco.Persistence.Default.AbstractStringSingleColumnAttribute
    Eco.Persistence.ISingleColumnAttributemapping
        Eco.Persistence.Default.GuidAsVarChar32


Inheritance Hierarchy

Inheritance Hierarchy
Inheritance Hierarchy
Eco.Persistence.Default.AbstractSingleColumnAttribute
    Eco.Persistence.Default.AbstractNumericSingleColumnAttribute
    Eco.Persistence.IDefaultReverseMapping
    Eco.Persistence.ISingleColumnAttributemapping
        Eco.Persistence.Default.Int16AsSmallint


Inheritance Hierarchy

Inheritance Hierarchy
Inheritance Hierarchy
Eco.Persistence.Default.AbstractSingleColumnAttribute
    Eco.Persistence.Default.AbstractNumericSingleColumnAttribute
    Eco.Persistence.IDefaultReverseMapping
    Eco.Persistence.ISingleColumnAttributemapping
        Eco.Persistence.Default.Int32AsInteger


Inheritance Hierarchy

Inheritance Hierarchy
Inheritance Hierarchy
Eco.Persistence.Default.AbstractSingleColumnAttribute
    Eco.Persistence.Default.AbstractNumericSingleColumnAttribute
    Eco.Persistence.IDefaultReverseMapping
    Eco.Persistence.ISingleColumnAttributemapping
        Eco.Persistence.Default.Int64AsLongInteger


Inheritance Hierarchy

Inheritance Hierarchy
Inheritance Hierarchy
Eco.Persistence.Default.InvalidFieldTypeException


Inheritance Hierarchy

Inheritance Hierarchy
Inheritance Hierarchy
Eco.Persistence.Default.MappingUtils


Inheritance Hierarchy

Inheritance Hierarchy
Inheritance Hierarchy
Eco.Persistence.Default.AbstractSingleColumnAttribute
    Eco.Persistence.Default.AbstractNumericSingleColumnAttribute
    Eco.Persistence.ISingleColumnAttributemapping
        Eco.Persistence.Default.SByteAsSmallInt


Inheritance Hierarchy

Inheritance Hierarchy
Inheritance Hierarchy
Eco.Persistence.Default.AbstractSingleColumnAttribute
    Eco.Persistence.Default.AbstractNumericSingleColumnAttribute
    Eco.Persistence.IDefaultReverseMapping
    Eco.Persistence.ISingleColumnAttributemapping
        Eco.Persistence.Default.SingleAsSingle


Inheritance Hierarchy

Inheritance Hierarchy
Inheritance Hierarchy
Eco.Persistence.Default.AbstractSingleColumnAttribute
    Eco.Persistence.Default.AbstractStringSingleColumnAttribute
    Eco.Persistence.IDefaultReverseMapping
    Eco.Persistence.ISingleColumnAttributemapping
        Eco.Persistence.Default.StringAsChar


Inheritance Hierarchy

Inheritance Hierarchy
Inheritance Hierarchy
Eco.Persistence.Default.AbstractSingleColumnAttribute
    Eco.Persistence.Default.AbstractStringSingleColumnAttribute
    Eco.Persistence.ISingleColumnAttributemapping
        Eco.Persistence.Default.StringAsNChar


Inheritance Hierarchy

Inheritance Hierarchy
Inheritance Hierarchy
Eco.Persistence.Default.AbstractSingleColumnAttribute
    Eco.Persistence.Default.AbstractStringSingleColumnAttribute
    Eco.Persistence.IDefaultReverseMapping
    Eco.Persistence.ISingleColumnAttributemapping
        Eco.Persistence.Default.StringAsNVarChar


Inheritance Hierarchy

Inheritance Hierarchy
Inheritance Hierarchy
Eco.Persistence.Default.AbstractSingleColumnAttribute
    Eco.Persistence.Default.AbstractStringSingleColumnAttribute
    Eco.Persistence.IDefaultReverseMapping
    Eco.Persistence.ISingleColumnAttributemapping
        Eco.Persistence.Default.StringAsVarChar


Inheritance Hierarchy

Inheritance Hierarchy
Inheritance Hierarchy
Eco.Persistence.Default.AbstractSingleColumnAttribute
Eco.Persistence.ISingleColumnAttributemapping
    Eco.Persistence.Default.GenericTimeSpanMapper
        Eco.Persistence.Default.TimeSpanAsDateTime


Inheritance Hierarchy

Inheritance Hierarchy
Inheritance Hierarchy
Eco.Persistence.Default.AbstractSingleColumnAttribute
Eco.Persistence.ISingleColumnAttributemapping
    Eco.Persistence.Default.GenericTimeSpanMapper
        Eco.Persistence.Default.TimeSpanAsTimeStamp


Inheritance Hierarchy

Inheritance Hierarchy
Inheritance Hierarchy
Eco.Persistence.IAttributemapping
    Eco.Persistence.Default.TimeStampAsTwoInt32


Inheritance Hierarchy

Inheritance Hierarchy
Inheritance Hierarchy
Eco.Persistence.Default.AbstractSingleColumnAttribute
    Eco.Persistence.Default.AbstractNumericSingleColumnAttribute
    Eco.Persistence.ISingleColumnAttributemapping
        Eco.Persistence.Default.UInt16AsLongInteger


Inheritance Hierarchy

Inheritance Hierarchy
Inheritance Hierarchy
Eco.Persistence.Default.AbstractSingleColumnAttribute
    Eco.Persistence.Default.AbstractNumericSingleColumnAttribute
    Eco.Persistence.ISingleColumnAttributemapping
        Eco.Persistence.Default.UInt32AsLongInteger


Inheritance Hierarchy

Inheritance Hierarchy
Inheritance Hierarchy
Eco.Persistence.Default.AbstractSingleColumnAttribute
    Eco.Persistence.Default.AbstractNumericSingleColumnAttribute
    Eco.Persistence.ISingleColumnAttributemapping
        Eco.Persistence.Default.UInt64AsDecimal


Inheritance Hierarchy

Inheritance Hierarchy
Inheritance Hierarchy
Eco.Persistence.IConfigureCleanPS
    Eco.Persistence.DefaultCleanPsConfig


Inheritance Hierarchy

Inheritance Hierarchy
Inheritance Hierarchy
Eco.Persistence.GenericKeyMapper
    Eco.Persistence.DefaultEcoKeyMapperBase
    Eco.Persistence.IKeyMapper
        Eco.Persistence.DefaultEcoIdMapper


Inheritance Hierarchy

Inheritance Hierarchy
Inheritance Hierarchy
Eco.Persistence.GenericKeyMapper
    Eco.Persistence.DefaultEcoKeyMapperBase
    Eco.Persistence.IKeyMapper
        Eco.Persistence.DefaultEcoInt64KeyMapper


Inheritance Hierarchy

Inheritance Hierarchy
Inheritance Hierarchy
Eco.Persistence.GenericKeyMapper
    Eco.Persistence.DefaultEcoKeyMapperBase
        Eco.Persistence.DefaultEcoIdMapper
        Eco.Persistence.DefaultEcoInt64KeyMapper


Inheritance Hierarchy

Inheritance Hierarchy
Inheritance Hierarchy
Eco.Persistence.DistributedTransactionManager


Inheritance Hierarchy

Inheritance Hierarchy
Inheritance Hierarchy
Eco.Persistence.EcoCantGetNewObjectIdException


Inheritance Hierarchy

Inheritance Hierarchy
Inheritance Hierarchy
Eco.Persistence.Evolutor.TBoldScriptOperation
    Eco.Persistence.Evolutor.TBoldAddColumn


Inheritance Hierarchy

Inheritance Hierarchy
Inheritance Hierarchy
Eco.Persistence.Evolutor.TBoldScriptOperation
    Eco.Persistence.Evolutor.TBoldAddTable


Inheritance Hierarchy

Inheritance Hierarchy
Inheritance Hierarchy
Eco.Persistence.Evolutor.TBoldScriptOperation
    Eco.Persistence.Evolutor.TBoldTwoTableOperation
        Eco.Persistence.Evolutor.TBoldCopyInstances


Inheritance Hierarchy

Inheritance Hierarchy
Inheritance Hierarchy
Eco.Persistence.IDBEvolutor
    Eco.Persistence.Evolutor.TBoldDataBaseEvolutor


Inheritance Hierarchy

Inheritance Hierarchy
Inheritance Hierarchy
Eco.Persistence.Evolutor.TBoldDataBaseEvolutorScript


Inheritance Hierarchy

Inheritance Hierarchy
Inheritance Hierarchy
Eco.Persistence.Evolutor.TBoldScriptOperation
    Eco.Persistence.Evolutor.TBoldTableOperation
        Eco.Persistence.Evolutor.TBoldDeleteInstances


Inheritance Hierarchy

Inheritance Hierarchy
Inheritance Hierarchy
Eco.Persistence.Evolutor.TBoldScriptOperation
    Eco.Persistence.Evolutor.TBoldDropColumn


Inheritance Hierarchy

Inheritance Hierarchy
Inheritance Hierarchy
Eco.Persistence.Evolutor.TBoldScriptOperation
    Eco.Persistence.Evolutor.TBoldDropIndex


Inheritance Hierarchy

Inheritance Hierarchy
Inheritance Hierarchy
Eco.Persistence.Evolutor.TBoldScriptOperation
    Eco.Persistence.Evolutor.TBoldDropTable


Inheritance Hierarchy

Inheritance Hierarchy
Inheritance Hierarchy
Eco.Persistence.Evolutor.TBoldScriptOperation
    Eco.Persistence.Evolutor.TBoldTwoTableOperation
        Eco.Persistence.Evolutor.TBoldTwoColumnOperation
            Eco.Persistence.Evolutor.TBoldMoveData


Inheritance Hierarchy

Inheritance Hierarchy
Inheritance Hierarchy
Eco.Persistence.Evolutor.TBoldScriptOperation
    Eco.Persistence.Evolutor.TBoldAddColumn
    Eco.Persistence.Evolutor.TBoldAddTable
    Eco.Persistence.Evolutor.TBoldDropColumn
    Eco.Persistence.Evolutor.TBoldDropIndex
    Eco.Persistence.Evolutor.TBoldDropTable
    Eco.Persistence.Evolutor.TBoldTableOperation
    Eco.Persistence.Evolutor.TBoldTwoTableOperation


Inheritance Hierarchy

Inheritance Hierarchy
Inheritance Hierarchy
Eco.Persistence.Evolutor.TBoldScriptOperation
    Eco.Persistence.Evolutor.TBoldTwoTableOperation
        Eco.Persistence.Evolutor.TBoldCopyInstances
        Eco.Persistence.Evolutor.TBoldTwoColumnOperation


Inheritance Hierarchy

Inheritance Hierarchy
Inheritance Hierarchy
Eco.Persistence.IDefaultReverseMapping
Eco.Persistence.ISingleColumnAttributemapping
    Eco.Persistence.Firebird.ByteArrayAsBlob


Inheritance Hierarchy

Inheritance Hierarchy
Inheritance Hierarchy
Eco.Persistence.IDefaultReverseMapping
Eco.Persistence.ISingleColumnAttributemapping
    Eco.Persistence.Firebird.DecimalAsDecimal


Inheritance Hierarchy

Inheritance Hierarchy
Inheritance Hierarchy
Eco.Persistence.IDefaultReverseMapping
Eco.Persistence.ISingleColumnAttributemapping
    Eco.Persistence.Firebird.StringAsBlob


Inheritance Hierarchy

Inheritance Hierarchy
Inheritance Hierarchy
Eco.Persistence.FormerNamesHandler


Inheritance Hierarchy

Inheritance Hierarchy
Inheritance Hierarchy
Eco.Persistence.GenericKeyMapper
    Eco.Persistence.AbstractAutoGuidKeyMapper
    Eco.Persistence.AbstractAutoIncKeyMapper
    Eco.Persistence.AttributeKeyMapper
    Eco.Persistence.DefaultEcoKeyMapperBase
    Eco.Persistence.GuidKeyMapper


Inheritance Hierarchy

Inheritance Hierarchy
Inheritance Hierarchy
Eco.Persistence.GenericKeyMapper
Eco.Persistence.IKeyMapper
    Eco.Persistence.GuidKeyMapper


Inheritance Hierarchy

Inheritance Hierarchy
Inheritance Hierarchy
Eco.Persistence.IAutoHookable
    Eco.Persistence.AbstractPersistenceMapperBlackfish
    Eco.Persistence.PersistenceMapperAdo2
    Eco.Persistence.PersistenceMapperBdp
    Eco.Persistence.PersistenceMapperBlackfish
    Eco.Persistence.PersistenceMapperBlackfishRemote
    Eco.Persistence.PersistenceMapperDbx
    Eco.Persistence.PersistenceMapperFirebird
    Eco.Persistence.PersistenceMapperMimer
    Eco.Persistence.PersistenceMapperNexusDB
    Eco.Persistence.PersistenceMapperSybase


Inheritance Hierarchy

Inheritance Hierarchy
Inheritance Hierarchy
Eco.Persistence.ISingleColumnAttributemapping
    Eco.Persistence.IAutoIncAttributemapping
        Eco.Persistence.Blackfish.Int32AsAutoInc
        Eco.Persistence.Interbase.Int16AsAutoInc
        Eco.Persistence.Interbase.Int32AsAutoInc
        Eco.Persistence.Mimer.Int32AsAutoInc
        Eco.Persistence.MySql.Int16AsAutoInc
        Eco.Persistence.MySql.Int32AsAutoInc
        Eco.Persistence.Nexus.Int32AsAutoInc
        Eco.Persistence.Oracle.Int32AsAutoInc
        Eco.Persistence.SQLite.Int32AsAutoInc
        Eco.Persistence.SqlServer.DecimalAsAutoInc
        Eco.Persistence.SqlServer.GuidAsUniqueIdentifierWithDefault
        Eco.Persistence.SqlServer.Int16AsAutoInc
        Eco.Persistence.SqlServer.Int32AsAutoInc
        Eco.Persistence.Sybase.Int32AsNumericIdentity


Inheritance Hierarchy

Inheritance Hierarchy
Inheritance Hierarchy
Eco.Persistence.IAutoIncIdMapper
    Eco.Persistence.AbstractAutoGuidKeyMapper
    Eco.Persistence.AbstractAutoIncKeyMapper
    Eco.Persistence.AutoGuidKeyMapper
    Eco.Persistence.AutoInc16KeyMapper
    Eco.Persistence.AutoIncKeyMapper


Inheritance Hierarchy

Inheritance Hierarchy
Inheritance Hierarchy
Eco.Persistence.IDefaultReverseMapping
    Eco.Persistence.Blackfish.BooleanAsBoolean
    Eco.Persistence.Blackfish.Int32AsAutoInc
    Eco.Persistence.Blackfish.Int64AsBigInt
    Eco.Persistence.Blackfish.SingleAsFloat
    Eco.Persistence.Db2.DecimalAsDecimal
    Eco.Persistence.Db2.Int64AsBigInt
    Eco.Persistence.Db2.Int64AsLongInteger
    Eco.Persistence.Db2.SingleAsFloat
    Eco.Persistence.Default.CharAsChar
    Eco.Persistence.Default.CharAsNChar
    Eco.Persistence.Default.DateTimeAsDateTime
    Eco.Persistence.Default.DateTimeAsTimeStamp
    Eco.Persistence.Default.DecimalAsDecimal
    Eco.Persistence.Default.DoubleAsDouble
    Eco.Persistence.Default.Int16AsSmallint
    Eco.Persistence.Default.Int32AsInteger
    Eco.Persistence.Default.Int64AsLongInteger
    Eco.Persistence.Default.SingleAsSingle
    Eco.Persistence.Default.StringAsChar
    Eco.Persistence.Default.StringAsNVarChar
    Eco.Persistence.Default.StringAsVarChar
    Eco.Persistence.Firebird.ByteArrayAsBlob
    Eco.Persistence.Firebird.DecimalAsDecimal
    Eco.Persistence.Firebird.StringAsBlob
    Eco.Persistence.Interbase.BooleanAsBoolean
    Eco.Persistence.Interbase.DecimalAsDecimal
    Eco.Persistence.Interbase.Int64AsLongInteger
    Eco.Persistence.MySql.ByteAsUnsingedTinyInt
    Eco.Persistence.MySql.DateTimeAsDateTime
    Eco.Persistence.MySql.Int16AsAutoInc
    Eco.Persistence.MySql.Int32AsAutoInc
    Eco.Persistence.MySql.Int64AsBigInt
    Eco.Persistence.MySql.MysClient.ByteArrayAsBlob
    Eco.Persistence.MySql.MysClient.Int64AsBigInt
    Eco.Persistence.MySql.MysClient.StringAsLongText
    Eco.Persistence.MySql.MysClient.StringAsUnicodeText
    Eco.Persistence.MySql.MysClient.StringAsUnicodeVarChar
    Eco.Persistence.MySql.UInt16AsUnsignedSmallint
    Eco.Persistence.Nexus.BooleanAsBool
    Eco.Persistence.Nexus.ByteArrayAsNexusDBBlob
    Eco.Persistence.Nexus.DecimalAsDecimal
    Eco.Persistence.Nexus.DoubleAsDouble
    Eco.Persistence.Nexus.GuidAsGuid
    Eco.Persistence.Nexus.Int32AsAutoInc
    Eco.Persistence.Nexus.Int64AsBigInt
    Eco.Persistence.Nexus.SingleAsFloat
    Eco.Persistence.Nexus.StringAsNexusDBClob
    Eco.Persistence.Nexus.StringAsNexusDBNClob
    Eco.Persistence.Nexus.StringAsVarChar
    Eco.Persistence.Oracle.DateTimeAsDate
    Eco.Persistence.Oracle.DateTimeAsTimeStamp
    Eco.Persistence.Oracle.DecimalAsDecimal
    Eco.Persistence.Oracle.DoubleAsNumber
    Eco.Persistence.Oracle.Int32AsNumber
    Eco.Persistence.Oracle.Int64AsLongInteger
    Eco.Persistence.Oracle.SingleAsSingle
    Eco.Persistence.OracleClient.ByteArrayAsBlob
    Eco.Persistence.OracleClient.StringAsClob
    Eco.Persistence.OracleClient.StringAsNClob
    Eco.Persistence.OracleClient.StringAsVarChar2
    Eco.Persistence.SQLite.ByteArrayAsBLOB
    Eco.Persistence.SQLite.Int32AsInteger
    Eco.Persistence.SQLite.SingleAsFloat
    Eco.Persistence.SQLite.StringAsText
    Eco.Persistence.SqlServer.BooleanAsBit
    Eco.Persistence.SqlServer.ByteAsTinyInt
    Eco.Persistence.SqlServer.DateTimeAsDateTime
    Eco.Persistence.SqlServer.DecimalAsAutoInc
    Eco.Persistence.SqlServer.DecimalAsDecimal
    Eco.Persistence.SqlServer.DecimalAsMoney
    Eco.Persistence.SqlServer.DecimalAsSmallMoney
    Eco.Persistence.SqlServer.GuidAsUniqueIdentifier
    Eco.Persistence.SqlServer.Int16AsAutoInc
    Eco.Persistence.SqlServer.Int32AsAutoInc
    Eco.Persistence.SqlServer.Int32AsInt
    Eco.Persistence.SqlServer.Int64AsLongInteger
    Eco.Persistence.SqlServer.SingleAsFloat
    Eco.Persistence.SqlServer.SingleAsReal
    Eco.Persistence.SqlServer.SqlClient.ByteArrayAsImage
    Eco.Persistence.SqlServer.SqlClient.StringAsNText
    Eco.Persistence.SqlServer.SqlClient.StringAsText
    Eco.Persistence.SqlServer.StringAsXml
    Eco.Persistence.Sybase.BooleanAsBit
    Eco.Persistence.Sybase.Int32AsNumericIdentity
    Eco.Persistence.Sybase.SingleAsFloat


Inheritance Hierarchy

Inheritance Hierarchy
Inheritance Hierarchy
Eco.Persistence.IDistributedTransactionParticipant
    Eco.Persistence.Connection.Ado2IDatabaseImpl


Inheritance Hierarchy

Inheritance Hierarchy
Inheritance Hierarchy
Eco.Persistence.ISingleColumnAttributemapping
    Eco.Persistence.IGenericSingleColumnAttributemapping
        Eco.Persistence.Default.GenericEnumAsInteger
        Eco.Persistence.Default.GenericEnumAsVarChar


Inheritance Hierarchy

Inheritance Hierarchy
Inheritance Hierarchy
Eco.Persistence.IKeyMapper
    Eco.Persistence.AbstractAutoGuidKeyMapper
    Eco.Persistence.AbstractAutoIncKeyMapper
    Eco.Persistence.AttributeKeyMapper
    Eco.Persistence.AutoGuidKeyMapper
    Eco.Persistence.AutoInc16KeyMapper
    Eco.Persistence.AutoIncKeyMapper
    Eco.Persistence.DefaultEcoIdMapper
    Eco.Persistence.DefaultEcoInt64KeyMapper
    Eco.Persistence.GuidKeyMapper


Example 1

Example 1

ECO_ID in (1, 5, 9)


Example 2

Example 2

ECO_ID = 2


Example 3

Example 3

ECO_ID in (?, ?, ?, ?) [actual datavalues are stored in parameters] Example composite key: (FIRSTNAME='Peter' AND LASTNAME='Smith') OR (FIRSTNAME='John' AND LASTNAME='Lane') OR (FIRSTNAME='Dave' AND LASTNAME='Short')


Inheritance Hierarchy

Inheritance Hierarchy
Inheritance Hierarchy
Eco.Persistence.INonBooleanBooleanMapping
    Eco.Persistence.Default.BooleanAsInteger
    Eco.Persistence.Default.BooleanAsYNChar
    Eco.Persistence.Interbase.BooleanAsBoolean
    Eco.Persistence.Nexus.BooleanAsBool
    Eco.Persistence.Oracle.BooleanAsInteger
    Eco.Persistence.SQLite.BooleanAsInteger


Inheritance Hierarchy

Inheritance Hierarchy
Inheritance Hierarchy
Eco.Persistence.Interbase.AbstractAutoInc
    Eco.Persistence.Interbase.Int16AsAutoInc
    Eco.Persistence.Interbase.Int32AsAutoInc


Inheritance Hierarchy

Inheritance Hierarchy
Inheritance Hierarchy
Eco.Persistence.IDefaultReverseMapping
Eco.Persistence.INonBooleanBooleanMapping
Eco.Persistence.ISingleColumnAttributemapping
    Eco.Persistence.Interbase.BooleanAsBoolean


Inheritance Hierarchy

Inheritance Hierarchy
Inheritance Hierarchy
Eco.Persistence.ISingleColumnAttributemapping
    Eco.Persistence.Interbase.ByteArrayAsBdpBlob


Inheritance Hierarchy

Inheritance Hierarchy
Inheritance Hierarchy
Eco.Persistence.ISingleColumnAttributemapping
    Eco.Persistence.Interbase.CharAsNCharUnicode


Inheritance Hierarchy

Inheritance Hierarchy
Inheritance Hierarchy
Eco.Persistence.IDefaultReverseMapping
Eco.Persistence.ISingleColumnAttributemapping
    Eco.Persistence.Interbase.DecimalAsDecimal


Inheritance Hierarchy

Inheritance Hierarchy
Inheritance Hierarchy
Eco.Persistence.ISingleColumnAttributemapping
    Eco.Persistence.IAutoIncAttributemapping
    Eco.Persistence.Interbase.AbstractAutoInc
        Eco.Persistence.Interbase.Int16AsAutoInc


Inheritance Hierarchy

Inheritance Hierarchy
Inheritance Hierarchy
Eco.Persistence.ISingleColumnAttributemapping
    Eco.Persistence.IAutoIncAttributemapping
    Eco.Persistence.Interbase.AbstractAutoInc
        Eco.Persistence.Interbase.Int32AsAutoInc


Inheritance Hierarchy

Inheritance Hierarchy
Inheritance Hierarchy
Eco.Persistence.IDefaultReverseMapping
Eco.Persistence.ISingleColumnAttributemapping
    Eco.Persistence.Interbase.Int64AsLongInteger


Inheritance Hierarchy

Inheritance Hierarchy
Inheritance Hierarchy
Eco.Persistence.ISingleColumnAttributemapping
    Eco.Persistence.Interbase.StringAsBdpBlob


Inheritance Hierarchy

Inheritance Hierarchy
Inheritance Hierarchy
Eco.Persistence.ISingleColumnAttributemapping
    Eco.Persistence.Interbase.StringAsNCharUnicode


Inheritance Hierarchy

Inheritance Hierarchy
Inheritance Hierarchy
Eco.Persistence.IOptimisticLockHandler


Inheritance Hierarchy

Inheritance Hierarchy
Inheritance Hierarchy
Eco.Persistence.IPersistenceMapper
    Eco.Persistence.AbstractDataBlockPersistenceMapper
    Eco.Persistence.ChainedPersistenceMapperImplBase


Inheritance Hierarchy

Inheritance Hierarchy
Inheritance Hierarchy
Eco.Persistence.IPersistenceMapperDb
    Eco.Persistence.PersistenceMapperDb


Inheritance Hierarchy

Inheritance Hierarchy
Inheritance Hierarchy
Eco.Persistence.IPersistencemapperProvider
    Eco.Persistence.PersistenceMapper
    Eco.Persistence.PersistenceMapperProvider


Inheritance Hierarchy

Inheritance Hierarchy
Inheritance Hierarchy
Eco.Persistence.IPersistenceMapperWithIDatabase


Inheritance Hierarchy

Inheritance Hierarchy
Inheritance Hierarchy
Eco.Persistence.IRemotePersistenceMapperProvider
    Eco.Persistence.PersistenceMapperProvider


Inheritance Hierarchy

Inheritance Hierarchy
Inheritance Hierarchy
Eco.Persistence.ISingleColumnAttributemapping
    Eco.Persistence.Blackfish.BooleanAsBoolean
    Eco.Persistence.Blackfish.ByteArrayAsBdpVarBinary
    Eco.Persistence.Blackfish.ByteArrayAsVarBinary
    Eco.Persistence.Blackfish.CharAsVarChar1
    Eco.Persistence.Blackfish.Int64AsBigInt
    Eco.Persistence.Blackfish.SingleAsFloat
    Eco.Persistence.Blackfish.StringAsText
    Eco.Persistence.Db2.DecimalAsDecimal
    Eco.Persistence.Db2.Int64AsBigInt
    Eco.Persistence.Db2.Int64AsLongInteger
    Eco.Persistence.Db2.SingleAsFloat
    Eco.Persistence.Db2.StringAsDbClob
    Eco.Persistence.Dbx.Blackfish.ByteArrayAsDbxVarBinary
    Eco.Persistence.Dbx.Db2.StringAsDbClob
    Eco.Persistence.Dbx.Interbase.ByteArrayAsDbxBlob
    Eco.Persistence.Dbx.Interbase.StringAsDbxBlob
    Eco.Persistence.Dbx.Interbase.StringAsDbxVarChar
    Eco.Persistence.Dbx.MySql.ByteArrayAsDbxBlob
    Eco.Persistence.Dbx.MySql.StringAsLongText
    Eco.Persistence.Dbx.Oracle.ByteArrayAsBlob
    Eco.Persistence.Dbx.Oracle.StringAsClob
    Eco.Persistence.Dbx.Oracle.StringAsNClob
    Eco.Persistence.Dbx.SqlServer.ByteArrayAsImage
    Eco.Persistence.Dbx.SqlServer.ByteAsTinyInt
    Eco.Persistence.Dbx.SqlServer.StringAsNText
    Eco.Persistence.Dbx.SqlServer.StringAsText
    Eco.Persistence.Dbx.Sybase.ByteArrayAsImage
    Eco.Persistence.Dbx.Sybase.StringAsText
    Eco.Persistence.Default.BooleanAsInteger
    Eco.Persistence.Default.BooleanAsYNChar
    Eco.Persistence.Default.ByteAsSmallInt
    Eco.Persistence.Default.CharAsChar
    Eco.Persistence.Default.CharAsNChar
    Eco.Persistence.Default.ColorAsInteger
    Eco.Persistence.Default.DecimalAsDecimal
    Eco.Persistence.Default.DoubleAsDouble
    Eco.Persistence.Default.GenericAttributeMapper
    Eco.Persistence.Default.GenericDateTimeMapper
    Eco.Persistence.Default.GenericTimeSpanMapper
    Eco.Persistence.Default.GuidAsVarChar32
    Eco.Persistence.Default.Int16AsSmallint
    Eco.Persistence.Default.Int32AsInteger
    Eco.Persistence.Default.Int64AsLongInteger
    Eco.Persistence.Default.SByteAsSmallInt
    Eco.Persistence.Default.SingleAsSingle
    Eco.Persistence.Default.StringAsChar
    Eco.Persistence.Default.StringAsNChar
    Eco.Persistence.Default.StringAsNVarChar
    Eco.Persistence.Default.StringAsVarChar
    Eco.Persistence.Default.UInt16AsLongInteger
    Eco.Persistence.Default.UInt32AsLongInteger
    Eco.Persistence.Default.UInt64AsDecimal
    Eco.Persistence.Firebird.ByteArrayAsBlob
    Eco.Persistence.Firebird.DecimalAsDecimal
    Eco.Persistence.Firebird.StringAsBlob
    Eco.Persistence.IAutoIncAttributemapping
    Eco.Persistence.IGenericSingleColumnAttributemapping
    Eco.Persistence.Interbase.BooleanAsBoolean
    Eco.Persistence.Interbase.ByteArrayAsBdpBlob
    Eco.Persistence.Interbase.CharAsNCharUnicode
    Eco.Persistence.Interbase.DecimalAsDecimal
    Eco.Persistence.Interbase.Int64AsLongInteger
    Eco.Persistence.Interbase.StringAsBdpBlob
    Eco.Persistence.Interbase.StringAsNCharUnicode
    Eco.Persistence.Mimer.ByteArrayAsMimerBlob
    Eco.Persistence.Mimer.Int64AsBigInt
    Eco.Persistence.Mimer.SingleAsFloat
    Eco.Persistence.Mimer.StringAsMimerClob
    Eco.Persistence.Mimer.StringAsMimerNClob
    Eco.Persistence.MySql.Bdp.ByteArrayAsBdpBlob
    Eco.Persistence.MySql.Bdp.StringAsLongText
    Eco.Persistence.MySql.ByteAsUnsingedTinyInt
    Eco.Persistence.MySql.DateTimeAsDateTime
    Eco.Persistence.MySql.Int64AsBigInt
    Eco.Persistence.MySql.MysClient.ByteArrayAsBlob
    Eco.Persistence.MySql.MysClient.Int64AsBigInt
    Eco.Persistence.MySql.MysClient.StringAsLongText
    Eco.Persistence.MySql.MysClient.StringAsUnicodeText
    Eco.Persistence.MySql.MysClient.StringAsUnicodeVarChar
    Eco.Persistence.MySql.UInt16AsUnsignedSmallint
    Eco.Persistence.Nexus.BooleanAsBool
    Eco.Persistence.Nexus.ByteArrayAsNexusDBBlob
    Eco.Persistence.Nexus.DecimalAsDecimal
    Eco.Persistence.Nexus.DoubleAsDouble
    Eco.Persistence.Nexus.GuidAsGuid
    Eco.Persistence.Nexus.Int64AsBigInt
    Eco.Persistence.Nexus.SingleAsFloat
    Eco.Persistence.Nexus.StringAsNexusDBClob
    Eco.Persistence.Nexus.StringAsNexusDBNClob
    Eco.Persistence.Nexus.StringAsVarChar
    Eco.Persistence.Oracle.BooleanAsInteger
    Eco.Persistence.Oracle.ByteArrayAsBlob
    Eco.Persistence.Oracle.ByteAsSmallInt
    Eco.Persistence.Oracle.DateTimeAsDate
    Eco.Persistence.Oracle.DateTimeAsTimeStamp
    Eco.Persistence.Oracle.DecimalAsDecimal
    Eco.Persistence.Oracle.DoubleAsNumber
    Eco.Persistence.Oracle.Int16AsNumber
    Eco.Persistence.Oracle.Int32AsNumber
    Eco.Persistence.Oracle.Int64AsLongInteger
    Eco.Persistence.Oracle.SingleAsSingle
    Eco.Persistence.Oracle.StringAsClob
    Eco.Persistence.Oracle.StringAsNClob
    Eco.Persistence.Oracle.StringAsVarChar2
    Eco.Persistence.Oracle.TimeSpanAsDate
    Eco.Persistence.Oracle.TimeSpanAsLongInteger
    Eco.Persistence.OracleClient.ByteArrayAsBlob
    Eco.Persistence.OracleClient.StringAsClob
    Eco.Persistence.OracleClient.StringAsNClob
    Eco.Persistence.OracleClient.StringAsVarChar2
    Eco.Persistence.SQLite.BooleanAsInteger
    Eco.Persistence.SQLite.ByteArrayAsBLOB
    Eco.Persistence.SQLite.Int32AsInteger
    Eco.Persistence.SQLite.Int64AsInteger
    Eco.Persistence.SQLite.SingleAsFloat
    Eco.Persistence.SQLite.StringAsText
    Eco.Persistence.SqlServer.Bdp.ByteArrayAsImage
    Eco.Persistence.SqlServer.Bdp.ByteAsTinyInt
    Eco.Persistence.SqlServer.Bdp.StringAsNText
    Eco.Persistence.SqlServer.Bdp.StringAsText
    Eco.Persistence.SqlServer.BooleanAsBit
    Eco.Persistence.SqlServer.ByteAsTinyInt
    Eco.Persistence.SqlServer.DateTimeAsDateTime
    Eco.Persistence.SqlServer.DateTimeAsDateTimeWithoutMilliseconds
    Eco.Persistence.SqlServer.DecimalAsDecimal
    Eco.Persistence.SqlServer.DecimalAsDecimal28
    Eco.Persistence.SqlServer.DecimalAsMoney
    Eco.Persistence.SqlServer.DecimalAsSmallMoney
    Eco.Persistence.SqlServer.GuidAsUniqueIdentifier
    Eco.Persistence.SqlServer.Int32AsInt
    Eco.Persistence.SqlServer.Int64AsLongInteger
    Eco.Persistence.SqlServer.Int64AsTimeStamp
    Eco.Persistence.SqlServer.SingleAsFloat
    Eco.Persistence.SqlServer.SingleAsReal
    Eco.Persistence.SqlServer.SqlClient.ByteArrayAsImage
    Eco.Persistence.SqlServer.SqlClient.StringAsNText
    Eco.Persistence.SqlServer.SqlClient.StringAsText
    Eco.Persistence.SqlServer.StringAsXml
    Eco.Persistence.SqlServer.TimeSpanAsDateTime
    Eco.Persistence.Sybase.Ase.ByteArrayAsImage
    Eco.Persistence.Sybase.Ase.StringAsText
    Eco.Persistence.Sybase.Ase.StringAsUniVarChar
    Eco.Persistence.Sybase.Bdp.ByteArrayAsImage
    Eco.Persistence.Sybase.Bdp.StringAsText
    Eco.Persistence.Sybase.BooleanAsBit
    Eco.Persistence.Sybase.SingleAsFloat


Inheritance Hierarchy

Inheritance Hierarchy
Inheritance Hierarchy
Eco.Persistence.LocalTransactionManager


Inheritance Hierarchy

Inheritance Hierarchy
Inheritance Hierarchy
Eco.Persistence.MemberIndexColumnIndex


Inheritance Hierarchy

Inheritance Hierarchy
Inheritance Hierarchy
Eco.Persistence.Mimer.AbstractAutoInc
    Eco.Persistence.Mimer.Int32AsAutoInc


Inheritance Hierarchy

Inheritance Hierarchy
Inheritance Hierarchy
Eco.Persistence.Mimer.AbstractByteArrayAsMimerBlob
    Eco.Persistence.Mimer.ByteArrayAsMimerBlob


Inheritance Hierarchy

Inheritance Hierarchy
Inheritance Hierarchy
Eco.Persistence.Mimer.AbstractStringAsMimerClob
    Eco.Persistence.Mimer.StringAsMimerClob


Inheritance Hierarchy

Inheritance Hierarchy
Inheritance Hierarchy
Eco.Persistence.Mimer.AbstractStringAsMimerNClob
    Eco.Persistence.Mimer.StringAsMimerNClob


Inheritance Hierarchy

Inheritance Hierarchy
Inheritance Hierarchy
Eco.Persistence.ISingleColumnAttributemapping
Eco.Persistence.Mimer.AbstractByteArrayAsMimerBlob
    Eco.Persistence.Mimer.ByteArrayAsMimerBlob


Inheritance Hierarchy

Inheritance Hierarchy
Inheritance Hierarchy
Eco.Persistence.ISingleColumnAttributemapping
    Eco.Persistence.IAutoIncAttributemapping
    Eco.Persistence.Mimer.AbstractAutoInc
        Eco.Persistence.Mimer.Int32AsAutoInc


Inheritance Hierarchy

Inheritance Hierarchy
Inheritance Hierarchy
Eco.Persistence.ISingleColumnAttributemapping
    Eco.Persistence.Mimer.Int64AsBigInt


Inheritance Hierarchy

Inheritance Hierarchy
Inheritance Hierarchy
Eco.Persistence.ISingleColumnAttributemapping
    Eco.Persistence.Mimer.SingleAsFloat


Inheritance Hierarchy

Inheritance Hierarchy
Inheritance Hierarchy
Eco.Persistence.ISingleColumnAttributemapping
Eco.Persistence.Mimer.AbstractStringAsMimerClob
    Eco.Persistence.Mimer.StringAsMimerClob


Inheritance Hierarchy

Inheritance Hierarchy
Inheritance Hierarchy
Eco.Persistence.ISingleColumnAttributemapping
Eco.Persistence.Mimer.AbstractStringAsMimerNClob
    Eco.Persistence.Mimer.StringAsMimerNClob


Inheritance Hierarchy

Inheritance Hierarchy
Inheritance Hierarchy
Eco.Persistence.ISingleColumnAttributemapping
    Eco.Persistence.MySql.Bdp.ByteArrayAsBdpBlob


Inheritance Hierarchy

Inheritance Hierarchy
Inheritance Hierarchy
Eco.Persistence.ISingleColumnAttributemapping
    Eco.Persistence.MySql.Bdp.StringAsLongText


Inheritance Hierarchy

Inheritance Hierarchy
Inheritance Hierarchy
Eco.Persistence.IDefaultReverseMapping
Eco.Persistence.ISingleColumnAttributemapping
    Eco.Persistence.MySql.ByteAsUnsingedTinyInt


Inheritance Hierarchy

Inheritance Hierarchy
Inheritance Hierarchy
Eco.Persistence.IDefaultReverseMapping
Eco.Persistence.ISingleColumnAttributemapping
    Eco.Persistence.MySql.DateTimeAsDateTime


Inheritance Hierarchy

Inheritance Hierarchy
Inheritance Hierarchy
Eco.Persistence.ISingleColumnAttributemapping
    Eco.Persistence.IAutoIncAttributemapping
    Eco.Persistence.IDefaultReverseMapping
        Eco.Persistence.MySql.Int16AsAutoInc


Inheritance Hierarchy

Inheritance Hierarchy
Inheritance Hierarchy
Eco.Persistence.ISingleColumnAttributemapping
    Eco.Persistence.IAutoIncAttributemapping
    Eco.Persistence.IDefaultReverseMapping
        Eco.Persistence.MySql.Int32AsAutoInc


Inheritance Hierarchy

Inheritance Hierarchy
Inheritance Hierarchy
Eco.Persistence.IDefaultReverseMapping
Eco.Persistence.ISingleColumnAttributemapping
    Eco.Persistence.MySql.Int64AsBigInt


Inheritance Hierarchy

Inheritance Hierarchy
Inheritance Hierarchy
Eco.Persistence.IDefaultReverseMapping
Eco.Persistence.ISingleColumnAttributemapping
    Eco.Persistence.MySql.MysClient.ByteArrayAsBlob


Inheritance Hierarchy

Inheritance Hierarchy
Inheritance Hierarchy
Eco.Persistence.IDefaultReverseMapping
Eco.Persistence.ISingleColumnAttributemapping
    Eco.Persistence.MySql.MysClient.Int64AsBigInt


Inheritance Hierarchy

Inheritance Hierarchy
Inheritance Hierarchy
Eco.Persistence.IDefaultReverseMapping
Eco.Persistence.ISingleColumnAttributemapping
    Eco.Persistence.MySql.MysClient.StringAsLongText


Inheritance Hierarchy

Inheritance Hierarchy
Inheritance Hierarchy
Eco.Persistence.IDefaultReverseMapping
Eco.Persistence.ISingleColumnAttributemapping
    Eco.Persistence.MySql.MysClient.StringAsUnicodeText


Inheritance Hierarchy

Inheritance Hierarchy
Inheritance Hierarchy
Eco.Persistence.IDefaultReverseMapping
Eco.Persistence.ISingleColumnAttributemapping
    Eco.Persistence.MySql.MysClient.StringAsUnicodeVarChar


Inheritance Hierarchy

Inheritance Hierarchy
Inheritance Hierarchy
Eco.Persistence.MySql.MySqlStringRes


Inheritance Hierarchy

Inheritance Hierarchy
Inheritance Hierarchy
Eco.Persistence.IDefaultReverseMapping
Eco.Persistence.ISingleColumnAttributemapping
    Eco.Persistence.MySql.UInt16AsUnsignedSmallint


Inheritance Hierarchy

Inheritance Hierarchy
Inheritance Hierarchy
Eco.Persistence.Nexus.AbstractAutoInc
    Eco.Persistence.Nexus.Int32AsAutoInc


Inheritance Hierarchy

Inheritance Hierarchy
Inheritance Hierarchy
Eco.Persistence.Nexus.AbstractByteArrayAsNexusDBBlob
    Eco.Persistence.Nexus.ByteArrayAsNexusDBBlob


Inheritance Hierarchy

Inheritance Hierarchy
Inheritance Hierarchy
Eco.Persistence.Nexus.AbstractStringAsNexusDBClob
    Eco.Persistence.Nexus.StringAsNexusDBClob


Inheritance Hierarchy

Inheritance Hierarchy
Inheritance Hierarchy
Eco.Persistence.Nexus.AbstractStringAsNexusDBNClob
    Eco.Persistence.Nexus.StringAsNexusDBNClob


Inheritance Hierarchy

Inheritance Hierarchy
Inheritance Hierarchy
Eco.Persistence.IDefaultReverseMapping
Eco.Persistence.INonBooleanBooleanMapping
Eco.Persistence.ISingleColumnAttributemapping
    Eco.Persistence.Nexus.BooleanAsBool


Inheritance Hierarchy

Inheritance Hierarchy
Inheritance Hierarchy
Eco.Persistence.IDefaultReverseMapping
Eco.Persistence.ISingleColumnAttributemapping
Eco.Persistence.Nexus.AbstractByteArrayAsNexusDBBlob
    Eco.Persistence.Nexus.ByteArrayAsNexusDBBlob


Inheritance Hierarchy

Inheritance Hierarchy
Inheritance Hierarchy
Eco.Persistence.IDefaultReverseMapping
Eco.Persistence.ISingleColumnAttributemapping
    Eco.Persistence.Nexus.DecimalAsDecimal


Inheritance Hierarchy

Inheritance Hierarchy
Inheritance Hierarchy
Eco.Persistence.IDefaultReverseMapping
Eco.Persistence.ISingleColumnAttributemapping
    Eco.Persistence.Nexus.DoubleAsDouble


Inheritance Hierarchy

Inheritance Hierarchy
Inheritance Hierarchy
Eco.Persistence.IDefaultReverseMapping
Eco.Persistence.ISingleColumnAttributemapping
    Eco.Persistence.Nexus.GuidAsGuid


Inheritance Hierarchy

Inheritance Hierarchy
Inheritance Hierarchy
Eco.Persistence.ISingleColumnAttributemapping
    Eco.Persistence.IAutoIncAttributemapping
    Eco.Persistence.IDefaultReverseMapping
    Eco.Persistence.Nexus.AbstractAutoInc
        Eco.Persistence.Nexus.Int32AsAutoInc


Inheritance Hierarchy

Inheritance Hierarchy
Inheritance Hierarchy
Eco.Persistence.IDefaultReverseMapping
Eco.Persistence.ISingleColumnAttributemapping
    Eco.Persistence.Nexus.Int64AsBigInt


Inheritance Hierarchy

Inheritance Hierarchy
Inheritance Hierarchy
Eco.Persistence.Nexus.NxIDatabaseImpl


Inheritance Hierarchy

Inheritance Hierarchy
Inheritance Hierarchy
Eco.Persistence.IDefaultReverseMapping
Eco.Persistence.ISingleColumnAttributemapping
    Eco.Persistence.Nexus.SingleAsFloat


Inheritance Hierarchy

Inheritance Hierarchy
Inheritance Hierarchy
Eco.Persistence.IDefaultReverseMapping
Eco.Persistence.ISingleColumnAttributemapping
Eco.Persistence.Nexus.AbstractStringAsNexusDBClob
    Eco.Persistence.Nexus.StringAsNexusDBClob


Inheritance Hierarchy

Inheritance Hierarchy
Inheritance Hierarchy
Eco.Persistence.IDefaultReverseMapping
Eco.Persistence.ISingleColumnAttributemapping
Eco.Persistence.Nexus.AbstractStringAsNexusDBNClob
    Eco.Persistence.Nexus.StringAsNexusDBNClob


Inheritance Hierarchy

Inheritance Hierarchy
Inheritance Hierarchy
Eco.Persistence.IDefaultReverseMapping
Eco.Persistence.ISingleColumnAttributemapping
    Eco.Persistence.Nexus.StringAsVarChar


Inheritance Hierarchy

Inheritance Hierarchy
Inheritance Hierarchy
Eco.Persistence.AbstractCondition
    Eco.Persistence.OclCondition


Inheritance Hierarchy

Inheritance Hierarchy
Inheritance Hierarchy
Eco.Persistence.OclCondition.IExternalVariable


Inheritance Hierarchy

Inheritance Hierarchy
Inheritance Hierarchy
Eco.Persistence.UpdateResult
    Eco.Persistence.OkResult


Inheritance Hierarchy

Inheritance Hierarchy
Inheritance Hierarchy
Eco.Persistence.UpdatePrecondition
    Eco.Persistence.OptimisticLockingPrecondition


Inheritance Hierarchy

Inheritance Hierarchy
Inheritance Hierarchy
Eco.Persistence.UpdateResult
    Eco.Persistence.OptimisticLockingResult


Inheritance Hierarchy

Inheritance Hierarchy
Inheritance Hierarchy
Eco.Persistence.Oracle.AbstractAutoInc
    Eco.Persistence.Oracle.Int32AsAutoInc


Inheritance Hierarchy

Inheritance Hierarchy
Inheritance Hierarchy
Eco.Persistence.INonBooleanBooleanMapping
Eco.Persistence.ISingleColumnAttributemapping
    Eco.Persistence.Oracle.BooleanAsInteger


Inheritance Hierarchy

Inheritance Hierarchy
Inheritance Hierarchy
Eco.Persistence.ISingleColumnAttributemapping
    Eco.Persistence.Oracle.ByteArrayAsBlob


Inheritance Hierarchy

Inheritance Hierarchy
Inheritance Hierarchy
Eco.Persistence.ISingleColumnAttributemapping
    Eco.Persistence.Oracle.ByteAsSmallInt


Inheritance Hierarchy

Inheritance Hierarchy
Inheritance Hierarchy
Eco.Persistence.IDefaultReverseMapping
Eco.Persistence.ISingleColumnAttributemapping
    Eco.Persistence.Oracle.DateTimeAsDate


Inheritance Hierarchy

Inheritance Hierarchy
Inheritance Hierarchy
Eco.Persistence.IDefaultReverseMapping
Eco.Persistence.ISingleColumnAttributemapping
    Eco.Persistence.Oracle.DateTimeAsTimeStamp


Inheritance Hierarchy

Inheritance Hierarchy
Inheritance Hierarchy
Eco.Persistence.IDefaultReverseMapping
Eco.Persistence.ISingleColumnAttributemapping
    Eco.Persistence.Oracle.DecimalAsDecimal


Inheritance Hierarchy

Inheritance Hierarchy
Inheritance Hierarchy
Eco.Persistence.IDefaultReverseMapping
Eco.Persistence.ISingleColumnAttributemapping
    Eco.Persistence.Oracle.DoubleAsNumber


Inheritance Hierarchy

Inheritance Hierarchy
Inheritance Hierarchy
Eco.Persistence.ISingleColumnAttributemapping
    Eco.Persistence.Oracle.Int16AsNumber


Inheritance Hierarchy

Inheritance Hierarchy
Inheritance Hierarchy
Eco.Persistence.ISingleColumnAttributemapping
    Eco.Persistence.IAutoIncAttributemapping
    Eco.Persistence.Oracle.AbstractAutoInc
        Eco.Persistence.Oracle.Int32AsAutoInc


Inheritance Hierarchy

Inheritance Hierarchy
Inheritance Hierarchy
Eco.Persistence.IDefaultReverseMapping
Eco.Persistence.ISingleColumnAttributemapping
    Eco.Persistence.Oracle.Int32AsNumber


Inheritance Hierarchy

Inheritance Hierarchy
Inheritance Hierarchy
Eco.Persistence.IDefaultReverseMapping
Eco.Persistence.ISingleColumnAttributemapping
    Eco.Persistence.Oracle.Int64AsLongInteger


Inheritance Hierarchy

Inheritance Hierarchy
Inheritance Hierarchy
Eco.Persistence.IDefaultReverseMapping
Eco.Persistence.ISingleColumnAttributemapping
    Eco.Persistence.Oracle.SingleAsSingle


Inheritance Hierarchy

Inheritance Hierarchy
Inheritance Hierarchy
Eco.Persistence.ISingleColumnAttributemapping
    Eco.Persistence.Oracle.StringAsClob


Inheritance Hierarchy

Inheritance Hierarchy
Inheritance Hierarchy
Eco.Persistence.ISingleColumnAttributemapping
    Eco.Persistence.Oracle.StringAsNClob


Inheritance Hierarchy

Inheritance Hierarchy
Inheritance Hierarchy
Eco.Persistence.ISingleColumnAttributemapping
    Eco.Persistence.Oracle.StringAsVarChar2


Inheritance Hierarchy

Inheritance Hierarchy
Inheritance Hierarchy
Eco.Persistence.ISingleColumnAttributemapping
    Eco.Persistence.Oracle.TimeSpanAsDate


Inheritance Hierarchy

Inheritance Hierarchy
Inheritance Hierarchy
Eco.Persistence.ISingleColumnAttributemapping
    Eco.Persistence.Oracle.TimeSpanAsLongInteger


Inheritance Hierarchy

Inheritance Hierarchy
Inheritance Hierarchy
Eco.Persistence.IDefaultReverseMapping
Eco.Persistence.ISingleColumnAttributemapping
    Eco.Persistence.OracleClient.ByteArrayAsBlob


Inheritance Hierarchy

Inheritance Hierarchy
Inheritance Hierarchy
Eco.Persistence.IDefaultReverseMapping
Eco.Persistence.ISingleColumnAttributemapping
    Eco.Persistence.OracleClient.StringAsClob


Inheritance Hierarchy

Inheritance Hierarchy
Inheritance Hierarchy
Eco.Persistence.IDefaultReverseMapping
Eco.Persistence.ISingleColumnAttributemapping
    Eco.Persistence.OracleClient.StringAsNClob


Inheritance Hierarchy

Inheritance Hierarchy
Inheritance Hierarchy
Eco.Persistence.IDefaultReverseMapping
Eco.Persistence.ISingleColumnAttributemapping
    Eco.Persistence.OracleClient.StringAsVarChar2


Inheritance Hierarchy

Inheritance Hierarchy
Inheritance Hierarchy
Eco.Persistence.ORMapping.AliasCollection


Inheritance Hierarchy

Inheritance Hierarchy
Inheritance Hierarchy
Eco.Persistence.ORMapping.NamedDefinition
    Eco.Persistence.ORMapping.AliasDefinition


Inheritance Hierarchy

Inheritance Hierarchy
Inheritance Hierarchy
Eco.Persistence.ORMapping.NamedDefinition
    Eco.Persistence.ORMapping.StructuralFeatureDefinition
        Eco.Persistence.ORMapping.AttributeDefinition


Inheritance Hierarchy

Inheritance Hierarchy
Inheritance Hierarchy
Eco.Persistence.ORMapping.ClassCollection


Inheritance Hierarchy

Inheritance Hierarchy
Inheritance Hierarchy
Eco.Persistence.ORMapping.NamedDefinition
    Eco.Persistence.ORMapping.ClassDefinition


Inheritance Hierarchy

Inheritance Hierarchy
Inheritance Hierarchy
Eco.Persistence.ORMapping.ColumnCollection


Inheritance Hierarchy

Inheritance Hierarchy
Inheritance Hierarchy
Eco.Persistence.ORMapping.NamedDefinition
    Eco.Persistence.ORMapping.ColumnDefinition


Inheritance Hierarchy

Inheritance Hierarchy
Inheritance Hierarchy
Eco.Persistence.ORMapping.ColumnReference


Inheritance Hierarchy

Inheritance Hierarchy
Inheritance Hierarchy
Eco.Persistence.ORMapping.ColumnReferenceCollection


Inheritance Hierarchy

Inheritance Hierarchy
Inheritance Hierarchy
Eco.Persistence.ORMapping.ColumnTypeFixer


Inheritance Hierarchy

Inheritance Hierarchy
Inheritance Hierarchy
Eco.Persistence.ORMapping.Common


Inheritance Hierarchy

Inheritance Hierarchy
Inheritance Hierarchy
Eco.Persistence.ORMapping.ConstantColumnCollection


Inheritance Hierarchy

Inheritance Hierarchy
Inheritance Hierarchy
Eco.Persistence.ORMapping.ConstantColumnDefinition


Inheritance Hierarchy

Inheritance Hierarchy
Inheritance Hierarchy
Eco.Persistence.ORMapping.DatabaseCollection


Inheritance Hierarchy

Inheritance Hierarchy
Inheritance Hierarchy
Eco.Persistence.ORMapping.NamedDefinition
    Eco.Persistence.ORMapping.DatabaseDefinition


Inheritance Hierarchy

Inheritance Hierarchy
Inheritance Hierarchy
Eco.Persistence.ORMapping.IORMappingProvider
    Eco.Persistence.ORMapping.DbMappingProvider


Inheritance Hierarchy

Inheritance Hierarchy
Inheritance Hierarchy
Eco.Persistence.ORMapping.DbMetaSupport


Inheritance Hierarchy

Inheritance Hierarchy
Inheritance Hierarchy
Eco.Persistence.ORMapping.IORMappingProvider
    Eco.Persistence.ORMapping.DefaultORMappingBuilder


Inheritance Hierarchy

Inheritance Hierarchy
Inheritance Hierarchy
Eco.Persistence.ORMapping.NamedDefinition
    Eco.Persistence.ORMapping.DiscriminatorDef


Inheritance Hierarchy

Inheritance Hierarchy
Inheritance Hierarchy
Eco.Persistence.ORMapping.DiscriminatorDefCollection


Inheritance Hierarchy

Inheritance Hierarchy
Inheritance Hierarchy
Eco.Persistence.ORMapping.DiscriminatorImplementation


Inheritance Hierarchy

Inheritance Hierarchy
Inheritance Hierarchy
Eco.Persistence.ORMapping.DiscriminatorImplementationCollection


Inheritance Hierarchy

Inheritance Hierarchy
Inheritance Hierarchy
Eco.Persistence.ORMapping.DiscriminatorValue


Inheritance Hierarchy

Inheritance Hierarchy
Inheritance Hierarchy
Eco.Persistence.ORMapping.DiscriminatorValueCollection


Inheritance Hierarchy

Inheritance Hierarchy
Inheritance Hierarchy
Eco.Persistence.ORMapping.FeatureCollection


Inheritance Hierarchy

Inheritance Hierarchy
Inheritance Hierarchy
Eco.Persistence.ORMapping.IORMappingProvider
    Eco.Persistence.ORMapping.FileMappingProvider


Inheritance Hierarchy

Inheritance Hierarchy
Inheritance Hierarchy
Eco.Persistence.ORMapping.ForeignKeyCollection


Inheritance Hierarchy

Inheritance Hierarchy
Inheritance Hierarchy
Eco.Persistence.ORMapping.NamedDefinition
    Eco.Persistence.ORMapping.ForeignKeyDefinition


Inheritance Hierarchy

Inheritance Hierarchy
Inheritance Hierarchy
Eco.Persistence.ORMapping.IndexCollection


Inheritance Hierarchy

Inheritance Hierarchy
Inheritance Hierarchy
Eco.Persistence.ORMapping.NamedDefinition
    Eco.Persistence.ORMapping.IndexDefinition


Inheritance Hierarchy

Inheritance Hierarchy
Inheritance Hierarchy
Eco.Persistence.ORMapping.IORMappingProvider
    Eco.Persistence.ORMapping.DbMappingProvider
    Eco.Persistence.ORMapping.DefaultORMappingBuilder
    Eco.Persistence.ORMapping.FileMappingProvider


Inheritance Hierarchy

Inheritance Hierarchy
Inheritance Hierarchy
Eco.Persistence.ORMapping.NamedDefinition
    Eco.Persistence.ORMapping.KeyDefinition


Inheritance Hierarchy

Inheritance Hierarchy
Inheritance Hierarchy
Eco.Persistence.ORMapping.KeyDefinitionCollection


Inheritance Hierarchy

Inheritance Hierarchy
Inheritance Hierarchy
Eco.Persistence.ORMapping.KeyImplementation


Inheritance Hierarchy

Inheritance Hierarchy
Inheritance Hierarchy
Eco.Persistence.ORMapping.KeyImplementationCollection


Inheritance Hierarchy

Inheritance Hierarchy
Inheritance Hierarchy
Eco.Persistence.ORMapping.NamedDefinition
    Eco.Persistence.ORMapping.AliasDefinition
    Eco.Persistence.ORMapping.ClassDefinition
    Eco.Persistence.ORMapping.ColumnDefinition
    Eco.Persistence.ORMapping.DatabaseDefinition
    Eco.Persistence.ORMapping.DiscriminatorDef
    Eco.Persistence.ORMapping.ForeignKeyDefinition
    Eco.Persistence.ORMapping.IndexDefinition
    Eco.Persistence.ORMapping.KeyDefinition
    Eco.Persistence.ORMapping.StructuralFeatureDefinition
    Eco.Persistence.ORMapping.TableDefinition


Inheritance Hierarchy

Inheritance Hierarchy
Inheritance Hierarchy
Eco.Persistence.ORMapping.ORMappingDefinition


Inheritance Hierarchy

Inheritance Hierarchy
Inheritance Hierarchy
Eco.Persistence.ORMapping.ORMappingValidator


Inheritance Hierarchy

Inheritance Hierarchy
Inheritance Hierarchy
Eco.Persistence.ORMapping.ORMappingXmlGenerator


Inheritance Hierarchy

Inheritance Hierarchy
Inheritance Hierarchy
Eco.Persistence.ORMapping.ORMappingXmlReader


Inheritance Hierarchy

Inheritance Hierarchy
Inheritance Hierarchy
Eco.Persistence.ORMapping.NamedDefinition
    Eco.Persistence.ORMapping.StructuralFeatureDefinition
        Eco.Persistence.ORMapping.SingleLinkDefinition


Inheritance Hierarchy

Inheritance Hierarchy
Inheritance Hierarchy
Eco.Persistence.ORMapping.NamedDefinition
    Eco.Persistence.ORMapping.StructuralFeatureDefinition
        Eco.Persistence.ORMapping.AttributeDefinition
        Eco.Persistence.ORMapping.SingleLinkDefinition


Inheritance Hierarchy

Inheritance Hierarchy
Inheritance Hierarchy
Eco.Persistence.ORMapping.TableCollection


Inheritance Hierarchy

Inheritance Hierarchy
Inheritance Hierarchy
Eco.Persistence.ORMapping.NamedDefinition
    Eco.Persistence.ORMapping.TableDefinition


Inheritance Hierarchy

Inheritance Hierarchy
Inheritance Hierarchy
Eco.Persistence.IPersistencemapperProvider
    Eco.Persistence.PersistenceMapper
        Eco.Persistence.AbstractDataBlockPersistenceMapper
        Eco.Persistence.AbstractPersistenceMapperDb
        Eco.Persistence.ChainedPersistenceMapperBase
        Eco.Persistence.PersistenceMapperSharer
        Eco.Persistence.Remoting.PersistenceMapperClient


Inheritance Hierarchy

Inheritance Hierarchy
Inheritance Hierarchy
Eco.Persistence.IPersistencemapperProvider
    Eco.Persistence.PersistenceMapper
        Eco.Persistence.AbstractPersistenceMapperDb
        Eco.Persistence.IPersistenceMapperDb
            Eco.Persistence.PersistenceMapperDb
            Eco.Persistence.IAutoHookable
                Eco.Persistence.PersistenceMapperAdo2
                    Eco.Persistence.AbstractPersistenceMapperBlackfish
                    Eco.Persistence.PersistenceMapperDbx
                    Eco.Persistence.PersistenceMapperFirebird
                    Eco.Persistence.PersistenceMapperMimer
                    Eco.Persistence.PersistenceMapperMySql
                    Eco.Persistence.PersistenceMapperNexusDB
                    Eco.Persistence.PersistenceMapperOracle
                    Eco.Persistence.PersistenceMapperSQLite
                    Eco.Persistence.PersistenceMapperSqlServer


Inheritance Hierarchy

Inheritance Hierarchy
Inheritance Hierarchy
Eco.Persistence.IPersistencemapperProvider
    Eco.Persistence.PersistenceMapper
        Eco.Persistence.AbstractPersistenceMapperDb
        Eco.Persistence.IPersistenceMapperDb
            Eco.Persistence.PersistenceMapperDb
            Eco.Persistence.IAutoHookable
                Eco.Persistence.PersistenceMapperBdp


Inheritance Hierarchy

Inheritance Hierarchy
Inheritance Hierarchy
Eco.Persistence.IPersistencemapperProvider
    Eco.Persistence.PersistenceMapper
        Eco.Persistence.AbstractPersistenceMapperDb
        Eco.Persistence.IPersistenceMapperDb
            Eco.Persistence.PersistenceMapperDb
            Eco.Persistence.IAutoHookable
                Eco.Persistence.PersistenceMapperAdo2
                    Eco.Persistence.AbstractPersistenceMapperBlackfish
                        Eco.Persistence.PersistenceMapperBlackfish


Inheritance Hierarchy

Inheritance Hierarchy
Inheritance Hierarchy
Eco.Persistence.IPersistencemapperProvider
    Eco.Persistence.PersistenceMapper
        Eco.Persistence.AbstractPersistenceMapperDb
        Eco.Persistence.IPersistenceMapperDb
            Eco.Persistence.PersistenceMapperDb
            Eco.Persistence.IAutoHookable
                Eco.Persistence.PersistenceMapperAdo2
                    Eco.Persistence.AbstractPersistenceMapperBlackfish
                        Eco.Persistence.PersistenceMapperBlackfishRemote


Inheritance Hierarchy

Inheritance Hierarchy
Inheritance Hierarchy
Eco.Persistence.IPersistencemapperProvider
    Eco.Persistence.PersistenceMapper
        Eco.Persistence.AbstractPersistenceMapperDb
        Eco.Persistence.IPersistenceMapperDb
            Eco.Persistence.PersistenceMapperDb
                Eco.Persistence.PersistenceMapperAdo2
                Eco.Persistence.PersistenceMapperBdp
                Eco.Persistence.PersistenceMapperSybase


Inheritance Hierarchy

Inheritance Hierarchy
Inheritance Hierarchy
Eco.Persistence.PersistenceMapperDbCollection


Inheritance Hierarchy

Inheritance Hierarchy
Inheritance Hierarchy
Eco.Persistence.IPersistencemapperProvider
    Eco.Persistence.PersistenceMapper
        Eco.Persistence.AbstractPersistenceMapperDb
        Eco.Persistence.IPersistenceMapperDb
            Eco.Persistence.PersistenceMapperDb
            Eco.Persistence.IAutoHookable
                Eco.Persistence.PersistenceMapperAdo2
                    Eco.Persistence.PersistenceMapperDbx


Inheritance Hierarchy

Inheritance Hierarchy
Inheritance Hierarchy
Eco.Persistence.IPersistencemapperProvider
    Eco.Persistence.PersistenceMapper
        Eco.Persistence.AbstractPersistenceMapperDb
        Eco.Persistence.IPersistenceMapperDb
            Eco.Persistence.PersistenceMapperDb
            Eco.Persistence.IAutoHookable
                Eco.Persistence.PersistenceMapperAdo2
                    Eco.Persistence.PersistenceMapperFirebird


Inheritance Hierarchy

Inheritance Hierarchy
Inheritance Hierarchy
Eco.Persistence.IPersistencemapperProvider
    Eco.Persistence.PersistenceMapper
    Eco.Persistence.IPersistenceMapper
        Eco.Persistence.AbstractDataBlockPersistenceMapper
            Eco.Persistence.PersistenceMapperMemory


Inheritance Hierarchy

Inheritance Hierarchy
Inheritance Hierarchy
Eco.Persistence.IPersistencemapperProvider
    Eco.Persistence.PersistenceMapper
        Eco.Persistence.AbstractPersistenceMapperDb
        Eco.Persistence.IPersistenceMapperDb
            Eco.Persistence.PersistenceMapperDb
            Eco.Persistence.IAutoHookable
                Eco.Persistence.PersistenceMapperAdo2
                    Eco.Persistence.PersistenceMapperMimer


Inheritance Hierarchy

Inheritance Hierarchy
Inheritance Hierarchy
Eco.Persistence.IPersistencemapperProvider
    Eco.Persistence.PersistenceMapper
        Eco.Persistence.AbstractPersistenceMapperDb
            Eco.Persistence.PersistenceMapperMultiDb


Inheritance Hierarchy

Inheritance Hierarchy
Inheritance Hierarchy
Eco.Persistence.IPersistencemapperProvider
    Eco.Persistence.PersistenceMapper
        Eco.Persistence.AbstractPersistenceMapperDb
        Eco.Persistence.IPersistenceMapperDb
            Eco.Persistence.PersistenceMapperDb
            Eco.Persistence.IAutoHookable
                Eco.Persistence.PersistenceMapperAdo2
                    Eco.Persistence.PersistenceMapperMySql


Inheritance Hierarchy

Inheritance Hierarchy
Inheritance Hierarchy
Eco.Persistence.IPersistencemapperProvider
    Eco.Persistence.PersistenceMapper
        Eco.Persistence.AbstractPersistenceMapperDb
        Eco.Persistence.IPersistenceMapperDb
            Eco.Persistence.PersistenceMapperDb
            Eco.Persistence.IAutoHookable
                Eco.Persistence.PersistenceMapperAdo2
                    Eco.Persistence.PersistenceMapperNexusDB


Inheritance Hierarchy

Inheritance Hierarchy
Inheritance Hierarchy
Eco.Persistence.IPersistencemapperProvider
    Eco.Persistence.PersistenceMapper
        Eco.Persistence.AbstractPersistenceMapperDb
        Eco.Persistence.IPersistenceMapperDb
            Eco.Persistence.PersistenceMapperDb
            Eco.Persistence.IAutoHookable
                Eco.Persistence.PersistenceMapperAdo2
                    Eco.Persistence.PersistenceMapperOracle


Inheritance Hierarchy

Inheritance Hierarchy
Inheritance Hierarchy
Eco.Persistence.IPersistencemapperProvider
Eco.Persistence.IRemotePersistenceMapperProvider
    Eco.Persistence.PersistenceMapperProvider


Example

Example

public EcoProject135PMP(): base() { this.InitializeComponent(); RegisterPersistenceMapper<PersistenceMapperSqlServer>("SqlServer", DataBaseEngine.SqlServerSqlClient); RegisterPersistenceMapper<PersistenceMapperOracle>("Oracle", DataBaseEngine.OracleClient);

string providerName = ... read provider name from config-file string connectionString = ... read connectionstring from config-file this.PersistenceMapper = CreatePersistenceMapper(providerName, connectionString);


Example

Example

In the constructor of the PersistenceMapperProvider in a project, you could register mappers like this: public EcoProject135PMP(): base() { this.InitializeComponent(); RegisterPersistenceMapper<PersistenceMapperSqlServer>("SqlServer", DataBaseEngine.SqlServerSqlClient); RegisterPersistenceMapper<PersistenceMapperOracle>("Oracle", DataBaseEngine.OracleClient);


Inheritance Hierarchy

Inheritance Hierarchy
Inheritance Hierarchy
Eco.Persistence.IPersistencemapperProvider
    Eco.Persistence.PersistenceMapper
        Eco.Persistence.PersistenceMapperSharer


Inheritance Hierarchy

Inheritance Hierarchy
Inheritance Hierarchy
Eco.Persistence.IPersistencemapperProvider
    Eco.Persistence.PersistenceMapper
        Eco.Persistence.AbstractPersistenceMapperDb
        Eco.Persistence.IPersistenceMapperDb
            Eco.Persistence.PersistenceMapperDb
            Eco.Persistence.IAutoHookable
                Eco.Persistence.PersistenceMapperAdo2
                    Eco.Persistence.PersistenceMapperSQLite


Inheritance Hierarchy

Inheritance Hierarchy
Inheritance Hierarchy
Eco.Persistence.IPersistencemapperProvider
    Eco.Persistence.PersistenceMapper
        Eco.Persistence.AbstractPersistenceMapperDb
        Eco.Persistence.IPersistenceMapperDb
            Eco.Persistence.PersistenceMapperDb
            Eco.Persistence.IAutoHookable
                Eco.Persistence.PersistenceMapperAdo2
                    Eco.Persistence.PersistenceMapperSqlServer


Inheritance Hierarchy

Inheritance Hierarchy
Inheritance Hierarchy
Eco.Persistence.IPersistencemapperProvider
    Eco.Persistence.PersistenceMapper
        Eco.Persistence.AbstractPersistenceMapperDb
        Eco.Persistence.IPersistenceMapperDb
            Eco.Persistence.PersistenceMapperDb
            Eco.Persistence.IAutoHookable
                Eco.Persistence.PersistenceMapperSybase


Inheritance Hierarchy

Inheritance Hierarchy
Inheritance Hierarchy
Eco.Persistence.PersistenceStringRes


Inheritance Hierarchy

Inheritance Hierarchy
Inheritance Hierarchy
Eco.Persistence.PMapperDef


Inheritance Hierarchy

Inheritance Hierarchy
Inheritance Hierarchy
Eco.Persistence.IPersistencemapperProvider
    Eco.Persistence.PersistenceMapper
        Eco.Persistence.Remoting.PersistenceMapperClient


Inheritance Hierarchy

Inheritance Hierarchy
Inheritance Hierarchy
Eco.Persistence.Remoting.RemotingException


Inheritance Hierarchy

Inheritance Hierarchy
Inheritance Hierarchy
Eco.Persistence.SimpleORMappingProvider


Inheritance Hierarchy

Inheritance Hierarchy
Inheritance Hierarchy
Eco.Persistence.INonBooleanBooleanMapping
Eco.Persistence.ISingleColumnAttributemapping
    Eco.Persistence.SQLite.BooleanAsInteger


Inheritance Hierarchy

Inheritance Hierarchy
Inheritance Hierarchy
Eco.Persistence.IDefaultReverseMapping
Eco.Persistence.ISingleColumnAttributemapping
    Eco.Persistence.SQLite.ByteArrayAsBLOB


Inheritance Hierarchy

Inheritance Hierarchy
Inheritance Hierarchy
Eco.Persistence.ISingleColumnAttributemapping
    Eco.Persistence.IAutoIncAttributemapping
        Eco.Persistence.SQLite.Int32AsAutoInc


Inheritance Hierarchy

Inheritance Hierarchy
Inheritance Hierarchy
Eco.Persistence.IDefaultReverseMapping
Eco.Persistence.ISingleColumnAttributemapping
    Eco.Persistence.SQLite.Int32AsInteger


Inheritance Hierarchy

Inheritance Hierarchy
Inheritance Hierarchy
Eco.Persistence.ISingleColumnAttributemapping
    Eco.Persistence.SQLite.Int64AsInteger


Inheritance Hierarchy

Inheritance Hierarchy
Inheritance Hierarchy
Eco.Persistence.IDefaultReverseMapping
Eco.Persistence.ISingleColumnAttributemapping
    Eco.Persistence.SQLite.SingleAsFloat


Inheritance Hierarchy

Inheritance Hierarchy
Inheritance Hierarchy
Eco.Persistence.IDefaultReverseMapping
Eco.Persistence.ISingleColumnAttributemapping
    Eco.Persistence.SQLite.StringAsText


Inheritance Hierarchy

Inheritance Hierarchy
Inheritance Hierarchy
Eco.Persistence.ISingleColumnAttributemapping
    Eco.Persistence.SqlServer.Bdp.ByteArrayAsImage


Inheritance Hierarchy

Inheritance Hierarchy
Inheritance Hierarchy
Eco.Persistence.ISingleColumnAttributemapping
    Eco.Persistence.SqlServer.Bdp.ByteAsTinyInt


Inheritance Hierarchy

Inheritance Hierarchy
Inheritance Hierarchy
Eco.Persistence.ISingleColumnAttributemapping
    Eco.Persistence.SqlServer.Bdp.StringAsNText


Inheritance Hierarchy

Inheritance Hierarchy
Inheritance Hierarchy
Eco.Persistence.ISingleColumnAttributemapping
    Eco.Persistence.SqlServer.Bdp.StringAsText


Inheritance Hierarchy

Inheritance Hierarchy
Inheritance Hierarchy
Eco.Persistence.IDefaultReverseMapping
Eco.Persistence.ISingleColumnAttributemapping
    Eco.Persistence.SqlServer.BooleanAsBit


Inheritance Hierarchy

Inheritance Hierarchy
Inheritance Hierarchy
Eco.Persistence.IDefaultReverseMapping
Eco.Persistence.ISingleColumnAttributemapping
    Eco.Persistence.SqlServer.ByteAsTinyInt


Inheritance Hierarchy

Inheritance Hierarchy
Inheritance Hierarchy
Eco.Persistence.IDefaultReverseMapping
Eco.Persistence.ISingleColumnAttributemapping
    Eco.Persistence.SqlServer.DateTimeAsDateTime


Inheritance Hierarchy

Inheritance Hierarchy
Inheritance Hierarchy
Eco.Persistence.ISingleColumnAttributemapping
    Eco.Persistence.SqlServer.DateTimeAsDateTimeWithoutMilliseconds


Inheritance Hierarchy

Inheritance Hierarchy
Inheritance Hierarchy
Eco.Persistence.ISingleColumnAttributemapping
    Eco.Persistence.IAutoIncAttributemapping
    Eco.Persistence.IDefaultReverseMapping
        Eco.Persistence.SqlServer.DecimalAsAutoInc


Inheritance Hierarchy

Inheritance Hierarchy
Inheritance Hierarchy
Eco.Persistence.ISingleColumnAttributemapping
    Eco.Persistence.SqlServer.DecimalAsDecimal28


Inheritance Hierarchy

Inheritance Hierarchy
Inheritance Hierarchy
Eco.Persistence.IDefaultReverseMapping
Eco.Persistence.ISingleColumnAttributemapping
    Eco.Persistence.SqlServer.DecimalAsDecimal


Inheritance Hierarchy

Inheritance Hierarchy
Inheritance Hierarchy
Eco.Persistence.IDefaultReverseMapping
Eco.Persistence.ISingleColumnAttributemapping
    Eco.Persistence.SqlServer.DecimalAsMoney


Inheritance Hierarchy

Inheritance Hierarchy
Inheritance Hierarchy
Eco.Persistence.IDefaultReverseMapping
Eco.Persistence.ISingleColumnAttributemapping
    Eco.Persistence.SqlServer.DecimalAsSmallMoney


Inheritance Hierarchy

Inheritance Hierarchy
Inheritance Hierarchy
Eco.Persistence.IDefaultReverseMapping
Eco.Persistence.ISingleColumnAttributemapping
    Eco.Persistence.SqlServer.GuidAsUniqueIdentifier


Inheritance Hierarchy

Inheritance Hierarchy
Inheritance Hierarchy
Eco.Persistence.ISingleColumnAttributemapping
    Eco.Persistence.IAutoIncAttributemapping
        Eco.Persistence.SqlServer.GuidAsUniqueIdentifierWithDefault


Inheritance Hierarchy

Inheritance Hierarchy
Inheritance Hierarchy
Eco.Persistence.ISingleColumnAttributemapping
    Eco.Persistence.IAutoIncAttributemapping
    Eco.Persistence.IDefaultReverseMapping
        Eco.Persistence.SqlServer.Int16AsAutoInc


Inheritance Hierarchy

Inheritance Hierarchy
Inheritance Hierarchy
Eco.Persistence.ISingleColumnAttributemapping
    Eco.Persistence.IAutoIncAttributemapping
    Eco.Persistence.IDefaultReverseMapping
        Eco.Persistence.SqlServer.Int32AsAutoInc


Inheritance Hierarchy

Inheritance Hierarchy
Inheritance Hierarchy
Eco.Persistence.IDefaultReverseMapping
Eco.Persistence.ISingleColumnAttributemapping
    Eco.Persistence.SqlServer.Int32AsInt


Inheritance Hierarchy

Inheritance Hierarchy
Inheritance Hierarchy
Eco.Persistence.IDefaultReverseMapping
Eco.Persistence.ISingleColumnAttributemapping
    Eco.Persistence.SqlServer.Int64AsLongInteger


Inheritance Hierarchy

Inheritance Hierarchy
Inheritance Hierarchy
Eco.Persistence.ISingleColumnAttributemapping
    Eco.Persistence.SqlServer.Int64AsTimeStamp


Inheritance Hierarchy

Inheritance Hierarchy
Inheritance Hierarchy
Eco.Persistence.IDefaultReverseMapping
Eco.Persistence.ISingleColumnAttributemapping
    Eco.Persistence.SqlServer.SingleAsFloat


Inheritance Hierarchy

Inheritance Hierarchy
Inheritance Hierarchy
Eco.Persistence.IDefaultReverseMapping
Eco.Persistence.ISingleColumnAttributemapping
    Eco.Persistence.SqlServer.SingleAsReal


Inheritance Hierarchy

Inheritance Hierarchy
Inheritance Hierarchy
Eco.Persistence.IDefaultReverseMapping
Eco.Persistence.ISingleColumnAttributemapping
    Eco.Persistence.SqlServer.SqlClient.ByteArrayAsImage


Inheritance Hierarchy

Inheritance Hierarchy
Inheritance Hierarchy
Eco.Persistence.IDefaultReverseMapping
Eco.Persistence.ISingleColumnAttributemapping
    Eco.Persistence.SqlServer.SqlClient.StringAsNText


Inheritance Hierarchy

Inheritance Hierarchy
Inheritance Hierarchy
Eco.Persistence.IDefaultReverseMapping
Eco.Persistence.ISingleColumnAttributemapping
    Eco.Persistence.SqlServer.SqlClient.StringAsText


Inheritance Hierarchy

Inheritance Hierarchy
Inheritance Hierarchy
Eco.Persistence.SqlServer.SqlServerStringRes


Inheritance Hierarchy

Inheritance Hierarchy
Inheritance Hierarchy
Eco.Persistence.IDefaultReverseMapping
Eco.Persistence.ISingleColumnAttributemapping
    Eco.Persistence.SqlServer.StringAsXml


Inheritance Hierarchy

Inheritance Hierarchy
Inheritance Hierarchy
Eco.Persistence.ISingleColumnAttributemapping
    Eco.Persistence.SqlServer.TimeSpanAsDateTime


Inheritance Hierarchy

Inheritance Hierarchy
Inheritance Hierarchy
Eco.Persistence.ISingleColumnAttributemapping
    Eco.Persistence.Sybase.Ase.ByteArrayAsImage


Inheritance Hierarchy

Inheritance Hierarchy
Inheritance Hierarchy
Eco.Persistence.ISingleColumnAttributemapping
    Eco.Persistence.Sybase.Ase.StringAsText


Inheritance Hierarchy

Inheritance Hierarchy
Inheritance Hierarchy
Eco.Persistence.ISingleColumnAttributemapping
    Eco.Persistence.Sybase.Ase.StringAsUniVarChar


Inheritance Hierarchy

Inheritance Hierarchy
Inheritance Hierarchy
Eco.Persistence.ISingleColumnAttributemapping
    Eco.Persistence.Sybase.Bdp.ByteArrayAsImage


Inheritance Hierarchy

Inheritance Hierarchy
Inheritance Hierarchy
Eco.Persistence.ISingleColumnAttributemapping
    Eco.Persistence.Sybase.Bdp.StringAsText


Inheritance Hierarchy

Inheritance Hierarchy
Inheritance Hierarchy
Eco.Persistence.IDefaultReverseMapping
Eco.Persistence.ISingleColumnAttributemapping
    Eco.Persistence.Sybase.BooleanAsBit


Inheritance Hierarchy

Inheritance Hierarchy
Inheritance Hierarchy
Eco.Persistence.ISingleColumnAttributemapping
    Eco.Persistence.IAutoIncAttributemapping
    Eco.Persistence.IDefaultReverseMapping
        Eco.Persistence.Sybase.Int32AsNumericIdentity


Inheritance Hierarchy

Inheritance Hierarchy
Inheritance Hierarchy
Eco.Persistence.IDefaultReverseMapping
Eco.Persistence.ISingleColumnAttributemapping
    Eco.Persistence.Sybase.SingleAsFloat


Inheritance Hierarchy

Inheritance Hierarchy
Inheritance Hierarchy
Eco.Persistence.SyncVersion


Inheritance Hierarchy

Inheritance Hierarchy
Inheritance Hierarchy
Eco.Persistence.TKeyJoinPair


Inheritance Hierarchy

Inheritance Hierarchy
Inheritance Hierarchy
Eco.Persistence.TransactionUtil


Inheritance Hierarchy

Inheritance Hierarchy
Inheritance Hierarchy
Eco.Persistence.TSelectQuery


Inheritance Hierarchy

Inheritance Hierarchy
Inheritance Hierarchy
Eco.Persistence.UpdateResult
    Eco.Persistence.OkResult
    Eco.Persistence.OptimisticLockingResult


Inheritance Hierarchy

Inheritance Hierarchy
Inheritance Hierarchy
Eco.Persistence.Validator.TBoldDbValidator
    Eco.Persistence.Validator.TBoldDbDataValidator


Inheritance Hierarchy

Inheritance Hierarchy
Inheritance Hierarchy
Eco.Persistence.Validator.TBoldDbValidator
    Eco.Persistence.Validator.TBoldDbStructureValidator


Inheritance Hierarchy

Inheritance Hierarchy
Inheritance Hierarchy
Eco.Persistence.Validator.TBoldDbValidator
    Eco.Persistence.Validator.TBoldDbDataValidator
    Eco.Persistence.Validator.TBoldDbStructureValidator


Inheritance Hierarchy

Inheritance Hierarchy
Inheritance Hierarchy
Eco.Persistence.VersionConst


Inheritance Hierarchy

Inheritance Hierarchy
Inheritance Hierarchy
Eco.ReflectionReader.AssociationClassLink


Inheritance Hierarchy

Inheritance Hierarchy
Inheritance Hierarchy
Eco.ReflectionReader.AssociationLink


Inheritance Hierarchy

Inheritance Hierarchy
Inheritance Hierarchy
Eco.ReflectionReader.ClassData


Inheritance Hierarchy

Inheritance Hierarchy
Inheritance Hierarchy
Eco.ReflectionReader.CustomAttributeCracker


Inheritance Hierarchy

Inheritance Hierarchy
Inheritance Hierarchy
Eco.ReflectionReader.NonNavigableAssociationEndData


Inheritance Hierarchy

Inheritance Hierarchy
Inheritance Hierarchy
Eco.ReflectionReader.ReflectionReader


Inheritance Hierarchy

Inheritance Hierarchy
Inheritance Hierarchy
Eco.ReflectionReader.StateMachineReader


Inheritance Hierarchy

Inheritance Hierarchy
Inheritance Hierarchy
Eco.Services.IUndoService
    Eco.Services.ChainedUndoServiceBase


Inheritance Hierarchy

Inheritance Hierarchy
Inheritance Hierarchy
Eco.Services.EcoServiceHelper


Related Topics

Related Topics
Related Topics

IOclPsService, IOclService


Inheritance Hierarchy

Inheritance Hierarchy
Inheritance Hierarchy
Eco.Services.ITypeService
    Eco.Services.IActionLanguageTypeService
        Eco.Services.IActionLanguageService


Inheritance Hierarchy

Inheritance Hierarchy
Inheritance Hierarchy
Eco.Services.IActionLanguageServiceExtensions


Inheritance Hierarchy

Inheritance Hierarchy
Inheritance Hierarchy
Eco.Services.IAutoSubscriptionContext


Inheritance Hierarchy

Inheritance Hierarchy
Inheritance Hierarchy
Eco.Services.IAutoSubscriptionService


Inheritance Hierarchy

Inheritance Hierarchy
Inheritance Hierarchy
Eco.Services.ICacheContentService


Inheritance Hierarchy

Inheritance Hierarchy
Inheritance Hierarchy
Eco.Services.IChange


Inheritance Hierarchy

Inheritance Hierarchy
Inheritance Hierarchy
Eco.Services.IDirtyListService


Inheritance Hierarchy

Inheritance Hierarchy
Inheritance Hierarchy
Eco.Services.IExtentService


Inheritance Hierarchy

Inheritance Hierarchy
Inheritance Hierarchy
Eco.Services.IExternalIdService


Inheritance Hierarchy

Inheritance Hierarchy
Inheritance Hierarchy
Eco.Services.IObjectFactoryService


Related Topics

Related Topics
Related Topics

IOclService, IActionLanguageService


Inheritance Hierarchy

Inheritance Hierarchy
Inheritance Hierarchy
Eco.Services.ITypeService
    Eco.Services.IOclPsTypeService
        Eco.Services.IOclPsService


Inheritance Hierarchy

Inheritance Hierarchy
Inheritance Hierarchy
Eco.Services.IOclPsServiceExtensions


Related Topics

Related Topics
Related Topics

IOclPsService, IActionLanguageService


Inheritance Hierarchy

Inheritance Hierarchy
Inheritance Hierarchy
Eco.Services.ITypeService
    Eco.Services.IOclTypeService
        Eco.Services.IOclService


Inheritance Hierarchy

Inheritance Hierarchy
Inheritance Hierarchy
Eco.Services.IOclServiceExtensions


Related Topics

Related Topics
Related Topics

Eco.ObjectRepresentation.IEcoServiceProvider


Inheritance Hierarchy

Inheritance Hierarchy
Inheritance Hierarchy
Eco.Services.IPersistenceService


Related Topics

Related Topics
Related Topics

SupportsSync


Related Topics

Related Topics
Related Topics

IDirtyListService.AllDirtyObjects, EnsureEnclosure


Inheritance Hierarchy

Inheritance Hierarchy
Inheritance Hierarchy
Eco.Services.IStateService


Inheritance Hierarchy

Inheritance Hierarchy
Inheritance Hierarchy
Eco.Services.IStaticContext


Inheritance Hierarchy

Inheritance Hierarchy
Inheritance Hierarchy
Eco.Services.ITypeService
    Eco.Services.IActionLanguageTypeService
    Eco.Services.IOclPsTypeService
    Eco.Services.IOclTypeService


Inheritance Hierarchy

Inheritance Hierarchy
Inheritance Hierarchy
Eco.Services.ITypeSystemService


Inheritance Hierarchy

Inheritance Hierarchy
Inheritance Hierarchy
Eco.Services.IUndoBlock


Inheritance Hierarchy

Inheritance Hierarchy
Inheritance Hierarchy
Eco.Services.IUndoBlockList


Related Topics

Related Topics
Related Topics

CanMoveBlock


Related Topics

Related Topics
Related Topics

IUndoBlockList.CanMoveBlock


Related Topics

Related Topics
Related Topics

StartTransaction, RollbackTransaction


Related Topics

Related Topics
Related Topics

IUndoService.CanUndoBlock


Related Topics

Related Topics
Related Topics

StartTransaction, CommitTransaction


Related Topics

Related Topics
Related Topics

CommitTransaction, RollbackTransaction


Inheritance Hierarchy

Inheritance Hierarchy
Inheritance Hierarchy
Eco.Services.IVariableFactoryService


Inheritance Hierarchy

Inheritance Hierarchy
Inheritance Hierarchy
Eco.Services.IVersionService


Inheritance Hierarchy

Inheritance Hierarchy
Inheritance Hierarchy
Eco.Services.ObjectListHelper


Inheritance Hierarchy

Inheritance Hierarchy
Inheritance Hierarchy
Eco.Services.OptimisticLockException


Inheritance Hierarchy

Inheritance Hierarchy
Inheritance Hierarchy
Eco.Services.PersistenceServiceExtensions


Related Topics

Related Topics
Related Topics

IPersistenceService.EnsureEnclosure


Inheritance Hierarchy

Inheritance Hierarchy
Inheritance Hierarchy
Eco.Subscription.EventSubscriber


Inheritance Hierarchy

Inheritance Hierarchy
Inheritance Hierarchy
Eco.Subscription.ISubscriber
    Eco.Subscription.SubscriberAdapterBase
    Eco.Subscription.TestSubscriber


Inheritance Hierarchy

Inheritance Hierarchy
Inheritance Hierarchy
Eco.Subscription.Publisher


Inheritance Hierarchy

Inheritance Hierarchy
Inheritance Hierarchy
Eco.Subscription.PublisherList
    Eco.Subscription.PublisherListMulti
    Eco.Subscription.PublisherListSingle


Inheritance Hierarchy

Inheritance Hierarchy
Inheritance Hierarchy
Eco.Subscription.PublisherList
    Eco.Subscription.PublisherListMulti


Inheritance Hierarchy

Inheritance Hierarchy
Inheritance Hierarchy
Eco.Subscription.PublisherList
    Eco.Subscription.PublisherListSingle


Inheritance Hierarchy

Inheritance Hierarchy
Inheritance Hierarchy
Eco.Subscription.ISubscriber
    Eco.Subscription.SubscriberAdapterBase


Inheritance Hierarchy

Inheritance Hierarchy
Inheritance Hierarchy
Eco.Subscription.SubscriberPair


Inheritance Hierarchy

Inheritance Hierarchy
Inheritance Hierarchy
Eco.Subscription.ISubscriber
    Eco.Subscription.TestSubscriber


Inheritance Hierarchy

Inheritance Hierarchy
Inheritance Hierarchy
Eco.Support.CommaTextSupport


Inheritance Hierarchy

Inheritance Hierarchy
Inheritance Hierarchy
Eco.Support.Deriver.AbstractDeriver


Inheritance Hierarchy

Inheritance Hierarchy
Inheritance Hierarchy
Eco.Support.EcoSupport


Inheritance Hierarchy

Inheritance Hierarchy
Inheritance Hierarchy
Eco.Support.HelpHelpers


Inheritance Hierarchy

Inheritance Hierarchy
Inheritance Hierarchy
Eco.Support.SerializationSupport


Inheritance Hierarchy

Inheritance Hierarchy
Inheritance Hierarchy
Eco.Support.TypeSupport


Inheritance Hierarchy

Inheritance Hierarchy
Inheritance Hierarchy
Eco.Tree.EcoTreeAbstractNodeDefinition
    Eco.Tree.EcoTreeRootNodeDefinition
    Eco.Tree.EcoTreeSubNodeDefinition


Inheritance Hierarchy

Inheritance Hierarchy
Inheritance Hierarchy
Eco.Tree.EcoTreeDefinition


Inheritance Hierarchy

Inheritance Hierarchy
Inheritance Hierarchy
Eco.Tree.EcoTreeDefinitionEditor


Inheritance Hierarchy

Inheritance Hierarchy
Inheritance Hierarchy
Eco.Tree.EcoTreeDefinitionHandle


Inheritance Hierarchy

Inheritance Hierarchy
Inheritance Hierarchy
Eco.Tree.EcoTreeDefinitionWinForm


Inheritance Hierarchy

Inheritance Hierarchy
Inheritance Hierarchy
Eco.Tree.EcoTreeAbstractNodeDefinition
    Eco.Tree.EcoTreeRootNodeDefinition


Inheritance Hierarchy

Inheritance Hierarchy
Inheritance Hierarchy
Eco.Tree.EcoTreeAbstractNodeDefinition
    Eco.Tree.EcoTreeSubNodeDefinition


Inheritance Hierarchy

Inheritance Hierarchy
Inheritance Hierarchy
Eco.Tree.EcoTreeUtility


Inheritance Hierarchy

Inheritance Hierarchy
Inheritance Hierarchy
Eco.UmlCodeAttributes.EcoAutoGeneratedAttribute


Inheritance Hierarchy

Inheritance Hierarchy
Inheritance Hierarchy
Eco.UmlCodeAttributes.EcoAutoMaintainedAttribute


Inheritance Hierarchy

Inheritance Hierarchy
Inheritance Hierarchy
Eco.UmlCodeAttributes.EcoCodeGenVersionAttribute


Inheritance Hierarchy

Inheritance Hierarchy
Inheritance Hierarchy
Eco.UmlCodeAttributes.EcoSpaceAttribute


Inheritance Hierarchy

Inheritance Hierarchy
Inheritance Hierarchy
Eco.UmlCodeAttributes.EcoSpacePackageAttribute


Inheritance Hierarchy

Inheritance Hierarchy
Inheritance Hierarchy
Eco.UmlCodeAttributes.InnerLinkAttribute


Inheritance Hierarchy

Inheritance Hierarchy
Inheritance Hierarchy
Eco.UmlCodeAttributes.LinkRoleAttribute


Inheritance Hierarchy

Inheritance Hierarchy
Inheritance Hierarchy
Eco.UmlCodeAttributes.StateMachineAttribute


Inheritance Hierarchy

Inheritance Hierarchy
Inheritance Hierarchy
Eco.UmlCodeAttributes.UmlCollectionAttribute


Inheritance Hierarchy

Inheritance Hierarchy
Inheritance Hierarchy
Eco.UmlCodeAttributes.UmlElementAttribute


Inheritance Hierarchy

Inheritance Hierarchy
Inheritance Hierarchy
Eco.UmlCodeAttributes.UmlMetaAttributeAttribute


Inheritance Hierarchy

Inheritance Hierarchy
Inheritance Hierarchy
Eco.UmlCodeAttributes.UmlTaggedValueAttribute


Inheritance Hierarchy

Inheritance Hierarchy
Inheritance Hierarchy
Eco.UmlRt.UmlTaggedValues
    Eco.UmlRt.EcoTaggedValues


Inheritance Hierarchy

Inheritance Hierarchy
Inheritance Hierarchy
Eco.UmlRt.EcoTaggedValues.DefaultRegionModeTV


Inheritance Hierarchy

Inheritance Hierarchy
Inheritance Hierarchy
Eco.UmlRt.EcoTaggedValues.DeleteActionTV


Inheritance Hierarchy

Inheritance Hierarchy
Inheritance Hierarchy
Eco.UmlRt.EcoTaggedValues.LengthTV


Inheritance Hierarchy

Inheritance Hierarchy
Inheritance Hierarchy
Eco.UmlRt.EcoTaggedValues.LinkFetchStrategyTV


Inheritance Hierarchy

Inheritance Hierarchy
Inheritance Hierarchy
Eco.UmlRt.EcoTaggedValues.OptimisticLockingTV


Inheritance Hierarchy

Inheritance Hierarchy
Inheritance Hierarchy
Eco.UmlRt.EcoTaggedValues.SaveActionTV


Inheritance Hierarchy

Inheritance Hierarchy
Inheritance Hierarchy
Eco.UmlRt.EcoTaggedValues.TableMappingTV


Inheritance Hierarchy

Inheritance Hierarchy
Inheritance Hierarchy
Eco.UmlRt.IActivity


Inheritance Hierarchy

Inheritance Hierarchy
Inheritance Hierarchy
Eco.UmlRt.IModelElement
    Eco.UmlRt.IAssociation
        Eco.UmlRt.IEcoAssociation


Inheritance Hierarchy

Inheritance Hierarchy
Inheritance Hierarchy
Eco.UmlRt.IAssociationCollection


Inheritance Hierarchy

Inheritance Hierarchy
Inheritance Hierarchy
Eco.UmlRt.IModelElement
    Eco.UmlRt.IFeature
        Eco.UmlRt.IStructuralFeature
            Eco.UmlRt.IAssociationEnd
                Eco.UmlRt.IEcoAssociationEnd


Inheritance Hierarchy

Inheritance Hierarchy
Inheritance Hierarchy
Eco.UmlRt.IModelElement
    Eco.UmlRt.IFeature
        Eco.UmlRt.IStructuralFeature
            Eco.UmlRt.IAttribute
                Eco.UmlRt.IEcoAttribute


Inheritance Hierarchy

Inheritance Hierarchy
Inheritance Hierarchy
Eco.UmlRt.IAttributeCollection


Inheritance Hierarchy

Inheritance Hierarchy
Inheritance Hierarchy
Eco.UmlRt.IModelElement
    Eco.UmlRt.IClassifier
        Eco.UmlRt.IDataType
            Eco.UmlRt.ICollectionType
                Eco.UmlRt.IBagType


Inheritance Hierarchy

Inheritance Hierarchy
Inheritance Hierarchy
Eco.UmlRt.IModelElement
    Eco.UmlRt.IClassifier
    Eco.UmlRt.IFeaturedType
        Eco.UmlRt.IClass
            Eco.UmlRt.IEcoClass


Related Topics

Related Topics
Related Topics

Eco.Services.IVersionService


Inheritance Hierarchy

Inheritance Hierarchy
Inheritance Hierarchy
Eco.UmlRt.IClassCollection


Inheritance Hierarchy

Inheritance Hierarchy
Inheritance Hierarchy
Eco.UmlRt.IModelElement
    Eco.UmlRt.IClassifier
        Eco.UmlRt.IClass
        Eco.UmlRt.IDataType
        Eco.UmlRt.IEcoClassifier


Inheritance Hierarchy

Inheritance Hierarchy
Inheritance Hierarchy
Eco.UmlRt.IClassifierCollection


Inheritance Hierarchy

Inheritance Hierarchy
Inheritance Hierarchy
Eco.UmlRt.ICollectionKinds


Inheritance Hierarchy

Inheritance Hierarchy
Inheritance Hierarchy
Eco.UmlRt.IModelElement
    Eco.UmlRt.IClassifier
        Eco.UmlRt.IDataType
            Eco.UmlRt.ICollectionType
                Eco.UmlRt.IBagType
                Eco.UmlRt.IOrderedSetType
                Eco.UmlRt.ISequenceType
                Eco.UmlRt.ISetType


Inheritance Hierarchy

Inheritance Hierarchy
Inheritance Hierarchy
Eco.UmlRt.IModelElement
    Eco.UmlRt.IConstraint
        Eco.UmlRt.IEcoConstraint


Example

Example

This is the description:name.length > 0


Example

Example

[UmlTaggedValue("Eco.GenerateMultiplicityConstraints", "False")]


Inheritance Hierarchy

Inheritance Hierarchy
Inheritance Hierarchy
Eco.UmlRt.IConstraintCollection


Inheritance Hierarchy

Inheritance Hierarchy
Inheritance Hierarchy
Eco.UmlRt.IModelElement
    Eco.UmlRt.IClassifier
        Eco.UmlRt.IDataType
            Eco.UmlRt.ICollectionType
            Eco.UmlRt.ISimpleType
            Eco.UmlRt.ITupleType


Inheritance Hierarchy

Inheritance Hierarchy
Inheritance Hierarchy
Eco.UmlRt.IModelElement
    Eco.UmlRt.IClassifier
        Eco.UmlRt.IEcoClassifier


Inheritance Hierarchy

Inheritance Hierarchy
Inheritance Hierarchy
Eco.UmlRt.IModelElement
    Eco.UmlRt.IEnumerationLiteral
        Eco.UmlRt.IEcoEnumerationLiteral


Inheritance Hierarchy

Inheritance Hierarchy
Inheritance Hierarchy
Eco.UmlRt.IModelElement
    Eco.UmlRt.IFeature
        Eco.UmlRt.IEcoFeature


Inheritance Hierarchy

Inheritance Hierarchy
Inheritance Hierarchy
Eco.UmlRt.IModelElement
    Eco.UmlRt.IFeature
        Eco.UmlRt.IMethod
            Eco.UmlRt.IEcoMethod


Inheritance Hierarchy

Inheritance Hierarchy
Inheritance Hierarchy
Eco.UmlRt.IModelElement
    Eco.UmlRt.IPackage
        Eco.UmlRt.IEcoPackage


Inheritance Hierarchy

Inheritance Hierarchy
Inheritance Hierarchy
Eco.UmlRt.IEcoPredefinedTypes


Inheritance Hierarchy

Inheritance Hierarchy
Inheritance Hierarchy
Eco.UmlRt.IModelElement
    Eco.UmlRt.IClassifier
        Eco.UmlRt.IDataType
            Eco.UmlRt.ISimpleType
                Eco.UmlRt.IPrimitiveType
                    Eco.UmlRt.IEcoPrimitiveType


Inheritance Hierarchy

Inheritance Hierarchy
Inheritance Hierarchy
Eco.UmlRt.IModelElement
    Eco.UmlRt.IRegion
        Eco.UmlRt.IEcoRegion


Inheritance Hierarchy

Inheritance Hierarchy
Inheritance Hierarchy
Eco.UmlRt.IRegionContainer
    Eco.UmlRt.IEcoRegionContainer


Inheritance Hierarchy

Inheritance Hierarchy
Inheritance Hierarchy
Eco.UmlRt.IModelElement
    Eco.UmlRt.IClassifier
        Eco.UmlRt.IDataType
            Eco.UmlRt.ISimpleType
                Eco.UmlRt.IEcoSimpleType


Inheritance Hierarchy

Inheritance Hierarchy
Inheritance Hierarchy
Eco.UmlRt.IModelElement
    Eco.UmlRt.IVertex
    Eco.UmlRt.IRegionContainer
        Eco.UmlRt.IState
            Eco.UmlRt.IEcoState


Inheritance Hierarchy

Inheritance Hierarchy
Inheritance Hierarchy
Eco.UmlRt.IModelElement
Eco.UmlRt.IRegionContainer
    Eco.UmlRt.IStateMachine
        Eco.UmlRt.IEcoStateMachine


Inheritance Hierarchy

Inheritance Hierarchy
Inheritance Hierarchy
Eco.UmlRt.IModelElement
    Eco.UmlRt.IFeature
        Eco.UmlRt.IStructuralFeature
            Eco.UmlRt.IEcoStructuralFeature


Inheritance Hierarchy

Inheritance Hierarchy
Inheritance Hierarchy
Eco.UmlRt.IModelElement
    Eco.UmlRt.IEcoTypeSystem


Inheritance Hierarchy

Inheritance Hierarchy
Inheritance Hierarchy
Eco.UmlRt.IModelElement
    Eco.UmlRt.IVertex
        Eco.UmlRt.IEcoVertex


Inheritance Hierarchy

Inheritance Hierarchy
Inheritance Hierarchy
Eco.UmlRt.IEnumerationLiteralCollection


Inheritance Hierarchy

Inheritance Hierarchy
Inheritance Hierarchy
Eco.UmlRt.IModelElement
    Eco.UmlRt.IClassifier
        Eco.UmlRt.IDataType
            Eco.UmlRt.ISimpleType
                Eco.UmlRt.IEnumerationType


Inheritance Hierarchy

Inheritance Hierarchy
Inheritance Hierarchy
Eco.UmlRt.IExpression


Inheritance Hierarchy

Inheritance Hierarchy
Inheritance Hierarchy
Eco.UmlRt.IModelElement
    Eco.UmlRt.IFeature
        Eco.UmlRt.IEcoFeature
        Eco.UmlRt.IMethod
        Eco.UmlRt.IStructuralFeature


Inheritance Hierarchy

Inheritance Hierarchy
Inheritance Hierarchy
Eco.UmlRt.IFeatureCollection


Inheritance Hierarchy

Inheritance Hierarchy
Inheritance Hierarchy
Eco.UmlRt.IFeaturedType
    Eco.UmlRt.IClass
    Eco.UmlRt.ITupleType


Inheritance Hierarchy

Inheritance Hierarchy
Inheritance Hierarchy
Eco.UmlRt.IModelElement
    Eco.UmlRt.IVertex
    Eco.UmlRt.IRegionContainer
        Eco.UmlRt.IState
            Eco.UmlRt.IFinalState


Inheritance Hierarchy

Inheritance Hierarchy
Inheritance Hierarchy
Eco.UmlRt.IMethodCollection


Inheritance Hierarchy

Inheritance Hierarchy
Inheritance Hierarchy
Eco.UmlRt.ITrigger
    Eco.UmlRt.IMethodTrigger


Inheritance Hierarchy

Inheritance Hierarchy
Inheritance Hierarchy
Eco.UmlRt.IModelElement
    Eco.UmlRt.IAssociation
    Eco.UmlRt.IClassifier
    Eco.UmlRt.IConstraint
    Eco.UmlRt.IEcoTypeSystem
    Eco.UmlRt.IEnumerationLiteral
    Eco.UmlRt.IFeature
    Eco.UmlRt.IPackage
    Eco.UmlRt.IParameter
    Eco.UmlRt.IRegion
    Eco.UmlRt.IStateMachine
    Eco.UmlRt.IStereotype
    Eco.UmlRt.IVertex


Inheritance Hierarchy

Inheritance Hierarchy
Inheritance Hierarchy
Eco.UmlRt.IModelElementCollection


Inheritance Hierarchy

Inheritance Hierarchy
Inheritance Hierarchy
Eco.UmlRt.IMultiplicity


Inheritance Hierarchy

Inheritance Hierarchy
Inheritance Hierarchy
Eco.UmlRt.IModelElement
    Eco.UmlRt.IClassifier
        Eco.UmlRt.IDataType
            Eco.UmlRt.ICollectionType
                Eco.UmlRt.IOrderedSetType


Inheritance Hierarchy

Inheritance Hierarchy
Inheritance Hierarchy
Eco.UmlRt.IPackageCollection


Inheritance Hierarchy

Inheritance Hierarchy
Inheritance Hierarchy
Eco.UmlRt.IModelElement
    Eco.UmlRt.IParameter


Related Topics

Related Topics
Related Topics

IClass, IDataType


Inheritance Hierarchy

Inheritance Hierarchy
Inheritance Hierarchy
Eco.UmlRt.IParameterCollection


Related Topics

Related Topics
Related Topics

Eco.UmlRt.IEcoTypeSystem.GetClassifierByType, Eco.Services.ITypeSystemService.TypeSystem


Inheritance Hierarchy

Inheritance Hierarchy
Inheritance Hierarchy
Eco.UmlRt.IModelElement
    Eco.UmlRt.IVertex
        Eco.UmlRt.IPseudostate


Inheritance Hierarchy

Inheritance Hierarchy
Inheritance Hierarchy
Eco.UmlRt.IRegionCollection


Related Topics

Related Topics
Related Topics

IStateMachine, IState


Inheritance Hierarchy

Inheritance Hierarchy
Inheritance Hierarchy
Eco.UmlRt.IRegionContainer
    Eco.UmlRt.IEcoRegionContainer
    Eco.UmlRt.IState
    Eco.UmlRt.IStateMachine


Inheritance Hierarchy

Inheritance Hierarchy
Inheritance Hierarchy
Eco.UmlRt.IModelElement
    Eco.UmlRt.IClassifier
        Eco.UmlRt.IDataType
            Eco.UmlRt.ICollectionType
                Eco.UmlRt.ISequenceType


Inheritance Hierarchy

Inheritance Hierarchy
Inheritance Hierarchy
Eco.UmlRt.IModelElement
    Eco.UmlRt.IClassifier
        Eco.UmlRt.IDataType
            Eco.UmlRt.ICollectionType
                Eco.UmlRt.ISetType


Inheritance Hierarchy

Inheritance Hierarchy
Inheritance Hierarchy
Eco.UmlRt.IModelElement
    Eco.UmlRt.IClassifier
        Eco.UmlRt.IDataType
            Eco.UmlRt.ISimpleType
                Eco.UmlRt.IEcoSimpleType
                Eco.UmlRt.IEnumerationType
                Eco.UmlRt.IPrimitiveType


Inheritance Hierarchy

Inheritance Hierarchy
Inheritance Hierarchy
Eco.UmlRt.ISimpleTypeCollection


Inheritance Hierarchy

Inheritance Hierarchy
Inheritance Hierarchy
Eco.UmlRt.IModelElement
    Eco.UmlRt.IVertex
    Eco.UmlRt.IRegionContainer
        Eco.UmlRt.IState
            Eco.UmlRt.IEcoState
            Eco.UmlRt.IFinalState


Inheritance Hierarchy

Inheritance Hierarchy
Inheritance Hierarchy
Eco.UmlRt.IStateCollection
    Eco.UmlRt.IStateNamedCollection


Inheritance Hierarchy

Inheritance Hierarchy
Inheritance Hierarchy
Eco.UmlRt.IStateName


Inheritance Hierarchy

Inheritance Hierarchy
Inheritance Hierarchy
Eco.UmlRt.IStateRepresentationPart


Inheritance Hierarchy

Inheritance Hierarchy
Inheritance Hierarchy
Eco.UmlRt.IStateRepresentationPartCollection


Inheritance Hierarchy

Inheritance Hierarchy
Inheritance Hierarchy
Eco.UmlRt.IModelElement
    Eco.UmlRt.IStereotype


Inheritance Hierarchy

Inheritance Hierarchy
Inheritance Hierarchy
Eco.UmlRt.IStereotypeCollection


Inheritance Hierarchy

Inheritance Hierarchy
Inheritance Hierarchy
Eco.UmlRt.IModelElement
    Eco.UmlRt.IFeature
        Eco.UmlRt.IStructuralFeature
            Eco.UmlRt.IAssociationEnd
            Eco.UmlRt.IAttribute
            Eco.UmlRt.IEcoStructuralFeature


Inheritance Hierarchy

Inheritance Hierarchy
Inheritance Hierarchy
Eco.UmlRt.IStructuralFeatureCollection


Example

Example

MyCompany.HumanReadibleName = First name


Inheritance Hierarchy

Inheritance Hierarchy
Inheritance Hierarchy
Eco.UmlRt.ITaggedValue


Inheritance Hierarchy

Inheritance Hierarchy
Inheritance Hierarchy
Eco.UmlRt.ITaggedValueCollection


Inheritance Hierarchy

Inheritance Hierarchy
Inheritance Hierarchy
Eco.UmlRt.ITransition


Inheritance Hierarchy

Inheritance Hierarchy
Inheritance Hierarchy
Eco.UmlRt.ITransitionCollection


Inheritance Hierarchy

Inheritance Hierarchy
Inheritance Hierarchy
Eco.UmlRt.ITriggerCollection


Inheritance Hierarchy

Inheritance Hierarchy
Inheritance Hierarchy
Eco.UmlRt.IModelElement
    Eco.UmlRt.IClassifier
        Eco.UmlRt.IDataType
        Eco.UmlRt.IFeaturedType
            Eco.UmlRt.ITupleType


Inheritance Hierarchy

Inheritance Hierarchy
Inheritance Hierarchy
Eco.UmlRt.ITypeConverter


Inheritance Hierarchy

Inheritance Hierarchy
Inheritance Hierarchy
Eco.UmlRt.IModelElement
    Eco.UmlRt.IVertex
        Eco.UmlRt.IEcoVertex
        Eco.UmlRt.IPseudostate
        Eco.UmlRt.IState


Inheritance Hierarchy

Inheritance Hierarchy
Inheritance Hierarchy
Eco.UmlRt.IVertexCollection


Inheritance Hierarchy

Inheritance Hierarchy
Inheritance Hierarchy
Eco.UmlRt.ModelElementSameHash


Inheritance Hierarchy

Inheritance Hierarchy
Inheritance Hierarchy
Eco.UmlRt.UmlTaggedValues.BooleanTV


Inheritance Hierarchy

Inheritance Hierarchy
Inheritance Hierarchy
Eco.UmlRt.UmlTaggedValues.EnumTV


Inheritance Hierarchy

Inheritance Hierarchy
Inheritance Hierarchy
Eco.UmlRt.UmlTaggedValues.PersistenceTV


Inheritance Hierarchy

Inheritance Hierarchy
Inheritance Hierarchy
Eco.UmlRt.UmlTaggedValues.StringTV


Inheritance Hierarchy

Inheritance Hierarchy
Inheritance Hierarchy
Eco.UmlRt.UmlTaggedValues.TaggedValue


Inheritance Hierarchy

Inheritance Hierarchy
Inheritance Hierarchy
Eco.Wcf.Client.PersistenceMapperWCFClient


Inheritance Hierarchy

Inheritance Hierarchy
Inheritance Hierarchy
Eco.Wcf.Common.AbstractConditionTransfer
    Eco.Wcf.Common.AllInstancesConditionTransfer
    Eco.Wcf.Common.OclConditionTransfer


Inheritance Hierarchy

Inheritance Hierarchy
Inheritance Hierarchy
Eco.Wcf.Common.AbstractConditionTransfer
    Eco.Wcf.Common.AllInstancesConditionTransfer


Inheritance Hierarchy

Inheritance Hierarchy
Inheritance Hierarchy
Eco.Wcf.Common.DatablockTransfer


Inheritance Hierarchy

Inheritance Hierarchy
Inheritance Hierarchy
Eco.Wcf.Common.DBChangeCollectionTransfer


Inheritance Hierarchy

Inheritance Hierarchy
Inheritance Hierarchy
Eco.Wcf.Common.DBChangeTransfer


Inheritance Hierarchy

Inheritance Hierarchy
Inheritance Hierarchy
Eco.Wcf.Common.ObjectIdTransfer
    Eco.Wcf.Common.DefaultIdTransfer
        Eco.Wcf.Common.TimestampedDefaultIdTransfer


Inheritance Hierarchy

Inheritance Hierarchy
Inheritance Hierarchy
Eco.Wcf.Common.IdTranslationListTransfer


Inheritance Hierarchy

Inheritance Hierarchy
Inheritance Hierarchy
Eco.Wcf.Common.ObjectIdTransfer
    Eco.Wcf.Common.InternalObjectIdTransfer


Inheritance Hierarchy

Inheritance Hierarchy
Inheritance Hierarchy
Eco.Wcf.Common.IPersistenceMapperWCF


Inheritance Hierarchy

Inheritance Hierarchy
Inheritance Hierarchy
Eco.Wcf.Common.ObjectIdListTransfer


Inheritance Hierarchy

Inheritance Hierarchy
Inheritance Hierarchy
Eco.Wcf.Common.ObjectIdTransfer
    Eco.Wcf.Common.DefaultIdTransfer
    Eco.Wcf.Common.InternalObjectIdTransfer


Inheritance Hierarchy

Inheritance Hierarchy
Inheritance Hierarchy
Eco.Wcf.Common.AbstractConditionTransfer
    Eco.Wcf.Common.OclConditionTransfer


Inheritance Hierarchy

Inheritance Hierarchy
Inheritance Hierarchy
Eco.Wcf.Common.UpdatePreconditionTransfer
    Eco.Wcf.Common.OptimisticLockingPreconditionTransfer


Inheritance Hierarchy

Inheritance Hierarchy
Inheritance Hierarchy
Eco.Wcf.Common.UpdateResultTransfer


Inheritance Hierarchy

Inheritance Hierarchy
Inheritance Hierarchy
Eco.Wcf.Server.PersistenceMapperProviderWCF


Inheritance Hierarchy

Inheritance Hierarchy
Inheritance Hierarchy
Eco.Web.ActionExecutor


Inheritance Hierarchy

Inheritance Hierarchy
Inheritance Hierarchy
Eco.Web.AspProviders.ASP_BlobPropValue


Inheritance Hierarchy

Inheritance Hierarchy
Inheritance Hierarchy
Eco.Web.AspProviders.ASP_BlobPropValue.Eco_LoopbackIndices


Inheritance Hierarchy

Inheritance Hierarchy
Inheritance Hierarchy
Eco.Web.AspProviders.ASP_IntPropValue


Inheritance Hierarchy

Inheritance Hierarchy
Inheritance Hierarchy
Eco.Web.AspProviders.ASP_IntPropValue.Eco_LoopbackIndices


Inheritance Hierarchy

Inheritance Hierarchy
Inheritance Hierarchy
Eco.Web.AspProviders.ASP_PersonalizationInfo


Inheritance Hierarchy

Inheritance Hierarchy
Inheritance Hierarchy
Eco.Web.AspProviders.ASP_PersonalizationInfo.Eco_LoopbackIndices


Inheritance Hierarchy

Inheritance Hierarchy
Inheritance Hierarchy
Eco.Web.AspProviders.ASP_PersonalizationShared


Inheritance Hierarchy

Inheritance Hierarchy
Inheritance Hierarchy
Eco.Web.AspProviders.ASP_PersonalizationShared.Eco_LoopbackIndices


Inheritance Hierarchy

Inheritance Hierarchy
Inheritance Hierarchy
Eco.Web.AspProviders.ASP_PersonalizationUser


Inheritance Hierarchy

Inheritance Hierarchy
Inheritance Hierarchy
Eco.Web.AspProviders.ASP_PersonalizationUser.Eco_LoopbackIndices


Inheritance Hierarchy

Inheritance Hierarchy
Inheritance Hierarchy
Eco.Web.AspProviders.ASP_Profile


Inheritance Hierarchy

Inheritance Hierarchy
Inheritance Hierarchy
Eco.Web.AspProviders.ASP_Profile.Eco_LoopbackIndices


Inheritance Hierarchy

Inheritance Hierarchy
Inheritance Hierarchy
Eco.Web.AspProviders.ASP_ProfilePropValue


Inheritance Hierarchy

Inheritance Hierarchy
Inheritance Hierarchy
Eco.Web.AspProviders.ASP_ProfilePropValue.Eco_LoopbackIndices


Inheritance Hierarchy

Inheritance Hierarchy
Inheritance Hierarchy
Eco.Web.AspProviders.ASP_Role


Inheritance Hierarchy

Inheritance Hierarchy
Inheritance Hierarchy
Eco.Web.AspProviders.ASP_Role.Eco_LoopbackIndices


Inheritance Hierarchy

Inheritance Hierarchy
Inheritance Hierarchy
Eco.Web.AspProviders.ASP_RoleUser


Inheritance Hierarchy

Inheritance Hierarchy
Inheritance Hierarchy
Eco.Web.AspProviders.ASP_RoleUser.Eco_LoopbackIndices


Inheritance Hierarchy

Inheritance Hierarchy
Inheritance Hierarchy
Eco.Web.AspProviders.ASP_Session


Inheritance Hierarchy

Inheritance Hierarchy
Inheritance Hierarchy
Eco.Web.AspProviders.ASP_Session.Eco_LoopbackIndices


Inheritance Hierarchy

Inheritance Hierarchy
Inheritance Hierarchy
Eco.Web.AspProviders.ASP_StringPropValue


Inheritance Hierarchy

Inheritance Hierarchy
Inheritance Hierarchy
Eco.Web.AspProviders.ASP_StringPropValue.Eco_LoopbackIndices


Inheritance Hierarchy

Inheritance Hierarchy
Inheritance Hierarchy
Eco.Web.AspProviders.ASP_User


Inheritance Hierarchy

Inheritance Hierarchy
Inheritance Hierarchy
Eco.Web.AspProviders.ASP_User.Eco_LoopbackIndices


Inheritance Hierarchy

Inheritance Hierarchy
Inheritance Hierarchy
Eco.Web.AspProviders.ASP_WebEvent


Inheritance Hierarchy

Inheritance Hierarchy
Inheritance Hierarchy
Eco.Web.AspProviders.ASP_WebEvent.Eco_LoopbackIndices


Inheritance Hierarchy

Inheritance Hierarchy
Inheritance Hierarchy
Eco.Web.AspProviders.ASP_XmlPropValue


Inheritance Hierarchy

Inheritance Hierarchy
Inheritance Hierarchy
Eco.Web.AspProviders.ASP_XmlPropValue.Eco_LoopbackIndices


Inheritance Hierarchy

Inheritance Hierarchy
Inheritance Hierarchy
Eco.Web.AspProviders.EcoAspProviderPackage


Inheritance Hierarchy

Inheritance Hierarchy
Inheritance Hierarchy
Eco.Web.AspProviders.EcoAspProviderPackage.ASP_ProfileProfileASP_ProfilePropValueValues


Inheritance Hierarchy

Inheritance Hierarchy
Inheritance Hierarchy
Eco.Web.AspProviders.EcoAspProviderPackage.ASP_ProfileProfileASP_UserUser


Inheritance Hierarchy

Inheritance Hierarchy
Inheritance Hierarchy
Eco.Web.AspProviders.EcoAspProviderPackage.ASP_RoleRolesASP_RoleUserRoleUsers


Inheritance Hierarchy

Inheritance Hierarchy
Inheritance Hierarchy
Eco.Web.AspProviders.EcoAspProviderPackage.ASP_RoleRolesASP_UserUsers


Inheritance Hierarchy

Inheritance Hierarchy
Inheritance Hierarchy
Eco.Web.AspProviders.EcoAspProviderPackage.ASP_RoleUserRoleUserASP_UserUser


Inheritance Hierarchy

Inheritance Hierarchy
Inheritance Hierarchy
Eco.Web.AspProviders.EcoMembershipProvider


Inheritance Hierarchy

Inheritance Hierarchy
Inheritance Hierarchy
Eco.Web.AspProviders.EcoPersonalizationProvider


Inheritance Hierarchy

Inheritance Hierarchy
Inheritance Hierarchy
Eco.Web.AspProviders.EcoProfileProvider


Inheritance Hierarchy

Inheritance Hierarchy
Inheritance Hierarchy
Eco.Web.AspProviders.EcoProviderSupport


Inheritance Hierarchy

Inheritance Hierarchy
Inheritance Hierarchy
Eco.Web.AspProviders.EcoRoleProvider


Inheritance Hierarchy

Inheritance Hierarchy
Inheritance Hierarchy
Eco.Web.AspProviders.EcoSessionStateStoreProvider


Inheritance Hierarchy

Inheritance Hierarchy
Inheritance Hierarchy
Eco.Web.AspProviders.EcoWebEventProvider


Inheritance Hierarchy

Inheritance Hierarchy
Inheritance Hierarchy
Eco.Web.AutoForm


Inheritance Hierarchy

Inheritance Hierarchy
Inheritance Hierarchy
Eco.Web.AutoFormDataGrid


Inheritance Hierarchy

Inheritance Hierarchy
Inheritance Hierarchy
Eco.Web.EcoPropertyBinding
    Eco.Web.CheckBoxAsBooleanBinding


Inheritance Hierarchy

Inheritance Hierarchy
Inheritance Hierarchy
Eco.Web.ControlBuilder


Inheritance Hierarchy

Inheritance Hierarchy
Inheritance Hierarchy
Eco.Web.DynamicData.EcoAttributeColumnProvider


Inheritance Hierarchy

Inheritance Hierarchy
Inheritance Hierarchy
Eco.Web.DynamicData.EcoDataModelProvider


Inheritance Hierarchy

Inheritance Hierarchy
Inheritance Hierarchy
Eco.Web.DynamicData.EcoIdColumnProvider


Inheritance Hierarchy

Inheritance Hierarchy
Inheritance Hierarchy
Eco.Web.DynamicData.EcoTableProvider


Inheritance Hierarchy

Inheritance Hierarchy
Inheritance Hierarchy
Eco.Web.EcoAspListActionExtender


Inheritance Hierarchy

Inheritance Hierarchy
Inheritance Hierarchy
Eco.Web.EcoCssClassNames


Inheritance Hierarchy

Inheritance Hierarchy
Inheritance Hierarchy
Eco.Web.EcoPropertyBinding
    Eco.Web.CheckBoxAsBooleanBinding
    Eco.Web.TextBoxAsAttributeBinding


Inheritance Hierarchy

Inheritance Hierarchy
Inheritance Hierarchy
Eco.Web.EcoQueryVariableNames


Inheritance Hierarchy

Inheritance Hierarchy
Inheritance Hierarchy
Eco.Web.EcoSpaceStrategyHandler


Inheritance Hierarchy

Inheritance Hierarchy
Inheritance Hierarchy
Eco.Web.MethodButtonBinding


Inheritance Hierarchy

Inheritance Hierarchy
Inheritance Hierarchy
Eco.Web.MethodCallBuilder


Inheritance Hierarchy

Inheritance Hierarchy
Inheritance Hierarchy
Eco.Web.MultiLinkBuilder


Inheritance Hierarchy

Inheritance Hierarchy
Inheritance Hierarchy
Eco.Web.Navigator


Inheritance Hierarchy

Inheritance Hierarchy
Inheritance Hierarchy
Eco.Web.ParameterBinding


Inheritance Hierarchy

Inheritance Hierarchy
Inheritance Hierarchy
Eco.Web.Providers.ProvidersStringRes


Inheritance Hierarchy

Inheritance Hierarchy
Inheritance Hierarchy
Eco.Web.StatePageBuilder


Inheritance Hierarchy

Inheritance Hierarchy
Inheritance Hierarchy
Eco.Web.EcoPropertyBinding
    Eco.Web.TextBoxAsAttributeBinding


Inheritance Hierarchy

Inheritance Hierarchy
Inheritance Hierarchy
Eco.Web.TriggerControlsRefresher


Inheritance Hierarchy

Inheritance Hierarchy
Inheritance Hierarchy
Eco.Web.UI.WebControls.AbstractColumn
    Eco.Web.UI.WebControls.EventDerivedColumn
    Eco.Web.UI.WebControls.OclColumn


Related Topics

Related Topics
Related Topics

EcoDataSource


Inheritance Hierarchy

Inheritance Hierarchy
Inheritance Hierarchy
Eco.Web.UI.WebControls.EcoDataSource


Related Topics

Related Topics
Related Topics

AddExternalId, Columns, MemberVisibility


Related Topics

Related Topics
Related Topics

EcoDataSource.AddDefaultProperties, EcoDataSource.AddExternalId, EcoDataSource.MemberVisibility


Related Topics

Related Topics
Related Topics

Eco.Web.UI.WebControls.DeleteMode


Inheritance Hierarchy

Inheritance Hierarchy
Inheritance Hierarchy
Eco.Web.UI.WebControls.EcoDataSourceColumnCollection


Inheritance Hierarchy

Inheritance Hierarchy
Inheritance Hierarchy
Eco.Web.UI.WebControls.EcoDataSourceObjectEventArgs


Inheritance Hierarchy

Inheritance Hierarchy
Inheritance Hierarchy
Eco.Web.UI.WebControls.EcoDataSourceSelectingEventArgs


Inheritance Hierarchy

Inheritance Hierarchy
Inheritance Hierarchy
Eco.Web.UI.WebControls.EcoDataSourceStatusEventArgs


Inheritance Hierarchy

Inheritance Hierarchy
Inheritance Hierarchy
Eco.Web.UI.WebControls.EcoDataSourceView


Inheritance Hierarchy

Inheritance Hierarchy
Inheritance Hierarchy
Eco.Web.UI.WebControls.EcoSpaceManager


Related Topics

Related Topics
Related Topics

EcoSpaceType, EcoSpace


Inheritance Hierarchy

Inheritance Hierarchy
Inheritance Hierarchy
Eco.Web.UI.WebControls.EcoSpaceManagerBuilder


Inheritance Hierarchy

Inheritance Hierarchy
Inheritance Hierarchy
Eco.Web.UI.WebControls.EcoSpaceManagerIDConverter


Inheritance Hierarchy

Inheritance Hierarchy
Inheritance Hierarchy
Eco.Web.UI.WebControls.AbstractColumn
    Eco.Web.UI.WebControls.EventDerivedColumn


Inheritance Hierarchy

Inheritance Hierarchy
Inheritance Hierarchy
Eco.Web.UI.WebControls.AbstractColumn
    Eco.Web.UI.WebControls.OclColumn


Inheritance Hierarchy

Inheritance Hierarchy
Inheritance Hierarchy
Eco.Web.UI.WebControls.OclParameter


Inheritance Hierarchy

Inheritance Hierarchy
Inheritance Hierarchy
Eco.Web.UI.WebControls.RowValidationFailedException


Inheritance Hierarchy

Inheritance Hierarchy
Inheritance Hierarchy
Eco.Web.WebStringRes


Inheritance Hierarchy

Inheritance Hierarchy
Inheritance Hierarchy
Eco.Web.WebUtils


Inheritance Hierarchy

Inheritance Hierarchy
Inheritance Hierarchy
Eco.Windows.Forms.IEcoSpaceDebuggerPanel
System.Windows.Forms.Form
    Eco.Windows.Forms.ClassAndOclDebuggerPanel


Inheritance Hierarchy

Inheritance Hierarchy
Inheritance Hierarchy
System.Windows.Forms.Form
    Eco.Windows.Forms.ConfigureCleanPSForm


Inheritance Hierarchy

Inheritance Hierarchy
Inheritance Hierarchy
Eco.Windows.Forms.ConstraintInfoBuilder


Inheritance Hierarchy

Inheritance Hierarchy
Inheritance Hierarchy
Eco.Windows.Forms.ControlBuilder


Inheritance Hierarchy

Inheritance Hierarchy
Inheritance Hierarchy
Eco.Windows.Forms.ControlBuilder.NavigationalContext


Inheritance Hierarchy

Inheritance Hierarchy
Inheritance Hierarchy
System.Windows.Forms.Form
    Eco.Windows.Forms.DBEvolutionForm


Inheritance Hierarchy

Inheritance Hierarchy
Inheritance Hierarchy
Eco.Windows.Forms.IEcoSpaceDebuggerPanel
System.Windows.Forms.Form
    Eco.Windows.Forms.DirtyObjectsDebuggerPanel


Inheritance Hierarchy

Inheritance Hierarchy
Inheritance Hierarchy
System.Windows.Forms.Form
    Eco.Windows.Forms.EcoSpaceDebugger


Inheritance Hierarchy

Inheritance Hierarchy
Inheritance Hierarchy
Eco.Windows.Forms.ErrorHandler


Inheritance Hierarchy

Inheritance Hierarchy
Inheritance Hierarchy
Eco.Windows.Forms.FormBasedConfigureCleanPS


Inheritance Hierarchy

Inheritance Hierarchy
Inheritance Hierarchy
Eco.Windows.Forms.FormsStringRes


Inheritance Hierarchy

Inheritance Hierarchy
Inheritance Hierarchy
Eco.Windows.Forms.IEcoSpaceDebuggerPanel
    Eco.Windows.Forms.ClassAndOclDebuggerPanel
    Eco.Windows.Forms.DirtyObjectsDebuggerPanel
    Eco.Windows.Forms.LoggerDebuggerPanel
    Eco.Windows.Forms.SyncDebuggerPanel
    Eco.Windows.Forms.UndoDebuggerPanel


Inheritance Hierarchy

Inheritance Hierarchy
Inheritance Hierarchy
Eco.Windows.Forms.IEcoSpaceDebuggerPanel
System.Windows.Forms.Form
    Eco.Windows.Forms.LoggerDebuggerPanel


Inheritance Hierarchy

Inheritance Hierarchy
Inheritance Hierarchy
Eco.Windows.Forms.MethodCallBuilder


Inheritance Hierarchy

Inheritance Hierarchy
Inheritance Hierarchy
Eco.Windows.Forms.MultilinkBuilder


Inheritance Hierarchy

Inheritance Hierarchy
Inheritance Hierarchy
System.Windows.Forms.TabPage
    Eco.Windows.Forms.MultilinkBuilder.MultilinkTabPage


Inheritance Hierarchy

Inheritance Hierarchy
Inheritance Hierarchy
System.Windows.Forms.NumericUpDown
    Eco.Windows.Forms.MyNumericUpDown


Inheritance Hierarchy

Inheritance Hierarchy
Inheritance Hierarchy
System.Windows.Forms.Form
    Eco.Windows.Forms.OclEditor


Inheritance Hierarchy

Inheritance Hierarchy
Inheritance Hierarchy
Eco.Windows.Forms.StatePageBuilder


Inheritance Hierarchy

Inheritance Hierarchy
Inheritance Hierarchy
Eco.Windows.Forms.IEcoSpaceDebuggerPanel
    Eco.Windows.Forms.SyncDebuggerPanel


Inheritance Hierarchy

Inheritance Hierarchy
Inheritance Hierarchy
Eco.Windows.Forms.TriggerControlsRefresher


Inheritance Hierarchy

Inheritance Hierarchy
Inheritance Hierarchy
Eco.Windows.Forms.IEcoSpaceDebuggerPanel
System.Windows.Forms.Form
    Eco.Windows.Forms.UndoDebuggerPanel


Inheritance Hierarchy

Inheritance Hierarchy
Inheritance Hierarchy
Eco.Windows.Forms.WinFormDequeuer


Inheritance Hierarchy

Inheritance Hierarchy
Inheritance Hierarchy
Eco.WinForm.DataGridMaxLengthSupportProvider


Inheritance Hierarchy

Inheritance Hierarchy
Inheritance Hierarchy
Eco.WinForm.DraggedElement


Inheritance Hierarchy

Inheritance Hierarchy
Inheritance Hierarchy
Eco.WinForm.EcoActionExtender


Inheritance Hierarchy

Inheritance Hierarchy
Inheritance Hierarchy
Eco.WinForm.EcoAutoFormExtender


Inheritance Hierarchy

Inheritance Hierarchy
Inheritance Hierarchy
System.Windows.Forms.DataGridTextBoxColumn
    Eco.WinForm.EcoDataGridTextBoxColumn


Inheritance Hierarchy

Inheritance Hierarchy
Inheritance Hierarchy
Eco.WinForm.EcoDragDropExtender


Inheritance Hierarchy

Inheritance Hierarchy
Inheritance Hierarchy
Eco.WinForm.EcoListActionExtender


Inheritance Hierarchy

Inheritance Hierarchy
Inheritance Hierarchy
Eco.WinForm.EcoListActionExtender.CurrencyManagerWrapper


Inheritance Hierarchy

Inheritance Hierarchy
Inheritance Hierarchy
Eco.WinForm.EcoListActionExtender.ICurrencyManager


Inheritance Hierarchy

Inheritance Hierarchy
Inheritance Hierarchy
Eco.WinForm.EcoWinFormHelper


Inheritance Hierarchy

Inheritance Hierarchy
Inheritance Hierarchy
Eco.WinForm.TextBoxMaxLengthSupportProvider


Inheritance Hierarchy

Inheritance Hierarchy
Inheritance Hierarchy
Eco.WPF.EcoBinding


Inheritance Hierarchy

Inheritance Hierarchy
Inheritance Hierarchy
Eco.WPF.EcoBindingInstance


Inheritance Hierarchy

Inheritance Hierarchy
Inheritance Hierarchy
Eco.WPF.EcoBindingInstance.ValueHolder


Inheritance Hierarchy

Inheritance Hierarchy
Inheritance Hierarchy
Eco.WPF.EcoServiceProviderReference


Inheritance Hierarchy

Inheritance Hierarchy
Inheritance Hierarchy
Eco.WPF.WPFDequeuer


Inheritance Hierarchy

Inheritance Hierarchy
Inheritance Hierarchy
System.Collections.Generic.ECO_IListOfStringExtender