terms of use.txt

Enterprise Core Objects - Design time API
terms of use.txt

Terms of use

Pixellogo.com License Agreement

  1. IMPORTANT INFORMATION

Please read carefully the following terms and conditions. Purchase or use of our products implies that the following terms and conditions have been read and accepted.

  2. LICENSE

Pixel Logo grants you a nonexclusive limited license to use the web templates and other products sold on Pixellogo.com (the "products") in accordance with these Terms and Conditions (the "license") issued by Pixellogo.com.

a) LIMITED USAGE GRANTED Clients may only use each individual logo for a single project, belonging to either them or their respective client. Clients have to purchase same logo once more in order to make another project with the same design.

b) MODIFICATIONS Clients are authorized to make any necessary modification(s) to our products, after purchase, to fit their purposes.

c) UNAUTHORIZED USE Clients may not place any of Pixellogo.com products, modified or unmodified, on a diskette, CD, website or any other medium and offer them for redistribution or resale of any kind without prior written consent from Pixellogo.com.

d) ASSIGNABILITY Clients may not sub-license, assign, or transfer this license to anyone else without prior written consent from Pixellogo.com.

e) OWNERSHIP Clients may not claim intellectual or exclusive ownership to any of Pixellogo.com products, modified or unmodified. All products are property of Pixellogo.com, unless the products is bought exclusively from Pixellogo.com as specified on our end user license agreement.

f) REFUND AND EXCHANGE POLICY Pixellogo.com products are digital files, hence there are no means to physically "return" the product for a refund or exchange. Therefore we do not grant refunds. However, we will replace a damaged file with the same file, if such a request is made.

Our products are provided "as is" without warranty of any kind, either expressed or implied. In no event shall Pixellogo.com be liable for any damages including, but not limited to, direct, indirect, special, incidental or consequential damages or other losses arising out of the use of or inability to use our products.

What do you think about this topic? Send feedback!
Copyright (c) 2007-2009. All rights reserved.


Eco.Handles.Design Namespace

Eco.Handles.Design Namespace
Classes Enumerations Interfaces Types
Collapse All

For ToolboxBitmap

Classes
Name | Description
AboutForm | Summary description for WinForm1.
AbstractExpressionHandleDesigner | This is class Eco.Handles.Design.AbstractExpressionHandleDesigner.
AbstractManipulator | Abstract base class for the manipulators.
ActionExpressionEditor | Subclass to edit the extendee's expression using the ActionLanguageTypeService.
AddValidatorsFromXml | This is class Eco.Handles.Design.AddValidatorsFromXml.
AllInstancesWidgetsCreatorHandler | This is class Eco.Handles.Design.AllInstancesWidgetsCreatorHandler.
AnyTypeNameSelectorEditor | Typename selector editor that shows all known types in the tree.
AssociationWidgetsCreatorHandler | This is class Eco.Handles.Design.AssociationWidgetsCreatorHandler.
ChangeEventArgs | This is class Eco.Handles.Design.ChangeEventArgs.
ClientIDManipulator | Sets the ClientID of the WebControl.
ColumnCollectionEditor | Editor for the ColumnCollection class.
ColumnCreatorNodeDescriptor | This is class Eco.Handles.Design.ColumnCreatorNodeDescriptor.
ColumnsManipulator | Implements dupe checking for manipulators that want to add columns.
ColumnWidgetsCreatorHandler | This is class Eco.Handles.Design.ColumnWidgetsCreatorHandler.
ComponentDefinition | Encapsulates creation of a component.
ConnectionManipulator | Sets the property to the just created connection.
ContextAgentLogger | Focal point for logging of acttions.
ContextAgentToolboxItem | Class responsible for component creation on a designer.
ContextAgentTreeNode | This is class Eco.Handles.Design.ContextAgentTreeNode.
ContextAgentWebToolboxItem | This is class Eco.Handles.Design.ContextAgentWebToolboxItem.
ContextComponentReader | This is class Eco.Handles.Design.ContextComponentReader.
ContextComponentsForm | This is class Eco.Handles.Design.ContextComponentsForm.
ContextController | This is class Eco.Handles.Design.ContextController.
CreatorContextNode | This is class Eco.Handles.Design.CreatorContextNode.
CreatorGroup | This class represents a top level grouping of context sets.
CreatorHandler | This class is responsible for getting information from the XML-file
CreatorInfo | Base class for creator classes that can be shown in tree view.
CreatorManager | This class is responsible for tracking the selected component and populating the display form.
CreatorNodeDescriptor | Container used by the selection form.
CurrencyManagerHandleDesigner | Designer for CurrencyManagerHandle.
DataBindManipulator | Binds propertyParams.PropVal to propertyParams.InvokingComponent/propertyParams.Name.
DesignerData | Parameter object passed to the AbstractManipulator.
DesignStringRes | Autogenerated class to get compiler safe access to resource strings.
DesignTimeLogger | Singleton class used to perform design time initialization code.
EcoAboutMenuItem | This is class Eco.Handles.Design.EcoAboutMenuItem.
EcoActionExtenderDesigner | Designer for EcoActionExtender.
EcoDatatypesMenuItem | , "Eco.Handles.Design.EcoDatatypesMenuItem.bmp")
EcoDesigner | Base class for the EcoSpaceDesigner and PersistenceMapperProviderDesigner. This class provides the infrastructure for plugging in tools, task hints and hooking up dropped components.
EcoIdeOptions | Singleton class that provides easy access to the IDE options pertaining to ECO.
EcoManipulator | Adds the ability to return a named IFeature.
EcoRegistry | Handle the ECO registry entries. Note, the key is duplicated in AssemblyRegistrator.pas in the native part of the BDS integration.
EcoSettingsForm | Summary description for WinForm1.
EcoSpaceDesigner | The designer for DefaultEcoSpace.
EcoSpaceDesignerForm | This is the class implementing the toolbar in the EcoDesigner.
EcoSpaceDesignerToolbox | Singleton class responsible for maintaining the list of registered IEcoSpaceDesignerTool.
EcoSpaceInspector | Provider for context sensitive task help for EcoSpace.
EcoSpaceTypeNameTypeConverter | This is class Eco.Handles.Design.EcoSpaceTypeNameTypeConverter.
EcoSpaceTypeTypeConverter | This is class Eco.Handles.Design.EcoSpaceTypeTypeConverter.
EcoToolboxArgs | Parameter class used when manipulating the tools registry.
EcoToolButtonBase | Basic implementation of the IEcoSpaceDesignerTool interface. Intended for subclassing.
EcoValidationHelper | This is class Eco.Handles.Design.EcoValidationHelper.
ErrorContextNode | This is class Eco.Handles.Design.ErrorContextNode.
ErrorManager | This is class Eco.Handles.Design.ErrorManager.
EventTester | Tester to show which events get sent by the context manager.
ExecuteArgs | Parameter object passed to IEcoSpaceDesignerTool.Execute.
ExpressionEditor | Abstract class for the editing of expressions on extended components. The only thing the subclasses have to provide is a ITypeService as returned by getOclTypeService.
ExpressionHandleDesigner | Designer for ExpressionHandle.
FormCreatorHandler | This is class Eco.Handles.Design.FormCreatorHandler.
FormValidationIncident | This is class Eco.Handles.Design.FormValidationIncident.
FormValidationReport | This is class Eco.Handles.Design.FormValidationReport.
FormValidator | This is class Eco.Handles.Design.FormValidator.
FormValidatorArgs | Parameter object used when calling validation instances.
GenericTypeNameConverter | This is class Eco.Handles.Design.GenericTypeNameConverter.
HandlesDesigner | HandlesDesigner adds the verb to create default columns - this is common for all handles.
HintHelper | HintHelper creates the strings shown in the fly-over hints as used by the Inspector mechanisms.
IdeHelper | Static helper class used to isolate IDE dependencies, and to be able to retrieve information about the environment easier.
ListActionCreatorHandler | This is class Eco.Handles.Design.ListActionCreatorHandler.
MessageDisplay | Helper class implementing IMessageDisplay to allow IDE logic to uniformly display messages in the IDE. Relies on MessageHelper to display messages.
MessageHelper | Singleton helper class to uniformly reach into the IDE's message display facilities.
MetaCreator | Represents a component group that can be created.
MetaCreatorType | This class represents a statically defined group of component sets.
ModalExpressionEditor | Base class for the OCL editor callers. This class adds modality to the brought up editor.
ModelElementNodeDescriptor | This is class Eco.Handles.Design.ModelElementNodeDescriptor.
ModelValidationContextNode | This is class Eco.Handles.Design.ModelValidationContextNode.
ModelValidationIncident | This is class Eco.Handles.Design.ModelValidationIncident.
ModelValidationManager | This is class Eco.Handles.Design.ModelValidationManager.
ModelValidationReport | Handles the information generated by a validation pass.
NameManipulator | Sets the name of the component.
NewVersionForm | Summary description for NewVersionForm.
NonCollectionTypeNameSelectorEditor | Typename selector editor that shows all known types except collections in the tree.
NotifyingDesigner | A designer setting up the framework to get notifications when components are removed. This is used to decouple components when linked components are removed
OclEditorWakeup | Class to wrap editing an expression using the Eco.Windows.Forms.OclEditor.
OclExpressionEditor | Subclass to edit the extendee's expression using the OclTypeService.
OclPsExpressionEditor | Subclass to edit the extendee's expression using the OclPsTypeService.
OclPSHandleDesigner | Designer for OclPSHandle.
OclVariableConverter | Type converter to make OclVariable Serialize
PackageSelectorForm | This class encapsulates the UI to select which packages are used in an ecospace.
PMapperCreatorHandler | This is class Eco.Handles.Design.PMapperCreatorHandler.
PropertyDefinition | Encapsulates the manipulation of property.
PropertyParams | Parameter object with some helper methods.
ReferenceHandleCreatorHandler | This is class Eco.Handles.Design.ReferenceHandleCreatorHandler.
RegisterRefreshXml | This is class Eco.Handles.Design.RegisterRefreshXml.
Registration | Singleton class used to perform design time initialization code.
RootedHandleDesigner | Designer for RootedHandle.
RootHandleEditor | Editor for the RootHandle property. Adds a null value on top of the list.
SecondOclEditorWakeup | Class to wrap editing second expression using the Eco.Windows.Forms.OclEditor.
SelectPackagesTool | Tool that encapsulates the ability to select which packages are associated with an ecospace.
TestValidator | This is class Eco.Handles.Design.TestValidator.
TopLocation | This is class Eco.Handles.Design.TopLocation.
TypeNameSelectorEditor | Abstract superclass to allow a typeselector treeview as editor for TypeName properties. Subclasses need to implement GetFilter to specify which category of types end up in the tree.
TypeTypeConverter | Abstract class for design time conversion between types and strings. Sets defaults for non-exclusive standard values lists.
ValidationIncident | This is class Eco.Handles.Design.ValidationIncident.
ValidationReport | This is class Eco.Handles.Design.ValidationReport.
WinFormValidator | Implements validation for handles and extenders.
Top
Enumerations
Name | Description
Context | This is record Eco.Handles.Design.Context.
CreateMode | Used to pass information from UI wether the node was invoked by doubleclick or dragging onto the designer.
DesignerTypes | Enumeration of the various designer tools can end up in.
DispatchEvent | This is record Eco.Handles.Design.DispatchEvent.
EcoToolKind | Specifying if the tool is a button or menu. Currently only Button is supported.
Severity | This is record Eco.Handles.Design.Severity.
Top
Interfaces
Name | Description
IComponentFilter | Used by AbstractManipulator.PreviousComponent() to get a requested component.
IComponentSetFilter | This is class Eco.Handles.Design.IComponentSetFilter.
IEcoSpaceDesignerTool | An interface that must be implemented to be part of the EcoDesigner tools
IFormValidator | Required interface to participate in form validation.
IModelValidateTool | This interface allows communication between tools without exposing their classes.
Top
Types
Name | Description
ChangeEventHandler | This is type Eco.Handles.Design.ChangeEventHandler.
Top


AboutForm Class

AboutForm Class
AboutForm Members Inheritance Hierarchy See Also
Collapse All

Summary description for WinForm1.

C#
public class AboutForm : System.Windows.Forms.Form;
Inheritance Hierarchy
System.Windows.Forms.Form
    Eco.Handles.Design.AboutForm
File

Eco.Handles.Design.AboutForm.cs

See Also
AboutForm Members
Inheritance Hierarchy


AboutForm Members

AboutForm Members
Protected Methods Public Methods
Collapse All

The following tables list the members exposed by AboutForm.

Protected Methods
Name | Description
Dispose | Clean up any resources being used.
Top
Public Methods
Name | Description
AboutForm | This is AboutForm, a member of class AboutForm.


AboutForm.AboutForm Constructor

AboutForm.AboutForm Constructor
AboutForm Class AboutForm Members Eco.Handles.Design Namespace See Also
Collapse All
C#
public AboutForm(
    EventHandler resetEcoToolboxItems
);
Remarks

This is AboutForm, a member of class AboutForm.

See Also
AboutForm Class
AboutForm Members
Eco.Handles.Design Namespace


AboutForm Methods

AboutForm Methods
Protected Methods
Collapse All

The methods of the AboutForm class are listed here.

Protected Methods
Name | Description
Dispose | Clean up any resources being used.


AboutForm.Dispose Method

AboutForm.Dispose Method
AboutForm Class AboutForm Members Eco.Handles.Design Namespace See Also
Collapse All

Clean up any resources being used.

C#
protected override void Dispose(
    bool disposing
);
See Also
AboutForm Class
AboutForm Members
Eco.Handles.Design Namespace


AbstractExpressionHandleDesigner Class

AbstractExpressionHandleDesigner Class
AbstractExpressionHandleDesigner Members Inheritance Hierarchy See Also
Collapse All
C#
public class AbstractExpressionHandleDesigner : RootedHandleDesigner;
Remarks

This is class Eco.Handles.Design.AbstractExpressionHandleDesigner.

Inheritance Hierarchy
Eco.Handles.Design.NotifyingDesigner
    Eco.Handles.Design.HandlesDesigner
        Eco.Handles.Design.RootedHandleDesigner
            Eco.Handles.Design.AbstractExpressionHandleDesigner
                Eco.Handles.Design.ExpressionHandleDesigner
                Eco.Handles.Design.OclPSHandleDesigner
File

Editors.cs

See Also
AbstractExpressionHandleDesigner Members
Inheritance Hierarchy


AbstractExpressionHandleDesigner Members

AbstractExpressionHandleDesigner Members
Protected Methods Public Methods Public Properties
Collapse All

The following tables list the members exposed by AbstractExpressionHandleDesigner.

Protected Methods
Name | Description
CreateActionLists | This is CreateActionLists, a member of class AbstractExpressionHandleDesigner.
Dispose | Unhooks up the OnComponentRemoved from IComponentChangeService.ComponentRemoved. Calls base.Dispose.
OnCreateDefaultColumns | Implements the creation of default columns.
Top
Public Methods
Name | Description
DoDefaultAction | DefaultAction is to edit the expression.
Initialize | Calls base.Initialize and then hooks up the OnComponentRemoved to IComponentChangeService.ComponentRemoved.
Top
Public Properties
Name | Description
ActionLists | This is ActionLists, a member of class AbstractExpressionHandleDesigner.
Verbs | Adds a verb to edit the expression to the inherited DesignerVerbCollection.


AbstractExpressionHandleDesigner Methods

AbstractExpressionHandleDesigner Methods
Protected Methods Public Methods
Collapse All

The methods of the AbstractExpressionHandleDesigner class are listed here.

Protected Methods
Name | Description
CreateActionLists | This is CreateActionLists, a member of class AbstractExpressionHandleDesigner.
Top
Public Methods
Name | Description
DoDefaultAction | DefaultAction is to edit the expression.


AbstractExpressionHandleDesigner.CreateActionLists Method

AbstractExpressionHandleDesigner.CreateActionLists Method
AbstractExpressionHandleDesigner Class AbstractExpressionHandleDesigner Members Eco.Handles.Design Namespace See Also
Collapse All
C#
protected virtual DesignerActionListCollection CreateActionLists();
Remarks

This is CreateActionLists, a member of class AbstractExpressionHandleDesigner.

See Also
AbstractExpressionHandleDesigner Class
AbstractExpressionHandleDesigner Members
Eco.Handles.Design Namespace


AbstractExpressionHandleDesigner.DoDefaultAction Method

AbstractExpressionHandleDesigner.DoDefaultAction Method
AbstractExpressionHandleDesigner Class AbstractExpressionHandleDesigner Members Eco.Handles.Design Namespace See Also
Collapse All

DefaultAction is to edit the expression.

C#
public override void DoDefaultAction();
See Also
AbstractExpressionHandleDesigner Class
AbstractExpressionHandleDesigner Members
Eco.Handles.Design Namespace


AbstractExpressionHandleDesigner Properties

AbstractExpressionHandleDesigner Properties
Public Properties
Collapse All

The properties of the AbstractExpressionHandleDesigner class are listed here.

Public Properties
Name | Description
ActionLists | This is ActionLists, a member of class AbstractExpressionHandleDesigner.
Verbs | Adds a verb to edit the expression to the inherited DesignerVerbCollection.


AbstractExpressionHandleDesigner.ActionLists Property

AbstractExpressionHandleDesigner.ActionLists Property
AbstractExpressionHandleDesigner Class AbstractExpressionHandleDesigner Members Eco.Handles.Design Namespace See Also
Collapse All
C#
public override DesignerActionListCollection ActionLists;
Remarks

This is ActionLists, a member of class AbstractExpressionHandleDesigner.

See Also
AbstractExpressionHandleDesigner Class
AbstractExpressionHandleDesigner Members
Eco.Handles.Design Namespace


AbstractExpressionHandleDesigner.Verbs Property

AbstractExpressionHandleDesigner.Verbs Property
AbstractExpressionHandleDesigner Class AbstractExpressionHandleDesigner Members Eco.Handles.Design Namespace See Also
Collapse All

Adds a verb to edit the expression to the inherited DesignerVerbCollection.

C#
public override DesignerVerbCollection Verbs;
See Also
AbstractExpressionHandleDesigner Class
AbstractExpressionHandleDesigner Members
Eco.Handles.Design Namespace


AbstractManipulator Class

AbstractManipulator Class
AbstractManipulator Members Inheritance Hierarchy See Also
Collapse All

Abstract base class for the manipulators.

C#
public abstract class AbstractManipulator;
Inheritance Hierarchy
Eco.Handles.Design.AbstractManipulator
    Eco.Handles.Design.ClientIDManipulator
    Eco.Handles.Design.ColumnsManipulator
    Eco.Handles.Design.ConnectionManipulator
    Eco.Handles.Design.DataBindManipulator
    Eco.Handles.Design.EcoManipulator
    Eco.Handles.Design.NameManipulator
File

AbstractPropertyManipulator.cs

See Also
AbstractManipulator Members
Inheritance Hierarchy


AbstractManipulator Members

AbstractManipulator Members
Protected Methods Public Methods
Collapse All

The following tables list the members exposed by AbstractManipulator.

Protected Methods
Name | Description
PreviousComponent | Returns the previously created component that matches filter.
Top
Public Methods
Name | Description
SetPropertyValue | Allows for setting the property value.


AbstractManipulator Methods

AbstractManipulator Methods
Protected Methods Public Methods
Collapse All

The methods of the AbstractManipulator class are listed here.

Protected Methods
Name | Description
PreviousComponent | Returns the previously created component that matches filter.
Top
Public Methods
Name | Description
SetPropertyValue | Allows for setting the property value.


AbstractManipulator.PreviousComponent Method

AbstractManipulator.PreviousComponent Method
AbstractManipulator Class AbstractManipulator Members Eco.Handles.Design Namespace See Also
Collapse All

Returns the previously created component that matches filter.

C#
protected IComponent PreviousComponent(
    PropertyParams propertyParams,
    IComponentFilter filter
);
See Also
AbstractManipulator Class
AbstractManipulator Members
Eco.Handles.Design Namespace


AbstractManipulator.SetPropertyValue Method

AbstractManipulator.SetPropertyValue Method
AbstractManipulator Class AbstractManipulator Members Eco.Handles.Design Namespace See Also
Collapse All

Allows for setting the property value.

C#
public abstract void SetPropertyValue(
    PropertyParams propertyParams
);
See Also
AbstractManipulator Class
AbstractManipulator Members
Eco.Handles.Design Namespace


ActionExpressionEditor Class

ActionExpressionEditor Class
ActionExpressionEditor Members Inheritance Hierarchy See Also
Collapse All

Subclass to edit the extendee's expression using the ActionLanguageTypeService.

C#
public class ActionExpressionEditor : ExpressionEditor;
Inheritance Hierarchy
Eco.Handles.Design.ModalExpressionEditor
    Eco.Handles.Design.ExpressionEditor
        Eco.Handles.Design.ActionExpressionEditor
File

OCLEditorWakeup.cs

See Also
ActionExpressionEditor Members
Inheritance Hierarchy


ActionExpressionEditor Members

ActionExpressionEditor Members
Protected Methods Public Methods
Collapse All

The following tables list the members exposed by ActionExpressionEditor.

Protected Methods
Name | Description
getOclTypeService |
ModalExpressionEditor | This is ModalExpressionEditor, a member of class ModalExpressionEditor.
Top
Public Methods
Name | Description
ActionExpressionEditor | This is ActionExpressionEditor, a member of class ActionExpressionEditor.
EditValue | Collects information from the environment and invokes OclEditor.ShowEditor.
GetEditStyle | Sets the editor to be modal.


ActionExpressionEditor.ActionExpressionEditor Constructor

ActionExpressionEditor.ActionExpressionEditor Constructor
ActionExpressionEditor Class ActionExpressionEditor Members Eco.Handles.Design Namespace See Also
Collapse All
C#
public ActionExpressionEditor();
Remarks

This is ActionExpressionEditor, a member of class ActionExpressionEditor.

See Also
ActionExpressionEditor Class
ActionExpressionEditor Members
Eco.Handles.Design Namespace


ActionExpressionEditor Methods

ActionExpressionEditor Methods
Protected Methods
Collapse All

The methods of the ActionExpressionEditor class are listed here.

Protected Methods
Name | Description
getOclTypeService |


ActionExpressionEditor.getOclTypeService Method

ActionExpressionEditor.getOclTypeService Method
ActionExpressionEditor Class ActionExpressionEditor Members Eco.Handles.Design Namespace See Also
Collapse All
C#
protected override ITypeService getOclTypeService(
    IStaticContext staticContext
);
Returns

Returns staticContext.ActionLanguageTypeService

Exceptions
Exceptions | Description
ArgumentNullException | Thrown if staticContext is null.
See Also
ActionExpressionEditor Class
ActionExpressionEditor Members
Eco.Handles.Design Namespace


AddValidatorsFromXml Class

AddValidatorsFromXml Class
Inheritance Hierarchy See Also
Collapse All
C#
public class AddValidatorsFromXml;
Remarks

This is class Eco.Handles.Design.AddValidatorsFromXml.

Inheritance Hierarchy
Eco.Handles.Design.AddValidatorsFromXml
File

ValidatorsFromXml.cs

See Also
Inheritance Hierarchy


AllInstancesWidgetsCreatorHandler Class

AllInstancesWidgetsCreatorHandler Class
AllInstancesWidgetsCreatorHandler Members Inheritance Hierarchy See Also
Collapse All
C#
public class AllInstancesWidgetsCreatorHandler : CreatorHandler;
Remarks

This is class Eco.Handles.Design.AllInstancesWidgetsCreatorHandler.

Inheritance Hierarchy
Eco.Handles.Design.CreatorHandler
    Eco.Handles.Design.AllInstancesWidgetsCreatorHandler
File

UmlRtSelectors.cs

See Also
AllInstancesWidgetsCreatorHandler Members
Inheritance Hierarchy


AllInstancesWidgetsCreatorHandler Members

AllInstancesWidgetsCreatorHandler Members
Public Methods Public Properties Protected Properties
Collapse All

The following tables list the members exposed by AllInstancesWidgetsCreatorHandler.

Public Methods
Name | Description
AllInstancesWidgetsCreatorHandler | This is AllInstancesWidgetsCreatorHandler, a member of class AllInstancesWidgetsCreatorHandler.
Clear | Clears the CreatorGroup.CreatorDescriptorList.
CreatorHandler | Creates a new instance and reads information from xml-file.
ReadFromXml | This is ReadFromXml, a member of class CreatorHandler.
RefreshCreatorTree | Adds creators for defined classes.
Top
Public Properties
Name | Description
CreatorGroup | The CreatorGroup represents the top node for this structure.
Top
Protected Properties
Name | Description
BinDir | Returns IIdeService.GetEcoConfigDir()
Filename | do not localize;
TopNodename | do not localize;


AllInstancesWidgetsCreatorHandler.AllInstancesWidgetsCreatorHandler Constructor

AllInstancesWidgetsCreatorHandler.AllInstancesWidgetsCreatorHandler Constructor
AllInstancesWidgetsCreatorHandler Class AllInstancesWidgetsCreatorHandler Members Eco.Handles.Design Namespace See Also
Collapse All
C#
public AllInstancesWidgetsCreatorHandler();
Remarks

This is AllInstancesWidgetsCreatorHandler, a member of class AllInstancesWidgetsCreatorHandler.

See Also
AllInstancesWidgetsCreatorHandler Class
AllInstancesWidgetsCreatorHandler Members
Eco.Handles.Design Namespace


AllInstancesWidgetsCreatorHandler Methods

AllInstancesWidgetsCreatorHandler Methods
Public Methods
Collapse All

The methods of the AllInstancesWidgetsCreatorHandler class are listed here.

Public Methods
Name | Description
RefreshCreatorTree | Adds creators for defined classes.


AllInstancesWidgetsCreatorHandler.RefreshCreatorTree Method

AllInstancesWidgetsCreatorHandler.RefreshCreatorTree Method
AllInstancesWidgetsCreatorHandler Class AllInstancesWidgetsCreatorHandler Members Eco.Handles.Design Namespace See Also
Collapse All

Adds creators for defined classes.

C#
public override void RefreshCreatorTree(
    DesignerData designerData
);
Remarks

InvokingComponent is ReferenceHandle, its TypeSystem must be available. The config node is "classifier". Nodes are created for all classes in the type system.

See Also
AllInstancesWidgetsCreatorHandler Class
AllInstancesWidgetsCreatorHandler Members
Eco.Handles.Design Namespace


AllInstancesWidgetsCreatorHandler Properties

AllInstancesWidgetsCreatorHandler Properties
Protected Properties
Collapse All

The properties of the AllInstancesWidgetsCreatorHandler class are listed here.

Protected Properties
Name | Description
Filename | do not localize;
TopNodename | do not localize;


AllInstancesWidgetsCreatorHandler.Filename Property

AllInstancesWidgetsCreatorHandler.Filename Property
AllInstancesWidgetsCreatorHandler Class AllInstancesWidgetsCreatorHandler Members Eco.Handles.Design Namespace See Also
Collapse All
C#
protected override string Filename;
Remarks

do not localize;

See Also
AllInstancesWidgetsCreatorHandler Class
AllInstancesWidgetsCreatorHandler Members
Eco.Handles.Design Namespace


AllInstancesWidgetsCreatorHandler.TopNodename Property

AllInstancesWidgetsCreatorHandler.TopNodename Property
AllInstancesWidgetsCreatorHandler Class AllInstancesWidgetsCreatorHandler Members Eco.Handles.Design Namespace See Also
Collapse All
C#
protected override string TopNodename;
Remarks

do not localize;

See Also
AllInstancesWidgetsCreatorHandler Class
AllInstancesWidgetsCreatorHandler Members
Eco.Handles.Design Namespace


AnyTypeNameSelectorEditor Class

AnyTypeNameSelectorEditor Class
AnyTypeNameSelectorEditor Members Inheritance Hierarchy See Also
Collapse All

Typename selector editor that shows all known types in the tree.

C#
public sealed class AnyTypeNameSelectorEditor : TypeNameSelectorEditor;
Inheritance Hierarchy
Eco.Handles.Design.TypeNameSelectorEditor
    Eco.Handles.Design.AnyTypeNameSelectorEditor
File

TypeNameSelectorEditor.cs

See Also
AnyTypeNameSelectorEditor Members
Inheritance Hierarchy


AnyTypeNameSelectorEditor Members

AnyTypeNameSelectorEditor Members
Protected Methods Public Methods
Collapse All

The following tables list the members exposed by AnyTypeNameSelectorEditor.

Protected Methods
Name | Description
FillTreeWithData | This is FillTreeWithData, a member of class TypeNameSelectorEditor.
GetFilter | Returns the array of valid ClassifierType for this editor.
Top
Public Methods
Name | Description
EditValue | Fills the selector tree with relevant data, drops it down and returns the selected node value.
SetValue | This is SetValue, a member of class TypeNameSelectorEditor.


AnyTypeNameSelectorEditor Methods

AnyTypeNameSelectorEditor Methods
Protected Methods
Collapse All

The methods of the AnyTypeNameSelectorEditor class are listed here.

Protected Methods
Name | Description
GetFilter | Returns the array of valid ClassifierType for this editor.


AnyTypeNameSelectorEditor.GetFilter Method

AnyTypeNameSelectorEditor.GetFilter Method
AnyTypeNameSelectorEditor Class AnyTypeNameSelectorEditor Members Eco.Handles.Design Namespace See Also
Collapse All

Returns the array of valid ClassifierType for this editor.

C#
protected override ClassifierType[] GetFilter();
Returns

Primitive, Enumeration, Class, Collection

See Also
AnyTypeNameSelectorEditor Class
AnyTypeNameSelectorEditor Members
Eco.Handles.Design Namespace


AssociationWidgetsCreatorHandler Class

AssociationWidgetsCreatorHandler Class
AssociationWidgetsCreatorHandler Members Inheritance Hierarchy See Also
Collapse All
C#
public class AssociationWidgetsCreatorHandler : CreatorHandler;
Remarks

This is class Eco.Handles.Design.AssociationWidgetsCreatorHandler.

Inheritance Hierarchy
Eco.Handles.Design.CreatorHandler
    Eco.Handles.Design.AssociationWidgetsCreatorHandler
File

UmlRtSelectors.cs

See Also
AssociationWidgetsCreatorHandler Members
Inheritance Hierarchy


AssociationWidgetsCreatorHandler Members

AssociationWidgetsCreatorHandler Members
Public Methods Public Properties Protected Properties
Collapse All

The following tables list the members exposed by AssociationWidgetsCreatorHandler.

Public Methods
Name | Description
AssociationWidgetsCreatorHandler | This is AssociationWidgetsCreatorHandler, a member of class AssociationWidgetsCreatorHandler.
Clear | Clears the CreatorGroup.CreatorDescriptorList.
CreatorHandler | Creates a new instance and reads information from xml-file.
ReadFromXml | This is ReadFromXml, a member of class CreatorHandler.
RefreshCreatorTree | Adds creators for ECO features.
Top
Public Properties
Name | Description
CreatorGroup | The CreatorGroup represents the top node for this structure.
Top
Protected Properties
Name | Description
BinDir | Returns IIdeService.GetEcoConfigDir()
Filename | do not localize;
TopNodename | do not localize;


AssociationWidgetsCreatorHandler.AssociationWidgetsCreatorHandler Constructor

AssociationWidgetsCreatorHandler.AssociationWidgetsCreatorHandler Constructor
AssociationWidgetsCreatorHandler Class AssociationWidgetsCreatorHandler Members Eco.Handles.Design Namespace See Also
Collapse All
C#
public AssociationWidgetsCreatorHandler();
Remarks

This is AssociationWidgetsCreatorHandler, a member of class AssociationWidgetsCreatorHandler.

See Also
AssociationWidgetsCreatorHandler Class
AssociationWidgetsCreatorHandler Members
Eco.Handles.Design Namespace


AssociationWidgetsCreatorHandler Methods

AssociationWidgetsCreatorHandler Methods
Public Methods
Collapse All

The methods of the AssociationWidgetsCreatorHandler class are listed here.

Public Methods
Name | Description
RefreshCreatorTree | Adds creators for ECO features.


AssociationWidgetsCreatorHandler.RefreshCreatorTree Method

AssociationWidgetsCreatorHandler.RefreshCreatorTree Method
AssociationWidgetsCreatorHandler Class AssociationWidgetsCreatorHandler Members Eco.Handles.Design Namespace See Also
Collapse All

Adds creators for ECO features.

C#
public override void RefreshCreatorTree(
    DesignerData designerData
);
Remarks

InvokingComponent is IStaticContext, its StaticUmlType must be an IClassifier. The config node is "classifier". Nodes are created for all features that are IAssociationEnds or of enum type. Configuration node is "AssociationEnd.Single", "AssociationEnd.Multi" and "enum"respectively.

See Also
AssociationWidgetsCreatorHandler Class
AssociationWidgetsCreatorHandler Members
Eco.Handles.Design Namespace


AssociationWidgetsCreatorHandler Properties

AssociationWidgetsCreatorHandler Properties
Protected Properties
Collapse All

The properties of the AssociationWidgetsCreatorHandler class are listed here.

Protected Properties
Name | Description
Filename | do not localize;
TopNodename | do not localize;


AssociationWidgetsCreatorHandler.Filename Property

AssociationWidgetsCreatorHandler.Filename Property
AssociationWidgetsCreatorHandler Class AssociationWidgetsCreatorHandler Members Eco.Handles.Design Namespace See Also
Collapse All
C#
protected override string Filename;
Remarks

do not localize;

See Also
AssociationWidgetsCreatorHandler Class
AssociationWidgetsCreatorHandler Members
Eco.Handles.Design Namespace


AssociationWidgetsCreatorHandler.TopNodename Property

AssociationWidgetsCreatorHandler.TopNodename Property
AssociationWidgetsCreatorHandler Class AssociationWidgetsCreatorHandler Members Eco.Handles.Design Namespace See Also
Collapse All
C#
protected override string TopNodename;
Remarks

do not localize;

See Also
AssociationWidgetsCreatorHandler Class
AssociationWidgetsCreatorHandler Members
Eco.Handles.Design Namespace


ChangeEventArgs Class

ChangeEventArgs Class
ChangeEventArgs Members Inheritance Hierarchy See Also
Collapse All
C#
public class ChangeEventArgs;
Remarks

This is class Eco.Handles.Design.ChangeEventArgs.

Inheritance Hierarchy
Eco.Handles.Design.ChangeEventArgs
File

WidgetSelector.cs

See Also
ChangeEventArgs Members
Inheritance Hierarchy


ChangeEventArgs Members

ChangeEventArgs Members
Public Methods Public Properties
Collapse All

The following tables list the members exposed by ChangeEventArgs.

Public Methods
Name | Description
ChangeEventArgs | This is the overview for the ChangeEventArgs constructor overload.
Top
Public Properties
Name | Description
DispatchedEvents | This is DispatchedEvents, a member of class ChangeEventArgs.
Form | This is Form, a member of class ChangeEventArgs.
Host | This is Host, a member of class ChangeEventArgs.


ChangeEventArgs Constructor

ChangeEventArgs Constructor
Collapse All

This is the overview for the ChangeEventArgs constructor overload.

Overload List
Name | Description
ChangeEventArgs.ChangeEventArgs (IDesignerHost, ContextComponentsForm) | This is ChangeEventArgs, a member of class ChangeEventArgs.
ChangeEventArgs.ChangeEventArgs (IDesignerHost, ContextComponentsForm, DispatchEvent) | This is ChangeEventArgs, a member of class ChangeEventArgs.


ChangeEventArgs.ChangeEventArgs Constructor (IDesignerHost, ContextComponentsForm)

ChangeEventArgs.ChangeEventArgs Constructor (IDesignerHost, ContextComponentsForm)
ChangeEventArgs Class ChangeEventArgs Members Eco.Handles.Design Namespace See Also
Collapse All
C#
public ChangeEventArgs(
    IDesignerHost host,
    ContextComponentsForm form
);
Remarks

This is ChangeEventArgs, a member of class ChangeEventArgs.

See Also
ChangeEventArgs Class
ChangeEventArgs Members
Eco.Handles.Design Namespace


ChangeEventArgs.ChangeEventArgs Constructor (IDesignerHost, ContextComponentsForm, DispatchEvent)

ChangeEventArgs.ChangeEventArgs Constructor (IDesignerHost, ContextComponentsForm, DispatchEvent)
ChangeEventArgs Class ChangeEventArgs Members Eco.Handles.Design Namespace See Also
Collapse All
C#
public ChangeEventArgs(
    IDesignerHost host,
    ContextComponentsForm form,
    DispatchEvent dispatchedEvents
);
Remarks

This is ChangeEventArgs, a member of class ChangeEventArgs.

See Also
ChangeEventArgs Class
ChangeEventArgs Members
Eco.Handles.Design Namespace


ChangeEventArgs Properties

ChangeEventArgs Properties
Public Properties
Collapse All

The properties of the ChangeEventArgs class are listed here.

Public Properties
Name | Description
DispatchedEvents | This is DispatchedEvents, a member of class ChangeEventArgs.
Form | This is Form, a member of class ChangeEventArgs.
Host | This is Host, a member of class ChangeEventArgs.


ChangeEventArgs.DispatchedEvents Property

ChangeEventArgs.DispatchedEvents Property
ChangeEventArgs Class ChangeEventArgs Members Eco.Handles.Design Namespace See Also
Collapse All
C#
public DispatchEvent DispatchedEvents;
Remarks

This is DispatchedEvents, a member of class ChangeEventArgs.

See Also
ChangeEventArgs Class
ChangeEventArgs Members
Eco.Handles.Design Namespace


ChangeEventArgs.Form Property

ChangeEventArgs.Form Property
ChangeEventArgs Class ChangeEventArgs Members Eco.Handles.Design Namespace See Also
Collapse All
C#
public ContextComponentsForm Form;
Remarks

This is Form, a member of class ChangeEventArgs.

See Also
ChangeEventArgs Class
ChangeEventArgs Members
Eco.Handles.Design Namespace


ChangeEventArgs.Host Property

ChangeEventArgs.Host Property
ChangeEventArgs Class ChangeEventArgs Members Eco.Handles.Design Namespace See Also
Collapse All
C#
public IDesignerHost Host;
Remarks

This is Host, a member of class ChangeEventArgs.

See Also
ChangeEventArgs Class
ChangeEventArgs Members
Eco.Handles.Design Namespace


ClientIDManipulator Class

ClientIDManipulator Class
ClientIDManipulator Members Inheritance Hierarchy See Also
Collapse All

Sets the ClientID of the WebControl.

C#
public class ClientIDManipulator : AbstractManipulator;
Remarks

If the component is one of GridView the name will be set to [prefix]propertyParams.Name[i]. In other cases the name will not change. Dupe checking code is there to prevent names from being reused.

Inheritance Hierarchy
Eco.Handles.Design.AbstractManipulator
    Eco.Handles.Design.ClientIDManipulator
File

PropertyManipulators.cs

See Also
ClientIDManipulator Members
Inheritance Hierarchy


ClientIDManipulator Members

ClientIDManipulator Members
Protected Methods Public Methods
Collapse All

The following tables list the members exposed by ClientIDManipulator.

Protected Methods
Name | Description
GetPrefix | This is GetPrefix, a member of class ClientIDManipulator.
PreviousComponent | Returns the previously created component that matches filter.
Top
Public Methods
Name | Description
SetPropertyValue | Allows for setting the property value.


ClientIDManipulator Methods

ClientIDManipulator Methods
Protected Methods Public Methods
Collapse All

The methods of the ClientIDManipulator class are listed here.

Protected Methods
Name | Description
GetPrefix | This is GetPrefix, a member of class ClientIDManipulator.
Top
Public Methods
Name | Description
SetPropertyValue | Allows for setting the property value.


ClientIDManipulator.GetPrefix Method

ClientIDManipulator.GetPrefix Method
ClientIDManipulator Class ClientIDManipulator Members Eco.Handles.Design Namespace See Also
Collapse All
C#
protected virtual string GetPrefix(
    IComponent component
);
Remarks

This is GetPrefix, a member of class ClientIDManipulator.

See Also
ClientIDManipulator Class
ClientIDManipulator Members
Eco.Handles.Design Namespace


ClientIDManipulator.SetPropertyValue Method

ClientIDManipulator.SetPropertyValue Method
ClientIDManipulator Class ClientIDManipulator Members Eco.Handles.Design Namespace See Also
Collapse All

Allows for setting the property value.

C#
public override void SetPropertyValue(
    PropertyParams propertyParams
);
See Also
ClientIDManipulator Class
ClientIDManipulator Members
Eco.Handles.Design Namespace


ColumnCollectionEditor Class

ColumnCollectionEditor Class
ColumnCollectionEditor Members Inheritance Hierarchy See Also
Collapse All

Editor for the ColumnCollection class.

C#
public class ColumnCollectionEditor : CollectionEditor;
Inheritance Hierarchy
Eco.Handles.Design.ColumnCollectionEditor
File

ColumnCollectionEditor.cs

See Also
ColumnCollectionEditor Members
Inheritance Hierarchy


ColumnCollectionEditor Members

ColumnCollectionEditor Members
Protected Methods Public Methods
Collapse All

The following tables list the members exposed by ColumnCollectionEditor.

Protected Methods
Name | Description
CreateNewItemTypes | Specifies that the collection can contain OclColumn and EventDerivedColumn.
Top
Public Methods
Name | Description
ColumnCollectionEditor | This is ColumnCollectionEditor, a member of class ColumnCollectionEditor.


ColumnCollectionEditor.ColumnCollectionEditor Constructor

ColumnCollectionEditor.ColumnCollectionEditor Constructor
ColumnCollectionEditor Class ColumnCollectionEditor Members Eco.Handles.Design Namespace See Also
Collapse All
C#
public ColumnCollectionEditor(
    Type type
);
Remarks

This is ColumnCollectionEditor, a member of class ColumnCollectionEditor.

See Also
ColumnCollectionEditor Class
ColumnCollectionEditor Members
Eco.Handles.Design Namespace


ColumnCollectionEditor Methods

ColumnCollectionEditor Methods
Protected Methods
Collapse All

The methods of the ColumnCollectionEditor class are listed here.

Protected Methods
Name | Description
CreateNewItemTypes | Specifies that the collection can contain OclColumn and EventDerivedColumn.


ColumnCollectionEditor.CreateNewItemTypes Method

ColumnCollectionEditor.CreateNewItemTypes Method
ColumnCollectionEditor Class ColumnCollectionEditor Members Eco.Handles.Design Namespace See Also
Collapse All

Specifies that the collection can contain OclColumn and EventDerivedColumn.

C#
protected override Type[] CreateNewItemTypes();
See Also
ColumnCollectionEditor Class
ColumnCollectionEditor Members
Eco.Handles.Design Namespace


ColumnCreatorNodeDescriptor Class

ColumnCreatorNodeDescriptor Class
ColumnCreatorNodeDescriptor Members Inheritance Hierarchy See Also
Collapse All
C#
public class ColumnCreatorNodeDescriptor : CreatorNodeDescriptor;
Remarks

This is class Eco.Handles.Design.ColumnCreatorNodeDescriptor.

Inheritance Hierarchy
Eco.Handles.Design.CreatorNodeDescriptor
    Eco.Handles.Design.ColumnCreatorNodeDescriptor
File

TypedListSelectors.cs

See Also
ColumnCreatorNodeDescriptor Members
Inheritance Hierarchy


ColumnCreatorNodeDescriptor Members

ColumnCreatorNodeDescriptor Members
Public Methods Public Properties
Collapse All

The following tables list the members exposed by ColumnCreatorNodeDescriptor.

Public Methods
Name | Description
ColumnCreatorNodeDescriptor | This is ColumnCreatorNodeDescriptor, a member of class ColumnCreatorNodeDescriptor.
CreatorNodeDescriptor | This is CreatorNodeDescriptor, a member of class CreatorNodeDescriptor.
DragInvoke | Invokes the MetaCreator linked to creatorInfo to create components.
Invoke | Invokes the MetaCreator linked to creatorInfo to create components.
MetaCreatorList | Derived list of all dynamically registered MetaCreator used to build UI nodes.
ToString | String representation is defined as DisplayName.
Top
Public Properties
Name | Description
Description | This is Description, a member of class CreatorNodeDescriptor.
DisplayName | This is DisplayName, a member of class ColumnCreatorNodeDescriptor.
MetaCreatorType | The MetaCreatorType with the list of defined component sets.
MetaCreatorTypeList | This is MetaCreatorTypeList, a member of class CreatorNodeDescriptor.
Name | This is Name, a member of class ColumnCreatorNodeDescriptor.
ToolTip | This is ToolTip, a member of class CreatorNodeDescriptor.


ColumnCreatorNodeDescriptor.ColumnCreatorNodeDescriptor Constructor

ColumnCreatorNodeDescriptor.ColumnCreatorNodeDescriptor Constructor
ColumnCreatorNodeDescriptor Class ColumnCreatorNodeDescriptor Members Eco.Handles.Design Namespace See Also
Collapse All
C#
public ColumnCreatorNodeDescriptor(
    PropertyDescriptor property
);
Remarks

This is ColumnCreatorNodeDescriptor, a member of class ColumnCreatorNodeDescriptor.

See Also
ColumnCreatorNodeDescriptor Class
ColumnCreatorNodeDescriptor Members
Eco.Handles.Design Namespace


ColumnCreatorNodeDescriptor Properties

ColumnCreatorNodeDescriptor Properties
Public Properties
Collapse All

The properties of the ColumnCreatorNodeDescriptor class are listed here.

Public Properties
Name | Description
DisplayName | This is DisplayName, a member of class ColumnCreatorNodeDescriptor.
Name | This is Name, a member of class ColumnCreatorNodeDescriptor.


ColumnCreatorNodeDescriptor.DisplayName Property

ColumnCreatorNodeDescriptor.DisplayName Property
ColumnCreatorNodeDescriptor Class ColumnCreatorNodeDescriptor Members Eco.Handles.Design Namespace See Also
Collapse All
C#
public override string DisplayName;
Remarks

This is DisplayName, a member of class ColumnCreatorNodeDescriptor.

See Also
ColumnCreatorNodeDescriptor Class
ColumnCreatorNodeDescriptor Members
Eco.Handles.Design Namespace


ColumnCreatorNodeDescriptor.Name Property

ColumnCreatorNodeDescriptor.Name Property
ColumnCreatorNodeDescriptor Class ColumnCreatorNodeDescriptor Members Eco.Handles.Design Namespace See Also
Collapse All
C#
public override string Name;
Remarks

This is Name, a member of class ColumnCreatorNodeDescriptor.

See Also
ColumnCreatorNodeDescriptor Class
ColumnCreatorNodeDescriptor Members
Eco.Handles.Design Namespace


ColumnsManipulator Class

ColumnsManipulator Class
ColumnsManipulator Members Inheritance Hierarchy See Also
Collapse All

Implements dupe checking for manipulators that want to add columns.

C#
public abstract class ColumnsManipulator : AbstractManipulator;
Inheritance Hierarchy
Eco.Handles.Design.AbstractManipulator
    Eco.Handles.Design.ColumnsManipulator
File

PropertyManipulators.cs

See Also
ColumnsManipulator Members
Inheritance Hierarchy


ColumnsManipulator Members

ColumnsManipulator Members
Protected Methods Public Methods
Collapse All

The following tables list the members exposed by ColumnsManipulator.

Protected Methods
Name | Description
AddColumn | Checks if the column name exists in the column collection and if not adds it.
CreateColumn | This is CreateColumn, a member of class ColumnsManipulator.
GetTargetComponent | This is GetTargetComponent, a member of class ColumnsManipulator.
PreviousComponent | Returns the previously created component that matches filter.
Top
Public Methods
Name | Description
SetPropertyValue | Allows for setting the property value.


ColumnsManipulator Methods

ColumnsManipulator Methods
Protected Methods Public Methods
Collapse All

The methods of the ColumnsManipulator class are listed here.

Protected Methods
Name | Description
AddColumn | Checks if the column name exists in the column collection and if not adds it.
CreateColumn | This is CreateColumn, a member of class ColumnsManipulator.
GetTargetComponent | This is GetTargetComponent, a member of class ColumnsManipulator.
Top
Public Methods
Name | Description
SetPropertyValue | Allows for setting the property value.


ColumnsManipulator.AddColumn Method

ColumnsManipulator.AddColumn Method
ColumnsManipulator Class ColumnsManipulator Members Eco.Handles.Design Namespace See Also
Collapse All

Checks if the column name exists in the column collection and if not adds it.

C#
protected bool AddColumn(
    AbstractColumn column,
    ColumnCollection columns
);
Returns

false if the name existed, true if the name did not exist. True indicates the column was added.

See Also
ColumnsManipulator Class
ColumnsManipulator Members
Eco.Handles.Design Namespace


ColumnsManipulator.CreateColumn Method

ColumnsManipulator.CreateColumn Method
ColumnsManipulator Class ColumnsManipulator Members Eco.Handles.Design Namespace See Also
Collapse All
C#
protected abstract AbstractColumn CreateColumn(
    PropertyParams propertyParams
);
Remarks

This is CreateColumn, a member of class ColumnsManipulator.

See Also
ColumnsManipulator Class
ColumnsManipulator Members
Eco.Handles.Design Namespace


ColumnsManipulator.GetTargetComponent Method

ColumnsManipulator.GetTargetComponent Method
ColumnsManipulator Class ColumnsManipulator Members Eco.Handles.Design Namespace See Also
Collapse All
C#
protected abstract IComponent GetTargetComponent(
    PropertyParams propertyParams
);
Remarks

This is GetTargetComponent, a member of class ColumnsManipulator.

See Also
ColumnsManipulator Class
ColumnsManipulator Members
Eco.Handles.Design Namespace


ColumnsManipulator.SetPropertyValue Method

ColumnsManipulator.SetPropertyValue Method
ColumnsManipulator Class ColumnsManipulator Members Eco.Handles.Design Namespace See Also
Collapse All

Allows for setting the property value.

C#
public override void SetPropertyValue(
    PropertyParams propertyParams
);
See Also
ColumnsManipulator Class
ColumnsManipulator Members
Eco.Handles.Design Namespace


ColumnWidgetsCreatorHandler Class

ColumnWidgetsCreatorHandler Class
ColumnWidgetsCreatorHandler Members Inheritance Hierarchy See Also
Collapse All
C#
public class ColumnWidgetsCreatorHandler : CreatorHandler;
Remarks

This is class Eco.Handles.Design.ColumnWidgetsCreatorHandler.

Inheritance Hierarchy
Eco.Handles.Design.CreatorHandler
    Eco.Handles.Design.ColumnWidgetsCreatorHandler
File

TypedListSelectors.cs

See Also
ColumnWidgetsCreatorHandler Members
Inheritance Hierarchy


ColumnWidgetsCreatorHandler Members

ColumnWidgetsCreatorHandler Members
Public Methods Public Properties Protected Properties
Collapse All

The following tables list the members exposed by ColumnWidgetsCreatorHandler.

Public Methods
Name | Description
Clear | Clears the CreatorGroup.CreatorDescriptorList.
ColumnWidgetsCreatorHandler | This is ColumnWidgetsCreatorHandler, a member of class ColumnWidgetsCreatorHandler.
CreatorHandler | Creates a new instance and reads information from xml-file.
ReadFromXml | This is ReadFromXml, a member of class CreatorHandler.
RefreshCreatorTree | Adds all defined columns to the tree.
Top
Public Properties
Name | Description
CreatorGroup | The CreatorGroup represents the top node for this structure.
Top
Protected Properties
Name | Description
BinDir | Returns IIdeService.GetEcoConfigDir()
Filename | do not localize;
TopNodename | do not localize


ColumnWidgetsCreatorHandler.ColumnWidgetsCreatorHandler Constructor

ColumnWidgetsCreatorHandler.ColumnWidgetsCreatorHandler Constructor
ColumnWidgetsCreatorHandler Class ColumnWidgetsCreatorHandler Members Eco.Handles.Design Namespace See Also
Collapse All
C#
public ColumnWidgetsCreatorHandler();
Remarks

This is ColumnWidgetsCreatorHandler, a member of class ColumnWidgetsCreatorHandler.

See Also
ColumnWidgetsCreatorHandler Class
ColumnWidgetsCreatorHandler Members
Eco.Handles.Design Namespace


ColumnWidgetsCreatorHandler Methods

ColumnWidgetsCreatorHandler Methods
Public Methods
Collapse All

The methods of the ColumnWidgetsCreatorHandler class are listed here.

Public Methods
Name | Description
RefreshCreatorTree | Adds all defined columns to the tree.


ColumnWidgetsCreatorHandler.RefreshCreatorTree Method

ColumnWidgetsCreatorHandler.RefreshCreatorTree Method
ColumnWidgetsCreatorHandler Class ColumnWidgetsCreatorHandler Members Eco.Handles.Design Namespace See Also
Collapse All

Adds all defined columns to the tree.

C#
public override void RefreshCreatorTree(
    DesignerData designerData
);
See Also
ColumnWidgetsCreatorHandler Class
ColumnWidgetsCreatorHandler Members
Eco.Handles.Design Namespace


ColumnWidgetsCreatorHandler Properties

ColumnWidgetsCreatorHandler Properties
Protected Properties
Collapse All

The properties of the ColumnWidgetsCreatorHandler class are listed here.

Protected Properties
Name | Description
Filename | do not localize;
TopNodename | do not localize


ColumnWidgetsCreatorHandler.Filename Property

ColumnWidgetsCreatorHandler.Filename Property
ColumnWidgetsCreatorHandler Class ColumnWidgetsCreatorHandler Members Eco.Handles.Design Namespace See Also
Collapse All
C#
protected override string Filename;
Remarks

do not localize;

See Also
ColumnWidgetsCreatorHandler Class
ColumnWidgetsCreatorHandler Members
Eco.Handles.Design Namespace


ColumnWidgetsCreatorHandler.TopNodename Property

ColumnWidgetsCreatorHandler.TopNodename Property
ColumnWidgetsCreatorHandler Class ColumnWidgetsCreatorHandler Members Eco.Handles.Design Namespace See Also
Collapse All
C#
protected override string TopNodename;
Remarks

do not localize

See Also
ColumnWidgetsCreatorHandler Class
ColumnWidgetsCreatorHandler Members
Eco.Handles.Design Namespace


ComponentDefinition Class

ComponentDefinition Class
ComponentDefinition Members Inheritance Hierarchy See Also
Collapse All

Encapsulates creation of a component.

C#
public class ComponentDefinition;
Inheritance Hierarchy
Eco.Handles.Design.ComponentDefinition
File

ContextComponentDictionary.cs

See Also
ComponentDefinition Members
Inheritance Hierarchy


ComponentDefinition Members

ComponentDefinition Members
Public Methods Public Properties
Collapse All

The following tables list the members exposed by ComponentDefinition.

Public Methods
Name | Description
AddPropertyDefinition | Adds a property that should be manipulated.
ComponentDefinition | This is the overview for the ComponentDefinition constructor overload.
CreateComponent | Creates a component as specified and returns it.
CreateWebComponent | This is CreateWebComponent, a member of class ComponentDefinition.
Top
Public Properties
Name | Description
Singleton | If true, a pre-existing component of the same type is reused.


ComponentDefinition Constructor

ComponentDefinition Constructor

This is the overview for the ComponentDefinition constructor overload.

Overload List
Name | Description
ComponentDefinition.ComponentDefinition () | This is ComponentDefinition, a member of class ComponentDefinition.
ComponentDefinition.ComponentDefinition (string, string) |


ComponentDefinition.ComponentDefinition Constructor ()

ComponentDefinition.ComponentDefinition Constructor ()
ComponentDefinition Class ComponentDefinition Members Eco.Handles.Design Namespace See Also
Collapse All
C#
public ComponentDefinition();
Remarks

This is ComponentDefinition, a member of class ComponentDefinition.

See Also
ComponentDefinition Class
ComponentDefinition Members
Eco.Handles.Design Namespace


ComponentDefinition.ComponentDefinition Constructor (string, string)

ComponentDefinition.ComponentDefinition Constructor (string, string)
ComponentDefinition Class ComponentDefinition Members Eco.Handles.Design Namespace See Also
Collapse All
C#
public ComponentDefinition(
    string typeName,
    string assemblyName
);
Parameters
Parameters | Description
typeName | Fully qualified name of component to instantiate.
assemblyName | Assembly in which the component resides.
See Also
ComponentDefinition Class
ComponentDefinition Members
Eco.Handles.Design Namespace


ComponentDefinition Methods

ComponentDefinition Methods
Public Methods
Collapse All

The methods of the ComponentDefinition class are listed here.

Public Methods
Name | Description
AddPropertyDefinition | Adds a property that should be manipulated.
CreateComponent | Creates a component as specified and returns it.
CreateWebComponent | This is CreateWebComponent, a member of class ComponentDefinition.


ComponentDefinition.AddPropertyDefinition Method

ComponentDefinition.AddPropertyDefinition Method
ComponentDefinition Class ComponentDefinition Members Eco.Handles.Design Namespace See Also
Collapse All

Adds a property that should be manipulated.

C#
public void AddPropertyDefinition(
    PropertyDefinition property
);
See Also
ComponentDefinition Class
ComponentDefinition Members
Eco.Handles.Design Namespace


ComponentDefinition.CreateComponent Method

ComponentDefinition.CreateComponent Method
ComponentDefinition Class ComponentDefinition Members Eco.Handles.Design Namespace See Also
Collapse All

Creates a component as specified and returns it.

C#
public IComponent CreateComponent(
    IDesignerHost host
);
Remarks

If this instance is Singleton a preexisting instance is retuned. Otherwise A new instance is created by means of an Activator and the class/assembly info from the xml-file.

See Also
ComponentDefinition Class
ComponentDefinition Members
Eco.Handles.Design Namespace


ComponentDefinition.CreateWebComponent Method

ComponentDefinition.CreateWebComponent Method
ComponentDefinition Class ComponentDefinition Members Eco.Handles.Design Namespace See Also
Collapse All
C#
public IComponent CreateWebComponent(
    WebFormsRootDesigner designer
);
Remarks

This is CreateWebComponent, a member of class ComponentDefinition.

See Also
ComponentDefinition Class
ComponentDefinition Members
Eco.Handles.Design Namespace


ComponentDefinition Properties

ComponentDefinition Properties
Public Properties
Collapse All

The properties of the ComponentDefinition class are listed here.

Public Properties
Name | Description
Singleton | If true, a pre-existing component of the same type is reused.


ComponentDefinition.Singleton Property

ComponentDefinition.Singleton Property
ComponentDefinition Class ComponentDefinition Members Eco.Handles.Design Namespace See Also
Collapse All

If true, a pre-existing component of the same type is reused.

C#
public bool Singleton;
See Also
ComponentDefinition Class
ComponentDefinition Members
Eco.Handles.Design Namespace


ConnectionManipulator Class

ConnectionManipulator Class
ConnectionManipulator Members Inheritance Hierarchy See Also
Collapse All

Sets the property to the just created connection.

C#
internal sealed class ConnectionManipulator : AbstractManipulator;
Inheritance Hierarchy
Eco.Handles.Design.AbstractManipulator
    Eco.Handles.Design.ConnectionManipulator
File

PropertyManipulators.cs

See Also
ConnectionManipulator Members
Inheritance Hierarchy


ConnectionManipulator Members

ConnectionManipulator Members
Protected Methods Public Methods
Collapse All

The following tables list the members exposed by ConnectionManipulator.

Protected Methods
Name | Description
PreviousComponent | Returns the previously created component that matches filter.
Top
Public Methods
Name | Description
SetPropertyValue | Allows for setting the property value.


ConnectionManipulator Methods

ConnectionManipulator Methods
Public Methods
Collapse All

The methods of the ConnectionManipulator class are listed here.

Public Methods
Name | Description
SetPropertyValue | Allows for setting the property value.


ConnectionManipulator.SetPropertyValue Method

ConnectionManipulator.SetPropertyValue Method
ConnectionManipulator Class ConnectionManipulator Members Eco.Handles.Design Namespace See Also
Collapse All

Allows for setting the property value.

C#
public override void SetPropertyValue(
    PropertyParams propertyParams
);
See Also
ConnectionManipulator Class
ConnectionManipulator Members
Eco.Handles.Design Namespace


ContextAgentLogger Class

ContextAgentLogger Class
ContextAgentLogger Members Inheritance Hierarchy See Also
Collapse All

Focal point for logging of acttions.

C#
public abstract class ContextAgentLogger;
Inheritance Hierarchy
Eco.Handles.Design.ContextAgentLogger
File

ContextComponentDictionary.cs

See Also
ContextAgentLogger Members
Inheritance Hierarchy


ContextAgentLogger Members

ContextAgentLogger Members
Public Methods Public Properties
Collapse All

The following tables list the members exposed by ContextAgentLogger.

Public Methods
Name | Description
ComponentName | Helper method to get the name of a component.
LogAction | Prints the message to the message pane if LogActivity returns true.
Top
Public Properties
Name | Description
LogActivity | This is LogActivity, a member of class ContextAgentLogger.


ContextAgentLogger Methods

ContextAgentLogger Methods
Public Methods
Collapse All

The methods of the ContextAgentLogger class are listed here.

Public Methods
Name | Description
ComponentName | Helper method to get the name of a component.
LogAction | Prints the message to the message pane if LogActivity returns true.


ContextAgentLogger.ComponentName Method

ContextAgentLogger.ComponentName Method
ContextAgentLogger Class ContextAgentLogger Members Eco.Handles.Design Namespace See Also
Collapse All

Helper method to get the name of a component.

C#
public static string ComponentName(
    IComponent component
);
Returns

"null" if component is null, otherwise component.Site.Name.

See Also
ContextAgentLogger Class
ContextAgentLogger Members
Eco.Handles.Design Namespace


ContextAgentLogger.LogAction Method

ContextAgentLogger.LogAction Method
ContextAgentLogger Class ContextAgentLogger Members Eco.Handles.Design Namespace See Also
Collapse All

Prints the message to the message pane if LogActivity returns true.

C#
public static void LogAction(
    string message
);
See Also
ContextAgentLogger Class
ContextAgentLogger Members
Eco.Handles.Design Namespace


ContextAgentLogger Properties

ContextAgentLogger Properties
Public Properties
Collapse All

The properties of the ContextAgentLogger class are listed here.

Public Properties
Name | Description
LogActivity | This is LogActivity, a member of class ContextAgentLogger.


ContextAgentLogger.LogActivity Property

ContextAgentLogger.LogActivity Property
ContextAgentLogger Class ContextAgentLogger Members Eco.Handles.Design Namespace See Also
Collapse All
C#
public static bool LogActivity;
Remarks

This is LogActivity, a member of class ContextAgentLogger.

See Also
ContextAgentLogger Class
ContextAgentLogger Members
Eco.Handles.Design Namespace


ContextAgentToolboxItem Class

ContextAgentToolboxItem Class
ContextAgentToolboxItem Members Inheritance Hierarchy See Also
Collapse All

Class responsible for component creation on a designer.

C#
public class ContextAgentToolboxItem : ToolboxItem;
Inheritance Hierarchy
Eco.Handles.Design.ContextAgentToolboxItem
File

ContextComponentDictionary.cs

See Also
ContextAgentToolboxItem Members
Inheritance Hierarchy


ContextAgentToolboxItem Members

ContextAgentToolboxItem Members
Protected Methods Public Methods
Collapse All

The following tables list the members exposed by ContextAgentToolboxItem.

Protected Methods
Name | Description
CreateComponentsCore | This is the overview for the CreateComponentsCore method overload.
Top
Public Methods
Name | Description
ContextAgentToolboxItem | This is the overview for the ContextAgentToolboxItem constructor overload.


ContextAgentToolboxItem Constructor

ContextAgentToolboxItem Constructor

This is the overview for the ContextAgentToolboxItem constructor overload.

Overload List
Name | Description
ContextAgentToolboxItem.ContextAgentToolboxItem (List<ComponentDefinition>, IComponent, string, string, CreateMode) | This is ContextAgentToolboxItem, a member of class ContextAgentToolboxItem.
ContextAgentToolboxItem.ContextAgentToolboxItem (SerializationInfo, StreamingContext) | This is ContextAgentToolboxItem, a member of class ContextAgentToolboxItem.


ContextAgentToolboxItem.ContextAgentToolboxItem Constructor (List<ComponentDefinition>, IComponent, string, string, CreateMode)

ContextAgentToolboxItem.ContextAgentToolboxItem Constructor (List<ComponentDefinition>, IComponent, string, string, CreateMode)
ContextAgentToolboxItem Class ContextAgentToolboxItem Members Eco.Handles.Design Namespace See Also
Collapse All
C#
public ContextAgentToolboxItem(
    List<ComponentDefinition> components,
    IComponent invokingComponent,
    string name,
    string displayName,
    CreateMode createMode
);
Remarks

This is ContextAgentToolboxItem, a member of class ContextAgentToolboxItem.

See Also
ContextAgentToolboxItem Class
ContextAgentToolboxItem Members
Eco.Handles.Design Namespace


ContextAgentToolboxItem.ContextAgentToolboxItem Constructor (SerializationInfo, StreamingContext)

ContextAgentToolboxItem.ContextAgentToolboxItem Constructor (SerializationInfo, StreamingContext)
ContextAgentToolboxItem Class ContextAgentToolboxItem Members Eco.Handles.Design Namespace See Also
Collapse All
C#
protected ContextAgentToolboxItem(
    SerializationInfo info,
    StreamingContext context
);
Remarks

This is ContextAgentToolboxItem, a member of class ContextAgentToolboxItem.

See Also
ContextAgentToolboxItem Class
ContextAgentToolboxItem Members
Eco.Handles.Design Namespace


ContextAgentToolboxItem Methods

ContextAgentToolboxItem Methods
Protected Methods
Collapse All

The methods of the ContextAgentToolboxItem class are listed here.

Protected Methods
Name | Description
CreateComponentsCore | This is the overview for the CreateComponentsCore method overload.


CreateComponentsCore Method

CreateComponentsCore Method

This is the overview for the CreateComponentsCore method overload.

Overload List
Name | Description
ContextAgentToolboxItem.CreateComponentsCore (IDesignerHost) | Creates the specified components.
ContextAgentToolboxItem.CreateComponentsCore (IDesignerHost, IDictionary) | Creates the specified components and sets their properties using their PropertyDefinitions.


ContextAgentToolboxItem.CreateComponentsCore Method (IDesignerHost)

ContextAgentToolboxItem.CreateComponentsCore Method (IDesignerHost)
ContextAgentToolboxItem Class ContextAgentToolboxItem Members Eco.Handles.Design Namespace See Also
Collapse All

Creates the specified components.

C#
protected override IComponent[] CreateComponentsCore(
    IDesignerHost host
);
See Also
ContextAgentToolboxItem Class
ContextAgentToolboxItem Members
Eco.Handles.Design Namespace


ContextAgentToolboxItem.CreateComponentsCore Method (IDesignerHost, IDictionary)

ContextAgentToolboxItem.CreateComponentsCore Method (IDesignerHost, IDictionary)
ContextAgentToolboxItem Class ContextAgentToolboxItem Members Eco.Handles.Design Namespace See Also
Collapse All

Creates the specified components and sets their properties using their PropertyDefinitions.

C#
protected override IComponent[] CreateComponentsCore(
    IDesignerHost host,
    IDictionary defaultValues
);
See Also
ContextAgentToolboxItem Class
ContextAgentToolboxItem Members
Eco.Handles.Design Namespace


ContextAgentTreeNode Class

ContextAgentTreeNode Class
ContextAgentTreeNode Members Inheritance Hierarchy See Also
Collapse All
C#
public class ContextAgentTreeNode : TreeNode, IComparable;
Remarks

This is class Eco.Handles.Design.ContextAgentTreeNode.

Inheritance Hierarchy
System.Windows.Forms.TreeNode
    Eco.Handles.Design.ContextAgentTreeNode
        Eco.Handles.Design.CreatorContextNode
File

Eco.Handles.Design.ContextComponentsForm.cs

See Also
ContextAgentTreeNode Members
Inheritance Hierarchy


ContextAgentTreeNode Members

ContextAgentTreeNode Members
Protected Methods Public Methods Public Properties
Collapse All

The following tables list the members exposed by ContextAgentTreeNode.

Protected Methods
Name | Description
Bitmap | This is Bitmap, a member of class ContextAgentTreeNode.
BitmapKey | This is BitmapKey, a member of class ContextAgentTreeNode.
Top
Public Methods
Name | Description
CanDragInvoke | This is CanDragInvoke, a member of class ContextAgentTreeNode.
CanInvoke | This is CanInvoke, a member of class ContextAgentTreeNode.
CompareTo | This is CompareTo, a member of class ContextAgentTreeNode.
DragInvoke | This is DragInvoke, a member of class ContextAgentTreeNode.
FixupImages | This is FixupImages, a member of class ContextAgentTreeNode.
Invoke | This is Invoke, a member of class ContextAgentTreeNode.
Top
Public Properties
Name | Description
Description | This is Description, a member of class ContextAgentTreeNode.
DesignerData | This is DesignerData, a member of class ContextAgentTreeNode.
SortOrder | This is SortOrder, a member of class ContextAgentTreeNode.
ToolTip | This is ToolTip, a member of class ContextAgentTreeNode.


ContextAgentTreeNode Methods

ContextAgentTreeNode Methods
Protected Methods Public Methods
Collapse All

The methods of the ContextAgentTreeNode class are listed here.

Protected Methods
Name | Description
Bitmap | This is Bitmap, a member of class ContextAgentTreeNode.
BitmapKey | This is BitmapKey, a member of class ContextAgentTreeNode.
Top
Public Methods
Name | Description
CanDragInvoke | This is CanDragInvoke, a member of class ContextAgentTreeNode.
CanInvoke | This is CanInvoke, a member of class ContextAgentTreeNode.
CompareTo | This is CompareTo, a member of class ContextAgentTreeNode.
DragInvoke | This is DragInvoke, a member of class ContextAgentTreeNode.
FixupImages | This is FixupImages, a member of class ContextAgentTreeNode.
Invoke | This is Invoke, a member of class ContextAgentTreeNode.


ContextAgentTreeNode.Bitmap Method

ContextAgentTreeNode.Bitmap Method
ContextAgentTreeNode Class ContextAgentTreeNode Members Eco.Handles.Design Namespace See Also
Collapse All
C#
protected virtual Bitmap Bitmap();
Remarks

This is Bitmap, a member of class ContextAgentTreeNode.

See Also
ContextAgentTreeNode Class
ContextAgentTreeNode Members
Eco.Handles.Design Namespace


ContextAgentTreeNode.BitmapKey Method

ContextAgentTreeNode.BitmapKey Method
ContextAgentTreeNode Class ContextAgentTreeNode Members Eco.Handles.Design Namespace See Also
Collapse All
C#
protected virtual string BitmapKey();
Remarks

This is BitmapKey, a member of class ContextAgentTreeNode.

See Also
ContextAgentTreeNode Class
ContextAgentTreeNode Members
Eco.Handles.Design Namespace


ContextAgentTreeNode.CanDragInvoke Method

ContextAgentTreeNode.CanDragInvoke Method
ContextAgentTreeNode Class ContextAgentTreeNode Members Eco.Handles.Design Namespace See Also
Collapse All
C#
public virtual bool CanDragInvoke();
Remarks

This is CanDragInvoke, a member of class ContextAgentTreeNode.

See Also
ContextAgentTreeNode Class
ContextAgentTreeNode Members
Eco.Handles.Design Namespace


ContextAgentTreeNode.CanInvoke Method

ContextAgentTreeNode.CanInvoke Method
ContextAgentTreeNode Class ContextAgentTreeNode Members Eco.Handles.Design Namespace See Also
Collapse All
C#
public virtual bool CanInvoke();
Remarks

This is CanInvoke, a member of class ContextAgentTreeNode.

See Also
ContextAgentTreeNode Class
ContextAgentTreeNode Members
Eco.Handles.Design Namespace


ContextAgentTreeNode.CompareTo Method

ContextAgentTreeNode.CompareTo Method
ContextAgentTreeNode Class ContextAgentTreeNode Members Eco.Handles.Design Namespace See Also
Collapse All
C#
public int CompareTo(
    Object obj
);
Remarks

This is CompareTo, a member of class ContextAgentTreeNode.

See Also
ContextAgentTreeNode Class
ContextAgentTreeNode Members
Eco.Handles.Design Namespace


ContextAgentTreeNode.DragInvoke Method

ContextAgentTreeNode.DragInvoke Method
ContextAgentTreeNode Class ContextAgentTreeNode Members Eco.Handles.Design Namespace See Also
Collapse All
C#
public virtual void DragInvoke();
Remarks

This is DragInvoke, a member of class ContextAgentTreeNode.

See Also
ContextAgentTreeNode Class
ContextAgentTreeNode Members
Eco.Handles.Design Namespace


ContextAgentTreeNode.FixupImages Method

ContextAgentTreeNode.FixupImages Method
ContextAgentTreeNode Class ContextAgentTreeNode Members Eco.Handles.Design Namespace See Also
Collapse All
C#
public void FixupImages();
Remarks

This is FixupImages, a member of class ContextAgentTreeNode.

See Also
ContextAgentTreeNode Class
ContextAgentTreeNode Members
Eco.Handles.Design Namespace


ContextAgentTreeNode.Invoke Method

ContextAgentTreeNode.Invoke Method
ContextAgentTreeNode Class ContextAgentTreeNode Members Eco.Handles.Design Namespace See Also
Collapse All
C#
public virtual void Invoke();
Remarks

This is Invoke, a member of class ContextAgentTreeNode.

See Also
ContextAgentTreeNode Class
ContextAgentTreeNode Members
Eco.Handles.Design Namespace


ContextAgentTreeNode Properties

ContextAgentTreeNode Properties
Public Properties
Collapse All

The properties of the ContextAgentTreeNode class are listed here.

Public Properties
Name | Description
Description | This is Description, a member of class ContextAgentTreeNode.
DesignerData | This is DesignerData, a member of class ContextAgentTreeNode.
SortOrder | This is SortOrder, a member of class ContextAgentTreeNode.
ToolTip | This is ToolTip, a member of class ContextAgentTreeNode.


ContextAgentTreeNode.Description Property

ContextAgentTreeNode.Description Property
ContextAgentTreeNode Class ContextAgentTreeNode Members Eco.Handles.Design Namespace See Also
Collapse All
C#
public virtual string Description;
Remarks

This is Description, a member of class ContextAgentTreeNode.

See Also
ContextAgentTreeNode Class
ContextAgentTreeNode Members
Eco.Handles.Design Namespace


ContextAgentTreeNode.DesignerData Property

ContextAgentTreeNode.DesignerData Property
ContextAgentTreeNode Class ContextAgentTreeNode Members Eco.Handles.Design Namespace See Also
Collapse All
C#
public DesignerData DesignerData;
Remarks

This is DesignerData, a member of class ContextAgentTreeNode.

See Also
ContextAgentTreeNode Class
ContextAgentTreeNode Members
Eco.Handles.Design Namespace


ContextAgentTreeNode.SortOrder Property

ContextAgentTreeNode.SortOrder Property
ContextAgentTreeNode Class ContextAgentTreeNode Members Eco.Handles.Design Namespace See Also
Collapse All
C#
public int SortOrder;
Remarks

This is SortOrder, a member of class ContextAgentTreeNode.

See Also
ContextAgentTreeNode Class
ContextAgentTreeNode Members
Eco.Handles.Design Namespace


ContextAgentTreeNode.ToolTip Property

ContextAgentTreeNode.ToolTip Property
ContextAgentTreeNode Class ContextAgentTreeNode Members Eco.Handles.Design Namespace See Also
Collapse All
C#
public virtual string ToolTip;
Remarks

This is ToolTip, a member of class ContextAgentTreeNode.

See Also
ContextAgentTreeNode Class
ContextAgentTreeNode Members
Eco.Handles.Design Namespace


ContextAgentWebToolboxItem Class

ContextAgentWebToolboxItem Class
ContextAgentWebToolboxItem Members Inheritance Hierarchy See Also
Collapse All
C#
public class ContextAgentWebToolboxItem : System.Web.UI.Design.WebControlToolboxItem;
Remarks

This is class Eco.Handles.Design.ContextAgentWebToolboxItem.

Inheritance Hierarchy
Eco.Handles.Design.ContextAgentWebToolboxItem
File

ContextComponentDictionary.cs

See Also
ContextAgentWebToolboxItem Members
Inheritance Hierarchy


ContextAgentWebToolboxItem Members

ContextAgentWebToolboxItem Members
Protected Methods Public Methods
Collapse All

The following tables list the members exposed by ContextAgentWebToolboxItem.

Protected Methods
Name | Description
CreateComponentsCore | This is the overview for the CreateComponentsCore method overload.
GetType | This is GetType, a member of class ContextAgentWebToolboxItem.
Top
Public Methods
Name | Description
ContextAgentWebToolboxItem | This is the overview for the ContextAgentWebToolboxItem constructor overload.
CreateWebComponents | This is CreateWebComponents, a member of class ContextAgentWebToolboxItem.
Initialize | This is Initialize, a member of class ContextAgentWebToolboxItem.


ContextAgentWebToolboxItem Constructor

ContextAgentWebToolboxItem Constructor

This is the overview for the ContextAgentWebToolboxItem constructor overload.

Overload List
Name | Description
ContextAgentWebToolboxItem.ContextAgentWebToolboxItem (List<ComponentDefinition>, IComponent, string, string, CreateMode) | This is ContextAgentWebToolboxItem, a member of class ContextAgentWebToolboxItem.
ContextAgentWebToolboxItem.ContextAgentWebToolboxItem (SerializationInfo, StreamingContext) | This is ContextAgentWebToolboxItem, a member of class ContextAgentWebToolboxItem.


ContextAgentWebToolboxItem.ContextAgentWebToolboxItem Constructor (List<ComponentDefinition>, IComponent, string, string, CreateMode)

ContextAgentWebToolboxItem.ContextAgentWebToolboxItem Constructor (List<ComponentDefinition>, IComponent, string, string, CreateMode)
ContextAgentWebToolboxItem Class ContextAgentWebToolboxItem Members Eco.Handles.Design Namespace See Also
Collapse All
C#
public ContextAgentWebToolboxItem(
    List<ComponentDefinition> components,
    IComponent invokingComponent,
    string name,
    string displayName,
    CreateMode createMode
);
Remarks

This is ContextAgentWebToolboxItem, a member of class ContextAgentWebToolboxItem.

See Also
ContextAgentWebToolboxItem Class
ContextAgentWebToolboxItem Members
Eco.Handles.Design Namespace


ContextAgentWebToolboxItem.ContextAgentWebToolboxItem Constructor (SerializationInfo, StreamingContext)

ContextAgentWebToolboxItem.ContextAgentWebToolboxItem Constructor (SerializationInfo, StreamingContext)
ContextAgentWebToolboxItem Class ContextAgentWebToolboxItem Members Eco.Handles.Design Namespace See Also
Collapse All
C#
protected ContextAgentWebToolboxItem(
    SerializationInfo info,
    StreamingContext context
);
Remarks

This is ContextAgentWebToolboxItem, a member of class ContextAgentWebToolboxItem.

See Also
ContextAgentWebToolboxItem Class
ContextAgentWebToolboxItem Members
Eco.Handles.Design Namespace


ContextAgentWebToolboxItem Methods

ContextAgentWebToolboxItem Methods
Protected Methods Public Methods
Collapse All

The methods of the ContextAgentWebToolboxItem class are listed here.

Protected Methods
Name | Description
CreateComponentsCore | This is the overview for the CreateComponentsCore method overload.
GetType | This is GetType, a member of class ContextAgentWebToolboxItem.
Top
Public Methods
Name | Description
CreateWebComponents | This is CreateWebComponents, a member of class ContextAgentWebToolboxItem.
Initialize | This is Initialize, a member of class ContextAgentWebToolboxItem.


CreateComponentsCore Method

CreateComponentsCore Method

This is the overview for the CreateComponentsCore method overload.

Overload List
Name | Description
ContextAgentWebToolboxItem.CreateComponentsCore (IDesignerHost) | Creates the specified components.
ContextAgentWebToolboxItem.CreateComponentsCore (IDesignerHost, IDictionary) | Creates the specified components and sets their properties using their PropertyDefinitions.


ContextAgentWebToolboxItem.CreateComponentsCore Method (IDesignerHost)

ContextAgentWebToolboxItem.CreateComponentsCore Method (IDesignerHost)
ContextAgentWebToolboxItem Class ContextAgentWebToolboxItem Members Eco.Handles.Design Namespace See Also
Collapse All

Creates the specified components.

C#
protected override IComponent[] CreateComponentsCore(
    IDesignerHost host
);
See Also
ContextAgentWebToolboxItem Class
ContextAgentWebToolboxItem Members
Eco.Handles.Design Namespace


ContextAgentWebToolboxItem.CreateComponentsCore Method (IDesignerHost, IDictionary)

ContextAgentWebToolboxItem.CreateComponentsCore Method (IDesignerHost, IDictionary)
ContextAgentWebToolboxItem Class ContextAgentWebToolboxItem Members Eco.Handles.Design Namespace See Also
Collapse All

Creates the specified components and sets their properties using their PropertyDefinitions.

C#
protected override IComponent[] CreateComponentsCore(
    IDesignerHost host,
    IDictionary defaultValues
);
See Also
ContextAgentWebToolboxItem Class
ContextAgentWebToolboxItem Members
Eco.Handles.Design Namespace


ContextAgentWebToolboxItem.CreateWebComponents Method

ContextAgentWebToolboxItem.CreateWebComponents Method
ContextAgentWebToolboxItem Class ContextAgentWebToolboxItem Members Eco.Handles.Design Namespace See Also
Collapse All
C#
public void CreateWebComponents(
    WebFormsRootDesigner designer,
    IDesignerHost host,
    IDictionary defaultValues
);
Remarks

This is CreateWebComponents, a member of class ContextAgentWebToolboxItem.

See Also
ContextAgentWebToolboxItem Class
ContextAgentWebToolboxItem Members
Eco.Handles.Design Namespace


ContextAgentWebToolboxItem.GetType Method

ContextAgentWebToolboxItem.GetType Method
ContextAgentWebToolboxItem Class ContextAgentWebToolboxItem Members Eco.Handles.Design Namespace See Also
Collapse All
C#
protected override Type GetType(
    IDesignerHost host,
    System.Reflection.AssemblyName assemblyName,
    string typeName,
    bool reference
);
Remarks

This is GetType, a member of class ContextAgentWebToolboxItem.

See Also
ContextAgentWebToolboxItem Class
ContextAgentWebToolboxItem Members
Eco.Handles.Design Namespace


ContextAgentWebToolboxItem.Initialize Method

ContextAgentWebToolboxItem.Initialize Method
ContextAgentWebToolboxItem Class ContextAgentWebToolboxItem Members Eco.Handles.Design Namespace See Also
Collapse All
C#
public override void Initialize(
    Type type
);
Remarks

This is Initialize, a member of class ContextAgentWebToolboxItem.

See Also
ContextAgentWebToolboxItem Class
ContextAgentWebToolboxItem Members
Eco.Handles.Design Namespace


ContextComponentReader Class

ContextComponentReader Class
ContextComponentReader Members Inheritance Hierarchy See Also
Collapse All
C#
public sealed class ContextComponentReader;
Remarks

This is class Eco.Handles.Design.ContextComponentReader.

Inheritance Hierarchy
Eco.Handles.Design.ContextComponentReader
File

ContextComponentXmlReader.cs

See Also
ContextComponentReader Members
Inheritance Hierarchy


ContextComponentReader Members

ContextComponentReader Members
Public Methods
Collapse All

The following tables list the members exposed by ContextComponentReader.

Public Methods
Name | Description
ReadFromFile | This is ReadFromFile, a member of class ContextComponentReader.


ContextComponentReader Methods

ContextComponentReader Methods
Public Methods
Collapse All

The methods of the ContextComponentReader class are listed here.

Public Methods
Name | Description
ReadFromFile | This is ReadFromFile, a member of class ContextComponentReader.


ContextComponentReader.ReadFromFile Method

ContextComponentReader.ReadFromFile Method
ContextComponentReader Class ContextComponentReader Members Eco.Handles.Design Namespace See Also
Collapse All
C#
public static void ReadFromFile(
    string fileName,
    CreatorGroup creatorGroup,
    string topnodeName
);
Remarks

This is ReadFromFile, a member of class ContextComponentReader.

See Also
ContextComponentReader Class
ContextComponentReader Members
Eco.Handles.Design Namespace


ContextComponentsForm Class

ContextComponentsForm Class
ContextComponentsForm Members Inheritance Hierarchy See Also
Collapse All
C#
public class ContextComponentsForm : System.Windows.Forms.Form;
Remarks

This is class Eco.Handles.Design.ContextComponentsForm.

Inheritance Hierarchy
System.Windows.Forms.Form
    Eco.Handles.Design.ContextComponentsForm
File

Eco.Handles.Design.ContextComponentsForm.cs

See Also
ContextComponentsForm Members
Inheritance Hierarchy


ContextComponentsForm Members

ContextComponentsForm Members
Protected Methods Public Methods
Collapse All

The following tables list the members exposed by ContextComponentsForm.

Protected Methods
Name | Description
Dispose | This is Dispose, a member of class ContextComponentsForm.
Top
Public Methods
Name | Description
AddRootNodes | This is AddRootNodes, a member of class ContextComponentsForm.
ClearInfo | This is ClearInfo, a member of class ContextComponentsForm.
ContextComponentsForm | This is ContextComponentsForm, a member of class ContextComponentsForm.
GetRootComponent | This is GetRootComponent, a member of class ContextComponentsForm.


ContextComponentsForm.ContextComponentsForm Constructor

ContextComponentsForm.ContextComponentsForm Constructor
ContextComponentsForm Class ContextComponentsForm Members Eco.Handles.Design Namespace See Also
Collapse All
C#
public ContextComponentsForm();
Remarks

This is ContextComponentsForm, a member of class ContextComponentsForm.

See Also
ContextComponentsForm Class
ContextComponentsForm Members
Eco.Handles.Design Namespace


ContextComponentsForm Methods

ContextComponentsForm Methods
Protected Methods Public Methods
Collapse All

The methods of the ContextComponentsForm class are listed here.

Protected Methods
Name | Description
Dispose | This is Dispose, a member of class ContextComponentsForm.
Top
Public Methods
Name | Description
AddRootNodes | This is AddRootNodes, a member of class ContextComponentsForm.
ClearInfo | This is ClearInfo, a member of class ContextComponentsForm.
GetRootComponent | This is GetRootComponent, a member of class ContextComponentsForm.


ContextComponentsForm.AddRootNodes Method

ContextComponentsForm.AddRootNodes Method
ContextComponentsForm Class ContextComponentsForm Members Eco.Handles.Design Namespace See Also
Collapse All
C#
public void AddRootNodes(
    Context context,
    ContextAgentTreeNode rootNode
);
Remarks

This is AddRootNodes, a member of class ContextComponentsForm.

See Also
ContextComponentsForm Class
ContextComponentsForm Members
Eco.Handles.Design Namespace


ContextComponentsForm.ClearInfo Method

ContextComponentsForm.ClearInfo Method
ContextComponentsForm Class ContextComponentsForm Members Eco.Handles.Design Namespace See Also
Collapse All
C#
public void ClearInfo(
    Context context,
    Type nodeType
);
Remarks

This is ClearInfo, a member of class ContextComponentsForm.

See Also
ContextComponentsForm Class
ContextComponentsForm Members
Eco.Handles.Design Namespace


ContextComponentsForm.Dispose Method

ContextComponentsForm.Dispose Method
ContextComponentsForm Class ContextComponentsForm Members Eco.Handles.Design Namespace See Also
Collapse All
C#
protected override void Dispose(
    bool disposing
);
Remarks

This is Dispose, a member of class ContextComponentsForm.

See Also
ContextComponentsForm Class
ContextComponentsForm Members
Eco.Handles.Design Namespace


ContextComponentsForm.GetRootComponent Method

ContextComponentsForm.GetRootComponent Method
ContextComponentsForm Class ContextComponentsForm Members Eco.Handles.Design Namespace See Also
Collapse All
C#
public Control GetRootComponent();
Remarks

This is GetRootComponent, a member of class ContextComponentsForm.

See Also
ContextComponentsForm Class
ContextComponentsForm Members
Eco.Handles.Design Namespace


ContextController Class

ContextController Class
ContextController Members Inheritance Hierarchy See Also
Collapse All
C#
public sealed class ContextController : IDisposable;
Remarks

This is class Eco.Handles.Design.ContextController.

Inheritance Hierarchy
Eco.Handles.Design.ContextController
File

WidgetSelector.cs

See Also
ContextController Members
Inheritance Hierarchy


ContextController Members

ContextController Members
Public Methods Public Properties Public Events
Collapse All

The following tables list the members exposed by ContextController.

Public Methods
Name | Description
Dispose | This is Dispose, a member of class ContextController.
GetRootControl | This is GetRootControl, a member of class ContextController.
Initialize | Sets up the IDE event receivers.
Refresh | This is Refresh, a member of class ContextController.
ShowForm | This is ShowForm, a member of class ContextController.
Top
Public Properties
Name | Description
Enabled | If not Enabled, the ContextEvent will not trigger.
Instance | singleton instance of this class.
Top
Public Events
Name | Description
ContextEvent | Event triggered on idle after any of the relevant IDE events have triggered.


ContextController Methods

ContextController Methods
Public Methods
Collapse All

The methods of the ContextController class are listed here.

Public Methods
Name | Description
Dispose | This is Dispose, a member of class ContextController.
GetRootControl | This is GetRootControl, a member of class ContextController.
Initialize | Sets up the IDE event receivers.
Refresh | This is Refresh, a member of class ContextController.
ShowForm | This is ShowForm, a member of class ContextController.


ContextController.Dispose Method

ContextController.Dispose Method
ContextController Class ContextController Members Eco.Handles.Design Namespace See Also
Collapse All
C#
public void Dispose();
Remarks

This is Dispose, a member of class ContextController.

See Also
ContextController Class
ContextController Members
Eco.Handles.Design Namespace


ContextController.GetRootControl Method

ContextController.GetRootControl Method
ContextController Class ContextController Members Eco.Handles.Design Namespace See Also
Collapse All
C#
public Control GetRootControl();
Remarks

This is GetRootControl, a member of class ContextController.

See Also
ContextController Class
ContextController Members
Eco.Handles.Design Namespace


ContextController.Initialize Method

ContextController.Initialize Method
ContextController Class ContextController Members Eco.Handles.Design Namespace See Also
Collapse All

Sets up the IDE event receivers.

C#
public void Initialize(
    IDesignerEventService designerEventService
);
Remarks

All events will be dispatched via the ContextEvent event handler.

See Also
ContextController Class
ContextController Members
Eco.Handles.Design Namespace


ContextController.Refresh Method

ContextController.Refresh Method
ContextController Class ContextController Members Eco.Handles.Design Namespace See Also
Collapse All
C#
public void Refresh();
Remarks

This is Refresh, a member of class ContextController.

See Also
ContextController Class
ContextController Members
Eco.Handles.Design Namespace


ContextController.ShowForm Method

ContextController.ShowForm Method
ContextController Class ContextController Members Eco.Handles.Design Namespace See Also
Collapse All
C#
public void ShowForm();
Remarks

This is ShowForm, a member of class ContextController.

See Also
ContextController Class
ContextController Members
Eco.Handles.Design Namespace


ContextController Properties

ContextController Properties
Public Properties
Collapse All

The properties of the ContextController class are listed here.

Public Properties
Name | Description
Enabled | If not Enabled, the ContextEvent will not trigger.
Instance | singleton instance of this class.


ContextController.Enabled Property

ContextController.Enabled Property
ContextController Class ContextController Members Eco.Handles.Design Namespace See Also
Collapse All

If not Enabled, the ContextEvent will not trigger.

C#
public bool Enabled;
See Also
ContextController Class
ContextController Members
Eco.Handles.Design Namespace


ContextController.Instance Property

ContextController.Instance Property
ContextController Class ContextController Members Eco.Handles.Design Namespace See Also
Collapse All

singleton instance of this class.

C#
public static ContextController Instance;
See Also
ContextController Class
ContextController Members
Eco.Handles.Design Namespace


ContextController Events

ContextController Events
Public Events
Collapse All

The events of the ContextController class are listed here.

Public Events
Name | Description
ContextEvent | Event triggered on idle after any of the relevant IDE events have triggered.


ContextController.ContextEvent Event

ContextController.ContextEvent Event
ContextController Class ContextController Members Eco.Handles.Design Namespace See Also
Collapse All

Event triggered on idle after any of the relevant IDE events have triggered.

C#
public event ChangeEventHandler ContextEvent;
Remarks

The event will be sent only once on application idle. The EventArgs has a flag DispatchedEvents that contains a list of all the events that have happened. It is up to the receiver to filter on those. The various events are expressed as a bitmasked enum of the type DispatchEvent.

See Also
ContextController Class
ContextController Members
Eco.Handles.Design Namespace


CreatorContextNode Class

CreatorContextNode Class
CreatorContextNode Members Inheritance Hierarchy See Also
Collapse All
C#
public class CreatorContextNode : ContextAgentTreeNode;
Remarks

This is class Eco.Handles.Design.CreatorContextNode.

Inheritance Hierarchy
System.Windows.Forms.TreeNode
    Eco.Handles.Design.ContextAgentTreeNode
        Eco.Handles.Design.CreatorContextNode
File

ContextCreatorManager.cs

See Also
CreatorContextNode Members
Inheritance Hierarchy


CreatorContextNode Members

CreatorContextNode Members
Protected Methods Public Methods Public Properties Protected Properties
Collapse All

The following tables list the members exposed by CreatorContextNode.

Protected Methods
Name | Description
Bitmap | This is Bitmap, a member of class CreatorContextNode.
BitmapKey | This is BitmapKey, a member of class CreatorContextNode.
Top
Public Methods
Name | Description
CanDragInvoke | This is CanDragInvoke, a member of class CreatorContextNode.
CanInvoke | This is CanInvoke, a member of class CreatorContextNode.
CompareTo | This is CompareTo, a member of class ContextAgentTreeNode.
CreatorContextNode | This is CreatorContextNode, a member of class CreatorContextNode.
DragInvoke | This is DragInvoke, a member of class CreatorContextNode.
FixupImages | This is FixupImages, a member of class ContextAgentTreeNode.
Invoke | This is Invoke, a member of class CreatorContextNode.
Top
Public Properties
Name | Description
Description | This is Description, a member of class CreatorContextNode.
DesignerData | This is DesignerData, a member of class ContextAgentTreeNode.
SortOrder | This is SortOrder, a member of class ContextAgentTreeNode.
ToolTip | This is ToolTip, a member of class CreatorContextNode.
Top
Protected Properties
Name | Description
CreatorInfo | This is CreatorInfo, a member of class CreatorContextNode.
Descriptor | This is Descriptor, a member of class CreatorContextNode.


CreatorContextNode.CreatorContextNode Constructor

CreatorContextNode.CreatorContextNode Constructor
CreatorContextNode Class CreatorContextNode Members Eco.Handles.Design Namespace See Also
Collapse All
C#
public CreatorContextNode(
    CreatorInfo node,
    CreatorNodeDescriptor descriptor
);
Remarks

This is CreatorContextNode, a member of class CreatorContextNode.

See Also
CreatorContextNode Class
CreatorContextNode Members
Eco.Handles.Design Namespace


CreatorContextNode Methods

CreatorContextNode Methods
Protected Methods Public Methods
Collapse All

The methods of the CreatorContextNode class are listed here.

Protected Methods
Name | Description
Bitmap | This is Bitmap, a member of class CreatorContextNode.
BitmapKey | This is BitmapKey, a member of class CreatorContextNode.
Top
Public Methods
Name | Description
CanDragInvoke | This is CanDragInvoke, a member of class CreatorContextNode.
CanInvoke | This is CanInvoke, a member of class CreatorContextNode.
DragInvoke | This is DragInvoke, a member of class CreatorContextNode.
Invoke | This is Invoke, a member of class CreatorContextNode.


CreatorContextNode.Bitmap Method

CreatorContextNode.Bitmap Method
CreatorContextNode Class CreatorContextNode Members Eco.Handles.Design Namespace See Also
Collapse All
C#
protected override Bitmap Bitmap();
Remarks

This is Bitmap, a member of class CreatorContextNode.

See Also
CreatorContextNode Class
CreatorContextNode Members
Eco.Handles.Design Namespace


CreatorContextNode.BitmapKey Method

CreatorContextNode.BitmapKey Method
CreatorContextNode Class CreatorContextNode Members Eco.Handles.Design Namespace See Also
Collapse All
C#
protected override string BitmapKey();
Remarks

This is BitmapKey, a member of class CreatorContextNode.

See Also
CreatorContextNode Class
CreatorContextNode Members
Eco.Handles.Design Namespace


CreatorContextNode.CanDragInvoke Method

CreatorContextNode.CanDragInvoke Method
CreatorContextNode Class CreatorContextNode Members Eco.Handles.Design Namespace See Also
Collapse All
C#
public override bool CanDragInvoke();
Remarks

This is CanDragInvoke, a member of class CreatorContextNode.

See Also
CreatorContextNode Class
CreatorContextNode Members
Eco.Handles.Design Namespace


CreatorContextNode.CanInvoke Method

CreatorContextNode.CanInvoke Method
CreatorContextNode Class CreatorContextNode Members Eco.Handles.Design Namespace See Also
Collapse All
C#
public override bool CanInvoke();
Remarks

This is CanInvoke, a member of class CreatorContextNode.

See Also
CreatorContextNode Class
CreatorContextNode Members
Eco.Handles.Design Namespace


CreatorContextNode.DragInvoke Method

CreatorContextNode.DragInvoke Method
CreatorContextNode Class CreatorContextNode Members Eco.Handles.Design Namespace See Also
Collapse All
C#
public override void DragInvoke();
Remarks

This is DragInvoke, a member of class CreatorContextNode.

See Also
CreatorContextNode Class
CreatorContextNode Members
Eco.Handles.Design Namespace


CreatorContextNode.Invoke Method

CreatorContextNode.Invoke Method
CreatorContextNode Class CreatorContextNode Members Eco.Handles.Design Namespace See Also
Collapse All
C#
public override void Invoke();
Remarks

This is Invoke, a member of class CreatorContextNode.

See Also
CreatorContextNode Class
CreatorContextNode Members
Eco.Handles.Design Namespace


CreatorContextNode Properties

CreatorContextNode Properties
Public Properties Protected Properties
Collapse All

The properties of the CreatorContextNode class are listed here.

Public Properties
Name | Description
Description | This is Description, a member of class CreatorContextNode.
ToolTip | This is ToolTip, a member of class CreatorContextNode.
Top
Protected Properties
Name | Description
CreatorInfo | This is CreatorInfo, a member of class CreatorContextNode.
Descriptor | This is Descriptor, a member of class CreatorContextNode.


CreatorContextNode.CreatorInfo Property

CreatorContextNode.CreatorInfo Property
CreatorContextNode Class CreatorContextNode Members Eco.Handles.Design Namespace See Also
Collapse All
C#
protected CreatorInfo CreatorInfo;
Remarks

This is CreatorInfo, a member of class CreatorContextNode.

See Also
CreatorContextNode Class
CreatorContextNode Members
Eco.Handles.Design Namespace


CreatorContextNode.Description Property

CreatorContextNode.Description Property
CreatorContextNode Class CreatorContextNode Members Eco.Handles.Design Namespace See Also
Collapse All
C#
public override string Description;
Remarks

This is Description, a member of class CreatorContextNode.

See Also
CreatorContextNode Class
CreatorContextNode Members
Eco.Handles.Design Namespace


CreatorContextNode.Descriptor Property

CreatorContextNode.Descriptor Property
CreatorContextNode Class CreatorContextNode Members Eco.Handles.Design Namespace See Also
Collapse All
C#
protected CreatorNodeDescriptor Descriptor;
Remarks

This is Descriptor, a member of class CreatorContextNode.

See Also
CreatorContextNode Class
CreatorContextNode Members
Eco.Handles.Design Namespace


CreatorContextNode.ToolTip Property

CreatorContextNode.ToolTip Property
CreatorContextNode Class CreatorContextNode Members Eco.Handles.Design Namespace See Also
Collapse All
C#
public override string ToolTip;
Remarks

This is ToolTip, a member of class CreatorContextNode.

See Also
CreatorContextNode Class
CreatorContextNode Members
Eco.Handles.Design Namespace


CreatorGroup Class

CreatorGroup Class
CreatorGroup Members Inheritance Hierarchy See Also
Collapse All

This class represents a top level grouping of context sets.

C#
public class CreatorGroup : CreatorInfo;
Inheritance Hierarchy
Eco.Handles.Design.CreatorInfo
    Eco.Handles.Design.CreatorGroup
File

ContextComponentDictionary.cs

See Also
CreatorGroup Members
Inheritance Hierarchy


CreatorGroup Members

CreatorGroup Members
Public Methods Public Properties
Collapse All

The following tables list the members exposed by CreatorGroup.

Public Methods
Name | Description
Bitmap | Returns the bitmap as found by information from XML-file.
CreatorGroup | Nodename defaults to {descriptorname}
EffectiveNodeName | Name of node as shown in tree (node.Text) with expansion of macros.
EnsuredMetaCreatorType | Returns the MetaCreatorType defined with the MetaCreatorFilter.value == filter.
GetMetaCreatorTypeByFilter | Returns the MetaCreatorType defined with the MetaCreatorFilter.value == filter.
SetNodeInfo | Called from xml reader to set information as read from xml-file
Top
Public Properties
Name | Description
BitmapKey | do not localize
CreatorDescriptorList | The dynamic configuration of the group.
Description | Description of node as read from xml-file-
MetaCreatorTypeList | List of MetaCreatorType instances statically belonging to this group (as read from xml-file).
Nodename | Name of node as read from xml-file.


CreatorGroup.CreatorGroup Constructor

CreatorGroup.CreatorGroup Constructor
CreatorGroup Class CreatorGroup Members Eco.Handles.Design Namespace See Also
Collapse All
C#
public CreatorGroup();
Remarks

Nodename defaults to {descriptorname}

See Also
CreatorGroup Class
CreatorGroup Members
Eco.Handles.Design Namespace


CreatorGroup Methods

CreatorGroup Methods
Public Methods
Collapse All

The methods of the CreatorGroup class are listed here.

Public Methods
Name | Description
EffectiveNodeName | Name of node as shown in tree (node.Text) with expansion of macros.
EnsuredMetaCreatorType | Returns the MetaCreatorType defined with the MetaCreatorFilter.value == filter.
GetMetaCreatorTypeByFilter | Returns the MetaCreatorType defined with the MetaCreatorFilter.value == filter.


CreatorGroup.EffectiveNodeName Method

CreatorGroup.EffectiveNodeName Method
CreatorGroup Class CreatorGroup Members Eco.Handles.Design Namespace See Also
Collapse All

Name of node as shown in tree (node.Text) with expansion of macros.

C#
public override string EffectiveNodeName(
    CreatorNodeDescriptor descriptor
);
Remarks

Expands {descriptorname} with descriptor.Name if descriptor is not null.

See Also
CreatorGroup Class
CreatorGroup Members
Eco.Handles.Design Namespace


CreatorGroup.EnsuredMetaCreatorType Method

CreatorGroup.EnsuredMetaCreatorType Method
CreatorGroup Class CreatorGroup Members Eco.Handles.Design Namespace See Also
Collapse All

Returns the MetaCreatorType defined with the MetaCreatorFilter.value == filter.

C#
public MetaCreatorType EnsuredMetaCreatorType(
    string filter
);
Remarks

Returns the MetaCreatorType instance with Filter == filter or craetes a new instance with the specified filter if none found. The newly created instance will be added to the MetaCreatorTypeList. This method is only called by the xml reader.

See Also
CreatorGroup Class
CreatorGroup Members
Eco.Handles.Design Namespace


CreatorGroup.GetMetaCreatorTypeByFilter Method

CreatorGroup.GetMetaCreatorTypeByFilter Method
CreatorGroup Class CreatorGroup Members Eco.Handles.Design Namespace See Also
Collapse All

Returns the MetaCreatorType defined with the MetaCreatorFilter.value == filter.

C#
public MetaCreatorType GetMetaCreatorTypeByFilter(
    string filter
);
Returns

Returns the MetaCreatorType instance with Filter == filter or null if none found.

See Also
CreatorGroup Class
CreatorGroup Members
Eco.Handles.Design Namespace


CreatorGroup Properties

CreatorGroup Properties
Public Properties
Collapse All

The properties of the CreatorGroup class are listed here.

Public Properties
Name | Description
CreatorDescriptorList | The dynamic configuration of the group.
MetaCreatorTypeList | List of MetaCreatorType instances statically belonging to this group (as read from xml-file).


CreatorGroup.CreatorDescriptorList Property

CreatorGroup.CreatorDescriptorList Property
CreatorGroup Class CreatorGroup Members Eco.Handles.Design Namespace See Also
Collapse All

The dynamic configuration of the group.

C#
public List<CreatorNodeDescriptor> CreatorDescriptorList;
Remarks

This list is maintained by the CreatorHandler responsible for building the dynamic structure parametrized on the selected component.

See Also
CreatorGroup Class
CreatorGroup Members
Eco.Handles.Design Namespace


CreatorGroup.MetaCreatorTypeList Property

CreatorGroup.MetaCreatorTypeList Property
CreatorGroup Class CreatorGroup Members Eco.Handles.Design Namespace See Also
Collapse All

List of MetaCreatorType instances statically belonging to this group (as read from xml-file).

C#
public List<MetaCreatorType> MetaCreatorTypeList;
See Also
CreatorGroup Class
CreatorGroup Members
Eco.Handles.Design Namespace


CreatorHandler Class

CreatorHandler Class
CreatorHandler Members Inheritance Hierarchy See Also
Collapse All

This class is responsible for getting information from the XML-file

C#
public abstract class CreatorHandler;
Inheritance Hierarchy
Eco.Handles.Design.CreatorHandler
    Eco.Handles.Design.AllInstancesWidgetsCreatorHandler
    Eco.Handles.Design.AssociationWidgetsCreatorHandler
    Eco.Handles.Design.ColumnWidgetsCreatorHandler
    Eco.Handles.Design.FormCreatorHandler
    Eco.Handles.Design.ListActionCreatorHandler
    Eco.Handles.Design.PMapperCreatorHandler
    Eco.Handles.Design.ReferenceHandleCreatorHandler
File

ContextCreatorManager.cs

See Also
CreatorHandler Members
Inheritance Hierarchy


CreatorHandler Members

CreatorHandler Members
Public Methods Public Properties Protected Properties
Collapse All

The following tables list the members exposed by CreatorHandler.

Public Methods
Name | Description
Clear | Clears the CreatorGroup.CreatorDescriptorList.
CreatorHandler | Creates a new instance and reads information from xml-file.
ReadFromXml | This is ReadFromXml, a member of class CreatorHandler.
RefreshCreatorTree | Builds the dynamic structure.
Top
Public Properties
Name | Description
CreatorGroup | The CreatorGroup represents the top node for this structure.
Top
Protected Properties
Name | Description
BinDir | Returns IIdeService.GetEcoConfigDir()
Filename | Specifies which xml file to read information from.
TopNodename | Specifies which top node to read information from.


CreatorHandler.CreatorHandler Constructor

CreatorHandler.CreatorHandler Constructor
CreatorHandler Class CreatorHandler Members Eco.Handles.Design Namespace See Also
Collapse All

Creates a new instance and reads information from xml-file.

C#
public CreatorHandler();
See Also
CreatorHandler Class
CreatorHandler Members
Eco.Handles.Design Namespace


CreatorHandler Methods

CreatorHandler Methods
Public Methods
Collapse All

The methods of the CreatorHandler class are listed here.

Public Methods
Name | Description
Clear | Clears the CreatorGroup.CreatorDescriptorList.
ReadFromXml | This is ReadFromXml, a member of class CreatorHandler.
RefreshCreatorTree | Builds the dynamic structure.


CreatorHandler.Clear Method

CreatorHandler.Clear Method
CreatorHandler Class CreatorHandler Members Eco.Handles.Design Namespace See Also
Collapse All

Clears the CreatorGroup.CreatorDescriptorList.

C#
public void Clear();
Remarks

This is the dynamically created structure. Called prior to RefreshCreatorTree.

See Also
CreatorHandler Class
CreatorHandler Members
Eco.Handles.Design Namespace


CreatorHandler.ReadFromXml Method

CreatorHandler.ReadFromXml Method
CreatorHandler Class CreatorHandler Members Eco.Handles.Design Namespace See Also
Collapse All
C#
public void ReadFromXml();
Remarks

This is ReadFromXml, a member of class CreatorHandler.

See Also
CreatorHandler Class
CreatorHandler Members
Eco.Handles.Design Namespace


CreatorHandler.RefreshCreatorTree Method

CreatorHandler.RefreshCreatorTree Method
CreatorHandler Class CreatorHandler Members Eco.Handles.Design Namespace See Also
Collapse All

Builds the dynamic structure.

C#
public abstract void RefreshCreatorTree(
    DesignerData designerData
);
Remarks

The implementatation of this method must retrieve a MetaCreatorType, create a new CreatorNodeDescriptor, add the MetaCreatorType instance to the descriptor's MetaCreatorTypeList after which the descriptor must be added to the CreatorGroup's CreatorDescriptorList. For each node to be visible in the tree. Maybe an example helps clear the fog:

Copy Code
MetaCreatorType metaCreatorType = CreatorGroup.GetMetaCreatorTypeByFilter(filter);
CreatorNodeDescriptor descriptor = new CreatorNodeDescriptor();
descriptor.MetaCreatorTypeList.Add(metaCreatorType);
CreatorGroup.CreatorDescriptorList.Add(descriptor);
See Also
CreatorHandler Class
CreatorHandler Members
Eco.Handles.Design Namespace


CreatorHandler Properties

CreatorHandler Properties
Public Properties Protected Properties
Collapse All

The properties of the CreatorHandler class are listed here.

Public Properties
Name | Description
CreatorGroup | The CreatorGroup represents the top node for this structure.
Top
Protected Properties
Name | Description
BinDir | Returns IIdeService.GetEcoConfigDir()
Filename | Specifies which xml file to read information from.
TopNodename | Specifies which top node to read information from.


CreatorHandler.BinDir Property

CreatorHandler.BinDir Property
CreatorHandler Class CreatorHandler Members Eco.Handles.Design Namespace See Also
Collapse All

Returns IIdeService.GetEcoConfigDir()

C#
protected string BinDir;
See Also
CreatorHandler Class
CreatorHandler Members
Eco.Handles.Design Namespace


CreatorHandler.CreatorGroup Property

CreatorHandler.CreatorGroup Property
CreatorHandler Class CreatorHandler Members Eco.Handles.Design Namespace See Also
Collapse All

The CreatorGroup represents the top node for this structure.

C#
public CreatorGroup CreatorGroup;
See Also
CreatorHandler Class
CreatorHandler Members
Eco.Handles.Design Namespace


CreatorHandler.Filename Property

CreatorHandler.Filename Property
CreatorHandler Class CreatorHandler Members Eco.Handles.Design Namespace See Also
Collapse All

Specifies which xml file to read information from.

C#
protected abstract string Filename;
See Also
CreatorHandler Class
CreatorHandler Members
Eco.Handles.Design Namespace


CreatorHandler.TopNodename Property

CreatorHandler.TopNodename Property
CreatorHandler Class CreatorHandler Members Eco.Handles.Design Namespace See Also
Collapse All

Specifies which top node to read information from.

C#
protected abstract string TopNodename;
See Also
CreatorHandler Class
CreatorHandler Members
Eco.Handles.Design Namespace


CreatorInfo Class

CreatorInfo Class
CreatorInfo Members Inheritance Hierarchy See Also
Collapse All

Base class for creator classes that can be shown in tree view.

C#
public abstract class CreatorInfo;
Inheritance Hierarchy
Eco.Handles.Design.CreatorInfo
    Eco.Handles.Design.CreatorGroup
    Eco.Handles.Design.MetaCreator
    Eco.Handles.Design.MetaCreatorType
File

ContextComponentDictionary.cs

See Also
CreatorInfo Members
Inheritance Hierarchy


CreatorInfo Members

CreatorInfo Members
Public Methods Public Properties
Collapse All

The following tables list the members exposed by CreatorInfo.

Public Methods
Name | Description
Bitmap | Returns the bitmap as found by information from XML-file.
EffectiveNodeName | Name of node as shown in tree (node.Text) with potential expansion of macros.
SetNodeInfo | Called from xml reader to set information as read from xml-file
Top
Public Properties
Name | Description
BitmapKey | do not localize
Description | Description of node as read from xml-file-
Nodename | Name of node as read from xml-file.


CreatorInfo Methods

CreatorInfo Methods
Public Methods
Collapse All

The methods of the CreatorInfo class are listed here.

Public Methods
Name | Description
Bitmap | Returns the bitmap as found by information from XML-file.
EffectiveNodeName | Name of node as shown in tree (node.Text) with potential expansion of macros.
SetNodeInfo | Called from xml reader to set information as read from xml-file


CreatorInfo.Bitmap Method

CreatorInfo.Bitmap Method
CreatorInfo Class CreatorInfo Members Eco.Handles.Design Namespace See Also
Collapse All

Returns the bitmap as found by information from XML-file.

C#
public Bitmap Bitmap();
Returns

null if the class could not be located, otherwise the bitmap.

Remarks

The bitmap is found by looking at the class specified by the Class and Assembly attributes in the Nodeinfo.Icon node in the xml-file. This class is passed to a ToolboxItem, and the bitmap of the toolbox item is returned.

See Also
CreatorInfo Class
CreatorInfo Members
Eco.Handles.Design Namespace


CreatorInfo.EffectiveNodeName Method

CreatorInfo.EffectiveNodeName Method
CreatorInfo Class CreatorInfo Members Eco.Handles.Design Namespace See Also
Collapse All

Name of node as shown in tree (node.Text) with potential expansion of macros.

C#
public virtual string EffectiveNodeName(
    CreatorNodeDescriptor descriptor
);
Remarks

Default implementation is to return Nodename.

See Also
CreatorInfo Class
CreatorInfo Members
Eco.Handles.Design Namespace


CreatorInfo.SetNodeInfo Method

CreatorInfo.SetNodeInfo Method
CreatorInfo Class CreatorInfo Members Eco.Handles.Design Namespace See Also
Collapse All

Called from xml reader to set information as read from xml-file

C#
public void SetNodeInfo(
    NodeInfo nodeInfo
);
See Also
CreatorInfo Class
CreatorInfo Members
Eco.Handles.Design Namespace


CreatorInfo Properties

CreatorInfo Properties
Public Properties
Collapse All

The properties of the CreatorInfo class are listed here.

Public Properties
Name | Description
BitmapKey | do not localize
Description | Description of node as read from xml-file-
Nodename | Name of node as read from xml-file.


CreatorInfo.BitmapKey Property

CreatorInfo.BitmapKey Property
CreatorInfo Class CreatorInfo Members Eco.Handles.Design Namespace See Also
Collapse All
C#
public string BitmapKey;
Remarks

do not localize

See Also
CreatorInfo Class
CreatorInfo Members
Eco.Handles.Design Namespace


CreatorInfo.Description Property

CreatorInfo.Description Property
CreatorInfo Class CreatorInfo Members Eco.Handles.Design Namespace See Also
Collapse All

Description of node as read from xml-file-

C#
public string Description;
See Also
CreatorInfo Class
CreatorInfo Members
Eco.Handles.Design Namespace


CreatorInfo.Nodename Property

CreatorInfo.Nodename Property
CreatorInfo Class CreatorInfo Members Eco.Handles.Design Namespace See Also
Collapse All

Name of node as read from xml-file.

C#
public string Nodename;
See Also
CreatorInfo Class
CreatorInfo Members
Eco.Handles.Design Namespace


CreatorManager Class

CreatorManager Class
CreatorManager Members Inheritance Hierarchy See Also
Collapse All

This class is responsible for tracking the selected component and populating the display form.

C#
public sealed class CreatorManager;
Inheritance Hierarchy
Eco.Handles.Design.CreatorManager
File

ContextCreatorManager.cs

See Also
CreatorManager Members
Inheritance Hierarchy


CreatorManager Members

CreatorManager Members
Public Methods Public Properties
Collapse All

The following tables list the members exposed by CreatorManager.

Public Methods
Name | Description
CreatorManager | This is CreatorManager, a member of class CreatorManager.
RereadXml | This is RereadXml, a member of class CreatorManager.
Top
Public Properties
Name | Description
CreatorHandlerList | This is CreatorHandlerList, a member of class CreatorManager.


CreatorManager.CreatorManager Constructor

CreatorManager.CreatorManager Constructor
CreatorManager Class CreatorManager Members Eco.Handles.Design Namespace See Also
Collapse All
C#
public CreatorManager();
Remarks

This is CreatorManager, a member of class CreatorManager.

See Also
CreatorManager Class
CreatorManager Members
Eco.Handles.Design Namespace


CreatorManager Methods

CreatorManager Methods
Public Methods
Collapse All

The methods of the CreatorManager class are listed here.

Public Methods
Name | Description
RereadXml | This is RereadXml, a member of class CreatorManager.


CreatorManager.RereadXml Method

CreatorManager.RereadXml Method
CreatorManager Class CreatorManager Members Eco.Handles.Design Namespace See Also
Collapse All
C#
public static void RereadXml();
Remarks

This is RereadXml, a member of class CreatorManager.

See Also
CreatorManager Class
CreatorManager Members
Eco.Handles.Design Namespace


CreatorManager Properties

CreatorManager Properties
Public Properties
Collapse All

The properties of the CreatorManager class are listed here.

Public Properties
Name | Description
CreatorHandlerList | This is CreatorHandlerList, a member of class CreatorManager.


CreatorManager.CreatorHandlerList Property

CreatorManager.CreatorHandlerList Property
CreatorManager Class CreatorManager Members Eco.Handles.Design Namespace See Also
Collapse All
C#
public static List<CreatorHandler> CreatorHandlerList;
Remarks

This is CreatorHandlerList, a member of class CreatorManager.

See Also
CreatorManager Class
CreatorManager Members
Eco.Handles.Design Namespace


CreatorNodeDescriptor Class

CreatorNodeDescriptor Class
CreatorNodeDescriptor Members Inheritance Hierarchy See Also
Collapse All

Container used by the selection form.

C#
public class CreatorNodeDescriptor;
Remarks

This class is the one used in the selection form. Its string representation is the name as picked up from the xml-file. The subclasses fill it with enough information to create the requested components.

Inheritance Hierarchy
Eco.Handles.Design.CreatorNodeDescriptor
    Eco.Handles.Design.ColumnCreatorNodeDescriptor
    Eco.Handles.Design.ModelElementNodeDescriptor
File

ContextCreatorManager.cs

See Also
CreatorNodeDescriptor Members
Inheritance Hierarchy


CreatorNodeDescriptor Members

CreatorNodeDescriptor Members
Public Methods Public Properties
Collapse All

The following tables list the members exposed by CreatorNodeDescriptor.

Public Methods
Name | Description
CreatorNodeDescriptor | This is CreatorNodeDescriptor, a member of class CreatorNodeDescriptor.
DragInvoke | Invokes the MetaCreator linked to creatorInfo to create components.
Invoke | Invokes the MetaCreator linked to creatorInfo to create components.
MetaCreatorList | Derived list of all dynamically registered MetaCreator used to build UI nodes.
ToString | String representation is defined as DisplayName.
Top
Public Properties
Name | Description
Description | This is Description, a member of class CreatorNodeDescriptor.
DisplayName | This is DisplayName, a member of class CreatorNodeDescriptor.
MetaCreatorType | The MetaCreatorType with the list of defined component sets.
MetaCreatorTypeList | This is MetaCreatorTypeList, a member of class CreatorNodeDescriptor.
Name | This is Name, a member of class CreatorNodeDescriptor.
ToolTip | This is ToolTip, a member of class CreatorNodeDescriptor.


CreatorNodeDescriptor.CreatorNodeDescriptor Constructor

CreatorNodeDescriptor.CreatorNodeDescriptor Constructor
CreatorNodeDescriptor Class CreatorNodeDescriptor Members Eco.Handles.Design Namespace See Also
Collapse All
C#
public CreatorNodeDescriptor();
Remarks

This is CreatorNodeDescriptor, a member of class CreatorNodeDescriptor.

See Also
CreatorNodeDescriptor Class
CreatorNodeDescriptor Members
Eco.Handles.Design Namespace


CreatorNodeDescriptor Methods

CreatorNodeDescriptor Methods
Public Methods
Collapse All

The methods of the CreatorNodeDescriptor class are listed here.

Public Methods
Name | Description
DragInvoke | Invokes the MetaCreator linked to creatorInfo to create components.
Invoke | Invokes the MetaCreator linked to creatorInfo to create components.
MetaCreatorList | Derived list of all dynamically registered MetaCreator used to build UI nodes.
ToString | String representation is defined as DisplayName.


CreatorNodeDescriptor.DragInvoke Method

CreatorNodeDescriptor.DragInvoke Method
CreatorNodeDescriptor Class CreatorNodeDescriptor Members Eco.Handles.Design Namespace See Also
Collapse All

Invokes the MetaCreator linked to creatorInfo to create components.

C#
public void DragInvoke(
    CreatorInfo creatorInfo,
    DesignerData designerData
);
See Also
CreatorNodeDescriptor Class
CreatorNodeDescriptor Members
Eco.Handles.Design Namespace


CreatorNodeDescriptor.Invoke Method

CreatorNodeDescriptor.Invoke Method
CreatorNodeDescriptor Class CreatorNodeDescriptor Members Eco.Handles.Design Namespace See Also
Collapse All

Invokes the MetaCreator linked to creatorInfo to create components.

C#
public void Invoke(
    CreatorInfo creatorInfo,
    DesignerData designerData
);
See Also
CreatorNodeDescriptor Class
CreatorNodeDescriptor Members
Eco.Handles.Design Namespace


CreatorNodeDescriptor.MetaCreatorList Method

CreatorNodeDescriptor.MetaCreatorList Method
CreatorNodeDescriptor Class CreatorNodeDescriptor Members Eco.Handles.Design Namespace See Also
Collapse All

Derived list of all dynamically registered MetaCreator used to build UI nodes.

C#
public List<MetaCreator> MetaCreatorList();
See Also
CreatorNodeDescriptor Class
CreatorNodeDescriptor Members
Eco.Handles.Design Namespace


CreatorNodeDescriptor.ToString Method

CreatorNodeDescriptor.ToString Method
CreatorNodeDescriptor Class CreatorNodeDescriptor Members Eco.Handles.Design Namespace See Also
Collapse All

String representation is defined as DisplayName.

C#
public override string ToString();
See Also
CreatorNodeDescriptor Class
CreatorNodeDescriptor Members
Eco.Handles.Design Namespace


CreatorNodeDescriptor Properties

CreatorNodeDescriptor Properties
Public Properties
Collapse All

The properties of the CreatorNodeDescriptor class are listed here.

Public Properties
Name | Description
Description | This is Description, a member of class CreatorNodeDescriptor.
DisplayName | This is DisplayName, a member of class CreatorNodeDescriptor.
MetaCreatorType | The MetaCreatorType with the list of defined component sets.
MetaCreatorTypeList | This is MetaCreatorTypeList, a member of class CreatorNodeDescriptor.
Name | This is Name, a member of class CreatorNodeDescriptor.
ToolTip | This is ToolTip, a member of class CreatorNodeDescriptor.


CreatorNodeDescriptor.Description Property

CreatorNodeDescriptor.Description Property
CreatorNodeDescriptor Class CreatorNodeDescriptor Members Eco.Handles.Design Namespace See Also
Collapse All
C#
public virtual string Description;
Remarks

This is Description, a member of class CreatorNodeDescriptor.

See Also
CreatorNodeDescriptor Class
CreatorNodeDescriptor Members
Eco.Handles.Design Namespace


CreatorNodeDescriptor.DisplayName Property

CreatorNodeDescriptor.DisplayName Property
CreatorNodeDescriptor Class CreatorNodeDescriptor Members Eco.Handles.Design Namespace See Also
Collapse All
C#
public virtual string DisplayName;
Remarks

This is DisplayName, a member of class CreatorNodeDescriptor.

See Also
CreatorNodeDescriptor Class
CreatorNodeDescriptor Members
Eco.Handles.Design Namespace


CreatorNodeDescriptor.MetaCreatorType Property

CreatorNodeDescriptor.MetaCreatorType Property
CreatorNodeDescriptor Class CreatorNodeDescriptor Members Eco.Handles.Design Namespace See Also
Collapse All

The MetaCreatorType with the list of defined component sets.

C#
public MetaCreatorType MetaCreatorType;
See Also
CreatorNodeDescriptor Class
CreatorNodeDescriptor Members
Eco.Handles.Design Namespace


CreatorNodeDescriptor.MetaCreatorTypeList Property

CreatorNodeDescriptor.MetaCreatorTypeList Property
CreatorNodeDescriptor Class CreatorNodeDescriptor Members Eco.Handles.Design Namespace See Also
Collapse All
C#
public List<MetaCreatorType> MetaCreatorTypeList;
Remarks

This is MetaCreatorTypeList, a member of class CreatorNodeDescriptor.

See Also
CreatorNodeDescriptor Class
CreatorNodeDescriptor Members
Eco.Handles.Design Namespace


CreatorNodeDescriptor.Name Property

CreatorNodeDescriptor.Name Property
CreatorNodeDescriptor Class CreatorNodeDescriptor Members Eco.Handles.Design Namespace See Also
Collapse All
C#
public virtual string Name;
Remarks

This is Name, a member of class CreatorNodeDescriptor.

See Also
CreatorNodeDescriptor Class
CreatorNodeDescriptor Members
Eco.Handles.Design Namespace


CreatorNodeDescriptor.ToolTip Property

CreatorNodeDescriptor.ToolTip Property
CreatorNodeDescriptor Class CreatorNodeDescriptor Members Eco.Handles.Design Namespace See Also
Collapse All
C#
public string ToolTip;
Remarks

This is ToolTip, a member of class CreatorNodeDescriptor.

See Also
CreatorNodeDescriptor Class
CreatorNodeDescriptor Members
Eco.Handles.Design Namespace


CurrencyManagerHandleDesigner Class

CurrencyManagerHandleDesigner Class
Inheritance Hierarchy See Also
Collapse All

Designer for CurrencyManagerHandle.

C#
public class CurrencyManagerHandleDesigner : RootedHandleDesigner;
Inheritance Hierarchy
Eco.Handles.Design.NotifyingDesigner
    Eco.Handles.Design.HandlesDesigner
        Eco.Handles.Design.RootedHandleDesigner
            Eco.Handles.Design.CurrencyManagerHandleDesigner
File

Editors.cs

See Also
Inheritance Hierarchy


DataBindManipulator Class

DataBindManipulator Class
DataBindManipulator Members Inheritance Hierarchy See Also
Collapse All

Binds propertyParams.PropVal to propertyParams.InvokingComponent/propertyParams.Name.

C#
public class DataBindManipulator : AbstractManipulator;
Inheritance Hierarchy
Eco.Handles.Design.AbstractManipulator
    Eco.Handles.Design.DataBindManipulator
File

PropertyManipulators.cs

See Also
DataBindManipulator Members
Inheritance Hierarchy


DataBindManipulator Members

DataBindManipulator Members
Protected Methods Public Methods
Collapse All

The following tables list the members exposed by DataBindManipulator.

Protected Methods
Name | Description
DataboundProperty | This is DataboundProperty, a member of class DataBindManipulator.
GetUpdateMode | This is GetUpdateMode, a member of class DataBindManipulator.
PreviousComponent | Returns the previously created component that matches filter.
Top
Public Methods
Name | Description
SetPropertyValue | Allows for setting the property value.


DataBindManipulator Methods

DataBindManipulator Methods
Protected Methods Public Methods
Collapse All

The methods of the DataBindManipulator class are listed here.

Protected Methods
Name | Description
DataboundProperty | This is DataboundProperty, a member of class DataBindManipulator.
GetUpdateMode | This is GetUpdateMode, a member of class DataBindManipulator.
Top
Public Methods
Name | Description
SetPropertyValue | Allows for setting the property value.


DataBindManipulator.DataboundProperty Method

DataBindManipulator.DataboundProperty Method
DataBindManipulator Class DataBindManipulator Members Eco.Handles.Design Namespace See Also
Collapse All
C#
protected virtual string DataboundProperty(
    PropertyParams propertyParams
);
Remarks

This is DataboundProperty, a member of class DataBindManipulator.

See Also
DataBindManipulator Class
DataBindManipulator Members
Eco.Handles.Design Namespace


DataBindManipulator.GetUpdateMode Method

DataBindManipulator.GetUpdateMode Method
DataBindManipulator Class DataBindManipulator Members Eco.Handles.Design Namespace See Also
Collapse All
C#
protected virtual DataSourceUpdateMode GetUpdateMode();
Remarks

This is GetUpdateMode, a member of class DataBindManipulator.

See Also
DataBindManipulator Class
DataBindManipulator Members
Eco.Handles.Design Namespace


DataBindManipulator.SetPropertyValue Method

DataBindManipulator.SetPropertyValue Method
DataBindManipulator Class DataBindManipulator Members Eco.Handles.Design Namespace See Also
Collapse All

Allows for setting the property value.

C#
public override void SetPropertyValue(
    PropertyParams propertyParams
);
See Also
DataBindManipulator Class
DataBindManipulator Members
Eco.Handles.Design Namespace


DesignerData Class

DesignerData Class
DesignerData Members Inheritance Hierarchy See Also
Collapse All

Parameter object passed to the AbstractManipulator.

C#
public class DesignerData;
Remarks

This object contains information about the design environment allowing the manipulator to reach out and get the information it needs to perform its task.

Inheritance Hierarchy
Eco.Handles.Design.DesignerData
File

WidgetSelector.cs

See Also
DesignerData Members
Inheritance Hierarchy


DesignerData Members

DesignerData Members
Public Methods Public Properties
Collapse All

The following tables list the members exposed by DesignerData.

Public Methods
Name | Description
DesignerData | This is DesignerData, a member of class DesignerData.
SelectInvokingComponent | Selects the invoking components.
Top
Public Properties
Name | Description
ChangeService | The IComponentChangeService holding the change transaction.
Host | The Host of the designed component.
InvokingComponent | The component initially selected when the create operation started.


DesignerData.DesignerData Constructor

DesignerData.DesignerData Constructor
DesignerData Class DesignerData Members Eco.Handles.Design Namespace See Also
Collapse All
C#
public DesignerData(
    IDesignerHost host
);
Remarks

This is DesignerData, a member of class DesignerData.

See Also
DesignerData Class
DesignerData Members
Eco.Handles.Design Namespace


DesignerData Methods

DesignerData Methods
Public Methods
Collapse All

The methods of the DesignerData class are listed here.

Public Methods
Name | Description
SelectInvokingComponent | Selects the invoking components.


DesignerData.SelectInvokingComponent Method

DesignerData.SelectInvokingComponent Method
DesignerData Class DesignerData Members Eco.Handles.Design Namespace See Also
Collapse All

Selects the invoking components.

C#
public void SelectInvokingComponent();
See Also
DesignerData Class
DesignerData Members
Eco.Handles.Design Namespace


DesignerData Properties

DesignerData Properties
Public Properties
Collapse All

The properties of the DesignerData class are listed here.

Public Properties
Name | Description
ChangeService | The IComponentChangeService holding the change transaction.
Host | The Host of the designed component.
InvokingComponent | The component initially selected when the create operation started.


DesignerData.ChangeService Property

DesignerData.ChangeService Property
DesignerData Class DesignerData Members Eco.Handles.Design Namespace See Also
Collapse All

The IComponentChangeService holding the change transaction.

C#
public IComponentChangeService ChangeService;
See Also
DesignerData Class
DesignerData Members
Eco.Handles.Design Namespace


DesignerData.Host Property

DesignerData.Host Property
DesignerData Class DesignerData Members Eco.Handles.Design Namespace See Also
Collapse All

The Host of the designed component.

C#
public IDesignerHost Host;
See Also
DesignerData Class
DesignerData Members
Eco.Handles.Design Namespace


DesignerData.InvokingComponent Property

DesignerData.InvokingComponent Property
DesignerData Class DesignerData Members Eco.Handles.Design Namespace See Also
Collapse All

The component initially selected when the create operation started.

C#
public IComponent InvokingComponent;
See Also
DesignerData Class
DesignerData Members
Eco.Handles.Design Namespace


DesignStringRes Class

DesignStringRes Class
DesignStringRes Members Inheritance Hierarchy See Also
Collapse All

Autogenerated class to get compiler safe access to resource strings.

C#
public sealed class DesignStringRes : StringResources;
Inheritance Hierarchy
Eco.Handles.Design.DesignStringRes
File

Eco.Handles.Design.Strings.cs

See Also
DesignStringRes Members
Inheritance Hierarchy


DesignStringRes Members

DesignStringRes Members
Public Methods Public Properties
Collapse All

The following tables list the members exposed by DesignStringRes.

Public Methods
Name | Description
AboutEco | Returns: "About ECO{0}..."
ColumnAdded | Returns: "Added {0} to {1}.{2}"
ComponentCreated | Returns: "Created instance of {0}"
ComponentReused | Returns: "Reused {0}"
DataBound | Returns: "{0}.{1} databound to {2} of {3}"
EcoSpaceTypeNameCouldNotBeResolved | Returns: "EcoSpaceTypeName ("{0}") could not be resolved to a type-reference"
ElementNameHasWrongCase | Returns: "208 Name "{0}" in derivation expression is wrong case, change to "{1}""
ElementNameNotAnElement | Returns: "206 No suitable element named "{0}" found for derivation expression"
ErrorHeader | Returns: "209 Invalid {0}"
FormCaption | Returns: "Form: {0}"
FormValidationError | Returns: "Property {0} ("{1}") - {2}"
FormValidationStarting | Returns: "Validating {0}..."
GlobalCaption | Returns: "Global: {0}"
KeyMapperTypeNameCouldNotBeResolved | Returns: "[SqlDatabaseConfig] The MapperTypeName for KeyMapper {0} could not be resolved to a type: {1}"
KeyMapperTypeNameNameMissing | Returns: "[SqlDatabaseConfig] The MapperTypeName for KeyMapper {0} is empty"
NoStaticEvaluationService | Returns: "{0} - {1} | Unable to extract static language service from component."
PMapperTypeNameCouldNotBeResolved | Returns: "[SqlDatabaseConfig] The MapperTypeName for PersistenceMapper {0} could not be resolved to a type: {1}"
PMapperTypeNameNameMissing | Returns: "[SqlDatabaseConfig] The MapperTypeName for PersistenceMapper {0} is empty"
PropertyChanged | Returns: "Set {0}.{1} to {2}"
PropertyNotFoundForType | Returns: "Specified property not available for setting. Something may be wrong with the configuration for {0}."
SelectionCaption | Returns: "Selection: {0}"
sErrorManipulatorNotFound | Returns: "Error locating manipulator ({0}/{1}) for property {2}: {3}"
sInvalidName | Returns: "Invalid name: {0}"
sInvalidOwnedElementsAttribute | Returns: "Invalid UmlMetaAttribute 'ownedElements' for package {0}"
sLookingForPackagesInDll | Returns: "Looking in {0}..."
sManipulatorNotFound | Returns: "Manipulator ({0}/{1}) not found for property {2}"
sModelContainsnClasses | Returns: "Model contains {0} classes"
sToolButtonMissing | Returns: "There is no image for tool button {0}"
sUnableToFindModel | Returns: "Unable to find a model for the ECO Space ({0}). Please compile the application first!"
sUsageTasksHeader | Returns: "Usage tasks for {0}:nr"
TypeMismatch | Returns: "Type mismatch: Expected {0} got {1}"
UMVAssociationAndClassNotEquallyPersistent | Returns: "146 Association ({0}) and its association class are not equally persistent"
UMVAssociationClassCannotBePart | Returns: "130 Association class for "{0}" cannot be one of the classes in the association"
UMVAssociationDerivedAndPersistent | Returns: "137 Association "{0}" is both derived and persistent"
UMVAssociationEndIllegalQualifier | Returns: "142 Qualifier {0} in association end {1} does not have matching attribute in class of other end"
UMVAssociationEndIsMultiWithOtherEndComposite | Returns: "117 Association end "{0}" is multi, but other end is composite"
UMVAssociationEndNeedsType | Returns: "126 Association end "{0}" is not associated with any class"
UMVAssociationEndQualifiedAndMulti | Returns: "143 Association end {0} is qualified and of multiple cardinality. Not supported"
UMVAssociationM2MNeedsClass | Returns: "128 Many-to-many association "{0}" must have association class"
UMVAssociationRolesNeedClass | Returns: "129 Non-embedded roles "{0}" and "{1}" need association class"
UMVAssociationWithTwoAggregatedEnds | Returns: "138 Association "{0}" has two ends that are aggregated"
UMVAttributeUnknownMapper | Returns: "116 Attribute "{0}" has unknown persistence mapper ({1})"
UMVChildrenMappedClass | Returns: "133 Children mapped class "{0}" must be abstract"
UMVColumnNameInvalid | Returns: "112 Invalid column name "{0}" in "{1}""
UMVDerivedAssociationCanNotHaveClass | Returns: "127 Derived association "{0}" can not have an association class"
UMVDuplicateAssociationEndName | Returns: "139 Association ends in Association {0} are both named {1}"
UMVExpressionNameEmpty | Returns: "103 "{0}" must have an expression name"
UMVExpressionNameOCLReserved | Returns: "104 Expression name "{0}" in "{1}" is a reserved word in OCL"
UMVInvalidMappingModeTimeStampColumn | Returns: "147 Class "{0}" has locking mode "TimeStamp", but persistence mapper does not specify "UseTimeStampColumn""
UMVLinkClassMustBeConcrete | Returns: "151 Link class {0} cannot be abstract"
UMVLinkClassWithSuperClassAsEnd | Returns: "145 LinkClass ({0}) must not inherit from any of the ends ({1})"
UMVMultipleSuperClasses | Returns: "152 {0} has multiple super classes"
UMVOtherEndNotSet | Returns: "153 The other end of {0} is not set [Internal model error]"
UMVParentMappedClass | Returns: "132 Parent mapped class "{0}" must have superclass"
UMVParentMappedWithNotNullAttribute | Returns: "135 Parent mapped class "{0}" with NotNull attributes"
UMVPersistenceSubClass | Returns: "131 Persistent class "{0}" has non-persistent superclass"
UMVRecursiveMapping | Returns: "134 Recursive mapping between "{0}" and "{1}""
UMVSingleAssociationEndsEmbeddedInBothEnds | Returns: "124 Association "{0}"s both ends are embedded and single-single ends."
UMVSQLColumnNameEmpty | Returns: "108 "{0}" must have a column name"
UMVSQLTableNameEmpty | Returns: "107 "{0}" must have a table name"
UMVTableNameInvalid | Returns: "109 Invalid table name "{0}" in "{1}""
UMVVersionedClassWithNonVersionedSuperClass | Returns: "140 Class "{0}" is versioned, but its superclass is not"
UnableToLoadRegistryValue | Returns: "Unable to load value from registry: {0}\{1}\{2}"
UnableToOpenFile | Returns: "Unable to open {0}"
UnknownTypeOfValue | Returns: "Unknown type of value: {0}"
UnsupportedContextType | Returns: "207 Unsupported context type ({0}) for OCL expression"
ValidationMessage | Returns: "{0}{1} [{2}]"
ViolationMessage | Returns: "{0}: {1}. Expression: "{2}""
ViolationMessageWithDesc | Returns: "{0}: {1} - {2}. Expression: "{3}""
Top
Public Properties
Name | Description
ActionButNoExpression | Returns: "Action is set to ExecuteAction but no ActionExpression is defined."
CaptionCancel | Returns: "Cancel"
CaptionOK | Returns: "OK"
EcoSpaceDesignerMessage | Returns: "Always compile your Eco Project after creation!nnTo add components to your EcoSpace, drag them from the Tool Palette and use the Object Inspector to set their properties. Typical components to add to an EcoSpace are PersistenceMappers and database connections.nRemember to connect the EcoSpace to the persistence mapper."
EcoSpaceTypeNameMissing | Returns: "RootHandle has no EcoSpaceTypeName"
EditExpression | Returns: "Edit Expression..."
EnterLicenseKey | Returns: "Enter license key..."
ExpressionForNonDerivedAssoc | Returns: "200 Derivation expression specified for non-derived association"
ExpressionForNonDerivedAttrib | Returns: "201 Derivation expression specified for non-derived attribute"
ExpressionRespecifiedForCodeDerivedAssoc | Returns: "205 Derivation expression respecified for code-derived association end"
ExpressionRespecifiedForCodeDerivedAttrib | Returns: "203 Derivation expression respecified for code-derived attribute"
ExpressionRespecifiedForNonDerivedAssoc | Returns: "204 Derivation expression respecified for non-derived association"
ExpressionRespecifiedForNonDerivedAttrib | Returns: "202 Derivation expression respecified for non-derived attribute"
FormContext | Returns: "Form"
FormValidation | Returns: "Form validation"
FormValidationOK | Returns: "Validation complete - no rules broken."
FormValidationWithError | Returns: "Validation complete - Rules were broken."
GlobalContext | Returns: "Global"
KeyMapperNameMissing | Returns: "[SqlDatabaseConfig] There is an entry in the KeyMappers collection that does not have a name"
LogValidatingModel | Returns: "Validating the model"
MenuCaption_Settings | Returns: "Settings..."
ModelValidation | Returns: "Model validation"
MsgError | Returns: "Error"
MsgException | Returns: "Exception"
MsgInternalError | Returns: "Internal error"
NoActionSpecified | Returns: "Action not specified."
NoBindingContext | Returns: "BindingContext not specified."
NoRootHandleSet | Returns: "RootHandle is not specified."
NoStaticEvaluationServiceProbableCause | Returns: "Probably related to some problem with the uplink component."
OpenEcoDatatypesXmlCaption | Returns: "Open EcoDatatypes.xml"
PersistenceMapperProviderDesignerMessage | Returns: "To add components to your PersistenceMapperProvider, drag them from the Tool Palette and use the Object Inspector to set their properties. Typical components to add to a PersistenceMapperProvider include persistence mapper and database connections.nRemember to connect the PersistenceMapperProvider to the EcoSpace type."
PMapperNameMissing | Returns: "[SqlDatabaseConfig] There is an entry in the PersistenceMappers collection that does not have a name"
PropertyNotFound | Returns: "Specified property not available for setting. Something may be wrong with the configuration file."
RefreshContextAgentXML | Returns: "Refresh ContextAgent XML"
sAttributeLists | Returns: "Attribute lists"
sAttributes | Returns: "Attributes"
sAutoCompileFailed | Returns: "Compile failed. Operation aborted"
sAutoCompileRecommended | Returns: "Recompilation recommended!"
sBinariesWrong | Returns: "The current code is not compiled. nModel information may be out of date and produce unexpected results. nDo you want to recompile now? n(You can set autocompile via Tools | Options | ECO General Options)"
sCannotFindDll | Returns: "Internal Error. Unable to find an ECO Space, this is probably a DLL mismatch issue!"
sCannotFindStaticTypeSystem | Returns: "Could not find StaticTypeSystem. Please compile the application."
sCannotWriteChangesToDOM | Returns: "Unable to write changes to the source file. Please switch to codeview and back to designer first"
sCircularReference | Returns: "Circular reference"
sClasses | Returns: "Classes"
sClassesInPackage | Returns: "Classes in package:"
sClassLists | Returns: "Class lists"
sConnectedToWrongType | Returns: "Maybe not a RootHandle... This only deals with RootHandles"
sCreateDefaultColumnsVerb | Returns: "Create Default Columns"
sDataTypeLists | Returns: "Data type lists"
sDataTypes | Returns: "Data types"
sEcoSpaceDeclarationNotFound | Returns: "Unable to find a declaration for an ECO Space in this file, perhaps the attribute '[EcoSpace]' has been accidentally removed"
sEcoSpaceNotFound | Returns: "EcoSpace not set. Cannot invoke tool!"
sEcoToolSelectPackagesHint | Returns: "Select &Packages"
SelectionContext | Returns: "Selection"
sElementHandleDesignerTransactionName | Returns: "Updating handle"
sEllipsis | Returns: "..."
sEndOfList | Returns: "<<end>>"
sHandleHasNoClassifier | Returns: "Cannot extract type information from connected handle. Is the handle properly configured?"
sHandleNotFound | Returns: "Unable to find a handle. Is the component connected to a handle?"
sHelpEcoSpaceType | Returns: "Specify the type of the EcoSpace"
sHelpMakePersistent | Returns: "Set persistenceMapper to make system persistent"
sHelpSelectPackages | Returns: "Use the 'Select packages' tool to specify packages for your application"
sInternalError_MissingInterface | Returns: "Internal error, Component does not implement IHasEditableExpression!"
sInternalError_MissingSecondInterface | Returns: "Internal error, Component does not implement IHasSecondEditableExpression!"
sLists | Returns: "Lists"
sLookingForPackagesDone | Returns: "Searching for packages complete."
sLookingForPackagesStart | Returns: "Searching for available packages..."
sNone | Returns: "(none)"
sNotAllComponentsHaveTheSameContext | Returns: "Selected components have different context. Unable to show editor."
sSelectPackage | Returns: "Please select a package first"
sSetsMustHaveNames | Returns: "Sets must have names"
sSpecifyXmlFile | Returns: "Specify file to use for data storage"
sSpecifyXmlMappingFile | Returns: "Specify file containing O/R mapping information"
sToolImplementationMissing | Returns: "Tool implementation missing"
sToolNotFound | Returns: "EcoSpaceTool not found. Requested operation cannot be performed."
sTypesInTheSystem | Returns: "Types in the system"
sUnableToCreateModel | Returns: "Unable to create the model"
sXmlFileFilter | Returns: "XML-files (*.xml)|*.xml|All files (*.*)|*.*"
UMVClassNameEmpty | Returns: "101 Class must have a name"
UMVNoClassesInModel | Returns: "149 Model contains no classes."
UMVRootClassMissing | Returns: "144 Root Class is missing"
UMVUMLModelNotAssigned | Returns: "150 Model information is not assigned"
ValidateForms | Returns: "Validate forms"
ValidationError | Returns: "Error"
ValidationHint | Returns: "Hint"
ValidationWarning | Returns: "Warning"


DesignStringRes Methods

DesignStringRes Methods
Public Methods
Collapse All

The methods of the DesignStringRes class are listed here.

Public Methods
Name | Description
AboutEco | Returns: "About ECO{0}..."
ColumnAdded | Returns: "Added {0} to {1}.{2}"
ComponentCreated | Returns: "Created instance of {0}"
ComponentReused | Returns: "Reused {0}"
DataBound | Returns: "{0}.{1} databound to {2} of {3}"
EcoSpaceTypeNameCouldNotBeResolved | Returns: "EcoSpaceTypeName ("{0}") could not be resolved to a type-reference"
ElementNameHasWrongCase | Returns: "208 Name "{0}" in derivation expression is wrong case, change to "{1}""
ElementNameNotAnElement | Returns: "206 No suitable element named "{0}" found for derivation expression"
ErrorHeader | Returns: "209 Invalid {0}"
FormCaption | Returns: "Form: {0}"
FormValidationError | Returns: "Property {0} ("{1}") - {2}"
FormValidationStarting | Returns: "Validating {0}..."
GlobalCaption | Returns: "Global: {0}"
KeyMapperTypeNameCouldNotBeResolved | Returns: "[SqlDatabaseConfig] The MapperTypeName for KeyMapper {0} could not be resolved to a type: {1}"
KeyMapperTypeNameNameMissing | Returns: "[SqlDatabaseConfig] The MapperTypeName for KeyMapper {0} is empty"
NoStaticEvaluationService | Returns: "{0} - {1} | Unable to extract static language service from component."
PMapperTypeNameCouldNotBeResolved | Returns: "[SqlDatabaseConfig] The MapperTypeName for PersistenceMapper {0} could not be resolved to a type: {1}"
PMapperTypeNameNameMissing | Returns: "[SqlDatabaseConfig] The MapperTypeName for PersistenceMapper {0} is empty"
PropertyChanged | Returns: "Set {0}.{1} to {2}"
PropertyNotFoundForType | Returns: "Specified property not available for setting. Something may be wrong with the configuration for {0}."
SelectionCaption | Returns: "Selection: {0}"
sErrorManipulatorNotFound | Returns: "Error locating manipulator ({0}/{1}) for property {2}: {3}"
sInvalidName | Returns: "Invalid name: {0}"
sInvalidOwnedElementsAttribute | Returns: "Invalid UmlMetaAttribute 'ownedElements' for package {0}"
sLookingForPackagesInDll | Returns: "Looking in {0}..."
sManipulatorNotFound | Returns: "Manipulator ({0}/{1}) not found for property {2}"
sModelContainsnClasses | Returns: "Model contains {0} classes"
sToolButtonMissing | Returns: "There is no image for tool button {0}"
sUnableToFindModel | Returns: "Unable to find a model for the ECO Space ({0}). Please compile the application first!"
sUsageTasksHeader | Returns: "Usage tasks for {0}:nr"
TypeMismatch | Returns: "Type mismatch: Expected {0} got {1}"
UMVAssociationAndClassNotEquallyPersistent | Returns: "146 Association ({0}) and its association class are not equally persistent"
UMVAssociationClassCannotBePart | Returns: "130 Association class for "{0}" cannot be one of the classes in the association"
UMVAssociationDerivedAndPersistent | Returns: "137 Association "{0}" is both derived and persistent"
UMVAssociationEndIllegalQualifier | Returns: "142 Qualifier {0} in association end {1} does not have matching attribute in class of other end"
UMVAssociationEndIsMultiWithOtherEndComposite | Returns: "117 Association end "{0}" is multi, but other end is composite"
UMVAssociationEndNeedsType | Returns: "126 Association end "{0}" is not associated with any class"
UMVAssociationEndQualifiedAndMulti | Returns: "143 Association end {0} is qualified and of multiple cardinality. Not supported"
UMVAssociationM2MNeedsClass | Returns: "128 Many-to-many association "{0}" must have association class"
UMVAssociationRolesNeedClass | Returns: "129 Non-embedded roles "{0}" and "{1}" need association class"
UMVAssociationWithTwoAggregatedEnds | Returns: "138 Association "{0}" has two ends that are aggregated"
UMVAttributeUnknownMapper | Returns: "116 Attribute "{0}" has unknown persistence mapper ({1})"
UMVChildrenMappedClass | Returns: "133 Children mapped class "{0}" must be abstract"
UMVColumnNameInvalid | Returns: "112 Invalid column name "{0}" in "{1}""
UMVDerivedAssociationCanNotHaveClass | Returns: "127 Derived association "{0}" can not have an association class"
UMVDuplicateAssociationEndName | Returns: "139 Association ends in Association {0} are both named {1}"
UMVExpressionNameEmpty | Returns: "103 "{0}" must have an expression name"
UMVExpressionNameOCLReserved | Returns: "104 Expression name "{0}" in "{1}" is a reserved word in OCL"
UMVInvalidMappingModeTimeStampColumn | Returns: "147 Class "{0}" has locking mode "TimeStamp", but persistence mapper does not specify "UseTimeStampColumn""
UMVLinkClassMustBeConcrete | Returns: "151 Link class {0} cannot be abstract"
UMVLinkClassWithSuperClassAsEnd | Returns: "145 LinkClass ({0}) must not inherit from any of the ends ({1})"
UMVMultipleSuperClasses | Returns: "152 {0} has multiple super classes"
UMVOtherEndNotSet | Returns: "153 The other end of {0} is not set [Internal model error]"
UMVParentMappedClass | Returns: "132 Parent mapped class "{0}" must have superclass"
UMVParentMappedWithNotNullAttribute | Returns: "135 Parent mapped class "{0}" with NotNull attributes"
UMVPersistenceSubClass | Returns: "131 Persistent class "{0}" has non-persistent superclass"
UMVRecursiveMapping | Returns: "134 Recursive mapping between "{0}" and "{1}""
UMVSingleAssociationEndsEmbeddedInBothEnds | Returns: "124 Association "{0}"s both ends are embedded and single-single ends."
UMVSQLColumnNameEmpty | Returns: "108 "{0}" must have a column name"
UMVSQLTableNameEmpty | Returns: "107 "{0}" must have a table name"
UMVTableNameInvalid | Returns: "109 Invalid table name "{0}" in "{1}""
UMVVersionedClassWithNonVersionedSuperClass | Returns: "140 Class "{0}" is versioned, but its superclass is not"
UnableToLoadRegistryValue | Returns: "Unable to load value from registry: {0}\{1}\{2}"
UnableToOpenFile | Returns: "Unable to open {0}"
UnknownTypeOfValue | Returns: "Unknown type of value: {0}"
UnsupportedContextType | Returns: "207 Unsupported context type ({0}) for OCL expression"
ValidationMessage | Returns: "{0}{1} [{2}]"
ViolationMessage | Returns: "{0}: {1}. Expression: "{2}""
ViolationMessageWithDesc | Returns: "{0}: {1} - {2}. Expression: "{3}""


DesignStringRes.AboutEco Method

DesignStringRes.AboutEco Method
DesignStringRes Class DesignStringRes Members Eco.Handles.Design Namespace See Also
Collapse All

Returns: "About ECO{0}..."

C#
public static string AboutEco(
    object param0
);
Remarks

For internal use.

See Also
DesignStringRes Class
DesignStringRes Members
Eco.Handles.Design Namespace


DesignStringRes.ColumnAdded Method

DesignStringRes.ColumnAdded Method
DesignStringRes Class DesignStringRes Members Eco.Handles.Design Namespace See Also
Collapse All

Returns: "Added {0} to {1}.{2}"

C#
public static string ColumnAdded(
    object param0,
    object param1,
    object param2
);
Remarks

For internal use.

See Also
DesignStringRes Class
DesignStringRes Members
Eco.Handles.Design Namespace


DesignStringRes.ComponentCreated Method

DesignStringRes.ComponentCreated Method
DesignStringRes Class DesignStringRes Members Eco.Handles.Design Namespace See Also
Collapse All

Returns: "Created instance of {0}"

C#
public static string ComponentCreated(
    object param0
);
Remarks

For internal use.

See Also
DesignStringRes Class
DesignStringRes Members
Eco.Handles.Design Namespace


DesignStringRes.ComponentReused Method

DesignStringRes.ComponentReused Method
DesignStringRes Class DesignStringRes Members Eco.Handles.Design Namespace See Also
Collapse All

Returns: "Reused {0}"

C#
public static string ComponentReused(
    object param0
);
Remarks

For internal use.

See Also
DesignStringRes Class
DesignStringRes Members
Eco.Handles.Design Namespace


DesignStringRes.DataBound Method

DesignStringRes.DataBound Method
DesignStringRes Class DesignStringRes Members Eco.Handles.Design Namespace See Also
Collapse All

Returns: "{0}.{1} databound to {2} of {3}"

C#
public static string DataBound(
    object param0,
    object param1,
    object param2,
    object param3
);
Remarks

For internal use.

See Also
DesignStringRes Class
DesignStringRes Members
Eco.Handles.Design Namespace


DesignStringRes.EcoSpaceTypeNameCouldNotBeResolved Method

DesignStringRes.EcoSpaceTypeNameCouldNotBeResolved Method
DesignStringRes Class DesignStringRes Members Eco.Handles.Design Namespace See Also
Collapse All

Returns: "EcoSpaceTypeName ("{0}") could not be resolved to a type-reference"

C#
public static string EcoSpaceTypeNameCouldNotBeResolved(
    object param0
);
Remarks

For internal use.

See Also
DesignStringRes Class
DesignStringRes Members
Eco.Handles.Design Namespace


DesignStringRes.ElementNameHasWrongCase Method

DesignStringRes.ElementNameHasWrongCase Method
DesignStringRes Class DesignStringRes Members Eco.Handles.Design Namespace See Also
Collapse All

Returns: "208 Name "{0}" in derivation expression is wrong case, change to "{1}""

C#
public static string ElementNameHasWrongCase(
    object param0,
    object param1
);
Remarks

For internal use.

See Also
DesignStringRes Class
DesignStringRes Members
Eco.Handles.Design Namespace


DesignStringRes.ElementNameNotAnElement Method

DesignStringRes.ElementNameNotAnElement Method
DesignStringRes Class DesignStringRes Members Eco.Handles.Design Namespace See Also
Collapse All

Returns: "206 No suitable element named "{0}" found for derivation expression"

C#
public static string ElementNameNotAnElement(
    object param0
);
Remarks

For internal use.

See Also
DesignStringRes Class
DesignStringRes Members
Eco.Handles.Design Namespace


DesignStringRes.ErrorHeader Method

DesignStringRes.ErrorHeader Method
DesignStringRes Class DesignStringRes Members Eco.Handles.Design Namespace See Also
Collapse All

Returns: "209 Invalid {0}"

C#
public static string ErrorHeader(
    object param0
);
Remarks

For internal use.

See Also
DesignStringRes Class
DesignStringRes Members
Eco.Handles.Design Namespace


DesignStringRes.FormCaption Method

DesignStringRes.FormCaption Method
DesignStringRes Class DesignStringRes Members Eco.Handles.Design Namespace See Also
Collapse All

Returns: "Form: {0}"

C#
public static string FormCaption(
    object param0
);
Remarks

For internal use.

See Also
DesignStringRes Class
DesignStringRes Members
Eco.Handles.Design Namespace


DesignStringRes.FormValidationError Method

DesignStringRes.FormValidationError Method
DesignStringRes Class DesignStringRes Members Eco.Handles.Design Namespace See Also
Collapse All

Returns: "Property {0} ("{1}") - {2}"

C#
public static string FormValidationError(
    object param0,
    object param1,
    object param2
);
Remarks

For internal use.

See Also
DesignStringRes Class
DesignStringRes Members
Eco.Handles.Design Namespace


DesignStringRes.FormValidationStarting Method

DesignStringRes.FormValidationStarting Method
DesignStringRes Class DesignStringRes Members Eco.Handles.Design Namespace See Also
Collapse All

Returns: "Validating {0}..."

C#
public static string FormValidationStarting(
    object param0
);
Remarks

For internal use.

See Also
DesignStringRes Class
DesignStringRes Members
Eco.Handles.Design Namespace


DesignStringRes.GlobalCaption Method

DesignStringRes.GlobalCaption Method
DesignStringRes Class DesignStringRes Members Eco.Handles.Design Namespace See Also
Collapse All

Returns: "Global: {0}"

C#
public static string GlobalCaption(
    object param0
);
Remarks

For internal use.

See Also
DesignStringRes Class
DesignStringRes Members
Eco.Handles.Design Namespace


DesignStringRes.KeyMapperTypeNameCouldNotBeResolved Method

DesignStringRes.KeyMapperTypeNameCouldNotBeResolved Method
DesignStringRes Class DesignStringRes Members Eco.Handles.Design Namespace See Also
Collapse All

Returns: "[SqlDatabaseConfig] The MapperTypeName for KeyMapper {0} could not be resolved to a type: {1}"

C#
public static string KeyMapperTypeNameCouldNotBeResolved(
    object param0,
    object param1
);
Remarks

For internal use.

See Also
DesignStringRes Class
DesignStringRes Members
Eco.Handles.Design Namespace


DesignStringRes.KeyMapperTypeNameNameMissing Method

DesignStringRes.KeyMapperTypeNameNameMissing Method
DesignStringRes Class DesignStringRes Members Eco.Handles.Design Namespace See Also
Collapse All

Returns: "[SqlDatabaseConfig] The MapperTypeName for KeyMapper {0} is empty"

C#
public static string KeyMapperTypeNameNameMissing(
    object param0
);
Remarks

For internal use.

See Also
DesignStringRes Class
DesignStringRes Members
Eco.Handles.Design Namespace


DesignStringRes.NoStaticEvaluationService Method

DesignStringRes.NoStaticEvaluationService Method
DesignStringRes Class DesignStringRes Members Eco.Handles.Design Namespace See Also
Collapse All

Returns: "{0} - {1} | Unable to extract static language service from component."

C#
public static string NoStaticEvaluationService(
    object param0,
    object param1
);
Remarks

For internal use.

See Also
DesignStringRes Class
DesignStringRes Members
Eco.Handles.Design Namespace


DesignStringRes.PMapperTypeNameCouldNotBeResolved Method

DesignStringRes.PMapperTypeNameCouldNotBeResolved Method
DesignStringRes Class DesignStringRes Members Eco.Handles.Design Namespace See Also
Collapse All

Returns: "[SqlDatabaseConfig] The MapperTypeName for PersistenceMapper {0} could not be resolved to a type: {1}"

C#
public static string PMapperTypeNameCouldNotBeResolved(
    object param0,
    object param1
);
Remarks

For internal use.

See Also
DesignStringRes Class
DesignStringRes Members
Eco.Handles.Design Namespace


DesignStringRes.PMapperTypeNameNameMissing Method

DesignStringRes.PMapperTypeNameNameMissing Method
DesignStringRes Class DesignStringRes Members Eco.Handles.Design Namespace See Also
Collapse All

Returns: "[SqlDatabaseConfig] The MapperTypeName for PersistenceMapper {0} is empty"

C#
public static string PMapperTypeNameNameMissing(
    object param0
);
Remarks

For internal use.

See Also
DesignStringRes Class
DesignStringRes Members
Eco.Handles.Design Namespace


DesignStringRes.PropertyChanged Method

DesignStringRes.PropertyChanged Method
DesignStringRes Class DesignStringRes Members Eco.Handles.Design Namespace See Also
Collapse All

Returns: "Set {0}.{1} to {2}"

C#
public static string PropertyChanged(
    object param0,
    object param1,
    object param2
);
Remarks

For internal use.

See Also
DesignStringRes Class
DesignStringRes Members
Eco.Handles.Design Namespace


DesignStringRes.PropertyNotFoundForType Method

DesignStringRes.PropertyNotFoundForType Method
DesignStringRes Class DesignStringRes Members Eco.Handles.Design Namespace See Also
Collapse All

Returns: "Specified property not available for setting. Something may be wrong with the configuration for {0}."

C#
public static string PropertyNotFoundForType(
    object param0
);
Remarks

For internal use.

See Also
DesignStringRes Class
DesignStringRes Members
Eco.Handles.Design Namespace


DesignStringRes.SelectionCaption Method

DesignStringRes.SelectionCaption Method
DesignStringRes Class DesignStringRes Members Eco.Handles.Design Namespace See Also
Collapse All

Returns: "Selection: {0}"

C#
public static string SelectionCaption(
    object param0
);
Remarks

For internal use.

See Also
DesignStringRes Class
DesignStringRes Members
Eco.Handles.Design Namespace


DesignStringRes.sErrorManipulatorNotFound Method

DesignStringRes.sErrorManipulatorNotFound Method
DesignStringRes Class DesignStringRes Members Eco.Handles.Design Namespace See Also
Collapse All

Returns: "Error locating manipulator ({0}/{1}) for property {2}: {3}"

C#
public static string sErrorManipulatorNotFound(
    object param0,
    object param1,
    object param2,
    object param3
);
Remarks

For internal use.

See Also
DesignStringRes Class
DesignStringRes Members
Eco.Handles.Design Namespace


DesignStringRes.sInvalidName Method

DesignStringRes.sInvalidName Method
DesignStringRes Class DesignStringRes Members Eco.Handles.Design Namespace See Also
Collapse All

Returns: "Invalid name: {0}"

C#
public static string sInvalidName(
    object param0
);
Remarks

For internal use.

See Also
DesignStringRes Class
DesignStringRes Members
Eco.Handles.Design Namespace


DesignStringRes.sInvalidOwnedElementsAttribute Method

DesignStringRes.sInvalidOwnedElementsAttribute Method
DesignStringRes Class DesignStringRes Members Eco.Handles.Design Namespace See Also
Collapse All

Returns: "Invalid UmlMetaAttribute 'ownedElements' for package {0}"

C#
public static string sInvalidOwnedElementsAttribute(
    object param0
);
Remarks

For internal use.

See Also
DesignStringRes Class
DesignStringRes Members
Eco.Handles.Design Namespace


DesignStringRes.sLookingForPackagesInDll Method

DesignStringRes.sLookingForPackagesInDll Method
DesignStringRes Class DesignStringRes Members Eco.Handles.Design Namespace See Also
Collapse All

Returns: "Looking in {0}..."

C#
public static string sLookingForPackagesInDll(
    object param0
);
Remarks

For internal use.

See Also
DesignStringRes Class
DesignStringRes Members
Eco.Handles.Design Namespace


DesignStringRes.sManipulatorNotFound Method

DesignStringRes.sManipulatorNotFound Method
DesignStringRes Class DesignStringRes Members Eco.Handles.Design Namespace See Also
Collapse All

Returns: "Manipulator ({0}/{1}) not found for property {2}"

C#
public static string sManipulatorNotFound(
    object param0,
    object param1,
    object param2
);
Remarks

For internal use.

See Also
DesignStringRes Class
DesignStringRes Members
Eco.Handles.Design Namespace


DesignStringRes.sModelContainsnClasses Method

DesignStringRes.sModelContainsnClasses Method
DesignStringRes Class DesignStringRes Members Eco.Handles.Design Namespace See Also
Collapse All

Returns: "Model contains {0} classes"

C#
public static string sModelContainsnClasses(
    object param0
);
Remarks

For internal use.

See Also
DesignStringRes Class
DesignStringRes Members
Eco.Handles.Design Namespace


DesignStringRes.sToolButtonMissing Method

DesignStringRes.sToolButtonMissing Method
DesignStringRes Class DesignStringRes Members Eco.Handles.Design Namespace See Also
Collapse All

Returns: "There is no image for tool button {0}"

C#
public static string sToolButtonMissing(
    object param0
);
Remarks

For internal use.

See Also
DesignStringRes Class
DesignStringRes Members
Eco.Handles.Design Namespace


DesignStringRes.sUnableToFindModel Method

DesignStringRes.sUnableToFindModel Method
DesignStringRes Class DesignStringRes Members Eco.Handles.Design Namespace See Also
Collapse All

Returns: "Unable to find a model for the ECO Space ({0}). Please compile the application first!"

C#
public static string sUnableToFindModel(
    object param0
);
Remarks

For internal use.

See Also
DesignStringRes Class
DesignStringRes Members
Eco.Handles.Design Namespace


DesignStringRes.sUsageTasksHeader Method

DesignStringRes.sUsageTasksHeader Method
DesignStringRes Class DesignStringRes Members Eco.Handles.Design Namespace See Also
Collapse All

Returns: "Usage tasks for {0}:nr"

C#
public static string sUsageTasksHeader(
    object param0
);
Remarks

For internal use.

See Also
DesignStringRes Class
DesignStringRes Members
Eco.Handles.Design Namespace


DesignStringRes.TypeMismatch Method

DesignStringRes.TypeMismatch Method
DesignStringRes Class DesignStringRes Members Eco.Handles.Design Namespace See Also
Collapse All

Returns: "Type mismatch: Expected {0} got {1}"

C#
public static string TypeMismatch(
    object param0,
    object param1
);
Remarks

For internal use.

See Also
DesignStringRes Class
DesignStringRes Members
Eco.Handles.Design Namespace


DesignStringRes.UMVAssociationAndClassNotEquallyPersistent Method

DesignStringRes.UMVAssociationAndClassNotEquallyPersistent Method
DesignStringRes Class DesignStringRes Members Eco.Handles.Design Namespace See Also
Collapse All

Returns: "146 Association ({0}) and its association class are not equally persistent"

C#
public static string UMVAssociationAndClassNotEquallyPersistent(
    object param0
);
Remarks

For internal use.

See Also
DesignStringRes Class
DesignStringRes Members
Eco.Handles.Design Namespace


DesignStringRes.UMVAssociationClassCannotBePart Method

DesignStringRes.UMVAssociationClassCannotBePart Method
DesignStringRes Class DesignStringRes Members Eco.Handles.Design Namespace See Also
Collapse All

Returns: "130 Association class for "{0}" cannot be one of the classes in the association"

C#
public static string UMVAssociationClassCannotBePart(
    object param0
);
Remarks

For internal use.

See Also
DesignStringRes Class
DesignStringRes Members
Eco.Handles.Design Namespace


DesignStringRes.UMVAssociationDerivedAndPersistent Method

DesignStringRes.UMVAssociationDerivedAndPersistent Method
DesignStringRes Class DesignStringRes Members Eco.Handles.Design Namespace See Also
Collapse All

Returns: "137 Association "{0}" is both derived and persistent"

C#
public static string UMVAssociationDerivedAndPersistent(
    object param0
);
Remarks

For internal use.

See Also
DesignStringRes Class
DesignStringRes Members
Eco.Handles.Design Namespace


DesignStringRes.UMVAssociationEndIllegalQualifier Method

DesignStringRes.UMVAssociationEndIllegalQualifier Method
DesignStringRes Class DesignStringRes Members Eco.Handles.Design Namespace See Also
Collapse All

Returns: "142 Qualifier {0} in association end {1} does not have matching attribute in class of other end"

C#
public static string UMVAssociationEndIllegalQualifier(
    object param0,
    object param1
);
Remarks

For internal use.

See Also
DesignStringRes Class
DesignStringRes Members
Eco.Handles.Design Namespace


DesignStringRes.UMVAssociationEndIsMultiWithOtherEndComposite Method

DesignStringRes.UMVAssociationEndIsMultiWithOtherEndComposite Method
DesignStringRes Class DesignStringRes Members Eco.Handles.Design Namespace See Also
Collapse All

Returns: "117 Association end "{0}" is multi, but other end is composite"

C#
public static string UMVAssociationEndIsMultiWithOtherEndComposite(
    object param0
);
Remarks

For internal use.

See Also
DesignStringRes Class
DesignStringRes Members
Eco.Handles.Design Namespace


DesignStringRes.UMVAssociationEndNeedsType Method

DesignStringRes.UMVAssociationEndNeedsType Method
DesignStringRes Class DesignStringRes Members Eco.Handles.Design Namespace See Also
Collapse All

Returns: "126 Association end "{0}" is not associated with any class"

C#
public static string UMVAssociationEndNeedsType(
    object param0
);
Remarks

For internal use.

See Also
DesignStringRes Class
DesignStringRes Members
Eco.Handles.Design Namespace


DesignStringRes.UMVAssociationEndQualifiedAndMulti Method

DesignStringRes.UMVAssociationEndQualifiedAndMulti Method
DesignStringRes Class DesignStringRes Members Eco.Handles.Design Namespace See Also
Collapse All

Returns: "143 Association end {0} is qualified and of multiple cardinality. Not supported"

C#
public static string UMVAssociationEndQualifiedAndMulti(
    object param0
);
Remarks

For internal use.

See Also
DesignStringRes Class
DesignStringRes Members
Eco.Handles.Design Namespace


DesignStringRes.UMVAssociationM2MNeedsClass Method

DesignStringRes.UMVAssociationM2MNeedsClass Method
DesignStringRes Class DesignStringRes Members Eco.Handles.Design Namespace See Also
Collapse All

Returns: "128 Many-to-many association "{0}" must have association class"

C#
public static string UMVAssociationM2MNeedsClass(
    object param0
);
Remarks

For internal use.

See Also
DesignStringRes Class
DesignStringRes Members
Eco.Handles.Design Namespace


DesignStringRes.UMVAssociationRolesNeedClass Method

DesignStringRes.UMVAssociationRolesNeedClass Method
DesignStringRes Class DesignStringRes Members Eco.Handles.Design Namespace See Also
Collapse All

Returns: "129 Non-embedded roles "{0}" and "{1}" need association class"

C#
public static string UMVAssociationRolesNeedClass(
    object param0,
    object param1
);
Remarks

For internal use.

See Also
DesignStringRes Class
DesignStringRes Members
Eco.Handles.Design Namespace


DesignStringRes.UMVAssociationWithTwoAggregatedEnds Method

DesignStringRes.UMVAssociationWithTwoAggregatedEnds Method
DesignStringRes Class DesignStringRes Members Eco.Handles.Design Namespace See Also
Collapse All

Returns: "138 Association "{0}" has two ends that are aggregated"

C#
public static string UMVAssociationWithTwoAggregatedEnds(
    object param0
);
Remarks

For internal use.

See Also
DesignStringRes Class
DesignStringRes Members
Eco.Handles.Design Namespace


DesignStringRes.UMVAttributeUnknownMapper Method

DesignStringRes.UMVAttributeUnknownMapper Method
DesignStringRes Class DesignStringRes Members Eco.Handles.Design Namespace See Also
Collapse All

Returns: "116 Attribute "{0}" has unknown persistence mapper ({1})"

C#
public static string UMVAttributeUnknownMapper(
    object param0,
    object param1
);
Remarks

For internal use.

See Also
DesignStringRes Class
DesignStringRes Members
Eco.Handles.Design Namespace


DesignStringRes.UMVChildrenMappedClass Method

DesignStringRes.UMVChildrenMappedClass Method
DesignStringRes Class DesignStringRes Members Eco.Handles.Design Namespace See Also
Collapse All

Returns: "133 Children mapped class "{0}" must be abstract"

C#
public static string UMVChildrenMappedClass(
    object param0
);
Remarks

For internal use.

See Also
DesignStringRes Class
DesignStringRes Members
Eco.Handles.Design Namespace


DesignStringRes.UMVColumnNameInvalid Method

DesignStringRes.UMVColumnNameInvalid Method
DesignStringRes Class DesignStringRes Members Eco.Handles.Design Namespace See Also
Collapse All

Returns: "112 Invalid column name "{0}" in "{1}""

C#
public static string UMVColumnNameInvalid(
    object param0,
    object param1
);
Remarks

For internal use.

See Also
DesignStringRes Class
DesignStringRes Members
Eco.Handles.Design Namespace


DesignStringRes.UMVDerivedAssociationCanNotHaveClass Method

DesignStringRes.UMVDerivedAssociationCanNotHaveClass Method
DesignStringRes Class DesignStringRes Members Eco.Handles.Design Namespace See Also
Collapse All

Returns: "127 Derived association "{0}" can not have an association class"

C#
public static string UMVDerivedAssociationCanNotHaveClass(
    object param0
);
Remarks

For internal use.

See Also
DesignStringRes Class
DesignStringRes Members
Eco.Handles.Design Namespace


DesignStringRes.UMVDuplicateAssociationEndName Method

DesignStringRes.UMVDuplicateAssociationEndName Method
DesignStringRes Class DesignStringRes Members Eco.Handles.Design Namespace See Also
Collapse All

Returns: "139 Association ends in Association {0} are both named {1}"

C#
public static string UMVDuplicateAssociationEndName(
    object param0,
    object param1
);
Remarks

For internal use.

See Also
DesignStringRes Class
DesignStringRes Members
Eco.Handles.Design Namespace


DesignStringRes.UMVExpressionNameEmpty Method

DesignStringRes.UMVExpressionNameEmpty Method
DesignStringRes Class DesignStringRes Members Eco.Handles.Design Namespace See Also
Collapse All

Returns: "103 "{0}" must have an expression name"

C#
public static string UMVExpressionNameEmpty(
    object param0
);
Remarks

For internal use.

See Also
DesignStringRes Class
DesignStringRes Members
Eco.Handles.Design Namespace


DesignStringRes.UMVExpressionNameOCLReserved Method

DesignStringRes.UMVExpressionNameOCLReserved Method
DesignStringRes Class DesignStringRes Members Eco.Handles.Design Namespace See Also
Collapse All

Returns: "104 Expression name "{0}" in "{1}" is a reserved word in OCL"

C#
public static string UMVExpressionNameOCLReserved(
    object param0,
    object param1
);
Remarks

For internal use.

See Also
DesignStringRes Class
DesignStringRes Members
Eco.Handles.Design Namespace


DesignStringRes.UMVInvalidMappingModeTimeStampColumn Method

DesignStringRes.UMVInvalidMappingModeTimeStampColumn Method
DesignStringRes Class DesignStringRes Members Eco.Handles.Design Namespace See Also
Collapse All

Returns: "147 Class "{0}" has locking mode "TimeStamp", but persistence mapper does not specify "UseTimeStampColumn""

C#
public static string UMVInvalidMappingModeTimeStampColumn(
    object param0
);
Remarks

For internal use.

See Also
DesignStringRes Class
DesignStringRes Members
Eco.Handles.Design Namespace


DesignStringRes.UMVLinkClassMustBeConcrete Method

DesignStringRes.UMVLinkClassMustBeConcrete Method
DesignStringRes Class DesignStringRes Members Eco.Handles.Design Namespace See Also
Collapse All

Returns: "151 Link class {0} cannot be abstract"

C#
public static string UMVLinkClassMustBeConcrete(
    object param0
);
Remarks

For internal use.

See Also
DesignStringRes Class
DesignStringRes Members
Eco.Handles.Design Namespace


DesignStringRes.UMVLinkClassWithSuperClassAsEnd Method

DesignStringRes.UMVLinkClassWithSuperClassAsEnd Method
DesignStringRes Class DesignStringRes Members Eco.Handles.Design Namespace See Also
Collapse All

Returns: "145 LinkClass ({0}) must not inherit from any of the ends ({1})"

C#
public static string UMVLinkClassWithSuperClassAsEnd(
    object param0,
    object param1
);
Remarks

For internal use.

See Also
DesignStringRes Class
DesignStringRes Members
Eco.Handles.Design Namespace


DesignStringRes.UMVMultipleSuperClasses Method

DesignStringRes.UMVMultipleSuperClasses Method
DesignStringRes Class DesignStringRes Members Eco.Handles.Design Namespace See Also
Collapse All

Returns: "152 {0} has multiple super classes"

C#
public static string UMVMultipleSuperClasses(
    object param0
);
Remarks

For internal use.

See Also
DesignStringRes Class
DesignStringRes Members
Eco.Handles.Design Namespace


DesignStringRes.UMVOtherEndNotSet Method

DesignStringRes.UMVOtherEndNotSet Method
DesignStringRes Class DesignStringRes Members Eco.Handles.Design Namespace See Also
Collapse All

Returns: "153 The other end of {0} is not set [Internal model error]"

C#
public static string UMVOtherEndNotSet(
    object param0
);
Remarks

For internal use.

See Also
DesignStringRes Class
DesignStringRes Members
Eco.Handles.Design Namespace


DesignStringRes.UMVParentMappedClass Method

DesignStringRes.UMVParentMappedClass Method
DesignStringRes Class DesignStringRes Members Eco.Handles.Design Namespace See Also
Collapse All

Returns: "132 Parent mapped class "{0}" must have superclass"

C#
public static string UMVParentMappedClass(
    object param0
);
Remarks

For internal use.

See Also
DesignStringRes Class
DesignStringRes Members
Eco.Handles.Design Namespace


DesignStringRes.UMVParentMappedWithNotNullAttribute Method

DesignStringRes.UMVParentMappedWithNotNullAttribute Method
DesignStringRes Class DesignStringRes Members Eco.Handles.Design Namespace See Also
Collapse All

Returns: "135 Parent mapped class "{0}" with NotNull attributes"

C#
public static string UMVParentMappedWithNotNullAttribute(
    object param0
);
Remarks

For internal use.

See Also
DesignStringRes Class
DesignStringRes Members
Eco.Handles.Design Namespace


DesignStringRes.UMVPersistenceSubClass Method

DesignStringRes.UMVPersistenceSubClass Method
DesignStringRes Class DesignStringRes Members Eco.Handles.Design Namespace See Also
Collapse All

Returns: "131 Persistent class "{0}" has non-persistent superclass"

C#
public static string UMVPersistenceSubClass(
    object param0
);
Remarks

For internal use.

See Also
DesignStringRes Class
DesignStringRes Members
Eco.Handles.Design Namespace


DesignStringRes.UMVRecursiveMapping Method

DesignStringRes.UMVRecursiveMapping Method
DesignStringRes Class DesignStringRes Members Eco.Handles.Design Namespace See Also
Collapse All

Returns: "134 Recursive mapping between "{0}" and "{1}""

C#
public static string UMVRecursiveMapping(
    object param0,
    object param1
);
Remarks

For internal use.

See Also
DesignStringRes Class
DesignStringRes Members
Eco.Handles.Design Namespace


DesignStringRes.UMVSingleAssociationEndsEmbeddedInBothEnds Method

DesignStringRes.UMVSingleAssociationEndsEmbeddedInBothEnds Method
DesignStringRes Class DesignStringRes Members Eco.Handles.Design Namespace See Also
Collapse All

Returns: "124 Association "{0}"s both ends are embedded and single-single ends."

C#
public static string UMVSingleAssociationEndsEmbeddedInBothEnds(
    object param0
);
Remarks

For internal use.

See Also
DesignStringRes Class
DesignStringRes Members
Eco.Handles.Design Namespace


DesignStringRes.UMVSQLColumnNameEmpty Method

DesignStringRes.UMVSQLColumnNameEmpty Method
DesignStringRes Class DesignStringRes Members Eco.Handles.Design Namespace See Also
Collapse All

Returns: "108 "{0}" must have a column name"

C#
public static string UMVSQLColumnNameEmpty(
    object param0
);
Remarks

For internal use.

See Also
DesignStringRes Class
DesignStringRes Members
Eco.Handles.Design Namespace


DesignStringRes.UMVSQLTableNameEmpty Method

DesignStringRes.UMVSQLTableNameEmpty Method
DesignStringRes Class DesignStringRes Members Eco.Handles.Design Namespace See Also
Collapse All

Returns: "107 "{0}" must have a table name"

C#
public static string UMVSQLTableNameEmpty(
    object param0
);
Remarks

For internal use.

See Also
DesignStringRes Class
DesignStringRes Members
Eco.Handles.Design Namespace


DesignStringRes.UMVTableNameInvalid Method

DesignStringRes.UMVTableNameInvalid Method
DesignStringRes Class DesignStringRes Members Eco.Handles.Design Namespace See Also
Collapse All

Returns: "109 Invalid table name "{0}" in "{1}""

C#
public static string UMVTableNameInvalid(
    object param0,
    object param1
);
Remarks

For internal use.

See Also
DesignStringRes Class
DesignStringRes Members
Eco.Handles.Design Namespace


DesignStringRes.UMVVersionedClassWithNonVersionedSuperClass Method

DesignStringRes.UMVVersionedClassWithNonVersionedSuperClass Method
DesignStringRes Class DesignStringRes Members Eco.Handles.Design Namespace See Also
Collapse All

Returns: "140 Class "{0}" is versioned, but its superclass is not"

C#
public static string UMVVersionedClassWithNonVersionedSuperClass(
    object param0
);
Remarks

For internal use.

See Also
DesignStringRes Class
DesignStringRes Members
Eco.Handles.Design Namespace


DesignStringRes.UnableToLoadRegistryValue Method

DesignStringRes.UnableToLoadRegistryValue Method
DesignStringRes Class DesignStringRes Members Eco.Handles.Design Namespace See Also
Collapse All

Returns: "Unable to load value from registry: {0}\{1}\{2}"

C#
public static string UnableToLoadRegistryValue(
    object param0,
    object param1,
    object param2
);
Remarks

For internal use.

See Also
DesignStringRes Class
DesignStringRes Members
Eco.Handles.Design Namespace


DesignStringRes.UnableToOpenFile Method

DesignStringRes.UnableToOpenFile Method
DesignStringRes Class DesignStringRes Members Eco.Handles.Design Namespace See Also
Collapse All

Returns: "Unable to open {0}"

C#
public static string UnableToOpenFile(
    object param0
);
Remarks

For internal use.

See Also
DesignStringRes Class
DesignStringRes Members
Eco.Handles.Design Namespace


DesignStringRes.UnknownTypeOfValue Method

DesignStringRes.UnknownTypeOfValue Method
DesignStringRes Class DesignStringRes Members Eco.Handles.Design Namespace See Also
Collapse All

Returns: "Unknown type of value: {0}"

C#
public static string UnknownTypeOfValue(
    object param0
);
Remarks

For internal use.

See Also
DesignStringRes Class
DesignStringRes Members
Eco.Handles.Design Namespace


DesignStringRes.UnsupportedContextType Method

DesignStringRes.UnsupportedContextType Method
DesignStringRes Class DesignStringRes Members Eco.Handles.Design Namespace See Also
Collapse All

Returns: "207 Unsupported context type ({0}) for OCL expression"

C#
public static string UnsupportedContextType(
    object param0
);
Remarks

For internal use.

See Also
DesignStringRes Class
DesignStringRes Members
Eco.Handles.Design Namespace


DesignStringRes.ValidationMessage Method

DesignStringRes.ValidationMessage Method
DesignStringRes Class DesignStringRes Members Eco.Handles.Design Namespace See Also
Collapse All

Returns: "{0}{1} [{2}]"

C#
public static string ValidationMessage(
    object param0,
    object param1,
    object param2
);
Remarks

For internal use.

See Also
DesignStringRes Class
DesignStringRes Members
Eco.Handles.Design Namespace


DesignStringRes.ViolationMessage Method

DesignStringRes.ViolationMessage Method
DesignStringRes Class DesignStringRes Members Eco.Handles.Design Namespace See Also
Collapse All

Returns: "{0}: {1}. Expression: "{2}""

C#
public static string ViolationMessage(
    object param0,
    object param1,
    object param2
);
Remarks

For internal use.

See Also
DesignStringRes Class
DesignStringRes Members
Eco.Handles.Design Namespace


DesignStringRes.ViolationMessageWithDesc Method

DesignStringRes.ViolationMessageWithDesc Method
DesignStringRes Class DesignStringRes Members Eco.Handles.Design Namespace See Also
Collapse All

Returns: "{0}: {1} - {2}. Expression: "{3}""

C#
public static string ViolationMessageWithDesc(
    object param0,
    object param1,
    object param2,
    object param3
);
Remarks

For internal use.

See Also
DesignStringRes Class
DesignStringRes Members
Eco.Handles.Design Namespace


DesignStringRes Properties

DesignStringRes Properties
Public Properties
Collapse All

The properties of the DesignStringRes class are listed here.

Public Properties
Name | Description
ActionButNoExpression | Returns: "Action is set to ExecuteAction but no ActionExpression is defined."
CaptionCancel | Returns: "Cancel"
CaptionOK | Returns: "OK"
EcoSpaceDesignerMessage | Returns: "Always compile your Eco Project after creation!nnTo add components to your EcoSpace, drag them from the Tool Palette and use the Object Inspector to set their properties. Typical components to add to an EcoSpace are PersistenceMappers and database connections.nRemember to connect the EcoSpace to the persistence mapper."
EcoSpaceTypeNameMissing | Returns: "RootHandle has no EcoSpaceTypeName"
EditExpression | Returns: "Edit Expression..."
EnterLicenseKey | Returns: "Enter license key..."
ExpressionForNonDerivedAssoc | Returns: "200 Derivation expression specified for non-derived association"
ExpressionForNonDerivedAttrib | Returns: "201 Derivation expression specified for non-derived attribute"
ExpressionRespecifiedForCodeDerivedAssoc | Returns: "205 Derivation expression respecified for code-derived association end"
ExpressionRespecifiedForCodeDerivedAttrib | Returns: "203 Derivation expression respecified for code-derived attribute"
ExpressionRespecifiedForNonDerivedAssoc | Returns: "204 Derivation expression respecified for non-derived association"
ExpressionRespecifiedForNonDerivedAttrib | Returns: "202 Derivation expression respecified for non-derived attribute"
FormContext | Returns: "Form"
FormValidation | Returns: "Form validation"
FormValidationOK | Returns: "Validation complete - no rules broken."
FormValidationWithError | Returns: "Validation complete - Rules were broken."
GlobalContext | Returns: "Global"
KeyMapperNameMissing | Returns: "[SqlDatabaseConfig] There is an entry in the KeyMappers collection that does not have a name"
LogValidatingModel | Returns: "Validating the model"
MenuCaption_Settings | Returns: "Settings..."
ModelValidation | Returns: "Model validation"
MsgError | Returns: "Error"
MsgException | Returns: "Exception"
MsgInternalError | Returns: "Internal error"
NoActionSpecified | Returns: "Action not specified."
NoBindingContext | Returns: "BindingContext not specified."
NoRootHandleSet | Returns: "RootHandle is not specified."
NoStaticEvaluationServiceProbableCause | Returns: "Probably related to some problem with the uplink component."
OpenEcoDatatypesXmlCaption | Returns: "Open EcoDatatypes.xml"
PersistenceMapperProviderDesignerMessage | Returns: "To add components to your PersistenceMapperProvider, drag them from the Tool Palette and use the Object Inspector to set their properties. Typical components to add to a PersistenceMapperProvider include persistence mapper and database connections.nRemember to connect the PersistenceMapperProvider to the EcoSpace type."
PMapperNameMissing | Returns: "[SqlDatabaseConfig] There is an entry in the PersistenceMappers collection that does not have a name"
PropertyNotFound | Returns: "Specified property not available for setting. Something may be wrong with the configuration file."
RefreshContextAgentXML | Returns: "Refresh ContextAgent XML"
sAttributeLists | Returns: "Attribute lists"
sAttributes | Returns: "Attributes"
sAutoCompileFailed | Returns: "Compile failed. Operation aborted"
sAutoCompileRecommended | Returns: "Recompilation recommended!"
sBinariesWrong | Returns: "The current code is not compiled. nModel information may be out of date and produce unexpected results. nDo you want to recompile now? n(You can set autocompile via Tools | Options | ECO General Options)"
sCannotFindDll | Returns: "Internal Error. Unable to find an ECO Space, this is probably a DLL mismatch issue!"
sCannotFindStaticTypeSystem | Returns: "Could not find StaticTypeSystem. Please compile the application."
sCannotWriteChangesToDOM | Returns: "Unable to write changes to the source file. Please switch to codeview and back to designer first"
sCircularReference | Returns: "Circular reference"
sClasses | Returns: "Classes"
sClassesInPackage | Returns: "Classes in package:"
sClassLists | Returns: "Class lists"
sConnectedToWrongType | Returns: "Maybe not a RootHandle... This only deals with RootHandles"
sCreateDefaultColumnsVerb | Returns: "Create Default Columns"
sDataTypeLists | Returns: "Data type lists"
sDataTypes | Returns: "Data types"
sEcoSpaceDeclarationNotFound | Returns: "Unable to find a declaration for an ECO Space in this file, perhaps the attribute '[EcoSpace]' has been accidentally removed"
sEcoSpaceNotFound | Returns: "EcoSpace not set. Cannot invoke tool!"
sEcoToolSelectPackagesHint | Returns: "Select &Packages"
SelectionContext | Returns: "Selection"
sElementHandleDesignerTransactionName | Returns: "Updating handle"
sEllipsis | Returns: "..."
sEndOfList | Returns: "<<end>>"
sHandleHasNoClassifier | Returns: "Cannot extract type information from connected handle. Is the handle properly configured?"
sHandleNotFound | Returns: "Unable to find a handle. Is the component connected to a handle?"
sHelpEcoSpaceType | Returns: "Specify the type of the EcoSpace"
sHelpMakePersistent | Returns: "Set persistenceMapper to make system persistent"
sHelpSelectPackages | Returns: "Use the 'Select packages' tool to specify packages for your application"
sInternalError_MissingInterface | Returns: "Internal error, Component does not implement IHasEditableExpression!"
sInternalError_MissingSecondInterface | Returns: "Internal error, Component does not implement IHasSecondEditableExpression!"
sLists | Returns: "Lists"
sLookingForPackagesDone | Returns: "Searching for packages complete."
sLookingForPackagesStart | Returns: "Searching for available packages..."
sNone | Returns: "(none)"
sNotAllComponentsHaveTheSameContext | Returns: "Selected components have different context. Unable to show editor."
sSelectPackage | Returns: "Please select a package first"
sSetsMustHaveNames | Returns: "Sets must have names"
sSpecifyXmlFile | Returns: "Specify file to use for data storage"
sSpecifyXmlMappingFile | Returns: "Specify file containing O/R mapping information"
sToolImplementationMissing | Returns: "Tool implementation missing"
sToolNotFound | Returns: "EcoSpaceTool not found. Requested operation cannot be performed."
sTypesInTheSystem | Returns: "Types in the system"
sUnableToCreateModel | Returns: "Unable to create the model"
sXmlFileFilter | Returns: "XML-files (*.xml)|*.xml|All files (*.*)|*.*"
UMVClassNameEmpty | Returns: "101 Class must have a name"
UMVNoClassesInModel | Returns: "149 Model contains no classes."
UMVRootClassMissing | Returns: "144 Root Class is missing"
UMVUMLModelNotAssigned | Returns: "150 Model information is not assigned"
ValidateForms | Returns: "Validate forms"
ValidationError | Returns: "Error"
ValidationHint | Returns: "Hint"
ValidationWarning | Returns: "Warning"


DesignStringRes.ActionButNoExpression Property

DesignStringRes.ActionButNoExpression Property
DesignStringRes Class DesignStringRes Members Eco.Handles.Design Namespace See Also
Collapse All

Returns: "Action is set to ExecuteAction but no ActionExpression is defined."

C#
public static string ActionButNoExpression;
Remarks

For internal use.

See Also
DesignStringRes Class
DesignStringRes Members
Eco.Handles.Design Namespace


DesignStringRes.CaptionCancel Property

DesignStringRes.CaptionCancel Property
DesignStringRes Class DesignStringRes Members Eco.Handles.Design Namespace See Also
Collapse All

Returns: "Cancel"

C#
public static string CaptionCancel;
Remarks

For internal use.

See Also
DesignStringRes Class
DesignStringRes Members
Eco.Handles.Design Namespace


DesignStringRes.CaptionOK Property

DesignStringRes.CaptionOK Property
DesignStringRes Class DesignStringRes Members Eco.Handles.Design Namespace See Also
Collapse All

Returns: "OK"

C#
public static string CaptionOK;
Remarks

For internal use.

See Also
DesignStringRes Class
DesignStringRes Members
Eco.Handles.Design Namespace


DesignStringRes.EcoSpaceDesignerMessage Property

DesignStringRes.EcoSpaceDesignerMessage Property
DesignStringRes Class DesignStringRes Members Eco.Handles.Design Namespace See Also
Collapse All

Returns: "Always compile your Eco Project after creation!nnTo add components to your EcoSpace, drag them from the Tool Palette and use the Object Inspector to set their properties. Typical components to add to an EcoSpace are PersistenceMappers and database connections.nRemember to connect the EcoSpace to the persistence mapper."

C#
public static string EcoSpaceDesignerMessage;
Remarks

For internal use.

See Also
DesignStringRes Class
DesignStringRes Members
Eco.Handles.Design Namespace


DesignStringRes.EcoSpaceTypeNameMissing Property

DesignStringRes.EcoSpaceTypeNameMissing Property
DesignStringRes Class DesignStringRes Members Eco.Handles.Design Namespace See Also
Collapse All

Returns: "RootHandle has no EcoSpaceTypeName"

C#
public static string EcoSpaceTypeNameMissing;
Remarks

For internal use.

See Also
DesignStringRes Class
DesignStringRes Members
Eco.Handles.Design Namespace


DesignStringRes.EditExpression Property

DesignStringRes.EditExpression Property
DesignStringRes Class DesignStringRes Members Eco.Handles.Design Namespace See Also
Collapse All

Returns: "Edit Expression..."

C#
public static string EditExpression;
Remarks

For internal use.

See Also
DesignStringRes Class
DesignStringRes Members
Eco.Handles.Design Namespace


DesignStringRes.EnterLicenseKey Property

DesignStringRes.EnterLicenseKey Property
DesignStringRes Class DesignStringRes Members Eco.Handles.Design Namespace See Also
Collapse All

Returns: "Enter license key..."

C#
public static string EnterLicenseKey;
Remarks

For internal use.

See Also
DesignStringRes Class
DesignStringRes Members
Eco.Handles.Design Namespace


DesignStringRes.ExpressionForNonDerivedAssoc Property

DesignStringRes.ExpressionForNonDerivedAssoc Property
DesignStringRes Class DesignStringRes Members Eco.Handles.Design Namespace See Also
Collapse All

Returns: "200 Derivation expression specified for non-derived association"

C#
public static string ExpressionForNonDerivedAssoc;
Remarks

For internal use.

See Also
DesignStringRes Class
DesignStringRes Members
Eco.Handles.Design Namespace


DesignStringRes.ExpressionForNonDerivedAttrib Property

DesignStringRes.ExpressionForNonDerivedAttrib Property
DesignStringRes Class DesignStringRes Members Eco.Handles.Design Namespace See Also
Collapse All

Returns: "201 Derivation expression specified for non-derived attribute"

C#
public static string ExpressionForNonDerivedAttrib;
Remarks

For internal use.

See Also
DesignStringRes Class
DesignStringRes Members
Eco.Handles.Design Namespace


DesignStringRes.ExpressionRespecifiedForCodeDerivedAssoc Property

DesignStringRes.ExpressionRespecifiedForCodeDerivedAssoc Property
DesignStringRes Class DesignStringRes Members Eco.Handles.Design Namespace See Also
Collapse All

Returns: "205 Derivation expression respecified for code-derived association end"

C#
public static string ExpressionRespecifiedForCodeDerivedAssoc;
Remarks

For internal use.

See Also
DesignStringRes Class
DesignStringRes Members
Eco.Handles.Design Namespace


DesignStringRes.ExpressionRespecifiedForCodeDerivedAttrib Property

DesignStringRes.ExpressionRespecifiedForCodeDerivedAttrib Property
DesignStringRes Class DesignStringRes Members Eco.Handles.Design Namespace See Also
Collapse All

Returns: "203 Derivation expression respecified for code-derived attribute"

C#
public static string ExpressionRespecifiedForCodeDerivedAttrib;
Remarks

For internal use.

See Also
DesignStringRes Class
DesignStringRes Members
Eco.Handles.Design Namespace


DesignStringRes.ExpressionRespecifiedForNonDerivedAssoc Property

DesignStringRes.ExpressionRespecifiedForNonDerivedAssoc Property
DesignStringRes Class DesignStringRes Members Eco.Handles.Design Namespace See Also
Collapse All

Returns: "204 Derivation expression respecified for non-derived association"

C#
public static string ExpressionRespecifiedForNonDerivedAssoc;
Remarks

For internal use.

See Also
DesignStringRes Class
DesignStringRes Members
Eco.Handles.Design Namespace


DesignStringRes.ExpressionRespecifiedForNonDerivedAttrib Property

DesignStringRes.ExpressionRespecifiedForNonDerivedAttrib Property
DesignStringRes Class DesignStringRes Members Eco.Handles.Design Namespace See Also
Collapse All

Returns: "202 Derivation expression respecified for non-derived attribute"

C#
public static string ExpressionRespecifiedForNonDerivedAttrib;
Remarks

For internal use.

See Also
DesignStringRes Class
DesignStringRes Members
Eco.Handles.Design Namespace


DesignStringRes.FormContext Property

DesignStringRes.FormContext Property
DesignStringRes Class DesignStringRes Members Eco.Handles.Design Namespace See Also
Collapse All

Returns: "Form"

C#
public static string FormContext;
Remarks

For internal use.

See Also
DesignStringRes Class
DesignStringRes Members
Eco.Handles.Design Namespace


DesignStringRes.FormValidation Property

DesignStringRes.FormValidation Property
DesignStringRes Class DesignStringRes Members Eco.Handles.Design Namespace See Also
Collapse All

Returns: "Form validation"

C#
public static string FormValidation;
Remarks

For internal use.

See Also
DesignStringRes Class
DesignStringRes Members
Eco.Handles.Design Namespace


DesignStringRes.FormValidationOK Property

DesignStringRes.FormValidationOK Property
DesignStringRes Class DesignStringRes Members Eco.Handles.Design Namespace See Also
Collapse All

Returns: "Validation complete - no rules broken."

C#
public static string FormValidationOK;
Remarks

For internal use.

See Also
DesignStringRes Class
DesignStringRes Members
Eco.Handles.Design Namespace


DesignStringRes.FormValidationWithError Property

DesignStringRes.FormValidationWithError Property
DesignStringRes Class DesignStringRes Members Eco.Handles.Design Namespace See Also
Collapse All

Returns: "Validation complete - Rules were broken."

C#
public static string FormValidationWithError;
Remarks

For internal use.

See Also
DesignStringRes Class
DesignStringRes Members
Eco.Handles.Design Namespace


DesignStringRes.GlobalContext Property

DesignStringRes.GlobalContext Property
DesignStringRes Class DesignStringRes Members Eco.Handles.Design Namespace See Also
Collapse All

Returns: "Global"

C#
public static string GlobalContext;
Remarks

For internal use.

See Also
DesignStringRes Class
DesignStringRes Members
Eco.Handles.Design Namespace


DesignStringRes.KeyMapperNameMissing Property

DesignStringRes.KeyMapperNameMissing Property
DesignStringRes Class DesignStringRes Members Eco.Handles.Design Namespace See Also
Collapse All

Returns: "[SqlDatabaseConfig] There is an entry in the KeyMappers collection that does not have a name"

C#
public static string KeyMapperNameMissing;
Remarks

For internal use.

See Also
DesignStringRes Class
DesignStringRes Members
Eco.Handles.Design Namespace


DesignStringRes.LogValidatingModel Property

DesignStringRes.LogValidatingModel Property
DesignStringRes Class DesignStringRes Members Eco.Handles.Design Namespace See Also
Collapse All

Returns: "Validating the model"

C#
public static string LogValidatingModel;
Remarks

For internal use.

See Also
DesignStringRes Class
DesignStringRes Members
Eco.Handles.Design Namespace


DesignStringRes.MenuCaption_Settings Property

DesignStringRes.MenuCaption_Settings Property
DesignStringRes Class DesignStringRes Members Eco.Handles.Design Namespace See Also
Collapse All

Returns: "Settings..."

C#
public static string MenuCaption_Settings;
Remarks

For internal use.

See Also
DesignStringRes Class
DesignStringRes Members
Eco.Handles.Design Namespace


DesignStringRes.ModelValidation Property

DesignStringRes.ModelValidation Property
DesignStringRes Class DesignStringRes Members Eco.Handles.Design Namespace See Also
Collapse All

Returns: "Model validation"

C#
public static string ModelValidation;
Remarks

For internal use.

See Also
DesignStringRes Class
DesignStringRes Members
Eco.Handles.Design Namespace


DesignStringRes.MsgError Property

DesignStringRes.MsgError Property
DesignStringRes Class DesignStringRes Members Eco.Handles.Design Namespace See Also
Collapse All

Returns: "Error"

C#
public static string MsgError;
Remarks

For internal use.

See Also
DesignStringRes Class
DesignStringRes Members
Eco.Handles.Design Namespace


DesignStringRes.MsgException Property

DesignStringRes.MsgException Property
DesignStringRes Class DesignStringRes Members Eco.Handles.Design Namespace See Also
Collapse All

Returns: "Exception"

C#
public static string MsgException;
Remarks

For internal use.

See Also
DesignStringRes Class
DesignStringRes Members
Eco.Handles.Design Namespace


DesignStringRes.MsgInternalError Property

DesignStringRes.MsgInternalError Property
DesignStringRes Class DesignStringRes Members Eco.Handles.Design Namespace See Also
Collapse All

Returns: "Internal error"

C#
public static string MsgInternalError;
Remarks

For internal use.

See Also
DesignStringRes Class
DesignStringRes Members
Eco.Handles.Design Namespace


DesignStringRes.NoActionSpecified Property

DesignStringRes.NoActionSpecified Property
DesignStringRes Class DesignStringRes Members Eco.Handles.Design Namespace See Also
Collapse All

Returns: "Action not specified."

C#
public static string NoActionSpecified;
Remarks

For internal use.

See Also
DesignStringRes Class
DesignStringRes Members
Eco.Handles.Design Namespace


DesignStringRes.NoBindingContext Property

DesignStringRes.NoBindingContext Property
DesignStringRes Class DesignStringRes Members Eco.Handles.Design Namespace See Also
Collapse All

Returns: "BindingContext not specified."

C#
public static string NoBindingContext;
Remarks

For internal use.

See Also
DesignStringRes Class
DesignStringRes Members
Eco.Handles.Design Namespace


DesignStringRes.NoRootHandleSet Property

DesignStringRes.NoRootHandleSet Property
DesignStringRes Class DesignStringRes Members Eco.Handles.Design Namespace See Also
Collapse All

Returns: "RootHandle is not specified."

C#
public static string NoRootHandleSet;
Remarks

For internal use.

See Also
DesignStringRes Class
DesignStringRes Members
Eco.Handles.Design Namespace


DesignStringRes.NoStaticEvaluationServiceProbableCause Property

DesignStringRes.NoStaticEvaluationServiceProbableCause Property
DesignStringRes Class DesignStringRes Members Eco.Handles.Design Namespace See Also
Collapse All

Returns: "Probably related to some problem with the uplink component."

C#
public static string NoStaticEvaluationServiceProbableCause;
Remarks

For internal use.

See Also
DesignStringRes Class
DesignStringRes Members
Eco.Handles.Design Namespace


DesignStringRes.OpenEcoDatatypesXmlCaption Property

DesignStringRes.OpenEcoDatatypesXmlCaption Property
DesignStringRes Class DesignStringRes Members Eco.Handles.Design Namespace See Also
Collapse All

Returns: "Open EcoDatatypes.xml"

C#
public static string OpenEcoDatatypesXmlCaption;
Remarks

For internal use.

See Also
DesignStringRes Class
DesignStringRes Members
Eco.Handles.Design Namespace


DesignStringRes.PersistenceMapperProviderDesignerMessage Property

DesignStringRes.PersistenceMapperProviderDesignerMessage Property
DesignStringRes Class DesignStringRes Members Eco.Handles.Design Namespace See Also
Collapse All

Returns: "To add components to your PersistenceMapperProvider, drag them from the Tool Palette and use the Object Inspector to set their properties. Typical components to add to a PersistenceMapperProvider include persistence mapper and database connections.nRemember to connect the PersistenceMapperProvider to the EcoSpace type."

C#
public static string PersistenceMapperProviderDesignerMessage;
Remarks

For internal use.

See Also
DesignStringRes Class
DesignStringRes Members
Eco.Handles.Design Namespace


DesignStringRes.PMapperNameMissing Property

DesignStringRes.PMapperNameMissing Property
DesignStringRes Class DesignStringRes Members Eco.Handles.Design Namespace See Also
Collapse All

Returns: "[SqlDatabaseConfig] There is an entry in the PersistenceMappers collection that does not have a name"

C#
public static string PMapperNameMissing;
Remarks

For internal use.

See Also
DesignStringRes Class
DesignStringRes Members
Eco.Handles.Design Namespace


DesignStringRes.PropertyNotFound Property

DesignStringRes.PropertyNotFound Property
DesignStringRes Class DesignStringRes Members Eco.Handles.Design Namespace See Also
Collapse All

Returns: "Specified property not available for setting. Something may be wrong with the configuration file."

C#
public static string PropertyNotFound;
Remarks

For internal use.

See Also
DesignStringRes Class
DesignStringRes Members
Eco.Handles.Design Namespace


DesignStringRes.RefreshContextAgentXML Property

DesignStringRes.RefreshContextAgentXML Property
DesignStringRes Class DesignStringRes Members Eco.Handles.Design Namespace See Also
Collapse All

Returns: "Refresh ContextAgent XML"

C#
public static string RefreshContextAgentXML;
Remarks

For internal use.

See Also
DesignStringRes Class
DesignStringRes Members
Eco.Handles.Design Namespace


DesignStringRes.sAttributeLists Property

DesignStringRes.sAttributeLists Property
DesignStringRes Class DesignStringRes Members Eco.Handles.Design Namespace See Also
Collapse All

Returns: "Attribute lists"

C#
public static string sAttributeLists;
Remarks

For internal use.

See Also
DesignStringRes Class
DesignStringRes Members
Eco.Handles.Design Namespace


DesignStringRes.sAttributes Property

DesignStringRes.sAttributes Property
DesignStringRes Class DesignStringRes Members Eco.Handles.Design Namespace See Also
Collapse All

Returns: "Attributes"

C#
public static string sAttributes;
Remarks

For internal use.

See Also
DesignStringRes Class
DesignStringRes Members
Eco.Handles.Design Namespace


DesignStringRes.sAutoCompileFailed Property

DesignStringRes.sAutoCompileFailed Property
DesignStringRes Class DesignStringRes Members Eco.Handles.Design Namespace See Also
Collapse All

Returns: "Compile failed. Operation aborted"

C#
public static string sAutoCompileFailed;
Remarks

For internal use.

See Also
DesignStringRes Class
DesignStringRes Members
Eco.Handles.Design Namespace


DesignStringRes.sAutoCompileRecommended Property

DesignStringRes.sAutoCompileRecommended Property
DesignStringRes Class DesignStringRes Members Eco.Handles.Design Namespace See Also
Collapse All

Returns: "Recompilation recommended!"

C#
public static string sAutoCompileRecommended;
Remarks

For internal use.

See Also
DesignStringRes Class
DesignStringRes Members
Eco.Handles.Design Namespace


DesignStringRes.sBinariesWrong Property

DesignStringRes.sBinariesWrong Property
DesignStringRes Class DesignStringRes Members Eco.Handles.Design Namespace See Also
Collapse All

Returns: "The current code is not compiled. nModel information may be out of date and produce unexpected results. nDo you want to recompile now? n(You can set autocompile via Tools | Options | ECO General Options)"

C#
public static string sBinariesWrong;
Remarks

For internal use.

See Also
DesignStringRes Class
DesignStringRes Members
Eco.Handles.Design Namespace


DesignStringRes.sCannotFindDll Property

DesignStringRes.sCannotFindDll Property
DesignStringRes Class DesignStringRes Members Eco.Handles.Design Namespace See Also
Collapse All

Returns: "Internal Error. Unable to find an ECO Space, this is probably a DLL mismatch issue!"

C#
public static string sCannotFindDll;
Remarks

For internal use.

See Also
DesignStringRes Class
DesignStringRes Members
Eco.Handles.Design Namespace


DesignStringRes.sCannotFindStaticTypeSystem Property

DesignStringRes.sCannotFindStaticTypeSystem Property
DesignStringRes Class DesignStringRes Members Eco.Handles.Design Namespace See Also
Collapse All

Returns: "Could not find StaticTypeSystem. Please compile the application."

C#
public static string sCannotFindStaticTypeSystem;
Remarks

For internal use.

See Also
DesignStringRes Class
DesignStringRes Members
Eco.Handles.Design Namespace


DesignStringRes.sCannotWriteChangesToDOM Property

DesignStringRes.sCannotWriteChangesToDOM Property
DesignStringRes Class DesignStringRes Members Eco.Handles.Design Namespace See Also
Collapse All

Returns: "Unable to write changes to the source file. Please switch to codeview and back to designer first"

C#
public static string sCannotWriteChangesToDOM;
Remarks

For internal use.

See Also
DesignStringRes Class
DesignStringRes Members
Eco.Handles.Design Namespace


DesignStringRes.sCircularReference Property

DesignStringRes.sCircularReference Property
DesignStringRes Class DesignStringRes Members Eco.Handles.Design Namespace See Also
Collapse All

Returns: "Circular reference"

C#
public static string sCircularReference;
Remarks

For internal use.

See Also
DesignStringRes Class
DesignStringRes Members
Eco.Handles.Design Namespace


DesignStringRes.sClasses Property

DesignStringRes.sClasses Property
DesignStringRes Class DesignStringRes Members Eco.Handles.Design Namespace See Also
Collapse All

Returns: "Classes"

C#
public static string sClasses;
Remarks

For internal use.

See Also
DesignStringRes Class
DesignStringRes Members
Eco.Handles.Design Namespace


DesignStringRes.sClassesInPackage Property

DesignStringRes.sClassesInPackage Property
DesignStringRes Class DesignStringRes Members Eco.Handles.Design Namespace See Also
Collapse All

Returns: "Classes in package:"

C#
public static string sClassesInPackage;
Remarks

For internal use.

See Also
DesignStringRes Class
DesignStringRes Members
Eco.Handles.Design Namespace


DesignStringRes.sClassLists Property

DesignStringRes.sClassLists Property
DesignStringRes Class DesignStringRes Members Eco.Handles.Design Namespace See Also
Collapse All

Returns: "Class lists"

C#
public static string sClassLists;
Remarks

For internal use.

See Also
DesignStringRes Class
DesignStringRes Members
Eco.Handles.Design Namespace


DesignStringRes.sConnectedToWrongType Property

DesignStringRes.sConnectedToWrongType Property
DesignStringRes Class DesignStringRes Members Eco.Handles.Design Namespace See Also
Collapse All

Returns: "Maybe not a RootHandle... This only deals with RootHandles"

C#
public static string sConnectedToWrongType;
Remarks

For internal use.

See Also
DesignStringRes Class
DesignStringRes Members
Eco.Handles.Design Namespace


DesignStringRes.sCreateDefaultColumnsVerb Property

DesignStringRes.sCreateDefaultColumnsVerb Property
DesignStringRes Class DesignStringRes Members Eco.Handles.Design Namespace See Also
Collapse All

Returns: "Create Default Columns"

C#
public static string sCreateDefaultColumnsVerb;
Remarks

For internal use.

See Also
DesignStringRes Class
DesignStringRes Members
Eco.Handles.Design Namespace


DesignStringRes.sDataTypeLists Property

DesignStringRes.sDataTypeLists Property
DesignStringRes Class DesignStringRes Members Eco.Handles.Design Namespace See Also
Collapse All

Returns: "Data type lists"

C#
public static string sDataTypeLists;
Remarks

For internal use.

See Also
DesignStringRes Class
DesignStringRes Members
Eco.Handles.Design Namespace


DesignStringRes.sDataTypes Property

DesignStringRes.sDataTypes Property
DesignStringRes Class DesignStringRes Members Eco.Handles.Design Namespace See Also
Collapse All

Returns: "Data types"

C#
public static string sDataTypes;
Remarks

For internal use.

See Also
DesignStringRes Class
DesignStringRes Members
Eco.Handles.Design Namespace


DesignStringRes.sEcoSpaceDeclarationNotFound Property

DesignStringRes.sEcoSpaceDeclarationNotFound Property
DesignStringRes Class DesignStringRes Members Eco.Handles.Design Namespace See Also
Collapse All

Returns: "Unable to find a declaration for an ECO Space in this file, perhaps the attribute '[EcoSpace]' has been accidentally removed"

C#
public static string sEcoSpaceDeclarationNotFound;
Remarks

For internal use.

See Also
DesignStringRes Class
DesignStringRes Members
Eco.Handles.Design Namespace


DesignStringRes.sEcoSpaceNotFound Property

DesignStringRes.sEcoSpaceNotFound Property
DesignStringRes Class DesignStringRes Members Eco.Handles.Design Namespace See Also
Collapse All

Returns: "EcoSpace not set. Cannot invoke tool!"

C#
public static string sEcoSpaceNotFound;
Remarks

For internal use.

See Also
DesignStringRes Class
DesignStringRes Members
Eco.Handles.Design Namespace


DesignStringRes.sEcoToolSelectPackagesHint Property

DesignStringRes.sEcoToolSelectPackagesHint Property
DesignStringRes Class DesignStringRes Members Eco.Handles.Design Namespace See Also
Collapse All

Returns: "Select &Packages"

C#
public static string sEcoToolSelectPackagesHint;
Remarks

For internal use.

See Also
DesignStringRes Class
DesignStringRes Members
Eco.Handles.Design Namespace


DesignStringRes.SelectionContext Property

DesignStringRes.SelectionContext Property
DesignStringRes Class DesignStringRes Members Eco.Handles.Design Namespace See Also
Collapse All

Returns: "Selection"

C#
public static string SelectionContext;
Remarks

For internal use.

See Also
DesignStringRes Class
DesignStringRes Members
Eco.Handles.Design Namespace


DesignStringRes.sElementHandleDesignerTransactionName Property

DesignStringRes.sElementHandleDesignerTransactionName Property
DesignStringRes Class DesignStringRes Members Eco.Handles.Design Namespace See Also
Collapse All

Returns: "Updating handle"

C#
public static string sElementHandleDesignerTransactionName;
Remarks

For internal use.

See Also
DesignStringRes Class
DesignStringRes Members
Eco.Handles.Design Namespace


DesignStringRes.sEllipsis Property

DesignStringRes.sEllipsis Property
DesignStringRes Class DesignStringRes Members Eco.Handles.Design Namespace See Also
Collapse All

Returns: "..."

C#
public static string sEllipsis;
Remarks

For internal use.

See Also
DesignStringRes Class
DesignStringRes Members
Eco.Handles.Design Namespace


DesignStringRes.sEndOfList Property

DesignStringRes.sEndOfList Property
DesignStringRes Class DesignStringRes Members Eco.Handles.Design Namespace See Also
Collapse All

Returns: "<<end>>"

C#
public static string sEndOfList;
Remarks

For internal use.

See Also
DesignStringRes Class
DesignStringRes Members
Eco.Handles.Design Namespace


DesignStringRes.sHandleHasNoClassifier Property

DesignStringRes.sHandleHasNoClassifier Property
DesignStringRes Class DesignStringRes Members Eco.Handles.Design Namespace See Also
Collapse All

Returns: "Cannot extract type information from connected handle. Is the handle properly configured?"

C#
public static string sHandleHasNoClassifier;
Remarks

For internal use.

See Also
DesignStringRes Class
DesignStringRes Members
Eco.Handles.Design Namespace


DesignStringRes.sHandleNotFound Property

DesignStringRes.sHandleNotFound Property
DesignStringRes Class DesignStringRes Members Eco.Handles.Design Namespace See Also
Collapse All

Returns: "Unable to find a handle. Is the component connected to a handle?"

C#
public static string sHandleNotFound;
Remarks

For internal use.

See Also
DesignStringRes Class
DesignStringRes Members
Eco.Handles.Design Namespace


DesignStringRes.sHelpEcoSpaceType Property

DesignStringRes.sHelpEcoSpaceType Property
DesignStringRes Class DesignStringRes Members Eco.Handles.Design Namespace See Also
Collapse All

Returns: "Specify the type of the EcoSpace"

C#
public static string sHelpEcoSpaceType;
Remarks

For internal use.

See Also
DesignStringRes Class
DesignStringRes Members
Eco.Handles.Design Namespace


DesignStringRes.sHelpMakePersistent Property

DesignStringRes.sHelpMakePersistent Property
DesignStringRes Class DesignStringRes Members Eco.Handles.Design Namespace See Also
Collapse All

Returns: "Set persistenceMapper to make system persistent"

C#
public static string sHelpMakePersistent;
Remarks

For internal use.

See Also
DesignStringRes Class
DesignStringRes Members
Eco.Handles.Design Namespace


DesignStringRes.sHelpSelectPackages Property

DesignStringRes.sHelpSelectPackages Property
DesignStringRes Class DesignStringRes Members Eco.Handles.Design Namespace See Also
Collapse All

Returns: "Use the 'Select packages' tool to specify packages for your application"

C#
public static string sHelpSelectPackages;
Remarks

For internal use.

See Also
DesignStringRes Class
DesignStringRes Members
Eco.Handles.Design Namespace


DesignStringRes.sInternalError_MissingInterface Property

DesignStringRes.sInternalError_MissingInterface Property
DesignStringRes Class DesignStringRes Members Eco.Handles.Design Namespace See Also
Collapse All

Returns: "Internal error, Component does not implement IHasEditableExpression!"

C#
public static string sInternalError_MissingInterface;
Remarks

For internal use.

See Also
DesignStringRes Class
DesignStringRes Members
Eco.Handles.Design Namespace


DesignStringRes.sInternalError_MissingSecondInterface Property

DesignStringRes.sInternalError_MissingSecondInterface Property
DesignStringRes Class DesignStringRes Members Eco.Handles.Design Namespace See Also
Collapse All

Returns: "Internal error, Component does not implement IHasSecondEditableExpression!"

C#
public static string sInternalError_MissingSecondInterface;
Remarks

For internal use.

See Also
DesignStringRes Class
DesignStringRes Members
Eco.Handles.Design Namespace


DesignStringRes.sLists Property

DesignStringRes.sLists Property
DesignStringRes Class DesignStringRes Members Eco.Handles.Design Namespace See Also
Collapse All

Returns: "Lists"

C#
public static string sLists;
Remarks

For internal use.

See Also
DesignStringRes Class
DesignStringRes Members
Eco.Handles.Design Namespace


DesignStringRes.sLookingForPackagesDone Property

DesignStringRes.sLookingForPackagesDone Property
DesignStringRes Class DesignStringRes Members Eco.Handles.Design Namespace See Also
Collapse All

Returns: "Searching for packages complete."

C#
public static string sLookingForPackagesDone;
Remarks

For internal use.

See Also
DesignStringRes Class
DesignStringRes Members
Eco.Handles.Design Namespace


DesignStringRes.sLookingForPackagesStart Property

DesignStringRes.sLookingForPackagesStart Property
DesignStringRes Class DesignStringRes Members Eco.Handles.Design Namespace See Also
Collapse All

Returns: "Searching for available packages..."

C#
public static string sLookingForPackagesStart;
Remarks

For internal use.

See Also
DesignStringRes Class
DesignStringRes Members
Eco.Handles.Design Namespace


DesignStringRes.sNone Property

DesignStringRes.sNone Property
DesignStringRes Class DesignStringRes Members Eco.Handles.Design Namespace See Also
Collapse All

Returns: "(none)"

C#
public static string sNone;
Remarks

For internal use.

See Also
DesignStringRes Class
DesignStringRes Members
Eco.Handles.Design Namespace


DesignStringRes.sNotAllComponentsHaveTheSameContext Property

DesignStringRes.sNotAllComponentsHaveTheSameContext Property
DesignStringRes Class DesignStringRes Members Eco.Handles.Design Namespace See Also
Collapse All

Returns: "Selected components have different context. Unable to show editor."

C#
public static string sNotAllComponentsHaveTheSameContext;
Remarks

For internal use.

See Also
DesignStringRes Class
DesignStringRes Members
Eco.Handles.Design Namespace


DesignStringRes.sSelectPackage Property

DesignStringRes.sSelectPackage Property
DesignStringRes Class DesignStringRes Members Eco.Handles.Design Namespace See Also
Collapse All

Returns: "Please select a package first"

C#
public static string sSelectPackage;
Remarks

For internal use.

See Also
DesignStringRes Class
DesignStringRes Members
Eco.Handles.Design Namespace


DesignStringRes.sSetsMustHaveNames Property

DesignStringRes.sSetsMustHaveNames Property
DesignStringRes Class DesignStringRes Members Eco.Handles.Design Namespace See Also
Collapse All

Returns: "Sets must have names"

C#
public static string sSetsMustHaveNames;
Remarks

For internal use.

See Also
DesignStringRes Class
DesignStringRes Members
Eco.Handles.Design Namespace


DesignStringRes.sSpecifyXmlFile Property

DesignStringRes.sSpecifyXmlFile Property
DesignStringRes Class DesignStringRes Members Eco.Handles.Design Namespace See Also
Collapse All

Returns: "Specify file to use for data storage"

C#
public static string sSpecifyXmlFile;
Remarks

For internal use.

See Also
DesignStringRes Class
DesignStringRes Members
Eco.Handles.Design Namespace


DesignStringRes.sSpecifyXmlMappingFile Property

DesignStringRes.sSpecifyXmlMappingFile Property
DesignStringRes Class DesignStringRes Members Eco.Handles.Design Namespace See Also
Collapse All

Returns: "Specify file containing O/R mapping information"

C#
public static string sSpecifyXmlMappingFile;
Remarks

For internal use.

See Also
DesignStringRes Class
DesignStringRes Members
Eco.Handles.Design Namespace


DesignStringRes.sToolImplementationMissing Property

DesignStringRes.sToolImplementationMissing Property
DesignStringRes Class DesignStringRes Members Eco.Handles.Design Namespace See Also
Collapse All

Returns: "Tool implementation missing"

C#
public static string sToolImplementationMissing;
Remarks

For internal use.

See Also
DesignStringRes Class
DesignStringRes Members
Eco.Handles.Design Namespace


DesignStringRes.sToolNotFound Property

DesignStringRes.sToolNotFound Property
DesignStringRes Class DesignStringRes Members Eco.Handles.Design Namespace See Also
Collapse All

Returns: "EcoSpaceTool not found. Requested operation cannot be performed."

C#
public static string sToolNotFound;
Remarks

For internal use.

See Also
DesignStringRes Class
DesignStringRes Members
Eco.Handles.Design Namespace


DesignStringRes.sTypesInTheSystem Property

DesignStringRes.sTypesInTheSystem Property
DesignStringRes Class DesignStringRes Members Eco.Handles.Design Namespace See Also
Collapse All

Returns: "Types in the system"

C#
public static string sTypesInTheSystem;
Remarks

For internal use.

See Also
DesignStringRes Class
DesignStringRes Members
Eco.Handles.Design Namespace


DesignStringRes.sUnableToCreateModel Property

DesignStringRes.sUnableToCreateModel Property
DesignStringRes Class DesignStringRes Members Eco.Handles.Design Namespace See Also
Collapse All

Returns: "Unable to create the model"

C#
public static string sUnableToCreateModel;
Remarks

For internal use.

See Also
DesignStringRes Class
DesignStringRes Members
Eco.Handles.Design Namespace


DesignStringRes.sXmlFileFilter Property

DesignStringRes.sXmlFileFilter Property
DesignStringRes Class DesignStringRes Members Eco.Handles.Design Namespace See Also
Collapse All

Returns: "XML-files (*.xml)|*.xml|All files (*.*)|*.*"

C#
public static string sXmlFileFilter;
Remarks

For internal use.

See Also
DesignStringRes Class
DesignStringRes Members
Eco.Handles.Design Namespace


DesignStringRes.UMVClassNameEmpty Property

DesignStringRes.UMVClassNameEmpty Property
DesignStringRes Class DesignStringRes Members Eco.Handles.Design Namespace See Also
Collapse All

Returns: "101 Class must have a name"

C#
public static string UMVClassNameEmpty;
Remarks

For internal use.

See Also
DesignStringRes Class
DesignStringRes Members
Eco.Handles.Design Namespace


DesignStringRes.UMVNoClassesInModel Property

DesignStringRes.UMVNoClassesInModel Property
DesignStringRes Class DesignStringRes Members Eco.Handles.Design Namespace See Also
Collapse All

Returns: "149 Model contains no classes."

C#
public static string UMVNoClassesInModel;
Remarks

For internal use.

See Also
DesignStringRes Class
DesignStringRes Members
Eco.Handles.Design Namespace


DesignStringRes.UMVRootClassMissing Property

DesignStringRes.UMVRootClassMissing Property
DesignStringRes Class DesignStringRes Members Eco.Handles.Design Namespace See Also
Collapse All

Returns: "144 Root Class is missing"

C#
public static string UMVRootClassMissing;
Remarks

For internal use.

See Also
DesignStringRes Class
DesignStringRes Members
Eco.Handles.Design Namespace


DesignStringRes.UMVUMLModelNotAssigned Property

DesignStringRes.UMVUMLModelNotAssigned Property
DesignStringRes Class DesignStringRes Members Eco.Handles.Design Namespace See Also
Collapse All

Returns: "150 Model information is not assigned"

C#
public static string UMVUMLModelNotAssigned;
Remarks

For internal use.

See Also
DesignStringRes Class
DesignStringRes Members
Eco.Handles.Design Namespace


DesignStringRes.ValidateForms Property

DesignStringRes.ValidateForms Property
DesignStringRes Class DesignStringRes Members Eco.Handles.Design Namespace See Also
Collapse All

Returns: "Validate forms"

C#
public static string ValidateForms;
Remarks

For internal use.

See Also
DesignStringRes Class
DesignStringRes Members
Eco.Handles.Design Namespace


DesignStringRes.ValidationError Property

DesignStringRes.ValidationError Property
DesignStringRes Class DesignStringRes Members Eco.Handles.Design Namespace See Also
Collapse All

Returns: "Error"

C#
public static string ValidationError;
Remarks

For internal use.

See Also
DesignStringRes Class
DesignStringRes Members
Eco.Handles.Design Namespace


DesignStringRes.ValidationHint Property

DesignStringRes.ValidationHint Property
DesignStringRes Class DesignStringRes Members Eco.Handles.Design Namespace See Also
Collapse All

Returns: "Hint"

C#
public static string ValidationHint;
Remarks

For internal use.

See Also
DesignStringRes Class
DesignStringRes Members
Eco.Handles.Design Namespace


DesignStringRes.ValidationWarning Property

DesignStringRes.ValidationWarning Property
DesignStringRes Class DesignStringRes Members Eco.Handles.Design Namespace See Also
Collapse All

Returns: "Warning"

C#
public static string ValidationWarning;
Remarks

For internal use.

See Also
DesignStringRes Class
DesignStringRes Members
Eco.Handles.Design Namespace


DesignTimeLogger Class

DesignTimeLogger Class
DesignTimeLogger Members Inheritance Hierarchy See Also
Collapse All

Singleton class used to perform design time initialization code.

C#
public sealed class DesignTimeLogger;
Inheritance Hierarchy
Eco.Handles.Design.DesignTimeLogger
File

DesignTimeLogger.cs

See Also
DesignTimeLogger Members
Inheritance Hierarchy


DesignTimeLogger Members

DesignTimeLogger Members
Public Methods
Collapse All

The following tables list the members exposed by DesignTimeLogger.

Public Methods
Name | Description
Initialize | Called during IDE startup to execute initialization code.


DesignTimeLogger Methods

DesignTimeLogger Methods
Public Methods
Collapse All

The methods of the DesignTimeLogger class are listed here.

Public Methods
Name | Description
Initialize | Called during IDE startup to execute initialization code.


DesignTimeLogger.Initialize Method

DesignTimeLogger.Initialize Method
DesignTimeLogger Class DesignTimeLogger Members Eco.Handles.Design Namespace See Also
Collapse All

Called during IDE startup to execute initialization code.

C#
public static void Initialize();
Remarks

This method registers the design time logging facility (that uses the IDE's message display facilities).

See Also
DesignTimeLogger Class
DesignTimeLogger Members
Eco.Handles.Design Namespace


EcoAboutMenuItem Class

EcoAboutMenuItem Class
EcoAboutMenuItem Members Inheritance Hierarchy See Also
Collapse All
C#
public class EcoAboutMenuItem;
Remarks

This is class Eco.Handles.Design.EcoAboutMenuItem.

Inheritance Hierarchy
Eco.Handles.Design.EcoAboutMenuItem
File

Eco.Handles.Design.AboutForm.cs

See Also
EcoAboutMenuItem Members
Inheritance Hierarchy


EcoAboutMenuItem Members

EcoAboutMenuItem Members
Public Methods
Collapse All

The following tables list the members exposed by EcoAboutMenuItem.

Public Methods
Name | Description
Register | This is Register, a member of class EcoAboutMenuItem.


EcoAboutMenuItem Methods

EcoAboutMenuItem Methods
Public Methods
Collapse All

The methods of the EcoAboutMenuItem class are listed here.

Public Methods
Name | Description
Register | This is Register, a member of class EcoAboutMenuItem.


EcoAboutMenuItem.Register Method

EcoAboutMenuItem.Register Method
EcoAboutMenuItem Class EcoAboutMenuItem Members Eco.Handles.Design Namespace See Also
Collapse All
C#
public static void Register();
Remarks

This is Register, a member of class EcoAboutMenuItem.

See Also
EcoAboutMenuItem Class
EcoAboutMenuItem Members
Eco.Handles.Design Namespace


EcoActionExtenderDesigner Class

EcoActionExtenderDesigner Class
Inheritance Hierarchy See Also
Collapse All

Designer for EcoActionExtender.

C#
internal class EcoActionExtenderDesigner : NotifyingDesigner;
Inheritance Hierarchy
Eco.Handles.Design.NotifyingDesigner
    Eco.Handles.Design.EcoActionExtenderDesigner
File

Editors.cs

See Also
Inheritance Hierarchy


EcoDatatypesMenuItem Class

EcoDatatypesMenuItem Class
EcoDatatypesMenuItem Members Inheritance Hierarchy See Also
Collapse All
C#
public class EcoDatatypesMenuItem;
Remarks

, "Eco.Handles.Design.EcoDatatypesMenuItem.bmp")

Inheritance Hierarchy
Eco.Handles.Design.EcoDatatypesMenuItem
File

EcoDatatypesMenuItem.cs

See Also
EcoDatatypesMenuItem Members
Inheritance Hierarchy


EcoDatatypesMenuItem Members

EcoDatatypesMenuItem Members
Public Methods
Collapse All

The following tables list the members exposed by EcoDatatypesMenuItem.

Public Methods
Name | Description
Register | This is Register, a member of class EcoDatatypesMenuItem.


EcoDatatypesMenuItem Methods

EcoDatatypesMenuItem Methods
Public Methods
Collapse All

The methods of the EcoDatatypesMenuItem class are listed here.

Public Methods
Name | Description
Register | This is Register, a member of class EcoDatatypesMenuItem.


EcoDatatypesMenuItem.Register Method

EcoDatatypesMenuItem.Register Method
EcoDatatypesMenuItem Class EcoDatatypesMenuItem Members Eco.Handles.Design Namespace See Also
Collapse All
C#
public static void Register();
Remarks

This is Register, a member of class EcoDatatypesMenuItem.

See Also
EcoDatatypesMenuItem Class
EcoDatatypesMenuItem Members
Eco.Handles.Design Namespace


EcoDesigner Class

EcoDesigner Class
EcoDesigner Members Inheritance Hierarchy See Also
Collapse All

Base class for the EcoSpaceDesigner and PersistenceMapperProviderDesigner. This class provides the infrastructure for plugging in tools, task hints and hooking up dropped components.

C#
public abstract class EcoDesigner : System.Windows.Forms.Design.ComponentDocumentDesigner;
Inheritance Hierarchy
Eco.Handles.Design.EcoDesigner
    Eco.Handles.Design.EcoSpaceDesigner
File

EcoDesigner.cs

See Also
EcoDesigner Members
Inheritance Hierarchy


EcoDesigner Members

EcoDesigner Members
Protected Methods Public Methods Public Properties Protected internal Methods Protected internal Properties
Collapse All

The following tables list the members exposed by EcoDesigner.

Protected Methods
Name | Description
ComponentRemoved | Override this method to act on the removal of a specific component. Typically used for disconnection of properties
EcoDesigner | This is EcoDesigner, a member of class EcoDesigner.
HookupCandidates | If there is only one potential candidate in the collection, hook it up.
HookupComponent | If hookable can be hooked up with component, do it.
LabelCaption | This abstract method MUST be overriden to provide a text in the middle of the designer
PerformAutoHookup | override this method to implement hookup logic. Typically this will be see which component has been dropped and you'll set some properties triggered by that.
Top
Public Methods
Name | Description
Initialize | This method performs some basic setup, like adding the toolbar for the tools, hooking events for controls added and removed etc.
Top
Public Properties
Name | Description
Verbs | Builds a verb collection from the tools registered in the EcoSpaceDesignerToolbox that are registered for the type of the executing instance of the designer.
Top
Protected internal Methods
Name | Description
DesignerType | This method must be implemented to return the type of the designer.
Top
Protected internal Properties
Name | Description
DesignedComponent | This abstract property helps provide an EcoSpace when required for Tool invocation. Some designer might not have an EcoSpace at hand at creation time.


EcoDesigner.EcoDesigner Constructor

EcoDesigner.EcoDesigner Constructor
EcoDesigner Class EcoDesigner Members Eco.Handles.Design Namespace See Also
Collapse All
C#
protected EcoDesigner();
Remarks

This is EcoDesigner, a member of class EcoDesigner.

See Also
EcoDesigner Class
EcoDesigner Members
Eco.Handles.Design Namespace


EcoDesigner Methods

EcoDesigner Methods
Protected Methods Public Methods Protected internal Methods
Collapse All

The methods of the EcoDesigner class are listed here.

Protected Methods
Name | Description
ComponentRemoved | Override this method to act on the removal of a specific component. Typically used for disconnection of properties
HookupCandidates | If there is only one potential candidate in the collection, hook it up.
HookupComponent | If hookable can be hooked up with component, do it.
LabelCaption | This abstract method MUST be overriden to provide a text in the middle of the designer
PerformAutoHookup | override this method to implement hookup logic. Typically this will be see which component has been dropped and you'll set some properties triggered by that.
Top
Public Methods
Name | Description
Initialize | This method performs some basic setup, like adding the toolbar for the tools, hooking events for controls added and removed etc.
Top
Protected internal Methods
Name | Description
DesignerType | This method must be implemented to return the type of the designer.


EcoDesigner.ComponentRemoved Method

EcoDesigner.ComponentRemoved Method
EcoDesigner Class EcoDesigner Members Eco.Handles.Design Namespace See Also
Collapse All

Override this method to act on the removal of a specific component. Typically used for disconnection of properties

C#
protected virtual void ComponentRemoved(
    Component removedComponent
);
See Also
EcoDesigner Class
EcoDesigner Members
Eco.Handles.Design Namespace


EcoDesigner.DesignerType Method

EcoDesigner.DesignerType Method
EcoDesigner Class EcoDesigner Members Eco.Handles.Design Namespace See Also
Collapse All

This method must be implemented to return the type of the designer.

C#
protected internal abstract DesignerTypes DesignerType();
See Also
EcoDesigner Class
EcoDesigner Members
Eco.Handles.Design Namespace


EcoDesigner.HookupCandidates Method

EcoDesigner.HookupCandidates Method
EcoDesigner Class EcoDesigner Members Eco.Handles.Design Namespace See Also
Collapse All

If there is only one potential candidate in the collection, hook it up.

C#
protected void HookupCandidates(
    IAutoHookable hookable,
    ComponentCollection components
);
Parameters
Parameters | Description
hookable | The component that has the property that will be altered.
components | List of candidate components.
Remarks

The components list is traversed, and the number of potential candidates for hooking up (hookable.CanHookup()) is counted. If the count is exactly one, perform the AutoHookup.

See Also
EcoDesigner Class
EcoDesigner Members
Eco.Handles.Design Namespace


EcoDesigner.HookupComponent Method

EcoDesigner.HookupComponent Method
EcoDesigner Class EcoDesigner Members Eco.Handles.Design Namespace See Also
Collapse All

If hookable can be hooked up with component, do it.

C#
protected void HookupComponent(
    IAutoHookable hookable,
    Component component
);
Parameters
Parameters | Description
hookable | The component that has the property that will be altered.
component | The component that is typically dropped on the form that a previously existing component can be hooked up with.
Remarks

Since the hooking up is completely abstracted, this method can be widely reused.

See Also
EcoDesigner Class
EcoDesigner Members
Eco.Handles.Design Namespace


EcoDesigner.Initialize Method

EcoDesigner.Initialize Method
EcoDesigner Class EcoDesigner Members Eco.Handles.Design Namespace See Also
Collapse All

This method performs some basic setup, like adding the toolbar for the tools, hooking events for controls added and removed etc.

C#
public override void Initialize(
    IComponent component
);
See Also
EcoDesigner Class
EcoDesigner Members
Eco.Handles.Design Namespace


EcoDesigner.LabelCaption Method

EcoDesigner.LabelCaption Method
EcoDesigner Class EcoDesigner Members Eco.Handles.Design Namespace See Also
Collapse All

This abstract method MUST be overriden to provide a text in the middle of the designer

C#
protected abstract string LabelCaption();
See Also
EcoDesigner Class
EcoDesigner Members
Eco.Handles.Design Namespace


EcoDesigner.PerformAutoHookup Method

EcoDesigner.PerformAutoHookup Method
EcoDesigner Class EcoDesigner Members Eco.Handles.Design Namespace See Also
Collapse All

override this method to implement hookup logic. Typically this will be see which component has been dropped and you'll set some properties triggered by that.

C#
protected virtual void PerformAutoHookup(
    Component addedComponent
);
See Also
EcoDesigner Class
EcoDesigner Members
Eco.Handles.Design Namespace


EcoDesigner Properties

EcoDesigner Properties
Public Properties Protected internal Properties
Collapse All

The properties of the EcoDesigner class are listed here.

Public Properties
Name | Description
Verbs | Builds a verb collection from the tools registered in the EcoSpaceDesignerToolbox that are registered for the type of the executing instance of the designer.
Top
Protected internal Properties
Name | Description
DesignedComponent | This abstract property helps provide an EcoSpace when required for Tool invocation. Some designer might not have an EcoSpace at hand at creation time.


EcoDesigner.DesignedComponent Property

EcoDesigner.DesignedComponent Property
EcoDesigner Class EcoDesigner Members Eco.Handles.Design Namespace See Also
Collapse All

This abstract property helps provide an EcoSpace when required for Tool invocation. Some designer might not have an EcoSpace at hand at creation time.

C#
protected internal abstract IComponent DesignedComponent;
See Also
EcoDesigner Class
EcoDesigner Members
Eco.Handles.Design Namespace


EcoDesigner.Verbs Property

EcoDesigner.Verbs Property
EcoDesigner Class EcoDesigner Members Eco.Handles.Design Namespace See Also
Collapse All

Builds a verb collection from the tools registered in the EcoSpaceDesignerToolbox that are registered for the type of the executing instance of the designer.

C#
public override DesignerVerbCollection Verbs;
See Also
EcoDesigner Class
EcoDesigner Members
Eco.Handles.Design Namespace


EcoIdeOptions Class

EcoIdeOptions Class
EcoIdeOptions Members Inheritance Hierarchy See Also
Collapse All

Singleton class that provides easy access to the IDE options pertaining to ECO.

C#
public sealed class EcoIdeOptions;
Inheritance Hierarchy
Eco.Handles.Design.EcoIdeOptions
File

EcoOptions.cs

See Also
EcoIdeOptions Members
Inheritance Hierarchy


EcoIdeOptions Members

EcoIdeOptions Members
Public Methods
Collapse All

The following tables list the members exposed by EcoIdeOptions.

Public Methods
Name | Description
AlwaysShowEcoMenu | This is AlwaysShowEcoMenu, a member of class EcoIdeOptions.
DefaultPluralSuffix | This is DefaultPluralSuffix, a member of class EcoIdeOptions.
EnableContextAgent | This is EnableContextAgent, a member of class EcoIdeOptions.
GetOptionBool | This is the overview for the GetOptionBool method overload.
GetOptionInt | This is the overview for the GetOptionInt method overload.
GetOptionValue | This is GetOptionValue, a member of class EcoIdeOptions.
ModelValidationNodes | This is ModelValidationNodes, a member of class EcoIdeOptions.
SaveSettingsToRegistry | This is SaveSettingsToRegistry, a member of class EcoIdeOptions.
SetOptionBool | This is SetOptionBool, a member of class EcoIdeOptions.
SetOptionInt | This is SetOptionInt, a member of class EcoIdeOptions.
SetOptionValue | This is SetOptionValue, a member of class EcoIdeOptions.
ValidatePostCompile | This is ValidatePostCompile, a member of class EcoIdeOptions.


EcoIdeOptions Methods

EcoIdeOptions Methods
Public Methods
Collapse All

The methods of the EcoIdeOptions class are listed here.

Public Methods
Name | Description
AlwaysShowEcoMenu | This is AlwaysShowEcoMenu, a member of class EcoIdeOptions.
DefaultPluralSuffix | This is DefaultPluralSuffix, a member of class EcoIdeOptions.
EnableContextAgent | This is EnableContextAgent, a member of class EcoIdeOptions.
GetOptionBool | This is the overview for the GetOptionBool method overload.
GetOptionInt | This is the overview for the GetOptionInt method overload.
GetOptionValue | This is GetOptionValue, a member of class EcoIdeOptions.
ModelValidationNodes | This is ModelValidationNodes, a member of class EcoIdeOptions.
SaveSettingsToRegistry | This is SaveSettingsToRegistry, a member of class EcoIdeOptions.
SetOptionBool | This is SetOptionBool, a member of class EcoIdeOptions.
SetOptionInt | This is SetOptionInt, a member of class EcoIdeOptions.
SetOptionValue | This is SetOptionValue, a member of class EcoIdeOptions.
ValidatePostCompile | This is ValidatePostCompile, a member of class EcoIdeOptions.


EcoIdeOptions.AlwaysShowEcoMenu Method

EcoIdeOptions.AlwaysShowEcoMenu Method
EcoIdeOptions Class EcoIdeOptions Members Eco.Handles.Design Namespace See Also
Collapse All
C#
public static bool AlwaysShowEcoMenu();
Remarks

This is AlwaysShowEcoMenu, a member of class EcoIdeOptions.

See Also
EcoIdeOptions Class
EcoIdeOptions Members
Eco.Handles.Design Namespace


EcoIdeOptions.DefaultPluralSuffix Method

EcoIdeOptions.DefaultPluralSuffix Method
EcoIdeOptions Class EcoIdeOptions Members Eco.Handles.Design Namespace See Also
Collapse All
C#
public static string DefaultPluralSuffix();
Remarks

This is DefaultPluralSuffix, a member of class EcoIdeOptions.

See Also
EcoIdeOptions Class
EcoIdeOptions Members
Eco.Handles.Design Namespace


EcoIdeOptions.EnableContextAgent Method

EcoIdeOptions.EnableContextAgent Method
EcoIdeOptions Class EcoIdeOptions Members Eco.Handles.Design Namespace See Also
Collapse All
C#
public static bool EnableContextAgent();
Remarks

This is EnableContextAgent, a member of class EcoIdeOptions.

See Also
EcoIdeOptions Class
EcoIdeOptions Members
Eco.Handles.Design Namespace


GetOptionBool Method

GetOptionBool Method

This is the overview for the GetOptionBool method overload.

Overload List
Name | Description
EcoIdeOptions.GetOptionBool (string) | Returns the boolean option named keyName. If there is no such option specified, the default is to return false.
EcoIdeOptions.GetOptionBool (string, bool) | This is GetOptionBool, a member of class EcoIdeOptions.


EcoIdeOptions.GetOptionBool Method (string)

EcoIdeOptions.GetOptionBool Method (string)
EcoIdeOptions Class EcoIdeOptions Members Eco.Handles.Design Namespace See Also
Collapse All

Returns the boolean option named keyName. If there is no such option specified, the default is to return false.

C#
public static bool GetOptionBool(
    string name
);
See Also
EcoIdeOptions Class
EcoIdeOptions Members
Eco.Handles.Design Namespace


EcoIdeOptions.GetOptionBool Method (string, bool)

EcoIdeOptions.GetOptionBool Method (string, bool)
EcoIdeOptions Class EcoIdeOptions Members Eco.Handles.Design Namespace See Also
Collapse All
C#
public static bool GetOptionBool(
    string name,
    bool defaultValue
);
Remarks

This is GetOptionBool, a member of class EcoIdeOptions.

See Also
EcoIdeOptions Class
EcoIdeOptions Members
Eco.Handles.Design Namespace


GetOptionInt Method

GetOptionInt Method

This is the overview for the GetOptionInt method overload.

Overload List
Name | Description
EcoIdeOptions.GetOptionInt (string) | This is GetOptionInt, a member of class EcoIdeOptions.
EcoIdeOptions.GetOptionInt (string, int) | This is GetOptionInt, a member of class EcoIdeOptions.


EcoIdeOptions.GetOptionInt Method (string)

EcoIdeOptions.GetOptionInt Method (string)
EcoIdeOptions Class EcoIdeOptions Members Eco.Handles.Design Namespace See Also
Collapse All
C#
public static int GetOptionInt(
    string name
);
Remarks

This is GetOptionInt, a member of class EcoIdeOptions.

See Also
EcoIdeOptions Class
EcoIdeOptions Members
Eco.Handles.Design Namespace


EcoIdeOptions.GetOptionInt Method (string, int)

EcoIdeOptions.GetOptionInt Method (string, int)
EcoIdeOptions Class EcoIdeOptions Members Eco.Handles.Design Namespace See Also
Collapse All
C#
public static int GetOptionInt(
    string name,
    int defaultValue
);
Remarks

This is GetOptionInt, a member of class EcoIdeOptions.

See Also
EcoIdeOptions Class
EcoIdeOptions Members
Eco.Handles.Design Namespace


EcoIdeOptions.GetOptionValue Method

EcoIdeOptions.GetOptionValue Method
EcoIdeOptions Class EcoIdeOptions Members Eco.Handles.Design Namespace See Also
Collapse All
C#
public static string GetOptionValue(
    string name
);
Remarks

This is GetOptionValue, a member of class EcoIdeOptions.

See Also
EcoIdeOptions Class
EcoIdeOptions Members
Eco.Handles.Design Namespace


EcoIdeOptions.ModelValidationNodes Method

EcoIdeOptions.ModelValidationNodes Method
EcoIdeOptions Class EcoIdeOptions Members Eco.Handles.Design Namespace See Also
Collapse All
C#
public static bool ModelValidationNodes();
Remarks

This is ModelValidationNodes, a member of class EcoIdeOptions.

See Also
EcoIdeOptions Class
EcoIdeOptions Members
Eco.Handles.Design Namespace


EcoIdeOptions.SaveSettingsToRegistry Method

EcoIdeOptions.SaveSettingsToRegistry Method
EcoIdeOptions Class EcoIdeOptions Members Eco.Handles.Design Namespace See Also
Collapse All
C#
public static void SaveSettingsToRegistry();
Remarks

This is SaveSettingsToRegistry, a member of class EcoIdeOptions.

See Also
EcoIdeOptions Class
EcoIdeOptions Members
Eco.Handles.Design Namespace


EcoIdeOptions.SetOptionBool Method

EcoIdeOptions.SetOptionBool Method
EcoIdeOptions Class EcoIdeOptions Members Eco.Handles.Design Namespace See Also
Collapse All
C#
public static void SetOptionBool(
    string name,
    bool value
);
Remarks

This is SetOptionBool, a member of class EcoIdeOptions.

See Also
EcoIdeOptions Class
EcoIdeOptions Members
Eco.Handles.Design Namespace


EcoIdeOptions.SetOptionInt Method

EcoIdeOptions.SetOptionInt Method
EcoIdeOptions Class EcoIdeOptions Members Eco.Handles.Design Namespace See Also
Collapse All
C#
public static void SetOptionInt(
    string name,
    int value
);
Remarks

This is SetOptionInt, a member of class EcoIdeOptions.

See Also
EcoIdeOptions Class
EcoIdeOptions Members
Eco.Handles.Design Namespace


EcoIdeOptions.SetOptionValue Method

EcoIdeOptions.SetOptionValue Method
EcoIdeOptions Class EcoIdeOptions Members Eco.Handles.Design Namespace See Also
Collapse All
C#
public static void SetOptionValue(
    string name,
    string value
);
Remarks

This is SetOptionValue, a member of class EcoIdeOptions.

See Also
EcoIdeOptions Class
EcoIdeOptions Members
Eco.Handles.Design Namespace


EcoIdeOptions.ValidatePostCompile Method

EcoIdeOptions.ValidatePostCompile Method
EcoIdeOptions Class EcoIdeOptions Members Eco.Handles.Design Namespace See Also
Collapse All
C#
public static bool ValidatePostCompile();
Remarks

This is ValidatePostCompile, a member of class EcoIdeOptions.

See Also
EcoIdeOptions Class
EcoIdeOptions Members
Eco.Handles.Design Namespace


EcoManipulator Class

EcoManipulator Class
EcoManipulator Members Inheritance Hierarchy See Also
Collapse All

Adds the ability to return a named IFeature.

C#
public abstract class EcoManipulator : AbstractManipulator;
Inheritance Hierarchy
Eco.Handles.Design.AbstractManipulator
    Eco.Handles.Design.EcoManipulator
File

EcoPropertyManipulators.cs

See Also
EcoManipulator Members
Inheritance Hierarchy


EcoManipulator Members

EcoManipulator Members
Protected Methods Public Methods
Collapse All

The following tables list the members exposed by EcoManipulator.

Protected Methods
Name | Description
GetNamedFeature | Returns the named IFeature from the InvokingComponent's StaticUmlType.
PreviousComponent | Returns the previously created component that matches filter.
Top
Public Methods
Name | Description
SetPropertyValue | Allows for setting the property value.


EcoManipulator Methods

EcoManipulator Methods
Protected Methods
Collapse All

The methods of the EcoManipulator class are listed here.

Protected Methods
Name | Description
GetNamedFeature | Returns the named IFeature from the InvokingComponent's StaticUmlType.


EcoManipulator.GetNamedFeature Method

EcoManipulator.GetNamedFeature Method
EcoManipulator Class EcoManipulator Members Eco.Handles.Design Namespace See Also
Collapse All

Returns the named IFeature from the InvokingComponent's StaticUmlType.

C#
protected IFeature GetNamedFeature(
    PropertyParams propertyParams
);
Returns

The requested named feature if found. If preconditions not met or feature not found, null is returned.

See Also
EcoManipulator Class
EcoManipulator Members
Eco.Handles.Design Namespace


EcoRegistry Class

EcoRegistry Class
EcoRegistry Members Inheritance Hierarchy See Also
Collapse All

Handle the ECO registry entries. Note, the key is duplicated in AssemblyRegistrator.pas in the native part of the BDS integration.

C#
public static class EcoRegistry;
Inheritance Hierarchy
Eco.Handles.Design.EcoRegistry
File

EcoRegistry.cs

See Also
EcoRegistry Members
Inheritance Hierarchy


EcoRegistry Members

EcoRegistry Members
Public Methods Public Properties
Collapse All

The following tables list the members exposed by EcoRegistry.

Public Methods
Name | Description
GetEcoMachineKey | This is GetEcoMachineKey, a member of class EcoRegistry.
GetEcoUserKey | This is GetEcoUserKey, a member of class EcoRegistry.
Top
Public Properties
Name | Description
EcoDesignDir | This is EcoDesignDir, a member of class EcoRegistry.
EcoInstallDir | This is EcoInstallDir, a member of class EcoRegistry.


EcoRegistry Methods

EcoRegistry Methods
Public Methods
Collapse All

The methods of the EcoRegistry class are listed here.

Public Methods
Name | Description
GetEcoMachineKey | This is GetEcoMachineKey, a member of class EcoRegistry.
GetEcoUserKey | This is GetEcoUserKey, a member of class EcoRegistry.


EcoRegistry.GetEcoMachineKey Method

EcoRegistry.GetEcoMachineKey Method
EcoRegistry Class EcoRegistry Members Eco.Handles.Design Namespace See Also
Collapse All
C#
public static RegistryKey GetEcoMachineKey();
Remarks

This is GetEcoMachineKey, a member of class EcoRegistry.

See Also
EcoRegistry Class
EcoRegistry Members
Eco.Handles.Design Namespace


EcoRegistry.GetEcoUserKey Method

EcoRegistry.GetEcoUserKey Method
EcoRegistry Class EcoRegistry Members Eco.Handles.Design Namespace See Also
Collapse All
C#
public static RegistryKey GetEcoUserKey();
Remarks

This is GetEcoUserKey, a member of class EcoRegistry.

See Also
EcoRegistry Class
EcoRegistry Members
Eco.Handles.Design Namespace


EcoRegistry Properties

EcoRegistry Properties
Public Properties
Collapse All

The properties of the EcoRegistry class are listed here.

Public Properties
Name | Description
EcoDesignDir | This is EcoDesignDir, a member of class EcoRegistry.
EcoInstallDir | This is EcoInstallDir, a member of class EcoRegistry.


EcoRegistry.EcoDesignDir Property

EcoRegistry.EcoDesignDir Property
EcoRegistry Class EcoRegistry Members Eco.Handles.Design Namespace See Also
Collapse All
C#
public static string EcoDesignDir;
Remarks

This is EcoDesignDir, a member of class EcoRegistry.

See Also
EcoRegistry Class
EcoRegistry Members
Eco.Handles.Design Namespace


EcoRegistry.EcoInstallDir Property

EcoRegistry.EcoInstallDir Property
EcoRegistry Class EcoRegistry Members Eco.Handles.Design Namespace See Also
Collapse All
C#
public static string EcoInstallDir;
Remarks

This is EcoInstallDir, a member of class EcoRegistry.

See Also
EcoRegistry Class
EcoRegistry Members
Eco.Handles.Design Namespace


EcoSettingsForm Class

EcoSettingsForm Class
EcoSettingsForm Members Inheritance Hierarchy See Also
Collapse All

Summary description for WinForm1.

C#
public class EcoSettingsForm : System.Windows.Forms.Form;
Inheritance Hierarchy
System.Windows.Forms.Form
    Eco.Handles.Design.EcoSettingsForm
File

Eco.Handles.Design.EcoSettingsForm.cs

See Also
EcoSettingsForm Members
Inheritance Hierarchy


EcoSettingsForm Members

EcoSettingsForm Members
Protected Methods Public Methods Public Fields
Collapse All

The following tables list the members exposed by EcoSettingsForm.

Protected Methods
Name | Description
Dispose | Clean up any resources being used.
Top
Public Methods
Name | Description
EcoSettingsForm | This is EcoSettingsForm, a member of class EcoSettingsForm.
Register | This is Register, a member of class EcoSettingsForm.
Top
Public Fields
Name | Description
tabContextAgent | This is tabContextAgent, a member of class EcoSettingsForm.


EcoSettingsForm.EcoSettingsForm Constructor

EcoSettingsForm.EcoSettingsForm Constructor
EcoSettingsForm Class EcoSettingsForm Members Eco.Handles.Design Namespace See Also
Collapse All
C#
public EcoSettingsForm();
Remarks

This is EcoSettingsForm, a member of class EcoSettingsForm.

See Also
EcoSettingsForm Class
EcoSettingsForm Members
Eco.Handles.Design Namespace


EcoSettingsForm Fields

EcoSettingsForm Fields
Public Fields
Collapse All

The fields of the EcoSettingsForm class are listed here.

Public Fields
Name | Description
tabContextAgent | This is tabContextAgent, a member of class EcoSettingsForm.


EcoSettingsForm.tabContextAgent Field

EcoSettingsForm.tabContextAgent Field
EcoSettingsForm Class EcoSettingsForm Members Eco.Handles.Design Namespace See Also
Collapse All
C#
public System.Windows.Forms.TabPage tabContextAgent;
Remarks

This is tabContextAgent, a member of class EcoSettingsForm.

See Also
EcoSettingsForm Class
EcoSettingsForm Members
Eco.Handles.Design Namespace


EcoSettingsForm Methods

EcoSettingsForm Methods
Protected Methods Public Methods
Collapse All

The methods of the EcoSettingsForm class are listed here.

Protected Methods
Name | Description
Dispose | Clean up any resources being used.
Top
Public Methods
Name | Description
Register | This is Register, a member of class EcoSettingsForm.


EcoSettingsForm.Dispose Method

EcoSettingsForm.Dispose Method
EcoSettingsForm Class EcoSettingsForm Members Eco.Handles.Design Namespace See Also
Collapse All

Clean up any resources being used.

C#
protected override void Dispose(
    bool disposing
);
See Also
EcoSettingsForm Class
EcoSettingsForm Members
Eco.Handles.Design Namespace


EcoSettingsForm.Register Method

EcoSettingsForm.Register Method
EcoSettingsForm Class EcoSettingsForm Members Eco.Handles.Design Namespace See Also
Collapse All
C#
public static void Register();
Remarks

This is Register, a member of class EcoSettingsForm.

See Also
EcoSettingsForm Class
EcoSettingsForm Members
Eco.Handles.Design Namespace


EcoSpaceDesigner Class

EcoSpaceDesigner Class
EcoSpaceDesigner Members Inheritance Hierarchy See Also
Collapse All

The designer for DefaultEcoSpace.

C#
public class EcoSpaceDesigner : EcoDesigner;
Inheritance Hierarchy
Eco.Handles.Design.EcoDesigner
    Eco.Handles.Design.EcoSpaceDesigner
File

EcoSpaceDesigner.cs

See Also
EcoSpaceDesigner Members
Inheritance Hierarchy


EcoSpaceDesigner Members

EcoSpaceDesigner Members
Protected Methods Public Methods Public Properties Protected internal Methods Protected internal Properties
Collapse All

The following tables list the members exposed by EcoSpaceDesigner.

Protected Methods
Name | Description
ComponentRemoved | Override this method to act on the removal of a specific component. Typically used for disconnection of properties
EcoDesigner | This is EcoDesigner, a member of class EcoDesigner.
EcoSpaceDesigner | This is EcoSpaceDesigner, a member of class EcoSpaceDesigner.
HookupCandidates | If there is only one potential candidate in the collection, hook it up.
HookupComponent | If hookable can be hooked up with component, do it.
LabelCaption | This abstract method MUST be overriden to provide a text in the middle of the designer
PerformAutoHookup | Implements the autohookup for dropped components. Any new hookups that should be done must be implemented in this method. There is currently no way to plug in new hookups.
Top
Public Methods
Name | Description
Initialize | This method performs some basic setup, like adding the toolbar for the tools, hooking events for controls added and removed etc.
Top
Public Properties
Name | Description
Verbs | Builds a verb collection from the tools registered in the EcoSpaceDesignerToolbox that are registered for the type of the executing instance of the designer.
Top
Protected internal Methods
Name | Description
DesignerType | This method must be implemented to return the type of the designer.
Top
Protected internal Properties
Name | Description
DesignedComponent | This abstract property helps provide an EcoSpace when required for Tool invocation. Some designer might not have an EcoSpace at hand at creation time.


EcoSpaceDesigner.EcoSpaceDesigner Constructor

EcoSpaceDesigner.EcoSpaceDesigner Constructor
EcoSpaceDesigner Class EcoSpaceDesigner Members Eco.Handles.Design Namespace See Also
Collapse All
C#
protected EcoSpaceDesigner();
Remarks

This is EcoSpaceDesigner, a member of class EcoSpaceDesigner.

See Also
EcoSpaceDesigner Class
EcoSpaceDesigner Members
Eco.Handles.Design Namespace


EcoSpaceDesigner Methods

EcoSpaceDesigner Methods
Protected Methods Protected internal Methods
Collapse All

The methods of the EcoSpaceDesigner class are listed here.

Protected Methods
Name | Description
ComponentRemoved | Override this method to act on the removal of a specific component. Typically used for disconnection of properties
LabelCaption | This abstract method MUST be overriden to provide a text in the middle of the designer
PerformAutoHookup | Implements the autohookup for dropped components. Any new hookups that should be done must be implemented in this method. There is currently no way to plug in new hookups.
Top
Protected internal Methods
Name | Description
DesignerType | This method must be implemented to return the type of the designer.


EcoSpaceDesigner.ComponentRemoved Method

EcoSpaceDesigner.ComponentRemoved Method
EcoSpaceDesigner Class EcoSpaceDesigner Members Eco.Handles.Design Namespace See Also
Collapse All

Override this method to act on the removal of a specific component. Typically used for disconnection of properties

C#
protected override void ComponentRemoved(
    Component removedComponent
);
See Also
EcoSpaceDesigner Class
EcoSpaceDesigner Members
Eco.Handles.Design Namespace


EcoSpaceDesigner.DesignerType Method

EcoSpaceDesigner.DesignerType Method
EcoSpaceDesigner Class EcoSpaceDesigner Members Eco.Handles.Design Namespace See Also
Collapse All

This method must be implemented to return the type of the designer.

C#
protected internal override DesignerTypes DesignerType();
See Also
EcoSpaceDesigner Class
EcoSpaceDesigner Members
Eco.Handles.Design Namespace


EcoSpaceDesigner.LabelCaption Method

EcoSpaceDesigner.LabelCaption Method
EcoSpaceDesigner Class EcoSpaceDesigner Members Eco.Handles.Design Namespace See Also
Collapse All

This abstract method MUST be overriden to provide a text in the middle of the designer

C#
protected override string LabelCaption();
See Also
EcoSpaceDesigner Class
EcoSpaceDesigner Members
Eco.Handles.Design Namespace


EcoSpaceDesigner.PerformAutoHookup Method

EcoSpaceDesigner.PerformAutoHookup Method
EcoSpaceDesigner Class EcoSpaceDesigner Members Eco.Handles.Design Namespace See Also
Collapse All

Implements the autohookup for dropped components. Any new hookups that should be done must be implemented in this method. There is currently no way to plug in new hookups.

C#
protected override void PerformAutoHookup(
    Component addedComponent
);
Remarks

It would be possible to change this implementation to allow registration of hookup-agents who get called once for each existing component + the new component.

See Also
EcoSpaceDesigner Class
EcoSpaceDesigner Members
Eco.Handles.Design Namespace


EcoSpaceDesigner Properties

EcoSpaceDesigner Properties
Protected internal Properties
Collapse All

The properties of the EcoSpaceDesigner class are listed here.

Protected internal Properties
Name | Description
DesignedComponent | This abstract property helps provide an EcoSpace when required for Tool invocation. Some designer might not have an EcoSpace at hand at creation time.


EcoSpaceDesigner.DesignedComponent Property

EcoSpaceDesigner.DesignedComponent Property
EcoSpaceDesigner Class EcoSpaceDesigner Members Eco.Handles.Design Namespace See Also
Collapse All

This abstract property helps provide an EcoSpace when required for Tool invocation. Some designer might not have an EcoSpace at hand at creation time.

C#
protected internal override IComponent DesignedComponent;
See Also
EcoSpaceDesigner Class
EcoSpaceDesigner Members
Eco.Handles.Design Namespace


EcoSpaceDesignerForm Class

EcoSpaceDesignerForm Class
EcoSpaceDesignerForm Members Inheritance Hierarchy See Also
Collapse All

This is the class implementing the toolbar in the EcoDesigner.

C#
public class EcoSpaceDesignerForm : System.Windows.Forms.Form;
Inheritance Hierarchy
System.Windows.Forms.Form
    Eco.Handles.Design.EcoSpaceDesignerForm
File

Eco.Handles.Design.EcoSpaceDesignerForm.cs

See Also
EcoSpaceDesignerForm Members
Inheritance Hierarchy


EcoSpaceDesignerForm Members

EcoSpaceDesignerForm Members
Protected Methods Public Methods
Collapse All

The following tables list the members exposed by EcoSpaceDesignerForm.

Protected Methods
Name | Description
Dispose | Clean up any resources being used.
Top
Public Methods
Name | Description
EcoSpaceDesignerForm | Creates a new instance of the toolbar holder and loads in all registered IEcoSpaceDesignerTool.


EcoSpaceDesignerForm.EcoSpaceDesignerForm Constructor

EcoSpaceDesignerForm.EcoSpaceDesignerForm Constructor
EcoSpaceDesignerForm Class EcoSpaceDesignerForm Members Eco.Handles.Design Namespace See Also
Collapse All

Creates a new instance of the toolbar holder and loads in all registered IEcoSpaceDesignerTool.

C#
public EcoSpaceDesignerForm(
    IComponent designedComponent,
    EcoDesigner designer,
    ITypeResolutionService typeResolutionService
);
Exceptions
Exceptions | Description
ArgumentNullException | Thrown if designer is null.
See Also
EcoSpaceDesignerForm Class
EcoSpaceDesignerForm Members
Eco.Handles.Design Namespace


EcoSpaceDesignerForm Methods

EcoSpaceDesignerForm Methods
Protected Methods
Collapse All

The methods of the EcoSpaceDesignerForm class are listed here.

Protected Methods
Name | Description
Dispose | Clean up any resources being used.


EcoSpaceDesignerForm.Dispose Method

EcoSpaceDesignerForm.Dispose Method
EcoSpaceDesignerForm Class EcoSpaceDesignerForm Members Eco.Handles.Design Namespace See Also
Collapse All

Clean up any resources being used.

C#
protected override void Dispose(
    bool disposing
);
See Also
EcoSpaceDesignerForm Class
EcoSpaceDesignerForm Members
Eco.Handles.Design Namespace


EcoSpaceDesignerToolbox Class

EcoSpaceDesignerToolbox Class
EcoSpaceDesignerToolbox Members Inheritance Hierarchy See Also
Collapse All

Singleton class responsible for maintaining the list of registered IEcoSpaceDesignerTool.

C#
public sealed class EcoSpaceDesignerToolbox;
Inheritance Hierarchy
Eco.Handles.Design.EcoSpaceDesignerToolbox
File

EcoSpaceDesignerToolBox.cs

See Also
EcoSpaceDesignerToolbox Members
Inheritance Hierarchy


EcoSpaceDesignerToolbox Members

EcoSpaceDesignerToolbox Members
Public Delegates Public Methods Public Properties Public Events Public Delegates See Also
Collapse All

The following tables list the members exposed by EcoSpaceDesignerToolbox.

Public Methods
Name | Description
AddTool | Adds the submitted tool to the list of registered tools.
DisableTool | Triggers the OnToolDisabled event. Note that the tool itself does not know what happened!
EnableTool | Triggers the OnToolEnabled event. Note that the tool itself does not know what happened!
InsertTool | Inserts the submitted tool in the list on the requested position.
RemoveTool | Removed the submitted tool from the list of registered tools.
RemoveToolAt | Removed the tool at the specified position from the list of registered tools.
Tool | Returns the IEcoSpaceDesignerTool at the specified position.
Top
Public Properties
Name | Description
Count | Returns the number of registered tools.
Top
Public Events
Name | Description
OnToolAdded | Raised when a new tool is added (using AddTool or InsertTool).
OnToolDisabled | Raised when a tool is disabled (using DisableTool).
OnToolEnabled | Raised when a tool is enabled (using EnableTool).
OnToolRemoved | Raised when a tool is removed (using RemoveTool or RemoveToolAt).
Top
Public Delegates
Name | Description
EcoToolboxEventHandler | This is nested type Eco.Handles.Design.EcoSpaceDesignerToolbox.EcoToolboxEventHandler.
Top
See Also
Public Delegates


EcoSpaceDesignerToolbox Methods

EcoSpaceDesignerToolbox Methods
Public Methods
Collapse All

The methods of the EcoSpaceDesignerToolbox class are listed here.

Public Methods
Name | Description
AddTool | Adds the submitted tool to the list of registered tools.
DisableTool | Triggers the OnToolDisabled event. Note that the tool itself does not know what happened!
EnableTool | Triggers the OnToolEnabled event. Note that the tool itself does not know what happened!
InsertTool | Inserts the submitted tool in the list on the requested position.
RemoveTool | Removed the submitted tool from the list of registered tools.
RemoveToolAt | Removed the tool at the specified position from the list of registered tools.
Tool | Returns the IEcoSpaceDesignerTool at the specified position.


EcoSpaceDesignerToolbox.AddTool Method

EcoSpaceDesignerToolbox.AddTool Method
EcoSpaceDesignerToolbox Class EcoSpaceDesignerToolbox Members Eco.Handles.Design Namespace See Also
Collapse All

Adds the submitted tool to the list of registered tools.

C#
public static void AddTool(
    IEcoSpaceDesignerTool tool
);
Parameters
Parameters | Description
tool | An instance of IEcoSpaceDesignerTool to insert in the list.
See Also
EcoSpaceDesignerToolbox Class
EcoSpaceDesignerToolbox Members
Eco.Handles.Design Namespace


EcoSpaceDesignerToolbox.DisableTool Method

EcoSpaceDesignerToolbox.DisableTool Method
EcoSpaceDesignerToolbox Class EcoSpaceDesignerToolbox Members Eco.Handles.Design Namespace See Also
Collapse All

Triggers the OnToolDisabled event. Note that the tool itself does not know what happened!

C#
public static void DisableTool(
    IEcoSpaceDesignerTool tool
);
Parameters
Parameters | Description
tool | An instance of IEcoSpaceDesignerTool to pass to the event.
See Also
EcoSpaceDesignerToolbox Class
EcoSpaceDesignerToolbox Members
Eco.Handles.Design Namespace


EcoSpaceDesignerToolbox.EnableTool Method

EcoSpaceDesignerToolbox.EnableTool Method
EcoSpaceDesignerToolbox Class EcoSpaceDesignerToolbox Members Eco.Handles.Design Namespace See Also
Collapse All

Triggers the OnToolEnabled event. Note that the tool itself does not know what happened!

C#
public static void EnableTool(
    IEcoSpaceDesignerTool tool
);
Parameters
Parameters | Description
tool | An instance of IEcoSpaceDesignerTool to pass to the event.
See Also
EcoSpaceDesignerToolbox Class
EcoSpaceDesignerToolbox Members
Eco.Handles.Design Namespace


EcoSpaceDesignerToolbox.InsertTool Method

EcoSpaceDesignerToolbox.InsertTool Method
EcoSpaceDesignerToolbox Class EcoSpaceDesignerToolbox Members Eco.Handles.Design Namespace See Also
Collapse All

Inserts the submitted tool in the list on the requested position.

C#
public static void InsertTool(
    int index,
    IEcoSpaceDesignerTool tool
);
Parameters
Parameters | Description
index | The position at which the tool shall be inserted.
tool | An instance of IEcoSpaceDesignerTool to insert in the list.
See Also
EcoSpaceDesignerToolbox Class
EcoSpaceDesignerToolbox Members
Eco.Handles.Design Namespace


EcoSpaceDesignerToolbox.RemoveTool Method

EcoSpaceDesignerToolbox.RemoveTool Method
EcoSpaceDesignerToolbox Class EcoSpaceDesignerToolbox Members Eco.Handles.Design Namespace See Also
Collapse All

Removed the submitted tool from the list of registered tools.

C#
public static void RemoveTool(
    IEcoSpaceDesignerTool tool
);
Parameters
Parameters | Description
tool | An instance of IEcoSpaceDesignerTool to insert in the list.
See Also
EcoSpaceDesignerToolbox Class
EcoSpaceDesignerToolbox Members
Eco.Handles.Design Namespace


EcoSpaceDesignerToolbox.RemoveToolAt Method

EcoSpaceDesignerToolbox.RemoveToolAt Method
EcoSpaceDesignerToolbox Class EcoSpaceDesignerToolbox Members Eco.Handles.Design Namespace See Also
Collapse All

Removed the tool at the specified position from the list of registered tools.

C#
public static void RemoveToolAt(
    int index
);
Parameters
Parameters | Description
index | The position from which the tool shall be removed.
See Also
EcoSpaceDesignerToolbox Class
EcoSpaceDesignerToolbox Members
Eco.Handles.Design Namespace


EcoSpaceDesignerToolbox.Tool Method

EcoSpaceDesignerToolbox.Tool Method
EcoSpaceDesignerToolbox Class EcoSpaceDesignerToolbox Members Eco.Handles.Design Namespace See Also
Collapse All

Returns the IEcoSpaceDesignerTool at the specified position.

C#
public static IEcoSpaceDesignerTool Tool(
    int index
);
Parameters
Parameters | Description
index | The position in list from which to return the tool.
See Also
EcoSpaceDesignerToolbox Class
EcoSpaceDesignerToolbox Members
Eco.Handles.Design Namespace


EcoSpaceDesignerToolbox Properties

EcoSpaceDesignerToolbox Properties
Public Properties
Collapse All

The properties of the EcoSpaceDesignerToolbox class are listed here.

Public Properties
Name | Description
Count | Returns the number of registered tools.


EcoSpaceDesignerToolbox.Count Property

EcoSpaceDesignerToolbox.Count Property
EcoSpaceDesignerToolbox Class EcoSpaceDesignerToolbox Members Eco.Handles.Design Namespace See Also
Collapse All

Returns the number of registered tools.

C#
public static int Count;
See Also
EcoSpaceDesignerToolbox Class
EcoSpaceDesignerToolbox Members
Eco.Handles.Design Namespace


EcoSpaceDesignerToolbox Delegates

EcoSpaceDesignerToolbox Delegates
Public Delegates Public Delegates See Also
Collapse All

The delegates of the EcoSpaceDesignerToolbox class are listed here.

Public Delegates
Name | Description
EcoToolboxEventHandler | This is nested type Eco.Handles.Design.EcoSpaceDesignerToolbox.EcoToolboxEventHandler.
Top
See Also
Public Delegates


EcoSpaceDesignerToolbox.EcoToolboxEventHandler Delegate

EcoSpaceDesignerToolbox.EcoToolboxEventHandler Delegate
EcoSpaceDesignerToolbox Class EcoSpaceDesignerToolbox Members Eco.Handles.Design Namespace See Also
Collapse All
C#
public delegate void EcoToolboxEventHandler(object sender, EcoToolboxArgs e);
Remarks

This is nested type Eco.Handles.Design.EcoSpaceDesignerToolbox.EcoToolboxEventHandler.

See Also
EcoSpaceDesignerToolbox Class
EcoSpaceDesignerToolbox Members
Eco.Handles.Design Namespace


EcoSpaceDesignerToolbox Events

EcoSpaceDesignerToolbox Events
Public Events
Collapse All

The events of the EcoSpaceDesignerToolbox class are listed here.

Public Events
Name | Description
OnToolAdded | Raised when a new tool is added (using AddTool or InsertTool).
OnToolDisabled | Raised when a tool is disabled (using DisableTool).
OnToolEnabled | Raised when a tool is enabled (using EnableTool).
OnToolRemoved | Raised when a tool is removed (using RemoveTool or RemoveToolAt).


EcoSpaceDesignerToolbox.OnToolAdded Event

EcoSpaceDesignerToolbox.OnToolAdded Event
EcoSpaceDesignerToolbox Class EcoSpaceDesignerToolbox Members Eco.Handles.Design Namespace See Also
Collapse All

Raised when a new tool is added (using AddTool or InsertTool).

C#
public static event EcoToolboxEventHandler OnToolAdded;
See Also
EcoSpaceDesignerToolbox Class
EcoSpaceDesignerToolbox Members
Eco.Handles.Design Namespace


EcoSpaceDesignerToolbox.OnToolDisabled Event

EcoSpaceDesignerToolbox.OnToolDisabled Event
EcoSpaceDesignerToolbox Class EcoSpaceDesignerToolbox Members Eco.Handles.Design Namespace See Also
Collapse All

Raised when a tool is disabled (using DisableTool).

C#
public static event EcoToolboxEventHandler OnToolDisabled;
See Also
EcoSpaceDesignerToolbox Class
EcoSpaceDesignerToolbox Members
Eco.Handles.Design Namespace


EcoSpaceDesignerToolbox.OnToolEnabled Event

EcoSpaceDesignerToolbox.OnToolEnabled Event
EcoSpaceDesignerToolbox Class EcoSpaceDesignerToolbox Members Eco.Handles.Design Namespace See Also
Collapse All

Raised when a tool is enabled (using EnableTool).

C#
public static event EcoToolboxEventHandler OnToolEnabled;
See Also
EcoSpaceDesignerToolbox Class
EcoSpaceDesignerToolbox Members
Eco.Handles.Design Namespace


EcoSpaceDesignerToolbox.OnToolRemoved Event

EcoSpaceDesignerToolbox.OnToolRemoved Event
EcoSpaceDesignerToolbox Class EcoSpaceDesignerToolbox Members Eco.Handles.Design Namespace See Also
Collapse All

Raised when a tool is removed (using RemoveTool or RemoveToolAt).

C#
public static event EcoToolboxEventHandler OnToolRemoved;
See Also
EcoSpaceDesignerToolbox Class
EcoSpaceDesignerToolbox Members
Eco.Handles.Design Namespace


EcoSpaceInspector Class

EcoSpaceInspector Class
EcoSpaceInspector Members Inheritance Hierarchy See Also
Collapse All

Provider for context sensitive task help for EcoSpace.

C#
internal sealed class EcoSpaceInspector : Inspector;
Remarks

This class provides tool tips for DefaultEcoSpace. It is used by the EcoDesigner and should not be instantiated by user.

Inheritance Hierarchy
Eco.Handles.Design.EcoSpaceInspector
File

ComponentInspectors.cs

See Also
EcoSpaceInspector Members
Inheritance Hierarchy


EcoSpaceInspector Members

EcoSpaceInspector Members
Public Methods
Collapse All

The following tables list the members exposed by EcoSpaceInspector.

Public Methods
Name | Description
EcoSpaceInspector | This is EcoSpaceInspector, a member of class EcoSpaceInspector.
RetrieveToolTip | Adds the strings specific for PersistenceMapperBdp.


EcoSpaceInspector.EcoSpaceInspector Constructor

EcoSpaceInspector.EcoSpaceInspector Constructor
EcoSpaceInspector Class EcoSpaceInspector Members Eco.Handles.Design Namespace See Also
Collapse All
C#
public EcoSpaceInspector();
Remarks

This is EcoSpaceInspector, a member of class EcoSpaceInspector.

See Also
EcoSpaceInspector Class
EcoSpaceInspector Members
Eco.Handles.Design Namespace


EcoSpaceInspector Methods

EcoSpaceInspector Methods
Public Methods
Collapse All

The methods of the EcoSpaceInspector class are listed here.

Public Methods
Name | Description
RetrieveToolTip | Adds the strings specific for PersistenceMapperBdp.


EcoSpaceInspector.RetrieveToolTip Method

EcoSpaceInspector.RetrieveToolTip Method
EcoSpaceInspector Class EcoSpaceInspector Members Eco.Handles.Design Namespace See Also
Collapse All

Adds the strings specific for PersistenceMapperBdp.

C#
public override string RetrieveToolTip(
    object component
);
Parameters
Parameters | Description
component | The component to inspect.
See Also
EcoSpaceInspector Class
EcoSpaceInspector Members
Eco.Handles.Design Namespace


EcoSpaceTypeNameTypeConverter Class

EcoSpaceTypeNameTypeConverter Class
EcoSpaceTypeNameTypeConverter Members Inheritance Hierarchy See Also
Collapse All
C#
public class EcoSpaceTypeNameTypeConverter : GenericTypeNameConverter;
Remarks

This is class Eco.Handles.Design.EcoSpaceTypeNameTypeConverter.

Inheritance Hierarchy
Eco.Handles.Design.GenericTypeNameConverter
    Eco.Handles.Design.EcoSpaceTypeNameTypeConverter
File

EcoSpaceTypeNameTypeConverter.cs

See Also
EcoSpaceTypeNameTypeConverter Members
Inheritance Hierarchy


EcoSpaceTypeNameTypeConverter Members

EcoSpaceTypeNameTypeConverter Members
Protected Methods Public Methods
Collapse All

The following tables list the members exposed by EcoSpaceTypeNameTypeConverter.

Protected Methods
Name | Description
InternalAccept | This is InternalAccept, a member of class EcoSpaceTypeNameTypeConverter.
Top
Public Methods
Name | Description
GetStandardValues | This is GetStandardValues, a member of class GenericTypeNameConverter.
GetStandardValuesExclusive | This is GetStandardValuesExclusive, a member of class GenericTypeNameConverter.
GetStandardValuesSupported | This is GetStandardValuesSupported, a member of class GenericTypeNameConverter.


EcoSpaceTypeNameTypeConverter Methods

EcoSpaceTypeNameTypeConverter Methods
Protected Methods
Collapse All

The methods of the EcoSpaceTypeNameTypeConverter class are listed here.

Protected Methods
Name | Description
InternalAccept | This is InternalAccept, a member of class EcoSpaceTypeNameTypeConverter.


EcoSpaceTypeNameTypeConverter.InternalAccept Method

EcoSpaceTypeNameTypeConverter.InternalAccept Method
EcoSpaceTypeNameTypeConverter Class EcoSpaceTypeNameTypeConverter Members Eco.Handles.Design Namespace See Also
Collapse All
C#
protected override bool InternalAccept(
    Type type
);
Remarks

This is InternalAccept, a member of class EcoSpaceTypeNameTypeConverter.

See Also
EcoSpaceTypeNameTypeConverter Class
EcoSpaceTypeNameTypeConverter Members
Eco.Handles.Design Namespace


EcoSpaceTypeTypeConverter Class

EcoSpaceTypeTypeConverter Class
EcoSpaceTypeTypeConverter Members Inheritance Hierarchy See Also
Collapse All
C#
public class EcoSpaceTypeTypeConverter : TypeTypeConverter;
Remarks

This is class Eco.Handles.Design.EcoSpaceTypeTypeConverter.

Inheritance Hierarchy
Eco.Handles.Design.TypeTypeConverter
    Eco.Handles.Design.EcoSpaceTypeTypeConverter
File

EcoSpaceTypeNameTypeConverter.cs

See Also
EcoSpaceTypeTypeConverter Members
Inheritance Hierarchy


EcoSpaceTypeTypeConverter Members

EcoSpaceTypeTypeConverter Members
Public Methods
Collapse All

The following tables list the members exposed by EcoSpaceTypeTypeConverter.

Public Methods
Name | Description
CanConvertFrom |
CanConvertTo |
ConvertFrom |
ConvertTo | This is ConvertTo, a member of class TypeTypeConverter.
GetStandardValues | This is GetStandardValues, a member of class EcoSpaceTypeTypeConverter.
GetStandardValuesExclusive | This is GetStandardValuesExclusive, a member of class TypeTypeConverter.
GetStandardValuesSupported | This is GetStandardValuesSupported, a member of class TypeTypeConverter.
MyInterfaceFilter | This is MyInterfaceFilter, a member of class TypeTypeConverter.


EcoSpaceTypeTypeConverter Methods

EcoSpaceTypeTypeConverter Methods
Public Methods
Collapse All

The methods of the EcoSpaceTypeTypeConverter class are listed here.

Public Methods
Name | Description
GetStandardValues | This is GetStandardValues, a member of class EcoSpaceTypeTypeConverter.


EcoSpaceTypeTypeConverter.GetStandardValues Method

EcoSpaceTypeTypeConverter.GetStandardValues Method
EcoSpaceTypeTypeConverter Class EcoSpaceTypeTypeConverter Members Eco.Handles.Design Namespace See Also
Collapse All
C#
public override StandardValuesCollection GetStandardValues(
    ITypeDescriptorContext context
);
Remarks

This is GetStandardValues, a member of class EcoSpaceTypeTypeConverter.

See Also
EcoSpaceTypeTypeConverter Class
EcoSpaceTypeTypeConverter Members
Eco.Handles.Design Namespace


EcoToolboxArgs Class

EcoToolboxArgs Class
EcoToolboxArgs Members Inheritance Hierarchy See Also
Collapse All

Parameter class used when manipulating the tools registry.

C#
public class EcoToolboxArgs : EventArgs;
Remarks

Using a parameter class protectes callers from having to update the signature if the encapsulated parameter list changes.

Inheritance Hierarchy
Eco.Handles.Design.EcoToolboxArgs
File

EcoSpaceDesignerToolBox.cs

See Also
EcoToolboxArgs Members
Inheritance Hierarchy


EcoToolboxArgs Members

EcoToolboxArgs Members
Public Methods Public Properties
Collapse All

The following tables list the members exposed by EcoToolboxArgs.

Public Methods
Name | Description
EcoToolboxArgs | This is EcoToolboxArgs, a member of class EcoToolboxArgs.
Top
Public Properties
Name | Description
Tool | The tool operated on.


EcoToolboxArgs.EcoToolboxArgs Constructor

EcoToolboxArgs.EcoToolboxArgs Constructor
EcoToolboxArgs Class EcoToolboxArgs Members Eco.Handles.Design Namespace See Also
Collapse All
C#
public EcoToolboxArgs(
    IEcoSpaceDesignerTool tool
);
Remarks

This is EcoToolboxArgs, a member of class EcoToolboxArgs.

See Also
EcoToolboxArgs Class
EcoToolboxArgs Members
Eco.Handles.Design Namespace


EcoToolboxArgs Properties

EcoToolboxArgs Properties
Public Properties
Collapse All

The properties of the EcoToolboxArgs class are listed here.

Public Properties
Name | Description
Tool | The tool operated on.


EcoToolboxArgs.Tool Property

EcoToolboxArgs.Tool Property
EcoToolboxArgs Class EcoToolboxArgs Members Eco.Handles.Design Namespace See Also
Collapse All

The tool operated on.

C#
public IEcoSpaceDesignerTool Tool;
See Also
EcoToolboxArgs Class
EcoToolboxArgs Members
Eco.Handles.Design Namespace


EcoToolButtonBase Class

EcoToolButtonBase Class
EcoToolButtonBase Members Inheritance Hierarchy See Also
Collapse All

Basic implementation of the IEcoSpaceDesignerTool interface. Intended for subclassing.

C#
public class EcoToolButtonBase : IEcoSpaceDesignerTool, IComparable;
Inheritance Hierarchy
Eco.Handles.Design.IEcoSpaceDesignerTool
    Eco.Handles.Design.EcoToolButtonBase
        Eco.Handles.Design.SelectPackagesTool
File

EcoSpaceDesignerToolBox.cs

See Also
EcoToolButtonBase Members
Inheritance Hierarchy


EcoToolButtonBase Members

EcoToolButtonBase Members
Public Methods
Collapse All

The following tables list the members exposed by EcoToolButtonBase.

Public Methods
Name | Description
CompareTo | IComparable.CompareTo implementation. Compares the type only!
Execute | IEcoSpaceDesignerTool.Execute implementation.
GetCaption | Default implementation is to return the empty string.
GetDesignerTypes | IEcoSpaceDesignerTool.GetDesignerType implementation. Default is to belong to EcoSpace designer.
GetHint | Implements IEcoSpaceDesignerTool.GetHint().
GetImage | IEcoSpaceDesignerTool.GetImage implementation. This implementation is enough. Provided ToolboxBitmapAttribute is used on the implementation class GetImage will not need to be reimplemented. It's virtual to allow for other means of providing an image.
GetToolKind | IEcoSpaceDesignerTool.GetToolKind implementation.
RequireRecompile | IEcoSpaceDesignerTool.RequireRecompile implementation. Default is to return True.


EcoToolButtonBase Methods

EcoToolButtonBase Methods
Public Methods
Collapse All

The methods of the EcoToolButtonBase class are listed here.

Public Methods
Name | Description
CompareTo | IComparable.CompareTo implementation. Compares the type only!
Execute | IEcoSpaceDesignerTool.Execute implementation.
GetCaption | Default implementation is to return the empty string.
GetDesignerTypes | IEcoSpaceDesignerTool.GetDesignerType implementation. Default is to belong to EcoSpace designer.
GetHint | Implements IEcoSpaceDesignerTool.GetHint().
GetImage | IEcoSpaceDesignerTool.GetImage implementation. This implementation is enough. Provided ToolboxBitmapAttribute is used on the implementation class GetImage will not need to be reimplemented. It's virtual to allow for other means of providing an image.
GetToolKind | IEcoSpaceDesignerTool.GetToolKind implementation.
RequireRecompile | IEcoSpaceDesignerTool.RequireRecompile implementation. Default is to return True.


EcoToolButtonBase.CompareTo Method

EcoToolButtonBase.CompareTo Method
EcoToolButtonBase Class EcoToolButtonBase Members Eco.Handles.Design Namespace See Also
Collapse All

IComparable.CompareTo implementation. Compares the type only!

C#
public int CompareTo(
    object obj
);
Remarks

public override bool Equals(object obj) { // This could probably change to GetType() == obj.GetType(). return base.Equals(obj); } public override int GetHashCode() { return base.GetHashCode(); }

See Also
EcoToolButtonBase Class
EcoToolButtonBase Members
Eco.Handles.Design Namespace


EcoToolButtonBase.Execute Method

EcoToolButtonBase.Execute Method
EcoToolButtonBase Class EcoToolButtonBase Members Eco.Handles.Design Namespace See Also
Collapse All

IEcoSpaceDesignerTool.Execute implementation.

C#
public virtual void Execute(
    ExecuteArgs executeArgs
);
See Also
EcoToolButtonBase Class
EcoToolButtonBase Members
Eco.Handles.Design Namespace


EcoToolButtonBase.GetCaption Method

EcoToolButtonBase.GetCaption Method
EcoToolButtonBase Class EcoToolButtonBase Members Eco.Handles.Design Namespace See Also
Collapse All

Default implementation is to return the empty string.

C#
public virtual string GetCaption();
See Also
EcoToolButtonBase Class
EcoToolButtonBase Members
Eco.Handles.Design Namespace


EcoToolButtonBase.GetDesignerTypes Method

EcoToolButtonBase.GetDesignerTypes Method
EcoToolButtonBase Class EcoToolButtonBase Members Eco.Handles.Design Namespace See Also
Collapse All

IEcoSpaceDesignerTool.GetDesignerType implementation. Default is to belong to EcoSpace designer.

C#
public virtual DesignerTypes GetDesignerTypes();
Remarks

// Currently unused // private Image GetImageFromType(System.Type t) { if (t == null) return null; MessageHelper.AddMessage("Looking at " + t.ToString()); ToolboxBitmapAttribute bitmapAttribute = (ToolboxBitmapAttribute)Attribute.GetCustomAttribute(t, typeof(ToolboxBitmapAttribute)); if (bitmapAttribute != null) { MessageHelper.AddMessage("Returning from " + t.ToString()); return bitmapAttribute.GetImage(t); } else return GetImageFromType(t.BaseType); } *

See Also
EcoToolButtonBase Class
EcoToolButtonBase Members
Eco.Handles.Design Namespace


EcoToolButtonBase.GetHint Method

EcoToolButtonBase.GetHint Method
EcoToolButtonBase Class EcoToolButtonBase Members Eco.Handles.Design Namespace See Also
Collapse All

Implements IEcoSpaceDesignerTool.GetHint().

C#
public virtual string GetHint();
Remarks

Implements IEcoSpaceDesignerTool.GetHint(). There should be no need to actually override this method. This implementation simply removes ampersands from GetCaption().

See Also
EcoToolButtonBase Class
EcoToolButtonBase Members
Eco.Handles.Design Namespace


EcoToolButtonBase.GetImage Method

EcoToolButtonBase.GetImage Method
EcoToolButtonBase Class EcoToolButtonBase Members Eco.Handles.Design Namespace See Also
Collapse All

IEcoSpaceDesignerTool.GetImage implementation. This implementation is enough. Provided ToolboxBitmapAttribute is used on the implementation class GetImage will not need to be reimplemented. It's virtual to allow for other means of providing an image.

C#
public virtual Image GetImage();
See Also
EcoToolButtonBase Class
EcoToolButtonBase Members
Eco.Handles.Design Namespace


EcoToolButtonBase.GetToolKind Method

EcoToolButtonBase.GetToolKind Method
EcoToolButtonBase Class EcoToolButtonBase Members Eco.Handles.Design Namespace See Also
Collapse All

IEcoSpaceDesignerTool.GetToolKind implementation.

C#
public virtual EcoToolKind GetToolKind();
See Also
EcoToolButtonBase Class
EcoToolButtonBase Members
Eco.Handles.Design Namespace


EcoToolButtonBase.RequireRecompile Method

EcoToolButtonBase.RequireRecompile Method
EcoToolButtonBase Class EcoToolButtonBase Members Eco.Handles.Design Namespace See Also
Collapse All

IEcoSpaceDesignerTool.RequireRecompile implementation. Default is to return True.

C#
public virtual bool RequireRecompile();
See Also
EcoToolButtonBase Class
EcoToolButtonBase Members
Eco.Handles.Design Namespace


EcoValidationHelper Class

EcoValidationHelper Class
EcoValidationHelper Members Inheritance Hierarchy See Also
Collapse All
C#
public sealed class EcoValidationHelper;
Remarks

This is class Eco.Handles.Design.EcoValidationHelper.

Inheritance Hierarchy
Eco.Handles.Design.EcoValidationHelper
File

FormValidator.cs

See Also
EcoValidationHelper Members
Inheritance Hierarchy


EcoValidationHelper Members

EcoValidationHelper Members
Public Methods
Collapse All

The following tables list the members exposed by EcoValidationHelper.

Public Methods
Name | Description
ValidateEcoComponent | Helper method to validate ECO components with expressions.
ValidateExpression | Helper method to validate an expression.


EcoValidationHelper Methods

EcoValidationHelper Methods
Public Methods
Collapse All

The methods of the EcoValidationHelper class are listed here.

Public Methods
Name | Description
ValidateEcoComponent | Helper method to validate ECO components with expressions.
ValidateExpression | Helper method to validate an expression.


EcoValidationHelper.ValidateEcoComponent Method

EcoValidationHelper.ValidateEcoComponent Method
EcoValidationHelper Class EcoValidationHelper Members Eco.Handles.Design Namespace See Also
Collapse All

Helper method to validate ECO components with expressions.

C#
public static void ValidateEcoComponent(
    FormValidatorArgs args
);
Parameters
Parameters | Description
args | Parameter object.
Remarks

ECO components with an expression typically implement IHasEditableExpression. From there, enough information to validate the component's expression can be extracted. The Component in args is cast to an IHasEditableExpression. The expression is then validated using ValidateExpression.

See Also
EcoValidationHelper Class
EcoValidationHelper Members
Eco.Handles.Design Namespace


EcoValidationHelper.ValidateExpression Method

EcoValidationHelper.ValidateExpression Method
EcoValidationHelper Class EcoValidationHelper Members Eco.Handles.Design Namespace See Also
Collapse All

Helper method to validate an expression.

C#
public static void ValidateExpression(
    FormValidatorArgs args,
    string property,
    object component,
    ITypeService typeService,
    string expression,
    IClassifier context,
    IExternalVariableList variables,
    IClassifier expectedType
);
Parameters
Parameters | Description
args | Parameter object.
property | The name of the property the expression comes from. Used in error message.
component | The component the expression comes from. Used in error message.
typeService | The evaluator used to validate the expression.
expression | The expression to validate. Also used in error message.
context | The root from which the expression is evaluated.
variables | Variables to take into account when validating the expression.
expectedType | The expected resulting type of the expression.
Remarks

If the expression does not yield the expectedType an error is logged. Any exception during type checking is trapped and yields an error.

Exceptions
Exceptions | Description
ArgumentNullException | If args, component or typeService is null
See Also
EcoValidationHelper Class
EcoValidationHelper Members
Eco.Handles.Design Namespace


ErrorContextNode Class

ErrorContextNode Class
ErrorContextNode Members Inheritance Hierarchy See Also
Collapse All
C#
public class ErrorContextNode : ValidationContextNode;
Remarks

This is class Eco.Handles.Design.ErrorContextNode.

Inheritance Hierarchy
Eco.Handles.Design.ErrorContextNode
File

ContextValidationManager.cs

See Also
ErrorContextNode Members
Inheritance Hierarchy


ErrorContextNode Members

ErrorContextNode Members
Protected Methods Public Methods
Collapse All

The following tables list the members exposed by ErrorContextNode.

Protected Methods
Name | Description
BitmapKey | This is BitmapKey, a member of class ErrorContextNode.
EnsureToolboxItem | This is EnsureToolboxItem, a member of class ErrorContextNode.
Top
Public Methods
Name | Description
CanInvoke | This is CanInvoke, a member of class ErrorContextNode.
ErrorContextNode | This is the overview for the ErrorContextNode constructor overload.
Invoke | This is Invoke, a member of class ErrorContextNode.


ErrorContextNode Constructor

ErrorContextNode Constructor

This is the overview for the ErrorContextNode constructor overload.

Overload List
Name | Description
ErrorContextNode.ErrorContextNode (FormValidationIncident) | This is ErrorContextNode, a member of class ErrorContextNode.
ErrorContextNode.ErrorContextNode (object, string, string) | This is ErrorContextNode, a member of class ErrorContextNode.
ErrorContextNode.ErrorContextNode (string, Type) | This is ErrorContextNode, a member of class ErrorContextNode.


ErrorContextNode.ErrorContextNode Constructor (FormValidationIncident)

ErrorContextNode.ErrorContextNode Constructor (FormValidationIncident)
ErrorContextNode Class ErrorContextNode Members Eco.Handles.Design Namespace See Also
Collapse All
C#
public ErrorContextNode(
    FormValidationIncident incident
);
Remarks

This is ErrorContextNode, a member of class ErrorContextNode.

See Also
ErrorContextNode Class
ErrorContextNode Members
Eco.Handles.Design Namespace


ErrorContextNode.ErrorContextNode Constructor (object, string, string)

ErrorContextNode.ErrorContextNode Constructor (object, string, string)
ErrorContextNode Class ErrorContextNode Members Eco.Handles.Design Namespace See Also
Collapse All
C#
public ErrorContextNode(
    object owner,
    string description,
    string tooltip
);
Remarks

This is ErrorContextNode, a member of class ErrorContextNode.

See Also
ErrorContextNode Class
ErrorContextNode Members
Eco.Handles.Design Namespace


ErrorContextNode.ErrorContextNode Constructor (string, Type)

ErrorContextNode.ErrorContextNode Constructor (string, Type)
ErrorContextNode Class ErrorContextNode Members Eco.Handles.Design Namespace See Also
Collapse All
C#
public ErrorContextNode(
    string description,
    Type bitmapHolder
);
Remarks

This is ErrorContextNode, a member of class ErrorContextNode.

See Also
ErrorContextNode Class
ErrorContextNode Members
Eco.Handles.Design Namespace


ErrorContextNode Methods

ErrorContextNode Methods
Protected Methods Public Methods
Collapse All

The methods of the ErrorContextNode class are listed here.

Protected Methods
Name | Description
BitmapKey | This is BitmapKey, a member of class ErrorContextNode.
EnsureToolboxItem | This is EnsureToolboxItem, a member of class ErrorContextNode.
Top
Public Methods
Name | Description
CanInvoke | This is CanInvoke, a member of class ErrorContextNode.
Invoke | This is Invoke, a member of class ErrorContextNode.


ErrorContextNode.BitmapKey Method

ErrorContextNode.BitmapKey Method
ErrorContextNode Class ErrorContextNode Members Eco.Handles.Design Namespace See Also
Collapse All
C#
protected override string BitmapKey();
Remarks

This is BitmapKey, a member of class ErrorContextNode.

See Also
ErrorContextNode Class
ErrorContextNode Members
Eco.Handles.Design Namespace


ErrorContextNode.CanInvoke Method

ErrorContextNode.CanInvoke Method
ErrorContextNode Class ErrorContextNode Members Eco.Handles.Design Namespace See Also
Collapse All
C#
public override bool CanInvoke();
Remarks

This is CanInvoke, a member of class ErrorContextNode.

See Also
ErrorContextNode Class
ErrorContextNode Members
Eco.Handles.Design Namespace


ErrorContextNode.EnsureToolboxItem Method

ErrorContextNode.EnsureToolboxItem Method
ErrorContextNode Class ErrorContextNode Members Eco.Handles.Design Namespace See Also
Collapse All
C#
protected override void EnsureToolboxItem();
Remarks

This is EnsureToolboxItem, a member of class ErrorContextNode.

See Also
ErrorContextNode Class
ErrorContextNode Members
Eco.Handles.Design Namespace


ErrorContextNode.Invoke Method

ErrorContextNode.Invoke Method
ErrorContextNode Class ErrorContextNode Members Eco.Handles.Design Namespace See Also
Collapse All
C#
public override void Invoke();
Remarks

This is Invoke, a member of class ErrorContextNode.

See Also
ErrorContextNode Class
ErrorContextNode Members
Eco.Handles.Design Namespace


ErrorManager Class

ErrorManager Class
ErrorManager Members Inheritance Hierarchy See Also
Collapse All
C#
public class ErrorManager;
Remarks

This is class Eco.Handles.Design.ErrorManager.

Inheritance Hierarchy
Eco.Handles.Design.ErrorManager
    Eco.Handles.Design.ModelValidationManager
File

ContextValidationManager.cs

See Also
ErrorManager Members
Inheritance Hierarchy


ErrorManager Members

ErrorManager Members
Public Methods
Collapse All

The following tables list the members exposed by ErrorManager.

Public Methods
Name | Description
ErrorManager | This is ErrorManager, a member of class ErrorManager.


ErrorManager.ErrorManager Constructor

ErrorManager.ErrorManager Constructor
ErrorManager Class ErrorManager Members Eco.Handles.Design Namespace See Also
Collapse All
C#
public ErrorManager();
Remarks

This is ErrorManager, a member of class ErrorManager.

See Also
ErrorManager Class
ErrorManager Members
Eco.Handles.Design Namespace


EventTester Class

EventTester Class
EventTester Members Inheritance Hierarchy See Also
Collapse All

Tester to show which events get sent by the context manager.

C#
public sealed class EventTester;
Inheritance Hierarchy
Eco.Handles.Design.EventTester
File

WidgetSelector.cs

See Also
EventTester Members
Inheritance Hierarchy


EventTester Members

EventTester Members
Public Methods
Collapse All

The following tables list the members exposed by EventTester.

Public Methods
Name | Description
EventTester | This is EventTester, a member of class EventTester.


EventTester.EventTester Constructor

EventTester.EventTester Constructor
EventTester Class EventTester Members Eco.Handles.Design Namespace See Also
Collapse All
C#
public EventTester();
Remarks

This is EventTester, a member of class EventTester.

See Also
EventTester Class
EventTester Members
Eco.Handles.Design Namespace


ExecuteArgs Class

ExecuteArgs Class
ExecuteArgs Members Inheritance Hierarchy See Also
Collapse All

Parameter object passed to IEcoSpaceDesignerTool.Execute.

C#
public class ExecuteArgs;
Inheritance Hierarchy
Eco.Handles.Design.ExecuteArgs
File

EcoSpaceDesignerToolBox.cs

See Also
ExecuteArgs Members
Inheritance Hierarchy


ExecuteArgs Members

ExecuteArgs Members
Public Methods Public Properties
Collapse All

The following tables list the members exposed by ExecuteArgs.

Public Methods
Name | Description
ExecuteArgs | Creates a new parameter object, accepting all required parameters
Top
Public Properties
Name | Description
Component | Provide access to parameter Component.
EcoSpace | Provide properly typed access to parameter component as DefaultEcoSpace. Returns null if not of correct type.
ServiceProvider | Provide access to parameter ServiceProvider.
TypeResolutionService | Provide access to parameter TypeResolutionService.


ExecuteArgs.ExecuteArgs Constructor

ExecuteArgs.ExecuteArgs Constructor
ExecuteArgs Class ExecuteArgs Members Eco.Handles.Design Namespace See Also
Collapse All

Creates a new parameter object, accepting all required parameters

C#
public ExecuteArgs(
    IServiceProvider serviceProvider,
    IComponent component,
    ITypeResolutionService typeResolutionService
);
See Also
ExecuteArgs Class
ExecuteArgs Members
Eco.Handles.Design Namespace


ExecuteArgs Properties

ExecuteArgs Properties
Public Properties
Collapse All

The properties of the ExecuteArgs class are listed here.

Public Properties
Name | Description
Component | Provide access to parameter Component.
EcoSpace | Provide properly typed access to parameter component as DefaultEcoSpace. Returns null if not of correct type.
ServiceProvider | Provide access to parameter ServiceProvider.
TypeResolutionService | Provide access to parameter TypeResolutionService.


ExecuteArgs.Component Property

ExecuteArgs.Component Property
ExecuteArgs Class ExecuteArgs Members Eco.Handles.Design Namespace See Also
Collapse All

Provide access to parameter Component.

C#
public IComponent Component;
See Also
ExecuteArgs Class
ExecuteArgs Members
Eco.Handles.Design Namespace


ExecuteArgs.EcoSpace Property

ExecuteArgs.EcoSpace Property
ExecuteArgs Class ExecuteArgs Members Eco.Handles.Design Namespace See Also
Collapse All

Provide properly typed access to parameter component as DefaultEcoSpace. Returns null if not of correct type.

C#
public EcoSpace EcoSpace;
See Also
ExecuteArgs Class
ExecuteArgs Members
Eco.Handles.Design Namespace


ExecuteArgs.ServiceProvider Property

ExecuteArgs.ServiceProvider Property
ExecuteArgs Class ExecuteArgs Members Eco.Handles.Design Namespace See Also
Collapse All

Provide access to parameter ServiceProvider.

C#
public IServiceProvider ServiceProvider;
See Also
ExecuteArgs Class
ExecuteArgs Members
Eco.Handles.Design Namespace


ExecuteArgs.TypeResolutionService Property

ExecuteArgs.TypeResolutionService Property
ExecuteArgs Class ExecuteArgs Members Eco.Handles.Design Namespace See Also
Collapse All

Provide access to parameter TypeResolutionService.

C#
public ITypeResolutionService TypeResolutionService;
See Also
ExecuteArgs Class
ExecuteArgs Members
Eco.Handles.Design Namespace


ExpressionEditor Class

ExpressionEditor Class
ExpressionEditor Members Inheritance Hierarchy See Also
Collapse All

Abstract class for the editing of expressions on extended components. The only thing the subclasses have to provide is a ITypeService as returned by getOclTypeService.

C#
public abstract class ExpressionEditor : ModalExpressionEditor;
Inheritance Hierarchy
Eco.Handles.Design.ModalExpressionEditor
    Eco.Handles.Design.ExpressionEditor
        Eco.Handles.Design.ActionExpressionEditor
        Eco.Handles.Design.OclExpressionEditor
        Eco.Handles.Design.OclPsExpressionEditor
File

OCLEditorWakeup.cs

See Also
ExpressionEditor Members
Inheritance Hierarchy


ExpressionEditor Members

ExpressionEditor Members
Protected Methods Public Methods
Collapse All

The following tables list the members exposed by ExpressionEditor.

Protected Methods
Name | Description
getOclTypeService | Must be overridden! Returns the ITypeService the Eco.Windows.Forms.OclEditor uses to find the valid operations.
ModalExpressionEditor | This is ModalExpressionEditor, a member of class ModalExpressionEditor.
Top
Public Methods
Name | Description
EditValue | Collects information from the environment and invokes OclEditor.ShowEditor.
GetEditStyle | Sets the editor to be modal.


ExpressionEditor Methods

ExpressionEditor Methods
Protected Methods Public Methods
Collapse All

The methods of the ExpressionEditor class are listed here.

Protected Methods
Name | Description
getOclTypeService | Must be overridden! Returns the ITypeService the Eco.Windows.Forms.OclEditor uses to find the valid operations.
Top
Public Methods
Name | Description
EditValue | Collects information from the environment and invokes OclEditor.ShowEditor.


ExpressionEditor.EditValue Method

ExpressionEditor.EditValue Method
ExpressionEditor Class ExpressionEditor Members Eco.Handles.Design Namespace See Also
Collapse All

Collects information from the environment and invokes OclEditor.ShowEditor.

C#
public override object EditValue(
    ITypeDescriptorContext context,
    IServiceProvider provider,
    object value
);
Exceptions
Exceptions | Description
ArgumentNullException | Thrown if context is null.
InvalidOperationException | Thrown if the extender cannot be found. The handle connected to the extendee has no context. Thrown if the extendee is not connected to a handle.
See Also
ExpressionEditor Class
ExpressionEditor Members
Eco.Handles.Design Namespace


ExpressionEditor.getOclTypeService Method

ExpressionEditor.getOclTypeService Method
ExpressionEditor Class ExpressionEditor Members Eco.Handles.Design Namespace See Also
Collapse All

Must be overridden! Returns the ITypeService the Eco.Windows.Forms.OclEditor uses to find the valid operations.

C#
protected abstract ITypeService getOclTypeService(
    IStaticContext staticContext
);
See Also
ExpressionEditor Class
ExpressionEditor Members
Eco.Handles.Design Namespace


ExpressionHandleDesigner Class

ExpressionHandleDesigner Class
Inheritance Hierarchy See Also
Collapse All

Designer for ExpressionHandle.

C#
internal class ExpressionHandleDesigner : AbstractExpressionHandleDesigner;
Inheritance Hierarchy
Eco.Handles.Design.NotifyingDesigner
    Eco.Handles.Design.HandlesDesigner
        Eco.Handles.Design.RootedHandleDesigner
            Eco.Handles.Design.AbstractExpressionHandleDesigner
                Eco.Handles.Design.ExpressionHandleDesigner
File

Editors.cs

See Also
Inheritance Hierarchy


FormCreatorHandler Class

FormCreatorHandler Class
FormCreatorHandler Members Inheritance Hierarchy See Also
Collapse All
C#
public class FormCreatorHandler : CreatorHandler;
Remarks

This is class Eco.Handles.Design.FormCreatorHandler.

Inheritance Hierarchy
Eco.Handles.Design.CreatorHandler
    Eco.Handles.Design.FormCreatorHandler
File

UmlRtSelectors.cs

See Also
FormCreatorHandler Members
Inheritance Hierarchy


FormCreatorHandler Members

FormCreatorHandler Members
Public Methods Public Properties Protected Properties
Collapse All

The following tables list the members exposed by FormCreatorHandler.

Public Methods
Name | Description
Clear | Clears the CreatorGroup.CreatorDescriptorList.
CreatorHandler | Creates a new instance and reads information from xml-file.
FormCreatorHandler | This is FormCreatorHandler, a member of class FormCreatorHandler.
ReadFromXml | This is ReadFromXml, a member of class CreatorHandler.
RefreshCreatorTree | Adds creators for defined classes.
Top
Public Properties
Name | Description
CreatorGroup | The CreatorGroup represents the top node for this structure.
Top
Protected Properties
Name | Description
BinDir | Returns IIdeService.GetEcoConfigDir()
Filename | do not localize;
TopNodename | do not localize;


FormCreatorHandler.FormCreatorHandler Constructor

FormCreatorHandler.FormCreatorHandler Constructor
FormCreatorHandler Class FormCreatorHandler Members Eco.Handles.Design Namespace See Also
Collapse All
C#
public FormCreatorHandler();
Remarks

This is FormCreatorHandler, a member of class FormCreatorHandler.

See Also
FormCreatorHandler Class
FormCreatorHandler Members
Eco.Handles.Design Namespace


FormCreatorHandler Methods

FormCreatorHandler Methods
Public Methods
Collapse All

The methods of the FormCreatorHandler class are listed here.

Public Methods
Name | Description
RefreshCreatorTree | Adds creators for defined classes.


FormCreatorHandler.RefreshCreatorTree Method

FormCreatorHandler.RefreshCreatorTree Method
FormCreatorHandler Class FormCreatorHandler Members Eco.Handles.Design Namespace See Also
Collapse All

Adds creators for defined classes.

C#
public override void RefreshCreatorTree(
    DesignerData designerData
);
Remarks

InvokingComponent is Form, and the node is ReferenceHandle.

See Also
FormCreatorHandler Class
FormCreatorHandler Members
Eco.Handles.Design Namespace


FormCreatorHandler Properties

FormCreatorHandler Properties
Protected Properties
Collapse All

The properties of the FormCreatorHandler class are listed here.

Protected Properties
Name | Description
Filename | do not localize;
TopNodename | do not localize;


FormCreatorHandler.Filename Property

FormCreatorHandler.Filename Property
FormCreatorHandler Class FormCreatorHandler Members Eco.Handles.Design Namespace See Also
Collapse All
C#
protected override string Filename;
Remarks

do not localize;

See Also
FormCreatorHandler Class
FormCreatorHandler Members
Eco.Handles.Design Namespace


FormCreatorHandler.TopNodename Property

FormCreatorHandler.TopNodename Property
FormCreatorHandler Class FormCreatorHandler Members Eco.Handles.Design Namespace See Also
Collapse All
C#
protected override string TopNodename;
Remarks

do not localize;

See Also
FormCreatorHandler Class
FormCreatorHandler Members
Eco.Handles.Design Namespace


FormValidationIncident Class

FormValidationIncident Class
FormValidationIncident Members Inheritance Hierarchy See Also
Collapse All
C#
public class FormValidationIncident : ValidationIncident;
Remarks

This is class Eco.Handles.Design.FormValidationIncident.

Inheritance Hierarchy
Eco.Handles.Design.ValidationIncident
    Eco.Handles.Design.FormValidationIncident
File

FormValidationReport.cs

See Also
FormValidationIncident Members
Inheritance Hierarchy


FormValidationIncident Members

FormValidationIncident Members
Public Methods Public Properties
Collapse All

The following tables list the members exposed by FormValidationIncident.

Public Methods
Name | Description
FormValidationIncident | This is FormValidationIncident, a member of class FormValidationIncident.
ToShortString | This is ToShortString, a member of class FormValidationIncident.
ToString | This is ToString, a member of class FormValidationIncident.
ValidationIncident | This is ValidationIncident, a member of class ValidationIncident.
Top
Public Properties
Name | Description
Message | This is Message, a member of class ValidationIncident.
Owner | This is Owner, a member of class FormValidationIncident.
Severity | This is Severity, a member of class ValidationIncident.


FormValidationIncident.FormValidationIncident Constructor

FormValidationIncident.FormValidationIncident Constructor
FormValidationIncident Class FormValidationIncident Members Eco.Handles.Design Namespace See Also
Collapse All
C#
public FormValidationIncident(
    object owner,
    Severity severity,
    string message
);
Remarks

This is FormValidationIncident, a member of class FormValidationIncident.

See Also
FormValidationIncident Class
FormValidationIncident Members
Eco.Handles.Design Namespace


FormValidationIncident Methods

FormValidationIncident Methods
Public Methods
Collapse All

The methods of the FormValidationIncident class are listed here.

Public Methods
Name | Description
ToShortString | This is ToShortString, a member of class FormValidationIncident.
ToString | This is ToString, a member of class FormValidationIncident.


FormValidationIncident.ToShortString Method

FormValidationIncident.ToShortString Method
FormValidationIncident Class FormValidationIncident Members Eco.Handles.Design Namespace See Also
Collapse All
C#
public override string ToShortString();
Remarks

This is ToShortString, a member of class FormValidationIncident.

See Also
FormValidationIncident Class
FormValidationIncident Members
Eco.Handles.Design Namespace


FormValidationIncident.ToString Method

FormValidationIncident.ToString Method
FormValidationIncident Class FormValidationIncident Members Eco.Handles.Design Namespace See Also
Collapse All
C#
public override string ToString();
Remarks

This is ToString, a member of class FormValidationIncident.

See Also
FormValidationIncident Class
FormValidationIncident Members
Eco.Handles.Design Namespace


FormValidationIncident Properties

FormValidationIncident Properties
Public Properties
Collapse All

The properties of the FormValidationIncident class are listed here.

Public Properties
Name | Description
Owner | This is Owner, a member of class FormValidationIncident.


FormValidationIncident.Owner Property

FormValidationIncident.Owner Property
FormValidationIncident Class FormValidationIncident Members Eco.Handles.Design Namespace See Also
Collapse All
C#
public object Owner;
Remarks

This is Owner, a member of class FormValidationIncident.

See Also
FormValidationIncident Class
FormValidationIncident Members
Eco.Handles.Design Namespace


FormValidationReport Class

FormValidationReport Class
FormValidationReport Members Inheritance Hierarchy See Also
Collapse All
C#
public class FormValidationReport : ValidationReport;
Remarks

This is class Eco.Handles.Design.FormValidationReport.

Inheritance Hierarchy
Eco.Handles.Design.ValidationReport
    Eco.Handles.Design.FormValidationReport
File

FormValidationReport.cs

See Also
FormValidationReport Members
Inheritance Hierarchy


FormValidationReport Members

FormValidationReport Members
Public Methods Public Properties
Collapse All

The following tables list the members exposed by FormValidationReport.

Public Methods
Name | Description
AddError | This is AddError, a member of class FormValidationReport.
AddHint | This is AddHint, a member of class FormValidationReport.
AddInfo | This is AddInfo, a member of class FormValidationReport.
AddWarning | This is AddWarning, a member of class FormValidationReport.
Clear | This method resets the Incidents.
Count | This is Count, a member of class ValidationReport.
Print | Prints the all incidents ToString() in the IDE's message display facility.
Top
Public Properties
Name | Description
Incidents | This is Incidents, a member of class ValidationReport.


FormValidationReport Methods

FormValidationReport Methods
Public Methods
Collapse All

The methods of the FormValidationReport class are listed here.

Public Methods
Name | Description
AddError | This is AddError, a member of class FormValidationReport.
AddHint | This is AddHint, a member of class FormValidationReport.
AddInfo | This is AddInfo, a member of class FormValidationReport.
AddWarning | This is AddWarning, a member of class FormValidationReport.


FormValidationReport.AddError Method

FormValidationReport.AddError Method
FormValidationReport Class FormValidationReport Members Eco.Handles.Design Namespace See Also
Collapse All
C#
public void AddError(
    object owner,
    string message
);
Remarks

This is AddError, a member of class FormValidationReport.

See Also
FormValidationReport Class
FormValidationReport Members
Eco.Handles.Design Namespace


FormValidationReport.AddHint Method

FormValidationReport.AddHint Method
FormValidationReport Class FormValidationReport Members Eco.Handles.Design Namespace See Also
Collapse All
C#
public void AddHint(
    object owner,
    string message
);
Remarks

This is AddHint, a member of class FormValidationReport.

See Also
FormValidationReport Class
FormValidationReport Members
Eco.Handles.Design Namespace


FormValidationReport.AddInfo Method

FormValidationReport.AddInfo Method
FormValidationReport Class FormValidationReport Members Eco.Handles.Design Namespace See Also
Collapse All
C#
public void AddInfo(
    object owner,
    string message
);
Remarks

This is AddInfo, a member of class FormValidationReport.

See Also
FormValidationReport Class
FormValidationReport Members
Eco.Handles.Design Namespace


FormValidationReport.AddWarning Method

FormValidationReport.AddWarning Method
FormValidationReport Class FormValidationReport Members Eco.Handles.Design Namespace See Also
Collapse All
C#
public void AddWarning(
    object owner,
    string message
);
Remarks

This is AddWarning, a member of class FormValidationReport.

See Also
FormValidationReport Class
FormValidationReport Members
Eco.Handles.Design Namespace


FormValidator Class

FormValidator Class
FormValidator Members Inheritance Hierarchy See Also
Collapse All
C#
public class FormValidator : IFormValidationService;
Remarks

This is class Eco.Handles.Design.FormValidator.

Inheritance Hierarchy
Eco.Handles.Design.FormValidator
File

FormValidator.cs

See Also
FormValidator Members
Inheritance Hierarchy


FormValidator Members

FormValidator Members
Public Methods Public Properties
Collapse All

The following tables list the members exposed by FormValidator.

Public Methods
Name | Description
ValidateForm | This is ValidateForm, a member of class FormValidator.
ValidateProject | This is ValidateProject, a member of class FormValidator.
Top
Public Properties
Name | Description
Registry | Contains the list of all known validators.


FormValidator Methods

FormValidator Methods
Public Methods
Collapse All

The methods of the FormValidator class are listed here.

Public Methods
Name | Description
ValidateForm | This is ValidateForm, a member of class FormValidator.
ValidateProject | This is ValidateProject, a member of class FormValidator.


FormValidator.ValidateForm Method

FormValidator.ValidateForm Method
FormValidator Class FormValidator Members Eco.Handles.Design Namespace See Also
Collapse All
C#
public void ValidateForm(
    IIdeFile file
);
Remarks

This is ValidateForm, a member of class FormValidator.

See Also
FormValidator Class
FormValidator Members
Eco.Handles.Design Namespace


FormValidator.ValidateProject Method

FormValidator.ValidateProject Method
FormValidator Class FormValidator Members Eco.Handles.Design Namespace See Also
Collapse All
C#
public void ValidateProject(
    IIdeProject project
);
Remarks

This is ValidateProject, a member of class FormValidator.

See Also
FormValidator Class
FormValidator Members
Eco.Handles.Design Namespace


FormValidator Properties

FormValidator Properties
Public Properties
Collapse All

The properties of the FormValidator class are listed here.

Public Properties
Name | Description
Registry | Contains the list of all known validators.


FormValidator.Registry Property

FormValidator.Registry Property
FormValidator Class FormValidator Members Eco.Handles.Design Namespace See Also
Collapse All

Contains the list of all known validators.

C#
public static List<IFormValidator> Registry;
Remarks

To add a validation rule set to the validation sweep, use

Copy Code
Registry.Add(new MyValidation());
See Also
FormValidator Class
FormValidator Members
Eco.Handles.Design Namespace


FormValidatorArgs Class

FormValidatorArgs Class
FormValidatorArgs Members Inheritance Hierarchy See Also
Collapse All

Parameter object used when calling validation instances.

C#
public class FormValidatorArgs;
Remarks

Passed as parameter to IFormValidator.ValidateComponent.

Inheritance Hierarchy
Eco.Handles.Design.FormValidatorArgs
File

FormValidator.cs

See Also
FormValidatorArgs Members
Inheritance Hierarchy


FormValidatorArgs Members

FormValidatorArgs Members
Public Methods Public Properties
Collapse All

The following tables list the members exposed by FormValidatorArgs.

Public Methods
Name | Description
FormValidatorArgs | This is FormValidatorArgs, a member of class FormValidatorArgs.
Top
Public Properties
Name | Description
Component | The component currently being validated.
Components | All components on the form.
Report | Report object to collate all the error messages.
RootContext | Name of the form operating on.


FormValidatorArgs.FormValidatorArgs Constructor

FormValidatorArgs.FormValidatorArgs Constructor
FormValidatorArgs Class FormValidatorArgs Members Eco.Handles.Design Namespace See Also
Collapse All
C#
public FormValidatorArgs(
    string rootContext,
    object component,
    ComponentCollection components,
    FormValidationReport report
);
Remarks

This is FormValidatorArgs, a member of class FormValidatorArgs.

See Also
FormValidatorArgs Class
FormValidatorArgs Members
Eco.Handles.Design Namespace


FormValidatorArgs Properties

FormValidatorArgs Properties
Public Properties
Collapse All

The properties of the FormValidatorArgs class are listed here.

Public Properties
Name | Description
Component | The component currently being validated.
Components | All components on the form.
Report | Report object to collate all the error messages.
RootContext | Name of the form operating on.


FormValidatorArgs.Component Property

FormValidatorArgs.Component Property
FormValidatorArgs Class FormValidatorArgs Members Eco.Handles.Design Namespace See Also
Collapse All

The component currently being validated.

C#
public object Component;
See Also
FormValidatorArgs Class
FormValidatorArgs Members
Eco.Handles.Design Namespace


FormValidatorArgs.Components Property

FormValidatorArgs.Components Property
FormValidatorArgs Class FormValidatorArgs Members Eco.Handles.Design Namespace See Also
Collapse All

All components on the form.

C#
public ComponentCollection Components;
See Also
FormValidatorArgs Class
FormValidatorArgs Members
Eco.Handles.Design Namespace


FormValidatorArgs.Report Property

FormValidatorArgs.Report Property
FormValidatorArgs Class FormValidatorArgs Members Eco.Handles.Design Namespace See Also
Collapse All

Report object to collate all the error messages.

C#
public FormValidationReport Report;
See Also
FormValidatorArgs Class
FormValidatorArgs Members
Eco.Handles.Design Namespace


FormValidatorArgs.RootContext Property

FormValidatorArgs.RootContext Property
FormValidatorArgs Class FormValidatorArgs Members Eco.Handles.Design Namespace See Also
Collapse All

Name of the form operating on.

C#
public string RootContext;
See Also
FormValidatorArgs Class
FormValidatorArgs Members
Eco.Handles.Design Namespace


GenericTypeNameConverter Class

GenericTypeNameConverter Class
GenericTypeNameConverter Members Inheritance Hierarchy See Also
Collapse All
C#
public abstract class GenericTypeNameConverter : StringConverter, ITypeFilter;
Remarks

This is class Eco.Handles.Design.GenericTypeNameConverter.

Inheritance Hierarchy
Eco.Handles.Design.GenericTypeNameConverter
    Eco.Handles.Design.EcoSpaceTypeNameTypeConverter
File

EcoSpaceTypeNameTypeConverter.cs

See Also
GenericTypeNameConverter Members
Inheritance Hierarchy


GenericTypeNameConverter Members

GenericTypeNameConverter Members
Protected Methods Public Methods
Collapse All

The following tables list the members exposed by GenericTypeNameConverter.

Protected Methods
Name | Description
InternalAccept | This is InternalAccept, a member of class GenericTypeNameConverter.
Top
Public Methods
Name | Description
GetStandardValues | This is GetStandardValues, a member of class GenericTypeNameConverter.
GetStandardValuesExclusive | This is GetStandardValuesExclusive, a member of class GenericTypeNameConverter.
GetStandardValuesSupported | This is GetStandardValuesSupported, a member of class GenericTypeNameConverter.


GenericTypeNameConverter Methods

GenericTypeNameConverter Methods
Protected Methods Public Methods
Collapse All

The methods of the GenericTypeNameConverter class are listed here.

Protected Methods
Name | Description
InternalAccept | This is InternalAccept, a member of class GenericTypeNameConverter.
Top
Public Methods
Name | Description
GetStandardValues | This is GetStandardValues, a member of class GenericTypeNameConverter.
GetStandardValuesExclusive | This is GetStandardValuesExclusive, a member of class GenericTypeNameConverter.
GetStandardValuesSupported | This is GetStandardValuesSupported, a member of class GenericTypeNameConverter.


GenericTypeNameConverter.GetStandardValues Method

GenericTypeNameConverter.GetStandardValues Method
GenericTypeNameConverter Class GenericTypeNameConverter Members Eco.Handles.Design Namespace See Also
Collapse All
C#
public override StandardValuesCollection GetStandardValues(
    ITypeDescriptorContext context
);
Remarks

This is GetStandardValues, a member of class GenericTypeNameConverter.

See Also
GenericTypeNameConverter Class
GenericTypeNameConverter Members
Eco.Handles.Design Namespace


GenericTypeNameConverter.GetStandardValuesExclusive Method

GenericTypeNameConverter.GetStandardValuesExclusive Method
GenericTypeNameConverter Class GenericTypeNameConverter Members Eco.Handles.Design Namespace See Also
Collapse All
C#
public override bool GetStandardValuesExclusive(
    ITypeDescriptorContext context
);
Remarks

This is GetStandardValuesExclusive, a member of class GenericTypeNameConverter.

See Also
GenericTypeNameConverter Class
GenericTypeNameConverter Members
Eco.Handles.Design Namespace


GenericTypeNameConverter.GetStandardValuesSupported Method

GenericTypeNameConverter.GetStandardValuesSupported Method
GenericTypeNameConverter Class GenericTypeNameConverter Members Eco.Handles.Design Namespace See Also
Collapse All
C#
public override bool GetStandardValuesSupported(
    ITypeDescriptorContext context
);
Remarks

This is GetStandardValuesSupported, a member of class GenericTypeNameConverter.

See Also
GenericTypeNameConverter Class
GenericTypeNameConverter Members
Eco.Handles.Design Namespace


GenericTypeNameConverter.InternalAccept Method

GenericTypeNameConverter.InternalAccept Method
GenericTypeNameConverter Class GenericTypeNameConverter Members Eco.Handles.Design Namespace See Also
Collapse All
C#
protected abstract bool InternalAccept(
    Type type
);
Remarks

This is InternalAccept, a member of class GenericTypeNameConverter.

See Also
GenericTypeNameConverter Class
GenericTypeNameConverter Members
Eco.Handles.Design Namespace


HandlesDesigner Class

HandlesDesigner Class
HandlesDesigner Members Inheritance Hierarchy See Also
Collapse All

HandlesDesigner adds the verb to create default columns - this is common for all handles.

C#
public abstract class HandlesDesigner : NotifyingDesigner;
Inheritance Hierarchy
Eco.Handles.Design.NotifyingDesigner
    Eco.Handles.Design.HandlesDesigner
        Eco.Handles.Design.RootedHandleDesigner
File

Editors.cs

See Also
HandlesDesigner Members
Inheritance Hierarchy


HandlesDesigner Members

HandlesDesigner Members
Protected Methods Public Methods Public Properties
Collapse All

The following tables list the members exposed by HandlesDesigner.

Protected Methods
Name | Description
Dispose | Unhooks up the OnComponentRemoved from IComponentChangeService.ComponentRemoved. Calls base.Dispose.
OnCreateDefaultColumns | Implements the creation of default columns.
Top
Public Methods
Name | Description
Initialize | Calls base.Initialize and then hooks up the OnComponentRemoved to IComponentChangeService.ComponentRemoved.
Top
Public Properties
Name | Description
Verbs | Installs the defined verbs.


HandlesDesigner Methods

HandlesDesigner Methods
Protected Methods
Collapse All

The methods of the HandlesDesigner class are listed here.

Protected Methods
Name | Description
OnCreateDefaultColumns | Implements the creation of default columns.


HandlesDesigner.OnCreateDefaultColumns Method

HandlesDesigner.OnCreateDefaultColumns Method
HandlesDesigner Class HandlesDesigner Members Eco.Handles.Design Namespace See Also
Collapse All

Implements the creation of default columns.

C#
protected void OnCreateDefaultColumns(
    object sender,
    EventArgs e
);
See Also
HandlesDesigner Class
HandlesDesigner Members
Eco.Handles.Design Namespace


HandlesDesigner Properties

HandlesDesigner Properties
Public Properties
Collapse All

The properties of the HandlesDesigner class are listed here.

Public Properties
Name | Description
Verbs | Installs the defined verbs.


HandlesDesigner.Verbs Property

HandlesDesigner.Verbs Property
HandlesDesigner Class HandlesDesigner Members Eco.Handles.Design Namespace See Also
Collapse All

Installs the defined verbs.

C#
public override DesignerVerbCollection Verbs;
See Also
HandlesDesigner Class
HandlesDesigner Members
Eco.Handles.Design Namespace


HintHelper Class

HintHelper Class
HintHelper Members Inheritance Hierarchy See Also
Collapse All

HintHelper creates the strings shown in the fly-over hints as used by the Inspector mechanisms.

C#
public sealed class HintHelper;
Inheritance Hierarchy
Eco.Handles.Design.HintHelper
File

ComponentInspectors.cs

See Also
HintHelper Members
Inheritance Hierarchy


HintHelper Members

HintHelper Members
Public Methods
Collapse All

The following tables list the members exposed by HintHelper.

Public Methods
Name | Description
AddHintString | Appends the hint prepended with a string checkmark representation of the checkmark to sb


HintHelper Methods

HintHelper Methods
Public Methods
Collapse All

The methods of the HintHelper class are listed here.

Public Methods
Name | Description
AddHintString | Appends the hint prepended with a string checkmark representation of the checkmark to sb


HintHelper.AddHintString Method

HintHelper.AddHintString Method
HintHelper Class HintHelper Members Eco.Handles.Design Namespace See Also
Collapse All

Appends the hint prepended with a string checkmark representation of the checkmark to sb

C#
public static void AddHintString(
    StringBuilder sb,
    bool checkmark,
    string hint
);
Parameters
Parameters | Description
sb | The StringBuilder that is appended to.
checkmark | Used to indicate if the hint shall appear checked or unchecked.
hint | The hint to display.
See Also
HintHelper Class
HintHelper Members
Eco.Handles.Design Namespace


IdeHelper Class

IdeHelper Class
IdeHelper Members Inheritance Hierarchy See Also
Collapse All

Static helper class used to isolate IDE dependencies, and to be able to retrieve information about the environment easier.

C#
public sealed class IdeHelper;
Inheritance Hierarchy
Eco.Handles.Design.IdeHelper
File

IDEHelpers.cs

See Also
IdeHelper Members
Inheritance Hierarchy


IdeHelper Members

IdeHelper Members
Public Methods
Collapse All

The following tables list the members exposed by IdeHelper.

Public Methods
Name | Description
EcoSpaceType | This is EcoSpaceType, a member of class IdeHelper.
GetTypeSystemServiceForFirstClass | Assumes that the codedomprovider for the site contains the EcoSpace class as the first class.
ProjectNeedsRebuild | This is the overview for the ProjectNeedsRebuild method overload.


IdeHelper Methods

IdeHelper Methods
Public Methods
Collapse All

The methods of the IdeHelper class are listed here.

Public Methods
Name | Description
EcoSpaceType | This is EcoSpaceType, a member of class IdeHelper.
GetTypeSystemServiceForFirstClass | Assumes that the codedomprovider for the site contains the EcoSpace class as the first class.
ProjectNeedsRebuild | This is the overview for the ProjectNeedsRebuild method overload.


IdeHelper.EcoSpaceType Method

IdeHelper.EcoSpaceType Method
IdeHelper Class IdeHelper Members Eco.Handles.Design Namespace See Also
Collapse All
C#
public static System.Type EcoSpaceType(
    IServiceProvider site,
    ITypeResolutionService typeResolutionService
);
Remarks

This is EcoSpaceType, a member of class IdeHelper.

See Also
IdeHelper Class
IdeHelper Members
Eco.Handles.Design Namespace


IdeHelper.GetTypeSystemServiceForFirstClass Method

IdeHelper.GetTypeSystemServiceForFirstClass Method
IdeHelper Class IdeHelper Members Eco.Handles.Design Namespace See Also
Collapse All
C#
public static ITypeSystemService GetTypeSystemServiceForFirstClass(
    bool required,
    IServiceProvider site,
    ITypeResolutionService typeResolutionService,
    bool mayRecompile
);
Remarks

Assumes that the codedomprovider for the site contains the EcoSpace class as the first class.

See Also
IdeHelper Class
IdeHelper Members
Eco.Handles.Design Namespace


ProjectNeedsRebuild Method

ProjectNeedsRebuild Method

This is the overview for the ProjectNeedsRebuild method overload.

Overload List
Name | Description
IdeHelper.ProjectNeedsRebuild () | Determines if the project of the active module needs rebuilding (with respect to model changes).
IdeHelper.ProjectNeedsRebuild (IIdeProject) | Determines if the project needs rebuilding (with respect to model changes).
IdeHelper.ProjectNeedsRebuild (IServiceProvider) | Determines if the project owning the site needs rebuilding (with respect to model changes).


IdeHelper.ProjectNeedsRebuild Method ()

IdeHelper.ProjectNeedsRebuild Method ()
IdeHelper Class IdeHelper Members Eco.Handles.Design Namespace See Also
Collapse All

Determines if the project of the active module needs rebuilding (with respect to model changes).

C#
public static bool ProjectNeedsRebuild();
See Also
IdeHelper Class
IdeHelper Members
Eco.Handles.Design Namespace


IdeHelper.ProjectNeedsRebuild Method (IIdeProject)

IdeHelper.ProjectNeedsRebuild Method (IIdeProject)
IdeHelper Class IdeHelper Members Eco.Handles.Design Namespace See Also
Collapse All

Determines if the project needs rebuilding (with respect to model changes).

C#
public static bool ProjectNeedsRebuild(
    IIdeProject project
);
See Also
IdeHelper Class
IdeHelper Members
Eco.Handles.Design Namespace


IdeHelper.ProjectNeedsRebuild Method (IServiceProvider)

IdeHelper.ProjectNeedsRebuild Method (IServiceProvider)
IdeHelper Class IdeHelper Members Eco.Handles.Design Namespace See Also
Collapse All

Determines if the project owning the site needs rebuilding (with respect to model changes).

C#
public static bool ProjectNeedsRebuild(
    IServiceProvider site
);
See Also
IdeHelper Class
IdeHelper Members
Eco.Handles.Design Namespace


ListActionCreatorHandler Class

ListActionCreatorHandler Class
ListActionCreatorHandler Members Inheritance Hierarchy See Also
Collapse All
C#
public class ListActionCreatorHandler : CreatorHandler;
Remarks

This is class Eco.Handles.Design.ListActionCreatorHandler.

Inheritance Hierarchy
Eco.Handles.Design.CreatorHandler
    Eco.Handles.Design.ListActionCreatorHandler
File

ListDisplaySelector.cs

See Also
ListActionCreatorHandler Members
Inheritance Hierarchy


ListActionCreatorHandler Members

ListActionCreatorHandler Members
Public Methods Public Properties Protected Properties
Collapse All

The following tables list the members exposed by ListActionCreatorHandler.

Public Methods
Name | Description
Clear | Clears the CreatorGroup.CreatorDescriptorList.
CreatorHandler | Creates a new instance and reads information from xml-file.
ListActionCreatorHandler | This is ListActionCreatorHandler, a member of class ListActionCreatorHandler.
ReadFromXml | This is ReadFromXml, a member of class CreatorHandler.
RefreshCreatorTree | Adds all ListActionExtender actions to the list.
Top
Public Properties
Name | Description
CreatorGroup | The CreatorGroup represents the top node for this structure.
Top
Protected Properties
Name | Description
BinDir | Returns IIdeService.GetEcoConfigDir()
Filename | do not localize;
TopNodename | do not localize


ListActionCreatorHandler.ListActionCreatorHandler Constructor

ListActionCreatorHandler.ListActionCreatorHandler Constructor
ListActionCreatorHandler Class ListActionCreatorHandler Members Eco.Handles.Design Namespace See Also
Collapse All
C#
public ListActionCreatorHandler();
Remarks

This is ListActionCreatorHandler, a member of class ListActionCreatorHandler.

See Also
ListActionCreatorHandler Class
ListActionCreatorHandler Members
Eco.Handles.Design Namespace


ListActionCreatorHandler Methods

ListActionCreatorHandler Methods
Public Methods
Collapse All

The methods of the ListActionCreatorHandler class are listed here.

Public Methods
Name | Description
RefreshCreatorTree | Adds all ListActionExtender actions to the list.


ListActionCreatorHandler.RefreshCreatorTree Method

ListActionCreatorHandler.RefreshCreatorTree Method
ListActionCreatorHandler Class ListActionCreatorHandler Members Eco.Handles.Design Namespace See Also
Collapse All

Adds all ListActionExtender actions to the list.

C#
public override void RefreshCreatorTree(
    DesignerData designerData
);
See Also
ListActionCreatorHandler Class
ListActionCreatorHandler Members
Eco.Handles.Design Namespace


ListActionCreatorHandler Properties

ListActionCreatorHandler Properties
Protected Properties
Collapse All

The properties of the ListActionCreatorHandler class are listed here.

Protected Properties
Name | Description
Filename | do not localize;
TopNodename | do not localize


ListActionCreatorHandler.Filename Property

ListActionCreatorHandler.Filename Property
ListActionCreatorHandler Class ListActionCreatorHandler Members Eco.Handles.Design Namespace See Also
Collapse All
C#
protected override string Filename;
Remarks

do not localize;

See Also
ListActionCreatorHandler Class
ListActionCreatorHandler Members
Eco.Handles.Design Namespace


ListActionCreatorHandler.TopNodename Property

ListActionCreatorHandler.TopNodename Property
ListActionCreatorHandler Class ListActionCreatorHandler Members Eco.Handles.Design Namespace See Also
Collapse All
C#
protected override string TopNodename;
Remarks

do not localize

See Also
ListActionCreatorHandler Class
ListActionCreatorHandler Members
Eco.Handles.Design Namespace


MessageDisplay Class

MessageDisplay Class
MessageDisplay Members Inheritance Hierarchy See Also
Collapse All

Helper class implementing IMessageDisplay to allow IDE logic to uniformly display messages in the IDE. Relies on MessageHelper to display messages.

C#
public sealed class MessageDisplay : System.Object, IMessageDisplay;
Inheritance Hierarchy
Eco.Handles.Design.MessageDisplay
File

IDEMessages.cs

See Also
MessageDisplay Members
Inheritance Hierarchy


MessageDisplay Members

MessageDisplay Members
Public Methods
Collapse All

The following tables list the members exposed by MessageDisplay.

Public Methods
Name | Description
AddMessage | This is the overview for the AddMessage method overload.


MessageDisplay Methods

MessageDisplay Methods
Public Methods
Collapse All

The methods of the MessageDisplay class are listed here.

Public Methods
Name | Description
AddMessage | This is the overview for the AddMessage method overload.


AddMessage Method

AddMessage Method

This is the overview for the AddMessage method overload.

Overload List
Name | Description
MessageDisplay.AddMessage (string) | Adds an untitled message to the IDE message display facilities.
MessageDisplay.AddMessage (string, string) | Adds a titled message to the IDE message display facilities.


MessageDisplay.AddMessage Method (string)

MessageDisplay.AddMessage Method (string)
MessageDisplay Class MessageDisplay Members Eco.Handles.Design Namespace See Also
Collapse All

Adds an untitled message to the IDE message display facilities.

C#
public void AddMessage(
    string message
);
See Also
MessageDisplay Class
MessageDisplay Members
Eco.Handles.Design Namespace


MessageDisplay.AddMessage Method (string, string)

MessageDisplay.AddMessage Method (string, string)
MessageDisplay Class MessageDisplay Members Eco.Handles.Design Namespace See Also
Collapse All

Adds a titled message to the IDE message display facilities.

C#
public void AddMessage(
    string title,
    string message
);
See Also
MessageDisplay Class
MessageDisplay Members
Eco.Handles.Design Namespace


MessageHelper Class

MessageHelper Class
MessageHelper Members Inheritance Hierarchy See Also
Collapse All

Singleton helper class to uniformly reach into the IDE's message display facilities.

C#
public static class MessageHelper;
Inheritance Hierarchy
Eco.Handles.Design.MessageHelper
File

IDEMessages.cs

See Also
MessageHelper Members
Inheritance Hierarchy


MessageHelper Members

MessageHelper Members
Public Methods
Collapse All

The following tables list the members exposed by MessageHelper.

Public Methods
Name | Description
AddErrorMessage | This is the overview for the AddErrorMessage method overload.
AddMessage | This is the overview for the AddMessage method overload.
ClearEcoTab | Clears the tab associated with ECO messages.
CloseEcoTab | Closes the tab associated with ECO messages.
DebugMessage | This is the overview for the DebugMessage method overload.


MessageHelper Methods

MessageHelper Methods
Public Methods
Collapse All

The methods of the MessageHelper class are listed here.

Public Methods
Name | Description
AddErrorMessage | This is the overview for the AddErrorMessage method overload.
AddMessage | This is the overview for the AddMessage method overload.
ClearEcoTab | Clears the tab associated with ECO messages.
CloseEcoTab | Closes the tab associated with ECO messages.
DebugMessage | This is the overview for the DebugMessage method overload.


AddErrorMessage Method

AddErrorMessage Method

This is the overview for the AddErrorMessage method overload.

Overload List
Name | Description
MessageHelper.AddErrorMessage (string) | Adds an error message to the IDE error message display facilities.
MessageHelper.AddErrorMessage (string, Exception) | Adds a titled error message to the IDE error message display facilities.
MessageHelper.AddErrorMessage (string, string) | Adds a titled error message to the IDE error message display facilities.


MessageHelper.AddErrorMessage Method (string)

MessageHelper.AddErrorMessage Method (string)
MessageHelper Class MessageHelper Members Eco.Handles.Design Namespace See Also
Collapse All

Adds an error message to the IDE error message display facilities.

C#
public static void AddErrorMessage(
    string message
);
Parameters
Parameters | Description
message | The message to log.
See Also
MessageHelper Class
MessageHelper Members
Eco.Handles.Design Namespace


MessageHelper.AddErrorMessage Method (string, Exception)

MessageHelper.AddErrorMessage Method (string, Exception)
MessageHelper Class MessageHelper Members Eco.Handles.Design Namespace See Also
Collapse All

Adds a titled error message to the IDE error message display facilities.

C#
public static void AddErrorMessage(
    string title,
    Exception e
);
Parameters
Parameters | Description
title | The title of the message.
e | The exception to log.
See Also
MessageHelper Class
MessageHelper Members
Eco.Handles.Design Namespace


MessageHelper.AddErrorMessage Method (string, string)

MessageHelper.AddErrorMessage Method (string, string)
MessageHelper Class MessageHelper Members Eco.Handles.Design Namespace See Also
Collapse All

Adds a titled error message to the IDE error message display facilities.

C#
public static void AddErrorMessage(
    string title,
    string message
);
Parameters
Parameters | Description
title | The title of the message.
message | The message to log.
See Also
MessageHelper Class
MessageHelper Members
Eco.Handles.Design Namespace


AddMessage Method

AddMessage Method

This is the overview for the AddMessage method overload.

Overload List
Name | Description
MessageHelper.AddMessage (Exception) | Displays the message of the exception to the message facility of the IDE.
MessageHelper.AddMessage (string) | Adds an untitled message to the IDE message display facilities.
MessageHelper.AddMessage (string, Exception) | Displays the message of the exception preceded by title to the message facility of the IDE.
MessageHelper.AddMessage (string, string) | Adds a titled message to the IDE message display facilities.


MessageHelper.AddMessage Method (Exception)

MessageHelper.AddMessage Method (Exception)
MessageHelper Class MessageHelper Members Eco.Handles.Design Namespace See Also
Collapse All

Displays the message of the exception to the message facility of the IDE.

C#
public static void AddMessage(
    Exception e
);
Parameters
Parameters | Description
e | The exception to log.
Remarks

The first string is the Exception.Message string. Then the ToString() of the exception is emitted indented and preceeded by vertical bar.

See Also
MessageHelper Class
MessageHelper Members
Eco.Handles.Design Namespace


MessageHelper.AddMessage Method (string)

MessageHelper.AddMessage Method (string)
MessageHelper Class MessageHelper Members Eco.Handles.Design Namespace See Also
Collapse All

Adds an untitled message to the IDE message display facilities.

C#
public static void AddMessage(
    string message
);
Parameters
Parameters | Description
message | The message to log.
See Also
MessageHelper Class
MessageHelper Members
Eco.Handles.Design Namespace


MessageHelper.AddMessage Method (string, Exception)

MessageHelper.AddMessage Method (string, Exception)
MessageHelper Class MessageHelper Members Eco.Handles.Design Namespace See Also
Collapse All

Displays the message of the exception preceded by title to the message facility of the IDE.

C#
public static void AddMessage(
    string title,
    Exception e
);
Parameters
Parameters | Description
title | The title of the message.
e | The exception to log.
Remarks

The first string is the Exception.Message string. Then the ToString() of the exception is emitted indented and preceeded by vertical bar.

See Also
MessageHelper Class
MessageHelper Members
Eco.Handles.Design Namespace


MessageHelper.AddMessage Method (string, string)

MessageHelper.AddMessage Method (string, string)
MessageHelper Class MessageHelper Members Eco.Handles.Design Namespace See Also
Collapse All

Adds a titled message to the IDE message display facilities.

C#
public static void AddMessage(
    string title,
    string message
);
Parameters
Parameters | Description
title | The title of the message.
message | The message to log.
See Also
MessageHelper Class
MessageHelper Members
Eco.Handles.Design Namespace


MessageHelper.ClearEcoTab Method

MessageHelper.ClearEcoTab Method
MessageHelper Class MessageHelper Members Eco.Handles.Design Namespace See Also
Collapse All

Clears the tab associated with ECO messages.

C#
public static void ClearEcoTab();
See Also
MessageHelper Class
MessageHelper Members
Eco.Handles.Design Namespace


MessageHelper.CloseEcoTab Method

MessageHelper.CloseEcoTab Method
MessageHelper Class MessageHelper Members Eco.Handles.Design Namespace See Also
Collapse All

Closes the tab associated with ECO messages.

C#
public static void CloseEcoTab();
See Also
MessageHelper Class
MessageHelper Members
Eco.Handles.Design Namespace


DebugMessage Method

DebugMessage Method

This is the overview for the DebugMessage method overload.

Overload List
Name | Description
MessageHelper.DebugMessage (string) | Intended for debug use. Messages will not be displayed unless compiled in DEBUG mode.
MessageHelper.DebugMessage (string, string) | Intended for debug use. Messages will not be displayed unless compiled in DEBUG mode.


MessageHelper.DebugMessage Method (string)

MessageHelper.DebugMessage Method (string)
MessageHelper Class MessageHelper Members Eco.Handles.Design Namespace See Also
Collapse All

Intended for debug use. Messages will not be displayed unless compiled in DEBUG mode.

C#
public static void DebugMessage(
    string message
);
Parameters
Parameters | Description
message | The message to log.
See Also
MessageHelper Class
MessageHelper Members
Eco.Handles.Design Namespace


MessageHelper.DebugMessage Method (string, string)

MessageHelper.DebugMessage Method (string, string)
MessageHelper Class MessageHelper Members Eco.Handles.Design Namespace See Also
Collapse All

Intended for debug use. Messages will not be displayed unless compiled in DEBUG mode.

C#
public static void DebugMessage(
    string title,
    string message
);
Parameters
Parameters | Description
title | The title of the message.
message | The message to log.
See Also
MessageHelper Class
MessageHelper Members
Eco.Handles.Design Namespace


MetaCreator Class

MetaCreator Class
MetaCreator Members Inheritance Hierarchy See Also
Collapse All

Represents a component group that can be created.

C#
public class MetaCreator : CreatorInfo;
Inheritance Hierarchy
Eco.Handles.Design.CreatorInfo
    Eco.Handles.Design.MetaCreator
File

ContextComponentDictionary.cs

See Also
MetaCreator Members
Inheritance Hierarchy


MetaCreator Members

MetaCreator Members
Public Methods Public Properties
Collapse All

The following tables list the members exposed by MetaCreator.

Public Methods
Name | Description
AddComponentDefinition | Adds a component to be created to the group.
Bitmap | Returns the bitmap as found by information from XML-file.
CheckFilter | This is CheckFilter, a member of class MetaCreator.
EffectiveNodeName | Name of node as shown in tree (node.Text) with expansion of macros.
MetaCreator | Nodename defaults to {name}
SetNodeInfo | Called from xml reader to set information as read from xml-file
Top
Public Properties
Name | Description
BitmapKey | do not localize
Description | Description of node as read from xml-file-
FilterAssembly | This is FilterAssembly, a member of class MetaCreator.
FilterType | This is FilterType, a member of class MetaCreator.
IsDefault | Indicates if this is the default comonent set.
Name | The name of the component group as specified in the xml-file.
Nodename | Name of node as read from xml-file.


MetaCreator.MetaCreator Constructor

MetaCreator.MetaCreator Constructor
MetaCreator Class MetaCreator Members Eco.Handles.Design Namespace See Also
Collapse All
C#
public MetaCreator(
    string name
);
Remarks

Nodename defaults to {name}

See Also
MetaCreator Class
MetaCreator Members
Eco.Handles.Design Namespace


MetaCreator Methods

MetaCreator Methods
Public Methods
Collapse All

The methods of the MetaCreator class are listed here.

Public Methods
Name | Description
AddComponentDefinition | Adds a component to be created to the group.
CheckFilter | This is CheckFilter, a member of class MetaCreator.
EffectiveNodeName | Name of node as shown in tree (node.Text) with expansion of macros.


MetaCreator.AddComponentDefinition Method

MetaCreator.AddComponentDefinition Method
MetaCreator Class MetaCreator Members Eco.Handles.Design Namespace See Also
Collapse All

Adds a component to be created to the group.

C#
public void AddComponentDefinition(
    ComponentDefinition componentDefinition
);
See Also
MetaCreator Class
MetaCreator Members
Eco.Handles.Design Namespace


MetaCreator.CheckFilter Method

MetaCreator.CheckFilter Method
MetaCreator Class MetaCreator Members Eco.Handles.Design Namespace See Also
Collapse All
C#
public bool CheckFilter(
    IComponent invokingComponent
);
Remarks

This is CheckFilter, a member of class MetaCreator.

See Also
MetaCreator Class
MetaCreator Members
Eco.Handles.Design Namespace


MetaCreator.EffectiveNodeName Method

MetaCreator.EffectiveNodeName Method
MetaCreator Class MetaCreator Members Eco.Handles.Design Namespace See Also
Collapse All

Name of node as shown in tree (node.Text) with expansion of macros.

C#
public override string EffectiveNodeName(
    CreatorNodeDescriptor descriptor
);
Remarks

Expands {name} with Name and {descriptorname} with descriptor.Name if descriptor is not null.

See Also
MetaCreator Class
MetaCreator Members
Eco.Handles.Design Namespace


MetaCreator Properties

MetaCreator Properties
Public Properties
Collapse All

The properties of the MetaCreator class are listed here.

Public Properties
Name | Description
FilterAssembly | This is FilterAssembly, a member of class MetaCreator.
FilterType | This is FilterType, a member of class MetaCreator.
IsDefault | Indicates if this is the default comonent set.
Name | The name of the component group as specified in the xml-file.


MetaCreator.FilterAssembly Property

MetaCreator.FilterAssembly Property
MetaCreator Class MetaCreator Members Eco.Handles.Design Namespace See Also
Collapse All
C#
public string FilterAssembly;
Remarks

This is FilterAssembly, a member of class MetaCreator.

See Also
MetaCreator Class
MetaCreator Members
Eco.Handles.Design Namespace


MetaCreator.FilterType Property

MetaCreator.FilterType Property
MetaCreator Class MetaCreator Members Eco.Handles.Design Namespace See Also
Collapse All
C#
public string FilterType;
Remarks

This is FilterType, a member of class MetaCreator.

See Also
MetaCreator Class
MetaCreator Members
Eco.Handles.Design Namespace


MetaCreator.IsDefault Property

MetaCreator.IsDefault Property
MetaCreator Class MetaCreator Members Eco.Handles.Design Namespace See Also
Collapse All

Indicates if this is the default comonent set.

C#
public bool IsDefault;
See Also
MetaCreator Class
MetaCreator Members
Eco.Handles.Design Namespace


MetaCreator.Name Property

MetaCreator.Name Property
MetaCreator Class MetaCreator Members Eco.Handles.Design Namespace See Also
Collapse All

The name of the component group as specified in the xml-file.

C#
public string Name;
See Also
MetaCreator Class
MetaCreator Members
Eco.Handles.Design Namespace


MetaCreatorType Class

MetaCreatorType Class
MetaCreatorType Members Inheritance Hierarchy See Also
Collapse All

This class represents a statically defined group of component sets.

C#
public class MetaCreatorType : CreatorInfo;
Inheritance Hierarchy
Eco.Handles.Design.CreatorInfo
    Eco.Handles.Design.MetaCreatorType
File

ContextComponentDictionary.cs

See Also
MetaCreatorType Members
Inheritance Hierarchy


MetaCreatorType Members

MetaCreatorType Members
Public Methods Public Properties
Collapse All

The following tables list the members exposed by MetaCreatorType.

Public Methods
Name | Description
AddMetaCreator | Adds the instance to the list of statically known MetaCreator.
Bitmap | Returns the bitmap as found by information from XML-file.
EffectiveNodeName | Name of node as shown in tree (node.Text) with expansion of macros.
MetaCreatorType | Nodename defaults to {descriptorname}
SetNodeInfo | Called from xml reader to set information as read from xml-file
this | Returns the MetaCreator registered at index.
Top
Public Properties
Name | Description
BitmapKey | do not localize
Count | Number of registered MetaCreator instances.
DefaultMetaCreator | Returns the default MetaCreator for this group.
Description | Description of node as read from xml-file-
Filter | The filter that caused this group to be created (as read from XML-file).
Nodename | Name of node as read from xml-file.


MetaCreatorType.MetaCreatorType Constructor

MetaCreatorType.MetaCreatorType Constructor
MetaCreatorType Class MetaCreatorType Members Eco.Handles.Design Namespace See Also
Collapse All
C#
public MetaCreatorType(
    string filter
);
Remarks

Nodename defaults to {descriptorname}

See Also
MetaCreatorType Class
MetaCreatorType Members
Eco.Handles.Design Namespace


MetaCreatorType Methods

MetaCreatorType Methods
Public Methods
Collapse All

The methods of the MetaCreatorType class are listed here.

Public Methods
Name | Description
AddMetaCreator | Adds the instance to the list of statically known MetaCreator.
EffectiveNodeName | Name of node as shown in tree (node.Text) with expansion of macros.
this | Returns the MetaCreator registered at index.


MetaCreatorType.AddMetaCreator Method

MetaCreatorType.AddMetaCreator Method
MetaCreatorType Class MetaCreatorType Members Eco.Handles.Design Namespace See Also
Collapse All

Adds the instance to the list of statically known MetaCreator.

C#
public void AddMetaCreator(
    MetaCreator metaCreator
);
Remarks

If metaCreator is null nothing is added to the list.

See Also
MetaCreatorType Class
MetaCreatorType Members
Eco.Handles.Design Namespace


MetaCreatorType.EffectiveNodeName Method

MetaCreatorType.EffectiveNodeName Method
MetaCreatorType Class MetaCreatorType Members Eco.Handles.Design Namespace See Also
Collapse All

Name of node as shown in tree (node.Text) with expansion of macros.

C#
public override string EffectiveNodeName(
    CreatorNodeDescriptor descriptor
);
Remarks

Expands {name} with Filter and {descriptorname} with descriptor.Name if descriptor is not null.

See Also
MetaCreatorType Class
MetaCreatorType Members
Eco.Handles.Design Namespace


MetaCreatorType.this Indexer

MetaCreatorType.this Indexer
MetaCreatorType Class MetaCreatorType Members Eco.Handles.Design Namespace See Also
Collapse All

Returns the MetaCreator registered at index.

C#
public MetaCreator this[
    int index
];
See Also
MetaCreatorType Class
MetaCreatorType Members
Eco.Handles.Design Namespace


MetaCreatorType Properties

MetaCreatorType Properties
Public Properties
Collapse All

The properties of the MetaCreatorType class are listed here.

Public Properties
Name | Description
Count | Number of registered MetaCreator instances.
DefaultMetaCreator | Returns the default MetaCreator for this group.
Filter | The filter that caused this group to be created (as read from XML-file).


MetaCreatorType.Count Property

MetaCreatorType.Count Property
MetaCreatorType Class MetaCreatorType Members Eco.Handles.Design Namespace See Also
Collapse All

Number of registered MetaCreator instances.

C#
public int Count;
See Also
MetaCreatorType Class
MetaCreatorType Members
Eco.Handles.Design Namespace


MetaCreatorType.DefaultMetaCreator Property

MetaCreatorType.DefaultMetaCreator Property
MetaCreatorType Class MetaCreatorType Members Eco.Handles.Design Namespace See Also
Collapse All

Returns the default MetaCreator for this group.

C#
public MetaCreator DefaultMetaCreator;
Remarks

Returns the first MetaCreator marked as default. If no MetaCreator is marked as default, the first in the list is returned. If there are no items in the list, null is returned.

See Also
MetaCreatorType Class
MetaCreatorType Members
Eco.Handles.Design Namespace


MetaCreatorType.Filter Property

MetaCreatorType.Filter Property
MetaCreatorType Class MetaCreatorType Members Eco.Handles.Design Namespace See Also
Collapse All

The filter that caused this group to be created (as read from XML-file).

C#
public string Filter;
See Also
MetaCreatorType Class
MetaCreatorType Members
Eco.Handles.Design Namespace


ModalExpressionEditor Class

ModalExpressionEditor Class
ModalExpressionEditor Members Inheritance Hierarchy See Also
Collapse All

Base class for the OCL editor callers. This class adds modality to the brought up editor.

C#
public abstract class ModalExpressionEditor : System.Drawing.Design.UITypeEditor;
Inheritance Hierarchy
Eco.Handles.Design.ModalExpressionEditor
    Eco.Handles.Design.ExpressionEditor
    Eco.Handles.Design.OclEditorWakeup
    Eco.Handles.Design.SecondOclEditorWakeup
File

OCLEditorWakeup.cs

See Also
ModalExpressionEditor Members
Inheritance Hierarchy


ModalExpressionEditor Members

ModalExpressionEditor Members
Protected Methods Public Methods
Collapse All

The following tables list the members exposed by ModalExpressionEditor.

Protected Methods
Name | Description
ModalExpressionEditor | This is ModalExpressionEditor, a member of class ModalExpressionEditor.
Top
Public Methods
Name | Description
GetEditStyle | Sets the editor to be modal.


ModalExpressionEditor.ModalExpressionEditor Constructor

ModalExpressionEditor.ModalExpressionEditor Constructor
ModalExpressionEditor Class ModalExpressionEditor Members Eco.Handles.Design Namespace See Also
Collapse All
C#
protected ModalExpressionEditor();
Remarks

This is ModalExpressionEditor, a member of class ModalExpressionEditor.

See Also
ModalExpressionEditor Class
ModalExpressionEditor Members
Eco.Handles.Design Namespace


ModalExpressionEditor Methods

ModalExpressionEditor Methods
Public Methods
Collapse All

The methods of the ModalExpressionEditor class are listed here.

Public Methods
Name | Description
GetEditStyle | Sets the editor to be modal.


ModalExpressionEditor.GetEditStyle Method

ModalExpressionEditor.GetEditStyle Method
ModalExpressionEditor Class ModalExpressionEditor Members Eco.Handles.Design Namespace See Also
Collapse All

Sets the editor to be modal.

C#
public override UITypeEditorEditStyle GetEditStyle(
    ITypeDescriptorContext context
);
See Also
ModalExpressionEditor Class
ModalExpressionEditor Members
Eco.Handles.Design Namespace


ModelElementNodeDescriptor Class

ModelElementNodeDescriptor Class
ModelElementNodeDescriptor Members Inheritance Hierarchy See Also
Collapse All
C#
public class ModelElementNodeDescriptor : CreatorNodeDescriptor;
Remarks

This is class Eco.Handles.Design.ModelElementNodeDescriptor.

Inheritance Hierarchy
Eco.Handles.Design.CreatorNodeDescriptor
    Eco.Handles.Design.ModelElementNodeDescriptor
File

UmlRtSelectors.cs

See Also
ModelElementNodeDescriptor Members
Inheritance Hierarchy


ModelElementNodeDescriptor Members

ModelElementNodeDescriptor Members
Public Methods Public Properties
Collapse All

The following tables list the members exposed by ModelElementNodeDescriptor.

Public Methods
Name | Description
CreatorNodeDescriptor | This is CreatorNodeDescriptor, a member of class CreatorNodeDescriptor.
DragInvoke | Invokes the MetaCreator linked to creatorInfo to create components.
Invoke | Invokes the MetaCreator linked to creatorInfo to create components.
MetaCreatorList | Derived list of all dynamically registered MetaCreator used to build UI nodes.
ModelElementNodeDescriptor | This is ModelElementNodeDescriptor, a member of class ModelElementNodeDescriptor.
ToString | String representation is defined as DisplayName.
Top
Public Properties
Name | Description
Description | This is Description, a member of class CreatorNodeDescriptor.
DisplayName | This is DisplayName, a member of class ModelElementNodeDescriptor.
MetaCreatorType | The MetaCreatorType with the list of defined component sets.
MetaCreatorTypeList | This is MetaCreatorTypeList, a member of class CreatorNodeDescriptor.
Name | This is Name, a member of class ModelElementNodeDescriptor.
ToolTip | This is ToolTip, a member of class CreatorNodeDescriptor.


ModelElementNodeDescriptor.ModelElementNodeDescriptor Constructor

ModelElementNodeDescriptor.ModelElementNodeDescriptor Constructor
ModelElementNodeDescriptor Class ModelElementNodeDescriptor Members Eco.Handles.Design Namespace See Also
Collapse All
C#
public ModelElementNodeDescriptor(
    IModelElement modelElement
);
Remarks

This is ModelElementNodeDescriptor, a member of class ModelElementNodeDescriptor.

See Also
ModelElementNodeDescriptor Class
ModelElementNodeDescriptor Members
Eco.Handles.Design Namespace


ModelElementNodeDescriptor Properties

ModelElementNodeDescriptor Properties
Public Properties
Collapse All

The properties of the ModelElementNodeDescriptor class are listed here.

Public Properties
Name | Description
DisplayName | This is DisplayName, a member of class ModelElementNodeDescriptor.
Name | This is Name, a member of class ModelElementNodeDescriptor.


ModelElementNodeDescriptor.DisplayName Property

ModelElementNodeDescriptor.DisplayName Property
ModelElementNodeDescriptor Class ModelElementNodeDescriptor Members Eco.Handles.Design Namespace See Also
Collapse All
C#
public override string DisplayName;
Remarks

This is DisplayName, a member of class ModelElementNodeDescriptor.

See Also
ModelElementNodeDescriptor Class
ModelElementNodeDescriptor Members
Eco.Handles.Design Namespace


ModelElementNodeDescriptor.Name Property

ModelElementNodeDescriptor.Name Property
ModelElementNodeDescriptor Class ModelElementNodeDescriptor Members Eco.Handles.Design Namespace See Also
Collapse All
C#
public override string Name;
Remarks

This is Name, a member of class ModelElementNodeDescriptor.

See Also
ModelElementNodeDescriptor Class
ModelElementNodeDescriptor Members
Eco.Handles.Design Namespace


ModelValidationContextNode Class

ModelValidationContextNode Class
ModelValidationContextNode Members Inheritance Hierarchy See Also
Collapse All
C#
public class ModelValidationContextNode : ValidationContextNode;
Remarks

This is class Eco.Handles.Design.ModelValidationContextNode.

Inheritance Hierarchy
Eco.Handles.Design.ModelValidationContextNode
File

ModelValidationManager.cs

See Also
ModelValidationContextNode Members
Inheritance Hierarchy


ModelValidationContextNode Members

ModelValidationContextNode Members
Protected Methods Public Methods Public Properties
Collapse All

The following tables list the members exposed by ModelValidationContextNode.

Protected Methods
Name | Description
BitmapKey | This is BitmapKey, a member of class ModelValidationContextNode.
EnsureToolboxItem | This is EnsureToolboxItem, a member of class ModelValidationContextNode.
Top
Public Methods
Name | Description
CanInvoke | This is CanInvoke, a member of class ModelValidationContextNode.
Invoke | This is Invoke, a member of class ModelValidationContextNode.
ModelValidationContextNode | This is the overview for the ModelValidationContextNode constructor overload.
Top
Public Properties
Name | Description
ModelElement | This is ModelElement, a member of class ModelValidationContextNode.


ModelValidationContextNode Constructor

ModelValidationContextNode Constructor

This is the overview for the ModelValidationContextNode constructor overload.

Overload List
Name | Description
ModelValidationContextNode.ModelValidationContextNode (ModelValidationIncident) | This is ModelValidationContextNode, a member of class ModelValidationContextNode.
ModelValidationContextNode.ModelValidationContextNode (object, string) | This is ModelValidationContextNode, a member of class ModelValidationContextNode.
ModelValidationContextNode.ModelValidationContextNode (object, string, string) | This is ModelValidationContextNode, a member of class ModelValidationContextNode.
ModelValidationContextNode.ModelValidationContextNode (string, Type) | This is ModelValidationContextNode, a member of class ModelValidationContextNode.


ModelValidationContextNode.ModelValidationContextNode Constructor (ModelValidationIncident)

ModelValidationContextNode.ModelValidationContextNode Constructor (ModelValidationIncident)
ModelValidationContextNode Class ModelValidationContextNode Members Eco.Handles.Design Namespace See Also
Collapse All
C#
public ModelValidationContextNode(
    ModelValidationIncident incident
);
Remarks

This is ModelValidationContextNode, a member of class ModelValidationContextNode.

See Also
ModelValidationContextNode Class
ModelValidationContextNode Members
Eco.Handles.Design Namespace


ModelValidationContextNode.ModelValidationContextNode Constructor (object, string)

ModelValidationContextNode.ModelValidationContextNode Constructor (object, string)
ModelValidationContextNode Class ModelValidationContextNode Members Eco.Handles.Design Namespace See Also
Collapse All
C#
public ModelValidationContextNode(
    object owner,
    string description
);
Remarks

This is ModelValidationContextNode, a member of class ModelValidationContextNode.

See Also
ModelValidationContextNode Class
ModelValidationContextNode Members
Eco.Handles.Design Namespace


ModelValidationContextNode.ModelValidationContextNode Constructor (object, string, string)

ModelValidationContextNode.ModelValidationContextNode Constructor (object, string, string)
ModelValidationContextNode Class ModelValidationContextNode Members Eco.Handles.Design Namespace See Also
Collapse All
C#
public ModelValidationContextNode(
    object owner,
    string description,
    string tooltip
);
Remarks

This is ModelValidationContextNode, a member of class ModelValidationContextNode.

See Also
ModelValidationContextNode Class
ModelValidationContextNode Members
Eco.Handles.Design Namespace


ModelValidationContextNode.ModelValidationContextNode Constructor (string, Type)

ModelValidationContextNode.ModelValidationContextNode Constructor (string, Type)
ModelValidationContextNode Class ModelValidationContextNode Members Eco.Handles.Design Namespace See Also
Collapse All
C#
public ModelValidationContextNode(
    string description,
    Type bitmapHolder
);
Remarks

This is ModelValidationContextNode, a member of class ModelValidationContextNode.

See Also
ModelValidationContextNode Class
ModelValidationContextNode Members
Eco.Handles.Design Namespace


ModelValidationContextNode Methods

ModelValidationContextNode Methods
Protected Methods Public Methods
Collapse All

The methods of the ModelValidationContextNode class are listed here.

Protected Methods
Name | Description
BitmapKey | This is BitmapKey, a member of class ModelValidationContextNode.
EnsureToolboxItem | This is EnsureToolboxItem, a member of class ModelValidationContextNode.
Top
Public Methods
Name | Description
CanInvoke | This is CanInvoke, a member of class ModelValidationContextNode.
Invoke | This is Invoke, a member of class ModelValidationContextNode.


ModelValidationContextNode.BitmapKey Method

ModelValidationContextNode.BitmapKey Method
ModelValidationContextNode Class ModelValidationContextNode Members Eco.Handles.Design Namespace See Also
Collapse All
C#
protected override string BitmapKey();
Remarks

This is BitmapKey, a member of class ModelValidationContextNode.

See Also
ModelValidationContextNode Class
ModelValidationContextNode Members
Eco.Handles.Design Namespace


ModelValidationContextNode.CanInvoke Method

ModelValidationContextNode.CanInvoke Method
ModelValidationContextNode Class ModelValidationContextNode Members Eco.Handles.Design Namespace See Also
Collapse All
C#
public override bool CanInvoke();
Remarks

This is CanInvoke, a member of class ModelValidationContextNode.

See Also
ModelValidationContextNode Class
ModelValidationContextNode Members
Eco.Handles.Design Namespace


ModelValidationContextNode.EnsureToolboxItem Method

ModelValidationContextNode.EnsureToolboxItem Method
ModelValidationContextNode Class ModelValidationContextNode Members Eco.Handles.Design Namespace See Also
Collapse All
C#
protected override void EnsureToolboxItem();
Remarks

This is EnsureToolboxItem, a member of class ModelValidationContextNode.

See Also
ModelValidationContextNode Class
ModelValidationContextNode Members
Eco.Handles.Design Namespace


ModelValidationContextNode.Invoke Method

ModelValidationContextNode.Invoke Method
ModelValidationContextNode Class ModelValidationContextNode Members Eco.Handles.Design Namespace See Also
Collapse All
C#
public override void Invoke();
Remarks

This is Invoke, a member of class ModelValidationContextNode.

See Also
ModelValidationContextNode Class
ModelValidationContextNode Members
Eco.Handles.Design Namespace


ModelValidationContextNode Properties

ModelValidationContextNode Properties
Public Properties
Collapse All

The properties of the ModelValidationContextNode class are listed here.

Public Properties
Name | Description
ModelElement | This is ModelElement, a member of class ModelValidationContextNode.


ModelValidationContextNode.ModelElement Property

ModelValidationContextNode.ModelElement Property
ModelValidationContextNode Class ModelValidationContextNode Members Eco.Handles.Design Namespace See Also
Collapse All
C#
public IModelElement ModelElement;
Remarks

This is ModelElement, a member of class ModelValidationContextNode.

See Also
ModelValidationContextNode Class
ModelValidationContextNode Members
Eco.Handles.Design Namespace


ModelValidationIncident Class

ModelValidationIncident Class
ModelValidationIncident Members Inheritance Hierarchy See Also
Collapse All
C#
public class ModelValidationIncident : ValidationIncident;
Remarks

This is class Eco.Handles.Design.ModelValidationIncident.

Inheritance Hierarchy
Eco.Handles.Design.ValidationIncident
    Eco.Handles.Design.ModelValidationIncident
File

ModelValidationReport.cs

See Also
ModelValidationIncident Members
Inheritance Hierarchy


ModelValidationIncident Members

ModelValidationIncident Members
Public Methods Public Properties
Collapse All

The following tables list the members exposed by ModelValidationIncident.

Public Methods
Name | Description
ModelValidationIncident | This is ModelValidationIncident, a member of class ModelValidationIncident.
ToShortString | This is ToShortString, a member of class ValidationIncident.
ToString | This is ToString, a member of class ModelValidationIncident.
ValidationIncident | This is ValidationIncident, a member of class ValidationIncident.
Top
Public Properties
Name | Description
Message | This is Message, a member of class ValidationIncident.
Owner | This is Owner, a member of class ModelValidationIncident.
Severity | This is Severity, a member of class ValidationIncident.


ModelValidationIncident.ModelValidationIncident Constructor

ModelValidationIncident.ModelValidationIncident Constructor
ModelValidationIncident Class ModelValidationIncident Members Eco.Handles.Design Namespace See Also
Collapse All
C#
public ModelValidationIncident(
    IModelElement owner,
    Severity severity,
    string message
);
Remarks

This is ModelValidationIncident, a member of class ModelValidationIncident.

See Also
ModelValidationIncident Class
ModelValidationIncident Members
Eco.Handles.Design Namespace


ModelValidationIncident Methods

ModelValidationIncident Methods
Public Methods
Collapse All

The methods of the ModelValidationIncident class are listed here.

Public Methods
Name | Description
ToString | This is ToString, a member of class ModelValidationIncident.


ModelValidationIncident.ToString Method

ModelValidationIncident.ToString Method
ModelValidationIncident Class ModelValidationIncident Members Eco.Handles.Design Namespace See Also
Collapse All
C#
public override string ToString();
Remarks

This is ToString, a member of class ModelValidationIncident.

See Also
ModelValidationIncident Class
ModelValidationIncident Members
Eco.Handles.Design Namespace


ModelValidationIncident Properties

ModelValidationIncident Properties
Public Properties
Collapse All

The properties of the ModelValidationIncident class are listed here.

Public Properties
Name | Description
Owner | This is Owner, a member of class ModelValidationIncident.


ModelValidationIncident.Owner Property

ModelValidationIncident.Owner Property
ModelValidationIncident Class ModelValidationIncident Members Eco.Handles.Design Namespace See Also
Collapse All
C#
public IModelElement Owner;
Remarks

This is Owner, a member of class ModelValidationIncident.

See Also
ModelValidationIncident Class
ModelValidationIncident Members
Eco.Handles.Design Namespace


ModelValidationManager Class

ModelValidationManager Class
ModelValidationManager Members Inheritance Hierarchy See Also
Collapse All
C#
public class ModelValidationManager : ErrorManager;
Remarks

This is class Eco.Handles.Design.ModelValidationManager.

Inheritance Hierarchy
Eco.Handles.Design.ErrorManager
    Eco.Handles.Design.ModelValidationManager
File

ModelValidationManager.cs

See Also
ModelValidationManager Members
Inheritance Hierarchy


ModelValidationManager Members

ModelValidationManager Members
Public Methods
Collapse All

The following tables list the members exposed by ModelValidationManager.

Public Methods
Name | Description
ErrorManager | This is ErrorManager, a member of class ErrorManager.
ModelValidationManager | This is ModelValidationManager, a member of class ModelValidationManager.


ModelValidationManager.ModelValidationManager Constructor

ModelValidationManager.ModelValidationManager Constructor
ModelValidationManager Class ModelValidationManager Members Eco.Handles.Design Namespace See Also
Collapse All
C#
public ModelValidationManager();
Remarks

This is ModelValidationManager, a member of class ModelValidationManager.

See Also
ModelValidationManager Class
ModelValidationManager Members
Eco.Handles.Design Namespace


ModelValidationReport Class

ModelValidationReport Class
ModelValidationReport Members Inheritance Hierarchy See Also
Collapse All

Handles the information generated by a validation pass.

C#
public class ModelValidationReport : ValidationReport;
Inheritance Hierarchy
Eco.Handles.Design.ValidationReport
    Eco.Handles.Design.ModelValidationReport
File

ModelValidationReport.cs

See Also
ModelValidationReport Members
Inheritance Hierarchy


ModelValidationReport Members

ModelValidationReport Members
Public Methods Public Properties
Collapse All

The following tables list the members exposed by ModelValidationReport.

Public Methods
Name | Description
AddError | Call this method to add information about a validation error. Messages will be prefixed with MVE.
AddHint | Call this method to add information about a validation hint. Messages will be prefixed with MVH.
AddWarning | Call this method to add information about a validation warning. Messages will be prefixed with MVW.
Clear | This method resets the Incidents.
Count | This is Count, a member of class ValidationReport.
Print | Prints the all incidents ToString() in the IDE's message display facility.
Top
Public Properties
Name | Description
Incidents | This is Incidents, a member of class ValidationReport.


ModelValidationReport Methods

ModelValidationReport Methods
Public Methods
Collapse All

The methods of the ModelValidationReport class are listed here.

Public Methods
Name | Description
AddError | Call this method to add information about a validation error. Messages will be prefixed with MVE.
AddHint | Call this method to add information about a validation hint. Messages will be prefixed with MVH.
AddWarning | Call this method to add information about a validation warning. Messages will be prefixed with MVW.


ModelValidationReport.AddError Method

ModelValidationReport.AddError Method
ModelValidationReport Class ModelValidationReport Members Eco.Handles.Design Namespace See Also
Collapse All

Call this method to add information about a validation error. Messages will be prefixed with MVE.

C#
public void AddError(
    string description,
    IModelElement element
);
Parameters
Parameters | Description
description | The message to add.
element | The model element causing the error.
See Also
ModelValidationReport Class
ModelValidationReport Members
Eco.Handles.Design Namespace


ModelValidationReport.AddHint Method

ModelValidationReport.AddHint Method
ModelValidationReport Class ModelValidationReport Members Eco.Handles.Design Namespace See Also
Collapse All

Call this method to add information about a validation hint. Messages will be prefixed with MVH.

C#
public void AddHint(
    string description,
    IModelElement element
);
Parameters
Parameters | Description
description | The message to add.
element | The model element causing the error.
See Also
ModelValidationReport Class
ModelValidationReport Members
Eco.Handles.Design Namespace


ModelValidationReport.AddWarning Method

ModelValidationReport.AddWarning Method
ModelValidationReport Class ModelValidationReport Members Eco.Handles.Design Namespace See Also
Collapse All

Call this method to add information about a validation warning. Messages will be prefixed with MVW.

C#
public void AddWarning(
    string description,
    IModelElement element
);
Parameters
Parameters | Description
description | The message to add.
element | The model element causing the error.
See Also
ModelValidationReport Class
ModelValidationReport Members
Eco.Handles.Design Namespace


NameManipulator Class

NameManipulator Class
NameManipulator Members Inheritance Hierarchy See Also
Collapse All

Sets the name of the component.

C#
public class NameManipulator : AbstractManipulator;
Remarks

If the component is one of Label, TextBox, ListBox, ComboBox, CheckBox, DataGrid the name will be set to [prefix]propertyParams.Name[i]. In other cases the name will not change. Dupe checking code is there to prevent names from being reused.

Inheritance Hierarchy
Eco.Handles.Design.AbstractManipulator
    Eco.Handles.Design.NameManipulator
File

PropertyManipulators.cs

See Also
NameManipulator Members
Inheritance Hierarchy


NameManipulator Members

NameManipulator Members
Protected Methods Public Methods
Collapse All

The following tables list the members exposed by NameManipulator.

Protected Methods
Name | Description
GetPrefix | This is GetPrefix, a member of class NameManipulator.
PreviousComponent | Returns the previously created component that matches filter.
Top
Public Methods
Name | Description
SetPropertyValue | Allows for setting the property value.


NameManipulator Methods

NameManipulator Methods
Protected Methods Public Methods
Collapse All

The methods of the NameManipulator class are listed here.

Protected Methods
Name | Description
GetPrefix | This is GetPrefix, a member of class NameManipulator.
Top
Public Methods
Name | Description
SetPropertyValue | Allows for setting the property value.


NameManipulator.GetPrefix Method

NameManipulator.GetPrefix Method
NameManipulator Class NameManipulator Members Eco.Handles.Design Namespace See Also
Collapse All
C#
protected virtual string GetPrefix(
    IComponent component
);
Remarks

This is GetPrefix, a member of class NameManipulator.

See Also
NameManipulator Class
NameManipulator Members
Eco.Handles.Design Namespace


NameManipulator.SetPropertyValue Method

NameManipulator.SetPropertyValue Method
NameManipulator Class NameManipulator Members Eco.Handles.Design Namespace See Also
Collapse All

Allows for setting the property value.

C#
public override void SetPropertyValue(
    PropertyParams propertyParams
);
See Also
NameManipulator Class
NameManipulator Members
Eco.Handles.Design Namespace


NewVersionForm Class

NewVersionForm Class
NewVersionForm Members Inheritance Hierarchy See Also
Collapse All

Summary description for NewVersionForm.

C#
public class NewVersionForm : System.Windows.Forms.Form;
Inheritance Hierarchy
System.Windows.Forms.Form
    Eco.Handles.Design.NewVersionForm
File

Eco.Handles.Design.NewVersionForm.cs

See Also
NewVersionForm Members
Inheritance Hierarchy


NewVersionForm Members

NewVersionForm Members
Protected Methods Public Methods Public Properties
Collapse All

The following tables list the members exposed by NewVersionForm.

Protected Methods
Name | Description
Dispose | Clean up any resources being used.
Top
Public Methods
Name | Description
NewVersionForm | This is NewVersionForm, a member of class NewVersionForm.
Top
Public Properties
Name | Description
Message | This is Message, a member of class NewVersionForm.


NewVersionForm.NewVersionForm Constructor

NewVersionForm.NewVersionForm Constructor
NewVersionForm Class NewVersionForm Members Eco.Handles.Design Namespace See Also
Collapse All
C#
public NewVersionForm();
Remarks

This is NewVersionForm, a member of class NewVersionForm.

See Also
NewVersionForm Class
NewVersionForm Members
Eco.Handles.Design Namespace


NewVersionForm Methods

NewVersionForm Methods
Protected Methods
Collapse All

The methods of the NewVersionForm class are listed here.

Protected Methods
Name | Description
Dispose | Clean up any resources being used.


NewVersionForm.Dispose Method

NewVersionForm.Dispose Method
NewVersionForm Class NewVersionForm Members Eco.Handles.Design Namespace See Also
Collapse All

Clean up any resources being used.

C#
protected override void Dispose(
    bool disposing
);
See Also
NewVersionForm Class
NewVersionForm Members
Eco.Handles.Design Namespace


NewVersionForm Properties

NewVersionForm Properties
Public Properties
Collapse All

The properties of the NewVersionForm class are listed here.

Public Properties
Name | Description
Message | This is Message, a member of class NewVersionForm.


NewVersionForm.Message Property

NewVersionForm.Message Property
NewVersionForm Class NewVersionForm Members Eco.Handles.Design Namespace See Also
Collapse All
C#
public string Message;
Remarks

This is Message, a member of class NewVersionForm.

See Also
NewVersionForm Class
NewVersionForm Members
Eco.Handles.Design Namespace


NonCollectionTypeNameSelectorEditor Class

NonCollectionTypeNameSelectorEditor Class
NonCollectionTypeNameSelectorEditor Members Inheritance Hierarchy See Also
Collapse All

Typename selector editor that shows all known types except collections in the tree.

C#
public sealed class NonCollectionTypeNameSelectorEditor : TypeNameSelectorEditor;
Inheritance Hierarchy
Eco.Handles.Design.TypeNameSelectorEditor
    Eco.Handles.Design.NonCollectionTypeNameSelectorEditor
File

TypeNameSelectorEditor.cs

See Also
NonCollectionTypeNameSelectorEditor Members
Inheritance Hierarchy


NonCollectionTypeNameSelectorEditor Members

NonCollectionTypeNameSelectorEditor Members
Protected Methods Public Methods
Collapse All

The following tables list the members exposed by NonCollectionTypeNameSelectorEditor.

Protected Methods
Name | Description
FillTreeWithData | This is FillTreeWithData, a member of class TypeNameSelectorEditor.
GetFilter | Returns the array of valid ClassifierType for this editor.
Top
Public Methods
Name | Description
EditValue | Fills the selector tree with relevant data, drops it down and returns the selected node value.
SetValue | This is SetValue, a member of class TypeNameSelectorEditor.


NonCollectionTypeNameSelectorEditor Methods

NonCollectionTypeNameSelectorEditor Methods
Protected Methods
Collapse All

The methods of the NonCollectionTypeNameSelectorEditor class are listed here.

Protected Methods
Name | Description
GetFilter | Returns the array of valid ClassifierType for this editor.


NonCollectionTypeNameSelectorEditor.GetFilter Method

NonCollectionTypeNameSelectorEditor.GetFilter Method
NonCollectionTypeNameSelectorEditor Class NonCollectionTypeNameSelectorEditor Members Eco.Handles.Design Namespace See Also
Collapse All

Returns the array of valid ClassifierType for this editor.

C#
protected override ClassifierType[] GetFilter();
Returns

Primitive, Enumeration, Class

See Also
NonCollectionTypeNameSelectorEditor Class
NonCollectionTypeNameSelectorEditor Members
Eco.Handles.Design Namespace


NotifyingDesigner Class

NotifyingDesigner Class
NotifyingDesigner Members Inheritance Hierarchy See Also
Collapse All

A designer setting up the framework to get notifications when components are removed. This is used to decouple components when linked components are removed

C#
public abstract class NotifyingDesigner : ComponentDesigner;
Inheritance Hierarchy
Eco.Handles.Design.NotifyingDesigner
    Eco.Handles.Design.EcoActionExtenderDesigner
    Eco.Handles.Design.HandlesDesigner
File

Editors.cs

See Also
NotifyingDesigner Members
Inheritance Hierarchy


NotifyingDesigner Members

NotifyingDesigner Members
Protected Methods Public Methods
Collapse All

The following tables list the members exposed by NotifyingDesigner.

Protected Methods
Name | Description
Dispose | Unhooks up the OnComponentRemoved from IComponentChangeService.ComponentRemoved. Calls base.Dispose.
Top
Public Methods
Name | Description
Initialize | Calls base.Initialize and then hooks up the OnComponentRemoved to IComponentChangeService.ComponentRemoved.


NotifyingDesigner Methods

NotifyingDesigner Methods
Protected Methods Public Methods
Collapse All

The methods of the NotifyingDesigner class are listed here.

Protected Methods
Name | Description
Dispose | Unhooks up the OnComponentRemoved from IComponentChangeService.ComponentRemoved. Calls base.Dispose.
Top
Public Methods
Name | Description
Initialize | Calls base.Initialize and then hooks up the OnComponentRemoved to IComponentChangeService.ComponentRemoved.


NotifyingDesigner.Dispose Method

NotifyingDesigner.Dispose Method
NotifyingDesigner Class NotifyingDesigner Members Eco.Handles.Design Namespace See Also
Collapse All

Unhooks up the OnComponentRemoved from IComponentChangeService.ComponentRemoved. Calls base.Dispose.

C#
protected override void Dispose(
    bool disposing
);
See Also
NotifyingDesigner Class
NotifyingDesigner Members
Eco.Handles.Design Namespace


NotifyingDesigner.Initialize Method

NotifyingDesigner.Initialize Method
NotifyingDesigner Class NotifyingDesigner Members Eco.Handles.Design Namespace See Also
Collapse All

Calls base.Initialize and then hooks up the OnComponentRemoved to IComponentChangeService.ComponentRemoved.

C#
public override void Initialize(
    System.ComponentModel.IComponent component
);
See Also
NotifyingDesigner Class
NotifyingDesigner Members
Eco.Handles.Design Namespace


OclEditorWakeup Class

OclEditorWakeup Class
OclEditorWakeup Members Inheritance Hierarchy See Also
Collapse All

Class to wrap editing an expression using the Eco.Windows.Forms.OclEditor.

C#
public class OclEditorWakeup : ModalExpressionEditor;
Inheritance Hierarchy
Eco.Handles.Design.ModalExpressionEditor
    Eco.Handles.Design.OclEditorWakeup
File

OCLEditorWakeup.cs

See Also
OclEditorWakeup Members
Inheritance Hierarchy


OclEditorWakeup Members

OclEditorWakeup Members
Protected Methods Public Methods
Collapse All

The following tables list the members exposed by OclEditorWakeup.

Protected Methods
Name | Description
ModalExpressionEditor | This is ModalExpressionEditor, a member of class ModalExpressionEditor.
Top
Public Methods
Name | Description
EditValue | Collects information from the environment and invokes OclEditor.ShowEditor.
GetEditStyle | Sets the editor to be modal.
OclEditorWakeup | This is OclEditorWakeup, a member of class OclEditorWakeup.


OclEditorWakeup.OclEditorWakeup Constructor

OclEditorWakeup.OclEditorWakeup Constructor
OclEditorWakeup Class OclEditorWakeup Members Eco.Handles.Design Namespace See Also
Collapse All
C#
public OclEditorWakeup();
Remarks

This is OclEditorWakeup, a member of class OclEditorWakeup.

See Also
OclEditorWakeup Class
OclEditorWakeup Members
Eco.Handles.Design Namespace


OclEditorWakeup Methods

OclEditorWakeup Methods
Public Methods
Collapse All

The methods of the OclEditorWakeup class are listed here.

Public Methods
Name | Description
EditValue | Collects information from the environment and invokes OclEditor.ShowEditor.


OclEditorWakeup.EditValue Method

OclEditorWakeup.EditValue Method
OclEditorWakeup Class OclEditorWakeup Members Eco.Handles.Design Namespace See Also
Collapse All

Collects information from the environment and invokes OclEditor.ShowEditor.

C#
public override object EditValue(
    ITypeDescriptorContext context,
    IServiceProvider provider,
    object value
);
Exceptions
Exceptions | Description
ArgumentNullException | Thrown if context is null.
InvalidOperationException | Thrown if the edited component does not implement IHasEditableExpression.
See Also
OclEditorWakeup Class
OclEditorWakeup Members
Eco.Handles.Design Namespace


OclExpressionEditor Class

OclExpressionEditor Class
OclExpressionEditor Members Inheritance Hierarchy See Also
Collapse All

Subclass to edit the extendee's expression using the OclTypeService.

C#
public class OclExpressionEditor : ExpressionEditor;
Inheritance Hierarchy
Eco.Handles.Design.ModalExpressionEditor
    Eco.Handles.Design.ExpressionEditor
        Eco.Handles.Design.OclExpressionEditor
File

OCLEditorWakeup.cs

See Also
OclExpressionEditor Members
Inheritance Hierarchy


OclExpressionEditor Members

OclExpressionEditor Members
Protected Methods Public Methods
Collapse All

The following tables list the members exposed by OclExpressionEditor.

Protected Methods
Name | Description
getOclTypeService |
ModalExpressionEditor | This is ModalExpressionEditor, a member of class ModalExpressionEditor.
Top
Public Methods
Name | Description
EditValue | Collects information from the environment and invokes OclEditor.ShowEditor.
GetEditStyle | Sets the editor to be modal.
OclExpressionEditor | This is OclExpressionEditor, a member of class OclExpressionEditor.


OclExpressionEditor.OclExpressionEditor Constructor

OclExpressionEditor.OclExpressionEditor Constructor
OclExpressionEditor Class OclExpressionEditor Members Eco.Handles.Design Namespace See Also
Collapse All
C#
public OclExpressionEditor();
Remarks

This is OclExpressionEditor, a member of class OclExpressionEditor.

See Also
OclExpressionEditor Class
OclExpressionEditor Members
Eco.Handles.Design Namespace


OclExpressionEditor Methods

OclExpressionEditor Methods
Protected Methods
Collapse All

The methods of the OclExpressionEditor class are listed here.

Protected Methods
Name | Description
getOclTypeService |


OclExpressionEditor.getOclTypeService Method

OclExpressionEditor.getOclTypeService Method
OclExpressionEditor Class OclExpressionEditor Members Eco.Handles.Design Namespace See Also
Collapse All
C#
protected override ITypeService getOclTypeService(
    IStaticContext staticContext
);
Returns

Returns staticContext.OclTypeService

Exceptions
Exceptions | Description
ArgumentNullException | Thrown if staticContext is null.
See Also
OclExpressionEditor Class
OclExpressionEditor Members
Eco.Handles.Design Namespace


OclPsExpressionEditor Class

OclPsExpressionEditor Class
OclPsExpressionEditor Members Inheritance Hierarchy See Also
Collapse All

Subclass to edit the extendee's expression using the OclPsTypeService.

C#
public class OclPsExpressionEditor : ExpressionEditor;
Inheritance Hierarchy
Eco.Handles.Design.ModalExpressionEditor
    Eco.Handles.Design.ExpressionEditor
        Eco.Handles.Design.OclPsExpressionEditor
File

OCLEditorWakeup.cs

See Also
OclPsExpressionEditor Members
Inheritance Hierarchy


OclPsExpressionEditor Members

OclPsExpressionEditor Members
Protected Methods Public Methods
Collapse All

The following tables list the members exposed by OclPsExpressionEditor.

Protected Methods
Name | Description
getOclTypeService |
ModalExpressionEditor | This is ModalExpressionEditor, a member of class ModalExpressionEditor.
Top
Public Methods
Name | Description
EditValue | Collects information from the environment and invokes OclEditor.ShowEditor.
GetEditStyle | Sets the editor to be modal.
OclPsExpressionEditor | This is OclPsExpressionEditor, a member of class OclPsExpressionEditor.


OclPsExpressionEditor.OclPsExpressionEditor Constructor

OclPsExpressionEditor.OclPsExpressionEditor Constructor
OclPsExpressionEditor Class OclPsExpressionEditor Members Eco.Handles.Design Namespace See Also
Collapse All
C#
public OclPsExpressionEditor();
Remarks

This is OclPsExpressionEditor, a member of class OclPsExpressionEditor.

See Also
OclPsExpressionEditor Class
OclPsExpressionEditor Members
Eco.Handles.Design Namespace


OclPsExpressionEditor Methods

OclPsExpressionEditor Methods
Protected Methods
Collapse All

The methods of the OclPsExpressionEditor class are listed here.

Protected Methods
Name | Description
getOclTypeService |


OclPsExpressionEditor.getOclTypeService Method

OclPsExpressionEditor.getOclTypeService Method
OclPsExpressionEditor Class OclPsExpressionEditor Members Eco.Handles.Design Namespace See Also
Collapse All
C#
protected override ITypeService getOclTypeService(
    IStaticContext staticContext
);
Returns

Returns staticContext.OclPsTypeService

Exceptions
Exceptions | Description
ArgumentNullException | Thrown if staticContext is null.
See Also
OclPsExpressionEditor Class
OclPsExpressionEditor Members
Eco.Handles.Design Namespace


OclPSHandleDesigner Class

OclPSHandleDesigner Class
Inheritance Hierarchy See Also
Collapse All

Designer for OclPSHandle.

C#
internal class OclPSHandleDesigner : AbstractExpressionHandleDesigner;
Inheritance Hierarchy
Eco.Handles.Design.NotifyingDesigner
    Eco.Handles.Design.HandlesDesigner
        Eco.Handles.Design.RootedHandleDesigner
            Eco.Handles.Design.AbstractExpressionHandleDesigner
                Eco.Handles.Design.OclPSHandleDesigner
File

Editors.cs

See Also
Inheritance Hierarchy


OclVariableConverter Class

OclVariableConverter Class
OclVariableConverter Members Inheritance Hierarchy See Also
Collapse All

Type converter to make OclVariable Serialize

C#
public class OclVariableConverter : TypeConverter;
Inheritance Hierarchy
Eco.Handles.Design.OclVariableConverter
File

OclVariableConverter.cs

See Also
OclVariableConverter Members
Inheritance Hierarchy


OclVariableConverter Members

OclVariableConverter Members
Public Methods
Collapse All

The following tables list the members exposed by OclVariableConverter.

Public Methods
Name | Description
CanConvertTo | Returns true if destinationType is an InstanceDescriptor else returns inherited result.
ConvertTo | If destinationType is an InstanceDescriptor an InstanceDescriptor is created to represent the OclVariable else the inherited result is returned.


OclVariableConverter Methods

OclVariableConverter Methods
Public Methods
Collapse All

The methods of the OclVariableConverter class are listed here.

Public Methods
Name | Description
CanConvertTo | Returns true if destinationType is an InstanceDescriptor else returns inherited result.
ConvertTo | If destinationType is an InstanceDescriptor an InstanceDescriptor is created to represent the OclVariable else the inherited result is returned.


OclVariableConverter.CanConvertTo Method

OclVariableConverter.CanConvertTo Method
OclVariableConverter Class OclVariableConverter Members Eco.Handles.Design Namespace See Also
Collapse All

Returns true if destinationType is an InstanceDescriptor else returns inherited result.

C#
public override bool CanConvertTo(
    ITypeDescriptorContext context,
    Type destinationType
);
See Also
OclVariableConverter Class
OclVariableConverter Members
Eco.Handles.Design Namespace


OclVariableConverter.ConvertTo Method

OclVariableConverter.ConvertTo Method
OclVariableConverter Class OclVariableConverter Members Eco.Handles.Design Namespace See Also
Collapse All

If destinationType is an InstanceDescriptor an InstanceDescriptor is created to represent the OclVariable else the inherited result is returned.

C#
public override object ConvertTo(
    ITypeDescriptorContext context,
    CultureInfo culture,
    object value,
    Type destinationType
);
See Also
OclVariableConverter Class
OclVariableConverter Members
Eco.Handles.Design Namespace


PackageSelectorForm Class

PackageSelectorForm Class
PackageSelectorForm Members Inheritance Hierarchy See Also
Collapse All

This class encapsulates the UI to select which packages are used in an ecospace.

C#
public class PackageSelectorForm : System.Windows.Forms.Form;
Inheritance Hierarchy
System.Windows.Forms.Form
    Eco.Handles.Design.PackageSelectorForm
File

Eco.Handles.Design.PackageSelectorForm.cs

See Also
PackageSelectorForm Members
Inheritance Hierarchy


PackageSelectorForm Members

PackageSelectorForm Members
Protected Methods Public Methods
Collapse All

The following tables list the members exposed by PackageSelectorForm.

Protected Methods
Name | Description
Dispose | Clean up any resources being used.
Top
Public Methods
Name | Description
GetSelectedPackages | Returns the selected packages as a string list.
InitPackages | Sets up the UI by adding all strings in availablePackages to one listbox and the strings in selectedPackages to the other.
PackageSelectorForm | This is the overview for the PackageSelectorForm constructor overload.


PackageSelectorForm Constructor

PackageSelectorForm Constructor

This is the overview for the PackageSelectorForm constructor overload.

Overload List
Name | Description
PackageSelectorForm.PackageSelectorForm () | This is PackageSelectorForm, a member of class PackageSelectorForm.
PackageSelectorForm.PackageSelectorForm (IServiceProvider) | Sets the serviceProvider and calls the parameterless constructor. The serviceProvider is used when requesting help.


PackageSelectorForm.PackageSelectorForm Constructor ()

PackageSelectorForm.PackageSelectorForm Constructor ()
PackageSelectorForm Class PackageSelectorForm Members Eco.Handles.Design Namespace See Also
Collapse All
C#
public PackageSelectorForm();
Remarks

This is PackageSelectorForm, a member of class PackageSelectorForm.

See Also
PackageSelectorForm Class
PackageSelectorForm Members
Eco.Handles.Design Namespace


PackageSelectorForm.PackageSelectorForm Constructor (IServiceProvider)

PackageSelectorForm.PackageSelectorForm Constructor (IServiceProvider)
PackageSelectorForm Class PackageSelectorForm Members Eco.Handles.Design Namespace See Also
Collapse All

Sets the serviceProvider and calls the parameterless constructor. The serviceProvider is used when requesting help.

C#
public PackageSelectorForm(
    IServiceProvider serviceProvider
);
See Also
PackageSelectorForm Class
PackageSelectorForm Members
Eco.Handles.Design Namespace


PackageSelectorForm Methods

PackageSelectorForm Methods
Protected Methods Public Methods
Collapse All

The methods of the PackageSelectorForm class are listed here.

Protected Methods
Name | Description
Dispose | Clean up any resources being used.
Top
Public Methods
Name | Description
GetSelectedPackages | Returns the selected packages as a string list.
InitPackages | Sets up the UI by adding all strings in availablePackages to one listbox and the strings in selectedPackages to the other.


PackageSelectorForm.Dispose Method

PackageSelectorForm.Dispose Method
PackageSelectorForm Class PackageSelectorForm Members Eco.Handles.Design Namespace See Also
Collapse All

Clean up any resources being used.

C#
protected override void Dispose(
    bool disposing
);
See Also
PackageSelectorForm Class
PackageSelectorForm Members
Eco.Handles.Design Namespace


PackageSelectorForm.GetSelectedPackages Method

PackageSelectorForm.GetSelectedPackages Method
PackageSelectorForm Class PackageSelectorForm Members Eco.Handles.Design Namespace See Also
Collapse All

Returns the selected packages as a string list.

C#
public ICollection<string> GetSelectedPackages();
Returns

Returns a stringlist containing all strings in the listbox of selected packages.

See Also
PackageSelectorForm Class
PackageSelectorForm Members
Eco.Handles.Design Namespace


PackageSelectorForm.InitPackages Method

PackageSelectorForm.InitPackages Method
PackageSelectorForm Class PackageSelectorForm Members Eco.Handles.Design Namespace See Also
Collapse All

Sets up the UI by adding all strings in availablePackages to one listbox and the strings in selectedPackages to the other.

C#
public void InitPackages(
    ICollection<string> availablePackages,
    ICollection<string> selectedPackages,
    Hashtable classesInPackage
);
Parameters
Parameters | Description
availablePackages | IList containing all non-selected packages
selectedPackages | IList containing all currently selected packages
classesInPackage | String collections of all packages in a package, hashed on package name. It is used for tooltip display of package contents.
Exceptions
Exceptions | Description
ArgumentNullException | Thrown if availablePackages is null. Thrown if selectedPackages is null.
See Also
PackageSelectorForm Class
PackageSelectorForm Members
Eco.Handles.Design Namespace


PMapperCreatorHandler Class

PMapperCreatorHandler Class
PMapperCreatorHandler Members Inheritance Hierarchy See Also
Collapse All
C#
public class PMapperCreatorHandler : CreatorHandler;
Remarks

This is class Eco.Handles.Design.PMapperCreatorHandler.

Inheritance Hierarchy
Eco.Handles.Design.CreatorHandler
    Eco.Handles.Design.PMapperCreatorHandler
File

PmapperSelector.cs

See Also
PMapperCreatorHandler Members
Inheritance Hierarchy


PMapperCreatorHandler Members

PMapperCreatorHandler Members
Protected Methods Public Methods Public Properties Protected Properties
Collapse All

The following tables list the members exposed by PMapperCreatorHandler.

Protected Methods
Name | Description
ValidHotspot | This is ValidHotspot, a member of class PMapperCreatorHandler.
Top
Public Methods
Name | Description
Clear | Clears the CreatorGroup.CreatorDescriptorList.
CreatorHandler | Creates a new instance and reads information from xml-file.
PMapperCreatorHandler | This is PMapperCreatorHandler, a member of class PMapperCreatorHandler.
ReadFromXml | This is ReadFromXml, a member of class CreatorHandler.
RefreshCreatorTree | Adds all PMappers to the list.
Top
Public Properties
Name | Description
CreatorGroup | The CreatorGroup represents the top node for this structure.
Top
Protected Properties
Name | Description
BinDir | Returns IIdeService.GetEcoConfigDir()
Filename | do not localize;
TopNodename | do not localize


PMapperCreatorHandler.PMapperCreatorHandler Constructor

PMapperCreatorHandler.PMapperCreatorHandler Constructor
PMapperCreatorHandler Class PMapperCreatorHandler Members Eco.Handles.Design Namespace See Also
Collapse All
C#
public PMapperCreatorHandler();
Remarks

This is PMapperCreatorHandler, a member of class PMapperCreatorHandler.

See Also
PMapperCreatorHandler Class
PMapperCreatorHandler Members
Eco.Handles.Design Namespace


PMapperCreatorHandler Methods

PMapperCreatorHandler Methods
Protected Methods Public Methods
Collapse All

The methods of the PMapperCreatorHandler class are listed here.

Protected Methods
Name | Description
ValidHotspot | This is ValidHotspot, a member of class PMapperCreatorHandler.
Top
Public Methods
Name | Description
RefreshCreatorTree | Adds all PMappers to the list.


PMapperCreatorHandler.RefreshCreatorTree Method

PMapperCreatorHandler.RefreshCreatorTree Method
PMapperCreatorHandler Class PMapperCreatorHandler Members Eco.Handles.Design Namespace See Also
Collapse All

Adds all PMappers to the list.

C#
public override void RefreshCreatorTree(
    DesignerData designerData
);
See Also
PMapperCreatorHandler Class
PMapperCreatorHandler Members
Eco.Handles.Design Namespace


PMapperCreatorHandler.ValidHotspot Method

PMapperCreatorHandler.ValidHotspot Method
PMapperCreatorHandler Class PMapperCreatorHandler Members Eco.Handles.Design Namespace See Also
Collapse All
C#
protected virtual bool ValidHotspot(
    DesignerData designerData
);
Remarks

This is ValidHotspot, a member of class PMapperCreatorHandler.

See Also
PMapperCreatorHandler Class
PMapperCreatorHandler Members
Eco.Handles.Design Namespace


PMapperCreatorHandler Properties

PMapperCreatorHandler Properties
Protected Properties
Collapse All

The properties of the PMapperCreatorHandler class are listed here.

Protected Properties
Name | Description
Filename | do not localize;
TopNodename | do not localize


PMapperCreatorHandler.Filename Property

PMapperCreatorHandler.Filename Property
PMapperCreatorHandler Class PMapperCreatorHandler Members Eco.Handles.Design Namespace See Also
Collapse All
C#
protected override string Filename;
Remarks

do not localize;

See Also
PMapperCreatorHandler Class
PMapperCreatorHandler Members
Eco.Handles.Design Namespace


PMapperCreatorHandler.TopNodename Property

PMapperCreatorHandler.TopNodename Property
PMapperCreatorHandler Class PMapperCreatorHandler Members Eco.Handles.Design Namespace See Also
Collapse All
C#
protected override string TopNodename;
Remarks

do not localize

See Also
PMapperCreatorHandler Class
PMapperCreatorHandler Members
Eco.Handles.Design Namespace


PropertyDefinition Class

PropertyDefinition Class
PropertyDefinition Members Inheritance Hierarchy See Also
Collapse All

Encapsulates the manipulation of property.

C#
public class PropertyDefinition;
Remarks

The setting of the property is done by instantiating a subclass of AbstractManipulator as defined by the manipulatorClass and manipulatorAssembly passed in the constructor. The PropertyDefinition is located by using the name passed into the constructor and lookup in the owning component.

Inheritance Hierarchy
Eco.Handles.Design.PropertyDefinition
File

ContextComponentDictionary.cs

See Also
PropertyDefinition Members
Inheritance Hierarchy


PropertyDefinition Members

PropertyDefinition Members
Public Methods
Collapse All

The following tables list the members exposed by PropertyDefinition.

Public Methods
Name | Description
PropertyDefinition | This is the overview for the PropertyDefinition constructor overload.


PropertyDefinition Constructor

PropertyDefinition Constructor

This is the overview for the PropertyDefinition constructor overload.

Overload List
Name | Description
PropertyDefinition.PropertyDefinition () | This is PropertyDefinition, a member of class PropertyDefinition.
PropertyDefinition.PropertyDefinition (string, string, string, string) |


PropertyDefinition.PropertyDefinition Constructor ()

PropertyDefinition.PropertyDefinition Constructor ()
PropertyDefinition Class PropertyDefinition Members Eco.Handles.Design Namespace See Also
Collapse All
C#
public PropertyDefinition();
Remarks

This is PropertyDefinition, a member of class PropertyDefinition.

See Also
PropertyDefinition Class
PropertyDefinition Members
Eco.Handles.Design Namespace


PropertyDefinition.PropertyDefinition Constructor (string, string, string, string)

PropertyDefinition.PropertyDefinition Constructor (string, string, string, string)
PropertyDefinition Class PropertyDefinition Members Eco.Handles.Design Namespace See Also
Collapse All
C#
public PropertyDefinition(
    string name,
    string propVal,
    string manipulatorClass,
    string manipulatorAssembly
);
Parameters
Parameters | Description
name | The name of the property to manipulate. If a corresponding property is not found, null will be passed to the see AbstractManipulator.SetPropertyValue
propVal | Will be passed to AbstractManipulator.SetPropertyValue as a suggested value. It is up to the manipulator to act on it.
manipulatorClass | Fully qualified name of AbstractManipulator subclass to instantiate.
manipulatorAssembly | Assembly in which the AbstractManipulator resides.
See Also
PropertyDefinition Class
PropertyDefinition Members
Eco.Handles.Design Namespace


PropertyParams Class

PropertyParams Class
PropertyParams Members Inheritance Hierarchy See Also
Collapse All

Parameter object with some helper methods.

C#
public class PropertyParams;
Remarks

Some information is passed all the way from the ContextAgentToolboxItem to the AbstractManipulator. The source of the information can be the invoking MetaCreator. As all information needs to be serialized, strings are used.

Inheritance Hierarchy
Eco.Handles.Design.PropertyParams
File

AbstractPropertyManipulator.cs

See Also
PropertyParams Members
Inheritance Hierarchy


PropertyParams Members

PropertyParams Members
Public Methods Public Properties
Collapse All

The following tables list the members exposed by PropertyParams.

Public Methods
Name | Description
GetValue | Returns the value of the OwningComponent.Property.
PropertyParams | This is PropertyParams, a member of class PropertyParams.
SetValue | Sets the value of the OwningComponent.Property and logs the action.
SetValueQuietly | Sets the value of the OwningComponent.Property without logging anything.
Top
Public Properties
Name | Description
DefaultValue | The default value for the specific property.
DefaultValues | The default values as passed to the ToolboxItem by the designer.
DisplayName | The display name of the invoking descriptor.
InvokingComponent | The component the user initially selected.
Name | The name of the invoking descriptor.
OwningComponent | The newly created component whose properties are being manipulated.
Property | This is Property, a member of class PropertyParams.
PropVal | The propval attribute as read from the xml-file.


PropertyParams.PropertyParams Constructor

PropertyParams.PropertyParams Constructor
PropertyParams Class PropertyParams Members Eco.Handles.Design Namespace See Also
Collapse All
C#
public PropertyParams(
    IComponent owningComponent,
    IComponent invokingComponent,
    string name,
    string displayName,
    IDictionary defaultValues
);
Remarks

This is PropertyParams, a member of class PropertyParams.

See Also
PropertyParams Class
PropertyParams Members
Eco.Handles.Design Namespace


PropertyParams Methods

PropertyParams Methods
Public Methods
Collapse All

The methods of the PropertyParams class are listed here.

Public Methods
Name | Description
GetValue | Returns the value of the OwningComponent.Property.
SetValue | Sets the value of the OwningComponent.Property and logs the action.
SetValueQuietly | Sets the value of the OwningComponent.Property without logging anything.


PropertyParams.GetValue Method

PropertyParams.GetValue Method
PropertyParams Class PropertyParams Members Eco.Handles.Design Namespace See Also
Collapse All

Returns the value of the OwningComponent.Property.

C#
public object GetValue();
See Also
PropertyParams Class
PropertyParams Members
Eco.Handles.Design Namespace


PropertyParams.SetValue Method

PropertyParams.SetValue Method
PropertyParams Class PropertyParams Members Eco.Handles.Design Namespace See Also
Collapse All

Sets the value of the OwningComponent.Property and logs the action.

C#
public void SetValue(
    object value
);
See Also
PropertyParams Class
PropertyParams Members
Eco.Handles.Design Namespace


PropertyParams.SetValueQuietly Method

PropertyParams.SetValueQuietly Method
PropertyParams Class PropertyParams Members Eco.Handles.Design Namespace See Also
Collapse All

Sets the value of the OwningComponent.Property without logging anything.

C#
public void SetValueQuietly(
    object value
);
See Also
PropertyParams Class
PropertyParams Members
Eco.Handles.Design Namespace


PropertyParams Properties

PropertyParams Properties
Public Properties
Collapse All

The properties of the PropertyParams class are listed here.

Public Properties
Name | Description
DefaultValue | The default value for the specific property.
DefaultValues | The default values as passed to the ToolboxItem by the designer.
DisplayName | The display name of the invoking descriptor.
InvokingComponent | The component the user initially selected.
Name | The name of the invoking descriptor.
OwningComponent | The newly created component whose properties are being manipulated.
Property | This is Property, a member of class PropertyParams.
PropVal | The propval attribute as read from the xml-file.


PropertyParams.DefaultValue Property

PropertyParams.DefaultValue Property
PropertyParams Class PropertyParams Members Eco.Handles.Design Namespace See Also
Collapse All

The default value for the specific property.

C#
public object DefaultValue;
Returns

null if the property was not found in DefaultValues or the value of the property.

See Also
PropertyParams Class
PropertyParams Members
Eco.Handles.Design Namespace


PropertyParams.DefaultValues Property

PropertyParams.DefaultValues Property
PropertyParams Class PropertyParams Members Eco.Handles.Design Namespace See Also
Collapse All

The default values as passed to the ToolboxItem by the designer.

C#
public IDictionary DefaultValues;
See Also
PropertyParams Class
PropertyParams Members
Eco.Handles.Design Namespace


PropertyParams.DisplayName Property

PropertyParams.DisplayName Property
PropertyParams Class PropertyParams Members Eco.Handles.Design Namespace See Also
Collapse All

The display name of the invoking descriptor.

C#
public string DisplayName;
Remarks

This information is passed to the ContextAgentToolboxItem from the invoking MetaCreator.

See Also
PropertyParams Class
PropertyParams Members
Eco.Handles.Design Namespace


PropertyParams.InvokingComponent Property

PropertyParams.InvokingComponent Property
PropertyParams Class PropertyParams Members Eco.Handles.Design Namespace See Also
Collapse All

The component the user initially selected.

C#
public IComponent InvokingComponent;
See Also
PropertyParams Class
PropertyParams Members
Eco.Handles.Design Namespace


PropertyParams.Name Property

PropertyParams.Name Property
PropertyParams Class PropertyParams Members Eco.Handles.Design Namespace See Also
Collapse All

The name of the invoking descriptor.

C#
public string Name;
Remarks

This information is passed to the ContextAgentToolboxItem from the invoking MetaCreator.

See Also
PropertyParams Class
PropertyParams Members
Eco.Handles.Design Namespace


PropertyParams.OwningComponent Property

PropertyParams.OwningComponent Property
PropertyParams Class PropertyParams Members Eco.Handles.Design Namespace See Also
Collapse All

The newly created component whose properties are being manipulated.

C#
public IComponent OwningComponent;
See Also
PropertyParams Class
PropertyParams Members
Eco.Handles.Design Namespace


PropertyParams.Property Property

PropertyParams.Property Property
PropertyParams Class PropertyParams Members Eco.Handles.Design Namespace See Also
Collapse All
C#
public PropertyDescriptor Property;
Remarks

This is Property, a member of class PropertyParams.

See Also
PropertyParams Class
PropertyParams Members
Eco.Handles.Design Namespace


PropertyParams.PropVal Property

PropertyParams.PropVal Property
PropertyParams Class PropertyParams Members Eco.Handles.Design Namespace See Also
Collapse All

The propval attribute as read from the xml-file.

C#
public string PropVal;
See Also
PropertyParams Class
PropertyParams Members
Eco.Handles.Design Namespace


ReferenceHandleCreatorHandler Class

ReferenceHandleCreatorHandler Class
ReferenceHandleCreatorHandler Members Inheritance Hierarchy See Also
Collapse All
C#
public class ReferenceHandleCreatorHandler : CreatorHandler;
Remarks

This is class Eco.Handles.Design.ReferenceHandleCreatorHandler.

Inheritance Hierarchy
Eco.Handles.Design.CreatorHandler
    Eco.Handles.Design.ReferenceHandleCreatorHandler
File

ReferenceHandleSelector.cs

See Also
ReferenceHandleCreatorHandler Members
Inheritance Hierarchy


ReferenceHandleCreatorHandler Members

ReferenceHandleCreatorHandler Members
Public Methods Public Properties Protected Properties
Collapse All

The following tables list the members exposed by ReferenceHandleCreatorHandler.

Public Methods
Name | Description
Clear | Clears the CreatorGroup.CreatorDescriptorList.
CreatorHandler | Creates a new instance and reads information from xml-file.
ReadFromXml | This is ReadFromXml, a member of class CreatorHandler.
ReferenceHandleCreatorHandler | This is ReferenceHandleCreatorHandler, a member of class ReferenceHandleCreatorHandler.
RefreshCreatorTree | Adds all action sets to the list.
Top
Public Properties
Name | Description
CreatorGroup | The CreatorGroup represents the top node for this structure.
Top
Protected Properties
Name | Description
BinDir | Returns IIdeService.GetEcoConfigDir()
Filename | do not localize;
TopNodename | do not localize


ReferenceHandleCreatorHandler.ReferenceHandleCreatorHandler Constructor

ReferenceHandleCreatorHandler.ReferenceHandleCreatorHandler Constructor
ReferenceHandleCreatorHandler Class ReferenceHandleCreatorHandler Members Eco.Handles.Design Namespace See Also
Collapse All
C#
public ReferenceHandleCreatorHandler();
Remarks

This is ReferenceHandleCreatorHandler, a member of class ReferenceHandleCreatorHandler.

See Also
ReferenceHandleCreatorHandler Class
ReferenceHandleCreatorHandler Members
Eco.Handles.Design Namespace


ReferenceHandleCreatorHandler Methods

ReferenceHandleCreatorHandler Methods
Public Methods
Collapse All

The methods of the ReferenceHandleCreatorHandler class are listed here.

Public Methods
Name | Description
RefreshCreatorTree | Adds all action sets to the list.


ReferenceHandleCreatorHandler.RefreshCreatorTree Method

ReferenceHandleCreatorHandler.RefreshCreatorTree Method
ReferenceHandleCreatorHandler Class ReferenceHandleCreatorHandler Members Eco.Handles.Design Namespace See Also
Collapse All

Adds all action sets to the list.

C#
public override void RefreshCreatorTree(
    DesignerData designerData
);
See Also
ReferenceHandleCreatorHandler Class
ReferenceHandleCreatorHandler Members
Eco.Handles.Design Namespace


ReferenceHandleCreatorHandler Properties

ReferenceHandleCreatorHandler Properties
Protected Properties
Collapse All

The properties of the ReferenceHandleCreatorHandler class are listed here.

Protected Properties
Name | Description
Filename | do not localize;
TopNodename | do not localize


ReferenceHandleCreatorHandler.Filename Property

ReferenceHandleCreatorHandler.Filename Property
ReferenceHandleCreatorHandler Class ReferenceHandleCreatorHandler Members Eco.Handles.Design Namespace See Also
Collapse All
C#
protected override string Filename;
Remarks

do not localize;

See Also
ReferenceHandleCreatorHandler Class
ReferenceHandleCreatorHandler Members
Eco.Handles.Design Namespace


ReferenceHandleCreatorHandler.TopNodename Property

ReferenceHandleCreatorHandler.TopNodename Property
ReferenceHandleCreatorHandler Class ReferenceHandleCreatorHandler Members Eco.Handles.Design Namespace See Also
Collapse All
C#
protected override string TopNodename;
Remarks

do not localize

See Also
ReferenceHandleCreatorHandler Class
ReferenceHandleCreatorHandler Members
Eco.Handles.Design Namespace


RegisterRefreshXml Class

RegisterRefreshXml Class
RegisterRefreshXml Members Inheritance Hierarchy See Also
Collapse All
C#
public class RegisterRefreshXml;
Remarks

This is class Eco.Handles.Design.RegisterRefreshXml.

Inheritance Hierarchy
Eco.Handles.Design.RegisterRefreshXml
File

ContextCreatorManager.cs

See Also
RegisterRefreshXml Members
Inheritance Hierarchy


RegisterRefreshXml Members

RegisterRefreshXml Members
Public Methods
Collapse All

The following tables list the members exposed by RegisterRefreshXml.

Public Methods
Name | Description
RegisterMenuItem | This is RegisterMenuItem, a member of class RegisterRefreshXml.


RegisterRefreshXml Methods

RegisterRefreshXml Methods
Public Methods
Collapse All

The methods of the RegisterRefreshXml class are listed here.

Public Methods
Name | Description
RegisterMenuItem | This is RegisterMenuItem, a member of class RegisterRefreshXml.


RegisterRefreshXml.RegisterMenuItem Method

RegisterRefreshXml.RegisterMenuItem Method
RegisterRefreshXml Class RegisterRefreshXml Members Eco.Handles.Design Namespace See Also
Collapse All
C#
public static void RegisterMenuItem();
Remarks

This is RegisterMenuItem, a member of class RegisterRefreshXml.

See Also
RegisterRefreshXml Class
RegisterRefreshXml Members
Eco.Handles.Design Namespace


Registration Class

Registration Class
Registration Members Inheritance Hierarchy See Also
Collapse All

Singleton class used to perform design time initialization code.

C#
public sealed class Registration;
Inheritance Hierarchy
Eco.Handles.Design.Registration
File

IDERegister.cs

See Also
Registration Members
Inheritance Hierarchy


Registration Members

Registration Members
Public Methods
Collapse All

The following tables list the members exposed by Registration.

Public Methods
Name | Description
ContextAgentRegistration | This is ContextAgentRegistration, a member of class Registration.
IDERegister | Called during IDE startup to execute initialization code.


Registration Methods

Registration Methods
Public Methods
Collapse All

The methods of the Registration class are listed here.

Public Methods
Name | Description
ContextAgentRegistration | This is ContextAgentRegistration, a member of class Registration.
IDERegister | Called during IDE startup to execute initialization code.


Registration.ContextAgentRegistration Method

Registration.ContextAgentRegistration Method
Registration Class Registration Members Eco.Handles.Design Namespace See Also
Collapse All
C#
public static void ContextAgentRegistration();
Remarks

This is ContextAgentRegistration, a member of class Registration.

See Also
Registration Class
Registration Members
Eco.Handles.Design Namespace


Registration.IDERegister Method

Registration.IDERegister Method
Registration Class Registration Members Eco.Handles.Design Namespace See Also
Collapse All

Called during IDE startup to execute initialization code.

C#
public static void IDERegister();
Remarks

This method turns off the EcoLogSwitches.

See Also
Registration Class
Registration Members
Eco.Handles.Design Namespace


RootedHandleDesigner Class

RootedHandleDesigner Class
Inheritance Hierarchy See Also
Collapse All

Designer for RootedHandle.

C#
public class RootedHandleDesigner : HandlesDesigner;
Inheritance Hierarchy
Eco.Handles.Design.NotifyingDesigner
    Eco.Handles.Design.HandlesDesigner
        Eco.Handles.Design.RootedHandleDesigner
            Eco.Handles.Design.AbstractExpressionHandleDesigner
            Eco.Handles.Design.CurrencyManagerHandleDesigner
File

Editors.cs

See Also
Inheritance Hierarchy


RootHandleEditor Class

RootHandleEditor Class
RootHandleEditor Members Inheritance Hierarchy See Also
Collapse All

Editor for the RootHandle property. Adds a null value on top of the list.

C#
public class RootHandleEditor : ObjectSelectorEditor;
Inheritance Hierarchy
Eco.Handles.Design.RootHandleEditor
File

RootHandleEditor.cs

See Also
RootHandleEditor Members
Inheritance Hierarchy


RootHandleEditor Members

RootHandleEditor Members
Protected Methods
Collapse All

The following tables list the members exposed by RootHandleEditor.

Protected Methods
Name | Description
FillTreeWithData | Fills the selector with component names. Adds a null-selection on top.


RootHandleEditor Methods

RootHandleEditor Methods
Protected Methods
Collapse All

The methods of the RootHandleEditor class are listed here.

Protected Methods
Name | Description
FillTreeWithData | Fills the selector with component names. Adds a null-selection on top.


RootHandleEditor.FillTreeWithData Method

RootHandleEditor.FillTreeWithData Method
RootHandleEditor Class RootHandleEditor Members Eco.Handles.Design Namespace See Also
Collapse All

Fills the selector with component names. Adds a null-selection on top.

C#
protected override void FillTreeWithData(
    ObjectSelectorEditor.Selector selector,
    ITypeDescriptorContext context,
    IServiceProvider provider
);
Exceptions
Exceptions | Description
ArgumentNullException | Thrown if selector is null. Thrown if context is null.
See Also
RootHandleEditor Class
RootHandleEditor Members
Eco.Handles.Design Namespace


SecondOclEditorWakeup Class

SecondOclEditorWakeup Class
SecondOclEditorWakeup Members Inheritance Hierarchy See Also
Collapse All

Class to wrap editing second expression using the Eco.Windows.Forms.OclEditor.

C#
public class SecondOclEditorWakeup : ModalExpressionEditor;
Inheritance Hierarchy
Eco.Handles.Design.ModalExpressionEditor
    Eco.Handles.Design.SecondOclEditorWakeup
File

OCLEditorWakeup.cs

See Also
SecondOclEditorWakeup Members
Inheritance Hierarchy


SecondOclEditorWakeup Members

SecondOclEditorWakeup Members
Protected Methods Public Methods
Collapse All

The following tables list the members exposed by SecondOclEditorWakeup.

Protected Methods
Name | Description
ModalExpressionEditor | This is ModalExpressionEditor, a member of class ModalExpressionEditor.
Top
Public Methods
Name | Description
EditValue | Collects information from the environment and invokes OclEditor.ShowEditor.
GetEditStyle | Sets the editor to be modal.
SecondOclEditorWakeup | This is SecondOclEditorWakeup, a member of class SecondOclEditorWakeup.


SecondOclEditorWakeup.SecondOclEditorWakeup Constructor

SecondOclEditorWakeup.SecondOclEditorWakeup Constructor
SecondOclEditorWakeup Class SecondOclEditorWakeup Members Eco.Handles.Design Namespace See Also
Collapse All
C#
public SecondOclEditorWakeup();
Remarks

This is SecondOclEditorWakeup, a member of class SecondOclEditorWakeup.

See Also
SecondOclEditorWakeup Class
SecondOclEditorWakeup Members
Eco.Handles.Design Namespace


SecondOclEditorWakeup Methods

SecondOclEditorWakeup Methods
Public Methods
Collapse All

The methods of the SecondOclEditorWakeup class are listed here.

Public Methods
Name | Description
EditValue | Collects information from the environment and invokes OclEditor.ShowEditor.


SecondOclEditorWakeup.EditValue Method

SecondOclEditorWakeup.EditValue Method
SecondOclEditorWakeup Class SecondOclEditorWakeup Members Eco.Handles.Design Namespace See Also
Collapse All

Collects information from the environment and invokes OclEditor.ShowEditor.

C#
public override object EditValue(
    ITypeDescriptorContext context,
    IServiceProvider provider,
    object value
);
Exceptions
Exceptions | Description
ArgumentNullException | Thrown if context is null.
InvalidOperationException | Thrown if the edited component does not implement IHasSecondEditableExpression.
See Also
SecondOclEditorWakeup Class
SecondOclEditorWakeup Members
Eco.Handles.Design Namespace


SelectPackagesTool Class

SelectPackagesTool Class
SelectPackagesTool Members Inheritance Hierarchy See Also
Collapse All

Tool that encapsulates the ability to select which packages are associated with an ecospace.

C#
public class SelectPackagesTool : EcoToolButtonBase;
Inheritance Hierarchy
Eco.Handles.Design.IEcoSpaceDesignerTool
    Eco.Handles.Design.EcoToolButtonBase
        Eco.Handles.Design.SelectPackagesTool
File

EcoSpaceDesignerTools.cs

See Also
SelectPackagesTool Members
Inheritance Hierarchy


SelectPackagesTool Members

SelectPackagesTool Members
Protected Methods Public Methods
Collapse All

The following tables list the members exposed by SelectPackagesTool.

Protected Methods
Name | Description
GenerateSelectedPackages | This is GenerateSelectedPackages, a member of class SelectPackagesTool.
RetrieveSelectedPackages | This is RetrieveSelectedPackages, a member of class SelectPackagesTool.
Top
Public Methods
Name | Description
CompareTo | IComparable.CompareTo implementation. Compares the type only!
Execute | IEcoSpaceDesignerTool.Execute implementation.
GetCaption | The caption of the tool.
GetDesignerTypes | IEcoSpaceDesignerTool.GetDesignerType implementation. Default is to belong to EcoSpace designer.
GetDesignerTypes | GetDesignerType will be called once for each time the EcoSpaceDesigner is recreated/shown. It determins which designers the tool belongs to.
GetHint | Implements IEcoSpaceDesignerTool.GetHint().
GetHint | GetHint will be called once for each time the EcoSpaceDesigner is recreated/shown. Any speed keys (ampersands) should be removed.
GetImage | IEcoSpaceDesignerTool.GetImage implementation. This implementation is enough. Provided ToolboxBitmapAttribute is used on the implementation class GetImage will not need to be reimplemented. It's virtual to allow for other means of providing an image.
GetImage | GetImage will be called once for each time the EcoSpaceDesigner is recreated/shown.
GetPackagesAndClasses | This is GetPackagesAndClasses, a member of class SelectPackagesTool.
GetToolKind | IEcoSpaceDesignerTool.GetToolKind implementation.
GetToolKind | GetToolKind will be called once for each time the EcoSpaceDesigner is recreated/shown.
RequireRecompile | IEcoSpaceDesignerTool.RequireRecompile implementation. Default is to return True.
RequireRecompile | RequireRecompile indicates if the calling site should attempt to recompile the project before invoking Execute. If True and compilation fails, an exception will be raised.


SelectPackagesTool Methods

SelectPackagesTool Methods
Protected Methods Public Methods
Collapse All

The methods of the SelectPackagesTool class are listed here.

Protected Methods
Name | Description
GenerateSelectedPackages | This is GenerateSelectedPackages, a member of class SelectPackagesTool.
RetrieveSelectedPackages | This is RetrieveSelectedPackages, a member of class SelectPackagesTool.
Top
Public Methods
Name | Description
Execute | IEcoSpaceDesignerTool.Execute implementation.
GetCaption | The caption of the tool.
GetPackagesAndClasses | This is GetPackagesAndClasses, a member of class SelectPackagesTool.


SelectPackagesTool.Execute Method

SelectPackagesTool.Execute Method
SelectPackagesTool Class SelectPackagesTool Members Eco.Handles.Design Namespace See Also
Collapse All

IEcoSpaceDesignerTool.Execute implementation.

C#
public override void Execute(
    ExecuteArgs executeArgs
);
See Also
SelectPackagesTool Class
SelectPackagesTool Members
Eco.Handles.Design Namespace


SelectPackagesTool.GenerateSelectedPackages Method

SelectPackagesTool.GenerateSelectedPackages Method
SelectPackagesTool Class SelectPackagesTool Members Eco.Handles.Design Namespace See Also
Collapse All
C#
protected static void GenerateSelectedPackages(
    IServiceProvider site,
    ICollection<string> selectedPackages
);
Remarks

This is GenerateSelectedPackages, a member of class SelectPackagesTool.

See Also
SelectPackagesTool Class
SelectPackagesTool Members
Eco.Handles.Design Namespace


SelectPackagesTool.GetCaption Method

SelectPackagesTool.GetCaption Method
SelectPackagesTool Class SelectPackagesTool Members Eco.Handles.Design Namespace See Also
Collapse All

The caption of the tool.

C#
public override string GetCaption();
See Also
SelectPackagesTool Class
SelectPackagesTool Members
Eco.Handles.Design Namespace


SelectPackagesTool.GetPackagesAndClasses Method

SelectPackagesTool.GetPackagesAndClasses Method
SelectPackagesTool Class SelectPackagesTool Members Eco.Handles.Design Namespace See Also
Collapse All
C#
public Hashtable GetPackagesAndClasses(
    System.Type ecoSpaceType,
    ITypeResolutionService typeResolutionService,
    IServiceProvider site
);
Remarks

This is GetPackagesAndClasses, a member of class SelectPackagesTool.

See Also
SelectPackagesTool Class
SelectPackagesTool Members
Eco.Handles.Design Namespace


SelectPackagesTool.RetrieveSelectedPackages Method

SelectPackagesTool.RetrieveSelectedPackages Method
SelectPackagesTool Class SelectPackagesTool Members Eco.Handles.Design Namespace See Also
Collapse All
C#
protected static IList<string> RetrieveSelectedPackages(
    IServiceProvider site
);
Remarks

This is RetrieveSelectedPackages, a member of class SelectPackagesTool.

See Also
SelectPackagesTool Class
SelectPackagesTool Members
Eco.Handles.Design Namespace


TestValidator Class

TestValidator Class
TestValidator Members Inheritance Hierarchy See Also
Collapse All
C#
public class TestValidator : IFormValidator;
Remarks

This is class Eco.Handles.Design.TestValidator.

Inheritance Hierarchy
Eco.Handles.Design.IFormValidator
    Eco.Handles.Design.TestValidator
File

ValidatorsFromXml.cs

See Also
TestValidator Members
Inheritance Hierarchy


TestValidator Members

TestValidator Members
Public Methods
Collapse All

The following tables list the members exposed by TestValidator.

Public Methods
Name | Description
ValidateComponent | Called once per component per form.


TestValidator Methods

TestValidator Methods
Public Methods
Collapse All

The methods of the TestValidator class are listed here.

Public Methods
Name | Description
ValidateComponent | Called once per component per form.


TestValidator.ValidateComponent Method

TestValidator.ValidateComponent Method
TestValidator Class TestValidator Members Eco.Handles.Design Namespace See Also
Collapse All

Called once per component per form.

C#
public void ValidateComponent(
    FormValidatorArgs args
);
Remarks

This method should implement the rules to validate that the component is properly defined. Any validation breakages should be added to args.Report.

See Also
TestValidator Class
TestValidator Members
Eco.Handles.Design Namespace


TopLocation Class

TopLocation Class
TopLocation Members Inheritance Hierarchy See Also
Collapse All
C#
public class TopLocation;
Remarks

This is class Eco.Handles.Design.TopLocation.

Inheritance Hierarchy
Eco.Handles.Design.TopLocation
File

PropertyManipulators.cs

See Also
TopLocation Members
Inheritance Hierarchy


TopLocation Members

TopLocation Members
Public Methods Public Fields Public Properties
Collapse All

The following tables list the members exposed by TopLocation.

Public Methods
Name | Description
IncreaseVal | This is IncreaseVal, a member of class TopLocation.
Reset | This is Reset, a member of class TopLocation.
Top
Public Fields
Name | Description
DefaultX | This is DefaultX, a member of class TopLocation.
DefaultY | This is DefaultY, a member of class TopLocation.
Top
Public Properties
Name | Description
Location | This is Location, a member of class TopLocation.
NextVal | This is NextVal, a member of class TopLocation.


TopLocation Fields

TopLocation Fields
Public Fields
Collapse All

The fields of the TopLocation class are listed here.

Public Fields
Name | Description
DefaultX | This is DefaultX, a member of class TopLocation.
DefaultY | This is DefaultY, a member of class TopLocation.


TopLocation.DefaultX Field

TopLocation.DefaultX Field
TopLocation Class TopLocation Members Eco.Handles.Design Namespace See Also
Collapse All
C#
public const int DefaultX = 32;
Remarks

This is DefaultX, a member of class TopLocation.

See Also
TopLocation Class
TopLocation Members
Eco.Handles.Design Namespace


TopLocation.DefaultY Field

TopLocation.DefaultY Field
TopLocation Class TopLocation Members Eco.Handles.Design Namespace See Also
Collapse All
C#
public const int DefaultY = 16;
Remarks

This is DefaultY, a member of class TopLocation.

See Also
TopLocation Class
TopLocation Members
Eco.Handles.Design Namespace


TopLocation Methods

TopLocation Methods
Public Methods
Collapse All

The methods of the TopLocation class are listed here.

Public Methods
Name | Description
IncreaseVal | This is IncreaseVal, a member of class TopLocation.
Reset | This is Reset, a member of class TopLocation.


TopLocation.IncreaseVal Method

TopLocation.IncreaseVal Method
TopLocation Class TopLocation Members Eco.Handles.Design Namespace See Also
Collapse All
C#
public static void IncreaseVal();
Remarks

This is IncreaseVal, a member of class TopLocation.

See Also
TopLocation Class
TopLocation Members
Eco.Handles.Design Namespace


TopLocation.Reset Method

TopLocation.Reset Method
TopLocation Class TopLocation Members Eco.Handles.Design Namespace See Also
Collapse All
C#
public static void Reset();
Remarks

This is Reset, a member of class TopLocation.

See Also
TopLocation Class
TopLocation Members
Eco.Handles.Design Namespace


TopLocation Properties

TopLocation Properties
Public Properties
Collapse All

The properties of the TopLocation class are listed here.

Public Properties
Name | Description
Location | This is Location, a member of class TopLocation.
NextVal | This is NextVal, a member of class TopLocation.


TopLocation.Location Property

TopLocation.Location Property
TopLocation Class TopLocation Members Eco.Handles.Design Namespace See Also
Collapse All
C#
public static Point Location;
Remarks

This is Location, a member of class TopLocation.

See Also
TopLocation Class
TopLocation Members
Eco.Handles.Design Namespace


TopLocation.NextVal Property

TopLocation.NextVal Property
TopLocation Class TopLocation Members Eco.Handles.Design Namespace See Also
Collapse All
C#
public static int NextVal;
Remarks

This is NextVal, a member of class TopLocation.

See Also
TopLocation Class
TopLocation Members
Eco.Handles.Design Namespace


TypeNameSelectorEditor Class

TypeNameSelectorEditor Class
TypeNameSelectorEditor Members Inheritance Hierarchy See Also
Collapse All

Abstract superclass to allow a typeselector treeview as editor for TypeName properties. Subclasses need to implement GetFilter to specify which category of types end up in the tree.

C#
public abstract class TypeNameSelectorEditor : ObjectSelectorEditor;
Inheritance Hierarchy
Eco.Handles.Design.TypeNameSelectorEditor
    Eco.Handles.Design.AnyTypeNameSelectorEditor
    Eco.Handles.Design.NonCollectionTypeNameSelectorEditor
File

TypeNameSelectorEditor.cs

See Also
TypeNameSelectorEditor Members
Inheritance Hierarchy


TypeNameSelectorEditor Members

TypeNameSelectorEditor Members
Protected Methods Public Methods
Collapse All

The following tables list the members exposed by TypeNameSelectorEditor.

Protected Methods
Name | Description
FillTreeWithData | This is FillTreeWithData, a member of class TypeNameSelectorEditor.
GetFilter | Hotspot for subclasses
Top
Public Methods
Name | Description
EditValue | Fills the selector tree with relevant data, drops it down and returns the selected node value.
SetValue | This is SetValue, a member of class TypeNameSelectorEditor.


TypeNameSelectorEditor Methods

TypeNameSelectorEditor Methods
Protected Methods Public Methods
Collapse All

The methods of the TypeNameSelectorEditor class are listed here.

Protected Methods
Name | Description
FillTreeWithData | This is FillTreeWithData, a member of class TypeNameSelectorEditor.
GetFilter | Hotspot for subclasses
Top
Public Methods
Name | Description
EditValue | Fills the selector tree with relevant data, drops it down and returns the selected node value.
SetValue | This is SetValue, a member of class TypeNameSelectorEditor.


TypeNameSelectorEditor.EditValue Method

TypeNameSelectorEditor.EditValue Method
TypeNameSelectorEditor Class TypeNameSelectorEditor Members Eco.Handles.Design Namespace See Also
Collapse All

Fills the selector tree with relevant data, drops it down and returns the selected node value.

C#
public override object EditValue(
    ITypeDescriptorContext context,
    IServiceProvider provider,
    object value
);
See Also
TypeNameSelectorEditor Class
TypeNameSelectorEditor Members
Eco.Handles.Design Namespace


TypeNameSelectorEditor.FillTreeWithData Method

TypeNameSelectorEditor.FillTreeWithData Method
TypeNameSelectorEditor Class TypeNameSelectorEditor Members Eco.Handles.Design Namespace See Also
Collapse All
C#
protected override void FillTreeWithData(
    ObjectSelectorEditor.Selector selector,
    ITypeDescriptorContext context,
    IServiceProvider provider
);
Remarks

This is FillTreeWithData, a member of class TypeNameSelectorEditor.

See Also
TypeNameSelectorEditor Class
TypeNameSelectorEditor Members
Eco.Handles.Design Namespace


TypeNameSelectorEditor.GetFilter Method

TypeNameSelectorEditor.GetFilter Method
TypeNameSelectorEditor Class TypeNameSelectorEditor Members Eco.Handles.Design Namespace See Also
Collapse All
C#
protected abstract ClassifierType[] GetFilter();
Remarks

Hotspot for subclasses

See Also
TypeNameSelectorEditor Class
TypeNameSelectorEditor Members
Eco.Handles.Design Namespace


TypeNameSelectorEditor.SetValue Method

TypeNameSelectorEditor.SetValue Method
TypeNameSelectorEditor Class TypeNameSelectorEditor Members Eco.Handles.Design Namespace See Also
Collapse All
C#
public override void SetValue(
    object value
);
Remarks

This is SetValue, a member of class TypeNameSelectorEditor.

See Also
TypeNameSelectorEditor Class
TypeNameSelectorEditor Members
Eco.Handles.Design Namespace


TypeTypeConverter Class

TypeTypeConverter Class
TypeTypeConverter Members Inheritance Hierarchy See Also
Collapse All

Abstract class for design time conversion between types and strings. Sets defaults for non-exclusive standard values lists.

C#
public abstract class TypeTypeConverter : TypeConverter;
Inheritance Hierarchy
Eco.Handles.Design.TypeTypeConverter
    Eco.Handles.Design.EcoSpaceTypeTypeConverter
File

EcoSpaceTypeNameTypeConverter.cs

See Also
TypeTypeConverter Members
Inheritance Hierarchy


TypeTypeConverter Members

TypeTypeConverter Members
Public Methods
Collapse All

The following tables list the members exposed by TypeTypeConverter.

Public Methods
Name | Description
CanConvertFrom |
CanConvertTo |
ConvertFrom |
ConvertTo | This is ConvertTo, a member of class TypeTypeConverter.
GetStandardValuesExclusive | This is GetStandardValuesExclusive, a member of class TypeTypeConverter.
GetStandardValuesSupported | This is GetStandardValuesSupported, a member of class TypeTypeConverter.
MyInterfaceFilter | This is MyInterfaceFilter, a member of class TypeTypeConverter.


TypeTypeConverter Methods

TypeTypeConverter Methods
Public Methods
Collapse All

The methods of the TypeTypeConverter class are listed here.

Public Methods
Name | Description
CanConvertFrom |
CanConvertTo |
ConvertFrom |
ConvertTo | This is ConvertTo, a member of class TypeTypeConverter.
GetStandardValuesExclusive | This is GetStandardValuesExclusive, a member of class TypeTypeConverter.
GetStandardValuesSupported | This is GetStandardValuesSupported, a member of class TypeTypeConverter.
MyInterfaceFilter | This is MyInterfaceFilter, a member of class TypeTypeConverter.


TypeTypeConverter.CanConvertFrom Method

TypeTypeConverter.CanConvertFrom Method
TypeTypeConverter Class TypeTypeConverter Members Eco.Handles.Design Namespace See Also
Collapse All
C#
public override bool CanConvertFrom(
    ITypeDescriptorContext context,
    Type sourceType
);
Returns

Returns true if the sourceType is string or returns the base answer.

See Also
TypeTypeConverter Class
TypeTypeConverter Members
Eco.Handles.Design Namespace


TypeTypeConverter.CanConvertTo Method

TypeTypeConverter.CanConvertTo Method
TypeTypeConverter Class TypeTypeConverter Members Eco.Handles.Design Namespace See Also
Collapse All
C#
public override bool CanConvertTo(
    ITypeDescriptorContext context,
    Type destinationType
);
Returns

Returns true if the destinationType is string or returns the base answer.

See Also
TypeTypeConverter Class
TypeTypeConverter Members
Eco.Handles.Design Namespace


TypeTypeConverter.ConvertFrom Method

TypeTypeConverter.ConvertFrom Method
TypeTypeConverter Class TypeTypeConverter Members Eco.Handles.Design Namespace See Also
Collapse All
C#
public override object ConvertFrom(
    ITypeDescriptorContext context,
    CultureInfo culture,
    object value
);
Exceptions
Exceptions | Description
ArgumentNullException | Thrown if value is null Thrown if context is null
See Also
TypeTypeConverter Class
TypeTypeConverter Members
Eco.Handles.Design Namespace


TypeTypeConverter.ConvertTo Method

TypeTypeConverter.ConvertTo Method
TypeTypeConverter Class TypeTypeConverter Members Eco.Handles.Design Namespace See Also
Collapse All
C#
public override object ConvertTo(
    ITypeDescriptorContext context,
    CultureInfo culture,
    object value,
    Type destinationType
);
Remarks

This is ConvertTo, a member of class TypeTypeConverter.

See Also
TypeTypeConverter Class
TypeTypeConverter Members
Eco.Handles.Design Namespace


TypeTypeConverter.GetStandardValuesExclusive Method

TypeTypeConverter.GetStandardValuesExclusive Method
TypeTypeConverter Class TypeTypeConverter Members Eco.Handles.Design Namespace See Also
Collapse All
C#
public override bool GetStandardValuesExclusive(
    ITypeDescriptorContext context
);
Remarks

This is GetStandardValuesExclusive, a member of class TypeTypeConverter.

See Also
TypeTypeConverter Class
TypeTypeConverter Members
Eco.Handles.Design Namespace


TypeTypeConverter.GetStandardValuesSupported Method

TypeTypeConverter.GetStandardValuesSupported Method
TypeTypeConverter Class TypeTypeConverter Members Eco.Handles.Design Namespace See Also
Collapse All
C#
public override bool GetStandardValuesSupported(
    ITypeDescriptorContext context
);
Remarks

This is GetStandardValuesSupported, a member of class TypeTypeConverter.

See Also
TypeTypeConverter Class
TypeTypeConverter Members
Eco.Handles.Design Namespace


TypeTypeConverter.MyInterfaceFilter Method

TypeTypeConverter.MyInterfaceFilter Method
TypeTypeConverter Class TypeTypeConverter Members Eco.Handles.Design Namespace See Also
Collapse All
C#
public static bool MyInterfaceFilter(
    Type typeObj,
    Object criteriaObj
);
Remarks

This is MyInterfaceFilter, a member of class TypeTypeConverter.

See Also
TypeTypeConverter Class
TypeTypeConverter Members
Eco.Handles.Design Namespace


ValidationIncident Class

ValidationIncident Class
ValidationIncident Members Inheritance Hierarchy See Also
Collapse All
C#
public class ValidationIncident;
Remarks

This is class Eco.Handles.Design.ValidationIncident.

Inheritance Hierarchy
Eco.Handles.Design.ValidationIncident
    Eco.Handles.Design.FormValidationIncident
    Eco.Handles.Design.ModelValidationIncident
File

ValidationReport.cs

See Also
ValidationIncident Members
Inheritance Hierarchy


ValidationIncident Members

ValidationIncident Members
Public Methods Public Properties
Collapse All

The following tables list the members exposed by ValidationIncident.

Public Methods
Name | Description
ToShortString | This is ToShortString, a member of class ValidationIncident.
ToString | This is ToString, a member of class ValidationIncident.
ValidationIncident | This is ValidationIncident, a member of class ValidationIncident.
Top
Public Properties
Name | Description
Message | This is Message, a member of class ValidationIncident.
Severity | This is Severity, a member of class ValidationIncident.


ValidationIncident.ValidationIncident Constructor

ValidationIncident.ValidationIncident Constructor
ValidationIncident Class ValidationIncident Members Eco.Handles.Design Namespace See Also
Collapse All
C#
public ValidationIncident(
    Severity severity,
    string message
);
Remarks

This is ValidationIncident, a member of class ValidationIncident.

See Also
ValidationIncident Class
ValidationIncident Members
Eco.Handles.Design Namespace


ValidationIncident Methods

ValidationIncident Methods
Public Methods
Collapse All

The methods of the ValidationIncident class are listed here.

Public Methods
Name | Description
ToShortString | This is ToShortString, a member of class ValidationIncident.
ToString | This is ToString, a member of class ValidationIncident.


ValidationIncident.ToShortString Method

ValidationIncident.ToShortString Method
ValidationIncident Class ValidationIncident Members Eco.Handles.Design Namespace See Also
Collapse All
C#
public virtual string ToShortString();
Remarks

This is ToShortString, a member of class ValidationIncident.

See Also
ValidationIncident Class
ValidationIncident Members
Eco.Handles.Design Namespace


ValidationIncident.ToString Method

ValidationIncident.ToString Method
ValidationIncident Class ValidationIncident Members Eco.Handles.Design Namespace See Also
Collapse All
C#
public override string ToString();
Remarks

This is ToString, a member of class ValidationIncident.

See Also
ValidationIncident Class
ValidationIncident Members
Eco.Handles.Design Namespace


ValidationIncident Properties

ValidationIncident Properties
Public Properties
Collapse All

The properties of the ValidationIncident class are listed here.

Public Properties
Name | Description
Message | This is Message, a member of class ValidationIncident.
Severity | This is Severity, a member of class ValidationIncident.


ValidationIncident.Message Property

ValidationIncident.Message Property
ValidationIncident Class ValidationIncident Members Eco.Handles.Design Namespace See Also
Collapse All
C#
public string Message;
Remarks

This is Message, a member of class ValidationIncident.

See Also
ValidationIncident Class
ValidationIncident Members
Eco.Handles.Design Namespace


ValidationIncident.Severity Property

ValidationIncident.Severity Property
ValidationIncident Class ValidationIncident Members Eco.Handles.Design Namespace See Also
Collapse All
C#
public Severity Severity;
Remarks

This is Severity, a member of class ValidationIncident.

See Also
ValidationIncident Class
ValidationIncident Members
Eco.Handles.Design Namespace


ValidationReport Class

ValidationReport Class
ValidationReport Members Inheritance Hierarchy See Also
Collapse All
C#
public class ValidationReport;
Remarks

This is class Eco.Handles.Design.ValidationReport.

Inheritance Hierarchy
Eco.Handles.Design.ValidationReport
    Eco.Handles.Design.FormValidationReport
    Eco.Handles.Design.ModelValidationReport
File

ValidationReport.cs

See Also
ValidationReport Members
Inheritance Hierarchy


ValidationReport Members

ValidationReport Members
Public Methods Public Properties
Collapse All

The following tables list the members exposed by ValidationReport.

Public Methods
Name | Description
Clear | This method resets the Incidents.
Count | This is Count, a member of class ValidationReport.
Print | Prints the all incidents ToString() in the IDE's message display facility.
Top
Public Properties
Name | Description
Incidents | This is Incidents, a member of class ValidationReport.


ValidationReport Methods

ValidationReport Methods
Public Methods
Collapse All

The methods of the ValidationReport class are listed here.

Public Methods
Name | Description
Clear | This method resets the Incidents.
Count | This is Count, a member of class ValidationReport.
Print | Prints the all incidents ToString() in the IDE's message display facility.


ValidationReport.Clear Method

ValidationReport.Clear Method
ValidationReport Class ValidationReport Members Eco.Handles.Design Namespace See Also
Collapse All

This method resets the Incidents.

C#
public void Clear();
See Also
ValidationReport Class
ValidationReport Members
Eco.Handles.Design Namespace


ValidationReport.Count Method

ValidationReport.Count Method
ValidationReport Class ValidationReport Members Eco.Handles.Design Namespace See Also
Collapse All
C#
public int Count(
    Severity severity
);
Remarks

This is Count, a member of class ValidationReport.

See Also
ValidationReport Class
ValidationReport Members
Eco.Handles.Design Namespace


ValidationReport.Print Method

ValidationReport.Print Method
ValidationReport Class ValidationReport Members Eco.Handles.Design Namespace See Also
Collapse All

Prints the all incidents ToString() in the IDE's message display facility.

C#
public virtual void Print();
See Also
ValidationReport Class
ValidationReport Members
Eco.Handles.Design Namespace


ValidationReport Properties

ValidationReport Properties
Public Properties
Collapse All

The properties of the ValidationReport class are listed here.

Public Properties
Name | Description
Incidents | This is Incidents, a member of class ValidationReport.


ValidationReport.Incidents Property

ValidationReport.Incidents Property
ValidationReport Class ValidationReport Members Eco.Handles.Design Namespace See Also
Collapse All
C#
public List<ValidationIncident> Incidents;
Remarks

This is Incidents, a member of class ValidationReport.

See Also
ValidationReport Class
ValidationReport Members
Eco.Handles.Design Namespace


WinFormValidator Class

WinFormValidator Class
WinFormValidator Members Inheritance Hierarchy See Also
Collapse All

Implements validation for handles and extenders.

C#
public class WinFormValidator : IFormValidator;
Inheritance Hierarchy
Eco.Handles.Design.IFormValidator
    Eco.Handles.Design.WinFormValidator
File

WinFormValidator.cs

See Also
WinFormValidator Members
Inheritance Hierarchy


WinFormValidator Members

WinFormValidator Members
Public Methods
Collapse All

The following tables list the members exposed by WinFormValidator.

Public Methods
Name | Description
ValidateComponent | Validates the component.


WinFormValidator Methods

WinFormValidator Methods
Public Methods
Collapse All

The methods of the WinFormValidator class are listed here.

Public Methods
Name | Description
ValidateComponent | Validates the component.


WinFormValidator.ValidateComponent Method

WinFormValidator.ValidateComponent Method
WinFormValidator Class WinFormValidator Members Eco.Handles.Design Namespace See Also
Collapse All

Validates the component.

C#
public void ValidateComponent(
    FormValidatorArgs args
);
Remarks

Checks that RootedHandle have RootHandle set. Yields a hint. Validates the expressions of columns of ElementHandle by means of EcoValidationHelper.ValidateEcoComponent. Validates the expressions (ActionOcl, EnabledOcl and VisibleOcl) of extended components using EcoValidationHelper.ValidateExpression. Validates the expressions components implementing IHasEditableExpression using EcoValidationHelper.ValidateEcoComponent. EcoValidationHelper.ValidateExpression. EcoValidationHelper.ValidateEcoComponent.

See Also
WinFormValidator Class
WinFormValidator Members
Eco.Handles.Design Namespace


IComponentFilter Interface

IComponentFilter Interface
IComponentFilter Members Inheritance Hierarchy See Also
Collapse All

Used by AbstractManipulator.PreviousComponent() to get a requested component.

C#
public interface IComponentFilter;
Inheritance Hierarchy
Eco.Handles.Design.IComponentFilter
File

AbstractPropertyManipulator.cs

See Also
IComponentFilter Members
Inheritance Hierarchy


IComponentFilter Members

IComponentFilter Members
Public Methods
Collapse All

The following tables list the members exposed by IComponentFilter.

Public Methods
Name | Description
CheckFilter | Returns true if the component fulfills the filter requirements.


IComponentFilter Methods

IComponentFilter Methods
Public Methods
Collapse All

The methods of the IComponentFilter class are listed here.

Public Methods
Name | Description
CheckFilter | Returns true if the component fulfills the filter requirements.


IComponentFilter.CheckFilter Method

IComponentFilter.CheckFilter Method
IComponentFilter Interface IComponentFilter Members Eco.Handles.Design Namespace See Also
Collapse All

Returns true if the component fulfills the filter requirements.

C#
bool CheckFilter(
    IComponent component
);
See Also
IComponentFilter Interface
IComponentFilter Members
Eco.Handles.Design Namespace


IComponentSetFilter Interface

IComponentSetFilter Interface
IComponentSetFilter Members Inheritance Hierarchy See Also
Collapse All
C#
public interface IComponentSetFilter;
Remarks

This is class Eco.Handles.Design.IComponentSetFilter.

Inheritance Hierarchy
Eco.Handles.Design.IComponentSetFilter
File

ContextComponentDictionary.cs

See Also
IComponentSetFilter Members
Inheritance Hierarchy


IComponentSetFilter Members

IComponentSetFilter Members
Public Methods
Collapse All

The following tables list the members exposed by IComponentSetFilter.

Public Methods
Name | Description
Allow | This is Allow, a member of class IComponentSetFilter.


IComponentSetFilter Methods

IComponentSetFilter Methods
Public Methods
Collapse All

The methods of the IComponentSetFilter class are listed here.

Public Methods
Name | Description
Allow | This is Allow, a member of class IComponentSetFilter.


IComponentSetFilter.Allow Method

IComponentSetFilter.Allow Method
IComponentSetFilter Interface IComponentSetFilter Members Eco.Handles.Design Namespace See Also
Collapse All
C#
bool Allow(
    IComponent component
);
Remarks

This is Allow, a member of class IComponentSetFilter.

See Also
IComponentSetFilter Interface
IComponentSetFilter Members
Eco.Handles.Design Namespace


IEcoSpaceDesignerTool Interface

IEcoSpaceDesignerTool Interface
IEcoSpaceDesignerTool Members Inheritance Hierarchy See Also
Collapse All

An interface that must be implemented to be part of the EcoDesigner tools

C#
public interface IEcoSpaceDesignerTool;
Inheritance Hierarchy
Eco.Handles.Design.IEcoSpaceDesignerTool
    Eco.Handles.Design.EcoToolButtonBase
File

EcoSpaceDesignerToolBox.cs

See Also
IEcoSpaceDesignerTool Members
Inheritance Hierarchy


IEcoSpaceDesignerTool Members

IEcoSpaceDesignerTool Members
Public Methods
Collapse All

The following tables list the members exposed by IEcoSpaceDesignerTool.

Public Methods
Name | Description
Execute | Execute is called when the GUI widget (button/menu) is invoked.
GetCaption | GetCaption will return the string used in the popup menu.
GetDesignerTypes | GetDesignerType will be called once for each time the EcoSpaceDesigner is recreated/shown. It determins which designers the tool belongs to.
GetHint | GetHint will be called once for each time the EcoSpaceDesigner is recreated/shown. Any speed keys (ampersands) should be removed.
GetImage | GetImage will be called once for each time the EcoSpaceDesigner is recreated/shown.
GetToolKind | GetToolKind will be called once for each time the EcoSpaceDesigner is recreated/shown.
RequireRecompile | RequireRecompile indicates if the calling site should attempt to recompile the project before invoking Execute. If True and compilation fails, an exception will be raised.


IEcoSpaceDesignerTool Methods

IEcoSpaceDesignerTool Methods
Public Methods
Collapse All

The methods of the IEcoSpaceDesignerTool class are listed here.

Public Methods
Name | Description
Execute | Execute is called when the GUI widget (button/menu) is invoked.
GetCaption | GetCaption will return the string used in the popup menu.
GetDesignerTypes | GetDesignerType will be called once for each time the EcoSpaceDesigner is recreated/shown. It determins which designers the tool belongs to.
GetHint | GetHint will be called once for each time the EcoSpaceDesigner is recreated/shown. Any speed keys (ampersands) should be removed.
GetImage | GetImage will be called once for each time the EcoSpaceDesigner is recreated/shown.
GetToolKind | GetToolKind will be called once for each time the EcoSpaceDesigner is recreated/shown.
RequireRecompile | RequireRecompile indicates if the calling site should attempt to recompile the project before invoking Execute. If True and compilation fails, an exception will be raised.


IEcoSpaceDesignerTool.Execute Method

IEcoSpaceDesignerTool.Execute Method
IEcoSpaceDesignerTool Interface IEcoSpaceDesignerTool Members Eco.Handles.Design Namespace See Also
Collapse All

Execute is called when the GUI widget (button/menu) is invoked.

C#
void Execute(
    ExecuteArgs executeArgs
);
See Also
IEcoSpaceDesignerTool Interface
IEcoSpaceDesignerTool Members
Eco.Handles.Design Namespace


IEcoSpaceDesignerTool.GetCaption Method

IEcoSpaceDesignerTool.GetCaption Method
IEcoSpaceDesignerTool Interface IEcoSpaceDesignerTool Members Eco.Handles.Design Namespace See Also
Collapse All

GetCaption will return the string used in the popup menu.

C#
string GetCaption();
See Also
IEcoSpaceDesignerTool Interface
IEcoSpaceDesignerTool Members
Eco.Handles.Design Namespace


IEcoSpaceDesignerTool.GetDesignerTypes Method

IEcoSpaceDesignerTool.GetDesignerTypes Method
IEcoSpaceDesignerTool Interface IEcoSpaceDesignerTool Members Eco.Handles.Design Namespace See Also
Collapse All

GetDesignerType will be called once for each time the EcoSpaceDesigner is recreated/shown. It determins which designers the tool belongs to.

C#
DesignerTypes GetDesignerTypes();
See Also
IEcoSpaceDesignerTool Interface
IEcoSpaceDesignerTool Members
Eco.Handles.Design Namespace


IEcoSpaceDesignerTool.GetHint Method

IEcoSpaceDesignerTool.GetHint Method
IEcoSpaceDesignerTool Interface IEcoSpaceDesignerTool Members Eco.Handles.Design Namespace See Also
Collapse All

GetHint will be called once for each time the EcoSpaceDesigner is recreated/shown. Any speed keys (ampersands) should be removed.

C#
string GetHint();
See Also
IEcoSpaceDesignerTool Interface
IEcoSpaceDesignerTool Members
Eco.Handles.Design Namespace


IEcoSpaceDesignerTool.GetImage Method

IEcoSpaceDesignerTool.GetImage Method
IEcoSpaceDesignerTool Interface IEcoSpaceDesignerTool Members Eco.Handles.Design Namespace See Also
Collapse All

GetImage will be called once for each time the EcoSpaceDesigner is recreated/shown.

C#
Image GetImage();
See Also
IEcoSpaceDesignerTool Interface
IEcoSpaceDesignerTool Members
Eco.Handles.Design Namespace


IEcoSpaceDesignerTool.GetToolKind Method

IEcoSpaceDesignerTool.GetToolKind Method
IEcoSpaceDesignerTool Interface IEcoSpaceDesignerTool Members Eco.Handles.Design Namespace See Also
Collapse All

GetToolKind will be called once for each time the EcoSpaceDesigner is recreated/shown.

C#
EcoToolKind GetToolKind();
See Also
IEcoSpaceDesignerTool Interface
IEcoSpaceDesignerTool Members
Eco.Handles.Design Namespace


IEcoSpaceDesignerTool.RequireRecompile Method

IEcoSpaceDesignerTool.RequireRecompile Method
IEcoSpaceDesignerTool Interface IEcoSpaceDesignerTool Members Eco.Handles.Design Namespace See Also
Collapse All

RequireRecompile indicates if the calling site should attempt to recompile the project before invoking Execute. If True and compilation fails, an exception will be raised.

C#
bool RequireRecompile();
See Also
IEcoSpaceDesignerTool Interface
IEcoSpaceDesignerTool Members
Eco.Handles.Design Namespace


IFormValidator Interface

IFormValidator Interface
IFormValidator Members Inheritance Hierarchy See Also
Collapse All

Required interface to participate in form validation.

C#
public interface IFormValidator;
Inheritance Hierarchy
Eco.Handles.Design.IFormValidator
    Eco.Handles.Design.TestValidator
    Eco.Handles.Design.WinFormValidator
File

FormValidator.cs

See Also
IFormValidator Members
Inheritance Hierarchy


IFormValidator Members

IFormValidator Members
Public Methods
Collapse All

The following tables list the members exposed by IFormValidator.

Public Methods
Name | Description
ValidateComponent | Called once per component per form.


IFormValidator Methods

IFormValidator Methods
Public Methods
Collapse All

The methods of the IFormValidator class are listed here.

Public Methods
Name | Description
ValidateComponent | Called once per component per form.


IFormValidator.ValidateComponent Method

IFormValidator.ValidateComponent Method
IFormValidator Interface IFormValidator Members Eco.Handles.Design Namespace See Also
Collapse All

Called once per component per form.

C#
void ValidateComponent(
    FormValidatorArgs args
);
Remarks

This method should implement the rules to validate that the component is properly defined. Any validation breakages should be added to args.Report.

See Also
IFormValidator Interface
IFormValidator Members
Eco.Handles.Design Namespace


IModelValidateTool Interface

IModelValidateTool Interface
IModelValidateTool Members Inheritance Hierarchy See Also
Collapse All

This interface allows communication between tools without exposing their classes.

C#
public interface IModelValidateTool;
Remarks

Tools in other packages may want to gain access to the report validator tool, defined in Eco.Persistence.Design without being allowed to know about that assembly. This is the case for the upgrade tool in ModelLayer.

Inheritance Hierarchy
Eco.Handles.Design.IModelValidateTool
File

EcoSpaceDesignerTools.cs

See Also
IModelValidateTool Members
Inheritance Hierarchy


IModelValidateTool Members

IModelValidateTool Members
Public Methods Public Properties
Collapse All

The following tables list the members exposed by IModelValidateTool.

Public Methods
Name | Description
Execute | The implementing class should execute the tool logic when this operation is invoked.
Top
Public Properties
Name | Description
ValidationReport | The implementing class should return a ValidationReport.


IModelValidateTool Methods

IModelValidateTool Methods
Public Methods
Collapse All

The methods of the IModelValidateTool class are listed here.

Public Methods
Name | Description
Execute | The implementing class should execute the tool logic when this operation is invoked.


IModelValidateTool.Execute Method

IModelValidateTool.Execute Method
IModelValidateTool Interface IModelValidateTool Members Eco.Handles.Design Namespace See Also
Collapse All

The implementing class should execute the tool logic when this operation is invoked.

C#
void Execute(
    ExecuteArgs executeArgs
);
See Also
IModelValidateTool Interface
IModelValidateTool Members
Eco.Handles.Design Namespace


IModelValidateTool Properties

IModelValidateTool Properties
Public Properties
Collapse All

The properties of the IModelValidateTool class are listed here.

Public Properties
Name | Description
ValidationReport | The implementing class should return a ValidationReport.


IModelValidateTool.ValidationReport Property

IModelValidateTool.ValidationReport Property
IModelValidateTool Interface IModelValidateTool Members Eco.Handles.Design Namespace See Also
Collapse All

The implementing class should return a ValidationReport.

C#
ValidationReport ValidationReport;
See Also
IModelValidateTool Interface
IModelValidateTool Members
Eco.Handles.Design Namespace


Eco.Handles.Design.Context Enumeration

Eco.Handles.Design.Context Enumeration
C#
public enum Context {
  Global,
  Form,
  Selection
}
Remarks

This is record Eco.Handles.Design.Context.

File

Eco.Handles.Design.ContextComponentsForm.cs


Eco.Handles.Design.CreateMode Enumeration

Eco.Handles.Design.CreateMode Enumeration

Used to pass information from UI wether the node was invoked by doubleclick or dragging onto the designer.

C#
public enum CreateMode {
  Clicked,
  Dragged
}
Members
Members | Description
Clicked | Invokation by double-click.
Dragged | Invokation by drag-drop.
File

ContextComponentDictionary.cs


Eco.Handles.Design.DesignerTypes Enumeration

Eco.Handles.Design.DesignerTypes Enumeration

Enumeration of the various designer tools can end up in.

C#
public enum DesignerTypes {
  EcoSpace = 1,
  PersistenceMapperProvider = 2
}
Members
Members | Description
EcoSpace | The tool shows on an ecospace designer.
PersistenceMapperProvider | The tool shows on an PersistenceMapperProvider designer.
File

EcoSpaceDesignerToolBox.cs


Eco.Handles.Design.DispatchEvent Enumeration

Eco.Handles.Design.DispatchEvent Enumeration
C#
public enum DispatchEvent {
  Unknown = 0,
  SelectionChanged = 1<<1,
  ComponentChanged = 1<<2,
  ComponentAdded = 1<<3,
  ComponentRemoved = 1<<4,
  DesignerChanged = 1<<5,
  ProjectRecompiled = 1<<6,
  ProjectClosed = 1<<7
}
Members
Members | Description
SelectionChanged | Designer selection changed
ComponentChanged | A component changed
ComponentAdded | Component added to the designer
ComponentRemoved | Component removed from the designer
DesignerChanged | Active designer changed
ProjectRecompiled | The project was recompiled
ProjectClosed | The last project was closed (no active project)
Remarks

This is record Eco.Handles.Design.DispatchEvent.

File

WidgetSelector.cs


Eco.Handles.Design.EcoToolKind Enumeration

Eco.Handles.Design.EcoToolKind Enumeration

Specifying if the tool is a button or menu. Currently only Button is supported.

C#
public enum EcoToolKind {
  Button,
  Menu
}
Members
Members | Description
Button | The tool will manifest as a button on the toolbar.
Menu | The tool will manifest as a menu on the toolbar.
File

EcoSpaceDesignerToolBox.cs


Eco.Handles.Design.Severity Enumeration

Eco.Handles.Design.Severity Enumeration
C#
public enum Severity {
  Error,
  Warning,
  Hint,
  Info
}
Remarks

This is record Eco.Handles.Design.Severity.

File

ValidationReport.cs


Eco.Handles.Design.ChangeEventHandler Type

Eco.Handles.Design.ChangeEventHandler Type
C#
public delegate void ChangeEventHandler(object sender, ChangeEventArgs e);
Remarks

This is type Eco.Handles.Design.ChangeEventHandler.

File

WidgetSelector.cs


Eco.ModelValidation Namespace

Eco.ModelValidation Namespace
Classes Interfaces
Collapse All

This is namespace Eco.ModelValidation.

Classes
Name | Description
ModelValidator | Validates the model for illegal modeling constructs.
OclValidator | This class implements IModelValidator to validate the model for various illegal or non-recommended contructs. ModelValidator cannot be inherited. If you want to extend the validation you need to implement IModelValidator and register your own class using ValidatorPlugins.
ValidationArgs | Class that passes arguments to the IModelValidator methods.
ValidatorPluginsValidator | Class to perform validation using all IModelValidators in ValidatorPlugins
Top
Interfaces
Name | Description
IModelValidator | To participate in model validation, implement this interface and register an instance of the implementing class in ValidatorPlugins.RegisterValidator. The calling sequence is as follows: Reset ValidateModelthen for all classes in model ValidateClassthen for all attributes in each class ValidateAttributethen for all associations in model ValidateAssociationthen for the two association ends in each association ValidateAssociationEnd PostValidation


ModelValidator Class

ModelValidator Class
ModelValidator Members Inheritance Hierarchy See Also
Collapse All

Validates the model for illegal modeling constructs.

C#
public sealed class ModelValidator : IModelValidator;
Remarks

This class implements IModelValidator to validate the model for various illegal or non-recommended contructs. ModelValidator cannot be inherited. If you want to extend the validation you need to implement IModelValidator and register your own class using ValidatorPlugins.

Inheritance Hierarchy
Eco.ModelValidation.IModelValidator
    Eco.ModelValidation.ModelValidator
File

ValidateModel.cs

See Also
ModelValidator Members
Inheritance Hierarchy


ModelValidator Members

ModelValidator Members
Public Methods
Collapse All

The following tables list the members exposed by ModelValidator.

Public Methods
Name | Description
PostValidation | Not implemented. Does nothing.
Reset | Not implemented. Does nothing.
ValidateAssociation | Validates an association.
ValidateAssociationEnd | Validates an association end.
ValidateAttribute | Validates an attribute.
ValidateClass | Validates things pertaining to a modeled class.
ValidateModel | Validates things global to the model.


ModelValidator Methods

ModelValidator Methods
Public Methods
Collapse All

The methods of the ModelValidator class are listed here.

Public Methods
Name | Description
PostValidation | Not implemented. Does nothing.
Reset | Not implemented. Does nothing.
ValidateAssociation | Validates an association.
ValidateAssociationEnd | Validates an association end.
ValidateAttribute | Validates an attribute.
ValidateClass | Validates things pertaining to a modeled class.
ValidateModel | Validates things global to the model.


ModelValidator.PostValidation Method

ModelValidator.PostValidation Method
ModelValidator Class ModelValidator Members Eco.ModelValidation Namespace See Also
Collapse All

Not implemented. Does nothing.

C#
public void PostValidation(
    IEcoTypeSystem model,
    ValidationArgs validationArgs
);
See Also
ModelValidator Class
ModelValidator Members
Eco.ModelValidation Namespace


ModelValidator.Reset Method

ModelValidator.Reset Method
ModelValidator Class ModelValidator Members Eco.ModelValidation Namespace See Also
Collapse All

Not implemented. Does nothing.

C#
public void Reset();
See Also
ModelValidator Class
ModelValidator Members
Eco.ModelValidation Namespace


ModelValidator.ValidateAssociation Method

ModelValidator.ValidateAssociation Method
ModelValidator Class ModelValidator Members Eco.ModelValidation Namespace See Also
Collapse All

Validates an association.

C#
public void ValidateAssociation(
    IAssociation association,
    ValidationArgs validationArgs
);
Exceptions
Exceptions | Description
ArgumentNullException | Thrown if association or validationArgs is null.
See Also
ModelValidator Class
ModelValidator Members
Eco.ModelValidation Namespace


ModelValidator.ValidateAssociationEnd Method

ModelValidator.ValidateAssociationEnd Method
ModelValidator Class ModelValidator Members Eco.ModelValidation Namespace See Also
Collapse All

Validates an association end.

C#
public void ValidateAssociationEnd(
    IAssociationEnd associationEnd,
    ValidationArgs validationArgs
);
Exceptions
Exceptions | Description
ArgumentNullException | Thrown if either of associationEnd or validationArgs is null.
See Also
ModelValidator Class
ModelValidator Members
Eco.ModelValidation Namespace


ModelValidator.ValidateAttribute Method

ModelValidator.ValidateAttribute Method
ModelValidator Class ModelValidator Members Eco.ModelValidation Namespace See Also
Collapse All

Validates an attribute.

C#
public void ValidateAttribute(
    IAttribute attribute,
    ValidationArgs validationArgs
);
Exceptions
Exceptions | Description
ArgumentNullException | Thrown if eithe rof attribute or validationArgs is null.
See Also
ModelValidator Class
ModelValidator Members
Eco.ModelValidation Namespace


ModelValidator.ValidateClass Method

ModelValidator.ValidateClass Method
ModelValidator Class ModelValidator Members Eco.ModelValidation Namespace See Also
Collapse All

Validates things pertaining to a modeled class.

C#
public void ValidateClass(
    IClass class_,
    ValidationArgs validationArgs
);
Remarks

///

private static string TaggedValuex(IModelElement element, string tag) { if (element == null) throw new ArgumentNullException("element"); ITaggedValue _taggedValue = element.TaggedValues.GetItemByTag(tag); if (_taggedValue == null) throw new InvalidOperationException(string.Format("{0} not found in {1}", tag, element.Name)); return _taggedValue.Value; }

Exceptions
Exceptions | Description
ArgumentNullException | Thrown if element is null. Thrown if either of class_ or validationArgs is null.
See Also
ModelValidator Class
ModelValidator Members
Eco.ModelValidation Namespace


ModelValidator.ValidateModel Method

ModelValidator.ValidateModel Method
ModelValidator Class ModelValidator Members Eco.ModelValidation Namespace See Also
Collapse All

Validates things global to the model.

C#
public void ValidateModel(
    IEcoTypeSystem model,
    ValidationArgs validationArgs
);
Exceptions
Exceptions | Description
ArgumentNullException | Thrown if model or validationArgs is null.
See Also
ModelValidator Class
ModelValidator Members
Eco.ModelValidation Namespace


OclValidator Class

OclValidator Class
OclValidator Members Inheritance Hierarchy See Also
Collapse All

This class implements IModelValidator to validate the model for various illegal or non-recommended contructs. ModelValidator cannot be inherited. If you want to extend the validation you need to implement IModelValidator and register your own class using ValidatorPlugins.

C#
public sealed class OclValidator : IModelValidator;
Inheritance Hierarchy
Eco.ModelValidation.IModelValidator
    Eco.ModelValidation.OclValidator
File

ValidateOcl.cs

See Also
OclValidator Members
Inheritance Hierarchy


OclValidator Members

OclValidator Members
Public Methods
Collapse All

The following tables list the members exposed by OclValidator.

Public Methods
Name | Description
PostValidation | Method can be used to operate on information collected during traversal of model elements.
Reset | If the implementing class needs to reset some state, it should be done here.
ValidateAssociation |
ValidateAssociationEnd |
ValidateAttribute |
ValidateClass |
ValidateModel |


OclValidator Methods

OclValidator Methods
Public Methods
Collapse All

The methods of the OclValidator class are listed here.

Public Methods
Name | Description
PostValidation | Method can be used to operate on information collected during traversal of model elements.
Reset | If the implementing class needs to reset some state, it should be done here.
ValidateAssociation |
ValidateAssociationEnd |
ValidateAttribute |
ValidateClass |
ValidateModel |


OclValidator.PostValidation Method

OclValidator.PostValidation Method
OclValidator Class OclValidator Members Eco.ModelValidation Namespace See Also
Collapse All

Method can be used to operate on information collected during traversal of model elements.

C#
public void PostValidation(
    IEcoTypeSystem model,
    ValidationArgs validationArgs
);
See Also
OclValidator Class
OclValidator Members
Eco.ModelValidation Namespace


OclValidator.Reset Method

OclValidator.Reset Method
OclValidator Class OclValidator Members Eco.ModelValidation Namespace See Also
Collapse All

If the implementing class needs to reset some state, it should be done here.

C#
public void Reset();
See Also
OclValidator Class
OclValidator Members
Eco.ModelValidation Namespace


OclValidator.ValidateAssociation Method

OclValidator.ValidateAssociation Method
OclValidator Class OclValidator Members Eco.ModelValidation Namespace See Also
Collapse All
C#
public void ValidateAssociation(
    IAssociation association,
    ValidationArgs validationArgs
);
Exceptions
Exceptions | Description
ArgumentNullException | Thrown if association is null.
See Also
OclValidator Class
OclValidator Members
Eco.ModelValidation Namespace


OclValidator.ValidateAssociationEnd Method

OclValidator.ValidateAssociationEnd Method
OclValidator Class OclValidator Members Eco.ModelValidation Namespace See Also
Collapse All
C#
public void ValidateAssociationEnd(
    IAssociationEnd associationEnd,
    ValidationArgs validationArgs
);
Exceptions
Exceptions | Description
ArgumentNullException | Thrown if associationEnd is null.
See Also
OclValidator Class
OclValidator Members
Eco.ModelValidation Namespace


OclValidator.ValidateAttribute Method

OclValidator.ValidateAttribute Method
OclValidator Class OclValidator Members Eco.ModelValidation Namespace See Also
Collapse All
C#
public void ValidateAttribute(
    IAttribute attribute,
    ValidationArgs validationArgs
);
Exceptions
Exceptions | Description
ArgumentNullException | Thrown if attribute is null.
See Also
OclValidator Class
OclValidator Members
Eco.ModelValidation Namespace


OclValidator.ValidateClass Method

OclValidator.ValidateClass Method
OclValidator Class OclValidator Members Eco.ModelValidation Namespace See Also
Collapse All
C#
public void ValidateClass(
    IClass class_,
    ValidationArgs validationArgs
);
Exceptions
Exceptions | Description
ArgumentNullException | Thrown if class_ is null.
See Also
OclValidator Class
OclValidator Members
Eco.ModelValidation Namespace


OclValidator.ValidateModel Method

OclValidator.ValidateModel Method
OclValidator Class OclValidator Members Eco.ModelValidation Namespace See Also
Collapse All
C#
public void ValidateModel(
    IEcoTypeSystem model,
    ValidationArgs validationArgs
);
Exceptions
Exceptions | Description
ArgumentNullException | Thrown if validationArgs is null.
See Also
OclValidator Class
OclValidator Members
Eco.ModelValidation Namespace


ValidationArgs Class

ValidationArgs Class
ValidationArgs Members Inheritance Hierarchy See Also
Collapse All

Class that passes arguments to the IModelValidator methods.

C#
public class ValidationArgs;
Inheritance Hierarchy
Eco.ModelValidation.ValidationArgs
File

ModelValidation.cs

See Also
ValidationArgs Members
Inheritance Hierarchy


ValidationArgs Members

ValidationArgs Members
Public Methods Public Properties
Collapse All

The following tables list the members exposed by ValidationArgs.

Public Methods
Name | Description
ValidationArgs | This is ValidationArgs, a member of class ValidationArgs.
Top
Public Properties
Name | Description
ActionLanguageTypeService | This is ActionLanguageTypeService, a member of class ValidationArgs.
DatabaseConfig | This is DatabaseConfig, a member of class ValidationArgs.
OclTypeService | This is OclTypeService, a member of class ValidationArgs.
Report | This is Report, a member of class ValidationArgs.
VariableFactoryService | This is VariableFactoryService, a member of class ValidationArgs.


ValidationArgs.ValidationArgs Constructor

ValidationArgs.ValidationArgs Constructor
ValidationArgs Class ValidationArgs Members Eco.ModelValidation Namespace See Also
Collapse All
C#
public ValidationArgs(
    IEcoServiceProvider serviceProvider,
    SqlDatabaseConfig databaseConfig,
    ModelValidationReport report
);
Remarks

This is ValidationArgs, a member of class ValidationArgs.

See Also
ValidationArgs Class
ValidationArgs Members
Eco.ModelValidation Namespace


ValidationArgs Properties

ValidationArgs Properties
Public Properties
Collapse All

The properties of the ValidationArgs class are listed here.

Public Properties
Name | Description
ActionLanguageTypeService | This is ActionLanguageTypeService, a member of class ValidationArgs.
DatabaseConfig | This is DatabaseConfig, a member of class ValidationArgs.
OclTypeService | This is OclTypeService, a member of class ValidationArgs.
Report | This is Report, a member of class ValidationArgs.
VariableFactoryService | This is VariableFactoryService, a member of class ValidationArgs.


ValidationArgs.ActionLanguageTypeService Property

ValidationArgs.ActionLanguageTypeService Property
ValidationArgs Class ValidationArgs Members Eco.ModelValidation Namespace See Also
Collapse All
C#
public IActionLanguageTypeService ActionLanguageTypeService;
Remarks

This is ActionLanguageTypeService, a member of class ValidationArgs.

See Also
ValidationArgs Class
ValidationArgs Members
Eco.ModelValidation Namespace


ValidationArgs.DatabaseConfig Property

ValidationArgs.DatabaseConfig Property
ValidationArgs Class ValidationArgs Members Eco.ModelValidation Namespace See Also
Collapse All
C#
public SqlDatabaseConfig DatabaseConfig;
Remarks

This is DatabaseConfig, a member of class ValidationArgs.

See Also
ValidationArgs Class
ValidationArgs Members
Eco.ModelValidation Namespace


ValidationArgs.OclTypeService Property

ValidationArgs.OclTypeService Property
ValidationArgs Class ValidationArgs Members Eco.ModelValidation Namespace See Also
Collapse All
C#
public IOclTypeService OclTypeService;
Remarks

This is OclTypeService, a member of class ValidationArgs.

See Also
ValidationArgs Class
ValidationArgs Members
Eco.ModelValidation Namespace


ValidationArgs.Report Property

ValidationArgs.Report Property
ValidationArgs Class ValidationArgs Members Eco.ModelValidation Namespace See Also
Collapse All
C#
public ModelValidationReport Report;
Remarks

This is Report, a member of class ValidationArgs.

See Also
ValidationArgs Class
ValidationArgs Members
Eco.ModelValidation Namespace


ValidationArgs.VariableFactoryService Property

ValidationArgs.VariableFactoryService Property
ValidationArgs Class ValidationArgs Members Eco.ModelValidation Namespace See Also
Collapse All
C#
public IVariableFactoryService VariableFactoryService;
Remarks

This is VariableFactoryService, a member of class ValidationArgs.

See Also
ValidationArgs Class
ValidationArgs Members
Eco.ModelValidation Namespace


ValidatorPluginsValidator Class

ValidatorPluginsValidator Class
ValidatorPluginsValidator Members Inheritance Hierarchy See Also
Collapse All

Class to perform validation using all IModelValidators in ValidatorPlugins

C#
public class ValidatorPluginsValidator;
Inheritance Hierarchy
Eco.ModelValidation.ValidatorPluginsValidator
File

ModelValidation.cs

See Also
ValidatorPluginsValidator Members
Inheritance Hierarchy


ValidatorPluginsValidator Members

ValidatorPluginsValidator Members
Public Methods Public Properties
Collapse All

The following tables list the members exposed by ValidatorPluginsValidator.

Public Methods
Name | Description
Validate | This is Validate, a member of class ValidatorPluginsValidator.
ValidatorPluginsValidator | This is ValidatorPluginsValidator, a member of class ValidatorPluginsValidator.
Top
Public Properties
Name | Description
Report | This is Report, a member of class ValidatorPluginsValidator.
ValidatorPlugins | This is ValidatorPlugins, a member of class ValidatorPluginsValidator.


ValidatorPluginsValidator.ValidatorPluginsValidator Constructor

ValidatorPluginsValidator.ValidatorPluginsValidator Constructor
ValidatorPluginsValidator Class ValidatorPluginsValidator Members Eco.ModelValidation Namespace See Also
Collapse All
C#
public ValidatorPluginsValidator(
    IEcoServiceProvider serviceProvider,
    SqlDatabaseConfig sqlDatabaseConfig
);
Remarks

This is ValidatorPluginsValidator, a member of class ValidatorPluginsValidator.

See Also
ValidatorPluginsValidator Class
ValidatorPluginsValidator Members
Eco.ModelValidation Namespace


ValidatorPluginsValidator Methods

ValidatorPluginsValidator Methods
Public Methods
Collapse All

The methods of the ValidatorPluginsValidator class are listed here.

Public Methods
Name | Description
Validate | This is Validate, a member of class ValidatorPluginsValidator.


ValidatorPluginsValidator.Validate Method

ValidatorPluginsValidator.Validate Method
ValidatorPluginsValidator Class ValidatorPluginsValidator Members Eco.ModelValidation Namespace See Also
Collapse All
C#
public void Validate();
Remarks

This is Validate, a member of class ValidatorPluginsValidator.

See Also
ValidatorPluginsValidator Class
ValidatorPluginsValidator Members
Eco.ModelValidation Namespace


ValidatorPluginsValidator Properties

ValidatorPluginsValidator Properties
Public Properties
Collapse All

The properties of the ValidatorPluginsValidator class are listed here.

Public Properties
Name | Description
Report | This is Report, a member of class ValidatorPluginsValidator.
ValidatorPlugins | This is ValidatorPlugins, a member of class ValidatorPluginsValidator.


ValidatorPluginsValidator.Report Property

ValidatorPluginsValidator.Report Property
ValidatorPluginsValidator Class ValidatorPluginsValidator Members Eco.ModelValidation Namespace See Also
Collapse All
C#
public ModelValidationReport Report;
Remarks

This is Report, a member of class ValidatorPluginsValidator.

See Also
ValidatorPluginsValidator Class
ValidatorPluginsValidator Members
Eco.ModelValidation Namespace


ValidatorPluginsValidator.ValidatorPlugins Property

ValidatorPluginsValidator.ValidatorPlugins Property
ValidatorPluginsValidator Class ValidatorPluginsValidator Members Eco.ModelValidation Namespace See Also
Collapse All
C#
public static List<IModelValidator> ValidatorPlugins;
Remarks

This is ValidatorPlugins, a member of class ValidatorPluginsValidator.

See Also
ValidatorPluginsValidator Class
ValidatorPluginsValidator Members
Eco.ModelValidation Namespace


IModelValidator Interface

IModelValidator Interface
IModelValidator Members Inheritance Hierarchy See Also
Collapse All

To participate in model validation, implement this interface and register an instance of the implementing class in ValidatorPlugins.RegisterValidator. The calling sequence is as follows: Reset ValidateModelthen for all classes in model ValidateClassthen for all attributes in each class ValidateAttributethen for all associations in model ValidateAssociationthen for the two association ends in each association ValidateAssociationEnd PostValidation

C#
public interface IModelValidator;
Inheritance Hierarchy
Eco.ModelValidation.IModelValidator
    Eco.ModelValidation.ModelValidator
    Eco.ModelValidation.OclValidator
File

ModelValidation.cs

See Also
IModelValidator Members
Inheritance Hierarchy


IModelValidator Members

IModelValidator Members
Public Methods
Collapse All

The following tables list the members exposed by IModelValidator.

Public Methods
Name | Description
PostValidation | Method can be used to operate on information collected during traversal of model elements.
Reset | If the implementing class needs to reset some state, it should be done here.
ValidateAssociation | Suitable method to implement validation on associations.
ValidateAssociationEnd | Suitable method to implement validation on association ends.
ValidateAttribute | Suitable method to implement validation on attributes.
ValidateClass | Suitable method to implement validation on class level.
ValidateModel | Suitable method to implement global validation on the model.


IModelValidator Methods

IModelValidator Methods
Public Methods
Collapse All

The methods of the IModelValidator class are listed here.

Public Methods
Name | Description
PostValidation | Method can be used to operate on information collected during traversal of model elements.
Reset | If the implementing class needs to reset some state, it should be done here.
ValidateAssociation | Suitable method to implement validation on associations.
ValidateAssociationEnd | Suitable method to implement validation on association ends.
ValidateAttribute | Suitable method to implement validation on attributes.
ValidateClass | Suitable method to implement validation on class level.
ValidateModel | Suitable method to implement global validation on the model.


IModelValidator.PostValidation Method

IModelValidator.PostValidation Method
IModelValidator Interface IModelValidator Members Eco.ModelValidation Namespace See Also
Collapse All

Method can be used to operate on information collected during traversal of model elements.

C#
void PostValidation(
    IEcoTypeSystem model,
    ValidationArgs validationArgs
);
See Also
IModelValidator Interface
IModelValidator Members
Eco.ModelValidation Namespace


IModelValidator.Reset Method

IModelValidator.Reset Method
IModelValidator Interface IModelValidator Members Eco.ModelValidation Namespace See Also
Collapse All

If the implementing class needs to reset some state, it should be done here.

C#
void Reset();
See Also
IModelValidator Interface
IModelValidator Members
Eco.ModelValidation Namespace


IModelValidator.ValidateAssociation Method

IModelValidator.ValidateAssociation Method
IModelValidator Interface IModelValidator Members Eco.ModelValidation Namespace See Also
Collapse All

Suitable method to implement validation on associations.

C#
void ValidateAssociation(
    IAssociation association,
    ValidationArgs validationArgs
);
See Also
IModelValidator Interface
IModelValidator Members
Eco.ModelValidation Namespace


IModelValidator.ValidateAssociationEnd Method

IModelValidator.ValidateAssociationEnd Method
IModelValidator Interface IModelValidator Members Eco.ModelValidation Namespace See Also
Collapse All

Suitable method to implement validation on association ends.

C#
void ValidateAssociationEnd(
    IAssociationEnd associationEnd,
    ValidationArgs validationArgs
);
See Also
IModelValidator Interface
IModelValidator Members
Eco.ModelValidation Namespace


IModelValidator.ValidateAttribute Method

IModelValidator.ValidateAttribute Method
IModelValidator Interface IModelValidator Members Eco.ModelValidation Namespace See Also
Collapse All

Suitable method to implement validation on attributes.

C#
void ValidateAttribute(
    IAttribute attribute,
    ValidationArgs validationArgs
);
See Also
IModelValidator Interface
IModelValidator Members
Eco.ModelValidation Namespace


IModelValidator.ValidateClass Method

IModelValidator.ValidateClass Method
IModelValidator Interface IModelValidator Members Eco.ModelValidation Namespace See Also
Collapse All

Suitable method to implement validation on class level.

C#
void ValidateClass(
    IClass class_,
    ValidationArgs validationArgs
);
See Also
IModelValidator Interface
IModelValidator Members
Eco.ModelValidation Namespace


IModelValidator.ValidateModel Method

IModelValidator.ValidateModel Method
IModelValidator Interface IModelValidator Members Eco.ModelValidation Namespace See Also
Collapse All

Suitable method to implement global validation on the model.

C#
void ValidateModel(
    IEcoTypeSystem model,
    ValidationArgs validationArgs
);
See Also
IModelValidator Interface
IModelValidator Members
Eco.ModelValidation Namespace


Eco.Persistence Namespace

Eco.Persistence Namespace
Classes
Collapse All

This is namespace Eco.Persistence.

Classes
Name | Description
PMapperDefConverter | Converter for PMapperDef.
SyncHandlerConverter | Converter for SyncHandler.


PMapperDefConverter Class

PMapperDefConverter Class
PMapperDefConverter Members Inheritance Hierarchy See Also
Collapse All

Converter for PMapperDef.

C#
public sealed class PMapperDefConverter : ExpandableObjectConverter;
Remarks

This class is used by the form designer and is not intended for direct use.

Inheritance Hierarchy
Eco.Persistence.PMapperDefConverter
File

PMapperDefConverter.cs

See Also
PMapperDefConverter Members
Inheritance Hierarchy


PMapperDefConverter Members

PMapperDefConverter Members
Public Methods
Collapse All

The following tables list the members exposed by PMapperDefConverter.

Public Methods
Name | Description
CanConvertTo | Returns true if destinationType is an InstanceDescriptor or returns the base result.
ConvertTo | This is ConvertTo, a member of class PMapperDefConverter.
PMapperDefConverter | This is PMapperDefConverter, a member of class PMapperDefConverter.


PMapperDefConverter.PMapperDefConverter Constructor

PMapperDefConverter.PMapperDefConverter Constructor
PMapperDefConverter Class PMapperDefConverter Members Eco.Persistence Namespace See Also
Collapse All
C#
public PMapperDefConverter();
Remarks

This is PMapperDefConverter, a member of class PMapperDefConverter.

See Also
PMapperDefConverter Class
PMapperDefConverter Members
Eco.Persistence Namespace


PMapperDefConverter Methods

PMapperDefConverter Methods
Public Methods
Collapse All

The methods of the PMapperDefConverter class are listed here.

Public Methods
Name | Description
CanConvertTo | Returns true if destinationType is an InstanceDescriptor or returns the base result.
ConvertTo | This is ConvertTo, a member of class PMapperDefConverter.


PMapperDefConverter.CanConvertTo Method

PMapperDefConverter.CanConvertTo Method
PMapperDefConverter Class PMapperDefConverter Members Eco.Persistence Namespace See Also
Collapse All

Returns true if destinationType is an InstanceDescriptor or returns the base result.

C#
public override bool CanConvertTo(
    ITypeDescriptorContext context,
    System.Type destinationType
);
See Also
PMapperDefConverter Class
PMapperDefConverter Members
Eco.Persistence Namespace


PMapperDefConverter.ConvertTo Method

PMapperDefConverter.ConvertTo Method
PMapperDefConverter Class PMapperDefConverter Members Eco.Persistence Namespace See Also
Collapse All
C#
public override object ConvertTo(
    ITypeDescriptorContext context,
    CultureInfo culture,
    object value,
    System.Type destinationType
);
Remarks

This is ConvertTo, a member of class PMapperDefConverter.

See Also
PMapperDefConverter Class
PMapperDefConverter Members
Eco.Persistence Namespace


SyncHandlerConverter Class

SyncHandlerConverter Class
SyncHandlerConverter Members Inheritance Hierarchy See Also
Collapse All

Converter for SyncHandler.

C#
public sealed class SyncHandlerConverter : TypeConverter;
Remarks

This class is used by the form designer and is not intended for direct use.

Inheritance Hierarchy
Eco.Persistence.SyncHandlerConverter
File

SyncHandlerConverter.cs

See Also
SyncHandlerConverter Members
Inheritance Hierarchy


SyncHandlerConverter Members

SyncHandlerConverter Members
Public Methods
Collapse All

The following tables list the members exposed by SyncHandlerConverter.

Public Methods
Name | Description
SyncHandlerConverter | This is SyncHandlerConverter, a member of class SyncHandlerConverter.


SyncHandlerConverter.SyncHandlerConverter Constructor

SyncHandlerConverter.SyncHandlerConverter Constructor
SyncHandlerConverter Class SyncHandlerConverter Members Eco.Persistence Namespace See Also
Collapse All
C#
public SyncHandlerConverter();
Remarks

This is SyncHandlerConverter, a member of class SyncHandlerConverter.

See Also
SyncHandlerConverter Class
SyncHandlerConverter Members
Eco.Persistence Namespace


Eco.Persistence.Design Namespace

Eco.Persistence.Design Namespace
Classes Interfaces
Collapse All

using Eco.Handles.Design;

Classes
Name | Description
AbstractBdpConfigurator | This class can be subclassed if you want to plug in your own configuration for PersistenceMapperBdp.
AbstractDbxConfigurator | This class can be subclassed if you want to plug in your own configuration for PersistenceMapperDbx.
AccessConfiguratorBdp | Configurator for AccessBdp.
AccessConfiguratorDbx | Configurator for AccessDbx.
AnsiConfigurator | Configurator for GenericANSISQL92.
BdpPersistenceMapperDesigner | This is class Eco.Persistence.Design.BdpPersistenceMapperDesigner.
BdpProvider | This is class Eco.Persistence.Design.BdpProvider.
BlackfishConfiguratorBdp | Configurator for BlackfishBdp.
BlackfishConfiguratorDbx | Configurator for BlackfishDbx.
BlackfishPersistenceMapperDesigner | This is class Eco.Persistence.Design.BlackfishPersistenceMapperDesigner.
BlackfishRemotePersistenceMapperDesigner | This is class Eco.Persistence.Design.BlackfishRemotePersistenceMapperDesigner.
ConnectionsCreatorHandler | This is class Eco.Persistence.Design.ConnectionsCreatorHandler.
DB2Configurator | Configurator for DB2.
DB2MBCSConfigurator | Configurator for DB2MBCS.
DBToolBase | Base class for persistence related tools.
DbxPersistenceMapperDesigner | This is class Eco.Persistence.Design.DbxPersistenceMapperDesigner.
DbxProvider | This is class Eco.Persistence.Design.DbxProvider.
DefaultORMappingBuilderDesigner | This is class Eco.Persistence.Design.DefaultORMappingBuilderDesigner.
DesignUtils | Helper class to set a property on an instance.
EcoBdpConfigurator | Abstract base class for configurators for all BDP supported backends.
EcoDbxConfigurator | Abstract base class for configurators for all Dbx supported backends.
EvolveDBTool | This tool encapsulates the evolving of a database schema with the preservation of data.
FirebirdConfiguratorFirebirdClient | This is class Eco.Persistence.Design.FirebirdConfiguratorFirebirdClient.
FirebirdPersistenceMapperDesigner | This is class Eco.Persistence.Design.FirebirdPersistenceMapperDesigner.
GenerateDBTool | This tool generates the default schema suitable to store the model.
GenerateDefaultMappingXmlTool | This tool saves the current OR mapping information to an xml-file
InformixConfigurator | Configurator for Informix.
Initialize | Helper class with only static to perform IDE registration tasks.
Interbase3Configurator | Configurator for InterbaseSqlDialect3.
Interbase3MBCSConfigurator | Configurator for InterbaseSqlDialect3MBCS.
KeyMapperNameConverter | KeyMapperNameConverter is the converter for the KeyMapperDefinition.Name property.
KeyMapperTypeNameConverter | KeyMapperTypeConverter is the converter for the KeyMapperDefinition.Mapper property.
ManualEditorManipulator | Invokes the connection editor for the TAdoDbxConnection.
MapperNameConverter | This base class supports a non-exclusive drop-down list in the OI.
MapperTypeEditor | Base class for the mappertype editors. A list of available selections are filled from the type's converter's GetStandardValues method. The list will contain name-type pairs. When a name is selected, the implementing assembly is added to the project's references list.
MapperTypeNameConverter | Baseclass for the mapper converters.
MapperTypeRegistry | This singleton class contains a list of mappers that will appear in the drop down list of the Mapper property of the PersistenceMapperDefinition.
MimerConfiguratorMimerClient | This is class Eco.Persistence.Design.MimerConfiguratorMimerClient.
MimerPersistenceHandleDesigner | This is class Eco.Persistence.Design.MimerPersistenceHandleDesigner.
MySql4Configurator | This is class Eco.Persistence.Design.MySql4Configurator.
MySql4ConfiguratorBdp | Configurator for MySql4Bdp.
MySql4ConfiguratorDbx | Configurator for MySql4Dbx.
MySql5Configurator | This is class Eco.Persistence.Design.MySql5Configurator.
MySql5ConfiguratorBdp | Configurator for MySql5Bdp.
MySql5ConfiguratorDbx | Configurator for MySql5Dbx.
MySqlPersistenceHandleDesigner | This is class Eco.Persistence.Design.MySqlPersistenceHandleDesigner.
NewXmlMappingFileNameEditor | Filename editor for files with extension xml.
OracleConfigurator | Configurator for Oracle.
OracleConfiguratorOracleClient | This is class Eco.Persistence.Design.OracleConfiguratorOracleClient.
OracleMBCSConfigurator | Configurator for OracleMBCS.
OraclePersistenceHandleDesigner | This is class Eco.Persistence.Design.OraclePersistenceHandleDesigner.
PersistenceHandleDesigner | Base class designer for the persistence handles.
PersistenceMapperDesignerXml | This is class Eco.Persistence.Design.PersistenceMapperDesignerXml.
PersistenceMapperInspector | Abstract baseclass to add task sensitive tool tips to PersistenceMapperDb subclasses.
PersistenceMapperNameConverter | PersistenceMapperNameConverter is the converter for the KeyMapperDefinition.Name property.
PersistenceMapperProviderDesigner | Designer for PersistenceMapperProvider.
PersistenceMapperProviderInspector | This class adds task sensitive tool tips to PersistenceMapperProvider.
PersistenceMapperProviderTypeNameTypeConverter | Type converter used by the MapperType of the PersistenceMapperSharer
PersistenceMapperTypeNameConverter | PersistenceMapperTypeConverter is the converter for the PersistenceMapperDefinition.MapperTypeName property.
PMapperBdpValidator | Validator to check that BdpConnection have relevant properties set.
PMapperBlackfishValidator | Validator to check that DatastoreConnection have relevant properties set.
PMapperCreatorHandlerPMP | This is class Eco.Persistence.Design.PMapperCreatorHandlerPMP.
PMapperDbxValidator | Validator to check that TAdoDbxConnection have relevant properties set.
PMapperFirebirdValidator | Validator to check that FirebirdConnection have relevant properties set.
PMapperMimerValidator | Validator to check that MimerConnection have relevant properties set.
PMapperOracleValidator | Validator to check that OracleConnection have relevant properties set.
PMapperSqlServerValidator | Validator to check that SqlConnection have relevant properties set.
PMapperValidator | Validator to check that pmappers have relevant properties set.
PMapperXmlValidator | Validator to check that XmlMapper have relevant properties set.
Registration | Singleton class used to perform design time initialization code.
SaveMappingInfoTool | This tool saves the mapping information to the database.
SQLServer7ConfiguratorBdp | Configurator for SqlServer7Bdp.
SQLServer7ConfiguratorBdpMBCS | Configurator for SqlServer7MBCSBdp.
SQLServer7ConfiguratorDbx | Configurator for SqlServer7Dbx.
SQLServer7ConfiguratorDbxMBCS | Configurator for SqlServer7MBCSDbx.
SQLServer7ConfiguratorSqlClient | This is class Eco.Persistence.Design.SQLServer7ConfiguratorSqlClient.
SQLServer7ConfiguratorSqlClientMBCS | This is class Eco.Persistence.Design.SQLServer7ConfiguratorSqlClientMBCS.
SQLServerConfiguratorBdp | Configurator for SqlServerBdp.
SQLServerConfiguratorBdpMBCS | Configurator for SqlServerMBCSBdp.
SQLServerConfiguratorDbx | Configurator for SqlServerDbx.
SQLServerConfiguratorDbxMBCS | Configurator for SqlServerMBCSDbx.
SQLServerConfiguratorSqlClient | This is class Eco.Persistence.Design.SQLServerConfiguratorSqlClient.
SQLServerConfiguratorSqlClientMBCS | This is class Eco.Persistence.Design.SQLServerConfiguratorSqlClientMBCS.
SqlServerPersistenceHandleDesigner | This is class Eco.Persistence.Design.SqlServerPersistenceHandleDesigner.
SybaseConfigurator | Configurator for SybaseDbx.
ValidateModelTool | Tool that implements model validation.
Top
Interfaces
Name | Description
IMapperVerbConfigurator | This interfaced is used to add verbs to the PersistenceHandleDesigner.


AbstractBdpConfigurator Class

AbstractBdpConfigurator Class
AbstractBdpConfigurator Members Inheritance Hierarchy See Also
Collapse All

This class can be subclassed if you want to plug in your own configuration for PersistenceMapperBdp.

C#
public abstract class AbstractBdpConfigurator : IMapperVerbConfigurator;
Inheritance Hierarchy
Eco.Persistence.Design.IMapperVerbConfigurator
    Eco.Persistence.Design.AbstractBdpConfigurator
        Eco.Persistence.Design.EcoBdpConfigurator
File

MapperConfiguratorsBdp.cs

See Also
AbstractBdpConfigurator Members
Inheritance Hierarchy


AbstractBdpConfigurator Members

AbstractBdpConfigurator Members
Protected Methods Public Methods
Collapse All

The following tables list the members exposed by AbstractBdpConfigurator.

Protected Methods
Name | Description
FilterData | This method should return the name of the bdp provider (such as Interbase, MSSQL or Oracle). There can be multiple configurators for the same provider.
Top
Public Methods
Name | Description
Caption | Override this method to provide a caption for your configurator.
ConfigureBackend | Override this method to perform the actual configuration. Modify the settings of sqlDatabaseConfig to suite your needs
IsVerbFor | This method determines if the instance is suited for configuring the submitted component.
PersistenceMapperType | This method will return typeof(PersistenceMapperBdp)


AbstractBdpConfigurator Methods

AbstractBdpConfigurator Methods
Protected Methods Public Methods
Collapse All

The methods of the AbstractBdpConfigurator class are listed here.

Protected Methods
Name | Description
FilterData | This method should return the name of the bdp provider (such as Interbase, MSSQL or Oracle). There can be multiple configurators for the same provider.
Top
Public Methods
Name | Description
Caption | Override this method to provide a caption for your configurator.
ConfigureBackend | Override this method to perform the actual configuration. Modify the settings of sqlDatabaseConfig to suite your needs
IsVerbFor | This method determines if the instance is suited for configuring the submitted component.
PersistenceMapperType | This method will return typeof(PersistenceMapperBdp)


AbstractBdpConfigurator.Caption Method

AbstractBdpConfigurator.Caption Method
AbstractBdpConfigurator Class AbstractBdpConfigurator Members Eco.Persistence.Design Namespace See Also
Collapse All

Override this method to provide a caption for your configurator.

C#
public abstract string Caption();
Remarks

IMapperVerbConfigurator

See Also
AbstractBdpConfigurator Class
AbstractBdpConfigurator Members
Eco.Persistence.Design Namespace


AbstractBdpConfigurator.ConfigureBackend Method

AbstractBdpConfigurator.ConfigureBackend Method
AbstractBdpConfigurator Class AbstractBdpConfigurator Members Eco.Persistence.Design Namespace See Also
Collapse All

Override this method to perform the actual configuration. Modify the settings of sqlDatabaseConfig to suite your needs

C#
public abstract void ConfigureBackend(
    SqlDatabaseConfig sqlDatabaseConfig
);
See Also
AbstractBdpConfigurator Class
AbstractBdpConfigurator Members
Eco.Persistence.Design Namespace


AbstractBdpConfigurator.FilterData Method

AbstractBdpConfigurator.FilterData Method
AbstractBdpConfigurator Class AbstractBdpConfigurator Members Eco.Persistence.Design Namespace See Also
Collapse All

This method should return the name of the bdp provider (such as Interbase, MSSQL or Oracle). There can be multiple configurators for the same provider.

C#
protected abstract string FilterData();
Remarks

Own members

See Also
AbstractBdpConfigurator Class
AbstractBdpConfigurator Members
Eco.Persistence.Design Namespace


AbstractBdpConfigurator.IsVerbFor Method

AbstractBdpConfigurator.IsVerbFor Method
AbstractBdpConfigurator Class AbstractBdpConfigurator Members Eco.Persistence.Design Namespace See Also
Collapse All

This method determines if the instance is suited for configuring the submitted component.

C#
public bool IsVerbFor(
    Component component
);
Parameters
Parameters | Description
component | The component to examine if the configurator can configure.
Returns

This method returns true if the instance can be used to configure component.

Remarks

The rules to determine if the instance can configure component are quite permitting. If the component is not a PersistenceMapperBdp or if there's no connection or if the connection's connectionstring is empty it's supported. After that, the connectionstring's provider is extracted. If that is an empty string, true is returned. The only way to return false is if the provider does not match FilterData - assuming that method does not return an empry string or null.

See Also
AbstractBdpConfigurator Class
AbstractBdpConfigurator Members
Eco.Persistence.Design Namespace


AbstractBdpConfigurator.PersistenceMapperType Method

AbstractBdpConfigurator.PersistenceMapperType Method
AbstractBdpConfigurator Class AbstractBdpConfigurator Members Eco.Persistence.Design Namespace See Also
Collapse All

This method will return typeof(PersistenceMapperBdp)

C#
public object PersistenceMapperType();
See Also
AbstractBdpConfigurator Class
AbstractBdpConfigurator Members
Eco.Persistence.Design Namespace


AbstractDbxConfigurator Class

AbstractDbxConfigurator Class
AbstractDbxConfigurator Members Inheritance Hierarchy See Also
Collapse All

This class can be subclassed if you want to plug in your own configuration for PersistenceMapperDbx.

C#
public abstract class AbstractDbxConfigurator : IMapperVerbConfigurator;
Inheritance Hierarchy
Eco.Persistence.Design.IMapperVerbConfigurator
    Eco.Persistence.Design.AbstractDbxConfigurator
        Eco.Persistence.Design.EcoDbxConfigurator
File

MapperConfiguratorsDbx.cs

See Also
AbstractDbxConfigurator Members
Inheritance Hierarchy


AbstractDbxConfigurator Members

AbstractDbxConfigurator Members
Protected Methods Public Methods
Collapse All

The following tables list the members exposed by AbstractDbxConfigurator.

Protected Methods
Name | Description
FilterData | This method should return the name of the Dbx provider (such as Interbase, MSSQL or Oracle). There can be multiple configurators for the same provider.
Top
Public Methods
Name | Description
Caption | Override this method to provide a caption for your configurator.
ConfigureBackend | Override this method to perform the actual configuration. Modify the settings of sqlDatabaseConfig to suite your needs
IsVerbFor | This method determines if the instance is suited for configuring the submitted component.
PersistenceMapperType | This method will return typeof(PersistenceMapperDbx)


AbstractDbxConfigurator Methods

AbstractDbxConfigurator Methods
Protected Methods Public Methods
Collapse All

The methods of the AbstractDbxConfigurator class are listed here.

Protected Methods
Name | Description
FilterData | This method should return the name of the Dbx provider (such as Interbase, MSSQL or Oracle). There can be multiple configurators for the same provider.
Top
Public Methods
Name | Description
Caption | Override this method to provide a caption for your configurator.
ConfigureBackend | Override this method to perform the actual configuration. Modify the settings of sqlDatabaseConfig to suite your needs
IsVerbFor | This method determines if the instance is suited for configuring the submitted component.
PersistenceMapperType | This method will return typeof(PersistenceMapperDbx)


AbstractDbxConfigurator.Caption Method

AbstractDbxConfigurator.Caption Method
AbstractDbxConfigurator Class AbstractDbxConfigurator Members Eco.Persistence.Design Namespace See Also
Collapse All

Override this method to provide a caption for your configurator.

C#
public abstract string Caption();
Remarks

IMapperVerbConfigurator

See Also
AbstractDbxConfigurator Class
AbstractDbxConfigurator Members
Eco.Persistence.Design Namespace


AbstractDbxConfigurator.ConfigureBackend Method

AbstractDbxConfigurator.ConfigureBackend Method
AbstractDbxConfigurator Class AbstractDbxConfigurator Members Eco.Persistence.Design Namespace See Also
Collapse All

Override this method to perform the actual configuration. Modify the settings of sqlDatabaseConfig to suite your needs

C#
public abstract void ConfigureBackend(
    SqlDatabaseConfig sqlDatabaseConfig
);
See Also
AbstractDbxConfigurator Class
AbstractDbxConfigurator Members
Eco.Persistence.Design Namespace


AbstractDbxConfigurator.FilterData Method

AbstractDbxConfigurator.FilterData Method
AbstractDbxConfigurator Class AbstractDbxConfigurator Members Eco.Persistence.Design Namespace See Also
Collapse All

This method should return the name of the Dbx provider (such as Interbase, MSSQL or Oracle). There can be multiple configurators for the same provider.

C#
protected abstract string FilterData();
Remarks

Own members

See Also
AbstractDbxConfigurator Class
AbstractDbxConfigurator Members
Eco.Persistence.Design Namespace


AbstractDbxConfigurator.IsVerbFor Method

AbstractDbxConfigurator.IsVerbFor Method
AbstractDbxConfigurator Class AbstractDbxConfigurator Members Eco.Persistence.Design Namespace See Also
Collapse All

This method determines if the instance is suited for configuring the submitted component.

C#
public bool IsVerbFor(
    Component component
);
Parameters
Parameters | Description
component | The component to examine if the configurator can configure.
Returns

This method returns true if the instance can be used to configure component.

Remarks

The rules to determine if the instance can configure component are quite permitting. If the component is not a PersistenceMapperDbx or if there's no connection or if the connection's connectionstring is empty it's supported. After that, the connectionstring's provider is extracted. If that is an empty string, true is returned. The only way to return false is if the provider does not match FilterData - assuming that method does not return an empry string or null.

See Also
AbstractDbxConfigurator Class
AbstractDbxConfigurator Members
Eco.Persistence.Design Namespace


AbstractDbxConfigurator.PersistenceMapperType Method

AbstractDbxConfigurator.PersistenceMapperType Method
AbstractDbxConfigurator Class AbstractDbxConfigurator Members Eco.Persistence.Design Namespace See Also
Collapse All

This method will return typeof(PersistenceMapperDbx)

C#
public object PersistenceMapperType();
See Also
AbstractDbxConfigurator Class
AbstractDbxConfigurator Members
Eco.Persistence.Design Namespace


AccessConfiguratorBdp Class

AccessConfiguratorBdp Class
AccessConfiguratorBdp Members Inheritance Hierarchy See Also
Collapse All

Configurator for AccessBdp.

C#
internal class AccessConfiguratorBdp : EcoBdpConfigurator;
Remarks

This class configures the persistence mapper using the settings for DataBaseEngine.AccessBdp.

Inheritance Hierarchy
Eco.Persistence.Design.IMapperVerbConfigurator
    Eco.Persistence.Design.AbstractBdpConfigurator
        Eco.Persistence.Design.EcoBdpConfigurator
            Eco.Persistence.Design.AccessConfiguratorBdp
File

MapperConfiguratorsBdp.cs

See Also
AccessConfiguratorBdp Members
Inheritance Hierarchy


AccessConfiguratorBdp Members

AccessConfiguratorBdp Members
Protected Methods Public Methods
Collapse All

The following tables list the members exposed by AccessConfiguratorBdp.

Protected Methods
Name | Description
FilterData | This method should return the name of the bdp provider (such as Interbase, MSSQL or Oracle). There can be multiple configurators for the same provider.
Top
Public Methods
Name | Description
Caption | The caption for this instance when used as a designer verb.
ConfigureBackend | Override this method to perform the actual configuration. Modify the settings of sqlDatabaseConfig to suite your needs
ConfigureBackend | Initializes sqlDatabaseConfig using the settings determined by SupportedDataBaseEngine.
ConfigureBackend | Configure SqlDatabaseConfig approprately. This method is called from inside a designer transaction
IsVerbFor | This method determines if the instance is suited for configuring the submitted component.
IsVerbFor | The configurator must decide if it can act in current circumstances
PersistenceMapperType | This method will return typeof(PersistenceMapperBdp)
PersistenceMapperType | Return the type of the PersistenceMapper this configurator deals with
SupportedDataBaseEngine | Override this method to provide the engine enum handled by the configurator.


AccessConfiguratorBdp Methods

AccessConfiguratorBdp Methods
Protected Methods Public Methods
Collapse All

The methods of the AccessConfiguratorBdp class are listed here.

Protected Methods
Name | Description
FilterData | This method should return the name of the bdp provider (such as Interbase, MSSQL or Oracle). There can be multiple configurators for the same provider.
Top
Public Methods
Name | Description
Caption | The caption for this instance when used as a designer verb.
SupportedDataBaseEngine | Override this method to provide the engine enum handled by the configurator.


AccessConfiguratorBdp.Caption Method

AccessConfiguratorBdp.Caption Method
AccessConfiguratorBdp Class AccessConfiguratorBdp Members Eco.Persistence.Design Namespace See Also
Collapse All

The caption for this instance when used as a designer verb.

C#
public override string Caption();
See Also
AccessConfiguratorBdp Class
AccessConfiguratorBdp Members
Eco.Persistence.Design Namespace


AccessConfiguratorBdp.FilterData Method

AccessConfiguratorBdp.FilterData Method
AccessConfiguratorBdp Class AccessConfiguratorBdp Members Eco.Persistence.Design Namespace See Also
Collapse All

This method should return the name of the bdp provider (such as Interbase, MSSQL or Oracle). There can be multiple configurators for the same provider.

C#
protected override string FilterData();
Remarks

Own members

See Also
AccessConfiguratorBdp Class
AccessConfiguratorBdp Members
Eco.Persistence.Design Namespace


AccessConfiguratorBdp.SupportedDataBaseEngine Method

AccessConfiguratorBdp.SupportedDataBaseEngine Method
AccessConfiguratorBdp Class AccessConfiguratorBdp Members Eco.Persistence.Design Namespace See Also
Collapse All

Override this method to provide the engine enum handled by the configurator.

C#
public override DataBaseEngine SupportedDataBaseEngine();
See Also
AccessConfiguratorBdp Class
AccessConfiguratorBdp Members
Eco.Persistence.Design Namespace


AccessConfiguratorDbx Class

AccessConfiguratorDbx Class
AccessConfiguratorDbx Members Inheritance Hierarchy See Also
Collapse All

Configurator for AccessDbx.

C#
internal class AccessConfiguratorDbx : EcoDbxConfigurator;
Remarks

This class configures the persistence mapper using the settings for DataBaseEngine.AccessDbx.

Inheritance Hierarchy
Eco.Persistence.Design.IMapperVerbConfigurator
    Eco.Persistence.Design.AbstractDbxConfigurator
        Eco.Persistence.Design.EcoDbxConfigurator
            Eco.Persistence.Design.AccessConfiguratorDbx
File

MapperConfiguratorsDbx.cs

See Also
AccessConfiguratorDbx Members
Inheritance Hierarchy


AccessConfiguratorDbx Members

AccessConfiguratorDbx Members
Protected Methods Public Methods
Collapse All

The following tables list the members exposed by AccessConfiguratorDbx.

Protected Methods
Name | Description
FilterData | This method should return the name of the Dbx provider (such as Interbase, MSSQL or Oracle). There can be multiple configurators for the same provider.
Top
Public Methods
Name | Description
Caption | The caption for this instance when used as a designer verb.
ConfigureBackend | Override this method to perform the actual configuration. Modify the settings of sqlDatabaseConfig to suite your needs
ConfigureBackend | Initializes sqlDatabaseConfig using the settings determined by SupportedDataBaseEngine.
ConfigureBackend | Configure SqlDatabaseConfig approprately. This method is called from inside a designer transaction
IsVerbFor | This method determines if the instance is suited for configuring the submitted component.
IsVerbFor | The configurator must decide if it can act in current circumstances
PersistenceMapperType | This method will return typeof(PersistenceMapperDbx)
PersistenceMapperType | Return the type of the PersistenceMapper this configurator deals with
SupportedDataBaseEngine | Override this method to provide the engine enum handled by the configurator.


AccessConfiguratorDbx Methods

AccessConfiguratorDbx Methods
Protected Methods Public Methods
Collapse All

The methods of the AccessConfiguratorDbx class are listed here.

Protected Methods
Name | Description
FilterData | This method should return the name of the Dbx provider (such as Interbase, MSSQL or Oracle). There can be multiple configurators for the same provider.
Top
Public Methods
Name | Description
Caption | The caption for this instance when used as a designer verb.
SupportedDataBaseEngine | Override this method to provide the engine enum handled by the configurator.


AccessConfiguratorDbx.Caption Method

AccessConfiguratorDbx.Caption Method
AccessConfiguratorDbx Class AccessConfiguratorDbx Members Eco.Persistence.Design Namespace See Also
Collapse All

The caption for this instance when used as a designer verb.

C#
public override string Caption();
See Also
AccessConfiguratorDbx Class
AccessConfiguratorDbx Members
Eco.Persistence.Design Namespace


AccessConfiguratorDbx.FilterData Method

AccessConfiguratorDbx.FilterData Method
AccessConfiguratorDbx Class AccessConfiguratorDbx Members Eco.Persistence.Design Namespace See Also
Collapse All

This method should return the name of the Dbx provider (such as Interbase, MSSQL or Oracle). There can be multiple configurators for the same provider.

C#
protected override string FilterData();
Remarks

Own members

See Also
AccessConfiguratorDbx Class
AccessConfiguratorDbx Members
Eco.Persistence.Design Namespace


AccessConfiguratorDbx.SupportedDataBaseEngine Method

AccessConfiguratorDbx.SupportedDataBaseEngine Method
AccessConfiguratorDbx Class AccessConfiguratorDbx Members Eco.Persistence.Design Namespace See Also
Collapse All

Override this method to provide the engine enum handled by the configurator.

C#
public override DataBaseEngine SupportedDataBaseEngine();
See Also
AccessConfiguratorDbx Class
AccessConfiguratorDbx Members
Eco.Persistence.Design Namespace


AnsiConfigurator Class

AnsiConfigurator Class
AnsiConfigurator Members Inheritance Hierarchy See Also
Collapse All

Configurator for GenericANSISQL92.

C#
internal class AnsiConfigurator : EcoDbxConfigurator;
Remarks

This class configures the persistence mapper using the settings for DataBaseEngine.GenericANSISQL92.

Inheritance Hierarchy
Eco.Persistence.Design.IMapperVerbConfigurator
    Eco.Persistence.Design.AbstractDbxConfigurator
        Eco.Persistence.Design.EcoDbxConfigurator
            Eco.Persistence.Design.AnsiConfigurator
File

MapperConfiguratorsDbx.cs

See Also
AnsiConfigurator Members
Inheritance Hierarchy


AnsiConfigurator Members

AnsiConfigurator Members
Protected Methods Public Methods
Collapse All

The following tables list the members exposed by AnsiConfigurator.

Protected Methods
Name | Description
FilterData | This method should return the name of the Dbx provider (such as Interbase, MSSQL or Oracle). There can be multiple configurators for the same provider.
Top
Public Methods
Name | Description
Caption | The caption for this instance when used as a designer verb.
ConfigureBackend | Override this method to perform the actual configuration. Modify the settings of sqlDatabaseConfig to suite your needs
ConfigureBackend | Initializes sqlDatabaseConfig using the settings determined by SupportedDataBaseEngine.
ConfigureBackend | Configure SqlDatabaseConfig approprately. This method is called from inside a designer transaction
IsVerbFor | This method determines if the instance is suited for configuring the submitted component.
IsVerbFor | The configurator must decide if it can act in current circumstances
PersistenceMapperType | This method will return typeof(PersistenceMapperDbx)
PersistenceMapperType | Return the type of the PersistenceMapper this configurator deals with
SupportedDataBaseEngine | Override this method to provide the engine enum handled by the configurator.


AnsiConfigurator Methods

AnsiConfigurator Methods
Protected Methods Public Methods
Collapse All

The methods of the AnsiConfigurator class are listed here.

Protected Methods
Name | Description
FilterData | This method should return the name of the Dbx provider (such as Interbase, MSSQL or Oracle). There can be multiple configurators for the same provider.
Top
Public Methods
Name | Description
Caption | The caption for this instance when used as a designer verb.
SupportedDataBaseEngine | Override this method to provide the engine enum handled by the configurator.


AnsiConfigurator.Caption Method

AnsiConfigurator.Caption Method
AnsiConfigurator Class AnsiConfigurator Members Eco.Persistence.Design Namespace See Also
Collapse All

The caption for this instance when used as a designer verb.

C#
public override string Caption();
See Also
AnsiConfigurator Class
AnsiConfigurator Members
Eco.Persistence.Design Namespace


AnsiConfigurator.FilterData Method

AnsiConfigurator.FilterData Method
AnsiConfigurator Class AnsiConfigurator Members Eco.Persistence.Design Namespace See Also
Collapse All

This method should return the name of the Dbx provider (such as Interbase, MSSQL or Oracle). There can be multiple configurators for the same provider.

C#
protected override string FilterData();
Remarks

Own members

See Also
AnsiConfigurator Class
AnsiConfigurator Members
Eco.Persistence.Design Namespace


AnsiConfigurator.SupportedDataBaseEngine Method

AnsiConfigurator.SupportedDataBaseEngine Method
AnsiConfigurator Class AnsiConfigurator Members Eco.Persistence.Design Namespace See Also
Collapse All

Override this method to provide the engine enum handled by the configurator.

C#
public override DataBaseEngine SupportedDataBaseEngine();
See Also
AnsiConfigurator Class
AnsiConfigurator Members
Eco.Persistence.Design Namespace


BdpPersistenceMapperDesigner Class

BdpPersistenceMapperDesigner Class
Inheritance Hierarchy See Also
Collapse All
C#
public class BdpPersistenceMapperDesigner : PersistenceHandleDesigner;
Remarks

This is class Eco.Persistence.Design.BdpPersistenceMapperDesigner.

Inheritance Hierarchy
Eco.Persistence.Design.PersistenceHandleDesigner
    Eco.Persistence.Design.BdpPersistenceMapperDesigner
File

PersistenceMapperDesignerBdp.cs

See Also
Inheritance Hierarchy


BdpProvider Class

BdpProvider Class
Inheritance Hierarchy See Also
Collapse All
C#
internal sealed class BdpProvider;
Remarks

This is class Eco.Persistence.Design.BdpProvider.

Inheritance Hierarchy
Eco.Persistence.Design.BdpProvider
File

MapperConfiguratorsBdp.cs

See Also
Inheritance Hierarchy


BlackfishConfiguratorBdp Class

BlackfishConfiguratorBdp Class
BlackfishConfiguratorBdp Members Inheritance Hierarchy See Also
Collapse All

Configurator for BlackfishBdp.

C#
internal class BlackfishConfiguratorBdp : EcoBdpConfigurator;
Remarks

This class configures the persistence mapper using the settings for DataBaseEngine.BlackfishBdp.

Inheritance Hierarchy
Eco.Persistence.Design.IMapperVerbConfigurator
    Eco.Persistence.Design.AbstractBdpConfigurator
        Eco.Persistence.Design.EcoBdpConfigurator
            Eco.Persistence.Design.BlackfishConfiguratorBdp
File

MapperConfiguratorsBdp.cs

See Also
BlackfishConfiguratorBdp Members
Inheritance Hierarchy


BlackfishConfiguratorBdp Members

BlackfishConfiguratorBdp Members
Protected Methods Public Methods
Collapse All

The following tables list the members exposed by BlackfishConfiguratorBdp.

Protected Methods
Name | Description
FilterData | This method should return the name of the bdp provider (such as Interbase, MSSQL or Oracle). There can be multiple configurators for the same provider.
Top
Public Methods
Name | Description
Caption | The caption for this instance when used as a designer verb.
ConfigureBackend | Override this method to perform the actual configuration. Modify the settings of sqlDatabaseConfig to suite your needs
ConfigureBackend | Initializes sqlDatabaseConfig using the settings determined by SupportedDataBaseEngine.
ConfigureBackend | Configure SqlDatabaseConfig approprately. This method is called from inside a designer transaction
IsVerbFor | This method determines if the instance is suited for configuring the submitted component.
IsVerbFor | The configurator must decide if it can act in current circumstances
PersistenceMapperType | This method will return typeof(PersistenceMapperBdp)
PersistenceMapperType | Return the type of the PersistenceMapper this configurator deals with
SupportedDataBaseEngine | Override this method to provide the engine enum handled by the configurator.


BlackfishConfiguratorBdp Methods

BlackfishConfiguratorBdp Methods
Protected Methods Public Methods
Collapse All

The methods of the BlackfishConfiguratorBdp class are listed here.

Protected Methods
Name | Description
FilterData | This method should return the name of the bdp provider (such as Interbase, MSSQL or Oracle). There can be multiple configurators for the same provider.
Top
Public Methods
Name | Description
Caption | The caption for this instance when used as a designer verb.
SupportedDataBaseEngine | Override this method to provide the engine enum handled by the configurator.


BlackfishConfiguratorBdp.Caption Method

BlackfishConfiguratorBdp.Caption Method
BlackfishConfiguratorBdp Class BlackfishConfiguratorBdp Members Eco.Persistence.Design Namespace See Also
Collapse All

The caption for this instance when used as a designer verb.

C#
public override string Caption();
See Also
BlackfishConfiguratorBdp Class
BlackfishConfiguratorBdp Members
Eco.Persistence.Design Namespace


BlackfishConfiguratorBdp.FilterData Method

BlackfishConfiguratorBdp.FilterData Method
BlackfishConfiguratorBdp Class BlackfishConfiguratorBdp Members Eco.Persistence.Design Namespace See Also
Collapse All

This method should return the name of the bdp provider (such as Interbase, MSSQL or Oracle). There can be multiple configurators for the same provider.

C#
protected override string FilterData();
Remarks

Own members

See Also
BlackfishConfiguratorBdp Class
BlackfishConfiguratorBdp Members
Eco.Persistence.Design Namespace


BlackfishConfiguratorBdp.SupportedDataBaseEngine Method

BlackfishConfiguratorBdp.SupportedDataBaseEngine Method
BlackfishConfiguratorBdp Class BlackfishConfiguratorBdp Members Eco.Persistence.Design Namespace See Also
Collapse All

Override this method to provide the engine enum handled by the configurator.

C#
public override DataBaseEngine SupportedDataBaseEngine();
See Also
BlackfishConfiguratorBdp Class
BlackfishConfiguratorBdp Members
Eco.Persistence.Design Namespace


BlackfishConfiguratorDbx Class

BlackfishConfiguratorDbx Class
BlackfishConfiguratorDbx Members Inheritance Hierarchy See Also
Collapse All

Configurator for BlackfishDbx.

C#
internal class BlackfishConfiguratorDbx : EcoDbxConfigurator;
Remarks

This class configures the persistence mapper using the settings for DataBaseEngine.BlackfishDbx.

Inheritance Hierarchy
Eco.Persistence.Design.IMapperVerbConfigurator
    Eco.Persistence.Design.AbstractDbxConfigurator
        Eco.Persistence.Design.EcoDbxConfigurator
            Eco.Persistence.Design.BlackfishConfiguratorDbx
File

MapperConfiguratorsDbx.cs

See Also
BlackfishConfiguratorDbx Members
Inheritance Hierarchy


BlackfishConfiguratorDbx Members

BlackfishConfiguratorDbx Members
Protected Methods Public Methods
Collapse All

The following tables list the members exposed by BlackfishConfiguratorDbx.

Protected Methods
Name | Description
FilterData | This method should return the name of the Dbx provider (such as Interbase, MSSQL or Oracle). There can be multiple configurators for the same provider.
Top
Public Methods
Name | Description
Caption | The caption for this instance when used as a designer verb.
ConfigureBackend | Override this method to perform the actual configuration. Modify the settings of sqlDatabaseConfig to suite your needs
ConfigureBackend | Initializes sqlDatabaseConfig using the settings determined by SupportedDataBaseEngine.
ConfigureBackend | Configure SqlDatabaseConfig approprately. This method is called from inside a designer transaction
IsVerbFor | This method determines if the instance is suited for configuring the submitted component.
IsVerbFor | The configurator must decide if it can act in current circumstances
PersistenceMapperType | This method will return typeof(PersistenceMapperDbx)
PersistenceMapperType | Return the type of the PersistenceMapper this configurator deals with
SupportedDataBaseEngine | Override this method to provide the engine enum handled by the configurator.


BlackfishConfiguratorDbx Methods

BlackfishConfiguratorDbx Methods
Protected Methods Public Methods
Collapse All

The methods of the BlackfishConfiguratorDbx class are listed here.

Protected Methods
Name | Description
FilterData | This method should return the name of the Dbx provider (such as Interbase, MSSQL or Oracle). There can be multiple configurators for the same provider.
Top
Public Methods
Name | Description
Caption | The caption for this instance when used as a designer verb.
SupportedDataBaseEngine | Override this method to provide the engine enum handled by the configurator.


BlackfishConfiguratorDbx.Caption Method

BlackfishConfiguratorDbx.Caption Method
BlackfishConfiguratorDbx Class BlackfishConfiguratorDbx Members Eco.Persistence.Design Namespace See Also
Collapse All

The caption for this instance when used as a designer verb.

C#
public override string Caption();
See Also
BlackfishConfiguratorDbx Class
BlackfishConfiguratorDbx Members
Eco.Persistence.Design Namespace


BlackfishConfiguratorDbx.FilterData Method

BlackfishConfiguratorDbx.FilterData Method
BlackfishConfiguratorDbx Class BlackfishConfiguratorDbx Members Eco.Persistence.Design Namespace See Also
Collapse All

This method should return the name of the Dbx provider (such as Interbase, MSSQL or Oracle). There can be multiple configurators for the same provider.

C#
protected override string FilterData();
Remarks

Own members

See Also
BlackfishConfiguratorDbx Class
BlackfishConfiguratorDbx Members
Eco.Persistence.Design Namespace


BlackfishConfiguratorDbx.SupportedDataBaseEngine Method

BlackfishConfiguratorDbx.SupportedDataBaseEngine Method
BlackfishConfiguratorDbx Class BlackfishConfiguratorDbx Members Eco.Persistence.Design Namespace See Also
Collapse All

Override this method to provide the engine enum handled by the configurator.

C#
public override DataBaseEngine SupportedDataBaseEngine();
See Also
BlackfishConfiguratorDbx Class
BlackfishConfiguratorDbx Members
Eco.Persistence.Design Namespace


BlackfishPersistenceMapperDesigner Class

BlackfishPersistenceMapperDesigner Class
Inheritance Hierarchy See Also
Collapse All
C#
public class BlackfishPersistenceMapperDesigner : PersistenceHandleDesigner;
Remarks

This is class Eco.Persistence.Design.BlackfishPersistenceMapperDesigner.

Inheritance Hierarchy
Eco.Persistence.Design.PersistenceHandleDesigner
    Eco.Persistence.Design.BlackfishPersistenceMapperDesigner
File

PersistenceMapperDesignerBlackfish.cs

See Also
Inheritance Hierarchy


BlackfishRemotePersistenceMapperDesigner Class

BlackfishRemotePersistenceMapperDesigner Class
Inheritance Hierarchy See Also
Collapse All
C#
public class BlackfishRemotePersistenceMapperDesigner : PersistenceHandleDesigner;
Remarks

This is class Eco.Persistence.Design.BlackfishRemotePersistenceMapperDesigner.

Inheritance Hierarchy
Eco.Persistence.Design.PersistenceHandleDesigner
    Eco.Persistence.Design.BlackfishRemotePersistenceMapperDesigner
File

PersistenceMapperDesignerBlackfishRemote.cs

See Also
Inheritance Hierarchy


ConnectionsCreatorHandler Class

ConnectionsCreatorHandler Class
ConnectionsCreatorHandler Members Inheritance Hierarchy See Also
Collapse All
C#
public class ConnectionsCreatorHandler : CreatorHandler;
Remarks

This is class Eco.Persistence.Design.ConnectionsCreatorHandler.

Inheritance Hierarchy
Eco.Persistence.Design.ConnectionsCreatorHandler
File

ConnectionSelectors.cs

See Also
ConnectionsCreatorHandler Members
Inheritance Hierarchy


ConnectionsCreatorHandler Members

ConnectionsCreatorHandler Members
Public Methods Protected Properties
Collapse All

The following tables list the members exposed by ConnectionsCreatorHandler.

Public Methods
Name | Description
ConnectionsCreatorHandler | This is ConnectionsCreatorHandler, a member of class ConnectionsCreatorHandler.
IDERegister | This is IDERegister, a member of class ConnectionsCreatorHandler.
RefreshCreatorTree | Adds creators for Connection components.
Top
Protected Properties
Name | Description
Filename | do not localize;
TopNodename | do not localize;


ConnectionsCreatorHandler.ConnectionsCreatorHandler Constructor

ConnectionsCreatorHandler.ConnectionsCreatorHandler Constructor
ConnectionsCreatorHandler Class ConnectionsCreatorHandler Members Eco.Persistence.Design Namespace See Also
Collapse All
C#
public ConnectionsCreatorHandler();
Remarks

This is ConnectionsCreatorHandler, a member of class ConnectionsCreatorHandler.

See Also
ConnectionsCreatorHandler Class
ConnectionsCreatorHandler Members
Eco.Persistence.Design Namespace


ConnectionsCreatorHandler Methods

ConnectionsCreatorHandler Methods
Public Methods
Collapse All

The methods of the ConnectionsCreatorHandler class are listed here.

Public Methods
Name | Description
IDERegister | This is IDERegister, a member of class ConnectionsCreatorHandler.
RefreshCreatorTree | Adds creators for Connection components.


ConnectionsCreatorHandler.IDERegister Method

ConnectionsCreatorHandler.IDERegister Method
ConnectionsCreatorHandler Class ConnectionsCreatorHandler Members Eco.Persistence.Design Namespace See Also
Collapse All
C#
public static void IDERegister();
Remarks

This is IDERegister, a member of class ConnectionsCreatorHandler.

See Also
ConnectionsCreatorHandler Class
ConnectionsCreatorHandler Members
Eco.Persistence.Design Namespace


ConnectionsCreatorHandler.RefreshCreatorTree Method

ConnectionsCreatorHandler.RefreshCreatorTree Method
ConnectionsCreatorHandler Class ConnectionsCreatorHandler Members Eco.Persistence.Design Namespace See Also
Collapse All

Adds creators for Connection components.

C#
public override void RefreshCreatorTree(
    DesignerData designerData
);
Remarks

InvokingComponent is a persistence mapper. Nodes are created for the matching connection component. Configuration node is "Connections".

See Also
ConnectionsCreatorHandler Class
ConnectionsCreatorHandler Members
Eco.Persistence.Design Namespace


ConnectionsCreatorHandler Properties

ConnectionsCreatorHandler Properties
Protected Properties
Collapse All

The properties of the ConnectionsCreatorHandler class are listed here.

Protected Properties
Name | Description
Filename | do not localize;
TopNodename | do not localize;


ConnectionsCreatorHandler.Filename Property

ConnectionsCreatorHandler.Filename Property
ConnectionsCreatorHandler Class ConnectionsCreatorHandler Members Eco.Persistence.Design Namespace See Also
Collapse All
C#
protected override string Filename;
Remarks

do not localize;

See Also
ConnectionsCreatorHandler Class
ConnectionsCreatorHandler Members
Eco.Persistence.Design Namespace


ConnectionsCreatorHandler.TopNodename Property

ConnectionsCreatorHandler.TopNodename Property
ConnectionsCreatorHandler Class ConnectionsCreatorHandler Members Eco.Persistence.Design Namespace See Also
Collapse All
C#
protected override string TopNodename;
Remarks

do not localize;

See Also
ConnectionsCreatorHandler Class
ConnectionsCreatorHandler Members
Eco.Persistence.Design Namespace


DB2Configurator Class

DB2Configurator Class
DB2Configurator Members Inheritance Hierarchy See Also
Collapse All

Configurator for DB2.

C#
internal class DB2Configurator : EcoDbxConfigurator;
Remarks

This class configures the persistence mapper using the settings for DataBaseEngine.DB2.

Inheritance Hierarchy
Eco.Persistence.Design.IMapperVerbConfigurator
    Eco.Persistence.Design.AbstractDbxConfigurator
        Eco.Persistence.Design.EcoDbxConfigurator
            Eco.Persistence.Design.DB2Configurator
File

MapperConfiguratorsDbx.cs

See Also
DB2Configurator Members
Inheritance Hierarchy


DB2Configurator Members

DB2Configurator Members
Protected Methods Public Methods
Collapse All

The following tables list the members exposed by DB2Configurator.

Protected Methods
Name | Description
FilterData | This method should return the name of the Dbx provider (such as Interbase, MSSQL or Oracle). There can be multiple configurators for the same provider.
Top
Public Methods
Name | Description
Caption | The caption for this instance when used as a designer verb.
ConfigureBackend | Override this method to perform the actual configuration. Modify the settings of sqlDatabaseConfig to suite your needs
ConfigureBackend | Initializes sqlDatabaseConfig using the settings determined by SupportedDataBaseEngine.
ConfigureBackend | Configure SqlDatabaseConfig approprately. This method is called from inside a designer transaction
IsVerbFor | This method determines if the instance is suited for configuring the submitted component.
IsVerbFor | The configurator must decide if it can act in current circumstances
PersistenceMapperType | This method will return typeof(PersistenceMapperDbx)
PersistenceMapperType | Return the type of the PersistenceMapper this configurator deals with
SupportedDataBaseEngine | Override this method to provide the engine enum handled by the configurator.


DB2Configurator Methods

DB2Configurator Methods
Protected Methods Public Methods
Collapse All

The methods of the DB2Configurator class are listed here.

Protected Methods
Name | Description
FilterData | This method should return the name of the Dbx provider (such as Interbase, MSSQL or Oracle). There can be multiple configurators for the same provider.
Top
Public Methods
Name | Description
Caption | The caption for this instance when used as a designer verb.
SupportedDataBaseEngine | Override this method to provide the engine enum handled by the configurator.


DB2Configurator.Caption Method

DB2Configurator.Caption Method
DB2Configurator Class DB2Configurator Members Eco.Persistence.Design Namespace See Also
Collapse All

The caption for this instance when used as a designer verb.

C#
public override string Caption();
See Also
DB2Configurator Class
DB2Configurator Members
Eco.Persistence.Design Namespace


DB2Configurator.FilterData Method

DB2Configurator.FilterData Method
DB2Configurator Class DB2Configurator Members Eco.Persistence.Design Namespace See Also
Collapse All

This method should return the name of the Dbx provider (such as Interbase, MSSQL or Oracle). There can be multiple configurators for the same provider.

C#
protected override string FilterData();
Remarks

Own members

See Also
DB2Configurator Class
DB2Configurator Members
Eco.Persistence.Design Namespace


DB2Configurator.SupportedDataBaseEngine Method

DB2Configurator.SupportedDataBaseEngine Method
DB2Configurator Class DB2Configurator Members Eco.Persistence.Design Namespace See Also
Collapse All

Override this method to provide the engine enum handled by the configurator.

C#
public override DataBaseEngine SupportedDataBaseEngine();
See Also
DB2Configurator Class
DB2Configurator Members
Eco.Persistence.Design Namespace


DB2MBCSConfigurator Class

DB2MBCSConfigurator Class
DB2MBCSConfigurator Members Inheritance Hierarchy See Also
Collapse All

Configurator for DB2MBCS.

C#
internal class DB2MBCSConfigurator : EcoDbxConfigurator;
Remarks

This class configures the persistence mapper using the settings for DataBaseEngine.DB2MBCS.

Inheritance Hierarchy
Eco.Persistence.Design.IMapperVerbConfigurator
    Eco.Persistence.Design.AbstractDbxConfigurator
        Eco.Persistence.Design.EcoDbxConfigurator
            Eco.Persistence.Design.DB2MBCSConfigurator
File

MapperConfiguratorsDbx.cs

See Also
DB2MBCSConfigurator Members
Inheritance Hierarchy


DB2MBCSConfigurator Members

DB2MBCSConfigurator Members
Protected Methods Public Methods
Collapse All

The following tables list the members exposed by DB2MBCSConfigurator.

Protected Methods
Name | Description
FilterData | This method should return the name of the Dbx provider (such as Interbase, MSSQL or Oracle). There can be multiple configurators for the same provider.
Top
Public Methods
Name | Description
Caption | The caption for this instance when used as a designer verb.
ConfigureBackend | Override this method to perform the actual configuration. Modify the settings of sqlDatabaseConfig to suite your needs
ConfigureBackend | Initializes sqlDatabaseConfig using the settings determined by SupportedDataBaseEngine.
ConfigureBackend | Configure SqlDatabaseConfig approprately. This method is called from inside a designer transaction
IsVerbFor | This method determines if the instance is suited for configuring the submitted component.
IsVerbFor | The configurator must decide if it can act in current circumstances
PersistenceMapperType | This method will return typeof(PersistenceMapperDbx)
PersistenceMapperType | Return the type of the PersistenceMapper this configurator deals with
SupportedDataBaseEngine | Override this method to provide the engine enum handled by the configurator.


DB2MBCSConfigurator Methods

DB2MBCSConfigurator Methods
Protected Methods Public Methods
Collapse All

The methods of the DB2MBCSConfigurator class are listed here.

Protected Methods
Name | Description
FilterData | This method should return the name of the Dbx provider (such as Interbase, MSSQL or Oracle). There can be multiple configurators for the same provider.
Top
Public Methods
Name | Description
Caption | The caption for this instance when used as a designer verb.
SupportedDataBaseEngine | Override this method to provide the engine enum handled by the configurator.


DB2MBCSConfigurator.Caption Method

DB2MBCSConfigurator.Caption Method
DB2MBCSConfigurator Class DB2MBCSConfigurator Members Eco.Persistence.Design Namespace See Also
Collapse All

The caption for this instance when used as a designer verb.

C#
public override string Caption();
See Also
DB2MBCSConfigurator Class
DB2MBCSConfigurator Members
Eco.Persistence.Design Namespace


DB2MBCSConfigurator.FilterData Method

DB2MBCSConfigurator.FilterData Method
DB2MBCSConfigurator Class DB2MBCSConfigurator Members Eco.Persistence.Design Namespace See Also
Collapse All

This method should return the name of the Dbx provider (such as Interbase, MSSQL or Oracle). There can be multiple configurators for the same provider.

C#
protected override string FilterData();
Remarks

Own members

See Also
DB2MBCSConfigurator Class
DB2MBCSConfigurator Members
Eco.Persistence.Design Namespace


DB2MBCSConfigurator.SupportedDataBaseEngine Method

DB2MBCSConfigurator.SupportedDataBaseEngine Method
DB2MBCSConfigurator Class DB2MBCSConfigurator Members Eco.Persistence.Design Namespace See Also
Collapse All

Override this method to provide the engine enum handled by the configurator.

C#
public override DataBaseEngine SupportedDataBaseEngine();
See Also
DB2MBCSConfigurator Class
DB2MBCSConfigurator Members
Eco.Persistence.Design Namespace


DBToolBase Class

DBToolBase Class
DBToolBase Members Inheritance Hierarchy See Also
Collapse All

Base class for persistence related tools.

C#
public abstract class DBToolBase : EcoToolButtonBase;
Remarks

This class adds some useful methods to extract information useful when developing persistence related tools such as returning the current persistence mapper (GetPersistenceMapper, GetPersistenceMapperDb) and the type system (GetTypeSystemService.

Inheritance Hierarchy
Eco.Persistence.Design.DBToolBase
    Eco.Persistence.Design.EvolveDBTool
    Eco.Persistence.Design.GenerateDBTool
    Eco.Persistence.Design.GenerateDefaultMappingXmlTool
    Eco.Persistence.Design.SaveMappingInfoTool
    Eco.Persistence.Design.ValidateModelTool
File

EcoSpaceDesignerToolsDb.cs

See Also
DBToolBase Members
Inheritance Hierarchy


DBToolBase Members

DBToolBase Members
Protected Methods Public Methods
Collapse All

The following tables list the members exposed by DBToolBase.

Protected Methods
Name | Description
DoExecute | DoExecute should be implemented to do the work the tool is intended for.
GetMessageCaption | Returns the string used as prefix when logging messages for this tool
GetPersistenceMapper | Returns the persistence mapper associated with the active designer.
GetTypeSystemService | Returns the ITypeSystemService associated with the active designer.
Top
Public Methods
Name | Description
Execute | The execute method is a wrapper for DoExecute.
GetDesignerTypes | Specifies which designer types this tool is associated with.


DBToolBase Methods

DBToolBase Methods
Protected Methods Public Methods
Collapse All

The methods of the DBToolBase class are listed here.

Protected Methods
Name | Description
DoExecute | DoExecute should be implemented to do the work the tool is intended for.
GetMessageCaption | Returns the string used as prefix when logging messages for this tool
GetPersistenceMapper | Returns the persistence mapper associated with the active designer.
GetTypeSystemService | Returns the ITypeSystemService associated with the active designer.
Top
Public Methods
Name | Description
Execute | The execute method is a wrapper for DoExecute.
GetDesignerTypes | Specifies which designer types this tool is associated with.


DBToolBase.DoExecute Method

DBToolBase.DoExecute Method
DBToolBase Class DBToolBase Members Eco.Persistence.Design Namespace See Also
Collapse All

DoExecute should be implemented to do the work the tool is intended for.

C#
protected abstract void DoExecute(
    ExecuteArgs executeArgs
);
Remarks

DoExecute is only called by Execute. The caller has ensured some preconditions and will trap all errors.

See Also
DBToolBase Class
DBToolBase Members
Eco.Persistence.Design Namespace


DBToolBase.Execute Method

DBToolBase.Execute Method
DBToolBase Class DBToolBase Members Eco.Persistence.Design Namespace See Also
Collapse All

The execute method is a wrapper for DoExecute.

C#
public override void Execute(
    ExecuteArgs executeArgs
);
Remarks

This methods checks that the executeArgs are not null, invokes DoExecute to do the real work. Subclasses must implement DoExecute.

See Also
DBToolBase Class
DBToolBase Members
Eco.Persistence.Design Namespace


DBToolBase.GetDesignerTypes Method

DBToolBase.GetDesignerTypes Method
DBToolBase Class DBToolBase Members Eco.Persistence.Design Namespace See Also
Collapse All

Specifies which designer types this tool is associated with.

C#
public override DesignerTypes GetDesignerTypes();
Remarks

This class is associated with PersistenceMapperProvider and EcoSpace.

See Also
DBToolBase Class
DBToolBase Members
Eco.Persistence.Design Namespace


DBToolBase.GetMessageCaption Method

DBToolBase.GetMessageCaption Method
DBToolBase Class DBToolBase Members Eco.Persistence.Design Namespace See Also
Collapse All

Returns the string used as prefix when logging messages for this tool

C#
protected abstract string GetMessageCaption();
See Also
DBToolBase Class
DBToolBase Members
Eco.Persistence.Design Namespace


DBToolBase.GetPersistenceMapper Method

DBToolBase.GetPersistenceMapper Method
DBToolBase Class DBToolBase Members Eco.Persistence.Design Namespace See Also
Collapse All

Returns the persistence mapper associated with the active designer.

C#
protected static PersistenceMapperDb GetPersistenceMapper(
    ExecuteArgs executeArgs,
    string operation,
    bool silent
);
Returns

If the active designer is a PersistenceMapperProvider the component pointed to by the PersistenceMapper is returned. Otherwise GetPersistenceMapperDb is called and the value returned.

See Also
DBToolBase Class
DBToolBase Members
Eco.Persistence.Design Namespace


DBToolBase.GetTypeSystemService Method

DBToolBase.GetTypeSystemService Method
DBToolBase Class DBToolBase Members Eco.Persistence.Design Namespace See Also
Collapse All

Returns the ITypeSystemService associated with the active designer.

C#
protected static ITypeSystemService GetTypeSystemService(
    ExecuteArgs executeArgs
);
Returns

If the active designer is a PersistenceMapperProvider it is queried via GetTypeSystemService for the result. Otherwise IdeHelper.GetTypeSystemService(string, bool, IServiceProvider, ITypeResolutionService, bool) is called and the value returned.

See Also
DBToolBase Class
DBToolBase Members
Eco.Persistence.Design Namespace


DbxPersistenceMapperDesigner Class

DbxPersistenceMapperDesigner Class
Inheritance Hierarchy See Also
Collapse All
C#
public class DbxPersistenceMapperDesigner : PersistenceHandleDesigner;
Remarks

This is class Eco.Persistence.Design.DbxPersistenceMapperDesigner.

Inheritance Hierarchy
Eco.Persistence.Design.PersistenceHandleDesigner
    Eco.Persistence.Design.DbxPersistenceMapperDesigner
File

PersistenceMapperDesignerDbx.cs

See Also
Inheritance Hierarchy


DbxProvider Class

DbxProvider Class
Inheritance Hierarchy See Also
Collapse All
C#
internal sealed class DbxProvider;
Remarks

This is class Eco.Persistence.Design.DbxProvider.

Inheritance Hierarchy
Eco.Persistence.Design.DbxProvider
File

MapperConfiguratorsDbx.cs

See Also
Inheritance Hierarchy


DefaultORMappingBuilderDesigner Class

DefaultORMappingBuilderDesigner Class
DefaultORMappingBuilderDesigner Members Inheritance Hierarchy See Also
Collapse All
C#
public class DefaultORMappingBuilderDesigner : ComponentDesigner;
Remarks

This is class Eco.Persistence.Design.DefaultORMappingBuilderDesigner.

Inheritance Hierarchy
Eco.Persistence.Design.DefaultORMappingBuilderDesigner
File

DefaultORMappingBuilderDesigner.cs

See Also
DefaultORMappingBuilderDesigner Members
Inheritance Hierarchy


DefaultORMappingBuilderDesigner Members

DefaultORMappingBuilderDesigner Members
Public Methods Public Properties
Collapse All

The following tables list the members exposed by DefaultORMappingBuilderDesigner.

Public Methods
Name | Description
DefaultORMappingBuilderDesigner | This is DefaultORMappingBuilderDesigner, a member of class DefaultORMappingBuilderDesigner.
Top
Public Properties
Name | Description
Verbs | This is Verbs, a member of class DefaultORMappingBuilderDesigner.


DefaultORMappingBuilderDesigner.DefaultORMappingBuilderDesigner Constructor

DefaultORMappingBuilderDesigner.DefaultORMappingBuilderDesigner Constructor
DefaultORMappingBuilderDesigner Class DefaultORMappingBuilderDesigner Members Eco.Persistence.Design Namespace See Also
Collapse All
C#
public DefaultORMappingBuilderDesigner();
Remarks

This is DefaultORMappingBuilderDesigner, a member of class DefaultORMappingBuilderDesigner.

See Also
DefaultORMappingBuilderDesigner Class
DefaultORMappingBuilderDesigner Members
Eco.Persistence.Design Namespace


DefaultORMappingBuilderDesigner Properties

DefaultORMappingBuilderDesigner Properties
Public Properties
Collapse All

The properties of the DefaultORMappingBuilderDesigner class are listed here.

Public Properties
Name | Description
Verbs | This is Verbs, a member of class DefaultORMappingBuilderDesigner.


DefaultORMappingBuilderDesigner.Verbs Property

DefaultORMappingBuilderDesigner.Verbs Property
DefaultORMappingBuilderDesigner Class DefaultORMappingBuilderDesigner Members Eco.Persistence.Design Namespace See Also
Collapse All
C#
public override DesignerVerbCollection Verbs;
Remarks

This is Verbs, a member of class DefaultORMappingBuilderDesigner.

See Also
DefaultORMappingBuilderDesigner Class
DefaultORMappingBuilderDesigner Members
Eco.Persistence.Design Namespace


DesignUtils Class

DesignUtils Class
DesignUtils Members Inheritance Hierarchy See Also
Collapse All

Helper class to set a property on an instance.

C#
public sealed class DesignUtils;
Inheritance Hierarchy
Eco.Persistence.Design.DesignUtils
File

PersistenceHandleDesigner.cs

See Also
DesignUtils Members
Inheritance Hierarchy


DesignUtils Members

DesignUtils Members
Public Methods
Collapse All

The following tables list the members exposed by DesignUtils.

Public Methods
Name | Description
SetPropertyValue | Sets a named property on an instance using reflection.


DesignUtils Methods

DesignUtils Methods
Public Methods
Collapse All

The methods of the DesignUtils class are listed here.

Public Methods
Name | Description
SetPropertyValue | Sets a named property on an instance using reflection.


DesignUtils.SetPropertyValue Method

DesignUtils.SetPropertyValue Method
DesignUtils Class DesignUtils Members Eco.Persistence.Design Namespace See Also
Collapse All

Sets a named property on an instance using reflection.

C#
public static void SetPropertyValue(
    object instance,
    string propertyName,
    object value
);
Parameters
Parameters | Description
instance | The instance to manipulate.
propertyName | Name of property to manipulate.
value | The value to set the property to.
Remarks

Sets the property named propertyName on instance to value. This is done using TypeDescriptor.GetProperties. No error handling.

See Also
DesignUtils Class
DesignUtils Members
Eco.Persistence.Design Namespace


EcoBdpConfigurator Class

EcoBdpConfigurator Class
EcoBdpConfigurator Members Inheritance Hierarchy See Also
Collapse All

Abstract base class for configurators for all BDP supported backends.

C#
internal abstract class EcoBdpConfigurator : AbstractBdpConfigurator;
Inheritance Hierarchy
Eco.Persistence.Design.IMapperVerbConfigurator
    Eco.Persistence.Design.AbstractBdpConfigurator
        Eco.Persistence.Design.EcoBdpConfigurator
            Eco.Persistence.Design.AccessConfiguratorBdp
            Eco.Persistence.Design.BlackfishConfiguratorBdp
            Eco.Persistence.Design.MySql4ConfiguratorBdp
            Eco.Persistence.Design.MySql5ConfiguratorBdp
            Eco.Persistence.Design.SQLServer7ConfiguratorBdp
            Eco.Persistence.Design.SQLServer7ConfiguratorBdpMBCS
            Eco.Persistence.Design.SQLServerConfiguratorBdp
            Eco.Persistence.Design.SQLServerConfiguratorBdpMBCS
File

MapperConfiguratorsBdp.cs

See Also
EcoBdpConfigurator Members
Inheritance Hierarchy


EcoBdpConfigurator Members

EcoBdpConfigurator Members
Protected Methods Public Methods
Collapse All

The following tables list the members exposed by EcoBdpConfigurator.

Protected Methods
Name | Description
FilterData | This method should return the name of the bdp provider (such as Interbase, MSSQL or Oracle). There can be multiple configurators for the same provider.
Top
Public Methods
Name | Description
Caption | Override this method to provide a caption for your configurator.
Caption | The caption of the verb.
ConfigureBackend | Initializes sqlDatabaseConfig using the settings determined by SupportedDataBaseEngine.
IsVerbFor | This method determines if the instance is suited for configuring the submitted component.
IsVerbFor | The configurator must decide if it can act in current circumstances
PersistenceMapperType | This method will return typeof(PersistenceMapperBdp)
PersistenceMapperType | Return the type of the PersistenceMapper this configurator deals with
SupportedDataBaseEngine | Override this method to provide the engine enum handled by the configurator.


EcoBdpConfigurator Methods

EcoBdpConfigurator Methods
Public Methods
Collapse All

The methods of the EcoBdpConfigurator class are listed here.

Public Methods
Name | Description
ConfigureBackend | Initializes sqlDatabaseConfig using the settings determined by SupportedDataBaseEngine.
SupportedDataBaseEngine | Override this method to provide the engine enum handled by the configurator.


EcoBdpConfigurator.ConfigureBackend Method

EcoBdpConfigurator.ConfigureBackend Method
EcoBdpConfigurator Class EcoBdpConfigurator Members Eco.Persistence.Design Namespace See Also
Collapse All

Initializes sqlDatabaseConfig using the settings determined by SupportedDataBaseEngine.

C#
public override void ConfigureBackend(
    SqlDatabaseConfig sqlDatabaseConfig
);
Parameters
Parameters | Description
sqlDatabaseConfig | The instance to configure.
See Also
EcoBdpConfigurator Class
EcoBdpConfigurator Members
Eco.Persistence.Design Namespace


EcoBdpConfigurator.SupportedDataBaseEngine Method

EcoBdpConfigurator.SupportedDataBaseEngine Method
EcoBdpConfigurator Class EcoBdpConfigurator Members Eco.Persistence.Design Namespace See Also
Collapse All

Override this method to provide the engine enum handled by the configurator.

C#
public abstract DataBaseEngine SupportedDataBaseEngine();
See Also
EcoBdpConfigurator Class
EcoBdpConfigurator Members
Eco.Persistence.Design Namespace


EcoDbxConfigurator Class

EcoDbxConfigurator Class
EcoDbxConfigurator Members Inheritance Hierarchy See Also
Collapse All

Abstract base class for configurators for all Dbx supported backends.

C#
internal abstract class EcoDbxConfigurator : AbstractDbxConfigurator;
Inheritance Hierarchy
Eco.Persistence.Design.IMapperVerbConfigurator
    Eco.Persistence.Design.AbstractDbxConfigurator
        Eco.Persistence.Design.EcoDbxConfigurator
            Eco.Persistence.Design.AccessConfiguratorDbx
            Eco.Persistence.Design.AnsiConfigurator
            Eco.Persistence.Design.BlackfishConfiguratorDbx
            Eco.Persistence.Design.DB2Configurator
            Eco.Persistence.Design.DB2MBCSConfigurator
            Eco.Persistence.Design.InformixConfigurator
            Eco.Persistence.Design.Interbase3Configurator
            Eco.Persistence.Design.Interbase3MBCSConfigurator
            Eco.Persistence.Design.MySql4ConfiguratorDbx
            Eco.Persistence.Design.MySql5ConfiguratorDbx
            Eco.Persistence.Design.OracleConfigurator
            Eco.Persistence.Design.OracleMBCSConfigurator
            Eco.Persistence.Design.SQLServer7ConfiguratorDbx
            Eco.Persistence.Design.SQLServer7ConfiguratorDbxMBCS
            Eco.Persistence.Design.SQLServerConfiguratorDbx
            Eco.Persistence.Design.SQLServerConfiguratorDbxMBCS
            Eco.Persistence.Design.SybaseConfigurator
File

MapperConfiguratorsDbx.cs

See Also
EcoDbxConfigurator Members
Inheritance Hierarchy


EcoDbxConfigurator Members

EcoDbxConfigurator Members
Protected Methods Public Methods
Collapse All

The following tables list the members exposed by EcoDbxConfigurator.

Protected Methods
Name | Description
FilterData | This method should return the name of the Dbx provider (such as Interbase, MSSQL or Oracle). There can be multiple configurators for the same provider.
Top
Public Methods
Name | Description
Caption | Override this method to provide a caption for your configurator.
Caption | The caption of the verb.
ConfigureBackend | Initializes sqlDatabaseConfig using the settings determined by SupportedDataBaseEngine.
IsVerbFor | This method determines if the instance is suited for configuring the submitted component.
IsVerbFor | The configurator must decide if it can act in current circumstances
PersistenceMapperType | This method will return typeof(PersistenceMapperDbx)
PersistenceMapperType | Return the type of the PersistenceMapper this configurator deals with
SupportedDataBaseEngine | Override this method to provide the engine enum handled by the configurator.


EcoDbxConfigurator Methods

EcoDbxConfigurator Methods
Public Methods
Collapse All

The methods of the EcoDbxConfigurator class are listed here.

Public Methods
Name | Description
ConfigureBackend | Initializes sqlDatabaseConfig using the settings determined by SupportedDataBaseEngine.
SupportedDataBaseEngine | Override this method to provide the engine enum handled by the configurator.


EcoDbxConfigurator.ConfigureBackend Method

EcoDbxConfigurator.ConfigureBackend Method
EcoDbxConfigurator Class EcoDbxConfigurator Members Eco.Persistence.Design Namespace See Also
Collapse All

Initializes sqlDatabaseConfig using the settings determined by SupportedDataBaseEngine.

C#
public override void ConfigureBackend(
    SqlDatabaseConfig sqlDatabaseConfig
);
Parameters
Parameters | Description
sqlDatabaseConfig | The instance to configure.
See Also
EcoDbxConfigurator Class
EcoDbxConfigurator Members
Eco.Persistence.Design Namespace


EcoDbxConfigurator.SupportedDataBaseEngine Method

EcoDbxConfigurator.SupportedDataBaseEngine Method
EcoDbxConfigurator Class EcoDbxConfigurator Members Eco.Persistence.Design Namespace See Also
Collapse All

Override this method to provide the engine enum handled by the configurator.

C#
public abstract DataBaseEngine SupportedDataBaseEngine();
See Also
EcoDbxConfigurator Class
EcoDbxConfigurator Members
Eco.Persistence.Design Namespace


EvolveDBTool Class

EvolveDBTool Class
EvolveDBTool Members Inheritance Hierarchy See Also
Collapse All

This tool encapsulates the evolving of a database schema with the preservation of data.

C#
public class EvolveDBTool : DBToolBase;
Inheritance Hierarchy
Eco.Persistence.Design.DBToolBase
    Eco.Persistence.Design.EvolveDBTool
File

EcoSpaceDesignerToolsDb.cs

See Also
EvolveDBTool Members
Inheritance Hierarchy


EvolveDBTool Members

EvolveDBTool Members
Protected Methods Public Methods
Collapse All

The following tables list the members exposed by EvolveDBTool.

Protected Methods
Name | Description
DoExecute | Executes the schema evolution.
GetMessageCaption | Returns the string used as prefix when logging messages for this tool
GetPersistenceMapper | Returns the persistence mapper associated with the active designer.
GetTypeSystemService | Returns the ITypeSystemService associated with the active designer.
Top
Public Methods
Name | Description
Execute | The execute method is a wrapper for DoExecute.
GetCaption |
GetDesignerTypes | Specifies which designer types this tool is associated with.


EvolveDBTool Methods

EvolveDBTool Methods
Protected Methods Public Methods
Collapse All

The methods of the EvolveDBTool class are listed here.

Protected Methods
Name | Description
DoExecute | Executes the schema evolution.
GetMessageCaption | Returns the string used as prefix when logging messages for this tool
Top
Public Methods
Name | Description
GetCaption |


EvolveDBTool.DoExecute Method

EvolveDBTool.DoExecute Method
EvolveDBTool Class EvolveDBTool Members Eco.Persistence.Design Namespace See Also
Collapse All

Executes the schema evolution.

C#
protected override void DoExecute(
    ExecuteArgs executeArgs
);
Remarks

This tool needs a fully configured PersistenceMapperDb connected to the ecospace to complete its operation. The actual work is performed by DBEvolutionForm.EvolveDB(IServiceProvider, IPersistenceMapperDb, ITypeSystemService).

See Also
EvolveDBTool Class
EvolveDBTool Members
Eco.Persistence.Design Namespace


EvolveDBTool.GetCaption Method

EvolveDBTool.GetCaption Method
EvolveDBTool Class EvolveDBTool Members Eco.Persistence.Design Namespace See Also
Collapse All
C#
public override string GetCaption();
See Also
EvolveDBTool Class
EvolveDBTool Members
Eco.Persistence.Design Namespace


EvolveDBTool.GetMessageCaption Method

EvolveDBTool.GetMessageCaption Method
EvolveDBTool Class EvolveDBTool Members Eco.Persistence.Design Namespace See Also
Collapse All

Returns the string used as prefix when logging messages for this tool

C#
protected override string GetMessageCaption();
See Also
EvolveDBTool Class
EvolveDBTool Members
Eco.Persistence.Design Namespace


FirebirdConfiguratorFirebirdClient Class

FirebirdConfiguratorFirebirdClient Class
FirebirdConfiguratorFirebirdClient Members Inheritance Hierarchy See Also
Collapse All
C#
internal class FirebirdConfiguratorFirebirdClient : IMapperVerbConfigurator;
Remarks

This is class Eco.Persistence.Design.FirebirdConfiguratorFirebirdClient.

Inheritance Hierarchy
Eco.Persistence.Design.IMapperVerbConfigurator
    Eco.Persistence.Design.FirebirdConfiguratorFirebirdClient
File

MapperConfiguratorsFirebird.cs

See Also
FirebirdConfiguratorFirebirdClient Members
Inheritance Hierarchy


FirebirdConfiguratorFirebirdClient Members

FirebirdConfiguratorFirebirdClient Members
Public Methods
Collapse All

The following tables list the members exposed by FirebirdConfiguratorFirebirdClient.

Public Methods
Name | Description
Caption | The caption of the verb.
ConfigureBackend | Configure SqlDatabaseConfig approprately. This method is called from inside a designer transaction
IsVerbFor | The configurator must decide if it can act in current circumstances
PersistenceMapperType | Return the type of the PersistenceMapper this configurator deals with


FirebirdConfiguratorFirebirdClient Methods

FirebirdConfiguratorFirebirdClient Methods
Public Methods
Collapse All

The methods of the FirebirdConfiguratorFirebirdClient class are listed here.

Public Methods
Name | Description
Caption | The caption of the verb.
ConfigureBackend | Configure SqlDatabaseConfig approprately. This method is called from inside a designer transaction
IsVerbFor | The configurator must decide if it can act in current circumstances
PersistenceMapperType | Return the type of the PersistenceMapper this configurator deals with


FirebirdConfiguratorFirebirdClient.Caption Method

FirebirdConfiguratorFirebirdClient.Caption Method
FirebirdConfiguratorFirebirdClient Class FirebirdConfiguratorFirebirdClient Members Eco.Persistence.Design Namespace See Also
Collapse All

The caption of the verb.

C#
public string Caption();
See Also
FirebirdConfiguratorFirebirdClient Class
FirebirdConfiguratorFirebirdClient Members
Eco.Persistence.Design Namespace


FirebirdConfiguratorFirebirdClient.ConfigureBackend Method

FirebirdConfiguratorFirebirdClient.ConfigureBackend Method
FirebirdConfiguratorFirebirdClient Class FirebirdConfiguratorFirebirdClient Members Eco.Persistence.Design Namespace See Also
Collapse All

Configure SqlDatabaseConfig approprately. This method is called from inside a designer transaction

C#
public void ConfigureBackend(
    SqlDatabaseConfig sqlDatabaseConfig
);
See Also
FirebirdConfiguratorFirebirdClient Class
FirebirdConfiguratorFirebirdClient Members
Eco.Persistence.Design Namespace


FirebirdConfiguratorFirebirdClient.IsVerbFor Method

FirebirdConfiguratorFirebirdClient.IsVerbFor Method
FirebirdConfiguratorFirebirdClient Class FirebirdConfiguratorFirebirdClient Members Eco.Persistence.Design Namespace See Also
Collapse All

The configurator must decide if it can act in current circumstances

C#
public bool IsVerbFor(
    Component component
);
See Also
FirebirdConfiguratorFirebirdClient Class
FirebirdConfiguratorFirebirdClient Members
Eco.Persistence.Design Namespace


FirebirdConfiguratorFirebirdClient.PersistenceMapperType Method

FirebirdConfiguratorFirebirdClient.PersistenceMapperType Method
FirebirdConfiguratorFirebirdClient Class FirebirdConfiguratorFirebirdClient Members Eco.Persistence.Design Namespace See Also
Collapse All

Return the type of the PersistenceMapper this configurator deals with

C#
public object PersistenceMapperType();
See Also
FirebirdConfiguratorFirebirdClient Class
FirebirdConfiguratorFirebirdClient Members
Eco.Persistence.Design Namespace


FirebirdPersistenceMapperDesigner Class

FirebirdPersistenceMapperDesigner Class
FirebirdPersistenceMapperDesigner Members Inheritance Hierarchy See Also
Collapse All
C#
public class FirebirdPersistenceMapperDesigner : PersistenceHandleDesigner;
Remarks

This is class Eco.Persistence.Design.FirebirdPersistenceMapperDesigner.

Inheritance Hierarchy
Eco.Persistence.Design.PersistenceHandleDesigner
    Eco.Persistence.Design.FirebirdPersistenceMapperDesigner
File

PersistenceHandleDesignerFirebird.cs

See Also
FirebirdPersistenceMapperDesigner Members
Inheritance Hierarchy


FirebirdPersistenceMapperDesigner Members

FirebirdPersistenceMapperDesigner Members
Protected Methods Public Methods Public Properties Protected Properties
Collapse All

The following tables list the members exposed by FirebirdPersistenceMapperDesigner.

Protected Methods
Name | Description
Dispose | This method uninstalls the OnComponentRemoved event handler.
OnComponentRemoved | Disconnects the removed component from the designed component.
PersistenceHandleDesigner | This is PersistenceHandleDesigner, a member of class PersistenceHandleDesigner.
Top
Public Methods
Name | Description
FirebirdPersistenceMapperDesigner | This is FirebirdPersistenceMapperDesigner, a member of class FirebirdPersistenceMapperDesigner.
Initialize | Initializes the component.
InitializeComponent | Called by the verb handler to initialize the designed component with the configurator.
InitializeNewComponent | This is InitializeNewComponent, a member of class FirebirdPersistenceMapperDesigner.
RegisterConfigurator | Registers the configurator in the list of known configurators.
Top
Public Properties
Name | Description
Verbs | Builds the verbs for the designed component.
Top
Protected Properties
Name | Description
MapperVerbConfigurators | This is MapperVerbConfigurators, a member of class PersistenceHandleDesigner.


FirebirdPersistenceMapperDesigner.FirebirdPersistenceMapperDesigner Constructor

FirebirdPersistenceMapperDesigner.FirebirdPersistenceMapperDesigner Constructor
FirebirdPersistenceMapperDesigner Class FirebirdPersistenceMapperDesigner Members Eco.Persistence.Design Namespace See Also
Collapse All
C#
public FirebirdPersistenceMapperDesigner();
Remarks

This is FirebirdPersistenceMapperDesigner, a member of class FirebirdPersistenceMapperDesigner.

See Also
FirebirdPersistenceMapperDesigner Class
FirebirdPersistenceMapperDesigner Members
Eco.Persistence.Design Namespace


FirebirdPersistenceMapperDesigner Methods

FirebirdPersistenceMapperDesigner Methods
Public Methods
Collapse All

The methods of the FirebirdPersistenceMapperDesigner class are listed here.

Public Methods
Name | Description
InitializeNewComponent | This is InitializeNewComponent, a member of class FirebirdPersistenceMapperDesigner.


FirebirdPersistenceMapperDesigner.InitializeNewComponent Method

FirebirdPersistenceMapperDesigner.InitializeNewComponent Method
FirebirdPersistenceMapperDesigner Class FirebirdPersistenceMapperDesigner Members Eco.Persistence.Design Namespace See Also
Collapse All
C#
public override void InitializeNewComponent(
    IDictionary defaultValues
);
Remarks

This is InitializeNewComponent, a member of class FirebirdPersistenceMapperDesigner.

See Also
FirebirdPersistenceMapperDesigner Class
FirebirdPersistenceMapperDesigner Members
Eco.Persistence.Design Namespace


GenerateDBTool Class

GenerateDBTool Class
GenerateDBTool Members Inheritance Hierarchy See Also
Collapse All

This tool generates the default schema suitable to store the model.

C#
public class GenerateDBTool : DBToolBase;
Inheritance Hierarchy
Eco.Persistence.Design.DBToolBase
    Eco.Persistence.Design.GenerateDBTool
File

EcoSpaceDesignerToolsDb.cs

See Also
GenerateDBTool Members
Inheritance Hierarchy


GenerateDBTool Members

GenerateDBTool Members
Protected Methods Public Methods
Collapse All

The following tables list the members exposed by GenerateDBTool.

Protected Methods
Name | Description
DoExecute | Executes the schema generation.
GetMessageCaption | Returns the string used as prefix when logging messages for this tool
GetPersistenceMapper | Returns the persistence mapper associated with the active designer.
GetTypeSystemService | Returns the ITypeSystemService associated with the active designer.
Top
Public Methods
Name | Description
Execute | The execute method is a wrapper for DoExecute.
GetCaption |
GetDesignerTypes | Specifies which designer types this tool is associated with.


GenerateDBTool Methods

GenerateDBTool Methods
Protected Methods Public Methods
Collapse All

The methods of the GenerateDBTool class are listed here.

Protected Methods
Name | Description
DoExecute | Executes the schema generation.
GetMessageCaption | Returns the string used as prefix when logging messages for this tool
Top
Public Methods
Name | Description
GetCaption |


GenerateDBTool.DoExecute Method

GenerateDBTool.DoExecute Method
GenerateDBTool Class GenerateDBTool Members Eco.Persistence.Design Namespace See Also
Collapse All

Executes the schema generation.

C#
protected override void DoExecute(
    ExecuteArgs executeArgs
);
Remarks

Assuming a non-empty model and a persistence mapper, the schema is derived and generated by this tool. The actual work is performed by PersistenceMapperDb.CreateDatabaseSchema(ITypeSystemService, IConfigureCleanPS).

This tool needs a fully configured PersistenceMapperDb connected to the ecospace to complete its operation.

See Also
GenerateDBTool Class
GenerateDBTool Members
Eco.Persistence.Design Namespace


GenerateDBTool.GetCaption Method

GenerateDBTool.GetCaption Method
GenerateDBTool Class GenerateDBTool Members Eco.Persistence.Design Namespace See Also
Collapse All
C#
public override string GetCaption();
See Also
GenerateDBTool Class
GenerateDBTool Members
Eco.Persistence.Design Namespace


GenerateDBTool.GetMessageCaption Method

GenerateDBTool.GetMessageCaption Method
GenerateDBTool Class GenerateDBTool Members Eco.Persistence.Design Namespace See Also
Collapse All

Returns the string used as prefix when logging messages for this tool

C#
protected override string GetMessageCaption();
See Also
GenerateDBTool Class
GenerateDBTool Members
Eco.Persistence.Design Namespace


GenerateDefaultMappingXmlTool Class

GenerateDefaultMappingXmlTool Class
GenerateDefaultMappingXmlTool Members Inheritance Hierarchy See Also
Collapse All

This tool saves the current OR mapping information to an xml-file

C#
public class GenerateDefaultMappingXmlTool : DBToolBase;
Inheritance Hierarchy
Eco.Persistence.Design.DBToolBase
    Eco.Persistence.Design.GenerateDefaultMappingXmlTool
File

EcoSpaceDesignerToolsDb.cs

See Also
GenerateDefaultMappingXmlTool Members
Inheritance Hierarchy


GenerateDefaultMappingXmlTool Members

GenerateDefaultMappingXmlTool Members
Protected Methods Public Methods
Collapse All

The following tables list the members exposed by GenerateDefaultMappingXmlTool.

Protected Methods
Name | Description
DoExecute | Generates the mapping file and adds it to the project.
GetMessageCaption | Returns the string used as prefix when logging messages for this tool
GetPersistenceMapper | Returns the persistence mapper associated with the active designer.
GetTypeSystemService | Returns the ITypeSystemService associated with the active designer.
Top
Public Methods
Name | Description
Execute | The execute method is a wrapper for DoExecute.
GetCaption |
GetDesignerTypes | Specifies which designer types this tool is associated with.


GenerateDefaultMappingXmlTool Methods

GenerateDefaultMappingXmlTool Methods
Protected Methods Public Methods
Collapse All

The methods of the GenerateDefaultMappingXmlTool class are listed here.

Protected Methods
Name | Description
DoExecute | Generates the mapping file and adds it to the project.
GetMessageCaption | Returns the string used as prefix when logging messages for this tool
Top
Public Methods
Name | Description
GetCaption |


GenerateDefaultMappingXmlTool.DoExecute Method

GenerateDefaultMappingXmlTool.DoExecute Method
GenerateDefaultMappingXmlTool Class GenerateDefaultMappingXmlTool Members Eco.Persistence.Design Namespace See Also
Collapse All

Generates the mapping file and adds it to the project.

C#
protected override void DoExecute(
    ExecuteArgs executeArgs
);
Remarks

The file will be placed next to the project file and it will be named OrMapping.xml. If that file exists, A new file will be generated by trying Ormapping1.xml until a free slot is found. The actual work is done by the classes DefaultORMappingBuilder and ORMappingXmlGenerator.

This tool needs a PersistenceMapperDb connected to the ecospace to complete its operation.

See Also
GenerateDefaultMappingXmlTool Class
GenerateDefaultMappingXmlTool Members
Eco.Persistence.Design Namespace


GenerateDefaultMappingXmlTool.GetCaption Method

GenerateDefaultMappingXmlTool.GetCaption Method
GenerateDefaultMappingXmlTool Class GenerateDefaultMappingXmlTool Members Eco.Persistence.Design Namespace See Also
Collapse All
C#
public override string GetCaption();
See Also
GenerateDefaultMappingXmlTool Class
GenerateDefaultMappingXmlTool Members
Eco.Persistence.Design Namespace


GenerateDefaultMappingXmlTool.GetMessageCaption Method

GenerateDefaultMappingXmlTool.GetMessageCaption Method
GenerateDefaultMappingXmlTool Class GenerateDefaultMappingXmlTool Members Eco.Persistence.Design Namespace See Also
Collapse All

Returns the string used as prefix when logging messages for this tool

C#
protected override string GetMessageCaption();
See Also
GenerateDefaultMappingXmlTool Class
GenerateDefaultMappingXmlTool Members
Eco.Persistence.Design Namespace


InformixConfigurator Class

InformixConfigurator Class
InformixConfigurator Members Inheritance Hierarchy See Also
Collapse All

Configurator for Informix.

C#
internal class InformixConfigurator : EcoDbxConfigurator;
Remarks

This class configures the persistence mapper using the settings for DataBaseEngine.Informix.

Inheritance Hierarchy
Eco.Persistence.Design.IMapperVerbConfigurator
    Eco.Persistence.Design.AbstractDbxConfigurator
        Eco.Persistence.Design.EcoDbxConfigurator
            Eco.Persistence.Design.InformixConfigurator
File

MapperConfiguratorsDbx.cs

See Also
InformixConfigurator Members
Inheritance Hierarchy


InformixConfigurator Members

InformixConfigurator Members
Protected Methods Public Methods
Collapse All

The following tables list the members exposed by InformixConfigurator.

Protected Methods
Name | Description
FilterData | This method should return the name of the Dbx provider (such as Interbase, MSSQL or Oracle). There can be multiple configurators for the same provider.
Top
Public Methods
Name | Description
Caption | The caption for this instance when used as a designer verb.
ConfigureBackend | Override this method to perform the actual configuration. Modify the settings of sqlDatabaseConfig to suite your needs
ConfigureBackend | Initializes sqlDatabaseConfig using the settings determined by SupportedDataBaseEngine.
ConfigureBackend | Configure SqlDatabaseConfig approprately. This method is called from inside a designer transaction
IsVerbFor | This method determines if the instance is suited for configuring the submitted component.
IsVerbFor | The configurator must decide if it can act in current circumstances
PersistenceMapperType | This method will return typeof(PersistenceMapperDbx)
PersistenceMapperType | Return the type of the PersistenceMapper this configurator deals with
SupportedDataBaseEngine | Override this method to provide the engine enum handled by the configurator.


InformixConfigurator Methods

InformixConfigurator Methods
Protected Methods Public Methods
Collapse All

The methods of the InformixConfigurator class are listed here.

Protected Methods
Name | Description
FilterData | This method should return the name of the Dbx provider (such as Interbase, MSSQL or Oracle). There can be multiple configurators for the same provider.
Top
Public Methods
Name | Description
Caption | The caption for this instance when used as a designer verb.
SupportedDataBaseEngine | Override this method to provide the engine enum handled by the configurator.


InformixConfigurator.Caption Method

InformixConfigurator.Caption Method
InformixConfigurator Class InformixConfigurator Members Eco.Persistence.Design Namespace See Also
Collapse All

The caption for this instance when used as a designer verb.

C#
public override string Caption();
See Also
InformixConfigurator Class
InformixConfigurator Members
Eco.Persistence.Design Namespace


InformixConfigurator.FilterData Method

InformixConfigurator.FilterData Method
InformixConfigurator Class InformixConfigurator Members Eco.Persistence.Design Namespace See Also
Collapse All

This method should return the name of the Dbx provider (such as Interbase, MSSQL or Oracle). There can be multiple configurators for the same provider.

C#
protected override string FilterData();
Remarks

Own members

See Also
InformixConfigurator Class
InformixConfigurator Members
Eco.Persistence.Design Namespace


InformixConfigurator.SupportedDataBaseEngine Method

InformixConfigurator.SupportedDataBaseEngine Method
InformixConfigurator Class InformixConfigurator Members Eco.Persistence.Design Namespace See Also
Collapse All

Override this method to provide the engine enum handled by the configurator.

C#
public override DataBaseEngine SupportedDataBaseEngine();
See Also
InformixConfigurator Class
InformixConfigurator Members
Eco.Persistence.Design Namespace


Initialize Class

Initialize Class
Initialize Members Inheritance Hierarchy See Also
Collapse All

Helper class with only static to perform IDE registration tasks.

C#
public static class Initialize;
Inheritance Hierarchy
Eco.Persistence.Design.Initialize
File

EcoSpaceDesignerToolsDb.cs

See Also
Initialize Members
Inheritance Hierarchy


Initialize Members

Initialize Members
Public Methods
Collapse All

The following tables list the members exposed by Initialize.

Public Methods
Name | Description
IDERegister | Adds persistence related tools to the EcoSpaceDesignerToolbox


Initialize Methods

Initialize Methods
Public Methods
Collapse All

The methods of the Initialize class are listed here.

Public Methods
Name | Description
IDERegister | Adds persistence related tools to the EcoSpaceDesignerToolbox


Initialize.IDERegister Method

Initialize.IDERegister Method
Initialize Class Initialize Members Eco.Persistence.Design Namespace See Also
Collapse All

Adds persistence related tools to the EcoSpaceDesignerToolbox

C#
public static void IDERegister();
See Also
Initialize Class
Initialize Members
Eco.Persistence.Design Namespace


Interbase3Configurator Class

Interbase3Configurator Class
Interbase3Configurator Members Inheritance Hierarchy See Also
Collapse All

Configurator for InterbaseSqlDialect3.

C#
internal class Interbase3Configurator : EcoDbxConfigurator;
Remarks

This class configures the persistence mapper using the settings for DataBaseEngine.InterbaseSqlDialect3.

Inheritance Hierarchy
Eco.Persistence.Design.IMapperVerbConfigurator
    Eco.Persistence.Design.AbstractDbxConfigurator
        Eco.Persistence.Design.EcoDbxConfigurator
            Eco.Persistence.Design.Interbase3Configurator
File

MapperConfiguratorsDbx.cs

See Also
Interbase3Configurator Members
Inheritance Hierarchy


Interbase3Configurator Members

Interbase3Configurator Members
Protected Methods Public Methods
Collapse All

The following tables list the members exposed by Interbase3Configurator.

Protected Methods
Name | Description
FilterData | This method should return the name of the Dbx provider (such as Interbase, MSSQL or Oracle). There can be multiple configurators for the same provider.
Top
Public Methods
Name | Description
Caption | The caption for this instance when used as a designer verb.
ConfigureBackend | Override this method to perform the actual configuration. Modify the settings of sqlDatabaseConfig to suite your needs
ConfigureBackend | Initializes sqlDatabaseConfig using the settings determined by SupportedDataBaseEngine.
ConfigureBackend | Configure SqlDatabaseConfig approprately. This method is called from inside a designer transaction
IsVerbFor | This method determines if the instance is suited for configuring the submitted component.
IsVerbFor | The configurator must decide if it can act in current circumstances
PersistenceMapperType | This method will return typeof(PersistenceMapperDbx)
PersistenceMapperType | Return the type of the PersistenceMapper this configurator deals with
SupportedDataBaseEngine | Override this method to provide the engine enum handled by the configurator.


Interbase3Configurator Methods

Interbase3Configurator Methods
Protected Methods Public Methods
Collapse All

The methods of the Interbase3Configurator class are listed here.

Protected Methods
Name | Description
FilterData | This method should return the name of the Dbx provider (such as Interbase, MSSQL or Oracle). There can be multiple configurators for the same provider.
Top
Public Methods
Name | Description
Caption | The caption for this instance when used as a designer verb.
SupportedDataBaseEngine | Override this method to provide the engine enum handled by the configurator.


Interbase3Configurator.Caption Method

Interbase3Configurator.Caption Method
Interbase3Configurator Class Interbase3Configurator Members Eco.Persistence.Design Namespace See Also
Collapse All

The caption for this instance when used as a designer verb.

C#
public override string Caption();
See Also
Interbase3Configurator Class
Interbase3Configurator Members
Eco.Persistence.Design Namespace


Interbase3Configurator.FilterData Method

Interbase3Configurator.FilterData Method
Interbase3Configurator Class Interbase3Configurator Members Eco.Persistence.Design Namespace See Also
Collapse All

This method should return the name of the Dbx provider (such as Interbase, MSSQL or Oracle). There can be multiple configurators for the same provider.

C#
protected override string FilterData();
Remarks

Own members

See Also
Interbase3Configurator Class
Interbase3Configurator Members
Eco.Persistence.Design Namespace


Interbase3Configurator.SupportedDataBaseEngine Method

Interbase3Configurator.SupportedDataBaseEngine Method
Interbase3Configurator Class Interbase3Configurator Members Eco.Persistence.Design Namespace See Also
Collapse All

Override this method to provide the engine enum handled by the configurator.

C#
public override DataBaseEngine SupportedDataBaseEngine();
See Also
Interbase3Configurator Class
Interbase3Configurator Members
Eco.Persistence.Design Namespace


Interbase3MBCSConfigurator Class

Interbase3MBCSConfigurator Class
Interbase3MBCSConfigurator Members Inheritance Hierarchy See Also
Collapse All

Configurator for InterbaseSqlDialect3MBCS.

C#
internal class Interbase3MBCSConfigurator : EcoDbxConfigurator;
Remarks

This class configures the persistence mapper using the settings for DataBaseEngine.InterbaseSqlDialect3MBCS.

Inheritance Hierarchy
Eco.Persistence.Design.IMapperVerbConfigurator
    Eco.Persistence.Design.AbstractDbxConfigurator
        Eco.Persistence.Design.EcoDbxConfigurator
            Eco.Persistence.Design.Interbase3MBCSConfigurator
File

MapperConfiguratorsDbx.cs

See Also
Interbase3MBCSConfigurator Members
Inheritance Hierarchy


Interbase3MBCSConfigurator Members

Interbase3MBCSConfigurator Members
Protected Methods Public Methods
Collapse All

The following tables list the members exposed by Interbase3MBCSConfigurator.

Protected Methods
Name | Description
FilterData | This method should return the name of the Dbx provider (such as Interbase, MSSQL or Oracle). There can be multiple configurators for the same provider.
Top
Public Methods
Name | Description
Caption | The caption for this instance when used as a designer verb.
ConfigureBackend | Override this method to perform the actual configuration. Modify the settings of sqlDatabaseConfig to suite your needs
ConfigureBackend | Initializes sqlDatabaseConfig using the settings determined by SupportedDataBaseEngine.
ConfigureBackend | Configure SqlDatabaseConfig approprately. This method is called from inside a designer transaction
IsVerbFor | This method determines if the instance is suited for configuring the submitted component.
IsVerbFor | The configurator must decide if it can act in current circumstances
PersistenceMapperType | This method will return typeof(PersistenceMapperDbx)
PersistenceMapperType | Return the type of the PersistenceMapper this configurator deals with
SupportedDataBaseEngine | Override this method to provide the engine enum handled by the configurator.


Interbase3MBCSConfigurator Methods

Interbase3MBCSConfigurator Methods
Protected Methods Public Methods
Collapse All

The methods of the Interbase3MBCSConfigurator class are listed here.

Protected Methods
Name | Description
FilterData | This method should return the name of the Dbx provider (such as Interbase, MSSQL or Oracle). There can be multiple configurators for the same provider.
Top
Public Methods
Name | Description
Caption | The caption for this instance when used as a designer verb.
SupportedDataBaseEngine | Override this method to provide the engine enum handled by the configurator.


Interbase3MBCSConfigurator.Caption Method

Interbase3MBCSConfigurator.Caption Method
Interbase3MBCSConfigurator Class Interbase3MBCSConfigurator Members Eco.Persistence.Design Namespace See Also
Collapse All

The caption for this instance when used as a designer verb.

C#
public override string Caption();
See Also
Interbase3MBCSConfigurator Class
Interbase3MBCSConfigurator Members
Eco.Persistence.Design Namespace


Interbase3MBCSConfigurator.FilterData Method

Interbase3MBCSConfigurator.FilterData Method
Interbase3MBCSConfigurator Class Interbase3MBCSConfigurator Members Eco.Persistence.Design Namespace See Also
Collapse All

This method should return the name of the Dbx provider (such as Interbase, MSSQL or Oracle). There can be multiple configurators for the same provider.

C#
protected override string FilterData();
Remarks

Own members

See Also
Interbase3MBCSConfigurator Class
Interbase3MBCSConfigurator Members
Eco.Persistence.Design Namespace


Interbase3MBCSConfigurator.SupportedDataBaseEngine Method

Interbase3MBCSConfigurator.SupportedDataBaseEngine Method
Interbase3MBCSConfigurator Class Interbase3MBCSConfigurator Members Eco.Persistence.Design Namespace See Also
Collapse All

Override this method to provide the engine enum handled by the configurator.

C#
public override DataBaseEngine SupportedDataBaseEngine();
See Also
Interbase3MBCSConfigurator Class
Interbase3MBCSConfigurator Members
Eco.Persistence.Design Namespace


KeyMapperNameConverter Class

KeyMapperNameConverter Class
KeyMapperNameConverter Members Inheritance Hierarchy See Also
Collapse All

KeyMapperNameConverter is the converter for the KeyMapperDefinition.Name property.

C#
public sealed class KeyMapperNameConverter : MapperNameConverter;
Inheritance Hierarchy
Eco.Persistence.Design.MapperNameConverter
    Eco.Persistence.Design.KeyMapperNameConverter
File

KeyMapperTypeConverter.cs

See Also
KeyMapperNameConverter Members
Inheritance Hierarchy


KeyMapperNameConverter Members

KeyMapperNameConverter Members
Protected Methods Public Methods
Collapse All

The following tables list the members exposed by KeyMapperNameConverter.

Protected Methods
Name | Description
SourceList |
Top
Public Methods
Name | Description
GetStandardValues | This is GetStandardValues, a member of class MapperNameConverter.
GetStandardValuesExclusive | The list is not exclusive.
GetStandardValuesSupported | Indicate supporting a value list.
KeyMapperNameConverter | This is KeyMapperNameConverter, a member of class KeyMapperNameConverter.


KeyMapperNameConverter.KeyMapperNameConverter Constructor

KeyMapperNameConverter.KeyMapperNameConverter Constructor
KeyMapperNameConverter Class KeyMapperNameConverter Members Eco.Persistence.Design Namespace See Also
Collapse All
C#
public KeyMapperNameConverter();
Remarks

This is KeyMapperNameConverter, a member of class KeyMapperNameConverter.

See Also
KeyMapperNameConverter Class
KeyMapperNameConverter Members
Eco.Persistence.Design Namespace


KeyMapperNameConverter Methods

KeyMapperNameConverter Methods
Protected Methods
Collapse All

The methods of the KeyMapperNameConverter class are listed here.

Protected Methods
Name | Description
SourceList |


KeyMapperNameConverter.SourceList Method

KeyMapperNameConverter.SourceList Method
KeyMapperNameConverter Class KeyMapperNameConverter Members Eco.Persistence.Design Namespace See Also
Collapse All
C#
protected override List<MapperDefinition> SourceList();
Returns

returns DatabaseEngineInitializer.KeyMapperList.

See Also
KeyMapperNameConverter Class
KeyMapperNameConverter Members
Eco.Persistence.Design Namespace


KeyMapperTypeNameConverter Class

KeyMapperTypeNameConverter Class
KeyMapperTypeNameConverter Members Inheritance Hierarchy See Also
Collapse All

KeyMapperTypeConverter is the converter for the KeyMapperDefinition.Mapper property.

C#
public sealed class KeyMapperTypeNameConverter : MapperTypeNameConverter;
Inheritance Hierarchy
Eco.Persistence.Design.MapperTypeNameConverter
    Eco.Persistence.Design.KeyMapperTypeNameConverter
File

KeyMapperTypeConverter.cs

See Also
KeyMapperTypeNameConverter Members
Inheritance Hierarchy


KeyMapperTypeNameConverter Members

KeyMapperTypeNameConverter Members
Protected Methods Public Methods
Collapse All

The following tables list the members exposed by KeyMapperTypeNameConverter.

Protected Methods
Name | Description
MapperList |
MapperTypeNameConverter | This is MapperTypeNameConverter, a member of class MapperTypeNameConverter.
Top
Public Methods
Name
Description
GetStandardValues
private bool assembliesRegistered = false;
private void RegisterAllAssemblies(ITypeResolutionService typeResolutionService) { if (assembliesRegistered) return; ListassyList = new List(); foreach (System.Type t in MapperList()) { Assembly assy = t.Assembly; if (assyList.Contains(assy)) continue; assyList.Add(assy); if (typeResolutionService.GetAssembly(assy.GetName()) == null) typeResolutionService.ReferenceAssembly(assy.GetName()); } assembliesRegistered = true; }
public override object ConvertFrom(ITypeDescriptorContext context, CultureInfo culture, object value) { RegisterAllAssemblies((ITypeResolutionService)context.GetService(typeof(ITypeResolutionService))); return base.ConvertFrom(context, culture, value);
GetStandardValuesExclusive
The list is not exclusive.
GetStandardValuesSupported
Indicate supporting a value list.
KeyMapperTypeNameConverter
This is KeyMapperTypeNameConverter, a member of class KeyMapperTypeNameConverter.


KeyMapperTypeNameConverter.KeyMapperTypeNameConverter Constructor

KeyMapperTypeNameConverter.KeyMapperTypeNameConverter Constructor
KeyMapperTypeNameConverter Class KeyMapperTypeNameConverter Members Eco.Persistence.Design Namespace See Also
Collapse All
C#
public KeyMapperTypeNameConverter();
Remarks

This is KeyMapperTypeNameConverter, a member of class KeyMapperTypeNameConverter.

See Also
KeyMapperTypeNameConverter Class
KeyMapperTypeNameConverter Members
Eco.Persistence.Design Namespace


KeyMapperTypeNameConverter Methods

KeyMapperTypeNameConverter Methods
Protected Methods
Collapse All

The methods of the KeyMapperTypeNameConverter class are listed here.

Protected Methods
Name | Description
MapperList |


KeyMapperTypeNameConverter.MapperList Method

KeyMapperTypeNameConverter.MapperList Method
KeyMapperTypeNameConverter Class KeyMapperTypeNameConverter Members Eco.Persistence.Design Namespace See Also
Collapse All
C#
protected override System.Collections.ICollection MapperList();
Returns

returns MapperTypeRegistry.KeyMapperList.

See Also
KeyMapperTypeNameConverter Class
KeyMapperTypeNameConverter Members
Eco.Persistence.Design Namespace


ManualEditorManipulator Class

ManualEditorManipulator Class
ManualEditorManipulator Members Inheritance Hierarchy See Also
Collapse All

Invokes the connection editor for the TAdoDbxConnection.

C#
internal sealed class ManualEditorManipulator : AbstractManipulator;
Inheritance Hierarchy
Eco.Persistence.Design.ManualEditorManipulator
File

DbxPropertyManipulators.cs

See Also
ManualEditorManipulator Members
Inheritance Hierarchy


ManualEditorManipulator Members

ManualEditorManipulator Members
Public Methods
Collapse All

The following tables list the members exposed by ManualEditorManipulator.

Public Methods
Name | Description
SetPropertyValue | This is SetPropertyValue, a member of class ManualEditorManipulator.


ManualEditorManipulator Methods

ManualEditorManipulator Methods
Public Methods
Collapse All

The methods of the ManualEditorManipulator class are listed here.

Public Methods
Name | Description
SetPropertyValue | This is SetPropertyValue, a member of class ManualEditorManipulator.


ManualEditorManipulator.SetPropertyValue Method

ManualEditorManipulator.SetPropertyValue Method
ManualEditorManipulator Class ManualEditorManipulator Members Eco.Persistence.Design Namespace See Also
Collapse All
C#
public override void SetPropertyValue(
    PropertyParams propertyParams
);
Remarks

This is SetPropertyValue, a member of class ManualEditorManipulator.

See Also
ManualEditorManipulator Class
ManualEditorManipulator Members
Eco.Persistence.Design Namespace


MapperNameConverter Class

MapperNameConverter Class
MapperNameConverter Members Inheritance Hierarchy See Also
Collapse All

This base class supports a non-exclusive drop-down list in the OI.

C#
public abstract class MapperNameConverter : StringConverter;
Inheritance Hierarchy
Eco.Persistence.Design.MapperNameConverter
    Eco.Persistence.Design.KeyMapperNameConverter
    Eco.Persistence.Design.PersistenceMapperNameConverter
File

PersistenceMapperTypeConverter.cs

See Also
MapperNameConverter Members
Inheritance Hierarchy


MapperNameConverter Members

MapperNameConverter Members
Protected Methods Public Methods
Collapse All

The following tables list the members exposed by MapperNameConverter.

Protected Methods
Name | Description
SourceList | Override this method to use a different source list from which to get the names.
Top
Public Methods
Name | Description
GetStandardValues | This is GetStandardValues, a member of class MapperNameConverter.
GetStandardValuesExclusive | The list is not exclusive.
GetStandardValuesSupported | Indicate supporting a value list.


MapperNameConverter Methods

MapperNameConverter Methods
Protected Methods Public Methods
Collapse All

The methods of the MapperNameConverter class are listed here.

Protected Methods
Name | Description
SourceList | Override this method to use a different source list from which to get the names.
Top
Public Methods
Name | Description
GetStandardValues | This is GetStandardValues, a member of class MapperNameConverter.
GetStandardValuesExclusive | The list is not exclusive.
GetStandardValuesSupported | Indicate supporting a value list.


MapperNameConverter.GetStandardValues Method

MapperNameConverter.GetStandardValues Method
MapperNameConverter Class MapperNameConverter Members Eco.Persistence.Design Namespace See Also
Collapse All
C#
public override StandardValuesCollection GetStandardValues(
    ITypeDescriptorContext context
);
Remarks

This is GetStandardValues, a member of class MapperNameConverter.

See Also
MapperNameConverter Class
MapperNameConverter Members
Eco.Persistence.Design Namespace


MapperNameConverter.GetStandardValuesExclusive Method

MapperNameConverter.GetStandardValuesExclusive Method
MapperNameConverter Class MapperNameConverter Members Eco.Persistence.Design Namespace See Also
Collapse All

The list is not exclusive.

C#
public override bool GetStandardValuesExclusive(
    ITypeDescriptorContext context
);
Returns

returns false

See Also
MapperNameConverter Class
MapperNameConverter Members
Eco.Persistence.Design Namespace


MapperNameConverter.GetStandardValuesSupported Method

MapperNameConverter.GetStandardValuesSupported Method
MapperNameConverter Class MapperNameConverter Members Eco.Persistence.Design Namespace See Also
Collapse All

Indicate supporting a value list.

C#
public override bool GetStandardValuesSupported(
    ITypeDescriptorContext context
);
Returns

returns true

See Also
MapperNameConverter Class
MapperNameConverter Members
Eco.Persistence.Design Namespace


MapperNameConverter.SourceList Method

MapperNameConverter.SourceList Method
MapperNameConverter Class MapperNameConverter Members Eco.Persistence.Design Namespace See Also
Collapse All

Override this method to use a different source list from which to get the names.

C#
protected abstract List<MapperDefinition> SourceList();
See Also
MapperNameConverter Class
MapperNameConverter Members
Eco.Persistence.Design Namespace


MapperTypeEditor Class

MapperTypeEditor Class
MapperTypeEditor Members Inheritance Hierarchy See Also
Collapse All

Base class for the mappertype editors. A list of available selections are filled from the type's converter's GetStandardValues method. The list will contain name-type pairs. When a name is selected, the implementing assembly is added to the project's references list.

C#
public class MapperTypeEditor : ObjectSelectorEditor;
Inheritance Hierarchy
Eco.Persistence.Design.MapperTypeEditor
File

PersistenceMapperTypeConverter.cs

See Also
MapperTypeEditor Members
Inheritance Hierarchy


MapperTypeEditor Members

MapperTypeEditor Members
Protected Methods Public Methods Public Properties
Collapse All

The following tables list the members exposed by MapperTypeEditor.

Protected Methods
Name | Description
FillTreeWithData | This is FillTreeWithData, a member of class MapperTypeEditor.
Top
Public Methods
Name | Description
EditValue | Creates the dropdown list, adds all implementing assemblies to the typeresolution service of the IDE.
GetEditStyle | This is GetEditStyle, a member of class MapperTypeEditor.
SetValue | This is SetValue, a member of class MapperTypeEditor.
Top
Public Properties
Name | Description
IsDropDownResizable | This is IsDropDownResizable, a member of class MapperTypeEditor.


MapperTypeEditor Methods

MapperTypeEditor Methods
Protected Methods Public Methods
Collapse All

The methods of the MapperTypeEditor class are listed here.

Protected Methods
Name | Description
FillTreeWithData | This is FillTreeWithData, a member of class MapperTypeEditor.
Top
Public Methods
Name | Description
EditValue | Creates the dropdown list, adds all implementing assemblies to the typeresolution service of the IDE.
GetEditStyle | This is GetEditStyle, a member of class MapperTypeEditor.
SetValue | This is SetValue, a member of class MapperTypeEditor.


MapperTypeEditor.EditValue Method

MapperTypeEditor.EditValue Method
MapperTypeEditor Class MapperTypeEditor Members Eco.Persistence.Design Namespace See Also
Collapse All

Creates the dropdown list, adds all implementing assemblies to the typeresolution service of the IDE.

C#
public override object EditValue(
    ITypeDescriptorContext context,
    IServiceProvider provider,
    object value
);
See Also
MapperTypeEditor Class
MapperTypeEditor Members
Eco.Persistence.Design Namespace


MapperTypeEditor.FillTreeWithData Method

MapperTypeEditor.FillTreeWithData Method
MapperTypeEditor Class MapperTypeEditor Members Eco.Persistence.Design Namespace See Also
Collapse All
C#
protected override void FillTreeWithData(
    ObjectSelectorEditor.Selector selector,
    ITypeDescriptorContext context,
    IServiceProvider provider
);
Remarks

This is FillTreeWithData, a member of class MapperTypeEditor.

See Also
MapperTypeEditor Class
MapperTypeEditor Members
Eco.Persistence.Design Namespace


MapperTypeEditor.GetEditStyle Method

MapperTypeEditor.GetEditStyle Method
MapperTypeEditor Class MapperTypeEditor Members Eco.Persistence.Design Namespace See Also
Collapse All
C#
public override UITypeEditorEditStyle GetEditStyle(
    ITypeDescriptorContext context
);
Remarks

This is GetEditStyle, a member of class MapperTypeEditor.

See Also
MapperTypeEditor Class
MapperTypeEditor Members
Eco.Persistence.Design Namespace


MapperTypeEditor.SetValue Method

MapperTypeEditor.SetValue Method
MapperTypeEditor Class MapperTypeEditor Members Eco.Persistence.Design Namespace See Also
Collapse All
C#
public override void SetValue(
    object value
);
Remarks

This is SetValue, a member of class MapperTypeEditor.

See Also
MapperTypeEditor Class
MapperTypeEditor Members
Eco.Persistence.Design Namespace


MapperTypeEditor Properties

MapperTypeEditor Properties
Public Properties
Collapse All

The properties of the MapperTypeEditor class are listed here.

Public Properties
Name | Description
IsDropDownResizable | This is IsDropDownResizable, a member of class MapperTypeEditor.


MapperTypeEditor.IsDropDownResizable Property

MapperTypeEditor.IsDropDownResizable Property
MapperTypeEditor Class MapperTypeEditor Members Eco.Persistence.Design Namespace See Also
Collapse All
C#
public override bool IsDropDownResizable;
Remarks

This is IsDropDownResizable, a member of class MapperTypeEditor.

See Also
MapperTypeEditor Class
MapperTypeEditor Members
Eco.Persistence.Design Namespace


MapperTypeNameConverter Class

MapperTypeNameConverter Class
MapperTypeNameConverter Members Inheritance Hierarchy See Also
Collapse All

Baseclass for the mapper converters.

C#
public abstract class MapperTypeNameConverter : StringConverter;
Inheritance Hierarchy
Eco.Persistence.Design.MapperTypeNameConverter
    Eco.Persistence.Design.KeyMapperTypeNameConverter
    Eco.Persistence.Design.PersistenceMapperTypeNameConverter
File

PersistenceMapperTypeConverter.cs

See Also
MapperTypeNameConverter Members
Inheritance Hierarchy


MapperTypeNameConverter Members

MapperTypeNameConverter Members
Protected Methods Public Methods
Collapse All

The following tables list the members exposed by MapperTypeNameConverter.

Protected Methods
Name | Description
MapperList | This is MapperList, a member of class MapperTypeNameConverter.
MapperTypeNameConverter | This is MapperTypeNameConverter, a member of class MapperTypeNameConverter.
Top
Public Methods
Name
Description
GetStandardValues
private bool assembliesRegistered = false;
private void RegisterAllAssemblies(ITypeResolutionService typeResolutionService) { if (assembliesRegistered) return; ListassyList = new List(); foreach (System.Type t in MapperList()) { Assembly assy = t.Assembly; if (assyList.Contains(assy)) continue; assyList.Add(assy); if (typeResolutionService.GetAssembly(assy.GetName()) == null) typeResolutionService.ReferenceAssembly(assy.GetName()); } assembliesRegistered = true; }
public override object ConvertFrom(ITypeDescriptorContext context, CultureInfo culture, object value) { RegisterAllAssemblies((ITypeResolutionService)context.GetService(typeof(ITypeResolutionService))); return base.ConvertFrom(context, culture, value);
GetStandardValuesExclusive
The list is not exclusive.
GetStandardValuesSupported
Indicate supporting a value list.


MapperTypeNameConverter.MapperTypeNameConverter Constructor

MapperTypeNameConverter.MapperTypeNameConverter Constructor
MapperTypeNameConverter Class MapperTypeNameConverter Members Eco.Persistence.Design Namespace See Also
Collapse All
C#
protected MapperTypeNameConverter();
Remarks

This is MapperTypeNameConverter, a member of class MapperTypeNameConverter.

See Also
MapperTypeNameConverter Class
MapperTypeNameConverter Members
Eco.Persistence.Design Namespace


MapperTypeNameConverter Methods

MapperTypeNameConverter Methods
Protected Methods Public Methods
Collapse All

The methods of the MapperTypeNameConverter class are listed here.

Protected Methods
Name | Description
MapperList | This is MapperList, a member of class MapperTypeNameConverter.
Top
Public Methods
Name
Description
GetStandardValues
private bool assembliesRegistered = false;
private void RegisterAllAssemblies(ITypeResolutionService typeResolutionService) { if (assembliesRegistered) return; ListassyList = new List(); foreach (System.Type t in MapperList()) { Assembly assy = t.Assembly; if (assyList.Contains(assy)) continue; assyList.Add(assy); if (typeResolutionService.GetAssembly(assy.GetName()) == null) typeResolutionService.ReferenceAssembly(assy.GetName()); } assembliesRegistered = true; }
public override object ConvertFrom(ITypeDescriptorContext context, CultureInfo culture, object value) { RegisterAllAssemblies((ITypeResolutionService)context.GetService(typeof(ITypeResolutionService))); return base.ConvertFrom(context, culture, value);
GetStandardValuesExclusive
The list is not exclusive.
GetStandardValuesSupported
Indicate supporting a value list.


MapperTypeNameConverter.GetStandardValues Method

MapperTypeNameConverter.GetStandardValues Method
MapperTypeNameConverter Class MapperTypeNameConverter Members Eco.Persistence.Design Namespace See Also
Collapse All
C#
public override StandardValuesCollection GetStandardValues(
    ITypeDescriptorContext context
);
Remarks

private bool assembliesRegistered = false;

private void RegisterAllAssemblies(ITypeResolutionService typeResolutionService) { if (assembliesRegistered) return; ListassyList = new List(); foreach (System.Type t in MapperList()) { Assembly assy = t.Assembly; if (assyList.Contains(assy)) continue; assyList.Add(assy); if (typeResolutionService.GetAssembly(assy.GetName()) == null) typeResolutionService.ReferenceAssembly(assy.GetName()); } assembliesRegistered = true; }

public override object ConvertFrom(ITypeDescriptorContext context, CultureInfo culture, object value) { RegisterAllAssemblies((ITypeResolutionService)context.GetService(typeof(ITypeResolutionService))); return base.ConvertFrom(context, culture, value);

See Also
MapperTypeNameConverter Class
MapperTypeNameConverter Members
Eco.Persistence.Design Namespace


MapperTypeNameConverter.GetStandardValuesExclusive Method

MapperTypeNameConverter.GetStandardValuesExclusive Method
MapperTypeNameConverter Class MapperTypeNameConverter Members Eco.Persistence.Design Namespace See Also
Collapse All

The list is not exclusive.

C#
public override bool GetStandardValuesExclusive(
    ITypeDescriptorContext context
);
Returns

returns false

See Also
MapperTypeNameConverter Class
MapperTypeNameConverter Members
Eco.Persistence.Design Namespace


MapperTypeNameConverter.GetStandardValuesSupported Method

MapperTypeNameConverter.GetStandardValuesSupported Method
MapperTypeNameConverter Class MapperTypeNameConverter Members Eco.Persistence.Design Namespace See Also
Collapse All

Indicate supporting a value list.

C#
public override bool GetStandardValuesSupported(
    ITypeDescriptorContext context
);
Returns

returns true

See Also
MapperTypeNameConverter Class
MapperTypeNameConverter Members
Eco.Persistence.Design Namespace


MapperTypeNameConverter.MapperList Method

MapperTypeNameConverter.MapperList Method
MapperTypeNameConverter Class MapperTypeNameConverter Members Eco.Persistence.Design Namespace See Also
Collapse All
C#
protected abstract System.Collections.ICollection MapperList();
Remarks

This is MapperList, a member of class MapperTypeNameConverter.

See Also
MapperTypeNameConverter Class
MapperTypeNameConverter Members
Eco.Persistence.Design Namespace


MapperTypeRegistry Class

MapperTypeRegistry Class
MapperTypeRegistry Members Inheritance Hierarchy See Also
Collapse All

This singleton class contains a list of mappers that will appear in the drop down list of the Mapper property of the PersistenceMapperDefinition.

C#
public class MapperTypeRegistry;
Inheritance Hierarchy
Eco.Persistence.Design.MapperTypeRegistry
File

PersistenceMapperTypeConverter.cs

See Also
MapperTypeRegistry Members
Inheritance Hierarchy


MapperTypeRegistry Members

MapperTypeRegistry Members
Public Methods Public Properties
Collapse All

The following tables list the members exposed by MapperTypeRegistry.

Public Methods
Name | Description
AddAttributeMapper | Adds mappertype to the list. If the type is already in the list nothing happens.
AddKeyMapper | Adds keymappertype to the list. If the type is already in the list nothing happens.
Top
Public Properties
Name | Description
AttributeMapperList | This list is served to the typeconverter to generate the content of the drop down.
KeyMapperList | This list is served to the typeconverter to generate the content of the drop down.


MapperTypeRegistry Methods

MapperTypeRegistry Methods
Public Methods
Collapse All

The methods of the MapperTypeRegistry class are listed here.

Public Methods
Name | Description
AddAttributeMapper | Adds mappertype to the list. If the type is already in the list nothing happens.
AddKeyMapper | Adds keymappertype to the list. If the type is already in the list nothing happens.


MapperTypeRegistry.AddAttributeMapper Method

MapperTypeRegistry.AddAttributeMapper Method
MapperTypeRegistry Class MapperTypeRegistry Members Eco.Persistence.Design Namespace See Also
Collapse All

Adds mappertype to the list. If the type is already in the list nothing happens.

C#
public static void AddAttributeMapper(
    System.Type mapperType
);
Parameters
Parameters | Description
mapperType | The type to add to the list.
See Also
MapperTypeRegistry Class
MapperTypeRegistry Members
Eco.Persistence.Design Namespace


MapperTypeRegistry.AddKeyMapper Method

MapperTypeRegistry.AddKeyMapper Method
MapperTypeRegistry Class MapperTypeRegistry Members Eco.Persistence.Design Namespace See Also
Collapse All

Adds keymappertype to the list. If the type is already in the list nothing happens.

C#
public static void AddKeyMapper(
    System.Type keymapperType
);
Parameters
Parameters | Description
keymapperType | The type to add to the list.
See Also
MapperTypeRegistry Class
MapperTypeRegistry Members
Eco.Persistence.Design Namespace


MapperTypeRegistry Properties

MapperTypeRegistry Properties
Public Properties
Collapse All

The properties of the MapperTypeRegistry class are listed here.

Public Properties
Name | Description
AttributeMapperList | This list is served to the typeconverter to generate the content of the drop down.
KeyMapperList | This list is served to the typeconverter to generate the content of the drop down.


MapperTypeRegistry.AttributeMapperList Property

MapperTypeRegistry.AttributeMapperList Property
MapperTypeRegistry Class MapperTypeRegistry Members Eco.Persistence.Design Namespace See Also
Collapse All

This list is served to the typeconverter to generate the content of the drop down.

C#
public static List<System.Type> AttributeMapperList;
See Also
MapperTypeRegistry Class
MapperTypeRegistry Members
Eco.Persistence.Design Namespace


MapperTypeRegistry.KeyMapperList Property

MapperTypeRegistry.KeyMapperList Property
MapperTypeRegistry Class MapperTypeRegistry Members Eco.Persistence.Design Namespace See Also
Collapse All

This list is served to the typeconverter to generate the content of the drop down.

C#
public static List<System.Type> KeyMapperList;
See Also
MapperTypeRegistry Class
MapperTypeRegistry Members
Eco.Persistence.Design Namespace


MimerConfiguratorMimerClient Class

MimerConfiguratorMimerClient Class
MimerConfiguratorMimerClient Members Inheritance Hierarchy See Also
Collapse All
C#
internal class MimerConfiguratorMimerClient : IMapperVerbConfigurator;
Remarks

This is class Eco.Persistence.Design.MimerConfiguratorMimerClient.

Inheritance Hierarchy
Eco.Persistence.Design.IMapperVerbConfigurator
    Eco.Persistence.Design.MimerConfiguratorMimerClient
File

MapperConfiguratorsMimer.cs

See Also
MimerConfiguratorMimerClient Members
Inheritance Hierarchy


MimerConfiguratorMimerClient Members

MimerConfiguratorMimerClient Members
Public Methods
Collapse All

The following tables list the members exposed by MimerConfiguratorMimerClient.

Public Methods
Name | Description
Caption | The caption of the verb.
ConfigureBackend | Configure SqlDatabaseConfig approprately. This method is called from inside a designer transaction
IsVerbFor | The configurator must decide if it can act in current circumstances
PersistenceMapperType | Return the type of the PersistenceMapper this configurator deals with


MimerConfiguratorMimerClient Methods

MimerConfiguratorMimerClient Methods
Public Methods
Collapse All

The methods of the MimerConfiguratorMimerClient class are listed here.

Public Methods
Name | Description
Caption | The caption of the verb.
ConfigureBackend | Configure SqlDatabaseConfig approprately. This method is called from inside a designer transaction
IsVerbFor | The configurator must decide if it can act in current circumstances
PersistenceMapperType | Return the type of the PersistenceMapper this configurator deals with


MimerConfiguratorMimerClient.Caption Method

MimerConfiguratorMimerClient.Caption Method
MimerConfiguratorMimerClient Class MimerConfiguratorMimerClient Members Eco.Persistence.Design Namespace See Also
Collapse All

The caption of the verb.

C#
public string Caption();
See Also
MimerConfiguratorMimerClient Class
MimerConfiguratorMimerClient Members
Eco.Persistence.Design Namespace


MimerConfiguratorMimerClient.ConfigureBackend Method

MimerConfiguratorMimerClient.ConfigureBackend Method
MimerConfiguratorMimerClient Class MimerConfiguratorMimerClient Members Eco.Persistence.Design Namespace See Also
Collapse All

Configure SqlDatabaseConfig approprately. This method is called from inside a designer transaction

C#
public void ConfigureBackend(
    SqlDatabaseConfig sqlDatabaseConfig
);
See Also
MimerConfiguratorMimerClient Class
MimerConfiguratorMimerClient Members
Eco.Persistence.Design Namespace


MimerConfiguratorMimerClient.IsVerbFor Method

MimerConfiguratorMimerClient.IsVerbFor Method
MimerConfiguratorMimerClient Class MimerConfiguratorMimerClient Members Eco.Persistence.Design Namespace See Also
Collapse All

The configurator must decide if it can act in current circumstances

C#
public bool IsVerbFor(
    Component component
);
See Also
MimerConfiguratorMimerClient Class
MimerConfiguratorMimerClient Members
Eco.Persistence.Design Namespace


MimerConfiguratorMimerClient.PersistenceMapperType Method

MimerConfiguratorMimerClient.PersistenceMapperType Method
MimerConfiguratorMimerClient Class MimerConfiguratorMimerClient Members Eco.Persistence.Design Namespace See Also
Collapse All

Return the type of the PersistenceMapper this configurator deals with

C#
public object PersistenceMapperType();
See Also
MimerConfiguratorMimerClient Class
MimerConfiguratorMimerClient Members
Eco.Persistence.Design Namespace


MimerPersistenceHandleDesigner Class

MimerPersistenceHandleDesigner Class
MimerPersistenceHandleDesigner Members Inheritance Hierarchy See Also
Collapse All
C#
public class MimerPersistenceHandleDesigner : PersistenceHandleDesigner;
Remarks

This is class Eco.Persistence.Design.MimerPersistenceHandleDesigner.

Inheritance Hierarchy
Eco.Persistence.Design.PersistenceHandleDesigner
    Eco.Persistence.Design.MimerPersistenceHandleDesigner
File

PersistenceHandleDesignerMimer.cs

See Also
MimerPersistenceHandleDesigner Members
Inheritance Hierarchy


MimerPersistenceHandleDesigner Members

MimerPersistenceHandleDesigner Members
Protected Methods Public Methods Public Properties Protected Properties
Collapse All

The following tables list the members exposed by MimerPersistenceHandleDesigner.

Protected Methods
Name | Description
Dispose | This method uninstalls the OnComponentRemoved event handler.
OnComponentRemoved | Disconnects the removed component from the designed component.
PersistenceHandleDesigner | This is PersistenceHandleDesigner, a member of class PersistenceHandleDesigner.
Top
Public Methods
Name | Description
Initialize | Initializes the component.
InitializeComponent | Called by the verb handler to initialize the designed component with the configurator.
InitializeNewComponent | This is InitializeNewComponent, a member of class MimerPersistenceHandleDesigner.
MimerPersistenceHandleDesigner | This is MimerPersistenceHandleDesigner, a member of class MimerPersistenceHandleDesigner.
RegisterConfigurator | Registers the configurator in the list of known configurators.
Top
Public Properties
Name | Description
Verbs | Builds the verbs for the designed component.
Top
Protected Properties
Name | Description
MapperVerbConfigurators | This is MapperVerbConfigurators, a member of class PersistenceHandleDesigner.


MimerPersistenceHandleDesigner.MimerPersistenceHandleDesigner Constructor

MimerPersistenceHandleDesigner.MimerPersistenceHandleDesigner Constructor
MimerPersistenceHandleDesigner Class MimerPersistenceHandleDesigner Members Eco.Persistence.Design Namespace See Also
Collapse All
C#
public MimerPersistenceHandleDesigner();
Remarks

This is MimerPersistenceHandleDesigner, a member of class MimerPersistenceHandleDesigner.

See Also
MimerPersistenceHandleDesigner Class
MimerPersistenceHandleDesigner Members
Eco.Persistence.Design Namespace


MimerPersistenceHandleDesigner Methods

MimerPersistenceHandleDesigner Methods
Public Methods
Collapse All

The methods of the MimerPersistenceHandleDesigner class are listed here.

Public Methods
Name | Description
InitializeNewComponent | This is InitializeNewComponent, a member of class MimerPersistenceHandleDesigner.


MimerPersistenceHandleDesigner.InitializeNewComponent Method

MimerPersistenceHandleDesigner.InitializeNewComponent Method
MimerPersistenceHandleDesigner Class MimerPersistenceHandleDesigner Members Eco.Persistence.Design Namespace See Also
Collapse All
C#
public override void InitializeNewComponent(
    IDictionary defaultValues
);
Remarks

This is InitializeNewComponent, a member of class MimerPersistenceHandleDesigner.

See Also
MimerPersistenceHandleDesigner Class
MimerPersistenceHandleDesigner Members
Eco.Persistence.Design Namespace


MySql4Configurator Class

MySql4Configurator Class
MySql4Configurator Members Inheritance Hierarchy See Also
Collapse All
C#
internal class MySql4Configurator : IMapperVerbConfigurator;
Remarks

This is class Eco.Persistence.Design.MySql4Configurator.

Inheritance Hierarchy
Eco.Persistence.Design.IMapperVerbConfigurator
    Eco.Persistence.Design.MySql4Configurator
File

MapperConfiguratorsMySql.cs

See Also
MySql4Configurator Members
Inheritance Hierarchy


MySql4Configurator Members

MySql4Configurator Members
Public Methods
Collapse All

The following tables list the members exposed by MySql4Configurator.

Public Methods
Name | Description
Caption | The caption of the verb.
ConfigureBackend | Configure SqlDatabaseConfig approprately. This method is called from inside a designer transaction
IsVerbFor | The configurator must decide if it can act in current circumstances
PersistenceMapperType | Return the type of the PersistenceMapper this configurator deals with


MySql4Configurator Methods

MySql4Configurator Methods
Public Methods
Collapse All

The methods of the MySql4Configurator class are listed here.

Public Methods
Name | Description
Caption | The caption of the verb.
ConfigureBackend | Configure SqlDatabaseConfig approprately. This method is called from inside a designer transaction
IsVerbFor | The configurator must decide if it can act in current circumstances
PersistenceMapperType | Return the type of the PersistenceMapper this configurator deals with


MySql4Configurator.Caption Method

MySql4Configurator.Caption Method
MySql4Configurator Class MySql4Configurator Members Eco.Persistence.Design Namespace See Also
Collapse All

The caption of the verb.

C#
public string Caption();
See Also
MySql4Configurator Class
MySql4Configurator Members
Eco.Persistence.Design Namespace


MySql4Configurator.ConfigureBackend Method

MySql4Configurator.ConfigureBackend Method
MySql4Configurator Class MySql4Configurator Members Eco.Persistence.Design Namespace See Also
Collapse All

Configure SqlDatabaseConfig approprately. This method is called from inside a designer transaction

C#
public void ConfigureBackend(
    SqlDatabaseConfig sqlDatabaseConfig
);
See Also
MySql4Configurator Class
MySql4Configurator Members
Eco.Persistence.Design Namespace


MySql4Configurator.IsVerbFor Method

MySql4Configurator.IsVerbFor Method
MySql4Configurator Class MySql4Configurator Members Eco.Persistence.Design Namespace See Also
Collapse All

The configurator must decide if it can act in current circumstances

C#
public bool IsVerbFor(
    Component component
);
See Also
MySql4Configurator Class
MySql4Configurator Members
Eco.Persistence.Design Namespace


MySql4Configurator.PersistenceMapperType Method

MySql4Configurator.PersistenceMapperType Method
MySql4Configurator Class MySql4Configurator Members Eco.Persistence.Design Namespace See Also
Collapse All

Return the type of the PersistenceMapper this configurator deals with

C#
public object PersistenceMapperType();
See Also
MySql4Configurator Class
MySql4Configurator Members
Eco.Persistence.Design Namespace


MySql4ConfiguratorBdp Class

MySql4ConfiguratorBdp Class
MySql4ConfiguratorBdp Members Inheritance Hierarchy See Also
Collapse All

Configurator for MySql4Bdp.

C#
internal class MySql4ConfiguratorBdp : EcoBdpConfigurator;
Remarks

This class configures the persistence mapper using the settings for DataBaseEngine.MySql4Bdp.

Inheritance Hierarchy
Eco.Persistence.Design.IMapperVerbConfigurator
    Eco.Persistence.Design.AbstractBdpConfigurator
        Eco.Persistence.Design.EcoBdpConfigurator
            Eco.Persistence.Design.MySql4ConfiguratorBdp
File

MapperConfiguratorsBdp.cs

See Also
MySql4ConfiguratorBdp Members
Inheritance Hierarchy


MySql4ConfiguratorBdp Members

MySql4ConfiguratorBdp Members
Protected Methods Public Methods
Collapse All

The following tables list the members exposed by MySql4ConfiguratorBdp.

Protected Methods
Name | Description
FilterData | This method should return the name of the bdp provider (such as Interbase, MSSQL or Oracle). There can be multiple configurators for the same provider.
Top
Public Methods
Name | Description
Caption | The caption for this instance when used as a designer verb.
ConfigureBackend | Override this method to perform the actual configuration. Modify the settings of sqlDatabaseConfig to suite your needs
ConfigureBackend | Initializes sqlDatabaseConfig using the settings determined by SupportedDataBaseEngine.
ConfigureBackend | Configure SqlDatabaseConfig approprately. This method is called from inside a designer transaction
IsVerbFor | This method determines if the instance is suited for configuring the submitted component.
IsVerbFor | The configurator must decide if it can act in current circumstances
PersistenceMapperType | This method will return typeof(PersistenceMapperBdp)
PersistenceMapperType | Return the type of the PersistenceMapper this configurator deals with
SupportedDataBaseEngine | Override this method to provide the engine enum handled by the configurator.


MySql4ConfiguratorBdp Methods

MySql4ConfiguratorBdp Methods
Protected Methods Public Methods
Collapse All

The methods of the MySql4ConfiguratorBdp class are listed here.

Protected Methods
Name | Description
FilterData | This method should return the name of the bdp provider (such as Interbase, MSSQL or Oracle). There can be multiple configurators for the same provider.
Top
Public Methods
Name | Description
Caption | The caption for this instance when used as a designer verb.
SupportedDataBaseEngine | Override this method to provide the engine enum handled by the configurator.


MySql4ConfiguratorBdp.Caption Method

MySql4ConfiguratorBdp.Caption Method
MySql4ConfiguratorBdp Class MySql4ConfiguratorBdp Members Eco.Persistence.Design Namespace See Also
Collapse All

The caption for this instance when used as a designer verb.

C#
public override string Caption();
See Also
MySql4ConfiguratorBdp Class
MySql4ConfiguratorBdp Members
Eco.Persistence.Design Namespace


MySql4ConfiguratorBdp.FilterData Method

MySql4ConfiguratorBdp.FilterData Method
MySql4ConfiguratorBdp Class MySql4ConfiguratorBdp Members Eco.Persistence.Design Namespace See Also
Collapse All

This method should return the name of the bdp provider (such as Interbase, MSSQL or Oracle). There can be multiple configurators for the same provider.

C#
protected override string FilterData();
Remarks

Own members

See Also
MySql4ConfiguratorBdp Class
MySql4ConfiguratorBdp Members
Eco.Persistence.Design Namespace


MySql4ConfiguratorBdp.SupportedDataBaseEngine Method

MySql4ConfiguratorBdp.SupportedDataBaseEngine Method
MySql4ConfiguratorBdp Class MySql4ConfiguratorBdp Members Eco.Persistence.Design Namespace See Also
Collapse All

Override this method to provide the engine enum handled by the configurator.

C#
public override DataBaseEngine SupportedDataBaseEngine();
See Also
MySql4ConfiguratorBdp Class
MySql4ConfiguratorBdp Members
Eco.Persistence.Design Namespace


MySql4ConfiguratorDbx Class

MySql4ConfiguratorDbx Class
MySql4ConfiguratorDbx Members Inheritance Hierarchy See Also
Collapse All

Configurator for MySql4Dbx.

C#
internal class MySql4ConfiguratorDbx : EcoDbxConfigurator;
Remarks

This class configures the persistence mapper using the settings for DataBaseEngine.MySql4Dbx.

Inheritance Hierarchy
Eco.Persistence.Design.IMapperVerbConfigurator
    Eco.Persistence.Design.AbstractDbxConfigurator
        Eco.Persistence.Design.EcoDbxConfigurator
            Eco.Persistence.Design.MySql4ConfiguratorDbx
File

MapperConfiguratorsDbx.cs

See Also
MySql4ConfiguratorDbx Members
Inheritance Hierarchy


MySql4ConfiguratorDbx Members

MySql4ConfiguratorDbx Members
Protected Methods Public Methods
Collapse All

The following tables list the members exposed by MySql4ConfiguratorDbx.

Protected Methods
Name | Description
FilterData | This method should return the name of the Dbx provider (such as Interbase, MSSQL or Oracle). There can be multiple configurators for the same provider.
Top
Public Methods
Name | Description
Caption | The caption for this instance when used as a designer verb.
ConfigureBackend | Override this method to perform the actual configuration. Modify the settings of sqlDatabaseConfig to suite your needs
ConfigureBackend | Initializes sqlDatabaseConfig using the settings determined by SupportedDataBaseEngine.
ConfigureBackend | Configure SqlDatabaseConfig approprately. This method is called from inside a designer transaction
IsVerbFor | This method determines if the instance is suited for configuring the submitted component.
IsVerbFor | The configurator must decide if it can act in current circumstances
PersistenceMapperType | This method will return typeof(PersistenceMapperDbx)
PersistenceMapperType | Return the type of the PersistenceMapper this configurator deals with
SupportedDataBaseEngine | Override this method to provide the engine enum handled by the configurator.


MySql4ConfiguratorDbx Methods

MySql4ConfiguratorDbx Methods
Protected Methods Public Methods
Collapse All

The methods of the MySql4ConfiguratorDbx class are listed here.

Protected Methods
Name | Description
FilterData | This method should return the name of the Dbx provider (such as Interbase, MSSQL or Oracle). There can be multiple configurators for the same provider.
Top
Public Methods
Name | Description
Caption | The caption for this instance when used as a designer verb.
SupportedDataBaseEngine | Override this method to provide the engine enum handled by the configurator.


MySql4ConfiguratorDbx.Caption Method

MySql4ConfiguratorDbx.Caption Method
MySql4ConfiguratorDbx Class MySql4ConfiguratorDbx Members Eco.Persistence.Design Namespace See Also
Collapse All

The caption for this instance when used as a designer verb.

C#
public override string Caption();
See Also
MySql4ConfiguratorDbx Class
MySql4ConfiguratorDbx Members
Eco.Persistence.Design Namespace


MySql4ConfiguratorDbx.FilterData Method

MySql4ConfiguratorDbx.FilterData Method
MySql4ConfiguratorDbx Class MySql4ConfiguratorDbx Members Eco.Persistence.Design Namespace See Also
Collapse All

This method should return the name of the Dbx provider (such as Interbase, MSSQL or Oracle). There can be multiple configurators for the same provider.

C#
protected override string FilterData();
Remarks

Own members

See Also
MySql4ConfiguratorDbx Class
MySql4ConfiguratorDbx Members
Eco.Persistence.Design Namespace


MySql4ConfiguratorDbx.SupportedDataBaseEngine Method

MySql4ConfiguratorDbx.SupportedDataBaseEngine Method
MySql4ConfiguratorDbx Class MySql4ConfiguratorDbx Members Eco.Persistence.Design Namespace See Also
Collapse All

Override this method to provide the engine enum handled by the configurator.

C#
public override DataBaseEngine SupportedDataBaseEngine();
See Also
MySql4ConfiguratorDbx Class
MySql4ConfiguratorDbx Members
Eco.Persistence.Design Namespace


MySql5Configurator Class

MySql5Configurator Class
MySql5Configurator Members Inheritance Hierarchy See Also
Collapse All
C#
internal class MySql5Configurator : IMapperVerbConfigurator;
Remarks

This is class Eco.Persistence.Design.MySql5Configurator.

Inheritance Hierarchy
Eco.Persistence.Design.IMapperVerbConfigurator
    Eco.Persistence.Design.MySql5Configurator
File

MapperConfiguratorsMySql.cs

See Also
MySql5Configurator Members
Inheritance Hierarchy


MySql5Configurator Members

MySql5Configurator Members
Public Methods
Collapse All

The following tables list the members exposed by MySql5Configurator.

Public Methods
Name | Description
Caption | The caption of the verb.
ConfigureBackend | Configure SqlDatabaseConfig approprately. This method is called from inside a designer transaction
IsVerbFor | The configurator must decide if it can act in current circumstances
PersistenceMapperType | Return the type of the PersistenceMapper this configurator deals with


MySql5Configurator Methods

MySql5Configurator Methods
Public Methods
Collapse All

The methods of the MySql5Configurator class are listed here.

Public Methods
Name | Description
Caption | The caption of the verb.
ConfigureBackend | Configure SqlDatabaseConfig approprately. This method is called from inside a designer transaction
IsVerbFor | The configurator must decide if it can act in current circumstances
PersistenceMapperType | Return the type of the PersistenceMapper this configurator deals with


MySql5Configurator.Caption Method

MySql5Configurator.Caption Method
MySql5Configurator Class MySql5Configurator Members Eco.Persistence.Design Namespace See Also
Collapse All

The caption of the verb.

C#
public string Caption();
See Also
MySql5Configurator Class
MySql5Configurator Members
Eco.Persistence.Design Namespace


MySql5Configurator.ConfigureBackend Method

MySql5Configurator.ConfigureBackend Method
MySql5Configurator Class MySql5Configurator Members Eco.Persistence.Design Namespace See Also
Collapse All

Configure SqlDatabaseConfig approprately. This method is called from inside a designer transaction

C#
public void ConfigureBackend(
    SqlDatabaseConfig sqlDatabaseConfig
);
See Also
MySql5Configurator Class
MySql5Configurator Members
Eco.Persistence.Design Namespace


MySql5Configurator.IsVerbFor Method

MySql5Configurator.IsVerbFor Method
MySql5Configurator Class MySql5Configurator Members Eco.Persistence.Design Namespace See Also
Collapse All

The configurator must decide if it can act in current circumstances

C#
public bool IsVerbFor(
    Component component
);
See Also
MySql5Configurator Class
MySql5Configurator Members
Eco.Persistence.Design Namespace


MySql5Configurator.PersistenceMapperType Method

MySql5Configurator.PersistenceMapperType Method
MySql5Configurator Class MySql5Configurator Members Eco.Persistence.Design Namespace See Also
Collapse All

Return the type of the PersistenceMapper this configurator deals with

C#
public object PersistenceMapperType();
See Also
MySql5Configurator Class
MySql5Configurator Members
Eco.Persistence.Design Namespace


MySql5ConfiguratorBdp Class

MySql5ConfiguratorBdp Class
MySql5ConfiguratorBdp Members Inheritance Hierarchy See Also
Collapse All

Configurator for MySql5Bdp.

C#
internal class MySql5ConfiguratorBdp : EcoBdpConfigurator;
Remarks

This class configures the persistence mapper using the settings for DataBaseEngine.MySql5Bdp.

Inheritance Hierarchy
Eco.Persistence.Design.IMapperVerbConfigurator
    Eco.Persistence.Design.AbstractBdpConfigurator
        Eco.Persistence.Design.EcoBdpConfigurator
            Eco.Persistence.Design.MySql5ConfiguratorBdp
File

MapperConfiguratorsBdp.cs

See Also
MySql5ConfiguratorBdp Members
Inheritance Hierarchy


MySql5ConfiguratorBdp Members

MySql5ConfiguratorBdp Members
Protected Methods Public Methods
Collapse All

The following tables list the members exposed by MySql5ConfiguratorBdp.

Protected Methods
Name | Description
FilterData | This method should return the name of the bdp provider (such as Interbase, MSSQL or Oracle). There can be multiple configurators for the same provider.
Top
Public Methods
Name | Description
Caption | The caption for this instance when used as a designer verb.
ConfigureBackend | Override this method to perform the actual configuration. Modify the settings of sqlDatabaseConfig to suite your needs
ConfigureBackend | Initializes sqlDatabaseConfig using the settings determined by SupportedDataBaseEngine.
ConfigureBackend | Configure SqlDatabaseConfig approprately. This method is called from inside a designer transaction
IsVerbFor | This method determines if the instance is suited for configuring the submitted component.
IsVerbFor | The configurator must decide if it can act in current circumstances
PersistenceMapperType | This method will return typeof(PersistenceMapperBdp)
PersistenceMapperType | Return the type of the PersistenceMapper this configurator deals with
SupportedDataBaseEngine | Override this method to provide the engine enum handled by the configurator.


MySql5ConfiguratorBdp Methods

MySql5ConfiguratorBdp Methods
Protected Methods Public Methods
Collapse All

The methods of the MySql5ConfiguratorBdp class are listed here.

Protected Methods
Name | Description
FilterData | This method should return the name of the bdp provider (such as Interbase, MSSQL or Oracle). There can be multiple configurators for the same provider.
Top
Public Methods
Name | Description
Caption | The caption for this instance when used as a designer verb.
SupportedDataBaseEngine | Override this method to provide the engine enum handled by the configurator.


MySql5ConfiguratorBdp.Caption Method

MySql5ConfiguratorBdp.Caption Method
MySql5ConfiguratorBdp Class MySql5ConfiguratorBdp Members Eco.Persistence.Design Namespace See Also
Collapse All

The caption for this instance when used as a designer verb.

C#
public override string Caption();
See Also
MySql5ConfiguratorBdp Class
MySql5ConfiguratorBdp Members
Eco.Persistence.Design Namespace


MySql5ConfiguratorBdp.FilterData Method

MySql5ConfiguratorBdp.FilterData Method
MySql5ConfiguratorBdp Class MySql5ConfiguratorBdp Members Eco.Persistence.Design Namespace See Also
Collapse All

This method should return the name of the bdp provider (such as Interbase, MSSQL or Oracle). There can be multiple configurators for the same provider.

C#
protected override string FilterData();
Remarks

Own members

See Also
MySql5ConfiguratorBdp Class
MySql5ConfiguratorBdp Members
Eco.Persistence.Design Namespace


MySql5ConfiguratorBdp.SupportedDataBaseEngine Method

MySql5ConfiguratorBdp.SupportedDataBaseEngine Method
MySql5ConfiguratorBdp Class MySql5ConfiguratorBdp Members Eco.Persistence.Design Namespace See Also
Collapse All

Override this method to provide the engine enum handled by the configurator.

C#
public override DataBaseEngine SupportedDataBaseEngine();
See Also
MySql5ConfiguratorBdp Class
MySql5ConfiguratorBdp Members
Eco.Persistence.Design Namespace


MySql5ConfiguratorDbx Class

MySql5ConfiguratorDbx Class
MySql5ConfiguratorDbx Members Inheritance Hierarchy See Also
Collapse All

Configurator for MySql5Dbx.

C#
internal class MySql5ConfiguratorDbx : EcoDbxConfigurator;
Remarks

This class configures the persistence mapper using the settings for DataBaseEngine.MySql5Dbx.

Inheritance Hierarchy
Eco.Persistence.Design.IMapperVerbConfigurator
    Eco.Persistence.Design.AbstractDbxConfigurator
        Eco.Persistence.Design.EcoDbxConfigurator
            Eco.Persistence.Design.MySql5ConfiguratorDbx
File

MapperConfiguratorsDbx.cs

See Also
MySql5ConfiguratorDbx Members
Inheritance Hierarchy


MySql5ConfiguratorDbx Members

MySql5ConfiguratorDbx Members
Protected Methods Public Methods
Collapse All

The following tables list the members exposed by MySql5ConfiguratorDbx.

Protected Methods
Name | Description
FilterData | This method should return the name of the Dbx provider (such as Interbase, MSSQL or Oracle). There can be multiple configurators for the same provider.
Top
Public Methods
Name | Description
Caption | The caption for this instance when used as a designer verb.
ConfigureBackend | Override this method to perform the actual configuration. Modify the settings of sqlDatabaseConfig to suite your needs
ConfigureBackend | Initializes sqlDatabaseConfig using the settings determined by SupportedDataBaseEngine.
ConfigureBackend | Configure SqlDatabaseConfig approprately. This method is called from inside a designer transaction
IsVerbFor | This method determines if the instance is suited for configuring the submitted component.
IsVerbFor | The configurator must decide if it can act in current circumstances
PersistenceMapperType | This method will return typeof(PersistenceMapperDbx)
PersistenceMapperType | Return the type of the PersistenceMapper this configurator deals with
SupportedDataBaseEngine | Override this method to provide the engine enum handled by the configurator.


MySql5ConfiguratorDbx Methods

MySql5ConfiguratorDbx Methods
Protected Methods Public Methods
Collapse All

The methods of the MySql5ConfiguratorDbx class are listed here.

Protected Methods
Name | Description
FilterData | This method should return the name of the Dbx provider (such as Interbase, MSSQL or Oracle). There can be multiple configurators for the same provider.
Top
Public Methods
Name | Description
Caption | The caption for this instance when used as a designer verb.
SupportedDataBaseEngine | Override this method to provide the engine enum handled by the configurator.


MySql5ConfiguratorDbx.Caption Method

MySql5ConfiguratorDbx.Caption Method
MySql5ConfiguratorDbx Class MySql5ConfiguratorDbx Members Eco.Persistence.Design Namespace See Also
Collapse All

The caption for this instance when used as a designer verb.

C#
public override string Caption();
See Also
MySql5ConfiguratorDbx Class
MySql5ConfiguratorDbx Members
Eco.Persistence.Design Namespace


MySql5ConfiguratorDbx.FilterData Method

MySql5ConfiguratorDbx.FilterData Method
MySql5ConfiguratorDbx Class MySql5ConfiguratorDbx Members Eco.Persistence.Design Namespace See Also
Collapse All

This method should return the name of the Dbx provider (such as Interbase, MSSQL or Oracle). There can be multiple configurators for the same provider.

C#
protected override string FilterData();
Remarks

Own members

See Also
MySql5ConfiguratorDbx Class
MySql5ConfiguratorDbx Members
Eco.Persistence.Design Namespace


MySql5ConfiguratorDbx.SupportedDataBaseEngine Method

MySql5ConfiguratorDbx.SupportedDataBaseEngine Method
MySql5ConfiguratorDbx Class MySql5ConfiguratorDbx Members Eco.Persistence.Design Namespace See Also
Collapse All

Override this method to provide the engine enum handled by the configurator.

C#
public override DataBaseEngine SupportedDataBaseEngine();
See Also
MySql5ConfiguratorDbx Class
MySql5ConfiguratorDbx Members
Eco.Persistence.Design Namespace


MySqlPersistenceHandleDesigner Class

MySqlPersistenceHandleDesigner Class
MySqlPersistenceHandleDesigner Members Inheritance Hierarchy See Also
Collapse All
C#
public class MySqlPersistenceHandleDesigner : PersistenceHandleDesigner;
Remarks

This is class Eco.Persistence.Design.MySqlPersistenceHandleDesigner.

Inheritance Hierarchy
Eco.Persistence.Design.PersistenceHandleDesigner
    Eco.Persistence.Design.MySqlPersistenceHandleDesigner
File

PersistenceHandleDesignerMySql.cs

See Also
MySqlPersistenceHandleDesigner Members
Inheritance Hierarchy


MySqlPersistenceHandleDesigner Members

MySqlPersistenceHandleDesigner Members
Protected Methods Public Methods Public Properties Protected Properties
Collapse All

The following tables list the members exposed by MySqlPersistenceHandleDesigner.

Protected Methods
Name | Description
Dispose | This method uninstalls the OnComponentRemoved event handler.
OnComponentRemoved | Disconnects the removed component from the designed component.
PersistenceHandleDesigner | This is PersistenceHandleDesigner, a member of class PersistenceHandleDesigner.
Top
Public Methods
Name | Description
Initialize | Initializes the component.
InitializeComponent | Called by the verb handler to initialize the designed component with the configurator.
InitializeNewComponent | This is InitializeNewComponent, a member of class MySqlPersistenceHandleDesigner.
MySqlPersistenceHandleDesigner | This is MySqlPersistenceHandleDesigner, a member of class MySqlPersistenceHandleDesigner.
RegisterConfigurator | Registers the configurator in the list of known configurators.
Top
Public Properties
Name | Description
Verbs | Builds the verbs for the designed component.
Top
Protected Properties
Name | Description
MapperVerbConfigurators | This is MapperVerbConfigurators, a member of class PersistenceHandleDesigner.


MySqlPersistenceHandleDesigner.MySqlPersistenceHandleDesigner Constructor

MySqlPersistenceHandleDesigner.MySqlPersistenceHandleDesigner Constructor
MySqlPersistenceHandleDesigner Class MySqlPersistenceHandleDesigner Members Eco.Persistence.Design Namespace See Also
Collapse All
C#
public MySqlPersistenceHandleDesigner();
Remarks

This is MySqlPersistenceHandleDesigner, a member of class MySqlPersistenceHandleDesigner.

See Also
MySqlPersistenceHandleDesigner Class
MySqlPersistenceHandleDesigner Members
Eco.Persistence.Design Namespace


MySqlPersistenceHandleDesigner Methods

MySqlPersistenceHandleDesigner Methods
Public Methods
Collapse All

The methods of the MySqlPersistenceHandleDesigner class are listed here.

Public Methods
Name | Description
InitializeNewComponent | This is InitializeNewComponent, a member of class MySqlPersistenceHandleDesigner.


MySqlPersistenceHandleDesigner.InitializeNewComponent Method

MySqlPersistenceHandleDesigner.InitializeNewComponent Method
MySqlPersistenceHandleDesigner Class MySqlPersistenceHandleDesigner Members Eco.Persistence.Design Namespace See Also
Collapse All
C#
public override void InitializeNewComponent(
    IDictionary defaultValues
);
Remarks

This is InitializeNewComponent, a member of class MySqlPersistenceHandleDesigner.

See Also
MySqlPersistenceHandleDesigner Class
MySqlPersistenceHandleDesigner Members
Eco.Persistence.Design Namespace


NewXmlMappingFileNameEditor Class

NewXmlMappingFileNameEditor Class
NewXmlMappingFileNameEditor Members Inheritance Hierarchy See Also
Collapse All

Filename editor for files with extension xml.

C#
public class NewXmlMappingFileNameEditor : FileNameEditor;
Inheritance Hierarchy
Eco.Persistence.Design.NewXmlMappingFileNameEditor
File

FilenameEditors.cs

See Also
NewXmlMappingFileNameEditor Members
Inheritance Hierarchy


NewXmlMappingFileNameEditor Members

NewXmlMappingFileNameEditor Members
Protected Methods
Collapse All

The following tables list the members exposed by NewXmlMappingFileNameEditor.

Protected Methods
Name | Description
InitializeDialog | Initializes the file open dialog.


NewXmlMappingFileNameEditor Methods

NewXmlMappingFileNameEditor Methods
Protected Methods
Collapse All

The methods of the NewXmlMappingFileNameEditor class are listed here.

Protected Methods
Name | Description
InitializeDialog | Initializes the file open dialog.


NewXmlMappingFileNameEditor.InitializeDialog Method

NewXmlMappingFileNameEditor.InitializeDialog Method
NewXmlMappingFileNameEditor Class NewXmlMappingFileNameEditor Members Eco.Persistence.Design Namespace See Also
Collapse All

Initializes the file open dialog.

C#
protected override void InitializeDialog(
    OpenFileDialog openFileDialog
);
Remarks

Refines the openFileDialog to CheckFileExists, sets the title and sets the default extension to xml.

Exceptions
Exceptions | Description
ArgumentNullException | Thrown if openFileDialog is null.
See Also
NewXmlMappingFileNameEditor Class
NewXmlMappingFileNameEditor Members
Eco.Persistence.Design Namespace


OracleConfigurator Class

OracleConfigurator Class
OracleConfigurator Members Inheritance Hierarchy See Also
Collapse All

Configurator for Oracle.

C#
internal class OracleConfigurator : EcoDbxConfigurator;
Remarks

This class configures the persistence mapper using the settings for DataBaseEngine.OracleDbx.

Inheritance Hierarchy
Eco.Persistence.Design.IMapperVerbConfigurator
    Eco.Persistence.Design.AbstractDbxConfigurator
        Eco.Persistence.Design.EcoDbxConfigurator
            Eco.Persistence.Design.OracleConfigurator
File

MapperConfiguratorsDbx.cs

See Also
OracleConfigurator Members
Inheritance Hierarchy


OracleConfigurator Members

OracleConfigurator Members
Protected Methods Public Methods
Collapse All

The following tables list the members exposed by OracleConfigurator.

Protected Methods
Name | Description
FilterData | This method should return the name of the Dbx provider (such as Interbase, MSSQL or Oracle). There can be multiple configurators for the same provider.
Top
Public Methods
Name | Description
Caption | The caption for this instance when used as a designer verb.
ConfigureBackend | Override this method to perform the actual configuration. Modify the settings of sqlDatabaseConfig to suite your needs
ConfigureBackend | Initializes sqlDatabaseConfig using the settings determined by SupportedDataBaseEngine.
ConfigureBackend | Configure SqlDatabaseConfig approprately. This method is called from inside a designer transaction
IsVerbFor | This method determines if the instance is suited for configuring the submitted component.
IsVerbFor | The configurator must decide if it can act in current circumstances
PersistenceMapperType | This method will return typeof(PersistenceMapperDbx)
PersistenceMapperType | Return the type of the PersistenceMapper this configurator deals with
SupportedDataBaseEngine | Override this method to provide the engine enum handled by the configurator.


OracleConfigurator Methods

OracleConfigurator Methods
Protected Methods Public Methods
Collapse All

The methods of the OracleConfigurator class are listed here.

Protected Methods
Name | Description
FilterData | This method should return the name of the Dbx provider (such as Interbase, MSSQL or Oracle). There can be multiple configurators for the same provider.
Top
Public Methods
Name | Description
Caption | The caption for this instance when used as a designer verb.
SupportedDataBaseEngine | Override this method to provide the engine enum handled by the configurator.


OracleConfigurator.Caption Method

OracleConfigurator.Caption Method
OracleConfigurator Class OracleConfigurator Members Eco.Persistence.Design Namespace See Also
Collapse All

The caption for this instance when used as a designer verb.

C#
public override string Caption();
See Also
OracleConfigurator Class
OracleConfigurator Members
Eco.Persistence.Design Namespace


OracleConfigurator.FilterData Method

OracleConfigurator.FilterData Method
OracleConfigurator Class OracleConfigurator Members Eco.Persistence.Design Namespace See Also
Collapse All

This method should return the name of the Dbx provider (such as Interbase, MSSQL or Oracle). There can be multiple configurators for the same provider.

C#
protected override string FilterData();
Remarks

Own members

See Also
OracleConfigurator Class
OracleConfigurator Members
Eco.Persistence.Design Namespace


OracleConfigurator.SupportedDataBaseEngine Method

OracleConfigurator.SupportedDataBaseEngine Method
OracleConfigurator Class OracleConfigurator Members Eco.Persistence.Design Namespace See Also
Collapse All

Override this method to provide the engine enum handled by the configurator.

C#
public override DataBaseEngine SupportedDataBaseEngine();
See Also
OracleConfigurator Class
OracleConfigurator Members
Eco.Persistence.Design Namespace


OracleConfiguratorOracleClient Class

OracleConfiguratorOracleClient Class
OracleConfiguratorOracleClient Members Inheritance Hierarchy See Also
Collapse All
C#
internal class OracleConfiguratorOracleClient : IMapperVerbConfigurator;
Remarks

This is class Eco.Persistence.Design.OracleConfiguratorOracleClient.

Inheritance Hierarchy
Eco.Persistence.Design.IMapperVerbConfigurator
    Eco.Persistence.Design.OracleConfiguratorOracleClient
File

MapperConfiguratorsOracle.cs

See Also
OracleConfiguratorOracleClient Members
Inheritance Hierarchy


OracleConfiguratorOracleClient Members

OracleConfiguratorOracleClient Members
Public Methods
Collapse All

The following tables list the members exposed by OracleConfiguratorOracleClient.

Public Methods
Name | Description
Caption | The caption of the verb.
ConfigureBackend | Configure SqlDatabaseConfig approprately. This method is called from inside a designer transaction
IsVerbFor | The configurator must decide if it can act in current circumstances
PersistenceMapperType | Return the type of the PersistenceMapper this configurator deals with


OracleConfiguratorOracleClient Methods

OracleConfiguratorOracleClient Methods
Public Methods
Collapse All

The methods of the OracleConfiguratorOracleClient class are listed here.

Public Methods
Name | Description
Caption | The caption of the verb.
ConfigureBackend | Configure SqlDatabaseConfig approprately. This method is called from inside a designer transaction
IsVerbFor | The configurator must decide if it can act in current circumstances
PersistenceMapperType | Return the type of the PersistenceMapper this configurator deals with


OracleConfiguratorOracleClient.Caption Method

OracleConfiguratorOracleClient.Caption Method
OracleConfiguratorOracleClient Class OracleConfiguratorOracleClient Members Eco.Persistence.Design Namespace See Also
Collapse All

The caption of the verb.

C#
public string Caption();
See Also
OracleConfiguratorOracleClient Class
OracleConfiguratorOracleClient Members
Eco.Persistence.Design Namespace


OracleConfiguratorOracleClient.ConfigureBackend Method

OracleConfiguratorOracleClient.ConfigureBackend Method
OracleConfiguratorOracleClient Class OracleConfiguratorOracleClient Members Eco.Persistence.Design Namespace See Also
Collapse All

Configure SqlDatabaseConfig approprately. This method is called from inside a designer transaction

C#
public void ConfigureBackend(
    SqlDatabaseConfig sqlDatabaseConfig
);
See Also
OracleConfiguratorOracleClient Class
OracleConfiguratorOracleClient Members
Eco.Persistence.Design Namespace


OracleConfiguratorOracleClient.IsVerbFor Method

OracleConfiguratorOracleClient.IsVerbFor Method
OracleConfiguratorOracleClient Class OracleConfiguratorOracleClient Members Eco.Persistence.Design Namespace See Also
Collapse All

The configurator must decide if it can act in current circumstances

C#
public bool IsVerbFor(
    Component component
);
See Also
OracleConfiguratorOracleClient Class
OracleConfiguratorOracleClient Members
Eco.Persistence.Design Namespace


OracleConfiguratorOracleClient.PersistenceMapperType Method

OracleConfiguratorOracleClient.PersistenceMapperType Method
OracleConfiguratorOracleClient Class OracleConfiguratorOracleClient Members Eco.Persistence.Design Namespace See Also
Collapse All

Return the type of the PersistenceMapper this configurator deals with

C#
public object PersistenceMapperType();
See Also
OracleConfiguratorOracleClient Class
OracleConfiguratorOracleClient Members
Eco.Persistence.Design Namespace


OracleMBCSConfigurator Class

OracleMBCSConfigurator Class
OracleMBCSConfigurator Members Inheritance Hierarchy See Also
Collapse All

Configurator for OracleMBCS.

C#
internal class OracleMBCSConfigurator : EcoDbxConfigurator;
Remarks

This class configures the persistence mapper using the settings for DataBaseEngine.OracleDbxMBCS.

Inheritance Hierarchy
Eco.Persistence.Design.IMapperVerbConfigurator
    Eco.Persistence.Design.AbstractDbxConfigurator
        Eco.Persistence.Design.EcoDbxConfigurator
            Eco.Persistence.Design.OracleMBCSConfigurator
File

MapperConfiguratorsDbx.cs

See Also
OracleMBCSConfigurator Members
Inheritance Hierarchy


OracleMBCSConfigurator Members

OracleMBCSConfigurator Members
Protected Methods Public Methods
Collapse All

The following tables list the members exposed by OracleMBCSConfigurator.

Protected Methods
Name | Description
FilterData | This method should return the name of the Dbx provider (such as Interbase, MSSQL or Oracle). There can be multiple configurators for the same provider.
Top
Public Methods
Name | Description
Caption | The caption for this instance when used as a designer verb.
ConfigureBackend | Override this method to perform the actual configuration. Modify the settings of sqlDatabaseConfig to suite your needs
ConfigureBackend | Initializes sqlDatabaseConfig using the settings determined by SupportedDataBaseEngine.
ConfigureBackend | Configure SqlDatabaseConfig approprately. This method is called from inside a designer transaction
IsVerbFor | This method determines if the instance is suited for configuring the submitted component.
IsVerbFor | The configurator must decide if it can act in current circumstances
PersistenceMapperType | This method will return typeof(PersistenceMapperDbx)
PersistenceMapperType | Return the type of the PersistenceMapper this configurator deals with
SupportedDataBaseEngine | Override this method to provide the engine enum handled by the configurator.


OracleMBCSConfigurator Methods

OracleMBCSConfigurator Methods
Protected Methods Public Methods
Collapse All

The methods of the OracleMBCSConfigurator class are listed here.

Protected Methods
Name | Description
FilterData | This method should return the name of the Dbx provider (such as Interbase, MSSQL or Oracle). There can be multiple configurators for the same provider.
Top
Public Methods
Name | Description
Caption | The caption for this instance when used as a designer verb.
SupportedDataBaseEngine | Override this method to provide the engine enum handled by the configurator.


OracleMBCSConfigurator.Caption Method

OracleMBCSConfigurator.Caption Method
OracleMBCSConfigurator Class OracleMBCSConfigurator Members Eco.Persistence.Design Namespace See Also
Collapse All

The caption for this instance when used as a designer verb.

C#
public override string Caption();
See Also
OracleMBCSConfigurator Class
OracleMBCSConfigurator Members
Eco.Persistence.Design Namespace


OracleMBCSConfigurator.FilterData Method

OracleMBCSConfigurator.FilterData Method
OracleMBCSConfigurator Class OracleMBCSConfigurator Members Eco.Persistence.Design Namespace See Also
Collapse All

This method should return the name of the Dbx provider (such as Interbase, MSSQL or Oracle). There can be multiple configurators for the same provider.

C#
protected override string FilterData();
Remarks

Own members

See Also
OracleMBCSConfigurator Class
OracleMBCSConfigurator Members
Eco.Persistence.Design Namespace


OracleMBCSConfigurator.SupportedDataBaseEngine Method

OracleMBCSConfigurator.SupportedDataBaseEngine Method
OracleMBCSConfigurator Class OracleMBCSConfigurator Members Eco.Persistence.Design Namespace See Also
Collapse All

Override this method to provide the engine enum handled by the configurator.

C#
public override DataBaseEngine SupportedDataBaseEngine();
See Also
OracleMBCSConfigurator Class
OracleMBCSConfigurator Members
Eco.Persistence.Design Namespace


OraclePersistenceHandleDesigner Class

OraclePersistenceHandleDesigner Class
OraclePersistenceHandleDesigner Members Inheritance Hierarchy See Also
Collapse All
C#
public class OraclePersistenceHandleDesigner : PersistenceHandleDesigner;
Remarks

This is class Eco.Persistence.Design.OraclePersistenceHandleDesigner.

Inheritance Hierarchy
Eco.Persistence.Design.PersistenceHandleDesigner
    Eco.Persistence.Design.OraclePersistenceHandleDesigner
File

PersistenceHandleDesignerOracle.cs

See Also
OraclePersistenceHandleDesigner Members
Inheritance Hierarchy


OraclePersistenceHandleDesigner Members

OraclePersistenceHandleDesigner Members
Protected Methods Public Methods Public Properties Protected Properties
Collapse All

The following tables list the members exposed by OraclePersistenceHandleDesigner.

Protected Methods
Name | Description
Dispose | This method uninstalls the OnComponentRemoved event handler.
OnComponentRemoved | Disconnects the removed component from the designed component.
PersistenceHandleDesigner | This is PersistenceHandleDesigner, a member of class PersistenceHandleDesigner.
Top
Public Methods
Name | Description
Initialize | Initializes the component.
InitializeComponent | Called by the verb handler to initialize the designed component with the configurator.
InitializeNewComponent | This is InitializeNewComponent, a member of class OraclePersistenceHandleDesigner.
OraclePersistenceHandleDesigner | This is OraclePersistenceHandleDesigner, a member of class OraclePersistenceHandleDesigner.
RegisterConfigurator | Registers the configurator in the list of known configurators.
Top
Public Properties
Name | Description
Verbs | Builds the verbs for the designed component.
Top
Protected Properties
Name | Description
MapperVerbConfigurators | This is MapperVerbConfigurators, a member of class PersistenceHandleDesigner.


OraclePersistenceHandleDesigner.OraclePersistenceHandleDesigner Constructor

OraclePersistenceHandleDesigner.OraclePersistenceHandleDesigner Constructor
OraclePersistenceHandleDesigner Class OraclePersistenceHandleDesigner Members Eco.Persistence.Design Namespace See Also
Collapse All
C#
public OraclePersistenceHandleDesigner();
Remarks

This is OraclePersistenceHandleDesigner, a member of class OraclePersistenceHandleDesigner.

See Also
OraclePersistenceHandleDesigner Class
OraclePersistenceHandleDesigner Members
Eco.Persistence.Design Namespace


OraclePersistenceHandleDesigner Methods

OraclePersistenceHandleDesigner Methods
Public Methods
Collapse All

The methods of the OraclePersistenceHandleDesigner class are listed here.

Public Methods
Name | Description
InitializeNewComponent | This is InitializeNewComponent, a member of class OraclePersistenceHandleDesigner.


OraclePersistenceHandleDesigner.InitializeNewComponent Method

OraclePersistenceHandleDesigner.InitializeNewComponent Method
OraclePersistenceHandleDesigner Class OraclePersistenceHandleDesigner Members Eco.Persistence.Design Namespace See Also
Collapse All
C#
public override void InitializeNewComponent(
    IDictionary defaultValues
);
Remarks

This is InitializeNewComponent, a member of class OraclePersistenceHandleDesigner.

See Also
OraclePersistenceHandleDesigner Class
OraclePersistenceHandleDesigner Members
Eco.Persistence.Design Namespace


PersistenceHandleDesigner Class

PersistenceHandleDesigner Class
PersistenceHandleDesigner Members Inheritance Hierarchy See Also
Collapse All

Base class designer for the persistence handles.

C#
public class PersistenceHandleDesigner : ComponentDesigner;
Inheritance Hierarchy
Eco.Persistence.Design.PersistenceHandleDesigner
    Eco.Persistence.Design.BdpPersistenceMapperDesigner
    Eco.Persistence.Design.BlackfishPersistenceMapperDesigner
    Eco.Persistence.Design.BlackfishRemotePersistenceMapperDesigner
    Eco.Persistence.Design.DbxPersistenceMapperDesigner
    Eco.Persistence.Design.FirebirdPersistenceMapperDesigner
    Eco.Persistence.Design.MimerPersistenceHandleDesigner
    Eco.Persistence.Design.MySqlPersistenceHandleDesigner
    Eco.Persistence.Design.OraclePersistenceHandleDesigner
    Eco.Persistence.Design.SqlServerPersistenceHandleDesigner
File

PersistenceHandleDesigner.cs

See Also
PersistenceHandleDesigner Members
Inheritance Hierarchy


PersistenceHandleDesigner Members

PersistenceHandleDesigner Members
Protected Methods Public Methods Public Properties Protected Properties
Collapse All

The following tables list the members exposed by PersistenceHandleDesigner.

Protected Methods
Name | Description
Dispose | This method uninstalls the OnComponentRemoved event handler.
OnComponentRemoved | Disconnects the removed component from the designed component.
PersistenceHandleDesigner | This is PersistenceHandleDesigner, a member of class PersistenceHandleDesigner.
Top
Public Methods
Name | Description
Initialize | Initializes the component.
InitializeComponent | Called by the verb handler to initialize the designed component with the configurator.
RegisterConfigurator | Registers the configurator in the list of known configurators.
Top
Public Properties
Name | Description
Verbs | Builds the verbs for the designed component.
Top
Protected Properties
Name | Description
MapperVerbConfigurators | This is MapperVerbConfigurators, a member of class PersistenceHandleDesigner.


PersistenceHandleDesigner.PersistenceHandleDesigner Constructor

PersistenceHandleDesigner.PersistenceHandleDesigner Constructor
PersistenceHandleDesigner Class PersistenceHandleDesigner Members Eco.Persistence.Design Namespace See Also
Collapse All
C#
protected PersistenceHandleDesigner();
Remarks

This is PersistenceHandleDesigner, a member of class PersistenceHandleDesigner.

See Also
PersistenceHandleDesigner Class
PersistenceHandleDesigner Members
Eco.Persistence.Design Namespace


PersistenceHandleDesigner Methods

PersistenceHandleDesigner Methods
Protected Methods Public Methods
Collapse All

The methods of the PersistenceHandleDesigner class are listed here.

Protected Methods
Name | Description
Dispose | This method uninstalls the OnComponentRemoved event handler.
OnComponentRemoved | Disconnects the removed component from the designed component.
Top
Public Methods
Name | Description
Initialize | Initializes the component.
InitializeComponent | Called by the verb handler to initialize the designed component with the configurator.
RegisterConfigurator | Registers the configurator in the list of known configurators.


PersistenceHandleDesigner.Dispose Method

PersistenceHandleDesigner.Dispose Method
PersistenceHandleDesigner Class PersistenceHandleDesigner Members Eco.Persistence.Design Namespace See Also
Collapse All
C#
protected override void Dispose(
    bool disposing
);
Remarks

This method uninstalls the OnComponentRemoved event handler.

See Also
PersistenceHandleDesigner Class
PersistenceHandleDesigner Members
Eco.Persistence.Design Namespace


PersistenceHandleDesigner.Initialize Method

PersistenceHandleDesigner.Initialize Method
PersistenceHandleDesigner Class PersistenceHandleDesigner Members Eco.Persistence.Design Namespace See Also
Collapse All

Initializes the component.

C#
public override void Initialize(
    System.ComponentModel.IComponent component
);
Remarks

This method calls the inherited Initialize and then installs the OnComponentRemoved event handler.

See Also
PersistenceHandleDesigner Class
PersistenceHandleDesigner Members
Eco.Persistence.Design Namespace


PersistenceHandleDesigner.InitializeComponent Method

PersistenceHandleDesigner.InitializeComponent Method
PersistenceHandleDesigner Class PersistenceHandleDesigner Members Eco.Persistence.Design Namespace See Also
Collapse All

Called by the verb handler to initialize the designed component with the configurator.

C#
public void InitializeComponent(
    IMapperVerbConfigurator configurator
);
Parameters
Parameters | Description
configurator | The IMapperVerbConfigurator used to configure the component.
Remarks

When a verb executes, the VerbHandler calls this method with the associated IMapperVerbConfigurator to set up the configuration it specifies.

Exceptions
Exceptions | Description
ArgumentNullException | Thrown if configurator is null.
See Also
PersistenceHandleDesigner Class
PersistenceHandleDesigner Members
Eco.Persistence.Design Namespace


PersistenceHandleDesigner.OnComponentRemoved Method

PersistenceHandleDesigner.OnComponentRemoved Method
PersistenceHandleDesigner Class PersistenceHandleDesigner Members Eco.Persistence.Design Namespace See Also
Collapse All

Disconnects the removed component from the designed component.

C#
protected virtual void OnComponentRemoved(
    object sender,
    ComponentEventArgs e
);
Remarks

The IDE calls this method when a component has been removed. If the removed component is hooked to the designed component as the OldMappingProvider, NewMappingProvider or RunTimeMappingProvider the respective property is set to null.

Exceptions
Exceptions | Description
ArgumentNullException | Thrown if e is null.
See Also
PersistenceHandleDesigner Class
PersistenceHandleDesigner Members
Eco.Persistence.Design Namespace


PersistenceHandleDesigner.RegisterConfigurator Method

PersistenceHandleDesigner.RegisterConfigurator Method
PersistenceHandleDesigner Class PersistenceHandleDesigner Members Eco.Persistence.Design Namespace See Also
Collapse All

Registers the configurator in the list of known configurators.

C#
public static void RegisterConfigurator(
    IMapperVerbConfigurator configurator
);
Parameters
Parameters | Description
configurator | The IMapperVerbConfigurator to register.
Remarks

Adds configurator to the list of known configurators, MapperVerbConfigurators.

See Also
PersistenceHandleDesigner Class
PersistenceHandleDesigner Members
Eco.Persistence.Design Namespace


PersistenceHandleDesigner Properties

PersistenceHandleDesigner Properties
Public Properties Protected Properties
Collapse All

The properties of the PersistenceHandleDesigner class are listed here.

Public Properties
Name | Description
Verbs | Builds the verbs for the designed component.
Top
Protected Properties
Name | Description
MapperVerbConfigurators | This is MapperVerbConfigurators, a member of class PersistenceHandleDesigner.


PersistenceHandleDesigner.MapperVerbConfigurators Property

PersistenceHandleDesigner.MapperVerbConfigurators Property
PersistenceHandleDesigner Class PersistenceHandleDesigner Members Eco.Persistence.Design Namespace See Also
Collapse All
C#
protected static List<IMapperVerbConfigurator> MapperVerbConfigurators;
Remarks

This is MapperVerbConfigurators, a member of class PersistenceHandleDesigner.

See Also
PersistenceHandleDesigner Class
PersistenceHandleDesigner Members
Eco.Persistence.Design Namespace


PersistenceHandleDesigner.Verbs Property

PersistenceHandleDesigner.Verbs Property
PersistenceHandleDesigner Class PersistenceHandleDesigner Members Eco.Persistence.Design Namespace See Also
Collapse All

Builds the verbs for the designed component.

C#
public override DesignerVerbCollection Verbs;
Remarks

The list of verbs is built from the MapperVerbConfigurators list. The list is traversed, and if the configurator IsVerbFor the designed component, a verb is created. The VerbHandler class is responsible for executing the verb.

See Also
PersistenceHandleDesigner Class
PersistenceHandleDesigner Members
Eco.Persistence.Design Namespace


PersistenceMapperDesignerXml Class

PersistenceMapperDesignerXml Class
Inheritance Hierarchy See Also
Collapse All
C#
public class PersistenceMapperDesignerXml : ComponentDesigner;
Remarks

This is class Eco.Persistence.Design.PersistenceMapperDesignerXml.

Inheritance Hierarchy
Eco.Persistence.Design.PersistenceMapperDesignerXml
File

PersistenceMapperDesignerXML.cs

See Also
Inheritance Hierarchy


PersistenceMapperInspector Class

PersistenceMapperInspector Class
PersistenceMapperInspector Members Inheritance Hierarchy See Also
Collapse All

Abstract baseclass to add task sensitive tool tips to PersistenceMapperDb subclasses.

C#
public class PersistenceMapperInspector : Inspector;
Inheritance Hierarchy
Eco.Persistence.Design.PersistenceMapperInspector
File

ComponentInspectorsPersistence.cs

See Also
PersistenceMapperInspector Members
Inheritance Hierarchy


PersistenceMapperInspector Members

PersistenceMapperInspector Members
Public Methods
Collapse All

The following tables list the members exposed by PersistenceMapperInspector.

Public Methods
Name | Description
PersistenceMapperInspector | This is PersistenceMapperInspector, a member of class PersistenceMapperInspector.
RetrieveToolTip | Adds hint strings (as formatted by HintHelper.AddHintString) to the tooltip-to-be.


PersistenceMapperInspector.PersistenceMapperInspector Constructor

PersistenceMapperInspector.PersistenceMapperInspector Constructor
PersistenceMapperInspector Class PersistenceMapperInspector Members Eco.Persistence.Design Namespace See Also
Collapse All
C#
public PersistenceMapperInspector();
Remarks

This is PersistenceMapperInspector, a member of class PersistenceMapperInspector.

See Also
PersistenceMapperInspector Class
PersistenceMapperInspector Members
Eco.Persistence.Design Namespace


PersistenceMapperInspector Methods

PersistenceMapperInspector Methods
Public Methods
Collapse All

The methods of the PersistenceMapperInspector class are listed here.

Public Methods
Name | Description
RetrieveToolTip | Adds hint strings (as formatted by HintHelper.AddHintString) to the tooltip-to-be.


PersistenceMapperInspector.RetrieveToolTip Method

PersistenceMapperInspector.RetrieveToolTip Method
PersistenceMapperInspector Class PersistenceMapperInspector Members Eco.Persistence.Design Namespace See Also
Collapse All

Adds hint strings (as formatted by HintHelper.AddHintString) to the tooltip-to-be.

C#
public override string RetrieveToolTip(
    object component
);
Remarks

The strings added are relevant for any component that is a PersistenceMapperDb.

See Also
PersistenceMapperInspector Class
PersistenceMapperInspector Members
Eco.Persistence.Design Namespace


PersistenceMapperNameConverter Class

PersistenceMapperNameConverter Class
PersistenceMapperNameConverter Members Inheritance Hierarchy See Also
Collapse All

PersistenceMapperNameConverter is the converter for the KeyMapperDefinition.Name property.

C#
public sealed class PersistenceMapperNameConverter : MapperNameConverter;
Returns

returns DatabaseEngineInitializer.AttributeMapperList

Inheritance Hierarchy
Eco.Persistence.Design.MapperNameConverter
    Eco.Persistence.Design.PersistenceMapperNameConverter
File

PersistenceMapperTypeConverter.cs

See Also
PersistenceMapperNameConverter Members
Inheritance Hierarchy


PersistenceMapperNameConverter Members

PersistenceMapperNameConverter Members
Protected Methods Public Methods
Collapse All

The following tables list the members exposed by PersistenceMapperNameConverter.

Protected Methods
Name | Description
SourceList | Override this method to use a different source list from which to get the names.
Top
Public Methods
Name | Description
GetStandardValues | This is GetStandardValues, a member of class MapperNameConverter.
GetStandardValuesExclusive | The list is not exclusive.
GetStandardValuesSupported | Indicate supporting a value list.


PersistenceMapperNameConverter Methods

PersistenceMapperNameConverter Methods
Protected Methods
Collapse All

The methods of the PersistenceMapperNameConverter class are listed here.

Protected Methods
Name | Description
SourceList | Override this method to use a different source list from which to get the names.


PersistenceMapperNameConverter.SourceList Method

PersistenceMapperNameConverter.SourceList Method
PersistenceMapperNameConverter Class PersistenceMapperNameConverter Members Eco.Persistence.Design Namespace See Also
Collapse All

Override this method to use a different source list from which to get the names.

C#
protected override List<MapperDefinition> SourceList();
See Also
PersistenceMapperNameConverter Class
PersistenceMapperNameConverter Members
Eco.Persistence.Design Namespace


PersistenceMapperProviderDesigner Class

PersistenceMapperProviderDesigner Class
PersistenceMapperProviderDesigner Members Inheritance Hierarchy See Also
Collapse All

Designer for PersistenceMapperProvider.

C#
public class PersistenceMapperProviderDesigner : EcoDesigner;
Inheritance Hierarchy
Eco.Persistence.Design.PersistenceMapperProviderDesigner
File

PersistenceMapperProviderDesigner.cs

See Also
PersistenceMapperProviderDesigner Members
Inheritance Hierarchy


PersistenceMapperProviderDesigner Members

PersistenceMapperProviderDesigner Members
Protected Methods Protected Properties
Collapse All

The following tables list the members exposed by PersistenceMapperProviderDesigner.

Protected Methods
Name | Description
ComponentRemoved | Disconnects the designed component from the removed component.
DesignerType | This is DesignerType, a member of class PersistenceMapperProviderDesigner.
LabelCaption | This is LabelCaption, a member of class PersistenceMapperProviderDesigner.
PerformAutoHookup | Hooks up the added component with the designed component.
PersistenceMapperProviderDesigner | This is PersistenceMapperProviderDesigner, a member of class PersistenceMapperProviderDesigner.
Top
Protected Properties
Name | Description
DesignedComponent | This is DesignedComponent, a member of class PersistenceMapperProviderDesigner.


PersistenceMapperProviderDesigner.PersistenceMapperProviderDesigner Constructor

PersistenceMapperProviderDesigner.PersistenceMapperProviderDesigner Constructor
PersistenceMapperProviderDesigner Class PersistenceMapperProviderDesigner Members Eco.Persistence.Design Namespace See Also
Collapse All
C#
protected PersistenceMapperProviderDesigner();
Remarks

This is PersistenceMapperProviderDesigner, a member of class PersistenceMapperProviderDesigner.

See Also
PersistenceMapperProviderDesigner Class
PersistenceMapperProviderDesigner Members
Eco.Persistence.Design Namespace


PersistenceMapperProviderDesigner Methods

PersistenceMapperProviderDesigner Methods
Protected Methods
Collapse All

The methods of the PersistenceMapperProviderDesigner class are listed here.

Protected Methods
Name | Description
ComponentRemoved | Disconnects the designed component from the removed component.
DesignerType | This is DesignerType, a member of class PersistenceMapperProviderDesigner.
LabelCaption | This is LabelCaption, a member of class PersistenceMapperProviderDesigner.
PerformAutoHookup | Hooks up the added component with the designed component.


PersistenceMapperProviderDesigner.ComponentRemoved Method

PersistenceMapperProviderDesigner.ComponentRemoved Method
PersistenceMapperProviderDesigner Class PersistenceMapperProviderDesigner Members Eco.Persistence.Design Namespace See Also
Collapse All

Disconnects the designed component from the removed component.

C#
protected override void ComponentRemoved(
    Component removedComponent
);
See Also
PersistenceMapperProviderDesigner Class
PersistenceMapperProviderDesigner Members
Eco.Persistence.Design Namespace


PersistenceMapperProviderDesigner.DesignerType Method

PersistenceMapperProviderDesigner.DesignerType Method
PersistenceMapperProviderDesigner Class PersistenceMapperProviderDesigner Members Eco.Persistence.Design Namespace See Also
Collapse All
C#
protected override DesignerTypes DesignerType();
Remarks

This is DesignerType, a member of class PersistenceMapperProviderDesigner.

See Also
PersistenceMapperProviderDesigner Class
PersistenceMapperProviderDesigner Members
Eco.Persistence.Design Namespace


PersistenceMapperProviderDesigner.LabelCaption Method

PersistenceMapperProviderDesigner.LabelCaption Method
PersistenceMapperProviderDesigner Class PersistenceMapperProviderDesigner Members Eco.Persistence.Design Namespace See Also
Collapse All
C#
protected override string LabelCaption();
Remarks

This is LabelCaption, a member of class PersistenceMapperProviderDesigner.

See Also
PersistenceMapperProviderDesigner Class
PersistenceMapperProviderDesigner Members
Eco.Persistence.Design Namespace


PersistenceMapperProviderDesigner.PerformAutoHookup Method

PersistenceMapperProviderDesigner.PerformAutoHookup Method
PersistenceMapperProviderDesigner Class PersistenceMapperProviderDesigner Members Eco.Persistence.Design Namespace See Also
Collapse All

Hooks up the added component with the designed component.

C#
protected override void PerformAutoHookup(
    Component addedComponent
);
Remarks

If the added comnponent is a PersistenceMapperDb and the PersistenceMapper of the designed component is not set they will be connected. If the added component is something that the persistence mapper can associate with (typically a connection component) that association will be made if the Connection property is empty.

See Also
PersistenceMapperProviderDesigner Class
PersistenceMapperProviderDesigner Members
Eco.Persistence.Design Namespace


PersistenceMapperProviderDesigner Properties

PersistenceMapperProviderDesigner Properties
Protected Properties
Collapse All

The properties of the PersistenceMapperProviderDesigner class are listed here.

Protected Properties
Name | Description
DesignedComponent | This is DesignedComponent, a member of class PersistenceMapperProviderDesigner.


PersistenceMapperProviderDesigner.DesignedComponent Property

PersistenceMapperProviderDesigner.DesignedComponent Property
PersistenceMapperProviderDesigner Class PersistenceMapperProviderDesigner Members Eco.Persistence.Design Namespace See Also
Collapse All
C#
protected override IComponent DesignedComponent;
Remarks

This is DesignedComponent, a member of class PersistenceMapperProviderDesigner.

See Also
PersistenceMapperProviderDesigner Class
PersistenceMapperProviderDesigner Members
Eco.Persistence.Design Namespace


PersistenceMapperProviderInspector Class

PersistenceMapperProviderInspector Class
PersistenceMapperProviderInspector Members Inheritance Hierarchy See Also
Collapse All

This class adds task sensitive tool tips to PersistenceMapperProvider.

C#
internal sealed class PersistenceMapperProviderInspector : Inspector;
Inheritance Hierarchy
Eco.Persistence.Design.PersistenceMapperProviderInspector
File

ComponentInspectorsPersistence.cs

See Also
PersistenceMapperProviderInspector Members
Inheritance Hierarchy


PersistenceMapperProviderInspector Members

PersistenceMapperProviderInspector Members
Public Methods
Collapse All

The following tables list the members exposed by PersistenceMapperProviderInspector.

Public Methods
Name | Description
PersistenceMapperProviderInspector | This is PersistenceMapperProviderInspector, a member of class PersistenceMapperProviderInspector.
RetrieveToolTip | Adds hint strings (as formatted by HintHelper.AddHintString) to the tooltip-to-be.


PersistenceMapperProviderInspector.PersistenceMapperProviderInspector Constructor

PersistenceMapperProviderInspector.PersistenceMapperProviderInspector Constructor
PersistenceMapperProviderInspector Class PersistenceMapperProviderInspector Members Eco.Persistence.Design Namespace See Also
Collapse All
C#
public PersistenceMapperProviderInspector();
Remarks

This is PersistenceMapperProviderInspector, a member of class PersistenceMapperProviderInspector.

See Also
PersistenceMapperProviderInspector Class
PersistenceMapperProviderInspector Members
Eco.Persistence.Design Namespace


PersistenceMapperProviderInspector Methods

PersistenceMapperProviderInspector Methods
Public Methods
Collapse All

The methods of the PersistenceMapperProviderInspector class are listed here.

Public Methods
Name | Description
RetrieveToolTip | Adds hint strings (as formatted by HintHelper.AddHintString) to the tooltip-to-be.


PersistenceMapperProviderInspector.RetrieveToolTip Method

PersistenceMapperProviderInspector.RetrieveToolTip Method
PersistenceMapperProviderInspector Class PersistenceMapperProviderInspector Members Eco.Persistence.Design Namespace See Also
Collapse All

Adds hint strings (as formatted by HintHelper.AddHintString) to the tooltip-to-be.

C#
public override string RetrieveToolTip(
    object component
);
Remarks

The strings added are relevant for a PersistenceMapperProvider. Note to implementors: Make sure to call base.RetrieveToolTip(component) to get the inherited hints!

See Also
PersistenceMapperProviderInspector Class
PersistenceMapperProviderInspector Members
Eco.Persistence.Design Namespace


PersistenceMapperProviderTypeNameTypeConverter Class

PersistenceMapperProviderTypeNameTypeConverter Class
PersistenceMapperProviderTypeNameTypeConverter Members Inheritance Hierarchy See Also
Collapse All

Type converter used by the MapperType of the PersistenceMapperSharer

C#
public class PersistenceMapperProviderTypeNameTypeConverter : GenericTypeNameConverter;
Inheritance Hierarchy
Eco.Persistence.Design.PersistenceMapperProviderTypeNameTypeConverter
File

PersistenceMapperProviderTypeConverter.cs

See Also
PersistenceMapperProviderTypeNameTypeConverter Members
Inheritance Hierarchy


PersistenceMapperProviderTypeNameTypeConverter Members

PersistenceMapperProviderTypeNameTypeConverter Members
Protected Methods
Collapse All

The following tables list the members exposed by PersistenceMapperProviderTypeNameTypeConverter.

Protected Methods
Name | Description
InternalAccept | This is InternalAccept, a member of class PersistenceMapperProviderTypeNameTypeConverter.


PersistenceMapperProviderTypeNameTypeConverter Methods

PersistenceMapperProviderTypeNameTypeConverter Methods
Protected Methods
Collapse All

The methods of the PersistenceMapperProviderTypeNameTypeConverter class are listed here.

Protected Methods
Name | Description
InternalAccept | This is InternalAccept, a member of class PersistenceMapperProviderTypeNameTypeConverter.


PersistenceMapperProviderTypeNameTypeConverter.InternalAccept Method

PersistenceMapperProviderTypeNameTypeConverter.InternalAccept Method
PersistenceMapperProviderTypeNameTypeConverter Class PersistenceMapperProviderTypeNameTypeConverter Members Eco.Persistence.Design Namespace See Also
Collapse All
C#
protected override bool InternalAccept(
    Type type
);
Remarks

This is InternalAccept, a member of class PersistenceMapperProviderTypeNameTypeConverter.

See Also
PersistenceMapperProviderTypeNameTypeConverter Class
PersistenceMapperProviderTypeNameTypeConverter Members
Eco.Persistence.Design Namespace


PersistenceMapperTypeNameConverter Class

PersistenceMapperTypeNameConverter Class
PersistenceMapperTypeNameConverter Members Inheritance Hierarchy See Also
Collapse All

PersistenceMapperTypeConverter is the converter for the PersistenceMapperDefinition.MapperTypeName property.

C#
public sealed class PersistenceMapperTypeNameConverter : MapperTypeNameConverter;
Inheritance Hierarchy
Eco.Persistence.Design.MapperTypeNameConverter
    Eco.Persistence.Design.PersistenceMapperTypeNameConverter
File

PersistenceMapperTypeConverter.cs

See Also
PersistenceMapperTypeNameConverter Members
Inheritance Hierarchy


PersistenceMapperTypeNameConverter Members

PersistenceMapperTypeNameConverter Members
Protected Methods Public Methods
Collapse All

The following tables list the members exposed by PersistenceMapperTypeNameConverter.

Protected Methods
Name | Description
MapperList | Returns the list of attribute mapper classes making up the standard values.
MapperTypeNameConverter | This is MapperTypeNameConverter, a member of class MapperTypeNameConverter.
Top
Public Methods
Name
Description
GetStandardValues
private bool assembliesRegistered = false;
private void RegisterAllAssemblies(ITypeResolutionService typeResolutionService) { if (assembliesRegistered) return; ListassyList = new List(); foreach (System.Type t in MapperList()) { Assembly assy = t.Assembly; if (assyList.Contains(assy)) continue; assyList.Add(assy); if (typeResolutionService.GetAssembly(assy.GetName()) == null) typeResolutionService.ReferenceAssembly(assy.GetName()); } assembliesRegistered = true; }
public override object ConvertFrom(ITypeDescriptorContext context, CultureInfo culture, object value) { RegisterAllAssemblies((ITypeResolutionService)context.GetService(typeof(ITypeResolutionService))); return base.ConvertFrom(context, culture, value);
GetStandardValuesExclusive
The list is not exclusive.
GetStandardValuesSupported
Indicate supporting a value list.
PersistenceMapperTypeNameConverter
This is PersistenceMapperTypeNameConverter, a member of class PersistenceMapperTypeNameConverter.


PersistenceMapperTypeNameConverter.PersistenceMapperTypeNameConverter Constructor

PersistenceMapperTypeNameConverter.PersistenceMapperTypeNameConverter Constructor
PersistenceMapperTypeNameConverter Class PersistenceMapperTypeNameConverter Members Eco.Persistence.Design Namespace See Also
Collapse All
C#
public PersistenceMapperTypeNameConverter();
Remarks

This is PersistenceMapperTypeNameConverter, a member of class PersistenceMapperTypeNameConverter.

See Also
PersistenceMapperTypeNameConverter Class
PersistenceMapperTypeNameConverter Members
Eco.Persistence.Design Namespace


PersistenceMapperTypeNameConverter Methods

PersistenceMapperTypeNameConverter Methods
Protected Methods
Collapse All

The methods of the PersistenceMapperTypeNameConverter class are listed here.

Protected Methods
Name | Description
MapperList | Returns the list of attribute mapper classes making up the standard values.


PersistenceMapperTypeNameConverter.MapperList Method

PersistenceMapperTypeNameConverter.MapperList Method
PersistenceMapperTypeNameConverter Class PersistenceMapperTypeNameConverter Members Eco.Persistence.Design Namespace See Also
Collapse All

Returns the list of attribute mapper classes making up the standard values.

C#
protected override System.Collections.ICollection MapperList();
Returns

returns MapperTypeRegistry.AttributeMapperList

See Also
PersistenceMapperTypeNameConverter Class
PersistenceMapperTypeNameConverter Members
Eco.Persistence.Design Namespace


PMapperBdpValidator Class

PMapperBdpValidator Class
PMapperBdpValidator Members Inheritance Hierarchy See Also
Collapse All

Validator to check that BdpConnection have relevant properties set.

C#
public class PMapperBdpValidator : IFormValidator;
Inheritance Hierarchy
Eco.Persistence.Design.PMapperBdpValidator
File

ValidateMapperBdp.cs

See Also
PMapperBdpValidator Members
Inheritance Hierarchy


PMapperBdpValidator Members

PMapperBdpValidator Members
Public Methods
Collapse All

The following tables list the members exposed by PMapperBdpValidator.

Public Methods
Name | Description
ValidateComponent | Validates the component.


PMapperBdpValidator Methods

PMapperBdpValidator Methods
Public Methods
Collapse All

The methods of the PMapperBdpValidator class are listed here.

Public Methods
Name | Description
ValidateComponent | Validates the component.


PMapperBdpValidator.ValidateComponent Method

PMapperBdpValidator.ValidateComponent Method
PMapperBdpValidator Class PMapperBdpValidator Members Eco.Persistence.Design Namespace See Also
Collapse All

Validates the component.

C#
public void ValidateComponent(
    FormValidatorArgs args
);
Remarks

Checks that a BdpConnection has the ConnectionString set. Yields a hint.

See Also
PMapperBdpValidator Class
PMapperBdpValidator Members
Eco.Persistence.Design Namespace


PMapperBlackfishValidator Class

PMapperBlackfishValidator Class
PMapperBlackfishValidator Members Inheritance Hierarchy See Also
Collapse All

Validator to check that DatastoreConnection have relevant properties set.

C#
public class PMapperBlackfishValidator : IFormValidator;
Inheritance Hierarchy
Eco.Persistence.Design.PMapperBlackfishValidator
File

ValidateMapperBlackfish.cs

See Also
PMapperBlackfishValidator Members
Inheritance Hierarchy


PMapperBlackfishValidator Members

PMapperBlackfishValidator Members
Public Methods
Collapse All

The following tables list the members exposed by PMapperBlackfishValidator.

Public Methods
Name | Description
ValidateComponent | Validates the component.


PMapperBlackfishValidator Methods

PMapperBlackfishValidator Methods
Public Methods
Collapse All

The methods of the PMapperBlackfishValidator class are listed here.

Public Methods
Name | Description
ValidateComponent | Validates the component.


PMapperBlackfishValidator.ValidateComponent Method

PMapperBlackfishValidator.ValidateComponent Method
PMapperBlackfishValidator Class PMapperBlackfishValidator Members Eco.Persistence.Design Namespace See Also
Collapse All

Validates the component.

C#
public void ValidateComponent(
    FormValidatorArgs args
);
Remarks

Checks that a DataStoreConnection has the ConnectionString set. Yields a hint.

See Also
PMapperBlackfishValidator Class
PMapperBlackfishValidator Members
Eco.Persistence.Design Namespace


PMapperCreatorHandlerPMP Class

PMapperCreatorHandlerPMP Class
PMapperCreatorHandlerPMP Members Inheritance Hierarchy See Also
Collapse All
C#
public class PMapperCreatorHandlerPMP : PMapperCreatorHandler;
Remarks

This is class Eco.Persistence.Design.PMapperCreatorHandlerPMP.

Inheritance Hierarchy
Eco.Persistence.Design.PMapperCreatorHandlerPMP
File

PMapperSelector_PMP.cs

See Also
PMapperCreatorHandlerPMP Members
Inheritance Hierarchy


PMapperCreatorHandlerPMP Members

PMapperCreatorHandlerPMP Members
Protected Methods Public Methods
Collapse All

The following tables list the members exposed by PMapperCreatorHandlerPMP.

Protected Methods
Name | Description
ValidHotspot | This is ValidHotspot, a member of class PMapperCreatorHandlerPMP.
Top
Public Methods
Name | Description
IDERegister | This is IDERegister, a member of class PMapperCreatorHandlerPMP.
PMapperCreatorHandlerPMP | This is PMapperCreatorHandlerPMP, a member of class PMapperCreatorHandlerPMP.


PMapperCreatorHandlerPMP.PMapperCreatorHandlerPMP Constructor

PMapperCreatorHandlerPMP.PMapperCreatorHandlerPMP Constructor
PMapperCreatorHandlerPMP Class PMapperCreatorHandlerPMP Members Eco.Persistence.Design Namespace See Also
Collapse All
C#
public PMapperCreatorHandlerPMP();
Remarks

This is PMapperCreatorHandlerPMP, a member of class PMapperCreatorHandlerPMP.

See Also
PMapperCreatorHandlerPMP Class
PMapperCreatorHandlerPMP Members
Eco.Persistence.Design Namespace


PMapperCreatorHandlerPMP Methods

PMapperCreatorHandlerPMP Methods
Protected Methods Public Methods
Collapse All

The methods of the PMapperCreatorHandlerPMP class are listed here.

Protected Methods
Name | Description
ValidHotspot | This is ValidHotspot, a member of class PMapperCreatorHandlerPMP.
Top
Public Methods
Name | Description
IDERegister | This is IDERegister, a member of class PMapperCreatorHandlerPMP.


PMapperCreatorHandlerPMP.IDERegister Method

PMapperCreatorHandlerPMP.IDERegister Method
PMapperCreatorHandlerPMP Class PMapperCreatorHandlerPMP Members Eco.Persistence.Design Namespace See Also
Collapse All
C#
public static void IDERegister();
Remarks

This is IDERegister, a member of class PMapperCreatorHandlerPMP.

See Also
PMapperCreatorHandlerPMP Class
PMapperCreatorHandlerPMP Members
Eco.Persistence.Design Namespace


PMapperCreatorHandlerPMP.ValidHotspot Method

PMapperCreatorHandlerPMP.ValidHotspot Method
PMapperCreatorHandlerPMP Class PMapperCreatorHandlerPMP Members Eco.Persistence.Design Namespace See Also
Collapse All
C#
protected override bool ValidHotspot(
    DesignerData designerData
);
Remarks

This is ValidHotspot, a member of class PMapperCreatorHandlerPMP.

See Also
PMapperCreatorHandlerPMP Class
PMapperCreatorHandlerPMP Members
Eco.Persistence.Design Namespace


PMapperDbxValidator Class

PMapperDbxValidator Class
PMapperDbxValidator Members Inheritance Hierarchy See Also
Collapse All

Validator to check that TAdoDbxConnection have relevant properties set.

C#
public class PMapperDbxValidator : IFormValidator;
Inheritance Hierarchy
Eco.Persistence.Design.PMapperDbxValidator
File

ValidateMapperDbx.cs

See Also
PMapperDbxValidator Members
Inheritance Hierarchy


PMapperDbxValidator Members

PMapperDbxValidator Members
Public Methods
Collapse All

The following tables list the members exposed by PMapperDbxValidator.

Public Methods
Name | Description
ValidateComponent | Validates the component.


PMapperDbxValidator Methods

PMapperDbxValidator Methods
Public Methods
Collapse All

The methods of the PMapperDbxValidator class are listed here.

Public Methods
Name | Description
ValidateComponent | Validates the component.


PMapperDbxValidator.ValidateComponent Method

PMapperDbxValidator.ValidateComponent Method
PMapperDbxValidator Class PMapperDbxValidator Members Eco.Persistence.Design Namespace See Also
Collapse All

Validates the component.

C#
public void ValidateComponent(
    FormValidatorArgs args
);
Remarks

Checks that a TAdoDbxConnection has the ConnectionString set. Yields a hint.

See Also
PMapperDbxValidator Class
PMapperDbxValidator Members
Eco.Persistence.Design Namespace


PMapperFirebirdValidator Class

PMapperFirebirdValidator Class
PMapperFirebirdValidator Members Inheritance Hierarchy See Also
Collapse All

Validator to check that FirebirdConnection have relevant properties set.

C#
public class PMapperFirebirdValidator : IFormValidator;
Inheritance Hierarchy
Eco.Persistence.Design.PMapperFirebirdValidator
File

ValidateMapperFirebird.cs

See Also
PMapperFirebirdValidator Members
Inheritance Hierarchy


PMapperFirebirdValidator Members

PMapperFirebirdValidator Members
Public Methods
Collapse All

The following tables list the members exposed by PMapperFirebirdValidator.

Public Methods
Name | Description
ValidateComponent | Validates the component.


PMapperFirebirdValidator Methods

PMapperFirebirdValidator Methods
Public Methods
Collapse All

The methods of the PMapperFirebirdValidator class are listed here.

Public Methods
Name | Description
ValidateComponent | Validates the component.


PMapperFirebirdValidator.ValidateComponent Method

PMapperFirebirdValidator.ValidateComponent Method
PMapperFirebirdValidator Class PMapperFirebirdValidator Members Eco.Persistence.Design Namespace See Also
Collapse All

Validates the component.

C#
public void ValidateComponent(
    FormValidatorArgs args
);
Remarks

Checks that a FirebirdConnection has the ConnectionString set. Yields a hint.

See Also
PMapperFirebirdValidator Class
PMapperFirebirdValidator Members
Eco.Persistence.Design Namespace


PMapperMimerValidator Class

PMapperMimerValidator Class
PMapperMimerValidator Members Inheritance Hierarchy See Also
Collapse All

Validator to check that MimerConnection have relevant properties set.

C#
public class PMapperMimerValidator : IFormValidator;
Inheritance Hierarchy
Eco.Persistence.Design.PMapperMimerValidator
File

ValidateMapperMimer.cs

See Also
PMapperMimerValidator Members
Inheritance Hierarchy


PMapperMimerValidator Members

PMapperMimerValidator Members
Public Methods
Collapse All

The following tables list the members exposed by PMapperMimerValidator.

Public Methods
Name | Description
ValidateComponent | Validates the component.


PMapperMimerValidator Methods

PMapperMimerValidator Methods
Public Methods
Collapse All

The methods of the PMapperMimerValidator class are listed here.

Public Methods
Name | Description
ValidateComponent | Validates the component.


PMapperMimerValidator.ValidateComponent Method

PMapperMimerValidator.ValidateComponent Method
PMapperMimerValidator Class PMapperMimerValidator Members Eco.Persistence.Design Namespace See Also
Collapse All

Validates the component.

C#
public void ValidateComponent(
    FormValidatorArgs args
);
Remarks

Checks that a MimerConnection has the ConnectionString set. Yields a hint.

See Also
PMapperMimerValidator Class
PMapperMimerValidator Members
Eco.Persistence.Design Namespace


PMapperOracleValidator Class

PMapperOracleValidator Class
PMapperOracleValidator Members Inheritance Hierarchy See Also
Collapse All

Validator to check that OracleConnection have relevant properties set.

C#
public class PMapperOracleValidator : IFormValidator;
Inheritance Hierarchy
Eco.Persistence.Design.PMapperOracleValidator
File

ValidateMapperOracle.cs

See Also
PMapperOracleValidator Members
Inheritance Hierarchy


PMapperOracleValidator Members

PMapperOracleValidator Members
Public Methods
Collapse All

The following tables list the members exposed by PMapperOracleValidator.

Public Methods
Name | Description
ValidateComponent | Validates the component.


PMapperOracleValidator Methods

PMapperOracleValidator Methods
Public Methods
Collapse All

The methods of the PMapperOracleValidator class are listed here.

Public Methods
Name | Description
ValidateComponent | Validates the component.


PMapperOracleValidator.ValidateComponent Method

PMapperOracleValidator.ValidateComponent Method
PMapperOracleValidator Class PMapperOracleValidator Members Eco.Persistence.Design Namespace See Also
Collapse All

Validates the component.

C#
public void ValidateComponent(
    FormValidatorArgs args
);
Remarks

Checks that a OracleConnection has the ConnectionString set. Yields a hint.

See Also
PMapperOracleValidator Class
PMapperOracleValidator Members
Eco.Persistence.Design Namespace


PMapperSqlServerValidator Class

PMapperSqlServerValidator Class
PMapperSqlServerValidator Members Inheritance Hierarchy See Also
Collapse All

Validator to check that SqlConnection have relevant properties set.

C#
public class PMapperSqlServerValidator : IFormValidator;
Inheritance Hierarchy
Eco.Persistence.Design.PMapperSqlServerValidator
File

ValidateMapperSqlServer.cs

See Also
PMapperSqlServerValidator Members
Inheritance Hierarchy


PMapperSqlServerValidator Members

PMapperSqlServerValidator Members
Public Methods
Collapse All

The following tables list the members exposed by PMapperSqlServerValidator.

Public Methods
Name | Description
ValidateComponent | Validates the component.


PMapperSqlServerValidator Methods

PMapperSqlServerValidator Methods
Public Methods
Collapse All

The methods of the PMapperSqlServerValidator class are listed here.

Public Methods
Name | Description
ValidateComponent | Validates the component.


PMapperSqlServerValidator.ValidateComponent Method

PMapperSqlServerValidator.ValidateComponent Method
PMapperSqlServerValidator Class PMapperSqlServerValidator Members Eco.Persistence.Design Namespace See Also
Collapse All

Validates the component.

C#
public void ValidateComponent(
    FormValidatorArgs args
);
Remarks

Checks that a SqlConnection has the ConnectionString set. Yields a hint.

See Also
PMapperSqlServerValidator Class
PMapperSqlServerValidator Members
Eco.Persistence.Design Namespace


PMapperValidator Class

PMapperValidator Class
PMapperValidator Members Inheritance Hierarchy See Also
Collapse All

Validator to check that pmappers have relevant properties set.

C#
public class PMapperValidator : IFormValidator;
Inheritance Hierarchy
Eco.Persistence.Design.PMapperValidator
File

ValidateMapper.cs

See Also
PMapperValidator Members
Inheritance Hierarchy


PMapperValidator Members

PMapperValidator Members
Public Methods
Collapse All

The following tables list the members exposed by PMapperValidator.

Public Methods
Name | Description
IDERegister | Registers the IFormValidator.
ValidateComponent | Validates the component.


PMapperValidator Methods

PMapperValidator Methods
Public Methods
Collapse All

The methods of the PMapperValidator class are listed here.

Public Methods
Name | Description
IDERegister | Registers the IFormValidator.
ValidateComponent | Validates the component.


PMapperValidator.IDERegister Method

PMapperValidator.IDERegister Method
PMapperValidator Class PMapperValidator Members Eco.Persistence.Design Namespace See Also
Collapse All

Registers the IFormValidator.

C#
public static void IDERegister();
See Also
PMapperValidator Class
PMapperValidator Members
Eco.Persistence.Design Namespace


PMapperValidator.ValidateComponent Method

PMapperValidator.ValidateComponent Method
PMapperValidator Class PMapperValidator Members Eco.Persistence.Design Namespace See Also
Collapse All

Validates the component.

C#
public void ValidateComponent(
    FormValidatorArgs args
);
Remarks

Checks that a PersistenceMapperDb has Connection. Yields a hint. Checks that the SqlDatabaseConfig is initialized. Yields a warning.

See Also
PMapperValidator Class
PMapperValidator Members
Eco.Persistence.Design Namespace


PMapperXmlValidator Class

PMapperXmlValidator Class
PMapperXmlValidator Members Inheritance Hierarchy See Also
Collapse All

Validator to check that XmlMapper have relevant properties set.

C#
public class PMapperXmlValidator : IFormValidator;
Inheritance Hierarchy
Eco.Persistence.Design.PMapperXmlValidator
File

ValidateMapperXml.cs

See Also
PMapperXmlValidator Members
Inheritance Hierarchy


PMapperXmlValidator Members

PMapperXmlValidator Members
Public Methods
Collapse All

The following tables list the members exposed by PMapperXmlValidator.

Public Methods
Name | Description
ValidateComponent | Validates the component.


PMapperXmlValidator Methods

PMapperXmlValidator Methods
Public Methods
Collapse All

The methods of the PMapperXmlValidator class are listed here.

Public Methods
Name | Description
ValidateComponent | Validates the component.


PMapperXmlValidator.ValidateComponent Method

PMapperXmlValidator.ValidateComponent Method
PMapperXmlValidator Class PMapperXmlValidator Members Eco.Persistence.Design Namespace See Also
Collapse All

Validates the component.

C#
public void ValidateComponent(
    FormValidatorArgs args
);
Remarks

Checks that the FileName property is not empty. Adds a hint if so.

See Also
PMapperXmlValidator Class
PMapperXmlValidator Members
Eco.Persistence.Design Namespace


Registration Class

Registration Class
Registration Members Inheritance Hierarchy See Also
Collapse All

Singleton class used to perform design time initialization code.

C#
public sealed class Registration;
Inheritance Hierarchy
Eco.Persistence.Design.Registration
File

IDERegister.cs

See Also
Registration Members
Inheritance Hierarchy


Registration Members

Registration Members
Public Methods
Collapse All

The following tables list the members exposed by Registration.

Public Methods
Name | Description
IDERegister | Called during IDE startup to execute initialization code.


Registration Methods

Registration Methods
Public Methods
Collapse All

The methods of the Registration class are listed here.

Public Methods
Name | Description
IDERegister | Called during IDE startup to execute initialization code.


Registration.IDERegister Method

Registration.IDERegister Method
Registration Class Registration Members Eco.Persistence.Design Namespace See Also
Collapse All

Called during IDE startup to execute initialization code.

C#
public static void IDERegister();
See Also
Registration Class
Registration Members
Eco.Persistence.Design Namespace


SaveMappingInfoTool Class

SaveMappingInfoTool Class
SaveMappingInfoTool Members Inheritance Hierarchy See Also
Collapse All

This tool saves the mapping information to the database.

C#
public class SaveMappingInfoTool : DBToolBase;
Inheritance Hierarchy
Eco.Persistence.Design.DBToolBase
    Eco.Persistence.Design.SaveMappingInfoTool
File

EcoSpaceDesignerToolsDb.cs

See Also
SaveMappingInfoTool Members
Inheritance Hierarchy


SaveMappingInfoTool Members

SaveMappingInfoTool Members
Protected Methods Public Methods
Collapse All

The following tables list the members exposed by SaveMappingInfoTool.

Protected Methods
Name | Description
DoExecute | Saves the mapping information.
GetMessageCaption | Returns the string used as prefix when logging messages for this tool
GetPersistenceMapper | Returns the persistence mapper associated with the active designer.
GetTypeSystemService | Returns the ITypeSystemService associated with the active designer.
Top
Public Methods
Name | Description
Execute | The execute method is a wrapper for DoExecute.
GetCaption |
GetDesignerTypes | Specifies which designer types this tool is associated with.


SaveMappingInfoTool Methods

SaveMappingInfoTool Methods
Protected Methods Public Methods
Collapse All

The methods of the SaveMappingInfoTool class are listed here.

Protected Methods
Name | Description
DoExecute | Saves the mapping information.
GetMessageCaption | Returns the string used as prefix when logging messages for this tool
Top
Public Methods
Name | Description
GetCaption |


SaveMappingInfoTool.DoExecute Method

SaveMappingInfoTool.DoExecute Method
SaveMappingInfoTool Class SaveMappingInfoTool Members Eco.Persistence.Design Namespace See Also
Collapse All

Saves the mapping information.

C#
protected override void DoExecute(
    ExecuteArgs executeArgs
);
Remarks

This tool saves the information about how classes are mapped to tables to the database. The actual work is performed by PersistenceMapperDb.SaveMappingInfo.

This tool needs a fully configured PersistenceMapperDb connected to the ecospace to complete its operation.

See Also
SaveMappingInfoTool Class
SaveMappingInfoTool Members
Eco.Persistence.Design Namespace


SaveMappingInfoTool.GetCaption Method

SaveMappingInfoTool.GetCaption Method
SaveMappingInfoTool Class SaveMappingInfoTool Members Eco.Persistence.Design Namespace See Also
Collapse All
C#
public override string GetCaption();
See Also
SaveMappingInfoTool Class
SaveMappingInfoTool Members
Eco.Persistence.Design Namespace


SaveMappingInfoTool.GetMessageCaption Method

SaveMappingInfoTool.GetMessageCaption Method
SaveMappingInfoTool Class SaveMappingInfoTool Members Eco.Persistence.Design Namespace See Also
Collapse All

Returns the string used as prefix when logging messages for this tool

C#
protected override string GetMessageCaption();
See Also
SaveMappingInfoTool Class
SaveMappingInfoTool Members
Eco.Persistence.Design Namespace


SQLServer7ConfiguratorBdp Class

SQLServer7ConfiguratorBdp Class
SQLServer7ConfiguratorBdp Members Inheritance Hierarchy See Also
Collapse All

Configurator for SqlServer7Bdp.

C#
internal class SQLServer7ConfiguratorBdp : EcoBdpConfigurator;
Remarks

This class configures the persistence mapper using the settings for DataBaseEngine.SqlServer7Bdp.

Inheritance Hierarchy
Eco.Persistence.Design.IMapperVerbConfigurator
    Eco.Persistence.Design.AbstractBdpConfigurator
        Eco.Persistence.Design.EcoBdpConfigurator
            Eco.Persistence.Design.SQLServer7ConfiguratorBdp
File

MapperConfiguratorsBdp.cs

See Also
SQLServer7ConfiguratorBdp Members
Inheritance Hierarchy


SQLServer7ConfiguratorBdp Members

SQLServer7ConfiguratorBdp Members
Protected Methods Public Methods
Collapse All

The following tables list the members exposed by SQLServer7ConfiguratorBdp.

Protected Methods
Name | Description
FilterData | This method should return the name of the bdp provider (such as Interbase, MSSQL or Oracle). There can be multiple configurators for the same provider.
Top
Public Methods
Name | Description
Caption | The caption for this instance when used as a designer verb.
ConfigureBackend | Override this method to perform the actual configuration. Modify the settings of sqlDatabaseConfig to suite your needs
ConfigureBackend | Initializes sqlDatabaseConfig using the settings determined by SupportedDataBaseEngine.
ConfigureBackend | Configure SqlDatabaseConfig approprately. This method is called from inside a designer transaction
IsVerbFor | This method determines if the instance is suited for configuring the submitted component.
IsVerbFor | The configurator must decide if it can act in current circumstances
PersistenceMapperType | This method will return typeof(PersistenceMapperBdp)
PersistenceMapperType | Return the type of the PersistenceMapper this configurator deals with
SupportedDataBaseEngine | Override this method to provide the engine enum handled by the configurator.


SQLServer7ConfiguratorBdp Methods

SQLServer7ConfiguratorBdp Methods
Protected Methods Public Methods
Collapse All

The methods of the SQLServer7ConfiguratorBdp class are listed here.

Protected Methods
Name | Description
FilterData | This method should return the name of the bdp provider (such as Interbase, MSSQL or Oracle). There can be multiple configurators for the same provider.
Top
Public Methods
Name | Description
Caption | The caption for this instance when used as a designer verb.
SupportedDataBaseEngine | Override this method to provide the engine enum handled by the configurator.


SQLServer7ConfiguratorBdp.Caption Method

SQLServer7ConfiguratorBdp.Caption Method
SQLServer7ConfiguratorBdp Class SQLServer7ConfiguratorBdp Members Eco.Persistence.Design Namespace See Also
Collapse All

The caption for this instance when used as a designer verb.

C#
public override string Caption();
See Also
SQLServer7ConfiguratorBdp Class
SQLServer7ConfiguratorBdp Members
Eco.Persistence.Design Namespace


SQLServer7ConfiguratorBdp.FilterData Method

SQLServer7ConfiguratorBdp.FilterData Method
SQLServer7ConfiguratorBdp Class SQLServer7ConfiguratorBdp Members Eco.Persistence.Design Namespace See Also
Collapse All

This method should return the name of the bdp provider (such as Interbase, MSSQL or Oracle). There can be multiple configurators for the same provider.

C#
protected override string FilterData();
Remarks

Own members

See Also
SQLServer7ConfiguratorBdp Class
SQLServer7ConfiguratorBdp Members
Eco.Persistence.Design Namespace


SQLServer7ConfiguratorBdp.SupportedDataBaseEngine Method

SQLServer7ConfiguratorBdp.SupportedDataBaseEngine Method
SQLServer7ConfiguratorBdp Class SQLServer7ConfiguratorBdp Members Eco.Persistence.Design Namespace See Also
Collapse All

Override this method to provide the engine enum handled by the configurator.

C#
public override DataBaseEngine SupportedDataBaseEngine();
See Also
SQLServer7ConfiguratorBdp Class
SQLServer7ConfiguratorBdp Members
Eco.Persistence.Design Namespace


SQLServer7ConfiguratorBdpMBCS Class

SQLServer7ConfiguratorBdpMBCS Class
SQLServer7ConfiguratorBdpMBCS Members Inheritance Hierarchy See Also
Collapse All

Configurator for SqlServer7MBCSBdp.

C#
internal class SQLServer7ConfiguratorBdpMBCS : EcoBdpConfigurator;
Remarks

This class configures the persistence mapper using the settings for DataBaseEngine.SqlServer7MBCSBdp.

Inheritance Hierarchy
Eco.Persistence.Design.IMapperVerbConfigurator
    Eco.Persistence.Design.AbstractBdpConfigurator
        Eco.Persistence.Design.EcoBdpConfigurator
            Eco.Persistence.Design.SQLServer7ConfiguratorBdpMBCS
File

MapperConfiguratorsBdp.cs

See Also
SQLServer7ConfiguratorBdpMBCS Members
Inheritance Hierarchy


SQLServer7ConfiguratorBdpMBCS Members

SQLServer7ConfiguratorBdpMBCS Members
Protected Methods Public Methods
Collapse All

The following tables list the members exposed by SQLServer7ConfiguratorBdpMBCS.

Protected Methods
Name | Description
FilterData | This method should return the name of the bdp provider (such as Interbase, MSSQL or Oracle). There can be multiple configurators for the same provider.
Top
Public Methods
Name | Description
Caption | The caption for this instance when used as a designer verb.
ConfigureBackend | Override this method to perform the actual configuration. Modify the settings of sqlDatabaseConfig to suite your needs
ConfigureBackend | Initializes sqlDatabaseConfig using the settings determined by SupportedDataBaseEngine.
ConfigureBackend | Configure SqlDatabaseConfig approprately. This method is called from inside a designer transaction
IsVerbFor | This method determines if the instance is suited for configuring the submitted component.
IsVerbFor | The configurator must decide if it can act in current circumstances
PersistenceMapperType | This method will return typeof(PersistenceMapperBdp)
PersistenceMapperType | Return the type of the PersistenceMapper this configurator deals with
SupportedDataBaseEngine | Override this method to provide the engine enum handled by the configurator.


SQLServer7ConfiguratorBdpMBCS Methods

SQLServer7ConfiguratorBdpMBCS Methods
Protected Methods Public Methods
Collapse All

The methods of the SQLServer7ConfiguratorBdpMBCS class are listed here.

Protected Methods
Name | Description
FilterData | This method should return the name of the bdp provider (such as Interbase, MSSQL or Oracle). There can be multiple configurators for the same provider.
Top
Public Methods
Name | Description
Caption | The caption for this instance when used as a designer verb.
SupportedDataBaseEngine | Override this method to provide the engine enum handled by the configurator.


SQLServer7ConfiguratorBdpMBCS.Caption Method

SQLServer7ConfiguratorBdpMBCS.Caption Method
SQLServer7ConfiguratorBdpMBCS Class SQLServer7ConfiguratorBdpMBCS Members Eco.Persistence.Design Namespace See Also
Collapse All

The caption for this instance when used as a designer verb.

C#
public override string Caption();
See Also
SQLServer7ConfiguratorBdpMBCS Class
SQLServer7ConfiguratorBdpMBCS Members
Eco.Persistence.Design Namespace


SQLServer7ConfiguratorBdpMBCS.FilterData Method

SQLServer7ConfiguratorBdpMBCS.FilterData Method
SQLServer7ConfiguratorBdpMBCS Class SQLServer7ConfiguratorBdpMBCS Members Eco.Persistence.Design Namespace See Also
Collapse All

This method should return the name of the bdp provider (such as Interbase, MSSQL or Oracle). There can be multiple configurators for the same provider.

C#
protected override string FilterData();
Remarks

Own members

See Also
SQLServer7ConfiguratorBdpMBCS Class
SQLServer7ConfiguratorBdpMBCS Members
Eco.Persistence.Design Namespace


SQLServer7ConfiguratorBdpMBCS.SupportedDataBaseEngine Method

SQLServer7ConfiguratorBdpMBCS.SupportedDataBaseEngine Method
SQLServer7ConfiguratorBdpMBCS Class SQLServer7ConfiguratorBdpMBCS Members Eco.Persistence.Design Namespace See Also
Collapse All

Override this method to provide the engine enum handled by the configurator.

C#
public override DataBaseEngine SupportedDataBaseEngine();
See Also
SQLServer7ConfiguratorBdpMBCS Class
SQLServer7ConfiguratorBdpMBCS Members
Eco.Persistence.Design Namespace


SQLServer7ConfiguratorDbx Class

SQLServer7ConfiguratorDbx Class
SQLServer7ConfiguratorDbx Members Inheritance Hierarchy See Also
Collapse All

Configurator for SqlServer7Dbx.

C#
internal class SQLServer7ConfiguratorDbx : EcoDbxConfigurator;
Remarks

This class configures the persistence mapper using the settings for DataBaseEngine.SqlServer7Dbx.

Inheritance Hierarchy
Eco.Persistence.Design.IMapperVerbConfigurator
    Eco.Persistence.Design.AbstractDbxConfigurator
        Eco.Persistence.Design.EcoDbxConfigurator
            Eco.Persistence.Design.SQLServer7ConfiguratorDbx
File

MapperConfiguratorsDbx.cs

See Also
SQLServer7ConfiguratorDbx Members
Inheritance Hierarchy


SQLServer7ConfiguratorDbx Members

SQLServer7ConfiguratorDbx Members
Protected Methods Public Methods
Collapse All

The following tables list the members exposed by SQLServer7ConfiguratorDbx.

Protected Methods
Name | Description
FilterData | This method should return the name of the Dbx provider (such as Interbase, MSSQL or Oracle). There can be multiple configurators for the same provider.
Top
Public Methods
Name | Description
Caption | The caption for this instance when used as a designer verb.
ConfigureBackend | Override this method to perform the actual configuration. Modify the settings of sqlDatabaseConfig to suite your needs
ConfigureBackend | Initializes sqlDatabaseConfig using the settings determined by SupportedDataBaseEngine.
ConfigureBackend | Configure SqlDatabaseConfig approprately. This method is called from inside a designer transaction
IsVerbFor | This method determines if the instance is suited for configuring the submitted component.
IsVerbFor | The configurator must decide if it can act in current circumstances
PersistenceMapperType | This method will return typeof(PersistenceMapperDbx)
PersistenceMapperType | Return the type of the PersistenceMapper this configurator deals with
SupportedDataBaseEngine | Override this method to provide the engine enum handled by the configurator.


SQLServer7ConfiguratorDbx Methods

SQLServer7ConfiguratorDbx Methods
Protected Methods Public Methods
Collapse All

The methods of the SQLServer7ConfiguratorDbx class are listed here.

Protected Methods
Name | Description
FilterData | This method should return the name of the Dbx provider (such as Interbase, MSSQL or Oracle). There can be multiple configurators for the same provider.
Top
Public Methods
Name | Description
Caption | The caption for this instance when used as a designer verb.
SupportedDataBaseEngine | Override this method to provide the engine enum handled by the configurator.


SQLServer7ConfiguratorDbx.Caption Method

SQLServer7ConfiguratorDbx.Caption Method
SQLServer7ConfiguratorDbx Class SQLServer7ConfiguratorDbx Members Eco.Persistence.Design Namespace See Also
Collapse All

The caption for this instance when used as a designer verb.

C#
public override string Caption();
See Also
SQLServer7ConfiguratorDbx Class
SQLServer7ConfiguratorDbx Members
Eco.Persistence.Design Namespace


SQLServer7ConfiguratorDbx.FilterData Method

SQLServer7ConfiguratorDbx.FilterData Method
SQLServer7ConfiguratorDbx Class SQLServer7ConfiguratorDbx Members Eco.Persistence.Design Namespace See Also
Collapse All

This method should return the name of the Dbx provider (such as Interbase, MSSQL or Oracle). There can be multiple configurators for the same provider.

C#
protected override string FilterData();
Remarks

Own members

See Also
SQLServer7ConfiguratorDbx Class
SQLServer7ConfiguratorDbx Members
Eco.Persistence.Design Namespace


SQLServer7ConfiguratorDbx.SupportedDataBaseEngine Method

SQLServer7ConfiguratorDbx.SupportedDataBaseEngine Method
SQLServer7ConfiguratorDbx Class SQLServer7ConfiguratorDbx Members Eco.Persistence.Design Namespace See Also
Collapse All

Override this method to provide the engine enum handled by the configurator.

C#
public override DataBaseEngine SupportedDataBaseEngine();
See Also
SQLServer7ConfiguratorDbx Class
SQLServer7ConfiguratorDbx Members
Eco.Persistence.Design Namespace


SQLServer7ConfiguratorDbxMBCS Class

SQLServer7ConfiguratorDbxMBCS Class
SQLServer7ConfiguratorDbxMBCS Members Inheritance Hierarchy See Also
Collapse All

Configurator for SqlServer7MBCSDbx.

C#
internal class SQLServer7ConfiguratorDbxMBCS : EcoDbxConfigurator;
Remarks

This class configures the persistence mapper using the settings for DataBaseEngine.SqlServer7MBCSDbx.

Inheritance Hierarchy
Eco.Persistence.Design.IMapperVerbConfigurator
    Eco.Persistence.Design.AbstractDbxConfigurator
        Eco.Persistence.Design.EcoDbxConfigurator
            Eco.Persistence.Design.SQLServer7ConfiguratorDbxMBCS
File

MapperConfiguratorsDbx.cs

See Also
SQLServer7ConfiguratorDbxMBCS Members
Inheritance Hierarchy


SQLServer7ConfiguratorDbxMBCS Members

SQLServer7ConfiguratorDbxMBCS Members
Protected Methods Public Methods
Collapse All

The following tables list the members exposed by SQLServer7ConfiguratorDbxMBCS.

Protected Methods
Name | Description
FilterData | This method should return the name of the Dbx provider (such as Interbase, MSSQL or Oracle). There can be multiple configurators for the same provider.
Top
Public Methods
Name | Description
Caption | The caption for this instance when used as a designer verb.
ConfigureBackend | Override this method to perform the actual configuration. Modify the settings of sqlDatabaseConfig to suite your needs
ConfigureBackend | Initializes sqlDatabaseConfig using the settings determined by SupportedDataBaseEngine.
ConfigureBackend | Configure SqlDatabaseConfig approprately. This method is called from inside a designer transaction
IsVerbFor | This method determines if the instance is suited for configuring the submitted component.
IsVerbFor | The configurator must decide if it can act in current circumstances
PersistenceMapperType | This method will return typeof(PersistenceMapperDbx)
PersistenceMapperType | Return the type of the PersistenceMapper this configurator deals with
SupportedDataBaseEngine | Override this method to provide the engine enum handled by the configurator.


SQLServer7ConfiguratorDbxMBCS Methods

SQLServer7ConfiguratorDbxMBCS Methods
Protected Methods Public Methods
Collapse All

The methods of the SQLServer7ConfiguratorDbxMBCS class are listed here.

Protected Methods
Name | Description
FilterData | This method should return the name of the Dbx provider (such as Interbase, MSSQL or Oracle). There can be multiple configurators for the same provider.
Top
Public Methods
Name | Description
Caption | The caption for this instance when used as a designer verb.
SupportedDataBaseEngine | Override this method to provide the engine enum handled by the configurator.


SQLServer7ConfiguratorDbxMBCS.Caption Method

SQLServer7ConfiguratorDbxMBCS.Caption Method
SQLServer7ConfiguratorDbxMBCS Class SQLServer7ConfiguratorDbxMBCS Members Eco.Persistence.Design Namespace See Also
Collapse All

The caption for this instance when used as a designer verb.

C#
public override string Caption();
See Also
SQLServer7ConfiguratorDbxMBCS Class
SQLServer7ConfiguratorDbxMBCS Members
Eco.Persistence.Design Namespace


SQLServer7ConfiguratorDbxMBCS.FilterData Method

SQLServer7ConfiguratorDbxMBCS.FilterData Method
SQLServer7ConfiguratorDbxMBCS Class SQLServer7ConfiguratorDbxMBCS Members Eco.Persistence.Design Namespace See Also
Collapse All

This method should return the name of the Dbx provider (such as Interbase, MSSQL or Oracle). There can be multiple configurators for the same provider.

C#
protected override string FilterData();
Remarks

Own members

See Also
SQLServer7ConfiguratorDbxMBCS Class
SQLServer7ConfiguratorDbxMBCS Members
Eco.Persistence.Design Namespace


SQLServer7ConfiguratorDbxMBCS.SupportedDataBaseEngine Method

SQLServer7ConfiguratorDbxMBCS.SupportedDataBaseEngine Method
SQLServer7ConfiguratorDbxMBCS Class SQLServer7ConfiguratorDbxMBCS Members Eco.Persistence.Design Namespace See Also
Collapse All

Override this method to provide the engine enum handled by the configurator.

C#
public override DataBaseEngine SupportedDataBaseEngine();
See Also
SQLServer7ConfiguratorDbxMBCS Class
SQLServer7ConfiguratorDbxMBCS Members
Eco.Persistence.Design Namespace


SQLServer7ConfiguratorSqlClient Class

SQLServer7ConfiguratorSqlClient Class
SQLServer7ConfiguratorSqlClient Members Inheritance Hierarchy See Also
Collapse All
C#
internal class SQLServer7ConfiguratorSqlClient : IMapperVerbConfigurator;
Remarks

This is class Eco.Persistence.Design.SQLServer7ConfiguratorSqlClient.

Inheritance Hierarchy
Eco.Persistence.Design.IMapperVerbConfigurator
    Eco.Persistence.Design.SQLServer7ConfiguratorSqlClient
File

MapperConfiguratorsSqlServer.cs

See Also
SQLServer7ConfiguratorSqlClient Members
Inheritance Hierarchy


SQLServer7ConfiguratorSqlClient Members

SQLServer7ConfiguratorSqlClient Members
Public Methods
Collapse All

The following tables list the members exposed by SQLServer7ConfiguratorSqlClient.

Public Methods
Name | Description
Caption | The caption of the verb.
ConfigureBackend | Configure SqlDatabaseConfig approprately. This method is called from inside a designer transaction
IsVerbFor | The configurator must decide if it can act in current circumstances
PersistenceMapperType | Return the type of the PersistenceMapper this configurator deals with


SQLServer7ConfiguratorSqlClient Methods

SQLServer7ConfiguratorSqlClient Methods
Public Methods
Collapse All

The methods of the SQLServer7ConfiguratorSqlClient class are listed here.

Public Methods
Name | Description
Caption | The caption of the verb.
ConfigureBackend | Configure SqlDatabaseConfig approprately. This method is called from inside a designer transaction
IsVerbFor | The configurator must decide if it can act in current circumstances
PersistenceMapperType | Return the type of the PersistenceMapper this configurator deals with


SQLServer7ConfiguratorSqlClient.Caption Method

SQLServer7ConfiguratorSqlClient.Caption Method
SQLServer7ConfiguratorSqlClient Class SQLServer7ConfiguratorSqlClient Members Eco.Persistence.Design Namespace See Also
Collapse All

The caption of the verb.

C#
public string Caption();
See Also
SQLServer7ConfiguratorSqlClient Class
SQLServer7ConfiguratorSqlClient Members
Eco.Persistence.Design Namespace


SQLServer7ConfiguratorSqlClient.ConfigureBackend Method

SQLServer7ConfiguratorSqlClient.ConfigureBackend Method
SQLServer7ConfiguratorSqlClient Class SQLServer7ConfiguratorSqlClient Members Eco.Persistence.Design Namespace See Also
Collapse All

Configure SqlDatabaseConfig approprately. This method is called from inside a designer transaction

C#
public void ConfigureBackend(
    SqlDatabaseConfig sqlDatabaseConfig
);
See Also
SQLServer7ConfiguratorSqlClient Class
SQLServer7ConfiguratorSqlClient Members
Eco.Persistence.Design Namespace


SQLServer7ConfiguratorSqlClient.IsVerbFor Method

SQLServer7ConfiguratorSqlClient.IsVerbFor Method
SQLServer7ConfiguratorSqlClient Class SQLServer7ConfiguratorSqlClient Members Eco.Persistence.Design Namespace See Also
Collapse All

The configurator must decide if it can act in current circumstances

C#
public bool IsVerbFor(
    Component component
);
See Also
SQLServer7ConfiguratorSqlClient Class
SQLServer7ConfiguratorSqlClient Members
Eco.Persistence.Design Namespace


SQLServer7ConfiguratorSqlClient.PersistenceMapperType Method

SQLServer7ConfiguratorSqlClient.PersistenceMapperType Method
SQLServer7ConfiguratorSqlClient Class SQLServer7ConfiguratorSqlClient Members Eco.Persistence.Design Namespace See Also
Collapse All

Return the type of the PersistenceMapper this configurator deals with

C#
public object PersistenceMapperType();
See Also
SQLServer7ConfiguratorSqlClient Class
SQLServer7ConfiguratorSqlClient Members
Eco.Persistence.Design Namespace


SQLServer7ConfiguratorSqlClientMBCS Class

SQLServer7ConfiguratorSqlClientMBCS Class
SQLServer7ConfiguratorSqlClientMBCS Members Inheritance Hierarchy See Also
Collapse All
C#
internal class SQLServer7ConfiguratorSqlClientMBCS : IMapperVerbConfigurator;
Remarks

This is class Eco.Persistence.Design.SQLServer7ConfiguratorSqlClientMBCS.

Inheritance Hierarchy
Eco.Persistence.Design.IMapperVerbConfigurator
    Eco.Persistence.Design.SQLServer7ConfiguratorSqlClientMBCS
File

MapperConfiguratorsSqlServer.cs

See Also
SQLServer7ConfiguratorSqlClientMBCS Members
Inheritance Hierarchy


SQLServer7ConfiguratorSqlClientMBCS Members

SQLServer7ConfiguratorSqlClientMBCS Members
Public Methods
Collapse All

The following tables list the members exposed by SQLServer7ConfiguratorSqlClientMBCS.

Public Methods
Name | Description
Caption | The caption of the verb.
ConfigureBackend | Configure SqlDatabaseConfig approprately. This method is called from inside a designer transaction
IsVerbFor | The configurator must decide if it can act in current circumstances
PersistenceMapperType | Return the type of the PersistenceMapper this configurator deals with


SQLServer7ConfiguratorSqlClientMBCS Methods

SQLServer7ConfiguratorSqlClientMBCS Methods
Public Methods
Collapse All

The methods of the SQLServer7ConfiguratorSqlClientMBCS class are listed here.

Public Methods
Name | Description
Caption | The caption of the verb.
ConfigureBackend | Configure SqlDatabaseConfig approprately. This method is called from inside a designer transaction
IsVerbFor | The configurator must decide if it can act in current circumstances
PersistenceMapperType | Return the type of the PersistenceMapper this configurator deals with


SQLServer7ConfiguratorSqlClientMBCS.Caption Method

SQLServer7ConfiguratorSqlClientMBCS.Caption Method
SQLServer7ConfiguratorSqlClientMBCS Class SQLServer7ConfiguratorSqlClientMBCS Members Eco.Persistence.Design Namespace See Also
Collapse All

The caption of the verb.

C#
public string Caption();
See Also
SQLServer7ConfiguratorSqlClientMBCS Class
SQLServer7ConfiguratorSqlClientMBCS Members
Eco.Persistence.Design Namespace


SQLServer7ConfiguratorSqlClientMBCS.ConfigureBackend Method

SQLServer7ConfiguratorSqlClientMBCS.ConfigureBackend Method
SQLServer7ConfiguratorSqlClientMBCS Class SQLServer7ConfiguratorSqlClientMBCS Members Eco.Persistence.Design Namespace See Also
Collapse All

Configure SqlDatabaseConfig approprately. This method is called from inside a designer transaction

C#
public void ConfigureBackend(
    SqlDatabaseConfig sqlDatabaseConfig
);
See Also
SQLServer7ConfiguratorSqlClientMBCS Class
SQLServer7ConfiguratorSqlClientMBCS Members
Eco.Persistence.Design Namespace


SQLServer7ConfiguratorSqlClientMBCS.IsVerbFor Method

SQLServer7ConfiguratorSqlClientMBCS.IsVerbFor Method
SQLServer7ConfiguratorSqlClientMBCS Class SQLServer7ConfiguratorSqlClientMBCS Members Eco.Persistence.Design Namespace See Also
Collapse All

The configurator must decide if it can act in current circumstances

C#
public bool IsVerbFor(
    Component component
);
See Also
SQLServer7ConfiguratorSqlClientMBCS Class
SQLServer7ConfiguratorSqlClientMBCS Members
Eco.Persistence.Design Namespace


SQLServer7ConfiguratorSqlClientMBCS.PersistenceMapperType Method

SQLServer7ConfiguratorSqlClientMBCS.PersistenceMapperType Method
SQLServer7ConfiguratorSqlClientMBCS Class SQLServer7ConfiguratorSqlClientMBCS Members Eco.Persistence.Design Namespace See Also
Collapse All

Return the type of the PersistenceMapper this configurator deals with

C#
public object PersistenceMapperType();
See Also
SQLServer7ConfiguratorSqlClientMBCS Class
SQLServer7ConfiguratorSqlClientMBCS Members
Eco.Persistence.Design Namespace


SQLServerConfiguratorBdp Class

SQLServerConfiguratorBdp Class
SQLServerConfiguratorBdp Members Inheritance Hierarchy See Also
Collapse All

Configurator for SqlServerBdp.

C#
internal class SQLServerConfiguratorBdp : EcoBdpConfigurator;
Remarks

This class configures the persistence mapper using the settings for DataBaseEngine.SqlServerBdp.

Inheritance Hierarchy
Eco.Persistence.Design.IMapperVerbConfigurator
    Eco.Persistence.Design.AbstractBdpConfigurator
        Eco.Persistence.Design.EcoBdpConfigurator
            Eco.Persistence.Design.SQLServerConfiguratorBdp
File

MapperConfiguratorsBdp.cs

See Also
SQLServerConfiguratorBdp Members
Inheritance Hierarchy


SQLServerConfiguratorBdp Members

SQLServerConfiguratorBdp Members
Protected Methods Public Methods
Collapse All

The following tables list the members exposed by SQLServerConfiguratorBdp.

Protected Methods
Name | Description
FilterData | This method should return the name of the bdp provider (such as Interbase, MSSQL or Oracle). There can be multiple configurators for the same provider.
Top
Public Methods
Name | Description
Caption | The caption for this instance when used as a designer verb.
ConfigureBackend | Override this method to perform the actual configuration. Modify the settings of sqlDatabaseConfig to suite your needs
ConfigureBackend | Initializes sqlDatabaseConfig using the settings determined by SupportedDataBaseEngine.
ConfigureBackend | Configure SqlDatabaseConfig approprately. This method is called from inside a designer transaction
IsVerbFor | This method determines if the instance is suited for configuring the submitted component.
IsVerbFor | The configurator must decide if it can act in current circumstances
PersistenceMapperType | This method will return typeof(PersistenceMapperBdp)
PersistenceMapperType | Return the type of the PersistenceMapper this configurator deals with
SupportedDataBaseEngine | Override this method to provide the engine enum handled by the configurator.


SQLServerConfiguratorBdp Methods

SQLServerConfiguratorBdp Methods
Protected Methods Public Methods
Collapse All

The methods of the SQLServerConfiguratorBdp class are listed here.

Protected Methods
Name | Description
FilterData | This method should return the name of the bdp provider (such as Interbase, MSSQL or Oracle). There can be multiple configurators for the same provider.
Top
Public Methods
Name | Description
Caption | The caption for this instance when used as a designer verb.
SupportedDataBaseEngine | Override this method to provide the engine enum handled by the configurator.


SQLServerConfiguratorBdp.Caption Method

SQLServerConfiguratorBdp.Caption Method
SQLServerConfiguratorBdp Class SQLServerConfiguratorBdp Members Eco.Persistence.Design Namespace See Also
Collapse All

The caption for this instance when used as a designer verb.

C#
public override string Caption();
See Also
SQLServerConfiguratorBdp Class
SQLServerConfiguratorBdp Members
Eco.Persistence.Design Namespace


SQLServerConfiguratorBdp.FilterData Method

SQLServerConfiguratorBdp.FilterData Method
SQLServerConfiguratorBdp Class SQLServerConfiguratorBdp Members Eco.Persistence.Design Namespace See Also
Collapse All

This method should return the name of the bdp provider (such as Interbase, MSSQL or Oracle). There can be multiple configurators for the same provider.

C#
protected override string FilterData();
Remarks

Own members

See Also
SQLServerConfiguratorBdp Class
SQLServerConfiguratorBdp Members
Eco.Persistence.Design Namespace


SQLServerConfiguratorBdp.SupportedDataBaseEngine Method

SQLServerConfiguratorBdp.SupportedDataBaseEngine Method
SQLServerConfiguratorBdp Class SQLServerConfiguratorBdp Members Eco.Persistence.Design Namespace See Also
Collapse All

Override this method to provide the engine enum handled by the configurator.

C#
public override DataBaseEngine SupportedDataBaseEngine();
See Also
SQLServerConfiguratorBdp Class
SQLServerConfiguratorBdp Members
Eco.Persistence.Design Namespace


SQLServerConfiguratorBdpMBCS Class

SQLServerConfiguratorBdpMBCS Class
SQLServerConfiguratorBdpMBCS Members Inheritance Hierarchy See Also
Collapse All

Configurator for SqlServerMBCSBdp.

C#
internal class SQLServerConfiguratorBdpMBCS : EcoBdpConfigurator;
Remarks

This class configures the persistence mapper using the settings for DataBaseEngine.SqlServerMBCSBdp.

Inheritance Hierarchy
Eco.Persistence.Design.IMapperVerbConfigurator
    Eco.Persistence.Design.AbstractBdpConfigurator
        Eco.Persistence.Design.EcoBdpConfigurator
            Eco.Persistence.Design.SQLServerConfiguratorBdpMBCS
File

MapperConfiguratorsBdp.cs

See Also
SQLServerConfiguratorBdpMBCS Members
Inheritance Hierarchy


SQLServerConfiguratorBdpMBCS Members

SQLServerConfiguratorBdpMBCS Members
Protected Methods Public Methods
Collapse All

The following tables list the members exposed by SQLServerConfiguratorBdpMBCS.

Protected Methods
Name | Description
FilterData | This method should return the name of the bdp provider (such as Interbase, MSSQL or Oracle). There can be multiple configurators for the same provider.
Top
Public Methods
Name | Description
Caption | The caption for this instance when used as a designer verb.
ConfigureBackend | Override this method to perform the actual configuration. Modify the settings of sqlDatabaseConfig to suite your needs
ConfigureBackend | Initializes sqlDatabaseConfig using the settings determined by SupportedDataBaseEngine.
ConfigureBackend | Configure SqlDatabaseConfig approprately. This method is called from inside a designer transaction
IsVerbFor | This method determines if the instance is suited for configuring the submitted component.
IsVerbFor | The configurator must decide if it can act in current circumstances
PersistenceMapperType | This method will return typeof(PersistenceMapperBdp)
PersistenceMapperType | Return the type of the PersistenceMapper this configurator deals with
SupportedDataBaseEngine | Override this method to provide the engine enum handled by the configurator.


SQLServerConfiguratorBdpMBCS Methods

SQLServerConfiguratorBdpMBCS Methods
Protected Methods Public Methods
Collapse All

The methods of the SQLServerConfiguratorBdpMBCS class are listed here.

Protected Methods
Name | Description
FilterData | This method should return the name of the bdp provider (such as Interbase, MSSQL or Oracle). There can be multiple configurators for the same provider.
Top
Public Methods
Name | Description
Caption | The caption for this instance when used as a designer verb.
SupportedDataBaseEngine | Override this method to provide the engine enum handled by the configurator.


SQLServerConfiguratorBdpMBCS.Caption Method

SQLServerConfiguratorBdpMBCS.Caption Method
SQLServerConfiguratorBdpMBCS Class SQLServerConfiguratorBdpMBCS Members Eco.Persistence.Design Namespace See Also
Collapse All

The caption for this instance when used as a designer verb.

C#
public override string Caption();
See Also
SQLServerConfiguratorBdpMBCS Class
SQLServerConfiguratorBdpMBCS Members
Eco.Persistence.Design Namespace


SQLServerConfiguratorBdpMBCS.FilterData Method

SQLServerConfiguratorBdpMBCS.FilterData Method
SQLServerConfiguratorBdpMBCS Class SQLServerConfiguratorBdpMBCS Members Eco.Persistence.Design Namespace See Also
Collapse All

This method should return the name of the bdp provider (such as Interbase, MSSQL or Oracle). There can be multiple configurators for the same provider.

C#
protected override string FilterData();
Remarks

Own members

See Also
SQLServerConfiguratorBdpMBCS Class
SQLServerConfiguratorBdpMBCS Members
Eco.Persistence.Design Namespace


SQLServerConfiguratorBdpMBCS.SupportedDataBaseEngine Method

SQLServerConfiguratorBdpMBCS.SupportedDataBaseEngine Method
SQLServerConfiguratorBdpMBCS Class SQLServerConfiguratorBdpMBCS Members Eco.Persistence.Design Namespace See Also
Collapse All

Override this method to provide the engine enum handled by the configurator.

C#
public override DataBaseEngine SupportedDataBaseEngine();
See Also
SQLServerConfiguratorBdpMBCS Class
SQLServerConfiguratorBdpMBCS Members
Eco.Persistence.Design Namespace


SQLServerConfiguratorDbx Class

SQLServerConfiguratorDbx Class
SQLServerConfiguratorDbx Members Inheritance Hierarchy See Also
Collapse All

Configurator for SqlServerDbx.

C#
internal class SQLServerConfiguratorDbx : EcoDbxConfigurator;
Remarks

This class configures the persistence mapper using the settings for DataBaseEngine.SqlServerDbx.

Inheritance Hierarchy
Eco.Persistence.Design.IMapperVerbConfigurator
    Eco.Persistence.Design.AbstractDbxConfigurator
        Eco.Persistence.Design.EcoDbxConfigurator
            Eco.Persistence.Design.SQLServerConfiguratorDbx
File

MapperConfiguratorsDbx.cs

See Also
SQLServerConfiguratorDbx Members
Inheritance Hierarchy


SQLServerConfiguratorDbx Members

SQLServerConfiguratorDbx Members
Protected Methods Public Methods
Collapse All

The following tables list the members exposed by SQLServerConfiguratorDbx.

Protected Methods
Name | Description
FilterData | This method should return the name of the Dbx provider (such as Interbase, MSSQL or Oracle). There can be multiple configurators for the same provider.
Top
Public Methods
Name | Description
Caption | The caption for this instance when used as a designer verb.
ConfigureBackend | Override this method to perform the actual configuration. Modify the settings of sqlDatabaseConfig to suite your needs
ConfigureBackend | Initializes sqlDatabaseConfig using the settings determined by SupportedDataBaseEngine.
ConfigureBackend | Configure SqlDatabaseConfig approprately. This method is called from inside a designer transaction
IsVerbFor | This method determines if the instance is suited for configuring the submitted component.
IsVerbFor | The configurator must decide if it can act in current circumstances
PersistenceMapperType | This method will return typeof(PersistenceMapperDbx)
PersistenceMapperType | Return the type of the PersistenceMapper this configurator deals with
SupportedDataBaseEngine | Override this method to provide the engine enum handled by the configurator.


SQLServerConfiguratorDbx Methods

SQLServerConfiguratorDbx Methods
Protected Methods Public Methods
Collapse All

The methods of the SQLServerConfiguratorDbx class are listed here.

Protected Methods
Name | Description
FilterData | This method should return the name of the Dbx provider (such as Interbase, MSSQL or Oracle). There can be multiple configurators for the same provider.
Top
Public Methods
Name | Description
Caption | The caption for this instance when used as a designer verb.
SupportedDataBaseEngine | Override this method to provide the engine enum handled by the configurator.


SQLServerConfiguratorDbx.Caption Method

SQLServerConfiguratorDbx.Caption Method
SQLServerConfiguratorDbx Class SQLServerConfiguratorDbx Members Eco.Persistence.Design Namespace See Also
Collapse All

The caption for this instance when used as a designer verb.

C#
public override string Caption();
See Also
SQLServerConfiguratorDbx Class
SQLServerConfiguratorDbx Members
Eco.Persistence.Design Namespace


SQLServerConfiguratorDbx.FilterData Method

SQLServerConfiguratorDbx.FilterData Method
SQLServerConfiguratorDbx Class SQLServerConfiguratorDbx Members Eco.Persistence.Design Namespace See Also
Collapse All

This method should return the name of the Dbx provider (such as Interbase, MSSQL or Oracle). There can be multiple configurators for the same provider.

C#
protected override string FilterData();
Remarks

Own members

See Also
SQLServerConfiguratorDbx Class
SQLServerConfiguratorDbx Members
Eco.Persistence.Design Namespace


SQLServerConfiguratorDbx.SupportedDataBaseEngine Method

SQLServerConfiguratorDbx.SupportedDataBaseEngine Method
SQLServerConfiguratorDbx Class SQLServerConfiguratorDbx Members Eco.Persistence.Design Namespace See Also
Collapse All

Override this method to provide the engine enum handled by the configurator.

C#
public override DataBaseEngine SupportedDataBaseEngine();
See Also
SQLServerConfiguratorDbx Class
SQLServerConfiguratorDbx Members
Eco.Persistence.Design Namespace


SQLServerConfiguratorDbxMBCS Class

SQLServerConfiguratorDbxMBCS Class
SQLServerConfiguratorDbxMBCS Members Inheritance Hierarchy See Also
Collapse All

Configurator for SqlServerMBCSDbx.

C#
internal class SQLServerConfiguratorDbxMBCS : EcoDbxConfigurator;
Remarks

This class configures the persistence mapper using the settings for DataBaseEngine.SqlServerMBCSDbx.

Inheritance Hierarchy
Eco.Persistence.Design.IMapperVerbConfigurator
    Eco.Persistence.Design.AbstractDbxConfigurator
        Eco.Persistence.Design.EcoDbxConfigurator
            Eco.Persistence.Design.SQLServerConfiguratorDbxMBCS
File

MapperConfiguratorsDbx.cs

See Also
SQLServerConfiguratorDbxMBCS Members
Inheritance Hierarchy


SQLServerConfiguratorDbxMBCS Members

SQLServerConfiguratorDbxMBCS Members
Protected Methods Public Methods
Collapse All

The following tables list the members exposed by SQLServerConfiguratorDbxMBCS.

Protected Methods
Name | Description
FilterData | This method should return the name of the Dbx provider (such as Interbase, MSSQL or Oracle). There can be multiple configurators for the same provider.
Top
Public Methods
Name | Description
Caption | The caption for this instance when used as a designer verb.
ConfigureBackend | Override this method to perform the actual configuration. Modify the settings of sqlDatabaseConfig to suite your needs
ConfigureBackend | Initializes sqlDatabaseConfig using the settings determined by SupportedDataBaseEngine.
ConfigureBackend | Configure SqlDatabaseConfig approprately. This method is called from inside a designer transaction
IsVerbFor | This method determines if the instance is suited for configuring the submitted component.
IsVerbFor | The configurator must decide if it can act in current circumstances
PersistenceMapperType | This method will return typeof(PersistenceMapperDbx)
PersistenceMapperType | Return the type of the PersistenceMapper this configurator deals with
SupportedDataBaseEngine | Override this method to provide the engine enum handled by the configurator.


SQLServerConfiguratorDbxMBCS Methods

SQLServerConfiguratorDbxMBCS Methods
Protected Methods Public Methods
Collapse All

The methods of the SQLServerConfiguratorDbxMBCS class are listed here.

Protected Methods
Name | Description
FilterData | This method should return the name of the Dbx provider (such as Interbase, MSSQL or Oracle). There can be multiple configurators for the same provider.
Top
Public Methods
Name | Description
Caption | The caption for this instance when used as a designer verb.
SupportedDataBaseEngine | Override this method to provide the engine enum handled by the configurator.


SQLServerConfiguratorDbxMBCS.Caption Method

SQLServerConfiguratorDbxMBCS.Caption Method
SQLServerConfiguratorDbxMBCS Class SQLServerConfiguratorDbxMBCS Members Eco.Persistence.Design Namespace See Also
Collapse All

The caption for this instance when used as a designer verb.

C#
public override string Caption();
See Also
SQLServerConfiguratorDbxMBCS Class
SQLServerConfiguratorDbxMBCS Members
Eco.Persistence.Design Namespace


SQLServerConfiguratorDbxMBCS.FilterData Method

SQLServerConfiguratorDbxMBCS.FilterData Method
SQLServerConfiguratorDbxMBCS Class SQLServerConfiguratorDbxMBCS Members Eco.Persistence.Design Namespace See Also
Collapse All

This method should return the name of the Dbx provider (such as Interbase, MSSQL or Oracle). There can be multiple configurators for the same provider.

C#
protected override string FilterData();
Remarks

Own members

See Also
SQLServerConfiguratorDbxMBCS Class
SQLServerConfiguratorDbxMBCS Members
Eco.Persistence.Design Namespace


SQLServerConfiguratorDbxMBCS.SupportedDataBaseEngine Method

SQLServerConfiguratorDbxMBCS.SupportedDataBaseEngine Method
SQLServerConfiguratorDbxMBCS Class SQLServerConfiguratorDbxMBCS Members Eco.Persistence.Design Namespace See Also
Collapse All

Override this method to provide the engine enum handled by the configurator.

C#
public override DataBaseEngine SupportedDataBaseEngine();
See Also
SQLServerConfiguratorDbxMBCS Class
SQLServerConfiguratorDbxMBCS Members
Eco.Persistence.Design Namespace


SQLServerConfiguratorSqlClient Class

SQLServerConfiguratorSqlClient Class
SQLServerConfiguratorSqlClient Members Inheritance Hierarchy See Also
Collapse All
C#
internal class SQLServerConfiguratorSqlClient : IMapperVerbConfigurator;
Remarks

This is class Eco.Persistence.Design.SQLServerConfiguratorSqlClient.

Inheritance Hierarchy
Eco.Persistence.Design.IMapperVerbConfigurator
    Eco.Persistence.Design.SQLServerConfiguratorSqlClient
File

MapperConfiguratorsSqlServer.cs

See Also
SQLServerConfiguratorSqlClient Members
Inheritance Hierarchy


SQLServerConfiguratorSqlClient Members

SQLServerConfiguratorSqlClient Members
Public Methods
Collapse All

The following tables list the members exposed by SQLServerConfiguratorSqlClient.

Public Methods
Name | Description
Caption | The caption of the verb.
ConfigureBackend | Configure SqlDatabaseConfig approprately. This method is called from inside a designer transaction
IsVerbFor | The configurator must decide if it can act in current circumstances
PersistenceMapperType | Return the type of the PersistenceMapper this configurator deals with


SQLServerConfiguratorSqlClient Methods

SQLServerConfiguratorSqlClient Methods
Public Methods
Collapse All

The methods of the SQLServerConfiguratorSqlClient class are listed here.

Public Methods
Name | Description
Caption | The caption of the verb.
ConfigureBackend | Configure SqlDatabaseConfig approprately. This method is called from inside a designer transaction
IsVerbFor | The configurator must decide if it can act in current circumstances
PersistenceMapperType | Return the type of the PersistenceMapper this configurator deals with


SQLServerConfiguratorSqlClient.Caption Method

SQLServerConfiguratorSqlClient.Caption Method
SQLServerConfiguratorSqlClient Class SQLServerConfiguratorSqlClient Members Eco.Persistence.Design Namespace See Also
Collapse All

The caption of the verb.

C#
public string Caption();
See Also
SQLServerConfiguratorSqlClient Class
SQLServerConfiguratorSqlClient Members
Eco.Persistence.Design Namespace


SQLServerConfiguratorSqlClient.ConfigureBackend Method

SQLServerConfiguratorSqlClient.ConfigureBackend Method
SQLServerConfiguratorSqlClient Class SQLServerConfiguratorSqlClient Members Eco.Persistence.Design Namespace See Also
Collapse All

Configure SqlDatabaseConfig approprately. This method is called from inside a designer transaction

C#
public void ConfigureBackend(
    SqlDatabaseConfig sqlDatabaseConfig
);
See Also
SQLServerConfiguratorSqlClient Class
SQLServerConfiguratorSqlClient Members
Eco.Persistence.Design Namespace


SQLServerConfiguratorSqlClient.IsVerbFor Method

SQLServerConfiguratorSqlClient.IsVerbFor Method
SQLServerConfiguratorSqlClient Class SQLServerConfiguratorSqlClient Members Eco.Persistence.Design Namespace See Also
Collapse All

The configurator must decide if it can act in current circumstances

C#
public bool IsVerbFor(
    Component component
);
See Also
SQLServerConfiguratorSqlClient Class
SQLServerConfiguratorSqlClient Members
Eco.Persistence.Design Namespace


SQLServerConfiguratorSqlClient.PersistenceMapperType Method

SQLServerConfiguratorSqlClient.PersistenceMapperType Method
SQLServerConfiguratorSqlClient Class SQLServerConfiguratorSqlClient Members Eco.Persistence.Design Namespace See Also
Collapse All

Return the type of the PersistenceMapper this configurator deals with

C#
public object PersistenceMapperType();
See Also
SQLServerConfiguratorSqlClient Class
SQLServerConfiguratorSqlClient Members
Eco.Persistence.Design Namespace


SQLServerConfiguratorSqlClientMBCS Class

SQLServerConfiguratorSqlClientMBCS Class
SQLServerConfiguratorSqlClientMBCS Members Inheritance Hierarchy See Also
Collapse All
C#
internal class SQLServerConfiguratorSqlClientMBCS : IMapperVerbConfigurator;
Remarks

This is class Eco.Persistence.Design.SQLServerConfiguratorSqlClientMBCS.

Inheritance Hierarchy
Eco.Persistence.Design.IMapperVerbConfigurator
    Eco.Persistence.Design.SQLServerConfiguratorSqlClientMBCS
File

MapperConfiguratorsSqlServer.cs

See Also
SQLServerConfiguratorSqlClientMBCS Members
Inheritance Hierarchy


SQLServerConfiguratorSqlClientMBCS Members

SQLServerConfiguratorSqlClientMBCS Members
Public Methods
Collapse All

The following tables list the members exposed by SQLServerConfiguratorSqlClientMBCS.

Public Methods
Name | Description
Caption | The caption of the verb.
ConfigureBackend | Configure SqlDatabaseConfig approprately. This method is called from inside a designer transaction
IsVerbFor | The configurator must decide if it can act in current circumstances
PersistenceMapperType | Return the type of the PersistenceMapper this configurator deals with


SQLServerConfiguratorSqlClientMBCS Methods

SQLServerConfiguratorSqlClientMBCS Methods
Public Methods
Collapse All

The methods of the SQLServerConfiguratorSqlClientMBCS class are listed here.

Public Methods
Name | Description
Caption | The caption of the verb.
ConfigureBackend | Configure SqlDatabaseConfig approprately. This method is called from inside a designer transaction
IsVerbFor | The configurator must decide if it can act in current circumstances
PersistenceMapperType | Return the type of the PersistenceMapper this configurator deals with


SQLServerConfiguratorSqlClientMBCS.Caption Method

SQLServerConfiguratorSqlClientMBCS.Caption Method
SQLServerConfiguratorSqlClientMBCS Class SQLServerConfiguratorSqlClientMBCS Members Eco.Persistence.Design Namespace See Also
Collapse All

The caption of the verb.

C#
public string Caption();
See Also
SQLServerConfiguratorSqlClientMBCS Class
SQLServerConfiguratorSqlClientMBCS Members
Eco.Persistence.Design Namespace


SQLServerConfiguratorSqlClientMBCS.ConfigureBackend Method

SQLServerConfiguratorSqlClientMBCS.ConfigureBackend Method
SQLServerConfiguratorSqlClientMBCS Class SQLServerConfiguratorSqlClientMBCS Members Eco.Persistence.Design Namespace See Also
Collapse All

Configure SqlDatabaseConfig approprately. This method is called from inside a designer transaction

C#
public void ConfigureBackend(
    SqlDatabaseConfig sqlDatabaseConfig
);
See Also
SQLServerConfiguratorSqlClientMBCS Class
SQLServerConfiguratorSqlClientMBCS Members
Eco.Persistence.Design Namespace


SQLServerConfiguratorSqlClientMBCS.IsVerbFor Method

SQLServerConfiguratorSqlClientMBCS.IsVerbFor Method
SQLServerConfiguratorSqlClientMBCS Class SQLServerConfiguratorSqlClientMBCS Members Eco.Persistence.Design Namespace See Also
Collapse All

The configurator must decide if it can act in current circumstances

C#
public bool IsVerbFor(
    Component component
);
See Also
SQLServerConfiguratorSqlClientMBCS Class
SQLServerConfiguratorSqlClientMBCS Members
Eco.Persistence.Design Namespace


SQLServerConfiguratorSqlClientMBCS.PersistenceMapperType Method

SQLServerConfiguratorSqlClientMBCS.PersistenceMapperType Method
SQLServerConfiguratorSqlClientMBCS Class SQLServerConfiguratorSqlClientMBCS Members Eco.Persistence.Design Namespace See Also
Collapse All

Return the type of the PersistenceMapper this configurator deals with

C#
public object PersistenceMapperType();
See Also
SQLServerConfiguratorSqlClientMBCS Class
SQLServerConfiguratorSqlClientMBCS Members
Eco.Persistence.Design Namespace


SqlServerPersistenceHandleDesigner Class

SqlServerPersistenceHandleDesigner Class
SqlServerPersistenceHandleDesigner Members Inheritance Hierarchy See Also
Collapse All
C#
public class SqlServerPersistenceHandleDesigner : PersistenceHandleDesigner;
Remarks

This is class Eco.Persistence.Design.SqlServerPersistenceHandleDesigner.

Inheritance Hierarchy
Eco.Persistence.Design.PersistenceHandleDesigner
    Eco.Persistence.Design.SqlServerPersistenceHandleDesigner
File

PersistenceHandleDesignerSqlServer.cs

See Also
SqlServerPersistenceHandleDesigner Members
Inheritance Hierarchy


SqlServerPersistenceHandleDesigner Members

SqlServerPersistenceHandleDesigner Members
Protected Methods Public Methods Public Properties Protected Properties
Collapse All

The following tables list the members exposed by SqlServerPersistenceHandleDesigner.

Protected Methods
Name | Description
Dispose | This method uninstalls the OnComponentRemoved event handler.
OnComponentRemoved | Disconnects the removed component from the designed component.
PersistenceHandleDesigner | This is PersistenceHandleDesigner, a member of class PersistenceHandleDesigner.
Top
Public Methods
Name | Description
CheckInitialize | This is CheckInitialize, a member of class SqlServerPersistenceHandleDesigner.
Initialize | This is Initialize, a member of class SqlServerPersistenceHandleDesigner.
InitializeComponent | Called by the verb handler to initialize the designed component with the configurator.
InitializeNewComponent | This is InitializeNewComponent, a member of class SqlServerPersistenceHandleDesigner.
RegisterConfigurator | Registers the configurator in the list of known configurators.
SqlServerPersistenceHandleDesigner | This is SqlServerPersistenceHandleDesigner, a member of class SqlServerPersistenceHandleDesigner.
Top
Public Properties
Name | Description
Verbs | Builds the verbs for the designed component.
Top
Protected Properties
Name | Description
MapperVerbConfigurators | This is MapperVerbConfigurators, a member of class PersistenceHandleDesigner.


SqlServerPersistenceHandleDesigner.SqlServerPersistenceHandleDesigner Constructor

SqlServerPersistenceHandleDesigner.SqlServerPersistenceHandleDesigner Constructor
SqlServerPersistenceHandleDesigner Class SqlServerPersistenceHandleDesigner Members Eco.Persistence.Design Namespace See Also
Collapse All
C#
public SqlServerPersistenceHandleDesigner();
Remarks

This is SqlServerPersistenceHandleDesigner, a member of class SqlServerPersistenceHandleDesigner.

See Also
SqlServerPersistenceHandleDesigner Class
SqlServerPersistenceHandleDesigner Members
Eco.Persistence.Design Namespace


SqlServerPersistenceHandleDesigner Methods

SqlServerPersistenceHandleDesigner Methods
Public Methods
Collapse All

The methods of the SqlServerPersistenceHandleDesigner class are listed here.

Public Methods
Name | Description
CheckInitialize | This is CheckInitialize, a member of class SqlServerPersistenceHandleDesigner.
Initialize | This is Initialize, a member of class SqlServerPersistenceHandleDesigner.
InitializeNewComponent | This is InitializeNewComponent, a member of class SqlServerPersistenceHandleDesigner.


SqlServerPersistenceHandleDesigner.CheckInitialize Method

SqlServerPersistenceHandleDesigner.CheckInitialize Method
SqlServerPersistenceHandleDesigner Class SqlServerPersistenceHandleDesigner Members Eco.Persistence.Design Namespace See Also
Collapse All
C#
public void CheckInitialize(
    object sender,
    EventArgs e
);
Remarks

This is CheckInitialize, a member of class SqlServerPersistenceHandleDesigner.

See Also
SqlServerPersistenceHandleDesigner Class
SqlServerPersistenceHandleDesigner Members
Eco.Persistence.Design Namespace


SqlServerPersistenceHandleDesigner.Initialize Method

SqlServerPersistenceHandleDesigner.Initialize Method
SqlServerPersistenceHandleDesigner Class SqlServerPersistenceHandleDesigner Members Eco.Persistence.Design Namespace See Also
Collapse All
C#
public override void Initialize(
    IComponent component
);
Remarks

This is Initialize, a member of class SqlServerPersistenceHandleDesigner.

See Also
SqlServerPersistenceHandleDesigner Class
SqlServerPersistenceHandleDesigner Members
Eco.Persistence.Design Namespace


SqlServerPersistenceHandleDesigner.InitializeNewComponent Method

SqlServerPersistenceHandleDesigner.InitializeNewComponent Method
SqlServerPersistenceHandleDesigner Class SqlServerPersistenceHandleDesigner Members Eco.Persistence.Design Namespace See Also
Collapse All
C#
public override void InitializeNewComponent(
    IDictionary defaultValues
);
Remarks

This is InitializeNewComponent, a member of class SqlServerPersistenceHandleDesigner.

See Also
SqlServerPersistenceHandleDesigner Class
SqlServerPersistenceHandleDesigner Members
Eco.Persistence.Design Namespace


SybaseConfigurator Class

SybaseConfigurator Class
SybaseConfigurator Members Inheritance Hierarchy See Also
Collapse All

Configurator for SybaseDbx.

C#
internal class SybaseConfigurator : EcoDbxConfigurator;
Remarks

This class configures the persistence mapper using the settings for DataBaseEngine.SybaseDbx.

Inheritance Hierarchy
Eco.Persistence.Design.IMapperVerbConfigurator
    Eco.Persistence.Design.AbstractDbxConfigurator
        Eco.Persistence.Design.EcoDbxConfigurator
            Eco.Persistence.Design.SybaseConfigurator
File

MapperConfiguratorsDbx.cs

See Also
SybaseConfigurator Members
Inheritance Hierarchy


SybaseConfigurator Members

SybaseConfigurator Members
Protected Methods Public Methods
Collapse All

The following tables list the members exposed by SybaseConfigurator.

Protected Methods
Name | Description
FilterData | This method should return the name of the Dbx provider (such as Interbase, MSSQL or Oracle). There can be multiple configurators for the same provider.
Top
Public Methods
Name | Description
Caption | The caption for this instance when used as a designer verb.
ConfigureBackend | Override this method to perform the actual configuration. Modify the settings of sqlDatabaseConfig to suite your needs
ConfigureBackend | Initializes sqlDatabaseConfig using the settings determined by SupportedDataBaseEngine.
ConfigureBackend | Configure SqlDatabaseConfig approprately. This method is called from inside a designer transaction
IsVerbFor | This method determines if the instance is suited for configuring the submitted component.
IsVerbFor | The configurator must decide if it can act in current circumstances
PersistenceMapperType | This method will return typeof(PersistenceMapperDbx)
PersistenceMapperType | Return the type of the PersistenceMapper this configurator deals with
SupportedDataBaseEngine | Override this method to provide the engine enum handled by the configurator.


SybaseConfigurator Methods

SybaseConfigurator Methods
Protected Methods Public Methods
Collapse All

The methods of the SybaseConfigurator class are listed here.

Protected Methods
Name | Description
FilterData | This method should return the name of the Dbx provider (such as Interbase, MSSQL or Oracle). There can be multiple configurators for the same provider.
Top
Public Methods
Name | Description
Caption | The caption for this instance when used as a designer verb.
SupportedDataBaseEngine | Override this method to provide the engine enum handled by the configurator.


SybaseConfigurator.Caption Method

SybaseConfigurator.Caption Method
SybaseConfigurator Class SybaseConfigurator Members Eco.Persistence.Design Namespace See Also
Collapse All

The caption for this instance when used as a designer verb.

C#
public override string Caption();
See Also
SybaseConfigurator Class
SybaseConfigurator Members
Eco.Persistence.Design Namespace


SybaseConfigurator.FilterData Method

SybaseConfigurator.FilterData Method
SybaseConfigurator Class SybaseConfigurator Members Eco.Persistence.Design Namespace See Also
Collapse All

This method should return the name of the Dbx provider (such as Interbase, MSSQL or Oracle). There can be multiple configurators for the same provider.

C#
protected override string FilterData();
Remarks

Own members

See Also
SybaseConfigurator Class
SybaseConfigurator Members
Eco.Persistence.Design Namespace


SybaseConfigurator.SupportedDataBaseEngine Method

SybaseConfigurator.SupportedDataBaseEngine Method
SybaseConfigurator Class SybaseConfigurator Members Eco.Persistence.Design Namespace See Also
Collapse All

Override this method to provide the engine enum handled by the configurator.

C#
public override DataBaseEngine SupportedDataBaseEngine();
See Also
SybaseConfigurator Class
SybaseConfigurator Members
Eco.Persistence.Design Namespace


ValidateModelTool Class

ValidateModelTool Class
ValidateModelTool Members Inheritance Hierarchy See Also
Collapse All

Tool that implements model validation.

C#
public class ValidateModelTool : DBToolBase, IModelValidateTool;
Inheritance Hierarchy
Eco.Persistence.Design.DBToolBase
    Eco.Persistence.Design.ValidateModelTool
File

EcoSpaceDesignerToolsDb.cs

See Also
ValidateModelTool Members
Inheritance Hierarchy


ValidateModelTool Members

ValidateModelTool Members
Protected Methods Public Methods Public Properties
Collapse All

The following tables list the members exposed by ValidateModelTool.

Protected Methods
Name | Description
DoExecute | Executes the model validation.
GetMessageCaption | Returns the string used as prefix when logging messages for this tool
GetPersistenceMapper | Returns the persistence mapper associated with the active designer.
GetTypeSystemService | Returns the ITypeSystemService associated with the active designer.
Top
Public Methods
Name | Description
Execute | The execute method is a wrapper for DoExecute.
GetCaption |
GetDesignerTypes | Specifies which designer types this tool is associated with.
Top
Public Properties
Name | Description
ValidationReport | Returns the validation report.


ValidateModelTool Methods

ValidateModelTool Methods
Protected Methods Public Methods
Collapse All

The methods of the ValidateModelTool class are listed here.

Protected Methods
Name | Description
DoExecute | Executes the model validation.
GetMessageCaption | Returns the string used as prefix when logging messages for this tool
Top
Public Methods
Name | Description
GetCaption |


ValidateModelTool.DoExecute Method

ValidateModelTool.DoExecute Method
ValidateModelTool Class ValidateModelTool Members Eco.Persistence.Design Namespace See Also
Collapse All

Executes the model validation.

C#
protected override void DoExecute(
    ExecuteArgs executeArgs
);
Remarks

This tool makes use of the ValidatorPluginsValidator which it instantiates and asks to validate the current model. The results from the validation are stored in the ValidationReport and displayed in the IDE's message display facility.

See Also
ValidateModelTool Class
ValidateModelTool Members
Eco.Persistence.Design Namespace


ValidateModelTool.GetCaption Method

ValidateModelTool.GetCaption Method
ValidateModelTool Class ValidateModelTool Members Eco.Persistence.Design Namespace See Also
Collapse All
C#
public override string GetCaption();
See Also
ValidateModelTool Class
ValidateModelTool Members
Eco.Persistence.Design Namespace


ValidateModelTool.GetMessageCaption Method

ValidateModelTool.GetMessageCaption Method
ValidateModelTool Class ValidateModelTool Members Eco.Persistence.Design Namespace See Also
Collapse All

Returns the string used as prefix when logging messages for this tool

C#
protected override string GetMessageCaption();
See Also
ValidateModelTool Class
ValidateModelTool Members
Eco.Persistence.Design Namespace


ValidateModelTool Properties

ValidateModelTool Properties
Public Properties
Collapse All

The properties of the ValidateModelTool class are listed here.

Public Properties
Name | Description
ValidationReport | Returns the validation report.


ValidateModelTool.ValidationReport Property

ValidateModelTool.ValidationReport Property
ValidateModelTool Class ValidateModelTool Members Eco.Persistence.Design Namespace See Also
Collapse All

Returns the validation report.

C#
public ValidationReport ValidationReport;
Remarks

Note that the report is not created by this call, but via the Execute (DoExecute) operation.

See Also
ValidateModelTool Class
ValidateModelTool Members
Eco.Persistence.Design Namespace


IMapperVerbConfigurator Interface

IMapperVerbConfigurator Interface
IMapperVerbConfigurator Members Inheritance Hierarchy See Also
Collapse All

This interfaced is used to add verbs to the PersistenceHandleDesigner.

C#
public interface IMapperVerbConfigurator;
Remarks

The interface has to be implemented and (an instance of the implementor) registered using PersistenceHandleDesigner.RegisterConfigurator(configurator) The benefit of using this approach rather than adding verbs the "normal" way is the softness of this pattern; verbs can be added without having access to the source of the designer.

Inheritance Hierarchy
Eco.Persistence.Design.IMapperVerbConfigurator
    Eco.Persistence.Design.AbstractBdpConfigurator
    Eco.Persistence.Design.AbstractDbxConfigurator
    Eco.Persistence.Design.FirebirdConfiguratorFirebirdClient
    Eco.Persistence.Design.MimerConfiguratorMimerClient
    Eco.Persistence.Design.MySql4Configurator
    Eco.Persistence.Design.MySql5Configurator
    Eco.Persistence.Design.OracleConfiguratorOracleClient
    Eco.Persistence.Design.SQLServer7ConfiguratorSqlClient
    Eco.Persistence.Design.SQLServer7ConfiguratorSqlClientMBCS
    Eco.Persistence.Design.SQLServerConfiguratorSqlClient
    Eco.Persistence.Design.SQLServerConfiguratorSqlClientMBCS
File

PersistenceHandleDesigner.cs

See Also
IMapperVerbConfigurator Members
Inheritance Hierarchy


IMapperVerbConfigurator Members

IMapperVerbConfigurator Members
Public Methods
Collapse All

The following tables list the members exposed by IMapperVerbConfigurator.

Public Methods
Name | Description
Caption | The caption of the verb.
ConfigureBackend | Configure SqlDatabaseConfig approprately. This method is called from inside a designer transaction
IsVerbFor | The configurator must decide if it can act in current circumstances
PersistenceMapperType | Return the type of the PersistenceMapper this configurator deals with


IMapperVerbConfigurator Methods

IMapperVerbConfigurator Methods
Public Methods
Collapse All

The methods of the IMapperVerbConfigurator class are listed here.

Public Methods
Name | Description
Caption | The caption of the verb.
ConfigureBackend | Configure SqlDatabaseConfig approprately. This method is called from inside a designer transaction
IsVerbFor | The configurator must decide if it can act in current circumstances
PersistenceMapperType | Return the type of the PersistenceMapper this configurator deals with


IMapperVerbConfigurator.Caption Method

IMapperVerbConfigurator.Caption Method
IMapperVerbConfigurator Interface IMapperVerbConfigurator Members Eco.Persistence.Design Namespace See Also
Collapse All

The caption of the verb.

C#
string Caption();
See Also
IMapperVerbConfigurator Interface
IMapperVerbConfigurator Members
Eco.Persistence.Design Namespace


IMapperVerbConfigurator.ConfigureBackend Method

IMapperVerbConfigurator.ConfigureBackend Method
IMapperVerbConfigurator Interface IMapperVerbConfigurator Members Eco.Persistence.Design Namespace See Also
Collapse All

Configure SqlDatabaseConfig approprately. This method is called from inside a designer transaction

C#
void ConfigureBackend(
    SqlDatabaseConfig sqlDatabaseConfig
);
See Also
IMapperVerbConfigurator Interface
IMapperVerbConfigurator Members
Eco.Persistence.Design Namespace


IMapperVerbConfigurator.IsVerbFor Method

IMapperVerbConfigurator.IsVerbFor Method
IMapperVerbConfigurator Interface IMapperVerbConfigurator Members Eco.Persistence.Design Namespace See Also
Collapse All

The configurator must decide if it can act in current circumstances

C#
bool IsVerbFor(
    Component component
);
See Also
IMapperVerbConfigurator Interface
IMapperVerbConfigurator Members
Eco.Persistence.Design Namespace


IMapperVerbConfigurator.PersistenceMapperType Method

IMapperVerbConfigurator.PersistenceMapperType Method
IMapperVerbConfigurator Interface IMapperVerbConfigurator Members Eco.Persistence.Design Namespace See Also
Collapse All

Return the type of the PersistenceMapper this configurator deals with

C#
object PersistenceMapperType();
See Also
IMapperVerbConfigurator Interface
IMapperVerbConfigurator Members
Eco.Persistence.Design Namespace


Eco.Persistence.Oracle.Design Namespace

Eco.Persistence.Oracle.Design Namespace
Classes
Collapse All

This is namespace Eco.Persistence.Oracle.Design.

Classes
Name | Description
Registration | Singleton class used to perform design time initialization code.


Registration Class

Registration Class
Registration Members Inheritance Hierarchy See Also
Collapse All

Singleton class used to perform design time initialization code.

C#
public sealed class Registration;
Inheritance Hierarchy
Eco.Persistence.Oracle.Design.Registration
File

IDERegister.cs

See Also
Registration Members
Inheritance Hierarchy


Registration.IDERegister Method

Registration.IDERegister Method
Registration Class Registration Members Eco.Persistence.Oracle.Design Namespace See Also
Collapse All

Called during IDE startup to execute initialization code.

C#
public static void IDERegister();
See Also
Registration Class
Registration Members
Eco.Persistence.Oracle.Design Namespace


Eco.Persistence.Xml.Design Namespace

Eco.Persistence.Xml.Design Namespace
Classes
Collapse All

This is namespace Eco.Persistence.Xml.Design.

Classes
Name | Description
NewXmlFileNameEditor | Filename editor for files with extension xml.
PersistenceMapperXmlInspector | Provider for context sensitive task help for PersistenceMapperXml.


NewXmlFileNameEditor Class

NewXmlFileNameEditor Class
NewXmlFileNameEditor Members Inheritance Hierarchy See Also
Collapse All

Filename editor for files with extension xml.

C#
public class NewXmlFileNameEditor : FileNameEditor;
Inheritance Hierarchy
Eco.Persistence.Xml.Design.NewXmlFileNameEditor
File

FilenameEditor.cs

See Also
NewXmlFileNameEditor Members
Inheritance Hierarchy


NewXmlFileNameEditor Members

NewXmlFileNameEditor Members
Protected Methods
Collapse All

The following tables list the members exposed by NewXmlFileNameEditor.

Protected Methods
Name | Description
InitializeDialog | Initializes the file open dialog.


NewXmlFileNameEditor Methods

NewXmlFileNameEditor Methods
Protected Methods
Collapse All

The methods of the NewXmlFileNameEditor class are listed here.

Protected Methods
Name | Description
InitializeDialog | Initializes the file open dialog.


NewXmlFileNameEditor.InitializeDialog Method

NewXmlFileNameEditor.InitializeDialog Method
NewXmlFileNameEditor Class NewXmlFileNameEditor Members Eco.Persistence.Xml.Design Namespace See Also
Collapse All

Initializes the file open dialog.

C#
protected override void InitializeDialog(
    OpenFileDialog openFileDialog
);
Parameters
Parameters | Description
openFileDialog | The dialog that will open to select the file.
Remarks

Refines the openFileDialog to not require CheckFileExists, sets the title and sets the default extension to xml.

Exceptions
Exceptions | Description
ArgumentNullException | Thrown if openFileDialog is null.
See Also
NewXmlFileNameEditor Class
NewXmlFileNameEditor Members
Eco.Persistence.Xml.Design Namespace


PersistenceMapperXmlInspector Class

PersistenceMapperXmlInspector Class
PersistenceMapperXmlInspector Members Inheritance Hierarchy See Also
Collapse All

Provider for context sensitive task help for PersistenceMapperXml.

C#
internal sealed class PersistenceMapperXmlInspector : Inspector;
Remarks

This class provides tool tips for PersistenceMapperXml. It is used by the EcoDesigner and should not be instantiated by user.

Inheritance Hierarchy
Eco.Persistence.Xml.Design.PersistenceMapperXmlInspector
File

ComponentInspectorsXml.cs

See Also
PersistenceMapperXmlInspector Members
Inheritance Hierarchy


PersistenceMapperXmlInspector Members

PersistenceMapperXmlInspector Members
Public Methods
Collapse All

The following tables list the members exposed by PersistenceMapperXmlInspector.

Public Methods
Name | Description
PersistenceMapperXmlInspector | This is PersistenceMapperXmlInspector, a member of class PersistenceMapperXmlInspector.
RetrieveToolTip | Adds the strings specific for PersistenceMapperXml.


PersistenceMapperXmlInspector.PersistenceMapperXmlInspector Constructor

PersistenceMapperXmlInspector.PersistenceMapperXmlInspector Constructor
PersistenceMapperXmlInspector Class PersistenceMapperXmlInspector Members Eco.Persistence.Xml.Design Namespace See Also
Collapse All
C#
public PersistenceMapperXmlInspector();
Remarks

This is PersistenceMapperXmlInspector, a member of class PersistenceMapperXmlInspector.

See Also
PersistenceMapperXmlInspector Class
PersistenceMapperXmlInspector Members
Eco.Persistence.Xml.Design Namespace


PersistenceMapperXmlInspector Methods

PersistenceMapperXmlInspector Methods
Public Methods
Collapse All

The methods of the PersistenceMapperXmlInspector class are listed here.

Public Methods
Name | Description
RetrieveToolTip | Adds the strings specific for PersistenceMapperXml.


PersistenceMapperXmlInspector.RetrieveToolTip Method

PersistenceMapperXmlInspector.RetrieveToolTip Method
PersistenceMapperXmlInspector Class PersistenceMapperXmlInspector Members Eco.Persistence.Xml.Design Namespace See Also
Collapse All

Adds the strings specific for PersistenceMapperXml.

C#
public override string RetrieveToolTip(
    object component
);
Parameters
Parameters | Description
component | The component to inspect.
See Also
PersistenceMapperXmlInspector Class
PersistenceMapperXmlInspector Members
Eco.Persistence.Xml.Design Namespace


Eco.Tree Namespace

Eco.Tree Namespace
Classes
Collapse All

This is namespace Eco.Tree.

Classes
Name | Description
EcoTreeEditorWakeup | This is class Eco.Tree.EcoTreeEditorWakeup.


EcoTreeEditorWakeup Class

EcoTreeEditorWakeup Class
EcoTreeEditorWakeup Members Inheritance Hierarchy See Also
Collapse All
C#
public class EcoTreeEditorWakeup : System.Drawing.Design.UITypeEditor;
Remarks

This is class Eco.Tree.EcoTreeEditorWakeup.

Inheritance Hierarchy
Eco.Tree.EcoTreeEditorWakeup
File

EcoTreeEditorWakeup.cs

See Also
EcoTreeEditorWakeup Members
Inheritance Hierarchy


EcoTreeEditorWakeup Members

EcoTreeEditorWakeup Members
Protected Methods Public Methods
Collapse All

The following tables list the members exposed by EcoTreeEditorWakeup.

Protected Methods
Name | Description
EcoTreeEditorWakeup | This is EcoTreeEditorWakeup, a member of class EcoTreeEditorWakeup.
Top
Public Methods
Name | Description
EditValue | This is EditValue, a member of class EcoTreeEditorWakeup.
GetEditStyle | Sets the editor to be modal.


EcoTreeEditorWakeup.EcoTreeEditorWakeup Constructor

EcoTreeEditorWakeup.EcoTreeEditorWakeup Constructor
EcoTreeEditorWakeup Class EcoTreeEditorWakeup Members Eco.Tree Namespace See Also
Collapse All
C#
protected EcoTreeEditorWakeup();
Remarks

This is EcoTreeEditorWakeup, a member of class EcoTreeEditorWakeup.

See Also
EcoTreeEditorWakeup Class
EcoTreeEditorWakeup Members
Eco.Tree Namespace


EcoTreeEditorWakeup Methods

EcoTreeEditorWakeup Methods
Public Methods
Collapse All

The methods of the EcoTreeEditorWakeup class are listed here.

Public Methods
Name | Description
EditValue | This is EditValue, a member of class EcoTreeEditorWakeup.
GetEditStyle | Sets the editor to be modal.


EcoTreeEditorWakeup.EditValue Method

EcoTreeEditorWakeup.EditValue Method
EcoTreeEditorWakeup Class EcoTreeEditorWakeup Members Eco.Tree Namespace See Also
Collapse All
C#
public override object EditValue(
    ITypeDescriptorContext context,
    IServiceProvider provider,
    object value
);
Remarks

This is EditValue, a member of class EcoTreeEditorWakeup.

See Also
EcoTreeEditorWakeup Class
EcoTreeEditorWakeup Members
Eco.Tree Namespace


EcoTreeEditorWakeup.GetEditStyle Method

EcoTreeEditorWakeup.GetEditStyle Method
EcoTreeEditorWakeup Class EcoTreeEditorWakeup Members Eco.Tree Namespace See Also
Collapse All

Sets the editor to be modal.

C#
public override UITypeEditorEditStyle GetEditStyle(
    ITypeDescriptorContext context
);
See Also
EcoTreeEditorWakeup Class
EcoTreeEditorWakeup Members
Eco.Tree Namespace


Eco.Web.Design Namespace

Eco.Web.Design Namespace
Classes
Collapse All

This is namespace Eco.Web.Design.

Classes
Name | Description
AllInstancesWebWidgetsCreatorHandler | This is class Eco.Web.Design.AllInstancesWebWidgetsCreatorHandler.
AspValidator | Implements validation for EcoDataSource and other ASP controls
EcoDataSourceColumnCollectionEditor | Editor for the EcoDataSourceColumnCollection class.
EcoDataSourceDesigner | Summary description for EcoDataSourceDesinger.
EcoDataSourceDesignerSchema | Summary description for Class1.
EcoDataSourceFieldSchema | This is class Eco.Web.Design.EcoDataSourceFieldSchema.
EcoDesignerDataSourceView |
EcoSpaceManagerDesigner | FIXME move to own file
Registration | Singleton class used to perform design time initialization code.
WebControlNameManipulator | This is class Eco.Web.Design.WebControlNameManipulator.


AllInstancesWebWidgetsCreatorHandler Class

AllInstancesWebWidgetsCreatorHandler Class
AllInstancesWebWidgetsCreatorHandler Members Inheritance Hierarchy See Also
Collapse All
C#
public class AllInstancesWebWidgetsCreatorHandler : CreatorHandler;
Remarks

This is class Eco.Web.Design.AllInstancesWebWidgetsCreatorHandler.

Inheritance Hierarchy
Eco.Web.Design.AllInstancesWebWidgetsCreatorHandler
File

EcoWebPropertyManipulators.cs

See Also
AllInstancesWebWidgetsCreatorHandler Members
Inheritance Hierarchy


AllInstancesWebWidgetsCreatorHandler Members

AllInstancesWebWidgetsCreatorHandler Members
Public Methods Protected Properties
Collapse All

The following tables list the members exposed by AllInstancesWebWidgetsCreatorHandler.

Public Methods
Name | Description
AllInstancesWebWidgetsCreatorHandler | This is AllInstancesWebWidgetsCreatorHandler, a member of class AllInstancesWebWidgetsCreatorHandler.
RefreshCreatorTree | Adds creators for defined classes.
Top
Protected Properties
Name | Description
Filename | do not localize;
TopNodename | do not localize;


AllInstancesWebWidgetsCreatorHandler.AllInstancesWebWidgetsCreatorHandler Constructor

AllInstancesWebWidgetsCreatorHandler.AllInstancesWebWidgetsCreatorHandler Constructor
AllInstancesWebWidgetsCreatorHandler Class AllInstancesWebWidgetsCreatorHandler Members Eco.Web.Design Namespace See Also
Collapse All
C#
public AllInstancesWebWidgetsCreatorHandler();
Remarks

This is AllInstancesWebWidgetsCreatorHandler, a member of class AllInstancesWebWidgetsCreatorHandler.

See Also
AllInstancesWebWidgetsCreatorHandler Class
AllInstancesWebWidgetsCreatorHandler Members
Eco.Web.Design Namespace


AllInstancesWebWidgetsCreatorHandler Methods

AllInstancesWebWidgetsCreatorHandler Methods
Public Methods
Collapse All

The methods of the AllInstancesWebWidgetsCreatorHandler class are listed here.

Public Methods
Name | Description
RefreshCreatorTree | Adds creators for defined classes.


AllInstancesWebWidgetsCreatorHandler.RefreshCreatorTree Method

AllInstancesWebWidgetsCreatorHandler.RefreshCreatorTree Method
AllInstancesWebWidgetsCreatorHandler Class AllInstancesWebWidgetsCreatorHandler Members Eco.Web.Design Namespace See Also
Collapse All

Adds creators for defined classes.

C#
public override void RefreshCreatorTree(
    DesignerData designerData
);
Remarks

InvokingComponent is ReferenceHandle, its TypeSystem must be available. The config node is "classifier". Nodes are created for all classes in the type system.

See Also
AllInstancesWebWidgetsCreatorHandler Class
AllInstancesWebWidgetsCreatorHandler Members
Eco.Web.Design Namespace


AllInstancesWebWidgetsCreatorHandler Properties

AllInstancesWebWidgetsCreatorHandler Properties
Protected Properties
Collapse All

The properties of the AllInstancesWebWidgetsCreatorHandler class are listed here.

Protected Properties
Name | Description
Filename | do not localize;
TopNodename | do not localize;


AllInstancesWebWidgetsCreatorHandler.Filename Property

AllInstancesWebWidgetsCreatorHandler.Filename Property
AllInstancesWebWidgetsCreatorHandler Class AllInstancesWebWidgetsCreatorHandler Members Eco.Web.Design Namespace See Also
Collapse All
C#
protected override string Filename;
Remarks

do not localize;

See Also
AllInstancesWebWidgetsCreatorHandler Class
AllInstancesWebWidgetsCreatorHandler Members
Eco.Web.Design Namespace


AllInstancesWebWidgetsCreatorHandler.TopNodename Property

AllInstancesWebWidgetsCreatorHandler.TopNodename Property
AllInstancesWebWidgetsCreatorHandler Class AllInstancesWebWidgetsCreatorHandler Members Eco.Web.Design Namespace See Also
Collapse All
C#
protected override string TopNodename;
Remarks

do not localize;

See Also
AllInstancesWebWidgetsCreatorHandler Class
AllInstancesWebWidgetsCreatorHandler Members
Eco.Web.Design Namespace


AspValidator Class

AspValidator Class
AspValidator Members Inheritance Hierarchy See Also
Collapse All

Implements validation for EcoDataSource and other ASP controls

C#
public class AspValidator : IFormValidator;
Inheritance Hierarchy
Eco.Web.Design.AspValidator
File

AspValidator.cs

See Also
AspValidator Members
Inheritance Hierarchy


AspValidator Members

AspValidator Members
Public Methods
Collapse All

The following tables list the members exposed by AspValidator.

Public Methods
Name | Description
ValidateComponent | Validates the component.


AspValidator Methods

AspValidator Methods
Public Methods
Collapse All

The methods of the AspValidator class are listed here.

Public Methods
Name | Description
ValidateComponent | Validates the component.


AspValidator.ValidateComponent Method

AspValidator.ValidateComponent Method
AspValidator Class AspValidator Members Eco.Web.Design Namespace See Also
Collapse All

Validates the component.

C#
public void ValidateComponent(
    FormValidatorArgs args
);
Remarks

Checks that EcoDataSource have EcoSpaceManagerID set. Yields a hint. Checks that EcoSpaceManager have EcoSpaceTypeName set. Yields a hint. Validates the expressions of columns of EcoDataSource by means of EcoValidationHelper.ValidateEcoComponent. Validates the expressions (Expression and PsExpression) of EcoDataSource using EcoValidationHelper.ValidateExpression.

See Also
AspValidator Class
AspValidator Members
Eco.Web.Design Namespace


EcoDataSourceColumnCollectionEditor Class

EcoDataSourceColumnCollectionEditor Class
EcoDataSourceColumnCollectionEditor Members Inheritance Hierarchy See Also
Collapse All

Editor for the EcoDataSourceColumnCollection class.

C#
public class EcoDataSourceColumnCollectionEditor : CollectionEditor;
Inheritance Hierarchy
Eco.Web.Design.EcoDataSourceColumnCollectionEditor
File

EcoDataSourceColumnCollectionEditor.cs

See Also
EcoDataSourceColumnCollectionEditor Members
Inheritance Hierarchy


EcoDataSourceColumnCollectionEditor Members

EcoDataSourceColumnCollectionEditor Members
Protected Methods Public Methods
Collapse All

The following tables list the members exposed by EcoDataSourceColumnCollectionEditor.

Protected Methods
Name | Description
CreateNewItemTypes | Specifies that the collection can contain OclColumn and EventDerivedColumn.
Top
Public Methods
Name | Description
EcoDataSourceColumnCollectionEditor | This is EcoDataSourceColumnCollectionEditor, a member of class EcoDataSourceColumnCollectionEditor.


EcoDataSourceColumnCollectionEditor.EcoDataSourceColumnCollectionEditor Constructor

EcoDataSourceColumnCollectionEditor.EcoDataSourceColumnCollectionEditor Constructor
EcoDataSourceColumnCollectionEditor Class EcoDataSourceColumnCollectionEditor Members Eco.Web.Design Namespace See Also
Collapse All
C#
public EcoDataSourceColumnCollectionEditor(
    Type type
);
Remarks

This is EcoDataSourceColumnCollectionEditor, a member of class EcoDataSourceColumnCollectionEditor.

See Also
EcoDataSourceColumnCollectionEditor Class
EcoDataSourceColumnCollectionEditor Members
Eco.Web.Design Namespace


EcoDataSourceColumnCollectionEditor Methods

EcoDataSourceColumnCollectionEditor Methods
Protected Methods
Collapse All

The methods of the EcoDataSourceColumnCollectionEditor class are listed here.

Protected Methods
Name | Description
CreateNewItemTypes | Specifies that the collection can contain OclColumn and EventDerivedColumn.


EcoDataSourceColumnCollectionEditor.CreateNewItemTypes Method

EcoDataSourceColumnCollectionEditor.CreateNewItemTypes Method
EcoDataSourceColumnCollectionEditor Class EcoDataSourceColumnCollectionEditor Members Eco.Web.Design Namespace See Also
Collapse All

Specifies that the collection can contain OclColumn and EventDerivedColumn.

C#
protected override Type[] CreateNewItemTypes();
See Also
EcoDataSourceColumnCollectionEditor Class
EcoDataSourceColumnCollectionEditor Members
Eco.Web.Design Namespace


EcoDataSourceDesigner Class

EcoDataSourceDesigner Class
EcoDataSourceDesigner Members Inheritance Hierarchy See Also
Collapse All

Summary description for EcoDataSourceDesinger.

C#
public class EcoDataSourceDesigner : DataSourceDesigner;
Inheritance Hierarchy
Eco.Web.Design.EcoDataSourceDesigner
File

EcoDataSourceDesigner.cs

See Also
EcoDataSourceDesigner Members
Inheritance Hierarchy


EcoDataSourceDesigner Members

EcoDataSourceDesigner Members
Public Methods Public Properties
Collapse All

The following tables list the members exposed by EcoDataSourceDesigner.

Public Methods
Name | Description
EcoDataSourceDesigner | This is EcoDataSourceDesigner, a member of class EcoDataSourceDesigner.
GetView | This is GetView, a member of class EcoDataSourceDesigner.
GetViewNames | This is GetViewNames, a member of class EcoDataSourceDesigner.
RefreshSchema | This is RefreshSchema, a member of class EcoDataSourceDesigner.
Top
Public Properties
Name | Description
Verbs | This is Verbs, a member of class EcoDataSourceDesigner.


EcoDataSourceDesigner.EcoDataSourceDesigner Constructor

EcoDataSourceDesigner.EcoDataSourceDesigner Constructor
EcoDataSourceDesigner Class EcoDataSourceDesigner Members Eco.Web.Design Namespace See Also
Collapse All
C#
public EcoDataSourceDesigner();
Remarks

This is EcoDataSourceDesigner, a member of class EcoDataSourceDesigner.

See Also
EcoDataSourceDesigner Class
EcoDataSourceDesigner Members
Eco.Web.Design Namespace


EcoDataSourceDesigner Methods

EcoDataSourceDesigner Methods
Public Methods
Collapse All

The methods of the EcoDataSourceDesigner class are listed here.

Public Methods
Name | Description
GetView | This is GetView, a member of class EcoDataSourceDesigner.
GetViewNames | This is GetViewNames, a member of class EcoDataSourceDesigner.
RefreshSchema | This is RefreshSchema, a member of class EcoDataSourceDesigner.


EcoDataSourceDesigner.GetView Method

EcoDataSourceDesigner.GetView Method
EcoDataSourceDesigner Class EcoDataSourceDesigner Members Eco.Web.Design Namespace See Also
Collapse All
C#
public override DesignerDataSourceView GetView(
    string viewName
);
Remarks

This is GetView, a member of class EcoDataSourceDesigner.

See Also
EcoDataSourceDesigner Class
EcoDataSourceDesigner Members
Eco.Web.Design Namespace


EcoDataSourceDesigner.GetViewNames Method

EcoDataSourceDesigner.GetViewNames Method
EcoDataSourceDesigner Class EcoDataSourceDesigner Members Eco.Web.Design Namespace See Also
Collapse All
C#
public override string[] GetViewNames();
Remarks

This is GetViewNames, a member of class EcoDataSourceDesigner.

See Also
EcoDataSourceDesigner Class
EcoDataSourceDesigner Members
Eco.Web.Design Namespace


EcoDataSourceDesigner.RefreshSchema Method

EcoDataSourceDesigner.RefreshSchema Method
EcoDataSourceDesigner Class EcoDataSourceDesigner Members Eco.Web.Design Namespace See Also
Collapse All
C#
public override void RefreshSchema(
    bool preferSilent
);
Remarks

This is RefreshSchema, a member of class EcoDataSourceDesigner.

See Also
EcoDataSourceDesigner Class
EcoDataSourceDesigner Members
Eco.Web.Design Namespace


EcoDataSourceDesigner Properties

EcoDataSourceDesigner Properties
Public Properties
Collapse All

The properties of the EcoDataSourceDesigner class are listed here.

Public Properties
Name | Description
Verbs | This is Verbs, a member of class EcoDataSourceDesigner.


EcoDataSourceDesigner.Verbs Property

EcoDataSourceDesigner.Verbs Property
EcoDataSourceDesigner Class EcoDataSourceDesigner Members Eco.Web.Design Namespace See Also
Collapse All
C#
public override DesignerVerbCollection Verbs;
Remarks

This is Verbs, a member of class EcoDataSourceDesigner.

See Also
EcoDataSourceDesigner Class
EcoDataSourceDesigner Members
Eco.Web.Design Namespace


EcoDataSourceDesignerSchema Class

EcoDataSourceDesignerSchema Class
EcoDataSourceDesignerSchema Members Inheritance Hierarchy See Also
Collapse All

Summary description for Class1.

C#
public class EcoDataSourceDesignerSchema : IDataSourceViewSchema;
Inheritance Hierarchy
Eco.Web.Design.EcoDataSourceDesignerSchema
File

EcoDataSourceDesignerSchema.cs

See Also
EcoDataSourceDesignerSchema Members
Inheritance Hierarchy


EcoDataSourceDesignerSchema Members

EcoDataSourceDesignerSchema Members
Public Methods Public Properties
Collapse All

The following tables list the members exposed by EcoDataSourceDesignerSchema.

Public Methods
Name | Description
EcoDataSourceDesignerSchema | This is EcoDataSourceDesignerSchema, a member of class EcoDataSourceDesignerSchema.
GetChildren | This is GetChildren, a member of class EcoDataSourceDesignerSchema.
GetFields | This is GetFields, a member of class EcoDataSourceDesignerSchema.
Top
Public Properties
Name | Description
Name | This is Name, a member of class EcoDataSourceDesignerSchema.


EcoDataSourceDesignerSchema.EcoDataSourceDesignerSchema Constructor

EcoDataSourceDesignerSchema.EcoDataSourceDesignerSchema Constructor
EcoDataSourceDesignerSchema Class EcoDataSourceDesignerSchema Members Eco.Web.Design Namespace See Also
Collapse All
C#
public EcoDataSourceDesignerSchema(
    EcoDataSource dataSource
);
Remarks

This is EcoDataSourceDesignerSchema, a member of class EcoDataSourceDesignerSchema.

See Also
EcoDataSourceDesignerSchema Class
EcoDataSourceDesignerSchema Members
Eco.Web.Design Namespace


EcoDataSourceDesignerSchema Methods

EcoDataSourceDesignerSchema Methods
Public Methods
Collapse All

The methods of the EcoDataSourceDesignerSchema class are listed here.

Public Methods
Name | Description
GetChildren | This is GetChildren, a member of class EcoDataSourceDesignerSchema.
GetFields | This is GetFields, a member of class EcoDataSourceDesignerSchema.


EcoDataSourceDesignerSchema.GetChildren Method

EcoDataSourceDesignerSchema.GetChildren Method
EcoDataSourceDesignerSchema Class EcoDataSourceDesignerSchema Members Eco.Web.Design Namespace See Also
Collapse All
C#
public IDataSourceViewSchema[] GetChildren();
Remarks

This is GetChildren, a member of class EcoDataSourceDesignerSchema.

See Also
EcoDataSourceDesignerSchema Class
EcoDataSourceDesignerSchema Members
Eco.Web.Design Namespace


EcoDataSourceDesignerSchema.GetFields Method

EcoDataSourceDesignerSchema.GetFields Method
EcoDataSourceDesignerSchema Class EcoDataSourceDesignerSchema Members Eco.Web.Design Namespace See Also
Collapse All
C#
public IDataSourceFieldSchema[] GetFields();
Remarks

This is GetFields, a member of class EcoDataSourceDesignerSchema.

See Also
EcoDataSourceDesignerSchema Class
EcoDataSourceDesignerSchema Members
Eco.Web.Design Namespace


EcoDataSourceDesignerSchema Properties

EcoDataSourceDesignerSchema Properties
Public Properties
Collapse All

The properties of the EcoDataSourceDesignerSchema class are listed here.

Public Properties
Name | Description
Name | This is Name, a member of class EcoDataSourceDesignerSchema.


EcoDataSourceDesignerSchema.Name Property

EcoDataSourceDesignerSchema.Name Property
EcoDataSourceDesignerSchema Class EcoDataSourceDesignerSchema Members Eco.Web.Design Namespace See Also
Collapse All
C#
public string Name;
Remarks

This is Name, a member of class EcoDataSourceDesignerSchema.

See Also
EcoDataSourceDesignerSchema Class
EcoDataSourceDesignerSchema Members
Eco.Web.Design Namespace


EcoDataSourceFieldSchema Class

EcoDataSourceFieldSchema Class
EcoDataSourceFieldSchema Members Inheritance Hierarchy See Also
Collapse All
C#
public class EcoDataSourceFieldSchema : IDataSourceFieldSchema;
Remarks

This is class Eco.Web.Design.EcoDataSourceFieldSchema.

Inheritance Hierarchy
Eco.Web.Design.EcoDataSourceFieldSchema
File

EcoDataSourceDesignerSchema.cs

See Also
EcoDataSourceFieldSchema Members
Inheritance Hierarchy


EcoDataSourceFieldSchema Members

EcoDataSourceFieldSchema Members
Public Methods Public Properties
Collapse All

The following tables list the members exposed by EcoDataSourceFieldSchema.

Public Methods
Name | Description
EcoDataSourceFieldSchema | This is EcoDataSourceFieldSchema, a member of class EcoDataSourceFieldSchema.
Top
Public Properties
Name | Description
DataType | This is DataType, a member of class EcoDataSourceFieldSchema.
Identity | This is Identity, a member of class EcoDataSourceFieldSchema.
IsReadOnly | This is IsReadOnly, a member of class EcoDataSourceFieldSchema.
IsUnique | This is IsUnique, a member of class EcoDataSourceFieldSchema.
Length | This is Length, a member of class EcoDataSourceFieldSchema.
Name | This is Name, a member of class EcoDataSourceFieldSchema.
Nullable | This is Nullable, a member of class EcoDataSourceFieldSchema.
Precision | This is Precision, a member of class EcoDataSourceFieldSchema.
PrimaryKey | This is PrimaryKey, a member of class EcoDataSourceFieldSchema.
Scale | This is Scale, a member of class EcoDataSourceFieldSchema.


EcoDataSourceFieldSchema.EcoDataSourceFieldSchema Constructor

EcoDataSourceFieldSchema.EcoDataSourceFieldSchema Constructor
EcoDataSourceFieldSchema Class EcoDataSourceFieldSchema Members Eco.Web.Design Namespace See Also
Collapse All
C#
public EcoDataSourceFieldSchema(
    PropertyDescriptor propertyDescriptor
);
Remarks

This is EcoDataSourceFieldSchema, a member of class EcoDataSourceFieldSchema.

See Also
EcoDataSourceFieldSchema Class
EcoDataSourceFieldSchema Members
Eco.Web.Design Namespace


EcoDataSourceFieldSchema Properties

EcoDataSourceFieldSchema Properties
Public Properties
Collapse All

The properties of the EcoDataSourceFieldSchema class are listed here.

Public Properties
Name | Description
DataType | This is DataType, a member of class EcoDataSourceFieldSchema.
Identity | This is Identity, a member of class EcoDataSourceFieldSchema.
IsReadOnly | This is IsReadOnly, a member of class EcoDataSourceFieldSchema.
IsUnique | This is IsUnique, a member of class EcoDataSourceFieldSchema.
Length | This is Length, a member of class EcoDataSourceFieldSchema.
Name | This is Name, a member of class EcoDataSourceFieldSchema.
Nullable | This is Nullable, a member of class EcoDataSourceFieldSchema.
Precision | This is Precision, a member of class EcoDataSourceFieldSchema.
PrimaryKey | This is PrimaryKey, a member of class EcoDataSourceFieldSchema.
Scale | This is Scale, a member of class EcoDataSourceFieldSchema.


EcoDataSourceFieldSchema.DataType Property

EcoDataSourceFieldSchema.DataType Property
EcoDataSourceFieldSchema Class EcoDataSourceFieldSchema Members Eco.Web.Design Namespace See Also
Collapse All
C#
public Type DataType;
Remarks

This is DataType, a member of class EcoDataSourceFieldSchema.

See Also
EcoDataSourceFieldSchema Class
EcoDataSourceFieldSchema Members
Eco.Web.Design Namespace


EcoDataSourceFieldSchema.Identity Property

EcoDataSourceFieldSchema.Identity Property
EcoDataSourceFieldSchema Class EcoDataSourceFieldSchema Members Eco.Web.Design Namespace See Also
Collapse All
C#
public bool Identity;
Remarks

This is Identity, a member of class EcoDataSourceFieldSchema.

See Also
EcoDataSourceFieldSchema Class
EcoDataSourceFieldSchema Members
Eco.Web.Design Namespace


EcoDataSourceFieldSchema.IsReadOnly Property

EcoDataSourceFieldSchema.IsReadOnly Property
EcoDataSourceFieldSchema Class EcoDataSourceFieldSchema Members Eco.Web.Design Namespace See Also
Collapse All
C#
public bool IsReadOnly;
Remarks

This is IsReadOnly, a member of class EcoDataSourceFieldSchema.

See Also
EcoDataSourceFieldSchema Class
EcoDataSourceFieldSchema Members
Eco.Web.Design Namespace


EcoDataSourceFieldSchema.IsUnique Property

EcoDataSourceFieldSchema.IsUnique Property
EcoDataSourceFieldSchema Class EcoDataSourceFieldSchema Members Eco.Web.Design Namespace See Also
Collapse All
C#
public bool IsUnique;
Remarks

This is IsUnique, a member of class EcoDataSourceFieldSchema.

See Also
EcoDataSourceFieldSchema Class
EcoDataSourceFieldSchema Members
Eco.Web.Design Namespace


EcoDataSourceFieldSchema.Length Property

EcoDataSourceFieldSchema.Length Property
EcoDataSourceFieldSchema Class EcoDataSourceFieldSchema Members Eco.Web.Design Namespace See Also
Collapse All
C#
public int Length;
Remarks

This is Length, a member of class EcoDataSourceFieldSchema.

See Also
EcoDataSourceFieldSchema Class
EcoDataSourceFieldSchema Members
Eco.Web.Design Namespace


EcoDataSourceFieldSchema.Name Property

EcoDataSourceFieldSchema.Name Property
EcoDataSourceFieldSchema Class EcoDataSourceFieldSchema Members Eco.Web.Design Namespace See Also
Collapse All
C#
public string Name;
Remarks

This is Name, a member of class EcoDataSourceFieldSchema.

See Also
EcoDataSourceFieldSchema Class
EcoDataSourceFieldSchema Members
Eco.Web.Design Namespace


EcoDataSourceFieldSchema.Nullable Property

EcoDataSourceFieldSchema.Nullable Property
EcoDataSourceFieldSchema Class EcoDataSourceFieldSchema Members Eco.Web.Design Namespace See Also
Collapse All
C#
public bool Nullable;
Remarks

This is Nullable, a member of class EcoDataSourceFieldSchema.

See Also
EcoDataSourceFieldSchema Class
EcoDataSourceFieldSchema Members
Eco.Web.Design Namespace


EcoDataSourceFieldSchema.Precision Property

EcoDataSourceFieldSchema.Precision Property
EcoDataSourceFieldSchema Class EcoDataSourceFieldSchema Members Eco.Web.Design Namespace See Also
Collapse All
C#
public int Precision;
Remarks

This is Precision, a member of class EcoDataSourceFieldSchema.

See Also
EcoDataSourceFieldSchema Class
EcoDataSourceFieldSchema Members
Eco.Web.Design Namespace


EcoDataSourceFieldSchema.PrimaryKey Property

EcoDataSourceFieldSchema.PrimaryKey Property
EcoDataSourceFieldSchema Class EcoDataSourceFieldSchema Members Eco.Web.Design Namespace See Also
Collapse All
C#
public bool PrimaryKey;
Remarks

This is PrimaryKey, a member of class EcoDataSourceFieldSchema.

See Also
EcoDataSourceFieldSchema Class
EcoDataSourceFieldSchema Members
Eco.Web.Design Namespace


EcoDataSourceFieldSchema.Scale Property

EcoDataSourceFieldSchema.Scale Property
EcoDataSourceFieldSchema Class EcoDataSourceFieldSchema Members Eco.Web.Design Namespace See Also
Collapse All
C#
public int Scale;
Remarks

This is Scale, a member of class EcoDataSourceFieldSchema.

See Also
EcoDataSourceFieldSchema Class
EcoDataSourceFieldSchema Members
Eco.Web.Design Namespace


EcoDesignerDataSourceView Class

EcoDesignerDataSourceView Class
EcoDesignerDataSourceView Members Inheritance Hierarchy See Also
Collapse All
C#
internal class EcoDesignerDataSourceView : DesignerDataSourceView;
Inheritance Hierarchy
Eco.Web.Design.EcoDesignerDataSourceView
File

EcoDataSourceDesignerView.cs

See Also
EcoDesignerDataSourceView Members
Inheritance Hierarchy


EcoDesignerDataSourceView Members

EcoDesignerDataSourceView Members
Public Methods Public Properties
Collapse All

The following tables list the members exposed by EcoDesignerDataSourceView.

Public Methods
Name | Description
GetDesignTimeData | This is GetDesignTimeData, a member of class EcoDesignerDataSourceView.
Top
Public Properties
Name | Description
CanDelete | This is CanDelete, a member of class EcoDesignerDataSourceView.
CanInsert | This is CanInsert, a member of class EcoDesignerDataSourceView.
CanPage | This is CanPage, a member of class EcoDesignerDataSourceView.
CanRetrieveTotalRowCount | This is CanRetrieveTotalRowCount, a member of class EcoDesignerDataSourceView.
CanSort | This is CanSort, a member of class EcoDesignerDataSourceView.
CanUpdate | This is CanUpdate, a member of class EcoDesignerDataSourceView.
Schema | This is Schema, a member of class EcoDesignerDataSourceView.


EcoDesignerDataSourceView Methods

EcoDesignerDataSourceView Methods
Public Methods
Collapse All

The methods of the EcoDesignerDataSourceView class are listed here.

Public Methods
Name | Description
GetDesignTimeData | This is GetDesignTimeData, a member of class EcoDesignerDataSourceView.


EcoDesignerDataSourceView.GetDesignTimeData Method

EcoDesignerDataSourceView.GetDesignTimeData Method
EcoDesignerDataSourceView Class EcoDesignerDataSourceView Members Eco.Web.Design Namespace See Also
Collapse All
C#
public override IEnumerable GetDesignTimeData(
    int minimumRows,
    out bool isSampleData
);
Remarks

This is GetDesignTimeData, a member of class EcoDesignerDataSourceView.

See Also
EcoDesignerDataSourceView Class
EcoDesignerDataSourceView Members
Eco.Web.Design Namespace


EcoDesignerDataSourceView Properties

EcoDesignerDataSourceView Properties
Public Properties
Collapse All

The properties of the EcoDesignerDataSourceView class are listed here.

Public Properties
Name | Description
CanDelete | This is CanDelete, a member of class EcoDesignerDataSourceView.
CanInsert | This is CanInsert, a member of class EcoDesignerDataSourceView.
CanPage | This is CanPage, a member of class EcoDesignerDataSourceView.
CanRetrieveTotalRowCount | This is CanRetrieveTotalRowCount, a member of class EcoDesignerDataSourceView.
CanSort | This is CanSort, a member of class EcoDesignerDataSourceView.
CanUpdate | This is CanUpdate, a member of class EcoDesignerDataSourceView.
Schema | This is Schema, a member of class EcoDesignerDataSourceView.


EcoDesignerDataSourceView.CanDelete Property

EcoDesignerDataSourceView.CanDelete Property
EcoDesignerDataSourceView Class EcoDesignerDataSourceView Members Eco.Web.Design Namespace See Also
Collapse All
C#
public override bool CanDelete;
Remarks

This is CanDelete, a member of class EcoDesignerDataSourceView.

See Also
EcoDesignerDataSourceView Class
EcoDesignerDataSourceView Members
Eco.Web.Design Namespace


EcoDesignerDataSourceView.CanInsert Property

EcoDesignerDataSourceView.CanInsert Property
EcoDesignerDataSourceView Class EcoDesignerDataSourceView Members Eco.Web.Design Namespace See Also
Collapse All
C#
public override bool CanInsert;
Remarks

This is CanInsert, a member of class EcoDesignerDataSourceView.

See Also
EcoDesignerDataSourceView Class
EcoDesignerDataSourceView Members
Eco.Web.Design Namespace


EcoDesignerDataSourceView.CanPage Property

EcoDesignerDataSourceView.CanPage Property
EcoDesignerDataSourceView Class EcoDesignerDataSourceView Members Eco.Web.Design Namespace See Also
Collapse All
C#
public override bool CanPage;
Remarks

This is CanPage, a member of class EcoDesignerDataSourceView.

See Also
EcoDesignerDataSourceView Class
EcoDesignerDataSourceView Members
Eco.Web.Design Namespace


EcoDesignerDataSourceView.CanRetrieveTotalRowCount Property

EcoDesignerDataSourceView.CanRetrieveTotalRowCount Property
EcoDesignerDataSourceView Class EcoDesignerDataSourceView Members Eco.Web.Design Namespace See Also
Collapse All
C#
public override bool CanRetrieveTotalRowCount;
Remarks

This is CanRetrieveTotalRowCount, a member of class EcoDesignerDataSourceView.

See Also
EcoDesignerDataSourceView Class
EcoDesignerDataSourceView Members
Eco.Web.Design Namespace


EcoDesignerDataSourceView.CanSort Property

EcoDesignerDataSourceView.CanSort Property
EcoDesignerDataSourceView Class EcoDesignerDataSourceView Members Eco.Web.Design Namespace See Also
Collapse All
C#
public override bool CanSort;
Remarks

This is CanSort, a member of class EcoDesignerDataSourceView.

See Also
EcoDesignerDataSourceView Class
EcoDesignerDataSourceView Members
Eco.Web.Design Namespace


EcoDesignerDataSourceView.CanUpdate Property

EcoDesignerDataSourceView.CanUpdate Property
EcoDesignerDataSourceView Class EcoDesignerDataSourceView Members Eco.Web.Design Namespace See Also
Collapse All
C#
public override bool CanUpdate;
Remarks

This is CanUpdate, a member of class EcoDesignerDataSourceView.

See Also
EcoDesignerDataSourceView Class
EcoDesignerDataSourceView Members
Eco.Web.Design Namespace


EcoDesignerDataSourceView.Schema Property

EcoDesignerDataSourceView.Schema Property
EcoDesignerDataSourceView Class EcoDesignerDataSourceView Members Eco.Web.Design Namespace See Also
Collapse All
C#
public override IDataSourceViewSchema Schema;
Remarks

This is Schema, a member of class EcoDesignerDataSourceView.

See Also
EcoDesignerDataSourceView Class
EcoDesignerDataSourceView Members
Eco.Web.Design Namespace


EcoSpaceManagerDesigner Class

EcoSpaceManagerDesigner Class
EcoSpaceManagerDesigner Members Inheritance Hierarchy See Also
Collapse All
C#
public class EcoSpaceManagerDesigner : ControlDesigner;
Remarks

FIXME move to own file

Inheritance Hierarchy
Eco.Web.Design.EcoSpaceManagerDesigner
File

EcoDataSourceDesigner.cs

See Also
EcoSpaceManagerDesigner Members
Inheritance Hierarchy


EcoSpaceManagerDesigner Members

EcoSpaceManagerDesigner Members
Public Methods
Collapse All

The following tables list the members exposed by EcoSpaceManagerDesigner.

Public Methods
Name | Description
GetDesignTimeHtml | This is GetDesignTimeHtml, a member of class EcoSpaceManagerDesigner.


EcoSpaceManagerDesigner Methods

EcoSpaceManagerDesigner Methods
Public Methods
Collapse All

The methods of the EcoSpaceManagerDesigner class are listed here.

Public Methods
Name | Description
GetDesignTimeHtml | This is GetDesignTimeHtml, a member of class EcoSpaceManagerDesigner.


EcoSpaceManagerDesigner.GetDesignTimeHtml Method

EcoSpaceManagerDesigner.GetDesignTimeHtml Method
EcoSpaceManagerDesigner Class EcoSpaceManagerDesigner Members Eco.Web.Design Namespace See Also
Collapse All
C#
public override string GetDesignTimeHtml();
Remarks

This is GetDesignTimeHtml, a member of class EcoSpaceManagerDesigner.

See Also
EcoSpaceManagerDesigner Class
EcoSpaceManagerDesigner Members
Eco.Web.Design Namespace


Registration Class

Registration Class
Registration Members Inheritance Hierarchy See Also
Collapse All

Singleton class used to perform design time initialization code.

C#
public sealed class Registration;
Inheritance Hierarchy
Eco.Web.Design.Registration
File

IDERegister.cs

See Also
Registration Members
Inheritance Hierarchy


Registration.IDERegister Method

Registration.IDERegister Method
Registration Class Registration Members Eco.Web.Design Namespace See Also
Collapse All

Called during IDE startup to execute initialization code.

C#
public static void IDERegister();
Remarks

This method turns off the EcoLogSwitches.

See Also
Registration Class
Registration Members
Eco.Web.Design Namespace


WebControlNameManipulator Class

WebControlNameManipulator Class
WebControlNameManipulator Members Inheritance Hierarchy See Also
Collapse All
C#
public sealed class WebControlNameManipulator : NameManipulator;
Remarks

This is class Eco.Web.Design.WebControlNameManipulator.

Inheritance Hierarchy
Eco.Web.Design.WebControlNameManipulator
File

EcoWebPropertyManipulators.cs

See Also
WebControlNameManipulator Members
Inheritance Hierarchy


WebControlNameManipulator Members

WebControlNameManipulator Members
Protected Methods
Collapse All

The following tables list the members exposed by WebControlNameManipulator.

Protected Methods
Name | Description
GetPrefix | This is GetPrefix, a member of class WebControlNameManipulator.


WebControlNameManipulator Methods

WebControlNameManipulator Methods
Protected Methods
Collapse All

The methods of the WebControlNameManipulator class are listed here.

Protected Methods
Name | Description
GetPrefix | This is GetPrefix, a member of class WebControlNameManipulator.


WebControlNameManipulator.GetPrefix Method

WebControlNameManipulator.GetPrefix Method
WebControlNameManipulator Class WebControlNameManipulator Members Eco.Web.Design Namespace See Also
Collapse All
C#
protected override string GetPrefix(
    IComponent component
);
Remarks

This is GetPrefix, a member of class WebControlNameManipulator.

See Also
WebControlNameManipulator Class
WebControlNameManipulator Members
Eco.Web.Design Namespace


EcoSpaceDesignerToolbox Members Public Delegates

EcoSpaceDesignerToolbox Members Public Delegates
Public Delegates
Name | Description
EcoToolboxEventHandler | This is nested type Eco.Handles.Design.EcoSpaceDesignerToolbox.EcoToolboxEventHandler.


EcoSpaceDesignerToolbox Delegates Public Delegates

EcoSpaceDesignerToolbox Delegates Public Delegates
Public Delegates
Name | Description
EcoToolboxEventHandler | This is nested type Eco.Handles.Design.EcoSpaceDesignerToolbox.EcoToolboxEventHandler.


Inheritance Hierarchy

Inheritance Hierarchy
Inheritance Hierarchy
System.Windows.Forms.Form
    Eco.Handles.Design.AboutForm


Inheritance Hierarchy

Inheritance Hierarchy
Inheritance Hierarchy
Eco.Handles.Design.NotifyingDesigner
    Eco.Handles.Design.HandlesDesigner
        Eco.Handles.Design.RootedHandleDesigner
            Eco.Handles.Design.AbstractExpressionHandleDesigner
                Eco.Handles.Design.ExpressionHandleDesigner
                Eco.Handles.Design.OclPSHandleDesigner


Inheritance Hierarchy

Inheritance Hierarchy
Inheritance Hierarchy
Eco.Handles.Design.AbstractManipulator
    Eco.Handles.Design.ClientIDManipulator
    Eco.Handles.Design.ColumnsManipulator
    Eco.Handles.Design.ConnectionManipulator
    Eco.Handles.Design.DataBindManipulator
    Eco.Handles.Design.EcoManipulator
    Eco.Handles.Design.NameManipulator


Inheritance Hierarchy

Inheritance Hierarchy
Inheritance Hierarchy
Eco.Handles.Design.ModalExpressionEditor
    Eco.Handles.Design.ExpressionEditor
        Eco.Handles.Design.ActionExpressionEditor


Inheritance Hierarchy

Inheritance Hierarchy
Inheritance Hierarchy
Eco.Handles.Design.AddValidatorsFromXml


Inheritance Hierarchy

Inheritance Hierarchy
Inheritance Hierarchy
Eco.Handles.Design.CreatorHandler
    Eco.Handles.Design.AllInstancesWidgetsCreatorHandler


Inheritance Hierarchy

Inheritance Hierarchy
Inheritance Hierarchy
Eco.Handles.Design.TypeNameSelectorEditor
    Eco.Handles.Design.AnyTypeNameSelectorEditor


Inheritance Hierarchy

Inheritance Hierarchy
Inheritance Hierarchy
Eco.Handles.Design.CreatorHandler
    Eco.Handles.Design.AssociationWidgetsCreatorHandler


Inheritance Hierarchy

Inheritance Hierarchy
Inheritance Hierarchy
Eco.Handles.Design.ChangeEventArgs


Inheritance Hierarchy

Inheritance Hierarchy
Inheritance Hierarchy
Eco.Handles.Design.AbstractManipulator
    Eco.Handles.Design.ClientIDManipulator


Inheritance Hierarchy

Inheritance Hierarchy
Inheritance Hierarchy
Eco.Handles.Design.ColumnCollectionEditor


Inheritance Hierarchy

Inheritance Hierarchy
Inheritance Hierarchy
Eco.Handles.Design.CreatorNodeDescriptor
    Eco.Handles.Design.ColumnCreatorNodeDescriptor


Inheritance Hierarchy

Inheritance Hierarchy
Inheritance Hierarchy
Eco.Handles.Design.AbstractManipulator
    Eco.Handles.Design.ColumnsManipulator


Inheritance Hierarchy

Inheritance Hierarchy
Inheritance Hierarchy
Eco.Handles.Design.CreatorHandler
    Eco.Handles.Design.ColumnWidgetsCreatorHandler


Inheritance Hierarchy

Inheritance Hierarchy
Inheritance Hierarchy
Eco.Handles.Design.ComponentDefinition


Inheritance Hierarchy

Inheritance Hierarchy
Inheritance Hierarchy
Eco.Handles.Design.AbstractManipulator
    Eco.Handles.Design.ConnectionManipulator


Inheritance Hierarchy

Inheritance Hierarchy
Inheritance Hierarchy
Eco.Handles.Design.ContextAgentLogger


Inheritance Hierarchy

Inheritance Hierarchy
Inheritance Hierarchy
Eco.Handles.Design.ContextAgentToolboxItem


Inheritance Hierarchy

Inheritance Hierarchy
Inheritance Hierarchy
System.Windows.Forms.TreeNode
    Eco.Handles.Design.ContextAgentTreeNode
        Eco.Handles.Design.CreatorContextNode


Inheritance Hierarchy

Inheritance Hierarchy
Inheritance Hierarchy
Eco.Handles.Design.ContextAgentWebToolboxItem


Inheritance Hierarchy

Inheritance Hierarchy
Inheritance Hierarchy
Eco.Handles.Design.ContextComponentReader


Inheritance Hierarchy

Inheritance Hierarchy
Inheritance Hierarchy
System.Windows.Forms.Form
    Eco.Handles.Design.ContextComponentsForm


Inheritance Hierarchy

Inheritance Hierarchy
Inheritance Hierarchy
Eco.Handles.Design.ContextController


Inheritance Hierarchy

Inheritance Hierarchy
Inheritance Hierarchy
Eco.Handles.Design.CreatorInfo
    Eco.Handles.Design.CreatorGroup


Inheritance Hierarchy

Inheritance Hierarchy
Inheritance Hierarchy
Eco.Handles.Design.CreatorHandler
    Eco.Handles.Design.AllInstancesWidgetsCreatorHandler
    Eco.Handles.Design.AssociationWidgetsCreatorHandler
    Eco.Handles.Design.ColumnWidgetsCreatorHandler
    Eco.Handles.Design.FormCreatorHandler
    Eco.Handles.Design.ListActionCreatorHandler
    Eco.Handles.Design.PMapperCreatorHandler
    Eco.Handles.Design.ReferenceHandleCreatorHandler


Inheritance Hierarchy

Inheritance Hierarchy
Inheritance Hierarchy
Eco.Handles.Design.CreatorInfo
    Eco.Handles.Design.CreatorGroup
    Eco.Handles.Design.MetaCreator
    Eco.Handles.Design.MetaCreatorType


Inheritance Hierarchy

Inheritance Hierarchy
Inheritance Hierarchy
Eco.Handles.Design.CreatorManager


Inheritance Hierarchy

Inheritance Hierarchy
Inheritance Hierarchy
Eco.Handles.Design.CreatorNodeDescriptor
    Eco.Handles.Design.ColumnCreatorNodeDescriptor
    Eco.Handles.Design.ModelElementNodeDescriptor


Inheritance Hierarchy

Inheritance Hierarchy
Inheritance Hierarchy
Eco.Handles.Design.NotifyingDesigner
    Eco.Handles.Design.HandlesDesigner
        Eco.Handles.Design.RootedHandleDesigner
            Eco.Handles.Design.CurrencyManagerHandleDesigner


Inheritance Hierarchy

Inheritance Hierarchy
Inheritance Hierarchy
Eco.Handles.Design.AbstractManipulator
    Eco.Handles.Design.DataBindManipulator


Inheritance Hierarchy

Inheritance Hierarchy
Inheritance Hierarchy
Eco.Handles.Design.DesignerData


Inheritance Hierarchy

Inheritance Hierarchy
Inheritance Hierarchy
Eco.Handles.Design.DesignStringRes


Inheritance Hierarchy

Inheritance Hierarchy
Inheritance Hierarchy
Eco.Handles.Design.DesignTimeLogger


Inheritance Hierarchy

Inheritance Hierarchy
Inheritance Hierarchy
Eco.Handles.Design.EcoAboutMenuItem


Inheritance Hierarchy

Inheritance Hierarchy
Inheritance Hierarchy
Eco.Handles.Design.NotifyingDesigner
    Eco.Handles.Design.EcoActionExtenderDesigner


Inheritance Hierarchy

Inheritance Hierarchy
Inheritance Hierarchy
Eco.Handles.Design.EcoDatatypesMenuItem


Inheritance Hierarchy

Inheritance Hierarchy
Inheritance Hierarchy
Eco.Handles.Design.EcoDesigner
    Eco.Handles.Design.EcoSpaceDesigner


Inheritance Hierarchy

Inheritance Hierarchy
Inheritance Hierarchy
Eco.Handles.Design.EcoIdeOptions


Inheritance Hierarchy

Inheritance Hierarchy
Inheritance Hierarchy
Eco.Handles.Design.AbstractManipulator
    Eco.Handles.Design.EcoManipulator


Inheritance Hierarchy

Inheritance Hierarchy
Inheritance Hierarchy
Eco.Handles.Design.EcoRegistry


Inheritance Hierarchy

Inheritance Hierarchy
Inheritance Hierarchy
System.Windows.Forms.Form
    Eco.Handles.Design.EcoSettingsForm


Inheritance Hierarchy

Inheritance Hierarchy
Inheritance Hierarchy
System.Windows.Forms.Form
    Eco.Handles.Design.EcoSpaceDesignerForm


Inheritance Hierarchy

Inheritance Hierarchy
Inheritance Hierarchy
Eco.Handles.Design.EcoSpaceDesignerToolbox


Inheritance Hierarchy

Inheritance Hierarchy
Inheritance Hierarchy
Eco.Handles.Design.EcoSpaceInspector


Inheritance Hierarchy

Inheritance Hierarchy
Inheritance Hierarchy
Eco.Handles.Design.GenericTypeNameConverter
    Eco.Handles.Design.EcoSpaceTypeNameTypeConverter


Inheritance Hierarchy

Inheritance Hierarchy
Inheritance Hierarchy
Eco.Handles.Design.TypeTypeConverter
    Eco.Handles.Design.EcoSpaceTypeTypeConverter


Inheritance Hierarchy

Inheritance Hierarchy
Inheritance Hierarchy
Eco.Handles.Design.EcoToolboxArgs


Inheritance Hierarchy

Inheritance Hierarchy
Inheritance Hierarchy
Eco.Handles.Design.IEcoSpaceDesignerTool
    Eco.Handles.Design.EcoToolButtonBase
        Eco.Handles.Design.SelectPackagesTool


Inheritance Hierarchy

Inheritance Hierarchy
Inheritance Hierarchy
Eco.Handles.Design.EcoValidationHelper


Inheritance Hierarchy

Inheritance Hierarchy
Inheritance Hierarchy
Eco.Handles.Design.ErrorContextNode


Inheritance Hierarchy

Inheritance Hierarchy
Inheritance Hierarchy
Eco.Handles.Design.ErrorManager
    Eco.Handles.Design.ModelValidationManager


Inheritance Hierarchy

Inheritance Hierarchy
Inheritance Hierarchy
Eco.Handles.Design.EventTester


Inheritance Hierarchy

Inheritance Hierarchy
Inheritance Hierarchy
Eco.Handles.Design.ExecuteArgs


Inheritance Hierarchy

Inheritance Hierarchy
Inheritance Hierarchy
Eco.Handles.Design.ModalExpressionEditor
    Eco.Handles.Design.ExpressionEditor
        Eco.Handles.Design.ActionExpressionEditor
        Eco.Handles.Design.OclExpressionEditor
        Eco.Handles.Design.OclPsExpressionEditor


Inheritance Hierarchy

Inheritance Hierarchy
Inheritance Hierarchy
Eco.Handles.Design.NotifyingDesigner
    Eco.Handles.Design.HandlesDesigner
        Eco.Handles.Design.RootedHandleDesigner
            Eco.Handles.Design.AbstractExpressionHandleDesigner
                Eco.Handles.Design.ExpressionHandleDesigner


Inheritance Hierarchy

Inheritance Hierarchy
Inheritance Hierarchy
Eco.Handles.Design.CreatorHandler
    Eco.Handles.Design.FormCreatorHandler


Inheritance Hierarchy

Inheritance Hierarchy
Inheritance Hierarchy
Eco.Handles.Design.ValidationIncident
    Eco.Handles.Design.FormValidationIncident


Inheritance Hierarchy

Inheritance Hierarchy
Inheritance Hierarchy
Eco.Handles.Design.ValidationReport
    Eco.Handles.Design.FormValidationReport


Inheritance Hierarchy

Inheritance Hierarchy
Inheritance Hierarchy
Eco.Handles.Design.FormValidator


Inheritance Hierarchy

Inheritance Hierarchy
Inheritance Hierarchy
Eco.Handles.Design.FormValidatorArgs


Inheritance Hierarchy

Inheritance Hierarchy
Inheritance Hierarchy
Eco.Handles.Design.NotifyingDesigner
    Eco.Handles.Design.HandlesDesigner
        Eco.Handles.Design.RootedHandleDesigner


Inheritance Hierarchy

Inheritance Hierarchy
Inheritance Hierarchy
Eco.Handles.Design.HintHelper


Inheritance Hierarchy

Inheritance Hierarchy
Inheritance Hierarchy
Eco.Handles.Design.IComponentFilter


Inheritance Hierarchy

Inheritance Hierarchy
Inheritance Hierarchy
Eco.Handles.Design.IComponentSetFilter


Inheritance Hierarchy

Inheritance Hierarchy
Inheritance Hierarchy
Eco.Handles.Design.IdeHelper


Inheritance Hierarchy

Inheritance Hierarchy
Inheritance Hierarchy
Eco.Handles.Design.IEcoSpaceDesignerTool
    Eco.Handles.Design.EcoToolButtonBase


Inheritance Hierarchy

Inheritance Hierarchy
Inheritance Hierarchy
Eco.Handles.Design.IFormValidator
    Eco.Handles.Design.TestValidator
    Eco.Handles.Design.WinFormValidator


Inheritance Hierarchy

Inheritance Hierarchy
Inheritance Hierarchy
Eco.Handles.Design.IModelValidateTool


Inheritance Hierarchy

Inheritance Hierarchy
Inheritance Hierarchy
Eco.Handles.Design.CreatorHandler
    Eco.Handles.Design.ListActionCreatorHandler


Inheritance Hierarchy

Inheritance Hierarchy
Inheritance Hierarchy
Eco.Handles.Design.MessageDisplay


Inheritance Hierarchy

Inheritance Hierarchy
Inheritance Hierarchy
Eco.Handles.Design.MessageHelper


Inheritance Hierarchy

Inheritance Hierarchy
Inheritance Hierarchy
Eco.Handles.Design.CreatorInfo
    Eco.Handles.Design.MetaCreator


Inheritance Hierarchy

Inheritance Hierarchy
Inheritance Hierarchy
Eco.Handles.Design.CreatorInfo
    Eco.Handles.Design.MetaCreatorType


Inheritance Hierarchy

Inheritance Hierarchy
Inheritance Hierarchy
Eco.Handles.Design.ModalExpressionEditor
    Eco.Handles.Design.ExpressionEditor
    Eco.Handles.Design.OclEditorWakeup
    Eco.Handles.Design.SecondOclEditorWakeup


Inheritance Hierarchy

Inheritance Hierarchy
Inheritance Hierarchy
Eco.Handles.Design.CreatorNodeDescriptor
    Eco.Handles.Design.ModelElementNodeDescriptor


Inheritance Hierarchy

Inheritance Hierarchy
Inheritance Hierarchy
Eco.Handles.Design.ModelValidationContextNode


Inheritance Hierarchy

Inheritance Hierarchy
Inheritance Hierarchy
Eco.Handles.Design.ValidationIncident
    Eco.Handles.Design.ModelValidationIncident


Inheritance Hierarchy

Inheritance Hierarchy
Inheritance Hierarchy
Eco.Handles.Design.ValidationReport
    Eco.Handles.Design.ModelValidationReport


Inheritance Hierarchy

Inheritance Hierarchy
Inheritance Hierarchy
Eco.Handles.Design.AbstractManipulator
    Eco.Handles.Design.NameManipulator


Inheritance Hierarchy

Inheritance Hierarchy
Inheritance Hierarchy
System.Windows.Forms.Form
    Eco.Handles.Design.NewVersionForm


Inheritance Hierarchy

Inheritance Hierarchy
Inheritance Hierarchy
Eco.Handles.Design.TypeNameSelectorEditor
    Eco.Handles.Design.NonCollectionTypeNameSelectorEditor


Inheritance Hierarchy

Inheritance Hierarchy
Inheritance Hierarchy
Eco.Handles.Design.NotifyingDesigner
    Eco.Handles.Design.EcoActionExtenderDesigner
    Eco.Handles.Design.HandlesDesigner


Inheritance Hierarchy

Inheritance Hierarchy
Inheritance Hierarchy
Eco.Handles.Design.ModalExpressionEditor
    Eco.Handles.Design.OclEditorWakeup


Inheritance Hierarchy

Inheritance Hierarchy
Inheritance Hierarchy
Eco.Handles.Design.ModalExpressionEditor
    Eco.Handles.Design.ExpressionEditor
        Eco.Handles.Design.OclExpressionEditor


Inheritance Hierarchy

Inheritance Hierarchy
Inheritance Hierarchy
Eco.Handles.Design.ModalExpressionEditor
    Eco.Handles.Design.ExpressionEditor
        Eco.Handles.Design.OclPsExpressionEditor


Inheritance Hierarchy

Inheritance Hierarchy
Inheritance Hierarchy
Eco.Handles.Design.NotifyingDesigner
    Eco.Handles.Design.HandlesDesigner
        Eco.Handles.Design.RootedHandleDesigner
            Eco.Handles.Design.AbstractExpressionHandleDesigner
                Eco.Handles.Design.OclPSHandleDesigner


Inheritance Hierarchy

Inheritance Hierarchy
Inheritance Hierarchy
Eco.Handles.Design.OclVariableConverter


Inheritance Hierarchy

Inheritance Hierarchy
Inheritance Hierarchy
System.Windows.Forms.Form
    Eco.Handles.Design.PackageSelectorForm


Inheritance Hierarchy

Inheritance Hierarchy
Inheritance Hierarchy
Eco.Handles.Design.CreatorHandler
    Eco.Handles.Design.PMapperCreatorHandler


Inheritance Hierarchy

Inheritance Hierarchy
Inheritance Hierarchy
Eco.Handles.Design.PropertyDefinition


Inheritance Hierarchy

Inheritance Hierarchy
Inheritance Hierarchy
Eco.Handles.Design.PropertyParams


Inheritance Hierarchy

Inheritance Hierarchy
Inheritance Hierarchy
Eco.Handles.Design.CreatorHandler
    Eco.Handles.Design.ReferenceHandleCreatorHandler


Inheritance Hierarchy

Inheritance Hierarchy
Inheritance Hierarchy
Eco.Handles.Design.RegisterRefreshXml


Inheritance Hierarchy

Inheritance Hierarchy
Inheritance Hierarchy
Eco.Handles.Design.Registration


Inheritance Hierarchy

Inheritance Hierarchy
Inheritance Hierarchy
Eco.Handles.Design.NotifyingDesigner
    Eco.Handles.Design.HandlesDesigner
        Eco.Handles.Design.RootedHandleDesigner
            Eco.Handles.Design.AbstractExpressionHandleDesigner
            Eco.Handles.Design.CurrencyManagerHandleDesigner


Inheritance Hierarchy

Inheritance Hierarchy
Inheritance Hierarchy
Eco.Handles.Design.RootHandleEditor


Inheritance Hierarchy

Inheritance Hierarchy
Inheritance Hierarchy
Eco.Handles.Design.ModalExpressionEditor
    Eco.Handles.Design.SecondOclEditorWakeup


Inheritance Hierarchy

Inheritance Hierarchy
Inheritance Hierarchy
Eco.Handles.Design.IFormValidator
    Eco.Handles.Design.TestValidator


Inheritance Hierarchy

Inheritance Hierarchy
Inheritance Hierarchy
Eco.Handles.Design.TopLocation


Inheritance Hierarchy

Inheritance Hierarchy
Inheritance Hierarchy
Eco.Handles.Design.TypeNameSelectorEditor
    Eco.Handles.Design.AnyTypeNameSelectorEditor
    Eco.Handles.Design.NonCollectionTypeNameSelectorEditor


Inheritance Hierarchy

Inheritance Hierarchy
Inheritance Hierarchy
Eco.Handles.Design.ValidationIncident
    Eco.Handles.Design.FormValidationIncident
    Eco.Handles.Design.ModelValidationIncident


Inheritance Hierarchy

Inheritance Hierarchy
Inheritance Hierarchy
Eco.Handles.Design.ValidationReport
    Eco.Handles.Design.FormValidationReport
    Eco.Handles.Design.ModelValidationReport


Inheritance Hierarchy

Inheritance Hierarchy
Inheritance Hierarchy
Eco.Handles.Design.IFormValidator
    Eco.Handles.Design.WinFormValidator


Inheritance Hierarchy

Inheritance Hierarchy
Inheritance Hierarchy
Eco.ModelValidation.IModelValidator
    Eco.ModelValidation.ModelValidator
    Eco.ModelValidation.OclValidator


Inheritance Hierarchy

Inheritance Hierarchy
Inheritance Hierarchy
Eco.ModelValidation.IModelValidator
    Eco.ModelValidation.ModelValidator


Inheritance Hierarchy

Inheritance Hierarchy
Inheritance Hierarchy
Eco.ModelValidation.IModelValidator
    Eco.ModelValidation.OclValidator


Inheritance Hierarchy

Inheritance Hierarchy
Inheritance Hierarchy
Eco.ModelValidation.ValidationArgs


Inheritance Hierarchy

Inheritance Hierarchy
Inheritance Hierarchy
Eco.ModelValidation.ValidatorPluginsValidator


Inheritance Hierarchy

Inheritance Hierarchy
Inheritance Hierarchy
Eco.Persistence.Design.IMapperVerbConfigurator
    Eco.Persistence.Design.AbstractBdpConfigurator
        Eco.Persistence.Design.EcoBdpConfigurator


Inheritance Hierarchy

Inheritance Hierarchy
Inheritance Hierarchy
Eco.Persistence.Design.IMapperVerbConfigurator
    Eco.Persistence.Design.AbstractDbxConfigurator
        Eco.Persistence.Design.EcoDbxConfigurator


Inheritance Hierarchy

Inheritance Hierarchy
Inheritance Hierarchy
Eco.Persistence.Design.IMapperVerbConfigurator
    Eco.Persistence.Design.AbstractBdpConfigurator
        Eco.Persistence.Design.EcoBdpConfigurator
            Eco.Persistence.Design.AccessConfiguratorBdp


Inheritance Hierarchy

Inheritance Hierarchy
Inheritance Hierarchy
Eco.Persistence.Design.IMapperVerbConfigurator
    Eco.Persistence.Design.AbstractDbxConfigurator
        Eco.Persistence.Design.EcoDbxConfigurator
            Eco.Persistence.Design.AccessConfiguratorDbx


Inheritance Hierarchy

Inheritance Hierarchy
Inheritance Hierarchy
Eco.Persistence.Design.IMapperVerbConfigurator
    Eco.Persistence.Design.AbstractDbxConfigurator
        Eco.Persistence.Design.EcoDbxConfigurator
            Eco.Persistence.Design.AnsiConfigurator


Inheritance Hierarchy

Inheritance Hierarchy
Inheritance Hierarchy
Eco.Persistence.Design.PersistenceHandleDesigner
    Eco.Persistence.Design.BdpPersistenceMapperDesigner


Inheritance Hierarchy

Inheritance Hierarchy
Inheritance Hierarchy
Eco.Persistence.Design.BdpProvider


Inheritance Hierarchy

Inheritance Hierarchy
Inheritance Hierarchy
Eco.Persistence.Design.IMapperVerbConfigurator
    Eco.Persistence.Design.AbstractBdpConfigurator
        Eco.Persistence.Design.EcoBdpConfigurator
            Eco.Persistence.Design.BlackfishConfiguratorBdp


Inheritance Hierarchy

Inheritance Hierarchy
Inheritance Hierarchy
Eco.Persistence.Design.IMapperVerbConfigurator
    Eco.Persistence.Design.AbstractDbxConfigurator
        Eco.Persistence.Design.EcoDbxConfigurator
            Eco.Persistence.Design.BlackfishConfiguratorDbx


Inheritance Hierarchy

Inheritance Hierarchy
Inheritance Hierarchy
Eco.Persistence.Design.PersistenceHandleDesigner
    Eco.Persistence.Design.BlackfishPersistenceMapperDesigner


Inheritance Hierarchy

Inheritance Hierarchy
Inheritance Hierarchy
Eco.Persistence.Design.PersistenceHandleDesigner
    Eco.Persistence.Design.BlackfishRemotePersistenceMapperDesigner


Inheritance Hierarchy

Inheritance Hierarchy
Inheritance Hierarchy
Eco.Persistence.Design.ConnectionsCreatorHandler


Inheritance Hierarchy

Inheritance Hierarchy
Inheritance Hierarchy
Eco.Persistence.Design.IMapperVerbConfigurator
    Eco.Persistence.Design.AbstractDbxConfigurator
        Eco.Persistence.Design.EcoDbxConfigurator
            Eco.Persistence.Design.DB2Configurator


Inheritance Hierarchy

Inheritance Hierarchy
Inheritance Hierarchy
Eco.Persistence.Design.IMapperVerbConfigurator
    Eco.Persistence.Design.AbstractDbxConfigurator
        Eco.Persistence.Design.EcoDbxConfigurator
            Eco.Persistence.Design.DB2MBCSConfigurator


Inheritance Hierarchy

Inheritance Hierarchy
Inheritance Hierarchy
Eco.Persistence.Design.DBToolBase
    Eco.Persistence.Design.EvolveDBTool
    Eco.Persistence.Design.GenerateDBTool
    Eco.Persistence.Design.GenerateDefaultMappingXmlTool
    Eco.Persistence.Design.SaveMappingInfoTool
    Eco.Persistence.Design.ValidateModelTool


Inheritance Hierarchy

Inheritance Hierarchy
Inheritance Hierarchy
Eco.Persistence.Design.PersistenceHandleDesigner
    Eco.Persistence.Design.DbxPersistenceMapperDesigner


Inheritance Hierarchy

Inheritance Hierarchy
Inheritance Hierarchy
Eco.Persistence.Design.DbxProvider


Inheritance Hierarchy

Inheritance Hierarchy
Inheritance Hierarchy
Eco.Persistence.Design.DefaultORMappingBuilderDesigner


Inheritance Hierarchy

Inheritance Hierarchy
Inheritance Hierarchy
Eco.Persistence.Design.DesignUtils


Inheritance Hierarchy

Inheritance Hierarchy
Inheritance Hierarchy
Eco.Persistence.Design.IMapperVerbConfigurator
    Eco.Persistence.Design.AbstractBdpConfigurator
        Eco.Persistence.Design.EcoBdpConfigurator
            Eco.Persistence.Design.AccessConfiguratorBdp
            Eco.Persistence.Design.BlackfishConfiguratorBdp
            Eco.Persistence.Design.MySql4ConfiguratorBdp
            Eco.Persistence.Design.MySql5ConfiguratorBdp
            Eco.Persistence.Design.SQLServer7ConfiguratorBdp
            Eco.Persistence.Design.SQLServer7ConfiguratorBdpMBCS
            Eco.Persistence.Design.SQLServerConfiguratorBdp
            Eco.Persistence.Design.SQLServerConfiguratorBdpMBCS


Inheritance Hierarchy

Inheritance Hierarchy
Inheritance Hierarchy
Eco.Persistence.Design.IMapperVerbConfigurator
    Eco.Persistence.Design.AbstractDbxConfigurator
        Eco.Persistence.Design.EcoDbxConfigurator
            Eco.Persistence.Design.AccessConfiguratorDbx
            Eco.Persistence.Design.AnsiConfigurator
            Eco.Persistence.Design.BlackfishConfiguratorDbx
            Eco.Persistence.Design.DB2Configurator
            Eco.Persistence.Design.DB2MBCSConfigurator
            Eco.Persistence.Design.InformixConfigurator
            Eco.Persistence.Design.Interbase3Configurator
            Eco.Persistence.Design.Interbase3MBCSConfigurator
            Eco.Persistence.Design.MySql4ConfiguratorDbx
            Eco.Persistence.Design.MySql5ConfiguratorDbx
            Eco.Persistence.Design.OracleConfigurator
            Eco.Persistence.Design.OracleMBCSConfigurator
            Eco.Persistence.Design.SQLServer7ConfiguratorDbx
            Eco.Persistence.Design.SQLServer7ConfiguratorDbxMBCS
            Eco.Persistence.Design.SQLServerConfiguratorDbx
            Eco.Persistence.Design.SQLServerConfiguratorDbxMBCS
            Eco.Persistence.Design.SybaseConfigurator


Inheritance Hierarchy

Inheritance Hierarchy
Inheritance Hierarchy
Eco.Persistence.Design.DBToolBase
    Eco.Persistence.Design.EvolveDBTool


Inheritance Hierarchy

Inheritance Hierarchy
Inheritance Hierarchy
Eco.Persistence.Design.IMapperVerbConfigurator
    Eco.Persistence.Design.FirebirdConfiguratorFirebirdClient


Inheritance Hierarchy

Inheritance Hierarchy
Inheritance Hierarchy
Eco.Persistence.Design.PersistenceHandleDesigner
    Eco.Persistence.Design.FirebirdPersistenceMapperDesigner


Inheritance Hierarchy

Inheritance Hierarchy
Inheritance Hierarchy
Eco.Persistence.Design.DBToolBase
    Eco.Persistence.Design.GenerateDBTool


Inheritance Hierarchy

Inheritance Hierarchy
Inheritance Hierarchy
Eco.Persistence.Design.DBToolBase
    Eco.Persistence.Design.GenerateDefaultMappingXmlTool


Inheritance Hierarchy

Inheritance Hierarchy
Inheritance Hierarchy
Eco.Persistence.Design.IMapperVerbConfigurator
    Eco.Persistence.Design.AbstractBdpConfigurator
    Eco.Persistence.Design.AbstractDbxConfigurator
    Eco.Persistence.Design.FirebirdConfiguratorFirebirdClient
    Eco.Persistence.Design.MimerConfiguratorMimerClient
    Eco.Persistence.Design.MySql4Configurator
    Eco.Persistence.Design.MySql5Configurator
    Eco.Persistence.Design.OracleConfiguratorOracleClient
    Eco.Persistence.Design.SQLServer7ConfiguratorSqlClient
    Eco.Persistence.Design.SQLServer7ConfiguratorSqlClientMBCS
    Eco.Persistence.Design.SQLServerConfiguratorSqlClient
    Eco.Persistence.Design.SQLServerConfiguratorSqlClientMBCS


Inheritance Hierarchy

Inheritance Hierarchy
Inheritance Hierarchy
Eco.Persistence.Design.IMapperVerbConfigurator
    Eco.Persistence.Design.AbstractDbxConfigurator
        Eco.Persistence.Design.EcoDbxConfigurator
            Eco.Persistence.Design.InformixConfigurator


Inheritance Hierarchy

Inheritance Hierarchy
Inheritance Hierarchy
Eco.Persistence.Design.Initialize


Inheritance Hierarchy

Inheritance Hierarchy
Inheritance Hierarchy
Eco.Persistence.Design.IMapperVerbConfigurator
    Eco.Persistence.Design.AbstractDbxConfigurator
        Eco.Persistence.Design.EcoDbxConfigurator
            Eco.Persistence.Design.Interbase3Configurator


Inheritance Hierarchy

Inheritance Hierarchy
Inheritance Hierarchy
Eco.Persistence.Design.IMapperVerbConfigurator
    Eco.Persistence.Design.AbstractDbxConfigurator
        Eco.Persistence.Design.EcoDbxConfigurator
            Eco.Persistence.Design.Interbase3MBCSConfigurator


Inheritance Hierarchy

Inheritance Hierarchy
Inheritance Hierarchy
Eco.Persistence.Design.MapperNameConverter
    Eco.Persistence.Design.KeyMapperNameConverter


Inheritance Hierarchy

Inheritance Hierarchy
Inheritance Hierarchy
Eco.Persistence.Design.MapperTypeNameConverter
    Eco.Persistence.Design.KeyMapperTypeNameConverter


Inheritance Hierarchy

Inheritance Hierarchy
Inheritance Hierarchy
Eco.Persistence.Design.ManualEditorManipulator


Inheritance Hierarchy

Inheritance Hierarchy
Inheritance Hierarchy
Eco.Persistence.Design.MapperNameConverter
    Eco.Persistence.Design.KeyMapperNameConverter
    Eco.Persistence.Design.PersistenceMapperNameConverter


Inheritance Hierarchy

Inheritance Hierarchy
Inheritance Hierarchy
Eco.Persistence.Design.MapperTypeEditor


Inheritance Hierarchy

Inheritance Hierarchy
Inheritance Hierarchy
Eco.Persistence.Design.MapperTypeNameConverter
    Eco.Persistence.Design.KeyMapperTypeNameConverter
    Eco.Persistence.Design.PersistenceMapperTypeNameConverter


Inheritance Hierarchy

Inheritance Hierarchy
Inheritance Hierarchy
Eco.Persistence.Design.MapperTypeRegistry


Inheritance Hierarchy

Inheritance Hierarchy
Inheritance Hierarchy
Eco.Persistence.Design.IMapperVerbConfigurator
    Eco.Persistence.Design.MimerConfiguratorMimerClient


Inheritance Hierarchy

Inheritance Hierarchy
Inheritance Hierarchy
Eco.Persistence.Design.PersistenceHandleDesigner
    Eco.Persistence.Design.MimerPersistenceHandleDesigner


Inheritance Hierarchy

Inheritance Hierarchy
Inheritance Hierarchy
Eco.Persistence.Design.IMapperVerbConfigurator
    Eco.Persistence.Design.MySql4Configurator


Inheritance Hierarchy

Inheritance Hierarchy
Inheritance Hierarchy
Eco.Persistence.Design.IMapperVerbConfigurator
    Eco.Persistence.Design.AbstractBdpConfigurator
        Eco.Persistence.Design.EcoBdpConfigurator
            Eco.Persistence.Design.MySql4ConfiguratorBdp


Inheritance Hierarchy

Inheritance Hierarchy
Inheritance Hierarchy
Eco.Persistence.Design.IMapperVerbConfigurator
    Eco.Persistence.Design.AbstractDbxConfigurator
        Eco.Persistence.Design.EcoDbxConfigurator
            Eco.Persistence.Design.MySql4ConfiguratorDbx


Inheritance Hierarchy

Inheritance Hierarchy
Inheritance Hierarchy
Eco.Persistence.Design.IMapperVerbConfigurator
    Eco.Persistence.Design.MySql5Configurator


Inheritance Hierarchy

Inheritance Hierarchy
Inheritance Hierarchy
Eco.Persistence.Design.IMapperVerbConfigurator
    Eco.Persistence.Design.AbstractBdpConfigurator
        Eco.Persistence.Design.EcoBdpConfigurator
            Eco.Persistence.Design.MySql5ConfiguratorBdp


Inheritance Hierarchy

Inheritance Hierarchy
Inheritance Hierarchy
Eco.Persistence.Design.IMapperVerbConfigurator
    Eco.Persistence.Design.AbstractDbxConfigurator
        Eco.Persistence.Design.EcoDbxConfigurator
            Eco.Persistence.Design.MySql5ConfiguratorDbx


Inheritance Hierarchy

Inheritance Hierarchy
Inheritance Hierarchy
Eco.Persistence.Design.PersistenceHandleDesigner
    Eco.Persistence.Design.MySqlPersistenceHandleDesigner


Inheritance Hierarchy

Inheritance Hierarchy
Inheritance Hierarchy
Eco.Persistence.Design.NewXmlMappingFileNameEditor


Inheritance Hierarchy

Inheritance Hierarchy
Inheritance Hierarchy
Eco.Persistence.Design.IMapperVerbConfigurator
    Eco.Persistence.Design.AbstractDbxConfigurator
        Eco.Persistence.Design.EcoDbxConfigurator
            Eco.Persistence.Design.OracleConfigurator


Inheritance Hierarchy

Inheritance Hierarchy
Inheritance Hierarchy
Eco.Persistence.Design.IMapperVerbConfigurator
    Eco.Persistence.Design.OracleConfiguratorOracleClient


Inheritance Hierarchy

Inheritance Hierarchy
Inheritance Hierarchy
Eco.Persistence.Design.IMapperVerbConfigurator
    Eco.Persistence.Design.AbstractDbxConfigurator
        Eco.Persistence.Design.EcoDbxConfigurator
            Eco.Persistence.Design.OracleMBCSConfigurator


Inheritance Hierarchy

Inheritance Hierarchy
Inheritance Hierarchy
Eco.Persistence.Design.PersistenceHandleDesigner
    Eco.Persistence.Design.OraclePersistenceHandleDesigner


Inheritance Hierarchy

Inheritance Hierarchy
Inheritance Hierarchy
Eco.Persistence.Design.PersistenceHandleDesigner
    Eco.Persistence.Design.BdpPersistenceMapperDesigner
    Eco.Persistence.Design.BlackfishPersistenceMapperDesigner
    Eco.Persistence.Design.BlackfishRemotePersistenceMapperDesigner
    Eco.Persistence.Design.DbxPersistenceMapperDesigner
    Eco.Persistence.Design.FirebirdPersistenceMapperDesigner
    Eco.Persistence.Design.MimerPersistenceHandleDesigner
    Eco.Persistence.Design.MySqlPersistenceHandleDesigner
    Eco.Persistence.Design.OraclePersistenceHandleDesigner
    Eco.Persistence.Design.SqlServerPersistenceHandleDesigner


Inheritance Hierarchy

Inheritance Hierarchy
Inheritance Hierarchy
Eco.Persistence.Design.PersistenceMapperDesignerXml


Inheritance Hierarchy

Inheritance Hierarchy
Inheritance Hierarchy
Eco.Persistence.Design.PersistenceMapperInspector


Inheritance Hierarchy

Inheritance Hierarchy
Inheritance Hierarchy
Eco.Persistence.Design.MapperNameConverter
    Eco.Persistence.Design.PersistenceMapperNameConverter


Inheritance Hierarchy

Inheritance Hierarchy
Inheritance Hierarchy
Eco.Persistence.Design.PersistenceMapperProviderDesigner


Inheritance Hierarchy

Inheritance Hierarchy
Inheritance Hierarchy
Eco.Persistence.Design.PersistenceMapperProviderInspector


Inheritance Hierarchy

Inheritance Hierarchy
Inheritance Hierarchy
Eco.Persistence.Design.PersistenceMapperProviderTypeNameTypeConverter


Inheritance Hierarchy

Inheritance Hierarchy
Inheritance Hierarchy
Eco.Persistence.Design.MapperTypeNameConverter
    Eco.Persistence.Design.PersistenceMapperTypeNameConverter


Inheritance Hierarchy

Inheritance Hierarchy
Inheritance Hierarchy
Eco.Persistence.Design.PMapperBdpValidator


Inheritance Hierarchy

Inheritance Hierarchy
Inheritance Hierarchy
Eco.Persistence.Design.PMapperBlackfishValidator


Inheritance Hierarchy

Inheritance Hierarchy
Inheritance Hierarchy
Eco.Persistence.Design.PMapperCreatorHandlerPMP


Inheritance Hierarchy

Inheritance Hierarchy
Inheritance Hierarchy
Eco.Persistence.Design.PMapperDbxValidator


Inheritance Hierarchy

Inheritance Hierarchy
Inheritance Hierarchy
Eco.Persistence.Design.PMapperFirebirdValidator


Inheritance Hierarchy

Inheritance Hierarchy
Inheritance Hierarchy
Eco.Persistence.Design.PMapperMimerValidator


Inheritance Hierarchy

Inheritance Hierarchy
Inheritance Hierarchy
Eco.Persistence.Design.PMapperOracleValidator


Inheritance Hierarchy

Inheritance Hierarchy
Inheritance Hierarchy
Eco.Persistence.Design.PMapperSqlServerValidator


Inheritance Hierarchy

Inheritance Hierarchy
Inheritance Hierarchy
Eco.Persistence.Design.PMapperValidator


Inheritance Hierarchy

Inheritance Hierarchy
Inheritance Hierarchy
Eco.Persistence.Design.PMapperXmlValidator


Inheritance Hierarchy

Inheritance Hierarchy
Inheritance Hierarchy
Eco.Persistence.Design.Registration


Inheritance Hierarchy

Inheritance Hierarchy
Inheritance Hierarchy
Eco.Persistence.Design.DBToolBase
    Eco.Persistence.Design.SaveMappingInfoTool


Inheritance Hierarchy

Inheritance Hierarchy
Inheritance Hierarchy
Eco.Persistence.Design.IMapperVerbConfigurator
    Eco.Persistence.Design.AbstractBdpConfigurator
        Eco.Persistence.Design.EcoBdpConfigurator
            Eco.Persistence.Design.SQLServer7ConfiguratorBdp


Inheritance Hierarchy

Inheritance Hierarchy
Inheritance Hierarchy
Eco.Persistence.Design.IMapperVerbConfigurator
    Eco.Persistence.Design.AbstractBdpConfigurator
        Eco.Persistence.Design.EcoBdpConfigurator
            Eco.Persistence.Design.SQLServer7ConfiguratorBdpMBCS


Inheritance Hierarchy

Inheritance Hierarchy
Inheritance Hierarchy
Eco.Persistence.Design.IMapperVerbConfigurator
    Eco.Persistence.Design.AbstractDbxConfigurator
        Eco.Persistence.Design.EcoDbxConfigurator
            Eco.Persistence.Design.SQLServer7ConfiguratorDbx


Inheritance Hierarchy

Inheritance Hierarchy
Inheritance Hierarchy
Eco.Persistence.Design.IMapperVerbConfigurator
    Eco.Persistence.Design.AbstractDbxConfigurator
        Eco.Persistence.Design.EcoDbxConfigurator
            Eco.Persistence.Design.SQLServer7ConfiguratorDbxMBCS


Inheritance Hierarchy

Inheritance Hierarchy
Inheritance Hierarchy
Eco.Persistence.Design.IMapperVerbConfigurator
    Eco.Persistence.Design.SQLServer7ConfiguratorSqlClient


Inheritance Hierarchy

Inheritance Hierarchy
Inheritance Hierarchy
Eco.Persistence.Design.IMapperVerbConfigurator
    Eco.Persistence.Design.SQLServer7ConfiguratorSqlClientMBCS


Inheritance Hierarchy

Inheritance Hierarchy
Inheritance Hierarchy
Eco.Persistence.Design.IMapperVerbConfigurator
    Eco.Persistence.Design.AbstractBdpConfigurator
        Eco.Persistence.Design.EcoBdpConfigurator
            Eco.Persistence.Design.SQLServerConfiguratorBdp


Inheritance Hierarchy

Inheritance Hierarchy
Inheritance Hierarchy
Eco.Persistence.Design.IMapperVerbConfigurator
    Eco.Persistence.Design.AbstractBdpConfigurator
        Eco.Persistence.Design.EcoBdpConfigurator
            Eco.Persistence.Design.SQLServerConfiguratorBdpMBCS


Inheritance Hierarchy

Inheritance Hierarchy
Inheritance Hierarchy
Eco.Persistence.Design.IMapperVerbConfigurator
    Eco.Persistence.Design.AbstractDbxConfigurator
        Eco.Persistence.Design.EcoDbxConfigurator
            Eco.Persistence.Design.SQLServerConfiguratorDbx


Inheritance Hierarchy

Inheritance Hierarchy
Inheritance Hierarchy
Eco.Persistence.Design.IMapperVerbConfigurator
    Eco.Persistence.Design.AbstractDbxConfigurator
        Eco.Persistence.Design.EcoDbxConfigurator
            Eco.Persistence.Design.SQLServerConfiguratorDbxMBCS


Inheritance Hierarchy

Inheritance Hierarchy
Inheritance Hierarchy
Eco.Persistence.Design.IMapperVerbConfigurator
    Eco.Persistence.Design.SQLServerConfiguratorSqlClient


Inheritance Hierarchy

Inheritance Hierarchy
Inheritance Hierarchy
Eco.Persistence.Design.IMapperVerbConfigurator
    Eco.Persistence.Design.SQLServerConfiguratorSqlClientMBCS


Inheritance Hierarchy

Inheritance Hierarchy
Inheritance Hierarchy
Eco.Persistence.Design.PersistenceHandleDesigner
    Eco.Persistence.Design.SqlServerPersistenceHandleDesigner


Inheritance Hierarchy

Inheritance Hierarchy
Inheritance Hierarchy
Eco.Persistence.Design.IMapperVerbConfigurator
    Eco.Persistence.Design.AbstractDbxConfigurator
        Eco.Persistence.Design.EcoDbxConfigurator
            Eco.Persistence.Design.SybaseConfigurator


Inheritance Hierarchy

Inheritance Hierarchy
Inheritance Hierarchy
Eco.Persistence.Design.DBToolBase
    Eco.Persistence.Design.ValidateModelTool


Inheritance Hierarchy

Inheritance Hierarchy
Inheritance Hierarchy
Eco.Persistence.Oracle.Design.Registration


Inheritance Hierarchy

Inheritance Hierarchy
Inheritance Hierarchy
Eco.Persistence.PMapperDefConverter


Inheritance Hierarchy

Inheritance Hierarchy
Inheritance Hierarchy
Eco.Persistence.SyncHandlerConverter


Inheritance Hierarchy

Inheritance Hierarchy
Inheritance Hierarchy
Eco.Persistence.Xml.Design.NewXmlFileNameEditor


Inheritance Hierarchy

Inheritance Hierarchy
Inheritance Hierarchy
Eco.Persistence.Xml.Design.PersistenceMapperXmlInspector


Inheritance Hierarchy

Inheritance Hierarchy
Inheritance Hierarchy
Eco.Tree.EcoTreeEditorWakeup


Inheritance Hierarchy

Inheritance Hierarchy
Inheritance Hierarchy
Eco.Web.Design.AllInstancesWebWidgetsCreatorHandler


Inheritance Hierarchy

Inheritance Hierarchy
Inheritance Hierarchy
Eco.Web.Design.AspValidator


Inheritance Hierarchy

Inheritance Hierarchy
Inheritance Hierarchy
Eco.Web.Design.EcoDataSourceColumnCollectionEditor


Inheritance Hierarchy

Inheritance Hierarchy
Inheritance Hierarchy
Eco.Web.Design.EcoDataSourceDesigner


Inheritance Hierarchy

Inheritance Hierarchy
Inheritance Hierarchy
Eco.Web.Design.EcoDataSourceDesignerSchema


Inheritance Hierarchy

Inheritance Hierarchy
Inheritance Hierarchy
Eco.Web.Design.EcoDataSourceFieldSchema


Inheritance Hierarchy

Inheritance Hierarchy
Inheritance Hierarchy
Eco.Web.Design.EcoDesignerDataSourceView


Inheritance Hierarchy

Inheritance Hierarchy
Inheritance Hierarchy
Eco.Web.Design.EcoSpaceManagerDesigner


Inheritance Hierarchy

Inheritance Hierarchy
Inheritance Hierarchy
Eco.Web.Design.Registration


Inheritance Hierarchy

Inheritance Hierarchy
Inheritance Hierarchy
Eco.Web.Design.WebControlNameManipulator