DroopyEyes.EcoExtensions.AutoContainers Namespace

EcoExtensions
DroopyEyes.EcoExtensions.AutoContainers Namespace
Classes
Collapse All

This is namespace DroopyEyes.EcoExtensions.AutoContainers.

Classes
Name | Description
AutoContainerAttribute | This is the attribute used to identify classes which implement the IAutoContainer interface, and should be used by the DroopyEyes.EcoExtensions.AutoContainers.AutoFormFactory
AutoContainerFactoryAttribute | This is the attribute used to identify classes which implement the IAutoContainerFactory interface
AutoFormFactory | This class registers itself as an AutoContainerFactory. Once created it will scan the current app for [AutoContainerFactor] attributes and register the form they are tagged too against the specified ElementName (class model name)
AutoFormFactoryException | Thrown by AutoFormFactory.
Top
What do you think about this topic? Send feedback!
Copyright (c) 2007-2009. All rights reserved.


AutoContainerAttribute Class

AutoContainerAttribute Class
AutoContainerAttribute Members Inheritance Hierarchy See Also
Collapse All

This is the attribute used to identify classes which implement the IAutoContainer interface, and should be used by the DroopyEyes.EcoExtensions.AutoContainers.AutoFormFactory

C#
public class AutoContainerAttribute : System.Attribute;
Inheritance Hierarchy
DroopyEyes.EcoExtensions.AutoContainers.AutoContainerAttribute
File

AutoContainerAttribute.cs

See Also
AutoContainerAttribute Members
Inheritance Hierarchy


AutoContainerAttribute Members

AutoContainerAttribute Members
Public Methods Public Fields Public Properties
Collapse All

The following tables list the members exposed by AutoContainerAttribute.

Public Methods
Name | Description
AutoContainerAttribute | Creates an instance of the class/
Top
Public Fields
Name | Description
IsCollection | Identifies whether or not a Collection(element) is expected
Top
Public Properties
Name | Description
ElementName | Contains the model name of the class for which the autocontainer provides a GUI


AutoContainerAttribute.AutoContainerAttribute Constructor

AutoContainerAttribute.AutoContainerAttribute Constructor
AutoContainerAttribute Class AutoContainerAttribute Members DroopyEyes.EcoExtensions.AutoContainers Namespace See Also
Collapse All

Creates an instance of the class/

C#
public AutoContainerAttribute(
    Type elementType
);
Parameters
Parameters | Description
elementType | Identifies the type of element this container supports
See Also
AutoContainerAttribute Class
AutoContainerAttribute Members
DroopyEyes.EcoExtensions.AutoContainers Namespace


AutoContainerAttribute Fields

AutoContainerAttribute Fields
Public Fields
Collapse All

The fields of the AutoContainerAttribute class are listed here.

Public Fields
Name | Description
IsCollection | Identifies whether or not a Collection(element) is expected


AutoContainerAttribute.IsCollection Field

AutoContainerAttribute.IsCollection Field
AutoContainerAttribute Class AutoContainerAttribute Members DroopyEyes.EcoExtensions.AutoContainers Namespace See Also
Collapse All

Identifies whether or not a Collection(element) is expected

C#
public bool IsCollection;
See Also
AutoContainerAttribute Class
AutoContainerAttribute Members
DroopyEyes.EcoExtensions.AutoContainers Namespace


AutoContainerAttribute Properties

AutoContainerAttribute Properties
Public Properties
Collapse All

The properties of the AutoContainerAttribute class are listed here.

Public Properties
Name | Description
ElementName | Contains the model name of the class for which the autocontainer provides a GUI


AutoContainerAttribute.ElementName Property

AutoContainerAttribute.ElementName Property
AutoContainerAttribute Class AutoContainerAttribute Members DroopyEyes.EcoExtensions.AutoContainers Namespace See Also
Collapse All

Contains the model name of the class for which the autocontainer provides a GUI

C#
public string ElementName;
See Also
AutoContainerAttribute Class
AutoContainerAttribute Members
DroopyEyes.EcoExtensions.AutoContainers Namespace


AutoContainerFactoryAttribute Class

AutoContainerFactoryAttribute Class
AutoContainerFactoryAttribute Members Inheritance Hierarchy See Also
Collapse All

This is the attribute used to identify classes which implement the IAutoContainerFactory interface

C#
public class AutoContainerFactoryAttribute : Attribute;
Inheritance Hierarchy
DroopyEyes.EcoExtensions.AutoContainers.AutoContainerFactoryAttribute
File

AutoContainerFactoryAttribute.cs

See Also
AutoContainerFactoryAttribute Members
Inheritance Hierarchy


AutoContainerFactoryAttribute Members

AutoContainerFactoryAttribute Members
Public Methods
Collapse All

The following tables list the members exposed by AutoContainerFactoryAttribute.

Public Methods
Name | Description
AutoContainerFactoryAttribute | Creates an instance of the class.


AutoContainerFactoryAttribute.AutoContainerFactoryAttribute Constructor

AutoContainerFactoryAttribute.AutoContainerFactoryAttribute Constructor
AutoContainerFactoryAttribute Class AutoContainerFactoryAttribute Members DroopyEyes.EcoExtensions.AutoContainers Namespace See Also
Collapse All

Creates an instance of the class.

C#
public AutoContainerFactoryAttribute();
See Also
AutoContainerFactoryAttribute Class
AutoContainerFactoryAttribute Members
DroopyEyes.EcoExtensions.AutoContainers Namespace


AutoFormFactory Class

AutoFormFactory Class
AutoFormFactory Members Inheritance Hierarchy See Also
Collapse All

This class registers itself as an AutoContainerFactory. Once created it will scan the current app for [AutoContainerFactor] attributes and register the form they are tagged too against the specified ElementName (class model name)

C#
public sealed class AutoFormFactory : IAutoContainerFactory;
Inheritance Hierarchy
DroopyEyes.EcoExtensions.AutoContainers.AutoFormFactory
File

AutoFormFactory.cs

See Also
AutoFormFactory Members
Inheritance Hierarchy


AutoFormFactory Members

AutoFormFactory Members
Public Methods Public Properties
Collapse All

The following tables list the members exposed by AutoFormFactory.

Public Methods
Name | Description
GetContainerForClassifierName | Returns an autocontainer for a given classifier name
Register | Call this method to register the AutoFormFactory
Top
Public Properties
Name | Description
Instance | Returns the singleton instance of the AutoFormFactory


AutoFormFactory Methods

AutoFormFactory Methods
Public Methods
Collapse All

The methods of the AutoFormFactory class are listed here.

Public Methods
Name | Description
GetContainerForClassifierName | Returns an autocontainer for a given classifier name
Register | Call this method to register the AutoFormFactory


AutoFormFactory.GetContainerForClassifierName Method

AutoFormFactory.GetContainerForClassifierName Method
AutoFormFactory Class AutoFormFactory Members DroopyEyes.EcoExtensions.AutoContainers Namespace See Also
Collapse All

Returns an autocontainer for a given classifier name

C#
public IAutoContainer GetContainerForClassifierName(
    string classifierName
);
See Also
AutoFormFactory Class
AutoFormFactory Members
DroopyEyes.EcoExtensions.AutoContainers Namespace


AutoFormFactory.Register Method

AutoFormFactory.Register Method
AutoFormFactory Class AutoFormFactory Members DroopyEyes.EcoExtensions.AutoContainers Namespace See Also
Collapse All

Call this method to register the AutoFormFactory

C#
public void Register();
See Also
AutoFormFactory Class
AutoFormFactory Members
DroopyEyes.EcoExtensions.AutoContainers Namespace


AutoFormFactory Properties

AutoFormFactory Properties
Public Properties
Collapse All

The properties of the AutoFormFactory class are listed here.

Public Properties
Name | Description
Instance | Returns the singleton instance of the AutoFormFactory


AutoFormFactory.Instance Property

AutoFormFactory.Instance Property
AutoFormFactory Class AutoFormFactory Members DroopyEyes.EcoExtensions.AutoContainers Namespace See Also
Collapse All

Returns the singleton instance of the AutoFormFactory

C#
public static AutoFormFactory Instance;
See Also
AutoFormFactory Class
AutoFormFactory Members
DroopyEyes.EcoExtensions.AutoContainers Namespace


AutoFormFactoryException Class

AutoFormFactoryException Class
AutoFormFactoryException Members Inheritance Hierarchy See Also
Collapse All

Thrown by AutoFormFactory.

C#
public class AutoFormFactoryException : Exception;
Inheritance Hierarchy
DroopyEyes.EcoExtensions.AutoContainers.AutoFormFactoryException
File

AutoFormFactoryException.cs

See Also
AutoFormFactoryException Members
Inheritance Hierarchy


AutoFormFactoryException Members

AutoFormFactoryException Members
Public Methods
Collapse All

The following tables list the members exposed by AutoFormFactoryException.

Public Methods
Name | Description
AutoFormFactoryException | Creates an instance of the exception.


AutoFormFactoryException.AutoFormFactoryException Constructor

AutoFormFactoryException.AutoFormFactoryException Constructor
AutoFormFactoryException Class AutoFormFactoryException Members DroopyEyes.EcoExtensions.AutoContainers Namespace See Also
Collapse All

Creates an instance of the exception.

C#
public AutoFormFactoryException(
    string message
);
See Also
AutoFormFactoryException Class
AutoFormFactoryException Members
DroopyEyes.EcoExtensions.AutoContainers Namespace


DroopyEyes.EcoExtensions.CacheFiltering Namespace

DroopyEyes.EcoExtensions.CacheFiltering Namespace
Classes Interfaces
Collapse All

This is namespace DroopyEyes.EcoExtensions.CacheFiltering.

Classes
Name | Description
EcoCacheFilterCollection | This class is a strongly typed list of EcoCacheFilterListItem
EcoCacheFilterCollectionItem | This class holds the order of an IEcoCacheFilter in the FilterPlugins list of an EcoCacheFilterPlugin
EcoCacheFilterPlugin | This component plugs into an EcoSpace's Cache chain, allowing the developer to plug in filters which intercept requests for operations such as creating new objects, deleting objects, and reading / changing attributes.
EcoCacheTraceFilter | An example of an EcoCacheFilter which intercepts EcoCache execution and outputs the actions using Trace.WriteLine
TraceFlags | A set of flags which determine which Eco cache methods should output a trace message
Top
Interfaces
Name | Description
ICacheFilter | This interface should be supported by all components which have been designed to be inserted into the CacheFilters property of the EcoCacheFilterPlugin component.


EcoCacheFilterCollection Class

EcoCacheFilterCollection Class
EcoCacheFilterCollection Members Inheritance Hierarchy See Also
Collapse All

This class is a strongly typed list of EcoCacheFilterListItem

C#
public class EcoCacheFilterCollection : CollectionBase;
Inheritance Hierarchy
DroopyEyes.EcoExtensions.CacheFiltering.EcoCacheFilterCollection
File

EcoCacheFilterCollection.cs

See Also
EcoCacheFilterCollection Members
Inheritance Hierarchy


EcoCacheFilterCollection Members

EcoCacheFilterCollection Members
Public Methods
Collapse All

The following tables list the members exposed by EcoCacheFilterCollection.

Public Methods
Name | Description
Add | Adds an item to the list
Contains | Checks if an item is contained within the list
CopyTo | Copies the list to an array of EcoCachePluginListItem
EcoCacheFilterCollection | This is EcoCacheFilterCollection, a member of class EcoCacheFilterCollection.
IndexOf | Returns the index of an item in the list, if the item is not present -1 is returned
Insert | Inserts an item at the given index
Remove | Removes the specified item from the list
this | Default property of the list


EcoCacheFilterCollection.EcoCacheFilterCollection Constructor

EcoCacheFilterCollection.EcoCacheFilterCollection Constructor
EcoCacheFilterCollection Class EcoCacheFilterCollection Members DroopyEyes.EcoExtensions.CacheFiltering Namespace See Also
Collapse All
C#
public EcoCacheFilterCollection();
Remarks

This is EcoCacheFilterCollection, a member of class EcoCacheFilterCollection.

See Also
EcoCacheFilterCollection Class
EcoCacheFilterCollection Members
DroopyEyes.EcoExtensions.CacheFiltering Namespace


EcoCacheFilterCollection Methods

EcoCacheFilterCollection Methods
Public Methods
Collapse All

The methods of the EcoCacheFilterCollection class are listed here.

Public Methods
Name | Description
Add | Adds an item to the list
Contains | Checks if an item is contained within the list
CopyTo | Copies the list to an array of EcoCachePluginListItem
IndexOf | Returns the index of an item in the list, if the item is not present -1 is returned
Insert | Inserts an item at the given index
Remove | Removes the specified item from the list
this | Default property of the list


EcoCacheFilterCollection.Add Method

EcoCacheFilterCollection.Add Method
EcoCacheFilterCollection Class EcoCacheFilterCollection Members DroopyEyes.EcoExtensions.CacheFiltering Namespace See Also
Collapse All

Adds an item to the list

C#
public Int32 Add(
    EcoCacheFilterCollectionItem item
);
Parameters
Parameters | Description
item | The item to add to the list
See Also
EcoCacheFilterCollection Class
EcoCacheFilterCollection Members
DroopyEyes.EcoExtensions.CacheFiltering Namespace


EcoCacheFilterCollection.Contains Method

EcoCacheFilterCollection.Contains Method
EcoCacheFilterCollection Class EcoCacheFilterCollection Members DroopyEyes.EcoExtensions.CacheFiltering Namespace See Also
Collapse All

Checks if an item is contained within the list

C#
public Boolean Contains(
    EcoCacheFilterCollectionItem item
);
Parameters
Parameters | Description
item | The item to check for in the list
See Also
EcoCacheFilterCollection Class
EcoCacheFilterCollection Members
DroopyEyes.EcoExtensions.CacheFiltering Namespace


EcoCacheFilterCollection.CopyTo Method

EcoCacheFilterCollection.CopyTo Method
EcoCacheFilterCollection Class EcoCacheFilterCollection Members DroopyEyes.EcoExtensions.CacheFiltering Namespace See Also
Collapse All

Copies the list to an array of EcoCachePluginListItem

C#
public void CopyTo(
    EcoCacheFilterCollectionItem[] array,
    Int32 index
);
Parameters
Parameters | Description
array | The array to copy the items to
index | The index in the array to start adding to
See Also
EcoCacheFilterCollection Class
EcoCacheFilterCollection Members
DroopyEyes.EcoExtensions.CacheFiltering Namespace


EcoCacheFilterCollection.IndexOf Method

EcoCacheFilterCollection.IndexOf Method
EcoCacheFilterCollection Class EcoCacheFilterCollection Members DroopyEyes.EcoExtensions.CacheFiltering Namespace See Also
Collapse All

Returns the index of an item in the list, if the item is not present -1 is returned

C#
public Int32 IndexOf(
    EcoCacheFilterCollectionItem item
);
Parameters
Parameters | Description
item | The item to check for in the list
See Also
EcoCacheFilterCollection Class
EcoCacheFilterCollection Members
DroopyEyes.EcoExtensions.CacheFiltering Namespace


EcoCacheFilterCollection.Insert Method

EcoCacheFilterCollection.Insert Method
EcoCacheFilterCollection Class EcoCacheFilterCollection Members DroopyEyes.EcoExtensions.CacheFiltering Namespace See Also
Collapse All

Inserts an item at the given index

C#
public void Insert(
    Int32 index,
    EcoCacheFilterCollectionItem item
);
Parameters
Parameters | Description
index | The position at which to insert
item | The item to add to the list
See Also
EcoCacheFilterCollection Class
EcoCacheFilterCollection Members
DroopyEyes.EcoExtensions.CacheFiltering Namespace


EcoCacheFilterCollection.Remove Method

EcoCacheFilterCollection.Remove Method
EcoCacheFilterCollection Class EcoCacheFilterCollection Members DroopyEyes.EcoExtensions.CacheFiltering Namespace See Also
Collapse All

Removes the specified item from the list

C#
public void Remove(
    EcoCacheFilterCollectionItem item
);
Parameters
Parameters | Description
item | The item to remove from the list
See Also
EcoCacheFilterCollection Class
EcoCacheFilterCollection Members
DroopyEyes.EcoExtensions.CacheFiltering Namespace


EcoCacheFilterCollection.this Indexer

EcoCacheFilterCollection.this Indexer
EcoCacheFilterCollection Class EcoCacheFilterCollection Members DroopyEyes.EcoExtensions.CacheFiltering Namespace See Also
Collapse All

Default property of the list

C#
public EcoCacheFilterCollectionItem this[
    Int32 index
];
Parameters
Parameters | Description
index | The index of the item to retrieve
See Also
EcoCacheFilterCollection Class
EcoCacheFilterCollection Members
DroopyEyes.EcoExtensions.CacheFiltering Namespace


EcoCacheFilterCollectionItem Class

EcoCacheFilterCollectionItem Class
EcoCacheFilterCollectionItem Members Inheritance Hierarchy See Also
Collapse All

This class holds the order of an IEcoCacheFilter in the FilterPlugins list of an EcoCacheFilterPlugin

C#
public class EcoCacheFilterCollectionItem;
Inheritance Hierarchy
DroopyEyes.EcoExtensions.CacheFiltering.EcoCacheFilterCollectionItem
File

EcoCacheFilterCollectionItem.cs

See Also
EcoCacheFilterCollectionItem Members
Inheritance Hierarchy


EcoCacheFilterCollectionItem Members

EcoCacheFilterCollectionItem Members
Public Methods Public Properties
Collapse All

The following tables list the members exposed by EcoCacheFilterCollectionItem.

Public Methods
Name | Description
EcoCacheFilterCollectionItem | This is EcoCacheFilterCollectionItem, a member of class EcoCacheFilterCollectionItem.
Top
Public Properties
Name | Description
CacheFilter | Holds a reference to a component which implements the ICacheFilter interface.


EcoCacheFilterCollectionItem.EcoCacheFilterCollectionItem Constructor

EcoCacheFilterCollectionItem.EcoCacheFilterCollectionItem Constructor
EcoCacheFilterCollectionItem Class EcoCacheFilterCollectionItem Members DroopyEyes.EcoExtensions.CacheFiltering Namespace See Also
Collapse All
C#
public EcoCacheFilterCollectionItem();
Remarks

This is EcoCacheFilterCollectionItem, a member of class EcoCacheFilterCollectionItem.

See Also
EcoCacheFilterCollectionItem Class
EcoCacheFilterCollectionItem Members
DroopyEyes.EcoExtensions.CacheFiltering Namespace


EcoCacheFilterCollectionItem Properties

EcoCacheFilterCollectionItem Properties
Public Properties
Collapse All

The properties of the EcoCacheFilterCollectionItem class are listed here.

Public Properties
Name | Description
CacheFilter | Holds a reference to a component which implements the ICacheFilter interface.


EcoCacheFilterCollectionItem.CacheFilter Property

EcoCacheFilterCollectionItem.CacheFilter Property
EcoCacheFilterCollectionItem Class EcoCacheFilterCollectionItem Members DroopyEyes.EcoExtensions.CacheFiltering Namespace See Also
Collapse All

Holds a reference to a component which implements the ICacheFilter interface.

C#
public ICacheFilter CacheFilter;
See Also
EcoCacheFilterCollectionItem Class
EcoCacheFilterCollectionItem Members
DroopyEyes.EcoExtensions.CacheFiltering Namespace


EcoCacheFilterPlugin Class

EcoCacheFilterPlugin Class
EcoCacheFilterPlugin Members Inheritance Hierarchy See Also
Collapse All

This component plugs into an EcoSpace's Cache chain, allowing the developer to plug in filters which intercept requests for operations such as creating new objects, deleting objects, and reading / changing attributes.

C#
public sealed class EcoCacheFilterPlugin : Component, ICache;
Inheritance Hierarchy
DroopyEyes.EcoExtensions.CacheFiltering.EcoCacheFilterPlugin
File

EcoCacheFilterPlugin.cs

See Also
EcoCacheFilterPlugin Members
Inheritance Hierarchy


EcoCacheFilterPlugin Members

EcoCacheFilterPlugin Members
Public Methods Public Properties Public Events
Collapse All

The following tables list the members exposed by EcoCacheFilterPlugin.

Public Methods
Name | Description
ApplyTranslationList | This is ApplyTranslationList, a member of class EcoCacheFilterPlugin.
Contains | This is Contains, a member of class EcoCacheFilterPlugin.
CreateNewObject | This is the overview for the CreateNewObject method overload.
DestroyObject | This is DestroyObject, a member of class EcoCacheFilterPlugin.
EcoCacheFilterPlugin | Create this object within your EcoSpace, then in the contructor of your EcoSpace add the following lines of code
GetAllLocators | This is GetAllLocators, a member of class EcoCacheFilterPlugin.
GetCurrentOrderNo | This is GetCurrentOrderNo, a member of class EcoCacheFilterPlugin.
GetCurrentValue | This is GetCurrentValue, a member of class EcoCacheFilterPlugin.
GetEnsuredLocatorById | This is GetEnsuredLocatorById, a member of class EcoCacheFilterPlugin.
GetExistenceState | This is GetExistenceState, a member of class EcoCacheFilterPlugin.
GetExtentIsCurrent | This is GetExtentIsCurrent, a member of class EcoCacheFilterPlugin.
GetFetchedOrderNo | This is GetFetchedOrderNo, a member of class EcoCacheFilterPlugin.
GetFetchedValue | This is GetFetchedValue, a member of class EcoCacheFilterPlugin.
GetIdByLocator | This is GetIdByLocator, a member of class EcoCacheFilterPlugin.
GetLocatorById | This is GetLocatorById, a member of class EcoCacheFilterPlugin.
GetMemberHasFetchedValue | This is GetMemberHasFetchedValue, a member of class EcoCacheFilterPlugin.
GetMemberPersistenceState | This is GetMemberPersistenceState, a member of class EcoCacheFilterPlugin.
GetPersistenceState | This is GetPersistenceState, a member of class EcoCacheFilterPlugin.
GetTimestamp | This is GetTimestamp, a member of class EcoCacheFilterPlugin.
GetUmlClass | This is GetUmlClass, a member of class EcoCacheFilterPlugin.
InvalidateExtent | This is InvalidateExtent, a member of class EcoCacheFilterPlugin.
IsDefaultFetched | This is IsDefaultFetched, a member of class EcoCacheFilterPlugin.
IsDirty | This is IsDirty, a member of class EcoCacheFilterPlugin.
IsPersistent | This is IsPersistent, a member of class EcoCacheFilterPlugin.
SetCurrentAndFetchedOrderNo | This is SetCurrentAndFetchedOrderNo, a member of class EcoCacheFilterPlugin.
SetCurrentAndFetchedValue | This is SetCurrentAndFetchedValue, a member of class EcoCacheFilterPlugin.
SetCurrentOrderNo | This is SetCurrentOrderNo, a member of class EcoCacheFilterPlugin.
SetCurrentValue | This is SetCurrentValue, a member of class EcoCacheFilterPlugin.
SetExistenceState | This is SetExistenceState, a member of class EcoCacheFilterPlugin.
SetExtentCurrent | This is SetExtentCurrent, a member of class EcoCacheFilterPlugin.
SetFetchedValue | This is SetFetchedValue, a member of class EcoCacheFilterPlugin.
SetMemberPersistenceState | This is SetMemberPersistenceState, a member of class EcoCacheFilterPlugin.
SetObjectId | This is SetObjectId, a member of class EcoCacheFilterPlugin.
SetPersistenceState | This is SetPersistenceState, a member of class EcoCacheFilterPlugin.
SetTimestamp | This is SetTimestamp, a member of class EcoCacheFilterPlugin.
Top
Public Properties
Name | Description
CacheFilters | This property holds a list of EcoCacheFilters, which are executed in turn in order to modify the standard operations of the EcoSpace.
DeleteStack | This is DeleteStack, a member of class EcoCacheFilterPlugin.
EcoCache | This property should only bet set once in the constructor of your EcoSpace.
Enabled | This property must be set to True at runtime to plug in the cache filters.
IsActive | This is IsActive, a member of class EcoCacheFilterPlugin.
Top
Public Events
Name | Description
CanRelease | This is CanRelease, a member of class EcoCacheFilterPlugin.
DirtyChanged | This is DirtyChanged, a member of class EcoCacheFilterPlugin.
ExistenceChanged | This is ExistenceChanged, a member of class EcoCacheFilterPlugin.
ExtentInvalidated | This is ExtentInvalidated, a member of class EcoCacheFilterPlugin.
LocatorAdded | This is LocatorAdded, a member of class EcoCacheFilterPlugin.
ValueChanged | This is ValueChanged, a member of class EcoCacheFilterPlugin.


EcoCacheFilterPlugin.EcoCacheFilterPlugin Constructor

EcoCacheFilterPlugin.EcoCacheFilterPlugin Constructor
EcoCacheFilterPlugin Class EcoCacheFilterPlugin Members DroopyEyes.EcoExtensions.CacheFiltering Namespace See Also
Collapse All

Create this object within your EcoSpace, then in the contructor of your EcoSpace add the following lines of code

Copy Code
    EcoCacheFilterPlugin.EcoCache = FrontSidePolicy.Cache;
    FrontSidePolicy.Cache = EcoCacheFilterPlugin;
C#
public EcoCacheFilterPlugin();
See Also
EcoCacheFilterPlugin Class
EcoCacheFilterPlugin Members
DroopyEyes.EcoExtensions.CacheFiltering Namespace


EcoCacheFilterPlugin Methods

EcoCacheFilterPlugin Methods
Public Methods
Collapse All

The methods of the EcoCacheFilterPlugin class are listed here.

Public Methods
Name | Description
ApplyTranslationList | This is ApplyTranslationList, a member of class EcoCacheFilterPlugin.
Contains | This is Contains, a member of class EcoCacheFilterPlugin.
CreateNewObject | This is the overview for the CreateNewObject method overload.
DestroyObject | This is DestroyObject, a member of class EcoCacheFilterPlugin.
GetAllLocators | This is GetAllLocators, a member of class EcoCacheFilterPlugin.
GetCurrentOrderNo | This is GetCurrentOrderNo, a member of class EcoCacheFilterPlugin.
GetCurrentValue | This is GetCurrentValue, a member of class EcoCacheFilterPlugin.
GetEnsuredLocatorById | This is GetEnsuredLocatorById, a member of class EcoCacheFilterPlugin.
GetExistenceState | This is GetExistenceState, a member of class EcoCacheFilterPlugin.
GetExtentIsCurrent | This is GetExtentIsCurrent, a member of class EcoCacheFilterPlugin.
GetFetchedOrderNo | This is GetFetchedOrderNo, a member of class EcoCacheFilterPlugin.
GetFetchedValue | This is GetFetchedValue, a member of class EcoCacheFilterPlugin.
GetIdByLocator | This is GetIdByLocator, a member of class EcoCacheFilterPlugin.
GetLocatorById | This is GetLocatorById, a member of class EcoCacheFilterPlugin.
GetMemberHasFetchedValue | This is GetMemberHasFetchedValue, a member of class EcoCacheFilterPlugin.
GetMemberPersistenceState | This is GetMemberPersistenceState, a member of class EcoCacheFilterPlugin.
GetPersistenceState | This is GetPersistenceState, a member of class EcoCacheFilterPlugin.
GetTimestamp | This is GetTimestamp, a member of class EcoCacheFilterPlugin.
GetUmlClass | This is GetUmlClass, a member of class EcoCacheFilterPlugin.
InvalidateExtent | This is InvalidateExtent, a member of class EcoCacheFilterPlugin.
IsDefaultFetched | This is IsDefaultFetched, a member of class EcoCacheFilterPlugin.
IsDirty | This is IsDirty, a member of class EcoCacheFilterPlugin.
IsPersistent | This is IsPersistent, a member of class EcoCacheFilterPlugin.
SetCurrentAndFetchedOrderNo | This is SetCurrentAndFetchedOrderNo, a member of class EcoCacheFilterPlugin.
SetCurrentAndFetchedValue | This is SetCurrentAndFetchedValue, a member of class EcoCacheFilterPlugin.
SetCurrentOrderNo | This is SetCurrentOrderNo, a member of class EcoCacheFilterPlugin.
SetCurrentValue | This is SetCurrentValue, a member of class EcoCacheFilterPlugin.
SetExistenceState | This is SetExistenceState, a member of class EcoCacheFilterPlugin.
SetExtentCurrent | This is SetExtentCurrent, a member of class EcoCacheFilterPlugin.
SetFetchedValue | This is SetFetchedValue, a member of class EcoCacheFilterPlugin.
SetMemberPersistenceState | This is SetMemberPersistenceState, a member of class EcoCacheFilterPlugin.
SetObjectId | This is SetObjectId, a member of class EcoCacheFilterPlugin.
SetPersistenceState | This is SetPersistenceState, a member of class EcoCacheFilterPlugin.
SetTimestamp | This is SetTimestamp, a member of class EcoCacheFilterPlugin.


EcoCacheFilterPlugin.ApplyTranslationList Method

EcoCacheFilterPlugin.ApplyTranslationList Method
EcoCacheFilterPlugin Class EcoCacheFilterPlugin Members DroopyEyes.EcoExtensions.CacheFiltering Namespace See Also
Collapse All
C#
public void ApplyTranslationList(
    Eco.DataRepresentation.IdTranslationList idTranslationList
);
Remarks

This is ApplyTranslationList, a member of class EcoCacheFilterPlugin.

See Also
EcoCacheFilterPlugin Class
EcoCacheFilterPlugin Members
DroopyEyes.EcoExtensions.CacheFiltering Namespace


EcoCacheFilterPlugin.Contains Method

EcoCacheFilterPlugin.Contains Method
EcoCacheFilterPlugin Class EcoCacheFilterPlugin Members DroopyEyes.EcoExtensions.CacheFiltering Namespace See Also
Collapse All
C#
public bool Contains(
    Locator locator
);
Remarks

This is Contains, a member of class EcoCacheFilterPlugin.

See Also
EcoCacheFilterPlugin Class
EcoCacheFilterPlugin Members
DroopyEyes.EcoExtensions.CacheFiltering Namespace


CreateNewObject Method

CreateNewObject Method
Collapse All

This is the overview for the CreateNewObject method overload.

Overload List
Name | Description
EcoCacheFilterPlugin.CreateNewObject (Eco.UmlRt.IClass) | This is CreateNewObject, a member of class EcoCacheFilterPlugin.
EcoCacheFilterPlugin.CreateNewObject (Eco.UmlRt.IClass, ILoopBack) | This is CreateNewObject, a member of class EcoCacheFilterPlugin.


EcoCacheFilterPlugin.CreateNewObject Method (Eco.UmlRt.IClass)

EcoCacheFilterPlugin.CreateNewObject Method (Eco.UmlRt.IClass)
EcoCacheFilterPlugin Class EcoCacheFilterPlugin Members DroopyEyes.EcoExtensions.CacheFiltering Namespace See Also
Collapse All
C#
public Locator CreateNewObject(
    Eco.UmlRt.IClass class_
);
Remarks

This is CreateNewObject, a member of class EcoCacheFilterPlugin.

See Also
EcoCacheFilterPlugin Class
EcoCacheFilterPlugin Members
DroopyEyes.EcoExtensions.CacheFiltering Namespace


EcoCacheFilterPlugin.CreateNewObject Method (Eco.UmlRt.IClass, ILoopBack)

EcoCacheFilterPlugin.CreateNewObject Method (Eco.UmlRt.IClass, ILoopBack)
EcoCacheFilterPlugin Class EcoCacheFilterPlugin Members DroopyEyes.EcoExtensions.CacheFiltering Namespace See Also
Collapse All
C#
public Locator CreateNewObject(
    Eco.UmlRt.IClass class_,
    ILoopBack loopback
);
Remarks

This is CreateNewObject, a member of class EcoCacheFilterPlugin.

See Also
EcoCacheFilterPlugin Class
EcoCacheFilterPlugin Members
DroopyEyes.EcoExtensions.CacheFiltering Namespace


EcoCacheFilterPlugin.DestroyObject Method

EcoCacheFilterPlugin.DestroyObject Method
EcoCacheFilterPlugin Class EcoCacheFilterPlugin Members DroopyEyes.EcoExtensions.CacheFiltering Namespace See Also
Collapse All
C#
public void DestroyObject(
    Locator locator
);
Remarks

This is DestroyObject, a member of class EcoCacheFilterPlugin.

See Also
EcoCacheFilterPlugin Class
EcoCacheFilterPlugin Members
DroopyEyes.EcoExtensions.CacheFiltering Namespace


EcoCacheFilterPlugin.GetAllLocators Method

EcoCacheFilterPlugin.GetAllLocators Method
EcoCacheFilterPlugin Class EcoCacheFilterPlugin Members DroopyEyes.EcoExtensions.CacheFiltering Namespace See Also
Collapse All
C#
public Locator[] GetAllLocators();
Remarks

This is GetAllLocators, a member of class EcoCacheFilterPlugin.

See Also
EcoCacheFilterPlugin Class
EcoCacheFilterPlugin Members
DroopyEyes.EcoExtensions.CacheFiltering Namespace


EcoCacheFilterPlugin.GetCurrentOrderNo Method

EcoCacheFilterPlugin.GetCurrentOrderNo Method
EcoCacheFilterPlugin Class EcoCacheFilterPlugin Members DroopyEyes.EcoExtensions.CacheFiltering Namespace See Also
Collapse All
C#
public int GetCurrentOrderNo(
    Locator locator,
    Eco.UmlRt.IStructuralFeature structuralFeature
);
Remarks

This is GetCurrentOrderNo, a member of class EcoCacheFilterPlugin.

See Also
EcoCacheFilterPlugin Class
EcoCacheFilterPlugin Members
DroopyEyes.EcoExtensions.CacheFiltering Namespace


EcoCacheFilterPlugin.GetCurrentValue Method

EcoCacheFilterPlugin.GetCurrentValue Method
EcoCacheFilterPlugin Class EcoCacheFilterPlugin Members DroopyEyes.EcoExtensions.CacheFiltering Namespace See Also
Collapse All
C#
public object GetCurrentValue(
    Locator locator,
    Eco.UmlRt.IStructuralFeature structuralFeature
);
Remarks

This is GetCurrentValue, a member of class EcoCacheFilterPlugin.

See Also
EcoCacheFilterPlugin Class
EcoCacheFilterPlugin Members
DroopyEyes.EcoExtensions.CacheFiltering Namespace


EcoCacheFilterPlugin.GetEnsuredLocatorById Method

EcoCacheFilterPlugin.GetEnsuredLocatorById Method
EcoCacheFilterPlugin Class EcoCacheFilterPlugin Members DroopyEyes.EcoExtensions.CacheFiltering Namespace See Also
Collapse All
C#
public Locator GetEnsuredLocatorById(
    Eco.DataRepresentation.ObjectId objectId
);
Remarks

This is GetEnsuredLocatorById, a member of class EcoCacheFilterPlugin.

See Also
EcoCacheFilterPlugin Class
EcoCacheFilterPlugin Members
DroopyEyes.EcoExtensions.CacheFiltering Namespace


EcoCacheFilterPlugin.GetExistenceState Method

EcoCacheFilterPlugin.GetExistenceState Method
EcoCacheFilterPlugin Class EcoCacheFilterPlugin Members DroopyEyes.EcoExtensions.CacheFiltering Namespace See Also
Collapse All
C#
public Eco.Cache.ExistenceState GetExistenceState(
    Locator locator
);
Remarks

This is GetExistenceState, a member of class EcoCacheFilterPlugin.

See Also
EcoCacheFilterPlugin Class
EcoCacheFilterPlugin Members
DroopyEyes.EcoExtensions.CacheFiltering Namespace


EcoCacheFilterPlugin.GetExtentIsCurrent Method

EcoCacheFilterPlugin.GetExtentIsCurrent Method
EcoCacheFilterPlugin Class EcoCacheFilterPlugin Members DroopyEyes.EcoExtensions.CacheFiltering Namespace See Also
Collapse All
C#
public bool GetExtentIsCurrent(
    IClass c
);
Remarks

This is GetExtentIsCurrent, a member of class EcoCacheFilterPlugin.

See Also
EcoCacheFilterPlugin Class
EcoCacheFilterPlugin Members
DroopyEyes.EcoExtensions.CacheFiltering Namespace


EcoCacheFilterPlugin.GetFetchedOrderNo Method

EcoCacheFilterPlugin.GetFetchedOrderNo Method
EcoCacheFilterPlugin Class EcoCacheFilterPlugin Members DroopyEyes.EcoExtensions.CacheFiltering Namespace See Also
Collapse All
C#
public int GetFetchedOrderNo(
    Locator locator,
    Eco.UmlRt.IStructuralFeature structuralFeature
);
Remarks

This is GetFetchedOrderNo, a member of class EcoCacheFilterPlugin.

See Also
EcoCacheFilterPlugin Class
EcoCacheFilterPlugin Members
DroopyEyes.EcoExtensions.CacheFiltering Namespace


EcoCacheFilterPlugin.GetFetchedValue Method

EcoCacheFilterPlugin.GetFetchedValue Method
EcoCacheFilterPlugin Class EcoCacheFilterPlugin Members DroopyEyes.EcoExtensions.CacheFiltering Namespace See Also
Collapse All
C#
public object GetFetchedValue(
    Locator locator,
    Eco.UmlRt.IStructuralFeature structuralFeature
);
Remarks

This is GetFetchedValue, a member of class EcoCacheFilterPlugin.

See Also
EcoCacheFilterPlugin Class
EcoCacheFilterPlugin Members
DroopyEyes.EcoExtensions.CacheFiltering Namespace


EcoCacheFilterPlugin.GetIdByLocator Method

EcoCacheFilterPlugin.GetIdByLocator Method
EcoCacheFilterPlugin Class EcoCacheFilterPlugin Members DroopyEyes.EcoExtensions.CacheFiltering Namespace See Also
Collapse All
C#
public Eco.DataRepresentation.ObjectId GetIdByLocator(
    Locator locator
);
Remarks

This is GetIdByLocator, a member of class EcoCacheFilterPlugin.

See Also
EcoCacheFilterPlugin Class
EcoCacheFilterPlugin Members
DroopyEyes.EcoExtensions.CacheFiltering Namespace


EcoCacheFilterPlugin.GetLocatorById Method

EcoCacheFilterPlugin.GetLocatorById Method
EcoCacheFilterPlugin Class EcoCacheFilterPlugin Members DroopyEyes.EcoExtensions.CacheFiltering Namespace See Also
Collapse All
C#
public Locator GetLocatorById(
    Eco.DataRepresentation.ObjectId objectId
);
Remarks

This is GetLocatorById, a member of class EcoCacheFilterPlugin.

See Also
EcoCacheFilterPlugin Class
EcoCacheFilterPlugin Members
DroopyEyes.EcoExtensions.CacheFiltering Namespace


EcoCacheFilterPlugin.GetMemberHasFetchedValue Method

EcoCacheFilterPlugin.GetMemberHasFetchedValue Method
EcoCacheFilterPlugin Class EcoCacheFilterPlugin Members DroopyEyes.EcoExtensions.CacheFiltering Namespace See Also
Collapse All
C#
public bool GetMemberHasFetchedValue(
    Locator locator,
    Eco.UmlRt.IStructuralFeature structuralFeature
);
Remarks

This is GetMemberHasFetchedValue, a member of class EcoCacheFilterPlugin.

See Also
EcoCacheFilterPlugin Class
EcoCacheFilterPlugin Members
DroopyEyes.EcoExtensions.CacheFiltering Namespace


EcoCacheFilterPlugin.GetMemberPersistenceState Method

EcoCacheFilterPlugin.GetMemberPersistenceState Method
EcoCacheFilterPlugin Class EcoCacheFilterPlugin Members DroopyEyes.EcoExtensions.CacheFiltering Namespace See Also
Collapse All
C#
public PersistenceState GetMemberPersistenceState(
    Locator locator,
    Eco.UmlRt.IStructuralFeature structuralFeature
);
Remarks

This is GetMemberPersistenceState, a member of class EcoCacheFilterPlugin.

See Also
EcoCacheFilterPlugin Class
EcoCacheFilterPlugin Members
DroopyEyes.EcoExtensions.CacheFiltering Namespace


EcoCacheFilterPlugin.GetPersistenceState Method

EcoCacheFilterPlugin.GetPersistenceState Method
EcoCacheFilterPlugin Class EcoCacheFilterPlugin Members DroopyEyes.EcoExtensions.CacheFiltering Namespace See Also
Collapse All
C#
public PersistenceState GetPersistenceState(
    Locator locator
);
Remarks

This is GetPersistenceState, a member of class EcoCacheFilterPlugin.

See Also
EcoCacheFilterPlugin Class
EcoCacheFilterPlugin Members
DroopyEyes.EcoExtensions.CacheFiltering Namespace


EcoCacheFilterPlugin.GetTimestamp Method

EcoCacheFilterPlugin.GetTimestamp Method
EcoCacheFilterPlugin Class EcoCacheFilterPlugin Members DroopyEyes.EcoExtensions.CacheFiltering Namespace See Also
Collapse All
C#
public int GetTimestamp(
    Locator locator
);
Remarks

This is GetTimestamp, a member of class EcoCacheFilterPlugin.

See Also
EcoCacheFilterPlugin Class
EcoCacheFilterPlugin Members
DroopyEyes.EcoExtensions.CacheFiltering Namespace


EcoCacheFilterPlugin.GetUmlClass Method

EcoCacheFilterPlugin.GetUmlClass Method
EcoCacheFilterPlugin Class EcoCacheFilterPlugin Members DroopyEyes.EcoExtensions.CacheFiltering Namespace See Also
Collapse All
C#
public Eco.UmlRt.IClass GetUmlClass(
    Locator locator
);
Remarks

This is GetUmlClass, a member of class EcoCacheFilterPlugin.

See Also
EcoCacheFilterPlugin Class
EcoCacheFilterPlugin Members
DroopyEyes.EcoExtensions.CacheFiltering Namespace


EcoCacheFilterPlugin.InvalidateExtent Method

EcoCacheFilterPlugin.InvalidateExtent Method
EcoCacheFilterPlugin Class EcoCacheFilterPlugin Members DroopyEyes.EcoExtensions.CacheFiltering Namespace See Also
Collapse All
C#
public void InvalidateExtent(
    IClass c
);
Remarks

This is InvalidateExtent, a member of class EcoCacheFilterPlugin.

See Also
EcoCacheFilterPlugin Class
EcoCacheFilterPlugin Members
DroopyEyes.EcoExtensions.CacheFiltering Namespace


EcoCacheFilterPlugin.IsDefaultFetched Method

EcoCacheFilterPlugin.IsDefaultFetched Method
EcoCacheFilterPlugin Class EcoCacheFilterPlugin Members DroopyEyes.EcoExtensions.CacheFiltering Namespace See Also
Collapse All
C#
public bool IsDefaultFetched(
    Locator locator
);
Remarks

This is IsDefaultFetched, a member of class EcoCacheFilterPlugin.

See Also
EcoCacheFilterPlugin Class
EcoCacheFilterPlugin Members
DroopyEyes.EcoExtensions.CacheFiltering Namespace


EcoCacheFilterPlugin.IsDirty Method

EcoCacheFilterPlugin.IsDirty Method
EcoCacheFilterPlugin Class EcoCacheFilterPlugin Members DroopyEyes.EcoExtensions.CacheFiltering Namespace See Also
Collapse All
C#
public bool IsDirty(
    Locator locator
);
Remarks

This is IsDirty, a member of class EcoCacheFilterPlugin.

See Also
EcoCacheFilterPlugin Class
EcoCacheFilterPlugin Members
DroopyEyes.EcoExtensions.CacheFiltering Namespace


EcoCacheFilterPlugin.IsPersistent Method

EcoCacheFilterPlugin.IsPersistent Method
EcoCacheFilterPlugin Class EcoCacheFilterPlugin Members DroopyEyes.EcoExtensions.CacheFiltering Namespace See Also
Collapse All
C#
public bool IsPersistent(
    Locator locator
);
Remarks

This is IsPersistent, a member of class EcoCacheFilterPlugin.

See Also
EcoCacheFilterPlugin Class
EcoCacheFilterPlugin Members
DroopyEyes.EcoExtensions.CacheFiltering Namespace


EcoCacheFilterPlugin.SetCurrentAndFetchedOrderNo Method

EcoCacheFilterPlugin.SetCurrentAndFetchedOrderNo Method
EcoCacheFilterPlugin Class EcoCacheFilterPlugin Members DroopyEyes.EcoExtensions.CacheFiltering Namespace See Also
Collapse All
C#
public void SetCurrentAndFetchedOrderNo(
    Locator locator,
    Eco.UmlRt.IStructuralFeature structuralFeature,
    int orderNo
);
Remarks

This is SetCurrentAndFetchedOrderNo, a member of class EcoCacheFilterPlugin.

See Also
EcoCacheFilterPlugin Class
EcoCacheFilterPlugin Members
DroopyEyes.EcoExtensions.CacheFiltering Namespace


EcoCacheFilterPlugin.SetCurrentAndFetchedValue Method

EcoCacheFilterPlugin.SetCurrentAndFetchedValue Method
EcoCacheFilterPlugin Class EcoCacheFilterPlugin Members DroopyEyes.EcoExtensions.CacheFiltering Namespace See Also
Collapse All
C#
public void SetCurrentAndFetchedValue(
    Locator locator,
    Eco.UmlRt.IStructuralFeature structuralFeature,
    object value
);
Remarks

This is SetCurrentAndFetchedValue, a member of class EcoCacheFilterPlugin.

See Also
EcoCacheFilterPlugin Class
EcoCacheFilterPlugin Members
DroopyEyes.EcoExtensions.CacheFiltering Namespace


EcoCacheFilterPlugin.SetCurrentOrderNo Method

EcoCacheFilterPlugin.SetCurrentOrderNo Method
EcoCacheFilterPlugin Class EcoCacheFilterPlugin Members DroopyEyes.EcoExtensions.CacheFiltering Namespace See Also
Collapse All
C#
public void SetCurrentOrderNo(
    Locator locator,
    Eco.UmlRt.IStructuralFeature structuralFeature,
    int orderNo
);
Remarks

This is SetCurrentOrderNo, a member of class EcoCacheFilterPlugin.

See Also
EcoCacheFilterPlugin Class
EcoCacheFilterPlugin Members
DroopyEyes.EcoExtensions.CacheFiltering Namespace


EcoCacheFilterPlugin.SetCurrentValue Method

EcoCacheFilterPlugin.SetCurrentValue Method
EcoCacheFilterPlugin Class EcoCacheFilterPlugin Members DroopyEyes.EcoExtensions.CacheFiltering Namespace See Also
Collapse All
C#
public void SetCurrentValue(
    Locator locator,
    Eco.UmlRt.IStructuralFeature structuralFeature,
    object value
);
Remarks

This is SetCurrentValue, a member of class EcoCacheFilterPlugin.

See Also
EcoCacheFilterPlugin Class
EcoCacheFilterPlugin Members
DroopyEyes.EcoExtensions.CacheFiltering Namespace


EcoCacheFilterPlugin.SetExistenceState Method

EcoCacheFilterPlugin.SetExistenceState Method
EcoCacheFilterPlugin Class EcoCacheFilterPlugin Members DroopyEyes.EcoExtensions.CacheFiltering Namespace See Also
Collapse All
C#
public void SetExistenceState(
    Locator locator,
    Eco.Cache.ExistenceState value
);
Remarks

This is SetExistenceState, a member of class EcoCacheFilterPlugin.

See Also
EcoCacheFilterPlugin Class
EcoCacheFilterPlugin Members
DroopyEyes.EcoExtensions.CacheFiltering Namespace


EcoCacheFilterPlugin.SetExtentCurrent Method

EcoCacheFilterPlugin.SetExtentCurrent Method
EcoCacheFilterPlugin Class EcoCacheFilterPlugin Members DroopyEyes.EcoExtensions.CacheFiltering Namespace See Also
Collapse All
C#
public void SetExtentCurrent(
    IClass c
);
Remarks

This is SetExtentCurrent, a member of class EcoCacheFilterPlugin.

See Also
EcoCacheFilterPlugin Class
EcoCacheFilterPlugin Members
DroopyEyes.EcoExtensions.CacheFiltering Namespace


EcoCacheFilterPlugin.SetFetchedValue Method

EcoCacheFilterPlugin.SetFetchedValue Method
EcoCacheFilterPlugin Class EcoCacheFilterPlugin Members DroopyEyes.EcoExtensions.CacheFiltering Namespace See Also
Collapse All
C#
public void SetFetchedValue(
    Locator locator,
    Eco.UmlRt.IStructuralFeature structuralFeature,
    object value
);
Remarks

This is SetFetchedValue, a member of class EcoCacheFilterPlugin.

See Also
EcoCacheFilterPlugin Class
EcoCacheFilterPlugin Members
DroopyEyes.EcoExtensions.CacheFiltering Namespace


EcoCacheFilterPlugin.SetMemberPersistenceState Method

EcoCacheFilterPlugin.SetMemberPersistenceState Method
EcoCacheFilterPlugin Class EcoCacheFilterPlugin Members DroopyEyes.EcoExtensions.CacheFiltering Namespace See Also
Collapse All
C#
public void SetMemberPersistenceState(
    Locator locator,
    Eco.UmlRt.IStructuralFeature structuralFeature,
    PersistenceState value
);
Remarks

This is SetMemberPersistenceState, a member of class EcoCacheFilterPlugin.

See Also
EcoCacheFilterPlugin Class
EcoCacheFilterPlugin Members
DroopyEyes.EcoExtensions.CacheFiltering Namespace


EcoCacheFilterPlugin.SetObjectId Method

EcoCacheFilterPlugin.SetObjectId Method
EcoCacheFilterPlugin Class EcoCacheFilterPlugin Members DroopyEyes.EcoExtensions.CacheFiltering Namespace See Also
Collapse All
C#
public void SetObjectId(
    Locator locator,
    Eco.DataRepresentation.ObjectId newId
);
Remarks

This is SetObjectId, a member of class EcoCacheFilterPlugin.

See Also
EcoCacheFilterPlugin Class
EcoCacheFilterPlugin Members
DroopyEyes.EcoExtensions.CacheFiltering Namespace


EcoCacheFilterPlugin.SetPersistenceState Method

EcoCacheFilterPlugin.SetPersistenceState Method
EcoCacheFilterPlugin Class EcoCacheFilterPlugin Members DroopyEyes.EcoExtensions.CacheFiltering Namespace See Also
Collapse All
C#
public void SetPersistenceState(
    Locator locator,
    PersistenceState value
);
Remarks

This is SetPersistenceState, a member of class EcoCacheFilterPlugin.

See Also
EcoCacheFilterPlugin Class
EcoCacheFilterPlugin Members
DroopyEyes.EcoExtensions.CacheFiltering Namespace


EcoCacheFilterPlugin.SetTimestamp Method

EcoCacheFilterPlugin.SetTimestamp Method
EcoCacheFilterPlugin Class EcoCacheFilterPlugin Members DroopyEyes.EcoExtensions.CacheFiltering Namespace See Also
Collapse All
C#
public void SetTimestamp(
    Locator locator,
    int value
);
Remarks

This is SetTimestamp, a member of class EcoCacheFilterPlugin.

See Also
EcoCacheFilterPlugin Class
EcoCacheFilterPlugin Members
DroopyEyes.EcoExtensions.CacheFiltering Namespace


EcoCacheFilterPlugin Properties

EcoCacheFilterPlugin Properties
Public Properties
Collapse All

The properties of the EcoCacheFilterPlugin class are listed here.

Public Properties
Name | Description
CacheFilters | This property holds a list of EcoCacheFilters, which are executed in turn in order to modify the standard operations of the EcoSpace.
DeleteStack | This is DeleteStack, a member of class EcoCacheFilterPlugin.
EcoCache | This property should only bet set once in the constructor of your EcoSpace.
Enabled | This property must be set to True at runtime to plug in the cache filters.
IsActive | This is IsActive, a member of class EcoCacheFilterPlugin.


EcoCacheFilterPlugin.CacheFilters Property

EcoCacheFilterPlugin.CacheFilters Property
EcoCacheFilterPlugin Class EcoCacheFilterPlugin Members DroopyEyes.EcoExtensions.CacheFiltering Namespace See Also
Collapse All

This property holds a list of EcoCacheFilters, which are executed in turn in order to modify the standard operations of the EcoSpace.

C#
public EcoCacheFilterCollection CacheFilters;
See Also
EcoCacheFilterPlugin Class
EcoCacheFilterPlugin Members
DroopyEyes.EcoExtensions.CacheFiltering Namespace


EcoCacheFilterPlugin.DeleteStack Property

EcoCacheFilterPlugin.DeleteStack Property
EcoCacheFilterPlugin Class EcoCacheFilterPlugin Members DroopyEyes.EcoExtensions.CacheFiltering Namespace See Also
Collapse All
C#
public ICollection<Locator> DeleteStack;
Remarks

This is DeleteStack, a member of class EcoCacheFilterPlugin.

See Also
EcoCacheFilterPlugin Class
EcoCacheFilterPlugin Members
DroopyEyes.EcoExtensions.CacheFiltering Namespace


EcoCacheFilterPlugin.EcoCache Property

EcoCacheFilterPlugin.EcoCache Property
EcoCacheFilterPlugin Class EcoCacheFilterPlugin Members DroopyEyes.EcoExtensions.CacheFiltering Namespace See Also
Collapse All

This property should only bet set once in the constructor of your EcoSpace.

C#
public ICache EcoCache;
See Also
EcoCacheFilterPlugin Class
EcoCacheFilterPlugin Members
DroopyEyes.EcoExtensions.CacheFiltering Namespace


EcoCacheFilterPlugin.Enabled Property

EcoCacheFilterPlugin.Enabled Property
EcoCacheFilterPlugin Class EcoCacheFilterPlugin Members DroopyEyes.EcoExtensions.CacheFiltering Namespace See Also
Collapse All

This property must be set to True at runtime to plug in the cache filters.

C#
public Boolean Enabled;
See Also
EcoCacheFilterPlugin Class
EcoCacheFilterPlugin Members
DroopyEyes.EcoExtensions.CacheFiltering Namespace


EcoCacheFilterPlugin.IsActive Property

EcoCacheFilterPlugin.IsActive Property
EcoCacheFilterPlugin Class EcoCacheFilterPlugin Members DroopyEyes.EcoExtensions.CacheFiltering Namespace See Also
Collapse All
C#
public bool IsActive;
Remarks

This is IsActive, a member of class EcoCacheFilterPlugin.

See Also
EcoCacheFilterPlugin Class
EcoCacheFilterPlugin Members
DroopyEyes.EcoExtensions.CacheFiltering Namespace


EcoCacheFilterPlugin Events

EcoCacheFilterPlugin Events
Public Events
Collapse All

The events of the EcoCacheFilterPlugin class are listed here.

Public Events
Name | Description
CanRelease | This is CanRelease, a member of class EcoCacheFilterPlugin.
DirtyChanged | This is DirtyChanged, a member of class EcoCacheFilterPlugin.
ExistenceChanged | This is ExistenceChanged, a member of class EcoCacheFilterPlugin.
ExtentInvalidated | This is ExtentInvalidated, a member of class EcoCacheFilterPlugin.
LocatorAdded | This is LocatorAdded, a member of class EcoCacheFilterPlugin.
ValueChanged | This is ValueChanged, a member of class EcoCacheFilterPlugin.


EcoCacheFilterPlugin.CanRelease Event

EcoCacheFilterPlugin.CanRelease Event
EcoCacheFilterPlugin Class EcoCacheFilterPlugin Members DroopyEyes.EcoExtensions.CacheFiltering Namespace See Also
Collapse All
C#
public event CanReleaseDelegate CanRelease;
Remarks

This is CanRelease, a member of class EcoCacheFilterPlugin.

See Also
EcoCacheFilterPlugin Class
EcoCacheFilterPlugin Members
DroopyEyes.EcoExtensions.CacheFiltering Namespace


EcoCacheFilterPlugin.DirtyChanged Event

EcoCacheFilterPlugin.DirtyChanged Event
EcoCacheFilterPlugin Class EcoCacheFilterPlugin Members DroopyEyes.EcoExtensions.CacheFiltering Namespace See Also
Collapse All
C#
public event LocatorEventHandler DirtyChanged;
Remarks

This is DirtyChanged, a member of class EcoCacheFilterPlugin.

See Also
EcoCacheFilterPlugin Class
EcoCacheFilterPlugin Members
DroopyEyes.EcoExtensions.CacheFiltering Namespace


EcoCacheFilterPlugin.ExistenceChanged Event

EcoCacheFilterPlugin.ExistenceChanged Event
EcoCacheFilterPlugin Class EcoCacheFilterPlugin Members DroopyEyes.EcoExtensions.CacheFiltering Namespace See Also
Collapse All
C#
public event LocatorEventHandler ExistenceChanged;
Remarks

This is ExistenceChanged, a member of class EcoCacheFilterPlugin.

See Also
EcoCacheFilterPlugin Class
EcoCacheFilterPlugin Members
DroopyEyes.EcoExtensions.CacheFiltering Namespace


EcoCacheFilterPlugin.ExtentInvalidated Event

EcoCacheFilterPlugin.ExtentInvalidated Event
EcoCacheFilterPlugin Class EcoCacheFilterPlugin Members DroopyEyes.EcoExtensions.CacheFiltering Namespace See Also
Collapse All
C#
public event ExtentChangedEventHandler ExtentInvalidated;
Remarks

This is ExtentInvalidated, a member of class EcoCacheFilterPlugin.

See Also
EcoCacheFilterPlugin Class
EcoCacheFilterPlugin Members
DroopyEyes.EcoExtensions.CacheFiltering Namespace


EcoCacheFilterPlugin.LocatorAdded Event

EcoCacheFilterPlugin.LocatorAdded Event
EcoCacheFilterPlugin Class EcoCacheFilterPlugin Members DroopyEyes.EcoExtensions.CacheFiltering Namespace See Also
Collapse All
C#
public event LocatorEventHandler LocatorAdded;
Remarks

This is LocatorAdded, a member of class EcoCacheFilterPlugin.

See Also
EcoCacheFilterPlugin Class
EcoCacheFilterPlugin Members
DroopyEyes.EcoExtensions.CacheFiltering Namespace


EcoCacheFilterPlugin.ValueChanged Event

EcoCacheFilterPlugin.ValueChanged Event
EcoCacheFilterPlugin Class EcoCacheFilterPlugin Members DroopyEyes.EcoExtensions.CacheFiltering Namespace See Also
Collapse All
C#
public event ValueChangedDelegate ValueChanged;
Remarks

This is ValueChanged, a member of class EcoCacheFilterPlugin.

See Also
EcoCacheFilterPlugin Class
EcoCacheFilterPlugin Members
DroopyEyes.EcoExtensions.CacheFiltering Namespace


EcoCacheTraceFilter Class

EcoCacheTraceFilter Class
EcoCacheTraceFilter Members Inheritance Hierarchy See Also
Collapse All

An example of an EcoCacheFilter which intercepts EcoCache execution and outputs the actions using Trace.WriteLine

C#
public class EcoCacheTraceFilter : ChainedCacheBase, ICacheFilter;
Inheritance Hierarchy
DroopyEyes.EcoExtensions.CacheFiltering.ICacheFilter
    DroopyEyes.EcoExtensions.CacheFiltering.EcoCacheTraceFilter
File

EcoCacheTraceFilter.cs

See Also
EcoCacheTraceFilter Members
Inheritance Hierarchy


EcoCacheTraceFilter Members

EcoCacheTraceFilter Members
Public Methods Public Properties
Collapse All

The following tables list the members exposed by EcoCacheTraceFilter.

Public Methods
Name | Description
ApplyTranslationList | This is ApplyTranslationList, a member of class EcoCacheTraceFilter.
CreateNewObject | This is CreateNewObject, a member of class EcoCacheTraceFilter.
DestroyObject | This is DestroyObject, a member of class EcoCacheTraceFilter.
EcoCacheTraceFilter | This is EcoCacheTraceFilter, a member of class EcoCacheTraceFilter.
GetAllLocators | This is GetAllLocators, a member of class EcoCacheTraceFilter.
GetCurrentOrderNo | This is GetCurrentOrderNo, a member of class EcoCacheTraceFilter.
GetCurrentValue | This is GetCurrentValue, a member of class EcoCacheTraceFilter.
GetEnsuredLocatorById | This is GetEnsuredLocatorById, a member of class EcoCacheTraceFilter.
GetExistenceState | This is GetExistenceState, a member of class EcoCacheTraceFilter.
GetFetchedValue | This is GetFetchedValue, a member of class EcoCacheTraceFilter.
GetIdByLocator | This is GetIdByLocator, a member of class EcoCacheTraceFilter.
GetLocatorById | This is GetLocatorById, a member of class EcoCacheTraceFilter.
GetMemberPersistenceState | This is GetMemberPersistenceState, a member of class EcoCacheTraceFilter.
GetPersistenceState | This is GetPersistenceState, a member of class EcoCacheTraceFilter.
GetTimestamp | This is GetTimestamp, a member of class EcoCacheTraceFilter.
GetUmlClass | This is GetUmlClass, a member of class EcoCacheTraceFilter.
IsPersistent | This is IsPersistent, a member of class EcoCacheTraceFilter.
SetCurrentAndFetchedOrderNo | This is SetCurrentAndFetchedOrderNo, a member of class EcoCacheTraceFilter.
SetCurrentAndFetchedValue | This is SetCurrentAndFetchedValue, a member of class EcoCacheTraceFilter.
SetCurrentOrderNo | This is SetCurrentOrderNo, a member of class EcoCacheTraceFilter.
SetCurrentValue | This is SetCurrentValue, a member of class EcoCacheTraceFilter.
SetExistenceState | This is SetExistenceState, a member of class EcoCacheTraceFilter.
SetFetchedValue | This is SetFetchedValue, a member of class EcoCacheTraceFilter.
SetMemberPersistenceState | This is SetMemberPersistenceState, a member of class EcoCacheTraceFilter.
SetPersistenceState | This is SetPersistenceState, a member of class EcoCacheTraceFilter.
SetTimestamp | This is SetTimestamp, a member of class EcoCacheTraceFilter.
Top
Public Properties
Name | Description
Enabled | Specified if interceptions should be written using Trace.WriteLine or not
MessageCategory | Specifies the category to use when calling Trace.WriteLine
MessagePrefix | If multiple Trace filters are inserted into the filter chain, this property is useful for identifying which filter output a message by prefixing each message with the specified text
NextCache | Holds a reference to the next ICache in the chain.
TraceFlags | A set of flags which determine which Eco cache methods should output a trace message


EcoCacheTraceFilter.EcoCacheTraceFilter Constructor

EcoCacheTraceFilter.EcoCacheTraceFilter Constructor
EcoCacheTraceFilter Class EcoCacheTraceFilter Members DroopyEyes.EcoExtensions.CacheFiltering Namespace See Also
Collapse All
C#
public EcoCacheTraceFilter();
Remarks

This is EcoCacheTraceFilter, a member of class EcoCacheTraceFilter.

See Also
EcoCacheTraceFilter Class
EcoCacheTraceFilter Members
DroopyEyes.EcoExtensions.CacheFiltering Namespace


EcoCacheTraceFilter Methods

EcoCacheTraceFilter Methods
Public Methods
Collapse All

The methods of the EcoCacheTraceFilter class are listed here.

Public Methods
Name | Description
ApplyTranslationList | This is ApplyTranslationList, a member of class EcoCacheTraceFilter.
CreateNewObject | This is CreateNewObject, a member of class EcoCacheTraceFilter.
DestroyObject | This is DestroyObject, a member of class EcoCacheTraceFilter.
GetAllLocators | This is GetAllLocators, a member of class EcoCacheTraceFilter.
GetCurrentOrderNo | This is GetCurrentOrderNo, a member of class EcoCacheTraceFilter.
GetCurrentValue | This is GetCurrentValue, a member of class EcoCacheTraceFilter.
GetEnsuredLocatorById | This is GetEnsuredLocatorById, a member of class EcoCacheTraceFilter.
GetExistenceState | This is GetExistenceState, a member of class EcoCacheTraceFilter.
GetFetchedValue | This is GetFetchedValue, a member of class EcoCacheTraceFilter.
GetIdByLocator | This is GetIdByLocator, a member of class EcoCacheTraceFilter.
GetLocatorById | This is GetLocatorById, a member of class EcoCacheTraceFilter.
GetMemberPersistenceState | This is GetMemberPersistenceState, a member of class EcoCacheTraceFilter.
GetPersistenceState | This is GetPersistenceState, a member of class EcoCacheTraceFilter.
GetTimestamp | This is GetTimestamp, a member of class EcoCacheTraceFilter.
GetUmlClass | This is GetUmlClass, a member of class EcoCacheTraceFilter.
IsPersistent | This is IsPersistent, a member of class EcoCacheTraceFilter.
SetCurrentAndFetchedOrderNo | This is SetCurrentAndFetchedOrderNo, a member of class EcoCacheTraceFilter.
SetCurrentAndFetchedValue | This is SetCurrentAndFetchedValue, a member of class EcoCacheTraceFilter.
SetCurrentOrderNo | This is SetCurrentOrderNo, a member of class EcoCacheTraceFilter.
SetCurrentValue | This is SetCurrentValue, a member of class EcoCacheTraceFilter.
SetExistenceState | This is SetExistenceState, a member of class EcoCacheTraceFilter.
SetFetchedValue | This is SetFetchedValue, a member of class EcoCacheTraceFilter.
SetMemberPersistenceState | This is SetMemberPersistenceState, a member of class EcoCacheTraceFilter.
SetPersistenceState | This is SetPersistenceState, a member of class EcoCacheTraceFilter.
SetTimestamp | This is SetTimestamp, a member of class EcoCacheTraceFilter.


EcoCacheTraceFilter.ApplyTranslationList Method

EcoCacheTraceFilter.ApplyTranslationList Method
EcoCacheTraceFilter Class EcoCacheTraceFilter Members DroopyEyes.EcoExtensions.CacheFiltering Namespace See Also
Collapse All
C#
public override void ApplyTranslationList(
    IdTranslationList idTranslationList
);
Remarks

This is ApplyTranslationList, a member of class EcoCacheTraceFilter.

See Also
EcoCacheTraceFilter Class
EcoCacheTraceFilter Members
DroopyEyes.EcoExtensions.CacheFiltering Namespace


EcoCacheTraceFilter.CreateNewObject Method

EcoCacheTraceFilter.CreateNewObject Method
EcoCacheTraceFilter Class EcoCacheTraceFilter Members DroopyEyes.EcoExtensions.CacheFiltering Namespace See Also
Collapse All
C#
public override Locator CreateNewObject(
    IClass classifier
);
Remarks

This is CreateNewObject, a member of class EcoCacheTraceFilter.

See Also
EcoCacheTraceFilter Class
EcoCacheTraceFilter Members
DroopyEyes.EcoExtensions.CacheFiltering Namespace


EcoCacheTraceFilter.DestroyObject Method

EcoCacheTraceFilter.DestroyObject Method
EcoCacheTraceFilter Class EcoCacheTraceFilter Members DroopyEyes.EcoExtensions.CacheFiltering Namespace See Also
Collapse All
C#
public override void DestroyObject(
    Locator locator
);
Remarks

This is DestroyObject, a member of class EcoCacheTraceFilter.

See Also
EcoCacheTraceFilter Class
EcoCacheTraceFilter Members
DroopyEyes.EcoExtensions.CacheFiltering Namespace


EcoCacheTraceFilter.GetAllLocators Method

EcoCacheTraceFilter.GetAllLocators Method
EcoCacheTraceFilter Class EcoCacheTraceFilter Members DroopyEyes.EcoExtensions.CacheFiltering Namespace See Also
Collapse All
C#
public override Locator[] GetAllLocators();
Remarks

This is GetAllLocators, a member of class EcoCacheTraceFilter.

See Also
EcoCacheTraceFilter Class
EcoCacheTraceFilter Members
DroopyEyes.EcoExtensions.CacheFiltering Namespace


EcoCacheTraceFilter.GetCurrentOrderNo Method

EcoCacheTraceFilter.GetCurrentOrderNo Method
EcoCacheTraceFilter Class EcoCacheTraceFilter Members DroopyEyes.EcoExtensions.CacheFiltering Namespace See Also
Collapse All
C#
public override Int32 GetCurrentOrderNo(
    Locator locator,
    IStructuralFeature structuralFeature
);
Remarks

This is GetCurrentOrderNo, a member of class EcoCacheTraceFilter.

See Also
EcoCacheTraceFilter Class
EcoCacheTraceFilter Members
DroopyEyes.EcoExtensions.CacheFiltering Namespace


EcoCacheTraceFilter.GetCurrentValue Method

EcoCacheTraceFilter.GetCurrentValue Method
EcoCacheTraceFilter Class EcoCacheTraceFilter Members DroopyEyes.EcoExtensions.CacheFiltering Namespace See Also
Collapse All
C#
public override object GetCurrentValue(
    Locator locator,
    IStructuralFeature structuralFeature
);
Remarks

This is GetCurrentValue, a member of class EcoCacheTraceFilter.

See Also
EcoCacheTraceFilter Class
EcoCacheTraceFilter Members
DroopyEyes.EcoExtensions.CacheFiltering Namespace


EcoCacheTraceFilter.GetEnsuredLocatorById Method

EcoCacheTraceFilter.GetEnsuredLocatorById Method
EcoCacheTraceFilter Class EcoCacheTraceFilter Members DroopyEyes.EcoExtensions.CacheFiltering Namespace See Also
Collapse All
C#
public override Locator GetEnsuredLocatorById(
    ObjectId objectId
);
Remarks

This is GetEnsuredLocatorById, a member of class EcoCacheTraceFilter.

See Also
EcoCacheTraceFilter Class
EcoCacheTraceFilter Members
DroopyEyes.EcoExtensions.CacheFiltering Namespace


EcoCacheTraceFilter.GetExistenceState Method

EcoCacheTraceFilter.GetExistenceState Method
EcoCacheTraceFilter Class EcoCacheTraceFilter Members DroopyEyes.EcoExtensions.CacheFiltering Namespace See Also
Collapse All
C#
public override Eco.Cache.ExistenceState GetExistenceState(
    Locator locator
);
Remarks

This is GetExistenceState, a member of class EcoCacheTraceFilter.

See Also
EcoCacheTraceFilter Class
EcoCacheTraceFilter Members
DroopyEyes.EcoExtensions.CacheFiltering Namespace


EcoCacheTraceFilter.GetFetchedValue Method

EcoCacheTraceFilter.GetFetchedValue Method
EcoCacheTraceFilter Class EcoCacheTraceFilter Members DroopyEyes.EcoExtensions.CacheFiltering Namespace See Also
Collapse All
C#
public override object GetFetchedValue(
    Locator locator,
    IStructuralFeature structuralFeature
);
Remarks

This is GetFetchedValue, a member of class EcoCacheTraceFilter.

See Also
EcoCacheTraceFilter Class
EcoCacheTraceFilter Members
DroopyEyes.EcoExtensions.CacheFiltering Namespace


EcoCacheTraceFilter.GetIdByLocator Method

EcoCacheTraceFilter.GetIdByLocator Method
EcoCacheTraceFilter Class EcoCacheTraceFilter Members DroopyEyes.EcoExtensions.CacheFiltering Namespace See Also
Collapse All
C#
public override ObjectId GetIdByLocator(
    Locator locator
);
Remarks

This is GetIdByLocator, a member of class EcoCacheTraceFilter.

See Also
EcoCacheTraceFilter Class
EcoCacheTraceFilter Members
DroopyEyes.EcoExtensions.CacheFiltering Namespace


EcoCacheTraceFilter.GetLocatorById Method

EcoCacheTraceFilter.GetLocatorById Method
EcoCacheTraceFilter Class EcoCacheTraceFilter Members DroopyEyes.EcoExtensions.CacheFiltering Namespace See Also
Collapse All
C#
public override Locator GetLocatorById(
    ObjectId objectId
);
Remarks

This is GetLocatorById, a member of class EcoCacheTraceFilter.

See Also
EcoCacheTraceFilter Class
EcoCacheTraceFilter Members
DroopyEyes.EcoExtensions.CacheFiltering Namespace


EcoCacheTraceFilter.GetMemberPersistenceState Method

EcoCacheTraceFilter.GetMemberPersistenceState Method
EcoCacheTraceFilter Class EcoCacheTraceFilter Members DroopyEyes.EcoExtensions.CacheFiltering Namespace See Also
Collapse All
C#
public override PersistenceState GetMemberPersistenceState(
    Locator locator,
    IStructuralFeature structuralFeature
);
Remarks

This is GetMemberPersistenceState, a member of class EcoCacheTraceFilter.

See Also
EcoCacheTraceFilter Class
EcoCacheTraceFilter Members
DroopyEyes.EcoExtensions.CacheFiltering Namespace


EcoCacheTraceFilter.GetPersistenceState Method

EcoCacheTraceFilter.GetPersistenceState Method
EcoCacheTraceFilter Class EcoCacheTraceFilter Members DroopyEyes.EcoExtensions.CacheFiltering Namespace See Also
Collapse All
C#
public override PersistenceState GetPersistenceState(
    Locator locator
);
Remarks

This is GetPersistenceState, a member of class EcoCacheTraceFilter.

See Also
EcoCacheTraceFilter Class
EcoCacheTraceFilter Members
DroopyEyes.EcoExtensions.CacheFiltering Namespace


EcoCacheTraceFilter.GetTimestamp Method

EcoCacheTraceFilter.GetTimestamp Method
EcoCacheTraceFilter Class EcoCacheTraceFilter Members DroopyEyes.EcoExtensions.CacheFiltering Namespace See Also
Collapse All
C#
public override Int32 GetTimestamp(
    Locator locator
);
Remarks

This is GetTimestamp, a member of class EcoCacheTraceFilter.

See Also
EcoCacheTraceFilter Class
EcoCacheTraceFilter Members
DroopyEyes.EcoExtensions.CacheFiltering Namespace


EcoCacheTraceFilter.GetUmlClass Method

EcoCacheTraceFilter.GetUmlClass Method
EcoCacheTraceFilter Class EcoCacheTraceFilter Members DroopyEyes.EcoExtensions.CacheFiltering Namespace See Also
Collapse All
C#
public override IClass GetUmlClass(
    Locator locator
);
Remarks

This is GetUmlClass, a member of class EcoCacheTraceFilter.

See Also
EcoCacheTraceFilter Class
EcoCacheTraceFilter Members
DroopyEyes.EcoExtensions.CacheFiltering Namespace


EcoCacheTraceFilter.IsPersistent Method

EcoCacheTraceFilter.IsPersistent Method
EcoCacheTraceFilter Class EcoCacheTraceFilter Members DroopyEyes.EcoExtensions.CacheFiltering Namespace See Also
Collapse All
C#
public override Boolean IsPersistent(
    Locator locator
);
Remarks

This is IsPersistent, a member of class EcoCacheTraceFilter.

See Also
EcoCacheTraceFilter Class
EcoCacheTraceFilter Members
DroopyEyes.EcoExtensions.CacheFiltering Namespace


EcoCacheTraceFilter.SetCurrentAndFetchedOrderNo Method

EcoCacheTraceFilter.SetCurrentAndFetchedOrderNo Method
EcoCacheTraceFilter Class EcoCacheTraceFilter Members DroopyEyes.EcoExtensions.CacheFiltering Namespace See Also
Collapse All
C#
public override void SetCurrentAndFetchedOrderNo(
    Locator locator,
    IStructuralFeature structuralFeature,
    Int32 orderNo
);
Remarks

This is SetCurrentAndFetchedOrderNo, a member of class EcoCacheTraceFilter.

See Also
EcoCacheTraceFilter Class
EcoCacheTraceFilter Members
DroopyEyes.EcoExtensions.CacheFiltering Namespace


EcoCacheTraceFilter.SetCurrentAndFetchedValue Method

EcoCacheTraceFilter.SetCurrentAndFetchedValue Method
EcoCacheTraceFilter Class EcoCacheTraceFilter Members DroopyEyes.EcoExtensions.CacheFiltering Namespace See Also
Collapse All
C#
public override void SetCurrentAndFetchedValue(
    Locator locator,
    IStructuralFeature structuralFeature,
    object value
);
Remarks

This is SetCurrentAndFetchedValue, a member of class EcoCacheTraceFilter.

See Also
EcoCacheTraceFilter Class
EcoCacheTraceFilter Members
DroopyEyes.EcoExtensions.CacheFiltering Namespace


EcoCacheTraceFilter.SetCurrentOrderNo Method

EcoCacheTraceFilter.SetCurrentOrderNo Method
EcoCacheTraceFilter Class EcoCacheTraceFilter Members DroopyEyes.EcoExtensions.CacheFiltering Namespace See Also
Collapse All
C#
public override void SetCurrentOrderNo(
    Locator locator,
    IStructuralFeature structuralFeature,
    Int32 orderNo
);
Remarks

This is SetCurrentOrderNo, a member of class EcoCacheTraceFilter.

See Also
EcoCacheTraceFilter Class
EcoCacheTraceFilter Members
DroopyEyes.EcoExtensions.CacheFiltering Namespace


EcoCacheTraceFilter.SetCurrentValue Method

EcoCacheTraceFilter.SetCurrentValue Method
EcoCacheTraceFilter Class EcoCacheTraceFilter Members DroopyEyes.EcoExtensions.CacheFiltering Namespace See Also
Collapse All
C#
public override void SetCurrentValue(
    Locator locator,
    IStructuralFeature structuralFeature,
    object value
);
Remarks

This is SetCurrentValue, a member of class EcoCacheTraceFilter.

See Also
EcoCacheTraceFilter Class
EcoCacheTraceFilter Members
DroopyEyes.EcoExtensions.CacheFiltering Namespace


EcoCacheTraceFilter.SetExistenceState Method

EcoCacheTraceFilter.SetExistenceState Method
EcoCacheTraceFilter Class EcoCacheTraceFilter Members DroopyEyes.EcoExtensions.CacheFiltering Namespace See Also
Collapse All
C#
public override void SetExistenceState(
    Locator locator,
    Eco.Cache.ExistenceState value
);
Remarks

This is SetExistenceState, a member of class EcoCacheTraceFilter.

See Also
EcoCacheTraceFilter Class
EcoCacheTraceFilter Members
DroopyEyes.EcoExtensions.CacheFiltering Namespace


EcoCacheTraceFilter.SetFetchedValue Method

EcoCacheTraceFilter.SetFetchedValue Method
EcoCacheTraceFilter Class EcoCacheTraceFilter Members DroopyEyes.EcoExtensions.CacheFiltering Namespace See Also
Collapse All
C#
public override void SetFetchedValue(
    Locator locator,
    IStructuralFeature structuralFeature,
    object value
);
Remarks

This is SetFetchedValue, a member of class EcoCacheTraceFilter.

See Also
EcoCacheTraceFilter Class
EcoCacheTraceFilter Members
DroopyEyes.EcoExtensions.CacheFiltering Namespace


EcoCacheTraceFilter.SetMemberPersistenceState Method

EcoCacheTraceFilter.SetMemberPersistenceState Method
EcoCacheTraceFilter Class EcoCacheTraceFilter Members DroopyEyes.EcoExtensions.CacheFiltering Namespace See Also
Collapse All
C#
public override void SetMemberPersistenceState(
    Locator locator,
    IStructuralFeature structuralFeature,
    PersistenceState value
);
Remarks

This is SetMemberPersistenceState, a member of class EcoCacheTraceFilter.

See Also
EcoCacheTraceFilter Class
EcoCacheTraceFilter Members
DroopyEyes.EcoExtensions.CacheFiltering Namespace


EcoCacheTraceFilter.SetPersistenceState Method

EcoCacheTraceFilter.SetPersistenceState Method
EcoCacheTraceFilter Class EcoCacheTraceFilter Members DroopyEyes.EcoExtensions.CacheFiltering Namespace See Also
Collapse All
C#
public override void SetPersistenceState(
    Locator locator,
    PersistenceState value
);
Remarks

This is SetPersistenceState, a member of class EcoCacheTraceFilter.

See Also
EcoCacheTraceFilter Class
EcoCacheTraceFilter Members
DroopyEyes.EcoExtensions.CacheFiltering Namespace


EcoCacheTraceFilter.SetTimestamp Method

EcoCacheTraceFilter.SetTimestamp Method
EcoCacheTraceFilter Class EcoCacheTraceFilter Members DroopyEyes.EcoExtensions.CacheFiltering Namespace See Also
Collapse All
C#
public override void SetTimestamp(
    Locator locator,
    Int32 value
);
Remarks

This is SetTimestamp, a member of class EcoCacheTraceFilter.

See Also
EcoCacheTraceFilter Class
EcoCacheTraceFilter Members
DroopyEyes.EcoExtensions.CacheFiltering Namespace


EcoCacheTraceFilter Properties

EcoCacheTraceFilter Properties
Public Properties
Collapse All

The properties of the EcoCacheTraceFilter class are listed here.

Public Properties
Name | Description
Enabled | Specified if interceptions should be written using Trace.WriteLine or not
MessageCategory | Specifies the category to use when calling Trace.WriteLine
MessagePrefix | If multiple Trace filters are inserted into the filter chain, this property is useful for identifying which filter output a message by prefixing each message with the specified text
TraceFlags | A set of flags which determine which Eco cache methods should output a trace message


EcoCacheTraceFilter.Enabled Property

EcoCacheTraceFilter.Enabled Property
EcoCacheTraceFilter Class EcoCacheTraceFilter Members DroopyEyes.EcoExtensions.CacheFiltering Namespace See Also
Collapse All

Specified if interceptions should be written using Trace.WriteLine or not

C#
public Boolean Enabled;
See Also
EcoCacheTraceFilter Class
EcoCacheTraceFilter Members
DroopyEyes.EcoExtensions.CacheFiltering Namespace


EcoCacheTraceFilter.MessageCategory Property

EcoCacheTraceFilter.MessageCategory Property
EcoCacheTraceFilter Class EcoCacheTraceFilter Members DroopyEyes.EcoExtensions.CacheFiltering Namespace See Also
Collapse All

Specifies the category to use when calling Trace.WriteLine

C#
public String MessageCategory;
See Also
EcoCacheTraceFilter Class
EcoCacheTraceFilter Members
DroopyEyes.EcoExtensions.CacheFiltering Namespace


EcoCacheTraceFilter.MessagePrefix Property

EcoCacheTraceFilter.MessagePrefix Property
EcoCacheTraceFilter Class EcoCacheTraceFilter Members DroopyEyes.EcoExtensions.CacheFiltering Namespace See Also
Collapse All

If multiple Trace filters are inserted into the filter chain, this property is useful for identifying which filter output a message by prefixing each message with the specified text

C#
public String MessagePrefix;
See Also
EcoCacheTraceFilter Class
EcoCacheTraceFilter Members
DroopyEyes.EcoExtensions.CacheFiltering Namespace


EcoCacheTraceFilter.TraceFlags Property

EcoCacheTraceFilter.TraceFlags Property
EcoCacheTraceFilter Class EcoCacheTraceFilter Members DroopyEyes.EcoExtensions.CacheFiltering Namespace See Also
Collapse All

A set of flags which determine which Eco cache methods should output a trace message

C#
public TraceFlags TraceFlags;
See Also
EcoCacheTraceFilter Class
EcoCacheTraceFilter Members
DroopyEyes.EcoExtensions.CacheFiltering Namespace


TraceFlags Class

TraceFlags Class
TraceFlags Members Inheritance Hierarchy See Also
Collapse All

A set of flags which determine which Eco cache methods should output a trace message

C#
public class TraceFlags;
Inheritance Hierarchy
DroopyEyes.EcoExtensions.CacheFiltering.TraceFlags
File

TraceFlags.cs

See Also
TraceFlags Members
Inheritance Hierarchy


TraceFlags Members

TraceFlags Members
Public Properties
Collapse All

The following tables list the members exposed by TraceFlags.

Public Properties
Name | Description
ApplyTranslationList | This is ApplyTranslationList, a member of class TraceFlags.
CreateNewObject | This is CreateNewObject, a member of class TraceFlags.
DestroyObject | This is DestroyObject, a member of class TraceFlags.
GetAllLocators | This is GetAllLocators, a member of class TraceFlags.
GetCurrentOrderNo | This is GetCurrentOrderNo, a member of class TraceFlags.
GetCurrentValue | This is GetCurrentValue, a member of class TraceFlags.
GetEnsuredLocatorById | This is GetEnsuredLocatorById, a member of class TraceFlags.
GetExistenceState | This is GetExistenceState, a member of class TraceFlags.
GetFetchedValue | This is GetFetchedValue, a member of class TraceFlags.
GetIdByLocator | This is GetIdByLocator, a member of class TraceFlags.
GetLocatorById | This is GetLocatorById, a member of class TraceFlags.
GetMemberPersistenceState | This is GetMemberPersistenceState, a member of class TraceFlags.
GetPersistenceState | This is GetPersistenceState, a member of class TraceFlags.
GetTimestamp | This is GetTimestamp, a member of class TraceFlags.
GetUmlClass | This is GetUmlClass, a member of class TraceFlags.
IsPersistent | This is IsPersistent, a member of class TraceFlags.
SetCurrentAndFetchedOrderNo | This is SetCurrentAndFetchedOrderNo, a member of class TraceFlags.
SetCurrentAndFetchedValue | This is SetCurrentAndFetchedValue, a member of class TraceFlags.
SetCurrentOrderNo | This is SetCurrentOrderNo, a member of class TraceFlags.
SetCurrentValue | This is SetCurrentValue, a member of class TraceFlags.
SetExistenceState | This is SetExistenceState, a member of class TraceFlags.
SetFetchedValue | This is SetFetchedValue, a member of class TraceFlags.
SetMemberPersistenceState | This is SetMemberPersistenceState, a member of class TraceFlags.
SetPersistenceState | This is SetPersistenceState, a member of class TraceFlags.
SetTimestamp | This is SetTimestamp, a member of class TraceFlags.


TraceFlags Properties

TraceFlags Properties
Public Properties
Collapse All

The properties of the TraceFlags class are listed here.

Public Properties
Name | Description
ApplyTranslationList | This is ApplyTranslationList, a member of class TraceFlags.
CreateNewObject | This is CreateNewObject, a member of class TraceFlags.
DestroyObject | This is DestroyObject, a member of class TraceFlags.
GetAllLocators | This is GetAllLocators, a member of class TraceFlags.
GetCurrentOrderNo | This is GetCurrentOrderNo, a member of class TraceFlags.
GetCurrentValue | This is GetCurrentValue, a member of class TraceFlags.
GetEnsuredLocatorById | This is GetEnsuredLocatorById, a member of class TraceFlags.
GetExistenceState | This is GetExistenceState, a member of class TraceFlags.
GetFetchedValue | This is GetFetchedValue, a member of class TraceFlags.
GetIdByLocator | This is GetIdByLocator, a member of class TraceFlags.
GetLocatorById | This is GetLocatorById, a member of class TraceFlags.
GetMemberPersistenceState | This is GetMemberPersistenceState, a member of class TraceFlags.
GetPersistenceState | This is GetPersistenceState, a member of class TraceFlags.
GetTimestamp | This is GetTimestamp, a member of class TraceFlags.
GetUmlClass | This is GetUmlClass, a member of class TraceFlags.
IsPersistent | This is IsPersistent, a member of class TraceFlags.
SetCurrentAndFetchedOrderNo | This is SetCurrentAndFetchedOrderNo, a member of class TraceFlags.
SetCurrentAndFetchedValue | This is SetCurrentAndFetchedValue, a member of class TraceFlags.
SetCurrentOrderNo | This is SetCurrentOrderNo, a member of class TraceFlags.
SetCurrentValue | This is SetCurrentValue, a member of class TraceFlags.
SetExistenceState | This is SetExistenceState, a member of class TraceFlags.
SetFetchedValue | This is SetFetchedValue, a member of class TraceFlags.
SetMemberPersistenceState | This is SetMemberPersistenceState, a member of class TraceFlags.
SetPersistenceState | This is SetPersistenceState, a member of class TraceFlags.
SetTimestamp | This is SetTimestamp, a member of class TraceFlags.


TraceFlags.ApplyTranslationList Property

TraceFlags.ApplyTranslationList Property
TraceFlags Class TraceFlags Members DroopyEyes.EcoExtensions.CacheFiltering Namespace See Also
Collapse All
C#
public Boolean ApplyTranslationList;
Remarks

This is ApplyTranslationList, a member of class TraceFlags.

See Also
TraceFlags Class
TraceFlags Members
DroopyEyes.EcoExtensions.CacheFiltering Namespace


TraceFlags.CreateNewObject Property

TraceFlags.CreateNewObject Property
TraceFlags Class TraceFlags Members DroopyEyes.EcoExtensions.CacheFiltering Namespace See Also
Collapse All
C#
public Boolean CreateNewObject;
Remarks

This is CreateNewObject, a member of class TraceFlags.

See Also
TraceFlags Class
TraceFlags Members
DroopyEyes.EcoExtensions.CacheFiltering Namespace


TraceFlags.DestroyObject Property

TraceFlags.DestroyObject Property
TraceFlags Class TraceFlags Members DroopyEyes.EcoExtensions.CacheFiltering Namespace See Also
Collapse All
C#
public Boolean DestroyObject;
Remarks

This is DestroyObject, a member of class TraceFlags.

See Also
TraceFlags Class
TraceFlags Members
DroopyEyes.EcoExtensions.CacheFiltering Namespace


TraceFlags.GetAllLocators Property

TraceFlags.GetAllLocators Property
TraceFlags Class TraceFlags Members DroopyEyes.EcoExtensions.CacheFiltering Namespace See Also
Collapse All
C#
public Boolean GetAllLocators;
Remarks

This is GetAllLocators, a member of class TraceFlags.

See Also
TraceFlags Class
TraceFlags Members
DroopyEyes.EcoExtensions.CacheFiltering Namespace


TraceFlags.GetCurrentOrderNo Property

TraceFlags.GetCurrentOrderNo Property
TraceFlags Class TraceFlags Members DroopyEyes.EcoExtensions.CacheFiltering Namespace See Also
Collapse All
C#
public Boolean GetCurrentOrderNo;
Remarks

This is GetCurrentOrderNo, a member of class TraceFlags.

See Also
TraceFlags Class
TraceFlags Members
DroopyEyes.EcoExtensions.CacheFiltering Namespace


TraceFlags.GetCurrentValue Property

TraceFlags.GetCurrentValue Property
TraceFlags Class TraceFlags Members DroopyEyes.EcoExtensions.CacheFiltering Namespace See Also
Collapse All
C#
public Boolean GetCurrentValue;
Remarks

This is GetCurrentValue, a member of class TraceFlags.

See Also
TraceFlags Class
TraceFlags Members
DroopyEyes.EcoExtensions.CacheFiltering Namespace


TraceFlags.GetEnsuredLocatorById Property

TraceFlags.GetEnsuredLocatorById Property
TraceFlags Class TraceFlags Members DroopyEyes.EcoExtensions.CacheFiltering Namespace See Also
Collapse All
C#
public Boolean GetEnsuredLocatorById;
Remarks

This is GetEnsuredLocatorById, a member of class TraceFlags.

See Also
TraceFlags Class
TraceFlags Members
DroopyEyes.EcoExtensions.CacheFiltering Namespace


TraceFlags.GetExistenceState Property

TraceFlags.GetExistenceState Property
TraceFlags Class TraceFlags Members DroopyEyes.EcoExtensions.CacheFiltering Namespace See Also
Collapse All
C#
public Boolean GetExistenceState;
Remarks

This is GetExistenceState, a member of class TraceFlags.

See Also
TraceFlags Class
TraceFlags Members
DroopyEyes.EcoExtensions.CacheFiltering Namespace


TraceFlags.GetFetchedValue Property

TraceFlags.GetFetchedValue Property
TraceFlags Class TraceFlags Members DroopyEyes.EcoExtensions.CacheFiltering Namespace See Also
Collapse All
C#
public Boolean GetFetchedValue;
Remarks

This is GetFetchedValue, a member of class TraceFlags.

See Also
TraceFlags Class
TraceFlags Members
DroopyEyes.EcoExtensions.CacheFiltering Namespace


TraceFlags.GetIdByLocator Property

TraceFlags.GetIdByLocator Property
TraceFlags Class TraceFlags Members DroopyEyes.EcoExtensions.CacheFiltering Namespace See Also
Collapse All
C#
public Boolean GetIdByLocator;
Remarks

This is GetIdByLocator, a member of class TraceFlags.

See Also
TraceFlags Class
TraceFlags Members
DroopyEyes.EcoExtensions.CacheFiltering Namespace


TraceFlags.GetLocatorById Property

TraceFlags.GetLocatorById Property
TraceFlags Class TraceFlags Members DroopyEyes.EcoExtensions.CacheFiltering Namespace See Also
Collapse All
C#
public Boolean GetLocatorById;
Remarks

This is GetLocatorById, a member of class TraceFlags.

See Also
TraceFlags Class
TraceFlags Members
DroopyEyes.EcoExtensions.CacheFiltering Namespace


TraceFlags.GetMemberPersistenceState Property

TraceFlags.GetMemberPersistenceState Property
TraceFlags Class TraceFlags Members DroopyEyes.EcoExtensions.CacheFiltering Namespace See Also
Collapse All
C#
public Boolean GetMemberPersistenceState;
Remarks

This is GetMemberPersistenceState, a member of class TraceFlags.

See Also
TraceFlags Class
TraceFlags Members
DroopyEyes.EcoExtensions.CacheFiltering Namespace


TraceFlags.GetPersistenceState Property

TraceFlags.GetPersistenceState Property
TraceFlags Class TraceFlags Members DroopyEyes.EcoExtensions.CacheFiltering Namespace See Also
Collapse All
C#
public Boolean GetPersistenceState;
Remarks

This is GetPersistenceState, a member of class TraceFlags.

See Also
TraceFlags Class
TraceFlags Members
DroopyEyes.EcoExtensions.CacheFiltering Namespace


TraceFlags.GetTimestamp Property

TraceFlags.GetTimestamp Property
TraceFlags Class TraceFlags Members DroopyEyes.EcoExtensions.CacheFiltering Namespace See Also
Collapse All
C#
public Boolean GetTimestamp;
Remarks

This is GetTimestamp, a member of class TraceFlags.

See Also
TraceFlags Class
TraceFlags Members
DroopyEyes.EcoExtensions.CacheFiltering Namespace


TraceFlags.GetUmlClass Property

TraceFlags.GetUmlClass Property
TraceFlags Class TraceFlags Members DroopyEyes.EcoExtensions.CacheFiltering Namespace See Also
Collapse All
C#
public Boolean GetUmlClass;
Remarks

This is GetUmlClass, a member of class TraceFlags.

See Also
TraceFlags Class
TraceFlags Members
DroopyEyes.EcoExtensions.CacheFiltering Namespace


TraceFlags.IsPersistent Property

TraceFlags.IsPersistent Property
TraceFlags Class TraceFlags Members DroopyEyes.EcoExtensions.CacheFiltering Namespace See Also
Collapse All
C#
public Boolean IsPersistent;
Remarks

This is IsPersistent, a member of class TraceFlags.

See Also
TraceFlags Class
TraceFlags Members
DroopyEyes.EcoExtensions.CacheFiltering Namespace


TraceFlags.SetCurrentAndFetchedOrderNo Property

TraceFlags.SetCurrentAndFetchedOrderNo Property
TraceFlags Class TraceFlags Members DroopyEyes.EcoExtensions.CacheFiltering Namespace See Also
Collapse All
C#
public Boolean SetCurrentAndFetchedOrderNo;
Remarks

This is SetCurrentAndFetchedOrderNo, a member of class TraceFlags.

See Also
TraceFlags Class
TraceFlags Members
DroopyEyes.EcoExtensions.CacheFiltering Namespace


TraceFlags.SetCurrentAndFetchedValue Property

TraceFlags.SetCurrentAndFetchedValue Property
TraceFlags Class TraceFlags Members DroopyEyes.EcoExtensions.CacheFiltering Namespace See Also
Collapse All
C#
public Boolean SetCurrentAndFetchedValue;
Remarks

This is SetCurrentAndFetchedValue, a member of class TraceFlags.

See Also
TraceFlags Class
TraceFlags Members
DroopyEyes.EcoExtensions.CacheFiltering Namespace


TraceFlags.SetCurrentOrderNo Property

TraceFlags.SetCurrentOrderNo Property
TraceFlags Class TraceFlags Members DroopyEyes.EcoExtensions.CacheFiltering Namespace See Also
Collapse All
C#
public Boolean SetCurrentOrderNo;
Remarks

This is SetCurrentOrderNo, a member of class TraceFlags.

See Also
TraceFlags Class
TraceFlags Members
DroopyEyes.EcoExtensions.CacheFiltering Namespace


TraceFlags.SetCurrentValue Property

TraceFlags.SetCurrentValue Property
TraceFlags Class TraceFlags Members DroopyEyes.EcoExtensions.CacheFiltering Namespace See Also
Collapse All
C#
public Boolean SetCurrentValue;
Remarks

This is SetCurrentValue, a member of class TraceFlags.

See Also
TraceFlags Class
TraceFlags Members
DroopyEyes.EcoExtensions.CacheFiltering Namespace


TraceFlags.SetExistenceState Property

TraceFlags.SetExistenceState Property
TraceFlags Class TraceFlags Members DroopyEyes.EcoExtensions.CacheFiltering Namespace See Also
Collapse All
C#
public Boolean SetExistenceState;
Remarks

This is SetExistenceState, a member of class TraceFlags.

See Also
TraceFlags Class
TraceFlags Members
DroopyEyes.EcoExtensions.CacheFiltering Namespace


TraceFlags.SetFetchedValue Property

TraceFlags.SetFetchedValue Property
TraceFlags Class TraceFlags Members DroopyEyes.EcoExtensions.CacheFiltering Namespace See Also
Collapse All
C#
public Boolean SetFetchedValue;
Remarks

This is SetFetchedValue, a member of class TraceFlags.

See Also
TraceFlags Class
TraceFlags Members
DroopyEyes.EcoExtensions.CacheFiltering Namespace


TraceFlags.SetMemberPersistenceState Property

TraceFlags.SetMemberPersistenceState Property
TraceFlags Class TraceFlags Members DroopyEyes.EcoExtensions.CacheFiltering Namespace See Also
Collapse All
C#
public Boolean SetMemberPersistenceState;
Remarks

This is SetMemberPersistenceState, a member of class TraceFlags.

See Also
TraceFlags Class
TraceFlags Members
DroopyEyes.EcoExtensions.CacheFiltering Namespace


TraceFlags.SetPersistenceState Property

TraceFlags.SetPersistenceState Property
TraceFlags Class TraceFlags Members DroopyEyes.EcoExtensions.CacheFiltering Namespace See Also
Collapse All
C#
public Boolean SetPersistenceState;
Remarks

This is SetPersistenceState, a member of class TraceFlags.

See Also
TraceFlags Class
TraceFlags Members
DroopyEyes.EcoExtensions.CacheFiltering Namespace


TraceFlags.SetTimestamp Property

TraceFlags.SetTimestamp Property
TraceFlags Class TraceFlags Members DroopyEyes.EcoExtensions.CacheFiltering Namespace See Also
Collapse All
C#
public Boolean SetTimestamp;
Remarks

This is SetTimestamp, a member of class TraceFlags.

See Also
TraceFlags Class
TraceFlags Members
DroopyEyes.EcoExtensions.CacheFiltering Namespace


ICacheFilter Interface

ICacheFilter Interface
ICacheFilter Members Inheritance Hierarchy See Also
Collapse All

This interface should be supported by all components which have been designed to be inserted into the CacheFilters property of the EcoCacheFilterPlugin component.

C#
public interface ICacheFilter : ICache;
Inheritance Hierarchy
DroopyEyes.EcoExtensions.CacheFiltering.ICacheFilter
    DroopyEyes.EcoExtensions.CacheFiltering.EcoCacheTraceFilter
File

ICacheFilter.cs

See Also
ICacheFilter Members
Inheritance Hierarchy


ICacheFilter Members

ICacheFilter Members
Public Properties
Collapse All

The following tables list the members exposed by ICacheFilter.

Public Properties
Name | Description
NextCache | Holds a reference to the next ICache in the chain.


ICacheFilter Properties

ICacheFilter Properties
Public Properties
Collapse All

The properties of the ICacheFilter class are listed here.

Public Properties
Name | Description
NextCache | Holds a reference to the next ICache in the chain.


ICacheFilter.NextCache Property

ICacheFilter.NextCache Property
ICacheFilter Interface ICacheFilter Members DroopyEyes.EcoExtensions.CacheFiltering Namespace See Also
Collapse All

Holds a reference to the next ICache in the chain.

C#
ICache NextCache;
See Also
ICacheFilter Interface
ICacheFilter Members
DroopyEyes.EcoExtensions.CacheFiltering Namespace


DroopyEyes.EcoExtensions.Core Namespace

DroopyEyes.EcoExtensions.Core Namespace
Classes
Collapse All

This is namespace DroopyEyes.EcoExtensions.Core.

Classes
Name | Description
Subscriber | This class introduces a simple way to create an ISubscriber without having to subclass SubscriberAdapterBase


Subscriber Class

Subscriber Class
Subscriber Members Inheritance Hierarchy See Also
Collapse All

This class introduces a simple way to create an ISubscriber without having to subclass SubscriberAdapterBase

C#
public class Subscriber : System.Object;
Inheritance Hierarchy
DroopyEyes.EcoExtensions.Core.Subscriber
File

Subscriber.cs

See Also
Subscriber Members
Inheritance Hierarchy


Subscriber Members

Subscriber Members
Protected Methods Public Methods Public Events
Collapse All

The following tables list the members exposed by Subscriber.

Protected Methods
Name | Description
OnReceive | This method is executed whenever the subject needs to notify the observer
Top
Public Methods
Name | Description
AsISubscriber | Returns an ISubscriber instance which should be used when placing subscriptions
CancelAllSubscriptions | Cancels all placed subscriptions
Subscriber | Constructs a new instance of the class
Top
Public Events
Name | Description
Receive | This event is triggered whenever a subscription notification is received


Subscriber.Subscriber Constructor

Subscriber.Subscriber Constructor
Subscriber Class Subscriber Members DroopyEyes.EcoExtensions.Core Namespace See Also
Collapse All

Constructs a new instance of the class

C#
public Subscriber();
See Also
Subscriber Class
Subscriber Members
DroopyEyes.EcoExtensions.Core Namespace


Subscriber Methods

Subscriber Methods
Protected Methods Public Methods
Collapse All

The methods of the Subscriber class are listed here.

Protected Methods
Name | Description
OnReceive | This method is executed whenever the subject needs to notify the observer
Top
Public Methods
Name | Description
AsISubscriber | Returns an ISubscriber instance which should be used when placing subscriptions
CancelAllSubscriptions | Cancels all placed subscriptions


Subscriber.AsISubscriber Method

Subscriber.AsISubscriber Method
Subscriber Class Subscriber Members DroopyEyes.EcoExtensions.Core Namespace See Also
Collapse All

Returns an ISubscriber instance which should be used when placing subscriptions

C#
public ISubscriber AsISubscriber();
See Also
Subscriber Class
Subscriber Members
DroopyEyes.EcoExtensions.Core Namespace


Subscriber.CancelAllSubscriptions Method

Subscriber.CancelAllSubscriptions Method
Subscriber Class Subscriber Members DroopyEyes.EcoExtensions.Core Namespace See Also
Collapse All

Cancels all placed subscriptions

C#
public void CancelAllSubscriptions();
See Also
Subscriber Class
Subscriber Members
DroopyEyes.EcoExtensions.Core Namespace


Subscriber.OnReceive Method

Subscriber.OnReceive Method
Subscriber Class Subscriber Members DroopyEyes.EcoExtensions.Core Namespace See Also
Collapse All

This method is executed whenever the subject needs to notify the observer

C#
protected virtual void OnReceive(
    object sender,
    System.EventArgs e
);
See Also
Subscriber Class
Subscriber Members
DroopyEyes.EcoExtensions.Core Namespace


Subscriber Events

Subscriber Events
Public Events
Collapse All

The events of the Subscriber class are listed here.

Public Events
Name | Description
Receive | This event is triggered whenever a subscription notification is received


Subscriber.Receive Event

Subscriber.Receive Event
Subscriber Class Subscriber Members DroopyEyes.EcoExtensions.Core Namespace See Also
Collapse All

This event is triggered whenever a subscription notification is received

C#
public event System.EventHandler Receive;
See Also
Subscriber Class
Subscriber Members
DroopyEyes.EcoExtensions.Core Namespace


DroopyEyes.EcoExtensions.Services.XmlQueryService Namespace

DroopyEyes.EcoExtensions.Services.XmlQueryService Namespace
Classes Interfaces
Collapse All

This is namespace DroopyEyes.EcoExtensions.Services.XmlQueryService.

Classes
Name | Description
AttributeNodeProcessor | This node processes the <attribute> node.
CDataNodeProcessor | This node processes the <cdata> node.
ContextIsNotAListOfObjectsException | This exception is thrown when a node expects to be executed within the context of an IObjectList but is not.
EcoRootNodeProcessor | This node processes the <ecoRoot> node.
EcoRootObjectNodeProcessor | This node processes the <ecoRootObject> node.
ElementNodeProcessor | This node processes the <element> node.
ForEachNodeProcessor | This node processes the <forEach> node.
IfNodeProcessor | Provides if/then/else
InvalidExpressionException | This exception is thrown when an expression is passed in the XML query that returns an unexpected type.
MissingRootNodeException | This exception is thrown when the main <xmlQuery> root node is not found in the XML query.
RequiredAttributeMissingException | This exception is thrown when a required attribute for a node was not passed in the XML query.
SwitchNodeProcessor | This node processes the <switch> node and its embedded <case> and <defaultCase> nodes.
UnexpectedAttributeException | This exception is thrown when an unexpected attribute is encountered during the processing of a node in the XML query.
UnexpectedAttributeValueException | This exception is thrown when an attribute value is not one of a specific list of valid values.
UnknownNodeTypeException | This exception is thrown when a node is encountered in the XML Query that has no registered node processor.
ValueNodeProcessor | This node processes the <value> node.
XmlNodeProcessor | This is the base class from which all custom node processors must be descended. Node processors employ the flyweight design pattern, therefore only a single instance of the class is used during parsing. The same instances is expected to be able to process multiple nodes for a single request without having to rely on a saved state.
XmlQueryNodeProcessor | This class processes the main <xmlQuery> node of the XML query.
XmlQueryService | Implements the IXmlQueryService interface
XmlQueryServiceException | This exception class is the base of all exceptions thrown by the XmlQueryService. Any 3rd party node processor classes should ideally only throw exceptions descended from this exception class.
XmlQueryServiceExceptionThrower | This sealed class is a helper for throwing exceptions.
Top
Interfaces
Name | Description
IXmlQueryService | Interface used to access the XmlQueryService


AttributeNodeProcessor Class

AttributeNodeProcessor Class
AttributeNodeProcessor Members Inheritance Hierarchy See Also
Collapse All

This node processes the <attribute> node.

C#
public class AttributeNodeProcessor : XmlNodeProcessor;
Inheritance Hierarchy
DroopyEyes.EcoExtensions.Services.XmlQueryService.XmlNodeProcessor
    DroopyEyes.EcoExtensions.Services.XmlQueryService.AttributeNodeProcessor
File

NodeProcessors.cs

See Also
AttributeNodeProcessor Members
Inheritance Hierarchy


AttributeNodeProcessor Members

AttributeNodeProcessor Members
Protected Methods Public Properties Protected Properties
Collapse All

The following tables list the members exposed by AttributeNodeProcessor.

Protected Methods
Name | Description
AfterProcessNode | This method is executed after the node processor has executed.
BeforeProcessNode | This method is executed before the node processor is expected to execute.
ProcessChildNodes | method will instruct the XmlQueryService to process all child nodes of the current XML node. The Context property should be updated before calling the base method if this node is required to change the context.
ProcessNode | Processes the node.
Top
Public Properties
Name | Description
XmlPath | Returns the full XML path of the XML query node that this node processor is currently processing.
XmlQueryService | A reference to XmlQueryService which owns this instance.
Top
Protected Properties
Name | Description
Context | The IElement on which the node processor should execute.
Node | The XML node within the XML query on which the node processor is expected to execute.
Response | The XmlTextWriter to which any output must be written.
ServiceProvider | A reference to the EcoSpace's service provider from which references to various ECO services may be obtained.


AttributeNodeProcessor Methods

AttributeNodeProcessor Methods
Protected Methods
Collapse All

The methods of the AttributeNodeProcessor class are listed here.

Protected Methods
Name | Description
ProcessNode | Processes the node.


AttributeNodeProcessor.ProcessNode Method

AttributeNodeProcessor.ProcessNode Method
AttributeNodeProcessor Class AttributeNodeProcessor Members DroopyEyes.EcoExtensions.Services.XmlQueryService Namespace See Also
Collapse All

Processes the node.

C#
protected override void ProcessNode();
See Also
AttributeNodeProcessor Class
AttributeNodeProcessor Members
DroopyEyes.EcoExtensions.Services.XmlQueryService Namespace


CDataNodeProcessor Class

CDataNodeProcessor Class
CDataNodeProcessor Members Inheritance Hierarchy See Also
Collapse All

This node processes the <cdata> node.

C#
public class CDataNodeProcessor : XmlNodeProcessor;
Inheritance Hierarchy
DroopyEyes.EcoExtensions.Services.XmlQueryService.XmlNodeProcessor
    DroopyEyes.EcoExtensions.Services.XmlQueryService.CDataNodeProcessor
File

NodeProcessors.cs

See Also
CDataNodeProcessor Members
Inheritance Hierarchy


CDataNodeProcessor Members

CDataNodeProcessor Members
Protected Methods Public Properties Protected Properties
Collapse All

The following tables list the members exposed by CDataNodeProcessor.

Protected Methods
Name | Description
AfterProcessNode | This method is executed after the node processor has executed.
BeforeProcessNode | This method is executed before the node processor is expected to execute.
ProcessChildNodes | method will instruct the XmlQueryService to process all child nodes of the current XML node. The Context property should be updated before calling the base method if this node is required to change the context.
ProcessNode | Processes the node.
Top
Public Properties
Name | Description
XmlPath | Returns the full XML path of the XML query node that this node processor is currently processing.
XmlQueryService | A reference to XmlQueryService which owns this instance.
Top
Protected Properties
Name | Description
Context | The IElement on which the node processor should execute.
Node | The XML node within the XML query on which the node processor is expected to execute.
Response | The XmlTextWriter to which any output must be written.
ServiceProvider | A reference to the EcoSpace's service provider from which references to various ECO services may be obtained.


CDataNodeProcessor Methods

CDataNodeProcessor Methods
Protected Methods
Collapse All

The methods of the CDataNodeProcessor class are listed here.

Protected Methods
Name | Description
ProcessNode | Processes the node.


CDataNodeProcessor.ProcessNode Method

CDataNodeProcessor.ProcessNode Method
CDataNodeProcessor Class CDataNodeProcessor Members DroopyEyes.EcoExtensions.Services.XmlQueryService Namespace See Also
Collapse All

Processes the node.

C#
protected override void ProcessNode();
See Also
CDataNodeProcessor Class
CDataNodeProcessor Members
DroopyEyes.EcoExtensions.Services.XmlQueryService Namespace


ContextIsNotAListOfObjectsException Class

ContextIsNotAListOfObjectsException Class
ContextIsNotAListOfObjectsException Members Inheritance Hierarchy See Also
Collapse All

This exception is thrown when a node expects to be executed within the context of an IObjectList but is not.

C#
public class ContextIsNotAListOfObjectsException : XmlQueryServiceException;
Inheritance Hierarchy
DroopyEyes.EcoExtensions.Services.XmlQueryService.XmlQueryServiceException
    DroopyEyes.EcoExtensions.Services.XmlQueryService.ContextIsNotAListOfObjectsException
File

Exceptions.cs

See Also
ContextIsNotAListOfObjectsException Members
Inheritance Hierarchy


ContextIsNotAListOfObjectsException Members

ContextIsNotAListOfObjectsException Members
Public Methods Public Fields
Collapse All

The following tables list the members exposed by ContextIsNotAListOfObjectsException.

Public Methods
Name | Description
ContextIsNotAListOfObjectsException | Initializes a new instance of the exception with a reference to the node processor that threw the exception.
XmlQueryServiceException | This is the overview for the XmlQueryServiceException constructor overload.
Top
Public Fields
Name | Description
NodeProcessor | The NodeProcess that was processing when the exception was thrown, this allows the developer to obtain additional information such as the XmlPath.


ContextIsNotAListOfObjectsException.ContextIsNotAListOfObjectsException Constructor

ContextIsNotAListOfObjectsException.ContextIsNotAListOfObjectsException Constructor
ContextIsNotAListOfObjectsException Class ContextIsNotAListOfObjectsException Members DroopyEyes.EcoExtensions.Services.XmlQueryService Namespace See Also
Collapse All

Initializes a new instance of the exception with a reference to the node processor that threw the exception.

C#
public ContextIsNotAListOfObjectsException(
    XmlNodeProcessor nodeProcessor
);
Parameters
Parameters | Description
nodeProcessor | A reference to the node processor that threw the exception.
See Also
ContextIsNotAListOfObjectsException Class
ContextIsNotAListOfObjectsException Members
DroopyEyes.EcoExtensions.Services.XmlQueryService Namespace


EcoRootNodeProcessor Class

EcoRootNodeProcessor Class
EcoRootNodeProcessor Members Inheritance Hierarchy See Also
Collapse All

This node processes the <ecoRoot> node.

C#
public class EcoRootNodeProcessor : XmlNodeProcessor;
Inheritance Hierarchy
DroopyEyes.EcoExtensions.Services.XmlQueryService.XmlNodeProcessor
    DroopyEyes.EcoExtensions.Services.XmlQueryService.EcoRootNodeProcessor
File

NodeProcessors.cs

See Also
EcoRootNodeProcessor Members
Inheritance Hierarchy


EcoRootNodeProcessor Members

EcoRootNodeProcessor Members
Protected Methods Public Properties Protected Properties
Collapse All

The following tables list the members exposed by EcoRootNodeProcessor.

Protected Methods
Name | Description
AfterProcessNode | This method is executed after the node processor has executed.
BeforeProcessNode | This method is executed before the node processor is expected to execute.
ProcessChildNodes | method will instruct the XmlQueryService to process all child nodes of the current XML node. The Context property should be updated before calling the base method if this node is required to change the context.
ProcessNode | Processes the node.
Top
Public Properties
Name | Description
XmlPath | Returns the full XML path of the XML query node that this node processor is currently processing.
XmlQueryService | A reference to XmlQueryService which owns this instance.
Top
Protected Properties
Name | Description
Context | The IElement on which the node processor should execute.
Node | The XML node within the XML query on which the node processor is expected to execute.
Response | The XmlTextWriter to which any output must be written.
ServiceProvider | A reference to the EcoSpace's service provider from which references to various ECO services may be obtained.


EcoRootNodeProcessor Methods

EcoRootNodeProcessor Methods
Protected Methods
Collapse All

The methods of the EcoRootNodeProcessor class are listed here.

Protected Methods
Name | Description
ProcessNode | Processes the node.


EcoRootNodeProcessor.ProcessNode Method

EcoRootNodeProcessor.ProcessNode Method
EcoRootNodeProcessor Class EcoRootNodeProcessor Members DroopyEyes.EcoExtensions.Services.XmlQueryService Namespace See Also
Collapse All

Processes the node.

C#
protected override void ProcessNode();
See Also
EcoRootNodeProcessor Class
EcoRootNodeProcessor Members
DroopyEyes.EcoExtensions.Services.XmlQueryService Namespace


EcoRootObjectNodeProcessor Class

EcoRootObjectNodeProcessor Class
EcoRootObjectNodeProcessor Members Inheritance Hierarchy See Also
Collapse All

This node processes the <ecoRootObject> node.

C#
public class EcoRootObjectNodeProcessor : XmlNodeProcessor;
Inheritance Hierarchy
DroopyEyes.EcoExtensions.Services.XmlQueryService.XmlNodeProcessor
    DroopyEyes.EcoExtensions.Services.XmlQueryService.EcoRootObjectNodeProcessor
File

NodeProcessors.cs

See Also
EcoRootObjectNodeProcessor Members
Inheritance Hierarchy


EcoRootObjectNodeProcessor Members

EcoRootObjectNodeProcessor Members
Protected Methods Public Properties Protected Properties
Collapse All

The following tables list the members exposed by EcoRootObjectNodeProcessor.

Protected Methods
Name | Description
AfterProcessNode | This method is executed after the node processor has executed.
BeforeProcessNode | This method is executed before the node processor is expected to execute.
ProcessChildNodes | method will instruct the XmlQueryService to process all child nodes of the current XML node. The Context property should be updated before calling the base method if this node is required to change the context.
ProcessNode | Processes the node.
Top
Public Properties
Name | Description
XmlPath | Returns the full XML path of the XML query node that this node processor is currently processing.
XmlQueryService | A reference to XmlQueryService which owns this instance.
Top
Protected Properties
Name | Description
Context | The IElement on which the node processor should execute.
Node | The XML node within the XML query on which the node processor is expected to execute.
Response | The XmlTextWriter to which any output must be written.
ServiceProvider | A reference to the EcoSpace's service provider from which references to various ECO services may be obtained.


EcoRootObjectNodeProcessor Methods

EcoRootObjectNodeProcessor Methods
Protected Methods
Collapse All

The methods of the EcoRootObjectNodeProcessor class are listed here.

Protected Methods
Name | Description
ProcessNode | Processes the node.


EcoRootObjectNodeProcessor.ProcessNode Method

EcoRootObjectNodeProcessor.ProcessNode Method
EcoRootObjectNodeProcessor Class EcoRootObjectNodeProcessor Members DroopyEyes.EcoExtensions.Services.XmlQueryService Namespace See Also
Collapse All

Processes the node.

C#
protected override void ProcessNode();
See Also
EcoRootObjectNodeProcessor Class
EcoRootObjectNodeProcessor Members
DroopyEyes.EcoExtensions.Services.XmlQueryService Namespace


ElementNodeProcessor Class

ElementNodeProcessor Class
ElementNodeProcessor Members Inheritance Hierarchy See Also
Collapse All

This node processes the <element> node.

C#
public class ElementNodeProcessor : XmlNodeProcessor;
Inheritance Hierarchy
DroopyEyes.EcoExtensions.Services.XmlQueryService.XmlNodeProcessor
    DroopyEyes.EcoExtensions.Services.XmlQueryService.ElementNodeProcessor
File

NodeProcessors.cs

See Also
ElementNodeProcessor Members
Inheritance Hierarchy


ElementNodeProcessor Members

ElementNodeProcessor Members
Protected Methods Public Properties Protected Properties
Collapse All

The following tables list the members exposed by ElementNodeProcessor.

Protected Methods
Name | Description
AfterProcessNode | Executed after the node is processed.
BeforeProcessNode | Executed before the node is processed.
ProcessChildNodes | method will instruct the XmlQueryService to process all child nodes of the current XML node. The Context property should be updated before calling the base method if this node is required to change the context.
ProcessNode | This method may be overridden in order to process the XML node and produce output. By default this method will execute the ProcessChildNodes method.
Top
Public Properties
Name | Description
XmlPath | Returns the full XML path of the XML query node that this node processor is currently processing.
XmlQueryService | A reference to XmlQueryService which owns this instance.
Top
Protected Properties
Name | Description
Context | The IElement on which the node processor should execute.
Node | The XML node within the XML query on which the node processor is expected to execute.
Response | The XmlTextWriter to which any output must be written.
ServiceProvider | A reference to the EcoSpace's service provider from which references to various ECO services may be obtained.


ElementNodeProcessor Methods

ElementNodeProcessor Methods
Protected Methods
Collapse All

The methods of the ElementNodeProcessor class are listed here.

Protected Methods
Name | Description
AfterProcessNode | Executed after the node is processed.
BeforeProcessNode | Executed before the node is processed.


ElementNodeProcessor.AfterProcessNode Method

ElementNodeProcessor.AfterProcessNode Method
ElementNodeProcessor Class ElementNodeProcessor Members DroopyEyes.EcoExtensions.Services.XmlQueryService Namespace See Also
Collapse All

Executed after the node is processed.

C#
protected override void AfterProcessNode();
See Also
ElementNodeProcessor Class
ElementNodeProcessor Members
DroopyEyes.EcoExtensions.Services.XmlQueryService Namespace


ElementNodeProcessor.BeforeProcessNode Method

ElementNodeProcessor.BeforeProcessNode Method
ElementNodeProcessor Class ElementNodeProcessor Members DroopyEyes.EcoExtensions.Services.XmlQueryService Namespace See Also
Collapse All

Executed before the node is processed.

C#
protected override void BeforeProcessNode();
See Also
ElementNodeProcessor Class
ElementNodeProcessor Members
DroopyEyes.EcoExtensions.Services.XmlQueryService Namespace


ForEachNodeProcessor Class

ForEachNodeProcessor Class
ForEachNodeProcessor Members Inheritance Hierarchy See Also
Collapse All

This node processes the <forEach> node.

C#
public class ForEachNodeProcessor : XmlNodeProcessor;
Inheritance Hierarchy
DroopyEyes.EcoExtensions.Services.XmlQueryService.XmlNodeProcessor
    DroopyEyes.EcoExtensions.Services.XmlQueryService.ForEachNodeProcessor
File

NodeProcessors.cs

See Also
ForEachNodeProcessor Members
Inheritance Hierarchy


ForEachNodeProcessor Members

ForEachNodeProcessor Members
Protected Methods Public Properties Protected Properties
Collapse All

The following tables list the members exposed by ForEachNodeProcessor.

Protected Methods
Name | Description
AfterProcessNode | This method is executed after the node processor has executed.
BeforeProcessNode | This method is executed before the node processor is expected to execute.
ProcessChildNodes | method will instruct the XmlQueryService to process all child nodes of the current XML node. The Context property should be updated before calling the base method if this node is required to change the context.
ProcessNode | Processes the node.
Top
Public Properties
Name | Description
XmlPath | Returns the full XML path of the XML query node that this node processor is currently processing.
XmlQueryService | A reference to XmlQueryService which owns this instance.
Top
Protected Properties
Name | Description
Context | The IElement on which the node processor should execute.
Node | The XML node within the XML query on which the node processor is expected to execute.
Response | The XmlTextWriter to which any output must be written.
ServiceProvider | A reference to the EcoSpace's service provider from which references to various ECO services may be obtained.


ForEachNodeProcessor Methods

ForEachNodeProcessor Methods
Protected Methods
Collapse All

The methods of the ForEachNodeProcessor class are listed here.

Protected Methods
Name | Description
ProcessNode | Processes the node.


ForEachNodeProcessor.ProcessNode Method

ForEachNodeProcessor.ProcessNode Method
ForEachNodeProcessor Class ForEachNodeProcessor Members DroopyEyes.EcoExtensions.Services.XmlQueryService Namespace See Also
Collapse All

Processes the node.

C#
protected override void ProcessNode();
See Also
ForEachNodeProcessor Class
ForEachNodeProcessor Members
DroopyEyes.EcoExtensions.Services.XmlQueryService Namespace


IfNodeProcessor Class

IfNodeProcessor Class
IfNodeProcessor Members Inheritance Hierarchy See Also
Collapse All

Provides if/then/else

C#
public class IfNodeProcessor : XmlNodeProcessor;
Inheritance Hierarchy
DroopyEyes.EcoExtensions.Services.XmlQueryService.XmlNodeProcessor
    DroopyEyes.EcoExtensions.Services.XmlQueryService.IfNodeProcessor
File

NodeProcessors.cs

See Also
IfNodeProcessor Members
Inheritance Hierarchy


IfNodeProcessor Members

IfNodeProcessor Members
Protected Methods Public Properties Protected Properties
Collapse All

The following tables list the members exposed by IfNodeProcessor.

Protected Methods
Name | Description
AfterProcessNode | This method is executed after the node processor has executed.
BeforeProcessNode | This method is executed before the node processor is expected to execute.
ProcessChildNodes | method will instruct the XmlQueryService to process all child nodes of the current XML node. The Context property should be updated before calling the base method if this node is required to change the context.
ProcessNode | Processes the node.
Top
Public Properties
Name | Description
XmlPath | Returns the full XML path of the XML query node that this node processor is currently processing.
XmlQueryService | A reference to XmlQueryService which owns this instance.
Top
Protected Properties
Name | Description
Context | The IElement on which the node processor should execute.
Node | The XML node within the XML query on which the node processor is expected to execute.
Response | The XmlTextWriter to which any output must be written.
ServiceProvider | A reference to the EcoSpace's service provider from which references to various ECO services may be obtained.


IfNodeProcessor Methods

IfNodeProcessor Methods
Protected Methods
Collapse All

The methods of the IfNodeProcessor class are listed here.

Protected Methods
Name | Description
ProcessNode | Processes the node.


IfNodeProcessor.ProcessNode Method

IfNodeProcessor.ProcessNode Method
IfNodeProcessor Class IfNodeProcessor Members DroopyEyes.EcoExtensions.Services.XmlQueryService Namespace See Also
Collapse All

Processes the node.

C#
protected override void ProcessNode();
See Also
IfNodeProcessor Class
IfNodeProcessor Members
DroopyEyes.EcoExtensions.Services.XmlQueryService Namespace


InvalidExpressionException Class

InvalidExpressionException Class
InvalidExpressionException Members Inheritance Hierarchy See Also
Collapse All

This exception is thrown when an expression is passed in the XML query that returns an unexpected type.

C#
public class InvalidExpressionException : XmlQueryServiceException;
Inheritance Hierarchy
DroopyEyes.EcoExtensions.Services.XmlQueryService.XmlQueryServiceException
    DroopyEyes.EcoExtensions.Services.XmlQueryService.InvalidExpressionException
File

Exceptions.cs

See Also
InvalidExpressionException Members
Inheritance Hierarchy


InvalidExpressionException Members

InvalidExpressionException Members
Public Methods Public Fields
Collapse All

The following tables list the members exposed by InvalidExpressionException.

Public Methods
Name | Description
InvalidExpressionException | Initializes a new instance of the exception with a reference to the node processor that threw the exception and a description of the error.
XmlQueryServiceException | This is the overview for the XmlQueryServiceException constructor overload.
Top
Public Fields
Name | Description
NodeProcessor | The NodeProcess that was processing when the exception was thrown, this allows the developer to obtain additional information such as the XmlPath.


InvalidExpressionException.InvalidExpressionException Constructor

InvalidExpressionException.InvalidExpressionException Constructor
InvalidExpressionException Class InvalidExpressionException Members DroopyEyes.EcoExtensions.Services.XmlQueryService Namespace See Also
Collapse All

Initializes a new instance of the exception with a reference to the node processor that threw the exception and a description of the error.

C#
public InvalidExpressionException(
    XmlNodeProcessor nodeProcessor,
    string message
);
Parameters
Parameters | Description
nodeProcessor | A reference to the node processor that threw the exception.
message | A description of the error.
See Also
InvalidExpressionException Class
InvalidExpressionException Members
DroopyEyes.EcoExtensions.Services.XmlQueryService Namespace


MissingRootNodeException Class

MissingRootNodeException Class
MissingRootNodeException Members Inheritance Hierarchy See Also
Collapse All

This exception is thrown when the main <xmlQuery> root node is not found in the XML query.

C#
public class MissingRootNodeException : XmlQueryServiceException;
Inheritance Hierarchy
DroopyEyes.EcoExtensions.Services.XmlQueryService.XmlQueryServiceException
    DroopyEyes.EcoExtensions.Services.XmlQueryService.MissingRootNodeException
File

Exceptions.cs

See Also
MissingRootNodeException Members
Inheritance Hierarchy


MissingRootNodeException Members

MissingRootNodeException Members
Public Methods Public Fields
Collapse All

The following tables list the members exposed by MissingRootNodeException.

Public Methods
Name | Description
MissingRootNodeException | Initializes a new instance of the exception.
XmlQueryServiceException | This is the overview for the XmlQueryServiceException constructor overload.
Top
Public Fields
Name | Description
NodeProcessor | The NodeProcess that was processing when the exception was thrown, this allows the developer to obtain additional information such as the XmlPath.


MissingRootNodeException.MissingRootNodeException Constructor

MissingRootNodeException.MissingRootNodeException Constructor
MissingRootNodeException Class MissingRootNodeException Members DroopyEyes.EcoExtensions.Services.XmlQueryService Namespace See Also
Collapse All

Initializes a new instance of the exception.

C#
public MissingRootNodeException();
See Also
MissingRootNodeException Class
MissingRootNodeException Members
DroopyEyes.EcoExtensions.Services.XmlQueryService Namespace


RequiredAttributeMissingException Class

RequiredAttributeMissingException Class
RequiredAttributeMissingException Members Inheritance Hierarchy See Also
Collapse All

This exception is thrown when a required attribute for a node was not passed in the XML query.

C#
public class RequiredAttributeMissingException : XmlQueryServiceException;
Inheritance Hierarchy
DroopyEyes.EcoExtensions.Services.XmlQueryService.XmlQueryServiceException
    DroopyEyes.EcoExtensions.Services.XmlQueryService.RequiredAttributeMissingException
File

Exceptions.cs

See Also
RequiredAttributeMissingException Members
Inheritance Hierarchy


RequiredAttributeMissingException Members

RequiredAttributeMissingException Members
Public Methods Public Fields
Collapse All

The following tables list the members exposed by RequiredAttributeMissingException.

Public Methods
Name | Description
RequiredAttributeMissingException | Initializes a new instance of the exception with a reference to the node processor that threw the exception and the name of the missing attribute.
XmlQueryServiceException | This is the overview for the XmlQueryServiceException constructor overload.
Top
Public Fields
Name | Description
AttributeName | The name of the mandatory attribute that was not included in the XML query.
NodeProcessor | The NodeProcess that was processing when the exception was thrown, this allows the developer to obtain additional information such as the XmlPath.


RequiredAttributeMissingException.RequiredAttributeMissingException Constructor

RequiredAttributeMissingException.RequiredAttributeMissingException Constructor
RequiredAttributeMissingException Class RequiredAttributeMissingException Members DroopyEyes.EcoExtensions.Services.XmlQueryService Namespace See Also
Collapse All

Initializes a new instance of the exception with a reference to the node processor that threw the exception and the name of the missing attribute.

C#
public RequiredAttributeMissingException(
    XmlNodeProcessor nodeProcessor,
    string attributeName
);
Parameters
Parameters | Description
nodeProcessor | A reference to the node processor that threw the exception.
attributeName | The name of the missing attribute.
See Also
RequiredAttributeMissingException Class
RequiredAttributeMissingException Members
DroopyEyes.EcoExtensions.Services.XmlQueryService Namespace


RequiredAttributeMissingException Fields

RequiredAttributeMissingException Fields
Public Fields
Collapse All

The fields of the RequiredAttributeMissingException class are listed here.

Public Fields
Name | Description
AttributeName | The name of the mandatory attribute that was not included in the XML query.


RequiredAttributeMissingException.AttributeName Field

RequiredAttributeMissingException.AttributeName Field
RequiredAttributeMissingException Class RequiredAttributeMissingException Members DroopyEyes.EcoExtensions.Services.XmlQueryService Namespace See Also
Collapse All

The name of the mandatory attribute that was not included in the XML query.

C#
public readonly string AttributeName;
See Also
RequiredAttributeMissingException Class
RequiredAttributeMissingException Members
DroopyEyes.EcoExtensions.Services.XmlQueryService Namespace


SwitchNodeProcessor Class

SwitchNodeProcessor Class
SwitchNodeProcessor Members Inheritance Hierarchy See Also
Collapse All

This node processes the <switch> node and its embedded <case> and <defaultCase> nodes.

C#
public class SwitchNodeProcessor : XmlNodeProcessor;
Inheritance Hierarchy
DroopyEyes.EcoExtensions.Services.XmlQueryService.XmlNodeProcessor
    DroopyEyes.EcoExtensions.Services.XmlQueryService.SwitchNodeProcessor
File

NodeProcessors.cs

See Also
SwitchNodeProcessor Members
Inheritance Hierarchy


SwitchNodeProcessor Members

SwitchNodeProcessor Members
Protected Methods Public Properties Protected Properties
Collapse All

The following tables list the members exposed by SwitchNodeProcessor.

Protected Methods
Name | Description
AfterProcessNode | This method is executed after the node processor has executed.
BeforeProcessNode | This method is executed before the node processor is expected to execute.
ProcessChildNodes | method will instruct the XmlQueryService to process all child nodes of the current XML node. The Context property should be updated before calling the base method if this node is required to change the context.
ProcessNode | Processes the node.
Top
Public Properties
Name | Description
XmlPath | Returns the full XML path of the XML query node that this node processor is currently processing.
XmlQueryService | A reference to XmlQueryService which owns this instance.
Top
Protected Properties
Name | Description
Context | The IElement on which the node processor should execute.
Node | The XML node within the XML query on which the node processor is expected to execute.
Response | The XmlTextWriter to which any output must be written.
ServiceProvider | A reference to the EcoSpace's service provider from which references to various ECO services may be obtained.


SwitchNodeProcessor Methods

SwitchNodeProcessor Methods
Protected Methods
Collapse All

The methods of the SwitchNodeProcessor class are listed here.

Protected Methods
Name | Description
ProcessNode | Processes the node.


SwitchNodeProcessor.ProcessNode Method

SwitchNodeProcessor.ProcessNode Method
SwitchNodeProcessor Class SwitchNodeProcessor Members DroopyEyes.EcoExtensions.Services.XmlQueryService Namespace See Also
Collapse All

Processes the node.

C#
protected override void ProcessNode();
See Also
SwitchNodeProcessor Class
SwitchNodeProcessor Members
DroopyEyes.EcoExtensions.Services.XmlQueryService Namespace


UnexpectedAttributeException Class

UnexpectedAttributeException Class
UnexpectedAttributeException Members Inheritance Hierarchy See Also
Collapse All

This exception is thrown when an unexpected attribute is encountered during the processing of a node in the XML query.

C#
public class UnexpectedAttributeException : XmlQueryServiceException;
Inheritance Hierarchy
DroopyEyes.EcoExtensions.Services.XmlQueryService.XmlQueryServiceException
    DroopyEyes.EcoExtensions.Services.XmlQueryService.UnexpectedAttributeException
File

Exceptions.cs

See Also
UnexpectedAttributeException Members
Inheritance Hierarchy


UnexpectedAttributeException Members

UnexpectedAttributeException Members
Public Methods Public Fields
Collapse All

The following tables list the members exposed by UnexpectedAttributeException.

Public Methods
Name | Description
UnexpectedAttributeException | Initializes a new instance of the exception with a reference to the node processor that threw the exception and the name of the unexpected attribute.
XmlQueryServiceException | This is the overview for the XmlQueryServiceException constructor overload.
Top
Public Fields
Name | Description
AttributeName | The name of the unexpected attribute.
NodeProcessor | The NodeProcess that was processing when the exception was thrown, this allows the developer to obtain additional information such as the XmlPath.


UnexpectedAttributeException.UnexpectedAttributeException Constructor

UnexpectedAttributeException.UnexpectedAttributeException Constructor
UnexpectedAttributeException Class UnexpectedAttributeException Members DroopyEyes.EcoExtensions.Services.XmlQueryService Namespace See Also
Collapse All

Initializes a new instance of the exception with a reference to the node processor that threw the exception and the name of the unexpected attribute.

C#
public UnexpectedAttributeException(
    XmlNodeProcessor nodeProcessor,
    string attributeName
);
Parameters
Parameters | Description
nodeProcessor | A reference to the node processor that threw the exception.
attributeName | The name of the unexpected attribute.
See Also
UnexpectedAttributeException Class
UnexpectedAttributeException Members
DroopyEyes.EcoExtensions.Services.XmlQueryService Namespace


UnexpectedAttributeException Fields

UnexpectedAttributeException Fields
Public Fields
Collapse All

The fields of the UnexpectedAttributeException class are listed here.

Public Fields
Name | Description
AttributeName | The name of the unexpected attribute.


UnexpectedAttributeException.AttributeName Field

UnexpectedAttributeException.AttributeName Field
UnexpectedAttributeException Class UnexpectedAttributeException Members DroopyEyes.EcoExtensions.Services.XmlQueryService Namespace See Also
Collapse All

The name of the unexpected attribute.

C#
public readonly string AttributeName;
See Also
UnexpectedAttributeException Class
UnexpectedAttributeException Members
DroopyEyes.EcoExtensions.Services.XmlQueryService Namespace


UnexpectedAttributeValueException Class

UnexpectedAttributeValueException Class
UnexpectedAttributeValueException Members Inheritance Hierarchy See Also
Collapse All

This exception is thrown when an attribute value is not one of a specific list of valid values.

C#
public class UnexpectedAttributeValueException : XmlQueryServiceException;
Inheritance Hierarchy
DroopyEyes.EcoExtensions.Services.XmlQueryService.XmlQueryServiceException
    DroopyEyes.EcoExtensions.Services.XmlQueryService.UnexpectedAttributeValueException
File

Exceptions.cs

See Also
UnexpectedAttributeValueException Members
Inheritance Hierarchy


UnexpectedAttributeValueException Members

UnexpectedAttributeValueException Members
Public Methods Public Fields
Collapse All

The following tables list the members exposed by UnexpectedAttributeValueException.

Public Methods
Name | Description
UnexpectedAttributeValueException | Initializes a new instance of the exception with a reference to the node processor that threw the exception, the name of the attribute in question, the attribute value passed in the XML query, and a list of permissable values for the specified attribute.
XmlQueryServiceException | This is the overview for the XmlQueryServiceException constructor overload.
Top
Public Fields
Name | Description
AttributeName | The name of the unexpected attribute.
AttributeValue | The value passed for the specified attribute.
ExpectedValues | A list of permissable values.
NodeProcessor | The NodeProcess that was processing when the exception was thrown, this allows the developer to obtain additional information such as the XmlPath.


UnexpectedAttributeValueException.UnexpectedAttributeValueException Constructor

UnexpectedAttributeValueException.UnexpectedAttributeValueException Constructor
UnexpectedAttributeValueException Class UnexpectedAttributeValueException Members DroopyEyes.EcoExtensions.Services.XmlQueryService Namespace See Also
Collapse All

Initializes a new instance of the exception with a reference to the node processor that threw the exception, the name of the attribute in question, the attribute value passed in the XML query, and a list of permissable values for the specified attribute.

C#
public UnexpectedAttributeValueException(
    XmlNodeProcessor nodeProcessor,
    string attributeName,
    string attributeValue,
    string[] expectedValues
);
Parameters
Parameters | Description
nodeProcessor | A reference to the node processor that threw the exception.
attributeName | The name of the attribute in question.
attributeValue | The value passed in the XML query.
expectedValues | A list of permissable values for the specified attribute.
See Also
UnexpectedAttributeValueException Class
UnexpectedAttributeValueException Members
DroopyEyes.EcoExtensions.Services.XmlQueryService Namespace


UnexpectedAttributeValueException Fields

UnexpectedAttributeValueException Fields
Public Fields
Collapse All

The fields of the UnexpectedAttributeValueException class are listed here.

Public Fields
Name | Description
AttributeName | The name of the unexpected attribute.
AttributeValue | The value passed for the specified attribute.
ExpectedValues | A list of permissable values.


UnexpectedAttributeValueException.AttributeName Field

UnexpectedAttributeValueException.AttributeName Field
UnexpectedAttributeValueException Class UnexpectedAttributeValueException Members DroopyEyes.EcoExtensions.Services.XmlQueryService Namespace See Also
Collapse All

The name of the unexpected attribute.

C#
public readonly string AttributeName;
See Also
UnexpectedAttributeValueException Class
UnexpectedAttributeValueException Members
DroopyEyes.EcoExtensions.Services.XmlQueryService Namespace


UnexpectedAttributeValueException.AttributeValue Field

UnexpectedAttributeValueException.AttributeValue Field
UnexpectedAttributeValueException Class UnexpectedAttributeValueException Members DroopyEyes.EcoExtensions.Services.XmlQueryService Namespace See Also
Collapse All

The value passed for the specified attribute.

C#
public readonly string AttributeValue;
See Also
UnexpectedAttributeValueException Class
UnexpectedAttributeValueException Members
DroopyEyes.EcoExtensions.Services.XmlQueryService Namespace


UnexpectedAttributeValueException.ExpectedValues Field

UnexpectedAttributeValueException.ExpectedValues Field
UnexpectedAttributeValueException Class UnexpectedAttributeValueException Members DroopyEyes.EcoExtensions.Services.XmlQueryService Namespace See Also
Collapse All

A list of permissable values.

C#
public readonly string[] ExpectedValues;
See Also
UnexpectedAttributeValueException Class
UnexpectedAttributeValueException Members
DroopyEyes.EcoExtensions.Services.XmlQueryService Namespace


UnknownNodeTypeException Class

UnknownNodeTypeException Class
UnknownNodeTypeException Members Inheritance Hierarchy See Also
Collapse All

This exception is thrown when a node is encountered in the XML Query that has no registered node processor.

C#
public class UnknownNodeTypeException : XmlQueryServiceException;
Inheritance Hierarchy
DroopyEyes.EcoExtensions.Services.XmlQueryService.XmlQueryServiceException
    DroopyEyes.EcoExtensions.Services.XmlQueryService.UnknownNodeTypeException
File

Exceptions.cs

See Also
UnknownNodeTypeException Members
Inheritance Hierarchy


UnknownNodeTypeException Members

UnknownNodeTypeException Members
Public Methods Public Fields
Collapse All

The following tables list the members exposed by UnknownNodeTypeException.

Public Methods
Name | Description
UnknownNodeTypeException | Initializes a new instance of the exception with the name of the node for which there is no registered node processor.
XmlQueryServiceException | This is the overview for the XmlQueryServiceException constructor overload.
Top
Public Fields
Name | Description
NodeProcessor | The NodeProcess that was processing when the exception was thrown, this allows the developer to obtain additional information such as the XmlPath.
NodeType | The name of the node encountered within the XML query.


UnknownNodeTypeException.UnknownNodeTypeException Constructor

UnknownNodeTypeException.UnknownNodeTypeException Constructor
UnknownNodeTypeException Class UnknownNodeTypeException Members DroopyEyes.EcoExtensions.Services.XmlQueryService Namespace See Also
Collapse All

Initializes a new instance of the exception with the name of the node for which there is no registered node processor.

C#
public UnknownNodeTypeException(
    string nodeType
);
Parameters
Parameters | Description
nodeType | The name of the node for which there is no registered node processor.
See Also
UnknownNodeTypeException Class
UnknownNodeTypeException Members
DroopyEyes.EcoExtensions.Services.XmlQueryService Namespace


UnknownNodeTypeException Fields

UnknownNodeTypeException Fields
Public Fields
Collapse All

The fields of the UnknownNodeTypeException class are listed here.

Public Fields
Name | Description
NodeType | The name of the node encountered within the XML query.


UnknownNodeTypeException.NodeType Field

UnknownNodeTypeException.NodeType Field
UnknownNodeTypeException Class UnknownNodeTypeException Members DroopyEyes.EcoExtensions.Services.XmlQueryService Namespace See Also
Collapse All

The name of the node encountered within the XML query.

C#
public readonly string NodeType;
See Also
UnknownNodeTypeException Class
UnknownNodeTypeException Members
DroopyEyes.EcoExtensions.Services.XmlQueryService Namespace


ValueNodeProcessor Class

ValueNodeProcessor Class
ValueNodeProcessor Members Inheritance Hierarchy See Also
Collapse All

This node processes the <value> node.

C#
public class ValueNodeProcessor : XmlNodeProcessor;
Inheritance Hierarchy
DroopyEyes.EcoExtensions.Services.XmlQueryService.XmlNodeProcessor
    DroopyEyes.EcoExtensions.Services.XmlQueryService.ValueNodeProcessor
File

NodeProcessors.cs

See Also
ValueNodeProcessor Members
Inheritance Hierarchy


ValueNodeProcessor Members

ValueNodeProcessor Members
Protected Methods Public Properties Protected Properties
Collapse All

The following tables list the members exposed by ValueNodeProcessor.

Protected Methods
Name | Description
AfterProcessNode | This method is executed after the node processor has executed.
BeforeProcessNode | This method is executed before the node processor is expected to execute.
ProcessChildNodes | method will instruct the XmlQueryService to process all child nodes of the current XML node. The Context property should be updated before calling the base method if this node is required to change the context.
ProcessNode | Processes the node.
Top
Public Properties
Name | Description
XmlPath | Returns the full XML path of the XML query node that this node processor is currently processing.
XmlQueryService | A reference to XmlQueryService which owns this instance.
Top
Protected Properties
Name | Description
Context | The IElement on which the node processor should execute.
Node | The XML node within the XML query on which the node processor is expected to execute.
Response | The XmlTextWriter to which any output must be written.
ServiceProvider | A reference to the EcoSpace's service provider from which references to various ECO services may be obtained.


ValueNodeProcessor Methods

ValueNodeProcessor Methods
Protected Methods
Collapse All

The methods of the ValueNodeProcessor class are listed here.

Protected Methods
Name | Description
ProcessNode | Processes the node.


ValueNodeProcessor.ProcessNode Method

ValueNodeProcessor.ProcessNode Method
ValueNodeProcessor Class ValueNodeProcessor Members DroopyEyes.EcoExtensions.Services.XmlQueryService Namespace See Also
Collapse All

Processes the node.

C#
protected override void ProcessNode();
See Also
ValueNodeProcessor Class
ValueNodeProcessor Members
DroopyEyes.EcoExtensions.Services.XmlQueryService Namespace


XmlNodeProcessor Class

XmlNodeProcessor Class
XmlNodeProcessor Members Inheritance Hierarchy See Also
Collapse All

This is the base class from which all custom node processors must be descended. Node processors employ the flyweight design pattern, therefore only a single instance of the class is used during parsing. The same instances is expected to be able to process multiple nodes for a single request without having to rely on a saved state.

C#
public abstract class XmlNodeProcessor;
Inheritance Hierarchy
DroopyEyes.EcoExtensions.Services.XmlQueryService.XmlNodeProcessor
    DroopyEyes.EcoExtensions.Services.XmlQueryService.AttributeNodeProcessor
    DroopyEyes.EcoExtensions.Services.XmlQueryService.CDataNodeProcessor
    DroopyEyes.EcoExtensions.Services.XmlQueryService.EcoRootNodeProcessor
    DroopyEyes.EcoExtensions.Services.XmlQueryService.EcoRootObjectNodeProcessor
    DroopyEyes.EcoExtensions.Services.XmlQueryService.ElementNodeProcessor
    DroopyEyes.EcoExtensions.Services.XmlQueryService.ForEachNodeProcessor
    DroopyEyes.EcoExtensions.Services.XmlQueryService.IfNodeProcessor
    DroopyEyes.EcoExtensions.Services.XmlQueryService.SwitchNodeProcessor
    DroopyEyes.EcoExtensions.Services.XmlQueryService.ValueNodeProcessor
    DroopyEyes.EcoExtensions.Services.XmlQueryService.XmlQueryNodeProcessor
File

NodeProcessors.cs

See Also
XmlNodeProcessor Members
Inheritance Hierarchy


XmlNodeProcessor Members

XmlNodeProcessor Members
Protected Methods Public Properties Protected Properties
Collapse All

The following tables list the members exposed by XmlNodeProcessor.

Protected Methods
Name | Description
AfterProcessNode | This method is executed after the node processor has executed.
BeforeProcessNode | This method is executed before the node processor is expected to execute.
ProcessChildNodes | method will instruct the XmlQueryService to process all child nodes of the current XML node. The Context property should be updated before calling the base method if this node is required to change the context.
ProcessNode | This method may be overridden in order to process the XML node and produce output. By default this method will execute the ProcessChildNodes method.
Top
Public Properties
Name | Description
XmlPath | Returns the full XML path of the XML query node that this node processor is currently processing.
XmlQueryService | A reference to XmlQueryService which owns this instance.
Top
Protected Properties
Name | Description
Context | The IElement on which the node processor should execute.
Node | The XML node within the XML query on which the node processor is expected to execute.
Response | The XmlTextWriter to which any output must be written.
ServiceProvider | A reference to the EcoSpace's service provider from which references to various ECO services may be obtained.


XmlNodeProcessor Methods

XmlNodeProcessor Methods
Protected Methods
Collapse All

The methods of the XmlNodeProcessor class are listed here.

Protected Methods
Name | Description
AfterProcessNode | This method is executed after the node processor has executed.
BeforeProcessNode | This method is executed before the node processor is expected to execute.
ProcessChildNodes | method will instruct the XmlQueryService to process all child nodes of the current XML node. The Context property should be updated before calling the base method if this node is required to change the context.
ProcessNode | This method may be overridden in order to process the XML node and produce output. By default this method will execute the ProcessChildNodes method.


XmlNodeProcessor.AfterProcessNode Method

XmlNodeProcessor.AfterProcessNode Method
XmlNodeProcessor Class XmlNodeProcessor Members DroopyEyes.EcoExtensions.Services.XmlQueryService Namespace Related Topics See Also
Collapse All

This method is executed after the node processor has executed.

C#
protected virtual void AfterProcessNode();
Related Topics

BeforeProcessNode, AfterProcessNode

See Also
XmlNodeProcessor Class
XmlNodeProcessor Members
DroopyEyes.EcoExtensions.Services.XmlQueryService Namespace
Related Topics


XmlNodeProcessor.BeforeProcessNode Method

XmlNodeProcessor.BeforeProcessNode Method
XmlNodeProcessor Class XmlNodeProcessor Members DroopyEyes.EcoExtensions.Services.XmlQueryService Namespace Related Topics See Also
Collapse All

This method is executed before the node processor is expected to execute.

C#
protected virtual void BeforeProcessNode();
Related Topics

ProcessNode, AfterProcessNode

See Also
XmlNodeProcessor Class
XmlNodeProcessor Members
DroopyEyes.EcoExtensions.Services.XmlQueryService Namespace
Related Topics


XmlNodeProcessor.ProcessChildNodes Method

XmlNodeProcessor.ProcessChildNodes Method
XmlNodeProcessor Class XmlNodeProcessor Members DroopyEyes.EcoExtensions.Services.XmlQueryService Namespace See Also
Collapse All

method will instruct the XmlQueryService to process all child nodes of the current XML node. The Context property should be updated before calling the base method if this node is required to change the context.

C#
protected virtual void ProcessChildNodes(
    XmlNode node
);
See Also
XmlNodeProcessor Class
XmlNodeProcessor Members
DroopyEyes.EcoExtensions.Services.XmlQueryService Namespace


XmlNodeProcessor.ProcessNode Method

XmlNodeProcessor.ProcessNode Method
XmlNodeProcessor Class XmlNodeProcessor Members DroopyEyes.EcoExtensions.Services.XmlQueryService Namespace Related Topics See Also
Collapse All

This method may be overridden in order to process the XML node and produce output. By default this method will execute the ProcessChildNodes method.

C#
protected virtual void ProcessNode();
Related Topics

Context, BeforeProcessNode, AfterProcessNode, ProcessChildNodes

See Also
XmlNodeProcessor Class
XmlNodeProcessor Members
DroopyEyes.EcoExtensions.Services.XmlQueryService Namespace
Related Topics


XmlNodeProcessor Properties

XmlNodeProcessor Properties
Public Properties Protected Properties
Collapse All

The properties of the XmlNodeProcessor class are listed here.

Public Properties
Name | Description
XmlPath | Returns the full XML path of the XML query node that this node processor is currently processing.
XmlQueryService | A reference to XmlQueryService which owns this instance.
Top
Protected Properties
Name | Description
Context | The IElement on which the node processor should execute.
Node | The XML node within the XML query on which the node processor is expected to execute.
Response | The XmlTextWriter to which any output must be written.
ServiceProvider | A reference to the EcoSpace's service provider from which references to various ECO services may be obtained.


XmlNodeProcessor.Context Property

XmlNodeProcessor.Context Property
XmlNodeProcessor Class XmlNodeProcessor Members DroopyEyes.EcoExtensions.Services.XmlQueryService Namespace See Also
Collapse All

The IElement on which the node processor should execute.

C#
protected IElement Context;
See Also
XmlNodeProcessor Class
XmlNodeProcessor Members
DroopyEyes.EcoExtensions.Services.XmlQueryService Namespace


XmlNodeProcessor.Node Property

XmlNodeProcessor.Node Property
XmlNodeProcessor Class XmlNodeProcessor Members DroopyEyes.EcoExtensions.Services.XmlQueryService Namespace See Also
Collapse All

The XML node within the XML query on which the node processor is expected to execute.

C#
protected XmlNode Node;
See Also
XmlNodeProcessor Class
XmlNodeProcessor Members
DroopyEyes.EcoExtensions.Services.XmlQueryService Namespace


XmlNodeProcessor.Response Property

XmlNodeProcessor.Response Property
XmlNodeProcessor Class XmlNodeProcessor Members DroopyEyes.EcoExtensions.Services.XmlQueryService Namespace See Also
Collapse All

The XmlTextWriter to which any output must be written.

C#
protected XmlTextWriter Response;
See Also
XmlNodeProcessor Class
XmlNodeProcessor Members
DroopyEyes.EcoExtensions.Services.XmlQueryService Namespace


XmlNodeProcessor.ServiceProvider Property

XmlNodeProcessor.ServiceProvider Property
XmlNodeProcessor Class XmlNodeProcessor Members DroopyEyes.EcoExtensions.Services.XmlQueryService Namespace See Also
Collapse All

A reference to the EcoSpace's service provider from which references to various ECO services may be obtained.

C#
protected IEcoServiceProvider ServiceProvider;
See Also
XmlNodeProcessor Class
XmlNodeProcessor Members
DroopyEyes.EcoExtensions.Services.XmlQueryService Namespace


XmlNodeProcessor.XmlPath Property

XmlNodeProcessor.XmlPath Property
XmlNodeProcessor Class XmlNodeProcessor Members DroopyEyes.EcoExtensions.Services.XmlQueryService Namespace See Also
Collapse All

Returns the full XML path of the XML query node that this node processor is currently processing.

C#
public string XmlPath;
See Also
XmlNodeProcessor Class
XmlNodeProcessor Members
DroopyEyes.EcoExtensions.Services.XmlQueryService Namespace


XmlNodeProcessor.XmlQueryService Property

XmlNodeProcessor.XmlQueryService Property
XmlNodeProcessor Class XmlNodeProcessor Members DroopyEyes.EcoExtensions.Services.XmlQueryService Namespace See Also
Collapse All

A reference to XmlQueryService which owns this instance.

C#
public XmlQueryService XmlQueryService;
See Also
XmlNodeProcessor Class
XmlNodeProcessor Members
DroopyEyes.EcoExtensions.Services.XmlQueryService Namespace


XmlQueryNodeProcessor Class

XmlQueryNodeProcessor Class
XmlQueryNodeProcessor Members Inheritance Hierarchy See Also
Collapse All

This class processes the main <xmlQuery> node of the XML query.

C#
public class XmlQueryNodeProcessor : XmlNodeProcessor;
Inheritance Hierarchy
DroopyEyes.EcoExtensions.Services.XmlQueryService.XmlNodeProcessor
    DroopyEyes.EcoExtensions.Services.XmlQueryService.XmlQueryNodeProcessor
File

NodeProcessors.cs

See Also
XmlQueryNodeProcessor Members
Inheritance Hierarchy


XmlQueryNodeProcessor Members

XmlQueryNodeProcessor Members
Protected Methods Public Properties Protected Properties
Collapse All

The following tables list the members exposed by XmlQueryNodeProcessor.

Protected Methods
Name | Description
AfterProcessNode | Executed after the node is processed
BeforeProcessNode | Executed before the node is processed
ProcessChildNodes | method will instruct the XmlQueryService to process all child nodes of the current XML node. The Context property should be updated before calling the base method if this node is required to change the context.
ProcessNode | This method may be overridden in order to process the XML node and produce output. By default this method will execute the ProcessChildNodes method.
Top
Public Properties
Name | Description
XmlPath | Returns the full XML path of the XML query node that this node processor is currently processing.
XmlQueryService | A reference to XmlQueryService which owns this instance.
Top
Protected Properties
Name | Description
Context | The IElement on which the node processor should execute.
Node | The XML node within the XML query on which the node processor is expected to execute.
Response | The XmlTextWriter to which any output must be written.
ServiceProvider | A reference to the EcoSpace's service provider from which references to various ECO services may be obtained.


XmlQueryNodeProcessor Methods

XmlQueryNodeProcessor Methods
Protected Methods
Collapse All

The methods of the XmlQueryNodeProcessor class are listed here.

Protected Methods
Name | Description
AfterProcessNode | Executed after the node is processed
BeforeProcessNode | Executed before the node is processed


XmlQueryNodeProcessor.AfterProcessNode Method

XmlQueryNodeProcessor.AfterProcessNode Method
XmlQueryNodeProcessor Class XmlQueryNodeProcessor Members DroopyEyes.EcoExtensions.Services.XmlQueryService Namespace See Also
Collapse All

Executed after the node is processed

C#
protected override void AfterProcessNode();
See Also
XmlQueryNodeProcessor Class
XmlQueryNodeProcessor Members
DroopyEyes.EcoExtensions.Services.XmlQueryService Namespace


XmlQueryNodeProcessor.BeforeProcessNode Method

XmlQueryNodeProcessor.BeforeProcessNode Method
XmlQueryNodeProcessor Class XmlQueryNodeProcessor Members DroopyEyes.EcoExtensions.Services.XmlQueryService Namespace See Also
Collapse All

Executed before the node is processed

C#
protected override void BeforeProcessNode();
See Also
XmlQueryNodeProcessor Class
XmlQueryNodeProcessor Members
DroopyEyes.EcoExtensions.Services.XmlQueryService Namespace


XmlQueryService Class

XmlQueryService Class
XmlQueryService Members Inheritance Hierarchy See Also
Collapse All

Implements the IXmlQueryService interface

C#
public class XmlQueryService : IXmlQueryService;
Inheritance Hierarchy
DroopyEyes.EcoExtensions.Services.XmlQueryService.IXmlQueryService
    DroopyEyes.EcoExtensions.Services.XmlQueryService.XmlQueryService
File

XmlQueryService.cs

See Also
XmlQueryService Members
Inheritance Hierarchy


XmlQueryService Members

XmlQueryService Members
Public Methods
Collapse All

The following tables list the members exposed by XmlQueryService.

Public Methods
Name | Description
Execute | This method will transform the xmlQuery and return the resulting XML
GetNodeProcessor | This method will return the most recently registered node processor for the given node name.
RegisterNodeProcessor | This method will allows the developer to register processors for custom node types.
XmlQueryService | Initializes a new instance of the XmlQueryService


XmlQueryService.XmlQueryService Constructor

XmlQueryService.XmlQueryService Constructor
XmlQueryService Class XmlQueryService Members DroopyEyes.EcoExtensions.Services.XmlQueryService Namespace See Also
Collapse All

Initializes a new instance of the XmlQueryService

C#
public XmlQueryService(
    IEcoServiceProvider serviceProvider
);
Parameters
Parameters | Description
serviceProvider | A reference to the owning EcoSpace
See Also
XmlQueryService Class
XmlQueryService Members
DroopyEyes.EcoExtensions.Services.XmlQueryService Namespace


XmlQueryService Methods

XmlQueryService Methods
Public Methods
Collapse All

The methods of the XmlQueryService class are listed here.

Public Methods
Name | Description
Execute | This method will transform the xmlQuery and return the resulting XML
GetNodeProcessor | This method will return the most recently registered node processor for the given node name.
RegisterNodeProcessor | This method will allows the developer to register processors for custom node types.


XmlQueryService.Execute Method

XmlQueryService.Execute Method
XmlQueryService Class XmlQueryService Members DroopyEyes.EcoExtensions.Services.XmlQueryService Namespace See Also
Collapse All

This method will transform the xmlQuery and return the resulting XML

C#
public string Execute(
    string queryString
);
Parameters
Parameters | Description
queryString | The xml formatted query for the service to parse
Returns

Returns a string containing the parsed XML

See Also
XmlQueryService Class
XmlQueryService Members
DroopyEyes.EcoExtensions.Services.XmlQueryService Namespace


XmlQueryService.GetNodeProcessor Method

XmlQueryService.GetNodeProcessor Method
XmlQueryService Class XmlQueryService Members DroopyEyes.EcoExtensions.Services.XmlQueryService Namespace Related Topics See Also
Collapse All

This method will return the most recently registered node processor for the given node name.

C#
public XmlNodeProcessor GetNodeProcessor(
    string nodeName
);
Parameters
Parameters | Description
nodeName | The name of the node for which a node processor is required
Returns

Returns the instance of the XmlNodeProcessor registered to process nodes with the specified name.

Exceptions
Exceptions | Description
DroopyEyes.EcoExtensions.Services.XmlQueryService.XmlQueryServiceExceptionThrower.ThrowUnknownNodeTypeException | ThrowUnknownNodeTypeException
Related Topics

RegisterNodeProcessor, DroopyEyes.EcoExtensions.Services.XmlQueryService.XmlNodeProcessor

See Also
XmlQueryService Class
XmlQueryService Members
DroopyEyes.EcoExtensions.Services.XmlQueryService Namespace
Related Topics


XmlQueryService.RegisterNodeProcessor Method

XmlQueryService.RegisterNodeProcessor Method
XmlQueryService Class XmlQueryService Members DroopyEyes.EcoExtensions.Services.XmlQueryService Namespace Related Topics See Also
Collapse All

This method will allows the developer to register processors for custom node types.

C#
public void RegisterNodeProcessor(
    string nodeName,
    XmlNodeProcessor nodeProcessor
);
Parameters
Parameters | Description
nodeName | The name of the node exactly as it is expected to appear in the xml query string
nodeProcessor | An instance of an XmlNodeProcessor that will be used to process the specified node when it is encountered.
Related Topics

GetNodeProcessor, DroopyEyes.EcoExtensions.Services.XmlQueryService.XmlNodeProcessor

See Also
XmlQueryService Class
XmlQueryService Members
DroopyEyes.EcoExtensions.Services.XmlQueryService Namespace
Related Topics


XmlQueryServiceException Class

XmlQueryServiceException Class
XmlQueryServiceException Members Inheritance Hierarchy See Also
Collapse All

This exception class is the base of all exceptions thrown by the XmlQueryService. Any 3rd party node processor classes should ideally only throw exceptions descended from this exception class.

C#
public abstract class XmlQueryServiceException : System.Exception;
Inheritance Hierarchy
DroopyEyes.EcoExtensions.Services.XmlQueryService.XmlQueryServiceException
    DroopyEyes.EcoExtensions.Services.XmlQueryService.ContextIsNotAListOfObjectsException
    DroopyEyes.EcoExtensions.Services.XmlQueryService.InvalidExpressionException
    DroopyEyes.EcoExtensions.Services.XmlQueryService.MissingRootNodeException
    DroopyEyes.EcoExtensions.Services.XmlQueryService.RequiredAttributeMissingException
    DroopyEyes.EcoExtensions.Services.XmlQueryService.UnexpectedAttributeException
    DroopyEyes.EcoExtensions.Services.XmlQueryService.UnexpectedAttributeValueException
    DroopyEyes.EcoExtensions.Services.XmlQueryService.UnknownNodeTypeException
File

Exceptions.cs

See Also
XmlQueryServiceException Members
Inheritance Hierarchy


XmlQueryServiceException Members

XmlQueryServiceException Members
Public Methods Public Fields
Collapse All

The following tables list the members exposed by XmlQueryServiceException.

Public Methods
Name | Description
XmlQueryServiceException | This is the overview for the XmlQueryServiceException constructor overload.
Top
Public Fields
Name | Description
NodeProcessor | The NodeProcess that was processing when the exception was thrown, this allows the developer to obtain additional information such as the XmlPath.


XmlQueryServiceException Constructor

XmlQueryServiceException Constructor

This is the overview for the XmlQueryServiceException constructor overload.

Overload List
Name | Description
XmlQueryServiceException.XmlQueryServiceException (string) | Initializes a new instance of the class with a specific error message.
XmlQueryServiceException.XmlQueryServiceException (string, Exception) | Initializes a new instance of the class with a specific error message and a reference to the exception that initially caused this exception.
XmlQueryServiceException.XmlQueryServiceException (XmlNodeProcessor, string) | Initializes a new instance of the class with a specific error message and a reference to the node processor that threw the exception.
XmlQueryServiceException.XmlQueryServiceException (XmlNodeProcessor, string, Exception) | Initializes a new instance of the class with a specific error message, a reference to the node processor that threw the exception, and a reference to the node processor that threw the exception.


XmlQueryServiceException.XmlQueryServiceException Constructor (XmlNodeProcessor, string)

XmlQueryServiceException.XmlQueryServiceException Constructor (XmlNodeProcessor, string)
XmlQueryServiceException Class XmlQueryServiceException Members DroopyEyes.EcoExtensions.Services.XmlQueryService Namespace See Also
Collapse All

Initializes a new instance of the class with a specific error message and a reference to the node processor that threw the exception.

C#
public XmlQueryServiceException(
    XmlNodeProcessor nodeProcessor,
    string message
);
Parameters
Parameters | Description
nodeProcessor | A reference to the node processor that threw the exception.
message | The message that describes the error.
See Also
XmlQueryServiceException Class
XmlQueryServiceException Members
DroopyEyes.EcoExtensions.Services.XmlQueryService Namespace


XmlQueryServiceException.XmlQueryServiceException Constructor (XmlNodeProcessor, string, Exception)

XmlQueryServiceException.XmlQueryServiceException Constructor (XmlNodeProcessor, string, Exception)
XmlQueryServiceException Class XmlQueryServiceException Members DroopyEyes.EcoExtensions.Services.XmlQueryService Namespace See Also
Collapse All

Initializes a new instance of the class with a specific error message, a reference to the node processor that threw the exception, and a reference to the node processor that threw the exception.

C#
public XmlQueryServiceException(
    XmlNodeProcessor nodeProcessor,
    string message,
    Exception innerException
);
Parameters
Parameters | Description
nodeProcessor | A reference to the node processor that threw the exception.
message | The message that describes the error.
innerException | The exception that caused the current exception to be thrown. This may be a null reference.
See Also
XmlQueryServiceException Class
XmlQueryServiceException Members
DroopyEyes.EcoExtensions.Services.XmlQueryService Namespace


XmlQueryServiceException.XmlQueryServiceException Constructor (string)

XmlQueryServiceException.XmlQueryServiceException Constructor (string)
XmlQueryServiceException Class XmlQueryServiceException Members DroopyEyes.EcoExtensions.Services.XmlQueryService Namespace See Also
Collapse All

Initializes a new instance of the class with a specific error message.

C#
public XmlQueryServiceException(
    string message
);
Parameters
Parameters | Description
message | The message that describes the error.
See Also
XmlQueryServiceException Class
XmlQueryServiceException Members
DroopyEyes.EcoExtensions.Services.XmlQueryService Namespace


XmlQueryServiceException.XmlQueryServiceException Constructor (string, Exception)

XmlQueryServiceException.XmlQueryServiceException Constructor (string, Exception)
XmlQueryServiceException Class XmlQueryServiceException Members DroopyEyes.EcoExtensions.Services.XmlQueryService Namespace See Also
Collapse All

Initializes a new instance of the class with a specific error message and a reference to the exception that initially caused this exception.

C#
public XmlQueryServiceException(
    string message,
    Exception innerException
);
Parameters
Parameters | Description
message | The message that describes the error.
innerException | The exception that caused the current exception to be thrown. This may be a null reference.
See Also
XmlQueryServiceException Class
XmlQueryServiceException Members
DroopyEyes.EcoExtensions.Services.XmlQueryService Namespace


XmlQueryServiceException Fields

XmlQueryServiceException Fields
Public Fields
Collapse All

The fields of the XmlQueryServiceException class are listed here.

Public Fields
Name | Description
NodeProcessor | The NodeProcess that was processing when the exception was thrown, this allows the developer to obtain additional information such as the XmlPath.


XmlQueryServiceException.NodeProcessor Field

XmlQueryServiceException.NodeProcessor Field
XmlQueryServiceException Class XmlQueryServiceException Members DroopyEyes.EcoExtensions.Services.XmlQueryService Namespace See Also
Collapse All

The NodeProcess that was processing when the exception was thrown, this allows the developer to obtain additional information such as the XmlPath.

C#
public readonly XmlNodeProcessor NodeProcessor;
See Also
XmlQueryServiceException Class
XmlQueryServiceException Members
DroopyEyes.EcoExtensions.Services.XmlQueryService Namespace


XmlQueryServiceExceptionThrower Class

XmlQueryServiceExceptionThrower Class
XmlQueryServiceExceptionThrower Members Inheritance Hierarchy See Also
Collapse All

This sealed class is a helper for throwing exceptions.

C#
public sealed class XmlQueryServiceExceptionThrower;
Inheritance Hierarchy
DroopyEyes.EcoExtensions.Services.XmlQueryService.XmlQueryServiceExceptionThrower
File

Exceptions.cs

See Also
XmlQueryServiceExceptionThrower Members
Inheritance Hierarchy


XmlQueryServiceExceptionThrower Members

XmlQueryServiceExceptionThrower Members
Public Methods
Collapse All

The following tables list the members exposed by XmlQueryServiceExceptionThrower.

Public Methods
Name | Description
ThrowContextIsNotAListOfObjectsException | Throws an ContextIsNotAListOfObjectsException
ThrowInvalidExpressionException | Throws an InvalidExpressionException
ThrowMissingRootNodeException | Throws an MissingRootNodeException
ThrowRequiredAttributeMissingException | Throws an RequiredAttributeMissingException
ThrowUnexpectedAttributeException | Throws an UnexpectedAttributeException
ThrowUnexpectedAttributeValueException | Throws an UnexpectedAttributeValueException
ThrowUnknownNodeTypeException | Throws an UnknownNodeTypeException.


XmlQueryServiceExceptionThrower Methods

XmlQueryServiceExceptionThrower Methods
Public Methods
Collapse All

The methods of the XmlQueryServiceExceptionThrower class are listed here.

Public Methods
Name | Description
ThrowContextIsNotAListOfObjectsException | Throws an ContextIsNotAListOfObjectsException
ThrowInvalidExpressionException | Throws an InvalidExpressionException
ThrowMissingRootNodeException | Throws an MissingRootNodeException
ThrowRequiredAttributeMissingException | Throws an RequiredAttributeMissingException
ThrowUnexpectedAttributeException | Throws an UnexpectedAttributeException
ThrowUnexpectedAttributeValueException | Throws an UnexpectedAttributeValueException
ThrowUnknownNodeTypeException | Throws an UnknownNodeTypeException.


XmlQueryServiceExceptionThrower.ThrowContextIsNotAListOfObjectsException Method

XmlQueryServiceExceptionThrower.ThrowContextIsNotAListOfObjectsException Method
XmlQueryServiceExceptionThrower Class XmlQueryServiceExceptionThrower Members DroopyEyes.EcoExtensions.Services.XmlQueryService Namespace See Also
Collapse All

Throws an ContextIsNotAListOfObjectsException

C#
public static void ThrowContextIsNotAListOfObjectsException(
    XmlNodeProcessor nodeProcessor
);
Exceptions
Exceptions | Description
DroopyEyes.EcoExtensions.Services.XmlQueryService.ContextIsNotAListOfObjectsException | ContextIsNotAListOfObjectsException
See Also
XmlQueryServiceExceptionThrower Class
XmlQueryServiceExceptionThrower Members
DroopyEyes.EcoExtensions.Services.XmlQueryService Namespace


XmlQueryServiceExceptionThrower.ThrowInvalidExpressionException Method

XmlQueryServiceExceptionThrower.ThrowInvalidExpressionException Method
XmlQueryServiceExceptionThrower Class XmlQueryServiceExceptionThrower Members DroopyEyes.EcoExtensions.Services.XmlQueryService Namespace See Also
Collapse All

Throws an InvalidExpressionException

C#
public static void ThrowInvalidExpressionException(
    XmlNodeProcessor nodeProcessor,
    string message
);
Exceptions
Exceptions | Description
DroopyEyes.EcoExtensions.Services.XmlQueryService.InvalidExpressionException | InvalidExpressionException
See Also
XmlQueryServiceExceptionThrower Class
XmlQueryServiceExceptionThrower Members
DroopyEyes.EcoExtensions.Services.XmlQueryService Namespace


XmlQueryServiceExceptionThrower.ThrowMissingRootNodeException Method

XmlQueryServiceExceptionThrower.ThrowMissingRootNodeException Method
XmlQueryServiceExceptionThrower Class XmlQueryServiceExceptionThrower Members DroopyEyes.EcoExtensions.Services.XmlQueryService Namespace See Also
Collapse All

Throws an MissingRootNodeException

C#
public static void ThrowMissingRootNodeException();
Exceptions
Exceptions | Description
DroopyEyes.EcoExtensions.Services.XmlQueryService.MissingRootNodeException | MissingRootNodeException
See Also
XmlQueryServiceExceptionThrower Class
XmlQueryServiceExceptionThrower Members
DroopyEyes.EcoExtensions.Services.XmlQueryService Namespace


XmlQueryServiceExceptionThrower.ThrowRequiredAttributeMissingException Method

XmlQueryServiceExceptionThrower.ThrowRequiredAttributeMissingException Method
XmlQueryServiceExceptionThrower Class XmlQueryServiceExceptionThrower Members DroopyEyes.EcoExtensions.Services.XmlQueryService Namespace See Also
Collapse All

Throws an RequiredAttributeMissingException

C#
public static void ThrowRequiredAttributeMissingException(
    XmlNodeProcessor nodeProcessor,
    string attributeName
);
Exceptions
Exceptions | Description
DroopyEyes.EcoExtensions.Services.XmlQueryService.RequiredAttributeMissingException | RequiredAttributeMissingException
See Also
XmlQueryServiceExceptionThrower Class
XmlQueryServiceExceptionThrower Members
DroopyEyes.EcoExtensions.Services.XmlQueryService Namespace


XmlQueryServiceExceptionThrower.ThrowUnexpectedAttributeException Method

XmlQueryServiceExceptionThrower.ThrowUnexpectedAttributeException Method
XmlQueryServiceExceptionThrower Class XmlQueryServiceExceptionThrower Members DroopyEyes.EcoExtensions.Services.XmlQueryService Namespace See Also
Collapse All

Throws an UnexpectedAttributeException

C#
public static void ThrowUnexpectedAttributeException(
    XmlNodeProcessor nodeProcessor,
    string attributeName
);
Exceptions
Exceptions | Description
DroopyEyes.EcoExtensions.Services.XmlQueryService.UnexpectedAttributeException | UnexpectedAttributeException
See Also
XmlQueryServiceExceptionThrower Class
XmlQueryServiceExceptionThrower Members
DroopyEyes.EcoExtensions.Services.XmlQueryService Namespace


XmlQueryServiceExceptionThrower.ThrowUnexpectedAttributeValueException Method

XmlQueryServiceExceptionThrower.ThrowUnexpectedAttributeValueException Method
XmlQueryServiceExceptionThrower Class XmlQueryServiceExceptionThrower Members DroopyEyes.EcoExtensions.Services.XmlQueryService Namespace See Also
Collapse All

Throws an UnexpectedAttributeValueException

C#
public static void ThrowUnexpectedAttributeValueException(
    XmlNodeProcessor nodeProcessor,
    string attributeName,
    string attributeValue,
    string[] expectedValues
);
Exceptions
Exceptions | Description
DroopyEyes.EcoExtensions.Services.XmlQueryService.UnexpectedAttributeValueException | UnexpectedAttributeValueException
See Also
XmlQueryServiceExceptionThrower Class
XmlQueryServiceExceptionThrower Members
DroopyEyes.EcoExtensions.Services.XmlQueryService Namespace


XmlQueryServiceExceptionThrower.ThrowUnknownNodeTypeException Method

XmlQueryServiceExceptionThrower.ThrowUnknownNodeTypeException Method
XmlQueryServiceExceptionThrower Class XmlQueryServiceExceptionThrower Members DroopyEyes.EcoExtensions.Services.XmlQueryService Namespace See Also
Collapse All

Throws an UnknownNodeTypeException.

C#
public static void ThrowUnknownNodeTypeException(
    string nodeType
);
Exceptions
Exceptions | Description
DroopyEyes.EcoExtensions.Services.XmlQueryService.UnknownNodeTypeException | UnknownNodeTypeException
See Also
XmlQueryServiceExceptionThrower Class
XmlQueryServiceExceptionThrower Members
DroopyEyes.EcoExtensions.Services.XmlQueryService Namespace


IXmlQueryService Interface

IXmlQueryService Interface
IXmlQueryService Members Inheritance Hierarchy See Also
Collapse All

Interface used to access the XmlQueryService

C#
public interface IXmlQueryService;
Inheritance Hierarchy
DroopyEyes.EcoExtensions.Services.XmlQueryService.IXmlQueryService
    DroopyEyes.EcoExtensions.Services.XmlQueryService.XmlQueryService
File

Interfaces.cs

See Also
IXmlQueryService Members
Inheritance Hierarchy


IXmlQueryService Members

IXmlQueryService Members
Public Methods
Collapse All

The following tables list the members exposed by IXmlQueryService.

Public Methods
Name | Description
Execute | This method will transform the xmlQuery and return the resulting XML
GetNodeProcessor | This method will return the most recently registered node processor for the given node name.
RegisterNodeProcessor | This method will allows the developer to register processors for custom node types.


IXmlQueryService Methods

IXmlQueryService Methods
Public Methods
Collapse All

The methods of the IXmlQueryService class are listed here.

Public Methods
Name | Description
Execute | This method will transform the xmlQuery and return the resulting XML
GetNodeProcessor | This method will return the most recently registered node processor for the given node name.
RegisterNodeProcessor | This method will allows the developer to register processors for custom node types.


IXmlQueryService.Execute Method

IXmlQueryService.Execute Method
IXmlQueryService Interface IXmlQueryService Members DroopyEyes.EcoExtensions.Services.XmlQueryService Namespace See Also
Collapse All

This method will transform the xmlQuery and return the resulting XML

C#
string Execute(
    string queryString
);
Parameters
Parameters | Description
queryString | The xml formatted query for the service to parse
Returns

Returns a string containing the parsed XML

See Also
IXmlQueryService Interface
IXmlQueryService Members
DroopyEyes.EcoExtensions.Services.XmlQueryService Namespace


IXmlQueryService.GetNodeProcessor Method

IXmlQueryService.GetNodeProcessor Method
IXmlQueryService Interface IXmlQueryService Members DroopyEyes.EcoExtensions.Services.XmlQueryService Namespace Related Topics See Also
Collapse All

This method will return the most recently registered node processor for the given node name.

C#
XmlNodeProcessor GetNodeProcessor(
    string nodeName
);
Parameters
Parameters | Description
nodeName | The name of the node for which a node processor is required
Returns

Returns the instance of the XmlNodeProcessor registered to process nodes with the specified name.

Exceptions
Exceptions | Description
DroopyEyes.EcoExtensions.Services.XmlQueryService.UnknownNodeTypeException | ThrowUnknownNodeTypeException
Related Topics

RegisterNodeProcessor, DroopyEyes.EcoExtensions.Services.XmlQueryService.XmlNodeProcessor

See Also
IXmlQueryService Interface
IXmlQueryService Members
DroopyEyes.EcoExtensions.Services.XmlQueryService Namespace
Related Topics


IXmlQueryService.RegisterNodeProcessor Method

IXmlQueryService.RegisterNodeProcessor Method
IXmlQueryService Interface IXmlQueryService Members DroopyEyes.EcoExtensions.Services.XmlQueryService Namespace Related Topics See Also
Collapse All

This method will allows the developer to register processors for custom node types.

C#
void RegisterNodeProcessor(
    string nodeName,
    XmlNodeProcessor nodeProcessor
);
Parameters
Parameters | Description
nodeName | The name of the node exactly as it is expected to appear in the xml query string
nodeProcessor | An instance of an XmlNodeProcessor that will be used to process the specified node when it is encountered.
Related Topics

GetNodeProcessor, DroopyEyes.EcoExtensions.Services.XmlQueryService.XmlNodeProcessor

See Also
IXmlQueryService Interface
IXmlQueryService Members
DroopyEyes.EcoExtensions.Services.XmlQueryService Namespace
Related Topics


DroopyEyes.EcoExtensions.Validation Namespace

DroopyEyes.EcoExtensions.Validation Namespace
Classes Interfaces Types
Collapse All

This is namespace DroopyEyes.EcoExtensions.Validation.

Classes
Name | Description
Constraint | Implements IConstraint which may be returned by an IConstraintProvider
ConstraintBrokenEventArgs | Used for handling ConstraintBroken events.
CreateConstraintArgs | These event args are passed by the ModeledConstraintProvider.CreateConstraint event DroopyEyes.EcoExtensions.Validation.ModeledConstraintProvider.CreateConstraint See ModeledConstraintProvider.CreateConstraint
ModeledConstraintProvider | This component will provide an ArrayList of IConstraint for a given IObject instance. It creates each of these IConstraints based on the "Constraints" modeled against a class at design time.
Top
Interfaces
Name | Description
IConstraint | Given an IObject instance and an ArrayList, this method will return a list of IConstraint
IConstraintProvider | Provides a common mechanism for retrieving constraints for an IObject
Top
Types
Name | Description
CreateConstraintHandler | Delegate used for CreateConstraint events


Constraint Class

Constraint Class
Constraint Members Inheritance Hierarchy See Also
Collapse All

Implements IConstraint which may be returned by an IConstraintProvider

C#
public class Constraint : IConstraint;
Inheritance Hierarchy
DroopyEyes.EcoExtensions.Validation.IConstraint
    DroopyEyes.EcoExtensions.Validation.Constraint
File

Constraint.cs

See Also
Constraint Members
Inheritance Hierarchy


Constraint Members

Constraint Members
Public Properties
Collapse All

The following tables list the members exposed by Constraint.

Public Properties
Name | Description
Expression | DroopyEyes.EcoExtensions.Validation.IConstraint.Expression See IConstraint.Expression
Instance | DroopyEyes.EcoExtensions.Validation.IConstraint.Instance See IConstraint.Instance
IsValid | DroopyEyes.EcoExtensions.Validation.IConstraint.IsValid See IConstraint.IsValid
Name | DroopyEyes.EcoExtensions.Validation.IConstraint.Name See IConstraint.Name


Constraint Properties

Constraint Properties
Public Properties
Collapse All

The properties of the Constraint class are listed here.

Public Properties
Name | Description
Expression | DroopyEyes.EcoExtensions.Validation.IConstraint.Expression See IConstraint.Expression
Instance | DroopyEyes.EcoExtensions.Validation.IConstraint.Instance See IConstraint.Instance
IsValid | DroopyEyes.EcoExtensions.Validation.IConstraint.IsValid See IConstraint.IsValid
Name | DroopyEyes.EcoExtensions.Validation.IConstraint.Name See IConstraint.Name


Constraint.Expression Property

Constraint.Expression Property
Constraint Class Constraint Members DroopyEyes.EcoExtensions.Validation Namespace See Also
Collapse All

DroopyEyes.EcoExtensions.Validation.IConstraint.Expression See IConstraint.Expression

C#
public string Expression;
See Also
Constraint Class
Constraint Members
DroopyEyes.EcoExtensions.Validation Namespace


Constraint.Instance Property

Constraint.Instance Property
Constraint Class Constraint Members DroopyEyes.EcoExtensions.Validation Namespace See Also
Collapse All

DroopyEyes.EcoExtensions.Validation.IConstraint.Instance See IConstraint.Instance

C#
public IObject Instance;
See Also
Constraint Class
Constraint Members
DroopyEyes.EcoExtensions.Validation Namespace


Constraint.IsValid Property

Constraint.IsValid Property
Constraint Class Constraint Members DroopyEyes.EcoExtensions.Validation Namespace See Also
Collapse All

DroopyEyes.EcoExtensions.Validation.IConstraint.IsValid See IConstraint.IsValid

C#
public bool IsValid;
See Also
Constraint Class
Constraint Members
DroopyEyes.EcoExtensions.Validation Namespace


Constraint.Name Property

Constraint.Name Property
Constraint Class Constraint Members DroopyEyes.EcoExtensions.Validation Namespace See Also
Collapse All

DroopyEyes.EcoExtensions.Validation.IConstraint.Name See IConstraint.Name

C#
public string Name;
See Also
Constraint Class
Constraint Members
DroopyEyes.EcoExtensions.Validation Namespace


ConstraintBrokenEventArgs Class

ConstraintBrokenEventArgs Class
ConstraintBrokenEventArgs Members Inheritance Hierarchy See Also
Collapse All

Used for handling ConstraintBroken events.

C#
public class ConstraintBrokenEventArgs : System.EventArgs;
Inheritance Hierarchy
DroopyEyes.EcoExtensions.Validation.ConstraintBrokenEventArgs
File

ConstraintBrokenEventArgs.cs

See Also
ConstraintBrokenEventArgs Members
Inheritance Hierarchy


ConstraintBrokenEventArgs Members

ConstraintBrokenEventArgs Members
Public Methods Public Fields
Collapse All

The following tables list the members exposed by ConstraintBrokenEventArgs.

Public Methods
Name | Description
ConstraintBrokenEventArgs | Creates a new instance.
Top
Public Fields
Name | Description
Constraint | Identifies which IConstraint is broken.


ConstraintBrokenEventArgs.ConstraintBrokenEventArgs Constructor

ConstraintBrokenEventArgs.ConstraintBrokenEventArgs Constructor
ConstraintBrokenEventArgs Class ConstraintBrokenEventArgs Members DroopyEyes.EcoExtensions.Validation Namespace See Also
Collapse All

Creates a new instance.

C#
public ConstraintBrokenEventArgs(
    IConstraint constraint
);
See Also
ConstraintBrokenEventArgs Class
ConstraintBrokenEventArgs Members
DroopyEyes.EcoExtensions.Validation Namespace


ConstraintBrokenEventArgs Fields

ConstraintBrokenEventArgs Fields
Public Fields
Collapse All

The fields of the ConstraintBrokenEventArgs class are listed here.

Public Fields
Name | Description
Constraint | Identifies which IConstraint is broken.


ConstraintBrokenEventArgs.Constraint Field

ConstraintBrokenEventArgs.Constraint Field
ConstraintBrokenEventArgs Class ConstraintBrokenEventArgs Members DroopyEyes.EcoExtensions.Validation Namespace See Also
Collapse All

Identifies which IConstraint is broken.

C#
public readonly IConstraint Constraint;
See Also
ConstraintBrokenEventArgs Class
ConstraintBrokenEventArgs Members
DroopyEyes.EcoExtensions.Validation Namespace


CreateConstraintArgs Class

CreateConstraintArgs Class
CreateConstraintArgs Members Inheritance Hierarchy See Also
Collapse All

These event args are passed by the ModeledConstraintProvider.CreateConstraint event DroopyEyes.EcoExtensions.Validation.ModeledConstraintProvider.CreateConstraint See ModeledConstraintProvider.CreateConstraint

C#
public class CreateConstraintArgs : System.EventArgs;
Inheritance Hierarchy
DroopyEyes.EcoExtensions.Validation.CreateConstraintArgs
File

CreateConstraintEventArgs.cs

See Also
CreateConstraintArgs Members
Inheritance Hierarchy


CreateConstraintArgs Members

CreateConstraintArgs Members
Public Methods Public Fields
Collapse All

The following tables list the members exposed by CreateConstraintArgs.

Public Methods
Name | Description
CreateConstraintArgs | Constructs a new instance of a CreateConstraintArgs class
Top
Public Fields
Name | Description
Constraint | This is a reference to the created IConstraint DroopyEyes.EcoExtensions.Validation.IConstraint See IConstraint
Expression | This read-only property holds the OCL expression for the constraint
Instance | This read-only property holds a reference to the IObject instance which owns the constraint
Name | This read-only property holds the Name of the constraint (ie, the error text)


CreateConstraintArgs.CreateConstraintArgs Constructor

CreateConstraintArgs.CreateConstraintArgs Constructor
CreateConstraintArgs Class CreateConstraintArgs Members DroopyEyes.EcoExtensions.Validation Namespace See Also
Collapse All

Constructs a new instance of a CreateConstraintArgs class

C#
public CreateConstraintArgs(
    IObject instance,
    string name,
    string expression
);
See Also
CreateConstraintArgs Class
CreateConstraintArgs Members
DroopyEyes.EcoExtensions.Validation Namespace


CreateConstraintArgs Fields

CreateConstraintArgs Fields
Public Fields
Collapse All

The fields of the CreateConstraintArgs class are listed here.

Public Fields
Name | Description
Constraint | This is a reference to the created IConstraint DroopyEyes.EcoExtensions.Validation.IConstraint See IConstraint
Expression | This read-only property holds the OCL expression for the constraint
Instance | This read-only property holds a reference to the IObject instance which owns the constraint
Name | This read-only property holds the Name of the constraint (ie, the error text)


CreateConstraintArgs.Constraint Field

CreateConstraintArgs.Constraint Field
CreateConstraintArgs Class CreateConstraintArgs Members DroopyEyes.EcoExtensions.Validation Namespace See Also
Collapse All

This is a reference to the created IConstraint DroopyEyes.EcoExtensions.Validation.IConstraint See IConstraint

C#
public IConstraint Constraint = null;
See Also
CreateConstraintArgs Class
CreateConstraintArgs Members
DroopyEyes.EcoExtensions.Validation Namespace


CreateConstraintArgs.Expression Field

CreateConstraintArgs.Expression Field
CreateConstraintArgs Class CreateConstraintArgs Members DroopyEyes.EcoExtensions.Validation Namespace See Also
Collapse All

This read-only property holds the OCL expression for the constraint

C#
public readonly string Expression;
See Also
CreateConstraintArgs Class
CreateConstraintArgs Members
DroopyEyes.EcoExtensions.Validation Namespace


CreateConstraintArgs.Instance Field

CreateConstraintArgs.Instance Field
CreateConstraintArgs Class CreateConstraintArgs Members DroopyEyes.EcoExtensions.Validation Namespace See Also
Collapse All

This read-only property holds a reference to the IObject instance which owns the constraint

C#
public readonly IObject Instance;
See Also
CreateConstraintArgs Class
CreateConstraintArgs Members
DroopyEyes.EcoExtensions.Validation Namespace


CreateConstraintArgs.Name Field

CreateConstraintArgs.Name Field
CreateConstraintArgs Class CreateConstraintArgs Members DroopyEyes.EcoExtensions.Validation Namespace See Also
Collapse All

This read-only property holds the Name of the constraint (ie, the error text)

C#
public readonly string Name;
See Also
CreateConstraintArgs Class
CreateConstraintArgs Members
DroopyEyes.EcoExtensions.Validation Namespace


ModeledConstraintProvider Class

ModeledConstraintProvider Class
ModeledConstraintProvider Members Inheritance Hierarchy Related Topics See Also
Collapse All

This component will provide an ArrayList of IConstraint for a given IObject instance. It creates each of these IConstraints based on the "Constraints" modeled against a class at design time.

C#
public class ModeledConstraintProvider : Component, IConstraintProvider;
Remarks

Deleted objects will not return any constraints

Related Topics

IConstraint

Inheritance Hierarchy
DroopyEyes.EcoExtensions.Validation.IConstraintProvider
    DroopyEyes.EcoExtensions.Validation.ModeledConstraintProvider
File

ModeledConstraintProvider.cs

See Also
ModeledConstraintProvider Members
Inheritance Hierarchy
Related Topics


ModeledConstraintProvider Members

ModeledConstraintProvider Members
Protected Methods Public Methods Public Events
Collapse All

The following tables list the members exposed by ModeledConstraintProvider.

Protected Methods
Name | Description
OnCreateConstraint | Creates the IConstraint instance, calls the CreateConstraint event, and returns the IConstraint.
Top
Public Methods
Name | Description
GetConstraintsForObject | This is the overview for the GetConstraintsForObject method overload.
GetConstraintsForObject | This is the overview for the GetConstraintsForObject method overload.
GetConstraintsForObjects | This is the overview for the GetConstraintsForObjects method overload.
GetConstraintsForObjects | This is the overview for the GetConstraintsForObjects method overload.
Top
Public Events
Name | Description
CreateConstraint | This event is executed whenever an IConstraint is added to the ArrayList from the model.


ModeledConstraintProvider Methods

ModeledConstraintProvider Methods
Protected Methods Public Methods
Collapse All

The methods of the ModeledConstraintProvider class are listed here.

Protected Methods
Name | Description
OnCreateConstraint | Creates the IConstraint instance, calls the CreateConstraint event, and returns the IConstraint.
Top
Public Methods
Name | Description
GetConstraintsForObject | This is the overview for the GetConstraintsForObject method overload.
GetConstraintsForObjects | This is the overview for the GetConstraintsForObjects method overload.


GetConstraintsForObject Method

GetConstraintsForObject Method

This is the overview for the GetConstraintsForObject method overload.

Overload List
Name | Description
ModeledConstraintProvider.GetConstraintsForObject (IObject, ArrayList) | Implementation of IConstraintProvider.GetConstraintsForObject
ModeledConstraintProvider.GetConstraintsForObject (IObject, List<IConstraint>) | Implementation of IConstraintProvider.GetConstraintsForObject


ModeledConstraintProvider.GetConstraintsForObject Method (IObject, ArrayList)

ModeledConstraintProvider.GetConstraintsForObject Method (IObject, ArrayList)
ModeledConstraintProvider Class ModeledConstraintProvider Members DroopyEyes.EcoExtensions.Validation Namespace Related Topics See Also
Collapse All

Implementation of IConstraintProvider.GetConstraintsForObject

C#
public void GetConstraintsForObject(
    IObject instance,
    ref ArrayList constraints
);
Related Topics

IConstraintProvider.GetConstraintsForObject(Eco.ObjectRepresentation.IObject, ref System.Collections.ArrayList)

See Also
ModeledConstraintProvider Class
ModeledConstraintProvider Members
DroopyEyes.EcoExtensions.Validation Namespace
Related Topics


ModeledConstraintProvider.GetConstraintsForObject Method (IObject, List<IConstraint>)

ModeledConstraintProvider.GetConstraintsForObject Method (IObject, List<IConstraint>)
ModeledConstraintProvider Class ModeledConstraintProvider Members DroopyEyes.EcoExtensions.Validation Namespace Related Topics See Also
Collapse All

Implementation of IConstraintProvider.GetConstraintsForObject

C#
public void GetConstraintsForObject(
    IObject instance,
    List<IConstraint> constraints
);
Related Topics

IConstraintProvider.GetConstraintsForObject

See Also
ModeledConstraintProvider Class
ModeledConstraintProvider Members
DroopyEyes.EcoExtensions.Validation Namespace
Related Topics


GetConstraintsForObjects Method

GetConstraintsForObjects Method

This is the overview for the GetConstraintsForObjects method overload.

Overload List
Name | Description
ModeledConstraintProvider.GetConstraintsForObjects (IObjectList, ArrayList) | Implementation of IConstraintProvider.GetConstraintsForObjects
ModeledConstraintProvider.GetConstraintsForObjects (IObjectList, List<IConstraint>) | Implementation of IConstraintProvider.GetConstraintsForObjects


ModeledConstraintProvider.GetConstraintsForObjects Method (IObjectList, ArrayList)

ModeledConstraintProvider.GetConstraintsForObjects Method (IObjectList, ArrayList)
ModeledConstraintProvider Class ModeledConstraintProvider Members DroopyEyes.EcoExtensions.Validation Namespace Related Topics See Also
Collapse All

Implementation of IConstraintProvider.GetConstraintsForObjects

C#
public void GetConstraintsForObjects(
    IObjectList objectList,
    ref ArrayList constraints
);
Related Topics

IConstraintProvider.GetConstraintsForObjects(Eco.ObjectRepresentation.IObjectList, ref System.Collections.ArrayList)

See Also
ModeledConstraintProvider Class
ModeledConstraintProvider Members
DroopyEyes.EcoExtensions.Validation Namespace
Related Topics


ModeledConstraintProvider.GetConstraintsForObjects Method (IObjectList, List<IConstraint>)

ModeledConstraintProvider.GetConstraintsForObjects Method (IObjectList, List<IConstraint>)
ModeledConstraintProvider Class ModeledConstraintProvider Members DroopyEyes.EcoExtensions.Validation Namespace Related Topics See Also
Collapse All

Implementation of IConstraintProvider.GetConstraintsForObjects

C#
public void GetConstraintsForObjects(
    IObjectList objectList,
    List<IConstraint> constraints
);
Related Topics

IConstraintProvider.GetConstraintsForObjects

See Also
ModeledConstraintProvider Class
ModeledConstraintProvider Members
DroopyEyes.EcoExtensions.Validation Namespace
Related Topics


ModeledConstraintProvider.OnCreateConstraint Method

ModeledConstraintProvider.OnCreateConstraint Method
ModeledConstraintProvider Class ModeledConstraintProvider Members DroopyEyes.EcoExtensions.Validation Namespace See Also
Collapse All

Creates the IConstraint instance, calls the CreateConstraint event, and returns the IConstraint.

C#
protected virtual IConstraint OnCreateConstraint(
    IObject instance,
    string name,
    string expression
);
See Also
ModeledConstraintProvider Class
ModeledConstraintProvider Members
DroopyEyes.EcoExtensions.Validation Namespace


ModeledConstraintProvider Events

ModeledConstraintProvider Events
Public Events
Collapse All

The events of the ModeledConstraintProvider class are listed here.

Public Events
Name | Description
CreateConstraint | This event is executed whenever an IConstraint is added to the ArrayList from the model.


ModeledConstraintProvider.CreateConstraint Event

ModeledConstraintProvider.CreateConstraint Event
ModeledConstraintProvider Class ModeledConstraintProvider Members DroopyEyes.EcoExtensions.Validation Namespace See Also
Collapse All

This event is executed whenever an IConstraint is added to the ArrayList from the model.

C#
public event CreateConstraintHandler CreateConstraint;
See Also
ModeledConstraintProvider Class
ModeledConstraintProvider Members
DroopyEyes.EcoExtensions.Validation Namespace


IConstraint Interface

IConstraint Interface
IConstraint Members Inheritance Hierarchy See Also
Collapse All

Given an IObject instance and an ArrayList, this method will return a list of IConstraint

C#
public interface IConstraint;
Inheritance Hierarchy
DroopyEyes.EcoExtensions.Validation.IConstraint
    DroopyEyes.EcoExtensions.Validation.Constraint
File

ConstraintInterface.cs

See Also
IConstraint Members
Inheritance Hierarchy


IConstraint Members

IConstraint Members
Public Properties
Collapse All

The following tables list the members exposed by IConstraint.

Public Properties
Name | Description
Expression | Returns the OCL expression of the constraint
Instance | Returns the IObject to which this constraint belongs
IsValid | Returns false if the constraint is broken, otherwise returns true. This is the result of evaluating Expression against Instance.
Name | Returns the name of the constraint (ie, the error text)


IConstraint Properties

IConstraint Properties
Public Properties
Collapse All

The properties of the IConstraint class are listed here.

Public Properties
Name | Description
Expression | Returns the OCL expression of the constraint
Instance | Returns the IObject to which this constraint belongs
IsValid | Returns false if the constraint is broken, otherwise returns true. This is the result of evaluating Expression against Instance.
Name | Returns the name of the constraint (ie, the error text)


IConstraint.Expression Property

IConstraint.Expression Property
IConstraint Interface IConstraint Members DroopyEyes.EcoExtensions.Validation Namespace See Also
Collapse All

Returns the OCL expression of the constraint

C#
string Expression;
See Also
IConstraint Interface
IConstraint Members
DroopyEyes.EcoExtensions.Validation Namespace


IConstraint.Instance Property

IConstraint.Instance Property
IConstraint Interface IConstraint Members DroopyEyes.EcoExtensions.Validation Namespace See Also
Collapse All

Returns the IObject to which this constraint belongs

C#
IObject Instance;
See Also
IConstraint Interface
IConstraint Members
DroopyEyes.EcoExtensions.Validation Namespace


IConstraint.IsValid Property

IConstraint.IsValid Property
IConstraint Interface IConstraint Members DroopyEyes.EcoExtensions.Validation Namespace See Also
Collapse All

Returns false if the constraint is broken, otherwise returns true. This is the result of evaluating Expression against Instance.

C#
bool IsValid;
See Also
IConstraint Interface
IConstraint Members
DroopyEyes.EcoExtensions.Validation Namespace


IConstraint.Name Property

IConstraint.Name Property
IConstraint Interface IConstraint Members DroopyEyes.EcoExtensions.Validation Namespace See Also
Collapse All

Returns the name of the constraint (ie, the error text)

C#
string Name;
See Also
IConstraint Interface
IConstraint Members
DroopyEyes.EcoExtensions.Validation Namespace


IConstraintProvider Interface

IConstraintProvider Interface
IConstraintProvider Members Inheritance Hierarchy See Also
Collapse All

Provides a common mechanism for retrieving constraints for an IObject

C#
public interface IConstraintProvider;
Inheritance Hierarchy
DroopyEyes.EcoExtensions.Validation.IConstraintProvider
    DroopyEyes.EcoExtensions.Validation.ModeledConstraintProvider
File

ConstraintProviderInterface.cs

See Also
IConstraintProvider Members
Inheritance Hierarchy


IConstraintProvider Members

IConstraintProvider Members
Public Methods
Collapse All

The following tables list the members exposed by IConstraintProvider.

Public Methods
Name | Description
GetConstraintsForObject | This is the overview for the GetConstraintsForObject method overload.
GetConstraintsForObjects | This is the overview for the GetConstraintsForObjects method overload.


IConstraintProvider Methods

IConstraintProvider Methods
Public Methods
Collapse All

The methods of the IConstraintProvider class are listed here.

Public Methods
Name | Description
GetConstraintsForObject | This is the overview for the GetConstraintsForObject method overload.
GetConstraintsForObjects | This is the overview for the GetConstraintsForObjects method overload.


GetConstraintsForObject Method

GetConstraintsForObject Method

This is the overview for the GetConstraintsForObject method overload.

Overload List
Name | Description
IConstraintProvider.GetConstraintsForObject (IObject, ArrayList) | Given an IObject instance and an ArrayList reference, this method will return a list of IConstraint
IConstraintProvider.GetConstraintsForObject (IObject, List<IConstraint>) | Given an IObject instance and an ArrayList reference, this method will return a list of IConstraint


IConstraintProvider.GetConstraintsForObject Method (IObject, ArrayList)

IConstraintProvider.GetConstraintsForObject Method (IObject, ArrayList)
IConstraintProvider Interface IConstraintProvider Members DroopyEyes.EcoExtensions.Validation Namespace See Also
Collapse All

Given an IObject instance and an ArrayList reference, this method will return a list of IConstraint

C#
void GetConstraintsForObject(
    IObject instance,
    ref ArrayList constraints
);
See Also
IConstraintProvider Interface
IConstraintProvider Members
DroopyEyes.EcoExtensions.Validation Namespace


IConstraintProvider.GetConstraintsForObject Method (IObject, List<IConstraint>)

IConstraintProvider.GetConstraintsForObject Method (IObject, List<IConstraint>)
IConstraintProvider Interface IConstraintProvider Members DroopyEyes.EcoExtensions.Validation Namespace See Also
Collapse All

Given an IObject instance and an ArrayList reference, this method will return a list of IConstraint

C#
void GetConstraintsForObject(
    IObject instance,
    List<IConstraint> constraints
);
See Also
IConstraintProvider Interface
IConstraintProvider Members
DroopyEyes.EcoExtensions.Validation Namespace


GetConstraintsForObjects Method

GetConstraintsForObjects Method

This is the overview for the GetConstraintsForObjects method overload.

Overload List
Name | Description
IConstraintProvider.GetConstraintsForObjects (IObjectList, ArrayList) | Given an IObjectList and an ArrayList reference, this method will return a list of IConstraint for all objects within the list
IConstraintProvider.GetConstraintsForObjects (IObjectList, List<IConstraint>) | Given an IObjectList and an ArrayList reference, this method will return a list of IConstraint for all objects within the list


IConstraintProvider.GetConstraintsForObjects Method (IObjectList, ArrayList)

IConstraintProvider.GetConstraintsForObjects Method (IObjectList, ArrayList)
IConstraintProvider Interface IConstraintProvider Members DroopyEyes.EcoExtensions.Validation Namespace See Also
Collapse All

Given an IObjectList and an ArrayList reference, this method will return a list of IConstraint for all objects within the list

C#
void GetConstraintsForObjects(
    IObjectList objectList,
    ref ArrayList constraints
);
See Also
IConstraintProvider Interface
IConstraintProvider Members
DroopyEyes.EcoExtensions.Validation Namespace


IConstraintProvider.GetConstraintsForObjects Method (IObjectList, List<IConstraint>)

IConstraintProvider.GetConstraintsForObjects Method (IObjectList, List<IConstraint>)
IConstraintProvider Interface IConstraintProvider Members DroopyEyes.EcoExtensions.Validation Namespace See Also
Collapse All

Given an IObjectList and an ArrayList reference, this method will return a list of IConstraint for all objects within the list

C#
void GetConstraintsForObjects(
    IObjectList objectList,
    List<IConstraint> constraints
);
See Also
IConstraintProvider Interface
IConstraintProvider Members
DroopyEyes.EcoExtensions.Validation Namespace


DroopyEyes.EcoExtensions.Validation.CreateConstraintHandler Type

DroopyEyes.EcoExtensions.Validation.CreateConstraintHandler Type
Collapse All

Delegate used for CreateConstraint events

C#
public delegate void CreateConstraintHandler(object sender, CreateConstraintArgs e);
File

CreateConstraintEventArgs.cs


DroopyEyes.EcoExtensions.WinForm Namespace

DroopyEyes.EcoExtensions.WinForm Namespace
Classes
Collapse All

This is namespace DroopyEyes.EcoExtensions.WinForm.

Classes
Name | Description
ConflictingUpdateException | Thrown when an inconsistent list of objects is passed to DirtyObjectCatcher for updating.
DirtyObjectCatcher | Catches all objects made dirty whilst the specified form is active. Changes can later be undone or saved to the database. To use this component simply drop it onto your form. Then when you set your EcoSpace property (or some other relevant point) you call
DirtyObjectCatcherException | Thrown by DroopyEyes.EcoExtensions.WinForm.DirtyObjectCatcher DirtyObjectCatcher
ObjectValidator | Given an IObjectList and an IObjectConstraintProvider this component will provide a list of broken constraints.
ObjectValidatorException | Thrown by DroopyEyes.EcoExtensions.WinForm.ObjectValidator ObjectValidator


ConflictingUpdateException Class

ConflictingUpdateException Class
ConflictingUpdateException Members Inheritance Hierarchy See Also
Collapse All

Thrown when an inconsistent list of objects is passed to DirtyObjectCatcher for updating.

C#
public class ConflictingUpdateException : DirtyObjectCatcherException;
Remarks

When DirtyObjectCatcher.UpdateDatabase() is executed the DirtyObjectCatcher will first call IPersistenceService.EnsureEnclosure and check if there are any dirty objects that need to be included in the update that are not in its UndoBlock and also belong to another undo block. If there are then this type of exception will be thrown.

This is to prevent the object in question from being added automatically by ECO and potentially destroying an undo block belonging to another part of the application.

Inheritance Hierarchy
DroopyEyes.EcoExtensions.WinForm.DirtyObjectCatcherException
    DroopyEyes.EcoExtensions.WinForm.ConflictingUpdateException
File

DirtyObjectCatcherException.cs

See Also
ConflictingUpdateException Members
Inheritance Hierarchy


ConflictingUpdateException Members

ConflictingUpdateException Members
Public Methods Public Properties
Collapse All

The following tables list the members exposed by ConflictingUpdateException.

Public Methods
Name | Description
ConflictingUpdateException | Creates an instance of the exception.
DirtyObjectCatcherException | Creates an instance of the exception.
Top
Public Properties
Name | Description
ConflictingObjects | A list of IObject instances that hold the objects that are required to perform a complete update but were part of another UndoBlock’s contents.


ConflictingUpdateException.ConflictingUpdateException Constructor

ConflictingUpdateException.ConflictingUpdateException Constructor
ConflictingUpdateException Class ConflictingUpdateException Members DroopyEyes.EcoExtensions.WinForm Namespace See Also
Collapse All

Creates an instance of the exception.

C#
public ConflictingUpdateException(
    string message,
    IObjectList conflictingObjects
);
See Also
ConflictingUpdateException Class
ConflictingUpdateException Members
DroopyEyes.EcoExtensions.WinForm Namespace


ConflictingUpdateException Properties

ConflictingUpdateException Properties
Public Properties
Collapse All

The properties of the ConflictingUpdateException class are listed here.

Public Properties
Name | Description
ConflictingObjects | A list of IObject instances that hold the objects that are required to perform a complete update but were part of another UndoBlock’s contents.


ConflictingUpdateException.ConflictingObjects Property

ConflictingUpdateException.ConflictingObjects Property
ConflictingUpdateException Class ConflictingUpdateException Members DroopyEyes.EcoExtensions.WinForm Namespace See Also
Collapse All

A list of IObject instances that hold the objects that are required to perform a complete update but were part of another UndoBlock’s contents.

C#
public IObjectList ConflictingObjects;
See Also
ConflictingUpdateException Class
ConflictingUpdateException Members
DroopyEyes.EcoExtensions.WinForm Namespace


DirtyObjectCatcher Class

DirtyObjectCatcher Class
DirtyObjectCatcher Members Example Inheritance Hierarchy See Also
Collapse All

Catches all objects made dirty whilst the specified form is active. Changes can later be undone or saved to the database. To use this component simply drop it onto your form. Then when you set your EcoSpace property (or some other relevant point) you call

C#
public class DirtyObjectCatcher : Component;
Example

private void Form1_Shown(object sender, EventArgs e) { DirtyObjectCather1.Activate(this, EcoSpace); }

Inheritance Hierarchy
DroopyEyes.EcoExtensions.WinForm.DirtyObjectCatcher
File

DirtyObjectCatcher.cs

See Also
DirtyObjectCatcher Members
Example
Inheritance Hierarchy


DirtyObjectCatcher Members

DirtyObjectCatcher Members
Protected Methods Public Methods Public Properties Public Events
Collapse All

The following tables list the members exposed by DirtyObjectCatcher.

Protected Methods
Name | Description
Dispose | Disposes of any undo/redo block resources
Top
Public Methods
Name | Description
Activate | Activates the DirtyObjectCatcher for the specified form. This should be executed by the parent form only once, and before the form is shown, so that any objects created within the form's constructor will also be caught
DirtyObjectCatcher | Creates an instance of the DirtyObjectCatcher
RedoChanges | If CanRedo returns True then reapplies the changes made by UndoChanges()
SaveChanges | This is the overview for the SaveChanges method overload.
UndoChanges | Reverses any changes made in the current form.
UpdateDatabase | This is the overview for the UpdateDatabase method overload.
Top
Public Properties
Name | Description
CanRedo | Returns True if there are changes which have been undone but may be re-applied
CheckForConflictOnUpdate | If True all other UndoBlocks will be checked when UpdateDatabase is called, if any other undo block contains any objects in common with the update then a ConflictingUpdateException will be thrown.
ContainsChanges | Returns True if there are any changes, otherwise returns false
DirtyObjects | Returns an IObjectList holding all dirty IObjects
UndoChangesOnFormClose | If True then all changes made by the owning form will be undone when it is closed
Top
Public Events
Name | Description
Activated | This event is executed after Activate() is called and the DirtyObjectCatcher has finished initialising. Use this event when you wish to create new object instances as it will ensure that they are caught in the correct undo block.
DirtyListChanged | Executed whenever an object is added/removed from the DirtyObjects list


DirtyObjectCatcher.DirtyObjectCatcher Constructor

DirtyObjectCatcher.DirtyObjectCatcher Constructor
DirtyObjectCatcher Class DirtyObjectCatcher Members DroopyEyes.EcoExtensions.WinForm Namespace See Also
Collapse All

Creates an instance of the DirtyObjectCatcher

C#
public DirtyObjectCatcher();
See Also
DirtyObjectCatcher Class
DirtyObjectCatcher Members
DroopyEyes.EcoExtensions.WinForm Namespace


DirtyObjectCatcher Methods

DirtyObjectCatcher Methods
Protected Methods Public Methods
Collapse All

The methods of the DirtyObjectCatcher class are listed here.

Protected Methods
Name | Description
Dispose | Disposes of any undo/redo block resources
Top
Public Methods
Name | Description
Activate | Activates the DirtyObjectCatcher for the specified form. This should be executed by the parent form only once, and before the form is shown, so that any objects created within the form's constructor will also be caught
RedoChanges | If CanRedo returns True then reapplies the changes made by UndoChanges()
SaveChanges | This is the overview for the SaveChanges method overload.
UndoChanges | Reverses any changes made in the current form.
UpdateDatabase | This is the overview for the UpdateDatabase method overload.


DirtyObjectCatcher.Activate Method

DirtyObjectCatcher.Activate Method
DirtyObjectCatcher Class DirtyObjectCatcher Members DroopyEyes.EcoExtensions.WinForm Namespace See Also
Collapse All

Activates the DirtyObjectCatcher for the specified form. This should be executed by the parent form only once, and before the form is shown, so that any objects created within the form's constructor will also be caught

C#
public void Activate(
    Form owner,
    IEcoServiceProvider serviceProvider
);
Parameters
Parameters | Description
owner | Specifies the form to catch dirty objects for
serviceProvider | Specifies the EcoSpace for the form
See Also
DirtyObjectCatcher Class
DirtyObjectCatcher Members
DroopyEyes.EcoExtensions.WinForm Namespace


DirtyObjectCatcher.Dispose Method

DirtyObjectCatcher.Dispose Method
DirtyObjectCatcher Class DirtyObjectCatcher Members DroopyEyes.EcoExtensions.WinForm Namespace See Also
Collapse All

Disposes of any undo/redo block resources

C#
protected override void Dispose(
    bool disposing
);
See Also
DirtyObjectCatcher Class
DirtyObjectCatcher Members
DroopyEyes.EcoExtensions.WinForm Namespace


DirtyObjectCatcher.RedoChanges Method

DirtyObjectCatcher.RedoChanges Method
DirtyObjectCatcher Class DirtyObjectCatcher Members DroopyEyes.EcoExtensions.WinForm Namespace See Also
Collapse All

If CanRedo returns True then reapplies the changes made by UndoChanges()

C#
public void RedoChanges();
See Also
DirtyObjectCatcher Class
DirtyObjectCatcher Members
DroopyEyes.EcoExtensions.WinForm Namespace


SaveChanges Method

SaveChanges Method

This is the overview for the SaveChanges method overload.

Overload List
Name | Description
DirtyObjectCatcher.SaveChanges (DirtyObjectCatcher) | Saves all modifications to a target DirtyObjectCatcher
DirtyObjectCatcher.SaveChanges (IUndoBlock) | Saves all modifications to a target undo block


DirtyObjectCatcher.SaveChanges Method (DirtyObjectCatcher)

DirtyObjectCatcher.SaveChanges Method (DirtyObjectCatcher)
DirtyObjectCatcher Class DirtyObjectCatcher Members DroopyEyes.EcoExtensions.WinForm Namespace See Also
Collapse All

Saves all modifications to a target DirtyObjectCatcher

C#
public void SaveChanges(
    DirtyObjectCatcher targetDirtyObjectCatcher
);
See Also
DirtyObjectCatcher Class
DirtyObjectCatcher Members
DroopyEyes.EcoExtensions.WinForm Namespace


DirtyObjectCatcher.SaveChanges Method (IUndoBlock)

DirtyObjectCatcher.SaveChanges Method (IUndoBlock)
DirtyObjectCatcher Class DirtyObjectCatcher Members DroopyEyes.EcoExtensions.WinForm Namespace See Also
Collapse All

Saves all modifications to a target undo block

C#
public void SaveChanges(
    IUndoBlock targetUndoBlock
);
See Also
DirtyObjectCatcher Class
DirtyObjectCatcher Members
DroopyEyes.EcoExtensions.WinForm Namespace


DirtyObjectCatcher.UndoChanges Method

DirtyObjectCatcher.UndoChanges Method
DirtyObjectCatcher Class DirtyObjectCatcher Members DroopyEyes.EcoExtensions.WinForm Namespace See Also
Collapse All

Reverses any changes made in the current form.

C#
public void UndoChanges();
Exceptions
Exceptions | Description
DroopyEyes.EcoExtensions.WinForm.DirtyObjectCatcherException | Thrown when the changes may not be undone
See Also
DirtyObjectCatcher Class
DirtyObjectCatcher Members
DroopyEyes.EcoExtensions.WinForm Namespace


UpdateDatabase Method

UpdateDatabase Method

This is the overview for the UpdateDatabase method overload.

Overload List
Name | Description
DirtyObjectCatcher.UpdateDatabase () | Saves all modifications to the database
DirtyObjectCatcher.UpdateDatabase (IUndoBlock) | Saves all modifications to the database


DirtyObjectCatcher.UpdateDatabase Method ()

DirtyObjectCatcher.UpdateDatabase Method ()
DirtyObjectCatcher Class DirtyObjectCatcher Members DroopyEyes.EcoExtensions.WinForm Namespace See Also
Collapse All

Saves all modifications to the database

C#
public void UpdateDatabase();
Exceptions
Exceptions | Description
DroopyEyes.EcoExtensions.WinForm.ConflictingUpdateException | Thrown when ECO needs to update an object to ensure consistency but that object already exists in another undo block.
See Also
DirtyObjectCatcher Class
DirtyObjectCatcher Members
DroopyEyes.EcoExtensions.WinForm Namespace


DirtyObjectCatcher.UpdateDatabase Method (IUndoBlock)

DirtyObjectCatcher.UpdateDatabase Method (IUndoBlock)
DirtyObjectCatcher Class DirtyObjectCatcher Members DroopyEyes.EcoExtensions.WinForm Namespace See Also
Collapse All

Saves all modifications to the database

C#
public void UpdateDatabase(
    IUndoBlock additionalUndoBlock
);
Parameters
Parameters | Description
additionalUndoBlock | An additional block to include in the update
Exceptions
Exceptions | Description
DroopyEyes.EcoExtensions.WinForm.ConflictingUpdateException | Thrown when ECO needs to update an object to ensure consistency but that object already exists in another undo block.
See Also
DirtyObjectCatcher Class
DirtyObjectCatcher Members
DroopyEyes.EcoExtensions.WinForm Namespace


DirtyObjectCatcher Properties

DirtyObjectCatcher Properties
Public Properties
Collapse All

The properties of the DirtyObjectCatcher class are listed here.

Public Properties
Name | Description
CanRedo | Returns True if there are changes which have been undone but may be re-applied
CheckForConflictOnUpdate | If True all other UndoBlocks will be checked when UpdateDatabase is called, if any other undo block contains any objects in common with the update then a ConflictingUpdateException will be thrown.
ContainsChanges | Returns True if there are any changes, otherwise returns false
DirtyObjects | Returns an IObjectList holding all dirty IObjects
UndoChangesOnFormClose | If True then all changes made by the owning form will be undone when it is closed


DirtyObjectCatcher.CanRedo Property

DirtyObjectCatcher.CanRedo Property
DirtyObjectCatcher Class DirtyObjectCatcher Members DroopyEyes.EcoExtensions.WinForm Namespace See Also
Collapse All

Returns True if there are changes which have been undone but may be re-applied

C#
public bool CanRedo;
See Also
DirtyObjectCatcher Class
DirtyObjectCatcher Members
DroopyEyes.EcoExtensions.WinForm Namespace


DirtyObjectCatcher.CheckForConflictOnUpdate Property

DirtyObjectCatcher.CheckForConflictOnUpdate Property
DirtyObjectCatcher Class DirtyObjectCatcher Members DroopyEyes.EcoExtensions.WinForm Namespace See Also
Collapse All

If True all other UndoBlocks will be checked when UpdateDatabase is called, if any other undo block contains any objects in common with the update then a ConflictingUpdateException will be thrown.

C#
public bool CheckForConflictOnUpdate;
See Also
DirtyObjectCatcher Class
DirtyObjectCatcher Members
DroopyEyes.EcoExtensions.WinForm Namespace


DirtyObjectCatcher.ContainsChanges Property

DirtyObjectCatcher.ContainsChanges Property
DirtyObjectCatcher Class DirtyObjectCatcher Members DroopyEyes.EcoExtensions.WinForm Namespace See Also
Collapse All

Returns True if there are any changes, otherwise returns false

C#
public bool ContainsChanges;
See Also
DirtyObjectCatcher Class
DirtyObjectCatcher Members
DroopyEyes.EcoExtensions.WinForm Namespace


DirtyObjectCatcher.DirtyObjects Property

DirtyObjectCatcher.DirtyObjects Property
DirtyObjectCatcher Class DirtyObjectCatcher Members DroopyEyes.EcoExtensions.WinForm Namespace See Also
Collapse All

Returns an IObjectList holding all dirty IObjects

C#
public IObjectList DirtyObjects;
See Also
DirtyObjectCatcher Class
DirtyObjectCatcher Members
DroopyEyes.EcoExtensions.WinForm Namespace


DirtyObjectCatcher.UndoChangesOnFormClose Property

DirtyObjectCatcher.UndoChangesOnFormClose Property
DirtyObjectCatcher Class DirtyObjectCatcher Members DroopyEyes.EcoExtensions.WinForm Namespace See Also
Collapse All

If True then all changes made by the owning form will be undone when it is closed

C#
public bool UndoChangesOnFormClose;
See Also
DirtyObjectCatcher Class
DirtyObjectCatcher Members
DroopyEyes.EcoExtensions.WinForm Namespace


DirtyObjectCatcher Events

DirtyObjectCatcher Events
Public Events
Collapse All

The events of the DirtyObjectCatcher class are listed here.

Public Events
Name | Description
Activated | This event is executed after Activate() is called and the DirtyObjectCatcher has finished initialising. Use this event when you wish to create new object instances as it will ensure that they are caught in the correct undo block.
DirtyListChanged | Executed whenever an object is added/removed from the DirtyObjects list


DirtyObjectCatcher.Activated Event

DirtyObjectCatcher.Activated Event
DirtyObjectCatcher Class DirtyObjectCatcher Members DroopyEyes.EcoExtensions.WinForm Namespace See Also
Collapse All

This event is executed after Activate() is called and the DirtyObjectCatcher has finished initialising. Use this event when you wish to create new object instances as it will ensure that they are caught in the correct undo block.

C#
public event EventHandler Activated;
See Also
DirtyObjectCatcher Class
DirtyObjectCatcher Members
DroopyEyes.EcoExtensions.WinForm Namespace


DirtyObjectCatcher.DirtyListChanged Event

DirtyObjectCatcher.DirtyListChanged Event
DirtyObjectCatcher Class DirtyObjectCatcher Members DroopyEyes.EcoExtensions.WinForm Namespace See Also
Collapse All

Executed whenever an object is added/removed from the DirtyObjects list

C#
public event EventHandler DirtyListChanged;
See Also
DirtyObjectCatcher Class
DirtyObjectCatcher Members
DroopyEyes.EcoExtensions.WinForm Namespace


DirtyObjectCatcherException Class

DirtyObjectCatcherException Class
DirtyObjectCatcherException Members Inheritance Hierarchy See Also
Collapse All

Thrown by DroopyEyes.EcoExtensions.WinForm.DirtyObjectCatcher DirtyObjectCatcher

C#
public class DirtyObjectCatcherException : System.Exception;
Inheritance Hierarchy
DroopyEyes.EcoExtensions.WinForm.DirtyObjectCatcherException
    DroopyEyes.EcoExtensions.WinForm.ConflictingUpdateException
File

DirtyObjectCatcherException.cs

See Also
DirtyObjectCatcherException Members
Inheritance Hierarchy


DirtyObjectCatcherException Members

DirtyObjectCatcherException Members
Public Methods
Collapse All

The following tables list the members exposed by DirtyObjectCatcherException.

Public Methods
Name | Description
DirtyObjectCatcherException | Creates an instance of the exception.


DirtyObjectCatcherException.DirtyObjectCatcherException Constructor

DirtyObjectCatcherException.DirtyObjectCatcherException Constructor
DirtyObjectCatcherException Class DirtyObjectCatcherException Members DroopyEyes.EcoExtensions.WinForm Namespace See Also
Collapse All

Creates an instance of the exception.

C#
public DirtyObjectCatcherException(
    string message
);
See Also
DirtyObjectCatcherException Class
DirtyObjectCatcherException Members
DroopyEyes.EcoExtensions.WinForm Namespace


ObjectValidator Class

ObjectValidator Class
ObjectValidator Members Inheritance Hierarchy See Also
Collapse All

Given an IObjectList and an IObjectConstraintProvider this component will provide a list of broken constraints.

C#
public class ObjectValidator : Component;
Inheritance Hierarchy
DroopyEyes.EcoExtensions.WinForm.ObjectValidator
File

ObjectValidator.cs

See Also
ObjectValidator Members
Inheritance Hierarchy


ObjectValidator Members

ObjectValidator Members
Public Delegates Protected Methods Public Methods Public Properties Public Events Public Delegates See Also
Collapse All

The following tables list the members exposed by ObjectValidator.

Protected Methods
Name | Description
Dispose | This is Dispose, a member of class ObjectValidator.
OnBeginValidation | Executes the DroopyEyes.EcoExtensions.WinForm.ObjectValidator.BeginValidation BeginValidationevent.
OnConstraintBroken | Executes the DroopyEyes.EcoExtensions.WinForm.ObjectValidator.ConstraintBroken ConstraintBrokenevent.
OnEndValidation | Executes the DroopyEyes.EcoExtensions.WinForm.ObjectValidator.EndValidation EndValidationevent.
Top
Public Methods
Name | Description
ObjectValidator | Constructs a new instance.
Top
Public Properties
Name | Description
ConstraintProvider | Identifies which component should be used to retrieve a list of constraints for a specific object instance.
DirtyObjectCatcher | Identifies the DirtyObjectCatcher which will hold a list of dirty objects and also trigger the subscription process.
Top
Public Events
Name | Description
BeginValidation | This event is executed when an object is altered and validation needs to take place.
ConstraintBroken | This event is executed for every broken constraint.
EndValidation | This event is executed when validation has completed.
Top
Public Delegates
Name | Description
ConstraintBrokenEventHandler | See DroopyEyes.EcoExtensions.WinForm.ObjectValidator.ConstraintBroken ObjectValidator.ConstraintBroken
Top
See Also
Public Delegates


ObjectValidator.ObjectValidator Constructor

ObjectValidator.ObjectValidator Constructor
ObjectValidator Class ObjectValidator Members DroopyEyes.EcoExtensions.WinForm Namespace See Also
Collapse All

Constructs a new instance.

C#
public ObjectValidator();
See Also
ObjectValidator Class
ObjectValidator Members
DroopyEyes.EcoExtensions.WinForm Namespace


ObjectValidator Methods

ObjectValidator Methods
Protected Methods
Collapse All

The methods of the ObjectValidator class are listed here.

Protected Methods
Name | Description
Dispose | This is Dispose, a member of class ObjectValidator.
OnBeginValidation | Executes the DroopyEyes.EcoExtensions.WinForm.ObjectValidator.BeginValidation BeginValidationevent.
OnConstraintBroken | Executes the DroopyEyes.EcoExtensions.WinForm.ObjectValidator.ConstraintBroken ConstraintBrokenevent.
OnEndValidation | Executes the DroopyEyes.EcoExtensions.WinForm.ObjectValidator.EndValidation EndValidationevent.


ObjectValidator.Dispose Method

ObjectValidator.Dispose Method
ObjectValidator Class ObjectValidator Members DroopyEyes.EcoExtensions.WinForm Namespace See Also
Collapse All
C#
protected override void Dispose(
    bool disposing
);
Remarks

This is Dispose, a member of class ObjectValidator.

See Also
ObjectValidator Class
ObjectValidator Members
DroopyEyes.EcoExtensions.WinForm Namespace


ObjectValidator.OnBeginValidation Method

ObjectValidator.OnBeginValidation Method
ObjectValidator Class ObjectValidator Members DroopyEyes.EcoExtensions.WinForm Namespace See Also
Collapse All

Executes the DroopyEyes.EcoExtensions.WinForm.ObjectValidator.BeginValidation BeginValidationevent.

C#
protected virtual void OnBeginValidation();
See Also
ObjectValidator Class
ObjectValidator Members
DroopyEyes.EcoExtensions.WinForm Namespace


ObjectValidator.OnConstraintBroken Method

ObjectValidator.OnConstraintBroken Method
ObjectValidator Class ObjectValidator Members DroopyEyes.EcoExtensions.WinForm Namespace See Also
Collapse All

Executes the DroopyEyes.EcoExtensions.WinForm.ObjectValidator.ConstraintBroken ConstraintBrokenevent.

C#
protected virtual void OnConstraintBroken(
    IConstraint constraint
);
See Also
ObjectValidator Class
ObjectValidator Members
DroopyEyes.EcoExtensions.WinForm Namespace


ObjectValidator.OnEndValidation Method

ObjectValidator.OnEndValidation Method
ObjectValidator Class ObjectValidator Members DroopyEyes.EcoExtensions.WinForm Namespace See Also
Collapse All

Executes the DroopyEyes.EcoExtensions.WinForm.ObjectValidator.EndValidation EndValidationevent.

C#
protected virtual void OnEndValidation();
See Also
ObjectValidator Class
ObjectValidator Members
DroopyEyes.EcoExtensions.WinForm Namespace


ObjectValidator Properties

ObjectValidator Properties
Public Properties
Collapse All

The properties of the ObjectValidator class are listed here.

Public Properties
Name | Description
ConstraintProvider | Identifies which component should be used to retrieve a list of constraints for a specific object instance.
DirtyObjectCatcher | Identifies the DirtyObjectCatcher which will hold a list of dirty objects and also trigger the subscription process.


ObjectValidator.ConstraintProvider Property

ObjectValidator.ConstraintProvider Property
ObjectValidator Class ObjectValidator Members DroopyEyes.EcoExtensions.WinForm Namespace See Also
Collapse All

Identifies which component should be used to retrieve a list of constraints for a specific object instance.

C#
public IConstraintProvider ConstraintProvider;
See Also
ObjectValidator Class
ObjectValidator Members
DroopyEyes.EcoExtensions.WinForm Namespace


ObjectValidator.DirtyObjectCatcher Property

ObjectValidator.DirtyObjectCatcher Property
ObjectValidator Class ObjectValidator Members DroopyEyes.EcoExtensions.WinForm Namespace See Also
Collapse All

Identifies the DirtyObjectCatcher which will hold a list of dirty objects and also trigger the subscription process.

C#
public DirtyObjectCatcher DirtyObjectCatcher;
See Also
ObjectValidator Class
ObjectValidator Members
DroopyEyes.EcoExtensions.WinForm Namespace


ObjectValidator Delegates

ObjectValidator Delegates
Public Delegates Public Delegates See Also
Collapse All

The delegates of the ObjectValidator class are listed here.

Public Delegates
Name | Description
ConstraintBrokenEventHandler | See DroopyEyes.EcoExtensions.WinForm.ObjectValidator.ConstraintBroken ObjectValidator.ConstraintBroken
Top
See Also
Public Delegates


ObjectValidator.ConstraintBrokenEventHandler Delegate

ObjectValidator.ConstraintBrokenEventHandler Delegate
ObjectValidator Class ObjectValidator Members DroopyEyes.EcoExtensions.WinForm Namespace See Also
Collapse All

See DroopyEyes.EcoExtensions.WinForm.ObjectValidator.ConstraintBroken ObjectValidator.ConstraintBroken

C#
public delegate void ConstraintBrokenEventHandler(object sender, ConstraintBrokenEventArgs e);
See Also
ObjectValidator Class
ObjectValidator Members
DroopyEyes.EcoExtensions.WinForm Namespace


ObjectValidator Events

ObjectValidator Events
Public Events
Collapse All

The events of the ObjectValidator class are listed here.

Public Events
Name | Description
BeginValidation | This event is executed when an object is altered and validation needs to take place.
ConstraintBroken | This event is executed for every broken constraint.
EndValidation | This event is executed when validation has completed.


ObjectValidator.BeginValidation Event

ObjectValidator.BeginValidation Event
ObjectValidator Class ObjectValidator Members DroopyEyes.EcoExtensions.WinForm Namespace See Also
Collapse All

This event is executed when an object is altered and validation needs to take place.

C#
public event System.EventHandler BeginValidation;
See Also
ObjectValidator Class
ObjectValidator Members
DroopyEyes.EcoExtensions.WinForm Namespace


ObjectValidator.ConstraintBroken Event

ObjectValidator.ConstraintBroken Event
ObjectValidator Class ObjectValidator Members DroopyEyes.EcoExtensions.WinForm Namespace See Also
Collapse All

This event is executed for every broken constraint.

C#
public event ConstraintBrokenEventHandler ConstraintBroken;
See Also
ObjectValidator Class
ObjectValidator Members
DroopyEyes.EcoExtensions.WinForm Namespace


ObjectValidator.EndValidation Event

ObjectValidator.EndValidation Event
ObjectValidator Class ObjectValidator Members DroopyEyes.EcoExtensions.WinForm Namespace See Also
Collapse All

This event is executed when validation has completed.

C#
public event System.EventHandler EndValidation;
See Also
ObjectValidator Class
ObjectValidator Members
DroopyEyes.EcoExtensions.WinForm Namespace


ObjectValidatorException Class

ObjectValidatorException Class
ObjectValidatorException Members Inheritance Hierarchy See Also
Collapse All

Thrown by DroopyEyes.EcoExtensions.WinForm.ObjectValidator ObjectValidator

C#
public class ObjectValidatorException : Exception;
Inheritance Hierarchy
DroopyEyes.EcoExtensions.WinForm.ObjectValidatorException
File

ObjectValidatorException.cs

See Also
ObjectValidatorException Members
Inheritance Hierarchy


ObjectValidatorException Members

ObjectValidatorException Members
Public Methods
Collapse All

The following tables list the members exposed by ObjectValidatorException.

Public Methods
Name | Description
ObjectValidatorException | Creates an instance of the exception.


ObjectValidatorException.ObjectValidatorException Constructor

ObjectValidatorException.ObjectValidatorException Constructor
ObjectValidatorException Class ObjectValidatorException Members DroopyEyes.EcoExtensions.WinForm Namespace See Also
Collapse All

Creates an instance of the exception.

C#
public ObjectValidatorException(
    string message
);
See Also
ObjectValidatorException Class
ObjectValidatorException Members
DroopyEyes.EcoExtensions.WinForm Namespace


DroopyEyes.EcoExtensions.XtraReports Namespace

DroopyEyes.EcoExtensions.XtraReports Namespace
Classes
Collapse All

This is namespace DroopyEyes.EcoExtensions.XtraReports.

Classes
Name | Description
XtraReportCursorHandle | This is class DroopyEyes.EcoExtensions.XtraReports.XtraReportCursorHandle.


XtraReportCursorHandle Class

XtraReportCursorHandle Class
XtraReportCursorHandle Members Inheritance Hierarchy See Also
Collapse All
C#
public class XtraReportCursorHandle : AbstractCursorHandle;
Remarks

This is class DroopyEyes.EcoExtensions.XtraReports.XtraReportCursorHandle.

Inheritance Hierarchy
DroopyEyes.EcoExtensions.XtraReports.XtraReportCursorHandle
File

XtraReportsCursorHandle.cs

See Also
XtraReportCursorHandle Members
Inheritance Hierarchy


XtraReportCursorHandle Members

XtraReportCursorHandle Members
Public Methods Public Properties Public Events
Collapse All

The following tables list the members exposed by XtraReportCursorHandle.

Public Methods
Name | Description
XtraReportCursorHandle | This is XtraReportCursorHandle, a member of class XtraReportCursorHandle.
Top
Public Properties
Name | Description
Position | This is Position, a member of class XtraReportCursorHandle.
XtraReport | Identifies the XtraReport that controls the position of this component's RootHandle.
Top
Public Events
Name | Description
PositionChanged | Executed whenever the value of Position is changed.


XtraReportCursorHandle.XtraReportCursorHandle Constructor

XtraReportCursorHandle.XtraReportCursorHandle Constructor
XtraReportCursorHandle Class XtraReportCursorHandle Members DroopyEyes.EcoExtensions.XtraReports Namespace See Also
Collapse All
C#
public XtraReportCursorHandle();
Remarks

This is XtraReportCursorHandle, a member of class XtraReportCursorHandle.

See Also
XtraReportCursorHandle Class
XtraReportCursorHandle Members
DroopyEyes.EcoExtensions.XtraReports Namespace


XtraReportCursorHandle Properties

XtraReportCursorHandle Properties
Public Properties
Collapse All

The properties of the XtraReportCursorHandle class are listed here.

Public Properties
Name | Description
Position | This is Position, a member of class XtraReportCursorHandle.
XtraReport | Identifies the XtraReport that controls the position of this component's RootHandle.


XtraReportCursorHandle.Position Property

XtraReportCursorHandle.Position Property
XtraReportCursorHandle Class XtraReportCursorHandle Members DroopyEyes.EcoExtensions.XtraReports Namespace See Also
Collapse All
C#
public override int Position;
Remarks

This is Position, a member of class XtraReportCursorHandle.

See Also
XtraReportCursorHandle Class
XtraReportCursorHandle Members
DroopyEyes.EcoExtensions.XtraReports Namespace


XtraReportCursorHandle.XtraReport Property

XtraReportCursorHandle.XtraReport Property
XtraReportCursorHandle Class XtraReportCursorHandle Members DroopyEyes.EcoExtensions.XtraReports Namespace See Also
Collapse All

Identifies the XtraReport that controls the position of this component's RootHandle.

C#
public XtraReportBase XtraReport;
Remarks

The XtraReport component controls the current position of its DataSource property. The XtraReport (which may be the main report, or a sub report) that controls the position of this component's RootHandle must be selected so that this component can determine whenever the report scrolls to a new data row.

See Also
XtraReportCursorHandle Class
XtraReportCursorHandle Members
DroopyEyes.EcoExtensions.XtraReports Namespace


XtraReportCursorHandle Events

XtraReportCursorHandle Events
Public Events
Collapse All

The events of the XtraReportCursorHandle class are listed here.

Public Events
Name | Description
PositionChanged | Executed whenever the value of Position is changed.


XtraReportCursorHandle.PositionChanged Event

XtraReportCursorHandle.PositionChanged Event
XtraReportCursorHandle Class XtraReportCursorHandle Members DroopyEyes.EcoExtensions.XtraReports Namespace See Also
Collapse All

Executed whenever the value of Position is changed.

C#
public event EventHandler PositionChanged;
See Also
XtraReportCursorHandle Class
XtraReportCursorHandle Members
DroopyEyes.EcoExtensions.XtraReports Namespace


ObjectValidator Members Public Delegates

ObjectValidator Members Public Delegates
Public Delegates
Name | Description
ConstraintBrokenEventHandler | See DroopyEyes.EcoExtensions.WinForm.ObjectValidator.ConstraintBroken ObjectValidator.ConstraintBroken


ObjectValidator Delegates Public Delegates

ObjectValidator Delegates Public Delegates
Public Delegates
Name | Description
ConstraintBrokenEventHandler | See DroopyEyes.EcoExtensions.WinForm.ObjectValidator.ConstraintBroken ObjectValidator.ConstraintBroken


Inheritance Hierarchy

Inheritance Hierarchy
Inheritance Hierarchy
DroopyEyes.EcoExtensions.AutoContainers.AutoContainerAttribute


Inheritance Hierarchy

Inheritance Hierarchy
Inheritance Hierarchy
DroopyEyes.EcoExtensions.AutoContainers.AutoContainerFactoryAttribute


Inheritance Hierarchy

Inheritance Hierarchy
Inheritance Hierarchy
DroopyEyes.EcoExtensions.AutoContainers.AutoFormFactory


Inheritance Hierarchy

Inheritance Hierarchy
Inheritance Hierarchy
DroopyEyes.EcoExtensions.AutoContainers.AutoFormFactoryException


Inheritance Hierarchy

Inheritance Hierarchy
Inheritance Hierarchy
DroopyEyes.EcoExtensions.CacheFiltering.EcoCacheFilterCollection


Inheritance Hierarchy

Inheritance Hierarchy
Inheritance Hierarchy
DroopyEyes.EcoExtensions.CacheFiltering.EcoCacheFilterCollectionItem


Inheritance Hierarchy

Inheritance Hierarchy
Inheritance Hierarchy
DroopyEyes.EcoExtensions.CacheFiltering.EcoCacheFilterPlugin


Inheritance Hierarchy

Inheritance Hierarchy
Inheritance Hierarchy
DroopyEyes.EcoExtensions.CacheFiltering.ICacheFilter
    DroopyEyes.EcoExtensions.CacheFiltering.EcoCacheTraceFilter


Inheritance Hierarchy

Inheritance Hierarchy
Inheritance Hierarchy
DroopyEyes.EcoExtensions.CacheFiltering.TraceFlags


Inheritance Hierarchy

Inheritance Hierarchy
Inheritance Hierarchy
DroopyEyes.EcoExtensions.Core.Subscriber


Inheritance Hierarchy

Inheritance Hierarchy
Inheritance Hierarchy
DroopyEyes.EcoExtensions.Services.XmlQueryService.XmlNodeProcessor
    DroopyEyes.EcoExtensions.Services.XmlQueryService.AttributeNodeProcessor


Inheritance Hierarchy

Inheritance Hierarchy
Inheritance Hierarchy
DroopyEyes.EcoExtensions.Services.XmlQueryService.XmlNodeProcessor
    DroopyEyes.EcoExtensions.Services.XmlQueryService.CDataNodeProcessor


Inheritance Hierarchy

Inheritance Hierarchy
Inheritance Hierarchy
DroopyEyes.EcoExtensions.Services.XmlQueryService.XmlQueryServiceException
    DroopyEyes.EcoExtensions.Services.XmlQueryService.ContextIsNotAListOfObjectsException


Inheritance Hierarchy

Inheritance Hierarchy
Inheritance Hierarchy
DroopyEyes.EcoExtensions.Services.XmlQueryService.XmlNodeProcessor
    DroopyEyes.EcoExtensions.Services.XmlQueryService.EcoRootNodeProcessor


Inheritance Hierarchy

Inheritance Hierarchy
Inheritance Hierarchy
DroopyEyes.EcoExtensions.Services.XmlQueryService.XmlNodeProcessor
    DroopyEyes.EcoExtensions.Services.XmlQueryService.EcoRootObjectNodeProcessor


Inheritance Hierarchy

Inheritance Hierarchy
Inheritance Hierarchy
DroopyEyes.EcoExtensions.Services.XmlQueryService.XmlNodeProcessor
    DroopyEyes.EcoExtensions.Services.XmlQueryService.ElementNodeProcessor


Inheritance Hierarchy

Inheritance Hierarchy
Inheritance Hierarchy
DroopyEyes.EcoExtensions.Services.XmlQueryService.XmlNodeProcessor
    DroopyEyes.EcoExtensions.Services.XmlQueryService.ForEachNodeProcessor


Inheritance Hierarchy

Inheritance Hierarchy
Inheritance Hierarchy
DroopyEyes.EcoExtensions.Services.XmlQueryService.XmlNodeProcessor
    DroopyEyes.EcoExtensions.Services.XmlQueryService.IfNodeProcessor


Inheritance Hierarchy

Inheritance Hierarchy
Inheritance Hierarchy
DroopyEyes.EcoExtensions.Services.XmlQueryService.XmlQueryServiceException
    DroopyEyes.EcoExtensions.Services.XmlQueryService.InvalidExpressionException


Inheritance Hierarchy

Inheritance Hierarchy
Inheritance Hierarchy
DroopyEyes.EcoExtensions.Services.XmlQueryService.IXmlQueryService
    DroopyEyes.EcoExtensions.Services.XmlQueryService.XmlQueryService


Related Topics

Related Topics
Related Topics

RegisterNodeProcessor, DroopyEyes.EcoExtensions.Services.XmlQueryService.XmlNodeProcessor


Related Topics

Related Topics
Related Topics

GetNodeProcessor, DroopyEyes.EcoExtensions.Services.XmlQueryService.XmlNodeProcessor


Inheritance Hierarchy

Inheritance Hierarchy
Inheritance Hierarchy
DroopyEyes.EcoExtensions.Services.XmlQueryService.XmlQueryServiceException
    DroopyEyes.EcoExtensions.Services.XmlQueryService.MissingRootNodeException


Inheritance Hierarchy

Inheritance Hierarchy
Inheritance Hierarchy
DroopyEyes.EcoExtensions.Services.XmlQueryService.XmlQueryServiceException
    DroopyEyes.EcoExtensions.Services.XmlQueryService.RequiredAttributeMissingException


Inheritance Hierarchy

Inheritance Hierarchy
Inheritance Hierarchy
DroopyEyes.EcoExtensions.Services.XmlQueryService.XmlNodeProcessor
    DroopyEyes.EcoExtensions.Services.XmlQueryService.SwitchNodeProcessor


Inheritance Hierarchy

Inheritance Hierarchy
Inheritance Hierarchy
DroopyEyes.EcoExtensions.Services.XmlQueryService.XmlQueryServiceException
    DroopyEyes.EcoExtensions.Services.XmlQueryService.UnexpectedAttributeException


Inheritance Hierarchy

Inheritance Hierarchy
Inheritance Hierarchy
DroopyEyes.EcoExtensions.Services.XmlQueryService.XmlQueryServiceException
    DroopyEyes.EcoExtensions.Services.XmlQueryService.UnexpectedAttributeValueException


Inheritance Hierarchy

Inheritance Hierarchy
Inheritance Hierarchy
DroopyEyes.EcoExtensions.Services.XmlQueryService.XmlQueryServiceException
    DroopyEyes.EcoExtensions.Services.XmlQueryService.UnknownNodeTypeException


Inheritance Hierarchy

Inheritance Hierarchy
Inheritance Hierarchy
DroopyEyes.EcoExtensions.Services.XmlQueryService.XmlNodeProcessor
    DroopyEyes.EcoExtensions.Services.XmlQueryService.ValueNodeProcessor


Inheritance Hierarchy

Inheritance Hierarchy
Inheritance Hierarchy
DroopyEyes.EcoExtensions.Services.XmlQueryService.XmlNodeProcessor
    DroopyEyes.EcoExtensions.Services.XmlQueryService.AttributeNodeProcessor
    DroopyEyes.EcoExtensions.Services.XmlQueryService.CDataNodeProcessor
    DroopyEyes.EcoExtensions.Services.XmlQueryService.EcoRootNodeProcessor
    DroopyEyes.EcoExtensions.Services.XmlQueryService.EcoRootObjectNodeProcessor
    DroopyEyes.EcoExtensions.Services.XmlQueryService.ElementNodeProcessor
    DroopyEyes.EcoExtensions.Services.XmlQueryService.ForEachNodeProcessor
    DroopyEyes.EcoExtensions.Services.XmlQueryService.IfNodeProcessor
    DroopyEyes.EcoExtensions.Services.XmlQueryService.SwitchNodeProcessor
    DroopyEyes.EcoExtensions.Services.XmlQueryService.ValueNodeProcessor
    DroopyEyes.EcoExtensions.Services.XmlQueryService.XmlQueryNodeProcessor


Related Topics

Related Topics
Related Topics

BeforeProcessNode, AfterProcessNode


Related Topics

Related Topics
Related Topics

ProcessNode, AfterProcessNode


Related Topics

Related Topics
Related Topics

Context, BeforeProcessNode, AfterProcessNode, ProcessChildNodes


Inheritance Hierarchy

Inheritance Hierarchy
Inheritance Hierarchy
DroopyEyes.EcoExtensions.Services.XmlQueryService.XmlNodeProcessor
    DroopyEyes.EcoExtensions.Services.XmlQueryService.XmlQueryNodeProcessor


Inheritance Hierarchy

Inheritance Hierarchy
Inheritance Hierarchy
DroopyEyes.EcoExtensions.Services.XmlQueryService.XmlQueryServiceException
    DroopyEyes.EcoExtensions.Services.XmlQueryService.ContextIsNotAListOfObjectsException
    DroopyEyes.EcoExtensions.Services.XmlQueryService.InvalidExpressionException
    DroopyEyes.EcoExtensions.Services.XmlQueryService.MissingRootNodeException
    DroopyEyes.EcoExtensions.Services.XmlQueryService.RequiredAttributeMissingException
    DroopyEyes.EcoExtensions.Services.XmlQueryService.UnexpectedAttributeException
    DroopyEyes.EcoExtensions.Services.XmlQueryService.UnexpectedAttributeValueException
    DroopyEyes.EcoExtensions.Services.XmlQueryService.UnknownNodeTypeException


Inheritance Hierarchy

Inheritance Hierarchy
Inheritance Hierarchy
DroopyEyes.EcoExtensions.Services.XmlQueryService.XmlQueryServiceExceptionThrower


Inheritance Hierarchy

Inheritance Hierarchy
Inheritance Hierarchy
DroopyEyes.EcoExtensions.Validation.IConstraint
    DroopyEyes.EcoExtensions.Validation.Constraint


Inheritance Hierarchy

Inheritance Hierarchy
Inheritance Hierarchy
DroopyEyes.EcoExtensions.Validation.ConstraintBrokenEventArgs


Inheritance Hierarchy

Inheritance Hierarchy
Inheritance Hierarchy
DroopyEyes.EcoExtensions.Validation.CreateConstraintArgs


Inheritance Hierarchy

Inheritance Hierarchy
Inheritance Hierarchy
DroopyEyes.EcoExtensions.Validation.IConstraintProvider
    DroopyEyes.EcoExtensions.Validation.ModeledConstraintProvider


Related Topics

Related Topics
Related Topics

IConstraint


Related Topics

Related Topics
Related Topics

IConstraintProvider.GetConstraintsForObject(Eco.ObjectRepresentation.IObject, ref System.Collections.ArrayList)


Related Topics

Related Topics
Related Topics

IConstraintProvider.GetConstraintsForObject


Related Topics

Related Topics
Related Topics

IConstraintProvider.GetConstraintsForObjects(Eco.ObjectRepresentation.IObjectList, ref System.Collections.ArrayList)


Related Topics

Related Topics
Related Topics

IConstraintProvider.GetConstraintsForObjects


Inheritance Hierarchy

Inheritance Hierarchy
Inheritance Hierarchy
DroopyEyes.EcoExtensions.WinForm.DirtyObjectCatcherException
    DroopyEyes.EcoExtensions.WinForm.ConflictingUpdateException


Example

Example

private void Form1_Shown(object sender, EventArgs e) { DirtyObjectCather1.Activate(this, EcoSpace); }


Inheritance Hierarchy

Inheritance Hierarchy
Inheritance Hierarchy
DroopyEyes.EcoExtensions.WinForm.DirtyObjectCatcher


Inheritance Hierarchy

Inheritance Hierarchy
Inheritance Hierarchy
DroopyEyes.EcoExtensions.WinForm.ObjectValidator


Inheritance Hierarchy

Inheritance Hierarchy
Inheritance Hierarchy
DroopyEyes.EcoExtensions.WinForm.ObjectValidatorException


Inheritance Hierarchy

Inheritance Hierarchy
Inheritance Hierarchy
DroopyEyes.EcoExtensions.XtraReports.XtraReportCursorHandle