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Responsibility will not be taken for the correctness of the information contained in this manual. The information is 
subject to modification without prior notice. combit GmbH does not accept any liability in connection with this 
document. The availability of many of the functions described in this manual (e.g. the procedure for accessing the 
functions) will depend on your system's version and release, the installed service packs (e.g. operating system, 
word processing software, mail client, etc.) and the configuration of the system. If in doubt, please ask the 
computer administrator. 

This manual or excerpts from this manual may not be copied or duplicated in any other form (e.g. digital) without 
the written approval of combit GmbH. 
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1. Introduction 

With combit Report Server, you can open business intelligence reports and other projects via the browser, display 
them, work on them and make them available to other users.  

The basis of all the reports and other printing projects is provided by the so-called report templates. These can be 
organized in clearly-presented file structures and protected by access rights. Within these individual report 
templates, the data source on which the report is based is then selected. 

In doing this, you can choose from a variety of possible database systems (e.g. Microsoft SQL Server, Oracle, DB2) 
and files (e.g. Access, Excel, CSV) as data sources. 

Once set up, reports can then be created and sent in a planned way, for example on the first of each month a 
report can be automatically saved to a directory or sent via email. 

combit Report Server is a flexible, scalable and reliable report creation system which can be integrated seamlessly 
into your IT infrastructure. combit Report Server is installed on a Windows Server operating system; for internal 
databases, combit Report Server requires a database server (Microsoft SQL Server or PostgreSQL). To spread the 
load, so-called worker services can be installed on additional computers. 

combit Report Server is then accessed by the user direct via the browser.  

The actual reports or print templates are created and processed in the Ad-hoc designer or in the combit Report 
Server Designer. The combit report Server Designer is a Windows application, which is normally called up directly 
from the associated report templates. The Ad-hoc Designer is a browser application. The data defined in the report 
template is available in both designers to prepare it for output in different ways. The Designer thus always relies 
on data which are supplied by combit Report Server, i.e. the data are selected and compiled based on the definition 
of the report template in combit Report Server.  

The Report Server Designer provides the project types lists, labels, and cards; the Ad-hoc Designer knows tables 
and diagrams. The projects contain objects for the output of text, images, tables, etc. 

This documentation supports you in reaching the right decisions and producing a reliable, powerful report 
preparation system for your company. 

1.1 System requirements 
The system must fulfil the following requirements in order for the application to run correctly. 

The availability of some of the functions described (e.g. the procedures for accessing them) will depend on the 
edition, version, release status, downloaded service packs etc. of your system (e.g. operating system) as well as 
its configuration. Some of the functions may not be available to all operating systems. Any limitations will be 
mentioned in the appropriate section. 

1.1.1 Application server 

▪ Windows 10 (Version 21H2 - 22H2, Pro/Enterprise Edition, 64-Bit only), Windows 11 (Version 22H2 - 25H2, 
Pro/Enterprise Edition), Windows Server 2019 - 2025 (64-Bit only) 

▪ Minimum 1,2 GB hard drive space. 

▪ For caching, we recommend at least 2 GB hard disk space. 

1.1.2 Database system (for the system database) 

The internal system database is required for saving report templates and configuration purposes. The database 
system can run on the same server as the application server. 

▪ Microsoft SQL Server 2012 SP4 - 2022 (including Express Edition). Please see the respective Microsoft 
references (e.g. https://www.microsoft.com/en-us/sql-server/) for information regarding system requirements 
and configuration. 

▪ PostgreSQL 12 - 17. Please see the respective PostgreSQL references (e.g. https://www.postgresql.org/) for 
information regarding system requirements and configuration. 

1.1.3 Worker Service 

If roughly 20 parallel print jobs or more are used (depending on the efficiency of the server), we recommend 
installation of the Worker Service so that computer performance will be distributed among other systems.  

▪ Windows 10 (Version 21H2 - 22H2, 64-Bit only), Windows 11 (Version 22H2 - 25H2), Windows Server 2019 - 
2025 (64-Bit only) 

1.1.4 combit Report Server Designer 

The combit Report Server Designer will be needed for designing report templates. 

▪ The external Designer is an application that will run on 32- and 64-bit operating systems. 

https://www.microsoft.com/en-us/sql-server/
https://www.postgresql.org/
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▪ Windows 10 (Version 21H2 - 22H2), Windows 11 (Version 22H2 - 25H2), Windows Server 2019 - 2025 

▪ Minimum 200 MB hard drive space. 

1.1.5 Access to the combit Report Server 

Note: Version numbers can change frequently. combit tries to provide the required changes for new versions, 
so that the latest version is supported, however combit does not assure that. Older versions which are no longer 
supported by the respective manufacturer ("end-of-life") may still be used, however combit does not assure that 
either. 

▪ Supported desktop browsers: Google Chrome, Microsoft Edge (Chromium), Mozilla Firefox, Apple Safari. 

▪ Supported mobile browsers: Android, Apple iOS. 

▪ JavaScript and cookies must be enabled (at least for the session). 

1.2 Installation 

1.2.1 Server installation 

Tip: Administration rights will be required for installation. The installation program must perform the installation 
process. 

1. Prior to installation, close any applications that are running on the system. During the installation procedure, 

disable all anti-virus software.  

2. Insert the DVD in the DVD drive and follow the instructions. If installation does not start automatically, you can 

start it by double-clicking the file "setup.exe". 

3. Destination folder: Enter a server directory as the installation directory. 

4. Feature selection: Now select "Install Report Server". For more information on installing the Worker Service, 

refer to Section "1.2.3 Worker Service installation". 

5. Database System Selection: combit Report Server requires a database server (Microsoft SQL Server or 

PostgreSQL). If an already available instance should be used, the specification of the database server and the 

associated login information for the database administrator can be entered after the installation. Setup will 

then be able to create the system database on the database server.  

▪ Installing Microsoft SQL Server Express Edition: After selecting this option, Setup will install a new English 
instance of Microsoft SQL Server Express on the computer. This option will perform the installation 
smoothly regardless of whether installations of MSSQL are already available or not, which is the reason 
for recommending it.  

A new named SQL Express instance, called "CMBTREPORTSERVER" will be installed with the user “sa”. 
You must enter a password for this user.  

▪ Installing PostgreSQL: If you want to use PostgreSQL server, it must first be downloaded and installed. 
combit Report Server should be installed afterwards. 

Cache Folder: Select the storage location for the temporary files. Please note that this folder´s size can quickly 
increase to several gigabytes. 

Installation wizard: After the server has been installed, the installation wizard will prepare combit Report Server for 
initial start-up. 

Enter the database connection that should be used for setting up the internal database: 

▪ Select the Database system. 

▪ Under Server, enter the name of the database server that was installed during setup.  

Important: When using PostgreSQL as a database system (for the system database), the IP address of 
the Report Server system must be stored in the pg_hba.conf file of the PostgreSQL installation before 
proceeding with the installation of the Report Server. For more information, see 
https://www.postgresql.org/docs/current/auth-pg-hba-conf.html. 

▪ Enter the login data for the database server. 

In addition, a new database user, "cmbtreportserver_user", will be created, which will be used by combit Report 
Server. Enter a password for this user. This password should not be changed in the future. 

6. Set up the administrator account: Set the password for the Administrator account and enter an e-mail address. 

https://www.postgresql.org/docs/current/auth-pg-hba-conf.html
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7. Entering the license key: The required license information can be found in the "PersonalLicense.txt" file in the 

main directory of your List & Label installation. 

8. After installation, combit Report Server Designer can be installed on the workstations. For more information 

on installation, refer to Chapter "combit Report Server Designer". 

9. The following steps are necessary: 

▪ Create user groups and assign rights 

▪ Create users and allocate to groups 

▪ Define data sources 

▪ Define the folder structure for the report templates 

▪ Prepare any report templates. 

1.2.2 Designer installation 

After installing the server, combit Report Server Designer can be setup on the workstations. 

▪ The installation program will be downloaded automatically as soon as the Designer is started. Run the 
installation program. 

▪ Administrator rights are required for installation, in part. These rights can be confirmed via a dialog. 

▪ Select the installation directory from the Destination folder dialog. The Designer is a 32-bit application that will 
run on 32- and 64-bit operating systems. 

▪ After a successful installation, the Designer can be launched from the desktop shortcut. The first time you 
start the application, you need to enter the combit Report Server URL. In the login dialog, enter your username 
and password. The checkbox "Force Login" automatically ends a possibly existing parallel session of the same 
user. 

▪ In the directory "Tools", the Designer installation program is also available as an msi file and can therefore be 
distributed automatically, e.g. via group policy. The license agreement can be accepted per parameter: 

RS31DesignerSetup.msi /q IACCEPTCOMBITLICENSETERMS=True 

1.2.3 Worker Service installation 

If roughly 20 parallel print jobs or more are used (depending on the efficiency of the server), we recommend 
installation of the Worker Services so that computer performance will be distributed among other systems.  

Important: When using PostgreSQL as a database system (for the system database), the IP address of the 
Worker Service system must be stored in the pg_hba.conf file of the PostgreSQL installation before you start 
installing the Worker Service. For more information, see https://www.postgresql.org/docs/current/auth-pg-hba-
conf.html. 

Tip: combit Report Server must be installed first! 

 

Installation will require administrator rights. The installation program must perform the installation process.  

1. Prior to installation, close any applications that are running on the system. During the installation procedure, 
disable all anti-virus software.  

2. Start the installation for the Worker Service on the computer where the Worker Service should be installed. 

3. Destination folder: Enter the installation directory. 

4. Feature selection: Select "Install Worker Service".  

5. The next step will select the configuration file for the Worker Service (WorkerSettings.config). If this file is not 

yet available, create the file with the help of combit Report Server. The file must be created on the client on 

which the Worker Service is to be installed. To do this, open the combit Report Server in the browser. Go to 

the Management > Worker Services pane. Then select "Install Worker Service" to add a new Worker Service. 

Step 2 of the configuration process will offer the option of downloading the configuration file. 

Tip: The downloaded configuration file will contain strictly confidential information that is used to protect the 
combit Report Server data. Make sure that this file is deleted immediately after it has been used for 
installation of the Worker Service. Do not create any unnecessary copies of this file. Never send this file by 
email! 

https://www.postgresql.org/docs/current/auth-pg-hba-conf.html
https://www.postgresql.org/docs/current/auth-pg-hba-conf.html
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1.3 Update installation 
combit strives to maximize backward compatibility, anyway we generally recommend to test your reports before 
the first productive use.  

1.3.1 Update Server installation 

Proceed as follows: 

1. Backup the database (combitReportServer) directly in the database system and backup the installation 
directory (e.g. C:\Program Files\combit\combit Report Server). 

2. Start the installation of the new version and follow the prompts. 

3. Install the new version in the same folder as the old version. 

1.3.2 Update Designer installation 

After updating the server installation, combit Report Server Designer can be updated on the workstations. 

▪ The update of the designer program will be started automatically as soon as the Designer is started. 

▪ Administrator rights are required for installation, in part. These rights can be confirmed via a dialog. 

▪ You can find further information about this process in the "Designer installation" chapter. 

1.4 Uninstall 

1.4.1 Uninstall server 

Start the uninstallation of the server installation from the control panel of the server. Then select the entry 'combit 
Report Server'. After confirmation prompt, all components of the combit Report Server be removed. Please note 
that the Microsoft SQL Server or PostgreSQL Server used is not uninstalled. 

1.4.2 Uninstall Designer 

Start the uninstallation of the server installation from the control panel of the server. Then select the entry 'combit 
Report Server Designer'. After confirmation prompt, all components of the combit Report Server Designer be 
removed.  

1.5 Service Pack installation 
It is recommended always to have the newest available service pack installed. Hints for installing the Service Pack: 

▪ Make sure that up-to-date backups of your complete combit Report Server installation directory and your 
databases do exist. 

▪ Quit the combit Report Server and combit Report Server Designer on the server and all 
workstations/computers in your network. 

▪ Start the Service Pack installation directly on the server or on any client, where the logged-in Windows user 
has full access to the central installation directory of the combit Report Server. 

▪ If the Service Pack includes also an update of the Report Server Designer, the update of the Designer will be 
started automatically as soon as the Designer is started.  

▪ Administrator rights are required for installation, in part. These rights can be confirmed via a dialog.  

1.6 Security 

1.6.1 Encryption 

The SSL encryption protocol is supported. 

Please note: A fundamental understanding of Microsoft Internet Information Services (IIS) is required. All content 
sent over SSL will not be temporarily stored. The encryption of requests and responses will create an additional 
load on the server. 

1.6.2 Data sources 

Configuring the data sources in the database system so that they will have read-only access is recommended. 

Critical information (e.g. connection strings) will be saved in encrypted format. 
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1.7 Data backup 
We strongly recommend a daily backup of the database (combitReportServer), if your data is being modified more 
frequently you should back it up even several times a day. Please note the fact that this has to be seen in the 
context of your own backup strategy. 
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2. Introduction and operation 
The following provides a general overview of the working environment and the various individual settings. 

2.1 Working environment 
The navigation system provides easy access to the different areas. 

▪ Overview: a dashboard view that shows the report templates that have been recently used and notifications. 
Clicking on a report will provide the most important features: Preview, Quick View, Export, Open in Designer, 
Edit and Schedule Report. 

▪ Report Templates: report definition. 

▪ Report Elements: elements that can be commonly used by multiple report templates. 

▪ Schedule Reports: definition of calendar-based triggers with actions. 

▪ Data Sources: definition of data sources 

▪ Management: users, user groups, export profiles, active print jobs, advanced settings (including additional 
data providers, export jobs, password rules, the user interface and debug mode), system logs, system 
information, licensing, the Worker Service and SMTP configuration 

▪ My Settings: Time zone, language and number of last report templates used in the overview. 

▪ Help 

2.2 Report templates 
The Report Templates pane will display all reports for which the user has access permission. Reports can be 
grouped into folders.  

If you wish to create a new report in the Designer, you must first generate a report template. 

A variety of functions are available. 

▪ Using Show All, folders can be hidden and all reports displayed in alphabetical order. Clicking on Show Folders 
will re-display the reports in their folder structure. 

▪ Use the button with the gear-shaped icon to delete, move and rename folders.  

▪ Use Filter items to reduce the number of list items displayed. Full-text search will search report names and 
descriptions. Use the X button on the filter bar to show the entire list once more. 

▪ Create new reports using Create Report Template, or new folders using Create Folder. 

▪ To generate a report, click on the Quick View magnifier button to the right of a report. 

 
Figure 2.1: Report templates 

2.2.1 Creating report templates 

New reports can be generated using "Create Report Template". 

▪ Choose an appropriate type of report template. You can choose from the basic templates and templates with 
an Ad-hoc designer. 

▪ Basic templates: With these templates, you can create your report using the combit Report Server 
Designer. These offer you complete control over the design of the report, but require more design effort. 
The following templates are available: 

▪ Standard: Tables, lists, diagrams and complex reports. 

▪ Label: Labels and label sheets: 

▪ File card: Letters, master data sheets and forms.  

▪ Invoice: Invoices with items (new page for each record from main table). 
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▪ With serial printing, each new invoice starts on a new page. Therefore, you can enter a main table as the 
data source. The main table refers to the table where the invoice data is stored (invoice date, invoice no., 
invoice recipient, etc.). The fields in this table and all tables linked 1:1 will then be available in the Designer 
as variables in the text fields. 

▪ Ad-hoc templates: With these templates (simple tables or diagrams), you choose from a range of 
preconfigured designs and design your report using the Ad-hoc designer. Later on, you can modify the 
details of the report using the combit Report Server Designer. You will find additional information on the 
Ad-hoc designer in the section "Ad-hoc designer". 

▪ Select the project type 

▪ Labels and cards: These projects are made up of groups of objects which will be printed out individually 
(cards) or in batches (columns and rows, labels) per page.  

▪ Lists: List projects are made up of objects which will be printed out once per page as well as of one or 
more objects which will be printed out using different content depending on the associated records. The 
Designer objects table, crosstab or report container will be responsible for such lists or repeated bands 
and are therefore available only for this type of project. 

▪ Enter a name and description.  

▪ Select the default export profile. Specify the format in which the report should generally be generated (in quick 
view). 

 
Figure 2.2: Creating report templates 

▪ Time for cached exports to expire. Enter the period of time for which a report is not generated when executed 
again. The report will be stored in the cache for this period of time. 

▪ Language: Language to be used when printing, the set language does not affect the Designer preview. Thus, 
for example, despite the english system language of the server, the report template can be printed with e.g. 
german formatting.   

In addition, dependent translations can also be defined via formulas:  

▪ Example: LangCase$("Hello (Default)", "en=Hello|de=Hallo|es=Hola") 

▪ to query language and region: LL.CurrentLanguage 

▪ other useful functions: LocCurr$(), LocNumber$(), LocVal(), LocDate$() 

▪ Define the data source. Select the data source that should be available in this report. Note that a report will no 
longer be able to be generated if you remove a data source without specifying an alternate data source with 
precisely the same table structure. For more information on data sources, refer to the Data sources section. 
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Figure 2.3: Selecting the data source 

▪ Assign report elements to this report template. Report elements are not available in the Ad-hoc designer. 

 
Figure 2.4: Assign report elements 

▪ Determine the groups that will have access rights to this template.  

 
Figure 2.5: Access permissions 

▪ Earlier versions: Click on a version entry to restore a previous version of this report template. Doing so will 
automatically save the current version. 

▪ To accept any changes, save the report template. 

▪ The associated print template can be created, or an existing one edited, in the Designer from the Further 
Options pane. 

Tip: The option of downloading the installation program will be offered, if the Designer has not yet been 
installed on the workstation. For more information on installation, refer to Section "Designer installation". 

2.2.2 Changing or executing report templates 

If you select a report, there are various options available. 

 
Figure 2.6: Details menu of a report template 

Select the appropriate function: 



Introduction and operation Report templates 

13 

▪ Export: Generate the report with the selected export profile. 

▪ Preview: Generate and display the report in the browser. 

▪ Open in Designer or Open in Ad-hoc designer: Open to edit in Designer or in Ad-hoc designer. 

▪ Edit: Change report properties, such as name or data source. 

▪ Schedule Report: Generate a report at a specific time and link with actions (refer to the Schedule reports 
section). 

▪ Other Options: move, duplicate or delete templates. 

Clicking on Properties provides you with access to additional options for further functions: 

▪ Convert (only for Ad-hoc templates): Converting an Ad-hoc report to a regular report template allows you to 
design it using the combit Report Server Designer instead of the Ad-hoc designer. Duplicating a report 
template prior to conversion allows you to retain a copy that you can use with the Ad-hoc Wizard. The Ad-hoc 
designer is no longer available after the conversion! 

▪ Quick View: You can configure quick access functionality (Quick View, Preview, Export) in your personal user 
settings. 

2.2.3 Ad-hoc designer 

With these templates, you can create your report using the Ad-hoc designer. Later on, you can modify details of 
the report using the combit Report Server Designer. 

▪ To use an Ad-hoc template, click on "Create Report Template" and choose an Ad-hoc template. You can choose 
either a simple table or a diagram. 

▪ To edit an Ad-hoc template, choose "Open Ad-hoc designer" in the Properties of the report template. 

▪ To edit an Ad-hoc template in combit Report Server Designer, you can convert it to a regular report template. 
Choose "Convert" in the Properties of the report template. The template can no longer be edited in the Ad-hoc 
designer after the conversion. 

Simple Table 

▪ As with basic templates, enter the name, standard export profile, data source and other properties. 

▪ Click on the "Open Ad-hoc designer" button. This launches the Ad-hoc Wizard and analyzes the data source. 

▪ First choose the base table whose data is to be exported. 

 
Figure 2.7: Selecting the base table 

▪ First, choose the table columns by clicking "Add Columns". 

▪ Click on the plus symbol to select a column. To delete a selected column, click on the minus symbol.  

▪ To return to the overview, click on the arrow at the upper left. 

▪ You can change the order of the columns by dragging the double arrow symbol. 

▪ Click on "Position Columns" to define the column width. 

 
Figure 2.8: Selecting columns 

▪ When you click on a column, you can edit the column properties and add a footer: 
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▪ Specify the title in the header 

 
Figure 2.9: Properties of a numeric column 

▪ Align left, centered, align right, justified 

▪ Display: Numeric (with choice of decimal places), currency (with choice of currency symbol), percent (with 
choice of decimal places). 

▪ Aggregate values:  

▪ With numeric columns, you can activate a footer using the "In table footer" option. This calculates the 
aggregate value for the column as defined in the option box. You can choose from: Average, Count, 
Maximum, Median, Minimum, Standard Deviation, Sum, Variance. 

▪ If the data is to be grouped together for output (see "Sorting and Grouping" below), a group footer 
can be activated using the "In Group Footer" option. Here, you can also choose from Average, Count, 
Maximum, Median, Minimum, Standard Deviation, Sum and Variance to aggregate the numerical 
values. 

▪ You can define the appearance of the report in the "Layout" section: 

▪ Color scheme: choose a predefined design scheme 

▪ Row coloring: Activate zebra pattern 

▪ Size: Choose output format 

▪ Orientation: Portrait or Landscape 

▪ Print Date Position: Do not Show/Use default/Bottom left/bottom centric/Bottom right and the ability to 
select the date format. 

▪ Page numbering position: Do not Show/Use default/Bottom left/bottom centric/Bottom right and the 
possibility to select the page numbering format. 

▪ In the "Sorting and Grouping" section, you can now choose the field according to which the records are to be 
grouped for display. When you define a grouping, a sorting scheme is automatically created based on this 
field. 

If you do not apply grouping, you can create additional (sub-)sorting schemes or create a sorting scheme. 

With grouped data, it is also possible to include group footers (see "Aggregate values" above) 

▪ Under "Filters", you specify which columns will be available for filtering during exports.  

▪ The selected column is added as a report parameter. For more information, refer to "Report Parameters" 
in the section "Advanced Functions" in the Designer-Manual. 

▪  

▪ Click of an entry to configure a filter definition: 

▪ Label of input field 

▪ For date fields: 

▪ Exact date, Define value range (from/to) 

▪ Select year/month/quarter 

▪ Numerical fields: 

▪ Allow no value (NULL) 

▪ Input type: Select from existing values (multi selection), Select from existing values (single 
selection), Manual input, Define value range (from/to) 

▪ For character fields: 



Introduction and operation Report templates 

15 

▪ Allow empty value 

▪ Input type: Select from existing values (multi selection), Select from existing values (single 
selection), Manual input 

▪ Save the changes at the top right and start the preview.  

Chart 

▪ As with basic templates, enter the name, standard export profile, data source and other properties. 

▪ Click on the "Open Ad-hoc designer" button. This launches the Ad-hoc Wizard and analyzes the data source. 

▪ First, choose the table from which data is to be exported.  

▪ Click on the arrow at the top right, choose the chart type and then choose a sub-type:  

▪ Lines/Symbols: Simple, Consecutively, Stacked, Relative to each other 

▪ Areas: Simple, Stacked, Relative to each other 

▪ Bars: Simple (also 3D), Tiled (also 3D), Consecutively (3D), Stacked (also 3D), Relative to each other (also 
3D) 

▪ Circle/Ring: Circle (also 3D), Ring (also 3D) 

▪ Radar/Web: Simple, Consecutively, Stacked, Relative to each other 

▪ Treemap: Simple, With sub-groups 

▪ Funnel: Vertical, Horizontal 

▪ General 

▪ Specify a title for the chart 

▪ Base table: when you change the base table, the diagram is recreated. 

▪ Horizontal Axis (X) (Lines/Areas/Bars), Segmentation (Circle/Ring/Funnel), Category assignment (Radar), 
separation in areas (Treemap): 

▪ Lines, areas, bars: Select the column for the x-coordinate. 

▪ Circle/Ring/Funnel: Select the column for the segment. 

▪ Radar: Select the column for the circle segment. 

▪ Treemap: Select the column for the area. 

▪ The values can be grouped. 

▪ Lines, areas, bars: Labeling of the x-axis 

▪ Only Lines simple/Areas Simple/Bars Simple/Treemap: Vertical Axis (Y) 

▪ Lines, Areas, Bars: Select the column for the height of the line 

▪ Treemap: Select the column for the size of the subarea 

▪ Determine whether the number of all values or the number of unique values is to be used. 

▪ Labeling Y-Axis 

▪ Only Lines, Areas, Bars (each without Simple), Radar: data series (Y/Z-axis) 

One bar will be shown per data series and x-coordinate. Define how the records will be assigned to the 
respective series.  

 
Figure 2.10: Defining data series 
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▪ Define data series by the value of a particular column:  

▪ Specify the column of the data series 

▪ Specify the column for the line height of the data series  

▪ Specify how multiple values are to be aggregated, e.g., count or sumSpecify the aggregation for the 
values, such as number or total. 

▪ Each data series corresponds to a particular column: To add columns to the data series, click on "Add 
Columns". 

▪ Only Circle/Ring/Funnel: Size of Segments 

▪ Select the column for calculating the (relative) segment size. 

 
Figure 2.11: Size of segments 

▪ Specify how multiple values are to be aggregated, e.g., quantity or sum. 

▪ Minimum percentage (%): Especially if you have many values with a small percentage, it might be helpful 
to combine these in an "Other" segment. You can select a threshold value here at which point the various 
segments are combined into a larger one. 

▪ Space between segments (%): The various segments are clearly delineated. This value is the segment 
spacing as a percentage of the radius. 

▪ Segment legend with percentages or absolute values. 

▪ You can change the appearance of the report in the "Layout" section: 

▪ Color scheme: choose a predefined design scheme 

▪ Size: Choose output format 

▪ Orientation: Portrait or Landscape 

▪ Only Ring/Circle: Ring/Circle chart type and flat/3D display mode 

▪ Only Radar: Display values on axis or at data points 

▪ Under "Filters", you specify which columns will be available for filtering during exports.  

▪ The selected column is added as a report parameter. For more information, refer to "Report Parameters" 
in the section "Advanced Functions" in the Designer-Manual. 

▪ Click of an entry to configure a filter definition: 

▪ Label of input field 

▪ For date fields: 

▪ Exact date, Define value range (from/to) 

▪ Select year/month/quarter 

▪ Numerical fields: 

▪ Allow no value (NULL) 

▪ Input type: Select from existing values (multiple selection), Select from existing values (single 
selection), Manual input, Define value range (from/to) 

▪ For character fields: 

▪ Allow empty value 

▪ Input type: Select from existing values (multiple selection), Select from existing values (single 
selection), Manual input 

▪ Save the changes at the top right and start the preview. 
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▪ At the bottom right you can activate the option "Instantly refresh preview when changes are made" via the 
gear-button. This updates the preview image immediately after changing a setting. 

▪ Using the additional option "Limit data volume for faster preview display", you can limit the number of data 
records that are taken into account for printing the preview. This is particularly useful if the "Instantly 
refresh preview when changes are made" option is activated. At a limit of 5, for example, only the first 5 
categories are considered, the first 5 products for each category, the first 5 orders for each product, and 
so on. 

2.3 Report Elements 
When designing similar projects, it is recommended to use "Report Elements" instead of creating recurring 
elements in every project every time. You can include e.g. a picture, a text or also a PDF file very easily and changes 
can be made globally. 

A changed address of your company can be edited e.g. in a single element instead of changing hundreds of reports. 

The definition is made in the "Report Elements" area. In this area all elements are displayed and can be grouped in 
folders. 

 
Figure 2.12: report elements 

A variety of functions are available. 

▪ Using "Show All", folders can be hidden and all elements will be displayed in alphabetical order. Clicking on 
"Show Folders" will display the elements in their folder structure again. 

▪ Use the button with the gear-shaped icon to delete, move and rename folders.  

▪ Use "Filter items" to reduce the number of list items displayed. A full-text search will search element names. 
Use the X button on the filter bar to return to the full list again. 

▪ Create new elements using "Create Report Element", or new folders using "Create Folder". 

Note: Report elements are not available in the Ad-hoc designer. 

2.3.1 Creating report elements 

New elements can be generated using "Create Report Element". 

▪ Select the element type: Text, Formatted Text, Picture, Rich Text Document (RTF), PDF Document, Shapefile. 

Note: The SHP and DBF files of a shapefile must be uploaded together. 

▪ Enter a name and the content (text or file).  

▪ Save the element in the current folder. 

Shapefiles 

You can use your own shape files by defining them as report elements. To do this, select the element type 
"Shapefile". For a shapefile you need the SHP and DBF file, which can only be uploaded together. 

When inserting a diagram of the type "Shapefile" in the designer, a dialog box for template selection opens. Select 
the option "No Template". 
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Figure  2.13: Template selection for shapefile diagram 

In the following dialog box, you can then select the shape file added as a report element: 

 
Figure  2.14: Dialog to load a shapefile 

2.3.2 Changing or executing report elements 

In the Designer, the defined report elements can be found in the variables list in the folder "ReportElements". 

If you select an element, there are various options available. 

▪ Edit: Change element properties, such as name or content. 

▪ Other Options: move, duplicate or delete elements. 

2.3.3 Sub-Reports and Report Includes 

Using the option 'Sub-Reports and Report Includes', you can add entire report templates of the same type as report 
includes and sub-reports to a report template in addition to the report elements. The selected report templates are 
then available in the Designer as report includes or sub-reports. Likewise, all data sources, report elements and 
uploaded images of the linked report template are added when printing and in the Designer. 

 

Figure 2.15: Sub-Reports and Report Includes 
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To add a sub-report or a report include, choose 'Select Report Template' and pick the corresponding report 
template. 

2.4 Data sources 
From here, new data sources can be defined or existing ones edited. 

 
Figure 2.16: Data sources 

2.4.1 General 

A variety of functions are available. 

▪ Create new data sources using 'Create Data Source' or new folders using 'Create Folder'. 

▪ Using 'Show All', folders can be hidden and all Data sources displayed in alphabetical order. Clicking on Show 
Folders will re-display the data sources in their folder structure. 

▪ Use 'Filter items' to reduce the number of list items displayed. For this, the data source names, types and 
descriptions will be searched using full text methods. Use the X button on the filter bar to show the entire list 
once more. 

▪ Click on a data source to edit or duplicate it. 

▪ Use the button with the gear-shaped icon to delete, move and rename folders.  

2.4.2 Creating data sources 

▪ Use Create Data Source to create new data sources. 

▪ Select the data source type. 

 
Figure 2.17: Setting up a new data source 

Data sources which use individual database files generally support both local files on the web server as well 
as files from network shares. XML- and JSON-based data sources can also download files from the Internet. 

▪ Define the general properties: 

▪ Name 

▪ Description 

▪ Specify the groups that have access rights. Without such an assignment, no user group will be able to access 
the data source and therefore it cannot be used for creating reports. 

▪ Click the Configure button. From there, access to the database and which data will be made available, if that 
data source is available, will be determined. 
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2.4.3 Configuration settings 

Various configuration options are available depending on the data source.  

• If the Worker Service is being used, "localhost" paths may not be used as server names. 

• When using file based data sources (e.g. SQLite, CSV) the data source (file) will be copied to the cache 
directory on the web server before accessing it. This process can take some time depending on the file 
size. This is necessary as not all data sources support concurrent access (e.g. by multiple users). It is 
recommended to set the time for cached exports to expire accordingly for the respective report templates 
to avoid frequent copying of the data source.  

SQL databases 

Connection settings Firebird, IBM DB2, MariaDB, Microsoft Azure SQL, Microsoft SQLServer, MySQL, Oracle, 
PostreSQL, SQLite 

▪ Basic settings: Specify the server (<Server name> 
[\<Instance name>][:<Port>] and select the type of authentication. Both SQL Server and Windows 
authentication are supported as methods for logging in.  

Windows authentication represents the highest level of security and also uses Windows user accounts for the 
logging into the SQL Server. 

SQL Server authentication (if such is supported by the server) will also allow external access. 

▪ Expert mode: For special connection settings, you can enter the connection string manually. 

Examples of connection strings: 

Firebird: User=SYSDBA;Password=masterkey;Database=myDataBase.fdb; 
DataSource=localhost;Port=3050;Dialect=3;Charset=NONE; Role=;Connection 
lifetime=15;Pooling=true;MinPoolSize=0; MaxPoolSize=50;Packet Size=8192;ServerType=0 

Microsoft Azure SQL: Server=tcp:myServerName.database.windows.net; Database=myDataBase;User 
ID=myUsername@myServerName; Password=myPassword;Trusted_Connection=False;Encrypt=True; 

Microsoft SQL Server: Server=myServerAddress;Database=myDataBase;User 
Id=myUsername;Password=myPassword; 

PostgreSQL: Server=127.0.0.1;Port=5432;Database=myDataBase;User  
Id=myUsername;Password=myPassword; 

MySQL: Server=myServerAddress;Port=3306;Database=myDataBase; 
Uid=myUsername;Pwd=myPassword; 

In special cases it may be necessary to increase the timeout directly in the connection string. Information about 
connection strings and possible parameters, see https://www.connectionstrings.com. 

Example for Postgres: 

Server=127.0.0.1;Port=5432;Database=myDataBase;User 

Id=myUsername;Password=myPassword;CommandTimeout=20;Timeout=15; 

Selecting data 

The database can be used as a data source in different ways.  

▪ Full Database: all tables and views will be available, to which the specified connection has access.  

▪ Selected tables: Only the selected tables and views are available. 

▪ Single Queries: Define any number of custom SQL queries, whose results can then be used by reports.  

▪ Add SQL Query: Enter the query. Test the query using the respective button. Any number of queries may 
be entered. 

Example for a single query: 

SELECT users.type,  sale.date_finished::date AS date, 

SUM(sale_position.amount) AS total_amount 

FROM public.sale_position, public.sale, public.users 

WHERE sale.date_finished IS NOT NULL  

GROUP BY sale.date_finished::date, users.type 

ORDER BY users.type, date; 

https://www.connectionstrings.com/
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▪ Add Query (Assistant): With some data sources (MS SQL, Oracle, MySQL, MariaDB, PostgreSQL, SQLite), 
a wizard is available for creating database queries. More information on the wizard is given in the section 
"Query-Assistant". 

▪ Add Routine (Wizard): For some data sources, routines (stored procedures, table value functions) can be 
added with the defined parameters (including support for data source parameters). These routines can 
also return data and be used directly in the Report Server. 

Supported data sources:  

▪ MSSQL: Stored Procedures, Table-Valued Functions 

▪ MySQL/MariaDB: Stored Procedures 

▪ PostgreSQL: Table-Valued Functions (At least 2 columns within the table return) 

▪ Oracle: Stored Procedures (table return only) 

▪ Schema: With some data sources (MS SQL, Oracle, DB2), you can specify a scheme to only load tables with 
this scheme. Depending on the type of data source, you can also specify multiple schemes (e.g., separated 
by commas). Particularly in relatively large databases, this can provide a clearer overview and increase 
processing speed. 

▪ Relations: You can define the relations between the various queries or add further relations to the automatically 
determined relations. The database structure will be analyzed, such that that all the user has to do is simply 
select the relevant tables and fields. Proceed as follows: 

4. Choose "Add Relation"  

5. Enter a table alias (relation name). This name is displayed below the 1:n linked child table beneath the parent 
table in the  Designer. 

6. Choose the parent table and the primary key field. 

▪ Chose the child table and the foreign key field that corresponds to the primary key of the parent table. 

 
Figure 2.18: Defining relations 

Database schemas 

The option "Use schema prefix for table names" is available for several databases. A database schema allows a 
logical separation of tables. E.g. tables with the same name can be used within the same database. 

Microsoft Access connection settings 

▪ Server URL: File path or URL[:Port] 

▪ User name and password 

▪ Database password 

Query-Assistant 

The Wizard for single queries is a highly flexible method of easily creating queries so that only certain types of 
records are available as data sources. You can define and combine any number of conditions and also group 
conditions. The Wizard is available for the following data sources: Microsoft SQL, Oracle, MySQL, PostgreSQL, 
SQLite and MariaDB. 

▪ In the Data section, choose the Single Queries option and click on Add Query (Assistant). 
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▪ Choose the table and the fields that will be passed to the query. This is equivalent to defining the SELECT 
<Fields> FROM <Table> section of the SQL query. 

▪ By clicking on the green plus sign, a context menu appears where you can choose whether to add a condition 
(WHERE) or create a new group. 

▪ Click on a condition to edit/change it. 

▪ Remove a condition by clicking on the X symbol. 

▪ By clicking on an operator, you can move the group up or down, move it into a new group or integrate it into 
a parent group. 

Click on "Convert to SQL Query" to convert the query created in the assistant to a regular SQL query. This allows 
you to process the query directly using SQL instead of the assistant. The assistant is no longer available for this 
query after the conversion! 

Add (WHERE) condition 

You can define any number of conditions and thereby access all of the displayed fields. 

▪ To define a condition, click on the green plus symbol in the Query Assistant and then "Add Condition". 

 
Figure 2.19: Define condition or group 

▪ In the "Fields" list, click on the field that contains the desired property.  

The symbols show the respective field types (alphanumeric, numeric, date, logical). 

 
Figure 2.20: Define condition 

▪ Select the desired operator from the "Operators" list. Operators that are permissible for the field selected will 
be displayed (e.g. equal to, not equal to, begins with, contains, is empty). 

▪ Enter or select the property (Fixed value) to be searched for in the "Comparative value" box or compare the 
property with another field in the same table (Field).  

▪ Example for fixed value: Status = "won" 

▪ Example for field: Start date greater than planned date. 

▪ For date (time) fields, the following additional functions are available: Year(), Quarter(), Month(), Day(), 
Hour(), Minute(), Second(). Select one of the functions and enter a comparative value. 

Example: All orders from year "2016". 

▪ If desired, specify "Case sensitive" for the input fields 

Note:  The "Case sensitive" option can only be executed when this has been configured in the database 

server.  

▪ To return to the Filter Assistant, select "OK". 

▪ To add an additional condition, click on the green plus sign. You now have the following options: 

▪ Add condition 
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▪ Create new group 

▪ Click on "Test Query" to check the query. 

Creating Groups 

Multiple conditions are combined into a group and groups can also contain additional groups. They can be created 
in various manners and any number of hierarchies are supported: 

▪ To create a new group, click on the green plus sign and select "Create new group" from the context menu.  

▪ By clicking on an operator (e.g., "all"), you can move the group up or down, move it into a new group or integrate 
it into a parent group. 

 
Figure 2.21: Link or edit conditions 

By default, for each group, the operator is set to "all". To change the operator, click on it and choose one of the 
logical operators: 

▪ All (AND): All conditions must match  

▪ Any (OR): Any of the conditions must match  

 
▪ Not any (NOT AND, NAND): One of the conditions must not match 

Example: All except (Country = "DE" and Category="Newsletter")  

Number of matches: All except "DE" and all "DE" without "Newsletter" 

▪ None (NOT OR, NOR): None of the conditions may match. 

Example: All except (Country = "DE" NOR Country = "CH" NOR Country "AT") 

Number of matches: All except "DE", "CH", "AT" 

General interfaces 

GraphQL connection settings 

▪ Server URL: URL[:Port] 

▪ Username and Password 

▪ HTTP Header: Define HTTP headers, for example, to specify an authentication key. 

▪ Timeout: For very large, complex results, a timeout can be specified. 

▪ Queries Root Name: Default name of the query object: Query 

▪ Mutations Root Name: Default object name of the mutations: Mutation 

OData connection settings 



Introduction and operation Data sources 

24 

▪ Server URL: URL[:Port] 

▪ Username and Password 

▪ HTTP Header: Define HTTP headers, for example, to specify an authentication key. 

▪ Timeout: For very large, complex results, a timeout can be specified. 

▪ Retrieve real values for the Designer: Using this option you can display live data in the Designer. 

ODBC connection settings 

▪ Example of a connection string: Driver={SQL Server};Server=myServerAddress 
;Database=myDataBase;Uid=myUsername;Pwd=myPassword; 

OLE DB connection settings 

▪ Example of a connection string: Provider=Microsoft.ACE.OLEDB.12.0;Data Source=\\myServer\myFile.mdb 

REST connection settings 

▪ Server URL: URL[:Port]. Data source parameters can be inserted into the URL using the syntax 
{{ParameterName=StandardValue}}. For more information, see the "Data source parameters" section. 

▪ Username and Password 

▪ HTTP Header: Define HTTP headers, for example, to specify an authentication key. 

▪ Timeout: For very large, complex results, a timeout can be specified. 

▪ JSON configuration: Name of the root table. If no value is defined, the default value of the data source is used. 

▪ In-Memory mode: With this option all data will be loaded into memory at first. This leads to a longer loading 
phase of the data source, however results in faster queries afterwards. Using this option leads to an increased 
load on the server and can require adjusting report templates as the data type of columns with unusual data 
types might change. 

REST connection settings with OAuth 2.0 

▪ In the configuration dialogue, select “OAuth 2.0” as the authentication type and start setting up the connection. 

▪ Enter the “Authorization endpoint”, „Access token endpoint”, “Grant Type”, “Client ID”, “Client Secret”, 
“Refresh Token” and, if required, the “Access areas (scope)”. This information is app-specific. Please refer to 
the manufacturer’s documentation. 

▪ Complete the authentication via „Request Refresh Token” 

NoSQL databases  

Connection settings Apache Cassandra 

▪ Server URL: Server[:Port] 

▪ Keyspace 

Connection settings CouchDB 

▪ Server URL: Server[:Port] 

▪ Username and Password 

▪ Database Name  

▪ View Name 

▪ Prefix 

Connection settings MongoDB 

▪ Server URL: Server[:Port] 

▪ Username and Password 

▪ Database Name 

Tip: The REST API must be enabled for a MongoDB data source. This is started with - - rest. This API currently 
does not support authentication, meaning that it has full read access after activation. 

Connection settings Redis 

▪ Connection String: Server[:Port] 

Note: Options and connection string are described e.g. here: 

https://stackexchange.github.io/StackExchange.Redis/Configuration#configuration-options 

▪ Separator-separated list of hash tables to be registered (separator: '|') 

▪ Compare-function for hash tables: Starts with / Ends with / Contains. 

https://stackexchange.github.io/StackExchange.Redis/Configuration%23configuration-options
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Note: Since no real tables with multiple columns are available, multiple hashtables are created with a 

specific pattern to allow multiple rows. For example, there is no table "user" with record 1, 2 and 3, but 3 

hash tables with the names user:1, user:2 and user:3. So that the Report Server recognizes which hash 

tables belong together, they must be defined separately with a "|" and the comparison function must also 

be used to specify how this name is to be checked. 

File-Based Data Sources 

Important: Please note that the Report Server on the server is not running under the account of a domain user, 
but under the user "IIS_USER". This means that for file-based data sources, e.g. located on the server of the 
Report Server, their access permissions must be set up for the same user "IIS_USER". 

CSV connection settings 

▪ Server or file path: File path or URL[:Port] 

▪ Username and Password 

▪ Table name 

▪ Separator character: enter \t for the TAB separator 

▪ Framing character 

▪ Number of rows to skip 

▪ The first row contains column names: first line is a header 

▪ Allow breaks in field contents (if framing character is set) 

▪ In-Memory mode: With this option all data will be loaded into memory at first. This leads to a longer loading 
phase of the data source, however results in faster queries afterwards. Using this option leads to an increased 
load on the server and can require adjusting report templates as the data type of columns with unusual data 
types might change. 

JSON connection settings 

▪ Server or file path: File path or URL[:Port]. Data source parameters can be inserted into the URL using the 
syntax {{ParameterName=StandardValue}}. For more information, see the "Data source parameters" section. 

▪ Username and Password 

▪ Name of the root table. If no value is defined, the default value of the data source is used. 

▪ In-Memory mode: With this option all data will be loaded into memory at first. This leads to a longer loading 
phase of the data source, however results in faster queries afterwards. Using this option leads to an increased 
load on the server and can require adjusting report templates as the data type of columns with unusual data 
types might change. 

Microsoft Excel connection settings 

▪ Server or file path: File path or URL[:Port] 

▪ Username and Password 

▪ Sheet names: Several Excel worksheets, which must be setup as tables, can be specified using a comma-
separated values format. 

▪ The first row contains column names: first line is a header 

▪ In-Memory mode: With this option all data will be loaded into memory at first. This leads to a longer loading 
phase of the data source, however results in faster queries afterwards. Using this option leads to an increased 
load on the server and can require adjusting report templates as the data type of columns with unusual data 
types might change. 

RSS/XML connection settings 

▪ Server or file path: File path or URL[:Port] 

▪ Username and Password 

▪ In-Memory mode (for XML data sources): With this option all data will be loaded into memory at first. This 
leads to a longer loading phase of the data source, however results in faster queries afterwards. Using this 
option leads to an increased load on the server and can require adjusting report templates as the data type of 
columns with unusual data types might change. 

Tip: The Atom format is not supported for a RSS data source. 

Other data providers 

Google Analytics and Google BigQuery connection settings 
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You need a valid Google account and must provide access to the database via the Google Developers Console. 
Proceed as follows: 

▪ Open with https://console.developers.google.com/project the Google Developers Console 

▪ Create a new project if there is none yet. By doing that a Project ID will be created. This value is needed for 
the connection settings. 

▪ Go to Project name > Permissions and select "Add Member". Provide your email address and define the 
authorization (Is owner, Can edit, Can view). The new member now receives an invitation. 

▪ Subsequently, this account must be authenticated using OAuth 2.0. Select "APIs & auth > Credentials" and 
create a new Client ID in the "OAuth" section by using the corresponding button. As application type select 
"Installed application" (Installed application type: Other). The Client ID and Client secret will be displayed 
afterwards. Both values are needed for the connection settings. 

▪ Select "APIs & auth > Consent screen" and enter at least one email address and the product name. The consent 
screen will be shown to users whenever you request access to their private data using your client id. 

Enter the corresponding values in the combit Report Server data source: 

▪ ProjectID, Client ID and Client Secret 

▪ Refresh Token: To set the Refresh Token, click on "Request Refresh Token". A dialog will be displayed where 
you can request a code. When clicking "Request code" the Google website will be opened in a new tab. Please 
login with your Google account and accept the access. Copy the generated code into the clipboard and return 
to the dialog. Paste the copied code into the input field. The code will be converted into a Refresh Token. 

▪ Single Queries: Define at least one SQL query to limit the data, e.g. SELECT <col1>, <col2> FROM 
[<ProjectID>:<dataset>.<table>] 

Google Sheets connection settings 

You need a valid Google account and must provide access to the data via Google Sheets or the Google Developers 
Console. Proceed as follows: 

▪ Table ID: For the table ID refer to the release link (see below). 

▪ Sheet names: E.g. "Sheet1". Multiple spreadsheets that should be provided as tables can be specified comma-
separated. 

▪ Data source is published on the web: Publish a file in Google Sheets via "File > Publish to the web". The 
generated link contains the table ID, e.g. 

https://docs.google.com/spreadsheets/d/<Table ID>/pubhtml. 

If the data source is not published on the web, the data must be enabled to read via the Google Developers 
Console. For Client ID, Client Secret and Refresh Token see "Google Analytics and Google BigQuery connection 
settings". 

Connection settings Progress OpenEdge Server 

▪ Server URL: URL Apache Tomcat REST Backend 

▪ User name and password: User and password Apache Tomcat Rest Backend (optional) 

▪ Service Name: ABL class name of the OpenEdge Service 

▪ Prerequisite Progress OpenEdge Server 

▪ Apache Tomcat 

▪ Progress OpenEdge State-free AppServer 

▪ ABL Backend on the AppServer in the Propath. 

Connection settings Salesforce 

You need a valid Salesforce Developer license. Access is via the Force.com Soap API. 

▪ Server URL: https://login.salesforce.com/services/oauth2/token 

▪ Username and Password 

2.4.4 Relations 

In addition to the possibility to define further relations within the same SQL data source (see section "SQL 
databases"), you can also define relations between different data sources, e.g. CSV file to SQL server and use them 
accordingly in the designer. 

The relations between different data sources are defined individually for each report template. To do this, first 
select the required data sources and then supplement the required relations between these data sources. 

https://console.developers.google.com/project
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Figure 2.22: Settings for a scheduled report 

1. Choose "Add Relation" and enter a table alias (relation name). This name is displayed below the 1:n linked child 
table beneath the parent table in the  Designer. 

 
Figure 2.23: Define relations 

2. Choose the parent table and the primary key field. 

3. Chose the child table and the foreign key field that corresponds to the primary key of the parent table. 

4. Relations can also be established with a compound key. The assignment (linking) of data records takes place 
when all fields match. Define one via "Add". If there are several entries in the assignments, a compound primary 
key is created. With a simple primary key, the list of assignments has only one entry.  

5. Relations can not be defined arbitrarily, only data sources with filterable tables are available as child table. 

▪ Filterable: All SQL databases, OData, ODBC, OLE DB, MongoDB, Cassandra, Salesforce 

▪ Only filterable with in-memory option: CSV, Excel 

▪ Not filterable: REST, JSON, XML, CouchDb, Google Analytics, Google BigQuery, Google Spreadsheet 

Tables from, for example, a XML data source are not offered in the selection list for the child table. A non-
filterable table as a parent table is possible, but the designer does not have the usual 1: 1 relations from the 
child to the parent table. 

2.4.5 Data source parameters 

For some data sources (e.g. JSON, REST, XLS, XML, CSV), data source parameters can be used in the URL. 

1. The data source parameters are inserted into the URL using the syntax {{ParameterName=StandardValue}}.  

2. The provider is then set up with a data source parameter in the URL: 

Example for JSON: 

JsonDataProvider orderData = new JsonDataProvider("http://example.net/api/ 
customers/{{KundenNr=123}}/orders"); 
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Example for REST: 

https://www.pegelonline.wsv.de/webservices/rest-
api/v2/stations/{{City=KONSTANZ|Choices=KONSTANZ,KOBLENZ,BONN|Multiselect=false}}/W/measurements.json?st
art=P30D 

1. The Designer recognizes the parameters in the data sources (here "Customer No." with default value 123) and 
automatically generates the corresponding report parameters. 

2. If a data provider has a data source parameter named "XYZ", List & Label now automatically supplies it with 
the current contents of the report parameter "XYZ". (The names only have to match). 

3. The usual control with the report parameters can be seen in the designer preview. 

4. If "456" is entered here instead of "123", the provider discards his current data and downloads it again with a 
modified URL (http://.../customers/456/orders). 

5. A wizard is also available for the definition of the data source parameters. For JSON and REST, start the wizard 
using the "Syntax" button in the "Server URL" field.  

▪ Note the two options "General" and "Source" 

▪ 'Displayed value (formula)': A formula can be specified if a table or 'Predefined values' is selected for 
'Source'. The parameter name is passed as '@parametername'. The specification is optional. 

 
Figure 2.24: Report Parameter Assistant 

2.4.6 Schema in JSON/REST data sources 

In a JSON and REST data source, it is possible to specify a schema by URL or file path. A schema defines the exact 
structure of a JSON file. 

This means that a JSON file can differ each time it is called up. A field content can also be zero. In addition, an 
entire table or a field can also be missing. 

A FirstSingleSchema is supported. Useful for generating this file is e.g. https://www.jsonschema.net/. 

2.5 Schedule reports 
Reports can be scheduled from this page. A report template can be selected and as well as certain actions, which 
will be executed after the report has been generated.  

2.5.1 General 

A variety of functions are available. 

▪ Generate new scheduled reports via Schedule Report or by selecting a report from the Report Templates list 
and then selecting Schedule Report. 

▪ Use Filter items to reduce the number of list items displayed. For this, the report names will be searched using 
full text methods. Use the X button on the filter bar to show to the entire list once more. 

▪ Click on the scheduled report to edit or duplicate it. 

http://.../customers/456/orders
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2.5.2 Properties 

▪ First, determine the general properties of the scheduled report. 

▪ Name 

▪ Report template 

▪ Choose export profile 

▪ Via "Active" you have the option to temporarily or permanently deactivate scheduled reports. If the option is 
deactivated, the report is no longer executed automatically and all triggers stored in the task planning are 
deactivated. A deactivated report is marked in the list with a small lock. Important: The synchronization 
between the interface and the Windows task scheduling can take up to one minute. 

▪ Expand the Triggers pane and select Add Trigger.  

▪ Enter a name for the trigger. Any number of triggers may be defined for a report. 

▪ Specify the initial timestamp. The terminating timestamp is optional. 

 
Figure 2.25: Settings for a scheduled report 

2.5.3 Triggers 

You can add a calendar-based trigger to a scheduled report e.g. that launches the scheduled report always on 
Mondays and Wednesdays at 4 pm. 

Accept the changes by clicking Save. You can delete an existing trigger by clicking Delete.  

Calendar-based trigger type of repetition 

▪ Once: The scheduled report will be executed once at the initial time. Additional settings will not be required. 

▪ Every Minute/Hourly/Daily: Enter the repetition interval in minutes/hours/ days. If the repetition interval is set 
to 3 days, the scheduled report will be repeated, e.g. every 3 days from the initial time (starting at the initial 
time). 

▪ Weekly: Enter the repetition interval in weeks. If the repetition interval is set to 3 weeks, the scheduled report 
will be repeated every 3 weeks from the initial time (starting at the initial time). Specific days of the week can 
also be defined, such as always on Mondays and Fridays. 

▪ Monthly: Specific months and days can be defined, such as always on April 1st and September 1st or last day. 

▪ Quarterly: Specific quarters and days, such as always on 1st day of the 2nd and 3rd quarters. 
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2.5.4 Actions 

Specific actions can be added to a scheduled report, e.g. an action that sends the report by e-mail to specific 
people. 

 
Figure 2.26: Actions for a scheduled report 

Expand the Actions pane and add one or more of the available options.  

▪ Accept the changes by clicking Save.  

▪ An existing action can be removed by clicking Delete. 

▪ Use the Test Connection button to check the settings. 

Data-driven Report Generation 

All variants offer the option "Skip this action if no records are to be exported". If you enable this option, a report will 
only be generated and shared if a project filter defined in the printing template actually delivers data.  

▪ Thus, an empty report (one without data) will no longer trigger any actions. 

▪ On the other hand, the action can also be data-driven, e.g., if "Order date = today" and "Job value > 10,000". 

▪ The Application.Report.LastExportDate and Application.Report.LastExportDate-UTC variables allow you to 
include the date from the last export in the filter. 

Send by Email 

Specify the name, addresses for the email recipients (use a semicolon to separate each email address), subject 
and message body for the email body (by doing so, the placeholder, [ReportName], will automatically be replaced 
with the report template's name). 

User groups can also be selected as e-mail recipients via the "Choose groups" button. Please note that you can 
only select user groups that also have access rights to the report template.  

Optionally, you can specify the filename for the attachment. 

With the "Always attach reports with only one file as a ZIP archive, too" option, reports are always zipped. When 
disabled, the export result only zipped when multiple files are generated. 

The option “Use recipient from report template” sends one email per record (invoice print) to the recipients defined 
in the Designer. If this option is activated, you can use other variables such as the subject from the report template. 
Other actions that have not activated or do not support document printing are skipped. The recipient data must be 
set in the Report Server Designer. However, these options are only available for the invoice project type. 

Connecting an OAuth 2.0 Application for SMTP: 

1. Access the „SMTP Configuration“ in the „Management” area of the Report Server. 

2. Choose “SASL XOAUTH2” as authentication type. 

3. Enter your Redirect-URL to your OAuth 2.0 application under the “Authorisation endpoint” field. Additionally, 
fill in the fields “Access token endpoint”, “Client ID”, “Client Secret”, “Refresh Token” and “Access area 
(scope)”. The scope value must be filled according to the documentation of the SMTP provider. 

4. For corporate accounts in “Office 365”, the option “Authenticated SMPT” must also be activated in the admin 
panel. 

Webhook Call 

A HTTP-POST event notification is sent to the set server with all required data. The target server (e.g. an application 
like Mattermost) must be able to understand or process this message accordingly. 

Enter the name, Webhook URL, timeout and optionally the secret key. Optionally, an http header can be added 
and user-defined fields can be created. 

With the "Always attach reports with only one file as a ZIP archive, too" option, reports are always zipped. When 
disabled, the export result only zipped when multiple files are generated. 
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Copy Files 

Specify the name, archive location, permissions for overwriting and, if necessary, any user account information for 
access. 

The options "Overwrite existing files" and "Create single ZIP archive" (for formats consisting of several files) are 
available. 

FTP Upload 

Specify the name, Base URL (destination), user name and password. 

▪ Base URL: The target folder must already exist and write access must be granted. 

▪ Relative path (optional): Subdirectory or file path relative to the base URL.  

▪ Subdirectories will be created automatically if needed.  

▪ A file name can only be entered if the report does not consist of multiple files. 

▪ The specification of a filename in the relative path is optional; this is the name of the report template with 
the appropriate file ending. If the report consists of several files (for example, JPG export), specifying a 
file name will result in an error during execution. 

SFTP Upload 

Specify the Description, Host, Username and Password. 

▪ Host: The host name and, if applicable, port of the destination server (e.g.: sftp.example.com:22) 

▪ Host key (optional): Expected host key from the server to verify the server (e.g.: ssh-ed25519 
AAAAC3NzaC1lZDI1NTE5AKyyInw61eCtgIAba0sDF31aETaai905). 

▪ Path (optional): Path of the target directory or file. Subdirectories are created automatically if required. A file 
name can only be specified if the report does not consist of multiple files. 

Google Drive Upload 

Specify the Description, Directory, Application Name, Client ID, Client Secret and Refresh Token. 

To set the Refresh Token, click on "Request Refresh Token". A dialog will be displayed where you can request a 
code. When clicking "Request code" the Google website will be opened in a new tab. Please login with your Google 
account and accept the access. Copy the generated code into the clipboard and return to the dialog. Paste the 
copied code into the input field. The code will be converted into a Refresh Token. 

For Client ID, Client Secret and Refresh Token you need a valid Google account and must provide access to Google 
Drive via the Google Developers Console. 

Create an OAuth 2.0 Application in Google 

1. Open https://console.developers.google.com/ (Google Developer Console) and create a project by clicking 
"Create Project". If you already have a project there and want to add another one just for this matter, there is a 
combobox at the top of the page showing the currently active project name or "Select a project". Click on it. 

2. Click on the '+' button on top right of the popup. Choose a name for your project and click on 'Create' button.  

3. After the project ID is created, use the same combobox to switch to this new project and then go to 
"Credentials > OAuth consent screen" tab and choose a product name (important: in Report Server by creating 
the GoogleDrive Upload Task action, you should write it in the "Application Name" field) and save it. 

4. Then go to Credentials tab and click "Create credentials" and "OAuth client ID". 

5. Choose "Other" as "Application Type" and click "Create". 

6. From the next popup copy your "Client ID" and "Client secret" to somewhere safe. 

7. To be able to use the Google Drive API, you also need to enable it first as follows: 

8. Open https://console.developers.google.com/ (Google Developer Console) and in the "Dashboard" tab click on 
the "Enable APIs and Services" link at the top of the page. 

9. On the next page write "Google Drive API" in the search box and then click on the "Google Drive API" result. 

10. On the next page click on the "Enable" button. 

Microsoft OneDrive Upload 

Specify the Description, Directory, Application ID, Application Key and Refresh Token. 

To set the Refresh Token, click on "Request Refresh Token". A dialog will be displayed where you can request a 
code. Copy the generated code into the clipboard and return to the dialog. Paste the copied code into the input 
field. The code will be converted into a Refresh Token. 

For the Application Key you need a valid Microsoft account and must provide access to Microsoft OneDrive via the 
Microsoft Application Registration Portal. 

Create an OAuth 2.0 Application in Microsoft: 

https://console.developers.google.com/
https://console.developers.google.com/
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1. To create a Microsoft Application, open App registrations 
https://portal.azure.com/#blade/Microsoft_AAD_RegisteredApps/ApplicationsListBlade and click on "New 
registration" on top left of the page.  

2. On the next page, choose an "Application Name" and since the Report-Server uses the "common"-tenant, we 
need to at least select one Multitenant option. 

3. After registering the Application, you will be redirected to the overview of your application. Here the 
"Application (client) ID" is the OAuth Client-ID. 

4. To generate the secret, go to "Certificates & secrets" and add a new client secret with "New client secret". The 
generated Secret will be displayed in the List below. 

Dropbox Upload 

Specify the Description, Directory, App Key, App secret and Refresh Token. 

To set the Refresh Token, click on "Request Refresh Token". A dialog will be displayed where you can request a 
code. Copy the generated code into the clipboard and return to the dialog. Paste the copied code into the input 
field. The code will be converted into a Refresh Token. 

For the App Key and App secret you need a valid Dropbox account and must provide access to Dropbox via the 
Dropbox App Console. 

Create an OAuth 2.0 Application in Dropbox: 

1. Open https://www.dropbox.com/developers/apps (App Console), go to the "My apps" tab and create a 
Dropbox Application by clicking "Create app" on top right of the page. 

2. On the next page choose "Dropbox API" option and then the "Full Dropbox" option and a name for our app and 
then click on the "Create app" button. 

3. On next page the "App key" is the OAuth client Id and the "App secret" is the OAuth client secret. 

SharePoint Online Upload 

Specify the name, token endpoint, application ID, base URL, username and password, SharePoint library and folder 
for reports. 

Token endpoint: OAuth authentication is performed against the token endpoint. It can be found in the Azure Active 
Directory; App Registries > [Your app name] > Endpoints > OAuth 2.0 Token Endpoint (v1). 

Application ID: The application ID is used for OAuth authentication against the defined endpoint. It can also be 
found in the Azure Active Directory; App Registries > [Your app name] > Overview > Application ID (Client).  

In both cases, an app must first be created. 

Create OAuth 2.0 Application in Azure AD: 

1. Go to the Azure AD portal via https://aad.portal.azure.com 

2. Here, select "Azure Active Directory" and "App Registrations" in the left navigation area and then "New 
Registration". 

3. Here you define the name of the application and the supported account types. The optional redirection URL 
must remain free. 

4. Switch to "API permissions" to grant permissions to your app. Here, select "Add a Permission", then 
"SharePoint", "Delegated Permissions" and finally, for example, "AllSites.Manage". 

5. Click on "Grant administrator approval" to give your approval for the required permissions of the application 

6. Select "Authentication" in the left navigation area. 

7. Change „Allow public client flows” from “No” to “Yes”. 

WebDAV Upload 

Enter the name, the server URL with path to the WebDAV endpoint, the path to the target directory and your login 
data. 

Variables for actions 

At various points, variables can be used which are replaced at runtime. 

https://portal.azure.com/#blade/Microsoft_AAD_RegisteredApps/ApplicationsListBlade
https://www.dropbox.com/developers/apps
https://aad.portal.azure.com/
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Figure 2.23: "Variables" button at the location for "Copy files" 

This variable translation can be prevented by a question mark, e.g. ?[User Name]. In this case, the [UserName] text 
is retained. 

The "Variables ..." button opens a selection dialog with the following options: 

 

Figure 2.23: Selection dialog of the Variables 

▪ Date/Time: u.a. [Year] Current Year, [Month] / [Day] Current Month / Day, [Hour] / [Hour12] / [Minute] / [Second] 
Current Hour / Minute / Second, [AmPm] AM/PM 

▪ Other: u.a. [ReportFileName] Name of the report template including the file extension, [ReportTemplateName] 
Name of the report template, [ReportFileExtension] File extension, [ReportTemplateID] ID of the report 
template, [UserName] User account name, [UserLoginName] Login name, [UserEMail] Email address of the 
user account, [UniqueID] ID of the process, [ServerURL] address of the report server. 

▪ Formula Input: The formula syntax corresponds with the report designer, so you can use the designer's formula 
wizard to write and test the formula more easily. The variables listed are also available within the formula. Be 
sure to enclose them with quotes to interpret them as text. For example: [{Upper$("[UserName]")}] to output 
the name of the active user in capital letters. 

2.6 Output options 
Reports can be exported and printed. The real data preview provides a detailed output on the screen. 

2.6.1 Print 

You have 3 options for printing. 

Print from the preview in Report Server 

▪ Select the report template and choose "Preview". 
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▪ Select the corresponding Print button in the HTML viewer. 

▪  

 
Figure 2.27: Printing from the preview 

Print from the preview in Report Server Designer 

▪ Select the report template and choose "Open in Designer". 

▪ On the upper or lower edge of the working space you can select "Preview" from the tabs. 

 
Figure 2.28: Tabs for selecting the view mode 

▪ Select the corresponding output button in the Designer's preview ribbon. 

Print from Report Server Designer 

▪ Select the report template and choose "Open in Designer". 

▪ Select File > Print 

Output Options for Report Server Designer 

You have various configuration options here: 

▪ Under "Print Target", you can change the printer settings. If you have defined different layout regions in the 
page layout dialog, you can also change the printer settings here for the various regions. Enter the number of 
copies under "Issues". 

▪ "Pages" lets you select certain pages or a page range for printing, e.g. 1, 3-4, 10-. 

▪ The "Print" drop-down list lets you restrict the output to even/odd pages or the pages that you have selected 
above. 

▪ Only available for printing via File > Print/Export from the Designer. 

▪ Select the output format (e.g. preview, printer, PDF) under "Direct to".  

▪ With "First Page", you specify the page number which the numbering starts with. 

 
Figure 2.29: print options 

▪ When printing labels, you have an extra "Select" button which you can use to specify the position where you 
want to start printing the sheet of labels.  
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Figure 2.30: Additional print settings for labels 

In this way, you can also print sheets of labels that have already been partly used. You will find a sample label 
sheet for your label project in the dialog for selecting the start position. Click the label where the print is to 
start. Please take note of the selected print order. You can print not only in rows from upper left to lower right 
but also column for column or in the reverse direction. The labels will be printed in the specified direction 
starting with the selected label.  

Test Print in the Report Server Designer 

Choose File > Print > Test Print (File > Print Sample) to print the current project with sample data. In the print 
sample, fixed text appears as it is defined in the project; variables and fields however are replaced by a predefined 
sample text or by a single repeated sample data record. 

2.6.2 Preview 

In this way, you can check the layout of a printout without wasting paper in order to do so. The screen preview is 
accurate down to the last detail (WYSIWYG – What You See Is What You Get), exactly as it would be when printed. 

Preview in Report Server 

The pages are shown as single pages.  

 
Figure 2.31: Preview in browser with drilldown via Report Paramters 

▪ You can adjust the view using the Zoom buttons and "1:1".  

▪ Using the Export function, choose one of the configured export profiles. 

▪ You can also choose a network printer using the Export function. For more information on network printers, 
refer to the chapter "Management" in the section "Manage Printers". 

▪ The print function initiates output at one of the printers configured at your workstation. 

▪ The report parameters you have defined for the preview are displayed in the section on the left. After choosing 
a report parameter, the filter can be executed using "Apply". 
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Preview in the Report Server Designer 

▪ The pages are continuously displayed. Via "Move" you can move the viewing area with the mouse, otherwise 
use the scroll bar. 

 
Figure 2.32: Real data preview in the Designer 

▪ Use "Zoom In", "Zoom Out", "Page width" and "100%" to adjust the view in the workspace. 

▪ If you zoom out, multiple pages are displayed.  

▪ A double click on a page gives a full page view. 

▪ Use the Zoom slider in the status bar to slide to the zoom percentage you requires (50% - 500%). 

▪ Hold the CTRL key and simultaneously rotate the mouse wheel to zoom with the mouse. 

▪ With the find function, you can search all pages of the preview. 

▪ The "Pages", "Directory", "Index" tabs are for fast, direct navigation. Information of contents and index, see 
"Common Object Properties" in Chapter "Overview of Properties" in the Designer-Manual. 

▪ Via File > Options > Preview, you can specify the maximum number of pages that are to be displayed in the 
real data preview. 

▪ The "Number of copies" specified in the print options is ignored in the preview as this is only relevant for the 
actual print. 

2.6.3 Export 

The export is configured in the combit Report Server.  

▪ Select the report template and choose "Export". 

▪ Select an export profile, e.g. "PDF". 

▪ The option "Do not use cached results" creates a report with the latest data. 

▪ The option "Do not delegate to Worker Services" creates reports without using Worker Services. 

▪ Further information about export profiles can be found in section "Export profiles". 

▪ For the export with report parameters, the parameters can be preset. This is helpful, for example, if a link is to 
be shared or the export is to be integrated in the user's own application. You can append possible report 
parameters to the url. 

Example: https://localhost/Report/Export/B2D6B8E3-FF08-4913-B723-4A0C4-BAE98F0?$DatasourceSingle= 
Seafood&$DatasourceMultiple=1;2;3&$Numeric=892&$Text=suhasuh&$Boolean=False&$NonRequiredBool
ean=True&$Date=2020-07-02T15:00:00.000Z 

https://localhost/Report/Export/B2D6B8E3-FF08-4913-B723-4A0C4-BAE98F0?$DatasourceSingle=


Introduction and operation Management 

37 

 
Figure 2.33: Export settings 

2.7 Management 
The 'Management' option will provide access to the different configuration settings. The system administrator 
normally makes these settings. 

▪ User: Create users and determine memberships in user groups. 

▪ User Groups: Create and edit user groups. 

▪ Export Profiles that can be used when exporting reports. 

▪ Active Export Jobs: Display or cancel export jobs that are currently running. 

▪ Advanced Settings: Includes additional data providers, export jobs, password regulations, user interface and 
debug mode. 

▪ System Protocol: Provides a list of the notifications, events and problems that have occurred. 

▪ System Information: Key information for the Support department. 

▪ Licensing: View an existing license and enter a new one. 

▪ Worker Services: Display and edit associated Worker Services. 

▪ SMTP Configuration: Settings for the transmission of email messages about scheduled reports. 

2.7.1 User 

User profiles can be created and edited from this pane. 

▪ Select Import User to import a user from Active Directory. 

▪ Select Create User or click on an existing user to edit their settings. 

General properties 

Define the general properties. 

• User name (max. 20 characters, must start with a letter. The following letters (Latin alphabet) and numbers as 
well as the period, underscore and hyphen may be used. Using upper- or lowercase letters does not matter). 

• Display as: Change the displayed name. 

• Master data: Email address, time zone and language. 

Group memberships 

All groups associated with a user will be displayed under Group Memberships. All associated users will be 
displayed correspondingly for a group. 

▪ To edit the memberships, click Select Group Memberships. 

▪ Each user may belong to any number of user groups, whereby specific rights are assigned to each group (read 
only, edit report templates, edit data sources and manage system). 

Permissions 

The user permissions will be determined by their group memberships and cannot be edited directly. If a user is a 
member of several groups, their rights will be represented by a union of all of their user groups (additive). 
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Example: The user has been added to the User group as well as the Administrator group. From the User group, 

the user does not have the right to create a report template. As a member of the Administrator group however, the 

user does have this right. In this case, the user will be granted the right regardless of whether the user does not 

actually have this right as a member of the User group or not. 

User login 

Login can be configured from Further Options. Select the user login method and specify the user name and 
password and/or domain. 

▪ Integrated account: Using an integrated account, the user must log in to combit Report Server using their user 
name and password. The user can change this password at any time. It will only apply for the login to combit 
Report Server. 

▪ Domain account: Using a domain account, the combit Report Server user profile will be linked with a user 
account in the local domain. In this case, the user can use the same password to login to combit Report Sever 
as they would when logging in to their own computer. 

▪ API account with token: An API account is used to access the REST API, logging into the user interface is not 
possible. For client authentication, a random token can be generated in the next step. 

Automatic user login 

combit Report Server can be operated using two Microsoft Internet Information Services (IIS) authentication modes 
(which cannot be combined). 

 Form authentication 

▪ The user enters their login name & password to login. Internally, the integrated or domain login method will 
check the password. Any login name may be chosen. 

▪ Will work with all devices and browsers. 

 Windows authentication (Single SignOn) 

▪ The user is logged in by the browser using their Windows or domain account. A password is not required. 

▪ Only works when the login name complies with the Domain_Name\NT_Name format. 

▪ Only works under Windows and only with the desktop browsers Google Chrome and Mozilla Firefox. Mobile 
access is not supported. 

Configuration settings: 

▪ Google Chrome: Open the "Internet Options" in the Windows Control Panel. Under "Advanced > Security" 
enable the option "Enable Integrated Windows Authentication" and add the site for combit Report Server under 
" Security > Local Intranet > Sites > Advanced". 

▪ Mozilla Firefox: Enter about:config in the address bar and find the network.automatic-ntlm-auth.trusted-uris 
setting. Double click to open a dialog. Enter the address for combit Report Server. If you want to enter multiple 
servers, separate them from each other using a comma.  

2.7.2 User groups 

User groups can be created and edited from here. 

▪ Select Create Group or click on an existing group to edit the settings. 

▪ Select the desired permissions.  

▪ Clicking Display Group Members will display a list of the users associated with the group. 

The default groups, Administrator and Everyone, cannot be deleted. The permissions for the Everyone group can 
be edited. 

2.7.3 Export profiles 

Use this pane to create or edit export profiles for use when exporting reports. 

Tip: Once the server has been set up, the operating system language will be used as the default language for 
the standard export profiles. Standard export profiles can also be deleted. 

Reports can be output in various file formats. The following formats are available: PDF, Word, Excel, XPS, RTF, 
XHTML, HTML, TIFF, PNG, JPEG, Bitmap, EMF, TTY, CSV, Text, XML, JSON and SVG. 

Some formats have export options. 

▪ In Excel format, for example, the number of columns and rows can be reduced to the quantity necessary using 
the Export Only Data from Table Objects option.  
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▪ In the case of the PDF format, there is the option for creating a PDF/A conformant file and security options, 
for example. 

Depending on the format, the layout cannot always be adopted 1:1 because there are specific restrictions on the 
implementation of these formats. Some formats have specific restrictions. 

Excel Export 

The Excel export creates Microsoft Excel® documents. The creation is independent of any installed version of this 
product, i.e. the export is native. Depending on your needs, the full layout can be conserved during export, or only 
the data from table objects is exported unformatted. 

Limitations 

The following limitations should be considered: 

▪ Excel renders texts with an increased height compared to the standard output. Thus, all fonts are scaled down 
by an optional factor. You may set this factor using the Font scaling option.  

▪ Excel does not accept any objects on the non-printable area of your printer. This results in a wider printout. 

▪ RTF texts are exported without formatting. 

▪ Tabs will be replaced by blanks. 

▪ The option 'Separators fixed' in the table object is not supported. 

▪ The option 'Fixed size' in the table object is not supported. 

▪ Fill patterns are not taken into account.  

▪ Chart and HTML objects are exported as pictures and thus cannot appear transparently.  

▪ The print order of lines and rectangles is disregarded, lines and rectangle frames always appear in the 
foreground. 

▪ The print order of texts and rectangles is disregarded, text always appears in the foreground. 

▪ Texts partially overlapping filled rectangles are filled completely. 

▪ Overlapping text and picture objects are ignored. 

▪ Lines that are neither horizontal nor vertical are ignored. 

▪ Picture objects are rendered with a white frame. 

▪ Large filled areas in projects with many different object coordinate values can decrease the speed remarkably. 

▪ Line widths are ignored. 

▪ Rectangle shadows cannot be exported. 

▪ If coordinates of different objects are very close to each other but not identical, frame lines may become 
invisible because Excel cannot display them anymore. 

▪ Rotated RTF objects and pictures are not supported. 

▪ Objects that are exported as pictures must not extend out of their object frame. Therefore, for example, 
barcode objects with a fixed bar width must be designed in the Designer in such a way that the content always 
finds room in the object rectangle. 

▪ If the coordinates of two objects are only slightly different (i.e. a fraction of a millimeter), frame lines might 
become invisible as Excel is not capable of displaying them correctly. 

▪ Gradient fills are not supported. 

▪ Texts rotated by 180° are not supported and are displayed with 0° rotation. 

▪ Paragraph spacing is not supported. 

▪ Negative values for spacing are not supported. 

▪ The maximum number of Excel columns is limited to 256. 

▪ Issue print is not supported. 

▪ Shadow Pages are not supported. 

▪ The wrapping option 'Minimum Size' in the crosstab object is not supported. 

▪ Expandable Regions for crosstabs are not supported. 

▪ Frame inner offsets are not supported. 

▪ Background color of the report container is not supported. 

▪ For the security option "Protect spreadsheets" no Unicode characters and a maximum length of 29 characters 
are supported for the password. 
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HTML Export 

The HTML export creates XHTML code according to the XHTML 1.0 specification and CSS code according to the 
CSS 2.1 specification. 

The export module collects all List & Label objects for the page currently being printed and orders them according 
to their height, width and position. The position of an object results from two values: left and top. They specify the 
distance from the upper left page border. All objects are positioned absolutely on a page, which leads to a more 
accurate export result. 

Limitations 

There are limitations set by the target format. The most important are listed now. 

▪ Rows that are anchored to each other are not correctly exported. 

▪ Decimal tabs will be transformed to right-aligned tabs. 

▪ Any other tabs will be transformed to a blank. 

▪ The option 'Line break' in text objects and table columns is always active in the export result. 

▪ The option 'Separators fixed' in table objects is not supported. 

▪ The chart object is exported as a picture and thus cannot appear transparently. 

▪ The transformation of RTF text to HTML code is carried out by an RTF parser. This parser interprets the basic 
RTF formatting. Extended RTF functionality such as embedded objects will be ignored. 

▪ Gradient fills are not completely supported. 

▪ Objects to be exported as picture should not overlap the object frame. Therefore e.g. barcode objects with 
fixed bar width must fit in the object rectangle.  

▪ Custom drawings in callbacks must be exported as picture. 

▪ Table frames of neighboring cells are not drawn so that they overlap each other, but discretely. This can double 
the frame width and needs to be considered during the design. 

▪ Even if the HTML object wraps over several pages, it will be exported in one stream, i.e. no page wrap will 
occur. 

▪ Embedded scripting functionalities may be lost. 

▪ Issue print is not supported. 

▪ Rotated descriptions in the crosstab object are not supported. 

▪ Shadow Pages are not supported. 

▪ The wrapping option 'Minimum Size' in the crosstab object is not supported. 

▪ The property "Link" is not supported. 

▪ Background color of the report container is not supported. 

▪ If the "Fit" property for a table row is set to "Shrink", tables may overlap across the page. To prevent this, the 
"Export as Picture" property can be used. 

▪ Horizontal wrapping is suppressed because a corresponding scroll bar is automatically provided for this 
purpose. 

▪ The "Fill Horizontally" property for multi-column tables is not supported correctly. 

▪ Linked crosstabs are not supported. 

▪ Frames around individual tables and background colors of individual tables are not supported. 

MHTML Export  

The MHTML (Multi Mime HTML) export functions analogously to the XHTML export. However, pictures are 
embedded MIME encoded into the export file. Thus the result is only one file (.MHT). This is most useful for sending 
invoices by mail, as the recipient can open the file directly and does not need any access to further (external) 
picture files. 

PDF Export  

The PDF export creates documents in the Portable Document Format. This format can be viewed platform-
independently with the free Adobe Acrobat Reader® software.  

Limitations 

Besides others, the following hints and limitations should be considered: 

▪ Fonts are automatically recognized and dynamically embedded if necessary. 

▪ Not all EMF records can be displayed accurately – if you are using complex EMFs, you should pass them as 
bitmaps or choose "export as picture" in the designer. 
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▪ Lines/Frames that are dashed/dotted in the layout may have a different spacing. In addition, each dash/dot is 
displayed as a single PDF record. To keep the resulting file size small, continuous lines/frames should be used 
for PDF export. 

▪ Note for PDF/A: 

o When using form elements in combination with PDF/A, PDF/A conformity cannot be maintained and 
the form elements are deactivated. 

o All fonts are always embedded. 

o Encryption is not supported. 

Picture Export 

This Export creates a graphics file (JPEG, BMP, EMF, TIFF, Multi-TIFF, PNG) for every printed page. The file names 
of the created graphics will be enumerated. If the file name contains the format identifier "%d", this identifier will 
be replaced by the page number. 

Limitations 

▪ Issue print is not supported. 

PowerPoint Export 

The PowerPoint export module creates documents in Microsoft PowerPoint® format. The creation is executed 
independently from the installation of the product; it is therefore natively supported. A full layout-preserving export 
is executed. 

Limitations 

Besides others, the following hints and limitations should be considered: 

▪ Compatible with Microsoft PowerPoint® 2010 and higher.  

▪ It is recommended that the width of all columns of a line matches the total width of the report container. 
During the design, try to always justify the borders of different cells that occur in multiple table sections 
(header line, data line etc.) or multiple line definitions. Otherwise the result can be falsified in Microsoft Word. 

▪ Columns cannot be smaller than 0,54 cm (5,4mm). All columns will be automatically resized to this Size by 
Microsoft PowerPoint. 

▪ Fonts will be reduced by 1%, otherwise the result can be wrong in Microsoft PowerPoint. 

▪ Table lines that contain a picture will be exported with a fixed height. 

▪ A mix of different page formats is not supported. To achieve an export of e.g. portrait and landscape format, 
all pages of the same format can be each exported to a separate document. 

▪ Tabulators are not supported. 

▪ Issue print is not supported. 

▪ Shadow Pages are not supported. 

▪ Nested tables will be exported as image by default. 

▪ The wrapping option 'Minimum Size' in the crosstab object is not supported. 

▪ PowerPoint adjusts pictures to the height of the line. 

▪ Frame inner offsets are not supported. 

▪ The "Fill Horizontally" property for multi-column tables is not supported correctly. 

RTF Export 

The RTF export creates documents in Rich Text Format based on Microsoft specification 1.5/1.7. The exported 
files have mainly been optimized for Microsoft Word and Lotus Word Pro. Please note that the rendering of the 
exported files can differ with different word processors.  

Limitations 

Besides others, the following hints and limitations should be considered: 

▪ Rows that are anchored to each other are not correctly exported. 

▪ The max. color depth is 24 bit (PNG: 32bit). 

▪ Shadows of rectangle objects are not supported. 

▪ Tabs will be replaced by blanks. 

▪ Objects should not be placed too close to the page borders. Some word processors create page breaks in 
such cases. This means that all following objects will then automatically be placed on the next page. 

▪ The option 'Separators fixed' in the table object is not supported. 

▪ The table option "Fixed size" is not supported 
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▪ Not all background patterns available in List & Label can be transformed to RTF. The number of patterns 
available in RTF is much smaller than that of the patterns available in List & Label.  

▪ The chart and HTML object are exported as pictures and thus cannot appear transparently. 

▪ Rotated RTF texts, plaintext and pictures are not supported. 

▪ Frames around objects are not supported. 

▪ Gradient fills are not supported. 

▪ Objects that are exported as images must not protrude from their object frame. Therefore, for example, 
barcode objects with a fixed bar width must be designed in the Designer in such a way that the content always 
finds room in the object rectangle. 

▪ Custom drawings in callbacks are not supported.  

▪ TotalPages$() may not be used in rotated text objects. 

▪ Paragraph spacing is not supported. 

▪ Issue print is not supported. 

▪ Shadow Pages are not supported. 

▪ Nested tables are only supported one level (i.e. no subtable support) if they are not exported as picture (see 
Verbosity.NestedTable below). 

▪ The wrapping option 'Minimum Size' in the crosstab object is not supported. 

▪ Table cells in the crosstab object, that horizontally and vertically overlap multiple other cells cannot be exported 
exactly. 

 

Known specialities in general: 

▪ Frames smaller than ½ pt will not be displayed correctly. 

▪ Positon frames in Word are handled unusual, because length properties are interpreted incorrect by Word. 

▪ Thin line objects may be not displayed because the corresponding bitmap gets an offset causing the line 
object to be out of the frame. 

▪ Table frames might not always be displayed correctly. 

▪ Distances between cells are not supported. 

▪ Not all colors that can be used in List & Label are interpreted correctly by Word. 

▪ When exporting large images at large resolutions, these images are sometimes not displayed by Word 
although they are referenced correctly in the RTF. 

▪ We recommend to make any objects and table cells more generous in height and width, because RTF uses 
additional inner spacing in some areas, which are of course not visible in the Designer. 

SVG Export 

The SVG export creates SVG code according to the Scalable Vector Graphics (SVG) 1.1 (Second Edition) 
specification. The export collects all objects for the page currently being printed and orders them according to their 
height, width and position. The position of an object results from two values: left and top. They specify the distance 
from the upper left page border. All objects are positioned absolutely on a page, which leads to a more accurate 
export result. 

Limitations 

There are limitations set by the target format. The most important are listed now. 

▪ Rows that are anchored to each other are not correctly exported. 

▪ Tabs and multiple sequential spaces are not supported. 

▪ The option 'Line break' in text objects and table columns is always active in the export result. 

▪ The option 'Separators fixed' in table objects is not supported. 

▪ The table option "fixed size" is not supported. 

▪ RTF text will be exported as pictures. 

▪ Objects to be exported as picture should not overlap the object frame. 

▪ Custom drawings in callbacks are not supported. 

▪ Table frames of neighboring cells are not drawn so that they overlap each other, but discretely. This can double 
the frame width and needs to be taken into account during the design. 

▪ TotalPages$() may not be used in rotated text objects. 

▪ Even if the HTML object wraps over several pages, it will be exported in one stream, i.e. no page wrap will 
occur. 
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▪ Embedded scripting functionalities may be lost. 

▪ Shadow Pages are not supported. 

▪ A mix of different page formats is not supported. To achieve an export of e.g. portrait and landscape format, 
all pages of the same format can be each exported to a separate document. 

▪ Issue print is not supported. 

Text (CSV) Export 

The CSV-Export exports data from table objects to a text format. The separator and framing character can be 
optionally set. The result is one single text file containing the data from all table objects. Please note that the layout 
is not preserved in any way, this is purely a data conversion export. 

Limitations 

▪ Issue print is not supported. 

▪ Nested tables are not supported. 

Word Export 

The Word export creates documents in Microsoft Word® format. The creation is executed independently from the 
installation of the product; it is therefore natively supported. A full layout-preserving export is executed. Tables are 
created on continuous pages to support editing later. 

Limitations 

Please note the following limitations and hints for the Word export: 

▪ Compatible with Microsoft Word® 2010 and higher 

▪ It is recommended that the width of all columns of a line matches the total width of the report container. 
During the design, try to always justify the borders of different cells that occur in multiple table sections 
(header line, data line etc.) or multiple line definitions. Otherwise the result can be falsified in Microsoft Word. 

▪ Table lines that contain a picture will be exported with a fixed height 

▪ A mix of different page formats is not supported. To achieve an export of e.g. portrait and landscape format, 
all pages of the same format can be each exported to a separate document. 

▪ Due to format restrictions it might be necessary to adapt the report's layout before exporting to DOCX. We 
suggest to thoroughly test the output before redistribution.  

▪ Tabulators are not supported. 

▪ Issue print is not supported. 

▪ The fit option "compress" in the properties of a column is not supported. 

▪ Shadow Pages are not supported. 

▪ The option 'Separators fixed' in the table object is not supported. 

▪ The option 'Fixed size' in the table object is not supported. 

▪ The wrapping option 'Minimum Size' in the crosstab object is not supported. 

▪ Frame inner offsets are not supported. 

▪ Columns of type 'Table' will be exported as picture. 

▪ Anchoring lines is not supported. 

▪ Table of contents and index are only exported as simple tables without links. 

▪ Line spacing is not directly supported. However, these can be simulated with the help of blank lines and the 
properties "Inerasable" (Yes) and "Blank Optimization" (No). Alternatively, it is also possible to use "Chr$(13)" 
without setting the above properties. 

▪ Table in table is not supported. 

▪ Background color of the report container is not supported. 

▪ The "Fill Horizontally" property for multi-column tables is not supported correctly. 

▪ Two-part gradients are not supported for ellipse objects, only horizontal and vertical gradients (bright). 

XML Export 

The XML export creates XML files. This allows flexible editing by other applications. All available object properties 
are exported. If you require, you may export data from tables only and ignore all further object properties. 

Limitations 

▪ Issue print is not supported. 
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JSON Export 

The JSON export creates JSON files. This allows flexible editing by other applications. 

Limitations 

▪ Issue print is not supported. 

▪ Nested tables are not supported. 

▪ Free objects or texts within the layout are not supported. 

▪ Headers, footers, group headers and group footers are not supported. However, the header lines determine 
the identifiers in the data lines. 

▪ Line breaks within the table lines are not supported. To exclude this as a possible source of error, the use of 
infinite pages is recommended. 

XPS Export  

The export uses the installed Microsoft XPS printer driver for the output. 

Limitations 

Some limitations must be taken into account here too, for example the driver does not currently support all clipping 
options of the Windows GDI. This can result in display errors in the XPS file when exporting charts and generally 
truncated/clipped objects. As a precaution, we recommend that you carefully check the XPS output. 

2.7.4 Active Export Jobs 

Use this page to display or to cancel export jobs that are currently running. 

A new job will always be started when a report is generated from a report template. 

2.7.5 Advanced Settings 

Data Sources 

Check all available tables during the data source connection text: By activating this option, every single table will 
be checked during the data source test. You can detect access errors for particular tables of a data source early, 
so that they will not occur on the end user side. As the table check is time consuming it might be practical to 
deactivate this option if you are using data sources with more than approx. 250 tables to avoid long waiting times 
during the connection test. 

Job Handling 

These settings are used to influence the processing of export jobs. A new job will always be started when a report 
must be generated from a report template. 

▪ Maximum concurrent local jobs: A local job will be created when a report is generated directly on the web 
server, meaning that it is not outsourced to the Worker Service. Too many concurrent local jobs can overload 
the web server and have a negative effect on other applications. 

▪ Maximum file size for Worker Services (in Megabytes): This setting will only affect jobs outsourced to the 
Worker Service. If, after compression, the generated report exceeds this limit, it will not be transferred from 
the Worker Service to the web server. It will be rejected and the job canceled. 

▪ Tries to delegate a job to a Worker Service: If a Worker Service is being used to capacity, after a few seconds 
another attempt will be made to assign the job to a Worker Service. If the maximum number of attempts is 
reached, the job will be canceled. 

▪ Timeout for report generation (in minutes): If a job has not been completed after this period of time, it will be 
canceled. 

Password Rules 

Changes to password rules will only affect new passwords and only those user accounts that use the integrated 
authentication method. 

REST API 

▪ Activate REST API: This interface allows developers to access functions of the combit Report Server and to 
integrate them e.g. in other applications, for instance to access reports. 

▪ Activate specification by Swagger / OpenAPI: The OpenAPI specification makes it possible to describe and 
visualize a REST interface uniformly. 

The documentation of the REST API, generated from the OpenAPI description, can be found at 
http://<Servername>/rs31/doc/v1#. From there you can retrieve the specifications for OpenAPI and Swagger 
in JSON format. 
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Proxy 

Global proxy settings to be used with web-based data sources. 

▪ Do not use a proxy 

▪ Use default system settings 

▪ Manual proxy settings 

System Protocol 

When you activate the option "Store uncritical information in system protocol", in addition to the warnings and 
errors also information messages will be stored in the system protocol. This puts load on your database and slows 
down the whole application, therefore you should activate this option in case of exceptions only. Please also note 
that only the display in the web browser is affected and that the information messages basically are always stored 
in the Windows Event Log of this server. 

Debugging 

If debug mode has been enabled, detailed protocols will be created and more error messages will be displayed. 
The application will run slower because of this and can represent a security risk. Therefore, debug mode should 
only be enabled if it is required by combit Support. 

2.7.6 System Protocol 

A list of notifications events and problems that have occurred can be displayed from here. The display can be 
filtered by time and type of information. 

2.7.7 System Information 

Important information about the installed 64-bit driver, for example, will be accessible from here. This information 
can be selected using the mouse and then copied in order to forward it to the Support department, for example. 

2.7.8 Licensing 

View an existing license and enter a new one. 

2.7.9 Manage Printers 

Use this page to set up a (network) printer that can then be assigned to the printer export profiles. 

▪ Click on a printer that has not yet been activated to make it available it for printing reports. 

▪ Click on a printer that has already been activated to delete the share. 

▪ Click on "Connect Network Printer" to add additional printers. 

▪ The printout is only executed on the server itself and not via workers. 

Add printer 

Network printers first have to be installed on the computer where the combit Report Server is installed, configured 
with any given user account and then imported using this wizard.  

To do so, proceed as follows: 

Step 1: Preparation 

1. Log in to the computer where combit Report Server is installed. The log-in can also be performed using a 
Remote Desktop connection. 

2. Next, install all desired network printers on the server using the Control Panel. 

3. Do not log out from the server until the import is complete. If necessary, change to a different user instead of 
logging out. 

Step 2: Import from other user account 

4. Enter the user account credentials (domain, user name, password) that you used to log in to the server 
previously when installing the network printers. 

Step 3: Choose printer for import 

5. Choose the desired printer for the import. 

6. After the import, this printer will be available in the section "Additional Printers Available on the Server". Click 
on the printer to prepare it for generating reports. 

2.7.10 Worker Services 

If roughly 20 parallel print jobs are used (depending on the efficiency of the server), we recommend installation of 
Worker Services so that computer performance will be distributed among other systems. combit Report Server 
must be installed first. 
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Details about associated Worker Services and downloading the necessary configuration file 
(WorkerSettings.config) for installation of the Worker Service can be displayed from this pane. For more 
information, refer to Section 1.2.3, Worker Service installation. 

2.7.11 SMTP Configuration 

The SMTP settings are needed for sending email messages about scheduled reports and for sending error 
messages to administrators. Using the IIS default settings for the connection settings is one option. 

2.7.12 Connection Strings 

Here, connection strings can be configured, which can then be selected as "preconfigured connection strings" (in 
expert mode) for data sources. 

This allows you to decouple a data source from the actual connection data. If parameters or access data change, 
these changes do not have to be made in all data sources, but only in this central location. Click on a connection 
string to edit or duplicate it. 

2.7.13 Import/Export 

You can exchange settings and report templates between Report Server systems.  

▪ Export: You can export either "All users, user groups, export profiles, data sources, report elements, report 
templates and folder structures" or "Selected report templates with their data sources, report elements and 
folder structures". 

The export can be encrypted with a password (AES-256). 

▪ Import: Since you cannot undo changes, we recommend a database backup before importing. Then select 
the export file and enter the password. 

If no users have been exported before, you must, for example, release data sources manually.  

If there is an entry in the database with the same unique key, it is not processed. 

2.7.14 Start Cleanup 

During runtime several temporary items are created that become obsolete after some time, however consume 
disk space. Use the button Cleanup Tool to delete unneeded elements. You can select different actions: 

▪ Delete log files: When running in Debug Mode, numerous log files are created to help with the error analysis. 
These files can consume large amounts of disk space and can be removed once the application is running 
properly again. 

▪ Delete usage statistics: The usage of the different report templates is logged per user. This includes functions 
like displaying the recently used report template per user, displaying the estimated export duration and logging 
the user logins. If you do not use this data for analysis yourself, it can be deleted unconsidered anytime. 

▪ Delete old system log entries: Removes all system log entries which are older than a week. 

▪ Optional: Delete cached reports. Deletes all cached reports. This action may free large amounts of disk space 
but can have a negative impact on application performance. 

2.7.15 Optics / Appearance 

Use these settings to adjust the combit Report Server web interface to your requirements. 

2.8 My Settings 
Use this page to configure your personal user defined settings. 

• Time zone 

• Language of the surface: This setting defines the display language of the report server. The display language 
of the designer is derived from the active Windows display language. 

• Number of recently used reports in the overview 

• Action for report templates quick access button: Quick View, Preview, Export 

• Other Options: Designer Download, option for not to be asked if Designer is installed and the App download. 

Note: If the time set on the server is more than 5 minutes different from the client, the login may not take place. 
The client and server can be in different time zones. Normally, this problem never occurs, since servers and 
clients regularly receive their times from time servers. 
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2.9 REST API 
This interface allows developers to access the functions of the combit Report Server and to e.g. integrate these 
into other applications, such as for project retrieval. In addition to the retrieval of reports it also supports the 
triggering of scheduled reports. 

Please note the information in the license agreement. 

The Assembly combit.ReportServer.ClientApi allows you to use many functions of the Report Server REST API with 
only a few simple lines of C#/VB.NET code. You can find this and an example in your List & Label installation. 

2.9.1 General 

API activation 

API must be activated via "Management > Advanced settings > REST API" before use.  

Configuring the client without Windows authentication 

As an alternative to Windows authentication for API access, a separate Report Server user account can be used. 
This account cannot be used on the normal login page. Similarly, a general user account (integrated authentication) 
cannot be used for API access either. 

Proceed as follows: 

1. Create a user in the user administration and during "Configure registration", choose the authentication type 
"API account with token" and confirm by choosing "continue". 

2. Generate and define a new client token with "Apply". Copy this token. The token cannot be displayed again, if 
you generate a new token then the token used so far will become invalid and all clients will need to be 
reconfigured! 

Using the API 

▪ Calling the API: All API calls begin with http://myreportserver/api/v1 

Exception handling: takes place via HTTP status codes and status texts. 

▪ Authentication without Windows authentication: Each request must be authenticated with ClientID (= login 
name of user) and ClientToken. 

▪ Variant 1 (in the URL, only for SSL connections) 

http://myreportserver/api/v1/........?clientid=wikiserver&clienttoken=XXXX 

▪ Variant 2 (as HTTP header; we recommend this option):  

X-ReportServer-ClientId: wikiserver 

X-ReportServer-ClientToken: XXXX 

General error codes 

Status code  Status text Explanation 

401  ERR_INVALID_CREDENTIALS Client ID / token not specified or invalid. 

403  ERR_SSL_REQUIRED Authentication attempt with ClientToken without SSL. 

404  ERR_INVALID_ID ID in URL is not valid (TemplateID, ExportprofileID 
or TaskID) 

Determination of IDs  

The following section describes the structure of API calls. For this purpose, unique IDs are used at various 
locations. These IDs (e.g. A0BCB71A-BA65-45C5-97F3-1282D9C7C126) can be copied from the URL, and are 
always located at the end of the address: 

▪ For the TemplateID, open the report template for editing 

▪ http://www.report-server.com/combitReportServer/Template/Edit/ 
A0BCB71A-BA65-45C5-97F3-1282D9C7C126 

▪ For the ExportProfileID, open the export profile for editing 

▪ http://www.report-server.com/combitReportServer/ExportConfig/Edit/ A0BCB71A-BA65-45C5-97F3-
1282D9C7C126 

▪ For the TaskID, open the scheduled report for editing 
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▪ http://www.report-server.com/combitReportServer/Task/Edit/  
A0BCB71A-BA65-45C5-97F3-1282D9C7C126 

2.9.2 Functions 

The REST API provides the following functions: Product version, API-Level, Retrieving report, start scheduled 
report, retrieving report templates, retrieving export profiles. 

Product version 

e.g. http://servername/rs31/api/v1/version  Result: 31.0.0.0 

API-Level 

This function provides a risk-free way to test the connection to the RS API and returns the API level of the servers 
without triggering any other actions. 

URLs 

GET    /api/v1/apilevel 

Optional parameters 

Parameter can be passed in URL as ?param=value or form-encoded in the request body. 

Name Values Default Function 

doHandshake true/false false  

clientApiLevel integer -  

format json/xml xml  

 

Result 

If the doHandshake parameter is not specified or is false, or if the server is earlier than version 23.0: 

▪ If the REST API has been addressed correctly (in particular correct authentication), the server response is only 
from the current API level (HTTP code 200). 

▪ All other server responses are to be considered a bounce. 

If the doHandshake parameter is set to true and a version as of 23.0 is installed as a server: 

▪ If the REST API has been addressed correctly (in particular, correct authentication), the response from the 
server consists of a HandshakeResult object (HTTP Code 200). The content type is "text / xml" or "application / 
json" (depending on the format parameter). 

This contains the following information: 

▪ ServerApiLevel (integer): Current API level of the server 

▪ IsCompatibleWithClientApiLevel (boolean): Is true if the server is compatible with the expected client API level 
(see clientApiLevel parameter) 

▪ UserPermissions (string array): List of permissions of the current user. 

Error codes (in addition to general error codes) 

None. 

Examples 

Request: GET:    /api/v1/apilevel 

Response: 3 

 

Request: GET   /api/v1/apiLevel?doHandshake=true&clientApiLevel=4&format=json 

Response:  

{ 
  "ServerApiLevel": 4, 
  "IsCompatibleWithClientApiLevel": true, 
  "UserPermissions": [ 
    "AccessUI", 
    "ManageReportTemplates", 
    "ManageReportElements", 
    "UseTaskPlaner", 
    "ManageDataSources", 
    "ManageSystem" 
  ] 
} 
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Retrieving report 

URLs 

GET    /api/v1/report/{TemplateID}/export 

GET    /api/v1/report/{TemplateID}/export/{ExportProfileID} 

If the ExportProfileID is not specified, the default profile of the report template will be used. 

Optional parameters 

Parameter can be passed in URL as ?param=value or form-encoded in the request body. 

Name Values Default Function 

resulttype firstpage/ 

pagelinks 

firstpage If value is "firstpage", the first exported file is returned directly. 
Additional files will be ignored. 

If value is "pagelinks", an object of type "ExportResult" (see below) 
will be returned serialized as JSON or XML which contains the 
paths of all created files. 

format json/ 

xml 

json Sets the format with which the ExportResult object will be 
serialized if the result type "pagelinks" is shown. 

$parameter String(s) - All URL parameters that begin with $ will be passed on to the 
export as report parameters. 

$param=value assigns the report parameter @param with the value 
"value". 

All report parameters must be url-encoded. 

Date values should be in an ISO 8601 format without time zone e.g. 
2015-04-28T04:07:02 

Report parameters that have multiple values must be separated by 
semicolon e.g. $ categories =1;2 

nocache true/ 

false 

false If value is "true", an export will always be triggered instead of using 
the cache 

zip true/ 

false 

false If value is "true", all exported files will be zipped and the archive 
returned 

 

Result 

The request will run until the report has been created (Code 200) or an error has occurred. 

▪ If resulttype=firstpage: 

The first created file will be returned; hence for several JPGs only the first will be returned. In the response, 
the Content-Type header will be set to the MIME type of the file created. If the zip option has been chosen, 
then the zip archive will be returned with all the files created. 

▪ If resulttype=pagelinks 

An ExportResult object will be returned (see below) which contains the URLs of all files created. These should 
be accessed within a few minutes (< 5), or the RS may already have removed them by then. 

Error codes (in addition to general error codes) 

Status code Status text Explanation 

500 - 
Error during export. A localized error message is located 
in the request body. 

404 ERR_INVALID_TEMPLATE Report template not found. 

404 ERR_INVALID_EXPORTPROFILE Export profile not found. 

403 ERR_ACCESS_DENIED No access rights for report template / export profile. 

410 GONE 
May occur if resulttype=pagelinks. The requested file 
has already been removed by the RS because it was not 
accessed in time. 

Return type: ExportResult 

This is returned (as XML or JSON) if a report with several files is requested (and the resulttype parameter was 
"pagelinks")  



Introduction and operation REST API 

50 

▪ FileUrls:  is a string array with absolute URLs to the created files. These are only accessible for a short time 
and will be deleted afterwards! Should the file no longer be available, then the server will return 410 GONE 

▪ ExpiresOnUTC: is a date formatted according to ISO-8601 (UTC-Time), as of which the report will no longer be 
valid (corresponds to internal cache time of RS, but NOT the time at which the files will be deleted. 

▪ IsFromCache:  is true if the report is delivered from the RS cache and has not been re-exported. 

▪ RelativeFilePaths: is a string array that contains the relative filenames of the files in FileUrls (relative to the file 
that contains the first page of the report). Example: 'images/page1/chart2.jpg'. The order of the two arrays is 
the same so that the relative path in RelativeFilePaths [i] belongs to the file that can be downloaded under 
FileUrls [i]. 

▪ FirstPageFilePath: contains the relative path of the file (usually a simple filename) that contains the first page 
of the report. Example for HTML export: 'index.html'. 

As XML 

<?xml version="1.0" encoding="utf-16"?> 
<ExportResult xmlns:xsd="http://www.w3.org/2001/XMLSchema" xmlns:xsi="http://www.w3.org/2001/XMLSchema-
instance"> 

<ReportName>delayed test</ReportName>  
<IsFromCache>true</IsFromCache> 
<FileUrls> 
<string>http://<servername>/rs31/api/v1/report/2551186E-F854-4D1A-ACAE-

8ABA02241AE2/tempresult/Rjg3ODZGMUQtQ0Y0RC00QjlELTlFQjUtQTAxRUQ3Mzc1QTRFL3Jlc3VsdC56aXA/result</string> 
</FileUrls> 
<ExpiresOnUTC>2015-04-13T21:34:52</ExpiresOnUTC> 

</ExportResult> 

As JSON 

{ 
"ReportName": "delayed test", 
"IsFromCache": true, 
"FileUrls": [ 
"http://<servername>/rs31/api/v1/report/2551186E-F854-4D1A-ACAE-

8ABA02241AE2/tempresult/Rjg3ODZGMUQtQ0Y0RC00QjlELTlFQjUtQTAxRUQ3Mzc1QTRFL3Jlc3VsdC56aXA/result"     
], 
"ExpiresOnUTC": "2015-04-13T21:34:52" 

} 

Print report 

Prints a report to the (network) printer entered in the export profile used. The export profiles available for printing 
can be retrieved as described in "Retrieve printer profiles". 

URL 

POST /api/v1/report/{TemplateID}/print/{ExportProfileID} 

Optional parameters 

Parameter can be passed in URL as ?param=value or form-encoded in the request body. 

Name Values Default Function 

format json/ 

xml 

xml Sets the format with which the ExportResult object will be 
serialized if the result type "pagelinks" is shown. 

$parameter String(s) - Used to transfer report parameters, corresponds to the parameter 
of the same name under "Retrieving report". 

 

Result 

The request runs until the report has been printed (code 200) or an error has occurred. 

Error codes (in addition to general error codes) 

Status code Status text Explanation 

500 - 
Error during export. There is a localized error message in 
the request body. 

404 ERR_INVALID_TEMPLATE 
Report template not found. 

 

404 ERR_INVALID_EXPORTPROFILE Export profile not found. 
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403 ERR_ACCESS_DENIED No access rights to report template / data source. 

417 ERR_INVALID_EXPORTPROFILE Export profile was found, but is invalid for printing. 

 

Return type 

No return except for errors. 

Retrieve report parameters 

Allows you to list and search for report templates. 

URL 

GET    /api/v1/report/{TemplateID}/parameters 

Optional parameters 

Parameter can be passed in URL as ?param=value or form-encoded in the request body. 

Name Values Default Function 

format json/xml xml Defines the format with which the ReportDataParameter object is 
serialized. 

 

Result 

An array of the type ReportDataParameter (see below) is returned. 

Error codes (in addition to general error codes) 

Status code Status text Explanation 

403 ERR_ACCESS_DENIED No access rights to report template / data source. 

404 ERR_INVALID_TEMPLATE Report template not found. 

520 - 
Error during export. A localized error message is in the 
request body (XML/JSON). 

 

ExportResult object: IEnumerable<ReportDataParameter> 

An array of ReportDataParameters is returned. 

ReportDataParameter 

string Guid The globally unique identifier of this parameter. 

string ParentGuid 
If not null, it is the identifier of the parameter on 
which this parameter depends. 

string Name Name of the parameter. 

string HelpText 
Text which helps to understand the usage of the 
parameter. 

bool IsVisible Visibility of the parameter. 

object Value Value of the parameter. 

IEnumerable<Choice> Choices 
IF Parameter has NO dependencies (ParentGuid 
== null) available choices will be here. 

bool SelectMultiple Whether you can select multiple items. 

bool MayBeEmpty Whether you can select no item. 

bool MayBeNull 
Whether this parameter is may be null / is 
required. 

ReportDataParameterSourceMode SourceMode The Mode of the Source of this parameter. 

ReportDataParameterSourceType SourceType The Type of the Source of this parameter. 

ReportDataParameterControlType ControlType The kind of control the user should see for the 
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parameter. 

 

The control for a parameter 

ReportDataParameterControlType 

Text z.B. TextField 

Date z.B. DatePicker 

BoolYesNo z.B. Switch, RadioButtons 

BoolTrueFalse z.B. Switch, RadioButtons 

bool z.B. DatePicker and TimePicker 

 

 

The SourceMode of a ReportDataParameter 

ReportDataParameterSourceMode 

Database Database Source 

Choice List of Choices 

EditableText Simple editable text 

 

The SourceType of a ReportDataParameter 

ReportDataParameterControlType 

Text String 

Numeric Numeric string 

Date DateTime 

Boolean Boolean value 

 

If the SourceMode is Database or Choice AND the parameter has no dependencies (ParentGuid == null), then all 
available choices are available in the Property Choices. 

A single choice: 

Choice 

string Key 
The variable name (e.g. "[LLvar]AvABAAA") of this 
selection. The server replaces the prefix "var://" 
with "[LLVar]" to avoid drawing problems. 

string Value The value / name of this selection. 

bool IsSelected Whether this selection is already selected. 

 

Special feature for dependencies: 

▪ use ParentGuid to find out the key of the parent parameter selection: "[LLvar]AvABAAA". 

▪ [optional] If parent parameter also has parent parameter; find its key of selection:"[LLVar]AvACAAA"". 

▪ query dependent selections (RS API v1) 

Here is an example of parameters retrieved: 

Second depends on First. 

Third depends on Second and therefore also on First. 

As XML 

<ArrayOfReportDataParameter xmlns:xsd="http://www.w3.org/2001/XMLSchema" 
xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance"> 
    <ReportDataParameter> 
        <Guid>4CC0CF55-24CA-4C49-9ABF-6402996FDB82</Guid> 
        <Name>First</Name> 
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        <HelpText /> 
        <IsVisible>false</IsVisible> 
        <Choices> 
            <Choice> 
                <Key>[LLVar]AwABAAAA</Key> 
                <Value>Beverages</Value> 
                <IsSelected>true</IsSelected> 
            </Choice> 
            <Choice> 
                <Key>[LLVar]AwACAAAA</Key> 
                <Value>Condiments</Value> 
                <IsSelected>false</IsSelected> 
            </Choice> 
            <Choice> 
                <Key>[LLVar]AwADAAAA</Key> 
                <Value>Confections</Value> 
                <IsSelected>false</IsSelected> 
            </Choice> 
            <Choice> 
                <Key>[LLVar]AwAEAAAA</Key> 
                <Value>Dairy Products</Value> 
                <IsSelected>false</IsSelected> 
            </Choice> 
            <Choice> 
                <Key>[LLVar]AwAFAAAA</Key> 
                <Value>Grains/Cereals</Value> 
                <IsSelected>false</IsSelected> 
            </Choice> 
            <Choice> 
                <Key>[LLVar]AwAGAAAA</Key> 
                <Value>Meat/Poultry</Value> 
                <IsSelected>false</IsSelected> 
            </Choice> 
            <Choice> 
                <Key>[LLVar]AwAHAAAA</Key> 
                <Value>Produce</Value> 
                <IsSelected>false</IsSelected> 
            </Choice> 
            <Choice> 
                <Key>[LLVar]AwAIAAAA</Key> 
                <Value>Seafood</Value> 
                <IsSelected>false</IsSelected> 
            </Choice> 
        </Choices> 
        <SelectMultiple>false</SelectMultiple> 
        <MayBeNull>false</MayBeNull> 
        <MayBeEmpty>false</MayBeEmpty> 
        <SourceMode>Database</SourceMode> 
        <SourceType>Numeric</SourceType> 
        <ControlType>Text</ControlType> 
    </ReportDataParameter> 
    <ReportDataParameter> 
        <Guid>4EBF075B-CAF6-4961-B0DE-493DEE4CE108</Guid> 
        <ParentGuid>4CC0CF55-24CA-4C49-9ABF-6402996FDB82</ParentGuid> 
        <Name>Second</Name> 
        <HelpText /> 
        <IsVisible>false</IsVisible> 
        <Choices /> 
        <SelectMultiple>false</SelectMultiple> 
        <MayBeNull>false</MayBeNull> 
        <MayBeEmpty>false</MayBeEmpty> 
        <SourceMode>Database</SourceMode> 
        <SourceType>Numeric</SourceType> 
        <ControlType>Text</ControlType> 
    </ReportDataParameter> 
    <ReportDataParameter> 
        <Guid>028703D7-A7C1-4B67-84F5-37437F9CE4B8</Guid> 
        <ParentGuid>4EBF075B-CAF6-4961-B0DE-493DEE4CE108</ParentGuid> 
        <Name>Third</Name> 
        <HelpText /> 
        <IsVisible>false</IsVisible> 
        <Choices /> 
        <SelectMultiple>false</SelectMultiple> 
        <MayBeNull>false</MayBeNull> 
        <MayBeEmpty>false</MayBeEmpty> 
        <SourceMode>Database</SourceMode> 
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        <SourceType>Numeric</SourceType> 
        <ControlType>Text</ControlType> 
    </ReportDataParameter> 
</ArrayOfReportDataParameter> 

As JSON 

[ 
    { 
        "Guid": "4CC0CF55-24CA-4C49-9ABF-6402996FDB82", 
        "Name": "First", 
        "HelpText": "", 
        "IsVisible": false, 
        "Choices": [ 
            { 
                "Key": "[LLVar]AwABAAAA", 
                "Value": "Beverages", 
                "IsSelected": true 
            }, 
            { 
                "Key": "[LLVar]AwACAAAA", 
                "Value": "Condiments", 
                "IsSelected": false 
            }, 
            { 
                "Key": "[LLVar]AwADAAAA", 
                "Value": "Confections", 
                "IsSelected": false 
            }, 
            { 
                "Key": "[LLVar]AwAEAAAA", 
                "Value": "Dairy Products", 
                "IsSelected": false 
            }, 
            { 
                "Key": "[LLVar]AwAFAAAA", 
                "Value": "Grains/Cereals", 
                "IsSelected": false 
            }, 
            { 
                "Key": "[LLVar]AwAGAAAA", 
                "Value": "Meat/Poultry", 
                "IsSelected": false 
            }, 
            { 
                "Key": "[LLVar]AwAHAAAA", 
                "Value": "Produce", 
                "IsSelected": false 
            }, 
            { 
                "Key": "[LLVar]AwAIAAAA", 
                "Value": "Seafood", 
                "IsSelected": false 
            } 
        ], 
        "SelectMultiple": false, 
        "MayBeNull": false, 
        "MayBeEmpty": false, 
        "SourceMode": "Database", 
        "SourceType": "Numeric", 
        "ControlType": "Text" 
    }, 
    { 
        "Guid": "4EBF075B-CAF6-4961-B0DE-493DEE4CE108", 
        "ParentGuid": "4CC0CF55-24CA-4C49-9ABF-6402996FDB82", 
        "Name": "Second", 
        "HelpText": "", 
        "IsVisible": false, 
        "Choices": [], 
        "SelectMultiple": false, 
        "MayBeNull": false, 
        "MayBeEmpty": false, 
        "SourceMode": "Database", 
        "SourceType": "Numeric", 
        "ControlType": "Text" 
    }, 
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    { 
        "Guid": "028703D7-A7C1-4B67-84F5-37437F9CE4B8", 
        "ParentGuid": "4EBF075B-CAF6-4961-B0DE-493DEE4CE108", 
        "Name": "Third", 
        "HelpText": "", 
        "IsVisible": false, 
        "Choices": [], 
        "SelectMultiple": false, 
        "MayBeNull": false, 
        "MayBeEmpty": false, 
        "SourceMode": "Database", 
        "SourceType": "Numeric", 
        "ControlType": "Text" 
    } 
] 

Retrieving report templates 

Allows report templates to be listed and searched. 

URLs 

GET    /api/v1/templates 

Optional parameters 

Parameter can be passed in URL as ?param=value or form-encoded in the request body. 

Name Values Default Function 

query string - If this is not specified, all report templates which the client has 
permission to access will be returned. 

Where specified, only report templates which contain all of the 
terms (separated with spaces) specified in their name and their 
description (search terms are linked with AND operator) will be 
returned. 

Query is limited to a maximum of 256 characters and may contain a 
maximum of 10 search terms. 

format json/xml xml Determines the data format of the resulting list (JSON or XML). 

 

Result 

An array of the type ReportTemplateEntry (see below) will be returned. 

Error codes (in addition to general error codes) 

Status code Status text Explanation 

400 ERR_INVALID_PARAM 
The query parameter is too long or contains too many 
search terms. 

 

Examples 

▪ http://combitreportserver/api/v1/templates 

Returns a list of all report templates which the client has permission to access. (Returns as XML) 

▪ http://combitreportserver/api/v1/templates?query=Sales%202015&format=json 

Provides a list of all report templates which contain the words "Sales" and "2015" (please note the coding of 
spaces as %20 in the URL!) (returns as JSON). 

Result type: ReportTemplateEntry 

As XML 

<?xml version="1.0" encoding="utf-16"?> 
<ArrayOfReportTemplateEntry xmlns:xsd="http://www.w3.org/2001/XMLSchema" 
xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance"> 
  <ReportTemplateEntry> 
    <ID>F92699D8-FA81-4C92-9AE5-A5EA2E5F8E61</ID> 
    <Name>Sales Charts 2015</Name> 
    <Description>This is the description.</Description> 
    <ExportLink>http://combitreportserver/api/v1/report/F92699D8-FA81-4C92- 
    9AE5-A5EA2E5F8E61/export</ExportLink> 
    <CreatedBy>Jon Doe</CreatedBy> 
    <CreatedOnUTC>2014-10-16T12:02:52</CreatedOnUTC> 
    <ModifiedBy>Foo Bar</ModifiedBy> 
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    <ModifiedOnUTC>2014-10-21T07:42:25</ModifiedOnUTC> 
  </ReportTemplateEntry> 
  [...] 
</ArrayOfReportTemplateEntry 

As JSON 

[ 
  { 
    "ID": "F92699D8-FA81-4C92-9AE5-A5EA2E5F8E61", 
    "Name": "Sales Charts 2015", 
    "Description": "This is the description.", 
    "ExportLink": "http://<servername>/rs31/api/v1/report/F92699D8-FA81-4C92-9AE5 
    -A5EA2E5F8E61/export", 
    "CreatedBy": "Jon Doe", 
    "CreatedOnUTC": "2014-10-16T12:02:52", 
    "ModifiedBy": "Foo Bar", 
    "ModifiedOnUTC": "2014-10-21T07:42:25" 
  }, 
  ... 
} 

Retrieve printer profiles 

Returns a list of all configured export profiles that print the report to a (network) printer and do not generate any 
files. 

URL 

GET    /api/v1/printerprofiles 

Optional parameters 

Parameter can be passed in URL as ?param=value or form-encoded in the request body. 

Name Values Default Function 

format json/xml xml Specifies the format in which the collection is returned. 

 

Result 

An array of the type PrinterProfileEntry (see below) is returned. 

Error codes (in addition to general error codes) 

None. 

Examples 

▪ http://combitreportserver/api/v1/printerprofiles 
Liefert eine Liste der Exportprofile im XML-Format. 

▪ http://combitreportserver/api/v1/printerprofiles?format=json 
Liefert eine Liste der Exportprofile im JSON-Format.  

ExportResult object: PrinterProfileEntry 

As XML 

<?xml version="1.0" encoding="utf-16"?> 
<ArrayOfPrinterProfileEntry xmlns:xsd="http://www.w3.org/2001/XMLSchema" 
xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance"> 
    <PrinterProfileEntry> 
        <ID>1DE96BF6-831A-47BF-8297-5017F7F600F3</ID> 
        <Name>Black/White-Printer</Name> 
    </PrinterProfileEntry> 
    <PrinterProfileEntry> 
        <ID>3F7ADB74-8F0A-4230-AC57-D1C588AA1654</ID> 
        <Name>Colored Print, Sales Office</Name> 
    </PrinterProfileEntry> 
    ... 
</ArrayOfPrinterProfileEntry> 

As JSON 

[ 
    { 
        "ID": "1DE96BF6-831A-47BF-8297-5017F7F600F3", 
        "Name": "Black/White-Printer" 
    }, 
    { 
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        "ID": "3F7ADB74-8F0A-4230-AC57-D1C588AA1654", 
        "Name": "Colored Print, Sales Office" 
    }, 
    ... 
] 

Retrieving export profiles 

Returns a list of all export profiles configured. 

URLs 

GET    /api/v1/exportprofiles 

Optional parameters 

Parameter can be passed in URL as ?param=value or form-encoded in the request body. 

Name Values Default Function 

format json/xml xml Specifies the format in which the list will be returned. 

 

Result 

An array of type ExportProfileEntry (see below) will be returned. 

Error codes (in addition to general error codes) 

None. 

Examples 

▪ http://combitreportserver/api/v1/exportprofiles 

Returns a list of all export profiles in XML format 

▪ http://combitreportserver/api/v1/exportprofiles?format=json 

Returns a list of all export profiles in JSON format 

Result type: ReportTemplateEntry 

As XML 

<?xml version="1.0" encoding="utf-16"?> 
<ArrayOfExportProfileEntry xmlns:xsd="http://www.w3.org/2001/XMLSchema" 
xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance"> 
  <ExportProfileEntry> 
    <ID>0135FB16-083B-4D0D-958D-DB395BC80EF1</ID> 
    <Name>Bitmap Grafik (.bmp)</Name> 
    <MimeType>image/bmp</MimeType> 
  </ExportProfileEntry> 
  <ExportProfileEntry> 
    <ID>E10FDE06-C266-4006-933C-A31654013279</ID> 
    <Name>CSV-formatted text (.csv)</Name> 
    <MimeType>application/octet-stream</MimeType> 
  </ExportProfileEntry> 
  ... 
</ArrayOfExportProfileEntry> 

As JSON 

[ 
  { 
    "ID": "0135FB16-083B-4D0D-958D-DB395BC80EF1", 
    "Name": "Bitmap Grafik (.bmp)", 
    "MimeType": "image/bmp" 
  }, 
  { 
    "ID": "E10FDE06-C266-4006-933C-A31654013279", 
    "Name": "CSV-formatted text (.csv)", 
    "MimeType": "application/octet-stream" 
  }, 
  ... 
] 

Start scheduled report 

URL 

POST   /api/v1/task/{TaskID}/run 

It is also possible to start the reports with report parameters and overwrite the default values. 
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Example: 

POST http://localhost/rs31/api/v1/tasks/1249E640-BB94-4449-88B4/run$Year=2019 

Important: Normally, users (without administrator rights) can only display and execute tasks which they have 
created themselves (to protect sensitive files in the task actions). API user accounts are not affected by this; 
they can start any task as soon as the Task ID is known. However, the access rights for report templates and 
data sources that are required to carry out a task will still be checked. 

Result 

The request will run until the task is complete (Code 200) or an error has occurred. 

Error codes (in addition to general error codes) 

Status code Status text Explanation 

500 - 

Error during export. The request body consists of two lines: 

[TASK_PHASE] 

[Localized error message] 

TASK_PHASE is "PrepareTask", "GenerateReport", 
"ExecuteActions" or "Unknown" 

404 ERR_INVALID_TASK task not found 

 

Query interdependent selection options 

Returns selection options for a report parameter of a report template if the parameter depends on one or two 
others. 

URLs 

GET    /api/v1/report/{TemplateID}/parameter/{ParameterGuid}/{ParentChoiceKey} 

GET   /api/v1/report/{TemplateID}/parameter/{ParameterGuid}/{ParentChoiceKey}/ 

{ParentParentChoiceKey} 

 

Example: 

/api/v1/report/872C4FEA-DDD4-47B8-B38F-970CEBAD9F50/parameter/4EBF075B-CAF6-4961-B0DE-
493DEE4CE108/dependencies/[LLVar]AwABAAAA 

Optional parameters 

Parameter can be passed in URL as ?param=value or form-encoded in the request body. 

Name Values Default Function 

format json/xml xml Defines the format with which the list of Choice objects is 
serialized. 

 

Result type: IEnumerable<Choice>  

A list of choices is returned. 

As XML 

<?xml version="1.0" encoding="utf-16"?> 
<ArrayOfChoice xmlns:xsd="http://www.w3.org/2001/XMLSchema" xmlns:xsi="http://www.w3.org/2001/XMLS
chema-instance"> 
    <Choice> 
        <Key>[LLVar]AwABAAAA</Key> 
        <Value>Chai</Value> 
        <IsSelected>true</IsSelected> 
    </Choice> 
    <Choice> 
        <Key>[LLVar]AwACAAAA</Key> 
        <Value>Chang</Value> 
        <IsSelected>false</IsSelected> 
    </Choice> 
    <Choice> 
        <Key>[LLVar]AwAYAAAA</Key> 
        <Value>Guaraná Fantástica</Value> 
        <IsSelected>false</IsSelected> 
    </Choice> 
    <Choice> 

http://www.w3.org/2001/XMLSchema
http://www.w3.org/2001/XMLSchema-instance
http://www.w3.org/2001/XMLSchema-instance
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        <Key>[LLVar]AwAiAAAA</Key> 
        <Value>Sasquatch Ale</Value> 
        <IsSelected>false</IsSelected> 
    </Choice> 
    <Choice> 
        <Key>[LLVar]AwAjAAAA</Key> 
        <Value>Steeleye Stout</Value> 
        <IsSelected>false</IsSelected> 
    </Choice> 
    <Choice> 
        <Key>[LLVar]AwAmAAAA</Key> 
        <Value>Côte de Blaye</Value> 
        <IsSelected>false</IsSelected> 
    </Choice> 
    <Choice> 
        <Key>[LLVar]AwAnAAAA</Key> 
        <Value>Chartreuse verte</Value> 
        <IsSelected>false</IsSelected> 
    </Choice> 
    <Choice> 
        <Key>[LLVar]AwArAAAA</Key> 
        <Value>Ipoh Coffee</Value> 
        <IsSelected>false</IsSelected> 
    </Choice> 
    <Choice> 
        <Key>[LLVar]AwBDAAAA</Key> 
        <Value>Laughing Lumberjack Lager</Value> 
        <IsSelected>false</IsSelected> 
    </Choice> 
    <Choice> 
        <Key>[LLVar]AwBGAAAA</Key> 
        <Value>Outback Lager</Value> 
        <IsSelected>false</IsSelected> 
    </Choice> 
    <Choice> 
        <Key>[LLVar]AwBLAAAA</Key> 
        <Value>Rhönbräu Klosterbier</Value> 
        <IsSelected>false</IsSelected> 
    </Choice> 
    <Choice> 
        <Key>[LLVar]AwBMAAAA</Key> 
        <Value>Lakkalikööri</Value> 
        <IsSelected>false</IsSelected> 
    </Choice> 
</ArrayOfChoice> 
 

As JSON 

[ 
    { 
        "Key": "[LLVar]AwABAAAA", 
        "Value": "Chai", 
        "IsSelected": true 
    }, 
    { 
        "Key": "[LLVar]AwACAAAA", 
        "Value": "Chang", 
        "IsSelected": false 
    }, 
    { 
        "Key": "[LLVar]AwAYAAAA", 
        "Value": "Guaraná Fantástica", 
        "IsSelected": false 
    }, 
    { 
        "Key": "[LLVar]AwAiAAAA", 
        "Value": "Sasquatch Ale", 
        "IsSelected": false 
    }, 
    { 
        "Key": "[LLVar]AwAjAAAA", 
        "Value": "Steeleye Stout", 
        "IsSelected": false 
    }, 
    { 
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        "Key": "[LLVar]AwAmAAAA", 
        "Value": "Côte de Blaye", 
        "IsSelected": false 
    }, 
    { 
        "Key": "[LLVar]AwAnAAAA", 
        "Value": "Chartreuse verte", 
        "IsSelected": false 
    }, 
    { 
        "Key": "[LLVar]AwArAAAA", 
        "Value": "Ipoh Coffee", 
        "IsSelected": false 
    }, 
    { 
        "Key": "[LLVar]AwBDAAAA", 
        "Value": "Laughing Lumberjack Lager", 
        "IsSelected": false 
    }, 
    { 
        "Key": "[LLVar]AwBGAAAA", 
        "Value": "Outback Lager", 
        "IsSelected": false 
    }, 
    { 
        "Key": "[LLVar]AwBLAAAA", 
        "Value": "Rhönbräu Klosterbier", 
        "IsSelected": false 
    }, 
    { 
        "Key": "[LLVar]AwBMAAAA", 
        "Value": "Lakkalikööri", 
        "IsSelected": false 
    } 
] 

Import report templates and settings 

URL 

POST    /api/v1/management/import 

The options are passed via the body as multipart/form-data. The export file to import is also added via the form 
body (only one file is supported): 

Name Type Function 

Password string The password to decrypt the export file (empty for no password) 

DatabaseUsername string only for PostgreSQL: username of the database administrator to log in (e.g. 
"postgres") 

DatabasePassword string only for PostgreSQL: password of the database admin-rator account 

 

Optional parameters 

can be passed in url as ?param=value or form-encoded in request body 

Name Values Default Function 

format json/xml xml Specifies the format in which the collection is returned. 

Name Values Default Function 

format json/xml xml Specifies the format in which the collection is returned. 

 

Result 

Return type: ImportResult 

Statuscode explanation 

ImportedDatasets Number of imported datasets 

SkipedDatasets Number of skipped datasets 
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As JSON 

{ 
  "ImportedDatasets": 0, 
  "SkipedDatasets": 0 
} 

Export report templates and settings 

URL 

POST    /api/v1/management/export 

The options are passed via the body as JSON with the following model: 

Name Type Function 

ExportAll boolean Specifies whether all settings should be exported (true), or only those 
specified in SelectedTempla-tes (false). 

Password string Optional password with which the export should be encrypted (must be 
entered during the later import). Encrypted with PBKDF2 and AES-256 

SelectedTemplates string[] Specifies the report templates to export (list of report template IDs) 

 

Optional parameters 

Can be passed in url as ?param=value or form-encoded in request body. 

Name values Default Function 

format json/xml xml Specifies the format in which the listing is returned. 

 

Result 

Return type: byte[] 

Returns the file as "content" with "applicati-on/octet-stream" and the filename "export.rsxfer" on successful export. 

2.9.3 Examples 

Introduction 

These examples have been created for the open source command line tool Curl. With this you can, for example, 
control and test REST-based interfaces; additional information can be found at https://curl.haxx.se 

Recognizing errors 

When using Curl, add "-v" to see the header. For example: Authentication with API token without (necessary) use 
of https:// leads to: 

curl -v "http://combitreportserver/api/v1/....?clientid=abc&clienttoken=123 
< HTTP/1.1 403 ERR_SSL_REQUIRED 
< Cache-Control: private 
< Date: Tue, 14 Apr 2015 11:04:04 GMT 
< Content-Length: 0 

The error code (i.e. "ERR_SSL_REQUIRED") will then be displayed here. 

Authentication with Windows authentication / NTLM 

The options "--ntlm --negotiate" and "-u" are required! 

1. By specifying the user name and password     

curl --ntlm --negotiate -u "DOMAIN\NAME:PASSWORD" "http://combitreportserver/api/....." 

2. Use user account of the current process (colon instead of user name & password) 

curl --ntlm --negotiate -u : "http://combitreportserver/api/....." 

Authentication with API token 

1. As header (recommended, possible without SSL) with "-H" option 

curl -H "X-ReportServer-ClientID: apiuser1" -H "X-ReportServer-ClientToken: 
y8kUirLTXL+KIl7tDXptvvu11WFB9yfn" "http://combitreportserver/api/....." 

https://curl.haxx.se/
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2. As URL parameter (only possible with SSL) 

curl "https://combitreportserver/api/.....?clientid=apiuser123& 
clienttoken=y8kUirLTXL+KIl7tDXptvvu11WFB9yfn" 

Access report and save to file 

ID of report template: 2551186E-F854-4D1A-ACAE-8ABA02241AE2 

Here with API token in URL; first file of the report will be accessed and saved to the file "salesreport.pdf" 

curl "https://combitreportserver/api/v1/report/2551186E-F854-4D1A-ACAE-
8ABA02241AE2/export?clientid=apiuser123&clienttoken=abc" > salesreport.pdf 

Access report with several files 

ID of the report template: 2551186E-F854-4D1A-ACAE-8ABA02241AE2 

ID of an Export profile which will create several JPG images: F8786F1D-CF4D-4B9D-9EB5-A01ED7375A4E 

Parameters for authentication have been omitted here; instead the option "zip=true" was set in order to obtain all 
exported files.   

curl "https://combitreportserver/api/v1/report/2551186E-F854-4D1A-ACAE-8ABA02241AE2/export/F8786F1D-
CF4D-4B9D-9EB5-A01ED7375A4E?zip=true" > temp.zip 
7z e temp.zip 

A 7z command is used in order to unpack the zip archive with the exported files delivered by the report server 
(requires installation of 7zip). 

Trigger scheduled report 

ID of scheduled report: 2551186E-F854-4D1A-ACAE-8ABA02241AE2 

Parameters for authentication have been omitted here, what is important here is the option "-X POST", because 
HTTP-get is not supported for starting tasks. 

curl -X POST "https://combitreportserver/api/v1/task/2551186E-F854-4D1A-ACAE-8ABA02241AE2/run" 
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3. Working with the Designer 

3.1 Introduction 
Various print templates for printing information originating from the data sources defined in combit Report Server 
can be created or edited by the Designer. The Designer will then provide all the data, which can be prepared in 
different ways for printing. 

In doing so, the Designer always uses the data that has been provided by combit Report Server, meaning the 
selection and compilation of the data is carried out by the definition of a report template in combit Report Server.  

The Designer and the preview and export dialog will usually be executed by combit Report Server. The Designer, 
however, can be launched from the desktop shortcut. The first time you start the application, you need to enter 
the combit Report Server URL. In the login dialog, enter your username and password. The checkbox "Force Login" 
automatically ends a possibly existing parallel session of the same user. 

 
Figure 3.1: combit Report Server Designer - Application 

3.1.1 General 

The different print templates are referred to as "Projects". Along with the actual print information, a project also 
contains, above all, layout specifications such as page size and orientation, fonts, colors, frames, circles, lines, 
graphics etc. The Designer can handle three different types of projects: Lists, labels and cards. 

The individual elements of such a project are called "objects". For example, a project can contain text objects, 
picture objects and a report container.  

The required objects are normally selected in the object list, created on the workspace with the mouse and then 
given the respective contents and layout properties.  

The Designer provides different types of objects which you can position freely in the workspace and change the 
size as required. 

▪ Text and contents of variables 

▪ Lines, Rectangles, Circles and ellipses 

▪ Picture object 

▪ Barcode 

▪ Report container: The Report containers can hold tables, charts, crosstabs and Gantt charts. 

▪ Charts: Schematic view of data. 

▪ Crosstabs: For presenting data in multiple dimensions. 

▪ Formatted text: For changing the formatting within a line. 

▪ Form elements: For entering data in the preview and PDF format. 

▪ Data Graphic: For simple visualization of data as a bar or symbol. 

▪ Gauge: For visualization of data as gauge or scale. 

▪ HTML content: For embedding HTML pages. 

▪ PDF: For embedding PDF documents. 
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3.1.2 Screen 

The Designer interface consists of a workspace and different tool windows.  

▪ A Ribbon with the particular available functions respectively the toolbars "Objects" and "Actions". You can select 
the display type (ribbon or toolbar) in the project options (File > Options > Workspace). This manual names 
the commands in the Ribbon and the corresponding menu option in brackets. 

 
Figure 3.2: The Ribbon 

The ribbon can be hidden by double clicking on the tab. The blue button in the top left is described as "File". 
The File menu contains commands for saving and using the print project. 

▪ The objects are placed in the workspace. You change the shape and size of the workspace via Project > Page 
Setup. 

▪ You can select the viewing mode by means of the tabs at the workspace borders: Layout, Layout Preview, 
Preview. 

▪ The status bar with the current mouse position, the current operation, the position/size and the Zoom Slider. 

▪ Tool windows for the available variables and fields (Variables-/Field-List), the objects and elements of the report 
container, the different display layers (Layers) and the properties of the selected object or project (Properties). 

3.1.3 Repository 

All files required for a project (project files, images, PDF files, DrillDown project files) are managed at a central 
location, the so-called repository. This collection allows the complete avoidance of local filenames, since all files 
are automatically transferred to the collection after selection. The files are then available for the respective report. 

 
Figure 3.3: Open file dialog with reference to repository 

3.2 Getting Started 
This chapter describes how to create a simple list based on a sample data source.  

3.2.1 The Examples in this manual 

A sample data source is used to create the examples for this manual. This sample data source contains a Microsoft 
Access Database for a fictitious company called "Northwind" with sample data for a food wholesaler.  

It is a relational database meaning that the data is distributed across several tables. Each table contains data 
elements that are related to one another. For instance, one table contains the product data. Another contains the 
product categories. A table's columns are referred to as fields (product name), and the rows of a table as data 
records. 
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Figure 3.4: Structure of the Microsoft Northwind sample database 

3.2.2 Creating a Simple Report 

For a first simple report, you will produce a product list in alphabetical order with a report title and a company logo. 

1. Create a report template (see "Creating report templates") based on the template type "Standard". 

2. Start the Designer. 

3. The standard project for the respective project type is displayed. This standard project is normally an empty 
workspace with a certain paper size and alignment.  

With label projects, a certain label format (size and arrangement of the individual labels on the sheet) is already 
specified as a default value. 

4. If you have chosen "New project wizard" under File > Options > Workspace the project wizard will start. The 
project wizard simplifies the job of creating new projects by leading you through different page setup options. 
We don´t use the wizard for this example. 

 
Figure 3.5: Empty workspace 

Inserting a Company Logo into the Report 

For the company logo you need the "Picture" object and an image file. Proceed as follows: 

1. Choose Insert > Picture (Objects > Insert > Picture). 

 
Figure 3.6: Tab "Insert" 

Note: Objects are your project's building blocks. They are generated in the workspace where they are also 
given a border with which their size and position can be changed. This border defines the space that the 
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object takes up and thus also the maximum size to which the contents of the respective object can be 
expanded. Objects may overlap fully or partly.  

2. In the workspace, point the mouse to the position where the upper left corner of the object is to begin. The 
mouse cursor changes to a crosshair. Hold down the left mouse button and drag the crosshair to the lower 
right corner of the planned object. Release the mouse button when the object (the dashed border) is the right 
size. 

Note: Objects can be added to the workspace in different ways: via the menu Objects > Insert, via the 
toolbar or via keyboard shortcuts, or with Drag & Drop from the list of variables. 

3. Select if the picture is loaded from the repository, a file or if the content is defined by a formula/variable. 

 
Figure 3.7: Picture source selection 

4. If you select File, a file selection dialog will appear. Select the image file.  

5. After you select the file, the logo will be inserted. 

 
Figure 3.8: Report with picture object 

Adding a Title to the Report 

Use a text object to add a title to the report. Text objects let you place text in the workspace. As well as fixed text, 
you can also insert the contents of fields (variables) from the database (e.g. company name), or you can use 
functions (page number, date etc.).  

1. Choose Insert > Text (Objects > Insert > Text). 

 
Figure 3.9: Tab "Insert" 

2. In the workspace, hold down the left mouse button and pull the object to the required size. Text objects should 
always be created in the maximum size you want, the object shrinks at print time to the required size.  

3. The formula wizard will now appear which you can use to define the contents of the text object.  
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This dialog consists of a series of tabs each containing different elements to be edited. The following chapters 
explain the meanings of these elements in more detail. 

▪ Data and Functions: the available variables, fields and functions. 

▪ Condition: for defining IF-THEN-ELSE conditions. 

▪ Text: for entering fixed text and tabs. 

▪ Date Format: different date formats. 

▪ Number Format: different number formats. 

▪ Operators: available conjunction operators. 

You can also enter the expression that you want directly in the edit box or modify the text that is there (e.g. 
put something in brackets). 

Therefore, enter our title "Products" directly. Fixed text must be enclosed in quotation marks. Enter names of 
data and functions without brackets.  

 
Figure 3.10: Text in the formula wizard 

4. The title will be displayed when you close the dialog with OK. 

5. Use the Tab Texttools > Text (mini-toolbar) to enlarge the font size. 

6. You have now added the title: 

 
Figure 3.11: Report with text object 
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Insert the Table for the Product List 

Use the "Report Container" object to add a table to the report. As the name says, a report container can hold several 
objects: tables, charts and crosstabs can be added in any order.  

1. Choose Insert > Report Container (Objects > Insert > Report Container). 

 
Figure 3.12: Tab "Insert" 

2. In the workspace, hold down the left mouse button and pull the object to the required size. 

3. A selection dialog will appear for the chosen element type. Choose the "Table" element type. 

 
Figure 3.13: Choosing the object type 

4. Now supply the data source in the following dialog. All available tables are shown hierarchically; in other 
words, under the tables, you will find the relational tables in each case. 

 
Figure 3.14: Choosing the data source 

Select the "Products" table because it contains the fields that we want for our product list.  

5. A selection wizard will appear with all the fields in the "Products" table. In addition, underneath the "Products" 
table, you will also find the fields in the tables "Categories" and "Suppliers" which have a 1:1.relationship with 
"Products". 
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Figure 3.15: Data Selection Wizard 

In this dialog, now choose the columns for the table. Double-click a field, e.g. "ProductName". The field will be 
added to the "Columns" area. 

6. Repeat this step for all fields that are to be shown in the table; i.e. also the "CategoryName" field from the 
linked table "Categories" and the "UnitPrice" field for the unit price. Confirm your selection with OK. 

7. The table will now be displayed in the workspace. 

▪ The selected fields are displayed in the data line, in other words, the data line contains the data.  

▪ In addition, a header line is automatically produced. Header lines are used mostly as column titles, i.e. the 
selected field names are now shown here as text. 

▪ If you pull the report container widthwise to make it wider or narrower while holding down the CTRL key, the 
columns will be adjusted proportionally to fit.  

▪ The width of the columns adjusts automatically. You can adjust the width of a column manually by moving the 
separating line to the right or the left with the mouse.  

Note: This changes all table columns, whose separators are within +/-2 mm from the mouse position. If 
you hold down the CTRL key, the action will only be carried out for the line on which the mouse is 
positioned. If the option "Change width individually" is enabled (Table> Lines and Columns or CTRL+M or 
project option "Column width modification affects next column"), you can alter the column width while 
making the next column smaller. 

 
Figure 3.16: Report with table in the report container object 

Formatting Table Fields 

Chapter "Creating Professional Tables" in the Designer-Manual describes how you can format and modify a table. 
Only a few basic formatting options are explained here. 
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1. In the product category column title, the field name "CategoryName" is shown. Click the respective field in 
order to change this text to "Category". The formula wizard will now appear, which you can use to change the 
contents of the field. Please consider that text must be enclosed in quotation marks. 

 
Figure 3.17: Formula wizard with text input 

2. In addition, we want to format the unit price as currency and align the entire column to the right. You will find 
both formatting options in the tab Table Tools > Table (mini-toolbar). Click in the upper left corner to select 
the field containing the unit price. 

 
Figure 3.18: Selecting a single field 

3. Click the button "% Format" for the formatting dialog 

4. A selection dialog will now appear in which you can select the formatting that you want for the numeric field. 
To do this, choose the type on the left hand side i.e. "Currency". In the right pane, you can specify the currency 
formatting in detail.  

By default, the application settings are used. The application setting is the same as the system setting. 
Alternatively select a custom setting. 

 
Figure 3.19: Formatting dialog 

5. Finally, select both fields (the header and the data line) to align them to the right. To do this, hold down the 
CTRL key and select both fields by clicking in the upper left corner in each case. Then click the button for right 
alignment.  
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Figure 3.20: Multiple field selection 

Displaying a Preview of the Report 

Until now, you have only seen the report in layout view as a structure with a record. To get an impression of the 
result, you can display a preview of the report. Use the tabs in the bottom margin of the workspace to change to 
the preview. 

 

Figure 3.21: "Preview Options" toolbar 

The report will now be displayed with the data from the "Products" table.  

1. To do this, save the report with File > Save. 

2. End the Designer with File > Close. 

3. Open the print template that you created again via Design > Extended Samples, and switch to preview mode. 
Your report will look roughly like this: 

 
Figure 3.22: Real data preview 

Adding a Page Number 

It's a good idea to add a page number in the lower area of the page. To do this, add a new text object. You will be 
using functions (such as the page number function) as well as fixed text with this object.  

1. Choose Insert > Text (Objects > Insert > Text). 

 
Figure 3.23: Tab "Insert" 

2. In the workspace, hold down the left mouse button and pull the object to the required size. 

3. The formula wizard will now appear which you can use to define the contents of the text object. The available 
functions are shown in the right pane. You can use an auto filter with this list. Type "page" in the filter field. 
This will cause all functions containing the expression "page" to be displayed. 

▪ The "Page$ ()" function returns the page number. 

▪ The "TotalPage$ ()" function returns the total number of pages. 

Add the "Page$ ()" function to the result area by double-clicking. 

4. If you now want to output a footer in the form of "Page 1 of 2", you can enter the text "of" directly in the usual 
way. Please consider that individual parts must be joined with a "+" and that text must be enclosed in quotation 
marks. 
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5. Now add the "TotalPages$ ()" function by double-clicking to get the total number pages. The formula will look 
like this: 

 
Figure 3.24: Formula wizard with functions and text 

6. You can center this line in the report in the usual way: 

 
Figure 3.25: Quick format "centered" alignment 

7. Switch to preview mode to view the result: 

 
Figure 3.26: Real data preview in the Designer 

3.2.3 Creating a Simple Invoice 

In this chapter, you will now meet functions and possibilities for designing reports. 
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For the next example, you will create a multi-page invoice with covering letter, invoice header, totals, footers, 
enclosure and printed copy. 

Create a New Print Template 

1. Create a report template (see "Creating report templates") based on the template type "Invoices". 

2. Start the Designer. 

3. A file selection dialog will appear. To start a new project, choose the New button. 

Note: This button is not available in Windows XP. Enter a name for the new print template in the "File name" 
field and then choose "Open".  

To open or edit an existing project, choose Open. 

Adding a Company Logo 

Use the picture object to add a logo. 

1. Choose Insert > Picture (Objects > Insert > Picture). 

 
Figure 3.27: Tab "Insert" 

2. Pull the object to the right size and select an image file (see Chapter "Inserting a Company Logo into the 
Report"). 

Add the Address Field 

To add an address, use the text object. Text objects let you place text or the contents of fields in the workspace. 

 
Figure 3.28: Address field: it should look like this. 

1. Choose Insert > Text (Objects > Insert > Text). 

 
Figure 3.29: Tab "Insert" 

2. Pull the object to the required size. Text objects should always be created in the maximum size you want, the 
object shrinks at print time to the required size. 

3. The formula wizard will now appear which you can use to define the contents of the text object.  

This dialog consists of a series of tabs. On the "Data and Functions" tab, select the variable for the company 
address (company) from the list of available variables and fields.  

You will see an auto filter field above the list of data. This means that you can enter "Company" to display all 
fields and variables containing this expression. Select the variable that you want by double-clicking and confirm 
your selection with OK. You have now defined the first line of the address field. 
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Figure 3.30: Formula wizard with variable 

4. A text object can hold as many paragraphs as you want and they can all have completely different display 
properties. You can add more paragraphs by means of the tab Text Tools > Text (mini-toolbar). Choose 
"Append" to define an additional line. 

 
Figure 3.31: The Tab Tools-Tab "Text" 

5. The formula wizard will now appear, which you can use to define the contents of the paragraph. Now enter 
the first name and the last name of the recipient. First choose the "Firstname" variable. 

6. You should insert a space before choosing the "Lastname" variable to prevent the contents of the two variables 
from being placed end to end. A space is simply "Text". Fixed text must be enclosed in quotation marks. So 
now enter "+" as a joining operator followed by " " for the space. 

7. Now select the "Lastname" variable. You must naturally also join this with "+". The whole line looks like this: 

 
Figure 3.32: Linking variables and text 

8. Now continue with the other variables: street and city. You have now completed the address field. 
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Figure 3.33: Text field with 4 paragraphs 

Create Invoice Header With Number and Date 

Use the text object again to add the text "Invoice", the invoice date and the invoice number to an invoice header.  

 
Figure 3.34: Invoice header: it should look like this. 

1. Choose Insert > Text (Objects > Insert > Text). 

2. Pull the object to the required size. 

3. The formula wizard will now appear, which you can use to define the contents of the text object. Type "Invoice". 

4. Add another paragraph by means of the tab Text Tools > Text (mini-toolbar) and the "Append" button. 

5. The formula wizard will appear. Type "Date". 

6. Before you enter the invoice date, insert a tab stop so that the invoice date is aligned to the right. You can 
insert a tab stop by means of the "Text" tab.  

 
Figure 3.35: Adding a tab stop to a text expression 

7. You create a tab stop with the "Tab" button and you define the position and alignment with the "Properties" 
button.  

Note: Only one tab stop can be inserted on each line. A tab stop causes the preceding text to run only as far 
as the tab stop. A tab stop that is right aligned will cause the text that follows it to be justified to the right. 
The distance from the left margin determines the position of the tab stop. 

Since a tab stop is also a character, it must also be enclosed in quotation marks. Alternatively, in this example, 
you can insert the tab stop with "Insert" to the existing "Invoice date" text. 

8. Finally, position the cursor outside of the text field and insert the "Invoice_Date" variable with the "Data and 
Functions" tab.  

The format will be converted automatically. 
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Conversion with the "Date$()" function is essential since the invoice date has the "date" type and the value that 
is returned is already defined as a "string" by the "Invoice date" text expression entered earlier. The return value 
must always be unique. The date value must therefore be converted to a string by means of a function. The 
"Date$()" function is one way of doing this.  

 

Figure 3.36: Format conversion with Date$() 

The automatic format conversion uses "%x" as the formatting parameter. If you want a different output format, 
switch to the "Date Format" tab. You can choose a format here and then select the "Invoice_Date" variable. 

9. Now add the invoice number in the same way. 

The format will be converted automatically here as well. 

 
Figure 3.37: Format conversion with Str$() 

Conversion with the "Str$()" function is essential since the invoice number is a field with the "number" type and 
the value that is returned is already defined as a "string" by the "Invoice number" text expression entered earlier. 
The return value must always be unique. The number must therefore be converted to a string by means of a 
function. The "Str$()" function is one way of doing this. This function has 3 parameters: The first parameter is 
the number that is to be converted to a string; the second parameter specifies the minimum length and the 
third parameter the number of decimal places. 

10. Now increase the font size for "Invoice". To do this, select the relevant line. 
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11. Set the font size to 24 by means of the "font size" button in Text Tools > Text (mini-toolbar). 

12. Now open the paragraph properties dialog via double-click to increase the distance to the next line. In this 
dialog, you can define the properties for each line. Set the value for the "Paragraph Spacing" property for the 
first line to 12 pt. 

 
Figure 3.38: Paragraph properties dialog 

13. And you now have an attractive invoice header. 

Adding the Item List 

Use the "Report Container" object to add the item list to the report. As the name says, a report container can hold 
several objects: tables and freely defined content, charts and cross tabulations. You need the "Table" element for 
the item list, and "Free content" for the covering letter. Please see chapter "Insert the Table for the Product List" for 
an introduction about how to create tables.  

1. Choose Insert > Report Container (Objects > Insert > Report Container). 

 
Figure 3.39: Tab "Insert" 

2. In the workspace, hold down the left mouse button and pull the object to the required size. 

3. A selection dialog will appear for the chosen element type. Choose the "Table" element type. 

 
Figure 3.40: Object type selection 

4. Now select the data source in the following dialog. All available tables are shown hierarchically; in other words, 
under the tables, you will find the related tables in each case. Select the "Items" table because it contains the 
fields that we want for our item list.  

5. A selection wizard will appear with all the fields in the "Items" table.  

6. In this dialog, now choose the columns for the item list. Double-click one after another on the fields: "Quantity", 
"No", "Description1", "UnitPrice". This will add the fields to the "Columns" area. Confirm your selection with OK. 
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Figure 3.41: Data Selection Wizard 

7. The table will now be displayed in the workspace. A header line with strings as the column titles and a data 
line with the contents of the fields will be created automatically. 

The width of the columns adjusts automatically. You can adjust the width of a column manually by moving the 
separating line to the right or the left with the mouse.  

Note: This changes all table columns, whose separators are within +/-2 mm from the mouse position. If you 
hold down the CTRL key, the action will only be carried out for the line on which the mouse is positioned. If 
the option "Change width individually" is enabled (Table> Lines and Columns or CTRL+M or project option 
"Column width modification affects next column"), you can alter the column width while making the next 
column smaller.  

 
Figure 3.42: Changing column widths with the mouse 

8. In the next step, you add a new column: "Total". Select the "UnitPrice" field by clicking in the upper left corner 
of the field. Then choose the "Insert Right" in Table Tools > Table (mini-toolbar). 

 
Figure 3.43: Select column 

9. A menu will appear for the selected field type. Choose "Text" here. 

10. The formula wizard will now appear, which you can use to define the contents of the field. Type "Total" and 
confirm with OK. 

A message will now appear giving you the option of reducing the width of the columns to allow the new 
column to be inserted in the visible area. Confirm this dialog. You have now added an additional column to the 
header line. You now need this column in the data line as well. 

11. Now select the data line field containing the item price and add a new column to it. The total price is now to 
be calculated here. The total price is calculated by entering "Quantity*ItemPrice". To do this, select the relevant 
variables by double-clicking them. 
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Figure 3.44: Multiplying two values in the formula wizard 

Note: Open the list of available operators by clicking the "Operators" tab. Operators join two or more values 
or variables to give a new value. In this way, you can formulate arithmetic expressions (basic arithmetic 
operations) or logical expression. You can combine multiple operations in one expression. Please consider 
the calculation hierarchy of the operators used and place them in brackets if necessary. The "+" operator has 
a special meaning. It is not only suitable for additions ("Number" and "Date" value types) but is also used for 
joining strings. 

Alignment and Formatting 

Make use of the numerous formatting options to present the invoice in the form that you want. For example, 
change the column title and format the amounts as currency.  

1. Click the column title that you want to change. The formula wizard will now appear, which you can use to 
change the contents of the field. Please consider that text must be enclosed in quotation marks. 

2. In addition, you should also align the columns for the unit price and the total price with the column titles. To 
do this, hold down the SHIFT key and select all 4 fields by clicking in the upper left corner of the "Item Price" 
data line. Then choose the button for right alignment in the Table Tools (mini-toolbar).  

3. To format both amounts as currency, hold down the CTRL key and select both fields by clicking in the upper 
left corner of each one. Then choose the button for the formatting dialog. 

 
Figure 3.45: Multiple field selection 

4. A selection dialog will now appear in which you can select the formatting that you want for the numeric field. 
To do this, choose the type on the left hand side i.e. "Currency". In the right pane, you can specify the currency 
formatting in detail. 

By default, the application settings are used. The application setting is the same as the system setting. 
Alternatively select a custom setting. 
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Figure 3.46: Formatting a field 

5. Format the field for the quantity as a number without decimal points. 

6. Our item list will now look roughly like this: 

 
Figure 3.47: Preview 

Background Color and Frame 

In order to structure the invoice and make it more attractive, it's a good idea to give at least the column headers a 
colored background. You can also modify the background color. 

1. To do this, select a column title. 

2. Now open the paragraph properties dialog via double-click. In this dialog, you can define the properties for 
each column and row. Hold down the CTRL key and select all columns. 

3. Click the "+" sign to expand the "Background" property group. 

4. For the background, choose the "Pattern/block color" property and the color, e.g. LL.Color.LightSkyBlue. You 
reach the LL.Colors via the arrow button and the standard color dialog via the ... button. 
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Figure 3.48: Object properties dialog for the table: background 

5. In addition, you want to increase the spacing between the header and the data line. Since this is a line property 
(and not a column property), select the line. Here you have the "Spacing" property. Choose e.g. 0.1 inch as 
"Bottom" to increase the spacing below the column title. 

 
Figure 3.49: Object properties dialog for the table: margins 

6. Now it only remains to make the settings for the frame. You can define different settings independently for 
each cell. However, it's normally a good idea to make the settings for the entire table. For this reason, the 
settings for the frame are included in the table properties. You will find the table properties, as standard, on 
the lower left when you select the table in the "Report Container" tool window. When you select the property, 
there is a button which you can use to open the dialog for the frame properties. 
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Figure 3.50: Frame properties 

7. Choose "white" as the color and click "Outline" to apply the color.  

Please note: If you don't apply the setting but simply confirm the dialog with OK, your settings will be lost! 

8. The invoice will now look roughly like this in the preview: 

 
Figure 3.51: Preview (frame and background) 

Invoice Footer With Totals 

You now need to output the net totals, the VAT and the total amount in the invoice footer. You can simply insert 
these values if they are held as fields in the database. 

In our case, however, you must first calculate the values. To do this, you use the "Sum()" aggregate function. This 
function totals the values that are passed to it. 

Since the totals are to be output at the end of the table, you define a footer for this purpose. 

1. Click "Insert Above" in the Table Tools (mini-toolbar) and then click "Footer Line". 

 
Figure 3.52: Add new line 

2. You have not yet defined a line for this line type so you will be asked whether you want to use an existing line 
definition from one of the other line types. This wouldn't save any time at this point. Therefore, choose the 
"Single field or free content" option. 

 
Figure 3.53: Applying a line definition 



Working with the Designer Getting Started 

83 

3. The formula wizard will open to allow you to define the contents of the first column. Enter "Subtotal", not 
forgetting to enclose it in quotation marks. 

4. Once you have created the first line, add another column to it for the aggregation. Use the "Sum()" function for 
aggregating values. You can either type it in directly in the result field in the formula wizard or you can select 
the function from the list of aggregate functions by double-clicking. As a parameter, enter the value to be 
aggregated – in this case Quantity*ItemPrice.  

 
Figure 3.54: Totaling with Sum() 

5. The entire line should now be moved a little to the right. Hold down the CTRL key and drag the column separator 
on the extreme left at the outer edge of the table to the right. An empty column will be inserted automatically 
as a spacer on the extreme left. 

6. You must also format the total field as currency, give both columns the same background color as the header 
line and set the "Top" margin to 0.1 inch to correspond with the "Bottom" margin of the header line. 

7. As these footers are only to be output on the last page, even in the case of multiple page invoices, you must 
now specify the "Lastpage()" or "LastFooterThisTable()" function for the "Appearance Condition" line property. 

 
Figure 3.55: Object dialog with 3 columns 

8. You have now defined the first footer and the invoice looks like this: 



Working with the Designer Getting Started 

84 

 
Figure 3.56: Preview (footer) 

Create Additional Footer Lines 

You can create as many line definitions as required for each line type (data line, footer). The different line definitions 
are shown in the object dialog as a tree structure.  

For our example, now create two more footers for the VAT and the grand total. 

 
Figure 3.57: Preview 3 footers 

1. To add more lines in the object dialog, first select an existing line definition. You can then create a new line 
definition with the "Append line definition" button.  

 
Figure 3.58: Object dialog with 4 lines 

Alternatively, you can add a new line via the context menu or with the Table Tools (the mini-toolbar) directly in 
the workspace. 

2. A dialog will appear asking you whether you want to use an existing line definition. It saves some time if you 
use the footer that you have already created as you will not have to configure the left margin, alignment or 
background colors. Therefore, choose the "Line definition 1" entry from the "Footer" area. 

3. The line will now be inserted. Click the "Subtotal" field so that you can then change the content to "VAT" with 
the formula wizard. Don't forget to enclose the text in quotation marks. 

4. Once you have created the column, click in the column to enter the aggregation. Instead of the total net 
amount, the 10% VAT is to be output here. Therefore, you simply multiply the amount by 0.1: 

Sum (Item.Quantity * Item.UnitPrice * 0.1) 
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5. Proceed in the same way with the third footer. Copy the existing footer, change the content and, in the formula, 
add the VAT to the total, like this: 

Sum (Item.Quantity * Item.UnitPrice * 1.1) 

6. You have now defined the footer and the invoice looks like this: 

 
Figure 3.59: Invoice with 3 footers 

3.2.4 Creating a Simple Label 

For your first label, you will now create an item label. 

1. Create a report template (see "Creating report templates") based on the template type "Label". 

2. Start the Designer. 

3. A file selection dialog will appear. To start a new project, choose the New button.  

Note: This button is not available in Windows XP. Enter a name for the new print template in the "File name" 
field and then choose "Open".  

To open or edit an existing project, choose Open. 

4. The standard project for this project type is displayed. This standard project is normally an empty workspace 
with a certain paper size and alignment.  

Select a label format via Project > Layout Regions (Project > Page Setup). In the "Templates" tab, choose the 
template that you want from the predefined label formats of various manufacturers. This specifies automatically 
the size of the individual labels, how many are to appear on the sheet and how they are to be distributed. You will 
find more information about this in the chapter "Templates for Label Formats" in the Designer-Manual. 
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Figure 3.60: Specify label format 

5. A single label will now be displayed in the workspace.  

Insert Object 

A picture of the item is to be displayed as a picture object on the label together with two text objects (Item_No, 
Description and Price). Place a tab stop between the text "Item No." and the "Item_No) variable. 

 
Figure 3.61: It should look like this 

1. Begin by positioning the text object. Choose Insert > Text (Objects > Insert > Text). 

 
Figure 3.62: Tab "Insert" 

2. Pull the object to the required size. 

3. The formula wizard will now appear, which you can use to define the contents of the text object.  

4. Now follow the steps described in Chapter "Add the Address Field" onwards. 
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5. Use the picture object to add a logo. Drag the "Picture" variable from the list of variables into the workspace. 
Pull the object to the required size. 

Insert Barcode 

The content dialog for the barcode object lets you define the barcode more precisely. Choose "Text" if you want to 
print fixed text as a barcode. Choose "Formula" if you want to use a formula as a barcode, and define a valid formula 
expression with the "Edit" button. The formula must return a "barcode" value type. You can, of course, also enter 
variables. However, they must first be converted to the "barcode" type with the Barcode() function.
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