ComponentSpace.Dns Namespace

[image]

ComponentSpace DNS Class Library
ComponentSpace.Dns Namespace
Send Feedback
The ComponentSpace.Dns namespace contains the DNS classes.

Classes

Class | Description
ARecord | A host name resource record.
CNAMERecord | A canonical name for an alias resource record.
DnsClient | Sends DNS requests and receives DNS responses using the Domain Name System Protocol (RFC-1034/RFC-1035).
DnsException | The exception that is thrown when a DNS operation fails.
DnsLookupException | The exception that is thrown when a DNS lookup fails.
DnsMessage | A DNS protocol request/response message.
DnsName | A domain name. For example, componentspace.com.
DnsQuestion | A domain question. Questions consist of a domain name, question type and question class.
DnsString | A domain string. DNS strings are counted ASCII strings.
HINFORecord | A host information resource record.
LookupCompletedEventArgs | Provides data for the LookupCompleted event.
MBRecord | A mailbox domain name resource record.
MDRecord | A mail destination resource record.
MFRecord | A mail forwarder resource record.
MGRecord | A mail group member resource record.
MINFORecord | A mailbox or mail list resource record.
MRRecord | A mail rename domain name resource record.
MXRecord | A mail exchange resource record.
NSRecord | An authoritative name server resource record.
NULLRecord | Null resource record.
OtherRecord | A generic resource record.
PTRRecord | A domain name pointer resource record.
QueryCompletedEventArgs | Provides data for the QueryCompleted event.
ReceiveCompletedEventArgs | Provides data for the ReceiveCompleted event.
ResourceRecord | The base class for all resource records.
SendCompletedEventArgs | Provides data for the SendCompleted event.
SOARecord | A start of zone of authority resource record.
TXTRecord | A text strings resource record.
WKSRecord | A well known service description resource record.

Delegates

Delegate | Description
LookupCompletedEventHandler | Represents the method that will handle the LookupCompleted event.
QueryCompletedEventHandler | Represents the method that will handle the QueryCompleted event.
ReceiveCompletedEventHandler | Represents the method that will handle the ReceiveCompleted event.
SendCompletedEventHandler | Represents the method that will handle the SendCompleted event.

Enumerations

Enumeration | Description
DnsMessage..::.OpCodes | The opcodes identifying the request type.
DnsMessage..::.ResponseCodes | The response codes.
DnsQuestion..::.QClasses | The question classes (QCLASS).
DnsQuestion..::.QTypes | The question types (QTYPE).
ResourceRecord..::.RRClasses | The resource record classes (CLASS).
ResourceRecord..::.RRTypes | The resource record types (TYPE).

Send comments on this topic to support@componentspace.com

Copyright (c) ComponentSpace Pty Ltd 2002-2008. All rights reserved.


ARecord Class

[image]

ComponentSpace DNS Class Library
ARecord Class
Members See Also Send Feedback
A host name resource record.

Namespace: ComponentSpace.Dns
Assembly: ComponentSpace.Dns (in ComponentSpace.Dns.dll) Version: 1.8.0.2

Syntax

C#
public class ARecord : ResourceRecord
Visual Basic (Declaration)
Public Class ARecord _
    Inherits ResourceRecord
Visual C++
public ref class ARecord : public ResourceRecord

Inheritance Hierarchy

System..::.Object
ComponentSpace.Dns..::.ResourceRecord
ComponentSpace.Dns..::.ARecord

See Also

ARecord Members
ComponentSpace.Dns Namespace


ARecord Members

[image] [image]

ComponentSpace DNS Class Library
ARecord Members
ARecord Class Constructors Methods Properties See Also Send Feedback

The ARecord type exposes the following members.

Constructors

Name | Description
ARecord | Overloaded.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToByteArray | Convert the resource record into a byte array. (Overrides ResourceRecord..::.ToByteArray()()().)
ToString | Convert the resource record to a string. (Overrides ResourceRecord..::.ToString()()().)

Properties

Name | Description
Address | Get or sets the address (ADDRESS).
DataLength | Get or sets the number of data bytes (RDLENGTH). (Inherited from ResourceRecord.)
DnsName | Get or sets the domain name (NAME). (Inherited from ResourceRecord.)
ResourceClass | Get or sets the resource class (CLASS). (Inherited from ResourceRecord.)
ResourceType | Get or sets the resource type (TYPE). (Inherited from ResourceRecord.)
TimeInterval | Get or sets the cache time interval (TTL). (Inherited from ResourceRecord.)

See Also

ARecord Class


ARecord Constructor

[image] [image]

ComponentSpace DNS Class Library
ARecord Constructor
ARecord Class See Also Send Feedback

Overload List

Name | Description
ARecord()()() | Default constructor.
ARecord(array<Byte>[]()[], Int32%, Int32%) | Construct from a byte array.

See Also

ARecord Class
ARecord Members


ARecord Constructor

[image]

ComponentSpace DNS Class Library
ARecord Constructor
ARecord Class See Also Send Feedback
Default constructor.

Namespace: ComponentSpace.Dns
Assembly: ComponentSpace.Dns (in ComponentSpace.Dns.dll) Version: 1.8.0.2

Syntax

C#
public ARecord()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
ARecord()

See Also

ARecord Class
ARecord Overload


ARecord Constructor (Byte[], Int32, Int32)

[image]

ComponentSpace DNS Class Library
ARecord Constructor (array<Byte>[]()[], Int32%, Int32%)
ARecord Class See Also Send Feedback
Construct from a byte array.

Namespace: ComponentSpace.Dns
Assembly: ComponentSpace.Dns (in ComponentSpace.Dns.dll) Version: 1.8.0.2

Syntax

C#
public ARecord(
    byte[] bytes,
    ref int index,
    ref int count
)
Visual Basic (Declaration)
Public Sub New ( _
    bytes As Byte(), _
    ByRef index As Integer, _
    ByRef count As Integer _
)
Visual C++
public:
ARecord(
    array<unsigned char>^ bytes,
    int% index,
    int% count
)

Parameters

bytes
Type: array< System..::.Byte >[]()[]
The byte array containing the resource record.
index
Type: System..::.Int32 %
The index into the byte array.
count
Type: System..::.Int32 %
The number of bytes available in the byte array.

See Also

ARecord Class
ARecord Overload


ARecord Methods

[image] [image]

ComponentSpace DNS Class Library
ARecord Methods
ARecord Class See Also Send Feedback

The ARecord type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToByteArray | Convert the resource record into a byte array. (Overrides ResourceRecord..::.ToByteArray()()().)
ToString | Convert the resource record to a string. (Overrides ResourceRecord..::.ToString()()().)

See Also

ARecord Class


ToByteArray Method

[image]

ComponentSpace DNS Class Library
ARecord..::.ToByteArray Method
ARecord Class See Also Send Feedback
Convert the resource record into a byte array.

Namespace: ComponentSpace.Dns
Assembly: ComponentSpace.Dns (in ComponentSpace.Dns.dll) Version: 1.8.0.2

Syntax

C#
public override byte[] ToByteArray()
Visual Basic (Declaration)
Public Overrides Function ToByteArray As Byte()
Visual C++
public:
virtual array<unsigned char>^ ToByteArray() override

Return Value

The byte array containing the resource record.

See Also

ARecord Class


ToString Method

[image]

ComponentSpace DNS Class Library
ARecord..::.ToString Method
ARecord Class See Also Send Feedback
Convert the resource record to a string.

Namespace: ComponentSpace.Dns
Assembly: ComponentSpace.Dns (in ComponentSpace.Dns.dll) Version: 1.8.0.2

Syntax

C#
public override string ToString()
Visual Basic (Declaration)
Public Overrides Function ToString As String
Visual C++
public:
virtual String^ ToString() override

Return Value

The resource record as a string.

See Also

ARecord Class


ARecord Properties

[image] [image]

ComponentSpace DNS Class Library
ARecord Properties
ARecord Class See Also Send Feedback

The ARecord type exposes the following members.

Properties

Name | Description
Address | Get or sets the address (ADDRESS).
DataLength | Get or sets the number of data bytes (RDLENGTH). (Inherited from ResourceRecord.)
DnsName | Get or sets the domain name (NAME). (Inherited from ResourceRecord.)
ResourceClass | Get or sets the resource class (CLASS). (Inherited from ResourceRecord.)
ResourceType | Get or sets the resource type (TYPE). (Inherited from ResourceRecord.)
TimeInterval | Get or sets the cache time interval (TTL). (Inherited from ResourceRecord.)

See Also

ARecord Class


Address Property

[image]

ComponentSpace DNS Class Library
ARecord..::.Address Property
ARecord Class See Also Send Feedback
Get or sets the address (ADDRESS).

Namespace: ComponentSpace.Dns
Assembly: ComponentSpace.Dns (in ComponentSpace.Dns.dll) Version: 1.8.0.2

Syntax

C#
public long Address { get; set; }
Visual Basic (Declaration)
Public Property Address As Long
Visual C++
public:
property long long Address {
    long long get ();
    void set (long long value);
}

Field Value

The address.

See Also

ARecord Class


CNAMERecord Class

[image]

ComponentSpace DNS Class Library
CNAMERecord Class
Members See Also Send Feedback
A canonical name for an alias resource record.

Namespace: ComponentSpace.Dns
Assembly: ComponentSpace.Dns (in ComponentSpace.Dns.dll) Version: 1.8.0.2

Syntax

C#
public class CNAMERecord : ResourceRecord
Visual Basic (Declaration)
Public Class CNAMERecord _
    Inherits ResourceRecord
Visual C++
public ref class CNAMERecord : public ResourceRecord

Inheritance Hierarchy

System..::.Object
ComponentSpace.Dns..::.ResourceRecord
ComponentSpace.Dns..::.CNAMERecord

See Also

CNAMERecord Members


CNAMERecord Members

[image] [image]

ComponentSpace DNS Class Library
CNAMERecord Members
CNAMERecord Class Constructors Methods Properties See Also Send Feedback

The CNAMERecord type exposes the following members.

Constructors

Name | Description
CNAMERecord | Overloaded.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToByteArray | Convert the resource record into a byte array. (Overrides ResourceRecord..::.ToByteArray()()().)
ToString | Convert the resource record to a string. (Overrides ResourceRecord..::.ToString()()().)

Properties

Name | Description
CanonicalName | Get or sets the canonical name (CNAME).
DataLength | Get or sets the number of data bytes (RDLENGTH). (Inherited from ResourceRecord.)
DnsName | Get or sets the domain name (NAME). (Inherited from ResourceRecord.)
ResourceClass | Get or sets the resource class (CLASS). (Inherited from ResourceRecord.)
ResourceType | Get or sets the resource type (TYPE). (Inherited from ResourceRecord.)
TimeInterval | Get or sets the cache time interval (TTL). (Inherited from ResourceRecord.)

See Also

CNAMERecord Class


CNAMERecord Constructor

[image] [image]

ComponentSpace DNS Class Library
CNAMERecord Constructor
CNAMERecord Class See Also Send Feedback

Overload List

Name | Description
CNAMERecord()()() | Default constructor.
CNAMERecord(array<Byte>[]()[], Int32%, Int32%) | Construct from a byte array.

See Also

CNAMERecord Class
CNAMERecord Members


CNAMERecord Constructor

[image]

ComponentSpace DNS Class Library
CNAMERecord Constructor
CNAMERecord Class See Also Send Feedback
Default constructor.

Namespace: ComponentSpace.Dns
Assembly: ComponentSpace.Dns (in ComponentSpace.Dns.dll) Version: 1.8.0.2

Syntax

C#
public CNAMERecord()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
CNAMERecord()

See Also

CNAMERecord Class
CNAMERecord Overload


CNAMERecord Constructor (Byte[], Int32, Int32)

[image]

ComponentSpace DNS Class Library
CNAMERecord Constructor (array<Byte>[]()[], Int32%, Int32%)
CNAMERecord Class See Also Send Feedback
Construct from a byte array.

Namespace: ComponentSpace.Dns
Assembly: ComponentSpace.Dns (in ComponentSpace.Dns.dll) Version: 1.8.0.2

Syntax

C#
public CNAMERecord(
    byte[] bytes,
    ref int index,
    ref int count
)
Visual Basic (Declaration)
Public Sub New ( _
    bytes As Byte(), _
    ByRef index As Integer, _
    ByRef count As Integer _
)
Visual C++
public:
CNAMERecord(
    array<unsigned char>^ bytes,
    int% index,
    int% count
)

Parameters

bytes
Type: array< System..::.Byte >[]()[]
The byte array containing the resource record.
index
Type: System..::.Int32 %
The index into the byte array.
count
Type: System..::.Int32 %
The number of bytes available in the byte array.

See Also

CNAMERecord Class
CNAMERecord Overload


CNAMERecord Methods

[image] [image]

ComponentSpace DNS Class Library
CNAMERecord Methods
CNAMERecord Class See Also Send Feedback

The CNAMERecord type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToByteArray | Convert the resource record into a byte array. (Overrides ResourceRecord..::.ToByteArray()()().)
ToString | Convert the resource record to a string. (Overrides ResourceRecord..::.ToString()()().)

See Also

CNAMERecord Class


ToByteArray Method

[image]

ComponentSpace DNS Class Library
CNAMERecord..::.ToByteArray Method
CNAMERecord Class See Also Send Feedback
Convert the resource record into a byte array.

Namespace: ComponentSpace.Dns
Assembly: ComponentSpace.Dns (in ComponentSpace.Dns.dll) Version: 1.8.0.2

Syntax

C#
public override byte[] ToByteArray()
Visual Basic (Declaration)
Public Overrides Function ToByteArray As Byte()
Visual C++
public:
virtual array<unsigned char>^ ToByteArray() override

Return Value

The byte array containing the resource record.

See Also

CNAMERecord Class


ToString Method

[image]

ComponentSpace DNS Class Library
CNAMERecord..::.ToString Method
CNAMERecord Class See Also Send Feedback
Convert the resource record to a string.

Namespace: ComponentSpace.Dns
Assembly: ComponentSpace.Dns (in ComponentSpace.Dns.dll) Version: 1.8.0.2

Syntax

C#
public override string ToString()
Visual Basic (Declaration)
Public Overrides Function ToString As String
Visual C++
public:
virtual String^ ToString() override

Return Value

The resource record as a string.

See Also

CNAMERecord Class


CNAMERecord Properties

[image] [image]

ComponentSpace DNS Class Library
CNAMERecord Properties
CNAMERecord Class See Also Send Feedback

The CNAMERecord type exposes the following members.

Properties

Name | Description
CanonicalName | Get or sets the canonical name (CNAME).
DataLength | Get or sets the number of data bytes (RDLENGTH). (Inherited from ResourceRecord.)
DnsName | Get or sets the domain name (NAME). (Inherited from ResourceRecord.)
ResourceClass | Get or sets the resource class (CLASS). (Inherited from ResourceRecord.)
ResourceType | Get or sets the resource type (TYPE). (Inherited from ResourceRecord.)
TimeInterval | Get or sets the cache time interval (TTL). (Inherited from ResourceRecord.)

See Also

CNAMERecord Class


CanonicalName Property

[image]

ComponentSpace DNS Class Library
CNAMERecord..::.CanonicalName Property
CNAMERecord Class See Also Send Feedback
Get or sets the canonical name (CNAME).

Namespace: ComponentSpace.Dns
Assembly: ComponentSpace.Dns (in ComponentSpace.Dns.dll) Version: 1.8.0.2

Syntax

C#
public DnsName CanonicalName { get; set; }
Visual Basic (Declaration)
Public Property CanonicalName As DnsName
Visual C++
public:
property DnsName^ CanonicalName {
    DnsName^ get ();
    void set (DnsName^ value);
}

Field Value

The canonical name.

See Also

CNAMERecord Class


DnsClient Class

[image]

ComponentSpace DNS Class Library
DnsClient Class
Members See Also Send Feedback
Sends DNS requests and receives DNS responses using the Domain Name System Protocol (RFC-1034/RFC-1035).

Namespace: ComponentSpace.Dns
Assembly: ComponentSpace.Dns (in ComponentSpace.Dns.dll) Version: 1.8.0.2

Syntax

C#
public class DnsClient : IDisposable
Visual Basic (Declaration)
Public Class DnsClient _
    Implements IDisposable
Visual C++
public ref class DnsClient : IDisposable

Remarks

The DnsClient constructor specifies the address of the DNS server. If no DNS server address is supplied then the first address returned by DnsServerList is used. Optionally, the ReceiveTimeout may be set.

DNS forward lookups, to resolve a host name to one or more IP addresses, may be performed synchronously (blocking) using Lookup(String), or asynchronously (non-blocking) using BeginLookup(String) and EndLookup(IAsyncResult) .

DNS reverse lookups, to resolve an IP address to one or more host names, may be performed synchronously using ReverseLookup(IPAddress), or asynchronously using BeginReverseLookup(IPAddress) and EndReverseLookup(IAsyncResult) .

DNS queries may be performed synchronously using Query(DnsMessage), or asynchronously using BeginQuery(DnsMessage) and EndQuery(IAsyncResult) .

You may construct and send your own DNS requests and the receive replies synchronously using Send(DnsMessage) and Receive()()(), or asynchronously (non-blocking) using BeginSend(DnsMessage), EndSend(IAsyncResult) and BeginReceive()()(), EndReceive(IAsyncResult).

If you're behind a firewall you must ensure outgoing UDP traffic to port 53 (the default DNS port) is permitted.

Inheritance Hierarchy

System..::.Object
ComponentSpace.Dns..::.DnsClient

See Also

DnsClient Members


DnsClient Members

[image] [image]

ComponentSpace DNS Class Library
DnsClient Members
DnsClient Class Constructors Methods Properties Events See Also Send Feedback

The DnsClient type exposes the following members.

Constructors

Name | Description
DnsClient | Overloaded.

Methods

Name | Description
BeginLookup | Overloaded.
BeginQuery | Overloaded.
BeginReceive | Overloaded.
BeginReverseLookup | Overloaded.
BeginSend | Overloaded.
Close | Close the DnsClient and the underlying socket object.
CreateReverseLookupName | Creates a reverse lookup name for use in a DNS reverse lookup. For example, given an address of 66.210.153.10 it returns 10.153.210.66.IN-ADDR.ARPA. For more information about reverse lookups, refer to RFC 1035.
Dispose | Dispose of the DnsClient and the underlying socket object.
EndLookup | Completes the specified asynchronous lookup operation.
EndQuery | Completes the specified asynchronous query operation.
EndReceive | Completes the specified asynchronous receive operation.
EndReverseLookup | Completes the specified asynchronous reverse lookup operation.
EndSend | Completes the specified asynchronous send operation.
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
Lookup | Performs a forward DNS lookup to resolve the host name to one or more IP addresses. For example, www.componentspace.com is resolved to 66.210.153.10.
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Query | Performs a DNS query by sending a DNS message to the DNS server and receiving a DNS response message.
Receive | Returns a DNS response message from the server.
ReverseLookup | Performs a reverse DNS lookup to resolve an IP address to one or more host names. For example, 66.210.153.10 is resolved to www.componentspace.com. For more information about reverse lookups, refer to RFC 1035.
Send | Send a DNS request message to the server.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
DnsServerList | Gets the list of configured DNS servers.
ReceiveTimeout | Gets or sets the number of milliseconds to wait for the response from the server.
SynchronizingObject | Gets or sets the synchonizing object for receiving events.

Events

Name | Description
LookupCompleted | Occurs when the lookup operation has completed.
QueryCompleted | Occurs when the query operation has completed.
ReceiveCompleted | Occurs when the receive operation has completed.
SendCompleted | Occurs when the send operation has completed.

See Also

DnsClient Class


DnsClient Constructor

[image] [image]

ComponentSpace DNS Class Library
DnsClient Constructor
DnsClient Class See Also Send Feedback

Overload List

Name | Description
DnsClient()()() | Initializes a new instance of the DnsClient class. The first configured DNS server is used.
DnsClient(IPAddress) | Initializes a new instance of the DnsClient class with the specified DNS server IP address.
DnsClient(IPEndPoint) | Initializes a new instance of the DnsClient class with the specified DNS server IP address.
DnsClient(String) | Initializes a new instance of the DnsClient class with the specified DNS server address. The address can either be the name of the server (eg. www.componentspace.com) or its IP address (eg. 66.210.153.10).

See Also

DnsClient Class
DnsClient Members


DnsClient Constructor

[image]

ComponentSpace DNS Class Library
DnsClient Constructor
DnsClient Class See Also Send Feedback
Initializes a new instance of the DnsClient class. The first configured DNS server is used.

Namespace: ComponentSpace.Dns
Assembly: ComponentSpace.Dns (in ComponentSpace.Dns.dll) Version: 1.8.0.2

Syntax

C#
public DnsClient()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
DnsClient()

Exceptions

Exception | Condition
ComponentSpace.Dns..::.DnsException | Thrown when a configured DNS server cannot be found.

See Also

DnsClient Class
DnsClient Overload


DnsClient Constructor (IPAddress)

[image]

ComponentSpace DNS Class Library
DnsClient Constructor (IPAddress)
DnsClient Class See Also Send Feedback
Initializes a new instance of the DnsClient class with the specified DNS server IP address.

Namespace: ComponentSpace.Dns
Assembly: ComponentSpace.Dns (in ComponentSpace.Dns.dll) Version: 1.8.0.2

Syntax

C#
public DnsClient(
    IPAddress serverAddress
)
Visual Basic (Declaration)
Public Sub New ( _
    serverAddress As IPAddress _
)
Visual C++
public:
DnsClient(
    IPAddress^ serverAddress
)

Parameters

serverAddress
Type: System.Net..::.IPAddress
The DNS server IP address.

See Also

DnsClient Class
DnsClient Overload


DnsClient Constructor (IPEndPoint)

[image]

ComponentSpace DNS Class Library
DnsClient Constructor (IPEndPoint)
DnsClient Class See Also Send Feedback
Initializes a new instance of the DnsClient class with the specified DNS server IP address.

Namespace: ComponentSpace.Dns
Assembly: ComponentSpace.Dns (in ComponentSpace.Dns.dll) Version: 1.8.0.2

Syntax

C#
public DnsClient(
    IPEndPoint serverAddress
)
Visual Basic (Declaration)
Public Sub New ( _
    serverAddress As IPEndPoint _
)
Visual C++
public:
DnsClient(
    IPEndPoint^ serverAddress
)

Parameters

serverAddress
Type: System.Net..::.IPEndPoint
The DNS server IP address.

See Also

DnsClient Class
DnsClient Overload


DnsClient Constructor (String)

[image]

ComponentSpace DNS Class Library
DnsClient Constructor (String)
DnsClient Class See Also Send Feedback
Initializes a new instance of the DnsClient class with the specified DNS server address. The address can either be the name of the server (eg. www.componentspace.com) or its IP address (eg. 66.210.153.10).

Namespace: ComponentSpace.Dns
Assembly: ComponentSpace.Dns (in ComponentSpace.Dns.dll) Version: 1.8.0.2

Syntax

C#
public DnsClient(
    string serverAddress
)
Visual Basic (Declaration)
Public Sub New ( _
    serverAddress As String _
)
Visual C++
public:
DnsClient(
    String^ serverAddress
)

Parameters

serverAddress
Type: System..::.String
The DNS server address (eg. 66.210.153.10 or www.componentspace.com).

See Also

DnsClient Class
DnsClient Overload


DnsClient Methods

[image] [image]

ComponentSpace DNS Class Library
DnsClient Methods
DnsClient Class See Also Send Feedback

The DnsClient type exposes the following members.

Methods

Name | Description
BeginLookup | Overloaded.
BeginQuery | Overloaded.
BeginReceive | Overloaded.
BeginReverseLookup | Overloaded.
BeginSend | Overloaded.
Close | Close the DnsClient and the underlying socket object.
CreateReverseLookupName | Creates a reverse lookup name for use in a DNS reverse lookup. For example, given an address of 66.210.153.10 it returns 10.153.210.66.IN-ADDR.ARPA. For more information about reverse lookups, refer to RFC 1035.
Dispose | Dispose of the DnsClient and the underlying socket object.
EndLookup | Completes the specified asynchronous lookup operation.
EndQuery | Completes the specified asynchronous query operation.
EndReceive | Completes the specified asynchronous receive operation.
EndReverseLookup | Completes the specified asynchronous reverse lookup operation.
EndSend | Completes the specified asynchronous send operation.
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
Lookup | Performs a forward DNS lookup to resolve the host name to one or more IP addresses. For example, www.componentspace.com is resolved to 66.210.153.10.
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Query | Performs a DNS query by sending a DNS message to the DNS server and receiving a DNS response message.
Receive | Returns a DNS response message from the server.
ReverseLookup | Performs a reverse DNS lookup to resolve an IP address to one or more host names. For example, 66.210.153.10 is resolved to www.componentspace.com. For more information about reverse lookups, refer to RFC 1035.
Send | Send a DNS request message to the server.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

DnsClient Class


BeginLookup Method

[image] [image]

ComponentSpace DNS Class Library
DnsClient..::.BeginLookup Method
DnsClient Class See Also Send Feedback

Overload List

Name | Description
BeginLookup(String) | Initiates an asynchronous lookup operation.
BeginLookup(String, Object) | Initiates an asynchronous lookup operation that has a specified state object.
BeginLookup(String, Object, AsyncCallback) | Initiates an asynchronous lookup operation that has a specified state object. This overload receives notification, through a callback, of the identity of the event handler for this operation.

See Also

DnsClient Class
DnsClient Members


BeginLookup Method (String)

[image]

ComponentSpace DNS Class Library
DnsClient..::.BeginLookup Method (String)
DnsClient Class See Also Send Feedback
Initiates an asynchronous lookup operation.

Namespace: ComponentSpace.Dns
Assembly: ComponentSpace.Dns (in ComponentSpace.Dns.dll) Version: 1.8.0.2

Syntax

C#
public IAsyncResult BeginLookup(
    string hostName
)
Visual Basic (Declaration)
Public Function BeginLookup ( _
    hostName As String _
) As IAsyncResult
Visual C++
public:
IAsyncResult^ BeginLookup(
    String^ hostName
)

Parameters

hostName
Type: System..::.String
The host name to resolve.

Return Value

The IAsyncResult that identifies the posted asynchronous request.

Remarks

In asynchronous processing, you use BeginLookup to raise the LookupCompleted event when the lookup operation has completed.

To use BeginLookup, create an event handler that processes the results of the asynchronous operation and associate it with your event delegate. BeginLookup initiates an asynchronous lookup operation; the DnsClient is notified, through the raising of the LookupCompleted event, when the lookup operation is completed. The DnsClient can then access the lookup status by calling EndLookup(IAsyncResult).

Note: The BeginLookup method returns immediately, but the asynchronous operation is not completed until the event handler is called.

Because BeginLookup is asynchronous, you can call it to receive the lookup status without blocking the current thread of execution. To synchronously lookup, use the Lookup(String) method.

Once an asynchronous operation completes, you can call BeginLookup again in the event handler to keep receiving notifications.

The IAsyncResult that BeginLookup returns identifies the asynchronous operation that the method call started. You can use this IAsyncResult throughout the lifetime of the operation, although you generally do not use it until EndLookup is called. However, if you start several asynchronous operations, you can place their IAsyncResult values in an array and specify whether to wait for all operations or any operation to complete. In this case, you use the AsyncWaitHandle property of the IAsyncResult to identify the completed operation.

See Also

DnsClient Class
BeginLookup Overload


BeginLookup Method (String, Object)

[image]

ComponentSpace DNS Class Library
DnsClient..::.BeginLookup Method (String, Object)
DnsClient Class See Also Send Feedback
Initiates an asynchronous lookup operation that has a specified state object.

Namespace: ComponentSpace.Dns
Assembly: ComponentSpace.Dns (in ComponentSpace.Dns.dll) Version: 1.8.0.2

Syntax

C#
public IAsyncResult BeginLookup(
    string hostName,
    Object stateObject
)
Visual Basic (Declaration)
Public Function BeginLookup ( _
    hostName As String, _
    stateObject As Object _
) As IAsyncResult
Visual C++
public:
IAsyncResult^ BeginLookup(
    String^ hostName,
    Object^ stateObject
)

Parameters

hostName
Type: System..::.String
The host name to resolve.
stateObject
Type: System..::.Object
A state object, specified by the application, that contains information associated with the asynchronous operation.

Return Value

The IAsyncResult that identifies the posted asynchronous request.

Remarks

In asynchronous processing, you use BeginLookup to raise the LookupCompleted event when the lookup operation has completed.

Use this overload to associate information with the operation that will be preserved throughout the operation's lifetime. The event handler can detect this information by looking at the AsyncState of the IAsyncResult that is associated with the operation.

To use BeginLookup, create an event handler that processes the results of the asynchronous operation and associate it with your event delegate. BeginLookup initiates an asynchronous lookup operation; the DnsClient is notified, through the raising of the LookupCompleted event, when the lookup operation is completed. The DnsClient can then access the lookup status by calling EndLookup(IAsyncResult).

Note: The BeginLookup method returns immediately, but the asynchronous operation is not completed until the event handler is called.

Because BeginLookup is asynchronous, you can call it to receive the lookup status without blocking the current thread of execution. To synchronously lookup, use the Lookup(String) method.

Once an asynchronous operation completes, you can call BeginLookup again in the event handler to keep receiving notifications.

The IAsyncResult that BeginLookup returns identifies the asynchronous operation that the method call started. You can use this IAsyncResult throughout the lifetime of the operation, although you generally do not use it until EndLookup is called. However, if you start several asynchronous operations, you can place their IAsyncResult values in an array and specify whether to wait for all operations or any operation to complete. In this case, you use the AsyncWaitHandle property of the IAsyncResult to identify the completed operation.

The state object associates state information with the operation. For example, if you call BeginLookup multiple times to initiate multiple operations, you can identify each operation through a separate state object that you define.

You can also use the state object to pass information across process threads. If a thread is started but the callback is on a different thread in an asynchronous scenario, the state object is marshaled and passed back along with information from the event.

See Also

DnsClient Class
BeginLookup Overload


BeginLookup Method (String, Object, AsyncCallback)

[image]

ComponentSpace DNS Class Library
DnsClient..::.BeginLookup Method (String, Object, AsyncCallback)
DnsClient Class See Also Send Feedback
Initiates an asynchronous lookup operation that has a specified state object. This overload receives notification, through a callback, of the identity of the event handler for this operation.

Namespace: ComponentSpace.Dns
Assembly: ComponentSpace.Dns (in ComponentSpace.Dns.dll) Version: 1.8.0.2

Syntax

C#
public IAsyncResult BeginLookup(
    string hostName,
    Object stateObject,
    AsyncCallback asyncCallback
)
Visual Basic (Declaration)
Public Function BeginLookup ( _
    hostName As String, _
    stateObject As Object, _
    asyncCallback As AsyncCallback _
) As IAsyncResult
Visual C++
public:
IAsyncResult^ BeginLookup(
    String^ hostName,
    Object^ stateObject,
    AsyncCallback^ asyncCallback
)

Parameters

hostName
Type: System..::.String
The host name to resolve.
stateObject
Type: System..::.Object
A state object, specified by the application, that contains information associated with the asynchronous operation.
asyncCallback
Type: System..::.AsyncCallback
The AsyncCallback that will receive the notification of the asynchronous operation completion.

Return Value

The IAsyncResult that identifies the posted asynchronous request.

Remarks

When you use this overload, the callback specified in the callback parameter is invoked directly when the lookup operation has completed; the LookupCompleted event is not raised. The other overloads of BeginLookup rely on this component to raise the LookupCompleted event.

To use BeginLookup, define an asynchronous callback method. BeginLookup initiates an asynchronous lookup operation; the DnsClient is notified, through a call to the callback method, when the lookup operation is completed. The DnsClient can then access the lookup status by calling EndLookup(IAsyncResult).

Use this overload to associate information with the operation that will be preserved throughout the operation's lifetime. The event handler can detect this information by looking at the AsyncState of the IAsyncResult that is associated with the operation.

Note: The BeginLookup method returns immediately, but the asynchronous operation is not completed until the event handler is called.

Because BeginLookup is asynchronous, you can call it to receive the lookup status without blocking the current thread of execution. To synchronously lookup, use the Lookup(String) method.

Once an asynchronous operation completes, you can call BeginLookup again in the event handler to keep receiving notifications.

The IAsyncResult that BeginLookup returns identifies the asynchronous operation that the method call started. You can use this IAsyncResult throughout the lifetime of the operation, although you generally do not use it until EndLookup is called. However, if you start several asynchronous operations, you can place their IAsyncResult values in an array and specify whether to wait for all operations or any operation to complete. In this case, you use the AsyncWaitHandle property of the IAsyncResult to identify the completed operation.

The state object associates state information with the operation. For example, if you call BeginLookup multiple times to initiate multiple operations, you can identify each operation through a separate state object that you define.

You can also use the state object to pass information across process threads. If a thread is started but the callback is on a different thread in an asynchronous scenario, the state object is marshaled and passed back along with information from the event.

See Also

DnsClient Class
BeginLookup Overload


BeginQuery Method

[image] [image]

ComponentSpace DNS Class Library
DnsClient..::.BeginQuery Method
DnsClient Class See Also Send Feedback

Overload List

Name | Description
BeginQuery(DnsMessage) | Initiates an asynchronous query operation.
BeginQuery(DnsMessage, Object) | Initiates an asynchronous query operation that has a specified state object.
BeginQuery(DnsMessage, Object, AsyncCallback) | Initiates an asynchronous query operation that has a specified state object. This overload receives notification, through a callback, of the identity of the event handler for this operation.

See Also

DnsClient Class
DnsClient Members


BeginQuery Method (DnsMessage)

[image]

ComponentSpace DNS Class Library
DnsClient..::.BeginQuery Method (DnsMessage)
DnsClient Class See Also Send Feedback
Initiates an asynchronous query operation.

Namespace: ComponentSpace.Dns
Assembly: ComponentSpace.Dns (in ComponentSpace.Dns.dll) Version: 1.8.0.2

Syntax

C#
public IAsyncResult BeginQuery(
    DnsMessage dnsMessage
)
Visual Basic (Declaration)
Public Function BeginQuery ( _
    dnsMessage As DnsMessage _
) As IAsyncResult
Visual C++
public:
IAsyncResult^ BeginQuery(
    DnsMessage^ dnsMessage
)

Parameters

dnsMessage
Type: ComponentSpace.Dns..::.DnsMessage
The DNS message to send.

Return Value

The IAsyncResult that identifies the posted asynchronous request.

Remarks

In asynchronous processing, you use BeginQuery to raise the QueryCompleted event when the query operation has completed.

To use BeginQuery, create an event handler that processes the results of the asynchronous operation and associate it with your event delegate. BeginQuery initiates an asynchronous query operation; the DnsClient is notified, through the raising of the QueryCompleted event, when the query operation is completed. The DnsClient can then access the query status by calling EndQuery(IAsyncResult).

Note: The BeginQuery method returns immediately, but the asynchronous operation is not completed until the event handler is called.

Because BeginQuery is asynchronous, you can call it to receive the query status without blocking the current thread of execution. To synchronously query, use the Query(DnsMessage) method.

Once an asynchronous operation completes, you can call BeginQuery again in the event handler to keep receiving notifications.

The IAsyncResult that BeginQuery returns identifies the asynchronous operation that the method call started. You can use this IAsyncResult throughout the lifetime of the operation, although you generally do not use it until EndQuery is called. However, if you start several asynchronous operations, you can place their IAsyncResult values in an array and specify whether to wait for all operations or any operation to complete. In this case, you use the AsyncWaitHandle property of the IAsyncResult to identify the completed operation.

See Also

DnsClient Class
BeginQuery Overload


BeginQuery Method (DnsMessage, Object)

[image]

ComponentSpace DNS Class Library
DnsClient..::.BeginQuery Method (DnsMessage, Object)
DnsClient Class See Also Send Feedback
Initiates an asynchronous query operation that has a specified state object.

Namespace: ComponentSpace.Dns
Assembly: ComponentSpace.Dns (in ComponentSpace.Dns.dll) Version: 1.8.0.2

Syntax

C#
public IAsyncResult BeginQuery(
    DnsMessage dnsMessage,
    Object stateObject
)
Visual Basic (Declaration)
Public Function BeginQuery ( _
    dnsMessage As DnsMessage, _
    stateObject As Object _
) As IAsyncResult
Visual C++
public:
IAsyncResult^ BeginQuery(
    DnsMessage^ dnsMessage,
    Object^ stateObject
)

Parameters

dnsMessage
Type: ComponentSpace.Dns..::.DnsMessage
The DNS message to send.
stateObject
Type: System..::.Object
A state object, specified by the application, that contains information associated with the asynchronous operation.

Return Value

The IAsyncResult that identifies the posted asynchronous request.

Remarks

In asynchronous processing, you use BeginQuery to raise the QueryCompleted event when the query operation has completed.

Use this overload to associate information with the operation that will be preserved throughout the operation's lifetime. The event handler can detect this information by looking at the AsyncState of the IAsyncResult that is associated with the operation.

To use BeginQuery, create an event handler that processes the results of the asynchronous operation and associate it with your event delegate. BeginQuery initiates an asynchronous query operation; the DnsClient is notified, through the raising of the QueryCompleted event, when the query operation is completed. The DnsClient can then access the query status by calling EndQuery(IAsyncResult).

Note: The BeginQuery method returns immediately, but the asynchronous operation is not completed until the event handler is called.

Because BeginQuery is asynchronous, you can call it to receive the query status without blocking the current thread of execution. To synchronously query, use the Query(DnsMessage) method.

Once an asynchronous operation completes, you can call BeginQuery again in the event handler to keep receiving notifications.

The IAsyncResult that BeginQuery returns identifies the asynchronous operation that the method call started. You can use this IAsyncResult throughout the lifetime of the operation, although you generally do not use it until EndQuery is called. However, if you start several asynchronous operations, you can place their IAsyncResult values in an array and specify whether to wait for all operations or any operation to complete. In this case, you use the AsyncWaitHandle property of the IAsyncResult to identify the completed operation.

The state object associates state information with the operation. For example, if you call BeginQuery multiple times to initiate multiple operations, you can identify each operation through a separate state object that you define.

You can also use the state object to pass information across process threads. If a thread is started but the callback is on a different thread in an asynchronous scenario, the state object is marshaled and passed back along with information from the event.

See Also

DnsClient Class
BeginQuery Overload


BeginQuery Method (DnsMessage, Object, AsyncCallback)

[image]

ComponentSpace DNS Class Library
DnsClient..::.BeginQuery Method (DnsMessage, Object, AsyncCallback)
DnsClient Class See Also Send Feedback
Initiates an asynchronous query operation that has a specified state object. This overload receives notification, through a callback, of the identity of the event handler for this operation.

Namespace: ComponentSpace.Dns
Assembly: ComponentSpace.Dns (in ComponentSpace.Dns.dll) Version: 1.8.0.2

Syntax

C#
public IAsyncResult BeginQuery(
    DnsMessage dnsMessage,
    Object stateObject,
    AsyncCallback asyncCallback
)
Visual Basic (Declaration)
Public Function BeginQuery ( _
    dnsMessage As DnsMessage, _
    stateObject As Object, _
    asyncCallback As AsyncCallback _
) As IAsyncResult
Visual C++
public:
IAsyncResult^ BeginQuery(
    DnsMessage^ dnsMessage,
    Object^ stateObject,
    AsyncCallback^ asyncCallback
)

Parameters

dnsMessage
Type: ComponentSpace.Dns..::.DnsMessage
The DNS message to send.
stateObject
Type: System..::.Object
A state object, specified by the application, that contains information associated with the asynchronous operation.
asyncCallback
Type: System..::.AsyncCallback
The AsyncCallback that will receive the notification of the asynchronous operation completion.

Return Value

The IAsyncResult that identifies the posted asynchronous request.

Remarks

When you use this overload, the callback specified in the callback parameter is invoked directly when the query operation has completed; the QueryCompleted event is not raised. The other overloads of BeginQuery rely on this component to raise the QueryCompleted event.

To use BeginQuery, define an asynchronous callback method. BeginQuery initiates an asynchronous query operation; the DnsClient is notified, through a call to the callback method, when the query operation is completed. The DnsClient can then access the query status by calling EndQuery(IAsyncResult).

Use this overload to associate information with the operation that will be preserved throughout the operation's lifetime. The event handler can detect this information by looking at the AsyncState of the IAsyncResult that is associated with the operation.

Note: The BeginQuery method returns immediately, but the asynchronous operation is not completed until the event handler is called.

Because BeginQuery is asynchronous, you can call it to receive the query status without blocking the current thread of execution. To synchronously query, use the Query(DnsMessage) method.

Once an asynchronous operation completes, you can call BeginQuery again in the event handler to keep receiving notifications.

The IAsyncResult that BeginQuery returns identifies the asynchronous operation that the method call started. You can use this IAsyncResult throughout the lifetime of the operation, although you generally do not use it until EndQuery is called. However, if you start several asynchronous operations, you can place their IAsyncResult values in an array and specify whether to wait for all operations or any operation to complete. In this case, you use the AsyncWaitHandle property of the IAsyncResult to identify the completed operation.

The state object associates state information with the operation. For example, if you call BeginQuery multiple times to initiate multiple operations, you can identify each operation through a separate state object that you define.

You can also use the state object to pass information across process threads. If a thread is started but the callback is on a different thread in an asynchronous scenario, the state object is marshaled and passed back along with information from the event.

See Also

DnsClient Class
BeginQuery Overload


BeginReceive Method

[image] [image]

ComponentSpace DNS Class Library
DnsClient..::.BeginReceive Method
DnsClient Class See Also Send Feedback

Overload List

Name | Description
BeginReceive()()() | Initiates an asynchronous receive operation.
BeginReceive(Object) | Initiates an asynchronous receive operation that has a specified state object.
BeginReceive(Object, AsyncCallback) | Initiates an asynchronous receive operation that has a specified state object. This overload receives notification, through a callback, of the identity of the event handler for this operation.

See Also

DnsClient Class
DnsClient Members


BeginReceive Method

[image]

ComponentSpace DNS Class Library
DnsClient..::.BeginReceive Method
DnsClient Class See Also Send Feedback
Initiates an asynchronous receive operation.

Namespace: ComponentSpace.Dns
Assembly: ComponentSpace.Dns (in ComponentSpace.Dns.dll) Version: 1.8.0.2

Syntax

C#
public IAsyncResult BeginReceive()
Visual Basic (Declaration)
Public Function BeginReceive As IAsyncResult
Visual C++
public:
IAsyncResult^ BeginReceive()

Return Value

The IAsyncResult that identifies the posted asynchronous request.

Remarks

In asynchronous processing, you use BeginReceive to raise the ReceiveCompleted event when the receive operation has completed.

To use BeginReceive, create an event handler that processes the results of the asynchronous operation and associate it with your event delegate. BeginReceive initiates an asynchronous receive operation; the DnsClient is notified, through the raising of the ReceiveCompleted event, when the receive operation is completed. The DnsClient can then access the receive status by calling EndReceive(IAsyncResult).

Note: The BeginReceive method returns immediately, but the asynchronous operation is not completed until the event handler is called.

Because BeginReceive is asynchronous, you can call it to receive the receive status without blocking the current thread of execution. To synchronously receive, use the Receive()()() method.

Once an asynchronous operation completes, you can call BeginReceive again in the event handler to keep receiving notifications.

The IAsyncResult that BeginReceive returns identifies the asynchronous operation that the method call started. You can use this IAsyncResult throughout the lifetime of the operation, although you generally do not use it until EndReceive is called. However, if you start several asynchronous operations, you can place their IAsyncResult values in an array and specify whether to wait for all operations or any operation to complete. In this case, you use the AsyncWaitHandle property of the IAsyncResult to identify the completed operation.

See Also

DnsClient Class
BeginReceive Overload


BeginReceive Method (Object)

[image]

ComponentSpace DNS Class Library
DnsClient..::.BeginReceive Method (Object)
DnsClient Class See Also Send Feedback
Initiates an asynchronous receive operation that has a specified state object.

Namespace: ComponentSpace.Dns
Assembly: ComponentSpace.Dns (in ComponentSpace.Dns.dll) Version: 1.8.0.2

Syntax

C#
public IAsyncResult BeginReceive(
    Object stateObject
)
Visual Basic (Declaration)
Public Function BeginReceive ( _
    stateObject As Object _
) As IAsyncResult
Visual C++
public:
IAsyncResult^ BeginReceive(
    Object^ stateObject
)

Parameters

stateObject
Type: System..::.Object
A state object, specified by the application, that contains information associated with the asynchronous operation.

Return Value

The IAsyncResult that identifies the posted asynchronous request.

Remarks

In asynchronous processing, you use BeginReceive to raise the ReceiveCompleted event when the receive operation has completed.

Use this overload to associate information with the operation that will be preserved throughout the operation's lifetime. The event handler can detect this information by looking at the AsyncState of the IAsyncResult that is associated with the operation.

To use BeginReceive, create an event handler that processes the results of the asynchronous operation and associate it with your event delegate. BeginReceive initiates an asynchronous receive operation; the DnsClient is notified, through the raising of the ReceiveCompleted event, when the receive operation is completed. The DnsClient can then access the receive status by calling EndReceive(IAsyncResult).

Note: The BeginReceive method returns immediately, but the asynchronous operation is not completed until the event handler is called.

Because BeginReceive is asynchronous, you can call it to receive the receive status without blocking the current thread of execution. To synchronously receive, use the Receive()()() method.

Once an asynchronous operation completes, you can call BeginReceive again in the event handler to keep receiving notifications.

The IAsyncResult that BeginReceive returns identifies the asynchronous operation that the method call started. You can use this IAsyncResult throughout the lifetime of the operation, although you generally do not use it until EndReceive is called. However, if you start several asynchronous operations, you can place their IAsyncResult values in an array and specify whether to wait for all operations or any operation to complete. In this case, you use the AsyncWaitHandle property of the IAsyncResult to identify the completed operation.

The state object associates state information with the operation. For example, if you call BeginReceive multiple times to initiate multiple operations, you can identify each operation through a separate state object that you define.

You can also use the state object to pass information across process threads. If a thread is started but the callback is on a different thread in an asynchronous scenario, the state object is marshaled and passed back along with information from the event.

See Also

DnsClient Class
BeginReceive Overload


BeginReceive Method (Object, AsyncCallback)

[image]

ComponentSpace DNS Class Library
DnsClient..::.BeginReceive Method (Object, AsyncCallback)
DnsClient Class See Also Send Feedback
Initiates an asynchronous receive operation that has a specified state object. This overload receives notification, through a callback, of the identity of the event handler for this operation.

Namespace: ComponentSpace.Dns
Assembly: ComponentSpace.Dns (in ComponentSpace.Dns.dll) Version: 1.8.0.2

Syntax

C#
public IAsyncResult BeginReceive(
    Object stateObject,
    AsyncCallback asyncCallback
)
Visual Basic (Declaration)
Public Function BeginReceive ( _
    stateObject As Object, _
    asyncCallback As AsyncCallback _
) As IAsyncResult
Visual C++
public:
IAsyncResult^ BeginReceive(
    Object^ stateObject,
    AsyncCallback^ asyncCallback
)

Parameters

stateObject
Type: System..::.Object
A state object, specified by the application, that contains information associated with the asynchronous operation.
asyncCallback
Type: System..::.AsyncCallback
The AsyncCallback that will receive the notification of the asynchronous operation completion.

Return Value

The IAsyncResult that identifies the posted asynchronous request.

Remarks

When you use this overload, the callback specified in the callback parameter is invoked directly when the receive operation has completed; the ReceiveCompleted event is not raised. The other overloads of BeginReceive rely on this component to raise the ReceiveCompleted event.

To use BeginReceive, define an asynchronous callback method. BeginReceive initiates an asynchronous receive operation; the DnsClient is notified, through a call to the callback method, when the receive operation is completed. The DnsClient can then access the receive status by calling EndReceive(IAsyncResult).

Use this overload to associate information with the operation that will be preserved throughout the operation's lifetime. The event handler can detect this information by looking at the AsyncState of the IAsyncResult that is associated with the operation.

Note: The BeginReceive method returns immediately, but the asynchronous operation is not completed until the event handler is called.

Because BeginReceive is asynchronous, you can call it to receive the receive status without blocking the current thread of execution. To synchronously receive, use the Receive()()() method.

Once an asynchronous operation completes, you can call BeginReceive again in the event handler to keep receiving notifications.

The IAsyncResult that BeginReceive returns identifies the asynchronous operation that the method call started. You can use this IAsyncResult throughout the lifetime of the operation, although you generally do not use it until EndReceive is called. However, if you start several asynchronous operations, you can place their IAsyncResult values in an array and specify whether to wait for all operations or any operation to complete. In this case, you use the AsyncWaitHandle property of the IAsyncResult to identify the completed operation.

The state object associates state information with the operation. For example, if you call BeginReceive multiple times to initiate multiple operations, you can identify each operation through a separate state object that you define.

You can also use the state object to pass information across process threads. If a thread is started but the callback is on a different thread in an asynchronous scenario, the state object is marshaled and passed back along with information from the event.

See Also

DnsClient Class
BeginReceive Overload


BeginReverseLookup Method

[image] [image]

ComponentSpace DNS Class Library
DnsClient..::.BeginReverseLookup Method
DnsClient Class See Also Send Feedback

Overload List

Name | Description
BeginReverseLookup(IPAddress) | Initiates an asynchronous reverse lookup operation.
BeginReverseLookup(IPAddress, Object) | Initiates an asynchronous reverse lookup operation that has a specified state object.
BeginReverseLookup(IPAddress, Object, AsyncCallback) | Initiates an asynchronous reverse lookup operation that has a specified state object. This overload receives notification, through a callback, of the identity of the event handler for this operation.

See Also

DnsClient Class
DnsClient Members


BeginReverseLookup Method (IPAddress)

[image]

ComponentSpace DNS Class Library
DnsClient..::.BeginReverseLookup Method (IPAddress)
DnsClient Class See Also Send Feedback
Initiates an asynchronous reverse lookup operation.

Namespace: ComponentSpace.Dns
Assembly: ComponentSpace.Dns (in ComponentSpace.Dns.dll) Version: 1.8.0.2

Syntax

C#
public IAsyncResult BeginReverseLookup(
    IPAddress hostAddress
)
Visual Basic (Declaration)
Public Function BeginReverseLookup ( _
    hostAddress As IPAddress _
) As IAsyncResult
Visual C++
public:
IAsyncResult^ BeginReverseLookup(
    IPAddress^ hostAddress
)

Parameters

hostAddress
Type: System.Net..::.IPAddress
The IP address to lookup.

Return Value

The IAsyncResult that identifies the posted asynchronous request.

Remarks

In asynchronous processing, you use BeginReverseLookup to raise the LookupCompleted event when the reverse lookup operation has completed.

To use BeginReverseLookup, create an event handler that processes the results of the asynchronous operation and associate it with your event delegate. BeginReverseLookup initiates an asynchronous reverse lookup operation; the DnsClient is notified, through the raising of the LookupCompleted event, when the reverse lookup operation is completed. The DnsClient can then access the reverse lookup status by calling EndReverseLookup(IAsyncResult).

Note: The BeginReverseLookup method returns immediately, but the asynchronous operation is not completed until the event handler is called.

Because BeginReverseLookup is asynchronous, you can call it to receive the reverse lookup status without blocking the current thread of execution. To synchronously reverse lookup, use the ReverseLookup(IPAddress) method.

Once an asynchronous operation completes, you can call BeginReverseLookup again in the event handler to keep receiving notifications.

The IAsyncResult that BeginReverseLookup returns identifies the asynchronous operation that the method call started. You can use this IAsyncResult throughout the lifetime of the operation, although you generally do not use it until EndReverseLookup is called. However, if you start several asynchronous operations, you can place their IAsyncResult values in an array and specify whether to wait for all operations or any operation to complete. In this case, you use the AsyncWaitHandle property of the IAsyncResult to identify the completed operation.

See Also

DnsClient Class
BeginReverseLookup Overload


BeginReverseLookup Method (IPAddress, Object)

[image]

ComponentSpace DNS Class Library
DnsClient..::.BeginReverseLookup Method (IPAddress, Object)
DnsClient Class See Also Send Feedback
Initiates an asynchronous reverse lookup operation that has a specified state object.

Namespace: ComponentSpace.Dns
Assembly: ComponentSpace.Dns (in ComponentSpace.Dns.dll) Version: 1.8.0.2

Syntax

C#
public IAsyncResult BeginReverseLookup(
    IPAddress hostAddress,
    Object stateObject
)
Visual Basic (Declaration)
Public Function BeginReverseLookup ( _
    hostAddress As IPAddress, _
    stateObject As Object _
) As IAsyncResult
Visual C++
public:
IAsyncResult^ BeginReverseLookup(
    IPAddress^ hostAddress,
    Object^ stateObject
)

Parameters

hostAddress
Type: System.Net..::.IPAddress
The IP address to lookup.
stateObject
Type: System..::.Object
A state object, specified by the application, that contains information associated with the asynchronous operation.

Return Value

The IAsyncResult that identifies the posted asynchronous request.

Remarks

In asynchronous processing, you use BeginReverseLookup to raise the LookupCompleted event when the reverse lookup operation has completed.

Use this overload to associate information with the operation that will be preserved throughout the operation's lifetime. The event handler can detect this information by looking at the AsyncState of the IAsyncResult that is associated with the operation.

To use BeginReverseLookup, create an event handler that processes the results of the asynchronous operation and associate it with your event delegate. BeginReverseLookup initiates an asynchronous reverse lookup operation; the DnsClient is notified, through the raising of the LookupCompleted event, when the reverse lookup operation is completed. The DnsClient can then access the reverse lookup status by calling EndReverseLookup(IAsyncResult).

Note: The BeginReverseLookup method returns immediately, but the asynchronous operation is not completed until the event handler is called.

Because BeginReverseLookup is asynchronous, you can call it to receive the reverse lookup status without blocking the current thread of execution. To synchronously reverse lookup, use the ReverseLookup(IPAddress) method.

Once an asynchronous operation completes, you can call BeginReverseLookup again in the event handler to keep receiving notifications.

The IAsyncResult that BeginReverseLookup returns identifies the asynchronous operation that the method call started. You can use this IAsyncResult throughout the lifetime of the operation, although you generally do not use it until EndReverseLookup is called. However, if you start several asynchronous operations, you can place their IAsyncResult values in an array and specify whether to wait for all operations or any operation to complete. In this case, you use the AsyncWaitHandle property of the IAsyncResult to identify the completed operation.

The state object associates state information with the operation. For example, if you call BeginReverseLookup multiple times to initiate multiple operations, you can identify each operation through a separate state object that you define.

You can also use the state object to pass information across process threads. If a thread is started but the callback is on a different thread in an asynchronous scenario, the state object is marshaled and passed back along with information from the event.

See Also

DnsClient Class
BeginReverseLookup Overload


BeginReverseLookup Method (IPAddress, Object, AsyncCallback)

[image]

ComponentSpace DNS Class Library
DnsClient..::.BeginReverseLookup Method (IPAddress, Object, AsyncCallback)
DnsClient Class See Also Send Feedback
Initiates an asynchronous reverse lookup operation that has a specified state object. This overload receives notification, through a callback, of the identity of the event handler for this operation.

Namespace: ComponentSpace.Dns
Assembly: ComponentSpace.Dns (in ComponentSpace.Dns.dll) Version: 1.8.0.2

Syntax

C#
public IAsyncResult BeginReverseLookup(
    IPAddress hostAddress,
    Object stateObject,
    AsyncCallback asyncCallback
)
Visual Basic (Declaration)
Public Function BeginReverseLookup ( _
    hostAddress As IPAddress, _
    stateObject As Object, _
    asyncCallback As AsyncCallback _
) As IAsyncResult
Visual C++
public:
IAsyncResult^ BeginReverseLookup(
    IPAddress^ hostAddress,
    Object^ stateObject,
    AsyncCallback^ asyncCallback
)

Parameters

hostAddress
Type: System.Net..::.IPAddress
The IP address to lookup.
stateObject
Type: System..::.Object
A state object, specified by the application, that contains information associated with the asynchronous operation.
asyncCallback
Type: System..::.AsyncCallback
The AsyncCallback that will receive the notification of the asynchronous operation completion.

Return Value

The IAsyncResult that identifies the posted asynchronous request.

Remarks

When you use this overload, the callback specified in the callback parameter is invoked directly when the reverse lookup operation has completed; the LookupCompleted event is not raised. The other overloads of BeginReverseLookup rely on this component to raise the LookupCompleted event.

To use BeginReverseLookup, define an asynchronous callback method. BeginReverseLookup initiates an asynchronous reverse lookup operation; the DnsClient is notified, through a call to the callback method, when the reverse lookup operation is completed. The DnsClient can then access the reverse lookup status by calling EndReverseLookup(IAsyncResult).

Use this overload to associate information with the operation that will be preserved throughout the operation's lifetime. The event handler can detect this information by looking at the AsyncState of the IAsyncResult that is associated with the operation.

Note: The BeginReverseLookup method returns immediately, but the asynchronous operation is not completed until the event handler is called.

Because BeginReverseLookup is asynchronous, you can call it to receive the reverse lookup status without blocking the current thread of execution. To synchronously reverse lookup, use the ReverseLookup(IPAddress) method.

Once an asynchronous operation completes, you can call BeginReverseLookup again in the event handler to keep receiving notifications.

The IAsyncResult that BeginReverseLookup returns identifies the asynchronous operation that the method call started. You can use this IAsyncResult throughout the lifetime of the operation, although you generally do not use it until EndReverseLookup is called. However, if you start several asynchronous operations, you can place their IAsyncResult values in an array and specify whether to wait for all operations or any operation to complete. In this case, you use the AsyncWaitHandle property of the IAsyncResult to identify the completed operation.

The state object associates state information with the operation. For example, if you call BeginReverseLookup multiple times to initiate multiple operations, you can identify each operation through a separate state object that you define.

You can also use the state object to pass information across process threads. If a thread is started but the callback is on a different thread in an asynchronous scenario, the state object is marshaled and passed back along with information from the event.

See Also

DnsClient Class
BeginReverseLookup Overload


BeginSend Method

[image] [image]

ComponentSpace DNS Class Library
DnsClient..::.BeginSend Method
DnsClient Class See Also Send Feedback

Overload List

Name | Description
BeginSend(DnsMessage) | Initiates an asynchronous send operation.
BeginSend(DnsMessage, Object) | Initiates an asynchronous send operation that has a specified state object.
BeginSend(DnsMessage, Object, AsyncCallback) | Initiates an asynchronous send operation that has a specified state object. This overload receives notification, through a callback, of the identity of the event handler for this operation.

See Also

DnsClient Class
DnsClient Members


BeginSend Method (DnsMessage)

[image]

ComponentSpace DNS Class Library
DnsClient..::.BeginSend Method (DnsMessage)
DnsClient Class See Also Send Feedback
Initiates an asynchronous send operation.

Namespace: ComponentSpace.Dns
Assembly: ComponentSpace.Dns (in ComponentSpace.Dns.dll) Version: 1.8.0.2

Syntax

C#
public IAsyncResult BeginSend(
    DnsMessage dnsMessage
)
Visual Basic (Declaration)
Public Function BeginSend ( _
    dnsMessage As DnsMessage _
) As IAsyncResult
Visual C++
public:
IAsyncResult^ BeginSend(
    DnsMessage^ dnsMessage
)

Parameters

dnsMessage
Type: ComponentSpace.Dns..::.DnsMessage
The DNS request message to send.

Return Value

The IAsyncResult that identifies the posted asynchronous request.

Remarks

In asynchronous processing, you use BeginSend to raise the SendCompleted event when the send operation has completed.

To use BeginSend, create an event handler that processes the results of the asynchronous operation and associate it with your event delegate. BeginSend initiates an asynchronous send operation; the DnsClient is notified, through the raising of the SendCompleted event, when the send operation is completed. The DnsClient can then access the send status by calling EndSend(IAsyncResult).

Note: The BeginSend method returns immediately, but the asynchronous operation is not completed until the event handler is called.

Because BeginSend is asynchronous, you can call it to receive the send status without blocking the current thread of execution. To synchronously send, use the Send(DnsMessage) method.

Once an asynchronous operation completes, you can call BeginSend again in the event handler to keep receiving notifications.

The IAsyncResult that BeginSend returns identifies the asynchronous operation that the method call started. You can use this IAsyncResult throughout the lifetime of the operation, although you generally do not use it until EndSend is called. However, if you start several asynchronous operations, you can place their IAsyncResult values in an array and specify whether to wait for all operations or any operation to complete. In this case, you use the AsyncWaitHandle property of the IAsyncResult to identify the completed operation.

See Also

DnsClient Class
BeginSend Overload


BeginSend Method (DnsMessage, Object)

[image]

ComponentSpace DNS Class Library
DnsClient..::.BeginSend Method (DnsMessage, Object)
DnsClient Class See Also Send Feedback
Initiates an asynchronous send operation that has a specified state object.

Namespace: ComponentSpace.Dns
Assembly: ComponentSpace.Dns (in ComponentSpace.Dns.dll) Version: 1.8.0.2

Syntax

C#
public IAsyncResult BeginSend(
    DnsMessage dnsMessage,
    Object stateObject
)
Visual Basic (Declaration)
Public Function BeginSend ( _
    dnsMessage As DnsMessage, _
    stateObject As Object _
) As IAsyncResult
Visual C++
public:
IAsyncResult^ BeginSend(
    DnsMessage^ dnsMessage,
    Object^ stateObject
)

Parameters

dnsMessage
Type: ComponentSpace.Dns..::.DnsMessage
The DNS request message to send.
stateObject
Type: System..::.Object
A state object, specified by the application, that contains information associated with the asynchronous operation.

Return Value

The IAsyncResult that identifies the posted asynchronous request.

Remarks

In asynchronous processing, you use BeginSend to raise the SendCompleted event when the send operation has completed.

Use this overload to associate information with the operation that will be preserved throughout the operation's lifetime. The event handler can detect this information by looking at the AsyncState of the IAsyncResult that is associated with the operation.

To use BeginSend, create an event handler that processes the results of the asynchronous operation and associate it with your event delegate. BeginSend initiates an asynchronous send operation; the DnsClient is notified, through the raising of the SendCompleted event, when the send operation is completed. The DnsClient can then access the send status by calling EndSend(IAsyncResult).

Note: The BeginSend method returns immediately, but the asynchronous operation is not completed until the event handler is called.

Because BeginSend is asynchronous, you can call it to receive the send status without blocking the current thread of execution. To synchronously send, use the Send(DnsMessage) method.

Once an asynchronous operation completes, you can call BeginSend again in the event handler to keep receiving notifications.

The IAsyncResult that BeginSend returns identifies the asynchronous operation that the method call started. You can use this IAsyncResult throughout the lifetime of the operation, although you generally do not use it until EndSend is called. However, if you start several asynchronous operations, you can place their IAsyncResult values in an array and specify whether to wait for all operations or any operation to complete. In this case, you use the AsyncWaitHandle property of the IAsyncResult to identify the completed operation.

The state object associates state information with the operation. For example, if you call BeginSend multiple times to initiate multiple operations, you can identify each operation through a separate state object that you define.

You can also use the state object to pass information across process threads. If a thread is started but the callback is on a different thread in an asynchronous scenario, the state object is marshaled and passed back along with information from the event.

See Also

DnsClient Class
BeginSend Overload


BeginSend Method (DnsMessage, Object, AsyncCallback)

[image]

ComponentSpace DNS Class Library
DnsClient..::.BeginSend Method (DnsMessage, Object, AsyncCallback)
DnsClient Class See Also Send Feedback
Initiates an asynchronous send operation that has a specified state object. This overload receives notification, through a callback, of the identity of the event handler for this operation.

Namespace: ComponentSpace.Dns
Assembly: ComponentSpace.Dns (in ComponentSpace.Dns.dll) Version: 1.8.0.2

Syntax

C#
public IAsyncResult BeginSend(
    DnsMessage dnsMessage,
    Object stateObject,
    AsyncCallback asyncCallback
)
Visual Basic (Declaration)
Public Function BeginSend ( _
    dnsMessage As DnsMessage, _
    stateObject As Object, _
    asyncCallback As AsyncCallback _
) As IAsyncResult
Visual C++
public:
IAsyncResult^ BeginSend(
    DnsMessage^ dnsMessage,
    Object^ stateObject,
    AsyncCallback^ asyncCallback
)

Parameters

dnsMessage
Type: ComponentSpace.Dns..::.DnsMessage
The DNS request message to send.
stateObject
Type: System..::.Object
A state object, specified by the application, that contains information associated with the asynchronous operation.
asyncCallback
Type: System..::.AsyncCallback
The AsyncCallback that will receive the notification of the asynchronous operation completion.

Return Value

The IAsyncResult that identifies the posted asynchronous request.

Remarks

When you use this overload, the callback specified in the callback parameter is invoked directly when the send operation has completed; the SendCompleted event is not raised. The other overloads of BeginSend rely on this component to raise the SendCompleted event.

To use BeginSend, define an asynchronous callback method. BeginSend initiates an asynchronous send operation; the DnsClient is notified, through a call to the callback method, when the send operation is completed. The DnsClient can then access the send status by calling EndSend(IAsyncResult).

Use this overload to associate information with the operation that will be preserved throughout the operation's lifetime. The event handler can detect this information by looking at the AsyncState of the IAsyncResult that is associated with the operation.

Note: The BeginSend method returns immediately, but the asynchronous operation is not completed until the event handler is called.

Because BeginSend is asynchronous, you can call it to receive the send status without blocking the current thread of execution. To synchronously send, use the Send(DnsMessage) method.

Once an asynchronous operation completes, you can call BeginSend again in the event handler to keep receiving notifications.

The IAsyncResult that BeginSend returns identifies the asynchronous operation that the method call started. You can use this IAsyncResult throughout the lifetime of the operation, although you generally do not use it until EndSend is called. However, if you start several asynchronous operations, you can place their IAsyncResult values in an array and specify whether to wait for all operations or any operation to complete. In this case, you use the AsyncWaitHandle property of the IAsyncResult to identify the completed operation.

The state object associates state information with the operation. For example, if you call BeginSend multiple times to initiate multiple operations, you can identify each operation through a separate state object that you define.

You can also use the state object to pass information across process threads. If a thread is started but the callback is on a different thread in an asynchronous scenario, the state object is marshaled and passed back along with information from the event.

See Also

DnsClient Class
BeginSend Overload


Close Method

[image]

ComponentSpace DNS Class Library
DnsClient..::.Close Method
DnsClient Class See Also Send Feedback
Close the DnsClient and the underlying socket object.

Namespace: ComponentSpace.Dns
Assembly: ComponentSpace.Dns (in ComponentSpace.Dns.dll) Version: 1.8.0.2

Syntax

C#
public void Close()
Visual Basic (Declaration)
Public Sub Close
Visual C++
public:
void Close()

See Also

DnsClient Class


CreateReverseLookupName Method

[image]

ComponentSpace DNS Class Library
DnsClient..::.CreateReverseLookupName Method
DnsClient Class See Also Send Feedback
Creates a reverse lookup name for use in a DNS reverse lookup. For example, given an address of 66.210.153.10 it returns 10.153.210.66.IN-ADDR.ARPA. For more information about reverse lookups, refer to RFC 1035.

Namespace: ComponentSpace.Dns
Assembly: ComponentSpace.Dns (in ComponentSpace.Dns.dll) Version: 1.8.0.2

Syntax

C#
public static string CreateReverseLookupName(
    IPAddress ipAddress
)
Visual Basic (Declaration)
Public Shared Function CreateReverseLookupName ( _
    ipAddress As IPAddress _
) As String
Visual C++
public:
static String^ CreateReverseLookupName(
    IPAddress^ ipAddress
)

Parameters

ipAddress
Type: System.Net..::.IPAddress
The IP address

Return Value

[Missing <returns> documentation for M:ComponentSpace.Dns.DnsClient.CreateReverseLookupName(System.Net.IPAddress)]

See Also

DnsClient Class


Dispose Method

[image]

ComponentSpace DNS Class Library
DnsClient..::.Dispose Method
DnsClient Class See Also Send Feedback
Dispose of the DnsClient and the underlying socket object.

Namespace: ComponentSpace.Dns
Assembly: ComponentSpace.Dns (in ComponentSpace.Dns.dll) Version: 1.8.0.2

Syntax

C#
public void Dispose()
Visual Basic (Declaration)
Public Sub Dispose
Visual C++
public:
virtual void Dispose() sealed

Implements

IDisposable..::.Dispose()()()

See Also

DnsClient Class


EndLookup Method

[image]

ComponentSpace DNS Class Library
DnsClient..::.EndLookup Method
DnsClient Class See Also Send Feedback
Completes the specified asynchronous lookup operation.

Namespace: ComponentSpace.Dns
Assembly: ComponentSpace.Dns (in ComponentSpace.Dns.dll) Version: 1.8.0.2

Syntax

C#
public IPAddress[] EndLookup(
    IAsyncResult asyncResult
)
Visual Basic (Declaration)
Public Function EndLookup ( _
    asyncResult As IAsyncResult _
) As IPAddress()
Visual C++
public:
array<IPAddress^>^ EndLookup(
    IAsyncResult^ asyncResult
)

Parameters

asyncResult
Type: System..::.IAsyncResult
The IAsyncResult that identifies the asynchronous lookup operation to finish, and from which to retrieve an end result.

Return Value

The resolved IP addresses.

Remarks

When the LookupCompleted event is raised, EndLookup completes the operation that was initiated by the BeginLookup(String) call.

Exceptions

Exception | Condition
ComponentSpace.Dns..::.DnsLookupException | Thrown when the lookup fails.

See Also

DnsClient Class


EndQuery Method

[image]

ComponentSpace DNS Class Library
DnsClient..::.EndQuery Method
DnsClient Class See Also Send Feedback
Completes the specified asynchronous query operation.

Namespace: ComponentSpace.Dns
Assembly: ComponentSpace.Dns (in ComponentSpace.Dns.dll) Version: 1.8.0.2

Syntax

C#
public DnsMessage EndQuery(
    IAsyncResult asyncResult
)
Visual Basic (Declaration)
Public Function EndQuery ( _
    asyncResult As IAsyncResult _
) As DnsMessage
Visual C++
public:
DnsMessage^ EndQuery(
    IAsyncResult^ asyncResult
)

Parameters

asyncResult
Type: System..::.IAsyncResult
The IAsyncResult that identifies the asynchronous query operation to finish, and from which to retrieve an end result.

Return Value

The DNS response message.

Remarks

When the QueryCompleted event is raised, EndQuery completes the operation that was initiated by the BeginQuery(DnsMessage) call.

Exceptions

Exception | Condition
ComponentSpace.Dns..::.DnsException | Thrown when the query fails.

See Also

DnsClient Class


EndReceive Method

[image]

ComponentSpace DNS Class Library
DnsClient..::.EndReceive Method
DnsClient Class See Also Send Feedback
Completes the specified asynchronous receive operation.

Namespace: ComponentSpace.Dns
Assembly: ComponentSpace.Dns (in ComponentSpace.Dns.dll) Version: 1.8.0.2

Syntax

C#
public DnsMessage EndReceive(
    IAsyncResult asyncResult
)
Visual Basic (Declaration)
Public Function EndReceive ( _
    asyncResult As IAsyncResult _
) As DnsMessage
Visual C++
public:
DnsMessage^ EndReceive(
    IAsyncResult^ asyncResult
)

Parameters

asyncResult
Type: System..::.IAsyncResult
The IAsyncResult that identifies the asynchronous receive operation to finish, and from which to retrieve an end result.

Return Value

The DNS response message.

Remarks

When the ReceiveCompleted event is raised, EndReceive completes the operation that was initiated by the BeginReceive()()() call.

Exceptions

Exception | Condition
ComponentSpace.Dns..::.DnsException | Thrown when the message cannot be received.

See Also

DnsClient Class


EndReverseLookup Method

[image]

ComponentSpace DNS Class Library
DnsClient..::.EndReverseLookup Method
DnsClient Class See Also Send Feedback
Completes the specified asynchronous reverse lookup operation.

Namespace: ComponentSpace.Dns
Assembly: ComponentSpace.Dns (in ComponentSpace.Dns.dll) Version: 1.8.0.2

Syntax

C#
public string[] EndReverseLookup(
    IAsyncResult asyncResult
)
Visual Basic (Declaration)
Public Function EndReverseLookup ( _
    asyncResult As IAsyncResult _
) As String()
Visual C++
public:
array<String^>^ EndReverseLookup(
    IAsyncResult^ asyncResult
)

Parameters

asyncResult
Type: System..::.IAsyncResult
The IAsyncResult that identifies the asynchronous reverse lookup operation to finish, and from which to retrieve an end result.

Return Value

The resolved host names.

Remarks

When the LookupCompleted event is raised, EndReverseLookup completes the operation that was initiated by the BeginReverseLookup(IPAddress) call.

Exceptions

Exception | Condition
ComponentSpace.Dns..::.DnsLookupException | Thrown when the lookup fails.

See Also

DnsClient Class


EndSend Method

[image]

ComponentSpace DNS Class Library
DnsClient..::.EndSend Method
DnsClient Class See Also Send Feedback
Completes the specified asynchronous send operation.

Namespace: ComponentSpace.Dns
Assembly: ComponentSpace.Dns (in ComponentSpace.Dns.dll) Version: 1.8.0.2

Syntax

C#
public void EndSend(
    IAsyncResult asyncResult
)
Visual Basic (Declaration)
Public Sub EndSend ( _
    asyncResult As IAsyncResult _
)
Visual C++
public:
void EndSend(
    IAsyncResult^ asyncResult
)

Parameters

asyncResult
Type: System..::.IAsyncResult
The IAsyncResult that identifies the asynchronous send operation to finish, and from which to retrieve an end result.

Remarks

When the SendCompleted event is raised, EndSend completes the operation that was initiated by the BeginSend(DnsMessage) call.

Exceptions

Exception | Condition
ComponentSpace.Dns..::.DnsException | Thrown when the message cannot be sent.

See Also

DnsClient Class


Lookup Method

[image]

ComponentSpace DNS Class Library
DnsClient..::.Lookup Method
DnsClient Class See Also Send Feedback
Performs a forward DNS lookup to resolve the host name to one or more IP addresses. For example, www.componentspace.com is resolved to 66.210.153.10.

Namespace: ComponentSpace.Dns
Assembly: ComponentSpace.Dns (in ComponentSpace.Dns.dll) Version: 1.8.0.2

Syntax

C#
public IPAddress[] Lookup(
    string hostName
)
Visual Basic (Declaration)
Public Function Lookup ( _
    hostName As String _
) As IPAddress()
Visual C++
public:
array<IPAddress^>^ Lookup(
    String^ hostName
)

Parameters

hostName
Type: System..::.String
The host name to resolve.

Return Value

The resolved IP addresses.

Exceptions

Exception | Condition
ComponentSpace.Dns..::.DnsLookupException | Thrown when the lookup fails.

See Also

DnsClient Class


Query Method

[image]

ComponentSpace DNS Class Library
DnsClient..::.Query Method
DnsClient Class See Also Send Feedback
Performs a DNS query by sending a DNS message to the DNS server and receiving a DNS response message.

Namespace: ComponentSpace.Dns
Assembly: ComponentSpace.Dns (in ComponentSpace.Dns.dll) Version: 1.8.0.2

Syntax

C#
public DnsMessage Query(
    DnsMessage dnsMessage
)
Visual Basic (Declaration)
Public Function Query ( _
    dnsMessage As DnsMessage _
) As DnsMessage
Visual C++
public:
DnsMessage^ Query(
    DnsMessage^ dnsMessage
)

Parameters

dnsMessage
Type: ComponentSpace.Dns..::.DnsMessage
The DNS request message to send.

Return Value

[Missing <returns> documentation for M:ComponentSpace.Dns.DnsClient.Query(ComponentSpace.Dns.DnsMessage)]

Exceptions

Exception | Condition
ComponentSpace.Dns..::.DnsLookupException | Thrown when the query fails.

See Also

DnsClient Class
ComponentSpace.Dns Namespace
DnsClient..::.Send(DnsMessage)
DnsClient..::.Receive()()()


Receive Method

[image]

ComponentSpace DNS Class Library
DnsClient..::.Receive Method
DnsClient Class See Also Send Feedback
Returns a DNS response message from the server.

Namespace: ComponentSpace.Dns
Assembly: ComponentSpace.Dns (in ComponentSpace.Dns.dll) Version: 1.8.0.2

Syntax

C#
public DnsMessage Receive()
Visual Basic (Declaration)
Public Function Receive As DnsMessage
Visual C++
public:
DnsMessage^ Receive()

Return Value

The DNS response message.

Exceptions

Exception | Condition
ComponentSpace.Dns..::.DnsException | Thrown when the message cannot be received.

See Also

DnsClient Class


ReverseLookup Method

[image]

ComponentSpace DNS Class Library
DnsClient..::.ReverseLookup Method
DnsClient Class See Also Send Feedback
Performs a reverse DNS lookup to resolve an IP address to one or more host names. For example, 66.210.153.10 is resolved to www.componentspace.com. For more information about reverse lookups, refer to RFC 1035.

Namespace: ComponentSpace.Dns
Assembly: ComponentSpace.Dns (in ComponentSpace.Dns.dll) Version: 1.8.0.2

Syntax

C#
public string[] ReverseLookup(
    IPAddress hostAddress
)
Visual Basic (Declaration)
Public Function ReverseLookup ( _
    hostAddress As IPAddress _
) As String()
Visual C++
public:
array<String^>^ ReverseLookup(
    IPAddress^ hostAddress
)

Parameters

hostAddress
Type: System.Net..::.IPAddress
The IP address to lookup.

Return Value

The resolved host names.

Exceptions

Exception | Condition
ComponentSpace.Dns..::.DnsLookupException | Thrown when the lookup fails.

See Also

DnsClient Class


Send Method

[image]

ComponentSpace DNS Class Library
DnsClient..::.Send Method
DnsClient Class See Also Send Feedback
Send a DNS request message to the server.

Namespace: ComponentSpace.Dns
Assembly: ComponentSpace.Dns (in ComponentSpace.Dns.dll) Version: 1.8.0.2

Syntax

C#
public void Send(
    DnsMessage dnsMessage
)
Visual Basic (Declaration)
Public Sub Send ( _
    dnsMessage As DnsMessage _
)
Visual C++
public:
void Send(
    DnsMessage^ dnsMessage
)

Parameters

dnsMessage
Type: ComponentSpace.Dns..::.DnsMessage
The DNS request message to send.

Exceptions

Exception | Condition
ComponentSpace.Dns..::.DnsException | Thrown when the message cannot be sent.

See Also

DnsClient Class


DnsClient Properties

[image] [image]

ComponentSpace DNS Class Library
DnsClient Properties
DnsClient Class See Also Send Feedback

The DnsClient type exposes the following members.

Properties

Name | Description
DnsServerList | Gets the list of configured DNS servers.
ReceiveTimeout | Gets or sets the number of milliseconds to wait for the response from the server.
SynchronizingObject | Gets or sets the synchonizing object for receiving events.

See Also

DnsClient Class


DnsServerList Property

[image]

ComponentSpace DNS Class Library
DnsClient..::.DnsServerList Property
DnsClient Class See Also Send Feedback
Gets the list of configured DNS servers.

Namespace: ComponentSpace.Dns
Assembly: ComponentSpace.Dns (in ComponentSpace.Dns.dll) Version: 1.8.0.2

Syntax

C#
public static IPAddress[] DnsServerList { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property DnsServerList As IPAddress()
Visual C++
public:
static property array<IPAddress^>^ DnsServerList {
    array<IPAddress^>^ get ();
}

Field Value

The IP addresses of the configured DNS servers.

See Also

DnsClient Class


ReceiveTimeout Property

[image]

ComponentSpace DNS Class Library
DnsClient..::.ReceiveTimeout Property
DnsClient Class See Also Send Feedback
Gets or sets the number of milliseconds to wait for the response from the server.

Namespace: ComponentSpace.Dns
Assembly: ComponentSpace.Dns (in ComponentSpace.Dns.dll) Version: 1.8.0.2

Syntax

C#
public int ReceiveTimeout { get; set; }
Visual Basic (Declaration)
Public Property ReceiveTimeout As Integer
Visual C++
public:
property int ReceiveTimeout {
    int get ();
    void set (int value);
}

Field Value

The number of milliseconds to wait for the response from the server. The default is 30 seconds.

See Also

DnsClient Class


SynchronizingObject Property

[image]

ComponentSpace DNS Class Library
DnsClient..::.SynchronizingObject Property
DnsClient Class See Also Send Feedback
Gets or sets the synchonizing object for receiving events.

Namespace: ComponentSpace.Dns
Assembly: ComponentSpace.Dns (in ComponentSpace.Dns.dll) Version: 1.8.0.2

Syntax

C#
public ISynchronizeInvoke SynchronizingObject { get; set; }
Visual Basic (Declaration)
Public Property SynchronizingObject As ISynchronizeInvoke
Visual C++
public:
property ISynchronizeInvoke^ SynchronizingObject {
    ISynchronizeInvoke^ get ();
    void set (ISynchronizeInvoke^ value);
}

Field Value

An ISynchronizeInvoke, which represents the object that marshals the event-handler call resulting from a SendCompleted or ReceiveCompleted event. The default is a null reference (Nothing in Visual Basic).

Remarks

A SendCompleted event results from a BeginSend(DnsMessage) request to a specific thread. A ReceiveCompleted event results from a BeginReceive()()() request to a specific thread. Typically, the SynchronizingObject is set when it's used within a form, because forms are bound to a specific thread.

Typically, the synchronizing object marshals a method call into a single thread.

See Also

DnsClient Class


DnsClient Events

[image] [image]

ComponentSpace DNS Class Library
DnsClient Events
DnsClient Class See Also Send Feedback

The DnsClient type exposes the following members.

Events

Name | Description
LookupCompleted | Occurs when the lookup operation has completed.
QueryCompleted | Occurs when the query operation has completed.
ReceiveCompleted | Occurs when the receive operation has completed.
SendCompleted | Occurs when the send operation has completed.

See Also

DnsClient Class


LookupCompleted Event

[image]

ComponentSpace DNS Class Library
DnsClient..::.LookupCompleted Event
DnsClient Class See Also Send Feedback
Occurs when the lookup operation has completed.

Namespace: ComponentSpace.Dns
Assembly: ComponentSpace.Dns (in ComponentSpace.Dns.dll) Version: 1.8.0.2

Syntax

C#
public event LookupCompletedEventHandler LookupCompleted
Visual Basic (Declaration)
Public Event LookupCompleted As LookupCompletedEventHandler
Visual C++
public:
 event LookupCompletedEventHandler^ LookupCompleted {
    void add (LookupCompletedEventHandler^ value);
    void remove (LookupCompletedEventHandler^ value);
}

Remarks

BeginLookup(String) or BeginReverseLookup(IPAddress) is used in asynchronous processing to raise the LookupCompleted event when the lookup operation has completed.

EndLookup(IAsyncResult) or EndReverseLookup(IAsyncResult) is used to complete the operation initiated by a call to BeginLookup(String) or BeginReverseLookup(IPAddress) and get the lookup status when the LookupCompleted event is raised.

See Also

DnsClient Class


QueryCompleted Event

[image]

ComponentSpace DNS Class Library
DnsClient..::.QueryCompleted Event
DnsClient Class See Also Send Feedback
Occurs when the query operation has completed.

Namespace: ComponentSpace.Dns
Assembly: ComponentSpace.Dns (in ComponentSpace.Dns.dll) Version: 1.8.0.2

Syntax

C#
public event QueryCompletedEventHandler QueryCompleted
Visual Basic (Declaration)
Public Event QueryCompleted As QueryCompletedEventHandler
Visual C++
public:
 event QueryCompletedEventHandler^ QueryCompleted {
    void add (QueryCompletedEventHandler^ value);
    void remove (QueryCompletedEventHandler^ value);
}

Remarks

BeginQuery(DnsMessage) is used in asynchronous processing to raise the QueryCompleted event when the query operation has completed.

EndQuery(IAsyncResult)is used to complete the operation initiated by a call to BeginQuery(DnsMessage) and get the query status when the QueryCompleted event is raised.

See Also

DnsClient Class


ReceiveCompleted Event

[image]

ComponentSpace DNS Class Library
DnsClient..::.ReceiveCompleted Event
DnsClient Class See Also Send Feedback
Occurs when the receive operation has completed.

Namespace: ComponentSpace.Dns
Assembly: ComponentSpace.Dns (in ComponentSpace.Dns.dll) Version: 1.8.0.2

Syntax

C#
public event ReceiveCompletedEventHandler ReceiveCompleted
Visual Basic (Declaration)
Public Event ReceiveCompleted As ReceiveCompletedEventHandler
Visual C++
public:
 event ReceiveCompletedEventHandler^ ReceiveCompleted {
    void add (ReceiveCompletedEventHandler^ value);
    void remove (ReceiveCompletedEventHandler^ value);
}

Remarks

BeginReceive()()() is used in asynchronous processing to raise the ReceiveCompleted event when the receive operation has completed.

EndReceive(IAsyncResult) is used to complete the operation initiated by a call to BeginReceive()()() and get the receive status when the ReceiveCompleted event is raised.

See Also

DnsClient Class


SendCompleted Event

[image]

ComponentSpace DNS Class Library
DnsClient..::.SendCompleted Event
DnsClient Class See Also Send Feedback
Occurs when the send operation has completed.

Namespace: ComponentSpace.Dns
Assembly: ComponentSpace.Dns (in ComponentSpace.Dns.dll) Version: 1.8.0.2

Syntax

C#
public event SendCompletedEventHandler SendCompleted
Visual Basic (Declaration)
Public Event SendCompleted As SendCompletedEventHandler
Visual C++
public:
 event SendCompletedEventHandler^ SendCompleted {
    void add (SendCompletedEventHandler^ value);
    void remove (SendCompletedEventHandler^ value);
}

Remarks

BeginSend(DnsMessage) is used in asynchronous processing to raise the SendCompleted event when the send operation has completed.

EndSend(IAsyncResult) is used to complete the operation initiated by a call to BeginSend(DnsMessage) and get the send status when the SendCompleted event is raised.

See Also

DnsClient Class


DnsException Class

[image]

ComponentSpace DNS Class Library
DnsException Class
Members See Also Send Feedback
The exception that is thrown when a DNS operation fails.

Namespace: ComponentSpace.Dns
Assembly: ComponentSpace.Dns (in ComponentSpace.Dns.dll) Version: 1.8.0.2

Syntax

C#
[SerializableAttribute]
public class DnsException : ApplicationException
Visual Basic (Declaration)
<SerializableAttribute> _
Public Class DnsException _
    Inherits ApplicationException
Visual C++
[SerializableAttribute]
public ref class DnsException : public ApplicationException

Inheritance Hierarchy

System..::.Object
System..::.Exception
System..::.ApplicationException
ComponentSpace.Dns..::.DnsException
ComponentSpace.Dns..::.DnsLookupException

See Also

DnsException Members


DnsException Members

[image] [image]

ComponentSpace DNS Class Library
DnsException Members
DnsException Class Methods Properties See Also Send Feedback

The DnsException type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetObjectData | When overridden in a derived class, sets the SerializationInfo with information about the exception. (Inherited from Exception.)
GetType | Gets the runtime type of the current instance. (Inherited from Exception.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Creates and returns a string representation of the current exception. (Inherited from Exception.)

Properties

Name | Description
Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Exception.)
HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Exception.)
InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
Message | Gets a message that describes the current exception. (Inherited from Exception.)
Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
StackTrace | Gets a string representation of the frames on the call stack at the time the current exception was thrown. (Inherited from Exception.)
TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)

See Also

DnsException Class


DnsException Methods

[image] [image]

ComponentSpace DNS Class Library
DnsException Methods
DnsException Class See Also Send Feedback

The DnsException type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetObjectData | When overridden in a derived class, sets the SerializationInfo with information about the exception. (Inherited from Exception.)
GetType | Gets the runtime type of the current instance. (Inherited from Exception.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Creates and returns a string representation of the current exception. (Inherited from Exception.)

See Also

DnsException Class


DnsException Properties

[image] [image]

ComponentSpace DNS Class Library
DnsException Properties
DnsException Class See Also Send Feedback

The DnsException type exposes the following members.

Properties

Name | Description
Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Exception.)
HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Exception.)
InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
Message | Gets a message that describes the current exception. (Inherited from Exception.)
Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
StackTrace | Gets a string representation of the frames on the call stack at the time the current exception was thrown. (Inherited from Exception.)
TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)

See Also

DnsException Class


DnsLookupException Class

[image]

ComponentSpace DNS Class Library
DnsLookupException Class
Members See Also Send Feedback
The exception that is thrown when a DNS lookup fails.

Namespace: ComponentSpace.Dns
Assembly: ComponentSpace.Dns (in ComponentSpace.Dns.dll) Version: 1.8.0.2

Syntax

C#
[SerializableAttribute]
public class DnsLookupException : DnsException
Visual Basic (Declaration)
<SerializableAttribute> _
Public Class DnsLookupException _
    Inherits DnsException
Visual C++
[SerializableAttribute]
public ref class DnsLookupException : public DnsException

Inheritance Hierarchy

System..::.Object
System..::.Exception
System..::.ApplicationException
ComponentSpace.Dns..::.DnsException
ComponentSpace.Dns..::.DnsLookupException

See Also

DnsLookupException Members


DnsLookupException Members

[image] [image]

ComponentSpace DNS Class Library
DnsLookupException Members
DnsLookupException Class Methods Properties See Also Send Feedback

The DnsLookupException type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetObjectData | When overridden in a derived class, sets the SerializationInfo with information about the exception. (Inherited from Exception.)
GetType | Gets the runtime type of the current instance. (Inherited from Exception.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Creates and returns a string representation of the current exception. (Inherited from Exception.)

Properties

Name | Description
Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Exception.)
DnsMessage | Gets the DNS response message associated with this exception, if any.
HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Exception.)
InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
Message | Gets a message that describes the current exception. (Inherited from Exception.)
Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
StackTrace | Gets a string representation of the frames on the call stack at the time the current exception was thrown. (Inherited from Exception.)
TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)

See Also

DnsLookupException Class


DnsLookupException Methods

[image] [image]

ComponentSpace DNS Class Library
DnsLookupException Methods
DnsLookupException Class See Also Send Feedback

The DnsLookupException type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetObjectData | When overridden in a derived class, sets the SerializationInfo with information about the exception. (Inherited from Exception.)
GetType | Gets the runtime type of the current instance. (Inherited from Exception.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Creates and returns a string representation of the current exception. (Inherited from Exception.)

See Also

DnsLookupException Class


DnsLookupException Properties

[image] [image]

ComponentSpace DNS Class Library
DnsLookupException Properties
DnsLookupException Class See Also Send Feedback

The DnsLookupException type exposes the following members.

Properties

Name | Description
Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Exception.)
DnsMessage | Gets the DNS response message associated with this exception, if any.
HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Exception.)
InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
Message | Gets a message that describes the current exception. (Inherited from Exception.)
Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
StackTrace | Gets a string representation of the frames on the call stack at the time the current exception was thrown. (Inherited from Exception.)
TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)

See Also

DnsLookupException Class


DnsMessage Property

[image]

ComponentSpace DNS Class Library
DnsLookupException..::.DnsMessage Property
DnsLookupException Class See Also Send Feedback
Gets the DNS response message associated with this exception, if any.

Namespace: ComponentSpace.Dns
Assembly: ComponentSpace.Dns (in ComponentSpace.Dns.dll) Version: 1.8.0.2

Syntax

C#
public DnsMessage DnsMessage { get; }
Visual Basic (Declaration)
Public ReadOnly Property DnsMessage As DnsMessage
Visual C++
public:
property DnsMessage^ DnsMessage {
    DnsMessage^ get ();
}

See Also

DnsLookupException Class


DnsMessage Class

[image]

ComponentSpace DNS Class Library
DnsMessage Class
Members See Also Send Feedback
A DNS protocol request/response message.

Namespace: ComponentSpace.Dns
Assembly: ComponentSpace.Dns (in ComponentSpace.Dns.dll) Version: 1.8.0.2

Syntax

C#
public class DnsMessage
Visual Basic (Declaration)
Public Class DnsMessage
Visual C++
public ref class DnsMessage

Remarks

For specific message details refer to the DNS RFCs.

Inheritance Hierarchy

System..::.Object
ComponentSpace.Dns..::.DnsMessage

See Also

DnsMessage Members


DnsMessage Members

[image] [image]

ComponentSpace DNS Class Library
DnsMessage Members
DnsMessage Class Constructors Methods Properties See Also Send Feedback

The DnsMessage type exposes the following members.

Constructors

Name | Description
DnsMessage | Overloaded.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToByteArray | Convert the message into a byte array.
ToString | Convert the message to a string. (Overrides Object..::.ToString()()().)

Properties

Name | Description
AdditionalResourceRecords | Get the list of additional information resource records.
AnswerResourceRecords | Get the list of answer resource records.
AuthoritativeAnswer | Get or sets the flag indicating whether the message contains an authoritative answer (AA).
AuthorityResourceRecords | Get the list of authority resource records.
DnsQuestions | Get the list of questions.
Identifier | Get or sets the message identifier (ID).
OpCode | Get or sets the message op code (Opcode).
RecursionAvailable | Get or sets the flag indicating whether recursion is available (RA).
RecursionDesired | Get or sets the flag indicating whether recursion is desired (RD).
Response | Get or sets the flag indicating whether the message is a request or response (QR).
ResponseCode | Get or sets the response code (RCODE).
Truncation | Get or sets the flag indicating whether the message is truncated (TC).

See Also

DnsMessage Class


DnsMessage Constructor

[image] [image]

ComponentSpace DNS Class Library
DnsMessage Constructor
DnsMessage Class See Also Send Feedback

Overload List

Name | Description
DnsMessage()()() | The default constructor.
DnsMessage(array<Byte>[]()[], Int32%, Int32%) | Construct from a byte array.

See Also

DnsMessage Class
DnsMessage Members


DnsMessage Constructor

[image]

ComponentSpace DNS Class Library
DnsMessage Constructor
DnsMessage Class See Also Send Feedback
The default constructor.

Namespace: ComponentSpace.Dns
Assembly: ComponentSpace.Dns (in ComponentSpace.Dns.dll) Version: 1.8.0.2

Syntax

C#
public DnsMessage()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
DnsMessage()

See Also

DnsMessage Class
DnsMessage Overload


DnsMessage Constructor (Byte[], Int32, Int32)

[image]

ComponentSpace DNS Class Library
DnsMessage Constructor (array<Byte>[]()[], Int32%, Int32%)
DnsMessage Class See Also Send Feedback
Construct from a byte array.

Namespace: ComponentSpace.Dns
Assembly: ComponentSpace.Dns (in ComponentSpace.Dns.dll) Version: 1.8.0.2

Syntax

C#
public DnsMessage(
    byte[] bytes,
    ref int index,
    ref int count
)
Visual Basic (Declaration)
Public Sub New ( _
    bytes As Byte(), _
    ByRef index As Integer, _
    ByRef count As Integer _
)
Visual C++
public:
DnsMessage(
    array<unsigned char>^ bytes,
    int% index,
    int% count
)

Parameters

bytes
Type: array< System..::.Byte >[]()[]
The byte array containing the message.
index
Type: System..::.Int32 %
The index into the byte array.
count
Type: System..::.Int32 %
The number of bytes available in the byte array.

See Also

DnsMessage Class
DnsMessage Overload


DnsMessage Methods

[image] [image]

ComponentSpace DNS Class Library
DnsMessage Methods
DnsMessage Class See Also Send Feedback

The DnsMessage type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToByteArray | Convert the message into a byte array.
ToString | Convert the message to a string. (Overrides Object..::.ToString()()().)

See Also

DnsMessage Class


ToByteArray Method

[image]

ComponentSpace DNS Class Library
DnsMessage..::.ToByteArray Method
DnsMessage Class See Also Send Feedback
Convert the message into a byte array.

Namespace: ComponentSpace.Dns
Assembly: ComponentSpace.Dns (in ComponentSpace.Dns.dll) Version: 1.8.0.2

Syntax

C#
public virtual byte[] ToByteArray()
Visual Basic (Declaration)
Public Overridable Function ToByteArray As Byte()
Visual C++
public:
virtual array<unsigned char>^ ToByteArray()

Return Value

The byte array containing the message.

See Also

DnsMessage Class


ToString Method

[image]

ComponentSpace DNS Class Library
DnsMessage..::.ToString Method
DnsMessage Class See Also Send Feedback
Convert the message to a string.

Namespace: ComponentSpace.Dns
Assembly: ComponentSpace.Dns (in ComponentSpace.Dns.dll) Version: 1.8.0.2

Syntax

C#
public override string ToString()
Visual Basic (Declaration)
Public Overrides Function ToString As String
Visual C++
public:
virtual String^ ToString() override

Return Value

The message as a string.

See Also

DnsMessage Class


DnsMessage Properties

[image] [image]

ComponentSpace DNS Class Library
DnsMessage Properties
DnsMessage Class See Also Send Feedback

The DnsMessage type exposes the following members.

Properties

Name | Description
AdditionalResourceRecords | Get the list of additional information resource records.
AnswerResourceRecords | Get the list of answer resource records.
AuthoritativeAnswer | Get or sets the flag indicating whether the message contains an authoritative answer (AA).
AuthorityResourceRecords | Get the list of authority resource records.
DnsQuestions | Get the list of questions.
Identifier | Get or sets the message identifier (ID).
OpCode | Get or sets the message op code (Opcode).
RecursionAvailable | Get or sets the flag indicating whether recursion is available (RA).
RecursionDesired | Get or sets the flag indicating whether recursion is desired (RD).
Response | Get or sets the flag indicating whether the message is a request or response (QR).
ResponseCode | Get or sets the response code (RCODE).
Truncation | Get or sets the flag indicating whether the message is truncated (TC).

See Also

DnsMessage Class


AdditionalResourceRecords Property

[image]

ComponentSpace DNS Class Library
DnsMessage..::.AdditionalResourceRecords Property
DnsMessage Class See Also Send Feedback
Get the list of additional information resource records.

Namespace: ComponentSpace.Dns
Assembly: ComponentSpace.Dns (in ComponentSpace.Dns.dll) Version: 1.8.0.2

Syntax

C#
public IList AdditionalResourceRecords { get; }
Visual Basic (Declaration)
Public ReadOnly Property AdditionalResourceRecords As IList
Visual C++
public:
property IList^ AdditionalResourceRecords {
    IList^ get ();
}

Field Value

The list of additional information ResourceRecord objects.

See Also

DnsMessage Class


AnswerResourceRecords Property

[image]

ComponentSpace DNS Class Library
DnsMessage..::.AnswerResourceRecords Property
DnsMessage Class See Also Send Feedback
Get the list of answer resource records.

Namespace: ComponentSpace.Dns
Assembly: ComponentSpace.Dns (in ComponentSpace.Dns.dll) Version: 1.8.0.2

Syntax

C#
public IList AnswerResourceRecords { get; }
Visual Basic (Declaration)
Public ReadOnly Property AnswerResourceRecords As IList
Visual C++
public:
property IList^ AnswerResourceRecords {
    IList^ get ();
}

Field Value

The list of answer ResourceRecord objects.

See Also

DnsMessage Class


AuthoritativeAnswer Property

[image]

ComponentSpace DNS Class Library
DnsMessage..::.AuthoritativeAnswer Property
DnsMessage Class See Also Send Feedback
Get or sets the flag indicating whether the message contains an authoritative answer (AA).

Namespace: ComponentSpace.Dns
Assembly: ComponentSpace.Dns (in ComponentSpace.Dns.dll) Version: 1.8.0.2

Syntax

C#
public bool AuthoritativeAnswer { get; set; }
Visual Basic (Declaration)
Public Property AuthoritativeAnswer As Boolean
Visual C++
public:
property bool AuthoritativeAnswer {
    bool get ();
    void set (bool value);
}

Field Value

The flag indicating whether the message contains an authoritative answer.

See Also

DnsMessage Class


AuthorityResourceRecords Property

[image]

ComponentSpace DNS Class Library
DnsMessage..::.AuthorityResourceRecords Property
DnsMessage Class See Also Send Feedback
Get the list of authority resource records.

Namespace: ComponentSpace.Dns
Assembly: ComponentSpace.Dns (in ComponentSpace.Dns.dll) Version: 1.8.0.2

Syntax

C#
public IList AuthorityResourceRecords { get; }
Visual Basic (Declaration)
Public ReadOnly Property AuthorityResourceRecords As IList
Visual C++
public:
property IList^ AuthorityResourceRecords {
    IList^ get ();
}

Field Value

The list of authority ResourceRecord objects.

See Also

DnsMessage Class


DnsQuestions Property

[image]

ComponentSpace DNS Class Library
DnsMessage..::.DnsQuestions Property
DnsMessage Class See Also Send Feedback
Get the list of questions.

Namespace: ComponentSpace.Dns
Assembly: ComponentSpace.Dns (in ComponentSpace.Dns.dll) Version: 1.8.0.2

Syntax

C#
public IList DnsQuestions { get; }
Visual Basic (Declaration)
Public ReadOnly Property DnsQuestions As IList
Visual C++
public:
property IList^ DnsQuestions {
    IList^ get ();
}

Field Value

The list of DnsQuestion objects.

See Also

DnsMessage Class


Identifier Property

[image]

ComponentSpace DNS Class Library
DnsMessage..::.Identifier Property
DnsMessage Class See Also Send Feedback
Get or sets the message identifier (ID).

Namespace: ComponentSpace.Dns
Assembly: ComponentSpace.Dns (in ComponentSpace.Dns.dll) Version: 1.8.0.2

Syntax

C#
public int Identifier { get; set; }
Visual Basic (Declaration)
Public Property Identifier As Integer
Visual C++
public:
property int Identifier {
    int get ();
    void set (int value);
}

Field Value

The message identifier.

See Also

DnsMessage Class


OpCode Property

[image]

ComponentSpace DNS Class Library
DnsMessage..::.OpCode Property
DnsMessage Class See Also Send Feedback
Get or sets the message op code (Opcode).

Namespace: ComponentSpace.Dns
Assembly: ComponentSpace.Dns (in ComponentSpace.Dns.dll) Version: 1.8.0.2

Syntax

C#
public int OpCode { get; set; }
Visual Basic (Declaration)
Public Property OpCode As Integer
Visual C++
public:
property int OpCode {
    int get ();
    void set (int value);
}

Field Value

The message op code. The value can be one of the defined DnsMessage..::.OpCodes.

See Also

DnsMessage Class


RecursionAvailable Property

[image]

ComponentSpace DNS Class Library
DnsMessage..::.RecursionAvailable Property
DnsMessage Class See Also Send Feedback
Get or sets the flag indicating whether recursion is available (RA).

Namespace: ComponentSpace.Dns
Assembly: ComponentSpace.Dns (in ComponentSpace.Dns.dll) Version: 1.8.0.2

Syntax

C#
public bool RecursionAvailable { get; set; }
Visual Basic (Declaration)
Public Property RecursionAvailable As Boolean
Visual C++
public:
property bool RecursionAvailable {
    bool get ();
    void set (bool value);
}

Field Value

The flag indicating whether recursion is available.

See Also

DnsMessage Class


RecursionDesired Property

[image]

ComponentSpace DNS Class Library
DnsMessage..::.RecursionDesired Property
DnsMessage Class See Also Send Feedback
Get or sets the flag indicating whether recursion is desired (RD).

Namespace: ComponentSpace.Dns
Assembly: ComponentSpace.Dns (in ComponentSpace.Dns.dll) Version: 1.8.0.2

Syntax

C#
public bool RecursionDesired { get; set; }
Visual Basic (Declaration)
Public Property RecursionDesired As Boolean
Visual C++
public:
property bool RecursionDesired {
    bool get ();
    void set (bool value);
}

Field Value

The flag indicating whether recursion is desired.

See Also

DnsMessage Class


Response Property

[image]

ComponentSpace DNS Class Library
DnsMessage..::.Response Property
DnsMessage Class See Also Send Feedback
Get or sets the flag indicating whether the message is a request or response (QR).

Namespace: ComponentSpace.Dns
Assembly: ComponentSpace.Dns (in ComponentSpace.Dns.dll) Version: 1.8.0.2

Syntax

C#
public bool Response { get; set; }
Visual Basic (Declaration)
Public Property Response As Boolean
Visual C++
public:
property bool Response {
    bool get ();
    void set (bool value);
}

Field Value

The flag indicating whether the message is a request or response.

See Also

DnsMessage Class


ResponseCode Property

[image]

ComponentSpace DNS Class Library
DnsMessage..::.ResponseCode Property
DnsMessage Class See Also Send Feedback
Get or sets the response code (RCODE).

Namespace: ComponentSpace.Dns
Assembly: ComponentSpace.Dns (in ComponentSpace.Dns.dll) Version: 1.8.0.2

Syntax

C#
public int ResponseCode { get; set; }
Visual Basic (Declaration)
Public Property ResponseCode As Integer
Visual C++
public:
property int ResponseCode {
    int get ();
    void set (int value);
}

Field Value

The message response code. The value can be one of the defined DnsMessage..::.ResponseCodes.

See Also

DnsMessage Class


Truncation Property

[image]

ComponentSpace DNS Class Library
DnsMessage..::.Truncation Property
DnsMessage Class See Also Send Feedback
Get or sets the flag indicating whether the message is truncated (TC).

Namespace: ComponentSpace.Dns
Assembly: ComponentSpace.Dns (in ComponentSpace.Dns.dll) Version: 1.8.0.2

Syntax

C#
public bool Truncation { get; set; }
Visual Basic (Declaration)
Public Property Truncation As Boolean
Visual C++
public:
property bool Truncation {
    bool get ();
    void set (bool value);
}

Field Value

The flag indicating whether the message is truncated.

See Also

DnsMessage Class


DnsMessage.OpCodes Enumeration

[image]

ComponentSpace DNS Class Library
DnsMessage..::.OpCodes Enumeration
DnsMessage Class See Also Send Feedback
The opcodes identifying the request type.

Namespace: ComponentSpace.Dns
Assembly: ComponentSpace.Dns (in ComponentSpace.Dns.dll) Version: 1.8.0.2

Syntax

C#
public enum OpCodes
Visual Basic (Declaration)
Public Enumeration OpCodes
Visual C++
public enum class OpCodes

Members

Member name | Description
Query | DNS query
InverseQuery | DNS inverse query
Status | DNS status
Unknown | DNS unknown
Notify | DNS notify
Update | DNS update

Remarks

Currently, only DNS queries are supported.

See Also

ComponentSpace.Dns Namespace

Send comments on this topic to support@componentspace.com

Copyright (c) ComponentSpace Pty Ltd 2002-2008. All rights reserved.


DnsMessage.ResponseCodes Enumeration

[image]

ComponentSpace DNS Class Library
DnsMessage..::.ResponseCodes Enumeration
DnsMessage Class See Also Send Feedback
The response codes.

Namespace: ComponentSpace.Dns
Assembly: ComponentSpace.Dns (in ComponentSpace.Dns.dll) Version: 1.8.0.2

Syntax

C#
public enum ResponseCodes
Visual Basic (Declaration)
Public Enumeration ResponseCodes
Visual C++
public enum class ResponseCodes

Members

Member name | Description
NoError | No error
FormatError | Format error
ServerFailure | Server failure
NameError | Name error
NotImplemented | Not implemented
Refused | Refused
DnsNameShouldNotExist | Name should not exist
RecordSetShouldNotExist | Record set should not exist
RecordSetDoesNotExist | Record set does not exist
NotAuthoritativeForZone | Not authoritative for zone
NameNotZone | Name not zone
BadSignature | Bad signature
BadKey | Bad key
BadTimestamp | Bad timestamp

See Also

ComponentSpace.Dns Namespace

Send comments on this topic to support@componentspace.com

Copyright (c) ComponentSpace Pty Ltd 2002-2008. All rights reserved.


DnsName Class

[image]

ComponentSpace DNS Class Library
DnsName Class
Members See Also Send Feedback
A domain name. For example, componentspace.com.

Namespace: ComponentSpace.Dns
Assembly: ComponentSpace.Dns (in ComponentSpace.Dns.dll) Version: 1.8.0.2

Syntax

C#
public class DnsName
Visual Basic (Declaration)
Public Class DnsName
Visual C++
public ref class DnsName

Inheritance Hierarchy

System..::.Object
ComponentSpace.Dns..::.DnsName

See Also

DnsName Members


DnsName Members

[image] [image]

ComponentSpace DNS Class Library
DnsName Members
DnsName Class Constructors Methods Properties See Also Send Feedback

The DnsName type exposes the following members.

Constructors

Name | Description
DnsName | Overloaded.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToByteArray | Convert the domain name into a byte array.
ToString | Convert the domain name to a string. (Overrides Object..::.ToString()()().)

Properties

Name | Description
Name | Get or sets the domain name.

See Also

DnsName Class


DnsName Constructor

[image] [image]

ComponentSpace DNS Class Library
DnsName Constructor
DnsName Class See Also Send Feedback

Overload List

Name | Description
DnsName()()() | The default constructor.
DnsName(String) | Construct from a domain name string.
DnsName(array<Byte>[]()[], Int32%, Int32%) | Construct from a byte array.

See Also

DnsName Class
DnsName Members


DnsName Constructor

[image]

ComponentSpace DNS Class Library
DnsName Constructor
DnsName Class See Also Send Feedback
The default constructor.

Namespace: ComponentSpace.Dns
Assembly: ComponentSpace.Dns (in ComponentSpace.Dns.dll) Version: 1.8.0.2

Syntax

C#
public DnsName()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
DnsName()

See Also

DnsName Class
DnsName Overload


DnsName Constructor (String)

[image]

ComponentSpace DNS Class Library
DnsName Constructor (String)
DnsName Class See Also Send Feedback
Construct from a domain name string.

Namespace: ComponentSpace.Dns
Assembly: ComponentSpace.Dns (in ComponentSpace.Dns.dll) Version: 1.8.0.2

Syntax

C#
public DnsName(
    string name
)
Visual Basic (Declaration)
Public Sub New ( _
    name As String _
)
Visual C++
public:
DnsName(
    String^ name
)

Parameters

name
Type: System..::.String
The domain name

See Also

DnsName Class
DnsName Overload


DnsName Constructor (Byte[], Int32, Int32)

[image]

ComponentSpace DNS Class Library
DnsName Constructor (array<Byte>[]()[], Int32%, Int32%)
DnsName Class See Also Send Feedback
Construct from a byte array.

Namespace: ComponentSpace.Dns
Assembly: ComponentSpace.Dns (in ComponentSpace.Dns.dll) Version: 1.8.0.2

Syntax

C#
public DnsName(
    byte[] bytes,
    ref int index,
    ref int count
)
Visual Basic (Declaration)
Public Sub New ( _
    bytes As Byte(), _
    ByRef index As Integer, _
    ByRef count As Integer _
)
Visual C++
public:
DnsName(
    array<unsigned char>^ bytes,
    int% index,
    int% count
)

Parameters

bytes
Type: array< System..::.Byte >[]()[]
The byte array containing the domain name.
index
Type: System..::.Int32 %
The index into the byte array.
count
Type: System..::.Int32 %
The number of bytes available in the byte array.

See Also

DnsName Class
DnsName Overload


DnsName Methods

[image] [image]

ComponentSpace DNS Class Library
DnsName Methods
DnsName Class See Also Send Feedback

The DnsName type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToByteArray | Convert the domain name into a byte array.
ToString | Convert the domain name to a string. (Overrides Object..::.ToString()()().)

See Also

DnsName Class


ToByteArray Method

[image]

ComponentSpace DNS Class Library
DnsName..::.ToByteArray Method
DnsName Class See Also Send Feedback
Convert the domain name into a byte array.

Namespace: ComponentSpace.Dns
Assembly: ComponentSpace.Dns (in ComponentSpace.Dns.dll) Version: 1.8.0.2

Syntax

C#
public byte[] ToByteArray()
Visual Basic (Declaration)
Public Function ToByteArray As Byte()
Visual C++
public:
array<unsigned char>^ ToByteArray()

Return Value

The byte array containing the domain name.

See Also

DnsName Class


ToString Method

[image]

ComponentSpace DNS Class Library
DnsName..::.ToString Method
DnsName Class See Also Send Feedback
Convert the domain name to a string.

Namespace: ComponentSpace.Dns
Assembly: ComponentSpace.Dns (in ComponentSpace.Dns.dll) Version: 1.8.0.2

Syntax

C#
public override string ToString()
Visual Basic (Declaration)
Public Overrides Function ToString As String
Visual C++
public:
virtual String^ ToString() override

Return Value

The domain name as a string.

See Also

DnsName Class


DnsName Properties

[image] [image]

ComponentSpace DNS Class Library
DnsName Properties
DnsName Class See Also Send Feedback

The DnsName type exposes the following members.

Properties

Name | Description
Name | Get or sets the domain name.

See Also

DnsName Class


Name Property

[image]

ComponentSpace DNS Class Library
DnsName..::.Name Property
DnsName Class See Also Send Feedback
Get or sets the domain name.

Namespace: ComponentSpace.Dns
Assembly: ComponentSpace.Dns (in ComponentSpace.Dns.dll) Version: 1.8.0.2

Syntax

C#
public string Name { get; set; }
Visual Basic (Declaration)
Public Property Name As String
Visual C++
public:
property String^ Name {
    String^ get ();
    void set (String^ value);
}

Field Value

The domain name.

See Also

DnsName Class


DnsQuestion Class

[image]

ComponentSpace DNS Class Library
DnsQuestion Class
Members See Also Send Feedback
A domain question. Questions consist of a domain name, question type and question class.

Namespace: ComponentSpace.Dns
Assembly: ComponentSpace.Dns (in ComponentSpace.Dns.dll) Version: 1.8.0.2

Syntax

C#
public class DnsQuestion
Visual Basic (Declaration)
Public Class DnsQuestion
Visual C++
public ref class DnsQuestion

Inheritance Hierarchy

System..::.Object
ComponentSpace.Dns..::.DnsQuestion

See Also

DnsQuestion Members


DnsQuestion Members

[image] [image]

ComponentSpace DNS Class Library
DnsQuestion Members
DnsQuestion Class Constructors Methods Properties See Also Send Feedback

The DnsQuestion type exposes the following members.

Constructors

Name | Description
DnsQuestion | Overloaded.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToByteArray | Convert the domain question into a byte array.
ToString | Convert the domain question to a string. (Overrides Object..::.ToString()()().)

Properties

Name | Description
DnsName | Get or sets the domain name.
QuestionClass | Get or sets the question class.
QuestionType | Get or sets the question type.

See Also

DnsQuestion Class


DnsQuestion Constructor

[image] [image]

ComponentSpace DNS Class Library
DnsQuestion Constructor
DnsQuestion Class See Also Send Feedback

Overload List

Name | Description
DnsQuestion()()() | Default constructor.
DnsQuestion(array<Byte>[]()[], Int32%, Int32%) | Construct from a byte array.
DnsQuestion(String, Int32, Int32) | Construct using the supplied values.

See Also

DnsQuestion Class
DnsQuestion Members


DnsQuestion Constructor

[image]

ComponentSpace DNS Class Library
DnsQuestion Constructor
DnsQuestion Class See Also Send Feedback
Default constructor.

Namespace: ComponentSpace.Dns
Assembly: ComponentSpace.Dns (in ComponentSpace.Dns.dll) Version: 1.8.0.2

Syntax

C#
public DnsQuestion()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
DnsQuestion()

See Also

DnsQuestion Class
DnsQuestion Overload


DnsQuestion Constructor (Byte[], Int32, Int32)

[image]

ComponentSpace DNS Class Library
DnsQuestion Constructor (array<Byte>[]()[], Int32%, Int32%)
DnsQuestion Class See Also Send Feedback
Construct from a byte array.

Namespace: ComponentSpace.Dns
Assembly: ComponentSpace.Dns (in ComponentSpace.Dns.dll) Version: 1.8.0.2

Syntax

C#
public DnsQuestion(
    byte[] bytes,
    ref int index,
    ref int count
)
Visual Basic (Declaration)
Public Sub New ( _
    bytes As Byte(), _
    ByRef index As Integer, _
    ByRef count As Integer _
)
Visual C++
public:
DnsQuestion(
    array<unsigned char>^ bytes,
    int% index,
    int% count
)

Parameters

bytes
Type: array< System..::.Byte >[]()[]
The byte array containing the domain question.
index
Type: System..::.Int32 %
The index into the byte array.
count
Type: System..::.Int32 %
The number of bytes available in the byte array.

See Also

DnsQuestion Class
DnsQuestion Overload


DnsQuestion Constructor (String, Int32, Int32)

[image]

ComponentSpace DNS Class Library
DnsQuestion Constructor (String, Int32, Int32)
DnsQuestion Class See Also Send Feedback
Construct using the supplied values.

Namespace: ComponentSpace.Dns
Assembly: ComponentSpace.Dns (in ComponentSpace.Dns.dll) Version: 1.8.0.2

Syntax

C#
public DnsQuestion(
    string domainName,
    int questionType,
    int questionClass
)
Visual Basic (Declaration)
Public Sub New ( _
    domainName As String, _
    questionType As Integer, _
    questionClass As Integer _
)
Visual C++
public:
DnsQuestion(
    String^ domainName,
    int questionType,
    int questionClass
)

Parameters

domainName
Type: System..::.String
The domain name.
questionType
Type: System..::.Int32
The question type. See DnsQuestion..::.QTypes.
questionClass
Type: System..::.Int32
The question class. See DnsQuestion..::.QClasses.

See Also

DnsQuestion Class
DnsQuestion Overload


DnsQuestion Methods

[image] [image]

ComponentSpace DNS Class Library
DnsQuestion Methods
DnsQuestion Class See Also Send Feedback

The DnsQuestion type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToByteArray | Convert the domain question into a byte array.
ToString | Convert the domain question to a string. (Overrides Object..::.ToString()()().)

See Also

DnsQuestion Class


ToByteArray Method

[image]

ComponentSpace DNS Class Library
DnsQuestion..::.ToByteArray Method
DnsQuestion Class See Also Send Feedback
Convert the domain question into a byte array.

Namespace: ComponentSpace.Dns
Assembly: ComponentSpace.Dns (in ComponentSpace.Dns.dll) Version: 1.8.0.2

Syntax

C#
public byte[] ToByteArray()
Visual Basic (Declaration)
Public Function ToByteArray As Byte()
Visual C++
public:
array<unsigned char>^ ToByteArray()

Return Value

The byte array containing the domain question.

See Also

DnsQuestion Class


ToString Method

[image]

ComponentSpace DNS Class Library
DnsQuestion..::.ToString Method
DnsQuestion Class See Also Send Feedback
Convert the domain question to a string.

Namespace: ComponentSpace.Dns
Assembly: ComponentSpace.Dns (in ComponentSpace.Dns.dll) Version: 1.8.0.2

Syntax

C#
public override string ToString()
Visual Basic (Declaration)
Public Overrides Function ToString As String
Visual C++
public:
virtual String^ ToString() override

Return Value

The domain question as a string.

See Also

DnsQuestion Class


DnsQuestion Properties

[image] [image]

ComponentSpace DNS Class Library
DnsQuestion Properties
DnsQuestion Class See Also Send Feedback

The DnsQuestion type exposes the following members.

Properties

Name | Description
DnsName | Get or sets the domain name.
QuestionClass | Get or sets the question class.
QuestionType | Get or sets the question type.

See Also

DnsQuestion Class


DnsName Property

[image]

ComponentSpace DNS Class Library
DnsQuestion..::.DnsName Property
DnsQuestion Class See Also Send Feedback
Get or sets the domain name.

Namespace: ComponentSpace.Dns
Assembly: ComponentSpace.Dns (in ComponentSpace.Dns.dll) Version: 1.8.0.2

Syntax

C#
public string DnsName { get; set; }
Visual Basic (Declaration)
Public Property DnsName As String
Visual C++
public:
property String^ DnsName {
    String^ get ();
    void set (String^ value);
}

Field Value

The domain name.

See Also

DnsQuestion Class


QuestionClass Property

[image]

ComponentSpace DNS Class Library
DnsQuestion..::.QuestionClass Property
DnsQuestion Class See Also Send Feedback
Get or sets the question class.

Namespace: ComponentSpace.Dns
Assembly: ComponentSpace.Dns (in ComponentSpace.Dns.dll) Version: 1.8.0.2

Syntax

C#
public int QuestionClass { get; set; }
Visual Basic (Declaration)
Public Property QuestionClass As Integer
Visual C++
public:
property int QuestionClass {
    int get ();
    void set (int value);
}

Field Value

The question class. See DnsQuestion..::.QClasses.

See Also

DnsQuestion Class


QuestionType Property

[image]

ComponentSpace DNS Class Library
DnsQuestion..::.QuestionType Property
DnsQuestion Class See Also Send Feedback
Get or sets the question type.

Namespace: ComponentSpace.Dns
Assembly: ComponentSpace.Dns (in ComponentSpace.Dns.dll) Version: 1.8.0.2

Syntax

C#
public int QuestionType { get; set; }
Visual Basic (Declaration)
Public Property QuestionType As Integer
Visual C++
public:
property int QuestionType {
    int get ();
    void set (int value);
}

Field Value

The question type. See DnsQuestion..::.QTypes.

See Also

DnsQuestion Class


DnsQuestion.QClasses Enumeration

[image]

ComponentSpace DNS Class Library
DnsQuestion..::.QClasses Enumeration
DnsQuestion Class See Also Send Feedback
The question classes (QCLASS).

Namespace: ComponentSpace.Dns
Assembly: ComponentSpace.Dns (in ComponentSpace.Dns.dll) Version: 1.8.0.2

Syntax

C#
public enum QClasses
Visual Basic (Declaration)
Public Enumeration QClasses
Visual C++
public enum class QClasses

Members

Member name | Description
IN | Internet.
CS | CSNET (obselete).
CH | CHAOS (obselete).
HS | Hesiod.
ANY | Any.

See Also

ComponentSpace.Dns Namespace

Send comments on this topic to support@componentspace.com

Copyright (c) ComponentSpace Pty Ltd 2002-2008. All rights reserved.


DnsQuestion.QTypes Enumeration

[image]

ComponentSpace DNS Class Library
DnsQuestion..::.QTypes Enumeration
DnsQuestion Class See Also Send Feedback
The question types (QTYPE).

Namespace: ComponentSpace.Dns
Assembly: ComponentSpace.Dns (in ComponentSpace.Dns.dll) Version: 1.8.0.2

Syntax

C#
public enum QTypes
Visual Basic (Declaration)
Public Enumeration QTypes
Visual C++
public enum class QTypes

Members

Member name | Description
A | Host Address.
NS | Authoritative name server.
MD | Mail destination (obselete).
MF | Mail forwarder (obselete).
CNAME | Canonical name for an alias.
SOA | Start of zone authority.
MB | Mailbox domain name.
MG | Mail group member.
MR | Mail rename domain name.
NULL | Null.
WKS | Well know service description.
PTR | Domain name pointer.
HINFO | Host information.
MINFO | Mailbox or mail list information.
MX | Mail exchange.
TXT | Text strings.
RP | RP.
AFSDB | AFSDB.
X25 | X25.
ISDN | ISDN.
RT | RT.
NSAP | NSAP.
NSAPPTR | NSAPPTR.
SIG | SIG.
KEY | KEY.
PX | PX.
GPOS | GPOS.
AAAA | AAAA.
LOC | LOC.
NXT | NXT.
SRV | SRV.
ATMA | ATMA.
TKEY | TKEY.
TSIG | TSIG.
IXFR | IXFR.
AXFR | Transfer entire zone.
MAILB | Mailbox related records.
MAILA | Mail agent records.
ALL | All records.

Remarks

Refer to RFC 1034, 1035, 1183, 1348, 2065, 1664, 1712, 1886, 1876, 2065, 2052, 1035, 1995.

See Also

ComponentSpace.Dns Namespace

Send comments on this topic to support@componentspace.com

Copyright (c) ComponentSpace Pty Ltd 2002-2008. All rights reserved.


DnsString Class

[image]

ComponentSpace DNS Class Library
DnsString Class
Members See Also Send Feedback
A domain string. DNS strings are counted ASCII strings.

Namespace: ComponentSpace.Dns
Assembly: ComponentSpace.Dns (in ComponentSpace.Dns.dll) Version: 1.8.0.2

Syntax

C#
public class DnsString
Visual Basic (Declaration)
Public Class DnsString
Visual C++
public ref class DnsString

Inheritance Hierarchy

System..::.Object
ComponentSpace.Dns..::.DnsString

See Also

DnsString Members


DnsString Members

[image] [image]

ComponentSpace DNS Class Library
DnsString Members
DnsString Class Constructors Methods Properties See Also Send Feedback

The DnsString type exposes the following members.

Constructors

Name | Description
DnsString | Overloaded.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToByteArray | Convert the domain string into a byte array.
ToString | Convert the domain string to a string. (Overrides Object..::.ToString()()().)

Properties

Name | Description
Text | Get or sets the domain string.

See Also

DnsString Class


DnsString Constructor

[image] [image]

ComponentSpace DNS Class Library
DnsString Constructor
DnsString Class See Also Send Feedback

Overload List

Name | Description
DnsString()()() | Default constructor.
DnsString(String) | Construct from a string.
DnsString(array<Byte>[]()[], Int32%, Int32%) | Construct from a byte array.

See Also

DnsString Class
DnsString Members


DnsString Constructor

[image]

ComponentSpace DNS Class Library
DnsString Constructor
DnsString Class See Also Send Feedback
Default constructor.

Namespace: ComponentSpace.Dns
Assembly: ComponentSpace.Dns (in ComponentSpace.Dns.dll) Version: 1.8.0.2

Syntax

C#
public DnsString()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
DnsString()

See Also

DnsString Class
DnsString Overload


DnsString Constructor (String)

[image]

ComponentSpace DNS Class Library
DnsString Constructor (String)
DnsString Class See Also Send Feedback
Construct from a string.

Namespace: ComponentSpace.Dns
Assembly: ComponentSpace.Dns (in ComponentSpace.Dns.dll) Version: 1.8.0.2

Syntax

C#
public DnsString(
    string text
)
Visual Basic (Declaration)
Public Sub New ( _
    text As String _
)
Visual C++
public:
DnsString(
    String^ text
)

Parameters

text
Type: System..::.String
The text.

See Also

DnsString Class
DnsString Overload


DnsString Constructor (Byte[], Int32, Int32)

[image]

ComponentSpace DNS Class Library
DnsString Constructor (array<Byte>[]()[], Int32%, Int32%)
DnsString Class See Also Send Feedback
Construct from a byte array.

Namespace: ComponentSpace.Dns
Assembly: ComponentSpace.Dns (in ComponentSpace.Dns.dll) Version: 1.8.0.2

Syntax

C#
public DnsString(
    byte[] bytes,
    ref int index,
    ref int count
)
Visual Basic (Declaration)
Public Sub New ( _
    bytes As Byte(), _
    ByRef index As Integer, _
    ByRef count As Integer _
)
Visual C++
public:
DnsString(
    array<unsigned char>^ bytes,
    int% index,
    int% count
)

Parameters

bytes
Type: array< System..::.Byte >[]()[]
The byte array containing the domain string.
index
Type: System..::.Int32 %
The index into the byte array.
count
Type: System..::.Int32 %
The number of bytes available in the byte array.

See Also

DnsString Class
DnsString Overload


DnsString Methods

[image] [image]

ComponentSpace DNS Class Library
DnsString Methods
DnsString Class See Also Send Feedback

The DnsString type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToByteArray | Convert the domain string into a byte array.
ToString | Convert the domain string to a string. (Overrides Object..::.ToString()()().)

See Also

DnsString Class


ToByteArray Method

[image]

ComponentSpace DNS Class Library
DnsString..::.ToByteArray Method
DnsString Class See Also Send Feedback
Convert the domain string into a byte array.

Namespace: ComponentSpace.Dns
Assembly: ComponentSpace.Dns (in ComponentSpace.Dns.dll) Version: 1.8.0.2

Syntax

C#
public byte[] ToByteArray()
Visual Basic (Declaration)
Public Function ToByteArray As Byte()
Visual C++
public:
array<unsigned char>^ ToByteArray()

Return Value

The byte array containing the domain string.

See Also

DnsString Class


ToString Method

[image]

ComponentSpace DNS Class Library
DnsString..::.ToString Method
DnsString Class See Also Send Feedback
Convert the domain string to a string.

Namespace: ComponentSpace.Dns
Assembly: ComponentSpace.Dns (in ComponentSpace.Dns.dll) Version: 1.8.0.2

Syntax

C#
public override string ToString()
Visual Basic (Declaration)
Public Overrides Function ToString As String
Visual C++
public:
virtual String^ ToString() override

Return Value

The domain string as a string.

See Also

DnsString Class


DnsString Properties

[image] [image]

ComponentSpace DNS Class Library
DnsString Properties
DnsString Class See Also Send Feedback

The DnsString type exposes the following members.

Properties

Name | Description
Text | Get or sets the domain string.

See Also

DnsString Class


Text Property

[image]

ComponentSpace DNS Class Library
DnsString..::.Text Property
DnsString Class See Also Send Feedback
Get or sets the domain string.

Namespace: ComponentSpace.Dns
Assembly: ComponentSpace.Dns (in ComponentSpace.Dns.dll) Version: 1.8.0.2

Syntax

C#
public string Text { get; set; }
Visual Basic (Declaration)
Public Property Text As String
Visual C++
public:
property String^ Text {
    String^ get ();
    void set (String^ value);
}

Field Value

The domain string.

See Also

DnsString Class


HINFORecord Class

[image]

ComponentSpace DNS Class Library
HINFORecord Class
Members See Also Send Feedback
A host information resource record.

Namespace: ComponentSpace.Dns
Assembly: ComponentSpace.Dns (in ComponentSpace.Dns.dll) Version: 1.8.0.2

Syntax

C#
public class HINFORecord : ResourceRecord
Visual Basic (Declaration)
Public Class HINFORecord _
    Inherits ResourceRecord
Visual C++
public ref class HINFORecord : public ResourceRecord

Inheritance Hierarchy

System..::.Object
ComponentSpace.Dns..::.ResourceRecord
ComponentSpace.Dns..::.HINFORecord

See Also

HINFORecord Members


HINFORecord Members

[image] [image]

ComponentSpace DNS Class Library
HINFORecord Members
HINFORecord Class Constructors Methods Properties See Also Send Feedback

The HINFORecord type exposes the following members.

Constructors

Name | Description
HINFORecord | Overloaded.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToByteArray | Convert the resource record into a byte array. (Overrides ResourceRecord..::.ToByteArray()()().)
ToString | Convert the resource record to a string. (Overrides ResourceRecord..::.ToString()()().)

Properties

Name | Description
CpuType | Get or sets the CPU type (CPU).
DataLength | Get or sets the number of data bytes (RDLENGTH). (Inherited from ResourceRecord.)
DnsName | Get or sets the domain name (NAME). (Inherited from ResourceRecord.)
OsType | Get or sets the operating system type (OS).
ResourceClass | Get or sets the resource class (CLASS). (Inherited from ResourceRecord.)
ResourceType | Get or sets the resource type (TYPE). (Inherited from ResourceRecord.)
TimeInterval | Get or sets the cache time interval (TTL). (Inherited from ResourceRecord.)

See Also

HINFORecord Class


HINFORecord Constructor

[image] [image]

ComponentSpace DNS Class Library
HINFORecord Constructor
HINFORecord Class See Also Send Feedback

Overload List

Name | Description
HINFORecord()()() | Default constructor.
HINFORecord(array<Byte>[]()[], Int32%, Int32%) | Construct from a byte array.

See Also

HINFORecord Class
HINFORecord Members


HINFORecord Constructor

[image]

ComponentSpace DNS Class Library
HINFORecord Constructor
HINFORecord Class See Also Send Feedback
Default constructor.

Namespace: ComponentSpace.Dns
Assembly: ComponentSpace.Dns (in ComponentSpace.Dns.dll) Version: 1.8.0.2

Syntax

C#
public HINFORecord()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
HINFORecord()

See Also

HINFORecord Class
HINFORecord Overload


HINFORecord Constructor (Byte[], Int32, Int32)

[image]

ComponentSpace DNS Class Library
HINFORecord Constructor (array<Byte>[]()[], Int32%, Int32%)
HINFORecord Class See Also Send Feedback
Construct from a byte array.

Namespace: ComponentSpace.Dns
Assembly: ComponentSpace.Dns (in ComponentSpace.Dns.dll) Version: 1.8.0.2

Syntax

C#
public HINFORecord(
    byte[] bytes,
    ref int index,
    ref int count
)
Visual Basic (Declaration)
Public Sub New ( _
    bytes As Byte(), _
    ByRef index As Integer, _
    ByRef count As Integer _
)
Visual C++
public:
HINFORecord(
    array<unsigned char>^ bytes,
    int% index,
    int% count
)

Parameters

bytes
Type: array< System..::.Byte >[]()[]
The byte array containing the resource record.
index
Type: System..::.Int32 %
The index into the byte array.
count
Type: System..::.Int32 %
The number of bytes available in the byte array.

See Also

HINFORecord Class
HINFORecord Overload


HINFORecord Methods

[image] [image]

ComponentSpace DNS Class Library
HINFORecord Methods
HINFORecord Class See Also Send Feedback

The HINFORecord type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToByteArray | Convert the resource record into a byte array. (Overrides ResourceRecord..::.ToByteArray()()().)
ToString | Convert the resource record to a string. (Overrides ResourceRecord..::.ToString()()().)

See Also

HINFORecord Class


ToByteArray Method

[image]

ComponentSpace DNS Class Library
HINFORecord..::.ToByteArray Method
HINFORecord Class See Also Send Feedback
Convert the resource record into a byte array.

Namespace: ComponentSpace.Dns
Assembly: ComponentSpace.Dns (in ComponentSpace.Dns.dll) Version: 1.8.0.2

Syntax

C#
public override byte[] ToByteArray()
Visual Basic (Declaration)
Public Overrides Function ToByteArray As Byte()
Visual C++
public:
virtual array<unsigned char>^ ToByteArray() override

Return Value

The byte array containing the resource record.

See Also

HINFORecord Class


ToString Method

[image]

ComponentSpace DNS Class Library
HINFORecord..::.ToString Method
HINFORecord Class See Also Send Feedback
Convert the resource record to a string.

Namespace: ComponentSpace.Dns
Assembly: ComponentSpace.Dns (in ComponentSpace.Dns.dll) Version: 1.8.0.2

Syntax

C#
public override string ToString()
Visual Basic (Declaration)
Public Overrides Function ToString As String
Visual C++
public:
virtual String^ ToString() override

Return Value

The resource record as a string.

See Also

HINFORecord Class


HINFORecord Properties

[image] [image]

ComponentSpace DNS Class Library
HINFORecord Properties
HINFORecord Class See Also Send Feedback

The HINFORecord type exposes the following members.

Properties

Name | Description
CpuType | Get or sets the CPU type (CPU).
DataLength | Get or sets the number of data bytes (RDLENGTH). (Inherited from ResourceRecord.)
DnsName | Get or sets the domain name (NAME). (Inherited from ResourceRecord.)
OsType | Get or sets the operating system type (OS).
ResourceClass | Get or sets the resource class (CLASS). (Inherited from ResourceRecord.)
ResourceType | Get or sets the resource type (TYPE). (Inherited from ResourceRecord.)
TimeInterval | Get or sets the cache time interval (TTL). (Inherited from ResourceRecord.)

See Also

HINFORecord Class


CpuType Property

[image]

ComponentSpace DNS Class Library
HINFORecord..::.CpuType Property
HINFORecord Class See Also Send Feedback
Get or sets the CPU type (CPU).

Namespace: ComponentSpace.Dns
Assembly: ComponentSpace.Dns (in ComponentSpace.Dns.dll) Version: 1.8.0.2

Syntax

C#
public DnsString CpuType { get; set; }
Visual Basic (Declaration)
Public Property CpuType As DnsString
Visual C++
public:
property DnsString^ CpuType {
    DnsString^ get ();
    void set (DnsString^ value);
}

Field Value

The CPU type.

See Also

HINFORecord Class


OsType Property

[image]

ComponentSpace DNS Class Library
HINFORecord..::.OsType Property
HINFORecord Class See Also Send Feedback
Get or sets the operating system type (OS).

Namespace: ComponentSpace.Dns
Assembly: ComponentSpace.Dns (in ComponentSpace.Dns.dll) Version: 1.8.0.2

Syntax

C#
public DnsString OsType { get; set; }
Visual Basic (Declaration)
Public Property OsType As DnsString
Visual C++
public:
property DnsString^ OsType {
    DnsString^ get ();
    void set (DnsString^ value);
}

Field Value

The operating system type.

See Also

HINFORecord Class


LookupCompletedEventArgs Class

[image]

ComponentSpace DNS Class Library
LookupCompletedEventArgs Class
Members See Also Send Feedback
Provides data for the LookupCompleted event.

Namespace: ComponentSpace.Dns
Assembly: ComponentSpace.Dns (in ComponentSpace.Dns.dll) Version: 1.8.0.2

Syntax

C#
public class LookupCompletedEventArgs : EventArgs
Visual Basic (Declaration)
Public Class LookupCompletedEventArgs _
    Inherits EventArgs
Visual C++
public ref class LookupCompletedEventArgs : public EventArgs

Remarks

The LookupCompleted event is raised by the DnsClient. It contains all the information needed to complete the asynchronous lookup operation.

Inheritance Hierarchy

System..::.Object
System..::.EventArgs
ComponentSpace.Dns..::.LookupCompletedEventArgs

See Also

LookupCompletedEventArgs Members


LookupCompletedEventArgs Members

[image] [image]

ComponentSpace DNS Class Library
LookupCompletedEventArgs Members
LookupCompletedEventArgs Class Methods Properties See Also Send Feedback

The LookupCompletedEventArgs type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
AsyncResult | Gets the result of the asynchronous lookup operation.

See Also

LookupCompletedEventArgs Class


LookupCompletedEventArgs Methods

[image] [image]

ComponentSpace DNS Class Library
LookupCompletedEventArgs Methods
LookupCompletedEventArgs Class See Also Send Feedback

The LookupCompletedEventArgs type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

LookupCompletedEventArgs Class


LookupCompletedEventArgs Properties

[image] [image]

ComponentSpace DNS Class Library
LookupCompletedEventArgs Properties
LookupCompletedEventArgs Class See Also Send Feedback

The LookupCompletedEventArgs type exposes the following members.

Properties

Name | Description
AsyncResult | Gets the result of the asynchronous lookup operation.

See Also

LookupCompletedEventArgs Class


AsyncResult Property

[image]

ComponentSpace DNS Class Library
LookupCompletedEventArgs..::.AsyncResult Property
LookupCompletedEventArgs Class See Also Send Feedback
Gets the result of the asynchronous lookup operation.

Namespace: ComponentSpace.Dns
Assembly: ComponentSpace.Dns (in ComponentSpace.Dns.dll) Version: 1.8.0.2

Syntax

C#
public IAsyncResult AsyncResult { get; }
Visual Basic (Declaration)
Public ReadOnly Property AsyncResult As IAsyncResult
Visual C++
public:
property IAsyncResult^ AsyncResult {
    IAsyncResult^ get ();
}

Field Value

An IAsyncResult that contains the data associated with the lookup operation.

Remarks

AsyncResult identifies ongoing or completed asynchronous operations. The property contains data that helps determine which of several potential asynchronous operations to complete, and when passed to the event handler, enables EndLookup to access the response message associated with the completed operation.

See Also

LookupCompletedEventArgs Class


LookupCompletedEventHandler Delegate

[image]

ComponentSpace DNS Class Library
LookupCompletedEventHandler Delegate
See Also Send Feedback
Represents the method that will handle the LookupCompleted event.

Namespace: ComponentSpace.Dns
Assembly: ComponentSpace.Dns (in ComponentSpace.Dns.dll) Version: 1.8.0.2

Syntax

C#
public delegate void LookupCompletedEventHandler(
    Object sender,
    LookupCompletedEventArgs e
)
Visual Basic (Declaration)
Public Delegate Sub LookupCompletedEventHandler ( _
    sender As Object, _
    e As LookupCompletedEventArgs _
)
Visual C++
public delegate void LookupCompletedEventHandler(
    Object^ sender,
    LookupCompletedEventArgs^ e
)

Parameters

sender
Type: System..::.Object
The source of the event.
e
Type: ComponentSpace.Dns..::.LookupCompletedEventArgs
A LookupCompletedEventArgs that contains the event data.

Remarks

When you create a LookupCompletedEventHandler delegate, you identify the method that will handle the event. To associate the event with your event handler, add an instance of the delegate to the event. The event handler is called whenever the event occurs, unless you remove the delegate.

See Also

ComponentSpace.Dns Namespace

Send comments on this topic to support@componentspace.com

Copyright (c) ComponentSpace Pty Ltd 2002-2008. All rights reserved.


MBRecord Class

[image]

ComponentSpace DNS Class Library
MBRecord Class
Members See Also Send Feedback
A mailbox domain name resource record.

Namespace: ComponentSpace.Dns
Assembly: ComponentSpace.Dns (in ComponentSpace.Dns.dll) Version: 1.8.0.2

Syntax

C#
public class MBRecord : ResourceRecord
Visual Basic (Declaration)
Public Class MBRecord _
    Inherits ResourceRecord
Visual C++
public ref class MBRecord : public ResourceRecord

Inheritance Hierarchy

System..::.Object
ComponentSpace.Dns..::.ResourceRecord
ComponentSpace.Dns..::.MBRecord

See Also

MBRecord Members


MBRecord Members

[image] [image]

ComponentSpace DNS Class Library
MBRecord Members
MBRecord Class Constructors Methods Properties See Also Send Feedback

The MBRecord type exposes the following members.

Constructors

Name | Description
MBRecord | Overloaded.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToByteArray | Convert the resource record into a byte array. (Overrides ResourceRecord..::.ToByteArray()()().)
ToString | Convert the resource record to a string. (Overrides ResourceRecord..::.ToString()()().)

Properties

Name | Description
DataLength | Get or sets the number of data bytes (RDLENGTH). (Inherited from ResourceRecord.)
DnsName | Get or sets the domain name (NAME). (Inherited from ResourceRecord.)
MailboxName | Get or sets the mailbox domain name (MADNAME).
ResourceClass | Get or sets the resource class (CLASS). (Inherited from ResourceRecord.)
ResourceType | Get or sets the resource type (TYPE). (Inherited from ResourceRecord.)
TimeInterval | Get or sets the cache time interval (TTL). (Inherited from ResourceRecord.)

See Also

MBRecord Class


MBRecord Constructor

[image] [image]

ComponentSpace DNS Class Library
MBRecord Constructor
MBRecord Class See Also Send Feedback

Overload List

Name | Description
MBRecord()()() | Default constructor.
MBRecord(array<Byte>[]()[], Int32%, Int32%) | Construct from a byte array.

See Also

MBRecord Class
MBRecord Members


MBRecord Constructor

[image]

ComponentSpace DNS Class Library
MBRecord Constructor
MBRecord Class See Also Send Feedback
Default constructor.

Namespace: ComponentSpace.Dns
Assembly: ComponentSpace.Dns (in ComponentSpace.Dns.dll) Version: 1.8.0.2

Syntax

C#
public MBRecord()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
MBRecord()

See Also

MBRecord Class
MBRecord Overload


MBRecord Constructor (Byte[], Int32, Int32)

[image]

ComponentSpace DNS Class Library
MBRecord Constructor (array<Byte>[]()[], Int32%, Int32%)
MBRecord Class See Also Send Feedback
Construct from a byte array.

Namespace: ComponentSpace.Dns
Assembly: ComponentSpace.Dns (in ComponentSpace.Dns.dll) Version: 1.8.0.2

Syntax

C#
public MBRecord(
    byte[] bytes,
    ref int index,
    ref int count
)
Visual Basic (Declaration)
Public Sub New ( _
    bytes As Byte(), _
    ByRef index As Integer, _
    ByRef count As Integer _
)
Visual C++
public:
MBRecord(
    array<unsigned char>^ bytes,
    int% index,
    int% count
)

Parameters

bytes
Type: array< System..::.Byte >[]()[]
The byte array containing the resource record.
index
Type: System..::.Int32 %
The index into the byte array.
count
Type: System..::.Int32 %
The number of bytes available in the byte array.

See Also

MBRecord Class
MBRecord Overload


MBRecord Methods

[image] [image]

ComponentSpace DNS Class Library
MBRecord Methods
MBRecord Class See Also Send Feedback

The MBRecord type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToByteArray | Convert the resource record into a byte array. (Overrides ResourceRecord..::.ToByteArray()()().)
ToString | Convert the resource record to a string. (Overrides ResourceRecord..::.ToString()()().)

See Also

MBRecord Class


ToByteArray Method

[image]

ComponentSpace DNS Class Library
MBRecord..::.ToByteArray Method
MBRecord Class See Also Send Feedback
Convert the resource record into a byte array.

Namespace: ComponentSpace.Dns
Assembly: ComponentSpace.Dns (in ComponentSpace.Dns.dll) Version: 1.8.0.2

Syntax

C#
public override byte[] ToByteArray()
Visual Basic (Declaration)
Public Overrides Function ToByteArray As Byte()
Visual C++
public:
virtual array<unsigned char>^ ToByteArray() override

Return Value

The byte array containing the resource record.

See Also

MBRecord Class


ToString Method

[image]

ComponentSpace DNS Class Library
MBRecord..::.ToString Method
MBRecord Class See Also Send Feedback
Convert the resource record to a string.

Namespace: ComponentSpace.Dns
Assembly: ComponentSpace.Dns (in ComponentSpace.Dns.dll) Version: 1.8.0.2

Syntax

C#
public override string ToString()
Visual Basic (Declaration)
Public Overrides Function ToString As String
Visual C++
public:
virtual String^ ToString() override

Return Value

The resource record as a string.

See Also

MBRecord Class


MBRecord Properties

[image] [image]

ComponentSpace DNS Class Library
MBRecord Properties
MBRecord Class See Also Send Feedback

The MBRecord type exposes the following members.

Properties

Name | Description
DataLength | Get or sets the number of data bytes (RDLENGTH). (Inherited from ResourceRecord.)
DnsName | Get or sets the domain name (NAME). (Inherited from ResourceRecord.)
MailboxName | Get or sets the mailbox domain name (MADNAME).
ResourceClass | Get or sets the resource class (CLASS). (Inherited from ResourceRecord.)
ResourceType | Get or sets the resource type (TYPE). (Inherited from ResourceRecord.)
TimeInterval | Get or sets the cache time interval (TTL). (Inherited from ResourceRecord.)

See Also

MBRecord Class


MailboxName Property

[image]

ComponentSpace DNS Class Library
MBRecord..::.MailboxName Property
MBRecord Class See Also Send Feedback
Get or sets the mailbox domain name (MADNAME).

Namespace: ComponentSpace.Dns
Assembly: ComponentSpace.Dns (in ComponentSpace.Dns.dll) Version: 1.8.0.2

Syntax

C#
public DnsName MailboxName { get; set; }
Visual Basic (Declaration)
Public Property MailboxName As DnsName
Visual C++
public:
property DnsName^ MailboxName {
    DnsName^ get ();
    void set (DnsName^ value);
}

Field Value

The mailbox domain name.

See Also

MBRecord Class


MDRecord Class

[image]

ComponentSpace DNS Class Library
MDRecord Class
Members See Also Send Feedback
A mail destination resource record.

Namespace: ComponentSpace.Dns
Assembly: ComponentSpace.Dns (in ComponentSpace.Dns.dll) Version: 1.8.0.2

Syntax

C#
public class MDRecord : ResourceRecord
Visual Basic (Declaration)
Public Class MDRecord _
    Inherits ResourceRecord
Visual C++
public ref class MDRecord : public ResourceRecord

Inheritance Hierarchy

System..::.Object
ComponentSpace.Dns..::.ResourceRecord
ComponentSpace.Dns..::.MDRecord

See Also

MDRecord Members


MDRecord Members

[image] [image]

ComponentSpace DNS Class Library
MDRecord Members
MDRecord Class Constructors Methods Properties See Also Send Feedback

The MDRecord type exposes the following members.

Constructors

Name | Description
MDRecord | Overloaded.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToByteArray | Convert the resource record into a byte array. (Overrides ResourceRecord..::.ToByteArray()()().)
ToString | Convert the resource record to a string. (Overrides ResourceRecord..::.ToString()()().)

Properties

Name | Description
DataLength | Get or sets the number of data bytes (RDLENGTH). (Inherited from ResourceRecord.)
DnsName | Get or sets the domain name (NAME). (Inherited from ResourceRecord.)
MailAgentName | Get or sets the mail agent name (MADNAME).
ResourceClass | Get or sets the resource class (CLASS). (Inherited from ResourceRecord.)
ResourceType | Get or sets the resource type (TYPE). (Inherited from ResourceRecord.)
TimeInterval | Get or sets the cache time interval (TTL). (Inherited from ResourceRecord.)

See Also

MDRecord Class


MDRecord Constructor

[image] [image]

ComponentSpace DNS Class Library
MDRecord Constructor
MDRecord Class See Also Send Feedback

Overload List

Name | Description
MDRecord()()() | Default constructor.
MDRecord(array<Byte>[]()[], Int32%, Int32%) | Construct from a byte array.

See Also

MDRecord Class
MDRecord Members


MDRecord Constructor

[image]

ComponentSpace DNS Class Library
MDRecord Constructor
MDRecord Class See Also Send Feedback
Default constructor.

Namespace: ComponentSpace.Dns
Assembly: ComponentSpace.Dns (in ComponentSpace.Dns.dll) Version: 1.8.0.2

Syntax

C#
public MDRecord()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
MDRecord()

See Also

MDRecord Class
MDRecord Overload


MDRecord Constructor (Byte[], Int32, Int32)

[image]

ComponentSpace DNS Class Library
MDRecord Constructor (array<Byte>[]()[], Int32%, Int32%)
MDRecord Class See Also Send Feedback
Construct from a byte array.

Namespace: ComponentSpace.Dns
Assembly: ComponentSpace.Dns (in ComponentSpace.Dns.dll) Version: 1.8.0.2

Syntax

C#
public MDRecord(
    byte[] bytes,
    ref int index,
    ref int count
)
Visual Basic (Declaration)
Public Sub New ( _
    bytes As Byte(), _
    ByRef index As Integer, _
    ByRef count As Integer _
)
Visual C++
public:
MDRecord(
    array<unsigned char>^ bytes,
    int% index,
    int% count
)

Parameters

bytes
Type: array< System..::.Byte >[]()[]
The byte array containing the resource record.
index
Type: System..::.Int32 %
The index into the byte array.
count
Type: System..::.Int32 %
The number of bytes available in the byte array.

See Also

MDRecord Class
MDRecord Overload


MDRecord Methods

[image] [image]

ComponentSpace DNS Class Library
MDRecord Methods
MDRecord Class See Also Send Feedback

The MDRecord type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToByteArray | Convert the resource record into a byte array. (Overrides ResourceRecord..::.ToByteArray()()().)
ToString | Convert the resource record to a string. (Overrides ResourceRecord..::.ToString()()().)

See Also

MDRecord Class


ToByteArray Method

[image]

ComponentSpace DNS Class Library
MDRecord..::.ToByteArray Method
MDRecord Class See Also Send Feedback
Convert the resource record into a byte array.

Namespace: ComponentSpace.Dns
Assembly: ComponentSpace.Dns (in ComponentSpace.Dns.dll) Version: 1.8.0.2

Syntax

C#
public override byte[] ToByteArray()
Visual Basic (Declaration)
Public Overrides Function ToByteArray As Byte()
Visual C++
public:
virtual array<unsigned char>^ ToByteArray() override

Return Value

The byte array containing the resource record.

See Also

MDRecord Class


ToString Method

[image]

ComponentSpace DNS Class Library
MDRecord..::.ToString Method
MDRecord Class See Also Send Feedback
Convert the resource record to a string.

Namespace: ComponentSpace.Dns
Assembly: ComponentSpace.Dns (in ComponentSpace.Dns.dll) Version: 1.8.0.2

Syntax

C#
public override string ToString()
Visual Basic (Declaration)
Public Overrides Function ToString As String
Visual C++
public:
virtual String^ ToString() override

Return Value

The resource record as a string.

See Also

MDRecord Class


MDRecord Properties

[image] [image]

ComponentSpace DNS Class Library
MDRecord Properties
MDRecord Class See Also Send Feedback

The MDRecord type exposes the following members.

Properties

Name | Description
DataLength | Get or sets the number of data bytes (RDLENGTH). (Inherited from ResourceRecord.)
DnsName | Get or sets the domain name (NAME). (Inherited from ResourceRecord.)
MailAgentName | Get or sets the mail agent name (MADNAME).
ResourceClass | Get or sets the resource class (CLASS). (Inherited from ResourceRecord.)
ResourceType | Get or sets the resource type (TYPE). (Inherited from ResourceRecord.)
TimeInterval | Get or sets the cache time interval (TTL). (Inherited from ResourceRecord.)

See Also

MDRecord Class


MailAgentName Property

[image]

ComponentSpace DNS Class Library
MDRecord..::.MailAgentName Property
MDRecord Class See Also Send Feedback
Get or sets the mail agent name (MADNAME).

Namespace: ComponentSpace.Dns
Assembly: ComponentSpace.Dns (in ComponentSpace.Dns.dll) Version: 1.8.0.2

Syntax

C#
public DnsName MailAgentName { get; set; }
Visual Basic (Declaration)
Public Property MailAgentName As DnsName
Visual C++
public:
property DnsName^ MailAgentName {
    DnsName^ get ();
    void set (DnsName^ value);
}

Field Value

The mail agent name.

See Also

MDRecord Class


MFRecord Class

[image]

ComponentSpace DNS Class Library
MFRecord Class
Members See Also Send Feedback
A mail forwarder resource record.

Namespace: ComponentSpace.Dns
Assembly: ComponentSpace.Dns (in ComponentSpace.Dns.dll) Version: 1.8.0.2

Syntax

C#
public class MFRecord : ResourceRecord
Visual Basic (Declaration)
Public Class MFRecord _
    Inherits ResourceRecord
Visual C++
public ref class MFRecord : public ResourceRecord

Inheritance Hierarchy

System..::.Object
ComponentSpace.Dns..::.ResourceRecord
ComponentSpace.Dns..::.MFRecord

See Also

MFRecord Members


MFRecord Members

[image] [image]

ComponentSpace DNS Class Library
MFRecord Members
MFRecord Class Constructors Methods Properties See Also Send Feedback

The MFRecord type exposes the following members.

Constructors

Name | Description
MFRecord | Overloaded.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToByteArray | Convert the resource record into a byte array. (Overrides ResourceRecord..::.ToByteArray()()().)
ToString | Convert the resource record to a string. (Overrides ResourceRecord..::.ToString()()().)

Properties

Name | Description
DataLength | Get or sets the number of data bytes (RDLENGTH). (Inherited from ResourceRecord.)
DnsName | Get or sets the domain name (NAME). (Inherited from ResourceRecord.)
MailAgentName | Get or sets the mail agent name (MADNAME).
ResourceClass | Get or sets the resource class (CLASS). (Inherited from ResourceRecord.)
ResourceType | Get or sets the resource type (TYPE). (Inherited from ResourceRecord.)
TimeInterval | Get or sets the cache time interval (TTL). (Inherited from ResourceRecord.)

See Also

MFRecord Class


MFRecord Constructor

[image] [image]

ComponentSpace DNS Class Library
MFRecord Constructor
MFRecord Class See Also Send Feedback

Overload List

Name | Description
MFRecord()()() | Default constructor.
MFRecord(array<Byte>[]()[], Int32%, Int32%) | Construct from a byte array.

See Also

MFRecord Class
MFRecord Members


MFRecord Constructor

[image]

ComponentSpace DNS Class Library
MFRecord Constructor
MFRecord Class See Also Send Feedback
Default constructor.

Namespace: ComponentSpace.Dns
Assembly: ComponentSpace.Dns (in ComponentSpace.Dns.dll) Version: 1.8.0.2

Syntax

C#
public MFRecord()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
MFRecord()

See Also

MFRecord Class
MFRecord Overload


MFRecord Constructor (Byte[], Int32, Int32)

[image]

ComponentSpace DNS Class Library
MFRecord Constructor (array<Byte>[]()[], Int32%, Int32%)
MFRecord Class See Also Send Feedback
Construct from a byte array.

Namespace: ComponentSpace.Dns
Assembly: ComponentSpace.Dns (in ComponentSpace.Dns.dll) Version: 1.8.0.2

Syntax

C#
public MFRecord(
    byte[] bytes,
    ref int index,
    ref int count
)
Visual Basic (Declaration)
Public Sub New ( _
    bytes As Byte(), _
    ByRef index As Integer, _
    ByRef count As Integer _
)
Visual C++
public:
MFRecord(
    array<unsigned char>^ bytes,
    int% index,
    int% count
)

Parameters

bytes
Type: array< System..::.Byte >[]()[]
The byte array containing the resource record.
index
Type: System..::.Int32 %
The index into the byte array.
count
Type: System..::.Int32 %
The number of bytes available in the byte array.

See Also

MFRecord Class
MFRecord Overload


MFRecord Methods

[image] [image]

ComponentSpace DNS Class Library
MFRecord Methods
MFRecord Class See Also Send Feedback

The MFRecord type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToByteArray | Convert the resource record into a byte array. (Overrides ResourceRecord..::.ToByteArray()()().)
ToString | Convert the resource record to a string. (Overrides ResourceRecord..::.ToString()()().)

See Also

MFRecord Class


ToByteArray Method

[image]

ComponentSpace DNS Class Library
MFRecord..::.ToByteArray Method
MFRecord Class See Also Send Feedback
Convert the resource record into a byte array.

Namespace: ComponentSpace.Dns
Assembly: ComponentSpace.Dns (in ComponentSpace.Dns.dll) Version: 1.8.0.2

Syntax

C#
public override byte[] ToByteArray()
Visual Basic (Declaration)
Public Overrides Function ToByteArray As Byte()
Visual C++
public:
virtual array<unsigned char>^ ToByteArray() override

Return Value

The byte array containing the resource record.

See Also

MFRecord Class


ToString Method

[image]

ComponentSpace DNS Class Library
MFRecord..::.ToString Method
MFRecord Class See Also Send Feedback
Convert the resource record to a string.

Namespace: ComponentSpace.Dns
Assembly: ComponentSpace.Dns (in ComponentSpace.Dns.dll) Version: 1.8.0.2

Syntax

C#
public override string ToString()
Visual Basic (Declaration)
Public Overrides Function ToString As String
Visual C++
public:
virtual String^ ToString() override

Return Value

The resource record as a string.

See Also

MFRecord Class


MFRecord Properties

[image] [image]

ComponentSpace DNS Class Library
MFRecord Properties
MFRecord Class See Also Send Feedback

The MFRecord type exposes the following members.

Properties

Name | Description
DataLength | Get or sets the number of data bytes (RDLENGTH). (Inherited from ResourceRecord.)
DnsName | Get or sets the domain name (NAME). (Inherited from ResourceRecord.)
MailAgentName | Get or sets the mail agent name (MADNAME).
ResourceClass | Get or sets the resource class (CLASS). (Inherited from ResourceRecord.)
ResourceType | Get or sets the resource type (TYPE). (Inherited from ResourceRecord.)
TimeInterval | Get or sets the cache time interval (TTL). (Inherited from ResourceRecord.)

See Also

MFRecord Class


MailAgentName Property

[image]

ComponentSpace DNS Class Library
MFRecord..::.MailAgentName Property
MFRecord Class See Also Send Feedback
Get or sets the mail agent name (MADNAME).

Namespace: ComponentSpace.Dns
Assembly: ComponentSpace.Dns (in ComponentSpace.Dns.dll) Version: 1.8.0.2

Syntax

C#
public DnsName MailAgentName { get; set; }
Visual Basic (Declaration)
Public Property MailAgentName As DnsName
Visual C++
public:
property DnsName^ MailAgentName {
    DnsName^ get ();
    void set (DnsName^ value);
}

Field Value

The mail agent name.

See Also

MFRecord Class


MGRecord Class

[image]

ComponentSpace DNS Class Library
MGRecord Class
Members See Also Send Feedback
A mail group member resource record.

Namespace: ComponentSpace.Dns
Assembly: ComponentSpace.Dns (in ComponentSpace.Dns.dll) Version: 1.8.0.2

Syntax

C#
public class MGRecord : ResourceRecord
Visual Basic (Declaration)
Public Class MGRecord _
    Inherits ResourceRecord
Visual C++
public ref class MGRecord : public ResourceRecord

Inheritance Hierarchy

System..::.Object
ComponentSpace.Dns..::.ResourceRecord
ComponentSpace.Dns..::.MGRecord

See Also

MGRecord Members


MGRecord Members

[image] [image]

ComponentSpace DNS Class Library
MGRecord Members
MGRecord Class Constructors Methods Properties See Also Send Feedback

The MGRecord type exposes the following members.

Constructors

Name | Description
MGRecord | Overloaded.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToByteArray | Convert the resource record into a byte array. (Overrides ResourceRecord..::.ToByteArray()()().)
ToString | Convert the resource record to a string. (Overrides ResourceRecord..::.ToString()()().)

Properties

Name | Description
DataLength | Get or sets the number of data bytes (RDLENGTH). (Inherited from ResourceRecord.)
DnsName | Get or sets the domain name (NAME). (Inherited from ResourceRecord.)
MailboxName | Get or sets the mail group domain name (MGMNAME).
ResourceClass | Get or sets the resource class (CLASS). (Inherited from ResourceRecord.)
ResourceType | Get or sets the resource type (TYPE). (Inherited from ResourceRecord.)
TimeInterval | Get or sets the cache time interval (TTL). (Inherited from ResourceRecord.)

See Also

MGRecord Class


MGRecord Constructor

[image] [image]

ComponentSpace DNS Class Library
MGRecord Constructor
MGRecord Class See Also Send Feedback

Overload List

Name | Description
MGRecord()()() | Default constructor.
MGRecord(array<Byte>[]()[], Int32%, Int32%) | Construct from a byte array.

See Also

MGRecord Class
MGRecord Members


MGRecord Constructor

[image]

ComponentSpace DNS Class Library
MGRecord Constructor
MGRecord Class See Also Send Feedback
Default constructor.

Namespace: ComponentSpace.Dns
Assembly: ComponentSpace.Dns (in ComponentSpace.Dns.dll) Version: 1.8.0.2

Syntax

C#
public MGRecord()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
MGRecord()

See Also

MGRecord Class
MGRecord Overload


MGRecord Constructor (Byte[], Int32, Int32)

[image]

ComponentSpace DNS Class Library
MGRecord Constructor (array<Byte>[]()[], Int32%, Int32%)
MGRecord Class See Also Send Feedback
Construct from a byte array.

Namespace: ComponentSpace.Dns
Assembly: ComponentSpace.Dns (in ComponentSpace.Dns.dll) Version: 1.8.0.2

Syntax

C#
public MGRecord(
    byte[] bytes,
    ref int index,
    ref int count
)
Visual Basic (Declaration)
Public Sub New ( _
    bytes As Byte(), _
    ByRef index As Integer, _
    ByRef count As Integer _
)
Visual C++
public:
MGRecord(
    array<unsigned char>^ bytes,
    int% index,
    int% count
)

Parameters

bytes
Type: array< System..::.Byte >[]()[]
The byte array containing the resource record.
index
Type: System..::.Int32 %
The index into the byte array.
count
Type: System..::.Int32 %
The number of bytes available in the byte array.

See Also

MGRecord Class
MGRecord Overload


MGRecord Methods

[image] [image]

ComponentSpace DNS Class Library
MGRecord Methods
MGRecord Class See Also Send Feedback

The MGRecord type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToByteArray | Convert the resource record into a byte array. (Overrides ResourceRecord..::.ToByteArray()()().)
ToString | Convert the resource record to a string. (Overrides ResourceRecord..::.ToString()()().)

See Also

MGRecord Class


ToByteArray Method

[image]

ComponentSpace DNS Class Library
MGRecord..::.ToByteArray Method
MGRecord Class See Also Send Feedback
Convert the resource record into a byte array.

Namespace: ComponentSpace.Dns
Assembly: ComponentSpace.Dns (in ComponentSpace.Dns.dll) Version: 1.8.0.2

Syntax

C#
public override byte[] ToByteArray()
Visual Basic (Declaration)
Public Overrides Function ToByteArray As Byte()
Visual C++
public:
virtual array<unsigned char>^ ToByteArray() override

Return Value

The byte array containing the resource record.

See Also

MGRecord Class


ToString Method

[image]

ComponentSpace DNS Class Library
MGRecord..::.ToString Method
MGRecord Class See Also Send Feedback
Convert the resource record to a string.

Namespace: ComponentSpace.Dns
Assembly: ComponentSpace.Dns (in ComponentSpace.Dns.dll) Version: 1.8.0.2

Syntax

C#
public override string ToString()
Visual Basic (Declaration)
Public Overrides Function ToString As String
Visual C++
public:
virtual String^ ToString() override

Return Value

The resource record as a string.

See Also

MGRecord Class


MGRecord Properties

[image] [image]

ComponentSpace DNS Class Library
MGRecord Properties
MGRecord Class See Also Send Feedback

The MGRecord type exposes the following members.

Properties

Name | Description
DataLength | Get or sets the number of data bytes (RDLENGTH). (Inherited from ResourceRecord.)
DnsName | Get or sets the domain name (NAME). (Inherited from ResourceRecord.)
MailboxName | Get or sets the mail group domain name (MGMNAME).
ResourceClass | Get or sets the resource class (CLASS). (Inherited from ResourceRecord.)
ResourceType | Get or sets the resource type (TYPE). (Inherited from ResourceRecord.)
TimeInterval | Get or sets the cache time interval (TTL). (Inherited from ResourceRecord.)

See Also

MGRecord Class


MailboxName Property

[image]

ComponentSpace DNS Class Library
MGRecord..::.MailboxName Property
MGRecord Class See Also Send Feedback
Get or sets the mail group domain name (MGMNAME).

Namespace: ComponentSpace.Dns
Assembly: ComponentSpace.Dns (in ComponentSpace.Dns.dll) Version: 1.8.0.2

Syntax

C#
public DnsName MailboxName { get; set; }
Visual Basic (Declaration)
Public Property MailboxName As DnsName
Visual C++
public:
property DnsName^ MailboxName {
    DnsName^ get ();
    void set (DnsName^ value);
}

Field Value

The mail group domain name.

See Also

MGRecord Class


MINFORecord Class

[image]

ComponentSpace DNS Class Library
MINFORecord Class
Members See Also Send Feedback
A mailbox or mail list resource record.

Namespace: ComponentSpace.Dns
Assembly: ComponentSpace.Dns (in ComponentSpace.Dns.dll) Version: 1.8.0.2

Syntax

C#
public class MINFORecord : ResourceRecord
Visual Basic (Declaration)
Public Class MINFORecord _
    Inherits ResourceRecord
Visual C++
public ref class MINFORecord : public ResourceRecord

Inheritance Hierarchy

System..::.Object
ComponentSpace.Dns..::.ResourceRecord
ComponentSpace.Dns..::.MINFORecord

See Also

MINFORecord Members


MINFORecord Members

[image] [image]

ComponentSpace DNS Class Library
MINFORecord Members
MINFORecord Class Constructors Methods Properties See Also Send Feedback

The MINFORecord type exposes the following members.

Constructors

Name | Description
MINFORecord | Overloaded.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToByteArray | Convert the resource record into a byte array. (Overrides ResourceRecord..::.ToByteArray()()().)
ToString | Convert the resource record to a string. (Overrides ResourceRecord..::.ToString()()().)

Properties

Name | Description
DataLength | Get or sets the number of data bytes (RDLENGTH). (Inherited from ResourceRecord.)
DnsName | Get or sets the domain name (NAME). (Inherited from ResourceRecord.)
ErrorMailboxName | Get or sets the domain name to receive error messages (EMAILBX).
ResourceClass | Get or sets the resource class (CLASS). (Inherited from ResourceRecord.)
ResourceType | Get or sets the resource type (TYPE). (Inherited from ResourceRecord.)
ResponsibleMailboxName | Get or sets the domain name responsible for the mailing list or mailbox (RMAILBX).
TimeInterval | Get or sets the cache time interval (TTL). (Inherited from ResourceRecord.)

See Also

MINFORecord Class


MINFORecord Constructor

[image] [image]

ComponentSpace DNS Class Library
MINFORecord Constructor
MINFORecord Class See Also Send Feedback

Overload List

Name | Description
MINFORecord()()() | Default constructor.
MINFORecord(array<Byte>[]()[], Int32%, Int32%) | Construct from a byte array.

See Also

MINFORecord Class
MINFORecord Members


MINFORecord Constructor

[image]

ComponentSpace DNS Class Library
MINFORecord Constructor
MINFORecord Class See Also Send Feedback
Default constructor.

Namespace: ComponentSpace.Dns
Assembly: ComponentSpace.Dns (in ComponentSpace.Dns.dll) Version: 1.8.0.2

Syntax

C#
public MINFORecord()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
MINFORecord()

See Also

MINFORecord Class
MINFORecord Overload


MINFORecord Constructor (Byte[], Int32, Int32)

[image]

ComponentSpace DNS Class Library
MINFORecord Constructor (array<Byte>[]()[], Int32%, Int32%)
MINFORecord Class See Also Send Feedback
Construct from a byte array.

Namespace: ComponentSpace.Dns
Assembly: ComponentSpace.Dns (in ComponentSpace.Dns.dll) Version: 1.8.0.2

Syntax

C#
public MINFORecord(
    byte[] bytes,
    ref int index,
    ref int count
)
Visual Basic (Declaration)
Public Sub New ( _
    bytes As Byte(), _
    ByRef index As Integer, _
    ByRef count As Integer _
)
Visual C++
public:
MINFORecord(
    array<unsigned char>^ bytes,
    int% index,
    int% count
)

Parameters

bytes
Type: array< System..::.Byte >[]()[]
The byte array containing the resource record.
index
Type: System..::.Int32 %
The index into the byte array.
count
Type: System..::.Int32 %
The number of bytes available in the byte array.

See Also

MINFORecord Class
MINFORecord Overload


MINFORecord Methods

[image] [image]

ComponentSpace DNS Class Library
MINFORecord Methods
MINFORecord Class See Also Send Feedback

The MINFORecord type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToByteArray | Convert the resource record into a byte array. (Overrides ResourceRecord..::.ToByteArray()()().)
ToString | Convert the resource record to a string. (Overrides ResourceRecord..::.ToString()()().)

See Also

MINFORecord Class


ToByteArray Method

[image]

ComponentSpace DNS Class Library
MINFORecord..::.ToByteArray Method
MINFORecord Class See Also Send Feedback
Convert the resource record into a byte array.

Namespace: ComponentSpace.Dns
Assembly: ComponentSpace.Dns (in ComponentSpace.Dns.dll) Version: 1.8.0.2

Syntax

C#
public override byte[] ToByteArray()
Visual Basic (Declaration)
Public Overrides Function ToByteArray As Byte()
Visual C++
public:
virtual array<unsigned char>^ ToByteArray() override

Return Value

The byte array containing the resource record.

See Also

MINFORecord Class


ToString Method

[image]

ComponentSpace DNS Class Library
MINFORecord..::.ToString Method
MINFORecord Class See Also Send Feedback
Convert the resource record to a string.

Namespace: ComponentSpace.Dns
Assembly: ComponentSpace.Dns (in ComponentSpace.Dns.dll) Version: 1.8.0.2

Syntax

C#
public override string ToString()
Visual Basic (Declaration)
Public Overrides Function ToString As String
Visual C++
public:
virtual String^ ToString() override

Return Value

The resource record as a string.

See Also

MINFORecord Class


MINFORecord Properties

[image] [image]

ComponentSpace DNS Class Library
MINFORecord Properties
MINFORecord Class See Also Send Feedback

The MINFORecord type exposes the following members.

Properties

Name | Description
DataLength | Get or sets the number of data bytes (RDLENGTH). (Inherited from ResourceRecord.)
DnsName | Get or sets the domain name (NAME). (Inherited from ResourceRecord.)
ErrorMailboxName | Get or sets the domain name to receive error messages (EMAILBX).
ResourceClass | Get or sets the resource class (CLASS). (Inherited from ResourceRecord.)
ResourceType | Get or sets the resource type (TYPE). (Inherited from ResourceRecord.)
ResponsibleMailboxName | Get or sets the domain name responsible for the mailing list or mailbox (RMAILBX).
TimeInterval | Get or sets the cache time interval (TTL). (Inherited from ResourceRecord.)

See Also

MINFORecord Class


ErrorMailboxName Property

[image]

ComponentSpace DNS Class Library
MINFORecord..::.ErrorMailboxName Property
MINFORecord Class See Also Send Feedback
Get or sets the domain name to receive error messages (EMAILBX).

Namespace: ComponentSpace.Dns
Assembly: ComponentSpace.Dns (in ComponentSpace.Dns.dll) Version: 1.8.0.2

Syntax

C#
public DnsName ErrorMailboxName { get; set; }
Visual Basic (Declaration)
Public Property ErrorMailboxName As DnsName
Visual C++
public:
property DnsName^ ErrorMailboxName {
    DnsName^ get ();
    void set (DnsName^ value);
}

Field Value

The domain name to receive error messages.

See Also

MINFORecord Class


ResponsibleMailboxName Property

[image]

ComponentSpace DNS Class Library
MINFORecord..::.ResponsibleMailboxName Property
MINFORecord Class See Also Send Feedback
Get or sets the domain name responsible for the mailing list or mailbox (RMAILBX).

Namespace: ComponentSpace.Dns
Assembly: ComponentSpace.Dns (in ComponentSpace.Dns.dll) Version: 1.8.0.2

Syntax

C#
public DnsName ResponsibleMailboxName { get; set; }
Visual Basic (Declaration)
Public Property ResponsibleMailboxName As DnsName
Visual C++
public:
property DnsName^ ResponsibleMailboxName {
    DnsName^ get ();
    void set (DnsName^ value);
}

Field Value

The domain name responsible for the mailing list or mailbox.

See Also

MINFORecord Class


MRRecord Class

[image]

ComponentSpace DNS Class Library
MRRecord Class
Members See Also Send Feedback
A mail rename domain name resource record.

Namespace: ComponentSpace.Dns
Assembly: ComponentSpace.Dns (in ComponentSpace.Dns.dll) Version: 1.8.0.2

Syntax

C#
public class MRRecord : ResourceRecord
Visual Basic (Declaration)
Public Class MRRecord _
    Inherits ResourceRecord
Visual C++
public ref class MRRecord : public ResourceRecord

Inheritance Hierarchy

System..::.Object
ComponentSpace.Dns..::.ResourceRecord
ComponentSpace.Dns..::.MRRecord

See Also

MRRecord Members


MRRecord Members

[image] [image]

ComponentSpace DNS Class Library
MRRecord Members
MRRecord Class Constructors Methods Properties See Also Send Feedback

The MRRecord type exposes the following members.

Constructors

Name | Description
MRRecord | Overloaded.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToByteArray | Convert the resource record into a byte array. (Overrides ResourceRecord..::.ToByteArray()()().)
ToString | Convert the resource record to a string. (Overrides ResourceRecord..::.ToString()()().)

Properties

Name | Description
DataLength | Get or sets the number of data bytes (RDLENGTH). (Inherited from ResourceRecord.)
DnsName | Get or sets the domain name (NAME). (Inherited from ResourceRecord.)
NewMailboxName | Get or sets the new name (NEWNAME).
ResourceClass | Get or sets the resource class (CLASS). (Inherited from ResourceRecord.)
ResourceType | Get or sets the resource type (TYPE). (Inherited from ResourceRecord.)
TimeInterval | Get or sets the cache time interval (TTL). (Inherited from ResourceRecord.)

See Also

MRRecord Class


MRRecord Constructor

[image] [image]

ComponentSpace DNS Class Library
MRRecord Constructor
MRRecord Class See Also Send Feedback

Overload List

Name | Description
MRRecord()()() | Default constructor.
MRRecord(array<Byte>[]()[], Int32%, Int32%) | Construct from a byte array.

See Also

MRRecord Class
MRRecord Members


MRRecord Constructor

[image]

ComponentSpace DNS Class Library
MRRecord Constructor
MRRecord Class See Also Send Feedback
Default constructor.

Namespace: ComponentSpace.Dns
Assembly: ComponentSpace.Dns (in ComponentSpace.Dns.dll) Version: 1.8.0.2

Syntax

C#
public MRRecord()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
MRRecord()

See Also

MRRecord Class
MRRecord Overload


MRRecord Constructor (Byte[], Int32, Int32)

[image]

ComponentSpace DNS Class Library
MRRecord Constructor (array<Byte>[]()[], Int32%, Int32%)
MRRecord Class See Also Send Feedback
Construct from a byte array.

Namespace: ComponentSpace.Dns
Assembly: ComponentSpace.Dns (in ComponentSpace.Dns.dll) Version: 1.8.0.2

Syntax

C#
public MRRecord(
    byte[] bytes,
    ref int index,
    ref int count
)
Visual Basic (Declaration)
Public Sub New ( _
    bytes As Byte(), _
    ByRef index As Integer, _
    ByRef count As Integer _
)
Visual C++
public:
MRRecord(
    array<unsigned char>^ bytes,
    int% index,
    int% count
)

Parameters

bytes
Type: array< System..::.Byte >[]()[]
The byte array containing the resource record.
index
Type: System..::.Int32 %
The index into the byte array.
count
Type: System..::.Int32 %
The number of bytes available in the byte array.

See Also

MRRecord Class
MRRecord Overload


MRRecord Methods

[image] [image]

ComponentSpace DNS Class Library
MRRecord Methods
MRRecord Class See Also Send Feedback

The MRRecord type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToByteArray | Convert the resource record into a byte array. (Overrides ResourceRecord..::.ToByteArray()()().)
ToString | Convert the resource record to a string. (Overrides ResourceRecord..::.ToString()()().)

See Also

MRRecord Class


ToByteArray Method

[image]

ComponentSpace DNS Class Library
MRRecord..::.ToByteArray Method
MRRecord Class See Also Send Feedback
Convert the resource record into a byte array.

Namespace: ComponentSpace.Dns
Assembly: ComponentSpace.Dns (in ComponentSpace.Dns.dll) Version: 1.8.0.2

Syntax

C#
public override byte[] ToByteArray()
Visual Basic (Declaration)
Public Overrides Function ToByteArray As Byte()
Visual C++
public:
virtual array<unsigned char>^ ToByteArray() override

Return Value

The byte array containing the resource record.

See Also

MRRecord Class


ToString Method

[image]

ComponentSpace DNS Class Library
MRRecord..::.ToString Method
MRRecord Class See Also Send Feedback
Convert the resource record to a string.

Namespace: ComponentSpace.Dns
Assembly: ComponentSpace.Dns (in ComponentSpace.Dns.dll) Version: 1.8.0.2

Syntax

C#
public override string ToString()
Visual Basic (Declaration)
Public Overrides Function ToString As String
Visual C++
public:
virtual String^ ToString() override

Return Value

The resource record as a string.

See Also

MRRecord Class


MRRecord Properties

[image] [image]

ComponentSpace DNS Class Library
MRRecord Properties
MRRecord Class See Also Send Feedback

The MRRecord type exposes the following members.

Properties

Name | Description
DataLength | Get or sets the number of data bytes (RDLENGTH). (Inherited from ResourceRecord.)
DnsName | Get or sets the domain name (NAME). (Inherited from ResourceRecord.)
NewMailboxName | Get or sets the new name (NEWNAME).
ResourceClass | Get or sets the resource class (CLASS). (Inherited from ResourceRecord.)
ResourceType | Get or sets the resource type (TYPE). (Inherited from ResourceRecord.)
TimeInterval | Get or sets the cache time interval (TTL). (Inherited from ResourceRecord.)

See Also

MRRecord Class


NewMailboxName Property

[image]

ComponentSpace DNS Class Library
MRRecord..::.NewMailboxName Property
MRRecord Class See Also Send Feedback
Get or sets the new name (NEWNAME).

Namespace: ComponentSpace.Dns
Assembly: ComponentSpace.Dns (in ComponentSpace.Dns.dll) Version: 1.8.0.2

Syntax

C#
public DnsName NewMailboxName { get; set; }
Visual Basic (Declaration)
Public Property NewMailboxName As DnsName
Visual C++
public:
property DnsName^ NewMailboxName {
    DnsName^ get ();
    void set (DnsName^ value);
}

Field Value

The new name.

See Also

MRRecord Class


MXRecord Class

[image]

ComponentSpace DNS Class Library
MXRecord Class
Members See Also Send Feedback
A mail exchange resource record.

Namespace: ComponentSpace.Dns
Assembly: ComponentSpace.Dns (in ComponentSpace.Dns.dll) Version: 1.8.0.2

Syntax

C#
public class MXRecord : ResourceRecord
Visual Basic (Declaration)
Public Class MXRecord _
    Inherits ResourceRecord
Visual C++
public ref class MXRecord : public ResourceRecord

Inheritance Hierarchy

System..::.Object
ComponentSpace.Dns..::.ResourceRecord
ComponentSpace.Dns..::.MXRecord

See Also

MXRecord Members


MXRecord Members

[image] [image]

ComponentSpace DNS Class Library
MXRecord Members
MXRecord Class Constructors Methods Properties See Also Send Feedback

The MXRecord type exposes the following members.

Constructors

Name | Description
MXRecord | Overloaded.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToByteArray | Convert the resource record into a byte array. (Overrides ResourceRecord..::.ToByteArray()()().)
ToString | Convert the resource record to a string. (Overrides ResourceRecord..::.ToString()()().)

Properties

Name | Description
DataLength | Get or sets the number of data bytes (RDLENGTH). (Inherited from ResourceRecord.)
DnsName | Get or sets the domain name (NAME). (Inherited from ResourceRecord.)
ExchangeName | Get or sets the mail exchange name (EXCHANGE).
Preference | Get or sets the preference (PREFERENCE).
ResourceClass | Get or sets the resource class (CLASS). (Inherited from ResourceRecord.)
ResourceType | Get or sets the resource type (TYPE). (Inherited from ResourceRecord.)
TimeInterval | Get or sets the cache time interval (TTL). (Inherited from ResourceRecord.)

See Also

MXRecord Class


MXRecord Constructor

[image] [image]

ComponentSpace DNS Class Library
MXRecord Constructor
MXRecord Class See Also Send Feedback

Overload List

Name | Description
MXRecord()()() | Default constructor.
MXRecord(array<Byte>[]()[], Int32%, Int32%) | Construct from a byte array.

See Also

MXRecord Class
MXRecord Members


MXRecord Constructor

[image]

ComponentSpace DNS Class Library
MXRecord Constructor
MXRecord Class See Also Send Feedback
Default constructor.

Namespace: ComponentSpace.Dns
Assembly: ComponentSpace.Dns (in ComponentSpace.Dns.dll) Version: 1.8.0.2

Syntax

C#
public MXRecord()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
MXRecord()

See Also

MXRecord Class
MXRecord Overload


MXRecord Constructor (Byte[], Int32, Int32)

[image]

ComponentSpace DNS Class Library
MXRecord Constructor (array<Byte>[]()[], Int32%, Int32%)
MXRecord Class See Also Send Feedback
Construct from a byte array.

Namespace: ComponentSpace.Dns
Assembly: ComponentSpace.Dns (in ComponentSpace.Dns.dll) Version: 1.8.0.2

Syntax

C#
public MXRecord(
    byte[] bytes,
    ref int index,
    ref int count
)
Visual Basic (Declaration)
Public Sub New ( _
    bytes As Byte(), _
    ByRef index As Integer, _
    ByRef count As Integer _
)
Visual C++
public:
MXRecord(
    array<unsigned char>^ bytes,
    int% index,
    int% count
)

Parameters

bytes
Type: array< System..::.Byte >[]()[]
The byte array containing the resource record.
index
Type: System..::.Int32 %
The index into the byte array.
count
Type: System..::.Int32 %
The number of bytes available in the byte array.

See Also

MXRecord Class
MXRecord Overload


MXRecord Methods

[image] [image]

ComponentSpace DNS Class Library
MXRecord Methods
MXRecord Class See Also Send Feedback

The MXRecord type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToByteArray | Convert the resource record into a byte array. (Overrides ResourceRecord..::.ToByteArray()()().)
ToString | Convert the resource record to a string. (Overrides ResourceRecord..::.ToString()()().)

See Also

MXRecord Class


ToByteArray Method

[image]

ComponentSpace DNS Class Library
MXRecord..::.ToByteArray Method
MXRecord Class See Also Send Feedback
Convert the resource record into a byte array.

Namespace: ComponentSpace.Dns
Assembly: ComponentSpace.Dns (in ComponentSpace.Dns.dll) Version: 1.8.0.2

Syntax

C#
public override byte[] ToByteArray()
Visual Basic (Declaration)
Public Overrides Function ToByteArray As Byte()
Visual C++
public:
virtual array<unsigned char>^ ToByteArray() override

Return Value

The byte array containing the resource record.

See Also

MXRecord Class


ToString Method

[image]

ComponentSpace DNS Class Library
MXRecord..::.ToString Method
MXRecord Class See Also Send Feedback
Convert the resource record to a string.

Namespace: ComponentSpace.Dns
Assembly: ComponentSpace.Dns (in ComponentSpace.Dns.dll) Version: 1.8.0.2

Syntax

C#
public override string ToString()
Visual Basic (Declaration)
Public Overrides Function ToString As String
Visual C++
public:
virtual String^ ToString() override

Return Value

The resource record as a string.

See Also

MXRecord Class


MXRecord Properties

[image] [image]

ComponentSpace DNS Class Library
MXRecord Properties
MXRecord Class See Also Send Feedback

The MXRecord type exposes the following members.

Properties

Name | Description
DataLength | Get or sets the number of data bytes (RDLENGTH). (Inherited from ResourceRecord.)
DnsName | Get or sets the domain name (NAME). (Inherited from ResourceRecord.)
ExchangeName | Get or sets the mail exchange name (EXCHANGE).
Preference | Get or sets the preference (PREFERENCE).
ResourceClass | Get or sets the resource class (CLASS). (Inherited from ResourceRecord.)
ResourceType | Get or sets the resource type (TYPE). (Inherited from ResourceRecord.)
TimeInterval | Get or sets the cache time interval (TTL). (Inherited from ResourceRecord.)

See Also

MXRecord Class


ExchangeName Property

[image]

ComponentSpace DNS Class Library
MXRecord..::.ExchangeName Property
MXRecord Class See Also Send Feedback
Get or sets the mail exchange name (EXCHANGE).

Namespace: ComponentSpace.Dns
Assembly: ComponentSpace.Dns (in ComponentSpace.Dns.dll) Version: 1.8.0.2

Syntax

C#
public DnsName ExchangeName { get; set; }
Visual Basic (Declaration)
Public Property ExchangeName As DnsName
Visual C++
public:
property DnsName^ ExchangeName {
    DnsName^ get ();
    void set (DnsName^ value);
}

Field Value

The mail exchange name.

See Also

MXRecord Class


Preference Property

[image]

ComponentSpace DNS Class Library
MXRecord..::.Preference Property
MXRecord Class See Also Send Feedback
Get or sets the preference (PREFERENCE).

Namespace: ComponentSpace.Dns
Assembly: ComponentSpace.Dns (in ComponentSpace.Dns.dll) Version: 1.8.0.2

Syntax

C#
public int Preference { get; set; }
Visual Basic (Declaration)
Public Property Preference As Integer
Visual C++
public:
property int Preference {
    int get ();
    void set (int value);
}

Field Value

The preference.

See Also

MXRecord Class


NSRecord Class

[image]

ComponentSpace DNS Class Library
NSRecord Class
Members See Also Send Feedback
An authoritative name server resource record.

Namespace: ComponentSpace.Dns
Assembly: ComponentSpace.Dns (in ComponentSpace.Dns.dll) Version: 1.8.0.2

Syntax

C#
public class NSRecord : ResourceRecord
Visual Basic (Declaration)
Public Class NSRecord _
    Inherits ResourceRecord
Visual C++
public ref class NSRecord : public ResourceRecord

Inheritance Hierarchy

System..::.Object
ComponentSpace.Dns..::.ResourceRecord
ComponentSpace.Dns..::.NSRecord

See Also

NSRecord Members


NSRecord Members

[image] [image]

ComponentSpace DNS Class Library
NSRecord Members
NSRecord Class Constructors Methods Properties See Also Send Feedback

The NSRecord type exposes the following members.

Constructors

Name | Description
NSRecord | Overloaded.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToByteArray | Convert the resource record into a byte array. (Overrides ResourceRecord..::.ToByteArray()()().)
ToString | Convert the resource record to a string. (Overrides ResourceRecord..::.ToString()()().)

Properties

Name | Description
AuthoritativeName | Get or sets the authoritative name (NSDNAME).
DataLength | Get or sets the number of data bytes (RDLENGTH). (Inherited from ResourceRecord.)
DnsName | Get or sets the domain name (NAME). (Inherited from ResourceRecord.)
ResourceClass | Get or sets the resource class (CLASS). (Inherited from ResourceRecord.)
ResourceType | Get or sets the resource type (TYPE). (Inherited from ResourceRecord.)
TimeInterval | Get or sets the cache time interval (TTL). (Inherited from ResourceRecord.)

See Also

NSRecord Class


NSRecord Constructor

[image] [image]

ComponentSpace DNS Class Library
NSRecord Constructor
NSRecord Class See Also Send Feedback

Overload List

Name | Description
NSRecord()()() | Default constructor.
NSRecord(array<Byte>[]()[], Int32%, Int32%) | Construct from a byte array.

See Also

NSRecord Class
NSRecord Members


NSRecord Constructor

[image]

ComponentSpace DNS Class Library
NSRecord Constructor
NSRecord Class See Also Send Feedback
Default constructor.

Namespace: ComponentSpace.Dns
Assembly: ComponentSpace.Dns (in ComponentSpace.Dns.dll) Version: 1.8.0.2

Syntax

C#
public NSRecord()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
NSRecord()

See Also

NSRecord Class
NSRecord Overload


NSRecord Constructor (Byte[], Int32, Int32)

[image]

ComponentSpace DNS Class Library
NSRecord Constructor (array<Byte>[]()[], Int32%, Int32%)
NSRecord Class See Also Send Feedback
Construct from a byte array.

Namespace: ComponentSpace.Dns
Assembly: ComponentSpace.Dns (in ComponentSpace.Dns.dll) Version: 1.8.0.2

Syntax

C#
public NSRecord(
    byte[] bytes,
    ref int index,
    ref int count
)
Visual Basic (Declaration)
Public Sub New ( _
    bytes As Byte(), _
    ByRef index As Integer, _
    ByRef count As Integer _
)
Visual C++
public:
NSRecord(
    array<unsigned char>^ bytes,
    int% index,
    int% count
)

Parameters

bytes
Type: array< System..::.Byte >[]()[]
The byte array containing the resource record.
index
Type: System..::.Int32 %
The index into the byte array.
count
Type: System..::.Int32 %
The number of bytes available in the byte array.

See Also

NSRecord Class
NSRecord Overload


NSRecord Methods

[image] [image]

ComponentSpace DNS Class Library
NSRecord Methods
NSRecord Class See Also Send Feedback

The NSRecord type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToByteArray | Convert the resource record into a byte array. (Overrides ResourceRecord..::.ToByteArray()()().)
ToString | Convert the resource record to a string. (Overrides ResourceRecord..::.ToString()()().)

See Also

NSRecord Class


ToByteArray Method

[image]

ComponentSpace DNS Class Library
NSRecord..::.ToByteArray Method
NSRecord Class See Also Send Feedback
Convert the resource record into a byte array.

Namespace: ComponentSpace.Dns
Assembly: ComponentSpace.Dns (in ComponentSpace.Dns.dll) Version: 1.8.0.2

Syntax

C#
public override byte[] ToByteArray()
Visual Basic (Declaration)
Public Overrides Function ToByteArray As Byte()
Visual C++
public:
virtual array<unsigned char>^ ToByteArray() override

Return Value

The byte array containing the resource record.

See Also

NSRecord Class


ToString Method

[image]

ComponentSpace DNS Class Library
NSRecord..::.ToString Method
NSRecord Class See Also Send Feedback
Convert the resource record to a string.

Namespace: ComponentSpace.Dns
Assembly: ComponentSpace.Dns (in ComponentSpace.Dns.dll) Version: 1.8.0.2

Syntax

C#
public override string ToString()
Visual Basic (Declaration)
Public Overrides Function ToString As String
Visual C++
public:
virtual String^ ToString() override

Return Value

The resource record as a string.

See Also

NSRecord Class


NSRecord Properties

[image] [image]

ComponentSpace DNS Class Library
NSRecord Properties
NSRecord Class See Also Send Feedback

The NSRecord type exposes the following members.

Properties

Name | Description
AuthoritativeName | Get or sets the authoritative name (NSDNAME).
DataLength | Get or sets the number of data bytes (RDLENGTH). (Inherited from ResourceRecord.)
DnsName | Get or sets the domain name (NAME). (Inherited from ResourceRecord.)
ResourceClass | Get or sets the resource class (CLASS). (Inherited from ResourceRecord.)
ResourceType | Get or sets the resource type (TYPE). (Inherited from ResourceRecord.)
TimeInterval | Get or sets the cache time interval (TTL). (Inherited from ResourceRecord.)

See Also

NSRecord Class


AuthoritativeName Property

[image]

ComponentSpace DNS Class Library
NSRecord..::.AuthoritativeName Property
NSRecord Class See Also Send Feedback
Get or sets the authoritative name (NSDNAME).

Namespace: ComponentSpace.Dns
Assembly: ComponentSpace.Dns (in ComponentSpace.Dns.dll) Version: 1.8.0.2

Syntax

C#
public DnsName AuthoritativeName { get; set; }
Visual Basic (Declaration)
Public Property AuthoritativeName As DnsName
Visual C++
public:
property DnsName^ AuthoritativeName {
    DnsName^ get ();
    void set (DnsName^ value);
}

Field Value

The address.

See Also

NSRecord Class


NULLRecord Class

[image]

ComponentSpace DNS Class Library
NULLRecord Class
Members See Also Send Feedback
Null resource record.

Namespace: ComponentSpace.Dns
Assembly: ComponentSpace.Dns (in ComponentSpace.Dns.dll) Version: 1.8.0.2

Syntax

C#
public class NULLRecord : ResourceRecord
Visual Basic (Declaration)
Public Class NULLRecord _
    Inherits ResourceRecord
Visual C++
public ref class NULLRecord : public ResourceRecord

Inheritance Hierarchy

System..::.Object
ComponentSpace.Dns..::.ResourceRecord
ComponentSpace.Dns..::.NULLRecord

See Also

NULLRecord Members


NULLRecord Members

[image] [image]

ComponentSpace DNS Class Library
NULLRecord Members
NULLRecord Class Constructors Methods Properties See Also Send Feedback

The NULLRecord type exposes the following members.

Constructors

Name | Description
NULLRecord | Overloaded.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToByteArray | Convert the resource record into a byte array. (Overrides ResourceRecord..::.ToByteArray()()().)
ToString | Convert the resource record to a string. (Overrides ResourceRecord..::.ToString()()().)

Properties

Name | Description
Data | Get or sets the data.
DataLength | Get or sets the number of data bytes (RDLENGTH). (Inherited from ResourceRecord.)
DnsName | Get or sets the domain name (NAME). (Inherited from ResourceRecord.)
ResourceClass | Get or sets the resource class (CLASS). (Inherited from ResourceRecord.)
ResourceType | Get or sets the resource type (TYPE). (Inherited from ResourceRecord.)
TimeInterval | Get or sets the cache time interval (TTL). (Inherited from ResourceRecord.)

See Also

NULLRecord Class


NULLRecord Constructor

[image] [image]

ComponentSpace DNS Class Library
NULLRecord Constructor
NULLRecord Class See Also Send Feedback

Overload List

Name | Description
NULLRecord()()() | Default constructor.
NULLRecord(array<Byte>[]()[], Int32%, Int32%) | Construct from a byte array.

See Also

NULLRecord Class
NULLRecord Members


NULLRecord Constructor

[image]

ComponentSpace DNS Class Library
NULLRecord Constructor
NULLRecord Class See Also Send Feedback
Default constructor.

Namespace: ComponentSpace.Dns
Assembly: ComponentSpace.Dns (in ComponentSpace.Dns.dll) Version: 1.8.0.2

Syntax

C#
public NULLRecord()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
NULLRecord()

See Also

NULLRecord Class
NULLRecord Overload


NULLRecord Constructor (Byte[], Int32, Int32)

[image]

ComponentSpace DNS Class Library
NULLRecord Constructor (array<Byte>[]()[], Int32%, Int32%)
NULLRecord Class See Also Send Feedback
Construct from a byte array.

Namespace: ComponentSpace.Dns
Assembly: ComponentSpace.Dns (in ComponentSpace.Dns.dll) Version: 1.8.0.2

Syntax

C#
public NULLRecord(
    byte[] bytes,
    ref int index,
    ref int count
)
Visual Basic (Declaration)
Public Sub New ( _
    bytes As Byte(), _
    ByRef index As Integer, _
    ByRef count As Integer _
)
Visual C++
public:
NULLRecord(
    array<unsigned char>^ bytes,
    int% index,
    int% count
)

Parameters

bytes
Type: array< System..::.Byte >[]()[]
The byte array containing the resource record.
index
Type: System..::.Int32 %
The index into the byte array.
count
Type: System..::.Int32 %
The number of bytes available in the byte array.

See Also

NULLRecord Class
NULLRecord Overload


NULLRecord Methods

[image] [image]

ComponentSpace DNS Class Library
NULLRecord Methods
NULLRecord Class See Also Send Feedback

The NULLRecord type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToByteArray | Convert the resource record into a byte array. (Overrides ResourceRecord..::.ToByteArray()()().)
ToString | Convert the resource record to a string. (Overrides ResourceRecord..::.ToString()()().)

See Also

NULLRecord Class


ToByteArray Method

[image]

ComponentSpace DNS Class Library
NULLRecord..::.ToByteArray Method
NULLRecord Class See Also Send Feedback
Convert the resource record into a byte array.

Namespace: ComponentSpace.Dns
Assembly: ComponentSpace.Dns (in ComponentSpace.Dns.dll) Version: 1.8.0.2

Syntax

C#
public override byte[] ToByteArray()
Visual Basic (Declaration)
Public Overrides Function ToByteArray As Byte()
Visual C++
public:
virtual array<unsigned char>^ ToByteArray() override

Return Value

The byte array containing the resource record.

See Also

NULLRecord Class


ToString Method

[image]

ComponentSpace DNS Class Library
NULLRecord..::.ToString Method
NULLRecord Class See Also Send Feedback
Convert the resource record to a string.

Namespace: ComponentSpace.Dns
Assembly: ComponentSpace.Dns (in ComponentSpace.Dns.dll) Version: 1.8.0.2

Syntax

C#
public override string ToString()
Visual Basic (Declaration)
Public Overrides Function ToString As String
Visual C++
public:
virtual String^ ToString() override

Return Value

The resource record as a string.

See Also

NULLRecord Class


NULLRecord Properties

[image] [image]

ComponentSpace DNS Class Library
NULLRecord Properties
NULLRecord Class See Also Send Feedback

The NULLRecord type exposes the following members.

Properties

Name | Description
Data | Get or sets the data.
DataLength | Get or sets the number of data bytes (RDLENGTH). (Inherited from ResourceRecord.)
DnsName | Get or sets the domain name (NAME). (Inherited from ResourceRecord.)
ResourceClass | Get or sets the resource class (CLASS). (Inherited from ResourceRecord.)
ResourceType | Get or sets the resource type (TYPE). (Inherited from ResourceRecord.)
TimeInterval | Get or sets the cache time interval (TTL). (Inherited from ResourceRecord.)

See Also

NULLRecord Class


Data Property

[image]

ComponentSpace DNS Class Library
NULLRecord..::.Data Property
NULLRecord Class See Also Send Feedback
Get or sets the data.

Namespace: ComponentSpace.Dns
Assembly: ComponentSpace.Dns (in ComponentSpace.Dns.dll) Version: 1.8.0.2

Syntax

C#
public byte[] Data { get; set; }
Visual Basic (Declaration)
Public Property Data As Byte()
Visual C++
public:
property array<unsigned char>^ Data {
    array<unsigned char>^ get ();
    void set (array<unsigned char>^ value);
}

Field Value

The data.

See Also

NULLRecord Class


OtherRecord Class

[image]

ComponentSpace DNS Class Library
OtherRecord Class
Members See Also Send Feedback
A generic resource record.

Namespace: ComponentSpace.Dns
Assembly: ComponentSpace.Dns (in ComponentSpace.Dns.dll) Version: 1.8.0.2

Syntax

C#
public class OtherRecord : ResourceRecord
Visual Basic (Declaration)
Public Class OtherRecord _
    Inherits ResourceRecord
Visual C++
public ref class OtherRecord : public ResourceRecord

Remarks

Unknown resource records types are returned as OtherRecord objects.

Inheritance Hierarchy

System..::.Object
ComponentSpace.Dns..::.ResourceRecord
ComponentSpace.Dns..::.OtherRecord

See Also

OtherRecord Members


OtherRecord Members

[image] [image]

ComponentSpace DNS Class Library
OtherRecord Members
OtherRecord Class Constructors Methods Properties See Also Send Feedback

The OtherRecord type exposes the following members.

Constructors

Name | Description
OtherRecord | Overloaded.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToByteArray | Convert the resource record into a byte array. (Overrides ResourceRecord..::.ToByteArray()()().)
ToString | Convert the resource record to a string. (Overrides ResourceRecord..::.ToString()()().)

Properties

Name | Description
Data | Get or sets the data.
DataLength | Get or sets the number of data bytes (RDLENGTH). (Inherited from ResourceRecord.)
DnsName | Get or sets the domain name (NAME). (Inherited from ResourceRecord.)
ResourceClass | Get or sets the resource class (CLASS). (Inherited from ResourceRecord.)
ResourceType | Get or sets the resource type (TYPE). (Inherited from ResourceRecord.)
TimeInterval | Get or sets the cache time interval (TTL). (Inherited from ResourceRecord.)

See Also

OtherRecord Class


OtherRecord Constructor

[image] [image]

ComponentSpace DNS Class Library
OtherRecord Constructor
OtherRecord Class See Also Send Feedback

Overload List

Name | Description
OtherRecord()()() | Default constructor.
OtherRecord(array<Byte>[]()[], Int32%, Int32%) | Construct from a byte array.

See Also

OtherRecord Class
OtherRecord Members


OtherRecord Constructor

[image]

ComponentSpace DNS Class Library
OtherRecord Constructor
OtherRecord Class See Also Send Feedback
Default constructor.

Namespace: ComponentSpace.Dns
Assembly: ComponentSpace.Dns (in ComponentSpace.Dns.dll) Version: 1.8.0.2

Syntax

C#
public OtherRecord()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
OtherRecord()

See Also

OtherRecord Class
OtherRecord Overload


OtherRecord Constructor (Byte[], Int32, Int32)

[image]

ComponentSpace DNS Class Library
OtherRecord Constructor (array<Byte>[]()[], Int32%, Int32%)
OtherRecord Class See Also Send Feedback
Construct from a byte array.

Namespace: ComponentSpace.Dns
Assembly: ComponentSpace.Dns (in ComponentSpace.Dns.dll) Version: 1.8.0.2

Syntax

C#
public OtherRecord(
    byte[] bytes,
    ref int index,
    ref int count
)
Visual Basic (Declaration)
Public Sub New ( _
    bytes As Byte(), _
    ByRef index As Integer, _
    ByRef count As Integer _
)
Visual C++
public:
OtherRecord(
    array<unsigned char>^ bytes,
    int% index,
    int% count
)

Parameters

bytes
Type: array< System..::.Byte >[]()[]
The byte array containing the resource record.
index
Type: System..::.Int32 %
The index into the byte array.
count
Type: System..::.Int32 %
The number of bytes available in the byte array.

See Also

OtherRecord Class
OtherRecord Overload


OtherRecord Methods

[image] [image]

ComponentSpace DNS Class Library
OtherRecord Methods
OtherRecord Class See Also Send Feedback

The OtherRecord type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToByteArray | Convert the resource record into a byte array. (Overrides ResourceRecord..::.ToByteArray()()().)
ToString | Convert the resource record to a string. (Overrides ResourceRecord..::.ToString()()().)

See Also

OtherRecord Class


ToByteArray Method

[image]

ComponentSpace DNS Class Library
OtherRecord..::.ToByteArray Method
OtherRecord Class See Also Send Feedback
Convert the resource record into a byte array.

Namespace: ComponentSpace.Dns
Assembly: ComponentSpace.Dns (in ComponentSpace.Dns.dll) Version: 1.8.0.2

Syntax

C#
public override byte[] ToByteArray()
Visual Basic (Declaration)
Public Overrides Function ToByteArray As Byte()
Visual C++
public:
virtual array<unsigned char>^ ToByteArray() override

Return Value

The byte array containing the resource record.

See Also

OtherRecord Class


ToString Method

[image]

ComponentSpace DNS Class Library
OtherRecord..::.ToString Method
OtherRecord Class See Also Send Feedback
Convert the resource record to a string.

Namespace: ComponentSpace.Dns
Assembly: ComponentSpace.Dns (in ComponentSpace.Dns.dll) Version: 1.8.0.2

Syntax

C#
public override string ToString()
Visual Basic (Declaration)
Public Overrides Function ToString As String
Visual C++
public:
virtual String^ ToString() override

Return Value

The resource record as a string.

See Also

OtherRecord Class


OtherRecord Properties

[image] [image]

ComponentSpace DNS Class Library
OtherRecord Properties
OtherRecord Class See Also Send Feedback

The OtherRecord type exposes the following members.

Properties

Name | Description
Data | Get or sets the data.
DataLength | Get or sets the number of data bytes (RDLENGTH). (Inherited from ResourceRecord.)
DnsName | Get or sets the domain name (NAME). (Inherited from ResourceRecord.)
ResourceClass | Get or sets the resource class (CLASS). (Inherited from ResourceRecord.)
ResourceType | Get or sets the resource type (TYPE). (Inherited from ResourceRecord.)
TimeInterval | Get or sets the cache time interval (TTL). (Inherited from ResourceRecord.)

See Also

OtherRecord Class


Data Property

[image]

ComponentSpace DNS Class Library
OtherRecord..::.Data Property
OtherRecord Class See Also Send Feedback
Get or sets the data.

Namespace: ComponentSpace.Dns
Assembly: ComponentSpace.Dns (in ComponentSpace.Dns.dll) Version: 1.8.0.2

Syntax

C#
public byte[] Data { get; set; }
Visual Basic (Declaration)
Public Property Data As Byte()
Visual C++
public:
property array<unsigned char>^ Data {
    array<unsigned char>^ get ();
    void set (array<unsigned char>^ value);
}

Field Value

The data.

See Also

OtherRecord Class


PTRRecord Class

[image]

ComponentSpace DNS Class Library
PTRRecord Class
Members See Also Send Feedback
A domain name pointer resource record.

Namespace: ComponentSpace.Dns
Assembly: ComponentSpace.Dns (in ComponentSpace.Dns.dll) Version: 1.8.0.2

Syntax

C#
public class PTRRecord : ResourceRecord
Visual Basic (Declaration)
Public Class PTRRecord _
    Inherits ResourceRecord
Visual C++
public ref class PTRRecord : public ResourceRecord

Inheritance Hierarchy

System..::.Object
ComponentSpace.Dns..::.ResourceRecord
ComponentSpace.Dns..::.PTRRecord

See Also

PTRRecord Members


PTRRecord Members

[image] [image]

ComponentSpace DNS Class Library
PTRRecord Members
PTRRecord Class Constructors Methods Properties See Also Send Feedback

The PTRRecord type exposes the following members.

Constructors

Name | Description
PTRRecord | Overloaded.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToByteArray | Convert the resource record into a byte array. (Overrides ResourceRecord..::.ToByteArray()()().)
ToString | Convert the resource record to a string. (Overrides ResourceRecord..::.ToString()()().)

Properties

Name | Description
DataLength | Get or sets the number of data bytes (RDLENGTH). (Inherited from ResourceRecord.)
DnsName | Get or sets the domain name (NAME). (Inherited from ResourceRecord.)
PointerName | Get or sets the pointer domain name (PTRDNAME).
ResourceClass | Get or sets the resource class (CLASS). (Inherited from ResourceRecord.)
ResourceType | Get or sets the resource type (TYPE). (Inherited from ResourceRecord.)
TimeInterval | Get or sets the cache time interval (TTL). (Inherited from ResourceRecord.)

See Also

PTRRecord Class


PTRRecord Constructor

[image] [image]

ComponentSpace DNS Class Library
PTRRecord Constructor
PTRRecord Class See Also Send Feedback

Overload List

Name | Description
PTRRecord()()() | Default constructor.
PTRRecord(array<Byte>[]()[], Int32%, Int32%) | Construct from a byte array.

See Also

PTRRecord Class
PTRRecord Members


PTRRecord Constructor

[image]

ComponentSpace DNS Class Library
PTRRecord Constructor
PTRRecord Class See Also Send Feedback
Default constructor.

Namespace: ComponentSpace.Dns
Assembly: ComponentSpace.Dns (in ComponentSpace.Dns.dll) Version: 1.8.0.2

Syntax

C#
public PTRRecord()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
PTRRecord()

See Also

PTRRecord Class
PTRRecord Overload


PTRRecord Constructor (Byte[], Int32, Int32)

[image]

ComponentSpace DNS Class Library
PTRRecord Constructor (array<Byte>[]()[], Int32%, Int32%)
PTRRecord Class See Also Send Feedback
Construct from a byte array.

Namespace: ComponentSpace.Dns
Assembly: ComponentSpace.Dns (in ComponentSpace.Dns.dll) Version: 1.8.0.2

Syntax

C#
public PTRRecord(
    byte[] bytes,
    ref int index,
    ref int count
)
Visual Basic (Declaration)
Public Sub New ( _
    bytes As Byte(), _
    ByRef index As Integer, _
    ByRef count As Integer _
)
Visual C++
public:
PTRRecord(
    array<unsigned char>^ bytes,
    int% index,
    int% count
)

Parameters

bytes
Type: array< System..::.Byte >[]()[]
The byte array containing the resource record.
index
Type: System..::.Int32 %
The index into the byte array.
count
Type: System..::.Int32 %
The number of bytes available in the byte array.

See Also

PTRRecord Class
PTRRecord Overload


PTRRecord Methods

[image] [image]

ComponentSpace DNS Class Library
PTRRecord Methods
PTRRecord Class See Also Send Feedback

The PTRRecord type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToByteArray | Convert the resource record into a byte array. (Overrides ResourceRecord..::.ToByteArray()()().)
ToString | Convert the resource record to a string. (Overrides ResourceRecord..::.ToString()()().)

See Also

PTRRecord Class


ToByteArray Method

[image]

ComponentSpace DNS Class Library
PTRRecord..::.ToByteArray Method
PTRRecord Class See Also Send Feedback
Convert the resource record into a byte array.

Namespace: ComponentSpace.Dns
Assembly: ComponentSpace.Dns (in ComponentSpace.Dns.dll) Version: 1.8.0.2

Syntax

C#
public override byte[] ToByteArray()
Visual Basic (Declaration)
Public Overrides Function ToByteArray As Byte()
Visual C++
public:
virtual array<unsigned char>^ ToByteArray() override

Return Value

The byte array containing the resource record.

See Also

PTRRecord Class


ToString Method

[image]

ComponentSpace DNS Class Library
PTRRecord..::.ToString Method
PTRRecord Class See Also Send Feedback
Convert the resource record to a string.

Namespace: ComponentSpace.Dns
Assembly: ComponentSpace.Dns (in ComponentSpace.Dns.dll) Version: 1.8.0.2

Syntax

C#
public override string ToString()
Visual Basic (Declaration)
Public Overrides Function ToString As String
Visual C++
public:
virtual String^ ToString() override

Return Value

The resource record as a string.

See Also

PTRRecord Class


PTRRecord Properties

[image] [image]

ComponentSpace DNS Class Library
PTRRecord Properties
PTRRecord Class See Also Send Feedback

The PTRRecord type exposes the following members.

Properties

Name | Description
DataLength | Get or sets the number of data bytes (RDLENGTH). (Inherited from ResourceRecord.)
DnsName | Get or sets the domain name (NAME). (Inherited from ResourceRecord.)
PointerName | Get or sets the pointer domain name (PTRDNAME).
ResourceClass | Get or sets the resource class (CLASS). (Inherited from ResourceRecord.)
ResourceType | Get or sets the resource type (TYPE). (Inherited from ResourceRecord.)
TimeInterval | Get or sets the cache time interval (TTL). (Inherited from ResourceRecord.)

See Also

PTRRecord Class


PointerName Property

[image]

ComponentSpace DNS Class Library
PTRRecord..::.PointerName Property
PTRRecord Class See Also Send Feedback
Get or sets the pointer domain name (PTRDNAME).

Namespace: ComponentSpace.Dns
Assembly: ComponentSpace.Dns (in ComponentSpace.Dns.dll) Version: 1.8.0.2

Syntax

C#
public DnsName PointerName { get; set; }
Visual Basic (Declaration)
Public Property PointerName As DnsName
Visual C++
public:
property DnsName^ PointerName {
    DnsName^ get ();
    void set (DnsName^ value);
}

Field Value

The pointer domain name.

See Also

PTRRecord Class


QueryCompletedEventArgs Class

[image]

ComponentSpace DNS Class Library
QueryCompletedEventArgs Class
Members See Also Send Feedback
Provides data for the QueryCompleted event.

Namespace: ComponentSpace.Dns
Assembly: ComponentSpace.Dns (in ComponentSpace.Dns.dll) Version: 1.8.0.2

Syntax

C#
public class QueryCompletedEventArgs : EventArgs
Visual Basic (Declaration)
Public Class QueryCompletedEventArgs _
    Inherits EventArgs
Visual C++
public ref class QueryCompletedEventArgs : public EventArgs

Remarks

The QueryCompleted event is raised by the DnsClient. It contains all the information needed to complete the asynchronous query operation.

Inheritance Hierarchy

System..::.Object
System..::.EventArgs
ComponentSpace.Dns..::.QueryCompletedEventArgs

See Also

QueryCompletedEventArgs Members


QueryCompletedEventArgs Members

[image] [image]

ComponentSpace DNS Class Library
QueryCompletedEventArgs Members
QueryCompletedEventArgs Class Methods Properties See Also Send Feedback

The QueryCompletedEventArgs type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
AsyncResult | Gets the result of the asynchronous query operation.

See Also

QueryCompletedEventArgs Class


QueryCompletedEventArgs Methods

[image] [image]

ComponentSpace DNS Class Library
QueryCompletedEventArgs Methods
QueryCompletedEventArgs Class See Also Send Feedback

The QueryCompletedEventArgs type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

QueryCompletedEventArgs Class


QueryCompletedEventArgs Properties

[image] [image]

ComponentSpace DNS Class Library
QueryCompletedEventArgs Properties
QueryCompletedEventArgs Class See Also Send Feedback

The QueryCompletedEventArgs type exposes the following members.

Properties

Name | Description
AsyncResult | Gets the result of the asynchronous query operation.

See Also

QueryCompletedEventArgs Class


AsyncResult Property

[image]

ComponentSpace DNS Class Library
QueryCompletedEventArgs..::.AsyncResult Property
QueryCompletedEventArgs Class See Also Send Feedback
Gets the result of the asynchronous query operation.

Namespace: ComponentSpace.Dns
Assembly: ComponentSpace.Dns (in ComponentSpace.Dns.dll) Version: 1.8.0.2

Syntax

C#
public IAsyncResult AsyncResult { get; }
Visual Basic (Declaration)
Public ReadOnly Property AsyncResult As IAsyncResult
Visual C++
public:
property IAsyncResult^ AsyncResult {
    IAsyncResult^ get ();
}

Field Value

An IAsyncResult that contains the data associated with the query operation.

Remarks

AsyncResult identifies ongoing or completed asynchronous operations. The property contains data that helps determine which of several potential asynchronous operations to complete, and when passed to the event handler, enables EndQuery to access the response message associated with the completed operation.

See Also

QueryCompletedEventArgs Class


QueryCompletedEventHandler Delegate

[image]

ComponentSpace DNS Class Library
QueryCompletedEventHandler Delegate
See Also Send Feedback
Represents the method that will handle the QueryCompleted event.

Namespace: ComponentSpace.Dns
Assembly: ComponentSpace.Dns (in ComponentSpace.Dns.dll) Version: 1.8.0.2

Syntax

C#
public delegate void QueryCompletedEventHandler(
    Object sender,
    QueryCompletedEventArgs e
)
Visual Basic (Declaration)
Public Delegate Sub QueryCompletedEventHandler ( _
    sender As Object, _
    e As QueryCompletedEventArgs _
)
Visual C++
public delegate void QueryCompletedEventHandler(
    Object^ sender,
    QueryCompletedEventArgs^ e
)

Parameters

sender
Type: System..::.Object
The source of the event.
e
Type: ComponentSpace.Dns..::.QueryCompletedEventArgs
A QueryCompletedEventArgs that contains the event data.

Remarks

When you create a QueryCompletedEventHandler delegate, you identify the method that will handle the event. To associate the event with your event handler, add an instance of the delegate to the event. The event handler is called whenever the event occurs, unless you remove the delegate.

See Also

ComponentSpace.Dns Namespace

Send comments on this topic to support@componentspace.com

Copyright (c) ComponentSpace Pty Ltd 2002-2008. All rights reserved.


ReceiveCompletedEventArgs Class

[image]

ComponentSpace DNS Class Library
ReceiveCompletedEventArgs Class
Members See Also Send Feedback
Provides data for the ReceiveCompleted event.

Namespace: ComponentSpace.Dns
Assembly: ComponentSpace.Dns (in ComponentSpace.Dns.dll) Version: 1.8.0.2

Syntax

C#
public class ReceiveCompletedEventArgs : EventArgs
Visual Basic (Declaration)
Public Class ReceiveCompletedEventArgs _
    Inherits EventArgs
Visual C++
public ref class ReceiveCompletedEventArgs : public EventArgs

Remarks

The ReceiveCompleted event is raised by the DnsClient. It contains all the information needed to complete the asynchronous receive operation.

Inheritance Hierarchy

System..::.Object
System..::.EventArgs
ComponentSpace.Dns..::.ReceiveCompletedEventArgs

See Also

ReceiveCompletedEventArgs Members


ReceiveCompletedEventArgs Members

[image] [image]

ComponentSpace DNS Class Library
ReceiveCompletedEventArgs Members
ReceiveCompletedEventArgs Class Methods Properties See Also Send Feedback

The ReceiveCompletedEventArgs type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
AsyncResult | Gets the result of the asynchronous receive operation.

See Also

ReceiveCompletedEventArgs Class


ReceiveCompletedEventArgs Methods

[image] [image]

ComponentSpace DNS Class Library
ReceiveCompletedEventArgs Methods
ReceiveCompletedEventArgs Class See Also Send Feedback

The ReceiveCompletedEventArgs type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

ReceiveCompletedEventArgs Class


ReceiveCompletedEventArgs Properties

[image] [image]

ComponentSpace DNS Class Library
ReceiveCompletedEventArgs Properties
ReceiveCompletedEventArgs Class See Also Send Feedback

The ReceiveCompletedEventArgs type exposes the following members.

Properties

Name | Description
AsyncResult | Gets the result of the asynchronous receive operation.

See Also

ReceiveCompletedEventArgs Class


AsyncResult Property

[image]

ComponentSpace DNS Class Library
ReceiveCompletedEventArgs..::.AsyncResult Property
ReceiveCompletedEventArgs Class See Also Send Feedback
Gets the result of the asynchronous receive operation.

Namespace: ComponentSpace.Dns
Assembly: ComponentSpace.Dns (in ComponentSpace.Dns.dll) Version: 1.8.0.2

Syntax

C#
public IAsyncResult AsyncResult { get; }
Visual Basic (Declaration)
Public ReadOnly Property AsyncResult As IAsyncResult
Visual C++
public:
property IAsyncResult^ AsyncResult {
    IAsyncResult^ get ();
}

Field Value

An IAsyncResult that contains the data associated with the receive operation.

Remarks

AsyncResult identifies ongoing or completed asynchronous operations. The property contains data that helps determine which of several potential asynchronous operations to complete, and when passed to the event handler, enables EndReceive to access the response message associated with the completed operation.

See Also

ReceiveCompletedEventArgs Class


ReceiveCompletedEventHandler Delegate

[image]

ComponentSpace DNS Class Library
ReceiveCompletedEventHandler Delegate
See Also Send Feedback
Represents the method that will handle the ReceiveCompleted event.

Namespace: ComponentSpace.Dns
Assembly: ComponentSpace.Dns (in ComponentSpace.Dns.dll) Version: 1.8.0.2

Syntax

C#
public delegate void ReceiveCompletedEventHandler(
    Object sender,
    ReceiveCompletedEventArgs e
)
Visual Basic (Declaration)
Public Delegate Sub ReceiveCompletedEventHandler ( _
    sender As Object, _
    e As ReceiveCompletedEventArgs _
)
Visual C++
public delegate void ReceiveCompletedEventHandler(
    Object^ sender,
    ReceiveCompletedEventArgs^ e
)

Parameters

sender
Type: System..::.Object
The source of the event.
e
Type: ComponentSpace.Dns..::.ReceiveCompletedEventArgs
A ReceiveCompletedEventArgs that contains the event data.

Remarks

When you create a ReceiveCompletedEventHandler delegate, you identify the method that will handle the event. To associate the event with your event handler, add an instance of the delegate to the event. The event handler is called whenever the event occurs, unless you remove the delegate.

See Also

ComponentSpace.Dns Namespace

Send comments on this topic to support@componentspace.com

Copyright (c) ComponentSpace Pty Ltd 2002-2008. All rights reserved.


ResourceRecord Class

[image]

ComponentSpace DNS Class Library
ResourceRecord Class
Members See Also Send Feedback
The base class for all resource records.

Namespace: ComponentSpace.Dns
Assembly: ComponentSpace.Dns (in ComponentSpace.Dns.dll) Version: 1.8.0.2

Syntax

C#
public abstract class ResourceRecord
Visual Basic (Declaration)
Public MustInherit Class ResourceRecord
Visual C++
public ref class ResourceRecord abstract

Inheritance Hierarchy

System..::.Object
ComponentSpace.Dns..::.ResourceRecord
ComponentSpace.Dns..::.ARecord
ComponentSpace.Dns..::.CNAMERecord
ComponentSpace.Dns..::.HINFORecord
ComponentSpace.Dns..::.MBRecord
ComponentSpace.Dns..::.MDRecord
ComponentSpace.Dns..::.MFRecord
ComponentSpace.Dns..::.MGRecord
ComponentSpace.Dns..::.MINFORecord
ComponentSpace.Dns..::.MRRecord
ComponentSpace.Dns..::.MXRecord
ComponentSpace.Dns..::.NSRecord
ComponentSpace.Dns..::.NULLRecord
ComponentSpace.Dns..::.OtherRecord
ComponentSpace.Dns..::.PTRRecord
ComponentSpace.Dns..::.SOARecord
ComponentSpace.Dns..::.TXTRecord
ComponentSpace.Dns..::.WKSRecord

See Also

ResourceRecord Members


ResourceRecord Members

[image] [image]

ComponentSpace DNS Class Library
ResourceRecord Members
ResourceRecord Class Constructors Methods Properties See Also Send Feedback

The ResourceRecord type exposes the following members.

Constructors

Name | Description
ResourceRecord | Overloaded.

Methods

Name | Description
Create | Create the correct resource record object from the byte array.
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToByteArray | Convert the resource record into a byte array.
ToString | Convert the resource record to a string. (Overrides Object..::.ToString()()().)

Properties

Name | Description
DataLength | Get or sets the number of data bytes (RDLENGTH).
DnsName | Get or sets the domain name (NAME).
ResourceClass | Get or sets the resource class (CLASS).
ResourceType | Get or sets the resource type (TYPE).
TimeInterval | Get or sets the cache time interval (TTL).

See Also

ResourceRecord Class


ResourceRecord Constructor

[image] [image]

ComponentSpace DNS Class Library
ResourceRecord Constructor
ResourceRecord Class See Also Send Feedback

Overload List

Name | Description
ResourceRecord()()() | Default constructor.
ResourceRecord(array<Byte>[]()[], Int32%, Int32%) | Construct from a byte array.

See Also

ResourceRecord Class
ResourceRecord Members


ResourceRecord Constructor

[image]

ComponentSpace DNS Class Library
ResourceRecord Constructor
ResourceRecord Class See Also Send Feedback
Default constructor.

Namespace: ComponentSpace.Dns
Assembly: ComponentSpace.Dns (in ComponentSpace.Dns.dll) Version: 1.8.0.2

Syntax

C#
public ResourceRecord()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
ResourceRecord()

See Also

ResourceRecord Class
ResourceRecord Overload


ResourceRecord Constructor (Byte[], Int32, Int32)

[image]

ComponentSpace DNS Class Library
ResourceRecord Constructor (array<Byte>[]()[], Int32%, Int32%)
ResourceRecord Class See Also Send Feedback
Construct from a byte array.

Namespace: ComponentSpace.Dns
Assembly: ComponentSpace.Dns (in ComponentSpace.Dns.dll) Version: 1.8.0.2

Syntax

C#
public ResourceRecord(
    byte[] bytes,
    ref int index,
    ref int count
)
Visual Basic (Declaration)
Public Sub New ( _
    bytes As Byte(), _
    ByRef index As Integer, _
    ByRef count As Integer _
)
Visual C++
public:
ResourceRecord(
    array<unsigned char>^ bytes,
    int% index,
    int% count
)

Parameters

bytes
Type: array< System..::.Byte >[]()[]
The byte array containing the resource record.
index
Type: System..::.Int32 %
The index into the byte array.
count
Type: System..::.Int32 %
The number of bytes available in the byte array.

See Also

ResourceRecord Class
ResourceRecord Overload


ResourceRecord Methods

[image] [image]

ComponentSpace DNS Class Library
ResourceRecord Methods
ResourceRecord Class See Also Send Feedback

The ResourceRecord type exposes the following members.

Methods

Name | Description
Create | Create the correct resource record object from the byte array.
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToByteArray | Convert the resource record into a byte array.
ToString | Convert the resource record to a string. (Overrides Object..::.ToString()()().)

See Also

ResourceRecord Class


Create Method

[image]

ComponentSpace DNS Class Library
ResourceRecord..::.Create Method
ResourceRecord Class See Also Send Feedback
Create the correct resource record object from the byte array.

Namespace: ComponentSpace.Dns
Assembly: ComponentSpace.Dns (in ComponentSpace.Dns.dll) Version: 1.8.0.2

Syntax

C#
public static ResourceRecord Create(
    byte[] bytes,
    ref int index,
    ref int count
)
Visual Basic (Declaration)
Public Shared Function Create ( _
    bytes As Byte(), _
    ByRef index As Integer, _
    ByRef count As Integer _
) As ResourceRecord
Visual C++
public:
static ResourceRecord^ Create(
    array<unsigned char>^ bytes,
    int% index,
    int% count
)

Parameters

bytes
Type: array< System..::.Byte >[]()[]
The byte array containing the resource record.
index
Type: System..::.Int32 %
The index into the byte array.
count
Type: System..::.Int32 %
The number of bytes available in the byte array.

Return Value

[Missing <returns> documentation for M:ComponentSpace.Dns.ResourceRecord.Create(System.Byte[],System.Int32@,System.Int32@)]

Remarks

If the resource record type is unknown then an OtherRecord object is returned.

See Also

ResourceRecord Class


ToByteArray Method

[image]

ComponentSpace DNS Class Library
ResourceRecord..::.ToByteArray Method
ResourceRecord Class See Also Send Feedback
Convert the resource record into a byte array.

Namespace: ComponentSpace.Dns
Assembly: ComponentSpace.Dns (in ComponentSpace.Dns.dll) Version: 1.8.0.2

Syntax

C#
public virtual byte[] ToByteArray()
Visual Basic (Declaration)
Public Overridable Function ToByteArray As Byte()
Visual C++
public:
virtual array<unsigned char>^ ToByteArray()

Return Value

The byte array containing the resource record.

See Also

ResourceRecord Class


ToString Method

[image]

ComponentSpace DNS Class Library
ResourceRecord..::.ToString Method
ResourceRecord Class See Also Send Feedback
Convert the resource record to a string.

Namespace: ComponentSpace.Dns
Assembly: ComponentSpace.Dns (in ComponentSpace.Dns.dll) Version: 1.8.0.2

Syntax

C#
public override string ToString()
Visual Basic (Declaration)
Public Overrides Function ToString As String
Visual C++
public:
virtual String^ ToString() override

Return Value

The resource record as a string.

See Also

ResourceRecord Class


ResourceRecord Properties

[image] [image]

ComponentSpace DNS Class Library
ResourceRecord Properties
ResourceRecord Class See Also Send Feedback

The ResourceRecord type exposes the following members.

Properties

Name | Description
DataLength | Get or sets the number of data bytes (RDLENGTH).
DnsName | Get or sets the domain name (NAME).
ResourceClass | Get or sets the resource class (CLASS).
ResourceType | Get or sets the resource type (TYPE).
TimeInterval | Get or sets the cache time interval (TTL).

See Also

ResourceRecord Class


DataLength Property

[image]

ComponentSpace DNS Class Library
ResourceRecord..::.DataLength Property
ResourceRecord Class See Also Send Feedback
Get or sets the number of data bytes (RDLENGTH).

Namespace: ComponentSpace.Dns
Assembly: ComponentSpace.Dns (in ComponentSpace.Dns.dll) Version: 1.8.0.2

Syntax

C#
public int DataLength { get; set; }
Visual Basic (Declaration)
Public Property DataLength As Integer
Visual C++
public:
property int DataLength {
    int get ();
    void set (int value);
}

Field Value

The number of data bytes.

See Also

ResourceRecord Class


DnsName Property

[image]

ComponentSpace DNS Class Library
ResourceRecord..::.DnsName Property
ResourceRecord Class See Also Send Feedback
Get or sets the domain name (NAME).

Namespace: ComponentSpace.Dns
Assembly: ComponentSpace.Dns (in ComponentSpace.Dns.dll) Version: 1.8.0.2

Syntax

C#
public string DnsName { get; set; }
Visual Basic (Declaration)
Public Property DnsName As String
Visual C++
public:
property String^ DnsName {
    String^ get ();
    void set (String^ value);
}

Field Value

The domain name.

See Also

ResourceRecord Class


ResourceClass Property

[image]

ComponentSpace DNS Class Library
ResourceRecord..::.ResourceClass Property
ResourceRecord Class See Also Send Feedback
Get or sets the resource class (CLASS).

Namespace: ComponentSpace.Dns
Assembly: ComponentSpace.Dns (in ComponentSpace.Dns.dll) Version: 1.8.0.2

Syntax

C#
public int ResourceClass { get; set; }
Visual Basic (Declaration)
Public Property ResourceClass As Integer
Visual C++
public:
property int ResourceClass {
    int get ();
    void set (int value);
}

Field Value

The resource class. See ResourceRecord..::.RRClasses.

See Also

ResourceRecord Class


ResourceType Property

[image]

ComponentSpace DNS Class Library
ResourceRecord..::.ResourceType Property
ResourceRecord Class See Also Send Feedback
Get or sets the resource type (TYPE).

Namespace: ComponentSpace.Dns
Assembly: ComponentSpace.Dns (in ComponentSpace.Dns.dll) Version: 1.8.0.2

Syntax

C#
public int ResourceType { get; set; }
Visual Basic (Declaration)
Public Property ResourceType As Integer
Visual C++
public:
property int ResourceType {
    int get ();
    void set (int value);
}

Field Value

The resource type. See ResourceRecord..::.RRTypes.

See Also

ResourceRecord Class


TimeInterval Property

[image]

ComponentSpace DNS Class Library
ResourceRecord..::.TimeInterval Property
ResourceRecord Class See Also Send Feedback
Get or sets the cache time interval (TTL).

Namespace: ComponentSpace.Dns
Assembly: ComponentSpace.Dns (in ComponentSpace.Dns.dll) Version: 1.8.0.2

Syntax

C#
public int TimeInterval { get; set; }
Visual Basic (Declaration)
Public Property TimeInterval As Integer
Visual C++
public:
property int TimeInterval {
    int get ();
    void set (int value);
}

Field Value

The cache time interval.

See Also

ResourceRecord Class


ResourceRecord.RRClasses Enumeration

[image]

ComponentSpace DNS Class Library
ResourceRecord..::.RRClasses Enumeration
ResourceRecord Class See Also Send Feedback
The resource record classes (CLASS).

Namespace: ComponentSpace.Dns
Assembly: ComponentSpace.Dns (in ComponentSpace.Dns.dll) Version: 1.8.0.2

Syntax

C#
public enum RRClasses
Visual Basic (Declaration)
Public Enumeration RRClasses
Visual C++
public enum class RRClasses

Members

Member name | Description
IN | Internet.
CS | CSNET (obselete).
CH | CHAOS.
HS | Hesiod.

Remarks

The resource record classes are a subset of the DnsQuestion..::.QClasses.

See Also

ComponentSpace.Dns Namespace

Send comments on this topic to support@componentspace.com

Copyright (c) ComponentSpace Pty Ltd 2002-2008. All rights reserved.


ResourceRecord.RRTypes Enumeration

[image]

ComponentSpace DNS Class Library
ResourceRecord..::.RRTypes Enumeration
ResourceRecord Class See Also Send Feedback
The resource record types (TYPE).

Namespace: ComponentSpace.Dns
Assembly: ComponentSpace.Dns (in ComponentSpace.Dns.dll) Version: 1.8.0.2

Syntax

C#
public enum RRTypes
Visual Basic (Declaration)
Public Enumeration RRTypes
Visual C++
public enum class RRTypes

Members

Member name | Description
A | Host address.
NS | Authoritative name server.
MD | Mail destination (obselete).
MF | Mail forwarder (obselete).
CNAME | Canonical name for alias.
SOA | Start of zone authority.
MB | Mailbox domain name.
MG | Mail group member.
MR | Mail rename domain name.
NULL | Null.
WKS | Well known service description.
PTR | Domain name pointer.
HINFO | Host informatiopn.
MINFO | Mailbox or mail list information.
MX | Mail exchange.
TXT | Text strings.
RP | RP.
AFSDB | AFSDB.
X25 | X25.
ISDN | ISDN.
RT | RT.
NSAP | NSAP.
NSAPPTR | NSAPPTR.
SIG | SIG.
KEY | KEY.
PX | PX.
GPOS | GPOS.
AAAA | AAAA.
LOC | LOC.
NXT | NXT.
SRV | SRV.
ATMA | ATMA.

Remarks

The resource record types are a subset of the DnsQuestion..::.QTypes.

See Also

ComponentSpace.Dns Namespace

Send comments on this topic to support@componentspace.com

Copyright (c) ComponentSpace Pty Ltd 2002-2008. All rights reserved.


SendCompletedEventArgs Class

[image]

ComponentSpace DNS Class Library
SendCompletedEventArgs Class
Members See Also Send Feedback
Provides data for the SendCompleted event.

Namespace: ComponentSpace.Dns
Assembly: ComponentSpace.Dns (in ComponentSpace.Dns.dll) Version: 1.8.0.2

Syntax

C#
public class SendCompletedEventArgs : EventArgs
Visual Basic (Declaration)
Public Class SendCompletedEventArgs _
    Inherits EventArgs
Visual C++
public ref class SendCompletedEventArgs : public EventArgs

Remarks

The SendCompleted event is raised by the DnsClient. It contains all the information needed to complete the asynchronous send operation.

Inheritance Hierarchy

System..::.Object
System..::.EventArgs
ComponentSpace.Dns..::.SendCompletedEventArgs

See Also

SendCompletedEventArgs Members


SendCompletedEventArgs Members

[image] [image]

ComponentSpace DNS Class Library
SendCompletedEventArgs Members
SendCompletedEventArgs Class Methods Properties See Also Send Feedback

The SendCompletedEventArgs type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
AsyncResult | Gets the result of the asynchronous send operation.

See Also

SendCompletedEventArgs Class


SendCompletedEventArgs Methods

[image] [image]

ComponentSpace DNS Class Library
SendCompletedEventArgs Methods
SendCompletedEventArgs Class See Also Send Feedback

The SendCompletedEventArgs type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

SendCompletedEventArgs Class


SendCompletedEventArgs Properties

[image] [image]

ComponentSpace DNS Class Library
SendCompletedEventArgs Properties
SendCompletedEventArgs Class See Also Send Feedback

The SendCompletedEventArgs type exposes the following members.

Properties

Name | Description
AsyncResult | Gets the result of the asynchronous send operation.

See Also

SendCompletedEventArgs Class


AsyncResult Property

[image]

ComponentSpace DNS Class Library
SendCompletedEventArgs..::.AsyncResult Property
SendCompletedEventArgs Class See Also Send Feedback
Gets the result of the asynchronous send operation.

Namespace: ComponentSpace.Dns
Assembly: ComponentSpace.Dns (in ComponentSpace.Dns.dll) Version: 1.8.0.2

Syntax

C#
public IAsyncResult AsyncResult { get; }
Visual Basic (Declaration)
Public ReadOnly Property AsyncResult As IAsyncResult
Visual C++
public:
property IAsyncResult^ AsyncResult {
    IAsyncResult^ get ();
}

Field Value

An IAsyncResult that contains the data associated with the send operation.

Remarks

AsyncResult identifies ongoing or completed asynchronous operations. The property contains data that helps determine which of several potential asynchronous operations to complete, and when passed to the event handler, enables EndSend to access the response message associated with the completed operation.

See Also

SendCompletedEventArgs Class


SendCompletedEventHandler Delegate

[image]

ComponentSpace DNS Class Library
SendCompletedEventHandler Delegate
See Also Send Feedback
Represents the method that will handle the SendCompleted event.

Namespace: ComponentSpace.Dns
Assembly: ComponentSpace.Dns (in ComponentSpace.Dns.dll) Version: 1.8.0.2

Syntax

C#
public delegate void SendCompletedEventHandler(
    Object sender,
    SendCompletedEventArgs e
)
Visual Basic (Declaration)
Public Delegate Sub SendCompletedEventHandler ( _
    sender As Object, _
    e As SendCompletedEventArgs _
)
Visual C++
public delegate void SendCompletedEventHandler(
    Object^ sender,
    SendCompletedEventArgs^ e
)

Parameters

sender
Type: System..::.Object
The source of the event.
e
Type: ComponentSpace.Dns..::.SendCompletedEventArgs
A SendCompletedEventArgs that contains the event data.

Remarks

When you create a SendCompletedEventHandler delegate, you identify the method that will handle the event. To associate the event with your event handler, add an instance of the delegate to the event. The event handler is called whenever the event occurs, unless you remove the delegate.

See Also

ComponentSpace.Dns Namespace

Send comments on this topic to support@componentspace.com

Copyright (c) ComponentSpace Pty Ltd 2002-2008. All rights reserved.


SOARecord Class

[image]

ComponentSpace DNS Class Library
SOARecord Class
Members See Also Send Feedback
A start of zone of authority resource record.

Namespace: ComponentSpace.Dns
Assembly: ComponentSpace.Dns (in ComponentSpace.Dns.dll) Version: 1.8.0.2

Syntax

C#
public class SOARecord : ResourceRecord
Visual Basic (Declaration)
Public Class SOARecord _
    Inherits ResourceRecord
Visual C++
public ref class SOARecord : public ResourceRecord

Inheritance Hierarchy

System..::.Object
ComponentSpace.Dns..::.ResourceRecord
ComponentSpace.Dns..::.SOARecord

See Also

SOARecord Members


SOARecord Members

[image] [image]

ComponentSpace DNS Class Library
SOARecord Members
SOARecord Class Constructors Methods Properties See Also Send Feedback

The SOARecord type exposes the following members.

Constructors

Name | Description
SOARecord | Overloaded.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToByteArray | Convert the resource record into a byte array. (Overrides ResourceRecord..::.ToByteArray()()().)
ToString | Convert the resource record to a string. (Overrides ResourceRecord..::.ToString()()().)

Properties

Name | Description
DataLength | Get or sets the number of data bytes (RDLENGTH). (Inherited from ResourceRecord.)
DnsName | Get or sets the domain name (NAME). (Inherited from ResourceRecord.)
ExpiryInterval | Get or sets the zone expiry interval (EXPIRE).
MinimumInterval | Get or sets the minimum TTL that should be exported with and RR from this zone (MINIMUM).
PrimaryNameServer | Get or sets the primary source name server (MNAME).
RefreshInterval | Get or sets the zone refresh interval (REFRESH).
ResourceClass | Get or sets the resource class (CLASS). (Inherited from ResourceRecord.)
ResourceType | Get or sets the resource type (TYPE). (Inherited from ResourceRecord.)
ResponsibleMailbox | Get or sets the mailbox of the responsible person (RNAME).
RetryInterval | Get or sets the retry interval for a failed refresh (RETRY).
TimeInterval | Get or sets the cache time interval (TTL). (Inherited from ResourceRecord.)
VersionNumber | Get or sets the version number of the original copy of the zone (SERIAL).

See Also

SOARecord Class


SOARecord Constructor

[image] [image]

ComponentSpace DNS Class Library
SOARecord Constructor
SOARecord Class See Also Send Feedback

Overload List

Name | Description
SOARecord()()() | Default constructor.
SOARecord(array<Byte>[]()[], Int32%, Int32%) | Construct from a byte array.

See Also

SOARecord Class
SOARecord Members


SOARecord Constructor

[image]

ComponentSpace DNS Class Library
SOARecord Constructor
SOARecord Class See Also Send Feedback
Default constructor.

Namespace: ComponentSpace.Dns
Assembly: ComponentSpace.Dns (in ComponentSpace.Dns.dll) Version: 1.8.0.2

Syntax

C#
public SOARecord()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
SOARecord()

See Also

SOARecord Class
SOARecord Overload


SOARecord Constructor (Byte[], Int32, Int32)

[image]

ComponentSpace DNS Class Library
SOARecord Constructor (array<Byte>[]()[], Int32%, Int32%)
SOARecord Class See Also Send Feedback
Construct from a byte array.

Namespace: ComponentSpace.Dns
Assembly: ComponentSpace.Dns (in ComponentSpace.Dns.dll) Version: 1.8.0.2

Syntax

C#
public SOARecord(
    byte[] bytes,
    ref int index,
    ref int count
)
Visual Basic (Declaration)
Public Sub New ( _
    bytes As Byte(), _
    ByRef index As Integer, _
    ByRef count As Integer _
)
Visual C++
public:
SOARecord(
    array<unsigned char>^ bytes,
    int% index,
    int% count
)

Parameters

bytes
Type: array< System..::.Byte >[]()[]
The byte array containing the resource record.
index
Type: System..::.Int32 %
The index into the byte array.
count
Type: System..::.Int32 %
The number of bytes available in the byte array.

See Also

SOARecord Class
SOARecord Overload


SOARecord Methods

[image] [image]

ComponentSpace DNS Class Library
SOARecord Methods
SOARecord Class See Also Send Feedback

The SOARecord type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToByteArray | Convert the resource record into a byte array. (Overrides ResourceRecord..::.ToByteArray()()().)
ToString | Convert the resource record to a string. (Overrides ResourceRecord..::.ToString()()().)

See Also

SOARecord Class


ToByteArray Method

[image]

ComponentSpace DNS Class Library
SOARecord..::.ToByteArray Method
SOARecord Class See Also Send Feedback
Convert the resource record into a byte array.

Namespace: ComponentSpace.Dns
Assembly: ComponentSpace.Dns (in ComponentSpace.Dns.dll) Version: 1.8.0.2

Syntax

C#
public override byte[] ToByteArray()
Visual Basic (Declaration)
Public Overrides Function ToByteArray As Byte()
Visual C++
public:
virtual array<unsigned char>^ ToByteArray() override

Return Value

The byte array containing the resource record.

See Also

SOARecord Class


ToString Method

[image]

ComponentSpace DNS Class Library
SOARecord..::.ToString Method
SOARecord Class See Also Send Feedback
Convert the resource record to a string.

Namespace: ComponentSpace.Dns
Assembly: ComponentSpace.Dns (in ComponentSpace.Dns.dll) Version: 1.8.0.2

Syntax

C#
public override string ToString()
Visual Basic (Declaration)
Public Overrides Function ToString As String
Visual C++
public:
virtual String^ ToString() override

Return Value

The resource record as a string.

See Also

SOARecord Class


SOARecord Properties

[image] [image]

ComponentSpace DNS Class Library
SOARecord Properties
SOARecord Class See Also Send Feedback

The SOARecord type exposes the following members.

Properties

Name | Description
DataLength | Get or sets the number of data bytes (RDLENGTH). (Inherited from ResourceRecord.)
DnsName | Get or sets the domain name (NAME). (Inherited from ResourceRecord.)
ExpiryInterval | Get or sets the zone expiry interval (EXPIRE).
MinimumInterval | Get or sets the minimum TTL that should be exported with and RR from this zone (MINIMUM).
PrimaryNameServer | Get or sets the primary source name server (MNAME).
RefreshInterval | Get or sets the zone refresh interval (REFRESH).
ResourceClass | Get or sets the resource class (CLASS). (Inherited from ResourceRecord.)
ResourceType | Get or sets the resource type (TYPE). (Inherited from ResourceRecord.)
ResponsibleMailbox | Get or sets the mailbox of the responsible person (RNAME).
RetryInterval | Get or sets the retry interval for a failed refresh (RETRY).
TimeInterval | Get or sets the cache time interval (TTL). (Inherited from ResourceRecord.)
VersionNumber | Get or sets the version number of the original copy of the zone (SERIAL).

See Also

SOARecord Class


ExpiryInterval Property

[image]

ComponentSpace DNS Class Library
SOARecord..::.ExpiryInterval Property
SOARecord Class See Also Send Feedback
Get or sets the zone expiry interval (EXPIRE).

Namespace: ComponentSpace.Dns
Assembly: ComponentSpace.Dns (in ComponentSpace.Dns.dll) Version: 1.8.0.2

Syntax

C#
public int ExpiryInterval { get; set; }
Visual Basic (Declaration)
Public Property ExpiryInterval As Integer
Visual C++
public:
property int ExpiryInterval {
    int get ();
    void set (int value);
}

Field Value

The expiry interval.

See Also

SOARecord Class


MinimumInterval Property

[image]

ComponentSpace DNS Class Library
SOARecord..::.MinimumInterval Property
SOARecord Class See Also Send Feedback
Get or sets the minimum TTL that should be exported with and RR from this zone (MINIMUM).

Namespace: ComponentSpace.Dns
Assembly: ComponentSpace.Dns (in ComponentSpace.Dns.dll) Version: 1.8.0.2

Syntax

C#
public int MinimumInterval { get; set; }
Visual Basic (Declaration)
Public Property MinimumInterval As Integer
Visual C++
public:
property int MinimumInterval {
    int get ();
    void set (int value);
}

Field Value

The minimum interval.

See Also

SOARecord Class


PrimaryNameServer Property

[image]

ComponentSpace DNS Class Library
SOARecord..::.PrimaryNameServer Property
SOARecord Class See Also Send Feedback
Get or sets the primary source name server (MNAME).

Namespace: ComponentSpace.Dns
Assembly: ComponentSpace.Dns (in ComponentSpace.Dns.dll) Version: 1.8.0.2

Syntax

C#
public DnsName PrimaryNameServer { get; set; }
Visual Basic (Declaration)
Public Property PrimaryNameServer As DnsName
Visual C++
public:
property DnsName^ PrimaryNameServer {
    DnsName^ get ();
    void set (DnsName^ value);
}

Field Value

The primary source name server.

See Also

SOARecord Class


RefreshInterval Property

[image]

ComponentSpace DNS Class Library
SOARecord..::.RefreshInterval Property
SOARecord Class See Also Send Feedback
Get or sets the zone refresh interval (REFRESH).

Namespace: ComponentSpace.Dns
Assembly: ComponentSpace.Dns (in ComponentSpace.Dns.dll) Version: 1.8.0.2

Syntax

C#
public int RefreshInterval { get; set; }
Visual Basic (Declaration)
Public Property RefreshInterval As Integer
Visual C++
public:
property int RefreshInterval {
    int get ();
    void set (int value);
}

Field Value

The zone refresh interval.

See Also

SOARecord Class


ResponsibleMailbox Property

[image]

ComponentSpace DNS Class Library
SOARecord..::.ResponsibleMailbox Property
SOARecord Class See Also Send Feedback
Get or sets the mailbox of the responsible person (RNAME).

Namespace: ComponentSpace.Dns
Assembly: ComponentSpace.Dns (in ComponentSpace.Dns.dll) Version: 1.8.0.2

Syntax

C#
public DnsName ResponsibleMailbox { get; set; }
Visual Basic (Declaration)
Public Property ResponsibleMailbox As DnsName
Visual C++
public:
property DnsName^ ResponsibleMailbox {
    DnsName^ get ();
    void set (DnsName^ value);
}

Field Value

The mailbox of the responsible person.

See Also

SOARecord Class


RetryInterval Property

[image]

ComponentSpace DNS Class Library
SOARecord..::.RetryInterval Property
SOARecord Class See Also Send Feedback
Get or sets the retry interval for a failed refresh (RETRY).

Namespace: ComponentSpace.Dns
Assembly: ComponentSpace.Dns (in ComponentSpace.Dns.dll) Version: 1.8.0.2

Syntax

C#
public int RetryInterval { get; set; }
Visual Basic (Declaration)
Public Property RetryInterval As Integer
Visual C++
public:
property int RetryInterval {
    int get ();
    void set (int value);
}

Field Value

The retry interval.

See Also

SOARecord Class


VersionNumber Property

[image]

ComponentSpace DNS Class Library
SOARecord..::.VersionNumber Property
SOARecord Class See Also Send Feedback
Get or sets the version number of the original copy of the zone (SERIAL).

Namespace: ComponentSpace.Dns
Assembly: ComponentSpace.Dns (in ComponentSpace.Dns.dll) Version: 1.8.0.2

Syntax

C#
public int VersionNumber { get; set; }
Visual Basic (Declaration)
Public Property VersionNumber As Integer
Visual C++
public:
property int VersionNumber {
    int get ();
    void set (int value);
}

Field Value

The version number.

See Also

SOARecord Class


TXTRecord Class

[image]

ComponentSpace DNS Class Library
TXTRecord Class
Members See Also Send Feedback
A text strings resource record.

Namespace: ComponentSpace.Dns
Assembly: ComponentSpace.Dns (in ComponentSpace.Dns.dll) Version: 1.8.0.2

Syntax

C#
public class TXTRecord : ResourceRecord
Visual Basic (Declaration)
Public Class TXTRecord _
    Inherits ResourceRecord
Visual C++
public ref class TXTRecord : public ResourceRecord

Inheritance Hierarchy

System..::.Object
ComponentSpace.Dns..::.ResourceRecord
ComponentSpace.Dns..::.TXTRecord

See Also

TXTRecord Members


TXTRecord Members

[image] [image]

ComponentSpace DNS Class Library
TXTRecord Members
TXTRecord Class Constructors Methods Properties See Also Send Feedback

The TXTRecord type exposes the following members.

Constructors

Name | Description
TXTRecord | Overloaded.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToByteArray | Convert the resource record into a byte array. (Overrides ResourceRecord..::.ToByteArray()()().)
ToString | Convert the resource record to a string. (Overrides ResourceRecord..::.ToString()()().)

Properties

Name | Description
DataLength | Get or sets the number of data bytes (RDLENGTH). (Inherited from ResourceRecord.)
DnsName | Get or sets the domain name (NAME). (Inherited from ResourceRecord.)
ResourceClass | Get or sets the resource class (CLASS). (Inherited from ResourceRecord.)
ResourceType | Get or sets the resource type (TYPE). (Inherited from ResourceRecord.)
Text | Get or sets the text (TXT-DATA).
TimeInterval | Get or sets the cache time interval (TTL). (Inherited from ResourceRecord.)

See Also

TXTRecord Class


TXTRecord Constructor

[image] [image]

ComponentSpace DNS Class Library
TXTRecord Constructor
TXTRecord Class See Also Send Feedback

Overload List

Name | Description
TXTRecord()()() | Default constructor.
TXTRecord(array<Byte>[]()[], Int32%, Int32%) | Construct from a byte array.

See Also

TXTRecord Class
TXTRecord Members


TXTRecord Constructor

[image]

ComponentSpace DNS Class Library
TXTRecord Constructor
TXTRecord Class See Also Send Feedback
Default constructor.

Namespace: ComponentSpace.Dns
Assembly: ComponentSpace.Dns (in ComponentSpace.Dns.dll) Version: 1.8.0.2

Syntax

C#
public TXTRecord()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
TXTRecord()

See Also

TXTRecord Class
TXTRecord Overload


TXTRecord Constructor (Byte[], Int32, Int32)

[image]

ComponentSpace DNS Class Library
TXTRecord Constructor (array<Byte>[]()[], Int32%, Int32%)
TXTRecord Class See Also Send Feedback
Construct from a byte array.

Namespace: ComponentSpace.Dns
Assembly: ComponentSpace.Dns (in ComponentSpace.Dns.dll) Version: 1.8.0.2

Syntax

C#
public TXTRecord(
    byte[] bytes,
    ref int index,
    ref int count
)
Visual Basic (Declaration)
Public Sub New ( _
    bytes As Byte(), _
    ByRef index As Integer, _
    ByRef count As Integer _
)
Visual C++
public:
TXTRecord(
    array<unsigned char>^ bytes,
    int% index,
    int% count
)

Parameters

bytes
Type: array< System..::.Byte >[]()[]
The byte array containing the resource record.
index
Type: System..::.Int32 %
The index into the byte array.
count
Type: System..::.Int32 %
The number of bytes available in the byte array.

See Also

TXTRecord Class
TXTRecord Overload


TXTRecord Methods

[image] [image]

ComponentSpace DNS Class Library
TXTRecord Methods
TXTRecord Class See Also Send Feedback

The TXTRecord type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToByteArray | Convert the resource record into a byte array. (Overrides ResourceRecord..::.ToByteArray()()().)
ToString | Convert the resource record to a string. (Overrides ResourceRecord..::.ToString()()().)

See Also

TXTRecord Class


ToByteArray Method

[image]

ComponentSpace DNS Class Library
TXTRecord..::.ToByteArray Method
TXTRecord Class See Also Send Feedback
Convert the resource record into a byte array.

Namespace: ComponentSpace.Dns
Assembly: ComponentSpace.Dns (in ComponentSpace.Dns.dll) Version: 1.8.0.2

Syntax

C#
public override byte[] ToByteArray()
Visual Basic (Declaration)
Public Overrides Function ToByteArray As Byte()
Visual C++
public:
virtual array<unsigned char>^ ToByteArray() override

Return Value

The byte array containing the resource record.

See Also

TXTRecord Class


ToString Method

[image]

ComponentSpace DNS Class Library
TXTRecord..::.ToString Method
TXTRecord Class See Also Send Feedback
Convert the resource record to a string.

Namespace: ComponentSpace.Dns
Assembly: ComponentSpace.Dns (in ComponentSpace.Dns.dll) Version: 1.8.0.2

Syntax

C#
public override string ToString()
Visual Basic (Declaration)
Public Overrides Function ToString As String
Visual C++
public:
virtual String^ ToString() override

Return Value

The resource record as a string.

See Also

TXTRecord Class


TXTRecord Properties

[image] [image]

ComponentSpace DNS Class Library
TXTRecord Properties
TXTRecord Class See Also Send Feedback

The TXTRecord type exposes the following members.

Properties

Name | Description
DataLength | Get or sets the number of data bytes (RDLENGTH). (Inherited from ResourceRecord.)
DnsName | Get or sets the domain name (NAME). (Inherited from ResourceRecord.)
ResourceClass | Get or sets the resource class (CLASS). (Inherited from ResourceRecord.)
ResourceType | Get or sets the resource type (TYPE). (Inherited from ResourceRecord.)
Text | Get or sets the text (TXT-DATA).
TimeInterval | Get or sets the cache time interval (TTL). (Inherited from ResourceRecord.)

See Also

TXTRecord Class


Text Property

[image]

ComponentSpace DNS Class Library
TXTRecord..::.Text Property
TXTRecord Class See Also Send Feedback
Get or sets the text (TXT-DATA).

Namespace: ComponentSpace.Dns
Assembly: ComponentSpace.Dns (in ComponentSpace.Dns.dll) Version: 1.8.0.2

Syntax

C#
public DnsString Text { get; set; }
Visual Basic (Declaration)
Public Property Text As DnsString
Visual C++
public:
property DnsString^ Text {
    DnsString^ get ();
    void set (DnsString^ value);
}

Field Value

The address.

See Also

TXTRecord Class


WKSRecord Class

[image]

ComponentSpace DNS Class Library
WKSRecord Class
Members See Also Send Feedback
A well known service description resource record.

Namespace: ComponentSpace.Dns
Assembly: ComponentSpace.Dns (in ComponentSpace.Dns.dll) Version: 1.8.0.2

Syntax

C#
public class WKSRecord : ResourceRecord
Visual Basic (Declaration)
Public Class WKSRecord _
    Inherits ResourceRecord
Visual C++
public ref class WKSRecord : public ResourceRecord

Inheritance Hierarchy

System..::.Object
ComponentSpace.Dns..::.ResourceRecord
ComponentSpace.Dns..::.WKSRecord

See Also

WKSRecord Members


WKSRecord Members

[image] [image]

ComponentSpace DNS Class Library
WKSRecord Members
WKSRecord Class Constructors Methods Properties See Also Send Feedback

The WKSRecord type exposes the following members.

Constructors

Name | Description
WKSRecord | Overloaded.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToByteArray | Convert the resource record into a byte array. (Overrides ResourceRecord..::.ToByteArray()()().)
ToString | Convert the resource record to a string. (Overrides ResourceRecord..::.ToString()()().)

Properties

Name | Description
Address | Get or sets the address (ADDRESS).
BitMap | Get or sets the bitmap (BITMAP).
DataLength | Get or sets the number of data bytes (RDLENGTH). (Inherited from ResourceRecord.)
DnsName | Get or sets the domain name (NAME). (Inherited from ResourceRecord.)
ProtocolNumber | Get or sets the IP protocol number (PROTOCOL).
ResourceClass | Get or sets the resource class (CLASS). (Inherited from ResourceRecord.)
ResourceType | Get or sets the resource type (TYPE). (Inherited from ResourceRecord.)
TimeInterval | Get or sets the cache time interval (TTL). (Inherited from ResourceRecord.)

See Also

WKSRecord Class


WKSRecord Constructor

[image] [image]

ComponentSpace DNS Class Library
WKSRecord Constructor
WKSRecord Class See Also Send Feedback

Overload List

Name | Description
WKSRecord()()() | Default constructor.
WKSRecord(array<Byte>[]()[], Int32%, Int32%) | Construct from a byte array.

See Also

WKSRecord Class
WKSRecord Members


WKSRecord Constructor

[image]

ComponentSpace DNS Class Library
WKSRecord Constructor
WKSRecord Class See Also Send Feedback
Default constructor.

Namespace: ComponentSpace.Dns
Assembly: ComponentSpace.Dns (in ComponentSpace.Dns.dll) Version: 1.8.0.2

Syntax

C#
public WKSRecord()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
WKSRecord()

See Also

WKSRecord Class
WKSRecord Overload


WKSRecord Constructor (Byte[], Int32, Int32)

[image]

ComponentSpace DNS Class Library
WKSRecord Constructor (array<Byte>[]()[], Int32%, Int32%)
WKSRecord Class See Also Send Feedback
Construct from a byte array.

Namespace: ComponentSpace.Dns
Assembly: ComponentSpace.Dns (in ComponentSpace.Dns.dll) Version: 1.8.0.2

Syntax

C#
public WKSRecord(
    byte[] bytes,
    ref int index,
    ref int count
)
Visual Basic (Declaration)
Public Sub New ( _
    bytes As Byte(), _
    ByRef index As Integer, _
    ByRef count As Integer _
)
Visual C++
public:
WKSRecord(
    array<unsigned char>^ bytes,
    int% index,
    int% count
)

Parameters

bytes
Type: array< System..::.Byte >[]()[]
The byte array containing the resource record.
index
Type: System..::.Int32 %
The index into the byte array.
count
Type: System..::.Int32 %
The number of bytes available in the byte array.

See Also

WKSRecord Class
WKSRecord Overload


WKSRecord Methods

[image] [image]

ComponentSpace DNS Class Library
WKSRecord Methods
WKSRecord Class See Also Send Feedback

The WKSRecord type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToByteArray | Convert the resource record into a byte array. (Overrides ResourceRecord..::.ToByteArray()()().)
ToString | Convert the resource record to a string. (Overrides ResourceRecord..::.ToString()()().)

See Also

WKSRecord Class


ToByteArray Method

[image]

ComponentSpace DNS Class Library
WKSRecord..::.ToByteArray Method
WKSRecord Class See Also Send Feedback
Convert the resource record into a byte array.

Namespace: ComponentSpace.Dns
Assembly: ComponentSpace.Dns (in ComponentSpace.Dns.dll) Version: 1.8.0.2

Syntax

C#
public override byte[] ToByteArray()
Visual Basic (Declaration)
Public Overrides Function ToByteArray As Byte()
Visual C++
public:
virtual array<unsigned char>^ ToByteArray() override

Return Value

The byte array containing the resource record.

See Also

WKSRecord Class


ToString Method

[image]

ComponentSpace DNS Class Library
WKSRecord..::.ToString Method
WKSRecord Class See Also Send Feedback
Convert the resource record to a string.

Namespace: ComponentSpace.Dns
Assembly: ComponentSpace.Dns (in ComponentSpace.Dns.dll) Version: 1.8.0.2

Syntax

C#
public override string ToString()
Visual Basic (Declaration)
Public Overrides Function ToString As String
Visual C++
public:
virtual String^ ToString() override

Return Value

The resource record as a string.

See Also

WKSRecord Class


WKSRecord Properties

[image] [image]

ComponentSpace DNS Class Library
WKSRecord Properties
WKSRecord Class See Also Send Feedback

The WKSRecord type exposes the following members.

Properties

Name | Description
Address | Get or sets the address (ADDRESS).
BitMap | Get or sets the bitmap (BITMAP).
DataLength | Get or sets the number of data bytes (RDLENGTH). (Inherited from ResourceRecord.)
DnsName | Get or sets the domain name (NAME). (Inherited from ResourceRecord.)
ProtocolNumber | Get or sets the IP protocol number (PROTOCOL).
ResourceClass | Get or sets the resource class (CLASS). (Inherited from ResourceRecord.)
ResourceType | Get or sets the resource type (TYPE). (Inherited from ResourceRecord.)
TimeInterval | Get or sets the cache time interval (TTL). (Inherited from ResourceRecord.)

See Also

WKSRecord Class


Address Property

[image]

ComponentSpace DNS Class Library
WKSRecord..::.Address Property
WKSRecord Class See Also Send Feedback
Get or sets the address (ADDRESS).

Namespace: ComponentSpace.Dns
Assembly: ComponentSpace.Dns (in ComponentSpace.Dns.dll) Version: 1.8.0.2

Syntax

C#
public long Address { get; set; }
Visual Basic (Declaration)
Public Property Address As Long
Visual C++
public:
property long long Address {
    long long get ();
    void set (long long value);
}

Field Value

The address.

See Also

WKSRecord Class


BitMap Property

[image]

ComponentSpace DNS Class Library
WKSRecord..::.BitMap Property
WKSRecord Class See Also Send Feedback
Get or sets the bitmap (BITMAP).

Namespace: ComponentSpace.Dns
Assembly: ComponentSpace.Dns (in ComponentSpace.Dns.dll) Version: 1.8.0.2

Syntax

C#
public byte[] BitMap { get; set; }
Visual Basic (Declaration)
Public Property BitMap As Byte()
Visual C++
public:
property array<unsigned char>^ BitMap {
    array<unsigned char>^ get ();
    void set (array<unsigned char>^ value);
}

Field Value

The bitmap.

See Also

WKSRecord Class


ProtocolNumber Property

[image]

ComponentSpace DNS Class Library
WKSRecord..::.ProtocolNumber Property
WKSRecord Class See Also Send Feedback
Get or sets the IP protocol number (PROTOCOL).

Namespace: ComponentSpace.Dns
Assembly: ComponentSpace.Dns (in ComponentSpace.Dns.dll) Version: 1.8.0.2

Syntax

C#
public byte ProtocolNumber { get; set; }
Visual Basic (Declaration)
Public Property ProtocolNumber As Byte
Visual C++
public:
property unsigned char ProtocolNumber {
    unsigned char get ();
    void set (unsigned char value);
}

Field Value

The IP protocol number.

See Also

WKSRecord Class