ComponentSpace.Icmp

ComponentSpace ICMP Class Library Reference

ComponentSpace.Icmp Namespace

The ComponentSpace.Icmp namespace contains classes that implement the ICMP protocol.

Namespace hierarchy

Classes

Class | Description
DestinationUnreachableMessage | The ICMP Destination Unreachable Message.
EchoClient | Sends echo messages and receives echo reply messages using the Internet Control Message Protocol (RFC-792).
EchoCompletedEventArgs | Provides data for the EchoCompleted event.
EchoMessage | The ICMP Echo Message.
EchoReplyMessage | The ICMP Echo Reply Message.
IcmpClient | Sends ICMP requests and receives ICMP responses using the Internet Control Message Protocol (RFC-792).
IcmpException | The exception that is thrown when an ICMP operation fails.
IcmpMessage | A ICMP request/response message.
InformationReplyMessage | The ICMP Information Reply Message.
InformationRequestMessage | The ICMP Information Request Message.
IpHeader | An IPv4 header.
ParameterProblemMessage | The ICMP Parameter Problem Message.
ReceiveCompletedEventArgs | Provides data for the ReceiveCompleted event.
RedirectMessage | The ICMP Redirect Message.
SendCompletedEventArgs | Provides data for the SendCompleted event.
SourceQuenchMessage | The ICMP Source Quench Message.
TimeExceededMessage | The ICMP Time Exceeded Message.
TimestampMessage | The ICMP Timestamp Message.
TimestampReplyMessage | The ICMP Timestamp Reply Message.

Delegates

Delegate | Description
EchoCompletedEventHandler | Represents the method that will handle the EchoCompleted event.
ReceiveCompletedEventHandler | Represents the method that will handle the ReceiveCompleted event.
SendCompletedEventHandler | Represents the method that will handle the SendCompleted event.

Enumerations

Enumeration | Description
IcmpMessage.MessageTypes | The message types.


DestinationUnreachableMessage Class

The ICMP Destination Unreachable Message.

For a list of all members of this type, see DestinationUnreachableMessage Members.

System.Object
ComponentSpace.Icmp.IcmpMessage
ComponentSpace.Icmp.DestinationUnreachableMessage

[Visual Basic]
Public Class DestinationUnreachableMessage
Inherits IcmpMessage
[C#]
public class DestinationUnreachableMessage : IcmpMessage

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: ComponentSpace.Icmp

Assembly: ComponentSpace.Icmp (in ComponentSpace.Icmp.dll)

See Also

DestinationUnreachableMessage Members | ComponentSpace.Icmp Namespace


DestinationUnreachableMessage Members

DestinationUnreachableMessage overview

Public Instance Constructors

DestinationUnreachableMessage Overloaded. Initializes a new instance of the DestinationUnreachableMessage class.

Public Instance Properties

Checksum (inherited from IcmpMessage) | Get or sets the checksum.
Code (inherited from IcmpMessage) | Get or sets the code value.
Data | Gets or sets the original data.
IpHeader (inherited from IcmpMessage) | Get the IP header.
MessageType (inherited from IcmpMessage) | Get or sets the message type.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
IsReply (inherited from IcmpMessage) | Overloaded. Indicate whether the response correlates to the request.
ToByteArray | Convert the message into a byte array.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

DestinationUnreachableMessage Class | ComponentSpace.Icmp Namespace


DestinationUnreachableMessage Constructor

Initializes a new instance of the DestinationUnreachableMessage class.

Overload List

Initializes a new instance of the DestinationUnreachableMessage class.

public DestinationUnreachableMessage();

Initializes a new instance of the DestinationUnreachableMessage class from the byte array.

public DestinationUnreachableMessage(byte[],ref int,ref int);

See Also

DestinationUnreachableMessage Class | ComponentSpace.Icmp Namespace


DestinationUnreachableMessage Constructor ()

Initializes a new instance of the DestinationUnreachableMessage class.

[Visual Basic]
Overloads Public Sub New()
[C#]
public DestinationUnreachableMessage();

See Also

DestinationUnreachableMessage Class | ComponentSpace.Icmp Namespace | DestinationUnreachableMessage Constructor Overload List


DestinationUnreachableMessage Constructor (Byte[], Int32, Int32)

Initializes a new instance of the DestinationUnreachableMessage class from the byte array.

[Visual Basic]
Overloads Public Sub New( _
ByVal bytes As Byte(), _
ByRef index As Integer, _
ByRef count As Integer _
)
[C#]
public DestinationUnreachableMessage(
byte[] bytes,
ref int index,
ref int count
);

Parameters

bytes
The byte array containing the message.
index
The index into the byte array.
count
The number of bytes available in the byte array.

See Also

DestinationUnreachableMessage Class | ComponentSpace.Icmp Namespace | DestinationUnreachableMessage Constructor Overload List


DestinationUnreachableMessage Properties

The properties of the DestinationUnreachableMessage class are listed below. For a complete list of DestinationUnreachableMessage class members, see the DestinationUnreachableMessage Members topic.

Public Instance Properties

Checksum (inherited from IcmpMessage) | Get or sets the checksum.
Code (inherited from IcmpMessage) | Get or sets the code value.
Data | Gets or sets the original data.
IpHeader (inherited from IcmpMessage) | Get the IP header.
MessageType (inherited from IcmpMessage) | Get or sets the message type.

See Also

DestinationUnreachableMessage Class | ComponentSpace.Icmp Namespace


DestinationUnreachableMessage.Data Property

Gets or sets the original data.

[Visual Basic]
Public Property Data As Byte()
[C#]
public byte[] Data {get; set;}

Property Value

The original data.

See Also

DestinationUnreachableMessage Class | ComponentSpace.Icmp Namespace


DestinationUnreachableMessage Methods

The methods of the DestinationUnreachableMessage class are listed below. For a complete list of DestinationUnreachableMessage class members, see the DestinationUnreachableMessage Members topic.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
IsReply (inherited from IcmpMessage) | Overloaded. Indicate whether the response correlates to the request.
ToByteArray | Convert the message into a byte array.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

DestinationUnreachableMessage Class | ComponentSpace.Icmp Namespace


DestinationUnreachableMessage.ToByteArray Method

Convert the message into a byte array.

[Visual Basic]
Overrides Public Function ToByteArray() As Byte()
[C#]
public override byte[] ToByteArray();

Return Value

The byte array containing the message.

See Also

DestinationUnreachableMessage Class | ComponentSpace.Icmp Namespace


EchoClient Class

Sends echo messages and receives echo reply messages using the Internet Control Message Protocol (RFC-792).

For a list of all members of this type, see EchoClient Members.

System.Object
ComponentSpace.Icmp.EchoClient

[Visual Basic]
Public Class EchoClient
[C#]
public class EchoClient

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

The EchoClient constructor specifies the address of the server. Optionally, the ReceiveTimeout may be set. The echo request may be sent and the reply received synchronously (blocking) using Echo, or asynchronously (non-blocking) using BeginEcho and EndEcho.

Requirements

Namespace: ComponentSpace.Icmp

Assembly: ComponentSpace.Icmp (in ComponentSpace.Icmp.dll)

See Also

EchoClient Members | ComponentSpace.Icmp Namespace


EchoClient Members

EchoClient overview

Public Instance Constructors

EchoClient Overloaded. Initializes a new instance of the EchoClient class.

Public Instance Properties

Identifier | Gets or sets the identifier to use in the echo message.
ReceiveTimeout | Gets or sets the number of milliseconds to wait for the response from the server.
ResponseTime | Gets the time elapsed between sending an echo message and receiving an echo reply.
ResponseTimeToLive | Gets the time to live (TTL) received in the echo reply.
SequenceNumber | Gets or sets the sequence number to use in the echo message. The sequence number automatically increments after each echo message is sent.
SynchronizingObject | Gets or sets the synchonizing object for receiving events.
TimeToLive | Gets or sets the time to live (TTL).

Public Instance Methods

BeginEcho | Overloaded. Initiates an asynchronous echo operation.
Echo | Overloaded. Send an echo request message to the server and waits for the echo reply.
EndEcho | Completes the specified asynchronous echo operation.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Public Instance Events

EchoCompleted Occurs when the echo has completed.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

EchoClient Class | ComponentSpace.Icmp Namespace


EchoClient Constructor

Initializes a new instance of the EchoClient class with the specified server address. The address can either be the name of the server (eg. www.componentspace.com) or its IP address (eg. 66.210.153.10).

Overload List

Initializes a new instance of the EchoClient class with the specified server IP address.

public EchoClient(IPAddress);

Initializes a new instance of the EchoClient class with the specified server IP address.

public EchoClient(IPEndPoint);

Initializes a new instance of the EchoClient class with the specified server address. The address can either be the name of the server (eg. www.componentspace.com) or its IP address (eg. 66.210.153.10).

public EchoClient(string);

See Also

EchoClient Class | ComponentSpace.Icmp Namespace


EchoClient Constructor (String)

Initializes a new instance of the EchoClient class with the specified server address. The address can either be the name of the server (eg. www.componentspace.com) or its IP address (eg. 66.210.153.10).

[Visual Basic]
Overloads Public Sub New( _
ByVal serverAddress As String _
)
[C#]
public EchoClient(
string serverAddress
);

Parameters

serverAddress
The server address (eg. 66.210.153.10 or www.componentspace.com).

See Also

EchoClient Class | ComponentSpace.Icmp Namespace | EchoClient Constructor Overload List


EchoClient Constructor (IPAddress)

Initializes a new instance of the EchoClient class with the specified server IP address.

[Visual Basic]
Overloads Public Sub New( _
ByVal serverAddress As IPAddress _
)
[C#]
public EchoClient(
IPAddress serverAddress
);

Parameters

serverAddress
The server IP address.

See Also

EchoClient Class | ComponentSpace.Icmp Namespace | EchoClient Constructor Overload List


EchoClient Constructor (IPEndPoint)

Initializes a new instance of the EchoClient class with the specified server IP address.

[Visual Basic]
Overloads Public Sub New( _
ByVal serverAddress As IPEndPoint _
)
[C#]
public EchoClient(
IPEndPoint serverAddress
);

Parameters

serverAddress
The server IP address.

See Also

EchoClient Class | ComponentSpace.Icmp Namespace | EchoClient Constructor Overload List


EchoClient Properties

The properties of the EchoClient class are listed below. For a complete list of EchoClient class members, see the EchoClient Members topic.

Public Instance Properties

Identifier | Gets or sets the identifier to use in the echo message.
ReceiveTimeout | Gets or sets the number of milliseconds to wait for the response from the server.
ResponseTime | Gets the time elapsed between sending an echo message and receiving an echo reply.
ResponseTimeToLive | Gets the time to live (TTL) received in the echo reply.
SequenceNumber | Gets or sets the sequence number to use in the echo message. The sequence number automatically increments after each echo message is sent.
SynchronizingObject | Gets or sets the synchonizing object for receiving events.
TimeToLive | Gets or sets the time to live (TTL).

See Also

EchoClient Class | ComponentSpace.Icmp Namespace


EchoClient.Identifier Property

Gets or sets the identifier to use in the echo message.

[Visual Basic]
Public Property Identifier As UInt16
[C#]
public ushort Identifier {get; set;}

Property Value

The identifier to use in the echo message. The default value is a random number.

See Also

EchoClient Class | ComponentSpace.Icmp Namespace


EchoClient.ReceiveTimeout Property

Gets or sets the number of milliseconds to wait for the response from the server.

[Visual Basic]
Public Property ReceiveTimeout As Integer
[C#]
public int ReceiveTimeout {get; set;}

Property Value

The number of milliseconds to wait for the response from the server. The default is 5 seconds.

See Also

EchoClient Class | ComponentSpace.Icmp Namespace


EchoClient.ResponseTime Property

Gets the time elapsed between sending an echo message and receiving an echo reply.

[Visual Basic]
Public ReadOnly Property ResponseTime As TimeSpan
[C#]
public System.TimeSpan ResponseTime {get;}

Property Value

The time elapsed between sending an echo message and receiving an echo reply.

See Also

EchoClient Class | ComponentSpace.Icmp Namespace


EchoClient.ResponseTimeToLive Property

Gets the time to live (TTL) received in the echo reply.

[Visual Basic]
Public ReadOnly Property ResponseTimeToLive As Byte
[C#]
public byte ResponseTimeToLive {get;}

Property Value

The time to live (TTL) received in the echo reply.

See Also

EchoClient Class | ComponentSpace.Icmp Namespace


EchoClient.SequenceNumber Property

Gets or sets the sequence number to use in the echo message. The sequence number automatically increments after each echo message is sent.

[Visual Basic]
Public Property SequenceNumber As UInt16
[C#]
public ushort SequenceNumber {get; set;}

Property Value

The sequence number to use in the echo message. The defaut value is 1.

See Also

EchoClient Class | ComponentSpace.Icmp Namespace


EchoClient.SynchronizingObject Property

Gets or sets the synchonizing object for receiving events.

[Visual Basic]
Public Property SynchronizingObject As ISynchronizeInvoke
[C#]
public System.ComponentModel.ISynchronizeInvoke SynchronizingObject {get; set;}

Property Value

An ISynchronizeInvoke, which represents the object that marshals the event-handler call resulting from a EchoCompleted event. The default is a null reference (Nothing in Visual Basic).

Remarks

A EchoCompleted event results from a BeginEcho request to a specific thread. Typically, the SynchronizingObject is set when it's used within a form, because forms are bound to a specific thread.

Typically, the synchronizing object marshals a method call into a single thread.

See Also

EchoClient Class | ComponentSpace.Icmp Namespace


EchoClient.TimeToLive Property

Gets or sets the time to live (TTL).

[Visual Basic]
Public Property TimeToLive As Byte
[C#]
public byte TimeToLive {get; set;}

Property Value

The time to live (TTL). The default is 32.

See Also

EchoClient Class | ComponentSpace.Icmp Namespace


EchoClient Methods

The methods of the EchoClient class are listed below. For a complete list of EchoClient class members, see the EchoClient Members topic.

Public Instance Methods

BeginEcho | Overloaded. Initiates an asynchronous echo operation.
Echo | Overloaded. Send an echo request message to the server and waits for the echo reply.
EndEcho | Completes the specified asynchronous echo operation.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

EchoClient Class | ComponentSpace.Icmp Namespace


BeginEcho Method

ComponentSpace ICMP Class Library Reference

EchoClient.BeginEcho Method

Initiates an asynchronous echo operation.

Overload List

Initiates an asynchronous echo operation.

public IAsyncResult BeginEcho(EchoMessage);

Initiates an asynchronous echo operation that has a specified state object.

public IAsyncResult BeginEcho(EchoMessage,object);

Initiates an asynchronous echo operation that has a specified state object. This overload receives notification, through a callback, of the identity of the event handler for this operation.

public IAsyncResult BeginEcho(EchoMessage,object,AsyncCallback);

See Also

EchoClient Class | ComponentSpace.Icmp Namespace


EchoClient.BeginEcho Method (EchoMessage)

Initiates an asynchronous echo operation.

[Visual Basic]
Overloads Public Function BeginEcho( _
ByVal echoMessage As EchoMessage _
) As IAsyncResult
[C#]
public IAsyncResult BeginEcho(
EchoMessage echoMessage
);

Parameters

echoMessage
The echo message.

Return Value

The IAsyncResult that identifies the posted asynchronous request.

Remarks

In asynchronous processing, you use BeginEcho to raise the EchoCompleted event when the echo operation has completed.

To use BeginEcho, create an event handler that processes the results of the asynchronous operation and associate it with your event delegate. BeginEcho initiates an asynchronous send operation; the EchoClient is notified, through the raising of the EchoCompleted event, when the echo operation is completed. The EchoClient can then access the echo status by calling EndEcho.

Note: The BeginEcho method returns immediately, but the asynchronous operation is not completed until the event handler is called.

Because BeginEcho is asynchronous, you can call it to receive the echo status without blocking the current thread of execution. To synchronously echo, use the Echo method.

Once an asynchronous operation completes, you can call BeginEcho again in the event handler to keep receiving notifications.

The IAsyncResult that BeginEcho returns identifies the asynchronous operation that the method call started. You can use this IAsyncResult throughout the lifetime of the operation, although you generally do not use it until EndEcho is called. However, if you start several asynchronous operations, you can place their IAsyncResult values in an array and specify whether to wait for all operations or any operation to complete. In this case, you use the AsyncWaitHandle property of the IAsyncResult to identify the completed operation.

See Also

EchoClient Class | ComponentSpace.Icmp Namespace | EchoClient.BeginEcho Overload List


EchoClient.BeginEcho Method (EchoMessage, Object)

Initiates an asynchronous echo operation that has a specified state object.

[Visual Basic]
Overloads Public Function BeginEcho( _
ByVal echoMessage As EchoMessage, _
ByVal stateObject As Object _
) As IAsyncResult
[C#]
public IAsyncResult BeginEcho(
EchoMessage echoMessage,
object stateObject
);

Parameters

echoMessage
The echo message.
stateObject
A state object, specified by the application, that contains information associated with the asynchronous operation.

Return Value

The IAsyncResult that identifies the posted asynchronous request.

Remarks

In asynchronous processing, you use BeginEcho to raise the EchoCompleted event when the echo operation has completed.

Use this overload to associate information with the operation that will be preserved throughout the operation's lifetime. The event handler can detect this information by looking at the AsyncState of the IAsyncResult that is associated with the operation.

To use BeginEcho, create an event handler that processes the results of the asynchronous operation and associate it with your event delegate. BeginEcho initiates an asynchronous echo operation; the EchoClient is notified, through the raising of the EchoCompleted event, when the echo operation is completed. The EchoClient can then access the echo status by calling EndEcho.

Note: The BeginEcho method returns immediately, but the asynchronous operation is not completed until the event handler is called.

Because BeginEcho is asynchronous, you can call it to receive the echo status without blocking the current thread of execution. To synchronously echo, use the Echo method.

Once an asynchronous operation completes, you can call BeginEcho again in the event handler to keep receiving notifications.

The IAsyncResult that BeginEcho returns indentifies the asynchronous operation that the method call started. You can use this IAsyncResult throughout the lifetime of the operation, although you generally do not use it until EndEcho is called. However, if you start several asynchronous operations, you can place their IAsyncResult values in an array and specify whether to wait for all operations or any operation to complete. In this case, you use the AsyncWaitHandle property of the IAsyncResult to identify the completed operation.

The state object associates state information with the operation. For example, if you call BeginEcho multiple times to initiate multiple operations, you can identify each operation through a separate state object that you define.

You can also use the state object to pass information across process threads. If a thread is started but the callback is on a different thread in an asynchronous scenario, the state object is marshaled and passed back along with information from the event.

See Also

EchoClient Class | ComponentSpace.Icmp Namespace | EchoClient.BeginEcho Overload List


EchoClient.BeginEcho Method (EchoMessage, Object, AsyncCallback)

Initiates an asynchronous echo operation that has a specified state object. This overload receives notification, through a callback, of the identity of the event handler for this operation.

[Visual Basic]
Overloads Public Function BeginEcho( _
ByVal echoMessage As EchoMessage, _
ByVal stateObject As Object, _
ByVal asyncCallback As AsyncCallback _
) As IAsyncResult
[C#]
public IAsyncResult BeginEcho(
EchoMessage echoMessage,
object stateObject,
AsyncCallback asyncCallback
);

Parameters

echoMessage
The echo message.
stateObject
A state object, specified by the application, that contains information associated with the asynchronous operation.
asyncCallback
The AsyncCallback that will receive the notification of the asynchronous operation completion.

Return Value

The IAsyncResult that identifies the posted asynchronous request.

Remarks

When you use this overload, the callback specified in the callback parameter is invoked directly when the echo operation has completed; the EchoCompleted event is not raised. The other overloads of BeginEcho rely on this component to raise the EchoCompleted event.

To use BeginEcho, define an asynchronous callback method. BeginEcho initiates an asynchronous echo operation; the EchoClient is notified, through a call to the callback method, when the echo operation is completed. The EchoClient can then access the echo status by calling EndEcho.

Use this overload to associate information with the operation that will be preserved throughout the operation's lifetime. The event handler can detect this information by looking at the AsyncState of the IAsyncResult that is associated with the operation.

Note: The BeginEcho method returns immediately, but the asynchronous operation is not completed until the event handler is called.

Because BeginEcho is asynchronous, you can call it to receive the echo status without blocking the current thread of execution. To synchronously echo, use the Echo method.

Once an asynchronous operation completes, you can call BeginEcho again in the event handler to keep receiving notifications.

The IAsyncResult that BeginEcho returns identifies the asynchronous operation that the method call started. You can use this IAsyncResult throughout the lifetime of the operation, although you generally do not use it until EndEcho is called. However, if you start several asynchronous operations, you can place their IAsyncResult values in an array and specify whether to wait for all operations or any operation to complete. In this case, you use the AsyncWaitHandle property of the IAsyncResult to identify the completed operation.

The state object associates state information with the operation. For example, if you call BeginEcho multiple times to initiate multiple operations, you can identify each operation through a separate state object that you define.

You can also use the state object to pass information across process threads. If a thread is started but the callback is on a different thread in an asynchronous scenario, the state object is marshaled and passed back along with information from the event.

See Also

EchoClient Class | ComponentSpace.Icmp Namespace | EchoClient.BeginEcho Overload List


Echo Method

ComponentSpace ICMP Class Library Reference

EchoClient.Echo Method

Send an echo request message to the server and waits for the echo reply.

Overload List

Send an echo request message to the server and waits for the echo reply.

public EchoReplyMessage Echo(EchoMessage);

Send an echo request message to the server and waits for the echo reply.

public void Echo(byte[]);

See Also

EchoClient Class | ComponentSpace.Icmp Namespace


EchoClient.Echo Method (EchoMessage)

Send an echo request message to the server and waits for the echo reply.

[Visual Basic]
Overloads Public Function Echo( _
ByVal echoMessage As EchoMessage _
) As EchoReplyMessage
[C#]
public EchoReplyMessage Echo(
EchoMessage echoMessage
);

Parameters

echoMessage
The echo message.

Return Value

The echo reply message.

Exceptions

Exception Type | Condition
IcmpException | Thrown when the echo fails.

See Also

EchoClient Class | ComponentSpace.Icmp Namespace | EchoClient.Echo Overload List


EchoClient.Echo Method (Byte[])

Send an echo request message to the server and waits for the echo reply.

[Visual Basic]
Overloads Public Sub Echo( _
ByVal echoData As Byte() _
)
[C#]
public void Echo(
byte[] echoData
);

Parameters

echoData
The data to echo.

Exceptions

Exception Type | Condition
IcmpException | Thrown when the echo fails.

See Also

EchoClient Class | ComponentSpace.Icmp Namespace | EchoClient.Echo Overload List


EchoClient.EndEcho Method

Completes the specified asynchronous echo operation.

[Visual Basic]
Public Function EndEcho( _
ByVal asyncResult As IAsyncResult _
) As EchoReplyMessage
[C#]
public EchoReplyMessage EndEcho(
IAsyncResult asyncResult
);

Parameters

asyncResult
The IAsyncResult that identifies the asynchronous echo operation to finish, and from which to retrieve an end result.

Return Value

The echo reply message.

Remarks

When the EchoCompleted event is raised, EndEcho completes the operation that was initiated by the BeginEcho call.

Exceptions

Exception Type | Condition
IcmpException | Thrown when the echo fails.

See Also

EchoClient Class | ComponentSpace.Icmp Namespace


EchoClient Events

The events of the EchoClient class are listed below. For a complete list of EchoClient class members, see the EchoClient Members topic.

Public Instance Events

EchoCompleted Occurs when the echo has completed.

See Also

EchoClient Class | ComponentSpace.Icmp Namespace


EchoClient.EchoCompleted Event

Occurs when the echo has completed.

[Visual Basic]
Public Event EchoCompleted As EchoCompletedEventHandler
[C#]
public event EchoCompletedEventHandler EchoCompleted;

Event Data

The event handler receives an argument of type EchoCompletedEventArgs containing data related to this event. The following EchoCompletedEventArgs property provides information specific to this event.

Property | Description
AsyncResult | Gets the result of the asynchronous echo operation.

Remarks

BeginEcho is used in asynchronous processing to raise the EchoCompleted event when the echo has completed.

EndEcho is used to complete the operation initiated by a call to BeginEcho and get the echo status when the EchoCompleted event is raised.

See Also

EchoClient Class | ComponentSpace.Icmp Namespace


EchoCompletedEventArgs Class

Provides data for the EchoCompleted event.

For a list of all members of this type, see EchoCompletedEventArgs Members.

System.Object
System.EventArgs
ComponentSpace.Icmp.EchoCompletedEventArgs

[Visual Basic]
Public Class EchoCompletedEventArgs
Inherits EventArgs
[C#]
public class EchoCompletedEventArgs : EventArgs

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

The EchoCompleted event is raised by the IcmpClient. It contains all the information needed to complete the asynchronous echo operation.

Requirements

Namespace: ComponentSpace.Icmp

Assembly: ComponentSpace.Icmp (in ComponentSpace.Icmp.dll)

See Also

EchoCompletedEventArgs Members | ComponentSpace.Icmp Namespace


EchoCompletedEventArgs Members

EchoCompletedEventArgs overview

Public Instance Properties

AsyncResult Gets the result of the asynchronous echo operation.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

EchoCompletedEventArgs Class | ComponentSpace.Icmp Namespace


EchoCompletedEventArgs Properties

The properties of the EchoCompletedEventArgs class are listed below. For a complete list of EchoCompletedEventArgs class members, see the EchoCompletedEventArgs Members topic.

Public Instance Properties

AsyncResult Gets the result of the asynchronous echo operation.

See Also

EchoCompletedEventArgs Class | ComponentSpace.Icmp Namespace


EchoCompletedEventArgs.AsyncResult Property

Gets the result of the asynchronous echo operation.

[Visual Basic]
Public ReadOnly Property AsyncResult As IAsyncResult
[C#]
public System.IAsyncResult AsyncResult {get;}

Property Value

An IAsyncResult that contains the data associated with the echo operation.

Remarks

AsyncResult identifies ongoing or completed asynchronous operations. The property contains data that helps determine which of several potential asynchronous operations to complete, and when passed to the event handler, enables EndEcho to access the status associated with the completed operation.

See Also

EchoCompletedEventArgs Class | ComponentSpace.Icmp Namespace


EchoCompletedEventHandler Delegate

Represents the method that will handle the EchoCompleted event.

[Visual Basic]
Public Delegate Sub EchoCompletedEventHandler( _
ByVal sender As Object, _
ByVal e As EchoCompletedEventArgs _
)
[C#]
public delegate void EchoCompletedEventHandler(
object sender,
EchoCompletedEventArgs e
);

Parameters

sender
The source of the event.
e
An EchoCompletedEventArgs that contains the event data.

Remarks

When you create a EchoCompletedEventHandler delegate, you identify the method that will handle the event. To associate the event with your event handler, add an instance of the delegate to the event. The event handler is called whenever the event occurs, unless you remove the delegate.

Requirements

Namespace: ComponentSpace.Icmp

Assembly: ComponentSpace.Icmp (in ComponentSpace.Icmp.dll)

See Also

ComponentSpace.Icmp Namespace


EchoMessage Class

The ICMP Echo Message.

For a list of all members of this type, see EchoMessage Members.

System.Object
ComponentSpace.Icmp.IcmpMessage
ComponentSpace.Icmp.EchoMessage

[Visual Basic]
Public Class EchoMessage
Inherits IcmpMessage
[C#]
public class EchoMessage : IcmpMessage

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: ComponentSpace.Icmp

Assembly: ComponentSpace.Icmp (in ComponentSpace.Icmp.dll)

See Also

EchoMessage Members | ComponentSpace.Icmp Namespace


EchoMessage Members

EchoMessage overview

Public Static (Shared) Methods

CreateRandomIdentifier Create a random identifier.

Public Instance Constructors

EchoMessage Overloaded. Initializes a new instance of the EchoMessage class.

Public Instance Properties

Checksum (inherited from IcmpMessage) | Get or sets the checksum.
Code (inherited from IcmpMessage) | Get or sets the code value.
Data | Gets or sets the echo data.
Identifier | Gets or sets the identifier.
IpHeader (inherited from IcmpMessage) | Get the IP header.
MessageType (inherited from IcmpMessage) | Get or sets the message type.
SequenceNumber | Gets or sets the sequence number.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
IncrementSequenceNumber | Increment the sequence number.
IsReply (inherited from IcmpMessage) | Overloaded. Indicate whether the response correlates to the request.
IsReply | Overloaded. Indicate whether the response correlates to the request.
ToByteArray | Convert the message into a byte array.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

EchoMessage Class | ComponentSpace.Icmp Namespace


EchoMessage Constructor

Initializes a new instance of the EchoMessage class with the supplied data.

Overload List

Initializes a new instance of the EchoMessage class.

public EchoMessage();

Initializes a new instance of the EchoMessage class with the supplied data.

public EchoMessage(byte[]);

Initializes a new instance of the EchoMessage class from the byte array.

public EchoMessage(byte[],ref int,ref int);

See Also

EchoMessage Class | ComponentSpace.Icmp Namespace


EchoMessage Constructor (Byte[])

Initializes a new instance of the EchoMessage class with the supplied data.

[Visual Basic]
Overloads Public Sub New( _
ByVal data As Byte() _
)
[C#]
public EchoMessage(
byte[] data
);

See Also

EchoMessage Class | ComponentSpace.Icmp Namespace | EchoMessage Constructor Overload List


EchoMessage Constructor ()

Initializes a new instance of the EchoMessage class.

[Visual Basic]
Overloads Public Sub New()
[C#]
public EchoMessage();

See Also

EchoMessage Class | ComponentSpace.Icmp Namespace | EchoMessage Constructor Overload List


EchoMessage Constructor (Byte[], Int32, Int32)

Initializes a new instance of the EchoMessage class from the byte array.

[Visual Basic]
Overloads Public Sub New( _
ByVal bytes As Byte(), _
ByRef index As Integer, _
ByRef count As Integer _
)
[C#]
public EchoMessage(
byte[] bytes,
ref int index,
ref int count
);

Parameters

bytes
The byte array containing the message.
index
The index into the byte array.
count
The number of bytes available in the byte array.

See Also

EchoMessage Class | ComponentSpace.Icmp Namespace | EchoMessage Constructor Overload List


EchoMessage Properties

The properties of the EchoMessage class are listed below. For a complete list of EchoMessage class members, see the EchoMessage Members topic.

Public Instance Properties

Checksum (inherited from IcmpMessage) | Get or sets the checksum.
Code (inherited from IcmpMessage) | Get or sets the code value.
Data | Gets or sets the echo data.
Identifier | Gets or sets the identifier.
IpHeader (inherited from IcmpMessage) | Get the IP header.
MessageType (inherited from IcmpMessage) | Get or sets the message type.
SequenceNumber | Gets or sets the sequence number.

See Also

EchoMessage Class | ComponentSpace.Icmp Namespace


EchoMessage.Data Property

Gets or sets the echo data.

[Visual Basic]
Public Property Data As Byte()
[C#]
public byte[] Data {get; set;}

Property Value

The echo data.

See Also

EchoMessage Class | ComponentSpace.Icmp Namespace


EchoMessage.Identifier Property

Gets or sets the identifier.

[Visual Basic]
Public Property Identifier As UInt16
[C#]
public ushort Identifier {get; set;}

Property Value

The identifier. The default value is a random number.

See Also

EchoMessage Class | ComponentSpace.Icmp Namespace


EchoMessage.SequenceNumber Property

Gets or sets the sequence number.

[Visual Basic]
Public Property SequenceNumber As UInt16
[C#]
public ushort SequenceNumber {get; set;}

Property Value

The sequence number. The default is 1.

See Also

EchoMessage Class | ComponentSpace.Icmp Namespace


EchoMessage Methods

The methods of the EchoMessage class are listed below. For a complete list of EchoMessage class members, see the EchoMessage Members topic.

Public Static (Shared) Methods

CreateRandomIdentifier Create a random identifier.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
IncrementSequenceNumber | Increment the sequence number.
IsReply (inherited from IcmpMessage) | Overloaded. Indicate whether the response correlates to the request.
IsReply | Overloaded. Indicate whether the response correlates to the request.
ToByteArray | Convert the message into a byte array.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

EchoMessage Class | ComponentSpace.Icmp Namespace


EchoMessage.CreateRandomIdentifier Method

Create a random identifier.

[Visual Basic]
Public Shared Function CreateRandomIdentifier() As UInt16
[C#]
public static ushort CreateRandomIdentifier();

Return Value

The random identifier.

See Also

EchoMessage Class | ComponentSpace.Icmp Namespace


EchoMessage.IncrementSequenceNumber Method

Increment the sequence number.

[Visual Basic]
Public Function IncrementSequenceNumber() As UInt16
[C#]
public ushort IncrementSequenceNumber();

Return Value

The incremented sequence number

See Also

EchoMessage Class | ComponentSpace.Icmp Namespace


IsReply Method

ComponentSpace ICMP Class Library Reference

EchoMessage.IsReply Method

Indicate whether the response correlates to the request.

Overload List

Inherited from IcmpMessage.

public virtual bool IsReply(DestinationUnreachableMessage);

Indicate whether the response correlates to the request.

public override bool IsReply(EchoReplyMessage);

Inherited from IcmpMessage.

public virtual bool IsReply(IcmpMessage);

Inherited from IcmpMessage.

public virtual bool IsReply(InformationReplyMessage);

Inherited from IcmpMessage.

public virtual bool IsReply(ParameterProblemMessage);

Inherited from IcmpMessage.

public virtual bool IsReply(RedirectMessage);

Inherited from IcmpMessage.

public virtual bool IsReply(SourceQuenchMessage);

Inherited from IcmpMessage.

public virtual bool IsReply(TimeExceededMessage);

Inherited from IcmpMessage.

public virtual bool IsReply(TimestampReplyMessage);

See Also

EchoMessage Class | ComponentSpace.Icmp Namespace


EchoMessage.IsReply Method (EchoReplyMessage)

Indicate whether the response correlates to the request.

[Visual Basic]
Overrides Overloads Public Function IsReply( _
ByVal response As EchoReplyMessage _
) As Boolean
[C#]
public override bool IsReply(
EchoReplyMessage response
);

Return Value

true if the response correlates to the request; false otherwise

See Also

EchoMessage Class | ComponentSpace.Icmp Namespace | EchoMessage.IsReply Overload List


EchoMessage.ToByteArray Method

Convert the message into a byte array.

[Visual Basic]
Overrides Public Function ToByteArray() As Byte()
[C#]
public override byte[] ToByteArray();

Return Value

The byte array containing the message.

See Also

EchoMessage Class | ComponentSpace.Icmp Namespace


EchoReplyMessage Class

The ICMP Echo Reply Message.

For a list of all members of this type, see EchoReplyMessage Members.

System.Object
ComponentSpace.Icmp.IcmpMessage
ComponentSpace.Icmp.EchoReplyMessage

[Visual Basic]
Public Class EchoReplyMessage
Inherits IcmpMessage
[C#]
public class EchoReplyMessage : IcmpMessage

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: ComponentSpace.Icmp

Assembly: ComponentSpace.Icmp (in ComponentSpace.Icmp.dll)

See Also

EchoReplyMessage Members | ComponentSpace.Icmp Namespace


EchoReplyMessage Members

EchoReplyMessage overview

Public Instance Constructors

EchoReplyMessage Overloaded. Initializes a new instance of the EchoReplyMessage class.

Public Instance Properties

Checksum (inherited from IcmpMessage) | Get or sets the checksum.
Code (inherited from IcmpMessage) | Get or sets the code value.
Data | Gets or sets the echo data.
Identifier | Gets or sets the identifier.
IpHeader (inherited from IcmpMessage) | Get the IP header.
MessageType (inherited from IcmpMessage) | Get or sets the message type.
SequenceNumber | Gets or sets the sequence number.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
IsReply (inherited from IcmpMessage) | Overloaded. Indicate whether the response correlates to the request.
ToByteArray | Convert the message into a byte array.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

EchoReplyMessage Class | ComponentSpace.Icmp Namespace


EchoReplyMessage Constructor

Initializes a new instance of the EchoReplyMessage class.

Overload List

Initializes a new instance of the EchoReplyMessage class.

public EchoReplyMessage();

Initializes a new instance of the EchoReplyMessage class from the byte array.

public EchoReplyMessage(byte[],ref int,ref int);

See Also

EchoReplyMessage Class | ComponentSpace.Icmp Namespace


EchoReplyMessage Constructor ()

Initializes a new instance of the EchoReplyMessage class.

[Visual Basic]
Overloads Public Sub New()
[C#]
public EchoReplyMessage();

See Also

EchoReplyMessage Class | ComponentSpace.Icmp Namespace | EchoReplyMessage Constructor Overload List


EchoReplyMessage Constructor (Byte[], Int32, Int32)

Initializes a new instance of the EchoReplyMessage class from the byte array.

[Visual Basic]
Overloads Public Sub New( _
ByVal bytes As Byte(), _
ByRef index As Integer, _
ByRef count As Integer _
)
[C#]
public EchoReplyMessage(
byte[] bytes,
ref int index,
ref int count
);

Parameters

bytes
The byte array containing the message.
index
The index into the byte array.
count
The number of bytes available in the byte array.

See Also

EchoReplyMessage Class | ComponentSpace.Icmp Namespace | EchoReplyMessage Constructor Overload List


EchoReplyMessage Properties

The properties of the EchoReplyMessage class are listed below. For a complete list of EchoReplyMessage class members, see the EchoReplyMessage Members topic.

Public Instance Properties

Checksum (inherited from IcmpMessage) | Get or sets the checksum.
Code (inherited from IcmpMessage) | Get or sets the code value.
Data | Gets or sets the echo data.
Identifier | Gets or sets the identifier.
IpHeader (inherited from IcmpMessage) | Get the IP header.
MessageType (inherited from IcmpMessage) | Get or sets the message type.
SequenceNumber | Gets or sets the sequence number.

See Also

EchoReplyMessage Class | ComponentSpace.Icmp Namespace


EchoReplyMessage.Data Property

Gets or sets the echo data.

[Visual Basic]
Public Property Data As Byte()
[C#]
public byte[] Data {get; set;}

Property Value

The echo data.

See Also

EchoReplyMessage Class | ComponentSpace.Icmp Namespace


EchoReplyMessage.Identifier Property

Gets or sets the identifier.

[Visual Basic]
Public Property Identifier As UInt16
[C#]
public ushort Identifier {get; set;}

Property Value

The identifier.

See Also

EchoReplyMessage Class | ComponentSpace.Icmp Namespace


EchoReplyMessage.SequenceNumber Property

Gets or sets the sequence number.

[Visual Basic]
Public Property SequenceNumber As UInt16
[C#]
public ushort SequenceNumber {get; set;}

Property Value

The sequence number.

See Also

EchoReplyMessage Class | ComponentSpace.Icmp Namespace


EchoReplyMessage Methods

The methods of the EchoReplyMessage class are listed below. For a complete list of EchoReplyMessage class members, see the EchoReplyMessage Members topic.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
IsReply (inherited from IcmpMessage) | Overloaded. Indicate whether the response correlates to the request.
ToByteArray | Convert the message into a byte array.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

EchoReplyMessage Class | ComponentSpace.Icmp Namespace


EchoReplyMessage.ToByteArray Method

Convert the message into a byte array.

[Visual Basic]
Overrides Public Function ToByteArray() As Byte()
[C#]
public override byte[] ToByteArray();

Return Value

The byte array containing the message.

See Also

EchoReplyMessage Class | ComponentSpace.Icmp Namespace


IcmpClient Class

Sends ICMP requests and receives ICMP responses using the Internet Control Message Protocol (RFC-792).

For a list of all members of this type, see IcmpClient Members.

System.Object
ComponentSpace.Icmp.IcmpClient

[Visual Basic]
Public Class IcmpClient
Implements IDisposable
[C#]
public class IcmpClient : IDisposable

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

The IcmpClient constructor specifies the address of the server. Optionally, the ReceiveTimeout may be set. The ICMP request may be sent and the reply received synchronously (blocking) using Send and Receive, or asynchronously (non-blocking) using BeginSend, EndSend and BeginReceive, EndReceive.

Requirements

Namespace: ComponentSpace.Icmp

Assembly: ComponentSpace.Icmp (in ComponentSpace.Icmp.dll)

See Also

IcmpClient Members | ComponentSpace.Icmp Namespace


IcmpClient Members

IcmpClient overview

Public Instance Constructors

IcmpClient Overloaded. Initializes a new instance of the IcmpClient class.

Public Instance Properties

ReceiveTimeout | Gets or sets the number of milliseconds to wait for the response from the server.
SynchronizingObject | Gets or sets the synchonizing object for receiving events.
TimeToLive | Gets or sets the time to live (TTL).

Public Instance Methods

BeginReceive | Overloaded. Initiates an asynchronous receive operation.
BeginSend | Overloaded. Initiates an asynchronous send operation.
Dispose | Dispose of the IcmpClient and the underlying socket object.
EndReceive | Completes the specified asynchronous receive operation.
EndSend | Completes the specified asynchronous send operation.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
IsReply | Indicate whether the response correlates to the request.
Receive | Returns an ICMP response message from the server.
Send | Send an ICMP request message to the server.
ToString (inherited from Object) | Returns a String that represents the current Object.

Public Instance Events

ReceiveCompleted | Occurs when the receive operation has completed.
SendCompleted | Occurs when the send operation has completed.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

IcmpClient Class | ComponentSpace.Icmp Namespace


IcmpClient Constructor

Initializes a new instance of the IcmpClient class with the specified server address. The address can either be the name of the server (eg. www.componentspace.com) or its IP address (eg. 66.210.153.10).

Overload List

Initializes a new instance of the IcmpClient class with the specified server IP address.

public IcmpClient(IPAddress);

Initializes a new instance of the IcmpClient class with the specified server IP address.

public IcmpClient(IPEndPoint);

Initializes a new instance of the IcmpClient class with the specified server address. The address can either be the name of the server (eg. www.componentspace.com) or its IP address (eg. 66.210.153.10).

public IcmpClient(string);

See Also

IcmpClient Class | ComponentSpace.Icmp Namespace


IcmpClient Constructor (String)

Initializes a new instance of the IcmpClient class with the specified server address. The address can either be the name of the server (eg. www.componentspace.com) or its IP address (eg. 66.210.153.10).

[Visual Basic]
Overloads Public Sub New( _
ByVal serverAddress As String _
)
[C#]
public IcmpClient(
string serverAddress
);

Parameters

serverAddress
The server address (eg. 66.210.153.10 or www.componentspace.com).

See Also

IcmpClient Class | ComponentSpace.Icmp Namespace | IcmpClient Constructor Overload List


IcmpClient Constructor (IPAddress)

Initializes a new instance of the IcmpClient class with the specified server IP address.

[Visual Basic]
Overloads Public Sub New( _
ByVal serverAddress As IPAddress _
)
[C#]
public IcmpClient(
IPAddress serverAddress
);

Parameters

serverAddress
The server IP address.

See Also

IcmpClient Class | ComponentSpace.Icmp Namespace | IcmpClient Constructor Overload List


IcmpClient Constructor (IPEndPoint)

Initializes a new instance of the IcmpClient class with the specified server IP address.

[Visual Basic]
Overloads Public Sub New( _
ByVal serverAddress As IPEndPoint _
)
[C#]
public IcmpClient(
IPEndPoint serverAddress
);

Parameters

serverAddress
The server IP address.

See Also

IcmpClient Class | ComponentSpace.Icmp Namespace | IcmpClient Constructor Overload List


IcmpClient Properties

The properties of the IcmpClient class are listed below. For a complete list of IcmpClient class members, see the IcmpClient Members topic.

Public Instance Properties

ReceiveTimeout | Gets or sets the number of milliseconds to wait for the response from the server.
SynchronizingObject | Gets or sets the synchonizing object for receiving events.
TimeToLive | Gets or sets the time to live (TTL).

See Also

IcmpClient Class | ComponentSpace.Icmp Namespace


IcmpClient.ReceiveTimeout Property

Gets or sets the number of milliseconds to wait for the response from the server.

[Visual Basic]
Public Property ReceiveTimeout As Integer
[C#]
public int ReceiveTimeout {get; set;}

Property Value

The number of milliseconds to wait for the response from the server. The default is 30 seconds.

See Also

IcmpClient Class | ComponentSpace.Icmp Namespace


IcmpClient.SynchronizingObject Property

Gets or sets the synchonizing object for receiving events.

[Visual Basic]
Public Property SynchronizingObject As ISynchronizeInvoke
[C#]
public System.ComponentModel.ISynchronizeInvoke SynchronizingObject {get; set;}

Property Value

An ISynchronizeInvoke, which represents the object that marshals the event-handler call resulting from a SendCompleted or ReceiveCompleted event. The default is a null reference (Nothing in Visual Basic).

Remarks

A SendCompleted event results from a BeginSend request to a specific thread. A ReceiveCompleted event results from a BeginReceive request to a specific thread. Typically, the SynchronizingObject is set when it's used within a form, because forms are bound to a specific thread.

Typically, the synchronizing object marshals a method call into a single thread.

See Also

IcmpClient Class | ComponentSpace.Icmp Namespace


IcmpClient.TimeToLive Property

Gets or sets the time to live (TTL).

[Visual Basic]
Public Property TimeToLive As Byte
[C#]
public byte TimeToLive {get; set;}

Property Value

The time to live (TTL). The default is 32.

See Also

IcmpClient Class | ComponentSpace.Icmp Namespace


IcmpClient Methods

The methods of the IcmpClient class are listed below. For a complete list of IcmpClient class members, see the IcmpClient Members topic.

Public Instance Methods

BeginReceive | Overloaded. Initiates an asynchronous receive operation.
BeginSend | Overloaded. Initiates an asynchronous send operation.
Dispose | Dispose of the IcmpClient and the underlying socket object.
EndReceive | Completes the specified asynchronous receive operation.
EndSend | Completes the specified asynchronous send operation.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
IsReply | Indicate whether the response correlates to the request.
Receive | Returns an ICMP response message from the server.
Send | Send an ICMP request message to the server.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

IcmpClient Class | ComponentSpace.Icmp Namespace


BeginReceive Method

ComponentSpace ICMP Class Library Reference

IcmpClient.BeginReceive Method

Initiates an asynchronous receive operation.

Overload List

Initiates an asynchronous receive operation.

public IAsyncResult BeginReceive();

Initiates an asynchronous receive operation that has a specified state object.

public IAsyncResult BeginReceive(object);

Initiates an asynchronous receive operation that has a specified state object. This overload receives notification, through a callback, of the identity of the event handler for this operation.

public IAsyncResult BeginReceive(object,AsyncCallback);

See Also

IcmpClient Class | ComponentSpace.Icmp Namespace


IcmpClient.BeginReceive Method ()

Initiates an asynchronous receive operation.

[Visual Basic]
Overloads Public Function BeginReceive() As IAsyncResult
[C#]
public IAsyncResult BeginReceive();

Return Value

The IAsyncResult that identifies the posted asynchronous request.

Remarks

In asynchronous processing, you use BeginReceive to raise the ReceiveCompleted event when the receive operation has completed.

To use BeginReceive, create an event handler that processes the results of the asynchronous operation and associate it with your event delegate. BeginReceive initiates an asynchronous receive operation; the IcmpClient is notified, through the raising of the ReceiveCompleted event, when the receive operation is completed. The IcmpClient can then access the receive status by calling EndReceive.

Note: The BeginReceive method returns immediately, but the asynchronous operation is not completed until the event handler is called.

Because BeginReceive is asynchronous, you can call it to receive the receive status without blocking the current thread of execution. To synchronously receive, use the Receive method.

Once an asynchronous operation completes, you can call BeginReceive again in the event handler to keep receiving notifications.

The IAsyncResult that BeginReceive returns identifies the asynchronous operation that the method call started. You can use this IAsyncResult throughout the lifetime of the operation, although you generally do not use it until EndReceive is called. However, if you start several asynchronous operations, you can place their IAsyncResult values in an array and specify whether to wait for all operations or any operation to complete. In this case, you use the AsyncWaitHandle property of the IAsyncResult to identify the completed operation.

See Also

IcmpClient Class | ComponentSpace.Icmp Namespace | IcmpClient.BeginReceive Overload List


IcmpClient.BeginReceive Method (Object)

Initiates an asynchronous receive operation that has a specified state object.

[Visual Basic]
Overloads Public Function BeginReceive( _
ByVal stateObject As Object _
) As IAsyncResult
[C#]
public IAsyncResult BeginReceive(
object stateObject
);

Parameters

stateObject
A state object, specified by the application, that contains information associated with the asynchronous operation.

Return Value

The IAsyncResult that identifies the posted asynchronous request.

Remarks

In asynchronous processing, you use BeginReceive to raise the ReceiveCompleted event when the receive operation has completed.

Use this overload to associate information with the operation that will be preserved throughout the operation's lifetime. The event handler can detect this information by looking at the AsyncState of the IAsyncResult that is associated with the operation.

To use BeginReceive, create an event handler that processes the results of the asynchronous operation and associate it with your event delegate. BeginReceive initiates an asynchronous receive operation; the IcmpClient is notified, through the raising of the ReceiveCompleted event, when the receive operation is completed. The IcmpClient can then access the receive status by calling EndReceive.

Note: The BeginReceive method returns immediately, but the asynchronous operation is not completed until the event handler is called.

Because BeginReceive is asynchronous, you can call it to receive the receive status without blocking the current thread of execution. To synchronously receive, use the Receive method.

Once an asynchronous operation completes, you can call BeginReceive again in the event handler to keep receiving notifications.

The IAsyncResult that BeginReceive returns identifies the asynchronous operation that the method call started. You can use this IAsyncResult throughout the lifetime of the operation, although you generally do not use it until EndReceive is called. However, if you start several asynchronous operations, you can place their IAsyncResult values in an array and specify whether to wait for all operations or any operation to complete. In this case, you use the AsyncWaitHandle property of the IAsyncResult to identify the completed operation.

The state object associates state information with the operation. For example, if you call BeginReceive multiple times to initiate multiple operations, you can identify each operation through a separate state object that you define.

You can also use the state object to pass information across process threads. If a thread is started but the callback is on a different thread in an asynchronous scenario, the state object is marshaled and passed back along with information from the event.

See Also

IcmpClient Class | ComponentSpace.Icmp Namespace | IcmpClient.BeginReceive Overload List


IcmpClient.BeginReceive Method (Object, AsyncCallback)

Initiates an asynchronous receive operation that has a specified state object. This overload receives notification, through a callback, of the identity of the event handler for this operation.

[Visual Basic]
Overloads Public Function BeginReceive( _
ByVal stateObject As Object, _
ByVal asyncCallback As AsyncCallback _
) As IAsyncResult
[C#]
public IAsyncResult BeginReceive(
object stateObject,
AsyncCallback asyncCallback
);

Parameters

stateObject
A state object, specified by the application, that contains information associated with the asynchronous operation.
asyncCallback
The AsyncCallback that will receive the notification of the asynchronous operation completion.

Return Value

The IAsyncResult that identifies the posted asynchronous request.

Remarks

When you use this overload, the callback specified in the callback parameter is invoked directly when the receive operation has completed; the ReceiveCompleted event is not raised. The other overloads of BeginReceive rely on this component to raise the ReceiveCompleted event.

To use BeginReceive, define an asynchronous callback method. BeginReceive initiates an asynchronous receive operation; the IcmpClient is notified, through a call to the callback method, when the receive operation is completed. The IcmpClient can then access the receive status by calling EndReceive.

Use this overload to associate information with the operation that will be preserved throughout the operation's lifetime. The event handler can detect this information by looking at the AsyncState of the IAsyncResult that is associated with the operation.

Note: The BeginReceive method returns immediately, but the asynchronous operation is not completed until the event handler is called.

Because BeginReceive is asynchronous, you can call it to receive the receive status without blocking the current thread of execution. To synchronously receive, use the Receive method.

Once an asynchronous operation completes, you can call BeginReceive again in the event handler to keep receiving notifications.

The IAsyncResult that BeginReceive returns identifies the asynchronous operation that the method call started. You can use this IAsyncResult throughout the lifetime of the operation, although you generally do not use it until EndReceive is called. However, if you start several asynchronous operations, you can place their IAsyncResult values in an array and specify whether to wait for all operations or any operation to complete. In this case, you use the AsyncWaitHandle property of the IAsyncResult to identify the completed operation.

The state object associates state information with the operation. For example, if you call BeginReceive multiple times to initiate multiple operations, you can identify each operation through a separate state object that you define.

You can also use the state object to pass information across process threads. If a thread is started but the callback is on a different thread in an asynchronous scenario, the state object is marshaled and passed back along with information from the event.

See Also

IcmpClient Class | ComponentSpace.Icmp Namespace | IcmpClient.BeginReceive Overload List


BeginSend Method

ComponentSpace ICMP Class Library Reference

IcmpClient.BeginSend Method

Initiates an asynchronous send operation.

Overload List

Initiates an asynchronous send operation.

public IAsyncResult BeginSend(IcmpMessage);

Initiates an asynchronous send operation that has a specified state object.

public IAsyncResult BeginSend(IcmpMessage,object);

Initiates an asynchronous send operation that has a specified state object. This overload receives notification, through a callback, of the identity of the event handler for this operation.

public IAsyncResult BeginSend(IcmpMessage,object,AsyncCallback);

See Also

IcmpClient Class | ComponentSpace.Icmp Namespace


IcmpClient.BeginSend Method (IcmpMessage)

Initiates an asynchronous send operation.

[Visual Basic]
Overloads Public Function BeginSend( _
ByVal icmpMessage As IcmpMessage _
) As IAsyncResult
[C#]
public IAsyncResult BeginSend(
IcmpMessage icmpMessage
);

Parameters

icmpMessage
The ICMP request message to send.

Return Value

The IAsyncResult that identifies the posted asynchronous request.

Remarks

In asynchronous processing, you use BeginSend to raise the SendCompleted event when the send operation has completed.

To use BeginSend, create an event handler that processes the results of the asynchronous operation and associate it with your event delegate. BeginSend initiates an asynchronous send operation; the IcmpClient is notified, through the raising of the SendCompleted event, when the send operation is completed. The IcmpClient can then access the send status by calling EndSend.

Note: The BeginSend method returns immediately, but the asynchronous operation is not completed until the event handler is called.

Because BeginSend is asynchronous, you can call it to receive the send status without blocking the current thread of execution. To synchronously send, use the Send method.

Once an asynchronous operation completes, you can call BeginSend again in the event handler to keep receiving notifications.

The IAsyncResult that BeginSend returns identifies the asynchronous operation that the method call started. You can use this IAsyncResult throughout the lifetime of the operation, although you generally do not use it until EndSend is called. However, if you start several asynchronous operations, you can place their IAsyncResult values in an array and specify whether to wait for all operations or any operation to complete. In this case, you use the AsyncWaitHandle property of the IAsyncResult to identify the completed operation.

See Also

IcmpClient Class | ComponentSpace.Icmp Namespace | IcmpClient.BeginSend Overload List


IcmpClient.BeginSend Method (IcmpMessage, Object)

Initiates an asynchronous send operation that has a specified state object.

[Visual Basic]
Overloads Public Function BeginSend( _
ByVal icmpMessage As IcmpMessage, _
ByVal stateObject As Object _
) As IAsyncResult
[C#]
public IAsyncResult BeginSend(
IcmpMessage icmpMessage,
object stateObject
);

Parameters

icmpMessage
The ICMP request message to send.
stateObject
A state object, specified by the application, that contains information associated with the asynchronous operation.

Return Value

The IAsyncResult that identifies the posted asynchronous request.

Remarks

In asynchronous processing, you use BeginSend to raise the SendCompleted event when the send operation has completed.

Use this overload to associate information with the operation that will be preserved throughout the operation's lifetime. The event handler can detect this information by looking at the AsyncState of the IAsyncResult that is associated with the operation.

To use BeginSend, create an event handler that processes the results of the asynchronous operation and associate it with your event delegate. BeginSend initiates an asynchronous send operation; the IcmpClient is notified, through the raising of the SendCompleted event, when the send operation is completed. The IcmpClient can then access the send status by calling EndSend.

Note: The BeginSend method returns immediately, but the asynchronous operation is not completed until the event handler is called.

Because BeginSend is asynchronous, you can call it to receive the send status without blocking the current thread of execution. To synchronously send, use the Send method.

Once an asynchronous operation completes, you can call BeginSend again in the event handler to keep receiving notifications.

The IAsyncResult that BeginSend returns identifies the asynchronous operation that the method call started. You can use this IAsyncResult throughout the lifetime of the operation, although you generally do not use it until EndSend is called. However, if you start several asynchronous operations, you can place their IAsyncResult values in an array and specify whether to wait for all operations or any operation to complete. In this case, you use the AsyncWaitHandle property of the IAsyncResult to identify the completed operation.

The state object associates state information with the operation. For example, if you call BeginSend multiple times to initiate multiple operations, you can identify each operation through a separate state object that you define.

You can also use the state object to pass information across process threads. If a thread is started but the callback is on a different thread in an asynchronous scenario, the state object is marshaled and passed back along with information from the event.

See Also

IcmpClient Class | ComponentSpace.Icmp Namespace | IcmpClient.BeginSend Overload List


IcmpClient.BeginSend Method (IcmpMessage, Object, AsyncCallback)

Initiates an asynchronous send operation that has a specified state object. This overload receives notification, through a callback, of the identity of the event handler for this operation.

[Visual Basic]
Overloads Public Function BeginSend( _
ByVal icmpMessage As IcmpMessage, _
ByVal stateObject As Object, _
ByVal asyncCallback As AsyncCallback _
) As IAsyncResult
[C#]
public IAsyncResult BeginSend(
IcmpMessage icmpMessage,
object stateObject,
AsyncCallback asyncCallback
);

Parameters

icmpMessage
The ICMP request message to send.
stateObject
A state object, specified by the application, that contains information associated with the asynchronous operation.
asyncCallback
The AsyncCallback that will receive the notification of the asynchronous operation completion.

Return Value

The IAsyncResult that identifies the posted asynchronous request.

Remarks

When you use this overload, the callback specified in the callback parameter is invoked directly when the send operation has completed; the SendCompleted event is not raised. The other overloads of BeginSend rely on this component to raise the SendCompleted event.

To use BeginSend, define an asynchronous callback method. BeginSend initiates an asynchronous send operation; the IcmpClient is notified, through a call to the callback method, when the send operation is completed. The IcmpClient can then access the send status by calling EndSend.

Use this overload to associate information with the operation that will be preserved throughout the operation's lifetime. The event handler can detect this information by looking at the AsyncState of the IAsyncResult that is associated with the operation.

Note: The BeginSend method returns immediately, but the asynchronous operation is not completed until the event handler is called.

Because BeginSend is asynchronous, you can call it to receive the send status without blocking the current thread of execution. To synchronously send, use the Send method.

Once an asynchronous operation completes, you can call BeginSend again in the event handler to keep receiving notifications.

The IAsyncResult that BeginSend returns identifies the asynchronous operation that the method call started. You can use this IAsyncResult throughout the lifetime of the operation, although you generally do not use it until EndSend is called. However, if you start several asynchronous operations, you can place their IAsyncResult values in an array and specify whether to wait for all operations or any operation to complete. In this case, you use the AsyncWaitHandle property of the IAsyncResult to identify the completed operation.

The state object associates state information with the operation. For example, if you call BeginSend multiple times to initiate multiple operations, you can identify each operation through a separate state object that you define.

You can also use the state object to pass information across process threads. If a thread is started but the callback is on a different thread in an asynchronous scenario, the state object is marshaled and passed back along with information from the event.

See Also

IcmpClient Class | ComponentSpace.Icmp Namespace | IcmpClient.BeginSend Overload List


IcmpClient.Dispose Method

Dispose of the IcmpClient and the underlying socket object.

[Visual Basic]
NotOverridable Public Sub Dispose() _
Implements IDisposable.Dispose
[C#]
public void Dispose();

Implements

IDisposable.Dispose

See Also

IcmpClient Class | ComponentSpace.Icmp Namespace


IcmpClient.EndReceive Method

Completes the specified asynchronous receive operation.

[Visual Basic]
Public Function EndReceive( _
ByVal asyncResult As IAsyncResult _
) As IcmpMessage
[C#]
public IcmpMessage EndReceive(
IAsyncResult asyncResult
);

Parameters

asyncResult
The IAsyncResult that identifies the asynchronous receive operation to finish, and from which to retrieve an end result.

Return Value

The ICMP response message.

Remarks

When the ReceiveCompleted event is raised, EndReceive completes the operation that was initiated by the BeginReceive call.

Exceptions

Exception Type | Condition
IcmpException | Thrown when the message cannot be received.

See Also

IcmpClient Class | ComponentSpace.Icmp Namespace


IcmpClient.EndSend Method

Completes the specified asynchronous send operation.

[Visual Basic]
Public Sub EndSend( _
ByVal asyncResult As IAsyncResult _
)
[C#]
public void EndSend(
IAsyncResult asyncResult
);

Parameters

asyncResult
The IAsyncResult that identifies the asynchronous send operation to finish, and from which to retrieve an end result.

Remarks

When the SendCompleted event is raised, EndSend completes the operation that was initiated by the BeginSend call.

Exceptions

Exception Type | Condition
IcmpException | Thrown when the message cannot be sent.

See Also

IcmpClient Class | ComponentSpace.Icmp Namespace


IcmpClient.IsReply Method

Indicate whether the response correlates to the request.

[Visual Basic]
Public Function IsReply( _
ByVal request As IcmpMessage, _
ByVal response As IcmpMessage _
) As Boolean
[C#]
public bool IsReply(
IcmpMessage request,
IcmpMessage response
);

Return Value

true if the response correlates to the request; false otherwise

See Also

IcmpClient Class | ComponentSpace.Icmp Namespace


IcmpClient.Receive Method

Returns an ICMP response message from the server.

[Visual Basic]
Public Function Receive() As IcmpMessage
[C#]
public IcmpMessage Receive();

Return Value

The ICMP response message.

Exceptions

Exception Type | Condition
IcmpException | Thrown when the message cannot be received.

See Also

IcmpClient Class | ComponentSpace.Icmp Namespace


IcmpClient.Send Method

Send an ICMP request message to the server.

[Visual Basic]
Public Sub Send( _
ByVal icmpMessage As IcmpMessage _
)
[C#]
public void Send(
IcmpMessage icmpMessage
);

Parameters

icmpMessage
The ICMP request message to send.

Exceptions

Exception Type | Condition
IcmpException | Thrown when the message cannot be sent.

See Also

IcmpClient Class | ComponentSpace.Icmp Namespace


IcmpClient Events

The events of the IcmpClient class are listed below. For a complete list of IcmpClient class members, see the IcmpClient Members topic.

Public Instance Events

ReceiveCompleted | Occurs when the receive operation has completed.
SendCompleted | Occurs when the send operation has completed.

See Also

IcmpClient Class | ComponentSpace.Icmp Namespace


IcmpClient.ReceiveCompleted Event

Occurs when the receive operation has completed.

[Visual Basic]
Public Event ReceiveCompleted As ReceiveCompletedEventHandler
[C#]
public event ReceiveCompletedEventHandler ReceiveCompleted;

Event Data

The event handler receives an argument of type ReceiveCompletedEventArgs containing data related to this event. The following ReceiveCompletedEventArgs property provides information specific to this event.

Property | Description
AsyncResult | Gets the result of the asynchronous receive operation.

Remarks

BeginReceive is used in asynchronous processing to raise the ReceiveCompleted event when the receive operation has completed.

EndReceive is used to complete the operation initiated by a call to BeginReceive and get the receive status when the ReceiveCompleted event is raised.

See Also

IcmpClient Class | ComponentSpace.Icmp Namespace


IcmpClient.SendCompleted Event

Occurs when the send operation has completed.

[Visual Basic]
Public Event SendCompleted As SendCompletedEventHandler
[C#]
public event SendCompletedEventHandler SendCompleted;

Event Data

The event handler receives an argument of type SendCompletedEventArgs containing data related to this event. The following SendCompletedEventArgs property provides information specific to this event.

Property | Description
AsyncResult | Gets the result of the asynchronous send operation.

Remarks

BeginSend is used in asynchronous processing to raise the SendCompleted event when the send operation has completed.

EndSend is used to complete the operation initiated by a call to BeginSend and get the send status when the SendCompleted event is raised.

See Also

IcmpClient Class | ComponentSpace.Icmp Namespace


IcmpException Class

The exception that is thrown when an ICMP operation fails.

For a list of all members of this type, see IcmpException Members.

System.Object
System.Exception
System.ApplicationException
ComponentSpace.Icmp.IcmpException

[Visual Basic]
Public Class IcmpException
Inherits ApplicationException
[C#]
public class IcmpException : ApplicationException

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: ComponentSpace.Icmp

Assembly: ComponentSpace.Icmp (in ComponentSpace.Icmp.dll)

See Also

IcmpException Members | ComponentSpace.Icmp Namespace


IcmpException Members

IcmpException overview

Public Instance Properties

HelpLink (inherited from Exception) | Gets or sets a link to the help file associated with this exception.
InnerException (inherited from Exception) | Gets the Exception instance that caused the current exception.
Message (inherited from Exception) | Gets a message that describes the current exception.
Source (inherited from Exception) | Gets or sets the name of the application or the object that causes the error.
StackTrace (inherited from Exception) | Gets a string representation of the frames on the call stack at the time the current exception was thrown.
TargetSite (inherited from Exception) | Gets the method that throws the current exception.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetBaseException (inherited from Exception) | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetObjectData (inherited from Exception) | When overridden in a derived class, sets the SerializationInfo with information about the exception.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Exception) | Creates and returns a string representation of the current exception.

Protected Instance Properties

HResult (inherited from Exception) Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

IcmpException Class | ComponentSpace.Icmp Namespace


IcmpMessage Class

A ICMP request/response message.

For a list of all members of this type, see IcmpMessage Members.

System.Object
ComponentSpace.Icmp.IcmpMessage
Derived types

[Visual Basic]
MustInherit Public Class IcmpMessage
[C#]
public abstract class IcmpMessage

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

For specific message details refer to the ICMP RFC.

Requirements

Namespace: ComponentSpace.Icmp

Assembly: ComponentSpace.Icmp (in ComponentSpace.Icmp.dll)

See Also

IcmpMessage Members | ComponentSpace.Icmp Namespace


IcmpMessage Members

IcmpMessage overview

Public Static (Shared) Methods

Create Create the correct IcmpMessage based on the message type field.

Public Instance Constructors

IcmpMessage Overloaded. Initializes a new instance of the IcmpMessage class.

Public Instance Properties

Checksum | Get or sets the checksum.
Code | Get or sets the code value.
IpHeader | Get the IP header.
MessageType | Get or sets the message type.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
IsReply | Overloaded. Indicate whether the response correlates to the request.
ToByteArray | Convert the message into a byte array.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

IcmpMessage Class | ComponentSpace.Icmp Namespace


IcmpMessage Constructor

The default constructor.

Overload List

The default constructor.

public IcmpMessage();

Construct from a byte array.

public IcmpMessage(byte[],ref int,ref int);

See Also

IcmpMessage Class | ComponentSpace.Icmp Namespace


IcmpMessage Constructor ()

The default constructor.

[Visual Basic]
Overloads Public Sub New()
[C#]
public IcmpMessage();

See Also

IcmpMessage Class | ComponentSpace.Icmp Namespace | IcmpMessage Constructor Overload List


IcmpMessage Constructor (Byte[], Int32, Int32)

Construct from a byte array.

[Visual Basic]
Overloads Public Sub New( _
ByVal bytes As Byte(), _
ByRef index As Integer, _
ByRef count As Integer _
)
[C#]
public IcmpMessage(
byte[] bytes,
ref int index,
ref int count
);

Parameters

bytes
The byte array containing the message.
index
The index into the byte array.
count
The number of bytes available in the byte array.

See Also

IcmpMessage Class | ComponentSpace.Icmp Namespace | IcmpMessage Constructor Overload List


IcmpMessage Properties

The properties of the IcmpMessage class are listed below. For a complete list of IcmpMessage class members, see the IcmpMessage Members topic.

Public Instance Properties

Checksum | Get or sets the checksum.
Code | Get or sets the code value.
IpHeader | Get the IP header.
MessageType | Get or sets the message type.

See Also

IcmpMessage Class | ComponentSpace.Icmp Namespace


IcmpMessage.Checksum Property

Get or sets the checksum.

[Visual Basic]
Public Property Checksum As UInt16
[C#]
public ushort Checksum {get; set;}

Property Value

The checksum.

See Also

IcmpMessage Class | ComponentSpace.Icmp Namespace


IcmpMessage.Code Property

Get or sets the code value.

[Visual Basic]
Public Property Code As Byte
[C#]
public byte Code {get; set;}

Property Value

The code value. The defaukt value is zero.

See Also

IcmpMessage Class | ComponentSpace.Icmp Namespace


IcmpMessage.IpHeader Property

Get the IP header.

[Visual Basic]
Public ReadOnly Property IpHeader As IpHeader
[C#]
public IpHeader IpHeader {get;}

Property Value

The IP header.

See Also

IcmpMessage Class | ComponentSpace.Icmp Namespace


IcmpMessage.MessageType Property

Get or sets the message type.

[Visual Basic]
Public Property MessageType As Byte
[C#]
public byte MessageType {get; set;}

Property Value

The message type.

See Also

IcmpMessage Class | ComponentSpace.Icmp Namespace


IcmpMessage Methods

The methods of the IcmpMessage class are listed below. For a complete list of IcmpMessage class members, see the IcmpMessage Members topic.

Public Static (Shared) Methods

Create Create the correct IcmpMessage based on the message type field.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
IsReply | Overloaded. Indicate whether the response correlates to the request.
ToByteArray | Convert the message into a byte array.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

IcmpMessage Class | ComponentSpace.Icmp Namespace


IcmpMessage.Create Method

Create the correct IcmpMessage based on the message type field.

[Visual Basic]
Public Shared Function Create( _
ByVal bytes As Byte(), _
ByRef index As Integer, _
ByRef count As Integer _
) As IcmpMessage
[C#]
public static IcmpMessage Create(
byte[] bytes,
ref int index,
ref int count
);

Parameters

bytes
The byte array containing the message.
index
The index into the byte array.
count
The number of bytes available in the byte array.

Return Value

The IcmpMessage.

See Also

IcmpMessage Class | ComponentSpace.Icmp Namespace


IsReply Method

ComponentSpace ICMP Class Library Reference

IcmpMessage.IsReply Method

Indicate whether the response correlates to the request.

Overload List

Indicate whether the response correlates to the request.

public virtual bool IsReply(DestinationUnreachableMessage);

Indicate whether the response correlates to the request.

public virtual bool IsReply(EchoReplyMessage);

Indicate whether the response correlates to the request.

public virtual bool IsReply(IcmpMessage);

Indicate whether the response correlates to the request.

public virtual bool IsReply(InformationReplyMessage);

Indicate whether the response correlates to the request.

public virtual bool IsReply(ParameterProblemMessage);

Indicate whether the response correlates to the request.

public virtual bool IsReply(RedirectMessage);

Indicate whether the response correlates to the request.

public virtual bool IsReply(SourceQuenchMessage);

Indicate whether the response correlates to the request.

public virtual bool IsReply(TimeExceededMessage);

Indicate whether the response correlates to the request.

public virtual bool IsReply(TimestampReplyMessage);

See Also

IcmpMessage Class | ComponentSpace.Icmp Namespace


IcmpMessage.IsReply Method (DestinationUnreachableMessage)

Indicate whether the response correlates to the request.

[Visual Basic]
Overridable Overloads Public Function IsReply( _
ByVal response As DestinationUnreachableMessage _
) As Boolean
[C#]
public virtual bool IsReply(
DestinationUnreachableMessage response
);

Return Value

true if the response correlates to the request; false otherwise

See Also

IcmpMessage Class | ComponentSpace.Icmp Namespace | IcmpMessage.IsReply Overload List


IcmpMessage.IsReply Method (EchoReplyMessage)

Indicate whether the response correlates to the request.

[Visual Basic]
Overridable Overloads Public Function IsReply( _
ByVal response As EchoReplyMessage _
) As Boolean
[C#]
public virtual bool IsReply(
EchoReplyMessage response
);

Return Value

true if the response correlates to the request; false otherwise

See Also

IcmpMessage Class | ComponentSpace.Icmp Namespace | IcmpMessage.IsReply Overload List


IcmpMessage.IsReply Method (IcmpMessage)

Indicate whether the response correlates to the request.

[Visual Basic]
Overridable Overloads Public Function IsReply( _
ByVal response As IcmpMessage _
) As Boolean
[C#]
public virtual bool IsReply(
IcmpMessage response
);

Return Value

true if the response correlates to the request; false otherwise

See Also

IcmpMessage Class | ComponentSpace.Icmp Namespace | IcmpMessage.IsReply Overload List


IcmpMessage.IsReply Method (InformationReplyMessage)

Indicate whether the response correlates to the request.

[Visual Basic]
Overridable Overloads Public Function IsReply( _
ByVal response As InformationReplyMessage _
) As Boolean
[C#]
public virtual bool IsReply(
InformationReplyMessage response
);

Return Value

true if the response correlates to the request; false otherwise

See Also

IcmpMessage Class | ComponentSpace.Icmp Namespace | IcmpMessage.IsReply Overload List


IcmpMessage.IsReply Method (ParameterProblemMessage)

Indicate whether the response correlates to the request.

[Visual Basic]
Overridable Overloads Public Function IsReply( _
ByVal response As ParameterProblemMessage _
) As Boolean
[C#]
public virtual bool IsReply(
ParameterProblemMessage response
);

Return Value

true if the response correlates to the request; false otherwise

See Also

IcmpMessage Class | ComponentSpace.Icmp Namespace | IcmpMessage.IsReply Overload List


IcmpMessage.IsReply Method (RedirectMessage)

Indicate whether the response correlates to the request.

[Visual Basic]
Overridable Overloads Public Function IsReply( _
ByVal response As RedirectMessage _
) As Boolean
[C#]
public virtual bool IsReply(
RedirectMessage response
);

Return Value

true if the response correlates to the request; false otherwise

See Also

IcmpMessage Class | ComponentSpace.Icmp Namespace | IcmpMessage.IsReply Overload List


IcmpMessage.IsReply Method (SourceQuenchMessage)

Indicate whether the response correlates to the request.

[Visual Basic]
Overridable Overloads Public Function IsReply( _
ByVal response As SourceQuenchMessage _
) As Boolean
[C#]
public virtual bool IsReply(
SourceQuenchMessage response
);

Return Value

true if the response correlates to the request; false otherwise

See Also

IcmpMessage Class | ComponentSpace.Icmp Namespace | IcmpMessage.IsReply Overload List


IcmpMessage.IsReply Method (TimeExceededMessage)

Indicate whether the response correlates to the request.

[Visual Basic]
Overridable Overloads Public Function IsReply( _
ByVal response As TimeExceededMessage _
) As Boolean
[C#]
public virtual bool IsReply(
TimeExceededMessage response
);

Return Value

true if the response correlates to the request; false otherwise

See Also

IcmpMessage Class | ComponentSpace.Icmp Namespace | IcmpMessage.IsReply Overload List


IcmpMessage.IsReply Method (TimestampReplyMessage)

Indicate whether the response correlates to the request.

[Visual Basic]
Overridable Overloads Public Function IsReply( _
ByVal response As TimestampReplyMessage _
) As Boolean
[C#]
public virtual bool IsReply(
TimestampReplyMessage response
);

Return Value

true if the response correlates to the request; false otherwise

See Also

IcmpMessage Class | ComponentSpace.Icmp Namespace | IcmpMessage.IsReply Overload List


IcmpMessage.ToByteArray Method

Convert the message into a byte array.

[Visual Basic]
Overridable Public Function ToByteArray() As Byte()
[C#]
public virtual byte[] ToByteArray();

Return Value

The byte array containing the message.

See Also

IcmpMessage Class | ComponentSpace.Icmp Namespace


IcmpMessage.MessageTypes Enumeration

The message types.

[Visual Basic]
Public Enum IcmpMessage.MessageTypes
[C#]
public enum IcmpMessage.MessageTypes

Members

Member Name | Description
EchoReply | Echo Reply
DestinationUnreachable | Destination Unreachable
SourceQuench | Source Quench
Redirect | Redirect
Echo | Echo
TimeExceeded | Time Exceeded
ParameterProblem | Parameter Problem
Timestamp | Timestamp
TimestampReply | Timestamp Reply
InformationRequest | Information Request
InformationReply | Information Reply

Requirements

Namespace: ComponentSpace.Icmp

Assembly: ComponentSpace.Icmp (in ComponentSpace.Icmp.dll)

See Also

ComponentSpace.Icmp Namespace


InformationReplyMessage Class

The ICMP Information Reply Message.

For a list of all members of this type, see InformationReplyMessage Members.

System.Object
ComponentSpace.Icmp.IcmpMessage
ComponentSpace.Icmp.InformationReplyMessage

[Visual Basic]
Public Class InformationReplyMessage
Inherits IcmpMessage
[C#]
public class InformationReplyMessage : IcmpMessage

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: ComponentSpace.Icmp

Assembly: ComponentSpace.Icmp (in ComponentSpace.Icmp.dll)

See Also

InformationReplyMessage Members | ComponentSpace.Icmp Namespace


InformationReplyMessage Members

InformationReplyMessage overview

Public Instance Constructors

InformationReplyMessage Overloaded. Initializes a new instance of the InformationReplyMessage class.

Public Instance Properties

Checksum (inherited from IcmpMessage) | Get or sets the checksum.
Code (inherited from IcmpMessage) | Get or sets the code value.
Identifier | Gets or sets the identifier.
IpHeader (inherited from IcmpMessage) | Get the IP header.
MessageType (inherited from IcmpMessage) | Get or sets the message type.
SequenceNumber | Gets or sets the sequence number.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
IsReply (inherited from IcmpMessage) | Overloaded. Indicate whether the response correlates to the request.
ToByteArray | Convert the message into a byte array.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

InformationReplyMessage Class | ComponentSpace.Icmp Namespace


InformationReplyMessage Constructor

Initializes a new instance of the InformationReplyMessage class.

Overload List

Initializes a new instance of the InformationReplyMessage class.

public InformationReplyMessage();

Initializes a new instance of the InformationReplyMessage class from the byte array.

public InformationReplyMessage(byte[],ref int,ref int);

See Also

InformationReplyMessage Class | ComponentSpace.Icmp Namespace


InformationReplyMessage Constructor ()

Initializes a new instance of the InformationReplyMessage class.

[Visual Basic]
Overloads Public Sub New()
[C#]
public InformationReplyMessage();

See Also

InformationReplyMessage Class | ComponentSpace.Icmp Namespace | InformationReplyMessage Constructor Overload List


InformationReplyMessage Constructor (Byte[], Int32, Int32)

Initializes a new instance of the InformationReplyMessage class from the byte array.

[Visual Basic]
Overloads Public Sub New( _
ByVal bytes As Byte(), _
ByRef index As Integer, _
ByRef count As Integer _
)
[C#]
public InformationReplyMessage(
byte[] bytes,
ref int index,
ref int count
);

Parameters

bytes
The byte array containing the message.
index
The index into the byte array.
count
The number of bytes available in the byte array.

See Also

InformationReplyMessage Class | ComponentSpace.Icmp Namespace | InformationReplyMessage Constructor Overload List


InformationReplyMessage Properties

The properties of the InformationReplyMessage class are listed below. For a complete list of InformationReplyMessage class members, see the InformationReplyMessage Members topic.

Public Instance Properties

Checksum (inherited from IcmpMessage) | Get or sets the checksum.
Code (inherited from IcmpMessage) | Get or sets the code value.
Identifier | Gets or sets the identifier.
IpHeader (inherited from IcmpMessage) | Get the IP header.
MessageType (inherited from IcmpMessage) | Get or sets the message type.
SequenceNumber | Gets or sets the sequence number.

See Also

InformationReplyMessage Class | ComponentSpace.Icmp Namespace


InformationReplyMessage.Identifier Property

Gets or sets the identifier.

[Visual Basic]
Public Property Identifier As UInt16
[C#]
public ushort Identifier {get; set;}

Property Value

The identifier.

See Also

InformationReplyMessage Class | ComponentSpace.Icmp Namespace


InformationReplyMessage.SequenceNumber Property

Gets or sets the sequence number.

[Visual Basic]
Public Property SequenceNumber As UInt16
[C#]
public ushort SequenceNumber {get; set;}

Property Value

The sequence number.

See Also

InformationReplyMessage Class | ComponentSpace.Icmp Namespace


InformationReplyMessage Methods

The methods of the InformationReplyMessage class are listed below. For a complete list of InformationReplyMessage class members, see the InformationReplyMessage Members topic.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
IsReply (inherited from IcmpMessage) | Overloaded. Indicate whether the response correlates to the request.
ToByteArray | Convert the message into a byte array.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

InformationReplyMessage Class | ComponentSpace.Icmp Namespace


InformationReplyMessage.ToByteArray Method

Convert the message into a byte array.

[Visual Basic]
Overrides Public Function ToByteArray() As Byte()
[C#]
public override byte[] ToByteArray();

Return Value

The byte array containing the message.

See Also

InformationReplyMessage Class | ComponentSpace.Icmp Namespace


InformationRequestMessage Class

The ICMP Information Request Message.

For a list of all members of this type, see InformationRequestMessage Members.

System.Object
ComponentSpace.Icmp.IcmpMessage
ComponentSpace.Icmp.InformationRequestMessage

[Visual Basic]
Public Class InformationRequestMessage
Inherits IcmpMessage
[C#]
public class InformationRequestMessage : IcmpMessage

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: ComponentSpace.Icmp

Assembly: ComponentSpace.Icmp (in ComponentSpace.Icmp.dll)

See Also

InformationRequestMessage Members | ComponentSpace.Icmp Namespace


InformationRequestMessage Members

InformationRequestMessage overview

Public Instance Constructors

InformationRequestMessage Overloaded. Initializes a new instance of the InformationRequestMessage class.

Public Instance Properties

Checksum (inherited from IcmpMessage) | Get or sets the checksum.
Code (inherited from IcmpMessage) | Get or sets the code value.
Identifier | Gets or sets the identifier.
IpHeader (inherited from IcmpMessage) | Get the IP header.
MessageType (inherited from IcmpMessage) | Get or sets the message type.
SequenceNumber | Gets or sets the sequence number.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
IsReply (inherited from IcmpMessage) | Overloaded. Indicate whether the response correlates to the request.
IsReply | Overloaded. Indicate whether the response correlates to the request.
ToByteArray | Convert the message into a byte array.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

InformationRequestMessage Class | ComponentSpace.Icmp Namespace


InformationRequestMessage Constructor

Initializes a new instance of the InformationRequestMessage class.

Overload List

Initializes a new instance of the InformationRequestMessage class.

public InformationRequestMessage();

Initializes a new instance of the InformationRequestMessage class from the byte array.

public InformationRequestMessage(byte[],ref int,ref int);

See Also

InformationRequestMessage Class | ComponentSpace.Icmp Namespace


InformationRequestMessage Constructor ()

Initializes a new instance of the InformationRequestMessage class.

[Visual Basic]
Overloads Public Sub New()
[C#]
public InformationRequestMessage();

See Also

InformationRequestMessage Class | ComponentSpace.Icmp Namespace | InformationRequestMessage Constructor Overload List


InformationRequestMessage Constructor (Byte[], Int32, Int32)

Initializes a new instance of the InformationRequestMessage class from the byte array.

[Visual Basic]
Overloads Public Sub New( _
ByVal bytes As Byte(), _
ByRef index As Integer, _
ByRef count As Integer _
)
[C#]
public InformationRequestMessage(
byte[] bytes,
ref int index,
ref int count
);

Parameters

bytes
The byte array containing the message.
index
The index into the byte array.
count
The number of bytes available in the byte array.

See Also

InformationRequestMessage Class | ComponentSpace.Icmp Namespace | InformationRequestMessage Constructor Overload List


InformationRequestMessage Properties

The properties of the InformationRequestMessage class are listed below. For a complete list of InformationRequestMessage class members, see the InformationRequestMessage Members topic.

Public Instance Properties

Checksum (inherited from IcmpMessage) | Get or sets the checksum.
Code (inherited from IcmpMessage) | Get or sets the code value.
Identifier | Gets or sets the identifier.
IpHeader (inherited from IcmpMessage) | Get the IP header.
MessageType (inherited from IcmpMessage) | Get or sets the message type.
SequenceNumber | Gets or sets the sequence number.

See Also

InformationRequestMessage Class | ComponentSpace.Icmp Namespace


InformationRequestMessage.Identifier Property

Gets or sets the identifier.

[Visual Basic]
Public Property Identifier As UInt16
[C#]
public ushort Identifier {get; set;}

Property Value

The identifier. The default is zero.

See Also

InformationRequestMessage Class | ComponentSpace.Icmp Namespace


InformationRequestMessage.SequenceNumber Property

Gets or sets the sequence number.

[Visual Basic]
Public Property SequenceNumber As UInt16
[C#]
public ushort SequenceNumber {get; set;}

Property Value

The sequence number. The default is an auto incrementing number.

See Also

InformationRequestMessage Class | ComponentSpace.Icmp Namespace


InformationRequestMessage Methods

The methods of the InformationRequestMessage class are listed below. For a complete list of InformationRequestMessage class members, see the InformationRequestMessage Members topic.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
IsReply (inherited from IcmpMessage) | Overloaded. Indicate whether the response correlates to the request.
IsReply | Overloaded. Indicate whether the response correlates to the request.
ToByteArray | Convert the message into a byte array.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

InformationRequestMessage Class | ComponentSpace.Icmp Namespace


IsReply Method

ComponentSpace ICMP Class Library Reference

InformationRequestMessage.IsReply Method

Indicate whether the response correlates to the request.

Overload List

Inherited from IcmpMessage.

public virtual bool IsReply(DestinationUnreachableMessage);

Inherited from IcmpMessage.

public virtual bool IsReply(EchoReplyMessage);

Inherited from IcmpMessage.

public virtual bool IsReply(IcmpMessage);

Indicate whether the response correlates to the request.

public override bool IsReply(InformationReplyMessage);

Inherited from IcmpMessage.

public virtual bool IsReply(ParameterProblemMessage);

Inherited from IcmpMessage.

public virtual bool IsReply(RedirectMessage);

Inherited from IcmpMessage.

public virtual bool IsReply(SourceQuenchMessage);

Inherited from IcmpMessage.

public virtual bool IsReply(TimeExceededMessage);

Inherited from IcmpMessage.

public virtual bool IsReply(TimestampReplyMessage);

See Also

InformationRequestMessage Class | ComponentSpace.Icmp Namespace


InformationRequestMessage.IsReply Method (InformationReplyMessage)

Indicate whether the response correlates to the request.

[Visual Basic]
Overrides Overloads Public Function IsReply( _
ByVal response As InformationReplyMessage _
) As Boolean
[C#]
public override bool IsReply(
InformationReplyMessage response
);

Return Value

true if the response correlates to the request; false otherwise

See Also

InformationRequestMessage Class | ComponentSpace.Icmp Namespace | InformationRequestMessage.IsReply Overload List


InformationRequestMessage.ToByteArray Method

Convert the message into a byte array.

[Visual Basic]
Overrides Public Function ToByteArray() As Byte()
[C#]
public override byte[] ToByteArray();

Return Value

The byte array containing the message.

See Also

InformationRequestMessage Class | ComponentSpace.Icmp Namespace


IpHeader Class

An IPv4 header.

For a list of all members of this type, see IpHeader Members.

System.Object
ComponentSpace.Icmp.IpHeader

[Visual Basic]
Public Class IpHeader
[C#]
public class IpHeader

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

For specific message details refer to the IPv4 RFC.

Requirements

Namespace: ComponentSpace.Icmp

Assembly: ComponentSpace.Icmp (in ComponentSpace.Icmp.dll)

See Also

IpHeader Members | ComponentSpace.Icmp Namespace


IpHeader Members

IpHeader overview

Public Static (Shared) Fields

MinimumInternetHeaderLength The minimum header length in bytes.

Public Static (Shared) Methods

GetHeaderLengthInBytes Initializes a new instance of the IpHeader class from the byte array.

Public Instance Constructors

IpHeader Overloaded. Initializes a new instance of the IpHeader class.

Public Instance Properties

DestinationAddress | Get the destination address.
Flags | Get the flags.
FragmentOffset | Get the fragment offset.
HeaderChecksum | Get the header checksum.
HeaderLength | Get the header length in 32 bit words.
HeaderLengthInBytes | Get the header length in bytes.
Identification | Get the identification.
Protocol | Get the protocol.
SourceAddress | Get the source address.
TimeToLive | Get the time to live.
TotalLength | Get the total length of the header and data.
TypeOfService | Get the type of service.
Version | Get the version.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

IpHeader Class | ComponentSpace.Icmp Namespace


IpHeader Constructor

Initializes a new instance of the IpHeader class.

Overload List

Initializes a new instance of the IpHeader class.

public IpHeader();

Initializes a new instance of the IpHeader class from the byte array.

public IpHeader(byte[],ref int,ref int);

See Also

IpHeader Class | ComponentSpace.Icmp Namespace


IpHeader Constructor ()

Initializes a new instance of the IpHeader class.

[Visual Basic]
Overloads Public Sub New()
[C#]
public IpHeader();

See Also

IpHeader Class | ComponentSpace.Icmp Namespace | IpHeader Constructor Overload List


IpHeader Constructor (Byte[], Int32, Int32)

Initializes a new instance of the IpHeader class from the byte array.

[Visual Basic]
Overloads Public Sub New( _
ByVal bytes As Byte(), _
ByRef index As Integer, _
ByRef count As Integer _
)
[C#]
public IpHeader(
byte[] bytes,
ref int index,
ref int count
);

Parameters

bytes
The byte array containing the header.
index
The index into the byte array.
count
The number of bytes available in the byte array.

See Also

IpHeader Class | ComponentSpace.Icmp Namespace | IpHeader Constructor Overload List


IpHeader Fields

The fields of the IpHeader class are listed below. For a complete list of IpHeader class members, see the IpHeader Members topic.

Public Static (Shared) Fields

MinimumInternetHeaderLength The minimum header length in bytes.

See Also

IpHeader Class | ComponentSpace.Icmp Namespace


IpHeader.MinimumInternetHeaderLength Field

The minimum header length in bytes.

[Visual Basic]
Public Const MinimumInternetHeaderLength As Integer = 20
[C#]
public const int MinimumInternetHeaderLength = 20;

See Also

IpHeader Class | ComponentSpace.Icmp Namespace


IpHeader Properties

The properties of the IpHeader class are listed below. For a complete list of IpHeader class members, see the IpHeader Members topic.

Public Instance Properties

DestinationAddress | Get the destination address.
Flags | Get the flags.
FragmentOffset | Get the fragment offset.
HeaderChecksum | Get the header checksum.
HeaderLength | Get the header length in 32 bit words.
HeaderLengthInBytes | Get the header length in bytes.
Identification | Get the identification.
Protocol | Get the protocol.
SourceAddress | Get the source address.
TimeToLive | Get the time to live.
TotalLength | Get the total length of the header and data.
TypeOfService | Get the type of service.
Version | Get the version.

See Also

IpHeader Class | ComponentSpace.Icmp Namespace


IpHeader.DestinationAddress Property

Get the destination address.

[Visual Basic]
Public ReadOnly Property DestinationAddress As UInt32
[C#]
public uint DestinationAddress {get;}

Property Value

The destination address.

See Also

IpHeader Class | ComponentSpace.Icmp Namespace


IpHeader.Flags Property

Get the flags.

[Visual Basic]
Public ReadOnly Property Flags As Byte
[C#]
public byte Flags {get;}

Property Value

The flags.

See Also

IpHeader Class | ComponentSpace.Icmp Namespace


IpHeader.FragmentOffset Property

Get the fragment offset.

[Visual Basic]
Public ReadOnly Property FragmentOffset As UInt16
[C#]
public ushort FragmentOffset {get;}

Property Value

The fragment offset.

See Also

IpHeader Class | ComponentSpace.Icmp Namespace


IpHeader.HeaderChecksum Property

Get the header checksum.

[Visual Basic]
Public ReadOnly Property HeaderChecksum As UInt16
[C#]
public ushort HeaderChecksum {get;}

Property Value

The header checksum.

See Also

IpHeader Class | ComponentSpace.Icmp Namespace


IpHeader.HeaderLength Property

Get the header length in 32 bit words.

[Visual Basic]
Public ReadOnly Property HeaderLength As Byte
[C#]
public byte HeaderLength {get;}

Property Value

The header length in 32 bit words.

See Also

IpHeader Class | ComponentSpace.Icmp Namespace


IpHeader.HeaderLengthInBytes Property

Get the header length in bytes.

[Visual Basic]
Public ReadOnly Property HeaderLengthInBytes As UInt16
[C#]
public ushort HeaderLengthInBytes {get;}

Property Value

The header length in bytes.

See Also

IpHeader Class | ComponentSpace.Icmp Namespace


IpHeader.Identification Property

Get the identification.

[Visual Basic]
Public ReadOnly Property Identification As UInt16
[C#]
public ushort Identification {get;}

Property Value

The identification.

See Also

IpHeader Class | ComponentSpace.Icmp Namespace


IpHeader.Protocol Property

Get the protocol.

[Visual Basic]
Public ReadOnly Property Protocol As Byte
[C#]
public byte Protocol {get;}

Property Value

The protocol.

See Also

IpHeader Class | ComponentSpace.Icmp Namespace


IpHeader.SourceAddress Property

Get the source address.

[Visual Basic]
Public ReadOnly Property SourceAddress As UInt32
[C#]
public uint SourceAddress {get;}

Property Value

The source address.

See Also

IpHeader Class | ComponentSpace.Icmp Namespace


IpHeader.TimeToLive Property

Get the time to live.

[Visual Basic]
Public ReadOnly Property TimeToLive As Byte
[C#]
public byte TimeToLive {get;}

Property Value

The time to live.

See Also

IpHeader Class | ComponentSpace.Icmp Namespace


IpHeader.TotalLength Property

Get the total length of the header and data.

[Visual Basic]
Public ReadOnly Property TotalLength As UInt16
[C#]
public ushort TotalLength {get;}

Property Value

The total length of the header and data.

See Also

IpHeader Class | ComponentSpace.Icmp Namespace


IpHeader.TypeOfService Property

Get the type of service.

[Visual Basic]
Public ReadOnly Property TypeOfService As Byte
[C#]
public byte TypeOfService {get;}

Property Value

The type of service.

See Also

IpHeader Class | ComponentSpace.Icmp Namespace


IpHeader.Version Property

Get the version.

[Visual Basic]
Public ReadOnly Property Version As Byte
[C#]
public byte Version {get;}

Property Value

The version.

See Also

IpHeader Class | ComponentSpace.Icmp Namespace


IpHeader Methods

The methods of the IpHeader class are listed below. For a complete list of IpHeader class members, see the IpHeader Members topic.

Public Static (Shared) Methods

GetHeaderLengthInBytes Initializes a new instance of the IpHeader class from the byte array.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

IpHeader Class | ComponentSpace.Icmp Namespace


IpHeader.GetHeaderLengthInBytes Method

Initializes a new instance of the IpHeader class from the byte array.

[Visual Basic]
Public Shared Function GetHeaderLengthInBytes( _
ByVal bytes As Byte(), _
ByVal index As Integer, _
ByVal count As Integer _
) As UInt16
[C#]
public static ushort GetHeaderLengthInBytes(
byte[] bytes,
int index,
int count
);

Parameters

bytes
The byte array containing the header.
index
The index into the byte array.
count
The number of bytes available in the byte array.

See Also

IpHeader Class | ComponentSpace.Icmp Namespace


ParameterProblemMessage Class

The ICMP Parameter Problem Message.

For a list of all members of this type, see ParameterProblemMessage Members.

System.Object
ComponentSpace.Icmp.IcmpMessage
ComponentSpace.Icmp.ParameterProblemMessage

[Visual Basic]
Public Class ParameterProblemMessage
Inherits IcmpMessage
[C#]
public class ParameterProblemMessage : IcmpMessage

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: ComponentSpace.Icmp

Assembly: ComponentSpace.Icmp (in ComponentSpace.Icmp.dll)

See Also

ParameterProblemMessage Members | ComponentSpace.Icmp Namespace


ParameterProblemMessage Members

ParameterProblemMessage overview

Public Instance Constructors

ParameterProblemMessage Overloaded. Initializes a new instance of the ParameterProblemMessage class.

Public Instance Properties

Checksum (inherited from IcmpMessage) | Get or sets the checksum.
Code (inherited from IcmpMessage) | Get or sets the code value.
Data | Gets or sets the original data.
IpHeader (inherited from IcmpMessage) | Get the IP header.
MessageType (inherited from IcmpMessage) | Get or sets the message type.
Pointer | Gets or sets the offset to where the error was detected.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
IsReply (inherited from IcmpMessage) | Overloaded. Indicate whether the response correlates to the request.
ToByteArray | Convert the message into a byte array.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

ParameterProblemMessage Class | ComponentSpace.Icmp Namespace


ParameterProblemMessage Constructor

Initializes a new instance of the ParameterProblemMessage class.

Overload List

Initializes a new instance of the ParameterProblemMessage class.

public ParameterProblemMessage();

Initializes a new instance of the ParameterProblemMessage class from the byte array.

public ParameterProblemMessage(byte[],ref int,ref int);

See Also

ParameterProblemMessage Class | ComponentSpace.Icmp Namespace


ParameterProblemMessage Constructor ()

Initializes a new instance of the ParameterProblemMessage class.

[Visual Basic]
Overloads Public Sub New()
[C#]
public ParameterProblemMessage();

See Also

ParameterProblemMessage Class | ComponentSpace.Icmp Namespace | ParameterProblemMessage Constructor Overload List


ParameterProblemMessage Constructor (Byte[], Int32, Int32)

Initializes a new instance of the ParameterProblemMessage class from the byte array.

[Visual Basic]
Overloads Public Sub New( _
ByVal bytes As Byte(), _
ByRef index As Integer, _
ByRef count As Integer _
)
[C#]
public ParameterProblemMessage(
byte[] bytes,
ref int index,
ref int count
);

Parameters

bytes
The byte array containing the message.
index
The index into the byte array.
count
The number of bytes available in the byte array.

See Also

ParameterProblemMessage Class | ComponentSpace.Icmp Namespace | ParameterProblemMessage Constructor Overload List


ParameterProblemMessage Properties

The properties of the ParameterProblemMessage class are listed below. For a complete list of ParameterProblemMessage class members, see the ParameterProblemMessage Members topic.

Public Instance Properties

Checksum (inherited from IcmpMessage) | Get or sets the checksum.
Code (inherited from IcmpMessage) | Get or sets the code value.
Data | Gets or sets the original data.
IpHeader (inherited from IcmpMessage) | Get the IP header.
MessageType (inherited from IcmpMessage) | Get or sets the message type.
Pointer | Gets or sets the offset to where the error was detected.

See Also

ParameterProblemMessage Class | ComponentSpace.Icmp Namespace


ParameterProblemMessage.Data Property

Gets or sets the original data.

[Visual Basic]
Public Property Data As Byte()
[C#]
public byte[] Data {get; set;}

Property Value

The original data.

See Also

ParameterProblemMessage Class | ComponentSpace.Icmp Namespace


ParameterProblemMessage.Pointer Property

Gets or sets the offset to where the error was detected.

[Visual Basic]
Public Property Pointer As Byte
[C#]
public byte Pointer {get; set;}

Property Value

The offset to where the error was detected.

See Also

ParameterProblemMessage Class | ComponentSpace.Icmp Namespace


ParameterProblemMessage Methods

The methods of the ParameterProblemMessage class are listed below. For a complete list of ParameterProblemMessage class members, see the ParameterProblemMessage Members topic.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
IsReply (inherited from IcmpMessage) | Overloaded. Indicate whether the response correlates to the request.
ToByteArray | Convert the message into a byte array.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

ParameterProblemMessage Class | ComponentSpace.Icmp Namespace


ParameterProblemMessage.ToByteArray Method

Convert the message into a byte array.

[Visual Basic]
Overrides Public Function ToByteArray() As Byte()
[C#]
public override byte[] ToByteArray();

Return Value

The byte array containing the message.

See Also

ParameterProblemMessage Class | ComponentSpace.Icmp Namespace


ReceiveCompletedEventArgs Class

Provides data for the ReceiveCompleted event.

For a list of all members of this type, see ReceiveCompletedEventArgs Members.

System.Object
System.EventArgs
ComponentSpace.Icmp.ReceiveCompletedEventArgs

[Visual Basic]
Public Class ReceiveCompletedEventArgs
Inherits EventArgs
[C#]
public class ReceiveCompletedEventArgs : EventArgs

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

The ReceiveCompleted event is raised by the IcmpClient. It contains all the information needed to complete the asynchronous receive operation.

Requirements

Namespace: ComponentSpace.Icmp

Assembly: ComponentSpace.Icmp (in ComponentSpace.Icmp.dll)

See Also

ReceiveCompletedEventArgs Members | ComponentSpace.Icmp Namespace


ReceiveCompletedEventArgs Members

ReceiveCompletedEventArgs overview

Public Instance Properties

AsyncResult Gets the result of the asynchronous receive operation.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

ReceiveCompletedEventArgs Class | ComponentSpace.Icmp Namespace


ReceiveCompletedEventArgs Properties

The properties of the ReceiveCompletedEventArgs class are listed below. For a complete list of ReceiveCompletedEventArgs class members, see the ReceiveCompletedEventArgs Members topic.

Public Instance Properties

AsyncResult Gets the result of the asynchronous receive operation.

See Also

ReceiveCompletedEventArgs Class | ComponentSpace.Icmp Namespace


ReceiveCompletedEventArgs.AsyncResult Property

Gets the result of the asynchronous receive operation.

[Visual Basic]
Public ReadOnly Property AsyncResult As IAsyncResult
[C#]
public System.IAsyncResult AsyncResult {get;}

Property Value

An IAsyncResult that contains the data associated with the receive operation.

Remarks

AsyncResult identifies ongoing or completed asynchronous operations. The property contains data that helps determine which of several potential asynchronous operations to complete, and when passed to the event handler, enables EndReceive to access the response message associated with the completed operation.

See Also

ReceiveCompletedEventArgs Class | ComponentSpace.Icmp Namespace


ReceiveCompletedEventHandler Delegate

Represents the method that will handle the ReceiveCompleted event.

[Visual Basic]
Public Delegate Sub ReceiveCompletedEventHandler( _
ByVal sender As Object, _
ByVal e As ReceiveCompletedEventArgs _
)
[C#]
public delegate void ReceiveCompletedEventHandler(
object sender,
ReceiveCompletedEventArgs e
);

Parameters

sender
The source of the event.
e
A ReceiveCompletedEventArgs that contains the event data.

Remarks

When you create a ReceiveCompletedEventHandler delegate, you identify the method that will handle the event. To associate the event with your event handler, add an instance of the delegate to the event. The event handler is called whenever the event occurs, unless you remove the delegate.

Requirements

Namespace: ComponentSpace.Icmp

Assembly: ComponentSpace.Icmp (in ComponentSpace.Icmp.dll)

See Also

ComponentSpace.Icmp Namespace


RedirectMessage Class

The ICMP Redirect Message.

For a list of all members of this type, see RedirectMessage Members.

System.Object
ComponentSpace.Icmp.IcmpMessage
ComponentSpace.Icmp.RedirectMessage

[Visual Basic]
Public Class RedirectMessage
Inherits IcmpMessage
[C#]
public class RedirectMessage : IcmpMessage

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: ComponentSpace.Icmp

Assembly: ComponentSpace.Icmp (in ComponentSpace.Icmp.dll)

See Also

RedirectMessage Members | ComponentSpace.Icmp Namespace


RedirectMessage Members

RedirectMessage overview

Public Instance Constructors

RedirectMessage Overloaded. Initializes a new instance of the RedirectMessage class.

Public Instance Properties

Checksum (inherited from IcmpMessage) | Get or sets the checksum.
Code (inherited from IcmpMessage) | Get or sets the code value.
Data | Gets or sets the original data.
GatewayAddress | Gets or sets the gateway internet address.
IpHeader (inherited from IcmpMessage) | Get the IP header.
MessageType (inherited from IcmpMessage) | Get or sets the message type.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
IsReply (inherited from IcmpMessage) | Overloaded. Indicate whether the response correlates to the request.
ToByteArray | Convert the message into a byte array.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

RedirectMessage Class | ComponentSpace.Icmp Namespace


RedirectMessage Constructor

Initializes a new instance of the RedirectMessage class.

Overload List

Initializes a new instance of the RedirectMessage class.

public RedirectMessage();

Initializes a new instance of the RedirectMessage class from the byte array.

public RedirectMessage(byte[],ref int,ref int);

See Also

RedirectMessage Class | ComponentSpace.Icmp Namespace


RedirectMessage Constructor ()

Initializes a new instance of the RedirectMessage class.

[Visual Basic]
Overloads Public Sub New()
[C#]
public RedirectMessage();

See Also

RedirectMessage Class | ComponentSpace.Icmp Namespace | RedirectMessage Constructor Overload List


RedirectMessage Constructor (Byte[], Int32, Int32)

Initializes a new instance of the RedirectMessage class from the byte array.

[Visual Basic]
Overloads Public Sub New( _
ByVal bytes As Byte(), _
ByRef index As Integer, _
ByRef count As Integer _
)
[C#]
public RedirectMessage(
byte[] bytes,
ref int index,
ref int count
);

Parameters

bytes
The byte array containing the message.
index
The index into the byte array.
count
The number of bytes available in the byte array.

See Also

RedirectMessage Class | ComponentSpace.Icmp Namespace | RedirectMessage Constructor Overload List


RedirectMessage Properties

The properties of the RedirectMessage class are listed below. For a complete list of RedirectMessage class members, see the RedirectMessage Members topic.

Public Instance Properties

Checksum (inherited from IcmpMessage) | Get or sets the checksum.
Code (inherited from IcmpMessage) | Get or sets the code value.
Data | Gets or sets the original data.
GatewayAddress | Gets or sets the gateway internet address.
IpHeader (inherited from IcmpMessage) | Get the IP header.
MessageType (inherited from IcmpMessage) | Get or sets the message type.

See Also

RedirectMessage Class | ComponentSpace.Icmp Namespace


RedirectMessage.Data Property

Gets or sets the original data.

[Visual Basic]
Public Property Data As Byte()
[C#]
public byte[] Data {get; set;}

Property Value

The original data.

See Also

RedirectMessage Class | ComponentSpace.Icmp Namespace


RedirectMessage.GatewayAddress Property

Gets or sets the gateway internet address.

[Visual Basic]
Public Property GatewayAddress As UInt32
[C#]
public uint GatewayAddress {get; set;}

Property Value

The gateway internet address.

See Also

RedirectMessage Class | ComponentSpace.Icmp Namespace


RedirectMessage Methods

The methods of the RedirectMessage class are listed below. For a complete list of RedirectMessage class members, see the RedirectMessage Members topic.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
IsReply (inherited from IcmpMessage) | Overloaded. Indicate whether the response correlates to the request.
ToByteArray | Convert the message into a byte array.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

RedirectMessage Class | ComponentSpace.Icmp Namespace


RedirectMessage.ToByteArray Method

Convert the message into a byte array.

[Visual Basic]
Overrides Public Function ToByteArray() As Byte()
[C#]
public override byte[] ToByteArray();

Return Value

The byte array containing the message.

See Also

RedirectMessage Class | ComponentSpace.Icmp Namespace


SendCompletedEventArgs Class

Provides data for the SendCompleted event.

For a list of all members of this type, see SendCompletedEventArgs Members.

System.Object
System.EventArgs
ComponentSpace.Icmp.SendCompletedEventArgs

[Visual Basic]
Public Class SendCompletedEventArgs
Inherits EventArgs
[C#]
public class SendCompletedEventArgs : EventArgs

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

The SendCompleted event is raised by the IcmpClient. It contains all the information needed to complete the asynchronous send operation.

Requirements

Namespace: ComponentSpace.Icmp

Assembly: ComponentSpace.Icmp (in ComponentSpace.Icmp.dll)

See Also

SendCompletedEventArgs Members | ComponentSpace.Icmp Namespace


SendCompletedEventArgs Members

SendCompletedEventArgs overview

Public Instance Properties

AsyncResult Gets the result of the asynchronous send operation.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

SendCompletedEventArgs Class | ComponentSpace.Icmp Namespace


SendCompletedEventArgs Properties

The properties of the SendCompletedEventArgs class are listed below. For a complete list of SendCompletedEventArgs class members, see the SendCompletedEventArgs Members topic.

Public Instance Properties

AsyncResult Gets the result of the asynchronous send operation.

See Also

SendCompletedEventArgs Class | ComponentSpace.Icmp Namespace


SendCompletedEventArgs.AsyncResult Property

Gets the result of the asynchronous send operation.

[Visual Basic]
Public ReadOnly Property AsyncResult As IAsyncResult
[C#]
public System.IAsyncResult AsyncResult {get;}

Property Value

An IAsyncResult that contains the data associated with the send operation.

Remarks

AsyncResult identifies ongoing or completed asynchronous operations. The property contains data that helps determine which of several potential asynchronous operations to complete, and when passed to the event handler, enables EndSend to access the response message associated with the completed operation.

See Also

SendCompletedEventArgs Class | ComponentSpace.Icmp Namespace


SendCompletedEventHandler Delegate

Represents the method that will handle the SendCompleted event.

[Visual Basic]
Public Delegate Sub SendCompletedEventHandler( _
ByVal sender As Object, _
ByVal e As SendCompletedEventArgs _
)
[C#]
public delegate void SendCompletedEventHandler(
object sender,
SendCompletedEventArgs e
);

Parameters

sender
The source of the event.
e
A SendCompletedEventArgs that contains the event data.

Remarks

When you create a SendCompletedEventHandler delegate, you identify the method that will handle the event. To associate the event with your event handler, add an instance of the delegate to the event. The event handler is called whenever the event occurs, unless you remove the delegate.

Requirements

Namespace: ComponentSpace.Icmp

Assembly: ComponentSpace.Icmp (in ComponentSpace.Icmp.dll)

See Also

ComponentSpace.Icmp Namespace


SourceQuenchMessage Class

The ICMP Source Quench Message.

For a list of all members of this type, see SourceQuenchMessage Members.

System.Object
ComponentSpace.Icmp.IcmpMessage
ComponentSpace.Icmp.SourceQuenchMessage

[Visual Basic]
Public Class SourceQuenchMessage
Inherits IcmpMessage
[C#]
public class SourceQuenchMessage : IcmpMessage

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: ComponentSpace.Icmp

Assembly: ComponentSpace.Icmp (in ComponentSpace.Icmp.dll)

See Also

SourceQuenchMessage Members | ComponentSpace.Icmp Namespace


SourceQuenchMessage Members

SourceQuenchMessage overview

Public Instance Constructors

SourceQuenchMessage Overloaded. Initializes a new instance of the SourceQuenchMessage class.

Public Instance Properties

Checksum (inherited from IcmpMessage) | Get or sets the checksum.
Code (inherited from IcmpMessage) | Get or sets the code value.
Data | Gets or sets the original data.
IpHeader (inherited from IcmpMessage) | Get the IP header.
MessageType (inherited from IcmpMessage) | Get or sets the message type.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
IsReply (inherited from IcmpMessage) | Overloaded. Indicate whether the response correlates to the request.
ToByteArray | Convert the message into a byte array.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

SourceQuenchMessage Class | ComponentSpace.Icmp Namespace


SourceQuenchMessage Constructor

Initializes a new instance of the SourceQuenchMessage class.

Overload List

Initializes a new instance of the SourceQuenchMessage class.

public SourceQuenchMessage();

Initializes a new instance of the SourceQuenchMessage class from the byte array.

public SourceQuenchMessage(byte[],ref int,ref int);

See Also

SourceQuenchMessage Class | ComponentSpace.Icmp Namespace


SourceQuenchMessage Constructor ()

Initializes a new instance of the SourceQuenchMessage class.

[Visual Basic]
Overloads Public Sub New()
[C#]
public SourceQuenchMessage();

See Also

SourceQuenchMessage Class | ComponentSpace.Icmp Namespace | SourceQuenchMessage Constructor Overload List


SourceQuenchMessage Constructor (Byte[], Int32, Int32)

Initializes a new instance of the SourceQuenchMessage class from the byte array.

[Visual Basic]
Overloads Public Sub New( _
ByVal bytes As Byte(), _
ByRef index As Integer, _
ByRef count As Integer _
)
[C#]
public SourceQuenchMessage(
byte[] bytes,
ref int index,
ref int count
);

Parameters

bytes
The byte array containing the message.
index
The index into the byte array.
count
The number of bytes available in the byte array.

See Also

SourceQuenchMessage Class | ComponentSpace.Icmp Namespace | SourceQuenchMessage Constructor Overload List


SourceQuenchMessage Properties

The properties of the SourceQuenchMessage class are listed below. For a complete list of SourceQuenchMessage class members, see the SourceQuenchMessage Members topic.

Public Instance Properties

Checksum (inherited from IcmpMessage) | Get or sets the checksum.
Code (inherited from IcmpMessage) | Get or sets the code value.
Data | Gets or sets the original data.
IpHeader (inherited from IcmpMessage) | Get the IP header.
MessageType (inherited from IcmpMessage) | Get or sets the message type.

See Also

SourceQuenchMessage Class | ComponentSpace.Icmp Namespace


SourceQuenchMessage.Data Property

Gets or sets the original data.

[Visual Basic]
Public Property Data As Byte()
[C#]
public byte[] Data {get; set;}

Property Value

The original data.

See Also

SourceQuenchMessage Class | ComponentSpace.Icmp Namespace


SourceQuenchMessage Methods

The methods of the SourceQuenchMessage class are listed below. For a complete list of SourceQuenchMessage class members, see the SourceQuenchMessage Members topic.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
IsReply (inherited from IcmpMessage) | Overloaded. Indicate whether the response correlates to the request.
ToByteArray | Convert the message into a byte array.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

SourceQuenchMessage Class | ComponentSpace.Icmp Namespace


SourceQuenchMessage.ToByteArray Method

Convert the message into a byte array.

[Visual Basic]
Overrides Public Function ToByteArray() As Byte()
[C#]
public override byte[] ToByteArray();

Return Value

The byte array containing the message.

See Also

SourceQuenchMessage Class | ComponentSpace.Icmp Namespace


TimeExceededMessage Class

The ICMP Time Exceeded Message.

For a list of all members of this type, see TimeExceededMessage Members.

System.Object
ComponentSpace.Icmp.IcmpMessage
ComponentSpace.Icmp.TimeExceededMessage

[Visual Basic]
Public Class TimeExceededMessage
Inherits IcmpMessage
[C#]
public class TimeExceededMessage : IcmpMessage

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: ComponentSpace.Icmp

Assembly: ComponentSpace.Icmp (in ComponentSpace.Icmp.dll)

See Also

TimeExceededMessage Members | ComponentSpace.Icmp Namespace


TimeExceededMessage Members

TimeExceededMessage overview

Public Instance Constructors

TimeExceededMessage Overloaded. Initializes a new instance of the TimeExceededMessage class.

Public Instance Properties

Checksum (inherited from IcmpMessage) | Get or sets the checksum.
Code (inherited from IcmpMessage) | Get or sets the code value.
Data | Gets or sets the original data.
IpHeader (inherited from IcmpMessage) | Get the IP header.
MessageType (inherited from IcmpMessage) | Get or sets the message type.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
IsReply (inherited from IcmpMessage) | Overloaded. Indicate whether the response correlates to the request.
ToByteArray | Convert the message into a byte array.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

TimeExceededMessage Class | ComponentSpace.Icmp Namespace


TimeExceededMessage Constructor

Initializes a new instance of the TimeExceededMessage class.

Overload List

Initializes a new instance of the TimeExceededMessage class.

public TimeExceededMessage();

Initializes a new instance of the TimeExceededMessage class from the byte array.

public TimeExceededMessage(byte[],ref int,ref int);

See Also

TimeExceededMessage Class | ComponentSpace.Icmp Namespace


TimeExceededMessage Constructor ()

Initializes a new instance of the TimeExceededMessage class.

[Visual Basic]
Overloads Public Sub New()
[C#]
public TimeExceededMessage();

See Also

TimeExceededMessage Class | ComponentSpace.Icmp Namespace | TimeExceededMessage Constructor Overload List


TimeExceededMessage Constructor (Byte[], Int32, Int32)

Initializes a new instance of the TimeExceededMessage class from the byte array.

[Visual Basic]
Overloads Public Sub New( _
ByVal bytes As Byte(), _
ByRef index As Integer, _
ByRef count As Integer _
)
[C#]
public TimeExceededMessage(
byte[] bytes,
ref int index,
ref int count
);

Parameters

bytes
The byte array containing the message.
index
The index into the byte array.
count
The number of bytes available in the byte array.

See Also

TimeExceededMessage Class | ComponentSpace.Icmp Namespace | TimeExceededMessage Constructor Overload List


TimeExceededMessage Properties

The properties of the TimeExceededMessage class are listed below. For a complete list of TimeExceededMessage class members, see the TimeExceededMessage Members topic.

Public Instance Properties

Checksum (inherited from IcmpMessage) | Get or sets the checksum.
Code (inherited from IcmpMessage) | Get or sets the code value.
Data | Gets or sets the original data.
IpHeader (inherited from IcmpMessage) | Get the IP header.
MessageType (inherited from IcmpMessage) | Get or sets the message type.

See Also

TimeExceededMessage Class | ComponentSpace.Icmp Namespace


TimeExceededMessage.Data Property

Gets or sets the original data.

[Visual Basic]
Public Property Data As Byte()
[C#]
public byte[] Data {get; set;}

Property Value

The original data.

See Also

TimeExceededMessage Class | ComponentSpace.Icmp Namespace


TimeExceededMessage Methods

The methods of the TimeExceededMessage class are listed below. For a complete list of TimeExceededMessage class members, see the TimeExceededMessage Members topic.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
IsReply (inherited from IcmpMessage) | Overloaded. Indicate whether the response correlates to the request.
ToByteArray | Convert the message into a byte array.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

TimeExceededMessage Class | ComponentSpace.Icmp Namespace


TimeExceededMessage.ToByteArray Method

Convert the message into a byte array.

[Visual Basic]
Overrides Public Function ToByteArray() As Byte()
[C#]
public override byte[] ToByteArray();

Return Value

The byte array containing the message.

See Also

TimeExceededMessage Class | ComponentSpace.Icmp Namespace


TimestampMessage Class

The ICMP Timestamp Message.

For a list of all members of this type, see TimestampMessage Members.

System.Object
ComponentSpace.Icmp.IcmpMessage
ComponentSpace.Icmp.TimestampMessage

[Visual Basic]
Public Class TimestampMessage
Inherits IcmpMessage
[C#]
public class TimestampMessage : IcmpMessage

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: ComponentSpace.Icmp

Assembly: ComponentSpace.Icmp (in ComponentSpace.Icmp.dll)

See Also

TimestampMessage Members | ComponentSpace.Icmp Namespace


TimestampMessage Members

TimestampMessage overview

Public Instance Constructors

TimestampMessage Overloaded. Initializes a new instance of the TimestampMessage class.

Public Instance Properties

Checksum (inherited from IcmpMessage) | Get or sets the checksum.
Code (inherited from IcmpMessage) | Get or sets the code value.
Identifier | Gets or sets the identifier.
IpHeader (inherited from IcmpMessage) | Get the IP header.
MessageType (inherited from IcmpMessage) | Get or sets the message type.
OriginateTimestamp | Gets or sets the originate timestamp.
ReceiveTimestamp | Gets or sets the receive timestamp.
SequenceNumber | Gets or sets the sequence number.
TransmitTimestamp | Gets or sets the transmit timestamp.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
IsReply (inherited from IcmpMessage) | Overloaded. Indicate whether the response correlates to the request.
IsReply | Overloaded. Indicate whether the response correlates to the request.
ToByteArray | Convert the message into a byte array.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

TimestampMessage Class | ComponentSpace.Icmp Namespace


TimestampMessage Constructor

Initializes a new instance of the TimestampMessage class.

Overload List

Initializes a new instance of the TimestampMessage class.

public TimestampMessage();

Initializes a new instance of the TimestampMessage class from the byte array.

public TimestampMessage(byte[],ref int,ref int);

See Also

TimestampMessage Class | ComponentSpace.Icmp Namespace


TimestampMessage Constructor ()

Initializes a new instance of the TimestampMessage class.

[Visual Basic]
Overloads Public Sub New()
[C#]
public TimestampMessage();

See Also

TimestampMessage Class | ComponentSpace.Icmp Namespace | TimestampMessage Constructor Overload List


TimestampMessage Constructor (Byte[], Int32, Int32)

Initializes a new instance of the TimestampMessage class from the byte array.

[Visual Basic]
Overloads Public Sub New( _
ByVal bytes As Byte(), _
ByRef index As Integer, _
ByRef count As Integer _
)
[C#]
public TimestampMessage(
byte[] bytes,
ref int index,
ref int count
);

Parameters

bytes
The byte array containing the message.
index
The index into the byte array.
count
The number of bytes available in the byte array.

See Also

TimestampMessage Class | ComponentSpace.Icmp Namespace | TimestampMessage Constructor Overload List


TimestampMessage Properties

The properties of the TimestampMessage class are listed below. For a complete list of TimestampMessage class members, see the TimestampMessage Members topic.

Public Instance Properties

Checksum (inherited from IcmpMessage) | Get or sets the checksum.
Code (inherited from IcmpMessage) | Get or sets the code value.
Identifier | Gets or sets the identifier.
IpHeader (inherited from IcmpMessage) | Get the IP header.
MessageType (inherited from IcmpMessage) | Get or sets the message type.
OriginateTimestamp | Gets or sets the originate timestamp.
ReceiveTimestamp | Gets or sets the receive timestamp.
SequenceNumber | Gets or sets the sequence number.
TransmitTimestamp | Gets or sets the transmit timestamp.

See Also

TimestampMessage Class | ComponentSpace.Icmp Namespace


TimestampMessage.Identifier Property

Gets or sets the identifier.

[Visual Basic]
Public Property Identifier As UInt16
[C#]
public ushort Identifier {get; set;}

Property Value

The identifier. The default is zero.

See Also

TimestampMessage Class | ComponentSpace.Icmp Namespace


TimestampMessage.OriginateTimestamp Property

Gets or sets the originate timestamp.

[Visual Basic]
Public Property OriginateTimestamp As UInt32
[C#]
public uint OriginateTimestamp {get; set;}

Property Value

The originate timestamp.

See Also

TimestampMessage Class | ComponentSpace.Icmp Namespace


TimestampMessage.ReceiveTimestamp Property

Gets or sets the receive timestamp.

[Visual Basic]
Public Property ReceiveTimestamp As UInt32
[C#]
public uint ReceiveTimestamp {get; set;}

Property Value

The receive timestamp.

See Also

TimestampMessage Class | ComponentSpace.Icmp Namespace


TimestampMessage.SequenceNumber Property

Gets or sets the sequence number.

[Visual Basic]
Public Property SequenceNumber As UInt16
[C#]
public ushort SequenceNumber {get; set;}

Property Value

The sequence number. The default is an auto incrementing number.

See Also

TimestampMessage Class | ComponentSpace.Icmp Namespace


TimestampMessage.TransmitTimestamp Property

Gets or sets the transmit timestamp.

[Visual Basic]
Public Property TransmitTimestamp As UInt32
[C#]
public uint TransmitTimestamp {get; set;}

Property Value

The transmit timestamp.

See Also

TimestampMessage Class | ComponentSpace.Icmp Namespace


TimestampMessage Methods

The methods of the TimestampMessage class are listed below. For a complete list of TimestampMessage class members, see the TimestampMessage Members topic.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
IsReply (inherited from IcmpMessage) | Overloaded. Indicate whether the response correlates to the request.
IsReply | Overloaded. Indicate whether the response correlates to the request.
ToByteArray | Convert the message into a byte array.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

TimestampMessage Class | ComponentSpace.Icmp Namespace


IsReply Method

ComponentSpace ICMP Class Library Reference

TimestampMessage.IsReply Method

Indicate whether the response correlates to the request.

Overload List

Inherited from IcmpMessage.

public virtual bool IsReply(DestinationUnreachableMessage);

Inherited from IcmpMessage.

public virtual bool IsReply(EchoReplyMessage);

Inherited from IcmpMessage.

public virtual bool IsReply(IcmpMessage);

Inherited from IcmpMessage.

public virtual bool IsReply(InformationReplyMessage);

Inherited from IcmpMessage.

public virtual bool IsReply(ParameterProblemMessage);

Inherited from IcmpMessage.

public virtual bool IsReply(RedirectMessage);

Inherited from IcmpMessage.

public virtual bool IsReply(SourceQuenchMessage);

Inherited from IcmpMessage.

public virtual bool IsReply(TimeExceededMessage);

Indicate whether the response correlates to the request.

public override bool IsReply(TimestampReplyMessage);

See Also

TimestampMessage Class | ComponentSpace.Icmp Namespace


TimestampMessage.IsReply Method (TimestampReplyMessage)

Indicate whether the response correlates to the request.

[Visual Basic]
Overrides Overloads Public Function IsReply( _
ByVal response As TimestampReplyMessage _
) As Boolean
[C#]
public override bool IsReply(
TimestampReplyMessage response
);

Return Value

true if the response correlates to the request; false otherwise

See Also

TimestampMessage Class | ComponentSpace.Icmp Namespace | TimestampMessage.IsReply Overload List


TimestampMessage.ToByteArray Method

Convert the message into a byte array.

[Visual Basic]
Overrides Public Function ToByteArray() As Byte()
[C#]
public override byte[] ToByteArray();

Return Value

The byte array containing the message.

See Also

TimestampMessage Class | ComponentSpace.Icmp Namespace


TimestampReplyMessage Class

The ICMP Timestamp Reply Message.

For a list of all members of this type, see TimestampReplyMessage Members.

System.Object
ComponentSpace.Icmp.IcmpMessage
ComponentSpace.Icmp.TimestampReplyMessage

[Visual Basic]
Public Class TimestampReplyMessage
Inherits IcmpMessage
[C#]
public class TimestampReplyMessage : IcmpMessage

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: ComponentSpace.Icmp

Assembly: ComponentSpace.Icmp (in ComponentSpace.Icmp.dll)

See Also

TimestampReplyMessage Members | ComponentSpace.Icmp Namespace


TimestampReplyMessage Members

TimestampReplyMessage overview

Public Instance Constructors

TimestampReplyMessage Overloaded. Initializes a new instance of the TimestampReplyMessage class.

Public Instance Properties

Checksum (inherited from IcmpMessage) | Get or sets the checksum.
Code (inherited from IcmpMessage) | Get or sets the code value.
Identifier | Gets or sets the identifier.
IpHeader (inherited from IcmpMessage) | Get the IP header.
MessageType (inherited from IcmpMessage) | Get or sets the message type.
OriginateTimestamp | Gets or sets the originate timestamp.
ReceiveTimestamp | Gets or sets the receive timestamp.
SequenceNumber | Gets or sets the sequence number.
TransmitTimestamp | Gets or sets the transmit timestamp.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
IsReply (inherited from IcmpMessage) | Overloaded. Indicate whether the response correlates to the request.
ToByteArray | Convert the message into a byte array.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

TimestampReplyMessage Class | ComponentSpace.Icmp Namespace


TimestampReplyMessage Constructor

Initializes a new instance of the TimestampReplyMessage class.

Overload List

Initializes a new instance of the TimestampReplyMessage class.

public TimestampReplyMessage();

Initializes a new instance of the TimestampReplyMessage class from the byte array.

public TimestampReplyMessage(byte[],ref int,ref int);

See Also

TimestampReplyMessage Class | ComponentSpace.Icmp Namespace


TimestampReplyMessage Constructor ()

Initializes a new instance of the TimestampReplyMessage class.

[Visual Basic]
Overloads Public Sub New()
[C#]
public TimestampReplyMessage();

See Also

TimestampReplyMessage Class | ComponentSpace.Icmp Namespace | TimestampReplyMessage Constructor Overload List


TimestampReplyMessage Constructor (Byte[], Int32, Int32)

Initializes a new instance of the TimestampReplyMessage class from the byte array.

[Visual Basic]
Overloads Public Sub New( _
ByVal bytes As Byte(), _
ByRef index As Integer, _
ByRef count As Integer _
)
[C#]
public TimestampReplyMessage(
byte[] bytes,
ref int index,
ref int count
);

Parameters

bytes
The byte array containing the message.
index
The index into the byte array.
count
The number of bytes available in the byte array.

See Also

TimestampReplyMessage Class | ComponentSpace.Icmp Namespace | TimestampReplyMessage Constructor Overload List


TimestampReplyMessage Properties

The properties of the TimestampReplyMessage class are listed below. For a complete list of TimestampReplyMessage class members, see the TimestampReplyMessage Members topic.

Public Instance Properties

Checksum (inherited from IcmpMessage) | Get or sets the checksum.
Code (inherited from IcmpMessage) | Get or sets the code value.
Identifier | Gets or sets the identifier.
IpHeader (inherited from IcmpMessage) | Get the IP header.
MessageType (inherited from IcmpMessage) | Get or sets the message type.
OriginateTimestamp | Gets or sets the originate timestamp.
ReceiveTimestamp | Gets or sets the receive timestamp.
SequenceNumber | Gets or sets the sequence number.
TransmitTimestamp | Gets or sets the transmit timestamp.

See Also

TimestampReplyMessage Class | ComponentSpace.Icmp Namespace


TimestampReplyMessage.Identifier Property

Gets or sets the identifier.

[Visual Basic]
Public Property Identifier As UInt16
[C#]
public ushort Identifier {get; set;}

Property Value

The identifier.

See Also

TimestampReplyMessage Class | ComponentSpace.Icmp Namespace


TimestampReplyMessage.OriginateTimestamp Property

Gets or sets the originate timestamp.

[Visual Basic]
Public Property OriginateTimestamp As UInt32
[C#]
public uint OriginateTimestamp {get; set;}

Property Value

The originate timestamp.

See Also

TimestampReplyMessage Class | ComponentSpace.Icmp Namespace


TimestampReplyMessage.ReceiveTimestamp Property

Gets or sets the receive timestamp.

[Visual Basic]
Public Property ReceiveTimestamp As UInt32
[C#]
public uint ReceiveTimestamp {get; set;}

Property Value

The receive timestamp.

See Also

TimestampReplyMessage Class | ComponentSpace.Icmp Namespace


TimestampReplyMessage.SequenceNumber Property

Gets or sets the sequence number.

[Visual Basic]
Public Property SequenceNumber As UInt16
[C#]
public ushort SequenceNumber {get; set;}

Property Value

The sequence number.

See Also

TimestampReplyMessage Class | ComponentSpace.Icmp Namespace


TimestampReplyMessage.TransmitTimestamp Property

Gets or sets the transmit timestamp.

[Visual Basic]
Public Property TransmitTimestamp As UInt32
[C#]
public uint TransmitTimestamp {get; set;}

Property Value

The transmit timestamp.

See Also

TimestampReplyMessage Class | ComponentSpace.Icmp Namespace


TimestampReplyMessage Methods

The methods of the TimestampReplyMessage class are listed below. For a complete list of TimestampReplyMessage class members, see the TimestampReplyMessage Members topic.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
IsReply (inherited from IcmpMessage) | Overloaded. Indicate whether the response correlates to the request.
ToByteArray | Convert the message into a byte array.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

TimestampReplyMessage Class | ComponentSpace.Icmp Namespace


TimestampReplyMessage.ToByteArray Method

Convert the message into a byte array.

[Visual Basic]
Overrides Public Function ToByteArray() As Byte()
[C#]
public override byte[] ToByteArray();

Return Value

The byte array containing the message.

See Also

TimestampReplyMessage Class | ComponentSpace.Icmp Namespace


IcmpMessage Hierarchy

System.Object
IcmpMessage
DestinationUnreachableMessage
EchoMessage
EchoReplyMessage
InformationReplyMessage
InformationRequestMessage
ParameterProblemMessage
RedirectMessage
SourceQuenchMessage
TimeExceededMessage
TimestampMessage
TimestampReplyMessage

See Also

IcmpMessage Class | IcmpMessage Members | ComponentSpace.Icmp Namespace


ComponentSpace.IcmpHierarchy

ComponentSpace ICMP Class Library Reference

ComponentSpace.Icmp Hierarchy

System.Object
ComponentSpace.Icmp.EchoClient
ComponentSpace.Icmp.IcmpClient ---- System.IDisposable
ComponentSpace.Icmp.IcmpMessage
ComponentSpace.Icmp.DestinationUnreachableMessage
ComponentSpace.Icmp.EchoMessage
ComponentSpace.Icmp.EchoReplyMessage
ComponentSpace.Icmp.InformationReplyMessage
ComponentSpace.Icmp.InformationRequestMessage
ComponentSpace.Icmp.ParameterProblemMessage
ComponentSpace.Icmp.RedirectMessage
ComponentSpace.Icmp.SourceQuenchMessage
ComponentSpace.Icmp.TimeExceededMessage
ComponentSpace.Icmp.TimestampMessage
ComponentSpace.Icmp.TimestampReplyMessage
ComponentSpace.Icmp.IpHeader
System.Delegate ---- System.ICloneable, System.Runtime.Serialization.ISerializable
System.MulticastDelegate
ComponentSpace.Icmp.EchoCompletedEventHandler
ComponentSpace.Icmp.ReceiveCompletedEventHandler
ComponentSpace.Icmp.SendCompletedEventHandler
System.EventArgs
ComponentSpace.Icmp.EchoCompletedEventArgs
ComponentSpace.Icmp.ReceiveCompletedEventArgs
ComponentSpace.Icmp.SendCompletedEventArgs
System.Exception ---- System.Runtime.Serialization.ISerializable
System.ApplicationException
ComponentSpace.Icmp.IcmpException
System.ValueType
System.Enum ---- System.IComparable, System.IConvertible, System.IFormattable
ComponentSpace.Icmp.IcmpMessage.MessageTypes

See Also

ComponentSpace.Icmp Namespace