ComponentSpace.Ftp

ComponentSpace FTP Class Library Reference

ComponentSpace.Ftp Namespace

The ComponentSpace.Ftp namespace contains classes that implement the FTP protocol (RFC-959 and related RFCs).

The FtpClient class provides high level functionality including uploading and downloading files, remote directory commands and more.

The FtpClientComponent class wraps the FtpClient as a .NET component to expose the most commonly used properties and events at both design and run time.

Typically, the FtpClientComponent component or the FtpClient class is what you would use in your application.

Also available is the FailSafeTransfer class for performing uploads and downloads with inbuilt automatic error recovery.

The low level classes for managing the command connection, FtpCommandConnection, and the data connections FtpDataConnection, as well as the wrapper classes for FTP commands and responses, and various helper classes are also exposed. You would use these classes instead of FtpClient if you need greater control.

The FtpWebRequestCreator, FtpWebRequest and FtpWebResponse classes expose the FTP functionality using the Microsoft pluggable protocols architecture. These classes provide generic web access to an FTP server but aren't as feature rich as FtpClient.

Namespace hierarchy

Classes

Class | Description
AbortCommand | Represents the FTP ABOR command.
AccountCommand | Represents the FTP ACCT command.
AllocateCommand | Represents the FTP ALLO command.
AppendCommand | Represents the FTP APPE command.
ChangeToParentDirectoryCommand | Represents the FTP CDUP command.
ChangeWorkingDirectoryCommand | Represents the FTP CWD command.
CommandTracedEventArgs | Provides data for the event.
DataTransferredEventArgs | Provides data for the event.
DeleteCommand | Represents the FTP DELE command.
DirectoryListItem | The base class for FTP remote directory list items.
DirectoryListParser | Parse remote directory lists - either Unix style or MS-DOS.
FailSafeTransfer | Performs failsafe file transfers.
FailSafeTransferEventArgs | Provides data for the event.
FileModificationTimeCommand | Represents the FTP MDTM command.
FtpClient | Sends FTP requests and receives FTP responses using the File Transfer Protocol (RFC-959).
FtpClientComponent | Wraps the FtpClient as a .NET component to expose the most commonly used properties and events at both design and run time.
FtpCommand | The base class for all FTP commands.
FtpCommandConnection | Sends FTP commands and receives FTP replies.
FtpCommandReply | Represents an FTP command reply.
FtpDataConnection | Sends and receives FTP data.
FtpException | The exception that is thrown when an FTP operation fails.
FtpOperationCompletedEventArgs | Provides data for the event.
FtpWebRequest | Represents an FTP web request in the Microsoft pluggable protocols architecture.
FtpWebRequestCreator | Factory class for the FTP web request in the Microsoft pluggable protocols architecture.
FtpWebResponse | Represents an FTP web request in the Microsoft pluggable protocols architecture.
HelpCommand | Represents the FTP HELP command.
ListCommand | Represents the FTP LIST command.
ListLineAvailableEventArgs | Provides data for the event.
MakeDirectoryCommand | Represents the FTP MKD command.
ModeCommand | Represents the FTP MODE command.
MSDOSDirectoryListItem | An MS-DOS directory list items.
MultiFile | Provides methods for manipulating multiple files.
MultiFileEventArgs | Provides data for the event.
NameListCommand | Represents the FTP NLST command.
NoopCommand | Represents the FTP NOOP command.
PassiveCommand | Represents the FTP PASV command.
PasswordCommand | Represents the FTP PASS command.
PortCommand | Represents the FTP PORT command.
PrintWorkingDirectoryCommand | Represents the FTP PWD command.
QuitCommand | Represents the FTP QUIT command.
ReinitializeCommand | Represents the FTP REIN command.
RemoteDirectory | Performs remote directory related commands.
RemoteFile | Performs remote file related commands.
RemoveDirectoryCommand | Represents the FTP RMD command.
RenameFromCommand | Represents the FTP RNFR command.
RenameToCommand | Represents the FTP RNTO command.
RestartCommand | Represents the FTP REST command.
RetrieveCommand | Represents the FTP RETR command.
SiteCommand | Represents the FTP SITE command.
StatusCommand | Represents the FTP STAT command.
StoreCommand | Represents the FTP STOR command.
StoreUniqueCommand | Represents the FTP STOU command.
StructureCommand | Represents the FTP STRU command.
StructureMountCommand | Represents the FTP SMNT command.
SystemCommand | Represents the FTP SYST command.
TypeCommand | Represents the FTP TYPE command.
UnixDirectoryListItem | A Unix directory list items.
UserNameCommand | Represents the FTP USER command.

Interfaces

Interface | Description
IFileFilter | Provides a filter for determining which files to upload or download during a multi-file operation.

Delegates

Delegate | Description
CommandTracedEventHandler | Represents the method that will handle FTP command traced events.
DataTransferredEventHandler | Represents the method that will handle FTP data transferred events.
FailSafeTransferEventHandler | Represents the method that will handle failsafe transfer events.
FtpOperationCompletedEventHandler | Represents the method that will handle FTP operation completion events.
ListLineAvailableEventHandler | Represents the method that will handle list line available events.
MultiFileEventHandler | Represents the method that will handle multi file events.

Enumerations

Enumeration | Description
CommandTraceEntryType | The command trace entry type.
DataConnectionType | The data connection type.
DirectoryListItemType | The directory list item types.
TransferMode | The transfer mode type.


AbortCommand Class

Represents the FTP ABOR command.

For a list of all members of this type, see AbortCommand Members.

System.Object
ComponentSpace.Ftp.FtpCommand
ComponentSpace.Ftp.AbortCommand

[Visual Basic]
Public Class AbortCommand
Inherits FtpCommand
[C#]
public class AbortCommand : FtpCommand

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: ComponentSpace.Ftp

Assembly: ComponentSpace.Ftp (in ComponentSpace.Ftp.dll)

See Also

AbortCommand Members | ComponentSpace.Ftp Namespace


AbortCommand Members

AbortCommand overview

Public Instance Constructors

AbortCommand Overloaded. Initializes a new instance of the AbortCommand class.

Public Instance Properties

CommandType (inherited from FtpCommand) Gets the command type.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString | Convert the command to the FTP command text.
ToTraceString (inherited from FtpCommand) | Convert the reply to the trace text.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

AbortCommand Class | ComponentSpace.Ftp Namespace


AbortCommand Constructor

Initializes a new instance of the AbortCommand.

Overload List

Initializes a new instance of the AbortCommand.

public AbortCommand();

Initializes a new instance of the AbortCommand from the raw command text.

public AbortCommand(string);

See Also

AbortCommand Class | ComponentSpace.Ftp Namespace


AbortCommand Constructor ()

Initializes a new instance of the AbortCommand.

[Visual Basic]
Overloads Public Sub New()
[C#]
public AbortCommand();

See Also

AbortCommand Class | ComponentSpace.Ftp Namespace | AbortCommand Constructor Overload List


AbortCommand Constructor (String)

Initializes a new instance of the AbortCommand from the raw command text.

[Visual Basic]
Overloads Public Sub New( _
ByVal command As String _
)
[C#]
public AbortCommand(
string command
);

Parameters

command
The raw command text.

See Also

AbortCommand Class | ComponentSpace.Ftp Namespace | AbortCommand Constructor Overload List


AbortCommand Methods

The methods of the AbortCommand class are listed below. For a complete list of AbortCommand class members, see the AbortCommand Members topic.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString | Convert the command to the FTP command text.
ToTraceString (inherited from FtpCommand) | Convert the reply to the trace text.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

AbortCommand Class | ComponentSpace.Ftp Namespace


AbortCommand.ToString Method

Convert the command to the FTP command text.

[Visual Basic]
Overrides Public Function ToString() As String
[C#]
public override string ToString();

Return Value

The FTP command text.

See Also

AbortCommand Class | ComponentSpace.Ftp Namespace


AccountCommand Class

Represents the FTP ACCT command.

For a list of all members of this type, see AccountCommand Members.

System.Object
ComponentSpace.Ftp.FtpCommand
ComponentSpace.Ftp.AccountCommand

[Visual Basic]
Public Class AccountCommand
Inherits FtpCommand
[C#]
public class AccountCommand : FtpCommand

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: ComponentSpace.Ftp

Assembly: ComponentSpace.Ftp (in ComponentSpace.Ftp.dll)

See Also

AccountCommand Members | ComponentSpace.Ftp Namespace


AccountCommand Members

AccountCommand overview

Public Instance Constructors

AccountCommand Overloaded. Initializes a new instance of the AccountCommand class.

Public Instance Properties

AccountInformation | Gets or sets the account information.
CommandType (inherited from FtpCommand) | Gets the command type.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString | Convert the command to the FTP command text.
ToTraceString (inherited from FtpCommand) | Convert the reply to the trace text.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

AccountCommand Class | ComponentSpace.Ftp Namespace


AccountCommand Constructor

Initializes a new instance of the AccountCommand.

Overload List

Initializes a new instance of the AccountCommand.

public AccountCommand();

Initializes a new instance of the AccountCommand from the raw command text.

public AccountCommand(string);

See Also

AccountCommand Class | ComponentSpace.Ftp Namespace


AccountCommand Constructor ()

Initializes a new instance of the AccountCommand.

[Visual Basic]
Overloads Public Sub New()
[C#]
public AccountCommand();

See Also

AccountCommand Class | ComponentSpace.Ftp Namespace | AccountCommand Constructor Overload List


AccountCommand Constructor (String)

Initializes a new instance of the AccountCommand from the raw command text.

[Visual Basic]
Overloads Public Sub New( _
ByVal command As String _
)
[C#]
public AccountCommand(
string command
);

Parameters

command
The raw command text.

See Also

AccountCommand Class | ComponentSpace.Ftp Namespace | AccountCommand Constructor Overload List


AccountCommand Properties

The properties of the AccountCommand class are listed below. For a complete list of AccountCommand class members, see the AccountCommand Members topic.

Public Instance Properties

AccountInformation | Gets or sets the account information.
CommandType (inherited from FtpCommand) | Gets the command type.

See Also

AccountCommand Class | ComponentSpace.Ftp Namespace


AccountCommand.AccountInformation Property

Gets or sets the account information.

[Visual Basic]
Public Property AccountInformation As String
[C#]
public string AccountInformation {get; set;}

Property Value

The account information.

See Also

AccountCommand Class | ComponentSpace.Ftp Namespace


AccountCommand Methods

The methods of the AccountCommand class are listed below. For a complete list of AccountCommand class members, see the AccountCommand Members topic.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString | Convert the command to the FTP command text.
ToTraceString (inherited from FtpCommand) | Convert the reply to the trace text.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

AccountCommand Class | ComponentSpace.Ftp Namespace


AccountCommand.ToString Method

Convert the command to the FTP command text.

[Visual Basic]
Overrides Public Function ToString() As String
[C#]
public override string ToString();

Return Value

The FTP command text.

See Also

AccountCommand Class | ComponentSpace.Ftp Namespace


AllocateCommand Class

Represents the FTP ALLO command.

For a list of all members of this type, see AllocateCommand Members.

System.Object
ComponentSpace.Ftp.FtpCommand
ComponentSpace.Ftp.AllocateCommand

[Visual Basic]
Public Class AllocateCommand
Inherits FtpCommand
[C#]
public class AllocateCommand : FtpCommand

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: ComponentSpace.Ftp

Assembly: ComponentSpace.Ftp (in ComponentSpace.Ftp.dll)

See Also

AllocateCommand Members | ComponentSpace.Ftp Namespace


AllocateCommand Members

AllocateCommand overview

Public Instance Constructors

AllocateCommand Overloaded. Initializes a new instance of the AllocateCommand class.

Public Instance Properties

BytesToReserve | Gets or sets the bytes to reserve count.
CommandType (inherited from FtpCommand) | Gets the command type.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString | Convert the command to the FTP command text.
ToTraceString (inherited from FtpCommand) | Convert the reply to the trace text.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

AllocateCommand Class | ComponentSpace.Ftp Namespace


AllocateCommand Constructor

Initializes a new instance of the AllocateCommand.

Overload List

Initializes a new instance of the AllocateCommand.

public AllocateCommand();

Initializes a new instance of the AllocateCommand from the raw command text.

public AllocateCommand(string);

See Also

AllocateCommand Class | ComponentSpace.Ftp Namespace


AllocateCommand Constructor ()

Initializes a new instance of the AllocateCommand.

[Visual Basic]
Overloads Public Sub New()
[C#]
public AllocateCommand();

See Also

AllocateCommand Class | ComponentSpace.Ftp Namespace | AllocateCommand Constructor Overload List


AllocateCommand Constructor (String)

Initializes a new instance of the AllocateCommand from the raw command text.

[Visual Basic]
Overloads Public Sub New( _
ByVal command As String _
)
[C#]
public AllocateCommand(
string command
);

Parameters

command
The raw command text.

See Also

AllocateCommand Class | ComponentSpace.Ftp Namespace | AllocateCommand Constructor Overload List


AllocateCommand Properties

The properties of the AllocateCommand class are listed below. For a complete list of AllocateCommand class members, see the AllocateCommand Members topic.

Public Instance Properties

BytesToReserve | Gets or sets the bytes to reserve count.
CommandType (inherited from FtpCommand) | Gets the command type.

See Also

AllocateCommand Class | ComponentSpace.Ftp Namespace


AllocateCommand.BytesToReserve Property

Gets or sets the bytes to reserve count.

[Visual Basic]
Public Property BytesToReserve As Long
[C#]
public long BytesToReserve {get; set;}

Property Value

The bytes to reserve count.

See Also

AllocateCommand Class | ComponentSpace.Ftp Namespace


AllocateCommand Methods

The methods of the AllocateCommand class are listed below. For a complete list of AllocateCommand class members, see the AllocateCommand Members topic.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString | Convert the command to the FTP command text.
ToTraceString (inherited from FtpCommand) | Convert the reply to the trace text.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

AllocateCommand Class | ComponentSpace.Ftp Namespace


AllocateCommand.ToString Method

Convert the command to the FTP command text.

[Visual Basic]
Overrides Public Function ToString() As String
[C#]
public override string ToString();

Return Value

The FTP command text.

See Also

AllocateCommand Class | ComponentSpace.Ftp Namespace


AppendCommand Class

Represents the FTP APPE command.

For a list of all members of this type, see AppendCommand Members.

System.Object
ComponentSpace.Ftp.FtpCommand
ComponentSpace.Ftp.AppendCommand

[Visual Basic]
Public Class AppendCommand
Inherits FtpCommand
[C#]
public class AppendCommand : FtpCommand

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: ComponentSpace.Ftp

Assembly: ComponentSpace.Ftp (in ComponentSpace.Ftp.dll)

See Also

AppendCommand Members | ComponentSpace.Ftp Namespace


AppendCommand Members

AppendCommand overview

Public Instance Constructors

AppendCommand Overloaded. Initializes a new instance of the AppendCommand class.

Public Instance Properties

CommandType (inherited from FtpCommand) | Gets the command type.
PathName | Gets or sets the destination path name.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString | Convert the command to the FTP command text.
ToTraceString (inherited from FtpCommand) | Convert the reply to the trace text.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

AppendCommand Class | ComponentSpace.Ftp Namespace


AppendCommand Constructor

Initializes a new instance of the AppendCommand.

Overload List

Initializes a new instance of the AppendCommand.

public AppendCommand();

Initializes a new instance of the AppendCommand from the raw command text.

public AppendCommand(string);

See Also

AppendCommand Class | ComponentSpace.Ftp Namespace


AppendCommand Constructor ()

Initializes a new instance of the AppendCommand.

[Visual Basic]
Overloads Public Sub New()
[C#]
public AppendCommand();

See Also

AppendCommand Class | ComponentSpace.Ftp Namespace | AppendCommand Constructor Overload List


AppendCommand Constructor (String)

Initializes a new instance of the AppendCommand from the raw command text.

[Visual Basic]
Overloads Public Sub New( _
ByVal command As String _
)
[C#]
public AppendCommand(
string command
);

Parameters

command
The raw command text.

See Also

AppendCommand Class | ComponentSpace.Ftp Namespace | AppendCommand Constructor Overload List


AppendCommand Properties

The properties of the AppendCommand class are listed below. For a complete list of AppendCommand class members, see the AppendCommand Members topic.

Public Instance Properties

CommandType (inherited from FtpCommand) | Gets the command type.
PathName | Gets or sets the destination path name.

See Also

AppendCommand Class | ComponentSpace.Ftp Namespace


AppendCommand.PathName Property

Gets or sets the destination path name.

[Visual Basic]
Public Property PathName As String
[C#]
public string PathName {get; set;}

Property Value

The destination path name.

See Also

AppendCommand Class | ComponentSpace.Ftp Namespace


AppendCommand Methods

The methods of the AppendCommand class are listed below. For a complete list of AppendCommand class members, see the AppendCommand Members topic.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString | Convert the command to the FTP command text.
ToTraceString (inherited from FtpCommand) | Convert the reply to the trace text.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

AppendCommand Class | ComponentSpace.Ftp Namespace


AppendCommand.ToString Method

Convert the command to the FTP command text.

[Visual Basic]
Overrides Public Function ToString() As String
[C#]
public override string ToString();

Return Value

The FTP command text.

See Also

AppendCommand Class | ComponentSpace.Ftp Namespace


ChangeToParentDirectoryCommand Class

Represents the FTP CDUP command.

For a list of all members of this type, see ChangeToParentDirectoryCommand Members.

System.Object
ComponentSpace.Ftp.FtpCommand
ComponentSpace.Ftp.ChangeToParentDirectoryCommand

[Visual Basic]
Public Class ChangeToParentDirectoryCommand
Inherits FtpCommand
[C#]
public class ChangeToParentDirectoryCommand : FtpCommand

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: ComponentSpace.Ftp

Assembly: ComponentSpace.Ftp (in ComponentSpace.Ftp.dll)

See Also

ChangeToParentDirectoryCommand Members | ComponentSpace.Ftp Namespace


ChangeToParentDirectoryCommand Members

ChangeToParentDirectoryCommand overview

Public Instance Constructors

ChangeToParentDirectoryCommand Overloaded. Initializes a new instance of the ChangeToParentDirectoryCommand class.

Public Instance Properties

CommandType (inherited from FtpCommand) Gets the command type.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString | Convert the command to the FTP command text.
ToTraceString (inherited from FtpCommand) | Convert the reply to the trace text.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

ChangeToParentDirectoryCommand Class | ComponentSpace.Ftp Namespace


ChangeToParentDirectoryCommand Constructor

Initializes a new instance of the ChangeToParentDirectoryCommand.

Overload List

Initializes a new instance of the ChangeToParentDirectoryCommand.

public ChangeToParentDirectoryCommand();

Initializes a new instance of the ChangeToParentDirectoryCommand from the raw command text.

public ChangeToParentDirectoryCommand(string);

See Also

ChangeToParentDirectoryCommand Class | ComponentSpace.Ftp Namespace


ChangeToParentDirectoryCommand Constructor ()

Initializes a new instance of the ChangeToParentDirectoryCommand.

[Visual Basic]
Overloads Public Sub New()
[C#]
public ChangeToParentDirectoryCommand();

See Also

ChangeToParentDirectoryCommand Class | ComponentSpace.Ftp Namespace | ChangeToParentDirectoryCommand Constructor Overload List


ChangeToParentDirectoryCommand Constructor (String)

Initializes a new instance of the ChangeToParentDirectoryCommand from the raw command text.

[Visual Basic]
Overloads Public Sub New( _
ByVal command As String _
)
[C#]
public ChangeToParentDirectoryCommand(
string command
);

Parameters

command
The raw command text.

See Also

ChangeToParentDirectoryCommand Class | ComponentSpace.Ftp Namespace | ChangeToParentDirectoryCommand Constructor Overload List


ChangeToParentDirectoryCommand Methods

The methods of the ChangeToParentDirectoryCommand class are listed below. For a complete list of ChangeToParentDirectoryCommand class members, see the ChangeToParentDirectoryCommand Members topic.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString | Convert the command to the FTP command text.
ToTraceString (inherited from FtpCommand) | Convert the reply to the trace text.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

ChangeToParentDirectoryCommand Class | ComponentSpace.Ftp Namespace


ChangeToParentDirectoryCommand.ToString Method

Convert the command to the FTP command text.

[Visual Basic]
Overrides Public Function ToString() As String
[C#]
public override string ToString();

Return Value

The FTP command text.

See Also

ChangeToParentDirectoryCommand Class | ComponentSpace.Ftp Namespace


ChangeWorkingDirectoryCommand Class

Represents the FTP CWD command.

For a list of all members of this type, see ChangeWorkingDirectoryCommand Members.

System.Object
ComponentSpace.Ftp.FtpCommand
ComponentSpace.Ftp.ChangeWorkingDirectoryCommand

[Visual Basic]
Public Class ChangeWorkingDirectoryCommand
Inherits FtpCommand
[C#]
public class ChangeWorkingDirectoryCommand : FtpCommand

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: ComponentSpace.Ftp

Assembly: ComponentSpace.Ftp (in ComponentSpace.Ftp.dll)

See Also

ChangeWorkingDirectoryCommand Members | ComponentSpace.Ftp Namespace


ChangeWorkingDirectoryCommand Members

ChangeWorkingDirectoryCommand overview

Public Instance Constructors

ChangeWorkingDirectoryCommand Overloaded. Initializes a new instance of the ChangeWorkingDirectoryCommand class.

Public Instance Properties

CommandType (inherited from FtpCommand) | Gets the command type.
PathName | Gets or sets the remote path name.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString | Convert the command to the FTP command text.
ToTraceString (inherited from FtpCommand) | Convert the reply to the trace text.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

ChangeWorkingDirectoryCommand Class | ComponentSpace.Ftp Namespace


ChangeWorkingDirectoryCommand Constructor

Initializes a new instance of the ChangeWorkingDirectoryCommand.

Overload List

Initializes a new instance of the ChangeWorkingDirectoryCommand.

public ChangeWorkingDirectoryCommand();

Initializes a new instance of the ChangeWorkingDirectoryCommand from the raw command text.

public ChangeWorkingDirectoryCommand(string);

See Also

ChangeWorkingDirectoryCommand Class | ComponentSpace.Ftp Namespace


ChangeWorkingDirectoryCommand Constructor ()

Initializes a new instance of the ChangeWorkingDirectoryCommand.

[Visual Basic]
Overloads Public Sub New()
[C#]
public ChangeWorkingDirectoryCommand();

See Also

ChangeWorkingDirectoryCommand Class | ComponentSpace.Ftp Namespace | ChangeWorkingDirectoryCommand Constructor Overload List


ChangeWorkingDirectoryCommand Constructor (String)

Initializes a new instance of the ChangeWorkingDirectoryCommand from the raw command text.

[Visual Basic]
Overloads Public Sub New( _
ByVal command As String _
)
[C#]
public ChangeWorkingDirectoryCommand(
string command
);

Parameters

command
The raw command text.

See Also

ChangeWorkingDirectoryCommand Class | ComponentSpace.Ftp Namespace | ChangeWorkingDirectoryCommand Constructor Overload List


ChangeWorkingDirectoryCommand Properties

The properties of the ChangeWorkingDirectoryCommand class are listed below. For a complete list of ChangeWorkingDirectoryCommand class members, see the ChangeWorkingDirectoryCommand Members topic.

Public Instance Properties

CommandType (inherited from FtpCommand) | Gets the command type.
PathName | Gets or sets the remote path name.

See Also

ChangeWorkingDirectoryCommand Class | ComponentSpace.Ftp Namespace


ChangeWorkingDirectoryCommand.PathName Property

Gets or sets the remote path name.

[Visual Basic]
Public Property PathName As String
[C#]
public string PathName {get; set;}

Property Value

The remote path name.

See Also

ChangeWorkingDirectoryCommand Class | ComponentSpace.Ftp Namespace


ChangeWorkingDirectoryCommand Methods

The methods of the ChangeWorkingDirectoryCommand class are listed below. For a complete list of ChangeWorkingDirectoryCommand class members, see the ChangeWorkingDirectoryCommand Members topic.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString | Convert the command to the FTP command text.
ToTraceString (inherited from FtpCommand) | Convert the reply to the trace text.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

ChangeWorkingDirectoryCommand Class | ComponentSpace.Ftp Namespace


ChangeWorkingDirectoryCommand.ToString Method

Convert the command to the FTP command text.

[Visual Basic]
Overrides Public Function ToString() As String
[C#]
public override string ToString();

Return Value

The FTP command text.

See Also

ChangeWorkingDirectoryCommand Class | ComponentSpace.Ftp Namespace


CommandTracedEventArgs Class

Provides data for the event.

For a list of all members of this type, see CommandTracedEventArgs Members.

System.Object
System.EventArgs
ComponentSpace.Ftp.CommandTracedEventArgs

[Visual Basic]
Public Class CommandTracedEventArgs
Inherits EventArgs
[C#]
public class CommandTracedEventArgs : EventArgs

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: ComponentSpace.Ftp

Assembly: ComponentSpace.Ftp (in ComponentSpace.Ftp.dll)

See Also

CommandTracedEventArgs Members | ComponentSpace.Ftp Namespace


CommandTracedEventArgs Members

CommandTracedEventArgs overview

Public Instance Properties

CommandTraceEntryType | Gets the command trace entry type.
TraceText | Gets the trace text.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

CommandTracedEventArgs Class | ComponentSpace.Ftp Namespace


CommandTracedEventArgs Properties

The properties of the CommandTracedEventArgs class are listed below. For a complete list of CommandTracedEventArgs class members, see the CommandTracedEventArgs Members topic.

Public Instance Properties

CommandTraceEntryType | Gets the command trace entry type.
TraceText | Gets the trace text.

See Also

CommandTracedEventArgs Class | ComponentSpace.Ftp Namespace


CommandTracedEventArgs.CommandTraceEntryType Property

Gets the command trace entry type.

[Visual Basic]
Public ReadOnly Property CommandTraceEntryType As CommandTraceEntryType
[C#]
public CommandTraceEntryType CommandTraceEntryType {get;}

Property Value

The command trace entry type.

See Also

CommandTracedEventArgs Class | ComponentSpace.Ftp Namespace


CommandTracedEventArgs.TraceText Property

Gets the trace text.

[Visual Basic]
Public ReadOnly Property TraceText As String
[C#]
public string TraceText {get;}

Property Value

The trace text.

See Also

CommandTracedEventArgs Class | ComponentSpace.Ftp Namespace


CommandTracedEventHandler Delegate

Represents the method that will handle FTP command traced events.

[Visual Basic]
Public Delegate Sub CommandTracedEventHandler( _
ByVal sender As Object, _
ByVal e As CommandTracedEventArgs _
)
[C#]
public delegate void CommandTracedEventHandler(
object sender,
CommandTracedEventArgs e
);

Parameters

sender
The source of the event.
e
A CommandTracedEventArgs that contains the event data.

Remarks

When you create a CommandTracedEventHandler delegate, you identify the method that will handle the event. To associate the event with your event handler, add an instance of the delegate to the event. The event handler is called whenever the event occurs, unless you remove the delegate.

Requirements

Namespace: ComponentSpace.Ftp

Assembly: ComponentSpace.Ftp (in ComponentSpace.Ftp.dll)

See Also

ComponentSpace.Ftp Namespace


CommandTraceEntryType Enumeration

The command trace entry type.

[Visual Basic]
Public Enum CommandTraceEntryType
[C#]
public enum CommandTraceEntryType

Members

Member Name | Description
CommandConnection | Command connection.
DataConnection | Data connection.
Command | Command.
CommandReply | Command reply.

Requirements

Namespace: ComponentSpace.Ftp

Assembly: ComponentSpace.Ftp (in ComponentSpace.Ftp.dll)

See Also

ComponentSpace.Ftp Namespace


DataConnectionType Enumeration

The data connection type.

[Visual Basic]
Public Enum DataConnectionType
[C#]
public enum DataConnectionType

Members

Member Name | Description
Inbound | Inbound. A PORT command is issued and the server connects to the client.
Outbound | Outbound. A PASV command is issued and the client connects to the server.
Auto | Outbound (PASV) is tried and if this fails inbound (PORT) is tried.

Requirements

Namespace: ComponentSpace.Ftp

Assembly: ComponentSpace.Ftp (in ComponentSpace.Ftp.dll)

See Also

ComponentSpace.Ftp Namespace


DataTransferredEventArgs Class

Provides data for the event.

For a list of all members of this type, see DataTransferredEventArgs Members.

System.Object
System.EventArgs
ComponentSpace.Ftp.DataTransferredEventArgs

[Visual Basic]
Public Class DataTransferredEventArgs
Inherits EventArgs
[C#]
public class DataTransferredEventArgs : EventArgs

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: ComponentSpace.Ftp

Assembly: ComponentSpace.Ftp (in ComponentSpace.Ftp.dll)

See Also

DataTransferredEventArgs Members | ComponentSpace.Ftp Namespace


DataTransferredEventArgs Members

DataTransferredEventArgs overview

Public Instance Properties

BytesTransferred Gets the total number of bytes transferred in the current operation.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

DataTransferredEventArgs Class | ComponentSpace.Ftp Namespace


DataTransferredEventArgs Properties

The properties of the DataTransferredEventArgs class are listed below. For a complete list of DataTransferredEventArgs class members, see the DataTransferredEventArgs Members topic.

Public Instance Properties

BytesTransferred Gets the total number of bytes transferred in the current operation.

See Also

DataTransferredEventArgs Class | ComponentSpace.Ftp Namespace


DataTransferredEventArgs.BytesTransferred Property

Gets the total number of bytes transferred in the current operation.

[Visual Basic]
Public ReadOnly Property BytesTransferred As Long
[C#]
public long BytesTransferred {get;}

Property Value

The trace text.

See Also

DataTransferredEventArgs Class | ComponentSpace.Ftp Namespace


DataTransferredEventHandler Delegate

Represents the method that will handle FTP data transferred events.

[Visual Basic]
Public Delegate Sub DataTransferredEventHandler( _
ByVal sender As Object, _
ByVal e As DataTransferredEventArgs _
)
[C#]
public delegate void DataTransferredEventHandler(
object sender,
DataTransferredEventArgs e
);

Parameters

sender
The source of the event.
e
A DataTransferredEventArgs that contains the event data.

Remarks

When you create a DataTransferredEventHandler delegate, you identify the method that will handle the event. To associate the event with your event handler, add an instance of the delegate to the event. The event handler is called whenever the event occurs, unless you remove the delegate.

Requirements

Namespace: ComponentSpace.Ftp

Assembly: ComponentSpace.Ftp (in ComponentSpace.Ftp.dll)

See Also

ComponentSpace.Ftp Namespace


DeleteCommand Class

Represents the FTP DELE command.

For a list of all members of this type, see DeleteCommand Members.

System.Object
ComponentSpace.Ftp.FtpCommand
ComponentSpace.Ftp.DeleteCommand

[Visual Basic]
Public Class DeleteCommand
Inherits FtpCommand
[C#]
public class DeleteCommand : FtpCommand

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: ComponentSpace.Ftp

Assembly: ComponentSpace.Ftp (in ComponentSpace.Ftp.dll)

See Also

DeleteCommand Members | ComponentSpace.Ftp Namespace


DeleteCommand Members

DeleteCommand overview

Public Instance Constructors

DeleteCommand Overloaded. Initializes a new instance of the DeleteCommand class.

Public Instance Properties

CommandType (inherited from FtpCommand) | Gets the command type.
PathName | Gets or sets the remote path name.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString | Convert the command to the FTP command text.
ToTraceString (inherited from FtpCommand) | Convert the reply to the trace text.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

DeleteCommand Class | ComponentSpace.Ftp Namespace


DeleteCommand Constructor

Initializes a new instance of the DeleteCommand.

Overload List

Initializes a new instance of the DeleteCommand.

public DeleteCommand();

Initializes a new instance of the DeleteCommand from the raw command text.

public DeleteCommand(string);

See Also

DeleteCommand Class | ComponentSpace.Ftp Namespace


DeleteCommand Constructor ()

Initializes a new instance of the DeleteCommand.

[Visual Basic]
Overloads Public Sub New()
[C#]
public DeleteCommand();

See Also

DeleteCommand Class | ComponentSpace.Ftp Namespace | DeleteCommand Constructor Overload List


DeleteCommand Constructor (String)

Initializes a new instance of the DeleteCommand from the raw command text.

[Visual Basic]
Overloads Public Sub New( _
ByVal command As String _
)
[C#]
public DeleteCommand(
string command
);

Parameters

command
The raw command text.

See Also

DeleteCommand Class | ComponentSpace.Ftp Namespace | DeleteCommand Constructor Overload List


DeleteCommand Properties

The properties of the DeleteCommand class are listed below. For a complete list of DeleteCommand class members, see the DeleteCommand Members topic.

Public Instance Properties

CommandType (inherited from FtpCommand) | Gets the command type.
PathName | Gets or sets the remote path name.

See Also

DeleteCommand Class | ComponentSpace.Ftp Namespace


DeleteCommand.PathName Property

Gets or sets the remote path name.

[Visual Basic]
Public Property PathName As String
[C#]
public string PathName {get; set;}

Property Value

The remote path name.

See Also

DeleteCommand Class | ComponentSpace.Ftp Namespace


DeleteCommand Methods

The methods of the DeleteCommand class are listed below. For a complete list of DeleteCommand class members, see the DeleteCommand Members topic.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString | Convert the command to the FTP command text.
ToTraceString (inherited from FtpCommand) | Convert the reply to the trace text.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

DeleteCommand Class | ComponentSpace.Ftp Namespace


DeleteCommand.ToString Method

Convert the command to the FTP command text.

[Visual Basic]
Overrides Public Function ToString() As String
[C#]
public override string ToString();

Return Value

The FTP command text.

See Also

DeleteCommand Class | ComponentSpace.Ftp Namespace


DirectoryListItem Class

The base class for FTP remote directory list items.

For a list of all members of this type, see DirectoryListItem Members.

System.Object
ComponentSpace.Ftp.DirectoryListItem
ComponentSpace.Ftp.MSDOSDirectoryListItem
ComponentSpace.Ftp.UnixDirectoryListItem

[Visual Basic]
MustInherit Public Class DirectoryListItem
[C#]
public abstract class DirectoryListItem

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: ComponentSpace.Ftp

Assembly: ComponentSpace.Ftp (in ComponentSpace.Ftp.dll)

See Also

DirectoryListItem Members | ComponentSpace.Ftp Namespace


DirectoryListItem Members

DirectoryListItem overview

Public Static (Shared) Methods

Sort Sort the array of directory list items in alphabetic order with directories first, followed by soft links and then ordinary files.

Public Instance Constructors

DirectoryListItem Constructor Initializes a new instance of the DirectoryListItem.

Public Instance Properties

Date | Gets the unprocessed remote directory item date as returned by the FTP server.
DateTime | Gets the DateTime.
ItemType | Gets the remote directory item type.
Name | Gets the remote directory item name.
Size | Gets the remote directory item size.
SoftLink | Gets soft link.
Time | Gets the unprocessed remote directory item time as returned by the FTP server.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

DirectoryListItem Class | ComponentSpace.Ftp Namespace


DirectoryListItem Constructor

Initializes a new instance of the DirectoryListItem.

[Visual Basic]
Public Sub New( _
ByVal name As String, _
ByVal itemType As DirectoryListItemType, _
ByVal date As String, _
ByVal time As String, _
ByVal size As Long, _
ByVal softLink As String _
)
[C#]
public DirectoryListItem(
string name,
DirectoryListItemType itemType,
string date,
string time,
long size,
string softLink
);

Parameters

name
The directory item name.
itemType
The directory item type.
date
The directory item date.
time
The directory item time.
size
The directory item size.
softLink
The soft link.

See Also

DirectoryListItem Class | ComponentSpace.Ftp Namespace


DirectoryListItem Properties

The properties of the DirectoryListItem class are listed below. For a complete list of DirectoryListItem class members, see the DirectoryListItem Members topic.

Public Instance Properties

Date | Gets the unprocessed remote directory item date as returned by the FTP server.
DateTime | Gets the DateTime.
ItemType | Gets the remote directory item type.
Name | Gets the remote directory item name.
Size | Gets the remote directory item size.
SoftLink | Gets soft link.
Time | Gets the unprocessed remote directory item time as returned by the FTP server.

See Also

DirectoryListItem Class | ComponentSpace.Ftp Namespace


DirectoryListItem.Date Property

Gets the unprocessed remote directory item date as returned by the FTP server.

[Visual Basic]
Overridable Public ReadOnly Property Date As String
[C#]
public virtual string Date {get;}

Property Value

The remote directory item date.

Remarks

The time may be accessed using the Time property.

Use the DateTime property to parse the date and time into a DateTime object.

See Also

DirectoryListItem Class | ComponentSpace.Ftp Namespace


DirectoryListItem.DateTime Property

Gets the DateTime.

[Visual Basic]
Overridable Public ReadOnly Property DateTime As Date
[C#]
public virtual System.DateTime DateTime {get;}

Property Value

The DateTime.

Remarks

The DateTime is constructed from the directory list item's Date and Time values.

It assumes the date is in one of the following formats:

month day [year]

where the month is assumed to be one of Jan through to Dec and, if no year is supplied, then it defaults to being in the last 12 month period;

or:

mm-dd-yy

where mm is 1 through 12 and if the year is greater than 50, 1900 is added to it, otherwise 2000 is added.

It assumes the time is in one of the following formats:

hh:mm

where hh is 00 through 23

or:

hh:mm [AM | PM]

where hh is 1 through 12.

The time is optional and, if not present, will default to 00:00.

If the date and time aren't in the expected format an exception is thrown.

Dates and times in the FTP standard (RFC-959) are problematic. With some FTP servers, a date but no time is supplied so the date/time is inaccurate. Also, FTP servers often report the date and time in their local time rather than UTC (GMT). This means that if you wish to convert the date/time to local time at the FTP client, you need to know the time zone in which the FTP server is running.

For an alternative method for obtaining file times refer to the GetModificationTime method.

Exceptions

Exception Type | Condition
FtpException | Thrown when the parsing of the date and time fails.

See Also

DirectoryListItem Class | ComponentSpace.Ftp Namespace


DirectoryListItem.ItemType Property

Gets the remote directory item type.

[Visual Basic]
Overridable Public ReadOnly Property ItemType As DirectoryListItemType
[C#]
public virtual DirectoryListItemType ItemType {get;}

Property Value

The remote directory item type.

See Also

DirectoryListItem Class | ComponentSpace.Ftp Namespace


DirectoryListItem.Name Property

Gets the remote directory item name.

[Visual Basic]
Overridable Public ReadOnly Property Name As String
[C#]
public virtual string Name {get;}

Property Value

The remote directory item name.

See Also

DirectoryListItem Class | ComponentSpace.Ftp Namespace


DirectoryListItem.Size Property

Gets the remote directory item size.

[Visual Basic]
Overridable Public ReadOnly Property Size As Long
[C#]
public virtual long Size {get;}

Property Value

The remote directory item size.

See Also

DirectoryListItem Class | ComponentSpace.Ftp Namespace


DirectoryListItem.SoftLink Property

Gets soft link.

[Visual Basic]
Overridable Public ReadOnly Property SoftLink As String
[C#]
public virtual string SoftLink {get;}

Property Value

The soft link.

See Also

DirectoryListItem Class | ComponentSpace.Ftp Namespace


DirectoryListItem.Time Property

Gets the unprocessed remote directory item time as returned by the FTP server.

[Visual Basic]
Overridable Public ReadOnly Property Time As String
[C#]
public virtual string Time {get;}

Property Value

The remote directory item time.

Remarks

The date may be accessed using the Date property.

Use the DateTime property to parse the date and time into a DateTime object.

See Also

DirectoryListItem Class | ComponentSpace.Ftp Namespace


DirectoryListItem Methods

The methods of the DirectoryListItem class are listed below. For a complete list of DirectoryListItem class members, see the DirectoryListItem Members topic.

Public Static (Shared) Methods

Sort Sort the array of directory list items in alphabetic order with directories first, followed by soft links and then ordinary files.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

DirectoryListItem Class | ComponentSpace.Ftp Namespace


DirectoryListItem.Sort Method

Sort the array of directory list items in alphabetic order with directories first, followed by soft links and then ordinary files.

[Visual Basic]
Public Shared Sub Sort( _
ByVal directoryListItems As DirectoryListItem() _
)
[C#]
public static void Sort(
DirectoryListItem[] directoryListItems
);

Parameters

directoryListItems
The array of directory list items to be sorted.

See Also

DirectoryListItem Class | ComponentSpace.Ftp Namespace


DirectoryListItemType Enumeration

The directory list item types.

[Visual Basic]
Public Enum DirectoryListItemType
[C#]
public enum DirectoryListItemType

Members

Member Name | Description
File | File.
Directory | Directory.
SoftLink | Soft link.

Requirements

Namespace: ComponentSpace.Ftp

Assembly: ComponentSpace.Ftp (in ComponentSpace.Ftp.dll)

See Also

ComponentSpace.Ftp Namespace


DirectoryListParser Class

Parse remote directory lists - either Unix style or MS-DOS.

For a list of all members of this type, see DirectoryListParser Members.

System.Object
ComponentSpace.Ftp.DirectoryListParser

[Visual Basic]
Public Class DirectoryListParser
[C#]
public class DirectoryListParser

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: ComponentSpace.Ftp

Assembly: ComponentSpace.Ftp (in ComponentSpace.Ftp.dll)

See Also

DirectoryListParser Members | ComponentSpace.Ftp Namespace


DirectoryListParser Members

DirectoryListParser overview

Public Static (Shared) Methods

IsMSDOSDirectoryList | Indicate whether the directory list lines are MS-DOS format.
IsUnixDirectoryList | Indicate whether the directory list lines are Unix format.
ParseDirectoryList | Parse either Unix or MS-DOS format directory list items into generic directory list items.
ParseDirectoryListItem | Parse either a Unix or MS-DOS format directory list line into a generic directory list item.
ParseMSDOSDirectoryList | Parse MS-DOS format directory list items into MS-DOS directory list items.
ParseMSDOSDirectoryListItem | Parse MS-DOS format directory list line into MS-DOS directory list item.
ParseUnixDirectoryList | Parse Unix format directory list items into Unix directory list items.
ParseUnixDirectoryListItem | Parse Unix format directory list line into Unix directory list item.

Public Instance Constructors

DirectoryListParser Constructor Initializes a new instance of the DirectoryListParser class.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

DirectoryListParser Class | ComponentSpace.Ftp Namespace


DirectoryListParser Constructor

Initializes a new instance of the DirectoryListParser class.

[Visual Basic]
Public Sub New()
[C#]
public DirectoryListParser();

See Also

DirectoryListParser Class | ComponentSpace.Ftp Namespace


DirectoryListParser Methods

The methods of the DirectoryListParser class are listed below. For a complete list of DirectoryListParser class members, see the DirectoryListParser Members topic.

Public Static (Shared) Methods

IsMSDOSDirectoryList | Indicate whether the directory list lines are MS-DOS format.
IsUnixDirectoryList | Indicate whether the directory list lines are Unix format.
ParseDirectoryList | Parse either Unix or MS-DOS format directory list items into generic directory list items.
ParseDirectoryListItem | Parse either a Unix or MS-DOS format directory list line into a generic directory list item.
ParseMSDOSDirectoryList | Parse MS-DOS format directory list items into MS-DOS directory list items.
ParseMSDOSDirectoryListItem | Parse MS-DOS format directory list line into MS-DOS directory list item.
ParseUnixDirectoryList | Parse Unix format directory list items into Unix directory list items.
ParseUnixDirectoryListItem | Parse Unix format directory list line into Unix directory list item.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

DirectoryListParser Class | ComponentSpace.Ftp Namespace


DirectoryListParser.IsMSDOSDirectoryList Method

Indicate whether the directory list lines are MS-DOS format.

[Visual Basic]
Public Shared Function IsMSDOSDirectoryList( _
ByVal listLine As String _
) As Boolean
[C#]
public static bool IsMSDOSDirectoryList(
string listLine
);

Return Value

true if MS-DOS directory line;false otherwise.

See Also

DirectoryListParser Class | ComponentSpace.Ftp Namespace


DirectoryListParser.IsUnixDirectoryList Method

Indicate whether the directory list lines are Unix format.

[Visual Basic]
Public Shared Function IsUnixDirectoryList( _
ByVal listLine As String _
) As Boolean
[C#]
public static bool IsUnixDirectoryList(
string listLine
);

Return Value

true if Unix directory line;false otherwise.

See Also

DirectoryListParser Class | ComponentSpace.Ftp Namespace


DirectoryListParser.ParseDirectoryList Method

Parse either Unix or MS-DOS format directory list items into generic directory list items.

[Visual Basic]
Public Shared Function ParseDirectoryList( _
ByVal listLines As String() _
) As DirectoryListItem()
[C#]
public static DirectoryListItem[] ParseDirectoryList(
string[] listLines
);

Return Value

The array of directory list items.

Exceptions

Exception Type | Condition
FtpException | Thrown when the parsing fails.

See Also

DirectoryListParser Class | ComponentSpace.Ftp Namespace


DirectoryListParser.ParseDirectoryListItem Method

Parse either a Unix or MS-DOS format directory list line into a generic directory list item.

[Visual Basic]
Public Shared Function ParseDirectoryListItem( _
ByVal listLine As String _
) As DirectoryListItem
[C#]
public static DirectoryListItem ParseDirectoryListItem(
string listLine
);

Return Value

The directory list item.

Exceptions

Exception Type | Condition
FtpException | Thrown when the parsing fails.

See Also

DirectoryListParser Class | ComponentSpace.Ftp Namespace


DirectoryListParser.ParseMSDOSDirectoryList Method

Parse MS-DOS format directory list items into MS-DOS directory list items.

[Visual Basic]
Public Shared Function ParseMSDOSDirectoryList( _
ByVal listLines As String() _
) As MSDOSDirectoryListItem()
[C#]
public static MSDOSDirectoryListItem[] ParseMSDOSDirectoryList(
string[] listLines
);

Parameters

listLines
The directory list lines.

Return Value

The array of directory list items.

Remarks

The expected format is: <date> <time> (<DIR> | <size>) <name>

Exceptions

Exception Type | Condition
FtpException | Thrown when the parsing fails.

See Also

DirectoryListParser Class | ComponentSpace.Ftp Namespace


DirectoryListParser.ParseMSDOSDirectoryListItem Method

Parse MS-DOS format directory list line into MS-DOS directory list item.

[Visual Basic]
Public Shared Function ParseMSDOSDirectoryListItem( _
ByVal listLine As String _
) As MSDOSDirectoryListItem
[C#]
public static MSDOSDirectoryListItem ParseMSDOSDirectoryListItem(
string listLine
);

Parameters

listLine
The directory list line.

Return Value

The directory list item.

Remarks

The expected format is: <date> <time> (<DIR> | <size>) <name>

Exceptions

Exception Type | Condition
FtpException | Thrown when the parsing fails.

See Also

DirectoryListParser Class | ComponentSpace.Ftp Namespace


DirectoryListParser.ParseUnixDirectoryList Method

Parse Unix format directory list items into Unix directory list items.

[Visual Basic]
Public Shared Function ParseUnixDirectoryList( _
ByVal listLines As String() _
) As UnixDirectoryListItem()
[C#]
public static UnixDirectoryListItem[] ParseUnixDirectoryList(
string[] listLines
);

Parameters

listLines
The directory list lines.

Return Value

The array of directory list items.

Remarks

The expected format is: <permissions> <inodes> <owner> <group> <size> <date> <time> <name>

Exceptions

Exception Type | Condition
FtpException | Thrown when the parsing fails.

See Also

DirectoryListParser Class | ComponentSpace.Ftp Namespace


DirectoryListParser.ParseUnixDirectoryListItem Method

Parse Unix format directory list line into Unix directory list item.

[Visual Basic]
Public Shared Function ParseUnixDirectoryListItem( _
ByVal listLine As String _
) As UnixDirectoryListItem
[C#]
public static UnixDirectoryListItem ParseUnixDirectoryListItem(
string listLine
);

Parameters

listLine
The directory list line.

Return Value

The directory list item.

Remarks

The expected format is: <permissions> <inodes> <owner> [<group>] <size> <date> <name>

where the <date> format is either: <month> <day> <hour>:<minute> or <month> <day> <year>.

and, for a soft link, the name is in the form of <name> -> <softlink>

Exceptions

Exception Type | Condition
FtpException | Thrown when the parsing fails.

See Also

DirectoryListParser Class | ComponentSpace.Ftp Namespace


FailSafeTransfer Class

Performs failsafe file transfers.

For a list of all members of this type, see FailSafeTransfer Members.

System.Object
ComponentSpace.Ftp.FailSafeTransfer

[Visual Basic]
Public Class FailSafeTransfer
[C#]
public class FailSafeTransfer

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

Transfers are considered failsafe as inbuilt retry logic will continue attempting the transfer until it is successful. Transfers may be aborted at any time using the Abort method.

The number of retries and the interval between retries may be configured using the RetryCount and RetryInterval properties respectively.

Requirements

Namespace: ComponentSpace.Ftp

Assembly: ComponentSpace.Ftp (in ComponentSpace.Ftp.dll)

See Also

FailSafeTransfer Members | ComponentSpace.Ftp Namespace


FailSafeTransfer Members

FailSafeTransfer overview

Public Instance Constructors

FailSafeTransfer Constructor Initializes a new instance of the FtpClient class.

Public Instance Properties

DataConnectionType | Gets or sets the data connection type.
RetryCount | Gets or sets the number of times to attempt the upload or download.
RetryInterval | Gets or sets the retry interval.
SynchronizingObject | Gets or sets the synchonizing object for receiving events.
TransferMode | Gets or sets the file transfer mode (ASCII or binary).

Public Instance Methods

Abort | Abort the current upload or download.
BeginDownload | Overloaded. Initiates an asynchronous download remote file.
BeginUpload | Overloaded. Initiates an asynchronous upload remote file.
Download | Download the remote file's contents to the local file.
EndDownload | Completes the specified asynchronous download remote file operation.
EndUpload | Completes the specified asynchronous upload remote file operation.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.
Upload | Upload the local file's contents to the remote file.

Public Instance Events

DataTransferred | Occurs at intervals to indicate how many bytes in total have been transferred during the current data transfer. This event may be used provide feedback during data transfers.
DownloadCompleted | Occurs when the download file has completed.
TransferError | Occurs when a transfer attempt fails.
UploadCompleted | Occurs when the upload file has completed.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

FailSafeTransfer Class | ComponentSpace.Ftp Namespace


FailSafeTransfer Constructor

Initializes a new instance of the FtpClient class.

[Visual Basic]
Public Sub New( _
ByVal serverAddress As String, _
ByVal port As Integer, _
ByVal userName As String, _
ByVal password As String _
)
[C#]
public FailSafeTransfer(
string serverAddress,
int port,
string userName,
string password
);

Parameters

serverAddress
The server address (eg. 207.46.133.140 or ftp.microsoft.com).
port
The server command port.
userName
The user name. "anonymous" for an anonymous user. If null no USER command is sent.
password
The password. Normally your email address for an anonymous user. If null no PASS command is sent.

See Also

FailSafeTransfer Class | ComponentSpace.Ftp Namespace


FailSafeTransfer Properties

The properties of the FailSafeTransfer class are listed below. For a complete list of FailSafeTransfer class members, see the FailSafeTransfer Members topic.

Public Instance Properties

DataConnectionType | Gets or sets the data connection type.
RetryCount | Gets or sets the number of times to attempt the upload or download.
RetryInterval | Gets or sets the retry interval.
SynchronizingObject | Gets or sets the synchonizing object for receiving events.
TransferMode | Gets or sets the file transfer mode (ASCII or binary).

See Also

FailSafeTransfer Class | ComponentSpace.Ftp Namespace


FailSafeTransfer.DataConnectionType Property

Gets or sets the data connection type.

[Visual Basic]
Public Property DataConnectionType As DataConnectionType
[C#]
public DataConnectionType DataConnectionType {get; set;}

Property Value

The data connection type. The default is Auto.

Remarks

If Inbound, a PORT command is issued and the server connects to the client. If Outbound, a PASV command is issued and the client connects to the server. This is referred to as passive mode. If Auto, an outbound connection is attempted and, if this fails, an inbound connection is then tried. However, if a previous inbound connection was made then an inbound connection is attempted again before trying an outbound connection.

See Also

FailSafeTransfer Class | ComponentSpace.Ftp Namespace


FailSafeTransfer.RetryCount Property

Gets or sets the number of times to attempt the upload or download.

[Visual Basic]
Public Property RetryCount As Integer
[C#]
public int RetryCount {get; set;}

Property Value

The transfer retry count. A value of zero indicates to retry indefinitely. The default value is zero (ie. retry indefinitely).

Remarks

Once the retry count has been reached no further transfers attempts are made and an exception is thrown to indicate the transfer failed.

See Also

FailSafeTransfer Class | ComponentSpace.Ftp Namespace


FailSafeTransfer.RetryInterval Property

Gets or sets the retry interval.

[Visual Basic]
Public Property RetryInterval As TimeSpan
[C#]
public System.TimeSpan RetryInterval {get; set;}

Property Value

The retry interval. The default value is 10 seconds.

Remarks

This is the interval between attempts to complete the transfer.

See Also

FailSafeTransfer Class | ComponentSpace.Ftp Namespace


FailSafeTransfer.SynchronizingObject Property

Gets or sets the synchonizing object for receiving events.

[Visual Basic]
Public Property SynchronizingObject As ISynchronizeInvoke
[C#]
public System.ComponentModel.ISynchronizeInvoke SynchronizingObject {get; set;}

Property Value

An ISynchronizeInvoke, which represents the object that marshals the event-handler call resulting from an event. The default is a null reference (Nothing in Visual Basic).

Remarks

Typically, the SynchronizingObject is set when it's used within a form, because forms are bound to a specific thread.

Typically, the synchronizing object marshals a method call into a single thread.

See Also

FailSafeTransfer Class | ComponentSpace.Ftp Namespace


FailSafeTransfer.TransferMode Property

Gets or sets the file transfer mode (ASCII or binary).

[Visual Basic]
Public Property TransferMode As TransferMode
[C#]
public TransferMode TransferMode {get; set;}

Property Value

The file transfer mode. The default is ASCII.

See Also

FailSafeTransfer Class | ComponentSpace.Ftp Namespace


FailSafeTransfer Methods

The methods of the FailSafeTransfer class are listed below. For a complete list of FailSafeTransfer class members, see the FailSafeTransfer Members topic.

Public Instance Methods

Abort | Abort the current upload or download.
BeginDownload | Overloaded. Initiates an asynchronous download remote file.
BeginUpload | Overloaded. Initiates an asynchronous upload remote file.
Download | Download the remote file's contents to the local file.
EndDownload | Completes the specified asynchronous download remote file operation.
EndUpload | Completes the specified asynchronous upload remote file operation.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.
Upload | Upload the local file's contents to the remote file.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

FailSafeTransfer Class | ComponentSpace.Ftp Namespace


FailSafeTransfer.Abort Method

Abort the current upload or download.

[Visual Basic]
Public Sub Abort()
[C#]
public void Abort();

See Also

FailSafeTransfer Class | ComponentSpace.Ftp Namespace


BeginDownload Method

ComponentSpace FTP Class Library Reference

FailSafeTransfer.BeginDownload Method

Initiates an asynchronous download remote file.

Overload List

Initiates an asynchronous download remote file.

public IAsyncResult BeginDownload(string,string);

Initiates an asynchronous download remote file that has a specified state object.

public IAsyncResult BeginDownload(string,string,object);

Initiates an asynchronous download remote file that has a specified state object. This overload receives notification, through a callback, of the identity of the event handler for this operation.

public IAsyncResult BeginDownload(string,string,object,AsyncCallback);

See Also

FailSafeTransfer Class | ComponentSpace.Ftp Namespace


FailSafeTransfer.BeginDownload Method (String, String)

Initiates an asynchronous download remote file.

[Visual Basic]
Overloads Public Function BeginDownload( _
ByVal sourcePathName As String, _
ByVal destinationPathName As String _
) As IAsyncResult
[C#]
public IAsyncResult BeginDownload(
string sourcePathName,
string destinationPathName
);

Parameters

sourcePathName
The remote file path name.
destinationPathName
The local file path name.

Return Value

The IAsyncResult that identifies the posted asynchronous request.

Remarks

In asynchronous processing, you use BeginDownload to raise the DownloadCompleted event when the download has completed. You complete the operation by calling EndDownload.

See Also

FailSafeTransfer Class | ComponentSpace.Ftp Namespace | FailSafeTransfer.BeginDownload Overload List


FailSafeTransfer.BeginDownload Method (String, String, Object)

Initiates an asynchronous download remote file that has a specified state object.

[Visual Basic]
Overloads Public Function BeginDownload( _
ByVal sourcePathName As String, _
ByVal destinationPathName As String, _
ByVal stateObject As Object _
) As IAsyncResult
[C#]
public IAsyncResult BeginDownload(
string sourcePathName,
string destinationPathName,
object stateObject
);

Parameters

sourcePathName
The remote file path name.
destinationPathName
The local file path name.
stateObject
A state object, specified by the application, that contains information associated with the asynchronous operation.

Return Value

The IAsyncResult that identifies the posted asynchronous request.

Remarks

In asynchronous processing, you use BeginDownload to raise the DownloadCompleted event when the download has completed. You complete the operation by calling EndDownload.

Use this overload to associate information with the operation that will be preserved throughout the operation's lifetime. The event handler can detect this information by looking at the AsyncState of the IAsyncResult that is associated with the operation.

See Also

FailSafeTransfer Class | ComponentSpace.Ftp Namespace | FailSafeTransfer.BeginDownload Overload List


FailSafeTransfer.BeginDownload Method (String, String, Object, AsyncCallback)

Initiates an asynchronous download remote file that has a specified state object. This overload receives notification, through a callback, of the identity of the event handler for this operation.

[Visual Basic]
Overloads Public Function BeginDownload( _
ByVal sourcePathName As String, _
ByVal destinationPathName As String, _
ByVal stateObject As Object, _
ByVal asyncCallback As AsyncCallback _
) As IAsyncResult
[C#]
public IAsyncResult BeginDownload(
string sourcePathName,
string destinationPathName,
object stateObject,
AsyncCallback asyncCallback
);

Parameters

sourcePathName
The remote file path name.
destinationPathName
The local file path name.
stateObject
A state object, specified by the application, that contains information associated with the asynchronous operation.
asyncCallback
The AsyncCallback that will receive the notification of the asynchronous operation completion.

Return Value

The IAsyncResult that identifies the posted asynchronous request.

Remarks

When you use this overload, the callback specified in the callback parameter is invoked directly when the download has completed; the DownloadCompleted event is not raised. The other overloads of BeginDownload rely on this component to raise the DownloadCompleted event.

See Also

FailSafeTransfer Class | ComponentSpace.Ftp Namespace | FailSafeTransfer.BeginDownload Overload List


BeginUpload Method

ComponentSpace FTP Class Library Reference

FailSafeTransfer.BeginUpload Method

Initiates an asynchronous upload remote file.

Overload List

Initiates an asynchronous upload remote file.

public IAsyncResult BeginUpload(string,string);

Initiates an asynchronous upload remote file that has a specified state object.

public IAsyncResult BeginUpload(string,string,object);

Initiates an asynchronous upload remote file that has a specified state object. This overload receives notification, through a callback, of the identity of the event handler for this operation.

public IAsyncResult BeginUpload(string,string,object,AsyncCallback);

See Also

FailSafeTransfer Class | ComponentSpace.Ftp Namespace


FailSafeTransfer.BeginUpload Method (String, String)

Initiates an asynchronous upload remote file.

[Visual Basic]
Overloads Public Function BeginUpload( _
ByVal sourcePathName As String, _
ByVal destinationPathName As String _
) As IAsyncResult
[C#]
public IAsyncResult BeginUpload(
string sourcePathName,
string destinationPathName
);

Parameters

sourcePathName
The local file name.
destinationPathName
The remote file name or null.

Return Value

The IAsyncResult that identifies the posted asynchronous request.

Remarks

In asynchronous processing, you use BeginUpload to raise the UploadCompleted event when the upload has completed. You complete the operation by calling EndUpload.

See Also

FailSafeTransfer Class | ComponentSpace.Ftp Namespace | FailSafeTransfer.BeginUpload Overload List


FailSafeTransfer.BeginUpload Method (String, String, Object)

Initiates an asynchronous upload remote file that has a specified state object.

[Visual Basic]
Overloads Public Function BeginUpload( _
ByVal sourcePathName As String, _
ByVal destinationPathName As String, _
ByVal stateObject As Object _
) As IAsyncResult
[C#]
public IAsyncResult BeginUpload(
string sourcePathName,
string destinationPathName,
object stateObject
);

Parameters

sourcePathName
The local file name.
destinationPathName
The remote file name.
stateObject
A state object, specified by the application, that contains information associated with the asynchronous operation.

Return Value

The IAsyncResult that identifies the posted asynchronous request.

Remarks

In asynchronous processing, you use BeginUpload to raise the UploadCompleted event when the upload has completed. You complete the operation by calling EndUpload.

Use this overload to associate information with the operation that will be preserved throughout the operation's lifetime. The event handler can detect this information by looking at the AsyncState of the IAsyncResult that is associated with the operation.

See Also

FailSafeTransfer Class | ComponentSpace.Ftp Namespace | FailSafeTransfer.BeginUpload Overload List


FailSafeTransfer.BeginUpload Method (String, String, Object, AsyncCallback)

Initiates an asynchronous upload remote file that has a specified state object. This overload receives notification, through a callback, of the identity of the event handler for this operation.

[Visual Basic]
Overloads Public Function BeginUpload( _
ByVal sourcePathName As String, _
ByVal destinationPathName As String, _
ByVal stateObject As Object, _
ByVal asyncCallback As AsyncCallback _
) As IAsyncResult
[C#]
public IAsyncResult BeginUpload(
string sourcePathName,
string destinationPathName,
object stateObject,
AsyncCallback asyncCallback
);

Parameters

sourcePathName
The local file name.
destinationPathName
The remote file name.
stateObject
A state object, specified by the application, that contains information associated with the asynchronous operation.
asyncCallback
The AsyncCallback that will receive the notification of the asynchronous operation completion.

Return Value

The IAsyncResult that identifies the posted asynchronous request.

Remarks

When you use this overload, the callback specified in the callback parameter is invoked directly when the upload has completed; the UploadCompleted event is not raised. The other overloads of BeginUpload rely on this component to raise the UploadCompleted event.

See Also

FailSafeTransfer Class | ComponentSpace.Ftp Namespace | FailSafeTransfer.BeginUpload Overload List


FailSafeTransfer.Download Method

Download the remote file's contents to the local file.

[Visual Basic]
Public Sub Download( _
ByVal sourcePathName As String, _
ByVal destinationPathName As String _
)
[C#]
public void Download(
string sourcePathName,
string destinationPathName
);

Parameters

sourcePathName
The remote file path name.
destinationPathName
The local file path name.

Exceptions

Exception Type | Condition
FtpException | Thrown when either the download is aborted or the retry limit has been reached.

See Also

FailSafeTransfer Class | ComponentSpace.Ftp Namespace


FailSafeTransfer.EndDownload Method

Completes the specified asynchronous download remote file operation.

[Visual Basic]
Public Sub EndDownload( _
ByVal asyncResult As IAsyncResult _
)
[C#]
public void EndDownload(
IAsyncResult asyncResult
);

Parameters

asyncResult
The IAsyncResult that identifies the asynchronous download to finish, and from which to retrieve an end result.

Remarks

When the DownloadCompleted event is raised, EndDownload completes the operation that was initiated by the BeginDownload call.

Exceptions

Exception Type | Condition
FtpException | Thrown when either the download is aborted or the retry limit has been reached.

See Also

FailSafeTransfer Class | ComponentSpace.Ftp Namespace


FailSafeTransfer.EndUpload Method

Completes the specified asynchronous upload remote file operation.

[Visual Basic]
Public Sub EndUpload( _
ByVal asyncResult As IAsyncResult _
)
[C#]
public void EndUpload(
IAsyncResult asyncResult
);

Parameters

asyncResult
The IAsyncResult that identifies the asynchronous upload to finish, and from which to retrieve an end result.

Remarks

When the UploadCompleted event is raised, EndUpload completes the operation that was initiated by the BeginUpload call.

Exceptions

Exception Type | Condition
FtpException | Thrown when either the upload is aborted or the retry limit has been reached.

See Also

FailSafeTransfer Class | ComponentSpace.Ftp Namespace


FailSafeTransfer.Upload Method

Upload the local file's contents to the remote file.

[Visual Basic]
Public Sub Upload( _
ByVal sourcePathName As String, _
ByVal destinationPathName As String _
)
[C#]
public void Upload(
string sourcePathName,
string destinationPathName
);

Parameters

sourcePathName
The local file name.
destinationPathName
The remote file name.

Exceptions

Exception Type | Condition
FtpException | Thrown when either the upload is aborted or the retry limit has been reached.

See Also

FailSafeTransfer Class | ComponentSpace.Ftp Namespace


FailSafeTransfer Events

The events of the FailSafeTransfer class are listed below. For a complete list of FailSafeTransfer class members, see the FailSafeTransfer Members topic.

Public Instance Events

DataTransferred | Occurs at intervals to indicate how many bytes in total have been transferred during the current data transfer. This event may be used provide feedback during data transfers.
DownloadCompleted | Occurs when the download file has completed.
TransferError | Occurs when a transfer attempt fails.
UploadCompleted | Occurs when the upload file has completed.

See Also

FailSafeTransfer Class | ComponentSpace.Ftp Namespace


FailSafeTransfer.DataTransferred Event

Occurs at intervals to indicate how many bytes in total have been transferred during the current data transfer. This event may be used provide feedback during data transfers.

[Visual Basic]
Public Event DataTransferred As DataTransferredEventHandler
[C#]
public event DataTransferredEventHandler DataTransferred;

Event Data

The event handler receives an argument of type DataTransferredEventArgs containing data related to this event. The following DataTransferredEventArgs property provides information specific to this event.

Property | Description
BytesTransferred | Gets the total number of bytes transferred in the current operation.

See Also

FailSafeTransfer Class | ComponentSpace.Ftp Namespace


FailSafeTransfer.DownloadCompleted Event

Occurs when the download file has completed.

[Visual Basic]
Public Event DownloadCompleted As FtpOperationCompletedEventHandler
[C#]
public event FtpOperationCompletedEventHandler DownloadCompleted;

Event Data

The event handler receives an argument of type FtpOperationCompletedEventArgs containing data related to this event. The following FtpOperationCompletedEventArgs property provides information specific to this event.

Property | Description
AsyncResult | Gets the result of the asynchronous send operation.

Remarks

BeginDownload is used in asynchronous processing to raise the DownloadCompleted event when the download file has completed.

EndDownload is used to complete the operation initiated by a call to BeginDownload and get the download file status when the DownloadCompleted event is raised.

See Also

FailSafeTransfer Class | ComponentSpace.Ftp Namespace


FailSafeTransfer.TransferError Event

Occurs when a transfer attempt fails.

[Visual Basic]
Public Event TransferError As FailSafeTransferEventHandler
[C#]
public event FailSafeTransferEventHandler TransferError;

Event Data

The event handler receives an argument of type FailSafeTransferEventArgs containing data related to this event. The following FailSafeTransferEventArgs properties provide information specific to this event.

Property | Description
Exception | Gets the exception.
RestartMarker | Gets the restart marker.
RetryNumber | Gets the retry number.

Remarks

Whilst performing a transfer this event will be raised for each failed attempt.

See Also

FailSafeTransfer Class | ComponentSpace.Ftp Namespace


FailSafeTransfer.UploadCompleted Event

Occurs when the upload file has completed.

[Visual Basic]
Public Event UploadCompleted As FtpOperationCompletedEventHandler
[C#]
public event FtpOperationCompletedEventHandler UploadCompleted;

Event Data

The event handler receives an argument of type FtpOperationCompletedEventArgs containing data related to this event. The following FtpOperationCompletedEventArgs property provides information specific to this event.

Property | Description
AsyncResult | Gets the result of the asynchronous send operation.

Remarks

BeginUpload is used in asynchronous processing to raise the UploadCompleted event when the upload file has completed.

EndUpload is used to complete the operation initiated by a call to BeginUpload and get the upload file status when the UploadCompleted event is raised.

See Also

FailSafeTransfer Class | ComponentSpace.Ftp Namespace


FailSafeTransferEventArgs Class

Provides data for the event.

For a list of all members of this type, see FailSafeTransferEventArgs Members.

System.Object
System.EventArgs
ComponentSpace.Ftp.FailSafeTransferEventArgs

[Visual Basic]
Public Class FailSafeTransferEventArgs
Inherits EventArgs
[C#]
public class FailSafeTransferEventArgs : EventArgs

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: ComponentSpace.Ftp

Assembly: ComponentSpace.Ftp (in ComponentSpace.Ftp.dll)

See Also

FailSafeTransferEventArgs Members | ComponentSpace.Ftp Namespace


FailSafeTransferEventArgs Members

FailSafeTransferEventArgs overview

Public Instance Properties

Exception | Gets the exception.
RestartMarker | Gets the restart marker.
RetryNumber | Gets the retry number.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

FailSafeTransferEventArgs Class | ComponentSpace.Ftp Namespace


FailSafeTransferEventArgs Properties

The properties of the FailSafeTransferEventArgs class are listed below. For a complete list of FailSafeTransferEventArgs class members, see the FailSafeTransferEventArgs Members topic.

Public Instance Properties

Exception | Gets the exception.
RestartMarker | Gets the restart marker.
RetryNumber | Gets the retry number.

See Also

FailSafeTransferEventArgs Class | ComponentSpace.Ftp Namespace


FailSafeTransferEventArgs.Exception Property

Gets the exception.

[Visual Basic]
Public ReadOnly Property Exception As Exception
[C#]
public System.Exception Exception {get;}

Property Value

The exception that occurred whilst attempting the transfer.

See Also

FailSafeTransferEventArgs Class | ComponentSpace.Ftp Namespace


FailSafeTransferEventArgs.RestartMarker Property

Gets the restart marker.

[Visual Basic]
Public ReadOnly Property RestartMarker As Long
[C#]
public long RestartMarker {get;}

Property Value

The restart marker is the current file offset for the transfer.

See Also

FailSafeTransferEventArgs Class | ComponentSpace.Ftp Namespace


FailSafeTransferEventArgs.RetryNumber Property

Gets the retry number.

[Visual Basic]
Public ReadOnly Property RetryNumber As Integer
[C#]
public int RetryNumber {get;}

Property Value

The retry number represents the current attempt number at performing the transfer.

See Also

FailSafeTransferEventArgs Class | ComponentSpace.Ftp Namespace


FailSafeTransferEventHandler Delegate

Represents the method that will handle failsafe transfer events.

[Visual Basic]
Public Delegate Sub FailSafeTransferEventHandler( _
ByVal sender As Object, _
ByVal e As FailSafeTransferEventArgs _
)
[C#]
public delegate void FailSafeTransferEventHandler(
object sender,
FailSafeTransferEventArgs e
);

Parameters

sender
The source of the event.
e
A FailSafeTransferEventArgs that contains the event data.

Remarks

When you create a FailSafeTransferEventHandler delegate, you identify the method that will handle the event. To associate the event with your event handler, add an instance of the delegate to the event. The event handler is called whenever the event occurs, unless you remove the delegate.

Requirements

Namespace: ComponentSpace.Ftp

Assembly: ComponentSpace.Ftp (in ComponentSpace.Ftp.dll)

See Also

ComponentSpace.Ftp Namespace


FileModificationTimeCommand Class

Represents the FTP MDTM command.

For a list of all members of this type, see FileModificationTimeCommand Members.

System.Object
ComponentSpace.Ftp.FtpCommand
ComponentSpace.Ftp.FileModificationTimeCommand

[Visual Basic]
Public Class FileModificationTimeCommand
Inherits FtpCommand
[C#]
public class FileModificationTimeCommand : FtpCommand

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: ComponentSpace.Ftp

Assembly: ComponentSpace.Ftp (in ComponentSpace.Ftp.dll)

See Also

FileModificationTimeCommand Members | ComponentSpace.Ftp Namespace


FileModificationTimeCommand Members

FileModificationTimeCommand overview

Public Instance Constructors

FileModificationTimeCommand Overloaded. Initializes a new instance of the FileModificationTimeCommand class.

Public Instance Properties

CommandType (inherited from FtpCommand) | Gets the command type.
PathName | Gets or sets the remote path name.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString | Convert the command to the FTP command text.
ToTraceString (inherited from FtpCommand) | Convert the reply to the trace text.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

FileModificationTimeCommand Class | ComponentSpace.Ftp Namespace


FileModificationTimeCommand Constructor

Initializes a new instance of the FileModificationTimeCommand.

Overload List

Initializes a new instance of the FileModificationTimeCommand.

public FileModificationTimeCommand();

Initializes a new instance of the FileModificationTimeCommand from the raw command text.

public FileModificationTimeCommand(string);

See Also

FileModificationTimeCommand Class | ComponentSpace.Ftp Namespace


FileModificationTimeCommand Constructor ()

Initializes a new instance of the FileModificationTimeCommand.

[Visual Basic]
Overloads Public Sub New()
[C#]
public FileModificationTimeCommand();

See Also

FileModificationTimeCommand Class | ComponentSpace.Ftp Namespace | FileModificationTimeCommand Constructor Overload List


FileModificationTimeCommand Constructor (String)

Initializes a new instance of the FileModificationTimeCommand from the raw command text.

[Visual Basic]
Overloads Public Sub New( _
ByVal command As String _
)
[C#]
public FileModificationTimeCommand(
string command
);

Parameters

command
The raw command text.

See Also

FileModificationTimeCommand Class | ComponentSpace.Ftp Namespace | FileModificationTimeCommand Constructor Overload List


FileModificationTimeCommand Properties

The properties of the FileModificationTimeCommand class are listed below. For a complete list of FileModificationTimeCommand class members, see the FileModificationTimeCommand Members topic.

Public Instance Properties

CommandType (inherited from FtpCommand) | Gets the command type.
PathName | Gets or sets the remote path name.

See Also

FileModificationTimeCommand Class | ComponentSpace.Ftp Namespace


FileModificationTimeCommand.PathName Property

Gets or sets the remote path name.

[Visual Basic]
Public Property PathName As String
[C#]
public string PathName {get; set;}

Property Value

The remote path name.

See Also

FileModificationTimeCommand Class | ComponentSpace.Ftp Namespace


FileModificationTimeCommand Methods

The methods of the FileModificationTimeCommand class are listed below. For a complete list of FileModificationTimeCommand class members, see the FileModificationTimeCommand Members topic.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString | Convert the command to the FTP command text.
ToTraceString (inherited from FtpCommand) | Convert the reply to the trace text.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

FileModificationTimeCommand Class | ComponentSpace.Ftp Namespace


FileModificationTimeCommand.ToString Method

Convert the command to the FTP command text.

[Visual Basic]
Overrides Public Function ToString() As String
[C#]
public override string ToString();

Return Value

The FTP command text.

See Also

FileModificationTimeCommand Class | ComponentSpace.Ftp Namespace


FtpClient Class

Sends FTP requests and receives FTP responses using the File Transfer Protocol (RFC-959).

For a list of all members of this type, see FtpClient Members.

System.Object
ComponentSpace.Ftp.FtpClient

[Visual Basic]
Public Class FtpClient
Implements IDisposable
[C#]
public class FtpClient : IDisposable

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

The FTP connection may be established synchronously (blocking) using Connect, or asynchronously (non-blocking) using BeginConnect and EndConnect. All other potentially time consuming operations may either be performed synchronously or asynchronously.

Remote directory related actions are accessed through RemoteDirectory. Remote file related actions are accessed through RemoteFile. Multi-file actions are accessed through MultiFile.

The DataConnectionType property determines whether the data connection is outbound or inbound.

Optionally, the CommandSendTimeout and CommandReceiveTimeout may be set for the command connection.

Optionally, the DataSendTimeout and DataReceiveTimeout may be set for the data connection.

Example

This simple download example uses the Download static method of the FtpClient class. It will connect, download and disconnect in a single method call.

FtpClient.Download("ftp.microsoft.com", _
                   "anonymous", _
                   "me@mycompany.com", _
                   TransferMode.Binary, _
                   "/Services/Museum/pictures/ballmerplunge.jpg", _
                   "c:\temp\ballmerplunge.jpg")
Alternatively you can connect, perform multiple operations and then disconnect.
Dim ftpClient As New FtpClient()

ftpClient.Connect("ftp.microsoft.com", _
                  "anonymous", _
                  "me@mycompany.com")

ftpClient.RemoteFile.Download("/Services/Museum/pictures/ballmerplunge.jpg", _
                              "c:\temp\ballmerplunge.jpg")

' Perform other FTP commands against this server

ftpClient.Disconnect()
Finally, you can perform all operations asynchronously. This example uses RemoteFile.BeginDownload and RemoteFile.EndDownload and an event handler.
Dim ftpClient As New FtpClient()

ftpClient.Connect("ftp.microsoft.com", _
                  "anonymous", _
                  "me@mycompany.com")

AddHandler ftpClient.RemoteFile.DownloadCompleted, AddressOf OnDownloadCompleted

ftpClient.RemoteFile.BeginDownload("/Services/Museum/pictures/ballmerplunge.jpg", _
                                   "c:\temp\ballmerplunge.jpg")

Private Sub OnDownloadCompleted(ByVal sender As Object, ByVal e As FtpOperationCompletedEventArgs)
    ftpClient.RemoteFile.EndDownload(e.AsyncResult)
End Sub

Requirements

Namespace: ComponentSpace.Ftp

Assembly: ComponentSpace.Ftp (in ComponentSpace.Ftp.dll)

See Also

FtpClient Members | ComponentSpace.Ftp Namespace


FtpClient Members

FtpClient overview

Public Static (Shared) Methods

Download | Download the remote file's contents to the local file.
Upload | Upload the local file's contents to the remote file. If destinationPathName is null then a unique name is generated on the remote server.

Public Instance Constructors

FtpClient Constructor Initializes a new instance of the FtpClient class.

Public Instance Properties

CommandReceiveTimeout | Gets or sets the number of milliseconds to wait for the command response from the server.
CommandSendTimeout | Gets or sets the number of milliseconds to wait for the command request to be sent to the server.
Connected | Gets the command connection status.
DataConnectionType | Gets or sets the data connection type.
DataReceiveTimeout | Gets or sets the number of milliseconds to wait for the command response from the server.
DataSendTimeout | Gets or sets the number of milliseconds to wait for the data request to be sent to the server.
FtpCommandConnection | Gets the FtpCommandConnection object that represents the FTP command connection.
MultiFile | Gets the MultiFile object that provides multiple file related functionality including deleting a non-empty directory.
RemoteDirectory | Gets the RemoteDirectory object that provides remote directory related functionality including directory listing and changing etc.
RemoteFile | Gets the RemoteFile object that provides remote file related functionality including file upload and download etc.
SynchronizingObject | Gets or sets the synchonizing object for receiving events.

Public Instance Methods

Abort | Ask the server to abort the current command and any associated data transfer.
BeginAbort | Overloaded. Initiates an asynchronous abort.
BeginConnect | Overloaded. Initiates an asynchronous connect as an anonymous user.
BeginGetRemoteStatus | Overloaded. Initiates an asynchronous get remote status.
BeginGetRemoteSystemInfo | Overloaded. Initiates an asynchronous get remote system information.
BeginSendQuoteCommand | Overloaded. Initiates an asynchronous quote command.
BeginSendSiteCommand | Overloaded. Initiates an asynchronous site command.
Connect | Overloaded. Connects to the server as an anonymous user. A user name of anonymous will be used and a nonexistent email address will be used for the password.
Disconnect | Disconnects from the server.
Dispose | Dispose of the FtpClient and the underlying socket objects.
EndAbort | Completes the specified asynchronous abort operation.
EndConnect | Completes the specified asynchronous connect operation.
EndGetRemoteStatus | Completes the specified asynchronous get remote status operation.
EndGetRemoteSystemInfo | Completes the specified asynchronous get remote system information operation.
EndSendQuoteCommand | Completes the specified asynchronous quote command operation.
EndSendSiteCommand | Completes the specified asynchronous site command operation.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetRemoteStatus | Get the remote system's status.
GetRemoteSystemInfo | Get the remote system's OS information.
GetType (inherited from Object) | Gets the Type of the current instance.
SendQuoteCommand | Execute an arbitrary command. The supplied command text is sent to the FTP server as is.
SendSiteCommand | Execute the site command.
ToString (inherited from Object) | Returns a String that represents the current Object.

Public Instance Events

AbortCompleted | Occurs when the abort has completed.
CommandTraced | Occurs when a command is being sent or a command reply has been received. This event may be used to trace commands and replies.
ConnectCompleted | Occurs when the connect has completed.
GetRemoteStatusCompleted | Occurs when the get remote status has completed.
GetRemoteSystemInfoCompleted | Occurs when the get remote system info has completed.
QuoteCommandCompleted | Occurs when the quote command has completed.
SiteCommandCompleted | Occurs when the site command has completed.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

FtpClient Class | ComponentSpace.Ftp Namespace


FtpClient Constructor

Initializes a new instance of the FtpClient class.

[Visual Basic]
Public Sub New()
[C#]
public FtpClient();

See Also

FtpClient Class | ComponentSpace.Ftp Namespace


FtpClient Properties

The properties of the FtpClient class are listed below. For a complete list of FtpClient class members, see the FtpClient Members topic.

Public Instance Properties

CommandReceiveTimeout | Gets or sets the number of milliseconds to wait for the command response from the server.
CommandSendTimeout | Gets or sets the number of milliseconds to wait for the command request to be sent to the server.
Connected | Gets the command connection status.
DataConnectionType | Gets or sets the data connection type.
DataReceiveTimeout | Gets or sets the number of milliseconds to wait for the command response from the server.
DataSendTimeout | Gets or sets the number of milliseconds to wait for the data request to be sent to the server.
FtpCommandConnection | Gets the FtpCommandConnection object that represents the FTP command connection.
MultiFile | Gets the MultiFile object that provides multiple file related functionality including deleting a non-empty directory.
RemoteDirectory | Gets the RemoteDirectory object that provides remote directory related functionality including directory listing and changing etc.
RemoteFile | Gets the RemoteFile object that provides remote file related functionality including file upload and download etc.
SynchronizingObject | Gets or sets the synchonizing object for receiving events.

See Also

FtpClient Class | ComponentSpace.Ftp Namespace


FtpClient.CommandReceiveTimeout Property

Gets or sets the number of milliseconds to wait for the command response from the server.

[Visual Basic]
Public Property CommandReceiveTimeout As Integer
[C#]
public int CommandReceiveTimeout {get; set;}

Property Value

The number of milliseconds to wait for the command response from the server. The default is 60 seconds.

See Also

FtpClient Class | ComponentSpace.Ftp Namespace


FtpClient.CommandSendTimeout Property

Gets or sets the number of milliseconds to wait for the command request to be sent to the server.

[Visual Basic]
Public Property CommandSendTimeout As Integer
[C#]
public int CommandSendTimeout {get; set;}

Property Value

The number of milliseconds to wait for the command request to be sent to the server. The default is 60 seconds.

See Also

FtpClient Class | ComponentSpace.Ftp Namespace


FtpClient.Connected Property

Gets the command connection status.

[Visual Basic]
Public ReadOnly Property Connected As Boolean
[C#]
public bool Connected {get;}

Property Value

true if connected; false if not connected.

See Also

FtpClient Class | ComponentSpace.Ftp Namespace


FtpClient.DataConnectionType Property

Gets or sets the data connection type.

[Visual Basic]
Public Property DataConnectionType As DataConnectionType
[C#]
public DataConnectionType DataConnectionType {get; set;}

Property Value

The data connection type. The default is Auto.

Remarks

If Inbound, a PORT command is issued and the server connects to the client. If Outbound, a PASV command is issued and the client connects to the server. This is referred to as passive mode. If Auto, an outbound connection is attempted and, if this fails, an inbound connection is then tried. However, if a previous inbound connection was made then an inbound connection is attempted again before trying an outbound connection.

See Also

FtpClient Class | ComponentSpace.Ftp Namespace


FtpClient.DataReceiveTimeout Property

Gets or sets the number of milliseconds to wait for the command response from the server.

[Visual Basic]
Public Property DataReceiveTimeout As Integer
[C#]
public int DataReceiveTimeout {get; set;}

Property Value

The number of milliseconds to wait for the data response from the server. The default is 60 seconds.

See Also

FtpClient Class | ComponentSpace.Ftp Namespace


FtpClient.DataSendTimeout Property

Gets or sets the number of milliseconds to wait for the data request to be sent to the server.

[Visual Basic]
Public Property DataSendTimeout As Integer
[C#]
public int DataSendTimeout {get; set;}

Property Value

The number of milliseconds to wait for the data request to be sent to the server. The default is 60 seconds.

See Also

FtpClient Class | ComponentSpace.Ftp Namespace


FtpClient.FtpCommandConnection Property

Gets the FtpCommandConnection object that represents the FTP command connection.

[Visual Basic]
Public ReadOnly Property FtpCommandConnection As FtpCommandConnection
[C#]
public FtpCommandConnection FtpCommandConnection {get;}

Property Value

The FtpCommandConnection object that represents the FTP command connection.

Remarks

Normally you don't need to access the FTP command connection directly and you should avoid doing so unless absolutely necessary (eg. to implement a non-standard login sequence to support certain firewalls).

See Also

FtpClient Class | ComponentSpace.Ftp Namespace


FtpClient.MultiFile Property

Gets the MultiFile object that provides multiple file related functionality including deleting a non-empty directory.

[Visual Basic]
Public ReadOnly Property MultiFile As MultiFile
[C#]
public MultiFile MultiFile {get;}

Property Value

The MultiFile object that provides multiple file related functionality.

See Also

FtpClient Class | ComponentSpace.Ftp Namespace


FtpClient.RemoteDirectory Property

Gets the RemoteDirectory object that provides remote directory related functionality including directory listing and changing etc.

[Visual Basic]
Public ReadOnly Property RemoteDirectory As RemoteDirectory
[C#]
public RemoteDirectory RemoteDirectory {get;}

Property Value

The RemoteDirectory object that provides remote directory related functionality.

See Also

FtpClient Class | ComponentSpace.Ftp Namespace


FtpClient.RemoteFile Property

Gets the RemoteFile object that provides remote file related functionality including file upload and download etc.

[Visual Basic]
Public ReadOnly Property RemoteFile As RemoteFile
[C#]
public RemoteFile RemoteFile {get;}

Property Value

The RemoteFile object that provides remote file related functionality.

See Also

FtpClient Class | ComponentSpace.Ftp Namespace


FtpClient.SynchronizingObject Property

Gets or sets the synchonizing object for receiving events.

[Visual Basic]
Public Property SynchronizingObject As ISynchronizeInvoke
[C#]
public System.ComponentModel.ISynchronizeInvoke SynchronizingObject {get; set;}

Property Value

An ISynchronizeInvoke, which represents the object that marshals the event-handler call resulting from an event. The default is a null reference (Nothing in Visual Basic).

Remarks

Typically, the SynchronizingObject is set when it's used within a form, because forms are bound to a specific thread.

Typically, the synchronizing object marshals a method call into a single thread.

See Also

FtpClient Class | ComponentSpace.Ftp Namespace


FtpClient Methods

The methods of the FtpClient class are listed below. For a complete list of FtpClient class members, see the FtpClient Members topic.

Public Static (Shared) Methods

Download | Download the remote file's contents to the local file.
Upload | Upload the local file's contents to the remote file. If destinationPathName is null then a unique name is generated on the remote server.

Public Instance Methods

Abort | Ask the server to abort the current command and any associated data transfer.
BeginAbort | Overloaded. Initiates an asynchronous abort.
BeginConnect | Overloaded. Initiates an asynchronous connect as an anonymous user.
BeginGetRemoteStatus | Overloaded. Initiates an asynchronous get remote status.
BeginGetRemoteSystemInfo | Overloaded. Initiates an asynchronous get remote system information.
BeginSendQuoteCommand | Overloaded. Initiates an asynchronous quote command.
BeginSendSiteCommand | Overloaded. Initiates an asynchronous site command.
Connect | Overloaded. Connects to the server as an anonymous user. A user name of anonymous will be used and a nonexistent email address will be used for the password.
Disconnect | Disconnects from the server.
Dispose | Dispose of the FtpClient and the underlying socket objects.
EndAbort | Completes the specified asynchronous abort operation.
EndConnect | Completes the specified asynchronous connect operation.
EndGetRemoteStatus | Completes the specified asynchronous get remote status operation.
EndGetRemoteSystemInfo | Completes the specified asynchronous get remote system information operation.
EndSendQuoteCommand | Completes the specified asynchronous quote command operation.
EndSendSiteCommand | Completes the specified asynchronous site command operation.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetRemoteStatus | Get the remote system's status.
GetRemoteSystemInfo | Get the remote system's OS information.
GetType (inherited from Object) | Gets the Type of the current instance.
SendQuoteCommand | Execute an arbitrary command. The supplied command text is sent to the FTP server as is.
SendSiteCommand | Execute the site command.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

FtpClient Class | ComponentSpace.Ftp Namespace


FtpClient.Abort Method

Ask the server to abort the current command and any associated data transfer.

[Visual Basic]
Public Sub Abort()
[C#]
public void Abort();

Exceptions

Exception Type | Condition
FtpException | Thrown when the abort fails.

See Also

FtpClient Class | ComponentSpace.Ftp Namespace


BeginAbort Method

ComponentSpace FTP Class Library Reference

FtpClient.BeginAbort Method

Initiates an asynchronous abort.

Overload List

Initiates an asynchronous abort.

public IAsyncResult BeginAbort();

Initiates an asynchronous abort that has a specified state object.

public IAsyncResult BeginAbort(object);

Initiates an asynchronous abort that has a specified state object. This overload receives notification, through a callback, of the identity of the event handler for this operation.

public IAsyncResult BeginAbort(object,AsyncCallback);

See Also

FtpClient Class | ComponentSpace.Ftp Namespace


FtpClient.BeginAbort Method ()

Initiates an asynchronous abort.

[Visual Basic]
Overloads Public Function BeginAbort() As IAsyncResult
[C#]
public IAsyncResult BeginAbort();

Return Value

The IAsyncResult that identifies the posted asynchronous request.

Remarks

In asynchronous processing, you use BeginAbort to raise the AbortCompleted event when the abort has completed. You complete the operation by calling EndAbort.

See Also

FtpClient Class | ComponentSpace.Ftp Namespace | FtpClient.BeginAbort Overload List


FtpClient.BeginAbort Method (Object)

Initiates an asynchronous abort that has a specified state object.

[Visual Basic]
Overloads Public Function BeginAbort( _
ByVal stateObject As Object _
) As IAsyncResult
[C#]
public IAsyncResult BeginAbort(
object stateObject
);

Parameters

stateObject
A state object, specified by the application, that contains information associated with the asynchronous operation.

Return Value

The IAsyncResult that identifies the posted asynchronous request.

Remarks

In asynchronous processing, you use BeginAbort to raise the AbortCompleted event when the abort has completed. You complete the operation by calling EndAbort.

Use this overload to associate information with the operation that will be preserved throughout the operation's lifetime. The event handler can detect this information by looking at the AsyncState of the IAsyncResult that is associated with the operation.

See Also

FtpClient Class | ComponentSpace.Ftp Namespace | FtpClient.BeginAbort Overload List


FtpClient.BeginAbort Method (Object, AsyncCallback)

Initiates an asynchronous abort that has a specified state object. This overload receives notification, through a callback, of the identity of the event handler for this operation.

[Visual Basic]
Overloads Public Function BeginAbort( _
ByVal stateObject As Object, _
ByVal asyncCallback As AsyncCallback _
) As IAsyncResult
[C#]
public IAsyncResult BeginAbort(
object stateObject,
AsyncCallback asyncCallback
);

Parameters

stateObject
A state object, specified by the application, that contains information associated with the asynchronous operation.
asyncCallback
The AsyncCallback that will receive the notification of the asynchronous operation completion.

Return Value

The IAsyncResult that identifies the posted asynchronous request.

Remarks

When you use this overload, the callback specified in the callback parameter is invoked directly when the abort has completed; the AbortCompleted event is not raised. The other overloads of BeginAbort rely on this component to raise the AbortCompleted event.

See Also

FtpClient Class | ComponentSpace.Ftp Namespace | FtpClient.BeginAbort Overload List


BeginConnect Method

ComponentSpace FTP Class Library Reference

FtpClient.BeginConnect Method

Initiates an asynchronous connect as an anonymous user.

Overload List

Initiates an asynchronous connect as an anonymous user.

public IAsyncResult BeginConnect(string);

Initiates an asynchronous connect using the specified port.

public IAsyncResult BeginConnect(string,int,string,string);

Initiates an asynchronous connect using the specified port and that has a specified state object.

public IAsyncResult BeginConnect(string,int,string,string,object);

Initiates an asynchronous connect using the specified port and that has a specified state object. This overload receives notification, through a callback, of the identity of the event handler for this operation.

public IAsyncResult BeginConnect(string,int,string,string,object,AsyncCallback);

Initiates an asynchronous connect using the specified port.

public IAsyncResult BeginConnect(string,int,string,string,string);

Initiates an asynchronous connect using the specified port and that has a specified state object.

public IAsyncResult BeginConnect(string,int,string,string,string,object);

Initiates an asynchronous connect using the specified port and that has a specified state object. This overload receives notification, through a callback, of the identity of the event handler for this operation.

public IAsyncResult BeginConnect(string,int,string,string,string,object,AsyncCallback);

Initiates an asynchronous connect using the default command port 21.

public IAsyncResult BeginConnect(string,string,string);

Initiates an asynchronous connect using the default command port 21 and that has a specified state object.

public IAsyncResult BeginConnect(string,string,string,object);

Initiates an asynchronous connect using the default command port 21 and that has a specified state object. This overload receives notification, through a callback, of the identity of the event handler for this operation.

public IAsyncResult BeginConnect(string,string,string,object,AsyncCallback);

See Also

FtpClient Class | ComponentSpace.Ftp Namespace


FtpClient.BeginConnect Method (String)

Initiates an asynchronous connect as an anonymous user.

[Visual Basic]
Overloads Public Function BeginConnect( _
ByVal serverAddress As String _
) As IAsyncResult
[C#]
public IAsyncResult BeginConnect(
string serverAddress
);

Parameters

serverAddress
The server address (eg. 207.46.133.140 or ftp.microsoft.com).

Return Value

The IAsyncResult that identifies the posted asynchronous request.

Remarks

In asynchronous processing, you use BeginConnect to raise the ConnectCompleted event when the connect has completed. You complete the operation by calling EndConnect.

See Also

FtpClient Class | ComponentSpace.Ftp Namespace | FtpClient.BeginConnect Overload List


FtpClient.BeginConnect Method (String, Int32, String, String)

Initiates an asynchronous connect using the specified port.

[Visual Basic]
Overloads Public Function BeginConnect( _
ByVal serverAddress As String, _
ByVal port As Integer, _
ByVal userName As String, _
ByVal password As String _
) As IAsyncResult
[C#]
public IAsyncResult BeginConnect(
string serverAddress,
int port,
string userName,
string password
);

Parameters

serverAddress
The server address (eg. 207.46.133.140 or ftp.microsoft.com).
port
The server command port.
userName
The user name. "anonymous" for an anonymous user.
password
The password. Normally your email address for an anonymous user.

Return Value

The IAsyncResult that identifies the posted asynchronous request.

Remarks

In asynchronous processing, you use BeginConnect to raise the ConnectCompleted event when the connect has completed. You complete the operation by calling EndConnect.

See Also

FtpClient Class | ComponentSpace.Ftp Namespace | FtpClient.BeginConnect Overload List


FtpClient.BeginConnect Method (String, Int32, String, String, Object)

Initiates an asynchronous connect using the specified port and that has a specified state object.

[Visual Basic]
Overloads Public Function BeginConnect( _
ByVal serverAddress As String, _
ByVal port As Integer, _
ByVal userName As String, _
ByVal password As String, _
ByVal stateObject As Object _
) As IAsyncResult
[C#]
public IAsyncResult BeginConnect(
string serverAddress,
int port,
string userName,
string password,
object stateObject
);

Parameters

serverAddress
The server address (eg. 207.46.133.140 or ftp.microsoft.com).
port
The server command port.
userName
The user name. "anonymous" for an anonymous user.
password
The password. Normally your email address for an anonymous user.
stateObject
A state object, specified by the application, that contains information associated with the asynchronous operation.

Return Value

The IAsyncResult that identifies the posted asynchronous request.

Remarks

In asynchronous processing, you use BeginConnect to raise the ConnectCompleted event when the connect has completed. You complete the operation by calling EndConnect.

Use this overload to associate information with the operation that will be preserved throughout the operation's lifetime. The event handler can detect this information by looking at the AsyncState of the IAsyncResult that is associated with the operation.

See Also

FtpClient Class | ComponentSpace.Ftp Namespace | FtpClient.BeginConnect Overload List


FtpClient.BeginConnect Method (String, Int32, String, String, Object, AsyncCallback)

Initiates an asynchronous connect using the specified port and that has a specified state object. This overload receives notification, through a callback, of the identity of the event handler for this operation.

[Visual Basic]
Overloads Public Function BeginConnect( _
ByVal serverAddress As String, _
ByVal port As Integer, _
ByVal userName As String, _
ByVal password As String, _
ByVal stateObject As Object, _
ByVal asyncCallback As AsyncCallback _
) As IAsyncResult
[C#]
public IAsyncResult BeginConnect(
string serverAddress,
int port,
string userName,
string password,
object stateObject,
AsyncCallback asyncCallback
);

Parameters

serverAddress
The server address (eg. 207.46.133.140 or ftp.microsoft.com).
port
The server command port.
userName
The user name. "anonymous" for an anonymous user.
password
The password. Normally your email address for an anonymous user.
stateObject
A state object, specified by the application, that contains information associated with the asynchronous operation.
asyncCallback
The AsyncCallback that will receive the notification of the asynchronous operation completion.

Return Value

The IAsyncResult that identifies the posted asynchronous request.

Remarks

When you use this overload, the callback specified in the callback parameter is invoked directly when the connect has completed; the ConnectCompleted event is not raised. The other overloads of BeginConnect rely on this component to raise the ConnectCompleted event.

See Also

FtpClient Class | ComponentSpace.Ftp Namespace | FtpClient.BeginConnect Overload List


FtpClient.BeginConnect Method (String, Int32, String, String, String)

Initiates an asynchronous connect using the specified port.

[Visual Basic]
Overloads Public Function BeginConnect( _
ByVal serverAddress As String, _
ByVal port As Integer, _
ByVal userName As String, _
ByVal password As String, _
ByVal accountInformation As String _
) As IAsyncResult
[C#]
public IAsyncResult BeginConnect(
string serverAddress,
int port,
string userName,
string password,
string accountInformation
);

Parameters

serverAddress
The server address (eg. 207.46.133.140 or ftp.microsoft.com).
port
The server command port.
userName
The user name. "anonymous" for an anonymous user.
password
The password. Normally your email address for an anonymous user.
accountInformation
The account information. If null no ACCT command is sent.

Return Value

The IAsyncResult that identifies the posted asynchronous request.

Remarks

In asynchronous processing, you use BeginConnect to raise the ConnectCompleted event when the connect has completed. You complete the operation by calling EndConnect.

See Also

FtpClient Class | ComponentSpace.Ftp Namespace | FtpClient.BeginConnect Overload List


FtpClient.BeginConnect Method (String, Int32, String, String, String, Object)

Initiates an asynchronous connect using the specified port and that has a specified state object.

[Visual Basic]
Overloads Public Function BeginConnect( _
ByVal serverAddress As String, _
ByVal port As Integer, _
ByVal userName As String, _
ByVal password As String, _
ByVal accountInformation As String, _
ByVal stateObject As Object _
) As IAsyncResult
[C#]
public IAsyncResult BeginConnect(
string serverAddress,
int port,
string userName,
string password,
string accountInformation,
object stateObject
);

Parameters

serverAddress
The server address (eg. 207.46.133.140 or ftp.microsoft.com).
port
The server command port.
userName
The user name. "anonymous" for an anonymous user.
password
The password. Normally your email address for an anonymous user.
accountInformation
The account information. If null no ACCT command is sent.
stateObject
A state object, specified by the application, that contains information associated with the asynchronous operation.

Return Value

The IAsyncResult that identifies the posted asynchronous request.

Remarks

In asynchronous processing, you use BeginConnect to raise the ConnectCompleted event when the connect has completed. You complete the operation by calling EndConnect.

Use this overload to associate information with the operation that will be preserved throughout the operation's lifetime. The event handler can detect this information by looking at the AsyncState of the IAsyncResult that is associated with the operation.

See Also

FtpClient Class | ComponentSpace.Ftp Namespace | FtpClient.BeginConnect Overload List


FtpClient.BeginConnect Method (String, Int32, String, String, String, Object, AsyncCallback)

Initiates an asynchronous connect using the specified port and that has a specified state object. This overload receives notification, through a callback, of the identity of the event handler for this operation.

[Visual Basic]
Overloads Public Function BeginConnect( _
ByVal serverAddress As String, _
ByVal port As Integer, _
ByVal userName As String, _
ByVal password As String, _
ByVal accountInformation As String, _
ByVal stateObject As Object, _
ByVal asyncCallback As AsyncCallback _
) As IAsyncResult
[C#]
public IAsyncResult BeginConnect(
string serverAddress,
int port,
string userName,
string password,
string accountInformation,
object stateObject,
AsyncCallback asyncCallback
);

Parameters

serverAddress
The server address (eg. 207.46.133.140 or ftp.microsoft.com).
port
The server command port.
userName
The user name. "anonymous" for an anonymous user.
password
The password. Normally your email address for an anonymous user.
accountInformation
The account information. If null no ACCT command is sent.
stateObject
A state object, specified by the application, that contains information associated with the asynchronous operation.
asyncCallback
The AsyncCallback that will receive the notification of the asynchronous operation completion.

Return Value

The IAsyncResult that identifies the posted asynchronous request.

Remarks

When you use this overload, the callback specified in the callback parameter is invoked directly when the connect has completed; the ConnectCompleted event is not raised. The other overloads of BeginConnect rely on this component to raise the ConnectCompleted event.

See Also

FtpClient Class | ComponentSpace.Ftp Namespace | FtpClient.BeginConnect Overload List


FtpClient.BeginConnect Method (String, String, String)

Initiates an asynchronous connect using the default command port 21.

[Visual Basic]
Overloads Public Function BeginConnect( _
ByVal serverAddress As String, _
ByVal userName As String, _
ByVal password As String _
) As IAsyncResult
[C#]
public IAsyncResult BeginConnect(
string serverAddress,
string userName,
string password
);

Parameters

serverAddress
The server address (eg. 207.46.133.140 or ftp.microsoft.com).
userName
The user name. "anonymous" for an anonymous user.
password
The password. Normally your email address for an anonymous user.

Return Value

The IAsyncResult that identifies the posted asynchronous request.

Remarks

In asynchronous processing, you use BeginConnect to raise the ConnectCompleted event when the connect has completed. You complete the operation by calling EndConnect.

See Also

FtpClient Class | ComponentSpace.Ftp Namespace | FtpClient.BeginConnect Overload List


FtpClient.BeginConnect Method (String, String, String, Object)

Initiates an asynchronous connect using the default command port 21 and that has a specified state object.

[Visual Basic]
Overloads Public Function BeginConnect( _
ByVal serverAddress As String, _
ByVal userName As String, _
ByVal password As String, _
ByVal stateObject As Object _
) As IAsyncResult
[C#]
public IAsyncResult BeginConnect(
string serverAddress,
string userName,
string password,
object stateObject
);

Parameters

serverAddress
The server address (eg. 207.46.133.140 or ftp.microsoft.com).
userName
The user name. "anonymous" for an anonymous user.
password
The password. Normally your email address for an anonymous user.
stateObject
A state object, specified by the application, that contains information associated with the asynchronous operation.

Return Value

The IAsyncResult that identifies the posted asynchronous request.

Remarks

In asynchronous processing, you use BeginConnect to raise the ConnectCompleted event when the connect has completed. You complete the operation by calling EndConnect.

Use this overload to associate information with the operation that will be preserved throughout the operation's lifetime. The event handler can detect this information by looking at the AsyncState of the IAsyncResult that is associated with the operation.

See Also

FtpClient Class | ComponentSpace.Ftp Namespace | FtpClient.BeginConnect Overload List


FtpClient.BeginConnect Method (String, String, String, Object, AsyncCallback)

Initiates an asynchronous connect using the default command port 21 and that has a specified state object. This overload receives notification, through a callback, of the identity of the event handler for this operation.

[Visual Basic]
Overloads Public Function BeginConnect( _
ByVal serverAddress As String, _
ByVal userName As String, _
ByVal password As String, _
ByVal stateObject As Object, _
ByVal asyncCallback As AsyncCallback _
) As IAsyncResult
[C#]
public IAsyncResult BeginConnect(
string serverAddress,
string userName,
string password,
object stateObject,
AsyncCallback asyncCallback
);

Parameters

serverAddress
The server address (eg. 207.46.133.140 or ftp.microsoft.com).
userName
The user name. "anonymous" for an anonymous user.
password
The password. Normally your email address for an anonymous user.
stateObject
A state object, specified by the application, that contains information associated with the asynchronous operation.
asyncCallback
The AsyncCallback that will receive the notification of the asynchronous operation completion.

Return Value

The IAsyncResult that identifies the posted asynchronous request.

Remarks

When you use this overload, the callback specified in the callback parameter is invoked directly when the connect has completed; the ConnectCompleted event is not raised. The other overloads of BeginConnect rely on this component to raise the ConnectCompleted event.

See Also

FtpClient Class | ComponentSpace.Ftp Namespace | FtpClient.BeginConnect Overload List


BeginGetRemoteStatus Method

ComponentSpace FTP Class Library Reference

FtpClient.BeginGetRemoteStatus Method

Initiates an asynchronous get remote status.

Overload List

Initiates an asynchronous get remote status.

public IAsyncResult BeginGetRemoteStatus();

Initiates an asynchronous get remote status that has a specified state object.

public IAsyncResult BeginGetRemoteStatus(object);

Initiates an asynchronous get remote status that has a specified state object. This overload receives notification, through a callback, of the identity of the event handler for this operation.

public IAsyncResult BeginGetRemoteStatus(object,AsyncCallback);

See Also

FtpClient Class | ComponentSpace.Ftp Namespace


FtpClient.BeginGetRemoteStatus Method ()

Initiates an asynchronous get remote status.

[Visual Basic]
Overloads Public Function BeginGetRemoteStatus() As IAsyncResult
[C#]
public IAsyncResult BeginGetRemoteStatus();

Return Value

The IAsyncResult that identifies the posted asynchronous request.

Remarks

In asynchronous processing, you use BeginGetRemoteStatus to raise the GetRemoteStatusCompleted event when the get remote status has completed. You complete the operation by calling EndGetRemoteStatus.

See Also

FtpClient Class | ComponentSpace.Ftp Namespace | FtpClient.BeginGetRemoteStatus Overload List


FtpClient.BeginGetRemoteStatus Method (Object)

Initiates an asynchronous get remote status that has a specified state object.

[Visual Basic]
Overloads Public Function BeginGetRemoteStatus( _
ByVal stateObject As Object _
) As IAsyncResult
[C#]
public IAsyncResult BeginGetRemoteStatus(
object stateObject
);

Parameters

stateObject
A state object, specified by the application, that contains information associated with the asynchronous operation.

Return Value

The IAsyncResult that identifies the posted asynchronous request.

Remarks

In asynchronous processing, you use BeginGetRemoteStatus to raise the GetRemoteStatusCompleted event when the get remote status has completed. You complete the operation by calling EndGetRemoteStatus.

Use this overload to associate information with the operation that will be preserved throughout the operation's lifetime. The event handler can detect this information by looking at the AsyncState of the IAsyncResult that is associated with the operation.

See Also

FtpClient Class | ComponentSpace.Ftp Namespace | FtpClient.BeginGetRemoteStatus Overload List


FtpClient.BeginGetRemoteStatus Method (Object, AsyncCallback)

Initiates an asynchronous get remote status that has a specified state object. This overload receives notification, through a callback, of the identity of the event handler for this operation.

[Visual Basic]
Overloads Public Function BeginGetRemoteStatus( _
ByVal stateObject As Object, _
ByVal asyncCallback As AsyncCallback _
) As IAsyncResult
[C#]
public IAsyncResult BeginGetRemoteStatus(
object stateObject,
AsyncCallback asyncCallback
);

Parameters

stateObject
A state object, specified by the application, that contains information associated with the asynchronous operation.
asyncCallback
The AsyncCallback that will receive the notification of the asynchronous operation completion.

Return Value

The IAsyncResult that identifies the posted asynchronous request.

Remarks

When you use this overload, the callback specified in the callback parameter is invoked directly when the get remote status has completed; the GetRemoteStatusCompleted event is not raised. The other overloads of BeginGetRemoteStatus rely on this component to raise the GetRemoteStatusCompleted event.

See Also

FtpClient Class | ComponentSpace.Ftp Namespace | FtpClient.BeginGetRemoteStatus Overload List


BeginGetRemoteSystemInfo Method

ComponentSpace FTP Class Library Reference

FtpClient.BeginGetRemoteSystemInfo Method

Initiates an asynchronous get remote system information.

Overload List

Initiates an asynchronous get remote system information.

public IAsyncResult BeginGetRemoteSystemInfo();

Initiates an asynchronous get remote system information that has a specified state object.

public IAsyncResult BeginGetRemoteSystemInfo(object);

Initiates an asynchronous get remote system information that has a specified state object. This overload receives notification, through a callback, of the identity of the event handler for this operation.

public IAsyncResult BeginGetRemoteSystemInfo(object,AsyncCallback);

See Also

FtpClient Class | ComponentSpace.Ftp Namespace


FtpClient.BeginGetRemoteSystemInfo Method ()

Initiates an asynchronous get remote system information.

[Visual Basic]
Overloads Public Function BeginGetRemoteSystemInfo() As IAsyncResult
[C#]
public IAsyncResult BeginGetRemoteSystemInfo();

Return Value

The IAsyncResult that identifies the posted asynchronous request.

Remarks

In asynchronous processing, you use BeginGetRemoteSystemInfo to raise the GetRemoteSystemInfoCompleted event when the get remote system information has completed. You complete the operation by calling EndGetRemoteSystemInfo.

See Also

FtpClient Class | ComponentSpace.Ftp Namespace | FtpClient.BeginGetRemoteSystemInfo Overload List


FtpClient.BeginGetRemoteSystemInfo Method (Object)

Initiates an asynchronous get remote system information that has a specified state object.

[Visual Basic]
Overloads Public Function BeginGetRemoteSystemInfo( _
ByVal stateObject As Object _
) As IAsyncResult
[C#]
public IAsyncResult BeginGetRemoteSystemInfo(
object stateObject
);

Parameters

stateObject
A state object, specified by the application, that contains information associated with the asynchronous operation.

Return Value

The IAsyncResult that identifies the posted asynchronous request.

Remarks

In asynchronous processing, you use BeginGetRemoteSystemInfo to raise the GetRemoteSystemInfoCompleted event when the get remote system information has completed. You complete the operation by calling EndGetRemoteSystemInfo.

Use this overload to associate information with the operation that will be preserved throughout the operation's lifetime. The event handler can detect this information by looking at the AsyncState of the IAsyncResult that is associated with the operation.

See Also

FtpClient Class | ComponentSpace.Ftp Namespace | FtpClient.BeginGetRemoteSystemInfo Overload List


FtpClient.BeginGetRemoteSystemInfo Method (Object, AsyncCallback)

Initiates an asynchronous get remote system information that has a specified state object. This overload receives notification, through a callback, of the identity of the event handler for this operation.

[Visual Basic]
Overloads Public Function BeginGetRemoteSystemInfo( _
ByVal stateObject As Object, _
ByVal asyncCallback As AsyncCallback _
) As IAsyncResult
[C#]
public IAsyncResult BeginGetRemoteSystemInfo(
object stateObject,
AsyncCallback asyncCallback
);

Parameters

stateObject
A state object, specified by the application, that contains information associated with the asynchronous operation.
asyncCallback
The AsyncCallback that will receive the notification of the asynchronous operation completion.

Return Value

The IAsyncResult that identifies the posted asynchronous request.

Remarks

When you use this overload, the callback specified in the callback parameter is invoked directly when the get remote system information has completed; the GetRemoteSystemInfoCompleted event is not raised. The other overloads of BeginGetRemoteSystemInfo rely on this component to raise the GetRemoteSystemInfoCompleted event.

See Also

FtpClient Class | ComponentSpace.Ftp Namespace | FtpClient.BeginGetRemoteSystemInfo Overload List


BeginSendQuoteCommand Method

ComponentSpace FTP Class Library Reference

FtpClient.BeginSendQuoteCommand Method

Initiates an asynchronous quote command.

Overload List

Initiates an asynchronous quote command.

public IAsyncResult BeginSendQuoteCommand(string);

Initiates an asynchronous quote command that has a specified state object.

public IAsyncResult BeginSendQuoteCommand(string,object);

Initiates an asynchronous quote command that has a specified state object. This overload receives notification, through a callback, of the identity of the event handler for this operation.

public IAsyncResult BeginSendQuoteCommand(string,object,AsyncCallback);

See Also

FtpClient Class | ComponentSpace.Ftp Namespace


FtpClient.BeginSendQuoteCommand Method (String)

Initiates an asynchronous quote command.

[Visual Basic]
Overloads Public Function BeginSendQuoteCommand( _
ByVal command As String _
) As IAsyncResult
[C#]
public IAsyncResult BeginSendQuoteCommand(
string command
);

Parameters

command
The arbitrary command text.

Return Value

The IAsyncResult that identifies the posted asynchronous request.

Remarks

In asynchronous processing, you use BeginSendQuoteCommand to raise the QuoteCommandCompleted event when the quote command has completed. You complete the operation by calling EndSendQuoteCommand.

See Also

FtpClient Class | ComponentSpace.Ftp Namespace | FtpClient.BeginSendQuoteCommand Overload List


FtpClient.BeginSendQuoteCommand Method (String, Object)

Initiates an asynchronous quote command that has a specified state object.

[Visual Basic]
Overloads Public Function BeginSendQuoteCommand( _
ByVal command As String, _
ByVal stateObject As Object _
) As IAsyncResult
[C#]
public IAsyncResult BeginSendQuoteCommand(
string command,
object stateObject
);

Parameters

command
The arbitrary command text.
stateObject
A state object, specified by the application, that contains information associated with the asynchronous operation.

Return Value

The IAsyncResult that identifies the posted asynchronous request.

Remarks

In asynchronous processing, you use BeginSendQuoteCommand to raise the QuoteCommandCompleted event when the quote command has completed. You complete the operation by calling EndSendQuoteCommand.

Use this overload to associate information with the operation that will be preserved throughout the operation's lifetime. The event handler can detect this information by looking at the AsyncState of the IAsyncResult that is associated with the operation.

See Also

FtpClient Class | ComponentSpace.Ftp Namespace | FtpClient.BeginSendQuoteCommand Overload List


FtpClient.BeginSendQuoteCommand Method (String, Object, AsyncCallback)

Initiates an asynchronous quote command that has a specified state object. This overload receives notification, through a callback, of the identity of the event handler for this operation.

[Visual Basic]
Overloads Public Function BeginSendQuoteCommand( _
ByVal command As String, _
ByVal stateObject As Object, _
ByVal asyncCallback As AsyncCallback _
) As IAsyncResult
[C#]
public IAsyncResult BeginSendQuoteCommand(
string command,
object stateObject,
AsyncCallback asyncCallback
);

Parameters

command
The arbitrary command text.
stateObject
A state object, specified by the application, that contains information associated with the asynchronous operation.
asyncCallback
The AsyncCallback that will receive the notification of the asynchronous operation completion.

Return Value

The IAsyncResult that identifies the posted asynchronous request.

Remarks

When you use this overload, the callback specified in the callback parameter is invoked directly when the quote command has completed; the QuoteCommandCompleted event is not raised. The other overloads of BeginSendQuoteCommand rely on this component to raise the QuoteCommandCompleted event.

See Also

FtpClient Class | ComponentSpace.Ftp Namespace | FtpClient.BeginSendQuoteCommand Overload List


BeginSendSiteCommand Method

ComponentSpace FTP Class Library Reference

FtpClient.BeginSendSiteCommand Method

Initiates an asynchronous site command.

Overload List

Initiates an asynchronous site command.

public IAsyncResult BeginSendSiteCommand(string);

Initiates an asynchronous site command that has a specified state object.

public IAsyncResult BeginSendSiteCommand(string,object);

Initiates an asynchronous site command that has a specified state object. This overload receives notification, through a callback, of the identity of the event handler for this operation.

public IAsyncResult BeginSendSiteCommand(string,object,AsyncCallback);

See Also

FtpClient Class | ComponentSpace.Ftp Namespace


FtpClient.BeginSendSiteCommand Method (String)

Initiates an asynchronous site command.

[Visual Basic]
Overloads Public Function BeginSendSiteCommand( _
ByVal arguments As String _
) As IAsyncResult
[C#]
public IAsyncResult BeginSendSiteCommand(
string arguments
);

Parameters

arguments
The site command arguments.

Return Value

The IAsyncResult that identifies the posted asynchronous request.

Remarks

In asynchronous processing, you use BeginSendSiteCommand to raise the SiteCommandCompleted event when the site command has completed. You complete the operation by calling EndSendSiteCommand.

See Also

FtpClient Class | ComponentSpace.Ftp Namespace | FtpClient.BeginSendSiteCommand Overload List


FtpClient.BeginSendSiteCommand Method (String, Object)

Initiates an asynchronous site command that has a specified state object.

[Visual Basic]
Overloads Public Function BeginSendSiteCommand( _
ByVal arguments As String, _
ByVal stateObject As Object _
) As IAsyncResult
[C#]
public IAsyncResult BeginSendSiteCommand(
string arguments,
object stateObject
);

Parameters

arguments
The site command arguments.
stateObject
A state object, specified by the application, that contains information associated with the asynchronous operation.

Return Value

The IAsyncResult that identifies the posted asynchronous request.

Remarks

In asynchronous processing, you use BeginSendSiteCommand to raise the SiteCommandCompleted event when the site command has completed. You complete the operation by calling EndSendSiteCommand.

Use this overload to associate information with the operation that will be preserved throughout the operation's lifetime. The event handler can detect this information by looking at the AsyncState of the IAsyncResult that is associated with the operation.

See Also

FtpClient Class | ComponentSpace.Ftp Namespace | FtpClient.BeginSendSiteCommand Overload List


FtpClient.BeginSendSiteCommand Method (String, Object, AsyncCallback)

Initiates an asynchronous site command that has a specified state object. This overload receives notification, through a callback, of the identity of the event handler for this operation.

[Visual Basic]
Overloads Public Function BeginSendSiteCommand( _
ByVal arguments As String, _
ByVal stateObject As Object, _
ByVal asyncCallback As AsyncCallback _
) As IAsyncResult
[C#]
public IAsyncResult BeginSendSiteCommand(
string arguments,
object stateObject,
AsyncCallback asyncCallback
);

Parameters

arguments
The site command arguments.
stateObject
A state object, specified by the application, that contains information associated with the asynchronous operation.
asyncCallback
The AsyncCallback that will receive the notification of the asynchronous operation completion.

Return Value

The IAsyncResult that identifies the posted asynchronous request.

Remarks

When you use this overload, the callback specified in the callback parameter is invoked directly when the site command has completed; the SiteCommandCompleted event is not raised. The other overloads of BeginSendSiteCommand rely on this component to raise the SiteCommandCompleted event.

See Also

FtpClient Class | ComponentSpace.Ftp Namespace | FtpClient.BeginSendSiteCommand Overload List


Connect Method

ComponentSpace FTP Class Library Reference

FtpClient.Connect Method

Connects to the server as an anonymous user. A user name of anonymous will be used and a nonexistent email address will be used for the password.

Overload List

Connects to the server as an anonymous user. A user name of anonymous will be used and a nonexistent email address will be used for the password.

public void Connect(string);

Connects to the server using the specified command port.

public void Connect(string,int,string,string);

Connects to the server using the specified command port and sends the optional account information.

public void Connect(string,int,string,string,string);

Connects to the server using the default command port 21.

public void Connect(string,string,string);

See Also

FtpClient Class | ComponentSpace.Ftp Namespace


FtpClient.Connect Method (String)

Connects to the server as an anonymous user. A user name of anonymous will be used and a nonexistent email address will be used for the password.

[Visual Basic]
Overloads Public Sub Connect( _
ByVal serverAddress As String _
)
[C#]
public void Connect(
string serverAddress
);

Parameters

serverAddress
The server address (eg. 207.46.133.140 or ftp.microsoft.com).

Remarks

After connecting an attempt will be made to login anonymously.

Exceptions

Exception Type | Condition
FtpException | Thrown when the connect fails.

See Also

FtpClient Class | ComponentSpace.Ftp Namespace | FtpClient.Connect Overload List


FtpClient.Connect Method (String, Int32, String, String)

Connects to the server using the specified command port.

[Visual Basic]
Overloads Public Sub Connect( _
ByVal serverAddress As String, _
ByVal port As Integer, _
ByVal userName As String, _
ByVal password As String _
)
[C#]
public void Connect(
string serverAddress,
int port,
string userName,
string password
);

Parameters

serverAddress
The server address (eg. 207.46.133.140 or ftp.microsoft.com).
port
The server command port.
userName
The user name. "anonymous" for an anonymous user. If null no USER command is sent.
password
The password. Normally your email address for an anonymous user. If null no PASS command is sent.

Remarks

After connecting an attempt will be made to login using the supplied user name and password. If you do not supply these then you must perform the login explicitly by sending the appropriate FTP commands. Performing the login explicitly normally is only required to support certain firewall configurations that don't involve sending a user and password command. In most cases the built in login is sufficient.

Exceptions

Exception Type | Condition
FtpException | Thrown when the connect fails.

See Also

FtpClient Class | ComponentSpace.Ftp Namespace | FtpClient.Connect Overload List


FtpClient.Connect Method (String, Int32, String, String, String)

Connects to the server using the specified command port and sends the optional account information.

[Visual Basic]
Overloads Public Sub Connect( _
ByVal serverAddress As String, _
ByVal port As Integer, _
ByVal userName As String, _
ByVal password As String, _
ByVal accountInformation As String _
)
[C#]
public void Connect(
string serverAddress,
int port,
string userName,
string password,
string accountInformation
);

Parameters

serverAddress
The server address (eg. 207.46.133.140 or ftp.microsoft.com).
port
The server command port.
userName
The user name. "anonymous" for an anonymous user. If null no USER command is sent.
password
The password. Normally your email address for an anonymous user. If null no PASS command is sent.
accountInformation
The account information. If null no ACCT command is sent.

Remarks

After connecting an attempt will be made to login using the supplied user name and password. If you do not supply these then you must perform the login explicitly by sending the appropriate FTP commands. Performing the login explicitly normally is only required to support certain firewall configurations that don't involve sending a user and password command. In most cases the built in login is sufficient.

Exceptions

Exception Type | Condition
FtpException | Thrown when the connect fails.

See Also

FtpClient Class | ComponentSpace.Ftp Namespace | FtpClient.Connect Overload List


FtpClient.Connect Method (String, String, String)

Connects to the server using the default command port 21.

[Visual Basic]
Overloads Public Sub Connect( _
ByVal serverAddress As String, _
ByVal userName As String, _
ByVal password As String _
)
[C#]
public void Connect(
string serverAddress,
string userName,
string password
);

Parameters

serverAddress
The server address (eg. 207.46.133.140 or ftp.microsoft.com).
userName
The user name. "anonymous" for an anonymous user. If null no USER command is sent.
password
The password. Normally your email address for an anonymous user. If null no PASS command is sent.

Remarks

After connecting an attempt will be made to login using the supplied user name and password. If you do not supply these then you must perform the login explicitly by sending the appropriate FTP commands. Performing the login explicitly normally is only required to support certain firewall configurations that don't involve sending a user and password command. In most cases the built in login is sufficient.

Exceptions

Exception Type | Condition
FtpException | Thrown when the connect fails.

See Also

FtpClient Class | ComponentSpace.Ftp Namespace | FtpClient.Connect Overload List


FtpClient.Disconnect Method

Disconnects from the server.

[Visual Basic]
Public Sub Disconnect()
[C#]
public void Disconnect();

Exceptions

Exception Type | Condition
FtpException | Thrown when the disconnect fails.

See Also

FtpClient Class | ComponentSpace.Ftp Namespace


FtpClient.Dispose Method

Dispose of the FtpClient and the underlying socket objects.

[Visual Basic]
NotOverridable Public Sub Dispose() _
Implements IDisposable.Dispose
[C#]
public void Dispose();

Implements

IDisposable.Dispose

See Also

FtpClient Class | ComponentSpace.Ftp Namespace


FtpClient.Download Method

Download the remote file's contents to the local file.

[Visual Basic]
Public Shared Sub Download( _
ByVal serverAddress As String, _
ByVal userName As String, _
ByVal password As String, _
ByVal transferMode As TransferMode, _
ByVal sourcePathName As String, _
ByVal destinationPathName As String _
)
[C#]
public static void Download(
string serverAddress,
string userName,
string password,
TransferMode transferMode,
string sourcePathName,
string destinationPathName
);

Parameters

serverAddress
The server address (eg. 207.46.133.140 or ftp.microsoft.com).
userName
The FTP user name eg. anonymous.
password
The FTP password eg. your email address.
transferMode
The transfer mode - ASCII or binary.
sourcePathName
The remote file path name.
destinationPathName
The local file path name.

Exceptions

Exception Type | Condition
FtpException | Thrown when the download fails.

See Also

FtpClient Class | ComponentSpace.Ftp Namespace


FtpClient.EndAbort Method

Completes the specified asynchronous abort operation.

[Visual Basic]
Public Sub EndAbort( _
ByVal asyncResult As IAsyncResult _
)
[C#]
public void EndAbort(
IAsyncResult asyncResult
);

Parameters

asyncResult
The IAsyncResult that identifies the asynchronous abort to finish, and from which to retrieve an end result.

Remarks

When the AbortCompleted event is raised, EndAbort completes the operation that was initiated by the BeginAbort call.

Exceptions

Exception Type | Condition
FtpException | Thrown when the abort fails.

See Also

FtpClient Class | ComponentSpace.Ftp Namespace


FtpClient.EndConnect Method

Completes the specified asynchronous connect operation.

[Visual Basic]
Public Sub EndConnect( _
ByVal asyncResult As IAsyncResult _
)
[C#]
public void EndConnect(
IAsyncResult asyncResult
);

Parameters

asyncResult
The IAsyncResult that identifies the asynchronous connect to finish, and from which to retrieve an end result.

Remarks

When the ConnectCompleted event is raised, EndConnect completes the operation that was initiated by the BeginConnect call.

Exceptions

Exception Type | Condition
FtpException | Thrown when the connect fails.

See Also

FtpClient Class | ComponentSpace.Ftp Namespace


FtpClient.EndGetRemoteStatus Method

Completes the specified asynchronous get remote status operation.

[Visual Basic]
Public Function EndGetRemoteStatus( _
ByVal asyncResult As IAsyncResult _
) As String
[C#]
public string EndGetRemoteStatus(
IAsyncResult asyncResult
);

Parameters

asyncResult
The IAsyncResult that identifies the asynchronous get remote status to finish, and from which to retrieve an end result.

Return Value

The remote system's OS information

Remarks

When the GetRemoteStatusCompleted event is raised, EndGetRemoteStatus completes the operation that was initiated by the BeginGetRemoteStatus call.

Exceptions

Exception Type | Condition
FtpException | Thrown when the get remote status fails.

See Also

FtpClient Class | ComponentSpace.Ftp Namespace


FtpClient.EndGetRemoteSystemInfo Method

Completes the specified asynchronous get remote system information operation.

[Visual Basic]
Public Function EndGetRemoteSystemInfo( _
ByVal asyncResult As IAsyncResult _
) As String
[C#]
public string EndGetRemoteSystemInfo(
IAsyncResult asyncResult
);

Parameters

asyncResult
The IAsyncResult that identifies the asynchronous get remote system information to finish, and from which to retrieve an end result.

Return Value

The remote system's OS information

Remarks

When the GetRemoteSystemInfoCompleted event is raised, EndGetRemoteSystemInfo completes the operation that was initiated by the BeginGetRemoteSystemInfo call.

Exceptions

Exception Type | Condition
FtpException | Thrown when the get remote system information fails.

See Also

FtpClient Class | ComponentSpace.Ftp Namespace


FtpClient.EndSendQuoteCommand Method

Completes the specified asynchronous quote command operation.

[Visual Basic]
Public Function EndSendQuoteCommand( _
ByVal asyncResult As IAsyncResult _
) As String
[C#]
public string EndSendQuoteCommand(
IAsyncResult asyncResult
);

Parameters

asyncResult
The IAsyncResult that identifies the asynchronous quote to finish, and from which to retrieve an end result.

Return Value

The command reply text.

Remarks

When the QuoteCommandCompleted event is raised, EndSendQuoteCommand completes the operation that was initiated by the BeginSendQuoteCommand call.

Exceptions

Exception Type | Condition
FtpException | Thrown when the quote fails.

See Also

FtpClient Class | ComponentSpace.Ftp Namespace


FtpClient.EndSendSiteCommand Method

Completes the specified asynchronous site command operation.

[Visual Basic]
Public Function EndSendSiteCommand( _
ByVal asyncResult As IAsyncResult _
) As String
[C#]
public string EndSendSiteCommand(
IAsyncResult asyncResult
);

Parameters

asyncResult
The IAsyncResult that identifies the asynchronous site to finish, and from which to retrieve an end result.

Return Value

The site command reply.

Remarks

When the SiteCommandCompleted event is raised, EndSendSiteCommand completes the operation that was initiated by the BeginSendSiteCommand call.

Exceptions

Exception Type | Condition
FtpException | Thrown when the site fails.

See Also

FtpClient Class | ComponentSpace.Ftp Namespace


FtpClient.GetRemoteStatus Method

Get the remote system's status.

[Visual Basic]
Public Function GetRemoteStatus() As String
[C#]
public string GetRemoteStatus();

Return Value

The remote system's status

Exceptions

Exception Type | Condition
FtpException | Thrown when the operation fails.

See Also

FtpClient Class | ComponentSpace.Ftp Namespace


FtpClient.GetRemoteSystemInfo Method

Get the remote system's OS information.

[Visual Basic]
Public Function GetRemoteSystemInfo() As String
[C#]
public string GetRemoteSystemInfo();

Return Value

The remote system's OS information

Exceptions

Exception Type | Condition
FtpException | Thrown when the operation fails.

See Also

FtpClient Class | ComponentSpace.Ftp Namespace


FtpClient.SendQuoteCommand Method

Execute an arbitrary command. The supplied command text is sent to the FTP server as is.

[Visual Basic]
Public Function SendQuoteCommand( _
ByVal command As String _
) As String
[C#]
public string SendQuoteCommand(
string command
);

Parameters

command
The arbitrary command text.

Return Value

The command reply text.

Exceptions

Exception Type | Condition
FtpException | Thrown when the operation fails.

See Also

FtpClient Class | ComponentSpace.Ftp Namespace


FtpClient.SendSiteCommand Method

Execute the site command.

[Visual Basic]
Public Function SendSiteCommand( _
ByVal arguments As String _
) As String
[C#]
public string SendSiteCommand(
string arguments
);

Parameters

arguments
The site command arguments.

Return Value

The site command reply.

Exceptions

Exception Type | Condition
FtpException | Thrown when the operation fails.

See Also

FtpClient Class | ComponentSpace.Ftp Namespace


FtpClient.Upload Method

Upload the local file's contents to the remote file. If destinationPathName is null then a unique name is generated on the remote server.

[Visual Basic]
Public Shared Sub Upload( _
ByVal serverAddress As String, _
ByVal userName As String, _
ByVal password As String, _
ByVal transferMode As TransferMode, _
ByVal sourcePathName As String, _
ByVal destinationPathName As String _
)
[C#]
public static void Upload(
string serverAddress,
string userName,
string password,
TransferMode transferMode,
string sourcePathName,
string destinationPathName
);

Parameters

serverAddress
The server address (eg. 207.46.133.140 or ftp.microsoft.com).
userName
The FTP user name eg. anonymous.
password
The FTP password eg. your email address.
transferMode
The transfer mode - ASCII or binary.
sourcePathName
The local file name.
destinationPathName
The remote file name or null.

Exceptions

Exception Type | Condition
FtpException | Thrown when the upload fails.

See Also

FtpClient Class | ComponentSpace.Ftp Namespace


FtpClient Events

The events of the FtpClient class are listed below. For a complete list of FtpClient class members, see the FtpClient Members topic.

Public Instance Events

AbortCompleted | Occurs when the abort has completed.
CommandTraced | Occurs when a command is being sent or a command reply has been received. This event may be used to trace commands and replies.
ConnectCompleted | Occurs when the connect has completed.
GetRemoteStatusCompleted | Occurs when the get remote status has completed.
GetRemoteSystemInfoCompleted | Occurs when the get remote system info has completed.
QuoteCommandCompleted | Occurs when the quote command has completed.
SiteCommandCompleted | Occurs when the site command has completed.

See Also

FtpClient Class | ComponentSpace.Ftp Namespace


FtpClient.AbortCompleted Event

Occurs when the abort has completed.

[Visual Basic]
Public Event AbortCompleted As FtpOperationCompletedEventHandler
[C#]
public event FtpOperationCompletedEventHandler AbortCompleted;

Event Data

The event handler receives an argument of type FtpOperationCompletedEventArgs containing data related to this event. The following FtpOperationCompletedEventArgs property provides information specific to this event.

Property | Description
AsyncResult | Gets the result of the asynchronous send operation.

Remarks

BeginAbort is used in asynchronous processing to raise the AbortCompleted event when the abort has completed.

EndAbort is used to complete the operation initiated by a call to BeginAbort and get the abort status when the AbortCompleted event is raised.

See Also

FtpClient Class | ComponentSpace.Ftp Namespace


FtpClient.CommandTraced Event

Occurs when a command is being sent or a command reply has been received. This event may be used to trace commands and replies.

[Visual Basic]
Public Event CommandTraced As CommandTracedEventHandler
[C#]
public event CommandTracedEventHandler CommandTraced;

Event Data

The event handler receives an argument of type CommandTracedEventArgs containing data related to this event. The following CommandTracedEventArgs properties provide information specific to this event.

Property | Description
CommandTraceEntryType | Gets the command trace entry type.
TraceText | Gets the trace text.

See Also

FtpClient Class | ComponentSpace.Ftp Namespace


FtpClient.ConnectCompleted Event

Occurs when the connect has completed.

[Visual Basic]
Public Event ConnectCompleted As FtpOperationCompletedEventHandler
[C#]
public event FtpOperationCompletedEventHandler ConnectCompleted;

Event Data

The event handler receives an argument of type FtpOperationCompletedEventArgs containing data related to this event. The following FtpOperationCompletedEventArgs property provides information specific to this event.

Property | Description
AsyncResult | Gets the result of the asynchronous send operation.

Remarks

BeginConnect is used in asynchronous processing to raise the ConnectCompleted event when the connect has completed.

EndConnect is used to complete the operation initiated by a call to BeginConnect and get the connect status when the ConnectCompleted event is raised.

See Also

FtpClient Class | ComponentSpace.Ftp Namespace


FtpClient.GetRemoteStatusCompleted Event

Occurs when the get remote status has completed.

[Visual Basic]
Public Event GetRemoteStatusCompleted As FtpOperationCompletedEventHandler
[C#]
public event FtpOperationCompletedEventHandler GetRemoteStatusCompleted;

Event Data

The event handler receives an argument of type FtpOperationCompletedEventArgs containing data related to this event. The following FtpOperationCompletedEventArgs property provides information specific to this event.

Property | Description
AsyncResult | Gets the result of the asynchronous send operation.

Remarks

BeginGetRemoteStatus is used in asynchronous processing to raise the GetRemoteStatusCompleted event when the get remote status has completed.

EndGetRemoteStatus is used to complete the operation initiated by a call to BeginGetRemoteStatus and get the get remote status status when the GetRemoteStatusCompleted event is raised.

See Also

FtpClient Class | ComponentSpace.Ftp Namespace


FtpClient.GetRemoteSystemInfoCompleted Event

Occurs when the get remote system info has completed.

[Visual Basic]
Public Event GetRemoteSystemInfoCompleted As FtpOperationCompletedEventHandler
[C#]
public event FtpOperationCompletedEventHandler GetRemoteSystemInfoCompleted;

Event Data

The event handler receives an argument of type FtpOperationCompletedEventArgs containing data related to this event. The following FtpOperationCompletedEventArgs property provides information specific to this event.

Property | Description
AsyncResult | Gets the result of the asynchronous send operation.

Remarks

BeginGetRemoteSystemInfo is used in asynchronous processing to raise the GetRemoteSystemInfoCompleted event when the get remote system info has completed.

EndGetRemoteSystemInfo is used to complete the operation initiated by a call to BeginGetRemoteSystemInfo and get the get remote system info status when the GetRemoteSystemInfoCompleted event is raised.

See Also

FtpClient Class | ComponentSpace.Ftp Namespace


FtpClient.QuoteCommandCompleted Event

Occurs when the quote command has completed.

[Visual Basic]
Public Event QuoteCommandCompleted As FtpOperationCompletedEventHandler
[C#]
public event FtpOperationCompletedEventHandler QuoteCommandCompleted;

Event Data

The event handler receives an argument of type FtpOperationCompletedEventArgs containing data related to this event. The following FtpOperationCompletedEventArgs property provides information specific to this event.

Property | Description
AsyncResult | Gets the result of the asynchronous send operation.

Remarks

BeginSendQuoteCommand is used in asynchronous processing to raise the QuoteCommandCompleted event when the quote command has completed.

EndSendQuoteCommand is used to complete the operation initiated by a call to BeginSendQuoteCommand and get the quote reply when the QuoteCommandCompleted event is raised.

See Also

FtpClient Class | ComponentSpace.Ftp Namespace


FtpClient.SiteCommandCompleted Event

Occurs when the site command has completed.

[Visual Basic]
Public Event SiteCommandCompleted As FtpOperationCompletedEventHandler
[C#]
public event FtpOperationCompletedEventHandler SiteCommandCompleted;

Event Data

The event handler receives an argument of type FtpOperationCompletedEventArgs containing data related to this event. The following FtpOperationCompletedEventArgs property provides information specific to this event.

Property | Description
AsyncResult | Gets the result of the asynchronous send operation.

Remarks

BeginSendSiteCommand is used in asynchronous processing to raise the SiteCommandCompleted event when the site command has completed.

EndSendSiteCommand is used to complete the operation initiated by a call to BeginSendSiteCommand and get the site reply when the SiteCommandCompleted event is raised.

See Also

FtpClient Class | ComponentSpace.Ftp Namespace


FtpClientComponent Class

Wraps the FtpClient as a .NET component to expose the most commonly used properties and events at both design and run time.

For a list of all members of this type, see FtpClientComponent Members.

System.Object
System.MarshalByRefObject
System.ComponentModel.Component
ComponentSpace.Ftp.FtpClientComponent

[Visual Basic]
Public Class FtpClientComponent
Inherits Component
[C#]
public class FtpClientComponent : Component

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

The FTP connection may be established synchronously (blocking) using Connect, or asynchronously (non-blocking) using BeginConnect and EndConnect. All other potentially time consuming operations may either be performed synchronously or asynchronously.

The DataConnectionType property determines whether the data connection is outbound or inbound.

Optionally, the CommandSendTimeout and CommandReceiveTimeout may be set for the command connection.

Optionally, the DataSendTimeout and DataReceiveTimeout may be set for the data connection.

Example

This example connects to an FTP server, performs a download and then disconnects.

Dim ftpClientComponent As New FtpClientComponent()

' These properties can also be set at design time
ftpClientComponent.ServerAddress = "ftp.microsoft.com"
ftpClientComponent.UserName = "anonymous"
ftpClientComponent.Password = "me@mycompany.com"

ftpClientComponent.Connect()

ftpClientComponent.Download("/Services/Museum/pictures/ballmerplunge.jpg", _
                            "c:\temp\ballmerplunge.jpg")

ftpClientComponent.Disconnect()
You can also perform operations asynchronously. This example uses BeginConnect and EndConnect as well as BeginDownload and EndDownload and associated event handlers.
Dim ftpClientComponent As New FtpClientComponent()

' These events handlers can also be added at design time
AddHandler ftpClientComponent.ConnectCompleted, AddressOf OnConnectCompleted
AddHandler ftpClientComponent.DownloadCompleted, AddressOf OnDownloadCompleted

' These properties can also be set at design time
ftpClientComponent.ServerAddress = "ftp.microsoft.com"
ftpClientComponent.UserName = "anonymous"
ftpClientComponent.Password = "me@mycompany.com"

ftpClientComponent.BeginConnect()

Private Sub OnConnectCompleted(ByVal sender As Object, ByVal e As FtpOperationCompletedEventArgs)
    ftpClientComponent.EndConnect(e.AsyncResult)

    ftpClientComponent.BeginDownload("/Services/Museum/pictures/ballmerplunge.jpg", _
                                     "c:\temp\ballmerplunge.jpg")

End Sub

Private Sub OnDownloadCompleted(ByVal sender As Object, ByVal e As FtpOperationCompletedEventArgs)
    ftpClientComponent.EndDownload(e.AsyncResult)
End Sub

Requirements

Namespace: ComponentSpace.Ftp

Assembly: ComponentSpace.Ftp (in ComponentSpace.Ftp.dll)

See Also

FtpClientComponent Members | ComponentSpace.Ftp Namespace


FtpClientComponent Members

FtpClientComponent overview

Public Instance Constructors

FtpClientComponent Constructor Initializes a new instance of the FtpClientComponent class.

Public Instance Properties

CommandReceiveTimeout | Gets or sets the number of milliseconds to wait for the command response from the server.
CommandSendTimeout | Gets or sets the number of milliseconds to wait for the command request to be sent to the server.
Connected | Gets the command connection status.
Container (inherited from Component) | Gets the IContainer that contains the Component.
DataConnectionType | Gets or sets the data connection type.
DataReceiveTimeout | Gets or sets the number of milliseconds to wait for the data response from the server.
DataSendTimeout | Gets or sets the number of milliseconds to wait for the data request to be sent to the server.
FtpClient | Gets the underlying FtpClient object wrapped by this component.
Password | Gets or sets the password. Normally your email address for an anonymous user.
Port | Gets or sets the FTP command port number.
ServerAddress | Gets or sets the FTP server address (eg. 207.46.133.140 or ftp.microsoft.com).
Site (inherited from Component) | Gets or sets the ISite of the Component.
SynchronizingObject | Gets or sets the synchonizing object for receiving events.
TransferMode | Gets or sets the file transfer mode (ASCII or binary).
UserName | Gets or sets the user name. "Anonymous" for an anonymous user.

Public Instance Methods

Abort | Ask the server to abort the current command and any associated data transfer.
BeginAbort | Overloaded. Initiates an asynchronous abort.
BeginConnect | Overloaded. Initiates an asynchronous connect.
BeginDownload | Overloaded. Initiates an asynchronous download remote file.
BeginUpload | Overloaded. Initiates an asynchronous upload remote file.
Connect | Connects to the server.
CreateObjRef (inherited from MarshalByRefObject) | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object.
Disconnect | Disconnects from the server.
Dispose (inherited from Component) | Overloaded. Releases all resources used by the Component.
Download | Overloaded. Download the remote file's contents to the local file.
EndAbort | Completes the specified asynchronous abort operation.
EndConnect | Completes the specified asynchronous connect operation.
EndDownload | Completes the specified asynchronous download remote file operation.
EndUpload | Completes the specified asynchronous upload remote file operation.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetLifetimeService (inherited from MarshalByRefObject) | Retrieves the current lifetime service object that controls the lifetime policy for this instance.
GetType (inherited from Object) | Gets the Type of the current instance.
InitializeLifetimeService (inherited from MarshalByRefObject) | Obtains a lifetime service object to control the lifetime policy for this instance.
ToString (inherited from Component) |
Upload | Overloaded. Upload the local file's contents to the remote file.

Public Instance Events

AbortCompleted | Occurs when the abort has completed.
CommandTraced | Occurs when a command is being sent or a command reply has been received. This event may be used to trace commands and replies.
ConnectCompleted | Occurs when the connect has completed.
DataTransferred | Occurs at intervals to indicate how many bytes in total have been transferred during the current data transfer. This event may be used provide feedback during data transfers.
Disposed (inherited from Component) | Adds an event handler to listen to the Disposed event on the component.
DownloadCompleted | Occurs when the download file has completed.
UploadCompleted | Occurs when the upload file has completed.

Protected Instance Properties

DesignMode (inherited from Component) | Gets a value that indicates whether the Component is currently in design mode.
Events (inherited from Component) | Gets the list of event handlers that are attached to this Component.

Protected Instance Methods

Dispose | Overloaded. Dispose of the FtpClientComponent and the underlying FtpClient object.
Finalize (inherited from Component) | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection.
GetService (inherited from Component) | Returns an object that represents a service provided by the Component or by its Container.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

FtpClientComponent Class | ComponentSpace.Ftp Namespace


FtpClientComponent Constructor

Initializes a new instance of the FtpClientComponent class.

[Visual Basic]
Public Sub New()
[C#]
public FtpClientComponent();

See Also

FtpClientComponent Class | ComponentSpace.Ftp Namespace


FtpClientComponent Properties

The properties of the FtpClientComponent class are listed below. For a complete list of FtpClientComponent class members, see the FtpClientComponent Members topic.

Public Instance Properties

CommandReceiveTimeout | Gets or sets the number of milliseconds to wait for the command response from the server.
CommandSendTimeout | Gets or sets the number of milliseconds to wait for the command request to be sent to the server.
Connected | Gets the command connection status.
Container (inherited from Component) | Gets the IContainer that contains the Component.
DataConnectionType | Gets or sets the data connection type.
DataReceiveTimeout | Gets or sets the number of milliseconds to wait for the data response from the server.
DataSendTimeout | Gets or sets the number of milliseconds to wait for the data request to be sent to the server.
FtpClient | Gets the underlying FtpClient object wrapped by this component.
Password | Gets or sets the password. Normally your email address for an anonymous user.
Port | Gets or sets the FTP command port number.
ServerAddress | Gets or sets the FTP server address (eg. 207.46.133.140 or ftp.microsoft.com).
Site (inherited from Component) | Gets or sets the ISite of the Component.
SynchronizingObject | Gets or sets the synchonizing object for receiving events.
TransferMode | Gets or sets the file transfer mode (ASCII or binary).
UserName | Gets or sets the user name. "Anonymous" for an anonymous user.

Protected Instance Properties

DesignMode (inherited from Component) | Gets a value that indicates whether the Component is currently in design mode.
Events (inherited from Component) | Gets the list of event handlers that are attached to this Component.

See Also

FtpClientComponent Class | ComponentSpace.Ftp Namespace


FtpClientComponent.CommandReceiveTimeout Property

Gets or sets the number of milliseconds to wait for the command response from the server.

[Visual Basic]
Public Property CommandReceiveTimeout As Integer
[C#]
public int CommandReceiveTimeout {get; set;}

Property Value

The number of milliseconds to wait for the command response from the server. The default is 60 seconds.

See Also

FtpClientComponent Class | ComponentSpace.Ftp Namespace


FtpClientComponent.CommandSendTimeout Property

Gets or sets the number of milliseconds to wait for the command request to be sent to the server.

[Visual Basic]
Public Property CommandSendTimeout As Integer
[C#]
public int CommandSendTimeout {get; set;}

Property Value

The number of milliseconds to wait for the command request to be sent to the server. The default is 60 seconds.

See Also

FtpClientComponent Class | ComponentSpace.Ftp Namespace


FtpClientComponent.Connected Property

Gets the command connection status.

[Visual Basic]
Public ReadOnly Property Connected As Boolean
[C#]
public bool Connected {get;}

Property Value

true if connected; false if not connected.

See Also

FtpClientComponent Class | ComponentSpace.Ftp Namespace


FtpClientComponent.DataConnectionType Property

Gets or sets the data connection type.

[Visual Basic]
Public Property DataConnectionType As DataConnectionType
[C#]
public DataConnectionType DataConnectionType {get; set;}

Property Value

The data connection type. The default is Auto.

Remarks

If Inbound, a PORT command is issued and the server connects to the client. If Outbound, a PASV command is issued and the client connects to the server. This is referred to as passive mode. If Auto, an outbound connection is attempted and, if this fails, an inbound connection is then tried. However, if a previous inbound connection was made then an inbound connection is attempted again before trying an outbound connection.

See Also

FtpClientComponent Class | ComponentSpace.Ftp Namespace


FtpClientComponent.DataReceiveTimeout Property

Gets or sets the number of milliseconds to wait for the data response from the server.

[Visual Basic]
Public Property DataReceiveTimeout As Integer
[C#]
public int DataReceiveTimeout {get; set;}

Property Value

The number of milliseconds to wait for the data response from the server. The default is 60 seconds.

See Also

FtpClientComponent Class | ComponentSpace.Ftp Namespace


FtpClientComponent.DataSendTimeout Property

Gets or sets the number of milliseconds to wait for the data request to be sent to the server.

[Visual Basic]
Public Property DataSendTimeout As Integer
[C#]
public int DataSendTimeout {get; set;}

Property Value

The number of milliseconds to wait for the data request to be sent to the server. The default is 60 seconds.

See Also

FtpClientComponent Class | ComponentSpace.Ftp Namespace


FtpClientComponent.FtpClient Property

Gets the underlying FtpClient object wrapped by this component.

[Visual Basic]
Public ReadOnly Property FtpClient As FtpClient
[C#]
public FtpClient FtpClient {get;}

Property Value

The underlying FtpClient object.

See Also

FtpClientComponent Class | ComponentSpace.Ftp Namespace


FtpClientComponent.Password Property

Gets or sets the password. Normally your email address for an anonymous user.

[Visual Basic]
Public Property Password As String
[C#]
public string Password {get; set;}

Property Value

The password.

See Also

FtpClientComponent Class | ComponentSpace.Ftp Namespace


FtpClientComponent.Port Property

Gets or sets the FTP command port number.

[Visual Basic]
Public Property Port As Integer
[C#]
public int Port {get; set;}

Property Value

The FTP command port number. The default is 21.

See Also

FtpClientComponent Class | ComponentSpace.Ftp Namespace


FtpClientComponent.ServerAddress Property

Gets or sets the FTP server address (eg. 207.46.133.140 or ftp.microsoft.com).

[Visual Basic]
Public Property ServerAddress As String
[C#]
public string ServerAddress {get; set;}

Property Value

The FTP server address.

See Also

FtpClientComponent Class | ComponentSpace.Ftp Namespace


FtpClientComponent.SynchronizingObject Property

Gets or sets the synchonizing object for receiving events.

[Visual Basic]
Public Property SynchronizingObject As ISynchronizeInvoke
[C#]
public System.ComponentModel.ISynchronizeInvoke SynchronizingObject {get; set;}

Property Value

An ISynchronizeInvoke, which represents the object that marshals the event-handler call resulting from an event. The default is a null reference (Nothing in Visual Basic).

Remarks

Typically, the SynchronizingObject is set when it's used within a form, because forms are bound to a specific thread.

Typically, the synchronizing object marshals a method call into a single thread.

See Also

FtpClientComponent Class | ComponentSpace.Ftp Namespace


FtpClientComponent.TransferMode Property

Gets or sets the file transfer mode (ASCII or binary).

[Visual Basic]
Public Property TransferMode As TransferMode
[C#]
public TransferMode TransferMode {get; set;}

Property Value

The file transfer mode. The default is ASCII.

See Also

FtpClientComponent Class | ComponentSpace.Ftp Namespace


FtpClientComponent.UserName Property

Gets or sets the user name. "Anonymous" for an anonymous user.

[Visual Basic]
Public Property UserName As String
[C#]
public string UserName {get; set;}

Property Value

The user name.

See Also

FtpClientComponent Class | ComponentSpace.Ftp Namespace


FtpClientComponent Methods

The methods of the FtpClientComponent class are listed below. For a complete list of FtpClientComponent class members, see the FtpClientComponent Members topic.

Public Instance Methods

Abort | Ask the server to abort the current command and any associated data transfer.
BeginAbort | Overloaded. Initiates an asynchronous abort.
BeginConnect | Overloaded. Initiates an asynchronous connect.
BeginDownload | Overloaded. Initiates an asynchronous download remote file.
BeginUpload | Overloaded. Initiates an asynchronous upload remote file.
Connect | Connects to the server.
CreateObjRef (inherited from MarshalByRefObject) | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object.
Disconnect | Disconnects from the server.
Dispose (inherited from Component) | Overloaded. Releases all resources used by the Component.
Download | Overloaded. Download the remote file's contents to the local file.
EndAbort | Completes the specified asynchronous abort operation.
EndConnect | Completes the specified asynchronous connect operation.
EndDownload | Completes the specified asynchronous download remote file operation.
EndUpload | Completes the specified asynchronous upload remote file operation.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetLifetimeService (inherited from MarshalByRefObject) | Retrieves the current lifetime service object that controls the lifetime policy for this instance.
GetType (inherited from Object) | Gets the Type of the current instance.
InitializeLifetimeService (inherited from MarshalByRefObject) | Obtains a lifetime service object to control the lifetime policy for this instance.
ToString (inherited from Component) |
Upload | Overloaded. Upload the local file's contents to the remote file.

Protected Instance Methods

Dispose | Overloaded. Dispose of the FtpClientComponent and the underlying FtpClient object.
Finalize (inherited from Component) | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection.
GetService (inherited from Component) | Returns an object that represents a service provided by the Component or by its Container.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

FtpClientComponent Class | ComponentSpace.Ftp Namespace


FtpClientComponent.Abort Method

Ask the server to abort the current command and any associated data transfer.

[Visual Basic]
Public Sub Abort()
[C#]
public void Abort();

Exceptions

Exception Type | Condition
FtpException | Thrown when the abort fails.

See Also

FtpClientComponent Class | ComponentSpace.Ftp Namespace


BeginAbort Method

ComponentSpace FTP Class Library Reference

FtpClientComponent.BeginAbort Method

Initiates an asynchronous abort.

Overload List

Initiates an asynchronous abort.

public IAsyncResult BeginAbort();

Initiates an asynchronous abort that has a specified state object.

public IAsyncResult BeginAbort(object);

Initiates an asynchronous abort that has a specified state object. This overload receives notification, through a callback, of the identity of the event handler for this operation.

public IAsyncResult BeginAbort(object,AsyncCallback);

See Also

FtpClientComponent Class | ComponentSpace.Ftp Namespace


FtpClientComponent.BeginAbort Method ()

Initiates an asynchronous abort.

[Visual Basic]
Overloads Public Function BeginAbort() As IAsyncResult
[C#]
public IAsyncResult BeginAbort();

Return Value

The IAsyncResult that identifies the posted asynchronous request.

Remarks

In asynchronous processing, you use BeginAbort to raise the AbortCompleted event when the abort has completed. You complete the operation by calling EndAbort.

See Also

FtpClientComponent Class | ComponentSpace.Ftp Namespace | FtpClientComponent.BeginAbort Overload List


FtpClientComponent.BeginAbort Method (Object)

Initiates an asynchronous abort that has a specified state object.

[Visual Basic]
Overloads Public Function BeginAbort( _
ByVal stateObject As Object _
) As IAsyncResult
[C#]
public IAsyncResult BeginAbort(
object stateObject
);

Parameters

stateObject
A state object, specified by the application, that contains information associated with the asynchronous operation.

Return Value

The IAsyncResult that identifies the posted asynchronous request.

Remarks

In asynchronous processing, you use BeginAbort to raise the AbortCompleted event when the abort has completed. You complete the operation by calling EndAbort.

Use this overload to associate information with the operation that will be preserved throughout the operation's lifetime. The event handler can detect this information by looking at the AsyncState of the IAsyncResult that is associated with the operation.

See Also

FtpClientComponent Class | ComponentSpace.Ftp Namespace | FtpClientComponent.BeginAbort Overload List


FtpClientComponent.BeginAbort Method (Object, AsyncCallback)

Initiates an asynchronous abort that has a specified state object. This overload receives notification, through a callback, of the identity of the event handler for this operation.

[Visual Basic]
Overloads Public Function BeginAbort( _
ByVal stateObject As Object, _
ByVal asyncCallback As AsyncCallback _
) As IAsyncResult
[C#]
public IAsyncResult BeginAbort(
object stateObject,
AsyncCallback asyncCallback
);

Parameters

stateObject
A state object, specified by the application, that contains information associated with the asynchronous operation.
asyncCallback
The AsyncCallback that will receive the notification of the asynchronous operation completion.

Return Value

The IAsyncResult that identifies the posted asynchronous request.

Remarks

When you use this overload, the callback specified in the callback parameter is invoked directly when the abort has completed; the AbortCompleted event is not raised. The other overloads of BeginAbort rely on this component to raise the AbortCompleted event.

See Also

FtpClientComponent Class | ComponentSpace.Ftp Namespace | FtpClientComponent.BeginAbort Overload List


BeginConnect Method

ComponentSpace FTP Class Library Reference

FtpClientComponent.BeginConnect Method

Initiates an asynchronous connect.

Overload List

Initiates an asynchronous connect.

public IAsyncResult BeginConnect();

Initiates an asynchronous connect using the specified state object.

public IAsyncResult BeginConnect(object);

Initiates an asynchronous connect using the specified state object. This overload receives notification, through a callback, of the identity of the event handler for this operation.

public IAsyncResult BeginConnect(object,AsyncCallback);

See Also

FtpClientComponent Class | ComponentSpace.Ftp Namespace


FtpClientComponent.BeginConnect Method ()

Initiates an asynchronous connect.

[Visual Basic]
Overloads Public Function BeginConnect() As IAsyncResult
[C#]
public IAsyncResult BeginConnect();

Return Value

The IAsyncResult that identifies the posted asynchronous request.

Remarks

In asynchronous processing, you use BeginConnect to raise the ConnectCompleted event when the connect has completed. You complete the operation by calling EndConnect.

See Also

FtpClientComponent Class | ComponentSpace.Ftp Namespace | FtpClientComponent.BeginConnect Overload List


FtpClientComponent.BeginConnect Method (Object)

Initiates an asynchronous connect using the specified state object.

[Visual Basic]
Overloads Public Function BeginConnect( _
ByVal stateObject As Object _
) As IAsyncResult
[C#]
public IAsyncResult BeginConnect(
object stateObject
);

Parameters

stateObject
A state object, specified by the application, that contains information associated with the asynchronous operation.

Return Value

The IAsyncResult that identifies the posted asynchronous request.

Remarks

In asynchronous processing, you use BeginConnect to raise the ConnectCompleted event when the connect has completed. You complete the operation by calling EndConnect.

Use this overload to associate information with the operation that will be preserved throughout the operation's lifetime. The event handler can detect this information by looking at the AsyncState of the IAsyncResult that is associated with the operation.

See Also

FtpClientComponent Class | ComponentSpace.Ftp Namespace | FtpClientComponent.BeginConnect Overload List


FtpClientComponent.BeginConnect Method (Object, AsyncCallback)

Initiates an asynchronous connect using the specified state object. This overload receives notification, through a callback, of the identity of the event handler for this operation.

[Visual Basic]
Overloads Public Function BeginConnect( _
ByVal stateObject As Object, _
ByVal asyncCallback As AsyncCallback _
) As IAsyncResult
[C#]
public IAsyncResult BeginConnect(
object stateObject,
AsyncCallback asyncCallback
);

Parameters

stateObject
A state object, specified by the application, that contains information associated with the asynchronous operation.
asyncCallback
The AsyncCallback that will receive the notification of the asynchronous operation completion.

Return Value

The IAsyncResult that identifies the posted asynchronous request.

Remarks

When you use this overload, the callback specified in the callback parameter is invoked directly when the connect has completed; the ConnectCompleted event is not raised. The other overloads of BeginConnect rely on this component to raise the ConnectCompleted event.

See Also

FtpClientComponent Class | ComponentSpace.Ftp Namespace | FtpClientComponent.BeginConnect Overload List


BeginDownload Method

ComponentSpace FTP Class Library Reference

FtpClientComponent.BeginDownload Method

Initiates an asynchronous download remote file.

Overload List

Initiates an asynchronous download remote file.

public IAsyncResult BeginDownload(string,Stream);

Initiates an asynchronous download remote file that has a specified state object.

public IAsyncResult BeginDownload(string,Stream,object);

Initiates an asynchronous download remote file that has a specified state object. This overload receives notification, through a callback, of the identity of the event handler for this operation.

public IAsyncResult BeginDownload(string,Stream,object,AsyncCallback);

Initiates an asynchronous download remote file.

public IAsyncResult BeginDownload(string,string);

Initiates an asynchronous download remote file that has a specified state object.

public IAsyncResult BeginDownload(string,string,object);

Initiates an asynchronous download remote file that has a specified state object. This overload receives notification, through a callback, of the identity of the event handler for this operation.

public IAsyncResult BeginDownload(string,string,object,AsyncCallback);

See Also

FtpClientComponent Class | ComponentSpace.Ftp Namespace


FtpClientComponent.BeginDownload Method (String, Stream)

Initiates an asynchronous download remote file.

[Visual Basic]
Overloads Public Function BeginDownload( _
ByVal sourcePathName As String, _
ByVal destinationData As Stream _
) As IAsyncResult
[C#]
public IAsyncResult BeginDownload(
string sourcePathName,
Stream destinationData
);

Parameters

sourcePathName
The remote file path name.
destinationData
The destination data stream.

Return Value

The IAsyncResult that identifies the posted asynchronous request.

Remarks

In asynchronous processing, you use BeginDownload to raise the DownloadCompleted event when the download has completed. You complete the operation by calling EndDownload.

See Also

FtpClientComponent Class | ComponentSpace.Ftp Namespace | FtpClientComponent.BeginDownload Overload List


FtpClientComponent.BeginDownload Method (String, Stream, Object)

Initiates an asynchronous download remote file that has a specified state object.

[Visual Basic]
Overloads Public Function BeginDownload( _
ByVal sourcePathName As String, _
ByVal destinationData As Stream, _
ByVal stateObject As Object _
) As IAsyncResult
[C#]
public IAsyncResult BeginDownload(
string sourcePathName,
Stream destinationData,
object stateObject
);

Parameters

sourcePathName
The remote file path name.
destinationData
The destination data stream.
stateObject
A state object, specified by the application, that contains information associated with the asynchronous operation.

Return Value

The IAsyncResult that identifies the posted asynchronous request.

Remarks

In asynchronous processing, you use BeginDownload to raise the DownloadCompleted event when the download has completed. You complete the operation by calling EndDownload.

Use this overload to associate information with the operation that will be preserved throughout the operation's lifetime. The event handler can detect this information by looking at the AsyncState of the IAsyncResult that is associated with the operation.

See Also

FtpClientComponent Class | ComponentSpace.Ftp Namespace | FtpClientComponent.BeginDownload Overload List


FtpClientComponent.BeginDownload Method (String, Stream, Object, AsyncCallback)

Initiates an asynchronous download remote file that has a specified state object. This overload receives notification, through a callback, of the identity of the event handler for this operation.

[Visual Basic]
Overloads Public Function BeginDownload( _
ByVal sourcePathName As String, _
ByVal destinationData As Stream, _
ByVal stateObject As Object, _
ByVal asyncCallback As AsyncCallback _
) As IAsyncResult
[C#]
public IAsyncResult BeginDownload(
string sourcePathName,
Stream destinationData,
object stateObject,
AsyncCallback asyncCallback
);

Parameters

sourcePathName
The remote file path name.
destinationData
The destination data stream.
stateObject
A state object, specified by the application, that contains information associated with the asynchronous operation.
asyncCallback
The AsyncCallback that will receive the notification of the asynchronous operation completion.

Return Value

The IAsyncResult that identifies the posted asynchronous request.

Remarks

When you use this overload, the callback specified in the callback parameter is invoked directly when the download has completed; the DownloadCompleted event is not raised. The other overloads of BeginDownload rely on this component to raise the DownloadCompleted event.

See Also

FtpClientComponent Class | ComponentSpace.Ftp Namespace | FtpClientComponent.BeginDownload Overload List


FtpClientComponent.BeginDownload Method (String, String)

Initiates an asynchronous download remote file.

[Visual Basic]
Overloads Public Function BeginDownload( _
ByVal sourcePathName As String, _
ByVal destinationPathName As String _
) As IAsyncResult
[C#]
public IAsyncResult BeginDownload(
string sourcePathName,
string destinationPathName
);

Parameters

sourcePathName
The remote file path name.
destinationPathName
The local file path name.

Return Value

The IAsyncResult that identifies the posted asynchronous request.

Remarks

In asynchronous processing, you use BeginDownload to raise the DownloadCompleted event when the download has completed. You complete the operation by calling EndDownload.

See Also

FtpClientComponent Class | ComponentSpace.Ftp Namespace | FtpClientComponent.BeginDownload Overload List


FtpClientComponent.BeginDownload Method (String, String, Object)

Initiates an asynchronous download remote file that has a specified state object.

[Visual Basic]
Overloads Public Function BeginDownload( _
ByVal sourcePathName As String, _
ByVal destinationPathName As String, _
ByVal stateObject As Object _
) As IAsyncResult
[C#]
public IAsyncResult BeginDownload(
string sourcePathName,
string destinationPathName,
object stateObject
);

Parameters

sourcePathName
The remote file path name.
destinationPathName
The local file path name.
stateObject
A state object, specified by the application, that contains information associated with the asynchronous operation.

Return Value

The IAsyncResult that identifies the posted asynchronous request.

Remarks

In asynchronous processing, you use BeginDownload to raise the DownloadCompleted event when the download has completed. You complete the operation by calling EndDownload.

Use this overload to associate information with the operation that will be preserved throughout the operation's lifetime. The event handler can detect this information by looking at the AsyncState of the IAsyncResult that is associated with the operation.

See Also

FtpClientComponent Class | ComponentSpace.Ftp Namespace | FtpClientComponent.BeginDownload Overload List


FtpClientComponent.BeginDownload Method (String, String, Object, AsyncCallback)

Initiates an asynchronous download remote file that has a specified state object. This overload receives notification, through a callback, of the identity of the event handler for this operation.

[Visual Basic]
Overloads Public Function BeginDownload( _
ByVal sourcePathName As String, _
ByVal destinationPathName As String, _
ByVal stateObject As Object, _
ByVal asyncCallback As AsyncCallback _
) As IAsyncResult
[C#]
public IAsyncResult BeginDownload(
string sourcePathName,
string destinationPathName,
object stateObject,
AsyncCallback asyncCallback
);

Parameters

sourcePathName
The remote file path name.
destinationPathName
The local file path name.
stateObject
A state object, specified by the application, that contains information associated with the asynchronous operation.
asyncCallback
The AsyncCallback that will receive the notification of the asynchronous operation completion.

Return Value

The IAsyncResult that identifies the posted asynchronous request.

Remarks

When you use this overload, the callback specified in the callback parameter is invoked directly when the download has completed; the DownloadCompleted event is not raised. The other overloads of BeginDownload rely on this component to raise the DownloadCompleted event.

See Also

FtpClientComponent Class | ComponentSpace.Ftp Namespace | FtpClientComponent.BeginDownload Overload List


BeginUpload Method

ComponentSpace FTP Class Library Reference

FtpClientComponent.BeginUpload Method

Initiates an asynchronous upload remote file.

Overload List

Initiates an asynchronous upload remote file.

public IAsyncResult BeginUpload(Stream,string);

Initiates an asynchronous upload remote file that has a specified state object.

public IAsyncResult BeginUpload(Stream,string,object);

Initiates an asynchronous upload remote file that has a specified state object. This overload receives notification, through a callback, of the identity of the event handler for this operation.

public IAsyncResult BeginUpload(Stream,string,object,AsyncCallback);

Initiates an asynchronous upload remote file.

public IAsyncResult BeginUpload(string,string);

Initiates an asynchronous upload remote file that has a specified state object.

public IAsyncResult BeginUpload(string,string,object);

Initiates an asynchronous upload remote file that has a specified state object. This overload receives notification, through a callback, of the identity of the event handler for this operation.

public IAsyncResult BeginUpload(string,string,object,AsyncCallback);

See Also

FtpClientComponent Class | ComponentSpace.Ftp Namespace


FtpClientComponent.BeginUpload Method (Stream, String)

Initiates an asynchronous upload remote file.

[Visual Basic]
Overloads Public Function BeginUpload( _
ByVal sourceData As Stream, _
ByVal destinationPathName As String _
) As IAsyncResult
[C#]
public IAsyncResult BeginUpload(
Stream sourceData,
string destinationPathName
);

Parameters

sourceData
The source data stream.
destinationPathName
The remote file name.

Return Value

The IAsyncResult that identifies the posted asynchronous request.

Remarks

In asynchronous processing, you use BeginUpload to raise the UploadCompleted event when the upload has completed. You complete the operation by calling EndUpload.

See Also

FtpClientComponent Class | ComponentSpace.Ftp Namespace | FtpClientComponent.BeginUpload Overload List


FtpClientComponent.BeginUpload Method (Stream, String, Object)

Initiates an asynchronous upload remote file that has a specified state object.

[Visual Basic]
Overloads Public Function BeginUpload( _
ByVal sourceData As Stream, _
ByVal destinationPathName As String, _
ByVal stateObject As Object _
) As IAsyncResult
[C#]
public IAsyncResult BeginUpload(
Stream sourceData,
string destinationPathName,
object stateObject
);

Parameters

sourceData
The source data stream.
destinationPathName
The remote file name.
stateObject
A state object, specified by the application, that contains information associated with the asynchronous operation.

Return Value

The IAsyncResult that identifies the posted asynchronous request.

Remarks

In asynchronous processing, you use BeginUpload to raise the UploadCompleted event when the upload has completed. You complete the operation by calling EndUpload.

Use this overload to associate information with the operation that will be preserved throughout the operation's lifetime. The event handler can detect this information by looking at the AsyncState of the IAsyncResult that is associated with the operation.

See Also

FtpClientComponent Class | ComponentSpace.Ftp Namespace | FtpClientComponent.BeginUpload Overload List


FtpClientComponent.BeginUpload Method (Stream, String, Object, AsyncCallback)

Initiates an asynchronous upload remote file that has a specified state object. This overload receives notification, through a callback, of the identity of the event handler for this operation.

[Visual Basic]
Overloads Public Function BeginUpload( _
ByVal sourceData As Stream, _
ByVal destinationPathName As String, _
ByVal stateObject As Object, _
ByVal asyncCallback As AsyncCallback _
) As IAsyncResult
[C#]
public IAsyncResult BeginUpload(
Stream sourceData,
string destinationPathName,
object stateObject,
AsyncCallback asyncCallback
);

Parameters

sourceData
The source data stream.
destinationPathName
The remote file name.
stateObject
A state object, specified by the application, that contains information associated with the asynchronous operation.
asyncCallback
The AsyncCallback that will receive the notification of the asynchronous operation completion.

Return Value

The IAsyncResult that identifies the posted asynchronous request.

Remarks

When you use this overload, the callback specified in the callback parameter is invoked directly when the upload has completed; the UploadCompleted event is not raised. The other overloads of BeginUpload rely on this component to raise the UploadCompleted event.

See Also

FtpClientComponent Class | ComponentSpace.Ftp Namespace | FtpClientComponent.BeginUpload Overload List


FtpClientComponent.BeginUpload Method (String, String)

Initiates an asynchronous upload remote file.

[Visual Basic]
Overloads Public Function BeginUpload( _
ByVal sourcePathName As String, _
ByVal destinationPathName As String _
) As IAsyncResult
[C#]
public IAsyncResult BeginUpload(
string sourcePathName,
string destinationPathName
);

Parameters

sourcePathName
The local file name.
destinationPathName
The remote file name or null.

Return Value

The IAsyncResult that identifies the posted asynchronous request.

Remarks

In asynchronous processing, you use BeginUpload to raise the UploadCompleted event when the upload has completed. You complete the operation by calling EndUpload.

See Also

FtpClientComponent Class | ComponentSpace.Ftp Namespace | FtpClientComponent.BeginUpload Overload List


FtpClientComponent.BeginUpload Method (String, String, Object)

Initiates an asynchronous upload remote file that has a specified state object.

[Visual Basic]
Overloads Public Function BeginUpload( _
ByVal sourcePathName As String, _
ByVal destinationPathName As String, _
ByVal stateObject As Object _
) As IAsyncResult
[C#]
public IAsyncResult BeginUpload(
string sourcePathName,
string destinationPathName,
object stateObject
);

Parameters

sourcePathName
The local file name.
destinationPathName
The remote file name.
stateObject
A state object, specified by the application, that contains information associated with the asynchronous operation.

Return Value

The IAsyncResult that identifies the posted asynchronous request.

Remarks

In asynchronous processing, you use BeginUpload to raise the UploadCompleted event when the upload has completed. You complete the operation by calling EndUpload.

Use this overload to associate information with the operation that will be preserved throughout the operation's lifetime. The event handler can detect this information by looking at the AsyncState of the IAsyncResult that is associated with the operation.

See Also

FtpClientComponent Class | ComponentSpace.Ftp Namespace | FtpClientComponent.BeginUpload Overload List


FtpClientComponent.BeginUpload Method (String, String, Object, AsyncCallback)

Initiates an asynchronous upload remote file that has a specified state object. This overload receives notification, through a callback, of the identity of the event handler for this operation.

[Visual Basic]
Overloads Public Function BeginUpload( _
ByVal sourcePathName As String, _
ByVal destinationPathName As String, _
ByVal stateObject As Object, _
ByVal asyncCallback As AsyncCallback _
) As IAsyncResult
[C#]
public IAsyncResult BeginUpload(
string sourcePathName,
string destinationPathName,
object stateObject,
AsyncCallback asyncCallback
);

Parameters

sourcePathName
The local file name.
destinationPathName
The remote file name.
stateObject
A state object, specified by the application, that contains information associated with the asynchronous operation.
asyncCallback
The AsyncCallback that will receive the notification of the asynchronous operation completion.

Return Value

The IAsyncResult that identifies the posted asynchronous request.

Remarks

When you use this overload, the callback specified in the callback parameter is invoked directly when the upload has completed; the UploadCompleted event is not raised. The other overloads of BeginUpload rely on this component to raise the UploadCompleted event.

See Also

FtpClientComponent Class | ComponentSpace.Ftp Namespace | FtpClientComponent.BeginUpload Overload List


FtpClientComponent.Connect Method

Connects to the server.

[Visual Basic]
Public Sub Connect()
[C#]
public void Connect();

Exceptions

Exception Type | Condition
FtpException | Thrown when the connect fails.

See Also

FtpClientComponent Class | ComponentSpace.Ftp Namespace


FtpClientComponent.Disconnect Method

Disconnects from the server.

[Visual Basic]
Public Sub Disconnect()
[C#]
public void Disconnect();

Exceptions

Exception Type | Condition
FtpException | Thrown when the disconnect fails.

See Also

FtpClientComponent Class | ComponentSpace.Ftp Namespace


Dispose Method

ComponentSpace FTP Class Library Reference

FtpClientComponent.Dispose Method

Dispose of the FtpClientComponent and the underlying FtpClient object.

Overload List

Inherited from Component.

public void Dispose();

Dispose of the FtpClientComponent and the underlying FtpClient object.

protected override void Dispose(bool);

See Also

FtpClientComponent Class | ComponentSpace.Ftp Namespace


FtpClientComponent.Dispose Method (Boolean)

Dispose of the FtpClientComponent and the underlying FtpClient object.

[Visual Basic]
Overrides Overloads Protected Sub Dispose( _
ByVal disposing As Boolean _
)
[C#]
protected override void Dispose(
bool disposing
);

See Also

FtpClientComponent Class | ComponentSpace.Ftp Namespace | FtpClientComponent.Dispose Overload List


Download Method

ComponentSpace FTP Class Library Reference

FtpClientComponent.Download Method

Download the remote file's contents to the data stream.

Overload List

Download the remote file's contents to the data stream.

public void Download(string,Stream);

Download the remote file's contents to the local file.

public void Download(string,string);

See Also

FtpClientComponent Class | ComponentSpace.Ftp Namespace


FtpClientComponent.Download Method (String, Stream)

Download the remote file's contents to the data stream.

[Visual Basic]
Overloads Public Sub Download( _
ByVal sourcePathName As String, _
ByVal destinationData As Stream _
)
[C#]
public void Download(
string sourcePathName,
Stream destinationData
);

Parameters

sourcePathName
The remote file path name.
destinationData
The destination data stream.

Exceptions

Exception Type | Condition
FtpException | Thrown when the download fails.

See Also

FtpClientComponent Class | ComponentSpace.Ftp Namespace | FtpClientComponent.Download Overload List


FtpClientComponent.Download Method (String, String)

Download the remote file's contents to the local file.

[Visual Basic]
Overloads Public Sub Download( _
ByVal sourcePathName As String, _
ByVal destinationPathName As String _
)
[C#]
public void Download(
string sourcePathName,
string destinationPathName
);

Parameters

sourcePathName
The remote file path name.
destinationPathName
The local file path name.

Exceptions

Exception Type | Condition
FtpException | Thrown when the download fails.

See Also

FtpClientComponent Class | ComponentSpace.Ftp Namespace | FtpClientComponent.Download Overload List


FtpClientComponent.EndAbort Method

Completes the specified asynchronous abort operation.

[Visual Basic]
Public Sub EndAbort( _
ByVal asyncResult As IAsyncResult _
)
[C#]
public void EndAbort(
IAsyncResult asyncResult
);

Parameters

asyncResult
The IAsyncResult that identifies the asynchronous abort to finish, and from which to retrieve an end result.

Remarks

When the AbortCompleted event is raised, EndAbort completes the operation that was initiated by the BeginAbort call.

Exceptions

Exception Type | Condition
FtpException | Thrown when the abort fails.

See Also

FtpClientComponent Class | ComponentSpace.Ftp Namespace


FtpClientComponent.EndConnect Method

Completes the specified asynchronous connect operation.

[Visual Basic]
Public Sub EndConnect( _
ByVal asyncResult As IAsyncResult _
)
[C#]
public void EndConnect(
IAsyncResult asyncResult
);

Parameters

asyncResult
The IAsyncResult that identifies the asynchronous connect to finish, and from which to retrieve an end result.

Remarks

When the ConnectCompleted event is raised, EndConnect completes the operation that was initiated by the BeginConnect call.

Exceptions

Exception Type | Condition
FtpException | Thrown when the connect fails.

See Also

FtpClientComponent Class | ComponentSpace.Ftp Namespace


FtpClientComponent.EndDownload Method

Completes the specified asynchronous download remote file operation.

[Visual Basic]
Public Sub EndDownload( _
ByVal asyncResult As IAsyncResult _
)
[C#]
public void EndDownload(
IAsyncResult asyncResult
);

Parameters

asyncResult
The IAsyncResult that identifies the asynchronous download to finish, and from which to retrieve an end result.

Remarks

When the DownloadCompleted event is raised, EndDownload completes the operation that was initiated by the BeginDownload call.

Exceptions

Exception Type | Condition
FtpException | Thrown when the download fails.

See Also

FtpClientComponent Class | ComponentSpace.Ftp Namespace


FtpClientComponent.EndUpload Method

Completes the specified asynchronous upload remote file operation.

[Visual Basic]
Public Function EndUpload( _
ByVal asyncResult As IAsyncResult _
) As String
[C#]
public string EndUpload(
IAsyncResult asyncResult
);

Parameters

asyncResult
The IAsyncResult that identifies the asynchronous upload to finish, and from which to retrieve an end result.

Return Value

The remote file name.

Remarks

When the UploadCompleted event is raised, EndUpload completes the operation that was initiated by the BeginUpload call.

Exceptions

Exception Type | Condition
FtpException | Thrown when the upload fails.

See Also

FtpClientComponent Class | ComponentSpace.Ftp Namespace


Upload Method

ComponentSpace FTP Class Library Reference

FtpClientComponent.Upload Method

Upload the data stream's contents to the remote file. If destinationPathName is null then a unique name is generated on the remote server.

Overload List

Upload the data stream's contents to the remote file. If destinationPathName is null then a unique name is generated on the remote server.

public string Upload(Stream,string);

Upload the local file's contents to the remote file.

public string Upload(string,string);

See Also

FtpClientComponent Class | ComponentSpace.Ftp Namespace


FtpClientComponent.Upload Method (Stream, String)

Upload the data stream's contents to the remote file. If destinationPathName is null then a unique name is generated on the remote server.

[Visual Basic]
Overloads Public Function Upload( _
ByVal sourceData As Stream, _
ByVal destinationPathName As String _
) As String
[C#]
public string Upload(
Stream sourceData,
string destinationPathName
);

Parameters

sourceData
The source data stream.
destinationPathName
The remote file name or null.

Return Value

The remote file name.

Exceptions

Exception Type | Condition
FtpException | Thrown when the upload fails.

See Also

FtpClientComponent Class | ComponentSpace.Ftp Namespace | FtpClientComponent.Upload Overload List


FtpClientComponent.Upload Method (String, String)

Upload the local file's contents to the remote file.

[Visual Basic]
Overloads Public Function Upload( _
ByVal sourcePathName As String, _
ByVal destinationPathName As String _
) As String
[C#]
public string Upload(
string sourcePathName,
string destinationPathName
);

Parameters

sourcePathName
The local file name.
destinationPathName
The remote file name or null.

Return Value

The remote file name.

Exceptions

Exception Type | Condition
FtpException | Thrown when the upload fails.

See Also

FtpClientComponent Class | ComponentSpace.Ftp Namespace | FtpClientComponent.Upload Overload List


FtpClientComponent Events

The events of the FtpClientComponent class are listed below. For a complete list of FtpClientComponent class members, see the FtpClientComponent Members topic.

Public Instance Events

AbortCompleted | Occurs when the abort has completed.
CommandTraced | Occurs when a command is being sent or a command reply has been received. This event may be used to trace commands and replies.
ConnectCompleted | Occurs when the connect has completed.
DataTransferred | Occurs at intervals to indicate how many bytes in total have been transferred during the current data transfer. This event may be used provide feedback during data transfers.
Disposed (inherited from Component) | Adds an event handler to listen to the Disposed event on the component.
DownloadCompleted | Occurs when the download file has completed.
UploadCompleted | Occurs when the upload file has completed.

See Also

FtpClientComponent Class | ComponentSpace.Ftp Namespace


FtpClientComponent.AbortCompleted Event

Occurs when the abort has completed.

[Visual Basic]
Public Event AbortCompleted As FtpOperationCompletedEventHandler
[C#]
public event FtpOperationCompletedEventHandler AbortCompleted;

Event Data

The event handler receives an argument of type FtpOperationCompletedEventArgs containing data related to this event. The following FtpOperationCompletedEventArgs property provides information specific to this event.

Property | Description
AsyncResult | Gets the result of the asynchronous send operation.

Remarks

BeginAbort is used in asynchronous processing to raise the AbortCompleted event when the abort has completed.

EndAbort is used to complete the operation initiated by a call to BeginAbort and get the abort status when the AbortCompleted event is raised.

See Also

FtpClientComponent Class | ComponentSpace.Ftp Namespace


FtpClientComponent.CommandTraced Event

Occurs when a command is being sent or a command reply has been received. This event may be used to trace commands and replies.

[Visual Basic]
Public Event CommandTraced As CommandTracedEventHandler
[C#]
public event CommandTracedEventHandler CommandTraced;

Event Data

The event handler receives an argument of type CommandTracedEventArgs containing data related to this event. The following CommandTracedEventArgs properties provide information specific to this event.

Property | Description
CommandTraceEntryType | Gets the command trace entry type.
TraceText | Gets the trace text.

See Also

FtpClientComponent Class | ComponentSpace.Ftp Namespace


FtpClientComponent.ConnectCompleted Event

Occurs when the connect has completed.

[Visual Basic]
Public Event ConnectCompleted As FtpOperationCompletedEventHandler
[C#]
public event FtpOperationCompletedEventHandler ConnectCompleted;

Event Data

The event handler receives an argument of type FtpOperationCompletedEventArgs containing data related to this event. The following FtpOperationCompletedEventArgs property provides information specific to this event.

Property | Description
AsyncResult | Gets the result of the asynchronous send operation.

Remarks

BeginConnect is used in asynchronous processing to raise the ConnectCompleted event when the connect has completed.

EndConnect is used to complete the operation initiated by a call to BeginConnect and get the connect status when the ConnectCompleted event is raised.

See Also

FtpClientComponent Class | ComponentSpace.Ftp Namespace


FtpClientComponent.DataTransferred Event

Occurs at intervals to indicate how many bytes in total have been transferred during the current data transfer. This event may be used provide feedback during data transfers.

[Visual Basic]
Public Event DataTransferred As DataTransferredEventHandler
[C#]
public event DataTransferredEventHandler DataTransferred;

Event Data

The event handler receives an argument of type DataTransferredEventArgs containing data related to this event. The following DataTransferredEventArgs property provides information specific to this event.

Property | Description
BytesTransferred | Gets the total number of bytes transferred in the current operation.

See Also

FtpClientComponent Class | ComponentSpace.Ftp Namespace


FtpClientComponent.DownloadCompleted Event

Occurs when the download file has completed.

[Visual Basic]
Public Event DownloadCompleted As FtpOperationCompletedEventHandler
[C#]
public event FtpOperationCompletedEventHandler DownloadCompleted;

Event Data

The event handler receives an argument of type FtpOperationCompletedEventArgs containing data related to this event. The following FtpOperationCompletedEventArgs property provides information specific to this event.

Property | Description
AsyncResult | Gets the result of the asynchronous send operation.

Remarks

BeginDownload is used in asynchronous processing to raise the DownloadCompleted event when the download file has completed.

EndDownload is used to complete the operation initiated by a call to BeginDownload and get the download file status when the DownloadCompleted event is raised.

See Also

FtpClientComponent Class | ComponentSpace.Ftp Namespace


FtpClientComponent.UploadCompleted Event

Occurs when the upload file has completed.

[Visual Basic]
Public Event UploadCompleted As FtpOperationCompletedEventHandler
[C#]
public event FtpOperationCompletedEventHandler UploadCompleted;

Event Data

The event handler receives an argument of type FtpOperationCompletedEventArgs containing data related to this event. The following FtpOperationCompletedEventArgs property provides information specific to this event.

Property | Description
AsyncResult | Gets the result of the asynchronous send operation.

Remarks

BeginUpload is used in asynchronous processing to raise the UploadCompleted event when the upload file has completed.

EndUpload is used to complete the operation initiated by a call to BeginUpload and get the upload file status when the UploadCompleted event is raised.

See Also

FtpClientComponent Class | ComponentSpace.Ftp Namespace


FtpCommand Class

The base class for all FTP commands.

For a list of all members of this type, see FtpCommand Members.

System.Object
ComponentSpace.Ftp.FtpCommand
Derived types

[Visual Basic]
MustInherit Public Class FtpCommand
[C#]
public abstract class FtpCommand

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: ComponentSpace.Ftp

Assembly: ComponentSpace.Ftp (in ComponentSpace.Ftp.dll)

See Also

FtpCommand Members | ComponentSpace.Ftp Namespace


FtpCommand Members

FtpCommand overview

Public Instance Constructors

FtpCommand Constructor Initializes a new instance of the FtpCommand.

Public Instance Properties

CommandType Gets the command type.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString | Convert the command to the FTP command text.
ToTraceString | Convert the reply to the trace text.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

FtpCommand Class | ComponentSpace.Ftp Namespace


FtpCommand Constructor

Initializes a new instance of the FtpCommand.

[Visual Basic]
Public Sub New( _
ByVal commandType As String _
)
[C#]
public FtpCommand(
string commandType
);

Parameters

commandType
The command type eg. USER

See Also

FtpCommand Class | ComponentSpace.Ftp Namespace


FtpCommand Properties

The properties of the FtpCommand class are listed below. For a complete list of FtpCommand class members, see the FtpCommand Members topic.

Public Instance Properties

CommandType Gets the command type.

See Also

FtpCommand Class | ComponentSpace.Ftp Namespace


FtpCommand.CommandType Property

Gets the command type.

[Visual Basic]
Public ReadOnly Property CommandType As String
[C#]
public string CommandType {get;}

Property Value

The mmand type eg. USER.

See Also

FtpCommand Class | ComponentSpace.Ftp Namespace


FtpCommand Methods

The methods of the FtpCommand class are listed below. For a complete list of FtpCommand class members, see the FtpCommand Members topic.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString | Convert the command to the FTP command text.
ToTraceString | Convert the reply to the trace text.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

FtpCommand Class | ComponentSpace.Ftp Namespace


FtpCommand.ToString Method

Convert the command to the FTP command text.

[Visual Basic]
Overrides Public Function ToString() As String
[C#]
public override string ToString();

Return Value

The FTP command text.

See Also

FtpCommand Class | ComponentSpace.Ftp Namespace


FtpCommand.ToTraceString Method

Convert the reply to the trace text.

[Visual Basic]
Overridable Public Function ToTraceString() As String
[C#]
public virtual string ToTraceString();

Return Value

The FTP trace text.

See Also

FtpCommand Class | ComponentSpace.Ftp Namespace


FtpCommandConnection Class

Sends FTP commands and receives FTP replies.

For a list of all members of this type, see FtpCommandConnection Members.

System.Object
ComponentSpace.Ftp.FtpCommandConnection

[Visual Basic]
Public Class FtpCommandConnection
Implements IDisposable
[C#]
public class FtpCommandConnection : IDisposable

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: ComponentSpace.Ftp

Assembly: ComponentSpace.Ftp (in ComponentSpace.Ftp.dll)

See Also

FtpCommandConnection Members | ComponentSpace.Ftp Namespace


FtpCommandConnection Members

FtpCommandConnection overview

Public Instance Constructors

FtpCommandConnection Constructor Initializes a new instance of the FtpCommandConnection class.

Public Instance Properties

Connected | Gets the connection status.
ReceiveTimeout | Gets or sets the number of milliseconds to wait for the response from the server.
SendTimeout | Gets or sets the number of milliseconds to wait for the request to be sent to the server.
SynchronizingObject | Gets or sets the synchonizing object for receiving events.

Public Instance Methods

Connect | Overloaded. Connects to the server's FTP command port. Defaults to port 21.
Disconnect | Disconnects from the server.
Dispose | Dispose of the FtpCommandConnection and the underlying socket object.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
OpenDataConnection | Open either an outbound data connection (PASV command, client connects to server) or an inbound data connection (PORT command, server connects to client). If Auto is specified then an outbound data connection is attempted and, if this fails, an inbound data connection is attempted. If the previous data connection was an inbound connection then an inbound connection is tried again before trying an outbound connection.
OpenInboundDataConnection | Open an inbound data connection (server connects to client).
OpenOutboundDataConnection | Open an outbound data connection (client connects to server).
Receive | Returns an FTP response message from the server.
ReceiveCommandReplyString | Returns an FTP command reply string from the server.
Send | Overloaded. Send an FTP command to the server.
ToString (inherited from Object) | Returns a String that represents the current Object.

Public Instance Events

CommandTraced Occurs when a command is being sent or a command reply has been received. This event may be used to trace commands and replies.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

FtpCommandConnection Class | ComponentSpace.Ftp Namespace


FtpCommandConnection Constructor

Initializes a new instance of the FtpCommandConnection class.

[Visual Basic]
Public Sub New()
[C#]
public FtpCommandConnection();

See Also

FtpCommandConnection Class | ComponentSpace.Ftp Namespace


FtpCommandConnection Properties

The properties of the FtpCommandConnection class are listed below. For a complete list of FtpCommandConnection class members, see the FtpCommandConnection Members topic.

Public Instance Properties

Connected | Gets the connection status.
ReceiveTimeout | Gets or sets the number of milliseconds to wait for the response from the server.
SendTimeout | Gets or sets the number of milliseconds to wait for the request to be sent to the server.
SynchronizingObject | Gets or sets the synchonizing object for receiving events.

See Also

FtpCommandConnection Class | ComponentSpace.Ftp Namespace


FtpCommandConnection.Connected Property

Gets the connection status.

[Visual Basic]
Public ReadOnly Property Connected As Boolean
[C#]
public bool Connected {get;}

Property Value

true if connected; false if not connected.

See Also

FtpCommandConnection Class | ComponentSpace.Ftp Namespace


FtpCommandConnection.ReceiveTimeout Property

Gets or sets the number of milliseconds to wait for the response from the server.

[Visual Basic]
Public Property ReceiveTimeout As Integer
[C#]
public int ReceiveTimeout {get; set;}

Property Value

The number of milliseconds to wait for the response from the server. The default is 10 seconds.

See Also

FtpCommandConnection Class | ComponentSpace.Ftp Namespace


FtpCommandConnection.SendTimeout Property

Gets or sets the number of milliseconds to wait for the request to be sent to the server.

[Visual Basic]
Public Property SendTimeout As Integer
[C#]
public int SendTimeout {get; set;}

Property Value

The number of milliseconds to wait for the request to be sent to the server. The default is 10 seconds.

See Also

FtpCommandConnection Class | ComponentSpace.Ftp Namespace


FtpCommandConnection.SynchronizingObject Property

Gets or sets the synchonizing object for receiving events.

[Visual Basic]
Public Property SynchronizingObject As ISynchronizeInvoke
[C#]
public System.ComponentModel.ISynchronizeInvoke SynchronizingObject {get; set;}

Property Value

An ISynchronizeInvoke, which represents the object that marshals the event-handler call resulting from an event. The default is a null reference (Nothing in Visual Basic).

Remarks

Typically, the SynchronizingObject is set when it's used within a form, because forms are bound to a specific thread.

Typically, the synchronizing object marshals a method call into a single thread.

See Also

FtpCommandConnection Class | ComponentSpace.Ftp Namespace


FtpCommandConnection Methods

The methods of the FtpCommandConnection class are listed below. For a complete list of FtpCommandConnection class members, see the FtpCommandConnection Members topic.

Public Instance Methods

Connect | Overloaded. Connects to the server's FTP command port. Defaults to port 21.
Disconnect | Disconnects from the server.
Dispose | Dispose of the FtpCommandConnection and the underlying socket object.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
OpenDataConnection | Open either an outbound data connection (PASV command, client connects to server) or an inbound data connection (PORT command, server connects to client). If Auto is specified then an outbound data connection is attempted and, if this fails, an inbound data connection is attempted. If the previous data connection was an inbound connection then an inbound connection is tried again before trying an outbound connection.
OpenInboundDataConnection | Open an inbound data connection (server connects to client).
OpenOutboundDataConnection | Open an outbound data connection (client connects to server).
Receive | Returns an FTP response message from the server.
ReceiveCommandReplyString | Returns an FTP command reply string from the server.
Send | Overloaded. Send an FTP command to the server.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

FtpCommandConnection Class | ComponentSpace.Ftp Namespace


Connect Method

ComponentSpace FTP Class Library Reference

FtpCommandConnection.Connect Method

Connects to the server's FTP command port. Defaults to port 21.

Overload List

Connects to the server's FTP command port. Defaults to port 21.

public void Connect(string);

Connects to the server's FTP command port.

public void Connect(string,int);

See Also

FtpCommandConnection Class | ComponentSpace.Ftp Namespace


FtpCommandConnection.Connect Method (String)

Connects to the server's FTP command port. Defaults to port 21.

[Visual Basic]
Overloads Public Sub Connect( _
ByVal serverAddress As String _
)
[C#]
public void Connect(
string serverAddress
);

Parameters

serverAddress
The server address (eg. 207.46.133.140 or ftp.microsoft.com).

Exceptions

Exception Type | Condition
FtpException | Thrown when the connect fails.

See Also

FtpCommandConnection Class | ComponentSpace.Ftp Namespace | FtpCommandConnection.Connect Overload List


FtpCommandConnection.Connect Method (String, Int32)

Connects to the server's FTP command port.

[Visual Basic]
Overloads Public Sub Connect( _
ByVal serverAddress As String, _
ByVal port As Integer _
)
[C#]
public void Connect(
string serverAddress,
int port
);

Parameters

serverAddress
The server address (eg. 207.46.133.140 or ftp.microsoft.com).
port
The FTP command port.

Exceptions

Exception Type | Condition
FtpException | Thrown when the connect fails.

See Also

FtpCommandConnection Class | ComponentSpace.Ftp Namespace | FtpCommandConnection.Connect Overload List


FtpCommandConnection.Disconnect Method

Disconnects from the server.

[Visual Basic]
Public Sub Disconnect()
[C#]
public void Disconnect();

Exceptions

Exception Type | Condition
FtpException | Thrown when the disconnect fails.

See Also

FtpCommandConnection Class | ComponentSpace.Ftp Namespace


FtpCommandConnection.Dispose Method

Dispose of the FtpCommandConnection and the underlying socket object.

[Visual Basic]
NotOverridable Public Sub Dispose() _
Implements IDisposable.Dispose
[C#]
public void Dispose();

Implements

IDisposable.Dispose

See Also

FtpCommandConnection Class | ComponentSpace.Ftp Namespace


FtpCommandConnection.OpenDataConnection Method

Open either an outbound data connection (PASV command, client connects to server) or an inbound data connection (PORT command, server connects to client). If Auto is specified then an outbound data connection is attempted and, if this fails, an inbound data connection is attempted. If the previous data connection was an inbound connection then an inbound connection is tried again before trying an outbound connection.

[Visual Basic]
Public Sub OpenDataConnection( _
ByVal ftpDataConnection As FtpDataConnection, _
ByVal dataConnectionType As DataConnectionType _
)
[C#]
public void OpenDataConnection(
FtpDataConnection ftpDataConnection,
DataConnectionType dataConnectionType
);

Parameters

ftpDataConnection
The FTP data connection to connect.
dataConnectionType
The type of data connection to make.

Remarks

The appropriate FTP command (PASV or PORT) is sent and the connection opened.

See Also

FtpCommandConnection Class | ComponentSpace.Ftp Namespace


FtpCommandConnection.OpenInboundDataConnection Method

Open an inbound data connection (server connects to client).

[Visual Basic]
Public Sub OpenInboundDataConnection( _
ByVal ftpDataConnection As FtpDataConnection _
)
[C#]
public void OpenInboundDataConnection(
FtpDataConnection ftpDataConnection
);

Parameters

ftpDataConnection
The FTP data connection to connect.

Remarks

An FTP port command is sent to the server specifying the data port and the client is ready to receive the connection request from the server.

See Also

FtpCommandConnection Class | ComponentSpace.Ftp Namespace


FtpCommandConnection.OpenOutboundDataConnection Method

Open an outbound data connection (client connects to server).

[Visual Basic]
Public Sub OpenOutboundDataConnection( _
ByVal ftpDataConnection As FtpDataConnection _
)
[C#]
public void OpenOutboundDataConnection(
FtpDataConnection ftpDataConnection
);

Parameters

ftpDataConnection
The FTP data connection to connect.

Remarks

An FTP passive command is sent to the server and a data connection made to the server address and port specified in the passive command reply.

See Also

FtpCommandConnection Class | ComponentSpace.Ftp Namespace


FtpCommandConnection.Receive Method

Returns an FTP response message from the server.

[Visual Basic]
Public Function Receive() As FtpCommandReply
[C#]
public FtpCommandReply Receive();

Return Value

The FTP command reply.

Exceptions

Exception Type | Condition
FtpException | Thrown when the message cannot be received.

See Also

FtpCommandConnection Class | ComponentSpace.Ftp Namespace


FtpCommandConnection.ReceiveCommandReplyString Method

Returns an FTP command reply string from the server.

[Visual Basic]
Public Function ReceiveCommandReplyString() As String
[C#]
public string ReceiveCommandReplyString();

Return Value

The FTP command reply string.

Exceptions

Exception Type | Condition
FtpException | Thrown when the command reply string cannot be received.

See Also

FtpCommandConnection Class | ComponentSpace.Ftp Namespace


Send Method

ComponentSpace FTP Class Library Reference

FtpCommandConnection.Send Method

Send an FTP command to the server.

Overload List

Send an FTP command to the server.

public void Send(FtpCommand);

Send an FTP command to the server.

public void Send(string,string);

See Also

FtpCommandConnection Class | ComponentSpace.Ftp Namespace


FtpCommandConnection.Send Method (FtpCommand)

Send an FTP command to the server.

[Visual Basic]
Overloads Public Sub Send( _
ByVal ftpCommand As FtpCommand _
)
[C#]
public void Send(
FtpCommand ftpCommand
);

Parameters

ftpCommand
The FTP command to send.

Exceptions

Exception Type | Condition
FtpException | Thrown when the message cannot be sent.

See Also

FtpCommandConnection Class | ComponentSpace.Ftp Namespace | FtpCommandConnection.Send Overload List


FtpCommandConnection.Send Method (String, String)

Send an FTP command to the server.

[Visual Basic]
Overloads Public Sub Send( _
ByVal command As String, _
ByVal commandTrace As String _
)
[C#]
public void Send(
string command,
string commandTrace
);

Parameters

command
The FTP command to send.
commandTrace
The trace entry for this command or null.

Exceptions

Exception Type | Condition
FtpException | Thrown when the message cannot be sent.

See Also

FtpCommandConnection Class | ComponentSpace.Ftp Namespace | FtpCommandConnection.Send Overload List


FtpCommandConnection Events

The events of the FtpCommandConnection class are listed below. For a complete list of FtpCommandConnection class members, see the FtpCommandConnection Members topic.

Public Instance Events

CommandTraced Occurs when a command is being sent or a command reply has been received. This event may be used to trace commands and replies.

See Also

FtpCommandConnection Class | ComponentSpace.Ftp Namespace


FtpCommandConnection.CommandTraced Event

Occurs when a command is being sent or a command reply has been received. This event may be used to trace commands and replies.

[Visual Basic]
Public Event CommandTraced As CommandTracedEventHandler
[C#]
public event CommandTracedEventHandler CommandTraced;

Event Data

The event handler receives an argument of type CommandTracedEventArgs containing data related to this event. The following CommandTracedEventArgs properties provide information specific to this event.

Property | Description
CommandTraceEntryType | Gets the command trace entry type.
TraceText | Gets the trace text.

See Also

FtpCommandConnection Class | ComponentSpace.Ftp Namespace


FtpCommandReply Class

Represents an FTP command reply.

For a list of all members of this type, see FtpCommandReply Members.

System.Object
ComponentSpace.Ftp.FtpCommandReply

[Visual Basic]
Public Class FtpCommandReply
[C#]
public class FtpCommandReply

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: ComponentSpace.Ftp

Assembly: ComponentSpace.Ftp (in ComponentSpace.Ftp.dll)

See Also

FtpCommandReply Members | ComponentSpace.Ftp Namespace


FtpCommandReply Members

FtpCommandReply overview

Public Instance Constructors

FtpCommandReply Overloaded. Initializes a new instance of the FtpCommandReply class.

Public Instance Properties

ReplyCode | Gets or sets the reply code.
Text | Gets or sets the reply text.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
IsPermanentNegativeReply | Indicate whether the reply is a permanent negative reply.
IsPositiveCompletionReply | Indicate whether the reply is a positive completion reply.
IsPositiveIntermediateReply | Indicate whether the reply is a positive intermediate reply.
IsPositivePreliminaryReply | Indicate whether the reply is a positive preliminary reply.
IsTransientNegativeReply | Indicate whether the reply is a transient negative reply.
ToString | Convert the reply to the FTP reply text.
ToTraceString | Convert the reply to the trace text.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

FtpCommandReply Class | ComponentSpace.Ftp Namespace


FtpCommandReply Constructor

Initializes a new instance of the FtpCommandReply.

Overload List

Initializes a new instance of the FtpCommandReply.

public FtpCommandReply();

Initializes a new instance of the FtpCommandReply from the raw reply text.

public FtpCommandReply(string);

See Also

FtpCommandReply Class | ComponentSpace.Ftp Namespace


FtpCommandReply Constructor ()

Initializes a new instance of the FtpCommandReply.

[Visual Basic]
Overloads Public Sub New()
[C#]
public FtpCommandReply();

See Also

FtpCommandReply Class | ComponentSpace.Ftp Namespace | FtpCommandReply Constructor Overload List


FtpCommandReply Constructor (String)

Initializes a new instance of the FtpCommandReply from the raw reply text.

[Visual Basic]
Overloads Public Sub New( _
ByVal reply As String _
)
[C#]
public FtpCommandReply(
string reply
);

Parameters

reply
The raw reply text.

See Also

FtpCommandReply Class | ComponentSpace.Ftp Namespace | FtpCommandReply Constructor Overload List


FtpCommandReply Properties

The properties of the FtpCommandReply class are listed below. For a complete list of FtpCommandReply class members, see the FtpCommandReply Members topic.

Public Instance Properties

ReplyCode | Gets or sets the reply code.
Text | Gets or sets the reply text.

See Also

FtpCommandReply Class | ComponentSpace.Ftp Namespace


FtpCommandReply.ReplyCode Property

Gets or sets the reply code.

[Visual Basic]
Public Property ReplyCode As Integer
[C#]
public int ReplyCode {get; set;}

Property Value

The reply code.

See Also

FtpCommandReply Class | ComponentSpace.Ftp Namespace


FtpCommandReply.Text Property

Gets or sets the reply text.

[Visual Basic]
Public Property Text As String
[C#]
public string Text {get; set;}

Property Value

The reply text.

See Also

FtpCommandReply Class | ComponentSpace.Ftp Namespace


FtpCommandReply Methods

The methods of the FtpCommandReply class are listed below. For a complete list of FtpCommandReply class members, see the FtpCommandReply Members topic.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
IsPermanentNegativeReply | Indicate whether the reply is a permanent negative reply.
IsPositiveCompletionReply | Indicate whether the reply is a positive completion reply.
IsPositiveIntermediateReply | Indicate whether the reply is a positive intermediate reply.
IsPositivePreliminaryReply | Indicate whether the reply is a positive preliminary reply.
IsTransientNegativeReply | Indicate whether the reply is a transient negative reply.
ToString | Convert the reply to the FTP reply text.
ToTraceString | Convert the reply to the trace text.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

FtpCommandReply Class | ComponentSpace.Ftp Namespace


FtpCommandReply.IsPermanentNegativeReply Method

Indicate whether the reply is a permanent negative reply.

[Visual Basic]
Public Function IsPermanentNegativeReply() As Boolean
[C#]
public bool IsPermanentNegativeReply();

Return Value

true if the reply is a permanent negative reply; false otherwise.

See Also

FtpCommandReply Class | ComponentSpace.Ftp Namespace


FtpCommandReply.IsPositiveCompletionReply Method

Indicate whether the reply is a positive completion reply.

[Visual Basic]
Public Function IsPositiveCompletionReply() As Boolean
[C#]
public bool IsPositiveCompletionReply();

Return Value

true if the reply is a positive completion reply; false otherwise.

See Also

FtpCommandReply Class | ComponentSpace.Ftp Namespace


FtpCommandReply.IsPositiveIntermediateReply Method

Indicate whether the reply is a positive intermediate reply.

[Visual Basic]
Public Function IsPositiveIntermediateReply() As Boolean
[C#]
public bool IsPositiveIntermediateReply();

Return Value

true if the reply is a positive intermediate reply; false otherwise.

See Also

FtpCommandReply Class | ComponentSpace.Ftp Namespace


FtpCommandReply.IsPositivePreliminaryReply Method

Indicate whether the reply is a positive preliminary reply.

[Visual Basic]
Public Function IsPositivePreliminaryReply() As Boolean
[C#]
public bool IsPositivePreliminaryReply();

Return Value

true if the reply is a positive preliminary reply; false otherwise.

See Also

FtpCommandReply Class | ComponentSpace.Ftp Namespace


FtpCommandReply.IsTransientNegativeReply Method

Indicate whether the reply is a transient negative reply.

[Visual Basic]
Public Function IsTransientNegativeReply() As Boolean
[C#]
public bool IsTransientNegativeReply();

Return Value

true if the reply is a transient negative reply; false otherwise.

See Also

FtpCommandReply Class | ComponentSpace.Ftp Namespace


FtpCommandReply.ToString Method

Convert the reply to the FTP reply text.

[Visual Basic]
Overrides Public Function ToString() As String
[C#]
public override string ToString();

Return Value

The FTP reply text.

See Also

FtpCommandReply Class | ComponentSpace.Ftp Namespace


FtpCommandReply.ToTraceString Method

Convert the reply to the trace text.

[Visual Basic]
Overridable Public Function ToTraceString() As String
[C#]
public virtual string ToTraceString();

Return Value

The FTP trace text.

See Also

FtpCommandReply Class | ComponentSpace.Ftp Namespace


FtpDataConnection Class

Sends and receives FTP data.

For a list of all members of this type, see FtpDataConnection Members.

System.Object
ComponentSpace.Ftp.FtpDataConnection

[Visual Basic]
Public Class FtpDataConnection
Implements IDisposable
[C#]
public class FtpDataConnection : IDisposable

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: ComponentSpace.Ftp

Assembly: ComponentSpace.Ftp (in ComponentSpace.Ftp.dll)

See Also

FtpDataConnection Members | ComponentSpace.Ftp Namespace


FtpDataConnection Members

FtpDataConnection overview

Public Instance Constructors

FtpDataConnection Constructor Initializes a new instance of the FtpDataConnection class.

Public Instance Properties

AcceptRequired | Indicate whether the connection is inbound (ie. initiated by the server) and a socket accept is required.
Connected | Gets the connection status.
ReceiveTimeout | Gets or sets the number of milliseconds to wait for the response from the server.
SendTimeout | Gets or sets the number of milliseconds to wait for the request to be sent to the server.
Stream | Gets the TCP stream.
SynchronizingObject | Gets or sets the synchonizing object for receiving events.

Public Instance Methods

Accept | Accept a server initiated connection. This only applies where a previous call to Listen has been made.
Connect | Connects to the server. The client initiates a connection to the server.
Disconnect | Disconnects from the server.
Dispose | Dispose of the FtpDataConnection and the underlying socket object.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
Listen | Listen for a server connection. A subsequent Accept is required to accept the server initiated connection.
Receive | Receive data from the server.
Send | Send data to the server.
ToString (inherited from Object) | Returns a String that represents the current Object.

Public Instance Events

DataTransferred Occurs at intervals to indicate how many bytes in total have been transferred during the current data transfer. This event may be used provide feedback during data transfers.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

FtpDataConnection Class | ComponentSpace.Ftp Namespace


FtpDataConnection Constructor

Initializes a new instance of the FtpDataConnection class.

[Visual Basic]
Public Sub New()
[C#]
public FtpDataConnection();

See Also

FtpDataConnection Class | ComponentSpace.Ftp Namespace


FtpDataConnection Properties

The properties of the FtpDataConnection class are listed below. For a complete list of FtpDataConnection class members, see the FtpDataConnection Members topic.

Public Instance Properties

AcceptRequired | Indicate whether the connection is inbound (ie. initiated by the server) and a socket accept is required.
Connected | Gets the connection status.
ReceiveTimeout | Gets or sets the number of milliseconds to wait for the response from the server.
SendTimeout | Gets or sets the number of milliseconds to wait for the request to be sent to the server.
Stream | Gets the TCP stream.
SynchronizingObject | Gets or sets the synchonizing object for receiving events.

See Also

FtpDataConnection Class | ComponentSpace.Ftp Namespace


FtpDataConnection.AcceptRequired Property

Indicate whether the connection is inbound (ie. initiated by the server) and a socket accept is required.

[Visual Basic]
Public ReadOnly Property AcceptRequired As Boolean
[C#]
public bool AcceptRequired {get;}

Property Value

true if inbound connection and accept is required; false if outbound connection or inbound connection and accept completed.

See Also

FtpDataConnection Class | ComponentSpace.Ftp Namespace


FtpDataConnection.Connected Property

Gets the connection status.

[Visual Basic]
Public ReadOnly Property Connected As Boolean
[C#]
public bool Connected {get;}

Property Value

true if connected; false if not connected.

See Also

FtpDataConnection Class | ComponentSpace.Ftp Namespace


FtpDataConnection.ReceiveTimeout Property

Gets or sets the number of milliseconds to wait for the response from the server.

[Visual Basic]
Public Property ReceiveTimeout As Integer
[C#]
public int ReceiveTimeout {get; set;}

Property Value

The number of milliseconds to wait for the response from the server. The default is 10 seconds.

See Also

FtpDataConnection Class | ComponentSpace.Ftp Namespace


FtpDataConnection.SendTimeout Property

Gets or sets the number of milliseconds to wait for the request to be sent to the server.

[Visual Basic]
Public Property SendTimeout As Integer
[C#]
public int SendTimeout {get; set;}

Property Value

The number of milliseconds to wait for the request to be sent to the server. The default is 10 seconds.

See Also

FtpDataConnection Class | ComponentSpace.Ftp Namespace


FtpDataConnection.Stream Property

Gets the TCP stream.

[Visual Basic]
Public ReadOnly Property Stream As Stream
[C#]
public System.IO.Stream Stream {get;}

Property Value

The TCP stream.

See Also

FtpDataConnection Class | ComponentSpace.Ftp Namespace


FtpDataConnection.SynchronizingObject Property

Gets or sets the synchonizing object for receiving events.

[Visual Basic]
Public Property SynchronizingObject As ISynchronizeInvoke
[C#]
public System.ComponentModel.ISynchronizeInvoke SynchronizingObject {get; set;}

Property Value

An ISynchronizeInvoke, which represents the object that marshals the event-handler call resulting from an event. The default is a null reference (Nothing in Visual Basic).

Remarks

Typically, the SynchronizingObject is set when it's used within a form, because forms are bound to a specific thread.

Typically, the synchronizing object marshals a method call into a single thread.

See Also

FtpDataConnection Class | ComponentSpace.Ftp Namespace


FtpDataConnection Methods

The methods of the FtpDataConnection class are listed below. For a complete list of FtpDataConnection class members, see the FtpDataConnection Members topic.

Public Instance Methods

Accept | Accept a server initiated connection. This only applies where a previous call to Listen has been made.
Connect | Connects to the server. The client initiates a connection to the server.
Disconnect | Disconnects from the server.
Dispose | Dispose of the FtpDataConnection and the underlying socket object.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
Listen | Listen for a server connection. A subsequent Accept is required to accept the server initiated connection.
Receive | Receive data from the server.
Send | Send data to the server.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

FtpDataConnection Class | ComponentSpace.Ftp Namespace


FtpDataConnection.Accept Method

Accept a server initiated connection. This only applies where a previous call to Listen has been made.

[Visual Basic]
Public Sub Accept()
[C#]
public void Accept();

Exceptions

Exception Type | Condition
FtpException | Thrown when the accept fails.

See Also

FtpDataConnection Class | ComponentSpace.Ftp Namespace


FtpDataConnection.Connect Method

Connects to the server. The client initiates a connection to the server.

[Visual Basic]
Public Sub Connect( _
ByVal dataPort As IPEndPoint _
)
[C#]
public void Connect(
IPEndPoint dataPort
);

Parameters

dataPort
The server data port.

Exceptions

Exception Type | Condition
FtpException | Thrown when the connect fails.

See Also

FtpDataConnection Class | ComponentSpace.Ftp Namespace


FtpDataConnection.Disconnect Method

Disconnects from the server.

[Visual Basic]
Public Sub Disconnect()
[C#]
public void Disconnect();

Exceptions

Exception Type | Condition
FtpException | Thrown when the disconnect fails.

See Also

FtpDataConnection Class | ComponentSpace.Ftp Namespace


FtpDataConnection.Dispose Method

Dispose of the FtpDataConnection and the underlying socket object.

[Visual Basic]
NotOverridable Public Sub Dispose() _
Implements IDisposable.Dispose
[C#]
public void Dispose();

Implements

IDisposable.Dispose

See Also

FtpDataConnection Class | ComponentSpace.Ftp Namespace


FtpDataConnection.Listen Method

Listen for a server connection. A subsequent Accept is required to accept the server initiated connection.

[Visual Basic]
Public Function Listen( _
ByVal localEndPoint As IPEndPoint _
) As IPEndPoint
[C#]
public IPEndPoint Listen(
IPEndPoint localEndPoint
);

Parameters

localEndPoint
The local end point to listen on.

Return Value

The end point on which a server connection is being listened for.

Exceptions

Exception Type | Condition
FtpException | Thrown when the listen fails.

See Also

FtpDataConnection Class | ComponentSpace.Ftp Namespace


FtpDataConnection.Receive Method

Receive data from the server.

[Visual Basic]
Public Sub Receive( _
ByVal dataStream As Stream _
)
[C#]
public void Receive(
Stream dataStream
);

Parameters

dataStream
The stream to receive the data.

Exceptions

Exception Type | Condition
FtpException | Thrown when the data cannot be received.

See Also

FtpDataConnection Class | ComponentSpace.Ftp Namespace


FtpDataConnection.Send Method

Send data to the server.

[Visual Basic]
Public Sub Send( _
ByVal dataStream As Stream _
)
[C#]
public void Send(
Stream dataStream
);

Parameters

dataStream
The data to send.

Exceptions

Exception Type | Condition
FtpException | Thrown when the data cannot be sent.

See Also

FtpDataConnection Class | ComponentSpace.Ftp Namespace


FtpDataConnection Events

The events of the FtpDataConnection class are listed below. For a complete list of FtpDataConnection class members, see the FtpDataConnection Members topic.

Public Instance Events

DataTransferred Occurs at intervals to indicate how many bytes in total have been transferred during the current data transfer. This event may be used provide feedback during data transfers.

See Also

FtpDataConnection Class | ComponentSpace.Ftp Namespace


FtpDataConnection.DataTransferred Event

Occurs at intervals to indicate how many bytes in total have been transferred during the current data transfer. This event may be used provide feedback during data transfers.

[Visual Basic]
Public Event DataTransferred As DataTransferredEventHandler
[C#]
public event DataTransferredEventHandler DataTransferred;

Event Data

The event handler receives an argument of type DataTransferredEventArgs containing data related to this event. The following DataTransferredEventArgs property provides information specific to this event.

Property | Description
BytesTransferred | Gets the total number of bytes transferred in the current operation.

See Also

FtpDataConnection Class | ComponentSpace.Ftp Namespace


FtpException Class

The exception that is thrown when an FTP operation fails.

For a list of all members of this type, see FtpException Members.

System.Object
System.Exception
System.ApplicationException
ComponentSpace.Ftp.FtpException

[Visual Basic]
Public Class FtpException
Inherits ApplicationException
[C#]
public class FtpException : ApplicationException

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: ComponentSpace.Ftp

Assembly: ComponentSpace.Ftp (in ComponentSpace.Ftp.dll)

See Also

FtpException Members | ComponentSpace.Ftp Namespace


FtpException Members

FtpException overview

Public Instance Properties

FtpCommandReply | Gets the associated FtpCommandReply or null.
HelpLink (inherited from Exception) | Gets or sets a link to the help file associated with this exception.
InnerException (inherited from Exception) | Gets the Exception instance that caused the current exception.
Message (inherited from Exception) | Gets a message that describes the current exception.
Source (inherited from Exception) | Gets or sets the name of the application or the object that causes the error.
StackTrace (inherited from Exception) | Gets a string representation of the frames on the call stack at the time the current exception was thrown.
TargetSite (inherited from Exception) | Gets the method that throws the current exception.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetBaseException (inherited from Exception) | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetObjectData (inherited from Exception) | When overridden in a derived class, sets the SerializationInfo with information about the exception.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Exception) | Creates and returns a string representation of the current exception.

Protected Instance Properties

HResult (inherited from Exception) Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

FtpException Class | ComponentSpace.Ftp Namespace


FtpException Properties

The properties of the FtpException class are listed below. For a complete list of FtpException class members, see the FtpException Members topic.

Public Instance Properties

FtpCommandReply | Gets the associated FtpCommandReply or null.
HelpLink (inherited from Exception) | Gets or sets a link to the help file associated with this exception.
InnerException (inherited from Exception) | Gets the Exception instance that caused the current exception.
Message (inherited from Exception) | Gets a message that describes the current exception.
Source (inherited from Exception) | Gets or sets the name of the application or the object that causes the error.
StackTrace (inherited from Exception) | Gets a string representation of the frames on the call stack at the time the current exception was thrown.
TargetSite (inherited from Exception) | Gets the method that throws the current exception.

Protected Instance Properties

HResult (inherited from Exception) Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception.

See Also

FtpException Class | ComponentSpace.Ftp Namespace


FtpException.FtpCommandReply Property

Gets the associated FtpCommandReply or null.

[Visual Basic]
Public ReadOnly Property FtpCommandReply As FtpCommandReply
[C#]
public FtpCommandReply FtpCommandReply {get;}

Property Value

The associated FtpCommandReply or null.

See Also

FtpException Class | ComponentSpace.Ftp Namespace


FtpOperationCompletedEventArgs Class

Provides data for the event.

For a list of all members of this type, see FtpOperationCompletedEventArgs Members.

System.Object
System.EventArgs
ComponentSpace.Ftp.FtpOperationCompletedEventArgs

[Visual Basic]
Public Class FtpOperationCompletedEventArgs
Inherits EventArgs
[C#]
public class FtpOperationCompletedEventArgs : EventArgs

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: ComponentSpace.Ftp

Assembly: ComponentSpace.Ftp (in ComponentSpace.Ftp.dll)

See Also

FtpOperationCompletedEventArgs Members | ComponentSpace.Ftp Namespace


FtpOperationCompletedEventArgs Members

FtpOperationCompletedEventArgs overview

Public Instance Properties

AsyncResult Gets the result of the asynchronous send operation.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

FtpOperationCompletedEventArgs Class | ComponentSpace.Ftp Namespace


FtpOperationCompletedEventArgs Properties

The properties of the FtpOperationCompletedEventArgs class are listed below. For a complete list of FtpOperationCompletedEventArgs class members, see the FtpOperationCompletedEventArgs Members topic.

Public Instance Properties

AsyncResult Gets the result of the asynchronous send operation.

See Also

FtpOperationCompletedEventArgs Class | ComponentSpace.Ftp Namespace


FtpOperationCompletedEventArgs.AsyncResult Property

Gets the result of the asynchronous send operation.

[Visual Basic]
Public ReadOnly Property AsyncResult As IAsyncResult
[C#]
public System.IAsyncResult AsyncResult {get;}

Property Value

An IAsyncResult that contains the data associated with the send operation.

Remarks

AsyncResult identifies ongoing or completed asynchronous operations.

See Also

FtpOperationCompletedEventArgs Class | ComponentSpace.Ftp Namespace


FtpOperationCompletedEventHandler Delegate

Represents the method that will handle FTP operation completion events.

[Visual Basic]
Public Delegate Sub FtpOperationCompletedEventHandler( _
ByVal sender As Object, _
ByVal e As FtpOperationCompletedEventArgs _
)
[C#]
public delegate void FtpOperationCompletedEventHandler(
object sender,
FtpOperationCompletedEventArgs e
);

Parameters

sender
The source of the event.
e
A FtpOperationCompletedEventArgs that contains the event data.

Remarks

When you create a FtpOperationCompletedEventHandler delegate, you identify the method that will handle the event. To associate the event with your event handler, add an instance of the delegate to the event. The event handler is called whenever the event occurs, unless you remove the delegate.

Requirements

Namespace: ComponentSpace.Ftp

Assembly: ComponentSpace.Ftp (in ComponentSpace.Ftp.dll)

See Also

ComponentSpace.Ftp Namespace


FtpWebRequest Class

Represents an FTP web request in the Microsoft pluggable protocols architecture.

For a list of all members of this type, see FtpWebRequest Members.

System.Object
System.MarshalByRefObject
System.Net.WebRequest
ComponentSpace.Ftp.FtpWebRequest

[Visual Basic]
Public Class FtpWebRequest
Inherits WebRequest
[C#]
public class FtpWebRequest : WebRequest

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: ComponentSpace.Ftp

Assembly: ComponentSpace.Ftp (in ComponentSpace.Ftp.dll)

See Also

FtpWebRequest Members | ComponentSpace.Ftp Namespace


FtpWebRequest Members

FtpWebRequest overview

Public Static (Shared) Fields

imageContentType | The content type representing a binary file transfer.
retrieveCommandType | The FTP retrieve command - copy the remote file from the FTP server to the local file system.
storeCommandType | The FTP store command - copy the local file to the FTP server from the local file system.
textContentType | The content type representing an ASCII file transfer.

Public Instance Properties

ConnectionGroupName (inherited from WebRequest) | When overridden in a descendant class, gets or sets the name of the connection group for the request.
ContentLength (inherited from WebRequest) | When overridden in a descendant class, gets or sets the content length of the request data being sent.
ContentType | Gets or sets the content type. The content type "text" specifies an ASCII transfer. The content type "image" specifies a binary transfer.
Credentials | Gets or sets the user name and password used when connecting to the FTP server. If none is specified it defaults to the anonymous user.
Headers (inherited from WebRequest) | When overridden in a descendant class, gets or sets the collection of header name/value pairs associated with the request.
Method | Gets or sets the method to the FTP command RETR (retrieve from server) or STOR (store on server).
PreAuthenticate (inherited from WebRequest) | When overridden in a descendant class, indicates whether to preauthenticate the request.
Proxy (inherited from WebRequest) | When overridden in a descendant class, gets or sets the network proxy to use to access this Internet resource.
RequestUri | Gets the URI.
Timeout | Gets or sets the timeout in milliseconds.

Public Instance Methods

Abort (inherited from WebRequest) | Cancels an asynchronous request to an Internet resource.
BeginGetRequestStream | Initiates an asynchronous get request stream operation. This overload receives notification, through a callback, of the identity of the event handler for this operation.
BeginGetResponse | Initiates an asynchronous get web response operation. This overload receives notification, through a callback, of the identity of the event handler for this operation.
CreateObjRef (inherited from MarshalByRefObject) | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object.
EndGetRequestStream | Completes the specified asynchronous get request stream operation.
EndGetResponse | Completes the specified asynchronous get web response operation.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetLifetimeService (inherited from MarshalByRefObject) | Retrieves the current lifetime service object that controls the lifetime policy for this instance.
GetRequestStream | Get the request stream. Calling this method will initiate the FTP request and, in the case of a STOR (store) command return a stream for writing the file data to the FTP server. The stream is not used with other commands.
GetResponse | Get the WebResponse. Calling this method will complete the FTP operation and, in the case of a RETR (retrieve) command make available a stream for reading the file data from the FTP server. The stream is not used with other commands.
GetType (inherited from Object) | Gets the Type of the current instance.
InitializeLifetimeService (inherited from MarshalByRefObject) | Obtains a lifetime service object to control the lifetime policy for this instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

FtpWebRequest Class | ComponentSpace.Ftp Namespace


FtpWebRequest Fields

The fields of the FtpWebRequest class are listed below. For a complete list of FtpWebRequest class members, see the FtpWebRequest Members topic.

Public Static (Shared) Fields

imageContentType | The content type representing a binary file transfer.
retrieveCommandType | The FTP retrieve command - copy the remote file from the FTP server to the local file system.
storeCommandType | The FTP store command - copy the local file to the FTP server from the local file system.
textContentType | The content type representing an ASCII file transfer.

See Also

FtpWebRequest Class | ComponentSpace.Ftp Namespace


FtpWebRequest.imageContentType Field

The content type representing a binary file transfer.

[Visual Basic]
Public Const imageContentType As String = "image"
[C#]
public const string imageContentType = "image";

See Also

FtpWebRequest Class | ComponentSpace.Ftp Namespace


FtpWebRequest.retrieveCommandType Field

The FTP retrieve command - copy the remote file from the FTP server to the local file system.

[Visual Basic]
Public Const retrieveCommandType As String = "RETR"
[C#]
public const string retrieveCommandType = "RETR";

See Also

FtpWebRequest Class | ComponentSpace.Ftp Namespace


FtpWebRequest.storeCommandType Field

The FTP store command - copy the local file to the FTP server from the local file system.

[Visual Basic]
Public Const storeCommandType As String = "STOR"
[C#]
public const string storeCommandType = "STOR";

See Also

FtpWebRequest Class | ComponentSpace.Ftp Namespace


FtpWebRequest.textContentType Field

The content type representing an ASCII file transfer.

[Visual Basic]
Public Const textContentType As String = "text"
[C#]
public const string textContentType = "text";

See Also

FtpWebRequest Class | ComponentSpace.Ftp Namespace


FtpWebRequest Properties

The properties of the FtpWebRequest class are listed below. For a complete list of FtpWebRequest class members, see the FtpWebRequest Members topic.

Public Instance Properties

ConnectionGroupName (inherited from WebRequest) | When overridden in a descendant class, gets or sets the name of the connection group for the request.
ContentLength (inherited from WebRequest) | When overridden in a descendant class, gets or sets the content length of the request data being sent.
ContentType | Gets or sets the content type. The content type "text" specifies an ASCII transfer. The content type "image" specifies a binary transfer.
Credentials | Gets or sets the user name and password used when connecting to the FTP server. If none is specified it defaults to the anonymous user.
Headers (inherited from WebRequest) | When overridden in a descendant class, gets or sets the collection of header name/value pairs associated with the request.
Method | Gets or sets the method to the FTP command RETR (retrieve from server) or STOR (store on server).
PreAuthenticate (inherited from WebRequest) | When overridden in a descendant class, indicates whether to preauthenticate the request.
Proxy (inherited from WebRequest) | When overridden in a descendant class, gets or sets the network proxy to use to access this Internet resource.
RequestUri | Gets the URI.
Timeout | Gets or sets the timeout in milliseconds.

See Also

FtpWebRequest Class | ComponentSpace.Ftp Namespace


FtpWebRequest.ContentType Property

Gets or sets the content type. The content type "text" specifies an ASCII transfer. The content type "image" specifies a binary transfer.

[Visual Basic]
Overrides Public Property ContentType As String
[C#]
public override string ContentType {get; set;}

Property Value

The content type. The default is image (binary transfer).

See Also

FtpWebRequest Class | ComponentSpace.Ftp Namespace


FtpWebRequest.Credentials Property

Gets or sets the user name and password used when connecting to the FTP server. If none is specified it defaults to the anonymous user.

[Visual Basic]
Overrides Public Property Credentials As ICredentials
[C#]
public override System.Net.ICredentials Credentials {get; set;}

Property Value

The user name and password credentials. The default is the anonymous user.

See Also

FtpWebRequest Class | ComponentSpace.Ftp Namespace


FtpWebRequest.Method Property

Gets or sets the method to the FTP command RETR (retrieve from server) or STOR (store on server).

[Visual Basic]
Overrides Public Property Method As String
[C#]
public override string Method {get; set;}

Property Value

The content type. The default is RETR (retrieve).

See Also

FtpWebRequest Class | ComponentSpace.Ftp Namespace


FtpWebRequest.RequestUri Property

Gets the URI.

[Visual Basic]
Overrides Public ReadOnly Property RequestUri As Uri
[C#]
public override System.Uri RequestUri {get;}

Property Value

The URI.

See Also

FtpWebRequest Class | ComponentSpace.Ftp Namespace


FtpWebRequest.Timeout Property

Gets or sets the timeout in milliseconds.

[Visual Basic]
Overrides Public Property Timeout As Integer
[C#]
public override int Timeout {get; set;}

Property Value

The timeout. Defaults to 60 seconds.

See Also

FtpWebRequest Class | ComponentSpace.Ftp Namespace


FtpWebRequest Methods

The methods of the FtpWebRequest class are listed below. For a complete list of FtpWebRequest class members, see the FtpWebRequest Members topic.

Public Instance Methods

Abort (inherited from WebRequest) | Cancels an asynchronous request to an Internet resource.
BeginGetRequestStream | Initiates an asynchronous get request stream operation. This overload receives notification, through a callback, of the identity of the event handler for this operation.
BeginGetResponse | Initiates an asynchronous get web response operation. This overload receives notification, through a callback, of the identity of the event handler for this operation.
CreateObjRef (inherited from MarshalByRefObject) | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object.
EndGetRequestStream | Completes the specified asynchronous get request stream operation.
EndGetResponse | Completes the specified asynchronous get web response operation.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetLifetimeService (inherited from MarshalByRefObject) | Retrieves the current lifetime service object that controls the lifetime policy for this instance.
GetRequestStream | Get the request stream. Calling this method will initiate the FTP request and, in the case of a STOR (store) command return a stream for writing the file data to the FTP server. The stream is not used with other commands.
GetResponse | Get the WebResponse. Calling this method will complete the FTP operation and, in the case of a RETR (retrieve) command make available a stream for reading the file data from the FTP server. The stream is not used with other commands.
GetType (inherited from Object) | Gets the Type of the current instance.
InitializeLifetimeService (inherited from MarshalByRefObject) | Obtains a lifetime service object to control the lifetime policy for this instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

FtpWebRequest Class | ComponentSpace.Ftp Namespace


FtpWebRequest.BeginGetRequestStream Method

Initiates an asynchronous get request stream operation. This overload receives notification, through a callback, of the identity of the event handler for this operation.

[Visual Basic]
Overrides Public Function BeginGetRequestStream( _
ByVal callback As AsyncCallback, _
ByVal state As Object _
) As IAsyncResult
[C#]
public override IAsyncResult BeginGetRequestStream(
AsyncCallback callback,
object state
);

Parameters

callback
The AsyncCallback that will receive the notification of the asynchronous operation completion.
state
A state object, specified by the application, that contains information associated with the asynchronous operation.

Return Value

The IAsyncResult that identifies the posted asynchronous request.

Remarks

When you use this overload, the callback specified in the callback parameter is invoked directly when the operation has completed.

See Also

FtpWebRequest Class | ComponentSpace.Ftp Namespace


FtpWebRequest.BeginGetResponse Method

Initiates an asynchronous get web response operation. This overload receives notification, through a callback, of the identity of the event handler for this operation.

[Visual Basic]
Overrides Public Function BeginGetResponse( _
ByVal callback As AsyncCallback, _
ByVal state As Object _
) As IAsyncResult
[C#]
public override IAsyncResult BeginGetResponse(
AsyncCallback callback,
object state
);

Parameters

callback
The AsyncCallback that will receive the notification of the asynchronous operation completion.
state
A state object, specified by the application, that contains information associated with the asynchronous operation.

Return Value

The IAsyncResult that identifies the posted asynchronous request.

Remarks

When you use this overload, the callback specified in the callback parameter is invoked directly when the operation has completed.

See Also

FtpWebRequest Class | ComponentSpace.Ftp Namespace


FtpWebRequest.EndGetRequestStream Method

Completes the specified asynchronous get request stream operation.

[Visual Basic]
Overrides Public Function EndGetRequestStream( _
ByVal asyncResult As IAsyncResult _
) As Stream
[C#]
public override Stream EndGetRequestStream(
IAsyncResult asyncResult
);

Parameters

asyncResult
The IAsyncResult that identifies the asynchronous operation to finish, and from which to retrieve an end result.

Return Value

The Stream used to write file data to the FTP server.

Exceptions

Exception Type | Condition
WebException | Thrown when the FTP operation fails.

See Also

FtpWebRequest Class | ComponentSpace.Ftp Namespace


FtpWebRequest.EndGetResponse Method

Completes the specified asynchronous get web response operation.

[Visual Basic]
Overrides Public Function EndGetResponse( _
ByVal asyncResult As IAsyncResult _
) As WebResponse
[C#]
public override WebResponse EndGetResponse(
IAsyncResult asyncResult
);

Parameters

asyncResult
The IAsyncResult that identifies the asynchronous operation to finish, and from which to retrieve an end result.

Return Value

The WebResponse used to retrieve the FTP operation's response data.

Exceptions

Exception Type | Condition
WebException | Thrown when the FTP operation fails.

See Also

FtpWebRequest Class | ComponentSpace.Ftp Namespace


FtpWebRequest.GetRequestStream Method

Get the request stream. Calling this method will initiate the FTP request and, in the case of a STOR (store) command return a stream for writing the file data to the FTP server. The stream is not used with other commands.

[Visual Basic]
Overrides Public Function GetRequestStream() As Stream
[C#]
public override Stream GetRequestStream();

Return Value

The Stream used to write file data to the FTP server.

Exceptions

Exception Type | Condition
WebException | Thrown when the operation fails.

See Also

FtpWebRequest Class | ComponentSpace.Ftp Namespace


FtpWebRequest.GetResponse Method

Get the WebResponse. Calling this method will complete the FTP operation and, in the case of a RETR (retrieve) command make available a stream for reading the file data from the FTP server. The stream is not used with other commands.

[Visual Basic]
Overrides Public Function GetResponse() As WebResponse
[C#]
public override WebResponse GetResponse();

Return Value

The WebResponse used to retrieve the FTP operation's response data.

Exceptions

Exception Type | Condition
WebException | Thrown when the operation fails.

See Also

FtpWebRequest Class | ComponentSpace.Ftp Namespace


FtpWebRequestCreator Class

Factory class for the FTP web request in the Microsoft pluggable protocols architecture.

For a list of all members of this type, see FtpWebRequestCreator Members.

System.Object
ComponentSpace.Ftp.FtpWebRequestCreator

[Visual Basic]
Public Class FtpWebRequestCreator
Implements IWebRequestCreate
[C#]
public class FtpWebRequestCreator : IWebRequestCreate

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: ComponentSpace.Ftp

Assembly: ComponentSpace.Ftp (in ComponentSpace.Ftp.dll)

See Also

FtpWebRequestCreator Members | ComponentSpace.Ftp Namespace


FtpWebRequestCreator Members

FtpWebRequestCreator overview

Public Instance Constructors

FtpWebRequestCreator Constructor Initializes a new instance of the FtpWebRequestCreator class.

Public Instance Methods

Create | Creates a FtpWebRequest instance.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

FtpWebRequestCreator Class | ComponentSpace.Ftp Namespace


FtpWebRequestCreator Constructor

Initializes a new instance of the FtpWebRequestCreator class.

[Visual Basic]
Public Sub New()
[C#]
public FtpWebRequestCreator();

See Also

FtpWebRequestCreator Class | ComponentSpace.Ftp Namespace


FtpWebRequestCreator Methods

The methods of the FtpWebRequestCreator class are listed below. For a complete list of FtpWebRequestCreator class members, see the FtpWebRequestCreator Members topic.

Public Instance Methods

Create | Creates a FtpWebRequest instance.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

FtpWebRequestCreator Class | ComponentSpace.Ftp Namespace


FtpWebRequestCreator.Create Method

Creates a FtpWebRequest instance.

[Visual Basic]
NotOverridable Public Function Create( _
ByVal uri As Uri _
) As WebRequest _
Implements IWebRequestCreate.Create
[C#]
public WebRequest Create(
Uri uri
);

Parameters

uri
The uniform resource identifier (URI) of the Web resource.

Return Value

A FtpWebRequest instance.

Implements

IWebRequestCreate.Create

See Also

FtpWebRequestCreator Class | ComponentSpace.Ftp Namespace


FtpWebResponse Class

Represents an FTP web request in the Microsoft pluggable protocols architecture.

For a list of all members of this type, see FtpWebResponse Members.

System.Object
System.MarshalByRefObject
System.Net.WebResponse
ComponentSpace.Ftp.FtpWebResponse

[Visual Basic]
Public Class FtpWebResponse
Inherits WebResponse
[C#]
public class FtpWebResponse : WebResponse

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: ComponentSpace.Ftp

Assembly: ComponentSpace.Ftp (in ComponentSpace.Ftp.dll)

See Also

FtpWebResponse Members | ComponentSpace.Ftp Namespace


FtpWebResponse Members

FtpWebResponse overview

Public Instance Properties

ContentLength (inherited from WebResponse) | When overridden in a descendant class, gets or sets the content length of data being received.
ContentType (inherited from WebResponse) | When overridden in a derived class, gets or sets the content type of the data being received.
Headers (inherited from WebResponse) | When overridden in a derived class, gets a collection of header name-value pairs associated with this request.
ResponseUri (inherited from WebResponse) | When overridden in a derived class, gets the URI of the Internet resource that actually responded to the request.

Public Instance Methods

Close | Close the associated stream.
CreateObjRef (inherited from MarshalByRefObject) | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object.
Dispose | Dispose of the FtpWebResponse and the underlying stream objects.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetLifetimeService (inherited from MarshalByRefObject) | Retrieves the current lifetime service object that controls the lifetime policy for this instance.
GetResponseStream | Get the associated stream.
GetType (inherited from Object) | Gets the Type of the current instance.
InitializeLifetimeService (inherited from MarshalByRefObject) | Obtains a lifetime service object to control the lifetime policy for this instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

FtpWebResponse Class | ComponentSpace.Ftp Namespace


FtpWebResponse Methods

The methods of the FtpWebResponse class are listed below. For a complete list of FtpWebResponse class members, see the FtpWebResponse Members topic.

Public Instance Methods

Close | Close the associated stream.
CreateObjRef (inherited from MarshalByRefObject) | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object.
Dispose | Dispose of the FtpWebResponse and the underlying stream objects.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetLifetimeService (inherited from MarshalByRefObject) | Retrieves the current lifetime service object that controls the lifetime policy for this instance.
GetResponseStream | Get the associated stream.
GetType (inherited from Object) | Gets the Type of the current instance.
InitializeLifetimeService (inherited from MarshalByRefObject) | Obtains a lifetime service object to control the lifetime policy for this instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

FtpWebResponse Class | ComponentSpace.Ftp Namespace


FtpWebResponse.Close Method

Close the associated stream.

[Visual Basic]
Overrides Public Sub Close()
[C#]
public override void Close();

See Also

FtpWebResponse Class | ComponentSpace.Ftp Namespace


FtpWebResponse.Dispose Method

Dispose of the FtpWebResponse and the underlying stream objects.

[Visual Basic]
Public Sub Dispose()
[C#]
public void Dispose();

See Also

FtpWebResponse Class | ComponentSpace.Ftp Namespace


FtpWebResponse.GetResponseStream Method

Get the associated stream.

[Visual Basic]
Overrides Public Function GetResponseStream() As Stream
[C#]
public override Stream GetResponseStream();

Return Value

The associated stream.

See Also

FtpWebResponse Class | ComponentSpace.Ftp Namespace


HelpCommand Class

Represents the FTP HELP command.

For a list of all members of this type, see HelpCommand Members.

System.Object
ComponentSpace.Ftp.FtpCommand
ComponentSpace.Ftp.HelpCommand

[Visual Basic]
Public Class HelpCommand
Inherits FtpCommand
[C#]
public class HelpCommand : FtpCommand

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: ComponentSpace.Ftp

Assembly: ComponentSpace.Ftp (in ComponentSpace.Ftp.dll)

See Also

HelpCommand Members | ComponentSpace.Ftp Namespace


HelpCommand Members

HelpCommand overview

Public Instance Constructors

HelpCommand Overloaded. Initializes a new instance of the HelpCommand class.

Public Instance Properties

Argument | Gets or sets the help argument.
CommandType (inherited from FtpCommand) | Gets the command type.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString | Convert the command to the FTP command text.
ToTraceString (inherited from FtpCommand) | Convert the reply to the trace text.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

HelpCommand Class | ComponentSpace.Ftp Namespace


HelpCommand Constructor

Initializes a new instance of the HelpCommand.

Overload List

Initializes a new instance of the HelpCommand.

public HelpCommand();

Initializes a new instance of the HelpCommand from the raw command text.

public HelpCommand(string);

See Also

HelpCommand Class | ComponentSpace.Ftp Namespace


HelpCommand Constructor ()

Initializes a new instance of the HelpCommand.

[Visual Basic]
Overloads Public Sub New()
[C#]
public HelpCommand();

See Also

HelpCommand Class | ComponentSpace.Ftp Namespace | HelpCommand Constructor Overload List


HelpCommand Constructor (String)

Initializes a new instance of the HelpCommand from the raw command text.

[Visual Basic]
Overloads Public Sub New( _
ByVal command As String _
)
[C#]
public HelpCommand(
string command
);

Parameters

command
The raw command text.

See Also

HelpCommand Class | ComponentSpace.Ftp Namespace | HelpCommand Constructor Overload List


HelpCommand Properties

The properties of the HelpCommand class are listed below. For a complete list of HelpCommand class members, see the HelpCommand Members topic.

Public Instance Properties

Argument | Gets or sets the help argument.
CommandType (inherited from FtpCommand) | Gets the command type.

See Also

HelpCommand Class | ComponentSpace.Ftp Namespace


HelpCommand.Argument Property

Gets or sets the help argument.

[Visual Basic]
Public Property Argument As String
[C#]
public string Argument {get; set;}

Property Value

The help argument.

See Also

HelpCommand Class | ComponentSpace.Ftp Namespace


HelpCommand Methods

The methods of the HelpCommand class are listed below. For a complete list of HelpCommand class members, see the HelpCommand Members topic.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString | Convert the command to the FTP command text.
ToTraceString (inherited from FtpCommand) | Convert the reply to the trace text.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

HelpCommand Class | ComponentSpace.Ftp Namespace


HelpCommand.ToString Method

Convert the command to the FTP command text.

[Visual Basic]
Overrides Public Function ToString() As String
[C#]
public override string ToString();

Return Value

The FTP command text.

See Also

HelpCommand Class | ComponentSpace.Ftp Namespace


IFileFilter Interface

Provides a filter for determining which files to upload or download during a multi-file operation.

For a list of all members of this type, see IFileFilter Members.

[Visual Basic]
Public Interface IFileFilter
[C#]
public interface IFileFilter

Remarks

Applications using the MultiFile class optionally may supply a filter for determining which files are to be uploaded or downloaded.

To do so, create a class that implements this interface and pass it to the MultiFile methods.

Requirements

Namespace: ComponentSpace.Ftp

Assembly: ComponentSpace.Ftp (in ComponentSpace.Ftp.dll)

See Also

IFileFilter Members | ComponentSpace.Ftp Namespace


IFileFilter Members

IFileFilter overview

Public Instance Methods

IsFileToBeDownloaded | Return true if the file should be downloaded. Otherwise, return false. This method is called for each file available for downloading.
IsFileToBeUploaded | Return true if the file should be uploaded. Otherwise, return false. This method is called for each file available for uploading.

See Also

IFileFilter Interface | ComponentSpace.Ftp Namespace


IFileFilter Methods

The methods of the IFileFilter interface are listed below. For a complete list of IFileFilter interface members, see the IFileFilter Members topic.

Public Instance Methods

IsFileToBeDownloaded | Return true if the file should be downloaded. Otherwise, return false. This method is called for each file available for downloading.
IsFileToBeUploaded | Return true if the file should be uploaded. Otherwise, return false. This method is called for each file available for uploading.

See Also

IFileFilter Interface | ComponentSpace.Ftp Namespace


IFileFilter.IsFileToBeDownloaded Method

Return true if the file should be downloaded. Otherwise, return false. This method is called for each file available for downloading.

[Visual Basic]
Function IsFileToBeDownloaded( _
ByVal directoryListItem As DirectoryListItem _
) As Boolean
[C#]
bool IsFileToBeDownloaded(
DirectoryListItem directoryListItem
);

Parameters

directoryListItem
The directory list item for the remote file

Return Value

true if the file should be downloaded; otherwise false

See Also

IFileFilter Interface | ComponentSpace.Ftp Namespace


IFileFilter.IsFileToBeUploaded Method

Return true if the file should be uploaded. Otherwise, return false. This method is called for each file available for uploading.

[Visual Basic]
Function IsFileToBeUploaded( _
ByVal fileName As String _
) As Boolean
[C#]
bool IsFileToBeUploaded(
string fileName
);

Parameters

fileName
The name of the local file

Return Value

true if the file should be uploaded; otherwise false

See Also

IFileFilter Interface | ComponentSpace.Ftp Namespace


ListCommand Class

Represents the FTP LIST command.

For a list of all members of this type, see ListCommand Members.

System.Object
ComponentSpace.Ftp.FtpCommand
ComponentSpace.Ftp.ListCommand

[Visual Basic]
Public Class ListCommand
Inherits FtpCommand
[C#]
public class ListCommand : FtpCommand

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: ComponentSpace.Ftp

Assembly: ComponentSpace.Ftp (in ComponentSpace.Ftp.dll)

See Also

ListCommand Members | ComponentSpace.Ftp Namespace


ListCommand Members

ListCommand overview

Public Instance Constructors

ListCommand Overloaded. Initializes a new instance of the ListCommand class.

Public Instance Properties

CommandType (inherited from FtpCommand) | Gets the command type.
PathName | Gets or sets the remote path name.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString | Convert the command to the FTP command text.
ToTraceString (inherited from FtpCommand) | Convert the reply to the trace text.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

ListCommand Class | ComponentSpace.Ftp Namespace


ListCommand Constructor

Initializes a new instance of the ListCommand.

Overload List

Initializes a new instance of the ListCommand.

public ListCommand();

Initializes a new instance of the ListCommand from the raw command text.

public ListCommand(string);

See Also

ListCommand Class | ComponentSpace.Ftp Namespace


ListCommand Constructor ()

Initializes a new instance of the ListCommand.

[Visual Basic]
Overloads Public Sub New()
[C#]
public ListCommand();

See Also

ListCommand Class | ComponentSpace.Ftp Namespace | ListCommand Constructor Overload List


ListCommand Constructor (String)

Initializes a new instance of the ListCommand from the raw command text.

[Visual Basic]
Overloads Public Sub New( _
ByVal command As String _
)
[C#]
public ListCommand(
string command
);

Parameters

command
The raw command text.

See Also

ListCommand Class | ComponentSpace.Ftp Namespace | ListCommand Constructor Overload List


ListCommand Properties

The properties of the ListCommand class are listed below. For a complete list of ListCommand class members, see the ListCommand Members topic.

Public Instance Properties

CommandType (inherited from FtpCommand) | Gets the command type.
PathName | Gets or sets the remote path name.

See Also

ListCommand Class | ComponentSpace.Ftp Namespace


ListCommand.PathName Property

Gets or sets the remote path name.

[Visual Basic]
Public Property PathName As String
[C#]
public string PathName {get; set;}

Property Value

The remote path name.

See Also

ListCommand Class | ComponentSpace.Ftp Namespace


ListCommand Methods

The methods of the ListCommand class are listed below. For a complete list of ListCommand class members, see the ListCommand Members topic.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString | Convert the command to the FTP command text.
ToTraceString (inherited from FtpCommand) | Convert the reply to the trace text.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

ListCommand Class | ComponentSpace.Ftp Namespace


ListCommand.ToString Method

Convert the command to the FTP command text.

[Visual Basic]
Overrides Public Function ToString() As String
[C#]
public override string ToString();

Return Value

The FTP command text.

See Also

ListCommand Class | ComponentSpace.Ftp Namespace


ListLineAvailableEventArgs Class

Provides data for the event.

For a list of all members of this type, see ListLineAvailableEventArgs Members.

System.Object
System.EventArgs
ComponentSpace.Ftp.ListLineAvailableEventArgs

[Visual Basic]
Public Class ListLineAvailableEventArgs
Inherits EventArgs
[C#]
public class ListLineAvailableEventArgs : EventArgs

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: ComponentSpace.Ftp

Assembly: ComponentSpace.Ftp (in ComponentSpace.Ftp.dll)

See Also

ListLineAvailableEventArgs Members | ComponentSpace.Ftp Namespace


ListLineAvailableEventArgs Members

ListLineAvailableEventArgs overview

Public Instance Properties

ListLine Gets the list line.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

ListLineAvailableEventArgs Class | ComponentSpace.Ftp Namespace


ListLineAvailableEventArgs Properties

The properties of the ListLineAvailableEventArgs class are listed below. For a complete list of ListLineAvailableEventArgs class members, see the ListLineAvailableEventArgs Members topic.

Public Instance Properties

ListLine Gets the list line.

See Also

ListLineAvailableEventArgs Class | ComponentSpace.Ftp Namespace


ListLineAvailableEventArgs.ListLine Property

Gets the list line.

[Visual Basic]
Public ReadOnly Property ListLine As String
[C#]
public string ListLine {get;}

Property Value

An IAsyncResult that contains the data associated with the send operation.

See Also

ListLineAvailableEventArgs Class | ComponentSpace.Ftp Namespace


ListLineAvailableEventHandler Delegate

Represents the method that will handle list line available events.

[Visual Basic]
Public Delegate Sub ListLineAvailableEventHandler( _
ByVal sender As Object, _
ByVal e As ListLineAvailableEventArgs _
)
[C#]
public delegate void ListLineAvailableEventHandler(
object sender,
ListLineAvailableEventArgs e
);

Parameters

sender
The source of the event.
e
A ListLineAvailableEventArgs that contains the event data.

Remarks

When you create a ListLineAvailableEventHandler delegate, you identify the method that will handle the event. To associate the event with your event handler, add an instance of the delegate to the event. The event handler is called whenever the event occurs, unless you remove the delegate.

Requirements

Namespace: ComponentSpace.Ftp

Assembly: ComponentSpace.Ftp (in ComponentSpace.Ftp.dll)

See Also

ComponentSpace.Ftp Namespace


MakeDirectoryCommand Class

Represents the FTP MKD command.

For a list of all members of this type, see MakeDirectoryCommand Members.

System.Object
ComponentSpace.Ftp.FtpCommand
ComponentSpace.Ftp.MakeDirectoryCommand

[Visual Basic]
Public Class MakeDirectoryCommand
Inherits FtpCommand
[C#]
public class MakeDirectoryCommand : FtpCommand

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: ComponentSpace.Ftp

Assembly: ComponentSpace.Ftp (in ComponentSpace.Ftp.dll)

See Also

MakeDirectoryCommand Members | ComponentSpace.Ftp Namespace


MakeDirectoryCommand Members

MakeDirectoryCommand overview

Public Instance Constructors

MakeDirectoryCommand Overloaded. Initializes a new instance of the MakeDirectoryCommand class.

Public Instance Properties

CommandType (inherited from FtpCommand) | Gets the command type.
PathName | Gets or sets the remote path name.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString | Convert the command to the FTP command text.
ToTraceString (inherited from FtpCommand) | Convert the reply to the trace text.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

MakeDirectoryCommand Class | ComponentSpace.Ftp Namespace


MakeDirectoryCommand Constructor

Initializes a new instance of the MakeDirectoryCommand.

Overload List

Initializes a new instance of the MakeDirectoryCommand.

public MakeDirectoryCommand();

Initializes a new instance of the MakeDirectoryCommand from the raw command text.

public MakeDirectoryCommand(string);

See Also

MakeDirectoryCommand Class | ComponentSpace.Ftp Namespace


MakeDirectoryCommand Constructor ()

Initializes a new instance of the MakeDirectoryCommand.

[Visual Basic]
Overloads Public Sub New()
[C#]
public MakeDirectoryCommand();

See Also

MakeDirectoryCommand Class | ComponentSpace.Ftp Namespace | MakeDirectoryCommand Constructor Overload List


MakeDirectoryCommand Constructor (String)

Initializes a new instance of the MakeDirectoryCommand from the raw command text.

[Visual Basic]
Overloads Public Sub New( _
ByVal command As String _
)
[C#]
public MakeDirectoryCommand(
string command
);

Parameters

command
The raw command text.

See Also

MakeDirectoryCommand Class | ComponentSpace.Ftp Namespace | MakeDirectoryCommand Constructor Overload List


MakeDirectoryCommand Properties

The properties of the MakeDirectoryCommand class are listed below. For a complete list of MakeDirectoryCommand class members, see the MakeDirectoryCommand Members topic.

Public Instance Properties

CommandType (inherited from FtpCommand) | Gets the command type.
PathName | Gets or sets the remote path name.

See Also

MakeDirectoryCommand Class | ComponentSpace.Ftp Namespace


MakeDirectoryCommand.PathName Property

Gets or sets the remote path name.

[Visual Basic]
Public Property PathName As String
[C#]
public string PathName {get; set;}

Property Value

The remote path name.

See Also

MakeDirectoryCommand Class | ComponentSpace.Ftp Namespace


MakeDirectoryCommand Methods

The methods of the MakeDirectoryCommand class are listed below. For a complete list of MakeDirectoryCommand class members, see the MakeDirectoryCommand Members topic.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString | Convert the command to the FTP command text.
ToTraceString (inherited from FtpCommand) | Convert the reply to the trace text.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

MakeDirectoryCommand Class | ComponentSpace.Ftp Namespace


MakeDirectoryCommand.ToString Method

Convert the command to the FTP command text.

[Visual Basic]
Overrides Public Function ToString() As String
[C#]
public override string ToString();

Return Value

The FTP command text.

See Also

MakeDirectoryCommand Class | ComponentSpace.Ftp Namespace


ModeCommand Class

Represents the FTP MODE command.

For a list of all members of this type, see ModeCommand Members.

System.Object
ComponentSpace.Ftp.FtpCommand
ComponentSpace.Ftp.ModeCommand

[Visual Basic]
Public Class ModeCommand
Inherits FtpCommand
[C#]
public class ModeCommand : FtpCommand

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: ComponentSpace.Ftp

Assembly: ComponentSpace.Ftp (in ComponentSpace.Ftp.dll)

See Also

ModeCommand Members | ComponentSpace.Ftp Namespace


ModeCommand Members

ModeCommand overview

Public Instance Constructors

ModeCommand Overloaded. Initializes a new instance of the ModeCommand class.

Public Instance Properties

CommandType (inherited from FtpCommand) | Gets the command type.
TransferMode | Gets or sets the transfer mode.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString | Convert the command to the FTP command text.
ToTraceString (inherited from FtpCommand) | Convert the reply to the trace text.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

ModeCommand Class | ComponentSpace.Ftp Namespace


ModeCommand Constructor

Initializes a new instance of the ModeCommand.

Overload List

Initializes a new instance of the ModeCommand.

public ModeCommand();

Initializes a new instance of the ModeCommand from the raw command text.

public ModeCommand(string);

See Also

ModeCommand Class | ComponentSpace.Ftp Namespace


ModeCommand Constructor ()

Initializes a new instance of the ModeCommand.

[Visual Basic]
Overloads Public Sub New()
[C#]
public ModeCommand();

See Also

ModeCommand Class | ComponentSpace.Ftp Namespace | ModeCommand Constructor Overload List


ModeCommand Constructor (String)

Initializes a new instance of the ModeCommand from the raw command text.

[Visual Basic]
Overloads Public Sub New( _
ByVal command As String _
)
[C#]
public ModeCommand(
string command
);

Parameters

command
The raw command text.

See Also

ModeCommand Class | ComponentSpace.Ftp Namespace | ModeCommand Constructor Overload List


ModeCommand Properties

The properties of the ModeCommand class are listed below. For a complete list of ModeCommand class members, see the ModeCommand Members topic.

Public Instance Properties

CommandType (inherited from FtpCommand) | Gets the command type.
TransferMode | Gets or sets the transfer mode.

See Also

ModeCommand Class | ComponentSpace.Ftp Namespace


ModeCommand.TransferMode Property

Gets or sets the transfer mode.

[Visual Basic]
Public Property TransferMode As Char
[C#]
public char TransferMode {get; set;}

Property Value

The transfer mode. Defaults to stream.

See Also

ModeCommand Class | ComponentSpace.Ftp Namespace


ModeCommand Methods

The methods of the ModeCommand class are listed below. For a complete list of ModeCommand class members, see the ModeCommand Members topic.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString | Convert the command to the FTP command text.
ToTraceString (inherited from FtpCommand) | Convert the reply to the trace text.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

ModeCommand Class | ComponentSpace.Ftp Namespace


ModeCommand.ToString Method

Convert the command to the FTP command text.

[Visual Basic]
Overrides Public Function ToString() As String
[C#]
public override string ToString();

Return Value

The FTP command text.

See Also

ModeCommand Class | ComponentSpace.Ftp Namespace


MSDOSDirectoryListItem Class

An MS-DOS directory list items.

For a list of all members of this type, see MSDOSDirectoryListItem Members.

System.Object
ComponentSpace.Ftp.DirectoryListItem
ComponentSpace.Ftp.MSDOSDirectoryListItem

[Visual Basic]
Public Class MSDOSDirectoryListItem
Inherits DirectoryListItem
[C#]
public class MSDOSDirectoryListItem : DirectoryListItem

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: ComponentSpace.Ftp

Assembly: ComponentSpace.Ftp (in ComponentSpace.Ftp.dll)

See Also

MSDOSDirectoryListItem Members | ComponentSpace.Ftp Namespace


MSDOSDirectoryListItem Members

MSDOSDirectoryListItem overview

Public Instance Constructors

MSDOSDirectoryListItem Constructor Initializes a new instance of the MSDOSDirectoryListItem.

Public Instance Properties

Date (inherited from DirectoryListItem) | Gets the unprocessed remote directory item date as returned by the FTP server.
DateTime (inherited from DirectoryListItem) | Gets the DateTime.
ItemType (inherited from DirectoryListItem) | Gets the remote directory item type.
Name (inherited from DirectoryListItem) | Gets the remote directory item name.
Size (inherited from DirectoryListItem) | Gets the remote directory item size.
SoftLink (inherited from DirectoryListItem) | Gets soft link.
Time (inherited from DirectoryListItem) | Gets the unprocessed remote directory item time as returned by the FTP server.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

MSDOSDirectoryListItem Class | ComponentSpace.Ftp Namespace


MSDOSDirectoryListItem Constructor

Initializes a new instance of the MSDOSDirectoryListItem.

[Visual Basic]
Public Sub New( _
ByVal date As String, _
ByVal time As String, _
ByVal isDirectory As Boolean, _
ByVal size As Long, _
ByVal name As String _
)
[C#]
public MSDOSDirectoryListItem(
string date,
string time,
bool isDirectory,
long size,
string name
);

Parameters

date
The directory item date.
time
The directory item time.
isDirectory
The flag indicating whether the directory item is a directory.
size
The directory item size.
name
The directory item name.

See Also

MSDOSDirectoryListItem Class | ComponentSpace.Ftp Namespace


MultiFile Class

Provides methods for manipulating multiple files.

For a list of all members of this type, see MultiFile Members.

System.Object
ComponentSpace.Ftp.MultiFile

[Visual Basic]
Public Class MultiFile
[C#]
public class MultiFile

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

Includes methods for deleting non-empty directories, downloading and uploading multiple files.

Requirements

Namespace: ComponentSpace.Ftp

Assembly: ComponentSpace.Ftp (in ComponentSpace.Ftp.dll)

See Also

MultiFile Members | ComponentSpace.Ftp Namespace


MultiFile Members

MultiFile overview

Public Instance Methods

BeginDownload | Overloaded. Initiates an asynchronous download directory.
BeginRemove | Overloaded. Initiates an asynchronous remove remote directory.
BeginUpload | Overloaded. Initiates an asynchronous upload directory.
Download | Download a directory. The source directory, as well as its contents, are downloaded. Subdirectories may also be included. An optional regular expression and file filter to match upon also may be specified.
EndDownload | Completes the specified asynchronous download directory operation.
EndRemove | Completes the specified asynchronous remove remote directory operation.
EndUpload | Completes the specified asynchronous upload directory operation.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
Remove | Remove the directory and all its contents including files and subdirectories.
ToString (inherited from Object) | Returns a String that represents the current Object.
Upload | Upload a directory. The source directory, as well as its contents, are uploaded. Subdirectories may also be included. An optional regular expression and file filter to match upon also may be specified.

Public Instance Events

DirectoryRemoved | Occurs when a subdirectory has been removed.
DownloadCompleted | Occurs when the download directory has completed.
FileDeleted | Occurs when a file has been deleted.
FileDownloaded | Occurs when a file has been downloaded.
FileUploaded | Occurs when a file has been uploaded.
RemoveCompleted | Occurs when the remove directory has completed.
UploadCompleted | Occurs when the upload directory has completed.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

MultiFile Class | ComponentSpace.Ftp Namespace


MultiFile Methods

The methods of the MultiFile class are listed below. For a complete list of MultiFile class members, see the MultiFile Members topic.

Public Instance Methods

BeginDownload | Overloaded. Initiates an asynchronous download directory.
BeginRemove | Overloaded. Initiates an asynchronous remove remote directory.
BeginUpload | Overloaded. Initiates an asynchronous upload directory.
Download | Download a directory. The source directory, as well as its contents, are downloaded. Subdirectories may also be included. An optional regular expression and file filter to match upon also may be specified.
EndDownload | Completes the specified asynchronous download directory operation.
EndRemove | Completes the specified asynchronous remove remote directory operation.
EndUpload | Completes the specified asynchronous upload directory operation.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
Remove | Remove the directory and all its contents including files and subdirectories.
ToString (inherited from Object) | Returns a String that represents the current Object.
Upload | Upload a directory. The source directory, as well as its contents, are uploaded. Subdirectories may also be included. An optional regular expression and file filter to match upon also may be specified.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

MultiFile Class | ComponentSpace.Ftp Namespace


BeginDownload Method

ComponentSpace FTP Class Library Reference

MultiFile.BeginDownload Method

Initiates an asynchronous download directory.

Overload List

Initiates an asynchronous download directory.

public IAsyncResult BeginDownload(string,string,bool,Regex,IFileFilter);

Initiates an asynchronous download directory that has a specified state object.

public IAsyncResult BeginDownload(string,string,bool,Regex,IFileFilter,object);

Initiates an asynchronous download directory that has a specified state object. This overload receives notification, through a callback, of the identity of the event handler for this operation.

public IAsyncResult BeginDownload(string,string,bool,Regex,IFileFilter,object,AsyncCallback);

See Also

MultiFile Class | ComponentSpace.Ftp Namespace


MultiFile.BeginDownload Method (String, String, Boolean, Regex, IFileFilter)

Initiates an asynchronous download directory.

[Visual Basic]
Overloads Public Function BeginDownload( _
ByVal sourcePathName As String, _
ByVal destinationPathName As String, _
ByVal includeSubDirectories As Boolean, _
ByVal matchRegularExpression As Regex, _
ByVal fileFilter As IFileFilter _
) As IAsyncResult
[C#]
public IAsyncResult BeginDownload(
string sourcePathName,
string destinationPathName,
bool includeSubDirectories,
Regex matchRegularExpression,
IFileFilter fileFilter
);

Parameters

sourcePathName
The remote directory name
destinationPathName
The local directory name
includeSubDirectories
Flag indicating whether to include subdirectories
matchRegularExpression
The optional regular expression to match file names on or
null
if all files are to be included
fileFilter
The optional file filter or null if no file filtering is to be performed

Return Value

The IAsyncResult that identifies the posted asynchronous request.

Remarks

In asynchronous processing, you use BeginDownload to raise the DownloadCompleted event when the download has completed. You complete the operation by calling EndDownload.

See Also

MultiFile Class | ComponentSpace.Ftp Namespace | MultiFile.BeginDownload Overload List


MultiFile.BeginDownload Method (String, String, Boolean, Regex, IFileFilter, Object)

Initiates an asynchronous download directory that has a specified state object.

[Visual Basic]
Overloads Public Function BeginDownload( _
ByVal sourcePathName As String, _
ByVal destinationPathName As String, _
ByVal includeSubDirectories As Boolean, _
ByVal matchRegularExpression As Regex, _
ByVal fileFilter As IFileFilter, _
ByVal stateObject As Object _
) As IAsyncResult
[C#]
public IAsyncResult BeginDownload(
string sourcePathName,
string destinationPathName,
bool includeSubDirectories,
Regex matchRegularExpression,
IFileFilter fileFilter,
object stateObject
);

Parameters

sourcePathName
The remote directory name
destinationPathName
The local directory name
includeSubDirectories
Flag indicating whether to include subdirectories
matchRegularExpression
The optional regular expression to match file names on or
null
if all files are to be included
fileFilter
The optional file filter or null if no file filtering is to be performed
stateObject
A state object, specified by the application, that contains information associated with the asynchronous operation.

Return Value

The IAsyncResult that identifies the posted asynchronous request.

Remarks

In asynchronous processing, you use BeginRemove to raise the RemoveCompleted event when the remove has completed. You complete the operation by calling EndRemove.

Use this overload to associate information with the operation that will be preserved throughout the operation's lifetime. The event handler can detect this information by looking at the AsyncState of the IAsyncResult that is associated with the operation.

See Also

MultiFile Class | ComponentSpace.Ftp Namespace | MultiFile.BeginDownload Overload List


MultiFile.BeginDownload Method (String, String, Boolean, Regex, IFileFilter, Object, AsyncCallback)

Initiates an asynchronous download directory that has a specified state object. This overload receives notification, through a callback, of the identity of the event handler for this operation.

[Visual Basic]
Overloads Public Function BeginDownload( _
ByVal sourcePathName As String, _
ByVal destinationPathName As String, _
ByVal includeSubDirectories As Boolean, _
ByVal matchRegularExpression As Regex, _
ByVal fileFilter As IFileFilter, _
ByVal stateObject As Object, _
ByVal asyncCallback As AsyncCallback _
) As IAsyncResult
[C#]
public IAsyncResult BeginDownload(
string sourcePathName,
string destinationPathName,
bool includeSubDirectories,
Regex matchRegularExpression,
IFileFilter fileFilter,
object stateObject,
AsyncCallback asyncCallback
);

Parameters

sourcePathName
The remote directory name
destinationPathName
The local directory name
includeSubDirectories
Flag indicating whether to include subdirectories
matchRegularExpression
The optional regular expression to match file names on or
null
if all files are to be included
fileFilter
The optional file filter or null if no file filtering is to be performed
stateObject
A state object, specified by the application, that contains information associated with the asynchronous operation.
asyncCallback
The AsyncCallback that will receive the notification of the asynchronous operation completion.

Return Value

The IAsyncResult that identifies the posted asynchronous request.

Remarks

When you use this overload, the callback specified in the callback parameter is invoked directly when the remove has completed; the RemoveCompleted event is not raised. The other overloads of BeginRemove rely on this component to raise the RemoveCompleted event.

See Also

MultiFile Class | ComponentSpace.Ftp Namespace | MultiFile.BeginDownload Overload List


BeginRemove Method

ComponentSpace FTP Class Library Reference

MultiFile.BeginRemove Method

Initiates an asynchronous remove remote directory.

Overload List

Initiates an asynchronous remove remote directory.

public IAsyncResult BeginRemove(string);

Initiates an asynchronous remove remote directory that has a specified state object.

public IAsyncResult BeginRemove(string,object);

Initiates an asynchronous remove remote directory that has a specified state object. This overload receives notification, through a callback, of the identity of the event handler for this operation.

public IAsyncResult BeginRemove(string,object,AsyncCallback);

See Also

MultiFile Class | ComponentSpace.Ftp Namespace


MultiFile.BeginRemove Method (String)

Initiates an asynchronous remove remote directory.

[Visual Basic]
Overloads Public Function BeginRemove( _
ByVal pathName As String _
) As IAsyncResult
[C#]
public IAsyncResult BeginRemove(
string pathName
);

Parameters

pathName
The remote directory path name.

Return Value

The IAsyncResult that identifies the posted asynchronous request.

Remarks

In asynchronous processing, you use BeginRemove to raise the RemoveCompleted event when the remove has completed. You complete the operation by calling EndRemove.

See Also

MultiFile Class | ComponentSpace.Ftp Namespace | MultiFile.BeginRemove Overload List


MultiFile.BeginRemove Method (String, Object)

Initiates an asynchronous remove remote directory that has a specified state object.

[Visual Basic]
Overloads Public Function BeginRemove( _
ByVal pathName As String, _
ByVal stateObject As Object _
) As IAsyncResult
[C#]
public IAsyncResult BeginRemove(
string pathName,
object stateObject
);

Parameters

pathName
The remote directory path name.
stateObject
A state object, specified by the application, that contains information associated with the asynchronous operation.

Return Value

The IAsyncResult that identifies the posted asynchronous request.

Remarks

In asynchronous processing, you use BeginRemove to raise the RemoveCompleted event when the remove has completed. You complete the operation by calling EndRemove.

Use this overload to associate information with the operation that will be preserved throughout the operation's lifetime. The event handler can detect this information by looking at the AsyncState of the IAsyncResult that is associated with the operation.

See Also

MultiFile Class | ComponentSpace.Ftp Namespace | MultiFile.BeginRemove Overload List


MultiFile.BeginRemove Method (String, Object, AsyncCallback)

Initiates an asynchronous remove remote directory that has a specified state object. This overload receives notification, through a callback, of the identity of the event handler for this operation.

[Visual Basic]
Overloads Public Function BeginRemove( _
ByVal pathName As String, _
ByVal stateObject As Object, _
ByVal asyncCallback As AsyncCallback _
) As IAsyncResult
[C#]
public IAsyncResult BeginRemove(
string pathName,
object stateObject,
AsyncCallback asyncCallback
);

Parameters

pathName
The remote directory path name.
stateObject
A state object, specified by the application, that contains information associated with the asynchronous operation.
asyncCallback
The AsyncCallback that will receive the notification of the asynchronous operation completion.

Return Value

The IAsyncResult that identifies the posted asynchronous request.

Remarks

When you use this overload, the callback specified in the callback parameter is invoked directly when the remove has completed; the RemoveCompleted event is not raised. The other overloads of BeginRemove rely on this component to raise the RemoveCompleted event.

See Also

MultiFile Class | ComponentSpace.Ftp Namespace | MultiFile.BeginRemove Overload List


BeginUpload Method

ComponentSpace FTP Class Library Reference

MultiFile.BeginUpload Method

Initiates an asynchronous upload directory.

Overload List

Initiates an asynchronous upload directory.

public IAsyncResult BeginUpload(string,string,bool,Regex,IFileFilter);

Initiates an asynchronous upload directory that has a specified state object.

public IAsyncResult BeginUpload(string,string,bool,Regex,IFileFilter,object);

Initiates an asynchronous upload directory that has a specified state object. This overload receives notification, through a callback, of the identity of the event handler for this operation.

public IAsyncResult BeginUpload(string,string,bool,Regex,IFileFilter,object,AsyncCallback);

See Also

MultiFile Class | ComponentSpace.Ftp Namespace


MultiFile.BeginUpload Method (String, String, Boolean, Regex, IFileFilter)

Initiates an asynchronous upload directory.

[Visual Basic]
Overloads Public Function BeginUpload( _
ByVal sourcePathName As String, _
ByVal destinationPathName As String, _
ByVal includeSubDirectories As Boolean, _
ByVal matchRegularExpression As Regex, _
ByVal fileFilter As IFileFilter _
) As IAsyncResult
[C#]
public IAsyncResult BeginUpload(
string sourcePathName,
string destinationPathName,
bool includeSubDirectories,
Regex matchRegularExpression,
IFileFilter fileFilter
);

Parameters

sourcePathName
The remote directory name
destinationPathName
The local directory name
includeSubDirectories
Flag indicating whether to include subdirectories
matchRegularExpression
The optional regular expression to match file names on or
null
if all files are to be included
fileFilter
The optional file filter or null if no file filtering is to be performed

Return Value

The IAsyncResult that identifies the posted asynchronous request.

Remarks

In asynchronous processing, you use BeginUpload to raise the UploadCompleted event when the upload has completed. You complete the operation by calling EndUpload.

See Also

MultiFile Class | ComponentSpace.Ftp Namespace | MultiFile.BeginUpload Overload List


MultiFile.BeginUpload Method (String, String, Boolean, Regex, IFileFilter, Object)

Initiates an asynchronous upload directory that has a specified state object.

[Visual Basic]
Overloads Public Function BeginUpload( _
ByVal sourcePathName As String, _
ByVal destinationPathName As String, _
ByVal includeSubDirectories As Boolean, _
ByVal matchRegularExpression As Regex, _
ByVal fileFilter As IFileFilter, _
ByVal stateObject As Object _
) As IAsyncResult
[C#]
public IAsyncResult BeginUpload(
string sourcePathName,
string destinationPathName,
bool includeSubDirectories,
Regex matchRegularExpression,
IFileFilter fileFilter,
object stateObject
);

Parameters

sourcePathName
The remote directory name
destinationPathName
The local directory name
includeSubDirectories
Flag indicating whether to include subdirectories
matchRegularExpression
The optional regular expression to match file names on or
null
if all files are to be included
fileFilter
The optional file filter or null if no file filtering is to be performed
stateObject
A state object, specified by the application, that contains information associated with the asynchronous operation.

Return Value

The IAsyncResult that identifies the posted asynchronous request.

Remarks

In asynchronous processing, you use BeginRemove to raise the RemoveCompleted event when the remove has completed. You complete the operation by calling EndRemove.

Use this overload to associate information with the operation that will be preserved throughout the operation's lifetime. The event handler can detect this information by looking at the AsyncState of the IAsyncResult that is associated with the operation.

See Also

MultiFile Class | ComponentSpace.Ftp Namespace | MultiFile.BeginUpload Overload List


MultiFile.BeginUpload Method (String, String, Boolean, Regex, IFileFilter, Object, AsyncCallback)

Initiates an asynchronous upload directory that has a specified state object. This overload receives notification, through a callback, of the identity of the event handler for this operation.

[Visual Basic]
Overloads Public Function BeginUpload( _
ByVal sourcePathName As String, _
ByVal destinationPathName As String, _
ByVal includeSubDirectories As Boolean, _
ByVal matchRegularExpression As Regex, _
ByVal fileFilter As IFileFilter, _
ByVal stateObject As Object, _
ByVal asyncCallback As AsyncCallback _
) As IAsyncResult
[C#]
public IAsyncResult BeginUpload(
string sourcePathName,
string destinationPathName,
bool includeSubDirectories,
Regex matchRegularExpression,
IFileFilter fileFilter,
object stateObject,
AsyncCallback asyncCallback
);

Parameters

sourcePathName
The remote directory name
destinationPathName
The local directory name
includeSubDirectories
Flag indicating whether to include subdirectories
matchRegularExpression
The optional regular expression to match file names on or
null
if all files are to be included
fileFilter
The optional file filter or null if no file filtering is to be performed
stateObject
A state object, specified by the application, that contains information associated with the asynchronous operation.
asyncCallback
The AsyncCallback that will receive the notification of the asynchronous operation completion.

Return Value

The IAsyncResult that identifies the posted asynchronous request.

Remarks

When you use this overload, the callback specified in the callback parameter is invoked directly when the remove has completed; the RemoveCompleted event is not raised. The other overloads of BeginRemove rely on this component to raise the RemoveCompleted event.

See Also

MultiFile Class | ComponentSpace.Ftp Namespace | MultiFile.BeginUpload Overload List


MultiFile.Download Method

Download a directory. The source directory, as well as its contents, are downloaded. Subdirectories may also be included. An optional regular expression and file filter to match upon also may be specified.

[Visual Basic]
Public Sub Download( _
ByVal sourcePathName As String, _
ByVal destinationPathName As String, _
ByVal includeSubDirectories As Boolean, _
ByVal matchRegularExpression As Regex, _
ByVal fileFilter As IFileFilter _
)
[C#]
public void Download(
string sourcePathName,
string destinationPathName,
bool includeSubDirectories,
Regex matchRegularExpression,
IFileFilter fileFilter
);

Parameters

sourcePathName
The remote directory name
destinationPathName
The local directory name
includeSubDirectories
Flag indicating whether to include subdirectories
matchRegularExpression
The optional regular expression to match file names on or
null
if all files are to be included
fileFilter
The optional file filter or null if no file filtering is to be performed

Remarks

If an optional regular expression is included then files available for downloading must match the regular expression.

If an optional file filter is provided then files available for downloading must be accepted by the filter.

If both a regular expression and file filter are supplied then both must match for the file to be downloaded.

Exceptions

Exception Type | Condition
FtpException | Thrown when the download fails.

See Also

MultiFile Class | ComponentSpace.Ftp Namespace


MultiFile.EndDownload Method

Completes the specified asynchronous download directory operation.

[Visual Basic]
Public Sub EndDownload( _
ByVal asyncResult As IAsyncResult _
)
[C#]
public void EndDownload(
IAsyncResult asyncResult
);

Parameters

asyncResult
The IAsyncResult that identifies the asynchronous download to finish, and from which to retrieve an end result.

Remarks

When the DownloadCompleted event is raised, EndDownload completes the operation that was initiated by the BeginDownload call.

Exceptions

Exception Type | Condition
FtpException | Thrown when the download fails.

See Also

MultiFile Class | ComponentSpace.Ftp Namespace


MultiFile.EndRemove Method

Completes the specified asynchronous remove remote directory operation.

[Visual Basic]
Public Sub EndRemove( _
ByVal asyncResult As IAsyncResult _
)
[C#]
public void EndRemove(
IAsyncResult asyncResult
);

Parameters

asyncResult
The IAsyncResult that identifies the asynchronous remove to finish, and from which to retrieve an end result.

Remarks

When the RemoveCompleted event is raised, EndRemove completes the operation that was initiated by the BeginRemove call.

Exceptions

Exception Type | Condition
FtpException | Thrown when the remove fails.

See Also

MultiFile Class | ComponentSpace.Ftp Namespace


MultiFile.EndUpload Method

Completes the specified asynchronous upload directory operation.

[Visual Basic]
Public Sub EndUpload( _
ByVal asyncResult As IAsyncResult _
)
[C#]
public void EndUpload(
IAsyncResult asyncResult
);

Parameters

asyncResult
The IAsyncResult that identifies the asynchronous upload to finish, and from which to retrieve an end result.

Remarks

When the UploadCompleted event is raised, EndUpload completes the operation that was initiated by the BeginUpload call.

Exceptions

Exception Type | Condition
FtpException | Thrown when the upload fails.

See Also

MultiFile Class | ComponentSpace.Ftp Namespace


MultiFile.Remove Method

Remove the directory and all its contents including files and subdirectories.

[Visual Basic]
Public Sub Remove( _
ByVal pathName As String _
)
[C#]
public void Remove(
string pathName
);

Parameters

pathName
The remote directory path name.

Remarks

Please exercise extreme caution when using this method.

Exceptions

Exception Type | Condition
FtpException | Thrown when the delete fails.

See Also

MultiFile Class | ComponentSpace.Ftp Namespace


MultiFile.Upload Method

Upload a directory. The source directory, as well as its contents, are uploaded. Subdirectories may also be included. An optional regular expression and file filter to match upon also may be specified.

[Visual Basic]
Public Sub Upload( _
ByVal sourcePathName As String, _
ByVal destinationPathName As String, _
ByVal includeSubDirectories As Boolean, _
ByVal matchRegularExpression As Regex, _
ByVal fileFilter As IFileFilter _
)
[C#]
public void Upload(
string sourcePathName,
string destinationPathName,
bool includeSubDirectories,
Regex matchRegularExpression,
IFileFilter fileFilter
);

Parameters

sourcePathName
The local directory name
destinationPathName
The remote directory name
includeSubDirectories
Flag indicating whether to include subdirectories
matchRegularExpression
The optional regular expression to match file names on or
null
if all files are to be included
fileFilter
The optional file filter or null if no file filtering is to be performed

Remarks

If an optional regular expression is included then files available for uploading must match the regular expression.

If an optional file filter is provided then files available for uploading must be accepted by the filter.

If both a regular expression and file filter are supplied then both must match for the file to be uploaded.

Exceptions

Exception Type | Condition
FtpException | Thrown when the upload fails.

See Also

MultiFile Class | ComponentSpace.Ftp Namespace


MultiFile Events

The events of the MultiFile class are listed below. For a complete list of MultiFile class members, see the MultiFile Members topic.

Public Instance Events

DirectoryRemoved | Occurs when a subdirectory has been removed.
DownloadCompleted | Occurs when the download directory has completed.
FileDeleted | Occurs when a file has been deleted.
FileDownloaded | Occurs when a file has been downloaded.
FileUploaded | Occurs when a file has been uploaded.
RemoveCompleted | Occurs when the remove directory has completed.
UploadCompleted | Occurs when the upload directory has completed.

See Also

MultiFile Class | ComponentSpace.Ftp Namespace


MultiFile.DirectoryRemoved Event

Occurs when a subdirectory has been removed.

[Visual Basic]
Public Event DirectoryRemoved As MultiFileEventHandler
[C#]
public event MultiFileEventHandler DirectoryRemoved;

Event Data

The event handler receives an argument of type MultiFileEventArgs containing data related to this event. The following MultiFileEventArgs property provides information specific to this event.

Property | Description
RemotePath | Gets the remote path.

Remarks

Whilst removing a directory this event will be raised for each subdirectory removed.

See Also

MultiFile Class | ComponentSpace.Ftp Namespace


MultiFile.DownloadCompleted Event

Occurs when the download directory has completed.

[Visual Basic]
Public Event DownloadCompleted As FtpOperationCompletedEventHandler
[C#]
public event FtpOperationCompletedEventHandler DownloadCompleted;

Event Data

The event handler receives an argument of type FtpOperationCompletedEventArgs containing data related to this event. The following FtpOperationCompletedEventArgs property provides information specific to this event.

Property | Description
AsyncResult | Gets the result of the asynchronous send operation.

Remarks

BeginDownload is used in asynchronous processing to raise the DownloadCompleted event when the download directory has completed.

EndDownload is used to complete the operation initiated by a call to BeginDownload and get the download directory status when the DownloadCompleted event is raised.

See Also

MultiFile Class | ComponentSpace.Ftp Namespace


MultiFile.FileDeleted Event

Occurs when a file has been deleted.

[Visual Basic]
Public Event FileDeleted As MultiFileEventHandler
[C#]
public event MultiFileEventHandler FileDeleted;

Event Data

The event handler receives an argument of type MultiFileEventArgs containing data related to this event. The following MultiFileEventArgs property provides information specific to this event.

Property | Description
RemotePath | Gets the remote path.

Remarks

Whilst removing a directory this event will be raised for each file deleted.

See Also

MultiFile Class | ComponentSpace.Ftp Namespace


MultiFile.FileDownloaded Event

Occurs when a file has been downloaded.

[Visual Basic]
Public Event FileDownloaded As MultiFileEventHandler
[C#]
public event MultiFileEventHandler FileDownloaded;

Event Data

The event handler receives an argument of type MultiFileEventArgs containing data related to this event. The following MultiFileEventArgs property provides information specific to this event.

Property | Description
RemotePath | Gets the remote path.

Remarks

Whilst downloading a directory this event will be raised for each file downloaded.

See Also

MultiFile Class | ComponentSpace.Ftp Namespace


MultiFile.FileUploaded Event

Occurs when a file has been uploaded.

[Visual Basic]
Public Event FileUploaded As MultiFileEventHandler
[C#]
public event MultiFileEventHandler FileUploaded;

Event Data

The event handler receives an argument of type MultiFileEventArgs containing data related to this event. The following MultiFileEventArgs property provides information specific to this event.

Property | Description
RemotePath | Gets the remote path.

Remarks

Whilst uploading a directory this event will be raised for each file uploaded.

See Also

MultiFile Class | ComponentSpace.Ftp Namespace


MultiFile.RemoveCompleted Event

Occurs when the remove directory has completed.

[Visual Basic]
Public Event RemoveCompleted As FtpOperationCompletedEventHandler
[C#]
public event FtpOperationCompletedEventHandler RemoveCompleted;

Event Data

The event handler receives an argument of type FtpOperationCompletedEventArgs containing data related to this event. The following FtpOperationCompletedEventArgs property provides information specific to this event.

Property | Description
AsyncResult | Gets the result of the asynchronous send operation.

Remarks

BeginRemove is used in asynchronous processing to raise the RemoveCompleted event when the remove directory has completed.

EndRemove is used to complete the operation initiated by a call to BeginRemove and get the remove directory status when the RemoveCompleted event is raised.

See Also

MultiFile Class | ComponentSpace.Ftp Namespace


MultiFile.UploadCompleted Event

Occurs when the upload directory has completed.

[Visual Basic]
Public Event UploadCompleted As FtpOperationCompletedEventHandler
[C#]
public event FtpOperationCompletedEventHandler UploadCompleted;

Event Data

The event handler receives an argument of type FtpOperationCompletedEventArgs containing data related to this event. The following FtpOperationCompletedEventArgs property provides information specific to this event.

Property | Description
AsyncResult | Gets the result of the asynchronous send operation.

Remarks

BeginUpload is used in asynchronous processing to raise the UploadCompleted event when the upload directory has completed.

EndUpload is used to complete the operation initiated by a call to BeginUpload and get the upload directory status when the UploadCompleted event is raised.

See Also

MultiFile Class | ComponentSpace.Ftp Namespace


MultiFileEventArgs Class

Provides data for the event.

For a list of all members of this type, see MultiFileEventArgs Members.

System.Object
System.EventArgs
ComponentSpace.Ftp.MultiFileEventArgs

[Visual Basic]
Public Class MultiFileEventArgs
Inherits EventArgs
[C#]
public class MultiFileEventArgs : EventArgs

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: ComponentSpace.Ftp

Assembly: ComponentSpace.Ftp (in ComponentSpace.Ftp.dll)

See Also

MultiFileEventArgs Members | ComponentSpace.Ftp Namespace


MultiFileEventArgs Members

MultiFileEventArgs overview

Public Instance Properties

RemotePath Gets the remote path.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

MultiFileEventArgs Class | ComponentSpace.Ftp Namespace


MultiFileEventArgs Properties

The properties of the MultiFileEventArgs class are listed below. For a complete list of MultiFileEventArgs class members, see the MultiFileEventArgs Members topic.

Public Instance Properties

RemotePath Gets the remote path.

See Also

MultiFileEventArgs Class | ComponentSpace.Ftp Namespace


MultiFileEventArgs.RemotePath Property

Gets the remote path.

[Visual Basic]
Public ReadOnly Property RemotePath As String
[C#]
public string RemotePath {get;}

Property Value

The remote path associated with the operation.

See Also

MultiFileEventArgs Class | ComponentSpace.Ftp Namespace


MultiFileEventHandler Delegate

Represents the method that will handle multi file events.

[Visual Basic]
Public Delegate Sub MultiFileEventHandler( _
ByVal sender As Object, _
ByVal e As MultiFileEventArgs _
)
[C#]
public delegate void MultiFileEventHandler(
object sender,
MultiFileEventArgs e
);

Parameters

sender
The source of the event.
e
A MultiFileEventArgs that contains the event data.

Remarks

When you create a MultiFileEventHandler delegate, you identify the method that will handle the event. To associate the event with your event handler, add an instance of the delegate to the event. The event handler is called whenever the event occurs, unless you remove the delegate.

Requirements

Namespace: ComponentSpace.Ftp

Assembly: ComponentSpace.Ftp (in ComponentSpace.Ftp.dll)

See Also

ComponentSpace.Ftp Namespace


NameListCommand Class

Represents the FTP NLST command.

For a list of all members of this type, see NameListCommand Members.

System.Object
ComponentSpace.Ftp.FtpCommand
ComponentSpace.Ftp.NameListCommand

[Visual Basic]
Public Class NameListCommand
Inherits FtpCommand
[C#]
public class NameListCommand : FtpCommand

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: ComponentSpace.Ftp

Assembly: ComponentSpace.Ftp (in ComponentSpace.Ftp.dll)

See Also

NameListCommand Members | ComponentSpace.Ftp Namespace


NameListCommand Members

NameListCommand overview

Public Instance Constructors

NameListCommand Overloaded. Initializes a new instance of the NameListCommand class.

Public Instance Properties

CommandType (inherited from FtpCommand) | Gets the command type.
PathName | Gets or sets the remote path name.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString | Convert the command to the FTP command text.
ToTraceString (inherited from FtpCommand) | Convert the reply to the trace text.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

NameListCommand Class | ComponentSpace.Ftp Namespace


NameListCommand Constructor

Initializes a new instance of the NameListCommand.

Overload List

Initializes a new instance of the NameListCommand.

public NameListCommand();

Initializes a new instance of the NameListCommand from the raw command text.

public NameListCommand(string);

See Also

NameListCommand Class | ComponentSpace.Ftp Namespace


NameListCommand Constructor ()

Initializes a new instance of the NameListCommand.

[Visual Basic]
Overloads Public Sub New()
[C#]
public NameListCommand();

See Also

NameListCommand Class | ComponentSpace.Ftp Namespace | NameListCommand Constructor Overload List


NameListCommand Constructor (String)

Initializes a new instance of the NameListCommand from the raw command text.

[Visual Basic]
Overloads Public Sub New( _
ByVal command As String _
)
[C#]
public NameListCommand(
string command
);

Parameters

command
The raw command text.

See Also

NameListCommand Class | ComponentSpace.Ftp Namespace | NameListCommand Constructor Overload List


NameListCommand Properties

The properties of the NameListCommand class are listed below. For a complete list of NameListCommand class members, see the NameListCommand Members topic.

Public Instance Properties

CommandType (inherited from FtpCommand) | Gets the command type.
PathName | Gets or sets the remote path name.

See Also

NameListCommand Class | ComponentSpace.Ftp Namespace


NameListCommand.PathName Property

Gets or sets the remote path name.

[Visual Basic]
Public Property PathName As String
[C#]
public string PathName {get; set;}

Property Value

The remote path name.

See Also

NameListCommand Class | ComponentSpace.Ftp Namespace


NameListCommand Methods

The methods of the NameListCommand class are listed below. For a complete list of NameListCommand class members, see the NameListCommand Members topic.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString | Convert the command to the FTP command text.
ToTraceString (inherited from FtpCommand) | Convert the reply to the trace text.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

NameListCommand Class | ComponentSpace.Ftp Namespace


NameListCommand.ToString Method

Convert the command to the FTP command text.

[Visual Basic]
Overrides Public Function ToString() As String
[C#]
public override string ToString();

Return Value

The FTP command text.

See Also

NameListCommand Class | ComponentSpace.Ftp Namespace


NoopCommand Class

Represents the FTP NOOP command.

For a list of all members of this type, see NoopCommand Members.

System.Object
ComponentSpace.Ftp.FtpCommand
ComponentSpace.Ftp.NoopCommand

[Visual Basic]
Public Class NoopCommand
Inherits FtpCommand
[C#]
public class NoopCommand : FtpCommand

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: ComponentSpace.Ftp

Assembly: ComponentSpace.Ftp (in ComponentSpace.Ftp.dll)

See Also

NoopCommand Members | ComponentSpace.Ftp Namespace


NoopCommand Members

NoopCommand overview

Public Instance Constructors

NoopCommand Overloaded. Initializes a new instance of the NoopCommand class.

Public Instance Properties

CommandType (inherited from FtpCommand) Gets the command type.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString | Convert the command to the FTP command text.
ToTraceString (inherited from FtpCommand) | Convert the reply to the trace text.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

NoopCommand Class | ComponentSpace.Ftp Namespace


NoopCommand Constructor

Initializes a new instance of the NoopCommand.

Overload List

Initializes a new instance of the NoopCommand.

public NoopCommand();

Initializes a new instance of the NoopCommand from the raw command text.

public NoopCommand(string);

See Also

NoopCommand Class | ComponentSpace.Ftp Namespace


NoopCommand Constructor ()

Initializes a new instance of the NoopCommand.

[Visual Basic]
Overloads Public Sub New()
[C#]
public NoopCommand();

See Also

NoopCommand Class | ComponentSpace.Ftp Namespace | NoopCommand Constructor Overload List


NoopCommand Constructor (String)

Initializes a new instance of the NoopCommand from the raw command text.

[Visual Basic]
Overloads Public Sub New( _
ByVal command As String _
)
[C#]
public NoopCommand(
string command
);

Parameters

command
The raw command text.

See Also

NoopCommand Class | ComponentSpace.Ftp Namespace | NoopCommand Constructor Overload List


NoopCommand Methods

The methods of the NoopCommand class are listed below. For a complete list of NoopCommand class members, see the NoopCommand Members topic.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString | Convert the command to the FTP command text.
ToTraceString (inherited from FtpCommand) | Convert the reply to the trace text.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

NoopCommand Class | ComponentSpace.Ftp Namespace


NoopCommand.ToString Method

Convert the command to the FTP command text.

[Visual Basic]
Overrides Public Function ToString() As String
[C#]
public override string ToString();

Return Value

The FTP command text.

See Also

NoopCommand Class | ComponentSpace.Ftp Namespace


PassiveCommand Class

Represents the FTP PASV command.

For a list of all members of this type, see PassiveCommand Members.

System.Object
ComponentSpace.Ftp.FtpCommand
ComponentSpace.Ftp.PassiveCommand

[Visual Basic]
Public Class PassiveCommand
Inherits FtpCommand
[C#]
public class PassiveCommand : FtpCommand

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: ComponentSpace.Ftp

Assembly: ComponentSpace.Ftp (in ComponentSpace.Ftp.dll)

See Also

PassiveCommand Members | ComponentSpace.Ftp Namespace


PassiveCommand Members

PassiveCommand overview

Public Instance Constructors

PassiveCommand Overloaded. Initializes a new instance of the PassiveCommand class.

Public Instance Properties

CommandType (inherited from FtpCommand) Gets the command type.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString | Convert the command to the FTP command text.
ToTraceString (inherited from FtpCommand) | Convert the reply to the trace text.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

PassiveCommand Class | ComponentSpace.Ftp Namespace


PassiveCommand Constructor

Initializes a new instance of the PassiveCommand.

Overload List

Initializes a new instance of the PassiveCommand.

public PassiveCommand();

Initializes a new instance of the PassiveCommand from the raw command text.

public PassiveCommand(string);

See Also

PassiveCommand Class | ComponentSpace.Ftp Namespace


PassiveCommand Constructor ()

Initializes a new instance of the PassiveCommand.

[Visual Basic]
Overloads Public Sub New()
[C#]
public PassiveCommand();

See Also

PassiveCommand Class | ComponentSpace.Ftp Namespace | PassiveCommand Constructor Overload List


PassiveCommand Constructor (String)

Initializes a new instance of the PassiveCommand from the raw command text.

[Visual Basic]
Overloads Public Sub New( _
ByVal command As String _
)
[C#]
public PassiveCommand(
string command
);

Parameters

command
The raw command text.

See Also

PassiveCommand Class | ComponentSpace.Ftp Namespace | PassiveCommand Constructor Overload List


PassiveCommand Methods

The methods of the PassiveCommand class are listed below. For a complete list of PassiveCommand class members, see the PassiveCommand Members topic.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString | Convert the command to the FTP command text.
ToTraceString (inherited from FtpCommand) | Convert the reply to the trace text.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

PassiveCommand Class | ComponentSpace.Ftp Namespace


PassiveCommand.ToString Method

Convert the command to the FTP command text.

[Visual Basic]
Overrides Public Function ToString() As String
[C#]
public override string ToString();

Return Value

The FTP command text.

See Also

PassiveCommand Class | ComponentSpace.Ftp Namespace


PasswordCommand Class

Represents the FTP PASS command.

For a list of all members of this type, see PasswordCommand Members.

System.Object
ComponentSpace.Ftp.FtpCommand
ComponentSpace.Ftp.PasswordCommand

[Visual Basic]
Public Class PasswordCommand
Inherits FtpCommand
[C#]
public class PasswordCommand : FtpCommand

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: ComponentSpace.Ftp

Assembly: ComponentSpace.Ftp (in ComponentSpace.Ftp.dll)

See Also

PasswordCommand Members | ComponentSpace.Ftp Namespace


PasswordCommand Members

PasswordCommand overview

Public Instance Constructors

PasswordCommand Overloaded. Initializes a new instance of the PasswordCommand class.

Public Instance Properties

CommandType (inherited from FtpCommand) | Gets the command type.
Password | Gets or sets the password.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString | Convert the command to the FTP command text.
ToTraceString | Convert the reply to the trace text.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

PasswordCommand Class | ComponentSpace.Ftp Namespace


PasswordCommand Constructor

Initializes a new instance of the PasswordCommand.

Overload List

Initializes a new instance of the PasswordCommand.

public PasswordCommand();

Initializes a new instance of the PasswordCommand from the raw command text.

public PasswordCommand(string);

See Also

PasswordCommand Class | ComponentSpace.Ftp Namespace


PasswordCommand Constructor ()

Initializes a new instance of the PasswordCommand.

[Visual Basic]
Overloads Public Sub New()
[C#]
public PasswordCommand();

See Also

PasswordCommand Class | ComponentSpace.Ftp Namespace | PasswordCommand Constructor Overload List


PasswordCommand Constructor (String)

Initializes a new instance of the PasswordCommand from the raw command text.

[Visual Basic]
Overloads Public Sub New( _
ByVal command As String _
)
[C#]
public PasswordCommand(
string command
);

Parameters

command
The raw command text.

See Also

PasswordCommand Class | ComponentSpace.Ftp Namespace | PasswordCommand Constructor Overload List


PasswordCommand Properties

The properties of the PasswordCommand class are listed below. For a complete list of PasswordCommand class members, see the PasswordCommand Members topic.

Public Instance Properties

CommandType (inherited from FtpCommand) | Gets the command type.
Password | Gets or sets the password.

See Also

PasswordCommand Class | ComponentSpace.Ftp Namespace


PasswordCommand.Password Property

Gets or sets the password.

[Visual Basic]
Public Property Password As String
[C#]
public string Password {get; set;}

Property Value

The password.

See Also

PasswordCommand Class | ComponentSpace.Ftp Namespace


PasswordCommand Methods

The methods of the PasswordCommand class are listed below. For a complete list of PasswordCommand class members, see the PasswordCommand Members topic.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString | Convert the command to the FTP command text.
ToTraceString | Convert the reply to the trace text.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

PasswordCommand Class | ComponentSpace.Ftp Namespace


PasswordCommand.ToString Method

Convert the command to the FTP command text.

[Visual Basic]
Overrides Public Function ToString() As String
[C#]
public override string ToString();

Return Value

The FTP command text.

See Also

PasswordCommand Class | ComponentSpace.Ftp Namespace


PasswordCommand.ToTraceString Method

Convert the reply to the trace text.

[Visual Basic]
Overrides Public Function ToTraceString() As String
[C#]
public override string ToTraceString();

Return Value

The FTP trace text.

See Also

PasswordCommand Class | ComponentSpace.Ftp Namespace


PortCommand Class

Represents the FTP PORT command.

For a list of all members of this type, see PortCommand Members.

System.Object
ComponentSpace.Ftp.FtpCommand
ComponentSpace.Ftp.PortCommand

[Visual Basic]
Public Class PortCommand
Inherits FtpCommand
[C#]
public class PortCommand : FtpCommand

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: ComponentSpace.Ftp

Assembly: ComponentSpace.Ftp (in ComponentSpace.Ftp.dll)

See Also

PortCommand Members | ComponentSpace.Ftp Namespace


PortCommand Members

PortCommand overview

Public Instance Constructors

PortCommand Overloaded. Initializes a new instance of the PortCommand class.

Public Instance Properties

CommandType (inherited from FtpCommand) | Gets the command type.
HostPort | Gets or sets the connection point.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString | Convert the command to the FTP command text.
ToTraceString (inherited from FtpCommand) | Convert the reply to the trace text.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

PortCommand Class | ComponentSpace.Ftp Namespace


PortCommand Constructor

Initializes a new instance of the PortCommand.

Overload List

Initializes a new instance of the PortCommand.

public PortCommand();

Initializes a new instance of the PortCommand from the raw command text.

public PortCommand(string);

See Also

PortCommand Class | ComponentSpace.Ftp Namespace


PortCommand Constructor ()

Initializes a new instance of the PortCommand.

[Visual Basic]
Overloads Public Sub New()
[C#]
public PortCommand();

See Also

PortCommand Class | ComponentSpace.Ftp Namespace | PortCommand Constructor Overload List


PortCommand Constructor (String)

Initializes a new instance of the PortCommand from the raw command text.

[Visual Basic]
Overloads Public Sub New( _
ByVal command As String _
)
[C#]
public PortCommand(
string command
);

Parameters

command
The raw command text.

See Also

PortCommand Class | ComponentSpace.Ftp Namespace | PortCommand Constructor Overload List


PortCommand Properties

The properties of the PortCommand class are listed below. For a complete list of PortCommand class members, see the PortCommand Members topic.

Public Instance Properties

CommandType (inherited from FtpCommand) | Gets the command type.
HostPort | Gets or sets the connection point.

See Also

PortCommand Class | ComponentSpace.Ftp Namespace


PortCommand.HostPort Property

Gets or sets the connection point.

[Visual Basic]
Public Property HostPort As IPEndPoint
[C#]
public System.Net.IPEndPoint HostPort {get; set;}

Property Value

The connection point.

See Also

PortCommand Class | ComponentSpace.Ftp Namespace


PortCommand Methods

The methods of the PortCommand class are listed below. For a complete list of PortCommand class members, see the PortCommand Members topic.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString | Convert the command to the FTP command text.
ToTraceString (inherited from FtpCommand) | Convert the reply to the trace text.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

PortCommand Class | ComponentSpace.Ftp Namespace


PortCommand.ToString Method

Convert the command to the FTP command text.

[Visual Basic]
Overrides Public Function ToString() As String
[C#]
public override string ToString();

Return Value

The FTP command text.

See Also

PortCommand Class | ComponentSpace.Ftp Namespace


PrintWorkingDirectoryCommand Class

Represents the FTP PWD command.

For a list of all members of this type, see PrintWorkingDirectoryCommand Members.

System.Object
ComponentSpace.Ftp.FtpCommand
ComponentSpace.Ftp.PrintWorkingDirectoryCommand

[Visual Basic]
Public Class PrintWorkingDirectoryCommand
Inherits FtpCommand
[C#]
public class PrintWorkingDirectoryCommand : FtpCommand

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: ComponentSpace.Ftp

Assembly: ComponentSpace.Ftp (in ComponentSpace.Ftp.dll)

See Also

PrintWorkingDirectoryCommand Members | ComponentSpace.Ftp Namespace


PrintWorkingDirectoryCommand Members

PrintWorkingDirectoryCommand overview

Public Instance Constructors

PrintWorkingDirectoryCommand Overloaded. Initializes a new instance of the PrintWorkingDirectoryCommand class.

Public Instance Properties

CommandType (inherited from FtpCommand) Gets the command type.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString | Convert the command to the FTP command text.
ToTraceString (inherited from FtpCommand) | Convert the reply to the trace text.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

PrintWorkingDirectoryCommand Class | ComponentSpace.Ftp Namespace


PrintWorkingDirectoryCommand Constructor

Initializes a new instance of the PrintWorkingDirectoryCommand.

Overload List

Initializes a new instance of the PrintWorkingDirectoryCommand.

public PrintWorkingDirectoryCommand();

Initializes a new instance of the PrintWorkingDirectoryCommand from the raw command text.

public PrintWorkingDirectoryCommand(string);

See Also

PrintWorkingDirectoryCommand Class | ComponentSpace.Ftp Namespace


PrintWorkingDirectoryCommand Constructor ()

Initializes a new instance of the PrintWorkingDirectoryCommand.

[Visual Basic]
Overloads Public Sub New()
[C#]
public PrintWorkingDirectoryCommand();

See Also

PrintWorkingDirectoryCommand Class | ComponentSpace.Ftp Namespace | PrintWorkingDirectoryCommand Constructor Overload List


PrintWorkingDirectoryCommand Constructor (String)

Initializes a new instance of the PrintWorkingDirectoryCommand from the raw command text.

[Visual Basic]
Overloads Public Sub New( _
ByVal command As String _
)
[C#]
public PrintWorkingDirectoryCommand(
string command
);

Parameters

command
The raw command text.

See Also

PrintWorkingDirectoryCommand Class | ComponentSpace.Ftp Namespace | PrintWorkingDirectoryCommand Constructor Overload List


PrintWorkingDirectoryCommand Methods

The methods of the PrintWorkingDirectoryCommand class are listed below. For a complete list of PrintWorkingDirectoryCommand class members, see the PrintWorkingDirectoryCommand Members topic.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString | Convert the command to the FTP command text.
ToTraceString (inherited from FtpCommand) | Convert the reply to the trace text.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

PrintWorkingDirectoryCommand Class | ComponentSpace.Ftp Namespace


PrintWorkingDirectoryCommand.ToString Method

Convert the command to the FTP command text.

[Visual Basic]
Overrides Public Function ToString() As String
[C#]
public override string ToString();

Return Value

The FTP command text.

See Also

PrintWorkingDirectoryCommand Class | ComponentSpace.Ftp Namespace


QuitCommand Class

Represents the FTP QUIT command.

For a list of all members of this type, see QuitCommand Members.

System.Object
ComponentSpace.Ftp.FtpCommand
ComponentSpace.Ftp.QuitCommand

[Visual Basic]
Public Class QuitCommand
Inherits FtpCommand
[C#]
public class QuitCommand : FtpCommand

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: ComponentSpace.Ftp

Assembly: ComponentSpace.Ftp (in ComponentSpace.Ftp.dll)

See Also

QuitCommand Members | ComponentSpace.Ftp Namespace


QuitCommand Members

QuitCommand overview

Public Instance Constructors

QuitCommand Overloaded. Initializes a new instance of the QuitCommand class.

Public Instance Properties

CommandType (inherited from FtpCommand) Gets the command type.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString | Convert the command to the FTP command text.
ToTraceString (inherited from FtpCommand) | Convert the reply to the trace text.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

QuitCommand Class | ComponentSpace.Ftp Namespace


QuitCommand Constructor

Initializes a new instance of the QuitCommand.

Overload List

Initializes a new instance of the QuitCommand.

public QuitCommand();

Initializes a new instance of the QuitCommand from the raw command text.

public QuitCommand(string);

See Also

QuitCommand Class | ComponentSpace.Ftp Namespace


QuitCommand Constructor ()

Initializes a new instance of the QuitCommand.

[Visual Basic]
Overloads Public Sub New()
[C#]
public QuitCommand();

See Also

QuitCommand Class | ComponentSpace.Ftp Namespace | QuitCommand Constructor Overload List


QuitCommand Constructor (String)

Initializes a new instance of the QuitCommand from the raw command text.

[Visual Basic]
Overloads Public Sub New( _
ByVal command As String _
)
[C#]
public QuitCommand(
string command
);

Parameters

command
The raw command text.

See Also

QuitCommand Class | ComponentSpace.Ftp Namespace | QuitCommand Constructor Overload List


QuitCommand Methods

The methods of the QuitCommand class are listed below. For a complete list of QuitCommand class members, see the QuitCommand Members topic.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString | Convert the command to the FTP command text.
ToTraceString (inherited from FtpCommand) | Convert the reply to the trace text.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

QuitCommand Class | ComponentSpace.Ftp Namespace


QuitCommand.ToString Method

Convert the command to the FTP command text.

[Visual Basic]
Overrides Public Function ToString() As String
[C#]
public override string ToString();

Return Value

The FTP command text.

See Also

QuitCommand Class | ComponentSpace.Ftp Namespace


ReinitializeCommand Class

Represents the FTP REIN command.

For a list of all members of this type, see ReinitializeCommand Members.

System.Object
ComponentSpace.Ftp.FtpCommand
ComponentSpace.Ftp.ReinitializeCommand

[Visual Basic]
Public Class ReinitializeCommand
Inherits FtpCommand
[C#]
public class ReinitializeCommand : FtpCommand

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: ComponentSpace.Ftp

Assembly: ComponentSpace.Ftp (in ComponentSpace.Ftp.dll)

See Also

ReinitializeCommand Members | ComponentSpace.Ftp Namespace


ReinitializeCommand Members

ReinitializeCommand overview

Public Instance Constructors

ReinitializeCommand Overloaded. Initializes a new instance of the ReinitializeCommand class.

Public Instance Properties

CommandType (inherited from FtpCommand) Gets the command type.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString | Convert the command to the FTP command text.
ToTraceString (inherited from FtpCommand) | Convert the reply to the trace text.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

ReinitializeCommand Class | ComponentSpace.Ftp Namespace


ReinitializeCommand Constructor

Initializes a new instance of the ReinitializeCommand.

Overload List

Initializes a new instance of the ReinitializeCommand.

public ReinitializeCommand();

Initializes a new instance of the ReinitializeCommand from the raw command text.

public ReinitializeCommand(string);

See Also

ReinitializeCommand Class | ComponentSpace.Ftp Namespace


ReinitializeCommand Constructor ()

Initializes a new instance of the ReinitializeCommand.

[Visual Basic]
Overloads Public Sub New()
[C#]
public ReinitializeCommand();

See Also

ReinitializeCommand Class | ComponentSpace.Ftp Namespace | ReinitializeCommand Constructor Overload List


ReinitializeCommand Constructor (String)

Initializes a new instance of the ReinitializeCommand from the raw command text.

[Visual Basic]
Overloads Public Sub New( _
ByVal command As String _
)
[C#]
public ReinitializeCommand(
string command
);

Parameters

command
The raw command text.

See Also

ReinitializeCommand Class | ComponentSpace.Ftp Namespace | ReinitializeCommand Constructor Overload List


ReinitializeCommand Methods

The methods of the ReinitializeCommand class are listed below. For a complete list of ReinitializeCommand class members, see the ReinitializeCommand Members topic.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString | Convert the command to the FTP command text.
ToTraceString (inherited from FtpCommand) | Convert the reply to the trace text.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

ReinitializeCommand Class | ComponentSpace.Ftp Namespace


ReinitializeCommand.ToString Method

Convert the command to the FTP command text.

[Visual Basic]
Overrides Public Function ToString() As String
[C#]
public override string ToString();

Return Value

The FTP command text.

See Also

ReinitializeCommand Class | ComponentSpace.Ftp Namespace


RemoteDirectory Class

Performs remote directory related commands.

For a list of all members of this type, see RemoteDirectory Members.

System.Object
ComponentSpace.Ftp.RemoteDirectory

[Visual Basic]
Public Class RemoteDirectory
[C#]
public class RemoteDirectory

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: ComponentSpace.Ftp

Assembly: ComponentSpace.Ftp (in ComponentSpace.Ftp.dll)

See Also

RemoteDirectory Members | ComponentSpace.Ftp Namespace


RemoteDirectory Members

RemoteDirectory overview

Public Instance Methods

BeginChange | Overloaded. Initiates an asynchronous change remote directory.
BeginChangeToParent | Overloaded. Initiates an asynchronous change to parent remote directory.
BeginGetCurrent | Overloaded. Initiates an asynchronous get current remote directory.
BeginList | Overloaded. Initiates an asynchronous list remote directory.
BeginMake | Overloaded. Initiates an asynchronous make remote directory.
BeginRemove | Overloaded. Initiates an asynchronous remove remote directory.
Change | Change the remote directory.
ChangeToParent | Change to the parent remote directory.
EndChange | Completes the specified asynchronous change remote directory operation.
EndChangeToParent | Completes the specified asynchronous change to parent remote directory operation.
EndGetCurrent | Completes the specified asynchronous get current remote directory operation.
EndList | Completes the specified asynchronous list remote directory operation.
EndMake | Completes the specified asynchronous make remote directory operation.
EndRemove | Completes the specified asynchronous remove remote directory operation.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
Exists | Indicate whether the remote directory exists.
GetCurrent | Return the current remote directory path name.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
List | List the contents of the remote directory. If pathName is null then the current remote directory's contents are listed.
Make | Make a new remote directory.
Remove | Remove the remote directory.
ToString (inherited from Object) | Returns a String that represents the current Object.

Public Instance Events

ChangeCompleted | Occurs when the change directory has completed.
ChangeToParentCompleted | Occurs when the change to parent directory has completed.
GetCurrentCompleted | Occurs when the get current directory has completed.
ListCompleted | Occurs when the list directory has completed.
ListLineAvailable | Occurs when a list directory line is available.
MakeCompleted | Occurs when the make directory has completed.
RemoveCompleted | Occurs when the remove directory has completed.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

RemoteDirectory Class | ComponentSpace.Ftp Namespace


RemoteDirectory Methods

The methods of the RemoteDirectory class are listed below. For a complete list of RemoteDirectory class members, see the RemoteDirectory Members topic.

Public Instance Methods

BeginChange | Overloaded. Initiates an asynchronous change remote directory.
BeginChangeToParent | Overloaded. Initiates an asynchronous change to parent remote directory.
BeginGetCurrent | Overloaded. Initiates an asynchronous get current remote directory.
BeginList | Overloaded. Initiates an asynchronous list remote directory.
BeginMake | Overloaded. Initiates an asynchronous make remote directory.
BeginRemove | Overloaded. Initiates an asynchronous remove remote directory.
Change | Change the remote directory.
ChangeToParent | Change to the parent remote directory.
EndChange | Completes the specified asynchronous change remote directory operation.
EndChangeToParent | Completes the specified asynchronous change to parent remote directory operation.
EndGetCurrent | Completes the specified asynchronous get current remote directory operation.
EndList | Completes the specified asynchronous list remote directory operation.
EndMake | Completes the specified asynchronous make remote directory operation.
EndRemove | Completes the specified asynchronous remove remote directory operation.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
Exists | Indicate whether the remote directory exists.
GetCurrent | Return the current remote directory path name.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
List | List the contents of the remote directory. If pathName is null then the current remote directory's contents are listed.
Make | Make a new remote directory.
Remove | Remove the remote directory.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

RemoteDirectory Class | ComponentSpace.Ftp Namespace


BeginChange Method

ComponentSpace FTP Class Library Reference

RemoteDirectory.BeginChange Method

Initiates an asynchronous change remote directory.

Overload List

Initiates an asynchronous change remote directory.

public IAsyncResult BeginChange(string);

Initiates an asynchronous change remote directory that has a specified state object.

public IAsyncResult BeginChange(string,object);

Initiates an asynchronous change remote directory that has a specified state object. This overload receives notification, through a callback, of the identity of the event handler for this operation.

public IAsyncResult BeginChange(string,object,AsyncCallback);

See Also

RemoteDirectory Class | ComponentSpace.Ftp Namespace


RemoteDirectory.BeginChange Method (String)

Initiates an asynchronous change remote directory.

[Visual Basic]
Overloads Public Function BeginChange( _
ByVal pathName As String _
) As IAsyncResult
[C#]
public IAsyncResult BeginChange(
string pathName
);

Parameters

pathName
The remote directory path name.

Return Value

The IAsyncResult that identifies the posted asynchronous request.

Remarks

In asynchronous processing, you use BeginChange to raise the ChangeCompleted event when the change has completed. You complete the operation by calling EndChange.

See Also

RemoteDirectory Class | ComponentSpace.Ftp Namespace | RemoteDirectory.BeginChange Overload List


RemoteDirectory.BeginChange Method (String, Object)

Initiates an asynchronous change remote directory that has a specified state object.

[Visual Basic]
Overloads Public Function BeginChange( _
ByVal pathName As String, _
ByVal stateObject As Object _
) As IAsyncResult
[C#]
public IAsyncResult BeginChange(
string pathName,
object stateObject
);

Parameters

pathName
The remote directory path name.
stateObject
A state object, specified by the application, that contains information associated with the asynchronous operation.

Return Value

The IAsyncResult that identifies the posted asynchronous request.

Remarks

In asynchronous processing, you use BeginChange to raise the ChangeCompleted event when the change has completed. You complete the operation by calling EndChange.

Use this overload to associate information with the operation that will be preserved throughout the operation's lifetime. The event handler can detect this information by looking at the AsyncState of the IAsyncResult that is associated with the operation.

See Also

RemoteDirectory Class | ComponentSpace.Ftp Namespace | RemoteDirectory.BeginChange Overload List


RemoteDirectory.BeginChange Method (String, Object, AsyncCallback)

Initiates an asynchronous change remote directory that has a specified state object. This overload receives notification, through a callback, of the identity of the event handler for this operation.

[Visual Basic]
Overloads Public Function BeginChange( _
ByVal pathName As String, _
ByVal stateObject As Object, _
ByVal asyncCallback As AsyncCallback _
) As IAsyncResult
[C#]
public IAsyncResult BeginChange(
string pathName,
object stateObject,
AsyncCallback asyncCallback
);

Parameters

pathName
The remote directory path name.
stateObject
A state object, specified by the application, that contains information associated with the asynchronous operation.
asyncCallback
The AsyncCallback that will receive the notification of the asynchronous operation completion.

Return Value

The IAsyncResult that identifies the posted asynchronous request.

Remarks

When you use this overload, the callback specified in the callback parameter is invoked directly when the change has completed; the ChangeCompleted event is not raised. The other overloads of BeginChange rely on this component to raise the ChangeCompleted event.

See Also

RemoteDirectory Class | ComponentSpace.Ftp Namespace | RemoteDirectory.BeginChange Overload List


BeginChangeToParent Method

ComponentSpace FTP Class Library Reference

RemoteDirectory.BeginChangeToParent Method

Initiates an asynchronous change to parent remote directory.

Overload List

Initiates an asynchronous change to parent remote directory.

public IAsyncResult BeginChangeToParent();

Initiates an asynchronous change to parent remote directory that has a specified state object.

public IAsyncResult BeginChangeToParent(object);

Initiates an asynchronous change to parent remote directory that has a specified state object. This overload receives notification, through a callback, of the identity of the event handler for this operation.

public IAsyncResult BeginChangeToParent(object,AsyncCallback);

See Also

RemoteDirectory Class | ComponentSpace.Ftp Namespace


RemoteDirectory.BeginChangeToParent Method ()

Initiates an asynchronous change to parent remote directory.

[Visual Basic]
Overloads Public Function BeginChangeToParent() As IAsyncResult
[C#]
public IAsyncResult BeginChangeToParent();

Return Value

The IAsyncResult that identifies the posted asynchronous request.

Remarks

In asynchronous processing, you use BeginChangeToParent to raise the ChangeToParentCompleted event when the change to parent has completed. You complete the operation by calling EndChangeToParent.

See Also

RemoteDirectory Class | ComponentSpace.Ftp Namespace | RemoteDirectory.BeginChangeToParent Overload List


RemoteDirectory.BeginChangeToParent Method (Object)

Initiates an asynchronous change to parent remote directory that has a specified state object.

[Visual Basic]
Overloads Public Function BeginChangeToParent( _
ByVal stateObject As Object _
) As IAsyncResult
[C#]
public IAsyncResult BeginChangeToParent(
object stateObject
);

Parameters

stateObject
A state object, specified by the application, that contains information associated with the asynchronous operation.

Return Value

The IAsyncResult that identifies the posted asynchronous request.

Remarks

In asynchronous processing, you use BeginChangeToParent to raise the ChangeToParentCompleted event when the change to parent has completed. You complete the operation by calling EndChangeToParent.

Use this overload to associate information with the operation that will be preserved throughout the operation's lifetime. The event handler can detect this information by looking at the AsyncState of the IAsyncResult that is associated with the operation.

See Also

RemoteDirectory Class | ComponentSpace.Ftp Namespace | RemoteDirectory.BeginChangeToParent Overload List


RemoteDirectory.BeginChangeToParent Method (Object, AsyncCallback)

Initiates an asynchronous change to parent remote directory that has a specified state object. This overload receives notification, through a callback, of the identity of the event handler for this operation.

[Visual Basic]
Overloads Public Function BeginChangeToParent( _
ByVal stateObject As Object, _
ByVal asyncCallback As AsyncCallback _
) As IAsyncResult
[C#]
public IAsyncResult BeginChangeToParent(
object stateObject,
AsyncCallback asyncCallback
);

Parameters

stateObject
A state object, specified by the application, that contains information associated with the asynchronous operation.
asyncCallback
The AsyncCallback that will receive the notification of the asynchronous operation completion.

Return Value

The IAsyncResult that identifies the posted asynchronous request.

Remarks

When you use this overload, the callback specified in the callback parameter is invoked directly when the change to parent has completed; the ChangeToParentCompleted event is not raised. The other overloads of BeginChangeToParent rely on this component to raise the ChangeToParentCompleted event.

See Also

RemoteDirectory Class | ComponentSpace.Ftp Namespace | RemoteDirectory.BeginChangeToParent Overload List


BeginGetCurrent Method

ComponentSpace FTP Class Library Reference

RemoteDirectory.BeginGetCurrent Method

Initiates an asynchronous get current remote directory.

Overload List

Initiates an asynchronous get current remote directory.

public IAsyncResult BeginGetCurrent();

Initiates an asynchronous get current remote directory that has a specified state object.

public IAsyncResult BeginGetCurrent(object);

Initiates an asynchronous get current remote directory that has a specified state object. This overload receives notification, through a callback, of the identity of the event handler for this operation.

public IAsyncResult BeginGetCurrent(object,AsyncCallback);

See Also

RemoteDirectory Class | ComponentSpace.Ftp Namespace


RemoteDirectory.BeginGetCurrent Method ()

Initiates an asynchronous get current remote directory.

[Visual Basic]
Overloads Public Function BeginGetCurrent() As IAsyncResult
[C#]
public IAsyncResult BeginGetCurrent();

Return Value

The IAsyncResult that identifies the posted asynchronous request.

Remarks

In asynchronous processing, you use BeginGetCurrent to raise the GetCurrentCompleted event when the get current has completed. You complete the operation by calling EndGetCurrent.

See Also

RemoteDirectory Class | ComponentSpace.Ftp Namespace | RemoteDirectory.BeginGetCurrent Overload List


RemoteDirectory.BeginGetCurrent Method (Object)

Initiates an asynchronous get current remote directory that has a specified state object.

[Visual Basic]
Overloads Public Function BeginGetCurrent( _
ByVal stateObject As Object _
) As IAsyncResult
[C#]
public IAsyncResult BeginGetCurrent(
object stateObject
);

Parameters

stateObject
A state object, specified by the application, that contains information associated with the asynchronous operation.

Return Value

The IAsyncResult that identifies the posted asynchronous request.

Remarks

In asynchronous processing, you use BeginGetCurrent to raise the GetCurrentCompleted event when the get current has completed. You complete the operation by calling EndGetCurrent.

Use this overload to associate information with the operation that will be preserved throughout the operation's lifetime. The event handler can detect this information by looking at the AsyncState of the IAsyncResult that is associated with the operation.

See Also

RemoteDirectory Class | ComponentSpace.Ftp Namespace | RemoteDirectory.BeginGetCurrent Overload List


RemoteDirectory.BeginGetCurrent Method (Object, AsyncCallback)

Initiates an asynchronous get current remote directory that has a specified state object. This overload receives notification, through a callback, of the identity of the event handler for this operation.

[Visual Basic]
Overloads Public Function BeginGetCurrent( _
ByVal stateObject As Object, _
ByVal asyncCallback As AsyncCallback _
) As IAsyncResult
[C#]
public IAsyncResult BeginGetCurrent(
object stateObject,
AsyncCallback asyncCallback
);

Parameters

stateObject
A state object, specified by the application, that contains information associated with the asynchronous operation.
asyncCallback
The AsyncCallback that will receive the notification of the asynchronous operation completion.

Return Value

The IAsyncResult that identifies the posted asynchronous request.

Remarks

When you use this overload, the callback specified in the callback parameter is invoked directly when the get current has completed; the GetCurrentCompleted event is not raised. The other overloads of BeginGetCurrent rely on this component to raise the GetCurrentCompleted event.

See Also

RemoteDirectory Class | ComponentSpace.Ftp Namespace | RemoteDirectory.BeginGetCurrent Overload List


BeginList Method

ComponentSpace FTP Class Library Reference

RemoteDirectory.BeginList Method

Initiates an asynchronous list remote directory.

Overload List

Initiates an asynchronous list remote directory.

public IAsyncResult BeginList(string);

Initiates an asynchronous list remote directory that has a specified state object.

public IAsyncResult BeginList(string,object);

Initiates an asynchronous list remote directory that has a specified state object. This overload receives notification, through a callback, of the identity of the event handler for this operation.

public IAsyncResult BeginList(string,object,AsyncCallback);

See Also

RemoteDirectory Class | ComponentSpace.Ftp Namespace


RemoteDirectory.BeginList Method (String)

Initiates an asynchronous list remote directory.

[Visual Basic]
Overloads Public Function BeginList( _
ByVal pathName As String _
) As IAsyncResult
[C#]
public IAsyncResult BeginList(
string pathName
);

Parameters

pathName
The remote directory path name.

Return Value

The IAsyncResult that identifies the posted asynchronous request.

Remarks

In asynchronous processing, you use BeginList to raise the ListCompleted event when the list has completed. You complete the operation by calling EndList.

See Also

RemoteDirectory Class | ComponentSpace.Ftp Namespace | RemoteDirectory.BeginList Overload List


RemoteDirectory.BeginList Method (String, Object)

Initiates an asynchronous list remote directory that has a specified state object.

[Visual Basic]
Overloads Public Function BeginList( _
ByVal pathName As String, _
ByVal stateObject As Object _
) As IAsyncResult
[C#]
public IAsyncResult BeginList(
string pathName,
object stateObject
);

Parameters

pathName
The remote directory path name.
stateObject
A state object, specified by the application, that contains information associated with the asynchronous operation.

Return Value

The IAsyncResult that identifies the posted asynchronous request.

Remarks

In asynchronous processing, you use BeginList to raise the ListCompleted event when the list has completed. You complete the operation by calling EndList.

Use this overload to associate information with the operation that will be preserved throughout the operation's lifetime. The event handler can detect this information by looking at the AsyncState of the IAsyncResult that is associated with the operation.

See Also

RemoteDirectory Class | ComponentSpace.Ftp Namespace | RemoteDirectory.BeginList Overload List


RemoteDirectory.BeginList Method (String, Object, AsyncCallback)

Initiates an asynchronous list remote directory that has a specified state object. This overload receives notification, through a callback, of the identity of the event handler for this operation.

[Visual Basic]
Overloads Public Function BeginList( _
ByVal pathName As String, _
ByVal stateObject As Object, _
ByVal asyncCallback As AsyncCallback _
) As IAsyncResult
[C#]
public IAsyncResult BeginList(
string pathName,
object stateObject,
AsyncCallback asyncCallback
);

Parameters

pathName
The remote directory path name.
stateObject
A state object, specified by the application, that contains information associated with the asynchronous operation.
asyncCallback
The AsyncCallback that will receive the notification of the asynchronous operation completion.

Return Value

The IAsyncResult that identifies the posted asynchronous request.

Remarks

When you use this overload, the callback specified in the callback parameter is invoked directly when the list has completed; the ListCompleted event is not raised. The other overloads of BeginList rely on this component to raise the ListCompleted event.

See Also

RemoteDirectory Class | ComponentSpace.Ftp Namespace | RemoteDirectory.BeginList Overload List


BeginMake Method

ComponentSpace FTP Class Library Reference

RemoteDirectory.BeginMake Method

Initiates an asynchronous make remote directory.

Overload List

Initiates an asynchronous make remote directory.

public IAsyncResult BeginMake(string);

Initiates an asynchronous make remote directory that has a specified state object.

public IAsyncResult BeginMake(string,object);

Initiates an asynchronous make remote directory that has a specified state object. This overload receives notification, through a callback, of the identity of the event handler for this operation.

public IAsyncResult BeginMake(string,object,AsyncCallback);

See Also

RemoteDirectory Class | ComponentSpace.Ftp Namespace


RemoteDirectory.BeginMake Method (String)

Initiates an asynchronous make remote directory.

[Visual Basic]
Overloads Public Function BeginMake( _
ByVal pathName As String _
) As IAsyncResult
[C#]
public IAsyncResult BeginMake(
string pathName
);

Parameters

pathName
The remote directory path name.

Return Value

The IAsyncResult that identifies the posted asynchronous request.

Remarks

In asynchronous processing, you use BeginMake to raise the MakeCompleted event when the make has completed. You complete the operation by calling EndMake.

See Also

RemoteDirectory Class | ComponentSpace.Ftp Namespace | RemoteDirectory.BeginMake Overload List


RemoteDirectory.BeginMake Method (String, Object)

Initiates an asynchronous make remote directory that has a specified state object.

[Visual Basic]
Overloads Public Function BeginMake( _
ByVal pathName As String, _
ByVal stateObject As Object _
) As IAsyncResult
[C#]
public IAsyncResult BeginMake(
string pathName,
object stateObject
);

Parameters

pathName
The remote directory path name.
stateObject
A state object, specified by the application, that contains information associated with the asynchronous operation.

Return Value

The IAsyncResult that identifies the posted asynchronous request.

Remarks

In asynchronous processing, you use BeginMake to raise the MakeCompleted event when the make has completed. You complete the operation by calling EndMake.

Use this overload to associate information with the operation that will be preserved throughout the operation's lifetime. The event handler can detect this information by looking at the AsyncState of the IAsyncResult that is associated with the operation.

See Also

RemoteDirectory Class | ComponentSpace.Ftp Namespace | RemoteDirectory.BeginMake Overload List


RemoteDirectory.BeginMake Method (String, Object, AsyncCallback)

Initiates an asynchronous make remote directory that has a specified state object. This overload receives notification, through a callback, of the identity of the event handler for this operation.

[Visual Basic]
Overloads Public Function BeginMake( _
ByVal pathName As String, _
ByVal stateObject As Object, _
ByVal asyncCallback As AsyncCallback _
) As IAsyncResult
[C#]
public IAsyncResult BeginMake(
string pathName,
object stateObject,
AsyncCallback asyncCallback
);

Parameters

pathName
The remote directory path name.
stateObject
A state object, specified by the application, that contains information associated with the asynchronous operation.
asyncCallback
The AsyncCallback that will receive the notification of the asynchronous operation completion.

Return Value

The IAsyncResult that identifies the posted asynchronous request.

Remarks

When you use this overload, the callback specified in the callback parameter is invoked directly when the make has completed; the MakeCompleted event is not raised. The other overloads of BeginMake rely on this component to raise the MakeCompleted event.

See Also

RemoteDirectory Class | ComponentSpace.Ftp Namespace | RemoteDirectory.BeginMake Overload List


BeginRemove Method

ComponentSpace FTP Class Library Reference

RemoteDirectory.BeginRemove Method

Initiates an asynchronous remove remote directory.

Overload List

Initiates an asynchronous remove remote directory.

public IAsyncResult BeginRemove(string);

Initiates an asynchronous remove remote directory that has a specified state object.

public IAsyncResult BeginRemove(string,object);

Initiates an asynchronous remove remote directory that has a specified state object. This overload receives notification, through a callback, of the identity of the event handler for this operation.

public IAsyncResult BeginRemove(string,object,AsyncCallback);

See Also

RemoteDirectory Class | ComponentSpace.Ftp Namespace


RemoteDirectory.BeginRemove Method (String)

Initiates an asynchronous remove remote directory.

[Visual Basic]
Overloads Public Function BeginRemove( _
ByVal pathName As String _
) As IAsyncResult
[C#]
public IAsyncResult BeginRemove(
string pathName
);

Parameters

pathName
The remote directory path name.

Return Value

The IAsyncResult that identifies the posted asynchronous request.

Remarks

In asynchronous processing, you use BeginRemove to raise the RemoveCompleted event when the remove has completed. You complete the operation by calling EndRemove.

See Also

RemoteDirectory Class | ComponentSpace.Ftp Namespace | RemoteDirectory.BeginRemove Overload List


RemoteDirectory.BeginRemove Method (String, Object)

Initiates an asynchronous remove remote directory that has a specified state object.

[Visual Basic]
Overloads Public Function BeginRemove( _
ByVal pathName As String, _
ByVal stateObject As Object _
) As IAsyncResult
[C#]
public IAsyncResult BeginRemove(
string pathName,
object stateObject
);

Parameters

pathName
The remote directory path name.
stateObject
A state object, specified by the application, that contains information associated with the asynchronous operation.

Return Value

The IAsyncResult that identifies the posted asynchronous request.

Remarks

In asynchronous processing, you use BeginRemove to raise the RemoveCompleted event when the remove has completed. You complete the operation by calling EndRemove.

Use this overload to associate information with the operation that will be preserved throughout the operation's lifetime. The event handler can detect this information by looking at the AsyncState of the IAsyncResult that is associated with the operation.

See Also

RemoteDirectory Class | ComponentSpace.Ftp Namespace | RemoteDirectory.BeginRemove Overload List


RemoteDirectory.BeginRemove Method (String, Object, AsyncCallback)

Initiates an asynchronous remove remote directory that has a specified state object. This overload receives notification, through a callback, of the identity of the event handler for this operation.

[Visual Basic]
Overloads Public Function BeginRemove( _
ByVal pathName As String, _
ByVal stateObject As Object, _
ByVal asyncCallback As AsyncCallback _
) As IAsyncResult
[C#]
public IAsyncResult BeginRemove(
string pathName,
object stateObject,
AsyncCallback asyncCallback
);

Parameters

pathName
The remote directory path name.
stateObject
A state object, specified by the application, that contains information associated with the asynchronous operation.
asyncCallback
The AsyncCallback that will receive the notification of the asynchronous operation completion.

Return Value

The IAsyncResult that identifies the posted asynchronous request.

Remarks

When you use this overload, the callback specified in the callback parameter is invoked directly when the remove has completed; the RemoveCompleted event is not raised. The other overloads of BeginRemove rely on this component to raise the RemoveCompleted event.

See Also

RemoteDirectory Class | ComponentSpace.Ftp Namespace | RemoteDirectory.BeginRemove Overload List


RemoteDirectory.Change Method

Change the remote directory.

[Visual Basic]
Public Sub Change( _
ByVal pathName As String _
)
[C#]
public void Change(
string pathName
);

Parameters

pathName
The remote directory path name.

Exceptions

Exception Type | Condition
FtpException | Thrown when the change directory fails.

See Also

RemoteDirectory Class | ComponentSpace.Ftp Namespace


RemoteDirectory.ChangeToParent Method

Change to the parent remote directory.

[Visual Basic]
Public Sub ChangeToParent()
[C#]
public void ChangeToParent();

Exceptions

Exception Type | Condition
FtpException | Thrown when the change directory fails.

See Also

RemoteDirectory Class | ComponentSpace.Ftp Namespace


RemoteDirectory.EndChange Method

Completes the specified asynchronous change remote directory operation.

[Visual Basic]
Public Sub EndChange( _
ByVal asyncResult As IAsyncResult _
)
[C#]
public void EndChange(
IAsyncResult asyncResult
);

Parameters

asyncResult
The IAsyncResult that identifies the asynchronous change to finish, and from which to retrieve an end result.

Remarks

When the ChangeCompleted event is raised, EndChange completes the operation that was initiated by the BeginChange call.

Exceptions

Exception Type | Condition
FtpException | Thrown when the change fails.

See Also

RemoteDirectory Class | ComponentSpace.Ftp Namespace


RemoteDirectory.EndChangeToParent Method

Completes the specified asynchronous change to parent remote directory operation.

[Visual Basic]
Public Sub EndChangeToParent( _
ByVal asyncResult As IAsyncResult _
)
[C#]
public void EndChangeToParent(
IAsyncResult asyncResult
);

Parameters

asyncResult
The IAsyncResult that identifies the asynchronous change to parent to finish, and from which to retrieve an end result.

Remarks

When the ChangeToParentCompleted event is raised, EndChangeToParent completes the operation that was initiated by the BeginChangeToParent call.

Exceptions

Exception Type | Condition
FtpException | Thrown when the change to parent fails.

See Also

RemoteDirectory Class | ComponentSpace.Ftp Namespace


RemoteDirectory.EndGetCurrent Method

Completes the specified asynchronous get current remote directory operation.

[Visual Basic]
Public Function EndGetCurrent( _
ByVal asyncResult As IAsyncResult _
) As String
[C#]
public string EndGetCurrent(
IAsyncResult asyncResult
);

Parameters

asyncResult
The IAsyncResult that identifies the asynchronous get current to finish, and from which to retrieve an end result.

Return Value

The current remote directory path name.

Remarks

When the GetCurrentCompleted event is raised, EndGetCurrent completes the operation that was initiated by the BeginGetCurrent call.

Exceptions

Exception Type | Condition
FtpException | Thrown when the get current fails.

See Also

RemoteDirectory Class | ComponentSpace.Ftp Namespace


RemoteDirectory.EndList Method

Completes the specified asynchronous list remote directory operation.

[Visual Basic]
Public Function EndList( _
ByVal asyncResult As IAsyncResult _
) As String()
[C#]
public string[] EndList(
IAsyncResult asyncResult
);

Parameters

asyncResult
The IAsyncResult that identifies the asynchronous list to finish, and from which to retrieve an end result.

Return Value

The remote directory contents list.

Remarks

When the ListCompleted event is raised, EndList completes the operation that was initiated by the BeginList call.

Exceptions

Exception Type | Condition
FtpException | Thrown when the list fails.

See Also

RemoteDirectory Class | ComponentSpace.Ftp Namespace


RemoteDirectory.EndMake Method

Completes the specified asynchronous make remote directory operation.

[Visual Basic]
Public Sub EndMake( _
ByVal asyncResult As IAsyncResult _
)
[C#]
public void EndMake(
IAsyncResult asyncResult
);

Parameters

asyncResult
The IAsyncResult that identifies the asynchronous make to finish, and from which to retrieve an end result.

Remarks

When the MakeCompleted event is raised, EndMake completes the operation that was initiated by the BeginMake call.

Exceptions

Exception Type | Condition
FtpException | Thrown when the make fails.

See Also

RemoteDirectory Class | ComponentSpace.Ftp Namespace


RemoteDirectory.EndRemove Method

Completes the specified asynchronous remove remote directory operation.

[Visual Basic]
Public Sub EndRemove( _
ByVal asyncResult As IAsyncResult _
)
[C#]
public void EndRemove(
IAsyncResult asyncResult
);

Parameters

asyncResult
The IAsyncResult that identifies the asynchronous remove to finish, and from which to retrieve an end result.

Remarks

When the RemoveCompleted event is raised, EndRemove completes the operation that was initiated by the BeginRemove call.

Exceptions

Exception Type | Condition
FtpException | Thrown when the remove fails.

See Also

RemoteDirectory Class | ComponentSpace.Ftp Namespace


RemoteDirectory.Exists Method

Indicate whether the remote directory exists.

[Visual Basic]
Public Function Exists( _
ByVal pathName As String _
) As Boolean
[C#]
public bool Exists(
string pathName
);

Parameters

pathName
The remote directory path name.

Return Value

true if the remote directory exists, false otherwise.

Exceptions

Exception Type | Condition
FtpException | Thrown when the check for remote directory existence fails.

See Also

RemoteDirectory Class | ComponentSpace.Ftp Namespace


RemoteDirectory.GetCurrent Method

Return the current remote directory path name.

[Visual Basic]
Public Function GetCurrent() As String
[C#]
public string GetCurrent();

Return Value

The current remote directory path name.

Exceptions

Exception Type | Condition
FtpException | Thrown when the get current directory fails.

See Also

RemoteDirectory Class | ComponentSpace.Ftp Namespace


RemoteDirectory.List Method

List the contents of the remote directory. If pathName is null then the current remote directory's contents are listed.

[Visual Basic]
Public Function List( _
ByVal pathName As String _
) As String()
[C#]
public string[] List(
string pathName
);

Parameters

pathName
The remote directory path name.

Return Value

The remote directory contents list.

Exceptions

Exception Type | Condition
FtpException | Thrown when the list directory fails.

See Also

RemoteDirectory Class | ComponentSpace.Ftp Namespace


RemoteDirectory.Make Method

Make a new remote directory.

[Visual Basic]
Public Sub Make( _
ByVal pathName As String _
)
[C#]
public void Make(
string pathName
);

Parameters

pathName
The remote directory path name.

Exceptions

Exception Type | Condition
FtpException | Thrown when the make directory fails.

See Also

RemoteDirectory Class | ComponentSpace.Ftp Namespace


RemoteDirectory.Remove Method

Remove the remote directory.

[Visual Basic]
Public Sub Remove( _
ByVal pathName As String _
)
[C#]
public void Remove(
string pathName
);

Parameters

pathName
The remote directory path name.

Remarks

The directory must be empty. To remove a non-empty directory see MultiFile.Remove

Exceptions

Exception Type | Condition
FtpException | Thrown when the remove directory fails.

See Also

RemoteDirectory Class | ComponentSpace.Ftp Namespace | MultiFile


RemoteDirectory Events

The events of the RemoteDirectory class are listed below. For a complete list of RemoteDirectory class members, see the RemoteDirectory Members topic.

Public Instance Events

ChangeCompleted | Occurs when the change directory has completed.
ChangeToParentCompleted | Occurs when the change to parent directory has completed.
GetCurrentCompleted | Occurs when the get current directory has completed.
ListCompleted | Occurs when the list directory has completed.
ListLineAvailable | Occurs when a list directory line is available.
MakeCompleted | Occurs when the make directory has completed.
RemoveCompleted | Occurs when the remove directory has completed.

See Also

RemoteDirectory Class | ComponentSpace.Ftp Namespace


RemoteDirectory.ChangeCompleted Event

Occurs when the change directory has completed.

[Visual Basic]
Public Event ChangeCompleted As FtpOperationCompletedEventHandler
[C#]
public event FtpOperationCompletedEventHandler ChangeCompleted;

Event Data

The event handler receives an argument of type FtpOperationCompletedEventArgs containing data related to this event. The following FtpOperationCompletedEventArgs property provides information specific to this event.

Property | Description
AsyncResult | Gets the result of the asynchronous send operation.

Remarks

BeginChange is used in asynchronous processing to raise the ChangeCompleted event when the change directory has completed.

EndChange is used to complete the operation initiated by a call to BeginChange and get the change directory status when the ChangeCompleted event is raised.

See Also

RemoteDirectory Class | ComponentSpace.Ftp Namespace


RemoteDirectory.ChangeToParentCompleted Event

Occurs when the change to parent directory has completed.

[Visual Basic]
Public Event ChangeToParentCompleted As FtpOperationCompletedEventHandler
[C#]
public event FtpOperationCompletedEventHandler ChangeToParentCompleted;

Event Data

The event handler receives an argument of type FtpOperationCompletedEventArgs containing data related to this event. The following FtpOperationCompletedEventArgs property provides information specific to this event.

Property | Description
AsyncResult | Gets the result of the asynchronous send operation.

Remarks

BeginChangeToParent is used in asynchronous processing to raise the ChangeToParentCompleted event when the change to parent directory has completed.

EndChangeToParent is used to complete the operation initiated by a call to BeginChangeToParent and get the change to parent directory status when the ChangeToParentCompleted event is raised.

See Also

RemoteDirectory Class | ComponentSpace.Ftp Namespace


RemoteDirectory.GetCurrentCompleted Event

Occurs when the get current directory has completed.

[Visual Basic]
Public Event GetCurrentCompleted As FtpOperationCompletedEventHandler
[C#]
public event FtpOperationCompletedEventHandler GetCurrentCompleted;

Event Data

The event handler receives an argument of type FtpOperationCompletedEventArgs containing data related to this event. The following FtpOperationCompletedEventArgs property provides information specific to this event.

Property | Description
AsyncResult | Gets the result of the asynchronous send operation.

Remarks

BeginGetCurrent is used in asynchronous processing to raise the GetCurrentCompleted event when the change directory has completed.

EndGetCurrent is used to complete the operation initiated by a call to BeginGetCurrent and get the change directory status when the GetCurrentCompleted event is raised.

See Also

RemoteDirectory Class | ComponentSpace.Ftp Namespace


RemoteDirectory.ListCompleted Event

Occurs when the list directory has completed.

[Visual Basic]
Public Event ListCompleted As FtpOperationCompletedEventHandler
[C#]
public event FtpOperationCompletedEventHandler ListCompleted;

Event Data

The event handler receives an argument of type FtpOperationCompletedEventArgs containing data related to this event. The following FtpOperationCompletedEventArgs property provides information specific to this event.

Property | Description
AsyncResult | Gets the result of the asynchronous send operation.

Remarks

BeginList is used in asynchronous processing to raise the ListCompleted event when the list directory has completed.

EndList is used to complete the operation initiated by a call to BeginList and get the list directory status when the ListCompleted event is raised.

See Also

RemoteDirectory Class | ComponentSpace.Ftp Namespace


RemoteDirectory.ListLineAvailable Event

Occurs when a list directory line is available.

[Visual Basic]
Public Event ListLineAvailable As ListLineAvailableEventHandler
[C#]
public event ListLineAvailableEventHandler ListLineAvailable;

Event Data

The event handler receives an argument of type ListLineAvailableEventArgs containing data related to this event. The following ListLineAvailableEventArgs property provides information specific to this event.

Property | Description
ListLine | Gets the list line.

Remarks

Whilst listing a directory this event will be raised for each list line received. This may be useful for presenting the list lines in a timely fashion to the user.

See Also

RemoteDirectory Class | ComponentSpace.Ftp Namespace


RemoteDirectory.MakeCompleted Event

Occurs when the make directory has completed.

[Visual Basic]
Public Event MakeCompleted As FtpOperationCompletedEventHandler
[C#]
public event FtpOperationCompletedEventHandler MakeCompleted;

Event Data

The event handler receives an argument of type FtpOperationCompletedEventArgs containing data related to this event. The following FtpOperationCompletedEventArgs property provides information specific to this event.

Property | Description
AsyncResult | Gets the result of the asynchronous send operation.

Remarks

BeginMake is used in asynchronous processing to raise the MakeCompleted event when the make directory has completed.

EndMake is used to complete the operation initiated by a call to BeginMake and get the make directory status when the MakeCompleted event is raised.

See Also

RemoteDirectory Class | ComponentSpace.Ftp Namespace


RemoteDirectory.RemoveCompleted Event

Occurs when the remove directory has completed.

[Visual Basic]
Public Event RemoveCompleted As FtpOperationCompletedEventHandler
[C#]
public event FtpOperationCompletedEventHandler RemoveCompleted;

Event Data

The event handler receives an argument of type FtpOperationCompletedEventArgs containing data related to this event. The following FtpOperationCompletedEventArgs property provides information specific to this event.

Property | Description
AsyncResult | Gets the result of the asynchronous send operation.

Remarks

BeginRemove is used in asynchronous processing to raise the RemoveCompleted event when the remove directory has completed.

EndRemove is used to complete the operation initiated by a call to BeginRemove and get the remove directory status when the RemoveCompleted event is raised.

See Also

RemoteDirectory Class | ComponentSpace.Ftp Namespace


RemoteFile Class

Performs remote file related commands.

For a list of all members of this type, see RemoteFile Members.

System.Object
ComponentSpace.Ftp.RemoteFile

[Visual Basic]
Public Class RemoteFile
[C#]
public class RemoteFile

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: ComponentSpace.Ftp

Assembly: ComponentSpace.Ftp (in ComponentSpace.Ftp.dll)

See Also

RemoteFile Members | ComponentSpace.Ftp Namespace


RemoteFile Members

RemoteFile overview

Public Instance Properties

TransferMode | Gets or sets the file transfer mode (ASCII or binary).
UseRemoteFileTime | Gets or sets the flag indicating whether, on a download, the local file's date/time properties are set to that of the remote file. If not set then the local file's date/time properties will be the current local time.

Public Instance Methods

Append | Overloaded. Append the local file's contents to the remote file.
BeginAppend | Overloaded. Initiates an asynchronous append remote file.
BeginDelete | Overloaded. Initiates an asynchronous delete remote file.
BeginDownload | Overloaded. Initiates an asynchronous download remote file.
BeginGetModificationTime | Overloaded. Initiates an asynchronous get file modification time operation.
BeginList | Overloaded. Initiates an asynchronous list remote file.
BeginRename | Overloaded. Initiates an asynchronous rename remote file.
BeginRestartDownload | Overloaded. Initiates an asynchronous restart download remote file. The restartMarker specifies the write position in the remote file.
BeginRestartUpload | Overloaded. Initiates an asynchronous restart upload remote file. The restartMarker specifies the write position in the remote file.
BeginUpload | Overloaded. Initiates an asynchronous upload remote file.
Delete | Delete the remote file.
Download | Overloaded. Download the remote file's contents to the local file.
EndAppend | Completes the specified asynchronous append remote file operation.
EndDelete | Completes the specified asynchronous delete remote file operation.
EndDownload | Completes the specified asynchronous download remote file operation.
EndGetModificationTime | Completes the specified asynchronous get file modification time operation.
EndList | Completes the specified asynchronous list remote file operation.
EndRename | Completes the specified asynchronous rename remote file operation.
EndRestartDownload | Completes the specified asynchronous restart download remote file operation.
EndRestartUpload | Completes the specified asynchronous restart upload remote file operation.
EndUpload | Completes the specified asynchronous upload remote file operation.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
Exists | Indicate whether the remote file exists.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetModificationTime | Get the modification time of the remote file.
GetType (inherited from Object) | Gets the Type of the current instance.
List | Get remote file information.
Rename | Rename the remote file.
RestartDownload | Overloaded. Restart the download of the remote file's contents to the local file. The restartMarker specifies the read position in the remote file.
RestartUpload | Overloaded. Restart the upload of the local file's contents to the remote file. The restartMarker specifies the write position in the remote file.
ToString (inherited from Object) | Returns a String that represents the current Object.
Upload | Overloaded. Upload the local file's contents to the remote file. If destinationPathName is null then a unique name is generated on the remote server.

Public Instance Events

AppendCompleted | Occurs when the append file has completed.
DataTransferred | Occurs at intervals to indicate how many bytes in total have been transferred during the current data transfer. This event may be used provide feedback during data transfers.
DeleteCompleted | Occurs when the delete file has completed.
DownloadCompleted | Occurs when the download file has completed.
GetModificationTimeCompleted | Occurs when the get file modification time operation has completed.
ListCompleted | Occurs when the list file has completed.
RenameCompleted | Occurs when the rename file has completed.
RestartDownloadCompleted | Occurs when the restart download file has completed.
RestartUploadCompleted | Occurs when the restart upload file has completed.
UploadCompleted | Occurs when the upload file has completed.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

RemoteFile Class | ComponentSpace.Ftp Namespace


RemoteFile Properties

The properties of the RemoteFile class are listed below. For a complete list of RemoteFile class members, see the RemoteFile Members topic.

Public Instance Properties

TransferMode | Gets or sets the file transfer mode (ASCII or binary).
UseRemoteFileTime | Gets or sets the flag indicating whether, on a download, the local file's date/time properties are set to that of the remote file. If not set then the local file's date/time properties will be the current local time.

See Also

RemoteFile Class | ComponentSpace.Ftp Namespace


RemoteFile.TransferMode Property

Gets or sets the file transfer mode (ASCII or binary).

[Visual Basic]
Public Property TransferMode As TransferMode
[C#]
public TransferMode TransferMode {get; set;}

Property Value

The file transfer mode. The default is ASCII.

See Also

RemoteFile Class | ComponentSpace.Ftp Namespace


RemoteFile.UseRemoteFileTime Property

Gets or sets the flag indicating whether, on a download, the local file's date/time properties are set to that of the remote file. If not set then the local file's date/time properties will be the current local time.

[Visual Basic]
Public Property UseRemoteFileTime As Boolean
[C#]
public bool UseRemoteFileTime {get; set;}

Property Value

true if local time is to be set; false if local time is not to be set. The default is false.

Remarks

If set, the local file's creation, last write, and last access time will be set to the date and time associated with the remote file.

Be aware that the remote file's date and time are used as is. No allowance is made for time zone or clock discrepencies between the client and server machines.

See Also

RemoteFile Class | ComponentSpace.Ftp Namespace


RemoteFile Methods

The methods of the RemoteFile class are listed below. For a complete list of RemoteFile class members, see the RemoteFile Members topic.

Public Instance Methods

Append | Overloaded. Append the local file's contents to the remote file.
BeginAppend | Overloaded. Initiates an asynchronous append remote file.
BeginDelete | Overloaded. Initiates an asynchronous delete remote file.
BeginDownload | Overloaded. Initiates an asynchronous download remote file.
BeginGetModificationTime | Overloaded. Initiates an asynchronous get file modification time operation.
BeginList | Overloaded. Initiates an asynchronous list remote file.
BeginRename | Overloaded. Initiates an asynchronous rename remote file.
BeginRestartDownload | Overloaded. Initiates an asynchronous restart download remote file. The restartMarker specifies the write position in the remote file.
BeginRestartUpload | Overloaded. Initiates an asynchronous restart upload remote file. The restartMarker specifies the write position in the remote file.
BeginUpload | Overloaded. Initiates an asynchronous upload remote file.
Delete | Delete the remote file.
Download | Overloaded. Download the remote file's contents to the local file.
EndAppend | Completes the specified asynchronous append remote file operation.
EndDelete | Completes the specified asynchronous delete remote file operation.
EndDownload | Completes the specified asynchronous download remote file operation.
EndGetModificationTime | Completes the specified asynchronous get file modification time operation.
EndList | Completes the specified asynchronous list remote file operation.
EndRename | Completes the specified asynchronous rename remote file operation.
EndRestartDownload | Completes the specified asynchronous restart download remote file operation.
EndRestartUpload | Completes the specified asynchronous restart upload remote file operation.
EndUpload | Completes the specified asynchronous upload remote file operation.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
Exists | Indicate whether the remote file exists.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetModificationTime | Get the modification time of the remote file.
GetType (inherited from Object) | Gets the Type of the current instance.
List | Get remote file information.
Rename | Rename the remote file.
RestartDownload | Overloaded. Restart the download of the remote file's contents to the local file. The restartMarker specifies the read position in the remote file.
RestartUpload | Overloaded. Restart the upload of the local file's contents to the remote file. The restartMarker specifies the write position in the remote file.
ToString (inherited from Object) | Returns a String that represents the current Object.
Upload | Overloaded. Upload the local file's contents to the remote file. If destinationPathName is null then a unique name is generated on the remote server.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

RemoteFile Class | ComponentSpace.Ftp Namespace


Append Method

ComponentSpace FTP Class Library Reference

RemoteFile.Append Method

Append the data stream's contents to the remote file.

Overload List

Append the data stream's contents to the remote file.

public void Append(Stream,string);

Append the local file's contents to the remote file.

public void Append(string,string);

See Also

RemoteFile Class | ComponentSpace.Ftp Namespace


RemoteFile.Append Method (Stream, String)

Append the data stream's contents to the remote file.

[Visual Basic]
Overloads Public Sub Append( _
ByVal sourceData As Stream, _
ByVal destinationPathName As String _
)
[C#]
public void Append(
Stream sourceData,
string destinationPathName
);

Parameters

sourceData
The source data stream.
destinationPathName
The remote file name.

Exceptions

Exception Type | Condition
FtpException | Thrown when the append fails.

See Also

RemoteFile Class | ComponentSpace.Ftp Namespace | RemoteFile.Append Overload List


RemoteFile.Append Method (String, String)

Append the local file's contents to the remote file.

[Visual Basic]
Overloads Public Sub Append( _
ByVal sourcePathName As String, _
ByVal destinationPathName As String _
)
[C#]
public void Append(
string sourcePathName,
string destinationPathName
);

Parameters

sourcePathName
The local file name.
destinationPathName
The remote file name.

Exceptions

Exception Type | Condition
FtpException | Thrown when the append fails.

See Also

RemoteFile Class | ComponentSpace.Ftp Namespace | RemoteFile.Append Overload List


BeginAppend Method

ComponentSpace FTP Class Library Reference

RemoteFile.BeginAppend Method

Initiates an asynchronous append remote file.

Overload List

Initiates an asynchronous append remote file.

public IAsyncResult BeginAppend(Stream,string);

Initiates an asynchronous append remote file that has a specified state object.

public IAsyncResult BeginAppend(Stream,string,object);

Initiates an asynchronous append remote file that has a specified state object. This overload receives notification, through a callback, of the identity of the event handler for this operation.

public IAsyncResult BeginAppend(Stream,string,object,AsyncCallback);

Initiates an asynchronous append remote file.

public IAsyncResult BeginAppend(string,string);

Initiates an asynchronous append remote file that has a specified state object.

public IAsyncResult BeginAppend(string,string,object);

Initiates an asynchronous append remote file that has a specified state object. This overload receives notification, through a callback, of the identity of the event handler for this operation.

public IAsyncResult BeginAppend(string,string,object,AsyncCallback);

See Also

RemoteFile Class | ComponentSpace.Ftp Namespace


RemoteFile.BeginAppend Method (Stream, String)

Initiates an asynchronous append remote file.

[Visual Basic]
Overloads Public Function BeginAppend( _
ByVal sourceData As Stream, _
ByVal destinationPathName As String _
) As IAsyncResult
[C#]
public IAsyncResult BeginAppend(
Stream sourceData,
string destinationPathName
);

Parameters

sourceData
The source data stream.
destinationPathName
The remote file name.

Return Value

The IAsyncResult that identifies the posted asynchronous request.

Remarks

In asynchronous processing, you use BeginAppend to raise the AppendCompleted event when the append has completed. You complete the operation by calling EndAppend.

See Also

RemoteFile Class | ComponentSpace.Ftp Namespace | RemoteFile.BeginAppend Overload List


RemoteFile.BeginAppend Method (Stream, String, Object)

Initiates an asynchronous append remote file that has a specified state object.

[Visual Basic]
Overloads Public Function BeginAppend( _
ByVal sourceData As Stream, _
ByVal destinationPathName As String, _
ByVal stateObject As Object _
) As IAsyncResult
[C#]
public IAsyncResult BeginAppend(
Stream sourceData,
string destinationPathName,
object stateObject
);

Parameters

sourceData
The source data stream.
destinationPathName
The remote file name.
stateObject
A state object, specified by the application, that contains information associated with the asynchronous operation.

Return Value

The IAsyncResult that identifies the posted asynchronous request.

Remarks

In asynchronous processing, you use BeginAppend to raise the AppendCompleted event when the append has completed. You complete the operation by calling EndAppend.

Use this overload to associate information with the operation that will be preserved throughout the operation's lifetime. The event handler can detect this information by looking at the AsyncState of the IAsyncResult that is associated with the operation.

See Also

RemoteFile Class | ComponentSpace.Ftp Namespace | RemoteFile.BeginAppend Overload List


RemoteFile.BeginAppend Method (Stream, String, Object, AsyncCallback)

Initiates an asynchronous append remote file that has a specified state object. This overload receives notification, through a callback, of the identity of the event handler for this operation.

[Visual Basic]
Overloads Public Function BeginAppend( _
ByVal sourceData As Stream, _
ByVal destinationPathName As String, _
ByVal stateObject As Object, _
ByVal asyncCallback As AsyncCallback _
) As IAsyncResult
[C#]
public IAsyncResult BeginAppend(
Stream sourceData,
string destinationPathName,
object stateObject,
AsyncCallback asyncCallback
);

Parameters

sourceData
The source data stream.
destinationPathName
The remote file name.
stateObject
A state object, specified by the application, that contains information associated with the asynchronous operation.
asyncCallback
The AsyncCallback that will receive the notification of the asynchronous operation completion.

Return Value

The IAsyncResult that identifies the posted asynchronous request.

Remarks

When you use this overload, the callback specified in the callback parameter is invoked directly when the append has completed; the AppendCompleted event is not raised. The other overloads of BeginAppend rely on this component to raise the AppendCompleted event.

See Also

RemoteFile Class | ComponentSpace.Ftp Namespace | RemoteFile.BeginAppend Overload List


RemoteFile.BeginAppend Method (String, String)

Initiates an asynchronous append remote file.

[Visual Basic]
Overloads Public Function BeginAppend( _
ByVal sourcePathName As String, _
ByVal destinationPathName As String _
) As IAsyncResult
[C#]
public IAsyncResult BeginAppend(
string sourcePathName,
string destinationPathName
);

Parameters

sourcePathName
The local file name.
destinationPathName
The remote file name.

Return Value

The IAsyncResult that identifies the posted asynchronous request.

Remarks

In asynchronous processing, you use BeginAppend to raise the AppendCompleted event when the append has completed. You complete the operation by calling EndAppend.

See Also

RemoteFile Class | ComponentSpace.Ftp Namespace | RemoteFile.BeginAppend Overload List


RemoteFile.BeginAppend Method (String, String, Object)

Initiates an asynchronous append remote file that has a specified state object.

[Visual Basic]
Overloads Public Function BeginAppend( _
ByVal sourcePathName As String, _
ByVal destinationPathName As String, _
ByVal stateObject As Object _
) As IAsyncResult
[C#]
public IAsyncResult BeginAppend(
string sourcePathName,
string destinationPathName,
object stateObject
);

Parameters

sourcePathName
The local file name.
destinationPathName
The remote file name.
stateObject
A state object, specified by the application, that contains information associated with the asynchronous operation.

Return Value

The IAsyncResult that identifies the posted asynchronous request.

Remarks

In asynchronous processing, you use BeginAppend to raise the AppendCompleted event when the append has completed. You complete the operation by calling EndAppend.

Use this overload to associate information with the operation that will be preserved throughout the operation's lifetime. The event handler can detect this information by looking at the AsyncState of the IAsyncResult that is associated with the operation.

See Also

RemoteFile Class | ComponentSpace.Ftp Namespace | RemoteFile.BeginAppend Overload List


RemoteFile.BeginAppend Method (String, String, Object, AsyncCallback)

Initiates an asynchronous append remote file that has a specified state object. This overload receives notification, through a callback, of the identity of the event handler for this operation.

[Visual Basic]
Overloads Public Function BeginAppend( _
ByVal sourcePathName As String, _
ByVal destinationPathName As String, _
ByVal stateObject As Object, _
ByVal asyncCallback As AsyncCallback _
) As IAsyncResult
[C#]
public IAsyncResult BeginAppend(
string sourcePathName,
string destinationPathName,
object stateObject,
AsyncCallback asyncCallback
);

Parameters

sourcePathName
The local file name.
destinationPathName
The remote file name.
stateObject
A state object, specified by the application, that contains information associated with the asynchronous operation.
asyncCallback
The AsyncCallback that will receive the notification of the asynchronous operation completion.

Return Value

The IAsyncResult that identifies the posted asynchronous request.

Remarks

When you use this overload, the callback specified in the callback parameter is invoked directly when the append has completed; the AppendCompleted event is not raised. The other overloads of BeginAppend rely on this component to raise the AppendCompleted event.

See Also

RemoteFile Class | ComponentSpace.Ftp Namespace | RemoteFile.BeginAppend Overload List


BeginDelete Method

ComponentSpace FTP Class Library Reference

RemoteFile.BeginDelete Method

Initiates an asynchronous delete remote file.

Overload List

Initiates an asynchronous delete remote file.

public IAsyncResult BeginDelete(string);

Initiates an asynchronous delete remote file that has a specified state object.

public IAsyncResult BeginDelete(string,object);

Initiates an asynchronous delete remote file that has a specified state object. This overload receives notification, through a callback, of the identity of the event handler for this operation.

public IAsyncResult BeginDelete(string,object,AsyncCallback);

See Also

RemoteFile Class | ComponentSpace.Ftp Namespace


RemoteFile.BeginDelete Method (String)

Initiates an asynchronous delete remote file.

[Visual Basic]
Overloads Public Function BeginDelete( _
ByVal pathName As String _
) As IAsyncResult
[C#]
public IAsyncResult BeginDelete(
string pathName
);

Parameters

pathName
The remote file path name.

Return Value

The IAsyncResult that identifies the posted asynchronous request.

Remarks

In asynchronous processing, you use BeginDelete to raise the DeleteCompleted event when the delete has completed. You complete the operation by calling EndDelete.

See Also

RemoteFile Class | ComponentSpace.Ftp Namespace | RemoteFile.BeginDelete Overload List


RemoteFile.BeginDelete Method (String, Object)

Initiates an asynchronous delete remote file that has a specified state object.

[Visual Basic]
Overloads Public Function BeginDelete( _
ByVal pathName As String, _
ByVal stateObject As Object _
) As IAsyncResult
[C#]
public IAsyncResult BeginDelete(
string pathName,
object stateObject
);

Parameters

pathName
The remote file path name.
stateObject
A state object, specified by the application, that contains information associated with the asynchronous operation.

Return Value

The IAsyncResult that identifies the posted asynchronous request.

Remarks

In asynchronous processing, you use BeginDelete to raise the DeleteCompleted event when the delete has completed. You complete the operation by calling EndDelete.

Use this overload to associate information with the operation that will be preserved throughout the operation's lifetime. The event handler can detect this information by looking at the AsyncState of the IAsyncResult that is associated with the operation.

See Also

RemoteFile Class | ComponentSpace.Ftp Namespace | RemoteFile.BeginDelete Overload List


RemoteFile.BeginDelete Method (String, Object, AsyncCallback)

Initiates an asynchronous delete remote file that has a specified state object. This overload receives notification, through a callback, of the identity of the event handler for this operation.

[Visual Basic]
Overloads Public Function BeginDelete( _
ByVal pathName As String, _
ByVal stateObject As Object, _
ByVal asyncCallback As AsyncCallback _
) As IAsyncResult
[C#]
public IAsyncResult BeginDelete(
string pathName,
object stateObject,
AsyncCallback asyncCallback
);

Parameters

pathName
The remote file path name.
stateObject
A state object, specified by the application, that contains information associated with the asynchronous operation.
asyncCallback
The AsyncCallback that will receive the notification of the asynchronous operation completion.

Return Value

The IAsyncResult that identifies the posted asynchronous request.

Remarks

When you use this overload, the callback specified in the callback parameter is invoked directly when the delete has completed; the DeleteCompleted event is not raised. The other overloads of BeginDelete rely on this component to raise the DeleteCompleted event.

See Also

RemoteFile Class | ComponentSpace.Ftp Namespace | RemoteFile.BeginDelete Overload List


BeginDownload Method

ComponentSpace FTP Class Library Reference

RemoteFile.BeginDownload Method

Initiates an asynchronous download remote file.

Overload List

Initiates an asynchronous download remote file.

public IAsyncResult BeginDownload(string,Stream);

Initiates an asynchronous download remote file that has a specified state object.

public IAsyncResult BeginDownload(string,Stream,object);

Initiates an asynchronous download remote file that has a specified state object. This overload receives notification, through a callback, of the identity of the event handler for this operation.

public IAsyncResult BeginDownload(string,Stream,object,AsyncCallback);

Initiates an asynchronous download remote file.

public IAsyncResult BeginDownload(string,string);

Initiates an asynchronous download remote file that has a specified state object.

public IAsyncResult BeginDownload(string,string,object);

Initiates an asynchronous download remote file that has a specified state object. This overload receives notification, through a callback, of the identity of the event handler for this operation.

public IAsyncResult BeginDownload(string,string,object,AsyncCallback);

See Also

RemoteFile Class | ComponentSpace.Ftp Namespace


RemoteFile.BeginDownload Method (String, Stream)

Initiates an asynchronous download remote file.

[Visual Basic]
Overloads Public Function BeginDownload( _
ByVal sourcePathName As String, _
ByVal destinationData As Stream _
) As IAsyncResult
[C#]
public IAsyncResult BeginDownload(
string sourcePathName,
Stream destinationData
);

Parameters

sourcePathName
The remote file path name.
destinationData
The destination data stream.

Return Value

The IAsyncResult that identifies the posted asynchronous request.

Remarks

In asynchronous processing, you use BeginDownload to raise the DownloadCompleted event when the download has completed. You complete the operation by calling EndDownload.

See Also

RemoteFile Class | ComponentSpace.Ftp Namespace | RemoteFile.BeginDownload Overload List


RemoteFile.BeginDownload Method (String, Stream, Object)

Initiates an asynchronous download remote file that has a specified state object.

[Visual Basic]
Overloads Public Function BeginDownload( _
ByVal sourcePathName As String, _
ByVal destinationData As Stream, _
ByVal stateObject As Object _
) As IAsyncResult
[C#]
public IAsyncResult BeginDownload(
string sourcePathName,
Stream destinationData,
object stateObject
);

Parameters

sourcePathName
The remote file path name.
destinationData
The destination data stream.
stateObject
A state object, specified by the application, that contains information associated with the asynchronous operation.

Return Value

The IAsyncResult that identifies the posted asynchronous request.

Remarks

In asynchronous processing, you use BeginDownload to raise the DownloadCompleted event when the download has completed. You complete the operation by calling EndDownload.

Use this overload to associate information with the operation that will be preserved throughout the operation's lifetime. The event handler can detect this information by looking at the AsyncState of the IAsyncResult that is associated with the operation.

See Also

RemoteFile Class | ComponentSpace.Ftp Namespace | RemoteFile.BeginDownload Overload List


RemoteFile.BeginDownload Method (String, Stream, Object, AsyncCallback)

Initiates an asynchronous download remote file that has a specified state object. This overload receives notification, through a callback, of the identity of the event handler for this operation.

[Visual Basic]
Overloads Public Function BeginDownload( _
ByVal sourcePathName As String, _
ByVal destinationData As Stream, _
ByVal stateObject As Object, _
ByVal asyncCallback As AsyncCallback _
) As IAsyncResult
[C#]
public IAsyncResult BeginDownload(
string sourcePathName,
Stream destinationData,
object stateObject,
AsyncCallback asyncCallback
);

Parameters

sourcePathName
The remote file path name.
destinationData
The destination data stream.
stateObject
A state object, specified by the application, that contains information associated with the asynchronous operation.
asyncCallback
The AsyncCallback that will receive the notification of the asynchronous operation completion.

Return Value

The IAsyncResult that identifies the posted asynchronous request.

Remarks

When you use this overload, the callback specified in the callback parameter is invoked directly when the download has completed; the DownloadCompleted event is not raised. The other overloads of BeginDownload rely on this component to raise the DownloadCompleted event.

See Also

RemoteFile Class | ComponentSpace.Ftp Namespace | RemoteFile.BeginDownload Overload List


RemoteFile.BeginDownload Method (String, String)

Initiates an asynchronous download remote file.

[Visual Basic]
Overloads Public Function BeginDownload( _
ByVal sourcePathName As String, _
ByVal destinationPathName As String _
) As IAsyncResult
[C#]
public IAsyncResult BeginDownload(
string sourcePathName,
string destinationPathName
);

Parameters

sourcePathName
The remote file path name.
destinationPathName
The local file path name.

Return Value

The IAsyncResult that identifies the posted asynchronous request.

Remarks

In asynchronous processing, you use BeginDownload to raise the DownloadCompleted event when the download has completed. You complete the operation by calling EndDownload.

See Also

RemoteFile Class | ComponentSpace.Ftp Namespace | RemoteFile.BeginDownload Overload List


RemoteFile.BeginDownload Method (String, String, Object)

Initiates an asynchronous download remote file that has a specified state object.

[Visual Basic]
Overloads Public Function BeginDownload( _
ByVal sourcePathName As String, _
ByVal destinationPathName As String, _
ByVal stateObject As Object _
) As IAsyncResult
[C#]
public IAsyncResult BeginDownload(
string sourcePathName,
string destinationPathName,
object stateObject
);

Parameters

sourcePathName
The remote file path name.
destinationPathName
The local file path name.
stateObject
A state object, specified by the application, that contains information associated with the asynchronous operation.

Return Value

The IAsyncResult that identifies the posted asynchronous request.

Remarks

In asynchronous processing, you use BeginDownload to raise the DownloadCompleted event when the download has completed. You complete the operation by calling EndDownload.

Use this overload to associate information with the operation that will be preserved throughout the operation's lifetime. The event handler can detect this information by looking at the AsyncState of the IAsyncResult that is associated with the operation.

See Also

RemoteFile Class | ComponentSpace.Ftp Namespace | RemoteFile.BeginDownload Overload List


RemoteFile.BeginDownload Method (String, String, Object, AsyncCallback)

Initiates an asynchronous download remote file that has a specified state object. This overload receives notification, through a callback, of the identity of the event handler for this operation.

[Visual Basic]
Overloads Public Function BeginDownload( _
ByVal sourcePathName As String, _
ByVal destinationPathName As String, _
ByVal stateObject As Object, _
ByVal asyncCallback As AsyncCallback _
) As IAsyncResult
[C#]
public IAsyncResult BeginDownload(
string sourcePathName,
string destinationPathName,
object stateObject,
AsyncCallback asyncCallback
);

Parameters

sourcePathName
The remote file path name.
destinationPathName
The local file path name.
stateObject
A state object, specified by the application, that contains information associated with the asynchronous operation.
asyncCallback
The AsyncCallback that will receive the notification of the asynchronous operation completion.

Return Value

The IAsyncResult that identifies the posted asynchronous request.

Remarks

When you use this overload, the callback specified in the callback parameter is invoked directly when the download has completed; the DownloadCompleted event is not raised. The other overloads of BeginDownload rely on this component to raise the DownloadCompleted event.

See Also

RemoteFile Class | ComponentSpace.Ftp Namespace | RemoteFile.BeginDownload Overload List


BeginGetModificationTime Method

ComponentSpace FTP Class Library Reference

RemoteFile.BeginGetModificationTime Method

Initiates an asynchronous get file modification time operation.

Overload List

Initiates an asynchronous get file modification time operation.

public IAsyncResult BeginGetModificationTime(string);

Initiates an asynchronous get file modification time operation that has a specified state object.

public IAsyncResult BeginGetModificationTime(string,object);

Initiates an asynchronous get file modification time operation that has a specified state object. This overload receives notification, through a callback, of the identity of the event handler for this operation.

public IAsyncResult BeginGetModificationTime(string,object,AsyncCallback);

See Also

RemoteFile Class | ComponentSpace.Ftp Namespace


RemoteFile.BeginGetModificationTime Method (String)

Initiates an asynchronous get file modification time operation.

[Visual Basic]
Overloads Public Function BeginGetModificationTime( _
ByVal pathName As String _
) As IAsyncResult
[C#]
public IAsyncResult BeginGetModificationTime(
string pathName
);

Parameters

pathName
The remote file path name.

Return Value

The IAsyncResult that identifies the posted asynchronous request.

Remarks

In asynchronous processing, you use BeginGetModificationTime to raise the GetModificationTimeCompleted event when the operation has completed. You complete the operation by calling EndGetModificationTime.

See Also

RemoteFile Class | ComponentSpace.Ftp Namespace | RemoteFile.BeginGetModificationTime Overload List


RemoteFile.BeginGetModificationTime Method (String, Object)

Initiates an asynchronous get file modification time operation that has a specified state object.

[Visual Basic]
Overloads Public Function BeginGetModificationTime( _
ByVal pathName As String, _
ByVal stateObject As Object _
) As IAsyncResult
[C#]
public IAsyncResult BeginGetModificationTime(
string pathName,
object stateObject
);

Parameters

pathName
The remote file path name.
stateObject
A state object, specified by the application, that contains information associated with the asynchronous operation.

Return Value

The IAsyncResult that identifies the posted asynchronous request.

Remarks

In asynchronous processing, you use BeginGetModificationTime to raise the GetModificationTimeCompleted event when the operation has completed. You complete the operation by calling EndGetModificationTime.

Use this overload to associate information with the operation that will be preserved throughout the operation's lifetime. The event handler can detect this information by looking at the AsyncState of the IAsyncResult that is associated with the operation.

See Also

RemoteFile Class | ComponentSpace.Ftp Namespace | RemoteFile.BeginGetModificationTime Overload List


RemoteFile.BeginGetModificationTime Method (String, Object, AsyncCallback)

Initiates an asynchronous get file modification time operation that has a specified state object. This overload receives notification, through a callback, of the identity of the event handler for this operation.

[Visual Basic]
Overloads Public Function BeginGetModificationTime( _
ByVal pathName As String, _
ByVal stateObject As Object, _
ByVal asyncCallback As AsyncCallback _
) As IAsyncResult
[C#]
public IAsyncResult BeginGetModificationTime(
string pathName,
object stateObject,
AsyncCallback asyncCallback
);

Parameters

pathName
The remote file path name.
stateObject
A state object, specified by the application, that contains information associated with the asynchronous operation.
asyncCallback
The AsyncCallback that will receive the notification of the asynchronous operation completion.

Return Value

The IAsyncResult that identifies the posted asynchronous request.

Remarks

When you use this overload, the callback specified in the callback parameter is invoked directly when the operation has completed; the GetModificationTimeCompleted event is not raised. The other overloads of BeginGetModificationTime rely on this component to raise the GetModificationTimeCompleted event.

See Also

RemoteFile Class | ComponentSpace.Ftp Namespace | RemoteFile.BeginGetModificationTime Overload List


BeginList Method

ComponentSpace FTP Class Library Reference

RemoteFile.BeginList Method

Initiates an asynchronous list remote file.

Overload List

Initiates an asynchronous list remote file.

public IAsyncResult BeginList(string);

Initiates an asynchronous list remote file that has a specified state object.

public IAsyncResult BeginList(string,object);

Initiates an asynchronous list remote file that has a specified state object. This overload receives notification, through a callback, of the identity of the event handler for this operation.

public IAsyncResult BeginList(string,object,AsyncCallback);

See Also

RemoteFile Class | ComponentSpace.Ftp Namespace


RemoteFile.BeginList Method (String)

Initiates an asynchronous list remote file.

[Visual Basic]
Overloads Public Function BeginList( _
ByVal pathName As String _
) As IAsyncResult
[C#]
public IAsyncResult BeginList(
string pathName
);

Parameters

pathName
The remote file path name.

Return Value

The IAsyncResult that identifies the posted asynchronous request.

Remarks

In asynchronous processing, you use BeginList to raise the ListCompleted event when the list has completed. You complete the operation by calling EndList.

See Also

RemoteFile Class | ComponentSpace.Ftp Namespace | RemoteFile.BeginList Overload List


RemoteFile.BeginList Method (String, Object)

Initiates an asynchronous list remote file that has a specified state object.

[Visual Basic]
Overloads Public Function BeginList( _
ByVal pathName As String, _
ByVal stateObject As Object _
) As IAsyncResult
[C#]
public IAsyncResult BeginList(
string pathName,
object stateObject
);

Parameters

pathName
The remote file path name.
stateObject
A state object, specified by the application, that contains information associated with the asynchronous operation.

Return Value

The IAsyncResult that identifies the posted asynchronous request.

Remarks

In asynchronous processing, you use BeginList to raise the ListCompleted event when the list has completed. You complete the operation by calling EndList.

Use this overload to associate information with the operation that will be preserved throughout the operation's lifetime. The event handler can detect this information by looking at the AsyncState of the IAsyncResult that is associated with the operation.

See Also

RemoteFile Class | ComponentSpace.Ftp Namespace | RemoteFile.BeginList Overload List


RemoteFile.BeginList Method (String, Object, AsyncCallback)

Initiates an asynchronous list remote file that has a specified state object. This overload receives notification, through a callback, of the identity of the event handler for this operation.

[Visual Basic]
Overloads Public Function BeginList( _
ByVal pathName As String, _
ByVal stateObject As Object, _
ByVal asyncCallback As AsyncCallback _
) As IAsyncResult
[C#]
public IAsyncResult BeginList(
string pathName,
object stateObject,
AsyncCallback asyncCallback
);

Parameters

pathName
The remote file path name.
stateObject
A state object, specified by the application, that contains information associated with the asynchronous operation.
asyncCallback
The AsyncCallback that will receive the notification of the asynchronous operation completion.

Return Value

The IAsyncResult that identifies the posted asynchronous request.

Remarks

When you use this overload, the callback specified in the callback parameter is invoked directly when the list has completed; the ListCompleted event is not raised. The other overloads of BeginList rely on this component to raise the ListCompleted event.

See Also

RemoteFile Class | ComponentSpace.Ftp Namespace | RemoteFile.BeginList Overload List


BeginRename Method

ComponentSpace FTP Class Library Reference

RemoteFile.BeginRename Method

Initiates an asynchronous rename remote file.

Overload List

Initiates an asynchronous rename remote file.

public IAsyncResult BeginRename(string,string);

Initiates an asynchronous rename remote file that has a specified state object.

public IAsyncResult BeginRename(string,string,object);

Initiates an asynchronous rename remote file that has a specified state object. This overload receives notification, through a callback, of the identity of the event handler for this operation.

public IAsyncResult BeginRename(string,string,object,AsyncCallback);

See Also

RemoteFile Class | ComponentSpace.Ftp Namespace


RemoteFile.BeginRename Method (String, String)

Initiates an asynchronous rename remote file.

[Visual Basic]
Overloads Public Function BeginRename( _
ByVal oldPathName As String, _
ByVal newPathName As String _
) As IAsyncResult
[C#]
public IAsyncResult BeginRename(
string oldPathName,
string newPathName
);

Parameters

oldPathName
The old path name.
newPathName
The new path name.

Return Value

The IAsyncResult that identifies the posted asynchronous request.

Remarks

In asynchronous processing, you use BeginRename to raise the RenameCompleted event when the rename has completed. You complete the operation by calling EndRename.

See Also

RemoteFile Class | ComponentSpace.Ftp Namespace | RemoteFile.BeginRename Overload List


RemoteFile.BeginRename Method (String, String, Object)

Initiates an asynchronous rename remote file that has a specified state object.

[Visual Basic]
Overloads Public Function BeginRename( _
ByVal oldPathName As String, _
ByVal newPathName As String, _
ByVal stateObject As Object _
) As IAsyncResult
[C#]
public IAsyncResult BeginRename(
string oldPathName,
string newPathName,
object stateObject
);

Parameters

oldPathName
The old path name.
newPathName
The new path name.
stateObject
A state object, specified by the application, that contains information associated with the asynchronous operation.

Return Value

The IAsyncResult that identifies the posted asynchronous request.

Remarks

In asynchronous processing, you use BeginRename to raise the RenameCompleted event when the rename has completed. You complete the operation by calling EndRename.

Use this overload to associate information with the operation that will be preserved throughout the operation's lifetime. The event handler can detect this information by looking at the AsyncState of the IAsyncResult that is associated with the operation.

See Also

RemoteFile Class | ComponentSpace.Ftp Namespace | RemoteFile.BeginRename Overload List


RemoteFile.BeginRename Method (String, String, Object, AsyncCallback)

Initiates an asynchronous rename remote file that has a specified state object. This overload receives notification, through a callback, of the identity of the event handler for this operation.

[Visual Basic]
Overloads Public Function BeginRename( _
ByVal oldPathName As String, _
ByVal newPathName As String, _
ByVal stateObject As Object, _
ByVal asyncCallback As AsyncCallback _
) As IAsyncResult
[C#]
public IAsyncResult BeginRename(
string oldPathName,
string newPathName,
object stateObject,
AsyncCallback asyncCallback
);

Parameters

oldPathName
The old path name.
newPathName
The new path name.
stateObject
A state object, specified by the application, that contains information associated with the asynchronous operation.
asyncCallback
The AsyncCallback that will receive the notification of the asynchronous operation completion.

Return Value

The IAsyncResult that identifies the posted asynchronous request.

Remarks

When you use this overload, the callback specified in the callback parameter is invoked directly when the rename has completed; the RenameCompleted event is not raised. The other overloads of BeginRename rely on this component to raise the RenameCompleted event.

See Also

RemoteFile Class | ComponentSpace.Ftp Namespace | RemoteFile.BeginRename Overload List


BeginRestartDownload Method

ComponentSpace FTP Class Library Reference

RemoteFile.BeginRestartDownload Method

Initiates an asynchronous restart download remote file. The restartMarker specifies the write position in the remote file.

Overload List

Initiates an asynchronous restart download remote file. The restartMarker specifies the write position in the remote file.

public IAsyncResult BeginRestartDownload(string,Stream,long);

Initiates an asynchronous restart download remote file that has a specified state object. The restartMarker specifies the write position in the remote file.

public IAsyncResult BeginRestartDownload(string,Stream,long,object);

Initiates an asynchronous restart download remote file that has a specified state object. This overload receives notification, through a callback, of the identity of the event handler for this operation. The restartMarker specifies the write position in the remote file.

public IAsyncResult BeginRestartDownload(string,Stream,long,object,AsyncCallback);

Initiates an asynchronous restart download remote file. The restartMarker specifies the write position in the remote file.

public IAsyncResult BeginRestartDownload(string,string,long);

Initiates an asynchronous restart download remote file that has a specified state object. The restartMarker specifies the write position in the remote file.

public IAsyncResult BeginRestartDownload(string,string,long,object);

Initiates an asynchronous restart download remote file that has a specified state object. This overload receives notification, through a callback, of the identity of the event handler for this operation. The restartMarker specifies the write position in the remote file.

public IAsyncResult BeginRestartDownload(string,string,long,object,AsyncCallback);

See Also

RemoteFile Class | ComponentSpace.Ftp Namespace


RemoteFile.BeginRestartDownload Method (String, Stream, Int64)

Initiates an asynchronous restart download remote file. The restartMarker specifies the write position in the remote file.

[Visual Basic]
Overloads Public Function BeginRestartDownload( _
ByVal sourcePathName As String, _
ByVal destinationData As Stream, _
ByVal restartMarker As Long _
) As IAsyncResult
[C#]
public IAsyncResult BeginRestartDownload(
string sourcePathName,
Stream destinationData,
long restartMarker
);

Parameters

sourcePathName
The remote file path name.
destinationData
The destination data stream.
restartMarker
The restart marker position.

Return Value

The IAsyncResult that identifies the posted asynchronous request.

Remarks

In asynchronous processing, you use BeginRestartDownload to raise the RestartDownloadCompleted event when the restart download has completed. You complete the operation by calling EndRestartDownload.

See Also

RemoteFile Class | ComponentSpace.Ftp Namespace | RemoteFile.BeginRestartDownload Overload List


RemoteFile.BeginRestartDownload Method (String, Stream, Int64, Object)

Initiates an asynchronous restart download remote file that has a specified state object. The restartMarker specifies the write position in the remote file.

[Visual Basic]
Overloads Public Function BeginRestartDownload( _
ByVal sourcePathName As String, _
ByVal destinationData As Stream, _
ByVal restartMarker As Long, _
ByVal stateObject As Object _
) As IAsyncResult
[C#]
public IAsyncResult BeginRestartDownload(
string sourcePathName,
Stream destinationData,
long restartMarker,
object stateObject
);

Parameters

sourcePathName
The remote file path name.
destinationData
The destination data stream.
restartMarker
The restart marker position.
stateObject
A state object, specified by the application, that contains information associated with the asynchronous operation.

Return Value

The IAsyncResult that identifies the posted asynchronous request.

Remarks

In asynchronous processing, you use BeginRestartDownload to raise the RestartDownloadCompleted event when the restart download has completed. You complete the operation by calling EndRestartDownload.

Use this overload to associate information with the operation that will be preserved throughout the operation's lifetime. The event handler can detect this information by looking at the AsyncState of the IAsyncResult that is associated with the operation.

See Also

RemoteFile Class | ComponentSpace.Ftp Namespace | RemoteFile.BeginRestartDownload Overload List


RemoteFile.BeginRestartDownload Method (String, Stream, Int64, Object, AsyncCallback)

Initiates an asynchronous restart download remote file that has a specified state object. This overload receives notification, through a callback, of the identity of the event handler for this operation. The restartMarker specifies the write position in the remote file.

[Visual Basic]
Overloads Public Function BeginRestartDownload( _
ByVal sourcePathName As String, _
ByVal destinationData As Stream, _
ByVal restartMarker As Long, _
ByVal stateObject As Object, _
ByVal asyncCallback As AsyncCallback _
) As IAsyncResult
[C#]
public IAsyncResult BeginRestartDownload(
string sourcePathName,
Stream destinationData,
long restartMarker,
object stateObject,
AsyncCallback asyncCallback
);

Parameters

sourcePathName
The remote file path name.
destinationData
The destination data stream.
restartMarker
The restart marker position.
stateObject
A state object, specified by the application, that contains information associated with the asynchronous operation.
asyncCallback
The AsyncCallback that will receive the notification of the asynchronous operation completion.

Return Value

The IAsyncResult that identifies the posted asynchronous request.

Remarks

When you use this overload, the callback specified in the callback parameter is invoked directly when the restart download has completed; the RestartDownloadCompleted event is not raised. The other overloads of BeginRestartDownload rely on this component to raise the RestartDownloadCompleted event.

See Also

RemoteFile Class | ComponentSpace.Ftp Namespace | RemoteFile.BeginRestartDownload Overload List


RemoteFile.BeginRestartDownload Method (String, String, Int64)

Initiates an asynchronous restart download remote file. The restartMarker specifies the write position in the remote file.

[Visual Basic]
Overloads Public Function BeginRestartDownload( _
ByVal sourcePathName As String, _
ByVal destinationPathName As String, _
ByVal restartMarker As Long _
) As IAsyncResult
[C#]
public IAsyncResult BeginRestartDownload(
string sourcePathName,
string destinationPathName,
long restartMarker
);

Parameters

sourcePathName
The remote file path name.
destinationPathName
The local file path name.
restartMarker
The restart marker position.

Return Value

The IAsyncResult that identifies the posted asynchronous request.

Remarks

In asynchronous processing, you use BeginRestartDownload to raise the RestartDownloadCompleted event when the restart download has completed. You complete the operation by calling EndRestartDownload.

See Also

RemoteFile Class | ComponentSpace.Ftp Namespace | RemoteFile.BeginRestartDownload Overload List


RemoteFile.BeginRestartDownload Method (String, String, Int64, Object)

Initiates an asynchronous restart download remote file that has a specified state object. The restartMarker specifies the write position in the remote file.

[Visual Basic]
Overloads Public Function BeginRestartDownload( _
ByVal sourcePathName As String, _
ByVal destinationPathName As String, _
ByVal restartMarker As Long, _
ByVal stateObject As Object _
) As IAsyncResult
[C#]
public IAsyncResult BeginRestartDownload(
string sourcePathName,
string destinationPathName,
long restartMarker,
object stateObject
);

Parameters

sourcePathName
The remote file path name.
destinationPathName
The local file path name.
restartMarker
The restart marker position.
stateObject
A state object, specified by the application, that contains information associated with the asynchronous operation.

Return Value

The IAsyncResult that identifies the posted asynchronous request.

Remarks

In asynchronous processing, you use BeginRestartDownload to raise the RestartDownloadCompleted event when the restart download has completed. You complete the operation by calling EndRestartDownload.

Use this overload to associate information with the operation that will be preserved throughout the operation's lifetime. The event handler can detect this information by looking at the AsyncState of the IAsyncResult that is associated with the operation.

See Also

RemoteFile Class | ComponentSpace.Ftp Namespace | RemoteFile.BeginRestartDownload Overload List


RemoteFile.BeginRestartDownload Method (String, String, Int64, Object, AsyncCallback)

Initiates an asynchronous restart download remote file that has a specified state object. This overload receives notification, through a callback, of the identity of the event handler for this operation. The restartMarker specifies the write position in the remote file.

[Visual Basic]
Overloads Public Function BeginRestartDownload( _
ByVal sourcePathName As String, _
ByVal destinationPathName As String, _
ByVal restartMarker As Long, _
ByVal stateObject As Object, _
ByVal asyncCallback As AsyncCallback _
) As IAsyncResult
[C#]
public IAsyncResult BeginRestartDownload(
string sourcePathName,
string destinationPathName,
long restartMarker,
object stateObject,
AsyncCallback asyncCallback
);

Parameters

sourcePathName
The remote file path name.
destinationPathName
The local file path name.
restartMarker
The restart marker position.
stateObject
A state object, specified by the application, that contains information associated with the asynchronous operation.
asyncCallback
The AsyncCallback that will receive the notification of the asynchronous operation completion.

Return Value

The IAsyncResult that identifies the posted asynchronous request.

Remarks

When you use this overload, the callback specified in the callback parameter is invoked directly when the restart download has completed; the RestartDownloadCompleted event is not raised. The other overloads of BeginRestartDownload rely on this component to raise the RestartDownloadCompleted event.

See Also

RemoteFile Class | ComponentSpace.Ftp Namespace | RemoteFile.BeginRestartDownload Overload List


BeginRestartUpload Method

ComponentSpace FTP Class Library Reference

RemoteFile.BeginRestartUpload Method

Initiates an asynchronous restart upload remote file. The restartMarker specifies the write position in the remote file.

Overload List

Initiates an asynchronous restart upload remote file. The restartMarker specifies the write position in the remote file.

public IAsyncResult BeginRestartUpload(Stream,string,long);

Initiates an asynchronous restart upload remote file that has a specified state object. The restartMarker specifies the write position in the remote file.

public IAsyncResult BeginRestartUpload(Stream,string,long,object);

Initiates an asynchronous restart upload remote file that has a specified state object. This overload receives notification, through a callback, of the identity of the event handler for this operation. The restartMarker specifies the write position in the remote file.

public IAsyncResult BeginRestartUpload(Stream,string,long,object,AsyncCallback);

Initiates an asynchronous restart upload remote file. The restartMarker specifies the write position in the remote file.

public IAsyncResult BeginRestartUpload(string,string,long);

Initiates an asynchronous restart upload remote file that has a specified state object. The restartMarker specifies the write position in the remote file.

public IAsyncResult BeginRestartUpload(string,string,long,object);

Initiates an asynchronous restart upload remote file that has a specified state object. This overload receives notification, through a callback, of the identity of the event handler for this operation. The restartMarker specifies the write position in the remote file.

public IAsyncResult BeginRestartUpload(string,string,long,object,AsyncCallback);

See Also

RemoteFile Class | ComponentSpace.Ftp Namespace


RemoteFile.BeginRestartUpload Method (Stream, String, Int64)

Initiates an asynchronous restart upload remote file. The restartMarker specifies the write position in the remote file.

[Visual Basic]
Overloads Public Function BeginRestartUpload( _
ByVal sourceData As Stream, _
ByVal destinationPathName As String, _
ByVal restartMarker As Long _
) As IAsyncResult
[C#]
public IAsyncResult BeginRestartUpload(
Stream sourceData,
string destinationPathName,
long restartMarker
);

Parameters

sourceData
The source data stream.
destinationPathName
The remote file name.
restartMarker
The restart marker position.

Return Value

The IAsyncResult that identifies the posted asynchronous request.

Remarks

In asynchronous processing, you use BeginRestartUpload to raise the RestartUploadCompleted event when the restart upload has completed. You complete the operation by calling EndRestartUpload.

See Also

RemoteFile Class | ComponentSpace.Ftp Namespace | RemoteFile.BeginRestartUpload Overload List


RemoteFile.BeginRestartUpload Method (Stream, String, Int64, Object)

Initiates an asynchronous restart upload remote file that has a specified state object. The restartMarker specifies the write position in the remote file.

[Visual Basic]
Overloads Public Function BeginRestartUpload( _
ByVal sourceData As Stream, _
ByVal destinationPathName As String, _
ByVal restartMarker As Long, _
ByVal stateObject As Object _
) As IAsyncResult
[C#]
public IAsyncResult BeginRestartUpload(
Stream sourceData,
string destinationPathName,
long restartMarker,
object stateObject
);

Parameters

sourceData
The source data stream.
destinationPathName
The remote file name.
restartMarker
The restart marker position.
stateObject
A state object, specified by the application, that contains information associated with the asynchronous operation.

Return Value

The IAsyncResult that identifies the posted asynchronous request.

Remarks

In asynchronous processing, you use BeginRestartUpload to raise the RestartUploadCompleted event when the restart upload has completed. You complete the operation by calling EndRestartUpload.

Use this overload to associate information with the operation that will be preserved throughout the operation's lifetime. The event handler can detect this information by looking at the AsyncState of the IAsyncResult that is associated with the operation.

See Also

RemoteFile Class | ComponentSpace.Ftp Namespace | RemoteFile.BeginRestartUpload Overload List


RemoteFile.BeginRestartUpload Method (Stream, String, Int64, Object, AsyncCallback)

Initiates an asynchronous restart upload remote file that has a specified state object. This overload receives notification, through a callback, of the identity of the event handler for this operation. The restartMarker specifies the write position in the remote file.

[Visual Basic]
Overloads Public Function BeginRestartUpload( _
ByVal sourceData As Stream, _
ByVal destinationPathName As String, _
ByVal restartMarker As Long, _
ByVal stateObject As Object, _
ByVal asyncCallback As AsyncCallback _
) As IAsyncResult
[C#]
public IAsyncResult BeginRestartUpload(
Stream sourceData,
string destinationPathName,
long restartMarker,
object stateObject,
AsyncCallback asyncCallback
);

Parameters

sourceData
The source data stream.
destinationPathName
The remote file name.
restartMarker
The restart marker position.
stateObject
A state object, specified by the application, that contains information associated with the asynchronous operation.
asyncCallback
The AsyncCallback that will receive the notification of the asynchronous operation completion.

Return Value

The IAsyncResult that identifies the posted asynchronous request.

Remarks

When you use this overload, the callback specified in the callback parameter is invoked directly when the restart upload has completed; the RestartUploadCompleted event is not raised. The other overloads of BeginRestartUpload rely on this component to raise the RestartUploadCompleted event.

See Also

RemoteFile Class | ComponentSpace.Ftp Namespace | RemoteFile.BeginRestartUpload Overload List


RemoteFile.BeginRestartUpload Method (String, String, Int64)

Initiates an asynchronous restart upload remote file. The restartMarker specifies the write position in the remote file.

[Visual Basic]
Overloads Public Function BeginRestartUpload( _
ByVal sourcePathName As String, _
ByVal destinationPathName As String, _
ByVal restartMarker As Long _
) As IAsyncResult
[C#]
public IAsyncResult BeginRestartUpload(
string sourcePathName,
string destinationPathName,
long restartMarker
);

Parameters

sourcePathName
The local file name.
destinationPathName
The remote file name or null.
restartMarker
The restart marker position.

Return Value

The IAsyncResult that identifies the posted asynchronous request.

Remarks

In asynchronous processing, you use BeginRestartUpload to raise the RestartUploadCompleted event when the restart upload has completed. You complete the operation by calling EndRestartUpload.

See Also

RemoteFile Class | ComponentSpace.Ftp Namespace | RemoteFile.BeginRestartUpload Overload List


RemoteFile.BeginRestartUpload Method (String, String, Int64, Object)

Initiates an asynchronous restart upload remote file that has a specified state object. The restartMarker specifies the write position in the remote file.

[Visual Basic]
Overloads Public Function BeginRestartUpload( _
ByVal sourcePathName As String, _
ByVal destinationPathName As String, _
ByVal restartMarker As Long, _
ByVal stateObject As Object _
) As IAsyncResult
[C#]
public IAsyncResult BeginRestartUpload(
string sourcePathName,
string destinationPathName,
long restartMarker,
object stateObject
);

Parameters

sourcePathName
The local file name.
destinationPathName
The remote file name.
restartMarker
The restart marker position.
stateObject
A state object, specified by the application, that contains information associated with the asynchronous operation.

Return Value

The IAsyncResult that identifies the posted asynchronous request.

Remarks

In asynchronous processing, you use BeginRestartUpload to raise the RestartUploadCompleted event when the restart upload has completed. You complete the operation by calling EndRestartUpload.

Use this overload to associate information with the operation that will be preserved throughout the operation's lifetime. The event handler can detect this information by looking at the AsyncState of the IAsyncResult that is associated with the operation.

See Also

RemoteFile Class | ComponentSpace.Ftp Namespace | RemoteFile.BeginRestartUpload Overload List


RemoteFile.BeginRestartUpload Method (String, String, Int64, Object, AsyncCallback)

Initiates an asynchronous restart upload remote file that has a specified state object. This overload receives notification, through a callback, of the identity of the event handler for this operation. The restartMarker specifies the write position in the remote file.

[Visual Basic]
Overloads Public Function BeginRestartUpload( _
ByVal sourcePathName As String, _
ByVal destinationPathName As String, _
ByVal restartMarker As Long, _
ByVal stateObject As Object, _
ByVal asyncCallback As AsyncCallback _
) As IAsyncResult
[C#]
public IAsyncResult BeginRestartUpload(
string sourcePathName,
string destinationPathName,
long restartMarker,
object stateObject,
AsyncCallback asyncCallback
);

Parameters

sourcePathName
The local file name.
destinationPathName
The remote file name.
restartMarker
The restart marker position.
stateObject
A state object, specified by the application, that contains information associated with the asynchronous operation.
asyncCallback
The AsyncCallback that will receive the notification of the asynchronous operation completion.

Return Value

The IAsyncResult that identifies the posted asynchronous request.

Remarks

When you use this overload, the callback specified in the callback parameter is invoked directly when the restart upload has completed; the RestartUploadCompleted event is not raised. The other overloads of BeginRestartUpload rely on this component to raise the RestartUploadCompleted event.

See Also

RemoteFile Class | ComponentSpace.Ftp Namespace | RemoteFile.BeginRestartUpload Overload List


BeginUpload Method

ComponentSpace FTP Class Library Reference

RemoteFile.BeginUpload Method

Initiates an asynchronous upload remote file.

Overload List

Initiates an asynchronous upload remote file.

public IAsyncResult BeginUpload(Stream,string);

Initiates an asynchronous upload remote file that has a specified state object.

public IAsyncResult BeginUpload(Stream,string,object);

Initiates an asynchronous upload remote file that has a specified state object. This overload receives notification, through a callback, of the identity of the event handler for this operation.

public IAsyncResult BeginUpload(Stream,string,object,AsyncCallback);

Initiates an asynchronous upload remote file.

public IAsyncResult BeginUpload(string,string);

Initiates an asynchronous upload remote file that has a specified state object.

public IAsyncResult BeginUpload(string,string,object);

Initiates an asynchronous upload remote file that has a specified state object. This overload receives notification, through a callback, of the identity of the event handler for this operation.

public IAsyncResult BeginUpload(string,string,object,AsyncCallback);

See Also

RemoteFile Class | ComponentSpace.Ftp Namespace


RemoteFile.BeginUpload Method (Stream, String)

Initiates an asynchronous upload remote file.

[Visual Basic]
Overloads Public Function BeginUpload( _
ByVal sourceData As Stream, _
ByVal destinationPathName As String _
) As IAsyncResult
[C#]
public IAsyncResult BeginUpload(
Stream sourceData,
string destinationPathName
);

Parameters

sourceData
The source data stream.
destinationPathName
The remote file name.

Return Value

The IAsyncResult that identifies the posted asynchronous request.

Remarks

In asynchronous processing, you use BeginUpload to raise the UploadCompleted event when the upload has completed. You complete the operation by calling EndUpload.

See Also

RemoteFile Class | ComponentSpace.Ftp Namespace | RemoteFile.BeginUpload Overload List


RemoteFile.BeginUpload Method (Stream, String, Object)

Initiates an asynchronous upload remote file that has a specified state object.

[Visual Basic]
Overloads Public Function BeginUpload( _
ByVal sourceData As Stream, _
ByVal destinationPathName As String, _
ByVal stateObject As Object _
) As IAsyncResult
[C#]
public IAsyncResult BeginUpload(
Stream sourceData,
string destinationPathName,
object stateObject
);

Parameters

sourceData
The source data stream.
destinationPathName
The remote file name.
stateObject
A state object, specified by the application, that contains information associated with the asynchronous operation.

Return Value

The IAsyncResult that identifies the posted asynchronous request.

Remarks

In asynchronous processing, you use BeginUpload to raise the UploadCompleted event when the upload has completed. You complete the operation by calling EndUpload.

Use this overload to associate information with the operation that will be preserved throughout the operation's lifetime. The event handler can detect this information by looking at the AsyncState of the IAsyncResult that is associated with the operation.

See Also

RemoteFile Class | ComponentSpace.Ftp Namespace | RemoteFile.BeginUpload Overload List


RemoteFile.BeginUpload Method (Stream, String, Object, AsyncCallback)

Initiates an asynchronous upload remote file that has a specified state object. This overload receives notification, through a callback, of the identity of the event handler for this operation.

[Visual Basic]
Overloads Public Function BeginUpload( _
ByVal sourceData As Stream, _
ByVal destinationPathName As String, _
ByVal stateObject As Object, _
ByVal asyncCallback As AsyncCallback _
) As IAsyncResult
[C#]
public IAsyncResult BeginUpload(
Stream sourceData,
string destinationPathName,
object stateObject,
AsyncCallback asyncCallback
);

Parameters

sourceData
The source data stream.
destinationPathName
The remote file name.
stateObject
A state object, specified by the application, that contains information associated with the asynchronous operation.
asyncCallback
The AsyncCallback that will receive the notification of the asynchronous operation completion.

Return Value

The IAsyncResult that identifies the posted asynchronous request.

Remarks

When you use this overload, the callback specified in the callback parameter is invoked directly when the upload has completed; the UploadCompleted event is not raised. The other overloads of BeginUpload rely on this component to raise the UploadCompleted event.

See Also

RemoteFile Class | ComponentSpace.Ftp Namespace | RemoteFile.BeginUpload Overload List


RemoteFile.BeginUpload Method (String, String)

Initiates an asynchronous upload remote file.

[Visual Basic]
Overloads Public Function BeginUpload( _
ByVal sourcePathName As String, _
ByVal destinationPathName As String _
) As IAsyncResult
[C#]
public IAsyncResult BeginUpload(
string sourcePathName,
string destinationPathName
);

Parameters

sourcePathName
The local file name.
destinationPathName
The remote file name or null.

Return Value

The IAsyncResult that identifies the posted asynchronous request.

Remarks

In asynchronous processing, you use BeginUpload to raise the UploadCompleted event when the upload has completed. You complete the operation by calling EndUpload.

See Also

RemoteFile Class | ComponentSpace.Ftp Namespace | RemoteFile.BeginUpload Overload List


RemoteFile.BeginUpload Method (String, String, Object)

Initiates an asynchronous upload remote file that has a specified state object.

[Visual Basic]
Overloads Public Function BeginUpload( _
ByVal sourcePathName As String, _
ByVal destinationPathName As String, _
ByVal stateObject As Object _
) As IAsyncResult
[C#]
public IAsyncResult BeginUpload(
string sourcePathName,
string destinationPathName,
object stateObject
);

Parameters

sourcePathName
The local file name.
destinationPathName
The remote file name.
stateObject
A state object, specified by the application, that contains information associated with the asynchronous operation.

Return Value

The IAsyncResult that identifies the posted asynchronous request.

Remarks

In asynchronous processing, you use BeginUpload to raise the UploadCompleted event when the upload has completed. You complete the operation by calling EndUpload.

Use this overload to associate information with the operation that will be preserved throughout the operation's lifetime. The event handler can detect this information by looking at the AsyncState of the IAsyncResult that is associated with the operation.

See Also

RemoteFile Class | ComponentSpace.Ftp Namespace | RemoteFile.BeginUpload Overload List


RemoteFile.BeginUpload Method (String, String, Object, AsyncCallback)

Initiates an asynchronous upload remote file that has a specified state object. This overload receives notification, through a callback, of the identity of the event handler for this operation.

[Visual Basic]
Overloads Public Function BeginUpload( _
ByVal sourcePathName As String, _
ByVal destinationPathName As String, _
ByVal stateObject As Object, _
ByVal asyncCallback As AsyncCallback _
) As IAsyncResult
[C#]
public IAsyncResult BeginUpload(
string sourcePathName,
string destinationPathName,
object stateObject,
AsyncCallback asyncCallback
);

Parameters

sourcePathName
The local file name.
destinationPathName
The remote file name.
stateObject
A state object, specified by the application, that contains information associated with the asynchronous operation.
asyncCallback
The AsyncCallback that will receive the notification of the asynchronous operation completion.

Return Value

The IAsyncResult that identifies the posted asynchronous request.

Remarks

When you use this overload, the callback specified in the callback parameter is invoked directly when the upload has completed; the UploadCompleted event is not raised. The other overloads of BeginUpload rely on this component to raise the UploadCompleted event.

See Also

RemoteFile Class | ComponentSpace.Ftp Namespace | RemoteFile.BeginUpload Overload List


RemoteFile.Delete Method

Delete the remote file.

[Visual Basic]
Public Sub Delete( _
ByVal pathName As String _
)
[C#]
public void Delete(
string pathName
);

Parameters

pathName
The remote file path name.

Exceptions

Exception Type | Condition
FtpException | Thrown when the delete fails.

See Also

RemoteFile Class | ComponentSpace.Ftp Namespace


Download Method

ComponentSpace FTP Class Library Reference

RemoteFile.Download Method

Download the remote file's contents to the data stream.

Overload List

Download the remote file's contents to the data stream.

public void Download(string,Stream);

Download the remote file's contents to the local file.

public void Download(string,string);

See Also

RemoteFile Class | ComponentSpace.Ftp Namespace


RemoteFile.Download Method (String, Stream)

Download the remote file's contents to the data stream.

[Visual Basic]
Overloads Public Sub Download( _
ByVal sourcePathName As String, _
ByVal destinationData As Stream _
)
[C#]
public void Download(
string sourcePathName,
Stream destinationData
);

Parameters

sourcePathName
The remote file path name.
destinationData
The destination data stream.

Exceptions

Exception Type | Condition
FtpException | Thrown when the download fails.

See Also

RemoteFile Class | ComponentSpace.Ftp Namespace | RemoteFile.Download Overload List


RemoteFile.Download Method (String, String)

Download the remote file's contents to the local file.

[Visual Basic]
Overloads Public Sub Download( _
ByVal sourcePathName As String, _
ByVal destinationPathName As String _
)
[C#]
public void Download(
string sourcePathName,
string destinationPathName
);

Parameters

sourcePathName
The remote file path name.
destinationPathName
The local file path name.

Remarks

To download multiple files, see the MultiFile class.

For failsafe downloads with automatic recovery from errors and network outages, see the FailSafeTransfer class.

Exceptions

Exception Type | Condition
FtpException | Thrown when the download fails.

See Also

RemoteFile Class | ComponentSpace.Ftp Namespace | RemoteFile.Download Overload List | MultiFile | FailSafeTransfer


RemoteFile.EndAppend Method

Completes the specified asynchronous append remote file operation.

[Visual Basic]
Public Sub EndAppend( _
ByVal asyncResult As IAsyncResult _
)
[C#]
public void EndAppend(
IAsyncResult asyncResult
);

Parameters

asyncResult
The IAsyncResult that identifies the asynchronous append to finish, and from which to retrieve an end result.

Remarks

When the AppendCompleted event is raised, EndAppend completes the operation that was initiated by the BeginAppend call.

Exceptions

Exception Type | Condition
FtpException | Thrown when the append fails.

See Also

RemoteFile Class | ComponentSpace.Ftp Namespace


RemoteFile.EndDelete Method

Completes the specified asynchronous delete remote file operation.

[Visual Basic]
Public Sub EndDelete( _
ByVal asyncResult As IAsyncResult _
)
[C#]
public void EndDelete(
IAsyncResult asyncResult
);

Parameters

asyncResult
The IAsyncResult that identifies the asynchronous delete to finish, and from which to retrieve an end result.

Remarks

When the DeleteCompleted event is raised, EndDelete completes the operation that was initiated by the BeginDelete call.

Exceptions

Exception Type | Condition
FtpException | Thrown when the delete fails.

See Also

RemoteFile Class | ComponentSpace.Ftp Namespace


RemoteFile.EndDownload Method

Completes the specified asynchronous download remote file operation.

[Visual Basic]
Public Sub EndDownload( _
ByVal asyncResult As IAsyncResult _
)
[C#]
public void EndDownload(
IAsyncResult asyncResult
);

Parameters

asyncResult
The IAsyncResult that identifies the asynchronous download to finish, and from which to retrieve an end result.

Remarks

When the DownloadCompleted event is raised, EndDownload completes the operation that was initiated by the BeginDownload call.

Exceptions

Exception Type | Condition
FtpException | Thrown when the download fails.

See Also

RemoteFile Class | ComponentSpace.Ftp Namespace


RemoteFile.EndGetModificationTime Method

Completes the specified asynchronous get file modification time operation.

[Visual Basic]
Public Function EndGetModificationTime( _
ByVal asyncResult As IAsyncResult _
) As Date
[C#]
public DateTime EndGetModificationTime(
IAsyncResult asyncResult
);

Parameters

asyncResult
The IAsyncResult that identifies the asynchronous operation to finish, and from which to retrieve an end result.

Return Value

The file's modification DateTime.

Remarks

When the GetModificationTimeCompleted event is raised, EndGetModificationTime completes the operation that was initiated by the BeginGetModificationTime call.

Exceptions

Exception Type | Condition
FtpException | Thrown when the et file modification time operation fails.

See Also

RemoteFile Class | ComponentSpace.Ftp Namespace


RemoteFile.EndList Method

Completes the specified asynchronous list remote file operation.

[Visual Basic]
Public Sub EndList( _
ByVal asyncResult As IAsyncResult _
)
[C#]
public void EndList(
IAsyncResult asyncResult
);

Parameters

asyncResult
The IAsyncResult that identifies the asynchronous list to finish, and from which to retrieve an end result.

Remarks

When the ListCompleted event is raised, EndList completes the operation that was initiated by the BeginList call.

Exceptions

Exception Type | Condition
FtpException | Thrown when the list fails.

See Also

RemoteFile Class | ComponentSpace.Ftp Namespace


RemoteFile.EndRename Method

Completes the specified asynchronous rename remote file operation.

[Visual Basic]
Public Sub EndRename( _
ByVal asyncResult As IAsyncResult _
)
[C#]
public void EndRename(
IAsyncResult asyncResult
);

Parameters

asyncResult
The IAsyncResult that identifies the asynchronous rename to finish, and from which to retrieve an end result.

Remarks

When the RenameCompleted event is raised, EndRename completes the operation that was initiated by the BeginRename call.

Exceptions

Exception Type | Condition
FtpException | Thrown when the rename fails.

See Also

RemoteFile Class | ComponentSpace.Ftp Namespace


RemoteFile.EndRestartDownload Method

Completes the specified asynchronous restart download remote file operation.

[Visual Basic]
Public Sub EndRestartDownload( _
ByVal asyncResult As IAsyncResult _
)
[C#]
public void EndRestartDownload(
IAsyncResult asyncResult
);

Parameters

asyncResult
The IAsyncResult that identifies the asynchronous restart download to finish, and from which to retrieve an end result.

Remarks

When the RestartDownloadCompleted event is raised, EndRestartDownload completes the operation that was initiated by the BeginRestartDownload call.

Exceptions

Exception Type | Condition
FtpException | Thrown when the restart download fails.

See Also

RemoteFile Class | ComponentSpace.Ftp Namespace


RemoteFile.EndRestartUpload Method

Completes the specified asynchronous restart upload remote file operation.

[Visual Basic]
Public Sub EndRestartUpload( _
ByVal asyncResult As IAsyncResult _
)
[C#]
public void EndRestartUpload(
IAsyncResult asyncResult
);

Parameters

asyncResult
The IAsyncResult that identifies the asynchronous restart upload to finish, and from which to retrieve an end result.

Remarks

When the RestartUploadCompleted event is raised, EndRestartUpload completes the operation that was initiated by the BeginRestartUpload call.

Exceptions

Exception Type | Condition
FtpException | Thrown when the restart upload fails.

See Also

RemoteFile Class | ComponentSpace.Ftp Namespace


RemoteFile.EndUpload Method

Completes the specified asynchronous upload remote file operation.

[Visual Basic]
Public Function EndUpload( _
ByVal asyncResult As IAsyncResult _
) As String
[C#]
public string EndUpload(
IAsyncResult asyncResult
);

Parameters

asyncResult
The IAsyncResult that identifies the asynchronous upload to finish, and from which to retrieve an end result.

Return Value

The remote file name.

Remarks

When the UploadCompleted event is raised, EndUpload completes the operation that was initiated by the BeginUpload call.

Exceptions

Exception Type | Condition
FtpException | Thrown when the upload fails.

See Also

RemoteFile Class | ComponentSpace.Ftp Namespace


RemoteFile.Exists Method

Indicate whether the remote file exists.

[Visual Basic]
Public Function Exists( _
ByVal pathName As String _
) As Boolean
[C#]
public bool Exists(
string pathName
);

Parameters

pathName
The remote file path name.

Return Value

true if the remote file exists, false otherwise.

Exceptions

Exception Type | Condition
FtpException | Thrown when the check for remote file existence fails.

See Also

RemoteFile Class | ComponentSpace.Ftp Namespace


RemoteFile.GetModificationTime Method

Get the modification time of the remote file.

[Visual Basic]
Public Function GetModificationTime( _
ByVal pathName As String _
) As Date
[C#]
public DateTime GetModificationTime(
string pathName
);

Parameters

pathName
The remote file path name.

Return Value

The file's modification DateTime.

Remarks

This uses the MTDM command which is described in http://www.ietf.org/proceedings/02nov/I-D/draft-ietf-ftpext-mlst-15.txt. As this is draft and not part of the FTP standard, not all FTP servers will support it.

If supported, the file's modification time is returned as a UTC (GMT) time. You may use Date.ToLocalTime to convert UTC to local time.

If not supported, an exception is thrown. In this case, the List method may be used in conjunction with the DirectoryListParser class.

Exceptions

Exception Type | Condition
FtpException | Thrown when the get modification time operation fails.

See Also

RemoteFile Class | ComponentSpace.Ftp Namespace


RemoteFile.List Method

Get remote file information.

[Visual Basic]
Public Function List( _
ByVal pathName As String _
) As String
[C#]
public string List(
string pathName
);

Parameters

pathName
The remote file path name.

Return Value

The remote file information

Exceptions

Exception Type | Condition
FtpException | Thrown when the list fails.

See Also

RemoteFile Class | ComponentSpace.Ftp Namespace


RemoteFile.Rename Method

Rename the remote file.

[Visual Basic]
Public Sub Rename( _
ByVal oldPathName As String, _
ByVal newPathName As String _
)
[C#]
public void Rename(
string oldPathName,
string newPathName
);

Parameters

oldPathName
The old path name.
newPathName
The new path name.

Exceptions

Exception Type | Condition
FtpException | Thrown when the rename fails.

See Also

RemoteFile Class | ComponentSpace.Ftp Namespace


RestartDownload Method

ComponentSpace FTP Class Library Reference

RemoteFile.RestartDownload Method

Restart the download of the remote file's contents to the data stream. The restartMarker specifies the read position in the remote file.

Overload List

Restart the download of the remote file's contents to the data stream. The restartMarker specifies the read position in the remote file.

public void RestartDownload(string,Stream,long);

Restart the download of the remote file's contents to the local file. The restartMarker specifies the read position in the remote file.

public void RestartDownload(string,string,long);

See Also

RemoteFile Class | ComponentSpace.Ftp Namespace


RemoteFile.RestartDownload Method (String, Stream, Int64)

Restart the download of the remote file's contents to the data stream. The restartMarker specifies the read position in the remote file.

[Visual Basic]
Overloads Public Sub RestartDownload( _
ByVal sourcePathName As String, _
ByVal destinationData As Stream, _
ByVal restartMarker As Long _
)
[C#]
public void RestartDownload(
string sourcePathName,
Stream destinationData,
long restartMarker
);

Parameters

sourcePathName
The remote file path name.
destinationData
The destination data stream.
restartMarker
The restart marker position.

Exceptions

Exception Type | Condition
FtpException | Thrown when the download fails.

See Also

RemoteFile Class | ComponentSpace.Ftp Namespace | RemoteFile.RestartDownload Overload List


RemoteFile.RestartDownload Method (String, String, Int64)

Restart the download of the remote file's contents to the local file. The restartMarker specifies the read position in the remote file.

[Visual Basic]
Overloads Public Sub RestartDownload( _
ByVal sourcePathName As String, _
ByVal destinationPathName As String, _
ByVal restartMarker As Long _
)
[C#]
public void RestartDownload(
string sourcePathName,
string destinationPathName,
long restartMarker
);

Parameters

sourcePathName
The remote file path name.
destinationPathName
The local file path name.
restartMarker
The restart marker position.

Remarks

For failsafe downloads with automatic recovery from errors and network outages, see the FailSafeTransfer class.

Exceptions

Exception Type | Condition
FtpException | Thrown when the download fails.

See Also

RemoteFile Class | ComponentSpace.Ftp Namespace | RemoteFile.RestartDownload Overload List | FailSafeTransfer


RestartUpload Method

ComponentSpace FTP Class Library Reference

RemoteFile.RestartUpload Method

Restart the upload of the data stream's contents to the remote file. The restartMarker specifies the write position in the remote file.

Overload List

Restart the upload of the data stream's contents to the remote file. The restartMarker specifies the write position in the remote file.

public void RestartUpload(Stream,string,long);

Restart the upload of the local file's contents to the remote file. The restartMarker specifies the write position in the remote file.

public void RestartUpload(string,string,long);

See Also

RemoteFile Class | ComponentSpace.Ftp Namespace


RemoteFile.RestartUpload Method (Stream, String, Int64)

Restart the upload of the data stream's contents to the remote file. The restartMarker specifies the write position in the remote file.

[Visual Basic]
Overloads Public Sub RestartUpload( _
ByVal sourceData As Stream, _
ByVal destinationPathName As String, _
ByVal restartMarker As Long _
)
[C#]
public void RestartUpload(
Stream sourceData,
string destinationPathName,
long restartMarker
);

Parameters

sourceData
The source data stream.
destinationPathName
The remote file name.
restartMarker
The restart marker position.

Exceptions

Exception Type | Condition
FtpException | Thrown when the upload fails.

See Also

RemoteFile Class | ComponentSpace.Ftp Namespace | RemoteFile.RestartUpload Overload List


RemoteFile.RestartUpload Method (String, String, Int64)

Restart the upload of the local file's contents to the remote file. The restartMarker specifies the write position in the remote file.

[Visual Basic]
Overloads Public Sub RestartUpload( _
ByVal sourcePathName As String, _
ByVal destinationPathName As String, _
ByVal restartMarker As Long _
)
[C#]
public void RestartUpload(
string sourcePathName,
string destinationPathName,
long restartMarker
);

Parameters

sourcePathName
The local file name.
destinationPathName
The remote file name.
restartMarker
The restart marker position.

Remarks

For failsafe uploads with automatic recovery from errors and network outages, see the FailSafeTransfer class.

Exceptions

Exception Type | Condition
FtpException | Thrown when the upload fails.

See Also

RemoteFile Class | ComponentSpace.Ftp Namespace | RemoteFile.RestartUpload Overload List | FailSafeTransfer


Upload Method

ComponentSpace FTP Class Library Reference

RemoteFile.Upload Method

Upload the data stream's contents to the remote file. If destinationPathName is null then a unique name is generated on the remote server.

Overload List

Upload the data stream's contents to the remote file. If destinationPathName is null then a unique name is generated on the remote server.

public string Upload(Stream,string);

Upload the local file's contents to the remote file. If destinationPathName is null then a unique name is generated on the remote server.

public string Upload(string,string);

See Also

RemoteFile Class | ComponentSpace.Ftp Namespace


RemoteFile.Upload Method (Stream, String)

Upload the data stream's contents to the remote file. If destinationPathName is null then a unique name is generated on the remote server.

[Visual Basic]
Overloads Public Function Upload( _
ByVal sourceData As Stream, _
ByVal destinationPathName As String _
) As String
[C#]
public string Upload(
Stream sourceData,
string destinationPathName
);

Parameters

sourceData
The source data stream.
destinationPathName
The remote file name or null.

Return Value

The remote file name.

Exceptions

Exception Type | Condition
FtpException | Thrown when the upload fails.

See Also

RemoteFile Class | ComponentSpace.Ftp Namespace | RemoteFile.Upload Overload List


RemoteFile.Upload Method (String, String)

Upload the local file's contents to the remote file. If destinationPathName is null then a unique name is generated on the remote server.

[Visual Basic]
Overloads Public Function Upload( _
ByVal sourcePathName As String, _
ByVal destinationPathName As String _
) As String
[C#]
public string Upload(
string sourcePathName,
string destinationPathName
);

Parameters

sourcePathName
The local file name.
destinationPathName
The remote file name or null.

Return Value

The remote file name.

Remarks

To upload multiple files, see the MultiFile class.

For failsafe uploads with automatic recovery from errors and network outages, see the FailSafeTransfer class.

Exceptions

Exception Type | Condition
FtpException | Thrown when the upload fails.

See Also

RemoteFile Class | ComponentSpace.Ftp Namespace | RemoteFile.Upload Overload List | MultiFile | FailSafeTransfer


RemoteFile Events

The events of the RemoteFile class are listed below. For a complete list of RemoteFile class members, see the RemoteFile Members topic.

Public Instance Events

AppendCompleted | Occurs when the append file has completed.
DataTransferred | Occurs at intervals to indicate how many bytes in total have been transferred during the current data transfer. This event may be used provide feedback during data transfers.
DeleteCompleted | Occurs when the delete file has completed.
DownloadCompleted | Occurs when the download file has completed.
GetModificationTimeCompleted | Occurs when the get file modification time operation has completed.
ListCompleted | Occurs when the list file has completed.
RenameCompleted | Occurs when the rename file has completed.
RestartDownloadCompleted | Occurs when the restart download file has completed.
RestartUploadCompleted | Occurs when the restart upload file has completed.
UploadCompleted | Occurs when the upload file has completed.

See Also

RemoteFile Class | ComponentSpace.Ftp Namespace


RemoteFile.AppendCompleted Event

Occurs when the append file has completed.

[Visual Basic]
Public Event AppendCompleted As FtpOperationCompletedEventHandler
[C#]
public event FtpOperationCompletedEventHandler AppendCompleted;

Event Data

The event handler receives an argument of type FtpOperationCompletedEventArgs containing data related to this event. The following FtpOperationCompletedEventArgs property provides information specific to this event.

Property | Description
AsyncResult | Gets the result of the asynchronous send operation.

Remarks

BeginAppend is used in asynchronous processing to raise the AppendCompleted event when the append file has completed.

EndAppend is used to complete the operation initiated by a call to BeginAppend and get the append file status when the AppendCompleted event is raised.

See Also

RemoteFile Class | ComponentSpace.Ftp Namespace


RemoteFile.DataTransferred Event

Occurs at intervals to indicate how many bytes in total have been transferred during the current data transfer. This event may be used provide feedback during data transfers.

[Visual Basic]
Public Event DataTransferred As DataTransferredEventHandler
[C#]
public event DataTransferredEventHandler DataTransferred;

Event Data

The event handler receives an argument of type DataTransferredEventArgs containing data related to this event. The following DataTransferredEventArgs property provides information specific to this event.

Property | Description
BytesTransferred | Gets the total number of bytes transferred in the current operation.

See Also

RemoteFile Class | ComponentSpace.Ftp Namespace


RemoteFile.DeleteCompleted Event

Occurs when the delete file has completed.

[Visual Basic]
Public Event DeleteCompleted As FtpOperationCompletedEventHandler
[C#]
public event FtpOperationCompletedEventHandler DeleteCompleted;

Event Data

The event handler receives an argument of type FtpOperationCompletedEventArgs containing data related to this event. The following FtpOperationCompletedEventArgs property provides information specific to this event.

Property | Description
AsyncResult | Gets the result of the asynchronous send operation.

Remarks

BeginDelete is used in asynchronous processing to raise the DeleteCompleted event when the delete file has completed.

EndDelete is used to complete the operation initiated by a call to BeginDelete and get the delete file status when the DeleteCompleted event is raised.

See Also

RemoteFile Class | ComponentSpace.Ftp Namespace


RemoteFile.DownloadCompleted Event

Occurs when the download file has completed.

[Visual Basic]
Public Event DownloadCompleted As FtpOperationCompletedEventHandler
[C#]
public event FtpOperationCompletedEventHandler DownloadCompleted;

Event Data

The event handler receives an argument of type FtpOperationCompletedEventArgs containing data related to this event. The following FtpOperationCompletedEventArgs property provides information specific to this event.

Property | Description
AsyncResult | Gets the result of the asynchronous send operation.

Remarks

BeginDownload is used in asynchronous processing to raise the DownloadCompleted event when the download file has completed.

EndDownload is used to complete the operation initiated by a call to BeginDownload and get the download file status when the DownloadCompleted event is raised.

See Also

RemoteFile Class | ComponentSpace.Ftp Namespace


RemoteFile.GetModificationTimeCompleted Event

Occurs when the get file modification time operation has completed.

[Visual Basic]
Public Event GetModificationTimeCompleted As FtpOperationCompletedEventHandler
[C#]
public event FtpOperationCompletedEventHandler GetModificationTimeCompleted;

Event Data

The event handler receives an argument of type FtpOperationCompletedEventArgs containing data related to this event. The following FtpOperationCompletedEventArgs property provides information specific to this event.

Property | Description
AsyncResult | Gets the result of the asynchronous send operation.

Remarks

BeginGetModificationTime is used in asynchronous processing to raise the GetModificationTimeCompleted event when the get file modification time operation has completed.

EndGetModificationTime is used to complete the operation initiated by a call to BeginGetModificationTime and get the file modification time when the GetModificationTimeCompleted event is raised.

See Also

RemoteFile Class | ComponentSpace.Ftp Namespace


RemoteFile.ListCompleted Event

Occurs when the list file has completed.

[Visual Basic]
Public Event ListCompleted As FtpOperationCompletedEventHandler
[C#]
public event FtpOperationCompletedEventHandler ListCompleted;

Event Data

The event handler receives an argument of type FtpOperationCompletedEventArgs containing data related to this event. The following FtpOperationCompletedEventArgs property provides information specific to this event.

Property | Description
AsyncResult | Gets the result of the asynchronous send operation.

Remarks

BeginList is used in asynchronous processing to raise the ListCompleted event when the list file has completed.

EndList is used to complete the operation initiated by a call to BeginList and get the list file status when the ListCompleted event is raised.

See Also

RemoteFile Class | ComponentSpace.Ftp Namespace


RemoteFile.RenameCompleted Event

Occurs when the rename file has completed.

[Visual Basic]
Public Event RenameCompleted As FtpOperationCompletedEventHandler
[C#]
public event FtpOperationCompletedEventHandler RenameCompleted;

Event Data

The event handler receives an argument of type FtpOperationCompletedEventArgs containing data related to this event. The following FtpOperationCompletedEventArgs property provides information specific to this event.

Property | Description
AsyncResult | Gets the result of the asynchronous send operation.

Remarks

BeginRename is used in asynchronous processing to raise the RenameCompleted event when the rename file has completed.

EndRename is used to complete the operation initiated by a call to BeginRename and get the rename file status when the RenameCompleted event is raised.

See Also

RemoteFile Class | ComponentSpace.Ftp Namespace


RemoteFile.RestartDownloadCompleted Event

Occurs when the restart download file has completed.

[Visual Basic]
Public Event RestartDownloadCompleted As FtpOperationCompletedEventHandler
[C#]
public event FtpOperationCompletedEventHandler RestartDownloadCompleted;

Event Data

The event handler receives an argument of type FtpOperationCompletedEventArgs containing data related to this event. The following FtpOperationCompletedEventArgs property provides information specific to this event.

Property | Description
AsyncResult | Gets the result of the asynchronous send operation.

Remarks

BeginRestartDownload is used in asynchronous processing to raise the RestartDownloadCompleted event when the restart download file has completed.

EndRestartDownload is used to complete the operation initiated by a call to BeginRestartDownload and get the restart download file status when the RestartDownloadCompleted event is raised.

See Also

RemoteFile Class | ComponentSpace.Ftp Namespace


RemoteFile.RestartUploadCompleted Event

Occurs when the restart upload file has completed.

[Visual Basic]
Public Event RestartUploadCompleted As FtpOperationCompletedEventHandler
[C#]
public event FtpOperationCompletedEventHandler RestartUploadCompleted;

Event Data

The event handler receives an argument of type FtpOperationCompletedEventArgs containing data related to this event. The following FtpOperationCompletedEventArgs property provides information specific to this event.

Property | Description
AsyncResult | Gets the result of the asynchronous send operation.

Remarks

BeginRestartUpload is used in asynchronous processing to raise the RestartUploadCompleted event when the restart upload file has completed.

EndRestartUpload is used to complete the operation initiated by a call to BeginRestartUpload and get the restart upload file status when the RestartUploadCompleted event is raised.

See Also

RemoteFile Class | ComponentSpace.Ftp Namespace


RemoteFile.UploadCompleted Event

Occurs when the upload file has completed.

[Visual Basic]
Public Event UploadCompleted As FtpOperationCompletedEventHandler
[C#]
public event FtpOperationCompletedEventHandler UploadCompleted;

Event Data

The event handler receives an argument of type FtpOperationCompletedEventArgs containing data related to this event. The following FtpOperationCompletedEventArgs property provides information specific to this event.

Property | Description
AsyncResult | Gets the result of the asynchronous send operation.

Remarks

BeginUpload is used in asynchronous processing to raise the UploadCompleted event when the upload file has completed.

EndUpload is used to complete the operation initiated by a call to BeginUpload and get the upload file status when the UploadCompleted event is raised.

See Also

RemoteFile Class | ComponentSpace.Ftp Namespace


RemoveDirectoryCommand Class

Represents the FTP RMD command.

For a list of all members of this type, see RemoveDirectoryCommand Members.

System.Object
ComponentSpace.Ftp.FtpCommand
ComponentSpace.Ftp.RemoveDirectoryCommand

[Visual Basic]
Public Class RemoveDirectoryCommand
Inherits FtpCommand
[C#]
public class RemoveDirectoryCommand : FtpCommand

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: ComponentSpace.Ftp

Assembly: ComponentSpace.Ftp (in ComponentSpace.Ftp.dll)

See Also

RemoveDirectoryCommand Members | ComponentSpace.Ftp Namespace


RemoveDirectoryCommand Members

RemoveDirectoryCommand overview

Public Instance Constructors

RemoveDirectoryCommand Overloaded. Initializes a new instance of the RemoveDirectoryCommand class.

Public Instance Properties

CommandType (inherited from FtpCommand) | Gets the command type.
PathName | Gets or sets the remote path name.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString | Convert the command to the FTP command text.
ToTraceString (inherited from FtpCommand) | Convert the reply to the trace text.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

RemoveDirectoryCommand Class | ComponentSpace.Ftp Namespace


RemoveDirectoryCommand Constructor

Initializes a new instance of the RemoveDirectoryCommand.

Overload List

Initializes a new instance of the RemoveDirectoryCommand.

public RemoveDirectoryCommand();

Initializes a new instance of the RemoveDirectoryCommand from the raw command text.

public RemoveDirectoryCommand(string);

See Also

RemoveDirectoryCommand Class | ComponentSpace.Ftp Namespace


RemoveDirectoryCommand Constructor ()

Initializes a new instance of the RemoveDirectoryCommand.

[Visual Basic]
Overloads Public Sub New()
[C#]
public RemoveDirectoryCommand();

See Also

RemoveDirectoryCommand Class | ComponentSpace.Ftp Namespace | RemoveDirectoryCommand Constructor Overload List


RemoveDirectoryCommand Constructor (String)

Initializes a new instance of the RemoveDirectoryCommand from the raw command text.

[Visual Basic]
Overloads Public Sub New( _
ByVal command As String _
)
[C#]
public RemoveDirectoryCommand(
string command
);

Parameters

command
The raw command text.

See Also

RemoveDirectoryCommand Class | ComponentSpace.Ftp Namespace | RemoveDirectoryCommand Constructor Overload List


RemoveDirectoryCommand Properties

The properties of the RemoveDirectoryCommand class are listed below. For a complete list of RemoveDirectoryCommand class members, see the RemoveDirectoryCommand Members topic.

Public Instance Properties

CommandType (inherited from FtpCommand) | Gets the command type.
PathName | Gets or sets the remote path name.

See Also

RemoveDirectoryCommand Class | ComponentSpace.Ftp Namespace


RemoveDirectoryCommand.PathName Property

Gets or sets the remote path name.

[Visual Basic]
Public Property PathName As String
[C#]
public string PathName {get; set;}

Property Value

The account information.

See Also

RemoveDirectoryCommand Class | ComponentSpace.Ftp Namespace


RemoveDirectoryCommand Methods

The methods of the RemoveDirectoryCommand class are listed below. For a complete list of RemoveDirectoryCommand class members, see the RemoveDirectoryCommand Members topic.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString | Convert the command to the FTP command text.
ToTraceString (inherited from FtpCommand) | Convert the reply to the trace text.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

RemoveDirectoryCommand Class | ComponentSpace.Ftp Namespace


RemoveDirectoryCommand.ToString Method

Convert the command to the FTP command text.

[Visual Basic]
Overrides Public Function ToString() As String
[C#]
public override string ToString();

Return Value

The FTP command text.

See Also

RemoveDirectoryCommand Class | ComponentSpace.Ftp Namespace


RenameFromCommand Class

Represents the FTP RNFR command.

For a list of all members of this type, see RenameFromCommand Members.

System.Object
ComponentSpace.Ftp.FtpCommand
ComponentSpace.Ftp.RenameFromCommand

[Visual Basic]
Public Class RenameFromCommand
Inherits FtpCommand
[C#]
public class RenameFromCommand : FtpCommand

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: ComponentSpace.Ftp

Assembly: ComponentSpace.Ftp (in ComponentSpace.Ftp.dll)

See Also

RenameFromCommand Members | ComponentSpace.Ftp Namespace


RenameFromCommand Members

RenameFromCommand overview

Public Instance Constructors

RenameFromCommand Overloaded. Initializes a new instance of the RenameFromCommand class.

Public Instance Properties

CommandType (inherited from FtpCommand) | Gets the command type.
PathName | Gets or sets the remote from path name.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString | Convert the command to the FTP command text.
ToTraceString (inherited from FtpCommand) | Convert the reply to the trace text.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

RenameFromCommand Class | ComponentSpace.Ftp Namespace


RenameFromCommand Constructor

Initializes a new instance of the RenameFromCommand.

Overload List

Initializes a new instance of the RenameFromCommand.

public RenameFromCommand();

Initializes a new instance of the RenameFromCommand from the raw command text.

public RenameFromCommand(string);

See Also

RenameFromCommand Class | ComponentSpace.Ftp Namespace


RenameFromCommand Constructor ()

Initializes a new instance of the RenameFromCommand.

[Visual Basic]
Overloads Public Sub New()
[C#]
public RenameFromCommand();

See Also

RenameFromCommand Class | ComponentSpace.Ftp Namespace | RenameFromCommand Constructor Overload List


RenameFromCommand Constructor (String)

Initializes a new instance of the RenameFromCommand from the raw command text.

[Visual Basic]
Overloads Public Sub New( _
ByVal command As String _
)
[C#]
public RenameFromCommand(
string command
);

Parameters

command
The raw command text.

See Also

RenameFromCommand Class | ComponentSpace.Ftp Namespace | RenameFromCommand Constructor Overload List


RenameFromCommand Properties

The properties of the RenameFromCommand class are listed below. For a complete list of RenameFromCommand class members, see the RenameFromCommand Members topic.

Public Instance Properties

CommandType (inherited from FtpCommand) | Gets the command type.
PathName | Gets or sets the remote from path name.

See Also

RenameFromCommand Class | ComponentSpace.Ftp Namespace


RenameFromCommand.PathName Property

Gets or sets the remote from path name.

[Visual Basic]
Public Property PathName As String
[C#]
public string PathName {get; set;}

Property Value

The remote from path name.

See Also

RenameFromCommand Class | ComponentSpace.Ftp Namespace


RenameFromCommand Methods

The methods of the RenameFromCommand class are listed below. For a complete list of RenameFromCommand class members, see the RenameFromCommand Members topic.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString | Convert the command to the FTP command text.
ToTraceString (inherited from FtpCommand) | Convert the reply to the trace text.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

RenameFromCommand Class | ComponentSpace.Ftp Namespace


RenameFromCommand.ToString Method

Convert the command to the FTP command text.

[Visual Basic]
Overrides Public Function ToString() As String
[C#]
public override string ToString();

Return Value

The FTP command text.

See Also

RenameFromCommand Class | ComponentSpace.Ftp Namespace


RenameToCommand Class

Represents the FTP RNTO command.

For a list of all members of this type, see RenameToCommand Members.

System.Object
ComponentSpace.Ftp.FtpCommand
ComponentSpace.Ftp.RenameToCommand

[Visual Basic]
Public Class RenameToCommand
Inherits FtpCommand
[C#]
public class RenameToCommand : FtpCommand

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: ComponentSpace.Ftp

Assembly: ComponentSpace.Ftp (in ComponentSpace.Ftp.dll)

See Also

RenameToCommand Members | ComponentSpace.Ftp Namespace


RenameToCommand Members

RenameToCommand overview

Public Instance Constructors

RenameToCommand Overloaded. Initializes a new instance of the RenameToCommand class.

Public Instance Properties

CommandType (inherited from FtpCommand) | Gets the command type.
PathName | Gets or sets the remote to path name.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString | Convert the command to the FTP command text.
ToTraceString (inherited from FtpCommand) | Convert the reply to the trace text.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

RenameToCommand Class | ComponentSpace.Ftp Namespace


RenameToCommand Constructor

Initializes a new instance of the RenameToCommand.

Overload List

Initializes a new instance of the RenameToCommand.

public RenameToCommand();

Initializes a new instance of the RenameToCommand from the raw command text.

public RenameToCommand(string);

See Also

RenameToCommand Class | ComponentSpace.Ftp Namespace


RenameToCommand Constructor ()

Initializes a new instance of the RenameToCommand.

[Visual Basic]
Overloads Public Sub New()
[C#]
public RenameToCommand();

See Also

RenameToCommand Class | ComponentSpace.Ftp Namespace | RenameToCommand Constructor Overload List


RenameToCommand Constructor (String)

Initializes a new instance of the RenameToCommand from the raw command text.

[Visual Basic]
Overloads Public Sub New( _
ByVal command As String _
)
[C#]
public RenameToCommand(
string command
);

Parameters

command
The raw command text.

See Also

RenameToCommand Class | ComponentSpace.Ftp Namespace | RenameToCommand Constructor Overload List


RenameToCommand Properties

The properties of the RenameToCommand class are listed below. For a complete list of RenameToCommand class members, see the RenameToCommand Members topic.

Public Instance Properties

CommandType (inherited from FtpCommand) | Gets the command type.
PathName | Gets or sets the remote to path name.

See Also

RenameToCommand Class | ComponentSpace.Ftp Namespace


RenameToCommand.PathName Property

Gets or sets the remote to path name.

[Visual Basic]
Public Property PathName As String
[C#]
public string PathName {get; set;}

Property Value

The remote to path name.

See Also

RenameToCommand Class | ComponentSpace.Ftp Namespace


RenameToCommand Methods

The methods of the RenameToCommand class are listed below. For a complete list of RenameToCommand class members, see the RenameToCommand Members topic.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString | Convert the command to the FTP command text.
ToTraceString (inherited from FtpCommand) | Convert the reply to the trace text.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

RenameToCommand Class | ComponentSpace.Ftp Namespace


RenameToCommand.ToString Method

Convert the command to the FTP command text.

[Visual Basic]
Overrides Public Function ToString() As String
[C#]
public override string ToString();

Return Value

The FTP command text.

See Also

RenameToCommand Class | ComponentSpace.Ftp Namespace


RestartCommand Class

Represents the FTP REST command.

For a list of all members of this type, see RestartCommand Members.

System.Object
ComponentSpace.Ftp.FtpCommand
ComponentSpace.Ftp.RestartCommand

[Visual Basic]
Public Class RestartCommand
Inherits FtpCommand
[C#]
public class RestartCommand : FtpCommand

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: ComponentSpace.Ftp

Assembly: ComponentSpace.Ftp (in ComponentSpace.Ftp.dll)

See Also

RestartCommand Members | ComponentSpace.Ftp Namespace


RestartCommand Members

RestartCommand overview

Public Instance Constructors

RestartCommand Overloaded. Initializes a new instance of the RestartCommand class.

Public Instance Properties

CommandType (inherited from FtpCommand) | Gets the command type.
Marker | Gets or sets the restart marker.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString | Convert the command to the FTP command text.
ToTraceString (inherited from FtpCommand) | Convert the reply to the trace text.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

RestartCommand Class | ComponentSpace.Ftp Namespace


RestartCommand Constructor

Initializes a new instance of the RestartCommand.

Overload List

Initializes a new instance of the RestartCommand.

public RestartCommand();

Initializes a new instance of the RestartCommand from the raw command text.

public RestartCommand(string);

See Also

RestartCommand Class | ComponentSpace.Ftp Namespace


RestartCommand Constructor ()

Initializes a new instance of the RestartCommand.

[Visual Basic]
Overloads Public Sub New()
[C#]
public RestartCommand();

See Also

RestartCommand Class | ComponentSpace.Ftp Namespace | RestartCommand Constructor Overload List


RestartCommand Constructor (String)

Initializes a new instance of the RestartCommand from the raw command text.

[Visual Basic]
Overloads Public Sub New( _
ByVal command As String _
)
[C#]
public RestartCommand(
string command
);

Parameters

command
The raw command text.

See Also

RestartCommand Class | ComponentSpace.Ftp Namespace | RestartCommand Constructor Overload List


RestartCommand Properties

The properties of the RestartCommand class are listed below. For a complete list of RestartCommand class members, see the RestartCommand Members topic.

Public Instance Properties

CommandType (inherited from FtpCommand) | Gets the command type.
Marker | Gets or sets the restart marker.

See Also

RestartCommand Class | ComponentSpace.Ftp Namespace


RestartCommand.Marker Property

Gets or sets the restart marker.

[Visual Basic]
Public Property Marker As Long
[C#]
public long Marker {get; set;}

Property Value

The restart marker.

See Also

RestartCommand Class | ComponentSpace.Ftp Namespace


RestartCommand Methods

The methods of the RestartCommand class are listed below. For a complete list of RestartCommand class members, see the RestartCommand Members topic.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString | Convert the command to the FTP command text.
ToTraceString (inherited from FtpCommand) | Convert the reply to the trace text.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

RestartCommand Class | ComponentSpace.Ftp Namespace


RestartCommand.ToString Method

Convert the command to the FTP command text.

[Visual Basic]
Overrides Public Function ToString() As String
[C#]
public override string ToString();

Return Value

The FTP command text.

See Also

RestartCommand Class | ComponentSpace.Ftp Namespace


RetrieveCommand Class

Represents the FTP RETR command.

For a list of all members of this type, see RetrieveCommand Members.

System.Object
ComponentSpace.Ftp.FtpCommand
ComponentSpace.Ftp.RetrieveCommand

[Visual Basic]
Public Class RetrieveCommand
Inherits FtpCommand
[C#]
public class RetrieveCommand : FtpCommand

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: ComponentSpace.Ftp

Assembly: ComponentSpace.Ftp (in ComponentSpace.Ftp.dll)

See Also

RetrieveCommand Members | ComponentSpace.Ftp Namespace


RetrieveCommand Members

RetrieveCommand overview

Public Instance Constructors

RetrieveCommand Overloaded. Initializes a new instance of the RetrieveCommand class.

Public Instance Properties

CommandType (inherited from FtpCommand) | Gets the command type.
PathName | Gets or sets the remote path name.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString | Convert the command to the FTP command text.
ToTraceString (inherited from FtpCommand) | Convert the reply to the trace text.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

RetrieveCommand Class | ComponentSpace.Ftp Namespace


RetrieveCommand Constructor

Initializes a new instance of the RetrieveCommand.

Overload List

Initializes a new instance of the RetrieveCommand.

public RetrieveCommand();

Initializes a new instance of the RetrieveCommand from the raw command text.

public RetrieveCommand(string);

See Also

RetrieveCommand Class | ComponentSpace.Ftp Namespace


RetrieveCommand Constructor ()

Initializes a new instance of the RetrieveCommand.

[Visual Basic]
Overloads Public Sub New()
[C#]
public RetrieveCommand();

See Also

RetrieveCommand Class | ComponentSpace.Ftp Namespace | RetrieveCommand Constructor Overload List


RetrieveCommand Constructor (String)

Initializes a new instance of the RetrieveCommand from the raw command text.

[Visual Basic]
Overloads Public Sub New( _
ByVal command As String _
)
[C#]
public RetrieveCommand(
string command
);

Parameters

command
The raw command text.

See Also

RetrieveCommand Class | ComponentSpace.Ftp Namespace | RetrieveCommand Constructor Overload List


RetrieveCommand Properties

The properties of the RetrieveCommand class are listed below. For a complete list of RetrieveCommand class members, see the RetrieveCommand Members topic.

Public Instance Properties

CommandType (inherited from FtpCommand) | Gets the command type.
PathName | Gets or sets the remote path name.

See Also

RetrieveCommand Class | ComponentSpace.Ftp Namespace


RetrieveCommand.PathName Property

Gets or sets the remote path name.

[Visual Basic]
Public Property PathName As String
[C#]
public string PathName {get; set;}

Property Value

The remote path name.

See Also

RetrieveCommand Class | ComponentSpace.Ftp Namespace


RetrieveCommand Methods

The methods of the RetrieveCommand class are listed below. For a complete list of RetrieveCommand class members, see the RetrieveCommand Members topic.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString | Convert the command to the FTP command text.
ToTraceString (inherited from FtpCommand) | Convert the reply to the trace text.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

RetrieveCommand Class | ComponentSpace.Ftp Namespace


RetrieveCommand.ToString Method

Convert the command to the FTP command text.

[Visual Basic]
Overrides Public Function ToString() As String
[C#]
public override string ToString();

Return Value

The FTP command text.

See Also

RetrieveCommand Class | ComponentSpace.Ftp Namespace


SiteCommand Class

Represents the FTP SITE command.

For a list of all members of this type, see SiteCommand Members.

System.Object
ComponentSpace.Ftp.FtpCommand
ComponentSpace.Ftp.SiteCommand

[Visual Basic]
Public Class SiteCommand
Inherits FtpCommand
[C#]
public class SiteCommand : FtpCommand

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: ComponentSpace.Ftp

Assembly: ComponentSpace.Ftp (in ComponentSpace.Ftp.dll)

See Also

SiteCommand Members | ComponentSpace.Ftp Namespace


SiteCommand Members

SiteCommand overview

Public Instance Constructors

SiteCommand Overloaded. Initializes a new instance of the SiteCommand class.

Public Instance Properties

Arguments | Gets or sets the site arguments.
CommandType (inherited from FtpCommand) | Gets the command type.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString | Convert the command to the FTP command text.
ToTraceString (inherited from FtpCommand) | Convert the reply to the trace text.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

SiteCommand Class | ComponentSpace.Ftp Namespace


SiteCommand Constructor

Initializes a new instance of the SiteCommand.

Overload List

Initializes a new instance of the SiteCommand.

public SiteCommand();

Initializes a new instance of the SiteCommand from the raw command text.

public SiteCommand(string);

See Also

SiteCommand Class | ComponentSpace.Ftp Namespace


SiteCommand Constructor ()

Initializes a new instance of the SiteCommand.

[Visual Basic]
Overloads Public Sub New()
[C#]
public SiteCommand();

See Also

SiteCommand Class | ComponentSpace.Ftp Namespace | SiteCommand Constructor Overload List


SiteCommand Constructor (String)

Initializes a new instance of the SiteCommand from the raw command text.

[Visual Basic]
Overloads Public Sub New( _
ByVal command As String _
)
[C#]
public SiteCommand(
string command
);

Parameters

command
The raw command text.

See Also

SiteCommand Class | ComponentSpace.Ftp Namespace | SiteCommand Constructor Overload List


SiteCommand Properties

The properties of the SiteCommand class are listed below. For a complete list of SiteCommand class members, see the SiteCommand Members topic.

Public Instance Properties

Arguments | Gets or sets the site arguments.
CommandType (inherited from FtpCommand) | Gets the command type.

See Also

SiteCommand Class | ComponentSpace.Ftp Namespace


SiteCommand.Arguments Property

Gets or sets the site arguments.

[Visual Basic]
Public Property Arguments As String
[C#]
public string Arguments {get; set;}

Property Value

The site arguments.

See Also

SiteCommand Class | ComponentSpace.Ftp Namespace


SiteCommand Methods

The methods of the SiteCommand class are listed below. For a complete list of SiteCommand class members, see the SiteCommand Members topic.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString | Convert the command to the FTP command text.
ToTraceString (inherited from FtpCommand) | Convert the reply to the trace text.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

SiteCommand Class | ComponentSpace.Ftp Namespace


SiteCommand.ToString Method

Convert the command to the FTP command text.

[Visual Basic]
Overrides Public Function ToString() As String
[C#]
public override string ToString();

Return Value

The FTP command text.

See Also

SiteCommand Class | ComponentSpace.Ftp Namespace


StatusCommand Class

Represents the FTP STAT command.

For a list of all members of this type, see StatusCommand Members.

System.Object
ComponentSpace.Ftp.FtpCommand
ComponentSpace.Ftp.StatusCommand

[Visual Basic]
Public Class StatusCommand
Inherits FtpCommand
[C#]
public class StatusCommand : FtpCommand

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: ComponentSpace.Ftp

Assembly: ComponentSpace.Ftp (in ComponentSpace.Ftp.dll)

See Also

StatusCommand Members | ComponentSpace.Ftp Namespace


StatusCommand Members

StatusCommand overview

Public Instance Constructors

StatusCommand Overloaded. Initializes a new instance of the StatusCommand class.

Public Instance Properties

CommandType (inherited from FtpCommand) | Gets the command type.
PathName | Gets or sets the remote path name.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString | Convert the command to the FTP command text.
ToTraceString (inherited from FtpCommand) | Convert the reply to the trace text.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

StatusCommand Class | ComponentSpace.Ftp Namespace


StatusCommand Constructor

Initializes a new instance of the StatusCommand.

Overload List

Initializes a new instance of the StatusCommand.

public StatusCommand();

Initializes a new instance of the StatusCommand from the raw command text.

public StatusCommand(string);

See Also

StatusCommand Class | ComponentSpace.Ftp Namespace


StatusCommand Constructor ()

Initializes a new instance of the StatusCommand.

[Visual Basic]
Overloads Public Sub New()
[C#]
public StatusCommand();

See Also

StatusCommand Class | ComponentSpace.Ftp Namespace | StatusCommand Constructor Overload List


StatusCommand Constructor (String)

Initializes a new instance of the StatusCommand from the raw command text.

[Visual Basic]
Overloads Public Sub New( _
ByVal command As String _
)
[C#]
public StatusCommand(
string command
);

Parameters

command
The raw command text.

See Also

StatusCommand Class | ComponentSpace.Ftp Namespace | StatusCommand Constructor Overload List


StatusCommand Properties

The properties of the StatusCommand class are listed below. For a complete list of StatusCommand class members, see the StatusCommand Members topic.

Public Instance Properties

CommandType (inherited from FtpCommand) | Gets the command type.
PathName | Gets or sets the remote path name.

See Also

StatusCommand Class | ComponentSpace.Ftp Namespace


StatusCommand.PathName Property

Gets or sets the remote path name.

[Visual Basic]
Public Property PathName As String
[C#]
public string PathName {get; set;}

Property Value

The remote path name.

See Also

StatusCommand Class | ComponentSpace.Ftp Namespace


StatusCommand Methods

The methods of the StatusCommand class are listed below. For a complete list of StatusCommand class members, see the StatusCommand Members topic.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString | Convert the command to the FTP command text.
ToTraceString (inherited from FtpCommand) | Convert the reply to the trace text.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

StatusCommand Class | ComponentSpace.Ftp Namespace


StatusCommand.ToString Method

Convert the command to the FTP command text.

[Visual Basic]
Overrides Public Function ToString() As String
[C#]
public override string ToString();

Return Value

The FTP command text.

See Also

StatusCommand Class | ComponentSpace.Ftp Namespace


StoreCommand Class

Represents the FTP STOR command.

For a list of all members of this type, see StoreCommand Members.

System.Object
ComponentSpace.Ftp.FtpCommand
ComponentSpace.Ftp.StoreCommand

[Visual Basic]
Public Class StoreCommand
Inherits FtpCommand
[C#]
public class StoreCommand : FtpCommand

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: ComponentSpace.Ftp

Assembly: ComponentSpace.Ftp (in ComponentSpace.Ftp.dll)

See Also

StoreCommand Members | ComponentSpace.Ftp Namespace


StoreCommand Members

StoreCommand overview

Public Instance Constructors

StoreCommand Overloaded. Initializes a new instance of the StoreCommand class.

Public Instance Properties

CommandType (inherited from FtpCommand) | Gets the command type.
PathName | Gets or sets the remote path name.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString | Convert the command to the FTP command text.
ToTraceString (inherited from FtpCommand) | Convert the reply to the trace text.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

StoreCommand Class | ComponentSpace.Ftp Namespace


StoreCommand Constructor

Initializes a new instance of the StoreCommand.

Overload List

Initializes a new instance of the StoreCommand.

public StoreCommand();

Initializes a new instance of the StoreCommand from the raw command text.

public StoreCommand(string);

See Also

StoreCommand Class | ComponentSpace.Ftp Namespace


StoreCommand Constructor ()

Initializes a new instance of the StoreCommand.

[Visual Basic]
Overloads Public Sub New()
[C#]
public StoreCommand();

See Also

StoreCommand Class | ComponentSpace.Ftp Namespace | StoreCommand Constructor Overload List


StoreCommand Constructor (String)

Initializes a new instance of the StoreCommand from the raw command text.

[Visual Basic]
Overloads Public Sub New( _
ByVal command As String _
)
[C#]
public StoreCommand(
string command
);

Parameters

command
The raw command text.

See Also

StoreCommand Class | ComponentSpace.Ftp Namespace | StoreCommand Constructor Overload List


StoreCommand Properties

The properties of the StoreCommand class are listed below. For a complete list of StoreCommand class members, see the StoreCommand Members topic.

Public Instance Properties

CommandType (inherited from FtpCommand) | Gets the command type.
PathName | Gets or sets the remote path name.

See Also

StoreCommand Class | ComponentSpace.Ftp Namespace


StoreCommand.PathName Property

Gets or sets the remote path name.

[Visual Basic]
Public Property PathName As String
[C#]
public string PathName {get; set;}

Property Value

The remote path name.

See Also

StoreCommand Class | ComponentSpace.Ftp Namespace


StoreCommand Methods

The methods of the StoreCommand class are listed below. For a complete list of StoreCommand class members, see the StoreCommand Members topic.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString | Convert the command to the FTP command text.
ToTraceString (inherited from FtpCommand) | Convert the reply to the trace text.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

StoreCommand Class | ComponentSpace.Ftp Namespace


StoreCommand.ToString Method

Convert the command to the FTP command text.

[Visual Basic]
Overrides Public Function ToString() As String
[C#]
public override string ToString();

Return Value

The FTP command text.

See Also

StoreCommand Class | ComponentSpace.Ftp Namespace


StoreUniqueCommand Class

Represents the FTP STOU command.

For a list of all members of this type, see StoreUniqueCommand Members.

System.Object
ComponentSpace.Ftp.FtpCommand
ComponentSpace.Ftp.StoreUniqueCommand

[Visual Basic]
Public Class StoreUniqueCommand
Inherits FtpCommand
[C#]
public class StoreUniqueCommand : FtpCommand

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: ComponentSpace.Ftp

Assembly: ComponentSpace.Ftp (in ComponentSpace.Ftp.dll)

See Also

StoreUniqueCommand Members | ComponentSpace.Ftp Namespace


StoreUniqueCommand Members

StoreUniqueCommand overview

Public Instance Constructors

StoreUniqueCommand Overloaded. Initializes a new instance of the StoreUniqueCommand class.

Public Instance Properties

CommandType (inherited from FtpCommand) Gets the command type.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString | Convert the command to the FTP command text.
ToTraceString (inherited from FtpCommand) | Convert the reply to the trace text.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

StoreUniqueCommand Class | ComponentSpace.Ftp Namespace


StoreUniqueCommand Constructor

Initializes a new instance of the StoreUniqueCommand.

Overload List

Initializes a new instance of the StoreUniqueCommand.

public StoreUniqueCommand();

Initializes a new instance of the StoreUniqueCommand from the raw command text.

public StoreUniqueCommand(string);

See Also

StoreUniqueCommand Class | ComponentSpace.Ftp Namespace


StoreUniqueCommand Constructor ()

Initializes a new instance of the StoreUniqueCommand.

[Visual Basic]
Overloads Public Sub New()
[C#]
public StoreUniqueCommand();

See Also

StoreUniqueCommand Class | ComponentSpace.Ftp Namespace | StoreUniqueCommand Constructor Overload List


StoreUniqueCommand Constructor (String)

Initializes a new instance of the StoreUniqueCommand from the raw command text.

[Visual Basic]
Overloads Public Sub New( _
ByVal command As String _
)
[C#]
public StoreUniqueCommand(
string command
);

Parameters

command
The raw command text.

See Also

StoreUniqueCommand Class | ComponentSpace.Ftp Namespace | StoreUniqueCommand Constructor Overload List


StoreUniqueCommand Methods

The methods of the StoreUniqueCommand class are listed below. For a complete list of StoreUniqueCommand class members, see the StoreUniqueCommand Members topic.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString | Convert the command to the FTP command text.
ToTraceString (inherited from FtpCommand) | Convert the reply to the trace text.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

StoreUniqueCommand Class | ComponentSpace.Ftp Namespace


StoreUniqueCommand.ToString Method

Convert the command to the FTP command text.

[Visual Basic]
Overrides Public Function ToString() As String
[C#]
public override string ToString();

Return Value

The FTP command text.

See Also

StoreUniqueCommand Class | ComponentSpace.Ftp Namespace


StructureCommand Class

Represents the FTP STRU command.

For a list of all members of this type, see StructureCommand Members.

System.Object
ComponentSpace.Ftp.FtpCommand
ComponentSpace.Ftp.StructureCommand

[Visual Basic]
Public Class StructureCommand
Inherits FtpCommand
[C#]
public class StructureCommand : FtpCommand

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: ComponentSpace.Ftp

Assembly: ComponentSpace.Ftp (in ComponentSpace.Ftp.dll)

See Also

StructureCommand Members | ComponentSpace.Ftp Namespace


StructureCommand Members

StructureCommand overview

Public Instance Constructors

StructureCommand Overloaded. Initializes a new instance of the StructureCommand class.

Public Instance Properties

CommandType (inherited from FtpCommand) | Gets the command type.
StructureCode | Gets or sets the structure code.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString | Convert the command to the FTP command text.
ToTraceString (inherited from FtpCommand) | Convert the reply to the trace text.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

StructureCommand Class | ComponentSpace.Ftp Namespace


StructureCommand Constructor

Initializes a new instance of the StructureCommand.

Overload List

Initializes a new instance of the StructureCommand.

public StructureCommand();

Initializes a new instance of the StructureCommand from the raw command text.

public StructureCommand(string);

See Also

StructureCommand Class | ComponentSpace.Ftp Namespace


StructureCommand Constructor ()

Initializes a new instance of the StructureCommand.

[Visual Basic]
Overloads Public Sub New()
[C#]
public StructureCommand();

See Also

StructureCommand Class | ComponentSpace.Ftp Namespace | StructureCommand Constructor Overload List


StructureCommand Constructor (String)

Initializes a new instance of the StructureCommand from the raw command text.

[Visual Basic]
Overloads Public Sub New( _
ByVal command As String _
)
[C#]
public StructureCommand(
string command
);

Parameters

command
The raw command text.

See Also

StructureCommand Class | ComponentSpace.Ftp Namespace | StructureCommand Constructor Overload List


StructureCommand Properties

The properties of the StructureCommand class are listed below. For a complete list of StructureCommand class members, see the StructureCommand Members topic.

Public Instance Properties

CommandType (inherited from FtpCommand) | Gets the command type.
StructureCode | Gets or sets the structure code.

See Also

StructureCommand Class | ComponentSpace.Ftp Namespace


StructureCommand.StructureCode Property

Gets or sets the structure code.

[Visual Basic]
Public Property StructureCode As Char
[C#]
public char StructureCode {get; set;}

Property Value

The structure code.

See Also

StructureCommand Class | ComponentSpace.Ftp Namespace


StructureCommand Methods

The methods of the StructureCommand class are listed below. For a complete list of StructureCommand class members, see the StructureCommand Members topic.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString | Convert the command to the FTP command text.
ToTraceString (inherited from FtpCommand) | Convert the reply to the trace text.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

StructureCommand Class | ComponentSpace.Ftp Namespace


StructureCommand.ToString Method

Convert the command to the FTP command text.

[Visual Basic]
Overrides Public Function ToString() As String
[C#]
public override string ToString();

Return Value

The FTP command text.

See Also

StructureCommand Class | ComponentSpace.Ftp Namespace


StructureMountCommand Class

Represents the FTP SMNT command.

For a list of all members of this type, see StructureMountCommand Members.

System.Object
ComponentSpace.Ftp.FtpCommand
ComponentSpace.Ftp.StructureMountCommand

[Visual Basic]
Public Class StructureMountCommand
Inherits FtpCommand
[C#]
public class StructureMountCommand : FtpCommand

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: ComponentSpace.Ftp

Assembly: ComponentSpace.Ftp (in ComponentSpace.Ftp.dll)

See Also

StructureMountCommand Members | ComponentSpace.Ftp Namespace


StructureMountCommand Members

StructureMountCommand overview

Public Instance Constructors

StructureMountCommand Overloaded. Initializes a new instance of the StructureMountCommand class.

Public Instance Properties

CommandType (inherited from FtpCommand) | Gets the command type.
PathName | Gets or sets the remote path name.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString | Convert the command to the FTP command text.
ToTraceString (inherited from FtpCommand) | Convert the reply to the trace text.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

StructureMountCommand Class | ComponentSpace.Ftp Namespace


StructureMountCommand Constructor

Initializes a new instance of the StructureMountCommand.

Overload List

Initializes a new instance of the StructureMountCommand.

public StructureMountCommand();

Initializes a new instance of the StructureMountCommand from the raw command text.

public StructureMountCommand(string);

See Also

StructureMountCommand Class | ComponentSpace.Ftp Namespace


StructureMountCommand Constructor ()

Initializes a new instance of the StructureMountCommand.

[Visual Basic]
Overloads Public Sub New()
[C#]
public StructureMountCommand();

See Also

StructureMountCommand Class | ComponentSpace.Ftp Namespace | StructureMountCommand Constructor Overload List


StructureMountCommand Constructor (String)

Initializes a new instance of the StructureMountCommand from the raw command text.

[Visual Basic]
Overloads Public Sub New( _
ByVal command As String _
)
[C#]
public StructureMountCommand(
string command
);

Parameters

command
The raw command text.

See Also

StructureMountCommand Class | ComponentSpace.Ftp Namespace | StructureMountCommand Constructor Overload List


StructureMountCommand Properties

The properties of the StructureMountCommand class are listed below. For a complete list of StructureMountCommand class members, see the StructureMountCommand Members topic.

Public Instance Properties

CommandType (inherited from FtpCommand) | Gets the command type.
PathName | Gets or sets the remote path name.

See Also

StructureMountCommand Class | ComponentSpace.Ftp Namespace


StructureMountCommand.PathName Property

Gets or sets the remote path name.

[Visual Basic]
Public Property PathName As String
[C#]
public string PathName {get; set;}

Property Value

The remote path name.

See Also

StructureMountCommand Class | ComponentSpace.Ftp Namespace


StructureMountCommand Methods

The methods of the StructureMountCommand class are listed below. For a complete list of StructureMountCommand class members, see the StructureMountCommand Members topic.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString | Convert the command to the FTP command text.
ToTraceString (inherited from FtpCommand) | Convert the reply to the trace text.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

StructureMountCommand Class | ComponentSpace.Ftp Namespace


StructureMountCommand.ToString Method

Convert the command to the FTP command text.

[Visual Basic]
Overrides Public Function ToString() As String
[C#]
public override string ToString();

Return Value

The FTP command text.

See Also

StructureMountCommand Class | ComponentSpace.Ftp Namespace


SystemCommand Class

Represents the FTP SYST command.

For a list of all members of this type, see SystemCommand Members.

System.Object
ComponentSpace.Ftp.FtpCommand
ComponentSpace.Ftp.SystemCommand

[Visual Basic]
Public Class SystemCommand
Inherits FtpCommand
[C#]
public class SystemCommand : FtpCommand

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: ComponentSpace.Ftp

Assembly: ComponentSpace.Ftp (in ComponentSpace.Ftp.dll)

See Also

SystemCommand Members | ComponentSpace.Ftp Namespace


SystemCommand Members

SystemCommand overview

Public Instance Constructors

SystemCommand Overloaded. Initializes a new instance of the SystemCommand class.

Public Instance Properties

CommandType (inherited from FtpCommand) Gets the command type.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString | Convert the command to the FTP command text.
ToTraceString (inherited from FtpCommand) | Convert the reply to the trace text.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

SystemCommand Class | ComponentSpace.Ftp Namespace


SystemCommand Constructor

Initializes a new instance of the SystemCommand.

Overload List

Initializes a new instance of the SystemCommand.

public SystemCommand();

Initializes a new instance of the SystemCommand from the raw command text.

public SystemCommand(string);

See Also

SystemCommand Class | ComponentSpace.Ftp Namespace


SystemCommand Constructor ()

Initializes a new instance of the SystemCommand.

[Visual Basic]
Overloads Public Sub New()
[C#]
public SystemCommand();

See Also

SystemCommand Class | ComponentSpace.Ftp Namespace | SystemCommand Constructor Overload List


SystemCommand Constructor (String)

Initializes a new instance of the SystemCommand from the raw command text.

[Visual Basic]
Overloads Public Sub New( _
ByVal command As String _
)
[C#]
public SystemCommand(
string command
);

Parameters

command
The raw command text.

See Also

SystemCommand Class | ComponentSpace.Ftp Namespace | SystemCommand Constructor Overload List


SystemCommand Methods

The methods of the SystemCommand class are listed below. For a complete list of SystemCommand class members, see the SystemCommand Members topic.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString | Convert the command to the FTP command text.
ToTraceString (inherited from FtpCommand) | Convert the reply to the trace text.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

SystemCommand Class | ComponentSpace.Ftp Namespace


SystemCommand.ToString Method

Convert the command to the FTP command text.

[Visual Basic]
Overrides Public Function ToString() As String
[C#]
public override string ToString();

Return Value

The FTP command text.

See Also

SystemCommand Class | ComponentSpace.Ftp Namespace


TransferMode Enumeration

The transfer mode type.

[Visual Basic]
Public Enum TransferMode
[C#]
public enum TransferMode

Members

Member Name | Description
Ascii | ASCII.
Binary | Binary.

Requirements

Namespace: ComponentSpace.Ftp

Assembly: ComponentSpace.Ftp (in ComponentSpace.Ftp.dll)

See Also

ComponentSpace.Ftp Namespace


TypeCommand Class

Represents the FTP TYPE command.

For a list of all members of this type, see TypeCommand Members.

System.Object
ComponentSpace.Ftp.FtpCommand
ComponentSpace.Ftp.TypeCommand

[Visual Basic]
Public Class TypeCommand
Inherits FtpCommand
[C#]
public class TypeCommand : FtpCommand

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: ComponentSpace.Ftp

Assembly: ComponentSpace.Ftp (in ComponentSpace.Ftp.dll)

See Also

TypeCommand Members | ComponentSpace.Ftp Namespace


TypeCommand Members

TypeCommand overview

Public Static (Shared) Fields

asciiTypeCode | ASCII type code.
carriageControltFormatCode | Carriage control format code.
ebcdicTypeCode | EBCDIC type code.
imageTypeCode | Image type code.
localByteTypeCode | Local byte type code.
nonprintFormatCode | Non-print format code.
telnetFormatCode | Telnet format code.

Public Instance Constructors

TypeCommand Overloaded. Initializes a new instance of the TypeCommand class.

Public Instance Properties

ByteSize | Gets or sets the byte size.
CommandType (inherited from FtpCommand) | Gets the command type.
FormatCode | Gets or sets the format code.
TypeCode | Gets or sets the type code.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString | Convert the command to the FTP command text.
ToTraceString (inherited from FtpCommand) | Convert the reply to the trace text.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

TypeCommand Class | ComponentSpace.Ftp Namespace


TypeCommand Constructor

Initializes a new instance of the TypeCommand.

Overload List

Initializes a new instance of the TypeCommand.

public TypeCommand();

Initializes a new instance of the TypeCommand from the raw command text.

public TypeCommand(string);

See Also

TypeCommand Class | ComponentSpace.Ftp Namespace


TypeCommand Constructor ()

Initializes a new instance of the TypeCommand.

[Visual Basic]
Overloads Public Sub New()
[C#]
public TypeCommand();

See Also

TypeCommand Class | ComponentSpace.Ftp Namespace | TypeCommand Constructor Overload List


TypeCommand Constructor (String)

Initializes a new instance of the TypeCommand from the raw command text.

[Visual Basic]
Overloads Public Sub New( _
ByVal command As String _
)
[C#]
public TypeCommand(
string command
);

Parameters

command
The raw command text.

See Also

TypeCommand Class | ComponentSpace.Ftp Namespace | TypeCommand Constructor Overload List


TypeCommand Fields

The fields of the TypeCommand class are listed below. For a complete list of TypeCommand class members, see the TypeCommand Members topic.

Public Static (Shared) Fields

asciiTypeCode | ASCII type code.
carriageControltFormatCode | Carriage control format code.
ebcdicTypeCode | EBCDIC type code.
imageTypeCode | Image type code.
localByteTypeCode | Local byte type code.
nonprintFormatCode | Non-print format code.
telnetFormatCode | Telnet format code.

See Also

TypeCommand Class | ComponentSpace.Ftp Namespace


TypeCommand.asciiTypeCode Field

ASCII type code.

[Visual Basic]
Public Const asciiTypeCode As Char = A
[C#]
public const char asciiTypeCode = A;

See Also

TypeCommand Class | ComponentSpace.Ftp Namespace


TypeCommand.carriageControltFormatCode Field

Carriage control format code.

[Visual Basic]
Public Const carriageControltFormatCode As Char = C
[C#]
public const char carriageControltFormatCode = C;

See Also

TypeCommand Class | ComponentSpace.Ftp Namespace


TypeCommand.ebcdicTypeCode Field

EBCDIC type code.

[Visual Basic]
Public Const ebcdicTypeCode As Char = E
[C#]
public const char ebcdicTypeCode = E;

See Also

TypeCommand Class | ComponentSpace.Ftp Namespace


TypeCommand.imageTypeCode Field

Image type code.

[Visual Basic]
Public Const imageTypeCode As Char = I
[C#]
public const char imageTypeCode = I;

See Also

TypeCommand Class | ComponentSpace.Ftp Namespace


TypeCommand.localByteTypeCode Field

Local byte type code.

[Visual Basic]
Public Const localByteTypeCode As Char = L
[C#]
public const char localByteTypeCode = L;

See Also

TypeCommand Class | ComponentSpace.Ftp Namespace


TypeCommand.nonprintFormatCode Field

Non-print format code.

[Visual Basic]
Public Const nonprintFormatCode As Char = N
[C#]
public const char nonprintFormatCode = N;

See Also

TypeCommand Class | ComponentSpace.Ftp Namespace


TypeCommand.telnetFormatCode Field

Telnet format code.

[Visual Basic]
Public Const telnetFormatCode As Char = T
[C#]
public const char telnetFormatCode = T;

See Also

TypeCommand Class | ComponentSpace.Ftp Namespace


TypeCommand Properties

The properties of the TypeCommand class are listed below. For a complete list of TypeCommand class members, see the TypeCommand Members topic.

Public Instance Properties

ByteSize | Gets or sets the byte size.
CommandType (inherited from FtpCommand) | Gets the command type.
FormatCode | Gets or sets the format code.
TypeCode | Gets or sets the type code.

See Also

TypeCommand Class | ComponentSpace.Ftp Namespace


TypeCommand.ByteSize Property

Gets or sets the byte size.

[Visual Basic]
Public Property ByteSize As Long
[C#]
public long ByteSize {get; set;}

Property Value

The byte size.

See Also

TypeCommand Class | ComponentSpace.Ftp Namespace


TypeCommand.FormatCode Property

Gets or sets the format code.

[Visual Basic]
Public Property FormatCode As Char
[C#]
public char FormatCode {get; set;}

Property Value

The format code. Defaults to nonprintable.

See Also

TypeCommand Class | ComponentSpace.Ftp Namespace


TypeCommand.TypeCode Property

Gets or sets the type code.

[Visual Basic]
Public Property TypeCode As Char
[C#]
public char TypeCode {get; set;}

Property Value

The type code. Defaults to Ascii.

See Also

TypeCommand Class | ComponentSpace.Ftp Namespace


TypeCommand Methods

The methods of the TypeCommand class are listed below. For a complete list of TypeCommand class members, see the TypeCommand Members topic.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString | Convert the command to the FTP command text.
ToTraceString (inherited from FtpCommand) | Convert the reply to the trace text.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

TypeCommand Class | ComponentSpace.Ftp Namespace


TypeCommand.ToString Method

Convert the command to the FTP command text.

[Visual Basic]
Overrides Public Function ToString() As String
[C#]
public override string ToString();

Return Value

The FTP command text.

See Also

TypeCommand Class | ComponentSpace.Ftp Namespace


UnixDirectoryListItem Class

A Unix directory list items.

For a list of all members of this type, see UnixDirectoryListItem Members.

System.Object
ComponentSpace.Ftp.DirectoryListItem
ComponentSpace.Ftp.UnixDirectoryListItem

[Visual Basic]
Public Class UnixDirectoryListItem
Inherits DirectoryListItem
[C#]
public class UnixDirectoryListItem : DirectoryListItem

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: ComponentSpace.Ftp

Assembly: ComponentSpace.Ftp (in ComponentSpace.Ftp.dll)

See Also

UnixDirectoryListItem Members | ComponentSpace.Ftp Namespace


UnixDirectoryListItem Members

UnixDirectoryListItem overview

Public Instance Constructors

UnixDirectoryListItem Constructor Initializes a new instance of the UnixDirectoryListItem.

Public Instance Properties

Date (inherited from DirectoryListItem) | Gets the unprocessed remote directory item date as returned by the FTP server.
DateTime (inherited from DirectoryListItem) | Gets the DateTime.
Group | Gets remote directory item group.
Inodes | Gets remote directory item inodes.
ItemType (inherited from DirectoryListItem) | Gets the remote directory item type.
Name (inherited from DirectoryListItem) | Gets the remote directory item name.
Owner | Gets remote directory item owner.
Permissions | Gets remote directory item permissions.
Size (inherited from DirectoryListItem) | Gets the remote directory item size.
SoftLink (inherited from DirectoryListItem) | Gets soft link.
Time (inherited from DirectoryListItem) | Gets the unprocessed remote directory item time as returned by the FTP server.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

UnixDirectoryListItem Class | ComponentSpace.Ftp Namespace


UnixDirectoryListItem Constructor

Initializes a new instance of the UnixDirectoryListItem.

[Visual Basic]
Public Sub New( _
ByVal permissions As String, _
ByVal inodes As Long, _
ByVal owner As String, _
ByVal group As String, _
ByVal size As Long, _
ByVal date As String, _
ByVal time As String, _
ByVal name As String _
)
[C#]
public UnixDirectoryListItem(
string permissions,
long inodes,
string owner,
string group,
long size,
string date,
string time,
string name
);

Parameters

permissions
The directory item permissions.
inodes
The directory item inodes.
owner
The directory item owner.
group
The directory item group.
size
The directory item size.
date
The directory item date.
time
The directory item time.
name
The directory item name.

See Also

UnixDirectoryListItem Class | ComponentSpace.Ftp Namespace


UnixDirectoryListItem Properties

The properties of the UnixDirectoryListItem class are listed below. For a complete list of UnixDirectoryListItem class members, see the UnixDirectoryListItem Members topic.

Public Instance Properties

Date (inherited from DirectoryListItem) | Gets the unprocessed remote directory item date as returned by the FTP server.
DateTime (inherited from DirectoryListItem) | Gets the DateTime.
Group | Gets remote directory item group.
Inodes | Gets remote directory item inodes.
ItemType (inherited from DirectoryListItem) | Gets the remote directory item type.
Name (inherited from DirectoryListItem) | Gets the remote directory item name.
Owner | Gets remote directory item owner.
Permissions | Gets remote directory item permissions.
Size (inherited from DirectoryListItem) | Gets the remote directory item size.
SoftLink (inherited from DirectoryListItem) | Gets soft link.
Time (inherited from DirectoryListItem) | Gets the unprocessed remote directory item time as returned by the FTP server.

See Also

UnixDirectoryListItem Class | ComponentSpace.Ftp Namespace


UnixDirectoryListItem.Group Property

Gets remote directory item group.

[Visual Basic]
Overridable Public ReadOnly Property Group As String
[C#]
public virtual string Group {get;}

Property Value

The remote directory item group.

See Also

UnixDirectoryListItem Class | ComponentSpace.Ftp Namespace


UnixDirectoryListItem.Inodes Property

Gets remote directory item inodes.

[Visual Basic]
Overridable Public ReadOnly Property Inodes As Long
[C#]
public virtual long Inodes {get;}

Property Value

The remote directory item inodes.

See Also

UnixDirectoryListItem Class | ComponentSpace.Ftp Namespace


UnixDirectoryListItem.Owner Property

Gets remote directory item owner.

[Visual Basic]
Overridable Public ReadOnly Property Owner As String
[C#]
public virtual string Owner {get;}

Property Value

The remote directory item owner.

See Also

UnixDirectoryListItem Class | ComponentSpace.Ftp Namespace


UnixDirectoryListItem.Permissions Property

Gets remote directory item permissions.

[Visual Basic]
Overridable Public ReadOnly Property Permissions As String
[C#]
public virtual string Permissions {get;}

Property Value

The remote directory item permissions.

See Also

UnixDirectoryListItem Class | ComponentSpace.Ftp Namespace


UserNameCommand Class

Represents the FTP USER command.

For a list of all members of this type, see UserNameCommand Members.

System.Object
ComponentSpace.Ftp.FtpCommand
ComponentSpace.Ftp.UserNameCommand

[Visual Basic]
Public Class UserNameCommand
Inherits FtpCommand
[C#]
public class UserNameCommand : FtpCommand

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: ComponentSpace.Ftp

Assembly: ComponentSpace.Ftp (in ComponentSpace.Ftp.dll)

See Also

UserNameCommand Members | ComponentSpace.Ftp Namespace


UserNameCommand Members

UserNameCommand overview

Public Instance Constructors

UserNameCommand Overloaded. Initializes a new instance of the UserNameCommand class.

Public Instance Properties

CommandType (inherited from FtpCommand) | Gets the command type.
UserName | Gets or sets the user name.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString | Convert the command to the FTP command text.
ToTraceString (inherited from FtpCommand) | Convert the reply to the trace text.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

UserNameCommand Class | ComponentSpace.Ftp Namespace


UserNameCommand Constructor

Initializes a new instance of the UserNameCommand.

Overload List

Initializes a new instance of the UserNameCommand.

public UserNameCommand();

Initializes a new instance of the UserNameCommand from the raw command text.

public UserNameCommand(string);

See Also

UserNameCommand Class | ComponentSpace.Ftp Namespace


UserNameCommand Constructor ()

Initializes a new instance of the UserNameCommand.

[Visual Basic]
Overloads Public Sub New()
[C#]
public UserNameCommand();

See Also

UserNameCommand Class | ComponentSpace.Ftp Namespace | UserNameCommand Constructor Overload List


UserNameCommand Constructor (String)

Initializes a new instance of the UserNameCommand from the raw command text.

[Visual Basic]
Overloads Public Sub New( _
ByVal command As String _
)
[C#]
public UserNameCommand(
string command
);

Parameters

command
The raw command text.

See Also

UserNameCommand Class | ComponentSpace.Ftp Namespace | UserNameCommand Constructor Overload List


UserNameCommand Properties

The properties of the UserNameCommand class are listed below. For a complete list of UserNameCommand class members, see the UserNameCommand Members topic.

Public Instance Properties

CommandType (inherited from FtpCommand) | Gets the command type.
UserName | Gets or sets the user name.

See Also

UserNameCommand Class | ComponentSpace.Ftp Namespace


UserNameCommand.UserName Property

Gets or sets the user name.

[Visual Basic]
Public Property UserName As String
[C#]
public string UserName {get; set;}

Property Value

The user name.

See Also

UserNameCommand Class | ComponentSpace.Ftp Namespace


UserNameCommand Methods

The methods of the UserNameCommand class are listed below. For a complete list of UserNameCommand class members, see the UserNameCommand Members topic.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString | Convert the command to the FTP command text.
ToTraceString (inherited from FtpCommand) | Convert the reply to the trace text.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

UserNameCommand Class | ComponentSpace.Ftp Namespace


UserNameCommand.ToString Method

Convert the command to the FTP command text.

[Visual Basic]
Overrides Public Function ToString() As String
[C#]
public override string ToString();

Return Value

The FTP command text.

See Also

UserNameCommand Class | ComponentSpace.Ftp Namespace


FtpCommand Hierarchy

System.Object
FtpCommand
AbortCommand
AccountCommand
AllocateCommand
AppendCommand
ChangeToParentDirectoryCommand
ChangeWorkingDirectoryCommand
DeleteCommand
FileModificationTimeCommand
HelpCommand
ListCommand
MakeDirectoryCommand
ModeCommand
NameListCommand
NoopCommand
PassiveCommand
PasswordCommand
PortCommand
PrintWorkingDirectoryCommand
QuitCommand
ReinitializeCommand
RemoveDirectoryCommand
RenameFromCommand
RenameToCommand
RestartCommand
RetrieveCommand
SiteCommand
StatusCommand
StoreCommand
StoreUniqueCommand
StructureCommand
StructureMountCommand
SystemCommand
TypeCommand
UserNameCommand

See Also

FtpCommand Class | FtpCommand Members | ComponentSpace.Ftp Namespace


ComponentSpace.FtpHierarchy

ComponentSpace FTP Class Library Reference

ComponentSpace.Ftp Hierarchy

System.Object
ComponentSpace.Ftp.DirectoryListItem
ComponentSpace.Ftp.MSDOSDirectoryListItem
ComponentSpace.Ftp.UnixDirectoryListItem
ComponentSpace.Ftp.DirectoryListParser
ComponentSpace.Ftp.FailSafeTransfer
ComponentSpace.Ftp.FtpClient ---- System.IDisposable
ComponentSpace.Ftp.FtpCommand
ComponentSpace.Ftp.AbortCommand
ComponentSpace.Ftp.AccountCommand
ComponentSpace.Ftp.AllocateCommand
ComponentSpace.Ftp.AppendCommand
ComponentSpace.Ftp.ChangeToParentDirectoryCommand
ComponentSpace.Ftp.ChangeWorkingDirectoryCommand
ComponentSpace.Ftp.DeleteCommand
ComponentSpace.Ftp.FileModificationTimeCommand
ComponentSpace.Ftp.HelpCommand
ComponentSpace.Ftp.ListCommand
ComponentSpace.Ftp.MakeDirectoryCommand
ComponentSpace.Ftp.ModeCommand
ComponentSpace.Ftp.NameListCommand
ComponentSpace.Ftp.NoopCommand
ComponentSpace.Ftp.PassiveCommand
ComponentSpace.Ftp.PasswordCommand
ComponentSpace.Ftp.PortCommand
ComponentSpace.Ftp.PrintWorkingDirectoryCommand
ComponentSpace.Ftp.QuitCommand
ComponentSpace.Ftp.ReinitializeCommand
ComponentSpace.Ftp.RemoveDirectoryCommand
ComponentSpace.Ftp.RenameFromCommand
ComponentSpace.Ftp.RenameToCommand
ComponentSpace.Ftp.RestartCommand
ComponentSpace.Ftp.RetrieveCommand
ComponentSpace.Ftp.SiteCommand
ComponentSpace.Ftp.StatusCommand
ComponentSpace.Ftp.StoreCommand
ComponentSpace.Ftp.StoreUniqueCommand
ComponentSpace.Ftp.StructureCommand
ComponentSpace.Ftp.StructureMountCommand
ComponentSpace.Ftp.SystemCommand
ComponentSpace.Ftp.TypeCommand
ComponentSpace.Ftp.UserNameCommand
ComponentSpace.Ftp.FtpCommandConnection ---- System.IDisposable
ComponentSpace.Ftp.FtpCommandReply
ComponentSpace.Ftp.FtpDataConnection ---- System.IDisposable
ComponentSpace.Ftp.FtpWebRequestCreator ---- System.Net.IWebRequestCreate
ComponentSpace.Ftp.IFileFilter
ComponentSpace.Ftp.MultiFile
ComponentSpace.Ftp.RemoteDirectory
ComponentSpace.Ftp.RemoteFile
System.Delegate ---- System.ICloneable, System.Runtime.Serialization.ISerializable
System.MulticastDelegate
ComponentSpace.Ftp.CommandTracedEventHandler
ComponentSpace.Ftp.DataTransferredEventHandler
ComponentSpace.Ftp.FailSafeTransferEventHandler
ComponentSpace.Ftp.FtpOperationCompletedEventHandler
ComponentSpace.Ftp.ListLineAvailableEventHandler
ComponentSpace.Ftp.MultiFileEventHandler
System.EventArgs
ComponentSpace.Ftp.CommandTracedEventArgs
ComponentSpace.Ftp.DataTransferredEventArgs
ComponentSpace.Ftp.FailSafeTransferEventArgs
ComponentSpace.Ftp.FtpOperationCompletedEventArgs
ComponentSpace.Ftp.ListLineAvailableEventArgs
ComponentSpace.Ftp.MultiFileEventArgs
System.Exception ---- System.Runtime.Serialization.ISerializable
System.ApplicationException
ComponentSpace.Ftp.FtpException
System.MarshalByRefObject
System.ComponentModel.Component ---- System.ComponentModel.IComponent, System.IDisposable
ComponentSpace.Ftp.FtpClientComponent
System.Net.WebRequest ---- System.Runtime.Serialization.ISerializable
ComponentSpace.Ftp.FtpWebRequest
System.Net.WebResponse ---- System.IDisposable, System.Runtime.Serialization.ISerializable
ComponentSpace.Ftp.FtpWebResponse
System.ValueType
System.Enum ---- System.IComparable, System.IConvertible, System.IFormattable
ComponentSpace.Ftp.CommandTraceEntryType
ComponentSpace.Ftp.DataConnectionType
ComponentSpace.Ftp.DirectoryListItemType
ComponentSpace.Ftp.TransferMode

See Also

ComponentSpace.Ftp Namespace