ComponentSpace Proxy Class Library

Proxy Class Library

Introduction provides an overview of the Proxy Class Library.

Installation details the prerequisite system requirements and installation procedures for the Proxy Class Library.

Reference documents the namespaces and classes that constitute the Proxy Class Library.

Examples describes the included example code.

FAQ lists frequently asked questions.

Support describes how to get support.

Send comments on this topic.


Introduction

Send messages via a proxy server. Proxy servers are often used to provide limited access from behind the corporate firewall to the outside world. The Proxy .NET class library supports outbound TCP connections to HTTP, SOCKS v4, SOCKS v4A and SOCKS v5 proxy servers. Written in 100% managed C# code, the class library offers .NET developers a simple way to traverse firewalls using proxy servers from within their applications.

The Proxy .NET class library may be used in any Windows or Web application by adding a reference to the assembly to access the classes in the ComponentSpace.Proxy namespace.

Features

  • Supports HTTP, SOCKS v4, SOCKS v4A and SOCKS v5 proxies
  • Calling applications may make either synchronous or asynchronous calls
  • Asynchronous calls may either use events or callbacks
  • Specify timeouts
  • 100% managed code written in C#
  • Object oriented design specifically for the .NET framework
  • All error handling through .NET exceptions
  • Comprehensive Visual Studio .NET style documentation
  • VB.NET and C# example source code
  • Includes prompt free email support
  • Royalty free runtime
  • Source code available

This class library may also be purchased as part of the ComponentSpace .NET Internet Suite.

Getting Started

  • Install the product in your development environment.
  • Compile and run one of the examples.
  • Refer to the reference section for further details.
  • Add a reference to the class library in your application.
  • Once completed, distribute the class library with your application.


Installation

To install this product double click the .MSI file and follow the installation steps.

Prerequisites

The Microsoft .NET framework runtime must already be installed on your computer. The Microsoft .NET framework redistributable may be downloaded from msdn.microsoft.com.

You will also need a development environment such as Visual Studio .NET.

Distribution

The class library's runtime is royalty free which means it may be freely distributed with your application. The only file that should be distributed is the class library's DLL.


Reference

The reference section is contained within a separate help file.


Examples

Example code, developed using Microsoft Visual Studio .NET, is included with the product. You will find these projects in sub-directories of the installation directory.

VBProxyClientExample
Demonstrates the use of the class library within a VB.NET application. This example uses asynchronous invocation with event notification.
ProxyClientExample
Demonstrates the use of the class library within a C# application. This example uses synchronous invocation.


FAQ

Frequently Asked Questions
  1. I can't build the examples. Why can't the ComponentSpace namespace be found?

    2. The assembly containing the namespace or the project referencing it has been moved. The simplest way to fix this is to re-add the reference to the project by browsing to where the DLL is located (typically the installation directory).

  2. What is SOCKS?

    3. SOCKS is a protocol for proxying across firewalls. There are three versions: SOCKS v4, SOCKS v4A, and SOCKS v5.


Support

For further information, visit us at http://www.componentspace.com or send email to info@componentspace.com.

If have a bug to report or a product enhancement request send email to support@componentspace.com.