ComponentSpace.TraceRoute

ComponentSpace Trace Route Class Library Reference

ComponentSpace.TraceRoute Namespace

The ComponentSpace.TraceRoute namespace contains classes that implement the Internet Trace Route functionality.

Namespace hierarchy

Classes

Class | Description
TraceRouteClient | Performs Internet Trace Route processing to the specified server.
TraceRouteCompletedEventArgs | Provides data for the TraceRouteCompleted event.
TraceRouteException | The exception that is thrown when a Trace Route operation fails.
TraceRouteHop | Describes trace route information for a single hop on the trace route.
TraceRouteHopCompletedEventArgs | Provides data for the TraceRouteHopCompleted event.
TraceRouteServicedComponent | Performs Internet Trace Route processing within an enterprise services component.
TraceRouteTiming | Describes trace route send/receive timing information for a single hop on the trace route.
TraceRouteTimingCompletedEventArgs | Provides data for the TraceRouteTimingCompleted event.

Interfaces

Interface | Description
ITraceRouteServicedComponent | The Internet Trace Route processing interface exposed within an enterprise services component.

Delegates

Delegate | Description
TraceRouteCompletedEventHandler | Represents the method that will handle the TraceRouteCompleted event.
TraceRouteHopCompletedEventHandler | Represents the method that will handle the TraceRouteHopCompleted event.
TraceRouteTimingCompletedEventHandler | Represents the method that will handle the TraceRouteTimingCompleted event.


ITraceRouteServicedComponent Interface

The Internet Trace Route processing interface exposed within an enterprise services component.

For a list of all members of this type, see ITraceRouteServicedComponent Members.

[Visual Basic]
Public Interface ITraceRouteServicedComponent
[C#]
public interface ITraceRouteServicedComponent

Types that implement ITraceRouteServicedComponent

Type | Description
TraceRouteServicedComponent | Performs Internet Trace Route processing within an enterprise services component.

Requirements

Namespace: ComponentSpace.TraceRoute

Assembly: ComponentSpace.TraceRoute (in ComponentSpace.TraceRoute.dll)

See Also

ITraceRouteServicedComponent Members | ComponentSpace.TraceRoute Namespace


ITraceRouteServicedComponent Members

ITraceRouteServicedComponent overview

Public Instance Properties

MaximumHops | Gets or sets the maximum number of hops.
ReceiveTimeout | Gets or sets the number of milliseconds to wait for a response.
ResolveAddresses | Gets or sets the flag indicating whether to resolve IP addresses to names.

Public Instance Methods

TraceRoute Performs Internet Trace Route processing to the specified server. The server address can either be the name of the server (eg. www.componentspace.com) or its IP address (eg. 66.210.153.10).

See Also

ITraceRouteServicedComponent Interface | ComponentSpace.TraceRoute Namespace


ITraceRouteServicedComponent Properties

The properties of the ITraceRouteServicedComponent interface are listed below. For a complete list of ITraceRouteServicedComponent interface members, see the ITraceRouteServicedComponent Members topic.

Public Instance Properties

MaximumHops | Gets or sets the maximum number of hops.
ReceiveTimeout | Gets or sets the number of milliseconds to wait for a response.
ResolveAddresses | Gets or sets the flag indicating whether to resolve IP addresses to names.

See Also

ITraceRouteServicedComponent Interface | ComponentSpace.TraceRoute Namespace


ITraceRouteServicedComponent.MaximumHops Property

Gets or sets the maximum number of hops.

[Visual Basic]
Property MaximumHops As Integer
[C#]
int MaximumHops {get; set;}

Property Value

The maximum number of hops. The default is 100.

See Also

ITraceRouteServicedComponent Interface | ComponentSpace.TraceRoute Namespace


ITraceRouteServicedComponent.ReceiveTimeout Property

Gets or sets the number of milliseconds to wait for a response.

[Visual Basic]
Property ReceiveTimeout As Integer
[C#]
int ReceiveTimeout {get; set;}

Property Value

The number of milliseconds to wait for a response. The default is 5 seconds.

See Also

ITraceRouteServicedComponent Interface | ComponentSpace.TraceRoute Namespace


ITraceRouteServicedComponent.ResolveAddresses Property

Gets or sets the flag indicating whether to resolve IP addresses to names.

[Visual Basic]
Property ResolveAddresses As Boolean
[C#]
bool ResolveAddresses {get; set;}

Property Value

The flag indicating whether to resolve IP addresses to names. The default is true.

See Also

ITraceRouteServicedComponent Interface | ComponentSpace.TraceRoute Namespace


ITraceRouteServicedComponent Methods

The methods of the ITraceRouteServicedComponent interface are listed below. For a complete list of ITraceRouteServicedComponent interface members, see the ITraceRouteServicedComponent Members topic.

Public Instance Methods

TraceRoute Performs Internet Trace Route processing to the specified server. The server address can either be the name of the server (eg. www.componentspace.com) or its IP address (eg. 66.210.153.10).

See Also

ITraceRouteServicedComponent Interface | ComponentSpace.TraceRoute Namespace


ITraceRouteServicedComponent.TraceRoute Method

Performs Internet Trace Route processing to the specified server. The server address can either be the name of the server (eg. www.componentspace.com) or its IP address (eg. 66.210.153.10).

[Visual Basic]
Function TraceRoute( _
ByVal serverAddress As String _
) As IList
[C#]
IList TraceRoute(
string serverAddress
);

Parameters

serverAddress
The server to which to trace the route (eg. 66.210.153.10 or www.componentspace.com).

Return Value

The list of TraceRouteHop objects describing the traced route.

Exceptions

Exception Type | Condition
TraceRouteException | Thrown when the trace route fails.

See Also

ITraceRouteServicedComponent Interface | ComponentSpace.TraceRoute Namespace


TraceRouteClient Class

Performs Internet Trace Route processing to the specified server.

For a list of all members of this type, see TraceRouteClient Members.

System.Object
ComponentSpace.TraceRoute.TraceRouteClient

[Visual Basic]
Public Class TraceRouteClient
[C#]
public class TraceRouteClient

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

The trace route operation may be performed synchronously (blocking) using TraceRoute, or asynchronously (non-blocking) using BeginTraceRoute and EndTraceRoute.

Requirements

Namespace: ComponentSpace.TraceRoute

Assembly: ComponentSpace.TraceRoute (in ComponentSpace.TraceRoute.dll)

See Also

TraceRouteClient Members | ComponentSpace.TraceRoute Namespace


TraceRouteClient Members

TraceRouteClient overview

Public Instance Constructors

TraceRouteClient Constructor Initializes a new instance of the TraceRouteClient class.

Public Instance Properties

MaximumHops | Gets or sets the maximum number of hops.
ReceiveTimeout | Gets or sets the number of milliseconds to wait for a response.
ResolveAddresses | Gets or sets the flag indicating whether to resolve IP addresses to names.
SynchronizingObject | Gets or sets the synchonizing object for receiving events.

Public Instance Methods

BeginTraceRoute | Overloaded. Initiates an asynchronous trace route operation.
EndTraceRoute | Completes the specified asynchronous trace route operation.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.
TraceRoute | Performs Internet Trace Route processing to the specified server. The server address can either be the name of the server (eg. www.componentspace.com) or its IP address (eg. 66.210.153.10).

Public Instance Events

TraceRouteCompleted | Occurs when the trace route has completed.
TraceRouteHopCompleted | Occurs when all the trace route timings for a hop have completed.
TraceRouteTimingCompleted | Occurs when a trace route timing has completed.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

TraceRouteClient Class | ComponentSpace.TraceRoute Namespace


TraceRouteClient Constructor

Initializes a new instance of the TraceRouteClient class.

[Visual Basic]
Public Sub New()
[C#]
public TraceRouteClient();

See Also

TraceRouteClient Class | ComponentSpace.TraceRoute Namespace


TraceRouteClient Properties

The properties of the TraceRouteClient class are listed below. For a complete list of TraceRouteClient class members, see the TraceRouteClient Members topic.

Public Instance Properties

MaximumHops | Gets or sets the maximum number of hops.
ReceiveTimeout | Gets or sets the number of milliseconds to wait for a response.
ResolveAddresses | Gets or sets the flag indicating whether to resolve IP addresses to names.
SynchronizingObject | Gets or sets the synchonizing object for receiving events.

See Also

TraceRouteClient Class | ComponentSpace.TraceRoute Namespace


TraceRouteClient.MaximumHops Property

Gets or sets the maximum number of hops.

[Visual Basic]
Public Property MaximumHops As Integer
[C#]
public int MaximumHops {get; set;}

Property Value

The maximum number of hops. The default is 100.

See Also

TraceRouteClient Class | ComponentSpace.TraceRoute Namespace


TraceRouteClient.ReceiveTimeout Property

Gets or sets the number of milliseconds to wait for a response.

[Visual Basic]
Public Property ReceiveTimeout As Integer
[C#]
public int ReceiveTimeout {get; set;}

Property Value

The number of milliseconds to wait for a response. The default is 5 seconds.

See Also

TraceRouteClient Class | ComponentSpace.TraceRoute Namespace


TraceRouteClient.ResolveAddresses Property

Gets or sets the flag indicating whether to resolve IP addresses to names.

[Visual Basic]
Public Property ResolveAddresses As Boolean
[C#]
public bool ResolveAddresses {get; set;}

Property Value

The flag indicating whether to resolve IP addresses to names. The default is true.

See Also

TraceRouteClient Class | ComponentSpace.TraceRoute Namespace


TraceRouteClient.SynchronizingObject Property

Gets or sets the synchonizing object for receiving events.

[Visual Basic]
Public Property SynchronizingObject As ISynchronizeInvoke
[C#]
public System.ComponentModel.ISynchronizeInvoke SynchronizingObject {get; set;}

Property Value

An ISynchronizeInvoke, which represents the object that marshals the event-handler call resulting from a TraceRouteCompleted event. The default is a null reference (Nothing in Visual Basic).

Remarks

A TraceRouteCompleted event results from a BeginTraceRoute request to a specific thread. Typically, the SynchronizingObject is set when it's used within a form, because forms are bound to a specific thread.

Typically, the synchronizing object marshals a method call into a single thread.

See Also

TraceRouteClient Class | ComponentSpace.TraceRoute Namespace


TraceRouteClient Methods

The methods of the TraceRouteClient class are listed below. For a complete list of TraceRouteClient class members, see the TraceRouteClient Members topic.

Public Instance Methods

BeginTraceRoute | Overloaded. Initiates an asynchronous trace route operation.
EndTraceRoute | Completes the specified asynchronous trace route operation.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.
TraceRoute | Performs Internet Trace Route processing to the specified server. The server address can either be the name of the server (eg. www.componentspace.com) or its IP address (eg. 66.210.153.10).

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

TraceRouteClient Class | ComponentSpace.TraceRoute Namespace


BeginTraceRoute Method

ComponentSpace Trace Route Class Library Reference

TraceRouteClient.BeginTraceRoute Method

Initiates an asynchronous trace route operation.

Overload List

Initiates an asynchronous trace route operation.

public IAsyncResult BeginTraceRoute(string);

Initiates an asynchronous trace route operation that has a specified state object.

public IAsyncResult BeginTraceRoute(string,object);

Initiates an asynchronous trace route operation that has a specified state object. This overload receives notification, through a callback, of the identity of the event handler for this operation.

public IAsyncResult BeginTraceRoute(string,object,AsyncCallback);

See Also

TraceRouteClient Class | ComponentSpace.TraceRoute Namespace


TraceRouteClient.BeginTraceRoute Method (String)

Initiates an asynchronous trace route operation.

[Visual Basic]
Overloads Public Function BeginTraceRoute( _
ByVal serverAddress As String _
) As IAsyncResult
[C#]
public IAsyncResult BeginTraceRoute(
string serverAddress
);

Parameters

serverAddress
The server to which to trace the route (eg. 66.210.153.10 or www.componentspace.com).

Return Value

The IAsyncResult that identifies the posted asynchronous request.

Remarks

In asynchronous processing, you use BeginTraceRoute to raise the TraceRouteCompleted event when the trace route operation has completed.

To use BeginTraceRoute, create an event handler that processes the results of the asynchronous operation and associate it with your event delegate. BeginTraceRoute initiates an asynchronous send operation; the TraceRouteClient is notified, through the raising of the TraceRouteCompleted event, when the trace route operation is completed. The TraceRouteClient can then access the trace route status by calling EndTraceRoute.

Note: The BeginTraceRoute method returns immediately, but the asynchronous operation is not completed until the event handler is called.

Because BeginTraceRoute is asynchronous, you can call it to receive the trace route status without blocking the current thread of execution. To synchronously trace route, use the TraceRoute method.

Once an asynchronous operation completes, you can call BeginTraceRoute again in the event handler to keep receiving notifications.

The IAsyncResult that BeginTraceRoute returns identifies the asynchronous operation that the method call started. You can use this IAsyncResult throughout the lifetime of the operation, although you generally do not use it until EndTraceRoute is called. However, if you start several asynchronous operations, you can place their IAsyncResult values in an array and specify whether to wait for all operations or any operation to complete. In this case, you use the AsyncWaitHandle property of the IAsyncResult to identify the completed operation.

See Also

TraceRouteClient Class | ComponentSpace.TraceRoute Namespace | TraceRouteClient.BeginTraceRoute Overload List


TraceRouteClient.BeginTraceRoute Method (String, Object)

Initiates an asynchronous trace route operation that has a specified state object.

[Visual Basic]
Overloads Public Function BeginTraceRoute( _
ByVal serverAddress As String, _
ByVal stateObject As Object _
) As IAsyncResult
[C#]
public IAsyncResult BeginTraceRoute(
string serverAddress,
object stateObject
);

Parameters

serverAddress
The server to which to trace the route (eg. 66.210.153.10 or www.componentspace.com).
stateObject
A state object, specified by the application, that contains information associated with the asynchronous operation.

Return Value

The IAsyncResult that identifies the posted asynchronous request.

Remarks

In asynchronous processing, you use BeginTraceRoute to raise the TraceRouteCompleted event when the trace route operation has completed.

Use this overload to associate information with the operation that will be preserved throughout the operation's lifetime. The event handler can detect this information by looking at the AsyncState of the IAsyncResult that is associated with the operation.

To use BeginTraceRoute, create an event handler that processes the results of the asynchronous operation and associate it with your event delegate. BeginTraceRoute initiates an asynchronous trace route operation; the TraceRouteClient is notified, through the raising of the TraceRouteCompleted event, when the trace route operation is completed. The TraceRouteClient can then access the trace route status by calling EndTraceRoute.

Note: The BeginTraceRoute method returns immediately, but the asynchronous operation is not completed until the event handler is called.

Because BeginTraceRoute is asynchronous, you can call it to receive the trace route status without blocking the current thread of execution. To synchronously trace route, use the TraceRoute method.

Once an asynchronous operation completes, you can call BeginTraceRoute again in the event handler to keep receiving notifications.

The IAsyncResult that BeginTraceRoute returns indentifies the asynchronous operation that the method call started. You can use this IAsyncResult throughout the lifetime of the operation, although you generally do not use it until EndTraceRoute is called. However, if you start several asynchronous operations, you can place their IAsyncResult values in an array and specify whether to wait for all operations or any operation to complete. In this case, you use the AsyncWaitHandle property of the IAsyncResult to identify the completed operation.

The state object associates state information with the operation. For example, if you call BeginTraceRoute multiple times to initiate multiple operations, you can identify each operation through a separate state object that you define.

You can also use the state object to pass information across process threads. If a thread is started but the callback is on a different thread in an asynchronous scenario, the state object is marshaled and passed back along with information from the event.

See Also

TraceRouteClient Class | ComponentSpace.TraceRoute Namespace | TraceRouteClient.BeginTraceRoute Overload List


TraceRouteClient.BeginTraceRoute Method (String, Object, AsyncCallback)

Initiates an asynchronous trace route operation that has a specified state object. This overload receives notification, through a callback, of the identity of the event handler for this operation.

[Visual Basic]
Overloads Public Function BeginTraceRoute( _
ByVal serverAddress As String, _
ByVal stateObject As Object, _
ByVal asyncCallback As AsyncCallback _
) As IAsyncResult
[C#]
public IAsyncResult BeginTraceRoute(
string serverAddress,
object stateObject,
AsyncCallback asyncCallback
);

Parameters

serverAddress
The server to which to trace the route (eg. 66.210.153.10 or www.componentspace.com).
stateObject
A state object, specified by the application, that contains information associated with the asynchronous operation.
asyncCallback
The AsyncCallback that will receive the notification of the asynchronous operation completion.

Return Value

The IAsyncResult that identifies the posted asynchronous request.

Remarks

When you use this overload, the callback specified in the callback parameter is invoked directly when the trace route operation has completed; the TraceRouteCompleted event is not raised. The other overloads of BeginTraceRoute rely on this component to raise the TraceRouteCompleted event.

To use BeginTraceRoute, define an asynchronous callback method. BeginTraceRoute initiates an asynchronous trace route operation; the TraceRouteClient is notified, through a call to the callback method, when the trace route operation is completed. The TraceRouteClient can then access the trace route status by calling EndTraceRoute.

Use this overload to associate information with the operation that will be preserved throughout the operation's lifetime. The event handler can detect this information by looking at the AsyncState of the IAsyncResult that is associated with the operation.

Note: The BeginTraceRoute method returns immediately, but the asynchronous operation is not completed until the event handler is called.

Because BeginTraceRoute is asynchronous, you can call it to receive the trace route status without blocking the current thread of execution. To synchronously trace route, use the TraceRoute method.

Once an asynchronous operation completes, you can call BeginTraceRoute again in the event handler to keep receiving notifications.

The IAsyncResult that BeginTraceRoute returns identifies the asynchronous operation that the method call started. You can use this IAsyncResult throughout the lifetime of the operation, although you generally do not use it until EndTraceRoute is called. However, if you start several asynchronous operations, you can place their IAsyncResult values in an array and specify whether to wait for all operations or any operation to complete. In this case, you use the AsyncWaitHandle property of the IAsyncResult to identify the completed operation.

The state object associates state information with the operation. For example, if you call BeginTraceRoute multiple times to initiate multiple operations, you can identify each operation through a separate state object that you define.

You can also use the state object to pass information across process threads. If a thread is started but the callback is on a different thread in an asynchronous scenario, the state object is marshaled and passed back along with information from the event.

See Also

TraceRouteClient Class | ComponentSpace.TraceRoute Namespace | TraceRouteClient.BeginTraceRoute Overload List


TraceRouteClient.EndTraceRoute Method

Completes the specified asynchronous trace route operation.

[Visual Basic]
Public Function EndTraceRoute( _
ByVal asyncResult As IAsyncResult _
) As IList
[C#]
public IList EndTraceRoute(
IAsyncResult asyncResult
);

Parameters

asyncResult
The IAsyncResult that identifies the asynchronous trace route operation to finish, and from which to retrieve an end result.

Return Value

The list of TraceRouteHop objects describing the traced route.

Remarks

When the TraceRouteCompleted event is raised, EndTraceRoute completes the operation that was initiated by the BeginTraceRoute call.

Exceptions

Exception Type | Condition
TraceRouteException | Thrown when the trace route fails.

See Also

TraceRouteClient Class | ComponentSpace.TraceRoute Namespace


TraceRouteClient.TraceRoute Method

Performs Internet Trace Route processing to the specified server. The server address can either be the name of the server (eg. www.componentspace.com) or its IP address (eg. 66.210.153.10).

[Visual Basic]
Public Function TraceRoute( _
ByVal serverAddress As String _
) As IList
[C#]
public IList TraceRoute(
string serverAddress
);

Parameters

serverAddress
The server to which to trace the route (eg. 66.210.153.10 or www.componentspace.com).

Return Value

The list of TraceRouteHop objects describing the traced route.

Exceptions

Exception Type | Condition
TraceRouteException | Thrown when the trace route fails.

See Also

TraceRouteClient Class | ComponentSpace.TraceRoute Namespace


TraceRouteClient Events

The events of the TraceRouteClient class are listed below. For a complete list of TraceRouteClient class members, see the TraceRouteClient Members topic.

Public Instance Events

TraceRouteCompleted | Occurs when the trace route has completed.
TraceRouteHopCompleted | Occurs when all the trace route timings for a hop have completed.
TraceRouteTimingCompleted | Occurs when a trace route timing has completed.

See Also

TraceRouteClient Class | ComponentSpace.TraceRoute Namespace


TraceRouteClient.TraceRouteCompleted Event

Occurs when the trace route has completed.

[Visual Basic]
Public Event TraceRouteCompleted As TraceRouteCompletedEventHandler
[C#]
public event TraceRouteCompletedEventHandler TraceRouteCompleted;

Event Data

The event handler receives an argument of type TraceRouteCompletedEventArgs containing data related to this event. The following TraceRouteCompletedEventArgs property provides information specific to this event.

Property | Description
AsyncResult | Gets the result of the asynchronous echo operation.

Remarks

BeginTraceRoute is used in asynchronous processing to raise the TraceRouteCompleted event when the trace route has completed.

EndTraceRoute is used to complete the operation initiated by a call to BeginTraceRoute and get the trace route status when the TraceRouteCompleted event is raised.

See Also

TraceRouteClient Class | ComponentSpace.TraceRoute Namespace


TraceRouteClient.TraceRouteHopCompleted Event

Occurs when all the trace route timings for a hop have completed.

[Visual Basic]
Public Event TraceRouteHopCompleted As TraceRouteHopCompletedEventHandler
[C#]
public event TraceRouteHopCompletedEventHandler TraceRouteHopCompleted;

Event Data

The event handler receives an argument of type TraceRouteHopCompletedEventArgs containing data related to this event. The following TraceRouteHopCompletedEventArgs property provides information specific to this event.

Property | Description
TraceRouteHop | Gets the trace route hop information for the just completed hop on the route.

See Also

TraceRouteClient Class | ComponentSpace.TraceRoute Namespace


TraceRouteClient.TraceRouteTimingCompleted Event

Occurs when a trace route timing has completed.

[Visual Basic]
Public Event TraceRouteTimingCompleted As TraceRouteTimingCompletedEventHandler
[C#]
public event TraceRouteTimingCompletedEventHandler TraceRouteTimingCompleted;

Event Data

The event handler receives an argument of type TraceRouteTimingCompletedEventArgs containing data related to this event. The following TraceRouteTimingCompletedEventArgs properties provide information specific to this event.

Property | Description
TraceRouteHop | Gets the trace route hop information for the just completed single send/receive operation to a hop on the route.
TraceRouteTiming | Gets the trace route timing information for the just completed single send/receive operation to a hop on the route.

See Also

TraceRouteClient Class | ComponentSpace.TraceRoute Namespace


TraceRouteCompletedEventArgs Class

Provides data for the TraceRouteCompleted event.

For a list of all members of this type, see TraceRouteCompletedEventArgs Members.

System.Object
System.EventArgs
ComponentSpace.TraceRoute.TraceRouteCompletedEventArgs

[Visual Basic]
Public Class TraceRouteCompletedEventArgs
Inherits EventArgs
[C#]
public class TraceRouteCompletedEventArgs : EventArgs

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

The TraceRouteCompleted event is raised by the TraceRouteClient. It contains all the information needed to complete the asynchronous echo operation.

Requirements

Namespace: ComponentSpace.TraceRoute

Assembly: ComponentSpace.TraceRoute (in ComponentSpace.TraceRoute.dll)

See Also

TraceRouteCompletedEventArgs Members | ComponentSpace.TraceRoute Namespace


TraceRouteCompletedEventArgs Members

TraceRouteCompletedEventArgs overview

Public Instance Properties

AsyncResult Gets the result of the asynchronous echo operation.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

TraceRouteCompletedEventArgs Class | ComponentSpace.TraceRoute Namespace


TraceRouteCompletedEventArgs Properties

The properties of the TraceRouteCompletedEventArgs class are listed below. For a complete list of TraceRouteCompletedEventArgs class members, see the TraceRouteCompletedEventArgs Members topic.

Public Instance Properties

AsyncResult Gets the result of the asynchronous echo operation.

See Also

TraceRouteCompletedEventArgs Class | ComponentSpace.TraceRoute Namespace


TraceRouteCompletedEventArgs.AsyncResult Property

Gets the result of the asynchronous echo operation.

[Visual Basic]
Public ReadOnly Property AsyncResult As IAsyncResult
[C#]
public System.IAsyncResult AsyncResult {get;}

Property Value

An IAsyncResult that contains the data associated with the echo operation.

Remarks

AsyncResult identifies ongoing or completed asynchronous operations. The property contains data that helps determine which of several potential asynchronous operations to complete, and when passed to the event handler, enables EndTraceRoute to access the status associated with the completed operation.

See Also

TraceRouteCompletedEventArgs Class | ComponentSpace.TraceRoute Namespace


TraceRouteCompletedEventHandler Delegate

Represents the method that will handle the TraceRouteCompleted event.

[Visual Basic]
Public Delegate Sub TraceRouteCompletedEventHandler( _
ByVal sender As Object, _
ByVal e As TraceRouteCompletedEventArgs _
)
[C#]
public delegate void TraceRouteCompletedEventHandler(
object sender,
TraceRouteCompletedEventArgs e
);

Parameters

sender
The source of the event.
e
An TraceRouteCompletedEventArgs that contains the event data.

Remarks

When you create a TraceRouteCompletedEventHandler delegate, you identify the method that will handle the event. To associate the event with your event handler, add an instance of the delegate to the event. The event handler is called whenever the event occurs, unless you remove the delegate.

Requirements

Namespace: ComponentSpace.TraceRoute

Assembly: ComponentSpace.TraceRoute (in ComponentSpace.TraceRoute.dll)

See Also

ComponentSpace.TraceRoute Namespace


TraceRouteException Class

The exception that is thrown when a Trace Route operation fails.

For a list of all members of this type, see TraceRouteException Members.

System.Object
System.Exception
System.ApplicationException
ComponentSpace.TraceRoute.TraceRouteException

[Visual Basic]
Public Class TraceRouteException
Inherits ApplicationException
[C#]
public class TraceRouteException : ApplicationException

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: ComponentSpace.TraceRoute

Assembly: ComponentSpace.TraceRoute (in ComponentSpace.TraceRoute.dll)

See Also

TraceRouteException Members | ComponentSpace.TraceRoute Namespace


TraceRouteException Members

TraceRouteException overview

Public Instance Properties

HelpLink (inherited from Exception) | Gets or sets a link to the help file associated with this exception.
InnerException (inherited from Exception) | Gets the Exception instance that caused the current exception.
Message (inherited from Exception) | Gets a message that describes the current exception.
Source (inherited from Exception) | Gets or sets the name of the application or the object that causes the error.
StackTrace (inherited from Exception) | Gets a string representation of the frames on the call stack at the time the current exception was thrown.
TargetSite (inherited from Exception) | Gets the method that throws the current exception.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetBaseException (inherited from Exception) | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetObjectData (inherited from Exception) | When overridden in a derived class, sets the SerializationInfo with information about the exception.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Exception) | Creates and returns a string representation of the current exception.

Protected Instance Properties

HResult (inherited from Exception) Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

TraceRouteException Class | ComponentSpace.TraceRoute Namespace


TraceRouteHop Class

Describes trace route information for a single hop on the trace route.

For a list of all members of this type, see TraceRouteHop Members.

System.Object
ComponentSpace.TraceRoute.TraceRouteHop

[Visual Basic]
Public Class TraceRouteHop
[C#]
public class TraceRouteHop

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: ComponentSpace.TraceRoute

Assembly: ComponentSpace.TraceRoute (in ComponentSpace.TraceRoute.dll)

See Also

TraceRouteHop Members | ComponentSpace.TraceRoute Namespace


TraceRouteHop Members

TraceRouteHop overview

Public Instance Constructors

TraceRouteHop Constructor Initializes a new instance of the TraceRouteHop class.

Public Instance Properties

DestinationReached | Gets or sets the flag indicating whether the destination server was reached.
HopNumber | Gets or sets the hop number.
ServerAddress | Gets or sets the server IP address.
ServerName | Gets or sets the server name. This will be the IP address is address resolution is disabled.
TraceRouteTimings | Gets the trace route timing information.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString | Obtain the string representation of the trace route hop.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

TraceRouteHop Class | ComponentSpace.TraceRoute Namespace


TraceRouteHop Constructor

Initializes a new instance of the TraceRouteHop class.

[Visual Basic]
Public Sub New()
[C#]
public TraceRouteHop();

See Also

TraceRouteHop Class | ComponentSpace.TraceRoute Namespace


TraceRouteHop Properties

The properties of the TraceRouteHop class are listed below. For a complete list of TraceRouteHop class members, see the TraceRouteHop Members topic.

Public Instance Properties

DestinationReached | Gets or sets the flag indicating whether the destination server was reached.
HopNumber | Gets or sets the hop number.
ServerAddress | Gets or sets the server IP address.
ServerName | Gets or sets the server name. This will be the IP address is address resolution is disabled.
TraceRouteTimings | Gets the trace route timing information.

See Also

TraceRouteHop Class | ComponentSpace.TraceRoute Namespace


TraceRouteHop.DestinationReached Property

Gets or sets the flag indicating whether the destination server was reached.

[Visual Basic]
Public Property DestinationReached As Boolean
[C#]
public bool DestinationReached {get; set;}

Property Value

The flag indicating whether the destination server was reached.

See Also

TraceRouteHop Class | ComponentSpace.TraceRoute Namespace


TraceRouteHop.HopNumber Property

Gets or sets the hop number.

[Visual Basic]
Public Property HopNumber As Integer
[C#]
public int HopNumber {get; set;}

Property Value

The hop number.

See Also

TraceRouteHop Class | ComponentSpace.TraceRoute Namespace


TraceRouteHop.ServerAddress Property

Gets or sets the server IP address.

[Visual Basic]
Public Property ServerAddress As String
[C#]
public string ServerAddress {get; set;}

Property Value

The server IP address.

See Also

TraceRouteHop Class | ComponentSpace.TraceRoute Namespace


TraceRouteHop.ServerName Property

Gets or sets the server name. This will be the IP address is address resolution is disabled.

[Visual Basic]
Public Property ServerName As String
[C#]
public string ServerName {get; set;}

Property Value

The server name.

See Also

TraceRouteHop Class | ComponentSpace.TraceRoute Namespace


TraceRouteHop.TraceRouteTimings Property

Gets the trace route timing information.

[Visual Basic]
Public ReadOnly Property TraceRouteTimings As IList
[C#]
public System.Collections.IList TraceRouteTimings {get;}

Property Value

The list of TraceRouteTiming objects.

See Also

TraceRouteHop Class | ComponentSpace.TraceRoute Namespace


TraceRouteHop Methods

The methods of the TraceRouteHop class are listed below. For a complete list of TraceRouteHop class members, see the TraceRouteHop Members topic.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString | Obtain the string representation of the trace route hop.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

TraceRouteHop Class | ComponentSpace.TraceRoute Namespace


TraceRouteHop.ToString Method

Obtain the string representation of the trace route hop.

[Visual Basic]
Overrides Public Function ToString() As String
[C#]
public override string ToString();

Return Value

The string representation of the trace route hop.

See Also

TraceRouteHop Class | ComponentSpace.TraceRoute Namespace


TraceRouteHopCompletedEventArgs Class

Provides data for the TraceRouteHopCompleted event.

For a list of all members of this type, see TraceRouteHopCompletedEventArgs Members.

System.Object
System.EventArgs
ComponentSpace.TraceRoute.TraceRouteHopCompletedEventArgs

[Visual Basic]
Public Class TraceRouteHopCompletedEventArgs
Inherits EventArgs
[C#]
public class TraceRouteHopCompletedEventArgs : EventArgs

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

The TraceRouteHopCompleted event is raised by the TraceRouteClient. It contains the information associated with a hop on the route.

Requirements

Namespace: ComponentSpace.TraceRoute

Assembly: ComponentSpace.TraceRoute (in ComponentSpace.TraceRoute.dll)

See Also

TraceRouteHopCompletedEventArgs Members | ComponentSpace.TraceRoute Namespace


TraceRouteHopCompletedEventArgs Members

TraceRouteHopCompletedEventArgs overview

Public Instance Properties

TraceRouteHop Gets the trace route hop information for the just completed hop on the route.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

TraceRouteHopCompletedEventArgs Class | ComponentSpace.TraceRoute Namespace


TraceRouteHopCompletedEventArgs Properties

The properties of the TraceRouteHopCompletedEventArgs class are listed below. For a complete list of TraceRouteHopCompletedEventArgs class members, see the TraceRouteHopCompletedEventArgs Members topic.

Public Instance Properties

TraceRouteHop Gets the trace route hop information for the just completed hop on the route.

See Also

TraceRouteHopCompletedEventArgs Class | ComponentSpace.TraceRoute Namespace


TraceRouteHopCompletedEventArgs.TraceRouteHop Property

Gets the trace route hop information for the just completed hop on the route.

[Visual Basic]
Public ReadOnly Property TraceRouteHop As TraceRouteHop
[C#]
public TraceRouteHop TraceRouteHop {get;}

Property Value

A TraceRouteHop that contains the trace route hop information.

See Also

TraceRouteHopCompletedEventArgs Class | ComponentSpace.TraceRoute Namespace


TraceRouteHopCompletedEventHandler Delegate

Represents the method that will handle the TraceRouteHopCompleted event.

[Visual Basic]
Public Delegate Sub TraceRouteHopCompletedEventHandler( _
ByVal sender As Object, _
ByVal e As TraceRouteHopCompletedEventArgs _
)
[C#]
public delegate void TraceRouteHopCompletedEventHandler(
object sender,
TraceRouteHopCompletedEventArgs e
);

Parameters

sender
The source of the event.
e
A TraceRouteHopCompletedEventArgs that contains the event data.

Remarks

When you create a TraceRouteHopCompletedEventHandler delegate, you identify the method that will handle the event. To associate the event with your event handler, add an instance of the delegate to the event. The event handler is called whenever the event occurs, unless you remove the delegate.

Requirements

Namespace: ComponentSpace.TraceRoute

Assembly: ComponentSpace.TraceRoute (in ComponentSpace.TraceRoute.dll)

See Also

ComponentSpace.TraceRoute Namespace


TraceRouteServicedComponent Class

Performs Internet Trace Route processing within an enterprise services component.

For a list of all members of this type, see TraceRouteServicedComponent Members.

System.Object
System.MarshalByRefObject
System.ContextBoundObject
System.EnterpriseServices.ServicedComponent
ComponentSpace.TraceRoute.TraceRouteServicedComponent

[Visual Basic]
Public Class TraceRouteServicedComponent
Inherits ServicedComponent
Implements ITraceRouteServicedComponent
[C#]
public class TraceRouteServicedComponent : ServicedComponent, ITraceRouteServicedComponent

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

Microsoft Knowledge Base Article 195445 states that raw socket access is denied to non-administrator users. This means that, unless you're running under an administrator account, you will not be able to perform trace route operations as they require the use of raw sockets.

One example of this situation is ASP.NET applications that typically won't run under an administrator account.

One approach to resolve this problem is to use an enterprise services (COM+) component. This component can be configured to run in a COM+ server application under an administrator account. Therefore, regardless of which account the caller is running under, the trace route operation will run under an administrator account.

Requirements

Namespace: ComponentSpace.TraceRoute

Assembly: ComponentSpace.TraceRoute (in ComponentSpace.TraceRoute.dll)

See Also

TraceRouteServicedComponent Members | ComponentSpace.TraceRoute Namespace


TraceRouteServicedComponent Members

TraceRouteServicedComponent overview

Public Instance Constructors

TraceRouteServicedComponent Constructor Initializes a new instance of the TraceRouteServicedComponent class.

Public Instance Properties

MaximumHops | Gets or sets the maximum number of hops.
ReceiveTimeout | Gets or sets the number of milliseconds to wait for a response.
ResolveAddresses | Gets or sets the flag indicating whether to resolve IP addresses to names.

Public Instance Methods

CreateObjRef (inherited from MarshalByRefObject) | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object.
Dispose (inherited from ServicedComponent) | Overloaded. Releases all resources used by the ServicedComponent .
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetLifetimeService (inherited from MarshalByRefObject) | Retrieves the current lifetime service object that controls the lifetime policy for this instance.
GetType (inherited from Object) | Gets the Type of the current instance.
InitializeLifetimeService (inherited from MarshalByRefObject) | Obtains a lifetime service object to control the lifetime policy for this instance.
ToString (inherited from Object) | Returns a String that represents the current Object.
TraceRoute | Performs Internet Trace Route processing to the specified server. The server address can either be the name of the server (eg. www.componentspace.com) or its IP address (eg. 66.210.153.10).

Protected Instance Methods

Dispose (inherited from ServicedComponent) | Overloaded. Releases the unmanaged resources used by the ServicedComponent and optionally releases the managed resources.
Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

Protected Internal Instance Methods

Activate (inherited from ServicedComponent) | This method is called by the infrastructure when the object is created or allocated from a pool. Override this method to add custom initialization code to objects.
CanBePooled (inherited from ServicedComponent) | This method is called by the infrastructure before the object is put back into the pool. Override this method to vote on whether the object is put back into the pool.
Construct (inherited from ServicedComponent) | This method is called by the infrastructure just after the constructor is called, passing in the constructor string. Override this method to make use of the construction string value.
Deactivate (inherited from ServicedComponent) | This method is called by the infrastructure when the object is about to be deactivated. Override this method to add custom finalization code to objects when just-in-time (JIT) compiled code or object pooling is used.

See Also

TraceRouteServicedComponent Class | ComponentSpace.TraceRoute Namespace


TraceRouteServicedComponent Constructor

Initializes a new instance of the TraceRouteServicedComponent class.

[Visual Basic]
Public Sub New()
[C#]
public TraceRouteServicedComponent();

See Also

TraceRouteServicedComponent Class | ComponentSpace.TraceRoute Namespace


TraceRouteServicedComponent Properties

The properties of the TraceRouteServicedComponent class are listed below. For a complete list of TraceRouteServicedComponent class members, see the TraceRouteServicedComponent Members topic.

Public Instance Properties

MaximumHops | Gets or sets the maximum number of hops.
ReceiveTimeout | Gets or sets the number of milliseconds to wait for a response.
ResolveAddresses | Gets or sets the flag indicating whether to resolve IP addresses to names.

See Also

TraceRouteServicedComponent Class | ComponentSpace.TraceRoute Namespace


TraceRouteServicedComponent.MaximumHops Property

Gets or sets the maximum number of hops.

[Visual Basic]
NotOverridable Public Property MaximumHops As Integer _
Implements ITraceRouteServicedComponent.MaximumHops
[C#]
public int MaximumHops {get; set;}

Property Value

The maximum number of hops. The default is 100.

Implements

ITraceRouteServicedComponent.MaximumHops

See Also

TraceRouteServicedComponent Class | ComponentSpace.TraceRoute Namespace


TraceRouteServicedComponent.ReceiveTimeout Property

Gets or sets the number of milliseconds to wait for a response.

[Visual Basic]
NotOverridable Public Property ReceiveTimeout As Integer _
Implements ITraceRouteServicedComponent.ReceiveTimeout
[C#]
public int ReceiveTimeout {get; set;}

Property Value

The number of milliseconds to wait for a response. The default is 5 seconds.

Implements

ITraceRouteServicedComponent.ReceiveTimeout

See Also

TraceRouteServicedComponent Class | ComponentSpace.TraceRoute Namespace


TraceRouteServicedComponent.ResolveAddresses Property

Gets or sets the flag indicating whether to resolve IP addresses to names.

[Visual Basic]
NotOverridable Public Property ResolveAddresses As Boolean _
Implements ITraceRouteServicedComponent.ResolveAddresses
[C#]
public bool ResolveAddresses {get; set;}

Property Value

The flag indicating whether to resolve IP addresses to names. The default is true.

Implements

ITraceRouteServicedComponent.ResolveAddresses

See Also

TraceRouteServicedComponent Class | ComponentSpace.TraceRoute Namespace


TraceRouteServicedComponent Methods

The methods of the TraceRouteServicedComponent class are listed below. For a complete list of TraceRouteServicedComponent class members, see the TraceRouteServicedComponent Members topic.

Public Instance Methods

CreateObjRef (inherited from MarshalByRefObject) | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object.
Dispose (inherited from ServicedComponent) | Overloaded. Releases all resources used by the ServicedComponent .
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetLifetimeService (inherited from MarshalByRefObject) | Retrieves the current lifetime service object that controls the lifetime policy for this instance.
GetType (inherited from Object) | Gets the Type of the current instance.
InitializeLifetimeService (inherited from MarshalByRefObject) | Obtains a lifetime service object to control the lifetime policy for this instance.
ToString (inherited from Object) | Returns a String that represents the current Object.
TraceRoute | Performs Internet Trace Route processing to the specified server. The server address can either be the name of the server (eg. www.componentspace.com) or its IP address (eg. 66.210.153.10).

Protected Instance Methods

Dispose (inherited from ServicedComponent) | Overloaded. Releases the unmanaged resources used by the ServicedComponent and optionally releases the managed resources.
Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

Protected Internal Instance Methods

Activate (inherited from ServicedComponent) | This method is called by the infrastructure when the object is created or allocated from a pool. Override this method to add custom initialization code to objects.
CanBePooled (inherited from ServicedComponent) | This method is called by the infrastructure before the object is put back into the pool. Override this method to vote on whether the object is put back into the pool.
Construct (inherited from ServicedComponent) | This method is called by the infrastructure just after the constructor is called, passing in the constructor string. Override this method to make use of the construction string value.
Deactivate (inherited from ServicedComponent) | This method is called by the infrastructure when the object is about to be deactivated. Override this method to add custom finalization code to objects when just-in-time (JIT) compiled code or object pooling is used.

See Also

TraceRouteServicedComponent Class | ComponentSpace.TraceRoute Namespace


TraceRouteServicedComponent.TraceRoute Method

Performs Internet Trace Route processing to the specified server. The server address can either be the name of the server (eg. www.componentspace.com) or its IP address (eg. 66.210.153.10).

[Visual Basic]
NotOverridable Public Function TraceRoute( _
ByVal serverAddress As String _
) As IList _
Implements ITraceRouteServicedComponent.TraceRoute
[C#]
public IList TraceRoute(
string serverAddress
);

Parameters

serverAddress
The server to which to trace the route (eg. 66.210.153.10 or www.componentspace.com).

Return Value

The list of TraceRouteHop objects describing the traced route.

Implements

ITraceRouteServicedComponent.TraceRoute

Exceptions

Exception Type | Condition
TraceRouteException | Thrown when the trace route fails.

See Also

TraceRouteServicedComponent Class | ComponentSpace.TraceRoute Namespace


TraceRouteTiming Class

Describes trace route send/receive timing information for a single hop on the trace route.

For a list of all members of this type, see TraceRouteTiming Members.

System.Object
ComponentSpace.TraceRoute.TraceRouteTiming

[Visual Basic]
Public Class TraceRouteTiming
[C#]
public class TraceRouteTiming

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: ComponentSpace.TraceRoute

Assembly: ComponentSpace.TraceRoute (in ComponentSpace.TraceRoute.dll)

See Also

TraceRouteTiming Members | ComponentSpace.TraceRoute Namespace


TraceRouteTiming Members

TraceRouteTiming overview

Public Instance Constructors

TraceRouteTiming Constructor Initializes a new instance of the TraceRouteTiming class.

Public Instance Properties

ResponseReceived | Gets or sets the response received flag.
ResponseTime | Gets or sets the response time in milliseconds.
ResponseTimeToLive | Gets or sets the response Time To Live (TTL) value. If this value doesn't match the hop number then it indicates an asymmetric path where the received packet takes a different route from the sent packet.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString | Obtain the string representation of the trace route timing.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

TraceRouteTiming Class | ComponentSpace.TraceRoute Namespace


TraceRouteTiming Constructor

Initializes a new instance of the TraceRouteTiming class.

[Visual Basic]
Public Sub New()
[C#]
public TraceRouteTiming();

See Also

TraceRouteTiming Class | ComponentSpace.TraceRoute Namespace


TraceRouteTiming Properties

The properties of the TraceRouteTiming class are listed below. For a complete list of TraceRouteTiming class members, see the TraceRouteTiming Members topic.

Public Instance Properties

ResponseReceived | Gets or sets the response received flag.
ResponseTime | Gets or sets the response time in milliseconds.
ResponseTimeToLive | Gets or sets the response Time To Live (TTL) value. If this value doesn't match the hop number then it indicates an asymmetric path where the received packet takes a different route from the sent packet.

See Also

TraceRouteTiming Class | ComponentSpace.TraceRoute Namespace


TraceRouteTiming.ResponseReceived Property

Gets or sets the response received flag.

[Visual Basic]
Public Property ResponseReceived As Boolean
[C#]
public bool ResponseReceived {get; set;}

Property Value

true if a response was received; false if a response wasn't received.

See Also

TraceRouteTiming Class | ComponentSpace.TraceRoute Namespace


TraceRouteTiming.ResponseTime Property

Gets or sets the response time in milliseconds.

[Visual Basic]
Public Property ResponseTime As Integer
[C#]
public int ResponseTime {get; set;}

Property Value

The response time in milliseconds.

See Also

TraceRouteTiming Class | ComponentSpace.TraceRoute Namespace


TraceRouteTiming.ResponseTimeToLive Property

Gets or sets the response Time To Live (TTL) value. If this value doesn't match the hop number then it indicates an asymmetric path where the received packet takes a different route from the sent packet.

[Visual Basic]
Public Property ResponseTimeToLive As Integer
[C#]
public int ResponseTimeToLive {get; set;}

Property Value

The response Time To Live (TTL) value.

See Also

TraceRouteTiming Class | ComponentSpace.TraceRoute Namespace


TraceRouteTiming Methods

The methods of the TraceRouteTiming class are listed below. For a complete list of TraceRouteTiming class members, see the TraceRouteTiming Members topic.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString | Obtain the string representation of the trace route timing.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

TraceRouteTiming Class | ComponentSpace.TraceRoute Namespace


TraceRouteTiming.ToString Method

Obtain the string representation of the trace route timing.

[Visual Basic]
Overrides Public Function ToString() As String
[C#]
public override string ToString();

Return Value

The string representation of the trace route timing.

See Also

TraceRouteTiming Class | ComponentSpace.TraceRoute Namespace


TraceRouteTimingCompletedEventArgs Class

Provides data for the TraceRouteTimingCompleted event.

For a list of all members of this type, see TraceRouteTimingCompletedEventArgs Members.

System.Object
System.EventArgs
ComponentSpace.TraceRoute.TraceRouteTimingCompletedEventArgs

[Visual Basic]
Public Class TraceRouteTimingCompletedEventArgs
Inherits EventArgs
[C#]
public class TraceRouteTimingCompletedEventArgs : EventArgs

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

The TraceRouteTimingCompleted event is raised by the TraceRouteClient. It contains the information associated with a single send/receive operation to a hop on the route.

Requirements

Namespace: ComponentSpace.TraceRoute

Assembly: ComponentSpace.TraceRoute (in ComponentSpace.TraceRoute.dll)

See Also

TraceRouteTimingCompletedEventArgs Members | ComponentSpace.TraceRoute Namespace


TraceRouteTimingCompletedEventArgs Members

TraceRouteTimingCompletedEventArgs overview

Public Instance Properties

TraceRouteHop | Gets the trace route hop information for the just completed single send/receive operation to a hop on the route.
TraceRouteTiming | Gets the trace route timing information for the just completed single send/receive operation to a hop on the route.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

TraceRouteTimingCompletedEventArgs Class | ComponentSpace.TraceRoute Namespace


TraceRouteTimingCompletedEventArgs Properties

The properties of the TraceRouteTimingCompletedEventArgs class are listed below. For a complete list of TraceRouteTimingCompletedEventArgs class members, see the TraceRouteTimingCompletedEventArgs Members topic.

Public Instance Properties

TraceRouteHop | Gets the trace route hop information for the just completed single send/receive operation to a hop on the route.
TraceRouteTiming | Gets the trace route timing information for the just completed single send/receive operation to a hop on the route.

See Also

TraceRouteTimingCompletedEventArgs Class | ComponentSpace.TraceRoute Namespace


TraceRouteTimingCompletedEventArgs.TraceRouteHop Property

Gets the trace route hop information for the just completed single send/receive operation to a hop on the route.

[Visual Basic]
Public ReadOnly Property TraceRouteHop As TraceRouteHop
[C#]
public TraceRouteHop TraceRouteHop {get;}

Property Value

A TraceRouteHop that contains the trace route hop information.

See Also

TraceRouteTimingCompletedEventArgs Class | ComponentSpace.TraceRoute Namespace


TraceRouteTimingCompletedEventArgs.TraceRouteTiming Property

Gets the trace route timing information for the just completed single send/receive operation to a hop on the route.

[Visual Basic]
Public ReadOnly Property TraceRouteTiming As TraceRouteTiming
[C#]
public TraceRouteTiming TraceRouteTiming {get;}

Property Value

A TraceRouteTiming that contains the trace route timing information.

See Also

TraceRouteTimingCompletedEventArgs Class | ComponentSpace.TraceRoute Namespace


TraceRouteTimingCompletedEventHandler Delegate

Represents the method that will handle the TraceRouteTimingCompleted event.

[Visual Basic]
Public Delegate Sub TraceRouteTimingCompletedEventHandler( _
ByVal sender As Object, _
ByVal e As TraceRouteTimingCompletedEventArgs _
)
[C#]
public delegate void TraceRouteTimingCompletedEventHandler(
object sender,
TraceRouteTimingCompletedEventArgs e
);

Parameters

sender
The source of the event.
e
A TraceRouteTimingCompletedEventArgs that contains the event data.

Remarks

When you create a TraceRouteTimingCompletedEventHandler delegate, you identify the method that will handle the event. To associate the event with your event handler, add an instance of the delegate to the event. The event handler is called whenever the event occurs, unless you remove the delegate.

Requirements

Namespace: ComponentSpace.TraceRoute

Assembly: ComponentSpace.TraceRoute (in ComponentSpace.TraceRoute.dll)

See Also

ComponentSpace.TraceRoute Namespace


ComponentSpace.TraceRouteHierarchy

ComponentSpace Trace Route Class Library Reference

ComponentSpace.TraceRoute Hierarchy

System.Object
ComponentSpace.TraceRoute.ITraceRouteServicedComponent
ComponentSpace.TraceRoute.TraceRouteClient
ComponentSpace.TraceRoute.TraceRouteHop
ComponentSpace.TraceRoute.TraceRouteTiming
System.Delegate ---- System.ICloneable, System.Runtime.Serialization.ISerializable
System.MulticastDelegate
ComponentSpace.TraceRoute.TraceRouteCompletedEventHandler
ComponentSpace.TraceRoute.TraceRouteHopCompletedEventHandler
ComponentSpace.TraceRoute.TraceRouteTimingCompletedEventHandler
System.EventArgs
ComponentSpace.TraceRoute.TraceRouteCompletedEventArgs
ComponentSpace.TraceRoute.TraceRouteHopCompletedEventArgs
ComponentSpace.TraceRoute.TraceRouteTimingCompletedEventArgs
System.Exception ---- System.Runtime.Serialization.ISerializable
System.ApplicationException
ComponentSpace.TraceRoute.TraceRouteException
System.MarshalByRefObject
System.ContextBoundObject
System.EnterpriseServices.ServicedComponent ---- System.EnterpriseServices.IRemoteDispatch, System.EnterpriseServices.IServicedComponentInfo, System.IDisposable
ComponentSpace.TraceRoute.TraceRouteServicedComponent ---- ComponentSpace.TraceRoute.ITraceRouteServicedComponent

See Also

ComponentSpace.TraceRoute Namespace